VTK 4.1.1 Documentation

Revision:
1.1187
Date:
2002/03/25 03:45:02
Useful links:
  • VTK Home: http://public.kitware.com/VTK
  • VTK Mailing-list: http://public.kitware.com/mailman/listinfo/vtkusers
  • VTK FAQ: http://public.kitware.com/cgi-bin/vtkfaq
  • VTK Search: http://www.kitware.com/search.html
  • VTK Dashboard: http://public.kitware.com/VTK/Testing/Dashboard/MostRecentResults-Nightly/Dashboard.html
  • VTK-Doxygen scripts (Sebastien Barre): http://www.barre.nom.fr/vtk/doc/README
  • Kitware Home: http://www.kitware.com
  • Sebastien's VTK Links: http://www.barre.nom.fr/vtk/links.html
  • Other Links: http://public.kitware.com/VTK/links.php
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


File Index

VTK File List

Here is a list of all files with brief descriptions:
doc_VTK_class2examples.dox
doc_VTK_class2tests.dox
doc_VTK_contributors.dox
doc_VTK_events.dox
doc_VTK_events2.dox
doc_VTK_index.dox
doc_VTK_version.dox
Common/vtkAbstractList.h [code]
Common/vtkAbstractMapper.h [code]
Common/vtkAbstractTransform.h [code]
Common/vtkActor2D.h [code]
Common/vtkActor2DCollection.h [code]
Common/vtkAssemblyNode.h [code]
Common/vtkAssemblyPath.h [code]
Common/vtkAssemblyPaths.h [code]
Common/vtkBitArray.h [code]
Common/vtkByteSwap.h [code]
Common/vtkCallbackCommand.h [code]
Common/vtkCell.h [code]
Common/vtkCell3D.h [code]
Common/vtkCellArray.h [code]
Common/vtkCellData.h [code]
Common/vtkCellLinks.h [code]
Common/vtkCellType.h [code]
Common/vtkCellTypes.h [code]
Common/vtkCharArray.h [code]
Common/vtkCollection.h [code]
Common/vtkCommand.h [code]
Common/vtkContainer.h [code]
Common/vtkContourValues.h [code]
Common/vtkCoordinate.h [code]
Common/vtkCriticalSection.h [code]
Common/vtkDataArray.h [code]
Common/vtkDataObject.h [code]
Common/vtkDataObjectCollection.h [code]
Common/vtkDataSet.h [code]
Common/vtkDataSetAttributes.h [code]
Common/vtkDataSetCollection.h [code]
Common/vtkDebugLeaks.h [code]
Common/vtkDirectory.h [code]
Common/vtkDoubleArray.h [code]
Common/vtkDynamicLoader.h [code]
Common/vtkEdgeTable.h [code]
Common/vtkEmptyCell.h [code]
Common/vtkErrorCode.h [code]
Common/vtkExplicitCell.h [code]
Common/vtkExtentTranslator.h [code]
Common/vtkFieldData.h [code]
Common/vtkFileOutputWindow.h [code]
Common/vtkFloatArray.h [code]
Common/vtkFunctionParser.h [code]
Common/vtkFunctionSet.h [code]
Common/vtkGeneralTransform.h [code]
Common/vtkGenericCell.h [code]
Common/vtkHeap.h [code]
Common/vtkHexahedron.h [code]
Common/vtkHomogeneousTransform.h [code]
Common/vtkIdentityTransform.h [code]
Common/vtkIdList.h [code]
Common/vtkIdTypeArray.h [code]
Common/vtkImageData.h [code]
Common/vtkImageIterator.h [code]
Common/vtkImageProgressIterator.h [code]
Common/vtkImplicitFunction.h [code]
Common/vtkImplicitFunctionCollection.h [code]
Common/vtkIndent.h [code]
Common/vtkInitialValueProblemSolver.h [code]
Common/vtkInstantiator.h [code]
Common/vtkIntArray.h [code]
Common/vtkInterpolatedVelocityField.h [code]
Common/vtkJavaAwt.h [code]
Common/vtkJavaUtil.h [code]
Common/vtkLargeInteger.h [code]
Common/vtkLine.h [code]
Common/vtkLinearTransform.h [code]
Common/vtkLocator.h [code]
Common/vtkLogLookupTable.h [code]
Common/vtkLongArray.h [code]
Common/vtkLookupTable.h [code]
Common/vtkMapper2D.h [code]
Common/vtkMarchingCubesCases.h [code]
Common/vtkMarchingSquaresCases.h [code]
Common/vtkMath.h [code]
Common/vtkMatrix4x4.h [code]
Common/vtkMatrixToHomogeneousTransform.h [code]
Common/vtkMatrixToLinearTransform.h [code]
Common/vtkMultiThreader.h [code]
Common/vtkMutexLock.h [code]
Common/vtkNonLinearCell.h [code]
Common/vtkObject.h [code]
Common/vtkObjectFactory.h [code]
Common/vtkObjectFactoryCollection.h [code]
Common/vtkOldStyleCallbackCommand.h [code]
Common/vtkOrderedTriangulator.h [code]
Common/vtkOutputWindow.h [code]
Common/vtkOverrideInformation.h [code]
Common/vtkOverrideInformationCollection.h [code]
Common/vtkPerspectiveTransform.h [code]
Common/vtkPixel.h [code]
Common/vtkPlane.h [code]
Common/vtkPlaneCollection.h [code]
Common/vtkPlanes.h [code]
Common/vtkPointData.h [code]
Common/vtkPointLocator.h [code]
Common/vtkPointLocator2D.h [code]
Common/vtkPoints.h [code]
Common/vtkPointSet.h [code]
Common/vtkPolyData.h [code]
Common/vtkPolygon.h [code]
Common/vtkPolyLine.h [code]
Common/vtkPolyVertex.h [code]
Common/vtkPriorityQueue.h [code]
Common/vtkProcessObject.h [code]
Common/vtkProcessStatistics.h [code]
Common/vtkProp.h [code]
Common/vtkPropAssembly.h [code]
Common/vtkPropCollection.h [code]
Common/vtkProperty2D.h [code]
Common/vtkPyramid.h [code]
Common/vtkPythonUtil.h [code]
Common/vtkQuad.h [code]
Common/vtkQuadraticEdge.h [code]
Common/vtkQuadric.h [code]
Common/vtkRayCastStructures.h [code]
Common/vtkRectilinearGrid.h [code]
Common/vtkReferenceCount.h [code]
Common/vtkRungeKutta2.h [code]
Common/vtkRungeKutta4.h [code]
Common/vtkRungeKutta45.h [code]
Common/vtkScalarsToColors.h [code]
Common/vtkSetGet.h [code]
Common/vtkShortArray.h [code]
Common/vtkSource.h [code]
Common/vtkStructuredData.h [code]
Common/vtkStructuredGrid.h [code]
Common/vtkStructuredPoints.h [code]
Common/vtkSystemIncludes.h [code]
Common/vtkTclUtil.h [code]
Common/vtkTensor.h [code]
Common/vtkTetra.h [code]
Common/vtkTimerLog.h [code]
Common/vtkTimeStamp.h [code]
Common/vtkTransform.h [code]
Common/vtkTransformCollection.h [code]
Common/vtkTriangle.h [code]
Common/vtkTriangleStrip.h [code]
Common/vtkUnsignedCharArray.h [code]
Common/vtkUnsignedIntArray.h [code]
Common/vtkUnsignedLongArray.h [code]
Common/vtkUnsignedShortArray.h [code]
Common/vtkUnstructuredGrid.h [code]
Common/vtkVersion.h [code]
Common/vtkVertex.h [code]
Common/vtkViewport.h [code]
Common/vtkVoidArray.h [code]
Common/vtkVoxel.h [code]
Common/vtkWarpTransform.h [code]
Common/vtkWedge.h [code]
Common/vtkWin32Header.h [code]
Common/vtkWin32OutputWindow.h [code]
Common/vtkWinCE.h [code]
Common/vtkWindow.h [code]
Common/vtkWindowLevelLookupTable.h [code]
Common/vtkXMLFileOutputWindow.h [code]
Filtering/vtkCardinalSpline.h [code]
Filtering/vtkCastToConcrete.h [code]
Filtering/vtkCellLocator.h [code]
Filtering/vtkColorTransferFunction.h [code]
Filtering/vtkCone.h [code]
Filtering/vtkCylinder.h [code]
Filtering/vtkDataObjectSource.h [code]
Filtering/vtkDataSetSource.h [code]
Filtering/vtkDataSetToDataSetFilter.h [code]
Filtering/vtkDataSetToPolyDataFilter.h [code]
Filtering/vtkDataSetToStructuredGridFilter.h [code]
Filtering/vtkDataSetToStructuredPointsFilter.h [code]
Filtering/vtkDataSetToUnstructuredGridFilter.h [code]
Filtering/vtkImageInPlaceFilter.h [code]
Filtering/vtkImageMultipleInputFilter.h [code]
Filtering/vtkImageMultipleInputOutputFilter.h [code]
Filtering/vtkImageSource.h [code]
Filtering/vtkImageToImageFilter.h [code]
Filtering/vtkImageToStructuredPoints.h [code]
Filtering/vtkImageTwoInputFilter.h [code]
Filtering/vtkImplicitBoolean.h [code]
Filtering/vtkImplicitDataSet.h [code]
Filtering/vtkImplicitSelectionLoop.h [code]
Filtering/vtkImplicitSum.h [code]
Filtering/vtkImplicitVolume.h [code]
Filtering/vtkImplicitWindowFunction.h [code]
Filtering/vtkKochanekSpline.h [code]
Filtering/vtkMergePoints.h [code]
Filtering/vtkMergePoints2D.h [code]
Filtering/vtkPerlinNoise.h [code]
Filtering/vtkPiecewiseFunction.h [code]
Filtering/vtkPiecewiseFunctionShiftScale.h [code]
Filtering/vtkPiecewiseFunctionSource.h [code]
Filtering/vtkPiecewiseFunctionToPiecewiseFunctionFilter.h [code]
Filtering/vtkPointSetSource.h [code]
Filtering/vtkPointSetToPointSetFilter.h [code]
Filtering/vtkPolyDataCollection.h [code]
Filtering/vtkPolyDataSource.h [code]
Filtering/vtkPolyDataToPolyDataFilter.h [code]
Filtering/vtkRectilinearGridSource.h [code]
Filtering/vtkRectilinearGridToPolyDataFilter.h [code]
Filtering/vtkScalarTree.h [code]
Filtering/vtkSimpleImageToImageFilter.h [code]
Filtering/vtkSimpleScalarTree.h [code]
Filtering/vtkSphere.h [code]
Filtering/vtkSpline.h [code]
Filtering/vtkStructuredGridSource.h [code]
Filtering/vtkStructuredGridToPolyDataFilter.h [code]
Filtering/vtkStructuredGridToStructuredGridFilter.h [code]
Filtering/vtkStructuredPointsCollection.h [code]
Filtering/vtkStructuredPointsSource.h [code]
Filtering/vtkStructuredPointsToPolyDataFilter.h [code]
Filtering/vtkStructuredPointsToStructuredPointsFilter.h [code]
Filtering/vtkStructuredPointsToUnstructuredGridFilter.h [code]
Filtering/vtkSuperquadric.h [code]
Filtering/vtkUnstructuredGridSource.h [code]
Filtering/vtkUnstructuredGridToPolyDataFilter.h [code]
Filtering/vtkUnstructuredGridToUnstructuredGridFilter.h [code]
Graphics/vtkAppendFilter.h [code]
Graphics/vtkAppendPolyData.h [code]
Graphics/vtkApproximatingSubdivisionFilter.h [code]
Graphics/vtkArrayCalculator.h [code]
Graphics/vtkArrowSource.h [code]
Graphics/vtkAssignAttribute.h [code]
Graphics/vtkAttributeDataToFieldDataFilter.h [code]
Graphics/vtkAxes.h [code]
Graphics/vtkBandedPolyDataContourFilter.h [code]
Graphics/vtkBlankStructuredGrid.h [code]
Graphics/vtkBlankStructuredGridWithImage.h [code]
Graphics/vtkBrownianPoints.h [code]
Graphics/vtkButterflySubdivisionFilter.h [code]
Graphics/vtkButtonSource.h [code]
Graphics/vtkCellCenters.h [code]
Graphics/vtkCellDataToPointData.h [code]
Graphics/vtkCellDerivatives.h [code]
Graphics/vtkCleanPolyData.h [code]
Graphics/vtkClipDataSet.h [code]
Graphics/vtkClipPolyData.h [code]
Graphics/vtkClipVolume.h [code]
Graphics/vtkConeSource.h [code]
Graphics/vtkConnectivityFilter.h [code]
Graphics/vtkContourFilter.h [code]
Graphics/vtkContourGrid.h [code]
Graphics/vtkCubeSource.h [code]
Graphics/vtkCursor3D.h [code]
Graphics/vtkCutter.h [code]
Graphics/vtkCylinderSource.h [code]
Graphics/vtkDashedStreamLine.h [code]
Graphics/vtkDataObjectToDataSetFilter.h [code]
Graphics/vtkDataSetSurfaceFilter.h [code]
Graphics/vtkDataSetToDataObjectFilter.h [code]
Graphics/vtkDataSetTriangleFilter.h [code]
Graphics/vtkDecimatePro.h [code]
Graphics/vtkDelaunay2D.h [code]
Graphics/vtkDelaunay3D.h [code]
Graphics/vtkDicer.h [code]
Graphics/vtkDiskSource.h [code]
Graphics/vtkEdgePoints.h [code]
Graphics/vtkElevationFilter.h [code]
Graphics/vtkExtractEdges.h [code]
Graphics/vtkExtractGeometry.h [code]
Graphics/vtkExtractGrid.h [code]
Graphics/vtkExtractPolyDataGeometry.h [code]
Graphics/vtkExtractTensorComponents.h [code]
Graphics/vtkExtractUnstructuredGrid.h [code]
Graphics/vtkExtractVectorComponents.h [code]
Graphics/vtkFeatureEdges.h [code]
Graphics/vtkFieldDataToAttributeDataFilter.h [code]
Graphics/vtkGeometryFilter.h [code]
Graphics/vtkGlyph2D.h [code]
Graphics/vtkGlyph3D.h [code]
Graphics/vtkGlyphSource2D.h [code]
Graphics/vtkGraphLayoutFilter.h [code]
Graphics/vtkHedgeHog.h [code]
Graphics/vtkHull.h [code]
Graphics/vtkHyperStreamline.h [code]
Graphics/vtkIdFilter.h [code]
Graphics/vtkImageDataGeometryFilter.h [code]
Graphics/vtkImplicitTextureCoords.h [code]
Graphics/vtkInterpolateDataSetAttributes.h [code]
Graphics/vtkInterpolatingSubdivisionFilter.h [code]
Graphics/vtkLinearExtrusionFilter.h [code]
Graphics/vtkLinearSubdivisionFilter.h [code]
Graphics/vtkLineSource.h [code]
Graphics/vtkLinkEdgels.h [code]
Graphics/vtkLoopSubdivisionFilter.h [code]
Graphics/vtkMaskFields.h [code]
Graphics/vtkMaskPoints.h [code]
Graphics/vtkMaskPolyData.h [code]
Graphics/vtkMassProperties.h [code]
Graphics/vtkMergeDataObjectFilter.h [code]
Graphics/vtkMergeFields.h [code]
Graphics/vtkMergeFilter.h [code]
Graphics/vtkOBBDicer.h [code]
Graphics/vtkOBBTree.h [code]
Graphics/vtkOutlineCornerFilter.h [code]
Graphics/vtkOutlineCornerSource.h [code]
Graphics/vtkOutlineFilter.h [code]
Graphics/vtkOutlineSource.h [code]
Graphics/vtkPlaneSource.h [code]
Graphics/vtkPointDataToCellData.h [code]
Graphics/vtkPointSource.h [code]
Graphics/vtkPolyDataConnectivityFilter.h [code]
Graphics/vtkPolyDataNormals.h [code]
Graphics/vtkPolyDataStreamer.h [code]
Graphics/vtkProbeFilter.h [code]
Graphics/vtkProgrammableAttributeDataFilter.h [code]
Graphics/vtkProgrammableDataObjectSource.h [code]
Graphics/vtkProgrammableFilter.h [code]
Graphics/vtkProgrammableGlyphFilter.h [code]
Graphics/vtkProgrammableSource.h [code]
Graphics/vtkProjectedTexture.h [code]
Graphics/vtkQuadricClustering.h [code]
Graphics/vtkQuadricDecimation.h [code]
Graphics/vtkQuantizePolyDataPoints.h [code]
Graphics/vtkRearrangeFields.h [code]
Graphics/vtkRectilinearGridGeometryFilter.h [code]
Graphics/vtkRecursiveDividingCubes.h [code]
Graphics/vtkReflectionFilter.h [code]
Graphics/vtkReverseSense.h [code]
Graphics/vtkRibbonFilter.h [code]
Graphics/vtkRotationalExtrusionFilter.h [code]
Graphics/vtkRuledSurfaceFilter.h [code]
Graphics/vtkSelectPolyData.h [code]
Graphics/vtkShrinkFilter.h [code]
Graphics/vtkShrinkPolyData.h [code]
Graphics/vtkSimpleElevationFilter.h [code]
Graphics/vtkSmoothPolyDataFilter.h [code]
Graphics/vtkSpatialRepresentationFilter.h [code]
Graphics/vtkSpherePuzzle.h [code]
Graphics/vtkSpherePuzzleArrows.h [code]
Graphics/vtkSphereSource.h [code]
Graphics/vtkSplitField.h [code]
Graphics/vtkStreamer.h [code]
Graphics/vtkStreamLine.h [code]
Graphics/vtkStreamPoints.h [code]
Graphics/vtkStripper.h [code]
Graphics/vtkStructuredGridGeometryFilter.h [code]
Graphics/vtkStructuredGridOutlineFilter.h [code]
Graphics/vtkStructuredPointsGeometryFilter.h [code]
Graphics/vtkSubdivideTetra.h [code]
Graphics/vtkSubPixelPositionEdgels.h [code]
Graphics/vtkSuperquadricSource.h [code]
Graphics/vtkTensorGlyph.h [code]
Graphics/vtkTextSource.h [code]
Graphics/vtkTexturedSphereSource.h [code]
Graphics/vtkTextureMapToCylinder.h [code]
Graphics/vtkTextureMapToPlane.h [code]
Graphics/vtkTextureMapToSphere.h [code]
Graphics/vtkThreshold.h [code]
Graphics/vtkThresholdPoints.h [code]
Graphics/vtkThresholdTextureCoords.h [code]
Graphics/vtkTransformFilter.h [code]
Graphics/vtkTransformPolyDataFilter.h [code]
Graphics/vtkTransformTextureCoords.h [code]
Graphics/vtkTriangleFilter.h [code]
Graphics/vtkTriangularTCoords.h [code]
Graphics/vtkTubeFilter.h [code]
Graphics/vtkVectorDot.h [code]
Graphics/vtkVectorNorm.h [code]
Graphics/vtkVoxelContoursToSurfaceFilter.h [code]
Graphics/vtkWarpLens.h [code]
Graphics/vtkWarpScalar.h [code]
Graphics/vtkWarpTo.h [code]
Graphics/vtkWarpVector.h [code]
Graphics/vtkWindowedSincPolyDataFilter.h [code]
Hybrid/vtk3DSImporter.h [code]
Hybrid/vtkArcPlotter.h [code]
Hybrid/vtkCaptionActor2D.h [code]
Hybrid/vtkCubeAxesActor2D.h [code]
Hybrid/vtkDepthSortPolyData.h [code]
Hybrid/vtkEarthSource.h [code]
Hybrid/vtkGLUTesselatorTriangleFilter.h [code]
Hybrid/vtkGridTransform.h [code]
Hybrid/vtkImageToPolyDataFilter.h [code]
Hybrid/vtkImplicitModeller.h [code]
Hybrid/vtkIterativeClosestPointTransform.h [code]
Hybrid/vtkLandmarkTransform.h [code]
Hybrid/vtkLegendBoxActor.h [code]
Hybrid/vtkMILVideoSource.h [code]
Hybrid/vtkPCAAnalysisFilter.h [code]
Hybrid/vtkPolyDataToImageStencil.h [code]
Hybrid/vtkProcrustesAlignmentFilter.h [code]
Hybrid/vtkRenderLargeImage.h [code]
Hybrid/vtkRIBExporter.h [code]
Hybrid/vtkRIBLight.h [code]
Hybrid/vtkRIBProperty.h [code]
Hybrid/vtkThinPlateSplineTransform.h [code]
Hybrid/vtkTransformToGrid.h [code]
Hybrid/vtkVectorText.h [code]
Hybrid/vtkVideoSource.h [code]
Hybrid/vtkVRML.h [code]
Hybrid/vtkVRMLImporter.h [code]
Hybrid/vtkWeightedTransformFilter.h [code]
Hybrid/vtkWin32VideoSource.h [code]
Hybrid/vtkXYPlotActor.h [code]
Imaging/vtkBooleanTexture.h [code]
Imaging/vtkExtractVOI.h [code]
Imaging/vtkGaussianSplatter.h [code]
Imaging/vtkImageAccumulate.h [code]
Imaging/vtkImageAnisotropicDiffusion2D.h [code]
Imaging/vtkImageAnisotropicDiffusion3D.h [code]
Imaging/vtkImageAppend.h [code]
Imaging/vtkImageAppendComponents.h [code]
Imaging/vtkImageBlend.h [code]
Imaging/vtkImageButterworthHighPass.h [code]
Imaging/vtkImageButterworthLowPass.h [code]
Imaging/vtkImageCacheFilter.h [code]
Imaging/vtkImageCanvasSource2D.h [code]
Imaging/vtkImageCast.h [code]
Imaging/vtkImageChangeInformation.h [code]
Imaging/vtkImageCheckerboard.h [code]
Imaging/vtkImageCityBlockDistance.h [code]
Imaging/vtkImageClip.h [code]
Imaging/vtkImageConnector.h [code]
Imaging/vtkImageConstantPad.h [code]
Imaging/vtkImageContinuousDilate3D.h [code]
Imaging/vtkImageContinuousErode3D.h [code]
Imaging/vtkImageConvolve.h [code]
Imaging/vtkImageCorrelation.h [code]
Imaging/vtkImageCursor3D.h [code]
Imaging/vtkImageDataStreamer.h [code]
Imaging/vtkImageDecomposeFilter.h [code]
Imaging/vtkImageDifference.h [code]
Imaging/vtkImageDilateErode3D.h [code]
Imaging/vtkImageDivergence.h [code]
Imaging/vtkImageDotProduct.h [code]
Imaging/vtkImageEllipsoidSource.h [code]
Imaging/vtkImageEuclideanDistance.h [code]
Imaging/vtkImageEuclideanToPolar.h [code]
Imaging/vtkImageExport.h [code]
Imaging/vtkImageExtractComponents.h [code]
Imaging/vtkImageFFT.h [code]
Imaging/vtkImageFlip.h [code]
Imaging/vtkImageFourierCenter.h [code]
Imaging/vtkImageFourierFilter.h [code]
Imaging/vtkImageGaussianSmooth.h [code]
Imaging/vtkImageGaussianSource.h [code]
Imaging/vtkImageGradient.h [code]
Imaging/vtkImageGradientMagnitude.h [code]
Imaging/vtkImageGridSource.h [code]
Imaging/vtkImageHSVToRGB.h [code]
Imaging/vtkImageHybridMedian2D.h [code]
Imaging/vtkImageIdealHighPass.h [code]
Imaging/vtkImageIdealLowPass.h [code]
Imaging/vtkImageImport.h [code]
Imaging/vtkImageIslandRemoval2D.h [code]
Imaging/vtkImageIterateFilter.h [code]
Imaging/vtkImageLaplacian.h [code]
Imaging/vtkImageLogarithmicScale.h [code]
Imaging/vtkImageLogic.h [code]
Imaging/vtkImageLuminance.h [code]
Imaging/vtkImageMagnify.h [code]
Imaging/vtkImageMagnitude.h [code]
Imaging/vtkImageMandelbrotSource.h [code]
Imaging/vtkImageMapToColors.h [code]
Imaging/vtkImageMapToRGBA.h [code]
Imaging/vtkImageMapToWindowLevelColors.h [code]
Imaging/vtkImageMask.h [code]
Imaging/vtkImageMaskBits.h [code]
Imaging/vtkImageMathematics.h [code]
Imaging/vtkImageMedian3D.h [code]
Imaging/vtkImageMirrorPad.h [code]
Imaging/vtkImageNoiseSource.h [code]
Imaging/vtkImageNonMaximumSuppression.h [code]
Imaging/vtkImageNormalize.h [code]
Imaging/vtkImageOpenClose3D.h [code]
Imaging/vtkImagePadFilter.h [code]
Imaging/vtkImagePermute.h [code]
Imaging/vtkImageQuantizeRGBToIndex.h [code]
Imaging/vtkImageRange3D.h [code]
Imaging/vtkImageResample.h [code]
Imaging/vtkImageReslice.h [code]
Imaging/vtkImageRFFT.h [code]
Imaging/vtkImageRGBToHSV.h [code]
Imaging/vtkImageSeedConnectivity.h [code]
Imaging/vtkImageSeparableConvolution.h [code]
Imaging/vtkImageShiftScale.h [code]
Imaging/vtkImageShrink3D.h [code]
Imaging/vtkImageSinusoidSource.h [code]
Imaging/vtkImageSkeleton2D.h [code]
Imaging/vtkImageSobel2D.h [code]
Imaging/vtkImageSobel3D.h [code]
Imaging/vtkImageSpatialFilter.h [code]
Imaging/vtkImageStencil.h [code]
Imaging/vtkImageStencilData.h [code]
Imaging/vtkImageStencilSource.h [code]
Imaging/vtkImageThreshold.h [code]
Imaging/vtkImageToImageStencil.h [code]
Imaging/vtkImageTranslateExtent.h [code]
Imaging/vtkImageVariance3D.h [code]
Imaging/vtkImageWrapPad.h [code]
Imaging/vtkImplicitFunctionToImageStencil.h [code]
Imaging/vtkPointLoad.h [code]
Imaging/vtkSampleFunction.h [code]
Imaging/vtkShepardMethod.h [code]
Imaging/vtkSimpleImageFilterExample.h [code]
Imaging/vtkSurfaceReconstructionFilter.h [code]
Imaging/vtkTriangularTexture.h [code]
Imaging/vtkVoxelModeller.h [code]
IO/vtk3DS.h [code]
IO/vtkBMPReader.h [code]
IO/vtkBMPWriter.h [code]
IO/vtkBYUReader.h [code]
IO/vtkBYUWriter.h [code]
IO/vtkCGMWriter.h [code]
IO/vtkDataObjectReader.h [code]
IO/vtkDataObjectWriter.h [code]
IO/vtkDataReader.h [code]
IO/vtkDataSetReader.h [code]
IO/vtkDataSetWriter.h [code]
IO/vtkDataWriter.h [code]
IO/vtkDEMReader.h [code]
IO/vtkEnSight6BinaryReader.h [code]
IO/vtkEnSight6Reader.h [code]
IO/vtkEnSightGoldBinaryReader.h [code]
IO/vtkEnSightGoldReader.h [code]
IO/vtkEnSightReader.h [code]
IO/vtkGenericEnSightReader.h [code]
IO/vtkGESignaReader.h [code]
IO/vtkImageReader.h [code]
IO/vtkImageReader2.h [code]
IO/vtkImageReader2Collection.h [code]
IO/vtkImageReader2Factory.h [code]
IO/vtkImageWriter.h [code]
IO/vtkIVWriter.h [code]
IO/vtkJPEGReader.h [code]
IO/vtkJPEGWriter.h [code]
IO/vtkMCubesReader.h [code]
IO/vtkMCubesWriter.h [code]
IO/vtkMedicalImageReader2.h [code]
IO/vtkOBJReader.h [code]
IO/vtkParticleReader.h [code]
IO/vtkPLOT3DReader.h [code]
IO/vtkPLY.h [code]
IO/vtkPLYReader.h [code]
IO/vtkPLYWriter.h [code]
IO/vtkPNGReader.h [code]
IO/vtkPNGWriter.h [code]
IO/vtkPNMReader.h [code]
IO/vtkPNMWriter.h [code]
IO/vtkPolyDataReader.h [code]
IO/vtkPolyDataWriter.h [code]
IO/vtkPostScriptWriter.h [code]
IO/vtkRectilinearGridReader.h [code]
IO/vtkRectilinearGridWriter.h [code]
IO/vtkSLCReader.h [code]
IO/vtkSTLReader.h [code]
IO/vtkSTLWriter.h [code]
IO/vtkStructuredGridReader.h [code]
IO/vtkStructuredGridWriter.h [code]
IO/vtkStructuredPointsReader.h [code]
IO/vtkStructuredPointsWriter.h [code]
IO/vtkTIFFReader.h [code]
IO/vtkTIFFWriter.h [code]
IO/vtkUGFacetReader.h [code]
IO/vtkUnstructuredGridReader.h [code]
IO/vtkUnstructuredGridWriter.h [code]
IO/vtkVolume16Reader.h [code]
IO/vtkVolumeReader.h [code]
IO/vtkWriter.h [code]
IO/vtkXMLParser.h [code]
Parallel/vtkBranchExtentTranslator.h [code]
Parallel/vtkCommunicator.h [code]
Parallel/vtkCompositeManager.h [code]
Parallel/vtkCutMaterial.h [code]
Parallel/vtkExtractPolyDataPiece.h [code]
Parallel/vtkExtractUnstructuredGridPiece.h [code]
Parallel/vtkImageBlockReader.h [code]
Parallel/vtkImageBlockWriter.h [code]
Parallel/vtkInputPort.h [code]
Parallel/vtkMemoryLimitImageDataStreamer.h [code]
Parallel/vtkMPICommunicator.h [code]
Parallel/vtkMPIController.h [code]
Parallel/vtkMPIEventLog.h [code]
Parallel/vtkMPIGroup.h [code]
Parallel/vtkMultiProcessController.h [code]
Parallel/vtkMultiProcessLog.h [code]
Parallel/vtkOutputPort.h [code]
Parallel/vtkParallelFactory.h [code]
Parallel/vtkPCellDataToPointData.h [code]
Parallel/vtkPDataSetReader.h [code]
Parallel/vtkPDataSetWriter.h [code]
Parallel/vtkPieceScalars.h [code]
Parallel/vtkPImageWriter.h [code]
Parallel/vtkPipelineSize.h [code]
Parallel/vtkPLinearExtrusionFilter.h [code]
Parallel/vtkPOPReader.h [code]
Parallel/vtkPPolyDataNormals.h [code]
Parallel/vtkPSphereSource.h [code]
Parallel/vtkPVGeometryFilter.h [code]
Parallel/vtkRectilinearGridOutlineFilter.h [code]
Parallel/vtkRTAnalyticSource.h [code]
Parallel/vtkSharedMemoryCommunicator.h [code]
Parallel/vtkSocketCommunicator.h [code]
Parallel/vtkSocketController.h [code]
Parallel/vtkThreadedController.h [code]
Parallel/vtkThreadSafeLog.h [code]
Parallel/vtkTransmitPolyDataPiece.h [code]
Parallel/vtkTransmitUnstructuredGridPiece.h [code]
Parallel/vtkTreeComposite.h [code]
Patented/vtkDecimate.h [code]
Patented/vtkDividingCubes.h [code]
Patented/vtkGridSynchronizedTemplates3D.h [code]
Patented/vtkImageMarchingCubes.h [code]
Patented/vtkKitwareContourFilter.h [code]
Patented/vtkKitwareObjectFactory.h [code]
Patented/vtkMarchingContourFilter.h [code]
Patented/vtkMarchingCubes.h [code]
Patented/vtkMarchingSquares.h [code]
Patented/vtkSliceCubes.h [code]
Patented/vtkSweptSurface.h [code]
Patented/vtkSynchronizedTemplates2D.h [code]
Patented/vtkSynchronizedTemplates3D.h [code]
Rendering/vtkAbstractMapper3D.h [code]
Rendering/vtkAbstractPicker.h [code]
Rendering/vtkAbstractPropPicker.h [code]
Rendering/vtkActor.h [code]
Rendering/vtkActorCollection.h [code]
Rendering/vtkAssembly.h [code]
Rendering/vtkAxisActor2D.h [code]
Rendering/vtkCamera.h [code]
Rendering/vtkCellPicker.h [code]
Rendering/vtkCuller.h [code]
Rendering/vtkCullerCollection.h [code]
Rendering/vtkDataSetMapper.h [code]
Rendering/vtkDirectionEncoder.h [code]
Rendering/vtkEncodedGradientEstimator.h [code]
Rendering/vtkEncodedGradientShader.h [code]
Rendering/vtkExporter.h [code]
Rendering/vtkFiniteDifferenceGradientEstimator.h [code]
Rendering/vtkFollower.h [code]
Rendering/vtkFrustumCoverageCuller.h [code]
Rendering/vtkgluPickMatrix.h [code]
Rendering/vtkGraphicsFactory.h [code]
Rendering/vtkImageActor.h [code]
Rendering/vtkImageMapper.h [code]
Rendering/vtkImager.h [code]
Rendering/vtkImagerCollection.h [code]
Rendering/vtkImageViewer.h [code]
Rendering/vtkImageViewer2.h [code]
Rendering/vtkImageWindow.h [code]
Rendering/vtkImagingFactory.h [code]
Rendering/vtkImporter.h [code]
Rendering/vtkInteractorStyle.h [code]
Rendering/vtkInteractorStyleFlight.h [code]
Rendering/vtkInteractorStyleImage.h [code]
Rendering/vtkInteractorStyleJoystickActor.h [code]
Rendering/vtkInteractorStyleJoystickCamera.h [code]
Rendering/vtkInteractorStyleSwitch.h [code]
Rendering/vtkInteractorStyleTrackball.h [code]
Rendering/vtkInteractorStyleTrackballActor.h [code]
Rendering/vtkInteractorStyleTrackballCamera.h [code]
Rendering/vtkInteractorStyleUnicam.h [code]
Rendering/vtkInteractorStyleUser.h [code]
Rendering/vtkIVExporter.h [code]
Rendering/vtkLabeledDataMapper.h [code]
Rendering/vtkLight.h [code]
Rendering/vtkLightCollection.h [code]
Rendering/vtkLightKit.h [code]
Rendering/vtkLODActor.h [code]
Rendering/vtkLODProp3D.h [code]
Rendering/vtkMapper.h [code]
Rendering/vtkMapperCollection.h [code]
Rendering/vtkMesaActor.h [code]
Rendering/vtkMesaCamera.h [code]
Rendering/vtkMesaImageActor.h [code]
Rendering/vtkMesaImageMapper.h [code]
Rendering/vtkMesaImager.h [code]
Rendering/vtkMesaImageWindow.h [code]
Rendering/vtkMesaLight.h [code]
Rendering/vtkMesaPolyDataMapper.h [code]
Rendering/vtkMesaPolyDataMapper2D.h [code]
Rendering/vtkMesaProperty.h [code]
Rendering/vtkMesaRenderer.h [code]
Rendering/vtkMesaRenderWindow.h [code]
Rendering/vtkMesaTexture.h [code]
Rendering/vtkMesaVolumeRayCastMapper.h [code]
Rendering/vtkMesaVolumeTextureMapper2D.h [code]
Rendering/vtkOBJExporter.h [code]
Rendering/vtkOOGLExporter.h [code]
Rendering/vtkOpenGLActor.h [code]
Rendering/vtkOpenGLCamera.h [code]
Rendering/vtkOpenGLImageActor.h [code]
Rendering/vtkOpenGLImageMapper.h [code]
Rendering/vtkOpenGLImager.h [code]
Rendering/vtkOpenGLImageWindow.h [code]
Rendering/vtkOpenGLLight.h [code]
Rendering/vtkOpenGLPolyDataMapper.h [code]
Rendering/vtkOpenGLPolyDataMapper2D.h [code]
Rendering/vtkOpenGLProperty.h [code]
Rendering/vtkOpenGLRenderer.h [code]
Rendering/vtkOpenGLRenderWindow.h [code]
Rendering/vtkOpenGLStateCache.h [code]
Rendering/vtkOpenGLTexture.h [code]
Rendering/vtkOpenGLVolumeProVG500Mapper.h [code]
Rendering/vtkOpenGLVolumeProVP1000Mapper.h [code]
Rendering/vtkOpenGLVolumeRayCastMapper.h [code]
Rendering/vtkOpenGLVolumeTextureMapper2D.h [code]
Rendering/vtkParallelCoordinatesActor.h [code]
Rendering/vtkPicker.h [code]
Rendering/vtkPointPicker.h [code]
Rendering/vtkPolyDataMapper.h [code]
Rendering/vtkPolyDataMapper2D.h [code]
Rendering/vtkProp3D.h [code]
Rendering/vtkProp3DCollection.h [code]
Rendering/vtkProperty.h [code]
Rendering/vtkPropPicker.h [code]
Rendering/vtkQuartzGLView.h [code]
Rendering/vtkQuartzImageMapper.h [code]
Rendering/vtkQuartzImageWindow.h [code]
Rendering/vtkQuartzRenderWindow.h [code]
Rendering/vtkQuartzRenderWindowInteractor.h [code]
Rendering/vtkQuartzTextMapper.h [code]
Rendering/vtkQuartzWindow.h [code]
Rendering/vtkRayCaster.h [code]
Rendering/vtkRecursiveSphereDirectionEncoder.h [code]
Rendering/vtkRender.h [code]
Rendering/vtkRenderer.h [code]
Rendering/vtkRendererCollection.h [code]
Rendering/vtkRendererSource.h [code]
Rendering/vtkRenderWindow.h [code]
Rendering/vtkRenderWindowCollection.h [code]
Rendering/vtkRenderWindowInteractor.h [code]
Rendering/vtkScalarBarActor.h [code]
Rendering/vtkScaledTextActor.h [code]
Rendering/vtkSelectVisiblePoints.h [code]
Rendering/vtkTextMapper.h [code]
Rendering/vtkTexture.h [code]
Rendering/vtkTkImageViewerWidget.h [code]
Rendering/vtkTkImageWindowWidget.h [code]
Rendering/vtkTkRenderWidget.h [code]
Rendering/vtkVolume.h [code]
Rendering/vtkVolumeCollection.h [code]
Rendering/vtkVolumeMapper.h [code]
Rendering/vtkVolumeProMapper.h [code]
Rendering/vtkVolumeProperty.h [code]
Rendering/vtkVolumeProVG500Mapper.h [code]
Rendering/vtkVolumeProVP1000Mapper.h [code]
Rendering/vtkVolumeRayCastCompositeFunction.h [code]
Rendering/vtkVolumeRayCastFunction.h [code]
Rendering/vtkVolumeRayCastIsosurfaceFunction.h [code]
Rendering/vtkVolumeRayCastMapper.h [code]
Rendering/vtkVolumeRayCastMIPFunction.h [code]
Rendering/vtkVolumeRayCastStructures.h [code]
Rendering/vtkVolumeTextureMapper.h [code]
Rendering/vtkVolumeTextureMapper2D.h [code]
Rendering/vtkVRMLExporter.h [code]
Rendering/vtkWin32ImageMapper.h [code]
Rendering/vtkWin32ImageWindow.h [code]
Rendering/vtkWin32OpenGLImageWindow.h [code]
Rendering/vtkWin32OpenGLRenderWindow.h [code]
Rendering/vtkWin32OpenGLTextMapper.h [code]
Rendering/vtkWin32PolyDataMapper2D.h [code]
Rendering/vtkWin32RenderWindowInteractor.h [code]
Rendering/vtkWin32TextMapper.h [code]
Rendering/vtkWinCEOpenGLRenderWindow.h [code]
Rendering/vtkWindowToImageFilter.h [code]
Rendering/vtkWorldPointPicker.h [code]
Rendering/vtkXImageMapper.h [code]
Rendering/vtkXImageWindow.h [code]
Rendering/vtkXMesaRenderWindow.h [code]
Rendering/vtkXMesaTextMapper.h [code]
Rendering/vtkXOpenGLRenderWindow.h [code]
Rendering/vtkXOpenGLTextMapper.h [code]
Rendering/vtkXPolyDataMapper2D.h [code]
Rendering/vtkXRenderWindowInteractor.h [code]
Rendering/vtkXRenderWindowTclInteractor.h [code]
Rendering/vtkXTextMapper.h [code]
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_class2examples.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_class2tests.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_contributors.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_events.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_events2.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_index.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


doc_VTK_version.dox File Reference

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractList.h File Reference

Common/vtkAbstractList.h File Reference

#include "vtkContainer.h"

Include dependency graph for vtkAbstractList.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAbstractList
a dynamic list data structure. More...

Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractMapper.h File Reference

Common/vtkAbstractMapper.h File Reference

#include "vtkProcessObject.h"
#include "vtkPlaneCollection.h"
#include "vtkPlane.h"
#include "vtkPlanes.h"
#include "vtkTimerLog.h"

Include dependency graph for vtkAbstractMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkAbstractMapper
abstract class specifies interface to map data. More...

Defines

#define | VTK_SCALAR_MODE_DEFAULT 0
#define | VTK_SCALAR_MODE_USE_POINT_DATA 1
#define | VTK_SCALAR_MODE_USE_CELL_DATA 2
#define | VTK_SCALAR_MODE_USE_POINT_FIELD_DATA 3
#define | VTK_SCALAR_MODE_USE_CELL_FIELD_DATA 4
#define | VTK_GET_ARRAY_BY_ID 0
#define | VTK_GET_ARRAY_BY_NAME 1

Define Documentation

#define VTK_SCALAR_MODE_DEFAULT 0

Definition at line 49 of file vtkAbstractMapper.h.

#define VTK_SCALAR_MODE_USE_POINT_DATA 1

Definition at line 50 of file vtkAbstractMapper.h.

#define VTK_SCALAR_MODE_USE_CELL_DATA 2

Definition at line 51 of file vtkAbstractMapper.h.

#define VTK_SCALAR_MODE_USE_POINT_FIELD_DATA 3

Definition at line 52 of file vtkAbstractMapper.h.

#define VTK_SCALAR_MODE_USE_CELL_FIELD_DATA 4

Definition at line 53 of file vtkAbstractMapper.h.

#define VTK_GET_ARRAY_BY_ID 0

Definition at line 55 of file vtkAbstractMapper.h.

#define VTK_GET_ARRAY_BY_NAME 1

Definition at line 56 of file vtkAbstractMapper.h.

Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractTransform.h File Reference

Common/vtkAbstractTransform.h File Reference

#include "vtkObject.h"
#include "vtkMatrix4x4.h"
#include "vtkPoints.h"

Include dependency graph for vtkAbstractTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkAbstractTransform
superclass for all geometric transformations. More...

class | vtkTransformPair
class | vtkTransformConcatenation
class | vtkTransformConcatenationStack

Generated on Mon Mar 25 01:08:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor2D.h File Reference

Common/vtkActor2D.h File Reference

#include "vtkProp.h"
#include "vtkCoordinate.h"
#include "vtkProperty2D.h"

Include dependency graph for vtkActor2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkActor2D
a actor that draws 2D data. More...

Generated on Mon Mar 25 01:08:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor2DCollection.h File Reference

Common/vtkActor2DCollection.h File Reference

#include "vtkPropCollection.h"
#include "vtkActor2D.h"

Include dependency graph for vtkActor2DCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkActor2DCollection

Generated on Mon Mar 25 01:08:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyNode.h File Reference

Common/vtkAssemblyNode.h File Reference

#include "vtkObject.h"
#include "vtkProp.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkAssemblyNode.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAssemblyNode
represent a node in an assembly. More...

Generated on Mon Mar 25 01:08:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyPath.h File Reference

Common/vtkAssemblyPath.h File Reference

#include "vtkCollection.h"

Include dependency graph for vtkAssemblyPath.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkAssemblyPath
a list of nodes that form an assembly path. More...

Generated on Mon Mar 25 01:08:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyPaths.h File Reference

Common/vtkAssemblyPaths.h File Reference

#include "vtkCollection.h"
#include "vtkAssemblyPath.h"

Include dependency graph for vtkAssemblyPaths.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkAssemblyPaths
a list of lists of props representing an assembly hierarchy. More...

Generated on Mon Mar 25 01:08:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBitArray.h File Reference

Common/vtkBitArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkBitArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBitArray
dynamic, self-adjusting array of bits. More...

Generated on Mon Mar 25 01:08:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkByteSwap.h File Reference

Common/vtkByteSwap.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkByteSwap.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkByteSwap
perform machine dependent byte swapping. More...

Generated on Mon Mar 25 01:08:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCallbackCommand.h File Reference

Common/vtkCallbackCommand.h File Reference

#include "vtkCommand.h"

Include dependency graph for vtkCallbackCommand.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCallbackCommand
generic callback. More...

Generated on Mon Mar 25 01:08:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCell.h File Reference

Common/vtkCell.h File Reference

#include "vtkObject.h"
#include "vtkPoints.h"
#include "vtkIdList.h"
#include "vtkCellType.h"

Include dependency graph for vtkCell.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkCell
abstract class to specify cell behavior. More...

Defines

#define | VTK_CELL_SIZE 512
#define | VTK_TOL 1.e-05

Define Documentation

#define VTK_CELL_SIZE 512

Definition at line 54 of file vtkCell.h.

#define VTK_TOL 1.e-05

Definition at line 55 of file vtkCell.h.

Generated on Mon Mar 25 01:08:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCell3D.h File Reference

Common/vtkCell3D.h File Reference

#include "vtkCell.h"

Include dependency graph for vtkCell3D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCell3D
abstract class to specify 3D cell interface. More...

Generated on Mon Mar 25 01:08:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellArray.h File Reference

Common/vtkCellArray.h File Reference

#include "vtkIdTypeArray.h"
#include "vtkCell.h"

Include dependency graph for vtkCellArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellArray
object to represent cell connectivity. More...

Generated on Mon Mar 25 01:08:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellData.h File Reference

Common/vtkCellData.h File Reference

#include "vtkDataSetAttributes.h"

Include dependency graph for vtkCellData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellData
represent and manipulate cell attribute data. More...

Generated on Mon Mar 25 01:08:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellLinks.h File Reference

Common/vtkCellLinks.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkCellLinks.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | _vtkLink_s
class | vtkCellLinks
object represents upward pointers from points to list of cells using each point. More...

Generated on Mon Mar 25 01:08:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellType.h File Reference

Common/vtkCellType.h File Reference

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | VTK_EMPTY_CELL 0
#define | VTK_VERTEX 1
#define | VTK_POLY_VERTEX 2
#define | VTK_LINE 3
#define | VTK_POLY_LINE 4
#define | VTK_TRIANGLE 5
#define | VTK_TRIANGLE_STRIP 6
#define | VTK_POLYGON 7
#define | VTK_PIXEL 8
#define | VTK_QUAD 9
#define | VTK_TETRA 10
#define | VTK_VOXEL 11
#define | VTK_HEXAHEDRON 12
#define | VTK_WEDGE 13
#define | VTK_PYRAMID 14
#define | VTK_QUADRATIC_EDGE 21
#define | VTK_QUADRATIC_TRIANGLE 22
#define | VTK_QUADRATIC_TETRA 23
#define | VTK_PARAMETRIC_CURVE 51
#define | VTK_PARAMETRIC_SURFACE 52

Define Documentation

#define VTK_EMPTY_CELL 0

Definition at line 46 of file vtkCellType.h.

#define VTK_VERTEX 1

Definition at line 47 of file vtkCellType.h.

#define VTK_POLY_VERTEX 2

Definition at line 48 of file vtkCellType.h.

#define VTK_LINE 3

Definition at line 49 of file vtkCellType.h.

#define VTK_POLY_LINE 4

Definition at line 50 of file vtkCellType.h.

#define VTK_TRIANGLE 5

Definition at line 51 of file vtkCellType.h.

#define VTK_TRIANGLE_STRIP 6

Definition at line 52 of file vtkCellType.h.

#define VTK_POLYGON 7

Definition at line 53 of file vtkCellType.h.

#define VTK_PIXEL 8

Definition at line 54 of file vtkCellType.h.

#define VTK_QUAD 9

Definition at line 55 of file vtkCellType.h.

#define VTK_TETRA 10

Definition at line 56 of file vtkCellType.h.

#define VTK_VOXEL 11

Definition at line 57 of file vtkCellType.h.

#define VTK_HEXAHEDRON 12

Definition at line 58 of file vtkCellType.h.

#define VTK_WEDGE 13

Definition at line 59 of file vtkCellType.h.

#define VTK_PYRAMID 14

Definition at line 60 of file vtkCellType.h.

#define VTK_QUADRATIC_EDGE 21

Definition at line 63 of file vtkCellType.h.

#define VTK_QUADRATIC_TRIANGLE 22

Definition at line 64 of file vtkCellType.h.

#define VTK_QUADRATIC_TETRA 23

Definition at line 65 of file vtkCellType.h.

#define VTK_PARAMETRIC_CURVE 51

Definition at line 68 of file vtkCellType.h.

#define VTK_PARAMETRIC_SURFACE 52

Definition at line 69 of file vtkCellType.h.

Generated on Mon Mar 25 01:08:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellTypes.h File Reference

Common/vtkCellTypes.h File Reference

#include "vtkObject.h"
#include "vtkCellType.h"
#include "vtkIntArray.h"
#include "vtkUnsignedCharArray.h"

Include dependency graph for vtkCellTypes.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellTypes
object provides direct access to cells in vtkCellArray and type information. More...

Generated on Mon Mar 25 01:08:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCharArray.h File Reference

Common/vtkCharArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkCharArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCharArray
dynamic, self-adjusting character array. More...

Generated on Mon Mar 25 01:08:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCollection.h File Reference

Common/vtkCollection.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkCollectionElement
class | vtkCollection
create and manipulate unsorted lists of objects. More...

Generated on Mon Mar 25 01:08:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCommand.h File Reference

Common/vtkCommand.h File Reference

#include "vtkWin32Header.h"

Include dependency graph for vtkCommand.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCommand
superclass for callback/observer methods. More...

Generated on Mon Mar 25 01:08:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContainer.h File Reference

Common/vtkContainer.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkContainer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkContainer
a base class for templated containers. More...

Generated on Mon Mar 25 01:08:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourValues.h File Reference

Common/vtkContourValues.h File Reference

#include "vtkObject.h"
#include "vtkIntArray.h"

Include dependency graph for vtkContourValues.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkContourValues
helper object to manage setting and generating contour values. More...

Generated on Mon Mar 25 01:08:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCoordinate.h File Reference

Common/vtkCoordinate.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkCoordinate.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkCoordinate
perform coordinate transformation, and represent position, in a variety of vtk coordinate systems. More...

Defines

#define | VTK_DISPLAY 0
#define | VTK_NORMALIZED_DISPLAY 1
#define | VTK_VIEWPORT 2
#define | VTK_NORMALIZED_VIEWPORT 3
#define | VTK_VIEW 4
#define | VTK_WORLD 5
#define | VTK_USERDEFINED 6

Define Documentation

#define VTK_DISPLAY 0

Definition at line 72 of file vtkCoordinate.h.

#define VTK_NORMALIZED_DISPLAY 1

Definition at line 73 of file vtkCoordinate.h.

#define VTK_VIEWPORT 2

Definition at line 74 of file vtkCoordinate.h.

#define VTK_NORMALIZED_VIEWPORT 3

Definition at line 75 of file vtkCoordinate.h.

#define VTK_VIEW 4

Definition at line 76 of file vtkCoordinate.h.

#define VTK_WORLD 5

Definition at line 77 of file vtkCoordinate.h.

#define VTK_USERDEFINED 6

Definition at line 78 of file vtkCoordinate.h.

Generated on Mon Mar 25 01:08:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCriticalSection.h File Reference

Common/vtkCriticalSection.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkCriticalSection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkSimpleCriticalSection
class | vtkCriticalSection
critical section locking class. More...

Typedefs

typedef int | vtkCritSecType

Typedef Documentation

typedef int vtkCritSecType

Definition at line 71 of file vtkCriticalSection.h.

Generated on Mon Mar 25 01:08:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataArray.h File Reference

Common/vtkDataArray.h File Reference

#include "vtkObject.h"
#include "vtkLargeInteger.h"

Include dependency graph for vtkDataArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataArray
abstract superclass for arrays. More...

Generated on Mon Mar 25 01:08:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObject.h File Reference

Common/vtkDataObject.h File Reference

#include "vtkObject.h"
#include "vtkFieldData.h"

Include dependency graph for vtkDataObject.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkDataObject
general representation of visualization data. More...

Defines

#define | VTK_PIECES_EXTENT 0
#define | VTK_3D_EXTENT 1

Define Documentation

#define VTK_PIECES_EXTENT 0

Definition at line 56 of file vtkDataObject.h.

#define VTK_3D_EXTENT 1

Definition at line 57 of file vtkDataObject.h.

Generated on Mon Mar 25 01:08:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectCollection.h File Reference

Common/vtkDataObjectCollection.h File Reference

#include "vtkCollection.h"
#include "vtkDataObject.h"

Include dependency graph for vtkDataObjectCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataObjectCollection
maintain an unordered list of data objects. More...

Generated on Mon Mar 25 01:08:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSet.h File Reference

Common/vtkDataSet.h File Reference

#include "vtkDataObject.h"
#include "vtkCellData.h"
#include "vtkPointData.h"
#include "vtkGenericCell.h"
#include "vtkCellTypes.h"

Include dependency graph for vtkDataSet.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSet
abstract class to specify dataset behavior. More...

Generated on Mon Mar 25 01:08:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetAttributes.h File Reference

Common/vtkDataSetAttributes.h File Reference

#include "vtkObject.h"
#include "vtkFieldData.h"

Include dependency graph for vtkDataSetAttributes.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkDataSetAttributes
represent and manipulate attribute data in a dataset. More...

class | vtkDataSetAttributes::FieldList

Generated on Mon Mar 25 01:08:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetCollection.h File Reference

Common/vtkDataSetCollection.h File Reference

#include "vtkCollection.h"
#include "vtkDataSet.h"

Include dependency graph for vtkDataSetCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetCollection
maintain an unordered list of dataset objects. More...

Generated on Mon Mar 25 01:08:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDebugLeaks.h File Reference

Common/vtkDebugLeaks.h File Reference

#include "vtkObject.h"
#include "vtkToolkits.h"

Include dependency graph for vtkDebugLeaks.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDebugLeaks
identify memory leaks at program termination. More...

Generated on Mon Mar 25 01:08:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDirectory.h File Reference

Common/vtkDirectory.h File Reference

#include "vtkObject.h"
#include "vtkDebugLeaks.h"

Include dependency graph for vtkDirectory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDirectory
OS independent class for access to system directories. More...

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDoubleArray.h File Reference

Common/vtkDoubleArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkDoubleArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDoubleArray
dynamic, self-adjusting double precision array. More...

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDynamicLoader.h File Reference

Common/vtkDynamicLoader.h File Reference

#include "vtkConfigure.h"
#include "vtkObject.h"

Include dependency graph for vtkDynamicLoader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkDynamicLoader
class interface to system dynamic libraries. More...

Typedefs

typedef void * | vtkLibHandle

Typedef Documentation

typedef void* vtkLibHandle

Definition at line 49 of file vtkDynamicLoader.h.

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEdgeTable.h File Reference

Common/vtkEdgeTable.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkEdgeTable.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkEdgeTable
keep track of edges (edge is pair of integer id's). More...

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEmptyCell.h File Reference

Common/vtkEmptyCell.h File Reference

#include "vtkCell.h"

Include dependency graph for vtkEmptyCell.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEmptyCell
an empty cell used as a place-holder during processing. More...

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkErrorCode.h File Reference

Common/vtkErrorCode.h File Reference

Go to the source code of this file.

Compounds

class vtkErrorCode
superclass for error codes. More...

Generated on Mon Mar 25 01:08:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExplicitCell.h File Reference

Common/vtkExplicitCell.h File Reference

#include "vtkNonLinearCell.h"

Include dependency graph for vtkExplicitCell.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExplicitCell
abstract superclass for cells requiring an explicit representation. More...

Generated on Mon Mar 25 01:08:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtentTranslator.h File Reference

Common/vtkExtentTranslator.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkExtentTranslator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkExtentTranslator
Generates a structured extent from unstructured. More...

Generated on Mon Mar 25 01:08:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldData.h File Reference

Common/vtkFieldData.h File Reference

#include "vtkDataArray.h"
#include "vtkIdList.h"

Include dependency graph for vtkFieldData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkFieldData
represent and manipulate fields of data. More...

struct | vtkFieldData::CopyFieldFlag
class | vtkFieldData::BasicIterator
class | vtkFieldData::Iterator

Generated on Mon Mar 25 01:08:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFileOutputWindow.h File Reference

Common/vtkFileOutputWindow.h File Reference

#include "vtkOutputWindow.h"

Include dependency graph for vtkFileOutputWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkFileOutputWindow
File Specific output window class. More...

Generated on Mon Mar 25 01:08:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFloatArray.h File Reference

Common/vtkFloatArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkFloatArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkFloatArray
dynamic, self-adjusting floating point array. More...

Generated on Mon Mar 25 01:08:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFunctionParser.h File Reference

Common/vtkFunctionParser.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkFunctionParser.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkFunctionParser
Parse and evaluate a mathematical expression. More...

Defines

#define | VTK_PARSER_IMMEDIATE 1
#define | VTK_PARSER_UNARY_MINUS 2
#define | VTK_PARSER_ADD 3
#define | VTK_PARSER_SUBTRACT 4
#define | VTK_PARSER_MULTIPLY 5
#define | VTK_PARSER_DIVIDE 6
#define | VTK_PARSER_POWER 7
#define | VTK_PARSER_ABSOLUTE_VALUE 8
#define | VTK_PARSER_EXPONENT 9
#define | VTK_PARSER_CEILING 10
#define | VTK_PARSER_FLOOR 11
#define | VTK_PARSER_LOGARITHM 12
#define | VTK_PARSER_SQUARE_ROOT 13
#define | VTK_PARSER_SINE 14
#define | VTK_PARSER_COSINE 15
#define | VTK_PARSER_TANGENT 16
#define | VTK_PARSER_ARCSINE 17
#define | VTK_PARSER_ARCCOSINE 18
#define | VTK_PARSER_ARCTANGENT 19
#define | VTK_PARSER_HYPERBOLIC_SINE 20
#define | VTK_PARSER_HYPERBOLIC_COSINE 21
#define | VTK_PARSER_HYPERBOLIC_TANGENT 22
#define | VTK_PARSER_VECTOR_UNARY_MINUS 23
#define | VTK_PARSER_DOT_PRODUCT 24
#define | VTK_PARSER_VECTOR_ADD 25
#define | VTK_PARSER_VECTOR_SUBTRACT 26
#define | VTK_PARSER_SCALAR_MULTIPLE 27
#define | VTK_PARSER_MAGNITUDE 28
#define | VTK_PARSER_NORMALIZE 29
#define | VTK_PARSER_BEGIN_VARIABLES 30
#define | VTK_PARSER_ERROR_RESULT VTK_LARGE_FLOAT

Define Documentation

#define VTK_PARSER_IMMEDIATE 1

Definition at line 39 of file vtkFunctionParser.h.

#define VTK_PARSER_UNARY_MINUS 2

Definition at line 40 of file vtkFunctionParser.h.

#define VTK_PARSER_ADD 3

Definition at line 43 of file vtkFunctionParser.h.

#define VTK_PARSER_SUBTRACT 4

Definition at line 44 of file vtkFunctionParser.h.

#define VTK_PARSER_MULTIPLY 5

Definition at line 45 of file vtkFunctionParser.h.

#define VTK_PARSER_DIVIDE 6

Definition at line 46 of file vtkFunctionParser.h.

#define VTK_PARSER_POWER 7

Definition at line 47 of file vtkFunctionParser.h.

#define VTK_PARSER_ABSOLUTE_VALUE 8

Definition at line 48 of file vtkFunctionParser.h.

#define VTK_PARSER_EXPONENT 9

Definition at line 49 of file vtkFunctionParser.h.

#define VTK_PARSER_CEILING 10

Definition at line 50 of file vtkFunctionParser.h.

#define VTK_PARSER_FLOOR 11

Definition at line 51 of file vtkFunctionParser.h.

#define VTK_PARSER_LOGARITHM 12

Definition at line 52 of file vtkFunctionParser.h.

#define VTK_PARSER_SQUARE_ROOT 13

Definition at line 53 of file vtkFunctionParser.h.

#define VTK_PARSER_SINE 14

Definition at line 54 of file vtkFunctionParser.h.

#define VTK_PARSER_COSINE 15

Definition at line 55 of file vtkFunctionParser.h.

#define VTK_PARSER_TANGENT 16

Definition at line 56 of file vtkFunctionParser.h.

#define VTK_PARSER_ARCSINE 17

Definition at line 57 of file vtkFunctionParser.h.

#define VTK_PARSER_ARCCOSINE 18

Definition at line 58 of file vtkFunctionParser.h.

#define VTK_PARSER_ARCTANGENT 19

Definition at line 59 of file vtkFunctionParser.h.

#define VTK_PARSER_HYPERBOLIC_SINE 20

Definition at line 60 of file vtkFunctionParser.h.

#define VTK_PARSER_HYPERBOLIC_COSINE 21

Definition at line 61 of file vtkFunctionParser.h.

#define VTK_PARSER_HYPERBOLIC_TANGENT 22

Definition at line 62 of file vtkFunctionParser.h.

#define VTK_PARSER_VECTOR_UNARY_MINUS 23

Definition at line 65 of file vtkFunctionParser.h.

#define VTK_PARSER_DOT_PRODUCT 24

Definition at line 66 of file vtkFunctionParser.h.

#define VTK_PARSER_VECTOR_ADD 25

Definition at line 67 of file vtkFunctionParser.h.

#define VTK_PARSER_VECTOR_SUBTRACT 26

Definition at line 68 of file vtkFunctionParser.h.

#define VTK_PARSER_SCALAR_MULTIPLE 27

Definition at line 69 of file vtkFunctionParser.h.

#define VTK_PARSER_MAGNITUDE 28

Definition at line 70 of file vtkFunctionParser.h.

#define VTK_PARSER_NORMALIZE 29

Definition at line 71 of file vtkFunctionParser.h.

#define VTK_PARSER_BEGIN_VARIABLES 30

Definition at line 74 of file vtkFunctionParser.h.

#define VTK_PARSER_ERROR_RESULT VTK_LARGE_FLOAT

Definition at line 77 of file vtkFunctionParser.h.

Generated on Mon Mar 25 01:08:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFunctionSet.h File Reference

Common/vtkFunctionSet.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkFunctionSet.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkFunctionSet
Abstract inteface for sets of functions. More...

Generated on Mon Mar 25 01:08:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGeneralTransform.h File Reference

Common/vtkGeneralTransform.h File Reference

#include "vtkAbstractTransform.h"

Include dependency graph for vtkGeneralTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGeneralTransform
allows operations on any transforms. More...

Generated on Mon Mar 25 01:08:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGenericCell.h File Reference

Common/vtkGenericCell.h File Reference

#include "vtkCell.h"

Include dependency graph for vtkGenericCell.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkGenericCell
provides thread-safe access to cells. More...

Generated on Mon Mar 25 01:08:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHeap.h File Reference

Common/vtkHeap.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkHeap.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkHeapNode
class | vtkHeap
replacement for malloc/free and new/delete. More...

Generated on Mon Mar 25 01:08:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHexahedron.h File Reference

Common/vtkHexahedron.h File Reference

#include "vtkCell3D.h"
#include "vtkLine.h"
#include "vtkQuad.h"

Include dependency graph for vtkHexahedron.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkHexahedron
a cell that represents a 3D rectangular hexahedron. More...

Generated on Mon Mar 25 01:08:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHomogeneousTransform.h File Reference

Common/vtkHomogeneousTransform.h File Reference

#include "vtkAbstractTransform.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkHomogeneousTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkHomogeneousTransform
superclass for homogeneous transformations. More...

Generated on Mon Mar 25 01:08:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdentityTransform.h File Reference

Common/vtkIdentityTransform.h File Reference

#include "vtkLinearTransform.h"

Include dependency graph for vtkIdentityTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkIdentityTransform
a transform that doesn't do anything. More...

Generated on Mon Mar 25 01:08:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdList.h File Reference

Common/vtkIdList.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkIdList.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkIdList
list of point or cell ids. More...

Generated on Mon Mar 25 01:08:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdTypeArray.h File Reference

Common/vtkIdTypeArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkIdTypeArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkIdTypeArray
dynamic, self-adjusting integer array. More...

Generated on Mon Mar 25 01:08:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageData.h File Reference

Common/vtkImageData.h File Reference

#include "vtkDataSet.h"
#include "vtkStructuredData.h"

Include dependency graph for vtkImageData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageData
topologically and geometrically regular array of data. More...

Generated on Mon Mar 25 01:08:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIterator.h File Reference

Common/vtkImageIterator.h File Reference

#include "vtkWin32Header.h"

Include dependency graph for vtkImageIterator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageIterator
a simple image iterator. More...

Generated on Mon Mar 25 01:08:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageProgressIterator.h File Reference

Common/vtkImageProgressIterator.h File Reference

#include "vtkImageIterator.h"

Include dependency graph for vtkImageProgressIterator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageProgressIterator
a simple image iterator with progress. More...

Generated on Mon Mar 25 01:08:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunction.h File Reference

Common/vtkImplicitFunction.h File Reference

#include "vtkObject.h"
#include "vtkAbstractTransform.h"

Include dependency graph for vtkImplicitFunction.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitFunction
abstract interface for implicit functions. More...

Generated on Mon Mar 25 01:08:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunctionCollection.h File Reference

Common/vtkImplicitFunctionCollection.h File Reference

#include "vtkCollection.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkImplicitFunctionCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitFunctionCollection
maintain a list of implicit functions. More...

Generated on Mon Mar 25 01:08:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIndent.h File Reference

Common/vtkIndent.h File Reference

#include "vtkWin32Header.h"
#include "vtkSystemIncludes.h"

Include dependency graph for vtkIndent.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkIndent
a simple class to control print indentation. More...

Generated on Mon Mar 25 01:09:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInitialValueProblemSolver.h File Reference

Common/vtkInitialValueProblemSolver.h File Reference

#include "vtkFunctionSet.h"

Include dependency graph for vtkInitialValueProblemSolver.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkInitialValueProblemSolver
Integrate a set of ordinary. More...

Generated on Mon Mar 25 01:09:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInstantiator.h File Reference

Common/vtkInstantiator.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkInstantiator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInstantiator
create an instance of any VTK class from its name. More...

class | vtkInstantiatorInitialize

Variables

vtkInstantiatorInitialize vtkInstantiatorInitializer

Variable Documentation

vtkInstantiatorInitialize vtkInstantiatorInitializer [static]

Definition at line 139 of file vtkInstantiator.h.

Generated on Mon Mar 25 01:09:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIntArray.h File Reference

Common/vtkIntArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkIntArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkIntArray
dynamic, self-adjusting integer array. More...

Generated on Mon Mar 25 01:09:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolatedVelocityField.h File Reference

Common/vtkInterpolatedVelocityField.h File Reference

#include "vtkFunctionSet.h"
#include "vtkDataSet.h"
#include "vtkGenericCell.h"

Include dependency graph for vtkInterpolatedVelocityField.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkInterpolatedVelocityField
Interface for obtaining. More...

Generated on Mon Mar 25 01:09:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJavaAwt.h File Reference

Common/vtkJavaAwt.h File Reference

#include "jawt_md.h"

Include dependency graph for vtkJavaAwt.h:

Include dependency graph

Go to the source code of this file.

Functions

JNIEXPORT void JNICALL | Java_vtkPanel_RenderCreate (JNIEnv *env, jobject canvas, jobject id0)
JNIEXPORT void JNICALL | Java_vtkPanel_Lock (JNIEnv *env, jobject canvas)
JNIEXPORT void JNICALL | Java_vtkPanel_UnLock (JNIEnv *env, jobject canvas)

Function Documentation

JNIEXPORT void JNICALL Java_vtkPanel_RenderCreate | ( | JNIEnv * | env,
 |  | jobject | canvas,
 |  | jobject | id0
 | ) |

Definition at line 20 of file vtkJavaAwt.h.

JNIEXPORT void JNICALL Java_vtkPanel_Lock | ( | JNIEnv * | env,
 |  | jobject | canvas
 | ) |

Definition at line 101 of file vtkJavaAwt.h.

JNIEXPORT void JNICALL Java_vtkPanel_UnLock | ( | JNIEnv * | env,
 |  | jobject | canvas
 | ) |

Definition at line 138 of file vtkJavaAwt.h.

Generated on Mon Mar 25 01:09:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJavaUtil.h File Reference

Common/vtkJavaUtil.h File Reference

#include "vtkSystemIncludes.h"
#include <jni.h>
#include "vtkCommand.h"

Include dependency graph for vtkJavaUtil.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | vtkJavaVoidFuncArg
class | vtkJavaCommand

Functions

JNIEXPORT int | vtkJavaGetId (JNIEnv *env, jobject obj)
JNIEXPORT int | vtkJavaRegisterNewObject (JNIEnv *env, jobject obj, void *ptr)
JNIEXPORT void | vtkJavaRegisterCastFunction (JNIEnv *env, jobject obj, int id, void *tcFunc)
JNIEXPORT void * | vtkJavaGetPointerFromObject (JNIEnv *env, jobject obj, char *result_type)
JNIEXPORT void | vtkJavaDeleteObject (JNIEnv *env, jobject obj)
JNIEXPORT jobject | vtkJavaGetObjectFromPointer (void *ptr)
JNIEXPORT char * | vtkJavaUTFToChar (JNIEnv *env, jstring in)
JNIEXPORT jstring | vtkJavaMakeJavaString (JNIEnv *env, const char *in)
JNIEXPORT jarray | vtkJavaMakeJArrayOfDoubleFromFloat (JNIEnv *env, float *arr, int size)
JNIEXPORT jarray | vtkJavaMakeJArrayOfDoubleFromDouble (JNIEnv *env, double *arr, int size)
JNIEXPORT jarray | vtkJavaMakeJArrayOfIntFromInt (JNIEnv *env, int *arr, int size)
JNIEXPORT jarray | vtkJavaMakeJArrayOfByteFromUnsignedChar (JNIEnv *env, unsigned char *arr, int size)
JNIEXPORT jobject | vtkJavaCreateNewJavaStubForObject (JNIEnv *env, vtkObject *obj)
JNIEXPORT jobject | vtkJavaCreateNewJavaStub (JNIEnv *env, const char *fullclassname, void *obj)
JNIEXPORT void | vtkJavaVoidFunc (void *)
JNIEXPORT void | vtkJavaVoidFuncArgDelete (void *)

Function Documentation

JNIEXPORT int vtkJavaGetId | ( | JNIEnv * | env,
 |  | jobject | obj
 | ) |

JNIEXPORT int vtkJavaRegisterNewObject | ( | JNIEnv * | env,
 |  | jobject | obj,
 |  | void * | ptr
 | ) |

JNIEXPORT void vtkJavaRegisterCastFunction | ( | JNIEnv * | env,
 |  | jobject | obj,
 |  | int | id,
 |  | void * | tcFunc
 | ) |

JNIEXPORT void* vtkJavaGetPointerFromObject | ( | JNIEnv * | env,
 |  | jobject | obj,
 |  | char * | result_type
 | ) |

Referenced by Java_vtkPanel_RenderCreate().

JNIEXPORT void vtkJavaDeleteObject | ( | JNIEnv * | env,
 |  | jobject | obj
 | ) |

JNIEXPORT jobject vtkJavaGetObjectFromPointer ( void * ptr )

JNIEXPORT char* vtkJavaUTFToChar | ( | JNIEnv * | env,
 |  | jstring | in
 | ) |

JNIEXPORT jstring vtkJavaMakeJavaString | ( | JNIEnv * | env,
 |  | const char * | in
 | ) |

JNIEXPORT jarray vtkJavaMakeJArrayOfDoubleFromFloat | ( | JNIEnv * | env,
 |  | float * | arr,
 |  | int | size
 | ) |

JNIEXPORT jarray vtkJavaMakeJArrayOfDoubleFromDouble | ( | JNIEnv * | env,
 |  | double * | arr,
 |  | int | size
 | ) |

JNIEXPORT jarray vtkJavaMakeJArrayOfIntFromInt | ( | JNIEnv * | env,
 |  | int * | arr,
 |  | int | size
 | ) |

JNIEXPORT jarray vtkJavaMakeJArrayOfByteFromUnsignedChar | ( | JNIEnv * | env,
 |  | unsigned char * | arr,
 |  | int | size
 | ) |

JNIEXPORT jobject vtkJavaCreateNewJavaStubForObject | ( | JNIEnv * | env,
 |  | vtkObject * | obj
 | ) |

JNIEXPORT jobject vtkJavaCreateNewJavaStub | ( | JNIEnv * | env,
 |  | const char * | fullclassname,
 |  | void * | obj
 | ) |

JNIEXPORT void vtkJavaVoidFunc ( void * )

JNIEXPORT void vtkJavaVoidFuncArgDelete ( void * )

Generated on Mon Mar 25 01:09:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLargeInteger.h File Reference

Common/vtkLargeInteger.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkLargeInteger.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkLargeInteger
class for arbitrarily large ints. More...

Generated on Mon Mar 25 01:09:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLine.h File Reference

Common/vtkLine.h File Reference

#include "vtkCell.h"

Include dependency graph for vtkLine.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkLine
cell represents a 1D line. More...

Generated on Mon Mar 25 01:09:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearTransform.h File Reference

Common/vtkLinearTransform.h File Reference

#include "vtkHomogeneousTransform.h"

Include dependency graph for vtkLinearTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkLinearTransform
abstract superclass for linear transformations. More...

Generated on Mon Mar 25 01:09:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLocator.h File Reference

Common/vtkLocator.h File Reference

#include "vtkObject.h"
#include "vtkDataSet.h"

Include dependency graph for vtkLocator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkLocator
abstract base class for objects that accelerate spatial searches. More...

Generated on Mon Mar 25 01:09:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLogLookupTable.h File Reference

Common/vtkLogLookupTable.h File Reference

#include "vtkLookupTable.h"

Include dependency graph for vtkLogLookupTable.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLogLookupTable
map scalars into colors using log (base 10) scale. More...

Generated on Mon Mar 25 01:09:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLongArray.h File Reference

Common/vtkLongArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkLongArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLongArray
dynamic, self-adjusting long integer array. More...

Generated on Mon Mar 25 01:09:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLookupTable.h File Reference

Common/vtkLookupTable.h File Reference

#include "vtkScalarsToColors.h"

Include dependency graph for vtkLookupTable.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkLookupTable
map scalar values into colors via a lookup table. More...

Defines

#define | VTK_RAMP_LINEAR 0
#define | VTK_RAMP_SCURVE 1
#define | VTK_SCALE_LINEAR 0
#define | VTK_SCALE_LOG10 1

Define Documentation

#define VTK_RAMP_LINEAR 0

Definition at line 52 of file vtkLookupTable.h.

#define VTK_RAMP_SCURVE 1

Definition at line 53 of file vtkLookupTable.h.

#define VTK_SCALE_LINEAR 0

Definition at line 54 of file vtkLookupTable.h.

#define VTK_SCALE_LOG10 1

Definition at line 55 of file vtkLookupTable.h.

Generated on Mon Mar 25 01:09:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapper2D.h File Reference

Common/vtkMapper2D.h File Reference

#include "vtkAbstractMapper.h"
#include "vtkWindow.h"

Include dependency graph for vtkMapper2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMapper2D

Generated on Mon Mar 25 01:09:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingCubesCases.h File Reference

Common/vtkMarchingCubesCases.h File Reference

Go to the source code of this file.

Compounds

struct | VTK_TRIANGLE_CASES

Typedefs

typedef int | EDGE_LIST

Typedef Documentation

typedef int EDGE_LIST

Definition at line 21 of file vtkMarchingCubesCases.h.

Generated on Mon Mar 25 01:09:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingSquaresCases.h File Reference

Common/vtkMarchingSquaresCases.h File Reference

Go to the source code of this file.

Compounds

struct | VTK_LINE_CASES

Typedefs

typedef int | EDGE_LIST

Typedef Documentation

typedef int EDGE_LIST

Definition at line 22 of file vtkMarchingSquaresCases.h.

Generated on Mon Mar 25 01:09:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMath.h File Reference

Common/vtkMath.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkMath.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkMath
performs common math operations. More...

Functions

template<class T> double | vtkDeterminant3x3 (T A[3][3])

Function Documentation

template<class T>
double vtkDeterminant3x3 ( T A[3][3] ) [inline, static]

Definition at line 573 of file vtkMath.h.

Referenced by vtkMath::Determinant3x3().

Generated on Mon Mar 25 01:09:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrix4x4.h File Reference

Common/vtkMatrix4x4.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkMatrix4x4.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMatrix4x4
represent and manipulate 4x4 transformation matrices. More...

Generated on Mon Mar 25 01:09:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrixToHomogeneousTransform.h File Reference

Common/vtkMatrixToHomogeneousTransform.h File Reference

#include "vtkHomogeneousTransform.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkMatrixToHomogeneousTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMatrixToHomogeneousTransform
convert a matrix to a transform. More...

Generated on Mon Mar 25 01:09:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrixToLinearTransform.h File Reference

Common/vtkMatrixToLinearTransform.h File Reference

#include "vtkLinearTransform.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkMatrixToLinearTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMatrixToLinearTransform
convert a matrix to a transform. More...

Generated on Mon Mar 25 01:09:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiThreader.h File Reference

Common/vtkMultiThreader.h File Reference

#include "vtkObject.h"
#include "vtkMutexLock.h"

Include dependency graph for vtkMultiThreader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | ThreadInfoStruct
class | vtkMultiThreader
A class for performing multithreaded execution. More...

Defines

#define | VTK_MAX_THREADS 1
#define | VTK_THREAD_RETURN_VALUE
#define | VTK_THREAD_RETURN_TYPE void

Typedefs

typedef void(* | vtkThreadFunctionType )(void *)
typedef int | vtkThreadProcessIDType

Define Documentation

#define VTK_MAX_THREADS 1

Definition at line 74 of file vtkMultiThreader.h.

#define VTK_THREAD_RETURN_VALUE

Definition at line 105 of file vtkMultiThreader.h.

#define VTK_THREAD_RETURN_TYPE void

Definition at line 106 of file vtkMultiThreader.h.

Typedef Documentation

typedef void(* vtkThreadFunctionType)(void *)

Definition at line 103 of file vtkMultiThreader.h.

typedef int vtkThreadProcessIDType

Definition at line 104 of file vtkMultiThreader.h.

Generated on Mon Mar 25 01:09:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMutexLock.h File Reference

Common/vtkMutexLock.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkMutexLock.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkSimpleMutexLock
class | vtkMutexLock
mutual exclusion locking class. More...

Typedefs

typedef int | vtkMutexType

Typedef Documentation

typedef int vtkMutexType

Definition at line 62 of file vtkMutexLock.h.

Generated on Mon Mar 25 01:09:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkNonLinearCell.h File Reference

Common/vtkNonLinearCell.h File Reference

#include "vtkCell.h"
#include "vtkPointLocator.h"

Include dependency graph for vtkNonLinearCell.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkNonLinearCell
abstract superclass for non-linear cells. More...

Generated on Mon Mar 25 01:09:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObject.h File Reference

Common/vtkObject.h File Reference

#include "vtkIndent.h"
#include "vtkTimeStamp.h"
#include "vtkSetGet.h"

Include dependency graph for vtkObject.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkObject
abstract base class for most VTK objects. More...

Generated on Mon Mar 25 01:09:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObjectFactory.h File Reference

Common/vtkObjectFactory.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkObjectFactory.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkObjectFactory
abstract base class for vtkObjectFactories. More...

struct | vtkObjectFactory::OverrideInformation

Defines

#define | VTK_CREATE_CREATE_FUNCTION(classname)
#define | VTK_FACTORY_INTERFACE_EXPORT
#define | VTK_FACTORY_INTERFACE_IMPLEMENT(factoryName)

Define Documentation

#define VTK_CREATE_CREATE_FUNCTION ( classname )

Value:

static vtkObject* vtkObjectFactoryCreate##classname() \
{ return classname::New(); }

Definition at line 257 of file vtkObjectFactory.h.

#define VTK_FACTORY_INTERFACE_EXPORT

Definition at line 267 of file vtkObjectFactory.h.

#define VTK_FACTORY_INTERFACE_IMPLEMENT ( factoryName )

Value:

extern "C"                                      \
VTK_FACTORY_INTERFACE_EXPORT                    \
const char* vtkGetFactoryCompilerUsed()         \
{                                               \
  return VTK_CXX_COMPILER;                      \
}                                               \
extern "C"                                      \
VTK_FACTORY_INTERFACE_EXPORT                    \
const char* vtkGetFactoryVersion()              \
{                                               \
  return VTK_SOURCE_VERSION;                    \
}                                               \
extern "C"                                      \
VTK_FACTORY_INTERFACE_EXPORT                    \
vtkObjectFactory* vtkLoad()                     \
{                                               \
  return factoryName ::New();                   \
}

Definition at line 275 of file vtkObjectFactory.h.

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObjectFactoryCollection.h File Reference

Common/vtkObjectFactoryCollection.h File Reference

#include "vtkCollection.h"
#include "vtkObjectFactory.h"
#include "vtkDebugLeaks.h"

Include dependency graph for vtkObjectFactoryCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkObjectFactoryCollection
maintain a list of object factories. More...

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOldStyleCallbackCommand.h File Reference

Common/vtkOldStyleCallbackCommand.h File Reference

#include "vtkCommand.h"

Include dependency graph for vtkOldStyleCallbackCommand.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOldStyleCallbackCommand
old syntax for callbacks. More...

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOrderedTriangulator.h File Reference

Common/vtkOrderedTriangulator.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkOrderedTriangulator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOrderedTriangulator
helper class to generate triangulations. More...

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutputWindow.h File Reference

Common/vtkOutputWindow.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkOutputWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkOutputWindowSmartPointer
class | vtkOutputWindow
base class for writing debug output to a console. More...

Variables

VTK_COMMON_EXPORT | vtkOutputWindow

Variable Documentation

class VTK_COMMON_EXPORT vtkOutputWindow

Definition at line 46 of file vtkOutputWindow.h.

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOverrideInformation.h File Reference

Common/vtkOverrideInformation.h File Reference

#include "vtkObject.h"
#include "vtkObjectFactory.h"

Include dependency graph for vtkOverrideInformation.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkOverrideInformation
Factory object override information. More...

Generated on Mon Mar 25 01:09:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOverrideInformationCollection.h File Reference

Common/vtkOverrideInformationCollection.h File Reference

#include "vtkCollection.h"
#include "vtkOverrideInformation.h"

Include dependency graph for vtkOverrideInformationCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOverrideInformationCollection
maintain a list of override information objects. More...

Generated on Mon Mar 25 01:09:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPerspectiveTransform.h File Reference

Common/vtkPerspectiveTransform.h File Reference

#include "vtkHomogeneousTransform.h"

Include dependency graph for vtkPerspectiveTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPerspectiveTransform
describes a 4x4 matrix transformation. More...

Generated on Mon Mar 25 01:09:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPixel.h File Reference

Common/vtkPixel.h File Reference

#include "vtkCell.h"
#include "vtkLine.h"

Include dependency graph for vtkPixel.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPixel
a cell that represents an orthogonal quadrilateral. More...

Generated on Mon Mar 25 01:09:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlane.h File Reference

Common/vtkPlane.h File Reference

#include <math.h>
#include "vtkImplicitFunction.h"

Include dependency graph for vtkPlane.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPlane
perform various plane computations. More...

Generated on Mon Mar 25 01:09:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlaneCollection.h File Reference

Common/vtkPlaneCollection.h File Reference

#include "vtkCollection.h"
#include "vtkPlane.h"

Include dependency graph for vtkPlaneCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPlaneCollection
maintain a list of planes. More...

Generated on Mon Mar 25 01:09:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlanes.h File Reference

Common/vtkPlanes.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkPlanes.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPlanes
implicit function for convex set of planes. More...

Generated on Mon Mar 25 01:09:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointData.h File Reference

Common/vtkPointData.h File Reference

#include "vtkDataSetAttributes.h"

Include dependency graph for vtkPointData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointData
represent and manipulate point attribute data. More...

Generated on Mon Mar 25 01:09:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLocator.h File Reference

Common/vtkPointLocator.h File Reference

#include "vtkLocator.h"
#include "vtkPoints.h"

Include dependency graph for vtkPointLocator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointLocator
quickly locate points in 3-space. More...

Generated on Mon Mar 25 01:09:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLocator2D.h File Reference

Common/vtkPointLocator2D.h File Reference

#include "vtkLocator.h"
#include "vtkPoints.h"
#include "vtkIdList.h"

Include dependency graph for vtkPointLocator2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointLocator2D
quickly locate points in 2-space. More...

Generated on Mon Mar 25 01:09:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPoints.h File Reference

Common/vtkPoints.h File Reference

#include "vtkObject.h"
#include "vtkDataArray.h"
#include "vtkIdList.h"

Include dependency graph for vtkPoints.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPoints
represent and manipulate 3D points. More...

Generated on Mon Mar 25 01:09:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSet.h File Reference

Common/vtkPointSet.h File Reference

#include "vtkDataSet.h"
#include "vtkPointLocator.h"

Include dependency graph for vtkPointSet.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointSet
abstract class for specifying dataset behavior. More...

Generated on Mon Mar 25 01:09:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyData.h File Reference

Common/vtkPolyData.h File Reference

#include "vtkPointSet.h"
#include "vtkPoints.h"
#include "vtkCellArray.h"
#include "vtkCellTypes.h"
#include "vtkCellLinks.h"

Include dependency graph for vtkPolyData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyData
concrete dataset represents vertices, lines, polygons, and triangle strips. More...

Generated on Mon Mar 25 01:09:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolygon.h File Reference

Common/vtkPolygon.h File Reference

#include "vtkCell.h"
#include "vtkPoints.h"
#include "vtkLine.h"
#include "vtkTriangle.h"
#include "vtkQuad.h"

Include dependency graph for vtkPolygon.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolygon
a cell that represents an n-sided polygon. More...

Generated on Mon Mar 25 01:09:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyLine.h File Reference

Common/vtkPolyLine.h File Reference

#include "vtkCell.h"
#include "vtkPoints.h"
#include "vtkCellArray.h"
#include "vtkLine.h"

Include dependency graph for vtkPolyLine.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyLine
cell represents a set of 1D lines. More...

Generated on Mon Mar 25 01:09:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyVertex.h File Reference

Common/vtkPolyVertex.h File Reference

#include "vtkCell.h"
#include "vtkVertex.h"

Include dependency graph for vtkPolyVertex.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyVertex
cell represents a set of 0D vertices. More...

Generated on Mon Mar 25 01:09:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPriorityQueue.h File Reference

Common/vtkPriorityQueue.h File Reference

#include "vtkObject.h"
#include "vtkIdTypeArray.h"

Include dependency graph for vtkPriorityQueue.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | _vtkPriorityItem
class | vtkPriorityQueue
an list of ids arranged in priority order. More...

Typedefs

typedef _vtkPriorityItem | vtkPriorityItem

Typedef Documentation

typedef struct _vtkPriorityItem vtkPriorityItem

Generated on Mon Mar 25 01:09:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcessObject.h File Reference

Common/vtkProcessObject.h File Reference

#include "vtkDataObject.h"

Include dependency graph for vtkProcessObject.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkProcessObject
abstract class specifies interface for visualization filters. More...

Generated on Mon Mar 25 01:09:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcessStatistics.h File Reference

Common/vtkProcessStatistics.h File Reference

#include "vtkObject.h"
#include "vtkLine.h"
#include "vtkPixel.h"

Include dependency graph for vtkProcessStatistics.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProcessStatistics
get statistics such as cpu and memory usage. More...

Generated on Mon Mar 25 01:09:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp.h File Reference

Common/vtkProp.h File Reference

#include "vtkObject.h"
#include "vtkAssemblyPaths.h"

Include dependency graph for vtkProp.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkProp
abstract superclass for all actors, volumes and annotations. More...

Generated on Mon Mar 25 01:09:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropAssembly.h File Reference

Common/vtkPropAssembly.h File Reference

#include "vtkProp.h"

Include dependency graph for vtkPropAssembly.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPropAssembly
create hierarchies of props. More...

Generated on Mon Mar 25 01:09:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropCollection.h File Reference

Common/vtkPropCollection.h File Reference

#include "vtkCollection.h"
#include "vtkProp.h"

Include dependency graph for vtkPropCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPropCollection
a list of Props. More...

Generated on Mon Mar 25 01:09:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProperty2D.h File Reference

Common/vtkProperty2D.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkProperty2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkProperty2D

Defines

#define | VTK_BACKGROUND_LOCATION 0
#define | VTK_FOREGROUND_LOCATION 1

Define Documentation

#define VTK_BACKGROUND_LOCATION 0

Definition at line 44 of file vtkProperty2D.h.

#define VTK_FOREGROUND_LOCATION 1

Definition at line 45 of file vtkProperty2D.h.

Generated on Mon Mar 25 01:09:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPyramid.h File Reference

Common/vtkPyramid.h File Reference

#include "vtkCell3D.h"
#include "vtkLine.h"
#include "vtkTriangle.h"
#include "vtkQuad.h"

Include dependency graph for vtkPyramid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPyramid
a 3D cell that represents a pyramid. More...

Generated on Mon Mar 25 01:09:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPythonUtil.h File Reference

Common/vtkPythonUtil.h File Reference

#include "vtkObject.h"
#include "vtkTimeStamp.h"
#include "Python.h"
#include "vtkCommand.h"

Include dependency graph for vtkPythonUtil.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | PyVTKClass
struct | PyVTKObject
struct | PyVTKSpecialObject
class | vtkPythonCommand

Defines

#define | VTK_PYTHON_EXPORT

Typedefs

typedef vtkObject *(* | vtknewfunc )()

Functions

VTK_PYTHON_EXPORT int | PyVTKObject_Check (PyObject *obj)
VTK_PYTHON_EXPORT int | PyVTKClass_Check (PyObject *obj)
VTK_PYTHON_EXPORT int | PyVTKSpecialObjectCheck (PyObject *obj)
VTK_PYTHON_EXPORT PyObject * | PyVTKObject_New (PyObject *vtkclass, vtkObject *ptr)
VTK_PYTHON_EXPORT PyObject * | PyVTKClass_New (vtknewfunc constructor, PyMethodDef *methods, char *classname, char *modulename, char *docstring[], PyObject *base)
VTK_PYTHON_EXPORT PyObject * | PyVTKSpecialObject_New (void *ptr, PyMethodDef *methods, char *classname, char *docstring[])
VTK_PYTHON_EXPORT vtkObject * | PyArg_VTKParseTuple (PyObject *self, PyObject *args, char *format,...)
VTK_PYTHON_EXPORT void | vtkPythonAddClassToHash (PyObject *obj, char *type)
VTK_PYTHON_EXPORT vtkObject * | vtkPythonGetPointerFromObject (PyObject *obj, char *type)
VTK_PYTHON_EXPORT PyObject * | vtkPythonGetObjectFromPointer (vtkObject *ptr)
VTK_PYTHON_EXPORT PyObject * | vtkPythonGetObjectFromObject (PyObject *arg, const char *type)
VTK_PYTHON_EXPORT void | vtkPythonAddObjectToHash (PyObject *obj, vtkObject *anInstance)
VTK_PYTHON_EXPORT void | vtkPythonDeleteObjectFromHash (PyObject *obj)
VTK_PYTHON_EXPORT char * | vtkPythonManglePointer (void *ptr, const char *type)
VTK_PYTHON_EXPORT void * | vtkPythonUnmanglePointer (char *ptrText, int *len, const char *type)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, char *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, unsigned char *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, short *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, unsigned short *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, int *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, unsigned int *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, long *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, unsigned long *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, float *a, int n)
VTK_PYTHON_EXPORT int | vtkPythonCheckArray (PyObject *args, int i, double *a, int n)
VTK_PYTHON_EXPORT void | vtkPythonVoidFunc (void *)
VTK_PYTHON_EXPORT void | vtkPythonVoidFuncArgDelete (void *)

Define Documentation

#define VTK_PYTHON_EXPORT

Definition at line 28 of file vtkPythonUtil.h.

Typedef Documentation

typedef vtkObject*(* vtknewfunc)()

Definition at line 33 of file vtkPythonUtil.h.

Function Documentation

VTK_PYTHON_EXPORT int PyVTKObject_Check ( PyObject * obj )

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT int PyVTKClass_Check ( PyObject * obj )

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT int PyVTKSpecialObjectCheck ( PyObject * obj )

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT PyObject* PyVTKObject_New | ( | PyObject * | vtkclass,
 |  | vtkObject * | ptr
 | ) |

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT PyObject* PyVTKClass_New | ( | vtknewfunc | constructor,
 |  | PyMethodDef * | methods,
 |  | char * | classname,
 |  | char * | modulename,
 |  | char * | docstring[],
 |  | PyObject * | base
 | ) |

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT PyObject* PyVTKSpecialObject_New | ( | void * | ptr,
 |  | PyMethodDef * | methods,
 |  | char * | classname,
 |  | char * | docstring[]
 | ) |

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT vtkObject* PyArg_VTKParseTuple | ( | PyObject * | self,
 |  | PyObject * | args,
 |  | char * | format,
 |  | ... |
 | ) |

Referenced by PyVTKSpecialObject::vtk_doc().

VTK_PYTHON_EXPORT void vtkPythonAddClassToHash | ( | PyObject * | obj,
 |  | char * | type
 | ) |

VTK_PYTHON_EXPORT vtkObject* vtkPythonGetPointerFromObject | ( | PyObject * | obj,
 |  | char * | type
 | ) |

VTK_PYTHON_EXPORT PyObject* vtkPythonGetObjectFromPointer ( vtkObject * ptr )

VTK_PYTHON_EXPORT PyObject* vtkPythonGetObjectFromObject | ( | PyObject * | arg,
 |  | const char * | type
 | ) |

VTK_PYTHON_EXPORT void vtkPythonAddObjectToHash | ( | PyObject * | obj,
 |  | vtkObject * | anInstance
 | ) |

VTK_PYTHON_EXPORT void vtkPythonDeleteObjectFromHash ( PyObject * obj )

VTK_PYTHON_EXPORT char* vtkPythonManglePointer | ( | void * | ptr,
 |  | const char * | type
 | ) |

VTK_PYTHON_EXPORT void* vtkPythonUnmanglePointer | ( | char * | ptrText,
 |  | int * | len,
 |  | const char * | type
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | char * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | unsigned char * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | short * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | unsigned short * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | int * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | unsigned int * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | long * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | unsigned long * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | float * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT int vtkPythonCheckArray | ( | PyObject * | args,
 |  | int | i,
 |  | double * | a,
 |  | int | n
 | ) |

VTK_PYTHON_EXPORT void vtkPythonVoidFunc ( void * )

VTK_PYTHON_EXPORT void vtkPythonVoidFuncArgDelete ( void * )

Generated on Mon Mar 25 01:09:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuad.h File Reference

Common/vtkQuad.h File Reference

#include "vtkCell.h"
#include "vtkLine.h"

Include dependency graph for vtkQuad.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkQuad
a cell that represents a 2D quadrilateral. More...

Generated on Mon Mar 25 01:09:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadraticEdge.h File Reference

Common/vtkQuadraticEdge.h File Reference

#include "vtkNonLinearCell.h"

Include dependency graph for vtkQuadraticEdge.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuadraticEdge
cell represents a parabolic, isoparametric edge. More...

Generated on Mon Mar 25 01:09:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadric.h File Reference

Common/vtkQuadric.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkQuadric.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkQuadric
evaluate implicit quadric function. More...

Generated on Mon Mar 25 01:09:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRayCastStructures.h File Reference

Common/vtkRayCastStructures.h File Reference

Go to the source code of this file.

Compounds

struct VTKRayCastRayInfo

Generated on Mon Mar 25 01:09:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGrid.h File Reference

Common/vtkRectilinearGrid.h File Reference

#include "vtkDataSet.h"
#include "vtkStructuredData.h"

Include dependency graph for vtkRectilinearGrid.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGrid
a datset that is topologically regular with variable spacing in the three coordinate directions. More...

Generated on Mon Mar 25 01:10:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReferenceCount.h File Reference

Common/vtkReferenceCount.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkReferenceCount.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkReferenceCount
Obsolete / empty subclass of object. More...

Generated on Mon Mar 25 01:10:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta2.h File Reference

Common/vtkRungeKutta2.h File Reference

#include "vtkInitialValueProblemSolver.h"

Include dependency graph for vtkRungeKutta2.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRungeKutta2
Integrate an initial value problem using 2nd. More...

Generated on Mon Mar 25 01:10:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta4.h File Reference

Common/vtkRungeKutta4.h File Reference

#include "vtkInitialValueProblemSolver.h"

Include dependency graph for vtkRungeKutta4.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRungeKutta4
Integrate an initial value problem using 4th. More...

Generated on Mon Mar 25 01:10:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta45.h File Reference

Common/vtkRungeKutta45.h File Reference

#include "vtkInitialValueProblemSolver.h"

Include dependency graph for vtkRungeKutta45.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRungeKutta45
Integrate an initial value problem using 5th. More...

Generated on Mon Mar 25 01:10:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarsToColors.h File Reference

Common/vtkScalarsToColors.h File Reference

#include "vtkObject.h"
#include "vtkUnsignedCharArray.h"

Include dependency graph for vtkScalarsToColors.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkScalarsToColors
map scalar values into colors. More...

Defines

#define | VTK_LUMINANCE 1
#define | VTK_LUMINANCE_ALPHA 2
#define | VTK_RGB 3
#define | VTK_RGBA 4
#define | VTK_COLOR_MODE_DEFAULT 0
#define | VTK_COLOR_MODE_MAP_SCALARS 1

Define Documentation

#define VTK_LUMINANCE 1

Definition at line 48 of file vtkScalarsToColors.h.

#define VTK_LUMINANCE_ALPHA 2

Definition at line 49 of file vtkScalarsToColors.h.

#define VTK_RGB 3

Definition at line 50 of file vtkScalarsToColors.h.

#define VTK_RGBA 4

Definition at line 51 of file vtkScalarsToColors.h.

#define VTK_COLOR_MODE_DEFAULT 0

Definition at line 53 of file vtkScalarsToColors.h.

#define VTK_COLOR_MODE_MAP_SCALARS 1

Definition at line 54 of file vtkScalarsToColors.h.

Generated on Mon Mar 25 01:10:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSetGet.h File Reference

Common/vtkSetGet.h File Reference

#include "vtkSystemIncludes.h"
#include <math.h>

Include dependency graph for vtkSetGet.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | VTK_LARGE_FLOAT 1.0e+38F
#define | VTK_LARGE_ID 2147483647
#define | VTK_LARGE_INTEGER 2147483647
#define | VTK_VOID 0
#define | VTK_BIT 1
#define | VTK_CHAR 2
#define | VTK_UNSIGNED_CHAR 3
#define | VTK_SHORT 4
#define | VTK_UNSIGNED_SHORT 5
#define | VTK_INT 6
#define | VTK_UNSIGNED_INT 7
#define | VTK_LONG 8
#define | VTK_UNSIGNED_LONG 9
#define | VTK_FLOAT 10
#define | VTK_DOUBLE 11
#define | VTK_ID_TYPE 12
#define | VTK_STRING 13
#define | VTK_OPAQUE 14
#define | VTK_BIT_MIN 0
#define | VTK_BIT_MAX 1
#define | VTK_CHAR_MIN -128
#define | VTK_CHAR_MAX 127
#define | VTK_UNSIGNED_CHAR_MIN 0
#define | VTK_UNSIGNED_CHAR_MAX 255
#define | VTK_SHORT_MIN -32768
#define | VTK_SHORT_MAX 32767
#define | VTK_UNSIGNED_SHORT_MIN 0
#define | VTK_UNSIGNED_SHORT_MAX 65535
#define | VTK_INT_MIN (-VTK_LARGE_INTEGER-1)
#define | VTK_INT_MAX VTK_LARGE_INTEGER
#define | VTK_UNSIGNED_INT_MIN 0
#define | VTK_UNSIGNED_INT_MAX 4294967295UL
#define | VTK_LONG_MIN (-VTK_LARGE_INTEGER-1)
#define | VTK_LONG_MAX VTK_LARGE_INTEGER
#define | VTK_UNSIGNED_LONG_MIN 0
#define | VTK_UNSIGNED_LONG_MAX 4294967295UL
#define | VTK_FLOAT_MIN -VTK_LARGE_FLOAT
#define | VTK_FLOAT_MAX VTK_LARGE_FLOAT
#define | VTK_DOUBLE_MIN -1.0e+99L
#define | VTK_DOUBLE_MAX 1.0e+99L
#define | VTK_POLY_DATA 0
#define | VTK_STRUCTURED_POINTS 1
#define | VTK_STRUCTURED_GRID 2
#define | VTK_RECTILINEAR_GRID 3
#define | VTK_UNSTRUCTURED_GRID 4
#define | VTK_PIECEWISE_FUNCTION 5
#define | VTK_IMAGE_DATA 6
#define | VTK_DATA_OBJECT 7
#define | VTK_DATA_SET 8
#define | VTK_OK 1
#define | VTK_ERROR 2
#define | vtkImageScalarTypeNameMacro(type)
#define | vtkSetMacro(name, type)
#define | vtkGetMacro(name, type)
#define | vtkSetStringMacro(name)
#define | vtkGetStringMacro(name)
#define | vtkSetClampMacro(name, type, min, max)
#define | vtkSetObjectBodyMacro(name, type, args)
#define | vtkSetObjectMacro(name, type)
#define | vtkSetObjectImplementationMacro(class, name, type) vtkCxxSetObjectMacro(class,name,type)
#define | vtkCxxSetObjectMacro(class, name, type)
#define | vtkGetObjectMacro(name, type)
#define | vtkBooleanMacro(name, type)
#define | vtkSetVector2Macro(name, type)
#define | vtkGetVector2Macro(name, type)
#define | vtkSetVector3Macro(name, type)
#define | vtkGetVector3Macro(name, type)
#define | vtkSetVector4Macro(name, type)
#define | vtkGetVector4Macro(name, type)
#define | vtkSetVector6Macro(name, type)
#define | vtkGetVector6Macro(name, type)
#define | vtkSetVectorMacro(name, type, count)
#define | vtkGetVectorMacro(name, type, count)
#define | vtkGenericWarningMacro(x)
#define | vtkDebugMacro(x)
#define | vtkWarningMacro(x) vtkWarningWithObjectMacro(this,x)
#define | vtkErrorMacro(x) vtkErrorWithObjectMacro(this,x)
#define | vtkErrorWithObjectMacro(self, x)
#define | vtkWarningWithObjectMacro(self, x)
#define | vtkNotUsed(x)
#define | vtkWorldCoordinateMacro(name)
#define | vtkViewportCoordinateMacro(name)
#define | vtkTypeMacro(thisClass, superclass)
#define | vtkTypeRevisionMacro(thisClass, superclass)
#define | vtkCxxRevisionMacro(thisClass, revision)
#define | vtkStandardNewMacro(thisClass)
#define | vtkTemplateMacro3(func, arg1, arg2, arg3)
#define | vtkTemplateMacro4(func, arg1, arg2, arg3, arg4)
#define | vtkTemplateMacro5(func, arg1, arg2, arg3, arg4, arg5)
#define | vtkTemplateMacro6(func, arg1, arg2, arg3, arg4, arg5, arg6)
#define | vtkTemplateMacro7(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7)
#define | vtkTemplateMacro8(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8)
#define | vtkTemplateMacro9(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9)
#define | vtkTemplateMacro10(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10)
#define | VTK_LEGACY_METHOD(oldMethod, versionStringMadeLegacy)

Functions

VTK_COMMON_EXPORT void | vtkOutputWindowDisplayText (const char *)
VTK_COMMON_EXPORT void | vtkOutputWindowDisplayErrorText (const char *)
VTK_COMMON_EXPORT void | vtkOutputWindowDisplayWarningText (const char *)
VTK_COMMON_EXPORT void | vtkOutputWindowDisplayGenericWarningText (const char *)
VTK_COMMON_EXPORT void | vtkOutputWindowDisplayDebugText (const char *)

Define Documentation

#define VTK_LARGE_FLOAT 1.0e+38F

Definition at line 45 of file vtkSetGet.h.

#define VTK_LARGE_ID 2147483647

Definition at line 53 of file vtkSetGet.h.

#define VTK_LARGE_INTEGER 2147483647

Definition at line 56 of file vtkSetGet.h.

#define VTK_VOID 0

Definition at line 59 of file vtkSetGet.h.

#define VTK_BIT 1

Definition at line 60 of file vtkSetGet.h.

#define VTK_CHAR 2

Definition at line 61 of file vtkSetGet.h.

#define VTK_UNSIGNED_CHAR 3

Definition at line 62 of file vtkSetGet.h.

#define VTK_SHORT 4

Definition at line 63 of file vtkSetGet.h.

#define VTK_UNSIGNED_SHORT 5

Definition at line 64 of file vtkSetGet.h.

#define VTK_INT 6

Definition at line 65 of file vtkSetGet.h.

#define VTK_UNSIGNED_INT 7

Definition at line 66 of file vtkSetGet.h.

#define VTK_LONG 8

Definition at line 67 of file vtkSetGet.h.

#define VTK_UNSIGNED_LONG 9

Definition at line 68 of file vtkSetGet.h.

#define VTK_FLOAT 10

Definition at line 69 of file vtkSetGet.h.

#define VTK_DOUBLE 11

Definition at line 70 of file vtkSetGet.h.

#define VTK_ID_TYPE 12

Definition at line 71 of file vtkSetGet.h.

#define VTK_STRING 13

Definition at line 75 of file vtkSetGet.h.

#define VTK_OPAQUE 14

Definition at line 76 of file vtkSetGet.h.

#define VTK_BIT_MIN 0

Definition at line 79 of file vtkSetGet.h.

#define VTK_BIT_MAX 1

Definition at line 80 of file vtkSetGet.h.

#define VTK_CHAR_MIN -128

Definition at line 81 of file vtkSetGet.h.

#define VTK_CHAR_MAX 127

Definition at line 82 of file vtkSetGet.h.

#define VTK_UNSIGNED_CHAR_MIN 0

Definition at line 83 of file vtkSetGet.h.

#define VTK_UNSIGNED_CHAR_MAX 255

Definition at line 84 of file vtkSetGet.h.

#define VTK_SHORT_MIN -32768

Definition at line 85 of file vtkSetGet.h.

#define VTK_SHORT_MAX 32767

Definition at line 86 of file vtkSetGet.h.

#define VTK_UNSIGNED_SHORT_MIN 0

Definition at line 87 of file vtkSetGet.h.

#define VTK_UNSIGNED_SHORT_MAX 65535

Definition at line 88 of file vtkSetGet.h.

#define VTK_INT_MIN (-VTK_LARGE_INTEGER-1)

Definition at line 89 of file vtkSetGet.h.

#define VTK_INT_MAX VTK_LARGE_INTEGER

Definition at line 90 of file vtkSetGet.h.

#define VTK_UNSIGNED_INT_MIN 0

Definition at line 91 of file vtkSetGet.h.

#define VTK_UNSIGNED_INT_MAX 4294967295UL

Definition at line 92 of file vtkSetGet.h.

#define VTK_LONG_MIN (-VTK_LARGE_INTEGER-1)

Definition at line 93 of file vtkSetGet.h.

#define VTK_LONG_MAX VTK_LARGE_INTEGER

Definition at line 94 of file vtkSetGet.h.

#define VTK_UNSIGNED_LONG_MIN 0

Definition at line 95 of file vtkSetGet.h.

#define VTK_UNSIGNED_LONG_MAX 4294967295UL

Definition at line 96 of file vtkSetGet.h.

#define VTK_FLOAT_MIN -VTK_LARGE_FLOAT

Definition at line 97 of file vtkSetGet.h.

#define VTK_FLOAT_MAX VTK_LARGE_FLOAT

Definition at line 98 of file vtkSetGet.h.

#define VTK_DOUBLE_MIN -1.0e+99L

Definition at line 99 of file vtkSetGet.h.

#define VTK_DOUBLE_MAX 1.0e+99L

Definition at line 100 of file vtkSetGet.h.

#define VTK_POLY_DATA 0

Definition at line 103 of file vtkSetGet.h.

#define VTK_STRUCTURED_POINTS 1

Definition at line 104 of file vtkSetGet.h.

#define VTK_STRUCTURED_GRID 2

Definition at line 105 of file vtkSetGet.h.

#define VTK_RECTILINEAR_GRID 3

Definition at line 106 of file vtkSetGet.h.

#define VTK_UNSTRUCTURED_GRID 4

Definition at line 107 of file vtkSetGet.h.

#define VTK_PIECEWISE_FUNCTION 5

Definition at line 108 of file vtkSetGet.h.

#define VTK_IMAGE_DATA 6

Definition at line 109 of file vtkSetGet.h.

#define VTK_DATA_OBJECT 7

Definition at line 110 of file vtkSetGet.h.

#define VTK_DATA_SET 8

Definition at line 111 of file vtkSetGet.h.

#define VTK_OK 1

Definition at line 114 of file vtkSetGet.h.

#define VTK_ERROR 2

Definition at line 115 of file vtkSetGet.h.

#define vtkImageScalarTypeNameMacro ( type )

Value:

(((type) == VTK_VOID) ? "void" : \
(((type) == VTK_FLOAT) ? "float" : \
(((type) == VTK_INT) ? "int" : \
(((type) == VTK_SHORT) ? "short" : \
(((type) == VTK_UNSIGNED_SHORT) ? "unsigned short" : \
(((type) == VTK_UNSIGNED_CHAR) ? "unsigned char" : \
"Undefined"))))))

Definition at line 118 of file vtkSetGet.h.

Referenced by vtkImageImport::GetDataScalarTypeAsString(), vtkImageGridSource::GetDataScalarTypeAsString(), vtkImageExport::GetDataScalarTypeAsString(), and vtkImageData::GetScalarTypeAsString().

#define vtkSetMacro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type _arg) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " #name " to " << _arg); \
  if (this->name != _arg) \
    { \
    this->name = _arg; \
    this->Modified(); \
    } \
  }

Definition at line 131 of file vtkSetGet.h.

#define vtkGetMacro | ( | name,
 |  | type | )

Value:

virtual type Get##name () { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " of " << this->name ); \
  return this->name; \
  }

Definition at line 145 of file vtkSetGet.h.

Referenced by vtkWindowLevelLookupTable::SetLevel().

#define vtkSetStringMacro ( name )

Value:

virtual void Set##name (const char* _arg) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to " << _arg ); \
  if ( this->name == NULL && _arg == NULL) { return;} \
  if ( this->name && _arg && (!strcmp(this->name,_arg))) { return;} \
  if (this->name) { delete [] this->name; } \
  if (_arg) \
    { \
    this->name = new char[strlen(_arg)+1]; \
    strcpy(this->name,_arg); \
    } \
   else \
    { \
    this->name = NULL; \
    } \
  this->Modified(); \
  }

Definition at line 156 of file vtkSetGet.h.

#define vtkGetStringMacro ( name )

Value:

virtual char* Get##name () { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " of " << this->name); \
  return this->name; \
  }

Definition at line 179 of file vtkSetGet.h.

#define vtkSetClampMacro | ( | name,
 |  | type,
 |  | min,
 |  | max | )

Value:

virtual void Set##name (type _arg) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to " << _arg ); \
  if (this->name != (_arg<min?min:(_arg>max?max:_arg))) \
    { \
    this->name = (_arg<min?min:(_arg>max?max:_arg)); \
    this->Modified(); \
    } \
  } \
virtual type Get##name##MinValue () \
  { \
  return min; \
  } \
virtual type Get##name##MaxValue () \
  { \
  return max; \
  }

Definition at line 192 of file vtkSetGet.h.

#define vtkSetObjectBodyMacro | ( | name,
 |  | type,
 |  | args | )

Value:

{                                                             \
  vtkDebugMacro(<< this->GetClassName() << " (" << this         \
                << "): setting " << #name " to " << args );     \
  if (this->name != args)                                       \
    {                                                           \
    if (this->name != NULL) { this->name->UnRegister(this); }   \
    this->name = args;                                          \
    if (this->name != NULL) { this->name->Register(this); }     \
    this->Modified();                                           \
    }                                                           \
  }

Definition at line 218 of file vtkSetGet.h.

#define vtkSetObjectMacro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type* _arg)             \
  {                                             \
  vtkSetObjectBodyMacro(name,type,_arg);        \
  }

Definition at line 236 of file vtkSetGet.h.

#define vtkSetObjectImplementationMacro | ( | class,
 |  | name,
 |  | type | ) | vtkCxxSetObjectMacro(class,name,type)

Definition at line 251 of file vtkSetGet.h.

#define vtkCxxSetObjectMacro | ( | class,
 |  | name,
 |  | type | )

Value:

void class::Set##name (type* _arg)              \
  {                                             \
  vtkSetObjectBodyMacro(name,type,_arg);        \
  }

Definition at line 254 of file vtkSetGet.h.

#define vtkGetObjectMacro | ( | name,
 |  | type | )

Value:

virtual type *Get##name ()                                              \
  {                                                                     \
  vtkDebugMacro(<< this->GetClassName() << " (" << this                 \
                << "): returning " #name " address " << this->name );   \
  return this->name;                                                    \
  }

Definition at line 264 of file vtkSetGet.h.

#define vtkBooleanMacro | ( | name,
 |  | type | )

Value:

virtual void name##On () { this->Set##name((type)1);}; \
virtual void name##Off () { this->Set##name((type)0);}

Definition at line 276 of file vtkSetGet.h.

Referenced by vtkWindowLevelLookupTable::SetLevel().

#define vtkSetVector2Macro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type _arg1, type _arg2) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << ")"); \
  if ((this->name[0] != _arg1)||(this->name[1] != _arg2)) \
    { \
    this->name[0] = _arg1; \
    this->name[1] = _arg2; \
    this->Modified(); \
    } \
  }; \
void Set##name (type _arg[2]) \
  { \
  this->Set##name (_arg[0], _arg[1]); \
  }

Definition at line 286 of file vtkSetGet.h.

#define vtkGetVector2Macro | ( | name,
 |  | type | )

Value:

virtual type *Get##name () \
{ \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
  return this->name; \
} \
virtual void Get##name (type &_arg1, type &_arg2) \
  { \
    _arg1 = this->name[0]; \
    _arg2 = this->name[1]; \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << ")"); \
  }; \
virtual void Get##name (type _arg[2]) \
  { \
  this->Get##name (_arg[0], _arg[1]);\
  }

Definition at line 302 of file vtkSetGet.h.

#define vtkSetVector3Macro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type _arg1, type _arg2, type _arg3) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << ")"); \
  if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)) \
    { \
    this->name[0] = _arg1; \
    this->name[1] = _arg2; \
    this->name[2] = _arg3; \
    this->Modified(); \
    } \
  }; \
virtual void Set##name (type _arg[3]) \
  { \
  this->Set##name (_arg[0], _arg[1], _arg[2]);\
  }

Definition at line 319 of file vtkSetGet.h.

Referenced by vtkImageReslice::GetBackgroundLevel().

#define vtkGetVector3Macro | ( | name,
 |  | type | )

Value:

virtual type *Get##name () \
{ \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
  return this->name; \
} \
virtual void Get##name (type &_arg1, type &_arg2, type &_arg3) \
  { \
    _arg1 = this->name[0]; \
    _arg2 = this->name[1]; \
    _arg3 = this->name[2]; \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << ")"); \
  }; \
virtual void Get##name (type _arg[3]) \
  { \
  this->Get##name (_arg[0], _arg[1], _arg[2]);\
  }

Definition at line 336 of file vtkSetGet.h.

Referenced by vtkImageReslice::GetBackgroundLevel().

#define vtkSetVector4Macro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type _arg1, type _arg2, type _arg3, type _arg4) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << ")"); \
  if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)||(this->name[3] != _arg4)) \
    { \
    this->name[0] = _arg1; \
    this->name[1] = _arg2; \
    this->name[2] = _arg3; \
    this->name[3] = _arg4; \
    this->Modified(); \
    } \
  }; \
virtual void Set##name (type _arg[4]) \
  { \
  this->Set##name (_arg[0], _arg[1], _arg[2], _arg[3]);\
  }

Definition at line 354 of file vtkSetGet.h.

Referenced by vtkWindowLevelLookupTable::SetLevel().

#define vtkGetVector4Macro | ( | name,
 |  | type | )

Value:

virtual type *Get##name () \
{ \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
  return this->name; \
} \
virtual void Get##name (type &_arg1, type &_arg2, type &_arg3, type &_arg4) \
  { \
    _arg1 = this->name[0]; \
    _arg2 = this->name[1]; \
    _arg3 = this->name[2]; \
    _arg4 = this->name[3]; \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << ")"); \
  }; \
virtual void Get##name (type _arg[4]) \
  { \
  this->Get##name (_arg[0], _arg[1], _arg[2], _arg[3]);\
  }

Definition at line 373 of file vtkSetGet.h.

Referenced by vtkWindowLevelLookupTable::SetLevel().

#define vtkSetVector6Macro | ( | name,
 |  | type | )

Value:

virtual void Set##name (type _arg1, type _arg2, type _arg3, type _arg4, type _arg5, type _arg6) \
  { \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << "," << _arg5 << "," << _arg6 << ")"); \
  if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)||(this->name[3] != _arg4)||(this->name[4] != _arg5)||(this->name[5] != _arg6)) \
    { \
    this->name[0] = _arg1; \
    this->name[1] = _arg2; \
    this->name[2] = _arg3; \
    this->name[3] = _arg4; \
    this->name[4] = _arg5; \
    this->name[5] = _arg6; \
    this->Modified(); \
    } \
  }; \
virtual void Set##name (type _arg[6]) \
  { \
  this->Set##name (_arg[0], _arg[1], _arg[2], _arg[3], _arg[4], _arg[5]);\
  }

Definition at line 392 of file vtkSetGet.h.

#define vtkGetVector6Macro | ( | name,
 |  | type | )

Value:

virtual type *Get##name () \
{ \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
  return this->name; \
} \
virtual void Get##name (type &_arg1, type &_arg2, type &_arg3, type &_arg4, type &_arg5, type &_arg6) \
  { \
    _arg1 = this->name[0]; \
    _arg2 = this->name[1]; \
    _arg3 = this->name[2]; \
    _arg4 = this->name[3]; \
    _arg5 = this->name[4]; \
    _arg6 = this->name[5]; \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << "," << _arg5 <<"," << _arg6 << ")"); \
  }; \
virtual void Get##name (type _arg[6]) \
  { \
  this->Get##name (_arg[0], _arg[1], _arg[2], _arg[3], _arg[4], _arg[5]);\
  }

Definition at line 412 of file vtkSetGet.h.

#define vtkSetVectorMacro | ( | name,
 |  | type,
 |  | count | )

Value:

virtual void Set##name(type data[]) \
{ \
  int i; \
  for (i=0; i<count; i++) { if ( data[i] != this->name[i] ) { break; }} \
  if ( i < count ) \
    { \
    for (i=0; i<count; i++) { this->name[i] = data[i]; }\
    this->Modified(); \
    } \
}

Definition at line 438 of file vtkSetGet.h.

#define vtkGetVectorMacro | ( | name,
 |  | type,
 |  | count | )

Value:

virtual type *Get##name () \
{ \
  vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
  return this->name; \
} \
virtual void Get##name (type data[count]) \
{ \
  for (int i=0; i<count; i++) { data[i] = this->name[i]; }\
}

Definition at line 456 of file vtkSetGet.h.

#define vtkGenericWarningMacro ( x )

Value:

{ if (vtkObject::GetGlobalWarningDisplay()) { \
      char *vtkmsgbuff; ostrstream vtkmsg; \
      vtkmsg << "Generic Warning: In " __FILE__ ", line " << __LINE__ << "\n" x \
      << "\n\n" << ends; \
      vtkmsgbuff = vtkmsg.str(); \
      vtkOutputWindowDisplayGenericWarningText(vtkmsgbuff);\
      vtkmsg.rdbuf()->freeze(0);}}

Definition at line 482 of file vtkSetGet.h.

#define vtkDebugMacro ( x )

Value:

{ if (this->Debug && vtkObject::GetGlobalWarningDisplay()) \
    { char *vtkmsgbuff; \
      ostrstream vtkmsg; \
      vtkmsg << "Debug: In " __FILE__ ", line " << __LINE__ << "\n" << this->GetClassName() << " (" << this << "): " x  << "\n\n" << ends; \
      vtkmsgbuff = vtkmsg.str(); \
      vtkOutputWindowDisplayDebugText(vtkmsgbuff);\
      vtkmsg.rdbuf()->freeze(0);}}

Definition at line 498 of file vtkSetGet.h.

Referenced by vtkWin32ImageWindow::GetGenericDisplayId(), vtkWin32ImageWindow::SetDisplayId(), vtkProp3D::SetOrigin(), vtkProp3D::SetPosition(), and vtkProp3D::SetScale().

#define vtkWarningMacro ( x ) vtkWarningWithObjectMacro(this,x)

Definition at line 511 of file vtkSetGet.h.

Referenced by vtkPicker::GetActors(), vtkImageViewer::GetGrayScaleHint(), vtkImageViewer::GetImageWindow(), vtkImageViewer::GetImager(), vtkImageViewer::GrayScaleHintOff(), vtkImageViewer::GrayScaleHintOn(), vtkAbstractTransform::Identity(), vtkImageViewer::SetGrayScaleHint(), vtkMatrixToLinearTransform::SetMatrix(), vtkMatrixToHomogeneousTransform::SetMatrix(), and vtkFieldData::SetNumberOfArrays().

#define vtkErrorMacro ( x ) vtkErrorWithObjectMacro(this,x)

Definition at line 518 of file vtkSetGet.h.

Referenced by vtkTensor::AddComponent(), vtkImageIterateFilter::ComputeInputUpdateExtent(), vtkImager::Erase(), vtkProgrammableAttributeDataFilter::ExecuteMethodArg(), vtkTensor::GetColumn(), vtkImageToImageFilter::GetInputMemoryLimit(), vtkAppendFilter::InputList(), vtkMultiProcessController::RemoveRMI(), vtkTensor::SetComponent(), vtkImageToImageFilter::SetInputMemoryLimit(), vtkImageWindow::SetParentInfo(), vtkDataObject::SetUpdateExtent(), vtkImageWindow::SetWindowInfo(), and vtkInterpolateDataSetAttributes::T().

#define vtkErrorWithObjectMacro | ( | self,
 |  | x | )

Value:

{                                                            \
   if (vtkObject::GetGlobalWarningDisplay())                    \
     {                                                          \
     char *vtkmsgbuff;                                          \
     ostrstream vtkmsg;                                         \
     vtkmsg << "ERROR: In " __FILE__ ", line " << __LINE__      \
            << "\n" << self->GetClassName() << " (" << self     \
            << "): " x << "\n\n" << ends;                       \
     vtkmsgbuff = vtkmsg.str();                                 \
     if ( self->HasObserver("ErrorEvent") )                     \
       {                                                        \
       self->InvokeEvent("ErrorEvent", vtkmsg.str());           \
       }                                                        \
     else                                                       \
       {                                                        \
       vtkOutputWindowDisplayErrorText(vtkmsgbuff);             \
       }                                                        \
     vtkmsg.rdbuf()->freeze(0); vtkObject::BreakOnError();      \
     }                                                          \
   }

Definition at line 525 of file vtkSetGet.h.

#define vtkWarningWithObjectMacro | ( | self,
 |  | x | )

Value:

{                                                            \
   if (vtkObject::GetGlobalWarningDisplay())                    \
     {                                                          \
     char *vtkmsgbuff;                                          \
     ostrstream vtkmsg;                                         \
     vtkmsg << "Warning: In " __FILE__ ", line " << __LINE__    \
            << "\n" << self->GetClassName() << " (" << self     \
            << "): " x << "\n\n" << ends;                       \
     vtkmsgbuff = vtkmsg.str();                                 \
     if ( self->HasObserver("WarningEvent") )                   \
       {                                                        \
       self->InvokeEvent("WarningEvent", vtkmsg.str());         \
       }                                                        \
     else                                                       \
       {                                                        \
       vtkOutputWindowDisplayWarningText(vtkmsgbuff);           \
       }                                                        \
     vtkmsg.rdbuf()->freeze(0);                                 \
     }                                                          \
   }

Definition at line 551 of file vtkSetGet.h.

#define vtkNotUsed ( x )

Definition at line 581 of file vtkSetGet.h.

#define vtkWorldCoordinateMacro ( name )

Value:

virtual vtkCoordinate *Get##name##Coordinate () \
{ \
    vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " #name "Coordinate address " << this->name##Coordinate ); \
    return this->name##Coordinate; \
} \
virtual void Set##name(float x[3]) {this->Set##name(x[0],x[1],x[2]);}; \
virtual void Set##name(float x, float y, float z) \
{ \
    this->name##Coordinate->SetValue(x,y,z); \
} \
virtual float *Get##name() \
{ \
    return this->name##Coordinate->GetValue(); \
}

Definition at line 583 of file vtkSetGet.h.

#define vtkViewportCoordinateMacro ( name )

Value:

virtual vtkCoordinate *Get##name##Coordinate () \
{ \
    vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " #name "Coordinate address " << this->name##Coordinate ); \
    return this->name##Coordinate; \
} \
virtual void Set##name(float x[2]) {this->Set##name(x[0],x[1]);}; \
virtual void Set##name(float x, float y) \
{ \
    this->name##Coordinate->SetValue(x,y); \
} \
virtual float *Get##name() \
{ \
    return this->name##Coordinate->GetValue(); \
}

Definition at line 599 of file vtkSetGet.h.

#define vtkTypeMacro | ( | thisClass,
 |  | superclass | )

Value:

typedef superclass Superclass; \
  virtual const char *GetClassName() {return #thisClass;} \
  static int IsTypeOf(const char *type) \
  { \
    if ( !strcmp(#thisClass,type) ) \
      { \
      return 1; \
      } \
    return superclass::IsTypeOf(type); \
  } \
  virtual int IsA(const char *type) \
  { \
    return this->thisClass::IsTypeOf(type); \
  } \
  static thisClass* SafeDownCast(vtkObject *o) \
  { \
    if ( o && o->IsA(#thisClass) ) \
      { \
      return (thisClass *)o; \
      } \
    return NULL;\
  }

Definition at line 618 of file vtkSetGet.h.

#define vtkTypeRevisionMacro | ( | thisClass,
 |  | superclass | )

Value:

protected: \
  void CollectRevisions(ostream& os); \
  public: \
  vtkTypeMacro(thisClass,superclass)

Definition at line 643 of file vtkSetGet.h.

#define vtkCxxRevisionMacro | ( | thisClass,
 |  | revision | )

Value:

void thisClass::CollectRevisions(ostream& os) \
  { \
    this->Superclass::CollectRevisions(os); \
    os << #thisClass " " revision "\n"; \
  }

Definition at line 650 of file vtkSetGet.h.

#define vtkStandardNewMacro ( thisClass )

Value:

thisClass* thisClass::New() \
  { \
    vtkObject* ret = vtkObjectFactory::CreateInstance(#thisClass); \
    if(ret) \
      { \
      return static_cast<thisClass*>(ret); \
      } \
    return new thisClass; \
  }

Definition at line 658 of file vtkSetGet.h.

#define vtkTemplateMacro3 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3 | )

Definition at line 673 of file vtkSetGet.h.

#define vtkTemplateMacro4 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4 | )

Definition at line 715 of file vtkSetGet.h.

#define vtkTemplateMacro5 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5 | )

Definition at line 757 of file vtkSetGet.h.

#define vtkTemplateMacro6 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5,
 |  | arg6 | )

Definition at line 799 of file vtkSetGet.h.

#define vtkTemplateMacro7 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5,
 |  | arg6,
 |  | arg7 | )

Definition at line 841 of file vtkSetGet.h.

#define vtkTemplateMacro8 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5,
 |  | arg6,
 |  | arg7,
 |  | arg8 | )

Definition at line 883 of file vtkSetGet.h.

#define vtkTemplateMacro9 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5,
 |  | arg6,
 |  | arg7,
 |  | arg8,
 |  | arg9 | )

Definition at line 925 of file vtkSetGet.h.

#define vtkTemplateMacro10 | ( | func,
 |  | arg1,
 |  | arg2,
 |  | arg3,
 |  | arg4,
 |  | arg5,
 |  | arg6,
 |  | arg7,
 |  | arg8,
 |  | arg9,
 |  | arg10 | )

Definition at line 967 of file vtkSetGet.h.

#define VTK_LEGACY_METHOD | ( | oldMethod,
 |  | versionStringMadeLegacy | )

Value:

vtkErrorMacro(<< #oldMethod \
                << " was obsoleted for version " << #versionStringMadeLegacy \
                << " and will be removed in a future version");

Definition at line 1013 of file vtkSetGet.h.

Referenced by vtkRayCaster::AutomaticScaleAdjustmentOff(), vtkRayCaster::AutomaticScaleAdjustmentOn(), vtkRayCaster::BilinearImageZoomOff(), vtkRayCaster::BilinearImageZoomOn(), vtkImageSource::ComputeRequiredInputUpdateExtent(), vtkUnsignedShortArray::DeepCopy(), vtkUnsignedLongArray::DeepCopy(), vtkUnsignedIntArray::DeepCopy(), vtkRayCaster::GetAutomaticScaleAdjustment(), vtkRayCaster::GetAutomaticScaleLowerLimit(), vtkRayCaster::GetBilinearImageZoom(), vtkCamera::GetCompositePerspectiveTransform(), vtkRayCaster::GetImageScale(), vtkRayCaster::GetImageScaleCount(), vtkPolyDataNormals::GetMaxRecursionDepth(), vtkRayCaster::GetNumberOfSamplesTaken(), vtkRayCaster::GetNumberOfThreads(), vtkRayCaster::GetParallelIncrements(), vtkRayCaster::GetParallelStartPosition(), vtkCamera::GetPerspectiveTransform(), vtkRayCaster::GetPerspectiveViewRays(), vtkRenderer::GetRayCaster(), vtkRayCaster::GetSelectedImageScaleIndex(), vtkRayCaster::GetTotalRenderTime(), vtkRayCaster::GetViewRaysStepSize(), vtkCamera::GetViewTransform(), vtkRayCaster::SetAutomaticScaleLowerLimit(), vtkRayCaster::SetBilinearImageZoom(), vtkRayCaster::SetImageScale(), vtkImageAppendComponents::SetInput1(), vtkImageAppendComponents::SetInput2(), vtkPolyDataNormals::SetMaxRecursionDepth(), vtkRayCaster::SetNumberOfThreads(), vtkImageMandelbrotSource::SetSample(), vtkRayCaster::SetSelectedImageScaleIndex(), and vtkRayCaster::SetViewRaysStepSize().

Function Documentation

VTK_COMMON_EXPORT void vtkOutputWindowDisplayText ( const char * )

VTK_COMMON_EXPORT void vtkOutputWindowDisplayErrorText ( const char * )

VTK_COMMON_EXPORT void vtkOutputWindowDisplayWarningText ( const char * )

VTK_COMMON_EXPORT void vtkOutputWindowDisplayGenericWarningText ( const char * )

VTK_COMMON_EXPORT void vtkOutputWindowDisplayDebugText ( const char * )

Generated on Mon Mar 25 01:10:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShortArray.h File Reference

Common/vtkShortArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkShortArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkShortArray
dynamic, self-adjusting short integer array. More...

Generated on Mon Mar 25 01:10:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSource.h File Reference

Common/vtkSource.h File Reference

#include "vtkProcessObject.h"
#include "vtkDataObject.h"

Include dependency graph for vtkSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkSource
abstract class specifies interface for visualization network source. More...

Generated on Mon Mar 25 01:10:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredData.h File Reference

Common/vtkStructuredData.h File Reference

#include "vtkObject.h"
#include "vtkIdList.h"

Include dependency graph for vtkStructuredData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkStructuredData
abstract class for topologically regular data. More...

Defines

#define | VTK_UNCHANGED 0
#define | VTK_SINGLE_POINT 1
#define | VTK_X_LINE 2
#define | VTK_Y_LINE 3
#define | VTK_Z_LINE 4
#define | VTK_XY_PLANE 5
#define | VTK_YZ_PLANE 6
#define | VTK_XZ_PLANE 7
#define | VTK_XYZ_GRID 8
#define | VTK_EMPTY 9

Define Documentation

#define VTK_UNCHANGED 0

Definition at line 41 of file vtkStructuredData.h.

#define VTK_SINGLE_POINT 1

Definition at line 42 of file vtkStructuredData.h.

#define VTK_X_LINE 2

Definition at line 43 of file vtkStructuredData.h.

#define VTK_Y_LINE 3

Definition at line 44 of file vtkStructuredData.h.

#define VTK_Z_LINE 4

Definition at line 45 of file vtkStructuredData.h.

#define VTK_XY_PLANE 5

Definition at line 46 of file vtkStructuredData.h.

#define VTK_YZ_PLANE 6

Definition at line 47 of file vtkStructuredData.h.

#define VTK_XZ_PLANE 7

Definition at line 48 of file vtkStructuredData.h.

#define VTK_XYZ_GRID 8

Definition at line 49 of file vtkStructuredData.h.

#define VTK_EMPTY 9

Definition at line 50 of file vtkStructuredData.h.

Generated on Mon Mar 25 01:10:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGrid.h File Reference

Common/vtkStructuredGrid.h File Reference

#include "vtkPointSet.h"
#include "vtkStructuredData.h"
#include "vtkUnsignedCharArray.h"

Include dependency graph for vtkStructuredGrid.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGrid
topologically regular array of data. More...

Generated on Mon Mar 25 01:10:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPoints.h File Reference

Common/vtkStructuredPoints.h File Reference

#include "vtkImageData.h"

Include dependency graph for vtkStructuredPoints.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPoints
A subclass of ImageData. More...

Generated on Mon Mar 25 01:10:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSystemIncludes.h File Reference

Common/vtkSystemIncludes.h File Reference

#include "vtkConfigure.h"
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream.h>
#include <strstream.h>
#include <fstream.h>

Include dependency graph for vtkSystemIncludes.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | VTK_HAS_ID_TYPE

Typedefs

typedef int | vtkIdType

Define Documentation

#define VTK_HAS_ID_TYPE

Definition at line 85 of file vtkSystemIncludes.h.

Typedef Documentation

typedef int vtkIdType

Definition at line 106 of file vtkSystemIncludes.h.

Generated on Mon Mar 25 01:10:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTclUtil.h File Reference

Common/vtkTclUtil.h File Reference

#include "vtkObject.h"
#include "vtkCommand.h"
#include <tcl.h>

Include dependency graph for vtkTclUtil.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkTclCommand
struct | _vtkTclVoidFuncArg
struct | vtkTclCommandArgStruct
struct | vtkTclCommandStruct
struct | vtkTclInterpStruct

Defines

#define | VTKTCL_EXPORT

Typedefs

typedef _vtkTclVoidFuncArg | vtkTclVoidFuncArg

Functions

VTKTCL_EXPORT void | vtkTclDeleteObjectFromHash (vtkObject *, unsigned long eventId, void *, void *)
VTKTCL_EXPORT void | vtkTclGenericDeleteObject (ClientData cd)
VTKTCL_EXPORT void | vtkTclGetObjectFromPointer (Tcl_Interp *interp, void *temp, int(*command)(ClientData, Tcl_Interp *, int, char *[]))
VTKTCL_EXPORT void * | vtkTclGetPointerFromObject (const char *name, const char *result_type, Tcl_Interp *interp, int &error)
VTKTCL_EXPORT void | vtkTclVoidFunc (void *)
VTKTCL_EXPORT void | vtkTclVoidFuncArgDelete (void *)
VTKTCL_EXPORT void | vtkTclListInstances (Tcl_Interp *interp, ClientData arg)
VTKTCL_EXPORT int | vtkTclInDelete (Tcl_Interp *interp)
VTKTCL_EXPORT int | vtkTclNewInstanceCommand (ClientData cd, Tcl_Interp *interp, int argc, char *argv[])
VTKTCL_EXPORT void | vtkTclDeleteCommandStruct (ClientData cd)
VTKTCL_EXPORT void | vtkTclCreateNew (Tcl_Interp *interp, const char *cname, ClientData(*NewCommand)(), int(*CommandFunction)(ClientData cd, Tcl_Interp *interp, int argc, char *argv[]))

Define Documentation

#define VTKTCL_EXPORT

Definition at line 27 of file vtkTclUtil.h.

Typedef Documentation

typedef struct _vtkTclVoidFuncArg vtkTclVoidFuncArg

Function Documentation

VTKTCL_EXPORT void vtkTclDeleteObjectFromHash | ( | vtkObject * | ,
 |  | unsigned long | eventId,
 |  | void * | ,
 |  | void * |
 | ) |

VTKTCL_EXPORT void vtkTclGenericDeleteObject ( ClientData cd )

VTKTCL_EXPORT void vtkTclGetObjectFromPointer | ( | Tcl_Interp * | interp,
 |  | void * | temp,
 |  | int(* | command)(ClientData, Tcl_Interp *, int, char *[])
 | ) |

VTKTCL_EXPORT void* vtkTclGetPointerFromObject | ( | const char * | name,
 |  | const char * | result_type,
 |  | Tcl_Interp * | interp,
 |  | int & | error
 | ) |

VTKTCL_EXPORT void vtkTclVoidFunc ( void * )

VTKTCL_EXPORT void vtkTclVoidFuncArgDelete ( void * )

VTKTCL_EXPORT void vtkTclListInstances | ( | Tcl_Interp * | interp,
 |  | ClientData | arg
 | ) |

VTKTCL_EXPORT int vtkTclInDelete ( Tcl_Interp * interp )

VTKTCL_EXPORT int vtkTclNewInstanceCommand | ( | ClientData | cd,
 |  | Tcl_Interp * | interp,
 |  | int | argc,
 |  | char * | argv[]
 | ) |

VTKTCL_EXPORT void vtkTclDeleteCommandStruct ( ClientData cd )

VTKTCL_EXPORT void vtkTclCreateNew | ( | Tcl_Interp * | interp,
 |  | const char * | cname,
 |  | ClientData(* | NewCommand)(),
 |  | int(* | CommandFunction)(ClientData cd, Tcl_Interp *interp, int argc, char *argv[])
 | ) |

Generated on Mon Mar 25 01:10:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTensor.h File Reference

Common/vtkTensor.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkTensor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTensor
supporting class to enable assignment and referencing of tensors. More...

Generated on Mon Mar 25 01:10:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTetra.h File Reference

Common/vtkTetra.h File Reference

#include "vtkCell3D.h"
#include "vtkLine.h"
#include "vtkTriangle.h"

Include dependency graph for vtkTetra.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTetra
a 3D cell that represents a tetrahedron. More...

Generated on Mon Mar 25 01:10:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTimerLog.h File Reference

Common/vtkTimerLog.h File Reference

#include "vtkSystemIncludes.h"
#include <time.h>
#include <sys/time.h>
#include <sys/types.h>
#include <sys/times.h>
#include <unistd.h>
#include <stdarg.h>
#include "vtkObject.h"

Include dependency graph for vtkTimerLog.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | vtkTimerLogEntry
class | vtkTimerLog
Timer support and logging. More...

Defines

#define | SELECT_MASK fd_set
#define | VTK_LOG_EVENT_LENGTH 40
#define | vtkTimerLogMacro(string)

Define Documentation

#define SELECT_MASK fd_set

Definition at line 69 of file vtkTimerLog.h.

#define VTK_LOG_EVENT_LENGTH 40

Definition at line 83 of file vtkTimerLog.h.

#define vtkTimerLogMacro ( string )

Value:

{ \
      vtkTimerLog::FormatAndMarkEvent("Mark: In %s, line %d, class %s: %s", \
                              __FILE__, __LINE__, this->GetClassName(), string); \
  }

Definition at line 194 of file vtkTimerLog.h.

Generated on Mon Mar 25 01:10:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTimeStamp.h File Reference

Common/vtkTimeStamp.h File Reference

#include "vtkWin32Header.h"

Include dependency graph for vtkTimeStamp.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkTimeStamp
record modification and/or execution time. More...

Generated on Mon Mar 25 01:10:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransform.h File Reference

Common/vtkTransform.h File Reference

#include "vtkLinearTransform.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkTransform
describes linear transformations via a 4x4 matrix. More...

Generated on Mon Mar 25 01:10:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformCollection.h File Reference

Common/vtkTransformCollection.h File Reference

#include "vtkCollection.h"
#include "vtkTransform.h"

Include dependency graph for vtkTransformCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkTransformCollection
maintain a list of transforms. More...

Generated on Mon Mar 25 01:10:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangle.h File Reference

Common/vtkTriangle.h File Reference

#include "vtkCell.h"
#include "vtkMath.h"
#include "vtkLine.h"
#include "vtkQuadric.h"

Include dependency graph for vtkTriangle.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkTriangle
a cell that represents a triangle. More...

Generated on Mon Mar 25 01:10:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangleStrip.h File Reference

Common/vtkTriangleStrip.h File Reference

#include "vtkCell.h"
#include "vtkLine.h"
#include "vtkTriangle.h"

Include dependency graph for vtkTriangleStrip.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTriangleStrip
a cell that represents a triangle strip. More...

Generated on Mon Mar 25 01:10:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedCharArray.h File Reference

Common/vtkUnsignedCharArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkUnsignedCharArray.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkUnsignedCharArray
dynamic, self-adjusting unsigned character array. More...

Generated on Mon Mar 25 01:11:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedIntArray.h File Reference

Common/vtkUnsignedIntArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkUnsignedIntArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUnsignedIntArray
dynamic, self-adjusting unsigned int integer array. More...

Generated on Mon Mar 25 01:11:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedLongArray.h File Reference

Common/vtkUnsignedLongArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkUnsignedLongArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUnsignedLongArray
dynamic, self-adjusting unsigned long integer array. More...

Generated on Mon Mar 25 01:11:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedShortArray.h File Reference

Common/vtkUnsignedShortArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkUnsignedShortArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUnsignedShortArray
dynamic, self-adjusting unsigned short integer array. More...

Generated on Mon Mar 25 01:11:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGrid.h File Reference

Common/vtkUnstructuredGrid.h File Reference

#include "vtkPointSet.h"
#include "vtkIdList.h"
#include "vtkCellArray.h"
#include "vtkCellLinks.h"
#include "vtkIntArray.h"
#include "vtkUnsignedCharArray.h"

Include dependency graph for vtkUnstructuredGrid.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGrid
dataset represents arbitrary combinations of all possible cell types. More...

Generated on Mon Mar 25 01:11:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVersion.h File Reference

Common/vtkVersion.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkVersion.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVersion
Versioning class for vtk. More...

Defines

#define | VTK_MAJOR_VERSION 4
#define | VTK_MINOR_VERSION 1
#define | VTK_BUILD_VERSION 1
#define | VTK_VERSION "4.1.1"
#define | VTK_SOURCE_VERSION "vtk version " VTK_VERSION ", vtk source $Revision: 1.1187 $, $Date: 2002/03/25 03:45:02 $ (GMT)"

Define Documentation

#define VTK_MAJOR_VERSION 4

Definition at line 36 of file vtkVersion.h.

#define VTK_MINOR_VERSION 1

Definition at line 37 of file vtkVersion.h.

#define VTK_BUILD_VERSION 1

Definition at line 38 of file vtkVersion.h.

#define VTK_VERSION "4.1.1"

Definition at line 39 of file vtkVersion.h.

#define VTK_SOURCE_VERSION "vtk version " VTK_VERSION ", vtk source $Revision: 1.1187 $, $Date: 2002/03/25 03:45:02 $ (GMT)"

Definition at line 40 of file vtkVersion.h.

Generated on Mon Mar 25 01:11:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVertex.h File Reference

Common/vtkVertex.h File Reference

#include "vtkCell.h"

Include dependency graph for vtkVertex.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVertex
a cell that represents a 3D point. More...

Generated on Mon Mar 25 01:11:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkViewport.h File Reference

Common/vtkViewport.h File Reference

#include "vtkObject.h"
#include "vtkPropCollection.h"
#include "vtkActor2DCollection.h"

Include dependency graph for vtkViewport.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkViewport
abstract specification for Viewports. More...

Generated on Mon Mar 25 01:11:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoidArray.h File Reference

Common/vtkVoidArray.h File Reference

#include "vtkDataArray.h"

Include dependency graph for vtkVoidArray.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVoidArray
dynamic, self-adjusting array of void* pointers. More...

Generated on Mon Mar 25 01:11:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxel.h File Reference

Common/vtkVoxel.h File Reference

#include "vtkCell3D.h"
#include "vtkLine.h"
#include "vtkPixel.h"

Include dependency graph for vtkVoxel.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVoxel
a cell that represents a 3D orthogonal parallelepiped. More...

Generated on Mon Mar 25 01:11:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpTransform.h File Reference

Common/vtkWarpTransform.h File Reference

#include "vtkAbstractTransform.h"

Include dependency graph for vtkWarpTransform.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkWarpTransform
superclass for nonlinear geometric transformations. More...

Generated on Mon Mar 25 01:11:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWedge.h File Reference

Common/vtkWedge.h File Reference

#include "vtkCell3D.h"
#include "vtkLine.h"
#include "vtkTriangle.h"
#include "vtkQuad.h"

Include dependency graph for vtkWedge.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWedge
a 3D cell that represents a wedge. More...

Generated on Mon Mar 25 01:11:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32Header.h File Reference

Common/vtkWin32Header.h File Reference

#include "vtkConfigure.h"

Include dependency graph for vtkWin32Header.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | VTK_COMMON_EXPORT
#define | VTK_FILTERING_EXPORT
#define | VTK_GRAPHICS_EXPORT
#define | VTK_IMAGING_EXPORT
#define | VTK_IO_EXPORT
#define | VTK_RENDERING_EXPORT
#define | VTK_HYBRID_EXPORT
#define | VTK_PARALLEL_EXPORT
#define | VTK_PATENTED_EXPORT
#define | VTK_EXPORT
#define | VTK_TK_EXPORT

Define Documentation

#define VTK_COMMON_EXPORT

Definition at line 124 of file vtkWin32Header.h.

#define VTK_FILTERING_EXPORT

Definition at line 125 of file vtkWin32Header.h.

#define VTK_GRAPHICS_EXPORT

Definition at line 126 of file vtkWin32Header.h.

#define VTK_IMAGING_EXPORT

Definition at line 127 of file vtkWin32Header.h.

#define VTK_IO_EXPORT

Definition at line 128 of file vtkWin32Header.h.

#define VTK_RENDERING_EXPORT

Definition at line 129 of file vtkWin32Header.h.

#define VTK_HYBRID_EXPORT

Definition at line 130 of file vtkWin32Header.h.

#define VTK_PARALLEL_EXPORT

Definition at line 131 of file vtkWin32Header.h.

#define VTK_PATENTED_EXPORT

Definition at line 132 of file vtkWin32Header.h.

#define VTK_EXPORT

Definition at line 133 of file vtkWin32Header.h.

#define VTK_TK_EXPORT

Definition at line 140 of file vtkWin32Header.h.

Generated on Mon Mar 25 01:11:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OutputWindow.h File Reference

Common/vtkWin32OutputWindow.h File Reference

#include "vtkOutputWindow.h"

Include dependency graph for vtkWin32OutputWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32OutputWindow
Win32 Specific output window class. More...

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWinCE.h File Reference

Common/vtkWinCE.h File Reference

Go to the source code of this file.

Compounds

struct | ostream
struct | ofstream
struct | ostrhelp
struct | ostrstream
struct | istream

Defines

#define | VTK_LEAN_AND_MEAN

Variables

char * | endl
ostream cout
ostream cerr
istream cin

Define Documentation

#define VTK_LEAN_AND_MEAN

Definition at line 36 of file vtkWinCE.h.

Variable Documentation

char* endl

Definition at line 105 of file vtkWinCE.h.

ostream cout

Definition at line 106 of file vtkWinCE.h.

ostream cerr

Definition at line 107 of file vtkWinCE.h.

istream cin

Definition at line 108 of file vtkWinCE.h.

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindow.h File Reference

Common/vtkWindow.h File Reference

#include "vtkObject.h"
#include <stdio.h>

Include dependency graph for vtkWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkWindow
window superclass for ImageWindow and RenderWindow. More...

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowLevelLookupTable.h File Reference

Common/vtkWindowLevelLookupTable.h File Reference

#include "vtkObject.h"
#include "vtkLookupTable.h"

Include dependency graph for vtkWindowLevelLookupTable.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWindowLevelLookupTable
map scalar values into colors or colors to scalars; generate color table. More...

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMLFileOutputWindow.h File Reference

Common/vtkXMLFileOutputWindow.h File Reference

#include "vtkFileOutputWindow.h"

Include dependency graph for vtkXMLFileOutputWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXMLFileOutputWindow
XML File Specific output window class. More...

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCardinalSpline.h File Reference

Filtering/vtkCardinalSpline.h File Reference

#include "vtkSpline.h"

Include dependency graph for vtkCardinalSpline.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCardinalSpline
computes an interpolating spline using a. More...

Generated on Mon Mar 25 01:11:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCastToConcrete.h File Reference

Filtering/vtkCastToConcrete.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkCastToConcrete.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCastToConcrete
works around type-checking limitations. More...

Generated on Mon Mar 25 01:11:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellLocator.h File Reference

Filtering/vtkCellLocator.h File Reference

#include "vtkLocator.h"

Include dependency graph for vtkCellLocator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellLocator
octree-based spatial search object to quickly locate cells. More...

Generated on Mon Mar 25 01:11:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkColorTransferFunction.h File Reference

Filtering/vtkColorTransferFunction.h File Reference

#include "vtkScalarsToColors.h"
#include "vtkPiecewiseFunction.h"

Include dependency graph for vtkColorTransferFunction.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkColorTransferFunction
Defines a transfer function for mapping a property to an RGB color value. More...

Defines

#define | VTK_CTF_RGB 0
#define | VTK_CTF_HSV 1

Define Documentation

#define VTK_CTF_RGB 0

Definition at line 50 of file vtkColorTransferFunction.h.

#define VTK_CTF_HSV 1

Definition at line 51 of file vtkColorTransferFunction.h.

Generated on Mon Mar 25 01:11:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCone.h File Reference

Filtering/vtkCone.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkCone.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCone
implicit function for a cone. More...

Generated on Mon Mar 25 01:11:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCylinder.h File Reference

Filtering/vtkCylinder.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkCylinder.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCylinder
implicit function for a cylinder. More...

Generated on Mon Mar 25 01:11:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectSource.h File Reference

Filtering/vtkDataObjectSource.h File Reference

#include "vtkSource.h"

Include dependency graph for vtkDataObjectSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataObjectSource
abstract class specifies interface for. More...

Generated on Mon Mar 25 01:11:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetSource.h File Reference

Filtering/vtkDataSetSource.h File Reference

#include "vtkSource.h"
#include "vtkDataSet.h"

Include dependency graph for vtkDataSetSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetSource
abstract class whose subclasses generate datasets. More...

Generated on Mon Mar 25 01:11:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToDataSetFilter.h File Reference

Filtering/vtkDataSetToDataSetFilter.h File Reference

#include "vtkDataSetSource.h"
#include "vtkDataSet.h"

Include dependency graph for vtkDataSetToDataSetFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToDataSetFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToPolyDataFilter.h File Reference

Filtering/vtkDataSetToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkPolyData.h"

Include dependency graph for vtkDataSetToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToStructuredGridFilter.h File Reference

Filtering/vtkDataSetToStructuredGridFilter.h File Reference

#include "vtkStructuredGridSource.h"

Include dependency graph for vtkDataSetToStructuredGridFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToStructuredGridFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToStructuredPointsFilter.h File Reference

Filtering/vtkDataSetToStructuredPointsFilter.h File Reference

#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkDataSetToStructuredPointsFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToStructuredPointsFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToUnstructuredGridFilter.h File Reference

Filtering/vtkDataSetToUnstructuredGridFilter.h File Reference

#include "vtkUnstructuredGridSource.h"

Include dependency graph for vtkDataSetToUnstructuredGridFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToUnstructuredGridFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageInPlaceFilter.h File Reference

Filtering/vtkImageInPlaceFilter.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageInPlaceFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageInPlaceFilter
Filter that operates in place. More...

Generated on Mon Mar 25 01:11:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMultipleInputFilter.h File Reference

Filtering/vtkImageMultipleInputFilter.h File Reference

#include "vtkImageSource.h"
#include "vtkMultiThreader.h"

Include dependency graph for vtkImageMultipleInputFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageMultipleInputFilter
Generic filter that has N inputs. More...

Generated on Mon Mar 25 01:11:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMultipleInputOutputFilter.h File Reference

Filtering/vtkImageMultipleInputOutputFilter.h File Reference

#include "vtkImageMultipleInputFilter.h"

Include dependency graph for vtkImageMultipleInputOutputFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMultipleInputOutputFilter
Generic filter that has N inputs. More...

Generated on Mon Mar 25 01:11:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSource.h File Reference

Filtering/vtkImageSource.h File Reference

#include "vtkImageData.h"
#include "vtkSource.h"

Include dependency graph for vtkImageSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageSource
Source of data for the imaging pipeline. More...

Generated on Mon Mar 25 01:11:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToImageFilter.h File Reference

Filtering/vtkImageToImageFilter.h File Reference

#include "vtkImageSource.h"
#include "vtkMultiThreader.h"

Include dependency graph for vtkImageToImageFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageToImageFilter
Generic filter that has one input.. More...

Generated on Mon Mar 25 01:11:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToStructuredPoints.h File Reference

Filtering/vtkImageToStructuredPoints.h File Reference

#include "vtkSource.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkImageToStructuredPoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageToStructuredPoints
Attaches image pipeline to VTK. More...

Generated on Mon Mar 25 01:11:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageTwoInputFilter.h File Reference

Filtering/vtkImageTwoInputFilter.h File Reference

#include "vtkImageMultipleInputFilter.h"

Include dependency graph for vtkImageTwoInputFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageTwoInputFilter
Generic superclass for filters that have. More...

Generated on Mon Mar 25 01:11:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitBoolean.h File Reference

Filtering/vtkImplicitBoolean.h File Reference

#include "vtkImplicitFunction.h"
#include "vtkImplicitFunctionCollection.h"

Include dependency graph for vtkImplicitBoolean.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImplicitBoolean
implicit function consisting of boolean combinations of implicit functions. More...

Defines

#define | VTK_UNION 0
#define | VTK_INTERSECTION 1
#define | VTK_DIFFERENCE 2
#define | VTK_UNION_OF_MAGNITUDES 3

Define Documentation

#define VTK_UNION 0

Definition at line 58 of file vtkImplicitBoolean.h.

#define VTK_INTERSECTION 1

Definition at line 59 of file vtkImplicitBoolean.h.

#define VTK_DIFFERENCE 2

Definition at line 60 of file vtkImplicitBoolean.h.

#define VTK_UNION_OF_MAGNITUDES 3

Definition at line 61 of file vtkImplicitBoolean.h.

Generated on Mon Mar 25 01:11:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitDataSet.h File Reference

Filtering/vtkImplicitDataSet.h File Reference

#include "vtkImplicitFunction.h"
#include "vtkDataSet.h"

Include dependency graph for vtkImplicitDataSet.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitDataSet
treat a dataset as if it were an implicit function. More...

Generated on Mon Mar 25 01:11:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitSelectionLoop.h File Reference

Filtering/vtkImplicitSelectionLoop.h File Reference

#include "vtkImplicitFunction.h"
#include "vtkPolygon.h"

Include dependency graph for vtkImplicitSelectionLoop.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitSelectionLoop
implicit function for a selection loop. More...

Generated on Mon Mar 25 01:11:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitSum.h File Reference

Filtering/vtkImplicitSum.h File Reference

#include "vtkImplicitFunctionCollection.h"
#include "vtkFloatArray.h"

Include dependency graph for vtkImplicitSum.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitSum
implicit sum of other implicit functions. More...

Generated on Mon Mar 25 01:11:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitVolume.h File Reference

Filtering/vtkImplicitVolume.h File Reference

#include "vtkImplicitFunction.h"
#include "vtkImageData.h"

Include dependency graph for vtkImplicitVolume.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitVolume
treat a volume as if it were an implicit function. More...

Generated on Mon Mar 25 01:11:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitWindowFunction.h File Reference

Filtering/vtkImplicitWindowFunction.h File Reference

#include <math.h>
#include "vtkImplicitFunction.h"

Include dependency graph for vtkImplicitWindowFunction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitWindowFunction
implicit function maps another implicit function to lie within a specified range. More...

Generated on Mon Mar 25 01:11:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKochanekSpline.h File Reference

Filtering/vtkKochanekSpline.h File Reference

#include <stdio.h>
#include "vtkSpline.h"

Include dependency graph for vtkKochanekSpline.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkKochanekSpline
computes an interpolating spline using a Kochanek basis. More...

Generated on Mon Mar 25 01:11:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergePoints.h File Reference

Filtering/vtkMergePoints.h File Reference

#include "vtkPointLocator.h"

Include dependency graph for vtkMergePoints.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMergePoints
merge exactly coincident points. More...

Generated on Mon Mar 25 01:11:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergePoints2D.h File Reference

Filtering/vtkMergePoints2D.h File Reference

#include "vtkPointLocator2D.h"

Include dependency graph for vtkMergePoints2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMergePoints2D
merge exactly coincident points. More...

Generated on Mon Mar 25 01:11:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPerlinNoise.h File Reference

Filtering/vtkPerlinNoise.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkPerlinNoise.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPerlinNoise
an implicit function that implements Perlin noise. More...

Generated on Mon Mar 25 01:11:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunction.h File Reference

Filtering/vtkPiecewiseFunction.h File Reference

#include "vtkDataObject.h"

Include dependency graph for vtkPiecewiseFunction.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPiecewiseFunction
Defines a 1D piecewise function. More...

Generated on Mon Mar 25 01:11:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionShiftScale.h File Reference

Filtering/vtkPiecewiseFunctionShiftScale.h File Reference

#include "vtkPiecewiseFunctionToPiecewiseFunctionFilter.h"
#include "vtkPiecewiseFunction.h"

Include dependency graph for vtkPiecewiseFunctionShiftScale.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPiecewiseFunctionShiftScale

Generated on Mon Mar 25 01:11:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionSource.h File Reference

Filtering/vtkPiecewiseFunctionSource.h File Reference

#include "vtkSource.h"
#include "vtkPiecewiseFunction.h"

Include dependency graph for vtkPiecewiseFunctionSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPiecewiseFunctionSource
abstract class whose subclasses generate piecewise functions. More...

Generated on Mon Mar 25 01:11:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionToPiecewiseFunctionFilter.h File Reference

Filtering/vtkPiecewiseFunctionToPiecewiseFunctionFilter.h File Reference

#include "vtkPiecewiseFunctionSource.h"
#include "vtkPiecewiseFunction.h"

Include dependency graph for vtkPiecewiseFunctionToPiecewiseFunctionFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPiecewiseFunctionToPiecewiseFunctionFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSetSource.h File Reference

Filtering/vtkPointSetSource.h File Reference

#include "vtkSource.h"
#include "vtkPointSet.h"

Include dependency graph for vtkPointSetSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointSetSource
abstract class whose subclasses generate point data. More...

Generated on Mon Mar 25 01:11:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSetToPointSetFilter.h File Reference

Filtering/vtkPointSetToPointSetFilter.h File Reference

#include "vtkPointSetSource.h"

Include dependency graph for vtkPointSetToPointSetFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPointSetToPointSetFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataCollection.h File Reference

Filtering/vtkPolyDataCollection.h File Reference

#include "vtkCollection.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataCollection
maintain a list of polygonal data objects. More...

Generated on Mon Mar 25 01:11:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataSource.h File Reference

Filtering/vtkPolyDataSource.h File Reference

#include "vtkSource.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataSource
abstract class whose subclasses generate polygonal data. More...

Generated on Mon Mar 25 01:11:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataToPolyDataFilter.h File Reference

Filtering/vtkPolyDataToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridSource.h File Reference

Filtering/vtkRectilinearGridSource.h File Reference

#include "vtkSource.h"
#include "vtkRectilinearGrid.h"

Include dependency graph for vtkRectilinearGridSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridSource
Abstract class whose subclasses generates rectilinear grid data. More...

Generated on Mon Mar 25 01:11:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridToPolyDataFilter.h File Reference

Filtering/vtkRectilinearGridToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkRectilinearGrid.h"

Include dependency graph for vtkRectilinearGridToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarTree.h File Reference

Filtering/vtkScalarTree.h File Reference

#include "vtkObject.h"
#include "vtkDataSet.h"

Include dependency graph for vtkScalarTree.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkScalarTree
organize data according to scalar values (used to accelerate contouring operations). More...

Generated on Mon Mar 25 01:11:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleImageToImageFilter.h File Reference

Filtering/vtkSimpleImageToImageFilter.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkSimpleImageToImageFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkSimpleImageToImageFilter
Generic image filter with one input. More...

Generated on Mon Mar 25 01:11:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleScalarTree.h File Reference

Filtering/vtkSimpleScalarTree.h File Reference

#include "vtkScalarTree.h"

Include dependency graph for vtkSimpleScalarTree.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSimpleScalarTree
organize data according to scalar values (used to accelerate contouring operations). More...

Generated on Mon Mar 25 01:11:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSphere.h File Reference

Filtering/vtkSphere.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkSphere.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSphere
implicit function for a sphere. More...

Generated on Mon Mar 25 01:11:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpline.h File Reference

Filtering/vtkSpline.h File Reference

#include <stdio.h>
#include "vtkObject.h"
#include "vtkPiecewiseFunction.h"

Include dependency graph for vtkSpline.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkSpline
spline abstract class. More...

Generated on Mon Mar 25 01:11:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridSource.h File Reference

Filtering/vtkStructuredGridSource.h File Reference

#include "vtkSource.h"
#include "vtkStructuredGrid.h"

Include dependency graph for vtkStructuredGridSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridSource
Abstract class whose subclasses generates structured grid data. More...

Generated on Mon Mar 25 01:11:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridToPolyDataFilter.h File Reference

Filtering/vtkStructuredGridToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkStructuredGrid.h"

Include dependency graph for vtkStructuredGridToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridToStructuredGridFilter.h File Reference

Filtering/vtkStructuredGridToStructuredGridFilter.h File Reference

#include "vtkStructuredGridSource.h"

Include dependency graph for vtkStructuredGridToStructuredGridFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridToStructuredGridFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsCollection.h File Reference

Filtering/vtkStructuredPointsCollection.h File Reference

#include "vtkCollection.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkStructuredPointsCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsCollection
maintain a list of structured points data objects. More...

Generated on Mon Mar 25 01:11:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsSource.h File Reference

Filtering/vtkStructuredPointsSource.h File Reference

#include "vtkSource.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkStructuredPointsSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsSource
Abstract class whose subclasses generates structured Points data. More...

Generated on Mon Mar 25 01:11:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToPolyDataFilter.h File Reference

Filtering/vtkStructuredPointsToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkImageData.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkStructuredPointsToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToStructuredPointsFilter.h File Reference

Filtering/vtkStructuredPointsToStructuredPointsFilter.h File Reference

#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkStructuredPointsToStructuredPointsFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsToStructuredPointsFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToUnstructuredGridFilter.h File Reference

Filtering/vtkStructuredPointsToUnstructuredGridFilter.h File Reference

#include "vtkStructuredPoints.h"
#include "vtkUnstructuredGridSource.h"

Include dependency graph for vtkStructuredPointsToUnstructuredGridFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsToUnstructuredGridFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSuperquadric.h File Reference

Filtering/vtkSuperquadric.h File Reference

#include "vtkImplicitFunction.h"

Include dependency graph for vtkSuperquadric.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSuperquadric
implicit function for a Superquadric. More...

Defines

#define | VTK_MIN_SUPERQUADRIC_THICKNESS 1e-4

Define Documentation

#define VTK_MIN_SUPERQUADRIC_THICKNESS 1e-4

Definition at line 56 of file vtkSuperquadric.h.

Generated on Mon Mar 25 01:11:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridSource.h File Reference

Filtering/vtkUnstructuredGridSource.h File Reference

#include "vtkSource.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkUnstructuredGridSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGridSource
abstract class whose subclasses generate unstructured grid data. More...

Generated on Mon Mar 25 01:11:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridToPolyDataFilter.h File Reference

Filtering/vtkUnstructuredGridToPolyDataFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkUnstructuredGridToPolyDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGridToPolyDataFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridToUnstructuredGridFilter.h File Reference

Filtering/vtkUnstructuredGridToUnstructuredGridFilter.h File Reference

#include "vtkUnstructuredGridSource.h"

Include dependency graph for vtkUnstructuredGridToUnstructuredGridFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGridToUnstructuredGridFilter
abstract filter class. More...

Generated on Mon Mar 25 01:11:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAppendFilter.h File Reference

Graphics/vtkAppendFilter.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"
#include "vtkDataSetCollection.h"

Include dependency graph for vtkAppendFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAppendFilter
appends one or more datasets together into a single unstructured grid. More...

Generated on Mon Mar 25 01:11:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAppendPolyData.h File Reference

Graphics/vtkAppendPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkAppendPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAppendPolyData
appends one or more polygonal datasets together. More...

Generated on Mon Mar 25 01:11:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkApproximatingSubdivisionFilter.h File Reference

Graphics/vtkApproximatingSubdivisionFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkIntArray.h"
#include "vtkIdList.h"
#include "vtkCellArray.h"

Include dependency graph for vtkApproximatingSubdivisionFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkApproximatingSubdivisionFilter
generate a subdivision surface using an Approximating Scheme. More...

Generated on Mon Mar 25 01:11:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArrayCalculator.h File Reference

Graphics/vtkArrayCalculator.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkArrayCalculator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkArrayCalculator
perform mathematical operations on data in field data arrays. More...

Defines

#define | VTK_ATTRIBUTE_MODE_DEFAULT 0
#define | VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
#define | VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Define Documentation

#define VTK_ATTRIBUTE_MODE_DEFAULT 0

Definition at line 52 of file vtkArrayCalculator.h.

#define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1

Definition at line 53 of file vtkArrayCalculator.h.

#define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Definition at line 54 of file vtkArrayCalculator.h.

Generated on Mon Mar 25 01:11:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArrowSource.h File Reference

Graphics/vtkArrowSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkArrowSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkArrowSource
Appends a cylinder to a cone to form an arrow. More...

Generated on Mon Mar 25 01:11:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssignAttribute.h File Reference

Graphics/vtkAssignAttribute.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkAssignAttribute.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAssignAttribute
Labels a field as an attribute. More...

Generated on Mon Mar 25 01:11:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAttributeDataToFieldDataFilter.h File Reference

Graphics/vtkAttributeDataToFieldDataFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkAttributeDataToFieldDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAttributeDataToFieldDataFilter
map attribute data to field data. More...

Generated on Mon Mar 25 01:11:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAxes.h File Reference

Graphics/vtkAxes.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkAxes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAxes
create an x-y-z axes. More...

Generated on Mon Mar 25 01:11:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBandedPolyDataContourFilter.h File Reference

Graphics/vtkBandedPolyDataContourFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkContourValues.h"

Include dependency graph for vtkBandedPolyDataContourFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkBandedPolyDataContourFilter
generate filled contours for vtkPolyData. More...

Defines

#define | VTK_SCALAR_MODE_INDEX 0
#define | VTK_SCALAR_MODE_VALUE 1

Define Documentation

#define VTK_SCALAR_MODE_INDEX 0

Definition at line 62 of file vtkBandedPolyDataContourFilter.h.

#define VTK_SCALAR_MODE_VALUE 1

Definition at line 63 of file vtkBandedPolyDataContourFilter.h.

Generated on Mon Mar 25 01:11:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBlankStructuredGrid.h File Reference

Graphics/vtkBlankStructuredGrid.h File Reference

#include "vtkStructuredGridToStructuredGridFilter.h"

Include dependency graph for vtkBlankStructuredGrid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBlankStructuredGrid
translate point attribute data into a blanking field. More...

Generated on Mon Mar 25 01:11:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBlankStructuredGridWithImage.h File Reference

Graphics/vtkBlankStructuredGridWithImage.h File Reference

#include "vtkStructuredGridToStructuredGridFilter.h"

Include dependency graph for vtkBlankStructuredGridWithImage.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBlankStructuredGridWithImage
blank a structured grid with an image. More...

Generated on Mon Mar 25 01:11:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBrownianPoints.h File Reference

Graphics/vtkBrownianPoints.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkBrownianPoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBrownianPoints
assign random vector to points. More...

Generated on Mon Mar 25 01:11:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkButterflySubdivisionFilter.h File Reference

Graphics/vtkButterflySubdivisionFilter.h File Reference

#include "vtkInterpolatingSubdivisionFilter.h"
#include "vtkIntArray.h"
#include "vtkIdList.h"
#include "vtkCellArray.h"

Include dependency graph for vtkButterflySubdivisionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkButterflySubdivisionFilter
generate a subdivision surface using the Butterfly Scheme. More...

Generated on Mon Mar 25 01:11:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkButtonSource.h File Reference

Graphics/vtkButtonSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkButtonSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkButtonSource
create a ellipsoidal-shaped button. More...

Defines

#define | VTK_TEXTURE_STYLE_FIT_IMAGE 0
#define | VTK_TEXTURE_STYLE_PROPORTIONAL 1

Define Documentation

#define VTK_TEXTURE_STYLE_FIT_IMAGE 0

Definition at line 54 of file vtkButtonSource.h.

#define VTK_TEXTURE_STYLE_PROPORTIONAL 1

Definition at line 55 of file vtkButtonSource.h.

Generated on Mon Mar 25 01:11:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellCenters.h File Reference

Graphics/vtkCellCenters.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkCellCenters.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCellCenters
generate points at center of cells. More...

Generated on Mon Mar 25 01:11:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellDataToPointData.h File Reference

Graphics/vtkCellDataToPointData.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkCellDataToPointData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellDataToPointData
map cell data to point data. More...

Generated on Mon Mar 25 01:11:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellDerivatives.h File Reference

Graphics/vtkCellDerivatives.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkCellDerivatives.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkCellDerivatives
compute derivatives of scalars and vectors. More...

Defines

#define | VTK_VECTOR_MODE_PASS_VECTORS 0
#define | VTK_VECTOR_MODE_COMPUTE_GRADIENT 1
#define | VTK_VECTOR_MODE_COMPUTE_VORTICITY 2
#define | VTK_TENSOR_MODE_PASS_TENSORS 0
#define | VTK_TENSOR_MODE_COMPUTE_GRADIENT 1
#define | VTK_TENSOR_MODE_COMPUTE_STRAIN 2

Define Documentation

#define VTK_VECTOR_MODE_PASS_VECTORS 0

Definition at line 63 of file vtkCellDerivatives.h.

#define VTK_VECTOR_MODE_COMPUTE_GRADIENT 1

Definition at line 64 of file vtkCellDerivatives.h.

#define VTK_VECTOR_MODE_COMPUTE_VORTICITY 2

Definition at line 65 of file vtkCellDerivatives.h.

#define VTK_TENSOR_MODE_PASS_TENSORS 0

Definition at line 67 of file vtkCellDerivatives.h.

#define VTK_TENSOR_MODE_COMPUTE_GRADIENT 1

Definition at line 68 of file vtkCellDerivatives.h.

#define VTK_TENSOR_MODE_COMPUTE_STRAIN 2

Definition at line 69 of file vtkCellDerivatives.h.

Generated on Mon Mar 25 01:11:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCleanPolyData.h File Reference

Graphics/vtkCleanPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkCleanPolyData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCleanPolyData
merge duplicate points, and/or remove unused points and/or remove degenerate cells. More...

Generated on Mon Mar 25 01:11:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipDataSet.h File Reference

Graphics/vtkClipDataSet.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkClipDataSet.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkClipDataSet
clip any dataset with user-specified implicit function or input scalar data. More...

Generated on Mon Mar 25 01:11:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipPolyData.h File Reference

Graphics/vtkClipPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkClipPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkClipPolyData
clip polygonal data with user-specified implicit function or input scalar data. More...

Generated on Mon Mar 25 01:11:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipVolume.h File Reference

Graphics/vtkClipVolume.h File Reference

#include "vtkStructuredPointsToUnstructuredGridFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkClipVolume.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkClipVolume
clip volume data with user-specified implicit function or input scalar data. More...

Generated on Mon Mar 25 01:11:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkConeSource.h File Reference

Graphics/vtkConeSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkConeSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkConeSource
generate polygonal cone. More...

Generated on Mon Mar 25 01:11:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkConnectivityFilter.h File Reference

Graphics/vtkConnectivityFilter.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"

Include dependency graph for vtkConnectivityFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkConnectivityFilter
extract data based on geometric connectivity. More...

Defines

#define | VTK_EXTRACT_POINT_SEEDED_REGIONS 1
#define | VTK_EXTRACT_CELL_SEEDED_REGIONS 2
#define | VTK_EXTRACT_SPECIFIED_REGIONS 3
#define | VTK_EXTRACT_LARGEST_REGION 4
#define | VTK_EXTRACT_ALL_REGIONS 5
#define | VTK_EXTRACT_CLOSEST_POINT_REGION 6

Define Documentation

#define VTK_EXTRACT_POINT_SEEDED_REGIONS 1

Definition at line 71 of file vtkConnectivityFilter.h.

#define VTK_EXTRACT_CELL_SEEDED_REGIONS 2

Definition at line 72 of file vtkConnectivityFilter.h.

#define VTK_EXTRACT_SPECIFIED_REGIONS 3

Definition at line 73 of file vtkConnectivityFilter.h.

#define VTK_EXTRACT_LARGEST_REGION 4

Definition at line 74 of file vtkConnectivityFilter.h.

#define VTK_EXTRACT_ALL_REGIONS 5

Definition at line 75 of file vtkConnectivityFilter.h.

#define VTK_EXTRACT_CLOSEST_POINT_REGION 6

Definition at line 76 of file vtkConnectivityFilter.h.

Generated on Mon Mar 25 01:11:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourFilter.h File Reference

Graphics/vtkContourFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkContourValues.h"
#include "vtkScalarTree.h"

Include dependency graph for vtkContourFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkContourFilter
generate isosurfaces/isolines from scalar values. More...

Generated on Mon Mar 25 01:11:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourGrid.h File Reference

Graphics/vtkContourGrid.h File Reference

#include "vtkUnstructuredGridToPolyDataFilter.h"
#include "vtkContourValues.h"

Include dependency graph for vtkContourGrid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkContourGrid
generate isosurfaces/isolines from scalar values (specialized for unstructured grids). More...

Generated on Mon Mar 25 01:11:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCubeSource.h File Reference

Graphics/vtkCubeSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkCubeSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCubeSource
create a polygonal representation of a cube. More...

Generated on Mon Mar 25 01:11:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCursor3D.h File Reference

Graphics/vtkCursor3D.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkCursor3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCursor3D
generate a 3D cursor representation. More...

Generated on Mon Mar 25 01:11:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCutter.h File Reference

Graphics/vtkCutter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkContourValues.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkCutter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkCutter
Cut vtkDataSet with user-specified implicit function. More...

Defines

#define | VTK_SORT_BY_VALUE 0
#define | VTK_SORT_BY_CELL 1

Define Documentation

#define VTK_SORT_BY_VALUE 0

Definition at line 65 of file vtkCutter.h.

#define VTK_SORT_BY_CELL 1

Definition at line 66 of file vtkCutter.h.

Generated on Mon Mar 25 01:11:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCylinderSource.h File Reference

Graphics/vtkCylinderSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkCylinderSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCylinderSource
generate a cylinder centered at origin. More...

Generated on Mon Mar 25 01:11:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDashedStreamLine.h File Reference

Graphics/vtkDashedStreamLine.h File Reference

#include "vtkStreamLine.h"

Include dependency graph for vtkDashedStreamLine.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDashedStreamLine
generate constant-time dashed streamline in arbitrary dataset. More...

Generated on Mon Mar 25 01:11:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectToDataSetFilter.h File Reference

Graphics/vtkDataObjectToDataSetFilter.h File Reference

#include "vtkSource.h"
#include "vtkFieldData.h"
#include "vtkDataSet.h"

Include dependency graph for vtkDataObjectToDataSetFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataObjectToDataSetFilter
map field data to concrete dataset. More...

Generated on Mon Mar 25 01:11:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetSurfaceFilter.h File Reference

Graphics/vtkDataSetSurfaceFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkStructuredGrid.h"
#include "vtkImageData.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkDataSetSurfaceFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetSurfaceFilter
Extracts outer (polygonal) surface. More...

Generated on Mon Mar 25 01:11:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToDataObjectFilter.h File Reference

Graphics/vtkDataSetToDataObjectFilter.h File Reference

#include "vtkDataObjectSource.h"
#include "vtkDataSet.h"
#include "vtkCollection.h"

Include dependency graph for vtkDataSetToDataObjectFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetToDataObjectFilter
map dataset into data object (i.e., a field). More...

Generated on Mon Mar 25 01:11:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetTriangleFilter.h File Reference

Graphics/vtkDataSetTriangleFilter.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"

Include dependency graph for vtkDataSetTriangleFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetTriangleFilter
triangulate any type of dataset. More...

Generated on Mon Mar 25 01:11:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDecimatePro.h File Reference

Graphics/vtkDecimatePro.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkPriorityQueue.h"

Include dependency graph for vtkDecimatePro.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | _vtkProLocalVertex
struct | _vtkProLocalTri
class | vtkProVertexArray
class | vtkProTriArray
class | vtkDecimatePro
reduce the number of triangles in a mesh. More...

Typedefs

typedef _vtkProLocalVertex | vtkProLocalVertex
typedef _vtkProLocalVertex * | vtkProLocalVertexPtr
typedef _vtkProLocalTri | vtkProLocalTri
typedef _vtkProLocalTri * | vtkProLocalTriPtr

Typedef Documentation

typedef struct _vtkProLocalVertex vtkProLocalVertex

typedef struct _vtkProLocalVertex * vtkProLocalVertexPtr

typedef struct _vtkProLocalTri vtkProLocalTri

typedef struct _vtkProLocalTri * vtkProLocalTriPtr

Generated on Mon Mar 25 01:11:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDelaunay2D.h File Reference

Graphics/vtkDelaunay2D.h File Reference

#include "vtkPointSet.h"
#include "vtkPolyDataSource.h"
#include "vtkAbstractTransform.h"

Include dependency graph for vtkDelaunay2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDelaunay2D
create 2D Delaunay triangulation of input points. More...

Generated on Mon Mar 25 01:11:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDelaunay3D.h File Reference

Graphics/vtkDelaunay3D.h File Reference

#include "vtkUnstructuredGridSource.h"

Include dependency graph for vtkDelaunay3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDelaunay3D
create 3D Delaunay triangulation of input points. More...

Generated on Mon Mar 25 01:11:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDicer.h File Reference

Graphics/vtkDicer.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkDicer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkDicer
abstract superclass to divide dataset into pieces. More...

Defines

#define | VTK_DICE_MODE_NUMBER_OF_POINTS 0
#define | VTK_DICE_MODE_SPECIFIED_NUMBER 1
#define | VTK_DICE_MODE_MEMORY_LIMIT 2

Define Documentation

#define VTK_DICE_MODE_NUMBER_OF_POINTS 0

Definition at line 58 of file vtkDicer.h.

#define VTK_DICE_MODE_SPECIFIED_NUMBER 1

Definition at line 59 of file vtkDicer.h.

#define VTK_DICE_MODE_MEMORY_LIMIT 2

Definition at line 60 of file vtkDicer.h.

Generated on Mon Mar 25 01:11:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDiskSource.h File Reference

Graphics/vtkDiskSource.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkPolyData.h"

Include dependency graph for vtkDiskSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDiskSource
create a disk with hole in center. More...

Generated on Mon Mar 25 01:11:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEdgePoints.h File Reference

Graphics/vtkEdgePoints.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkMergePoints.h"

Include dependency graph for vtkEdgePoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEdgePoints
generate points on isosurface. More...

Generated on Mon Mar 25 01:11:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkElevationFilter.h File Reference

Graphics/vtkElevationFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkElevationFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkElevationFilter
generate scalars along a specified direction. More...

Generated on Mon Mar 25 01:11:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractEdges.h File Reference

Graphics/vtkExtractEdges.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkExtractEdges.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractEdges
extract cell edges from any type of data. More...

Generated on Mon Mar 25 01:11:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractGeometry.h File Reference

Graphics/vtkExtractGeometry.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkExtractGeometry.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractGeometry
extract cells that lie either entirely inside or outside of a specified implicit function. More...

Generated on Mon Mar 25 01:12:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractGrid.h File Reference

Graphics/vtkExtractGrid.h File Reference

#include "vtkStructuredGridToStructuredGridFilter.h"

Include dependency graph for vtkExtractGrid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractGrid
select piece (e.g., volume of interest) and/or subsample structured grid dataset. More...

Generated on Mon Mar 25 01:12:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractPolyDataGeometry.h File Reference

Graphics/vtkExtractPolyDataGeometry.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkExtractPolyDataGeometry.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractPolyDataGeometry
extract vtkPolyData cells that lies either entirely inside or outside of a specified implicit function. More...

Generated on Mon Mar 25 01:12:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractTensorComponents.h File Reference

Graphics/vtkExtractTensorComponents.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkExtractTensorComponents.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkExtractTensorComponents
extract parts of tensor and create a scalar, vector, normal, or texture coordinates. More...

Defines

#define | VTK_EXTRACT_COMPONENT 0
#define | VTK_EXTRACT_EFFECTIVE_STRESS 1
#define | VTK_EXTRACT_DETERMINANT 2

Define Documentation

#define VTK_EXTRACT_COMPONENT 0

Definition at line 62 of file vtkExtractTensorComponents.h.

#define VTK_EXTRACT_EFFECTIVE_STRESS 1

Definition at line 63 of file vtkExtractTensorComponents.h.

#define VTK_EXTRACT_DETERMINANT 2

Definition at line 64 of file vtkExtractTensorComponents.h.

Generated on Mon Mar 25 01:12:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractUnstructuredGrid.h File Reference

Graphics/vtkExtractUnstructuredGrid.h File Reference

#include "vtkUnstructuredGridToUnstructuredGridFilter.h"

Include dependency graph for vtkExtractUnstructuredGrid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractUnstructuredGrid
extract subset of unstructured grid geometry. More...

Generated on Mon Mar 25 01:12:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractVectorComponents.h File Reference

Graphics/vtkExtractVectorComponents.h File Reference

#include "vtkSource.h"
#include "vtkDataSet.h"

Include dependency graph for vtkExtractVectorComponents.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractVectorComponents
extract components of vector as separate scalars. More...

Generated on Mon Mar 25 01:12:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFeatureEdges.h File Reference

Graphics/vtkFeatureEdges.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkFeatureEdges.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkFeatureEdges
extract boundary, non-manifold, and/or sharp edges from polygonal data. More...

Generated on Mon Mar 25 01:12:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldDataToAttributeDataFilter.h File Reference

Graphics/vtkFieldDataToAttributeDataFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkFieldDataToAttributeDataFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkFieldDataToAttributeDataFilter
map field data to dataset attribute data. More...

Defines

#define | VTK_DATA_OBJECT_FIELD 0
#define | VTK_POINT_DATA_FIELD 1
#define | VTK_CELL_DATA_FIELD 2
#define | VTK_CELL_DATA 0
#define | VTK_POINT_DATA 1

Define Documentation

#define VTK_DATA_OBJECT_FIELD 0

Definition at line 75 of file vtkFieldDataToAttributeDataFilter.h.

#define VTK_POINT_DATA_FIELD 1

Definition at line 76 of file vtkFieldDataToAttributeDataFilter.h.

#define VTK_CELL_DATA_FIELD 2

Definition at line 77 of file vtkFieldDataToAttributeDataFilter.h.

#define VTK_CELL_DATA 0

Definition at line 79 of file vtkFieldDataToAttributeDataFilter.h.

#define VTK_POINT_DATA 1

Definition at line 80 of file vtkFieldDataToAttributeDataFilter.h.

Generated on Mon Mar 25 01:12:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGeometryFilter.h File Reference

Graphics/vtkGeometryFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkGeometryFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGeometryFilter
extract geometry from data (or convert data to polygonal type). More...

Generated on Mon Mar 25 01:12:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyph2D.h File Reference

Graphics/vtkGlyph2D.h File Reference

#include "vtkGlyph3D.h"

Include dependency graph for vtkGlyph2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGlyph2D
copy oriented and scaled glyph geometry to every input point (2D specialization). More...

Generated on Mon Mar 25 01:12:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyph3D.h File Reference

Graphics/vtkGlyph3D.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkGlyph3D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkGlyph3D
copy oriented and scaled glyph geometry to every input point. More...

Defines

#define | VTK_SCALE_BY_SCALAR 0
#define | VTK_SCALE_BY_VECTOR 1
#define | VTK_SCALE_BY_VECTORCOMPONENTS 2
#define | VTK_DATA_SCALING_OFF 3
#define | VTK_COLOR_BY_SCALE 0
#define | VTK_COLOR_BY_SCALAR 1
#define | VTK_COLOR_BY_VECTOR 2
#define | VTK_USE_VECTOR 0
#define | VTK_USE_NORMAL 1
#define | VTK_VECTOR_ROTATION_OFF 2
#define | VTK_INDEXING_OFF 0
#define | VTK_INDEXING_BY_SCALAR 1
#define | VTK_INDEXING_BY_VECTOR 2

Define Documentation

#define VTK_SCALE_BY_SCALAR 0

Definition at line 97 of file vtkGlyph3D.h.

#define VTK_SCALE_BY_VECTOR 1

Definition at line 98 of file vtkGlyph3D.h.

#define VTK_SCALE_BY_VECTORCOMPONENTS 2

Definition at line 99 of file vtkGlyph3D.h.

#define VTK_DATA_SCALING_OFF 3

Definition at line 100 of file vtkGlyph3D.h.

#define VTK_COLOR_BY_SCALE 0

Definition at line 102 of file vtkGlyph3D.h.

#define VTK_COLOR_BY_SCALAR 1

Definition at line 103 of file vtkGlyph3D.h.

#define VTK_COLOR_BY_VECTOR 2

Definition at line 104 of file vtkGlyph3D.h.

#define VTK_USE_VECTOR 0

Definition at line 106 of file vtkGlyph3D.h.

#define VTK_USE_NORMAL 1

Definition at line 107 of file vtkGlyph3D.h.

#define VTK_VECTOR_ROTATION_OFF 2

Definition at line 108 of file vtkGlyph3D.h.

#define VTK_INDEXING_OFF 0

Definition at line 110 of file vtkGlyph3D.h.

#define VTK_INDEXING_BY_SCALAR 1

Definition at line 111 of file vtkGlyph3D.h.

#define VTK_INDEXING_BY_VECTOR 2

Definition at line 112 of file vtkGlyph3D.h.

Generated on Mon Mar 25 01:12:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyphSource2D.h File Reference

Graphics/vtkGlyphSource2D.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkGlyphSource2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkGlyphSource2D
create 2D glyphs represented by vtkPolyData. More...

Defines

#define | VTK_NO_GLYPH 0
#define | VTK_VERTEX_GLYPH 1
#define | VTK_DASH_GLYPH 2
#define | VTK_CROSS_GLYPH 3
#define | VTK_THICKCROSS_GLYPH 4
#define | VTK_TRIANGLE_GLYPH 5
#define | VTK_SQUARE_GLYPH 6
#define | VTK_CIRCLE_GLYPH 7
#define | VTK_DIAMOND_GLYPH 8
#define | VTK_ARROW_GLYPH 9
#define | VTK_THICKARROW_GLYPH 10
#define | VTK_HOOKEDARROW_GLYPH 11

Define Documentation

#define VTK_NO_GLYPH 0

Definition at line 50 of file vtkGlyphSource2D.h.

#define VTK_VERTEX_GLYPH 1

Definition at line 51 of file vtkGlyphSource2D.h.

#define VTK_DASH_GLYPH 2

Definition at line 52 of file vtkGlyphSource2D.h.

#define VTK_CROSS_GLYPH 3

Definition at line 53 of file vtkGlyphSource2D.h.

#define VTK_THICKCROSS_GLYPH 4

Definition at line 54 of file vtkGlyphSource2D.h.

#define VTK_TRIANGLE_GLYPH 5

Definition at line 55 of file vtkGlyphSource2D.h.

#define VTK_SQUARE_GLYPH 6

Definition at line 56 of file vtkGlyphSource2D.h.

#define VTK_CIRCLE_GLYPH 7

Definition at line 57 of file vtkGlyphSource2D.h.

#define VTK_DIAMOND_GLYPH 8

Definition at line 58 of file vtkGlyphSource2D.h.

#define VTK_ARROW_GLYPH 9

Definition at line 59 of file vtkGlyphSource2D.h.

#define VTK_THICKARROW_GLYPH 10

Definition at line 60 of file vtkGlyphSource2D.h.

#define VTK_HOOKEDARROW_GLYPH 11

Definition at line 61 of file vtkGlyphSource2D.h.

Generated on Mon Mar 25 01:12:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGraphLayoutFilter.h File Reference

Graphics/vtkGraphLayoutFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkGraphLayoutFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGraphLayoutFilter
nice layout of undirected graphs in 3D. More...

Generated on Mon Mar 25 01:12:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHedgeHog.h File Reference

Graphics/vtkHedgeHog.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkHedgeHog.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkHedgeHog
create oriented lines from vector data. More...

Defines

#define | VTK_USE_VECTOR 0
#define | VTK_USE_NORMAL 1

Define Documentation

#define VTK_USE_VECTOR 0

Definition at line 48 of file vtkHedgeHog.h.

#define VTK_USE_NORMAL 1

Definition at line 49 of file vtkHedgeHog.h.

Generated on Mon Mar 25 01:12:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHull.h File Reference

Graphics/vtkHull.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkHull.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkHull
produce an n-sided convex hull. More...

Generated on Mon Mar 25 01:12:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHyperStreamline.h File Reference

Graphics/vtkHyperStreamline.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkHyperStreamline.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkHyperStreamline
generate hyperstreamline in arbitrary dataset. More...

Defines

#define | VTK_INTEGRATE_FORWARD 0
#define | VTK_INTEGRATE_BACKWARD 1
#define | VTK_INTEGRATE_BOTH_DIRECTIONS 2

Define Documentation

#define VTK_INTEGRATE_FORWARD 0

Definition at line 67 of file vtkHyperStreamline.h.

#define VTK_INTEGRATE_BACKWARD 1

Definition at line 68 of file vtkHyperStreamline.h.

#define VTK_INTEGRATE_BOTH_DIRECTIONS 2

Definition at line 69 of file vtkHyperStreamline.h.

Generated on Mon Mar 25 01:12:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdFilter.h File Reference

Graphics/vtkIdFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkIdFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkIdFilter
generate scalars or field data from point and cell ids. More...

Generated on Mon Mar 25 01:12:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDataGeometryFilter.h File Reference

Graphics/vtkImageDataGeometryFilter.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"

Include dependency graph for vtkImageDataGeometryFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageDataGeometryFilter
extract geometry for structured points. More...

Generated on Mon Mar 25 01:12:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitTextureCoords.h File Reference

Graphics/vtkImplicitTextureCoords.h File Reference

#include "vtkDataSetToDataSetFilter.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkImplicitTextureCoords.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitTextureCoords
generate 1D, 2D, or 3D texture coordinates based on implicit function(s). More...

Generated on Mon Mar 25 01:12:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolateDataSetAttributes.h File Reference

Graphics/vtkInterpolateDataSetAttributes.h File Reference

#include "vtkDataSetToDataSetFilter.h"
#include "vtkDataSetCollection.h"

Include dependency graph for vtkInterpolateDataSetAttributes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkInterpolateDataSetAttributes
interpolate scalars, vectors, etc. and other dataset attributes. More...

Generated on Mon Mar 25 01:12:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolatingSubdivisionFilter.h File Reference

Graphics/vtkInterpolatingSubdivisionFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkInterpolatingSubdivisionFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkInterpolatingSubdivisionFilter
generate a subdivision surface using an Interpolating Scheme. More...

Generated on Mon Mar 25 01:12:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearExtrusionFilter.h File Reference

Graphics/vtkLinearExtrusionFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkLinearExtrusionFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkLinearExtrusionFilter
sweep polygonal data creating a "skirt" from free edges and lines, and lines from vertices. More...

Defines

#define | VTK_VECTOR_EXTRUSION 1
#define | VTK_NORMAL_EXTRUSION 2
#define | VTK_POINT_EXTRUSION 3

Define Documentation

#define VTK_VECTOR_EXTRUSION 1

Definition at line 70 of file vtkLinearExtrusionFilter.h.

#define VTK_NORMAL_EXTRUSION 2

Definition at line 71 of file vtkLinearExtrusionFilter.h.

#define VTK_POINT_EXTRUSION 3

Definition at line 72 of file vtkLinearExtrusionFilter.h.

Generated on Mon Mar 25 01:12:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearSubdivisionFilter.h File Reference

Graphics/vtkLinearSubdivisionFilter.h File Reference

#include "vtkInterpolatingSubdivisionFilter.h"
#include "vtkIntArray.h"

Include dependency graph for vtkLinearSubdivisionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLinearSubdivisionFilter
generate a subdivision surface using the Linear Scheme. More...

Generated on Mon Mar 25 01:12:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLineSource.h File Reference

Graphics/vtkLineSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkLineSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLineSource
create a line defined by two end points. More...

Generated on Mon Mar 25 01:12:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinkEdgels.h File Reference

Graphics/vtkLinkEdgels.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"

Include dependency graph for vtkLinkEdgels.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLinkEdgels
links edgels together to form digital curves. More...

Generated on Mon Mar 25 01:12:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLoopSubdivisionFilter.h File Reference

Graphics/vtkLoopSubdivisionFilter.h File Reference

#include "vtkApproximatingSubdivisionFilter.h"
#include "vtkIntArray.h"
#include "vtkIdList.h"
#include "vtkCellArray.h"

Include dependency graph for vtkLoopSubdivisionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLoopSubdivisionFilter
generate a subdivision surface using the Loop Scheme. More...

Generated on Mon Mar 25 01:12:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskFields.h File Reference

Graphics/vtkMaskFields.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkMaskFields.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkMaskFields
Allow control of which fields get passed. More...

struct | vtkMaskFields::CopyFieldFlag

Generated on Mon Mar 25 01:12:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskPoints.h File Reference

Graphics/vtkMaskPoints.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkMaskPoints.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMaskPoints
selectively filter points. More...

Generated on Mon Mar 25 01:12:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskPolyData.h File Reference

Graphics/vtkMaskPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkMaskPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMaskPolyData
sample subset of input polygonal data. More...

Generated on Mon Mar 25 01:12:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMassProperties.h File Reference

Graphics/vtkMassProperties.h File Reference

#include "vtkProcessObject.h"
#include "vtkPolyData.h"

Include dependency graph for vtkMassProperties.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMassProperties
estimate volume, area, shape index of triangle mesh. More...

Generated on Mon Mar 25 01:12:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeDataObjectFilter.h File Reference

Graphics/vtkMergeDataObjectFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"
#include "vtkFieldDataToAttributeDataFilter.h"

Include dependency graph for vtkMergeDataObjectFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMergeDataObjectFilter
merge dataset and data object field to create dataset with attribute data. More...

Generated on Mon Mar 25 01:12:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeFields.h File Reference

Graphics/vtkMergeFields.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkMergeFields.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkMergeFields
Merge multiple fields into one. More...

struct | vtkMergeFields::Component

Generated on Mon Mar 25 01:12:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeFilter.h File Reference

Graphics/vtkMergeFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkMergeFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMergeFilter
extract separate components of data from different datasets. More...

Generated on Mon Mar 25 01:12:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBBDicer.h File Reference

Graphics/vtkOBBDicer.h File Reference

#include "vtkDicer.h"
#include "vtkOBBTree.h"

Include dependency graph for vtkOBBDicer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOBBDicer
divide dataset into spatially aggregated pieces. More...

Generated on Mon Mar 25 01:12:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBBTree.h File Reference

Graphics/vtkOBBTree.h File Reference

#include "vtkCellLocator.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkOBBTree.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkOBBNode
class | vtkOBBTree
generate oriented bounding box (OBB) tree. More...

Generated on Mon Mar 25 01:12:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineCornerFilter.h File Reference

Graphics/vtkOutlineCornerFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkOutlineCornerFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOutlineCornerFilter
create wireframe outline corners for arbitrary data set. More...

Generated on Mon Mar 25 01:12:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineCornerSource.h File Reference

Graphics/vtkOutlineCornerSource.h File Reference

#include "vtkOutlineSource.h"

Include dependency graph for vtkOutlineCornerSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOutlineCornerSource
create wireframe outline corners around bounding box. More...

Generated on Mon Mar 25 01:12:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineFilter.h File Reference

Graphics/vtkOutlineFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkOutlineFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkOutlineFilter
create wireframe outline for arbitrary data set. More...

Generated on Mon Mar 25 01:12:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineSource.h File Reference

Graphics/vtkOutlineSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkOutlineSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkOutlineSource
create wireframe outline around bounding box. More...

Generated on Mon Mar 25 01:12:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlaneSource.h File Reference

Graphics/vtkPlaneSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkPlaneSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPlaneSource
create an array of quadrilaterals located in a plane. More...

Generated on Mon Mar 25 01:12:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointDataToCellData.h File Reference

Graphics/vtkPointDataToCellData.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkPointDataToCellData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPointDataToCellData
map point data to cell data. More...

Generated on Mon Mar 25 01:12:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSource.h File Reference

Graphics/vtkPointSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkPointSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkPointSource
create a random cloud of points. More...

Defines

#define | VTK_POINT_UNIFORM 1
#define | VTK_POINT_SHELL 0

Define Documentation

#define VTK_POINT_UNIFORM 1

Definition at line 47 of file vtkPointSource.h.

#define VTK_POINT_SHELL 0

Definition at line 48 of file vtkPointSource.h.

Generated on Mon Mar 25 01:12:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataConnectivityFilter.h File Reference

Graphics/vtkPolyDataConnectivityFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkPolyDataConnectivityFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkPolyDataConnectivityFilter
extract polygonal data based on geometric connectivity. More...

Defines

#define | VTK_EXTRACT_POINT_SEEDED_REGIONS 1
#define | VTK_EXTRACT_CELL_SEEDED_REGIONS 2
#define | VTK_EXTRACT_SPECIFIED_REGIONS 3
#define | VTK_EXTRACT_LARGEST_REGION 4
#define | VTK_EXTRACT_ALL_REGIONS 5
#define | VTK_EXTRACT_CLOSEST_POINT_REGION 6

Define Documentation

#define VTK_EXTRACT_POINT_SEEDED_REGIONS 1

Definition at line 63 of file vtkPolyDataConnectivityFilter.h.

#define VTK_EXTRACT_CELL_SEEDED_REGIONS 2

Definition at line 64 of file vtkPolyDataConnectivityFilter.h.

#define VTK_EXTRACT_SPECIFIED_REGIONS 3

Definition at line 65 of file vtkPolyDataConnectivityFilter.h.

#define VTK_EXTRACT_LARGEST_REGION 4

Definition at line 66 of file vtkPolyDataConnectivityFilter.h.

#define VTK_EXTRACT_ALL_REGIONS 5

Definition at line 67 of file vtkPolyDataConnectivityFilter.h.

#define VTK_EXTRACT_CLOSEST_POINT_REGION 6

Definition at line 68 of file vtkPolyDataConnectivityFilter.h.

Generated on Mon Mar 25 01:12:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataNormals.h File Reference

Graphics/vtkPolyDataNormals.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkPolyDataNormals.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataNormals
compute normals for polygonal mesh. More...

Generated on Mon Mar 25 01:12:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataStreamer.h File Reference

Graphics/vtkPolyDataStreamer.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkPolyDataStreamer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataStreamer
Stream appends input pieces to the output. More...

Generated on Mon Mar 25 01:12:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProbeFilter.h File Reference

Graphics/vtkProbeFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"
#include "vtkIdTypeArray.h"

Include dependency graph for vtkProbeFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProbeFilter
sample data values at specified point locations. More...

Generated on Mon Mar 25 01:12:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableAttributeDataFilter.h File Reference

Graphics/vtkProgrammableAttributeDataFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"
#include "vtkDataSetCollection.h"

Include dependency graph for vtkProgrammableAttributeDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProgrammableAttributeDataFilter
manipulate attribute (cell and point) data via a user-specified function. More...

Generated on Mon Mar 25 01:12:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableDataObjectSource.h File Reference

Graphics/vtkProgrammableDataObjectSource.h File Reference

#include "vtkSource.h"

Include dependency graph for vtkProgrammableDataObjectSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProgrammableDataObjectSource
generate source data object via a user-specified function. More...

Generated on Mon Mar 25 01:12:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableFilter.h File Reference

Graphics/vtkProgrammableFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkProgrammableFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProgrammableFilter
a user-programmable filter. More...

Generated on Mon Mar 25 01:12:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableGlyphFilter.h File Reference

Graphics/vtkProgrammableGlyphFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkProgrammableGlyphFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkProgrammableGlyphFilter
control the generation and placement of glyphs at input points. More...

Defines

#define | VTK_COLOR_BY_INPUT 0
#define | VTK_COLOR_BY_SOURCE 1

Define Documentation

#define VTK_COLOR_BY_INPUT 0

Definition at line 78 of file vtkProgrammableGlyphFilter.h.

#define VTK_COLOR_BY_SOURCE 1

Definition at line 79 of file vtkProgrammableGlyphFilter.h.

Generated on Mon Mar 25 01:12:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableSource.h File Reference

Graphics/vtkProgrammableSource.h File Reference

#include "vtkSource.h"

Include dependency graph for vtkProgrammableSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProgrammableSource
generate source dataset via a user-specified function. More...

Generated on Mon Mar 25 01:12:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProjectedTexture.h File Reference

Graphics/vtkProjectedTexture.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkProjectedTexture.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProjectedTexture
assign texture coordinates for a projected texture. More...

Generated on Mon Mar 25 01:12:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadricClustering.h File Reference

Graphics/vtkQuadricClustering.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkDataSetCollection.h"

Include dependency graph for vtkQuadricClustering.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | VTK_POINT_QUADRIC
class | vtkQuadricClustering
reduce the number of triangles in a mesh. More...

Generated on Mon Mar 25 01:12:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadricDecimation.h File Reference

Graphics/vtkQuadricDecimation.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkEdgeTable.h"
#include "vtkPriorityQueue.h"
#include "vtkIdList.h"

Include dependency graph for vtkQuadricDecimation.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | VTK_ERROR_QUADRIC
class | vtkQuadricDecimation
reduce the number of triangles in a mesh. More...

Generated on Mon Mar 25 01:12:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuantizePolyDataPoints.h File Reference

Graphics/vtkQuantizePolyDataPoints.h File Reference

#include "vtkCleanPolyData.h"

Include dependency graph for vtkQuantizePolyDataPoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuantizePolyDataPoints
quantizes x,y,z coordinates of points. More...

Generated on Mon Mar 25 01:12:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRearrangeFields.h File Reference

Graphics/vtkRearrangeFields.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkRearrangeFields.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkRearrangeFields
Move/copy fields between field data, point data and cell data. More...

struct | vtkRearrangeFields::Operation

Generated on Mon Mar 25 01:12:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridGeometryFilter.h File Reference

Graphics/vtkRectilinearGridGeometryFilter.h File Reference

#include "vtkRectilinearGridToPolyDataFilter.h"

Include dependency graph for vtkRectilinearGridGeometryFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridGeometryFilter
extract geometry for a rectilinear grid. More...

Generated on Mon Mar 25 01:12:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRecursiveDividingCubes.h File Reference

Graphics/vtkRecursiveDividingCubes.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"

Include dependency graph for vtkRecursiveDividingCubes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRecursiveDividingCubes
create points lying on isosurface (using recursive approach). More...

Generated on Mon Mar 25 01:12:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReflectionFilter.h File Reference

Graphics/vtkReflectionFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkReflectionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkReflectionFilter
reflects a data set across a plane. More...

Defines

#define | VTK_USE_X_MIN 0
#define | VTK_USE_Y_MIN 1
#define | VTK_USE_Z_MIN 2
#define | VTK_USE_X_MAX 3
#define | VTK_USE_Y_MAX 4
#define | VTK_USE_Z_MAX 5

Define Documentation

#define VTK_USE_X_MIN 0

Definition at line 40 of file vtkReflectionFilter.h.

#define VTK_USE_Y_MIN 1

Definition at line 41 of file vtkReflectionFilter.h.

#define VTK_USE_Z_MIN 2

Definition at line 42 of file vtkReflectionFilter.h.

#define VTK_USE_X_MAX 3

Definition at line 43 of file vtkReflectionFilter.h.

#define VTK_USE_Y_MAX 4

Definition at line 44 of file vtkReflectionFilter.h.

#define VTK_USE_Z_MAX 5

Definition at line 45 of file vtkReflectionFilter.h.

Generated on Mon Mar 25 01:12:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReverseSense.h File Reference

Graphics/vtkReverseSense.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkReverseSense.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkReverseSense
reverse the ordering of polygonal cells and/or vertex normals. More...

Generated on Mon Mar 25 01:12:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRibbonFilter.h File Reference

Graphics/vtkRibbonFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkRibbonFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRibbonFilter
create oriented ribbons from lines defined in polygonal dataset. More...

Generated on Mon Mar 25 01:12:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRotationalExtrusionFilter.h File Reference

Graphics/vtkRotationalExtrusionFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkRotationalExtrusionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRotationalExtrusionFilter
sweep polygonal data creating "skirt" from free edges and lines, and lines from vertices. More...

Generated on Mon Mar 25 01:12:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRuledSurfaceFilter.h File Reference

Graphics/vtkRuledSurfaceFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkRuledSurfaceFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkRuledSurfaceFilter
generates a surface from a set of lines. More...

Defines

#define | VTK_RULED_MODE_RESAMPLE 0
#define | VTK_RULED_MODE_POINT_WALK 1

Define Documentation

#define VTK_RULED_MODE_RESAMPLE 0

Definition at line 74 of file vtkRuledSurfaceFilter.h.

#define VTK_RULED_MODE_POINT_WALK 1

Definition at line 75 of file vtkRuledSurfaceFilter.h.

Generated on Mon Mar 25 01:12:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSelectPolyData.h File Reference

Graphics/vtkSelectPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkSelectPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSelectPolyData
select portion of polygonal mesh; generate selection scalars. More...

Defines

#define | VTK_INSIDE_SMALLEST_REGION 0
#define | VTK_INSIDE_LARGEST_REGION 1
#define | VTK_INSIDE_CLOSEST_POINT_REGION 2

Define Documentation

#define VTK_INSIDE_SMALLEST_REGION 0

Definition at line 97 of file vtkSelectPolyData.h.

#define VTK_INSIDE_LARGEST_REGION 1

Definition at line 98 of file vtkSelectPolyData.h.

#define VTK_INSIDE_CLOSEST_POINT_REGION 2

Definition at line 99 of file vtkSelectPolyData.h.

Generated on Mon Mar 25 01:12:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShrinkFilter.h File Reference

Graphics/vtkShrinkFilter.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"

Include dependency graph for vtkShrinkFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkShrinkFilter
shrink cells composing an arbitrary data set. More...

Generated on Mon Mar 25 01:12:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShrinkPolyData.h File Reference

Graphics/vtkShrinkPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkShrinkPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkShrinkPolyData
shrink cells composing PolyData. More...

Generated on Mon Mar 25 01:12:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleElevationFilter.h File Reference

Graphics/vtkSimpleElevationFilter.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkSimpleElevationFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSimpleElevationFilter
generate scalars along a specified direction. More...

Generated on Mon Mar 25 01:12:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSmoothPolyDataFilter.h File Reference

Graphics/vtkSmoothPolyDataFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkSmoothPolyDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSmoothPolyDataFilter

Generated on Mon Mar 25 01:12:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpatialRepresentationFilter.h File Reference

Graphics/vtkSpatialRepresentationFilter.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkLocator.h"

Include dependency graph for vtkSpatialRepresentationFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSpatialRepresentationFilter
generate polygonal model of spatial search object (i.e., a vtkLocator). More...

Defines

#define | VTK_MAX_SPATIAL_REP_LEVEL 24

Define Documentation

#define VTK_MAX_SPATIAL_REP_LEVEL 24

Definition at line 77 of file vtkSpatialRepresentationFilter.h.

Generated on Mon Mar 25 01:12:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpherePuzzle.h File Reference

Graphics/vtkSpherePuzzle.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkTransform.h"

Include dependency graph for vtkSpherePuzzle.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkSpherePuzzle
create a polygonal sphere centered at the origin. More...

Defines

#define | VTK_MAX_SPHERE_RESOLUTION 1024

Define Documentation

#define VTK_MAX_SPHERE_RESOLUTION 1024

Definition at line 43 of file vtkSpherePuzzle.h.

Generated on Mon Mar 25 01:12:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpherePuzzleArrows.h File Reference

Graphics/vtkSpherePuzzleArrows.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkSpherePuzzle.h"

Include dependency graph for vtkSpherePuzzleArrows.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSpherePuzzleArrows
Visualize permutation of the sphere puzzle. More...

Generated on Mon Mar 25 01:12:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSphereSource.h File Reference

Graphics/vtkSphereSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkSphereSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkSphereSource
create a polygonal sphere centered at the origin. More...

Defines

#define | VTK_MAX_SPHERE_RESOLUTION 1024

Define Documentation

#define VTK_MAX_SPHERE_RESOLUTION 1024

Definition at line 55 of file vtkSphereSource.h.

Generated on Mon Mar 25 01:12:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSplitField.h File Reference

Graphics/vtkSplitField.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkSplitField.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSplitField
Split a field into single component fields. More...

struct | vtkSplitField::Component

Generated on Mon Mar 25 01:12:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamer.h File Reference

Graphics/vtkStreamer.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkInitialValueProblemSolver.h"
#include "vtkMultiThreader.h"

Include dependency graph for vtkStreamer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | _vtkStreamPoint
class | vtkStreamArray
class | vtkStreamer
abstract object implements integration of massless particle through vector field. More...

Defines

#define | VTK_INTEGRATE_FORWARD 0
#define | VTK_INTEGRATE_BACKWARD 1
#define | VTK_INTEGRATE_BOTH_DIRECTIONS 2

Typedefs

typedef _vtkStreamPoint | vtkStreamPoint

Define Documentation

#define VTK_INTEGRATE_FORWARD 0

Definition at line 72 of file vtkStreamer.h.

#define VTK_INTEGRATE_BACKWARD 1

Definition at line 73 of file vtkStreamer.h.

#define VTK_INTEGRATE_BOTH_DIRECTIONS 2

Definition at line 74 of file vtkStreamer.h.

Typedef Documentation

typedef struct _vtkStreamPoint vtkStreamPoint

Generated on Mon Mar 25 01:12:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamLine.h File Reference

Graphics/vtkStreamLine.h File Reference

#include "vtkStreamer.h"

Include dependency graph for vtkStreamLine.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkStreamLine
generate streamline in arbitrary dataset. More...

Generated on Mon Mar 25 01:12:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamPoints.h File Reference

Graphics/vtkStreamPoints.h File Reference

#include "vtkStreamer.h"

Include dependency graph for vtkStreamPoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStreamPoints
generate points along streamer separated by constant time increment. More...

Generated on Mon Mar 25 01:12:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStripper.h File Reference

Graphics/vtkStripper.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkStripper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStripper
create triangle strips and/or poly-lines. More...

Generated on Mon Mar 25 01:12:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridGeometryFilter.h File Reference

Graphics/vtkStructuredGridGeometryFilter.h File Reference

#include "vtkStructuredGridToPolyDataFilter.h"

Include dependency graph for vtkStructuredGridGeometryFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridGeometryFilter
extract geometry for structured grid. More...

Generated on Mon Mar 25 01:12:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridOutlineFilter.h File Reference

Graphics/vtkStructuredGridOutlineFilter.h File Reference

#include "vtkStructuredGridToPolyDataFilter.h"

Include dependency graph for vtkStructuredGridOutlineFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridOutlineFilter
create wireframe outline for structured grid. More...

Generated on Mon Mar 25 01:12:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsGeometryFilter.h File Reference

Graphics/vtkStructuredPointsGeometryFilter.h File Reference

#include "vtkImageDataGeometryFilter.h"

Include dependency graph for vtkStructuredPointsGeometryFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsGeometryFilter
obsolete class. More...

Generated on Mon Mar 25 01:12:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSubdivideTetra.h File Reference

Graphics/vtkSubdivideTetra.h File Reference

#include "vtkUnstructuredGridToUnstructuredGridFilter.h"

Include dependency graph for vtkSubdivideTetra.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSubdivideTetra
subdivide one tetrahedron into twelve for every tetra. More...

Generated on Mon Mar 25 01:12:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSubPixelPositionEdgels.h File Reference

Graphics/vtkSubPixelPositionEdgels.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkSubPixelPositionEdgels.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSubPixelPositionEdgels
adjust edgel locations based on gradients. More...

Generated on Mon Mar 25 01:12:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSuperquadricSource.h File Reference

Graphics/vtkSuperquadricSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkSuperquadricSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSuperquadricSource
create a polygonal superquadric centered. More...

Defines

#define | VTK_MAX_SUPERQUADRIC_RESOLUTION 1024
#define | VTK_MIN_SUPERQUADRIC_THICKNESS 1e-4
#define | VTK_MIN_SUPERQUADRIC_ROUNDNESS 1e-24

Define Documentation

#define VTK_MAX_SUPERQUADRIC_RESOLUTION 1024

Definition at line 67 of file vtkSuperquadricSource.h.

#define VTK_MIN_SUPERQUADRIC_THICKNESS 1e-4

Definition at line 68 of file vtkSuperquadricSource.h.

#define VTK_MIN_SUPERQUADRIC_ROUNDNESS 1e-24

Definition at line 69 of file vtkSuperquadricSource.h.

Generated on Mon Mar 25 01:12:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTensorGlyph.h File Reference

Graphics/vtkTensorGlyph.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkTensorGlyph.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTensorGlyph
scale and orient glyph according to tensor eigenvalues and eigenvectors. More...

Generated on Mon Mar 25 01:12:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextSource.h File Reference

Graphics/vtkTextSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkTextSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTextSource
create polygonal text. More...

Generated on Mon Mar 25 01:12:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTexturedSphereSource.h File Reference

Graphics/vtkTexturedSphereSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkTexturedSphereSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkTexturedSphereSource
create a sphere centered at the origin. More...

Defines

#define | VTK_MAX_SPHERE_RESOLUTION 1024

Define Documentation

#define VTK_MAX_SPHERE_RESOLUTION 1024

Definition at line 44 of file vtkTexturedSphereSource.h.

Generated on Mon Mar 25 01:12:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToCylinder.h File Reference

Graphics/vtkTextureMapToCylinder.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkTextureMapToCylinder.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTextureMapToCylinder
generate texture coordinates by mapping points to cylinder. More...

Generated on Mon Mar 25 01:12:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToPlane.h File Reference

Graphics/vtkTextureMapToPlane.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkTextureMapToPlane.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTextureMapToPlane
generate texture coordinates by mapping points to plane. More...

Generated on Mon Mar 25 01:12:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToSphere.h File Reference

Graphics/vtkTextureMapToSphere.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkTextureMapToSphere.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTextureMapToSphere
generate texture coordinates by mapping points to sphere. More...

Generated on Mon Mar 25 01:12:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreshold.h File Reference

Graphics/vtkThreshold.h File Reference

#include "vtkDataSetToUnstructuredGridFilter.h"

Include dependency graph for vtkThreshold.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkThreshold
extracts cells where scalar value in cell satisfies threshold criterion. More...

Defines

#define | VTK_ATTRIBUTE_MODE_DEFAULT 0
#define | VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
#define | VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Define Documentation

#define VTK_ATTRIBUTE_MODE_DEFAULT 0

Definition at line 56 of file vtkThreshold.h.

#define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1

Definition at line 57 of file vtkThreshold.h.

#define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Definition at line 58 of file vtkThreshold.h.

Generated on Mon Mar 25 01:12:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThresholdPoints.h File Reference

Graphics/vtkThresholdPoints.h File Reference

#include "vtkDataSetToPolyDataFilter.h"

Include dependency graph for vtkThresholdPoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkThresholdPoints
extracts points whose scalar value satisfies threshold criterion. More...

Generated on Mon Mar 25 01:12:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThresholdTextureCoords.h File Reference

Graphics/vtkThresholdTextureCoords.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkThresholdTextureCoords.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkThresholdTextureCoords
compute 1D, 2D, or 3D texture coordinates based on scalar threshold. More...

Generated on Mon Mar 25 01:12:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformFilter.h File Reference

Graphics/vtkTransformFilter.h File Reference

#include "vtkPointSetToPointSetFilter.h"
#include "vtkAbstractTransform.h"

Include dependency graph for vtkTransformFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransformFilter
transform points and associated normals and vectors. More...

Generated on Mon Mar 25 01:12:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformPolyDataFilter.h File Reference

Graphics/vtkTransformPolyDataFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkTransform.h"

Include dependency graph for vtkTransformPolyDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransformPolyDataFilter
transform points and associated normals and vectors for polygonal dataset. More...

Generated on Mon Mar 25 01:12:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformTextureCoords.h File Reference

Graphics/vtkTransformTextureCoords.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkTransformTextureCoords.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransformTextureCoords
transform (scale, rotate, translate) texture coordinates. More...

Generated on Mon Mar 25 01:12:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangleFilter.h File Reference

Graphics/vtkTriangleFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkTriangleFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTriangleFilter
create triangle polygons from input polygons and triangle strips. More...

Generated on Mon Mar 25 01:12:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangularTCoords.h File Reference

Graphics/vtkTriangularTCoords.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkTriangularTCoords.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTriangularTCoords
2D texture coordinates based for triangles. More...

Generated on Mon Mar 25 01:12:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTubeFilter.h File Reference

Graphics/vtkTubeFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkTubeFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkTubeFilter
filter that generates tubes around lines. More...

Defines

#define | VTK_VARY_RADIUS_OFF 0
#define | VTK_VARY_RADIUS_BY_SCALAR 1
#define | VTK_VARY_RADIUS_BY_VECTOR 2

Define Documentation

#define VTK_VARY_RADIUS_OFF 0

Definition at line 71 of file vtkTubeFilter.h.

#define VTK_VARY_RADIUS_BY_SCALAR 1

Definition at line 72 of file vtkTubeFilter.h.

#define VTK_VARY_RADIUS_BY_VECTOR 2

Definition at line 73 of file vtkTubeFilter.h.

Generated on Mon Mar 25 01:12:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorDot.h File Reference

Graphics/vtkVectorDot.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkVectorDot.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVectorDot
generate scalars from dot product of vectors and normals (e.g., show displacement plot). More...

Generated on Mon Mar 25 01:12:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorNorm.h File Reference

Graphics/vtkVectorNorm.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkVectorNorm.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkVectorNorm
generate scalars from Euclidean norm of vectors. More...

Defines

#define | VTK_ATTRIBUTE_MODE_DEFAULT 0
#define | VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
#define | VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Define Documentation

#define VTK_ATTRIBUTE_MODE_DEFAULT 0

Definition at line 47 of file vtkVectorNorm.h.

#define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1

Definition at line 48 of file vtkVectorNorm.h.

#define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2

Definition at line 49 of file vtkVectorNorm.h.

Generated on Mon Mar 25 01:12:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxelContoursToSurfaceFilter.h File Reference

Graphics/vtkVoxelContoursToSurfaceFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkVoxelContoursToSurfaceFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVoxelContoursToSurfaceFilter
create surface from contours. More...

Generated on Mon Mar 25 01:12:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpLens.h File Reference

Graphics/vtkWarpLens.h File Reference

#include "vtkPointSetToPointSetFilter.h"

Include dependency graph for vtkWarpLens.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWarpLens
deform geometry by applying lens distortion. More...

Generated on Mon Mar 25 01:12:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpScalar.h File Reference

Graphics/vtkWarpScalar.h File Reference

#include "vtkPointSetToPointSetFilter.h"

Include dependency graph for vtkWarpScalar.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWarpScalar
deform geometry with scalar data. More...

Generated on Mon Mar 25 01:12:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpTo.h File Reference

Graphics/vtkWarpTo.h File Reference

#include "vtkPointSetToPointSetFilter.h"

Include dependency graph for vtkWarpTo.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWarpTo
deform geometry by warping towards a point. More...

Generated on Mon Mar 25 01:12:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpVector.h File Reference

Graphics/vtkWarpVector.h File Reference

#include "vtkPointSetToPointSetFilter.h"

Include dependency graph for vtkWarpVector.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWarpVector
deform geometry with vector data. More...

Generated on Mon Mar 25 01:12:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowedSincPolyDataFilter.h File Reference

Graphics/vtkWindowedSincPolyDataFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkWindowedSincPolyDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWindowedSincPolyDataFilter
adjust point positions using a windowed sinc function interpolation kernel. More...

Generated on Mon Mar 25 01:12:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtk3DSImporter.h File Reference

Hybrid/vtk3DSImporter.h File Reference

#include <stdio.h>
#include "vtkImporter.h"
#include "vtk3DS.h"
#include "vtkPolyData.h"

Include dependency graph for vtk3DSImporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtk3DSImporter
imports 3D Studio files. More...

Generated on Mon Mar 25 01:12:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArcPlotter.h File Reference

Hybrid/vtkArcPlotter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkCamera.h"

Include dependency graph for vtkArcPlotter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkArcPlotter
plot data along an arbitrary polyline. More...

Defines

#define | VTK_PLOT_SCALARS 1
#define | VTK_PLOT_VECTORS 2
#define | VTK_PLOT_NORMALS 3
#define | VTK_PLOT_TCOORDS 4
#define | VTK_PLOT_TENSORS 5
#define | VTK_PLOT_FIELD_DATA 6

Define Documentation

#define VTK_PLOT_SCALARS 1

Definition at line 60 of file vtkArcPlotter.h.

#define VTK_PLOT_VECTORS 2

Definition at line 61 of file vtkArcPlotter.h.

#define VTK_PLOT_NORMALS 3

Definition at line 62 of file vtkArcPlotter.h.

#define VTK_PLOT_TCOORDS 4

Definition at line 63 of file vtkArcPlotter.h.

#define VTK_PLOT_TENSORS 5

Definition at line 64 of file vtkArcPlotter.h.

#define VTK_PLOT_FIELD_DATA 6

Definition at line 65 of file vtkArcPlotter.h.

Generated on Mon Mar 25 01:12:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCaptionActor2D.h File Reference

Hybrid/vtkCaptionActor2D.h File Reference

#include "vtkActor2D.h"
#include "vtkTextMapper.h"
#include "vtkPolyData.h"

Include dependency graph for vtkCaptionActor2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCaptionActor2D
draw text label associated with a point. More...

Generated on Mon Mar 25 01:12:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCubeAxesActor2D.h File Reference

Hybrid/vtkCubeAxesActor2D.h File Reference

#include "vtkAxisActor2D.h"
#include "vtkCamera.h"

Include dependency graph for vtkCubeAxesActor2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkCubeAxesActor2D
create a 2D plot of a bounding box edges - used for navigation. More...

Defines

#define | VTK_FLY_OUTER_EDGES 0
#define | VTK_FLY_CLOSEST_TRIAD 1

Define Documentation

#define VTK_FLY_OUTER_EDGES 0

Definition at line 66 of file vtkCubeAxesActor2D.h.

#define VTK_FLY_CLOSEST_TRIAD 1

Definition at line 67 of file vtkCubeAxesActor2D.h.

Generated on Mon Mar 25 01:12:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDepthSortPolyData.h File Reference

Hybrid/vtkDepthSortPolyData.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkCamera.h"
#include "vtkProp3D.h"
#include "vtkTransform.h"

Include dependency graph for vtkDepthSortPolyData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkDepthSortPolyData
sort poly data along camera view direction. More...

Defines

#define | VTK_DIRECTION_BACK_TO_FRONT 0
#define | VTK_DIRECTION_FRONT_TO_BACK 1
#define | VTK_DIRECTION_SPECIFIED_VECTOR 2
#define | VTK_SORT_FIRST_POINT 0
#define | VTK_SORT_BOUNDS_CENTER 1
#define | VTK_SORT_PARAMETRIC_CENTER 2

Define Documentation

#define VTK_DIRECTION_BACK_TO_FRONT 0

Definition at line 55 of file vtkDepthSortPolyData.h.

#define VTK_DIRECTION_FRONT_TO_BACK 1

Definition at line 56 of file vtkDepthSortPolyData.h.

#define VTK_DIRECTION_SPECIFIED_VECTOR 2

Definition at line 57 of file vtkDepthSortPolyData.h.

#define VTK_SORT_FIRST_POINT 0

Definition at line 59 of file vtkDepthSortPolyData.h.

#define VTK_SORT_BOUNDS_CENTER 1

Definition at line 60 of file vtkDepthSortPolyData.h.

#define VTK_SORT_PARAMETRIC_CENTER 2

Definition at line 61 of file vtkDepthSortPolyData.h.

Generated on Mon Mar 25 01:12:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEarthSource.h File Reference

Hybrid/vtkEarthSource.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkEarthSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEarthSource
create the continents of the Earth as a sphere. More...

Generated on Mon Mar 25 01:12:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGLUTesselatorTriangleFilter.h File Reference

Hybrid/vtkGLUTesselatorTriangleFilter.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include <GL/GLU.h>

Include dependency graph for vtkGLUTesselatorTriangleFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGLUTesselatorTriangleFilter
create triangle polygons from input polygons and triangle strips. More...

Generated on Mon Mar 25 01:12:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGridTransform.h File Reference

Hybrid/vtkGridTransform.h File Reference

#include "vtkWarpTransform.h"
#include "vtkImageData.h"

Include dependency graph for vtkGridTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkGridTransform
a nonlinear warp transformation. More...

Defines

#define | VTK_GRID_NEAREST 0
#define | VTK_GRID_LINEAR 1
#define | VTK_GRID_CUBIC 3

Define Documentation

#define VTK_GRID_NEAREST 0

Definition at line 46 of file vtkGridTransform.h.

#define VTK_GRID_LINEAR 1

Definition at line 47 of file vtkGridTransform.h.

#define VTK_GRID_CUBIC 3

Definition at line 48 of file vtkGridTransform.h.

Generated on Mon Mar 25 01:12:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToPolyDataFilter.h File Reference

Hybrid/vtkImageToPolyDataFilter.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"
#include "vtkScalarsToColors.h"

Include dependency graph for vtkImageToPolyDataFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageToPolyDataFilter
generate linear primitives (vtkPolyData) from an image. More...

Defines

#define | VTK_STYLE_PIXELIZE 0
#define | VTK_STYLE_POLYGONALIZE 1
#define | VTK_STYLE_RUN_LENGTH 2
#define | VTK_COLOR_MODE_LUT 0
#define | VTK_COLOR_MODE_LINEAR_256 1

Define Documentation

#define VTK_STYLE_PIXELIZE 0

Definition at line 82 of file vtkImageToPolyDataFilter.h.

#define VTK_STYLE_POLYGONALIZE 1

Definition at line 83 of file vtkImageToPolyDataFilter.h.

#define VTK_STYLE_RUN_LENGTH 2

Definition at line 84 of file vtkImageToPolyDataFilter.h.

#define VTK_COLOR_MODE_LUT 0

Definition at line 86 of file vtkImageToPolyDataFilter.h.

#define VTK_COLOR_MODE_LINEAR_256 1

Definition at line 87 of file vtkImageToPolyDataFilter.h.

Generated on Mon Mar 25 01:12:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitModeller.h File Reference

Hybrid/vtkImplicitModeller.h File Reference

#include "vtkDataSetToStructuredPointsFilter.h"

Include dependency graph for vtkImplicitModeller.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImplicitModeller
compute distance from input geometry on structured point dataset. More...

Defines

#define | VTK_VOXEL_MODE 0
#define | VTK_CELL_MODE 1

Define Documentation

#define VTK_VOXEL_MODE 0

Definition at line 94 of file vtkImplicitModeller.h.

#define VTK_CELL_MODE 1

Definition at line 95 of file vtkImplicitModeller.h.

Generated on Mon Mar 25 01:12:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIterativeClosestPointTransform.h File Reference

Hybrid/vtkIterativeClosestPointTransform.h File Reference

#include "vtkLinearTransform.h"

Include dependency graph for vtkIterativeClosestPointTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkIterativeClosestPointTransform
Implementation of the ICP algorithm. More...

Defines

#define | VTK_ICP_MODE_RMS 0
#define | VTK_ICP_MODE_AV 1

Define Documentation

#define VTK_ICP_MODE_RMS 0

Definition at line 56 of file vtkIterativeClosestPointTransform.h.

#define VTK_ICP_MODE_AV 1

Definition at line 57 of file vtkIterativeClosestPointTransform.h.

Generated on Mon Mar 25 01:12:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLandmarkTransform.h File Reference

Hybrid/vtkLandmarkTransform.h File Reference

#include "vtkLinearTransform.h"
#include "vtkMutexLock.h"

Include dependency graph for vtkLandmarkTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkLandmarkTransform
a linear transform specified by two corresponding point sets. More...

Defines

#define | VTK_LANDMARK_RIGIDBODY 6
#define | VTK_LANDMARK_SIMILARITY 7
#define | VTK_LANDMARK_AFFINE 12

Define Documentation

#define VTK_LANDMARK_RIGIDBODY 6

Definition at line 48 of file vtkLandmarkTransform.h.

#define VTK_LANDMARK_SIMILARITY 7

Definition at line 49 of file vtkLandmarkTransform.h.

#define VTK_LANDMARK_AFFINE 12

Definition at line 50 of file vtkLandmarkTransform.h.

Generated on Mon Mar 25 01:12:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLegendBoxActor.h File Reference

Hybrid/vtkLegendBoxActor.h File Reference

#include "vtkActor2D.h"
#include "vtkTextMapper.h"

Include dependency graph for vtkLegendBoxActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLegendBoxActor
draw symbols with text. More...

Generated on Mon Mar 25 01:12:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMILVideoSource.h File Reference

Hybrid/vtkMILVideoSource.h File Reference

#include "vtkVideoSource.h"

Include dependency graph for vtkMILVideoSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkMILVideoSource
Matrox Imaging Library frame grabbers. More...

Defines

#define | VTK_MIL_DEFAULT 0
#define | VTK_MIL_METEOR 1
#define | VTK_MIL_METEOR_II 2
#define | VTK_MIL_METEOR_II_DIG 3
#define | VTK_MIL_CORONA 4
#define | VTK_MIL_PULSAR 5
#define | VTK_MIL_GENESIS 6
#define | VTK_MIL_MONO 0
#define | VTK_MIL_COMPOSITE 1
#define | VTK_MIL_YC 2
#define | VTK_MIL_RGB 3
#define | VTK_MIL_DIGITAL 4
#define | VTK_MIL_RS170 0
#define | VTK_MIL_NTSC 1
#define | VTK_MIL_CCIR 2
#define | VTK_MIL_PAL 3
#define | VTK_MIL_SECAM 4
#define | VTK_MIL_NONSTANDARD 5

Define Documentation

#define VTK_MIL_DEFAULT 0

Definition at line 43 of file vtkMILVideoSource.h.

#define VTK_MIL_METEOR 1

Definition at line 44 of file vtkMILVideoSource.h.

#define VTK_MIL_METEOR_II 2

Definition at line 45 of file vtkMILVideoSource.h.

#define VTK_MIL_METEOR_II_DIG 3

Definition at line 46 of file vtkMILVideoSource.h.

#define VTK_MIL_CORONA 4

Definition at line 47 of file vtkMILVideoSource.h.

#define VTK_MIL_PULSAR 5

Definition at line 48 of file vtkMILVideoSource.h.

#define VTK_MIL_GENESIS 6

Definition at line 49 of file vtkMILVideoSource.h.

#define VTK_MIL_MONO 0

Definition at line 52 of file vtkMILVideoSource.h.

#define VTK_MIL_COMPOSITE 1

Definition at line 53 of file vtkMILVideoSource.h.

#define VTK_MIL_YC 2

Definition at line 54 of file vtkMILVideoSource.h.

#define VTK_MIL_RGB 3

Definition at line 55 of file vtkMILVideoSource.h.

#define VTK_MIL_DIGITAL 4

Definition at line 56 of file vtkMILVideoSource.h.

#define VTK_MIL_RS170 0

Definition at line 59 of file vtkMILVideoSource.h.

#define VTK_MIL_NTSC 1

Definition at line 60 of file vtkMILVideoSource.h.

#define VTK_MIL_CCIR 2

Definition at line 61 of file vtkMILVideoSource.h.

#define VTK_MIL_PAL 3

Definition at line 62 of file vtkMILVideoSource.h.

#define VTK_MIL_SECAM 4

Definition at line 63 of file vtkMILVideoSource.h.

#define VTK_MIL_NONSTANDARD 5

Definition at line 64 of file vtkMILVideoSource.h.

Generated on Mon Mar 25 01:12:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPCAAnalysisFilter.h File Reference

Hybrid/vtkPCAAnalysisFilter.h File Reference

#include "vtkSource.h"

Include dependency graph for vtkPCAAnalysisFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPCAAnalysisFilter
Performs principal component analysis of a set of aligned pointsets. More...

Generated on Mon Mar 25 01:12:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataToImageStencil.h File Reference

Hybrid/vtkPolyDataToImageStencil.h File Reference

#include "vtkImageStencilSource.h"
#include "vtkPolyData.h"
#include "vtkOBBTree.h"

Include dependency graph for vtkPolyDataToImageStencil.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataToImageStencil
clip an image with polydata. More...

Generated on Mon Mar 25 01:12:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcrustesAlignmentFilter.h File Reference

Hybrid/vtkProcrustesAlignmentFilter.h File Reference

#include "vtkSource.h"

Include dependency graph for vtkProcrustesAlignmentFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkProcrustesAlignmentFilter
aligns a set of pointsets together. More...

Generated on Mon Mar 25 01:12:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderLargeImage.h File Reference

Hybrid/vtkRenderLargeImage.h File Reference

#include "vtkImageSource.h"
#include "vtkRenderer.h"

Include dependency graph for vtkRenderLargeImage.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRenderLargeImage
Use tiling to generate a large rendering. More...

Generated on Mon Mar 25 01:12:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBExporter.h File Reference

Hybrid/vtkRIBExporter.h File Reference

#include <stdio.h>
#include "vtkExporter.h"
#include "vtkRenderer.h"
#include "vtkTexture.h"
#include "vtkPolyData.h"

Include dependency graph for vtkRIBExporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRIBExporter
export a scene into RenderMan RIB format. More...

Generated on Mon Mar 25 01:12:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBLight.h File Reference

Hybrid/vtkRIBLight.h File Reference

#include <stdio.h>
#include "vtkLight.h"

Include dependency graph for vtkRIBLight.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRIBLight
RIP Light. More...

Generated on Mon Mar 25 01:12:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBProperty.h File Reference

Hybrid/vtkRIBProperty.h File Reference

#include <stdio.h>
#include "vtkProperty.h"

Include dependency graph for vtkRIBProperty.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRIBProperty
RIP Property. More...

Generated on Mon Mar 25 01:12:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThinPlateSplineTransform.h File Reference

Hybrid/vtkThinPlateSplineTransform.h File Reference

#include "vtkWarpTransform.h"

Include dependency graph for vtkThinPlateSplineTransform.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkThinPlateSplineTransform
a nonlinear warp transformation. More...

Defines

#define | VTK_RBF_CUSTOM 0
#define | VTK_RBF_R 1
#define | VTK_RBF_R2LOGR 2

Define Documentation

#define VTK_RBF_CUSTOM 0

Definition at line 52 of file vtkThinPlateSplineTransform.h.

#define VTK_RBF_R 1

Definition at line 53 of file vtkThinPlateSplineTransform.h.

#define VTK_RBF_R2LOGR 2

Definition at line 54 of file vtkThinPlateSplineTransform.h.

Generated on Mon Mar 25 01:12:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformToGrid.h File Reference

Hybrid/vtkTransformToGrid.h File Reference

#include "vtkImageSource.h"
#include "vtkAbstractTransform.h"

Include dependency graph for vtkTransformToGrid.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransformToGrid
create a grid for a vtkGridTransform. More...

Generated on Mon Mar 25 01:12:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorText.h File Reference

Hybrid/vtkVectorText.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkVectorText.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVectorText
create polygonal text. More...

Generated on Mon Mar 25 01:12:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVideoSource.h File Reference

Hybrid/vtkVideoSource.h File Reference

#include "vtkTimerLog.h"
#include "vtkCriticalSection.h"
#include "vtkMultiThreader.h"
#include "vtkImageSource.h"
#include "vtkScalarsToColors.h"

Include dependency graph for vtkVideoSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVideoSource
Superclass of video input devices for VTK. More...

Generated on Mon Mar 25 01:12:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRML.h File Reference

Hybrid/vtkVRML.h File Reference

#include <stdlib.h>
#include "vtkConfigure.h"
#include <new.h>
#include <iostream.h>
#include <string.h>
#include "vtkWin32Header.h"
#include "vtkHeap.h"

Include dependency graph for vtkVRML.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | vtkVRMLAllocator
class | VectorType

Defines

#define | DEFAULTINCREMENT 100

Variables

const char | standardNodes [][2042]

Define Documentation

#define DEFAULTINCREMENT 100

Definition at line 36 of file vtkVRML.h.

Variable Documentation

const char standardNodes[][2042] [static]

Definition at line 205 of file vtkVRML.h.

Generated on Mon Mar 25 01:12:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRMLImporter.h File Reference

Hybrid/vtkVRMLImporter.h File Reference

#include "vtkVRML.h"
#include "vtkImporter.h"

Include dependency graph for vtkVRMLImporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVRMLImporter
imports VRML 2.0 files. More...

Generated on Mon Mar 25 01:12:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWeightedTransformFilter.h File Reference

Hybrid/vtkWeightedTransformFilter.h File Reference

#include "vtkPointSetToPointSetFilter.h"
#include "vtkAbstractTransform.h"

Include dependency graph for vtkWeightedTransformFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWeightedTransformFilter

Generated on Mon Mar 25 01:12:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32VideoSource.h File Reference

Hybrid/vtkWin32VideoSource.h File Reference

#include "vtkVideoSource.h"
#include <windows.h>
#include <winuser.h>
#include <vfw.h>

Include dependency graph for vtkWin32VideoSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32VideoSource
Video-for-Windows video digitizer. More...

Generated on Mon Mar 25 01:12:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXYPlotActor.h File Reference

Hybrid/vtkXYPlotActor.h File Reference

#include "vtkAxisActor2D.h"

Include dependency graph for vtkXYPlotActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkXYPlotActor
generate an x-y plot from input dataset(s) or field data. More...

Defines

#define | VTK_XYPLOT_INDEX 0
#define | VTK_XYPLOT_ARC_LENGTH 1
#define | VTK_XYPLOT_NORMALIZED_ARC_LENGTH 2
#define | VTK_XYPLOT_VALUE 3
#define | VTK_XYPLOT_ROW 0
#define | VTK_XYPLOT_COLUMN 1

Define Documentation

#define VTK_XYPLOT_INDEX 0

Definition at line 91 of file vtkXYPlotActor.h.

#define VTK_XYPLOT_ARC_LENGTH 1

Definition at line 92 of file vtkXYPlotActor.h.

#define VTK_XYPLOT_NORMALIZED_ARC_LENGTH 2

Definition at line 93 of file vtkXYPlotActor.h.

#define VTK_XYPLOT_VALUE 3

Definition at line 94 of file vtkXYPlotActor.h.

#define VTK_XYPLOT_ROW 0

Definition at line 96 of file vtkXYPlotActor.h.

#define VTK_XYPLOT_COLUMN 1

Definition at line 97 of file vtkXYPlotActor.h.

Generated on Mon Mar 25 01:12:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBooleanTexture.h File Reference

Imaging/vtkBooleanTexture.h File Reference

#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkBooleanTexture.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBooleanTexture
generate 2D texture map based on combinations of inside, outside, and on region boundary. More...

Generated on Mon Mar 25 01:12:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractVOI.h File Reference

Imaging/vtkExtractVOI.h File Reference

#include "vtkStructuredPointsToStructuredPointsFilter.h"

Include dependency graph for vtkExtractVOI.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractVOI
select piece (e.g., volume of interest) and/or subsample structured points dataset. More...

Generated on Mon Mar 25 01:12:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGaussianSplatter.h File Reference

Imaging/vtkGaussianSplatter.h File Reference

#include "vtkDataSetToStructuredPointsFilter.h"

Include dependency graph for vtkGaussianSplatter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkGaussianSplatter
splat points into a volume with an elliptical, Gaussian distribution. More...

Defines

#define | VTK_ACCUMULATION_MODE_MIN 0
#define | VTK_ACCUMULATION_MODE_MAX 1
#define | VTK_ACCUMULATION_MODE_SUM 2

Define Documentation

#define VTK_ACCUMULATION_MODE_MIN 0

Definition at line 90 of file vtkGaussianSplatter.h.

#define VTK_ACCUMULATION_MODE_MAX 1

Definition at line 91 of file vtkGaussianSplatter.h.

#define VTK_ACCUMULATION_MODE_SUM 2

Definition at line 92 of file vtkGaussianSplatter.h.

Generated on Mon Mar 25 01:12:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAccumulate.h File Reference

Imaging/vtkImageAccumulate.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkImageStencilData.h"

Include dependency graph for vtkImageAccumulate.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageAccumulate
Generalized histograms up to 4 dimensions. More...

Generated on Mon Mar 25 01:12:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAnisotropicDiffusion2D.h File Reference

Imaging/vtkImageAnisotropicDiffusion2D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageAnisotropicDiffusion2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageAnisotropicDiffusion2D
edge preserving smoothing. More...

Generated on Mon Mar 25 01:12:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAnisotropicDiffusion3D.h File Reference

Imaging/vtkImageAnisotropicDiffusion3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageAnisotropicDiffusion3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageAnisotropicDiffusion3D
edge preserving smoothing. More...

Generated on Mon Mar 25 01:12:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAppend.h File Reference

Imaging/vtkImageAppend.h File Reference

#include "vtkImageMultipleInputFilter.h"

Include dependency graph for vtkImageAppend.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageAppend
Collects data from multiple inputs into one image. More...

Generated on Mon Mar 25 01:12:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAppendComponents.h File Reference

Imaging/vtkImageAppendComponents.h File Reference

#include "vtkImageMultipleInputFilter.h"

Include dependency graph for vtkImageAppendComponents.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageAppendComponents
Collects components from two inputs into. More...

Generated on Mon Mar 25 01:12:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlend.h File Reference

Imaging/vtkImageBlend.h File Reference

#include "vtkImageMultipleInputFilter.h"
#include "vtkImageStencilData.h"

Include dependency graph for vtkImageBlend.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageBlend
blend images together using alpha or opacity. More...

Defines

#define | VTK_IMAGE_BLEND_MODE_NORMAL 0
#define | VTK_IMAGE_BLEND_MODE_COMPOUND 1

Define Documentation

#define VTK_IMAGE_BLEND_MODE_NORMAL 0

Definition at line 94 of file vtkImageBlend.h.

#define VTK_IMAGE_BLEND_MODE_COMPOUND 1

Definition at line 95 of file vtkImageBlend.h.

Generated on Mon Mar 25 01:12:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageButterworthHighPass.h File Reference

Imaging/vtkImageButterworthHighPass.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageButterworthHighPass.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageButterworthHighPass
Frequency domain high pass. More...

Generated on Mon Mar 25 01:12:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageButterworthLowPass.h File Reference

Imaging/vtkImageButterworthLowPass.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageButterworthLowPass.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageButterworthLowPass
Frequency domain Low pass. More...

Generated on Mon Mar 25 01:12:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCacheFilter.h File Reference

Imaging/vtkImageCacheFilter.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageCacheFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCacheFilter
Caches multiple vtkImageData objects. More...

Generated on Mon Mar 25 01:12:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCanvasSource2D.h File Reference

Imaging/vtkImageCanvasSource2D.h File Reference

#include <math.h>
#include "vtkStructuredPoints.h"

Include dependency graph for vtkImageCanvasSource2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageCanvasSource2DPixel
class | vtkImageCanvasSource2D
Paints on a canvas. More...

Generated on Mon Mar 25 01:12:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCast.h File Reference

Imaging/vtkImageCast.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageCast.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCast
Image Data type Casting Filter. More...

Generated on Mon Mar 25 01:12:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageChangeInformation.h File Reference

Imaging/vtkImageChangeInformation.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageChangeInformation.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageChangeInformation
modify spacing, origin and extent. More...

Generated on Mon Mar 25 01:12:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCheckerboard.h File Reference

Imaging/vtkImageCheckerboard.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageCheckerboard.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCheckerboard
show two images at once using a checkboard pattern. More...

Generated on Mon Mar 25 01:12:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCityBlockDistance.h File Reference

Imaging/vtkImageCityBlockDistance.h File Reference

#include "vtkImageDecomposeFilter.h"

Include dependency graph for vtkImageCityBlockDistance.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCityBlockDistance
1,2 or 3D distance map. More...

Generated on Mon Mar 25 01:12:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageClip.h File Reference

Imaging/vtkImageClip.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageClip.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageClip
Reduces the image extent of the input. More...

Generated on Mon Mar 25 01:12:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConnector.h File Reference

Imaging/vtkImageConnector.h File Reference

#include "vtkObject.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageConnector.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkImageConnectorSeed
class | vtkImageConnector
Create a binary image of a sphere. More...

Generated on Mon Mar 25 01:12:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConstantPad.h File Reference

Imaging/vtkImageConstantPad.h File Reference

#include "vtkImagePadFilter.h"

Include dependency graph for vtkImageConstantPad.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageConstantPad
Makes image larger by padding with constant. More...

Generated on Mon Mar 25 01:12:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageContinuousDilate3D.h File Reference

Imaging/vtkImageContinuousDilate3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageContinuousDilate3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageContinuousDilate3D
Dilate implemented as a maximum. More...

Generated on Mon Mar 25 01:12:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageContinuousErode3D.h File Reference

Imaging/vtkImageContinuousErode3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageContinuousErode3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageContinuousErode3D
Erosion implemented as a minimum. More...

Generated on Mon Mar 25 01:12:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConvolve.h File Reference

Imaging/vtkImageConvolve.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageConvolve.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageConvolve
Convolution of an image with a kernel. More...

Generated on Mon Mar 25 01:12:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCorrelation.h File Reference

Imaging/vtkImageCorrelation.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageCorrelation.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCorrelation
Correlation imageof the two inputs. More...

Generated on Mon Mar 25 01:12:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCursor3D.h File Reference

Imaging/vtkImageCursor3D.h File Reference

#include "vtkImageInPlaceFilter.h"

Include dependency graph for vtkImageCursor3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageCursor3D
Paints a cursor on top of an image or volume. More...

Generated on Mon Mar 25 01:12:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDataStreamer.h File Reference

Imaging/vtkImageDataStreamer.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkExtentTranslator.h"

Include dependency graph for vtkImageDataStreamer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageDataStreamer
Initiates streaming on image data. More...

Generated on Mon Mar 25 01:12:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDecomposeFilter.h File Reference

Imaging/vtkImageDecomposeFilter.h File Reference

#include "vtkImageIterateFilter.h"

Include dependency graph for vtkImageDecomposeFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageDecomposeFilter
Filters that execute axes in series. More...

Generated on Mon Mar 25 01:12:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDifference.h File Reference

Imaging/vtkImageDifference.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageDifference.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageDifference
Compares images for regression tests. More...

Generated on Mon Mar 25 01:12:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDilateErode3D.h File Reference

Imaging/vtkImageDilateErode3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageDilateErode3D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageDilateErode3D
Dilates one value and erodes another. More...

Generated on Mon Mar 25 01:12:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDivergence.h File Reference

Imaging/vtkImageDivergence.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageDivergence.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageDivergence
Divergence of a vector field. More...

Generated on Mon Mar 25 01:12:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDotProduct.h File Reference

Imaging/vtkImageDotProduct.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageDotProduct.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageDotProduct
Dot product of two vector images. More...

Generated on Mon Mar 25 01:12:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEllipsoidSource.h File Reference

Imaging/vtkImageEllipsoidSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageEllipsoidSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageEllipsoidSource
Create a binary image of an ellipsoid. More...

Generated on Mon Mar 25 01:12:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEuclideanDistance.h File Reference

Imaging/vtkImageEuclideanDistance.h File Reference

#include "vtkImageDecomposeFilter.h"

Include dependency graph for vtkImageEuclideanDistance.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageEuclideanDistance
computes 3D Euclidean DT. More...

Defines

#define | VTK_EDT_SAITO_CACHED 0
#define | VTK_EDT_SAITO 1

Define Documentation

#define VTK_EDT_SAITO_CACHED 0

Definition at line 63 of file vtkImageEuclideanDistance.h.

#define VTK_EDT_SAITO 1

Definition at line 64 of file vtkImageEuclideanDistance.h.

Generated on Mon Mar 25 01:12:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEuclideanToPolar.h File Reference

Imaging/vtkImageEuclideanToPolar.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageEuclideanToPolar.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageEuclideanToPolar
Converts 2D Euclidean coordinates to polar. More...

Generated on Mon Mar 25 01:12:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageExport.h File Reference

Imaging/vtkImageExport.h File Reference

#include "vtkProcessObject.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageExport.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageExport
Export VTK images to third-party systems. More...

Generated on Mon Mar 25 01:12:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageExtractComponents.h File Reference

Imaging/vtkImageExtractComponents.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageExtractComponents.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageExtractComponents
Outputs a single component. More...

Generated on Mon Mar 25 01:12:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFFT.h File Reference

Imaging/vtkImageFFT.h File Reference

#include "vtkImageFourierFilter.h"

Include dependency graph for vtkImageFFT.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageFFT
Fast Fourier Transform. More...

Generated on Mon Mar 25 01:12:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFlip.h File Reference

Imaging/vtkImageFlip.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageFlip.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageFlip
This flips an axis of an image. Right becomes left ... More...

Generated on Mon Mar 25 01:12:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFourierCenter.h File Reference

Imaging/vtkImageFourierCenter.h File Reference

#include "vtkImageDecomposeFilter.h"

Include dependency graph for vtkImageFourierCenter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageFourierCenter
Shifts constant frequency to center for. More...

Generated on Mon Mar 25 01:12:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFourierFilter.h File Reference

Imaging/vtkImageFourierFilter.h File Reference

#include "vtkImageDecomposeFilter.h"

Include dependency graph for vtkImageFourierFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkImageFourierFilter
Superclass that implements complex numbers. More...

Defines

#define | vtkImageComplexEuclidSet(C, R, I)
#define | vtkImageComplexPolarSet(C, M, P)
#define | vtkImageComplexPrint(C) printf("(%.3f, %.3f)", (C).Real, (C).Imag)
#define | vtkImageComplexScale(cOut, S, cIn)
#define | vtkImageComplexConjugate(cIn, cOut)
#define | vtkImageComplexAdd(C1, C2, cOut)
#define | vtkImageComplexSubtract(C1, C2, cOut)
#define | vtkImageComplexMultiply(C1, C2, cOut)
#define | vtkImageComplexExponential(cIn, cOut)

Typedefs

typedef double | Real

Variables

double | Imag
vtkImageComplex

Define Documentation

#define vtkImageComplexEuclidSet | ( | C,
 |  | R,
 |  | I | )

Value:

(C).Real = (R); \
  (C).Imag = (I)

Definition at line 54 of file vtkImageFourierFilter.h.

#define vtkImageComplexPolarSet | ( | C,
 |  | M,
 |  | P | )

Value:

(C).Real = (M)*cos(P); \
  (C).Imag = (M)*sin(P)

Definition at line 58 of file vtkImageFourierFilter.h.

#define vtkImageComplexPrint ( C ) printf("(%.3f, %.3f)", (C).Real, (C).Imag)

Definition at line 62 of file vtkImageFourierFilter.h.

#define vtkImageComplexScale | ( | cOut,
 |  | S,
 |  | cIn | )

Value:

(cOut).Real = (cIn).Real * (S); \
  (cOut).Imag = (cIn).Imag * (S)

Definition at line 65 of file vtkImageFourierFilter.h.

#define vtkImageComplexConjugate | ( | cIn,
 |  | cOut | )

Value:

(cOut).Imag = (cIn).Imag * -1.0;    \
  (cOut).Real = (cIn).Real

Definition at line 69 of file vtkImageFourierFilter.h.

#define vtkImageComplexAdd | ( | C1,
 |  | C2,
 |  | cOut | )

Value:

(cOut).Real = (C1).Real + (C2).Real; \
  (cOut).Imag = (C1).Imag + (C2).Imag

Definition at line 73 of file vtkImageFourierFilter.h.

#define vtkImageComplexSubtract | ( | C1,
 |  | C2,
 |  | cOut | )

Value:

(cOut).Real = (C1).Real - (C2).Real; \
  (cOut).Imag = (C1).Imag - (C2).Imag

Definition at line 77 of file vtkImageFourierFilter.h.

#define vtkImageComplexMultiply | ( | C1,
 |  | C2,
 |  | cOut | )

Value:

{ \
  vtkImageComplex _vtkImageComplexMultiplyTemp; \
  _vtkImageComplexMultiplyTemp.Real = (C1).Real*(C2).Real-(C1).Imag*(C2).Imag;\
  _vtkImageComplexMultiplyTemp.Imag = (C1).Real*(C2).Imag+(C1).Imag*(C2).Real;\
  cOut = _vtkImageComplexMultiplyTemp; \
}

Definition at line 81 of file vtkImageFourierFilter.h.

#define vtkImageComplexExponential | ( | cIn,
 |  | cOut | )

Value:

{ \
  float tmp = exp(cIn.Real); \
  cOut.Real = tmp * cos(cIn.Imag); \
  cOut.Imag = tmp * sin(cIn.Imag); \
}

Definition at line 90 of file vtkImageFourierFilter.h.

Typedef Documentation

typedef struct double Real

Definition at line 48 of file vtkImageFourierFilter.h.

Variable Documentation

double Imag

Definition at line 50 of file vtkImageFourierFilter.h.

vtkImageComplex

Definition at line 51 of file vtkImageFourierFilter.h.

Generated on Mon Mar 25 01:12:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGaussianSmooth.h File Reference

Imaging/vtkImageGaussianSmooth.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageGaussianSmooth.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageGaussianSmooth
Performs a gaussian convolution. More...

Generated on Mon Mar 25 01:12:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGaussianSource.h File Reference

Imaging/vtkImageGaussianSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageGaussianSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageGaussianSource
Create an image with Gaussian pixel values. More...

Generated on Mon Mar 25 01:12:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGradient.h File Reference

Imaging/vtkImageGradient.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageGradient.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageGradient
Computes the gradient vector. More...

Generated on Mon Mar 25 01:13:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGradientMagnitude.h File Reference

Imaging/vtkImageGradientMagnitude.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageGradientMagnitude.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageGradientMagnitude
Computes magnitude of the gradient. More...

Generated on Mon Mar 25 01:13:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGridSource.h File Reference

Imaging/vtkImageGridSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageGridSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageGridSource
Create an image of a grid. More...

Generated on Mon Mar 25 01:13:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageHSVToRGB.h File Reference

Imaging/vtkImageHSVToRGB.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageHSVToRGB.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageHSVToRGB
Converts HSV components to RGB. More...

Generated on Mon Mar 25 01:13:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageHybridMedian2D.h File Reference

Imaging/vtkImageHybridMedian2D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageHybridMedian2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageHybridMedian2D
Median filter that preserves lines and. More...

Generated on Mon Mar 25 01:13:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIdealHighPass.h File Reference

Imaging/vtkImageIdealHighPass.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageIdealHighPass.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageIdealHighPass
Simple frequency domain band pass. More...

Generated on Mon Mar 25 01:13:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIdealLowPass.h File Reference

Imaging/vtkImageIdealLowPass.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageIdealLowPass.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageIdealLowPass
Simple frequency domain band pass. More...

Generated on Mon Mar 25 01:13:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageImport.h File Reference

Imaging/vtkImageImport.h File Reference

#include "vtkImageSource.h"
#include "vtkTransform.h"

Include dependency graph for vtkImageImport.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageImport
Import data from a C array. More...

Generated on Mon Mar 25 01:13:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIslandRemoval2D.h File Reference

Imaging/vtkImageIslandRemoval2D.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageIslandRemoval2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageIslandRemoval2D
Removes small clusters in masks. More...

Typedefs

typedef void * | inPtr

Variables

void * | outPtr
int | idx0
int | idx1
vtkImage2DIslandPixel

Typedef Documentation

typedef struct void* inPtr

Definition at line 45 of file vtkImageIslandRemoval2D.h.

Variable Documentation

void* outPtr

Definition at line 47 of file vtkImageIslandRemoval2D.h.

int idx0

Definition at line 48 of file vtkImageIslandRemoval2D.h.

int idx1

Definition at line 49 of file vtkImageIslandRemoval2D.h.

vtkImage2DIslandPixel

Definition at line 50 of file vtkImageIslandRemoval2D.h.

Generated on Mon Mar 25 01:13:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIterateFilter.h File Reference

Imaging/vtkImageIterateFilter.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageIterateFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageIterateFilter
Multiple executes per update. More...

Generated on Mon Mar 25 01:13:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLaplacian.h File Reference

Imaging/vtkImageLaplacian.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageLaplacian.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageLaplacian
Computes divergence of gradient. More...

Generated on Mon Mar 25 01:13:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLogarithmicScale.h File Reference

Imaging/vtkImageLogarithmicScale.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageLogarithmicScale.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageLogarithmicScale
Passes each pixel through log function. More...

Generated on Mon Mar 25 01:13:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLogic.h File Reference

Imaging/vtkImageLogic.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageLogic.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkImageLogic
And, or, xor, nand, nor, not. More...

Defines

#define | VTK_AND 0
#define | VTK_OR 1
#define | VTK_XOR 2
#define | VTK_NAND 3
#define | VTK_NOR 4
#define | VTK_NOT 5
#define | VTK_NOP 6

Define Documentation

#define VTK_AND 0

Definition at line 42 of file vtkImageLogic.h.

#define VTK_OR 1

Definition at line 43 of file vtkImageLogic.h.

#define VTK_XOR 2

Definition at line 44 of file vtkImageLogic.h.

#define VTK_NAND 3

Definition at line 45 of file vtkImageLogic.h.

#define VTK_NOR 4

Definition at line 46 of file vtkImageLogic.h.

#define VTK_NOT 5

Definition at line 47 of file vtkImageLogic.h.

#define VTK_NOP 6

Definition at line 48 of file vtkImageLogic.h.

Generated on Mon Mar 25 01:13:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLuminance.h File Reference

Imaging/vtkImageLuminance.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageLuminance.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageLuminance
Computes the luminance of the input. More...

Generated on Mon Mar 25 01:13:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMagnify.h File Reference

Imaging/vtkImageMagnify.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageMagnify.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMagnify
magnify an image by an integer value. More...

Generated on Mon Mar 25 01:13:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMagnitude.h File Reference

Imaging/vtkImageMagnitude.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageMagnitude.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMagnitude
Colapses components with magnitude function.. More...

Generated on Mon Mar 25 01:13:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMandelbrotSource.h File Reference

Imaging/vtkImageMandelbrotSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageMandelbrotSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMandelbrotSource
Mandelbrot image. More...

Generated on Mon Mar 25 01:13:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToColors.h File Reference

Imaging/vtkImageMapToColors.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkScalarsToColors.h"

Include dependency graph for vtkImageMapToColors.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageMapToColors
map the input image through a lookup table. More...

Generated on Mon Mar 25 01:13:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToRGBA.h File Reference

Imaging/vtkImageMapToRGBA.h File Reference

#include "vtkImageMapToColors.h"

Include dependency graph for vtkImageMapToRGBA.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMapToRGBA
map the input image through a lookup table. More...

Generated on Mon Mar 25 01:13:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToWindowLevelColors.h File Reference

Imaging/vtkImageMapToWindowLevelColors.h File Reference

#include "vtkImageMapToColors.h"

Include dependency graph for vtkImageMapToWindowLevelColors.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageMapToWindowLevelColors
map the input image through a lookup table and window / level it. More...

Generated on Mon Mar 25 01:13:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMask.h File Reference

Imaging/vtkImageMask.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageMask.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMask
Combines a mask and an image. More...

Generated on Mon Mar 25 01:13:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMaskBits.h File Reference

Imaging/vtkImageMaskBits.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkImageLogic.h"

Include dependency graph for vtkImageMaskBits.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMaskBits
applies a bit-mask pattern to each component. More...

Generated on Mon Mar 25 01:13:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMathematics.h File Reference

Imaging/vtkImageMathematics.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageMathematics.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageMathematics
Add, subtract, multiply, divide, invert, sin, cos, exp, log. More...

Defines

#define | VTK_ADD 0
#define | VTK_SUBTRACT 1
#define | VTK_MULTIPLY 2
#define | VTK_DIVIDE 3
#define | VTK_INVERT 4
#define | VTK_SIN 5
#define | VTK_COS 6
#define | VTK_EXP 7
#define | VTK_LOG 8
#define | VTK_ABS 9
#define | VTK_SQR 10
#define | VTK_SQRT 11
#define | VTK_MIN 12
#define | VTK_MAX 13
#define | VTK_ATAN 14
#define | VTK_ATAN2 15
#define | VTK_MULTIPLYBYK 16
#define | VTK_ADDC 17
#define | VTK_CONJUGATE 18
#define | VTK_COMPLEX_MULTIPLY 19
#define | VTK_REPLACECBYK 20

Define Documentation

#define VTK_ADD 0

Definition at line 44 of file vtkImageMathematics.h.

#define VTK_SUBTRACT 1

Definition at line 45 of file vtkImageMathematics.h.

#define VTK_MULTIPLY 2

Definition at line 46 of file vtkImageMathematics.h.

#define VTK_DIVIDE 3

Definition at line 47 of file vtkImageMathematics.h.

#define VTK_INVERT 4

Definition at line 48 of file vtkImageMathematics.h.

#define VTK_SIN 5

Definition at line 49 of file vtkImageMathematics.h.

#define VTK_COS 6

Definition at line 50 of file vtkImageMathematics.h.

#define VTK_EXP 7

Definition at line 51 of file vtkImageMathematics.h.

#define VTK_LOG 8

Definition at line 52 of file vtkImageMathematics.h.

#define VTK_ABS 9

Definition at line 53 of file vtkImageMathematics.h.

#define VTK_SQR 10

Definition at line 54 of file vtkImageMathematics.h.

#define VTK_SQRT 11

Definition at line 55 of file vtkImageMathematics.h.

#define VTK_MIN 12

Definition at line 56 of file vtkImageMathematics.h.

#define VTK_MAX 13

Definition at line 57 of file vtkImageMathematics.h.

#define VTK_ATAN 14

Definition at line 58 of file vtkImageMathematics.h.

#define VTK_ATAN2 15

Definition at line 59 of file vtkImageMathematics.h.

#define VTK_MULTIPLYBYK 16

Definition at line 60 of file vtkImageMathematics.h.

#define VTK_ADDC 17

Definition at line 61 of file vtkImageMathematics.h.

#define VTK_CONJUGATE 18

Definition at line 62 of file vtkImageMathematics.h.

#define VTK_COMPLEX_MULTIPLY 19

Definition at line 63 of file vtkImageMathematics.h.

#define VTK_REPLACECBYK 20

Definition at line 64 of file vtkImageMathematics.h.

Generated on Mon Mar 25 01:13:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMedian3D.h File Reference

Imaging/vtkImageMedian3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageMedian3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMedian3D
Median Filter. More...

Generated on Mon Mar 25 01:13:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMirrorPad.h File Reference

Imaging/vtkImageMirrorPad.h File Reference

#include "vtkImagePadFilter.h"

Include dependency graph for vtkImageMirrorPad.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMirrorPad
Extra pixels are filled by mirror images. More...

Generated on Mon Mar 25 01:13:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNoiseSource.h File Reference

Imaging/vtkImageNoiseSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageNoiseSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageNoiseSource
Create an image filled with noise. More...

Generated on Mon Mar 25 01:13:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNonMaximumSuppression.h File Reference

Imaging/vtkImageNonMaximumSuppression.h File Reference

#include "vtkImageTwoInputFilter.h"

Include dependency graph for vtkImageNonMaximumSuppression.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageNonMaximumSuppression
Performs non-maximum suppression. More...

Defines

#define | VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_MAGNITUDE_INPUT 0
#define | VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_VECTOR_INPUT 1

Define Documentation

#define VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_MAGNITUDE_INPUT 0

Definition at line 43 of file vtkImageNonMaximumSuppression.h.

#define VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_VECTOR_INPUT 1

Definition at line 44 of file vtkImageNonMaximumSuppression.h.

Generated on Mon Mar 25 01:13:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNormalize.h File Reference

Imaging/vtkImageNormalize.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageNormalize.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageNormalize
Normalizes that scalar components for each point. More...

Generated on Mon Mar 25 01:13:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageOpenClose3D.h File Reference

Imaging/vtkImageOpenClose3D.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkImageDilateErode3D.h"

Include dependency graph for vtkImageOpenClose3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageOpenClose3D
Will perform opening or closing. More...

Generated on Mon Mar 25 01:13:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagePadFilter.h File Reference

Imaging/vtkImagePadFilter.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImagePadFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImagePadFilter
Super class for filters that fill in extra pixels. More...

Generated on Mon Mar 25 01:13:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagePermute.h File Reference

Imaging/vtkImagePermute.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImagePermute.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImagePermute
Permutes axes of input. More...

Generated on Mon Mar 25 01:13:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageQuantizeRGBToIndex.h File Reference

Imaging/vtkImageQuantizeRGBToIndex.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkLookupTable.h"

Include dependency graph for vtkImageQuantizeRGBToIndex.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageQuantizeRGBToIndex
generalized histograms up to 4 dimensions. More...

Generated on Mon Mar 25 01:13:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRange3D.h File Reference

Imaging/vtkImageRange3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageRange3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageRange3D
Max - min of a circular neighborhood. More...

Generated on Mon Mar 25 01:13:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageResample.h File Reference

Imaging/vtkImageResample.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageResample.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageResample
Resamples an image to be larger or smaller. More...

Generated on Mon Mar 25 01:13:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReslice.h File Reference

Imaging/vtkImageReslice.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkAbstractTransform.h"
#include "vtkMatrix4x4.h"
#include "vtkImageStencilData.h"

Include dependency graph for vtkImageReslice.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkImageReslice
Reslices a volume along a new set of axes. More...

Defines

#define | VTK_RESLICE_NEAREST 0
#define | VTK_RESLICE_LINEAR 1
#define | VTK_RESLICE_CUBIC 3

Define Documentation

#define VTK_RESLICE_NEAREST 0

Definition at line 74 of file vtkImageReslice.h.

#define VTK_RESLICE_LINEAR 1

Definition at line 75 of file vtkImageReslice.h.

#define VTK_RESLICE_CUBIC 3

Definition at line 76 of file vtkImageReslice.h.

Generated on Mon Mar 25 01:13:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRFFT.h File Reference

Imaging/vtkImageRFFT.h File Reference

#include "vtkImageFourierFilter.h"

Include dependency graph for vtkImageRFFT.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageRFFT
Reverse Fast Fourier Transform. More...

Generated on Mon Mar 25 01:13:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRGBToHSV.h File Reference

Imaging/vtkImageRGBToHSV.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageRGBToHSV.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageRGBToHSV
Converts RGB components to HSV. More...

Generated on Mon Mar 25 01:13:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSeedConnectivity.h File Reference

Imaging/vtkImageSeedConnectivity.h File Reference

#include "vtkImageConnector.h"
#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageSeedConnectivity.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSeedConnectivity
SeedConnectivity with user defined seeds. More...

Generated on Mon Mar 25 01:13:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSeparableConvolution.h File Reference

Imaging/vtkImageSeparableConvolution.h File Reference

#include "vtkImageDecomposeFilter.h"
#include "vtkFloatArray.h"

Include dependency graph for vtkImageSeparableConvolution.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSeparableConvolution
3 1D convolutions on an image. More...

Generated on Mon Mar 25 01:13:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageShiftScale.h File Reference

Imaging/vtkImageShiftScale.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageShiftScale.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageShiftScale
shift and scale an input image. More...

Generated on Mon Mar 25 01:13:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageShrink3D.h File Reference

Imaging/vtkImageShrink3D.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageShrink3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageShrink3D
Subsamples an image. More...

Generated on Mon Mar 25 01:13:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSinusoidSource.h File Reference

Imaging/vtkImageSinusoidSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageSinusoidSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSinusoidSource
Create an image with sinusoidal pixel values. More...

Generated on Mon Mar 25 01:13:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSkeleton2D.h File Reference

Imaging/vtkImageSkeleton2D.h File Reference

#include "vtkImageIterateFilter.h"

Include dependency graph for vtkImageSkeleton2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSkeleton2D
Skeleton of 2D images. More...

Generated on Mon Mar 25 01:13:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSobel2D.h File Reference

Imaging/vtkImageSobel2D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageSobel2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSobel2D
Computes a vector field using sobel functions. More...

Generated on Mon Mar 25 01:13:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSobel3D.h File Reference

Imaging/vtkImageSobel3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageSobel3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageSobel3D
Computes a vector field using sobel functions. More...

Generated on Mon Mar 25 01:13:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSpatialFilter.h File Reference

Imaging/vtkImageSpatialFilter.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageSpatialFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageSpatialFilter
Filters that operate on pixel neighborhoods. More...

Generated on Mon Mar 25 01:13:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencil.h File Reference

Imaging/vtkImageStencil.h File Reference

#include "vtkImageToImageFilter.h"
#include "vtkImageStencilData.h"

Include dependency graph for vtkImageStencil.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageStencil
combine images via a cookie-cutter operation. More...

Generated on Mon Mar 25 01:13:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencilData.h File Reference

Imaging/vtkImageStencilData.h File Reference

#include "vtkDataObject.h"

Include dependency graph for vtkImageStencilData.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageStencilData
efficient description of an image stencil. More...

Generated on Mon Mar 25 01:13:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencilSource.h File Reference

Imaging/vtkImageStencilSource.h File Reference

#include "vtkSource.h"
#include "vtkImageStencilData.h"

Include dependency graph for vtkImageStencilSource.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageStencilSource
helper class for clipping images. More...

Generated on Mon Mar 25 01:13:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageThreshold.h File Reference

Imaging/vtkImageThreshold.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageThreshold.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageThreshold
Flexible threshold. More...

Generated on Mon Mar 25 01:13:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToImageStencil.h File Reference

Imaging/vtkImageToImageStencil.h File Reference

#include "vtkImageStencilSource.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageToImageStencil.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageToImageStencil
clip an image with a mask image. More...

Generated on Mon Mar 25 01:13:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageTranslateExtent.h File Reference

Imaging/vtkImageTranslateExtent.h File Reference

#include "vtkImageToImageFilter.h"

Include dependency graph for vtkImageTranslateExtent.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageTranslateExtent
Changes extent, nothing else. More...

Generated on Mon Mar 25 01:13:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageVariance3D.h File Reference

Imaging/vtkImageVariance3D.h File Reference

#include "vtkImageSpatialFilter.h"

Include dependency graph for vtkImageVariance3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageVariance3D
Variance in a neighborhood. More...

Generated on Mon Mar 25 01:13:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWrapPad.h File Reference

Imaging/vtkImageWrapPad.h File Reference

#include "vtkImagePadFilter.h"

Include dependency graph for vtkImageWrapPad.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageWrapPad
Makes an image larger by wrapping existing data. More...

Generated on Mon Mar 25 01:13:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunctionToImageStencil.h File Reference

Imaging/vtkImplicitFunctionToImageStencil.h File Reference

#include "vtkImageStencilSource.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkImplicitFunctionToImageStencil.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImplicitFunctionToImageStencil
clip an image with a function. More...

Generated on Mon Mar 25 01:13:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLoad.h File Reference

Imaging/vtkPointLoad.h File Reference

#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkPointLoad.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPointLoad
compute stress tensors given point load on semi-infinite domain. More...

Generated on Mon Mar 25 01:13:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSampleFunction.h File Reference

Imaging/vtkSampleFunction.h File Reference

#include "vtkStructuredPointsSource.h"
#include "vtkImplicitFunction.h"

Include dependency graph for vtkSampleFunction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSampleFunction
sample an implicit function over a structured point set. More...

Generated on Mon Mar 25 01:13:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShepardMethod.h File Reference

Imaging/vtkShepardMethod.h File Reference

#include "vtkDataSetToStructuredPointsFilter.h"

Include dependency graph for vtkShepardMethod.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkShepardMethod
sample unstructured points onto structured points using the method of Shepard. More...

Generated on Mon Mar 25 01:13:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleImageFilterExample.h File Reference

Imaging/vtkSimpleImageFilterExample.h File Reference

#include "vtkSimpleImageToImageFilter.h"

Include dependency graph for vtkSimpleImageFilterExample.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSimpleImageFilterExample
Simple example of an image-image filter. More...

Generated on Mon Mar 25 01:13:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSurfaceReconstructionFilter.h File Reference

Imaging/vtkSurfaceReconstructionFilter.h File Reference

#include "vtkDataSetToStructuredPointsFilter.h"

Include dependency graph for vtkSurfaceReconstructionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSurfaceReconstructionFilter
reconstructs a surface from unorganized points. More...

Generated on Mon Mar 25 01:13:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangularTexture.h File Reference

Imaging/vtkTriangularTexture.h File Reference

#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkTriangularTexture.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTriangularTexture
generate 2D triangular texture map. More...

Generated on Mon Mar 25 01:13:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxelModeller.h File Reference

Imaging/vtkVoxelModeller.h File Reference

#include "vtkDataSetToStructuredPointsFilter.h"

Include dependency graph for vtkVoxelModeller.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVoxelModeller
convert an arbitrary dataset to a voxel representation. More...

Generated on Mon Mar 25 01:13:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtk3DS.h File Reference

IO/vtk3DS.h File Reference

#include <ctype.h>

Include dependency graph for vtk3DS.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | List
struct | Face
struct | Colour
struct | OmniLight
struct | SpotLight
struct | Camera
struct | Material
struct | Summary
struct | MatProp
struct | Mesh
struct | Chunk
struct | Colour_24

Defines

#define | VTK_LIST_INSERT(root, node) list_insert ((List **)&root, reinterpret_cast<List *>(node))
#define | VTK_LIST_FIND(root, name) list_find ((List **)&root, name)
#define | VTK_LIST_DELETE(root, node) list_delete ((List **)&root, (List *)node)
#define | VTK_LIST_KILL(root) list_kill ((List **)&root)
#define | VTK_LIST_FIELDS

Typedefs

typedef float | Vector [3]
typedef unsigned char | byte
typedef unsigned short | word
typedef unsigned int | dword

Define Documentation

#define VTK_LIST_INSERT | ( | root,
 |  | node | ) | list_insert ((List **)&root, reinterpret_cast<List *>(node))

Definition at line 22 of file vtk3DS.h.

#define VTK_LIST_FIND | ( | root,
 |  | name | ) | list_find ((List **)&root, name)

Definition at line 23 of file vtk3DS.h.

#define VTK_LIST_DELETE | ( | root,
 |  | node | ) | list_delete ((List **)&root, (List *)node)

Definition at line 24 of file vtk3DS.h.

#define VTK_LIST_KILL ( root ) list_kill ((List **)&root)

Definition at line 25 of file vtk3DS.h.

#define VTK_LIST_FIELDS

Value:

char name[80];   \
    void *next;

Definition at line 27 of file vtk3DS.h.

Typedef Documentation

typedef float Vector[3]

Definition at line 19 of file vtk3DS.h.

typedef unsigned char byte

Definition at line 32 of file vtk3DS.h.

typedef unsigned short word

Definition at line 33 of file vtk3DS.h.

typedef unsigned int dword

Definition at line 34 of file vtk3DS.h.

Generated on Mon Mar 25 01:13:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBMPReader.h File Reference

IO/vtkBMPReader.h File Reference

#include <stdio.h>
#include "vtkImageReader.h"

Include dependency graph for vtkBMPReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBMPReader
read Windows BMP files. More...

Generated on Mon Mar 25 01:13:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBMPWriter.h File Reference

IO/vtkBMPWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkBMPWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBMPWriter
Writes Windows BMP files. More...

Generated on Mon Mar 25 01:13:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBYUReader.h File Reference

IO/vtkBYUReader.h File Reference

#include <stdio.h>
#include "vtkPolyDataSource.h"

Include dependency graph for vtkBYUReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBYUReader
read MOVIE.BYU polygon files. More...

Generated on Mon Mar 25 01:13:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBYUWriter.h File Reference

IO/vtkBYUWriter.h File Reference

#include <stdio.h>
#include "vtkPolyDataWriter.h"
#include "vtkPolyData.h"

Include dependency graph for vtkBYUWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBYUWriter
write MOVIE.BYU files. More...

Generated on Mon Mar 25 01:13:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCGMWriter.h File Reference

IO/vtkCGMWriter.h File Reference

#include "vtkPolyDataWriter.h"
#include "vtkViewport.h"

Include dependency graph for vtkCGMWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkCGMWriter
write polygonal data as a CGM file. More...

Defines

#define | VTK_COLOR_MODE_DEFAULT 0
#define | VTK_COLOR_MODE_SPECIFIED_COLOR 1
#define | VTK_COLOR_MODE_RANDOM_COLORS 2

Define Documentation

#define VTK_COLOR_MODE_DEFAULT 0

Definition at line 53 of file vtkCGMWriter.h.

#define VTK_COLOR_MODE_SPECIFIED_COLOR 1

Definition at line 54 of file vtkCGMWriter.h.

#define VTK_COLOR_MODE_RANDOM_COLORS 2

Definition at line 55 of file vtkCGMWriter.h.

Generated on Mon Mar 25 01:13:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectReader.h File Reference

IO/vtkDataObjectReader.h File Reference

#include "vtkDataReader.h"
#include "vtkDataObject.h"

Include dependency graph for vtkDataObjectReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataObjectReader
read vtk field data file. More...

Generated on Mon Mar 25 01:13:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectWriter.h File Reference

IO/vtkDataObjectWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkFieldData.h"

Include dependency graph for vtkDataObjectWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataObjectWriter
write vtk field data. More...

Generated on Mon Mar 25 01:13:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataReader.h File Reference

IO/vtkDataReader.h File Reference

#include "vtkSource.h"
#include "vtkDataSetAttributes.h"
#include "vtkCharArray.h"

Include dependency graph for vtkDataReader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkDataReader
helper superclass for objects that read vtk data files. More...

Defines

#define | VTK_ASCII 1
#define | VTK_BINARY 2

Define Documentation

#define VTK_ASCII 1

Definition at line 47 of file vtkDataReader.h.

#define VTK_BINARY 2

Definition at line 48 of file vtkDataReader.h.

Generated on Mon Mar 25 01:13:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetReader.h File Reference

IO/vtkDataSetReader.h File Reference

#include "vtkDataReader.h"
#include "vtkDataSet.h"

Include dependency graph for vtkDataSetReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetReader
class to read any type of vtk dataset. More...

Generated on Mon Mar 25 01:13:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetWriter.h File Reference

IO/vtkDataSetWriter.h File Reference

#include "vtkDataWriter.h"

Include dependency graph for vtkDataSetWriter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetWriter
write any type of vtk dataset to file. More...

Generated on Mon Mar 25 01:13:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataWriter.h File Reference

IO/vtkDataWriter.h File Reference

#include <stdio.h>
#include "vtkWriter.h"

Include dependency graph for vtkDataWriter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDataWriter
helper class for objects that write vtk data files. More...

Generated on Mon Mar 25 01:13:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDEMReader.h File Reference

IO/vtkDEMReader.h File Reference

#include <stdio.h>
#include "vtkImageSource.h"

Include dependency graph for vtkDEMReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDEMReader
read a digital elevation model (DEM) file. More...

Generated on Mon Mar 25 01:13:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSight6BinaryReader.h File Reference

IO/vtkEnSight6BinaryReader.h File Reference

#include "vtkEnSightReader.h"

Include dependency graph for vtkEnSight6BinaryReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEnSight6BinaryReader
class to read binary EnSight6 files. More...

Generated on Mon Mar 25 01:13:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSight6Reader.h File Reference

IO/vtkEnSight6Reader.h File Reference

#include "vtkEnSightReader.h"

Include dependency graph for vtkEnSight6Reader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEnSight6Reader
class to read EnSight6 files. More...

Generated on Mon Mar 25 01:13:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightGoldBinaryReader.h File Reference

IO/vtkEnSightGoldBinaryReader.h File Reference

#include "vtkEnSightReader.h"

Include dependency graph for vtkEnSightGoldBinaryReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEnSightGoldBinaryReader
class to read binary EnSight Gold files. More...

Generated on Mon Mar 25 01:13:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightGoldReader.h File Reference

IO/vtkEnSightGoldReader.h File Reference

#include "vtkEnSightReader.h"

Include dependency graph for vtkEnSightGoldReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkEnSightGoldReader
class to read EnSight Gold files. More...

Generated on Mon Mar 25 01:13:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightReader.h File Reference

IO/vtkEnSightReader.h File Reference

#include "vtkDataSetSource.h"
#include "vtkCollection.h"

Include dependency graph for vtkEnSightReader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkEnSightReader
superclass for EnSight file readers. More...

Defines

#define | VTK_ENSIGHT_POINT 0
#define | VTK_ENSIGHT_BAR2 1
#define | VTK_ENSIGHT_BAR3 2
#define | VTK_ENSIGHT_NSIDED 3
#define | VTK_ENSIGHT_TRIA3 4
#define | VTK_ENSIGHT_TRIA6 5
#define | VTK_ENSIGHT_QUAD4 6
#define | VTK_ENSIGHT_QUAD8 7
#define | VTK_ENSIGHT_TETRA4 8
#define | VTK_ENSIGHT_TETRA10 9
#define | VTK_ENSIGHT_PYRAMID5 10
#define | VTK_ENSIGHT_PYRAMID13 11
#define | VTK_ENSIGHT_HEXA8 12
#define | VTK_ENSIGHT_HEXA20 13
#define | VTK_ENSIGHT_PENTA6 14
#define | VTK_ENSIGHT_PENTA15 15
#define | VTK_SCALAR_PER_NODE 0
#define | VTK_VECTOR_PER_NODE 1
#define | VTK_TENSOR_SYMM_PER_NODE 2
#define | VTK_SCALAR_PER_ELEMENT 3
#define | VTK_VECTOR_PER_ELEMENT 4
#define | VTK_TENSOR_SYMM_PER_ELEMENT 5
#define | VTK_SCALAR_PER_MEASURED_NODE 6
#define | VTK_VECTOR_PER_MEASURED_NODE 7
#define | VTK_COMPLEX_SCALAR_PER_NODE 8
#define | VTK_COMPLEX_VECTOR_PER_NODE 9
#define | VTK_COMPLEX_SCALAR_PER_ELEMENT 10
#define | VTK_COMPLEX_VECTOR_PER_ELEMENT 11

Define Documentation

#define VTK_ENSIGHT_POINT 0

Definition at line 36 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_BAR2 1

Definition at line 37 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_BAR3 2

Definition at line 38 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_NSIDED 3

Definition at line 39 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_TRIA3 4

Definition at line 40 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_TRIA6 5

Definition at line 41 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_QUAD4 6

Definition at line 42 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_QUAD8 7

Definition at line 43 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_TETRA4 8

Definition at line 44 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_TETRA10 9

Definition at line 45 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_PYRAMID5 10

Definition at line 46 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_PYRAMID13 11

Definition at line 47 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_HEXA8 12

Definition at line 48 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_HEXA20 13

Definition at line 49 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_PENTA6 14

Definition at line 50 of file vtkEnSightReader.h.

#define VTK_ENSIGHT_PENTA15 15

Definition at line 51 of file vtkEnSightReader.h.

#define VTK_SCALAR_PER_NODE 0

Definition at line 54 of file vtkEnSightReader.h.

#define VTK_VECTOR_PER_NODE 1

Definition at line 55 of file vtkEnSightReader.h.

#define VTK_TENSOR_SYMM_PER_NODE 2

Definition at line 56 of file vtkEnSightReader.h.

#define VTK_SCALAR_PER_ELEMENT 3

Definition at line 57 of file vtkEnSightReader.h.

#define VTK_VECTOR_PER_ELEMENT 4

Definition at line 58 of file vtkEnSightReader.h.

#define VTK_TENSOR_SYMM_PER_ELEMENT 5

Definition at line 59 of file vtkEnSightReader.h.

#define VTK_SCALAR_PER_MEASURED_NODE 6

Definition at line 60 of file vtkEnSightReader.h.

#define VTK_VECTOR_PER_MEASURED_NODE 7

Definition at line 61 of file vtkEnSightReader.h.

#define VTK_COMPLEX_SCALAR_PER_NODE 8

Definition at line 62 of file vtkEnSightReader.h.

#define VTK_COMPLEX_VECTOR_PER_NODE 9

Definition at line 63 of file vtkEnSightReader.h.

#define VTK_COMPLEX_SCALAR_PER_ELEMENT 10

Definition at line 64 of file vtkEnSightReader.h.

#define VTK_COMPLEX_VECTOR_PER_ELEMENT 11

Definition at line 65 of file vtkEnSightReader.h.

Generated on Mon Mar 25 01:13:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGenericEnSightReader.h File Reference

IO/vtkGenericEnSightReader.h File Reference

#include "vtkEnSightReader.h"

Include dependency graph for vtkGenericEnSightReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkGenericEnSightReader
class to read any type of EnSight files. More...

Defines

#define | VTK_ENSIGHT_6 0
#define | VTK_ENSIGHT_6_BINARY 1
#define | VTK_ENSIGHT_GOLD 2
#define | VTK_ENSIGHT_GOLD_BINARY 3

Define Documentation

#define VTK_ENSIGHT_6 0

Definition at line 40 of file vtkGenericEnSightReader.h.

#define VTK_ENSIGHT_6_BINARY 1

Definition at line 41 of file vtkGenericEnSightReader.h.

#define VTK_ENSIGHT_GOLD 2

Definition at line 42 of file vtkGenericEnSightReader.h.

#define VTK_ENSIGHT_GOLD_BINARY 3

Definition at line 43 of file vtkGenericEnSightReader.h.

Generated on Mon Mar 25 01:13:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGESignaReader.h File Reference

IO/vtkGESignaReader.h File Reference

#include <stdio.h>
#include "vtkMedicalImageReader2.h"

Include dependency graph for vtkGESignaReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGESignaReader
read GE Signa ximg files. More...

Generated on Mon Mar 25 01:13:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader.h File Reference

IO/vtkImageReader.h File Reference

#include "vtkImageReader2.h"
#include "vtkTransform.h"

Include dependency graph for vtkImageReader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkImageReader
Superclass of transformable binary file readers. More...

Defines

#define | VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
#define | VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Define Documentation

#define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 50 of file vtkImageReader.h.

#define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 51 of file vtkImageReader.h.

Generated on Mon Mar 25 01:13:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2.h File Reference

IO/vtkImageReader2.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageReader2.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkImageReader2
Superclass of binary file readers. More...

Defines

#define | VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
#define | VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Define Documentation

#define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 44 of file vtkImageReader2.h.

#define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 45 of file vtkImageReader2.h.

Generated on Mon Mar 25 01:13:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2Collection.h File Reference

IO/vtkImageReader2Collection.h File Reference

#include "vtkCollection.h"
#include "vtkImageReader2.h"

Include dependency graph for vtkImageReader2Collection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageReader2Collection
maintain a list of implicit functions. More...

Generated on Mon Mar 25 01:13:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2Factory.h File Reference

IO/vtkImageReader2Factory.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkImageReader2Factory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageReader2Factory
Superclass of binary file readers. More...

Generated on Mon Mar 25 01:13:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWriter.h File Reference

IO/vtkImageWriter.h File Reference

#include "vtkProcessObject.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageWriter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageWriter
Writes images to files. More...

Generated on Mon Mar 25 01:13:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIVWriter.h File Reference

IO/vtkIVWriter.h File Reference

#include "vtkPolyDataWriter.h"

Include dependency graph for vtkIVWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkIVWriter
export polydata into OpenInventor 2.0 format. More...

Generated on Mon Mar 25 01:13:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJPEGReader.h File Reference

IO/vtkJPEGReader.h File Reference

#include <stdio.h>
#include "vtkImageReader2.h"

Include dependency graph for vtkJPEGReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkJPEGReader
read JPEG files. More...

Generated on Mon Mar 25 01:13:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJPEGWriter.h File Reference

IO/vtkJPEGWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkJPEGWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkJPEGWriter
Writes JPEG files. More...

Generated on Mon Mar 25 01:13:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMCubesReader.h File Reference

IO/vtkMCubesReader.h File Reference

#include <stdio.h>
#include "vtkPolyDataSource.h"
#include "vtkPoints.h"
#include "vtkCellArray.h"

Include dependency graph for vtkMCubesReader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkMCubesReader
read binary marching cubes file. More...

Defines

#define | VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
#define | VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Define Documentation

#define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 76 of file vtkMCubesReader.h.

#define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 77 of file vtkMCubesReader.h.

Generated on Mon Mar 25 01:13:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMCubesWriter.h File Reference

IO/vtkMCubesWriter.h File Reference

#include <stdio.h>
#include "vtkPolyDataWriter.h"

Include dependency graph for vtkMCubesWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMCubesWriter
write binary marching cubes file. More...

Generated on Mon Mar 25 01:13:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMedicalImageReader2.h File Reference

IO/vtkMedicalImageReader2.h File Reference

#include "vtkImageReader2.h"

Include dependency graph for vtkMedicalImageReader2.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMedicalImageReader2
vtkImageReader2 with medical meta data. More...

Generated on Mon Mar 25 01:13:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBJReader.h File Reference

IO/vtkOBJReader.h File Reference

#include <stdio.h>
#include "vtkPolyDataSource.h"

Include dependency graph for vtkOBJReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOBJReader
read Wavefront .obj files. More...

Generated on Mon Mar 25 01:13:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParticleReader.h File Reference

IO/vtkParticleReader.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkParticleReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkParticleReader
Read raw particle data and one array. More...

Defines

#define | VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
#define | VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Define Documentation

#define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 46 of file vtkParticleReader.h.

#define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 47 of file vtkParticleReader.h.

Generated on Mon Mar 25 01:13:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLOT3DReader.h File Reference

IO/vtkPLOT3DReader.h File Reference

#include <stdio.h>
#include "vtkStructuredGridSource.h"
#include "vtkIntArray.h"

Include dependency graph for vtkPLOT3DReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkPLOT3DReader
read PLOT3D data files. More...

Defines

#define | VTK_WHOLE_SINGLE_GRID_NO_IBLANKING 0
#define | VTK_WHOLE_MULTI_GRID_NO_IBLANKING 2

Define Documentation

#define VTK_WHOLE_SINGLE_GRID_NO_IBLANKING 0

Definition at line 106 of file vtkPLOT3DReader.h.

#define VTK_WHOLE_MULTI_GRID_NO_IBLANKING 2

Definition at line 107 of file vtkPLOT3DReader.h.

Generated on Mon Mar 25 01:13:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLY.h File Reference

IO/vtkPLY.h File Reference

#include <stdio.h>
#include <stddef.h>
#include "vtkObject.h"

Include dependency graph for vtkPLY.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | PlyProperty
struct | PlyElement
struct | PlyOtherProp
struct | OtherData
struct | OtherElem
struct | PlyOtherElems
struct | PlyFile
class | vtkPLY
a modified version of the PLY 1.1 library. More...

Defines

#define | PLY_ASCII 1
#define | PLY_BINARY_BE 2
#define | PLY_BINARY_LE 3
#define | PLY_OKAY 0
#define | PLY_ERROR -1
#define | PLY_START_TYPE 0
#define | PLY_CHAR 1
#define | PLY_SHORT 2
#define | PLY_INT 3
#define | PLY_UCHAR 4
#define | PLY_USHORT 5
#define | PLY_UINT 6
#define | PLY_FLOAT 7
#define | PLY_DOUBLE 8
#define | PLY_END_TYPE 9
#define | PLY_SCALAR 0
#define | PLY_LIST 1
#define | myalloc(mem_size) vtkPLY::my_alloc((mem_size), __LINE__, __FILE__)

Typedefs

typedef PlyProperty | PlyProperty
typedef PlyElement | PlyElement
typedef PlyOtherProp | PlyOtherProp
typedef OtherData | OtherData
typedef OtherElem | OtherElem
typedef PlyOtherElems | PlyOtherElems
typedef PlyFile | PlyFile

Define Documentation

#define PLY_ASCII 1

Definition at line 81 of file vtkPLY.h.

#define PLY_BINARY_BE 2

Definition at line 82 of file vtkPLY.h.

#define PLY_BINARY_LE 3

Definition at line 83 of file vtkPLY.h.

#define PLY_OKAY 0

Definition at line 85 of file vtkPLY.h.

#define PLY_ERROR -1

Definition at line 86 of file vtkPLY.h.

#define PLY_START_TYPE 0

Definition at line 90 of file vtkPLY.h.

#define PLY_CHAR 1

Definition at line 91 of file vtkPLY.h.

#define PLY_SHORT 2

Definition at line 92 of file vtkPLY.h.

#define PLY_INT 3

Definition at line 93 of file vtkPLY.h.

#define PLY_UCHAR 4

Definition at line 94 of file vtkPLY.h.

#define PLY_USHORT 5

Definition at line 95 of file vtkPLY.h.

#define PLY_UINT 6

Definition at line 96 of file vtkPLY.h.

#define PLY_FLOAT 7

Definition at line 97 of file vtkPLY.h.

#define PLY_DOUBLE 8

Definition at line 98 of file vtkPLY.h.

#define PLY_END_TYPE 9

Definition at line 99 of file vtkPLY.h.

#define PLY_SCALAR 0

Definition at line 101 of file vtkPLY.h.

#define PLY_LIST 1

Definition at line 102 of file vtkPLY.h.

#define myalloc ( mem_size ) vtkPLY::my_alloc((mem_size), __LINE__, __FILE__)

Definition at line 167 of file vtkPLY.h.

Typedef Documentation

typedef struct PlyProperty PlyProperty

typedef struct PlyElement PlyElement

typedef struct PlyOtherProp PlyOtherProp

typedef struct OtherData OtherData

typedef struct OtherElem OtherElem

typedef struct PlyOtherElems PlyOtherElems

typedef struct PlyFile PlyFile

Generated on Mon Mar 25 01:13:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLYReader.h File Reference

IO/vtkPLYReader.h File Reference

#include "vtkPolyDataSource.h"

Include dependency graph for vtkPLYReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPLYReader
read Stanford University PLY polygonal file format. More...

Generated on Mon Mar 25 01:13:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLYWriter.h File Reference

IO/vtkPLYWriter.h File Reference

#include "vtkPolyDataWriter.h"
#include "vtkPolyData.h"
#include "vtkScalarsToColors.h"

Include dependency graph for vtkPLYWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkPLYWriter
write Stanford PLY file format. More...

Defines

#define | VTK_LITTLE_ENDIAN 0
#define | VTK_BIG_ENDIAN 1
#define | VTK_COLOR_MODE_DEFAULT 0
#define | VTK_COLOR_MODE_UNIFORM_CELL_COLOR 1
#define | VTK_COLOR_MODE_UNIFORM_POINT_COLOR 2
#define | VTK_COLOR_MODE_UNIFORM_COLOR 3
#define | VTK_COLOR_MODE_OFF 4

Define Documentation

#define VTK_LITTLE_ENDIAN 0

Definition at line 51 of file vtkPLYWriter.h.

#define VTK_BIG_ENDIAN 1

Definition at line 52 of file vtkPLYWriter.h.

#define VTK_COLOR_MODE_DEFAULT 0

Definition at line 54 of file vtkPLYWriter.h.

#define VTK_COLOR_MODE_UNIFORM_CELL_COLOR 1

Definition at line 55 of file vtkPLYWriter.h.

#define VTK_COLOR_MODE_UNIFORM_POINT_COLOR 2

Definition at line 56 of file vtkPLYWriter.h.

#define VTK_COLOR_MODE_UNIFORM_COLOR 3

Definition at line 57 of file vtkPLYWriter.h.

#define VTK_COLOR_MODE_OFF 4

Definition at line 58 of file vtkPLYWriter.h.

Generated on Mon Mar 25 01:13:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNGReader.h File Reference

IO/vtkPNGReader.h File Reference

#include <stdio.h>
#include "vtkImageReader2.h"

Include dependency graph for vtkPNGReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPNGReader
read PNG files. More...

Generated on Mon Mar 25 01:13:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNGWriter.h File Reference

IO/vtkPNGWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkPNGWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPNGWriter
Writes PNG files. More...

Generated on Mon Mar 25 01:13:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNMReader.h File Reference

IO/vtkPNMReader.h File Reference

#include <stdio.h>
#include "vtkImageReader.h"

Include dependency graph for vtkPNMReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPNMReader
read pnm (i.e., portable anymap) files. More...

Generated on Mon Mar 25 01:13:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNMWriter.h File Reference

IO/vtkPNMWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkPNMWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPNMWriter
Writes PNM (portable any map) files. More...

Generated on Mon Mar 25 01:13:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataReader.h File Reference

IO/vtkPolyDataReader.h File Reference

#include "vtkDataReader.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataReader
read vtk polygonal data file. More...

Generated on Mon Mar 25 01:13:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataWriter.h File Reference

IO/vtkPolyDataWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataWriter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataWriter
write vtk polygonal data. More...

Generated on Mon Mar 25 01:13:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPostScriptWriter.h File Reference

IO/vtkPostScriptWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkPostScriptWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPostScriptWriter
Writes an image as a PostScript file. More...

Generated on Mon Mar 25 01:13:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridReader.h File Reference

IO/vtkRectilinearGridReader.h File Reference

#include "vtkDataReader.h"
#include "vtkRectilinearGrid.h"

Include dependency graph for vtkRectilinearGridReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridReader
read vtk rectilinear grid data file. More...

Generated on Mon Mar 25 01:13:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridWriter.h File Reference

IO/vtkRectilinearGridWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkRectilinearGrid.h"

Include dependency graph for vtkRectilinearGridWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridWriter
write vtk rectilinear grid data file. More...

Generated on Mon Mar 25 01:13:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSLCReader.h File Reference

IO/vtkSLCReader.h File Reference

#include <stdio.h>
#include "vtkImageReader2.h"

Include dependency graph for vtkSLCReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSLCReader
read an SLC volume file. More...

Generated on Mon Mar 25 01:13:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSTLReader.h File Reference

IO/vtkSTLReader.h File Reference

#include <stdio.h>
#include "vtkPolyDataSource.h"
#include "vtkPoints.h"
#include "vtkCellArray.h"

Include dependency graph for vtkSTLReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSTLReader
read ASCII or binary stereo lithography files. More...

Generated on Mon Mar 25 01:13:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSTLWriter.h File Reference

IO/vtkSTLWriter.h File Reference

#include <stdio.h>
#include "vtkPolyDataWriter.h"
#include "vtkPolyData.h"

Include dependency graph for vtkSTLWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSTLWriter
write stereo lithography files. More...

Generated on Mon Mar 25 01:13:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridReader.h File Reference

IO/vtkStructuredGridReader.h File Reference

#include "vtkDataReader.h"
#include "vtkStructuredGrid.h"

Include dependency graph for vtkStructuredGridReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridReader
read vtk structured grid data file. More...

Generated on Mon Mar 25 01:13:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridWriter.h File Reference

IO/vtkStructuredGridWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkStructuredGrid.h"

Include dependency graph for vtkStructuredGridWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredGridWriter
write vtk structured grid data file. More...

Generated on Mon Mar 25 01:13:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsReader.h File Reference

IO/vtkStructuredPointsReader.h File Reference

#include "vtkDataReader.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkStructuredPointsReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsReader
read vtk structured points data file. More...

Generated on Mon Mar 25 01:13:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsWriter.h File Reference

IO/vtkStructuredPointsWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkImageData.h"

Include dependency graph for vtkStructuredPointsWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkStructuredPointsWriter
write vtk structured points data file. More...

Generated on Mon Mar 25 01:13:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTIFFReader.h File Reference

IO/vtkTIFFReader.h File Reference

#include <stdio.h>
#include "vtkImageReader2.h"

Include dependency graph for vtkTIFFReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTIFFReader
read TIFF files. More...

Generated on Mon Mar 25 01:13:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTIFFWriter.h File Reference

IO/vtkTIFFWriter.h File Reference

#include <stdio.h>
#include "vtkImageWriter.h"

Include dependency graph for vtkTIFFWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTIFFWriter
write out structured points as a TIFF file. More...

Generated on Mon Mar 25 01:13:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUGFacetReader.h File Reference

IO/vtkUGFacetReader.h File Reference

#include <stdio.h>
#include "vtkPolyDataSource.h"
#include "vtkShortArray.h"

Include dependency graph for vtkUGFacetReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUGFacetReader
read EDS Unigraphics facet files. More...

Generated on Mon Mar 25 01:13:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridReader.h File Reference

IO/vtkUnstructuredGridReader.h File Reference

#include "vtkDataReader.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkUnstructuredGridReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGridReader
read vtk unstructured grid data file. More...

Generated on Mon Mar 25 01:13:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridWriter.h File Reference

IO/vtkUnstructuredGridWriter.h File Reference

#include "vtkDataWriter.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkUnstructuredGridWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkUnstructuredGridWriter
write vtk unstructured grid data file. More...

Generated on Mon Mar 25 01:13:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolume16Reader.h File Reference

IO/vtkVolume16Reader.h File Reference

#include <stdio.h>
#include "vtkVolumeReader.h"
#include "vtkTransform.h"

Include dependency graph for vtkVolume16Reader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkVolume16Reader
read 16 bit image files. More...

Defines

#define | VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
#define | VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Define Documentation

#define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0

Definition at line 71 of file vtkVolume16Reader.h.

#define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1

Definition at line 72 of file vtkVolume16Reader.h.

Generated on Mon Mar 25 01:13:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeReader.h File Reference

IO/vtkVolumeReader.h File Reference

#include <stdio.h>
#include "vtkStructuredPointsSource.h"

Include dependency graph for vtkVolumeReader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVolumeReader
read image files. More...

Generated on Mon Mar 25 01:13:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWriter.h File Reference

IO/vtkWriter.h File Reference

#include "vtkProcessObject.h"
#include "vtkDataObject.h"

Include dependency graph for vtkWriter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkWriter
abstract class to write data to file(s). More...

Defines

#define | VTK_ASCII 1
#define | VTK_BINARY 2

Define Documentation

#define VTK_ASCII 1

Definition at line 58 of file vtkWriter.h.

#define VTK_BINARY 2

Definition at line 59 of file vtkWriter.h.

Generated on Mon Mar 25 01:13:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMLParser.h File Reference

IO/vtkXMLParser.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkXMLParser.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXMLParser
Parse XML to handle element tags and attributes. More...

Generated on Mon Mar 25 01:13:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBranchExtentTranslator.h File Reference

Parallel/vtkBranchExtentTranslator.h File Reference

#include "vtkExtentTranslator.h"
#include "vtkImageData.h"

Include dependency graph for vtkBranchExtentTranslator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkBranchExtentTranslator
Uses alternative source for whole extent. More...

Generated on Mon Mar 25 01:13:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCommunicator.h File Reference

Parallel/vtkCommunicator.h File Reference

#include "vtkObject.h"
#include "vtkDataObject.h"
#include "vtkDataArray.h"

Include dependency graph for vtkCommunicator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCommunicator
Used to send/receive messages in a multiprocess/thread environment. More...

Generated on Mon Mar 25 01:13:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCompositeManager.h File Reference

Parallel/vtkCompositeManager.h File Reference

#include "vtkObject.h"
#include "vtkRenderWindow.h"
#include "vtkRenderWindowInteractor.h"
#include "vtkRenderer.h"
#include "vtkMultiProcessController.h"

Include dependency graph for vtkCompositeManager.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCompositeManager
An object to composite multiple render windows. More...

Generated on Mon Mar 25 01:13:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCutMaterial.h File Reference

Parallel/vtkCutMaterial.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkPlane.h"

Include dependency graph for vtkCutMaterial.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkCutMaterial
Automatically computes the cut plane for a material array pair. More...

Generated on Mon Mar 25 01:13:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractPolyDataPiece.h File Reference

Parallel/vtkExtractPolyDataPiece.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"

Include dependency graph for vtkExtractPolyDataPiece.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractPolyDataPiece
Return specified piece, including specified. More...

Generated on Mon Mar 25 01:13:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractUnstructuredGridPiece.h File Reference

Parallel/vtkExtractUnstructuredGridPiece.h File Reference

#include "vtkUnstructuredGridToUnstructuredGridFilter.h"

Include dependency graph for vtkExtractUnstructuredGridPiece.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkExtractUnstructuredGridPiece
Return specified piece, including specified. More...

Generated on Mon Mar 25 01:13:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlockReader.h File Reference

Parallel/vtkImageBlockReader.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkImageBlockReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageBlockReader
Breaks up image into blocks and save in files. More...

Generated on Mon Mar 25 01:13:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlockWriter.h File Reference

Parallel/vtkImageBlockWriter.h File Reference

#include "vtkProcessObject.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageBlockWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageBlockWriter
Breaks up image into blocks and save in files. More...

Generated on Mon Mar 25 01:13:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInputPort.h File Reference

Parallel/vtkInputPort.h File Reference

#include "vtkSource.h"
#include "vtkMultiProcessController.h"

Include dependency graph for vtkInputPort.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkInputPort
Receives data from another process. More...

Generated on Mon Mar 25 01:13:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMemoryLimitImageDataStreamer.h File Reference

Parallel/vtkMemoryLimitImageDataStreamer.h File Reference

#include "vtkImageDataStreamer.h"

Include dependency graph for vtkMemoryLimitImageDataStreamer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMemoryLimitImageDataStreamer

Generated on Mon Mar 25 01:13:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPICommunicator.h File Reference

Parallel/vtkMPICommunicator.h File Reference

#include "mpi.h"
#include "vtkCommunicator.h"
#include "vtkMPIGroup.h"

Include dependency graph for vtkMPICommunicator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkMPICommunicator
Class for creating user defined MPI communicators. More...

class | vtkMPICommunicator::Request

Generated on Mon Mar 25 01:13:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIController.h File Reference

Parallel/vtkMPIController.h File Reference

#include "mpi.h"
#include "vtkMultiProcessController.h"
#include "vtkMPICommunicator.h"

Include dependency graph for vtkMPIController.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMPIController
Process communication using MPI. More...

Generated on Mon Mar 25 01:13:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIEventLog.h File Reference

Parallel/vtkMPIEventLog.h File Reference

#include "vtkObject.h"
#include "vtkMPIController.h"

Include dependency graph for vtkMPIEventLog.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMPIEventLog
Class for logging and timing. More...

Generated on Mon Mar 25 01:13:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIGroup.h File Reference

Parallel/vtkMPIGroup.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkMPIGroup.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMPIGroup
Class for creating MPI groups. More...

Generated on Mon Mar 25 01:13:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiProcessController.h File Reference

Parallel/vtkMultiProcessController.h File Reference

#include "vtkObject.h"
#include "vtkDataObject.h"
#include "vtkCommunicator.h"

Include dependency graph for vtkMultiProcessController.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkMultiProcessController
Multiprocessing communication superclass. More...

Typedefs

typedef void(* | vtkProcessFunctionType )(vtkMultiProcessController *controller, void *userData)
typedef void(* | vtkRMIFunctionType )(void *localArg, void *remoteArg, int remoteArgLength, int remoteProcessId)

Typedef Documentation

typedef void(* vtkProcessFunctionType)(vtkMultiProcessController *controller, void *userData)

Definition at line 74 of file vtkMultiProcessController.h.

typedef void(* vtkRMIFunctionType)(void *localArg, void *remoteArg, int remoteArgLength, int remoteProcessId)

Definition at line 78 of file vtkMultiProcessController.h.

Generated on Mon Mar 25 01:13:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiProcessLog.h File Reference

Parallel/vtkMultiProcessLog.h File Reference

#include "vtkObject.h"
#include "vtkThreadSafeLog.h"

Include dependency graph for vtkMultiProcessLog.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkMultiProcessLog
Manages logs for multiple threads/processes. More...

Defines

#define | VTK_MULTI_PROCESS_LOG_MAX 1000

Define Documentation

#define VTK_MULTI_PROCESS_LOG_MAX 1000

Definition at line 39 of file vtkMultiProcessLog.h.

Generated on Mon Mar 25 01:13:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutputPort.h File Reference

Parallel/vtkOutputPort.h File Reference

#include "vtkProcessObject.h"
#include "vtkMultiProcessController.h"

Include dependency graph for vtkOutputPort.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOutputPort
Connects pipelines in different processes. More...

Generated on Mon Mar 25 01:13:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParallelFactory.h File Reference

Parallel/vtkParallelFactory.h File Reference

#include "vtkObjectFactory.h"

Include dependency graph for vtkParallelFactory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkParallelFactory

Functions

VTK_PARALLEL_EXPORT vtkObjectFactory * | vtkLoad ()

Function Documentation

VTK_PARALLEL_EXPORT vtkObjectFactory* vtkLoad ( )

Generated on Mon Mar 25 01:13:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPCellDataToPointData.h File Reference

Parallel/vtkPCellDataToPointData.h File Reference

#include "vtkCellDataToPointData.h"

Include dependency graph for vtkPCellDataToPointData.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPCellDataToPointData
Compute point arrays from cell arrays. More...

Generated on Mon Mar 25 01:13:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPDataSetReader.h File Reference

Parallel/vtkPDataSetReader.h File Reference

#include "vtkSource.h"
#include "vtkDataSet.h"
#include "vtkImageData.h"

Include dependency graph for vtkPDataSetReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPDataSetReader
Manages writing pieces of a data set. More...

Generated on Mon Mar 25 01:13:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPDataSetWriter.h File Reference

Parallel/vtkPDataSetWriter.h File Reference

#include "vtkDataSetWriter.h"
#include "vtkImageData.h"
#include "vtkStructuredGrid.h"
#include "vtkRectilinearGrid.h"

Include dependency graph for vtkPDataSetWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPDataSetWriter
Manages writing pieces of a data set. More...

Generated on Mon Mar 25 01:13:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPieceScalars.h File Reference

Parallel/vtkPieceScalars.h File Reference

#include "vtkDataSetToDataSetFilter.h"

Include dependency graph for vtkPieceScalars.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPieceScalars
Sets all cell scalars from the update piece. More...

Generated on Mon Mar 25 01:13:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPImageWriter.h File Reference

Parallel/vtkPImageWriter.h File Reference

#include "vtkImageWriter.h"

Include dependency graph for vtkPImageWriter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPImageWriter

Generated on Mon Mar 25 01:13:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPipelineSize.h File Reference

Parallel/vtkPipelineSize.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkPipelineSize.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPipelineSize
compute the memory required by a pipeline. More...

Generated on Mon Mar 25 01:13:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLinearExtrusionFilter.h File Reference

Parallel/vtkPLinearExtrusionFilter.h File Reference

#include "vtkLinearExtrusionFilter.h"

Include dependency graph for vtkPLinearExtrusionFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPLinearExtrusionFilter
Subclass that handles piece invariance. More...

Generated on Mon Mar 25 01:13:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPOPReader.h File Reference

Parallel/vtkPOPReader.h File Reference

#include <stdio.h>
#include "vtkImageData.h"
#include "vtkStructuredGridSource.h"

Include dependency graph for vtkPOPReader.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPOPReader
read POP data files. More...

Generated on Mon Mar 25 01:13:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPPolyDataNormals.h File Reference

Parallel/vtkPPolyDataNormals.h File Reference

#include "vtkPolyDataNormals.h"

Include dependency graph for vtkPPolyDataNormals.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPPolyDataNormals
compute normals for polygonal mesh. More...

Generated on Mon Mar 25 01:13:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPSphereSource.h File Reference

Parallel/vtkPSphereSource.h File Reference

#include "vtkSphereSource.h"

Include dependency graph for vtkPSphereSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPSphereSource
sphere source that supports pieces. More...

Generated on Mon Mar 25 01:13:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPVGeometryFilter.h File Reference

Parallel/vtkPVGeometryFilter.h File Reference

#include "vtkDataSetSurfaceFilter.h"
#include "vtkImageData.h"
#include "vtkStructuredGrid.h"
#include "vtkRectilinearGrid.h"
#include "vtkUnstructuredGrid.h"

Include dependency graph for vtkPVGeometryFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPVGeometryFilter
Geometry filter that does outlines for volumes. More...

Generated on Mon Mar 25 01:13:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridOutlineFilter.h File Reference

Parallel/vtkRectilinearGridOutlineFilter.h File Reference

#include "vtkRectilinearGridToPolyDataFilter.h"

Include dependency graph for vtkRectilinearGridOutlineFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRectilinearGridOutlineFilter
create wireframe outline for a rectilinear grid. More...

Generated on Mon Mar 25 01:13:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRTAnalyticSource.h File Reference

Parallel/vtkRTAnalyticSource.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkRTAnalyticSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRTAnalyticSource
Create an image for regression testing. More...

Generated on Mon Mar 25 01:13:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSharedMemoryCommunicator.h File Reference

Parallel/vtkSharedMemoryCommunicator.h File Reference

#include "vtkCommunicator.h"
#include "vtkMultiProcessController.h"
#include "vtkCriticalSection.h"

Include dependency graph for vtkSharedMemoryCommunicator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkSharedMemoryCommunicator
Provides communication using shared memory. More...

Generated on Mon Mar 25 01:13:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSocketCommunicator.h File Reference

Parallel/vtkSocketCommunicator.h File Reference

#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
#include <unistd.h>
#include "vtkObject.h"
#include "vtkByteSwap.h"
#include "vtkCommunicator.h"

Include dependency graph for vtkSocketCommunicator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkSocketCommunicator
Process communication using Sockets. More...

Defines

#define | vtkSwap4 vtkByteSwap::Swap4BE
#define | vtkSwap4Range vtkByteSwap::Swap4BERange
#define | vtkSwap8 vtkByteSwap::Swap8BE
#define | vtkSwap8Range vtkByteSwap::Swap8BERange

Define Documentation

#define vtkSwap4 vtkByteSwap::Swap4BE

Definition at line 70 of file vtkSocketCommunicator.h.

#define vtkSwap4Range vtkByteSwap::Swap4BERange

Definition at line 71 of file vtkSocketCommunicator.h.

#define vtkSwap8 vtkByteSwap::Swap8BE

Definition at line 72 of file vtkSocketCommunicator.h.

#define vtkSwap8Range vtkByteSwap::Swap8BERange

Definition at line 73 of file vtkSocketCommunicator.h.

Generated on Mon Mar 25 01:13:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSocketController.h File Reference

Parallel/vtkSocketController.h File Reference

#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
#include <unistd.h>
#include "vtkObject.h"
#include "vtkMultiProcessController.h"
#include "vtkSocketCommunicator.h"

Include dependency graph for vtkSocketController.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSocketController
Process communication using Sockets. More...

Generated on Mon Mar 25 01:13:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreadedController.h File Reference

Parallel/vtkThreadedController.h File Reference

#include "vtkObject.h"
#include "vtkMultiProcessController.h"
#include "vtkMultiThreader.h"
#include "vtkSharedMemoryCommunicator.h"
#include "vtkCriticalSection.h"

Include dependency graph for vtkThreadedController.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkThreadedController
Allows communication between running threads. More...

Generated on Mon Mar 25 01:13:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreadSafeLog.h File Reference

Parallel/vtkThreadSafeLog.h File Reference

#include "vtkObject.h"
#include "vtkTimerLog.h"

Include dependency graph for vtkThreadSafeLog.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkThreadSafeLog
Saves tag/float entries. More...

Defines

#define | VTK_THREAD_SAFE_LOG_MAX 1000

Define Documentation

#define VTK_THREAD_SAFE_LOG_MAX 1000

Definition at line 39 of file vtkThreadSafeLog.h.

Generated on Mon Mar 25 01:13:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransmitPolyDataPiece.h File Reference

Parallel/vtkTransmitPolyDataPiece.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkMultiProcessController.h"

Include dependency graph for vtkTransmitPolyDataPiece.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransmitPolyDataPiece
Return specified piece, including specified. More...

Generated on Mon Mar 25 01:13:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransmitUnstructuredGridPiece.h File Reference

Parallel/vtkTransmitUnstructuredGridPiece.h File Reference

#include "vtkUnstructuredGridToUnstructuredGridFilter.h"
#include "vtkMultiProcessController.h"

Include dependency graph for vtkTransmitUnstructuredGridPiece.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTransmitUnstructuredGridPiece
Return specified piece, including specified. More...

Generated on Mon Mar 25 01:13:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTreeComposite.h File Reference

Parallel/vtkTreeComposite.h File Reference

#include "vtkCompositeManager.h"

Include dependency graph for vtkTreeComposite.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTreeComposite
Implements tree based compositing. More...

Generated on Mon Mar 25 01:13:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDecimate.h File Reference

Patented/vtkDecimate.h File Reference

#include "vtkPolyDataToPolyDataFilter.h"
#include "vtkMath.h"
#include "vtkTriangle.h"
#include "vtkPlane.h"
#include "vtkPolygon.h"
#include "vtkLine.h"

Include dependency graph for vtkDecimate.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | _vtkLocalVertex
struct | _vtkLocalTri
class | vtkVertexArray
class | vtkTriArray
class | vtkDecimate
reduce the number of triangles in a mesh. More...

Defines

#define | VTK_NUMBER_STATISTICS 12

Typedefs

typedef _vtkLocalVertex | vtkLocalVertex
typedef _vtkLocalVertex * | vtkLocalVertexPtr
typedef _vtkLocalTri | vtkLocalTri
typedef _vtkLocalTri * | vtkLocalTriPtr

Define Documentation

#define VTK_NUMBER_STATISTICS 12

Definition at line 124 of file vtkDecimate.h.

Typedef Documentation

typedef struct _vtkLocalVertex vtkLocalVertex

typedef struct _vtkLocalVertex * vtkLocalVertexPtr

typedef struct _vtkLocalTri vtkLocalTri

typedef struct _vtkLocalTri * vtkLocalTriPtr

Generated on Mon Mar 25 01:13:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDividingCubes.h File Reference

Patented/vtkDividingCubes.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"

Include dependency graph for vtkDividingCubes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDividingCubes
create points lying on isosurface. More...

Generated on Mon Mar 25 01:13:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGridSynchronizedTemplates3D.h File Reference

Patented/vtkGridSynchronizedTemplates3D.h File Reference

#include "vtkStructuredGridToPolyDataFilter.h"
#include "vtkContourValues.h"
#include "vtkMultiThreader.h"
#include "vtkKitwareContourFilter.h"
#include "vtkFloatArray.h"

Include dependency graph for vtkGridSynchronizedTemplates3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkGridSynchronizedTemplates3D
generate isosurface from structured grids. More...

Generated on Mon Mar 25 01:13:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMarchingCubes.h File Reference

Patented/vtkImageMarchingCubes.h File Reference

#include "vtkImageData.h"
#include "vtkPolyDataSource.h"
#include "vtkContourValues.h"

Include dependency graph for vtkImageMarchingCubes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageMarchingCubes
generate isosurface(s) from volume/images. More...

Generated on Mon Mar 25 01:13:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKitwareContourFilter.h File Reference

Patented/vtkKitwareContourFilter.h File Reference

#include "vtkContourFilter.h"

Include dependency graph for vtkKitwareContourFilter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkKitwareContourFilter
generate isosurfaces/isolines from scalar values. More...

Generated on Mon Mar 25 01:13:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKitwareObjectFactory.h File Reference

Patented/vtkKitwareObjectFactory.h File Reference

#include "vtkObjectFactory.h"

Include dependency graph for vtkKitwareObjectFactory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkKitwareObjectFactory
Object Factory for Kitware patented objects. More...

Functions

VTK_PATENTED_EXPORT vtkObjectFactory * | vtkLoad ()

Function Documentation

VTK_PATENTED_EXPORT vtkObjectFactory* vtkLoad ( )

Generated on Mon Mar 25 01:13:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingContourFilter.h File Reference

Patented/vtkMarchingContourFilter.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkContourValues.h"

Include dependency graph for vtkMarchingContourFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMarchingContourFilter
generate isosurfaces/isolines from scalar values. More...

Generated on Mon Mar 25 01:13:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingCubes.h File Reference

Patented/vtkMarchingCubes.h File Reference

#include "vtkStructuredPointsToPolyDataFilter.h"
#include "vtkContourValues.h"

Include dependency graph for vtkMarchingCubes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMarchingCubes
generate isosurface(s) from volume. More...

Generated on Mon Mar 25 01:13:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingSquares.h File Reference

Patented/vtkMarchingSquares.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkImageData.h"
#include "vtkContourValues.h"

Include dependency graph for vtkMarchingSquares.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMarchingSquares
generate isoline(s) from structured points set. More...

Generated on Mon Mar 25 01:13:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSliceCubes.h File Reference

Patented/vtkSliceCubes.h File Reference

#include "vtkObject.h"
#include "vtkVolumeReader.h"
#include "vtkMCubesReader.h"

Include dependency graph for vtkSliceCubes.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSliceCubes
generate isosurface(s) from volume four slices at a time. More...

Generated on Mon Mar 25 01:13:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSweptSurface.h File Reference

Patented/vtkSweptSurface.h File Reference

#include "vtkStructuredPointsToStructuredPointsFilter.h"
#include "vtkTransformCollection.h"

Include dependency graph for vtkSweptSurface.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSweptSurface
given a path and input geometry generate an (implicit) representation of a swept surface. More...

Generated on Mon Mar 25 01:13:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSynchronizedTemplates2D.h File Reference

Patented/vtkSynchronizedTemplates2D.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkImageData.h"
#include "vtkContourValues.h"
#include "vtkKitwareContourFilter.h"

Include dependency graph for vtkSynchronizedTemplates2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSynchronizedTemplates2D
generate isoline(s) from a structured points set. More...

Generated on Mon Mar 25 01:13:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSynchronizedTemplates3D.h File Reference

Patented/vtkSynchronizedTemplates3D.h File Reference

#include "vtkPolyDataSource.h"
#include "vtkImageData.h"
#include "vtkContourValues.h"
#include "vtkMultiThreader.h"
#include "vtkKitwareContourFilter.h"

Include dependency graph for vtkSynchronizedTemplates3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkSynchronizedTemplates3D
generate isosurface from structured points. More...

Variables

int | VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_1 []
int | VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_2 []

Variable Documentation

int VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_1[]

Definition at line 229 of file vtkSynchronizedTemplates3D.h.

int VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_2[]

Definition at line 230 of file vtkSynchronizedTemplates3D.h.

Generated on Mon Mar 25 01:13:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractMapper3D.h File Reference

Rendering/vtkAbstractMapper3D.h File Reference

#include "vtkAbstractMapper.h"

Include dependency graph for vtkAbstractMapper3D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkAbstractMapper3D
abstract class specifies interface to map 3D data. More...

Generated on Mon Mar 25 01:13:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractPicker.h File Reference

Rendering/vtkAbstractPicker.h File Reference

#include "vtkObject.h"
#include "vtkRenderer.h"

Include dependency graph for vtkAbstractPicker.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkAbstractPicker
define API for picking subclasses. More...

Generated on Mon Mar 25 01:13:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractPropPicker.h File Reference

Rendering/vtkAbstractPropPicker.h File Reference

#include "vtkAbstractPicker.h"

Include dependency graph for vtkAbstractPropPicker.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkAbstractPropPicker
abstract API for pickers that can pick an instance of vtkProp. More...

Generated on Mon Mar 25 01:13:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor.h File Reference

Rendering/vtkActor.h File Reference

#include "vtkProp3D.h"
#include "vtkProperty.h"
#include "vtkTexture.h"
#include "vtkMapper.h"

Include dependency graph for vtkActor.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkActor
represents an object (geometry & properties) in a rendered scene. More...

Generated on Mon Mar 25 01:14:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActorCollection.h File Reference

Rendering/vtkActorCollection.h File Reference

#include "vtkPropCollection.h"
#include "vtkActor.h"

Include dependency graph for vtkActorCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkActorCollection
a list of actors. More...

Generated on Mon Mar 25 01:14:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssembly.h File Reference

Rendering/vtkAssembly.h File Reference

#include "vtkProp3D.h"
#include "vtkAbstractMapper3D.h"

Include dependency graph for vtkAssembly.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkAssembly
create hierarchies of vtkProp3Ds (transformable props). More...

Generated on Mon Mar 25 01:14:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAxisActor2D.h File Reference

Rendering/vtkAxisActor2D.h File Reference

#include "vtkActor2D.h"
#include "vtkPolyDataMapper2D.h"
#include "vtkTextMapper.h"

Include dependency graph for vtkAxisActor2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkAxisActor2D
Create an axis with tick marks and labels. More...

Defines

#define | VTK_MAX_LABELS 25

Define Documentation

#define VTK_MAX_LABELS 25

Definition at line 70 of file vtkAxisActor2D.h.

Generated on Mon Mar 25 01:14:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCamera.h File Reference

Rendering/vtkCamera.h File Reference

#include "vtkObject.h"
#include "vtkTransform.h"
#include "vtkPerspectiveTransform.h"

Include dependency graph for vtkCamera.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCamera
a virtual camera for 3D rendering. More...

Generated on Mon Mar 25 01:14:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellPicker.h File Reference

Rendering/vtkCellPicker.h File Reference

#include "vtkPicker.h"

Include dependency graph for vtkCellPicker.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCellPicker
select a cell by shooting a ray into graphics window. More...

Generated on Mon Mar 25 01:14:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCuller.h File Reference

Rendering/vtkCuller.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkCuller.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCuller
a superclass for prop cullers. More...

Generated on Mon Mar 25 01:14:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCullerCollection.h File Reference

Rendering/vtkCullerCollection.h File Reference

#include "vtkCollection.h"
#include "vtkCuller.h"

Include dependency graph for vtkCullerCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkCullerCollection
a list of Cullers. More...

Generated on Mon Mar 25 01:14:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetMapper.h File Reference

Rendering/vtkDataSetMapper.h File Reference

#include "vtkDataSetSurfaceFilter.h"
#include "vtkPolyDataMapper.h"
#include "vtkRenderer.h"
#include "vtkImageData.h"

Include dependency graph for vtkDataSetMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkDataSetMapper
map vtkDataSet and derived classes to graphics primitives. More...

Generated on Mon Mar 25 01:14:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDirectionEncoder.h File Reference

Rendering/vtkDirectionEncoder.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkDirectionEncoder.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkDirectionEncoder
encode a direction into a one or two byte value. More...

Generated on Mon Mar 25 01:14:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEncodedGradientEstimator.h File Reference

Rendering/vtkEncodedGradientEstimator.h File Reference

#include "vtkObject.h"
#include "vtkMultiThreader.h"
#include "vtkImageData.h"
#include "vtkDirectionEncoder.h"

Include dependency graph for vtkEncodedGradientEstimator.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkEncodedGradientEstimator
Superclass for gradient estimation. More...

Generated on Mon Mar 25 01:14:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEncodedGradientShader.h File Reference

Rendering/vtkEncodedGradientShader.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkEncodedGradientShader.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkEncodedGradientShader
Compute shading tables for encoded normals. More...

Defines

#define | VTK_MAX_SHADING_TABLES 100

Define Documentation

#define VTK_MAX_SHADING_TABLES 100

Definition at line 52 of file vtkEncodedGradientShader.h.

Generated on Mon Mar 25 01:14:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExporter.h File Reference

Rendering/vtkExporter.h File Reference

#include "vtkObject.h"
#include "vtkRenderWindow.h"

Include dependency graph for vtkExporter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkExporter
abstract class to write a scene to a file. More...

Generated on Mon Mar 25 01:14:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFiniteDifferenceGradientEstimator.h File Reference

Rendering/vtkFiniteDifferenceGradientEstimator.h File Reference

#include "vtkEncodedGradientEstimator.h"

Include dependency graph for vtkFiniteDifferenceGradientEstimator.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkFiniteDifferenceGradientEstimator
Use finite differences to estimate gradient. More...

Generated on Mon Mar 25 01:14:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFollower.h File Reference

Rendering/vtkFollower.h File Reference

#include "vtkActor.h"
#include "vtkCamera.h"

Include dependency graph for vtkFollower.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkFollower
a subclass of actor that always faces the camera. More...

Generated on Mon Mar 25 01:14:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFrustumCoverageCuller.h File Reference

Rendering/vtkFrustumCoverageCuller.h File Reference

#include "vtkCuller.h"

Include dependency graph for vtkFrustumCoverageCuller.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkFrustumCoverageCuller
cull props based on frustum coverage. More...

Defines

#define | VTK_CULLER_SORT_NONE 0
#define | VTK_CULLER_SORT_FRONT_TO_BACK 1
#define | VTK_CULLER_SORT_BACK_TO_FRONT 2

Define Documentation

#define VTK_CULLER_SORT_NONE 0

Definition at line 51 of file vtkFrustumCoverageCuller.h.

#define VTK_CULLER_SORT_FRONT_TO_BACK 1

Definition at line 52 of file vtkFrustumCoverageCuller.h.

#define VTK_CULLER_SORT_BACK_TO_FRONT 2

Definition at line 53 of file vtkFrustumCoverageCuller.h.

Generated on Mon Mar 25 01:14:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkgluPickMatrix.h File Reference

Rendering/vtkgluPickMatrix.h File Reference

Go to the source code of this file.

Defines

#define | M(row, col) m[col*4+row]

Functions

void | vtkgluPickMatrix (GLdouble x, GLdouble y, GLdouble width, GLdouble height, int *origin, int *size)

Define Documentation

#define M | ( | row,
 |  | col | ) | m[col*4+row]

Referenced by vtkgluPickMatrix().

Function Documentation

void vtkgluPickMatrix | ( | GLdouble | x,
 |  | GLdouble | y,
 |  | GLdouble | width,
 |  | GLdouble | height,
 |  | int * | origin,
 |  | int * | size
 | ) | [inline]

Definition at line 30 of file vtkgluPickMatrix.h.

Generated on Mon Mar 25 01:14:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGraphicsFactory.h File Reference

Rendering/vtkGraphicsFactory.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkGraphicsFactory.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkGraphicsFactory

Generated on Mon Mar 25 01:14:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageActor.h File Reference

Rendering/vtkImageActor.h File Reference

#include "vtkProp.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageActor.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageActor
draw an image (data & properties) in a rendered 3D scene. More...

Generated on Mon Mar 25 01:14:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapper.h File Reference

Rendering/vtkImageMapper.h File Reference

#include "vtkMapper2D.h"
#include "vtkImageData.h"

Include dependency graph for vtkImageMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageMapper
2D image display. More...

Generated on Mon Mar 25 01:14:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImager.h File Reference

Rendering/vtkImager.h File Reference

#include "vtkObject.h"
#include "vtkActor2DCollection.h"
#include "vtkActor2D.h"
#include "vtkViewport.h"
#include "vtkWindow.h"

Include dependency graph for vtkImager.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImager
Renders into part of a ImageWindow. More...

Generated on Mon Mar 25 01:14:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagerCollection.h File Reference

Rendering/vtkImagerCollection.h File Reference

#include "vtkCollection.h"
#include "vtkImager.h"

Include dependency graph for vtkImagerCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImagerCollection
a collection of imagers. More...

Generated on Mon Mar 25 01:14:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageViewer.h File Reference

Rendering/vtkImageViewer.h File Reference

#include "vtkObject.h"
#include "vtkImageWindow.h"
#include "vtkRenderWindow.h"

Include dependency graph for vtkImageViewer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageViewer
Display a 2d image. More...

Generated on Mon Mar 25 01:14:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageViewer2.h File Reference

Rendering/vtkImageViewer2.h File Reference

#include "vtkObject.h"
#include "vtkRenderWindow.h"
#include "vtkImageActor.h"
#include "vtkImageMapToWindowLevelColors.h"

Include dependency graph for vtkImageViewer2.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImageViewer2

Generated on Mon Mar 25 01:14:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWindow.h File Reference

Rendering/vtkImageWindow.h File Reference

#include "vtkWindow.h"
#include "vtkActor2D.h"
#include "vtkImager.h"
#include "vtkImageMapper.h"
#include "vtkImagerCollection.h"

Include dependency graph for vtkImageWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImageWindow
a 2D display window. More...

Generated on Mon Mar 25 01:14:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagingFactory.h File Reference

Rendering/vtkImagingFactory.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkImagingFactory.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkImagingFactory

Generated on Mon Mar 25 01:14:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImporter.h File Reference

Rendering/vtkImporter.h File Reference

#include <stdio.h>
#include "vtkObject.h"
#include "vtkRenderWindow.h"
#include "vtkRenderer.h"
#include "vtkPolyData.h"
#include "vtkActorCollection.h"
#include "vtkLightCollection.h"

Include dependency graph for vtkImporter.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkImporter
importer abstract class. More...

Generated on Mon Mar 25 01:14:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyle.h File Reference

Rendering/vtkInteractorStyle.h File Reference

#include "vtkRenderWindowInteractor.h"

Include dependency graph for vtkInteractorStyle.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyle
provide event-driven interface to the rendering window (defines trackball mode). More...

Defines

#define | VTKIS_START 0
#define | VTKIS_ROTATE 1
#define | VTKIS_ZOOM 2
#define | VTKIS_PAN 3
#define | VTKIS_SPIN 4
#define | VTKIS_DOLLY 5
#define | VTKIS_USCALE 6
#define | VTKIS_TIMER 7
#define | VTKIS_ANIM_OFF 0
#define | VTKIS_ANIM_ON 1

Define Documentation

#define VTKIS_START 0

Definition at line 103 of file vtkInteractorStyle.h.

#define VTKIS_ROTATE 1

Definition at line 104 of file vtkInteractorStyle.h.

#define VTKIS_ZOOM 2

Definition at line 105 of file vtkInteractorStyle.h.

#define VTKIS_PAN 3

Definition at line 106 of file vtkInteractorStyle.h.

#define VTKIS_SPIN 4

Definition at line 107 of file vtkInteractorStyle.h.

#define VTKIS_DOLLY 5

Definition at line 108 of file vtkInteractorStyle.h.

#define VTKIS_USCALE 6

Definition at line 109 of file vtkInteractorStyle.h.

#define VTKIS_TIMER 7

Definition at line 110 of file vtkInteractorStyle.h.

#define VTKIS_ANIM_OFF 0

Definition at line 111 of file vtkInteractorStyle.h.

#define VTKIS_ANIM_ON 1

Definition at line 112 of file vtkInteractorStyle.h.

Generated on Mon Mar 25 01:14:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleFlight.h File Reference

Rendering/vtkInteractorStyleFlight.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkInteractorStyleFlight.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkInteractorStyleFlight
provides flight motion routines. More...

Generated on Mon Mar 25 01:14:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleImage.h File Reference

Rendering/vtkInteractorStyleImage.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkInteractorStyleImage.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleImage
interactive manipulation of the camera specialized for images. More...

Defines

#define | VTK_INTERACTOR_STYLE_IMAGE_NONE 0
#define | VTK_INTERACTOR_STYLE_IMAGE_WINDOW_LEVEL 1
#define | VTK_INTERACTOR_STYLE_IMAGE_PAN 2
#define | VTK_INTERACTOR_STYLE_IMAGE_ZOOM 3
#define | VTK_INTERACTOR_STYLE_IMAGE_SPIN 4

Define Documentation

#define VTK_INTERACTOR_STYLE_IMAGE_NONE 0

Definition at line 61 of file vtkInteractorStyleImage.h.

#define VTK_INTERACTOR_STYLE_IMAGE_WINDOW_LEVEL 1

Definition at line 62 of file vtkInteractorStyleImage.h.

#define VTK_INTERACTOR_STYLE_IMAGE_PAN 2

Definition at line 63 of file vtkInteractorStyleImage.h.

#define VTK_INTERACTOR_STYLE_IMAGE_ZOOM 3

Definition at line 64 of file vtkInteractorStyleImage.h.

#define VTK_INTERACTOR_STYLE_IMAGE_SPIN 4

Definition at line 65 of file vtkInteractorStyleImage.h.

Generated on Mon Mar 25 01:14:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleJoystickActor.h File Reference

Rendering/vtkInteractorStyleJoystickActor.h File Reference

#include "vtkInteractorStyle.h"
#include "vtkCellPicker.h"

Include dependency graph for vtkInteractorStyleJoystickActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleJoystickActor
manipulate objects in the scene independently of one another. More...

Defines

#define | VTK_INTERACTOR_STYLE_ACTOR_NONE 0
#define | VTK_INTERACTOR_STYLE_ACTOR_ROTATE 1
#define | VTK_INTERACTOR_STYLE_ACTOR_PAN 2
#define | VTK_INTERACTOR_STYLE_ACTOR_ZOOM 3
#define | VTK_INTERACTOR_STYLE_ACTOR_SPIN 4
#define | VTK_INTERACTOR_STYLE_ACTOR_SCALE 5

Define Documentation

#define VTK_INTERACTOR_STYLE_ACTOR_NONE 0

Definition at line 50 of file vtkInteractorStyleJoystickActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_ROTATE 1

Definition at line 51 of file vtkInteractorStyleJoystickActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_PAN 2

Definition at line 52 of file vtkInteractorStyleJoystickActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_ZOOM 3

Definition at line 53 of file vtkInteractorStyleJoystickActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_SPIN 4

Definition at line 54 of file vtkInteractorStyleJoystickActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_SCALE 5

Definition at line 55 of file vtkInteractorStyleJoystickActor.h.

Generated on Mon Mar 25 01:14:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleJoystickCamera.h File Reference

Rendering/vtkInteractorStyleJoystickCamera.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkInteractorStyleJoystickCamera.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleJoystickCamera
interactive manipulation of the camera. More...

Defines

#define | VTK_INTERACTOR_STYLE_CAMERA_NONE 0
#define | VTK_INTERACTOR_STYLE_CAMERA_ROTATE 1
#define | VTK_INTERACTOR_STYLE_CAMERA_PAN 2
#define | VTK_INTERACTOR_STYLE_CAMERA_ZOOM 3
#define | VTK_INTERACTOR_STYLE_CAMERA_SPIN 4

Define Documentation

#define VTK_INTERACTOR_STYLE_CAMERA_NONE 0

Definition at line 51 of file vtkInteractorStyleJoystickCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_ROTATE 1

Definition at line 52 of file vtkInteractorStyleJoystickCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_PAN 2

Definition at line 53 of file vtkInteractorStyleJoystickCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_ZOOM 3

Definition at line 54 of file vtkInteractorStyleJoystickCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_SPIN 4

Definition at line 55 of file vtkInteractorStyleJoystickCamera.h.

Generated on Mon Mar 25 01:14:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleSwitch.h File Reference

Rendering/vtkInteractorStyleSwitch.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkInteractorStyleSwitch.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleSwitch
class to swap between interactory styles. More...

Defines

#define | VTKIS_JOYSTICK 0
#define | VTKIS_TRACKBALL 1
#define | VTKIS_CAMERA 0
#define | VTKIS_ACTOR 1

Define Documentation

#define VTKIS_JOYSTICK 0

Definition at line 45 of file vtkInteractorStyleSwitch.h.

#define VTKIS_TRACKBALL 1

Definition at line 46 of file vtkInteractorStyleSwitch.h.

#define VTKIS_CAMERA 0

Definition at line 47 of file vtkInteractorStyleSwitch.h.

#define VTKIS_ACTOR 1

Definition at line 48 of file vtkInteractorStyleSwitch.h.

Generated on Mon Mar 25 01:14:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackball.h File Reference

Rendering/vtkInteractorStyleTrackball.h File Reference

#include "vtkInteractorStyle.h"
#include "vtkAbstractPropPicker.h"

Include dependency graph for vtkInteractorStyleTrackball.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleTrackball
provides trackball motion control. More...

Defines

#define | VTKIS_JOY 0
#define | VTKIS_TRACK 1
#define | VTKIS_CAMERA 0
#define | VTKIS_ACTOR 1
#define | VTKIS_CONTROL_OFF 0
#define | VTKIS_CONTROL_ON 1

Define Documentation

#define VTKIS_JOY 0

Definition at line 53 of file vtkInteractorStyleTrackball.h.

#define VTKIS_TRACK 1

Definition at line 54 of file vtkInteractorStyleTrackball.h.

#define VTKIS_CAMERA 0

Definition at line 55 of file vtkInteractorStyleTrackball.h.

#define VTKIS_ACTOR 1

Definition at line 56 of file vtkInteractorStyleTrackball.h.

#define VTKIS_CONTROL_OFF 0

Definition at line 57 of file vtkInteractorStyleTrackball.h.

#define VTKIS_CONTROL_ON 1

Definition at line 58 of file vtkInteractorStyleTrackball.h.

Generated on Mon Mar 25 01:14:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackballActor.h File Reference

Rendering/vtkInteractorStyleTrackballActor.h File Reference

#include "vtkInteractorStyle.h"
#include "vtkCellPicker.h"

Include dependency graph for vtkInteractorStyleTrackballActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleTrackballActor
manipulate objects in the scene independent of each other. More...

Defines

#define | VTK_INTERACTOR_STYLE_ACTOR_NONE 0
#define | VTK_INTERACTOR_STYLE_ACTOR_ROTATE 1
#define | VTK_INTERACTOR_STYLE_ACTOR_PAN 2
#define | VTK_INTERACTOR_STYLE_ACTOR_ZOOM 3
#define | VTK_INTERACTOR_STYLE_ACTOR_SPIN 4
#define | VTK_INTERACTOR_STYLE_ACTOR_SCALE 5

Define Documentation

#define VTK_INTERACTOR_STYLE_ACTOR_NONE 0

Definition at line 49 of file vtkInteractorStyleTrackballActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_ROTATE 1

Definition at line 50 of file vtkInteractorStyleTrackballActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_PAN 2

Definition at line 51 of file vtkInteractorStyleTrackballActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_ZOOM 3

Definition at line 52 of file vtkInteractorStyleTrackballActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_SPIN 4

Definition at line 53 of file vtkInteractorStyleTrackballActor.h.

#define VTK_INTERACTOR_STYLE_ACTOR_SCALE 5

Definition at line 54 of file vtkInteractorStyleTrackballActor.h.

Generated on Mon Mar 25 01:14:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackballCamera.h File Reference

Rendering/vtkInteractorStyleTrackballCamera.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkInteractorStyleTrackballCamera.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleTrackballCamera
interactive manipulation of the camera. More...

Defines

#define | VTK_INTERACTOR_STYLE_CAMERA_NONE 0
#define | VTK_INTERACTOR_STYLE_CAMERA_ROTATE 1
#define | VTK_INTERACTOR_STYLE_CAMERA_PAN 2
#define | VTK_INTERACTOR_STYLE_CAMERA_ZOOM 3
#define | VTK_INTERACTOR_STYLE_CAMERA_SPIN 4

Define Documentation

#define VTK_INTERACTOR_STYLE_CAMERA_NONE 0

Definition at line 52 of file vtkInteractorStyleTrackballCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_ROTATE 1

Definition at line 53 of file vtkInteractorStyleTrackballCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_PAN 2

Definition at line 54 of file vtkInteractorStyleTrackballCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_ZOOM 3

Definition at line 55 of file vtkInteractorStyleTrackballCamera.h.

#define VTK_INTERACTOR_STYLE_CAMERA_SPIN 4

Definition at line 56 of file vtkInteractorStyleTrackballCamera.h.

Generated on Mon Mar 25 01:14:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleUnicam.h File Reference

Rendering/vtkInteractorStyleUnicam.h File Reference

#include "vtkInteractorStyle.h"
#include "vtkRenderer.h"
#include <sys/time.h>

Include dependency graph for vtkInteractorStyleUnicam.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleUnicam
provides Unicam navigation style. More...

Defines

#define | VTK_UNICAM_NONE 0
#define | VTK_UNICAM_BUTTON_LEFT 1
#define | VTK_UNICAM_BUTTON_MIDDLE 2
#define | VTK_UNICAM_BUTTON_RIGHT 3
#define | VTK_UNICAM_CAM_INT_ROT 0
#define | VTK_UNICAM_CAM_INT_CHOOSE 1
#define | VTK_UNICAM_CAM_INT_PAN 2
#define | VTK_UNICAM_CAM_INT_DOLLY 3

Functions

double | TheTime ()

Define Documentation

#define VTK_UNICAM_NONE 0

Definition at line 123 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_BUTTON_LEFT 1

Definition at line 124 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_BUTTON_MIDDLE 2

Definition at line 125 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_BUTTON_RIGHT 3

Definition at line 126 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_CAM_INT_ROT 0

Definition at line 129 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_CAM_INT_CHOOSE 1

Definition at line 130 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_CAM_INT_PAN 2

Definition at line 131 of file vtkInteractorStyleUnicam.h.

#define VTK_UNICAM_CAM_INT_DOLLY 3

Definition at line 132 of file vtkInteractorStyleUnicam.h.

Function Documentation

double TheTime ( ) [inline]

Definition at line 105 of file vtkInteractorStyleUnicam.h.

Generated on Mon Mar 25 01:14:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleUser.h File Reference

Rendering/vtkInteractorStyleUser.h File Reference

#include "vtkInteractorStyleSwitch.h"

Include dependency graph for vtkInteractorStyleUser.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkInteractorStyleUser
provides customizable interaction routines. More...

Defines

#define | VTKIS_USERINTERACTION 8

Define Documentation

#define VTKIS_USERINTERACTION 8

Definition at line 52 of file vtkInteractorStyleUser.h.

Generated on Mon Mar 25 01:14:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIVExporter.h File Reference

Rendering/vtkIVExporter.h File Reference

#include <stdio.h>
#include "vtkExporter.h"

Include dependency graph for vtkIVExporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkIVExporter
export a scene into OpenInventor 2.0 format. More...

Generated on Mon Mar 25 01:14:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLabeledDataMapper.h File Reference

Rendering/vtkLabeledDataMapper.h File Reference

#include "vtkMapper2D.h"
#include "vtkTextMapper.h"
#include "vtkDataSet.h"

Include dependency graph for vtkLabeledDataMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkLabeledDataMapper
draw text labels at dataset points. More...

Defines

#define | VTK_LABEL_IDS 0
#define | VTK_LABEL_SCALARS 1
#define | VTK_LABEL_VECTORS 2
#define | VTK_LABEL_NORMALS 3
#define | VTK_LABEL_TCOORDS 4
#define | VTK_LABEL_TENSORS 5
#define | VTK_LABEL_FIELD_DATA 6

Define Documentation

#define VTK_LABEL_IDS 0

Definition at line 72 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_SCALARS 1

Definition at line 73 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_VECTORS 2

Definition at line 74 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_NORMALS 3

Definition at line 75 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_TCOORDS 4

Definition at line 76 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_TENSORS 5

Definition at line 77 of file vtkLabeledDataMapper.h.

#define VTK_LABEL_FIELD_DATA 6

Definition at line 78 of file vtkLabeledDataMapper.h.

Generated on Mon Mar 25 01:14:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLight.h File Reference

Rendering/vtkLight.h File Reference

#include "vtkObject.h"
#include "vtkMatrix4x4.h"

Include dependency graph for vtkLight.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkLight
a virtual light for 3D rendering. More...

Defines

#define | VTK_LIGHT_TYPE_HEADLIGHT 1
#define | VTK_LIGHT_TYPE_CAMERA_LIGHT 2
#define | VTK_LIGHT_TYPE_SCENE_LIGHT 3

Define Documentation

#define VTK_LIGHT_TYPE_HEADLIGHT 1

Definition at line 67 of file vtkLight.h.

#define VTK_LIGHT_TYPE_CAMERA_LIGHT 2

Definition at line 68 of file vtkLight.h.

#define VTK_LIGHT_TYPE_SCENE_LIGHT 3

Definition at line 69 of file vtkLight.h.

Generated on Mon Mar 25 01:14:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLightCollection.h File Reference

Rendering/vtkLightCollection.h File Reference

#include "vtkCollection.h"
#include "vtkLight.h"

Include dependency graph for vtkLightCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkLightCollection
a list of lights. More...

Generated on Mon Mar 25 01:14:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLightKit.h File Reference

Rendering/vtkLightKit.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkLightKit.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLightKit
a simple but quality lighting kit. More...

Generated on Mon Mar 25 01:14:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLODActor.h File Reference

Rendering/vtkLODActor.h File Reference

#include "vtkActor.h"
#include "vtkMaskPoints.h"
#include "vtkOutlineFilter.h"
#include "vtkPolyDataMapper.h"
#include "vtkMapperCollection.h"

Include dependency graph for vtkLODActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkLODActor
an actor that supports multiple levels of detail. More...

Generated on Mon Mar 25 01:14:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLODProp3D.h File Reference

Rendering/vtkLODProp3D.h File Reference

#include "vtkProp3D.h"
#include "vtkTransform.h"

Include dependency graph for vtkLODProp3D.h:

Include dependency graph

Go to the source code of this file.

Compounds

struct | vtkLODProp3DEntry
class | vtkLODProp3D
level of detail 3D prop. More...

Generated on Mon Mar 25 01:14:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapper.h File Reference

Rendering/vtkMapper.h File Reference

#include "vtkAbstractMapper3D.h"
#include "vtkScalarsToColors.h"
#include "vtkDataSet.h"

Include dependency graph for vtkMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkMapper
abstract class specifies interface to map data to graphics primitives. More...

Defines

#define | VTK_RESOLVE_OFF 0
#define | VTK_RESOLVE_POLYGON_OFFSET 1
#define | VTK_RESOLVE_SHIFT_ZBUFFER 2
#define | VTK_GET_ARRAY_BY_ID 0
#define | VTK_GET_ARRAY_BY_NAME 1

Define Documentation

#define VTK_RESOLVE_OFF 0

Definition at line 75 of file vtkMapper.h.

#define VTK_RESOLVE_POLYGON_OFFSET 1

Definition at line 76 of file vtkMapper.h.

#define VTK_RESOLVE_SHIFT_ZBUFFER 2

Definition at line 77 of file vtkMapper.h.

#define VTK_GET_ARRAY_BY_ID 0

Definition at line 79 of file vtkMapper.h.

#define VTK_GET_ARRAY_BY_NAME 1

Definition at line 80 of file vtkMapper.h.

Generated on Mon Mar 25 01:14:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapperCollection.h File Reference

Rendering/vtkMapperCollection.h File Reference

#include "vtkCollection.h"
#include "vtkMapper.h"

Include dependency graph for vtkMapperCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMapperCollection
a list of mappers. More...

Generated on Mon Mar 25 01:14:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaActor.h File Reference

Rendering/vtkMesaActor.h File Reference

#include "vtkActor.h"

Include dependency graph for vtkMesaActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaActor
Mesa actor. More...

Generated on Mon Mar 25 01:14:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaCamera.h File Reference

Rendering/vtkMesaCamera.h File Reference

#include "vtkCamera.h"

Include dependency graph for vtkMesaCamera.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaCamera
Mesa camera. More...

Generated on Mon Mar 25 01:14:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageActor.h File Reference

Rendering/vtkMesaImageActor.h File Reference

#include "vtkImageActor.h"

Include dependency graph for vtkMesaImageActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaImageActor
Mesa texture map. More...

Generated on Mon Mar 25 01:14:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageMapper.h File Reference

Rendering/vtkMesaImageMapper.h File Reference

#include "vtkImageMapper.h"

Include dependency graph for vtkMesaImageMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaImageMapper
2D image display support for Mesa. More...

Generated on Mon Mar 25 01:14:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImager.h File Reference

Rendering/vtkMesaImager.h File Reference

#include "vtkImager.h"

Include dependency graph for vtkMesaImager.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaImager

Generated on Mon Mar 25 01:14:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageWindow.h File Reference

Rendering/vtkMesaImageWindow.h File Reference

#include "MangleMesaInclude/glx_mangle.h"
#include "MangleMesaInclude/glx.h"
#include "MangleMesaInclude/osmesa.h"
#include <stdlib.h>
#include <X11/X.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include "vtkToolkits.h"
#include "vtkXImageWindow.h"

Include dependency graph for vtkMesaImageWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaImageWindow
Mesa Imageing window. More...

Generated on Mon Mar 25 01:14:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaLight.h File Reference

Rendering/vtkMesaLight.h File Reference

#include "vtkLight.h"

Include dependency graph for vtkMesaLight.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaLight
Mesa light. More...

Generated on Mon Mar 25 01:14:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaPolyDataMapper.h File Reference

Rendering/vtkMesaPolyDataMapper.h File Reference

#include "MangleMesaInclude/gl_mangle.h"
#include "MangleMesaInclude/gl.h"
#include "vtkPolyDataMapper.h"
#include <stdlib.h>
#include "vtkToolkits.h"

Include dependency graph for vtkMesaPolyDataMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaPolyDataMapper
a PolyDataMapper for the Mesa library. More...

Generated on Mon Mar 25 01:14:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaPolyDataMapper2D.h File Reference

Rendering/vtkMesaPolyDataMapper2D.h File Reference

#include "vtkPolyDataMapper2D.h"

Include dependency graph for vtkMesaPolyDataMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaPolyDataMapper2D

Generated on Mon Mar 25 01:14:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaProperty.h File Reference

Rendering/vtkMesaProperty.h File Reference

#include "vtkProperty.h"

Include dependency graph for vtkMesaProperty.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaProperty
Mesa property. More...

Generated on Mon Mar 25 01:14:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaRenderer.h File Reference

Rendering/vtkMesaRenderer.h File Reference

#include <stdlib.h>
#include "vtkRenderer.h"

Include dependency graph for vtkMesaRenderer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaRenderer
OpenGL renderer. More...

Generated on Mon Mar 25 01:14:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaRenderWindow.h File Reference

Rendering/vtkMesaRenderWindow.h File Reference

#include "MangleMesaInclude/gl_mangle.h"
#include <MangleMesaInclude/gl.h>
#include <stdlib.h>
#include "vtkRenderWindow.h"

Include dependency graph for vtkMesaRenderWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkMesaRenderWindow
Mesa rendering window. More...

Generated on Mon Mar 25 01:14:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaTexture.h File Reference

Rendering/vtkMesaTexture.h File Reference

#include "vtkTexture.h"

Include dependency graph for vtkMesaTexture.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaTexture
Mesa texture map. More...

Generated on Mon Mar 25 01:14:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaVolumeRayCastMapper.h File Reference

Rendering/vtkMesaVolumeRayCastMapper.h File Reference

#include "MangleMesaInclude/gl_mangle.h"
#include "MangleMesaInclude/gl.h"
#include "vtkVolumeRayCastMapper.h"
#include <stdlib.h>
#include "vtkToolkits.h"

Include dependency graph for vtkMesaVolumeRayCastMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaVolumeRayCastMapper
Mesa subclass that draws the image to the screen. More...

Generated on Mon Mar 25 01:14:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaVolumeTextureMapper2D.h File Reference

Rendering/vtkMesaVolumeTextureMapper2D.h File Reference

#include "vtkVolumeTextureMapper2D.h"

Include dependency graph for vtkMesaVolumeTextureMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkMesaVolumeTextureMapper2D
Abstract class for a volume mapper. More...

Generated on Mon Mar 25 01:14:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBJExporter.h File Reference

Rendering/vtkOBJExporter.h File Reference

#include <stdio.h>
#include "vtkExporter.h"

Include dependency graph for vtkOBJExporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOBJExporter
export a scene into Wavefront format. More...

Generated on Mon Mar 25 01:14:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOOGLExporter.h File Reference

Rendering/vtkOOGLExporter.h File Reference

#include <stdio.h>
#include "vtkExporter.h"

Include dependency graph for vtkOOGLExporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOOGLExporter
export a scene into Geomview OOGL format. More...

Generated on Mon Mar 25 01:14:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLActor.h File Reference

Rendering/vtkOpenGLActor.h File Reference

#include "vtkActor.h"

Include dependency graph for vtkOpenGLActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLActor
OpenGL actor. More...

Generated on Mon Mar 25 01:14:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLCamera.h File Reference

Rendering/vtkOpenGLCamera.h File Reference

#include "vtkCamera.h"

Include dependency graph for vtkOpenGLCamera.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLCamera
OpenGL camera. More...

Generated on Mon Mar 25 01:14:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageActor.h File Reference

Rendering/vtkOpenGLImageActor.h File Reference

#include "vtkImageActor.h"

Include dependency graph for vtkOpenGLImageActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLImageActor
OpenGL texture map. More...

Generated on Mon Mar 25 01:14:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageMapper.h File Reference

Rendering/vtkOpenGLImageMapper.h File Reference

#include "vtkImageMapper.h"

Include dependency graph for vtkOpenGLImageMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLImageMapper
2D image display support for OpenGL. More...

Generated on Mon Mar 25 01:14:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImager.h File Reference

Rendering/vtkOpenGLImager.h File Reference

#include "vtkImager.h"

Include dependency graph for vtkOpenGLImager.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLImager

Generated on Mon Mar 25 01:14:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageWindow.h File Reference

Rendering/vtkOpenGLImageWindow.h File Reference

#include <stdlib.h>
#include <X11/X.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include "vtkXImageWindow.h"
#include "GL/glx.h"

Include dependency graph for vtkOpenGLImageWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLImageWindow
OpenGL Imageing window. More...

Generated on Mon Mar 25 01:14:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLLight.h File Reference

Rendering/vtkOpenGLLight.h File Reference

#include "vtkLight.h"

Include dependency graph for vtkOpenGLLight.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLLight
OpenGL light. More...

Generated on Mon Mar 25 01:14:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLPolyDataMapper.h File Reference

Rendering/vtkOpenGLPolyDataMapper.h File Reference

#include "vtkPolyDataMapper.h"
#include <stdlib.h>
#include <GL/gl.h>

Include dependency graph for vtkOpenGLPolyDataMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLPolyDataMapper
a PolyDataMapper for the OpenGL library. More...

Generated on Mon Mar 25 01:14:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLPolyDataMapper2D.h File Reference

Rendering/vtkOpenGLPolyDataMapper2D.h File Reference

#include "vtkPolyDataMapper2D.h"

Include dependency graph for vtkOpenGLPolyDataMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLPolyDataMapper2D

Generated on Mon Mar 25 01:14:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLProperty.h File Reference

Rendering/vtkOpenGLProperty.h File Reference

#include "vtkProperty.h"

Include dependency graph for vtkOpenGLProperty.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLProperty
OpenGL property. More...

Generated on Mon Mar 25 01:14:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLRenderer.h File Reference

Rendering/vtkOpenGLRenderer.h File Reference

#include <stdlib.h>
#include "vtkRenderer.h"

Include dependency graph for vtkOpenGLRenderer.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLRenderer
OpenGL renderer. More...

Generated on Mon Mar 25 01:14:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLRenderWindow.h File Reference

Rendering/vtkOpenGLRenderWindow.h File Reference

#include <stdlib.h>
#include "vtkRenderWindow.h"
#include <GL/gl.h>

Include dependency graph for vtkOpenGLRenderWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLRenderWindow
OpenGL rendering window. More...

Generated on Mon Mar 25 01:14:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLStateCache.h File Reference

Rendering/vtkOpenGLStateCache.h File Reference

#include <GL/gl.h>

Include dependency graph for vtkOpenGLStateCache.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkOpenGLStateCache

Defines

#define | vtkOpenGLCall_glEnable vtkOpenGLStateCache::CurrentGLCache->glEnable
#define | vtkOpenGLCall_glDisable vtkOpenGLStateCache::CurrentGLCache->glDisable
#define | vtkOpenGLCall_glAlphaFunc vtkOpenGLStateCache::CurrentGLCache->glAlphaFunc
#define | vtkOpenGLCall_glBlendFunc vtkOpenGLStateCache::CurrentGLCache->glBlendFunc
#define | vtkOpenGLCall_glDepthFunc vtkOpenGLStateCache::CurrentGLCache->glDepthFunc
#define | vtkOpenGLCall_glTexEnvf vtkOpenGLStateCache::CurrentGLCache->glTexEnvf
#define | vtkOpenGLCall_glLightModeli vtkOpenGLStateCache::CurrentGLCache->glLightModeli
#define | vtkOpenGLCall_glLightModelfv vtkOpenGLStateCache::CurrentGLCache->glLightMOdelfv
#define | vtkOpenGLCall_glLightfv vtkOpenGLStateCache::CurrentGLCache->glLightfv
#define | vtkOpenGLCall_glLightf vtkOpenGLStateCache::CurrentGLCache->glLightf
#define | vtkOpenGLCall_glLighti vtkOpenGLStateCache::CurrentGLCache->glLighti
#define | vtkOpenGLCall_glMaterialfv vtkOpenGLStateCache::CurrentGLCache->glMaterialfv
#define | vtkOpenGLCall_glShadeModel vtkOpenGLStateCache::CurrentGLCache->glShadeModel
#define | vtkOpenGLCall_glClearColor vtkOpenGLStateCache::CurrentGLCache->glClearColor
#define | vtkOpenGLCall_glClearDepth vtkOpenGLStateCache::CurrentGLCache->glClearDepth
#define | vtkOpenGLCall_glDepthMask vtkOpenGLStateCache::CurrentGLCache->glDepthMask
#define | vtkOpenGLCall_glCullFace vtkOpenGLStateCache::CurrentGLCache->glCullFace
#define | vtkOpenGLCall_glClear vtkOpenGLStateCache::CurrentGLCache->glClear
#define | vtkOpenGLCall_glDrawBuffer vtkOpenGLStateCache::CurrentGLCache->glDrawBuffer
#define | vtkOpenGLCall_glMatrixMode vtkOpenGLStateCache::CurrentGLCache->glMatrixMode
#define | vtkOpenGLCall_glViewport vtkOpenGLStateCache::CurrentGLCache->glViewport
#define | vtkOpenGLCall_glScissor vtkOpenGLStateCache::CurrentGLCache->glScissor
#define | vtkOpenGLCall_glClipPlane vtkOpenGLStateCache::CurrentGLCache->glClipPlane
#define | vtkOpenGLCall_glColorMaterial vtkOpenGLStateCache::CurrentGLCache->glColorMaterial
#define | vtkOpenGLCall_glPointSize vtkOpenGLStateCache::CurrentGLCache->glPointSize
#define | vtkOpenGLCall_glLineWidth vtkOpenGLStateCache::CurrentGLCache->glLineWidth
#define | vtkOpenGLCall_glLineStipple vtkOpenGLStateCache::CurrentGLCache->glLineStipple
#define | vtkOpenGLCall_glDepthRange vtkOpenGLStateCache::CurrentGLCache->glDepthRange
#define | vtkOpenGLCall_glPolygonOffset vtkOpenGLStateCache::CurrentGLCache->glPolygonOffset
#define | vtkOpenGLCall_glPushMatrix glPushMatrix
#define | vtkOpenGLCall_glPopMatrix glPopMatrix
#define | vtkOpenGLCall_glMultMatrixd glMultMatrixd
#define | vtkOpenGLCall_glLoadMatrixd glLoadMatrixd
#define | vtkOpenGLCall_glLoadIdentity glLoadIdentity
#define | vtkOpenGLCall_glSelectBuffer glSelectBuffer
#define | vtkOpenGLCall_glRenderMode glRenderMode
#define | vtkOpenGLCall_glInitNames glInitNames
#define | vtkOpenGLCall_glPushName glPushName
#define | vtkOpenGLCall_glLoadName glLoadName
#define | vtkOpenGLCall_glGetIntegerv glGetIntegerv
#define | vtkOpenGLCall_glIsTexture glIsTexture
#define | vtkOpenGLCall_glDeleteTextures glDeleteTexture
#define | vtkOpenGLCall_glGenTextures glGenTextures
#define | vtkOpenGLCall_glBindTexture glBindTexture
#define | vtkOpenGLCall_glTexParameterf glTextParameterf
#define | vtkOpenGLCall_glTexCoord2fv glTexCoord2fv
#define | vtkOpenGLCall_glVertex3fv glVertex3fv
#define | vtkOpenGLCall_glNormal3fv glNormal3fv
#define | vtkOpenGLCall_glColor3f glColor3f
#define | vtkOpenGLCall_glColor4ubv glColor4ubv
#define | vtkOpenGLCall_glColor4fv glColor4fv
#define | vtkOpenGLCall_glBegin glBegin
#define | vtkOpenGLCall_glEnd glEnd
#define | vtkOpenGLCall_glTexImage2D glTextImage2D
#define | vtkOpenGLCall_glDeleteLists glDeleteLists
#define | vtkOpenGLCall_glIsList glIsList
#define | vtkOpenGLCall_glGenLists glGenLists
#define | vtkOpenGLCall_glCallList glCallList
#define | vtkOpenGLCall_glReadBuffer glReadBuffer
#define | vtkOpenGLCall_glPixelStorei glPixelStorei
#define | vtkOpenGLCall_glReadPixels glReadPixels
#define | vtkOpenGLCall_glRasterPos3f glRasterPos3f
#define | vtkOpenGLCall_glDrawPixels glDrawPixels
#define | vtkOpenGLCall_glRasterPos2f glRasterPos2f
#define | vtkOpenGLCall_glNewList glNewList
#define | vtkOpenGLCall_glEndList glEndList

Define Documentation

#define vtkOpenGLCall_glEnable vtkOpenGLStateCache::CurrentGLCache->glEnable

Definition at line 32 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDisable vtkOpenGLStateCache::CurrentGLCache->glDisable

Definition at line 33 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glAlphaFunc vtkOpenGLStateCache::CurrentGLCache->glAlphaFunc

Definition at line 34 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glBlendFunc vtkOpenGLStateCache::CurrentGLCache->glBlendFunc

Definition at line 35 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDepthFunc vtkOpenGLStateCache::CurrentGLCache->glDepthFunc

Definition at line 36 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glTexEnvf vtkOpenGLStateCache::CurrentGLCache->glTexEnvf

Definition at line 37 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLightModeli vtkOpenGLStateCache::CurrentGLCache->glLightModeli

Definition at line 38 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLightModelfv vtkOpenGLStateCache::CurrentGLCache->glLightMOdelfv

Definition at line 39 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLightfv vtkOpenGLStateCache::CurrentGLCache->glLightfv

Definition at line 40 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLightf vtkOpenGLStateCache::CurrentGLCache->glLightf

Definition at line 41 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLighti vtkOpenGLStateCache::CurrentGLCache->glLighti

Definition at line 42 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glMaterialfv vtkOpenGLStateCache::CurrentGLCache->glMaterialfv

Definition at line 43 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glShadeModel vtkOpenGLStateCache::CurrentGLCache->glShadeModel

Definition at line 44 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glClearColor vtkOpenGLStateCache::CurrentGLCache->glClearColor

Definition at line 45 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glClearDepth vtkOpenGLStateCache::CurrentGLCache->glClearDepth

Definition at line 46 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDepthMask vtkOpenGLStateCache::CurrentGLCache->glDepthMask

Definition at line 47 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glCullFace vtkOpenGLStateCache::CurrentGLCache->glCullFace

Definition at line 48 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glClear vtkOpenGLStateCache::CurrentGLCache->glClear

Definition at line 49 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDrawBuffer vtkOpenGLStateCache::CurrentGLCache->glDrawBuffer

Definition at line 50 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glMatrixMode vtkOpenGLStateCache::CurrentGLCache->glMatrixMode

Definition at line 51 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glViewport vtkOpenGLStateCache::CurrentGLCache->glViewport

Definition at line 52 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glScissor vtkOpenGLStateCache::CurrentGLCache->glScissor

Definition at line 53 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glClipPlane vtkOpenGLStateCache::CurrentGLCache->glClipPlane

Definition at line 54 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glColorMaterial vtkOpenGLStateCache::CurrentGLCache->glColorMaterial

Definition at line 55 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPointSize vtkOpenGLStateCache::CurrentGLCache->glPointSize

Definition at line 56 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLineWidth vtkOpenGLStateCache::CurrentGLCache->glLineWidth

Definition at line 57 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLineStipple vtkOpenGLStateCache::CurrentGLCache->glLineStipple

Definition at line 58 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDepthRange vtkOpenGLStateCache::CurrentGLCache->glDepthRange

Definition at line 59 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPolygonOffset vtkOpenGLStateCache::CurrentGLCache->glPolygonOffset

Definition at line 60 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPushMatrix glPushMatrix

Definition at line 62 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPopMatrix glPopMatrix

Definition at line 63 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glMultMatrixd glMultMatrixd

Definition at line 64 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLoadMatrixd glLoadMatrixd

Definition at line 65 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLoadIdentity glLoadIdentity

Definition at line 66 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glSelectBuffer glSelectBuffer

Definition at line 67 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glRenderMode glRenderMode

Definition at line 68 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glInitNames glInitNames

Definition at line 69 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPushName glPushName

Definition at line 70 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glLoadName glLoadName

Definition at line 71 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glGetIntegerv glGetIntegerv

Definition at line 72 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glIsTexture glIsTexture

Definition at line 73 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDeleteTextures glDeleteTexture

Definition at line 74 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glGenTextures glGenTextures

Definition at line 75 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glBindTexture glBindTexture

Definition at line 76 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glTexParameterf glTextParameterf

Definition at line 77 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glTexCoord2fv glTexCoord2fv

Definition at line 78 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glVertex3fv glVertex3fv

Definition at line 79 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glNormal3fv glNormal3fv

Definition at line 80 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glColor3f glColor3f

Definition at line 81 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glColor4ubv glColor4ubv

Definition at line 82 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glColor4fv glColor4fv

Definition at line 83 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glBegin glBegin

Definition at line 84 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glEnd glEnd

Definition at line 85 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glTexImage2D glTextImage2D

Definition at line 86 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDeleteLists glDeleteLists

Definition at line 87 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glIsList glIsList

Definition at line 88 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glGenLists glGenLists

Definition at line 89 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glCallList glCallList

Definition at line 90 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glReadBuffer glReadBuffer

Definition at line 91 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glPixelStorei glPixelStorei

Definition at line 92 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glReadPixels glReadPixels

Definition at line 93 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glRasterPos3f glRasterPos3f

Definition at line 94 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glDrawPixels glDrawPixels

Definition at line 95 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glRasterPos2f glRasterPos2f

Definition at line 96 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glNewList glNewList

Definition at line 97 of file vtkOpenGLStateCache.h.

#define vtkOpenGLCall_glEndList glEndList

Definition at line 98 of file vtkOpenGLStateCache.h.

Generated on Mon Mar 25 01:14:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLTexture.h File Reference

Rendering/vtkOpenGLTexture.h File Reference

#include "vtkTexture.h"

Include dependency graph for vtkOpenGLTexture.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLTexture
OpenGL texture map. More...

Generated on Mon Mar 25 01:14:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeProVG500Mapper.h File Reference

Rendering/vtkOpenGLVolumeProVG500Mapper.h File Reference

#include "vtkVolumeProVG500Mapper.h"

Include dependency graph for vtkOpenGLVolumeProVG500Mapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLVolumeProVG500Mapper
Concrete class for VolumePRO mapper. More...

Generated on Mon Mar 25 01:14:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeProVP1000Mapper.h File Reference

Rendering/vtkOpenGLVolumeProVP1000Mapper.h File Reference

#include "vtkVolumeProVP1000Mapper.h"

Include dependency graph for vtkOpenGLVolumeProVP1000Mapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLVolumeProVP1000Mapper
Concrete class for VolumePRO mapper. More...

Generated on Mon Mar 25 01:14:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeRayCastMapper.h File Reference

Rendering/vtkOpenGLVolumeRayCastMapper.h File Reference

#include "vtkVolumeRayCastMapper.h"
#include <stdlib.h>
#include <GL/gl.h>

Include dependency graph for vtkOpenGLVolumeRayCastMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLVolumeRayCastMapper
OpenGL subclass that draws the image to the screen. More...

Generated on Mon Mar 25 01:14:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeTextureMapper2D.h File Reference

Rendering/vtkOpenGLVolumeTextureMapper2D.h File Reference

#include "vtkVolumeTextureMapper2D.h"

Include dependency graph for vtkOpenGLVolumeTextureMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkOpenGLVolumeTextureMapper2D
Abstract class for a volume mapper. More...

Generated on Mon Mar 25 01:14:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParallelCoordinatesActor.h File Reference

Rendering/vtkParallelCoordinatesActor.h File Reference

#include "vtkAxisActor2D.h"
#include "vtkDataObject.h"

Include dependency graph for vtkParallelCoordinatesActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkParallelCoordinatesActor
create parallel coordinate display from input field. More...

Defines

#define | VTK_IV_COLUMN 0
#define | VTK_IV_ROW 1

Define Documentation

#define VTK_IV_COLUMN 0

Definition at line 66 of file vtkParallelCoordinatesActor.h.

#define VTK_IV_ROW 1

Definition at line 67 of file vtkParallelCoordinatesActor.h.

Generated on Mon Mar 25 01:14:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPicker.h File Reference

Rendering/vtkPicker.h File Reference

#include "vtkObject.h"
#include "vtkAbstractPropPicker.h"
#include "vtkRenderer.h"
#include "vtkActor.h"
#include "vtkActorCollection.h"
#include "vtkProp3DCollection.h"
#include "vtkMapper.h"
#include "vtkTransform.h"

Include dependency graph for vtkPicker.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPicker
superclass for 3D geometric pickers (uses ray cast). More...

Generated on Mon Mar 25 01:14:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointPicker.h File Reference

Rendering/vtkPointPicker.h File Reference

#include "vtkPicker.h"

Include dependency graph for vtkPointPicker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPointPicker
select a point by shooting a ray into a graphics window. More...

Generated on Mon Mar 25 01:14:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataMapper.h File Reference

Rendering/vtkPolyDataMapper.h File Reference

#include "vtkMapper.h"
#include "vtkPolyData.h"
#include "vtkRenderer.h"

Include dependency graph for vtkPolyDataMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataMapper
map vtkPolyData to graphics primitives. More...

Generated on Mon Mar 25 01:14:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataMapper2D.h File Reference

Rendering/vtkPolyDataMapper2D.h File Reference

#include "vtkMapper2D.h"
#include "vtkWindow.h"
#include "vtkViewport.h"
#include "vtkActor2D.h"
#include "vtkProperty2D.h"
#include "vtkScalarsToColors.h"
#include "vtkPolyData.h"

Include dependency graph for vtkPolyDataMapper2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkPolyDataMapper2D
draw vtkPolyData onto the image plane. More...

Generated on Mon Mar 25 01:14:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp3D.h File Reference

Rendering/vtkProp3D.h File Reference

#include "vtkProp.h"
#include "vtkTransform.h"

Include dependency graph for vtkProp3D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkProp3D
represents an 3D object for placement in a rendered scene. More...

Generated on Mon Mar 25 01:14:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp3DCollection.h File Reference

Rendering/vtkProp3DCollection.h File Reference

#include "vtkPropCollection.h"
#include "vtkProp3D.h"

Include dependency graph for vtkProp3DCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkProp3DCollection
a list of 3D props. More...

Generated on Mon Mar 25 01:14:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProperty.h File Reference

Rendering/vtkProperty.h File Reference

#include "vtkRender.h"
#include "vtkObject.h"
#include "vtkStructuredPoints.h"

Include dependency graph for vtkProperty.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkProperty
represent surface properties of a geometric object. More...

Generated on Mon Mar 25 01:14:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropPicker.h File Reference

Rendering/vtkPropPicker.h File Reference

#include "vtkAbstractPropPicker.h"

Include dependency graph for vtkPropPicker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkPropPicker
pick an actor/prop using graphics hardware. More...

Generated on Mon Mar 25 01:14:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzGLView.h File Reference

Rendering/vtkQuartzGLView.h File Reference

#include "vtkInteractorStyle.h"

Include dependency graph for vtkQuartzGLView.h:

Include dependency graph

Go to the source code of this file.

Compounds

interface | vtkQuartzGLView

Defines

#define | id Id

Variables

void | drawRect
id | initWithFrame
vtkQuartzRenderWindow * getVTKRenderWindow
void | setVTKRenderWindow
vtkQuartzRenderWindowInteractor * getVTKRenderWindowInteractor
void | setVTKRenderWindowInteractor

Define Documentation

#define id Id

Definition at line 3 of file vtkQuartzGLView.h.

Variable Documentation

void drawRect

Definition at line 19 of file vtkQuartzGLView.h.

id initWithFrame

Definition at line 20 of file vtkQuartzGLView.h.

vtkQuartzRenderWindow* getVTKRenderWindow

Definition at line 22 of file vtkQuartzGLView.h.

void setVTKRenderWindow

Definition at line 23 of file vtkQuartzGLView.h.

vtkQuartzRenderWindowInteractor* getVTKRenderWindowInteractor

Definition at line 25 of file vtkQuartzGLView.h.

void setVTKRenderWindowInteractor

Definition at line 26 of file vtkQuartzGLView.h.

Generated on Mon Mar 25 01:14:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzImageMapper.h File Reference

Rendering/vtkQuartzImageMapper.h File Reference

#include "vtkImageMapper.h"

Include dependency graph for vtkQuartzImageMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuartzImageMapper
2D image display support for Quartz windows. More...

Generated on Mon Mar 25 01:14:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzImageWindow.h File Reference

Rendering/vtkQuartzImageWindow.h File Reference

#include <stdlib.h>
#include "vtkImageWindow.h"
#include "vtkMutexLock.h"

Include dependency graph for vtkQuartzImageWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuartzImageWindow
OpenGL Imageing window. More...

Generated on Mon Mar 25 01:14:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzRenderWindow.h File Reference

Rendering/vtkQuartzRenderWindow.h File Reference

#include <stdlib.h>
#include "vtkRenderWindow.h"
#include "vtkMutexLock.h"
#include <OpenGL/gl.h>

Include dependency graph for vtkQuartzRenderWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuartzRenderWindow
OpenGL rendering window. More...

Generated on Mon Mar 25 01:14:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzRenderWindowInteractor.h File Reference

Rendering/vtkQuartzRenderWindowInteractor.h File Reference

#include <stdlib.h>
#include "vtkRenderWindowInteractor.h"

Include dependency graph for vtkQuartzRenderWindowInteractor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuartzRenderWindowInteractor
implements Quartz specific functions. More...

Generated on Mon Mar 25 01:14:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzTextMapper.h File Reference

Rendering/vtkQuartzTextMapper.h File Reference

#include "vtkTextMapper.h"

Include dependency graph for vtkQuartzTextMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkQuartzTextMapper
2D Text annotation support for windows. More...

Generated on Mon Mar 25 01:14:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzWindow.h File Reference

Rendering/vtkQuartzWindow.h File Reference

Go to the source code of this file.

Compounds

interface | vtkQuartzWindow

Variables

vtkQuartzGLView * getvtkQuartzGLView
void | setvtkQuartzGLView
void * | getVTKRenderWindow
void | setVTKRenderWindow
void * | getVTKRenderWindowInteractor
void | setVTKRenderWindowInteractor
void | makeCurrentContext
NSSize | windowWillResize
BOOL | windowShouldZoom
void | close

Variable Documentation

vtkQuartzGLView* getvtkQuartzGLView

Definition at line 16 of file vtkQuartzWindow.h.

void setvtkQuartzGLView

Definition at line 17 of file vtkQuartzWindow.h.

void* getVTKRenderWindow

Definition at line 19 of file vtkQuartzWindow.h.

void setVTKRenderWindow

Definition at line 20 of file vtkQuartzWindow.h.

void* getVTKRenderWindowInteractor

Definition at line 22 of file vtkQuartzWindow.h.

void setVTKRenderWindowInteractor

Definition at line 23 of file vtkQuartzWindow.h.

void makeCurrentContext

Definition at line 25 of file vtkQuartzWindow.h.

NSSize windowWillResize

Definition at line 27 of file vtkQuartzWindow.h.

BOOL windowShouldZoom

Definition at line 28 of file vtkQuartzWindow.h.

void close

Definition at line 29 of file vtkQuartzWindow.h.

Generated on Mon Mar 25 01:14:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRayCaster.h File Reference

Rendering/vtkRayCaster.h File Reference

#include "vtkObject.h"
#include "vtkObjectFactory.h"

Include dependency graph for vtkRayCaster.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRayCaster
obsolete class. More...

Generated on Mon Mar 25 01:14:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRecursiveSphereDirectionEncoder.h File Reference

Rendering/vtkRecursiveSphereDirectionEncoder.h File Reference

#include "vtkDirectionEncoder.h"

Include dependency graph for vtkRecursiveSphereDirectionEncoder.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRecursiveSphereDirectionEncoder
A direction encoder based on the recursive subdivision of an octahedron. More...

Generated on Mon Mar 25 01:14:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRender.h File Reference

Rendering/vtkRender.h File Reference

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Defines

#define | VTK_FLAT 0
#define | VTK_GOURAUD 1
#define | VTK_PHONG 2
#define | VTK_POINTS 0
#define | VTK_WIREFRAME 1
#define | VTK_SURFACE 2

Define Documentation

#define VTK_FLAT 0

Definition at line 20 of file vtkRender.h.

#define VTK_GOURAUD 1

Definition at line 21 of file vtkRender.h.

#define VTK_PHONG 2

Definition at line 22 of file vtkRender.h.

#define VTK_POINTS 0

Definition at line 25 of file vtkRender.h.

#define VTK_WIREFRAME 1

Definition at line 26 of file vtkRender.h.

#define VTK_SURFACE 2

Definition at line 27 of file vtkRender.h.

Generated on Mon Mar 25 01:14:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderer.h File Reference

Rendering/vtkRenderer.h File Reference

#include "vtkMatrix4x4.h"
#include "vtkLightCollection.h"
#include "vtkVolumeCollection.h"
#include "vtkCullerCollection.h"
#include "vtkCamera.h"
#include "vtkActor.h"
#include "vtkActor2D.h"
#include "vtkViewport.h"
#include "vtkActorCollection.h"

Include dependency graph for vtkRenderer.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkRenderer
abstract specification for renderers. More...

Generated on Mon Mar 25 01:14:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRendererCollection.h File Reference

Rendering/vtkRendererCollection.h File Reference

#include "vtkCollection.h"
#include "vtkRenderer.h"

Include dependency graph for vtkRendererCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkRendererCollection
a list of renderers. More...

Generated on Mon Mar 25 01:14:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRendererSource.h File Reference

Rendering/vtkRendererSource.h File Reference

#include "vtkStructuredPointsSource.h"
#include "vtkRenderer.h"

Include dependency graph for vtkRendererSource.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRendererSource
take a renderer into the pipeline. More...

Generated on Mon Mar 25 01:14:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindow.h File Reference

Rendering/vtkRenderWindow.h File Reference

#include "vtkWindow.h"
#include "vtkRendererCollection.h"
#include <stdio.h>
#include "vtkGraphicsFactory.h"

Include dependency graph for vtkRenderWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkRenderWindow
create a window for renderers to draw into. More...

Defines

#define | VTK_STEREO_CRYSTAL_EYES 1
#define | VTK_STEREO_RED_BLUE 2
#define | VTK_STEREO_INTERLACED 3
#define | VTK_STEREO_LEFT 4
#define | VTK_STEREO_RIGHT 5
#define | VTK_STEREO_DRESDEN 6

Define Documentation

#define VTK_STEREO_CRYSTAL_EYES 1

Definition at line 74 of file vtkRenderWindow.h.

#define VTK_STEREO_RED_BLUE 2

Definition at line 75 of file vtkRenderWindow.h.

#define VTK_STEREO_INTERLACED 3

Definition at line 76 of file vtkRenderWindow.h.

#define VTK_STEREO_LEFT 4

Definition at line 77 of file vtkRenderWindow.h.

#define VTK_STEREO_RIGHT 5

Definition at line 78 of file vtkRenderWindow.h.

#define VTK_STEREO_DRESDEN 6

Definition at line 79 of file vtkRenderWindow.h.

Generated on Mon Mar 25 01:14:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindowCollection.h File Reference

Rendering/vtkRenderWindowCollection.h File Reference

#include "vtkCollection.h"
#include "vtkRenderWindow.h"

Include dependency graph for vtkRenderWindowCollection.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkRenderWindowCollection
a list of RenderWindows. More...

Generated on Mon Mar 25 01:14:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindowInteractor.h File Reference

Rendering/vtkRenderWindowInteractor.h File Reference

#include "vtkObject.h"
#include "vtkRenderWindow.h"
#include "vtkAbstractPropPicker.h"

Include dependency graph for vtkRenderWindowInteractor.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkRenderWindowInteractor
platform-independent render window interaction including picking and frame rate control. More...

Defines

#define | VTKI_TIMER_FIRST 0
#define | VTKI_TIMER_UPDATE 1

Define Documentation

#define VTKI_TIMER_FIRST 0

Definition at line 65 of file vtkRenderWindowInteractor.h.

#define VTKI_TIMER_UPDATE 1

Definition at line 66 of file vtkRenderWindowInteractor.h.

Generated on Mon Mar 25 01:14:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarBarActor.h File Reference

Rendering/vtkScalarBarActor.h File Reference

#include "vtkActor2D.h"
#include "vtkScalarsToColors.h"
#include "vtkPolyDataMapper2D.h"
#include "vtkTextMapper.h"

Include dependency graph for vtkScalarBarActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkScalarBarActor
Create a scalar bar with labels. More...

Defines

#define | VTK_ORIENT_HORIZONTAL 0
#define | VTK_ORIENT_VERTICAL 1

Define Documentation

#define VTK_ORIENT_HORIZONTAL 0

Definition at line 72 of file vtkScalarBarActor.h.

#define VTK_ORIENT_VERTICAL 1

Definition at line 73 of file vtkScalarBarActor.h.

Generated on Mon Mar 25 01:14:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScaledTextActor.h File Reference

Rendering/vtkScaledTextActor.h File Reference

#include "vtkActor2D.h"
#include "vtkTextMapper.h"

Include dependency graph for vtkScaledTextActor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkScaledTextActor
create text that will scale as needed. More...

Generated on Mon Mar 25 01:14:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSelectVisiblePoints.h File Reference

Rendering/vtkSelectVisiblePoints.h File Reference

#include "vtkDataSetToPolyDataFilter.h"
#include "vtkRenderer.h"

Include dependency graph for vtkSelectVisiblePoints.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkSelectVisiblePoints
extract points that are visible (based on z-buffer calculation). More...

Generated on Mon Mar 25 01:14:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextMapper.h File Reference

Rendering/vtkTextMapper.h File Reference

#include "vtkMapper2D.h"
#include "vtkWindow.h"
#include "vtkViewport.h"
#include "vtkActor2D.h"
#include "vtkProperty2D.h"

Include dependency graph for vtkTextMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkTextMapper
2D text annotation. More...

Defines

#define | VTK_ARIAL 0
#define | VTK_COURIER 1
#define | VTK_TIMES 2
#define | VTK_TEXT_LEFT 0
#define | VTK_TEXT_CENTERED 1
#define | VTK_TEXT_RIGHT 2
#define | VTK_TEXT_BOTTOM 0
#define | VTK_TEXT_TOP 2

Define Documentation

#define VTK_ARIAL 0

Definition at line 63 of file vtkTextMapper.h.

#define VTK_COURIER 1

Definition at line 64 of file vtkTextMapper.h.

#define VTK_TIMES 2

Definition at line 65 of file vtkTextMapper.h.

#define VTK_TEXT_LEFT 0

Definition at line 67 of file vtkTextMapper.h.

#define VTK_TEXT_CENTERED 1

Definition at line 68 of file vtkTextMapper.h.

#define VTK_TEXT_RIGHT 2

Definition at line 69 of file vtkTextMapper.h.

#define VTK_TEXT_BOTTOM 0

Definition at line 71 of file vtkTextMapper.h.

#define VTK_TEXT_TOP 2

Definition at line 72 of file vtkTextMapper.h.

Generated on Mon Mar 25 01:14:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTexture.h File Reference

Rendering/vtkTexture.h File Reference

#include "vtkProcessObject.h"
#include "vtkImageData.h"
#include "vtkLookupTable.h"

Include dependency graph for vtkTexture.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkTexture
handles properties associated with a texture map. More...

Defines

#define | VTK_TEXTURE_QUALITY_DEFAULT 0
#define | VTK_TEXTURE_QUALITY_16BIT 16
#define | VTK_TEXTURE_QUALITY_32BIT 32

Define Documentation

#define VTK_TEXTURE_QUALITY_DEFAULT 0

Definition at line 75 of file vtkTexture.h.

#define VTK_TEXTURE_QUALITY_16BIT 16

Definition at line 76 of file vtkTexture.h.

#define VTK_TEXTURE_QUALITY_32BIT 32

Definition at line 77 of file vtkTexture.h.

Generated on Mon Mar 25 01:14:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkImageViewerWidget.h File Reference

Rendering/vtkTkImageViewerWidget.h File Reference

#include "vtkImageViewer.h"
#include <tcl.h>
#include <tk.h>
#include "vtkTclUtil.h"

Include dependency graph for vtkTkImageViewerWidget.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTkImageViewerWidget
a Tk Widget for viewing vtk images. More...

Generated on Mon Mar 25 01:14:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkImageWindowWidget.h File Reference

Rendering/vtkTkImageWindowWidget.h File Reference

#include "vtkImageWindow.h"
#include <tcl.h>
#include <tk.h>
#include "vtkTclUtil.h"

Include dependency graph for vtkTkImageWindowWidget.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTkImageWindowWidget
a Tk Widget for viewing vtk images. More...

Generated on Mon Mar 25 01:14:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkRenderWidget.h File Reference

Rendering/vtkTkRenderWidget.h File Reference

#include "vtkRenderWindow.h"
#include <tcl.h>
#include <tk.h>
#include "vtkTclUtil.h"

Include dependency graph for vtkTkRenderWidget.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkTkRenderWidget
a Tk Widget for vtk renderering. More...

Generated on Mon Mar 25 01:14:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolume.h File Reference

Rendering/vtkVolume.h File Reference

#include "vtkProp3D.h"
#include "vtkTransform.h"
#include "vtkVolumeProperty.h"
#include "vtkVolumeMapper.h"

Include dependency graph for vtkVolume.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVolume
represents a volume (data & properties) in a rendered scene. More...

Generated on Mon Mar 25 01:14:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeCollection.h File Reference

Rendering/vtkVolumeCollection.h File Reference

#include "vtkPropCollection.h"
#include "vtkVolume.h"

Include dependency graph for vtkVolumeCollection.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVolumeCollection
a list of volumes. More...

Generated on Mon Mar 25 01:14:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeMapper.h File Reference

Rendering/vtkVolumeMapper.h File Reference

#include "vtkAbstractMapper3D.h"
#include "vtkImageData.h"

Include dependency graph for vtkVolumeMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeMapper
Abstract class for a volume mapper. More...

Defines

#define | VTK_CROP_SUBVOLUME 0x0002000
#define | VTK_CROP_FENCE 0x2ebfeba
#define | VTK_CROP_INVERTED_FENCE 0x5140145
#define | VTK_CROP_CROSS 0x0417410
#define | VTK_CROP_INVERTED_CROSS 0x7be8bef

Define Documentation

#define VTK_CROP_SUBVOLUME 0x0002000

Definition at line 50 of file vtkVolumeMapper.h.

#define VTK_CROP_FENCE 0x2ebfeba

Definition at line 51 of file vtkVolumeMapper.h.

#define VTK_CROP_INVERTED_FENCE 0x5140145

Definition at line 52 of file vtkVolumeMapper.h.

#define VTK_CROP_CROSS 0x0417410

Definition at line 53 of file vtkVolumeMapper.h.

#define VTK_CROP_INVERTED_CROSS 0x7be8bef

Definition at line 54 of file vtkVolumeMapper.h.

Generated on Mon Mar 25 01:14:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProMapper.h File Reference

Rendering/vtkVolumeProMapper.h File Reference

#include "vtkVolumeMapper.h"
#include "vtkToolkits.h"
#include "vtkVersion.h"

Include dependency graph for vtkVolumeProMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeProMapper
Superclass for VolumePRO volume rendering mappers. More...

Defines

#define | VTK_BLEND_MODE_COMPOSITE 0
#define | VTK_BLEND_MODE_MAX_INTENSITY 1
#define | VTK_BLEND_MODE_MIN_INTENSITY 2
#define | VTK_CURSOR_TYPE_CROSSHAIR 0
#define | VTK_CURSOR_TYPE_PLANE 1
#define | VTK_VOLUME_8BIT 0
#define | VTK_VOLUME_12BIT_UPPER 1
#define | VTK_VOLUME_12BIT_LOWER 2

Define Documentation

#define VTK_BLEND_MODE_COMPOSITE 0

Definition at line 80 of file vtkVolumeProMapper.h.

#define VTK_BLEND_MODE_MAX_INTENSITY 1

Definition at line 81 of file vtkVolumeProMapper.h.

#define VTK_BLEND_MODE_MIN_INTENSITY 2

Definition at line 82 of file vtkVolumeProMapper.h.

#define VTK_CURSOR_TYPE_CROSSHAIR 0

Definition at line 84 of file vtkVolumeProMapper.h.

#define VTK_CURSOR_TYPE_PLANE 1

Definition at line 85 of file vtkVolumeProMapper.h.

#define VTK_VOLUME_8BIT 0

Definition at line 87 of file vtkVolumeProMapper.h.

#define VTK_VOLUME_12BIT_UPPER 1

Definition at line 88 of file vtkVolumeProMapper.h.

#define VTK_VOLUME_12BIT_LOWER 2

Definition at line 89 of file vtkVolumeProMapper.h.

Generated on Mon Mar 25 01:14:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProperty.h File Reference

Rendering/vtkVolumeProperty.h File Reference

#include "vtkObject.h"
#include "vtkPiecewiseFunction.h"
#include "vtkColorTransferFunction.h"
#include "vtkTimeStamp.h"

Include dependency graph for vtkVolumeProperty.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeProperty
represents the common properties for rendering a volume. More...

Defines

#define | VTK_NEAREST_INTERPOLATION 0
#define | VTK_LINEAR_INTERPOLATION 1

Define Documentation

#define VTK_NEAREST_INTERPOLATION 0

Definition at line 70 of file vtkVolumeProperty.h.

#define VTK_LINEAR_INTERPOLATION 1

Definition at line 71 of file vtkVolumeProperty.h.

Generated on Mon Mar 25 01:14:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProVG500Mapper.h File Reference

Rendering/vtkVolumeProVG500Mapper.h File Reference

#include "vtkVolumeProMapper.h"
#include "vli/include/vli.h"

Include dependency graph for vtkVolumeProVG500Mapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeProVG500Mapper
Superclass for VG500 board. More...

Defines

#define | VTK_VOLUMEPRO_EXPORT

Define Documentation

#define VTK_VOLUMEPRO_EXPORT

Definition at line 74 of file vtkVolumeProVG500Mapper.h.

Generated on Mon Mar 25 01:14:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProVP1000Mapper.h File Reference

Rendering/vtkVolumeProVP1000Mapper.h File Reference

#include "vtkVolumeProMapper.h"
#include "vli3/include/vli.h"

Include dependency graph for vtkVolumeProVP1000Mapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeProVP1000Mapper
Superclass for VP1000 board. More...

Defines

#define | VTK_VOLUME_16BIT 3
#define | VTK_VOLUME_32BIT 4

Define Documentation

#define VTK_VOLUME_16BIT 3

Definition at line 70 of file vtkVolumeProVP1000Mapper.h.

#define VTK_VOLUME_32BIT 4

Definition at line 71 of file vtkVolumeProVP1000Mapper.h.

Generated on Mon Mar 25 01:14:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastCompositeFunction.h File Reference

Rendering/vtkVolumeRayCastCompositeFunction.h File Reference

#include "vtkVolumeRayCastFunction.h"

Include dependency graph for vtkVolumeRayCastCompositeFunction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeRayCastCompositeFunction
a ray function for compositing. More...

Defines

#define | VTK_COMPOSITE_CLASSIFY_FIRST 0
#define | VTK_COMPOSITE_INTERPOLATE_FIRST 1

Define Documentation

#define VTK_COMPOSITE_CLASSIFY_FIRST 0

Definition at line 49 of file vtkVolumeRayCastCompositeFunction.h.

#define VTK_COMPOSITE_INTERPOLATE_FIRST 1

Definition at line 50 of file vtkVolumeRayCastCompositeFunction.h.

Generated on Mon Mar 25 01:14:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastFunction.h File Reference

Rendering/vtkVolumeRayCastFunction.h File Reference

#include "vtkObject.h"

Include dependency graph for vtkVolumeRayCastFunction.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

struct | VTKVRCDynamicInfo
struct | VTKVRCStaticInfo
class | vtkVolumeRayCastFunction
a superclass for ray casting functions. More...

Generated on Mon Mar 25 01:14:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastIsosurfaceFunction.h File Reference

Rendering/vtkVolumeRayCastIsosurfaceFunction.h File Reference

#include "vtkVolumeRayCastFunction.h"

Include dependency graph for vtkVolumeRayCastIsosurfaceFunction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVolumeRayCastIsosurfaceFunction
An isosurface ray caster for volumes. More...

Generated on Mon Mar 25 01:14:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastMapper.h File Reference

Rendering/vtkVolumeRayCastMapper.h File Reference

#include "vtkVolumeMapper.h"
#include "vtkMultiThreader.h"
#include "vtkVolumeRayCastFunction.h"
#include "vtkEncodedGradientShader.h"
#include "vtkEncodedGradientEstimator.h"

Include dependency graph for vtkVolumeRayCastMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeRayCastMapper
A slow but accurate mapper for rendering volumes. More...

Defines

#define | vtkFloorFuncMacro(x) (((x) < 0.0)?((int)((x)-1.0)):((int)(x)))
#define | vtkRoundFuncMacro(x) (int)((x)+0.5)
#define | vtkTrilinFuncMacro(v, x, y, z, a, b, c, d, e, f, g, h)

Define Documentation

#define vtkFloorFuncMacro ( x ) (((x) < 0.0)?((int)((x)-1.0)):((int)(x)))

Definition at line 58 of file vtkVolumeRayCastMapper.h.

#define vtkRoundFuncMacro ( x ) (int)((x)+0.5)

Definition at line 61 of file vtkVolumeRayCastMapper.h.

#define vtkTrilinFuncMacro | ( | v,
 |  | x,
 |  | y,
 |  | z,
 |  | a,
 |  | b,
 |  | c,
 |  | d,
 |  | e,
 |  | f,
 |  | g,
 |  | h | )

Value:

t00 =   a + (x)*(b-a);      \
        t01 =   c + (x)*(d-c);      \
        t10 =   e + (x)*(f-e);      \
        t11 =   g + (x)*(h-g);      \
        t0  = t00 + (y)*(t01-t00);  \
        t1  = t10 + (y)*(t11-t10);  \
        v   =  t0 + (z)*(t1-t0);

Definition at line 66 of file vtkVolumeRayCastMapper.h.

Generated on Mon Mar 25 01:14:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastMIPFunction.h File Reference

Rendering/vtkVolumeRayCastMIPFunction.h File Reference

#include "vtkVolumeRayCastFunction.h"

Include dependency graph for vtkVolumeRayCastMIPFunction.h:

Include dependency graph

Go to the source code of this file.

Compounds

class | vtkVolumeRayCastMIPFunction
A maximum intensity projection ray caster for volumes. More...

Defines

#define | VTK_MAXIMIZE_SCALAR_VALUE 0
#define | VTK_MAXIMIZE_OPACITY 1

Define Documentation

#define VTK_MAXIMIZE_SCALAR_VALUE 0

Definition at line 52 of file vtkVolumeRayCastMIPFunction.h.

#define VTK_MAXIMIZE_OPACITY 1

Definition at line 53 of file vtkVolumeRayCastMIPFunction.h.

Generated on Mon Mar 25 01:14:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastStructures.h File Reference

Rendering/vtkVolumeRayCastStructures.h File Reference

Go to the source code of this file.

Compounds

struct VTKRayCastVolumeInfo

Generated on Mon Mar 25 01:14:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeTextureMapper.h File Reference

Rendering/vtkVolumeTextureMapper.h File Reference

#include "vtkVolumeMapper.h"
#include "vtkEncodedGradientShader.h"
#include "vtkEncodedGradientEstimator.h"

Include dependency graph for vtkVolumeTextureMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVolumeTextureMapper
Abstract class for a volume mapper. More...

Generated on Mon Mar 25 01:14:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeTextureMapper2D.h File Reference

Rendering/vtkVolumeTextureMapper2D.h File Reference

#include "vtkVolumeTextureMapper.h"

Include dependency graph for vtkVolumeTextureMapper2D.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkVolumeTextureMapper2D
Abstract class for a volume mapper. More...

Generated on Mon Mar 25 01:14:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRMLExporter.h File Reference

Rendering/vtkVRMLExporter.h File Reference

#include <stdio.h>
#include "vtkExporter.h"

Include dependency graph for vtkVRMLExporter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkVRMLExporter
export a scene into VRML 2.0 format. More...

Generated on Mon Mar 25 01:14:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32ImageMapper.h File Reference

Rendering/vtkWin32ImageMapper.h File Reference

#include "vtkImageMapper.h"
#include "vtkLookupTable.h"

Include dependency graph for vtkWin32ImageMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32ImageMapper
(obsolete) 2D image display support for Microsoft windows. More...

Generated on Mon Mar 25 01:14:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32ImageWindow.h File Reference

Rendering/vtkWin32ImageWindow.h File Reference

#include "vtkImageWindow.h"

Include dependency graph for vtkWin32ImageWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32ImageWindow
(obsolete)2D display window for Windows. More...

Generated on Mon Mar 25 01:14:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLImageWindow.h File Reference

Rendering/vtkWin32OpenGLImageWindow.h File Reference

#include <stdlib.h>
#include "vtkImageWindow.h"
#include "vtkMutexLock.h"

Include dependency graph for vtkWin32OpenGLImageWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32OpenGLImageWindow
OpenGL Imageing window. More...

Generated on Mon Mar 25 01:14:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLRenderWindow.h File Reference

Rendering/vtkWin32OpenGLRenderWindow.h File Reference

#include <stdlib.h>
#include "vtkOpenGLRenderWindow.h"
#include <GL/gl.h>

Include dependency graph for vtkWin32OpenGLRenderWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32OpenGLRenderWindow
OpenGL rendering window. More...

Generated on Mon Mar 25 01:14:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLTextMapper.h File Reference

Rendering/vtkWin32OpenGLTextMapper.h File Reference

#include "vtkWin32TextMapper.h"

Include dependency graph for vtkWin32OpenGLTextMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32OpenGLTextMapper
2D Text annotation support for windows. More...

Generated on Mon Mar 25 01:14:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32PolyDataMapper2D.h File Reference

Rendering/vtkWin32PolyDataMapper2D.h File Reference

#include "vtkPolyDataMapper2D.h"

Include dependency graph for vtkWin32PolyDataMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32PolyDataMapper2D
2D PolyData support for windows. More...

Generated on Mon Mar 25 01:14:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32RenderWindowInteractor.h File Reference

Rendering/vtkWin32RenderWindowInteractor.h File Reference

#include <stdlib.h>
#include "vtkRenderWindowInteractor.h"

Include dependency graph for vtkWin32RenderWindowInteractor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWin32RenderWindowInteractor
implements Win32 specific functions. More...

Generated on Mon Mar 25 01:14:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32TextMapper.h File Reference

Rendering/vtkWin32TextMapper.h File Reference

#include "vtkTextMapper.h"

Include dependency graph for vtkWin32TextMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkWin32TextMapper
2D Text annotation support for windows. More...

Generated on Mon Mar 25 01:14:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWinCEOpenGLRenderWindow.h File Reference

Rendering/vtkWinCEOpenGLRenderWindow.h File Reference

#include <stdlib.h>
#include "vtkOpenGLRenderWindow.h"
#include "GL/osmesa.h"

Include dependency graph for vtkWinCEOpenGLRenderWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWinCEOpenGLRenderWindow
OpenGL rendering window. More...

Generated on Mon Mar 25 01:14:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowToImageFilter.h File Reference

Rendering/vtkWindowToImageFilter.h File Reference

#include "vtkImageSource.h"

Include dependency graph for vtkWindowToImageFilter.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWindowToImageFilter
Use a vtkWindow as input to image pipeline. More...

Generated on Mon Mar 25 01:14:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWorldPointPicker.h File Reference

Rendering/vtkWorldPointPicker.h File Reference

#include "vtkAbstractPropPicker.h"

Include dependency graph for vtkWorldPointPicker.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkWorldPointPicker
find world x,y,z corresponding to display x,y,z. More...

Generated on Mon Mar 25 01:14:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXImageMapper.h File Reference

Rendering/vtkXImageMapper.h File Reference

#include "vtkImageMapper.h"
#include "vtkWindow.h"
#include "vtkViewport.h"
#include "vtkImageData.h"
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <X11/cursorfont.h>
#include <X11/X.h>
#include <X11/keysym.h>

Include dependency graph for vtkXImageMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXImageMapper
2D image display support for X windows. More...

Generated on Mon Mar 25 01:14:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXImageWindow.h File Reference

Rendering/vtkXImageWindow.h File Reference

#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <X11/cursorfont.h>
#include <X11/X.h>
#include <X11/keysym.h>
#include "vtkImageWindow.h"

Include dependency graph for vtkXImageWindow.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkXImageWindow
2D display window for X. More...

Generated on Mon Mar 25 01:14:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMesaRenderWindow.h File Reference

Rendering/vtkXMesaRenderWindow.h File Reference

#include "MangleMesaInclude/gl_mangle.h"
#include "MangleMesaInclude/glx_mangle.h"
#include <stdlib.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include "vtkMesaRenderWindow.h"
#include "MangleMesaInclude/glx.h"
#include "MangleMesaInclude/osmesa.h"

Include dependency graph for vtkXMesaRenderWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXMesaRenderWindow
Mesa rendering window. More...

Generated on Mon Mar 25 01:14:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMesaTextMapper.h File Reference

Rendering/vtkXMesaTextMapper.h File Reference

#include "vtkXTextMapper.h"

Include dependency graph for vtkXMesaTextMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXMesaTextMapper

Generated on Mon Mar 25 01:14:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXOpenGLRenderWindow.h File Reference

Rendering/vtkXOpenGLRenderWindow.h File Reference

#include <stdlib.h>
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include "vtkOpenGLRenderWindow.h"
#include "GL/glx.h"
#include "vtkToolkits.h"

Include dependency graph for vtkXOpenGLRenderWindow.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXOpenGLRenderWindow
OpenGL rendering window. More...

Generated on Mon Mar 25 01:14:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXOpenGLTextMapper.h File Reference

Rendering/vtkXOpenGLTextMapper.h File Reference

#include "vtkXTextMapper.h"

Include dependency graph for vtkXOpenGLTextMapper.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXOpenGLTextMapper
2D Text annotation support for windows. More...

Generated on Mon Mar 25 01:15:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXPolyDataMapper2D.h File Reference

Rendering/vtkXPolyDataMapper2D.h File Reference

#include "vtkPolyDataMapper2D.h"

Include dependency graph for vtkXPolyDataMapper2D.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXPolyDataMapper2D
2D PolyData support for windows. More...

Generated on Mon Mar 25 01:15:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXRenderWindowInteractor.h File Reference

Rendering/vtkXRenderWindowInteractor.h File Reference

#include "vtkRenderWindowInteractor.h"
#include <X11/StringDefs.h>
#include <X11/Intrinsic.h>

Include dependency graph for vtkXRenderWindowInteractor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXRenderWindowInteractor
an X event driven interface for a RenderWindow. More...

Generated on Mon Mar 25 01:15:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXRenderWindowTclInteractor.h File Reference

Rendering/vtkXRenderWindowTclInteractor.h File Reference

#include "vtkRenderWindowInteractor.h"
#include <X11/StringDefs.h>
#include <X11/Intrinsic.h>

Include dependency graph for vtkXRenderWindowTclInteractor.h:

Include dependency graph

Go to the source code of this file.

Compounds

class vtkXRenderWindowTclInteractor
a TCL event driven interface for a RenderWindow. More...

Generated on Mon Mar 25 01:15:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXTextMapper.h File Reference

Rendering/vtkXTextMapper.h File Reference

#include "vtkTextMapper.h"
#include <X11/Xlib.h>
#include <X11/Xutil.h>
#include <X11/cursorfont.h>
#include <X11/X.h>
#include <X11/keysym.h>

Include dependency graph for vtkXTextMapper.h:

Include dependency graph

This graph shows which files directly or indirectly include this file:

Included by dependency graph

Go to the source code of this file.

Compounds

class vtkXTextMapper
2D Text annotation support for X. More...

Generated on Mon Mar 25 01:15:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Annotated Index

VTK Compound List

Here are the classes, structs, unions and interfaces with brief descriptions:
vtk3DSImporter | Imports 3D Studio files
_vtkLink_s |
_vtkLocalTri |
_vtkLocalVertex |
_vtkPriorityItem |
_vtkProLocalTri |
_vtkProLocalVertex |
_vtkStreamPoint |
_vtkTclVoidFuncArg |
vtkAbstractList< DType > | A dynamic list data structure
vtkAbstractMapper | Abstract class specifies interface to map data
vtkAbstractMapper3D | Abstract class specifies interface to map 3D data
vtkAbstractPicker | Define API for picking subclasses
vtkAbstractPropPicker | Abstract API for pickers that can pick an instance of vtkProp
vtkAbstractTransform | Superclass for all geometric transformations
vtkActor | Represents an object (geometry & properties) in a rendered scene
vtkActor2D | A actor that draws 2D data
vtkActor2DCollection |
vtkActorCollection | A list of actors
vtkAppendFilter | Appends one or more datasets together into a single unstructured grid
vtkAppendPolyData | Appends one or more polygonal datasets together
vtkApproximatingSubdivisionFilter | Generate a subdivision surface using an Approximating Scheme
vtkArcPlotter | Plot data along an arbitrary polyline
vtkArrayCalculator | Perform mathematical operations on data in field data arrays
vtkArrowSource | Appends a cylinder to a cone to form an arrow
vtkAssembly | Create hierarchies of vtkProp3Ds (transformable props)
vtkAssemblyNode | Represent a node in an assembly
vtkAssemblyPath | A list of nodes that form an assembly path
vtkAssemblyPaths | A list of lists of props representing an assembly hierarchy
vtkAssignAttribute | Labels a field as an attribute
vtkAttributeDataToFieldDataFilter | Map attribute data to field data
vtkAxes | Create an x-y-z axes
vtkAxisActor2D | Create an axis with tick marks and labels
vtkBandedPolyDataContourFilter | Generate filled contours for vtkPolyData
vtkBitArray | Dynamic, self-adjusting array of bits
vtkBlankStructuredGrid | Translate point attribute data into a blanking field
vtkBlankStructuredGridWithImage | Blank a structured grid with an image
vtkBMPReader | Read Windows BMP files
vtkBMPWriter | Writes Windows BMP files
vtkBooleanTexture | Generate 2D texture map based on combinations of inside, outside, and on region boundary
vtkBranchExtentTranslator | Uses alternative source for whole extent
vtkBrownianPoints | Assign random vector to points
vtkButterflySubdivisionFilter | Generate a subdivision surface using the Butterfly Scheme
vtkButtonSource | Create a ellipsoidal-shaped button
vtkByteSwap | Perform machine dependent byte swapping
vtkBYUReader | Read MOVIE.BYU polygon files
vtkBYUWriter | Write MOVIE.BYU files
vtkCallbackCommand | Generic callback
Camera |
vtkCamera | A virtual camera for 3D rendering
vtkCaptionActor2D | Draw text label associated with a point
vtkCardinalSpline | Computes an interpolating spline using a
vtkCastToConcrete | Works around type-checking limitations
vtkCell | Abstract class to specify cell behavior
vtkCell3D | Abstract class to specify 3D cell interface
vtkCellArray | Object to represent cell connectivity
vtkCellCenters | Generate points at center of cells
vtkCellData | Represent and manipulate cell attribute data
vtkCellDataToPointData | Map cell data to point data
vtkCellDerivatives | Compute derivatives of scalars and vectors
vtkCellLinks | Object represents upward pointers from points to list of cells using each point
vtkCellLocator | Octree-based spatial search object to quickly locate cells
vtkCellPicker | Select a cell by shooting a ray into graphics window
vtkCellType | Define types of cells
vtkCellTypes | Object provides direct access to cells in vtkCellArray and type information
vtkCGMWriter | Write polygonal data as a CGM file
vtkCharArray | Dynamic, self-adjusting character array
Chunk |
vtkCleanPolyData | Merge duplicate points, and/or remove unused points and/or remove degenerate cells
vtkClipDataSet | Clip any dataset with user-specified implicit function or input scalar data
vtkClipPolyData | Clip polygonal data with user-specified implicit function or input scalar data
vtkClipVolume | Clip volume data with user-specified implicit function or input scalar data
vtkCollection | Create and manipulate unsorted lists of objects
vtkCollectionElement |
vtkColorTransferFunction | Defines a transfer function for mapping a property to an RGB color value
Colour |
Colour_24 |
vtkCommand | Superclass for callback/observer methods
vtkCommunicator | Used to send/receive messages in a multiprocess/thread environment
vtkCompositeManager | An object to composite multiple render windows
vtkCone | Implicit function for a cone
vtkConeSource | Generate polygonal cone
vtkConnectivityFilter | Extract data based on geometric connectivity
vtkContainer | A base class for templated containers
vtkContourFilter | Generate isosurfaces/isolines from scalar values
vtkContourGrid | Generate isosurfaces/isolines from scalar values (specialized for unstructured grids)
vtkContourValues | Helper object to manage setting and generating contour values
vtkCoordinate | Perform coordinate transformation, and represent position, in a variety of vtk coordinate systems
vtkCriticalSection | Critical section locking class
vtkCubeAxesActor2D | Create a 2D plot of a bounding box edges - used for navigation
vtkCubeSource | Create a polygonal representation of a cube
vtkCuller | A superclass for prop cullers
vtkCullerCollection | A list of Cullers
vtkCursor3D | Generate a 3D cursor representation
vtkCutMaterial | Automatically computes the cut plane for a material array pair
vtkCutter | Cut vtkDataSet with user-specified implicit function
vtkCylinder | Implicit function for a cylinder
vtkCylinderSource | Generate a cylinder centered at origin
vtkDashedStreamLine | Generate constant-time dashed streamline in arbitrary dataset
vtkDataArray | Abstract superclass for arrays
vtkDataObject | General representation of visualization data
vtkDataObjectCollection | Maintain an unordered list of data objects
vtkDataObjectReader | Read vtk field data file
vtkDataObjectSource | Abstract class specifies interface for
vtkDataObjectToDataSetFilter | Map field data to concrete dataset
vtkDataObjectWriter | Write vtk field data
vtkDataReader | Helper superclass for objects that read vtk data files
vtkDataSet | Abstract class to specify dataset behavior
vtkDataSetAttributes | Represent and manipulate attribute data in a dataset
vtkDataSetAttributes::FieldList |
vtkDataSetCollection | Maintain an unordered list of dataset objects
vtkDataSetMapper | Map vtkDataSet and derived classes to graphics primitives
vtkDataSetReader | Class to read any type of vtk dataset
vtkDataSetSource | Abstract class whose subclasses generate datasets
vtkDataSetSurfaceFilter | Extracts outer (polygonal) surface
vtkDataSetToDataObjectFilter | Map dataset into data object (i.e., a field)
vtkDataSetToDataSetFilter | Abstract filter class
vtkDataSetToPolyDataFilter | Abstract filter class
vtkDataSetToStructuredGridFilter | Abstract filter class
vtkDataSetToStructuredPointsFilter | Abstract filter class
vtkDataSetToUnstructuredGridFilter | Abstract filter class
vtkDataSetTriangleFilter | Triangulate any type of dataset
vtkDataSetWriter | Write any type of vtk dataset to file
vtkDataWriter | Helper class for objects that write vtk data files
vtkDebugLeaks | Identify memory leaks at program termination
vtkDecimate | Reduce the number of triangles in a mesh
vtkDecimatePro | Reduce the number of triangles in a mesh
vtkDelaunay2D | Create 2D Delaunay triangulation of input points
vtkDelaunay3D | Create 3D Delaunay triangulation of input points
vtkDEMReader | Read a digital elevation model (DEM) file
vtkDepthSortPolyData | Sort poly data along camera view direction
vtkDicer | Abstract superclass to divide dataset into pieces
vtkDirectionEncoder | Encode a direction into a one or two byte value
vtkDirectory | OS independent class for access to system directories
vtkDiskSource | Create a disk with hole in center
vtkDividingCubes | Create points lying on isosurface
vtkDoubleArray | Dynamic, self-adjusting double precision array
vtkDynamicLoader | Class interface to system dynamic libraries
vtkEarthSource | Create the continents of the Earth as a sphere
vtkEdgePoints | Generate points on isosurface
vtkEdgeTable | Keep track of edges (edge is pair of integer id's)
vtkElevationFilter | Generate scalars along a specified direction
vtkEmptyCell | An empty cell used as a place-holder during processing
vtkEncodedGradientEstimator | Superclass for gradient estimation
vtkEncodedGradientShader | Compute shading tables for encoded normals
vtkEnSight6BinaryReader | Class to read binary EnSight6 files
vtkEnSight6Reader | Class to read EnSight6 files
vtkEnSightGoldBinaryReader | Class to read binary EnSight Gold files
vtkEnSightGoldReader | Class to read EnSight Gold files
vtkEnSightReader | Superclass for EnSight file readers
vtkErrorCode | Superclass for error codes
vtkExplicitCell | Abstract superclass for cells requiring an explicit representation
vtkExporter | Abstract class to write a scene to a file
vtkExtentTranslator | Generates a structured extent from unstructured
vtkExtractEdges | Extract cell edges from any type of data
vtkExtractGeometry | Extract cells that lie either entirely inside or outside of a specified implicit function
vtkExtractGrid | Select piece (e.g., volume of interest) and/or subsample structured grid dataset
vtkExtractPolyDataGeometry | Extract vtkPolyData cells that lies either entirely inside or outside of a specified implicit function
vtkExtractPolyDataPiece | Return specified piece, including specified
vtkExtractTensorComponents | Extract parts of tensor and create a scalar, vector, normal, or texture coordinates
vtkExtractUnstructuredGrid | Extract subset of unstructured grid geometry
vtkExtractUnstructuredGridPiece | Return specified piece, including specified
vtkExtractVectorComponents | Extract components of vector as separate scalars
vtkExtractVOI | Select piece (e.g., volume of interest) and/or subsample structured points dataset
Face |
vtkFeatureEdges | Extract boundary, non-manifold, and/or sharp edges from polygonal data
vtkFieldData | Represent and manipulate fields of data
vtkFieldData::BasicIterator |
vtkFieldData::CopyFieldFlag |
vtkFieldData::Iterator |
vtkFieldDataToAttributeDataFilter | Map field data to dataset attribute data
vtkFileOutputWindow | File Specific output window class
vtkFiniteDifferenceGradientEstimator | Use finite differences to estimate gradient
vtkFloatArray | Dynamic, self-adjusting floating point array
vtkFollower | A subclass of actor that always faces the camera
vtkFrustumCoverageCuller | Cull props based on frustum coverage
vtkFunctionParser | Parse and evaluate a mathematical expression
vtkFunctionSet | Abstract inteface for sets of functions
vtkGaussianSplatter | Splat points into a volume with an elliptical, Gaussian distribution
vtkGeneralTransform | Allows operations on any transforms
vtkGenericCell | Provides thread-safe access to cells
vtkGenericEnSightReader | Class to read any type of EnSight files
vtkGeometryFilter | Extract geometry from data (or convert data to polygonal type)
vtkGESignaReader | Read GE Signa ximg files
vtkGLUTesselatorTriangleFilter | Create triangle polygons from input polygons and triangle strips
vtkGlyph2D | Copy oriented and scaled glyph geometry to every input point (2D specialization)
vtkGlyph3D | Copy oriented and scaled glyph geometry to every input point
vtkGlyphSource2D | Create 2D glyphs represented by vtkPolyData
vtkGraphicsFactory |
vtkGraphLayoutFilter | Nice layout of undirected graphs in 3D
vtkGridSynchronizedTemplates3D | Generate isosurface from structured grids
vtkGridTransform | A nonlinear warp transformation
vtkHeap | Replacement for malloc/free and new/delete
vtkHeapNode |
vtkHedgeHog | Create oriented lines from vector data
vtkHexahedron | A cell that represents a 3D rectangular hexahedron
vtkHomogeneousTransform | Superclass for homogeneous transformations
vtkHull | Produce an n-sided convex hull
vtkHyperStreamline | Generate hyperstreamline in arbitrary dataset
vtkIdentityTransform | A transform that doesn't do anything
vtkIdFilter | Generate scalars or field data from point and cell ids
vtkIdList | List of point or cell ids
vtkIdTypeArray | Dynamic, self-adjusting integer array
vtkImageAccumulate | Generalized histograms up to 4 dimensions
vtkImageActor | Draw an image (data & properties) in a rendered 3D scene
vtkImageAnisotropicDiffusion2D | Edge preserving smoothing
vtkImageAnisotropicDiffusion3D | Edge preserving smoothing
vtkImageAppend | Collects data from multiple inputs into one image
vtkImageAppendComponents | Collects components from two inputs into
vtkImageBlend | Blend images together using alpha or opacity
vtkImageBlockReader | Breaks up image into blocks and save in files
vtkImageBlockWriter | Breaks up image into blocks and save in files
vtkImageButterworthHighPass | Frequency domain high pass
vtkImageButterworthLowPass | Frequency domain Low pass
vtkImageCacheFilter | Caches multiple vtkImageData objects
vtkImageCanvasSource2D | Paints on a canvas
vtkImageCanvasSource2DPixel |
vtkImageCast | Image Data type Casting Filter
vtkImageChangeInformation | Modify spacing, origin and extent
vtkImageCheckerboard | Show two images at once using a checkboard pattern
vtkImageCityBlockDistance | 1,2 or 3D distance map
vtkImageClip | Reduces the image extent of the input
vtkImageConnector | Create a binary image of a sphere
vtkImageConnectorSeed |
vtkImageConstantPad | Makes image larger by padding with constant
vtkImageContinuousDilate3D | Dilate implemented as a maximum
vtkImageContinuousErode3D | Erosion implemented as a minimum
vtkImageConvolve | Convolution of an image with a kernel
vtkImageCorrelation | Correlation imageof the two inputs
vtkImageCursor3D | Paints a cursor on top of an image or volume
vtkImageData | Topologically and geometrically regular array of data
vtkImageDataGeometryFilter | Extract geometry for structured points
vtkImageDataStreamer | Initiates streaming on image data
vtkImageDecomposeFilter | Filters that execute axes in series
vtkImageDifference | Compares images for regression tests
vtkImageDilateErode3D | Dilates one value and erodes another
vtkImageDivergence | Divergence of a vector field
vtkImageDotProduct | Dot product of two vector images
vtkImageEllipsoidSource | Create a binary image of an ellipsoid
vtkImageEuclideanDistance | Computes 3D Euclidean DT
vtkImageEuclideanToPolar | Converts 2D Euclidean coordinates to polar
vtkImageExport | Export VTK images to third-party systems
vtkImageExtractComponents | Outputs a single component
vtkImageFFT | Fast Fourier Transform
vtkImageFlip | This flips an axis of an image. Right becomes left ..
vtkImageFourierCenter | Shifts constant frequency to center for
vtkImageFourierFilter | Superclass that implements complex numbers
vtkImageGaussianSmooth | Performs a gaussian convolution
vtkImageGaussianSource | Create an image with Gaussian pixel values
vtkImageGradient | Computes the gradient vector
vtkImageGradientMagnitude | Computes magnitude of the gradient
vtkImageGridSource | Create an image of a grid
vtkImageHSVToRGB | Converts HSV components to RGB
vtkImageHybridMedian2D | Median filter that preserves lines and
vtkImageIdealHighPass | Simple frequency domain band pass
vtkImageIdealLowPass | Simple frequency domain band pass
vtkImageImport | Import data from a C array
vtkImageInPlaceFilter | Filter that operates in place
vtkImageIslandRemoval2D | Removes small clusters in masks
vtkImageIterateFilter | Multiple executes per update
vtkImageIterator< DType > | A simple image iterator
vtkImageLaplacian | Computes divergence of gradient
vtkImageLogarithmicScale | Passes each pixel through log function
vtkImageLogic | And, or, xor, nand, nor, not
vtkImageLuminance | Computes the luminance of the input
vtkImageMagnify | Magnify an image by an integer value
vtkImageMagnitude | Colapses components with magnitude function.
vtkImageMandelbrotSource | Mandelbrot image
vtkImageMapper | 2D image display
vtkImageMapToColors | Map the input image through a lookup table
vtkImageMapToRGBA | Map the input image through a lookup table
vtkImageMapToWindowLevelColors | Map the input image through a lookup table and window / level it
vtkImageMarchingCubes | Generate isosurface(s) from volume/images
vtkImageMask | Combines a mask and an image
vtkImageMaskBits | Applies a bit-mask pattern to each component
vtkImageMathematics | Add, subtract, multiply, divide, invert, sin, cos, exp, log
vtkImageMedian3D | Median Filter
vtkImageMirrorPad | Extra pixels are filled by mirror images
vtkImageMultipleInputFilter | Generic filter that has N inputs
vtkImageMultipleInputOutputFilter | Generic filter that has N inputs
vtkImageNoiseSource | Create an image filled with noise
vtkImageNonMaximumSuppression | Performs non-maximum suppression
vtkImageNormalize | Normalizes that scalar components for each point
vtkImageOpenClose3D | Will perform opening or closing
vtkImagePadFilter | Super class for filters that fill in extra pixels
vtkImagePermute | Permutes axes of input
vtkImageProgressIterator< DType > | A simple image iterator with progress
vtkImageQuantizeRGBToIndex | Generalized histograms up to 4 dimensions
vtkImager | Renders into part of a ImageWindow
vtkImageRange3D | Max - min of a circular neighborhood
vtkImagerCollection | A collection of imagers
vtkImageReader | Superclass of transformable binary file readers
vtkImageReader2 | Superclass of binary file readers
vtkImageReader2Collection | Maintain a list of implicit functions
vtkImageReader2Factory | Superclass of binary file readers
vtkImageResample | Resamples an image to be larger or smaller
vtkImageReslice | Reslices a volume along a new set of axes
vtkImageRFFT | Reverse Fast Fourier Transform
vtkImageRGBToHSV | Converts RGB components to HSV
vtkImageSeedConnectivity | SeedConnectivity with user defined seeds
vtkImageSeparableConvolution | 3 1D convolutions on an image
vtkImageShiftScale | Shift and scale an input image
vtkImageShrink3D | Subsamples an image
vtkImageSinusoidSource | Create an image with sinusoidal pixel values
vtkImageSkeleton2D | Skeleton of 2D images
vtkImageSobel2D | Computes a vector field using sobel functions
vtkImageSobel3D | Computes a vector field using sobel functions
vtkImageSource | Source of data for the imaging pipeline
vtkImageSpatialFilter | Filters that operate on pixel neighborhoods
vtkImageStencil | Combine images via a cookie-cutter operation
vtkImageStencilData | Efficient description of an image stencil
vtkImageStencilSource | Helper class for clipping images
vtkImageThreshold | Flexible threshold
vtkImageToImageFilter | Generic filter that has one input.
vtkImageToImageStencil | Clip an image with a mask image
vtkImageToPolyDataFilter | Generate linear primitives (vtkPolyData) from an image
vtkImageToStructuredPoints | Attaches image pipeline to VTK
vtkImageTranslateExtent | Changes extent, nothing else
vtkImageTwoInputFilter | Generic superclass for filters that have
vtkImageVariance3D | Variance in a neighborhood
vtkImageViewer | Display a 2d image
vtkImageViewer2 |
vtkImageWindow | A 2D display window
vtkImageWrapPad | Makes an image larger by wrapping existing data
vtkImageWriter | Writes images to files
vtkImagingFactory |
vtkImplicitBoolean | Implicit function consisting of boolean combinations of implicit functions
vtkImplicitDataSet | Treat a dataset as if it were an implicit function
vtkImplicitFunction | Abstract interface for implicit functions
vtkImplicitFunctionCollection | Maintain a list of implicit functions
vtkImplicitFunctionToImageStencil | Clip an image with a function
vtkImplicitModeller | Compute distance from input geometry on structured point dataset
vtkImplicitSelectionLoop | Implicit function for a selection loop
vtkImplicitSum | Implicit sum of other implicit functions
vtkImplicitTextureCoords | Generate 1D, 2D, or 3D texture coordinates based on implicit function(s)
vtkImplicitVolume | Treat a volume as if it were an implicit function
vtkImplicitWindowFunction | Implicit function maps another implicit function to lie within a specified range
vtkImporter | Importer abstract class
vtkIndent | A simple class to control print indentation
vtkInitialValueProblemSolver | Integrate a set of ordinary
vtkInputPort | Receives data from another process
vtkInstantiator | Create an instance of any VTK class from its name
vtkInstantiatorInitialize |
vtkIntArray | Dynamic, self-adjusting integer array
vtkInteractorStyle | Provide event-driven interface to the rendering window (defines trackball mode)
vtkInteractorStyleFlight | Provides flight motion routines
vtkInteractorStyleImage | Interactive manipulation of the camera specialized for images
vtkInteractorStyleJoystickActor | Manipulate objects in the scene independently of one another
vtkInteractorStyleJoystickCamera | Interactive manipulation of the camera
vtkInteractorStyleSwitch | Class to swap between interactory styles
vtkInteractorStyleTrackball | Provides trackball motion control
vtkInteractorStyleTrackballActor | Manipulate objects in the scene independent of each other
vtkInteractorStyleTrackballCamera | Interactive manipulation of the camera
vtkInteractorStyleUnicam | Provides Unicam navigation style
vtkInteractorStyleUser | Provides customizable interaction routines
vtkInterpolateDataSetAttributes | Interpolate scalars, vectors, etc. and other dataset attributes
vtkInterpolatedVelocityField | Interface for obtaining
vtkInterpolatingSubdivisionFilter | Generate a subdivision surface using an Interpolating Scheme
istream |
vtkIterativeClosestPointTransform | Implementation of the ICP algorithm
vtkIVExporter | Export a scene into OpenInventor 2.0 format
vtkIVWriter | Export polydata into OpenInventor 2.0 format
vtkJavaCommand |
vtkJavaVoidFuncArg |
vtkJPEGReader | Read JPEG files
vtkJPEGWriter | Writes JPEG files
vtkKitwareContourFilter | Generate isosurfaces/isolines from scalar values
vtkKitwareObjectFactory | Object Factory for Kitware patented objects
vtkKochanekSpline | Computes an interpolating spline using a Kochanek basis
vtkLabeledDataMapper | Draw text labels at dataset points
vtkLandmarkTransform | A linear transform specified by two corresponding point sets
vtkLargeInteger | Class for arbitrarily large ints
vtkLegendBoxActor | Draw symbols with text
vtkLight | A virtual light for 3D rendering
vtkLightCollection | A list of lights
vtkLightKit | A simple but quality lighting kit
vtkLine | Cell represents a 1D line
vtkLinearExtrusionFilter | Sweep polygonal data creating a "skirt" from free edges and lines, and lines from vertices
vtkLinearSubdivisionFilter | Generate a subdivision surface using the Linear Scheme
vtkLinearTransform | Abstract superclass for linear transformations
vtkLineSource | Create a line defined by two end points
vtkLinkEdgels | Links edgels together to form digital curves
List |
vtkLocator | Abstract base class for objects that accelerate spatial searches
vtkLODActor | An actor that supports multiple levels of detail
vtkLODProp3D | Level of detail 3D prop
vtkLODProp3DEntry |
vtkLogLookupTable | Map scalars into colors using log (base 10) scale
vtkLongArray | Dynamic, self-adjusting long integer array
vtkLookupTable | Map scalar values into colors via a lookup table
vtkLoopSubdivisionFilter | Generate a subdivision surface using the Loop Scheme
vtkMapper | Abstract class specifies interface to map data to graphics primitives
vtkMapper2D |
vtkMapperCollection | A list of mappers
vtkMarchingContourFilter | Generate isosurfaces/isolines from scalar values
vtkMarchingCubes | Generate isosurface(s) from volume
vtkMarchingSquares | Generate isoline(s) from structured points set
vtkMaskFields | Allow control of which fields get passed
vtkMaskFields::CopyFieldFlag |
vtkMaskPoints | Selectively filter points
vtkMaskPolyData | Sample subset of input polygonal data
vtkMassProperties | Estimate volume, area, shape index of triangle mesh
Material |
vtkMath | Performs common math operations
MatProp |
vtkMatrix4x4 | Represent and manipulate 4x4 transformation matrices
vtkMatrixToHomogeneousTransform | Convert a matrix to a transform
vtkMatrixToLinearTransform | Convert a matrix to a transform
vtkMCubesReader | Read binary marching cubes file
vtkMCubesWriter | Write binary marching cubes file
vtkMedicalImageReader2 | VtkImageReader2 with medical meta data
vtkMemoryLimitImageDataStreamer |
vtkMergeDataObjectFilter | Merge dataset and data object field to create dataset with attribute data
vtkMergeFields | Merge multiple fields into one
vtkMergeFields::Component |
vtkMergeFilter | Extract separate components of data from different datasets
vtkMergePoints | Merge exactly coincident points
vtkMergePoints2D | Merge exactly coincident points
vtkMesaActor | Mesa actor
vtkMesaCamera | Mesa camera
vtkMesaImageActor | Mesa texture map
vtkMesaImageMapper | 2D image display support for Mesa
vtkMesaImager |
vtkMesaImageWindow | Mesa Imageing window
vtkMesaLight | Mesa light
vtkMesaPolyDataMapper | A PolyDataMapper for the Mesa library
vtkMesaPolyDataMapper2D |
vtkMesaProperty | Mesa property
vtkMesaRenderer | OpenGL renderer
vtkMesaRenderWindow | Mesa rendering window
vtkMesaTexture | Mesa texture map
vtkMesaVolumeRayCastMapper | Mesa subclass that draws the image to the screen
vtkMesaVolumeTextureMapper2D | Abstract class for a volume mapper
Mesh |
vtkMILVideoSource | Matrox Imaging Library frame grabbers
vtkMPICommunicator | Class for creating user defined MPI communicators
vtkMPICommunicator::Request |
vtkMPIController | Process communication using MPI
vtkMPIEventLog | Class for logging and timing
vtkMPIGroup | Class for creating MPI groups
vtkMultiProcessController | Multiprocessing communication superclass
vtkMultiProcessLog | Manages logs for multiple threads/processes
vtkMultiThreader | A class for performing multithreaded execution
vtkMutexLock | Mutual exclusion locking class
vtkNonLinearCell | Abstract superclass for non-linear cells
NSOpenGLView |
NSWindow |
vtkOBBDicer | Divide dataset into spatially aggregated pieces
vtkOBBNode |
vtkOBBTree | Generate oriented bounding box (OBB) tree
vtkObject | Abstract base class for most VTK objects
vtkObjectFactory | Abstract base class for vtkObjectFactories
vtkObjectFactory::OverrideInformation |
vtkObjectFactoryCollection | Maintain a list of object factories
vtkOBJExporter | Export a scene into Wavefront format
vtkOBJReader | Read Wavefront .obj files
ofstream |
vtkOldStyleCallbackCommand | Old syntax for callbacks
OmniLight |
vtkOOGLExporter | Export a scene into Geomview OOGL format
vtkOpenGLActor | OpenGL actor
vtkOpenGLCamera | OpenGL camera
vtkOpenGLImageActor | OpenGL texture map
vtkOpenGLImageMapper | 2D image display support for OpenGL
vtkOpenGLImager |
vtkOpenGLImageWindow | OpenGL Imageing window
vtkOpenGLLight | OpenGL light
vtkOpenGLPolyDataMapper | A PolyDataMapper for the OpenGL library
vtkOpenGLPolyDataMapper2D |
vtkOpenGLProperty | OpenGL property
vtkOpenGLRenderer | OpenGL renderer
vtkOpenGLRenderWindow | OpenGL rendering window
vtkOpenGLStateCache |
vtkOpenGLTexture | OpenGL texture map
vtkOpenGLVolumeProVG500Mapper | Concrete class for VolumePRO mapper
vtkOpenGLVolumeProVP1000Mapper | Concrete class for VolumePRO mapper
vtkOpenGLVolumeRayCastMapper | OpenGL subclass that draws the image to the screen
vtkOpenGLVolumeTextureMapper2D | Abstract class for a volume mapper
vtkOrderedTriangulator | Helper class to generate triangulations
ostream |
ostrhelp |
ostrstream |
OtherData |
OtherElem |
vtkOutlineCornerFilter | Create wireframe outline corners for arbitrary data set
vtkOutlineCornerSource | Create wireframe outline corners around bounding box
vtkOutlineFilter | Create wireframe outline for arbitrary data set
vtkOutlineSource | Create wireframe outline around bounding box
vtkOutputPort | Connects pipelines in different processes
vtkOutputWindow | Base class for writing debug output to a console
vtkOutputWindowSmartPointer |
vtkOverrideInformation | Factory object override information
vtkOverrideInformationCollection | Maintain a list of override information objects
vtkParallelCoordinatesActor | Create parallel coordinate display from input field
vtkParallelFactory |
vtkParticleReader | Read raw particle data and one array
vtkPCAAnalysisFilter | Performs principal component analysis of a set of aligned pointsets
vtkPCellDataToPointData | Compute point arrays from cell arrays
vtkPDataSetReader | Manages writing pieces of a data set
vtkPDataSetWriter | Manages writing pieces of a data set
vtkPerlinNoise | An implicit function that implements Perlin noise
vtkPerspectiveTransform | Describes a 4x4 matrix transformation
vtkPicker | Superclass for 3D geometric pickers (uses ray cast)
vtkPieceScalars | Sets all cell scalars from the update piece
vtkPiecewiseFunction | Defines a 1D piecewise function
vtkPiecewiseFunctionShiftScale |
vtkPiecewiseFunctionSource | Abstract class whose subclasses generate piecewise functions
vtkPiecewiseFunctionToPiecewiseFunctionFilter | Abstract filter class
vtkPImageWriter |
vtkPipelineSize | Compute the memory required by a pipeline
vtkPixel | A cell that represents an orthogonal quadrilateral
vtkPlane | Perform various plane computations
vtkPlaneCollection | Maintain a list of planes
vtkPlanes | Implicit function for convex set of planes
vtkPlaneSource | Create an array of quadrilaterals located in a plane
vtkPLinearExtrusionFilter | Subclass that handles piece invariance
vtkPLOT3DReader | Read PLOT3D data files
vtkPLY | A modified version of the PLY 1.1 library
PlyElement |
PlyFile |
PlyOtherElems |
PlyOtherProp |
PlyProperty |
vtkPLYReader | Read Stanford University PLY polygonal file format
vtkPLYWriter | Write Stanford PLY file format
vtkPNGReader | Read PNG files
vtkPNGWriter | Writes PNG files
vtkPNMReader | Read pnm (i.e., portable anymap) files
vtkPNMWriter | Writes PNM (portable any map) files
vtkPointData | Represent and manipulate point attribute data
vtkPointDataToCellData | Map point data to cell data
vtkPointLoad | Compute stress tensors given point load on semi-infinite domain
vtkPointLocator | Quickly locate points in 3-space
vtkPointLocator2D | Quickly locate points in 2-space
vtkPointPicker | Select a point by shooting a ray into a graphics window
vtkPoints | Represent and manipulate 3D points
vtkPointSet | Abstract class for specifying dataset behavior
vtkPointSetSource | Abstract class whose subclasses generate point data
vtkPointSetToPointSetFilter | Abstract filter class
vtkPointSource | Create a random cloud of points
vtkPolyData | Concrete dataset represents vertices, lines, polygons, and triangle strips
vtkPolyDataCollection | Maintain a list of polygonal data objects
vtkPolyDataConnectivityFilter | Extract polygonal data based on geometric connectivity
vtkPolyDataMapper | Map vtkPolyData to graphics primitives
vtkPolyDataMapper2D | Draw vtkPolyData onto the image plane
vtkPolyDataNormals | Compute normals for polygonal mesh
vtkPolyDataReader | Read vtk polygonal data file
vtkPolyDataSource | Abstract class whose subclasses generate polygonal data
vtkPolyDataStreamer | Stream appends input pieces to the output
vtkPolyDataToImageStencil | Clip an image with polydata
vtkPolyDataToPolyDataFilter | Abstract filter class
vtkPolyDataWriter | Write vtk polygonal data
vtkPolygon | A cell that represents an n-sided polygon
vtkPolyLine | Cell represents a set of 1D lines
vtkPolyVertex | Cell represents a set of 0D vertices
vtkPOPReader | Read POP data files
vtkPostScriptWriter | Writes an image as a PostScript file
vtkPPolyDataNormals | Compute normals for polygonal mesh
vtkPriorityQueue | An list of ids arranged in priority order
vtkProbeFilter | Sample data values at specified point locations
vtkProcessObject | Abstract class specifies interface for visualization filters
vtkProcessStatistics | Get statistics such as cpu and memory usage
vtkProcrustesAlignmentFilter | Aligns a set of pointsets together
vtkProgrammableAttributeDataFilter | Manipulate attribute (cell and point) data via a user-specified function
vtkProgrammableDataObjectSource | Generate source data object via a user-specified function
vtkProgrammableFilter | A user-programmable filter
vtkProgrammableGlyphFilter | Control the generation and placement of glyphs at input points
vtkProgrammableSource | Generate source dataset via a user-specified function
vtkProjectedTexture | Assign texture coordinates for a projected texture
vtkProp | Abstract superclass for all actors, volumes and annotations
vtkProp3D | Represents an 3D object for placement in a rendered scene
vtkProp3DCollection | A list of 3D props
vtkPropAssembly | Create hierarchies of props
vtkPropCollection | A list of Props
vtkProperty | Represent surface properties of a geometric object
vtkProperty2D |
vtkPropPicker | Pick an actor/prop using graphics hardware
vtkProTriArray |
vtkProVertexArray |
vtkPSphereSource | Sphere source that supports pieces
vtkPVGeometryFilter | Geometry filter that does outlines for volumes
vtkPyramid | A 3D cell that represents a pyramid
vtkPythonCommand |
PyVTKClass |
PyVTKObject |
PyVTKSpecialObject |
vtkQuad | A cell that represents a 2D quadrilateral
vtkQuadraticEdge | Cell represents a parabolic, isoparametric edge
vtkQuadric | Evaluate implicit quadric function
vtkQuadricClustering | Reduce the number of triangles in a mesh
vtkQuadricDecimation | Reduce the number of triangles in a mesh
vtkQuantizePolyDataPoints | Quantizes x,y,z coordinates of points
vtkQuartzGLView |
vtkQuartzImageMapper | 2D image display support for Quartz windows
vtkQuartzImageWindow | OpenGL Imageing window
vtkQuartzRenderWindow | OpenGL rendering window
vtkQuartzRenderWindowInteractor | Implements Quartz specific functions
vtkQuartzTextMapper | 2D Text annotation support for windows
vtkQuartzWindow |
vtkRayCaster | Obsolete class
vtkRayCastStructures | The structure definitions for ray casting
vtkRearrangeFields | Move/copy fields between field data, point data and cell data
vtkRearrangeFields::Operation |
vtkRectilinearGrid | A datset that is topologically regular with variable spacing in the three coordinate directions
vtkRectilinearGridGeometryFilter | Extract geometry for a rectilinear grid
vtkRectilinearGridOutlineFilter | Create wireframe outline for a rectilinear grid
vtkRectilinearGridReader | Read vtk rectilinear grid data file
vtkRectilinearGridSource | Abstract class whose subclasses generates rectilinear grid data
vtkRectilinearGridToPolyDataFilter | Abstract filter class
vtkRectilinearGridWriter | Write vtk rectilinear grid data file
vtkRecursiveDividingCubes | Create points lying on isosurface (using recursive approach)
vtkRecursiveSphereDirectionEncoder | A direction encoder based on the recursive subdivision of an octahedron
vtkReferenceCount | Obsolete / empty subclass of object
vtkReflectionFilter | Reflects a data set across a plane
vtkRenderer | Abstract specification for renderers
vtkRendererCollection | A list of renderers
vtkRendererSource | Take a renderer into the pipeline
vtkRenderLargeImage | Use tiling to generate a large rendering
vtkRenderWindow | Create a window for renderers to draw into
vtkRenderWindowCollection | A list of RenderWindows
vtkRenderWindowInteractor | Platform-independent render window interaction including picking and frame rate control
vtkReverseSense | Reverse the ordering of polygonal cells and/or vertex normals
vtkRibbonFilter | Create oriented ribbons from lines defined in polygonal dataset
vtkRIBExporter | Export a scene into RenderMan RIB format
vtkRIBLight | RIP Light
vtkRIBProperty | RIP Property
vtkRotationalExtrusionFilter | Sweep polygonal data creating "skirt" from free edges and lines, and lines from vertices
vtkRTAnalyticSource | Create an image for regression testing
vtkRuledSurfaceFilter | Generates a surface from a set of lines
vtkRungeKutta2 | Integrate an initial value problem using 2nd
vtkRungeKutta4 | Integrate an initial value problem using 4th
vtkRungeKutta45 | Integrate an initial value problem using 5th
vtkSampleFunction | Sample an implicit function over a structured point set
vtkScalarBarActor | Create a scalar bar with labels
vtkScalarsToColors | Map scalar values into colors
vtkScalarTree | Organize data according to scalar values (used to accelerate contouring operations)
vtkScaledTextActor | Create text that will scale as needed
vtkSelectPolyData | Select portion of polygonal mesh; generate selection scalars
vtkSelectVisiblePoints | Extract points that are visible (based on z-buffer calculation)
SetGet |
vtkSharedMemoryCommunicator | Provides communication using shared memory
vtkShepardMethod | Sample unstructured points onto structured points using the method of Shepard
vtkShortArray | Dynamic, self-adjusting short integer array
vtkShrinkFilter | Shrink cells composing an arbitrary data set
vtkShrinkPolyData | Shrink cells composing PolyData
vtkSimpleCriticalSection |
vtkSimpleElevationFilter | Generate scalars along a specified direction
vtkSimpleImageFilterExample | Simple example of an image-image filter
vtkSimpleImageToImageFilter | Generic image filter with one input
vtkSimpleMutexLock |
vtkSimpleScalarTree | Organize data according to scalar values (used to accelerate contouring operations)
vtkSLCReader | Read an SLC volume file
vtkSliceCubes | Generate isosurface(s) from volume four slices at a time
vtkSmoothPolyDataFilter |
vtkSocketCommunicator | Process communication using Sockets
vtkSocketController | Process communication using Sockets
vtkSource | Abstract class specifies interface for visualization network source
vtkSpatialRepresentationFilter | Generate polygonal model of spatial search object (i.e., a vtkLocator)
vtkSphere | Implicit function for a sphere
vtkSpherePuzzle | Create a polygonal sphere centered at the origin
vtkSpherePuzzleArrows | Visualize permutation of the sphere puzzle
vtkSphereSource | Create a polygonal sphere centered at the origin
vtkSpline | Spline abstract class
vtkSplitField | Split a field into single component fields
vtkSplitField::Component |
SpotLight |
vtkSTLReader | Read ASCII or binary stereo lithography files
vtkSTLWriter | Write stereo lithography files
vtkStreamArray |
vtkStreamer | Abstract object implements integration of massless particle through vector field
vtkStreamLine | Generate streamline in arbitrary dataset
vtkStreamPoints | Generate points along streamer separated by constant time increment
vtkStripper | Create triangle strips and/or poly-lines
vtkStructuredData | Abstract class for topologically regular data
vtkStructuredGrid | Topologically regular array of data
vtkStructuredGridGeometryFilter | Extract geometry for structured grid
vtkStructuredGridOutlineFilter | Create wireframe outline for structured grid
vtkStructuredGridReader | Read vtk structured grid data file
vtkStructuredGridSource | Abstract class whose subclasses generates structured grid data
vtkStructuredGridToPolyDataFilter | Abstract filter class
vtkStructuredGridToStructuredGridFilter | Abstract filter class
vtkStructuredGridWriter | Write vtk structured grid data file
vtkStructuredPoints | A subclass of ImageData
vtkStructuredPointsCollection | Maintain a list of structured points data objects
vtkStructuredPointsGeometryFilter | Obsolete class
vtkStructuredPointsReader | Read vtk structured points data file
vtkStructuredPointsSource | Abstract class whose subclasses generates structured Points data
vtkStructuredPointsToPolyDataFilter | Abstract filter class
vtkStructuredPointsToStructuredPointsFilter | Abstract filter class
vtkStructuredPointsToUnstructuredGridFilter | Abstract filter class
vtkStructuredPointsWriter | Write vtk structured points data file
vtkSubdivideTetra | Subdivide one tetrahedron into twelve for every tetra
vtkSubPixelPositionEdgels | Adjust edgel locations based on gradients
Summary |
vtkSuperquadric | Implicit function for a Superquadric
vtkSuperquadricSource | Create a polygonal superquadric centered
vtkSurfaceReconstructionFilter | Reconstructs a surface from unorganized points
vtkSweptSurface | Given a path and input geometry generate an (implicit) representation of a swept surface
vtkSynchronizedTemplates2D | Generate isoline(s) from a structured points set
vtkSynchronizedTemplates3D | Generate isosurface from structured points
vtkSystemIncludes | Transition VTK to ANSI C++, centralize inclusion of system files
vtkTclCommand |
vtkTclCommandArgStruct |
vtkTclCommandStruct |
vtkTclInterpStruct |
vtkTensor | Supporting class to enable assignment and referencing of tensors
vtkTensorGlyph | Scale and orient glyph according to tensor eigenvalues and eigenvectors
vtkTetra | A 3D cell that represents a tetrahedron
vtkTextMapper | 2D text annotation
vtkTextSource | Create polygonal text
vtkTexture | Handles properties associated with a texture map
vtkTexturedSphereSource | Create a sphere centered at the origin
vtkTextureMapToCylinder | Generate texture coordinates by mapping points to cylinder
vtkTextureMapToPlane | Generate texture coordinates by mapping points to plane
vtkTextureMapToSphere | Generate texture coordinates by mapping points to sphere
vtkThinPlateSplineTransform | A nonlinear warp transformation
vtkThreadedController | Allows communication between running threads
ThreadInfoStruct |
vtkThreadSafeLog | Saves tag/float entries
vtkThreshold | Extracts cells where scalar value in cell satisfies threshold criterion
vtkThresholdPoints | Extracts points whose scalar value satisfies threshold criterion
vtkThresholdTextureCoords | Compute 1D, 2D, or 3D texture coordinates based on scalar threshold
vtkTIFFReader | Read TIFF files
vtkTIFFWriter | Write out structured points as a TIFF file
vtkTimerLog | Timer support and logging
vtkTimerLogEntry |
vtkTimeStamp | Record modification and/or execution time
vtkTkImageViewerWidget | A Tk Widget for viewing vtk images
vtkTkImageWindowWidget | A Tk Widget for viewing vtk images
vtkTkRenderWidget | A Tk Widget for vtk renderering
vtkTransform | Describes linear transformations via a 4x4 matrix
vtkTransformCollection | Maintain a list of transforms
vtkTransformConcatenation |
vtkTransformConcatenationStack |
vtkTransformFilter | Transform points and associated normals and vectors
vtkTransformPair |
vtkTransformPolyDataFilter | Transform points and associated normals and vectors for polygonal dataset
vtkTransformTextureCoords | Transform (scale, rotate, translate) texture coordinates
vtkTransformToGrid | Create a grid for a vtkGridTransform
vtkTransmitPolyDataPiece | Return specified piece, including specified
vtkTransmitUnstructuredGridPiece | Return specified piece, including specified
vtkTreeComposite | Implements tree based compositing
vtkTriangle | A cell that represents a triangle
vtkTriangleFilter | Create triangle polygons from input polygons and triangle strips
vtkTriangleStrip | A cell that represents a triangle strip
vtkTriangularTCoords | 2D texture coordinates based for triangles
vtkTriangularTexture | Generate 2D triangular texture map
vtkTriArray |
vtkTubeFilter | Filter that generates tubes around lines
vtkUGFacetReader | Read EDS Unigraphics facet files
vtkUnsignedCharArray | Dynamic, self-adjusting unsigned character array
vtkUnsignedIntArray | Dynamic, self-adjusting unsigned int integer array
vtkUnsignedLongArray | Dynamic, self-adjusting unsigned long integer array
vtkUnsignedShortArray | Dynamic, self-adjusting unsigned short integer array
vtkUnstructuredGrid | Dataset represents arbitrary combinations of all possible cell types
vtkUnstructuredGridReader | Read vtk unstructured grid data file
vtkUnstructuredGridSource | Abstract class whose subclasses generate unstructured grid data
vtkUnstructuredGridToPolyDataFilter | Abstract filter class
vtkUnstructuredGridToUnstructuredGridFilter | Abstract filter class
vtkUnstructuredGridWriter | Write vtk unstructured grid data file
vtkVectorDot | Generate scalars from dot product of vectors and normals (e.g., show displacement plot)
vtkVectorNorm | Generate scalars from Euclidean norm of vectors
vtkVectorText | Create polygonal text
VectorType< T > |
vtkVersion | Versioning class for vtk
vtkVertex | A cell that represents a 3D point
vtkVertexArray |
vtkVideoSource | Superclass of video input devices for VTK
vtkViewport | Abstract specification for Viewports
vtkVoidArray | Dynamic, self-adjusting array of void* pointers
vtkVolume | Represents a volume (data & properties) in a rendered scene
vtkVolume16Reader | Read 16 bit image files
vtkVolumeCollection | A list of volumes
vtkVolumeMapper | Abstract class for a volume mapper
vtkVolumeProMapper | Superclass for VolumePRO volume rendering mappers
vtkVolumeProperty | Represents the common properties for rendering a volume
vtkVolumeProVG500Mapper | Superclass for VG500 board
vtkVolumeProVP1000Mapper | Superclass for VP1000 board
vtkVolumeRayCastCompositeFunction | A ray function for compositing
vtkVolumeRayCastFunction | A superclass for ray casting functions
vtkVolumeRayCastIsosurfaceFunction | An isosurface ray caster for volumes
vtkVolumeRayCastMapper | A slow but accurate mapper for rendering volumes
vtkVolumeRayCastMIPFunction | A maximum intensity projection ray caster for volumes
vtkVolumeRayCastStructures | Structures for ray casting volumes
vtkVolumeReader | Read image files
vtkVolumeTextureMapper | Abstract class for a volume mapper
vtkVolumeTextureMapper2D | Abstract class for a volume mapper
vtkVoxel | A cell that represents a 3D orthogonal parallelepiped
vtkVoxelContoursToSurfaceFilter | Create surface from contours
vtkVoxelModeller | Convert an arbitrary dataset to a voxel representation
vtkVRMLAllocator |
vtkVRMLExporter | Export a scene into VRML 2.0 format
vtkVRMLImporter | Imports VRML 2.0 files
VTK_ERROR_QUADRIC |
VTK_LINE_CASES |
VTK_POINT_QUADRIC |
VTK_TRIANGLE_CASES |
VTKRayCastRayInfo |
VTKRayCastVolumeInfo |
VTKVRCDynamicInfo |
VTKVRCStaticInfo |
vtkWarpLens | Deform geometry by applying lens distortion
vtkWarpScalar | Deform geometry with scalar data
vtkWarpTo | Deform geometry by warping towards a point
vtkWarpTransform | Superclass for nonlinear geometric transformations
vtkWarpVector | Deform geometry with vector data
vtkWedge | A 3D cell that represents a wedge
vtkWeightedTransformFilter |
vtkWin32Header | Manage Windows system differences
vtkWin32ImageMapper | (obsolete) 2D image display support for Microsoft windows
vtkWin32ImageWindow | (obsolete)2D display window for Windows
vtkWin32OpenGLImageWindow | OpenGL Imageing window
vtkWin32OpenGLRenderWindow | OpenGL rendering window
vtkWin32OpenGLTextMapper | 2D Text annotation support for windows
vtkWin32OutputWindow | Win32 Specific output window class
vtkWin32PolyDataMapper2D | 2D PolyData support for windows
vtkWin32RenderWindowInteractor | Implements Win32 specific functions
vtkWin32TextMapper | 2D Text annotation support for windows
vtkWin32VideoSource | Video-for-Windows video digitizer
vtkWinCE | Support for C++ functionality missing in WinCE
vtkWinCEOpenGLRenderWindow | OpenGL rendering window
vtkWindow | Window superclass for ImageWindow and RenderWindow
vtkWindowedSincPolyDataFilter | Adjust point positions using a windowed sinc function interpolation kernel
vtkWindowLevelLookupTable | Map scalar values into colors or colors to scalars; generate color table
vtkWindowToImageFilter | Use a vtkWindow as input to image pipeline
vtkWorldPointPicker | Find world x,y,z corresponding to display x,y,z
vtkWriter | Abstract class to write data to file(s)
vtkXImageMapper | 2D image display support for X windows
vtkXImageWindow | 2D display window for X
vtkXMesaRenderWindow | Mesa rendering window
vtkXMesaTextMapper |
vtkXMLFileOutputWindow | XML File Specific output window class
vtkXMLParser | Parse XML to handle element tags and attributes
vtkXOpenGLRenderWindow | OpenGL rendering window
vtkXOpenGLTextMapper | 2D Text annotation support for windows
vtkXPolyDataMapper2D | 2D PolyData support for windows
vtkXRenderWindowInteractor | An X event driven interface for a RenderWindow
vtkXRenderWindowTclInteractor | A TCL event driven interface for a RenderWindow
vtkXTextMapper | 2D Text annotation support for X
vtkXYPlotActor | Generate an x-y plot from input dataset(s) or field data
Generated on Mon Mar 25 01:15:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtk3DSImporter Class Reference

imports 3D Studio files. More...

#include <vtk3DSImporter.h>

Inheritance diagram for vtk3DSImporter:

[legend]
Collaboration diagram for vtk3DSImporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtk3DSImporter, vtkImporter)
void | PrintSelf (ostream &os, vtkIndent indent)
FILE * | GetFileFD ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()

Static Public Methods

vtk3DSImporter * | New ()

Public Attributes

OmniLight * OmniList
SpotLight * SpotLightList
Camera * CameraList
Mesh * MeshList
Material * MaterialList
MatProp * MatPropList

Protected Methods

vtk3DSImporter ()
~vtk3DSImporter ()
virtual int | ImportBegin ()
virtual void | ImportEnd ()
virtual void | ImportActors (vtkRenderer *renderer)
virtual void | ImportCameras (vtkRenderer *renderer)
virtual void | ImportLights (vtkRenderer *renderer)
virtual void | ImportProperties (vtkRenderer *renderer)
vtkPolyData * | GeneratePolyData (Mesh *meshPtr)
int | Read3DS ()

Protected Attributes

char * | FileName
FILE * | FileFD
int | ComputeNormals

Detailed Description

imports 3D Studio files.

Date:
2002/01/22 15:30:23
Revision:
1.18

vtk3DSImporter imports 3D Studio files into vtk.

See also:
vtkImporter
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (68%)
  • Schroeder, Will (29%)
Examples:
vtk3DSImporter (Examples)
Tests:
vtk3DSImporter (Tests)

Definition at line 49 of file vtk3DSImporter.h.

Constructor & Destructor Documentation

vtk3DSImporter::vtk3DSImporter ( ) [protected]

vtk3DSImporter::~vtk3DSImporter ( ) [protected]

Member Function Documentation

vtk3DSImporter* vtk3DSImporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtk3DSImporter::vtkTypeRevisionMacro | ( | vtk3DSImporter | ,
 |  | vtkImporter |
 | ) |

Reimplemented from vtkImporter.

void vtk3DSImporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImporter.

virtual void vtk3DSImporter::SetFileName ( const char * ) [virtual]

Specify the name of the file to read.

virtual char* vtk3DSImporter::GetFileName ( ) [virtual]

Specify the name of the file to read.

virtual void vtk3DSImporter::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. If on, imported geometry will be run through vtkPolyDataNormals.

virtual int vtk3DSImporter::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. If on, imported geometry will be run through vtkPolyDataNormals.

virtual void vtk3DSImporter::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. If on, imported geometry will be run through vtkPolyDataNormals.

virtual void vtk3DSImporter::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. If on, imported geometry will be run through vtkPolyDataNormals.

FILE* vtk3DSImporter::GetFileFD ( ) [inline]

Return the file pointer to the open file.

Definition at line 72 of file vtk3DSImporter.h.

virtual int vtk3DSImporter::ImportBegin ( ) [protected, virtual]

Reimplemented from vtkImporter.

virtual void vtk3DSImporter::ImportEnd ( ) [protected, virtual]

Reimplemented from vtkImporter.

virtual void vtk3DSImporter::ImportActors ( vtkRenderer * renderer ) [protected, virtual]

virtual void vtk3DSImporter::ImportCameras ( vtkRenderer * renderer ) [protected, virtual]

virtual void vtk3DSImporter::ImportLights ( vtkRenderer * renderer ) [protected, virtual]

virtual void vtk3DSImporter::ImportProperties ( vtkRenderer * renderer ) [protected, virtual]

vtkPolyData* vtk3DSImporter::GeneratePolyData ( Mesh * meshPtr ) [protected]

int vtk3DSImporter::Read3DS ( ) [protected]

Member Data Documentation

OmniLight* vtk3DSImporter::OmniList

Definition at line 74 of file vtk3DSImporter.h.

SpotLight* vtk3DSImporter::SpotLightList

Definition at line 75 of file vtk3DSImporter.h.

Camera* vtk3DSImporter::CameraList

Definition at line 76 of file vtk3DSImporter.h.

Mesh* vtk3DSImporter::MeshList

Definition at line 77 of file vtk3DSImporter.h.

Material* vtk3DSImporter::MaterialList

Definition at line 78 of file vtk3DSImporter.h.

MatProp* vtk3DSImporter::MatPropList

Definition at line 79 of file vtk3DSImporter.h.

char* vtk3DSImporter::FileName [protected]

Definition at line 94 of file vtk3DSImporter.h.

FILE* vtk3DSImporter::FileFD [protected]

Definition at line 95 of file vtk3DSImporter.h.

int vtk3DSImporter::ComputeNormals [protected]

Definition at line 96 of file vtk3DSImporter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtk3DSImporter.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkLink_s Struct Reference

#include <vtkCellLinks.h>

Collaboration diagram for _vtkLink_s:

[legend]
List of all members.

Public Attributes

unsigned short ncells
vtkIdType * cells

Member Data Documentation

unsigned short _vtkLink_s::ncells

Definition at line 48 of file vtkCellLinks.h.

Referenced by vtkCellLinks::AddCellReference(), vtkCellLinks::DeletePoint(), vtkCellLinks::InsertNextCellReference(), vtkCellLinks::RemoveCellReference(), and vtkCellLinks::ResizeCellList().

vtkIdType* _vtkLink_s::cells

Definition at line 49 of file vtkCellLinks.h.

Referenced by vtkCellLinks::AddCellReference(), vtkCellLinks::DeletePoint(), vtkCellLinks::InsertCellReference(), vtkCellLinks::InsertNextCellReference(), vtkCellLinks::RemoveCellReference(), and vtkCellLinks::ResizeCellList().

The documentation for this struct was generated from the following file:
  • Common/vtkCellLinks.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkLocalTri Struct Reference

#include <vtkDecimate.h>

Collaboration diagram for _vtkLocalTri:

[legend]
List of all members.

Public Attributes

vtkIdType id
float | area
float | n [3]
vtkIdType | verts [3]

Member Data Documentation

vtkIdType _vtkLocalTri::id

Definition at line 139 of file vtkDecimate.h.

float _vtkLocalTri::area

Definition at line 140 of file vtkDecimate.h.

float _vtkLocalTri::n[3]

Definition at line 141 of file vtkDecimate.h.

vtkIdType _vtkLocalTri::verts[3]

Definition at line 142 of file vtkDecimate.h.

The documentation for this struct was generated from the following file:
  • Patented/vtkDecimate.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkLocalVertex Struct Reference

#include <vtkDecimate.h>

Collaboration diagram for _vtkLocalVertex:

[legend]
List of all members.

Public Attributes

vtkIdType id
float | x [3]
float | FAngle
int | deRefs
int | newRefs

Member Data Documentation

vtkIdType _vtkLocalVertex::id

Definition at line 130 of file vtkDecimate.h.

float _vtkLocalVertex::x[3]

Definition at line 131 of file vtkDecimate.h.

float _vtkLocalVertex::FAngle

Definition at line 132 of file vtkDecimate.h.

int _vtkLocalVertex::deRefs

Definition at line 133 of file vtkDecimate.h.

int _vtkLocalVertex::newRefs

Definition at line 134 of file vtkDecimate.h.

The documentation for this struct was generated from the following file:
  • Patented/vtkDecimate.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkPriorityItem Struct Reference

#include <vtkPriorityQueue.h>

Collaboration diagram for _vtkPriorityItem:

[legend]
List of all members.

Public Attributes

float priority
vtkIdType id

Member Data Documentation

float _vtkPriorityItem::priority

Definition at line 60 of file vtkPriorityQueue.h.

Referenced by vtkPriorityQueue::GetPriority(), and vtkPriorityQueue::Peek().

vtkIdType _vtkPriorityItem::id

Definition at line 61 of file vtkPriorityQueue.h.

Referenced by vtkPriorityQueue::Peek().

The documentation for this struct was generated from the following file:
  • Common/vtkPriorityQueue.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkProLocalTri Struct Reference

#include <vtkDecimatePro.h>

Collaboration diagram for _vtkProLocalTri:

[legend]
List of all members.

Public Attributes

vtkIdType id
float | area
float | n [3]
vtkIdType | verts [3]

Member Data Documentation

vtkIdType _vtkProLocalTri::id

Definition at line 113 of file vtkDecimatePro.h.

float _vtkProLocalTri::area

Definition at line 114 of file vtkDecimatePro.h.

float _vtkProLocalTri::n[3]

Definition at line 115 of file vtkDecimatePro.h.

vtkIdType _vtkProLocalTri::verts[3]

Definition at line 116 of file vtkDecimatePro.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkDecimatePro.h
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkProLocalVertex Struct Reference

#include <vtkDecimatePro.h>

Collaboration diagram for _vtkProLocalVertex:

[legend]
List of all members.

Public Attributes

vtkIdType id
float | x [3]
float | FAngle

Member Data Documentation

vtkIdType _vtkProLocalVertex::id

Definition at line 106 of file vtkDecimatePro.h.

float _vtkProLocalVertex::x[3]

Definition at line 107 of file vtkDecimatePro.h.

float _vtkProLocalVertex::FAngle

Definition at line 108 of file vtkDecimatePro.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkDecimatePro.h
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkStreamPoint Struct Reference

#include <vtkStreamer.h>

Collaboration diagram for _vtkStreamPoint:

[legend]
List of all members.

Public Attributes

float | x [3]
vtkIdType cellId
int | subId
float | p [3]
float | v [3]
float | speed
float | s
float | t
float | d
float | omega
float | theta

Member Data Documentation

float _vtkStreamPoint::x[3]

Definition at line 77 of file vtkStreamer.h.

vtkIdType _vtkStreamPoint::cellId

Definition at line 78 of file vtkStreamer.h.

int _vtkStreamPoint::subId

Definition at line 79 of file vtkStreamer.h.

float _vtkStreamPoint::p[3]

Definition at line 80 of file vtkStreamer.h.

float _vtkStreamPoint::v[3]

Definition at line 81 of file vtkStreamer.h.

float _vtkStreamPoint::speed

Definition at line 82 of file vtkStreamer.h.

float _vtkStreamPoint::s

Definition at line 83 of file vtkStreamer.h.

float _vtkStreamPoint::t

Definition at line 84 of file vtkStreamer.h.

float _vtkStreamPoint::d

Definition at line 85 of file vtkStreamer.h.

float _vtkStreamPoint::omega

Definition at line 86 of file vtkStreamer.h.

float _vtkStreamPoint::theta

Definition at line 87 of file vtkStreamer.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkStreamer.h
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


_vtkTclVoidFuncArg Struct Reference

#include <vtkTclUtil.h>

Collaboration diagram for _vtkTclVoidFuncArg:

[legend]
List of all members.

Public Attributes

Tcl_Interp * | interp
char * | command

Member Data Documentation

Tcl_Interp* _vtkTclVoidFuncArg::interp

Definition at line 80 of file vtkTclUtil.h.

char* _vtkTclVoidFuncArg::command

Definition at line 81 of file vtkTclUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkTclUtil.h
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplatevtkAbstractList class Reference

vtkAbstractList Class Template Reference

a dynamic list data structure. More...

#include <vtkAbstractList.h>

Inheritance diagram for vtkAbstractList:

[legend]
Collaboration diagram for vtkAbstractList:

[legend]
List of all members.

Public Types

typedef int(* | CompareFunction )(DType item1, DType item2)

Public Methods

virtual int | AppendItem (DType a)=0
virtual int | PrependItem (DType a)=0
virtual int | InsertItem (unsigned long loc, DType a)=0
virtual int | SetItem (unsigned long loc, DType a)=0
virtual void | SetItemNoCheck (unsigned long loc, DType a)=0
virtual int | RemoveItem (unsigned long id)=0
virtual int | GetItem (unsigned long id, DType &ret)=0
virtual int | FindItem (DType a, unsigned long &res)=0
virtual int | SetSize (unsigned long size)=0
virtual int | FindItem (DType a, CompareFunction compare, unsigned long &res)=0

Detailed Description

template<class DType>
class vtkAbstractList< DType >

a dynamic list data structure.

Date:
2002/03/22 22:50:58
Revision:
1.6

vtkAbstractList is a an abstract templated superclass of all containers that implement list data structure.

List data structure is a one dimensional sequence of elements with strict ordering. Every element has an index and each element except the first and the last one, have unique predecessor and successor. Examples of list data structure are dynamic array (vector) and linked list.

See also:
vtkContainer
Created by:
  • Cedilnik, Andy
Contributed by (if > 5%):
  • Cedilnik, Andy (100%)
Tests:
vtkAbstractList (Tests)

Definition at line 71 of file vtkAbstractList.h.

Member Typedef Documentation

template<class DType>
typedef int(* vtkAbstractList::CompareFunction)(DType item1, DType item2)

This is a prototype for a compare function. It has to return true if objects are the same and false if not.

Member Function Documentation

template<class DType>
virtual int vtkAbstractList< DType >::AppendItem ( DType a ) [pure virtual]

Append an Item to the end of the list. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::PrependItem ( DType a ) [pure virtual]

Insert an Item to the front of the list. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::InsertItem | ( | unsigned long | loc,
 |  | DType | a
 | ) | [pure virtual]

Insert an Item to the specific location in the list. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::SetItem | ( | unsigned long | loc,
 |  | DType | a
 | ) | [pure virtual]

Sets the Item at the specific location in the list to a new value. It also checks if the item can be set. It returns VTK_OK if successfull.

template<class DType>
virtual void vtkAbstractList< DType >::SetItemNoCheck | ( | unsigned long | loc,
 |  | DType | a
 | ) | [pure virtual]

Sets the Item at the specific location in the list to a new value. This method does not perform any error checking.

template<class DType>
virtual int vtkAbstractList< DType >::RemoveItem ( unsigned long id ) [pure virtual]

Remove an Item from the list It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::GetItem | ( | unsigned long | id,
 |  | DType & | ret
 | ) | [pure virtual]

Return an item that was previously added to this list. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::FindItem | ( | DType | a,
 |  | unsigned long & | res
 | ) | [pure virtual]

Find an item in the list. Return one if it was found, zero if it was not found. The location of the item is returned in res. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::FindItem | ( | DType | a,
 |  | CompareFunction | compare,
 |  | unsigned long & | res
 | ) | [pure virtual]

Find an item in the list using a comparison routine. Return one if it was found, zero if it was not found. The location of the item is returned in res. It returns VTK_OK if successfull.

template<class DType>
virtual int vtkAbstractList< DType >::SetSize ( unsigned long size ) [pure virtual]

Set the capacity of the list. It returns VTK_OK if successfull.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractList.h
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractMapper Class Reference

abstract class specifies interface to map data. More...

#include <vtkAbstractMapper.h>

Inheritance diagram for vtkAbstractMapper:

[legend]
Collaboration diagram for vtkAbstractMapper:

[legend]
List of all members.

[NOHEADER]

virtual int | GetNumberOfConsumers ()
vtkDataArray * | GetScalars (vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component)

Public Methods

vtkTypeRevisionMacro (vtkAbstractMapper, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual unsigned long | GetMTime ()
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | SetClippingPlanes (vtkPlanes *planes)
void | ShallowCopy (vtkAbstractMapper *m)
virtual float | GetTimeToDraw ()
void | AddClippingPlane (vtkPlane *plane)
void | RemoveClippingPlane (vtkPlane *plane)
void | RemoveAllClippingPlanes ()
virtual void | SetClippingPlanes (vtkPlaneCollection *)
virtual vtkPlaneCollection * | GetClippingPlanes ()
void | AddConsumer (vtkObject *c)
void | RemoveConsumer (vtkObject *c)
vtkObject * | GetConsumer (int i)
int | IsConsumer (vtkObject *c)

Protected Methods

vtkAbstractMapper ()
~vtkAbstractMapper ()

Protected Attributes

vtkTimerLog * Timer
float | TimeToDraw
vtkWindow * LastWindow
vtkPlaneCollection * ClippingPlanes
int | NumberOfConsumers
vtkObject ** Consumers

Detailed Description

abstract class specifies interface to map data.

Date:
2002/02/21 18:51:48
Revision:
1.27

vtkAbstractMapper is an abstract class to specify interface between data and graphics primitives or software rendering techniques. Subclasses of vtkAbstractMapper can be used for rendering 2D data, geometry, or volumetric data.

See also:
vtkAbstractMapper3D vtkMapper vtkPolyDataMapper vtkVolumeMapper
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (38%)
  • Biddiscombe, John (31%)
  • Martin, Ken (14%)
  • Lorensen, Bill (14%)

Definition at line 61 of file vtkAbstractMapper.h.

Constructor & Destructor Documentation

vtkAbstractMapper::vtkAbstractMapper ( ) [protected]

vtkAbstractMapper::~vtkAbstractMapper ( ) [protected]

Member Function Documentation

vtkAbstractMapper::vtkTypeRevisionMacro | ( | vtkAbstractMapper | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

Reimplemented in vtkMapper2D, vtkAbstractMapper3D, vtkDataSetMapper, vtkImageMapper, vtkLabeledDataMapper, vtkMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper, vtkMesaPolyDataMapper2D, vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper, vtkOpenGLPolyDataMapper2D, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkTextMapper, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, vtkVolumeTextureMapper2D, vtkWin32ImageMapper, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32TextMapper, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, and vtkXTextMapper.

void vtkAbstractMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

Reimplemented in vtkMapper2D, vtkAbstractMapper3D, vtkDataSetMapper, vtkImageMapper, vtkLabeledDataMapper, vtkMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkTextMapper, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, vtkVolumeTextureMapper2D, vtkWin32ImageMapper, and vtkXImageMapper.

virtual unsigned long vtkAbstractMapper::GetMTime ( ) [virtual]

Override Modifiedtime as we have added Clipping planes

Reimplemented from vtkObject.

Reimplemented in vtkDataSetMapper, vtkImageMapper, vtkMapper, vtkPolyDataMapper2D, and vtkWin32ImageMapper.

virtual void vtkAbstractMapper::ReleaseGraphicsResources ( vtkWindow * ) [inline, virtual]

Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented in vtkDataSetMapper, vtkLabeledDataMapper, vtkMapper, vtkMesaPolyDataMapper, vtkOpenGLPolyDataMapper, vtkVolumeMapper, vtkVolumeRayCastMapper, vtkWin32OpenGLTextMapper, vtkXMesaTextMapper, and vtkXOpenGLTextMapper.

Definition at line 73 of file vtkAbstractMapper.h.

virtual float vtkAbstractMapper::GetTimeToDraw ( ) [virtual]

Get the time required to draw the geometry last time it was rendered

void vtkAbstractMapper::AddClippingPlane ( vtkPlane * plane )

Specify clipping planes to be applied when the data is mapped (at most 6 clipping planes can be specified).

void vtkAbstractMapper::RemoveClippingPlane ( vtkPlane * plane )

Specify clipping planes to be applied when the data is mapped (at most 6 clipping planes can be specified).

void vtkAbstractMapper::RemoveAllClippingPlanes ( )

Specify clipping planes to be applied when the data is mapped (at most 6 clipping planes can be specified).

virtual void vtkAbstractMapper::SetClippingPlanes ( vtkPlaneCollection * ) [virtual]

Get/Set the vtkPlaneCollection which specifies the clipping planes.

virtual vtkPlaneCollection* vtkAbstractMapper::GetClippingPlanes ( ) [virtual]

Get/Set the vtkPlaneCollection which specifies the clipping planes.

void vtkAbstractMapper::SetClippingPlanes ( vtkPlanes * planes )

An alternative way to set clipping planes: use up to six planes found in the supplied instance of the implicit function vtkPlanes.

void vtkAbstractMapper::ShallowCopy ( vtkAbstractMapper * m )

Make a shallow copy of this mapper.

Reimplemented in vtkMapper, vtkPolyDataMapper, and vtkPolyDataMapper2D.

vtkDataArray* vtkAbstractMapper::GetScalars | ( | vtkDataSet * | input,
 |  | int | scalarMode,
 |  | int | arrayAccessMode,
 |  | int | arrayId,
 |  | const char * | arrayName,
 |  | int & | component
 | ) | [static]

Internal helper function for getting the active scalars. The scalar mode indicates where the scalars come from; the arrayAccessMode is used to indicate how to retrieve the scalars from field data (if the scalarMode indicates that). The component is used to indicate which component in the data array to use as the scalars.

virtual int vtkAbstractMapper::GetNumberOfConsumers ( ) [virtual]

void vtkAbstractMapper::AddConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

void vtkAbstractMapper::RemoveConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

vtkObject* vtkAbstractMapper::GetConsumer ( int i )

Add or remove or get or check a consumer,

int vtkAbstractMapper::IsConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

Member Data Documentation

vtkTimerLog* vtkAbstractMapper::Timer [protected]

Definition at line 127 of file vtkAbstractMapper.h.

float vtkAbstractMapper::TimeToDraw [protected]

Definition at line 128 of file vtkAbstractMapper.h.

vtkWindow* vtkAbstractMapper::LastWindow [protected]

Definition at line 129 of file vtkAbstractMapper.h.

vtkPlaneCollection* vtkAbstractMapper::ClippingPlanes [protected]

Definition at line 130 of file vtkAbstractMapper.h.

int vtkAbstractMapper::NumberOfConsumers [protected]

Definition at line 133 of file vtkAbstractMapper.h.

vtkObject** vtkAbstractMapper::Consumers [protected]

Definition at line 134 of file vtkAbstractMapper.h.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractMapper.h
Generated on Mon Mar 25 01:15:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractMapper3D Class Reference

abstract class specifies interface to map 3D data. More...

#include <vtkAbstractMapper3D.h>

Inheritance diagram for vtkAbstractMapper3D:

[legend]
Collaboration diagram for vtkAbstractMapper3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAbstractMapper3D, vtkAbstractMapper)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual float * | GetBounds ()=0
virtual void | GetBounds (float bounds[6])
float * | GetCenter ()
float | GetLength ()
virtual int | IsARayCastMapper ()
virtual int | IsARenderIntoImageMapper ()
virtual void | Update ()=0

Protected Methods

vtkAbstractMapper3D ()
~vtkAbstractMapper3D ()

Protected Attributes

float | Bounds [6]
float | Center [3]

Detailed Description

abstract class specifies interface to map 3D data.

Date:
2002/01/22 15:38:26
Revision:
1.18

vtkAbstractMapper3D is an abstract class to specify interface between 3D data and graphics primitives or software rendering techniques. Subclasses of vtkAbstractMapper3D can be used for rendering geometry or rendering volumetric data.

This class also defines an API to support hardware clipping planes (at most six planes can be defined). It also provides geometric data about the input data it maps, such as the bounding box and center.

See also:
vtkAbstractMapper vtkMapper vtkPolyDataMapper vtkVolumeMapper
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Biddiscombe, John (18%)
  • Lorensen, Bill (15%)
  • Avila, Lisa (5%)

Definition at line 52 of file vtkAbstractMapper3D.h.

Constructor & Destructor Documentation

vtkAbstractMapper3D::vtkAbstractMapper3D ( ) [protected]

vtkAbstractMapper3D::~vtkAbstractMapper3D ( ) [inline, protected]

Definition at line 85 of file vtkAbstractMapper3D.h.

Member Function Documentation

vtkAbstractMapper3D::vtkTypeRevisionMacro | ( | vtkAbstractMapper3D | ,
 |  | vtkAbstractMapper |
 | ) |

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkDataSetMapper, vtkMapper, vtkMesaPolyDataMapper, vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLPolyDataMapper, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, and vtkVolumeTextureMapper2D.

void vtkAbstractMapper3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkDataSetMapper, vtkMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, and vtkVolumeTextureMapper2D.

virtual float* vtkAbstractMapper3D::GetBounds ( ) [pure virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented in vtkMapper, vtkPolyDataMapper, and vtkVolumeMapper.

Referenced by vtkVolumeMapper::GetBounds(), and vtkMapper::GetBounds().

virtual void vtkAbstractMapper3D::GetBounds ( float bounds[6] ) [virtual]

Get the bounds for this mapper as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax).

Reimplemented in vtkMapper, vtkPolyDataMapper, and vtkVolumeMapper.

float* vtkAbstractMapper3D::GetCenter ( )

Return the Center of this mapper's data.

float vtkAbstractMapper3D::GetLength ( void )

Return the diagonal length of this mappers bounding box.

virtual int vtkAbstractMapper3D::IsARayCastMapper ( ) [inline, virtual]

Is this a ray cast mapper? A subclass would return 1 if the ray caster is needed to generate an image from this mapper.

Definition at line 73 of file vtkAbstractMapper3D.h.

virtual int vtkAbstractMapper3D::IsARenderIntoImageMapper ( ) [inline, virtual]

Is this a "render into image" mapper? A subclass would return 1 if the mapper produces an image by rendering into a software image buffer.

Definition at line 78 of file vtkAbstractMapper3D.h.

virtual void vtkAbstractMapper3D::Update ( ) [pure virtual]

Update the network connected to this mapper.

Reimplemented in vtkMapper, vtkPolyDataMapper, vtkVolumeMapper, and vtkVolumeTextureMapper.

Member Data Documentation

float vtkAbstractMapper3D::Bounds[6] [protected]

Definition at line 87 of file vtkAbstractMapper3D.h.

float vtkAbstractMapper3D::Center[3] [protected]

Definition at line 88 of file vtkAbstractMapper3D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkAbstractMapper3D.h
Generated on Mon Mar 25 01:15:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractPicker Class Reference

define API for picking subclasses. More...

#include <vtkAbstractPicker.h>

Inheritance diagram for vtkAbstractPicker:

[legend]
Collaboration diagram for vtkAbstractPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAbstractPicker, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetStartPickMethod (void(*f)(void *), void *arg)
void | SetPickMethod (void(*f)(void *), void *arg)
void | SetEndPickMethod (void(*f)(void *), void *arg)
void | SetStartPickMethodArgDelete (void(*f)(void *))
void | SetPickMethodArgDelete (void(*f)(void *))
void | SetEndPickMethodArgDelete (void(*f)(void *))
void | InitializePickList ()
void | AddPickList (vtkProp *)
void | DeletePickList (vtkProp *)
vtkPropCollection * GetPickList ()
virtual vtkRenderer * | GetRenderer ()
virtual float * | GetSelectionPoint ()
virtual void | GetSelectionPoint (float data[3])
virtual float * | GetPickPosition ()
virtual void | GetPickPosition (float data[3])
virtual int | Pick (float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)=0
int | Pick (float selectionPt[3], vtkRenderer *ren)
virtual void | SetPickFromList (int)
virtual int | GetPickFromList ()
virtual void | PickFromListOn ()
virtual void | PickFromListOff ()

Protected Methods

vtkAbstractPicker ()
~vtkAbstractPicker ()
virtual void | Initialize ()

Protected Attributes

vtkRenderer * Renderer
float | SelectionPoint [3]
float | PickPosition [3]
unsigned long | StartPickTag
unsigned long | PickTag
unsigned long | EndPickTag
int | PickFromList
vtkPropCollection * PickList

Detailed Description

define API for picking subclasses.

Date:
2002/01/22 15:38:26
Revision:
1.10

vtkAbstractPicker is an abstract superclass that defines a minimal API for its concrete subclasses. The minimum functionality of a picker is to return the x-y-z global coordinate position of a pick (the pick itself is defined in display coordinates).

The API to this class is to invoke the Pick() method with a selection point (in display coordinates - pixels) and a renderer. Then get the resulting pick position in global coordinates with the GetPickPosition() method.

vtkPicker has hooks for methods to call during the picking process. These methods are StartPickMethod(), PickMethod(), and EndPickMethod() which are invoked prior to picking, when something is picked, and after all picking candidates have been tested. Note that during the pick process the PickMethod() of vtkProp (and its subclasses such as vtkActor) is called prior to the pick method of vtkPicker.

Warning:
vtkAbstractPicker and its subclasses will not pick props that are "unpickable" (see vtkProp) or are fully transparent (if transparency is a property of the vtkProp).
Warning:
There are two classes of pickers: those that pick using geometric methods (typically a ray cast); and those that use rendering hardware. Geometric methods return more information but are slower. Hardware methods are much faster and return minimal information. Examples of geometric pickers include vtkPicker, vtkCellPicker, and vtkPointPicker. Examples of hardware pickers include vtkWorldPointPicker and vtkPropPicker.
See also:
vtkPropPicker uses hardware acceleration to pick an instance of vtkProp. (This means that 2D and 3D props can be picked, and it's relatively fast.) If you need to pick cells or points, you might wish to use vtkCellPicker or vtkPointPicker. vtkWorldPointPicker is the fastest picker, returning an x-y-z coordinate value using the hardware z-buffer. vtkPicker can be used to pick the bounding box of 3D props.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)
  • Avila, Lisa (8%)

Definition at line 74 of file vtkAbstractPicker.h.

Constructor & Destructor Documentation

vtkAbstractPicker::vtkAbstractPicker ( ) [protected]

vtkAbstractPicker::~vtkAbstractPicker ( ) [protected]

Member Function Documentation

vtkAbstractPicker::vtkTypeRevisionMacro | ( | vtkAbstractPicker | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkAbstractPropPicker, vtkCellPicker, vtkPicker, vtkPointPicker, vtkPropPicker, and vtkWorldPointPicker.

void vtkAbstractPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkAbstractPropPicker, vtkCellPicker, vtkPicker, vtkPointPicker, vtkPropPicker, and vtkWorldPointPicker.

virtual vtkRenderer* vtkAbstractPicker::GetRenderer ( ) [virtual]

Get the renderer in which pick event occurred.

virtual float* vtkAbstractPicker::GetSelectionPoint ( ) [virtual]

Get the selection point in screen (pixel) coordinates. The third value is related to z-buffer depth. (Normally should be =0.)

virtual void vtkAbstractPicker::GetSelectionPoint ( float data[3] ) [virtual]

Get the selection point in screen (pixel) coordinates. The third value is related to z-buffer depth. (Normally should be =0.)

virtual float* vtkAbstractPicker::GetPickPosition ( ) [virtual]

Return position in global coordinates of pick point.

virtual void vtkAbstractPicker::GetPickPosition ( float data[3] ) [virtual]

Return position in global coordinates of pick point.

virtual int vtkAbstractPicker::Pick | ( | float | selectionX,
 |  | float | selectionY,
 |  | float | selectionZ,
 |  | vtkRenderer * | renderer
 | ) | [pure virtual]

Perform pick operation with selection point provided. Normally the first two values for the selection point are x-y pixel coordinate, and the third value is =0. Return non-zero if something was successfully picked.

Reimplemented in vtkPicker, vtkPropPicker, and vtkWorldPointPicker.

Referenced by vtkWorldPointPicker::Pick(), vtkPropPicker::Pick(), and vtkPicker::Pick().

int vtkAbstractPicker::Pick | ( | float | selectionPt[3],
 |  | vtkRenderer * | renderer
 | ) | [inline]

provided. Normally the first two values for the selection point are x-y pixel coordinate, and the third value is =0. Return non-zero if something was successfully picked.

Reimplemented in vtkPicker, vtkPropPicker, and vtkWorldPointPicker.

Definition at line 109 of file vtkAbstractPicker.h.

void vtkAbstractPicker::SetStartPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

begins.

void vtkAbstractPicker::SetPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called when something is picked.

void vtkAbstractPicker::SetEndPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called after all picking operations have been performed.

void vtkAbstractPicker::SetStartPickMethodArgDelete ( void(* f)(void *) )

Set a method to delete user arguments for StartPickMethod.

void vtkAbstractPicker::SetPickMethodArgDelete ( void(* f)(void *) )

Set a method to delete user arguments for PickMethod.

void vtkAbstractPicker::SetEndPickMethodArgDelete ( void(* f)(void *) )

Set a method to delete user arguments for EndPickMethod.

virtual void vtkAbstractPicker::SetPickFromList ( int ) [virtual]

Use these methods to control whether to limit the picking to this list (rather than renderer's actors). Make sure that the pick list contains actors that referred to by the picker's renderer.

virtual int vtkAbstractPicker::GetPickFromList ( ) [virtual]

Use these methods to control whether to limit the picking to this list (rather than renderer's actors). Make sure that the pick list contains actors that referred to by the picker's renderer.

virtual void vtkAbstractPicker::PickFromListOn ( ) [virtual]

Use these methods to control whether to limit the picking to this list (rather than renderer's actors). Make sure that the pick list contains actors that referred to by the picker's renderer.

virtual void vtkAbstractPicker::PickFromListOff ( ) [virtual]

Use these methods to control whether to limit the picking to this list (rather than renderer's actors). Make sure that the pick list contains actors that referred to by the picker's renderer.

void vtkAbstractPicker::InitializePickList ( )

Initialize list of actors in pick list.

void vtkAbstractPicker::AddPickList ( vtkProp * )

Add an actor to the pick list.

void vtkAbstractPicker::DeletePickList ( vtkProp * )

Delete an actor from the pick list.

vtkPropCollection* vtkAbstractPicker::GetPickList ( ) [inline]

Return the list of actors in the PickList.

Definition at line 151 of file vtkAbstractPicker.h.

virtual void vtkAbstractPicker::Initialize ( ) [protected, virtual]

Reimplemented in vtkAbstractPropPicker, vtkCellPicker, vtkPicker, vtkPointPicker, and vtkPropPicker.

Member Data Documentation

vtkRenderer* vtkAbstractPicker::Renderer [protected]

Definition at line 159 of file vtkAbstractPicker.h.

float vtkAbstractPicker::SelectionPoint[3] [protected]

Definition at line 160 of file vtkAbstractPicker.h.

float vtkAbstractPicker::PickPosition[3] [protected]

Definition at line 161 of file vtkAbstractPicker.h.

unsigned long vtkAbstractPicker::StartPickTag [protected]

Definition at line 164 of file vtkAbstractPicker.h.

unsigned long vtkAbstractPicker::PickTag [protected]

Definition at line 165 of file vtkAbstractPicker.h.

unsigned long vtkAbstractPicker::EndPickTag [protected]

Definition at line 166 of file vtkAbstractPicker.h.

int vtkAbstractPicker::PickFromList [protected]

Definition at line 169 of file vtkAbstractPicker.h.

vtkPropCollection* vtkAbstractPicker::PickList [protected]

Definition at line 170 of file vtkAbstractPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkAbstractPicker.h
Generated on Mon Mar 25 01:15:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractPropPicker Class Reference

abstract API for pickers that can pick an instance of vtkProp. More...

#include <vtkAbstractPropPicker.h>

Inheritance diagram for vtkAbstractPropPicker:

[legend]
Collaboration diagram for vtkAbstractPropPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAbstractPropPicker, vtkAbstractPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkProp * | GetProp ()
virtual vtkProp3D * | GetProp3D ()
virtual vtkActor * | GetActor ()
virtual vtkActor2D * | GetActor2D ()
virtual vtkVolume * | GetVolume ()
virtual vtkAssembly * | GetAssembly ()
virtual vtkPropAssembly * | GetPropAssembly ()
virtual void | SetPath (vtkAssemblyPath *)
virtual vtkAssemblyPath * | GetPath ()

Protected Methods

vtkAbstractPropPicker ()
~vtkAbstractPropPicker ()
void | Initialize ()

Protected Attributes

vtkAssemblyPath * Path

Detailed Description

abstract API for pickers that can pick an instance of vtkProp.

Date:
2002/01/22 15:38:27
Revision:
1.11

vtkAbstractPropPicker is an abstract superclass for pickers that can pick an instance of vtkProp. Some pickers, like vtkWorldPointPicker (not a subclass of this class), cannot identify the prop that is picked. Subclasses of vtkAbstractPropPicker return a prop in the form of a vtkAssemblyPath when a pick is invoked. Note that an vtkAssemblyPath contain a list of vtkAssemblyNodes, each of which in turn contains a reference to a vtkProp and a 4x4 transformation matrix. The path fully describes the entire pick path, so you can pick assemblies or portions of assemblies, or just grab the tail end of the vtkAssemblyPath (which is the picked prop).

Warning:
Because a vtkProp can be placed into different assemblies, or even in different leaf positions of the same assembly, the vtkAssemblyPath is used to fully qualify exactly which use of the vtkProp was picked, including its position (since vtkAssemblyPath includes a transformation matrix per node).
Warning:
The class returns information about picked actors, props, etc. Note that what is returned by these methods is the top level of the assembly path. This can cause a lot of confusion! For example, if you pick a vtkAssembly, and the returned vtkAssemblyPath has as a leaf a vtkActor, then if you invoke GetActor(), you will get NULL, even though an actor was indeed picked. (GetAssembly() will return something.) Note that the safest thing to do is to do a GetProp(), which will always return something if something was picked. A better way to manage picking is to work with vtkAssemblyPath, since this completely defines the pick path from top to bottom in a assembly hierarchy, and avoids confusion when the same prop is used in different assemblies.
Warning:
The returned assembly paths refer to assembly nodes that in turn refer to vtkProp and vtkMatrix. This association to vtkProp is not a reference counted association, meaning that dangling references are possible if you do a pick, get an assembly path, and then delete a vtkProp. (Reason: assembly paths create many self-referencing loops that destroy reference counting.)
See also:
vtkPropPicker vtkPicker vtkWorldPointPicker vtkCellPicker vtkPointPicker vtkAssemblyPath vtkAssemblyNode vtkAssemblyPaths vtkAbstractPicker vtkRenderer
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)
  • Martin, Ken (6%)

Definition at line 86 of file vtkAbstractPropPicker.h.

Constructor & Destructor Documentation

vtkAbstractPropPicker::vtkAbstractPropPicker ( ) [protected]

vtkAbstractPropPicker::~vtkAbstractPropPicker ( ) [protected]

Member Function Documentation

vtkAbstractPropPicker::vtkTypeRevisionMacro | ( | vtkAbstractPropPicker | ,
 |  | vtkAbstractPicker |
 | ) |

Reimplemented from vtkAbstractPicker.

Reimplemented in vtkCellPicker, vtkPicker, vtkPointPicker, and vtkPropPicker.

void vtkAbstractPropPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractPicker.

Reimplemented in vtkCellPicker, vtkPicker, vtkPointPicker, and vtkPropPicker.

virtual void vtkAbstractPropPicker::SetPath ( vtkAssemblyPath * ) [virtual]

Return the vtkAssemblyPath that has been picked. The assembly path lists all the vtkProps that form an assembly. If no assembly is present, then the assembly path will have one node (which is the picked prop). The set method is used internally to set the path. (Note: the structure of an assembly path is a collection of vtkAssemblyNode, each node pointing to a vtkProp and (possibly) a transformation matrix.)

virtual vtkAssemblyPath* vtkAbstractPropPicker::GetPath ( ) [virtual]

Return the vtkAssemblyPath that has been picked. The assembly path lists all the vtkProps that form an assembly. If no assembly is present, then the assembly path will have one node (which is the picked prop). The set method is used internally to set the path. (Note: the structure of an assembly path is a collection of vtkAssemblyNode, each node pointing to a vtkProp and (possibly) a transformation matrix.)

virtual vtkProp* vtkAbstractPropPicker::GetProp ( ) [virtual]

Return the vtkProp that has been picked. If NULL, nothing was picked. If anything at all was picked, this method will return something.

virtual vtkProp3D* vtkAbstractPropPicker::GetProp3D ( ) [virtual]

Return the vtkProp that has been picked. If NULL, no vtkProp3D was picked.

virtual vtkActor* vtkAbstractPropPicker::GetActor ( ) [virtual]

Return the vtkActor that has been picked. If NULL, no actor was picked.

virtual vtkActor2D* vtkAbstractPropPicker::GetActor2D ( ) [virtual]

Return the vtkActor2D that has been picked. If NULL, no actor2D was picked.

virtual vtkVolume* vtkAbstractPropPicker::GetVolume ( ) [virtual]

Return the vtkVolume that has been picked. If NULL, no volume was picked.

virtual vtkAssembly* vtkAbstractPropPicker::GetAssembly ( ) [virtual]

Return the vtkAssembly that has been picked. If NULL, no assembly was picked. (Note: the returned assembly is the first node in the assembly path. If the path is one node long, then the assembly and the prop are the same, assuming that the first node is a vtkAssembly.)

virtual vtkPropAssembly* vtkAbstractPropPicker::GetPropAssembly ( ) [virtual]

Return the vtkPropAssembly that has been picked. If NULL, no prop assembly was picked. (Note: the returned prop assembly is the first node in the assembly path. If the path is one node long, then the prop assembly and the prop are the same, assuming that the first node is a vtkPropAssembly.)

void vtkAbstractPropPicker::Initialize ( ) [protected, virtual]

Reimplemented from vtkAbstractPicker.

Reimplemented in vtkCellPicker, vtkPicker, vtkPointPicker, and vtkPropPicker.

Member Data Documentation

vtkAssemblyPath* vtkAbstractPropPicker::Path [protected]

Definition at line 149 of file vtkAbstractPropPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkAbstractPropPicker.h
Generated on Mon Mar 25 01:15:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAbstractTransform Class Reference

superclass for all geometric transformations. More...

#include <vtkAbstractTransform.h>

Inheritance diagram for vtkAbstractTransform:

[legend]
Collaboration diagram for vtkAbstractTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAbstractTransform, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
double * | TransformNormalAtPoint (const double point[3], const double normal[3])
double * | TransformVectorAtPoint (const double point[3], const double vector[3])
virtual void | TransformPoints (vtkPoints *inPts, vtkPoints *outPts)
vtkAbstractTransform * | GetInverse ()
void | SetInverse (vtkAbstractTransform *transform)
virtual void | Inverse ()=0
void | DeepCopy (vtkAbstractTransform *)
void | Update ()
virtual vtkAbstractTransform * | MakeTransform ()=0
virtual int | CircuitCheck (vtkAbstractTransform *transform)
unsigned long | GetMTime ()
void | UnRegister (vtkObject *O)
void | TransformPoint (const float in[3], float out[3])
void | TransformPoint (const double in[3], double out[3])
double * | TransformPoint (double x, double y, double z)
double * | TransformPoint (const double point[3])
float * | TransformFloatPoint (float x, float y, float z)
float * | TransformFloatPoint (const float point[3])
double * | TransformDoublePoint (double x, double y, double z)
double * | TransformDoublePoint (const double point[3])
void | TransformNormalAtPoint (const float point[3], const float in[3], float out[3])
void | TransformNormalAtPoint (const double point[3], const double in[3], double out[3])
double * | TransformDoubleNormalAtPoint (const double point[3], const double normal[3])
float * | TransformFloatNormalAtPoint (const float point[3], const float normal[3])
void | TransformVectorAtPoint (const float point[3], const float in[3], float out[3])
void | TransformVectorAtPoint (const double point[3], const double in[3], double out[3])
double * | TransformDoubleVectorAtPoint (const double point[3], const double vector[3])
float * | TransformFloatVectorAtPoint (const float point[3], const float vector[3])
virtual void | TransformPointsNormalsVectors (vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs)
virtual void | InternalTransformPoint (const float in[3], float out[3])=0
virtual void | InternalTransformPoint (const double in[3], double out[3])=0
virtual void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])=0
virtual void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])=0
void | Identity ()

Protected Methods

vtkAbstractTransform ()
~vtkAbstractTransform ()
virtual void | InternalUpdate ()
virtual void | InternalDeepCopy (vtkAbstractTransform *)

Protected Attributes

float | InternalFloatPoint [3]
double | InternalDoublePoint [3]

Detailed Description

superclass for all geometric transformations.

Date:
2002/01/22 15:25:09
Revision:
1.18

vtkAbstractTransform is the superclass for all VTK geometric transformations. The VTK transform hierarchy is split into two major branches: warp transformations and homogeneous (including linear) transformations. The latter can be represented in terms of a 4x4 transformation matrix, the former cannot.

Transformations can be pipelined through two mechanisms:

1) GetInverse() returns the pipelined inverse of a transformation i.e. if you modify the original transform, any transform previously returned by the GetInverse() method will automatically update itself according to the change.

2) You can do pipelined concatenation of transformations through the vtkGeneralTransform class, the vtkPerspectiveTransform class, or the vtkTransform class.

See also:
vtkGeneralTransform vtkWarpTransform vtkHomogeneousTransform vtkLinearTransform vtkIdentityTransform vtkTransformPolyDataFilter vtkTransformFilter vtkImageReslice vtkImplicitFunction
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (93%)

Definition at line 58 of file vtkAbstractTransform.h.

Constructor & Destructor Documentation

vtkAbstractTransform::vtkAbstractTransform ( ) [protected]

vtkAbstractTransform::~vtkAbstractTransform ( ) [protected]

Member Function Documentation

vtkAbstractTransform::vtkTypeRevisionMacro | ( | vtkAbstractTransform | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkWarpTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

void vtkAbstractTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkWarpTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

void vtkAbstractTransform::TransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [inline]

Apply the transformation to a coordinate. You can use the same array to store both the input and output point.

Definition at line 68 of file vtkAbstractTransform.h.

void vtkAbstractTransform::TransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [inline]

Apply the transformation to a double-precision coordinate. You can use the same array to store both the input and output point.

Definition at line 75 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformPoint | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Apply the transformation to a double-precision coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 82 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformPoint ( const double point[3] ) [inline]

Apply the transformation to a double-precision coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 84 of file vtkAbstractTransform.h.

float* vtkAbstractTransform::TransformFloatPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Apply the transformation to an (x,y,z) coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 91 of file vtkAbstractTransform.h.

float* vtkAbstractTransform::TransformFloatPoint ( const float point[3] ) [inline]

Apply the transformation to an (x,y,z) coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 97 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformDoublePoint | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Apply the transformation to a double-precision (x,y,z) coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 104 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformDoublePoint ( const double point[3] ) [inline]

Apply the transformation to a double-precision (x,y,z) coordinate. Use this if you are programming in Python, tcl or Java.

Definition at line 110 of file vtkAbstractTransform.h.

void vtkAbstractTransform::TransformNormalAtPoint | ( | const float | point[3],
 |  | const float | in[3],
 |  | float | out[3]
 | ) |

Apply the transformation to a normal at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformNormal() instead.

void vtkAbstractTransform::TransformNormalAtPoint | ( | const double | point[3],
 |  | const double | in[3],
 |  | double | out[3]
 | ) |

Apply the transformation to a normal at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformNormal() instead.

double* vtkAbstractTransform::TransformNormalAtPoint | ( | const double | point[3],
 |  | const double | normal[3]
 | ) | [inline]

Definition at line 124 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformDoubleNormalAtPoint | ( | const double | point[3],
 |  | const double | normal[3]
 | ) | [inline]

Apply the transformation to a double-precision normal at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformDoubleNormal() instead.

Definition at line 133 of file vtkAbstractTransform.h.

float* vtkAbstractTransform::TransformFloatNormalAtPoint | ( | const float | point[3],
 |  | const float | normal[3]
 | ) | [inline]

Apply the transformation to a single-precision normal at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformFloatNormal() instead.

Definition at line 143 of file vtkAbstractTransform.h.

void vtkAbstractTransform::TransformVectorAtPoint | ( | const float | point[3],
 |  | const float | in[3],
 |  | float | out[3]
 | ) |

Apply the transformation to a vector at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformVector() instead.

void vtkAbstractTransform::TransformVectorAtPoint | ( | const double | point[3],
 |  | const double | in[3],
 |  | double | out[3]
 | ) |

Apply the transformation to a vector at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformVector() instead.

double* vtkAbstractTransform::TransformVectorAtPoint | ( | const double | point[3],
 |  | const double | vector[3]
 | ) | [inline]

Definition at line 159 of file vtkAbstractTransform.h.

double* vtkAbstractTransform::TransformDoubleVectorAtPoint | ( | const double | point[3],
 |  | const double | vector[3]
 | ) | [inline]

Apply the transformation to a double-precision vector at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformDoubleVector() instead.

Definition at line 168 of file vtkAbstractTransform.h.

float* vtkAbstractTransform::TransformFloatVectorAtPoint | ( | const float | point[3],
 |  | const float | vector[3]
 | ) | [inline]

Apply the transformation to a single-precision vector at the specified vertex. If the transformation is a vtkLinearTransform, you can use TransformFloatVector() instead.

Definition at line 178 of file vtkAbstractTransform.h.

virtual void vtkAbstractTransform::TransformPoints | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts
 | ) | [virtual]

Apply the transformation to a series of points, and append the results to outPts.

Reimplemented in vtkHomogeneousTransform, vtkIdentityTransform, and vtkLinearTransform.

virtual void vtkAbstractTransform::TransformPointsNormalsVectors | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts,
 |  | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms,
 |  | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a combination of points, normals and vectors.

Reimplemented in vtkHomogeneousTransform, vtkIdentityTransform, and vtkLinearTransform.

vtkAbstractTransform* vtkAbstractTransform::GetInverse ( )

Get the inverse of this transform. If you modify this transform, the returned inverse transform will automatically update. If you want the inverse of a vtkTransform, you might want to use GetLinearInverse() instead which will type cast the result from vtkAbstractTransform to vtkLinearTransform.

Reimplemented in vtkTransform.

Referenced by vtkHomogeneousTransform::GetHomogeneousInverse(), vtkTransform::GetInverse(), and vtkLinearTransform::GetLinearInverse().

void vtkAbstractTransform::SetInverse ( vtkAbstractTransform * transform )

Set a transformation that this transform will be the inverse of. This transform will automatically update to agree with the inverse transform that you set.

virtual void vtkAbstractTransform::Inverse ( ) [pure virtual]

Invert the transformation.

Reimplemented in vtkGeneralTransform, vtkIdentityTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkWarpTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

void vtkAbstractTransform::DeepCopy ( vtkAbstractTransform * )

Copy this transform from another of the same type.

void vtkAbstractTransform::Update ( )

Update the transform to account for any changes which have been made. You do not have to call this method yourself, it is called automatically whenever the transform needs an update.

Referenced by vtkHomogeneousTransform::GetMatrix(), vtkLinearTransform::TransformNormal(), and vtkLinearTransform::TransformVector().

virtual void vtkAbstractTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [pure virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, and vtkWarpTransform.

virtual void vtkAbstractTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [pure virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, and vtkWarpTransform.

virtual void vtkAbstractTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [pure virtual]

This will transform a point and, at the same time, calculate a 3x3 Jacobian matrix that provides the partial derivatives of the transformation at that point. This method does not call Update. Meant for use only within other VTK classes.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, and vtkWarpTransform.

virtual void vtkAbstractTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [pure virtual]

This will transform a point and, at the same time, calculate a 3x3 Jacobian matrix that provides the partial derivatives of the transformation at that point. This method does not call Update. Meant for use only within other VTK classes.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkLinearTransform, and vtkWarpTransform.

virtual vtkAbstractTransform* vtkAbstractTransform::MakeTransform ( ) [pure virtual]

Make another transform of the same type.

Reimplemented in vtkGeneralTransform, vtkIdentityTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

virtual int vtkAbstractTransform::CircuitCheck ( vtkAbstractTransform * transform ) [virtual]

Check for self-reference. Will return true if concatenating with the specified transform, setting it to be our inverse, or setting it to be our input will create a circular reference. CircuitCheck is automatically called by SetInput(), SetInverse(), and Concatenate(vtkXTransform *). Avoid using this function, it is experimental.

Reimplemented in vtkGeneralTransform, vtkPerspectiveTransform, and vtkTransform.

unsigned long vtkAbstractTransform::GetMTime ( ) [virtual]

Override GetMTime necessary because of inverse transforms.

Reimplemented from vtkObject.

Reimplemented in vtkGeneralTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

void vtkAbstractTransform::UnRegister ( vtkObject * O ) [virtual]

Needs a special UnRegister() implementation to avoid circular references.

Reimplemented from vtkObject.

void vtkAbstractTransform::Identity ( ) [inline]

This method is deprecated in the base class. It is still valid to use it on many of the specialized classes.

Reimplemented in vtkGeneralTransform, vtkPerspectiveTransform, and vtkTransform.

Definition at line 261 of file vtkAbstractTransform.h.

Referenced by vtkTransform::SetMatrix(), and vtkPerspectiveTransform::SetMatrix().

virtual void vtkAbstractTransform::InternalUpdate ( ) [inline, protected, virtual]

Perform any subclass-specific Update.

Reimplemented in vtkGeneralTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

Definition at line 270 of file vtkAbstractTransform.h.

virtual void vtkAbstractTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [inline, protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented in vtkGeneralTransform, vtkHomogeneousTransform, vtkIdentityTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, and vtkThinPlateSplineTransform.

Definition at line 273 of file vtkAbstractTransform.h.

Member Data Documentation

float vtkAbstractTransform::InternalFloatPoint[3] [protected]

Definition at line 275 of file vtkAbstractTransform.h.

double vtkAbstractTransform::InternalDoublePoint[3] [protected]

Definition at line 276 of file vtkAbstractTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractTransform.h
Generated on Mon Mar 25 01:15:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor Class Reference

represents an object (geometry & properties) in a rendered scene. More...

#include <vtkActor.h>

Inheritance diagram for vtkActor:

[legend]
Collaboration diagram for vtkActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkActor, vtkProp3D)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | GetActors (vtkPropCollection *)
virtual void | Render (vtkRenderer *, vtkMapper *)
void | ShallowCopy (vtkProp *prop)
void | ReleaseGraphicsResources (vtkWindow *)
virtual vtkProperty * | MakeProperty ()
virtual void | SetMapper (vtkMapper *)
virtual void | ApplyProperties ()
unsigned long int | GetMTime ()
virtual unsigned long | GetRedrawMTime ()
virtual int | RenderOpaqueGeometry (vtkViewport *viewport)
virtual int | RenderTranslucentGeometry (vtkViewport *viewport)
void | SetProperty (vtkProperty *lut)
vtkProperty * GetProperty ()
void | SetBackfaceProperty (vtkProperty *lut)
vtkProperty * GetBackfaceProperty ()
virtual void | SetTexture (vtkTexture *)
virtual vtkTexture * | GetTexture ()
virtual vtkMapper * | GetMapper ()
void | GetBounds (float bounds[6])
float * | GetBounds ()
virtual void | InitPartTraversal ()
virtual vtkActor * | GetNextPart ()
virtual int | GetNumberOfParts ()

Static Public Methods

vtkActor * | New ()

Protected Methods

vtkActor ()
~vtkActor ()
int | GetIsOpaque ()

Protected Attributes

vtkProperty * Property
vtkProperty * BackfaceProperty
vtkTexture * Texture
vtkMapper * Mapper
float | MapperBounds [6]
vtkTimeStamp BoundsMTime

Detailed Description

represents an object (geometry & properties) in a rendered scene.

Date:
2002/02/22 16:43:26
Revision:
1.96

vtkActor is used to represent an entity in a rendering scene. It inherits functions related to the actors position, and orientation from vtkProp. The actor also has scaling and maintains a reference to the defining geometry (i.e., the mapper), rendering properties, and possibly a texture map. vtkActor combines these instance variables into one 4x4 transformation matrix as follows: [x y z 1] = [x y z 1] Translate(-origin) Scale(scale) Rot(y) Rot(x) Rot (z) Trans(origin) Trans(position)

See also:
vtkProperty vtkTexture vtkMapper vtkAssembly vtkFollower vtkLODActor
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (44%)
  • Schroeder, Will (26%)
  • Avila, Lisa (12%)
  • Law, Charles (5%)
Examples:
vtkActor (Examples)
Tests:
vtkActor (Tests)

Definition at line 62 of file vtkActor.h.

Constructor & Destructor Documentation

vtkActor::vtkActor ( ) [protected]

vtkActor::~vtkActor ( ) [protected]

Member Function Documentation

vtkActor::vtkTypeRevisionMacro | ( | vtkActor | ,
 |  | vtkProp3D |
 | ) |

Reimplemented from vtkProp3D.

Reimplemented in vtkFollower, vtkLODActor, vtkMesaActor, and vtkOpenGLActor.

void vtkActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp3D.

Reimplemented in vtkFollower, and vtkLODActor.

vtkActor* vtkActor::New ( ) [static]

Creates an actor with the following defaults: origin(0,0,0) position=(0,0,0) scale=(1,1,1) visibility=1 pickable=1 dragable=1 orientation=(0,0,0). No user defined matrix and no texture map.

Reimplemented from vtkProp.

Reimplemented in vtkFollower, vtkLODActor, vtkMesaActor, and vtkOpenGLActor.

virtual void vtkActor::GetActors ( vtkPropCollection * ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented from vtkProp.

virtual int vtkActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

Reimplemented in vtkFollower, and vtkLODActor.

virtual int vtkActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

Reimplemented in vtkFollower.

virtual void vtkActor::Render | ( | vtkRenderer * | ren,
 |  | vtkMapper * | mapper
 | ) | [inline, virtual]

This causes the actor to be rendered. It in turn will render the actor's property, texture map and then mapper. If a property hasn't been assigned, then the actor will create one automatically. Note that a side effect of this method is that the pipeline will be updated.

Reimplemented in vtkLODActor, vtkMesaActor, and vtkOpenGLActor.

Definition at line 89 of file vtkActor.h.

void vtkActor::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of an actor. Overloads the virtual vtkProp method.

Reimplemented from vtkProp3D.

Reimplemented in vtkFollower, and vtkLODActor.

void vtkActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

Reimplemented in vtkLODActor.

void vtkActor::SetProperty ( vtkProperty * lut )

Set/Get the property object that controls this actors surface properties. This should be an instance of a vtkProperty object. Every actor must have a property associated with it. If one isn't specified, then one will be generated automatically. Multiple actors can share one property object.

vtkProperty* vtkActor::GetProperty ( )

Set/Get the property object that controls this actors surface properties. This should be an instance of a vtkProperty object. Every actor must have a property associated with it. If one isn't specified, then one will be generated automatically. Multiple actors can share one property object.

virtual vtkProperty* vtkActor::MakeProperty ( ) [virtual]

Create a new property sutible for use with this type of Actor. For example, a vtkMesaActor should create a vtkMesaProperty in this function. The default is to just call vtkProperty::New.

Reimplemented in vtkMesaActor.

void vtkActor::SetBackfaceProperty ( vtkProperty * lut )

Set/Get the property object that controls this actors backface surface properties. This should be an instance of a vtkProperty object. If one isn't specified, then the front face properties will be used. Multiple actors can share one property object.

vtkProperty* vtkActor::GetBackfaceProperty ( )

Set/Get the property object that controls this actors backface surface properties. This should be an instance of a vtkProperty object. If one isn't specified, then the front face properties will be used. Multiple actors can share one property object.

virtual void vtkActor::SetTexture ( vtkTexture * ) [virtual]

Set/Get the texture object to control rendering texture maps. This will be a vtkTexture object. An actor does not need to have an associated texture map and multiple actors can share one texture.

virtual vtkTexture* vtkActor::GetTexture ( ) [virtual]

Set/Get the texture object to control rendering texture maps. This will be a vtkTexture object. An actor does not need to have an associated texture map and multiple actors can share one texture.

virtual void vtkActor::SetMapper ( vtkMapper * ) [virtual]

This is the method that is used to connect an actor to the end of a visualization pipeline, i.e. the mapper. This should be a subclass of vtkMapper. Typically vtkPolyDataMapper and vtkDataSetMapper will be used.

virtual vtkMapper* vtkActor::GetMapper ( void ) [virtual]

Returns the Mapper that this actor is getting its data from.

void vtkActor::GetBounds ( float bounds[6] ) [inline]

Get the bounds for this Actor as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax). (The method GetBounds(float bounds[6]) is available from the superclass.)

Reimplemented from vtkProp3D.

Definition at line 146 of file vtkActor.h.

float* vtkActor::GetBounds ( ) [virtual]

Get the bounds for this Actor as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax). (The method GetBounds(float bounds[6]) is available from the superclass.)

Reimplemented from vtkProp3D.

virtual void vtkActor::ApplyProperties ( ) [inline, virtual]

Apply the current properties to all parts that compose this actor. This method is overloaded in vtkAssembly to apply the assemblies' properties to all its parts in a recursive manner. Typically the use of this method is to set the desired properties in the assembly, and then push the properties down to the assemblies parts with ApplyProperties().

Definition at line 156 of file vtkActor.h.

unsigned long int vtkActor::GetMTime ( ) [virtual]

Get the actors mtime plus consider its properties, texture and usermatrix if set.

Reimplemented from vtkObject.

virtual unsigned long vtkActor::GetRedrawMTime ( ) [virtual]

Return the mtime of anything that would cause the rendered image to appear differently. Usually this involves checking the mtime of the prop plus anything else it depends on such as properties, textures etc.

Reimplemented from vtkProp.

virtual void vtkActor::InitPartTraversal ( ) [virtual]

The following methods are for compatibility. The methods will be deprecated in the near future. Use vtkProp::GetNextPath() (and related functionality) to get the parts in an assembly (or more correctly, the paths in the assembly).

virtual vtkActor* vtkActor::GetNextPart ( ) [virtual]

The following methods are for compatibility. The methods will be deprecated in the near future. Use vtkProp::GetNextPath() (and related functionality) to get the parts in an assembly (or more correctly, the paths in the assembly).

virtual int vtkActor::GetNumberOfParts ( ) [virtual]

The following methods are for compatibility. The methods will be deprecated in the near future. Use vtkProp::GetNextPath() (and related functionality) to get the parts in an assembly (or more correctly, the paths in the assembly).

int vtkActor::GetIsOpaque ( ) [protected]

Member Data Documentation

vtkProperty* vtkActor::Property [protected]

Definition at line 182 of file vtkActor.h.

vtkProperty* vtkActor::BackfaceProperty [protected]

Definition at line 183 of file vtkActor.h.

vtkTexture* vtkActor::Texture [protected]

Definition at line 184 of file vtkActor.h.

vtkMapper* vtkActor::Mapper [protected]

Definition at line 185 of file vtkActor.h.

float vtkActor::MapperBounds[6] [protected]

Definition at line 192 of file vtkActor.h.

vtkTimeStamp vtkActor::BoundsMTime [protected]

Definition at line 193 of file vtkActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkActor.h
Generated on Mon Mar 25 01:15:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor2D Class Reference

a actor that draws 2D data. More...

#include <vtkActor2D.h>

Inheritance diagram for vtkActor2D:

[legend]
Collaboration diagram for vtkActor2D:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkActor2D, vtkProp)
vtkProperty2D * GetProperty ()
void | SetDisplayPosition (int, int)
unsigned long | GetMTime ()
virtual void | GetActors2D (vtkPropCollection *pc)
void | ShallowCopy (vtkProp *prop)
virtual void | ReleaseGraphicsResources (vtkWindow *)
int | RenderOverlay (vtkViewport *viewport)
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *viewport)
virtual void | SetMapper (vtkMapper2D *mapper)
virtual vtkMapper2D * | GetMapper ()
virtual void | SetLayerNumber (int)
virtual int | GetLayerNumber ()
virtual void | SetProperty (vtkProperty2D *)
virtual vtkCoordinate * | GetPositionCoordinate ()
virtual void | SetPosition (float x[2])
virtual void | SetPosition (float x, float y)
virtual float * | GetPosition ()
virtual vtkCoordinate * | GetPosition2Coordinate ()
virtual void | SetPosition2 (float x[2])
virtual void | SetPosition2 (float x, float y)
virtual float * | GetPosition2 ()
void | SetWidth (float w)
float | GetWidth ()
void | SetHeight (float h)
float | GetHeight ()

Static Public Methods

vtkActor2D * | New ()

Protected Methods

vtkActor2D ()
~vtkActor2D ()

Protected Attributes

vtkMapper2D * Mapper
int | LayerNumber
vtkProperty2D * Property
vtkCoordinate * PositionCoordinate
vtkCoordinate * Position2Coordinate

Detailed Description

a actor that draws 2D data.

Date:
2002/01/22 15:25:09
Revision:
1.36

vtkActor2D is similar to vtkActor, but it is made to be used with two dimensional images and annotation. vtkActor2D has a position but does not use a transformation matrix like vtkActor (see the superclass vtkProp for information on positioning vtkActor2D). vtkActor2D has a reference to a vtkMapper2D object which does the rendering.

See also:
vtkProp vtkMapper2D vtkProperty2D
Created by:
  • Turek, Matt
Contributed by (if > 5%):
  • Martin, Ken (38%)
  • Turek, Matt (36%)
  • Schroeder, Will (11%)
  • Biddiscombe, John (6%)
Examples:
vtkActor2D (Examples)
Tests:
vtkActor2D (Tests)

Definition at line 55 of file vtkActor2D.h.

Constructor & Destructor Documentation

vtkActor2D::vtkActor2D ( ) [protected]

vtkActor2D::~vtkActor2D ( ) [protected]

Member Function Documentation

void vtkActor2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

vtkActor2D::vtkTypeRevisionMacro | ( | vtkActor2D | ,
 |  | vtkProp |
 | ) |

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

vtkActor2D* vtkActor2D::New ( ) [static]

Creates an actor2D with the following defaults: position (0,0) (coordinate system is viewport); at layer 0.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

int vtkActor2D::RenderOverlay ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

int vtkActor2D::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

int vtkActor2D::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

virtual void vtkActor2D::SetMapper ( vtkMapper2D * mapper ) [virtual]

Set/Get the vtkMapper2D which defines the data to be drawn.

Reimplemented in vtkScaledTextActor.

virtual vtkMapper2D* vtkActor2D::GetMapper ( void ) [virtual]

Set/Get the vtkMapper2D which defines the data to be drawn.

Reimplemented in vtkScaledTextActor.

virtual void vtkActor2D::SetLayerNumber ( int ) [virtual]

Set/Get the layer number in the overlay planes into which to render.

virtual int vtkActor2D::GetLayerNumber ( ) [virtual]

Set/Get the layer number in the overlay planes into which to render.

vtkProperty2D* vtkActor2D::GetProperty ( )

Returns this actor's vtkProperty2D. Creates a property if one doesn't already exist.

virtual void vtkActor2D::SetProperty ( vtkProperty2D * ) [virtual]

Set this vtkProp's vtkProperty2D.

virtual vtkCoordinate* vtkActor2D::GetPositionCoordinate ( ) [virtual]

Get the PositionCoordinate instance of vtkCoordinate. This is used for for complicated or relative positioning. The position variable controls the lower left corner of the Actor2D

virtual void vtkActor2D::SetPosition ( float x[2] ) [virtual]

Get the PositionCoordinate instance of vtkCoordinate. This is used for for complicated or relative positioning. The position variable controls the lower left corner of the Actor2D

virtual void vtkActor2D::SetPosition | ( | float | x,
 |  | float | y
 | ) | [virtual]

Get the PositionCoordinate instance of vtkCoordinate. This is used for for complicated or relative positioning. The position variable controls the lower left corner of the Actor2D

virtual float* vtkActor2D::GetPosition ( ) [virtual]

Get the PositionCoordinate instance of vtkCoordinate. This is used for for complicated or relative positioning. The position variable controls the lower left corner of the Actor2D

void vtkActor2D::SetDisplayPosition | ( | int | ,
 |  | int |
 | ) |

Set the Prop2D's position in display coordinates.

virtual vtkCoordinate* vtkActor2D::GetPosition2Coordinate ( ) [virtual]

Access the Position2 instance variable. This variable controls the upper right corner of the Actor2D. It is by default relative to Position and in normalized viewport coordinates. Some 2D actor subclasses ignore the position2 variable

virtual void vtkActor2D::SetPosition2 ( float x[2] ) [virtual]

Access the Position2 instance variable. This variable controls the upper right corner of the Actor2D. It is by default relative to Position and in normalized viewport coordinates. Some 2D actor subclasses ignore the position2 variable

virtual void vtkActor2D::SetPosition2 | ( | float | x,
 |  | float | y
 | ) | [virtual]

Access the Position2 instance variable. This variable controls the upper right corner of the Actor2D. It is by default relative to Position and in normalized viewport coordinates. Some 2D actor subclasses ignore the position2 variable

virtual float* vtkActor2D::GetPosition2 ( ) [virtual]

Access the Position2 instance variable. This variable controls the upper right corner of the Actor2D. It is by default relative to Position and in normalized viewport coordinates. Some 2D actor subclasses ignore the position2 variable

void vtkActor2D::SetWidth ( float w )

Set/Get the height and width of the Actor2D. The value is expressed as a fraction of the viewport. This really is just another way of setting the Position2 instance variable.

float vtkActor2D::GetWidth ( )

Set/Get the height and width of the Actor2D. The value is expressed as a fraction of the viewport. This really is just another way of setting the Position2 instance variable.

void vtkActor2D::SetHeight ( float h )

Set/Get the height and width of the Actor2D. The value is expressed as a fraction of the viewport. This really is just another way of setting the Position2 instance variable.

float vtkActor2D::GetHeight ( )

Set/Get the height and width of the Actor2D. The value is expressed as a fraction of the viewport. This really is just another way of setting the Position2 instance variable.

unsigned long vtkActor2D::GetMTime ( ) [virtual]

Return this objects MTime.

Reimplemented from vtkObject.

Reimplemented in vtkXYPlotActor.

virtual void vtkActor2D::GetActors2D ( vtkPropCollection * pc ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented from vtkProp.

void vtkActor2D::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this vtkActor2D. Overloads the virtual vtkProp method.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkLegendBoxActor, vtkAxisActor2D, vtkScalarBarActor, and vtkScaledTextActor.

virtual void vtkActor2D::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

Reimplemented in vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

Member Data Documentation

vtkMapper2D* vtkActor2D::Mapper [protected]

Definition at line 142 of file vtkActor2D.h.

int vtkActor2D::LayerNumber [protected]

Definition at line 143 of file vtkActor2D.h.

vtkProperty2D* vtkActor2D::Property [protected]

Definition at line 144 of file vtkActor2D.h.

vtkCoordinate* vtkActor2D::PositionCoordinate [protected]

Definition at line 145 of file vtkActor2D.h.

vtkCoordinate* vtkActor2D::Position2Coordinate [protected]

Definition at line 146 of file vtkActor2D.h.

The documentation for this class was generated from the following file:
  • Common/vtkActor2D.h
Generated on Mon Mar 25 01:15:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActor2DCollection Class Reference

#include <vtkActor2DCollection.h>

Inheritance diagram for vtkActor2DCollection:

[legend]
Collaboration diagram for vtkActor2DCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkActor2DCollection, vtkPropCollection)
void | Sort ()
void | AddItem (vtkActor2D *a)
void | RenderOverlay (vtkViewport *viewport)
int | IsItemPresent (vtkActor2D *a)
vtkActor2D * GetNextActor2D ()
vtkActor2D * GetLastActor2D ()
vtkActor2D * GetNextItem ()
vtkActor2D * GetLastItem ()

Static Public Methods

vtkActor2DCollection * | New ()

Protected Methods

vtkActor2DCollection ()
~vtkActor2DCollection ()
virtual void | DeleteElement (vtkCollectionElement *)

Detailed Description

Date:
2002/01/22 15:25:09
Revision:
1.27

vtkActor2DCollection is a subclass of vtkCollection. vtkActor2DCollection maintains a collection of vtkActor2D objects that is sorted by layer number, with lower layer numbers at the start of the list. This allows the vtkActor2D objects to be rendered in the correct order.

See also:
vtkActor2D vtkCollection
Created by:
  • Turek, Matt
Contributed by (if > 5%):
  • Turek, Matt (72%)
  • Martin, Ken (12%)
  • Miller, Jim (7%)

Definition at line 45 of file vtkActor2DCollection.h.

Constructor & Destructor Documentation

vtkActor2DCollection::vtkActor2DCollection ( ) [inline, protected]

Definition at line 83 of file vtkActor2DCollection.h.

vtkActor2DCollection::~vtkActor2DCollection ( ) [protected]

Member Function Documentation

vtkActor2DCollection* vtkActor2DCollection::New ( ) [static]

Desctructor for the vtkActor2DCollection class. This removes all objects from the collection.

Reimplemented from vtkPropCollection.

vtkActor2DCollection::vtkTypeRevisionMacro | ( | vtkActor2DCollection | ,
 |  | vtkPropCollection |
 | ) |

Reimplemented from vtkPropCollection.

void vtkActor2DCollection::Sort ( )

Sorts the vtkActor2DCollection by layer number. Smaller layer numbers are first. Layer numbers can be any integer value.

void vtkActor2DCollection::AddItem ( vtkActor2D * a )

Add an actor to the list. The new actor is inserted in the list according to it's layer number.

int vtkActor2DCollection::IsItemPresent ( vtkActor2D * a ) [inline]

Standard Collection methods

Definition at line 99 of file vtkActor2DCollection.h.

vtkActor2D * vtkActor2DCollection::GetNextActor2D ( ) [inline]

Standard Collection methods

Definition at line 104 of file vtkActor2DCollection.h.

Referenced by GetNextItem().

vtkActor2D * vtkActor2DCollection::GetLastActor2D ( ) [inline]

Standard Collection methods

Definition at line 109 of file vtkActor2DCollection.h.

Referenced by GetLastItem().

vtkActor2D * vtkActor2DCollection::GetNextItem ( ) [inline]

Access routines that are provided for compatibility with previous version of VTK. Please use the GetNextActor2D(), GetLastActor2D() variants where possible.

Definition at line 121 of file vtkActor2DCollection.h.

vtkActor2D * vtkActor2DCollection::GetLastItem ( ) [inline]

Access routines that are provided for compatibility with previous version of VTK. Please use the GetNextActor2D(), GetLastActor2D() variants where possible.

Definition at line 126 of file vtkActor2DCollection.h.

void vtkActor2DCollection::RenderOverlay ( vtkViewport * viewport )

Sort and then render the collection of 2D actors.

virtual void vtkActor2DCollection::DeleteElement ( vtkCollectionElement * ) [protected, virtual]

Reimplemented from vtkCollection.

The documentation for this class was generated from the following file:
  • Common/vtkActor2DCollection.h
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkActorCollection Class Reference

a list of actors. More...

#include <vtkActorCollection.h>

Inheritance diagram for vtkActorCollection:

[legend]
Collaboration diagram for vtkActorCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkActorCollection, vtkPropCollection)
void | AddItem (vtkActor *a)
vtkActor * GetNextActor ()
vtkActor * GetLastActor ()
void | ApplyProperties (vtkProperty *p)
vtkActor * GetNextItem ()
vtkActor * GetLastItem ()

Static Public Methods

vtkActorCollection * | New ()

Protected Methods

vtkActorCollection ()
~vtkActorCollection ()

Detailed Description

a list of actors.

Date:
2002/01/22 15:38:28
Revision:
1.42

vtkActorCollection represents and provides methods to manipulate a list of actors (i.e., vtkActor and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkActor vtkCollection
Created by:
  • Hoffman, Bill
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (36%)
  • Schroeder, Will (25%)
  • Miller, Jim (19%)
  • Hoffman, Bill (15%)

Definition at line 47 of file vtkActorCollection.h.

Constructor & Destructor Documentation

vtkActorCollection::vtkActorCollection ( ) [inline, protected]

Definition at line 74 of file vtkActorCollection.h.

vtkActorCollection::~vtkActorCollection ( ) [inline, protected]

Definition at line 75 of file vtkActorCollection.h.

Member Function Documentation

vtkActorCollection* vtkActorCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkPropCollection.

vtkActorCollection::vtkTypeRevisionMacro | ( | vtkActorCollection | ,
 |  | vtkPropCollection |
 | ) |

Reimplemented from vtkPropCollection.

void vtkActorCollection::AddItem ( vtkActor * a ) [inline]

Add an actor to the list.

Definition at line 88 of file vtkActorCollection.h.

vtkActor * vtkActorCollection::GetNextActor ( ) [inline]

Get the next actor in the list.

Definition at line 93 of file vtkActorCollection.h.

Referenced by GetNextItem().

vtkActor * vtkActorCollection::GetLastActor ( ) [inline]

Get the last actor in the list.

Definition at line 98 of file vtkActorCollection.h.

Referenced by GetLastItem().

vtkActor * vtkActorCollection::GetNextItem ( ) [inline]

Access routines that are provided for compatibility with previous version of VTK. Please use the GetNextActor(), GetLastActor() variants where possible.

Definition at line 110 of file vtkActorCollection.h.

vtkActor * vtkActorCollection::GetLastItem ( ) [inline]

Access routines that are provided for compatibility with previous version of VTK. Please use the GetNextActor(), GetLastActor() variants where possible.

Definition at line 115 of file vtkActorCollection.h.

void vtkActorCollection::ApplyProperties ( vtkProperty * p )

Apply properties to all actors in this collection.

The documentation for this class was generated from the following file:
  • Rendering/vtkActorCollection.h
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAppendFilter Class Reference

appends one or more datasets together into a single unstructured grid. More...

#include <vtkAppendFilter.h>

Inheritance diagram for vtkAppendFilter:

[legend]
Collaboration diagram for vtkAppendFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAppendFilter, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddInput (vtkDataSet *in)
void | RemoveInput (vtkDataSet *in)
vtkDataSetCollection * GetInputList ()
vtkDataSet * | GetInput (int idx)
vtkDataSet * GetInput ()

Static Public Methods

vtkAppendFilter * | New ()

Protected Methods

vtkAppendFilter ()
~vtkAppendFilter ()
void | Execute ()

Protected Attributes

vtkDataSetCollection * InputList

Detailed Description

appends one or more datasets together into a single unstructured grid.

Date:
2002/01/22 15:29:00
Revision:
1.43

vtkAppendFilter is a filter that appends one of more datasets into a single unstructured grid. All geometry is extracted and appended, but point attributes (i.e., scalars, vectors, normals, field data, etc.) are extracted and appended only if all datasets have the point attributes available. (For example, if one dataset has scalars but another does not, scalars will not be appended.)

See also:
vtkAppendPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Geveci, Berk (17%)
  • Lorensen, Bill (13%)
  • Miller, Jim (9%)
  • Martin, Ken (7%)
Tests:
vtkAppendFilter (Tests)

Definition at line 52 of file vtkAppendFilter.h.

Constructor & Destructor Documentation

vtkAppendFilter::vtkAppendFilter ( ) [protected]

vtkAppendFilter::~vtkAppendFilter ( ) [protected]

Member Function Documentation

vtkAppendFilter* vtkAppendFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkAppendFilter::vtkTypeRevisionMacro | ( | vtkAppendFilter | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkAppendFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkAppendFilter::AddInput ( vtkDataSet * in )

Add a dataset to the list of data to append.

vtkDataSet* vtkAppendFilter::GetInput ( int idx )

Get any input of this filter.

vtkDataSet* vtkAppendFilter::GetInput ( ) [inline]

Get any input of this filter.

Reimplemented from vtkDataSetToUnstructuredGridFilter.

Definition at line 66 of file vtkAppendFilter.h.

void vtkAppendFilter::RemoveInput ( vtkDataSet * in )

Remove a dataset from the list of data to append.

vtkDataSetCollection* vtkAppendFilter::GetInputList ( )

Returns a copy of the input array. Modifications to this list will not be reflected in the actual inputs.

void vtkAppendFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkDataSetCollection* vtkAppendFilter::InputList [protected]

Definition at line 86 of file vtkAppendFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkAppendFilter.h
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAppendPolyData Class Reference

appends one or more polygonal datasets together. More...

#include <vtkAppendPolyData.h>

Inheritance diagram for vtkAppendPolyData:

[legend]
Collaboration diagram for vtkAppendPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAppendPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddInput (vtkPolyData *)
void | RemoveInput (vtkPolyData *)
void | SetNumberOfInputs (int num)
void | SetInputByNumber (int num, vtkPolyData *input)
virtual void | SetUserManagedInputs (int)
virtual int | GetUserManagedInputs ()
virtual void | UserManagedInputsOn ()
virtual void | UserManagedInputsOff ()
vtkPolyData * | GetInput (int idx)
vtkPolyData * GetInput ()
virtual void | SetParallelStreaming (int)
virtual int | GetParallelStreaming ()
virtual void | ParallelStreamingOn ()
virtual void | ParallelStreamingOff ()

Static Public Methods

vtkAppendPolyData * | New ()

Protected Methods

vtkAppendPolyData ()
~vtkAppendPolyData ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | AppendData (vtkDataArray *dest, vtkDataArray *src, vtkIdType offset)
void | AppendDifferentPoints (vtkDataArray *dest, vtkDataArray *src, vtkIdType offset)
vtkIdType * | AppendCells (vtkIdType *pDest, vtkCellArray *src, vtkIdType offset)

Protected Attributes

int | ParallelStreaming

Detailed Description

appends one or more polygonal datasets together.

Date:
2002/01/22 15:29:01
Revision:
1.53

vtkAppendPolyData is a filter that appends one of more polygonal datasets into a single polygonal dataset. All geometry is extracted and appended, but point and cell attributes (i.e., scalars, vectors, normals) are extracted and appended only if all datasets have the point and/or cell attributes available. (For example, if one dataset has point scalars but another does not, point scalars will not be appended.)

See also:
vtkAppendFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Law, Charles (32%)
  • Schroeder, Will (25%)
  • Biddiscombe, John (14%)
  • Geveci, Berk (9%)
  • Miller, Jim (7%)
Examples:
vtkAppendPolyData (Examples)
Tests:
vtkAppendPolyData (Tests)

Definition at line 55 of file vtkAppendPolyData.h.

Constructor & Destructor Documentation

vtkAppendPolyData::vtkAppendPolyData ( ) [protected]

vtkAppendPolyData::~vtkAppendPolyData ( ) [protected]

Member Function Documentation

vtkAppendPolyData* vtkAppendPolyData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkAppendPolyData::vtkTypeRevisionMacro | ( | vtkAppendPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkAppendPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkAppendPolyData::SetUserManagedInputs ( int ) [virtual]

UserManagedInputs allows the user to set inputs by number instead of using the AddInput/RemoveInput functions. Calls to SetNumberOfInputs/SetInputByNumber should not be mixed with calls to AddInput/RemoveInput. By default, UserManagedInputs is false.

virtual int vtkAppendPolyData::GetUserManagedInputs ( ) [virtual]

UserManagedInputs allows the user to set inputs by number instead of using the AddInput/RemoveInput functions. Calls to SetNumberOfInputs/SetInputByNumber should not be mixed with calls to AddInput/RemoveInput. By default, UserManagedInputs is false.

virtual void vtkAppendPolyData::UserManagedInputsOn ( ) [virtual]

UserManagedInputs allows the user to set inputs by number instead of using the AddInput/RemoveInput functions. Calls to SetNumberOfInputs/SetInputByNumber should not be mixed with calls to AddInput/RemoveInput. By default, UserManagedInputs is false.

virtual void vtkAppendPolyData::UserManagedInputsOff ( ) [virtual]

UserManagedInputs allows the user to set inputs by number instead of using the AddInput/RemoveInput functions. Calls to SetNumberOfInputs/SetInputByNumber should not be mixed with calls to AddInput/RemoveInput. By default, UserManagedInputs is false.

void vtkAppendPolyData::AddInput ( vtkPolyData * )

Add a dataset to the list of data to append. Should not be used when UserManagedInputs is true, use SetInputByNumber instead.

void vtkAppendPolyData::RemoveInput ( vtkPolyData * )

Remove a dataset from the list of data to append. Should not be used when UserManagedInputs is true, use SetInputByNumber (NULL) instead.

vtkPolyData* vtkAppendPolyData::GetInput ( int idx )

Get any input of this filter.

vtkPolyData* vtkAppendPolyData::GetInput ( ) [inline]

Get any input of this filter.

Reimplemented from vtkPolyDataToPolyDataFilter.

Definition at line 84 of file vtkAppendPolyData.h.

void vtkAppendPolyData::SetNumberOfInputs ( int num )

Directly set(allocate) number of inputs, should only be used when UserManagedInputs is true.

Reimplemented from vtkProcessObject.

void vtkAppendPolyData::SetInputByNumber | ( | int | num,
 |  | vtkPolyData * | input
 | ) |

virtual void vtkAppendPolyData::SetParallelStreaming ( int ) [virtual]

ParallelStreaming is for a particular application. It causes this filter to ask for a different piece from each of its inputs. If all the inputs are the same, then the output of this append filter is the whole dataset pieced back together. Duplicate points are create along the seams. The purpose of this feature is to get data parallelism at a course scale. Each of the inputs can be generated in a different process at the same time.

virtual int vtkAppendPolyData::GetParallelStreaming ( ) [virtual]

ParallelStreaming is for a particular application. It causes this filter to ask for a different piece from each of its inputs. If all the inputs are the same, then the output of this append filter is the whole dataset pieced back together. Duplicate points are create along the seams. The purpose of this feature is to get data parallelism at a course scale. Each of the inputs can be generated in a different process at the same time.

virtual void vtkAppendPolyData::ParallelStreamingOn ( ) [virtual]

ParallelStreaming is for a particular application. It causes this filter to ask for a different piece from each of its inputs. If all the inputs are the same, then the output of this append filter is the whole dataset pieced back together. Duplicate points are create along the seams. The purpose of this feature is to get data parallelism at a course scale. Each of the inputs can be generated in a different process at the same time.

virtual void vtkAppendPolyData::ParallelStreamingOff ( ) [virtual]

ParallelStreaming is for a particular application. It causes this filter to ask for a different piece from each of its inputs. If all the inputs are the same, then the output of this append filter is the whole dataset pieced back together. Duplicate points are create along the seams. The purpose of this feature is to get data parallelism at a course scale. Each of the inputs can be generated in a different process at the same time.

void vtkAppendPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkAppendPolyData::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

void vtkAppendPolyData::AppendData | ( | vtkDataArray * | dest,
 |  | vtkDataArray * | src,
 |  | vtkIdType | offset
 | ) | [protected]

void vtkAppendPolyData::AppendDifferentPoints | ( | vtkDataArray * | dest,
 |  | vtkDataArray * | src,
 |  | vtkIdType | offset
 | ) | [protected]

vtkIdType* vtkAppendPolyData::AppendCells | ( | vtkIdType * | pDest,
 |  | vtkCellArray * | src,
 |  | vtkIdType | offset
 | ) | [protected]

Member Data Documentation

int vtkAppendPolyData::ParallelStreaming [protected]

Definition at line 112 of file vtkAppendPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkAppendPolyData.h
Generated on Mon Mar 25 01:15:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkApproximatingSubdivisionFilter Class Reference

generate a subdivision surface using an Approximating Scheme. More...

#include <vtkApproximatingSubdivisionFilter.h>

Inheritance diagram for vtkApproximatingSubdivisionFilter:

[legend]
Collaboration diagram for vtkApproximatingSubdivisionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkApproximatingSubdivisionFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNumberOfSubdivisions (int)
virtual int | GetNumberOfSubdivisions ()

Protected Methods

vtkApproximatingSubdivisionFilter ()
~vtkApproximatingSubdivisionFilter ()
void | Execute ()
virtual void | GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)=0
void | GenerateSubdivisionCells (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD)
int | FindEdge (vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds)
vtkIdType | InterpolatePosition (vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights)

Protected Attributes

int | NumberOfSubdivisions

Detailed Description

generate a subdivision surface using an Approximating Scheme.

Date:
2002/01/22 15:29:01
Revision:
1.13

vtkApproximatingSubdivisionFilter is an abstract class that defines the protocol for Approximating subdivision surface filters.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (68%)
  • Henderson, Amy (9%)
  • Law, Charles (9%)
  • Hoffman, Bill (5%)

Definition at line 43 of file vtkApproximatingSubdivisionFilter.h.

Constructor & Destructor Documentation

vtkApproximatingSubdivisionFilter::vtkApproximatingSubdivisionFilter ( ) [protected]

vtkApproximatingSubdivisionFilter::~vtkApproximatingSubdivisionFilter ( ) [inline, protected]

Definition at line 57 of file vtkApproximatingSubdivisionFilter.h.

Member Function Documentation

vtkApproximatingSubdivisionFilter::vtkTypeRevisionMacro | ( | vtkApproximatingSubdivisionFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

Reimplemented in vtkLoopSubdivisionFilter.

void vtkApproximatingSubdivisionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkApproximatingSubdivisionFilter::SetNumberOfSubdivisions ( int ) [virtual]

Set/get the number of subdivisions.

virtual int vtkApproximatingSubdivisionFilter::GetNumberOfSubdivisions ( ) [virtual]

Set/get the number of subdivisions.

void vtkApproximatingSubdivisionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkApproximatingSubdivisionFilter::GenerateSubdivisionPoints | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkPoints * | outputPts,
 |  | vtkPointData * | outputPD
 | ) | [protected, pure virtual]

Reimplemented in vtkLoopSubdivisionFilter.

void vtkApproximatingSubdivisionFilter::GenerateSubdivisionCells | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkCellArray * | outputPolys,
 |  | vtkCellData * | outputCD
 | ) | [protected]

int vtkApproximatingSubdivisionFilter::FindEdge | ( | vtkPolyData * | mesh,
 |  | vtkIdType | cellId,
 |  | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | vtkIntArray * | edgeData,
 |  | vtkIdList * | cellIds
 | ) | [protected]

vtkIdType vtkApproximatingSubdivisionFilter::InterpolatePosition | ( | vtkPoints * | inputPts,
 |  | vtkPoints * | outputPts,
 |  | vtkIdList * | stencil,
 |  | float * | weights
 | ) | [protected]

Member Data Documentation

int vtkApproximatingSubdivisionFilter::NumberOfSubdivisions [protected]

Definition at line 71 of file vtkApproximatingSubdivisionFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkApproximatingSubdivisionFilter.h
Generated on Mon Mar 25 01:15:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArcPlotter Class Reference

plot data along an arbitrary polyline. More...

#include <vtkArcPlotter.h>

Inheritance diagram for vtkArcPlotter:

[legend]
Collaboration diagram for vtkArcPlotter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkArcPlotter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetCamera (vtkCamera *)
virtual vtkCamera * | GetCamera ()
virtual void | SetPlotMode (int)
virtual int | GetPlotMode ()
void | SetPlotModeToPlotScalars ()
void | SetPlotModeToPlotVectors ()
void | SetPlotModeToPlotNormals ()
void | SetPlotModeToPlotTCoords ()
void | SetPlotModeToPlotTensors ()
void | SetPlotModeToPlotFieldData ()
virtual void | SetPlotComponent (int)
virtual int | GetPlotComponent ()
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetHeight (float)
virtual float | GetHeight ()
virtual void | SetOffset (float)
virtual float | GetOffset ()
virtual void | SetUseDefaultNormal (int)
virtual int | GetUseDefaultNormal ()
virtual void | UseDefaultNormalOn ()
virtual void | UseDefaultNormalOff ()
virtual void | SetDefaultNormal (float, float, float)
virtual void | SetDefaultNormal (float[3])
virtual float * | GetDefaultNormal ()
virtual void | GetDefaultNormal (float data[3])
virtual void | SetFieldDataArray (int)
virtual int | GetFieldDataArray ()

Static Public Methods

vtkArcPlotter * | New ()

Protected Methods

vtkArcPlotter ()
~vtkArcPlotter ()
void | Execute ()
int | OffsetPoint (vtkIdType ptId, vtkPoints *inPts, float n[3], vtkPoints *newPts, float offset, float *range, float val)
int | ProcessComponents (vtkIdType numPts, vtkPointData *pd)

Protected Attributes

vtkCamera * Camera
int | PlotMode
int | PlotComponent
float | Radius
float | Height
float | Offset
float | DefaultNormal [3]
int | UseDefaultNormal
int | FieldDataArray

Detailed Description

plot data along an arbitrary polyline.

Date:
2002/02/27 16:26:50
Revision:
1.9

vtkArcPlotter performs plotting of attribute data along polylines defined with an input vtkPolyData data object. Any type of attribute data can be plotted including scalars, vectors, tensors, normals, texture coordinates, and field data. Either one or multiple data components can be plotted.

To use this class you must specify an input data set that contains one or more polylines, and some attribute data including which component of the attribute data. (By default, this class processes the first component of scalar data.) You will also need to set an offset radius (the distance of the polyline to the median line of the plot), a width for the plot (the distance that the minimum and maximum plot values are mapped into), an possibly an offset (used to offset attribute data with multiple components).

Normally the filter automatically computes normals for generating the offset arc plot. However, you can specify a default normal and use that instead.

See also:
vtkXYPlotActor
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (83%)
  • Geveci, Berk (8%)
Tests:
vtkArcPlotter (Tests)

Definition at line 67 of file vtkArcPlotter.h.

Constructor & Destructor Documentation

vtkArcPlotter::vtkArcPlotter ( ) [protected]

vtkArcPlotter::~vtkArcPlotter ( ) [protected]

Member Function Documentation

vtkArcPlotter* vtkArcPlotter::New ( ) [static]

Instantiate with no default camera and plot mode set to VTK_SCALARS.

Reimplemented from vtkPolyDataSource.

vtkArcPlotter::vtkTypeRevisionMacro | ( | vtkArcPlotter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkArcPlotter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkArcPlotter::SetCamera ( vtkCamera * ) [virtual]

Specify a camera used to orient the plot along the arc. If no camera is specified, then the orientation of the plot is arbitrary.

virtual vtkCamera* vtkArcPlotter::GetCamera ( ) [virtual]

Specify a camera used to orient the plot along the arc. If no camera is specified, then the orientation of the plot is arbitrary.

virtual void vtkArcPlotter::SetPlotMode ( int ) [virtual]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

virtual int vtkArcPlotter::GetPlotMode ( ) [virtual]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

void vtkArcPlotter::SetPlotModeToPlotScalars ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 90 of file vtkArcPlotter.h.

void vtkArcPlotter::SetPlotModeToPlotVectors ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 91 of file vtkArcPlotter.h.

void vtkArcPlotter::SetPlotModeToPlotNormals ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 92 of file vtkArcPlotter.h.

void vtkArcPlotter::SetPlotModeToPlotTCoords ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 93 of file vtkArcPlotter.h.

void vtkArcPlotter::SetPlotModeToPlotTensors ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 94 of file vtkArcPlotter.h.

void vtkArcPlotter::SetPlotModeToPlotFieldData ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetPlotComponent to control which component to plot.

Definition at line 95 of file vtkArcPlotter.h.

virtual void vtkArcPlotter::SetPlotComponent ( int ) [virtual]

Set/Get the component number to plot if the data has more than one component. If the value of the plot component is == (-1), then all the components will be plotted.

virtual int vtkArcPlotter::GetPlotComponent ( ) [virtual]

Set/Get the component number to plot if the data has more than one component. If the value of the plot component is == (-1), then all the components will be plotted.

virtual void vtkArcPlotter::SetRadius ( float ) [virtual]

Set the radius of the "median" value of the first plotted component.

virtual float vtkArcPlotter::GetRadius ( ) [virtual]

Set the radius of the "median" value of the first plotted component.

virtual void vtkArcPlotter::SetHeight ( float ) [virtual]

Set the height of the plot. (The radius combined with the height define the location of the plot relative to the generating polyline.)

virtual float vtkArcPlotter::GetHeight ( ) [virtual]

Set the height of the plot. (The radius combined with the height define the location of the plot relative to the generating polyline.)

virtual void vtkArcPlotter::SetOffset ( float ) [virtual]

Specify an offset that translates each subsequent plot (if there is more than one component plotted) from the defining arc (i.e., polyline).

virtual float vtkArcPlotter::GetOffset ( ) [virtual]

Specify an offset that translates each subsequent plot (if there is more than one component plotted) from the defining arc (i.e., polyline).

virtual void vtkArcPlotter::SetUseDefaultNormal ( int ) [virtual]

Set a boolean to control whether to use default normals. By default, normals are automatically computed from the generating polyline and camera.

virtual int vtkArcPlotter::GetUseDefaultNormal ( ) [virtual]

Set a boolean to control whether to use default normals. By default, normals are automatically computed from the generating polyline and camera.

virtual void vtkArcPlotter::UseDefaultNormalOn ( ) [virtual]

Set a boolean to control whether to use default normals. By default, normals are automatically computed from the generating polyline and camera.

virtual void vtkArcPlotter::UseDefaultNormalOff ( ) [virtual]

Set a boolean to control whether to use default normals. By default, normals are automatically computed from the generating polyline and camera.

virtual void vtkArcPlotter::SetDefaultNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the default normal to use if you do not wish automatic normal calculation. The arc plot will be generated using this normal.

virtual void vtkArcPlotter::SetDefaultNormal ( float [3] ) [virtual]

Set the default normal to use if you do not wish automatic normal calculation. The arc plot will be generated using this normal.

virtual float* vtkArcPlotter::GetDefaultNormal ( ) [virtual]

Set the default normal to use if you do not wish automatic normal calculation. The arc plot will be generated using this normal.

virtual void vtkArcPlotter::GetDefaultNormal ( float data[3] ) [virtual]

Set the default normal to use if you do not wish automatic normal calculation. The arc plot will be generated using this normal.

virtual void vtkArcPlotter::SetFieldDataArray ( int ) [virtual]

Set/Get the field data array to plot. This instance variable is only applicable if field data is plotted.

virtual int vtkArcPlotter::GetFieldDataArray ( ) [virtual]

Set/Get the field data array to plot. This instance variable is only applicable if field data is plotted.

unsigned long vtkArcPlotter::GetMTime ( ) [virtual]

New GetMTime because of camera dependency.

Reimplemented from vtkObject.

void vtkArcPlotter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkArcPlotter::OffsetPoint | ( | vtkIdType | ptId,
 |  | vtkPoints * | inPts,
 |  | float | n[3],
 |  | vtkPoints * | newPts,
 |  | float | offset,
 |  | float * | range,
 |  | float | val
 | ) | [protected]

int vtkArcPlotter::ProcessComponents | ( | vtkIdType | numPts,
 |  | vtkPointData * | pd
 | ) | [protected]

Member Data Documentation

vtkCamera* vtkArcPlotter::Camera [protected]

Definition at line 163 of file vtkArcPlotter.h.

int vtkArcPlotter::PlotMode [protected]

Definition at line 164 of file vtkArcPlotter.h.

int vtkArcPlotter::PlotComponent [protected]

Definition at line 165 of file vtkArcPlotter.h.

float vtkArcPlotter::Radius [protected]

Definition at line 166 of file vtkArcPlotter.h.

float vtkArcPlotter::Height [protected]

Definition at line 167 of file vtkArcPlotter.h.

float vtkArcPlotter::Offset [protected]

Definition at line 168 of file vtkArcPlotter.h.

float vtkArcPlotter::DefaultNormal[3] [protected]

Definition at line 169 of file vtkArcPlotter.h.

int vtkArcPlotter::UseDefaultNormal [protected]

Definition at line 170 of file vtkArcPlotter.h.

int vtkArcPlotter::FieldDataArray [protected]

Definition at line 171 of file vtkArcPlotter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkArcPlotter.h
Generated on Mon Mar 25 01:15:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArrayCalculator Class Reference

perform mathematical operations on data in field data arrays. More...

#include <vtkArrayCalculator.h>

Inheritance diagram for vtkArrayCalculator:

[legend]
Collaboration diagram for vtkArrayCalculator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkArrayCalculator, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RemoveAllVariables ()
void | SetFunction (const char *function)
virtual char * | GetFunction ()
void | AddScalarArrayName (const char *arrayName, int component=0)
void | AddVectorArrayName (const char *arrayName, int component0=0, int component1=1, int component2=2)
void | AddScalarVariable (const char *variableName, const char *arrayName, int component=0)
void | AddVectorVariable (const char *variableName, const char *arrayName, int component0=0, int component1=1, int component2=2)
void | SetResultArrayName (const char *name)
virtual char * | GetResultArrayName ()
virtual void | SetAttributeMode (int)
virtual int | GetAttributeMode ()
void | SetAttributeModeToDefault ()
void | SetAttributeModeToUsePointData ()
void | SetAttributeModeToUseCellData ()
const char * | GetAttributeModeAsString ()
char ** | GetScalarArrayNames ()
char * | GetScalarArrayName (int i)
char ** | GetVectorArrayNames ()
char * | GetVectorArrayName (int i)
char ** | GetScalarVariableNames ()
char * | GetScalarVariableName (int i)
char ** | GetVectorVariableNames ()
char * | GetVectorVariableName (int i)
int * | GetSelectedScalarComponents ()
int | GetSelectedScalarComponent (int i)
int ** | GetSelectedVectorComponents ()
int * | GetSelectedVectorComponents (int i)
virtual int | GetNumberOfScalarArrays ()
virtual int | GetNumberOfVectorArrays ()

Static Public Methods

vtkArrayCalculator * | New ()

Protected Methods

vtkArrayCalculator ()
~vtkArrayCalculator ()
void | Execute ()

Protected Attributes

char * | Function
char * | ResultArrayName
char ** | ScalarArrayNames
char ** | VectorArrayNames
char ** | ScalarVariableNames
char ** | VectorVariableNames
int | NumberOfScalarArrays
int | NumberOfVectorArrays
int | AttributeMode
int * | SelectedScalarComponents
int ** | SelectedVectorComponents
vtkFunctionParser * FunctionParser

Detailed Description

perform mathematical operations on data in field data arrays.

Date:
2002/01/22 15:29:02
Revision:
1.11

vtkArrayCalculator performs operations on vectors or scalars in field data arrays. It uses vtkFunctionParser to do the parsing and to evaluate the function for each entry in the input arrays. The arrays used in a given function must be all in point data or all in cell data. The resulting array will be stored as a field data array. The result array can either be stored in a new array or it can overwrite an existing array.

See also:
vtkFunctionParser
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (92%)
Examples:
vtkArrayCalculator (Examples)
Tests:
vtkArrayCalculator (Tests)

Definition at line 56 of file vtkArrayCalculator.h.

Constructor & Destructor Documentation

vtkArrayCalculator::vtkArrayCalculator ( ) [protected]

vtkArrayCalculator::~vtkArrayCalculator ( ) [protected]

Member Function Documentation

vtkArrayCalculator::vtkTypeRevisionMacro | ( | vtkArrayCalculator | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkArrayCalculator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkArrayCalculator* vtkArrayCalculator::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

void vtkArrayCalculator::SetFunction ( const char * function )

Set/Get the function to be evaluated.

virtual char* vtkArrayCalculator::GetFunction ( ) [virtual]

Set/Get the function to be evaluated.

void vtkArrayCalculator::AddScalarArrayName | ( | const char * | arrayName,
 |  | int | component = 0
 | ) |

Add an array name to the list of arrays used in the function and specify which components of the array to use in evaluating the function. The array name must match the name in the function. Use AddScalarVariable or AddVectorVariable to use a variable name different from the array name.

void vtkArrayCalculator::AddVectorArrayName | ( | const char * | arrayName,
 |  | int | component0 = 0,
 |  | int | component1 = 1,
 |  | int | component2 = 2
 | ) |

Add an array name to the list of arrays used in the function and specify which components of the array to use in evaluating the function. The array name must match the name in the function. Use AddScalarVariable or AddVectorVariable to use a variable name different from the array name.

void vtkArrayCalculator::AddScalarVariable | ( | const char * | variableName,
 |  | const char * | arrayName,
 |  | int | component = 0
 | ) |

Add a variable name, a corresponding array name, and which components of the array to use.

void vtkArrayCalculator::AddVectorVariable | ( | const char * | variableName,
 |  | const char * | arrayName,
 |  | int | component0 = 0,
 |  | int | component1 = 1,
 |  | int | component2 = 2
 | ) |

Add a variable name, a corresponding array name, and which components of the array to use.

void vtkArrayCalculator::SetResultArrayName ( const char * name )

Set the name of the array in which to store the result of evaluating this function. If this is the name of an existing array, that array will be overwritten. Otherwise a new array will be created with the specified name.

virtual char* vtkArrayCalculator::GetResultArrayName ( ) [virtual]

Set the name of the array in which to store the result of evaluating this function. If this is the name of an existing array, that array will be overwritten. Otherwise a new array will be created with the specified name.

virtual void vtkArrayCalculator::SetAttributeMode ( int ) [virtual]

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

virtual int vtkArrayCalculator::GetAttributeMode ( ) [virtual]

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

void vtkArrayCalculator::SetAttributeModeToDefault ( ) [inline]

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 108 of file vtkArrayCalculator.h.

void vtkArrayCalculator::SetAttributeModeToUsePointData ( ) [inline]

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 110 of file vtkArrayCalculator.h.

void vtkArrayCalculator::SetAttributeModeToUseCellData ( ) [inline]

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 112 of file vtkArrayCalculator.h.

const char* vtkArrayCalculator::GetAttributeModeAsString ( )

Control whether the filter operates on point data or cell data. By default (AttributeModeToDefault), the filter uses point data. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

void vtkArrayCalculator::RemoveAllVariables ( )

Remove all the variable names and their associated array names.

char** vtkArrayCalculator::GetScalarArrayNames ( ) [inline]

Methods to get information about the current variables.

Definition at line 122 of file vtkArrayCalculator.h.

char* vtkArrayCalculator::GetScalarArrayName ( int i )

Methods to get information about the current variables.

char** vtkArrayCalculator::GetVectorArrayNames ( ) [inline]

Methods to get information about the current variables.

Definition at line 124 of file vtkArrayCalculator.h.

char* vtkArrayCalculator::GetVectorArrayName ( int i )

Methods to get information about the current variables.

char** vtkArrayCalculator::GetScalarVariableNames ( ) [inline]

Methods to get information about the current variables.

Definition at line 126 of file vtkArrayCalculator.h.

char* vtkArrayCalculator::GetScalarVariableName ( int i )

Methods to get information about the current variables.

char** vtkArrayCalculator::GetVectorVariableNames ( ) [inline]

Methods to get information about the current variables.

Definition at line 128 of file vtkArrayCalculator.h.

char* vtkArrayCalculator::GetVectorVariableName ( int i )

Methods to get information about the current variables.

int* vtkArrayCalculator::GetSelectedScalarComponents ( ) [inline]

Methods to get information about the current variables.

Definition at line 130 of file vtkArrayCalculator.h.

int vtkArrayCalculator::GetSelectedScalarComponent ( int i )

Methods to get information about the current variables.

int** vtkArrayCalculator::GetSelectedVectorComponents ( ) [inline]

Methods to get information about the current variables.

Definition at line 132 of file vtkArrayCalculator.h.

int* vtkArrayCalculator::GetSelectedVectorComponents ( int i )

Methods to get information about the current variables.

virtual int vtkArrayCalculator::GetNumberOfScalarArrays ( ) [virtual]

Methods to get information about the current variables.

virtual int vtkArrayCalculator::GetNumberOfVectorArrays ( ) [virtual]

Methods to get information about the current variables.

void vtkArrayCalculator::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkArrayCalculator::Function [protected]

Definition at line 144 of file vtkArrayCalculator.h.

char* vtkArrayCalculator::ResultArrayName [protected]

Definition at line 145 of file vtkArrayCalculator.h.

char** vtkArrayCalculator::ScalarArrayNames [protected]

Definition at line 146 of file vtkArrayCalculator.h.

char** vtkArrayCalculator::VectorArrayNames [protected]

Definition at line 147 of file vtkArrayCalculator.h.

char** vtkArrayCalculator::ScalarVariableNames [protected]

Definition at line 148 of file vtkArrayCalculator.h.

char** vtkArrayCalculator::VectorVariableNames [protected]

Definition at line 149 of file vtkArrayCalculator.h.

int vtkArrayCalculator::NumberOfScalarArrays [protected]

Definition at line 150 of file vtkArrayCalculator.h.

int vtkArrayCalculator::NumberOfVectorArrays [protected]

Definition at line 151 of file vtkArrayCalculator.h.

int vtkArrayCalculator::AttributeMode [protected]

Definition at line 152 of file vtkArrayCalculator.h.

int* vtkArrayCalculator::SelectedScalarComponents [protected]

Definition at line 153 of file vtkArrayCalculator.h.

int** vtkArrayCalculator::SelectedVectorComponents [protected]

Definition at line 154 of file vtkArrayCalculator.h.

vtkFunctionParser* vtkArrayCalculator::FunctionParser [protected]

Definition at line 155 of file vtkArrayCalculator.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkArrayCalculator.h
Generated on Mon Mar 25 01:15:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkArrowSource Class Reference

Appends a cylinder to a cone to form an arrow. More...

#include <vtkArrowSource.h>

Inheritance diagram for vtkArrowSource:

[legend]
Collaboration diagram for vtkArrowSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkArrowSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetTipLength (float)
virtual float | GetTipLength ()
virtual void | SetTipRadius (float)
virtual float | GetTipRadius ()
virtual void | SetTipResolution (int)
virtual int | GetTipResolution ()
virtual void | SetShaftRadius (float)
virtual float | GetShaftRadius ()
virtual void | SetShaftResolution (int)
virtual int | GetShaftResolution ()

Static Public Methods

vtkArrowSource * | New ()

Protected Methods

vtkArrowSource ()
~vtkArrowSource ()
void | Execute ()

Protected Attributes

int | TipResolution
float | TipLength
float | TipRadius
int | ShaftResolution
float | ShaftRadius

Detailed Description

Appends a cylinder to a cone to form an arrow.

Date:
2002/01/22 15:29:03
Revision:
1.6

vtkArrowSource was intended to be used as the source for a glyph. The shaft base is always at (0,0,0). The arrow tip is always at (1,0,0). The resolution of the cone and shaft can be set and default to 6. The radius of the cone and shaft can be set and default to 0.03 and 0.1. The length of the tip can also be set, and defaults to 0.35.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (95%)
Tests:
vtkArrowSource (Tests)

Definition at line 43 of file vtkArrowSource.h.

Constructor & Destructor Documentation

vtkArrowSource::vtkArrowSource ( ) [protected]

vtkArrowSource::~vtkArrowSource ( ) [inline, protected]

Definition at line 82 of file vtkArrowSource.h.

Member Function Documentation

vtkArrowSource* vtkArrowSource::New ( ) [static]

Construct cone with angle of 45 degrees.

Reimplemented from vtkPolyDataSource.

vtkArrowSource::vtkTypeRevisionMacro | ( | vtkArrowSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkArrowSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkArrowSource::SetTipLength ( float ) [virtual]

Set the length, and radius of the tip. They default to 0.35 and 0.1

virtual float vtkArrowSource::GetTipLength ( ) [virtual]

Set the length, and radius of the tip. They default to 0.35 and 0.1

virtual void vtkArrowSource::SetTipRadius ( float ) [virtual]

Set the length, and radius of the tip. They default to 0.35 and 0.1

virtual float vtkArrowSource::GetTipRadius ( ) [virtual]

Set the length, and radius of the tip. They default to 0.35 and 0.1

virtual void vtkArrowSource::SetTipResolution ( int ) [virtual]

Set the resolution of the tip. The tip behaves the same as a cone. Resoultion 1 gives a single triangle, 2 gives two crossed triangles.

virtual int vtkArrowSource::GetTipResolution ( ) [virtual]

Set the resolution of the tip. The tip behaves the same as a cone. Resoultion 1 gives a single triangle, 2 gives two crossed triangles.

virtual void vtkArrowSource::SetShaftRadius ( float ) [virtual]

Set the radius of the shaft. Defaults to 0.03.

virtual float vtkArrowSource::GetShaftRadius ( ) [virtual]

Set the radius of the shaft. Defaults to 0.03.

virtual void vtkArrowSource::SetShaftResolution ( int ) [virtual]

Set the resolution of the shaft. 2 gives a rectangle. I would like to extend the cone to produce a line, but this is not an option now.

virtual int vtkArrowSource::GetShaftResolution ( ) [virtual]

Set the resolution of the shaft. 2 gives a rectangle. I would like to extend the cone to produce a line, but this is not an option now.

void vtkArrowSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkArrowSource::TipResolution [protected]

Definition at line 86 of file vtkArrowSource.h.

float vtkArrowSource::TipLength [protected]

Definition at line 87 of file vtkArrowSource.h.

float vtkArrowSource::TipRadius [protected]

Definition at line 88 of file vtkArrowSource.h.

int vtkArrowSource::ShaftResolution [protected]

Definition at line 90 of file vtkArrowSource.h.

float vtkArrowSource::ShaftRadius [protected]

Definition at line 91 of file vtkArrowSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkArrowSource.h
Generated on Mon Mar 25 01:15:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssembly Class Reference

create hierarchies of vtkProp3Ds (transformable props). More...

#include <vtkAssembly.h>

Inheritance diagram for vtkAssembly:

[legend]
Collaboration diagram for vtkAssembly:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAssembly, vtkProp3D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddPart (vtkProp3D *)
void | RemovePart (vtkProp3D *)
vtkProp3DCollection * GetParts ()
void | ReleaseGraphicsResources (vtkWindow *)
unsigned long int | GetMTime ()
void | ShallowCopy (vtkProp *prop)
void | BuildPaths (vtkAssemblyPaths *paths, vtkAssemblyPath *path)
void | GetActors (vtkPropCollection *)
void | GetVolumes (vtkPropCollection *)
int | RenderOpaqueGeometry (vtkViewport *ren)
int | RenderTranslucentGeometry (vtkViewport *ren)
void | InitPathTraversal ()
vtkAssemblyPath * GetNextPath ()
int | GetNumberOfPaths ()
void | GetBounds (float bounds[6])
float * | GetBounds ()

Static Public Methods

vtkAssembly * | New ()

Protected Methods

vtkAssembly ()
~vtkAssembly ()
virtual void | UpdatePaths ()

Protected Attributes

vtkProp3DCollection * Parts
vtkTimeStamp PathTime

Detailed Description

create hierarchies of vtkProp3Ds (transformable props).

Date:
2002/01/22 15:38:28
Revision:
1.48

vtkAssembly is an object that groups vtkProp3Ds, its subclasses, and other assemblies into a tree-like hierarchy. The vtkProp3Ds and assemblies can then be transformed together by transforming just the root assembly of the hierarchy.

A vtkAssembly object can be used in place of an vtkProp3D since it is a subclass of vtkProp3D. The difference is that vtkAssembly maintains a list of vtkProp3D instances (its "parts") that form the assembly. Then, any operation that transforms (i.e., scales, rotates, translates) the parent assembly will transform all its parts. Note that this process is recursive: you can create groups consisting of assemblies and/or vtkProp3Ds to arbitrary depth.

To add an assembly to the renderer's list of props, you only need to add the root of the assembly. During rendering, the parts of the assembly are rendered during a hierarchical traversal process.

Warning:
Collections of assemblies are slower to render than an equivalent list of actors. This is because to support arbitrary nesting of assemblies, the state of the assemblies (i.e., transformation matrices) must be propagated through the assembly hierarchy.
Warning:
Assemblies can consist of hierarchies of assemblies, where one actor or assembly used in one hierarchy is also used in other hierarchies. However, make that there are no cycles (e.g., parent->child->parent), this will cause program failure.
Warning:
If you wish to create assemblies without any transformation (using the assembly strictly as a grouping mechanism), then you may wish to consider using vtkPropAssembly.
See also:
vtkActor vtkTransform vtkMapper vtkPolyDataMapper vtkPropAssembly
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (80%)
  • Martin, Ken (6%)
Examples:
vtkAssembly (Examples)
Tests:
vtkAssembly (Tests)

Definition at line 85 of file vtkAssembly.h.

Constructor & Destructor Documentation

vtkAssembly::vtkAssembly ( ) [protected]

vtkAssembly::~vtkAssembly ( ) [protected]

Member Function Documentation

vtkAssembly* vtkAssembly::New ( ) [static]

Creates an instance with visibility=1, pickable=1, and dragable=1.

Reimplemented from vtkProp.

vtkAssembly::vtkTypeRevisionMacro | ( | vtkAssembly | ,
 |  | vtkProp3D |
 | ) |

Reimplemented from vtkProp3D.

void vtkAssembly::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp3D.

void vtkAssembly::AddPart ( vtkProp3D * )

Add a part to the list of parts.

void vtkAssembly::RemovePart ( vtkProp3D * )

Remove a part from the list of parts,

vtkProp3DCollection * vtkAssembly::GetParts ( ) [inline]

Return the parts (direct descendants) of this assembly.

Definition at line 180 of file vtkAssembly.h.

void vtkAssembly::GetActors ( vtkPropCollection * ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented from vtkProp.

void vtkAssembly::GetVolumes ( vtkPropCollection * vc ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented from vtkProp.

int vtkAssembly::RenderOpaqueGeometry ( vtkViewport * ren ) [virtual]

Render this assembly and all its parts. The rendering process is recursive. Note that a mapper need not be defined. If not defined, then no geometry will be drawn for this assembly. This allows you to create "logical" assemblies; that is, assemblies that only serve to group and transform its parts.

Reimplemented from vtkProp.

int vtkAssembly::RenderTranslucentGeometry ( vtkViewport * ren ) [virtual]

Render this assembly and all its parts. The rendering process is recursive. Note that a mapper need not be defined. If not defined, then no geometry will be drawn for this assembly. This allows you to create "logical" assemblies; that is, assemblies that only serve to group and transform its parts.

Reimplemented from vtkProp.

void vtkAssembly::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

void vtkAssembly::InitPathTraversal ( ) [virtual]

Methods to traverse the parts of an assembly. Each part (starting from the root) will appear properly transformed and with the correct properties (depending upon the ApplyProperty and ApplyTransform ivars). Note that the part appears as an instance of vtkProp. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily with the correct transformation or properties. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented from vtkProp3D.

vtkAssemblyPath* vtkAssembly::GetNextPath ( ) [virtual]

Methods to traverse the parts of an assembly. Each part (starting from the root) will appear properly transformed and with the correct properties (depending upon the ApplyProperty and ApplyTransform ivars). Note that the part appears as an instance of vtkProp. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily with the correct transformation or properties. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented from vtkProp.

int vtkAssembly::GetNumberOfPaths ( ) [virtual]

Methods to traverse the parts of an assembly. Each part (starting from the root) will appear properly transformed and with the correct properties (depending upon the ApplyProperty and ApplyTransform ivars). Note that the part appears as an instance of vtkProp. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily with the correct transformation or properties. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented from vtkProp.

void vtkAssembly::GetBounds ( float bounds[6] ) [inline]

Get the bounds for the assembly as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax).

Reimplemented from vtkProp3D.

Definition at line 143 of file vtkAssembly.h.

float* vtkAssembly::GetBounds ( ) [virtual]

Get the bounds for the assembly as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax).

Reimplemented from vtkProp3D.

unsigned long int vtkAssembly::GetMTime ( ) [virtual]

Override default GetMTime method to also consider all of the assembly's parts.

Reimplemented from vtkObject.

void vtkAssembly::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of an assembly. Overloads the virtual vtkProp method.

Reimplemented from vtkProp3D.

void vtkAssembly::BuildPaths | ( | vtkAssemblyPaths * | paths,
 |  | vtkAssemblyPath * | path
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Overload the superclass' vtkProp BuildPaths() method. Paths consist of an ordered sequence of actors, with transformations properly concatenated.

Reimplemented from vtkProp.

virtual void vtkAssembly::UpdatePaths ( ) [protected, virtual]

Member Data Documentation

vtkProp3DCollection* vtkAssembly::Parts [protected]

Definition at line 167 of file vtkAssembly.h.

vtkTimeStamp vtkAssembly::PathTime [protected]

Definition at line 171 of file vtkAssembly.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkAssembly.h
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyNode Class Reference

represent a node in an assembly. More...

#include <vtkAssemblyNode.h>

Inheritance diagram for vtkAssemblyNode:

[legend]
Collaboration diagram for vtkAssemblyNode:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAssemblyNode, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual unsigned long | GetMTime ()
void | SetProp (vtkProp *prop)
virtual vtkProp * | GetProp ()
void | SetMatrix (vtkMatrix4x4 *matrix)
virtual vtkMatrix4x4 * | GetMatrix ()

Static Public Methods

vtkAssemblyNode * | New ()

Protected Methods

vtkAssemblyNode ()
~vtkAssemblyNode ()
vtkAssemblyNode (const vtkAssemblyNode &)

Detailed Description

represent a node in an assembly.

Date:
2002/01/22 15:25:10
Revision:
1.9

vtkAssemblyNode represents a node in an assembly. It is used by vtkAssemblyPath to create hierarchical assemblies of props. The props can be either 2D or 3D.

An assembly node refers to a vtkProp, and possibly a vtkMatrix4x4. Nodes are used by vtkAssemblyPath to build fully evaluated path (matrices are concatenated through the path) that is used by picking and other operations involving assemblies.

Warning:
The assembly node is guaranteed to contain a reference to an instance of vtkMatrix4x4 if the prop referred to by the node is of type vtkProp3D (or subclass). The matrix is evaluated through the assembly path, so the assembly node's matrix is a function of its location in the vtkAssemblyPath.
Warning:
vtkAssemblyNode does not reference count its association with vtkProp. Therefore, do not create an assembly node, associate a prop with it, delete the prop, and then try to dereference the prop. The program will break! (Reason: vtkAssemblyPath (which uses vtkAssemblyNode) create self-referencing loops that destroy reference counting.)
See also:
vtkAssemblyPath vtkProp vtkPicker vtkMatrix4x4
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (85%)
  • Martin, Ken (12%)

Definition at line 63 of file vtkAssemblyNode.h.

Constructor & Destructor Documentation

vtkAssemblyNode::vtkAssemblyNode ( ) [protected]

vtkAssemblyNode::~vtkAssemblyNode ( ) [protected]

vtkAssemblyNode::vtkAssemblyNode ( const vtkAssemblyNode & ) [protected]

Member Function Documentation

vtkAssemblyNode* vtkAssemblyNode::New ( ) [static]

Create an assembly node.

Reimplemented from vtkObject.

vtkAssemblyNode::vtkTypeRevisionMacro | ( | vtkAssemblyNode | ,
 |  | vtkObject |
 | ) |

void vtkAssemblyNode::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkAssemblyNode::SetProp ( vtkProp * prop )

Set/Get the prop that this assembly node refers to.

virtual vtkProp* vtkAssemblyNode::GetProp ( ) [virtual]

Set/Get the prop that this assembly node refers to.

void vtkAssemblyNode::SetMatrix ( vtkMatrix4x4 * matrix )

Specify a transformation matrix associated with the prop. Note: if the prop is not a type of vtkProp3D, then the transformation matrix is ignored (and expected to be NULL). Also, internal to this object the matrix is copied because the matrix is used for computation by vtkAssemblyPath.

virtual vtkMatrix4x4* vtkAssemblyNode::GetMatrix ( ) [virtual]

Specify a transformation matrix associated with the prop. Note: if the prop is not a type of vtkProp3D, then the transformation matrix is ignored (and expected to be NULL). Also, internal to this object the matrix is copied because the matrix is used for computation by vtkAssemblyPath.

virtual unsigned long vtkAssemblyNode::GetMTime ( ) [virtual]

Override the standard GetMTime() to check for the modified times of the prop and matrix.

Reimplemented from vtkObject.

The documentation for this class was generated from the following file:
  • Common/vtkAssemblyNode.h
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyPath Class Reference

a list of nodes that form an assembly path. More...

#include <vtkAssemblyPath.h>

Inheritance diagram for vtkAssemblyPath:

[legend]
Collaboration diagram for vtkAssemblyPath:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAssemblyPath, vtkCollection)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddNode (vtkProp *p, vtkMatrix4x4 *m)
vtkAssemblyNode * GetNextNode ()
vtkAssemblyNode * GetFirstNode ()
vtkAssemblyNode * GetLastNode ()
void | DeleteLastNode ()
void | ShallowCopy (vtkAssemblyPath *path)
virtual unsigned long | GetMTime ()

Static Public Methods

vtkAssemblyPath * | New ()

Protected Methods

vtkAssemblyPath ()
~vtkAssemblyPath ()
void | AddNode (vtkAssemblyNode *n)

Protected Attributes

vtkTransform * Transform
vtkProp * TransformedProp

Detailed Description

a list of nodes that form an assembly path.

Date:
2002/01/22 15:25:10
Revision:
1.8

vtkAssemblyPath represents an ordered list of assembly nodes that represent a fully evaluated assembly path. This class is used primarily for picking. Note that the use of this class is to add one or more assembly nodes to form the path. (An assembly node consists of an instance of vtkProp and vtkMatrix4x4, the matrix may be NULL.) As each node is added, the matrices are concatenated to create a final, evaluated matrix.

See also:
vtkAssemblyNode vtkAssembly vtkActor vtkMatrix4x4 vtkProp vtkAbstractPicker
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (95%)

Definition at line 49 of file vtkAssemblyPath.h.

Constructor & Destructor Documentation

vtkAssemblyPath::vtkAssemblyPath ( ) [protected]

vtkAssemblyPath::~vtkAssemblyPath ( ) [protected]

Member Function Documentation

vtkAssemblyPath::vtkTypeRevisionMacro | ( | vtkAssemblyPath | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkAssemblyPath::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCollection.

vtkAssemblyPath* vtkAssemblyPath::New ( ) [static]

Instantiate empty path with identify matrix.

Reimplemented from vtkCollection.

void vtkAssemblyPath::AddNode | ( | vtkProp * | p,
 |  | vtkMatrix4x4 * | m
 | ) |

Convenience method adds a prop and matrix together, creating an assembly node transparently. The matrix pointer m may be NULL. Note: that matrix is the one, if any, associated with the prop.

vtkAssemblyNode* vtkAssemblyPath::GetNextNode ( )

Get the next assembly node in the list. The node returned contains a pointer to a prop and a 4x4 matrix. The matrix is evaluated based on the preceding assembly hierarchy (i.e., the matrix is not necessarily as the same as the one that was added with AddNode() because of the concatenation of matrices in the assembly hierarchy).

vtkAssemblyNode* vtkAssemblyPath::GetFirstNode ( )

Get the first assembly node in the list. See the comments for GetNextNode() regarding the contents of the returned node. (Note: This node corresponds to the vtkProp associated with the vtkRenderer.

vtkAssemblyNode* vtkAssemblyPath::GetLastNode ( )

Get the last assembly node in the list. See the comments for GetNextNode() regarding the contents of the returned node.

void vtkAssemblyPath::DeleteLastNode ( )

Delete the last assembly node in the list. This is like a stack pop.

void vtkAssemblyPath::ShallowCopy ( vtkAssemblyPath * path )

Perform a shallow copy (reference counted) on the incoming path.

virtual unsigned long vtkAssemblyPath::GetMTime ( ) [virtual]

Override the standard GetMTime() to check for the modified times of the nodes in this path.

Reimplemented from vtkObject.

void vtkAssemblyPath::AddNode ( vtkAssemblyNode * n ) [protected]

Member Data Documentation

vtkTransform* vtkAssemblyPath::Transform [protected]

Definition at line 94 of file vtkAssemblyPath.h.

vtkProp* vtkAssemblyPath::TransformedProp [protected]

Definition at line 95 of file vtkAssemblyPath.h.

The documentation for this class was generated from the following file:
  • Common/vtkAssemblyPath.h
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssemblyPaths Class Reference

a list of lists of props representing an assembly hierarchy. More...

#include <vtkAssemblyPaths.h>

Inheritance diagram for vtkAssemblyPaths:

[legend]
Collaboration diagram for vtkAssemblyPaths:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAssemblyPaths, vtkCollection)
void | AddItem (vtkAssemblyPath *p)
void | RemoveItem (vtkAssemblyPath *p)
int | IsItemPresent (vtkAssemblyPath *p)
vtkAssemblyPath * GetNextItem ()
virtual unsigned long | GetMTime ()

Static Public Methods

vtkAssemblyPaths * | New ()

Protected Methods

vtkAssemblyPaths ()
~vtkAssemblyPaths ()

Detailed Description

a list of lists of props representing an assembly hierarchy.

Date:
2002/01/22 15:25:10
Revision:
1.9

vtkAssemblyPaths represents an assembly hierarchy as a list of vtkAssemblyPath. Each path represents the complete path from the top level assembly (if any) down to the leaf prop.

See also:
vtkAssemblyPath vtkAssemblyNode vtkPicker vtkAssembly vtkProp
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)
  • Martin, Ken (5%)

Definition at line 45 of file vtkAssemblyPaths.h.

Constructor & Destructor Documentation

vtkAssemblyPaths::vtkAssemblyPaths ( ) [inline, protected]

Definition at line 69 of file vtkAssemblyPaths.h.

vtkAssemblyPaths::~vtkAssemblyPaths ( ) [inline, protected]

Definition at line 70 of file vtkAssemblyPaths.h.

Member Function Documentation

vtkAssemblyPaths* vtkAssemblyPaths::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkAssemblyPaths::vtkTypeRevisionMacro | ( | vtkAssemblyPaths | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkAssemblyPaths::AddItem ( vtkAssemblyPath * p ) [inline]

Add a path to the list.

Definition at line 84 of file vtkAssemblyPaths.h.

void vtkAssemblyPaths::RemoveItem ( vtkAssemblyPath * p ) [inline]

Remove a path from the list.

Definition at line 89 of file vtkAssemblyPaths.h.

int vtkAssemblyPaths::IsItemPresent ( vtkAssemblyPath * p ) [inline]

Determine whether a particular path is present. Returns its position in the list.

Definition at line 94 of file vtkAssemblyPaths.h.

vtkAssemblyPath * vtkAssemblyPaths::GetNextItem ( ) [inline]

Get the next path in the list.

Definition at line 99 of file vtkAssemblyPaths.h.

virtual unsigned long vtkAssemblyPaths::GetMTime ( ) [virtual]

Override the standard GetMTime() to check for the modified times of the paths.

Reimplemented from vtkObject.

The documentation for this class was generated from the following file:
  • Common/vtkAssemblyPaths.h
Generated on Mon Mar 25 01:15:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAssignAttribute Class Reference

Labels a field as an attribute. More...

#include <vtkAssignAttribute.h>

Inheritance diagram for vtkAssignAttribute:

[legend]
Collaboration diagram for vtkAssignAttribute:

[legend]
List of all members.

Public Types

enum | AttributeLocation { POINT_DATA = 0, CELL_DATA = 1 }

Public Methods

vtkTypeRevisionMacro (vtkAssignAttribute, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Assign (int inputAttributeType, int attributeType, int attributeLoc)
void | Assign (const char *fieldName, int attributeType, int attributeLoc)
void | Assign (const char *name, const char *attributeType, const char *attributeLoc)

Static Public Methods

vtkAssignAttribute * | New ()

Protected Types

enum | FieldType { NAME, ATTRIBUTE }

Protected Methods

vtkAssignAttribute ()
virtual | ~vtkAssignAttribute ()
void | Execute ()

Protected Attributes

char * | FieldName
int | FieldType
int | AttributeType
int | InputAttributeType
int | AttributeLocation

Static Protected Attributes

char | AttributeLocationNames [2][12]
char | AttributeNames [vtkDataSetAttributes::NUM_ATTRIBUTES][10]

Detailed Description

Labels a field as an attribute.

Date:
2002/01/22 15:29:04
Revision:
1.6

vtkAssignAttribute is use to label a field (vtkDataArray) as an attribute. A field name or an attribute to labeled can be specified. For example:

 aa->Assign("foo", vtkDataSetAttributes::SCALARS,
            vtkAttributeLocation::POINT_DATA);
tells vtkAssignAttribute to make the array in the point data called "foo" the active scalars. On the other hand,
 aa->Assign(vtkDataSetAttributes::VECTORS, vtkDataSetAttributes::SCALARS,
            vtkAttributeLocation::POINT_DATA);
tells vtkAssignAttribute to make the active vectors also the active scalars. The same can be done more easily from Tcl by using the Assign() method which takes strings:
 aa Assign "foo" SCALARS POINT_DATA
 or
 aa Assign SCALARS VECTORS POINT_DATA

 AttributeTypes: SCALARS, VECTORS, NORMALS, TCOORDS, TENSORS
 Attribute locations: POINT_DATA, CELL_DATA

Warning:
When using Tcl, Java, Python or Visual Basic bindings, the array name can not be one of the AttributeTypes when calling Assign() which takes strings as arguments. The Tcl (Java etc.) command will always assume the string corresponds to an attribute type when the argument is one of the AttributeTypes. In this situation, use the Assign() which takes enums.
See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray vtkRearrangeFields vtkSplitField vtkMergeFields
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (97%)
Examples:
vtkAssignAttribute (Examples)
Tests:
vtkAssignAttribute (Tests)

Definition at line 79 of file vtkAssignAttribute.h.

Member Enumeration Documentation

enum vtkAssignAttribute::AttributeLocation

Enumeration values:
POINT_DATA
CELL_DATA

Definition at line 103 of file vtkAssignAttribute.h.

enum vtkAssignAttribute::FieldType [protected]

Enumeration values:
NAME
ATTRIBUTE

Definition at line 113 of file vtkAssignAttribute.h.

Constructor & Destructor Documentation

vtkAssignAttribute::vtkAssignAttribute ( ) [protected]

virtual vtkAssignAttribute::~vtkAssignAttribute ( ) [protected, virtual]

Member Function Documentation

vtkAssignAttribute::vtkTypeRevisionMacro | ( | vtkAssignAttribute | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkAssignAttribute::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkAssignAttribute* vtkAssignAttribute::New ( ) [static]

Create a new vtkAssignAttribute.

Reimplemented from vtkDataSetSource.

void vtkAssignAttribute::Assign | ( | int | inputAttributeType,
 |  | int | attributeType,
 |  | int | attributeLoc
 | ) |

Label an attribute as another attribute.

void vtkAssignAttribute::Assign | ( | const char * | fieldName,
 |  | int | attributeType,
 |  | int | attributeLoc
 | ) |

Label an array as an attribute.

void vtkAssignAttribute::Assign | ( | const char * | name,
 |  | const char * | attributeType,
 |  | const char * | attributeLoc
 | ) |

Helper method used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

void vtkAssignAttribute::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkAssignAttribute::FieldName [protected]

Definition at line 125 of file vtkAssignAttribute.h.

int vtkAssignAttribute::FieldType [protected]

Definition at line 126 of file vtkAssignAttribute.h.

int vtkAssignAttribute::AttributeType [protected]

Definition at line 127 of file vtkAssignAttribute.h.

int vtkAssignAttribute::InputAttributeType [protected]

Definition at line 128 of file vtkAssignAttribute.h.

int vtkAssignAttribute::AttributeLocation [protected]

Definition at line 129 of file vtkAssignAttribute.h.

char vtkAssignAttribute::AttributeLocationNames[2][12] [static, protected]

Definition at line 131 of file vtkAssignAttribute.h.

char vtkAssignAttribute::AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10] [static, protected]

Definition at line 132 of file vtkAssignAttribute.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkAssignAttribute.h
Generated on Mon Mar 25 01:15:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAttributeDataToFieldDataFilter Class Reference

map attribute data to field data. More...

#include <vtkAttributeDataToFieldDataFilter.h>

Inheritance diagram for vtkAttributeDataToFieldDataFilter:

[legend]
Collaboration diagram for vtkAttributeDataToFieldDataFilter:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkAttributeDataToFieldDataFilter, vtkDataSetToDataSetFilter)
virtual void | SetPassAttributeData (int)
virtual int | GetPassAttributeData ()
virtual void | PassAttributeDataOn ()
virtual void | PassAttributeDataOff ()

Static Public Methods

vtkAttributeDataToFieldDataFilter * | New ()

Protected Methods

vtkAttributeDataToFieldDataFilter ()
~vtkAttributeDataToFieldDataFilter ()
void | Execute ()

Protected Attributes

int | PassAttributeData

Detailed Description

map attribute data to field data.

Date:
2002/01/22 15:29:05
Revision:
1.16

vtkAttributeDataToFieldDataFilter is a class that maps attribute data into field data. Since this filter is a subclass of vtkDataSetToDataSetFilter, the output dataset (whose structure is the same as the input dataset), will contain the field data that is generated. The filter will convert point and cell attribute data to field data and assign it as point and cell field data, replacing any point or field data that was there previously. By default, the original non-field point and cell attribute data will be passed to the output of the filter, although you can shut this behavior down.

Warning:
Reference counting the underlying data arrays is used to create the field data. Therefore, no extra memory is utilized.
Warning:
The original field data (if any) associated with the point and cell attribute data is placed into the generated fields along with the scalars, vectors, etc.
See also:
vtkFieldData vtkDataObject vtkDataSet vtkFieldDataToAttributeDataFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Geveci, Berk (25%)
  • Henderson, Amy (5%)

Definition at line 58 of file vtkAttributeDataToFieldDataFilter.h.

Constructor & Destructor Documentation

vtkAttributeDataToFieldDataFilter::vtkAttributeDataToFieldDataFilter ( ) [protected]

vtkAttributeDataToFieldDataFilter::~vtkAttributeDataToFieldDataFilter ( ) [inline, protected]

Definition at line 77 of file vtkAttributeDataToFieldDataFilter.h.

Member Function Documentation

void vtkAttributeDataToFieldDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkAttributeDataToFieldDataFilter::vtkTypeRevisionMacro | ( | vtkAttributeDataToFieldDataFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

vtkAttributeDataToFieldDataFilter* vtkAttributeDataToFieldDataFilter::New ( ) [static]

Construct this object.

Reimplemented from vtkDataSetSource.

virtual void vtkAttributeDataToFieldDataFilter::SetPassAttributeData ( int ) [virtual]

Turn on/off the passing of point and cell non-field attribute data to the output of the filter.

virtual int vtkAttributeDataToFieldDataFilter::GetPassAttributeData ( ) [virtual]

Turn on/off the passing of point and cell non-field attribute data to the output of the filter.

virtual void vtkAttributeDataToFieldDataFilter::PassAttributeDataOn ( ) [virtual]

Turn on/off the passing of point and cell non-field attribute data to the output of the filter.

virtual void vtkAttributeDataToFieldDataFilter::PassAttributeDataOff ( ) [virtual]

Turn on/off the passing of point and cell non-field attribute data to the output of the filter.

void vtkAttributeDataToFieldDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkAttributeDataToFieldDataFilter::PassAttributeData [protected]

Definition at line 81 of file vtkAttributeDataToFieldDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkAttributeDataToFieldDataFilter.h
Generated on Mon Mar 25 01:15:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAxes Class Reference

create an x-y-z axes. More...

#include <vtkAxes.h>

Inheritance diagram for vtkAxes:

[legend]
Collaboration diagram for vtkAxes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAxes, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetSymmetric (int)
virtual int | GetSymmetric ()
virtual void | SymmetricOn ()
virtual void | SymmetricOff ()
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()

Static Public Methods

vtkAxes * | New ()

Protected Methods

vtkAxes ()
~vtkAxes ()
void | Execute ()
int | ComputeDivisionExtents (vtkDataObject *output, int idx, int numDivisions)

Protected Attributes

float | Origin [3]
float | ScaleFactor
int | Symmetric
int | ComputeNormals

Detailed Description

create an x-y-z axes.

Date:
2002/01/22 15:29:06
Revision:
1.39

vtkAxes creates three lines that form an x-y-z axes. The origin of the axes is user specified (0,0,0 is default), and the size is specified with a scale factor. Three scalar values are generated for the three lines and can be used (via color map) to indicate a particular coordinate axis.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (55%)
  • Law, Charles (23%)
  • Martin, Ken (9%)
  • Geveci, Berk (6%)
Examples:
vtkAxes (Examples)
Tests:
vtkAxes (Tests)

Definition at line 48 of file vtkAxes.h.

Constructor & Destructor Documentation

vtkAxes::vtkAxes ( ) [protected]

vtkAxes::~vtkAxes ( ) [inline, protected]

Definition at line 84 of file vtkAxes.h.

Member Function Documentation

vtkAxes* vtkAxes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkAxes::vtkTypeRevisionMacro | ( | vtkAxes | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkAxes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkAxes::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the origin of the axes.

virtual void vtkAxes::SetOrigin ( float [3] ) [virtual]

Set the origin of the axes.

virtual float* vtkAxes::GetOrigin ( ) [virtual]

Set the origin of the axes.

virtual void vtkAxes::GetOrigin ( float data[3] ) [virtual]

Set the origin of the axes.

virtual void vtkAxes::SetScaleFactor ( float ) [virtual]

Set the scale factor of the axes. Used to control size.

virtual float vtkAxes::GetScaleFactor ( ) [virtual]

Set the scale factor of the axes. Used to control size.

virtual void vtkAxes::SetSymmetric ( int ) [virtual]

If Symetric is on, the the axis continue to negative values.

virtual int vtkAxes::GetSymmetric ( ) [virtual]

If Symetric is on, the the axis continue to negative values.

virtual void vtkAxes::SymmetricOn ( ) [virtual]

If Symetric is on, the the axis continue to negative values.

virtual void vtkAxes::SymmetricOff ( ) [virtual]

If Symetric is on, the the axis continue to negative values.

virtual void vtkAxes::SetComputeNormals ( int ) [virtual]

Option for computing normals. By default they are computed.

virtual int vtkAxes::GetComputeNormals ( ) [virtual]

Option for computing normals. By default they are computed.

virtual void vtkAxes::ComputeNormalsOn ( ) [virtual]

Option for computing normals. By default they are computed.

virtual void vtkAxes::ComputeNormalsOff ( ) [virtual]

Option for computing normals. By default they are computed.

void vtkAxes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkAxes::ComputeDivisionExtents | ( | vtkDataObject * | output,
 |  | int | idx,
 |  | int | numDivisions
 | ) | [protected]

Member Data Documentation

float vtkAxes::Origin[3] [protected]

Definition at line 91 of file vtkAxes.h.

float vtkAxes::ScaleFactor [protected]

Definition at line 92 of file vtkAxes.h.

int vtkAxes::Symmetric [protected]

Definition at line 94 of file vtkAxes.h.

int vtkAxes::ComputeNormals [protected]

Definition at line 95 of file vtkAxes.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkAxes.h
Generated on Mon Mar 25 01:15:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkAxisActor2D Class Reference

Create an axis with tick marks and labels. More...

#include <vtkAxisActor2D.h>

Inheritance diagram for vtkAxisActor2D:

[legend]
Collaboration diagram for vtkAxisActor2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkAxisActor2D, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ReleaseGraphicsResources (vtkWindow *)
void | ShallowCopy (vtkProp *prop)
virtual vtkCoordinate * | GetPoint1Coordinate ()
virtual void | SetPoint1 (float x[2])
virtual void | SetPoint1 (float x, float y)
virtual float * | GetPoint1 ()
virtual vtkCoordinate * | GetPoint2Coordinate ()
virtual void | SetPoint2 (float x[2])
virtual void | SetPoint2 (float x, float y)
virtual float * | GetPoint2 ()
virtual void | SetRange (float, float)
void | SetRange (float[2])
virtual float * | GetRange ()
virtual void | GetRange (float data[2])
virtual void | SetNumberOfLabels (int)
virtual int | GetNumberOfLabels ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
virtual void | SetAdjustLabels (int)
virtual int | GetAdjustLabels ()
virtual void | AdjustLabelsOn ()
virtual void | AdjustLabelsOff ()
virtual void | SetTitle (const char *)
virtual char * | GetTitle ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetTickLength (int)
virtual int | GetTickLength ()
virtual void | SetTickOffset (int)
virtual int | GetTickOffset ()
virtual void | SetAxisVisibility (int)
virtual int | GetAxisVisibility ()
virtual void | AxisVisibilityOn ()
virtual void | AxisVisibilityOff ()
virtual void | SetTickVisibility (int)
virtual int | GetTickVisibility ()
virtual void | TickVisibilityOn ()
virtual void | TickVisibilityOff ()
virtual void | SetLabelVisibility (int)
virtual int | GetLabelVisibility ()
virtual void | LabelVisibilityOn ()
virtual void | LabelVisibilityOff ()
virtual void | SetTitleVisibility (int)
virtual int | GetTitleVisibility ()
virtual void | TitleVisibilityOn ()
virtual void | TitleVisibilityOff ()
virtual void | SetFontFactor (float)
virtual float | GetFontFactor ()
virtual void | SetLabelFactor (float)
virtual float | GetLabelFactor ()
int | RenderOverlay (vtkViewport *viewport)
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *)

Static Public Methods

vtkAxisActor2D * | New ()
void | ComputeRange (float inRange[2], float outRange[2], int inNumTicks, int &outNumTicks, float &interval)
int | SetFontSize (vtkViewport *viewport, vtkTextMapper *textMapper, int *size, float factor, int &stringWidth, int &stringHeight)

Protected Methods

vtkAxisActor2D ()
~vtkAxisActor2D ()
virtual void | BuildAxis (vtkViewport *viewport)

Static Protected Methods

float | ComputeStringOffset (float width, float height, float theta)
void | SetOffsetPosition (float xTick[3], float theta, int stringHeight, int stringWidth, int offset, vtkActor2D *actor)

Protected Attributes

vtkCoordinate * Point1Coordinate
vtkCoordinate * Point2Coordinate
char * | Title
float | Range [2]
int | NumberOfLabels
char * | LabelFormat
int | NumberOfLabelsBuilt
int | AdjustLabels
float | FontFactor
float | LabelFactor
int | TickLength
int | TickOffset
int | Bold
int | Italic
int | Shadow
int | FontFamily
int | AxisVisibility
int | TickVisibility
int | LabelVisibility
int | TitleVisibility
int | LastPoint1 [2]
int | LastPoint2 [2]
int | LastSize [2]
int | LastTitleFontSize
int | LastLabelFontSize
vtkTextMapper * TitleMapper
vtkActor2D * TitleActor
vtkTextMapper ** LabelMappers
vtkActor2D ** LabelActors
vtkPolyData * Axis
vtkPolyDataMapper2D * AxisMapper
vtkActor2D * AxisActor
vtkTimeStamp BuildTime

Detailed Description

Create an axis with tick marks and labels.

Date:
2002/03/03 14:18:39
Revision:
1.23

vtkAxisActor2D creates an axis with tick marks, labels, and/or a title, depending on the particular instance variable settings. vtkAxisActor2D is a 2D actor; that is, it is drawn on the overlay plane and is not occluded by 3D geometry. To use this class, you typically specify two points defining the start and end points of the line (x-y definition using vtkCoordinate class), the number of labels, and the data range (min,max). You can also control what parts of the axis are visible including the line, the tick marks, the labels, and the title. It is also possible to control the font family, the font style (bold and/or italic), and whether font shadows are drawn. You can also specify the label format (a printf style format).

This class decides what font size to use and how to locate the labels. It also decides how to create reasonable tick marks and labels. The number of labels and the range of values may not match the number specified, but should be close.

Labels are drawn on the "right" side of the axis. The "right" side is the side of the axis on the right as you move from Point1 to Point2. The way the labels and title line up with the axis and tick marks depends on whether the line is considered horizontal or vertical.

The instance variables Point1 and Point2 are instances of vtkCoordinate. What this means is that you can specify the axis in a variety of coordinate systems. Also, the axis does not have to be either horizontal or vertical. The tick marks are created so that they are perpendicular to the axis.

See also:
vtkAxisActor3D can be used to create axes in world coordinate space. vtkActor2D vtkTextMapper vtkPolyDataMapper2D vtkScalarBarActor vtkCoordinate
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Lee, Jeff (20%)
  • Biddiscombe, John (8%)

Definition at line 72 of file vtkAxisActor2D.h.

Constructor & Destructor Documentation

vtkAxisActor2D::vtkAxisActor2D ( ) [protected]

vtkAxisActor2D::~vtkAxisActor2D ( ) [protected]

Member Function Documentation

vtkAxisActor2D::vtkTypeRevisionMacro | ( | vtkAxisActor2D | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkAxisActor2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkAxisActor2D* vtkAxisActor2D::New ( ) [static]

Instantiate object.

Reimplemented from vtkActor2D.

virtual vtkCoordinate* vtkAxisActor2D::GetPoint1Coordinate ( ) [virtual]

Specify the position of the first point defining the axis.

virtual void vtkAxisActor2D::SetPoint1 ( float x[2] ) [virtual]

Specify the position of the first point defining the axis.

virtual void vtkAxisActor2D::SetPoint1 | ( | float | x,
 |  | float | y
 | ) | [virtual]

Specify the position of the first point defining the axis.

virtual float* vtkAxisActor2D::GetPoint1 ( ) [virtual]

Specify the position of the first point defining the axis.

virtual vtkCoordinate* vtkAxisActor2D::GetPoint2Coordinate ( ) [virtual]

Specify the position of the second point defining the axis. Note that the order from Point1 to Point2 controls which side the tick marks are drawn on (ticks are drawn on the right, if visible).

virtual void vtkAxisActor2D::SetPoint2 ( float x[2] ) [virtual]

Specify the position of the second point defining the axis. Note that the order from Point1 to Point2 controls which side the tick marks are drawn on (ticks are drawn on the right, if visible).

virtual void vtkAxisActor2D::SetPoint2 | ( | float | x,
 |  | float | y
 | ) | [virtual]

Specify the position of the second point defining the axis. Note that the order from Point1 to Point2 controls which side the tick marks are drawn on (ticks are drawn on the right, if visible).

virtual float* vtkAxisActor2D::GetPoint2 ( ) [virtual]

Specify the position of the second point defining the axis. Note that the order from Point1 to Point2 controls which side the tick marks are drawn on (ticks are drawn on the right, if visible).

virtual void vtkAxisActor2D::SetRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify the (min,max) axis range. This will be used in the generation of labels, if labels are visible.

void vtkAxisActor2D::SetRange ( float [2] )

Specify the (min,max) axis range. This will be used in the generation of labels, if labels are visible.

virtual float* vtkAxisActor2D::GetRange ( ) [virtual]

Specify the (min,max) axis range. This will be used in the generation of labels, if labels are visible.

virtual void vtkAxisActor2D::GetRange ( float data[2] ) [virtual]

Specify the (min,max) axis range. This will be used in the generation of labels, if labels are visible.

virtual void vtkAxisActor2D::SetNumberOfLabels ( int ) [virtual]

Set/Get the number of annotation labels to show.

virtual int vtkAxisActor2D::GetNumberOfLabels ( ) [virtual]

Set/Get the number of annotation labels to show.

virtual void vtkAxisActor2D::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual char* vtkAxisActor2D::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual void vtkAxisActor2D::SetAdjustLabels ( int ) [virtual]

Set/Get the flag that controls whether the labels and ticks are adjusted for "nice" numerical values to make it easier to read the labels. The adjustment is based in the Range instance variable.

virtual int vtkAxisActor2D::GetAdjustLabels ( ) [virtual]

Set/Get the flag that controls whether the labels and ticks are adjusted for "nice" numerical values to make it easier to read the labels. The adjustment is based in the Range instance variable.

virtual void vtkAxisActor2D::AdjustLabelsOn ( ) [virtual]

Set/Get the flag that controls whether the labels and ticks are adjusted for "nice" numerical values to make it easier to read the labels. The adjustment is based in the Range instance variable.

virtual void vtkAxisActor2D::AdjustLabelsOff ( ) [virtual]

Set/Get the flag that controls whether the labels and ticks are adjusted for "nice" numerical values to make it easier to read the labels. The adjustment is based in the Range instance variable.

virtual void vtkAxisActor2D::SetTitle ( const char * ) [virtual]

Set/Get the title of the scalar bar actor,

virtual char* vtkAxisActor2D::GetTitle ( ) [virtual]

Set/Get the title of the scalar bar actor,

virtual void vtkAxisActor2D::SetBold ( int ) [virtual]

Enable/Disable bolding annotation text.

virtual int vtkAxisActor2D::GetBold ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkAxisActor2D::BoldOn ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkAxisActor2D::BoldOff ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkAxisActor2D::SetItalic ( int ) [virtual]

Enable/Disable italicizing annotation text.

virtual int vtkAxisActor2D::GetItalic ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkAxisActor2D::ItalicOn ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkAxisActor2D::ItalicOff ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkAxisActor2D::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual int vtkAxisActor2D::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkAxisActor2D::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkAxisActor2D::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkAxisActor2D::SetFontFamily ( int ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkAxisActor2D::GetFontFamily ( ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkAxisActor2D::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 155 of file vtkAxisActor2D.h.

void vtkAxisActor2D::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 156 of file vtkAxisActor2D.h.

void vtkAxisActor2D::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 157 of file vtkAxisActor2D.h.

virtual void vtkAxisActor2D::SetTickLength ( int ) [virtual]

Set/Get the length of the tick marks (expressed in pixels or display coordinates).

virtual int vtkAxisActor2D::GetTickLength ( ) [virtual]

Set/Get the length of the tick marks (expressed in pixels or display coordinates).

virtual void vtkAxisActor2D::SetTickOffset ( int ) [virtual]

Set/Get the offset of the labels (expressed in pixels or display coordinates). The offset is the distance of labels from tick marks or other objects.

virtual int vtkAxisActor2D::GetTickOffset ( ) [virtual]

Set/Get the offset of the labels (expressed in pixels or display coordinates). The offset is the distance of labels from tick marks or other objects.

virtual void vtkAxisActor2D::SetAxisVisibility ( int ) [virtual]

Set/Get visibility of the axis line.

virtual int vtkAxisActor2D::GetAxisVisibility ( ) [virtual]

Set/Get visibility of the axis line.

virtual void vtkAxisActor2D::AxisVisibilityOn ( ) [virtual]

Set/Get visibility of the axis line.

virtual void vtkAxisActor2D::AxisVisibilityOff ( ) [virtual]

Set/Get visibility of the axis line.

virtual void vtkAxisActor2D::SetTickVisibility ( int ) [virtual]

Set/Get visibility of the axis tick marks.

virtual int vtkAxisActor2D::GetTickVisibility ( ) [virtual]

Set/Get visibility of the axis tick marks.

virtual void vtkAxisActor2D::TickVisibilityOn ( ) [virtual]

Set/Get visibility of the axis tick marks.

virtual void vtkAxisActor2D::TickVisibilityOff ( ) [virtual]

Set/Get visibility of the axis tick marks.

virtual void vtkAxisActor2D::SetLabelVisibility ( int ) [virtual]

Set/Get visibility of the axis labels.

virtual int vtkAxisActor2D::GetLabelVisibility ( ) [virtual]

Set/Get visibility of the axis labels.

virtual void vtkAxisActor2D::LabelVisibilityOn ( ) [virtual]

Set/Get visibility of the axis labels.

virtual void vtkAxisActor2D::LabelVisibilityOff ( ) [virtual]

Set/Get visibility of the axis labels.

virtual void vtkAxisActor2D::SetTitleVisibility ( int ) [virtual]

Set/Get visibility of the axis title.

virtual int vtkAxisActor2D::GetTitleVisibility ( ) [virtual]

Set/Get visibility of the axis title.

virtual void vtkAxisActor2D::TitleVisibilityOn ( ) [virtual]

Set/Get visibility of the axis title.

virtual void vtkAxisActor2D::TitleVisibilityOff ( ) [virtual]

Set/Get visibility of the axis title.

virtual void vtkAxisActor2D::SetFontFactor ( float ) [virtual]

Set/Get the factor that controls the overall size of the fonts used to label and title the axes. This ivar used in conjunction with the LabelFactor can be used to control font sizes.

virtual float vtkAxisActor2D::GetFontFactor ( ) [virtual]

Set/Get the factor that controls the overall size of the fonts used to label and title the axes. This ivar used in conjunction with the LabelFactor can be used to control font sizes.

virtual void vtkAxisActor2D::SetLabelFactor ( float ) [virtual]

Set/Get the factor that controls the relative size of the axis labels to the axis title.

virtual float vtkAxisActor2D::GetLabelFactor ( ) [virtual]

Set/Get the factor that controls the relative size of the axis labels to the axis title.

int vtkAxisActor2D::RenderOverlay ( vtkViewport * viewport ) [virtual]

Draw the axis.

Reimplemented from vtkActor2D.

int vtkAxisActor2D::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Draw the axis.

Reimplemented from vtkActor2D.

int vtkAxisActor2D::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

Draw the axis.

Reimplemented from vtkActor2D.

Definition at line 222 of file vtkAxisActor2D.h.

void vtkAxisActor2D::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

void vtkAxisActor2D::ComputeRange | ( | float | inRange[2],
 |  | float | outRange[2],
 |  | int | inNumTicks,
 |  | int & | outNumTicks,
 |  | float & | interval
 | ) | [static]

This method computes the range of the axis given an input range. It also computes the number of tick marks given a suggested number. (The number of tick marks includes end ticks as well.) The number of tick marks computed (in conjunction with the output range) will yield "nice" tick values. For example, if the input range is (0.25,96.7) and the number of ticks requested is 10, the output range will be (0,100) with the number of computed ticks to 11 to yield tick values of (0,10,20,...,100).

int vtkAxisActor2D::SetFontSize | ( | vtkViewport * | viewport,
 |  | vtkTextMapper * | textMapper,
 |  | int * | size,
 |  | float | factor,
 |  | int & | stringWidth,
 |  | int & | stringHeight
 | ) | [static]

General method computes font size from a representative size on the viewport (given by size[2]). The method returns the font size (in points) and the string height/width (in pixels). It also sets the font size of the instance of vtkTextMapper provided. The factor is used when you're trying to create text of different size-factor is usually =1 but you can adjust the font size by making factor larger or smaller.

void vtkAxisActor2D::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of an axis actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor2D.

virtual void vtkAxisActor2D::BuildAxis ( vtkViewport * viewport ) [protected, virtual]

float vtkAxisActor2D::ComputeStringOffset | ( | float | width,
 |  | float | height,
 |  | float | theta
 | ) | [static, protected]

void vtkAxisActor2D::SetOffsetPosition | ( | float | xTick[3],
 |  | float | theta,
 |  | int | stringHeight,
 |  | int | stringWidth,
 |  | int | offset,
 |  | vtkActor2D * | actor
 | ) | [static, protected]

Member Data Documentation

vtkCoordinate* vtkAxisActor2D::Point1Coordinate [protected]

Definition at line 263 of file vtkAxisActor2D.h.

vtkCoordinate* vtkAxisActor2D::Point2Coordinate [protected]

Definition at line 264 of file vtkAxisActor2D.h.

char* vtkAxisActor2D::Title [protected]

Definition at line 265 of file vtkAxisActor2D.h.

float vtkAxisActor2D::Range[2] [protected]

Definition at line 266 of file vtkAxisActor2D.h.

int vtkAxisActor2D::NumberOfLabels [protected]

Definition at line 267 of file vtkAxisActor2D.h.

char* vtkAxisActor2D::LabelFormat [protected]

Definition at line 268 of file vtkAxisActor2D.h.

int vtkAxisActor2D::NumberOfLabelsBuilt [protected]

Definition at line 269 of file vtkAxisActor2D.h.

int vtkAxisActor2D::AdjustLabels [protected]

Definition at line 270 of file vtkAxisActor2D.h.

float vtkAxisActor2D::FontFactor [protected]

Definition at line 271 of file vtkAxisActor2D.h.

float vtkAxisActor2D::LabelFactor [protected]

Definition at line 272 of file vtkAxisActor2D.h.

int vtkAxisActor2D::TickLength [protected]

Definition at line 273 of file vtkAxisActor2D.h.

int vtkAxisActor2D::TickOffset [protected]

Definition at line 274 of file vtkAxisActor2D.h.

int vtkAxisActor2D::Bold [protected]

Definition at line 276 of file vtkAxisActor2D.h.

int vtkAxisActor2D::Italic [protected]

Definition at line 277 of file vtkAxisActor2D.h.

int vtkAxisActor2D::Shadow [protected]

Definition at line 278 of file vtkAxisActor2D.h.

int vtkAxisActor2D::FontFamily [protected]

Definition at line 279 of file vtkAxisActor2D.h.

int vtkAxisActor2D::AxisVisibility [protected]

Definition at line 281 of file vtkAxisActor2D.h.

int vtkAxisActor2D::TickVisibility [protected]

Definition at line 282 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LabelVisibility [protected]

Definition at line 283 of file vtkAxisActor2D.h.

int vtkAxisActor2D::TitleVisibility [protected]

Definition at line 284 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LastPoint1[2] [protected]

Definition at line 286 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LastPoint2[2] [protected]

Definition at line 287 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LastSize[2] [protected]

Definition at line 289 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LastTitleFontSize [protected]

Definition at line 290 of file vtkAxisActor2D.h.

int vtkAxisActor2D::LastLabelFontSize [protected]

Definition at line 291 of file vtkAxisActor2D.h.

vtkTextMapper* vtkAxisActor2D::TitleMapper [protected]

Definition at line 298 of file vtkAxisActor2D.h.

vtkActor2D* vtkAxisActor2D::TitleActor [protected]

Definition at line 299 of file vtkAxisActor2D.h.

vtkTextMapper** vtkAxisActor2D::LabelMappers [protected]

Definition at line 301 of file vtkAxisActor2D.h.

vtkActor2D** vtkAxisActor2D::LabelActors [protected]

Definition at line 302 of file vtkAxisActor2D.h.

vtkPolyData* vtkAxisActor2D::Axis [protected]

Definition at line 304 of file vtkAxisActor2D.h.

vtkPolyDataMapper2D* vtkAxisActor2D::AxisMapper [protected]

Definition at line 305 of file vtkAxisActor2D.h.

vtkActor2D* vtkAxisActor2D::AxisActor [protected]

Definition at line 306 of file vtkAxisActor2D.h.

vtkTimeStamp vtkAxisActor2D::BuildTime [protected]

Definition at line 308 of file vtkAxisActor2D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkAxisActor2D.h
Generated on Mon Mar 25 01:15:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBandedPolyDataContourFilter Class Reference

generate filled contours for vtkPolyData. More...

#include <vtkBandedPolyDataContourFilter.h>

Inheritance diagram for vtkBandedPolyDataContourFilter:

[legend]
Collaboration diagram for vtkBandedPolyDataContourFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBandedPolyDataContourFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetClipping (int)
virtual int | GetClipping ()
virtual void | ClippingOn ()
virtual void | ClippingOff ()
virtual void | SetScalarMode (int)
virtual int | GetScalarMode ()
void | SetScalarModeToIndex ()
void | SetScalarModeToValue ()
virtual void | SetGenerateContourEdges (int)
virtual int | GetGenerateContourEdges ()
virtual void | GenerateContourEdgesOn ()
virtual void | GenerateContourEdgesOff ()
vtkPolyData * GetContourEdgesOutput ()

Static Public Methods

vtkBandedPolyDataContourFilter * | New ()

Protected Methods

vtkBandedPolyDataContourFilter ()
~vtkBandedPolyDataContourFilter ()
void | Execute ()
int | ComputeScalarIndex (float)
int | IsContourValue (float val)
int | ClipEdge (int v1, int v2, vtkPoints *pts, vtkDataArray *scalars, vtkPointData *inPD, vtkPointData *outPD)
int | InsertCell (vtkCellArray *cells, int npts, vtkIdType *pts, int cellId, float s, vtkFloatArray *newS)

Protected Attributes

vtkContourValues * ContourValues
int | Clipping
int | ScalarMode
float * | ClipValues
int | NumberOfClipValues
int | ClipIndex [2]
float | ClipTolerance
int | GenerateContourEdges

Detailed Description

generate filled contours for vtkPolyData.

Date:
2002/02/11 21:26:30
Revision:
1.14

vtkBandedPolyDataContourFilter is a filter that takes as input vtkPolyData and produces as output filled contours (also represented as vtkPolyData). Filled conoturs are bands of cells that all have the same cell scalar value, and can therefore be colored the same. The method is also referred to as filled contour generation.

To use this filter you must specify one or more contour values. You can either use the method SetValue() to specify each contour value, or use GenerateValues() to generate a series of evenly spaced contours. Each contour value divides (or clips) the data into two pieces, values below the contour value, and values above it. The scalar values of each band correspond to the specified contour value. Note that if the first and last contour values are not the minimum/maximum contour range, then two extra contour values are added corresponding to the minimum and maximum range values. These extra contour bands can be prevented from being output by turning clipping on.

See also:
vtkClipDataSet vtkClipPolyData vtkClipVolume vtkContourFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (95%)
Examples:
vtkBandedPolyDataContourFilter (Examples)
Tests:
vtkBandedPolyDataContourFilter (Tests)

Definition at line 65 of file vtkBandedPolyDataContourFilter.h.

Constructor & Destructor Documentation

vtkBandedPolyDataContourFilter::vtkBandedPolyDataContourFilter ( ) [protected]

vtkBandedPolyDataContourFilter::~vtkBandedPolyDataContourFilter ( ) [protected]

Member Function Documentation

vtkBandedPolyDataContourFilter::vtkTypeRevisionMacro | ( | vtkBandedPolyDataContourFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkBandedPolyDataContourFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkBandedPolyDataContourFilter* vtkBandedPolyDataContourFilter::New ( ) [static]

Construct object with no contours defined.

Reimplemented from vtkPolyDataSource.

void vtkBandedPolyDataContourFilter::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Methods to set / get contour values. A single value at a time can be set with SetValue(). Multiple contour values can be set with GenerateValues(). Note that GenerateValues() generates n values inclusive of the start and end range values.

Definition at line 169 of file vtkBandedPolyDataContourFilter.h.

float vtkBandedPolyDataContourFilter::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 175 of file vtkBandedPolyDataContourFilter.h.

float * vtkBandedPolyDataContourFilter::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 182 of file vtkBandedPolyDataContourFilter.h.

void vtkBandedPolyDataContourFilter::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 190 of file vtkBandedPolyDataContourFilter.h.

void vtkBandedPolyDataContourFilter::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 198 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 204 of file vtkBandedPolyDataContourFilter.h.

void vtkBandedPolyDataContourFilter::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 211 of file vtkBandedPolyDataContourFilter.h.

void vtkBandedPolyDataContourFilter::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 219 of file vtkBandedPolyDataContourFilter.h.

virtual void vtkBandedPolyDataContourFilter::SetClipping ( int ) [virtual]

Indicate whether to clip outside the range specified by the user. (The range is contour value[0] to contour value[numContours-1].) Clipping means all cells outside of the range specified are not sent to the output.

virtual int vtkBandedPolyDataContourFilter::GetClipping ( ) [virtual]

Indicate whether to clip outside the range specified by the user. (The range is contour value[0] to contour value[numContours-1].) Clipping means all cells outside of the range specified are not sent to the output.

virtual void vtkBandedPolyDataContourFilter::ClippingOn ( ) [virtual]

Indicate whether to clip outside the range specified by the user. (The range is contour value[0] to contour value[numContours-1].) Clipping means all cells outside of the range specified are not sent to the output.

virtual void vtkBandedPolyDataContourFilter::ClippingOff ( ) [virtual]

Indicate whether to clip outside the range specified by the user. (The range is contour value[0] to contour value[numContours-1].) Clipping means all cells outside of the range specified are not sent to the output.

virtual void vtkBandedPolyDataContourFilter::SetScalarMode ( int ) [virtual]

Control whether the cell scalars are output as an integer index or a scalar value. If an index, the index refers to the bands produced by the clipping range. If a value, then a scalar value which is a value between clip values is used.

virtual int vtkBandedPolyDataContourFilter::GetScalarMode ( ) [virtual]

Control whether the cell scalars are output as an integer index or a scalar value. If an index, the index refers to the bands produced by the clipping range. If a value, then a scalar value which is a value between clip values is used.

void vtkBandedPolyDataContourFilter::SetScalarModeToIndex ( ) [inline]

Control whether the cell scalars are output as an integer index or a scalar value. If an index, the index refers to the bands produced by the clipping range. If a value, then a scalar value which is a value between clip values is used.

Definition at line 106 of file vtkBandedPolyDataContourFilter.h.

void vtkBandedPolyDataContourFilter::SetScalarModeToValue ( ) [inline]

Control whether the cell scalars are output as an integer index or a scalar value. If an index, the index refers to the bands produced by the clipping range. If a value, then a scalar value which is a value between clip values is used.

Definition at line 108 of file vtkBandedPolyDataContourFilter.h.

virtual void vtkBandedPolyDataContourFilter::SetGenerateContourEdges ( int ) [virtual]

Turn on/off a flag to control whether contour edges are generated. Contour edges are the edges between bands. If enabled, they are generated from polygons/triangle strips and placed into the second output (the ContourEdgesOutput).

virtual int vtkBandedPolyDataContourFilter::GetGenerateContourEdges ( ) [virtual]

Turn on/off a flag to control whether contour edges are generated. Contour edges are the edges between bands. If enabled, they are generated from polygons/triangle strips and placed into the second output (the ContourEdgesOutput).

virtual void vtkBandedPolyDataContourFilter::GenerateContourEdgesOn ( ) [virtual]

Turn on/off a flag to control whether contour edges are generated. Contour edges are the edges between bands. If enabled, they are generated from polygons/triangle strips and placed into the second output (the ContourEdgesOutput).

virtual void vtkBandedPolyDataContourFilter::GenerateContourEdgesOff ( ) [virtual]

Turn on/off a flag to control whether contour edges are generated. Contour edges are the edges between bands. If enabled, they are generated from polygons/triangle strips and placed into the second output (the ContourEdgesOutput).

vtkPolyData* vtkBandedPolyDataContourFilter::GetContourEdgesOutput ( ) [inline]

Get the second output which contains the edges divinding the contour bands. This output is empty unless GenerateContourEdges is enabled.

Definition at line 125 of file vtkBandedPolyDataContourFilter.h.

unsigned long vtkBandedPolyDataContourFilter::GetMTime ( ) [virtual]

Overload GetMTime because we delegate to vtkContourValues so its modified time must be taken into account.

Reimplemented from vtkObject.

void vtkBandedPolyDataContourFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkBandedPolyDataContourFilter::ComputeScalarIndex ( float ) [protected]

int vtkBandedPolyDataContourFilter::IsContourValue ( float val ) [protected]

int vtkBandedPolyDataContourFilter::ClipEdge | ( | int | v1,
 |  | int | v2,
 |  | vtkPoints * | pts,
 |  | vtkDataArray * | scalars,
 |  | vtkPointData * | inPD,
 |  | vtkPointData * | outPD
 | ) | [protected]

int vtkBandedPolyDataContourFilter::InsertCell | ( | vtkCellArray * | cells,
 |  | int | npts,
 |  | vtkIdType * | pts,
 |  | int | cellId,
 |  | float | s,
 |  | vtkFloatArray * | newS
 | ) | [protected]

Member Data Documentation

vtkContourValues* vtkBandedPolyDataContourFilter::ContourValues [protected]

Definition at line 147 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::Clipping [protected]

Definition at line 149 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::ScalarMode [protected]

Definition at line 150 of file vtkBandedPolyDataContourFilter.h.

float* vtkBandedPolyDataContourFilter::ClipValues [protected]

Definition at line 153 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::NumberOfClipValues [protected]

Definition at line 154 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::ClipIndex[2] [protected]

Definition at line 155 of file vtkBandedPolyDataContourFilter.h.

float vtkBandedPolyDataContourFilter::ClipTolerance [protected]

Definition at line 156 of file vtkBandedPolyDataContourFilter.h.

int vtkBandedPolyDataContourFilter::GenerateContourEdges [protected]

Definition at line 159 of file vtkBandedPolyDataContourFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkBandedPolyDataContourFilter.h
Generated on Mon Mar 25 01:15:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBitArray Class Reference

dynamic, self-adjusting array of bits. More...

#include <vtkBitArray.h>

Inheritance diagram for vtkBitArray:

[legend]
Collaboration diagram for vtkBitArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBitArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
int | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | SetValue (const vtkIdType id, const int value)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
unsigned char * | GetPointer (const vtkIdType id)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | InsertValue (const vtkIdType id, const int i)
vtkIdType | InsertNextValue (const int i)
unsigned char * | WritePointer (const vtkIdType id, const vtkIdType number)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (unsigned char *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkBitArray * | New ()

Protected Methods

vtkBitArray (vtkIdType numComp=1)
~vtkBitArray ()
unsigned char * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

unsigned char * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting array of bits.

Date:
2002/02/13 22:46:27
Revision:
1.63

vtkBitArray is an array of bits (0/1 data value). The array is packed so that each byte stores eight bits. vtkBitArray provides methods for insertion and retrieval of bits, and will automatically resize itself to hold new data.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (40%)
  • Schroeder, Will (25%)
  • Henderson, Amy (7%)
  • Miller, Jim (7%)
  • Geveci, Berk (5%)
  • Kelly, Ann (5%)

Definition at line 44 of file vtkBitArray.h.

Constructor & Destructor Documentation

vtkBitArray::vtkBitArray ( vtkIdType numComp = 1 ) [protected]

vtkBitArray::~vtkBitArray ( ) [protected]

Member Function Documentation

vtkBitArray* vtkBitArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkBitArray::vtkTypeRevisionMacro | ( | vtkBitArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkBitArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkBitArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkBitArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkBitArray::MakeObject ( ) [virtual]

Virtual constructor creates an object of the same type as this one. The created object also has the same number of components. You are responsible for freeing the object.

Reimplemented from vtkDataArray.

int vtkBitArray::GetDataType ( ) [inline, virtual]

Return the underlying data type. An integer indicating data type is returned as specified in vtkSetGet.h.

Reimplemented from vtkDataArray.

Definition at line 60 of file vtkBitArray.h.

int vtkBitArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the underlying data type. For a bit, 0 is returned.

Reimplemented from vtkDataArray.

Definition at line 61 of file vtkBitArray.h.

void vtkBitArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkBitArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkBitArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkBitArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkBitArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkBitArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkBitArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkBitArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkBitArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkBitArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkBitArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkBitArray::Squeeze ( ) [inline, virtual]

Free any unneeded memory.

Reimplemented from vtkDataArray.

Definition at line 241 of file vtkBitArray.h.

virtual void vtkBitArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

int vtkBitArray::GetValue ( const vtkIdType id )

Get the data at a particular index.

void vtkBitArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Fast method based setting of values without memory checks. First use SetNumberOfValues then use SetValue to actually set them. Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 198 of file vtkBitArray.h.

void vtkBitArray::SetValue | ( | const vtkIdType | id,
 |  | const int | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 204 of file vtkBitArray.h.

void vtkBitArray::InsertValue | ( | const vtkIdType | id,
 |  | const int | i
 | ) | [inline]

Insets values and checks to make sure there is enough memory

Definition at line 216 of file vtkBitArray.h.

Referenced by InsertNextValue().

vtkIdType vtkBitArray::InsertNextValue ( const int i ) [inline]

Insets values and checks to make sure there is enough memory

Definition at line 236 of file vtkBitArray.h.

virtual void vtkBitArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

unsigned char* vtkBitArray::GetPointer ( const vtkIdType id ) [inline]

Direct manipulation of the underlying data.

Definition at line 134 of file vtkBitArray.h.

unsigned char * vtkBitArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 183 of file vtkBitArray.h.

void* vtkBitArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Reimplemented from vtkDataArray.

Definition at line 141 of file vtkBitArray.h.

void vtkBitArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another bit array.

Reimplemented from vtkDataArray.

void vtkBitArray::SetArray | ( | unsigned char * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkBitArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 156 of file vtkBitArray.h.

unsigned char* vtkBitArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), Squeeze(), and WritePointer().

Member Data Documentation

unsigned char* vtkBitArray::Array [protected]

Definition at line 165 of file vtkBitArray.h.

int vtkBitArray::TupleSize [protected]

Definition at line 169 of file vtkBitArray.h.

float* vtkBitArray::Tuple [protected]

Definition at line 170 of file vtkBitArray.h.

int vtkBitArray::SaveUserArray [protected]

Definition at line 172 of file vtkBitArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkBitArray.h
Generated on Mon Mar 25 01:15:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBlankStructuredGrid Class Reference

translate point attribute data into a blanking field. More...

#include <vtkBlankStructuredGrid.h>

Inheritance diagram for vtkBlankStructuredGrid:

[legend]
Collaboration diagram for vtkBlankStructuredGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBlankStructuredGrid, vtkStructuredGridToStructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMinBlankingValue (float)
virtual float | GetMinBlankingValue ()
virtual void | SetMaxBlankingValue (float)
virtual float | GetMaxBlankingValue ()
virtual void | SetArrayName (const char *)
virtual char * | GetArrayName ()
virtual void | SetArrayId (int)
virtual int | GetArrayId ()
virtual void | SetComponent (int)
virtual int | GetComponent ()

Static Public Methods

vtkBlankStructuredGrid * | New ()

Protected Methods

vtkBlankStructuredGrid ()
~vtkBlankStructuredGrid ()
void | Execute ()

Protected Attributes

float | MinBlankingValue
float | MaxBlankingValue
char * | ArrayName
int | ArrayId
int | Component

Detailed Description

translate point attribute data into a blanking field.

Date:
2002/01/22 15:29:07
Revision:
1.7

vtkBlankStructuredGrid is a filter that sets the blanking field in a vtkStructuredGrid dataset. The blanking field is set by examining a specified point attribute data array (e.g., scalars) and converting values in the data array to either a "1" (visible) or "0" (blanked) value in the blanking array. The values to be blanked are specified by giving a min/max range. All data values in the data array indicated and laying within the range specified (inclusive on both ends) are translated to a "off" blanking value.

See also:
vtkStructuredGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (95%)
Tests:
vtkBlankStructuredGrid (Tests)

Definition at line 50 of file vtkBlankStructuredGrid.h.

Constructor & Destructor Documentation

vtkBlankStructuredGrid::vtkBlankStructuredGrid ( ) [protected]

vtkBlankStructuredGrid::~vtkBlankStructuredGrid ( ) [protected]

Member Function Documentation

vtkBlankStructuredGrid* vtkBlankStructuredGrid::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredGridSource.

vtkBlankStructuredGrid::vtkTypeRevisionMacro | ( | vtkBlankStructuredGrid | ,
 |  | vtkStructuredGridToStructuredGridFilter |
 | ) |

Reimplemented from vtkStructuredGridToStructuredGridFilter.

void vtkBlankStructuredGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkBlankStructuredGrid::SetMinBlankingValue ( float ) [virtual]

Specify the lower data value in the data array specified which will be converted into a "blank" (or off) value in the blanking array.

virtual float vtkBlankStructuredGrid::GetMinBlankingValue ( ) [virtual]

Specify the lower data value in the data array specified which will be converted into a "blank" (or off) value in the blanking array.

virtual void vtkBlankStructuredGrid::SetMaxBlankingValue ( float ) [virtual]

Specify the upper data value in the data array specified which will be converted into a "blank" (or off) value in the blanking array.

virtual float vtkBlankStructuredGrid::GetMaxBlankingValue ( ) [virtual]

Specify the upper data value in the data array specified which will be converted into a "blank" (or off) value in the blanking array.

virtual void vtkBlankStructuredGrid::SetArrayName ( const char * ) [virtual]

Specify the data array name to use to generate the blanking field. Alternatively, you can specify the array id. (If both are set, the array name takes precedence.)

virtual char* vtkBlankStructuredGrid::GetArrayName ( ) [virtual]

Specify the data array name to use to generate the blanking field. Alternatively, you can specify the array id. (If both are set, the array name takes precedence.)

virtual void vtkBlankStructuredGrid::SetArrayId ( int ) [virtual]

Specify the data array id to use to generate the blanking field. Alternatively, you can specify the array name. (If both are set, the array name takes precedence.)

virtual int vtkBlankStructuredGrid::GetArrayId ( ) [virtual]

Specify the data array id to use to generate the blanking field. Alternatively, you can specify the array name. (If both are set, the array name takes precedence.)

virtual void vtkBlankStructuredGrid::SetComponent ( int ) [virtual]

Specify the component in the data array to use to generate the blanking field.

virtual int vtkBlankStructuredGrid::GetComponent ( ) [virtual]

Specify the component in the data array to use to generate the blanking field.

void vtkBlankStructuredGrid::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkBlankStructuredGrid::MinBlankingValue [protected]

Definition at line 100 of file vtkBlankStructuredGrid.h.

float vtkBlankStructuredGrid::MaxBlankingValue [protected]

Definition at line 101 of file vtkBlankStructuredGrid.h.

char* vtkBlankStructuredGrid::ArrayName [protected]

Definition at line 102 of file vtkBlankStructuredGrid.h.

int vtkBlankStructuredGrid::ArrayId [protected]

Definition at line 103 of file vtkBlankStructuredGrid.h.

int vtkBlankStructuredGrid::Component [protected]

Definition at line 104 of file vtkBlankStructuredGrid.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkBlankStructuredGrid.h
Generated on Mon Mar 25 01:15:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBlankStructuredGridWithImage Class Reference

blank a structured grid with an image. More...

#include <vtkBlankStructuredGridWithImage.h>

Inheritance diagram for vtkBlankStructuredGridWithImage:

[legend]
Collaboration diagram for vtkBlankStructuredGridWithImage:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBlankStructuredGridWithImage, vtkStructuredGridToStructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetBlankingInput (vtkImageData *input)
vtkImageData * GetBlankingInput ()

Static Public Methods

vtkBlankStructuredGridWithImage * | New ()

Protected Methods

vtkBlankStructuredGridWithImage ()
~vtkBlankStructuredGridWithImage ()
void | Execute ()

Detailed Description

blank a structured grid with an image.

Date:
2002/01/22 15:29:08
Revision:
1.6

This filter can be used to set the blanking in a structured grid with an image. The filter takes two inputs: the structured grid to blank, and the image used to set the blanking. Make sure that the dimensions of both the image and the structured grid are identical.

Note that the image is interpreted as follows: zero values indicate that the structured grid point is blanked; non-zero values indicate that the structured grid point is visible. The blanking data must be unsigned char.

See also:
vtkStructuredGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)
Tests:
vtkBlankStructuredGridWithImage (Tests)

Definition at line 51 of file vtkBlankStructuredGridWithImage.h.

Constructor & Destructor Documentation

vtkBlankStructuredGridWithImage::vtkBlankStructuredGridWithImage ( ) [inline, protected]

Definition at line 65 of file vtkBlankStructuredGridWithImage.h.

vtkBlankStructuredGridWithImage::~vtkBlankStructuredGridWithImage ( ) [inline, protected]

Definition at line 66 of file vtkBlankStructuredGridWithImage.h.

Member Function Documentation

vtkBlankStructuredGridWithImage* vtkBlankStructuredGridWithImage::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredGridSource.

vtkBlankStructuredGridWithImage::vtkTypeRevisionMacro | ( | vtkBlankStructuredGridWithImage | ,
 |  | vtkStructuredGridToStructuredGridFilter |
 | ) |

Reimplemented from vtkStructuredGridToStructuredGridFilter.

void vtkBlankStructuredGridWithImage::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkBlankStructuredGridWithImage::SetBlankingInput ( vtkImageData * input )

Set / get the input image used to perform the blanking.

vtkImageData* vtkBlankStructuredGridWithImage::GetBlankingInput ( )

Set / get the input image used to perform the blanking.

void vtkBlankStructuredGridWithImage::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Graphics/vtkBlankStructuredGridWithImage.h
Generated on Mon Mar 25 01:15:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBMPReader Class Reference

read Windows BMP files. More...

#include <vtkBMPReader.h>

Inheritance diagram for vtkBMPReader:

[legend]
Collaboration diagram for vtkBMPReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBMPReader, vtkImageReader)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | GetDepth ()
virtual vtkImageReader2 * | MakeObject ()
virtual int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()
virtual unsigned char * | GetColors ()

Static Public Methods

vtkBMPReader * | New ()

Protected Methods

vtkBMPReader ()
~vtkBMPReader ()
virtual void | ComputeDataIncrements ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)

Protected Attributes

unsigned char * | Colors
short | Depth

Detailed Description

read Windows BMP files.

Date:
2002/01/31 23:53:13
Revision:
1.25

vtkBMPReader is a source object that reads Windows BMP files. This includes indexed and 24bit bitmaps

BMPReader creates structured point datasets. The dimension of the dataset depends upon the number of files read. Reading a single file results in a 2D image, while reading more than one file results in a 3D volume.

To read a volume, files must be of the form "FileName.<number>" (e.g., foo.ppm.0, foo.ppm.1, ...). You must also specify the image range. This range specifies the beginning and ending files to read (range can be any pair of non-negative numbers).

The default behavior is to read a single file. In this case, the form of the file is simply "FileName" (e.g., foo.bar, foo.ppm, foo.BMP).

See also:
vtkBMPWriter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (62%)
  • Miller, Jim (15%)
  • Lorensen, Bill (10%)
  • Hoffman, Bill (5%)
Examples:
vtkBMPReader (Examples)
Tests:
vtkBMPReader (Tests)

Definition at line 63 of file vtkBMPReader.h.

Constructor & Destructor Documentation

vtkBMPReader::vtkBMPReader ( ) [protected]

vtkBMPReader::~vtkBMPReader ( ) [protected]

Member Function Documentation

vtkBMPReader* vtkBMPReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader.

Referenced by MakeObject().

vtkBMPReader::vtkTypeRevisionMacro | ( | vtkBMPReader | ,
 |  | vtkImageReader |
 | ) |

Reimplemented from vtkImageReader.

void vtkBMPReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageReader.

virtual int vtkBMPReader::GetDepth ( ) [virtual]

Returns the depth of the BMP, either 8 or 24.

virtual vtkImageReader2* vtkBMPReader::MakeObject ( ) [inline, virtual]

Returns the depth of the BMP, either 8 or 24.

Reimplemented from vtkImageReader2.

Definition at line 75 of file vtkBMPReader.h.

virtual int vtkBMPReader::CanReadFile ( const char * fname ) [virtual]

virtual const char* vtkBMPReader::GetFileExensions ( ) [inline, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented from vtkImageReader2.

Definition at line 84 of file vtkBMPReader.h.

virtual const char* vtkBMPReader::GetDescriptiveName ( ) [inline, virtual]

Return a descriptive name for the file format that might be useful in a GUI.

Reimplemented from vtkImageReader2.

Definition at line 93 of file vtkBMPReader.h.

virtual unsigned char* vtkBMPReader::GetColors ( ) [virtual]

Returns the color lut.

virtual void vtkBMPReader::ComputeDataIncrements ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

virtual void vtkBMPReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader.

virtual void vtkBMPReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader.

Member Data Documentation

unsigned char* vtkBMPReader::Colors [protected]

Definition at line 110 of file vtkBMPReader.h.

short vtkBMPReader::Depth [protected]

Definition at line 111 of file vtkBMPReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkBMPReader.h
Generated on Mon Mar 25 01:15:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBMPWriter Class Reference

Writes Windows BMP files. More...

#include <vtkBMPWriter.h>

Inheritance diagram for vtkBMPWriter:

[legend]
Collaboration diagram for vtkBMPWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBMPWriter, vtkImageWriter)

Static Public Methods

vtkBMPWriter * | New ()

Protected Methods

vtkBMPWriter ()
~vtkBMPWriter ()
virtual void | WriteFile (ofstream *file, vtkImageData *data, int ext[6])
virtual void | WriteFileHeader (ofstream *, vtkImageData *)

Detailed Description

Writes Windows BMP files.

Date:
2002/01/22 15:38:08
Revision:
1.18

vtkBMPWriter writes BMP files. The data type of the file is unsigned char regardless of the input type.

See also:
vtkBMPReader
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (95%)
Tests:
vtkBMPWriter (Tests)

Definition at line 43 of file vtkBMPWriter.h.

Constructor & Destructor Documentation

vtkBMPWriter::vtkBMPWriter ( ) [protected]

vtkBMPWriter::~vtkBMPWriter ( ) [inline, protected]

Definition at line 51 of file vtkBMPWriter.h.

Member Function Documentation

vtkBMPWriter* vtkBMPWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkBMPWriter::vtkTypeRevisionMacro | ( | vtkBMPWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

virtual void vtkBMPWriter::WriteFile | ( | ofstream * | file,
 |  | vtkImageData * | data,
 |  | int | ext[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkBMPWriter::WriteFileHeader | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

The documentation for this class was generated from the following file:
  • IO/vtkBMPWriter.h
Generated on Mon Mar 25 01:15:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBooleanTexture Class Reference

generate 2D texture map based on combinations of inside, outside, and on region boundary. More...

#include <vtkBooleanTexture.h>

Inheritance diagram for vtkBooleanTexture:

[legend]
Collaboration diagram for vtkBooleanTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBooleanTexture, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetXSize (int)
virtual int | GetXSize ()
virtual void | SetYSize (int)
virtual int | GetYSize ()
virtual void | SetThickness (int)
virtual int | GetThickness ()
virtual void | SetInIn (unsigned char, unsigned char)
void | SetInIn (unsigned char[2])
virtual unsigned char * | GetInIn ()
virtual void | GetInIn (unsigned char data[2])
virtual void | SetInOut (unsigned char, unsigned char)
void | SetInOut (unsigned char[2])
virtual unsigned char * | GetInOut ()
virtual void | GetInOut (unsigned char data[2])
virtual void | SetOutIn (unsigned char, unsigned char)
void | SetOutIn (unsigned char[2])
virtual unsigned char * | GetOutIn ()
virtual void | GetOutIn (unsigned char data[2])
virtual void | SetOutOut (unsigned char, unsigned char)
void | SetOutOut (unsigned char[2])
virtual unsigned char * | GetOutOut ()
virtual void | GetOutOut (unsigned char data[2])
virtual void | SetOnOn (unsigned char, unsigned char)
void | SetOnOn (unsigned char[2])
virtual unsigned char * | GetOnOn ()
virtual void | GetOnOn (unsigned char data[2])
virtual void | SetOnIn (unsigned char, unsigned char)
void | SetOnIn (unsigned char[2])
virtual unsigned char * | GetOnIn ()
virtual void | GetOnIn (unsigned char data[2])
virtual void | SetOnOut (unsigned char, unsigned char)
void | SetOnOut (unsigned char[2])
virtual unsigned char * | GetOnOut ()
virtual void | GetOnOut (unsigned char data[2])
virtual void | SetInOn (unsigned char, unsigned char)
void | SetInOn (unsigned char[2])
virtual unsigned char * | GetInOn ()
virtual void | GetInOn (unsigned char data[2])
virtual void | SetOutOn (unsigned char, unsigned char)
void | SetOutOn (unsigned char[2])
virtual unsigned char * | GetOutOn ()
virtual void | GetOutOn (unsigned char data[2])

Static Public Methods

vtkBooleanTexture * | New ()

Protected Methods

vtkBooleanTexture ()
~vtkBooleanTexture ()
void | Execute ()

Protected Attributes

int | XSize
int | YSize
int | Thickness
unsigned char | InIn [2]
unsigned char | InOut [2]
unsigned char | OutIn [2]
unsigned char | OutOut [2]
unsigned char | OnOn [2]
unsigned char | OnIn [2]
unsigned char | OnOut [2]
unsigned char | InOn [2]
unsigned char | OutOn [2]

Detailed Description

generate 2D texture map based on combinations of inside, outside, and on region boundary.

Date:
2002/01/22 15:31:44
Revision:
1.33

vtkBooleanTexture is a filter to generate a 2D texture map based on combinations of inside, outside, and on region boundary. The "region" is implicitly represented via 2D texture coordinates. These texture coordinates are normally generated using a filter like vtkImplicitTextureCoords, which generates the texture coordinates for any implicit function.

vtkBooleanTexture generates the map according to the s-t texture coordinates plus the notion of being in, on, or outside of a region. An in region is when the texture coordinate is between (0,0.5-thickness/2). An out region is where the texture coordinate is (0.5+thickness/2). An on region is between (0.5-thickness/2,0.5+thickness/2). The combination in, on, and out for each of the s-t texture coordinates results in 16 possible combinations (see text). For each combination, a different value of intensity and transparency can be assigned. To assign maximum intensity and/or opacity use the value 255. A minimum value of 0 results in a black region (for intensity) and a fully transparent region (for transparency).

See also:
vtkImplicitTextureCoords vtkThresholdTextureCoords
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Lorensen, Bill (10%)
  • Martin, Ken (9%)
  • Geveci, Berk (8%)
Tests:
vtkBooleanTexture (Tests)

Definition at line 64 of file vtkBooleanTexture.h.

Constructor & Destructor Documentation

vtkBooleanTexture::vtkBooleanTexture ( ) [protected]

vtkBooleanTexture::~vtkBooleanTexture ( ) [inline, protected]

Definition at line 146 of file vtkBooleanTexture.h.

Member Function Documentation

vtkBooleanTexture* vtkBooleanTexture::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredPointsSource.

vtkBooleanTexture::vtkTypeRevisionMacro | ( | vtkBooleanTexture | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

void vtkBooleanTexture::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkBooleanTexture::SetXSize ( int ) [virtual]

Set the X texture map dimension.

virtual int vtkBooleanTexture::GetXSize ( ) [virtual]

Set the X texture map dimension.

virtual void vtkBooleanTexture::SetYSize ( int ) [virtual]

Set the Y texture map dimension.

virtual int vtkBooleanTexture::GetYSize ( ) [virtual]

Set the Y texture map dimension.

virtual void vtkBooleanTexture::SetThickness ( int ) [virtual]

Set the thickness of the "on" region.

virtual int vtkBooleanTexture::GetThickness ( ) [virtual]

Set the thickness of the "on" region.

virtual void vtkBooleanTexture::SetInIn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "in/in" region.

void vtkBooleanTexture::SetInIn ( unsigned char[2] )

Specify intensity/transparency for "in/in" region.

virtual unsigned char* vtkBooleanTexture::GetInIn ( ) [virtual]

Specify intensity/transparency for "in/in" region.

virtual void vtkBooleanTexture::GetInIn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "in/in" region.

virtual void vtkBooleanTexture::SetInOut | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "in/out" region.

void vtkBooleanTexture::SetInOut ( unsigned char[2] )

Specify intensity/transparency for "in/out" region.

virtual unsigned char* vtkBooleanTexture::GetInOut ( ) [virtual]

Specify intensity/transparency for "in/out" region.

virtual void vtkBooleanTexture::GetInOut ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "in/out" region.

virtual void vtkBooleanTexture::SetOutIn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "out/in" region.

void vtkBooleanTexture::SetOutIn ( unsigned char[2] )

Specify intensity/transparency for "out/in" region.

virtual unsigned char* vtkBooleanTexture::GetOutIn ( ) [virtual]

Specify intensity/transparency for "out/in" region.

virtual void vtkBooleanTexture::GetOutIn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "out/in" region.

virtual void vtkBooleanTexture::SetOutOut | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "out/out" region.

void vtkBooleanTexture::SetOutOut ( unsigned char[2] )

Specify intensity/transparency for "out/out" region.

virtual unsigned char* vtkBooleanTexture::GetOutOut ( ) [virtual]

Specify intensity/transparency for "out/out" region.

virtual void vtkBooleanTexture::GetOutOut ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "out/out" region.

virtual void vtkBooleanTexture::SetOnOn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "on/on" region.

void vtkBooleanTexture::SetOnOn ( unsigned char[2] )

Specify intensity/transparency for "on/on" region.

virtual unsigned char* vtkBooleanTexture::GetOnOn ( ) [virtual]

Specify intensity/transparency for "on/on" region.

virtual void vtkBooleanTexture::GetOnOn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "on/on" region.

virtual void vtkBooleanTexture::SetOnIn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "on/in" region.

void vtkBooleanTexture::SetOnIn ( unsigned char[2] )

Specify intensity/transparency for "on/in" region.

virtual unsigned char* vtkBooleanTexture::GetOnIn ( ) [virtual]

Specify intensity/transparency for "on/in" region.

virtual void vtkBooleanTexture::GetOnIn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "on/in" region.

virtual void vtkBooleanTexture::SetOnOut | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "on/out" region.

void vtkBooleanTexture::SetOnOut ( unsigned char[2] )

Specify intensity/transparency for "on/out" region.

virtual unsigned char* vtkBooleanTexture::GetOnOut ( ) [virtual]

Specify intensity/transparency for "on/out" region.

virtual void vtkBooleanTexture::GetOnOut ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "on/out" region.

virtual void vtkBooleanTexture::SetInOn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "in/on" region.

void vtkBooleanTexture::SetInOn ( unsigned char[2] )

Specify intensity/transparency for "in/on" region.

virtual unsigned char* vtkBooleanTexture::GetInOn ( ) [virtual]

Specify intensity/transparency for "in/on" region.

virtual void vtkBooleanTexture::GetInOn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "in/on" region.

virtual void vtkBooleanTexture::SetOutOn | ( | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Specify intensity/transparency for "out/on" region.

void vtkBooleanTexture::SetOutOn ( unsigned char[2] )

Specify intensity/transparency for "out/on" region.

virtual unsigned char* vtkBooleanTexture::GetOutOn ( ) [virtual]

Specify intensity/transparency for "out/on" region.

virtual void vtkBooleanTexture::GetOutOn ( unsigned char data[2] ) [virtual]

Specify intensity/transparency for "out/on" region.

void vtkBooleanTexture::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkBooleanTexture::XSize [protected]

Definition at line 150 of file vtkBooleanTexture.h.

int vtkBooleanTexture::YSize [protected]

Definition at line 151 of file vtkBooleanTexture.h.

int vtkBooleanTexture::Thickness [protected]

Definition at line 153 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::InIn[2] [protected]

Definition at line 154 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::InOut[2] [protected]

Definition at line 155 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OutIn[2] [protected]

Definition at line 156 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OutOut[2] [protected]

Definition at line 157 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OnOn[2] [protected]

Definition at line 158 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OnIn[2] [protected]

Definition at line 159 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OnOut[2] [protected]

Definition at line 160 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::InOn[2] [protected]

Definition at line 161 of file vtkBooleanTexture.h.

unsigned char vtkBooleanTexture::OutOn[2] [protected]

Definition at line 162 of file vtkBooleanTexture.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkBooleanTexture.h
Generated on Mon Mar 25 01:15:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBranchExtentTranslator Class Reference

Uses alternative source for whole extent. More...

#include <vtkBranchExtentTranslator.h>

Inheritance diagram for vtkBranchExtentTranslator:

[legend]
Collaboration diagram for vtkBranchExtentTranslator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBranchExtentTranslator, vtkExtentTranslator)
void | PrintSelf (ostream &os, vtkIndent indent)
int | PieceToExtent ()
virtual void | SetOriginalSource (vtkImageData *)
virtual vtkImageData * | GetOriginalSource ()
virtual void | SetAssignedPiece (int)
virtual int | GetAssignedPiece ()
virtual void | SetAssignedNumberOfPieces (int)
virtual int | GetAssignedNumberOfPieces ()

Static Public Methods

vtkBranchExtentTranslator * | New ()

Protected Methods

vtkBranchExtentTranslator ()
~vtkBranchExtentTranslator ()

Protected Attributes

vtkImageData * OriginalSource
int | AssignedPiece
int | AssignedNumberOfPieces

Detailed Description

Uses alternative source for whole extent.

Date:
2002/01/22 15:34:26
Revision:
1.9

vtkBranchExtentTranslator is like extent translator, but it uses an alternative source as a whole extent. The whole extent passed is assumed to be a subextent of the original source. we simply take the intersection of the split extent and the whole extdent passed in. We are attempting to make branching pipelines request consistent extents with the same piece requests.

Warning:
This object is still under development.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (97%)
Tests:
vtkBranchExtentTranslator (Tests)

Definition at line 49 of file vtkBranchExtentTranslator.h.

Constructor & Destructor Documentation

vtkBranchExtentTranslator::vtkBranchExtentTranslator ( ) [protected]

vtkBranchExtentTranslator::~vtkBranchExtentTranslator ( ) [protected]

Member Function Documentation

vtkBranchExtentTranslator* vtkBranchExtentTranslator::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkExtentTranslator.

vtkBranchExtentTranslator::vtkTypeRevisionMacro | ( | vtkBranchExtentTranslator | ,
 |  | vtkExtentTranslator |
 | ) |

Reimplemented from vtkExtentTranslator.

void vtkBranchExtentTranslator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExtentTranslator.

virtual void vtkBranchExtentTranslator::SetOriginalSource ( vtkImageData * ) [virtual]

This is the original upstream image source.

virtual vtkImageData* vtkBranchExtentTranslator::GetOriginalSource ( ) [virtual]

This is the original upstream image source.

int vtkBranchExtentTranslator::PieceToExtent ( ) [virtual]

Generates the extent from the pieces.

Reimplemented from vtkExtentTranslator.

virtual void vtkBranchExtentTranslator::SetAssignedPiece ( int ) [virtual]

This unstructured extent/piece is store here for the users convenience. It is not used internally. The intent was to let an "assignment" be made when the translator/first source is created. The translator/assignment can be used for any new filter that uses the original source as output. Branches will then have the same assignment.

virtual int vtkBranchExtentTranslator::GetAssignedPiece ( ) [virtual]

This unstructured extent/piece is store here for the users convenience. It is not used internally. The intent was to let an "assignment" be made when the translator/first source is created. The translator/assignment can be used for any new filter that uses the original source as output. Branches will then have the same assignment.

virtual void vtkBranchExtentTranslator::SetAssignedNumberOfPieces ( int ) [virtual]

This unstructured extent/piece is store here for the users convenience. It is not used internally. The intent was to let an "assignment" be made when the translator/first source is created. The translator/assignment can be used for any new filter that uses the original source as output. Branches will then have the same assignment.

virtual int vtkBranchExtentTranslator::GetAssignedNumberOfPieces ( ) [virtual]

This unstructured extent/piece is store here for the users convenience. It is not used internally. The intent was to let an "assignment" be made when the translator/first source is created. The translator/assignment can be used for any new filter that uses the original source as output. Branches will then have the same assignment.

Member Data Documentation

vtkImageData* vtkBranchExtentTranslator::OriginalSource [protected]

Definition at line 83 of file vtkBranchExtentTranslator.h.

int vtkBranchExtentTranslator::AssignedPiece [protected]

Definition at line 84 of file vtkBranchExtentTranslator.h.

int vtkBranchExtentTranslator::AssignedNumberOfPieces [protected]

Definition at line 85 of file vtkBranchExtentTranslator.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkBranchExtentTranslator.h
Generated on Mon Mar 25 01:15:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBrownianPoints Class Reference

assign random vector to points. More...

#include <vtkBrownianPoints.h>

Inheritance diagram for vtkBrownianPoints:

[legend]
Collaboration diagram for vtkBrownianPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBrownianPoints, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMinimumSpeed (float)
virtual float | GetMinimumSpeed ()
virtual void | SetMaximumSpeed (float)
virtual float | GetMaximumSpeed ()

Static Public Methods

vtkBrownianPoints * | New ()

Protected Methods

vtkBrownianPoints ()
~vtkBrownianPoints ()
void | Execute ()

Protected Attributes

float | MinimumSpeed
float | MaximumSpeed

Detailed Description

assign random vector to points.

Date:
2002/01/22 15:29:08
Revision:
1.31

vtkBrownianPoints is a filter object that assigns a random vector (i.e., magnitude and direction) to each point. The minimum and maximum speed values can be controlled by the user.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Martin, Ken (21%)
  • Miller, Jim (5%)
Tests:
vtkBrownianPoints (Tests)

Definition at line 43 of file vtkBrownianPoints.h.

Constructor & Destructor Documentation

vtkBrownianPoints::vtkBrownianPoints ( ) [protected]

vtkBrownianPoints::~vtkBrownianPoints ( ) [inline, protected]

Definition at line 66 of file vtkBrownianPoints.h.

Member Function Documentation

vtkBrownianPoints* vtkBrownianPoints::New ( ) [static]

Create instance with minimum speed 0.0, maximum speed 1.0.

Reimplemented from vtkDataSetSource.

vtkBrownianPoints::vtkTypeRevisionMacro | ( | vtkBrownianPoints | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkBrownianPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkBrownianPoints::SetMinimumSpeed ( float ) [virtual]

Set the minimum speed value.

virtual float vtkBrownianPoints::GetMinimumSpeed ( ) [virtual]

Set the minimum speed value.

virtual void vtkBrownianPoints::SetMaximumSpeed ( float ) [virtual]

Set the maximum speed value.

virtual float vtkBrownianPoints::GetMaximumSpeed ( ) [virtual]

Set the maximum speed value.

void vtkBrownianPoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkBrownianPoints::MinimumSpeed [protected]

Definition at line 69 of file vtkBrownianPoints.h.

float vtkBrownianPoints::MaximumSpeed [protected]

Definition at line 70 of file vtkBrownianPoints.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkBrownianPoints.h
Generated on Mon Mar 25 01:15:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkButterflySubdivisionFilter Class Reference

generate a subdivision surface using the Butterfly Scheme. More...

#include <vtkButterflySubdivisionFilter.h>

Inheritance diagram for vtkButterflySubdivisionFilter:

[legend]
Collaboration diagram for vtkButterflySubdivisionFilter:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkButterflySubdivisionFilter, vtkInterpolatingSubdivisionFilter)
vtkButterflySubdivisionFilter * New ()

Protected Methods

vtkButterflySubdivisionFilter ()
~vtkButterflySubdivisionFilter ()

Detailed Description

generate a subdivision surface using the Butterfly Scheme.

Date:
2002/01/22 15:29:09
Revision:
1.13

vtkButterflySubdivisionFilter is an interpolating subdivision scheme that creates four new triangles for each triangle in the mesh. The user can specify the NumberOfSubdivisions. This filter implements the 8-point butterfly scheme described in: Zorin, D., Schroder, P., and Sweldens, W., "Interpolating Subdivisions for Meshes with Arbitrary Topology," Computer Graphics Proceedings, Annual Conference Series, 1996, ACM SIGGRAPH, pp.189-192. This scheme improves previous butterfly subdivisions with special treatment of vertices with valence other than 6.

Currently, the filter only operates on triangles. Users should use the vtkTriangleFilter to triangulate meshes that contain polygons or triangle strips.

The filter interpolates point data using the same scheme. New triangles created at a subdivision step will have the cell data of their parent cell.

See also:
vtkInterpolatingSubdivisionFilter vtkLinearSubdivisionFilter
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (89%)
  • Henderson, Amy (8%)
Tests:
vtkButterflySubdivisionFilter (Tests)

Definition at line 62 of file vtkButterflySubdivisionFilter.h.

Constructor & Destructor Documentation

vtkButterflySubdivisionFilter::vtkButterflySubdivisionFilter ( ) [inline, protected]

Definition at line 72 of file vtkButterflySubdivisionFilter.h.

vtkButterflySubdivisionFilter::~vtkButterflySubdivisionFilter ( ) [inline, protected]

Definition at line 73 of file vtkButterflySubdivisionFilter.h.

Member Function Documentation

vtkButterflySubdivisionFilter* vtkButterflySubdivisionFilter::New ( ) [static]

Construct object with NumberOfSubdivisions set to 1.

Reimplemented from vtkPolyDataSource.

vtkButterflySubdivisionFilter::vtkTypeRevisionMacro | ( | vtkButterflySubdivisionFilter | ,
 |  | vtkInterpolatingSubdivisionFilter |
 | ) |

Reimplemented from vtkInterpolatingSubdivisionFilter.

The documentation for this class was generated from the following file:
  • Graphics/vtkButterflySubdivisionFilter.h
Generated on Mon Mar 25 01:15:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkButtonSource Class Reference

create a ellipsoidal-shaped button. More...

#include <vtkButtonSource.h>

Inheritance diagram for vtkButtonSource:

[legend]
Collaboration diagram for vtkButtonSource:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkButtonSource, vtkPolyDataSource)
virtual void | SetWidth (float)
virtual float | GetWidth ()
virtual void | SetHeight (float)
virtual float | GetHeight ()
virtual void | SetDepth (float)
virtual float | GetDepth ()
virtual void | SetRadialRatio (float)
virtual float | GetRadialRatio ()
virtual void | SetCircumferentialResolution (int)
virtual int | GetCircumferentialResolution ()
virtual void | SetTextureResolution (int)
virtual int | GetTextureResolution ()
virtual void | SetShoulderResolution (int)
virtual int | GetShoulderResolution ()
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetTextureStyle (int)
virtual int | GetTextureStyle ()
void | SetTextureStyleToFitImage ()
void | SetTextureStyleToProportional ()
virtual void | SetTextureDimensions (int, int)
void | SetTextureDimensions (int[2])
virtual int * | GetTextureDimensions ()
virtual void | GetTextureDimensions (int &, int &)
virtual void | GetTextureDimensions (int[2])
virtual void | SetShoulderTextureCoordinate (float, float)
void | SetShoulderTextureCoordinate (float[2])
virtual float * | GetShoulderTextureCoordinate ()
virtual void | GetShoulderTextureCoordinate (float &, float &)
virtual void | GetShoulderTextureCoordinate (float[2])
virtual void | SetTwoSided (int)
virtual int | GetTwoSided ()
virtual void | TwoSidedOn ()
virtual void | TwoSidedOff ()

Static Public Methods

vtkButtonSource * | New ()

Protected Methods

vtkButtonSource ()
~vtkButtonSource ()
void | Execute ()

Protected Attributes

float | Width
float | Height
float | Depth
int | CircumferentialResolution
int | TextureResolution
int | ShoulderResolution
float | Origin [3]
float | ShoulderTextureCoordinate [2]
float | RadialRatio
int | TextureStyle
int | TextureDimensions [2]
int | TwoSided

Detailed Description

create a ellipsoidal-shaped button.

Date:
2002/02/11 17:47:41
Revision:
1.1

vtkButtonSource creates a ellipsoidal shaped button with texture coordinates suitable for application of a texture map. This provides a way to make nice looking 3D buttons. The buttons are represented as vtkPolyData that includes texture coordinates and normals. The button lies in the x-y plane.

To use this class you must define the major and minor axes lengths of an ellipsoid (expressed as width (x), height (y) and depth (z)). The button has a rectangular mesh region in the center with texture coordinates that range smoothly from (0,1). (This flat region is called the texture region.) The outer, curved portion of the button (called the shoulder) has texture coordinates set to a user specified value (by default (0,0). (This results in coloring the button curve the same color as the (s,t) location of the texture map.) The resolution in the radial direction, the texture region, and the shoulder region must also be set. The button can be moved by specifying an origin.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (99%)
Tests:
vtkButtonSource (Tests)

Definition at line 57 of file vtkButtonSource.h.

Constructor & Destructor Documentation

vtkButtonSource::vtkButtonSource ( ) [protected]

vtkButtonSource::~vtkButtonSource ( ) [inline, protected]

Definition at line 164 of file vtkButtonSource.h.

Member Function Documentation

void vtkButtonSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkButtonSource::vtkTypeRevisionMacro | ( | vtkButtonSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

vtkButtonSource* vtkButtonSource::New ( ) [static]

Construct a circular button with depth 10% of its height.

Reimplemented from vtkPolyDataSource.

virtual void vtkButtonSource::SetWidth ( float ) [virtual]

Set/Get the width of the button (the x-ellipsoid axis length * 2).

virtual float vtkButtonSource::GetWidth ( ) [virtual]

Set/Get the width of the button (the x-ellipsoid axis length * 2).

virtual void vtkButtonSource::SetHeight ( float ) [virtual]

Set/Get the height of the button (the y-ellipsoid axis length * 2).

virtual float vtkButtonSource::GetHeight ( ) [virtual]

Set/Get the height of the button (the y-ellipsoid axis length * 2).

virtual void vtkButtonSource::SetDepth ( float ) [virtual]

Set/Get the depth of the button (the z-eliipsoid axis length).

virtual float vtkButtonSource::GetDepth ( ) [virtual]

Set/Get the depth of the button (the z-eliipsoid axis length).

virtual void vtkButtonSource::SetRadialRatio ( float ) [virtual]

Set/Get the radial ratio. This is the measure of the radius of the outer ellipsoid to the inner ellipsoid of the button. The outer ellipsoid is the boundary of the button defined by the height and width. The inner ellipsoid circumscribes the texture region. Larger RadialRatio's cause the button to be more rounded (and the texture region to be smaller); smaller ratios produce sharply curved shoulders with a larger texture region.

virtual float vtkButtonSource::GetRadialRatio ( ) [virtual]

Set/Get the radial ratio. This is the measure of the radius of the outer ellipsoid to the inner ellipsoid of the button. The outer ellipsoid is the boundary of the button defined by the height and width. The inner ellipsoid circumscribes the texture region. Larger RadialRatio's cause the button to be more rounded (and the texture region to be smaller); smaller ratios produce sharply curved shoulders with a larger texture region.

virtual void vtkButtonSource::SetCircumferentialResolution ( int ) [virtual]

Specify the resolution of the button in the circumferential direction.

virtual int vtkButtonSource::GetCircumferentialResolution ( ) [virtual]

Specify the resolution of the button in the circumferential direction.

virtual void vtkButtonSource::SetTextureResolution ( int ) [virtual]

Specify the resolution of the texture in the radial direction in the texture region.

virtual int vtkButtonSource::GetTextureResolution ( ) [virtual]

Specify the resolution of the texture in the radial direction in the texture region.

virtual void vtkButtonSource::SetShoulderResolution ( int ) [virtual]

Specify the resolution of the texture in the radial direction in the shoulder region.

virtual int vtkButtonSource::GetShoulderResolution ( ) [virtual]

Specify the resolution of the texture in the radial direction in the shoulder region.

virtual void vtkButtonSource::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the origin of the button.

virtual void vtkButtonSource::SetOrigin ( float [3] ) [virtual]

Specify a point defining the origin of the button.

virtual float* vtkButtonSource::GetOrigin ( ) [virtual]

Specify a point defining the origin of the button.

virtual void vtkButtonSource::GetOrigin ( float data[3] ) [virtual]

Specify a point defining the origin of the button.

virtual void vtkButtonSource::SetTextureStyle ( int ) [virtual]

Set/Get the style of the texture region: whether to size it according to the x-y dimensions of the texture, or whether to make the texture region proportional to the width/height of the button. When using the texture dimensions, the texture region is adjusted to be circumscribed by the elliptical, inner shape of the button. (The inner elliptical radius is controled by the RadiusRatio.)

virtual int vtkButtonSource::GetTextureStyle ( ) [virtual]

Set/Get the style of the texture region: whether to size it according to the x-y dimensions of the texture, or whether to make the texture region proportional to the width/height of the button. When using the texture dimensions, the texture region is adjusted to be circumscribed by the elliptical, inner shape of the button. (The inner elliptical radius is controled by the RadiusRatio.)

void vtkButtonSource::SetTextureStyleToFitImage ( ) [inline]

Set/Get the style of the texture region: whether to size it according to the x-y dimensions of the texture, or whether to make the texture region proportional to the width/height of the button. When using the texture dimensions, the texture region is adjusted to be circumscribed by the elliptical, inner shape of the button. (The inner elliptical radius is controled by the RadiusRatio.)

Definition at line 133 of file vtkButtonSource.h.

void vtkButtonSource::SetTextureStyleToProportional ( ) [inline]

Set/Get the style of the texture region: whether to size it according to the x-y dimensions of the texture, or whether to make the texture region proportional to the width/height of the button. When using the texture dimensions, the texture region is adjusted to be circumscribed by the elliptical, inner shape of the button. (The inner elliptical radius is controled by the RadiusRatio.)

Definition at line 135 of file vtkButtonSource.h.

virtual void vtkButtonSource::SetTextureDimensions | ( | int | ,
 |  | int |
 | ) | [virtual]

Set/get the texture dimension. This needs to be set if the texture style is set to fit the image.

void vtkButtonSource::SetTextureDimensions ( int [2] )

Set/get the texture dimension. This needs to be set if the texture style is set to fit the image.

virtual int* vtkButtonSource::GetTextureDimensions ( ) [virtual]

Set/get the texture dimension. This needs to be set if the texture style is set to fit the image.

virtual void vtkButtonSource::GetTextureDimensions | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Set/get the texture dimension. This needs to be set if the texture style is set to fit the image.

virtual void vtkButtonSource::GetTextureDimensions ( int [2] ) [virtual]

Set/get the texture dimension. This needs to be set if the texture style is set to fit the image.

virtual void vtkButtonSource::SetShoulderTextureCoordinate | ( | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the default texture coordinate to set the shoulder region to.

void vtkButtonSource::SetShoulderTextureCoordinate ( float [2] )

Set/Get the default texture coordinate to set the shoulder region to.

virtual float* vtkButtonSource::GetShoulderTextureCoordinate ( ) [virtual]

Set/Get the default texture coordinate to set the shoulder region to.

virtual void vtkButtonSource::GetShoulderTextureCoordinate | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the default texture coordinate to set the shoulder region to.

virtual void vtkButtonSource::GetShoulderTextureCoordinate ( float [2] ) [virtual]

Set/Get the default texture coordinate to set the shoulder region to.

virtual void vtkButtonSource::SetTwoSided ( int ) [virtual]

Indicate whether the button is single or double sided. A double sided button can be viewed from two sides...it looks sort of like a "pill." A single-sided button is meant to viewed from a single side; it looks like a "clam-shell."

virtual int vtkButtonSource::GetTwoSided ( ) [virtual]

Indicate whether the button is single or double sided. A double sided button can be viewed from two sides...it looks sort of like a "pill." A single-sided button is meant to viewed from a single side; it looks like a "clam-shell."

virtual void vtkButtonSource::TwoSidedOn ( ) [virtual]

Indicate whether the button is single or double sided. A double sided button can be viewed from two sides...it looks sort of like a "pill." A single-sided button is meant to viewed from a single side; it looks like a "clam-shell."

virtual void vtkButtonSource::TwoSidedOff ( ) [virtual]

Indicate whether the button is single or double sided. A double sided button can be viewed from two sides...it looks sort of like a "pill." A single-sided button is meant to viewed from a single side; it looks like a "clam-shell."

void vtkButtonSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkButtonSource::Width [protected]

Definition at line 168 of file vtkButtonSource.h.

float vtkButtonSource::Height [protected]

Definition at line 169 of file vtkButtonSource.h.

float vtkButtonSource::Depth [protected]

Definition at line 170 of file vtkButtonSource.h.

int vtkButtonSource::CircumferentialResolution [protected]

Definition at line 172 of file vtkButtonSource.h.

int vtkButtonSource::TextureResolution [protected]

Definition at line 173 of file vtkButtonSource.h.

int vtkButtonSource::ShoulderResolution [protected]

Definition at line 174 of file vtkButtonSource.h.

float vtkButtonSource::Origin[3] [protected]

Definition at line 176 of file vtkButtonSource.h.

float vtkButtonSource::ShoulderTextureCoordinate[2] [protected]

Definition at line 177 of file vtkButtonSource.h.

float vtkButtonSource::RadialRatio [protected]

Definition at line 179 of file vtkButtonSource.h.

int vtkButtonSource::TextureStyle [protected]

Definition at line 180 of file vtkButtonSource.h.

int vtkButtonSource::TextureDimensions[2] [protected]

Definition at line 181 of file vtkButtonSource.h.

int vtkButtonSource::TwoSided [protected]

Definition at line 182 of file vtkButtonSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkButtonSource.h
Generated on Mon Mar 25 01:15:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkByteSwap Class Reference

perform machine dependent byte swapping. More...

#include <vtkByteSwap.h>

Inheritance diagram for vtkByteSwap:

[legend]
Collaboration diagram for vtkByteSwap:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkByteSwap, vtkObject)

Static Public Methods

vtkByteSwap * | New ()
void | SwapVoidRange (void *buffer, int numWords, int wordSize)
void | Swap2LE (short *s)
void | Swap2LE (unsigned short *s)
void | Swap4LE (char *c)
void | Swap4LE (float *p)
void | Swap4LE (int *i)
void | Swap4LE (unsigned long *i)
void | Swap4LE (long *i)
void | Swap8LE (char *c)
void | Swap8LE (double *d)
void | Swap2LERange (char *c, int num)
void | Swap2LERange (short *i, int num)
void | Swap4LERange (char *c, int num)
void | Swap4LERange (unsigned char *c, int num)
void | Swap4LERange (float *p, int num)
void | Swap4LERange (int *i, int num)
void | Swap4LERange (unsigned long *i, int num)
void | Swap8LERange (char *c, int num)
void | Swap8LERange (double *d, int num)
void | Swap2BE (short *s)
void | Swap2BE (unsigned short *s)
void | Swap4BE (char *c)
void | Swap4BE (float *p)
void | Swap4BE (int *i)
void | Swap4BE (unsigned long *i)
void | Swap8BE (char *c)
void | Swap8BE (double *d)
void | Swap2BERange (char *c, int num)
void | Swap2BERange (short *i, int num)
void | Swap4BERange (char *c, int num)
void | Swap4BERange (float *p, int num)
void | Swap4BERange (int *i, int num)
void | Swap4BERange (unsigned long *i, int num)
void | Swap8BERange (char *c, int num)
void | Swap8BERange (double *d, int num)
void | SwapWrite2BERange (char *c, int num, FILE *fp)
void | SwapWrite2BERange (short *i, int num, FILE *fp)
void | SwapWrite4BERange (char *c, int num, FILE *fp)
void | SwapWrite4BERange (float *p, int num, FILE *fp)
void | SwapWrite4BERange (int *i, int num, FILE *fp)
void | SwapWrite4BERange (unsigned long *i, int num, FILE *fp)
void | SwapWrite8BERange (char *c, int num, FILE *fp)
void | SwapWrite8BERange (double *d, int num, FILE *fp)
void | SwapWrite2BERange (char *c, int num, ostream *fp)
void | SwapWrite2BERange (short *i, int num, ostream *fp)
void | SwapWrite4BERange (char *c, int num, ostream *fp)
void | SwapWrite4BERange (float *p, int num, ostream *fp)
void | SwapWrite4BERange (int *i, int num, ostream *fp)
void | SwapWrite4BERange (unsigned long *i, int num, ostream *fp)
void | SwapWrite8BERange (char *c, int num, ostream *fp)
void | SwapWrite8BERange (double *d, int num, ostream *fp)

Protected Methods

vtkByteSwap ()
~vtkByteSwap ()

Detailed Description

perform machine dependent byte swapping.

Date:
2002/01/22 15:25:11
Revision:
1.51

vtkByteSwap is used by other classes to perform machine dependent byte swapping. Byte swapping is often used when reading or writing binary files.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Lee, Jeff (45%)
  • Martin, Ken (27%)
  • Blue, Rusty (8%)
  • Lorensen, Bill (6%)
  • Schroeder, Will (5%)
Tests:
vtkByteSwap (Tests)

Definition at line 45 of file vtkByteSwap.h.

Constructor & Destructor Documentation

vtkByteSwap::vtkByteSwap ( ) [inline, protected]

Definition at line 232 of file vtkByteSwap.h.

vtkByteSwap::~vtkByteSwap ( ) [inline, protected]

Definition at line 233 of file vtkByteSwap.h.

Member Function Documentation

vtkByteSwap* vtkByteSwap::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkByteSwap::vtkTypeRevisionMacro | ( | vtkByteSwap | ,
 |  | vtkObject |
 | ) |

void vtkByteSwap::Swap2LE ( short * s ) [static]

Swap 2 byte word to be LE.

void vtkByteSwap::Swap2LE ( unsigned short * s ) [static]

Swap 2 byte word to be LE.

void vtkByteSwap::Swap4LE ( char * c ) [static]

Swap four byte word to be LE.

Referenced by Swap4LE().

void vtkByteSwap::Swap4LE ( float * p ) [inline, static]

Swap four byte word to be LE.

Definition at line 60 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LE ( int * i ) [inline, static]

Swap four byte word to be LE.

Definition at line 61 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LE ( unsigned long * i ) [inline, static]

Swap four byte word to be LE.

Definition at line 62 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LE ( long * i ) [inline, static]

Swap four byte word to be LE.

Definition at line 63 of file vtkByteSwap.h.

void vtkByteSwap::Swap8LE ( char * c ) [static]

Swap eight byte word to be LE. Currently implemented for doubles, but will be necessary for 64bit integers? 16bit chars?

Referenced by Swap8LE().

void vtkByteSwap::Swap8LE ( double * d ) [inline, static]

Swap eight byte word to be LE. Currently implemented for doubles, but will be necessary for 64bit integers? 16bit chars?

Definition at line 70 of file vtkByteSwap.h.

void vtkByteSwap::Swap2LERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to LE. Num is the number of two byte words to swap.

Referenced by Swap2LERange().

void vtkByteSwap::Swap2LERange | ( | short * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to LE. Num is the number of two byte words to swap.

Definition at line 77 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to be LE. Num is the number of four byte words to swap.

Referenced by Swap4LERange().

void vtkByteSwap::Swap4LERange | ( | unsigned char * | c,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be LE. Num is the number of four byte words to swap.

Definition at line 85 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LERange | ( | float * | p,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be LE. Num is the number of four byte words to swap.

Definition at line 87 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LERange | ( | int * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be LE. Num is the number of four byte words to swap.

Definition at line 89 of file vtkByteSwap.h.

void vtkByteSwap::Swap4LERange | ( | unsigned long * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be LE. Num is the number of four byte words to swap.

Definition at line 91 of file vtkByteSwap.h.

void vtkByteSwap::Swap8LERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to be LE. Num is the number of eight byte words to swap. Currently implemented for doubles...

Referenced by Swap8LERange().

void vtkByteSwap::Swap8LERange | ( | double * | d,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be LE. Num is the number of eight byte words to swap. Currently implemented for doubles...

Definition at line 99 of file vtkByteSwap.h.

void vtkByteSwap::Swap2BE ( short * s ) [static]

Swap 2 byte word to BE.

void vtkByteSwap::Swap2BE ( unsigned short * s ) [static]

Swap 2 byte word to BE.

void vtkByteSwap::Swap4BE ( char * c ) [static]

For writing, swap four byte word to be BE. For reading, swap four byte word from BE to machine's internal representation.

Referenced by Swap4BE().

void vtkByteSwap::Swap4BE ( float * p ) [inline, static]

For writing, swap four byte word to be BE. For reading, swap four byte word from BE to machine's internal representation.

Definition at line 113 of file vtkByteSwap.h.

void vtkByteSwap::Swap4BE ( int * i ) [inline, static]

For writing, swap four byte word to be BE. For reading, swap four byte word from BE to machine's internal representation.

Definition at line 114 of file vtkByteSwap.h.

void vtkByteSwap::Swap4BE ( unsigned long * i ) [inline, static]

For writing, swap four byte word to be BE. For reading, swap four byte word from BE to machine's internal representation.

Definition at line 115 of file vtkByteSwap.h.

void vtkByteSwap::Swap8BE ( char * c ) [static]

For writing, swap eight byte word to be BE. For reading, swap eight byte word from BE to machine's internal representation.

Referenced by Swap8BE().

void vtkByteSwap::Swap8BE ( double * d ) [inline, static]

For writing, swap eight byte word to be BE. For reading, swap eight byte word from BE to machine's internal representation.

Definition at line 122 of file vtkByteSwap.h.

void vtkByteSwap::Swap2BERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap.

Referenced by Swap2BERange().

void vtkByteSwap::Swap2BERange | ( | short * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap.

Definition at line 129 of file vtkByteSwap.h.

void vtkByteSwap::Swap4BERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to be BE. Num is the number of four byte words to swap.

Referenced by Swap4BERange().

void vtkByteSwap::Swap4BERange | ( | float * | p,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be BE. Num is the number of four byte words to swap.

Definition at line 137 of file vtkByteSwap.h.

void vtkByteSwap::Swap4BERange | ( | int * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be BE. Num is the number of four byte words to swap.

Definition at line 139 of file vtkByteSwap.h.

void vtkByteSwap::Swap4BERange | ( | unsigned long * | i,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be BE. Num is the number of four byte words to swap.

Definition at line 141 of file vtkByteSwap.h.

void vtkByteSwap::Swap8BERange | ( | char * | c,
 |  | int | num
 | ) | [static]

Swap bunch of bytes to be BE. Num is the number of eight byte words to swap.

Referenced by Swap8BERange().

void vtkByteSwap::Swap8BERange | ( | double * | d,
 |  | int | num
 | ) | [inline, static]

Swap bunch of bytes to be BE. Num is the number of eight byte words to swap.

Definition at line 154 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite2BERange | ( | char * | c,
 |  | int | num,
 |  | FILE * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Referenced by SwapWrite2BERange().

void vtkByteSwap::SwapWrite2BERange | ( | short * | i,
 |  | int | num,
 |  | FILE * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Definition at line 163 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | char * | c,
 |  | int | num,
 |  | FILE * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Referenced by SwapWrite4BERange().

void vtkByteSwap::SwapWrite4BERange | ( | float * | p,
 |  | int | num,
 |  | FILE * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Definition at line 172 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | int * | i,
 |  | int | num,
 |  | FILE * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Definition at line 174 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | unsigned long * | i,
 |  | int | num,
 |  | FILE * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Definition at line 176 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite8BERange | ( | char * | c,
 |  | int | num,
 |  | FILE * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of eight byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory. Implemented for doubles for now.

Referenced by SwapWrite8BERange().

void vtkByteSwap::SwapWrite8BERange | ( | double * | d,
 |  | int | num,
 |  | FILE * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to file to prevent having to keep the swapped copy in memory.

Definition at line 188 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite2BERange | ( | char * | c,
 |  | int | num,
 |  | ostream * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

void vtkByteSwap::SwapWrite2BERange | ( | short * | i,
 |  | int | num,
 |  | ostream * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of two byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

Definition at line 197 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | char * | c,
 |  | int | num,
 |  | ostream * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

void vtkByteSwap::SwapWrite4BERange | ( | float * | p,
 |  | int | num,
 |  | ostream * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

Definition at line 206 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | int * | i,
 |  | int | num,
 |  | ostream * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

Definition at line 208 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite4BERange | ( | unsigned long * | i,
 |  | int | num,
 |  | ostream * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

Definition at line 210 of file vtkByteSwap.h.

void vtkByteSwap::SwapWrite8BERange | ( | char * | c,
 |  | int | num,
 |  | ostream * | fp
 | ) | [static]

Swap bunch of bytes to BE. Num is the number of eight byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

void vtkByteSwap::SwapWrite8BERange | ( | double * | d,
 |  | int | num,
 |  | ostream * | fp
 | ) | [inline, static]

Swap bunch of bytes to BE. Num is the number of four byte words to swap. The results are written out to stream to prevent having to keep the swapped copy in memory.

Definition at line 222 of file vtkByteSwap.h.

void vtkByteSwap::SwapVoidRange | ( | void * | buffer,
 |  | int | numWords,
 |  | int | wordSize
 | ) | [static]

Swaps the bytes of a buffer. Uses an arbitrary word size, but assumes the word size is divisible by two.

The documentation for this class was generated from the following file:
  • Common/vtkByteSwap.h
Generated on Mon Mar 25 01:15:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBYUReader Class Reference

read MOVIE.BYU polygon files. More...

#include <vtkBYUReader.h>

Inheritance diagram for vtkBYUReader:

[legend]
Collaboration diagram for vtkBYUReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBYUReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetGeometryFileName (const char *)
virtual char * | GetGeometryFileName ()
virtual void | SetDisplacementFileName (const char *)
virtual char * | GetDisplacementFileName ()
virtual void | SetScalarFileName (const char *)
virtual char * | GetScalarFileName ()
virtual void | SetTextureFileName (const char *)
virtual char * | GetTextureFileName ()
virtual void | SetReadDisplacement (int)
virtual int | GetReadDisplacement ()
virtual void | ReadDisplacementOn ()
virtual void | ReadDisplacementOff ()
virtual void | SetReadScalar (int)
virtual int | GetReadScalar ()
virtual void | ReadScalarOn ()
virtual void | ReadScalarOff ()
virtual void | SetReadTexture (int)
virtual int | GetReadTexture ()
virtual void | ReadTextureOn ()
virtual void | ReadTextureOff ()
virtual void | SetPartNumber (int)
virtual int | GetPartNumber ()

Static Public Methods

vtkBYUReader * | New ()

Protected Methods

vtkBYUReader ()
~vtkBYUReader ()
void | Execute ()
int | ComputeDivisionExtents (vtkDataObject *output, int idx, int numDivisions)
void | ReadGeometryFile (FILE *fp, int &numPts)
void | ReadDisplacementFile (int numPts)
void | ReadScalarFile (int numPts)
void | ReadTextureFile (int numPts)

Protected Attributes

char * | GeometryFileName
char * | DisplacementFileName
char * | ScalarFileName
char * | TextureFileName
int | ReadDisplacement
int | ReadScalar
int | ReadTexture
int | PartNumber

Detailed Description

read MOVIE.BYU polygon files.

Date:
2002/01/22 15:38:09
Revision:
1.41

vtkBYUReader is a source object that reads MOVIE.BYU polygon files. These files consist of a geometry file (.g), a scalar file (.s), a displacement or vector file (.d), and a 2D texture coordinate file (.t).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Martin, Ken (9%)
  • Miller, Jim (7%)
Examples:
vtkBYUReader (Examples)
Tests:
vtkBYUReader (Tests)

Definition at line 48 of file vtkBYUReader.h.

Constructor & Destructor Documentation

vtkBYUReader::vtkBYUReader ( ) [protected]

vtkBYUReader::~vtkBYUReader ( ) [protected]

Member Function Documentation

vtkBYUReader* vtkBYUReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkBYUReader::vtkTypeRevisionMacro | ( | vtkBYUReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkBYUReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkBYUReader::SetGeometryFileName ( const char * ) [virtual]

Specify name of geometry FileName.

virtual char* vtkBYUReader::GetGeometryFileName ( ) [virtual]

Specify name of geometry FileName.

virtual void vtkBYUReader::SetDisplacementFileName ( const char * ) [virtual]

Specify name of displacement FileName.

virtual char* vtkBYUReader::GetDisplacementFileName ( ) [virtual]

Specify name of displacement FileName.

virtual void vtkBYUReader::SetScalarFileName ( const char * ) [virtual]

Specify name of scalar FileName.

virtual char* vtkBYUReader::GetScalarFileName ( ) [virtual]

Specify name of scalar FileName.

virtual void vtkBYUReader::SetTextureFileName ( const char * ) [virtual]

Specify name of texture coordinates FileName.

virtual char* vtkBYUReader::GetTextureFileName ( ) [virtual]

Specify name of texture coordinates FileName.

virtual void vtkBYUReader::SetReadDisplacement ( int ) [virtual]

Turn on/off the reading of the displacement file.

virtual int vtkBYUReader::GetReadDisplacement ( ) [virtual]

Turn on/off the reading of the displacement file.

virtual void vtkBYUReader::ReadDisplacementOn ( ) [virtual]

Turn on/off the reading of the displacement file.

virtual void vtkBYUReader::ReadDisplacementOff ( ) [virtual]

Turn on/off the reading of the displacement file.

virtual void vtkBYUReader::SetReadScalar ( int ) [virtual]

Turn on/off the reading of the scalar file.

virtual int vtkBYUReader::GetReadScalar ( ) [virtual]

Turn on/off the reading of the scalar file.

virtual void vtkBYUReader::ReadScalarOn ( ) [virtual]

Turn on/off the reading of the scalar file.

virtual void vtkBYUReader::ReadScalarOff ( ) [virtual]

Turn on/off the reading of the scalar file.

virtual void vtkBYUReader::SetReadTexture ( int ) [virtual]

Turn on/off the reading of the texture coordinate file. Specify name of geometry FileName.

virtual int vtkBYUReader::GetReadTexture ( ) [virtual]

Turn on/off the reading of the texture coordinate file. Specify name of geometry FileName.

virtual void vtkBYUReader::ReadTextureOn ( ) [virtual]

Turn on/off the reading of the texture coordinate file. Specify name of geometry FileName.

virtual void vtkBYUReader::ReadTextureOff ( ) [virtual]

Turn on/off the reading of the texture coordinate file. Specify name of geometry FileName.

virtual void vtkBYUReader::SetPartNumber ( int ) [virtual]

Set/Get the part number to be read.

virtual int vtkBYUReader::GetPartNumber ( ) [virtual]

Set/Get the part number to be read.

void vtkBYUReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkBYUReader::ComputeDivisionExtents | ( | vtkDataObject * | output,
 |  | int | idx,
 |  | int | numDivisions
 | ) | [protected]

void vtkBYUReader::ReadGeometryFile | ( | FILE * | fp,
 |  | int & | numPts
 | ) | [protected]

void vtkBYUReader::ReadDisplacementFile ( int numPts ) [protected]

void vtkBYUReader::ReadScalarFile ( int numPts ) [protected]

void vtkBYUReader::ReadTextureFile ( int numPts ) [protected]

Member Data Documentation

char* vtkBYUReader::GeometryFileName [protected]

Definition at line 117 of file vtkBYUReader.h.

char* vtkBYUReader::DisplacementFileName [protected]

Definition at line 118 of file vtkBYUReader.h.

char* vtkBYUReader::ScalarFileName [protected]

Definition at line 119 of file vtkBYUReader.h.

char* vtkBYUReader::TextureFileName [protected]

Definition at line 120 of file vtkBYUReader.h.

int vtkBYUReader::ReadDisplacement [protected]

Definition at line 121 of file vtkBYUReader.h.

int vtkBYUReader::ReadScalar [protected]

Definition at line 122 of file vtkBYUReader.h.

int vtkBYUReader::ReadTexture [protected]

Definition at line 123 of file vtkBYUReader.h.

int vtkBYUReader::PartNumber [protected]

Definition at line 124 of file vtkBYUReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkBYUReader.h
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkBYUWriter Class Reference

write MOVIE.BYU files. More...

#include <vtkBYUWriter.h>

Inheritance diagram for vtkBYUWriter:

[legend]
Collaboration diagram for vtkBYUWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkBYUWriter, vtkPolyDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetGeometryFileName (const char *)
virtual char * | GetGeometryFileName ()
virtual void | SetDisplacementFileName (const char *)
virtual char * | GetDisplacementFileName ()
virtual void | SetScalarFileName (const char *)
virtual char * | GetScalarFileName ()
virtual void | SetTextureFileName (const char *)
virtual char * | GetTextureFileName ()
virtual void | SetWriteDisplacement (int)
virtual int | GetWriteDisplacement ()
virtual void | WriteDisplacementOn ()
virtual void | WriteDisplacementOff ()
virtual void | SetWriteScalar (int)
virtual int | GetWriteScalar ()
virtual void | WriteScalarOn ()
virtual void | WriteScalarOff ()
virtual void | SetWriteTexture (int)
virtual int | GetWriteTexture ()
virtual void | WriteTextureOn ()
virtual void | WriteTextureOff ()

Static Public Methods

vtkBYUWriter * | New ()

Protected Methods

vtkBYUWriter ()
~vtkBYUWriter ()
void | WriteData ()
void | WriteGeometryFile (FILE *fp, int numPts)
void | WriteDisplacementFile (int numPts)
void | WriteScalarFile (int numPts)
void | WriteTextureFile (int numPts)

Protected Attributes

char * | GeometryFileName
char * | DisplacementFileName
char * | ScalarFileName
char * | TextureFileName
int | WriteDisplacement
int | WriteScalar
int | WriteTexture

Detailed Description

write MOVIE.BYU files.

Date:
2002/01/22 15:38:09
Revision:
1.40

vtkBYUWriter writes MOVIE.BYU polygonal files. These files consist of a geometry file (.g), a scalar file (.s), a displacement or vector file (.d), and a 2D texture coordinate file (.t). These files must be specified to the object, the appropriate boolean variables must be true, and data must be available from the input for the files to be written. WARNING: this writer does not currently write triangle strips. Use vtkTriangleFilter to convert strips to triangles.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Miller, Jim (9%)
  • Martin, Ken (7%)
  • Lorensen, Bill (5%)
Tests:
vtkBYUWriter (Tests)

Definition at line 51 of file vtkBYUWriter.h.

Constructor & Destructor Documentation

vtkBYUWriter::vtkBYUWriter ( ) [protected]

vtkBYUWriter::~vtkBYUWriter ( ) [protected]

Member Function Documentation

vtkBYUWriter* vtkBYUWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkPolyDataWriter.

vtkBYUWriter::vtkTypeRevisionMacro | ( | vtkBYUWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkBYUWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPolyDataWriter.

virtual void vtkBYUWriter::SetGeometryFileName ( const char * ) [virtual]

Specify the name of the geometry file to write.

virtual char* vtkBYUWriter::GetGeometryFileName ( ) [virtual]

Specify the name of the geometry file to write.

virtual void vtkBYUWriter::SetDisplacementFileName ( const char * ) [virtual]

Specify the name of the displacement file to write.

virtual char* vtkBYUWriter::GetDisplacementFileName ( ) [virtual]

Specify the name of the displacement file to write.

virtual void vtkBYUWriter::SetScalarFileName ( const char * ) [virtual]

Specify the name of the scalar file to write.

virtual char* vtkBYUWriter::GetScalarFileName ( ) [virtual]

Specify the name of the scalar file to write.

virtual void vtkBYUWriter::SetTextureFileName ( const char * ) [virtual]

Specify the name of the texture file to write.

virtual char* vtkBYUWriter::GetTextureFileName ( ) [virtual]

Specify the name of the texture file to write.

virtual void vtkBYUWriter::SetWriteDisplacement ( int ) [virtual]

Turn on/off writing the displacement file.

virtual int vtkBYUWriter::GetWriteDisplacement ( ) [virtual]

Turn on/off writing the displacement file.

virtual void vtkBYUWriter::WriteDisplacementOn ( ) [virtual]

Turn on/off writing the displacement file.

virtual void vtkBYUWriter::WriteDisplacementOff ( ) [virtual]

Turn on/off writing the displacement file.

virtual void vtkBYUWriter::SetWriteScalar ( int ) [virtual]

Turn on/off writing the scalar file.

virtual int vtkBYUWriter::GetWriteScalar ( ) [virtual]

Turn on/off writing the scalar file.

virtual void vtkBYUWriter::WriteScalarOn ( ) [virtual]

Turn on/off writing the scalar file.

virtual void vtkBYUWriter::WriteScalarOff ( ) [virtual]

Turn on/off writing the scalar file.

virtual void vtkBYUWriter::SetWriteTexture ( int ) [virtual]

Turn on/off writing the texture file.

virtual int vtkBYUWriter::GetWriteTexture ( ) [virtual]

Turn on/off writing the texture file.

virtual void vtkBYUWriter::WriteTextureOn ( ) [virtual]

Turn on/off writing the texture file.

virtual void vtkBYUWriter::WriteTextureOff ( ) [virtual]

Turn on/off writing the texture file.

void vtkBYUWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

void vtkBYUWriter::WriteGeometryFile | ( | FILE * | fp,
 |  | int | numPts
 | ) | [protected]

void vtkBYUWriter::WriteDisplacementFile ( int numPts ) [protected]

void vtkBYUWriter::WriteScalarFile ( int numPts ) [protected]

void vtkBYUWriter::WriteTextureFile ( int numPts ) [protected]

Member Data Documentation

char* vtkBYUWriter::GeometryFileName [protected]

Definition at line 110 of file vtkBYUWriter.h.

char* vtkBYUWriter::DisplacementFileName [protected]

Definition at line 111 of file vtkBYUWriter.h.

char* vtkBYUWriter::ScalarFileName [protected]

Definition at line 112 of file vtkBYUWriter.h.

char* vtkBYUWriter::TextureFileName [protected]

Definition at line 113 of file vtkBYUWriter.h.

int vtkBYUWriter::WriteDisplacement [protected]

Definition at line 114 of file vtkBYUWriter.h.

int vtkBYUWriter::WriteScalar [protected]

Definition at line 115 of file vtkBYUWriter.h.

int vtkBYUWriter::WriteTexture [protected]

Definition at line 116 of file vtkBYUWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkBYUWriter.h
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCallbackCommand Class Reference

generic callback. More...

#include <vtkCallbackCommand.h>

Inheritance diagram for vtkCallbackCommand:

[legend]
Collaboration diagram for vtkCallbackCommand:

[legend]
List of all members.

Public Methods

void | SetClientData (void *cd)
void * | GetClientData ()
void | SetCallback (void(*f)(vtkObject *, unsigned long, void *, void *))
void | SetClientDataDeleteCallback (void(*f)(void *))
void | Execute (vtkObject *caller, unsigned long event, void *callData)

Static Public Methods

vtkCallbackCommand * | New ()

Public Attributes

void * | ClientData
void(* | Callback )(vtkObject *, unsigned long, void *, void *)
void(* | ClientDataDeleteCallback )(void *)

Protected Methods

vtkCallbackCommand ()
~vtkCallbackCommand ()

Detailed Description

generic callback.

Date:
2002/01/22 15:25:12
Revision:
1.3
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (95%)

Definition at line 37 of file vtkCallbackCommand.h.

Constructor & Destructor Documentation

vtkCallbackCommand::vtkCallbackCommand ( ) [protected]

vtkCallbackCommand::~vtkCallbackCommand ( ) [protected]

Member Function Documentation

vtkCallbackCommand* vtkCallbackCommand::New ( ) [inline, static]

Definition at line 40 of file vtkCallbackCommand.h.

void vtkCallbackCommand::SetClientData ( void * cd ) [inline]

Definition at line 43 of file vtkCallbackCommand.h.

void* vtkCallbackCommand::GetClientData ( ) [inline]

Definition at line 45 of file vtkCallbackCommand.h.

void vtkCallbackCommand::SetCallback ( void(* f)(vtkObject *, unsigned long, void *, void *) ) [inline]

Definition at line 47 of file vtkCallbackCommand.h.

void vtkCallbackCommand::SetClientDataDeleteCallback ( void(* f)(void *) ) [inline]

Definition at line 49 of file vtkCallbackCommand.h.

void vtkCallbackCommand::Execute | ( | vtkObject * | caller,
 |  | unsigned long | event,
 |  | void * | callData
 | ) | [virtual]

Reimplemented from vtkCommand.

Member Data Documentation

void* vtkCallbackCommand::ClientData

Definition at line 54 of file vtkCallbackCommand.h.

void(* vtkCallbackCommand::Callback)(vtkObject *, unsigned long, void *, void *)

void(* vtkCallbackCommand::ClientDataDeleteCallback)(void *)

The documentation for this class was generated from the following file:
  • Common/vtkCallbackCommand.h
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Camera Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Camera:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS Vector | pos
Vector target
float | bank
float | lens
vtkCamera * aCamera

Member Data Documentation

VTK_LIST_FIELDS Vector Camera::pos

Definition at line 79 of file vtk3DS.h.

Vector Camera::target

Definition at line 80 of file vtk3DS.h.

float Camera::bank

Definition at line 81 of file vtk3DS.h.

float Camera::lens

Definition at line 82 of file vtk3DS.h.

vtkCamera* Camera::aCamera

Definition at line 83 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:15:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCamera Class Reference

a virtual camera for 3D rendering. More...

#include <vtkCamera.h>

Inheritance diagram for vtkCamera:

[legend]
Collaboration diagram for vtkCamera:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkCamera, vtkObject)
void | OrthogonalizeViewUp ()
void | Dolly (double distance)
void | Roll (double angle)
void | Azimuth (double angle)
void | Yaw (double angle)
void | Elevation (double angle)
void | Pitch (double angle)
void | Zoom (double factor)
void | SetObliqueAngles (double alpha, double beta)
void | ApplyTransform (vtkTransform *t)
virtual void | Render (vtkRenderer *)
unsigned long | GetViewingRaysMTime ()
void | ViewingRaysModified ()
void | GetFrustumPlanes (float aspect, float planes[24])
void | ComputeViewPlaneNormal ()
vtkMatrix4x4 * GetCameraLightTransformMatrix ()
virtual void | UpdateViewport (vtkRenderer *vtkNotUsed(ren))
vtkTransform * GetViewTransformObject ()
void | SetPosition (double x, double y, double z)
void | SetPosition (const double a[3])
void | SetPosition (const float a[3])
virtual double * | GetPosition ()
virtual void | GetPosition (double &, double &, double &)
virtual void | GetPosition (double[3])
void | GetPosition (float a[3])
void | SetFocalPoint (double x, double y, double z)
void | SetFocalPoint (const double a[3])
void | SetFocalPoint (const float a[3])
virtual double * | GetFocalPoint ()
virtual void | GetFocalPoint (double &, double &, double &)
virtual void | GetFocalPoint (double[3])
void | GetFocalPoint (float a[3])
void | SetViewUp (double vx, double vy, double vz)
void | SetViewUp (const double a[3])
void | SetViewUp (const float a[3])
virtual double * | GetViewUp ()
virtual void | GetViewUp (double &, double &, double &)
virtual void | GetViewUp (double[3])
void | GetViewUp (float a[3])
void | SetDistance (double)
virtual double | GetDistance ()
virtual double * | GetDirectionOfProjection ()
virtual void | GetDirectionOfProjection (double &, double &, double &)
virtual void | GetDirectionOfProjection (double[3])
void | GetDirectionOfProjection (float a[3])
void | SetRoll (double angle)
double | GetRoll ()
void | SetParallelProjection (int flag)
virtual int | GetParallelProjection ()
virtual void | ParallelProjectionOn ()
virtual void | ParallelProjectionOff ()
void | SetViewAngle (double angle)
virtual double | GetViewAngle ()
void | SetParallelScale (double scale)
virtual double | GetParallelScale ()
void | SetClippingRange (double near, double far)
void | SetClippingRange (const double a[2])
void | SetClippingRange (const float a[2])
virtual double * | GetClippingRange ()
virtual void | GetClippingRange (double &, double &)
virtual void | GetClippingRange (double[2])
void | GetClippingRange (float a[2])
void | SetThickness (double)
virtual double | GetThickness ()
void | SetWindowCenter (double x, double y)
virtual double * | GetWindowCenter ()
virtual void | GetWindowCenter (double &, double &)
virtual void | GetWindowCenter (double[2])
virtual double * | GetViewPlaneNormal ()
virtual void | GetViewPlaneNormal (double &, double &, double &)
virtual void | GetViewPlaneNormal (double[3])
void | GetViewPlaneNormal (float a[3])
void | SetViewShear (double dxdz, double dydz, double center)
void | SetViewShear (double d[3])
virtual double * | GetViewShear ()
virtual void | GetViewShear (double &, double &, double &)
virtual void | GetViewShear (double[3])
virtual void | SetEyeAngle (double)
virtual double | GetEyeAngle ()
virtual void | SetFocalDisk (double)
virtual double | GetFocalDisk ()
vtkMatrix4x4 * GetViewTransformMatrix ()
vtkMatrix4x4 * | GetPerspectiveTransformMatrix (double aspect, double nearz, double farz)
vtkMatrix4x4 * | GetCompositePerspectiveTransformMatrix (double aspect, double nearz, double farz)
float * | GetOrientation ()
float * | GetOrientationWXYZ ()
void | SetViewPlaneNormal (double x, double y, double z)
void | SetViewPlaneNormal (const double a[3])
void | SetViewPlaneNormal (const float a[3])
vtkMatrix4x4 & GetViewTransform ()
vtkMatrix4x4 & | GetPerspectiveTransform (double aspect, double nearz, double farz)
vtkMatrix4x4 & | GetCompositePerspectiveTransform (double aspect, double nearz, double farz)

Static Public Methods

vtkCamera * | New ()

Protected Methods

vtkCamera ()
~vtkCamera ()
void | ComputeDistance ()
void | ComputeViewTransform ()
void | ComputePerspectiveTransform (double aspect, double nearz, double farz)
void | ComputeCompositePerspectiveTransform (double aspect, double nearz, double farz)
void | ComputeCameraLightTransform ()

Protected Attributes

double | WindowCenter [2]
double | ObliqueAngles [2]
double | FocalPoint [3]
double | Position [3]
double | ViewUp [3]
double | ViewAngle
double | ClippingRange [2]
double | EyeAngle
int | ParallelProjection
double | ParallelScale
int | Stereo
int | LeftEye
double | Thickness
double | Distance
double | DirectionOfProjection [3]
double | ViewPlaneNormal [3]
double | ViewShear [3]
vtkTransform * ViewTransform
vtkPerspectiveTransform * PerspectiveTransform
vtkPerspectiveTransform * Transform
vtkTransform * CameraLightTransform
double | FocalDisk
vtkTimeStamp ViewingRaysMTime

Detailed Description

a virtual camera for 3D rendering.

Date:
2002/03/20 21:12:52
Revision:
1.83

vtkCamera is a virtual camera for 3D rendering. It provides methods to position and orient the view point and focal point. Convenience methods for moving about the focal point also are provided. More complex methods allow the manipulation of the computer graphics model including view up vector, clipping planes, and camera perspective.

See also:
vtkPerspectiveTransform
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (49%)
  • Gobbi, David (29%)
  • Schroeder, Will (7%)
Examples:
vtkCamera (Examples)
Tests:
vtkCamera (Tests)

Definition at line 55 of file vtkCamera.h.

Constructor & Destructor Documentation

vtkCamera::vtkCamera ( ) [protected]

vtkCamera::~vtkCamera ( ) [protected]

Member Function Documentation

void vtkCamera::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkCamera::vtkTypeRevisionMacro | ( | vtkCamera | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkMesaCamera, and vtkOpenGLCamera.

vtkCamera* vtkCamera::New ( ) [static]

Construct camera instance with its focal point at the origin, and position=(0,0,1). The view up is along the y-axis, view angle is 30 degrees, and the clipping range is (.1,1000).

Reimplemented from vtkObject.

Reimplemented in vtkMesaCamera, and vtkOpenGLCamera.

void vtkCamera::SetPosition | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

void vtkCamera::SetPosition ( const double a[3] ) [inline]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

Definition at line 70 of file vtkCamera.h.

void vtkCamera::SetPosition ( const float a[3] ) [inline]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

Definition at line 72 of file vtkCamera.h.

virtual double* vtkCamera::GetPosition ( ) [virtual]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

virtual void vtkCamera::GetPosition | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

virtual void vtkCamera::GetPosition ( double [3] ) [virtual]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

void vtkCamera::GetPosition ( float a[3] ) [inline]

Set/Get the position of the camera in world coordinates. The default position is (0,0,1).

Definition at line 75 of file vtkCamera.h.

void vtkCamera::SetFocalPoint | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

void vtkCamera::SetFocalPoint ( const double a[3] ) [inline]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

Definition at line 84 of file vtkCamera.h.

void vtkCamera::SetFocalPoint ( const float a[3] ) [inline]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

Definition at line 86 of file vtkCamera.h.

virtual double* vtkCamera::GetFocalPoint ( ) [virtual]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

virtual void vtkCamera::GetFocalPoint | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

virtual void vtkCamera::GetFocalPoint ( double [3] ) [virtual]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

void vtkCamera::GetFocalPoint ( float a[3] ) [inline]

Set/Get the focal of the camera in world coordinates. The default focal point is the origin.

Definition at line 89 of file vtkCamera.h.

void vtkCamera::SetViewUp | ( | double | vx,
 |  | double | vy,
 |  | double | vz
 | ) |

Set/Get the view up direction for the camera. The default is (0,1,0).

void vtkCamera::SetViewUp ( const double a[3] ) [inline]

Set/Get the view up direction for the camera. The default is (0,1,0).

Definition at line 98 of file vtkCamera.h.

void vtkCamera::SetViewUp ( const float a[3] ) [inline]

Set/Get the view up direction for the camera. The default is (0,1,0).

Definition at line 100 of file vtkCamera.h.

virtual double* vtkCamera::GetViewUp ( ) [virtual]

Set/Get the view up direction for the camera. The default is (0,1,0).

virtual void vtkCamera::GetViewUp | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Set/Get the view up direction for the camera. The default is (0,1,0).

virtual void vtkCamera::GetViewUp ( double [3] ) [virtual]

Set/Get the view up direction for the camera. The default is (0,1,0).

void vtkCamera::GetViewUp ( float a[3] ) [inline]

Set/Get the view up direction for the camera. The default is (0,1,0).

Definition at line 103 of file vtkCamera.h.

void vtkCamera::OrthogonalizeViewUp ( )

Recompute the ViewUp vector to force it to be perpendicular to camera->focalpoint vector. Unless you are going to use Yaw or Azimuth on the camera, there is no need to do this.

void vtkCamera::SetDistance ( double )

Move the focal point so that it is the specified distance from the camera position. This distance must be positive.

virtual double vtkCamera::GetDistance ( ) [virtual]

Move the focal point so that it is the specified distance from the camera position. This distance must be positive.

virtual double* vtkCamera::GetDirectionOfProjection ( ) [virtual]

Get the vector in the direction from the camera position to the focal point. This is usually the opposite of the ViewPlaneNormal, the vector perpendicular to the screen, unless the view is oblique.

virtual void vtkCamera::GetDirectionOfProjection | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the vector in the direction from the camera position to the focal point. This is usually the opposite of the ViewPlaneNormal, the vector perpendicular to the screen, unless the view is oblique.

virtual void vtkCamera::GetDirectionOfProjection ( double [3] ) [virtual]

Get the vector in the direction from the camera position to the focal point. This is usually the opposite of the ViewPlaneNormal, the vector perpendicular to the screen, unless the view is oblique.

void vtkCamera::GetDirectionOfProjection ( float a[3] ) [inline]

Get the vector in the direction from the camera position to the focal point. This is usually the opposite of the ViewPlaneNormal, the vector perpendicular to the screen, unless the view is oblique.

Definition at line 125 of file vtkCamera.h.

void vtkCamera::Dolly ( double distance )

Move the position of the camera along the direction of projection. Moving towards the focal point (e.g., greater than 1) is a dolly-in, moving away from the focal point (e.g., less than 1) is a dolly-out.

void vtkCamera::SetRoll ( double angle )

Set the roll angle of the camera about the direction of projection.

double vtkCamera::GetRoll ( )

Set the roll angle of the camera about the direction of projection.

void vtkCamera::Roll ( double angle )

Rotate the camera about the direction of projection.

void vtkCamera::Azimuth ( double angle )

Rotate the camera about the view up vector centered at the focal point. Note that the view up vector is not necessarily perpendicular to the direction of projection.

void vtkCamera::Yaw ( double angle )

Rotate the focal point about the view up vector centered at the camera's position. Note that the view up vector is not necessarily perpendicular to the direction of projection.

void vtkCamera::Elevation ( double angle )

Rotate the camera about the cross product of the direction of projection and the view up vector centered on the focal point.

void vtkCamera::Pitch ( double angle )

Rotate the focal point about the cross product of the view up vector and the direction of projection, centered at the camera's position.

void vtkCamera::SetParallelProjection ( int flag )

Set/Get the value of the ParallelProjection instance variable. This determines if the camera should do a perspective or parallel projection.

virtual int vtkCamera::GetParallelProjection ( ) [virtual]

Set/Get the value of the ParallelProjection instance variable. This determines if the camera should do a perspective or parallel projection.

virtual void vtkCamera::ParallelProjectionOn ( ) [virtual]

Set/Get the value of the ParallelProjection instance variable. This determines if the camera should do a perspective or parallel projection.

virtual void vtkCamera::ParallelProjectionOff ( ) [virtual]

Set/Get the value of the ParallelProjection instance variable. This determines if the camera should do a perspective or parallel projection.

void vtkCamera::SetViewAngle ( double angle )

Set/Get the camera view angle, which is the angular height of the camera view measured in degrees. The default angle is 30 degrees. This method has no effect in parallel projection mode. The formula for setting the angle up for perfect perspective viewing is: angle = 2*atan((h/2)/d) where h is the height of the RenderWindow (measured in mm by holding a ruler up to your screen) and d is the distance from your eyes to the screen.

virtual double vtkCamera::GetViewAngle ( ) [virtual]

Set/Get the camera view angle, which is the angular height of the camera view measured in degrees. The default angle is 30 degrees. This method has no effect in parallel projection mode. The formula for setting the angle up for perfect perspective viewing is: angle = 2*atan((h/2)/d) where h is the height of the RenderWindow (measured in mm by holding a ruler up to your screen) and d is the distance from your eyes to the screen.

void vtkCamera::SetParallelScale ( double scale )

Set/Get the scaling used for a parallel projection, i.e. the height of the viewport in world-coordinate distances. The default is 1. Note that the "scale" parameter works as an "inverse scale" --- larger numbers produce smaller images. This method has no effect in perspective projection mode.

virtual double vtkCamera::GetParallelScale ( ) [virtual]

Set/Get the scaling used for a parallel projection, i.e. the height of the viewport in world-coordinate distances. The default is 1. Note that the "scale" parameter works as an "inverse scale" --- larger numbers produce smaller images. This method has no effect in perspective projection mode.

void vtkCamera::Zoom ( double factor )

In perspective mode, decrease the view angle by the specified factor. In parallel mode, decrease the parallel scale by the specified factor. A value greater than 1 is a zoom-in, a value less than 1 is a zoom-out.

void vtkCamera::SetClippingRange | ( | double | near,
 |  | double | far
 | ) |

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

void vtkCamera::SetClippingRange ( const double a[2] ) [inline]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

Definition at line 208 of file vtkCamera.h.

void vtkCamera::SetClippingRange ( const float a[2] ) [inline]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

Definition at line 210 of file vtkCamera.h.

virtual double* vtkCamera::GetClippingRange ( ) [virtual]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

virtual void vtkCamera::GetClippingRange | ( | double & | ,
 |  | double & |
 | ) | [virtual]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

virtual void vtkCamera::GetClippingRange ( double [2] ) [virtual]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

void vtkCamera::GetClippingRange ( float a[2] ) [inline]

Set/Get the location of the near and far clipping planes along the direction of projection. Both of these values must be positive. How the clipping planes are set can have a large impact on how well z-buffering works. In particular the front clipping plane can make a very big difference. Setting it to 0.01 when it really could be 1.0 can have a big impact on your z-buffer resolution farther away. The default clipping range is (0.1,1000).

Definition at line 213 of file vtkCamera.h.

void vtkCamera::SetThickness ( double )

Set the distance between clipping planes. This method adjusts the far clipping plane to be set a distance 'thickness' beyond the near clipping plane.

virtual double vtkCamera::GetThickness ( ) [virtual]

Set the distance between clipping planes. This method adjusts the far clipping plane to be set a distance 'thickness' beyond the near clipping plane.

void vtkCamera::SetWindowCenter | ( | double | x,
 |  | double | y
 | ) |

Set/Get the center of the window in viewport coordinates. The viewport coordinate range is ([-1,+1],[-1,+1]). This method is for if you have one window which consists of several viewports, or if you have several screens which you want to act together as one large screen.

virtual double* vtkCamera::GetWindowCenter ( ) [virtual]

Set/Get the center of the window in viewport coordinates. The viewport coordinate range is ([-1,+1],[-1,+1]). This method is for if you have one window which consists of several viewports, or if you have several screens which you want to act together as one large screen.

virtual void vtkCamera::GetWindowCenter | ( | double & | ,
 |  | double & |
 | ) | [virtual]

Set/Get the center of the window in viewport coordinates. The viewport coordinate range is ([-1,+1],[-1,+1]). This method is for if you have one window which consists of several viewports, or if you have several screens which you want to act together as one large screen.

virtual void vtkCamera::GetWindowCenter ( double [2] ) [virtual]

Set/Get the center of the window in viewport coordinates. The viewport coordinate range is ([-1,+1],[-1,+1]). This method is for if you have one window which consists of several viewports, or if you have several screens which you want to act together as one large screen.

void vtkCamera::SetObliqueAngles | ( | double | alpha,
 |  | double | beta
 | ) |

Get/Set the oblique viewing angles. The first angle, alpha, is the angle (measured from the horizontal) that rays along the direction of projection will follow once projected onto the 2D screen. The second angle, beta, is the angle between the view plane and the direction of projection. This creates a shear transform x' = x + dz*cos(alpha)/tan(beta), y' = dz*sin(alpha)/tan(beta) where dz is the distance of the point from the focal plane. The angles are (45,90) by default. Oblique projections commonly use (30,63.435).

void vtkCamera::ApplyTransform ( vtkTransform * t )

Apply a transform to the camera. The camera position, focal-point, and view-up are re-calulated using the transform's matrix to multiply the old points by the new transform.

virtual double* vtkCamera::GetViewPlaneNormal ( ) [virtual]

Get the ViewPlaneNormal. This vector will point opposite to the direction of projection, unless you have created an sheared output view using SetViewShear/SetObliqueAngles.

virtual void vtkCamera::GetViewPlaneNormal | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the ViewPlaneNormal. This vector will point opposite to the direction of projection, unless you have created an sheared output view using SetViewShear/SetObliqueAngles.

virtual void vtkCamera::GetViewPlaneNormal ( double [3] ) [virtual]

Get the ViewPlaneNormal. This vector will point opposite to the direction of projection, unless you have created an sheared output view using SetViewShear/SetObliqueAngles.

void vtkCamera::GetViewPlaneNormal ( float a[3] ) [inline]

Get the ViewPlaneNormal. This vector will point opposite to the direction of projection, unless you have created an sheared output view using SetViewShear/SetObliqueAngles.

Definition at line 256 of file vtkCamera.h.

void vtkCamera::SetViewShear | ( | double | dxdz,
 |  | double | dydz,
 |  | double | center
 | ) |

Set/get the shear transform of the viewing frustum. Parameters are dx/dz, dy/dz, and center. center is a factor that describes where to shear around. The distance dshear from the camera where no shear occurs is given by (dshear = center * FocalDistance).

void vtkCamera::SetViewShear ( double d[3] )

Set/get the shear transform of the viewing frustum. Parameters are dx/dz, dy/dz, and center. center is a factor that describes where to shear around. The distance dshear from the camera where no shear occurs is given by (dshear = center * FocalDistance).

virtual double* vtkCamera::GetViewShear ( ) [virtual]

Set/get the shear transform of the viewing frustum. Parameters are dx/dz, dy/dz, and center. center is a factor that describes where to shear around. The distance dshear from the camera where no shear occurs is given by (dshear = center * FocalDistance).

virtual void vtkCamera::GetViewShear | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Set/get the shear transform of the viewing frustum. Parameters are dx/dz, dy/dz, and center. center is a factor that describes where to shear around. The distance dshear from the camera where no shear occurs is given by (dshear = center * FocalDistance).

virtual void vtkCamera::GetViewShear ( double [3] ) [virtual]

Set/get the shear transform of the viewing frustum. Parameters are dx/dz, dy/dz, and center. center is a factor that describes where to shear around. The distance dshear from the camera where no shear occurs is given by (dshear = center * FocalDistance).

virtual void vtkCamera::SetEyeAngle ( double ) [virtual]

Set/Get the separation between eyes (in degrees). This is used when generating stereo images.

virtual double vtkCamera::GetEyeAngle ( ) [virtual]

Set/Get the separation between eyes (in degrees). This is used when generating stereo images.

virtual void vtkCamera::SetFocalDisk ( double ) [virtual]

Set the size of the cameras lens in world coordinates. This is only used when the renderer is doing focal depth rendering. When that is being done the size of the focal disk will effect how significant the depth effects will be.

virtual double vtkCamera::GetFocalDisk ( ) [virtual]

Set the size of the cameras lens in world coordinates. This is only used when the renderer is doing focal depth rendering. When that is being done the size of the focal disk will effect how significant the depth effects will be.

vtkMatrix4x4* vtkCamera::GetViewTransformMatrix ( ) [inline]

Return the matrix of the view transform.

Definition at line 290 of file vtkCamera.h.

vtkMatrix4x4* vtkCamera::GetPerspectiveTransformMatrix | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) |

Return the perspective transform matrix, which converts from camera coordinates to viewport coordinates. The 'aspect' is the width/height for the viewport, and the nearz and farz are the Z-buffer values that map to the near and far clipping planes. The viewport coordinates are in the range ([-1,+1],[-1,+1],[nearz,farz]).

vtkMatrix4x4* vtkCamera::GetCompositePerspectiveTransformMatrix | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) |

Return the concatenation of the ViewTransform and the PerspectiveTransform. This transform will convert world coordinates to viewport coordinates. The 'aspect' is the width/height for the viewport, and the nearz and farz are the Z-buffer values that map to the near and far clipping planes. The viewport coordinates are in the range ([-1,+1],[-1,+1],[nearz,farz]).

virtual void vtkCamera::Render ( vtkRenderer * ren ) [inline, virtual]

This method causes the camera to set up whatever is required for viewing the scene. This is actually handled by an subclass of vtkCamera, which is created through New()

Reimplemented in vtkMesaCamera, and vtkOpenGLCamera.

Definition at line 320 of file vtkCamera.h.

unsigned long vtkCamera::GetViewingRaysMTime ( )

Return the MTime that concerns recomputing the view rays of the camera.

void vtkCamera::ViewingRaysModified ( )

Mark that something has changed which requires the view rays to be recomputed.

void vtkCamera::GetFrustumPlanes | ( | float | aspect,
 |  | float | planes[24]
 | ) |

Get the plane equations that bound the view frustum. The plane normals point inward. The planes array contains six plane equations of the form (Ax+By+Cz+D=0), the first four values are (A,B,C,D) which repeats for each of the planes. The aspect of the viewport is needed to correctly compute the planes

float* vtkCamera::GetOrientation ( ) [inline]

Get the orientation of the camera.

Definition at line 339 of file vtkCamera.h.

float* vtkCamera::GetOrientationWXYZ ( ) [inline]

Get the orientation of the camera.

Definition at line 341 of file vtkCamera.h.

void vtkCamera::SetViewPlaneNormal | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

These methods have been deprecated. The view plane normal is automatically set from the DirectionOfProjection according to the ViewShear.

void vtkCamera::SetViewPlaneNormal ( const double a[3] ) [inline]

These methods have been deprecated. The view plane normal is automatically set from the DirectionOfProjection according to the ViewShear.

Definition at line 350 of file vtkCamera.h.

void vtkCamera::SetViewPlaneNormal ( const float a[3] ) [inline]

These methods have been deprecated. The view plane normal is automatically set from the DirectionOfProjection according to the ViewShear.

Definition at line 352 of file vtkCamera.h.

void vtkCamera::ComputeViewPlaneNormal ( )

This method is called automatically whenever necessary, it should never be used outside of vtkCamera.cxx.

vtkMatrix4x4* vtkCamera::GetCameraLightTransformMatrix ( )

Returns a transformation matrix for a coordinate frame attached to the camera, where the camera is located at (0, 0, 1) looking at the focal point at (0, 0, 0), with up being (0, 1, 0).

virtual void vtkCamera::UpdateViewport ( vtkRenderer *vtkNotUsed(ren) ) [inline, virtual]

Update the viewport

Definition at line 366 of file vtkCamera.h.

vtkMatrix4x4& vtkCamera::GetViewTransform ( ) [inline]

For legacy compatibility. Do not use.

Definition at line 371 of file vtkCamera.h.

vtkMatrix4x4& vtkCamera::GetPerspectiveTransform | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) | [inline]

For legacy compatibility. Do not use.

Definition at line 373 of file vtkCamera.h.

vtkMatrix4x4& vtkCamera::GetCompositePerspectiveTransform | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) | [inline]

For legacy compatibility. Do not use.

Definition at line 375 of file vtkCamera.h.

vtkTransform* vtkCamera::GetViewTransformObject ( ) [inline]

Definition at line 380 of file vtkCamera.h.

void vtkCamera::ComputeDistance ( ) [protected]

These methods should only be used within vtkCamera.cxx.

void vtkCamera::ComputeViewTransform ( ) [protected]

These methods should only be used within vtkCamera.cxx.

void vtkCamera::ComputePerspectiveTransform | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) | [protected]

These methods should only be used within vtkCamera.cxx.

void vtkCamera::ComputeCompositePerspectiveTransform | ( | double | aspect,
 |  | double | nearz,
 |  | double | farz
 | ) | [protected]

These methods should only be used within vtkCamera.cxx.

void vtkCamera::ComputeCameraLightTransform ( ) [protected]

These methods should only be used within vtkCamera.cxx.

Member Data Documentation

double vtkCamera::WindowCenter[2] [protected]

Definition at line 396 of file vtkCamera.h.

double vtkCamera::ObliqueAngles[2] [protected]

Definition at line 397 of file vtkCamera.h.

double vtkCamera::FocalPoint[3] [protected]

Definition at line 398 of file vtkCamera.h.

double vtkCamera::Position[3] [protected]

Definition at line 399 of file vtkCamera.h.

double vtkCamera::ViewUp[3] [protected]

Definition at line 400 of file vtkCamera.h.

double vtkCamera::ViewAngle [protected]

Definition at line 401 of file vtkCamera.h.

double vtkCamera::ClippingRange[2] [protected]

Definition at line 402 of file vtkCamera.h.

double vtkCamera::EyeAngle [protected]

Definition at line 403 of file vtkCamera.h.

int vtkCamera::ParallelProjection [protected]

Definition at line 404 of file vtkCamera.h.

double vtkCamera::ParallelScale [protected]

Definition at line 405 of file vtkCamera.h.

int vtkCamera::Stereo [protected]

Definition at line 406 of file vtkCamera.h.

int vtkCamera::LeftEye [protected]

Definition at line 407 of file vtkCamera.h.

double vtkCamera::Thickness [protected]

Definition at line 408 of file vtkCamera.h.

double vtkCamera::Distance [protected]

Definition at line 409 of file vtkCamera.h.

double vtkCamera::DirectionOfProjection[3] [protected]

Definition at line 410 of file vtkCamera.h.

double vtkCamera::ViewPlaneNormal[3] [protected]

Definition at line 411 of file vtkCamera.h.

double vtkCamera::ViewShear[3] [protected]

Definition at line 412 of file vtkCamera.h.

vtkTransform* vtkCamera::ViewTransform [protected]

Definition at line 414 of file vtkCamera.h.

vtkPerspectiveTransform* vtkCamera::PerspectiveTransform [protected]

Definition at line 415 of file vtkCamera.h.

vtkPerspectiveTransform* vtkCamera::Transform [protected]

Definition at line 416 of file vtkCamera.h.

vtkTransform* vtkCamera::CameraLightTransform [protected]

Definition at line 417 of file vtkCamera.h.

double vtkCamera::FocalDisk [protected]

Definition at line 419 of file vtkCamera.h.

vtkTimeStamp vtkCamera::ViewingRaysMTime [protected]

Definition at line 424 of file vtkCamera.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkCamera.h
Generated on Mon Mar 25 01:15:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCaptionActor2D Class Reference

draw text label associated with a point. More...

#include <vtkCaptionActor2D.h>

Inheritance diagram for vtkCaptionActor2D:

[legend]
Collaboration diagram for vtkCaptionActor2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCaptionActor2D, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ShallowCopy (vtkProp *prop)
virtual void | ReleaseGraphicsResources (vtkWindow *)
virtual void | SetCaption (const char *)
virtual char * | GetCaption ()
virtual vtkCoordinate * | GetAttachmentPointCoordinate ()
virtual void | SetAttachmentPoint (float x[3])
virtual void | SetAttachmentPoint (float x, float y, float z)
virtual float * | GetAttachmentPoint ()
virtual void | SetBorder (int)
virtual int | GetBorder ()
virtual void | BorderOn ()
virtual void | BorderOff ()
virtual void | SetLeader (int)
virtual int | GetLeader ()
virtual void | LeaderOn ()
virtual void | LeaderOff ()
virtual void | SetThreeDimensionalLeader (int)
virtual int | GetThreeDimensionalLeader ()
virtual void | ThreeDimensionalLeaderOn ()
virtual void | ThreeDimensionalLeaderOff ()
virtual void | SetLeaderGlyph (vtkPolyData *)
virtual vtkPolyData * | GetLeaderGlyph ()
virtual void | SetLeaderGlyphSize (float)
virtual float | GetLeaderGlyphSize ()
virtual void | SetMaximumLeaderGlyphSize (int)
virtual int | GetMaximumLeaderGlyphSize ()
virtual void | SetPadding (int)
virtual int | GetPadding ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetJustification (int)
virtual int | GetJustification ()
void | SetJustificationToLeft ()
void | SetJustificationToCentered ()
void | SetJustificationToRight ()
virtual void | SetVerticalJustification (int)
virtual int | GetVerticalJustification ()
void | SetVerticalJustificationToBottom ()
void | SetVerticalJustificationToCentered ()
void | SetVerticalJustificationToTop ()
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *viewport)

Static Public Methods

vtkCaptionActor2D * | New ()

Protected Methods

vtkCaptionActor2D ()
~vtkCaptionActor2D ()

Protected Attributes

vtkCoordinate * AttachmentPointCoordinate
char * | Caption
int | Border
int | Leader
int | ThreeDimensionalLeader
float | LeaderGlyphSize
int | MaximumLeaderGlyphSize
vtkPolyData * LeaderGlyph
int | Padding
int | Bold
int | Italic
int | Shadow
int | FontFamily
int | Justification
int | VerticalJustification

Detailed Description

draw text label associated with a point.

Date:
2002/01/22 15:30:25
Revision:
1.7

vtkCaptionActor2D is a hybrid 2D/3D actor that is used to associate text with a point (the AttachmentPoint) in the scene. The caption can be drawn with a rectangular border and a leader connecting the caption to the attachment point. Optionally, the leader can be glyphed at its endpoint to create arrow heads or other indicators.

To use the caption actor, you normally specify the Position and Position2 coordinates (these are inherited from the vtkActor2D superclass). (Note that Position2 can be set using vtkActor2D's SetWidth() and SetHeight() methods.) Position and Position2 define the size of the caption, and a third point, the AttachmentPoint, defines a point that the caption is associated with. You must also define the caption text, font attributes, whether you want a border around the caption, and whether you want a leader from the caption to the attachment point. The color of the text is controlled with vtkActor2D's property. You also indicate whether you want the leader to be 2D or 3D. (2D leaders are always drawn over the underlying geometry. 3D leaders may be occluded by the geometry.) The leader may also be terminated by an optional glyph (e.g., arrow).

The trickiest part about using this class is setting Position, Position2, and AttachmentPoint correctly. These instance variables are vtkCoordinates, and can be set up in various ways. In default usage, the AttachmentPoint is defined in the world coordinate system, Position is the lower-left corner of the caption and relative to AttachmentPoint (defined in display coordaintes, i.e., pixels), and Position2 is relative to Position and is the upper-right corner (also in display coordinates). However, the user has full control over the coordinates, and can do things like place the caption in a fixed position in the renderer, with the leader moving with the AttachmentPoint.

See also:
vtkLegendBoxActor vtkTextMapper vtkScaledTextActor vtkTextMapper vtkCoordinate
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (98%)
Tests:
vtkCaptionActor2D (Tests)

Definition at line 81 of file vtkCaptionActor2D.h.

Constructor & Destructor Documentation

vtkCaptionActor2D::vtkCaptionActor2D ( ) [protected]

vtkCaptionActor2D::~vtkCaptionActor2D ( ) [protected]

Member Function Documentation

vtkCaptionActor2D::vtkTypeRevisionMacro | ( | vtkCaptionActor2D | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkCaptionActor2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkCaptionActor2D* vtkCaptionActor2D::New ( ) [static]

Creates an actor2D with the following defaults: position (0,0) (coordinate system is viewport); at layer 0.

Reimplemented from vtkActor2D.

virtual void vtkCaptionActor2D::SetCaption ( const char * ) [virtual]

Define the text to be placed in the caption. The text can be multiple lines (separated by "
").

virtual char* vtkCaptionActor2D::GetCaption ( ) [virtual]

Define the text to be placed in the caption. The text can be multiple lines (separated by "
").

virtual vtkCoordinate* vtkCaptionActor2D::GetAttachmentPointCoordinate ( ) [virtual]

Set/Get the attachment point for the caption. By default, the attachment point is defined in world coordinates, but this can be changed using vtkCoordinate methods.

virtual void vtkCaptionActor2D::SetAttachmentPoint ( float x[3] ) [virtual]

Set/Get the attachment point for the caption. By default, the attachment point is defined in world coordinates, but this can be changed using vtkCoordinate methods.

virtual void vtkCaptionActor2D::SetAttachmentPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [virtual]

Set/Get the attachment point for the caption. By default, the attachment point is defined in world coordinates, but this can be changed using vtkCoordinate methods.

virtual float* vtkCaptionActor2D::GetAttachmentPoint ( ) [virtual]

Set/Get the attachment point for the caption. By default, the attachment point is defined in world coordinates, but this can be changed using vtkCoordinate methods.

virtual void vtkCaptionActor2D::SetBorder ( int ) [virtual]

Enable/disable the placement of a border around the text.

virtual int vtkCaptionActor2D::GetBorder ( ) [virtual]

Enable/disable the placement of a border around the text.

virtual void vtkCaptionActor2D::BorderOn ( ) [virtual]

Enable/disable the placement of a border around the text.

virtual void vtkCaptionActor2D::BorderOff ( ) [virtual]

Enable/disable the placement of a border around the text.

virtual void vtkCaptionActor2D::SetLeader ( int ) [virtual]

Enable/disable drawing a "line" from the caption to the attachment point.

virtual int vtkCaptionActor2D::GetLeader ( ) [virtual]

Enable/disable drawing a "line" from the caption to the attachment point.

virtual void vtkCaptionActor2D::LeaderOn ( ) [virtual]

Enable/disable drawing a "line" from the caption to the attachment point.

virtual void vtkCaptionActor2D::LeaderOff ( ) [virtual]

Enable/disable drawing a "line" from the caption to the attachment point.

virtual void vtkCaptionActor2D::SetThreeDimensionalLeader ( int ) [virtual]

Indicate whether the leader is 2D (no hidden line) or 3D (z-buffered).

virtual int vtkCaptionActor2D::GetThreeDimensionalLeader ( ) [virtual]

Indicate whether the leader is 2D (no hidden line) or 3D (z-buffered).

virtual void vtkCaptionActor2D::ThreeDimensionalLeaderOn ( ) [virtual]

Indicate whether the leader is 2D (no hidden line) or 3D (z-buffered).

virtual void vtkCaptionActor2D::ThreeDimensionalLeaderOff ( ) [virtual]

Indicate whether the leader is 2D (no hidden line) or 3D (z-buffered).

virtual void vtkCaptionActor2D::SetLeaderGlyph ( vtkPolyData * ) [virtual]

Specify a glyph to be used as the leader "head". This could be something like an arrow or sphere. If not specified, no glyph is drawn.

virtual vtkPolyData* vtkCaptionActor2D::GetLeaderGlyph ( ) [virtual]

Specify a glyph to be used as the leader "head". This could be something like an arrow or sphere. If not specified, no glyph is drawn.

virtual void vtkCaptionActor2D::SetLeaderGlyphSize ( float ) [virtual]

Specify the relative size of the leader head. This is expressed as a fraction of the size (diagonal length) of the renderer. The leader head is automatically scaled so that window resize, zooming or other camera motion results in proportional changes in size to the leader glyph.

virtual float vtkCaptionActor2D::GetLeaderGlyphSize ( ) [virtual]

Specify the relative size of the leader head. This is expressed as a fraction of the size (diagonal length) of the renderer. The leader head is automatically scaled so that window resize, zooming or other camera motion results in proportional changes in size to the leader glyph.

virtual void vtkCaptionActor2D::SetMaximumLeaderGlyphSize ( int ) [virtual]

Specify the maximum size of the leader head (if any) in pixels. This is used in conjunction with LeaderGlyphSize to cap the maximum size of the LeaderGlyph.

virtual int vtkCaptionActor2D::GetMaximumLeaderGlyphSize ( ) [virtual]

Specify the maximum size of the leader head (if any) in pixels. This is used in conjunction with LeaderGlyphSize to cap the maximum size of the LeaderGlyph.

virtual void vtkCaptionActor2D::SetPadding ( int ) [virtual]

Set/Get the padding between the caption and the border. The value is specified in pixels.

virtual int vtkCaptionActor2D::GetPadding ( ) [virtual]

Set/Get the padding between the caption and the border. The value is specified in pixels.

virtual void vtkCaptionActor2D::SetBold ( int ) [virtual]

Enable/Disable bolding the caption.

virtual int vtkCaptionActor2D::GetBold ( ) [virtual]

Enable/Disable bolding the caption.

virtual void vtkCaptionActor2D::BoldOn ( ) [virtual]

Enable/Disable bolding the caption.

virtual void vtkCaptionActor2D::BoldOff ( ) [virtual]

Enable/Disable bolding the caption.

virtual void vtkCaptionActor2D::SetItalic ( int ) [virtual]

Enable/Disable italicizing the caption.

virtual int vtkCaptionActor2D::GetItalic ( ) [virtual]

Enable/Disable italicizing the caption.

virtual void vtkCaptionActor2D::ItalicOn ( ) [virtual]

Enable/Disable italicizing the caption.

virtual void vtkCaptionActor2D::ItalicOff ( ) [virtual]

Enable/Disable italicizing the caption.

virtual void vtkCaptionActor2D::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the caption. Shadows make the text easier to read.

virtual int vtkCaptionActor2D::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the caption. Shadows make the text easier to read.

virtual void vtkCaptionActor2D::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the caption. Shadows make the text easier to read.

virtual void vtkCaptionActor2D::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the caption. Shadows make the text easier to read.

virtual void vtkCaptionActor2D::SetFontFamily ( int ) [virtual]

Set/Get the font family for the caption. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkCaptionActor2D::GetFontFamily ( ) [virtual]

Set/Get the font family for the caption. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkCaptionActor2D::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the caption. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 187 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the caption. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 188 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the caption. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 189 of file vtkCaptionActor2D.h.

virtual void vtkCaptionActor2D::SetJustification ( int ) [virtual]

Set/Get the horizontal justification to left (default), centered, or right.

virtual int vtkCaptionActor2D::GetJustification ( ) [virtual]

Set/Get the horizontal justification to left (default), centered, or right.

void vtkCaptionActor2D::SetJustificationToLeft ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 197 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetJustificationToCentered ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 199 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetJustificationToRight ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 201 of file vtkCaptionActor2D.h.

virtual void vtkCaptionActor2D::SetVerticalJustification ( int ) [virtual]

Set/Get the vertical justification to bottom (default), middle, or top.

virtual int vtkCaptionActor2D::GetVerticalJustification ( ) [virtual]

Set/Get the vertical justification to bottom (default), middle, or top.

void vtkCaptionActor2D::SetVerticalJustificationToBottom ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 210 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetVerticalJustificationToCentered ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 212 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::SetVerticalJustificationToTop ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 214 of file vtkCaptionActor2D.h.

void vtkCaptionActor2D::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this scaled text actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor2D.

virtual void vtkCaptionActor2D::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

int vtkCaptionActor2D::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

int vtkCaptionActor2D::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

Definition at line 234 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::RenderOverlay ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

Member Data Documentation

vtkCoordinate* vtkCaptionActor2D::AttachmentPointCoordinate [protected]

Definition at line 243 of file vtkCaptionActor2D.h.

char* vtkCaptionActor2D::Caption [protected]

Definition at line 245 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Border [protected]

Definition at line 246 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Leader [protected]

Definition at line 247 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::ThreeDimensionalLeader [protected]

Definition at line 248 of file vtkCaptionActor2D.h.

float vtkCaptionActor2D::LeaderGlyphSize [protected]

Definition at line 249 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::MaximumLeaderGlyphSize [protected]

Definition at line 250 of file vtkCaptionActor2D.h.

vtkPolyData* vtkCaptionActor2D::LeaderGlyph [protected]

Definition at line 251 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Padding [protected]

Definition at line 253 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Bold [protected]

Definition at line 254 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Italic [protected]

Definition at line 255 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Shadow [protected]

Definition at line 256 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::FontFamily [protected]

Definition at line 257 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::Justification [protected]

Definition at line 258 of file vtkCaptionActor2D.h.

int vtkCaptionActor2D::VerticalJustification [protected]

Definition at line 259 of file vtkCaptionActor2D.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkCaptionActor2D.h
Generated on Mon Mar 25 01:16:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCardinalSpline Class Reference

computes an interpolating spline using a. More...

#include <vtkCardinalSpline.h>

Inheritance diagram for vtkCardinalSpline:

[legend]
Collaboration diagram for vtkCardinalSpline:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCardinalSpline, vtkSpline)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Compute ()
float | Evaluate (float t)

Static Public Methods

vtkCardinalSpline * | New ()

Protected Methods

vtkCardinalSpline ()
~vtkCardinalSpline ()
void | Fit1D (int n, float *x, float *y, float *w, float coefficients[][4], int leftConstraint, float leftValue, int rightConstraint, float rightValue)
void | FitClosed1D (int n, float *x, float *y, float *w, float coefficients[][4])

Detailed Description

computes an interpolating spline using a.

Date:
2002/01/22 15:28:00
Revision:
1.20
a Cardinal basis.

vtkCardinalSpline is a concrete implementation of vtkSpline using a Cardinal basis.

See also:
vtkSpline vtkKochanekSpline
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (90%)
Examples:
vtkCardinalSpline (Examples)
Tests:
vtkCardinalSpline (Tests)

Definition at line 48 of file vtkCardinalSpline.h.

Constructor & Destructor Documentation

vtkCardinalSpline::vtkCardinalSpline ( ) [protected]

vtkCardinalSpline::~vtkCardinalSpline ( ) [inline, protected]

Definition at line 64 of file vtkCardinalSpline.h.

Member Function Documentation

vtkCardinalSpline* vtkCardinalSpline::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkCardinalSpline::vtkTypeRevisionMacro | ( | vtkCardinalSpline | ,
 |  | vtkSpline |
 | ) |

Reimplemented from vtkSpline.

void vtkCardinalSpline::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSpline.

void vtkCardinalSpline::Compute ( ) [virtual]

Compute Cardinal Splines for each dependent variable

Reimplemented from vtkSpline.

float vtkCardinalSpline::Evaluate ( float t )

Evaluate a 1D cardinal spline.

void vtkCardinalSpline::Fit1D | ( | int | n,
 |  | float * | x,
 |  | float * | y,
 |  | float * | w,
 |  | float | coefficients[][4],
 |  | int | leftConstraint,
 |  | float | leftValue,
 |  | int | rightConstraint,
 |  | float | rightValue
 | ) | [protected]

void vtkCardinalSpline::FitClosed1D | ( | int | n,
 |  | float * | x,
 |  | float * | y,
 |  | float * | w,
 |  | float | coefficients[][4]
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Filtering/vtkCardinalSpline.h
Generated on Mon Mar 25 01:16:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCastToConcrete Class Reference

works around type-checking limitations. More...

#include <vtkCastToConcrete.h>

Inheritance diagram for vtkCastToConcrete:

[legend]
Collaboration diagram for vtkCastToConcrete:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCastToConcrete, vtkDataSetToDataSetFilter)

Static Public Methods

vtkCastToConcrete * | New ()

Protected Methods

vtkCastToConcrete ()
~vtkCastToConcrete ()
void | Execute ()
void | ExecuteInformation ()

Detailed Description

works around type-checking limitations.

Date:
2002/01/22 15:28:00
Revision:
1.31

vtkCastToConcrete is a filter that works around type-checking limitations in the filter classes. Some filters generate abstract types on output, and cannot be connected to the input of filters requiring a concrete input type. For example, vtkElevationFilter generates vtkDataSet for output, and cannot be connected to vtkDecimate, because vtkDecimate requires vtkPolyData as input. This is true even though (in this example) the input to vtkElevationFilter is of type vtkPolyData, and you know the output of vtkElevationFilter is the same type as its input.

vtkCastToConcrete performs run-time checking to insure that output type is of the right type. An error message will result if you try to cast an input type improperly. Otherwise, the filter performs the appropriate cast and returns the data.

Warning:
You must specify the input before you can get the output. Otherwise an error results.
See also:
vtkDataSetToDataSetFilter vtkPointSetToPointSetFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Martin, Ken (14%)
  • Lorensen, Bill (9%)
  • Kelly, Ann (5%)
Examples:
vtkCastToConcrete (Examples)
Tests:
vtkCastToConcrete (Tests)

Definition at line 64 of file vtkCastToConcrete.h.

Constructor & Destructor Documentation

vtkCastToConcrete::vtkCastToConcrete ( ) [inline, protected]

Definition at line 72 of file vtkCastToConcrete.h.

vtkCastToConcrete::~vtkCastToConcrete ( ) [inline, protected]

Definition at line 73 of file vtkCastToConcrete.h.

Member Function Documentation

vtkCastToConcrete* vtkCastToConcrete::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkCastToConcrete::vtkTypeRevisionMacro | ( | vtkCastToConcrete | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkCastToConcrete::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkCastToConcrete::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkDataSetToDataSetFilter.

The documentation for this class was generated from the following file:
  • Filtering/vtkCastToConcrete.h
Generated on Mon Mar 25 01:16:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCell Class Reference

abstract class to specify cell behavior. More...

#include <vtkCell.h>

Inheritance diagram for vtkCell:

[legend]
Collaboration diagram for vtkCell:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCell, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Initialize (int npts, vtkIdType *pts, vtkPoints *p)
virtual vtkCell * | MakeObject ()=0
virtual void | ShallowCopy (vtkCell *c)
virtual void | DeepCopy (vtkCell *c)
virtual int | GetCellType ()=0
virtual int | GetCellDimension ()=0
virtual int | IsLinear ()
virtual int | IsExplicitCell ()
vtkPoints * GetPoints ()
int | GetNumberOfPoints ()
virtual int | GetNumberOfEdges ()=0
virtual int | GetNumberOfFaces ()=0
vtkIdList * GetPointIds ()
vtkIdType | GetPointId (int ptId)
virtual vtkCell * | GetEdge (int edgeId)=0
virtual vtkCell * | GetFace (int faceId)=0
virtual int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)=0
virtual int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)=0
void | GetBounds (float bounds[6])
float * | GetBounds ()
float | GetLength2 ()
virtual int | GetParametricCenter (float pcoords[3])
virtual int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)=0
virtual void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)=0
virtual void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)=0
virtual void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)=0
virtual int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)=0
virtual void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)=0

Static Public Methods

char | HitBBox (float bounds[6], float origin[3], float dir[3], float coord[3], float &t)

Public Attributes

vtkPoints * Points
vtkIdList * PointIds

Protected Methods

vtkCell ()
~vtkCell ()

Protected Attributes

float | Bounds [6]

Detailed Description

abstract class to specify cell behavior.

Date:
2002/03/06 15:39:59
Revision:
1.75

vtkCell is an abstract class that specifies the interfaces for data cells. Data cells are simple topological elements like points, lines, polygons, and tetrahedra of which visualization datasets are composed. In some cases visualization datasets may explicitly represent cells (e.g., vtkPolyData, vtkUnstructuredGrid), and in some cases, the datasets are implicitly composed of cells (e.g., vtkStructuredPoints).

Warning:
The define VTK_CELL_SIZE is a parameter used to construct cells and provide a general guideline for controlling object execution. This parameter is not a hard boundary: you can create cells with more points.
See also:
vtkHexahedron vtkLine vtkPixel vtkPolyLine vtkPolyVertex vtkPolygon vtkQuad vtkTetra vtkTriangle vtkTriangleStrip vtkVertex vtkVoxel vtkWedge vtkPyramid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (68%)
  • Martin, Ken (6%)
  • Geveci, Berk (6%)
Tests:
vtkCell (Tests)

Definition at line 69 of file vtkCell.h.

Constructor & Destructor Documentation

vtkCell::vtkCell ( ) [protected]

vtkCell::~vtkCell ( ) [protected]

Member Function Documentation

vtkCell::vtkTypeRevisionMacro | ( | vtkCell | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkCell3D, vtkEmptyCell, vtkExplicitCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkNonLinearCell, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

void vtkCell::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkCell3D, vtkExplicitCell, and vtkNonLinearCell.

void vtkCell::Initialize | ( | int | npts,
 |  | vtkIdType * | pts,
 |  | vtkPoints * | p
 | ) |

Initialize cell from outside with point ids and point coordinates specified.

virtual vtkCell* vtkCell::MakeObject ( ) [pure virtual]

Create concrete copy of this cell. Initially, the copy is made by performing a ShallowCopy() operation.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual void vtkCell::ShallowCopy ( vtkCell * c ) [virtual]

Copy this cell by reference counting the internal data structures. This is safe if you want a "read-only" copy. If you modify the cell you might wish to use DeepCopy().

Reimplemented in vtkGenericCell.

virtual void vtkCell::DeepCopy ( vtkCell * c ) [virtual]

Copy this cell by completely copying internal data structures. This is slower but safer than ShallowCopy().

Reimplemented in vtkGenericCell.

virtual int vtkCell::GetCellType ( ) [pure virtual]

Return the type of cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::GetCellDimension ( ) [pure virtual]

Return the topological dimensional of the cell (0,1,2, or 3).

Reimplemented in vtkCell3D, vtkEmptyCell, vtkGenericCell, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::IsLinear ( ) [inline, virtual]

Non-linear cells require special treatment beyond the usual cell type and connectivity list information. Most cells in VTK are implicit cells.

Reimplemented in vtkGenericCell, and vtkNonLinearCell.

Definition at line 101 of file vtkCell.h.

virtual int vtkCell::IsExplicitCell ( ) [inline, virtual]

Explicit cells require additional representational information beyond the usual cell type and connectivity list information. Most cells in VTK are implicit cells.

Reimplemented in vtkExplicitCell.

Definition at line 106 of file vtkCell.h.

vtkPoints* vtkCell::GetPoints ( ) [inline]

Get the point coordinates for the cell.

Definition at line 109 of file vtkCell.h.

int vtkCell::GetNumberOfPoints ( ) [inline]

Return the number of points in the cell.

Definition at line 112 of file vtkCell.h.

Referenced by vtkTriangleStrip::GetNumberOfEdges(), vtkPolygon::GetNumberOfEdges(), and vtkCellArray::InsertNextCell().

virtual int vtkCell::GetNumberOfEdges ( ) [pure virtual]

Return the number of edges in the cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::GetNumberOfFaces ( ) [pure virtual]

Return the number of faces in the cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

vtkIdList* vtkCell::GetPointIds ( ) [inline]

Return the list of point ids defining the cell.

Definition at line 121 of file vtkCell.h.

vtkIdType vtkCell::GetPointId ( int ptId ) [inline]

For cell point i, return the actual point id.

Definition at line 124 of file vtkCell.h.

virtual vtkCell* vtkCell::GetEdge ( int edgeId ) [pure virtual]

Return the edge cell from the edgeId of the cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual vtkCell* vtkCell::GetFace ( int faceId ) [pure virtual]

Return the face cell from the faceId of the cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [pure virtual]

Given parametric coordinates of a point, return the closest cell boundary, and whether the point is inside or outside of the cell. The cell boundary is defined by a list of points (pts) that specify a face (3D cell), edge (2D cell), or vertex (1D cell). If the return value of the method is != 0, then the point is inside the cell.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [pure virtual]

Given a point x[3] return inside(=1) or outside(=0) cell; evaluate parametric coordinates, sub-cell id (!=0 only if cell is composite), distance squared of point x[3] to cell (in particular, the sub-cell indicated), closest point on cell to x[3] (unless closestPoint is null, in which case, the closest point and dist2 are not found), and interpolation weights in cell. (The number of weights is equal to the number of points defining the cell). Note: on rare occasions a -1 is returned from the method. This means that numerical error has occurred and all data returned from this method should be ignored. Also, inside/outside is determine parametrically. That is, a point is inside if it satisfies parametric limits. This can cause problems for cells of topological dimension 2 or less, since a point in 3D can project onto the cell within parametric limits but be "far" from the cell. Thus the value dist2 may be checked to determine true in/out.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual void vtkCell::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [pure virtual]

Determine global coordinate (x[3]) from subId and parametric coordinates. Also returns interpolation weights. (The number of weights is equal to the number of points in the cell.)

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual void vtkCell::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [pure virtual]

Generate contouring primitives. The scalar list cellScalars are scalar values at each cell point. The point locator is essentially a points list that merges points as they are inserted (i.e., prevents duplicates). Contouring primitives can be vertices, lines, or polygons. It is possible to interpolate point data along the edge by providing input and output point data - if outPd is NULL, then no interpolation is performed. Also, if the output cell data is non-NULL, the cell data from the contoured cell is passed to the generated contouring primitives. (Note: the CopyAllocate() method must be invoked on both the output cell and point data. The cellId refers to the cell from which the cell data is copied.)

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual void vtkCell::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | connectivity,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [pure virtual]

Cut (or clip) the cell based on the input cellScalars and the specified value. The output of the clip operation will be one or more cells of the same topological dimension as the original cell. The flag insideOut controls what part of the cell is considered inside - normally cell points whose scalar value is greater than "value" are considered inside. If insideOut is on, this is reversed. Also, if the output cell data is non-NULL, the cell data from the clipped cell is passed to the generated contouring primitives. (Note: the CopyAllocate() method must be invoked on both the output cell and point data. The cellId refers to the cell from which the cell data is copied.)

Reimplemented in vtkCell3D, vtkEmptyCell, vtkGenericCell, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, and vtkVertex.

virtual int vtkCell::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [pure virtual]

Intersect with a ray. Return parametric coordinates (both line and cell) and global intersection coordinates, given ray definition and tolerance. The method returns non-zero value if intersection occurs.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual int vtkCell::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [pure virtual]

Generate simplices of proper dimension. If cell is 3D, tetrahedron are generated; if 2D triangles; if 1D lines; if 0D points. The form of the output is a sequence of points, each n+1 points (where n is topological cell dimension) defining a simplex. The index is a parameter that controls which triangulation to use (if more than one is possible). If numerical degeneracy encountered, 0 is returned, otherwise 1 is returned.

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

virtual void vtkCell::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [pure virtual]

Compute derivatives given cell subId and parametric coordinates. The values array is a series of data value(s) at the cell points. There is a one-to-one correspondence between cell point and data value(s). Dim is the number of data values per cell point. Derivs are derivatives in the x-y-z coordinate directions for each data value. Thus, if computing derivatives for a scalar function in a hexahedron, dim=1, 8 values are supplied, and 3 deriv values are returned (i.e., derivatives in x-y-z directions). On the other hand, if computing derivatives of velocity (vx,vy,vz) dim=3, 24 values are supplied ((vx,vy,vz)1, (vx,vy,vz)2, ....()8), and 9 deriv values are returned ((d(vx)/dx),(d(vx)/dy),(d(vx)/dz), (d(vy)/dx),(d(vy)/dy), (d(vy)/dz), (d(vz)/dx),(d(vz)/dy),(d(vz)/dz)).

Reimplemented in vtkEmptyCell, vtkGenericCell, vtkHexahedron, vtkLine, vtkPixel, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkTetra, vtkTriangle, vtkTriangleStrip, vtkVertex, vtkVoxel, and vtkWedge.

void vtkCell::GetBounds ( float bounds[6] )

Compute cell bounding box (xmin,xmax,ymin,ymax,zmin,zmax). Copy result into user provided array.

float* vtkCell::GetBounds ( )

Compute cell bounding box (xmin,xmax,ymin,ymax,zmin,zmax). Return pointer to array of six float values.

float vtkCell::GetLength2 ( )

Compute Length squared of cell (i.e., bounding box diagonal squared).

virtual int vtkCell::GetParametricCenter ( float pcoords[3] ) [virtual]

Return center of the cell in parametric coordinates. Note that the parametric center is not always located at (0.5,0.5,0.5). The return value is the subId that the center is in (if a composite cell). If you want the center in x-y-z space, invoke the EvaluateLocation() method.

Reimplemented in vtkGenericCell, vtkPolyLine, vtkPolyVertex, vtkPyramid, vtkTetra, vtkTriangle, vtkTriangleStrip, and vtkWedge.

char vtkCell::HitBBox | ( | float | bounds[6],
 |  | float | origin[3],
 |  | float | dir[3],
 |  | float | coord[3],
 |  | float & | t
 | ) | [static]

Bounding box intersection modified from Graphics Gems Vol I. The method returns a non-zero value if the bounding box is hit. Origin[3] starts the ray, dir[3] is the vector components of the ray in the x-y-z directions, coord[3] is the location of hit, and t is the parametric coordinate along line. (Notes: the intersection ray dir[3] is NOT normalized. Valid intersections will only occur between 0<=t<=1.)

Member Data Documentation

vtkPoints* vtkCell::Points

Definition at line 277 of file vtkCell.h.

vtkIdList* vtkCell::PointIds

Definition at line 278 of file vtkCell.h.

Referenced by vtkCellArray::InsertNextCell().

float vtkCell::Bounds[6] [protected]

Definition at line 284 of file vtkCell.h.

The documentation for this class was generated from the following file:
  • Common/vtkCell.h
Generated on Mon Mar 25 01:16:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCell3D Class Reference

abstract class to specify 3D cell interface. More...

#include <vtkCell3D.h>

Inheritance diagram for vtkCell3D:

[legend]
Collaboration diagram for vtkCell3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCell3D, vtkCell)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | GetEdgePoints (int edgeId, int *&pts)=0
virtual void | GetFacePoints (int faceId, int *&pts)=0
virtual int | GetCellDimension ()
virtual void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)

Protected Methods

vtkCell3D ()
~vtkCell3D ()

Protected Attributes

vtkOrderedTriangulator * Triangulator

Detailed Description

abstract class to specify 3D cell interface.

Date:
2002/01/22 15:25:12
Revision:
1.15

vtkCell3D is an abstract class that extends the interfaces for 3D data cells, and implements methods needed to satisfy the vtkCell API. The 3D cells include hexehedra, tetrahedra, wedge, pyramid, and voxel.

See also:
vtkTetra vtkHexahedron vtkVoxel vtkWedge vtkPyramid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (54%)
  • Geveci, Berk (41%)

Definition at line 44 of file vtkCell3D.h.

Constructor & Destructor Documentation

vtkCell3D::vtkCell3D ( ) [inline, protected]

Definition at line 87 of file vtkCell3D.h.

vtkCell3D::~vtkCell3D ( ) [protected]

Member Function Documentation

vtkCell3D::vtkTypeRevisionMacro | ( | vtkCell3D | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

Reimplemented in vtkHexahedron, vtkPyramid, vtkTetra, vtkVoxel, and vtkWedge.

void vtkCell3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCell.

virtual void vtkCell3D::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [pure virtual]

Get the pair of vertices that define an edge. The method returns the number of vertices, along with an array of vertices. Note that the vertices are 0-offset; that is, they refer to the ids of the cell, not the point ids of the mesh that the cell belongs to. The edgeId must range between 0<=edgeId<this->GetNumberOfEdges().

Reimplemented in vtkHexahedron, vtkPyramid, vtkTetra, vtkVoxel, and vtkWedge.

virtual void vtkCell3D::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [pure virtual]

Get the list of vertices that define a face. The list is terminated with a negative number. Note that the vertices are 0-offset; that is, they refer to the ids of the cell, not the point ids of the mesh that the cell belongs to. The faceId must range between 0<=faceId<this->GetNumberOfFaces().

Reimplemented in vtkHexahedron, vtkPyramid, vtkTetra, vtkVoxel, and vtkWedge.

virtual void vtkCell3D::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | connectivity,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

Cut (or clip) the cell based on the input cellScalars and the specified value. The output of the clip operation will be one or more cells of the same topological dimension as the original cell. The flag insideOut controls what part of the cell is considered inside - normally cell points whose scalar value is greater than "value" are considered inside. If insideOut is on, this is reversed. Also, if the output cell data is non-NULL, the cell data from the clipped cell is passed to the generated contouring primitives. (Note: the CopyAllocate() method must be invoked on both the output cell and point data. The cellId refers to the cell from which the cell data is copied.) (Satisfies vtkCell API.)

Reimplemented from vtkCell.

Reimplemented in vtkTetra.

virtual int vtkCell3D::GetCellDimension ( ) [inline, virtual]

The topological dimension of the cell. (Satisfies vtkCell API.)

Reimplemented from vtkCell.

Reimplemented in vtkPyramid, vtkVoxel, and vtkWedge.

Definition at line 84 of file vtkCell3D.h.

Member Data Documentation

vtkOrderedTriangulator* vtkCell3D::Triangulator [protected]

Definition at line 90 of file vtkCell3D.h.

The documentation for this class was generated from the following file:
  • Common/vtkCell3D.h
Generated on Mon Mar 25 01:16:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellArray Class Reference

object to represent cell connectivity. More...

#include <vtkCellArray.h>

Inheritance diagram for vtkCellArray:

[legend]
Collaboration diagram for vtkCellArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellArray, vtkObject)
void | InitTraversal ()
int | GetNextCell (vtkIdType &npts, vtkIdType *&pts)
void | GetCell (vtkIdType loc, vtkIdType &npts, vtkIdType *&pts)
vtkIdType | InsertNextCell (vtkCell *cell)
vtkIdType | InsertNextCell (vtkIdType npts, vtkIdType *pts)
vtkIdType | InsertNextCell (vtkIdList *pts)
vtkIdType | InsertNextCell (int npts)
void | InsertCellPoint (vtkIdType id)
void | UpdateCellCount (int npts)
void | ReverseCell (vtkIdType loc)
void | ReplaceCell (vtkIdType loc, int npts, vtkIdType *pts)
int | GetMaxCellSize ()
vtkIdType * | WritePointer (const vtkIdType ncells, const vtkIdType size)
void | SetCells (vtkIdType ncells, vtkIdTypeArray *cells)
void | DeepCopy (vtkCellArray *ca)
void | Reset ()
unsigned long | GetActualMemorySize ()
int | Allocate (const vtkIdType sz, const int ext=1000)
void | Initialize ()
vtkIdType GetNumberOfCells ()
vtkIdType | EstimateSize (vtkIdType numCells, int maxPtsPerCell)
vtkIdType GetSize ()
vtkIdType GetNumberOfConnectivityEntries ()
vtkIdType | GetInsertLocation (int npts)
vtkIdType GetTraversalLocation ()
void | SetTraversalLocation (vtkIdType loc)
vtkIdType | GetTraversalLocation (vtkIdType npts)
vtkIdType * GetPointer ()
vtkDataArray * GetData ()
void | Squeeze ()

Static Public Methods

vtkCellArray * | New ()

Protected Methods

vtkCellArray ()
~vtkCellArray ()

Protected Attributes

vtkIdType NumberOfCells
vtkIdType InsertLocation
vtkIdType TraversalLocation
vtkIdTypeArray * Ia

Detailed Description

object to represent cell connectivity.

Date:
2002/01/22 15:25:13
Revision:
1.86

vtkCellArray is a supporting object that explicitly represents cell connectivity. The cell array structure is a raw integer list of the form: (n,id1,id2,...,idn, n,id1,id2,...,idn, ...) where n is the number of points in the cell, and id is a zero-offset index into an associated point list.

Advantages of this data structure are its compactness, simplicity, and easy interface to external data. However, it is totally inadequate for random access. This functionality (when necessary) is accomplished by using the vtkCellTypes and vtkCellLinks objects to extend the definition of the data structure.

See also:
vtkCellTypes vtkCellLinks
Created by:
  • Martin, Ken
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Martin, Ken (17%)
  • Henderson, Amy (7%)
  • Law, Charles (7%)
Examples:
vtkCellArray (Examples)
Tests:
vtkCellArray (Tests)

Definition at line 60 of file vtkCellArray.h.

Constructor & Destructor Documentation

vtkCellArray::vtkCellArray ( ) [protected]

vtkCellArray::~vtkCellArray ( ) [protected]

Member Function Documentation

vtkCellArray::vtkTypeRevisionMacro | ( | vtkCellArray | ,
 |  | vtkObject |
 | ) |

vtkCellArray* vtkCellArray::New ( ) [static]

Instantiate cell array (connectivity list).

Reimplemented from vtkObject.

int vtkCellArray::Allocate | ( | const vtkIdType | sz,
 |  | const int | ext = 1000
 | ) | [inline]

Allocate memory and set the size to extend by.

Definition at line 70 of file vtkCellArray.h.

void vtkCellArray::Initialize ( ) [inline]

Free any memory and reset to an empty state.

Definition at line 76 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetNumberOfCells ( ) [inline]

Get the number of cells in the array.

Definition at line 82 of file vtkCellArray.h.

vtkIdType vtkCellArray::EstimateSize | ( | vtkIdType | numCells,
 |  | int | maxPtsPerCell
 | ) | [inline]

Utility routines help manage memory of cell array. EstimateSize() returns a value used to initialize and allocate memory for array based on number of cells and maximum number of points making up cell. If every cell is the same size (in terms of number of points), then the memory estimate is guaranteed exact. (If not exact, use Squeeze() to reclaim any extra memory.)

Definition at line 93 of file vtkCellArray.h.

void vtkCellArray::InitTraversal ( ) [inline]

A cell traversal methods that is more efficient than vtkDataSet traversal methods. InitTraversal() initializes the traversal of the list of cells.

Definition at line 100 of file vtkCellArray.h.

int vtkCellArray::GetNextCell | ( | vtkIdType & | npts,
 |  | vtkIdType *& | pts
 | ) | [inline]

A cell traversal methods that is more efficient than vtkDataSet traversal methods. GetNextCell() gets the next cell in the list. If end of list is encountered, 0 is returned.

Definition at line 321 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetSize ( ) [inline]

Get the size of the allocated connectivity array.

Definition at line 109 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetNumberOfConnectivityEntries ( ) [inline]

Get the total number of entries (i.e., data values) in the connectivity array. This may be much less than the allocated size (i.e., return value from GetSize().)

Definition at line 117 of file vtkCellArray.h.

void vtkCellArray::GetCell | ( | vtkIdType | loc,
 |  | vtkIdType & | npts,
 |  | vtkIdType *& | pts
 | ) | [inline]

Internal method used to retrieve a cell given an offset into the internal array.

Definition at line 337 of file vtkCellArray.h.

vtkIdType vtkCellArray::InsertNextCell ( vtkCell * cell ) [inline]

Insert a cell object. Return the cell id of the cell.

Definition at line 294 of file vtkCellArray.h.

vtkIdType vtkCellArray::InsertNextCell | ( | vtkIdType | npts,
 |  | vtkIdType * | pts
 | ) | [inline]

Create a cell by specifying the number of points and an array of point id's. Return the cell id of the cell.

Definition at line 243 of file vtkCellArray.h.

vtkIdType vtkCellArray::InsertNextCell ( vtkIdList * pts ) [inline]

Create a cell by specifying a list of point ids. Return the cell id of the cell.

Definition at line 259 of file vtkCellArray.h.

vtkIdType vtkCellArray::InsertNextCell ( int npts ) [inline]

Create cells by specifying count, and then adding points one at a time using method InsertCellPoint(). If you don't know the count initially, use the method UpdateCellCount() to complete the cell. Return the cell id of the cell.

Definition at line 276 of file vtkCellArray.h.

void vtkCellArray::InsertCellPoint ( vtkIdType id ) [inline]

Used in conjunction with InsertNextCell(int npts) to add another point to the list of cells.

Definition at line 284 of file vtkCellArray.h.

void vtkCellArray::UpdateCellCount ( int npts ) [inline]

Used in conjunction with InsertNextCell(int npts) and InsertCellPoint() to update the number of points defining the cell.

Definition at line 289 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetInsertLocation ( int npts ) [inline]

Computes the current insertion location within the internal array. Used in conjunction with GetCell(int loc,...).

Definition at line 153 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetTraversalLocation ( ) [inline]

Get/Set the current traversal location.

Definition at line 159 of file vtkCellArray.h.

void vtkCellArray::SetTraversalLocation ( vtkIdType loc ) [inline]

Get/Set the current traversal location.

Definition at line 161 of file vtkCellArray.h.

vtkIdType vtkCellArray::GetTraversalLocation ( vtkIdType npts ) [inline]

Computes the current traversal location within the internal array. Used in conjunction with GetCell(int loc,...).

Definition at line 168 of file vtkCellArray.h.

void vtkCellArray::ReverseCell ( vtkIdType loc ) [inline]

Special method inverts ordering of current cell. Must be called carefully or the cell topology may be corrupted.

Definition at line 345 of file vtkCellArray.h.

void vtkCellArray::ReplaceCell | ( | vtkIdType | loc,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) | [inline]

Replace the point ids of the cell with a different list of point ids.

Definition at line 359 of file vtkCellArray.h.

int vtkCellArray::GetMaxCellSize ( )

Returns the size of the largest cell. The size is the number of points defining the cell.

vtkIdType* vtkCellArray::GetPointer ( ) [inline]

Get pointer to array of cell data.

Definition at line 185 of file vtkCellArray.h.

vtkIdType * vtkCellArray::WritePointer | ( | const vtkIdType | ncells,
 |  | const vtkIdType | size
 | ) | [inline]

Get pointer to data array for purpose of direct writes of data. Size is the total storage consumed by the cell array. ncells is the number of cells represented in the array.

Definition at line 368 of file vtkCellArray.h.

void vtkCellArray::SetCells | ( | vtkIdType | ncells,
 |  | vtkIdTypeArray * | cells
 | ) |

Define multiple cells by providing a connectivity list. The list is in the form (npts,p0,p1,...p(npts-1), repeated for each cell). Be careful using this method because it discards the old cells, and anything referring these cells becomes invalid (for example, if BuildCells() has been called see vtkPolyData). The traversal location is reset to the beginning of the list; the insertion location is set to the end of the list.

void vtkCellArray::DeepCopy ( vtkCellArray * ca )

Perform a deep copy (no reference counting) of the given cell array.

vtkDataArray* vtkCellArray::GetData ( ) [inline]

Return the underlying data as a data array.

Definition at line 208 of file vtkCellArray.h.

void vtkCellArray::Reset ( ) [inline]

Reuse list. Reset to initial condition.

Definition at line 312 of file vtkCellArray.h.

void vtkCellArray::Squeeze ( ) [inline]

Reclaim any extra memory.

Definition at line 217 of file vtkCellArray.h.

unsigned long vtkCellArray::GetActualMemorySize ( )

Return the memory in kilobytes consumed by this cell array. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object. The information returned is valid only after the pipeline has been updated.

Member Data Documentation

vtkIdType vtkCellArray::NumberOfCells [protected]

Definition at line 233 of file vtkCellArray.h.

vtkIdType vtkCellArray::InsertLocation [protected]

Definition at line 234 of file vtkCellArray.h.

vtkIdType vtkCellArray::TraversalLocation [protected]

Definition at line 235 of file vtkCellArray.h.

vtkIdTypeArray* vtkCellArray::Ia [protected]

Definition at line 236 of file vtkCellArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkCellArray.h
Generated on Mon Mar 25 01:16:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellCenters Class Reference

generate points at center of cells. More...

#include <vtkCellCenters.h>

Inheritance diagram for vtkCellCenters:

[legend]
Collaboration diagram for vtkCellCenters:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellCenters, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetVertexCells (int)
virtual int | GetVertexCells ()
virtual void | VertexCellsOn ()
virtual void | VertexCellsOff ()

Static Public Methods

vtkCellCenters * | New ()

Protected Methods

vtkCellCenters ()
~vtkCellCenters ()
void | Execute ()

Protected Attributes

int | VertexCells

Detailed Description

generate points at center of cells.

Date:
2002/01/22 15:29:09
Revision:
1.17

vtkCellCenters is a filter that takes as input any dataset and generates on output points at the center of the cells in the dataset. These points can be used for placing glyphs (vtkGlyph3D) or labeling (vtkLabeledDataMapper). (The center is the parametric center of the cell, not necessarily the geometric or bounding box center.) The cell attributes will be associated with the points on output.

Warning:
You can choose to generate just points or points and vertex cells. Vertex cells are drawn during rendering; points are not. Use the ivar VertexCells to generate cells.
See also:
vtkGlyph3D vtkLabeledDataMapper
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Martin, Ken (8%)
Examples:
vtkCellCenters (Examples)
Tests:
vtkCellCenters (Tests)

Definition at line 56 of file vtkCellCenters.h.

Constructor & Destructor Documentation

vtkCellCenters::vtkCellCenters ( ) [protected]

vtkCellCenters::~vtkCellCenters ( ) [inline, protected]

Definition at line 74 of file vtkCellCenters.h.

Member Function Documentation

vtkCellCenters::vtkTypeRevisionMacro | ( | vtkCellCenters | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkCellCenters::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkCellCenters* vtkCellCenters::New ( ) [static]

Construct object with vertex cell generation turned off.

Reimplemented from vtkPolyDataSource.

virtual void vtkCellCenters::SetVertexCells ( int ) [virtual]

Enable/disable the generation of vertex cells.

virtual int vtkCellCenters::GetVertexCells ( ) [virtual]

Enable/disable the generation of vertex cells.

virtual void vtkCellCenters::VertexCellsOn ( ) [virtual]

Enable/disable the generation of vertex cells.

virtual void vtkCellCenters::VertexCellsOff ( ) [virtual]

Enable/disable the generation of vertex cells.

void vtkCellCenters::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkCellCenters::VertexCells [protected]

Definition at line 78 of file vtkCellCenters.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCellCenters.h
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellData Class Reference

represent and manipulate cell attribute data. More...

#include <vtkCellData.h>

Inheritance diagram for vtkCellData:

[legend]
Collaboration diagram for vtkCellData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellData, vtkDataSetAttributes)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkCellData * | New ()

Protected Methods

vtkCellData ()
~vtkCellData ()

Detailed Description

represent and manipulate cell attribute data.

Date:
2002/01/22 15:25:13
Revision:
1.18

vtkCellData is a class that is used to represent and manipulate cell attribute data (e.g., scalars, vectors, normals, texture coordinates, etc.) Special methods are provided to work with filter objects, such as passing data through filter, copying data from one cell to another, and interpolating data given cell interpolation weights.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (76%)
  • Geveci, Berk (13%)
Tests:
vtkCellData (Tests)

Definition at line 44 of file vtkCellData.h.

Constructor & Destructor Documentation

vtkCellData::vtkCellData ( ) [inline, protected]

Definition at line 53 of file vtkCellData.h.

vtkCellData::~vtkCellData ( ) [inline, protected]

Definition at line 54 of file vtkCellData.h.

Member Function Documentation

vtkCellData* vtkCellData::New ( ) [static]

Construct object with copying turned on for all data.

Reimplemented from vtkDataSetAttributes.

vtkCellData::vtkTypeRevisionMacro | ( | vtkCellData | ,
 |  | vtkDataSetAttributes |
 | ) |

Reimplemented from vtkDataSetAttributes.

void vtkCellData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSetAttributes.

The documentation for this class was generated from the following file:
  • Common/vtkCellData.h
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellDataToPointData Class Reference

map cell data to point data. More...

#include <vtkCellDataToPointData.h>

Inheritance diagram for vtkCellDataToPointData:

[legend]
Collaboration diagram for vtkCellDataToPointData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellDataToPointData, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPassCellData (int)
virtual int | GetPassCellData ()
virtual void | PassCellDataOn ()
virtual void | PassCellDataOff ()

Static Public Methods

vtkCellDataToPointData * | New ()

Protected Methods

vtkCellDataToPointData ()
~vtkCellDataToPointData ()
void | Execute ()

Protected Attributes

int | PassCellData

Detailed Description

map cell data to point data.

Date:
2002/01/22 15:29:10
Revision:
1.17

vtkCellDataToPointData is a filter that transforms cell data (i.e., data specified per cell) into point data (i.e., data specified at cell points). The method of transformation is based on averaging the data values of all cells using a particular point. Optionally, the input cell data can be passed through to the output as well.

Warning:
This filter is an abstract filter, that is, the output is an abstract type (i.e., vtkDataSet). Use the convenience methods (e.g., vtkGetPolyDataOutput(), GetStructuredPointsOutput(), etc.) to get the type of output you want.
See also:
vtkDataSetToDataSetFilter vtkPointData vtkCellData vtkPointDataToCellData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Law, Charles (6%)
Tests:
vtkCellDataToPointData (Tests)

Definition at line 53 of file vtkCellDataToPointData.h.

Constructor & Destructor Documentation

vtkCellDataToPointData::vtkCellDataToPointData ( ) [protected]

vtkCellDataToPointData::~vtkCellDataToPointData ( ) [inline, protected]

Definition at line 71 of file vtkCellDataToPointData.h.

Member Function Documentation

vtkCellDataToPointData* vtkCellDataToPointData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

Reimplemented in vtkPCellDataToPointData.

vtkCellDataToPointData::vtkTypeRevisionMacro | ( | vtkCellDataToPointData | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

Reimplemented in vtkPCellDataToPointData.

void vtkCellDataToPointData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkPCellDataToPointData.

virtual void vtkCellDataToPointData::SetPassCellData ( int ) [virtual]

Control whether the input cell data is to be passed to the output. If on, then the input cell data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual int vtkCellDataToPointData::GetPassCellData ( ) [virtual]

Control whether the input cell data is to be passed to the output. If on, then the input cell data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual void vtkCellDataToPointData::PassCellDataOn ( ) [virtual]

Control whether the input cell data is to be passed to the output. If on, then the input cell data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual void vtkCellDataToPointData::PassCellDataOff ( ) [virtual]

Control whether the input cell data is to be passed to the output. If on, then the input cell data is passed through to the output; otherwise, only generated point data is placed into the output.

void vtkCellDataToPointData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkPCellDataToPointData.

Member Data Documentation

int vtkCellDataToPointData::PassCellData [protected]

Definition at line 75 of file vtkCellDataToPointData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCellDataToPointData.h
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellDerivatives Class Reference

compute derivatives of scalars and vectors. More...

#include <vtkCellDerivatives.h>

Inheritance diagram for vtkCellDerivatives:

[legend]
Collaboration diagram for vtkCellDerivatives:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellDerivatives, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetVectorMode (int)
virtual int | GetVectorMode ()
void | SetVectorModeToPassVectors ()
void | SetVectorModeToComputeGradient ()
void | SetVectorModeToComputeVorticity ()
const char * | GetVectorModeAsString ()
virtual void | SetTensorMode (int)
virtual int | GetTensorMode ()
void | SetTensorModeToPassTensors ()
void | SetTensorModeToComputeGradient ()
void | SetTensorModeToComputeStrain ()
const char * | GetTensorModeAsString ()

Static Public Methods

vtkCellDerivatives * | New ()

Protected Methods

vtkCellDerivatives ()
~vtkCellDerivatives ()
void | Execute ()

Protected Attributes

int | VectorMode
int | TensorMode

Detailed Description

compute derivatives of scalars and vectors.

Date:
2002/01/22 15:29:10
Revision:
1.17

vtkCellDerivatives is a filter that computes derivatives of scalars and vectors at the center of cells. You can choose to generate different output including the scalar gradient (a vector), computed tensor vorticity (a vector), gradient of input vectors (a tensor), and strain matrix of the input vectors (a tensor); or you may choose to pass data through to the output.

Note that it is assumed that on input scalars and vector point data is available, which are then used to generate cell vectors and tensors. (The interpolation functions of the cells are used to compute the derivatives which is why point data is required.)

Warning:
The computed derivatives are cell attribute data; you can convert them to point attribute data by using the vtkCellDataToPointData filter. Note that, due to the interpolation function used (obtained using 1/r**2 normalized sum), the derivatives calculated for polygons with more than 4 vertices are inaccurate in most cases.
Warning:
The point data is passed through the filter to the output.
See also:
vtkVectorNorm
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Geveci, Berk (11%)
Tests:
vtkCellDerivatives (Tests)

Definition at line 71 of file vtkCellDerivatives.h.

Constructor & Destructor Documentation

vtkCellDerivatives::vtkCellDerivatives ( ) [protected]

vtkCellDerivatives::~vtkCellDerivatives ( ) [inline, protected]

Definition at line 116 of file vtkCellDerivatives.h.

Member Function Documentation

vtkCellDerivatives::vtkTypeRevisionMacro | ( | vtkCellDerivatives | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkCellDerivatives::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkCellDerivatives* vtkCellDerivatives::New ( ) [static]

Construct to compute the gradient of the scalars and vectors.

Reimplemented from vtkDataSetSource.

virtual void vtkCellDerivatives::SetVectorMode ( int ) [virtual]

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

virtual int vtkCellDerivatives::GetVectorMode ( ) [virtual]

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

void vtkCellDerivatives::SetVectorModeToPassVectors ( ) [inline]

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

Definition at line 88 of file vtkCellDerivatives.h.

void vtkCellDerivatives::SetVectorModeToComputeGradient ( ) [inline]

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

Definition at line 90 of file vtkCellDerivatives.h.

void vtkCellDerivatives::SetVectorModeToComputeVorticity ( ) [inline]

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

Definition at line 92 of file vtkCellDerivatives.h.

const char* vtkCellDerivatives::GetVectorModeAsString ( )

Control how the filter works to generate vector cell data. You can choose to pass the input cell vectors, compute the gradient of the input scalars, or extract the vorticity of the computed vector gradient tensor. By default (VectorModeToComputeGradient), the filter will take the gradient of the input scalar data.

virtual void vtkCellDerivatives::SetTensorMode ( int ) [virtual]

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

virtual int vtkCellDerivatives::GetTensorMode ( ) [virtual]

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

void vtkCellDerivatives::SetTensorModeToPassTensors ( ) [inline]

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

Definition at line 105 of file vtkCellDerivatives.h.

void vtkCellDerivatives::SetTensorModeToComputeGradient ( ) [inline]

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

Definition at line 107 of file vtkCellDerivatives.h.

void vtkCellDerivatives::SetTensorModeToComputeStrain ( ) [inline]

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

Definition at line 109 of file vtkCellDerivatives.h.

const char* vtkCellDerivatives::GetTensorModeAsString ( )

Control how the filter works to generate tensor cell data. You can choose to pass the input cell tensors, compute the gradient of the input vectors, or compute the strain tensor of the vector gradient tensor. By default (TensorModeToComputeGradient), the filter will take the gradient of the vector data to construct a tensor.

void vtkCellDerivatives::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkCellDerivatives::VectorMode [protected]

Definition at line 119 of file vtkCellDerivatives.h.

int vtkCellDerivatives::TensorMode [protected]

Definition at line 120 of file vtkCellDerivatives.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCellDerivatives.h
Generated on Mon Mar 25 01:16:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellLinks Class Reference

object represents upward pointers from points to list of cells using each point. More...

#include <vtkCellLinks.h>

Inheritance diagram for vtkCellLinks:

[legend]
Collaboration diagram for vtkCellLinks:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellLinks, vtkObject)
void | Allocate (vtkIdType numLinks, vtkIdType ext=1000)
_vtkLink_s & | GetLink (vtkIdType ptId)
unsigned short | GetNcells (vtkIdType ptId)
void | BuildLinks (vtkDataSet *data)
void | BuildLinks (vtkDataSet *data, vtkCellArray *Connectivity)
vtkIdType * | GetCells (vtkIdType ptId)
vtkIdType | InsertNextPoint (int numLinks)
void | InsertNextCellReference (vtkIdType ptId, vtkIdType cellId)
void | DeletePoint (vtkIdType ptId)
void | RemoveCellReference (vtkIdType cellId, vtkIdType ptId)
void | AddCellReference (vtkIdType cellId, vtkIdType ptId)
void | ResizeCellList (vtkIdType ptId, int size)
void | Squeeze ()
void | Reset ()
unsigned long | GetActualMemorySize ()
void | DeepCopy (vtkCellLinks *src)

Static Public Methods

vtkCellLinks * | New ()

Protected Methods

vtkCellLinks ()
~vtkCellLinks ()
void | IncrementLinkCount (vtkIdType ptId)
void | AllocateLinks (vtkIdType n)
_vtkLink_s * | Resize (vtkIdType sz)
void | InsertCellReference (vtkIdType ptId, unsigned short pos, vtkIdType cellId)

Protected Attributes

_vtkLink_s * Array
vtkIdType Size
vtkIdType MaxId
vtkIdType Extend

Detailed Description

object represents upward pointers from points to list of cells using each point.

Date:
2002/01/22 15:25:13
Revision:
1.27

vtkCellLinks is a supplemental object to vtkCellArray and vtkCellTypes, enabling access from points to the cells using the points. vtkCellLinks is a list of Links, each link represents a dynamic list of cell id's using the point. The information provided by this object can be used to determine neighbors and construct other local topological information.

See also:
vtkCellArray vtkCellTypes
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (56%)
  • Martin, Ken (16%)
  • Henderson, Amy (13%)
  • Miller, Jim (7%)

Definition at line 52 of file vtkCellLinks.h.

Constructor & Destructor Documentation

vtkCellLinks::vtkCellLinks ( ) [inline, protected]

Definition at line 122 of file vtkCellLinks.h.

vtkCellLinks::~vtkCellLinks ( ) [protected]

Member Function Documentation

vtkCellLinks* vtkCellLinks::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkCellLinks::vtkTypeRevisionMacro | ( | vtkCellLinks | ,
 |  | vtkObject |
 | ) |

void vtkCellLinks::Allocate | ( | vtkIdType | numLinks,
 |  | vtkIdType | ext = 1000
 | ) |

Allocate the specified number of links (i.e., number of points) that will be built.

_vtkLink_s& vtkCellLinks::GetLink ( vtkIdType ptId ) [inline]

Get a link structure given a point id.

Definition at line 63 of file vtkCellLinks.h.

unsigned short vtkCellLinks::GetNcells ( vtkIdType ptId ) [inline]

Get the number of cells using the point specified by ptId.

Definition at line 66 of file vtkCellLinks.h.

Referenced by vtkPolyData::GetPointCells().

void vtkCellLinks::BuildLinks ( vtkDataSet * data )

Build the link list array.

void vtkCellLinks::BuildLinks | ( | vtkDataSet * | data,
 |  | vtkCellArray * | Connectivity
 | ) |

Build the link list array.

vtkIdType* vtkCellLinks::GetCells ( vtkIdType ptId ) [inline]

Return a list of cell ids using the point.

Definition at line 75 of file vtkCellLinks.h.

Referenced by vtkPolyData::GetPointCells().

vtkIdType vtkCellLinks::InsertNextPoint ( int numLinks )

Insert a new point into the cell-links data structure. The size parameter is the initial size of the list.

void vtkCellLinks::InsertNextCellReference | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) | [inline]

Insert a cell id into the list of cells (at the end) using the cell id provided. (Make sure to extend the link list (if necessary) using the method ResizeCellList().)

Definition at line 161 of file vtkCellLinks.h.

void vtkCellLinks::DeletePoint ( vtkIdType ptId ) [inline]

Delete point (and storage) by destroying links to using cells.

Definition at line 154 of file vtkCellLinks.h.

Referenced by vtkPolyData::DeletePoint().

void vtkCellLinks::RemoveCellReference | ( | vtkIdType | cellId,
 |  | vtkIdType | ptId
 | ) | [inline]

Delete the reference to the cell (cellId) from the point (ptId). This removes the reference to the cellId from the cell list, but does not resize the list (recover memory with ResizeCellList(), if necessary).

Definition at line 167 of file vtkCellLinks.h.

Referenced by vtkPolyData::RemoveCellReference().

void vtkCellLinks::AddCellReference | ( | vtkIdType | cellId,
 |  | vtkIdType | ptId
 | ) | [inline]

Add the reference to the cell (cellId) from the point (ptId). This adds a reference to the cellId from the cell list, but does not resize the list (extend memory with ResizeCellList(), if necessary).

Definition at line 186 of file vtkCellLinks.h.

Referenced by vtkPolyData::AddCellReference().

void vtkCellLinks::ResizeCellList | ( | vtkIdType | ptId,
 |  | int | size
 | ) | [inline]

Change the length of a point's link list (i.e., list of cells using a point) by the size specified.

Definition at line 191 of file vtkCellLinks.h.

Referenced by vtkPolyData::ResizeCellList().

void vtkCellLinks::Squeeze ( )

Reclaim any unused memory.

void vtkCellLinks::Reset ( )

Reset to a state of no entries without freeing the memory.

unsigned long vtkCellLinks::GetActualMemorySize ( )

Return the memory in kilobytes consumed by this cell links array. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object. The information returned is valid only after the pipeline has been updated.

void vtkCellLinks::DeepCopy ( vtkCellLinks * src )

Standard DeepCopy method. Since this object contains no reference to other objects, there is no ShallowCopy.

void vtkCellLinks::IncrementLinkCount ( vtkIdType ptId ) [inline, protected]

Increment the count of the number of cells using the point.

Definition at line 126 of file vtkCellLinks.h.

void vtkCellLinks::AllocateLinks ( vtkIdType n ) [protected]

void vtkCellLinks::InsertCellReference | ( | vtkIdType | ptId,
 |  | unsigned short | pos,
 |  | vtkIdType | cellId
 | ) | [inline, protected]

Insert a cell id into the list of cells using the point.

Definition at line 147 of file vtkCellLinks.h.

_vtkLink_s* vtkCellLinks::Resize ( vtkIdType sz ) [protected]

Member Data Documentation

_vtkLink_s* vtkCellLinks::Array [protected]

Definition at line 136 of file vtkCellLinks.h.

vtkIdType vtkCellLinks::Size [protected]

Definition at line 137 of file vtkCellLinks.h.

vtkIdType vtkCellLinks::MaxId [protected]

Definition at line 138 of file vtkCellLinks.h.

vtkIdType vtkCellLinks::Extend [protected]

Definition at line 139 of file vtkCellLinks.h.

The documentation for this class was generated from the following file:
  • Common/vtkCellLinks.h
Generated on Mon Mar 25 01:16:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellLocator Class Reference

octree-based spatial search object to quickly locate cells. More...

#include <vtkCellLocator.h>

Inheritance diagram for vtkCellLocator:

[legend]
Collaboration diagram for vtkCellLocator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellLocator, vtkLocator)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkIdList * | GetCells (int bucket)
virtual int | GetNumberOfBuckets (void)
virtual void | SetNumberOfCellsPerBucket (int)
virtual int | GetNumberOfCellsPerBucket ()
virtual void | SetCacheCellBounds (int)
virtual int | GetCacheCellBounds ()
virtual void | CacheCellBoundsOn ()
virtual void | CacheCellBoundsOff ()
virtual int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
virtual int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId)
virtual int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId, vtkGenericCell *cell)
void | FindClosestPoint (float x[3], float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
void | FindClosestPoint (float x[3], float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
int | FindClosestPointWithinRadius (float x[3], float radius, float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
int | FindClosestPointWithinRadius (float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
int | FindClosestPointWithinRadius (float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2, int &inside)
void | FreeSearchStructure ()
void | BuildLocator ()
void | GenerateRepresentation (int level, vtkPolyData *pd)

Static Public Methods

vtkCellLocator * | New ()

Protected Methods

vtkCellLocator ()
~vtkCellLocator ()
void | GetBucketNeighbors (int ijk[3], int ndivs, int level)
void | GetOverlappingBuckets (float x[3], int ijk[3], float dist, int prevMinLevel[3], int prevMaxLevel[3])
void | ClearCellHasBeenVisited ()
void | ClearCellHasBeenVisited (int id)
float | Distance2ToBucket (float x[3], int nei[3])
float | Distance2ToBounds (float x[3], float bounds[6])
void | MarkParents (void *, int, int, int, int, int)
void | GetChildren (int idx, int level, int children[8])
int | GenerateIndex (int offset, int numDivs, int i, int j, int k, vtkIdType &idx)
void | GenerateFace (int face, int numDivs, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys)

Protected Attributes

int | NumberOfCellsPerBucket
int | NumberOfOctants
float | Bounds [6]
int | NumberOfParents
float | H [3]
int | NumberOfDivisions
vtkIdList ** Tree
vtkNeighborCells * | Buckets
unsigned char * | CellHasBeenVisited
unsigned char | QueryNumber
int | CacheCellBounds
float(* | CellBounds )[6]

Detailed Description

octree-based spatial search object to quickly locate cells.

Date:
2002/01/22 15:28:01
Revision:
1.57

vtkCellLocator is a spatial search object to quickly locate cells in 3D. vtkCellLocator uses a uniform-level octree subdivision, where each octant (an octant is also referred to as a bucket) carries an indication of whether it is empty or not, and each leaf octant carries a list of the cells inside of it. (An octant is not empty if it has one or more cells inside of it.) Typical operations are intersection with a line to return candidate cells, or intersection with another vtkCellLocator to return candidate cells.

Warning:
Many other types of spatial locators have been developed, such as variable depth octrees and kd-trees. These are often more efficient for the operations described here. vtkCellLocator has been designed for subclassing; so these locators can be derived if necessary.
See also:
vtkLocator vtkPointLocator vtkOBBTree
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (30%)
  • Miller, Jim (30%)
  • Blue, Rusty (28%)
  • Martin, Ken (7%)
Tests:
vtkCellLocator (Tests)

Definition at line 60 of file vtkCellLocator.h.

Constructor & Destructor Documentation

vtkCellLocator::vtkCellLocator ( ) [protected]

vtkCellLocator::~vtkCellLocator ( ) [protected]

Member Function Documentation

vtkCellLocator::vtkTypeRevisionMacro | ( | vtkCellLocator | ,
 |  | vtkLocator |
 | ) |

Reimplemented from vtkLocator.

Reimplemented in vtkOBBTree.

void vtkCellLocator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLocator.

vtkCellLocator* vtkCellLocator::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 cells per bucket.

Reimplemented from vtkObject.

Reimplemented in vtkOBBTree.

virtual void vtkCellLocator::SetNumberOfCellsPerBucket ( int ) [virtual]

Specify the average number of cells in each octant.

virtual int vtkCellLocator::GetNumberOfCellsPerBucket ( ) [virtual]

Specify the average number of cells in each octant.

virtual void vtkCellLocator::SetCacheCellBounds ( int ) [virtual]

Boolean controls whether the bounds of each cell are computed only once and then saved. Should be 10 to 20% faster if repeatedly calling any of the FindClosestPoint routines and the extra memory won't cause disk caching (24 extra bytes per cell are required to save the bounds).

virtual int vtkCellLocator::GetCacheCellBounds ( ) [virtual]

Boolean controls whether the bounds of each cell are computed only once and then saved. Should be 10 to 20% faster if repeatedly calling any of the FindClosestPoint routines and the extra memory won't cause disk caching (24 extra bytes per cell are required to save the bounds).

virtual void vtkCellLocator::CacheCellBoundsOn ( ) [virtual]

Boolean controls whether the bounds of each cell are computed only once and then saved. Should be 10 to 20% faster if repeatedly calling any of the FindClosestPoint routines and the extra memory won't cause disk caching (24 extra bytes per cell are required to save the bounds).

virtual void vtkCellLocator::CacheCellBoundsOff ( ) [virtual]

Boolean controls whether the bounds of each cell are computed only once and then saved. Should be 10 to 20% faster if repeatedly calling any of the FindClosestPoint routines and the extra memory won't cause disk caching (24 extra bytes per cell are required to save the bounds).

virtual int vtkCellLocator::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Return intersection point (if any) of finite line with cells contained in cell locator.

Reimplemented in vtkOBBTree.

virtual int vtkCellLocator::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId,
 |  | vtkIdType & | cellId
 | ) | [virtual]

Return intersection point (if any) AND the cell which was intersected by the finite line.

Reimplemented in vtkOBBTree.

virtual int vtkCellLocator::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId,
 |  | vtkIdType & | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Return intersection point (if any) AND the cell which was intersected by the finite line. The cell is returned as a cell id and as a generic cell.

Reimplemented in vtkOBBTree.

void vtkCellLocator::FindClosestPoint | ( | float | x[3],
 |  | float | closestPoint[3],
 |  | vtkIdType & | cellId,
 |  | int & | subId,
 |  | float & | dist2
 | ) |

Return the closest point and the cell which is closest to the point x. The closest point is somewhere on a cell, it need not be one of the vertices of the cell.

void vtkCellLocator::FindClosestPoint | ( | float | x[3],
 |  | float | closestPoint[3],
 |  | vtkGenericCell * | cell,
 |  | vtkIdType & | cellId,
 |  | int & | subId,
 |  | float & | dist2
 | ) |

Return the closest point and the cell which is closest to the point x. The closest point is somewhere on a cell, it need not be one of the vertices of the cell. This version takes in a vtkGenericCell to avoid allocating and deallocating the cell. This is much faster than the version which does not take a *cell, especially when this function is called many times in a row such as by a for loop, where the allocation and deallocation can be done only once outside the for loop. If a cell is found, "cell" contains the points and ptIds for the cell "cellId" upon exit.

int vtkCellLocator::FindClosestPointWithinRadius | ( | float | x[3],
 |  | float | radius,
 |  | float | closestPoint[3],
 |  | vtkIdType & | cellId,
 |  | int & | subId,
 |  | float & | dist2
 | ) |

Return the closest point within a specified radius and the cell which is closest to the point x. The closest point is somewhere on a cell, it need not be one of the vertices of the cell. This method returns 1 if a point is found within the specified radius. If there are no cells within the specified radius, the method returns 0 and the values of closestPoint, cellId, subId, and dist2 are undefined.

int vtkCellLocator::FindClosestPointWithinRadius | ( | float | x[3],
 |  | float | radius,
 |  | float | closestPoint[3],
 |  | vtkGenericCell * | cell,
 |  | vtkIdType & | cellId,
 |  | int & | subId,
 |  | float & | dist2
 | ) |

Return the closest point within a specified radius and the cell which is closest to the point x. The closest point is somewhere on a cell, it need not be one of the vertices of the cell. This method returns 1 if a point is found within the specified radius. If there are no cells within the specified radius, the method returns 0 and the values of closestPoint, cellId, subId, and dist2 are undefined. This version takes in a vtkGenericCell to avoid allocating and deallocating the cell. This is much faster than the version which does not take a *cell, especially when this function is called many times in a row such as by a for loop, where the allocation and deallocation can be done only once outside the for loop. If a closest point is found, "cell" contains the points and ptIds for the cell "cellId" upon exit.

int vtkCellLocator::FindClosestPointWithinRadius | ( | float | x[3],
 |  | float | radius,
 |  | float | closestPoint[3],
 |  | vtkGenericCell * | cell,
 |  | vtkIdType & | cellId,
 |  | int & | subId,
 |  | float & | dist2,
 |  | int & | inside
 | ) |

Return the closest point within a specified radius and the cell which is closest to the point x. The closest point is somewhere on a cell, it need not be one of the vertices of the cell. This method returns 1 if a point is found within the specified radius. If there are no cells within the specified radius, the method returns 0 and the values of closestPoint, cellId, subId, and dist2 are undefined. This version takes in a vtkGenericCell to avoid allocating and deallocating the cell. This is much faster than the version which does not take a *cell, especially when this function is called many times in a row such as by a for loop, where the allocation and dealloction can be done only once outside the for loop. If a closest point is found, "cell" contains the points and ptIds for the cell "cellId" upon exit. If a closest point is found, inside returns the return value of the EvaluatePosition call to the closest cell; inside(=1) or outside(=0).

virtual vtkIdList* vtkCellLocator::GetCells ( int bucket ) [virtual]

Get the cells in a particular bucket.

virtual int vtkCellLocator::GetNumberOfBuckets ( void ) [virtual]

Return number of buckets available. Insure that the locator has been built before attempting to access buckets (octants).

void vtkCellLocator::FreeSearchStructure ( ) [virtual]

Satisfy vtkLocator abstract interface.

Reimplemented from vtkLocator.

Reimplemented in vtkOBBTree.

void vtkCellLocator::BuildLocator ( ) [virtual]

Satisfy vtkLocator abstract interface.

Reimplemented from vtkLocator.

Reimplemented in vtkOBBTree.

void vtkCellLocator::GenerateRepresentation | ( | int | level,
 |  | vtkPolyData * | pd
 | ) | [virtual]

Satisfy vtkLocator abstract interface.

Reimplemented from vtkLocator.

Reimplemented in vtkOBBTree.

void vtkCellLocator::GetBucketNeighbors | ( | int | ijk[3],
 |  | int | ndivs,
 |  | int | level
 | ) | [protected]

void vtkCellLocator::GetOverlappingBuckets | ( | float | x[3],
 |  | int | ijk[3],
 |  | float | dist,
 |  | int | prevMinLevel[3],
 |  | int | prevMaxLevel[3]
 | ) | [protected]

void vtkCellLocator::ClearCellHasBeenVisited ( ) [protected]

void vtkCellLocator::ClearCellHasBeenVisited ( int id ) [protected]

float vtkCellLocator::Distance2ToBucket | ( | float | x[3],
 |  | int | nei[3]
 | ) | [protected]

float vtkCellLocator::Distance2ToBounds | ( | float | x[3],
 |  | float | bounds[6]
 | ) | [protected]

void vtkCellLocator::MarkParents | ( | void * | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [protected]

void vtkCellLocator::GetChildren | ( | int | idx,
 |  | int | level,
 |  | int | children[8]
 | ) | [protected]

int vtkCellLocator::GenerateIndex | ( | int | offset,
 |  | int | numDivs,
 |  | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkIdType & | idx
 | ) | [protected]

void vtkCellLocator::GenerateFace | ( | int | face,
 |  | int | numDivs,
 |  | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

Member Data Documentation

int vtkCellLocator::NumberOfCellsPerBucket [protected]

Definition at line 218 of file vtkCellLocator.h.

int vtkCellLocator::NumberOfOctants [protected]

Definition at line 219 of file vtkCellLocator.h.

float vtkCellLocator::Bounds[6] [protected]

Definition at line 220 of file vtkCellLocator.h.

int vtkCellLocator::NumberOfParents [protected]

Definition at line 221 of file vtkCellLocator.h.

float vtkCellLocator::H[3] [protected]

Definition at line 222 of file vtkCellLocator.h.

int vtkCellLocator::NumberOfDivisions [protected]

Definition at line 223 of file vtkCellLocator.h.

vtkIdList** vtkCellLocator::Tree [protected]

Reimplemented in vtkOBBTree.

Definition at line 224 of file vtkCellLocator.h.

vtkNeighborCells* vtkCellLocator::Buckets [protected]

Definition at line 233 of file vtkCellLocator.h.

unsigned char* vtkCellLocator::CellHasBeenVisited [protected]

Definition at line 234 of file vtkCellLocator.h.

unsigned char vtkCellLocator::QueryNumber [protected]

Definition at line 235 of file vtkCellLocator.h.

int vtkCellLocator::CacheCellBounds [protected]

Definition at line 236 of file vtkCellLocator.h.

float(* vtkCellLocator::CellBounds)[6] [protected]

Definition at line 238 of file vtkCellLocator.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkCellLocator.h
Generated on Mon Mar 25 01:16:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellPicker Class Reference

select a cell by shooting a ray into graphics window. More...

#include <vtkCellPicker.h>

Inheritance diagram for vtkCellPicker:

[legend]
Collaboration diagram for vtkCellPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellPicker, vtkPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkIdType | GetCellId ()
virtual int | GetSubId ()
virtual float * | GetPCoords ()
virtual void | GetPCoords (float data[3])

Static Public Methods

vtkCellPicker * | New ()

Protected Methods

vtkCellPicker ()
~vtkCellPicker ()
virtual float | IntersectWithLine (float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m)
void | Initialize ()

Protected Attributes

vtkIdType CellId
int | SubId
float | PCoords [3]

Detailed Description

select a cell by shooting a ray into graphics window.

Date:
2002/01/22 15:38:29
Revision:
1.35

vtkCellPicker is used to select a cell by shooting a ray into graphics window and intersecting with actor's defining geometry - specifically its cells. Beside returning coordinates, actor and mapper, vtkCellPicker returns the id of the closest cell within the tolerance along the pick ray, and the dataset that was picked.

See also:
vtkPicker vtkPointPicker
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Martin, Ken (12%)
  • Miller, Jim (6%)
Examples:
vtkCellPicker (Examples)
Tests:
vtkCellPicker (Tests)

Definition at line 52 of file vtkCellPicker.h.

Constructor & Destructor Documentation

vtkCellPicker::vtkCellPicker ( ) [protected]

vtkCellPicker::~vtkCellPicker ( ) [protected]

Member Function Documentation

vtkCellPicker* vtkCellPicker::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkPicker.

vtkCellPicker::vtkTypeRevisionMacro | ( | vtkCellPicker | ,
 |  | vtkPicker |
 | ) |

Reimplemented from vtkPicker.

void vtkCellPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPicker.

virtual vtkIdType vtkCellPicker::GetCellId ( ) [virtual]

Get the id of the picked cell. If CellId = -1, nothing was picked.

virtual int vtkCellPicker::GetSubId ( ) [virtual]

Get the subId of the picked cell. If SubId = -1, nothing was picked.

virtual float* vtkCellPicker::GetPCoords ( ) [virtual]

Get the parametric coordinates of the picked cell. Only valid if pick was made.

virtual void vtkCellPicker::GetPCoords ( float data[3] ) [virtual]

Get the parametric coordinates of the picked cell. Only valid if pick was made.

virtual float vtkCellPicker::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | vtkAssemblyPath * | path,
 |  | vtkProp3D * | p,
 |  | vtkAbstractMapper3D * | m
 | ) | [protected, virtual]

Reimplemented from vtkPicker.

void vtkCellPicker::Initialize ( ) [protected, virtual]

Reimplemented from vtkPicker.

Member Data Documentation

vtkIdType vtkCellPicker::CellId [protected]

Definition at line 79 of file vtkCellPicker.h.

int vtkCellPicker::SubId [protected]

Definition at line 80 of file vtkCellPicker.h.

float vtkCellPicker::PCoords[3] [protected]

Definition at line 81 of file vtkCellPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkCellPicker.h
Generated on Mon Mar 25 01:16:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellType Class Reference

define types of cells. More...

#include <vtkCellType.h>

Detailed Description

define types of cells.

Date:
2002/03/06 15:39:59
Revision:
1.20

vtkCellType defines the allowable cell types in the visualization library (vtk). In vtk, datasets consist of collections of cells. Different datasets consist of different cell types. The cells may be explicitly represented (as in vtkPolyData), or may be implicit to the data type (as in vtkStructuredPoints).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (100%)

The documentation for this class was generated from the following file:
  • Common/vtkCellType.h
Generated on Mon Mar 25 01:16:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCellTypes Class Reference

object provides direct access to cells in vtkCellArray and type information. More...

#include <vtkCellTypes.h>

Inheritance diagram for vtkCellTypes:

[legend]
Collaboration diagram for vtkCellTypes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCellTypes, vtkObject)
int | Allocate (int sz=512, int ext=1000)
void | InsertCell (int id, unsigned char type, int loc)
int | InsertNextCell (unsigned char type, int loc)
void | SetCellTypes (int ncells, vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations)
int | GetCellLocation (int cellId)
void | DeleteCell (int cellId)
int | GetNumberOfTypes ()
int | IsType (unsigned char type)
int | InsertNextType (unsigned char type)
unsigned char | GetCellType (int cellId)
void | Squeeze ()
void | Reset ()
unsigned long | GetActualMemorySize ()
void | DeepCopy (vtkCellTypes *src)

Static Public Methods

vtkCellTypes * | New ()

Protected Methods

vtkCellTypes ()
~vtkCellTypes ()

Protected Attributes

vtkUnsignedCharArray * TypeArray
vtkIntArray * LocationArray
int | Size
int | MaxId
int | Extend

Detailed Description

object provides direct access to cells in vtkCellArray and type information.

Date:
2002/01/22 15:25:14
Revision:
1.24

This class is a supplemental object to vtkCellArray to allow random access into cells as well as representing cell type information. The "location" field is the location in the vtkCellArray list in terms of an integer offset. An integer offset was used instead of a pointer for easy storage and inter-process communication. The type information is defined in the file vtkCellType.h.

Warning:
Sometimes this class is used to pass type information independent of the random access (i.e., location) information. For example, see vtkDataSet::GetCellTypes(). If you use the class in this way, you can use a location value of -1.
See also:
vtkCellArray vtkCellLinks
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Lee, Jeff (24%)
  • Martin, Ken (12%)
  • Miller, Jim (6%)
Tests:
vtkCellTypes (Tests)

Definition at line 60 of file vtkCellTypes.h.

Constructor & Destructor Documentation

vtkCellTypes::vtkCellTypes ( ) [protected]

vtkCellTypes::~vtkCellTypes ( ) [protected]

Member Function Documentation

vtkCellTypes* vtkCellTypes::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkCellTypes::vtkTypeRevisionMacro | ( | vtkCellTypes | ,
 |  | vtkObject |
 | ) |

int vtkCellTypes::Allocate | ( | int | sz = 512,
 |  | int | ext = 1000
 | ) |

Allocate memory for this array. Delete old storage only if necessary.

void vtkCellTypes::InsertCell | ( | int | id,
 |  | unsigned char | type,
 |  | int | loc
 | ) |

Add a cell at specified id.

int vtkCellTypes::InsertNextCell | ( | unsigned char | type,
 |  | int | loc
 | ) |

Add a cell to the object in the next available slot.

void vtkCellTypes::SetCellTypes | ( | int | ncells,
 |  | vtkUnsignedCharArray * | cellTypes,
 |  | vtkIntArray * | cellLocations
 | ) |

Specify a group of cell types.

int vtkCellTypes::GetCellLocation ( int cellId ) [inline]

Return the location of the cell in the associated vtkCellArray.

Definition at line 79 of file vtkCellTypes.h.

void vtkCellTypes::DeleteCell ( int cellId ) [inline]

Delete cell by setting to NULL cell type.

Definition at line 82 of file vtkCellTypes.h.

Referenced by vtkPolyData::DeleteCell().

int vtkCellTypes::GetNumberOfTypes ( ) [inline]

Return the number of types in the list.

Definition at line 85 of file vtkCellTypes.h.

Referenced by IsType().

int vtkCellTypes::IsType ( unsigned char type ) [inline]

Return 1 if type specified is contained in list; 0 otherwise.

Definition at line 131 of file vtkCellTypes.h.

int vtkCellTypes::InsertNextType ( unsigned char type ) [inline]

Add the type specified to the end of the list. Range checking is performed.

Definition at line 92 of file vtkCellTypes.h.

unsigned char vtkCellTypes::GetCellType ( int cellId ) [inline]

Return the type of cell.

Definition at line 95 of file vtkCellTypes.h.

Referenced by IsType().

void vtkCellTypes::Squeeze ( )

Reclaim any extra memory.

void vtkCellTypes::Reset ( )

Initialize object without releasing memory.

unsigned long vtkCellTypes::GetActualMemorySize ( )

Return the memory in kilobytes consumed by this cell type array. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object. The information returned is valid only after the pipeline has been updated.

void vtkCellTypes::DeepCopy ( vtkCellTypes * src )

Standard DeepCopy method. Since this object contains no reference to other objects, there is no ShallowCopy.

Member Data Documentation

vtkUnsignedCharArray* vtkCellTypes::TypeArray [protected]

Definition at line 119 of file vtkCellTypes.h.

vtkIntArray* vtkCellTypes::LocationArray [protected]

Definition at line 120 of file vtkCellTypes.h.

int vtkCellTypes::Size [protected]

Definition at line 121 of file vtkCellTypes.h.

int vtkCellTypes::MaxId [protected]

Definition at line 122 of file vtkCellTypes.h.

int vtkCellTypes::Extend [protected]

Definition at line 123 of file vtkCellTypes.h.

The documentation for this class was generated from the following file:
  • Common/vtkCellTypes.h
Generated on Mon Mar 25 01:16:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCGMWriter Class Reference

write polygonal data as a CGM file. More...

#include <vtkCGMWriter.h>

Inheritance diagram for vtkCGMWriter:

[legend]
Collaboration diagram for vtkCGMWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCGMWriter, vtkPolyDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetViewport (vtkViewport *)
virtual vtkViewport * | GetViewport ()
virtual void | SetSort (int)
virtual int | GetSort ()
virtual void | SetResolution (int)
virtual int | GetResolution ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToDefault ()
void | SetColorModeToSpecifiedColor ()
void | SetColorModeToRandomColors ()
virtual void | SetSpecifiedColor (float, float, float)
virtual void | SetSpecifiedColor (float[3])
virtual float * | GetSpecifiedColor ()
virtual void | GetSpecifiedColor (float data[3])

Static Public Methods

vtkCGMWriter * | New ()

Protected Methods

vtkCGMWriter ()
~vtkCGMWriter ()
void | WriteData ()

Protected Attributes

vtkViewport * Viewport
int | ColorMode
float | SpecifiedColor [3]
int | Resolution
int | Sort

Detailed Description

write polygonal data as a CGM file.

Date:
2002/01/22 15:38:09
Revision:
1.9

vtkCGMWriter writes CGM (Computer Graphics Metafile) output. CGM is a 2D graphics vector format typically used by large plotters. This writer can handle vertices, lines, polygons, and triangle strips in any combination. Colors are specified either 1) from cell scalars (assumed to be RGB or RGBA color specification), 2) from a specified color; or 3) randomly assigned colors.

Note: During output of the polygonal data, stringle strips are converted to triangles, and polylines to lines. Also, due to limitations in the CGM color model, only 256 colors are available to the color palette.

Warning:
The class vtkImageToPolyDataFilter is convenient for converting a raster image into polygons (and color map) suitable for plotting with CGM.
See also:
vtkPolyDataWriter vtkPointDataToCellData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (99%)

Definition at line 57 of file vtkCGMWriter.h.

Constructor & Destructor Documentation

vtkCGMWriter::vtkCGMWriter ( ) [protected]

vtkCGMWriter::~vtkCGMWriter ( ) [protected]

Member Function Documentation

vtkCGMWriter* vtkCGMWriter::New ( ) [inline, static]

Instantiate with no viewport defined and sorting on. The default resolution is 10,000, and the color mode is set to default.

Reimplemented from vtkPolyDataWriter.

Definition at line 62 of file vtkCGMWriter.h.

vtkCGMWriter::vtkTypeRevisionMacro | ( | vtkCGMWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkCGMWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPolyDataWriter.

virtual void vtkCGMWriter::SetViewport ( vtkViewport * ) [virtual]

Specify a vtkViewport object to be used to transform the vtkPolyData points into 2D coordinates. By default (no vtkViewport specified), the point coordinates are generated by ignoring the z values. If a viewport is defined, then the points are transformed into viewport coordinates.

virtual vtkViewport* vtkCGMWriter::GetViewport ( ) [virtual]

Specify a vtkViewport object to be used to transform the vtkPolyData points into 2D coordinates. By default (no vtkViewport specified), the point coordinates are generated by ignoring the z values. If a viewport is defined, then the points are transformed into viewport coordinates.

virtual void vtkCGMWriter::SetSort ( int ) [virtual]

Turn on/off the sorting of the cells via depth. If enabled, polygonal cells will be sorted from back to front, i.e., a Painter's algorithm sort.

virtual int vtkCGMWriter::GetSort ( ) [virtual]

Turn on/off the sorting of the cells via depth. If enabled, polygonal cells will be sorted from back to front, i.e., a Painter's algorithm sort.

virtual void vtkCGMWriter::SetResolution ( int ) [virtual]

Specify the resolution of the CGM file. This number is used to integerize the maximum coordinate range of the plot file.

virtual int vtkCGMWriter::GetResolution ( ) [virtual]

Specify the resolution of the CGM file. This number is used to integerize the maximum coordinate range of the plot file.

virtual void vtkCGMWriter::SetColorMode ( int ) [virtual]

Control how output polydata is colored. By default (ColorModeToDefault), if per cell colors are defined (unsigned chars of 1-4 components), then the cells are colored with these values. (If point colors are defined and cell colors are not, you can use vtkPointDataToCellData to convert the point colors to cell colors.) Otherwise, by default, the cells are set to the specified color. If ColorModeToSpecifiedColor is set, then the primitives will all be set to this color. If ColorModeToRandomColors is set, each cell will be randomly assigned a color.

virtual int vtkCGMWriter::GetColorMode ( ) [virtual]

Control how output polydata is colored. By default (ColorModeToDefault), if per cell colors are defined (unsigned chars of 1-4 components), then the cells are colored with these values. (If point colors are defined and cell colors are not, you can use vtkPointDataToCellData to convert the point colors to cell colors.) Otherwise, by default, the cells are set to the specified color. If ColorModeToSpecifiedColor is set, then the primitives will all be set to this color. If ColorModeToRandomColors is set, each cell will be randomly assigned a color.

void vtkCGMWriter::SetColorModeToDefault ( ) [inline]

Control how output polydata is colored. By default (ColorModeToDefault), if per cell colors are defined (unsigned chars of 1-4 components), then the cells are colored with these values. (If point colors are defined and cell colors are not, you can use vtkPointDataToCellData to convert the point colors to cell colors.) Otherwise, by default, the cells are set to the specified color. If ColorModeToSpecifiedColor is set, then the primitives will all be set to this color. If ColorModeToRandomColors is set, each cell will be randomly assigned a color.

Definition at line 104 of file vtkCGMWriter.h.

void vtkCGMWriter::SetColorModeToSpecifiedColor ( ) [inline]

Control how output polydata is colored. By default (ColorModeToDefault), if per cell colors are defined (unsigned chars of 1-4 components), then the cells are colored with these values. (If point colors are defined and cell colors are not, you can use vtkPointDataToCellData to convert the point colors to cell colors.) Otherwise, by default, the cells are set to the specified color. If ColorModeToSpecifiedColor is set, then the primitives will all be set to this color. If ColorModeToRandomColors is set, each cell will be randomly assigned a color.

Definition at line 106 of file vtkCGMWriter.h.

void vtkCGMWriter::SetColorModeToRandomColors ( ) [inline]

Control how output polydata is colored. By default (ColorModeToDefault), if per cell colors are defined (unsigned chars of 1-4 components), then the cells are colored with these values. (If point colors are defined and cell colors are not, you can use vtkPointDataToCellData to convert the point colors to cell colors.) Otherwise, by default, the cells are set to the specified color. If ColorModeToSpecifiedColor is set, then the primitives will all be set to this color. If ColorModeToRandomColors is set, each cell will be randomly assigned a color.

Definition at line 108 of file vtkCGMWriter.h.

virtual void vtkCGMWriter::SetSpecifiedColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the specified color to color the polydata cells. This color is only used when the color mode is set to ColorModeToSpecifiedColor, or ColorModeToDefault is set and no cell colors are specified. The specified color is specified as RGB values ranging from (0,1). (Note: CGM will map this color to the closest color it supports.)

virtual void vtkCGMWriter::SetSpecifiedColor ( float [3] ) [virtual]

Set/Get the specified color to color the polydata cells. This color is only used when the color mode is set to ColorModeToSpecifiedColor, or ColorModeToDefault is set and no cell colors are specified. The specified color is specified as RGB values ranging from (0,1). (Note: CGM will map this color to the closest color it supports.)

virtual float* vtkCGMWriter::GetSpecifiedColor ( ) [virtual]

Set/Get the specified color to color the polydata cells. This color is only used when the color mode is set to ColorModeToSpecifiedColor, or ColorModeToDefault is set and no cell colors are specified. The specified color is specified as RGB values ranging from (0,1). (Note: CGM will map this color to the closest color it supports.)

virtual void vtkCGMWriter::GetSpecifiedColor ( float data[3] ) [virtual]

Set/Get the specified color to color the polydata cells. This color is only used when the color mode is set to ColorModeToSpecifiedColor, or ColorModeToDefault is set and no cell colors are specified. The specified color is specified as RGB values ranging from (0,1). (Note: CGM will map this color to the closest color it supports.)

void vtkCGMWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

Member Data Documentation

vtkViewport* vtkCGMWriter::Viewport [protected]

Definition at line 127 of file vtkCGMWriter.h.

int vtkCGMWriter::ColorMode [protected]

Definition at line 128 of file vtkCGMWriter.h.

float vtkCGMWriter::SpecifiedColor[3] [protected]

Definition at line 129 of file vtkCGMWriter.h.

int vtkCGMWriter::Resolution [protected]

Definition at line 130 of file vtkCGMWriter.h.

int vtkCGMWriter::Sort [protected]

Definition at line 131 of file vtkCGMWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkCGMWriter.h
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCharArray Class Reference

dynamic, self-adjusting character array. More...

#include <vtkCharArray.h>

Inheritance diagram for vtkCharArray:

[legend]
Collaboration diagram for vtkCharArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCharArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
char | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
char * | WritePointer (const vtkIdType id, const vtkIdType number)
void | InsertValue (const vtkIdType id, const char c)
vtkIdType | InsertNextValue (const char c)
void | DeepCopy (vtkDataArray *ia)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const char value)
void * | GetVoidPointer (const vtkIdType id)
char * | GetPointer (const vtkIdType id)
void | SetArray (char *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkCharArray * | New ()

Protected Methods

vtkCharArray (vtkIdType numComp=1)
~vtkCharArray ()
char * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

char * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting character array.

Date:
2002/02/13 22:46:27
Revision:
1.44

vtkCharArray is an array of character values. It provides methods for insertion and retrieval of characters, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (20%)
  • Henderson, Amy (8%)
  • Geveci, Berk (8%)
  • Kelly, Ann (7%)
  • Miller, Jim (6%)
Tests:
vtkCharArray (Tests)

Definition at line 46 of file vtkCharArray.h.

Constructor & Destructor Documentation

vtkCharArray::vtkCharArray ( vtkIdType numComp = 1 ) [protected]

vtkCharArray::~vtkCharArray ( ) [protected]

Member Function Documentation

vtkCharArray* vtkCharArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkCharArray::vtkTypeRevisionMacro | ( | vtkCharArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkCharArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkCharArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkCharArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkCharArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkCharArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkCharArray.h.

int vtkCharArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkCharArray.h.

void vtkCharArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of tuples in the array. Note that this allocates space depending on the tuple dimension.

Reimplemented from vtkDataArray.

float* vtkCharArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkCharArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkCharArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkCharArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkCharArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkCharArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkCharArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkCharArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkCharArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkCharArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 105 of file vtkCharArray.h.

virtual void vtkCharArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

float vtkCharArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkCharArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkCharArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

char vtkCharArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 127 of file vtkCharArray.h.

void vtkCharArray::SetValue | ( | const vtkIdType | id,
 |  | const char | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 132 of file vtkCharArray.h.

void vtkCharArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 196 of file vtkCharArray.h.

char * vtkCharArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 206 of file vtkCharArray.h.

void vtkCharArray::InsertValue | ( | const vtkIdType | id,
 |  | const char | c
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 221 of file vtkCharArray.h.

Referenced by InsertNextValue().

vtkIdType vtkCharArray::InsertNextValue ( const char c ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 234 of file vtkCharArray.h.

void* vtkCharArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 156 of file vtkCharArray.h.

char* vtkCharArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 158 of file vtkCharArray.h.

void vtkCharArray::DeepCopy ( vtkDataArray * ia ) [virtual]

Deep copy of another char array.

Reimplemented from vtkDataArray.

void vtkCharArray::SetArray | ( | char * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkCharArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 172 of file vtkCharArray.h.

char* vtkCharArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

char* vtkCharArray::Array [protected]

Definition at line 180 of file vtkCharArray.h.

int vtkCharArray::TupleSize [protected]

Definition at line 183 of file vtkCharArray.h.

float* vtkCharArray::Tuple [protected]

Definition at line 184 of file vtkCharArray.h.

int vtkCharArray::SaveUserArray [protected]

Definition at line 186 of file vtkCharArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkCharArray.h
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Chunk Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Chunk:

[legend]
List of all members.

Public Attributes

dword start
dword end
dword length
word tag

Member Data Documentation

dword Chunk::start

Definition at line 157 of file vtk3DS.h.

dword Chunk::end

Definition at line 158 of file vtk3DS.h.

dword Chunk::length

Definition at line 159 of file vtk3DS.h.

word Chunk::tag

Definition at line 160 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCleanPolyData Class Reference

merge duplicate points, and/or remove unused points and/or remove degenerate cells. More...

#include <vtkCleanPolyData.h>

Inheritance diagram for vtkCleanPolyData:

[legend]
Collaboration diagram for vtkCleanPolyData:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkCleanPolyData, vtkPolyDataToPolyDataFilter)
void | CreateDefaultLocator (void)
void | ReleaseLocator (void)
unsigned long int | GetMTime ()
virtual void | OperateOnPoint (float in[3], float out[3])
virtual void | OperateOnBounds (float in[6], float out[6])
virtual void | SetPieceInvariant (int)
virtual int | GetPieceInvariant ()
virtual void | PieceInvariantOn ()
virtual void | PieceInvariantOff ()
virtual void | SetToleranceIsAbsolute (int)
virtual void | ToleranceIsAbsoluteOn ()
virtual void | ToleranceIsAbsoluteOff ()
virtual int | GetToleranceIsAbsolute ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()
virtual void | SetAbsoluteTolerance (float)
virtual float | GetAbsoluteTolerance ()
virtual void | SetConvertLinesToPoints (int)
virtual void | ConvertLinesToPointsOn ()
virtual void | ConvertLinesToPointsOff ()
virtual int | GetConvertLinesToPoints ()
virtual void | SetConvertPolysToLines (int)
virtual void | ConvertPolysToLinesOn ()
virtual void | ConvertPolysToLinesOff ()
virtual int | GetConvertPolysToLines ()
virtual void | SetConvertStripsToPolys (int)
virtual void | ConvertStripsToPolysOn ()
virtual void | ConvertStripsToPolysOff ()
virtual int | GetConvertStripsToPolys ()
virtual void | SetPointMerging (int)
virtual int | GetPointMerging ()
virtual void | PointMergingOn ()
virtual void | PointMergingOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkCleanPolyData * | New ()

Protected Methods

vtkCleanPolyData ()
~vtkCleanPolyData ()
void | Execute ()
void | ExecuteInformation ()
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | PointMerging
float | Tolerance
float | AbsoluteTolerance
int | ConvertLinesToPoints
int | ConvertPolysToLines
int | ConvertStripsToPolys
int | ToleranceIsAbsolute
vtkPointLocator * Locator
int | PieceInvariant

Detailed Description

merge duplicate points, and/or remove unused points and/or remove degenerate cells.

Date:
2002/01/22 15:29:10
Revision:
1.51

vtkCleanPolyData is a filter that takes polygonal data as input and generates polygonal data as output. vtkCleanPolyData can merge duplicate points (within specified tolerance and if enabled), eliminate points that are not used, and if enabled, transform degenerate cells into appropriate forms (for example, a triangle is converted into a line if two points of triangle are merged).

Conversion of degenerate cells is controlled by the flags ConvertLinesToPoints, ConvertPolysToLines, ConvertStripsToPolys which act cumulatively such that a degenerate strip may become a poly. The full set is Line with 1 points -> Vert (if ConvertLinesToPoints) Poly with 2 points -> Line (if ConvertPolysToLines) Poly with 1 points -> Vert (if ConvertPolysToLines && ConvertLinesToPoints) Strp with 3 points -> Poly (if ConvertStripsToPolys) Strp with 2 points -> Line (if ConvertStripsToPolys && ConvertPolysToLines) Strp with 1 points -> Vert (if ConvertStripsToPolys && ConvertPolysToLines && ConvertLinesToPoints)

If tolerance is specified precisely=0.0, then vtkCleanPolyData will use the vtkMergePoints object to merge points (which is faster). Otherwise the slower vtkPointLocator is used. Before inserting points into the point locator, this class calls a function OperateOnPoint which can be used (in subclasses) to further refine the cleaning process. See vtkQuantizePolyDataPoints.

Note that merging of points can be disabled. In this case, a point locator will not be used, and points that are not used by any cells will be eliminated, but never merged.

Warning:
Merging points can alter topology, including introducing non-manifold forms. The tolerance should be chosen carefully to avoid these problems. Subclasses should handle OperateOnBounds as well as OperateOnPoint to ensure that the locator is correctly initialized (i.e. all modified points must lie inside modified bounds).
See also:
vtkQuantizePolyDataPoints
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (56%)
  • Biddiscombe, John (25%)
  • Law, Charles (6%)
Tests:
vtkCleanPolyData (Tests)

Definition at line 79 of file vtkCleanPolyData.h.

Constructor & Destructor Documentation

vtkCleanPolyData::vtkCleanPolyData ( ) [protected]

vtkCleanPolyData::~vtkCleanPolyData ( ) [protected]

Member Function Documentation

vtkCleanPolyData* vtkCleanPolyData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkQuantizePolyDataPoints.

void vtkCleanPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkQuantizePolyDataPoints.

vtkCleanPolyData::vtkTypeRevisionMacro | ( | vtkCleanPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

Reimplemented in vtkQuantizePolyDataPoints.

virtual void vtkCleanPolyData::SetToleranceIsAbsolute ( int ) [virtual]

By default ToleranceIsAbsolute is false and Tolerance is a fraction of Bounding box diagonal, if true, AbsoluteTolerance is used when adding points to locator (merging)

virtual void vtkCleanPolyData::ToleranceIsAbsoluteOn ( ) [virtual]

By default ToleranceIsAbsolute is false and Tolerance is a fraction of Bounding box diagonal, if true, AbsoluteTolerance is used when adding points to locator (merging)

virtual void vtkCleanPolyData::ToleranceIsAbsoluteOff ( ) [virtual]

By default ToleranceIsAbsolute is false and Tolerance is a fraction of Bounding box diagonal, if true, AbsoluteTolerance is used when adding points to locator (merging)

virtual int vtkCleanPolyData::GetToleranceIsAbsolute ( ) [virtual]

By default ToleranceIsAbsolute is false and Tolerance is a fraction of Bounding box diagonal, if true, AbsoluteTolerance is used when adding points to locator (merging)

virtual void vtkCleanPolyData::SetTolerance ( float ) [virtual]

Specify tolerance in terms of fraction of bounding box length.

virtual float vtkCleanPolyData::GetTolerance ( ) [virtual]

Specify tolerance in terms of fraction of bounding box length.

virtual void vtkCleanPolyData::SetAbsoluteTolerance ( float ) [virtual]

Specify tolerance in absolute terms

virtual float vtkCleanPolyData::GetAbsoluteTolerance ( ) [virtual]

Specify tolerance in absolute terms

virtual void vtkCleanPolyData::SetConvertLinesToPoints ( int ) [virtual]

Turn on/off conversion of degenerate lines to points

virtual void vtkCleanPolyData::ConvertLinesToPointsOn ( ) [virtual]

Turn on/off conversion of degenerate lines to points

virtual void vtkCleanPolyData::ConvertLinesToPointsOff ( ) [virtual]

Turn on/off conversion of degenerate lines to points

virtual int vtkCleanPolyData::GetConvertLinesToPoints ( ) [virtual]

Turn on/off conversion of degenerate lines to points

virtual void vtkCleanPolyData::SetConvertPolysToLines ( int ) [virtual]

Turn on/off conversion of degenerate polys to lines

virtual void vtkCleanPolyData::ConvertPolysToLinesOn ( ) [virtual]

Turn on/off conversion of degenerate polys to lines

virtual void vtkCleanPolyData::ConvertPolysToLinesOff ( ) [virtual]

Turn on/off conversion of degenerate polys to lines

virtual int vtkCleanPolyData::GetConvertPolysToLines ( ) [virtual]

Turn on/off conversion of degenerate polys to lines

virtual void vtkCleanPolyData::SetConvertStripsToPolys ( int ) [virtual]

Turn on/off conversion of degenerate strips to polys

virtual void vtkCleanPolyData::ConvertStripsToPolysOn ( ) [virtual]

Turn on/off conversion of degenerate strips to polys

virtual void vtkCleanPolyData::ConvertStripsToPolysOff ( ) [virtual]

Turn on/off conversion of degenerate strips to polys

virtual int vtkCleanPolyData::GetConvertStripsToPolys ( ) [virtual]

Turn on/off conversion of degenerate strips to polys

virtual void vtkCleanPolyData::SetPointMerging ( int ) [virtual]

Set/Get a boolean value that controls whether point merging is performed. If on, a locator will be used, and points laying within the appropriate tolerance may be merged. If off, points are never merged. By default, merging is on.

virtual int vtkCleanPolyData::GetPointMerging ( ) [virtual]

Set/Get a boolean value that controls whether point merging is performed. If on, a locator will be used, and points laying within the appropriate tolerance may be merged. If off, points are never merged. By default, merging is on.

virtual void vtkCleanPolyData::PointMergingOn ( ) [virtual]

Set/Get a boolean value that controls whether point merging is performed. If on, a locator will be used, and points laying within the appropriate tolerance may be merged. If off, points are never merged. By default, merging is on.

virtual void vtkCleanPolyData::PointMergingOff ( ) [virtual]

Set/Get a boolean value that controls whether point merging is performed. If on, a locator will be used, and points laying within the appropriate tolerance may be merged. If off, points are never merged. By default, merging is on.

void vtkCleanPolyData::SetLocator ( vtkPointLocator * locator )

Set/Get a spatial locator for speeding the search process. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkCleanPolyData::GetLocator ( ) [virtual]

Set/Get a spatial locator for speeding the search process. By default an instance of vtkMergePoints is used.

void vtkCleanPolyData::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

void vtkCleanPolyData::ReleaseLocator ( void )

Release locator

unsigned long int vtkCleanPolyData::GetMTime ( ) [virtual]

Get the MTime of this object also considering the locator.

Reimplemented from vtkObject.

virtual void vtkCleanPolyData::OperateOnPoint | ( | float | in[3],
 |  | float | out[3]
 | ) | [virtual]

Perform operation on a point

Reimplemented in vtkQuantizePolyDataPoints.

virtual void vtkCleanPolyData::OperateOnBounds | ( | float | in[6],
 |  | float | out[6]
 | ) | [virtual]

Perform operation on bounds

Reimplemented in vtkQuantizePolyDataPoints.

virtual void vtkCleanPolyData::SetPieceInvariant ( int ) [virtual]

virtual int vtkCleanPolyData::GetPieceInvariant ( ) [virtual]

virtual void vtkCleanPolyData::PieceInvariantOn ( ) [virtual]

virtual void vtkCleanPolyData::PieceInvariantOff ( ) [virtual]

void vtkCleanPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkCleanPolyData::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkCleanPolyData::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

int vtkCleanPolyData::PointMerging [protected]

Definition at line 178 of file vtkCleanPolyData.h.

float vtkCleanPolyData::Tolerance [protected]

Definition at line 179 of file vtkCleanPolyData.h.

float vtkCleanPolyData::AbsoluteTolerance [protected]

Definition at line 180 of file vtkCleanPolyData.h.

int vtkCleanPolyData::ConvertLinesToPoints [protected]

Definition at line 181 of file vtkCleanPolyData.h.

int vtkCleanPolyData::ConvertPolysToLines [protected]

Definition at line 182 of file vtkCleanPolyData.h.

int vtkCleanPolyData::ConvertStripsToPolys [protected]

Definition at line 183 of file vtkCleanPolyData.h.

int vtkCleanPolyData::ToleranceIsAbsolute [protected]

Definition at line 184 of file vtkCleanPolyData.h.

vtkPointLocator* vtkCleanPolyData::Locator [protected]

Definition at line 185 of file vtkCleanPolyData.h.

int vtkCleanPolyData::PieceInvariant [protected]

Definition at line 187 of file vtkCleanPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCleanPolyData.h
Generated on Mon Mar 25 01:16:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipDataSet Class Reference

clip any dataset with user-specified implicit function or input scalar data. More...

#include <vtkClipDataSet.h>

Inheritance diagram for vtkClipDataSet:

[legend]
Collaboration diagram for vtkClipDataSet:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkClipDataSet, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkUnstructuredGrid * GetClippedOutput ()
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetInsideOut (int)
virtual int | GetInsideOut ()
virtual void | InsideOutOn ()
virtual void | InsideOutOff ()
virtual void | SetClipFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetClipFunction ()
virtual void | SetGenerateClipScalars (int)
virtual int | GetGenerateClipScalars ()
virtual void | GenerateClipScalarsOn ()
virtual void | GenerateClipScalarsOff ()
virtual void | SetGenerateClippedOutput (int)
virtual int | GetGenerateClippedOutput ()
virtual void | GenerateClippedOutputOn ()
virtual void | GenerateClippedOutputOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkClipDataSet * | New ()

Protected Methods

vtkClipDataSet (vtkImplicitFunction *cf=NULL)
~vtkClipDataSet ()
void | Execute ()
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

vtkImplicitFunction * ClipFunction
vtkPointLocator * Locator
int | InsideOut
float | Value
int | GenerateClipScalars
int | GenerateClippedOutput
char * | InputScalarsSelection

Detailed Description

clip any dataset with user-specified implicit function or input scalar data.

Date:
2002/02/08 20:56:31
Revision:
1.7

vtkClipDataSet is a filter that any type of dataset using either any subclass of vtkImplicitFunction, or the input scalar data. Clipping means that it actually "cuts" through the cells of the dataset, returning everything inside of the specified implicit function (or greater than the scalar value) including "pieces" of a cell. (Compare this with vtkExtractGeometry, which pulls out entire, uncut cells.) The output of this filter is an unstructured grid.

To use this filter, you must decide if you will be clipping with an implicit function, or whether you will be using the input scalar data. If you want to clip with an implicit function, you must: 1) define an implicit function 2) set it with the SetClipFunction method 3) apply the GenerateClipScalarsOn method If a ClipFunction is not specified, or GenerateClipScalars is off (the default), then the input's scalar data will be used to clip the polydata.

You can also specify a scalar value, which is used to decide what is inside and outside of the implicit function. You can also reverse the sense of what inside/outside is by setting the InsideOut instance variable. (The clipping algorithm proceeds by computing an implicit function value or using the input scalar data for each point in the dataset. This is compared to the scalar value to determine inside/outside.)

This filter can be configured to compute a second output. The second output is the part of the cell that is clipped away. Set the GenerateClippedData boolean on if you wish to access this output data.

Warning:
vtkClipDataSet will triangulate all types of 3D cells (i.e., create tetrahedra). This is true even if the cell is not actually cut. This is necessary to preserve compatibility across face neighbors. 2D cells will only be triangulated if the cutting function passes through them.
See also:
vtkImplicitFunction vtkCutter vtkClipVolume vtkClipPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (83%)
  • Law, Charles (7%)
Tests:
vtkClipDataSet (Tests)

Definition at line 79 of file vtkClipDataSet.h.

Constructor & Destructor Documentation

vtkClipDataSet::vtkClipDataSet ( vtkImplicitFunction * cf = NULL ) [protected]

vtkClipDataSet::~vtkClipDataSet ( ) [protected]

Member Function Documentation

vtkClipDataSet::vtkTypeRevisionMacro | ( | vtkClipDataSet | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkClipDataSet::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkClipDataSet* vtkClipDataSet::New ( ) [static]

Construct with user-specified implicit function; InsideOut turned off; value set to 0.0; and generate clip scalars turned off.

Reimplemented from vtkUnstructuredGridSource.

virtual void vtkClipDataSet::SetValue ( float ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual float vtkClipDataSet::GetValue ( ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual void vtkClipDataSet::SetInsideOut ( int ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual int vtkClipDataSet::GetInsideOut ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipDataSet::InsideOutOn ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipDataSet::InsideOutOff ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipDataSet::SetClipFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual vtkImplicitFunction* vtkClipDataSet::GetClipFunction ( ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual void vtkClipDataSet::SetGenerateClipScalars ( int ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual int vtkClipDataSet::GetGenerateClipScalars ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipDataSet::GenerateClipScalarsOn ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipDataSet::GenerateClipScalarsOff ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipDataSet::SetGenerateClippedOutput ( int ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual int vtkClipDataSet::GetGenerateClippedOutput ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual void vtkClipDataSet::GenerateClippedOutputOn ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual void vtkClipDataSet::GenerateClippedOutputOff ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

vtkUnstructuredGrid* vtkClipDataSet::GetClippedOutput ( )

Return the Clipped output.

void vtkClipDataSet::SetLocator ( vtkPointLocator * locator )

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkClipDataSet::GetLocator ( ) [virtual]

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkClipDataSet::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

unsigned long vtkClipDataSet::GetMTime ( ) [virtual]

Return the mtime also considering the locator and clip function.

Reimplemented from vtkObject.

virtual char* vtkClipDataSet::GetInputScalarsSelection ( ) [virtual]

If you want to clip by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkClipDataSet::SelectInputScalars ( const char * fieldName ) [inline]

If you want to clip by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 155 of file vtkClipDataSet.h.

void vtkClipDataSet::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkClipDataSet::SetInputScalarsSelection ( const char * ) [protected, virtual]

Member Data Documentation

vtkImplicitFunction* vtkClipDataSet::ClipFunction [protected]

Definition at line 164 of file vtkClipDataSet.h.

vtkPointLocator* vtkClipDataSet::Locator [protected]

Definition at line 166 of file vtkClipDataSet.h.

int vtkClipDataSet::InsideOut [protected]

Definition at line 167 of file vtkClipDataSet.h.

float vtkClipDataSet::Value [protected]

Definition at line 168 of file vtkClipDataSet.h.

int vtkClipDataSet::GenerateClipScalars [protected]

Definition at line 169 of file vtkClipDataSet.h.

int vtkClipDataSet::GenerateClippedOutput [protected]

Definition at line 171 of file vtkClipDataSet.h.

char* vtkClipDataSet::InputScalarsSelection [protected]

Definition at line 173 of file vtkClipDataSet.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkClipDataSet.h
Generated on Mon Mar 25 01:16:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipPolyData Class Reference

clip polygonal data with user-specified implicit function or input scalar data. More...

#include <vtkClipPolyData.h>

Inheritance diagram for vtkClipPolyData:

[legend]
Collaboration diagram for vtkClipPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkClipPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * GetClippedOutput ()
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetInsideOut (int)
virtual int | GetInsideOut ()
virtual void | InsideOutOn ()
virtual void | InsideOutOff ()
virtual void | SetClipFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetClipFunction ()
virtual void | SetGenerateClipScalars (int)
virtual int | GetGenerateClipScalars ()
virtual void | GenerateClipScalarsOn ()
virtual void | GenerateClipScalarsOff ()
virtual void | SetGenerateClippedOutput (int)
virtual int | GetGenerateClippedOutput ()
virtual void | GenerateClippedOutputOn ()
virtual void | GenerateClippedOutputOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkClipPolyData * | New ()

Protected Methods

vtkClipPolyData (vtkImplicitFunction *cf=NULL)
~vtkClipPolyData ()
void | Execute ()

Protected Attributes

vtkImplicitFunction * ClipFunction
vtkPointLocator * Locator
int | InsideOut
float | Value
int | GenerateClipScalars
int | GenerateClippedOutput

Detailed Description

clip polygonal data with user-specified implicit function or input scalar data.

Date:
2002/01/22 15:29:11
Revision:
1.41

vtkClipPolyData is a filter that clips polygonal data using either any subclass of vtkImplicitFunction, or the input scalar data. Clipping means that it actually "cuts" through the cells of the dataset, returning everything inside of the specified implicit function (or greater than the scalar value) including "pieces" of a cell. (Compare this with vtkExtractGeometry, which pulls out entire, uncut cells.) The output of this filter is polygonal data.

To use this filter, you must decide if you will be clipping with an implicit function, or whether you will be using the input scalar data. If you want to clip with an implicit function, you must: 1) define an implicit function 2) set it with the SetClipFunction method 3) apply the GenerateClipScalarsOn method If a ClipFunction is not specified, or GenerateClipScalars is off (the default), then the input's scalar data will be used to clip the polydata.

You can also specify a scalar value, which is used to decide what is inside and outside of the implicit function. You can also reverse the sense of what inside/outside is by setting the InsideOut instance variable. (The cutting algorithm proceeds by computing an implicit function value or using the input scalar data for each point in the dataset. This is compared to the scalar value to determine inside/outside.)

This filter can be configured to compute a second output. The second output is the polygonal data that is clipped away. Set the GenerateClippedData boolean on if you wish to access this output data.

Warning:
In order to cut all types of cells in polygonal data, vtkClipPolyData triangulates some cells, and then cuts the resulting simplices (i.e., points, lines, and triangles). This means that the resulting output may consist of different cell types than the input data.
See also:
vtkImplicitFunction vtkCutter vtkClipVolume
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (63%)
  • Lorensen, Bill (10%)
  • Martin, Ken (10%)
  • Law, Charles (6%)
Examples:
vtkClipPolyData (Examples)
Tests:
vtkClipPolyData (Tests)

Definition at line 83 of file vtkClipPolyData.h.

Constructor & Destructor Documentation

vtkClipPolyData::vtkClipPolyData ( vtkImplicitFunction * cf = NULL ) [protected]

vtkClipPolyData::~vtkClipPolyData ( ) [protected]

Member Function Documentation

vtkClipPolyData::vtkTypeRevisionMacro | ( | vtkClipPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkClipPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkClipPolyData* vtkClipPolyData::New ( ) [static]

Construct with user-specified implicit function; InsideOut turned off; value set to 0.0; and generate clip scalars turned off.

Reimplemented from vtkPolyDataSource.

virtual void vtkClipPolyData::SetValue ( float ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual float vtkClipPolyData::GetValue ( ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual void vtkClipPolyData::SetInsideOut ( int ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual int vtkClipPolyData::GetInsideOut ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipPolyData::InsideOutOn ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipPolyData::InsideOutOff ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipPolyData::SetClipFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual vtkImplicitFunction* vtkClipPolyData::GetClipFunction ( ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual void vtkClipPolyData::SetGenerateClipScalars ( int ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual int vtkClipPolyData::GetGenerateClipScalars ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipPolyData::GenerateClipScalarsOn ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipPolyData::GenerateClipScalarsOff ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipPolyData::SetGenerateClippedOutput ( int ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual int vtkClipPolyData::GetGenerateClippedOutput ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual void vtkClipPolyData::GenerateClippedOutputOn ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

virtual void vtkClipPolyData::GenerateClippedOutputOff ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's been clipped away.

vtkPolyData* vtkClipPolyData::GetClippedOutput ( )

Return the Clipped output.

void vtkClipPolyData::SetLocator ( vtkPointLocator * locator )

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkClipPolyData::GetLocator ( ) [virtual]

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkClipPolyData::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

unsigned long vtkClipPolyData::GetMTime ( ) [virtual]

Return the mtime also considering the locator and clip function.

Reimplemented from vtkObject.

void vtkClipPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkImplicitFunction* vtkClipPolyData::ClipFunction [protected]

Definition at line 160 of file vtkClipPolyData.h.

vtkPointLocator* vtkClipPolyData::Locator [protected]

Definition at line 162 of file vtkClipPolyData.h.

int vtkClipPolyData::InsideOut [protected]

Definition at line 163 of file vtkClipPolyData.h.

float vtkClipPolyData::Value [protected]

Definition at line 164 of file vtkClipPolyData.h.

int vtkClipPolyData::GenerateClipScalars [protected]

Definition at line 165 of file vtkClipPolyData.h.

int vtkClipPolyData::GenerateClippedOutput [protected]

Definition at line 167 of file vtkClipPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkClipPolyData.h
Generated on Mon Mar 25 01:16:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkClipVolume Class Reference

clip volume data with user-specified implicit function or input scalar data. More...

#include <vtkClipVolume.h>

Inheritance diagram for vtkClipVolume:

[legend]
Collaboration diagram for vtkClipVolume:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkClipVolume, vtkStructuredPointsToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkUnstructuredGrid * GetClippedOutput ()
void | CreateDefaultLocator ()
unsigned long int | GetMTime ()
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetInsideOut (int)
virtual int | GetInsideOut ()
virtual void | InsideOutOn ()
virtual void | InsideOutOff ()
virtual void | SetClipFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetClipFunction ()
virtual void | SetGenerateClipScalars (int)
virtual int | GetGenerateClipScalars ()
virtual void | GenerateClipScalarsOn ()
virtual void | GenerateClipScalarsOff ()
virtual void | SetGenerateClippedOutput (int)
virtual int | GetGenerateClippedOutput ()
virtual void | GenerateClippedOutputOn ()
virtual void | GenerateClippedOutputOff ()
virtual void | SetMergeTolerance (float)
virtual float | GetMergeTolerance ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkClipVolume * | New ()

Protected Methods

vtkClipVolume (vtkImplicitFunction *cf=NULL)
~vtkClipVolume ()
void | Execute ()
void | ClipVoxel (float value, vtkDataArray *cellScalars, int flip, float origin[3], float spacing[3], vtkIdList *cellIds, vtkPoints *cellPts, vtkPointData *inPD, vtkPointData *outPD, vtkCellData *inCD, vtkIdType cellId, vtkCellData *outCD, vtkCellData *clippedCD)

Protected Attributes

vtkImplicitFunction * ClipFunction
vtkPointLocator * Locator
int | InsideOut
float | Value
int | GenerateClipScalars
float | MergeTolerance
int | GenerateClippedOutput
vtkUnstructuredGrid * ClippedOutput

Detailed Description

clip volume data with user-specified implicit function or input scalar data.

Date:
2002/01/22 15:29:11
Revision:
1.32

vtkClipVolume is a filter that clips volume data (i.e., structured points) using either: any subclass of vtkImplicitFunction; or the input scalar data. Clipping means that it actually "cuts" through the cells of the dataset, returning everything inside of the specified implicit function (or greater than the scalar value) including "pieces" of a cell. (Compare this with vtkExtractGeometry or vtkGeometryFilter, which pulls out entire, uncut cells.) The output of this filter is a 3D unstructured grid (e.g., tetrahedra).

To use this filter, you must decide if you will be clipping with an implicit function, or whether you will be using the input scalar data. If you want to clip with an implicit function, you must first define and then set the implicit function with the SetClipFunction() method. Otherwise, you must make sure input scalar data is available. You can also specify a scalar value, which is used to decide what is inside and outside of the implicit function. You can also reverse the sense of what inside/outside is by setting the InsideOut instance variable. (The cutting algorithm proceeds by computing an implicit function value or using the input scalar data for each point in the dataset. This is compared to the scalar value to determine inside/outside.)

This filter can be configured to compute a second output. The second output is the portion of the volume that is clipped away. Set the GenerateClippedData boolean on if you wish to access this output data.

Warning:
This filter is designed to function with 3D structured points. Clipping 2D images can be better done by converting the image to polygonal data and using vtkClipPolyData,
See also:
vtkImplicitFunction vtkClipPolyData vtkGeometryFilter vtkExtractGeometry
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Geveci, Berk (10%)
  • Law, Charles (9%)
  • Miller, Jim (6%)
  • Lorensen, Bill (5%)
Tests:
vtkClipVolume (Tests)

Definition at line 78 of file vtkClipVolume.h.

Constructor & Destructor Documentation

vtkClipVolume::vtkClipVolume ( vtkImplicitFunction * cf = NULL ) [protected]

vtkClipVolume::~vtkClipVolume ( ) [protected]

Member Function Documentation

vtkClipVolume::vtkTypeRevisionMacro | ( | vtkClipVolume | ,
 |  | vtkStructuredPointsToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkStructuredPointsToUnstructuredGridFilter.

void vtkClipVolume::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkClipVolume* vtkClipVolume::New ( ) [static]

Construct with user-specified implicit function; InsideOut turned off; value set to 0.0; and generate clip scalars turned off. The merge tolerance is set to 0.01.

Reimplemented from vtkUnstructuredGridSource.

virtual void vtkClipVolume::SetValue ( float ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual float vtkClipVolume::GetValue ( ) [virtual]

Set the clipping value of the implicit function (if clipping with implicit function) or scalar value (if clipping with scalars). The default value is 0.0.

virtual void vtkClipVolume::SetInsideOut ( int ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual int vtkClipVolume::GetInsideOut ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipVolume::InsideOutOn ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipVolume::InsideOutOff ( ) [virtual]

Set/Get the InsideOut flag. When off, a vertex is considered inside the implicit function if its value is greater than the Value ivar. When InsideOutside is turned on, a vertex is considered inside the implicit function if its implicit function value is less than or equal to the Value ivar. InsideOut is off by default.

virtual void vtkClipVolume::SetClipFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual vtkImplicitFunction* vtkClipVolume::GetClipFunction ( ) [virtual]

Specify the implicit function with which to perform the clipping. If you do not define an implicit function, then the input scalar data will be used for clipping.

virtual void vtkClipVolume::SetGenerateClipScalars ( int ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual int vtkClipVolume::GetGenerateClipScalars ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipVolume::GenerateClipScalarsOn ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipVolume::GenerateClipScalarsOff ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data. If you enable this flag but do not provide an implicit function an error will be reported.

virtual void vtkClipVolume::SetGenerateClippedOutput ( int ) [virtual]

Control whether a second output is generated. The second output contains the unstructured grid that's been clipped away.

virtual int vtkClipVolume::GetGenerateClippedOutput ( ) [virtual]

Control whether a second output is generated. The second output contains the unstructured grid that's been clipped away.

virtual void vtkClipVolume::GenerateClippedOutputOn ( ) [virtual]

Control whether a second output is generated. The second output contains the unstructured grid that's been clipped away.

virtual void vtkClipVolume::GenerateClippedOutputOff ( ) [virtual]

Control whether a second output is generated. The second output contains the unstructured grid that's been clipped away.

vtkUnstructuredGrid* vtkClipVolume::GetClippedOutput ( )

Return the clipped output.

virtual void vtkClipVolume::SetMergeTolerance ( float ) [virtual]

Set the tolerance for merging clip intersection points that are near the corners of voxels. This tolerance is used to prevent the generation of degenerate tetrahedra.

virtual float vtkClipVolume::GetMergeTolerance ( ) [virtual]

Set the tolerance for merging clip intersection points that are near the corners of voxels. This tolerance is used to prevent the generation of degenerate tetrahedra.

void vtkClipVolume::SetLocator ( vtkPointLocator * locator )

Set / Get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkClipVolume::GetLocator ( ) [virtual]

Set / Get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkClipVolume::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

unsigned long int vtkClipVolume::GetMTime ( ) [virtual]

Return the mtime also considering the locator and clip function.

Reimplemented from vtkObject.

void vtkClipVolume::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkClipVolume::ClipVoxel | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | int | flip,
 |  | float | origin[3],
 |  | float | spacing[3],
 |  | vtkIdList * | cellIds,
 |  | vtkPoints * | cellPts,
 |  | vtkPointData * | inPD,
 |  | vtkPointData * | outPD,
 |  | vtkCellData * | inCD,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCD,
 |  | vtkCellData * | clippedCD
 | ) | [protected]

Member Data Documentation

vtkImplicitFunction* vtkClipVolume::ClipFunction [protected]

Definition at line 169 of file vtkClipVolume.h.

vtkPointLocator* vtkClipVolume::Locator [protected]

Definition at line 170 of file vtkClipVolume.h.

int vtkClipVolume::InsideOut [protected]

Definition at line 171 of file vtkClipVolume.h.

float vtkClipVolume::Value [protected]

Definition at line 172 of file vtkClipVolume.h.

int vtkClipVolume::GenerateClipScalars [protected]

Definition at line 173 of file vtkClipVolume.h.

float vtkClipVolume::MergeTolerance [protected]

Definition at line 174 of file vtkClipVolume.h.

int vtkClipVolume::GenerateClippedOutput [protected]

Definition at line 176 of file vtkClipVolume.h.

vtkUnstructuredGrid* vtkClipVolume::ClippedOutput [protected]

Definition at line 177 of file vtkClipVolume.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkClipVolume.h
Generated on Mon Mar 25 01:16:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCollection Class Reference

create and manipulate unsorted lists of objects. More...

#include <vtkCollection.h>

Inheritance diagram for vtkCollection:

[legend]
Collaboration diagram for vtkCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCollection, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddItem (vtkObject *)
void | ReplaceItem (int i, vtkObject *)
void | RemoveItem (int i)
void | RemoveItem (vtkObject *)
void | RemoveAllItems ()
int | IsItemPresent (vtkObject *)
int | GetNumberOfItems ()
void | InitTraversal ()
vtkObject * GetNextItemAsObject ()
vtkObject * | GetItemAsObject (int i)

Static Public Methods

vtkCollection * | New ()

Protected Methods

vtkCollection ()
~vtkCollection ()
virtual void | DeleteElement (vtkCollectionElement *)

Protected Attributes

int | NumberOfItems
vtkCollectionElement * Top
vtkCollectionElement * Bottom
vtkCollectionElement * Current

Detailed Description

create and manipulate unsorted lists of objects.

Date:
2002/01/22 15:25:15
Revision:
1.44

vtkCollection is a general object for creating and manipulating lists of objects. The lists are unsorted and allow duplicate entries. vtkCollection also serves as a base class for lists of specific types of objects.

See also:
vtkActorCollection vtkAssemblyPaths vtkDataSetCollection vtkImplicitFunctionCollection vtkLightCollection vtkPolyDataCollection vtkRenderWindowCollection vtkRendererCollection vtkStructuredPointsCollection vtkTransformCollection vtkVolumeCollection
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (50%)
  • Schroeder, Will (17%)
  • Blue, Rusty (8%)
  • Kelly, Ann (7%)

Definition at line 58 of file vtkCollection.h.

Constructor & Destructor Documentation

vtkCollection::vtkCollection ( ) [protected]

vtkCollection::~vtkCollection ( ) [protected]

Member Function Documentation

vtkCollection::vtkTypeRevisionMacro | ( | vtkCollection | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkActor2DCollection, vtkAssemblyPath, vtkAssemblyPaths, vtkDataObjectCollection, vtkDataSetCollection, vtkImplicitFunctionCollection, vtkObjectFactoryCollection, vtkOverrideInformationCollection, vtkPlaneCollection, vtkPropCollection, vtkTransformCollection, vtkPolyDataCollection, vtkStructuredPointsCollection, vtkImageReader2Collection, vtkActorCollection, vtkCullerCollection, vtkImagerCollection, vtkLightCollection, vtkMapperCollection, vtkProp3DCollection, vtkRendererCollection, vtkRenderWindowCollection, and vtkVolumeCollection.

void vtkCollection::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkAssemblyPath.

vtkCollection* vtkCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkObject.

Reimplemented in vtkActor2DCollection, vtkAssemblyPath, vtkAssemblyPaths, vtkDataObjectCollection, vtkDataSetCollection, vtkImplicitFunctionCollection, vtkObjectFactoryCollection, vtkOverrideInformationCollection, vtkPlaneCollection, vtkPropCollection, vtkTransformCollection, vtkPolyDataCollection, vtkStructuredPointsCollection, vtkImageReader2Collection, vtkActorCollection, vtkCullerCollection, vtkImagerCollection, vtkLightCollection, vtkMapperCollection, vtkProp3DCollection, vtkRendererCollection, vtkRenderWindowCollection, and vtkVolumeCollection.

void vtkCollection::AddItem ( vtkObject * o )

Add an object to the list. Does not prevent duplicate entries.

Referenced by vtkVolumeCollection::AddItem(), vtkRenderWindowCollection::AddItem(), vtkRendererCollection::AddItem(), vtkProp3DCollection::AddItem(), vtkMapperCollection::AddItem(), vtkImagerCollection::AddItem(), vtkCullerCollection::AddItem(), vtkActorCollection::AddItem(), vtkImageReader2Collection::AddItem(), vtkStructuredPointsCollection::AddItem(), vtkPolyDataCollection::AddItem(), vtkTransformCollection::AddItem(), vtkPropCollection::AddItem(), vtkPlaneCollection::AddItem(), vtkOverrideInformationCollection::AddItem(), vtkObjectFactoryCollection::AddItem(), vtkImplicitFunctionCollection::AddItem(), vtkDataSetCollection::AddItem(), vtkDataObjectCollection::AddItem(), vtkAssemblyPaths::AddItem(), and vtkAssemblyPath::TransformedProp().

void vtkCollection::ReplaceItem | ( | int | i,
 |  | vtkObject * |
 | ) |

Replace the i'th item in the collection with a

void vtkCollection::RemoveItem ( int i )

Remove the i'th item in the list. Be careful if using this function during traversal of the list using GetNextItemAsObject (or GetNextItem in derived class). The list WILL be shortened if a valid index is given! If this->Current is equal to the element being removed, have it point to then next element in the list.

Referenced by vtkAssemblyPaths::RemoveItem().

void vtkCollection::RemoveItem ( vtkObject * o )

Remove an object from the list. Removes the first object found, not all occurrences. If no object found, list is unaffected. See warning in description of RemoveItem(int).

void vtkCollection::RemoveAllItems ( )

Remove all objects from the list.

int vtkCollection::IsItemPresent ( vtkObject * o )

Search for an object and return location in list. If location == 0, object was not found.

Referenced by vtkAssemblyPaths::IsItemPresent(), and vtkActor2DCollection::IsItemPresent().

int vtkCollection::GetNumberOfItems ( )

Return the number of objects in the list.

void vtkCollection::InitTraversal ( ) [inline]

Initialize the traversal of the collection. This means the data pointer is set at the beginning of the list.

Definition at line 97 of file vtkCollection.h.

vtkObject * vtkCollection::GetNextItemAsObject ( ) [inline]

Get the next item in the collection. NULL is returned if the collection is exhausted.

Definition at line 123 of file vtkCollection.h.

Referenced by vtkActorCollection::GetNextActor(), vtkActor2DCollection::GetNextActor2D(), vtkRenderWindowCollection::GetNextItem(), vtkRendererCollection::GetNextItem(), vtkMapperCollection::GetNextItem(), vtkImagerCollection::GetNextItem(), vtkCullerCollection::GetNextItem(), vtkImageReader2Collection::GetNextItem(), vtkStructuredPointsCollection::GetNextItem(), vtkPolyDataCollection::GetNextItem(), vtkTransformCollection::GetNextItem(), vtkPlaneCollection::GetNextItem(), vtkOverrideInformationCollection::GetNextItem(), vtkObjectFactoryCollection::GetNextItem(), vtkImplicitFunctionCollection::GetNextItem(), vtkDataSetCollection::GetNextItem(), vtkDataObjectCollection::GetNextItem(), vtkAssemblyPaths::GetNextItem(), vtkPropCollection::GetNextProp(), vtkProp3DCollection::GetNextProp3D(), and vtkVolumeCollection::GetNextVolume().

vtkObject* vtkCollection::GetItemAsObject ( int i )

Get the i'th item in the collection. NULL is returned if i is out of range

Referenced by vtkDataSetCollection::GetItem(), and vtkDataObjectCollection::GetItem().

virtual void vtkCollection::DeleteElement ( vtkCollectionElement * ) [protected, virtual]

Reimplemented in vtkActor2DCollection.

Member Data Documentation

int vtkCollection::NumberOfItems [protected]

Definition at line 112 of file vtkCollection.h.

vtkCollectionElement* vtkCollection::Top [protected]

Definition at line 113 of file vtkCollection.h.

vtkCollectionElement* vtkCollection::Bottom [protected]

Definition at line 114 of file vtkCollection.h.

vtkCollectionElement* vtkCollection::Current [protected]

Definition at line 115 of file vtkCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkCollection.h
Generated on Mon Mar 25 01:16:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCollectionElement Class Reference

#include <vtkCollection.h>

Collaboration diagram for vtkCollectionElement:

[legend]
List of all members.

Public Methods

vtkCollectionElement ()

Public Attributes

vtkObject * Item
vtkCollectionElement * Next

Constructor & Destructor Documentation

vtkCollectionElement::vtkCollectionElement ( ) [inline]

Definition at line 52 of file vtkCollection.h.

Member Data Documentation

vtkObject* vtkCollectionElement::Item

Definition at line 53 of file vtkCollection.h.

Referenced by vtkCollection::GetNextItemAsObject().

vtkCollectionElement* vtkCollectionElement::Next

Definition at line 54 of file vtkCollection.h.

Referenced by vtkCollection::GetNextItemAsObject().

The documentation for this class was generated from the following file:
  • Common/vtkCollection.h
Generated on Mon Mar 25 01:16:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkColorTransferFunction Class Reference

Defines a transfer function for mapping a property to an RGB color value. More...

#include <vtkColorTransferFunction.h>

Inheritance diagram for vtkColorTransferFunction:

[legend]
Collaboration diagram for vtkColorTransferFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkColorTransferFunction, vtkScalarsToColors)
void | DeepCopy (vtkColorTransferFunction *f)
void | PrintSelf (ostream &os, vtkIndent indent)
int | GetSize ()
virtual unsigned char * | MapValue (float v)
void | BuildFunctionFromTable (float x1, float x2, int size, float *table)
float * | GetDataPointer ()
void | AddRGBPoint (float x, float r, float g, float b)
void | AddHSVPoint (float x, float h, float s, float v)
void | AddRGBSegment (float x1, float r1, float g1, float b1, float x2, float r2, float g2, float b2)
void | AddHSVSegment (float x1, float h1, float s1, float v1, float x2, float h2, float s2, float v2)
void | RemovePoint (float x)
void | RemoveAllPoints ()
float * | GetColor (float x)
void | GetColor (float x, float rgb[3])
float | GetRedValue (float x)
float | GetGreenValue (float x)
float | GetBlueValue (float x)
virtual float * | GetRange ()
virtual void | GetRange (float &, float &)
virtual void | GetRange (float[2])
void | GetTable (float x1, float x2, int n, float *table)
const unsigned char * | GetTable (float x1, float x2, int n)
virtual void | SetClamping (int)
virtual int | GetClamping ()
virtual void | ClampingOn ()
virtual void | ClampingOff ()
virtual void | SetColorSpace (int)
void | SetColorSpaceToRGB ()
void | SetColorSpaceToHSV ()
virtual int | GetColorSpace ()
virtual void | MapScalarsThroughTable2 (void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement)

Static Public Methods

vtkColorTransferFunction * | New ()

Protected Methods

vtkColorTransferFunction ()
~vtkColorTransferFunction ()
void | RGBToHSV (float r, float g, float b, float &h, float &s, float &v)
void | HSVToRGB (float h, float s, float v, float &r, float &g, float &b)
virtual void | SetRange (float, float)
void | SetRange (float rng[2])

Protected Attributes

int | Clamping
int | ColorSpace
float * | Function
int | FunctionSize
int | NumberOfPoints
unsigned char | UnsignedCharRGBAValue [4]
float | Range [2]
vtkPiecewiseFunction * Red
vtkPiecewiseFunction * Green
vtkPiecewiseFunction * Blue
vtkTimeStamp BuildTime
unsigned char * | Table
int | TableSize

Detailed Description

Defines a transfer function for mapping a property to an RGB color value.

Date:
2002/01/22 15:28:01
Revision:
1.36

vtkColorTransferFunction encapsulates three vtkPiecewiseFunction instances to provide a full RGB transfer function.

See also:
vtkPiecewiseFunction
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (52%)
  • Martin, Ken (28%)
  • Gobbi, David (12%)
Examples:
vtkColorTransferFunction (Examples)
Tests:
vtkColorTransferFunction (Tests)

Definition at line 53 of file vtkColorTransferFunction.h.

Constructor & Destructor Documentation

vtkColorTransferFunction::vtkColorTransferFunction ( ) [protected]

vtkColorTransferFunction::~vtkColorTransferFunction ( ) [protected]

Member Function Documentation

vtkColorTransferFunction* vtkColorTransferFunction::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkColorTransferFunction::vtkTypeRevisionMacro | ( | vtkColorTransferFunction | ,
 |  | vtkScalarsToColors |
 | ) |

Reimplemented from vtkScalarsToColors.

void vtkColorTransferFunction::DeepCopy ( vtkColorTransferFunction * f )

void vtkColorTransferFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print method for vtkColorTransferFunction

Reimplemented from vtkScalarsToColors.

int vtkColorTransferFunction::GetSize ( ) [inline]

How many points are there defining this function?

Definition at line 64 of file vtkColorTransferFunction.h.

void vtkColorTransferFunction::AddRGBPoint | ( | float | x,
 |  | float | r,
 |  | float | g,
 |  | float | b
 | ) |

Add a point to the function defined in RGB or HSV

void vtkColorTransferFunction::AddHSVPoint | ( | float | x,
 |  | float | h,
 |  | float | s,
 |  | float | v
 | ) |

Add a point to the function defined in RGB or HSV

void vtkColorTransferFunction::AddRGBSegment | ( | float | x1,
 |  | float | r1,
 |  | float | g1,
 |  | float | b1,
 |  | float | x2,
 |  | float | r2,
 |  | float | g2,
 |  | float | b2
 | ) |

Add two points to the function and remove all the points between them

void vtkColorTransferFunction::AddHSVSegment | ( | float | x1,
 |  | float | h1,
 |  | float | s1,
 |  | float | v1,
 |  | float | x2,
 |  | float | h2,
 |  | float | s2,
 |  | float | v2
 | ) |

Add two points to the function and remove all the points between them

void vtkColorTransferFunction::RemovePoint ( float x )

Remove a point / remove all points

void vtkColorTransferFunction::RemoveAllPoints ( )

Remove a point / remove all points

float* vtkColorTransferFunction::GetColor ( float x ) [inline]

Returns an RGB color for the specified scalar value (from vtkScalarsToColors)

Reimplemented from vtkScalarsToColors.

Definition at line 89 of file vtkColorTransferFunction.h.

void vtkColorTransferFunction::GetColor | ( | float | x,
 |  | float | rgb[3]
 | ) | [virtual]

Returns an RGB color for the specified scalar value (from vtkScalarsToColors)

Reimplemented from vtkScalarsToColors.

float vtkColorTransferFunction::GetRedValue ( float x )

Get the color components individually.

float vtkColorTransferFunction::GetGreenValue ( float x )

Get the color components individually.

float vtkColorTransferFunction::GetBlueValue ( float x )

Get the color components individually.

virtual unsigned char* vtkColorTransferFunction::MapValue ( float v ) [virtual]

Map one value through the lookup table.

Reimplemented from vtkScalarsToColors.

virtual float* vtkColorTransferFunction::GetRange ( ) [virtual]

Returns min and max position of all function points.

Reimplemented from vtkScalarsToColors.

virtual void vtkColorTransferFunction::GetRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Returns min and max position of all function points.

virtual void vtkColorTransferFunction::GetRange ( float [2] ) [virtual]

Returns min and max position of all function points.

void vtkColorTransferFunction::GetTable | ( | float | x1,
 |  | float | x2,
 |  | int | n,
 |  | float * | table
 | ) |

Fills in a table of n function values between x1 and x2

const unsigned char* vtkColorTransferFunction::GetTable | ( | float | x1,
 |  | float | x2,
 |  | int | n
 | ) |

Fills in a table of n function values between x1 and x2

void vtkColorTransferFunction::BuildFunctionFromTable | ( | float | x1,
 |  | float | x2,
 |  | int | size,
 |  | float * | table
 | ) |

Construct a color transfer function from a table. Function range is is set to [x1, x2], each function size is set to size, and function points are regularly spaced between x1 and x2. Parameter "table" is assumed to be a block of memory of size [3*size]

virtual void vtkColorTransferFunction::SetClamping ( int ) [virtual]

Sets and gets the clamping value for this transfer function.

virtual int vtkColorTransferFunction::GetClamping ( ) [virtual]

Sets and gets the clamping value for this transfer function.

virtual void vtkColorTransferFunction::ClampingOn ( ) [virtual]

Sets and gets the clamping value for this transfer function.

virtual void vtkColorTransferFunction::ClampingOff ( ) [virtual]

Sets and gets the clamping value for this transfer function.

virtual void vtkColorTransferFunction::SetColorSpace ( int ) [virtual]

How should we interpolate - in RGB, or HSV

void vtkColorTransferFunction::SetColorSpaceToRGB ( ) [inline]

How should we interpolate - in RGB, or HSV

Definition at line 131 of file vtkColorTransferFunction.h.

void vtkColorTransferFunction::SetColorSpaceToHSV ( ) [inline]

How should we interpolate - in RGB, or HSV

Definition at line 132 of file vtkColorTransferFunction.h.

virtual int vtkColorTransferFunction::GetColorSpace ( ) [virtual]

How should we interpolate - in RGB, or HSV

float* vtkColorTransferFunction::GetDataPointer ( ) [inline]

Returns a list of all nodes

Definition at line 137 of file vtkColorTransferFunction.h.

virtual void vtkColorTransferFunction::MapScalarsThroughTable2 | ( | void * | input,
 |  | unsigned char * | output,
 |  | int | inputDataType,
 |  | int | numberOfValues,
 |  | int | inputIncrement,
 |  | int | outputIncrement
 | ) | [virtual]

map a set of scalars through the lookup table

Reimplemented from vtkScalarsToColors.

void vtkColorTransferFunction::RGBToHSV | ( | float | r,
 |  | float | g,
 |  | float | b,
 |  | float & | h,
 |  | float & | s,
 |  | float & | v
 | ) | [protected]

void vtkColorTransferFunction::HSVToRGB | ( | float | h,
 |  | float | s,
 |  | float | v,
 |  | float & | r,
 |  | float & | g,
 |  | float & | b
 | ) | [protected]

virtual void vtkColorTransferFunction::SetRange | ( | float | min,
 |  | float | max
 | ) | [inline, protected, virtual]

Set the range of scalars being mapped. The set has no functionality in this subclass of vtkScalarsToColors.

Reimplemented from vtkScalarsToColors.

Definition at line 186 of file vtkColorTransferFunction.h.

void vtkColorTransferFunction::SetRange ( float rng[2] ) [inline, protected]

Set the range of scalars being mapped. The set has no functionality in this subclass of vtkScalarsToColors.

Reimplemented from vtkScalarsToColors.

Definition at line 187 of file vtkColorTransferFunction.h.

Member Data Documentation

int vtkColorTransferFunction::Clamping [protected]

Definition at line 154 of file vtkColorTransferFunction.h.

int vtkColorTransferFunction::ColorSpace [protected]

Definition at line 157 of file vtkColorTransferFunction.h.

float* vtkColorTransferFunction::Function [protected]

Definition at line 160 of file vtkColorTransferFunction.h.

int vtkColorTransferFunction::FunctionSize [protected]

Definition at line 161 of file vtkColorTransferFunction.h.

int vtkColorTransferFunction::NumberOfPoints [protected]

Definition at line 162 of file vtkColorTransferFunction.h.

unsigned char vtkColorTransferFunction::UnsignedCharRGBAValue[4] [protected]

Definition at line 169 of file vtkColorTransferFunction.h.

float vtkColorTransferFunction::Range[2] [protected]

Definition at line 172 of file vtkColorTransferFunction.h.

vtkPiecewiseFunction* vtkColorTransferFunction::Red [protected]

Definition at line 176 of file vtkColorTransferFunction.h.

vtkPiecewiseFunction* vtkColorTransferFunction::Green [protected]

Definition at line 177 of file vtkColorTransferFunction.h.

vtkPiecewiseFunction* vtkColorTransferFunction::Blue [protected]

Definition at line 178 of file vtkColorTransferFunction.h.

vtkTimeStamp vtkColorTransferFunction::BuildTime [protected]

Definition at line 179 of file vtkColorTransferFunction.h.

unsigned char* vtkColorTransferFunction::Table [protected]

Definition at line 180 of file vtkColorTransferFunction.h.

int vtkColorTransferFunction::TableSize [protected]

Definition at line 181 of file vtkColorTransferFunction.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkColorTransferFunction.h
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Colour Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Colour:

[legend]
List of all members.

Public Attributes

float | red
float | green
float | blue

Member Data Documentation

float Colour::red

Definition at line 47 of file vtk3DS.h.

float Colour::green

Definition at line 47 of file vtk3DS.h.

float Colour::blue

Definition at line 47 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Colour_24 Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Colour_24:

[legend]
List of all members.

Public Attributes

byte red
byte green
byte blue

Member Data Documentation

byte Colour_24::red

Definition at line 165 of file vtk3DS.h.

byte Colour_24::green

Definition at line 166 of file vtk3DS.h.

byte Colour_24::blue

Definition at line 167 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCommand Class Reference

superclass for callback/observer methods. More...

#include <vtkCommand.h>

Inheritance diagram for vtkCommand:

[legend]
Collaboration diagram for vtkCommand:

[legend]
List of all members.

Public Types

enum EventIds {
NoEvent = 0, AnyEvent, DeleteEvent, StartEvent,
EndEvent, ProgressEvent, PickEvent, StartPickEvent,
EndPickEvent, AbortCheckEvent, ExitEvent, LeftButtonPressEvent,
LeftButtonReleaseEvent, MiddleButtonPressEvent, MiddleButtonReleaseEvent, RightButtonPressEvent,
RightButtonReleaseEvent, EnterEvent, LeaveEvent, KeyPressEvent,
KeyReleaseEvent, CharEvent, ConfigureEvent, TimerEvent,
MouseMoveEvent, ResetCameraEvent, ResetCameraClippingRangeEvent, ModifiedEvent,
WindowLevelEvent, NextDataEvent, PushDataStartEvent, SetOutputEvent,
EndOfDataEvent, ErrorEvent, WarningEvent, UserEvent = 1000
}

Public Methods

void | Delete ()
virtual void | Execute (vtkObject *caller, unsigned long, void *callData)=0
void | Register ()
void | Register (vtkObject *)
void | UnRegister ()
void | UnRegister (vtkObject *)
void | SetAbortFlagPointer (int *f)
void | SetAbortFlag (int f)
int | GetAbortFlag ()

Static Public Methods

const char * | GetStringFromEventId (unsigned long event)
unsigned long | GetEventIdFromString (const char *event)

Protected Methods

vtkCommand ()
virtual | ~vtkCommand ()

Protected Attributes

int * | AbortFlag
int | ReferenceCount

Detailed Description

superclass for callback/observer methods.

Date:
2002/03/18 17:34:57
Revision:
1.25

vtkCommand is an implementation of the command design pattern that is used in callbacks (such as StartMethod(), ProgressMethod(), and EndMethod()) in VTK. vtkObject implements a Subject/Observer pattern. When a subject needs to notify a observer, it does so using a vtkCommand.

Created by:
  • Gobbi, David
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (37%)
  • Gobbi, David (33%)
  • Lorensen, Bill (12%)
  • Schroeder, Will (10%)

Definition at line 46 of file vtkCommand.h.

Member Enumeration Documentation

enum vtkCommand::EventIds

Enumeration values:
NoEvent
AnyEvent
DeleteEvent
StartEvent
EndEvent
ProgressEvent
PickEvent
StartPickEvent
EndPickEvent
AbortCheckEvent
ExitEvent
LeftButtonPressEvent
LeftButtonReleaseEvent
MiddleButtonPressEvent
MiddleButtonReleaseEvent
RightButtonPressEvent
RightButtonReleaseEvent
EnterEvent
LeaveEvent
KeyPressEvent
KeyReleaseEvent
CharEvent
ConfigureEvent
TimerEvent
MouseMoveEvent
ResetCameraEvent
ResetCameraClippingRangeEvent
ModifiedEvent
WindowLevelEvent
NextDataEvent
PushDataStartEvent
SetOutputEvent
EndOfDataEvent
ErrorEvent
WarningEvent
UserEvent

Definition at line 86 of file vtkCommand.h.

Constructor & Destructor Documentation

vtkCommand::vtkCommand ( ) [inline, protected]

Definition at line 128 of file vtkCommand.h.

virtual vtkCommand::~vtkCommand ( ) [inline, protected, virtual]

Definition at line 129 of file vtkCommand.h.

Member Function Documentation

void vtkCommand::Delete ( ) [inline]

Definition at line 49 of file vtkCommand.h.

void vtkCommand::Register ( )

Increase the reference count (mark as used by another object).

void vtkCommand::Register ( vtkObject * ) [inline]

Increase the reference count (mark as used by another object).

Definition at line 55 of file vtkCommand.h.

void vtkCommand::UnRegister ( )

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

void vtkCommand::UnRegister ( vtkObject * ) [inline]

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

Definition at line 64 of file vtkCommand.h.

virtual void vtkCommand::Execute | ( | vtkObject * | ptr,
 |  | unsigned long | eventtype,
 |  | void * | callData
 | ) | [pure virtual]

Reimplemented in vtkCallbackCommand, vtkJavaCommand, vtkOldStyleCallbackCommand, vtkPythonCommand, and vtkTclCommand.

const char* vtkCommand::GetStringFromEventId ( unsigned long event ) [static]

unsigned long vtkCommand::GetEventIdFromString ( const char * event ) [static]

void vtkCommand::SetAbortFlagPointer ( int * f ) [inline]

Set/Get the abort flag. If this is set to true no further commands are executed.

Definition at line 75 of file vtkCommand.h.

void vtkCommand::SetAbortFlag ( int f ) [inline]

Set/Get the abort flag. If this is set to true no further commands are executed.

Definition at line 76 of file vtkCommand.h.

int vtkCommand::GetAbortFlag ( ) [inline]

Set/Get the abort flag. If this is set to true no further commands are executed.

Definition at line 77 of file vtkCommand.h.

Member Data Documentation

int* vtkCommand::AbortFlag [protected]

Definition at line 126 of file vtkCommand.h.

int vtkCommand::ReferenceCount [protected]

Definition at line 127 of file vtkCommand.h.

The documentation for this class was generated from the following file:
  • Common/vtkCommand.h
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCommunicator Class Reference

Used to send/receive messages in a multiprocess/thread environment. More...

#include <vtkCommunicator.h>

Inheritance diagram for vtkCommunicator:

[legend]
Collaboration diagram for vtkCommunicator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCommunicator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | Send (vtkDataObject *data, int remoteHandle, int tag)
virtual int | Send (vtkDataArray *data, int remoteHandle, int tag)
virtual int | Send (int *data, int length, int remoteHandle, int tag)=0
virtual int | Send (unsigned long *data, int length, int remoteHandle, int tag)=0
virtual int | Send (unsigned char *data, int length, int remoteHandle, int tag)=0
virtual int | Send (char *data, int length, int remoteHandle, int tag)=0
virtual int | Send (float *data, int length, int remoteHandle, int tag)=0
virtual int | Send (double *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (vtkDataObject *data, int remoteHandle, int tag)
virtual int | Receive (vtkDataArray *data, int remoteHandle, int tag)
virtual int | Receive (int *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (unsigned long *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (unsigned char *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (char *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (float *data, int length, int remoteHandle, int tag)=0
virtual int | Receive (double *data, int length, int remoteHandle, int tag)=0

Protected Methods

void | DeleteAndSetMarshalString (char *str, int strLength)
int | WriteObject (vtkDataObject *object)
int | ReadObject (vtkDataObject *object)
int | WriteDataSet (vtkDataSet *object)
int | ReadDataSet (vtkDataSet *object)
int | WriteImageData (vtkImageData *object)
int | ReadImageData (vtkImageData *object)
int | WriteDataArray (vtkDataArray *object)
int | ReadDataArray (vtkDataArray *object)
vtkCommunicator ()
~vtkCommunicator ()

Protected Attributes

char * | MarshalString
int | MarshalStringLength
int | MarshalDataLength

Detailed Description

Used to send/receive messages in a multiprocess/thread environment.

Date:
2002/01/22 15:34:27
Revision:
1.14

This is an abstact class which contains functionality for sending and receiving inter-process messages. It contains methods for marshaling an object into a string (currently used by the MPI communicator but not the shared memory communicator).

Warning:
Communication between systems with different vtkIdTypes is not supported. All machines have to have the same vtkIdType.
See also:
vtkSharedMemoryCommunicator vtkMPICommunicator
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (53%)
  • Geveci, Berk (35%)
  • Lee, Jeff (9%)
Tests:
vtkCommunicator (Tests)

Definition at line 56 of file vtkCommunicator.h.

Constructor & Destructor Documentation

vtkCommunicator::vtkCommunicator ( ) [protected]

vtkCommunicator::~vtkCommunicator ( ) [protected]

Member Function Documentation

vtkCommunicator::vtkTypeRevisionMacro | ( | vtkCommunicator | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

void vtkCommunicator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | vtkDataObject * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [virtual]

This method sends a data object to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

Referenced by vtkSocketCommunicator::Send(), vtkMultiProcessController::Send(), and vtkMPICommunicator::Send().

virtual int vtkCommunicator::Send | ( | vtkDataArray * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [virtual]

This method sends a data array to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Subclass have to supply these methods to send various arrays of data.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Send | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | vtkDataObject * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [virtual]

This method receives a data object from a corresponding send. It blocks until the receive is finished.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

Referenced by vtkSocketCommunicator::Receive(), vtkMultiProcessController::Receive(), and vtkMPICommunicator::Receive().

virtual int vtkCommunicator::Receive | ( | vtkDataArray * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [virtual]

This method receives a data array from a corresponding send. It blocks until the receive is finished.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Subclass have to supply these methods to receive various arrays of data.

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

virtual int vtkCommunicator::Receive | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [pure virtual]

Reimplemented in vtkMPICommunicator, vtkSharedMemoryCommunicator, and vtkSocketCommunicator.

void vtkCommunicator::DeleteAndSetMarshalString | ( | char * | str,
 |  | int | strLength
 | ) | [protected]

int vtkCommunicator::WriteObject ( vtkDataObject * object ) [protected]

int vtkCommunicator::ReadObject ( vtkDataObject * object ) [protected]

int vtkCommunicator::WriteDataSet ( vtkDataSet * object ) [protected]

int vtkCommunicator::ReadDataSet ( vtkDataSet * object ) [protected]

int vtkCommunicator::WriteImageData ( vtkImageData * object ) [protected]

int vtkCommunicator::ReadImageData ( vtkImageData * object ) [protected]

int vtkCommunicator::WriteDataArray ( vtkDataArray * object ) [protected]

int vtkCommunicator::ReadDataArray ( vtkDataArray * object ) [protected]

Member Data Documentation

char* vtkCommunicator::MarshalString [protected]

Definition at line 142 of file vtkCommunicator.h.

int vtkCommunicator::MarshalStringLength [protected]

Definition at line 143 of file vtkCommunicator.h.

int vtkCommunicator::MarshalDataLength [protected]

Definition at line 145 of file vtkCommunicator.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkCommunicator.h
Generated on Mon Mar 25 01:16:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCompositeManager Class Reference

An object to composite multiple render windows. More...

#include <vtkCompositeManager.h>

Inheritance diagram for vtkCompositeManager:

[legend]
Collaboration diagram for vtkCompositeManager:

[legend]
List of all members.

Public Types

enum Tags {
RENDER_RMI_TAG = 12721, COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG = 56563, WIN_INFO_TAG = 22134, REN_INFO_TAG = 22135,
BOUNDS_TAG = 94135
}

Public Methods

vtkTypeRevisionMacro (vtkCompositeManager, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | InitializePieces ()
void | InitializeOffScreen ()
void | InitializeRMIs ()
float | GetZ (int x, int y)
virtual void | ComputeVisiblePropBounds (vtkRenderer *ren, float bounds[6])
virtual vtkRenderWindow * | GetRenderWindow ()
void | SetRenderWindow (vtkRenderWindow *renWin)
void | StartInteractor ()
void | ExitInteractor ()
void | StartRender ()
void | EndRender ()
void | RenderRMI ()
void | ResetCamera (vtkRenderer *ren)
void | ResetCameraClippingRange (vtkRenderer *ren)
void | ComputeVisiblePropBoundsRMI ()
void | SetReductionFactor (int factor)
virtual int | GetReductionFactor ()
virtual void | SetUseChar (int)
virtual int | GetUseChar ()
virtual void | UseCharOn ()
virtual void | UseCharOff ()
virtual void | SetUseCompositing (int)
virtual int | GetUseCompositing ()
virtual void | UseCompositingOn ()
virtual void | UseCompositingOff ()
virtual double | GetGetBuffersTime ()
virtual double | GetSetBuffersTime ()
virtual double | GetCompositeTime ()
virtual double | GetMaxRenderTime ()
virtual void | SetController (vtkMultiProcessController *)
virtual vtkMultiProcessController * | GetController ()
virtual void | CheckForAbortRender ()
virtual int | CheckForAbortComposite ()
virtual void | SetManual (int)
virtual int | GetManual ()
virtual void | ManualOn ()
virtual void | ManualOff ()
void | Composite ()

Protected Methods

vtkCompositeManager ()
~vtkCompositeManager ()
vtkCompositeManager (const vtkCompositeManager &)
void | operator= (const vtkCompositeManager &)
virtual void | CompositeBuffer (int width, int height, int useCharFlag, void *pBuf, float *zBuf, void *pTmp, float *zTmp)=0
void | SetRendererSize (int x, int y)
float * | MagnifyBuffer (float *localPdata, int windowSize[2])
void | SetRenderWindowInteractor (vtkRenderWindowInteractor *iren)

Protected Attributes

vtkRenderWindow * RenderWindow
vtkRenderWindowInteractor * RenderWindowInteractor
vtkMultiProcessController * Controller
unsigned long | StartInteractorTag
unsigned long | EndInteractorTag
unsigned long | StartTag
unsigned long | EndTag
unsigned long | ResetCameraTag
unsigned long | ResetCameraClippingRangeTag
int | UseChar
int | UseCompositing
float * | PData
float * | ZData
int | RendererSize [2]
int | ReductionFactor
int | Lock
double | GetBuffersTime
double | SetBuffersTime
double | CompositeTime
double | MaxRenderTime
vtkTimerLog * Timer
int | Manual

Detailed Description

An object to composite multiple render windows.

Date:
2002/03/18 20:47:26
Revision:
1.6

vtkCompositeManager operates in multiple processes. Each compositer has a render window. They use vtkMultiProcessControllers to comunicate the color and depth buffer to process 0's render window. Subclass implementation may not handle transparency well.

Attention:
You should set up the renders and render window interactor before setting the compositers render window. We set up observers on the renderer, An have no easy way of knowing when the renderers change. We could create AddRenderer and RemoveRenderer events ...
See also:
vtkMultiProcessController vtkRenderWindow vtkTreeComposite.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Hoffman, Bill (85%)
  • Law, Charles (6%)
  • Geveci, Berk (5%)

Definition at line 55 of file vtkCompositeManager.h.

Member Enumeration Documentation

enum vtkCompositeManager::Tags

Enumeration values:
RENDER_RMI_TAG
COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG
WIN_INFO_TAG
REN_INFO_TAG
BOUNDS_TAG

Definition at line 140 of file vtkCompositeManager.h.

Constructor & Destructor Documentation

vtkCompositeManager::vtkCompositeManager ( ) [protected]

vtkCompositeManager::~vtkCompositeManager ( ) [protected]

vtkCompositeManager::vtkCompositeManager ( const vtkCompositeManager & ) [protected]

Member Function Documentation

vtkCompositeManager::vtkTypeRevisionMacro | ( | vtkCompositeManager | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkTreeComposite.

void vtkCompositeManager::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkTreeComposite.

virtual vtkRenderWindow* vtkCompositeManager::GetRenderWindow ( ) [virtual]

Set/Get the RenderWindow to use for compositing. We add a start and end observer to the window.

void vtkCompositeManager::SetRenderWindow ( vtkRenderWindow * renWin )

Set/Get the RenderWindow to use for compositing. We add a start and end observer to the window.

void vtkCompositeManager::InitializePieces ( )

This method sets the piece and number of pieces for each actor with a polydata mapper. My other option is to do it every render, but that would force a partioning scheme.

void vtkCompositeManager::InitializeOffScreen ( )

turn off screen rendering on for the

void vtkCompositeManager::StartInteractor ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::ExitInteractor ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::StartRender ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::EndRender ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::RenderRMI ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::ResetCamera ( vtkRenderer * ren )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::ResetCameraClippingRange ( vtkRenderer * ren )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::ComputeVisiblePropBoundsRMI ( )

Callbacks that initialize and finish the compositing.

void vtkCompositeManager::InitializeRMIs ( )

If the user wants to handle the event loop, then they must call this method to initialize the RMIs.

void vtkCompositeManager::SetReductionFactor ( int factor )

The reduction facor makes the transfered images smaller to decrease the render time. The final image is pixel replicated to be the original size. This option can be used by an interactor style to help get desired frame rates. The factor only needs to be set on process 0. Call SetRenderWindow before calling SetReductionFactor.

virtual int vtkCompositeManager::GetReductionFactor ( ) [virtual]

The reduction facor makes the transfered images smaller to decrease the render time. The final image is pixel replicated to be the original size. This option can be used by an interactor style to help get desired frame rates. The factor only needs to be set on process 0. Call SetRenderWindow before calling SetReductionFactor.

virtual void vtkCompositeManager::SetUseChar ( int ) [virtual]

This flag tells the compositer to use char values for pixel data rather than float. Default is float. I have seen some artifacts on some systems with char.

virtual int vtkCompositeManager::GetUseChar ( ) [virtual]

This flag tells the compositer to use char values for pixel data rather than float. Default is float. I have seen some artifacts on some systems with char.

virtual void vtkCompositeManager::UseCharOn ( ) [virtual]

This flag tells the compositer to use char values for pixel data rather than float. Default is float. I have seen some artifacts on some systems with char.

virtual void vtkCompositeManager::UseCharOff ( ) [virtual]

This flag tells the compositer to use char values for pixel data rather than float. Default is float. I have seen some artifacts on some systems with char.

virtual void vtkCompositeManager::SetUseCompositing ( int ) [virtual]

This flag turns the compositer on or off.

virtual int vtkCompositeManager::GetUseCompositing ( ) [virtual]

This flag turns the compositer on or off.

virtual void vtkCompositeManager::UseCompositingOn ( ) [virtual]

This flag turns the compositer on or off.

virtual void vtkCompositeManager::UseCompositingOff ( ) [virtual]

This flag turns the compositer on or off.

virtual double vtkCompositeManager::GetGetBuffersTime ( ) [virtual]

Get the times to set/get the buffers, Composite, and the time it takes all processes to finish the rendering step.

virtual double vtkCompositeManager::GetSetBuffersTime ( ) [virtual]

Get the times to set/get the buffers, Composite, and the time it takes all processes to finish the rendering step.

virtual double vtkCompositeManager::GetCompositeTime ( ) [virtual]

Get the times to set/get the buffers, Composite, and the time it takes all processes to finish the rendering step.

virtual double vtkCompositeManager::GetMaxRenderTime ( ) [virtual]

Get the times to set/get the buffers, Composite, and the time it takes all processes to finish the rendering step.

float vtkCompositeManager::GetZ | ( | int | x,
 |  | int | y
 | ) |

Get the value of the z buffer at a position.

virtual void vtkCompositeManager::SetController ( vtkMultiProcessController * ) [virtual]

Set/Get the controller use in compositing (set to the global controller by default) If not using the default, this must be called before any other methods.

virtual vtkMultiProcessController* vtkCompositeManager::GetController ( ) [virtual]

Set/Get the controller use in compositing (set to the global controller by default) If not using the default, this must be called before any other methods.

virtual void vtkCompositeManager::CheckForAbortRender ( ) [inline, virtual]

Used by call backs. Not intended to be called by the user. Empty methods that can be used by the subclass to interupt a parallel render.

Definition at line 152 of file vtkCompositeManager.h.

virtual int vtkCompositeManager::CheckForAbortComposite ( ) [inline, virtual]

Used by call backs. Not intended to be called by the user. Empty methods that can be used by the subclass to interupt a parallel render.

Definition at line 153 of file vtkCompositeManager.h.

virtual void vtkCompositeManager::ComputeVisiblePropBounds | ( | vtkRenderer * | ren,
 |  | float | bounds[6]
 | ) | [virtual]

Calculate the bounds by gather information from all processes

virtual void vtkCompositeManager::SetManual ( int ) [virtual]

This is for manually compositing. By default Manual is off. When manual compositing is on, then the user must call Render and Composite on each process. The start and end render are not setup in manual mode.

virtual int vtkCompositeManager::GetManual ( ) [virtual]

This is for manually compositing. By default Manual is off. When manual compositing is on, then the user must call Render and Composite on each process. The start and end render are not setup in manual mode.

virtual void vtkCompositeManager::ManualOn ( ) [virtual]

This is for manually compositing. By default Manual is off. When manual compositing is on, then the user must call Render and Composite on each process. The start and end render are not setup in manual mode.

virtual void vtkCompositeManager::ManualOff ( ) [virtual]

This is for manually compositing. By default Manual is off. When manual compositing is on, then the user must call Render and Composite on each process. The start and end render are not setup in manual mode.

void vtkCompositeManager::Composite ( )

This is for manually compositing. By default Manual is off. When manual compositing is on, then the user must call Render and Composite on each process. The start and end render are not setup in manual mode.

void vtkCompositeManager::operator= ( const vtkCompositeManager & ) [protected]

virtual void vtkCompositeManager::CompositeBuffer | ( | int | width,
 |  | int | height,
 |  | int | useCharFlag,
 |  | void * | pBuf,
 |  | float * | zBuf,
 |  | void * | pTmp,
 |  | float * | zTmp
 | ) | [protected, pure virtual]

Reimplemented in vtkTreeComposite.

void vtkCompositeManager::SetRendererSize | ( | int | x,
 |  | int | y
 | ) | [protected]

float* vtkCompositeManager::MagnifyBuffer | ( | float * | localPdata,
 |  | int | windowSize[2]
 | ) | [protected]

void vtkCompositeManager::SetRenderWindowInteractor ( vtkRenderWindowInteractor * iren ) [protected]

Member Data Documentation

vtkRenderWindow* vtkCompositeManager::RenderWindow [protected]

Definition at line 186 of file vtkCompositeManager.h.

vtkRenderWindowInteractor* vtkCompositeManager::RenderWindowInteractor [protected]

Definition at line 187 of file vtkCompositeManager.h.

vtkMultiProcessController* vtkCompositeManager::Controller [protected]

Definition at line 188 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::StartInteractorTag [protected]

Definition at line 190 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::EndInteractorTag [protected]

Definition at line 191 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::StartTag [protected]

Definition at line 192 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::EndTag [protected]

Definition at line 193 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::ResetCameraTag [protected]

Definition at line 194 of file vtkCompositeManager.h.

unsigned long vtkCompositeManager::ResetCameraClippingRangeTag [protected]

Definition at line 195 of file vtkCompositeManager.h.

int vtkCompositeManager::UseChar [protected]

Definition at line 196 of file vtkCompositeManager.h.

int vtkCompositeManager::UseCompositing [protected]

Definition at line 197 of file vtkCompositeManager.h.

float* vtkCompositeManager::PData [protected]

Definition at line 205 of file vtkCompositeManager.h.

float* vtkCompositeManager::ZData [protected]

Definition at line 206 of file vtkCompositeManager.h.

int vtkCompositeManager::RendererSize[2] [protected]

Definition at line 207 of file vtkCompositeManager.h.

int vtkCompositeManager::ReductionFactor [protected]

Definition at line 210 of file vtkCompositeManager.h.

int vtkCompositeManager::Lock [protected]

Definition at line 217 of file vtkCompositeManager.h.

double vtkCompositeManager::GetBuffersTime [protected]

Definition at line 219 of file vtkCompositeManager.h.

double vtkCompositeManager::SetBuffersTime [protected]

Definition at line 220 of file vtkCompositeManager.h.

double vtkCompositeManager::CompositeTime [protected]

Definition at line 221 of file vtkCompositeManager.h.

double vtkCompositeManager::MaxRenderTime [protected]

Definition at line 222 of file vtkCompositeManager.h.

vtkTimerLog* vtkCompositeManager::Timer [protected]

Definition at line 225 of file vtkCompositeManager.h.

int vtkCompositeManager::Manual [protected]

Definition at line 228 of file vtkCompositeManager.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkCompositeManager.h
Generated on Mon Mar 25 01:16:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCone Class Reference

implicit function for a cone. More...

#include <vtkCone.h>

Inheritance diagram for vtkCone:

[legend]
Collaboration diagram for vtkCone:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCone, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetAngle (float)
virtual float | GetAngle ()

Static Public Methods

vtkCone * | New ()

Protected Methods

vtkCone ()
~vtkCone ()

Protected Attributes

float | Angle

Detailed Description

implicit function for a cone.

Date:
2002/01/22 15:28:02
Revision:
1.37

vtkCone computes the implicit function and function gradient for a cone. vtkCone is a concrete implementation of vtkImplicitFunction. The cone vertex is located at the origin with axis of rotation coincident with x-axis. (Use the superclass' vtkImplicitFunction transformation matrix if necessary to reposition.) The angle specifies the angle between the axis of rotation and the side of the cone.

Warning:
The cone is infinite in extent. To truncate the cone use the vtkImplicitBoolean in combination with clipping planes.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Martin, Ken (15%)
  • Kelly, Ann (7%)
Examples:
vtkCone (Examples)
Tests:
vtkCone (Tests)

Definition at line 53 of file vtkCone.h.

Constructor & Destructor Documentation

vtkCone::vtkCone ( ) [protected]

vtkCone::~vtkCone ( ) [inline, protected]

Definition at line 80 of file vtkCone.h.

Member Function Documentation

vtkCone* vtkCone::New ( ) [static]

Construct cone with angle of 45 degrees.

Reimplemented from vtkObject.

vtkCone::vtkTypeRevisionMacro | ( | vtkCone | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkCone::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

float vtkCone::EvaluateFunction ( float x[3] ) [virtual]

Evaluate cone equation.

Reimplemented from vtkImplicitFunction.

float vtkCone::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate cone equation.

Reimplemented from vtkImplicitFunction.

Definition at line 65 of file vtkCone.h.

void vtkCone::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate cone normal.

Reimplemented from vtkImplicitFunction.

virtual void vtkCone::SetAngle ( float ) [virtual]

Set/Get the cone angle (expressed in degrees).

virtual float vtkCone::GetAngle ( ) [virtual]

Set/Get the cone angle (expressed in degrees).

Member Data Documentation

float vtkCone::Angle [protected]

Definition at line 82 of file vtkCone.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkCone.h
Generated on Mon Mar 25 01:16:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkConeSource Class Reference

generate polygonal cone. More...

#include <vtkConeSource.h>

Inheritance diagram for vtkConeSource:

[legend]
Collaboration diagram for vtkConeSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkConeSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetHeight (float)
virtual float | GetHeight ()
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetResolution (int)
virtual int | GetResolution ()
void | SetAngle (float angle)
float | GetAngle ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()

Static Public Methods

vtkConeSource * | New ()

Protected Methods

vtkConeSource (int res=6)
~vtkConeSource ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

float | Height
float | Radius
int | Resolution
int | Capping

Detailed Description

generate polygonal cone.

Date:
2002/01/22 15:29:12
Revision:
1.51

vtkConeSource creates a cone centered at origin and pointing down the x-axis. Depending upon the resolution of this object, different representations are created. If resolution=0 a line is created; if resolution=1, a single triangle is created; if resolution=2, two crossed triangles are created. For resolution > 2, a 3D cone (with resolution number of sides) is created. It also is possible to control whether the bottom of the cone is capped with a (resolution-sided) polygon, and to specify the height and radius of the cone.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (60%)
  • Law, Charles (18%)
  • Lorensen, Bill (10%)
Examples:
vtkConeSource (Examples)
Tests:
vtkConeSource (Tests)

Definition at line 51 of file vtkConeSource.h.

Constructor & Destructor Documentation

vtkConeSource::vtkConeSource ( int res = 6 ) [protected]

vtkConeSource::~vtkConeSource ( ) [inline, protected]

Definition at line 94 of file vtkConeSource.h.

Member Function Documentation

vtkConeSource::vtkTypeRevisionMacro | ( | vtkConeSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkConeSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkConeSource* vtkConeSource::New ( ) [static]

Construct with default resolution 6, height 1.0, radius 0.5, and capping on.

Reimplemented from vtkPolyDataSource.

virtual void vtkConeSource::SetHeight ( float ) [virtual]

Set the height of the cone.

virtual float vtkConeSource::GetHeight ( ) [virtual]

Set the height of the cone.

virtual void vtkConeSource::SetRadius ( float ) [virtual]

Set the radius of the cone.

virtual float vtkConeSource::GetRadius ( ) [virtual]

Set the radius of the cone.

virtual void vtkConeSource::SetResolution ( int ) [virtual]

Set the number of facets used to represent the cone.

virtual int vtkConeSource::GetResolution ( ) [virtual]

Set the number of facets used to represent the cone.

void vtkConeSource::SetAngle ( float angle )

Set the angle of the cone. As a side effect, this method sets radius.

float vtkConeSource::GetAngle ( )

Set the angle of the cone. As a side effect, this method sets radius.

virtual void vtkConeSource::SetCapping ( int ) [virtual]

Turn on/off whether to cap the cone with a polygon.

virtual int vtkConeSource::GetCapping ( ) [virtual]

Turn on/off whether to cap the cone with a polygon.

virtual void vtkConeSource::CappingOn ( ) [virtual]

Turn on/off whether to cap the cone with a polygon.

virtual void vtkConeSource::CappingOff ( ) [virtual]

Turn on/off whether to cap the cone with a polygon.

void vtkConeSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkConeSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

float vtkConeSource::Height [protected]

Definition at line 98 of file vtkConeSource.h.

float vtkConeSource::Radius [protected]

Definition at line 99 of file vtkConeSource.h.

int vtkConeSource::Resolution [protected]

Definition at line 100 of file vtkConeSource.h.

int vtkConeSource::Capping [protected]

Definition at line 101 of file vtkConeSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkConeSource.h
Generated on Mon Mar 25 01:16:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkConnectivityFilter Class Reference

extract data based on geometric connectivity. More...

#include <vtkConnectivityFilter.h>

Inheritance diagram for vtkConnectivityFilter:

[legend]
Collaboration diagram for vtkConnectivityFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkConnectivityFilter, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | InitializeSeedList ()
void | AddSeed (vtkIdType id)
void | DeleteSeed (vtkIdType id)
void | InitializeSpecifiedRegionList ()
void | AddSpecifiedRegion (int id)
void | DeleteSpecifiedRegion (int id)
int | GetNumberOfExtractedRegions ()
virtual void | SetScalarConnectivity (int)
virtual int | GetScalarConnectivity ()
virtual void | ScalarConnectivityOn ()
virtual void | ScalarConnectivityOff ()
virtual void | SetScalarRange (float, float)
void | SetScalarRange (float[2])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float &, float &)
virtual void | GetScalarRange (float[2])
virtual void | SetExtractionMode (int)
virtual int | GetExtractionMode ()
void | SetExtractionModeToPointSeededRegions ()
void | SetExtractionModeToCellSeededRegions ()
void | SetExtractionModeToLargestRegion ()
void | SetExtractionModeToSpecifiedRegions ()
void | SetExtractionModeToClosestPointRegion ()
void | SetExtractionModeToAllRegions ()
const char * | GetExtractionModeAsString ()
virtual void | SetClosestPoint (float, float, float)
virtual void | SetClosestPoint (float[3])
virtual float * | GetClosestPoint ()
virtual void | GetClosestPoint (float data[3])
virtual void | SetColorRegions (int)
virtual int | GetColorRegions ()
virtual void | ColorRegionsOn ()
virtual void | ColorRegionsOff ()

Static Public Methods

vtkConnectivityFilter * | New ()

Protected Methods

vtkConnectivityFilter ()
~vtkConnectivityFilter ()
void | Execute ()
void | TraverseAndMark ()

Protected Attributes

int | ColorRegions
int | ExtractionMode
vtkIdList * Seeds
vtkIdList * SpecifiedRegionIds
vtkIntArray * RegionSizes
float | ClosestPoint [3]
int | ScalarConnectivity
float | ScalarRange [2]

Detailed Description

extract data based on geometric connectivity.

Date:
2002/01/22 15:29:12
Revision:
1.52

vtkConnectivityFilter is a filter that extracts cells that share common points and/or meet other connectivity criterion. (Cells that share vertices and meet other connectivity criterion such as scalar range are known as a region.) The filter works in one of six ways: 1) extract the largest connected region in the dataset; 2) extract specified region numbers; 3) extract all regions sharing specified point ids; 4) extract all regions sharing specified cell ids; 5) extract the region closest to the specified point; or 6) extract all regions (used to color the data by region).

vtkConnectivityFilter is generalized to handle any type of input dataset. It generates output data of type vtkUnstructuredGrid. If you know that your input type is vtkPolyData, you may wish to use vtkPolyDataConnectivityFilter.

The behavior of vtkConnectivityFilter can be modified by turning on the boolean ivar ScalarConnectivity. If this flag is on, the connectivity algorithm is modified so that cells are considered connected only if 1) they are geometrically connected (share a point) and 2) the scalar values of one of the cell's points falls in the scalar range specified. This use of ScalarConnectivity is particularly useful for volume datasets: it can be used as a simple "connected segmentation" algorithm. For example, by using a seed voxel (i.e., cell) on a known anatomical structure, connectivity will pull out all voxels "containing" the anatomical structure. These voxels can then be contoured or processed by other visualization filters.

See also:
vtkPolyDataConnectivityFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Martin, Ken (20%)
Examples:
vtkConnectivityFilter (Examples)
Tests:
vtkConnectivityFilter (Tests)

Definition at line 80 of file vtkConnectivityFilter.h.

Constructor & Destructor Documentation

vtkConnectivityFilter::vtkConnectivityFilter ( ) [protected]

vtkConnectivityFilter::~vtkConnectivityFilter ( ) [protected]

Member Function Documentation

vtkConnectivityFilter::vtkTypeRevisionMacro | ( | vtkConnectivityFilter | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkConnectivityFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkConnectivityFilter* vtkConnectivityFilter::New ( ) [static]

Construct with default extraction mode to extract largest regions.

Reimplemented from vtkUnstructuredGridSource.

virtual void vtkConnectivityFilter::SetScalarConnectivity ( int ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual int vtkConnectivityFilter::GetScalarConnectivity ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkConnectivityFilter::ScalarConnectivityOn ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkConnectivityFilter::ScalarConnectivityOff ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkConnectivityFilter::SetScalarRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

void vtkConnectivityFilter::SetScalarRange ( float [2] )

Set the scalar range to use to extract cells based on scalar connectivity.

virtual float* vtkConnectivityFilter::GetScalarRange ( ) [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual void vtkConnectivityFilter::GetScalarRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual void vtkConnectivityFilter::GetScalarRange ( float [2] ) [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual void vtkConnectivityFilter::SetExtractionMode ( int ) [virtual]

Control the extraction of connected surfaces.

virtual int vtkConnectivityFilter::GetExtractionMode ( ) [virtual]

Control the extraction of connected surfaces.

void vtkConnectivityFilter::SetExtractionModeToPointSeededRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 110 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::SetExtractionModeToCellSeededRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 112 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::SetExtractionModeToLargestRegion ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 114 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::SetExtractionModeToSpecifiedRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 116 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::SetExtractionModeToClosestPointRegion ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 118 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::SetExtractionModeToAllRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 120 of file vtkConnectivityFilter.h.

const char * vtkConnectivityFilter::GetExtractionModeAsString ( void ) [inline]

Return the method of extraction as a string.

Definition at line 201 of file vtkConnectivityFilter.h.

void vtkConnectivityFilter::InitializeSeedList ( )

Initialize list of point ids/cell ids used to seed regions.

void vtkConnectivityFilter::AddSeed ( vtkIdType id )

Add a seed id (point or cell id). Note: ids are 0-offset.

void vtkConnectivityFilter::DeleteSeed ( vtkIdType id )

Delete a seed id (point or cell id). Note: ids are 0-offset.

void vtkConnectivityFilter::InitializeSpecifiedRegionList ( )

Initialize list of region ids to extract.

void vtkConnectivityFilter::AddSpecifiedRegion ( int id )

Add a region id to extract. Note: ids are 0-offset.

void vtkConnectivityFilter::DeleteSpecifiedRegion ( int id )

Delete a region id to extract. Note: ids are 0-offset.

virtual void vtkConnectivityFilter::SetClosestPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual void vtkConnectivityFilter::SetClosestPoint ( float [3] ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual float* vtkConnectivityFilter::GetClosestPoint ( ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual void vtkConnectivityFilter::GetClosestPoint ( float data[3] ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

int vtkConnectivityFilter::GetNumberOfExtractedRegions ( )

Obtain the number of connected regions.

virtual void vtkConnectivityFilter::SetColorRegions ( int ) [virtual]

Turn on/off the coloring of connected regions.

virtual int vtkConnectivityFilter::GetColorRegions ( ) [virtual]

Turn on/off the coloring of connected regions.

virtual void vtkConnectivityFilter::ColorRegionsOn ( ) [virtual]

Turn on/off the coloring of connected regions.

virtual void vtkConnectivityFilter::ColorRegionsOff ( ) [virtual]

Turn on/off the coloring of connected regions.

void vtkConnectivityFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkConnectivityFilter::TraverseAndMark ( ) [protected]

Member Data Documentation

int vtkConnectivityFilter::ColorRegions [protected]

Definition at line 167 of file vtkConnectivityFilter.h.

int vtkConnectivityFilter::ExtractionMode [protected]

Definition at line 168 of file vtkConnectivityFilter.h.

vtkIdList* vtkConnectivityFilter::Seeds [protected]

Definition at line 169 of file vtkConnectivityFilter.h.

vtkIdList* vtkConnectivityFilter::SpecifiedRegionIds [protected]

Definition at line 170 of file vtkConnectivityFilter.h.

vtkIntArray* vtkConnectivityFilter::RegionSizes [protected]

Definition at line 171 of file vtkConnectivityFilter.h.

float vtkConnectivityFilter::ClosestPoint[3] [protected]

Definition at line 173 of file vtkConnectivityFilter.h.

int vtkConnectivityFilter::ScalarConnectivity [protected]

Definition at line 175 of file vtkConnectivityFilter.h.

float vtkConnectivityFilter::ScalarRange[2] [protected]

Definition at line 176 of file vtkConnectivityFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkConnectivityFilter.h
Generated on Mon Mar 25 01:16:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContainer Class Reference

a base class for templated containers. More...

#include <vtkContainer.h>

Inheritance diagram for vtkContainer:

[legend]
Collaboration diagram for vtkContainer:

[legend]
List of all members.

Public Methods

virtual unsigned long | GetNumberOfItems ()=0
virtual void | RemoveAllItems ()=0
void | Delete ()
void | Register ()
void | Register (vtkObject *)
void | UnRegister ()
void | UnRegister (vtkObject *)

Protected Methods

vtkContainer ()
virtual | ~vtkContainer ()

Protected Attributes

unsigned long | ReferenceCount

Detailed Description

a base class for templated containers.

Date:
2002/03/22 22:50:59
Revision:
1.2

vtkContainer is a superclass for all container classes. Since it does not provide any actuall data access methods, it is not templated, but it provides a set of method that can be used on all containers. It also provide a simple reference counting scheme.

Caveates:
Since vtkContainer and vtkAbstractList provide some pure virtual methods, each object of type container will have v-tabe.
Caveates:
The reference counting scheme used in vtkContainer is not used with debug leaks yet.
Created by:
  • Cedilnik, Andy
Contributed by (if > 5%):
  • Cedilnik, Andy (100%)
Tests:
vtkContainer (Tests)

Definition at line 50 of file vtkContainer.h.

Constructor & Destructor Documentation

vtkContainer::vtkContainer ( ) [inline, protected]

Definition at line 81 of file vtkContainer.h.

virtual vtkContainer::~vtkContainer ( ) [inline, protected, virtual]

Definition at line 82 of file vtkContainer.h.

Member Function Documentation

virtual unsigned long vtkContainer::GetNumberOfItems ( ) [pure virtual]

Return the number of items currently held in this container. This different from GetSize which is provided for some containers. GetSize will return how many items the container can currently hold.

virtual void vtkContainer::RemoveAllItems ( ) [pure virtual]

Removes all items from the container.

void vtkContainer::Delete ( ) [inline]

The counterpart to New(), Delete simply calls UnRegister to lower the reference count by one. It is no different than calling UnRegister.

Definition at line 63 of file vtkContainer.h.

void vtkContainer::Register ( )

Increase the reference count of this container.

void vtkContainer::Register ( vtkObject * ) [inline]

Increase the reference count of this container.

Definition at line 68 of file vtkContainer.h.

void vtkContainer::UnRegister ( )

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

void vtkContainer::UnRegister ( vtkObject * ) [inline]

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

Definition at line 76 of file vtkContainer.h.

Member Data Documentation

unsigned long vtkContainer::ReferenceCount [protected]

Definition at line 80 of file vtkContainer.h.

The documentation for this class was generated from the following file:
  • Common/vtkContainer.h
Generated on Mon Mar 25 01:16:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourFilter Class Reference

generate isosurfaces/isolines from scalar values. More...

#include <vtkContourFilter.h>

Inheritance diagram for vtkContourFilter:

[legend]
Collaboration diagram for vtkContourFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkContourFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | CreateDefaultLocator ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
virtual void | SetUseScalarTree (int)
virtual int | GetUseScalarTree ()
virtual void | UseScalarTreeOn ()
virtual void | UseScalarTreeOff ()
virtual void | SetScalarTree (vtkScalarTree *)
virtual vtkScalarTree * | GetScalarTree ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkContourFilter * | New ()

Protected Methods

vtkContourFilter ()
~vtkContourFilter ()
void | Execute ()
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

vtkContourValues * ContourValues
int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkPointLocator * Locator
int | UseScalarTree
vtkScalarTree * ScalarTree
char * | InputScalarsSelection

Detailed Description

generate isosurfaces/isolines from scalar values.

Date:
2002/01/22 15:29:12
Revision:
1.65

vtkContourFilter is a filter that takes as input any dataset and generates on output isosurfaces and/or isolines. The exact form of the output depends upon the dimensionality of the input data. Data consisting of 3D cells will generate isosurfaces, data consisting of 2D cells will generate isolines, and data with 1D or 0D cells will generate isopoints. Combinations of output type are possible if the input dimension is mixed.

To use this filter you must specify one or more contour values. You can either use the method SetValue() to specify each contour value, or use GenerateValues() to generate a series of evenly spaced contours. It is also possible to accelerate the operation of this filter (at the cost of extra memory) by using a vtkScalarTree. A scalar tree is used to quickly locate cells that contain a contour surface. This is especially effective if multiple contours are being extracted. If you want to use a scalar tree, invoke the method UseScalarTreeOn().

If the input data is structured, consider using a filter that is optimized for structured data. These can be found in the patented classes of vtk.

Warning:
For unstructured data or structured grids, normals and gradients are not computed. Use vtkPolyDataNormals to compute the surface normals.
See also:
vtkMarchingContourFilter vtkKitwareContourFilter vtkMarchingCubes vtkSliceCubes vtkDividingCubes vtkMarchingSquares vtkImageMarchingCubes
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (45%)
  • Law, Charles (15%)
  • Martin, Ken (13%)
  • Henderson, Amy (12%)
  • Lorensen, Bill (8%)
Examples:
vtkContourFilter (Examples)
Tests:
vtkContourFilter (Tests)

Definition at line 78 of file vtkContourFilter.h.

Constructor & Destructor Documentation

vtkContourFilter::vtkContourFilter ( ) [protected]

vtkContourFilter::~vtkContourFilter ( ) [protected]

Member Function Documentation

vtkContourFilter::vtkTypeRevisionMacro | ( | vtkContourFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

Reimplemented in vtkKitwareContourFilter.

void vtkContourFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkContourFilter* vtkContourFilter::New ( ) [static]

Construct object with initial range (0,1) and single contour value of 0.0.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkKitwareContourFilter.

void vtkContourFilter::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Methods to set / get contour values.

Definition at line 189 of file vtkContourFilter.h.

float vtkContourFilter::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 194 of file vtkContourFilter.h.

float * vtkContourFilter::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 201 of file vtkContourFilter.h.

void vtkContourFilter::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 208 of file vtkContourFilter.h.

void vtkContourFilter::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 214 of file vtkContourFilter.h.

int vtkContourFilter::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 219 of file vtkContourFilter.h.

void vtkContourFilter::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 226 of file vtkContourFilter.h.

void vtkContourFilter::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 233 of file vtkContourFilter.h.

unsigned long vtkContourFilter::GetMTime ( ) [virtual]

Modified GetMTime Because we delegate to vtkContourValues

Reimplemented from vtkObject.

virtual void vtkContourFilter::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkContourFilter::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkContourFilter::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourFilter::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkContourFilter::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourFilter::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourFilter::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourFilter::SetUseScalarTree ( int ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual int vtkContourFilter::GetUseScalarTree ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkContourFilter::UseScalarTreeOn ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkContourFilter::UseScalarTreeOff ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkContourFilter::SetScalarTree ( vtkScalarTree * ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual vtkScalarTree* vtkContourFilter::GetScalarTree ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

void vtkContourFilter::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkContourFilter::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkContourFilter::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

virtual char* vtkContourFilter::GetInputScalarsSelection ( ) [virtual]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkContourFilter::SelectInputScalars ( const char * fieldName ) [inline]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 161 of file vtkContourFilter.h.

void vtkContourFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkKitwareContourFilter.

virtual void vtkContourFilter::SetInputScalarsSelection ( const char * ) [protected, virtual]

Member Data Documentation

vtkContourValues* vtkContourFilter::ContourValues [protected]

Definition at line 171 of file vtkContourFilter.h.

int vtkContourFilter::ComputeNormals [protected]

Definition at line 172 of file vtkContourFilter.h.

int vtkContourFilter::ComputeGradients [protected]

Definition at line 173 of file vtkContourFilter.h.

int vtkContourFilter::ComputeScalars [protected]

Definition at line 174 of file vtkContourFilter.h.

vtkPointLocator* vtkContourFilter::Locator [protected]

Definition at line 175 of file vtkContourFilter.h.

int vtkContourFilter::UseScalarTree [protected]

Definition at line 176 of file vtkContourFilter.h.

vtkScalarTree* vtkContourFilter::ScalarTree [protected]

Definition at line 177 of file vtkContourFilter.h.

char* vtkContourFilter::InputScalarsSelection [protected]

Definition at line 179 of file vtkContourFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkContourFilter.h
Generated on Mon Mar 25 01:16:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourGrid Class Reference

generate isosurfaces/isolines from scalar values (specialized for unstructured grids). More...

#include <vtkContourGrid.h>

Inheritance diagram for vtkContourGrid:

[legend]
Collaboration diagram for vtkContourGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkContourGrid, vtkUnstructuredGridToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | CreateDefaultLocator ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
virtual void | SetUseScalarTree (int)
virtual int | GetUseScalarTree ()
virtual void | UseScalarTreeOn ()
virtual void | UseScalarTreeOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkContourGrid * | New ()

Protected Methods

vtkContourGrid ()
~vtkContourGrid ()
void | Execute ()
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

vtkContourValues * ContourValues
int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkPointLocator * Locator
int | UseScalarTree
vtkScalarTree * ScalarTree
vtkEdgeTable * EdgeTable
char * | InputScalarsSelection

Detailed Description

generate isosurfaces/isolines from scalar values (specialized for unstructured grids).

Date:
2002/01/22 15:29:12
Revision:
1.13

vtkContourGrid is a filter that takes as input datasets of type vtkUnstructuredGrid and generates on output isosurfaces and/or isolines. The exact form of the output depends upon the dimensionality of the input data. Data consisting of 3D cells will generate isosurfaces, data consisting of 2D cells will generate isolines, and data with 1D or 0D cells will generate isopoints. Combinations of output type are possible if the input dimension is mixed.

To use this filter you must specify one or more contour values. You can either use the method SetValue() to specify each contour value, or use GenerateValues() to generate a series of evenly spaced contours. It is also possible to accelerate the operation of this filter (at the cost of extra memory) by using a vtkScalarTree. A scalar tree is used to quickly locate cells that contain a contour surface. This is especially effective if multiple contours are being extracted. If you want to use a scalar tree, invoke the method UseScalarTreeOn().

If the input data is structured, consider using a filter that is optimized for structured data. These can be found in the patented classes of vtk.

Warning:
For unstructured data or structured grids, normals and gradients are not computed. Use vtkPolyDataNormals to compute the surface normals of the resulting isosurface.
See also:
vtkMarchingContourFilter vtkKitwareContourFilter vtkMarchingCubes vtkSliceCubes vtkDividingCubes vtkMarchingSquares vtkImageMarchingCubes
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (67%)
  • Martin, Ken (15%)
  • Schroeder, Will (10%)

Definition at line 72 of file vtkContourGrid.h.

Constructor & Destructor Documentation

vtkContourGrid::vtkContourGrid ( ) [protected]

vtkContourGrid::~vtkContourGrid ( ) [protected]

Member Function Documentation

vtkContourGrid::vtkTypeRevisionMacro | ( | vtkContourGrid | ,
 |  | vtkUnstructuredGridToPolyDataFilter |
 | ) |

Reimplemented from vtkUnstructuredGridToPolyDataFilter.

void vtkContourGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkContourGrid* vtkContourGrid::New ( ) [static]

Construct object with initial range (0,1) and single contour value of 0.0.

Reimplemented from vtkPolyDataSource.

void vtkContourGrid::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Methods to set / get contour values.

Definition at line 178 of file vtkContourGrid.h.

float vtkContourGrid::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 183 of file vtkContourGrid.h.

float * vtkContourGrid::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 190 of file vtkContourGrid.h.

void vtkContourGrid::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 197 of file vtkContourGrid.h.

void vtkContourGrid::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 203 of file vtkContourGrid.h.

int vtkContourGrid::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 208 of file vtkContourGrid.h.

void vtkContourGrid::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 215 of file vtkContourGrid.h.

void vtkContourGrid::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 222 of file vtkContourGrid.h.

unsigned long vtkContourGrid::GetMTime ( ) [virtual]

Modified GetMTime Because we delegate to vtkContourValues

Reimplemented from vtkObject.

virtual void vtkContourGrid::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkContourGrid::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkContourGrid::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkContourGrid::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkContourGrid::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourGrid::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourGrid::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkContourGrid::SetUseScalarTree ( int ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual int vtkContourGrid::GetUseScalarTree ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkContourGrid::UseScalarTreeOn ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkContourGrid::UseScalarTreeOff ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

void vtkContourGrid::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkContourGrid::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkContourGrid::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

virtual char* vtkContourGrid::GetInputScalarsSelection ( ) [virtual]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkContourGrid::SelectInputScalars ( const char * fieldName ) [inline]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 149 of file vtkContourGrid.h.

void vtkContourGrid::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkContourGrid::SetInputScalarsSelection ( const char * ) [protected, virtual]

Member Data Documentation

vtkContourValues* vtkContourGrid::ContourValues [protected]

Definition at line 159 of file vtkContourGrid.h.

int vtkContourGrid::ComputeNormals [protected]

Definition at line 160 of file vtkContourGrid.h.

int vtkContourGrid::ComputeGradients [protected]

Definition at line 161 of file vtkContourGrid.h.

int vtkContourGrid::ComputeScalars [protected]

Definition at line 162 of file vtkContourGrid.h.

vtkPointLocator* vtkContourGrid::Locator [protected]

Definition at line 163 of file vtkContourGrid.h.

int vtkContourGrid::UseScalarTree [protected]

Definition at line 164 of file vtkContourGrid.h.

vtkScalarTree* vtkContourGrid::ScalarTree [protected]

Definition at line 165 of file vtkContourGrid.h.

vtkEdgeTable* vtkContourGrid::EdgeTable [protected]

Definition at line 166 of file vtkContourGrid.h.

char* vtkContourGrid::InputScalarsSelection [protected]

Definition at line 168 of file vtkContourGrid.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkContourGrid.h
Generated on Mon Mar 25 01:16:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkContourValues Class Reference

helper object to manage setting and generating contour values. More...

#include <vtkContourValues.h>

Inheritance diagram for vtkContourValues:

[legend]
Collaboration diagram for vtkContourValues:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkContourValues, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (const int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)

Static Public Methods

vtkContourValues * | New ()

Protected Methods

vtkContourValues ()
~vtkContourValues ()

Protected Attributes

vtkFloatArray * Contours

Detailed Description

helper object to manage setting and generating contour values.

Date:
2002/01/22 15:25:15
Revision:
1.21

vtkContourValues is a general class to manage the creation, generation, and retrieval of contour values. This class serves as a helper class for contouring classes, or those classes operating on lists of contour values.

See also:
vtkContourFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Kelly, Ann (12%)
  • Martin, Ken (11%)
  • Lorensen, Bill (8%)
  • Avila, Lisa (8%)

Definition at line 48 of file vtkContourValues.h.

Constructor & Destructor Documentation

vtkContourValues::vtkContourValues ( ) [protected]

vtkContourValues::~vtkContourValues ( ) [protected]

Member Function Documentation

vtkContourValues* vtkContourValues::New ( ) [static]

Construct object with a single contour value at 0.0.

Reimplemented from vtkObject.

vtkContourValues::vtkTypeRevisionMacro | ( | vtkContourValues | ,
 |  | vtkObject |
 | ) |

void vtkContourValues::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkContourValues::SetValue | ( | int | i,
 |  | float | value
 | ) |

Set the ith contour value.

Referenced by vtkMarchingSquares::SetValue(), vtkMarchingCubes::SetValue(), vtkMarchingContourFilter::SetValue(), vtkImageMarchingCubes::SetValue(), vtkContourGrid::SetValue(), vtkContourFilter::SetValue(), and vtkBandedPolyDataContourFilter::SetValue().

float vtkContourValues::GetValue ( int i )

Get the ith contour value. The return value will be clamped if the index i is out of range.

Referenced by vtkMarchingSquares::GetValue(), vtkMarchingCubes::GetValue(), vtkMarchingContourFilter::GetValue(), vtkImageMarchingCubes::GetValue(), vtkContourGrid::GetValue(), vtkContourFilter::GetValue(), and vtkBandedPolyDataContourFilter::GetValue().

float* vtkContourValues::GetValues ( )

Return a pointer to a list of contour values. The contents of the list will be garbage if the number of contours <= 0.

Referenced by vtkMarchingSquares::GetValues(), vtkMarchingCubes::GetValues(), vtkMarchingContourFilter::GetValues(), vtkImageMarchingCubes::GetValues(), vtkContourGrid::GetValues(), vtkContourFilter::GetValues(), and vtkBandedPolyDataContourFilter::GetValues().

void vtkContourValues::GetValues ( float * contourValues )

Fill a supplied list with contour values. Make sure you've allocated memory of size GetNumberOfContours().

void vtkContourValues::SetNumberOfContours ( const int number )

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Referenced by vtkMarchingSquares::SetNumberOfContours(), vtkMarchingCubes::SetNumberOfContours(), vtkMarchingContourFilter::SetNumberOfContours(), vtkImageMarchingCubes::SetNumberOfContours(), vtkContourGrid::SetNumberOfContours(), vtkContourFilter::SetNumberOfContours(), and vtkBandedPolyDataContourFilter::SetNumberOfContours().

int vtkContourValues::GetNumberOfContours ( )

Return the number of contours in the

Referenced by vtkMarchingSquares::GetNumberOfContours(), vtkMarchingCubes::GetNumberOfContours(), vtkMarchingContourFilter::GetNumberOfContours(), vtkImageMarchingCubes::GetNumberOfContours(), vtkContourGrid::GetNumberOfContours(), vtkContourFilter::GetNumberOfContours(), and vtkBandedPolyDataContourFilter::GetNumberOfContours().

void vtkContourValues::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) |

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Referenced by vtkMarchingSquares::GenerateValues(), vtkMarchingCubes::GenerateValues(), vtkImageMarchingCubes::GenerateValues(), vtkContourGrid::GenerateValues(), vtkContourFilter::GenerateValues(), and vtkBandedPolyDataContourFilter::GenerateValues().

void vtkContourValues::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) |

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Member Data Documentation

vtkFloatArray* vtkContourValues::Contours [protected]

Definition at line 93 of file vtkContourValues.h.

The documentation for this class was generated from the following file:
  • Common/vtkContourValues.h
Generated on Mon Mar 25 01:16:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCoordinate Class Reference

perform coordinate transformation, and represent position, in a variety of vtk coordinate systems. More...

#include <vtkCoordinate.h>

Inheritance diagram for vtkCoordinate:

[legend]
Collaboration diagram for vtkCoordinate:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCoordinate, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
const char * | GetCoordinateSystemAsString ()
float * | GetComputedFloatViewportValue (vtkViewport *)
float * | GetComputedFloatDisplayValue (vtkViewport *)
float * | GetComputedValue (vtkViewport *)
virtual void | SetCoordinateSystem (int)
virtual int | GetCoordinateSystem ()
void | SetCoordinateSystemToDisplay ()
void | SetCoordinateSystemToNormalizedDisplay ()
void | SetCoordinateSystemToViewport ()
void | SetCoordinateSystemToNormalizedViewport ()
void | SetCoordinateSystemToView ()
void | SetCoordinateSystemToWorld ()
virtual void | SetValue (float, float, float)
virtual void | SetValue (float[3])
virtual float * | GetValue ()
virtual void | GetValue (float &, float &, float &)
virtual void | GetValue (float[3])
void | SetValue (float a, float b)
virtual void | SetReferenceCoordinate (vtkCoordinate *)
virtual vtkCoordinate * | GetReferenceCoordinate ()
void | SetViewport (vtkViewport *viewport)
virtual vtkViewport * | GetViewport ()
float * | GetComputedWorldValue (vtkViewport *)
int * | GetComputedViewportValue (vtkViewport *)
int * | GetComputedDisplayValue (vtkViewport *)
int * | GetComputedLocalDisplayValue (vtkViewport *)
virtual float * | GetComputedUserDefinedValue (vtkViewport *)

Static Public Methods

vtkCoordinate * | New ()

Protected Methods

vtkCoordinate ()
~vtkCoordinate ()

Protected Attributes

float | Value [3]
int | CoordinateSystem
vtkCoordinate * | ReferenceCoordinate
vtkViewport * Viewport
float | ComputedWorldValue [3]
int | ComputedDisplayValue [2]
int | ComputedViewportValue [2]
int | Computing
float | ComputedFloatDisplayValue [2]
float | ComputedFloatViewportValue [2]
float | ComputedUserDefinedValue [3]

Detailed Description

perform coordinate transformation, and represent position, in a variety of vtk coordinate systems.

Date:
2002/01/22 15:25:15
Revision:
1.28

vtkCoordinate represents position in a variety of coordinate systems, and converts position to other coordinate systems. It also supports relative positioning, so you can create a cascade of vtkCoordinate objects (no loops please!) that refer to each other. The typical usage of this object is to set the coordinate system in which to represent a position (e.g., SetCoordinateSystemToNormalizedDisplay()), set the value of the coordinate (e.g., SetValue()), and then invoke the appropriate method to convert to another coordinate system (e.g., GetComputedWorldValue()).

The coordinate systems in vtk are as follows:

  DISPLAY -             x-y pixel values in window
  NORMALIZED DISPLAY -  x-y (0,1) normalized values
  VIEWPORT -            x-y pixel values in viewport
  NORMALIZED VIEWPORT - x-y (0,1) normalized value in viewport
  VIEW -                x-y-z (-1,1) values in camera coordinates. (z is depth)
  WORLD -               x-y-z global coordinate values
  USERDEFINED -         x-y-z in User defined space

If you cascade vtkCoordinate objects, you refer to another vtkCoordinate object which in turn can refer to others, and so on. This allows you to create composite groups of things like vtkActor2D that are positioned relative to one another. Note that in cascaded sequences, each vtkCoordinate object may be specified in different coordinate systems!

See also:
vtkProp2D vtkActor2D vtkScalarBarActor
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (66%)
  • Biddiscombe, John (14%)
  • Lorensen, Bill (7%)
Examples:
vtkCoordinate (Examples)
Tests:
vtkCoordinate (Tests)

Definition at line 80 of file vtkCoordinate.h.

Constructor & Destructor Documentation

vtkCoordinate::vtkCoordinate ( ) [protected]

vtkCoordinate::~vtkCoordinate ( ) [protected]

Member Function Documentation

vtkCoordinate::vtkTypeRevisionMacro | ( | vtkCoordinate | ,
 |  | vtkObject |
 | ) |

void vtkCoordinate::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkCoordinate* vtkCoordinate::New ( ) [static]

Creates an instance of this class with the following defaults: value of (0,0,0) in world coordinates.

Reimplemented from vtkObject.

virtual void vtkCoordinate::SetCoordinateSystem ( int ) [virtual]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

virtual int vtkCoordinate::GetCoordinateSystem ( ) [virtual]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

void vtkCoordinate::SetCoordinateSystemToDisplay ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 96 of file vtkCoordinate.h.

void vtkCoordinate::SetCoordinateSystemToNormalizedDisplay ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 97 of file vtkCoordinate.h.

void vtkCoordinate::SetCoordinateSystemToViewport ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 99 of file vtkCoordinate.h.

void vtkCoordinate::SetCoordinateSystemToNormalizedViewport ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 101 of file vtkCoordinate.h.

void vtkCoordinate::SetCoordinateSystemToView ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 103 of file vtkCoordinate.h.

void vtkCoordinate::SetCoordinateSystemToWorld ( ) [inline]

Set/get the coordinate system which this coordinate is defined in. The options are Display, Normalized Display, Viewport, Normalized Viewport, View, and World.

Definition at line 104 of file vtkCoordinate.h.

const char* vtkCoordinate::GetCoordinateSystemAsString ( )

virtual void vtkCoordinate::SetValue | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

virtual void vtkCoordinate::SetValue ( float [3] ) [virtual]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

virtual float* vtkCoordinate::GetValue ( ) [virtual]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

virtual void vtkCoordinate::GetValue | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

virtual void vtkCoordinate::GetValue ( float [3] ) [virtual]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

void vtkCoordinate::SetValue | ( | float | a,
 |  | float | b
 | ) | [inline]

Set/get the value of this coordinate. This can be thought of as the position of this coordinate in its coordinate system.

Definition at line 114 of file vtkCoordinate.h.

virtual void vtkCoordinate::SetReferenceCoordinate ( vtkCoordinate * ) [virtual]

If this coordinate is relative to another coordinate, then specify that coordinate as the ReferenceCoordinate. If this is NULL the coordinate is assumed to be absolute.

virtual vtkCoordinate* vtkCoordinate::GetReferenceCoordinate ( ) [virtual]

If this coordinate is relative to another coordinate, then specify that coordinate as the ReferenceCoordinate. If this is NULL the coordinate is assumed to be absolute.

void vtkCoordinate::SetViewport ( vtkViewport * viewport )

If you want this coordinate to be relative to a specific vtkViewport (vtkRenderer, vtkImager) then you can specify that here.

virtual vtkViewport* vtkCoordinate::GetViewport ( ) [virtual]

If you want this coordinate to be relative to a specific vtkViewport (vtkRenderer, vtkImager) then you can specify that here.

float* vtkCoordinate::GetComputedWorldValue ( vtkViewport * )

Return the computed value in a specified coordinate system.

int* vtkCoordinate::GetComputedViewportValue ( vtkViewport * )

Return the computed value in a specified coordinate system.

int* vtkCoordinate::GetComputedDisplayValue ( vtkViewport * )

Return the computed value in a specified coordinate system.

int* vtkCoordinate::GetComputedLocalDisplayValue ( vtkViewport * )

Return the computed value in a specified coordinate system.

float* vtkCoordinate::GetComputedFloatViewportValue ( vtkViewport * )

float* vtkCoordinate::GetComputedFloatDisplayValue ( vtkViewport * )

float* vtkCoordinate::GetComputedValue ( vtkViewport * )

GetComputedValue() will return either World, Viewport or Display based on what has been set as the coordinate system. This is good for objects like vtkLineSource, where the user might want to use them as World or Viewport coordinates

virtual float* vtkCoordinate::GetComputedUserDefinedValue ( vtkViewport * ) [inline, virtual]

GetComputedUserDefinedValue() is to be used only when the coordinate system is VTK_USERDEFINED. The user must subclass vtkCoordinate and override this function, when set as the TransformCoordinate in 2D-Mappers, the user can customize display of 2D polygons

Definition at line 154 of file vtkCoordinate.h.

Member Data Documentation

float vtkCoordinate::Value[3] [protected]

Definition at line 162 of file vtkCoordinate.h.

int vtkCoordinate::CoordinateSystem [protected]

Definition at line 163 of file vtkCoordinate.h.

vtkCoordinate* vtkCoordinate::ReferenceCoordinate [protected]

Definition at line 164 of file vtkCoordinate.h.

vtkViewport* vtkCoordinate::Viewport [protected]

Definition at line 165 of file vtkCoordinate.h.

float vtkCoordinate::ComputedWorldValue[3] [protected]

Definition at line 166 of file vtkCoordinate.h.

int vtkCoordinate::ComputedDisplayValue[2] [protected]

Definition at line 167 of file vtkCoordinate.h.

int vtkCoordinate::ComputedViewportValue[2] [protected]

Definition at line 168 of file vtkCoordinate.h.

int vtkCoordinate::Computing [protected]

Definition at line 169 of file vtkCoordinate.h.

float vtkCoordinate::ComputedFloatDisplayValue[2] [protected]

Definition at line 171 of file vtkCoordinate.h.

float vtkCoordinate::ComputedFloatViewportValue[2] [protected]

Definition at line 172 of file vtkCoordinate.h.

float vtkCoordinate::ComputedUserDefinedValue[3] [protected]

Definition at line 173 of file vtkCoordinate.h.

The documentation for this class was generated from the following file:
  • Common/vtkCoordinate.h
Generated on Mon Mar 25 01:16:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCriticalSection Class Reference

critical section locking class. More...

#include <vtkCriticalSection.h>

Inheritance diagram for vtkCriticalSection:

[legend]
Collaboration diagram for vtkCriticalSection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCriticalSection, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Lock (void)
void | Unlock (void)

Static Public Methods

vtkCriticalSection * | New ()

Protected Methods

vtkCriticalSection ()

Protected Attributes

vtkSimpleCriticalSection SimpleCriticalSection

Detailed Description

critical section locking class.

Date:
2002/01/22 15:25:16
Revision:
1.13

vtkCriticalSection allows the locking of variables which are accessed through different threads. This header file also defines vtkSimpleCriticalSection which is not a subclass of vtkObject. The API is identical to that of vtkMutexLock, and the behavior is identical as well, except on Windows 9x/NT platforms. The only difference on these platforms is that vtkMutexLock is more flexible, in that it works across processes as well as across threads, but also costs more, in that it evokes a 600-cycle x86 ring transition. The vtkCriticalSection provides a higher-performance equivalent (on Windows) but won't work across processes. Since it is unclear how, in vtk, an object at the vtk level can be shared across processes in the first place, one should use vtkCriticalSection unless one has a very good reason to use vtkMutexLock. If higher-performance equivalents for non-Windows platforms (Irix, SunOS, etc) are discovered, they should replace the implementations in this class

Created by:
  • Volpe, Christopher
Contributed by (if > 5%):
  • Volpe, Christopher (81%)
  • Geveci, Berk (8%)

Definition at line 120 of file vtkCriticalSection.h.

Constructor & Destructor Documentation

vtkCriticalSection::vtkCriticalSection ( ) [inline, protected]

Definition at line 136 of file vtkCriticalSection.h.

Member Function Documentation

vtkCriticalSection* vtkCriticalSection::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkCriticalSection::vtkTypeRevisionMacro | ( | vtkCriticalSection | ,
 |  | vtkObject |
 | ) |

void vtkCriticalSection::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkCriticalSection::Lock ( void ) [inline]

Lock the vtkCriticalSection

Definition at line 143 of file vtkCriticalSection.h.

void vtkCriticalSection::Unlock ( void ) [inline]

Unlock the vtkCriticalSection

Definition at line 148 of file vtkCriticalSection.h.

Member Data Documentation

vtkSimpleCriticalSection vtkCriticalSection::SimpleCriticalSection [protected]

Definition at line 135 of file vtkCriticalSection.h.

The documentation for this class was generated from the following file:
  • Common/vtkCriticalSection.h
Generated on Mon Mar 25 01:16:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCubeAxesActor2D Class Reference

create a 2D plot of a bounding box edges - used for navigation. More...

#include <vtkCubeAxesActor2D.h>

Inheritance diagram for vtkCubeAxesActor2D:

[legend]
Collaboration diagram for vtkCubeAxesActor2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCubeAxesActor2D, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ReleaseGraphicsResources (vtkWindow *)
void | ShallowCopy (vtkCubeAxesActor2D *actor)
int | RenderOverlay (vtkViewport *)
int | RenderOpaqueGeometry (vtkViewport *)
int | RenderTranslucentGeometry (vtkViewport *)
virtual void | SetInput (vtkDataSet *)
virtual vtkDataSet * | GetInput ()
virtual void | SetProp (vtkProp *)
virtual vtkProp * | GetProp ()
virtual void | SetBounds (float, float, float, float, float, float)
virtual void | SetBounds (float[6])
float * | GetBounds ()
void | GetBounds (float &xmin, float &xmax, float &ymin, float &ymax, float &zmin, float &zmax)
void | GetBounds (float bounds[6])
virtual void | SetRanges (float, float, float, float, float, float)
virtual void | SetRanges (float[6])
float * | GetRanges ()
void | GetRanges (float &xmin, float &xmax, float &ymin, float &ymax, float &zmin, float &zmax)
void | GetRanges (float ranges[6])
virtual void | SetUseRanges (int)
virtual int | GetUseRanges ()
virtual void | UseRangesOn ()
virtual void | UseRangesOff ()
virtual void | SetCamera (vtkCamera *)
virtual vtkCamera * | GetCamera ()
virtual void | SetFlyMode (int)
virtual int | GetFlyMode ()
void | SetFlyModeToOuterEdges ()
void | SetFlyModeToClosestTriad ()
virtual void | SetScaling (int)
virtual int | GetScaling ()
virtual void | ScalingOn ()
virtual void | ScalingOff ()
virtual void | SetNumberOfLabels (int)
virtual int | GetNumberOfLabels ()
virtual void | SetXLabel (const char *)
virtual char * | GetXLabel ()
virtual void | SetYLabel (const char *)
virtual char * | GetYLabel ()
virtual void | SetZLabel (const char *)
virtual char * | GetZLabel ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
virtual void | SetFontFactor (float)
virtual float | GetFontFactor ()
virtual void | SetInertia (int)
virtual float | GetInertia ()
virtual void | SetCornerOffset (float)
virtual float | GetCornerOffset ()
virtual void | SetXAxisVisibility (int)
virtual int | GetXAxisVisibility ()
virtual void | XAxisVisibilityOn ()
virtual void | XAxisVisibilityOff ()
virtual void | SetYAxisVisibility (int)
virtual int | GetYAxisVisibility ()
virtual void | YAxisVisibilityOn ()
virtual void | YAxisVisibilityOff ()
virtual void | SetZAxisVisibility (int)
virtual int | GetZAxisVisibility ()
virtual void | ZAxisVisibilityOn ()
virtual void | ZAxisVisibilityOff ()

Static Public Methods

vtkCubeAxesActor2D * | New ()

Protected Methods

vtkCubeAxesActor2D ()
~vtkCubeAxesActor2D ()
void | TransformBounds (vtkViewport *viewport, float bounds[6], float pts[8][3])
int | ClipBounds (vtkViewport *viewport, float pts[8][3], float bounds[6])
float | EvaluatePoint (float planes[24], float x[3])
float | EvaluateBounds (float planes[24], float bounds[6])
void | AdjustAxes (float pts[8][3], float bounds[6], int idx, int xIdx, int yIdx, int zIdx, int zIdx2, int xAxes, int yAxes, int zAxes, float xCoords[4], float yCoords[4], float zCoords[4], float xRange[2], float yRange[2], float zRange[2])

Protected Attributes

vtkDataSet * Input
vtkProp * Prop
float | Bounds [6]
float | Ranges [6]
int | UseRanges
vtkCamera * Camera
int | FlyMode
int | Scaling
vtkAxisActor2D * XAxis
vtkAxisActor2D * YAxis
vtkAxisActor2D * ZAxis
int | NumberOfLabels
char * | XLabel
char * | YLabel
char * | ZLabel
char * | Labels [3]
int | XAxisVisibility
int | YAxisVisibility
int | ZAxisVisibility
int | Bold
int | Italic
int | Shadow
int | FontFamily
char * | LabelFormat
float | FontFactor
float | CornerOffset
int | Inertia
int | RenderCount
int | InertiaAxes [8]
int | RenderSomething

Detailed Description

create a 2D plot of a bounding box edges - used for navigation.

Date:
2002/01/22 15:30:26
Revision:
1.28

vtkCubeAxesActor2D is a composite actor that draws three axes of the bounding box of an input dataset. The axes include labels and titles for the x-y-z axes. The algorithm selects the axes that are on the "exterior" of the bounding box, exterior as determined from examining outer edges of the bounding box in projection (display) space. Alternatively, the edges closest to the viewer (i.e., camera position) can be drawn.

To use this object you must define a bounding box and the camera used to render the vtkCubeAxesActor2D. You may optionally define font family, font size, bolding on/off, italics on/off, and text shadows on/off. (The camera is used to control the scaling and position of the vtkCubeAxesActor2D so that it fits in the viewport and always remains visible.)

The bounding box to use is defined in one of three ways. First, if the Input ivar is defined, then the input dataset's bounds is used. If the Input is not defined, and the Prop (superclass of all actors) is defined, then the Prop's bounds is used. If neither the Input or Prop is defined, then the Bounds instance variable (an array of six floats) is used.

See also:
vtkActor2D vtkAxis2DActor vtkXYPlotActor
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (84%)
  • Cedilnik, Andy (6%)
  • Martin, Ken (5%)
Examples:
vtkCubeAxesActor2D (Examples)
Tests:
vtkCubeAxesActor2D (Tests)

Definition at line 69 of file vtkCubeAxesActor2D.h.

Constructor & Destructor Documentation

vtkCubeAxesActor2D::vtkCubeAxesActor2D ( ) [protected]

vtkCubeAxesActor2D::~vtkCubeAxesActor2D ( ) [protected]

Member Function Documentation

vtkCubeAxesActor2D::vtkTypeRevisionMacro | ( | vtkCubeAxesActor2D | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkCubeAxesActor2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkCubeAxesActor2D* vtkCubeAxesActor2D::New ( ) [static]

Instantiate object with bold, italic, and shadow enabled; font family set to Arial; and label format "6.3g". The number of labels per axis is set to 3.

Reimplemented from vtkActor2D.

int vtkCubeAxesActor2D::RenderOverlay ( vtkViewport * viewport ) [virtual]

Draw the axes as per the vtkProp superclass' API.

Reimplemented from vtkActor2D.

int vtkCubeAxesActor2D::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Draw the axes as per the vtkProp superclass' API.

Reimplemented from vtkActor2D.

int vtkCubeAxesActor2D::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

Draw the axes as per the vtkProp superclass' API.

Reimplemented from vtkActor2D.

Definition at line 84 of file vtkCubeAxesActor2D.h.

virtual void vtkCubeAxesActor2D::SetInput ( vtkDataSet * ) [virtual]

Use the bounding box of this input dataset to draw the cube axes. If this is not specified, then the class will attempt to determine the bounds from the defined Prop or Bounds.

virtual vtkDataSet* vtkCubeAxesActor2D::GetInput ( ) [virtual]

Use the bounding box of this input dataset to draw the cube axes. If this is not specified, then the class will attempt to determine the bounds from the defined Prop or Bounds.

virtual void vtkCubeAxesActor2D::SetProp ( vtkProp * ) [virtual]

Use the bounding box of this prop to draw the cube axes. The Prop is used to determine the bounds only if the Input is not defined.

virtual vtkProp* vtkCubeAxesActor2D::GetProp ( ) [virtual]

Use the bounding box of this prop to draw the cube axes. The Prop is used to determine the bounds only if the Input is not defined.

virtual void vtkCubeAxesActor2D::SetBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Explicitly specify the region in space around which to draw the bounds. The bounds is used only when no Input or Prop is specified. The bounds are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

virtual void vtkCubeAxesActor2D::SetBounds ( float [6] ) [virtual]

Explicitly specify the region in space around which to draw the bounds. The bounds is used only when no Input or Prop is specified. The bounds are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

float* vtkCubeAxesActor2D::GetBounds ( ) [virtual]

Explicitly specify the region in space around which to draw the bounds. The bounds is used only when no Input or Prop is specified. The bounds are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

Reimplemented from vtkProp.

void vtkCubeAxesActor2D::GetBounds | ( | float & | xmin,
 |  | float & | xmax,
 |  | float & | ymin,
 |  | float & | ymax,
 |  | float & | zmin,
 |  | float & | zmax
 | ) |

Explicitly specify the region in space around which to draw the bounds. The bounds is used only when no Input or Prop is specified. The bounds are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

void vtkCubeAxesActor2D::GetBounds ( float bounds[6] )

Explicitly specify the region in space around which to draw the bounds. The bounds is used only when no Input or Prop is specified. The bounds are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

virtual void vtkCubeAxesActor2D::SetRanges | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Explicitly specify the range of values used on the bounds. The ranges are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

virtual void vtkCubeAxesActor2D::SetRanges ( float [6] ) [virtual]

Explicitly specify the range of values used on the bounds. The ranges are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

float* vtkCubeAxesActor2D::GetRanges ( )

Explicitly specify the range of values used on the bounds. The ranges are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

void vtkCubeAxesActor2D::GetRanges | ( | float & | xmin,
 |  | float & | xmax,
 |  | float & | ymin,
 |  | float & | ymax,
 |  | float & | zmin,
 |  | float & | zmax
 | ) |

Explicitly specify the range of values used on the bounds. The ranges are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

void vtkCubeAxesActor2D::GetRanges ( float ranges[6] )

Explicitly specify the range of values used on the bounds. The ranges are specified according to (xmin,xmax, ymin,ymax, zmin,zmax), making sure that the min's are less than the max's.

virtual void vtkCubeAxesActor2D::SetUseRanges ( int ) [virtual]

Set/Get a flag that controls whether the axes use the data ranges or the ranges set by SetRanges. By default the axes use the data ranges.

virtual int vtkCubeAxesActor2D::GetUseRanges ( ) [virtual]

Set/Get a flag that controls whether the axes use the data ranges or the ranges set by SetRanges. By default the axes use the data ranges.

virtual void vtkCubeAxesActor2D::UseRangesOn ( ) [virtual]

Set/Get a flag that controls whether the axes use the data ranges or the ranges set by SetRanges. By default the axes use the data ranges.

virtual void vtkCubeAxesActor2D::UseRangesOff ( ) [virtual]

Set/Get a flag that controls whether the axes use the data ranges or the ranges set by SetRanges. By default the axes use the data ranges.

virtual void vtkCubeAxesActor2D::SetCamera ( vtkCamera * ) [virtual]

Set/Get the camera to perform scaling and translation of the vtkCubeAxesActor2D.

virtual vtkCamera* vtkCubeAxesActor2D::GetCamera ( ) [virtual]

Set/Get the camera to perform scaling and translation of the vtkCubeAxesActor2D.

virtual void vtkCubeAxesActor2D::SetFlyMode ( int ) [virtual]

Specify a mode to control how the axes are drawn: either outer edges or closest triad to the camera position.

virtual int vtkCubeAxesActor2D::GetFlyMode ( ) [virtual]

Specify a mode to control how the axes are drawn: either outer edges or closest triad to the camera position.

void vtkCubeAxesActor2D::SetFlyModeToOuterEdges ( ) [inline]

Specify a mode to control how the axes are drawn: either outer edges or closest triad to the camera position.

Definition at line 145 of file vtkCubeAxesActor2D.h.

void vtkCubeAxesActor2D::SetFlyModeToClosestTriad ( ) [inline]

Specify a mode to control how the axes are drawn: either outer edges or closest triad to the camera position.

Definition at line 147 of file vtkCubeAxesActor2D.h.

virtual void vtkCubeAxesActor2D::SetScaling ( int ) [virtual]

Set/Get a flag that controls whether the axes are scaled to fit in the viewport. If off, the axes size remains constant (i.e., stay the size of the bounding box). By default scaling is on so the axes are scaled to fit inside the viewport.

virtual int vtkCubeAxesActor2D::GetScaling ( ) [virtual]

Set/Get a flag that controls whether the axes are scaled to fit in the viewport. If off, the axes size remains constant (i.e., stay the size of the bounding box). By default scaling is on so the axes are scaled to fit inside the viewport.

virtual void vtkCubeAxesActor2D::ScalingOn ( ) [virtual]

Set/Get a flag that controls whether the axes are scaled to fit in the viewport. If off, the axes size remains constant (i.e., stay the size of the bounding box). By default scaling is on so the axes are scaled to fit inside the viewport.

virtual void vtkCubeAxesActor2D::ScalingOff ( ) [virtual]

Set/Get a flag that controls whether the axes are scaled to fit in the viewport. If off, the axes size remains constant (i.e., stay the size of the bounding box). By default scaling is on so the axes are scaled to fit inside the viewport.

virtual void vtkCubeAxesActor2D::SetNumberOfLabels ( int ) [virtual]

Set/Get the number of annotation labels to show along the x, y, and z axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data.

virtual int vtkCubeAxesActor2D::GetNumberOfLabels ( ) [virtual]

Set/Get the number of annotation labels to show along the x, y, and z axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data.

virtual void vtkCubeAxesActor2D::SetXLabel ( const char * ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual char* vtkCubeAxesActor2D::GetXLabel ( ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual void vtkCubeAxesActor2D::SetYLabel ( const char * ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual char* vtkCubeAxesActor2D::GetYLabel ( ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual void vtkCubeAxesActor2D::SetZLabel ( const char * ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual char* vtkCubeAxesActor2D::GetZLabel ( ) [virtual]

Set/Get the labels for the x, y, and z axes. By default, use "X", "Y" and "Z".

virtual void vtkCubeAxesActor2D::SetBold ( int ) [virtual]

Enable/Disable bolding annotation text.

virtual int vtkCubeAxesActor2D::GetBold ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkCubeAxesActor2D::BoldOn ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkCubeAxesActor2D::BoldOff ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkCubeAxesActor2D::SetItalic ( int ) [virtual]

Enable/Disable italicizing annotation text.

virtual int vtkCubeAxesActor2D::GetItalic ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkCubeAxesActor2D::ItalicOn ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkCubeAxesActor2D::ItalicOff ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkCubeAxesActor2D::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual int vtkCubeAxesActor2D::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkCubeAxesActor2D::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkCubeAxesActor2D::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkCubeAxesActor2D::SetFontFamily ( int ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkCubeAxesActor2D::GetFontFamily ( ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkCubeAxesActor2D::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 208 of file vtkCubeAxesActor2D.h.

void vtkCubeAxesActor2D::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 209 of file vtkCubeAxesActor2D.h.

void vtkCubeAxesActor2D::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 210 of file vtkCubeAxesActor2D.h.

virtual void vtkCubeAxesActor2D::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels on each of the x-y-z axes.

virtual char* vtkCubeAxesActor2D::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels on each of the x-y-z axes.

virtual void vtkCubeAxesActor2D::SetFontFactor ( float ) [virtual]

Set/Get the factor that controls the overall size of the fonts used to label and title the axes.

virtual float vtkCubeAxesActor2D::GetFontFactor ( ) [virtual]

Set/Get the factor that controls the overall size of the fonts used to label and title the axes.

virtual void vtkCubeAxesActor2D::SetInertia ( int ) [virtual]

Set/Get the inertial factor that controls how often (i.e, how many renders) the axes can switch position (jump from one axes to another).

virtual float vtkCubeAxesActor2D::GetInertia ( ) [virtual]

Set/Get the inertial factor that controls how often (i.e, how many renders) the axes can switch position (jump from one axes to another).

virtual void vtkCubeAxesActor2D::SetCornerOffset ( float ) [virtual]

Specify an offset value to "pull back" the axes from the corner at which they are joined to avoid overlap of axes labels. The "COrnerOffset" is the fraction of the axis length to pull back.

virtual float vtkCubeAxesActor2D::GetCornerOffset ( ) [virtual]

Specify an offset value to "pull back" the axes from the corner at which they are joined to avoid overlap of axes labels. The "COrnerOffset" is the fraction of the axis length to pull back.

void vtkCubeAxesActor2D::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

virtual void vtkCubeAxesActor2D::SetXAxisVisibility ( int ) [virtual]

Turn on and off the visibility of each axis.

virtual int vtkCubeAxesActor2D::GetXAxisVisibility ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::XAxisVisibilityOn ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::XAxisVisibilityOff ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::SetYAxisVisibility ( int ) [virtual]

Turn on and off the visibility of each axis.

virtual int vtkCubeAxesActor2D::GetYAxisVisibility ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::YAxisVisibilityOn ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::YAxisVisibilityOff ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::SetZAxisVisibility ( int ) [virtual]

Turn on and off the visibility of each axis.

virtual int vtkCubeAxesActor2D::GetZAxisVisibility ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::ZAxisVisibilityOn ( ) [virtual]

Turn on and off the visibility of each axis.

virtual void vtkCubeAxesActor2D::ZAxisVisibilityOff ( ) [virtual]

Turn on and off the visibility of each axis.

void vtkCubeAxesActor2D::ShallowCopy ( vtkCubeAxesActor2D * actor )

Shallow copy of a CubeAxesActor2D.

void vtkCubeAxesActor2D::TransformBounds | ( | vtkViewport * | viewport,
 |  | float | bounds[6],
 |  | float | pts[8][3]
 | ) | [protected]

int vtkCubeAxesActor2D::ClipBounds | ( | vtkViewport * | viewport,
 |  | float | pts[8][3],
 |  | float | bounds[6]
 | ) | [protected]

float vtkCubeAxesActor2D::EvaluatePoint | ( | float | planes[24],
 |  | float | x[3]
 | ) | [protected]

float vtkCubeAxesActor2D::EvaluateBounds | ( | float | planes[24],
 |  | float | bounds[6]
 | ) | [protected]

void vtkCubeAxesActor2D::AdjustAxes | ( | float | pts[8][3],
 |  | float | bounds[6],
 |  | int | idx,
 |  | int | xIdx,
 |  | int | yIdx,
 |  | int | zIdx,
 |  | int | zIdx2,
 |  | int | xAxes,
 |  | int | yAxes,
 |  | int | zAxes,
 |  | float | xCoords[4],
 |  | float | yCoords[4],
 |  | float | zCoords[4],
 |  | float | xRange[2],
 |  | float | yRange[2],
 |  | float | zRange[2]
 | ) | [protected]

Member Data Documentation

vtkDataSet* vtkCubeAxesActor2D::Input [protected]

Definition at line 268 of file vtkCubeAxesActor2D.h.

vtkProp* vtkCubeAxesActor2D::Prop [protected]

Definition at line 269 of file vtkCubeAxesActor2D.h.

float vtkCubeAxesActor2D::Bounds[6] [protected]

Definition at line 270 of file vtkCubeAxesActor2D.h.

float vtkCubeAxesActor2D::Ranges[6] [protected]

Definition at line 271 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::UseRanges [protected]

Definition at line 272 of file vtkCubeAxesActor2D.h.

vtkCamera* vtkCubeAxesActor2D::Camera [protected]

Definition at line 274 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::FlyMode [protected]

Definition at line 275 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::Scaling [protected]

Definition at line 276 of file vtkCubeAxesActor2D.h.

vtkAxisActor2D* vtkCubeAxesActor2D::XAxis [protected]

Definition at line 278 of file vtkCubeAxesActor2D.h.

vtkAxisActor2D* vtkCubeAxesActor2D::YAxis [protected]

Definition at line 279 of file vtkCubeAxesActor2D.h.

vtkAxisActor2D* vtkCubeAxesActor2D::ZAxis [protected]

Definition at line 280 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::NumberOfLabels [protected]

Definition at line 282 of file vtkCubeAxesActor2D.h.

char* vtkCubeAxesActor2D::XLabel [protected]

Definition at line 283 of file vtkCubeAxesActor2D.h.

char* vtkCubeAxesActor2D::YLabel [protected]

Definition at line 284 of file vtkCubeAxesActor2D.h.

char* vtkCubeAxesActor2D::ZLabel [protected]

Definition at line 285 of file vtkCubeAxesActor2D.h.

char* vtkCubeAxesActor2D::Labels[3] [protected]

Definition at line 286 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::XAxisVisibility [protected]

Definition at line 288 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::YAxisVisibility [protected]

Definition at line 289 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::ZAxisVisibility [protected]

Definition at line 290 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::Bold [protected]

Definition at line 292 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::Italic [protected]

Definition at line 293 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::Shadow [protected]

Definition at line 294 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::FontFamily [protected]

Definition at line 295 of file vtkCubeAxesActor2D.h.

char* vtkCubeAxesActor2D::LabelFormat [protected]

Definition at line 296 of file vtkCubeAxesActor2D.h.

float vtkCubeAxesActor2D::FontFactor [protected]

Definition at line 297 of file vtkCubeAxesActor2D.h.

float vtkCubeAxesActor2D::CornerOffset [protected]

Definition at line 298 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::Inertia [protected]

Definition at line 299 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::RenderCount [protected]

Definition at line 300 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::InertiaAxes[8] [protected]

Definition at line 301 of file vtkCubeAxesActor2D.h.

int vtkCubeAxesActor2D::RenderSomething [protected]

Definition at line 303 of file vtkCubeAxesActor2D.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkCubeAxesActor2D.h
Generated on Mon Mar 25 01:16:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCubeSource Class Reference

create a polygonal representation of a cube. More...

#include <vtkCubeSource.h>

Inheritance diagram for vtkCubeSource:

[legend]
Collaboration diagram for vtkCubeSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCubeSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetXLength (float)
virtual float | GetXLength ()
virtual void | SetYLength (float)
virtual float | GetYLength ()
virtual void | SetZLength (float)
virtual float | GetZLength ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
void | SetBounds (float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
void | SetBounds (float bounds[6])

Static Public Methods

vtkCubeSource * | New ()

Protected Methods

vtkCubeSource (float xL=1.0, float yL=1.0, float zL=1.0)
~vtkCubeSource ()
void | Execute ()

Protected Attributes

float | XLength
float | YLength
float | ZLength
float | Center [3]

Detailed Description

create a polygonal representation of a cube.

Date:
2002/01/22 15:29:13
Revision:
1.42

vtkCubeSource creates a cube centered at origin. The cube is represented with four-sided polygons. It is possible to specify the length, width, and height of the cube independently.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (75%)
  • Lorensen, Bill (6%)
  • Martin, Ken (6%)
Examples:
vtkCubeSource (Examples)
Tests:
vtkCubeSource (Tests)

Definition at line 46 of file vtkCubeSource.h.

Constructor & Destructor Documentation

vtkCubeSource::vtkCubeSource | ( | float | xL = 1.0,
 |  | float | yL = 1.0,
 |  | float | zL = 1.0
 | ) | [protected]

vtkCubeSource::~vtkCubeSource ( ) [inline, protected]

Definition at line 89 of file vtkCubeSource.h.

Member Function Documentation

vtkCubeSource* vtkCubeSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkCubeSource::vtkTypeRevisionMacro | ( | vtkCubeSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkCubeSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkCubeSource::SetXLength ( float ) [virtual]

Set the length of the cube in the x-direction.

virtual float vtkCubeSource::GetXLength ( ) [virtual]

Set the length of the cube in the x-direction.

virtual void vtkCubeSource::SetYLength ( float ) [virtual]

Set the length of the cube in the y-direction.

virtual float vtkCubeSource::GetYLength ( ) [virtual]

Set the length of the cube in the y-direction.

virtual void vtkCubeSource::SetZLength ( float ) [virtual]

Set the length of the cube in the z-direction.

virtual float vtkCubeSource::GetZLength ( ) [virtual]

Set the length of the cube in the z-direction.

virtual void vtkCubeSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the cube.

virtual void vtkCubeSource::SetCenter ( float [3] ) [virtual]

Set the center of the cube.

virtual float* vtkCubeSource::GetCenter ( ) [virtual]

Set the center of the cube.

virtual void vtkCubeSource::GetCenter ( float data[3] ) [virtual]

Set the center of the cube.

void vtkCubeSource::SetBounds | ( | float | xMin,
 |  | float | xMax,
 |  | float | yMin,
 |  | float | yMax,
 |  | float | zMin,
 |  | float | zMax
 | ) |

Convenience method allows creation of cube by specifying bounding box.

void vtkCubeSource::SetBounds ( float bounds[6] )

Convenience method allows creation of cube by specifying bounding box.

void vtkCubeSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkCubeSource::XLength [protected]

Definition at line 92 of file vtkCubeSource.h.

float vtkCubeSource::YLength [protected]

Definition at line 93 of file vtkCubeSource.h.

float vtkCubeSource::ZLength [protected]

Definition at line 94 of file vtkCubeSource.h.

float vtkCubeSource::Center[3] [protected]

Definition at line 95 of file vtkCubeSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCubeSource.h
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCuller Class Reference

a superclass for prop cullers. More...

#include <vtkCuller.h>

Inheritance diagram for vtkCuller:

[legend]
Collaboration diagram for vtkCuller:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCuller, vtkObject)
virtual float Cull (vtkRenderer *ren, vtkProp **propList, int &listLength, int &initialized)=0

Protected Methods

vtkCuller ()
~vtkCuller ()

Detailed Description

a superclass for prop cullers.

Date:
2002/01/22 15:38:29
Revision:
1.15

A culler has a cull method called by the vtkRenderer. The cull method is called before any rendering is performed, and it allows the culler to do some processing on the props and to modify their AllocatedRenderTime and re-order them in the prop list.

See also:
vtkFrustumCoverageCuller
Created by:
  • Avila, Lisa
  • King, Brad
Contributed by (if > 5%):
  • Avila, Lisa (56%)
  • King, Brad (28%)
  • Martin, Ken (10%)

Definition at line 48 of file vtkCuller.h.

Constructor & Destructor Documentation

vtkCuller::vtkCuller ( ) [protected]

vtkCuller::~vtkCuller ( ) [protected]

Member Function Documentation

vtkCuller::vtkTypeRevisionMacro | ( | vtkCuller | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkFrustumCoverageCuller.

virtual float vtkCuller::Cull | ( | vtkRenderer * | ren,
 |  | vtkProp ** | propList,
 |  | int & | listLength,
 |  | int & | initialized
 | ) | [pure virtual]

This is called outside the render loop by vtkRenderer

Reimplemented in vtkFrustumCoverageCuller.

The documentation for this class was generated from the following file:
  • Rendering/vtkCuller.h
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCullerCollection Class Reference

a list of Cullers. More...

#include <vtkCullerCollection.h>

Inheritance diagram for vtkCullerCollection:

[legend]
Collaboration diagram for vtkCullerCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCullerCollection, vtkCollection)
vtkCuller * GetLastItem ()
void | AddItem (vtkCuller *a)
vtkCuller * GetNextItem ()

Static Public Methods

vtkCullerCollection * | New ()

Protected Methods

vtkCullerCollection ()
~vtkCullerCollection ()

Detailed Description

a list of Cullers.

Date:
2002/01/22 15:38:29
Revision:
1.19

vtkCullerCollection represents and provides methods to manipulate a list of Cullers (i.e., vtkCuller and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkCuller vtkCollection
Created by:
  • Avila, Lisa
  • Hoffman, Bill
Contributed by (if > 5%):
  • Avila, Lisa (46%)
  • Martin, Ken (25%)
  • Hoffman, Bill (23%)

Definition at line 45 of file vtkCullerCollection.h.

Constructor & Destructor Documentation

vtkCullerCollection::vtkCullerCollection ( ) [inline, protected]

Definition at line 67 of file vtkCullerCollection.h.

vtkCullerCollection::~vtkCullerCollection ( ) [inline, protected]

Definition at line 68 of file vtkCullerCollection.h.

Member Function Documentation

vtkCullerCollection* vtkCullerCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkCullerCollection::vtkTypeRevisionMacro | ( | vtkCullerCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkCullerCollection::AddItem ( vtkCuller * a ) [inline]

Add an Culler to the list.

Definition at line 53 of file vtkCullerCollection.h.

vtkCuller* vtkCullerCollection::GetNextItem ( ) [inline]

Get the next Culler in the list.

Definition at line 59 of file vtkCullerCollection.h.

vtkCuller * vtkCullerCollection::GetLastItem ( ) [inline]

Get the last Culler in the list.

Definition at line 81 of file vtkCullerCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkCullerCollection.h
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCursor3D Class Reference

generate a 3D cursor representation. More...

#include <vtkCursor3D.h>

Inheritance diagram for vtkCursor3D:

[legend]
Collaboration diagram for vtkCursor3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCursor3D, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * GetFocus ()
void | SetModelBounds (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
void | SetModelBounds (float bounds[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetFocalPoint (float, float, float)
virtual void | SetFocalPoint (float[3])
virtual float * | GetFocalPoint ()
virtual void | GetFocalPoint (float data[3])
virtual void | SetOutline (int)
virtual int | GetOutline ()
virtual void | OutlineOn ()
virtual void | OutlineOff ()
virtual void | SetAxes (int)
virtual int | GetAxes ()
virtual void | AxesOn ()
virtual void | AxesOff ()
virtual void | SetXShadows (int)
virtual int | GetXShadows ()
virtual void | XShadowsOn ()
virtual void | XShadowsOff ()
virtual void | SetYShadows (int)
virtual int | GetYShadows ()
virtual void | YShadowsOn ()
virtual void | YShadowsOff ()
virtual void | SetZShadows (int)
virtual int | GetZShadows ()
virtual void | ZShadowsOn ()
virtual void | ZShadowsOff ()
virtual void | SetWrap (int)
virtual int | GetWrap ()
virtual void | WrapOn ()
virtual void | WrapOff ()
void | AllOn ()
void | AllOff ()

Static Public Methods

vtkCursor3D * | New ()

Protected Methods

vtkCursor3D ()
~vtkCursor3D ()
void | Execute ()

Protected Attributes

vtkPolyData * Focus
float | ModelBounds [6]
float | FocalPoint [3]
int | Outline
int | Axes
int | XShadows
int | YShadows
int | ZShadows
int | Wrap

Detailed Description

generate a 3D cursor representation.

Date:
2002/01/22 15:29:13
Revision:
1.39

vtkCursor3D is an object that generates a 3D representation of a cursor. The cursor consists of a wireframe bounding box, three intersecting axes lines that meet at the cursor focus, and "shadows" or projections of the axes against the sides of the bounding box. Each of these components can be turned on/off.

This filter generates two output datasets. The first (Output) is just the geometric representation of the cursor. The second (Focus) is a single point at the focal point.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (83%)
  • Martin, Ken (6%)
  • Miller, Jim (5%)
Tests:
vtkCursor3D (Tests)

Definition at line 49 of file vtkCursor3D.h.

Constructor & Destructor Documentation

vtkCursor3D::vtkCursor3D ( ) [protected]

vtkCursor3D::~vtkCursor3D ( ) [protected]

Member Function Documentation

vtkCursor3D::vtkTypeRevisionMacro | ( | vtkCursor3D | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkCursor3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkCursor3D* vtkCursor3D::New ( ) [static]

Construct with model bounds = (-1,1,-1,1,-1,1), focal point = (0,0,0), all parts of cursor visible, and wrapping off.

Reimplemented from vtkPolyDataSource.

void vtkCursor3D::SetModelBounds | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

Set / get the boundary of the 3D cursor.

void vtkCursor3D::SetModelBounds ( float bounds[6] )

Set / get the boundary of the 3D cursor.

virtual float* vtkCursor3D::GetModelBounds ( ) [virtual]

Set / get the boundary of the 3D cursor.

virtual void vtkCursor3D::GetModelBounds ( float data[6] ) [virtual]

Set / get the boundary of the 3D cursor.

virtual void vtkCursor3D::SetFocalPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the position of cursor focus.

virtual void vtkCursor3D::SetFocalPoint ( float [3] ) [virtual]

Specify the position of cursor focus.

virtual float* vtkCursor3D::GetFocalPoint ( ) [virtual]

Specify the position of cursor focus.

virtual void vtkCursor3D::GetFocalPoint ( float data[3] ) [virtual]

Specify the position of cursor focus.

virtual void vtkCursor3D::SetOutline ( int ) [virtual]

Turn on/off the wireframe bounding box.

virtual int vtkCursor3D::GetOutline ( ) [virtual]

Turn on/off the wireframe bounding box.

virtual void vtkCursor3D::OutlineOn ( ) [virtual]

Turn on/off the wireframe bounding box.

virtual void vtkCursor3D::OutlineOff ( ) [virtual]

Turn on/off the wireframe bounding box.

virtual void vtkCursor3D::SetAxes ( int ) [virtual]

Turn on/off the wireframe axes.

virtual int vtkCursor3D::GetAxes ( ) [virtual]

Turn on/off the wireframe axes.

virtual void vtkCursor3D::AxesOn ( ) [virtual]

Turn on/off the wireframe axes.

virtual void vtkCursor3D::AxesOff ( ) [virtual]

Turn on/off the wireframe axes.

virtual void vtkCursor3D::SetXShadows ( int ) [virtual]

Turn on/off the wireframe x-shadows.

virtual int vtkCursor3D::GetXShadows ( ) [virtual]

Turn on/off the wireframe x-shadows.

virtual void vtkCursor3D::XShadowsOn ( ) [virtual]

Turn on/off the wireframe x-shadows.

virtual void vtkCursor3D::XShadowsOff ( ) [virtual]

Turn on/off the wireframe x-shadows.

virtual void vtkCursor3D::SetYShadows ( int ) [virtual]

Turn on/off the wireframe y-shadows.

virtual int vtkCursor3D::GetYShadows ( ) [virtual]

Turn on/off the wireframe y-shadows.

virtual void vtkCursor3D::YShadowsOn ( ) [virtual]

Turn on/off the wireframe y-shadows.

virtual void vtkCursor3D::YShadowsOff ( ) [virtual]

Turn on/off the wireframe y-shadows.

virtual void vtkCursor3D::SetZShadows ( int ) [virtual]

Turn on/off the wireframe z-shadows.

virtual int vtkCursor3D::GetZShadows ( ) [virtual]

Turn on/off the wireframe z-shadows.

virtual void vtkCursor3D::ZShadowsOn ( ) [virtual]

Turn on/off the wireframe z-shadows.

virtual void vtkCursor3D::ZShadowsOff ( ) [virtual]

Turn on/off the wireframe z-shadows.

virtual void vtkCursor3D::SetWrap ( int ) [virtual]

Turn on/off cursor wrapping. If the cursor focus moves outside the specified bounds, the cursor will either be restrained against the nearest "wall" (Wrap=off), or it will wrap around (Wrap=on).

virtual int vtkCursor3D::GetWrap ( ) [virtual]

Turn on/off cursor wrapping. If the cursor focus moves outside the specified bounds, the cursor will either be restrained against the nearest "wall" (Wrap=off), or it will wrap around (Wrap=on).

virtual void vtkCursor3D::WrapOn ( ) [virtual]

Turn on/off cursor wrapping. If the cursor focus moves outside the specified bounds, the cursor will either be restrained against the nearest "wall" (Wrap=off), or it will wrap around (Wrap=on).

virtual void vtkCursor3D::WrapOff ( ) [virtual]

Turn on/off cursor wrapping. If the cursor focus moves outside the specified bounds, the cursor will either be restrained against the nearest "wall" (Wrap=off), or it will wrap around (Wrap=on).

vtkPolyData* vtkCursor3D::GetFocus ( ) [inline]

Get the focus for this filter.

Definition at line 118 of file vtkCursor3D.h.

void vtkCursor3D::AllOn ( )

Turn every part of the 3D cursor on or off.

void vtkCursor3D::AllOff ( )

Turn every part of the 3D cursor on or off.

void vtkCursor3D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkPolyData* vtkCursor3D::Focus [protected]

Definition at line 132 of file vtkCursor3D.h.

float vtkCursor3D::ModelBounds[6] [protected]

Definition at line 133 of file vtkCursor3D.h.

float vtkCursor3D::FocalPoint[3] [protected]

Definition at line 134 of file vtkCursor3D.h.

int vtkCursor3D::Outline [protected]

Definition at line 135 of file vtkCursor3D.h.

int vtkCursor3D::Axes [protected]

Definition at line 136 of file vtkCursor3D.h.

int vtkCursor3D::XShadows [protected]

Definition at line 137 of file vtkCursor3D.h.

int vtkCursor3D::YShadows [protected]

Definition at line 138 of file vtkCursor3D.h.

int vtkCursor3D::ZShadows [protected]

Definition at line 139 of file vtkCursor3D.h.

int vtkCursor3D::Wrap [protected]

Definition at line 140 of file vtkCursor3D.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCursor3D.h
Generated on Mon Mar 25 01:16:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCutMaterial Class Reference

Automatically computes the cut plane for a material array pair. More...

#include <vtkCutMaterial.h>

Inheritance diagram for vtkCutMaterial:

[legend]
Collaboration diagram for vtkCutMaterial:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkCutMaterial, vtkDataSetToPolyDataFilter)
virtual void | SetMaterialArrayName (const char *)
virtual char * | GetMaterialArrayName ()
virtual void | SetMaterial (int)
virtual int | GetMaterial ()
virtual void | SetArrayName (const char *)
virtual char * | GetArrayName ()
virtual void | SetUpVector (float, float, float)
virtual void | SetUpVector (float[3])
virtual float * | GetUpVector ()
virtual void | GetUpVector (float &, float &, float &)
virtual void | GetUpVector (float[3])
virtual float * | GetMaximumPoint ()
virtual void | GetMaximumPoint (float &, float &, float &)
virtual void | GetMaximumPoint (float[3])
virtual float * | GetCenterPoint ()
virtual void | GetCenterPoint (float &, float &, float &)
virtual void | GetCenterPoint (float[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float &, float &, float &)
virtual void | GetNormal (float[3])

Static Public Methods

vtkCutMaterial * | New ()

Protected Methods

vtkCutMaterial ()
~vtkCutMaterial ()
void | Execute ()
void | ComputeMaximumPoint (vtkDataSet *input)
void | ComputeNormal ()

Protected Attributes

char * | MaterialArrayName
int | Material
char * | ArrayName
float | UpVector [3]
float | MaximumPoint [3]
float | CenterPoint [3]
float | Normal [3]
vtkPlane * PlaneFunction

Detailed Description

Automatically computes the cut plane for a material array pair.

Date:
2002/01/22 15:34:29
Revision:
1.8

vtkCutMaterial computes a cut plane based on an up vector, center of the bounding box and the location of the maximum variable value. These computed values are available so that they can be used to set the camera for the best view of the plane.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (90%)
  • Geveci, Berk (5%)
Tests:
vtkCutMaterial (Tests)

Definition at line 45 of file vtkCutMaterial.h.

Constructor & Destructor Documentation

vtkCutMaterial::vtkCutMaterial ( ) [protected]

vtkCutMaterial::~vtkCutMaterial ( ) [protected]

Member Function Documentation

void vtkCutMaterial::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkCutMaterial::vtkTypeRevisionMacro | ( | vtkCutMaterial | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

vtkCutMaterial* vtkCutMaterial::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

virtual void vtkCutMaterial::SetMaterialArrayName ( const char * ) [virtual]

Cell array that contains the material values.

virtual char* vtkCutMaterial::GetMaterialArrayName ( ) [virtual]

Cell array that contains the material values.

virtual void vtkCutMaterial::SetMaterial ( int ) [virtual]

Material to probe.

virtual int vtkCutMaterial::GetMaterial ( ) [virtual]

Material to probe.

virtual void vtkCutMaterial::SetArrayName ( const char * ) [virtual]

For now, we just use the cell values. The array name to cut.

virtual char* vtkCutMaterial::GetArrayName ( ) [virtual]

For now, we just use the cell values. The array name to cut.

virtual void vtkCutMaterial::SetUpVector | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

The last piece of information that specifies the plane.

virtual void vtkCutMaterial::SetUpVector ( float [3] ) [virtual]

The last piece of information that specifies the plane.

virtual float* vtkCutMaterial::GetUpVector ( ) [virtual]

The last piece of information that specifies the plane.

virtual void vtkCutMaterial::GetUpVector | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

The last piece of information that specifies the plane.

virtual void vtkCutMaterial::GetUpVector ( float [3] ) [virtual]

The last piece of information that specifies the plane.

virtual float* vtkCutMaterial::GetMaximumPoint ( ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetMaximumPoint | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetMaximumPoint ( float [3] ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual float* vtkCutMaterial::GetCenterPoint ( ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetCenterPoint | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetCenterPoint ( float [3] ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual float* vtkCutMaterial::GetNormal ( ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetNormal | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

virtual void vtkCutMaterial::GetNormal ( float [3] ) [virtual]

Accesses to the values computed during the execute method. They could be used to get a good camera view for the resulting plane.

void vtkCutMaterial::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkCutMaterial::ComputeMaximumPoint ( vtkDataSet * input ) [protected]

void vtkCutMaterial::ComputeNormal ( ) [protected]

Member Data Documentation

char* vtkCutMaterial::MaterialArrayName [protected]

Definition at line 92 of file vtkCutMaterial.h.

int vtkCutMaterial::Material [protected]

Definition at line 93 of file vtkCutMaterial.h.

char* vtkCutMaterial::ArrayName [protected]

Definition at line 94 of file vtkCutMaterial.h.

float vtkCutMaterial::UpVector[3] [protected]

Definition at line 95 of file vtkCutMaterial.h.

float vtkCutMaterial::MaximumPoint[3] [protected]

Definition at line 96 of file vtkCutMaterial.h.

float vtkCutMaterial::CenterPoint[3] [protected]

Definition at line 97 of file vtkCutMaterial.h.

float vtkCutMaterial::Normal[3] [protected]

Definition at line 98 of file vtkCutMaterial.h.

vtkPlane* vtkCutMaterial::PlaneFunction [protected]

Definition at line 100 of file vtkCutMaterial.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkCutMaterial.h
Generated on Mon Mar 25 01:16:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCutter Class Reference

Cut vtkDataSet with user-specified implicit function. More...

#include <vtkCutter.h>

Inheritance diagram for vtkCutter:

[legend]
Collaboration diagram for vtkCutter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCutter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | CreateDefaultLocator ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetCutFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetCutFunction ()
virtual void | SetGenerateCutScalars (int)
virtual int | GetGenerateCutScalars ()
virtual void | GenerateCutScalarsOn ()
virtual void | GenerateCutScalarsOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
virtual void | SetSortBy (int)
virtual int | GetSortBy ()
void | SetSortByToSortByValue ()
void | SetSortByToSortByCell ()
const char * | GetSortByAsString ()

Static Public Methods

vtkCutter * | New ()

Protected Methods

vtkCutter (vtkImplicitFunction *cf=NULL)
~vtkCutter ()
void | Execute ()

Protected Attributes

vtkImplicitFunction * CutFunction
vtkPointLocator * Locator
int | SortBy
vtkContourValues * ContourValues
int | GenerateCutScalars

Detailed Description

Cut vtkDataSet with user-specified implicit function.

Date:
2002/01/22 15:29:13
Revision:
1.54

vtkCutter is a filter to cut through data using any subclass of vtkImplicitFunction. That is, a polygonal surface is created corresponding to the implicit function F(x,y,z) = value(s), where you can specify one or more values used to cut with.

In VTK, cutting means reducing a cell of dimension N to a cut surface of dimension N-1. For example, a tetrahedron when cut by a plane (i.e., vtkPlane implicit function) will generate triangles. (Clipping takes a N dimensional cell and creates N dimension primitives.)

vtkCutter is generally used to "slice-through" a dataset, generating a surface that can be visualized. It is also possible to use vtkCutter to do a form of volume rendering. vtkCutter does this by generating multiple cut surfaces (usually planes) which are ordered (and rendered) from back-to-front. The surfaces are set translucent to give a volumetric rendering effect.

See also:
vtkImplicitFunction vtkClipPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (61%)
  • Lorensen, Bill (15%)
  • Martin, Ken (9%)
  • Law, Charles (5%)
Examples:
vtkCutter (Examples)
Tests:
vtkCutter (Tests)

Definition at line 68 of file vtkCutter.h.

Constructor & Destructor Documentation

vtkCutter::vtkCutter ( vtkImplicitFunction * cf = NULL ) [protected]

vtkCutter::~vtkCutter ( ) [protected]

Member Function Documentation

vtkCutter::vtkTypeRevisionMacro | ( | vtkCutter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkCutter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkCutter* vtkCutter::New ( ) [static]

Construct with user-specified implicit function; initial value of 0.0; and generating cut scalars turned off.

Reimplemented from vtkPolyDataSource.

void vtkCutter::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 81 of file vtkCutter.h.

float vtkCutter::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 87 of file vtkCutter.h.

float* vtkCutter::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 94 of file vtkCutter.h.

void vtkCutter::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 102 of file vtkCutter.h.

void vtkCutter::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 110 of file vtkCutter.h.

int vtkCutter::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 116 of file vtkCutter.h.

void vtkCutter::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 123 of file vtkCutter.h.

void vtkCutter::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 130 of file vtkCutter.h.

unsigned long vtkCutter::GetMTime ( ) [virtual]

Override GetMTime because we delegate to vtkContourValues and refer to vtkImplicitFunction.

Reimplemented from vtkObject.

virtual void vtkCutter::SetCutFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function to perform the cutting.

virtual vtkImplicitFunction* vtkCutter::GetCutFunction ( ) [virtual]

Specify the implicit function to perform the cutting.

virtual void vtkCutter::SetGenerateCutScalars ( int ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data.

virtual int vtkCutter::GetGenerateCutScalars ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data.

virtual void vtkCutter::GenerateCutScalarsOn ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data.

virtual void vtkCutter::GenerateCutScalarsOff ( ) [virtual]

If this flag is enabled, then the output scalar values will be interpolated from the implicit function values, and not the input scalar data.

void vtkCutter::SetLocator ( vtkPointLocator * locator )

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkCutter::GetLocator ( ) [virtual]

Specify a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual void vtkCutter::SetSortBy ( int ) [virtual]

Set the sorting order for the generated polydata. There are two possibilities: Sort by value = 0 - This is the most efficient sort. For each cell, all contour values are processed. This is the default. Sort by cell = 1 - For each contour value, all cells are processed. This order should be used if the extracted polygons must be rendered in a back-to-front or front-to-back order. This is very problem dependent. For most applications, the default order is fine (and faster).

virtual int vtkCutter::GetSortBy ( ) [virtual]

Set the sorting order for the generated polydata. There are two possibilities: Sort by value = 0 - This is the most efficient sort. For each cell, all contour values are processed. This is the default. Sort by cell = 1 - For each contour value, all cells are processed. This order should be used if the extracted polygons must be rendered in a back-to-front or front-to-back order. This is very problem dependent. For most applications, the default order is fine (and faster).

void vtkCutter::SetSortByToSortByValue ( ) [inline]

Set the sorting order for the generated polydata. There are two possibilities: Sort by value = 0 - This is the most efficient sort. For each cell, all contour values are processed. This is the default. Sort by cell = 1 - For each contour value, all cells are processed. This order should be used if the extracted polygons must be rendered in a back-to-front or front-to-back order. This is very problem dependent. For most applications, the default order is fine (and faster).

Definition at line 171 of file vtkCutter.h.

void vtkCutter::SetSortByToSortByCell ( ) [inline]

Set the sorting order for the generated polydata. There are two possibilities: Sort by value = 0 - This is the most efficient sort. For each cell, all contour values are processed. This is the default. Sort by cell = 1 - For each contour value, all cells are processed. This order should be used if the extracted polygons must be rendered in a back-to-front or front-to-back order. This is very problem dependent. For most applications, the default order is fine (and faster).

Definition at line 173 of file vtkCutter.h.

const char * vtkCutter::GetSortByAsString ( void ) [inline]

Return the sorting procedure as a descriptive character string.

Definition at line 199 of file vtkCutter.h.

void vtkCutter::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

void vtkCutter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkImplicitFunction* vtkCutter::CutFunction [protected]

Definition at line 187 of file vtkCutter.h.

vtkPointLocator* vtkCutter::Locator [protected]

Definition at line 189 of file vtkCutter.h.

int vtkCutter::SortBy [protected]

Definition at line 190 of file vtkCutter.h.

vtkContourValues* vtkCutter::ContourValues [protected]

Definition at line 191 of file vtkCutter.h.

int vtkCutter::GenerateCutScalars [protected]

Definition at line 192 of file vtkCutter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCutter.h
Generated on Mon Mar 25 01:16:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCylinder Class Reference

implicit function for a cylinder. More...

#include <vtkCylinder.h>

Inheritance diagram for vtkCylinder:

[legend]
Collaboration diagram for vtkCylinder:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCylinder, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])

Static Public Methods

vtkCylinder * | New ()

Protected Methods

vtkCylinder ()
~vtkCylinder ()

Protected Attributes

float | Radius
float | Center [3]

Detailed Description

implicit function for a cylinder.

Date:
2002/01/22 15:28:02
Revision:
1.36

vtkCylinder computes the implicit function and function gradient for a cylinder. vtkCylinder is a concrete implementation of vtkImplicitFunction. Cylinder is centered at Center and axes of rotation is along the y-axis. (Use the superclass' vtkImplicitFunction transformation matrix if necessary to reposition.)

Warning:
The cylinder is infinite in extent. To truncate the cylinder use the vtkImplicitBoolean in combination with clipping planes.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (63%)
  • Martin, Ken (13%)
  • Lorensen, Bill (13%)
  • Kelly, Ann (7%)
Tests:
vtkCylinder (Tests)

Definition at line 50 of file vtkCylinder.h.

Constructor & Destructor Documentation

vtkCylinder::vtkCylinder ( ) [protected]

vtkCylinder::~vtkCylinder ( ) [inline, protected]

Definition at line 82 of file vtkCylinder.h.

Member Function Documentation

vtkCylinder::vtkTypeRevisionMacro | ( | vtkCylinder | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkCylinder::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkCylinder* vtkCylinder::New ( ) [static]

Construct cylinder radius of 0.5.

Reimplemented from vtkObject.

float vtkCylinder::EvaluateFunction ( float x[3] ) [virtual]

Evaluate cylinder equation F(x,y,z) = (x-x0)^2 + (z-z0)^2 - R^2.

Reimplemented from vtkImplicitFunction.

float vtkCylinder::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate cylinder equation F(x,y,z) = (x-x0)^2 + (z-z0)^2 - R^2.

Reimplemented from vtkImplicitFunction.

Definition at line 62 of file vtkCylinder.h.

void vtkCylinder::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate cylinder function gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkCylinder::SetRadius ( float ) [virtual]

Set/Get cylinder radius.

virtual float vtkCylinder::GetRadius ( ) [virtual]

Set/Get cylinder radius.

virtual void vtkCylinder::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get cylinder center

virtual void vtkCylinder::SetCenter ( float [3] ) [virtual]

Set/Get cylinder center

virtual float* vtkCylinder::GetCenter ( ) [virtual]

Set/Get cylinder center

virtual void vtkCylinder::GetCenter ( float data[3] ) [virtual]

Set/Get cylinder center

Member Data Documentation

float vtkCylinder::Radius [protected]

Definition at line 84 of file vtkCylinder.h.

float vtkCylinder::Center[3] [protected]

Definition at line 85 of file vtkCylinder.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkCylinder.h
Generated on Mon Mar 25 01:16:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkCylinderSource Class Reference

generate a cylinder centered at origin. More...

#include <vtkCylinderSource.h>

Inheritance diagram for vtkCylinderSource:

[legend]
Collaboration diagram for vtkCylinderSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkCylinderSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetHeight (float)
virtual float | GetHeight ()
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetResolution (int)
virtual int | GetResolution ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()

Static Public Methods

vtkCylinderSource * | New ()

Protected Methods

vtkCylinderSource (int res=6)
~vtkCylinderSource ()
void | Execute ()

Protected Attributes

float | Height
float | Radius
float | Center [3]
int | Resolution
int | Capping

Detailed Description

generate a cylinder centered at origin.

Date:
2002/01/22 15:29:13
Revision:
1.43

vtkCylinderSource creates a polygonal cylinder centered at Center; The axis of the cylinder is aligned along the global y-axis. The height and radius of the cylinder can be specified, as well as the number of sides. It is also possible to control whether the cylinder is open-ended or capped.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (80%)
  • Lorensen, Bill (7%)
  • Geveci, Berk (5%)
Examples:
vtkCylinderSource (Examples)
Tests:
vtkCylinderSource (Tests)

Definition at line 48 of file vtkCylinderSource.h.

Constructor & Destructor Documentation

vtkCylinderSource::vtkCylinderSource ( int res = 6 ) [protected]

vtkCylinderSource::~vtkCylinderSource ( ) [inline, protected]

Definition at line 88 of file vtkCylinderSource.h.

Member Function Documentation

vtkCylinderSource* vtkCylinderSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkCylinderSource::vtkTypeRevisionMacro | ( | vtkCylinderSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkCylinderSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkCylinderSource::SetHeight ( float ) [virtual]

Set the height of the cylinder.

virtual float vtkCylinderSource::GetHeight ( ) [virtual]

Set the height of the cylinder.

virtual void vtkCylinderSource::SetRadius ( float ) [virtual]

Set the radius of the cylinder.

virtual float vtkCylinderSource::GetRadius ( ) [virtual]

Set the radius of the cylinder.

virtual void vtkCylinderSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get cylinder center

virtual void vtkCylinderSource::SetCenter ( float [3] ) [virtual]

Set/Get cylinder center

virtual float* vtkCylinderSource::GetCenter ( ) [virtual]

Set/Get cylinder center

virtual void vtkCylinderSource::GetCenter ( float data[3] ) [virtual]

Set/Get cylinder center

virtual void vtkCylinderSource::SetResolution ( int ) [virtual]

Set the number of facets used to define cylinder.

virtual int vtkCylinderSource::GetResolution ( ) [virtual]

Set the number of facets used to define cylinder.

virtual void vtkCylinderSource::SetCapping ( int ) [virtual]

Turn on/off whether to cap cylinder with polygons.

virtual int vtkCylinderSource::GetCapping ( ) [virtual]

Turn on/off whether to cap cylinder with polygons.

virtual void vtkCylinderSource::CappingOn ( ) [virtual]

Turn on/off whether to cap cylinder with polygons.

virtual void vtkCylinderSource::CappingOff ( ) [virtual]

Turn on/off whether to cap cylinder with polygons.

void vtkCylinderSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkCylinderSource::Height [protected]

Definition at line 91 of file vtkCylinderSource.h.

float vtkCylinderSource::Radius [protected]

Definition at line 92 of file vtkCylinderSource.h.

float vtkCylinderSource::Center[3] [protected]

Definition at line 93 of file vtkCylinderSource.h.

int vtkCylinderSource::Resolution [protected]

Definition at line 94 of file vtkCylinderSource.h.

int vtkCylinderSource::Capping [protected]

Definition at line 95 of file vtkCylinderSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkCylinderSource.h
Generated on Mon Mar 25 01:16:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDashedStreamLine Class Reference

generate constant-time dashed streamline in arbitrary dataset. More...

#include <vtkDashedStreamLine.h>

Inheritance diagram for vtkDashedStreamLine:

[legend]
Collaboration diagram for vtkDashedStreamLine:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDashedStreamLine, vtkStreamLine)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDashFactor (float)
virtual float | GetDashFactor ()

Static Public Methods

vtkDashedStreamLine * | New ()

Protected Methods

vtkDashedStreamLine ()
~vtkDashedStreamLine ()
void | Execute ()

Protected Attributes

float | DashFactor

Detailed Description

generate constant-time dashed streamline in arbitrary dataset.

Date:
2002/01/22 15:29:14
Revision:
1.33

vtkDashedStreamLine is a filter that generates a "dashed" streamline for an arbitrary dataset. The streamline consists of a series of dashes, each of which represents (approximately) a constant time increment. Thus, in the resulting visual representation, relatively long dashes represent areas of high velocity, and small dashes represent areas of low velocity.

vtkDashedStreamLine introduces the instance variable DashFactor. DashFactor interacts with its superclass' instance variable StepLength to create the dashes. DashFactor is the percentage of the StepLength line segment that is visible. Thus, if the DashFactor=0.75, the dashes will be "three-quarters on" and "one-quarter off".

See also:
vtkStreamer vtkStreamLine vtkStreamPoints
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (82%)
  • Geveci, Berk (6%)
  • Martin, Ken (6%)
Tests:
vtkDashedStreamLine (Tests)

Definition at line 54 of file vtkDashedStreamLine.h.

Constructor & Destructor Documentation

vtkDashedStreamLine::vtkDashedStreamLine ( ) [protected]

vtkDashedStreamLine::~vtkDashedStreamLine ( ) [inline, protected]

Definition at line 71 of file vtkDashedStreamLine.h.

Member Function Documentation

vtkDashedStreamLine* vtkDashedStreamLine::New ( ) [static]

Construct object with step size set to 1.0.

Reimplemented from vtkStreamLine.

vtkDashedStreamLine::vtkTypeRevisionMacro | ( | vtkDashedStreamLine | ,
 |  | vtkStreamLine |
 | ) |

Reimplemented from vtkStreamLine.

void vtkDashedStreamLine::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkStreamLine.

virtual void vtkDashedStreamLine::SetDashFactor ( float ) [virtual]

For each dash, specify the fraction of the dash that is "on". A factor of 1.0 will result in a continuous line, a factor of 0.5 will result in dashed that are half on and half off.

virtual float vtkDashedStreamLine::GetDashFactor ( ) [virtual]

For each dash, specify the fraction of the dash that is "on". A factor of 1.0 will result in a continuous line, a factor of 0.5 will result in dashed that are half on and half off.

void vtkDashedStreamLine::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkStreamLine.

Member Data Documentation

float vtkDashedStreamLine::DashFactor [protected]

Definition at line 77 of file vtkDashedStreamLine.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDashedStreamLine.h
Generated on Mon Mar 25 01:16:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataArray Class Reference

abstract superclass for arrays. More...

#include <vtkDataArray.h>

Inheritance diagram for vtkDataArray:

[legend]
Collaboration diagram for vtkDataArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataArray, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkDataArray * | MakeObject ()=0
virtual int | GetDataType ()=0
virtual int | GetDataTypeSize ()=0
virtual void | SetNumberOfTuples (const vtkIdType number)=0
virtual float * | GetTuple (const vtkIdType i)=0
void | GetTuples (vtkIdList *ptIds, vtkDataArray *output)
void | GetTuples (vtkIdType p1, vtkIdType p2, vtkDataArray *output)
virtual float | GetComponent (const vtkIdType i, const int j)
virtual void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
virtual void | DeepCopy (vtkDataArray *da)
virtual void | FillComponent (const int j, const float c)
virtual void * | GetVoidPointer (const vtkIdType id)=0
virtual void | Squeeze ()=0
virtual void | Resize (vtkIdType numTuples)=0
unsigned long | GetActualMemorySize ()
void | CreateDefaultLookupTable ()
virtual void | ComputeRange (int comp)
virtual float | GetMaxNorm ()
virtual int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)=0
virtual void | Initialize ()=0
virtual void | SetNumberOfComponents (int)
int | GetNumberOfComponents ()
vtkIdType GetNumberOfTuples ()
virtual void | GetTuple (const vtkIdType i, float *tuple)=0
virtual void | GetTuple (const vtkIdType i, double *tuple)
float | GetTuple1 (const vtkIdType i)
float * | GetTuple2 (const vtkIdType i)
float * | GetTuple3 (const vtkIdType i)
float * | GetTuple4 (const vtkIdType i)
float * | GetTuple9 (const vtkIdType i)
virtual void | SetTuple (const vtkIdType i, const float *tuple)=0
virtual void | SetTuple (const vtkIdType i, const double *tuple)
void | SetTuple1 (const vtkIdType i, float value)
void | SetTuple2 (const vtkIdType i, float val0, float val1)
void | SetTuple3 (const vtkIdType i, float val0, float val1, float val2)
void | SetTuple4 (const vtkIdType i, float val0, float val1, float val2, float val3)
void | SetTuple9 (const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
virtual void | InsertTuple (const vtkIdType i, const float *tuple)=0
virtual void | InsertTuple (const vtkIdType i, const double *tuple)
void | InsertTuple1 (const vtkIdType i, float value)
void | InsertTuple2 (const vtkIdType i, float val0, float val1)
void | InsertTuple3 (const vtkIdType i, float val0, float val1, float val2)
void | InsertTuple4 (const vtkIdType i, float val0, float val1, float val2, float val3)
void | InsertTuple9 (const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
virtual vtkIdType | InsertNextTuple (const float *tuple)=0
virtual vtkIdType | InsertNextTuple (const double *tuple)
void | InsertNextTuple1 (float value)
void | InsertNextTuple2 (float val0, float val1)
void | InsertNextTuple3 (float val0, float val1, float val2)
void | InsertNextTuple4 (float val0, float val1, float val2, float val3)
void | InsertNextTuple9 (float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
virtual void | GetData (vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data)
virtual void | CopyComponent (const int j, vtkDataArray *from, const int fromComponent)
void | Reset ()
vtkIdType GetSize ()
vtkIdType GetMaxId ()
virtual void | SetVoidArray (void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save))
void | SetLookupTable (vtkLookupTable *lut)
virtual vtkLookupTable * | GetLookupTable ()
void | SetName (const char *name)
const char * | GetName ()
void | GetRange (float range[2], int comp)
float * | GetRange (int comp)
float * | GetRange ()
void | GetRange (float range[2])
void | GetDataTypeRange (double range[2])
double | GetDataTypeMin ()
double | GetDataTypeMax ()

Static Public Methods

vtkDataArray * | CreateDataArray (int dataType)

Protected Methods

vtkDataArray (vtkIdType numComp=1)
~vtkDataArray ()

Protected Attributes

vtkLookupTable * LookupTable
vtkIdType Size
vtkIdType MaxId
int | NumberOfComponents
char * | Name

Detailed Description

abstract superclass for arrays.

Date:
2002/02/13 22:46:28
Revision:
1.44

vtkDataArray is an abstract superclass for data array objects. This class defines an API that all array objects must support. Note that the concrete subclasses of this class represent data in native form (char, int, etc.) and often have specialized more efficient methods for operating on this data (for example, getting pointers to data or getting/inserting data in native form).

The logical structure of this class is an array of tuples, where each tuple is made up of n-components (also called a component group), and n is the number of component values in a tuple(n >= 1). Another view of this class is a mxn matrix, where m is the number of tuples, and n is the number of components in a tuple. Thus vtkDataArray can be used to represent scalars (1-4 components), 3D vectors (3 components), texture coordinates (1-3 components), tensors, (9 components) and so on.

Each data array is required to have a character-string name. The naming of the array occurs automatically when it is instantiated, but you are free to name arrays using the SetName() method. (The array name is used for data manipulation.)

See also:
vtkBitArray vtkCharArray vtkUnsignedCharArray vtkShortArray vtkUnsignedShortArray vtkIntArray vtkUnsignedIntArray vtkLongArray vtkUnsignedLongArray vtkFloatArray vtkDoubleArray vtkVoidArray
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Geveci, Berk (53%)
  • Schroeder, Will (30%)
Tests:
vtkDataArray (Tests)

Definition at line 68 of file vtkDataArray.h.

Constructor & Destructor Documentation

vtkDataArray::vtkDataArray ( vtkIdType numComp = 1 ) [protected]

vtkDataArray::~vtkDataArray ( ) [protected]

Member Function Documentation

vtkDataArray::vtkTypeRevisionMacro | ( | vtkDataArray | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

void vtkDataArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual int vtkDataArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [pure virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::Initialize ( ) [pure virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual vtkDataArray* vtkDataArray::MakeObject ( ) [pure virtual]

Virtual constructor creates an object of the same type as this one. The created object also has the same number of components. You are responsible for freeing the object.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual int vtkDataArray::GetDataType ( ) [pure virtual]

Return the underlying data type. An integer indicating data type is returned as specified in vtkSetGet.h.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual int vtkDataArray::GetDataTypeSize ( ) [pure virtual]

Return the size of the underlying data type. For a bit, 0 is returned.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::SetNumberOfComponents ( int ) [virtual]

Set/Get the dimension (n) of the components. Must be >= 1. Make sure that this is set before allocation.

Referenced by vtkPoints::SetNumberOfPoints().

int vtkDataArray::GetNumberOfComponents ( ) [inline]

Set/Get the dimension (n) of the components. Must be >= 1. Make sure that this is set before allocation.

Definition at line 98 of file vtkDataArray.h.

virtual void vtkDataArray::SetNumberOfTuples ( const vtkIdType number ) [pure virtual]

Set the number of tuples (a component group) in the array. Note that this may allocate space depending on the number of components.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

Referenced by vtkPoints::SetNumberOfPoints().

vtkIdType vtkDataArray::GetNumberOfTuples ( ) [inline]

Get the number of tuples (a component group) in the array.

Definition at line 107 of file vtkDataArray.h.

virtual float* vtkDataArray::GetTuple ( const vtkIdType i ) [pure virtual]

Get the data tuple at ith location. Return it as a pointer to an array. Note: this method is not thread-safe, and the pointer is only valid as long as another method invocation to a vtk object is not performed.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [pure virtual]

Get the data tuple at ith location by filling in a user-provided array, Make sure that your array is large enough to hold the NumberOfComponents amount of data being returned.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Get the data tuple at ith location by filling in a user-provided array, Make sure that your array is large enough to hold the NumberOfComponents amount of data being returned.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

float vtkDataArray::GetTuple1 ( const vtkIdType i )

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

float* vtkDataArray::GetTuple2 ( const vtkIdType i )

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

float* vtkDataArray::GetTuple3 ( const vtkIdType i )

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

float* vtkDataArray::GetTuple4 ( const vtkIdType i )

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

float* vtkDataArray::GetTuple9 ( const vtkIdType i )

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::GetTuples | ( | vtkIdList * | ptIds,
 |  | vtkDataArray * | output
 | ) |

Given a list of point ids, return an array of tuples. You must insure that the output array has been previously allocated with enough space to hold the data.

void vtkDataArray::GetTuples | ( | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | vtkDataArray * | output
 | ) |

Get the tuples for the range of points ids specified (i.e., p1->p2 inclusive). You must insure that the output array has been previously allocated with enough space to hold the data.

virtual void vtkDataArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [pure virtual]

Set the data tuple at ith location. Note that range checking or memory allocation is not performed; use this method in conjunction with SetNumberOfTuples() to allocate space.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

Referenced by vtkPoints::SetPoint().

virtual void vtkDataArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the data tuple at ith location. Note that range checking or memory allocation is not performed; use this method in conjunction with SetNumberOfTuples() to allocate space.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

void vtkDataArray::SetTuple1 | ( | const vtkIdType | i,
 |  | float | value
 | ) |

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::SetTuple2 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1
 | ) |

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::SetTuple3 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2
 | ) |

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::SetTuple4 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3
 | ) |

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::SetTuple9 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3,
 |  | float | val4,
 |  | float | val5,
 |  | float | val6,
 |  | float | val7,
 |  | float | val8
 | ) |

These methods are included as convenience for the wrappers. GetTuple() and SetTuple() which return/take arrays can not be used from wrapped languages. These methods can be used instead.

virtual void vtkDataArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [pure virtual]

Insert the data tuple at ith location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

Referenced by vtkPoints::InsertPoint().

virtual void vtkDataArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert the data tuple at ith location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

void vtkDataArray::InsertTuple1 | ( | const vtkIdType | i,
 |  | float | value
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertTuple2 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertTuple3 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertTuple4 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertTuple9 | ( | const vtkIdType | i,
 |  | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3,
 |  | float | val4,
 |  | float | val5,
 |  | float | val6,
 |  | float | val7,
 |  | float | val8
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

virtual vtkIdType vtkDataArray::InsertNextTuple ( const float * tuple ) [pure virtual]

Insert the data tuple at the end of the array and return the location at which the data was inserted. Memory is allocated as necessary to hold the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

Referenced by vtkPoints::InsertNextPoint().

virtual vtkIdType vtkDataArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert the data tuple at the end of the array and return the location at which the data was inserted. Memory is allocated as necessary to hold the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

void vtkDataArray::InsertNextTuple1 ( float value )

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertNextTuple2 | ( | float | val0,
 |  | float | val1
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertNextTuple3 | ( | float | val0,
 |  | float | val1,
 |  | float | val2
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertNextTuple4 | ( | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

void vtkDataArray::InsertNextTuple9 | ( | float | val0,
 |  | float | val1,
 |  | float | val2,
 |  | float | val3,
 |  | float | val4,
 |  | float | val5,
 |  | float | val6,
 |  | float | val7,
 |  | float | val8
 | ) |

These methods are included as convenience for the wrappers. InsertTuple() which takes arrays can not be used from wrapped languages. These methods can be used instead.

virtual float vtkDataArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents.

Reimplemented in vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, and vtkUnsignedShortArray.

virtual void vtkDataArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, and vtkUnsignedShortArray.

virtual void vtkDataArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, and vtkUnsignedShortArray.

virtual void vtkDataArray::GetData | ( | vtkIdType | tupleMin,
 |  | vtkIdType | tupleMax,
 |  | int | compMin,
 |  | int | compMax,
 |  | vtkFloatArray * | data
 | ) | [virtual]

Get the data as a float array in the range (tupleMin,tupleMax) and (compMin, compMax). The resulting float array consists of all data in the tuple range specified and only the component range specified. This process typically requires casting the data from native form into floating point values. This method is provided as a convenience for data exchange, and is not very fast.

virtual void vtkDataArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of data. Copies data from different data arrays even if they are different types (using floating-point exchange).

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

Referenced by vtkUnsignedShortArray::DeepCopy(), vtkUnsignedLongArray::DeepCopy(), vtkUnsignedIntArray::DeepCopy(), and vtkBitArray::SaveUserArray().

virtual void vtkDataArray::FillComponent | ( | const int | j,
 |  | const float | c
 | ) | [virtual]

Fill a component of a data array with a specified value. This method sets the specified component to specified value for all tuples in the data array. This methods can be used to initialize or reinitialize a single component of a multi-component array.

virtual void vtkDataArray::CopyComponent | ( | const int | j,
 |  | vtkDataArray * | from,
 |  | const int | fromComponent
 | ) | [virtual]

Copy a component from one data array into a component on this data array. This method copies the specified component ("fromComponent") from the specified data array ("from") to the specified component ("j") over all the tuples in this data array. This method can be used to extract a component (column) from one data array and paste that data into a component on this data array.

virtual void* vtkDataArray::GetVoidPointer ( const vtkIdType id ) [pure virtual]

Return a void pointer. For image pipeline interface and other special pointer manipulation.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::Squeeze ( ) [pure virtual]

Free any unnecessary memory.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

virtual void vtkDataArray::Resize ( vtkIdType numTuples ) [pure virtual]

Resize the array while conserving the data.

Reimplemented in vtkBitArray, vtkCharArray, vtkDoubleArray, vtkFloatArray, vtkIdTypeArray, vtkIntArray, vtkLongArray, vtkShortArray, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, and vtkVoidArray.

void vtkDataArray::Reset ( ) [inline]

Reset to an empty state, without freeing any memory.

Definition at line 271 of file vtkDataArray.h.

Referenced by vtkCellArray::Reset().

vtkIdType vtkDataArray::GetSize ( ) [inline]

Return the size of the data.

Definition at line 277 of file vtkDataArray.h.

vtkIdType vtkDataArray::GetMaxId ( ) [inline]

What is the maximum id currently in the array.

Definition at line 283 of file vtkDataArray.h.

Referenced by vtkPriorityQueue::DeleteId(), vtkCellArray::GetNextCell(), vtkPriorityQueue::GetPriority(), and vtkCellArray::InsertNextCell().

virtual void vtkDataArray::SetVoidArray | ( | void *vtkNotUsed(array) | ,
 |  | vtkIdType vtkNotUsed(size) | ,
 |  | int vtkNotUsed(save) |
 | ) | [inline, virtual]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the supplied array.

Definition at line 294 of file vtkDataArray.h.

unsigned long vtkDataArray::GetActualMemorySize ( )

Return the memory in kilobytes consumed by this data array. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object. The information returned is valid only after the pipeline has been updated.

void vtkDataArray::CreateDefaultLookupTable ( )

Create default lookup table. Generally used to create one when none is available.

void vtkDataArray::SetLookupTable ( vtkLookupTable * lut )

Set/get the lookup table associated with this scalar data, if any.

virtual vtkLookupTable* vtkDataArray::GetLookupTable ( ) [virtual]

Set/get the lookup table associated with this scalar data, if any.

void vtkDataArray::SetName ( const char * name )

Set/get array's name

const char* vtkDataArray::GetName ( )

Set/get array's name

Referenced by vtkFieldData::GetArrayName().

void vtkDataArray::GetRange | ( | float | range[2],
 |  | int | comp
 | ) | [inline]

Return the range of the array values for the given component. Range is copied into the array provided.

Definition at line 326 of file vtkDataArray.h.

float* vtkDataArray::GetRange ( int comp ) [inline]

Return the range of the array values for the given component. Range is copied into the array provided.

Definition at line 331 of file vtkDataArray.h.

virtual void vtkDataArray::ComputeRange ( int comp ) [virtual]

float* vtkDataArray::GetRange ( ) [inline]

Return the range of the array values for the 0th component. Range is copied into the array provided.

Definition at line 342 of file vtkDataArray.h.

void vtkDataArray::GetRange ( float range[2] ) [inline]

Return the range of the array values for the 0th component. Range is copied into the array provided.

Definition at line 347 of file vtkDataArray.h.

void vtkDataArray::GetDataTypeRange ( double range[2] )

These methods return the Min and Max possible range of the native data type. For example if a vtkScalars consists of unsigned char data these will return (0,255).

double vtkDataArray::GetDataTypeMin ( )

These methods return the Min and Max possible range of the native data type. For example if a vtkScalars consists of unsigned char data these will return (0,255).

double vtkDataArray::GetDataTypeMax ( )

These methods return the Min and Max possible range of the native data type. For example if a vtkScalars consists of unsigned char data these will return (0,255).

virtual float vtkDataArray::GetMaxNorm ( ) [virtual]

Return the maximum norm for the tuples. Note that the max. is computed everytime GetMaxNorm is called.

vtkDataArray* vtkDataArray::CreateDataArray ( int dataType ) [static]

Creates an array for dataType where dataType is one of VTK_BIT, VTK_CHAR, VTK_UNSIGNED_CHAR, VTK_SHORT, VTK_UNSIGNED_SHORT, VTK_INT, VTK_UNSIGNED_INT, VTK_LONG, VTK_UNSIGNED_LONG, VTK_FLOAT, VTK_DOUBLE, VTK_ID_TYPE. Note that the data array returned has be deleted by the user.

Member Data Documentation

vtkLookupTable* vtkDataArray::LookupTable [protected]

Definition at line 378 of file vtkDataArray.h.

vtkIdType vtkDataArray::Size [protected]

Definition at line 380 of file vtkDataArray.h.

vtkIdType vtkDataArray::MaxId [protected]

Definition at line 381 of file vtkDataArray.h.

int vtkDataArray::NumberOfComponents [protected]

Definition at line 382 of file vtkDataArray.h.

char* vtkDataArray::Name [protected]

Definition at line 384 of file vtkDataArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataArray.h
Generated on Mon Mar 25 01:16:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObject Class Reference

general representation of visualization data. More...

#include <vtkDataObject.h>

Inheritance diagram for vtkDataObject:

[legend]
Collaboration diagram for vtkDataObject:

[legend]
List of all members.

[NOHEADER]

void | GlobalReleaseDataFlagOn ()
void | GlobalReleaseDataFlagOff ()
void | SetGlobalReleaseDataFlag (int val)
int | GetGlobalReleaseDataFlag ()

Public Methods

vtkTypeRevisionMacro (vtkDataObject, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkDataObject * | MakeObject ()
unsigned long int | GetMTime ()
virtual void | Initialize ()
void | ReleaseData ()
int | ShouldIReleaseData ()
void | UnRegister (vtkObject *o)
virtual int | GetNetReferenceCount ()
virtual void | Update ()
virtual void | UpdateInformation ()
virtual void | PropagateUpdateExtent ()
virtual void | TriggerAsynchronousUpdate ()
virtual void | UpdateData ()
virtual unsigned long | GetEstimatedMemorySize ()
virtual int | GetDataObjectType ()
unsigned long | GetUpdateTime ()
void | SetUpdateExtentToWholeExtent ()
void | SetPipelineMTime (unsigned long time)
virtual unsigned long | GetPipelineMTime ()
virtual unsigned long | GetActualMemorySize ()
void | CopyInformation (vtkDataObject *data)
void | DataHasBeenGenerated ()
virtual void | PrepareForNewData ()
virtual vtkSource * | GetSource ()
void | SetSource (vtkSource *s)
virtual int | GetDataReleased ()
virtual void | SetReleaseDataFlag (int)
virtual int | GetReleaseDataFlag ()
virtual void | ReleaseDataFlagOn ()
virtual void | ReleaseDataFlagOff ()
virtual void | SetFieldData (vtkFieldData *)
virtual vtkFieldData * | GetFieldData ()
virtual void | SetUpdateExtent (int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel))
void | SetUpdateExtent (int piece, int numPieces)
virtual void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
virtual void | SetUpdateExtent (int ext[6])
virtual int * | GetUpdateExtent ()
virtual void | GetUpdateExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetUpdateExtent (int[6])
virtual void | CopyTypeSpecificInformation (vtkDataObject *data)
void | SetUpdatePiece (int piece)
void | SetUpdateNumberOfPieces (int num)
virtual int | GetUpdatePiece ()
virtual int | GetUpdateNumberOfPieces ()
void | SetUpdateGhostLevel (int level)
virtual int | GetUpdateGhostLevel ()
void | SetRequestExactExtent (int v)
virtual int | GetRequestExactExtent ()
virtual void | RequestExactExtentOn ()
virtual void | RequestExactExtentOff ()
virtual void | SetWholeExtent (int, int, int, int, int, int)
virtual void | SetWholeExtent (int[6])
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetMaximumNumberOfPieces (int)
virtual int | GetMaximumNumberOfPieces ()
virtual void | ShallowCopy (vtkDataObject *src)
virtual void | DeepCopy (vtkDataObject *src)
virtual void | SetLocality (float)
virtual float | GetLocality ()
void | SetExtentTranslator (vtkExtentTranslator *translator)
vtkExtentTranslator * GetExtentTranslator ()
virtual int | GetNumberOfConsumers ()
void | AddConsumer (vtkObject *c)
void | RemoveConsumer (vtkObject *c)
vtkObject * | GetConsumer (int i)
int | IsConsumer (vtkObject *c)

Static Public Methods

vtkDataObject * | New ()

Protected Methods

vtkDataObject ()
~vtkDataObject ()
int | UpdateExtentIsOutsideOfTheExtent ()
int | UpdateExtentIsEmpty ()
virtual int | VerifyUpdateExtent ()
virtual int | GetExtentType ()
virtual void | Crop ()

Protected Attributes

vtkFieldData * FieldData
vtkSource * Source
int | DataReleased
int | NumberOfConsumers
vtkObject ** Consumers
int | WholeExtent [6]
int | Extent [6]
int | UpdateExtent [6]
unsigned char | UpdateExtentInitialized
vtkExtentTranslator * ExtentTranslator
int | NumberOfPieces
int | Piece
int | MaximumNumberOfPieces
int | UpdateNumberOfPieces
int | UpdatePiece
int | RequestExactExtent
int | GhostLevel
int | UpdateGhostLevel
int | ReleaseDataFlag
vtkTimeStamp UpdateTime
unsigned long | PipelineMTime
int | LastUpdateExtentWasOutsideOfTheExtent
float | Locality

Detailed Description

general representation of visualization data.

Date:
2002/02/12 20:34:48
Revision:
1.65

vtkDataObject is an general representation of visualization data. It serves to encapsulate instance variables and methods for visualization network execution, as well as representing data consisting of a field (i.e., just an unstructured pile of data). This is to be compared with a vtkDataSet, which is data with geometric and/or topological structure.

vtkDataObjects are used to represent arbitrary repositories of data via the vtkFieldData instance variable. These data must be eventually mapped into a concrete subclass of vtkDataSet before they can actually be displayed.

See also:
vtkDataSet vtkFieldData vtkDataObjectSource vtkDataObjectFilter vtkDataObjectMapper vtkDataObjectToDataSet vtkFieldDataToAttributeDataFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Law, Charles (53%)
  • Martin, Ken (17%)
  • Schroeder, Will (16%)

Definition at line 59 of file vtkDataObject.h.

Constructor & Destructor Documentation

vtkDataObject::vtkDataObject ( ) [protected]

vtkDataObject::~vtkDataObject ( ) [protected]

Member Function Documentation

vtkDataObject* vtkDataObject::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, vtkUnstructuredGrid, vtkPiecewiseFunction, vtkImageCanvasSource2D, and vtkImageStencilData.

Referenced by MakeObject().

vtkDataObject::vtkTypeRevisionMacro | ( | vtkDataObject | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkDataSet, vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, vtkUnstructuredGrid, vtkPiecewiseFunction, vtkImageCanvasSource2D, and vtkImageStencilData.

void vtkDataObject::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkDataSet, vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkUnstructuredGrid, vtkPiecewiseFunction, vtkImageCanvasSource2D, and vtkImageStencilData.

virtual vtkDataObject* vtkDataObject::MakeObject ( ) [inline, virtual]

Create concrete instance of this data object.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, vtkUnstructuredGrid, vtkPiecewiseFunction, and vtkImageStencilData.

Definition at line 68 of file vtkDataObject.h.

virtual vtkSource* vtkDataObject::GetSource ( ) [virtual]

Set/Get the source object creating this data object.

void vtkDataObject::SetSource ( vtkSource * s )

Set/Get the source object creating this data object.

unsigned long int vtkDataObject::GetMTime ( ) [virtual]

Data objects are composite objects and need to check each part for MTime. The information object also needs to be considered.

Reimplemented from vtkObject.

Reimplemented in vtkDataSet, vtkPointSet, and vtkPiecewiseFunction.

virtual void vtkDataObject::Initialize ( ) [virtual]

Reimplemented in vtkDataSet, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkUnstructuredGrid, vtkPiecewiseFunction, and vtkImageStencilData.

void vtkDataObject::ReleaseData ( )

Release data back to system to conserve memory resource. Used during visualization network execution. Releasing this data does not make down-stream data invalid, so it does not modify the MTime of this data object.

int vtkDataObject::ShouldIReleaseData ( )

Return flag indicating whether data should be released after use by a filter.

virtual int vtkDataObject::GetDataReleased ( ) [virtual]

Get the flag indicating the data has been released.

virtual void vtkDataObject::SetReleaseDataFlag ( int ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a filter.

virtual int vtkDataObject::GetReleaseDataFlag ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a filter.

virtual void vtkDataObject::ReleaseDataFlagOn ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a filter.

virtual void vtkDataObject::ReleaseDataFlagOff ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a filter.

void vtkDataObject::SetGlobalReleaseDataFlag ( int val ) [static]

Turn on/off flag to control whether every object releases its data after being used by a filter.

void vtkDataObject::GlobalReleaseDataFlagOn ( ) [inline]

Definition at line 111 of file vtkDataObject.h.

void vtkDataObject::GlobalReleaseDataFlagOff ( ) [inline]

Definition at line 112 of file vtkDataObject.h.

int vtkDataObject::GetGlobalReleaseDataFlag ( ) [static]

virtual void vtkDataObject::SetFieldData ( vtkFieldData * ) [virtual]

Assign or retrieve field data to this data object.

virtual vtkFieldData* vtkDataObject::GetFieldData ( ) [virtual]

Assign or retrieve field data to this data object.

void vtkDataObject::UnRegister ( vtkObject * o ) [virtual]

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

Reimplemented from vtkObject.

Reimplemented in vtkPointSet.

virtual int vtkDataObject::GetNetReferenceCount ( ) [inline, virtual]

Get the net reference count. That is the count minus any self created loops. This is used in the Source/Data registration to properly free the objects.

Reimplemented in vtkPointSet.

Definition at line 128 of file vtkDataObject.h.

virtual void vtkDataObject::Update ( ) [virtual]

Provides opportunity for the data object to insure internal consistency before access. Also causes owning source/filter (if any) to update itself. The Update() method is composed of UpdateInformation(), PropagateUpdateExtent(), TriggerAsynchronousUpdate(), and UpdateData().

virtual void vtkDataObject::UpdateInformation ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. Update all the "easy to update" information about the object such as the extent which will be used to control the update. This propagates all the way up then back down the pipeline. As a by-product the PipelineMTime is updated.

virtual void vtkDataObject::PropagateUpdateExtent ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. The update extent for this object is propagated up the pipeline. This propagation may early terminate based on the PipelineMTime.

Reimplemented in vtkImageStencilData.

virtual void vtkDataObject::TriggerAsynchronousUpdate ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. Propagate back up the pipeline for ports and trigger the update on the other side of the port to allow for asynchronous parallel processing in the pipeline. This propagation may early terminate based on the PipelineMTime.

Reimplemented in vtkImageStencilData.

virtual void vtkDataObject::UpdateData ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. Propagate the update back up the pipeline, and perform the actual work of updating on the way down. When the propagate arrives at a port, block and wait for the asynchronous update to finish on the other side. This propagation may early terminate based on the PipelineMTime.

Reimplemented in vtkImageData, and vtkImageStencilData.

virtual unsigned long vtkDataObject::GetEstimatedMemorySize ( ) [virtual]

Get the estimated size of this data object itself. Should be called after UpdateInformation() and PropagateUpdateExtent() have both been called. Should be overridden in a subclass - otherwise the default is to assume that this data object requires no memory. The size is returned in kilobytes.

Reimplemented in vtkImageData.

virtual void vtkDataObject::SetUpdateExtent | ( | int vtkNotUsed(piece) | ,
 |  | int vtkNotUsed(numPieces) | ,
 |  | int vtkNotUsed(ghostLevel) |
 | ) | [inline, virtual]

A generic way of specifying an update extent. Subclasses must decide what a piece is. When the NumberOfPieces is zero, then no data is requested, and the source will not execute.

Definition at line 176 of file vtkDataObject.h.

Referenced by vtkUnstructuredGrid::SetUpdateExtent(), vtkStructuredGrid::SetUpdateExtent(), vtkRectilinearGrid::SetUpdateExtent(), vtkPolyData::SetUpdateExtent(), and vtkImageData::SetUpdateExtent().

void vtkDataObject::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

A generic way of specifying an update extent. Subclasses must decide what a piece is. When the NumberOfPieces is zero, then no data is requested, and the source will not execute.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

Definition at line 179 of file vtkDataObject.h.

virtual void vtkDataObject::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [virtual]

Set the update extent for data objects that use 3D extents. Using this method on data objects that set extents as pieces (such as vtkPolyData or vtkUnstructuredGrid) has no real effect. Don't use the set macro to set the update extent since we don't want this object to be modified just due to a change in update extent. When the volume of the extent is zero (0, -1,..), then no data is requested, and the source will not execute.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataObject::SetUpdateExtent ( int ext[6] ) [virtual]

Set the update extent for data objects that use 3D extents. Using this method on data objects that set extents as pieces (such as vtkPolyData or vtkUnstructuredGrid) has no real effect. Don't use the set macro to set the update extent since we don't want this object to be modified just due to a change in update extent. When the volume of the extent is zero (0, -1,..), then no data is requested, and the source will not execute.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual int* vtkDataObject::GetUpdateExtent ( ) [virtual]

Set the update extent for data objects that use 3D extents. Using this method on data objects that set extents as pieces (such as vtkPolyData or vtkUnstructuredGrid) has no real effect. Don't use the set macro to set the update extent since we don't want this object to be modified just due to a change in update extent. When the volume of the extent is zero (0, -1,..), then no data is requested, and the source will not execute.

Reimplemented in vtkPolyData, and vtkUnstructuredGrid.

virtual void vtkDataObject::GetUpdateExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the update extent for data objects that use 3D extents. Using this method on data objects that set extents as pieces (such as vtkPolyData or vtkUnstructuredGrid) has no real effect. Don't use the set macro to set the update extent since we don't want this object to be modified just due to a change in update extent. When the volume of the extent is zero (0, -1,..), then no data is requested, and the source will not execute.

Reimplemented in vtkPolyData, and vtkUnstructuredGrid.

virtual void vtkDataObject::GetUpdateExtent ( int [6] ) [virtual]

Set the update extent for data objects that use 3D extents. Using this method on data objects that set extents as pieces (such as vtkPolyData or vtkUnstructuredGrid) has no real effect. Don't use the set macro to set the update extent since we don't want this object to be modified just due to a change in update extent. When the volume of the extent is zero (0, -1,..), then no data is requested, and the source will not execute.

Reimplemented in vtkPolyData, and vtkUnstructuredGrid.

virtual int vtkDataObject::GetDataObjectType ( ) [inline, virtual]

Return class name of data type. This is one of VTK_STRUCTURED_GRID, VTK_STRUCTURED_POINTS, VTK_UNSTRUCTURED_GRID, VTK_POLY_DATA, or VTK_RECTILINEAR_GRID (see vtkSetGet.h for definitions). THIS METHOD IS THREAD SAFE

Reimplemented in vtkDataSet, vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, vtkUnstructuredGrid, vtkPiecewiseFunction, and vtkImageStencilData.

Definition at line 200 of file vtkDataObject.h.

unsigned long vtkDataObject::GetUpdateTime ( )

Used by Threaded ports to determine if they should initiate an asynchronous update (still in development).

void vtkDataObject::SetUpdateExtentToWholeExtent ( )

If the whole input extent is required to generate the requested output extent, this method can be called to set the input update extent to the whole input extent. This method assumes that the whole extent is known (that UpdateInformation has been called)

void vtkDataObject::SetPipelineMTime ( unsigned long time ) [inline]

Definition at line 212 of file vtkDataObject.h.

virtual unsigned long vtkDataObject::GetPipelineMTime ( ) [virtual]

virtual unsigned long vtkDataObject::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value).

Reimplemented in vtkDataSet, vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkDataObject::CopyInformation ( vtkDataObject * data )

Copy the generic information (WholeExtent ...)

virtual void vtkDataObject::CopyTypeSpecificInformation ( vtkDataObject * image ) [inline, virtual]

By default, there is no type specific information

Reimplemented in vtkImageData.

Definition at line 227 of file vtkDataObject.h.

void vtkDataObject::SetUpdatePiece ( int piece )

Set / Get the update piece and the update number of pieces. Similar to update extent in 3D.

void vtkDataObject::SetUpdateNumberOfPieces ( int num )

Set / Get the update piece and the update number of pieces. Similar to update extent in 3D.

virtual int vtkDataObject::GetUpdatePiece ( ) [virtual]

Set / Get the update piece and the update number of pieces. Similar to update extent in 3D.

virtual int vtkDataObject::GetUpdateNumberOfPieces ( ) [virtual]

Set / Get the update piece and the update number of pieces. Similar to update extent in 3D.

void vtkDataObject::SetUpdateGhostLevel ( int level )

Set / Get the update ghost level and the update number of ghost levels. Similar to update extent in 3D.

virtual int vtkDataObject::GetUpdateGhostLevel ( ) [virtual]

Set / Get the update ghost level and the update number of ghost levels. Similar to update extent in 3D.

void vtkDataObject::SetRequestExactExtent ( int v )

This request flag indicates whether the requester can handle more data than requested. Right now it is used in vtkImageData. Image filters can return more data than requested. The the consumer cannot handle this (i.e. DataSetToDataSetFitler) the image will crop itself. This functionality used to be in ImageToStructuredPoints.

virtual int vtkDataObject::GetRequestExactExtent ( ) [virtual]

This request flag indicates whether the requester can handle more data than requested. Right now it is used in vtkImageData. Image filters can return more data than requested. The the consumer cannot handle this (i.e. DataSetToDataSetFitler) the image will crop itself. This functionality used to be in ImageToStructuredPoints.

virtual void vtkDataObject::RequestExactExtentOn ( ) [virtual]

This request flag indicates whether the requester can handle more data than requested. Right now it is used in vtkImageData. Image filters can return more data than requested. The the consumer cannot handle this (i.e. DataSetToDataSetFitler) the image will crop itself. This functionality used to be in ImageToStructuredPoints.

virtual void vtkDataObject::RequestExactExtentOff ( ) [virtual]

This request flag indicates whether the requester can handle more data than requested. Right now it is used in vtkImageData. Image filters can return more data than requested. The the consumer cannot handle this (i.e. DataSetToDataSetFitler) the image will crop itself. This functionality used to be in ImageToStructuredPoints.

virtual void vtkDataObject::SetWholeExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the whole extent of this data object. The whole extent is meta data for structured data sets. It gets set by the source during the update information call.

virtual void vtkDataObject::SetWholeExtent ( int [6] ) [virtual]

Set/Get the whole extent of this data object. The whole extent is meta data for structured data sets. It gets set by the source during the update information call.

virtual int* vtkDataObject::GetWholeExtent ( ) [virtual]

Set/Get the whole extent of this data object. The whole extent is meta data for structured data sets. It gets set by the source during the update information call.

virtual void vtkDataObject::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the whole extent of this data object. The whole extent is meta data for structured data sets. It gets set by the source during the update information call.

virtual void vtkDataObject::GetWholeExtent ( int [6] ) [virtual]

Set/Get the whole extent of this data object. The whole extent is meta data for structured data sets. It gets set by the source during the update information call.

virtual void vtkDataObject::SetMaximumNumberOfPieces ( int ) [virtual]

Set/Get the maximum number of pieces that can be requested. The maximum number of pieces is meta data for unstructured data sets. It gets set by the source during the update information call. A value of -1 indicates that there is no maximum. A value of

virtual int vtkDataObject::GetMaximumNumberOfPieces ( ) [virtual]

Set/Get the maximum number of pieces that can be requested. The maximum number of pieces is meta data for unstructured data sets. It gets set by the source during the update information call. A value of -1 indicates that there is no maximum. A value of

void vtkDataObject::DataHasBeenGenerated ( )

This method is called by the source when it executes to generate data. It is sort of the opposite of ReleaseData. It sets the DataReleased flag to 0, and sets a new UpdateTime.

virtual void vtkDataObject::PrepareForNewData ( ) [inline, virtual]

make the output data ready for new data to be inserted. For most objects we just call Initialize. But for vtkImageData we leave the old data in case the memory can be reused.

Reimplemented in vtkImageData.

Definition at line 283 of file vtkDataObject.h.

virtual void vtkDataObject::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented in vtkDataSet, vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkUnstructuredGrid, vtkPiecewiseFunction, and vtkImageStencilData.

virtual void vtkDataObject::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented in vtkDataSet, vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkUnstructuredGrid, vtkPiecewiseFunction, and vtkImageStencilData.

virtual void vtkDataObject::SetLocality ( float ) [virtual]

Locality is used internally by the pipeline update mechanism. It is used to get parralel execution when a filter has multiple inputs with ports upstream.

virtual float vtkDataObject::GetLocality ( ) [virtual]

Locality is used internally by the pipeline update mechanism. It is used to get parralel execution when a filter has multiple inputs with ports upstream.

void vtkDataObject::SetExtentTranslator ( vtkExtentTranslator * translator )

An object that will translate pieces into structured extents.

vtkExtentTranslator* vtkDataObject::GetExtentTranslator ( )

An object that will translate pieces into structured extents.

virtual int vtkDataObject::GetNumberOfConsumers ( ) [virtual]

Get the number of consumers

void vtkDataObject::AddConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

void vtkDataObject::RemoveConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

vtkObject* vtkDataObject::GetConsumer ( int i )

Add or remove or get or check a consumer,

int vtkDataObject::IsConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

int vtkDataObject::UpdateExtentIsOutsideOfTheExtent ( ) [protected]

Return non zero if the UpdateExtent is outside of the Extent

int vtkDataObject::UpdateExtentIsEmpty ( ) [protected]

This detects when the UpdateExtent will generate no data, and UpdateData on the source is not necessary. This condition is satisfied when the UpdateExtent has zero volume (0,-1,...) of the UpdateNumberOfPieces is 0.

virtual int vtkDataObject::VerifyUpdateExtent ( ) [protected, virtual]

Default behavior is to make sure that the update extent lies within the whole extent. If it does not, an error condition occurs and this method returns 0. If it is ok, then 1 is returned. Since uninitialized extents are initialized to the whole extent during UpdateInformation() there should not be errors. If a data object subclass wants to try to take care of errors silently, then this method should be overridden.

virtual int vtkDataObject::GetExtentType ( ) [inline, protected, virtual]

Reimplemented in vtkImageData, vtkRectilinearGrid, vtkStructuredGrid, and vtkImageStencilData.

Definition at line 362 of file vtkDataObject.h.

virtual void vtkDataObject::Crop ( ) [protected, virtual]

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, and vtkStructuredGrid.

Member Data Documentation

vtkFieldData* vtkDataObject::FieldData [protected]

Definition at line 326 of file vtkDataObject.h.

vtkSource* vtkDataObject::Source [protected]

Definition at line 329 of file vtkDataObject.h.

int vtkDataObject::DataReleased [protected]

Definition at line 332 of file vtkDataObject.h.

int vtkDataObject::NumberOfConsumers [protected]

Definition at line 335 of file vtkDataObject.h.

vtkObject** vtkDataObject::Consumers [protected]

Definition at line 336 of file vtkDataObject.h.

int vtkDataObject::WholeExtent[6] [protected]

Definition at line 367 of file vtkDataObject.h.

int vtkDataObject::Extent[6] [protected]

Definition at line 368 of file vtkDataObject.h.

int vtkDataObject::UpdateExtent[6] [protected]

Definition at line 369 of file vtkDataObject.h.

unsigned char vtkDataObject::UpdateExtentInitialized [protected]

Definition at line 371 of file vtkDataObject.h.

vtkExtentTranslator* vtkDataObject::ExtentTranslator [protected]

Definition at line 373 of file vtkDataObject.h.

int vtkDataObject::NumberOfPieces [protected]

Definition at line 376 of file vtkDataObject.h.

int vtkDataObject::Piece [protected]

Definition at line 377 of file vtkDataObject.h.

int vtkDataObject::MaximumNumberOfPieces [protected]

Definition at line 378 of file vtkDataObject.h.

int vtkDataObject::UpdateNumberOfPieces [protected]

Definition at line 379 of file vtkDataObject.h.

int vtkDataObject::UpdatePiece [protected]

Definition at line 380 of file vtkDataObject.h.

int vtkDataObject::RequestExactExtent [protected]

Definition at line 388 of file vtkDataObject.h.

int vtkDataObject::GhostLevel [protected]

Definition at line 394 of file vtkDataObject.h.

int vtkDataObject::UpdateGhostLevel [protected]

Definition at line 395 of file vtkDataObject.h.

int vtkDataObject::ReleaseDataFlag [protected]

Definition at line 398 of file vtkDataObject.h.

vtkTimeStamp vtkDataObject::UpdateTime [protected]

Definition at line 401 of file vtkDataObject.h.

unsigned long vtkDataObject::PipelineMTime [protected]

Definition at line 405 of file vtkDataObject.h.

int vtkDataObject::LastUpdateExtentWasOutsideOfTheExtent [protected]

Definition at line 408 of file vtkDataObject.h.

float vtkDataObject::Locality [protected]

Definition at line 415 of file vtkDataObject.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataObject.h
Generated on Mon Mar 25 01:16:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectCollection Class Reference

maintain an unordered list of data objects. More...

#include <vtkDataObjectCollection.h>

Inheritance diagram for vtkDataObjectCollection:

[legend]
Collaboration diagram for vtkDataObjectCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataObjectCollection, vtkCollection)
void | AddItem (vtkDataObject *ds)
vtkDataObject * GetNextItem ()
vtkDataObject * | GetItem (int i)

Static Public Methods

vtkDataObjectCollection * | New ()

Protected Methods

vtkDataObjectCollection ()
~vtkDataObjectCollection ()

Detailed Description

maintain an unordered list of data objects.

Date:
2002/01/22 15:25:17
Revision:
1.9

vtkDataObjectCollection is an object that creates and manipulates lists of data objects. See also vtkCollection and subclasses.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (89%)
  • Martin, Ken (6%)

Definition at line 39 of file vtkDataObjectCollection.h.

Constructor & Destructor Documentation

vtkDataObjectCollection::vtkDataObjectCollection ( ) [inline, protected]

Definition at line 64 of file vtkDataObjectCollection.h.

vtkDataObjectCollection::~vtkDataObjectCollection ( ) [inline, protected]

Definition at line 65 of file vtkDataObjectCollection.h.

Member Function Documentation

vtkDataObjectCollection* vtkDataObjectCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkDataObjectCollection::vtkTypeRevisionMacro | ( | vtkDataObjectCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkDataObjectCollection::AddItem ( vtkDataObject * ds ) [inline]

Add a data object to the list.

Definition at line 47 of file vtkDataObjectCollection.h.

vtkDataObject* vtkDataObjectCollection::GetNextItem ( ) [inline]

Get the next data object in the list.

Definition at line 53 of file vtkDataObjectCollection.h.

vtkDataObject* vtkDataObjectCollection::GetItem ( int i ) [inline]

Get the ith data object in the list.

Definition at line 59 of file vtkDataObjectCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataObjectCollection.h
Generated on Mon Mar 25 01:16:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectReader Class Reference

read vtk field data file. More...

#include <vtkDataObjectReader.h>

Inheritance diagram for vtkDataObjectReader:

[legend]
Collaboration diagram for vtkDataObjectReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataObjectReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * GetOutput ()
vtkDataObject * | GetOutput (int idx)
void | SetOutput (vtkDataObject *)

Static Public Methods

vtkDataObjectReader * | New ()

Protected Methods

vtkDataObjectReader ()
~vtkDataObjectReader ()
void | Execute ()

Detailed Description

read vtk field data file.

Date:
2002/01/22 15:38:10
Revision:
1.19

vtkDataObjectReader is a source object that reads ASCII or binary field data files in vtk format. Fields are general matrix structures used represent complex data. (See text for format details). The output of this reader is a single vtkDataObject. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkFieldData vtkDataObjectWriter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (88%)
  • Lorensen, Bill (7%)
Tests:
vtkDataObjectReader (Tests)

Definition at line 50 of file vtkDataObjectReader.h.

Constructor & Destructor Documentation

vtkDataObjectReader::vtkDataObjectReader ( ) [protected]

vtkDataObjectReader::~vtkDataObjectReader ( ) [protected]

Member Function Documentation

vtkDataObjectReader* vtkDataObjectReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkDataObjectReader::vtkTypeRevisionMacro | ( | vtkDataObjectReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkDataObjectReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkDataObject* vtkDataObjectReader::GetOutput ( )

Get the output field of this reader.

vtkDataObject* vtkDataObjectReader::GetOutput ( int idx ) [inline]

Get the output field of this reader.

Reimplemented from vtkSource.

Definition at line 60 of file vtkDataObjectReader.h.

void vtkDataObjectReader::SetOutput ( vtkDataObject * )

Get the output field of this reader.

void vtkDataObjectReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • IO/vtkDataObjectReader.h
Generated on Mon Mar 25 01:16:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectSource Class Reference

abstract class specifies interface for. More...

#include <vtkDataObjectSource.h>

Inheritance diagram for vtkDataObjectSource:

[legend]
Collaboration diagram for vtkDataObjectSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataObjectSource, vtkSource)
vtkDataObject * GetOutput ()
vtkDataObject * | GetOutput (int idx)
void | SetOutput (vtkDataObject *)

Static Public Methods

vtkDataObjectSource * | New ()

Protected Methods

vtkDataObjectSource ()
~vtkDataObjectSource ()

Detailed Description

abstract class specifies interface for.

Date:
2002/01/22 15:28:02
Revision:
1.16
field source (or objects that generate field output)

vtkDataObjectSource is an abstract object that specifies behavior and interface of field source objects. Field source objects are source objects that create vtkFieldData (field data) on output.

Concrete subclasses of vtkDataObjectSource must define Update() and Execute() methods. The public method Update() invokes network execution and will bring the network up-to-date. The protected Execute() method actually does the work of data creation/generation. The difference between the two methods is that Update() implements input consistency checks and modified time comparisons and then invokes the Execute() which is an implementation of a particular algorithm.

vtkDataObjectSource provides a mechanism for invoking the methods StartMethod() and EndMethod() before and after object execution (via Execute()). These are convenience methods you can use for any purpose (e.g., debugging info, highlighting/notifying user interface, etc.) These methods accept a single void* pointer that can be used to send data to the methods. It is also possible to specify a function to delete the argument via StartMethodArgDelete and EndMethodArgDelete.

Another method, ProgressMethod() can be specified. Some filters invoke this method periodically during their execution. The use is similar to that of StartMethod() and EndMethod().

An important feature of subclasses of vtkDataObjectSource is that it is possible to control the memory-management model (i.e., retain output versus delete output data). If enabled the ReleaseDataFlag enables the deletion of the output data once the downstream process object finishes processing the data (please see text).

See also:
vtkSource vtkFilter vtkFieldDataFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)

Definition at line 71 of file vtkDataObjectSource.h.

Constructor & Destructor Documentation

vtkDataObjectSource::vtkDataObjectSource ( ) [protected]

vtkDataObjectSource::~vtkDataObjectSource ( ) [inline, protected]

Definition at line 87 of file vtkDataObjectSource.h.

Member Function Documentation

vtkDataObjectSource* vtkDataObjectSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkDataSetToDataObjectFilter.

vtkDataObjectSource::vtkTypeRevisionMacro | ( | vtkDataObjectSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToDataObjectFilter.

vtkDataObject* vtkDataObjectSource::GetOutput ( )

Get the output field of this source.

vtkDataObject* vtkDataObjectSource::GetOutput ( int idx ) [inline]

Get the output field of this source.

Reimplemented from vtkSource.

Definition at line 80 of file vtkDataObjectSource.h.

void vtkDataObjectSource::SetOutput ( vtkDataObject * )

Get the output field of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataObjectSource.h
Generated on Mon Mar 25 01:16:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectToDataSetFilter Class Reference

map field data to concrete dataset. More...

#include <vtkDataObjectToDataSetFilter.h>

Inheritance diagram for vtkDataObjectToDataSetFilter:

[legend]
Collaboration diagram for vtkDataObjectToDataSetFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataObjectToDataSetFilter, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkDataObject *input)
vtkDataObject * GetInput ()
void | SetDataSetType (int)
virtual int | GetDataSetType ()
void | SetDataSetTypeToPolyData ()
void | SetDataSetTypeToStructuredPoints ()
void | SetDataSetTypeToStructuredGrid ()
void | SetDataSetTypeToRectilinearGrid ()
void | SetDataSetTypeToUnstructuredGrid ()
vtkDataSet * GetOutput ()
vtkDataSet * | GetOutput (int idx)
vtkPolyData * GetPolyDataOutput ()
vtkStructuredPoints * GetStructuredPointsOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
vtkRectilinearGrid * GetRectilinearGridOutput ()
void | SetPointComponent (int comp, char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetPointComponent (int comp, char *arrayName, int arrayComp)
const char * | GetPointComponentArrayName (int comp)
int | GetPointComponentArrayComponent (int comp)
int | GetPointComponentMinRange (int comp)
int | GetPointComponentMaxRange (int comp)
int | GetPointComponentNormailzeFlag (int comp)
void | SetVertsComponent (char *arrayName, int arrayComp, int min, int max)
void | SetVertsComponent (char *arrayName, int arrayComp)
const char * | GetVertsComponentArrayName ()
int | GetVertsComponentArrayComponent ()
int | GetVertsComponentMinRange ()
int | GetVertsComponentMaxRange ()
void | SetLinesComponent (char *arrayName, int arrayComp, int min, int max)
void | SetLinesComponent (char *arrayName, int arrayComp)
const char * | GetLinesComponentArrayName ()
int | GetLinesComponentArrayComponent ()
int | GetLinesComponentMinRange ()
int | GetLinesComponentMaxRange ()
void | SetPolysComponent (char *arrayName, int arrayComp, int min, int max)
void | SetPolysComponent (char *arrayName, int arrayComp)
const char * | GetPolysComponentArrayName ()
int | GetPolysComponentArrayComponent ()
int | GetPolysComponentMinRange ()
int | GetPolysComponentMaxRange ()
void | SetStripsComponent (char *arrayName, int arrayComp, int min, int max)
void | SetStripsComponent (char *arrayName, int arrayComp)
const char * | GetStripsComponentArrayName ()
int | GetStripsComponentArrayComponent ()
int | GetStripsComponentMinRange ()
int | GetStripsComponentMaxRange ()
void | SetCellTypeComponent (char *arrayName, int arrayComp, int min, int max)
void | SetCellTypeComponent (char *arrayName, int arrayComp)
const char * | GetCellTypeComponentArrayName ()
int | GetCellTypeComponentArrayComponent ()
int | GetCellTypeComponentMinRange ()
int | GetCellTypeComponentMaxRange ()
void | SetCellConnectivityComponent (char *arrayName, int arrayComp, int min, int max)
void | SetCellConnectivityComponent (char *arrayName, int arrayComp)
const char * | GetCellConnectivityComponentArrayName ()
int | GetCellConnectivityComponentArrayComponent ()
int | GetCellConnectivityComponentMinRange ()
int | GetCellConnectivityComponentMaxRange ()
virtual void | SetDefaultNormalize (int)
virtual int | GetDefaultNormalize ()
virtual void | DefaultNormalizeOn ()
virtual void | DefaultNormalizeOff ()
virtual void | SetDimensions (int, int, int)
virtual void | SetDimensions (int[3])
virtual int * | GetDimensions ()
virtual void | GetDimensions (int data[3])
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetSpacing (float, float, float)
virtual void | SetSpacing (float[3])
virtual float * | GetSpacing ()
virtual void | GetSpacing (float data[3])
void | SetDimensionsComponent (char *arrayName, int arrayComp, int min, int max)
void | SetDimensionsComponent (char *arrayName, int arrayComp)
void | SetSpacingComponent (char *arrayName, int arrayComp, int min, int max)
void | SetSpacingComponent (char *arrayName, int arrayComp)
void | SetOriginComponent (char *arrayName, int arrayComp, int min, int max)
void | SetOriginComponent (char *arrayName, int arrayComp)

Static Public Methods

vtkDataObjectToDataSetFilter * | New ()

Protected Methods

vtkDataObjectToDataSetFilter ()
~vtkDataObjectToDataSetFilter ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | SetArrayName (char *&name, char *newName)
vtkIdType | ConstructPoints (vtkPointSet *ps)
vtkIdType | ConstructPoints (vtkRectilinearGrid *rg)
int | ConstructCells (vtkPolyData *pd)
int | ConstructCells (vtkUnstructuredGrid *ug)
vtkCellArray * | ConstructCellArray (vtkDataArray *da, int comp, vtkIdType compRange[2])
void | ConstructDimensions ()
void | ConstructSpacing ()
void | ConstructOrigin ()

Protected Attributes

char | Updating
int | DataSetType
char * | PointArrays [3]
int | PointArrayComponents [3]
vtkIdType | PointComponentRange [3][2]
int | PointNormalize [3]
char * | VertsArray
int | VertsArrayComponent
vtkIdType | VertsComponentRange [2]
char * | LinesArray
int | LinesArrayComponent
vtkIdType | LinesComponentRange [2]
char * | PolysArray
int | PolysArrayComponent
vtkIdType | PolysComponentRange [2]
char * | StripsArray
int | StripsArrayComponent
vtkIdType | StripsComponentRange [2]
char * | CellTypeArray
int | CellTypeArrayComponent
vtkIdType | CellTypeComponentRange [2]
char * | CellConnectivityArray
int | CellConnectivityArrayComponent
vtkIdType | CellConnectivityComponentRange [2]
int | DefaultNormalize
int | Dimensions [3]
float | Origin [3]
float | Spacing [3]
char * | DimensionsArray
int | DimensionsArrayComponent
vtkIdType | DimensionsComponentRange [2]
char * | OriginArray
int | OriginArrayComponent
vtkIdType | OriginComponentRange [2]
char * | SpacingArray
int | SpacingArrayComponent
vtkIdType | SpacingComponentRange [2]

Detailed Description

map field data to concrete dataset.

Date:
2002/01/22 15:29:14
Revision:
1.25

vtkDataObjectToDataSetFilter is an class that maps a data object (i.e., a field) into a concrete dataset, i.e., gives structure to the field by defining a geometry and topology.

To use this filter you associate components in the input field data with portions of the output dataset. (A component is an array of values from the field.) For example, you would specify x-y-z points by assigning components from the field for the x, then y, then z values of the points. You may also have to specify component ranges (for each z-y-z) to make sure that the number of x, y, and z values is the same. Also, you may want to normalize the components which helps distribute the data uniformly. Once you've setup the filter to combine all the pieces of data into a specified dataset (the geometry, topology, point and cell data attributes), the various output methods (e.g., GetPolyData()) are used to retrieve the final product.

This filter is often used in conjunction with vtkFieldDataToAttributeDataFilter. vtkFieldDataToAttributeDataFilter takes field data and transforms it into attribute data (e.g., point and cell data attributes such as scalars and vectors). To do this, use this filter which constructs a concrete dataset and passes the input data object field data to its output. and then use vtkFieldDataToAttributeDataFilter to generate the attribute data associated with the dataset.

Warning:
Make sure that the data you extract is consistent. That is, if you have N points, extract N x, y, and z components. Also, all the information necessary to define a dataset must be given. For example, vtkPolyData requires points at a minimum; vtkStructuredPoints requires setting the dimensions; vtkStructuredGrid requires defining points and dimensions; vtkUnstructuredGrid requires setting points; and vtkRectilinearGrid requires that you define the x, y, and z-coordinate arrays (by specifying points) as well as the dimensions.
Warning:
If you wish to create a dataset of just points (i.e., unstructured points dataset), create vtkPolyData consisting of points. There will be no cells in such a dataset.
See also:
vtkDataObject vtkFieldData vtkDataSet vtkPolyData vtkStructuredPoints vtkStructuredGrid vtkUnstructuredGrid vtkRectilinearGrid vtkDataSetAttributes vtkDataArray
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (78%)
  • Martin, Ken (6%)
  • Lorensen, Bill (6%)
Examples:
vtkDataObjectToDataSetFilter (Examples)
Tests:
vtkDataObjectToDataSetFilter (Tests)

Definition at line 97 of file vtkDataObjectToDataSetFilter.h.

Constructor & Destructor Documentation

vtkDataObjectToDataSetFilter::vtkDataObjectToDataSetFilter ( ) [protected]

vtkDataObjectToDataSetFilter::~vtkDataObjectToDataSetFilter ( ) [protected]

Member Function Documentation

vtkDataObjectToDataSetFilter* vtkDataObjectToDataSetFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkDataObjectToDataSetFilter::vtkTypeRevisionMacro | ( | vtkDataObjectToDataSetFilter | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkDataObjectToDataSetFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkDataObjectToDataSetFilter::SetInput ( vtkDataObject * input )

Set the input to the filter.

vtkDataObject* vtkDataObjectToDataSetFilter::GetInput ( )

Set the input to the filter.

void vtkDataObjectToDataSetFilter::SetDataSetType ( int )

Control what type of data is generated for output.

virtual int vtkDataObjectToDataSetFilter::GetDataSetType ( ) [virtual]

Control what type of data is generated for output.

void vtkDataObjectToDataSetFilter::SetDataSetTypeToPolyData ( ) [inline]

Control what type of data is generated for output.

Definition at line 114 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetDataSetTypeToStructuredPoints ( ) [inline]

Control what type of data is generated for output.

Definition at line 116 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetDataSetTypeToStructuredGrid ( ) [inline]

Control what type of data is generated for output.

Definition at line 118 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetDataSetTypeToRectilinearGrid ( ) [inline]

Control what type of data is generated for output.

Definition at line 120 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetDataSetTypeToUnstructuredGrid ( ) [inline]

Control what type of data is generated for output.

Definition at line 122 of file vtkDataObjectToDataSetFilter.h.

vtkDataSet* vtkDataObjectToDataSetFilter::GetOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

vtkDataSet* vtkDataObjectToDataSetFilter::GetOutput ( int idx ) [inline]

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

Reimplemented from vtkSource.

Definition at line 133 of file vtkDataObjectToDataSetFilter.h.

vtkPolyData* vtkDataObjectToDataSetFilter::GetPolyDataOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

vtkStructuredPoints* vtkDataObjectToDataSetFilter::GetStructuredPointsOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

vtkStructuredGrid* vtkDataObjectToDataSetFilter::GetStructuredGridOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

vtkUnstructuredGrid* vtkDataObjectToDataSetFilter::GetUnstructuredGridOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

vtkRectilinearGrid* vtkDataObjectToDataSetFilter::GetRectilinearGridOutput ( )

Get the output in different forms. The particular method invoked should be consistent with the SetDataSetType() method. (Note: GetOutput() will always return a type consistent with SetDataSetType(). Also, GetOutput() will return NULL if the filter aborted due to inconsistent data.)

void vtkDataObjectToDataSetFilter::SetPointComponent | ( | int | comp,
 |  | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

void vtkDataObjectToDataSetFilter::SetPointComponent | ( | int | comp,
 |  | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

Definition at line 156 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetPointComponentArrayName ( int comp )

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

int vtkDataObjectToDataSetFilter::GetPointComponentArrayComponent ( int comp )

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

int vtkDataObjectToDataSetFilter::GetPointComponentMinRange ( int comp )

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

int vtkDataObjectToDataSetFilter::GetPointComponentMaxRange ( int comp )

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

int vtkDataObjectToDataSetFilter::GetPointComponentNormailzeFlag ( int comp )

Define the component of the field to be used for the x, y, and z values of the points. Note that the parameter comp must lie between (0,2) and refers to the x-y-z (i.e., 0,1,2) components of the points. To define the field component to use you can specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract. (This method should be used for vtkPolyData, vtkUnstructuredGrid, vtkStructuredGrid, and vtkRectilinearGrid.) A convenience method, SetPointComponent(),is also provided which does not require setting the (min,max) component range or the normalize flag (normalize is set to DefaulatNormalize value).

void vtkDataObjectToDataSetFilter::SetVertsComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetVertsComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 174 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetVertsComponentArrayName ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetVertsComponentArrayComponent ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetVertsComponentMinRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetVertsComponentMaxRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetLinesComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetLinesComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 181 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetLinesComponentArrayName ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetLinesComponentArrayComponent ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetLinesComponentMinRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetLinesComponentMaxRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetPolysComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetPolysComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 188 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetPolysComponentArrayName ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetPolysComponentArrayComponent ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetPolysComponentMinRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetPolysComponentMaxRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetStripsComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetStripsComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 195 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetStripsComponentArrayName ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetStripsComponentArrayComponent ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetStripsComponentMinRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetStripsComponentMaxRange ( )

Define cell connectivity when creating vtkPolyData. You can define vertices, lines, polygons, and/or triangle strips via these methods. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of values that (for each cell) includes the number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetCellTypeComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetCellTypeComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 213 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetCellTypeComponentArrayName ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellTypeComponentArrayComponent ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellTypeComponentMinRange ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellTypeComponentMaxRange ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetCellConnectivityComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

void vtkDataObjectToDataSetFilter::SetCellConnectivityComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

Definition at line 221 of file vtkDataObjectToDataSetFilter.h.

const char* vtkDataObjectToDataSetFilter::GetCellConnectivityComponentArrayName ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellConnectivityComponentArrayComponent ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellConnectivityComponentMinRange ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

int vtkDataObjectToDataSetFilter::GetCellConnectivityComponentMaxRange ( )

Define cell types and cell connectivity when creating unstructured grid data. These methods are similar to those for defining points, except that no normalization of the data is possible. Basically, you need to define an array of cell types (an integer value per cell), and another array consisting (for each cell) of a number of points per cell, and then the cell connectivity. (This is the vtk file format described in in the textbook or User's Guide.)

virtual void vtkDataObjectToDataSetFilter::SetDefaultNormalize ( int ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetPointComponent).

virtual int vtkDataObjectToDataSetFilter::GetDefaultNormalize ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetPointComponent).

virtual void vtkDataObjectToDataSetFilter::DefaultNormalizeOn ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetPointComponent).

virtual void vtkDataObjectToDataSetFilter::DefaultNormalizeOff ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetPointComponent).

virtual void vtkDataObjectToDataSetFilter::SetDimensions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify the dimensions to use if generating a dataset that requires dimensions specification (vtkStructuredPoints, vtkStructuredGrid, vtkRectilinearGrid).

virtual void vtkDataObjectToDataSetFilter::SetDimensions ( int [3] ) [virtual]

Specify the dimensions to use if generating a dataset that requires dimensions specification (vtkStructuredPoints, vtkStructuredGrid, vtkRectilinearGrid).

virtual int* vtkDataObjectToDataSetFilter::GetDimensions ( ) [virtual]

Specify the dimensions to use if generating a dataset that requires dimensions specification (vtkStructuredPoints, vtkStructuredGrid, vtkRectilinearGrid).

virtual void vtkDataObjectToDataSetFilter::GetDimensions ( int data[3] ) [virtual]

Specify the dimensions to use if generating a dataset that requires dimensions specification (vtkStructuredPoints, vtkStructuredGrid, vtkRectilinearGrid).

virtual void vtkDataObjectToDataSetFilter::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the origin to use if generating a dataset whose origin can be set (i.e., a vtkStructuredPoints dataset).

virtual void vtkDataObjectToDataSetFilter::SetOrigin ( float [3] ) [virtual]

Specify the origin to use if generating a dataset whose origin can be set (i.e., a vtkStructuredPoints dataset).

virtual float* vtkDataObjectToDataSetFilter::GetOrigin ( ) [virtual]

Specify the origin to use if generating a dataset whose origin can be set (i.e., a vtkStructuredPoints dataset).

virtual void vtkDataObjectToDataSetFilter::GetOrigin ( float data[3] ) [virtual]

Specify the origin to use if generating a dataset whose origin can be set (i.e., a vtkStructuredPoints dataset).

virtual void vtkDataObjectToDataSetFilter::SetSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the spacing to use if generating a dataset whose spacing can be set (i.e., a vtkStructuredPoints dataset).

virtual void vtkDataObjectToDataSetFilter::SetSpacing ( float [3] ) [virtual]

Specify the spacing to use if generating a dataset whose spacing can be set (i.e., a vtkStructuredPoints dataset).

virtual float* vtkDataObjectToDataSetFilter::GetSpacing ( ) [virtual]

Specify the spacing to use if generating a dataset whose spacing can be set (i.e., a vtkStructuredPoints dataset).

virtual void vtkDataObjectToDataSetFilter::GetSpacing ( float data[3] ) [virtual]

Specify the spacing to use if generating a dataset whose spacing can be set (i.e., a vtkStructuredPoints dataset).

void vtkDataObjectToDataSetFilter::SetDimensionsComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

void vtkDataObjectToDataSetFilter::SetDimensionsComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

Definition at line 266 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetSpacingComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

void vtkDataObjectToDataSetFilter::SetSpacingComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

Definition at line 269 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::SetOriginComponent | ( | char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max
 | ) |

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

void vtkDataObjectToDataSetFilter::SetOriginComponent | ( | char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Alternative methods to specify the dimensions, spacing, and origin for those datasets requiring this information. You need to specify the name of an array; the component of the array, and the range of the array (min,max). These methods will override the information given by the previous methods.

Definition at line 272 of file vtkDataObjectToDataSetFilter.h.

void vtkDataObjectToDataSetFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDataObjectToDataSetFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkDataObjectToDataSetFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

void vtkDataObjectToDataSetFilter::SetArrayName | ( | char *& | name,
 |  | char * | newName
 | ) | [protected]

vtkIdType vtkDataObjectToDataSetFilter::ConstructPoints ( vtkPointSet * ps ) [protected]

vtkIdType vtkDataObjectToDataSetFilter::ConstructPoints ( vtkRectilinearGrid * rg ) [protected]

int vtkDataObjectToDataSetFilter::ConstructCells ( vtkPolyData * pd ) [protected]

int vtkDataObjectToDataSetFilter::ConstructCells ( vtkUnstructuredGrid * ug ) [protected]

vtkCellArray* vtkDataObjectToDataSetFilter::ConstructCellArray | ( | vtkDataArray * | da,
 |  | int | comp,
 |  | vtkIdType | compRange[2]
 | ) | [protected]

void vtkDataObjectToDataSetFilter::ConstructDimensions ( ) [protected]

void vtkDataObjectToDataSetFilter::ConstructSpacing ( ) [protected]

void vtkDataObjectToDataSetFilter::ConstructOrigin ( ) [protected]

Member Data Documentation

char vtkDataObjectToDataSetFilter::Updating [protected]

Reimplemented from vtkSource.

Definition at line 284 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::DataSetType [protected]

Definition at line 287 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::PointArrays[3] [protected]

Definition at line 290 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::PointArrayComponents[3] [protected]

Definition at line 291 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::PointComponentRange[3][2] [protected]

Definition at line 292 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::PointNormalize[3] [protected]

Definition at line 293 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::VertsArray [protected]

Definition at line 296 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::VertsArrayComponent [protected]

Definition at line 297 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::VertsComponentRange[2] [protected]

Definition at line 298 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::LinesArray [protected]

Definition at line 300 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::LinesArrayComponent [protected]

Definition at line 301 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::LinesComponentRange[2] [protected]

Definition at line 302 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::PolysArray [protected]

Definition at line 304 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::PolysArrayComponent [protected]

Definition at line 305 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::PolysComponentRange[2] [protected]

Definition at line 306 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::StripsArray [protected]

Definition at line 308 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::StripsArrayComponent [protected]

Definition at line 309 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::StripsComponentRange[2] [protected]

Definition at line 310 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::CellTypeArray [protected]

Definition at line 313 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::CellTypeArrayComponent [protected]

Definition at line 314 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::CellTypeComponentRange[2] [protected]

Definition at line 315 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::CellConnectivityArray [protected]

Definition at line 317 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::CellConnectivityArrayComponent [protected]

Definition at line 318 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::CellConnectivityComponentRange[2] [protected]

Definition at line 319 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::DefaultNormalize [protected]

Definition at line 331 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::Dimensions[3] [protected]

Definition at line 334 of file vtkDataObjectToDataSetFilter.h.

float vtkDataObjectToDataSetFilter::Origin[3] [protected]

Definition at line 335 of file vtkDataObjectToDataSetFilter.h.

float vtkDataObjectToDataSetFilter::Spacing[3] [protected]

Definition at line 336 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::DimensionsArray [protected]

Definition at line 338 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::DimensionsArrayComponent [protected]

Definition at line 339 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::DimensionsComponentRange[2] [protected]

Definition at line 340 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::OriginArray [protected]

Definition at line 342 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::OriginArrayComponent [protected]

Definition at line 343 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::OriginComponentRange[2] [protected]

Definition at line 344 of file vtkDataObjectToDataSetFilter.h.

char* vtkDataObjectToDataSetFilter::SpacingArray [protected]

Definition at line 346 of file vtkDataObjectToDataSetFilter.h.

int vtkDataObjectToDataSetFilter::SpacingArrayComponent [protected]

Definition at line 347 of file vtkDataObjectToDataSetFilter.h.

vtkIdType vtkDataObjectToDataSetFilter::SpacingComponentRange[2] [protected]

Definition at line 348 of file vtkDataObjectToDataSetFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDataObjectToDataSetFilter.h
Generated on Mon Mar 25 01:16:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataObjectWriter Class Reference

write vtk field data. More...

#include <vtkDataObjectWriter.h>

Inheritance diagram for vtkDataObjectWriter:

[legend]
Collaboration diagram for vtkDataObjectWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataObjectWriter, vtkWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkDataObject *input)
vtkDataObject * GetInput ()
void | SetFileName (const char *filename)
char * | GetFileName ()
void | SetHeader (char *header)
char * | GetHeader ()
void | SetFileType (int type)
int | GetFileType ()
void | SetFileTypeToASCII ()
void | SetFileTypeToBinary ()
void | SetFieldDataName (char *fieldname)
char * | GetFieldDataName ()
void | SetInput (vtkDataObject &input)

Static Public Methods

vtkDataObjectWriter * | New ()

Protected Methods

vtkDataObjectWriter ()
~vtkDataObjectWriter ()
void | WriteData ()

Protected Attributes

vtkDataWriter * Writer

Detailed Description

write vtk field data.

Date:
2002/01/22 15:38:10
Revision:
1.18

vtkDataObjectWriter is a source object that writes ASCII or binary field data files in vtk format. Field data is a general form of data in matrix form.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkFieldData vtkFieldDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)
  • Lorensen, Bill (9%)
Tests:
vtkDataObjectWriter (Tests)

Definition at line 49 of file vtkDataObjectWriter.h.

Constructor & Destructor Documentation

vtkDataObjectWriter::vtkDataObjectWriter ( ) [protected]

vtkDataObjectWriter::~vtkDataObjectWriter ( ) [protected]

Member Function Documentation

vtkDataObjectWriter* vtkDataObjectWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkDataObjectWriter::vtkTypeRevisionMacro | ( | vtkDataObjectWriter | ,
 |  | vtkWriter |
 | ) |

Reimplemented from vtkWriter.

void vtkDataObjectWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWriter.

void vtkDataObjectWriter::SetInput ( vtkDataObject * input )

Set / get the input data or filter.

vtkDataObject* vtkDataObjectWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkDataObjectWriter::SetFileName ( const char * filename ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 64 of file vtkDataObjectWriter.h.

char* vtkDataObjectWriter::GetFileName ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 65 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetHeader ( char * header ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 66 of file vtkDataObjectWriter.h.

char* vtkDataObjectWriter::GetHeader ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 67 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetFileType ( int type ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 68 of file vtkDataObjectWriter.h.

int vtkDataObjectWriter::GetFileType ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 69 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetFileTypeToASCII ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 70 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetFileTypeToBinary ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 71 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetFieldDataName ( char * fieldname ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 72 of file vtkDataObjectWriter.h.

char* vtkDataObjectWriter::GetFieldDataName ( ) [inline]

Methods delegated to vtkDataWriter, see vtkDataWriter.

Definition at line 73 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::SetInput ( vtkDataObject & input ) [inline]

For legacy compatibility. Do not use.

Definition at line 78 of file vtkDataObjectWriter.h.

void vtkDataObjectWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkWriter.

Member Data Documentation

vtkDataWriter* vtkDataObjectWriter::Writer [protected]

Definition at line 87 of file vtkDataObjectWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkDataObjectWriter.h
Generated on Mon Mar 25 01:16:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataReader Class Reference

helper superclass for objects that read vtk data files. More...

#include <vtkDataReader.h>

Inheritance diagram for vtkDataReader:

[legend]
Collaboration diagram for vtkDataReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataReader, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
int | OpenVTKFile ()
int | ReadHeader ()
int | ReadCellData (vtkDataSet *ds, int numCells)
int | ReadPointData (vtkDataSet *ds, int numPts)
int | ReadPoints (vtkPointSet *ps, int numPts)
int | ReadCells (int size, int *data)
int | ReadCells (int size, int *data, int skip1, int read2, int skip3)
int | ReadCoordinates (vtkRectilinearGrid *rg, int axes, int numCoords)
void | CloseVTKFile ()
int | ReadLine (char result[256])
int | ReadString (char result[256])
char * | LowerCase (char *str, const size_t len=256)
istream * GetIStream ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
int | IsFileValid (const char *dstype)
int | IsFileStructuredPoints ()
int | IsFilePolyData ()
int | IsFileStructuredGrid ()
int | IsFileUnstructuredGrid ()
int | IsFileRectilinearGrid ()
void | SetInputString (const char *in)
virtual char * | GetInputString ()
void | SetInputString (const char *in, int len)
virtual int | GetInputStringLength ()
void | SetBinaryInputString (const char *, int len)
virtual void | SetInputArray (vtkCharArray *)
virtual vtkCharArray * | GetInputArray ()
virtual char * | GetHeader ()
virtual void | SetReadFromInputString (int)
virtual int | GetReadFromInputString ()
virtual void | ReadFromInputStringOn ()
virtual void | ReadFromInputStringOff ()
virtual int | GetFileType ()
int | GetNumberOfScalarsInFile ()
int | GetNumberOfVectorsInFile ()
int | GetNumberOfTensorsInFile ()
int | GetNumberOfNormalsInFile ()
int | GetNumberOfTCoordsInFile ()
int | GetNumberOfFieldDataInFile ()
const char * | GetScalarsNameInFile (int i)
const char * | GetVectorsNameInFile (int i)
const char * | GetTensorsNameInFile (int i)
const char * | GetNormalsNameInFile (int i)
const char * | GetTCoordsNameInFile (int i)
const char * | GetFieldDataNameInFile (int i)
virtual void | SetScalarsName (const char *)
virtual char * | GetScalarsName ()
virtual void | SetVectorsName (const char *)
virtual char * | GetVectorsName ()
virtual void | SetTensorsName (const char *)
virtual char * | GetTensorsName ()
virtual void | SetNormalsName (const char *)
virtual char * | GetNormalsName ()
virtual void | SetTCoordsName (const char *)
virtual char * | GetTCoordsName ()
virtual void | SetLookupTableName (const char *)
virtual char * | GetLookupTableName ()
virtual void | SetFieldDataName (const char *)
virtual char * | GetFieldDataName ()
vtkDataArray * | ReadArray (const char *dataType, int numTuples, int numComp)
vtkFieldData * ReadFieldData ()
int | Read (char *)
int | Read (unsigned char *)
int | Read (short *)
int | Read (unsigned short *)
int | Read (int *)
int | Read (unsigned int *)
int | Read (long *)
int | Read (unsigned long *)
int | Read (float *)
int | Read (double *)

Static Public Methods

vtkDataReader * | New ()

Protected Methods

vtkDataReader ()
~vtkDataReader ()
virtual void | SetScalarLut (const char *)
virtual char * | GetScalarLut ()
int | ReadScalarData (vtkDataSetAttributes *a, int num)
int | ReadVectorData (vtkDataSetAttributes *a, int num)
int | ReadNormalData (vtkDataSetAttributes *a, int num)
int | ReadTensorData (vtkDataSetAttributes *a, int num)
int | ReadCoScalarData (vtkDataSetAttributes *a, int num)
int | ReadLutData (vtkDataSetAttributes *a)
int | ReadTCoordsData (vtkDataSetAttributes *a, int num)
int | ReadDataSetData (vtkDataSet *ds)
void | InitializeCharacteristics ()
int | CharacterizeFile ()
void | CheckFor (const char *name, char *line, int &num, char **&array, int &allocSize)
void | DecodeArrayName (char *resname, const char *name)

Protected Attributes

char * | FileName
int | FileType
istream * IS
char * | ScalarsName
char * | VectorsName
char * | TensorsName
char * | TCoordsName
char * | NormalsName
char * | LookupTableName
char * | FieldDataName
char * | ScalarLut
int | ReadFromInputString
char * | InputString
int | InputStringLength
int | InputStringPos
char * | Header
int | NumberOfScalarsInFile
char ** | ScalarsNameInFile
int | ScalarsNameAllocSize
int | NumberOfVectorsInFile
char ** | VectorsNameInFile
int | VectorsNameAllocSize
int | NumberOfTensorsInFile
char ** | TensorsNameInFile
int | TensorsNameAllocSize
int | NumberOfTCoordsInFile
char ** | TCoordsNameInFile
int | TCoordsNameAllocSize
int | NumberOfNormalsInFile
char ** | NormalsNameInFile
int | NormalsNameAllocSize
int | NumberOfFieldDataInFile
char ** | FieldDataNameInFile
int | FieldDataNameAllocSize
vtkTimeStamp CharacteristicsTime
vtkCharArray * InputArray

Detailed Description

helper superclass for objects that read vtk data files.

Date:
2002/03/13 02:20:12
Revision:
1.69

vtkDataReader is a helper superclass that reads the vtk data file header, dataset type, and attribute data (point and cell attributes such as scalars, vectors, normals, etc.) from a vtk data file. See text for the format of the various vtk file types.

See also:
vtkPolyDataReader vtkStructuredPointsReader vtkStructuredGridReader vtkUnsutructuredGridReader vtkRectilinearGridReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (56%)
  • Martin, Ken (22%)
  • Lorensen, Bill (9%)

Definition at line 54 of file vtkDataReader.h.

Constructor & Destructor Documentation

vtkDataReader::vtkDataReader ( ) [protected]

vtkDataReader::~vtkDataReader ( ) [protected]

Member Function Documentation

vtkDataReader* vtkDataReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkDataObjectReader, vtkDataSetReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkStructuredGridReader, vtkStructuredPointsReader, and vtkUnstructuredGridReader.

vtkDataReader::vtkTypeRevisionMacro | ( | vtkDataReader | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataObjectReader, vtkDataSetReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkStructuredGridReader, vtkStructuredPointsReader, and vtkUnstructuredGridReader.

void vtkDataReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkDataObjectReader, vtkDataSetReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkStructuredGridReader, vtkStructuredPointsReader, and vtkUnstructuredGridReader.

virtual void vtkDataReader::SetFileName ( const char * ) [virtual]

Specify file name of vtk data file to read.

virtual char* vtkDataReader::GetFileName ( ) [virtual]

Specify file name of vtk data file to read.

int vtkDataReader::IsFileValid ( const char * dstype )

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

int vtkDataReader::IsFileStructuredPoints ( ) [inline]

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

Definition at line 71 of file vtkDataReader.h.

int vtkDataReader::IsFilePolyData ( ) [inline]

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

Definition at line 73 of file vtkDataReader.h.

int vtkDataReader::IsFileStructuredGrid ( ) [inline]

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

Definition at line 75 of file vtkDataReader.h.

int vtkDataReader::IsFileUnstructuredGrid ( ) [inline]

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

Definition at line 77 of file vtkDataReader.h.

int vtkDataReader::IsFileRectilinearGrid ( ) [inline]

Is the file a valid vtk file of the passed dataset type ? The dataset type is passed as a lower case string.

Definition at line 79 of file vtkDataReader.h.

void vtkDataReader::SetInputString ( const char * in )

Specify the InputString for use when reading from a character array. Optionally include the length for binary strings. Note that a copy of the string is made and stored. If this causes exceedingly large memory consumption, consider using InputArray instead.

virtual char* vtkDataReader::GetInputString ( ) [virtual]

Specify the InputString for use when reading from a character array. Optionally include the length for binary strings. Note that a copy of the string is made and stored. If this causes exceedingly large memory consumption, consider using InputArray instead.

void vtkDataReader::SetInputString | ( | const char * | in,
 |  | int | len
 | ) |

Specify the InputString for use when reading from a character array. Optionally include the length for binary strings. Note that a copy of the string is made and stored. If this causes exceedingly large memory consumption, consider using InputArray instead.

virtual int vtkDataReader::GetInputStringLength ( ) [virtual]

Specify the InputString for use when reading from a character array. Optionally include the length for binary strings. Note that a copy of the string is made and stored. If this causes exceedingly large memory consumption, consider using InputArray instead.

void vtkDataReader::SetBinaryInputString | ( | const char * | ,
 |  | int | len
 | ) |

Specify the InputString for use when reading from a character array. Optionally include the length for binary strings. Note that a copy of the string is made and stored. If this causes exceedingly large memory consumption, consider using InputArray instead.

virtual void vtkDataReader::SetInputArray ( vtkCharArray * ) [virtual]

Specify the vtkCharArray to be used when reading from a string. If set, this array has precendence over InputString. Use this instead of InputString to avoid the extra memory copy. It should be noted that if the underlying char* is owned by the user ( vtkCharArray::SetArray(array, 1); ) and is deleted before the reader, bad things will happen during a pipeline update.

virtual vtkCharArray* vtkDataReader::GetInputArray ( ) [virtual]

Specify the vtkCharArray to be used when reading from a string. If set, this array has precendence over InputString. Use this instead of InputString to avoid the extra memory copy. It should be noted that if the underlying char* is owned by the user ( vtkCharArray::SetArray(array, 1); ) and is deleted before the reader, bad things will happen during a pipeline update.

virtual char* vtkDataReader::GetHeader ( ) [virtual]

Get the header from the vtk data file.

virtual void vtkDataReader::SetReadFromInputString ( int ) [virtual]

Enable reading from an InputString or InputArray instead of the default, a file.

virtual int vtkDataReader::GetReadFromInputString ( ) [virtual]

Enable reading from an InputString or InputArray instead of the default, a file.

virtual void vtkDataReader::ReadFromInputStringOn ( ) [virtual]

Enable reading from an InputString or InputArray instead of the default, a file.

virtual void vtkDataReader::ReadFromInputStringOff ( ) [virtual]

Enable reading from an InputString or InputArray instead of the default, a file.

virtual int vtkDataReader::GetFileType ( ) [virtual]

Get the type of file (ASCII or BINARY). Returned value only valid after file has been read.

int vtkDataReader::GetNumberOfScalarsInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 130 of file vtkDataReader.h.

int vtkDataReader::GetNumberOfVectorsInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 132 of file vtkDataReader.h.

int vtkDataReader::GetNumberOfTensorsInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 134 of file vtkDataReader.h.

int vtkDataReader::GetNumberOfNormalsInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 136 of file vtkDataReader.h.

int vtkDataReader::GetNumberOfTCoordsInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 138 of file vtkDataReader.h.

int vtkDataReader::GetNumberOfFieldDataInFile ( ) [inline]

How many attributes of various types are in this file? This requires reading the file, so the filename must be set prior to invoking this operation. (Note: file characteristics are cached, so only a single read is necessary to return file characteristics.)

Definition at line 140 of file vtkDataReader.h.

const char* vtkDataReader::GetScalarsNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

const char* vtkDataReader::GetVectorsNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

const char* vtkDataReader::GetTensorsNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

const char* vtkDataReader::GetNormalsNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

const char* vtkDataReader::GetTCoordsNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

const char* vtkDataReader::GetFieldDataNameInFile ( int i )

What is the name of the ith attribute of a certain type in this file? This requires reading the file, so the filename must be set prior to invoking this operation.

virtual void vtkDataReader::SetScalarsName ( const char * ) [virtual]

Set the name of the scalar data to extract. If not specified, first scalar data encountered is extracted.

virtual char* vtkDataReader::GetScalarsName ( ) [virtual]

Set the name of the scalar data to extract. If not specified, first scalar data encountered is extracted.

virtual void vtkDataReader::SetVectorsName ( const char * ) [virtual]

Set the name of the vector data to extract. If not specified, first vector data encountered is extracted.

virtual char* vtkDataReader::GetVectorsName ( ) [virtual]

Set the name of the vector data to extract. If not specified, first vector data encountered is extracted.

virtual void vtkDataReader::SetTensorsName ( const char * ) [virtual]

Set the name of the tensor data to extract. If not specified, first tensor data encountered is extracted.

virtual char* vtkDataReader::GetTensorsName ( ) [virtual]

Set the name of the tensor data to extract. If not specified, first tensor data encountered is extracted.

virtual void vtkDataReader::SetNormalsName ( const char * ) [virtual]

Set the name of the normal data to extract. If not specified, first normal data encountered is extracted.

virtual char* vtkDataReader::GetNormalsName ( ) [virtual]

Set the name of the normal data to extract. If not specified, first normal data encountered is extracted.

virtual void vtkDataReader::SetTCoordsName ( const char * ) [virtual]

Set the name of the texture coordinate data to extract. If not specified, first texture coordinate data encountered is extracted.

virtual char* vtkDataReader::GetTCoordsName ( ) [virtual]

Set the name of the texture coordinate data to extract. If not specified, first texture coordinate data encountered is extracted.

virtual void vtkDataReader::SetLookupTableName ( const char * ) [virtual]

Set the name of the lookup table data to extract. If not specified, uses lookup table named by scalar. Otherwise, this specification supersedes.

virtual char* vtkDataReader::GetLookupTableName ( ) [virtual]

Set the name of the lookup table data to extract. If not specified, uses lookup table named by scalar. Otherwise, this specification supersedes.

virtual void vtkDataReader::SetFieldDataName ( const char * ) [virtual]

Set the name of the field data to extract. If not specified, uses first field data encountered in file.

virtual char* vtkDataReader::GetFieldDataName ( ) [virtual]

Set the name of the field data to extract. If not specified, uses first field data encountered in file.

int vtkDataReader::OpenVTKFile ( )

Open a vtk data file. Returns zero if error.

int vtkDataReader::ReadHeader ( )

Read the header of a vtk data file. Returns 0 if error.

int vtkDataReader::ReadCellData | ( | vtkDataSet * | ds,
 |  | int | numCells
 | ) |

Read the cell data of a vtk data file. The number of cells (from the dataset) must match the number of cells defined in cell attributes (unless no geometry was defined).

int vtkDataReader::ReadPointData | ( | vtkDataSet * | ds,
 |  | int | numPts
 | ) |

Read the point data of a vtk data file. The number of points (from the dataset) must match the number of points defined in point attributes (unless no geometry was defined).

int vtkDataReader::ReadPoints | ( | vtkPointSet * | ps,
 |  | int | numPts
 | ) |

Read point coordinates. Return 0 if error.

int vtkDataReader::ReadCells | ( | int | size,
 |  | int * | data
 | ) |

Read a bunch of "cells". Return 0 if error.

int vtkDataReader::ReadCells | ( | int | size,
 |  | int * | data,
 |  | int | skip1,
 |  | int | read2,
 |  | int | skip3
 | ) |

Read a piece of the cells (for streaming compliance)

int vtkDataReader::ReadCoordinates | ( | vtkRectilinearGrid * | rg,
 |  | int | axes,
 |  | int | numCoords
 | ) |

Read the coordinates for a rectilinear grid. The axes parameter specifies which coordinate axes (0,1,2) is being read.

vtkDataArray* vtkDataReader::ReadArray | ( | const char * | dataType,
 |  | int | numTuples,
 |  | int | numComp
 | ) |

Helper functions for reading data.

vtkFieldData* vtkDataReader::ReadFieldData ( )

Helper functions for reading data.

int vtkDataReader::Read ( char * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( unsigned char * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( short * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( unsigned short * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( int * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( unsigned int * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( long * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( unsigned long * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( float * )

Internal function to read in a value. Returns zero if there was an error.

int vtkDataReader::Read ( double * )

Internal function to read in a value. Returns zero if there was an error.

void vtkDataReader::CloseVTKFile ( )

Close the vtk file.

int vtkDataReader::ReadLine ( char result[256] )

Internal function to read in a line up to 256 characters. Returns zero if there was an error.

int vtkDataReader::ReadString ( char result[256] )

Internal function to read in a string up to 256 characters. Returns zero if there was an error.

char* vtkDataReader::LowerCase | ( | char * | str,
 |  | const size_t | len = 256
 | ) |

Helper method for reading in data.

istream* vtkDataReader::GetIStream ( ) [inline]

Return the istream being used to read in the data.

Definition at line 272 of file vtkDataReader.h.

virtual void vtkDataReader::SetScalarLut ( const char * ) [protected, virtual]

virtual char* vtkDataReader::GetScalarLut ( ) [protected, virtual]

int vtkDataReader::ReadScalarData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadVectorData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadNormalData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadTensorData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadCoScalarData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadLutData ( vtkDataSetAttributes * a ) [protected]

int vtkDataReader::ReadTCoordsData | ( | vtkDataSetAttributes * | a,
 |  | int | num
 | ) | [protected]

int vtkDataReader::ReadDataSetData ( vtkDataSet * ds ) [protected]

void vtkDataReader::InitializeCharacteristics ( ) [protected]

int vtkDataReader::CharacterizeFile ( ) [protected]

void vtkDataReader::CheckFor | ( | const char * | name,
 |  | char * | line,
 |  | int & | num,
 |  | char **& | array,
 |  | int & | allocSize
 | ) | [protected]

void vtkDataReader::DecodeArrayName | ( | char * | resname,
 |  | const char * | name
 | ) | [protected]

Decode the name of array. This method is the inverse of vtkWriter::EncodeName.

Member Data Documentation

char* vtkDataReader::FileName [protected]

Definition at line 279 of file vtkDataReader.h.

int vtkDataReader::FileType [protected]

Definition at line 280 of file vtkDataReader.h.

istream* vtkDataReader::IS [protected]

Definition at line 281 of file vtkDataReader.h.

char* vtkDataReader::ScalarsName [protected]

Definition at line 283 of file vtkDataReader.h.

char* vtkDataReader::VectorsName [protected]

Definition at line 284 of file vtkDataReader.h.

char* vtkDataReader::TensorsName [protected]

Definition at line 285 of file vtkDataReader.h.

char* vtkDataReader::TCoordsName [protected]

Definition at line 286 of file vtkDataReader.h.

char* vtkDataReader::NormalsName [protected]

Definition at line 287 of file vtkDataReader.h.

char* vtkDataReader::LookupTableName [protected]

Definition at line 288 of file vtkDataReader.h.

char* vtkDataReader::FieldDataName [protected]

Definition at line 289 of file vtkDataReader.h.

char* vtkDataReader::ScalarLut [protected]

Definition at line 290 of file vtkDataReader.h.

int vtkDataReader::ReadFromInputString [protected]

Definition at line 292 of file vtkDataReader.h.

char* vtkDataReader::InputString [protected]

Definition at line 293 of file vtkDataReader.h.

int vtkDataReader::InputStringLength [protected]

Definition at line 294 of file vtkDataReader.h.

int vtkDataReader::InputStringPos [protected]

Definition at line 295 of file vtkDataReader.h.

char* vtkDataReader::Header [protected]

Definition at line 300 of file vtkDataReader.h.

int vtkDataReader::NumberOfScalarsInFile [protected]

Definition at line 313 of file vtkDataReader.h.

char** vtkDataReader::ScalarsNameInFile [protected]

Definition at line 314 of file vtkDataReader.h.

int vtkDataReader::ScalarsNameAllocSize [protected]

Definition at line 315 of file vtkDataReader.h.

int vtkDataReader::NumberOfVectorsInFile [protected]

Definition at line 316 of file vtkDataReader.h.

char** vtkDataReader::VectorsNameInFile [protected]

Definition at line 317 of file vtkDataReader.h.

int vtkDataReader::VectorsNameAllocSize [protected]

Definition at line 318 of file vtkDataReader.h.

int vtkDataReader::NumberOfTensorsInFile [protected]

Definition at line 319 of file vtkDataReader.h.

char** vtkDataReader::TensorsNameInFile [protected]

Definition at line 320 of file vtkDataReader.h.

int vtkDataReader::TensorsNameAllocSize [protected]

Definition at line 321 of file vtkDataReader.h.

int vtkDataReader::NumberOfTCoordsInFile [protected]

Definition at line 322 of file vtkDataReader.h.

char** vtkDataReader::TCoordsNameInFile [protected]

Definition at line 323 of file vtkDataReader.h.

int vtkDataReader::TCoordsNameAllocSize [protected]

Definition at line 324 of file vtkDataReader.h.

int vtkDataReader::NumberOfNormalsInFile [protected]

Definition at line 325 of file vtkDataReader.h.

char** vtkDataReader::NormalsNameInFile [protected]

Definition at line 326 of file vtkDataReader.h.

int vtkDataReader::NormalsNameAllocSize [protected]

Definition at line 327 of file vtkDataReader.h.

int vtkDataReader::NumberOfFieldDataInFile [protected]

Definition at line 328 of file vtkDataReader.h.

char** vtkDataReader::FieldDataNameInFile [protected]

Definition at line 329 of file vtkDataReader.h.

int vtkDataReader::FieldDataNameAllocSize [protected]

Definition at line 330 of file vtkDataReader.h.

vtkTimeStamp vtkDataReader::CharacteristicsTime [protected]

Definition at line 331 of file vtkDataReader.h.

vtkCharArray* vtkDataReader::InputArray [protected]

Definition at line 338 of file vtkDataReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkDataReader.h
Generated on Mon Mar 25 01:16:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSet Class Reference

abstract class to specify dataset behavior. More...

#include <vtkDataSet.h>

Inheritance diagram for vtkDataSet:

[legend]
Collaboration diagram for vtkDataSet:

[legend]
List of all members.

Public Types

enum | FieldDataType { DATA_OBJECT_FIELD = 0, POINT_DATA_FIELD = 1, CELL_DATA_FIELD = 2 }

Public Methods

vtkTypeRevisionMacro (vtkDataSet, vtkDataObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | CopyStructure (vtkDataSet *ds)=0
virtual vtkIdType | GetNumberOfPoints ()=0
virtual vtkIdType | GetNumberOfCells ()=0
virtual float * | GetPoint (vtkIdType ptId)=0
virtual void | GetPoint (vtkIdType id, float x[3])
virtual vtkCell * | GetCell (vtkIdType cellId)=0
virtual void | GetCell (vtkIdType cellId, vtkGenericCell *cell)=0
virtual void | GetCellBounds (vtkIdType cellId, float bounds[6])
virtual int | GetCellType (vtkIdType cellId)=0
virtual void | GetCellTypes (vtkCellTypes *types)
virtual void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)=0
virtual void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)=0
unsigned long int | GetMTime ()
vtkCellData * GetCellData ()
vtkPointData * GetPointData ()
virtual void | Squeeze ()
virtual void | ComputeBounds ()
float * | GetBounds ()
void | GetBounds (float bounds[6])
float * | GetCenter ()
void | GetCenter (float center[3])
float | GetLength ()
void | Initialize ()
virtual void | GetScalarRange (float range[2])
float * | GetScalarRange ()
virtual int | GetMaxCellSize ()=0
unsigned long | GetActualMemorySize ()
int | CheckAttributes ()
virtual void | GetCellNeighbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds)
vtkIdType | FindPoint (float x, float y, float z)
virtual vtkIdType | FindPoint (float x[3])=0
virtual vtkIdType | FindCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)=0
virtual vtkIdType | FindCell (float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)=0
virtual vtkCell * | FindAndGetCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
int | GetDataObjectType ()
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)

Protected Methods

vtkDataSet ()
~vtkDataSet ()

Protected Attributes

vtkCellData * CellData
vtkPointData * PointData
vtkTimeStamp ComputeTime
float | Bounds [6]
float | ScalarRange [2]
float | Center [3]

Detailed Description

abstract class to specify dataset behavior.

Date:
2002/01/22 15:25:17
Revision:
1.112

vtkDataSet is an abstract class that specifies an interface for dataset objects. vtkDataSet also provides methods to provide informations about the data, such as center, bounding box, and representative length.

In vtk a dataset consists of a structure (geometry and topology) and attribute data. The structure is defined implicitly or explicitly as a collection of cells. The geometry of the structure is contained in point coordinates plus the cell interpolation functions. The topology of the dataset structure is defined by cell types and how the cells share their defining points.

Attribute data in vtk is either point data (data at points) or cell data (data at cells). Typically filters operate on point data, but some may operate on cell data, both cell and point data, either one, or none.

See also:
vtkPointSet vtkStructuredPoints vtkStructuredGrid vtkUnstructuredGrid vtkRectilinearGrid vtkPolyData vtkPointData vtkCellData vtkDataObject vtkField
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (54%)
  • Martin, Ken (14%)
  • Law, Charles (12%)
Examples:
vtkDataSet (Examples)

Definition at line 63 of file vtkDataSet.h.

Member Enumeration Documentation

enum vtkDataSet::FieldDataType

Enumeration values:
DATA_OBJECT_FIELD
POINT_DATA_FIELD
CELL_DATA_FIELD

Definition at line 277 of file vtkDataSet.h.

Constructor & Destructor Documentation

vtkDataSet::vtkDataSet ( ) [protected]

vtkDataSet::~vtkDataSet ( ) [protected]

Member Function Documentation

vtkDataSet::vtkTypeRevisionMacro | ( | vtkDataSet | ,
 |  | vtkDataObject |
 | ) |

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, vtkUnstructuredGrid, and vtkImageCanvasSource2D.

void vtkDataSet::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkUnstructuredGrid, and vtkImageCanvasSource2D.

virtual void vtkDataSet::CopyStructure ( vtkDataSet * ds ) [pure virtual]

Copy the geometric and topological structure of an object. Note that the invoking object and the object pointed to by the parameter ds must be of the same type. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual vtkIdType vtkDataSet::GetNumberOfPoints ( ) [pure virtual]

Determine the number of points composing the dataset. THIS METHOD IS THREAD SAFE

Reimplemented in vtkImageData, vtkPointSet, vtkRectilinearGrid, and vtkStructuredGrid.

virtual vtkIdType vtkDataSet::GetNumberOfCells ( ) [pure virtual]

Determine the number of cells composing the dataset. THIS METHOD IS THREAD SAFE

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual float* vtkDataSet::GetPoint ( vtkIdType ptId ) [pure virtual]

Get point coordinates with ptId such that: 0 <= ptId < NumberOfPoints. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, vtkPointSet, vtkRectilinearGrid, and vtkStructuredGrid.

Referenced by GetPoint().

void vtkDataSet::GetPoint | ( | vtkIdType | ptId,
 |  | float | p[3]
 | ) | [inline, virtual]

Copy point coordinates into user provided array x[3] for specified point id. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPointSet, vtkRectilinearGrid, and vtkStructuredGrid.

Definition at line 312 of file vtkDataSet.h.

virtual vtkCell* vtkDataSet::GetCell ( vtkIdType cellId ) [pure virtual]

Get cell with cellId such that: 0 <= cellId < NumberOfCells. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [pure virtual]

Get cell with cellId such that: 0 <= cellId < NumberOfCells. This is a thread-safe alternative to the previous GetCell() method. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Get the bounds of the cell with cellId such that: 0 <= cellId < NumberOfCells. A subclass may be able to determine the bounds of cell without using an expensive GetCell() method. A default implementation is provided that actually uses a GetCell() call. This is to ensure the method is available to all datasets. Subclasses should override this method to provide an efficient implementation. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual int vtkDataSet::GetCellType ( vtkIdType cellId ) [pure virtual]

Get type of cell with cellId such that: 0 <= cellId < NumberOfCells. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetCellTypes ( vtkCellTypes * types ) [virtual]

Get a list of types of cells in a dataset. The list consists of an array of types (not necessarily in any order), with a single entry per type. For example a dataset 5 triangles, 3 lines, and 100 hexahedra would result a list of three entries, corresponding to the types VTK_TRIANGLE, VTK_LINE, and VTK_HEXAHEDRON. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

virtual void vtkDataSet::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [pure virtual]

Topological inquiry to get points defining cell. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [pure virtual]

Topological inquiry to get cells using point. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetCellNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Topological inquiry to get all cells using list of points exclusive of cell specified (e.g., cellId). Note that the list consists of only cells that use ALL the points provided. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

Referenced by vtkUnstructuredGrid::Locations(), and vtkRectilinearGrid::PointReturn().

vtkIdType vtkDataSet::FindPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Locate the closest point to the global coordinate x. Return the point id. If point id < 0; then no point found. (This may arise when point is outside of dataset.) THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPointSet, and vtkRectilinearGrid.

Definition at line 149 of file vtkDataSet.h.

Referenced by vtkRectilinearGrid::FindPoint(), vtkPointSet::FindPoint(), and vtkImageData::FindPoint().

virtual vtkIdType vtkDataSet::FindPoint ( float x[3] ) [pure virtual]

Locate the closest point to the global coordinate x. Return the point id. If point id < 0; then no point found. (This may arise when point is outside of dataset.) THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPointSet, and vtkRectilinearGrid.

virtual vtkIdType vtkDataSet::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [pure virtual]

Locate cell based on global coordinate x and tolerance squared. If cell and cellId is non-NULL, then search starts from this cell and looks at immediate neighbors. Returns cellId >= 0 if inside, < 0 otherwise. The parametric coordinates are provided in pcoords[3]. The interpolation weights are returned in weights[]. (The number of weights is equal to the number of points in the found cell). Tolerance is used to control how close the point is to be considered "in" the cell. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, vtkPointSet, and vtkRectilinearGrid.

virtual vtkIdType vtkDataSet::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkGenericCell * | gencell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [pure virtual]

This is a version of the above method that can be used with multithreaded applications. A vtkGenericCell must be passed in to be used in internal calls that might be made to GetCell() THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkImageData, vtkPointSet, and vtkRectilinearGrid.

virtual vtkCell* vtkDataSet::FindAndGetCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Locate the cell that contains a point and return the cell. Also returns the subcell id, parametric coordinates and weights for subsequent interpolation. This method combines the derived class methods int FindCell and vtkCell *GetCell. Derived classes may provide a more efficient implementation. See for example vtkStructuredPoints. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, and vtkRectilinearGrid.

unsigned long int vtkDataSet::GetMTime ( ) [virtual]

Datasets are composite objects and need to check each part for MTime THIS METHOD IS THREAD SAFE

Reimplemented from vtkDataObject.

Reimplemented in vtkPointSet.

vtkCellData* vtkDataSet::GetCellData ( ) [inline]

return pointer to this dataset's point data THIS METHOD IS THREAD SAFE

Definition at line 202 of file vtkDataSet.h.

vtkPointData* vtkDataSet::GetPointData ( ) [inline]

return pointer to this dataset's point data THIS METHOD IS THREAD SAFE

Definition at line 206 of file vtkDataSet.h.

virtual void vtkDataSet::Squeeze ( ) [virtual]

Reclaim any extra memory used to store data. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkPointSet, vtkPolyData, and vtkUnstructuredGrid.

virtual void vtkDataSet::ComputeBounds ( ) [virtual]

Compute the data bounding box from data points. THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, and vtkRectilinearGrid.

float* vtkDataSet::GetBounds ( )

Return a pointer to the geometry bounding box in the form (xmin,xmax, ymin,ymax, zmin,zmax). THIS METHOD IS NOT THREAD SAFE.

void vtkDataSet::GetBounds ( float bounds[6] )

Return a pointer to the geometry bounding box in the form (xmin,xmax, ymin,ymax, zmin,zmax). THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

float* vtkDataSet::GetCenter ( )

Get the center of the bounding box. THIS METHOD IS NOT THREAD SAFE.

void vtkDataSet::GetCenter ( float center[3] )

Get the center of the bounding box. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

float vtkDataSet::GetLength ( )

Return the length of the diagonal of the bounding box. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

void vtkDataSet::Initialize ( ) [virtual]

Restore data object to initial state, THIS METHOD IS NOT THREAD SAFE.

Reimplemented from vtkDataObject.

Reimplemented in vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

virtual void vtkDataSet::GetScalarRange ( float range[2] ) [virtual]

Convenience method to get the range of the scalar data (if there is any scalar data). Returns the (min/max) range of combined point and cell data. If there are no point or cell scalars the method will return (0,1). Note: Update needs to be called to create the scalars. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented in vtkStructuredGrid.

float* vtkDataSet::GetScalarRange ( )

Convenience method to get the range of the scalar data (if there is any scalar data). THIS METHOD IS NOT THREAD SAFE.

Reimplemented in vtkStructuredGrid.

Referenced by vtkStructuredGrid::GetScalarRange().

virtual int vtkDataSet::GetMaxCellSize ( ) [pure virtual]

Convenience method returns largest cell size in dataset. This is generally used to allocate memory for supporting data structures. THIS METHOD IS THREAD SAFE

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

unsigned long vtkDataSet::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

int vtkDataSet::GetDataObjectType ( ) [inline, virtual]

Return the type of data object.

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, vtkStructuredPoints, and vtkUnstructuredGrid.

Definition at line 266 of file vtkDataSet.h.

void vtkDataSet::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkDataSet::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataObject.

Reimplemented in vtkImageData, vtkPointSet, vtkPolyData, vtkRectilinearGrid, vtkStructuredGrid, and vtkUnstructuredGrid.

int vtkDataSet::CheckAttributes ( )

This method checks to see if the cell and point attributes match the geometry. Many filters will crash if the number of tupples in an array is less than the number of points/cells. This method returns 1 if there is a mismatch, and 0 if everything is ok. It prints an error if an array is too short, and a warning if an array is too long.

Member Data Documentation

vtkCellData* vtkDataSet::CellData [protected]

Definition at line 298 of file vtkDataSet.h.

vtkPointData* vtkDataSet::PointData [protected]

Definition at line 299 of file vtkDataSet.h.

vtkTimeStamp vtkDataSet::ComputeTime [protected]

Definition at line 300 of file vtkDataSet.h.

float vtkDataSet::Bounds[6] [protected]

Definition at line 301 of file vtkDataSet.h.

float vtkDataSet::ScalarRange[2] [protected]

Definition at line 302 of file vtkDataSet.h.

float vtkDataSet::Center[3] [protected]

Definition at line 303 of file vtkDataSet.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataSet.h
Generated on Mon Mar 25 01:16:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetAttributes Class Reference

represent and manipulate attribute data in a dataset. More...

#include <vtkDataSetAttributes.h>

Inheritance diagram for vtkDataSetAttributes:

[legend]
Collaboration diagram for vtkDataSetAttributes:

[legend]
List of all members.

Public Types

enum AttributeTypes {
SCALARS = 0, VECTORS = 1, NORMALS = 2, TCOORDS = 3,
TENSORS = 4, NUM_ATTRIBUTES
}
enum | AttributeLimitTypes { MAX, EXACT, NOLIMIT }

Public Methods

vtkTypeRevisionMacro (vtkDataSetAttributes, vtkFieldData)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
virtual void | Update ()
virtual void | PassData (vtkFieldData *fd)
void | CopyData (vtkDataSetAttributes *fromPd, vtkIdType fromId, vtkIdType toId)
virtual void | DeepCopy (vtkFieldData *pd)
virtual void | ShallowCopy (vtkFieldData *pd)
int | SetActiveAttribute (const char *name, int attributeType)
int | SetActiveAttribute (int index, int attributeType)
void | SetCopyAttribute (int index, int value)
virtual void | CopyAllOn ()
virtual void | CopyAllOff ()
void | GetAttributeIndices (int *indexArray)
int | IsArrayAnAttribute (int idx)
vtkDataArray * | GetAttribute (int attributeType)
virtual void | RemoveArray (const char *name)
void | CopyAllocate (vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
void | InterpolateAllocate (vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
void | InterpolatePoint (vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdList *ids, float *weights)
void | InterpolateEdge (vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdType p1, vtkIdType p2, float t)
void | InterpolateTime (vtkDataSetAttributes *from1, vtkDataSetAttributes *from2, vtkIdType id, float t)
int | SetScalars (vtkDataArray *da)
int | SetActiveScalars (const char *name)
vtkDataArray * GetScalars ()
int | SetVectors (vtkDataArray *da)
int | SetActiveVectors (const char *name)
vtkDataArray * GetVectors ()
int | SetNormals (vtkDataArray *da)
int | SetActiveNormals (const char *name)
vtkDataArray * GetNormals ()
int | SetTCoords (vtkDataArray *da)
int | SetActiveTCoords (const char *name)
vtkDataArray * GetTCoords ()
int | SetTensors (vtkDataArray *da)
int | SetActiveTensors (const char *name)
vtkDataArray * GetTensors ()
vtkDataArray * | GetScalars (const char *name)
vtkDataArray * | GetVectors (const char *name)
vtkDataArray * | GetNormals (const char *name)
vtkDataArray * | GetTCoords (const char *name)
vtkDataArray * | GetTensors (const char *name)
void | SetCopyScalars (int i)
int | GetCopyScalars ()
virtual void | CopyScalarsOn ()
virtual void | CopyScalarsOff ()
void | SetCopyVectors (int i)
int | GetCopyVectors ()
virtual void | CopyVectorsOn ()
virtual void | CopyVectorsOff ()
void | SetCopyNormals (int i)
int | GetCopyNormals ()
virtual void | CopyNormalsOn ()
virtual void | CopyNormalsOff ()
void | SetCopyTCoords (int i)
int | GetCopyTCoords ()
virtual void | CopyTCoordsOn ()
virtual void | CopyTCoordsOff ()
void | SetCopyTensors (int i)
int | GetCopyTensors ()
virtual void | CopyTensorsOn ()
virtual void | CopyTensorsOff ()
void | CopyTuple (vtkDataArray *fromData, vtkDataArray *toData, vtkIdType fromId, vtkIdType toId)
void | CopyAllocate (vtkDataSetAttributes::FieldList &list, vtkIdType sze=0, vtkIdType ext=1000)
void | CopyData (vtkDataSetAttributes::FieldList &list, vtkDataSetAttributes *dsa, int idx, vtkIdType fromId, vtkIdType toId)

Static Public Methods

vtkDataSetAttributes * | New ()
const char * | GetAttributeTypeAsString (int attributeType)

Protected Methods

vtkDataSetAttributes ()
~vtkDataSetAttributes ()
void | InterpolateTuple (vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdList *ptIds, float *weights)
void | InterpolateTuple (vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdType id1, vtkIdType id2, float t)
void | InterpolateTuple (vtkDataArray *fromData1, vtkDataArray *fromData2, vtkDataArray *toData, vtkIdType id, float t)
virtual void | InitializeFields ()
virtual void | RemoveArray (int index)

Protected Attributes

int | AttributeIndices [NUM_ATTRIBUTES]
int | CopyAttributeFlags [NUM_ATTRIBUTES]
vtkFieldData::BasicIterator RequiredArrays
int * | TargetIndices

Static Protected Attributes

const int | NumberOfAttributeComponents [NUM_ATTRIBUTES]
const int | AttributeLimits [NUM_ATTRIBUTES]
const char | AttributeNames [NUM_ATTRIBUTES][10]

Friends

class | vtkDataSetAttributes::FieldList

Detailed Description

represent and manipulate attribute data in a dataset.

Date:
2002/02/13 22:44:37
Revision:
1.51

vtkDataSetAttributes is a class that is used to represent and manipulate attribute data (e.g., scalars, vectors, normals, texture coordinates, tensors, and field data) Special methods are provided to work with filter objects, such as passing data through filter, copying data from one attribute set to another, and interpolating data given cell interpolation weights.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Geveci, Berk (48%)
  • Schroeder, Will (31%)
  • Miller, Jim (5%)
Examples:
vtkDataSetAttributes (Examples)
Tests:
vtkDataSetAttributes (Tests)

Definition at line 50 of file vtkDataSetAttributes.h.

Member Enumeration Documentation

enum vtkDataSetAttributes::AttributeTypes

Enumeration values:
SCALARS
VECTORS
NORMALS
TCOORDS
TENSORS
NUM_ATTRIBUTES

Definition at line 308 of file vtkDataSetAttributes.h.

enum vtkDataSetAttributes::AttributeLimitTypes

Enumeration values:
MAX
EXACT
NOLIMIT

Definition at line 318 of file vtkDataSetAttributes.h.

Constructor & Destructor Documentation

vtkDataSetAttributes::vtkDataSetAttributes ( ) [protected]

vtkDataSetAttributes::~vtkDataSetAttributes ( ) [protected]

Member Function Documentation

vtkDataSetAttributes* vtkDataSetAttributes::New ( ) [static]

Construct object with copying turned on for all data.

Reimplemented from vtkFieldData.

Reimplemented in vtkCellData, and vtkPointData.

vtkDataSetAttributes::vtkTypeRevisionMacro | ( | vtkDataSetAttributes | ,
 |  | vtkFieldData |
 | ) |

Reimplemented from vtkFieldData.

Reimplemented in vtkCellData, and vtkPointData.

void vtkDataSetAttributes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkFieldData.

Reimplemented in vtkCellData, and vtkPointData.

virtual void vtkDataSetAttributes::Initialize ( ) [virtual]

Initialize all of the object's data to NULL Also, clear the copy flags.

Reimplemented from vtkFieldData.

virtual void vtkDataSetAttributes::Update ( ) [inline, virtual]

Attributes have a chance to bring themselves up to date; right now this is ignored.

Definition at line 65 of file vtkDataSetAttributes.h.

virtual void vtkDataSetAttributes::PassData ( vtkFieldData * fd ) [virtual]

Pass entire arrays of input data through to output. Obey the "copy" flags. When passing a field, the following copying rules are followed: 1) Check if a field is an attribute, if yes and if there is a copy flag for that attribute (on or off), obey the flag for that attribute, ignore (2) and (3), 2) if there is a copy field for that field (on or off), obey the flag, ignore (3) 3) obey CopyAllOn/Off

Reimplemented from vtkFieldData.

void vtkDataSetAttributes::CopyAllocate | ( | vtkDataSetAttributes * | pd,
 |  | vtkIdType | sze = 0,
 |  | vtkIdType | ext = 1000
 | ) |

Allocates point data for point-by-point (or cell-by-cell) copy operation. If sze=0, then use the input DataSetAttributes to create (i.e., find initial size of) new objects; otherwise use the sze variable. Note that pd HAS to be the vtkDataSetAttributes object which will later be used with CopyData. If this is not the case, consider using the alternative forms of CopyAllocate and CopyData. ext is no longer used.

void vtkDataSetAttributes::CopyData | ( | vtkDataSetAttributes * | fromPd,
 |  | vtkIdType | fromId,
 |  | vtkIdType | toId
 | ) |

Copy the attribute data from one id to another. Make sure CopyAllocate() has been invoked before using this method. When copying a field, the following copying rules are followed: 1) Check if a field is an attribute, if yes and if there is a copy flag for that attribute (on or off), obey the flag for that attribute, ignore (2) and (3), 2) if there is a copy field for that field (on or off), obey the flag, ignore (3) 3) obey CopyAllOn/Off

void vtkDataSetAttributes::InterpolateAllocate | ( | vtkDataSetAttributes * | pd,
 |  | vtkIdType | sze = 0,
 |  | vtkIdType | ext = 1000
 | ) |

Initialize point interpolation method. Note that pd HAS to be the vtkDataSetAttributes object which will later be used with InterpolatePoint or InterpolateEdge. ext is no longer used.

void vtkDataSetAttributes::InterpolatePoint | ( | vtkDataSetAttributes * | fromPd,
 |  | vtkIdType | toId,
 |  | vtkIdList * | ids,
 |  | float * | weights
 | ) |

Interpolate data set attributes from other data set attributes given cell or point ids and associated interpolation weights.

void vtkDataSetAttributes::InterpolateEdge | ( | vtkDataSetAttributes * | fromPd,
 |  | vtkIdType | toId,
 |  | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | float | t
 | ) |

Interpolate data from the two points p1,p2 (forming an edge) and an interpolation factor, t, along the edge. The weight ranges from (0,1), with t=0 located at p1. Make sure that the method InterpolateAllocate() has been invoked before using this method.

void vtkDataSetAttributes::InterpolateTime | ( | vtkDataSetAttributes * | from1,
 |  | vtkDataSetAttributes * | from2,
 |  | vtkIdType | id,
 |  | float | t
 | ) |

Interpolate data from the same id (point or cell) at different points in time (parameter t). Two input data set attributes objects are input. The parameter t lies between (0<=t<=1). IMPORTANT: it is assumed that the number of attributes and number of components is the same for both from1 and from2, and the type of data for from1 and from2 are the same. Make sure that the method InterpolateAllocate() has been invoked before using this method.

virtual void vtkDataSetAttributes::DeepCopy ( vtkFieldData * pd ) [virtual]

Deep copy of data (i.e., create new data arrays and copy from input data).

Reimplemented from vtkFieldData.

virtual void vtkDataSetAttributes::ShallowCopy ( vtkFieldData * pd ) [virtual]

Shallow copy of data (i.e., use reference counting).

Reimplemented from vtkFieldData.

int vtkDataSetAttributes::SetScalars ( vtkDataArray * da )

Set/Get the scalar data.

int vtkDataSetAttributes::SetActiveScalars ( const char * name )

Set/Get the scalar data.

vtkDataArray* vtkDataSetAttributes::GetScalars ( )

Set/Get the scalar data.

int vtkDataSetAttributes::SetVectors ( vtkDataArray * da )

Set/Get the vector data.

int vtkDataSetAttributes::SetActiveVectors ( const char * name )

Set/Get the vector data.

vtkDataArray* vtkDataSetAttributes::GetVectors ( )

Set/Get the vector data.

int vtkDataSetAttributes::SetNormals ( vtkDataArray * da )

Set/get the normal data.

int vtkDataSetAttributes::SetActiveNormals ( const char * name )

Set/get the normal data.

vtkDataArray* vtkDataSetAttributes::GetNormals ( )

Set/get the normal data.

int vtkDataSetAttributes::SetTCoords ( vtkDataArray * da )

Set/Get the texture coordinate data.

int vtkDataSetAttributes::SetActiveTCoords ( const char * name )

Set/Get the texture coordinate data.

vtkDataArray* vtkDataSetAttributes::GetTCoords ( )

Set/Get the texture coordinate data.

int vtkDataSetAttributes::SetTensors ( vtkDataArray * da )

Set/Get the tensor data.

int vtkDataSetAttributes::SetActiveTensors ( const char * name )

Set/Get the tensor data.

vtkDataArray* vtkDataSetAttributes::GetTensors ( )

Set/Get the tensor data.

vtkDataArray* vtkDataSetAttributes::GetScalars ( const char * name )

This will first look for an array with the correct name. If one exists, it is returned. Otherwise, the name argument is ignored, and the active attribute is returned.

vtkDataArray* vtkDataSetAttributes::GetVectors ( const char * name )

This will first look for an array with the correct name. If one exists, it is returned. Otherwise, the name argument is ignored, and the active attribute is returned.

vtkDataArray* vtkDataSetAttributes::GetNormals ( const char * name )

This will first look for an array with the correct name. If one exists, it is returned. Otherwise, the name argument is ignored, and the active attribute is returned.

vtkDataArray* vtkDataSetAttributes::GetTCoords ( const char * name )

This will first look for an array with the correct name. If one exists, it is returned. Otherwise, the name argument is ignored, and the active attribute is returned.

vtkDataArray* vtkDataSetAttributes::GetTensors ( const char * name )

This will first look for an array with the correct name. If one exists, it is returned. Otherwise, the name argument is ignored, and the active attribute is returned.

int vtkDataSetAttributes::SetActiveAttribute | ( | const char * | name,
 |  | int | attributeType
 | ) |

Make the array with the given name the active attribute. Attribute types are: vtkDataSetAttributes::SCALARS = 0 vtkDataSetAttributes::VECTORS = 1 vtkDataSetAttributes::NORMALS = 2 vtkDataSetAttributes::TCOORDS = 3 vtkDataSetAttributes::TENSORS = 4 Returns the index of the array if succesful, -1 if the array is not in the list of arrays.

int vtkDataSetAttributes::SetActiveAttribute | ( | int | index,
 |  | int | attributeType
 | ) |

Make the array with the given index the active attribute.

void vtkDataSetAttributes::SetCopyAttribute | ( | int | index,
 |  | int | value
 | ) |

Specify whether to copy the data attribute referred to by index i.

void vtkDataSetAttributes::SetCopyScalars ( int i )

Turn on/off the copying of scalar data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

int vtkDataSetAttributes::GetCopyScalars ( )

Turn on/off the copying of scalar data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyScalarsOn ( ) [virtual]

Turn on/off the copying of scalar data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyScalarsOff ( ) [virtual]

Turn on/off the copying of scalar data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

void vtkDataSetAttributes::SetCopyVectors ( int i )

Turn on/off the copying of vector data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

int vtkDataSetAttributes::GetCopyVectors ( )

Turn on/off the copying of vector data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyVectorsOn ( ) [virtual]

Turn on/off the copying of vector data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyVectorsOff ( ) [virtual]

Turn on/off the copying of vector data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

void vtkDataSetAttributes::SetCopyNormals ( int i )

Turn on/off the copying of normals data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

int vtkDataSetAttributes::GetCopyNormals ( )

Turn on/off the copying of normals data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyNormalsOn ( ) [virtual]

Turn on/off the copying of normals data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyNormalsOff ( ) [virtual]

Turn on/off the copying of normals data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

void vtkDataSetAttributes::SetCopyTCoords ( int i )

Turn on/off the copying of texture coordinates data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

int vtkDataSetAttributes::GetCopyTCoords ( )

Turn on/off the copying of texture coordinates data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyTCoordsOn ( ) [virtual]

Turn on/off the copying of texture coordinates data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyTCoordsOff ( ) [virtual]

Turn on/off the copying of texture coordinates data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

void vtkDataSetAttributes::SetCopyTensors ( int i )

Turn on/off the copying of tensor data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

int vtkDataSetAttributes::GetCopyTensors ( )

Turn on/off the copying of tensor data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyTensorsOn ( ) [virtual]

Turn on/off the copying of tensor data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyTensorsOff ( ) [virtual]

Turn on/off the copying of tensor data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkDataSetAttributes::CopyAllOn ( ) [virtual]

Turn on copying of all data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Reimplemented from vtkFieldData.

virtual void vtkDataSetAttributes::CopyAllOff ( ) [virtual]

Turn off copying of all data. During the copy/pass, the following rules are followed for each array: 1. If the copy flag for an attribute is set (on or off), it is applied. This overrides rules 2 and 3. 2. If the copy flag for an array is set (on or off), it is applied This overrides rule 3. 3. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Reimplemented from vtkFieldData.

void vtkDataSetAttributes::CopyTuple | ( | vtkDataArray * | fromData,
 |  | vtkDataArray * | toData,
 |  | vtkIdType | fromId,
 |  | vtkIdType | toId
 | ) |

Copy a tuple of data from one data array to another. This method (and following ones) assume that the fromData and toData objects are of the same type, and have the same number of components. This is true if you invoke CopyAllocate() or InterpolateAllocate().

void vtkDataSetAttributes::GetAttributeIndices ( int * indexArray )

Get the field data array indices corresponding to scalars, vectors, tensors, etc.

int vtkDataSetAttributes::IsArrayAnAttribute ( int idx )

Determine whether a data array of index idx is considered a data set attribute (i.e., scalar, vector, tensor, etc). Return less-than zero if it is, otherwise an index 0<=idx<NUM_ATTRIBUTES to indicate which attribute.

vtkDataArray* vtkDataSetAttributes::GetAttribute ( int attributeType )

Return an attribute given the attribute type (see vtkDataSetAttributes::AttributeTypes).

virtual void vtkDataSetAttributes::RemoveArray ( const char * name ) [virtual]

Remove an array (with the given name) from the list of arrays.

Reimplemented from vtkFieldData.

const char* vtkDataSetAttributes::GetAttributeTypeAsString ( int attributeType ) [static]

Given an integer attribute type, this static method returns a string type for the attribute (i.e. type = 0: returns "Scalars").

void vtkDataSetAttributes::CopyAllocate | ( | vtkDataSetAttributes::FieldList & | list,
 |  | vtkIdType | sze = 0,
 |  | vtkIdType | ext = 1000
 | ) |

A special form of CopyAllocate() to be used with FieldLists. Use it when you are copying data from a set of vtkDataSetAttributes.

void vtkDataSetAttributes::CopyData | ( | vtkDataSetAttributes::FieldList & | list,
 |  | vtkDataSetAttributes * | dsa,
 |  | int | idx,
 |  | vtkIdType | fromId,
 |  | vtkIdType | toId
 | ) |

A special form of CopyData() to be used with FieldLists. Use it when you are copying data from a set of vtkDataSetAttributes. Make sure that you have called the special form of CopyAllocate that accepts FieldLists.

void vtkDataSetAttributes::InterpolateTuple | ( | vtkDataArray * | fromData,
 |  | vtkDataArray * | toData,
 |  | vtkIdType | toId,
 |  | vtkIdList * | ptIds,
 |  | float * | weights
 | ) | [protected]

void vtkDataSetAttributes::InterpolateTuple | ( | vtkDataArray * | fromData,
 |  | vtkDataArray * | toData,
 |  | vtkIdType | toId,
 |  | vtkIdType | id1,
 |  | vtkIdType | id2,
 |  | float | t
 | ) | [protected]

void vtkDataSetAttributes::InterpolateTuple | ( | vtkDataArray * | fromData1,
 |  | vtkDataArray * | fromData2,
 |  | vtkDataArray * | toData,
 |  | vtkIdType | id,
 |  | float | t
 | ) | [protected]

virtual void vtkDataSetAttributes::InitializeFields ( ) [protected, virtual]

Initialize all of the object's data to NULL

Reimplemented from vtkFieldData.

virtual void vtkDataSetAttributes::RemoveArray ( int index ) [protected, virtual]

Reimplemented from vtkFieldData.

Friends And Related Function Documentation

friend class vtkDataSetAttributes::FieldList [friend]

Definition at line 344 of file vtkDataSetAttributes.h.

Member Data Documentation

int vtkDataSetAttributes::AttributeIndices[NUM_ATTRIBUTES] [protected]

Definition at line 362 of file vtkDataSetAttributes.h.

int vtkDataSetAttributes::CopyAttributeFlags[NUM_ATTRIBUTES] [protected]

Definition at line 363 of file vtkDataSetAttributes.h.

vtkFieldData::BasicIterator vtkDataSetAttributes::RequiredArrays [protected]

Definition at line 366 of file vtkDataSetAttributes.h.

int* vtkDataSetAttributes::TargetIndices [protected]

Definition at line 369 of file vtkDataSetAttributes.h.

const int vtkDataSetAttributes::NumberOfAttributeComponents[NUM_ATTRIBUTES] [static, protected]

Definition at line 373 of file vtkDataSetAttributes.h.

const int vtkDataSetAttributes::AttributeLimits[NUM_ATTRIBUTES] [static, protected]

Definition at line 374 of file vtkDataSetAttributes.h.

const char vtkDataSetAttributes::AttributeNames[NUM_ATTRIBUTES][10] [static, protected]

Definition at line 375 of file vtkDataSetAttributes.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataSetAttributes.h
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetAttributes::FieldList Class Reference

#include <vtkDataSetAttributes.h>

Collaboration diagram for vtkDataSetAttributes::FieldList:

[legend]
List of all members.

Public Methods

FieldList (int numInputs)
~FieldList ()
void | InitializeFieldList (vtkDataSetAttributes *dsa)
void | IntersectFieldList (vtkDataSetAttributes *dsa)
int | IsAttributePresent (int attrType)

Protected Methods

FieldList (const FieldList &)
void | operator= (const FieldList &)

Friends

class | vtkDataSetAttributes

Constructor & Destructor Documentation

vtkDataSetAttributes::FieldList::FieldList ( int numInputs )

vtkDataSetAttributes::FieldList::~FieldList ( )

vtkDataSetAttributes::FieldList::FieldList ( const FieldList & ) [inline, protected]

Definition at line 407 of file vtkDataSetAttributes.h.

Member Function Documentation

void vtkDataSetAttributes::FieldList::InitializeFieldList ( vtkDataSetAttributes * dsa )

void vtkDataSetAttributes::FieldList::IntersectFieldList ( vtkDataSetAttributes * dsa )

int vtkDataSetAttributes::FieldList::IsAttributePresent ( int attrType )

void vtkDataSetAttributes::FieldList::operator= ( const FieldList & ) [inline, protected]

Definition at line 408 of file vtkDataSetAttributes.h.

Friends And Related Function Documentation

friend class vtkDataSetAttributes [friend]

Definition at line 404 of file vtkDataSetAttributes.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataSetAttributes.h
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetCollection Class Reference

maintain an unordered list of dataset objects. More...

#include <vtkDataSetCollection.h>

Inheritance diagram for vtkDataSetCollection:

[legend]
Collaboration diagram for vtkDataSetCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetCollection, vtkCollection)
void | AddItem (vtkDataSet *ds)
vtkDataSet * GetNextItem ()
vtkDataSet * | GetItem (int i)

Static Public Methods

vtkDataSetCollection * | New ()

Protected Methods

vtkDataSetCollection ()
~vtkDataSetCollection ()

Detailed Description

maintain an unordered list of dataset objects.

Date:
2002/01/22 15:25:19
Revision:
1.17

vtkDataSetCollection is an object that creates and manipulates lists of datasets. See also vtkCollection and subclasses.

Created by:
  • Hoffman, Bill
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (50%)
  • Hoffman, Bill (34%)
  • Martin, Ken (11%)

Definition at line 41 of file vtkDataSetCollection.h.

Constructor & Destructor Documentation

vtkDataSetCollection::vtkDataSetCollection ( ) [inline, protected]

Definition at line 66 of file vtkDataSetCollection.h.

vtkDataSetCollection::~vtkDataSetCollection ( ) [inline, protected]

Definition at line 67 of file vtkDataSetCollection.h.

Member Function Documentation

vtkDataSetCollection* vtkDataSetCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkDataSetCollection::vtkTypeRevisionMacro | ( | vtkDataSetCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkDataSetCollection::AddItem ( vtkDataSet * ds ) [inline]

Add a dataset to the list.

Definition at line 49 of file vtkDataSetCollection.h.

vtkDataSet* vtkDataSetCollection::GetNextItem ( ) [inline]

Get the next dataset in the list.

Definition at line 55 of file vtkDataSetCollection.h.

vtkDataSet* vtkDataSetCollection::GetItem ( int i ) [inline]

Get the ith dataset in the list.

Definition at line 61 of file vtkDataSetCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkDataSetCollection.h
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetMapper Class Reference

map vtkDataSet and derived classes to graphics primitives. More...

#include <vtkDataSetMapper.h>

Inheritance diagram for vtkDataSetMapper:

[legend]
Collaboration diagram for vtkDataSetMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetMapper, vtkMapper)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Render (vtkRenderer *ren, vtkActor *act)
void | ReleaseGraphicsResources (vtkWindow *)
unsigned long | GetMTime ()
virtual vtkPolyDataMapper * | GetPolyDataMapper ()
void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Static Public Methods

vtkDataSetMapper * | New ()

Protected Methods

vtkDataSetMapper ()
~vtkDataSetMapper ()

Protected Attributes

vtkDataSetSurfaceFilter * GeometryExtractor
vtkPolyDataMapper * PolyDataMapper

Detailed Description

map vtkDataSet and derived classes to graphics primitives.

Date:
2002/01/22 15:38:30
Revision:
1.53

vtkDataSetMapper is a mapper to map data sets (i.e., vtkDataSet and all derived classes) to graphics primitives. The mapping procedure is as follows: all 0D, 1D, and 2D cells are converted into points, lines, and polygons/triangle strips and then mapped to the graphics system. The 2D faces of 3D cells are mapped only if they are used by only one cell, i.e., on the boundary of the data set.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Martin, Ken (12%)
  • Law, Charles (7%)
  • Avila, Lisa (5%)
Examples:
vtkDataSetMapper (Examples)
Tests:
vtkDataSetMapper (Tests)

Definition at line 54 of file vtkDataSetMapper.h.

Constructor & Destructor Documentation

vtkDataSetMapper::vtkDataSetMapper ( ) [protected]

vtkDataSetMapper::~vtkDataSetMapper ( ) [protected]

Member Function Documentation

vtkDataSetMapper* vtkDataSetMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkDataSetMapper::vtkTypeRevisionMacro | ( | vtkDataSetMapper | ,
 |  | vtkMapper |
 | ) |

Reimplemented from vtkMapper.

void vtkDataSetMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper.

void vtkDataSetMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkActor * | act
 | ) | [virtual]

Method initiates the mapping process. Generally sent by the actor as each frame is rendered.

Reimplemented from vtkMapper.

virtual vtkPolyDataMapper* vtkDataSetMapper::GetPolyDataMapper ( ) [virtual]

Get the internal poly data mapper used to map data set to graphics system.

void vtkDataSetMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkMapper.

unsigned long vtkDataSetMapper::GetMTime ( ) [virtual]

Get the mtime also considering the lookup table.

Reimplemented from vtkMapper.

void vtkDataSetMapper::SetInput ( vtkDataSet * input )

Set the Input of this mapper.

vtkDataSet* vtkDataSetMapper::GetInput ( )

Set the Input of this mapper.

Reimplemented from vtkMapper.

Member Data Documentation

vtkDataSetSurfaceFilter* vtkDataSetMapper::GeometryExtractor [protected]

Definition at line 86 of file vtkDataSetMapper.h.

vtkPolyDataMapper* vtkDataSetMapper::PolyDataMapper [protected]

Definition at line 87 of file vtkDataSetMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkDataSetMapper.h
Generated on Mon Mar 25 01:17:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetReader Class Reference

class to read any type of vtk dataset. More...

#include <vtkDataSetReader.h>

Inheritance diagram for vtkDataSetReader:

[legend]
Collaboration diagram for vtkDataSetReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Update ()
virtual int | ReadOutputType ()
vtkDataSet * GetOutput ()
vtkDataSet * | GetOutput (int idx)
vtkPolyData * GetPolyDataOutput ()
vtkStructuredPoints * GetStructuredPointsOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
vtkRectilinearGrid * GetRectilinearGridOutput ()

Static Public Methods

vtkDataSetReader * | New ()

Protected Methods

vtkDataSetReader ()
~vtkDataSetReader ()
void | Execute ()

Protected Attributes

vtkDataReader * Reader

Detailed Description

class to read any type of vtk dataset.

Date:
2002/03/07 02:12:30
Revision:
1.53

vtkDataSetReader is a class that provides instance variables and methods to read any type of dataset in Visualization Toolkit (vtk) format. The output type of this class will vary depending upon the type of data file. Convenience methods are provided to keep the data as a particular type. (See text for format description details). The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkDataReader vtkPolyDataReader vtkRectilinearGridReader vtkStructuredPointsReader vtkStructuredGridReader vtkUnstructuredGridReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (49%)
  • Law, Charles (21%)
  • Martin, Ken (10%)
  • Lorensen, Bill (9%)
Examples:
vtkDataSetReader (Examples)
Tests:
vtkDataSetReader (Tests)

Definition at line 64 of file vtkDataSetReader.h.

Constructor & Destructor Documentation

vtkDataSetReader::vtkDataSetReader ( ) [protected]

vtkDataSetReader::~vtkDataSetReader ( ) [protected]

Member Function Documentation

vtkDataSetReader* vtkDataSetReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkDataSetReader::vtkTypeRevisionMacro | ( | vtkDataSetReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkDataSetReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkDataSet* vtkDataSetReader::GetOutput ( )

Get the output of this source as a general vtkDataSet. Since we need to know the type of the data, the FileName must be set before GetOutput is applied.

vtkDataSet* vtkDataSetReader::GetOutput ( int idx ) [inline]

Get the output of this source as a general vtkDataSet. Since we need to know the type of the data, the FileName must be set before GetOutput is applied.

Reimplemented from vtkSource.

Definition at line 76 of file vtkDataSetReader.h.

vtkPolyData* vtkDataSetReader::GetPolyDataOutput ( )

Get the output as various concrete types. This method is typically used when you know exactly what type of data is being read. Otherwise, use the general GetOutput() method. If the wrong type is used NULL is returned. (You must also set the filename of the object prior to getting the output.)

vtkStructuredPoints* vtkDataSetReader::GetStructuredPointsOutput ( )

Get the output as various concrete types. This method is typically used when you know exactly what type of data is being read. Otherwise, use the general GetOutput() method. If the wrong type is used NULL is returned. (You must also set the filename of the object prior to getting the output.)

vtkStructuredGrid* vtkDataSetReader::GetStructuredGridOutput ( )

Get the output as various concrete types. This method is typically used when you know exactly what type of data is being read. Otherwise, use the general GetOutput() method. If the wrong type is used NULL is returned. (You must also set the filename of the object prior to getting the output.)

vtkUnstructuredGrid* vtkDataSetReader::GetUnstructuredGridOutput ( )

Get the output as various concrete types. This method is typically used when you know exactly what type of data is being read. Otherwise, use the general GetOutput() method. If the wrong type is used NULL is returned. (You must also set the filename of the object prior to getting the output.)

vtkRectilinearGrid* vtkDataSetReader::GetRectilinearGridOutput ( )

Get the output as various concrete types. This method is typically used when you know exactly what type of data is being read. Otherwise, use the general GetOutput() method. If the wrong type is used NULL is returned. (You must also set the filename of the object prior to getting the output.)

void vtkDataSetReader::Update ( ) [virtual]

If there is no output, execute anyway. Execute creates an output.

Reimplemented from vtkSource.

virtual int vtkDataSetReader::ReadOutputType ( ) [virtual]

This method can be used to find out the type of output expected without needing to read the whole file.

void vtkDataSetReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkDataReader* vtkDataSetReader::Reader [protected]

Definition at line 105 of file vtkDataSetReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkDataSetReader.h
Generated on Mon Mar 25 01:17:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetSource Class Reference

abstract class whose subclasses generate datasets. More...

#include <vtkDataSetSource.h>

Inheritance diagram for vtkDataSetSource:

[legend]
Collaboration diagram for vtkDataSetSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetSource, vtkSource)
vtkDataSet * GetOutput ()
vtkDataSet * | GetOutput (int idx)
void | SetOutput (vtkDataSet *)

Static Public Methods

vtkDataSetSource * | New ()

Protected Methods

vtkDataSetSource ()
~vtkDataSetSource ()

Detailed Description

abstract class whose subclasses generate datasets.

Date:
2002/01/22 15:28:02
Revision:
1.14

vtkDataSetSource is an abstract class whose subclasses generate datasets.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (96%)

Definition at line 37 of file vtkDataSetSource.h.

Constructor & Destructor Documentation

vtkDataSetSource::vtkDataSetSource ( ) [protected]

vtkDataSetSource::~vtkDataSetSource ( ) [inline, protected]

Definition at line 53 of file vtkDataSetSource.h.

Member Function Documentation

vtkDataSetSource* vtkDataSetSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkCastToConcrete, vtkArrayCalculator, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkBrownianPoints, vtkCellDataToPointData, vtkCellDerivatives, vtkElevationFilter, vtkExtractTensorComponents, vtkFieldDataToAttributeDataFilter, vtkIdFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkMaskFields, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkPointDataToCellData, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableFilter, vtkProjectedTexture, vtkRearrangeFields, vtkSimpleElevationFilter, vtkSplitField, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThresholdTextureCoords, vtkTransformTextureCoords, vtkVectorDot, vtkVectorNorm, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkGenericEnSightReader, vtkPCellDataToPointData, and vtkPieceScalars.

vtkDataSetSource::vtkTypeRevisionMacro | ( | vtkDataSetSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkCastToConcrete, vtkDataSetToDataSetFilter, vtkArrayCalculator, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkBrownianPoints, vtkCellDataToPointData, vtkCellDerivatives, vtkDicer, vtkElevationFilter, vtkExtractTensorComponents, vtkFieldDataToAttributeDataFilter, vtkIdFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkMaskFields, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkPointDataToCellData, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableFilter, vtkProjectedTexture, vtkRearrangeFields, vtkSimpleElevationFilter, vtkSplitField, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThresholdTextureCoords, vtkTransformTextureCoords, vtkVectorDot, vtkVectorNorm, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkEnSightReader, vtkGenericEnSightReader, vtkPCellDataToPointData, and vtkPieceScalars.

vtkDataSet* vtkDataSetSource::GetOutput ( )

Get the output of this source.

Reimplemented in vtkDataSetToDataSetFilter.

Referenced by vtkDataSetToDataSetFilter::GetOutput().

vtkDataSet* vtkDataSetSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToDataSetFilter.

Definition at line 46 of file vtkDataSetSource.h.

void vtkDataSetSource::SetOutput ( vtkDataSet * )

Get the output of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetSource.h
Generated on Mon Mar 25 01:17:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetSurfaceFilter Class Reference

Extracts outer (polygonal) surface. More...

#include <vtkDataSetSurfaceFilter.h>

Inheritance diagram for vtkDataSetSurfaceFilter:

[legend]
Collaboration diagram for vtkDataSetSurfaceFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetSurfaceFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetUseStrips (int)
virtual int | GetUseStrips ()
virtual void | UseStripsOn ()
virtual void | UseStripsOff ()

Static Public Methods

vtkDataSetSurfaceFilter * | New ()

Protected Methods

vtkDataSetSurfaceFilter ()
~vtkDataSetSurfaceFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | Execute ()
void | StructuredExecute (vtkDataSet *input, int *ext)
void | UnstructuredGridExecute ()
void | DataSetExecute ()
void | ExecuteInformation ()
void | ExecuteFaceStrips (vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis)
void | ExecuteFaceQuads (vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis)
void | InitializeQuadHash (vtkIdType numPoints)
void | DeleteQuadHash ()
void | InsertQuadInHash (vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType d, vtkIdType sourceId)
void | InsertTriInHash (vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType sourceId)
void | InitQuadHashTraversal ()
vtkFastGeomQuad * | GetNextVisibleQuadFromHash ()
vtkIdType | GetOutputPointId (vtkIdType inPtId, vtkDataSet *input, vtkPoints *outPts, vtkPointData *outPD)

Protected Attributes

int | UseStrips
vtkFastGeomQuad ** | QuadHash
vtkIdType QuadHashLength
vtkFastGeomQuad * | QuadHashTraversal
vtkIdType QuadHashTraversalIndex
vtkIdType * PointMap
vtkIdType NumberOfNewCells

Detailed Description

Extracts outer (polygonal) surface.

Date:
2002/01/22 15:29:14
Revision:
1.9

vtkDataSetSurfaceFilter is a fast version of vtkGeometry filter, but it does not have an option to select bounds. It may use more memory than vtkGeometryFilter. It only has one option: whether to use triangle strips when the input type is structured.

See also:
vtkGeometryFilter vtkStructuredGridGeometryFilter.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (79%)
  • Hoffman, Bill (10%)
  • Henderson, Amy (9%)
Tests:
vtkDataSetSurfaceFilter (Tests)

Definition at line 53 of file vtkDataSetSurfaceFilter.h.

Constructor & Destructor Documentation

vtkDataSetSurfaceFilter::vtkDataSetSurfaceFilter ( ) [protected]

vtkDataSetSurfaceFilter::~vtkDataSetSurfaceFilter ( ) [protected]

Member Function Documentation

vtkDataSetSurfaceFilter* vtkDataSetSurfaceFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkPVGeometryFilter.

vtkDataSetSurfaceFilter::vtkTypeRevisionMacro | ( | vtkDataSetSurfaceFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

Reimplemented in vtkPVGeometryFilter.

void vtkDataSetSurfaceFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkPVGeometryFilter.

virtual void vtkDataSetSurfaceFilter::SetUseStrips ( int ) [virtual]

When input is structured data, this flag will generate faces with triangle strips. This should render faster and use less memory, but no cell data is copied. By default, UseStrips is Off.

virtual int vtkDataSetSurfaceFilter::GetUseStrips ( ) [virtual]

When input is structured data, this flag will generate faces with triangle strips. This should render faster and use less memory, but no cell data is copied. By default, UseStrips is Off.

virtual void vtkDataSetSurfaceFilter::UseStripsOn ( ) [virtual]

When input is structured data, this flag will generate faces with triangle strips. This should render faster and use less memory, but no cell data is copied. By default, UseStrips is Off.

virtual void vtkDataSetSurfaceFilter::UseStripsOff ( ) [virtual]

When input is structured data, this flag will generate faces with triangle strips. This should render faster and use less memory, but no cell data is copied. By default, UseStrips is Off.

void vtkDataSetSurfaceFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

Do not let images return more than requested.

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkDataSetSurfaceFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkPVGeometryFilter.

void vtkDataSetSurfaceFilter::StructuredExecute | ( | vtkDataSet * | input,
 |  | int * | ext
 | ) | [protected]

void vtkDataSetSurfaceFilter::UnstructuredGridExecute ( ) [protected]

void vtkDataSetSurfaceFilter::DataSetExecute ( ) [protected]

void vtkDataSetSurfaceFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkDataSetSurfaceFilter::ExecuteFaceStrips | ( | vtkDataSet * | input,
 |  | int | maxFlag,
 |  | int * | ext,
 |  | int | aAxis,
 |  | int | bAxis,
 |  | int | cAxis
 | ) | [protected]

void vtkDataSetSurfaceFilter::ExecuteFaceQuads | ( | vtkDataSet * | input,
 |  | int | maxFlag,
 |  | int * | ext,
 |  | int | aAxis,
 |  | int | bAxis,
 |  | int | cAxis
 | ) | [protected]

void vtkDataSetSurfaceFilter::InitializeQuadHash ( vtkIdType numPoints ) [protected]

void vtkDataSetSurfaceFilter::DeleteQuadHash ( ) [protected]

void vtkDataSetSurfaceFilter::InsertQuadInHash | ( | vtkIdType | a,
 |  | vtkIdType | b,
 |  | vtkIdType | c,
 |  | vtkIdType | d,
 |  | vtkIdType | sourceId
 | ) | [protected]

void vtkDataSetSurfaceFilter::InsertTriInHash | ( | vtkIdType | a,
 |  | vtkIdType | b,
 |  | vtkIdType | c,
 |  | vtkIdType | sourceId
 | ) | [protected]

void vtkDataSetSurfaceFilter::InitQuadHashTraversal ( ) [protected]

vtkFastGeomQuad* vtkDataSetSurfaceFilter::GetNextVisibleQuadFromHash ( ) [protected]

vtkIdType vtkDataSetSurfaceFilter::GetOutputPointId | ( | vtkIdType | inPtId,
 |  | vtkDataSet * | input,
 |  | vtkPoints * | outPts,
 |  | vtkPointData * | outPD
 | ) | [protected]

Member Data Documentation

int vtkDataSetSurfaceFilter::UseStrips [protected]

Definition at line 73 of file vtkDataSetSurfaceFilter.h.

vtkFastGeomQuad** vtkDataSetSurfaceFilter::QuadHash [protected]

Definition at line 98 of file vtkDataSetSurfaceFilter.h.

vtkIdType vtkDataSetSurfaceFilter::QuadHashLength [protected]

Definition at line 99 of file vtkDataSetSurfaceFilter.h.

vtkFastGeomQuad* vtkDataSetSurfaceFilter::QuadHashTraversal [protected]

Definition at line 100 of file vtkDataSetSurfaceFilter.h.

vtkIdType vtkDataSetSurfaceFilter::QuadHashTraversalIndex [protected]

Definition at line 101 of file vtkDataSetSurfaceFilter.h.

vtkIdType* vtkDataSetSurfaceFilter::PointMap [protected]

Definition at line 103 of file vtkDataSetSurfaceFilter.h.

vtkIdType vtkDataSetSurfaceFilter::NumberOfNewCells [protected]

Definition at line 107 of file vtkDataSetSurfaceFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDataSetSurfaceFilter.h
Generated on Mon Mar 25 01:17:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToDataObjectFilter Class Reference

map dataset into data object (i.e., a field). More...

#include <vtkDataSetToDataObjectFilter.h>

Inheritance diagram for vtkDataSetToDataObjectFilter:

[legend]
Collaboration diagram for vtkDataSetToDataObjectFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToDataObjectFilter, vtkDataObjectSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetGeometry (int)
virtual int | GetGeometry ()
virtual void | GeometryOn ()
virtual void | GeometryOff ()
virtual void | SetTopology (int)
virtual int | GetTopology ()
virtual void | TopologyOn ()
virtual void | TopologyOff ()
virtual void | SetFieldData (int)
virtual int | GetFieldData ()
virtual void | FieldDataOn ()
virtual void | FieldDataOff ()
virtual void | SetPointData (int)
virtual int | GetPointData ()
virtual void | PointDataOn ()
virtual void | PointDataOff ()
virtual void | SetCellData (int)
virtual int | GetCellData ()
virtual void | CellDataOn ()
virtual void | CellDataOff ()
virtual void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Static Public Methods

vtkDataSetToDataObjectFilter * | New ()

Protected Methods

vtkDataSetToDataObjectFilter ()
~vtkDataSetToDataObjectFilter ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | Geometry
int | Topology
int | PointData
int | CellData
int | FieldData

Detailed Description

map dataset into data object (i.e., a field).

Date:
2002/01/22 15:29:15
Revision:
1.18

vtkDataSetToDataObjectFilter is an class that transforms a dataset into data object (i.e., a field). The field will have labeled data arrays corresponding to the topology, geometry, field data, and point and cell attribute data.

You can control what portions of the dataset are converted into the output data object's field data. The instance variables Geometry, Topology, FieldData, PointData, and CellData are flags that control whether the dataset's geometry (e.g., points, spacing, origin); topology (e.g., cell connectivity, dimensions); the field data associated with the dataset's superclass data object; the dataset's point data attributes; and the dataset's cell data attributes. (Note: the data attributes include scalars, vectors, tensors, normals, texture coordinates, and field data.)

The names used to create the field data are as follows. For vtkPolyData, "Points", "Verts", "Lines", "Polys", and "Strips". For vtkUnstructuredGrid, "Cells" and "CellTypes". For vtkStructuredPoints, "Dimensions", "Spacing", and "Origin". For vtkStructuredGrid, "Points" and "Dimensions". For vtkRectilinearGrid, "XCoordinates", "YCoordinates", and "ZCoordinates". for point attribute data, "PointScalars", "PointVectors", etc. For cell attribute data, "CellScalars", "CellVectors", etc. Field data arrays retain their original name.

See also:
vtkDataObject vtkFieldData vtkDataObjectToDataSetFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Geveci, Berk (20%)
  • Law, Charles (7%)
Tests:
vtkDataSetToDataObjectFilter (Tests)

Definition at line 68 of file vtkDataSetToDataObjectFilter.h.

Constructor & Destructor Documentation

vtkDataSetToDataObjectFilter::vtkDataSetToDataObjectFilter ( ) [protected]

vtkDataSetToDataObjectFilter::~vtkDataSetToDataObjectFilter ( ) [protected]

Member Function Documentation

vtkDataSetToDataObjectFilter::vtkTypeRevisionMacro | ( | vtkDataSetToDataObjectFilter | ,
 |  | vtkDataObjectSource |
 | ) |

Reimplemented from vtkDataObjectSource.

void vtkDataSetToDataObjectFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkDataSetToDataObjectFilter* vtkDataSetToDataObjectFilter::New ( ) [static]

Instantiate the object to transform all data into a data object.

Reimplemented from vtkDataObjectSource.

virtual void vtkDataSetToDataObjectFilter::SetGeometry ( int ) [virtual]

Turn on/off the conversion of dataset geometry to a data object.

virtual int vtkDataSetToDataObjectFilter::GetGeometry ( ) [virtual]

Turn on/off the conversion of dataset geometry to a data object.

virtual void vtkDataSetToDataObjectFilter::GeometryOn ( ) [virtual]

Turn on/off the conversion of dataset geometry to a data object.

virtual void vtkDataSetToDataObjectFilter::GeometryOff ( ) [virtual]

Turn on/off the conversion of dataset geometry to a data object.

virtual void vtkDataSetToDataObjectFilter::SetTopology ( int ) [virtual]

Turn on/off the conversion of dataset topology to a data object.

virtual int vtkDataSetToDataObjectFilter::GetTopology ( ) [virtual]

Turn on/off the conversion of dataset topology to a data object.

virtual void vtkDataSetToDataObjectFilter::TopologyOn ( ) [virtual]

Turn on/off the conversion of dataset topology to a data object.

virtual void vtkDataSetToDataObjectFilter::TopologyOff ( ) [virtual]

Turn on/off the conversion of dataset topology to a data object.

virtual void vtkDataSetToDataObjectFilter::SetFieldData ( int ) [virtual]

Turn on/off the conversion of dataset field data to a data object.

virtual int vtkDataSetToDataObjectFilter::GetFieldData ( ) [virtual]

Turn on/off the conversion of dataset field data to a data object.

virtual void vtkDataSetToDataObjectFilter::FieldDataOn ( ) [virtual]

Turn on/off the conversion of dataset field data to a data object.

virtual void vtkDataSetToDataObjectFilter::FieldDataOff ( ) [virtual]

Turn on/off the conversion of dataset field data to a data object.

virtual void vtkDataSetToDataObjectFilter::SetPointData ( int ) [virtual]

Turn on/off the conversion of dataset point data to a data object.

virtual int vtkDataSetToDataObjectFilter::GetPointData ( ) [virtual]

Turn on/off the conversion of dataset point data to a data object.

virtual void vtkDataSetToDataObjectFilter::PointDataOn ( ) [virtual]

Turn on/off the conversion of dataset point data to a data object.

virtual void vtkDataSetToDataObjectFilter::PointDataOff ( ) [virtual]

Turn on/off the conversion of dataset point data to a data object.

virtual void vtkDataSetToDataObjectFilter::SetCellData ( int ) [virtual]

Turn on/off the conversion of dataset cell data to a data object.

virtual int vtkDataSetToDataObjectFilter::GetCellData ( ) [virtual]

Turn on/off the conversion of dataset cell data to a data object.

virtual void vtkDataSetToDataObjectFilter::CellDataOn ( ) [virtual]

Turn on/off the conversion of dataset cell data to a data object.

virtual void vtkDataSetToDataObjectFilter::CellDataOff ( ) [virtual]

Turn on/off the conversion of dataset cell data to a data object.

virtual void vtkDataSetToDataObjectFilter::SetInput ( vtkDataSet * input ) [virtual]

Cast input to DataSet.

vtkDataSet* vtkDataSetToDataObjectFilter::GetInput ( )

Cast input to DataSet.

void vtkDataSetToDataObjectFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDataSetToDataObjectFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Member Data Documentation

int vtkDataSetToDataObjectFilter::Geometry [protected]

Definition at line 125 of file vtkDataSetToDataObjectFilter.h.

int vtkDataSetToDataObjectFilter::Topology [protected]

Definition at line 126 of file vtkDataSetToDataObjectFilter.h.

int vtkDataSetToDataObjectFilter::PointData [protected]

Definition at line 127 of file vtkDataSetToDataObjectFilter.h.

int vtkDataSetToDataObjectFilter::CellData [protected]

Definition at line 128 of file vtkDataSetToDataObjectFilter.h.

int vtkDataSetToDataObjectFilter::FieldData [protected]

Definition at line 129 of file vtkDataSetToDataObjectFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDataSetToDataObjectFilter.h
Generated on Mon Mar 25 01:17:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToDataSetFilter Class Reference

abstract filter class. More...

#include <vtkDataSetToDataSetFilter.h>

Inheritance diagram for vtkDataSetToDataSetFilter:

[legend]
Collaboration diagram for vtkDataSetToDataSetFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToDataSetFilter, vtkDataSetSource)
void | SetInput (vtkDataSet *input)
vtkPolyData * GetPolyDataOutput ()
vtkStructuredPoints * GetStructuredPointsOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
vtkRectilinearGrid * GetRectilinearGridOutput ()
vtkDataSet * GetInput ()
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
vtkDataSet * GetOutput ()
vtkDataSet * | GetOutput (int idx)

Protected Methods

vtkDataSetToDataSetFilter ()
~vtkDataSetToDataSetFilter ()
void | ExecuteInformation ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:03
Revision:
1.69

vtkDataSetToDataSetFilter is an abstract filter class. Subclasses of vtkDataSetToDataSetFilter take a dataset as input and create a dataset as output. The form of the input geometry is not changed in these filters, only the point attributes (e.g. scalars, vectors, etc.).

This is an abstract filter type. What that means is that the output of the filter is an abstract type (i.e., vtkDataSet), no matter what the input of the filter is. This can cause problems connecting together filters due to the change in dataset type. (For example, in a series of filters processing vtkPolyData, when a vtkDataSetToDataSetFilter or subclass is introduced into the pipeline, if the filter downstream of it takes vtkPolyData as input, the pipeline connection cannot be made.) To get around this problem, use one of the convenience methods to return a concrete type (e.g., vtkGetPolyDataOutput(), GetStructuredPointsOutput(), etc.).

See also:
vtkBrownianPoints vtkProbeFilter vtkThresholdTextureCoords vtkDicer vtkElevationFilter vtkImplicitTextureCoords vtkTextureMapToBox vtkTextureMapToPlane vtkVectorDot vtkVectorNorm
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (60%)
  • Martin, Ken (24%)
  • Lorensen, Bill (5%)

Definition at line 64 of file vtkDataSetToDataSetFilter.h.

Constructor & Destructor Documentation

vtkDataSetToDataSetFilter::vtkDataSetToDataSetFilter ( ) [protected]

vtkDataSetToDataSetFilter::~vtkDataSetToDataSetFilter ( ) [protected]

Member Function Documentation

vtkDataSetToDataSetFilter::vtkTypeRevisionMacro | ( | vtkDataSetToDataSetFilter | ,
 |  | vtkDataSetSource |
 | ) |

Reimplemented from vtkDataSetSource.

Reimplemented in vtkCastToConcrete, vtkArrayCalculator, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkBrownianPoints, vtkCellDataToPointData, vtkCellDerivatives, vtkDicer, vtkElevationFilter, vtkExtractTensorComponents, vtkFieldDataToAttributeDataFilter, vtkIdFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkMaskFields, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkPointDataToCellData, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableFilter, vtkProjectedTexture, vtkRearrangeFields, vtkSimpleElevationFilter, vtkSplitField, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThresholdTextureCoords, vtkTransformTextureCoords, vtkVectorDot, vtkVectorNorm, vtkPCellDataToPointData, and vtkPieceScalars.

void vtkDataSetToDataSetFilter::SetInput ( vtkDataSet * input )

Specify the input data or filter.

Referenced by vtkMergeFilter::SetGeometry().

vtkDataSet* vtkDataSetToDataSetFilter::GetOutput ( )

Get the output of this filter. If output is NULL then input hasn't been set which is necessary for abstract objects.

Reimplemented from vtkDataSetSource.

vtkDataSet* vtkDataSetToDataSetFilter::GetOutput ( int idx ) [inline]

Get the output of this filter. If output is NULL then input hasn't been set which is necessary for abstract objects.

Reimplemented from vtkDataSetSource.

Definition at line 77 of file vtkDataSetToDataSetFilter.h.

vtkPolyData* vtkDataSetToDataSetFilter::GetPolyDataOutput ( )

Get the output as vtkPolyData.

vtkStructuredPoints* vtkDataSetToDataSetFilter::GetStructuredPointsOutput ( )

Get the output as vtkStructuredPoints.

vtkStructuredGrid* vtkDataSetToDataSetFilter::GetStructuredGridOutput ( )

Get the output as vtkStructuredGrid.

vtkUnstructuredGrid* vtkDataSetToDataSetFilter::GetUnstructuredGridOutput ( )

Get the output as vtkUnstructuredGrid.

vtkRectilinearGrid* vtkDataSetToDataSetFilter::GetRectilinearGridOutput ( )

Get the output as vtkRectilinearGrid.

vtkDataSet* vtkDataSetToDataSetFilter::GetInput ( )

Get the input data or filter.

Referenced by vtkMergeFilter::GetGeometry().

virtual void vtkDataSetToDataSetFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

By default copy the output update extent to the input

Reimplemented from vtkSource.

Reimplemented in vtkFieldDataToAttributeDataFilter, vtkMergeFilter, vtkProbeFilter, and vtkPCellDataToPointData.

void vtkDataSetToDataSetFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Reimplemented in vtkCastToConcrete, and vtkProbeFilter.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetToDataSetFilter.h
Generated on Mon Mar 25 01:17:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkDataSetToPolyDataFilter.h>

Inheritance diagram for vtkDataSetToPolyDataFilter:

[legend]
Collaboration diagram for vtkDataSetToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToPolyDataFilter, vtkPolyDataSource)
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Protected Methods

vtkDataSetToPolyDataFilter ()
~vtkDataSetToPolyDataFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:03
Revision:
1.21

vtkDataSetToPolyDataFilter is an abstract filter class whose subclasses take as input any dataset and generate polygonal data on output.

See also:
vtkContourFilter vtkCutter vtkEdgePoints vtkExtractEdges vtkGeometryFilter vtkGlyph3D vtkHedgeHog vtkHyperStreamline vtkMaskPoints vtkOutlineFilter vtkStreamer vtkTensorGlyph vtkThresholdPoints vtkVectorTopology
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Law, Charles (17%)
  • Lorensen, Bill (11%)
  • Martin, Ken (5%)

Definition at line 47 of file vtkDataSetToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkDataSetToPolyDataFilter::vtkDataSetToPolyDataFilter ( ) [inline, protected]

Definition at line 62 of file vtkDataSetToPolyDataFilter.h.

vtkDataSetToPolyDataFilter::~vtkDataSetToPolyDataFilter ( ) [inline, protected]

Definition at line 63 of file vtkDataSetToPolyDataFilter.h.

Member Function Documentation

vtkDataSetToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkDataSetToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkCellCenters, vtkContourFilter, vtkCutter, vtkDashedStreamLine, vtkDataSetSurfaceFilter, vtkEdgePoints, vtkExtractEdges, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkHedgeHog, vtkHyperStreamline, vtkMaskPoints, vtkOutlineCornerFilter, vtkOutlineFilter, vtkProgrammableGlyphFilter, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkTensorGlyph, vtkThresholdPoints, vtkCutMaterial, vtkPVGeometryFilter, vtkKitwareContourFilter, vtkMarchingContourFilter, and vtkSelectVisiblePoints.

virtual void vtkDataSetToPolyDataFilter::SetInput ( vtkDataSet * input ) [virtual]

Set / get the input data or filter.

vtkDataSet* vtkDataSetToPolyDataFilter::GetInput ( )

Set / get the input data or filter.

virtual void vtkDataSetToPolyDataFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

Do not let images return more than requested.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkDataSetSurfaceFilter, vtkGeometryFilter, vtkGlyph3D, and vtkKitwareContourFilter.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetToPolyDataFilter.h
Generated on Mon Mar 25 01:17:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToStructuredGridFilter Class Reference

abstract filter class. More...

#include <vtkDataSetToStructuredGridFilter.h>

Inheritance diagram for vtkDataSetToStructuredGridFilter:

[legend]
Collaboration diagram for vtkDataSetToStructuredGridFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToStructuredGridFilter, vtkStructuredGridSource)
virtual void SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Protected Methods

vtkDataSetToStructuredGridFilter ()
~vtkDataSetToStructuredGridFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:04
Revision:
1.27

vtkDataSetToStructuredGridFilter is an abstract filter class whose subclasses take as input any dataset and generate a structured grid on output.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (86%)
  • Lorensen, Bill (9%)

Definition at line 39 of file vtkDataSetToStructuredGridFilter.h.

Constructor & Destructor Documentation

vtkDataSetToStructuredGridFilter::vtkDataSetToStructuredGridFilter ( ) [inline, protected]

Definition at line 51 of file vtkDataSetToStructuredGridFilter.h.

vtkDataSetToStructuredGridFilter::~vtkDataSetToStructuredGridFilter ( ) [inline, protected]

Definition at line 52 of file vtkDataSetToStructuredGridFilter.h.

Member Function Documentation

vtkDataSetToStructuredGridFilter::vtkTypeRevisionMacro | ( | vtkDataSetToStructuredGridFilter | ,
 |  | vtkStructuredGridSource |
 | ) |

Reimplemented from vtkStructuredGridSource.

virtual void vtkDataSetToStructuredGridFilter::SetInput ( vtkDataSet * input ) [virtual]

Set / get the input data or filter.

vtkDataSet* vtkDataSetToStructuredGridFilter::GetInput ( )

Set / get the input data or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetToStructuredGridFilter.h
Generated on Mon Mar 25 01:17:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToStructuredPointsFilter Class Reference

abstract filter class. More...

#include <vtkDataSetToStructuredPointsFilter.h>

Inheritance diagram for vtkDataSetToStructuredPointsFilter:

[legend]
Collaboration diagram for vtkDataSetToStructuredPointsFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToStructuredPointsFilter, vtkStructuredPointsSource)
virtual void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Protected Methods

vtkDataSetToStructuredPointsFilter ()
~vtkDataSetToStructuredPointsFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:04
Revision:
1.42

vtkDataSetToStructuredPointsFilter is an abstract filter class whose subclasses take as input any dataset and generate structured points data on output.

See also:
vtkGaussianSplatter vtkImplicitModeller vtkShepardMethod vtkVoxelModeller
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (60%)
  • Martin, Ken (24%)
  • Lorensen, Bill (10%)

Definition at line 43 of file vtkDataSetToStructuredPointsFilter.h.

Constructor & Destructor Documentation

vtkDataSetToStructuredPointsFilter::vtkDataSetToStructuredPointsFilter ( ) [inline, protected]

Definition at line 55 of file vtkDataSetToStructuredPointsFilter.h.

vtkDataSetToStructuredPointsFilter::~vtkDataSetToStructuredPointsFilter ( ) [inline, protected]

Definition at line 56 of file vtkDataSetToStructuredPointsFilter.h.

Member Function Documentation

vtkDataSetToStructuredPointsFilter::vtkTypeRevisionMacro | ( | vtkDataSetToStructuredPointsFilter | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

Reimplemented in vtkImplicitModeller, vtkGaussianSplatter, vtkShepardMethod, vtkSurfaceReconstructionFilter, and vtkVoxelModeller.

virtual void vtkDataSetToStructuredPointsFilter::SetInput ( vtkDataSet * input ) [virtual]

Set / get the input data or filter.

vtkDataSet* vtkDataSetToStructuredPointsFilter::GetInput ( )

Set / get the input data or filter.

void vtkDataSetToStructuredPointsFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetToStructuredPointsFilter.h
Generated on Mon Mar 25 01:17:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetToUnstructuredGridFilter Class Reference

abstract filter class. More...

#include <vtkDataSetToUnstructuredGridFilter.h>

Inheritance diagram for vtkDataSetToUnstructuredGridFilter:

[legend]
Collaboration diagram for vtkDataSetToUnstructuredGridFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetToUnstructuredGridFilter, vtkUnstructuredGridSource)
virtual void SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Protected Methods

vtkDataSetToUnstructuredGridFilter ()
~vtkDataSetToUnstructuredGridFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:04
Revision:
1.39

vtkDataSetToUnstructuredGridFilter is an abstract filter class whose subclasses take as input any dataset and generate an unstructured grid on output.

See also:
vtkAppendFilter vtkConnectivityFilter vtkExtractGeometry vtkShrinkFilter vtkThreshold
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Martin, Ken (25%)
  • Lorensen, Bill (11%)
  • Law, Charles (5%)

Definition at line 45 of file vtkDataSetToUnstructuredGridFilter.h.

Constructor & Destructor Documentation

vtkDataSetToUnstructuredGridFilter::vtkDataSetToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 57 of file vtkDataSetToUnstructuredGridFilter.h.

vtkDataSetToUnstructuredGridFilter::~vtkDataSetToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 58 of file vtkDataSetToUnstructuredGridFilter.h.

Member Function Documentation

vtkDataSetToUnstructuredGridFilter::vtkTypeRevisionMacro | ( | vtkDataSetToUnstructuredGridFilter | ,
 |  | vtkUnstructuredGridSource |
 | ) |

Reimplemented from vtkUnstructuredGridSource.

Reimplemented in vtkAppendFilter, vtkClipDataSet, vtkConnectivityFilter, vtkDataSetTriangleFilter, vtkExtractGeometry, vtkShrinkFilter, and vtkThreshold.

virtual void vtkDataSetToUnstructuredGridFilter::SetInput ( vtkDataSet * input ) [virtual]

Set / get the input data or filter.

vtkDataSet* vtkDataSetToUnstructuredGridFilter::GetInput ( )

Set / get the input data or filter.

Reimplemented in vtkAppendFilter.

Referenced by vtkAppendFilter::GetInput().

The documentation for this class was generated from the following file:
  • Filtering/vtkDataSetToUnstructuredGridFilter.h
Generated on Mon Mar 25 01:17:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetTriangleFilter Class Reference

triangulate any type of dataset. More...

#include <vtkDataSetTriangleFilter.h>

Inheritance diagram for vtkDataSetTriangleFilter:

[legend]
Collaboration diagram for vtkDataSetTriangleFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetTriangleFilter, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkDataSetTriangleFilter * | New ()

Protected Methods

vtkDataSetTriangleFilter ()
~vtkDataSetTriangleFilter ()
void | Execute ()
void | StructuredExecute ()
void | UnstructuredExecute ()

Protected Attributes

vtkOrderedTriangulator * Triangulator

Detailed Description

triangulate any type of dataset.

Date:
2002/01/22 15:29:15
Revision:
1.8

vtkTriangulateDataSet generates n-dimensional simplices from any input dataset. That is, 3D cells are converted to tetrahedral meshes, 2D cells to triangles, and so on. The triangulation is guaranteed compatible as long as the dataset is either zero-, one- or two-dimensional; or if a three-dimensional dataset, all cells in the 3D dataset are convex with planar facets.

See also:
vtkOrderedTriangulator vtkTriangleFilter
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (60%)
  • Schroeder, Will (32%)
Tests:
vtkDataSetTriangleFilter (Tests)

Definition at line 50 of file vtkDataSetTriangleFilter.h.

Constructor & Destructor Documentation

vtkDataSetTriangleFilter::vtkDataSetTriangleFilter ( ) [inline, protected]

Definition at line 58 of file vtkDataSetTriangleFilter.h.

vtkDataSetTriangleFilter::~vtkDataSetTriangleFilter ( ) [protected]

Member Function Documentation

vtkDataSetTriangleFilter* vtkDataSetTriangleFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkDataSetTriangleFilter::vtkTypeRevisionMacro | ( | vtkDataSetTriangleFilter | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkDataSetTriangleFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkDataSetTriangleFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDataSetTriangleFilter::StructuredExecute ( ) [protected]

void vtkDataSetTriangleFilter::UnstructuredExecute ( ) [protected]

Member Data Documentation

vtkOrderedTriangulator* vtkDataSetTriangleFilter::Triangulator [protected]

Definition at line 68 of file vtkDataSetTriangleFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDataSetTriangleFilter.h
Generated on Mon Mar 25 01:17:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataSetWriter Class Reference

write any type of vtk dataset to file. More...

#include <vtkDataSetWriter.h>

Inheritance diagram for vtkDataSetWriter:

[legend]
Collaboration diagram for vtkDataSetWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataSetWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Static Public Methods

vtkDataSetWriter * | New ()

Protected Methods

vtkDataSetWriter ()
~vtkDataSetWriter ()
void | WriteData ()

Detailed Description

write any type of vtk dataset to file.

Date:
2002/01/22 15:38:11
Revision:
1.43

vtkDataSetWriter is an abstract class for mapper objects that write their data to disk (or into a communications port). The input to this object is a dataset of any type.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Law, Charles (13%)
  • Martin, Ken (12%)
Tests:
vtkDataSetWriter (Tests)

Definition at line 43 of file vtkDataSetWriter.h.

Constructor & Destructor Documentation

vtkDataSetWriter::vtkDataSetWriter ( ) [inline, protected]

Definition at line 57 of file vtkDataSetWriter.h.

vtkDataSetWriter::~vtkDataSetWriter ( ) [inline, protected]

Definition at line 58 of file vtkDataSetWriter.h.

Member Function Documentation

vtkDataSetWriter* vtkDataSetWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

Reimplemented in vtkPDataSetWriter.

vtkDataSetWriter::vtkTypeRevisionMacro | ( | vtkDataSetWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

Reimplemented in vtkPDataSetWriter.

void vtkDataSetWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

Reimplemented in vtkPDataSetWriter.

void vtkDataSetWriter::SetInput ( vtkDataSet * input )

Set / get the input data or filter.

vtkDataSet* vtkDataSetWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkDataSetWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

The documentation for this class was generated from the following file:
  • IO/vtkDataSetWriter.h
Generated on Mon Mar 25 01:17:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDataWriter Class Reference

helper class for objects that write vtk data files. More...

#include <vtkDataWriter.h>

Inheritance diagram for vtkDataWriter:

[legend]
Collaboration diagram for vtkDataWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDataWriter, vtkWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
char * | RegisterAndGetOutputString ()
virtual ostream * | OpenVTKFile ()
int | WriteHeader (ostream *fp)
int | WritePoints (ostream *fp, vtkPoints *p)
int | WriteCoordinates (ostream *fp, vtkDataArray *coords, int axes)
int | WriteCells (ostream *fp, vtkCellArray *cells, const char *label)
int | WriteCellData (ostream *fp, vtkDataSet *ds)
int | WritePointData (ostream *fp, vtkDataSet *ds)
int | WriteFieldData (ostream *fp, vtkFieldData *f)
int | WriteDataSetData (ostream *fp, vtkDataSet *ds)
void | CloseVTKFile (ostream *fp)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetWriteToOutputString (int)
virtual int | GetWriteToOutputString ()
virtual void | WriteToOutputStringOn ()
virtual void | WriteToOutputStringOff ()
virtual int | GetOutputStringLength ()
virtual char * | GetOutputString ()
unsigned char * | GetBinaryOutputString ()
virtual void | SetHeader (const char *)
virtual char * | GetHeader ()
virtual void | SetFileType (int)
virtual int | GetFileType ()
void | SetFileTypeToASCII ()
void | SetFileTypeToBinary ()
virtual void | SetScalarsName (const char *)
virtual char * | GetScalarsName ()
virtual void | SetVectorsName (const char *)
virtual char * | GetVectorsName ()
virtual void | SetTensorsName (const char *)
virtual char * | GetTensorsName ()
virtual void | SetNormalsName (const char *)
virtual char * | GetNormalsName ()
virtual void | SetTCoordsName (const char *)
virtual char * | GetTCoordsName ()
virtual void | SetLookupTableName (const char *)
virtual char * | GetLookupTableName ()
virtual void | SetFieldDataName (const char *)
virtual char * | GetFieldDataName ()

Static Public Methods

vtkDataWriter * | New ()

Protected Methods

vtkDataWriter ()
~vtkDataWriter ()
void | WriteData ()
int | WriteArray (ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp)
int | WriteScalarData (ostream *fp, vtkDataArray *s, int num)
int | WriteVectorData (ostream *fp, vtkDataArray *v, int num)
int | WriteNormalData (ostream *fp, vtkDataArray *n, int num)
int | WriteTCoordData (ostream *fp, vtkDataArray *tc, int num)
int | WriteTensorData (ostream *fp, vtkDataArray *t, int num)

Protected Attributes

int | WriteToOutputString
char * | OutputString
int | OutputStringLength
int | OutputStringAllocatedLength
char * | FileName
char * | Header
int | FileType
char * | ScalarsName
char * | VectorsName
char * | TensorsName
char * | TCoordsName
char * | NormalsName
char * | LookupTableName
char * | FieldDataName

Detailed Description

helper class for objects that write vtk data files.

Date:
2002/01/22 15:38:11
Revision:
1.52

vtkDataWriter is a helper class that opens and writes the vtk header and point data (e.g., scalars, vectors, normals, etc.) from a vtk data file. See text for various formats.

See also:
vtkDataSetWriter vtkPolyDataWriter vtkStructuredGridWriter vtkStructuredPointsWriter vtkUnstructuredGridWriter vtkFieldDataWriter vtkRectilinearGridWriter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (29%)
  • Lorensen, Bill (8%)
  • Geveci, Berk (7%)
  • Law, Charles (5%)

Definition at line 53 of file vtkDataWriter.h.

Constructor & Destructor Documentation

vtkDataWriter::vtkDataWriter ( ) [protected]

vtkDataWriter::~vtkDataWriter ( ) [protected]

Member Function Documentation

vtkDataWriter::vtkTypeRevisionMacro | ( | vtkDataWriter | ,
 |  | vtkWriter |
 | ) |

Reimplemented from vtkWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataSetWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkSTLWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, vtkUnstructuredGridWriter, and vtkPDataSetWriter.

void vtkDataWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataSetWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, vtkUnstructuredGridWriter, and vtkPDataSetWriter.

vtkDataWriter* vtkDataWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkProcessObject.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataSetWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkSTLWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, vtkUnstructuredGridWriter, and vtkPDataSetWriter.

virtual void vtkDataWriter::SetFileName ( const char * ) [virtual]

Specify file name of vtk polygon data file to write.

virtual char* vtkDataWriter::GetFileName ( ) [virtual]

Specify file name of vtk polygon data file to write.

virtual void vtkDataWriter::SetWriteToOutputString ( int ) [virtual]

Enable writing to an OutputString instead of the default, a file.

virtual int vtkDataWriter::GetWriteToOutputString ( ) [virtual]

Enable writing to an OutputString instead of the default, a file.

virtual void vtkDataWriter::WriteToOutputStringOn ( ) [virtual]

Enable writing to an OutputString instead of the default, a file.

virtual void vtkDataWriter::WriteToOutputStringOff ( ) [virtual]

Enable writing to an OutputString instead of the default, a file.

virtual int vtkDataWriter::GetOutputStringLength ( ) [virtual]

When WriteToOutputString in on, then a string is allocated, written to, and can be retrieved with these methods. The string is deleted during the next call to write ...

virtual char* vtkDataWriter::GetOutputString ( ) [virtual]

When WriteToOutputString in on, then a string is allocated, written to, and can be retrieved with these methods. The string is deleted during the next call to write ...

unsigned char* vtkDataWriter::GetBinaryOutputString ( ) [inline]

When WriteToOutputString in on, then a string is allocated, written to, and can be retrieved with these methods. The string is deleted during the next call to write ...

Definition at line 82 of file vtkDataWriter.h.

char* vtkDataWriter::RegisterAndGetOutputString ( )

This convenience method returns the string, sets the IVAR to NULL, so that the user is responsible for deleting the string. I am not sure what the name should be, so it may change in the future.

virtual void vtkDataWriter::SetHeader ( const char * ) [virtual]

Specify the header for the vtk data file.

virtual char* vtkDataWriter::GetHeader ( ) [virtual]

Specify the header for the vtk data file.

virtual void vtkDataWriter::SetFileType ( int ) [virtual]

Specify file type (ASCII or BINARY) for vtk data file.

virtual int vtkDataWriter::GetFileType ( ) [virtual]

Specify file type (ASCII or BINARY) for vtk data file.

void vtkDataWriter::SetFileTypeToASCII ( ) [inline]

Specify file type (ASCII or BINARY) for vtk data file.

Definition at line 101 of file vtkDataWriter.h.

void vtkDataWriter::SetFileTypeToBinary ( ) [inline]

Specify file type (ASCII or BINARY) for vtk data file.

Definition at line 102 of file vtkDataWriter.h.

virtual void vtkDataWriter::SetScalarsName ( const char * ) [virtual]

Give a name to the scalar data. If not specified, uses default name "scalars".

virtual char* vtkDataWriter::GetScalarsName ( ) [virtual]

Give a name to the scalar data. If not specified, uses default name "scalars".

virtual void vtkDataWriter::SetVectorsName ( const char * ) [virtual]

Give a name to the vector data. If not specified, uses default name "vectors".

virtual char* vtkDataWriter::GetVectorsName ( ) [virtual]

Give a name to the vector data. If not specified, uses default name "vectors".

virtual void vtkDataWriter::SetTensorsName ( const char * ) [virtual]

Give a name to the tensors data. If not specified, uses default name "tensors".

virtual char* vtkDataWriter::GetTensorsName ( ) [virtual]

Give a name to the tensors data. If not specified, uses default name "tensors".

virtual void vtkDataWriter::SetNormalsName ( const char * ) [virtual]

Give a name to the normals data. If not specified, uses default name "normals".

virtual char* vtkDataWriter::GetNormalsName ( ) [virtual]

Give a name to the normals data. If not specified, uses default name "normals".

virtual void vtkDataWriter::SetTCoordsName ( const char * ) [virtual]

Give a name to the texture coordinates data. If not specified, uses default name "textureCoords".

virtual char* vtkDataWriter::GetTCoordsName ( ) [virtual]

Give a name to the texture coordinates data. If not specified, uses default name "textureCoords".

virtual void vtkDataWriter::SetLookupTableName ( const char * ) [virtual]

Give a name to the lookup table. If not specified, uses default name "lookupTable".

virtual char* vtkDataWriter::GetLookupTableName ( ) [virtual]

Give a name to the lookup table. If not specified, uses default name "lookupTable".

virtual void vtkDataWriter::SetFieldDataName ( const char * ) [virtual]

Give a name to the field data. If not specified, uses default name "field".

virtual char* vtkDataWriter::GetFieldDataName ( ) [virtual]

Give a name to the field data. If not specified, uses default name "field".

virtual ostream* vtkDataWriter::OpenVTKFile ( ) [virtual]

Open a vtk data file. Returns NULL if error.

int vtkDataWriter::WriteHeader ( ostream * fp )

Write the header of a vtk data file. Returns 0 if error.

int vtkDataWriter::WritePoints | ( | ostream * | fp,
 |  | vtkPoints * | p
 | ) |

Write out the points of the data set.

int vtkDataWriter::WriteCoordinates | ( | ostream * | fp,
 |  | vtkDataArray * | coords,
 |  | int | axes
 | ) |

Write out coordinates for rectilinear grids.

int vtkDataWriter::WriteCells | ( | ostream * | fp,
 |  | vtkCellArray * | cells,
 |  | const char * | label
 | ) |

Write out the cells of the data set.

int vtkDataWriter::WriteCellData | ( | ostream * | fp,
 |  | vtkDataSet * | ds
 | ) |

Write the cell data (e.g., scalars, vectors, ...) of a vtk dataset. Returns 0 if error.

int vtkDataWriter::WritePointData | ( | ostream * | fp,
 |  | vtkDataSet * | ds
 | ) |

Write the point data (e.g., scalars, vectors, ...) of a vtk dataset. Returns 0 if error.

int vtkDataWriter::WriteFieldData | ( | ostream * | fp,
 |  | vtkFieldData * | f
 | ) |

Write out the field data.

int vtkDataWriter::WriteDataSetData | ( | ostream * | fp,
 |  | vtkDataSet * | ds
 | ) |

Write out the data associated with the dataset (i.e. field data owned by the dataset itself - distinct from that owned by the cells or points).

void vtkDataWriter::CloseVTKFile ( ostream * fp )

Close a vtk file.

void vtkDataWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataSetWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkSTLWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, and vtkUnstructuredGridWriter.

int vtkDataWriter::WriteArray | ( | ostream * | fp,
 |  | int | dataType,
 |  | vtkDataArray * | data,
 |  | const char * | format,
 |  | int | num,
 |  | int | numComp
 | ) | [protected]

int vtkDataWriter::WriteScalarData | ( | ostream * | fp,
 |  | vtkDataArray * | s,
 |  | int | num
 | ) | [protected]

int vtkDataWriter::WriteVectorData | ( | ostream * | fp,
 |  | vtkDataArray * | v,
 |  | int | num
 | ) | [protected]

int vtkDataWriter::WriteNormalData | ( | ostream * | fp,
 |  | vtkDataArray * | n,
 |  | int | num
 | ) | [protected]

int vtkDataWriter::WriteTCoordData | ( | ostream * | fp,
 |  | vtkDataArray * | tc,
 |  | int | num
 | ) | [protected]

int vtkDataWriter::WriteTensorData | ( | ostream * | fp,
 |  | vtkDataArray * | t,
 |  | int | num
 | ) | [protected]

Member Data Documentation

int vtkDataWriter::WriteToOutputString [protected]

Definition at line 193 of file vtkDataWriter.h.

char* vtkDataWriter::OutputString [protected]

Definition at line 194 of file vtkDataWriter.h.

int vtkDataWriter::OutputStringLength [protected]

Definition at line 195 of file vtkDataWriter.h.

int vtkDataWriter::OutputStringAllocatedLength [protected]

Definition at line 196 of file vtkDataWriter.h.

char* vtkDataWriter::FileName [protected]

Definition at line 200 of file vtkDataWriter.h.

char* vtkDataWriter::Header [protected]

Definition at line 201 of file vtkDataWriter.h.

int vtkDataWriter::FileType [protected]

Definition at line 202 of file vtkDataWriter.h.

char* vtkDataWriter::ScalarsName [protected]

Definition at line 204 of file vtkDataWriter.h.

char* vtkDataWriter::VectorsName [protected]

Definition at line 205 of file vtkDataWriter.h.

char* vtkDataWriter::TensorsName [protected]

Definition at line 206 of file vtkDataWriter.h.

char* vtkDataWriter::TCoordsName [protected]

Definition at line 207 of file vtkDataWriter.h.

char* vtkDataWriter::NormalsName [protected]

Definition at line 208 of file vtkDataWriter.h.

char* vtkDataWriter::LookupTableName [protected]

Definition at line 209 of file vtkDataWriter.h.

char* vtkDataWriter::FieldDataName [protected]

Definition at line 210 of file vtkDataWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkDataWriter.h
Generated on Mon Mar 25 01:17:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDebugLeaks Class Reference

identify memory leaks at program termination. More...

#include <vtkDebugLeaks.h>

Inheritance diagram for vtkDebugLeaks:

[legend]
Collaboration diagram for vtkDebugLeaks:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDebugLeaks, vtkObject)

Static Public Methods

vtkDebugLeaks * | New ()
void | ConstructClass (const char *classname)
void | DestructClass (const char *classname)
void | PrintCurrentLeaks ()
void | DeleteTable ()
void | PromptUserOn ()
void | PromptUserOff ()

Protected Methods

vtkDebugLeaks ()
virtual | ~vtkDebugLeaks ()

Static Protected Attributes

int | PromptUser

Detailed Description

identify memory leaks at program termination.

Date:
2002/01/22 15:25:19
Revision:
1.14

vtkDebugLeaks is used to report memory leaks at the exit of the program. It uses the vtkObjectFactory to intercept the construction of all VTK objects. It uses the UnRegister method of vtkObject to intercept the destruction of all objects. A table of object name to number of instances is kept. At the exit of the program if there are still VTK objects around it will print them out. To enable this class add the flag -DVTK_DEBUG_LEAKS to the compile line, and rebuild vtkObject and vtkObjectFactory.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (67%)
  • Schroeder, Will (11%)
  • Lorensen, Bill (10%)
  • Geveci, Berk (6%)
Tests:
vtkDebugLeaks (Tests)

Definition at line 52 of file vtkDebugLeaks.h.

Constructor & Destructor Documentation

vtkDebugLeaks::vtkDebugLeaks ( ) [inline, protected]

Definition at line 77 of file vtkDebugLeaks.h.

virtual vtkDebugLeaks::~vtkDebugLeaks ( ) [inline, protected, virtual]

Definition at line 78 of file vtkDebugLeaks.h.

Member Function Documentation

vtkDebugLeaks* vtkDebugLeaks::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkDebugLeaks::vtkTypeRevisionMacro | ( | vtkDebugLeaks | ,
 |  | vtkObject |
 | ) |

void vtkDebugLeaks::ConstructClass ( const char * classname ) [static]

Call this when creating a class of a given name.

Referenced by vtkDirectory::New().

void vtkDebugLeaks::DestructClass ( const char * classname ) [static]

Call this when deleting a class of a given name.

void vtkDebugLeaks::PrintCurrentLeaks ( ) [static]

Print all the values in the table.

void vtkDebugLeaks::DeleteTable ( ) [static]

Clean up the table memory.

void vtkDebugLeaks::PromptUserOn ( ) [static]

Turn prompt at exit on/off.

void vtkDebugLeaks::PromptUserOff ( ) [static]

Turn prompt at exit on/off.

Member Data Documentation

int vtkDebugLeaks::PromptUser [static, protected]

Definition at line 80 of file vtkDebugLeaks.h.

The documentation for this class was generated from the following file:
  • Common/vtkDebugLeaks.h
Generated on Mon Mar 25 01:17:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDecimate Class Reference

reduce the number of triangles in a mesh. More...

#include <vtkDecimate.h>

Inheritance diagram for vtkDecimate:

[legend]
Collaboration diagram for vtkDecimate:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDecimate, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInitialError (float)
virtual float | GetInitialError ()
virtual void | SetErrorIncrement (float)
virtual float | GetErrorIncrement ()
virtual void | SetMaximumError (float)
virtual float | GetMaximumError ()
virtual void | SetTargetReduction (float)
virtual float | GetTargetReduction ()
virtual void | SetMaximumIterations (int)
virtual int | GetMaximumIterations ()
virtual void | SetMaximumSubIterations (int)
virtual int | GetMaximumSubIterations ()
virtual void | SetInitialFeatureAngle (float)
virtual float | GetInitialFeatureAngle ()
virtual void | SetFeatureAngleIncrement (float)
virtual float | GetFeatureAngleIncrement ()
virtual void | SetMaximumFeatureAngle (float)
virtual float | GetMaximumFeatureAngle ()
virtual void | SetGenerateErrorScalars (int)
virtual int | GetGenerateErrorScalars ()
virtual void | GenerateErrorScalarsOn ()
virtual void | GenerateErrorScalarsOff ()
virtual void | SetPreserveEdges (int)
virtual int | GetPreserveEdges ()
virtual void | PreserveEdgesOn ()
virtual void | PreserveEdgesOff ()
virtual void | SetBoundaryVertexDeletion (int)
virtual int | GetBoundaryVertexDeletion ()
virtual void | BoundaryVertexDeletionOn ()
virtual void | BoundaryVertexDeletionOff ()
virtual void | SetAspectRatio (float)
virtual float | GetAspectRatio ()
virtual void | SetPreserveTopology (int)
virtual int | GetPreserveTopology ()
virtual void | PreserveTopologyOn ()
virtual void | PreserveTopologyOff ()
virtual void | SetDegree (int)
virtual int | GetDegree ()
virtual void | SetMaximumNumberOfSquawks (int)
virtual int | GetMaximumNumberOfSquawks ()

Static Public Methods

vtkDecimate * | New ()

Protected Methods

vtkDecimate ()
~vtkDecimate ()
void | Execute ()
void | CreateOutput (vtkIdType numPts, vtkIdType numTris, vtkIdType numEliminated, vtkPointData *pd, vtkPoints *inPts)
int | BuildLoop (vtkIdType ptId, unsigned short int nTris, vtkIdType *tris)
void | EvaluateLoop (int &vtype, vtkIdType &numFEdges, vtkLocalVertexPtr fedges[])
int | CanSplitLoop (vtkLocalVertexPtr fedges[2], vtkIdType numVerts, vtkLocalVertexPtr verts[], vtkIdType &n1, vtkLocalVertexPtr l1[], vtkIdType &n2, vtkLocalVertexPtr l2[], float &ar)
void | SplitLoop (vtkLocalVertexPtr fedges[2], vtkIdType numVerts, vtkLocalVertexPtr *verts, vtkIdType &n1, vtkLocalVertexPtr *l1, vtkIdType &n2, vtkLocalVertexPtr *l2)
void | Triangulate (vtkIdType numVerts, vtkLocalVertexPtr verts[])
int | CheckError ()

Protected Attributes

float | InitialFeatureAngle
float | FeatureAngleIncrement
float | MaximumFeatureAngle
int | PreserveEdges
int | BoundaryVertexDeletion
float | InitialError
float | ErrorIncrement
float | MaximumError
float | TargetReduction
int | MaximumIterations
int | MaximumSubIterations
float | AspectRatio
int | Degree
int | Stats [VTK_NUMBER_STATISTICS]
int | GenerateErrorScalars
int | MaximumNumberOfSquawks
int | PreserveTopology
vtkIdList * Neighbors
vtkVertexArray * V
vtkTriArray * T

Detailed Description

reduce the number of triangles in a mesh.

Date:
2002/01/22 22:02:16
Revision:
1.56

vtkDecimate is a filter to reduce the number of triangles in a triangle mesh, while preserving the original topology and a forming good approximation to the original geometry. The input to vtkDecimate is a vtkPolyData object, and only triangles are treated. If you desire to decimate polygonal meshes, first triangulate the polygons with the vtkTriangleFilter object.

The algorithm proceeds as follows. Each vertex in the triangle list is evaluated for local planarity (i.e., the triangles using the vertex are gathered and compared to an "average" plane). If the region is locally planar, that is if the target vertex is within a certain distance of the average plane (i.e., the error), and there are no edges radiating from the vertex that have a dihedral angle greater than a user-specified edge angle (i.e., feature angle), and topology is not altered, then that vertex is deleted. The resulting hole is then patched by re-triangulation. The process continues over the entire vertex list (this constitutes an iteration). Iterations proceed until a target reduction is reached or a maximum iteration count is exceeded.

There are a number of additional parameters you can set to control the decimation algorithm. The Error ivar may be increased over each iteration with the ErrorIncrement. (These two variables have the largest effect.) Edge preservation (i.e., PreserveEdges ivar) may be disabled or enabled. You can turn on/off edge vertex deletion (i.e., BoundaryVertexDeletion ivar). (Edge vertices are vertices that lie along boundaries of meshes.) Sub iterations are iterations that are performed without changing the decimation criterion. The AspectRatio ivar controls the shape of the triangles that are created, and is the ratio of maximum edge length to minimum edge length. The Degree is the number of triangles using a single vertex. Vertices of high degree are considered "complex" and are never deleted.

Warning:
This implementation has been adapted for a global error bound decimation criterion. That is, the error is a global bound on distance to original surface. This is an improvement over the original Siggraph paper ("Decimation of Triangle Meshes", Proc Siggraph `92.)
Warning:
The algorithm has been extended with a special flag to allow topology modification. When the PreserveTopology flag is on, then the algorithm will preserve the topology of the original mesh. If off, the algorithm may close holes and/or collapse tunnels (i.e., form non-manifold attachments).
See also:
vtkDecimatePro vtkQuadricClustering vtkQuadricDecimation
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Law, Charles (7%)
  • Lorensen, Bill (7%)
  • Henderson, Amy (5%)
Tests:
vtkDecimate (Tests)

Definition at line 181 of file vtkDecimate.h.

Constructor & Destructor Documentation

vtkDecimate::vtkDecimate ( ) [protected]

vtkDecimate::~vtkDecimate ( ) [protected]

Member Function Documentation

vtkDecimate* vtkDecimate::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkDecimate::vtkTypeRevisionMacro | ( | vtkDecimate | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkDecimate::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkDecimate::SetInitialError ( float ) [virtual]

Set the decimation error bounds. Expressed as a fraction of the longest side of the input data's bounding box.

virtual float vtkDecimate::GetInitialError ( ) [virtual]

Set the decimation error bounds. Expressed as a fraction of the longest side of the input data's bounding box.

virtual void vtkDecimate::SetErrorIncrement ( float ) [virtual]

Set the value of the increment by which to increase the decimation error after each iteration.

virtual float vtkDecimate::GetErrorIncrement ( ) [virtual]

Set the value of the increment by which to increase the decimation error after each iteration.

virtual void vtkDecimate::SetMaximumError ( float ) [virtual]

Set the largest decimation error that can be achieved by incrementing the error.

virtual float vtkDecimate::GetMaximumError ( ) [virtual]

Set the largest decimation error that can be achieved by incrementing the error.

virtual void vtkDecimate::SetTargetReduction ( float ) [virtual]

Specify the desired reduction in the total number of polygons. Because of various constraints, this level of reduction may not be realizable.

virtual float vtkDecimate::GetTargetReduction ( ) [virtual]

Specify the desired reduction in the total number of polygons. Because of various constraints, this level of reduction may not be realizable.

virtual void vtkDecimate::SetMaximumIterations ( int ) [virtual]

Specify the maximum number of iterations to attempt. If decimation target is reached first, this value will not be reached.

virtual int vtkDecimate::GetMaximumIterations ( ) [virtual]

Specify the maximum number of iterations to attempt. If decimation target is reached first, this value will not be reached.

virtual void vtkDecimate::SetMaximumSubIterations ( int ) [virtual]

Specify the maximum sub-iterations to perform. If no triangles are deleted in a sub-iteration, the sub-iteration process is stopped.

virtual int vtkDecimate::GetMaximumSubIterations ( ) [virtual]

Specify the maximum sub-iterations to perform. If no triangles are deleted in a sub-iteration, the sub-iteration process is stopped.

virtual void vtkDecimate::SetInitialFeatureAngle ( float ) [virtual]

Specify the mesh feature angles.

virtual float vtkDecimate::GetInitialFeatureAngle ( ) [virtual]

Specify the mesh feature angles.

virtual void vtkDecimate::SetFeatureAngleIncrement ( float ) [virtual]

Set/Get the angle by which to increase feature angle over each iteration.

virtual float vtkDecimate::GetFeatureAngleIncrement ( ) [virtual]

Set/Get the angle by which to increase feature angle over each iteration.

virtual void vtkDecimate::SetMaximumFeatureAngle ( float ) [virtual]

Set the largest permissible feature angle.

virtual float vtkDecimate::GetMaximumFeatureAngle ( ) [virtual]

Set the largest permissible feature angle.

virtual void vtkDecimate::SetGenerateErrorScalars ( int ) [virtual]

Turn on/off the generation of error scalars.

virtual int vtkDecimate::GetGenerateErrorScalars ( ) [virtual]

Turn on/off the generation of error scalars.

virtual void vtkDecimate::GenerateErrorScalarsOn ( ) [virtual]

Turn on/off the generation of error scalars.

virtual void vtkDecimate::GenerateErrorScalarsOff ( ) [virtual]

Turn on/off the generation of error scalars.

virtual void vtkDecimate::SetPreserveEdges ( int ) [virtual]

Turn on/off the preservation of feature edges.

virtual int vtkDecimate::GetPreserveEdges ( ) [virtual]

Turn on/off the preservation of feature edges.

virtual void vtkDecimate::PreserveEdgesOn ( ) [virtual]

Turn on/off the preservation of feature edges.

virtual void vtkDecimate::PreserveEdgesOff ( ) [virtual]

Turn on/off the preservation of feature edges.

virtual void vtkDecimate::SetBoundaryVertexDeletion ( int ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh.

virtual int vtkDecimate::GetBoundaryVertexDeletion ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh.

virtual void vtkDecimate::BoundaryVertexDeletionOn ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh.

virtual void vtkDecimate::BoundaryVertexDeletionOff ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh.

virtual void vtkDecimate::SetAspectRatio ( float ) [virtual]

Specify the maximum allowable aspect ratio during triangulation.

virtual float vtkDecimate::GetAspectRatio ( ) [virtual]

Specify the maximum allowable aspect ratio during triangulation.

virtual void vtkDecimate::SetPreserveTopology ( int ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If off, hole elimination and non-manifold attachment can occur.

virtual int vtkDecimate::GetPreserveTopology ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If off, hole elimination and non-manifold attachment can occur.

virtual void vtkDecimate::PreserveTopologyOn ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If off, hole elimination and non-manifold attachment can occur.

virtual void vtkDecimate::PreserveTopologyOff ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If off, hole elimination and non-manifold attachment can occur.

virtual void vtkDecimate::SetDegree ( int ) [virtual]

If the number of triangles connected to a vertex exceeds "Degree", then the vertex is considered complex and is never deleted. (NOTE: the complexity of the triangulation algorithm is proportional to Degree^2.)

virtual int vtkDecimate::GetDegree ( ) [virtual]

If the number of triangles connected to a vertex exceeds "Degree", then the vertex is considered complex and is never deleted. (NOTE: the complexity of the triangulation algorithm is proportional to Degree^2.)

virtual void vtkDecimate::SetMaximumNumberOfSquawks ( int ) [virtual]

Control the printout of warnings. This flag limits the number of warnings regarding non-manifold geometry and complex vertices. If set to zero, no warnings will appear.

virtual int vtkDecimate::GetMaximumNumberOfSquawks ( ) [virtual]

Control the printout of warnings. This flag limits the number of warnings regarding non-manifold geometry and complex vertices. If set to zero, no warnings will appear.

void vtkDecimate::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDecimate::CreateOutput | ( | vtkIdType | numPts,
 |  | vtkIdType | numTris,
 |  | vtkIdType | numEliminated,
 |  | vtkPointData * | pd,
 |  | vtkPoints * | inPts
 | ) | [protected]

int vtkDecimate::BuildLoop | ( | vtkIdType | ptId,
 |  | unsigned short int | nTris,
 |  | vtkIdType * | tris
 | ) | [protected]

void vtkDecimate::EvaluateLoop | ( | int & | vtype,
 |  | vtkIdType & | numFEdges,
 |  | vtkLocalVertexPtr | fedges[]
 | ) | [protected]

int vtkDecimate::CanSplitLoop | ( | vtkLocalVertexPtr | fedges[2],
 |  | vtkIdType | numVerts,
 |  | vtkLocalVertexPtr | verts[],
 |  | vtkIdType & | n1,
 |  | vtkLocalVertexPtr | l1[],
 |  | vtkIdType & | n2,
 |  | vtkLocalVertexPtr | l2[],
 |  | float & | ar
 | ) | [protected]

void vtkDecimate::SplitLoop | ( | vtkLocalVertexPtr | fedges[2],
 |  | vtkIdType | numVerts,
 |  | vtkLocalVertexPtr * | verts,
 |  | vtkIdType & | n1,
 |  | vtkLocalVertexPtr * | l1,
 |  | vtkIdType & | n2,
 |  | vtkLocalVertexPtr * | l2
 | ) | [protected]

void vtkDecimate::Triangulate | ( | vtkIdType | numVerts,
 |  | vtkLocalVertexPtr | verts[]
 | ) | [protected]

int vtkDecimate::CheckError ( ) [protected]

Member Data Documentation

float vtkDecimate::InitialFeatureAngle [protected]

Definition at line 308 of file vtkDecimate.h.

float vtkDecimate::FeatureAngleIncrement [protected]

Definition at line 309 of file vtkDecimate.h.

float vtkDecimate::MaximumFeatureAngle [protected]

Definition at line 310 of file vtkDecimate.h.

int vtkDecimate::PreserveEdges [protected]

Definition at line 311 of file vtkDecimate.h.

int vtkDecimate::BoundaryVertexDeletion [protected]

Definition at line 312 of file vtkDecimate.h.

float vtkDecimate::InitialError [protected]

Definition at line 313 of file vtkDecimate.h.

float vtkDecimate::ErrorIncrement [protected]

Definition at line 314 of file vtkDecimate.h.

float vtkDecimate::MaximumError [protected]

Definition at line 315 of file vtkDecimate.h.

float vtkDecimate::TargetReduction [protected]

Definition at line 316 of file vtkDecimate.h.

int vtkDecimate::MaximumIterations [protected]

Definition at line 317 of file vtkDecimate.h.

int vtkDecimate::MaximumSubIterations [protected]

Definition at line 318 of file vtkDecimate.h.

float vtkDecimate::AspectRatio [protected]

Definition at line 319 of file vtkDecimate.h.

int vtkDecimate::Degree [protected]

Definition at line 320 of file vtkDecimate.h.

int vtkDecimate::Stats[VTK_NUMBER_STATISTICS] [protected]

Definition at line 321 of file vtkDecimate.h.

int vtkDecimate::GenerateErrorScalars [protected]

Definition at line 322 of file vtkDecimate.h.

int vtkDecimate::MaximumNumberOfSquawks [protected]

Definition at line 323 of file vtkDecimate.h.

int vtkDecimate::PreserveTopology [protected]

Definition at line 324 of file vtkDecimate.h.

vtkIdList* vtkDecimate::Neighbors [protected]

Definition at line 325 of file vtkDecimate.h.

vtkVertexArray* vtkDecimate::V [protected]

Definition at line 326 of file vtkDecimate.h.

vtkTriArray* vtkDecimate::T [protected]

Definition at line 327 of file vtkDecimate.h.

The documentation for this class was generated from the following file:
  • Patented/vtkDecimate.h
Generated on Mon Mar 25 01:17:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDecimatePro Class Reference

reduce the number of triangles in a mesh. More...

#include <vtkDecimatePro.h>

Inheritance diagram for vtkDecimatePro:

[legend]
Collaboration diagram for vtkDecimatePro:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDecimatePro, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkIdType GetNumberOfInflectionPoints ()
void | GetInflectionPoints (float *inflectionPoints)
float * | GetInflectionPoints ()
virtual void | SetTargetReduction (float)
virtual float | GetTargetReduction ()
virtual void | SetPreserveTopology (int)
virtual int | GetPreserveTopology ()
virtual void | PreserveTopologyOn ()
virtual void | PreserveTopologyOff ()
virtual void | SetFeatureAngle (float)
virtual float | GetFeatureAngle ()
virtual void | SetSplitting (int)
virtual int | GetSplitting ()
virtual void | SplittingOn ()
virtual void | SplittingOff ()
virtual void | SetSplitAngle (float)
virtual float | GetSplitAngle ()
virtual void | SetPreSplitMesh (int)
virtual int | GetPreSplitMesh ()
virtual void | PreSplitMeshOn ()
virtual void | PreSplitMeshOff ()
virtual void | SetMaximumError (float)
virtual float | GetMaximumError ()
virtual void | SetAccumulateError (int)
virtual int | GetAccumulateError ()
virtual void | AccumulateErrorOn ()
virtual void | AccumulateErrorOff ()
virtual void | SetErrorIsAbsolute (int)
virtual int | GetErrorIsAbsolute ()
virtual void | SetAbsoluteError (float)
virtual float | GetAbsoluteError ()
virtual void | SetBoundaryVertexDeletion (int)
virtual int | GetBoundaryVertexDeletion ()
virtual void | BoundaryVertexDeletionOn ()
virtual void | BoundaryVertexDeletionOff ()
virtual void | SetDegree (int)
virtual int | GetDegree ()
virtual void | SetInflectionPointRatio (float)
virtual float | GetInflectionPointRatio ()

Static Public Methods

vtkDecimatePro * | New ()

Protected Methods

vtkDecimatePro ()
~vtkDecimatePro ()
void | Execute ()
void | SplitMesh ()
int | EvaluateVertex (vtkIdType ptId, unsigned short int numTris, vtkIdType *tris, vtkIdType fedges[2])
vtkIdType | FindSplit (int type, vtkIdType fedges[2], vtkIdType &pt1, vtkIdType &pt2, vtkIdList *CollapseTris)
int | IsValidSplit (int index)
void | SplitLoop (vtkIdType fedges[2], vtkIdType &n1, vtkIdType *l1, vtkIdType &n2, vtkIdType *l2)
void | SplitVertex (vtkIdType ptId, int type, unsigned short int numTris, vtkIdType *tris, int insert)
int | CollapseEdge (int type, vtkIdType ptId, vtkIdType collapseId, vtkIdType pt1, vtkIdType pt2, vtkIdList *CollapseTris)
void | DistributeError (float error)

Protected Attributes

float | TargetReduction
float | FeatureAngle
float | MaximumError
float | AbsoluteError
int | ErrorIsAbsolute
int | AccumulateError
float | SplitAngle
int | Splitting
int | PreSplitMesh
int | BoundaryVertexDeletion
int | PreserveTopology
int | Degree
float | InflectionPointRatio
vtkFloatArray * InflectionPoints
vtkIdList * Neighbors
vtkPriorityQueue * EdgeLengths

Detailed Description

reduce the number of triangles in a mesh.

Date:
2002/01/22 15:29:16
Revision:
1.51

vtkDecimatePro is a filter to reduce the number of triangles in a triangle mesh, forming a good approximation to the original geometry. The input to vtkDecimatePro is a vtkPolyData object, and only triangles are treated. If you desire to decimate polygonal meshes, first triangulate the polygons with vtkTriangleFilter object.

The implementation of vtkDecimatePro is similar to the algorithm originally described in "Decimation of Triangle Meshes", Proc Siggraph `92, with three major differences. First, this algorithm does not necessarily preserve the topology of the mesh. Second, it is guaranteed to give the a mesh reduction factor specified by the user (as long as certain constraints are not set - see Caveats). Third, it is set up generate progressive meshes, that is a stream of operations that can be easily transmitted and incrementally updated (see Hugues Hoppe's Siggraph '96 paper on progressive meshes).

The algorithm proceeds as follows. Each vertex in the mesh is classified and inserted into a priority queue. The priority is based on the error to delete the vertex and retriangulate the hole. Vertices that cannot be deleted or triangulated (at this point in the algorithm) are skipped. Then, each vertex in the priority queue is processed (i.e., deleted followed by hole triangulation using edge collapse). This continues until the priority queue is empty. Next, all remaining vertices are processed, and the mesh is split into separate pieces along sharp edges or at non-manifold attachment points and reinserted into the priority queue. Again, the priority queue is processed until empty. If the desired reduction is still not achieved, the remaining vertices are split as necessary (in a recursive fashion) so that it is possible to eliminate every triangle as necessary.

To use this object, at a minimum you need to specify the ivar TargetReduction. The algorithm is guaranteed to generate a reduced mesh at this level as long as the following four conditions are met: 1) topology modification is allowed (i.e., the ivar PreserveTopology is off); 2) mesh splitting is enabled (i.e., the ivar Splitting is on); 3) the algorithm is allowed to modify the boundary of the mesh (i.e., the ivar BoundaryVertexDeletion is on); and 4) the maximum allowable error (i.e., the ivar MaximumError) is set to VTK_LARGE_FLOAT. Other important parameters to adjust include the FeatureAngle and SplitAngle ivars, since these can impact the quality of the final mesh. Also, you can set the ivar AccumulateError to force incremental error update and distribution to surrounding vertices as each vertex is deleted. The accumulated error is a conservative global error bounds and decimation error, but requires additional memory and time to compute.

Warning:
To guarantee a given level of reduction, the ivar PreserveTopology must be off; the ivar Splitting is on; the ivar BoundaryVertexDeletion is on; and the ivar MaximumError is set to VTK_LARGE_FLOAT.
Warning:
If PreserveTopology is off, and SplitEdges is off; the mesh topology may be modified by closing holes.
Warning:
Once mesh splitting begins, the feature angle is set to the split angle.
See also:
vtkDecimate vtkQuadricClustering vtkQuadricDecimation
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Lorensen, Bill (10%)
  • Henderson, Amy (5%)
Examples:
vtkDecimatePro (Examples)
Tests:
vtkDecimatePro (Tests)

Definition at line 169 of file vtkDecimatePro.h.

Constructor & Destructor Documentation

vtkDecimatePro::vtkDecimatePro ( ) [protected]

vtkDecimatePro::~vtkDecimatePro ( ) [protected]

Member Function Documentation

vtkDecimatePro::vtkTypeRevisionMacro | ( | vtkDecimatePro | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkDecimatePro::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkDecimatePro* vtkDecimatePro::New ( ) [static]

Create object with specified reduction of 90% and feature angle of 15 degrees. Edge splitting is on, defer splitting is on, and the split angle is 75 degrees. Topology preservation is off, delete boundary vertices is on, and the maximum error is set to VTK_LARGE_FLOAT. The inflection point ratio is 10 and the vertex degree is 25. Error accumulation is turned off.

Reimplemented from vtkPolyDataSource.

virtual void vtkDecimatePro::SetTargetReduction ( float ) [virtual]

Specify the desired reduction in the total number of polygons. Because of various constraints, this level of reduction may not be realized. If you want to guarantee a particular reduction, you must turn off PreserveTopology and BoundaryVertexDeletion, turn on SplitEdges, and set the MaximumError to VTK_LARGE_FLOAT (these ivars are initialized this way when the object is instantiated).

virtual float vtkDecimatePro::GetTargetReduction ( ) [virtual]

Specify the desired reduction in the total number of polygons. Because of various constraints, this level of reduction may not be realized. If you want to guarantee a particular reduction, you must turn off PreserveTopology and BoundaryVertexDeletion, turn on SplitEdges, and set the MaximumError to VTK_LARGE_FLOAT (these ivars are initialized this way when the object is instantiated).

virtual void vtkDecimatePro::SetPreserveTopology ( int ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If on, mesh splitting and hole elimination will not occur. This may limit the maximum reduction that may be achieved.

virtual int vtkDecimatePro::GetPreserveTopology ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If on, mesh splitting and hole elimination will not occur. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::PreserveTopologyOn ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If on, mesh splitting and hole elimination will not occur. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::PreserveTopologyOff ( ) [virtual]

Turn on/off whether to preserve the topology of the original mesh. If on, mesh splitting and hole elimination will not occur. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::SetFeatureAngle ( float ) [virtual]

Specify the mesh feature angle. This angle is used to define what an edge is (i.e., if the surface normal between two adjacent triangles is >= FeatureAngle, an edge exists).

virtual float vtkDecimatePro::GetFeatureAngle ( ) [virtual]

Specify the mesh feature angle. This angle is used to define what an edge is (i.e., if the surface normal between two adjacent triangles is >= FeatureAngle, an edge exists).

virtual void vtkDecimatePro::SetSplitting ( int ) [virtual]

Turn on/off the splitting of the mesh at corners, along edges, at non-manifold points, or anywhere else a split is required. Turning splitting off will better preserve the original topology of the mesh, but you may not obtain the requested reduction.

virtual int vtkDecimatePro::GetSplitting ( ) [virtual]

Turn on/off the splitting of the mesh at corners, along edges, at non-manifold points, or anywhere else a split is required. Turning splitting off will better preserve the original topology of the mesh, but you may not obtain the requested reduction.

virtual void vtkDecimatePro::SplittingOn ( ) [virtual]

Turn on/off the splitting of the mesh at corners, along edges, at non-manifold points, or anywhere else a split is required. Turning splitting off will better preserve the original topology of the mesh, but you may not obtain the requested reduction.

virtual void vtkDecimatePro::SplittingOff ( ) [virtual]

Turn on/off the splitting of the mesh at corners, along edges, at non-manifold points, or anywhere else a split is required. Turning splitting off will better preserve the original topology of the mesh, but you may not obtain the requested reduction.

virtual void vtkDecimatePro::SetSplitAngle ( float ) [virtual]

Specify the mesh split angle. This angle is used to control the splitting of the mesh. A split line exists when the surface normals between two edge connected triangles are >= SplitAngle.

virtual float vtkDecimatePro::GetSplitAngle ( ) [virtual]

Specify the mesh split angle. This angle is used to control the splitting of the mesh. A split line exists when the surface normals between two edge connected triangles are >= SplitAngle.

virtual void vtkDecimatePro::SetPreSplitMesh ( int ) [virtual]

In some cases you may wish to split the mesh prior to algorithm execution. This separates the mesh into semi-planar patches, which are disconnected from each other. This can give superior results in some cases. If the ivar PreSplitMesh ivar is enabled, the mesh is split with the specified SplitAngle. Otherwise mesh splitting is deferred as long as possible.

virtual int vtkDecimatePro::GetPreSplitMesh ( ) [virtual]

In some cases you may wish to split the mesh prior to algorithm execution. This separates the mesh into semi-planar patches, which are disconnected from each other. This can give superior results in some cases. If the ivar PreSplitMesh ivar is enabled, the mesh is split with the specified SplitAngle. Otherwise mesh splitting is deferred as long as possible.

virtual void vtkDecimatePro::PreSplitMeshOn ( ) [virtual]

In some cases you may wish to split the mesh prior to algorithm execution. This separates the mesh into semi-planar patches, which are disconnected from each other. This can give superior results in some cases. If the ivar PreSplitMesh ivar is enabled, the mesh is split with the specified SplitAngle. Otherwise mesh splitting is deferred as long as possible.

virtual void vtkDecimatePro::PreSplitMeshOff ( ) [virtual]

In some cases you may wish to split the mesh prior to algorithm execution. This separates the mesh into semi-planar patches, which are disconnected from each other. This can give superior results in some cases. If the ivar PreSplitMesh ivar is enabled, the mesh is split with the specified SplitAngle. Otherwise mesh splitting is deferred as long as possible.

virtual void vtkDecimatePro::SetMaximumError ( float ) [virtual]

Set the largest decimation error that is allowed during the decimation process. This may limit the maximum reduction that may be achieved. The maximum error is specified as a fraction of the maximum length of the input data bounding box.

virtual float vtkDecimatePro::GetMaximumError ( ) [virtual]

Set the largest decimation error that is allowed during the decimation process. This may limit the maximum reduction that may be achieved. The maximum error is specified as a fraction of the maximum length of the input data bounding box.

virtual void vtkDecimatePro::SetAccumulateError ( int ) [virtual]

The computed error can either be computed directly from the mesh or the error may be accumulated as the mesh is modified. If the error is accumulated, then it represents a global error bounds, and the ivar MaximumError becomes a global bounds on mesh error. Accumulating the error requires extra memory proportional to the number of vertices in the mesh. If AccumulateError is off, then the error is not accumulated.

virtual int vtkDecimatePro::GetAccumulateError ( ) [virtual]

The computed error can either be computed directly from the mesh or the error may be accumulated as the mesh is modified. If the error is accumulated, then it represents a global error bounds, and the ivar MaximumError becomes a global bounds on mesh error. Accumulating the error requires extra memory proportional to the number of vertices in the mesh. If AccumulateError is off, then the error is not accumulated.

virtual void vtkDecimatePro::AccumulateErrorOn ( ) [virtual]

The computed error can either be computed directly from the mesh or the error may be accumulated as the mesh is modified. If the error is accumulated, then it represents a global error bounds, and the ivar MaximumError becomes a global bounds on mesh error. Accumulating the error requires extra memory proportional to the number of vertices in the mesh. If AccumulateError is off, then the error is not accumulated.

virtual void vtkDecimatePro::AccumulateErrorOff ( ) [virtual]

The computed error can either be computed directly from the mesh or the error may be accumulated as the mesh is modified. If the error is accumulated, then it represents a global error bounds, and the ivar MaximumError becomes a global bounds on mesh error. Accumulating the error requires extra memory proportional to the number of vertices in the mesh. If AccumulateError is off, then the error is not accumulated.

virtual void vtkDecimatePro::SetErrorIsAbsolute ( int ) [virtual]

The MaximumError is normally defined as a fraction of the dataset bounding diagonal. By setting ErrorIsAbsolute to 1, the error is instead defined as that specified by AbsoluteError. By default ErrorIsAbsolute=0.

virtual int vtkDecimatePro::GetErrorIsAbsolute ( ) [virtual]

The MaximumError is normally defined as a fraction of the dataset bounding diagonal. By setting ErrorIsAbsolute to 1, the error is instead defined as that specified by AbsoluteError. By default ErrorIsAbsolute=0.

virtual void vtkDecimatePro::SetAbsoluteError ( float ) [virtual]

Same as MaximumError, but to be used when ErrorIsAbsolute is 1

virtual float vtkDecimatePro::GetAbsoluteError ( ) [virtual]

Same as MaximumError, but to be used when ErrorIsAbsolute is 1

virtual void vtkDecimatePro::SetBoundaryVertexDeletion ( int ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh. This may limit the maximum reduction that may be achieved.

virtual int vtkDecimatePro::GetBoundaryVertexDeletion ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::BoundaryVertexDeletionOn ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::BoundaryVertexDeletionOff ( ) [virtual]

Turn on/off the deletion of vertices on the boundary of a mesh. This may limit the maximum reduction that may be achieved.

virtual void vtkDecimatePro::SetDegree ( int ) [virtual]

If the number of triangles connected to a vertex exceeds "Degree", then the vertex will be split. (NOTE: the complexity of the triangulation algorithm is proportional to Degree^2. Setting degree small can improve the performance of the algorithm.)

virtual int vtkDecimatePro::GetDegree ( ) [virtual]

If the number of triangles connected to a vertex exceeds "Degree", then the vertex will be split. (NOTE: the complexity of the triangulation algorithm is proportional to Degree^2. Setting degree small can improve the performance of the algorithm.)

virtual void vtkDecimatePro::SetInflectionPointRatio ( float ) [virtual]

Specify the inflection point ratio. An inflection point occurs when the ratio of reduction error between two iterations is greater than or equal to the InflectionPointRatio.

virtual float vtkDecimatePro::GetInflectionPointRatio ( ) [virtual]

Specify the inflection point ratio. An inflection point occurs when the ratio of reduction error between two iterations is greater than or equal to the InflectionPointRatio.

vtkIdType vtkDecimatePro::GetNumberOfInflectionPoints ( )

Get the number of inflection points. Only returns a valid value after the filter has executed. The values in the list are mesh reduction values at each inflection point. Note: the first inflection point always occurs right before non-planar triangles are decimated (i.e., as the error becomes non-zero).

void vtkDecimatePro::GetInflectionPoints ( float * inflectionPoints )

Get a list of inflection points. These are float values 0 < r <= 1.0 corresponding to reduction level, and there are a total of NumberOfInflectionPoints() values. You must provide an array (of the correct size) into which the inflection points are written.

float* vtkDecimatePro::GetInflectionPoints ( )

Get a list of inflection points. These are float values 0 < r <= 1.0 corresponding to reduction level, and there are a total of NumberOfInflectionPoints() values. You must provide an array (of the correct size) into which the inflection points are written. This method returns a pointer to a list of inflection points.

void vtkDecimatePro::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDecimatePro::SplitMesh ( ) [protected]

int vtkDecimatePro::EvaluateVertex | ( | vtkIdType | ptId,
 |  | unsigned short int | numTris,
 |  | vtkIdType * | tris,
 |  | vtkIdType | fedges[2]
 | ) | [protected]

vtkIdType vtkDecimatePro::FindSplit | ( | int | type,
 |  | vtkIdType | fedges[2],
 |  | vtkIdType & | pt1,
 |  | vtkIdType & | pt2,
 |  | vtkIdList * | CollapseTris
 | ) | [protected]

int vtkDecimatePro::IsValidSplit ( int index ) [protected]

void vtkDecimatePro::SplitLoop | ( | vtkIdType | fedges[2],
 |  | vtkIdType & | n1,
 |  | vtkIdType * | l1,
 |  | vtkIdType & | n2,
 |  | vtkIdType * | l2
 | ) | [protected]

void vtkDecimatePro::SplitVertex | ( | vtkIdType | ptId,
 |  | int | type,
 |  | unsigned short int | numTris,
 |  | vtkIdType * | tris,
 |  | int | insert
 | ) | [protected]

int vtkDecimatePro::CollapseEdge | ( | int | type,
 |  | vtkIdType | ptId,
 |  | vtkIdType | collapseId,
 |  | vtkIdType | pt1,
 |  | vtkIdType | pt2,
 |  | vtkIdList * | CollapseTris
 | ) | [protected]

void vtkDecimatePro::DistributeError ( float error ) [protected]

Member Data Documentation

float vtkDecimatePro::TargetReduction [protected]

Definition at line 330 of file vtkDecimatePro.h.

float vtkDecimatePro::FeatureAngle [protected]

Definition at line 331 of file vtkDecimatePro.h.

float vtkDecimatePro::MaximumError [protected]

Definition at line 332 of file vtkDecimatePro.h.

float vtkDecimatePro::AbsoluteError [protected]

Definition at line 333 of file vtkDecimatePro.h.

int vtkDecimatePro::ErrorIsAbsolute [protected]

Definition at line 334 of file vtkDecimatePro.h.

int vtkDecimatePro::AccumulateError [protected]

Definition at line 335 of file vtkDecimatePro.h.

float vtkDecimatePro::SplitAngle [protected]

Definition at line 336 of file vtkDecimatePro.h.

int vtkDecimatePro::Splitting [protected]

Definition at line 337 of file vtkDecimatePro.h.

int vtkDecimatePro::PreSplitMesh [protected]

Definition at line 338 of file vtkDecimatePro.h.

int vtkDecimatePro::BoundaryVertexDeletion [protected]

Definition at line 339 of file vtkDecimatePro.h.

int vtkDecimatePro::PreserveTopology [protected]

Definition at line 340 of file vtkDecimatePro.h.

int vtkDecimatePro::Degree [protected]

Definition at line 341 of file vtkDecimatePro.h.

float vtkDecimatePro::InflectionPointRatio [protected]

Definition at line 342 of file vtkDecimatePro.h.

vtkFloatArray* vtkDecimatePro::InflectionPoints [protected]

Definition at line 343 of file vtkDecimatePro.h.

vtkIdList* vtkDecimatePro::Neighbors [protected]

Definition at line 346 of file vtkDecimatePro.h.

vtkPriorityQueue* vtkDecimatePro::EdgeLengths [protected]

Definition at line 347 of file vtkDecimatePro.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDecimatePro.h
Generated on Mon Mar 25 01:17:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDelaunay2D Class Reference

create 2D Delaunay triangulation of input points. More...

#include <vtkDelaunay2D.h>

Inheritance diagram for vtkDelaunay2D:

[legend]
Collaboration diagram for vtkDelaunay2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDelaunay2D, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSource (vtkPolyData *)
vtkPolyData * GetSource ()
virtual void | SetAlpha (double)
virtual double | GetAlpha ()
virtual void | SetTolerance (double)
virtual double | GetTolerance ()
virtual void | SetOffset (double)
virtual double | GetOffset ()
virtual void | SetBoundingTriangulation (int)
virtual int | GetBoundingTriangulation ()
virtual void | BoundingTriangulationOn ()
virtual void | BoundingTriangulationOff ()
virtual void | SetInput (vtkPointSet *input)
vtkPointSet * GetInput ()
virtual void | SetTransform (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetTransform ()

Static Public Methods

vtkDelaunay2D * | New ()

Protected Methods

vtkDelaunay2D ()
~vtkDelaunay2D ()
void | Execute ()

Protected Attributes

double | Alpha
double | Tolerance
int | BoundingTriangulation
double | Offset
vtkAbstractTransform * Transform

Detailed Description

create 2D Delaunay triangulation of input points.

Date:
2002/01/22 15:29:16
Revision:
1.37

vtkDelaunay2D is a filter that constructs a 2D Delaunay triangulation from a list of input points. These points may be represented by any dataset of type vtkPointSet and subclasses. The output of the filter is a polygonal dataset. Usually the output is a triangle mesh, but if a non-zero alpha distance value is specified (called the "alpha" value), then only triangles, edges, and vertices lying within the alpha radius are output. In other words, non-zero alpha values may result in arbitrary combinations of triangles, lines, and vertices. (The notion of alpha value is derived from Edelsbrunner's work on "alpha shapes".) Also, it is possible to generate "constrained triangulations" using this filter. A constrained triangulation is one where edges and loops (i.e., polygons) can be defined and the triangulation will preserve them (read on for more information).

The 2D Delaunay triangulation is defined as the triangulation that satisfies the Delaunay criterion for n-dimensional simplexes (in this case n=2 and the simplexes are triangles). This criterion states that a circumsphere of each simplex in a triangulation contains only the n+1 defining points of the simplex. (See "The Visualization Toolkit" text for more information.) In two dimensions, this translates into an optimal triangulation. That is, the maximum interior angle of any triangle is less than or equal to that of any possible triangulation.

Delaunay triangulations are used to build topological structures from unorganized (or unstructured) points. The input to this filter is a list of points specified in 3D, even though the triangulation is 2D. Thus the triangulation is constructed in the x-y plane, and the z coordinate is ignored (although carried through to the output). If you desire to triangulate in a different plane, you can use the vtkTransformFilter to transform the points into and out of the x-y plane or you can specify a transform to the Delaunay2D directly. In the latter case, the input points are transformed, the transformed points are triangulated, and the output will use the triangulated topology for the original (non-transformed) points. This avoids transforming the data back as would be required when using the vtkTransformFilter method. Specifying a transform directly also allows any transform to be used: rigid, non-rigid, non-invertible, etc.

If an input transform is used, then alpha values are applied (for the most part) in the original data space. The exception is when BoundingTriangulation is on. In this case, alpha values are applied in the original data space unless a cell uses a bounding vertex.

The Delaunay triangulation can be numerically sensitive in some cases. To prevent problems, try to avoid injecting points that will result in triangles with bad aspect ratios (1000:1 or greater). In practice this means inserting points that are "widely dispersed", and enables smooth transition of triangle sizes throughout the mesh. (You may even want to add extra points to create a better point distribution.) If numerical problems are present, you will see a warning message to this effect at the end of the triangulation process.

To create constrained meshes, you must define an additional input. This input is an instance of vtkPolyData which contains lines, polylines, and/or polygons that define constrained edges and loops. Only the topology of (lines and polygones) from this second input are used. The topology is assumed to reference points in the input point set (the one to be triangulated). In other words, the lines and polygons use point ids from the first input point set. Lines and polylines found in the input will be mesh edges in the output. Polygons define a loop with inside and outside regions. The inside of the polygon is determined by using the right-hand-rule, i.e., looking down the z-axis a polygon should be ordered counter-clockwise. Holes in a polygon should be ordered clockwise. If you choose to create a constrained triangulation, the final mesh may not satisfy the Delaunay criterion. (Noted: the lines/polygon edges must not intersect when projected onto the 2D plane. It may not be possible to recover all edges due to not enough points in the triangulation, or poorly defined edges (coincident or excessively long). The form of the lines or polygons is a list of point ids that correspond to the input point ids used to generate the triangulation.)

If an input transform is used, constraints are defined in the "transformed" space. So when the right hand rule is used for a polygon constraint, that operation is applied using the transformed points. Since the input transform can be any transformation (rigid or non-rigid), care must be taken in constructing constraints when an input transform is used.

Warning:
Points arranged on a regular lattice (termed degenerate cases) can be triangulated in more than one way (at least according to the Delaunay criterion). The choice of triangulation (as implemented by this algorithm) depends on the order of the input points. The first three points will form a triangle; other degenerate points will not break this triangle.
Warning:
Points that are coincident (or nearly so) may be discarded by the algorithm. This is because the Delaunay triangulation requires unique input points. You can control the definition of coincidence with the "Tolerance" instance variable.
Warning:
The output of the Delaunay triangulation is supposedly a convex hull. In certain cases this implementation may not generate the convex hull. This behavior can be controlled by the Offset instance variable. Offset is a multiplier used to control the size of the initial triangulation. The larger the offset value, the more likely you will generate a convex hull; but the more likely you are to see numerical problems.
See also:
vtkDelaunay3D vtkTransformFilter vtkGaussianSplatter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (75%)
  • Miller, Jim (8%)
  • Lorensen, Bill (6%)
Examples:
vtkDelaunay2D (Examples)
Tests:
vtkDelaunay2D (Tests)

Definition at line 151 of file vtkDelaunay2D.h.

Constructor & Destructor Documentation

vtkDelaunay2D::vtkDelaunay2D ( ) [protected]

vtkDelaunay2D::~vtkDelaunay2D ( ) [protected]

Member Function Documentation

vtkDelaunay2D::vtkTypeRevisionMacro | ( | vtkDelaunay2D | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkDelaunay2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkDelaunay2D* vtkDelaunay2D::New ( ) [static]

Construct object with Alpha = 0.0; Tolerance = 0.001; Offset = 1.25; BoundingTriangulation turned off.

Reimplemented from vtkPolyDataSource.

void vtkDelaunay2D::SetSource ( vtkPolyData * )

Specify the source object used to specify constrained edges and loops. (This is optional.) If set, and lines/polygons are defined, a constrained triangulation is created. The lines/polygons are assumed to reference points in the input point set (i.e. point ids are identical in the input and source).

vtkPolyData* vtkDelaunay2D::GetSource ( )

Specify the source object used to specify constrained edges and loops. (This is optional.) If set, and lines/polygons are defined, a constrained triangulation is created. The lines/polygons are assumed to reference points in the input point set (i.e. point ids are identical in the input and source).

virtual void vtkDelaunay2D::SetAlpha ( double ) [virtual]

Specify alpha (or distance) value to control output of this filter. For a non-zero alpha value, only edges or triangles contained within a sphere centered at mesh vertices will be output. Otherwise, only triangles will be output.

virtual double vtkDelaunay2D::GetAlpha ( ) [virtual]

Specify alpha (or distance) value to control output of this filter. For a non-zero alpha value, only edges or triangles contained within a sphere centered at mesh vertices will be output. Otherwise, only triangles will be output.

virtual void vtkDelaunay2D::SetTolerance ( double ) [virtual]

Specify a tolerance to control discarding of closely spaced points. This tolerance is specified as a fraction of the diagonal length of the bounding box of the points.

virtual double vtkDelaunay2D::GetTolerance ( ) [virtual]

Specify a tolerance to control discarding of closely spaced points. This tolerance is specified as a fraction of the diagonal length of the bounding box of the points.

virtual void vtkDelaunay2D::SetOffset ( double ) [virtual]

Specify a multiplier to control the size of the initial, bounding Delaunay triangulation.

virtual double vtkDelaunay2D::GetOffset ( ) [virtual]

Specify a multiplier to control the size of the initial, bounding Delaunay triangulation.

virtual void vtkDelaunay2D::SetBoundingTriangulation ( int ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual int vtkDelaunay2D::GetBoundingTriangulation ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual void vtkDelaunay2D::BoundingTriangulationOn ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual void vtkDelaunay2D::BoundingTriangulationOff ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual void vtkDelaunay2D::SetInput ( vtkPointSet * input ) [virtual]

Set / get the input data or filter.

vtkPointSet* vtkDelaunay2D::GetInput ( )

Set / get the input data or filter.

virtual void vtkDelaunay2D::SetTransform ( vtkAbstractTransform * ) [virtual]

Set / get the transform which is applied to points to generate a 2D problem. This maps a 3D dataset into a 2D dataset where triangulation can be done on the XY plane. The points are transformed and triangulated. The topology of triangulated points is used as the output topology. The output points are the original (untransformed) points. The transform can be any subclass of vtkAbstractTransform (thus it does not need to be a linear or invertible transform).

virtual vtkAbstractTransform* vtkDelaunay2D::GetTransform ( ) [virtual]

Set / get the transform which is applied to points to generate a 2D problem. This maps a 3D dataset into a 2D dataset where triangulation can be done on the XY plane. The points are transformed and triangulated. The topology of triangulated points is used as the output topology. The output points are the original (untransformed) points. The transform can be any subclass of vtkAbstractTransform (thus it does not need to be a linear or invertible transform).

void vtkDelaunay2D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

double vtkDelaunay2D::Alpha [protected]

Definition at line 230 of file vtkDelaunay2D.h.

double vtkDelaunay2D::Tolerance [protected]

Definition at line 231 of file vtkDelaunay2D.h.

int vtkDelaunay2D::BoundingTriangulation [protected]

Definition at line 232 of file vtkDelaunay2D.h.

double vtkDelaunay2D::Offset [protected]

Definition at line 233 of file vtkDelaunay2D.h.

vtkAbstractTransform* vtkDelaunay2D::Transform [protected]

Definition at line 235 of file vtkDelaunay2D.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDelaunay2D.h
Generated on Mon Mar 25 01:17:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDelaunay3D Class Reference

create 3D Delaunay triangulation of input points. More...

#include <vtkDelaunay3D.h>

Inheritance diagram for vtkDelaunay3D:

[legend]
Collaboration diagram for vtkDelaunay3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDelaunay3D, vtkUnstructuredGridSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
void | EndPointInsertion ()
unsigned long | GetMTime ()
virtual void | SetAlpha (float)
virtual float | GetAlpha ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()
virtual void | SetOffset (float)
virtual float | GetOffset ()
virtual void | SetBoundingTriangulation (int)
virtual int | GetBoundingTriangulation ()
virtual void | BoundingTriangulationOn ()
virtual void | BoundingTriangulationOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
vtkUnstructuredGrid * | InitPointInsertion (float center[3], float length, vtkIdType numPts, vtkPoints *&pts)
void | InsertPoint (vtkUnstructuredGrid *Mesh, vtkPoints *points, vtkIdType id, float x[3], vtkIdList *holeTetras)
virtual void | SetInput (vtkPointSet *input)
vtkPointSet * GetInput ()

Static Public Methods

vtkDelaunay3D * | New ()

Protected Methods

vtkDelaunay3D ()
~vtkDelaunay3D ()
void | Execute ()
int | FindTetra (vtkUnstructuredGrid *Mesh, double x[3], vtkIdType tetId, int depth)
int | InSphere (double x[3], vtkIdType tetraId)
void | InsertTetra (vtkUnstructuredGrid *Mesh, vtkPoints *pts, vtkIdType tetraId)
vtkIdType | FindEnclosingFaces (float x[3], vtkUnstructuredGrid *Mesh, vtkIdList *tetras, vtkIdList *faces, vtkPointLocator *Locator)

Protected Attributes

float | Alpha
float | Tolerance
int | BoundingTriangulation
float | Offset
vtkPointLocator * Locator
vtkTetraArray * | TetraArray
int | NumberOfDuplicatePoints
int | NumberOfDegeneracies
int * | References

Detailed Description

create 3D Delaunay triangulation of input points.

Date:
2002/01/22 15:29:16
Revision:
1.45

vtkDelaunay3D is a filter that constructs a 3D Delaunay triangulation from a list of input points. These points may be represented by any dataset of type vtkPointSet and subclasses. The output of the filter is an unstructured grid dataset. Usually the output is a tetrahedral mesh, but if a non-zero alpha distance value is specified (called the "alpha" value), then only tetrahedra, triangles, edges, and vertices lying within the alpha radius are output. In other words, non-zero alpha values may result in arbitrary combinations of tetrahedra, triangles, lines, and vertices. (The notion of alpha value is derived from Edelsbrunner's work on "alpha shapes".)

The 3D Delaunay triangulation is defined as the triangulation that satisfies the Delaunay criterion for n-dimensional simplexes (in this case n=3 and the simplexes are tetrahedra). This criterion states that a circumsphere of each simplex in a triangulation contains only the n+1 defining points of the simplex. (See text for more information.) While in two dimensions this translates into an "optimal" triangulation, this is not true in 3D, since a measurement for optimality in 3D is not agreed on.

Delaunay triangulations are used to build topological structures from unorganized (or unstructured) points. The input to this filter is a list of points specified in 3D. (If you wish to create 2D triangulations see vtkDelaunay2D.) The output is an unstructured grid.

The Delaunay triangulation can be numerically sensitive. To prevent problems, try to avoid injecting points that will result in triangles with bad aspect ratios (1000:1 or greater). In practice this means inserting points that are "widely dispersed", and enables smooth transition of triangle sizes throughout the mesh. (You may even want to add extra points to create a better point distribution.) If numerical problems are present, you will see a warning message to this effect at the end of the triangulation process.

Warning:
Points arranged on a regular lattice (termed degenerate cases) can be triangulated in more than one way (at least according to the Delaunay criterion). The choice of triangulation (as implemented by this algorithm) depends on the order of the input points. The first four points will form a tetrahedron; other degenerate points (relative to this initial tetrahedron) will not break it.
Warning:
Points that are coincident (or nearly so) may be discarded by the algorithm. This is because the Delaunay triangulation requires unique input points. You can control the definition of coincidence with the "Tolerance" instance variable.
Warning:
The output of the Delaunay triangulation is supposedly a convex hull. In certain cases this implementation may not generate the convex hull. This behavior can be controlled by the Offset instance variable. Offset is a multiplier used to control the size of the initial triangulation. The larger the offset value, the more likely you will generate a convex hull; and the more likely you are to see numerical problems.
Warning:
The implementation of this algorithm varies from the 2D Delaunay algorithm (i.e., vtkDelaunay2D) in an important way. When points are injected into the triangulation, the search for the enclosing tetrahedron is quite different. In the 3D case, the closest previously inserted point point is found, and then the connected tetrahedra are searched to find the containing one. (In 2D, a "walk" towards the enclosing triangle is performed.) If the triangulation is Delaunay, then an
See also:
vtkDelaunay2D vtkGaussianSplatter vtkUnstructuredGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (78%)
  • Law, Charles (10%)
Examples:
vtkDelaunay3D (Examples)
Tests:
vtkDelaunay3D (Tests)

Definition at line 112 of file vtkDelaunay3D.h.

Constructor & Destructor Documentation

vtkDelaunay3D::vtkDelaunay3D ( ) [protected]

vtkDelaunay3D::~vtkDelaunay3D ( ) [protected]

Member Function Documentation

vtkDelaunay3D::vtkTypeRevisionMacro | ( | vtkDelaunay3D | ,
 |  | vtkUnstructuredGridSource |
 | ) |

Reimplemented from vtkUnstructuredGridSource.

void vtkDelaunay3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkDelaunay3D* vtkDelaunay3D::New ( ) [static]

Construct object with Alpha = 0.0; Tolerance = 0.001; Offset = 2.5; BoundingTriangulation turned off.

Reimplemented from vtkUnstructuredGridSource.

virtual void vtkDelaunay3D::SetAlpha ( float ) [virtual]

Specify alpha (or distance) value to control output of this filter. For a non-zero alpha value, only edges, faces, or tetra contained within the circumsphere (of radius alpha) will be output. Otherwise, only tetrahedra will be output.

virtual float vtkDelaunay3D::GetAlpha ( ) [virtual]

Specify alpha (or distance) value to control output of this filter. For a non-zero alpha value, only edges, faces, or tetra contained within the circumsphere (of radius alpha) will be output. Otherwise, only tetrahedra will be output.

virtual void vtkDelaunay3D::SetTolerance ( float ) [virtual]

Specify a tolerance to control discarding of closely spaced points. This tolerance is specified as a fraction of the diagonal length of the bounding box of the points.

virtual float vtkDelaunay3D::GetTolerance ( ) [virtual]

Specify a tolerance to control discarding of closely spaced points. This tolerance is specified as a fraction of the diagonal length of the bounding box of the points.

virtual void vtkDelaunay3D::SetOffset ( float ) [virtual]

Specify a multiplier to control the size of the initial, bounding Delaunay triangulation.

virtual float vtkDelaunay3D::GetOffset ( ) [virtual]

Specify a multiplier to control the size of the initial, bounding Delaunay triangulation.

virtual void vtkDelaunay3D::SetBoundingTriangulation ( int ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual int vtkDelaunay3D::GetBoundingTriangulation ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual void vtkDelaunay3D::BoundingTriangulationOn ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

virtual void vtkDelaunay3D::BoundingTriangulationOff ( ) [virtual]

Boolean controls whether bounding triangulation points (and associated triangles) are included in the output. (These are introduced as an initial triangulation to begin the triangulation process. This feature is nice for debugging output.)

void vtkDelaunay3D::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default, an instance of vtkPointLocator is used.

virtual vtkPointLocator* vtkDelaunay3D::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default, an instance of vtkPointLocator is used.

void vtkDelaunay3D::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to eliminate "coincident" points.

vtkUnstructuredGrid* vtkDelaunay3D::InitPointInsertion | ( | float | center[3],
 |  | float | length,
 |  | vtkIdType | numPts,
 |  | vtkPoints *& | pts
 | ) |

This is a helper method used with InsertPoint() to create tetrahedronalizations of points. Its purpose is construct an initial Delaunay triangulation into which to inject other points. You must specify the center of a cubical bounding box and its length, as well as the number of points to insert. The method returns a pointer to an unstructured grid. Use this pointer to manipulate the mesh as necessary. You must delete (with Delete()) the mesh when done. Note: This initialization method places points forming bounding octahedron at the end of the Mesh's point list. That is, InsertPoint() assumes that you will be inserting points between (0,numPtsToInsert-1).

void vtkDelaunay3D::InsertPoint | ( | vtkUnstructuredGrid * | Mesh,
 |  | vtkPoints * | points,
 |  | vtkIdType | id,
 |  | float | x[3],
 |  | vtkIdList * | holeTetras
 | ) |

This is a helper method used with InitPointInsertion() to create tetrahedronalizations of points. Its purpose is to inject point at coordinates specified into tetrahedronalization. The point id is an index into the list of points in the mesh structure. (See vtkDelaunay3D::InitPointInsertion() for more information.) When you have completed inserting points, traverse the mesh structure to extract desired tetrahedra (or tetra faces and edges).The holeTetras id list lists all the tetrahedra that are deleted (invalid) in the mesh structure.

void vtkDelaunay3D::EndPointInsertion ( )

Invoke this method after all points have been inserted. The purpose of the method is to clean up internal data structures. Note that the (vtkUnstructuredGrid *)Mesh returned from InitPointInsertion() is NOT deleted, you still are responsible for cleaning that up.

unsigned long vtkDelaunay3D::GetMTime ( ) [virtual]

Return the MTime also considering the locator.

Reimplemented from vtkObject.

virtual void vtkDelaunay3D::SetInput ( vtkPointSet * input ) [virtual]

Set / get the input data or filter.

vtkPointSet* vtkDelaunay3D::GetInput ( )

Set / get the input data or filter.

void vtkDelaunay3D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkDelaunay3D::FindTetra | ( | vtkUnstructuredGrid * | Mesh,
 |  | double | x[3],
 |  | vtkIdType | tetId,
 |  | int | depth
 | ) | [protected]

int vtkDelaunay3D::InSphere | ( | double | x[3],
 |  | vtkIdType | tetraId
 | ) | [protected]

void vtkDelaunay3D::InsertTetra | ( | vtkUnstructuredGrid * | Mesh,
 |  | vtkPoints * | pts,
 |  | vtkIdType | tetraId
 | ) | [protected]

vtkIdType vtkDelaunay3D::FindEnclosingFaces | ( | float | x[3],
 |  | vtkUnstructuredGrid * | Mesh,
 |  | vtkIdList * | tetras,
 |  | vtkIdList * | faces,
 |  | vtkPointLocator * | Locator
 | ) | [protected]

Member Data Documentation

float vtkDelaunay3D::Alpha [protected]

Definition at line 217 of file vtkDelaunay3D.h.

float vtkDelaunay3D::Tolerance [protected]

Definition at line 218 of file vtkDelaunay3D.h.

int vtkDelaunay3D::BoundingTriangulation [protected]

Definition at line 219 of file vtkDelaunay3D.h.

float vtkDelaunay3D::Offset [protected]

Definition at line 220 of file vtkDelaunay3D.h.

vtkPointLocator* vtkDelaunay3D::Locator [protected]

Definition at line 222 of file vtkDelaunay3D.h.

vtkTetraArray* vtkDelaunay3D::TetraArray [protected]

Definition at line 224 of file vtkDelaunay3D.h.

int vtkDelaunay3D::NumberOfDuplicatePoints [protected]

Definition at line 231 of file vtkDelaunay3D.h.

int vtkDelaunay3D::NumberOfDegeneracies [protected]

Definition at line 232 of file vtkDelaunay3D.h.

int* vtkDelaunay3D::References [protected]

Definition at line 235 of file vtkDelaunay3D.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDelaunay3D.h
Generated on Mon Mar 25 01:17:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDEMReader Class Reference

read a digital elevation model (DEM) file. More...

#include <vtkDEMReader.h>

Inheritance diagram for vtkDEMReader:

[legend]
Collaboration diagram for vtkDEMReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDEMReader, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ExecuteInformation ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual char * | GetMapLabel ()
virtual int | GetDEMLevel ()
virtual int | GetElevationPattern ()
virtual int | GetGroundSystem ()
virtual int | GetGroundZone ()
virtual float * | GetProjectionParameters ()
virtual void | GetProjectionParameters (float data[15])
virtual int | GetPlaneUnitOfMeasure ()
virtual int | GetElevationUnitOfMeasure ()
virtual int | GetPolygonSize ()
virtual float * | GetElevationBounds ()
virtual void | GetElevationBounds (float data[2])
virtual float | GetLocalRotation ()
virtual int | GetAccuracyCode ()
virtual float * | GetSpatialResolution ()
virtual void | GetSpatialResolution (float data[3])
virtual int * | GetProfileDimension ()
virtual void | GetProfileDimension (int data[2])

Static Public Methods

vtkDEMReader * | New ()

Protected Methods

vtkDEMReader ()
~vtkDEMReader ()
void | ComputeExtentOriginAndSpacing (int extent[6], float origin[6], float spacing[6])
int | ReadTypeARecord ()
int | ReadProfiles (vtkImageData *data)
void | ExecuteData (vtkDataObject *out)

Protected Attributes

vtkTimeStamp ReadHeaderTime
int | NumberOfColumns
int | NumberOfRows
int | WholeExtent [6]
char * | FileName
char | MapLabel [145]
int | DEMLevel
int | ElevationPattern
int | GroundSystem
int | GroundZone
float | ProjectionParameters [15]
int | PlaneUnitOfMeasure
int | ElevationUnitOfMeasure
int | PolygonSize
float | GroundCoords [4][2]
float | ElevationBounds [2]
float | LocalRotation
int | AccuracyCode
float | SpatialResolution [3]
int | ProfileDimension [2]
int | ProfileSeekOffset

Detailed Description

read a digital elevation model (DEM) file.

Date:
2002/01/22 15:38:10
Revision:
1.26

vtkDEMReader reads digital elevation files and creates image data. Digital elevation files are produced by the US Geological Survey. A complete description of the DEM file is located at the USGS site. The reader reads the entire dem file and create a vtkImageData that contains a single scalar component that is the elevation in meters. The spacing is also expressed in meters. A number of get methods provide access to fields on the header.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (90%)
Examples:
vtkDEMReader (Examples)
Tests:
vtkDEMReader (Tests)

Definition at line 49 of file vtkDEMReader.h.

Constructor & Destructor Documentation

vtkDEMReader::vtkDEMReader ( ) [protected]

vtkDEMReader::~vtkDEMReader ( ) [protected]

Member Function Documentation

vtkDEMReader* vtkDEMReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkDEMReader::vtkTypeRevisionMacro | ( | vtkDEMReader | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkDEMReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkDEMReader::SetFileName ( const char * ) [virtual]

Specify file name of Digital Elevation Model (DEM) file

virtual char* vtkDEMReader::GetFileName ( ) [virtual]

Specify file name of Digital Elevation Model (DEM) file

virtual char* vtkDEMReader::GetMapLabel ( ) [virtual]

An ASCII description of the map

virtual int vtkDEMReader::GetDEMLevel ( ) [virtual]

Code 1=DEM-1, 2=DEM_2, ...

virtual int vtkDEMReader::GetElevationPattern ( ) [virtual]

Code 1=regular, 2=random, reserved for future use

virtual int vtkDEMReader::GetGroundSystem ( ) [virtual]

Ground planimetric reference system

virtual int vtkDEMReader::GetGroundZone ( ) [virtual]

Zone in ground planimetric reference system

virtual float* vtkDEMReader::GetProjectionParameters ( ) [virtual]

Map Projection parameters. All are zero.

virtual void vtkDEMReader::GetProjectionParameters ( float data[15] ) [virtual]

Map Projection parameters. All are zero.

virtual int vtkDEMReader::GetPlaneUnitOfMeasure ( ) [virtual]

Defining unit of measure for ground planimetric coordinates throughout the file. 0 = radians, 1 = feet, 2 = meters, 3 = arc-seconds.

virtual int vtkDEMReader::GetElevationUnitOfMeasure ( ) [virtual]

Defining unit of measure for elevation coordinates throughout the file. 1 = feet, 2 = meters

virtual int vtkDEMReader::GetPolygonSize ( ) [virtual]

Number of sides in the polygon which defines the coverage of the DEM file. Set to 4.

virtual float* vtkDEMReader::GetElevationBounds ( ) [virtual]

Minimum and maximum elevation for the DEM. The units in the file are in ElevationUnitOfMeasure. This class converts them to meters.

virtual void vtkDEMReader::GetElevationBounds ( float data[2] ) [virtual]

Minimum and maximum elevation for the DEM. The units in the file are in ElevationUnitOfMeasure. This class converts them to meters.

virtual float vtkDEMReader::GetLocalRotation ( ) [virtual]

Counterclockwise angle (in radians) from the primary axis of the planimetric reference to the primary axis of the DEM local reference system. IGNORED BY THIS IMPLEMENTATION.

virtual int vtkDEMReader::GetAccuracyCode ( ) [virtual]

Accuracy code for elevations. 0=unknown accuracy

virtual float* vtkDEMReader::GetSpatialResolution ( ) [virtual]

DEM spatial resolution for x,y,z. Values are expressed in units of resolution. Since elevations are read as integers, this permits fractional elevations.

virtual void vtkDEMReader::GetSpatialResolution ( float data[3] ) [virtual]

DEM spatial resolution for x,y,z. Values are expressed in units of resolution. Since elevations are read as integers, this permits fractional elevations.

virtual int* vtkDEMReader::GetProfileDimension ( ) [virtual]

The number of rows and columns in the DEM.

virtual void vtkDEMReader::GetProfileDimension ( int data[2] ) [virtual]

The number of rows and columns in the DEM.

void vtkDEMReader::ExecuteInformation ( ) [virtual]

Reads the DEM Type A record to compute the extent, origin and spacing of the image data. The number of scalar components is set to 1 and the output scalar type is VTK_FLOAT.

Reimplemented from vtkSource.

void vtkDEMReader::ComputeExtentOriginAndSpacing | ( | int | extent[6],
 |  | float | origin[6],
 |  | float | spacing[6]
 | ) | [protected]

int vtkDEMReader::ReadTypeARecord ( ) [protected]

int vtkDEMReader::ReadProfiles ( vtkImageData * data ) [protected]

void vtkDEMReader::ExecuteData ( vtkDataObject * out ) [protected]

Member Data Documentation

vtkTimeStamp vtkDEMReader::ReadHeaderTime [protected]

Definition at line 150 of file vtkDEMReader.h.

int vtkDEMReader::NumberOfColumns [protected]

Definition at line 151 of file vtkDEMReader.h.

int vtkDEMReader::NumberOfRows [protected]

Definition at line 152 of file vtkDEMReader.h.

int vtkDEMReader::WholeExtent[6] [protected]

Definition at line 153 of file vtkDEMReader.h.

char* vtkDEMReader::FileName [protected]

Definition at line 154 of file vtkDEMReader.h.

char vtkDEMReader::MapLabel[145] [protected]

Definition at line 155 of file vtkDEMReader.h.

int vtkDEMReader::DEMLevel [protected]

Definition at line 156 of file vtkDEMReader.h.

int vtkDEMReader::ElevationPattern [protected]

Definition at line 157 of file vtkDEMReader.h.

int vtkDEMReader::GroundSystem [protected]

Definition at line 158 of file vtkDEMReader.h.

int vtkDEMReader::GroundZone [protected]

Definition at line 159 of file vtkDEMReader.h.

float vtkDEMReader::ProjectionParameters[15] [protected]

Definition at line 160 of file vtkDEMReader.h.

int vtkDEMReader::PlaneUnitOfMeasure [protected]

Definition at line 161 of file vtkDEMReader.h.

int vtkDEMReader::ElevationUnitOfMeasure [protected]

Definition at line 162 of file vtkDEMReader.h.

int vtkDEMReader::PolygonSize [protected]

Definition at line 163 of file vtkDEMReader.h.

float vtkDEMReader::GroundCoords[4][2] [protected]

Definition at line 164 of file vtkDEMReader.h.

float vtkDEMReader::ElevationBounds[2] [protected]

Definition at line 165 of file vtkDEMReader.h.

float vtkDEMReader::LocalRotation [protected]

Definition at line 166 of file vtkDEMReader.h.

int vtkDEMReader::AccuracyCode [protected]

Definition at line 167 of file vtkDEMReader.h.

float vtkDEMReader::SpatialResolution[3] [protected]

Definition at line 168 of file vtkDEMReader.h.

int vtkDEMReader::ProfileDimension[2] [protected]

Definition at line 169 of file vtkDEMReader.h.

int vtkDEMReader::ProfileSeekOffset [protected]

Definition at line 170 of file vtkDEMReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkDEMReader.h
Generated on Mon Mar 25 01:17:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDepthSortPolyData Class Reference

sort poly data along camera view direction. More...

#include <vtkDepthSortPolyData.h>

Inheritance diagram for vtkDepthSortPolyData:

[legend]
Collaboration diagram for vtkDepthSortPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDepthSortPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetDirection (int)
virtual int | GetDirection ()
void | SetDirectionToFrontToBack ()
void | SetDirectionToBackToFront ()
void | SetDirectionToSpecifiedVector ()
virtual void | SetDepthSortMode (int)
virtual int | GetDepthSortMode ()
void | SetDepthSortModeToFirstPoint ()
void | SetDepthSortModeToBoundsCenter ()
void | SetDepthSortModeToParametricCenter ()
virtual void | SetCamera (vtkCamera *)
virtual vtkCamera * | GetCamera ()
void | SetProp3D (vtkProp3D *)
vtkProp3D * GetProp3D ()
virtual void | SetVector (double, double, double)
virtual void | SetVector (double[3])
virtual double * | GetVector ()
virtual void | GetVector (double data[3])
virtual void | SetOrigin (double, double, double)
virtual void | SetOrigin (double[3])
virtual double * | GetOrigin ()
virtual void | GetOrigin (double data[3])
virtual void | SetSortScalars (int)
virtual int | GetSortScalars ()
virtual void | SortScalarsOn ()
virtual void | SortScalarsOff ()

Static Public Methods

vtkDepthSortPolyData * | New ()

Protected Methods

vtkDepthSortPolyData ()
~vtkDepthSortPolyData ()
void | Execute ()
void | ComputeProjectionVector (double vector[3], double origin[3])

Protected Attributes

int | Direction
int | DepthSortMode
vtkCamera * Camera
vtkProp3D * Prop3D
vtkTransform * Transform
double | Vector [3]
double | Origin [3]
int | SortScalars

Detailed Description

sort poly data along camera view direction.

Date:
2002/01/22 15:30:27
Revision:
1.9

vtkDepthSortPolyData rearranges the order of cells so that certain rendering operations (e.g., transparency or Painter's algorithms) generate correct results. To use this filter you must specify the direction vector along which to sort the cells. You can do this by specifying a camera and/or prop to define a view direction; or explicitly set a view direction.

Warning:
The sort operation will not work well for long, thin primitives, or cells that intersect, overlap, or interpenetrate each other.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (85%)
  • Martin, Ken (6%)
Examples:
vtkDepthSortPolyData (Examples)
Tests:
vtkDepthSortPolyData (Tests)

Definition at line 63 of file vtkDepthSortPolyData.h.

Constructor & Destructor Documentation

vtkDepthSortPolyData::vtkDepthSortPolyData ( ) [protected]

vtkDepthSortPolyData::~vtkDepthSortPolyData ( ) [protected]

Member Function Documentation

vtkDepthSortPolyData* vtkDepthSortPolyData::New ( ) [static]

Instantiate object.

Reimplemented from vtkPolyDataSource.

vtkDepthSortPolyData::vtkTypeRevisionMacro | ( | vtkDepthSortPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkDepthSortPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkDepthSortPolyData::SetDirection ( int ) [virtual]

Specify the sort method for the polygonal primitives. By default, the poly data is sorted from back to front.

virtual int vtkDepthSortPolyData::GetDirection ( ) [virtual]

Specify the sort method for the polygonal primitives. By default, the poly data is sorted from back to front.

void vtkDepthSortPolyData::SetDirectionToFrontToBack ( ) [inline]

Specify the sort method for the polygonal primitives. By default, the poly data is sorted from back to front.

Definition at line 77 of file vtkDepthSortPolyData.h.

void vtkDepthSortPolyData::SetDirectionToBackToFront ( ) [inline]

Specify the sort method for the polygonal primitives. By default, the poly data is sorted from back to front.

Definition at line 79 of file vtkDepthSortPolyData.h.

void vtkDepthSortPolyData::SetDirectionToSpecifiedVector ( ) [inline]

Specify the sort method for the polygonal primitives. By default, the poly data is sorted from back to front.

Definition at line 81 of file vtkDepthSortPolyData.h.

virtual void vtkDepthSortPolyData::SetDepthSortMode ( int ) [virtual]

Specify the point to use when sorting. The fastest is to just take the first cell point. Other options are to take the bounding box center or the parametric center of the cell. By default, the first cell point is used.

virtual int vtkDepthSortPolyData::GetDepthSortMode ( ) [virtual]

Specify the point to use when sorting. The fastest is to just take the first cell point. Other options are to take the bounding box center or the parametric center of the cell. By default, the first cell point is used.

void vtkDepthSortPolyData::SetDepthSortModeToFirstPoint ( ) [inline]

Specify the point to use when sorting. The fastest is to just take the first cell point. Other options are to take the bounding box center or the parametric center of the cell. By default, the first cell point is used.

Definition at line 92 of file vtkDepthSortPolyData.h.

void vtkDepthSortPolyData::SetDepthSortModeToBoundsCenter ( ) [inline]

Specify the point to use when sorting. The fastest is to just take the first cell point. Other options are to take the bounding box center or the parametric center of the cell. By default, the first cell point is used.

Definition at line 94 of file vtkDepthSortPolyData.h.

void vtkDepthSortPolyData::SetDepthSortModeToParametricCenter ( ) [inline]

Specify the point to use when sorting. The fastest is to just take the first cell point. Other options are to take the bounding box center or the parametric center of the cell. By default, the first cell point is used.

Definition at line 96 of file vtkDepthSortPolyData.h.

virtual void vtkDepthSortPolyData::SetCamera ( vtkCamera * ) [virtual]

Specify a camera that is used to define a view direction along which the cells are sorted. This ivar only has effect if the direction is set to front-to-back or back-to-front, and a camera is specified.

virtual vtkCamera* vtkDepthSortPolyData::GetCamera ( ) [virtual]

Specify a camera that is used to define a view direction along which the cells are sorted. This ivar only has effect if the direction is set to front-to-back or back-to-front, and a camera is specified.

void vtkDepthSortPolyData::SetProp3D ( vtkProp3D * )

Specify a transformation matrix (via the vtkProp3D::GetMatrix() method) that is used to include the effects of transformation. This ivar only has effect if the direction is set to front-to-back or back-to-front, and a camera is specified. Specifying the vtkProp3D is optional.

vtkProp3D* vtkDepthSortPolyData::GetProp3D ( )

Specify a transformation matrix (via the vtkProp3D::GetMatrix() method) that is used to include the effects of transformation. This ivar only has effect if the direction is set to front-to-back or back-to-front, and a camera is specified. Specifying the vtkProp3D is optional.

virtual void vtkDepthSortPolyData::SetVector | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the sort direction. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector.

virtual void vtkDepthSortPolyData::SetVector ( double [3] ) [virtual]

Set/Get the sort direction. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector.

virtual double* vtkDepthSortPolyData::GetVector ( ) [virtual]

Set/Get the sort direction. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector.

virtual void vtkDepthSortPolyData::GetVector ( double data[3] ) [virtual]

Set/Get the sort direction. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector.

virtual void vtkDepthSortPolyData::SetOrigin | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the sort origin. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector, with this point specifying the origin.

virtual void vtkDepthSortPolyData::SetOrigin ( double [3] ) [virtual]

Set/Get the sort origin. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector, with this point specifying the origin.

virtual double* vtkDepthSortPolyData::GetOrigin ( ) [virtual]

Set/Get the sort origin. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector, with this point specifying the origin.

virtual void vtkDepthSortPolyData::GetOrigin ( double data[3] ) [virtual]

Set/Get the sort origin. This ivar only has effect if the sort direction is set to SetDirectionToSpecifiedVector(). The sort occurs in the direction of the vector, with this point specifying the origin.

virtual void vtkDepthSortPolyData::SetSortScalars ( int ) [virtual]

Set/Get a flag that controls the generation of scalar values corresponding to the sort order. If enabled, the output of this filter will include scalar values that range from 0 to (ncells-1), where 0 is closest to the sort direction.

virtual int vtkDepthSortPolyData::GetSortScalars ( ) [virtual]

Set/Get a flag that controls the generation of scalar values corresponding to the sort order. If enabled, the output of this filter will include scalar values that range from 0 to (ncells-1), where 0 is closest to the sort direction.

virtual void vtkDepthSortPolyData::SortScalarsOn ( ) [virtual]

Set/Get a flag that controls the generation of scalar values corresponding to the sort order. If enabled, the output of this filter will include scalar values that range from 0 to (ncells-1), where 0 is closest to the sort direction.

virtual void vtkDepthSortPolyData::SortScalarsOff ( ) [virtual]

Set/Get a flag that controls the generation of scalar values corresponding to the sort order. If enabled, the output of this filter will include scalar values that range from 0 to (ncells-1), where 0 is closest to the sort direction.

unsigned long vtkDepthSortPolyData::GetMTime ( ) [virtual]

Return MTime also considering the dependent objects: the camera and/or the prop3D.

Reimplemented from vtkObject.

void vtkDepthSortPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDepthSortPolyData::ComputeProjectionVector | ( | double | vector[3],
 |  | double | origin[3]
 | ) | [protected]

Member Data Documentation

int vtkDepthSortPolyData::Direction [protected]

Definition at line 156 of file vtkDepthSortPolyData.h.

int vtkDepthSortPolyData::DepthSortMode [protected]

Definition at line 157 of file vtkDepthSortPolyData.h.

vtkCamera* vtkDepthSortPolyData::Camera [protected]

Definition at line 158 of file vtkDepthSortPolyData.h.

vtkProp3D* vtkDepthSortPolyData::Prop3D [protected]

Definition at line 159 of file vtkDepthSortPolyData.h.

vtkTransform* vtkDepthSortPolyData::Transform [protected]

Definition at line 160 of file vtkDepthSortPolyData.h.

double vtkDepthSortPolyData::Vector[3] [protected]

Definition at line 161 of file vtkDepthSortPolyData.h.

double vtkDepthSortPolyData::Origin[3] [protected]

Definition at line 162 of file vtkDepthSortPolyData.h.

int vtkDepthSortPolyData::SortScalars [protected]

Definition at line 163 of file vtkDepthSortPolyData.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkDepthSortPolyData.h
Generated on Mon Mar 25 01:17:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDicer Class Reference

abstract superclass to divide dataset into pieces. More...

#include <vtkDicer.h>

Inheritance diagram for vtkDicer:

[legend]
Collaboration diagram for vtkDicer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDicer, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFieldData (int)
virtual int | GetFieldData ()
virtual void | FieldDataOn ()
virtual void | FieldDataOff ()
virtual void | SetDiceMode (int)
virtual int | GetDiceMode ()
void | SetDiceModeToNumberOfPointsPerPiece ()
void | SetDiceModeToSpecifiedNumberOfPieces ()
void | SetDiceModeToMemoryLimitPerPiece ()
virtual int | GetNumberOfActualPieces ()
virtual void | SetNumberOfPointsPerPiece (int)
virtual int | GetNumberOfPointsPerPiece ()
virtual void | SetNumberOfPieces (int)
virtual int | GetNumberOfPieces ()
virtual void | SetMemoryLimit (unsigned long)
virtual unsigned long | GetMemoryLimit ()

Protected Methods

vtkDicer ()
~vtkDicer ()
virtual void | UpdatePieceMeasures ()

Protected Attributes

int | NumberOfPointsPerPiece
int | NumberOfPieces
unsigned long | MemoryLimit
int | NumberOfActualPieces
int | FieldData
int | DiceMode

Detailed Description

abstract superclass to divide dataset into pieces.

Date:
2002/01/22 15:29:17
Revision:
1.30

Subclasses of vtkDicer divides the input dataset into separate pieces. These pieces can then be operated on by other filters (e.g., vtkThreshold). One application is to break very large polygonal models into pieces and performing viewing and occlusion culling on the pieces. Multiple pieces can also be streamed through the visualization pipeline.

To use this filter, you must specify the execution mode of the filter; i.e., set the way that the piece size is controlled (do this by setting the DiceMode ivar). The filter does not change the geometry or topology of the input dataset, rather it generates integer numbers that indicate which piece a particular point belongs to (i.e., it modifies the point and cell attribute data). The integer number can be placed into the output scalar data, or the output field data.

Warning:
The number of pieces generated may not equal the specified number of pieces. Use the method GetNumberOfActualPieces() after filter execution to get the actual number of pieces generated.
See also:
vtkOBBDicer vtkConnectedDicer vtkSpatialDicer
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (86%)

Definition at line 62 of file vtkDicer.h.

Constructor & Destructor Documentation

vtkDicer::vtkDicer ( ) [protected]

vtkDicer::~vtkDicer ( ) [inline, protected]

Definition at line 126 of file vtkDicer.h.

Member Function Documentation

vtkDicer::vtkTypeRevisionMacro | ( | vtkDicer | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

Reimplemented in vtkOBBDicer.

void vtkDicer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkOBBDicer.

virtual void vtkDicer::SetFieldData ( int ) [virtual]

Set/Get the flag which controls whether to generate point scalar data or point field data. If this flag is off, scalar data is generated. Otherwise, field data is generated. Note that the generated the data are integer numbers indicating which piece a particular point belongs to.

virtual int vtkDicer::GetFieldData ( ) [virtual]

Set/Get the flag which controls whether to generate point scalar data or point field data. If this flag is off, scalar data is generated. Otherwise, field data is generated. Note that the generated the data are integer numbers indicating which piece a particular point belongs to.

virtual void vtkDicer::FieldDataOn ( ) [virtual]

Set/Get the flag which controls whether to generate point scalar data or point field data. If this flag is off, scalar data is generated. Otherwise, field data is generated. Note that the generated the data are integer numbers indicating which piece a particular point belongs to.

virtual void vtkDicer::FieldDataOff ( ) [virtual]

Set/Get the flag which controls whether to generate point scalar data or point field data. If this flag is off, scalar data is generated. Otherwise, field data is generated. Note that the generated the data are integer numbers indicating which piece a particular point belongs to.

virtual void vtkDicer::SetDiceMode ( int ) [virtual]

Specify the method to determine how many pieces the data should be broken into. By default, the number of points per piece is used.

virtual int vtkDicer::GetDiceMode ( ) [virtual]

Specify the method to determine how many pieces the data should be broken into. By default, the number of points per piece is used.

void vtkDicer::SetDiceModeToNumberOfPointsPerPiece ( ) [inline]

Specify the method to determine how many pieces the data should be broken into. By default, the number of points per piece is used.

Definition at line 84 of file vtkDicer.h.

void vtkDicer::SetDiceModeToSpecifiedNumberOfPieces ( ) [inline]

Specify the method to determine how many pieces the data should be broken into. By default, the number of points per piece is used.

Definition at line 86 of file vtkDicer.h.

void vtkDicer::SetDiceModeToMemoryLimitPerPiece ( ) [inline]

Specify the method to determine how many pieces the data should be broken into. By default, the number of points per piece is used.

Definition at line 88 of file vtkDicer.h.

virtual int vtkDicer::GetNumberOfActualPieces ( ) [virtual]

Use the following method after the filter has updated to determine the actual number of pieces the data was separated into.

virtual void vtkDicer::SetNumberOfPointsPerPiece ( int ) [virtual]

Control piece size based on the maximum number of points per piece. (This ivar has effect only when the DiceMode is set to SetDiceModeToNumberOfPoints().)

virtual int vtkDicer::GetNumberOfPointsPerPiece ( ) [virtual]

Control piece size based on the maximum number of points per piece. (This ivar has effect only when the DiceMode is set to SetDiceModeToNumberOfPoints().)

virtual void vtkDicer::SetNumberOfPieces ( int ) [virtual]

Set/Get the number of pieces the object is to be separated into. (This ivar has effect only when the DiceMode is set to SetDiceModeToSpecifiedNumber()). Note that the ivar NumberOfPieces is a target - depending on the particulars of the data, more or less number of pieces than the target value may be created.

virtual int vtkDicer::GetNumberOfPieces ( ) [virtual]

Set/Get the number of pieces the object is to be separated into. (This ivar has effect only when the DiceMode is set to SetDiceModeToSpecifiedNumber()). Note that the ivar NumberOfPieces is a target - depending on the particulars of the data, more or less number of pieces than the target value may be created.

virtual void vtkDicer::SetMemoryLimit ( unsigned long ) [virtual]

Control piece size based on a memory limit. (This ivar has effect only when the DiceMode is set to SetDiceModeToMemoryLimit()). The memory limit should be set in kilobytes.

virtual unsigned long vtkDicer::GetMemoryLimit ( ) [virtual]

Control piece size based on a memory limit. (This ivar has effect only when the DiceMode is set to SetDiceModeToMemoryLimit()). The memory limit should be set in kilobytes.

virtual void vtkDicer::UpdatePieceMeasures ( ) [protected, virtual]

Member Data Documentation

int vtkDicer::NumberOfPointsPerPiece [protected]

Definition at line 130 of file vtkDicer.h.

int vtkDicer::NumberOfPieces [protected]

Definition at line 131 of file vtkDicer.h.

unsigned long vtkDicer::MemoryLimit [protected]

Definition at line 132 of file vtkDicer.h.

int vtkDicer::NumberOfActualPieces [protected]

Definition at line 133 of file vtkDicer.h.

int vtkDicer::FieldData [protected]

Definition at line 134 of file vtkDicer.h.

int vtkDicer::DiceMode [protected]

Definition at line 135 of file vtkDicer.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDicer.h
Generated on Mon Mar 25 01:17:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDirectionEncoder Class Reference

encode a direction into a one or two byte value. More...

#include <vtkDirectionEncoder.h>

Inheritance diagram for vtkDirectionEncoder:

[legend]
Collaboration diagram for vtkDirectionEncoder:

[legend]
List of all members.

Public Methods

virtual int | GetEncodedDirection (float n[3])=0
virtual float * | GetDecodedGradient (int value)=0
virtual int | GetNumberOfEncodedDirections (void)=0
virtual float * | GetDecodedGradientTable (void)=0
vtkTypeRevisionMacro (vtkDirectionEncoder, vtkObject)

Protected Methods

vtkDirectionEncoder ()
~vtkDirectionEncoder ()

Detailed Description

encode a direction into a one or two byte value.

Date:
2002/01/22 15:38:30
Revision:
1.16

Given a direction, encode it into an integer value. This value should be less than 65536, which is the maximum number of encoded directions supported by this superclass. A direction encoded is used to encode normals in a volume for use during volume rendering, and the amount of space that is allocated per normal is 2 bytes. This is an abstract superclass - see the subclasses for specific implementation details.

See also:
vtkRecursiveSphereDirectionEncoder
Created by:
  • Avila, Lisa
  • King, Brad
Contributed by (if > 5%):
  • Avila, Lisa (70%)
  • King, Brad (20%)

Definition at line 49 of file vtkDirectionEncoder.h.

Constructor & Destructor Documentation

vtkDirectionEncoder::vtkDirectionEncoder ( ) [inline, protected]

Definition at line 73 of file vtkDirectionEncoder.h.

vtkDirectionEncoder::~vtkDirectionEncoder ( ) [inline, protected]

Definition at line 74 of file vtkDirectionEncoder.h.

Member Function Documentation

vtkDirectionEncoder::vtkTypeRevisionMacro | ( | vtkDirectionEncoder | ,
 |  | vtkObject |
 | ) |

Get the name of this class

Reimplemented in vtkRecursiveSphereDirectionEncoder.

virtual int vtkDirectionEncoder::GetEncodedDirection ( float n[3] ) [pure virtual]

Given a normal vector n, return the encoded direction

Reimplemented in vtkRecursiveSphereDirectionEncoder.

virtual float* vtkDirectionEncoder::GetDecodedGradient ( int value ) [pure virtual]

/ Given an encoded value, return a pointer to the normal vector

Reimplemented in vtkRecursiveSphereDirectionEncoder.

virtual int vtkDirectionEncoder::GetNumberOfEncodedDirections ( void ) [pure virtual]

Return the number of encoded directions

Reimplemented in vtkRecursiveSphereDirectionEncoder.

virtual float* vtkDirectionEncoder::GetDecodedGradientTable ( void ) [pure virtual]

Get the decoded gradient table. There are this->GetNumberOfEncodedDirections() entries in the table, each containing a normal (direction) vector. This is a flat structure - 3 times the number of directions floats in an array.

Reimplemented in vtkRecursiveSphereDirectionEncoder.

The documentation for this class was generated from the following file:
  • Rendering/vtkDirectionEncoder.h
Generated on Mon Mar 25 01:17:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDirectory Class Reference

OS independent class for access to system directories. More...

#include <vtkDirectory.h>

Inheritance diagram for vtkDirectory:

[legend]
Collaboration diagram for vtkDirectory:

[legend]
List of all members.

[NOHEADER]

virtual void | PrintSelf (ostream &os, vtkIndent indent)
int | Open (const char *dir)
int | GetNumberOfFiles ()
const char * | GetFile (int index)
vtkDirectory * | New ()

Public Methods

vtkTypeRevisionMacro (vtkDirectory, vtkObject)

Protected Methods

vtkDirectory ()
~vtkDirectory ()

Detailed Description

OS independent class for access to system directories.

Date:
2002/01/22 15:25:20
Revision:
1.16

vtkDirectory provides a portable way of finding the names of the files in a system directory.

Warning:
vtkDirectory works with windows and unix only.
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (89%)
  • Martin, Ken (6%)

Definition at line 42 of file vtkDirectory.h.

Constructor & Destructor Documentation

vtkDirectory::vtkDirectory ( ) [protected]

vtkDirectory::~vtkDirectory ( ) [protected]

Member Function Documentation

vtkDirectory::vtkTypeRevisionMacro | ( | vtkDirectory | ,
 |  | vtkObject |
 | ) |

Return the class name as a string.

vtkDirectory* vtkDirectory::New ( ) [inline, static]

Create a new vtkDirectory object.

Reimplemented from vtkObject.

Definition at line 52 of file vtkDirectory.h.

virtual void vtkDirectory::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print directory to stream.

Reimplemented from vtkObject.

int vtkDirectory::Open ( const char * dir )

Open the specified directory and load the names of the files in that directory. 0 is returned if the directory can not be opened, 1 if it is opened.

int vtkDirectory::GetNumberOfFiles ( ) [inline]

Print directory to stream.

Definition at line 69 of file vtkDirectory.h.

const char* vtkDirectory::GetFile ( int index )

Print directory to stream.

The documentation for this class was generated from the following file:
  • Common/vtkDirectory.h
Generated on Mon Mar 25 01:17:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDiskSource Class Reference

create a disk with hole in center. More...

#include <vtkDiskSource.h>

Inheritance diagram for vtkDiskSource:

[legend]
Collaboration diagram for vtkDiskSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDiskSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInnerRadius (float)
virtual float | GetInnerRadius ()
virtual void | SetOuterRadius (float)
virtual float | GetOuterRadius ()
virtual void | SetRadialResolution (int)
virtual int | GetRadialResolution ()
virtual void | SetCircumferentialResolution (int)
virtual int | GetCircumferentialResolution ()

Static Public Methods

vtkDiskSource * | New ()

Protected Methods

vtkDiskSource ()
~vtkDiskSource ()
void | Execute ()

Protected Attributes

float | InnerRadius
float | OuterRadius
int | RadialResolution
int | CircumferentialResolution

Detailed Description

create a disk with hole in center.

Date:
2002/01/22 15:29:18
Revision:
1.35

vtkDiskSource creates a polygonal disk with a hole in the center. The disk has zero height. The user can specify the inner and outer radius of the disk, and the radial and circumferential resolution of the polygonal representation.

See also:
vtkLinearExtrusionFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (82%)
  • Martin, Ken (12%)
Tests:
vtkDiskSource (Tests)

Definition at line 46 of file vtkDiskSource.h.

Constructor & Destructor Documentation

vtkDiskSource::vtkDiskSource ( ) [protected]

vtkDiskSource::~vtkDiskSource ( ) [inline, protected]

Definition at line 79 of file vtkDiskSource.h.

Member Function Documentation

vtkDiskSource* vtkDiskSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkDiskSource::vtkTypeRevisionMacro | ( | vtkDiskSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkDiskSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkDiskSource::SetInnerRadius ( float ) [virtual]

Specify inner radius of hole in disc.

virtual float vtkDiskSource::GetInnerRadius ( ) [virtual]

Specify inner radius of hole in disc.

virtual void vtkDiskSource::SetOuterRadius ( float ) [virtual]

Specify outer radius of disc.

virtual float vtkDiskSource::GetOuterRadius ( ) [virtual]

Specify outer radius of disc.

virtual void vtkDiskSource::SetRadialResolution ( int ) [virtual]

Set the number of points in radius direction.

virtual int vtkDiskSource::GetRadialResolution ( ) [virtual]

Set the number of points in radius direction.

virtual void vtkDiskSource::SetCircumferentialResolution ( int ) [virtual]

Set the number of points in circumferential direction.

virtual int vtkDiskSource::GetCircumferentialResolution ( ) [virtual]

Set the number of points in circumferential direction.

void vtkDiskSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkDiskSource::InnerRadius [protected]

Definition at line 82 of file vtkDiskSource.h.

float vtkDiskSource::OuterRadius [protected]

Definition at line 83 of file vtkDiskSource.h.

int vtkDiskSource::RadialResolution [protected]

Definition at line 84 of file vtkDiskSource.h.

int vtkDiskSource::CircumferentialResolution [protected]

Definition at line 85 of file vtkDiskSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDiskSource.h
Generated on Mon Mar 25 01:17:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDividingCubes Class Reference

create points lying on isosurface. More...

#include <vtkDividingCubes.h>

Inheritance diagram for vtkDividingCubes:

[legend]
Collaboration diagram for vtkDividingCubes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDividingCubes, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetDistance (float)
virtual float | GetDistance ()
virtual void | SetIncrement (int)
virtual int | GetIncrement ()

Static Public Methods

vtkDividingCubes * | New ()

Protected Methods

vtkDividingCubes ()
~vtkDividingCubes ()
void | Execute ()
void | SubDivide (float origin[3], int dim[3], float h[3], float values[8])

Protected Attributes

float | Value
float | Distance
int | Increment
int | Count
vtkIdList * SubVoxelPts
vtkVoxel * SubVoxel
vtkFloatArray * SubVoxelScalars
vtkFloatArray * SubVoxelNormals

Detailed Description

create points lying on isosurface.

Date:
2002/01/22 22:02:17
Revision:
1.46

vtkDividingCubes is a filter that generates points lying on a surface of constant scalar value (i.e., an isosurface). Dense point clouds (i.e., at screen resolution) will appear as a surface. Less dense clouds can be used as a source to generate streamlines or to generate "transparent" surfaces. This filter is based on the generate program written by H. Cline, S. Ludke and W. Lorensen.

The density of the point cloud is controlled by the Distance instance variable. This is a distance value in global coordinates specifying the approximate distance between points.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Law, Charles (8%)
  • Geveci, Berk (5%)
  • Lorensen, Bill (5%)
Tests:
vtkDividingCubes (Tests)

Definition at line 66 of file vtkDividingCubes.h.

Constructor & Destructor Documentation

vtkDividingCubes::vtkDividingCubes ( ) [protected]

vtkDividingCubes::~vtkDividingCubes ( ) [protected]

Member Function Documentation

vtkDividingCubes* vtkDividingCubes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkDividingCubes::vtkTypeRevisionMacro | ( | vtkDividingCubes | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

void vtkDividingCubes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkDividingCubes::SetValue ( float ) [virtual]

Set isosurface value.

virtual float vtkDividingCubes::GetValue ( ) [virtual]

Set isosurface value.

virtual void vtkDividingCubes::SetDistance ( float ) [virtual]

Specify sub-voxel size at which to generate point.

virtual float vtkDividingCubes::GetDistance ( ) [virtual]

Specify sub-voxel size at which to generate point.

virtual void vtkDividingCubes::SetIncrement ( int ) [virtual]

Every "Increment" point is added to the list of points. This parameter, if set to a large value, can be used to limit the number of points while retaining good accuracy.

virtual int vtkDividingCubes::GetIncrement ( ) [virtual]

Every "Increment" point is added to the list of points. This parameter, if set to a large value, can be used to limit the number of points while retaining good accuracy.

void vtkDividingCubes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkDividingCubes::SubDivide | ( | float | origin[3],
 |  | int | dim[3],
 |  | float | h[3],
 |  | float | values[8]
 | ) | [protected]

Member Data Documentation

float vtkDividingCubes::Value [protected]

Definition at line 100 of file vtkDividingCubes.h.

float vtkDividingCubes::Distance [protected]

Definition at line 101 of file vtkDividingCubes.h.

int vtkDividingCubes::Increment [protected]

Definition at line 102 of file vtkDividingCubes.h.

int vtkDividingCubes::Count [protected]

Definition at line 105 of file vtkDividingCubes.h.

vtkIdList* vtkDividingCubes::SubVoxelPts [protected]

Definition at line 107 of file vtkDividingCubes.h.

vtkVoxel* vtkDividingCubes::SubVoxel [protected]

Definition at line 108 of file vtkDividingCubes.h.

vtkFloatArray* vtkDividingCubes::SubVoxelScalars [protected]

Definition at line 109 of file vtkDividingCubes.h.

vtkFloatArray* vtkDividingCubes::SubVoxelNormals [protected]

Definition at line 110 of file vtkDividingCubes.h.

The documentation for this class was generated from the following file:
  • Patented/vtkDividingCubes.h
Generated on Mon Mar 25 01:17:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDoubleArray Class Reference

dynamic, self-adjusting double precision array. More...

#include <vtkDoubleArray.h>

Inheritance diagram for vtkDoubleArray:

[legend]
Collaboration diagram for vtkDoubleArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDoubleArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
double | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const double f)
vtkIdType | InsertNextValue (const double f)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
double * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const double value)
double * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (double *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkDoubleArray * | New ()

Protected Methods

vtkDoubleArray (vtkIdType numComp=1)
~vtkDoubleArray ()
double * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

double * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting double precision array.

Date:
2002/02/13 22:46:28
Revision:
1.55

vtkDoubleArray is an array of double precision numbers. It provides methods for insertion and retrieval of double precision values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (41%)
  • Martin, Ken (24%)
  • Henderson, Amy (7%)
  • Miller, Jim (6%)
  • Geveci, Berk (6%)
  • Kelly, Ann (5%)
Examples:
vtkDoubleArray (Examples)
Tests:
vtkDoubleArray (Tests)

Definition at line 49 of file vtkDoubleArray.h.

Constructor & Destructor Documentation

vtkDoubleArray::vtkDoubleArray ( vtkIdType numComp = 1 ) [protected]

vtkDoubleArray::~vtkDoubleArray ( ) [protected]

Member Function Documentation

vtkDoubleArray* vtkDoubleArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkDoubleArray::vtkTypeRevisionMacro | ( | vtkDoubleArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkDoubleArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkDoubleArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkDoubleArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkDoubleArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkDoubleArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkDoubleArray.h.

int vtkDoubleArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 71 of file vtkDoubleArray.h.

void vtkDoubleArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkDoubleArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkDoubleArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkDoubleArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkDoubleArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 107 of file vtkDoubleArray.h.

virtual void vtkDoubleArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

double vtkDoubleArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 113 of file vtkDoubleArray.h.

void vtkDoubleArray::SetValue | ( | const vtkIdType | id,
 |  | const double | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 118 of file vtkDoubleArray.h.

void vtkDoubleArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 194 of file vtkDoubleArray.h.

void vtkDoubleArray::InsertValue | ( | const vtkIdType | id,
 |  | const double | f
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 215 of file vtkDoubleArray.h.

Referenced by InsertNextValue().

vtkIdType vtkDoubleArray::InsertNextValue ( const double f ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 228 of file vtkDoubleArray.h.

float vtkDoubleArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkDoubleArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

virtual void vtkDoubleArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

double * vtkDoubleArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 200 of file vtkDoubleArray.h.

double* vtkDoubleArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 158 of file vtkDoubleArray.h.

void* vtkDoubleArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 159 of file vtkDoubleArray.h.

void vtkDoubleArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another double array.

Reimplemented from vtkDataArray.

void vtkDoubleArray::SetArray | ( | double * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkDoubleArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 174 of file vtkDoubleArray.h.

double* vtkDoubleArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

double* vtkDoubleArray::Array [protected]

Definition at line 182 of file vtkDoubleArray.h.

int vtkDoubleArray::TupleSize [protected]

Definition at line 185 of file vtkDoubleArray.h.

float* vtkDoubleArray::Tuple [protected]

Definition at line 186 of file vtkDoubleArray.h.

int vtkDoubleArray::SaveUserArray [protected]

Definition at line 188 of file vtkDoubleArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkDoubleArray.h
Generated on Mon Mar 25 01:17:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkDynamicLoader Class Reference

class interface to system dynamic libraries. More...

#include <vtkDynamicLoader.h>

Inheritance diagram for vtkDynamicLoader:

[legend]
Collaboration diagram for vtkDynamicLoader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkDynamicLoader, vtkObject)

Static Public Methods

vtkDynamicLoader * | New ()
vtkLibHandle | OpenLibrary (const char *)
void * | GetSymbolAddress (vtkLibHandle, const char *)
const char * | LibPrefix ()
const char * | LibExtension ()
const char * | LastError ()
int | CloseLibrary (vtkLibHandle)

Protected Methods

vtkDynamicLoader ()
~vtkDynamicLoader ()

Detailed Description

class interface to system dynamic libraries.

Date:
2002/01/22 15:25:20
Revision:
1.16

vtkDynamicLoader provides a portable interface to loading dynamic libraries into a process.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (73%)
  • Starreveld, Yves (12%)
  • Martin, Ken (6%)
  • Schroeder, Will (5%)

Definition at line 56 of file vtkDynamicLoader.h.

Constructor & Destructor Documentation

vtkDynamicLoader::vtkDynamicLoader ( ) [inline, protected]

Definition at line 87 of file vtkDynamicLoader.h.

vtkDynamicLoader::~vtkDynamicLoader ( ) [inline, protected]

Definition at line 88 of file vtkDynamicLoader.h.

Member Function Documentation

vtkDynamicLoader* vtkDynamicLoader::New ( ) [inline, static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Definition at line 59 of file vtkDynamicLoader.h.

vtkDynamicLoader::vtkTypeRevisionMacro | ( | vtkDynamicLoader | ,
 |  | vtkObject |
 | ) |

vtkLibHandle vtkDynamicLoader::OpenLibrary ( const char * ) [static]

Load a dynamic library into the current process. The returned vtkLibHandle can be used to access the symbols in the library.

int vtkDynamicLoader::CloseLibrary ( vtkLibHandle ) [static]

Attempt to detach a dynamic library from the process. A value of true is returned if it is successful.

void* vtkDynamicLoader::GetSymbolAddress | ( | vtkLibHandle | ,
 |  | const char * |
 | ) | [static]

Find the address of the symbol in the given library

const char* vtkDynamicLoader::LibPrefix ( ) [static]

Return the library prefix for the given architecture

const char* vtkDynamicLoader::LibExtension ( ) [static]

Return the library extension for the given architecture

const char* vtkDynamicLoader::LastError ( ) [static]

Return the last error produced from a calls made on this class.

The documentation for this class was generated from the following file:
  • Common/vtkDynamicLoader.h
Generated on Mon Mar 25 01:17:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEarthSource Class Reference

create the continents of the Earth as a sphere. More...

#include <vtkEarthSource.h>

Inheritance diagram for vtkEarthSource:

[legend]
Collaboration diagram for vtkEarthSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEarthSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetOnRatio (int)
virtual int | GetOnRatio ()
virtual void | SetOutline (int)
virtual int | GetOutline ()
virtual void | OutlineOn ()
virtual void | OutlineOff ()

Static Public Methods

vtkEarthSource * | New ()

Protected Methods

vtkEarthSource ()
~vtkEarthSource ()
void | Execute ()

Protected Attributes

float | Radius
int | OnRatio
int | Outline

Detailed Description

create the continents of the Earth as a sphere.

Date:
2002/01/22 15:30:28
Revision:
1.25

vtkEarthSource creates a spherical rendering of the geographical shapes of the major continents of the earth. The OnRatio determines how much of the data is actually used. The radius defines the radius of the sphere at which the continents are placed. Obtains data from an imbedded array of coordinates.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (98%)
Tests:
vtkEarthSource (Tests)

Definition at line 43 of file vtkEarthSource.h.

Constructor & Destructor Documentation

vtkEarthSource::vtkEarthSource ( ) [protected]

vtkEarthSource::~vtkEarthSource ( ) [inline, protected]

Definition at line 76 of file vtkEarthSource.h.

Member Function Documentation

vtkEarthSource* vtkEarthSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkEarthSource::vtkTypeRevisionMacro | ( | vtkEarthSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkEarthSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkEarthSource::SetRadius ( float ) [virtual]

Set radius of earth.

virtual float vtkEarthSource::GetRadius ( ) [virtual]

Set radius of earth.

virtual void vtkEarthSource::SetOnRatio ( int ) [virtual]

Turn on every nth entity. This controls how much detail the model will have. The maximum ratio is sixteen. (The smaller OnRatio, the more detail there is.)

virtual int vtkEarthSource::GetOnRatio ( ) [virtual]

Turn on every nth entity. This controls how much detail the model will have. The maximum ratio is sixteen. (The smaller OnRatio, the more detail there is.)

virtual void vtkEarthSource::SetOutline ( int ) [virtual]

Turn on/off drawing continents as filled polygons or as wireframe outlines. Warning: some graphics systems will have trouble with the very large, concave filled polygons. Recommend you use OutlienOn (i.e., disable filled polygons) for now.

virtual int vtkEarthSource::GetOutline ( ) [virtual]

Turn on/off drawing continents as filled polygons or as wireframe outlines. Warning: some graphics systems will have trouble with the very large, concave filled polygons. Recommend you use OutlienOn (i.e., disable filled polygons) for now.

virtual void vtkEarthSource::OutlineOn ( ) [virtual]

Turn on/off drawing continents as filled polygons or as wireframe outlines. Warning: some graphics systems will have trouble with the very large, concave filled polygons. Recommend you use OutlienOn (i.e., disable filled polygons) for now.

virtual void vtkEarthSource::OutlineOff ( ) [virtual]

Turn on/off drawing continents as filled polygons or as wireframe outlines. Warning: some graphics systems will have trouble with the very large, concave filled polygons. Recommend you use OutlienOn (i.e., disable filled polygons) for now.

void vtkEarthSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkEarthSource::Radius [protected]

Definition at line 80 of file vtkEarthSource.h.

int vtkEarthSource::OnRatio [protected]

Definition at line 81 of file vtkEarthSource.h.

int vtkEarthSource::Outline [protected]

Definition at line 82 of file vtkEarthSource.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkEarthSource.h
Generated on Mon Mar 25 01:17:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEdgePoints Class Reference

generate points on isosurface. More...

#include <vtkEdgePoints.h>

Inheritance diagram for vtkEdgePoints:

[legend]
Collaboration diagram for vtkEdgePoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEdgePoints, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetValue (float)
virtual float | GetValue ()

Static Public Methods

vtkEdgePoints * | New ()

Protected Methods

vtkEdgePoints ()
~vtkEdgePoints ()
void | Execute ()

Protected Attributes

float | Value
vtkMergePoints * Locator

Detailed Description

generate points on isosurface.

Date:
2002/01/22 15:29:18
Revision:
1.35

vtkEdgePoints is a filter that takes as input any dataset and generates for output a set of points that lie on an isosurface. The points are created by interpolation along cells edges whose end-points are below and above the contour value.

Warning:
vtkEdgePoints can be considered a "poor man's" dividing cubes algorithm (see vtkDividingCubes). Points are generated only on the edges of cells, not in the interior, and at lower density than dividing cubes. However, it is more general than dividing cubes since it treats any type of dataset.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (63%)
  • Law, Charles (10%)
  • Lorensen, Bill (10%)
  • Martin, Ken (5%)
Tests:
vtkEdgePoints (Tests)

Definition at line 51 of file vtkEdgePoints.h.

Constructor & Destructor Documentation

vtkEdgePoints::vtkEdgePoints ( ) [protected]

vtkEdgePoints::~vtkEdgePoints ( ) [protected]

Member Function Documentation

vtkEdgePoints::vtkTypeRevisionMacro | ( | vtkEdgePoints | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkEdgePoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkEdgePoints* vtkEdgePoints::New ( ) [static]

Construct object with contour value of 0.0.

Reimplemented from vtkPolyDataSource.

virtual void vtkEdgePoints::SetValue ( float ) [virtual]

Set/get the contour value.

virtual float vtkEdgePoints::GetValue ( ) [virtual]

Set/get the contour value.

void vtkEdgePoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkEdgePoints::Value [protected]

Definition at line 72 of file vtkEdgePoints.h.

vtkMergePoints* vtkEdgePoints::Locator [protected]

Definition at line 73 of file vtkEdgePoints.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkEdgePoints.h
Generated on Mon Mar 25 01:17:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEdgeTable Class Reference

keep track of edges (edge is pair of integer id's). More...

#include <vtkEdgeTable.h>

Inheritance diagram for vtkEdgeTable:

[legend]
Collaboration diagram for vtkEdgeTable:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEdgeTable, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Initialize ()
int | InitEdgeInsertion (vtkIdType numPoints, int storeAttributes=0)
vtkIdType | InsertEdge (vtkIdType p1, vtkIdType p2)
void | InsertEdge (vtkIdType p1, vtkIdType p2, int attributeId)
int | IsEdge (vtkIdType p1, vtkIdType p2)
int | InitPointInsertion (vtkPoints *newPts, vtkIdType estSize)
void | InitTraversal ()
int | GetNextEdge (vtkIdType &p1, vtkIdType &p2)
void | Reset ()
int | InsertUniquePoint (vtkIdType p1, vtkIdType p2, float x[3], vtkIdType &ptId)
virtual vtkIdType | GetNumberOfEdges ()

Static Public Methods

vtkEdgeTable * | New ()

Protected Methods

vtkEdgeTable ()
~vtkEdgeTable ()
vtkIdList ** | Resize (vtkIdType size)

Protected Attributes

vtkIdList ** Table
vtkIdList ** Attributes
int | StoreAttributes
vtkIdType TableMaxId
vtkIdType TableSize
int | Position [2]
int | Extend
vtkIdType NumberOfEdges
vtkPoints * Points

Detailed Description

keep track of edges (edge is pair of integer id's).

Date:
2002/01/22 15:25:21
Revision:
1.31

vtkEdgeTable is a general object for keeping track of lists of edges. An edge is defined by the pair of point id's (p1,p2). Methods are available to insert edges, check if edges exist, and traverse the list of edges. Also, it's possible to associate attribute information with each edge.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Martin, Ken (6%)
  • Henderson, Amy (5%)

Definition at line 44 of file vtkEdgeTable.h.

Constructor & Destructor Documentation

vtkEdgeTable::vtkEdgeTable ( ) [protected]

vtkEdgeTable::~vtkEdgeTable ( ) [protected]

Member Function Documentation

vtkEdgeTable* vtkEdgeTable::New ( ) [static]

Instantiate object assuming that 1000 edges are to be inserted.

Reimplemented from vtkObject.

vtkEdgeTable::vtkTypeRevisionMacro | ( | vtkEdgeTable | ,
 |  | vtkObject |
 | ) |

void vtkEdgeTable::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkEdgeTable::Initialize ( )

Free memory and return to instantiated state.

int vtkEdgeTable::InitEdgeInsertion | ( | vtkIdType | numPoints,
 |  | int | storeAttributes = 0
 | ) |

Initialize the edge insertion process. Provide an estimate of the number of points in a dataset (the maximum range value of p1 or p2). The storeAttributes variable controls whether attributes are to be stored with the edge. If on, additional memory will be required by the data structure to store an integer id per each edge. This method is used in conjunction with one of the two InsertEdge() methods described below (don't mix the InsertEdge() methods).

vtkIdType vtkEdgeTable::InsertEdge | ( | vtkIdType | p1,
 |  | vtkIdType | p2
 | ) |

Insert the edge (p1,p2) into the table. It is the user's responsibility to check if the edge has already been inserted (use IsEdge()). If the storeAttributes flag in InitEdgeInsertion() has been set, then the method returns a unique integer id (i.e., the edge id) that can be used to set and get edge attributes. Otherwise, the method will return 1. Do not mix this method with the InsertEdge() method that follows.

void vtkEdgeTable::InsertEdge | ( | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | int | attributeId
 | ) |

Insert the edge (p1,p2) into the table with the attribute id specified (make sure the attributeId >= 0). Note that the attributeId is ignored if the storeAttributes variable was set to 0 in the InitEdgeInsertion() method. It is the user's responsibility to check if the edge has already been inserted (use IsEdge()). Do not mix this method with the previous InsertEdge() method.

int vtkEdgeTable::IsEdge | ( | vtkIdType | p1,
 |  | vtkIdType | p2
 | ) |

Return an integer id for the edge, or an attributeId of the edge (p1,p2) if the edge has been previously defined (it depends upon which version of InsertEdge() is being used); otherwise -1. The unique integer id can be used to set and retrieve attributes to the edge.

int vtkEdgeTable::InitPointInsertion | ( | vtkPoints * | newPts,
 |  | vtkIdType | estSize
 | ) |

Initialize the point insertion process. The newPts is an object representing point coordinates into which incremental insertion methods place their data. The points are associated with the edge.

int vtkEdgeTable::InsertUniquePoint | ( | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | float | x[3],
 |  | vtkIdType & | ptId
 | ) |

Insert a unique point on the specified edge. Invoke this method only after InitPointInsertion() has been called. Return 0 if point was already in the list, otherwise return 1.

virtual vtkIdType vtkEdgeTable::GetNumberOfEdges ( ) [virtual]

Return the number of edges that have been inserted thus far.

void vtkEdgeTable::InitTraversal ( )

Intialize traversal of edges in table.

int vtkEdgeTable::GetNextEdge | ( | vtkIdType & | p1,
 |  | vtkIdType & | p2
 | ) |

Traverse list of edges in table. Return the edge as (p1,p2), where p1 and p2 are point id's. Method return value is zero if list is exhausted; non-zero otherwise. The value of p1 is guaranteed to be <= p2.

void vtkEdgeTable::Reset ( )

Reset the object and prepare for reinsertion of edges. Does not delete memory like the Initialize() method.

vtkIdList** vtkEdgeTable::Resize ( vtkIdType size ) [protected]

Member Data Documentation

vtkIdList** vtkEdgeTable::Table [protected]

Definition at line 124 of file vtkEdgeTable.h.

vtkIdList** vtkEdgeTable::Attributes [protected]

Definition at line 125 of file vtkEdgeTable.h.

int vtkEdgeTable::StoreAttributes [protected]

Definition at line 126 of file vtkEdgeTable.h.

vtkIdType vtkEdgeTable::TableMaxId [protected]

Definition at line 127 of file vtkEdgeTable.h.

vtkIdType vtkEdgeTable::TableSize [protected]

Definition at line 128 of file vtkEdgeTable.h.

int vtkEdgeTable::Position[2] [protected]

Definition at line 129 of file vtkEdgeTable.h.

int vtkEdgeTable::Extend [protected]

Definition at line 130 of file vtkEdgeTable.h.

vtkIdType vtkEdgeTable::NumberOfEdges [protected]

Definition at line 131 of file vtkEdgeTable.h.

vtkPoints* vtkEdgeTable::Points [protected]

Definition at line 132 of file vtkEdgeTable.h.

The documentation for this class was generated from the following file:
  • Common/vtkEdgeTable.h
Generated on Mon Mar 25 01:17:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkElevationFilter Class Reference

generate scalars along a specified direction. More...

#include <vtkElevationFilter.h>

Inheritance diagram for vtkElevationFilter:

[legend]
Collaboration diagram for vtkElevationFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkElevationFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetLowPoint (float, float, float)
virtual void | SetLowPoint (float[3])
virtual float * | GetLowPoint ()
virtual void | GetLowPoint (float data[3])
virtual void | SetHighPoint (float, float, float)
virtual void | SetHighPoint (float[3])
virtual float * | GetHighPoint ()
virtual void | GetHighPoint (float data[3])
virtual void | SetScalarRange (float, float)
void | SetScalarRange (float[2])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float data[2])

Static Public Methods

vtkElevationFilter * | New ()

Protected Methods

vtkElevationFilter ()
~vtkElevationFilter ()
void | Execute ()

Protected Attributes

float | LowPoint [3]
float | HighPoint [3]
float | ScalarRange [2]

Detailed Description

generate scalars along a specified direction.

Date:
2002/01/22 15:29:18
Revision:
1.37

vtkElevationFilter is a filter to generate scalar values from a dataset. The scalar values lie within a user specified range, and are generated by computing a projection of each dataset point onto a line. The line can be oriented arbitrarily. A typical example is to generate scalars based on elevation or height above a plane.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Martin, Ken (9%)
  • Lorensen, Bill (5%)
Examples:
vtkElevationFilter (Examples)
Tests:
vtkElevationFilter (Tests)

Definition at line 48 of file vtkElevationFilter.h.

Constructor & Destructor Documentation

vtkElevationFilter::vtkElevationFilter ( ) [protected]

vtkElevationFilter::~vtkElevationFilter ( ) [inline, protected]

Definition at line 78 of file vtkElevationFilter.h.

Member Function Documentation

vtkElevationFilter::vtkTypeRevisionMacro | ( | vtkElevationFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkElevationFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkElevationFilter* vtkElevationFilter::New ( ) [static]

Construct object with LowPoint=(0,0,0) and HighPoint=(0,0,1). Scalar range is (0,1).

Reimplemented from vtkDataSetSource.

virtual void vtkElevationFilter::SetLowPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Define one end of the line (small scalar values).

virtual void vtkElevationFilter::SetLowPoint ( float [3] ) [virtual]

Define one end of the line (small scalar values).

virtual float* vtkElevationFilter::GetLowPoint ( ) [virtual]

Define one end of the line (small scalar values).

virtual void vtkElevationFilter::GetLowPoint ( float data[3] ) [virtual]

Define one end of the line (small scalar values).

virtual void vtkElevationFilter::SetHighPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Define other end of the line (large scalar values).

virtual void vtkElevationFilter::SetHighPoint ( float [3] ) [virtual]

Define other end of the line (large scalar values).

virtual float* vtkElevationFilter::GetHighPoint ( ) [virtual]

Define other end of the line (large scalar values).

virtual void vtkElevationFilter::GetHighPoint ( float data[3] ) [virtual]

Define other end of the line (large scalar values).

virtual void vtkElevationFilter::SetScalarRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify range to map scalars into.

void vtkElevationFilter::SetScalarRange ( float [2] )

Specify range to map scalars into.

virtual float* vtkElevationFilter::GetScalarRange ( ) [virtual]

Specify range to map scalars into.

virtual void vtkElevationFilter::GetScalarRange ( float data[2] ) [virtual]

Specify range to map scalars into.

void vtkElevationFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkElevationFilter::LowPoint[3] [protected]

Definition at line 81 of file vtkElevationFilter.h.

float vtkElevationFilter::HighPoint[3] [protected]

Definition at line 82 of file vtkElevationFilter.h.

float vtkElevationFilter::ScalarRange[2] [protected]

Definition at line 83 of file vtkElevationFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkElevationFilter.h
Generated on Mon Mar 25 01:17:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEmptyCell Class Reference

an empty cell used as a place-holder during processing. More...

#include <vtkEmptyCell.h>

Inheritance diagram for vtkEmptyCell:

[legend]
Collaboration diagram for vtkEmptyCell:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEmptyCell, vtkCell)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int)
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts1, vtkCellArray *lines, vtkCellArray *verts2, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *pts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)

Static Public Methods

vtkEmptyCell * | New ()

Protected Methods

vtkEmptyCell ()
~vtkEmptyCell ()

Detailed Description

an empty cell used as a place-holder during processing.

Date:
2002/01/22 15:25:21
Revision:
1.33

vtkEmptyCell is a concrete implementation of vtkCell. It is used during processing to represented a deleted element.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Geveci, Berk (12%)
  • Law, Charles (7%)
Tests:
vtkEmptyCell (Tests)

Definition at line 42 of file vtkEmptyCell.h.

Constructor & Destructor Documentation

vtkEmptyCell::vtkEmptyCell ( ) [inline, protected]

Definition at line 82 of file vtkEmptyCell.h.

vtkEmptyCell::~vtkEmptyCell ( ) [inline, protected]

Definition at line 83 of file vtkEmptyCell.h.

Member Function Documentation

vtkEmptyCell* vtkEmptyCell::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Referenced by MakeObject().

vtkEmptyCell::vtkTypeRevisionMacro | ( | vtkEmptyCell | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkEmptyCell::MakeObject ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 50 of file vtkEmptyCell.h.

int vtkEmptyCell::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 51 of file vtkEmptyCell.h.

int vtkEmptyCell::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 52 of file vtkEmptyCell.h.

int vtkEmptyCell::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 53 of file vtkEmptyCell.h.

int vtkEmptyCell::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 54 of file vtkEmptyCell.h.

vtkCell* vtkEmptyCell::GetEdge ( int edgeId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 55 of file vtkEmptyCell.h.

vtkCell* vtkEmptyCell::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 56 of file vtkEmptyCell.h.

int vtkEmptyCell::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkEmptyCell::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts1,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | verts2,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkEmptyCell::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | pts,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkEmptyCell::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

Given a point x[3] return inside(=1) or outside(=0) cell; evaluate parametric coordinates, sub-cell id (!=0 only if cell is composite), distance squared of point x[3] to cell (in particular, the sub-cell indicated), closest point on cell to x[3] (unless closestPoint is null, in which case, the closest point and dist2 are not found), and interpolation weights in cell. (The number of weights is equal to the number of points defining the cell). Note: on rare occasions a -1 is returned from the method. This means that numerical error has occurred and all data returned from this method should be ignored. Also, inside/outside is determine parametrically. That is, a point is inside if it satisfies parametric limits. This can cause problems for cells of topological dimension 2 or less, since a point in 3D can project onto the cell within parametric limits but be "far" from the cell. Thus the value dist2 may be checked to determine true in/out.

Reimplemented from vtkCell.

void vtkEmptyCell::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

Determine global coordinate (x[3]) from subId and parametric coordinates. Also returns interpolation weights. (The number of weights is equal to the number of points in the cell.)

Reimplemented from vtkCell.

int vtkEmptyCell::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Intersect with a ray. Return parametric coordinates (both line and cell) and global intersection coordinates, given ray definition and tolerance. The method returns non-zero value if intersection occurs.

Reimplemented from vtkCell.

int vtkEmptyCell::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

Generate simplices of proper dimension. If cell is 3D, tetrahedron are generated; if 2D triangles; if 1D lines; if 0D points. The form of the output is a sequence of points, each n+1 points (where n is topological cell dimension) defining a simplex. The index is a parameter that controls which triangulation to use (if more than one is possible). If numerical degeneracy encountered, 0 is returned, otherwise 1 is returned.

Reimplemented from vtkCell.

void vtkEmptyCell::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

Compute derivatives given cell subId and parametric coordinates. The values array is a series of data value(s) at the cell points. There is a one-to-one correspondence between cell point and data value(s). Dim is the number of data values per cell point. Derivs are derivatives in the x-y-z coordinate directions for each data value. Thus, if computing derivatives for a scalar function in a hexahedron, dim=1, 8 values are supplied, and 3 deriv values are returned (i.e., derivatives in x-y-z directions). On the other hand, if computing derivatives of velocity (vx,vy,vz) dim=3, 24 values are supplied ((vx,vy,vz)1, (vx,vy,vz)2, ....()8), and 9 deriv values are returned ((d(vx)/dx),(d(vx)/dy),(d(vx)/dz), (d(vy)/dx),(d(vy)/dy), (d(vy)/dz), (d(vz)/dx),(d(vz)/dy),(d(vz)/dz)).

Reimplemented from vtkCell.

The documentation for this class was generated from the following file:
  • Common/vtkEmptyCell.h
Generated on Mon Mar 25 01:17:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEncodedGradientEstimator Class Reference

Superclass for gradient estimation. More...

#include <vtkEncodedGradientEstimator.h>

Inheritance diagram for vtkEncodedGradientEstimator:

[legend]
Collaboration diagram for vtkEncodedGradientEstimator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEncodedGradientEstimator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent index)
void | Update (void)
unsigned short * | GetEncodedNormals (void)
unsigned char * | GetGradientMagnitudes (void)
virtual int | GetUseCylinderClip ()
int * | GetCircleLimits ()
virtual int * | GetInputSize ()
virtual void | GetInputSize (int data[3])
virtual float * | GetInputAspect ()
virtual void | GetInputAspect (float data[3])
virtual void | SetInput (vtkImageData *)
virtual vtkImageData * | GetInput ()
virtual void | SetGradientMagnitudeScale (float)
virtual float | GetGradientMagnitudeScale ()
virtual void | SetGradientMagnitudeBias (float)
virtual float | GetGradientMagnitudeBias ()
virtual void | SetBoundsClip (int)
virtual int | GetBoundsClip ()
virtual void | BoundsClipOn ()
virtual void | BoundsClipOff ()
virtual void | SetBounds (int, int, int, int, int, int)
virtual void | SetBounds (int[6])
virtual int * | GetBounds ()
virtual void | GetBounds (int data[6])
int | GetEncodedNormalIndex (int xyz_index)
int | GetEncodedNormalIndex (int x_index, int y_index, int z_index)
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
void | SetDirectionEncoder (vtkDirectionEncoder *direnc)
virtual vtkDirectionEncoder * | GetDirectionEncoder ()
virtual void | SetComputeGradientMagnitudes (int)
virtual int | GetComputeGradientMagnitudes ()
virtual void | ComputeGradientMagnitudesOn ()
virtual void | ComputeGradientMagnitudesOff ()
virtual void | SetCylinderClip (int)
virtual int | GetCylinderClip ()
virtual void | CylinderClipOn ()
virtual void | CylinderClipOff ()
virtual float | GetLastUpdateTimeInSeconds ()
virtual float | GetLastUpdateTimeInCPUSeconds ()
void | SetZeroNormalThreshold (float v)
virtual float | GetZeroNormalThreshold ()
virtual void | SetZeroPad (int)
virtual int | GetZeroPad ()
virtual void | ZeroPadOn ()
virtual void | ZeroPadOff ()

Public Attributes

vtkImageData * Input
unsigned short * | EncodedNormals
int | EncodedNormalsSize [3]
unsigned char * | GradientMagnitudes
vtkTimeStamp BuildTime

Protected Methods

vtkEncodedGradientEstimator ()
~vtkEncodedGradientEstimator ()
virtual void | UpdateNormals (void)=0
void | ComputeCircleLimits (int size)

Protected Attributes

int | NumberOfThreads
vtkMultiThreader * Threader
vtkDirectionEncoder * DirectionEncoder
float | GradientMagnitudeScale
float | GradientMagnitudeBias
float | LastUpdateTimeInSeconds
float | LastUpdateTimeInCPUSeconds
float | ZeroNormalThreshold
int | CylinderClip
int * | CircleLimits
int | CircleLimitsSize
int | UseCylinderClip
int | BoundsClip
int | Bounds [6]
int | InputSize [3]
float | InputAspect [3]
int | ComputeGradientMagnitudes
int | ZeroPad

Detailed Description

Superclass for gradient estimation.

Date:
2002/01/22 15:38:30
Revision:
1.28

vtkEncodedGradientEstimator is an abstract superclass for gradient estimation. It takes a scalar input of vtkImageData, computes a gradient value for every point, and encodes this value into a three byte value (2 for direction, 1 for magnitude) using the vtkDirectionEncoder. The direction encoder is defaulted to a vtkRecursiveSphereDirectionEncoder, but can be overridden with the SetDirectionEncoder method. The scale and the bias values for the gradient magnitude are used to convert it into a one byte value according to v = m*scale + bias where m is the magnitude and v is the resulting one byte value.

See also:
vtkFiniteDifferenceGradientEstimator vtkDirectionEncoder
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (90%)

Definition at line 51 of file vtkEncodedGradientEstimator.h.

Constructor & Destructor Documentation

vtkEncodedGradientEstimator::vtkEncodedGradientEstimator ( ) [protected]

vtkEncodedGradientEstimator::~vtkEncodedGradientEstimator ( ) [protected]

Member Function Documentation

vtkEncodedGradientEstimator::vtkTypeRevisionMacro | ( | vtkEncodedGradientEstimator | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkFiniteDifferenceGradientEstimator.

void vtkEncodedGradientEstimator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkFiniteDifferenceGradientEstimator.

virtual void vtkEncodedGradientEstimator::SetInput ( vtkImageData * ) [virtual]

Set/Get the scalar input for which the normals will be calculated

virtual vtkImageData* vtkEncodedGradientEstimator::GetInput ( ) [virtual]

Set/Get the scalar input for which the normals will be calculated

virtual void vtkEncodedGradientEstimator::SetGradientMagnitudeScale ( float ) [virtual]

Set/Get the scale and bias for the gradient magnitude

virtual float vtkEncodedGradientEstimator::GetGradientMagnitudeScale ( ) [virtual]

Set/Get the scale and bias for the gradient magnitude

virtual void vtkEncodedGradientEstimator::SetGradientMagnitudeBias ( float ) [virtual]

Set/Get the scale and bias for the gradient magnitude

virtual float vtkEncodedGradientEstimator::GetGradientMagnitudeBias ( ) [virtual]

Set/Get the scale and bias for the gradient magnitude

virtual void vtkEncodedGradientEstimator::SetBoundsClip ( int ) [virtual]

Turn on / off the bounding of the normal computation by the this->Bounds bounding box

virtual int vtkEncodedGradientEstimator::GetBoundsClip ( ) [virtual]

Turn on / off the bounding of the normal computation by the this->Bounds bounding box

virtual void vtkEncodedGradientEstimator::BoundsClipOn ( ) [virtual]

Turn on / off the bounding of the normal computation by the this->Bounds bounding box

virtual void vtkEncodedGradientEstimator::BoundsClipOff ( ) [virtual]

Turn on / off the bounding of the normal computation by the this->Bounds bounding box

virtual void vtkEncodedGradientEstimator::SetBounds | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set / Get the bounds of the computation (used if this->ComputationBounds is 1.) The bounds are specified xmin, xmax, ymin, ymax, zmin, zmax.

virtual void vtkEncodedGradientEstimator::SetBounds ( int [6] ) [virtual]

Set / Get the bounds of the computation (used if this->ComputationBounds is 1.) The bounds are specified xmin, xmax, ymin, ymax, zmin, zmax.

virtual int* vtkEncodedGradientEstimator::GetBounds ( ) [virtual]

Set / Get the bounds of the computation (used if this->ComputationBounds is 1.) The bounds are specified xmin, xmax, ymin, ymax, zmin, zmax.

virtual void vtkEncodedGradientEstimator::GetBounds ( int data[6] ) [virtual]

Set / Get the bounds of the computation (used if this->ComputationBounds is 1.) The bounds are specified xmin, xmax, ymin, ymax, zmin, zmax.

void vtkEncodedGradientEstimator::Update ( void )

Recompute the encoded normals and gradient magnitudes.

unsigned short* vtkEncodedGradientEstimator::GetEncodedNormals ( void )

Get the encoded normals.

int vtkEncodedGradientEstimator::GetEncodedNormalIndex ( int xyz_index )

Get the encoded normal at an x,y,z location in the volume

int vtkEncodedGradientEstimator::GetEncodedNormalIndex | ( | int | x_index,
 |  | int | y_index,
 |  | int | z_index
 | ) |

Get the encoded normal at an x,y,z location in the volume

unsigned char* vtkEncodedGradientEstimator::GetGradientMagnitudes ( void )

Get the gradient magnitudes

virtual void vtkEncodedGradientEstimator::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create when encoding normals This defaults to the number of available processors on the machine

virtual int vtkEncodedGradientEstimator::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create when encoding normals This defaults to the number of available processors on the machine

void vtkEncodedGradientEstimator::SetDirectionEncoder ( vtkDirectionEncoder * direnc )

Set / Get the direction encoder used to encode normal directions to fit within two bytes

virtual vtkDirectionEncoder* vtkEncodedGradientEstimator::GetDirectionEncoder ( ) [virtual]

Set / Get the direction encoder used to encode normal directions to fit within two bytes

virtual void vtkEncodedGradientEstimator::SetComputeGradientMagnitudes ( int ) [virtual]

If you don't want to compute gradient magnitudes (but you do want normals for shading) this can be used. Be careful - if if you a non-constant gradient magnitude transfer function and you turn this on, it may crash

virtual int vtkEncodedGradientEstimator::GetComputeGradientMagnitudes ( ) [virtual]

If you don't want to compute gradient magnitudes (but you do want normals for shading) this can be used. Be careful - if if you a non-constant gradient magnitude transfer function and you turn this on, it may crash

virtual void vtkEncodedGradientEstimator::ComputeGradientMagnitudesOn ( ) [virtual]

If you don't want to compute gradient magnitudes (but you do want normals for shading) this can be used. Be careful - if if you a non-constant gradient magnitude transfer function and you turn this on, it may crash

virtual void vtkEncodedGradientEstimator::ComputeGradientMagnitudesOff ( ) [virtual]

If you don't want to compute gradient magnitudes (but you do want normals for shading) this can be used. Be careful - if if you a non-constant gradient magnitude transfer function and you turn this on, it may crash

virtual void vtkEncodedGradientEstimator::SetCylinderClip ( int ) [virtual]

If the data in each slice is only contained within a circle circumscribed within the slice, and the slice is square, then don't compute anything outside the circle. This circle through the slices forms a cylinder.

virtual int vtkEncodedGradientEstimator::GetCylinderClip ( ) [virtual]

If the data in each slice is only contained within a circle circumscribed within the slice, and the slice is square, then don't compute anything outside the circle. This circle through the slices forms a cylinder.

virtual void vtkEncodedGradientEstimator::CylinderClipOn ( ) [virtual]

If the data in each slice is only contained within a circle circumscribed within the slice, and the slice is square, then don't compute anything outside the circle. This circle through the slices forms a cylinder.

virtual void vtkEncodedGradientEstimator::CylinderClipOff ( ) [virtual]

If the data in each slice is only contained within a circle circumscribed within the slice, and the slice is square, then don't compute anything outside the circle. This circle through the slices forms a cylinder.

virtual float vtkEncodedGradientEstimator::GetLastUpdateTimeInSeconds ( ) [virtual]

Get the time required for the last update in seconds or cpu seconds

virtual float vtkEncodedGradientEstimator::GetLastUpdateTimeInCPUSeconds ( ) [virtual]

Get the time required for the last update in seconds or cpu seconds

virtual int vtkEncodedGradientEstimator::GetUseCylinderClip ( ) [virtual]

int* vtkEncodedGradientEstimator::GetCircleLimits ( ) [inline]

Definition at line 143 of file vtkEncodedGradientEstimator.h.

void vtkEncodedGradientEstimator::SetZeroNormalThreshold ( float v )

Set / Get the ZeroNormalThreshold - this defines the minimum magnitude of a gradient that is considered sufficient to define a direction. Gradients with magnitudes at or less than this value are given a "zero normal" index. These are handled specially in the shader, and you can set the intensity of light for these zero normals in the gradient shader.

virtual float vtkEncodedGradientEstimator::GetZeroNormalThreshold ( ) [virtual]

Set / Get the ZeroNormalThreshold - this defines the minimum magnitude of a gradient that is considered sufficient to define a direction. Gradients with magnitudes at or less than this value are given a "zero normal" index. These are handled specially in the shader, and you can set the intensity of light for these zero normals in the gradient shader.

virtual void vtkEncodedGradientEstimator::SetZeroPad ( int ) [virtual]

Assume that the data value outside the volume is zero when computing normals.

virtual int vtkEncodedGradientEstimator::GetZeroPad ( ) [virtual]

Assume that the data value outside the volume is zero when computing normals.

virtual void vtkEncodedGradientEstimator::ZeroPadOn ( ) [virtual]

Assume that the data value outside the volume is zero when computing normals.

virtual void vtkEncodedGradientEstimator::ZeroPadOff ( ) [virtual]

Assume that the data value outside the volume is zero when computing normals.

virtual int* vtkEncodedGradientEstimator::GetInputSize ( ) [virtual]

virtual void vtkEncodedGradientEstimator::GetInputSize ( int data[3] ) [virtual]

virtual float* vtkEncodedGradientEstimator::GetInputAspect ( ) [virtual]

virtual void vtkEncodedGradientEstimator::GetInputAspect ( float data[3] ) [virtual]

virtual void vtkEncodedGradientEstimator::UpdateNormals ( void ) [protected, pure virtual]

Reimplemented in vtkFiniteDifferenceGradientEstimator.

void vtkEncodedGradientEstimator::ComputeCircleLimits ( int size ) [protected]

Member Data Documentation

vtkImageData* vtkEncodedGradientEstimator::Input

Definition at line 171 of file vtkEncodedGradientEstimator.h.

unsigned short* vtkEncodedGradientEstimator::EncodedNormals

Definition at line 174 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::EncodedNormalsSize[3]

Definition at line 175 of file vtkEncodedGradientEstimator.h.

unsigned char* vtkEncodedGradientEstimator::GradientMagnitudes

Definition at line 178 of file vtkEncodedGradientEstimator.h.

vtkTimeStamp vtkEncodedGradientEstimator::BuildTime

Definition at line 181 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::NumberOfThreads [protected]

Definition at line 193 of file vtkEncodedGradientEstimator.h.

vtkMultiThreader* vtkEncodedGradientEstimator::Threader [protected]

Definition at line 195 of file vtkEncodedGradientEstimator.h.

vtkDirectionEncoder* vtkEncodedGradientEstimator::DirectionEncoder [protected]

Definition at line 197 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::GradientMagnitudeScale [protected]

Definition at line 201 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::GradientMagnitudeBias [protected]

Definition at line 202 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::LastUpdateTimeInSeconds [protected]

Definition at line 204 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::LastUpdateTimeInCPUSeconds [protected]

Definition at line 205 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::ZeroNormalThreshold [protected]

Definition at line 207 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::CylinderClip [protected]

Definition at line 209 of file vtkEncodedGradientEstimator.h.

int* vtkEncodedGradientEstimator::CircleLimits [protected]

Definition at line 210 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::CircleLimitsSize [protected]

Definition at line 211 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::UseCylinderClip [protected]

Definition at line 212 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::BoundsClip [protected]

Definition at line 215 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::Bounds[6] [protected]

Definition at line 216 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::InputSize[3] [protected]

Definition at line 218 of file vtkEncodedGradientEstimator.h.

float vtkEncodedGradientEstimator::InputAspect[3] [protected]

Definition at line 219 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::ComputeGradientMagnitudes [protected]

Definition at line 221 of file vtkEncodedGradientEstimator.h.

int vtkEncodedGradientEstimator::ZeroPad [protected]

Definition at line 223 of file vtkEncodedGradientEstimator.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkEncodedGradientEstimator.h
Generated on Mon Mar 25 01:17:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEncodedGradientShader Class Reference

Compute shading tables for encoded normals. More...

#include <vtkEncodedGradientShader.h>

Inheritance diagram for vtkEncodedGradientShader:

[legend]
Collaboration diagram for vtkEncodedGradientShader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEncodedGradientShader, vtkObject)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | SetZeroNormalDiffuseIntensity (float)
virtual float | GetZeroNormalDiffuseIntensity ()
virtual void | SetZeroNormalSpecularIntensity (float)
virtual float | GetZeroNormalSpecularIntensity ()
void | UpdateShadingTable (vtkRenderer *ren, vtkVolume *vol, vtkEncodedGradientEstimator *gradest)
float * | GetRedDiffuseShadingTable (vtkVolume *vol)
float * | GetGreenDiffuseShadingTable (vtkVolume *vol)
float * | GetBlueDiffuseShadingTable (vtkVolume *vol)
float * | GetRedSpecularShadingTable (vtkVolume *vol)
float * | GetGreenSpecularShadingTable (vtkVolume *vol)
float * | GetBlueSpecularShadingTable (vtkVolume *vol)

Static Public Methods

vtkEncodedGradientShader * | New ()

Protected Methods

vtkEncodedGradientShader ()
~vtkEncodedGradientShader ()
void | BuildShadingTable (int index, float lightDirection[3], float lightColor[3], float lightIntensity, float viewDirection[3], float material[4], int twoSided, vtkEncodedGradientEstimator *gradest, int updateFlag)

Protected Attributes

float * | ShadingTable [VTK_MAX_SHADING_TABLES][6]
vtkVolume * | ShadingTableVolume [VTK_MAX_SHADING_TABLES]
int | ShadingTableSize [VTK_MAX_SHADING_TABLES]
float | ZeroNormalDiffuseIntensity
float | ZeroNormalSpecularIntensity

Detailed Description

Compute shading tables for encoded normals.

Date:
2002/01/22 15:38:31
Revision:
1.23

vtkEncodedGradientShader computes shading tables for encoded normals that indicates the amount of diffuse and specular illumination that is received from all light sources at a surface location with that normal. For diffuse illumination this is accurate, but for specular illumination it is approximate for perspective projections since the center view direction is always used as the view direction. Since the shading table is dependent on the volume (for the transformation that must be applied to the normals to put them into world coordinates) there is a shading table per volume. This is necessary because multiple volumes can share a volume mapper.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (89%)
  • Lorensen, Bill (6%)

Definition at line 54 of file vtkEncodedGradientShader.h.

Constructor & Destructor Documentation

vtkEncodedGradientShader::vtkEncodedGradientShader ( ) [protected]

vtkEncodedGradientShader::~vtkEncodedGradientShader ( ) [protected]

Member Function Documentation

vtkEncodedGradientShader* vtkEncodedGradientShader::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkEncodedGradientShader::vtkTypeRevisionMacro | ( | vtkEncodedGradientShader | ,
 |  | vtkObject |
 | ) |

void vtkEncodedGradientShader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Print the vtkEncodedGradientShader

Reimplemented from vtkObject.

virtual void vtkEncodedGradientShader::SetZeroNormalDiffuseIntensity ( float ) [virtual]

Set / Get the intensity diffuse / specular light used for the zero normals.

virtual float vtkEncodedGradientShader::GetZeroNormalDiffuseIntensity ( ) [virtual]

Set / Get the intensity diffuse / specular light used for the zero normals.

virtual void vtkEncodedGradientShader::SetZeroNormalSpecularIntensity ( float ) [virtual]

Set / Get the intensity diffuse / specular light used for the zero normals.

virtual float vtkEncodedGradientShader::GetZeroNormalSpecularIntensity ( ) [virtual]

Set / Get the intensity diffuse / specular light used for the zero normals.

void vtkEncodedGradientShader::UpdateShadingTable | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | vtkEncodedGradientEstimator * | gradest
 | ) |

Cause the shading table to be updated

float* vtkEncodedGradientShader::GetRedDiffuseShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

float* vtkEncodedGradientShader::GetGreenDiffuseShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

float* vtkEncodedGradientShader::GetBlueDiffuseShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

float* vtkEncodedGradientShader::GetRedSpecularShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

float* vtkEncodedGradientShader::GetGreenSpecularShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

float* vtkEncodedGradientShader::GetBlueSpecularShadingTable ( vtkVolume * vol )

Get the red/green/blue shading table.

void vtkEncodedGradientShader::BuildShadingTable | ( | int | index,
 |  | float | lightDirection[3],
 |  | float | lightColor[3],
 |  | float | lightIntensity,
 |  | float | viewDirection[3],
 |  | float | material[4],
 |  | int | twoSided,
 |  | vtkEncodedGradientEstimator * | gradest,
 |  | int | updateFlag
 | ) | [protected]

Build a shading table for a light with the specified direction, and color for an object of the specified material properties. material[0] = ambient, material[1] = diffuse, material[2] = specular and material[3] = specular exponent. If the ambient flag is 1, then ambient illumination is added. If not, then this means we are calculating the "other side" of two sided lighting, so no ambient intensity is added in. If the update flag is 0, the shading table is overwritten with these new shading values. If the updateFlag is 1, then the computed light contribution is added to the current shading table values. There is one shading table per volume, and the index value indicated which index table should be used. It is computed in the UpdateShadingTable method.

Member Data Documentation

float* vtkEncodedGradientShader::ShadingTable[VTK_MAX_SHADING_TABLES][6] [protected]

Definition at line 121 of file vtkEncodedGradientShader.h.

vtkVolume* vtkEncodedGradientShader::ShadingTableVolume[VTK_MAX_SHADING_TABLES] [protected]

Definition at line 122 of file vtkEncodedGradientShader.h.

int vtkEncodedGradientShader::ShadingTableSize[VTK_MAX_SHADING_TABLES] [protected]

Definition at line 123 of file vtkEncodedGradientShader.h.

float vtkEncodedGradientShader::ZeroNormalDiffuseIntensity [protected]

Definition at line 127 of file vtkEncodedGradientShader.h.

float vtkEncodedGradientShader::ZeroNormalSpecularIntensity [protected]

Definition at line 128 of file vtkEncodedGradientShader.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkEncodedGradientShader.h
Generated on Mon Mar 25 01:17:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSight6BinaryReader Class Reference

class to read binary EnSight6 files. More...

#include <vtkEnSight6BinaryReader.h>

Inheritance diagram for vtkEnSight6BinaryReader:

[legend]
Collaboration diagram for vtkEnSight6BinaryReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEnSight6BinaryReader, vtkEnSightReader)

Static Public Methods

vtkEnSight6BinaryReader * | New ()

Protected Methods

vtkEnSight6BinaryReader ()
~vtkEnSight6BinaryReader ()
virtual int | ReadGeometryFile (char *fileName, int timeStep)
virtual int | ReadMeasuredGeometryFile (char *fileName, int timeStep)
virtual int | CreateUnstructuredGridOutput (int partId, char line[256])
virtual int | CreateStructuredGridOutput (int partId, char line[256])
int | ReadLine (char result[80])
int | ReadInt (int *result)
int | ReadIntArray (int *result, int numInts)
int | ReadFloatArray (float *result, int numFloats)
virtual int | ReadScalarsPerNode (char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerNode (char *fileName, char *description, int timeStep, int measured=0)
virtual int | ReadTensorsPerNode (char *fileName, char *description, int timeStep)
virtual int | ReadScalarsPerElement (char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerElement (char *fileName, char *description, int timeStep)
virtual int | ReadTensorsPerElement (char *fileName, char *description, int timeStep)
void | SkipTimeStep ()
int | SkipStructuredGrid (char line[256])
int | SkipUnstructuredGrid (char line[256])

Protected Attributes

int | NumberOfUnstructuredPoints
vtkPoints * UnstructuredPoints
vtkIdList * UnstructuredNodeIds
int | ElementIdsListed
FILE * | IFile

Detailed Description

class to read binary EnSight6 files.

Date:
2002/01/22 15:38:12
Revision:
1.11

vtkEnSight6BinaryReader is a class to read binary EnSight6 files into vtk. Because the different parts of the EnSight data can be of various data types, this reader produces multiple outputs, one per part in the input file. All variable information is being stored in field data. The descriptions listed in the case file are used as the array names in the field data. For complex vector variables, the description is appended with _r (for the array of real values) and _i (for the array if imaginary values). Complex scalar variables are stored as a single array with 2 components, real and imaginary, listed in that order.

Warning:
You must manually call Update on this reader and then connect the rest of the pipeline because (due to the nature of the file format) it is not possible to know ahead of time how many outputs you will have or what types they will be. This reader can only handle static EnSight datasets (both static geometry and variables).
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (96%)

Definition at line 52 of file vtkEnSight6BinaryReader.h.

Constructor & Destructor Documentation

vtkEnSight6BinaryReader::vtkEnSight6BinaryReader ( ) [protected]

vtkEnSight6BinaryReader::~vtkEnSight6BinaryReader ( ) [protected]

Member Function Documentation

vtkEnSight6BinaryReader* vtkEnSight6BinaryReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkEnSight6BinaryReader::vtkTypeRevisionMacro | ( | vtkEnSight6BinaryReader | ,
 |  | vtkEnSightReader |
 | ) |

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadMeasuredGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the measured geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadScalarsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per node for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the scalars array, we assume that 0 is the first component added to the array.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadVectorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0
 | ) | [protected, virtual]

Read vectors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadTensorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadScalarsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per element for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the scalars array, we assume that 0 is the first component added to the array.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadVectorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read vectors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::ReadTensorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::CreateUnstructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read an unstructured part (partId) from the geometry file and create a vtkUnstructuredGrid output. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6BinaryReader::CreateStructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read a structured part from the geometry file and create a vtkStructuredGridOutput. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

int vtkEnSight6BinaryReader::ReadLine ( char result[80] ) [protected]

Internal function to read in a line up to 80 characters. Returns zero if there was an error.

int vtkEnSight6BinaryReader::ReadInt ( int * result ) [protected]

Internal function to read in a single integer. Returns zero if there was an error.

int vtkEnSight6BinaryReader::ReadIntArray | ( | int * | result,
 |  | int | numInts
 | ) | [protected]

Internal function to read in an integer array. Returns zero if there was an error.

int vtkEnSight6BinaryReader::ReadFloatArray | ( | float * | result,
 |  | int | numFloats
 | ) | [protected]

Internal function to read in a float array. Returns zero if there was an error.

void vtkEnSight6BinaryReader::SkipTimeStep ( ) [protected]

Read to the next time step in the geometry file.

int vtkEnSight6BinaryReader::SkipStructuredGrid ( char line[256] ) [protected]

Read to the next time step in the geometry file.

int vtkEnSight6BinaryReader::SkipUnstructuredGrid ( char line[256] ) [protected]

Read to the next time step in the geometry file.

Member Data Documentation

int vtkEnSight6BinaryReader::NumberOfUnstructuredPoints [protected]

Definition at line 151 of file vtkEnSight6BinaryReader.h.

vtkPoints* vtkEnSight6BinaryReader::UnstructuredPoints [protected]

Definition at line 152 of file vtkEnSight6BinaryReader.h.

vtkIdList* vtkEnSight6BinaryReader::UnstructuredNodeIds [protected]

Definition at line 153 of file vtkEnSight6BinaryReader.h.

int vtkEnSight6BinaryReader::ElementIdsListed [protected]

Definition at line 155 of file vtkEnSight6BinaryReader.h.

FILE* vtkEnSight6BinaryReader::IFile [protected]

Definition at line 157 of file vtkEnSight6BinaryReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkEnSight6BinaryReader.h
Generated on Mon Mar 25 01:17:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSight6Reader Class Reference

class to read EnSight6 files. More...

#include <vtkEnSight6Reader.h>

Inheritance diagram for vtkEnSight6Reader:

[legend]
Collaboration diagram for vtkEnSight6Reader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEnSight6Reader, vtkEnSightReader)

Static Public Methods

vtkEnSight6Reader * | New ()

Protected Methods

vtkEnSight6Reader ()
~vtkEnSight6Reader ()
virtual int | ReadGeometryFile (char *fileName, int timeStep)
virtual int | ReadMeasuredGeometryFile (char *fileName, int timeStep)
virtual int | CreateUnstructuredGridOutput (int partId, char line[256])
virtual int | CreateStructuredGridOutput (int partId, char line[256])
virtual int | ReadScalarsPerNode (char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerNode (char *fileName, char *description, int timeStep, int measured=0)
virtual int | ReadTensorsPerNode (char *fileName, char *description, int timeStep)
virtual int | ReadScalarsPerElement (char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerElement (char *fileName, char *description, int timeStep)
virtual int | ReadTensorsPerElement (char *fileName, char *description, int timeStep)

Protected Attributes

int | NumberOfUnstructuredPoints
vtkPoints * UnstructuredPoints
vtkIdList * UnstructuredNodeIds

Detailed Description

class to read EnSight6 files.

Date:
2002/01/22 15:38:12
Revision:
1.11

vtkEnSight6Reader is a class to read EnSight6 files into vtk. Because the different parts of the EnSight data can be of various data types, this reader produces multiple outputs, one per part in the input file. All variable information is being stored in field data. The descriptions listed in the case file are used as the array names in the field data. For complex vector variables, the description is appended with _r (for the array of real values) and _i (for the array if imaginary values). Complex scalar variables are stored as a single array with 2 components, real and imaginary, listed in that order.

Warning:
You must manually call Update on this reader and then connect the rest of the pipeline because (due to the nature of the file format) it is not possible to know ahead of time how many outputs you will have or what types they will be. This reader can only handle static EnSight datasets (both static geometry and variables).
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (97%)

Definition at line 52 of file vtkEnSight6Reader.h.

Constructor & Destructor Documentation

vtkEnSight6Reader::vtkEnSight6Reader ( ) [protected]

vtkEnSight6Reader::~vtkEnSight6Reader ( ) [protected]

Member Function Documentation

vtkEnSight6Reader* vtkEnSight6Reader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkEnSight6Reader::vtkTypeRevisionMacro | ( | vtkEnSight6Reader | ,
 |  | vtkEnSightReader |
 | ) |

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadMeasuredGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the measured geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadScalarsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per node for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the scalars array, we assume that 0 is the first component added to the array.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadVectorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0
 | ) | [protected, virtual]

Read vectors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadTensorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadScalarsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per element for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the scalars array, we assume that 0 is the first component added to the array.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadVectorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read vectors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::ReadTensorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::CreateUnstructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read an unstructured part (partId) from the geometry file and create a vtkUnstructuredGrid output. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSight6Reader::CreateStructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read a structured part from the geometry file and create a vtkStructuredGridOutput. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

Member Data Documentation

int vtkEnSight6Reader::NumberOfUnstructuredPoints [protected]

Definition at line 128 of file vtkEnSight6Reader.h.

vtkPoints* vtkEnSight6Reader::UnstructuredPoints [protected]

Definition at line 129 of file vtkEnSight6Reader.h.

vtkIdList* vtkEnSight6Reader::UnstructuredNodeIds [protected]

Definition at line 130 of file vtkEnSight6Reader.h.

The documentation for this class was generated from the following file:
  • IO/vtkEnSight6Reader.h
Generated on Mon Mar 25 01:17:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightGoldBinaryReader Class Reference

class to read binary EnSight Gold files. More...

#include <vtkEnSightGoldBinaryReader.h>

Inheritance diagram for vtkEnSightGoldBinaryReader:

[legend]
Collaboration diagram for vtkEnSightGoldBinaryReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEnSightGoldBinaryReader, vtkEnSightReader)

Static Public Methods

vtkEnSightGoldBinaryReader * | New ()

Protected Methods

vtkEnSightGoldBinaryReader ()
~vtkEnSightGoldBinaryReader ()
virtual int | ReadGeometryFile (char *fileName, int timeStep)
virtual int | ReadMeasuredGeometryFile (char *fileName, int timeStep)
virtual int | CreateUnstructuredGridOutput (int partId, char line[80])
virtual int | CreateStructuredGridOutput (int partId, char line[256])
int | CreateRectilinearGridOutput (int partId, char line[256])
int | CreateImageDataOutput (int partId, char line[80])
int | ReadLine (char result[80])
int | ReadInt (int *result)
int | ReadIntArray (int *result, int numInts)
int | ReadFloatArray (float *result, int numFloats)
virtual int | ReadScalarsPerNode (char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerNode (char *fileName, char *description, int timeStep, int measured=0)
virtual int | ReadTensorsPerNode (char *fileName, char *description, int timeStep)
virtual int | ReadScalarsPerElement (char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerElement (char *fileName, char *description, int timeStep)
virtual int | ReadTensorsPerElement (char *fileName, char *description, int timeStep)
void | SkipTimeStep ()
int | SkipStructuredGrid (char line[256])
int | SkipUnstructuredGrid (char line[256])
int | SkipRectilinearGrid (char line[256])
int | SkipImageData (char line[256])

Protected Attributes

int | NodeIdsListed
int | ElementIdsListed
FILE * | IFile

Detailed Description

class to read binary EnSight Gold files.

Date:
2002/01/22 15:38:12
Revision:
1.10

vtkEnSightGoldBinaryReader is a class to read EnSight Gold files into vtk. Because the different parts of the EnSight data can be of various data types, this reader produces multiple outputs, one per part in the input file. All variable information is being stored in field data. The descriptions listed in the case file are used as the array names in the field data. For complex vector variables, the description is appended with _r (for the array of real values) and _i (for the array if imaginary values). Complex scalar variables are stored as a single array with 2 components, real and imaginary, listed in that order.

Warning:
You must manually call Update on this reader and then connect the rest of the pipeline because (due to the nature of the file format) it is not possible to know ahead of time how many outputs you will have or what types they will be. This reader can only handle static EnSight datasets (both static geometry and variables).
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (96%)
Tests:
vtkEnSightGoldBinaryReader (Tests)

Definition at line 55 of file vtkEnSightGoldBinaryReader.h.

Constructor & Destructor Documentation

vtkEnSightGoldBinaryReader::vtkEnSightGoldBinaryReader ( ) [protected]

vtkEnSightGoldBinaryReader::~vtkEnSightGoldBinaryReader ( ) [protected]

Member Function Documentation

vtkEnSightGoldBinaryReader* vtkEnSightGoldBinaryReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkEnSightGoldBinaryReader::vtkTypeRevisionMacro | ( | vtkEnSightGoldBinaryReader | ,
 |  | vtkEnSightReader |
 | ) |

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadMeasuredGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the measured geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadScalarsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per node for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the data array, it is assumed that 0 is the first component added.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadVectorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0
 | ) | [protected, virtual]

Read vectors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadTensorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadScalarsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per element for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one componenet in the data array, it is assumed that 0 is the first component added.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadVectorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read vectors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::ReadTensorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldBinaryReader::CreateUnstructuredGridOutput | ( | int | partId,
 |  | char | line[80]
 | ) | [protected, virtual]

Read an unstructured part (partId) from the geometry file and create a vtkUnstructuredGrid output. Return 0 if EOF reached. Return -1 if an error occurred.

virtual int vtkEnSightGoldBinaryReader::CreateStructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read a structured part from the geometry file and create a vtkStructuredGrid output. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

int vtkEnSightGoldBinaryReader::CreateRectilinearGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected]

Read a structured part from the geometry file and create a vtkRectilinearGrid output. Return 0 if EOF reached.

int vtkEnSightGoldBinaryReader::CreateImageDataOutput | ( | int | partId,
 |  | char | line[80]
 | ) | [protected]

Read a structured part from the geometry file and create a vtkImageData output. Return 0 if EOF reached.

int vtkEnSightGoldBinaryReader::ReadLine ( char result[80] ) [protected]

Internal function to read in a line up to 80 characters. Returns zero if there was an error.

int vtkEnSightGoldBinaryReader::ReadInt ( int * result ) [protected]

Internal function to read in a single integer. Returns zero if there was an error.

int vtkEnSightGoldBinaryReader::ReadIntArray | ( | int * | result,
 |  | int | numInts
 | ) | [protected]

Internal function to read in an integer array. Returns zero if there was an error.

int vtkEnSightGoldBinaryReader::ReadFloatArray | ( | float * | result,
 |  | int | numFloats
 | ) | [protected]

Internal function to read in a float array. Returns zero if there was an error.

void vtkEnSightGoldBinaryReader::SkipTimeStep ( ) [protected]

Read to the next time step in the geometry file.

int vtkEnSightGoldBinaryReader::SkipStructuredGrid ( char line[256] ) [protected]

Read to the next time step in the geometry file.

int vtkEnSightGoldBinaryReader::SkipUnstructuredGrid ( char line[256] ) [protected]

Read to the next time step in the geometry file.

int vtkEnSightGoldBinaryReader::SkipRectilinearGrid ( char line[256] ) [protected]

Read to the next time step in the geometry file.

int vtkEnSightGoldBinaryReader::SkipImageData ( char line[256] ) [protected]

Read to the next time step in the geometry file.

Member Data Documentation

int vtkEnSightGoldBinaryReader::NodeIdsListed [protected]

Definition at line 162 of file vtkEnSightGoldBinaryReader.h.

int vtkEnSightGoldBinaryReader::ElementIdsListed [protected]

Definition at line 163 of file vtkEnSightGoldBinaryReader.h.

FILE* vtkEnSightGoldBinaryReader::IFile [protected]

Definition at line 165 of file vtkEnSightGoldBinaryReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkEnSightGoldBinaryReader.h
Generated on Mon Mar 25 01:17:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightGoldReader Class Reference

class to read EnSight Gold files. More...

#include <vtkEnSightGoldReader.h>

Inheritance diagram for vtkEnSightGoldReader:

[legend]
Collaboration diagram for vtkEnSightGoldReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEnSightGoldReader, vtkEnSightReader)

Static Public Methods

vtkEnSightGoldReader * | New ()

Protected Methods

vtkEnSightGoldReader ()
~vtkEnSightGoldReader ()
virtual int | ReadGeometryFile (char *fileName, int timeStep)
virtual int | ReadMeasuredGeometryFile (char *fileName, int timeStep)
virtual int | CreateUnstructuredGridOutput (int partId, char line[256])
virtual int | CreateStructuredGridOutput (int partId, char line[256])
int | CreateRectilinearGridOutput (int partId, char line[256])
int | CreateImageDataOutput (int partId, char line[256])
virtual int | ReadScalarsPerNode (char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerNode (char *fileName, char *description, int timeStep, int measured=0)
virtual int | ReadTensorsPerNode (char *fileName, char *description, int timeStep)
virtual int | ReadScalarsPerElement (char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)
virtual int | ReadVectorsPerElement (char *fileName, char *description, int timeStep)
virtual int | ReadTensorsPerElement (char *fileName, char *description, int timeStep)
virtual void | SetGeometryFileName (const char *)
virtual char * | GetGeometryFileName ()
virtual void | SetMeasuredFileName (const char *)
virtual char * | GetMeasuredFileName ()
virtual void | SetMatchFileName (const char *)
virtual char * | GetMatchFileName ()

Detailed Description

class to read EnSight Gold files.

Date:
2002/01/22 15:38:12
Revision:
1.14

vtkEnSightGoldReader is a class to read EnSight Gold files into vtk. Because the different parts of the EnSight data can be of various data types, this reader produces multiple outputs, one per part in the input file. All variable information is being stored in field data. The descriptions listed in the case file are used as the array names in the field data. For complex vector variables, the description is appended with _r (for the array of real values) and _i (for the array if imaginary values). Complex scalar variables are stored as a single array with 2 components, real and imaginary, listed in that order.

Warning:
You must manually call Update on this reader and then connect the rest of the pipeline because (due to the nature of the file format) it is not possible to know ahead of time how many outputs you will have or what types they will be. This reader can only handle static EnSight datasets (both static geometry and variables).
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (97%)

Definition at line 52 of file vtkEnSightGoldReader.h.

Constructor & Destructor Documentation

vtkEnSightGoldReader::vtkEnSightGoldReader ( ) [inline, protected]

Definition at line 59 of file vtkEnSightGoldReader.h.

vtkEnSightGoldReader::~vtkEnSightGoldReader ( ) [inline, protected]

Definition at line 60 of file vtkEnSightGoldReader.h.

Member Function Documentation

vtkEnSightGoldReader* vtkEnSightGoldReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkEnSightGoldReader::vtkTypeRevisionMacro | ( | vtkEnSightGoldReader | ,
 |  | vtkEnSightReader |
 | ) |

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadMeasuredGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, virtual]

Read the measured geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadScalarsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per node for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one component in the data array, it is assumed that 0 is the first component added.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadVectorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0
 | ) | [protected, virtual]

Read vectors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadTensorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadScalarsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, virtual]

Read scalars per element for this dataset. If an error occurred, 0 is returned; otherwise 1. If there will be more than one componenet in the data array, it is assumed that 0 is the first component added.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadVectorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read vectors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::ReadTensorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, virtual]

Read tensors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::CreateUnstructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read an unstructured part (partId) from the geometry file and create a vtkUnstructuredGrid output. Return 0 if EOF reached. Return -1 if an error occurred.

Reimplemented from vtkEnSightReader.

virtual int vtkEnSightGoldReader::CreateStructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, virtual]

Read a structured part from the geometry file and create a vtkStructuredGrid output. Return 0 if EOF reached.

Reimplemented from vtkEnSightReader.

int vtkEnSightGoldReader::CreateRectilinearGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected]

Read a structured part from the geometry file and create a vtkRectilinearGrid output. Return 0 if EOF reached.

int vtkEnSightGoldReader::CreateImageDataOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected]

Read a structured part from the geometry file and create a vtkImageData output. Return 0 if EOF reached.

virtual void vtkEnSightGoldReader::SetGeometryFileName ( const char * ) [protected, virtual]

Set/Get the Model file name.

Reimplemented from vtkEnSightReader.

virtual char* vtkEnSightGoldReader::GetGeometryFileName ( ) [protected, virtual]

Set/Get the Model file name.

Reimplemented from vtkEnSightReader.

virtual void vtkEnSightGoldReader::SetMeasuredFileName ( const char * ) [protected, virtual]

Set/Get the Measured file name.

Reimplemented from vtkEnSightReader.

virtual char* vtkEnSightGoldReader::GetMeasuredFileName ( ) [protected, virtual]

Set/Get the Measured file name.

Reimplemented from vtkEnSightReader.

virtual void vtkEnSightGoldReader::SetMatchFileName ( const char * ) [protected, virtual]

Set/Get the Match file name.

Reimplemented from vtkEnSightReader.

virtual char* vtkEnSightGoldReader::GetMatchFileName ( ) [protected, virtual]

Set/Get the Match file name.

Reimplemented from vtkEnSightReader.

The documentation for this class was generated from the following file:
  • IO/vtkEnSightGoldReader.h
Generated on Mon Mar 25 01:17:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkEnSightReader Class Reference

superclass for EnSight file readers. More...

#include <vtkEnSightReader.h>

Inheritance diagram for vtkEnSightReader:

[legend]
Collaboration diagram for vtkEnSightReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkEnSightReader, vtkDataSetSource)
void | PrintSelf (ostream &os, vtkIndent indent)
char * | GetDescription (int n)
char * | GetComplexDescription (int n)
char * | GetDescription (int n, int type)
void | Update ()
void | SetCaseFileName (char *fileName)
virtual char * | GetCaseFileName ()
virtual void | SetFilePath (const char *)
virtual char * | GetFilePath ()
int | GetNumberOfVariables ()
int | GetNumberOfComplexVariables ()
int | GetNumberOfVariables (int type)
virtual int | GetNumberOfScalarsPerNode ()
virtual int | GetNumberOfVectorsPerNode ()
virtual int | GetNumberOfTensorsSymmPerNode ()
virtual int | GetNumberOfScalarsPerElement ()
virtual int | GetNumberOfVectorsPerElement ()
virtual int | GetNumberOfTensorsSymmPerElement ()
virtual int | GetNumberOfScalarsPerMeasuredNode ()
virtual int | GetNumberOfVectorsPerMeasuredNode ()
virtual int | GetNumberOfComplexScalarsPerNode ()
virtual int | GetNumberOfComplexVectorsPerNode ()
virtual int | GetNumberOfComplexScalarsPerElement ()
virtual int | GetNumberOfComplexVectorsPerElement ()
int | GetVariableType (int n)
int | GetComplexVariableType (int n)
virtual void | SetTimeValue (float)
virtual float | GetTimeValue ()
virtual float | GetMinimumTimeValue ()
virtual float | GetMaximumTimeValue ()

Protected Methods

vtkEnSightReader ()
~vtkEnSightReader ()
void | Execute ()
int | ReadCaseFile ()
virtual int | ReadGeometryFile (char *fileName, int timeStep)=0
virtual int | ReadMeasuredGeometryFile (char *fileName, int timeStep)=0
int | ReadVariableFiles ()
virtual int | CreateUnstructuredGridOutput (int partId, char line[256])=0
virtual int | CreateStructuredGridOutput (int partId, char line[256])=0
int | ReadLine (char result[256])
int | ReadNextDataLine (char result[256])
void | AddVariableFileName (char *fileName1, char *fileName2=NULL)
void | AddVariableDescription (char *description)
void | AddVariableType ()
int | GetElementType (char *line)
void | ReplaceWildcards (char *filename, int num)
virtual void | SetUseTimeSets (int)
virtual int | GetUseTimeSets ()
virtual void | UseTimeSetsOn ()
virtual void | UseTimeSetsOff ()
virtual void | SetUseFileSets (int)
virtual int | GetUseFileSets ()
virtual void | UseFileSetsOn ()
virtual void | UseFileSetsOff ()
virtual int | ReadScalarsPerNode (char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)=0
virtual int | ReadVectorsPerNode (char *fileName, char *description, int timeStep, int measured=0)=0
virtual int | ReadTensorsPerNode (char *fileName, char *description, int timeStep)=0
virtual int | ReadScalarsPerElement (char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)=0
virtual int | ReadVectorsPerElement (char *fileName, char *description, int timeStep)=0
virtual int | ReadTensorsPerElement (char *fileName, char *description, int timeStep)=0
virtual void | SetGeometryFileName (const char *)
virtual char * | GetGeometryFileName ()
virtual void | SetMeasuredFileName (const char *)
virtual char * | GetMeasuredFileName ()
virtual void | SetMatchFileName (const char *)
virtual char * | GetMatchFileName ()

Protected Attributes

char * | FilePath
char * | CaseFileName
char * | GeometryFileName
char * | MeasuredFileName
char * | MatchFileName
vtkIdList *** CellIds
vtkIdList * UnstructuredPartIds
int | VariableMode
int | NumberOfVariables
int | NumberOfComplexVariables
int * | VariableTypes
int * | ComplexVariableTypes
char ** | VariableFileNames
char ** | ComplexVariableFileNames
char ** | VariableDescriptions
char ** | ComplexVariableDescriptions
vtkIdList * VariableTimeSets
vtkIdList * ComplexVariableTimeSets
vtkIdList * VariableFileSets
vtkIdList * ComplexVariableFileSets
vtkCollection * TimeSetFilenameNumbersCollection
vtkIdList * TimeSetsWithFilenameNumbers
vtkCollection * TimeSetTimeValuesCollection
vtkCollection * FileSetFilenameNumbersCollection
vtkIdList * FileSetsWithFilenameNumbers
vtkCollection * FileSetNumberOfStepsCollection
vtkIdList * TimeSets
vtkIdList * FileSets
int | GeometryTimeSet
int | GeometryFileSet
int | MeasuredTimeSet
int | MeasuredFileSet
float | TimeValue
float | GeometryTimeValue
float | MeasuredTimeValue
float | MinimumTimeValue
float | MaximumTimeValue
int | NumberOfScalarsPerNode
int | NumberOfVectorsPerNode
int | NumberOfTensorsSymmPerNode
int | NumberOfScalarsPerElement
int | NumberOfVectorsPerElement
int | NumberOfTensorsSymmPerElement
int | NumberOfScalarsPerMeasuredNode
int | NumberOfVectorsPerMeasuredNode
int | NumberOfComplexScalarsPerNode
int | NumberOfComplexVectorsPerNode
int | NumberOfComplexScalarsPerElement
int | NumberOfComplexVectorsPerElement
istream * IS
int | UseTimeSets
int | UseFileSets
int | NumberOfGeometryParts
int | NumberOfMeasuredPoints
vtkIdList * MeasuredNodeIds

Detailed Description

superclass for EnSight file readers.

Date:
2002/01/22 15:38:13
Revision:
1.14
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (99%)

Definition at line 67 of file vtkEnSightReader.h.

Constructor & Destructor Documentation

vtkEnSightReader::vtkEnSightReader ( ) [protected]

vtkEnSightReader::~vtkEnSightReader ( ) [protected]

Member Function Documentation

vtkEnSightReader::vtkTypeRevisionMacro | ( | vtkEnSightReader | ,
 |  | vtkDataSetSource |
 | ) |

Reimplemented from vtkDataSetSource.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

void vtkEnSightReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkEnSightReader::SetCaseFileName ( char * fileName )

Set/Get the Case file name.

virtual char* vtkEnSightReader::GetCaseFileName ( ) [virtual]

Set/Get the Case file name.

virtual void vtkEnSightReader::SetFilePath ( const char * ) [virtual]

Set/Get the path the the data files. If specified, this reader will look in this directory for all data files.

virtual char* vtkEnSightReader::GetFilePath ( ) [virtual]

Set/Get the path the the data files. If specified, this reader will look in this directory for all data files.

int vtkEnSightReader::GetNumberOfVariables ( ) [inline]

Get the number of variables listed in the case file.

Definition at line 88 of file vtkEnSightReader.h.

int vtkEnSightReader::GetNumberOfComplexVariables ( ) [inline]

Get the number of variables listed in the case file.

Definition at line 89 of file vtkEnSightReader.h.

int vtkEnSightReader::GetNumberOfVariables ( int type )

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfScalarsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfVectorsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfTensorsSymmPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfScalarsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfVectorsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfTensorsSymmPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfScalarsPerMeasuredNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfVectorsPerMeasuredNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfComplexScalarsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfComplexVectorsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfComplexScalarsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkEnSightReader::GetNumberOfComplexVectorsPerElement ( ) [virtual]

Get the number of variables of a particular type.

char* vtkEnSightReader::GetDescription ( int n )

Get the nth description for a non-complex variable.

char* vtkEnSightReader::GetComplexDescription ( int n )

Get the nth description for a complex variable.

char* vtkEnSightReader::GetDescription | ( | int | n,
 |  | int | type
 | ) |

Get the nth description of a particular variable type. Returns NULL if no variable of this type exists in this data set. VTK_SCALAR_PER_NODE = 0; VTK_VECTOR_PER_NODE = 1; VTK_TENSOR_SYMM_PER_NODE = 2; VTK_SCALAR_PER_ELEMENT = 3; VTK_VECTOR_PER_ELEMENT = 4; VTK_TENSOR_SYMM_PER_ELEMENT = 5; VTK_SCALAR_PER_MEASURED_NODE = 6; VTK_VECTOR_PER_MEASURED_NODE = 7; VTK_COMPLEX_SCALAR_PER_NODE = 8; VTK_COMPLEX_VECTOR_PER_NODE 9; VTK_COMPLEX_SCALAR_PER_ELEMENT = 10; VTK_COMPLEX_VECTOR_PER_ELEMENT = 11

int vtkEnSightReader::GetVariableType ( int n )

Get the variable type of variable n.

int vtkEnSightReader::GetComplexVariableType ( int n )

Get the variable type of variable n.

void vtkEnSightReader::Update ( ) [virtual]

Bring object up-to-date before execution. Update() checks modified time against last execution time, and re-executes object if necessary.

Reimplemented from vtkSource.

virtual void vtkEnSightReader::SetTimeValue ( float ) [virtual]

Set/Get the time value at which to get the value.

virtual float vtkEnSightReader::GetTimeValue ( ) [virtual]

Set/Get the time value at which to get the value.

virtual float vtkEnSightReader::GetMinimumTimeValue ( ) [virtual]

Get the minimum or maximum time value in this data set.

virtual float vtkEnSightReader::GetMaximumTimeValue ( ) [virtual]

Get the minimum or maximum time value in this data set.

void vtkEnSightReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkEnSightReader::ReadCaseFile ( ) [protected]

Read the case file. If an error occurred, 0 is returned; otherwise 1.

virtual int vtkEnSightReader::ReadGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, pure virtual]

Read the geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadMeasuredGeometryFile | ( | char * | fileName,
 |  | int | timeStep
 | ) | [protected, pure virtual]

Read the measured geometry file. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

int vtkEnSightReader::ReadVariableFiles ( ) [protected]

Read the variable files. If an error occurred, 0 is returned; otherwise 1.

virtual int vtkEnSightReader::ReadScalarsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, pure virtual]

Read scalars per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadVectorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | measured = 0
 | ) | [protected, pure virtual]

Read vectors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadTensorsPerNode | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, pure virtual]

Read tensors per node for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadScalarsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep,
 |  | int | numberOfComponents = 1,
 |  | int | component = 0
 | ) | [protected, pure virtual]

Read scalars per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadVectorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, pure virtual]

Read vectors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::ReadTensorsPerElement | ( | char * | fileName,
 |  | char * | description,
 |  | int | timeStep
 | ) | [protected, pure virtual]

Read tensors per element for this dataset. If an error occurred, 0 is returned; otherwise 1.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::CreateUnstructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, pure virtual]

Read an unstructured part (partId) from the geometry file and create a vtkUnstructuredGrid output. Return 0 if EOF reached.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, and vtkEnSightGoldReader.

virtual int vtkEnSightReader::CreateStructuredGridOutput | ( | int | partId,
 |  | char | line[256]
 | ) | [protected, pure virtual]

Read a structured part from the geometry file and create a vtkStructuredGridOutput. Return 0 if EOF reached.

Reimplemented in vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, and vtkEnSightGoldReader.

virtual void vtkEnSightReader::SetGeometryFileName ( const char * ) [protected, virtual]

Set/Get the Model file name.

Reimplemented in vtkEnSightGoldReader.

virtual char* vtkEnSightReader::GetGeometryFileName ( ) [protected, virtual]

Set/Get the Model file name.

Reimplemented in vtkEnSightGoldReader.

virtual void vtkEnSightReader::SetMeasuredFileName ( const char * ) [protected, virtual]

Set/Get the Measured file name.

Reimplemented in vtkEnSightGoldReader.

virtual char* vtkEnSightReader::GetMeasuredFileName ( ) [protected, virtual]

Set/Get the Measured file name.

Reimplemented in vtkEnSightGoldReader.

virtual void vtkEnSightReader::SetMatchFileName ( const char * ) [protected, virtual]

Set/Get the Match file name.

Reimplemented in vtkEnSightGoldReader.

virtual char* vtkEnSightReader::GetMatchFileName ( ) [protected, virtual]

Set/Get the Match file name.

Reimplemented in vtkEnSightGoldReader.

int vtkEnSightReader::ReadLine ( char result[256] ) [protected]

Internal function to read in a line up to 256 characters. Returns zero if there was an error.

int vtkEnSightReader::ReadNextDataLine ( char result[256] ) [protected]

void vtkEnSightReader::AddVariableFileName | ( | char * | fileName1,
 |  | char * | fileName2 = NULL
 | ) | [protected]

Add another file name to the list for a particular variable type.

void vtkEnSightReader::AddVariableDescription ( char * description ) [protected]

Add another description to the list for a particular variable type.

void vtkEnSightReader::AddVariableType ( ) [protected]

Record the variable type for the variable line just read.

int vtkEnSightReader::GetElementType ( char * line ) [protected]

Determine the element type from a line read a file. Return -1 for invalid element type.

void vtkEnSightReader::ReplaceWildcards | ( | char * | filename,
 |  | int | num
 | ) | [protected]

Replace the *'s in the filename with the given filename number.

virtual void vtkEnSightReader::SetUseTimeSets ( int ) [protected, virtual]

virtual int vtkEnSightReader::GetUseTimeSets ( ) [protected, virtual]

virtual void vtkEnSightReader::UseTimeSetsOn ( ) [protected, virtual]

virtual void vtkEnSightReader::UseTimeSetsOff ( ) [protected, virtual]

virtual void vtkEnSightReader::SetUseFileSets ( int ) [protected, virtual]

virtual int vtkEnSightReader::GetUseFileSets ( ) [protected, virtual]

virtual void vtkEnSightReader::UseFileSetsOn ( ) [protected, virtual]

virtual void vtkEnSightReader::UseFileSetsOff ( ) [protected, virtual]

Member Data Documentation

char* vtkEnSightReader::FilePath [protected]

Definition at line 264 of file vtkEnSightReader.h.

char* vtkEnSightReader::CaseFileName [protected]

Definition at line 266 of file vtkEnSightReader.h.

char* vtkEnSightReader::GeometryFileName [protected]

Definition at line 267 of file vtkEnSightReader.h.

char* vtkEnSightReader::MeasuredFileName [protected]

Definition at line 268 of file vtkEnSightReader.h.

char* vtkEnSightReader::MatchFileName [protected]

Definition at line 269 of file vtkEnSightReader.h.

vtkIdList*** vtkEnSightReader::CellIds [protected]

Definition at line 272 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::UnstructuredPartIds [protected]

Definition at line 275 of file vtkEnSightReader.h.

int vtkEnSightReader::VariableMode [protected]

Definition at line 277 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfVariables [protected]

Definition at line 278 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfComplexVariables [protected]

Definition at line 279 of file vtkEnSightReader.h.

int* vtkEnSightReader::VariableTypes [protected]

Definition at line 282 of file vtkEnSightReader.h.

int* vtkEnSightReader::ComplexVariableTypes [protected]

Definition at line 283 of file vtkEnSightReader.h.

char** vtkEnSightReader::VariableFileNames [protected]

Definition at line 286 of file vtkEnSightReader.h.

char** vtkEnSightReader::ComplexVariableFileNames [protected]

Definition at line 287 of file vtkEnSightReader.h.

char** vtkEnSightReader::VariableDescriptions [protected]

Definition at line 290 of file vtkEnSightReader.h.

char** vtkEnSightReader::ComplexVariableDescriptions [protected]

Definition at line 291 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::VariableTimeSets [protected]

Definition at line 294 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::ComplexVariableTimeSets [protected]

Definition at line 295 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::VariableFileSets [protected]

Definition at line 298 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::ComplexVariableFileSets [protected]

Definition at line 299 of file vtkEnSightReader.h.

vtkCollection* vtkEnSightReader::TimeSetFilenameNumbersCollection [protected]

Definition at line 302 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::TimeSetsWithFilenameNumbers [protected]

Definition at line 303 of file vtkEnSightReader.h.

vtkCollection* vtkEnSightReader::TimeSetTimeValuesCollection [protected]

Definition at line 306 of file vtkEnSightReader.h.

vtkCollection* vtkEnSightReader::FileSetFilenameNumbersCollection [protected]

Definition at line 309 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::FileSetsWithFilenameNumbers [protected]

Definition at line 310 of file vtkEnSightReader.h.

vtkCollection* vtkEnSightReader::FileSetNumberOfStepsCollection [protected]

Definition at line 313 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::TimeSets [protected]

Definition at line 316 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::FileSets [protected]

Definition at line 317 of file vtkEnSightReader.h.

int vtkEnSightReader::GeometryTimeSet [protected]

Definition at line 319 of file vtkEnSightReader.h.

int vtkEnSightReader::GeometryFileSet [protected]

Definition at line 320 of file vtkEnSightReader.h.

int vtkEnSightReader::MeasuredTimeSet [protected]

Definition at line 321 of file vtkEnSightReader.h.

int vtkEnSightReader::MeasuredFileSet [protected]

Definition at line 322 of file vtkEnSightReader.h.

float vtkEnSightReader::TimeValue [protected]

Definition at line 324 of file vtkEnSightReader.h.

float vtkEnSightReader::GeometryTimeValue [protected]

Definition at line 325 of file vtkEnSightReader.h.

float vtkEnSightReader::MeasuredTimeValue [protected]

Definition at line 326 of file vtkEnSightReader.h.

float vtkEnSightReader::MinimumTimeValue [protected]

Definition at line 328 of file vtkEnSightReader.h.

float vtkEnSightReader::MaximumTimeValue [protected]

Definition at line 329 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfScalarsPerNode [protected]

Definition at line 332 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfVectorsPerNode [protected]

Definition at line 333 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfTensorsSymmPerNode [protected]

Definition at line 334 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfScalarsPerElement [protected]

Definition at line 335 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfVectorsPerElement [protected]

Definition at line 336 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfTensorsSymmPerElement [protected]

Definition at line 337 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfScalarsPerMeasuredNode [protected]

Definition at line 338 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfVectorsPerMeasuredNode [protected]

Definition at line 339 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfComplexScalarsPerNode [protected]

Definition at line 340 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfComplexVectorsPerNode [protected]

Definition at line 341 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfComplexScalarsPerElement [protected]

Definition at line 342 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfComplexVectorsPerElement [protected]

Definition at line 343 of file vtkEnSightReader.h.

istream* vtkEnSightReader::IS [protected]

Definition at line 345 of file vtkEnSightReader.h.

int vtkEnSightReader::UseTimeSets [protected]

Definition at line 347 of file vtkEnSightReader.h.

int vtkEnSightReader::UseFileSets [protected]

Definition at line 352 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfGeometryParts [protected]

Definition at line 357 of file vtkEnSightReader.h.

int vtkEnSightReader::NumberOfMeasuredPoints [protected]

Definition at line 360 of file vtkEnSightReader.h.

vtkIdList* vtkEnSightReader::MeasuredNodeIds [protected]

Definition at line 361 of file vtkEnSightReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkEnSightReader.h
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkErrorCode Class Reference

superclass for error codes. More...

#include <vtkErrorCode.h>

List of all members.

Public Types

enum ErrorIds {
NoError = 0, FileNotFoundError, CannotOpenFileError, UnrecognizedFileTypeError,
PrematureEndOfFileError, FileFormatError, NoFileNameError, UnknownError,
UserError = 1000
}

Static Public Methods

const char * | GetStringFromErrorCode (unsigned long event)
unsigned long | GetErrorCodeFromString (const char *event)

Detailed Description

superclass for error codes.

Date:
2002/01/22 15:25:22
Revision:
1.2

vtkErrorCode is an mechanism for (currently) reader object to return errors during reading file.

Created by:
  • Cedilnik, Andy
Contributed by (if > 5%):
  • Cedilnik, Andy (100%)

Definition at line 36 of file vtkErrorCode.h.

Member Enumeration Documentation

enum vtkErrorCode::ErrorIds

Enumeration values:
NoError
FileNotFoundError
CannotOpenFileError
UnrecognizedFileTypeError
PrematureEndOfFileError
FileFormatError
NoFileNameError
UnknownError
UserError

Definition at line 48 of file vtkErrorCode.h.

Member Function Documentation

const char* vtkErrorCode::GetStringFromErrorCode ( unsigned long event ) [static]

unsigned long vtkErrorCode::GetErrorCodeFromString ( const char * event ) [static]

The documentation for this class was generated from the following file:
  • Common/vtkErrorCode.h
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExplicitCell Class Reference

abstract superclass for cells requiring an explicit representation. More...

#include <vtkExplicitCell.h>

Inheritance diagram for vtkExplicitCell:

[legend]
Collaboration diagram for vtkExplicitCell:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExplicitCell, vtkNonLinearCell)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | IsExplicitCell ()

Protected Methods

vtkExplicitCell ()
~vtkExplicitCell ()

Protected Attributes

vtkIdType CellId

Detailed Description

abstract superclass for cells requiring an explicit representation.

Date:
2002/03/06 15:43:41
Revision:
1.1

vtkExplicitCell is an abstract superclass for cells that cannot be represented implicitly. An implicit representation requires only a cell type and connectivity list (e.g., triangle). Explicit cells require information beyond this; e.g., a NURBS surface or cells that require explicit face/edge descriptions. Most cells in VTK are implicitly represented.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (100%)

Definition at line 41 of file vtkExplicitCell.h.

Constructor & Destructor Documentation

vtkExplicitCell::vtkExplicitCell ( ) [protected]

vtkExplicitCell::~vtkExplicitCell ( ) [inline, protected]

Definition at line 55 of file vtkExplicitCell.h.

Member Function Documentation

vtkExplicitCell::vtkTypeRevisionMacro | ( | vtkExplicitCell | ,
 |  | vtkNonLinearCell |
 | ) |

Reimplemented from vtkNonLinearCell.

void vtkExplicitCell::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkNonLinearCell.

virtual int vtkExplicitCell::IsExplicitCell ( ) [inline, virtual]

Explicit cells require additional representational information beyond the usual cell type and connectivity list information. Most cells in VTK are implicit cells. The vtkCell::IsImplicitCell() virtual function is overloaded to reflect this requirement.

Reimplemented from vtkCell.

Definition at line 51 of file vtkExplicitCell.h.

Member Data Documentation

vtkIdType vtkExplicitCell::CellId [protected]

Definition at line 57 of file vtkExplicitCell.h.

The documentation for this class was generated from the following file:
  • Common/vtkExplicitCell.h
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExporter Class Reference

abstract class to write a scene to a file. More...

#include <vtkExporter.h>

Inheritance diagram for vtkExporter:

[legend]
Collaboration diagram for vtkExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExporter, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Write ()
void | Update ()
void | SetStartWrite (void(*f)(void *), void *arg)
void | SetEndWrite (void(*f)(void *), void *arg)
void | SetStartWriteArgDelete (void(*f)(void *))
void | SetEndWriteArgDelete (void(*f)(void *))
unsigned long | GetMTime ()
virtual void | SetRenderWindow (vtkRenderWindow *)
virtual vtkRenderWindow * | GetRenderWindow ()
void | SetInput (vtkRenderWindow *renWin)
vtkRenderWindow * GetInput ()

Protected Methods

vtkExporter ()
~vtkExporter ()
virtual void | WriteData ()=0

Protected Attributes

vtkRenderWindow * RenderWindow
void(* | StartWrite )(void *)
void(* | StartWriteArgDelete )(void *)
void * | StartWriteArg
void(* | EndWrite )(void *)
void(* | EndWriteArgDelete )(void *)
void * | EndWriteArg

Detailed Description

abstract class to write a scene to a file.

Date:
2002/01/22 15:38:31
Revision:
1.26

vtkExporter is an abstract class that exports a scene to a file. It is very similar to vtkWriter except that a writer only writes out the geometric and topological data for an object, where an exporter can write out material properties, lighting, camera parameters etc. The concrete subclasses of this class may not write out all of this information. For example vtkOBJExporter writes out Wavefront obj files which do not include support for camera parameters.

vtkExporter provides the convenience methods StartWrite and EndWrite. These methods are executed before and after execution of the Write() method. You can also specify arguments to these methods. This class defines SetInput and GetInput methods which take or return a vtkRenderWindow.

Warning:
Every subclass of vtkExporter must implement a WriteData() method.
See also:
vtkOBJExporter vtkRenderWindow vtkWriter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (74%)
  • Kelly, Ann (8%)
  • Law, Charles (6%)
  • Schroeder, Will (6%)

Definition at line 57 of file vtkExporter.h.

Constructor & Destructor Documentation

vtkExporter::vtkExporter ( ) [protected]

vtkExporter::~vtkExporter ( ) [protected]

Member Function Documentation

vtkExporter::vtkTypeRevisionMacro | ( | vtkExporter | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkRIBExporter, vtkIVExporter, vtkOBJExporter, vtkOOGLExporter, and vtkVRMLExporter.

void vtkExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkRIBExporter, vtkIVExporter, vtkOBJExporter, vtkOOGLExporter, and vtkVRMLExporter.

virtual void vtkExporter::Write ( ) [virtual]

Write data to output. Method executes subclasses WriteData() method, as well as StartWrite and EndWrite methods.

void vtkExporter::Update ( void )

Convenient alias for Write() method.

virtual void vtkExporter::SetRenderWindow ( vtkRenderWindow * ) [virtual]

Set/Get the rendering window that contains the scene to be written.

virtual vtkRenderWindow* vtkExporter::GetRenderWindow ( ) [virtual]

Set/Get the rendering window that contains the scene to be written.

void vtkExporter::SetInput ( vtkRenderWindow * renWin ) [inline]

These methods are provided for backward compatibility. Will disappear soon.

Definition at line 79 of file vtkExporter.h.

vtkRenderWindow* vtkExporter::GetInput ( ) [inline]

These methods are provided for backward compatibility. Will disappear soon.

Definition at line 80 of file vtkExporter.h.

void vtkExporter::SetStartWrite | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a function to be called before data is written. Function will be called with argument provided.

void vtkExporter::SetEndWrite | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a function to be called after data is written. Function will be called with argument provided.

void vtkExporter::SetStartWriteArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkExporter::SetEndWriteArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

unsigned long vtkExporter::GetMTime ( ) [virtual]

Returns the MTime also considering the RenderWindow.

Reimplemented from vtkObject.

virtual void vtkExporter::WriteData ( ) [protected, pure virtual]

Reimplemented in vtkRIBExporter, vtkIVExporter, vtkOBJExporter, vtkOOGLExporter, and vtkVRMLExporter.

Member Data Documentation

vtkRenderWindow* vtkExporter::RenderWindow [protected]

Definition at line 104 of file vtkExporter.h.

void(* vtkExporter::StartWrite)(void *) [protected]

void(* vtkExporter::StartWriteArgDelete)(void *) [protected]

void* vtkExporter::StartWriteArg [protected]

Definition at line 109 of file vtkExporter.h.

void(* vtkExporter::EndWrite)(void *) [protected]

void(* vtkExporter::EndWriteArgDelete)(void *) [protected]

void* vtkExporter::EndWriteArg [protected]

Definition at line 112 of file vtkExporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkExporter.h
Generated on Mon Mar 25 01:17:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtentTranslator Class Reference

Generates a structured extent from unstructured. More...

#include <vtkExtentTranslator.h>

Inheritance diagram for vtkExtentTranslator:

[legend]
Collaboration diagram for vtkExtentTranslator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtentTranslator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetWholeExtent (int, int, int, int, int, int)
virtual void | SetWholeExtent (int[6])
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetExtent (int, int, int, int, int, int)
virtual void | SetExtent (int[6])
virtual int * | GetExtent ()
virtual void | GetExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetExtent (int[6])
virtual void | SetPiece (int)
virtual int | GetPiece ()
virtual void | SetNumberOfPieces (int)
virtual int | GetNumberOfPieces ()
virtual void | SetGhostLevel (int)
virtual int | GetGhostLevel ()
virtual int | PieceToExtent ()
virtual int | PieceToExtentByPoints ()
virtual int | PieceToExtentThreadSafe (int piece, int numPieces, int ghostLevel, int *wholeExtent, int *resultExtent, int splitMode, int byPoints)
void | SetSplitModeToBlock ()
void | SetSplitModeToXSlab ()
void | SetSplitModeToYSlab ()
void | SetSplitModeToZSlab ()
virtual int | GetSplitMode ()

Static Public Methods

vtkExtentTranslator * | New ()

Protected Types

enum | Modes { X_SLAB_MODE = 0, Y_SLAB_MODE = 1, Z_SLAB_MODE = 2, BLOCK_MODE = 3 }

Protected Methods

vtkExtentTranslator ()
~vtkExtentTranslator ()
int | SplitExtent (int piece, int numPieces, int *extent, int splitMode)
int | SplitExtentByPoints (int piece, int numPieces, int *extent, int splitMode)

Protected Attributes

int | Piece
int | NumberOfPieces
int | GhostLevel
int | Extent [6]
int | WholeExtent [6]
int | SplitMode

Detailed Description

Generates a structured extent from unstructured.

Date:
2002/01/22 15:25:22
Revision:
1.15

vtkExtentTranslator generates a structured extent from an unstructured extent. It uses a recursive scheme that splits the largest axis. A hard coded extent can be used for a starting point.

Warning:
This object is still under development.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (50%)
  • Martin, Ken (41%)

Definition at line 44 of file vtkExtentTranslator.h.

Member Enumeration Documentation

enum vtkExtentTranslator::Modes [protected]

Enumeration values:
X_SLAB_MODE
Y_SLAB_MODE
Z_SLAB_MODE
BLOCK_MODE

Definition at line 121 of file vtkExtentTranslator.h.

Constructor & Destructor Documentation

vtkExtentTranslator::vtkExtentTranslator ( ) [protected]

vtkExtentTranslator::~vtkExtentTranslator ( ) [protected]

Member Function Documentation

vtkExtentTranslator* vtkExtentTranslator::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkBranchExtentTranslator.

vtkExtentTranslator::vtkTypeRevisionMacro | ( | vtkExtentTranslator | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkBranchExtentTranslator.

void vtkExtentTranslator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkBranchExtentTranslator.

virtual void vtkExtentTranslator::SetWholeExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetWholeExtent ( int [6] ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int* vtkExtentTranslator::GetWholeExtent ( ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::GetWholeExtent ( int [6] ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetExtent ( int [6] ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int* vtkExtentTranslator::GetExtent ( ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::GetExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::GetExtent ( int [6] ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetPiece ( int ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int vtkExtentTranslator::GetPiece ( ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetNumberOfPieces ( int ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int vtkExtentTranslator::GetNumberOfPieces ( ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual void vtkExtentTranslator::SetGhostLevel ( int ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int vtkExtentTranslator::GetGhostLevel ( ) [virtual]

Set the Piece/NumPieces. Set the WholeExtent and then call PieceToExtent. The result can be obtained from the Extent ivar.

virtual int vtkExtentTranslator::PieceToExtent ( ) [virtual]

These are the main methods that should be called. These methods are responsible for converting a piece to an extent. The signatures without arguments are only thread safe when each thread accesses a different instance. The signatures with arguements are fully thread safe.

Reimplemented in vtkBranchExtentTranslator.

virtual int vtkExtentTranslator::PieceToExtentByPoints ( ) [virtual]

These are the main methods that should be called. These methods are responsible for converting a piece to an extent. The signatures without arguments are only thread safe when each thread accesses a different instance. The signatures with arguements are fully thread safe.

virtual int vtkExtentTranslator::PieceToExtentThreadSafe | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel,
 |  | int * | wholeExtent,
 |  | int * | resultExtent,
 |  | int | splitMode,
 |  | int | byPoints
 | ) | [virtual]

These are the main methods that should be called. These methods are responsible for converting a piece to an extent. The signatures without arguments are only thread safe when each thread accesses a different instance. The signatures with arguements are fully thread safe.

void vtkExtentTranslator::SetSplitModeToBlock ( ) [inline]

How should the streamer break up extents. Block mode tries to break an extent up into cube blocks. It always chooses the largest axis to split. Slab mode first breaks up the Z axis. If it gets to one slice, then it starts breaking up other axes.

Definition at line 88 of file vtkExtentTranslator.h.

void vtkExtentTranslator::SetSplitModeToXSlab ( ) [inline]

How should the streamer break up extents. Block mode tries to break an extent up into cube blocks. It always chooses the largest axis to split. Slab mode first breaks up the Z axis. If it gets to one slice, then it starts breaking up other axes.

Definition at line 90 of file vtkExtentTranslator.h.

void vtkExtentTranslator::SetSplitModeToYSlab ( ) [inline]

How should the streamer break up extents. Block mode tries to break an extent up into cube blocks. It always chooses the largest axis to split. Slab mode first breaks up the Z axis. If it gets to one slice, then it starts breaking up other axes.

Definition at line 92 of file vtkExtentTranslator.h.

void vtkExtentTranslator::SetSplitModeToZSlab ( ) [inline]

How should the streamer break up extents. Block mode tries to break an extent up into cube blocks. It always chooses the largest axis to split. Slab mode first breaks up the Z axis. If it gets to one slice, then it starts breaking up other axes.

Definition at line 94 of file vtkExtentTranslator.h.

virtual int vtkExtentTranslator::GetSplitMode ( ) [virtual]

How should the streamer break up extents. Block mode tries to break an extent up into cube blocks. It always chooses the largest axis to split. Slab mode first breaks up the Z axis. If it gets to one slice, then it starts breaking up other axes.

int vtkExtentTranslator::SplitExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int * | extent,
 |  | int | splitMode
 | ) | [protected]

Returns 0 if no data exist for a piece. The whole extent Should be passed in as the extent. It is modified to return the result.

int vtkExtentTranslator::SplitExtentByPoints | ( | int | piece,
 |  | int | numPieces,
 |  | int * | extent,
 |  | int | splitMode
 | ) | [protected]

Returns 0 if no data exist for a piece. The whole extent Should be passed in as the extent. It is modified to return the result.

Member Data Documentation

int vtkExtentTranslator::Piece [protected]

Definition at line 111 of file vtkExtentTranslator.h.

int vtkExtentTranslator::NumberOfPieces [protected]

Definition at line 112 of file vtkExtentTranslator.h.

int vtkExtentTranslator::GhostLevel [protected]

Definition at line 113 of file vtkExtentTranslator.h.

int vtkExtentTranslator::Extent[6] [protected]

Definition at line 114 of file vtkExtentTranslator.h.

int vtkExtentTranslator::WholeExtent[6] [protected]

Definition at line 115 of file vtkExtentTranslator.h.

int vtkExtentTranslator::SplitMode [protected]

Definition at line 116 of file vtkExtentTranslator.h.

The documentation for this class was generated from the following file:
  • Common/vtkExtentTranslator.h
Generated on Mon Mar 25 01:17:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractEdges Class Reference

extract cell edges from any type of data. More...

#include <vtkExtractEdges.h>

Inheritance diagram for vtkExtractEdges:

[legend]
Collaboration diagram for vtkExtractEdges:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractEdges, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkExtractEdges * | New ()

Protected Methods

vtkExtractEdges ()
~vtkExtractEdges ()
void | Execute ()

Protected Attributes

vtkPointLocator * Locator

Detailed Description

extract cell edges from any type of data.

Date:
2002/01/22 15:29:18
Revision:
1.32

vtkExtractEdges is a filter to extract edges from a dataset. Edges are extracted as lines or polylines.

See also:
vtkFeatureEdges
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Lorensen, Bill (19%)
  • Law, Charles (13%)
  • Martin, Ken (6%)
Examples:
vtkExtractEdges (Examples)
Tests:
vtkExtractEdges (Tests)

Definition at line 49 of file vtkExtractEdges.h.

Constructor & Destructor Documentation

vtkExtractEdges::vtkExtractEdges ( ) [protected]

vtkExtractEdges::~vtkExtractEdges ( ) [protected]

Member Function Documentation

vtkExtractEdges* vtkExtractEdges::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkExtractEdges::vtkTypeRevisionMacro | ( | vtkExtractEdges | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkExtractEdges::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkExtractEdges::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkExtractEdges::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkExtractEdges::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

unsigned long vtkExtractEdges::GetMTime ( ) [virtual]

Return MTime also considering the locator.

Reimplemented from vtkObject.

void vtkExtractEdges::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkPointLocator* vtkExtractEdges::Locator [protected]

Definition at line 76 of file vtkExtractEdges.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractEdges.h
Generated on Mon Mar 25 01:17:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractGeometry Class Reference

extract cells that lie either entirely inside or outside of a specified implicit function. More...

#include <vtkExtractGeometry.h>

Inheritance diagram for vtkExtractGeometry:

[legend]
Collaboration diagram for vtkExtractGeometry:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractGeometry, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetImplicitFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetImplicitFunction ()
virtual void | SetExtractInside (int)
virtual int | GetExtractInside ()
virtual void | ExtractInsideOn ()
virtual void | ExtractInsideOff ()
virtual void | SetExtractBoundaryCells (int)
virtual int | GetExtractBoundaryCells ()
virtual void | ExtractBoundaryCellsOn ()
virtual void | ExtractBoundaryCellsOff ()

Static Public Methods

vtkExtractGeometry * | New ()

Protected Methods

vtkExtractGeometry (vtkImplicitFunction *f=NULL)
~vtkExtractGeometry ()
void | Execute ()

Protected Attributes

vtkImplicitFunction * ImplicitFunction
int | ExtractInside
int | ExtractBoundaryCells

Detailed Description

extract cells that lie either entirely inside or outside of a specified implicit function.

Date:
2002/01/22 15:29:19
Revision:
1.38

vtkExtractGeometry extracts from its input dataset all cells that are either completely inside or outside of a specified implicit function. Any type of dataset can be input to this filter. On output the filter generates an unstructured grid.

To use this filter you must specify an implicit function. You must also specify whethter to extract cells lying inside or outside of the implicit function. (The inside of an implicit function is the negative values region.) An option exists to extract cells that are neither inside or outside (i.e., boundary).

A more efficient version of this filter is available for vtkPolyData input. See vtkExtractPolyDataGeometry.

See also:
vtkExtractPolyDataGeometry vtkGeometryFilter vtkExtractVOI
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Martin, Ken (7%)
Examples:
vtkExtractGeometry (Examples)
Tests:
vtkExtractGeometry (Tests)

Definition at line 60 of file vtkExtractGeometry.h.

Constructor & Destructor Documentation

vtkExtractGeometry::vtkExtractGeometry ( vtkImplicitFunction * f = NULL ) [protected]

vtkExtractGeometry::~vtkExtractGeometry ( ) [protected]

Member Function Documentation

vtkExtractGeometry::vtkTypeRevisionMacro | ( | vtkExtractGeometry | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkExtractGeometry::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkExtractGeometry* vtkExtractGeometry::New ( ) [static]

Construct object with ExtractInside turned on.

Reimplemented from vtkUnstructuredGridSource.

unsigned long vtkExtractGeometry::GetMTime ( ) [virtual]

Return the MTime taking into account changes to the implicit function

Reimplemented from vtkObject.

virtual void vtkExtractGeometry::SetImplicitFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function for inside/outside checks.

virtual vtkImplicitFunction* vtkExtractGeometry::GetImplicitFunction ( ) [virtual]

Specify the implicit function for inside/outside checks.

virtual void vtkExtractGeometry::SetExtractInside ( int ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual int vtkExtractGeometry::GetExtractInside ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractGeometry::ExtractInsideOn ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractGeometry::ExtractInsideOff ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractGeometry::SetExtractBoundaryCells ( int ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual int vtkExtractGeometry::GetExtractBoundaryCells ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual void vtkExtractGeometry::ExtractBoundaryCellsOn ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual void vtkExtractGeometry::ExtractBoundaryCellsOff ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

void vtkExtractGeometry::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkImplicitFunction* vtkExtractGeometry::ImplicitFunction [protected]

Definition at line 102 of file vtkExtractGeometry.h.

int vtkExtractGeometry::ExtractInside [protected]

Definition at line 103 of file vtkExtractGeometry.h.

int vtkExtractGeometry::ExtractBoundaryCells [protected]

Definition at line 104 of file vtkExtractGeometry.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractGeometry.h
Generated on Mon Mar 25 01:17:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractGrid Class Reference

select piece (e.g., volume of interest) and/or subsample structured grid dataset. More...

#include <vtkExtractGrid.h>

Inheritance diagram for vtkExtractGrid:

[legend]
Collaboration diagram for vtkExtractGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractGrid, vtkStructuredGridToStructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetVOI (int, int, int, int, int, int)
virtual void | SetVOI (int[6])
virtual int * | GetVOI ()
virtual void | GetVOI (int data[6])
virtual void | SetSampleRate (int, int, int)
virtual void | SetSampleRate (int[3])
virtual int * | GetSampleRate ()
virtual void | GetSampleRate (int data[3])
virtual void | SetIncludeBoundary (int)
virtual int | GetIncludeBoundary ()
virtual void | IncludeBoundaryOn ()
virtual void | IncludeBoundaryOff ()

Static Public Methods

vtkExtractGrid * | New ()

Protected Methods

vtkExtractGrid ()
~vtkExtractGrid ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *out)

Protected Attributes

int | VOI [6]
int | SampleRate [3]
int | IncludeBoundary

Detailed Description

select piece (e.g., volume of interest) and/or subsample structured grid dataset.

Date:
2002/01/22 15:29:19
Revision:
1.31

vtkExtractGrid is a filter that selects a portion of an input structured grid dataset, or subsamples an input dataset. (The selected portion of interested is referred to as the Volume Of Interest, or VOI.) The output of this filter is a structured grid dataset. The filter treats input data of any topological dimension (i.e., point, line, image, or volume) and can generate output data of any topological dimension.

To use this filter set the VOI ivar which are i-j-k min/max indices that specify a rectangular region in the data. (Note that these are 0-offset.) You can also specify a sampling rate to subsample the data.

Typical applications of this filter are to extract a plane from a grid for contouring, subsampling large grids to reduce data size, or extracting regions of a grid with interesting data.

See also:
vtkGeometryFilter vtkExtractGeometry vtkExtractVOI vtkStructuredGridGeometryFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (42%)
  • Law, Charles (35%)
  • Lorensen, Bill (9%)
  • Avila, Lisa (6%)
Examples:
vtkExtractGrid (Examples)
Tests:
vtkExtractGrid (Tests)

Definition at line 63 of file vtkExtractGrid.h.

Constructor & Destructor Documentation

vtkExtractGrid::vtkExtractGrid ( ) [protected]

vtkExtractGrid::~vtkExtractGrid ( ) [inline, protected]

Definition at line 101 of file vtkExtractGrid.h.

Member Function Documentation

vtkExtractGrid* vtkExtractGrid::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredGridSource.

vtkExtractGrid::vtkTypeRevisionMacro | ( | vtkExtractGrid | ,
 |  | vtkStructuredGridToStructuredGridFilter |
 | ) |

Reimplemented from vtkStructuredGridToStructuredGridFilter.

void vtkExtractGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkExtractGrid::SetVOI | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured grid dataset can be of any topological dimension (i.e., point, line, plane, or 3D grid).

virtual void vtkExtractGrid::SetVOI ( int [6] ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured grid dataset can be of any topological dimension (i.e., point, line, plane, or 3D grid).

virtual int* vtkExtractGrid::GetVOI ( ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured grid dataset can be of any topological dimension (i.e., point, line, plane, or 3D grid).

virtual void vtkExtractGrid::GetVOI ( int data[6] ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured grid dataset can be of any topological dimension (i.e., point, line, plane, or 3D grid).

virtual void vtkExtractGrid::SetSampleRate | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual void vtkExtractGrid::SetSampleRate ( int [3] ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual int* vtkExtractGrid::GetSampleRate ( ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual void vtkExtractGrid::GetSampleRate ( int data[3] ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual void vtkExtractGrid::SetIncludeBoundary ( int ) [virtual]

Control whether to enforce that the "boundary" of the grid is output in the subsampling process. (This ivar only has effect when the SampleRate in any direction is not equal to 1.) When this ivar IncludeBoundary is on, the subsampling will always include the boundary of the grid even though the sample rate is not an even multiple of the grid dimensions. (By default IncludeBoundary is off.)

virtual int vtkExtractGrid::GetIncludeBoundary ( ) [virtual]

Control whether to enforce that the "boundary" of the grid is output in the subsampling process. (This ivar only has effect when the SampleRate in any direction is not equal to 1.) When this ivar IncludeBoundary is on, the subsampling will always include the boundary of the grid even though the sample rate is not an even multiple of the grid dimensions. (By default IncludeBoundary is off.)

virtual void vtkExtractGrid::IncludeBoundaryOn ( ) [virtual]

Control whether to enforce that the "boundary" of the grid is output in the subsampling process. (This ivar only has effect when the SampleRate in any direction is not equal to 1.) When this ivar IncludeBoundary is on, the subsampling will always include the boundary of the grid even though the sample rate is not an even multiple of the grid dimensions. (By default IncludeBoundary is off.)

virtual void vtkExtractGrid::IncludeBoundaryOff ( ) [virtual]

Control whether to enforce that the "boundary" of the grid is output in the subsampling process. (This ivar only has effect when the SampleRate in any direction is not equal to 1.) When this ivar IncludeBoundary is on, the subsampling will always include the boundary of the grid even though the sample rate is not an even multiple of the grid dimensions. (By default IncludeBoundary is off.)

void vtkExtractGrid::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkExtractGrid::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkExtractGrid::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Member Data Documentation

int vtkExtractGrid::VOI[6] [protected]

Definition at line 107 of file vtkExtractGrid.h.

int vtkExtractGrid::SampleRate[3] [protected]

Definition at line 108 of file vtkExtractGrid.h.

int vtkExtractGrid::IncludeBoundary [protected]

Definition at line 109 of file vtkExtractGrid.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractGrid.h
Generated on Mon Mar 25 01:17:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractPolyDataGeometry Class Reference

extract vtkPolyData cells that lies either entirely inside or outside of a specified implicit function. More...

#include <vtkExtractPolyDataGeometry.h>

Inheritance diagram for vtkExtractPolyDataGeometry:

[legend]
Collaboration diagram for vtkExtractPolyDataGeometry:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractPolyDataGeometry, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetImplicitFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetImplicitFunction ()
virtual void | SetExtractInside (int)
virtual int | GetExtractInside ()
virtual void | ExtractInsideOn ()
virtual void | ExtractInsideOff ()
virtual void | SetExtractBoundaryCells (int)
virtual int | GetExtractBoundaryCells ()
virtual void | ExtractBoundaryCellsOn ()
virtual void | ExtractBoundaryCellsOff ()

Static Public Methods

vtkExtractPolyDataGeometry * | New ()

Protected Methods

vtkExtractPolyDataGeometry (vtkImplicitFunction *f=NULL)
~vtkExtractPolyDataGeometry ()
void | Execute ()

Protected Attributes

vtkImplicitFunction * ImplicitFunction
int | ExtractInside
int | ExtractBoundaryCells

Detailed Description

extract vtkPolyData cells that lies either entirely inside or outside of a specified implicit function.

Date:
2002/01/22 15:29:20
Revision:
1.16

vtkExtractPolyDataGeometry extracts from its input vtkPolyData all cells that are either completely inside or outside of a specified implicit function. This filter is specialized to vtkPolyData. On output the filter generates vtkPolyData.

To use this filter you must specify an implicit function. You must also specify whethter to extract cells lying inside or outside of the implicit function. (The inside of an implicit function is the negative values region.) An option exists to extract cells that are neither inside or outside (i.e., boundary).

A more general version of this filter is available for arbitrary vtkDataSet input (see vtkExtractGeometry).

See also:
vtkExtractGeometry vtkClipPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (93%)
Tests:
vtkExtractPolyDataGeometry (Tests)

Definition at line 56 of file vtkExtractPolyDataGeometry.h.

Constructor & Destructor Documentation

vtkExtractPolyDataGeometry::vtkExtractPolyDataGeometry ( vtkImplicitFunction * f = NULL ) [protected]

vtkExtractPolyDataGeometry::~vtkExtractPolyDataGeometry ( ) [protected]

Member Function Documentation

vtkExtractPolyDataGeometry::vtkTypeRevisionMacro | ( | vtkExtractPolyDataGeometry | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkExtractPolyDataGeometry::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkExtractPolyDataGeometry* vtkExtractPolyDataGeometry::New ( ) [static]

Construct object with ExtractInside turned on.

Reimplemented from vtkPolyDataSource.

unsigned long vtkExtractPolyDataGeometry::GetMTime ( ) [virtual]

Return the MTime taking into account changes to the implicit function

Reimplemented from vtkObject.

virtual void vtkExtractPolyDataGeometry::SetImplicitFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function for inside/outside checks.

virtual vtkImplicitFunction* vtkExtractPolyDataGeometry::GetImplicitFunction ( ) [virtual]

Specify the implicit function for inside/outside checks.

virtual void vtkExtractPolyDataGeometry::SetExtractInside ( int ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual int vtkExtractPolyDataGeometry::GetExtractInside ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractPolyDataGeometry::ExtractInsideOn ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractPolyDataGeometry::ExtractInsideOff ( ) [virtual]

Boolean controls whether to extract cells that are inside of implicit function (ExtractInside == 1) or outside of implicit function (ExtractInside == 0).

virtual void vtkExtractPolyDataGeometry::SetExtractBoundaryCells ( int ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual int vtkExtractPolyDataGeometry::GetExtractBoundaryCells ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual void vtkExtractPolyDataGeometry::ExtractBoundaryCellsOn ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

virtual void vtkExtractPolyDataGeometry::ExtractBoundaryCellsOff ( ) [virtual]

Boolean controls whether to extract cells that are partially inside. By default, ExtractBoundaryCells is off.

void vtkExtractPolyDataGeometry::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkImplicitFunction* vtkExtractPolyDataGeometry::ImplicitFunction [protected]

Definition at line 98 of file vtkExtractPolyDataGeometry.h.

int vtkExtractPolyDataGeometry::ExtractInside [protected]

Definition at line 99 of file vtkExtractPolyDataGeometry.h.

int vtkExtractPolyDataGeometry::ExtractBoundaryCells [protected]

Definition at line 100 of file vtkExtractPolyDataGeometry.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractPolyDataGeometry.h
Generated on Mon Mar 25 01:17:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractPolyDataPiece Class Reference

Return specified piece, including specified. More...

#include <vtkExtractPolyDataPiece.h>

Inheritance diagram for vtkExtractPolyDataPiece:

[legend]
Collaboration diagram for vtkExtractPolyDataPiece:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractPolyDataPiece, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCreateGhostCells (int)
virtual int | GetCreateGhostCells ()
virtual void | CreateGhostCellsOn ()
virtual void | CreateGhostCellsOff ()

Static Public Methods

vtkExtractPolyDataPiece * | New ()

Protected Methods

vtkExtractPolyDataPiece ()
~vtkExtractPolyDataPiece ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *out)
void | ComputeCellTags (vtkIntArray *cellTags, vtkIdList *pointOwnership, int piece, int numPieces)
void | AddGhostLevel (vtkPolyData *input, vtkIntArray *cellTags, int ghostLevel)

Protected Attributes

int | CreateGhostCells

Detailed Description

Return specified piece, including specified.

Date:
2002/01/22 15:34:30
Revision:
1.7
number of ghost levels.
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (92%)
Tests:
vtkExtractPolyDataPiece (Tests)

Definition at line 38 of file vtkExtractPolyDataPiece.h.

Constructor & Destructor Documentation

vtkExtractPolyDataPiece::vtkExtractPolyDataPiece ( ) [protected]

vtkExtractPolyDataPiece::~vtkExtractPolyDataPiece ( ) [inline, protected]

Definition at line 54 of file vtkExtractPolyDataPiece.h.

Member Function Documentation

vtkExtractPolyDataPiece* vtkExtractPolyDataPiece::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkExtractPolyDataPiece::vtkTypeRevisionMacro | ( | vtkExtractPolyDataPiece | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkExtractPolyDataPiece::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkExtractPolyDataPiece::SetCreateGhostCells ( int ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual int vtkExtractPolyDataPiece::GetCreateGhostCells ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkExtractPolyDataPiece::CreateGhostCellsOn ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkExtractPolyDataPiece::CreateGhostCellsOff ( ) [virtual]

Turn on/off creating ghost cells (on by default).

void vtkExtractPolyDataPiece::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkExtractPolyDataPiece::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkExtractPolyDataPiece::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

void vtkExtractPolyDataPiece::ComputeCellTags | ( | vtkIntArray * | cellTags,
 |  | vtkIdList * | pointOwnership,
 |  | int | piece,
 |  | int | numPieces
 | ) | [protected]

void vtkExtractPolyDataPiece::AddGhostLevel | ( | vtkPolyData * | input,
 |  | vtkIntArray * | cellTags,
 |  | int | ghostLevel
 | ) | [protected]

Member Data Documentation

int vtkExtractPolyDataPiece::CreateGhostCells [protected]

Definition at line 67 of file vtkExtractPolyDataPiece.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkExtractPolyDataPiece.h
Generated on Mon Mar 25 01:17:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractTensorComponents Class Reference

extract parts of tensor and create a scalar, vector, normal, or texture coordinates. More...

#include <vtkExtractTensorComponents.h>

Inheritance diagram for vtkExtractTensorComponents:

[legend]
Collaboration diagram for vtkExtractTensorComponents:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractTensorComponents, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPassTensorsToOutput (int)
virtual int | GetPassTensorsToOutput ()
virtual void | PassTensorsToOutputOn ()
virtual void | PassTensorsToOutputOff ()
virtual void | SetExtractScalars (int)
virtual int | GetExtractScalars ()
virtual void | ExtractScalarsOn ()
virtual void | ExtractScalarsOff ()
virtual void | SetScalarComponents (int, int)
void | SetScalarComponents (int[2])
virtual int * | GetScalarComponents ()
virtual void | GetScalarComponents (int data[2])
virtual void | SetScalarMode (int)
virtual int | GetScalarMode ()
void | ScalarIsComponent ()
void | ScalarIsEffectiveStress ()
void | ScalarIsDeterminant ()
virtual void | SetExtractVectors (int)
virtual int | GetExtractVectors ()
virtual void | ExtractVectorsOn ()
virtual void | ExtractVectorsOff ()
virtual void | SetVectorComponents (int, int, int, int, int, int)
virtual void | SetVectorComponents (int[6])
virtual int * | GetVectorComponents ()
virtual void | GetVectorComponents (int data[6])
virtual void | SetExtractNormals (int)
virtual int | GetExtractNormals ()
virtual void | ExtractNormalsOn ()
virtual void | ExtractNormalsOff ()
virtual void | SetNormalizeNormals (int)
virtual int | GetNormalizeNormals ()
virtual void | NormalizeNormalsOn ()
virtual void | NormalizeNormalsOff ()
virtual void | SetNormalComponents (int, int, int, int, int, int)
virtual void | SetNormalComponents (int[6])
virtual int * | GetNormalComponents ()
virtual void | GetNormalComponents (int data[6])
virtual void | SetExtractTCoords (int)
virtual int | GetExtractTCoords ()
virtual void | ExtractTCoordsOn ()
virtual void | ExtractTCoordsOff ()
virtual void | SetNumberOfTCoords (int)
virtual int | GetNumberOfTCoords ()
virtual void | SetTCoordComponents (int, int, int, int, int, int)
virtual void | SetTCoordComponents (int[6])
virtual int * | GetTCoordComponents ()
virtual void | GetTCoordComponents (int data[6])

Static Public Methods

vtkExtractTensorComponents * | New ()

Protected Methods

vtkExtractTensorComponents ()
~vtkExtractTensorComponents ()
void | Execute ()

Protected Attributes

int | PassTensorsToOutput
int | ExtractScalars
int | ExtractVectors
int | ExtractNormals
int | ExtractTCoords
int | ScalarMode
int | ScalarComponents [2]
int | VectorComponents [6]
int | NormalizeNormals
int | NormalComponents [6]
int | NumberOfTCoords
int | TCoordComponents [6]

Detailed Description

extract parts of tensor and create a scalar, vector, normal, or texture coordinates.

Date:
2002/01/22 15:29:20
Revision:
1.27

vtkExtractTensorComponents is a filter that extracts components of a tensor to create a scalar, vector, normal, or texture coords. For example, if the tensor contains components of stress, then you could extract the normal stress in the x-direction as a scalar (i.e., tensor component (0,0).

To use this filter, you must set some boolean flags to control which data is extracted from the tensors, and whether you want to pass the tensor data through to the output. Also, you must specify the tensor component(s) for each type of data you want to extract. The tensor component(s) is(are) specified using matrix notation into a 3x3 matrix. That is, use the (row,column) address to specify a particular tensor component; and if the data you are extracting requires more than one component, use a list of addresses. (Note that the addresses are 0-offset -> (0,0) specifies upper left corner of the tensor.)

There are two optional methods to extract scalar data. You can extract the determinant of the tensor, or you can extract the effective stress of the tensor. These require that the ivar ExtractScalars is on, and the appropriate scalar extraction mode is set.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Geveci, Berk (9%)
  • Lorensen, Bill (5%)
Tests:
vtkExtractTensorComponents (Tests)

Definition at line 66 of file vtkExtractTensorComponents.h.

Constructor & Destructor Documentation

vtkExtractTensorComponents::vtkExtractTensorComponents ( ) [protected]

vtkExtractTensorComponents::~vtkExtractTensorComponents ( ) [inline, protected]

Definition at line 170 of file vtkExtractTensorComponents.h.

Member Function Documentation

vtkExtractTensorComponents::vtkTypeRevisionMacro | ( | vtkExtractTensorComponents | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkExtractTensorComponents::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkExtractTensorComponents* vtkExtractTensorComponents::New ( ) [static]

Construct object to extract nothing and to not pass tensor data through the pipeline.

Reimplemented from vtkDataSetSource.

virtual void vtkExtractTensorComponents::SetPassTensorsToOutput ( int ) [virtual]

Boolean controls whether tensor data is passed through to output.

virtual int vtkExtractTensorComponents::GetPassTensorsToOutput ( ) [virtual]

Boolean controls whether tensor data is passed through to output.

virtual void vtkExtractTensorComponents::PassTensorsToOutputOn ( ) [virtual]

Boolean controls whether tensor data is passed through to output.

virtual void vtkExtractTensorComponents::PassTensorsToOutputOff ( ) [virtual]

Boolean controls whether tensor data is passed through to output.

virtual void vtkExtractTensorComponents::SetExtractScalars ( int ) [virtual]

Boolean controls whether scalar data is extracted from tensor.

virtual int vtkExtractTensorComponents::GetExtractScalars ( ) [virtual]

Boolean controls whether scalar data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractScalarsOn ( ) [virtual]

Boolean controls whether scalar data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractScalarsOff ( ) [virtual]

Boolean controls whether scalar data is extracted from tensor.

virtual void vtkExtractTensorComponents::SetScalarComponents | ( | int | ,
 |  | int |
 | ) | [virtual]

Specify the (row,column) tensor component to extract as a scalar.

void vtkExtractTensorComponents::SetScalarComponents ( int [2] )

Specify the (row,column) tensor component to extract as a scalar.

virtual int* vtkExtractTensorComponents::GetScalarComponents ( ) [virtual]

Specify the (row,column) tensor component to extract as a scalar.

virtual void vtkExtractTensorComponents::GetScalarComponents ( int data[2] ) [virtual]

Specify the (row,column) tensor component to extract as a scalar.

virtual void vtkExtractTensorComponents::SetScalarMode ( int ) [virtual]

Specify how to extract the scalar. You can extract it as one of the components of the tensor, as effective stress, or as the determinant of the tensor. If you extract a component make sure that you set the ScalarComponents ivar.

virtual int vtkExtractTensorComponents::GetScalarMode ( ) [virtual]

Specify how to extract the scalar. You can extract it as one of the components of the tensor, as effective stress, or as the determinant of the tensor. If you extract a component make sure that you set the ScalarComponents ivar.

void vtkExtractTensorComponents::ScalarIsComponent ( ) [inline]

Specify how to extract the scalar. You can extract it as one of the components of the tensor, as effective stress, or as the determinant of the tensor. If you extract a component make sure that you set the ScalarComponents ivar.

Definition at line 103 of file vtkExtractTensorComponents.h.

void vtkExtractTensorComponents::ScalarIsEffectiveStress ( ) [inline]

Specify how to extract the scalar. You can extract it as one of the components of the tensor, as effective stress, or as the determinant of the tensor. If you extract a component make sure that you set the ScalarComponents ivar.

Definition at line 104 of file vtkExtractTensorComponents.h.

void vtkExtractTensorComponents::ScalarIsDeterminant ( ) [inline]

Specify how to extract the scalar. You can extract it as one of the components of the tensor, as effective stress, or as the determinant of the tensor. If you extract a component make sure that you set the ScalarComponents ivar.

Definition at line 106 of file vtkExtractTensorComponents.h.

virtual void vtkExtractTensorComponents::SetExtractVectors ( int ) [virtual]

Boolean controls whether vector data is extracted from tensor.

virtual int vtkExtractTensorComponents::GetExtractVectors ( ) [virtual]

Boolean controls whether vector data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractVectorsOn ( ) [virtual]

Boolean controls whether vector data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractVectorsOff ( ) [virtual]

Boolean controls whether vector data is extracted from tensor.

virtual void vtkExtractTensorComponents::SetVectorComponents | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::SetVectorComponents ( int [6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual int* vtkExtractTensorComponents::GetVectorComponents ( ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::GetVectorComponents ( int data[6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::SetExtractNormals ( int ) [virtual]

Boolean controls whether normal data is extracted from tensor.

virtual int vtkExtractTensorComponents::GetExtractNormals ( ) [virtual]

Boolean controls whether normal data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractNormalsOn ( ) [virtual]

Boolean controls whether normal data is extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractNormalsOff ( ) [virtual]

Boolean controls whether normal data is extracted from tensor.

virtual void vtkExtractTensorComponents::SetNormalizeNormals ( int ) [virtual]

Boolean controls whether normal vector is converted to unit normal after extraction.

virtual int vtkExtractTensorComponents::GetNormalizeNormals ( ) [virtual]

Boolean controls whether normal vector is converted to unit normal after extraction.

virtual void vtkExtractTensorComponents::NormalizeNormalsOn ( ) [virtual]

Boolean controls whether normal vector is converted to unit normal after extraction.

virtual void vtkExtractTensorComponents::NormalizeNormalsOff ( ) [virtual]

Boolean controls whether normal vector is converted to unit normal after extraction.

virtual void vtkExtractTensorComponents::SetNormalComponents | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::SetNormalComponents ( int [6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual int* vtkExtractTensorComponents::GetNormalComponents ( ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::GetNormalComponents ( int data[6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector.

virtual void vtkExtractTensorComponents::SetExtractTCoords ( int ) [virtual]

Boolean controls whether texture coordinates are extracted from tensor.

virtual int vtkExtractTensorComponents::GetExtractTCoords ( ) [virtual]

Boolean controls whether texture coordinates are extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractTCoordsOn ( ) [virtual]

Boolean controls whether texture coordinates are extracted from tensor.

virtual void vtkExtractTensorComponents::ExtractTCoordsOff ( ) [virtual]

Boolean controls whether texture coordinates are extracted from tensor.

virtual void vtkExtractTensorComponents::SetNumberOfTCoords ( int ) [virtual]

Set the dimension of the texture coordinates to extract.

virtual int vtkExtractTensorComponents::GetNumberOfTCoords ( ) [virtual]

Set the dimension of the texture coordinates to extract.

virtual void vtkExtractTensorComponents::SetTCoordComponents | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector. Up to NumberOfTCoords components are extracted.

virtual void vtkExtractTensorComponents::SetTCoordComponents ( int [6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector. Up to NumberOfTCoords components are extracted.

virtual int* vtkExtractTensorComponents::GetTCoordComponents ( ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector. Up to NumberOfTCoords components are extracted.

virtual void vtkExtractTensorComponents::GetTCoordComponents ( int data[6] ) [virtual]

Specify the ((row,column)0,(row,column)1,(row,column)2) tensor components to extract as a vector. Up to NumberOfTCoords components are extracted.

void vtkExtractTensorComponents::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkExtractTensorComponents::PassTensorsToOutput [protected]

Definition at line 174 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ExtractScalars [protected]

Definition at line 176 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ExtractVectors [protected]

Definition at line 177 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ExtractNormals [protected]

Definition at line 178 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ExtractTCoords [protected]

Definition at line 179 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ScalarMode [protected]

Definition at line 181 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::ScalarComponents[2] [protected]

Definition at line 182 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::VectorComponents[6] [protected]

Definition at line 184 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::NormalizeNormals [protected]

Definition at line 186 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::NormalComponents[6] [protected]

Definition at line 187 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::NumberOfTCoords [protected]

Definition at line 189 of file vtkExtractTensorComponents.h.

int vtkExtractTensorComponents::TCoordComponents[6] [protected]

Definition at line 190 of file vtkExtractTensorComponents.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractTensorComponents.h
Generated on Mon Mar 25 01:17:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractUnstructuredGrid Class Reference

extract subset of unstructured grid geometry. More...

#include <vtkExtractUnstructuredGrid.h>

Inheritance diagram for vtkExtractUnstructuredGrid:

[legend]
Collaboration diagram for vtkExtractUnstructuredGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractUnstructuredGrid, vtkUnstructuredGridToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetPointClipping (int)
virtual int | GetPointClipping ()
virtual void | PointClippingOn ()
virtual void | PointClippingOff ()
virtual void | SetCellClipping (int)
virtual int | GetCellClipping ()
virtual void | CellClippingOn ()
virtual void | CellClippingOff ()
virtual void | SetExtentClipping (int)
virtual int | GetExtentClipping ()
virtual void | ExtentClippingOn ()
virtual void | ExtentClippingOff ()
virtual void | SetPointMinimum (vtkIdType)
virtual vtkIdType | GetPointMinimum ()
virtual void | SetPointMaximum (vtkIdType)
virtual vtkIdType | GetPointMaximum ()
virtual void | SetCellMinimum (vtkIdType)
virtual vtkIdType | GetCellMinimum ()
virtual void | SetCellMaximum (vtkIdType)
virtual vtkIdType | GetCellMaximum ()
void | SetExtent (float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
void | SetExtent (float extent[6])
float * | GetExtent ()
virtual void | SetMerging (int)
virtual int | GetMerging ()
virtual void | MergingOn ()
virtual void | MergingOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkExtractUnstructuredGrid * | New ()

Protected Methods

vtkExtractUnstructuredGrid ()
~vtkExtractUnstructuredGrid ()
void | Execute ()

Protected Attributes

vtkIdType PointMinimum
vtkIdType PointMaximum
vtkIdType CellMinimum
vtkIdType CellMaximum
float | Extent [6]
int | PointClipping
int | CellClipping
int | ExtentClipping
int | Merging
vtkPointLocator * Locator

Detailed Description

extract subset of unstructured grid geometry.

Date:
2002/01/22 15:29:20
Revision:
1.26

vtkExtractUnstructuredGrid is a general-purpose filter to extract geometry (and associated data) from an unstructured grid dataset. The extraction process is controlled by specifying a range of point ids, cell ids, or a bounding box (referred to as "Extent"). Those cells lying within these regions are sent to the output. The user has the choice of merging coincident points (Merging is on) or using the original point set (Merging is off).

Warning:
If merging is off, the input points are copied through to the output. This means unused points may be present in the output data. If merging is on, then coincident points with different point attribute values are merged.
See also:
vtkImageDataGeometryFilter vtkStructuredGridGeometryFilter vtkRectilinearGridGeometryFilter vtkExtractGeometry vtkExtractVOI
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (80%)
  • Henderson, Amy (6%)
Examples:
vtkExtractUnstructuredGrid (Examples)
Tests:
vtkExtractUnstructuredGrid (Tests)

Definition at line 60 of file vtkExtractUnstructuredGrid.h.

Constructor & Destructor Documentation

vtkExtractUnstructuredGrid::vtkExtractUnstructuredGrid ( ) [protected]

vtkExtractUnstructuredGrid::~vtkExtractUnstructuredGrid ( ) [inline, protected]

Definition at line 152 of file vtkExtractUnstructuredGrid.h.

Member Function Documentation

vtkExtractUnstructuredGrid::vtkTypeRevisionMacro | ( | vtkExtractUnstructuredGrid | ,
 |  | vtkUnstructuredGridToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkUnstructuredGridToUnstructuredGridFilter.

void vtkExtractUnstructuredGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkExtractUnstructuredGrid* vtkExtractUnstructuredGrid::New ( ) [static]

Construct with all types of clipping turned off.

Reimplemented from vtkUnstructuredGridSource.

virtual void vtkExtractUnstructuredGrid::SetPointClipping ( int ) [virtual]

Turn on/off selection of geometry by point id.

virtual int vtkExtractUnstructuredGrid::GetPointClipping ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkExtractUnstructuredGrid::PointClippingOn ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkExtractUnstructuredGrid::PointClippingOff ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkExtractUnstructuredGrid::SetCellClipping ( int ) [virtual]

Turn on/off selection of geometry by cell id.

virtual int vtkExtractUnstructuredGrid::GetCellClipping ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkExtractUnstructuredGrid::CellClippingOn ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkExtractUnstructuredGrid::CellClippingOff ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkExtractUnstructuredGrid::SetExtentClipping ( int ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual int vtkExtractUnstructuredGrid::GetExtentClipping ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkExtractUnstructuredGrid::ExtentClippingOn ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkExtractUnstructuredGrid::ExtentClippingOff ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkExtractUnstructuredGrid::SetPointMinimum ( vtkIdType ) [virtual]

Specify the minimum point id for point id selection.

virtual vtkIdType vtkExtractUnstructuredGrid::GetPointMinimum ( ) [virtual]

Specify the minimum point id for point id selection.

virtual void vtkExtractUnstructuredGrid::SetPointMaximum ( vtkIdType ) [virtual]

Specify the maximum point id for point id selection.

virtual vtkIdType vtkExtractUnstructuredGrid::GetPointMaximum ( ) [virtual]

Specify the maximum point id for point id selection.

virtual void vtkExtractUnstructuredGrid::SetCellMinimum ( vtkIdType ) [virtual]

Specify the minimum cell id for point id selection.

virtual vtkIdType vtkExtractUnstructuredGrid::GetCellMinimum ( ) [virtual]

Specify the minimum cell id for point id selection.

virtual void vtkExtractUnstructuredGrid::SetCellMaximum ( vtkIdType ) [virtual]

Specify the maximum cell id for point id selection.

virtual vtkIdType vtkExtractUnstructuredGrid::GetCellMaximum ( ) [virtual]

Specify the maximum cell id for point id selection.

void vtkExtractUnstructuredGrid::SetExtent | ( | float | xMin,
 |  | float | xMax,
 |  | float | yMin,
 |  | float | yMax,
 |  | float | zMin,
 |  | float | zMax
 | ) |

Specify a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

void vtkExtractUnstructuredGrid::SetExtent ( float extent[6] )

Set / get a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

float* vtkExtractUnstructuredGrid::GetExtent ( ) [inline]

Set / get a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

Definition at line 125 of file vtkExtractUnstructuredGrid.h.

virtual void vtkExtractUnstructuredGrid::SetMerging ( int ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual int vtkExtractUnstructuredGrid::GetMerging ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual void vtkExtractUnstructuredGrid::MergingOn ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual void vtkExtractUnstructuredGrid::MergingOff ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

void vtkExtractUnstructuredGrid::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkExtractUnstructuredGrid::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkExtractUnstructuredGrid::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

unsigned long vtkExtractUnstructuredGrid::GetMTime ( ) [virtual]

Return the MTime also considering the locator.

Reimplemented from vtkObject.

void vtkExtractUnstructuredGrid::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkIdType vtkExtractUnstructuredGrid::PointMinimum [protected]

Definition at line 156 of file vtkExtractUnstructuredGrid.h.

vtkIdType vtkExtractUnstructuredGrid::PointMaximum [protected]

Definition at line 157 of file vtkExtractUnstructuredGrid.h.

vtkIdType vtkExtractUnstructuredGrid::CellMinimum [protected]

Definition at line 158 of file vtkExtractUnstructuredGrid.h.

vtkIdType vtkExtractUnstructuredGrid::CellMaximum [protected]

Definition at line 159 of file vtkExtractUnstructuredGrid.h.

float vtkExtractUnstructuredGrid::Extent[6] [protected]

Definition at line 160 of file vtkExtractUnstructuredGrid.h.

int vtkExtractUnstructuredGrid::PointClipping [protected]

Definition at line 161 of file vtkExtractUnstructuredGrid.h.

int vtkExtractUnstructuredGrid::CellClipping [protected]

Definition at line 162 of file vtkExtractUnstructuredGrid.h.

int vtkExtractUnstructuredGrid::ExtentClipping [protected]

Definition at line 163 of file vtkExtractUnstructuredGrid.h.

int vtkExtractUnstructuredGrid::Merging [protected]

Definition at line 165 of file vtkExtractUnstructuredGrid.h.

vtkPointLocator* vtkExtractUnstructuredGrid::Locator [protected]

Definition at line 166 of file vtkExtractUnstructuredGrid.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractUnstructuredGrid.h
Generated on Mon Mar 25 01:17:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractUnstructuredGridPiece Class Reference

Return specified piece, including specified. More...

#include <vtkExtractUnstructuredGridPiece.h>

Inheritance diagram for vtkExtractUnstructuredGridPiece:

[legend]
Collaboration diagram for vtkExtractUnstructuredGridPiece:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCreateGhostCells (int)
virtual int | GetCreateGhostCells ()
virtual void | CreateGhostCellsOn ()
virtual void | CreateGhostCellsOff ()

Static Public Methods

vtkExtractUnstructuredGridPiece * | New ()

Protected Methods

vtkExtractUnstructuredGridPiece ()
~vtkExtractUnstructuredGridPiece ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *out)
void | ComputeCellTags (vtkIntArray *cellTags, vtkIdList *pointOwnership, int piece, int numPieces)
void | AddGhostLevel (vtkUnstructuredGrid *input, vtkIntArray *cellTags, int ghostLevel)

Protected Attributes

int | CreateGhostCells

Detailed Description

Return specified piece, including specified.

Date:
2002/01/22 15:34:31
Revision:
1.7
number of ghost levels.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (90%)
  • Henderson, Amy (5%)
Tests:
vtkExtractUnstructuredGridPiece (Tests)

Definition at line 39 of file vtkExtractUnstructuredGridPiece.h.

Constructor & Destructor Documentation

vtkExtractUnstructuredGridPiece::vtkExtractUnstructuredGridPiece ( ) [protected]

vtkExtractUnstructuredGridPiece::~vtkExtractUnstructuredGridPiece ( ) [inline, protected]

Definition at line 55 of file vtkExtractUnstructuredGridPiece.h.

Member Function Documentation

vtkExtractUnstructuredGridPiece* vtkExtractUnstructuredGridPiece::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkExtractUnstructuredGridPiece::vtkTypeRevisionMacro | ( | vtkExtractUnstructuredGridPiece | ,
 |  | vtkUnstructuredGridToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkUnstructuredGridToUnstructuredGridFilter.

void vtkExtractUnstructuredGridPiece::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkExtractUnstructuredGridPiece::SetCreateGhostCells ( int ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual int vtkExtractUnstructuredGridPiece::GetCreateGhostCells ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkExtractUnstructuredGridPiece::CreateGhostCellsOn ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkExtractUnstructuredGridPiece::CreateGhostCellsOff ( ) [virtual]

Turn on/off creating ghost cells (on by default).

void vtkExtractUnstructuredGridPiece::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkExtractUnstructuredGridPiece::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkExtractUnstructuredGridPiece::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkUnstructuredGridSource.

void vtkExtractUnstructuredGridPiece::ComputeCellTags | ( | vtkIntArray * | cellTags,
 |  | vtkIdList * | pointOwnership,
 |  | int | piece,
 |  | int | numPieces
 | ) | [protected]

void vtkExtractUnstructuredGridPiece::AddGhostLevel | ( | vtkUnstructuredGrid * | input,
 |  | vtkIntArray * | cellTags,
 |  | int | ghostLevel
 | ) | [protected]

Member Data Documentation

int vtkExtractUnstructuredGridPiece::CreateGhostCells [protected]

Definition at line 68 of file vtkExtractUnstructuredGridPiece.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkExtractUnstructuredGridPiece.h
Generated on Mon Mar 25 01:17:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractVectorComponents Class Reference

extract components of vector as separate scalars. More...

#include <vtkExtractVectorComponents.h>

Inheritance diagram for vtkExtractVectorComponents:

[legend]
Collaboration diagram for vtkExtractVectorComponents:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractVectorComponents, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()
vtkDataSet * GetVxComponent ()
vtkDataSet * GetVyComponent ()
vtkDataSet * GetVzComponent ()
vtkDataSet * | GetOutput (int i=0)
virtual void | SetExtractToFieldData (int)
virtual int | GetExtractToFieldData ()
virtual void | ExtractToFieldDataOn ()
virtual void | ExtractToFieldDataOff ()

Static Public Methods

vtkExtractVectorComponents * | New ()

Protected Methods

vtkExtractVectorComponents ()
~vtkExtractVectorComponents ()
void | Execute ()

Protected Attributes

int | ExtractToFieldData

Detailed Description

extract components of vector as separate scalars.

Date:
2002/01/22 15:29:20
Revision:
1.36

vtkExtractVectorComponents is a filter that extracts vector components as separate scalars. This is accomplished by creating three different outputs. Each output is the same as the input, except that the scalar values will be one of the three components of the vector. These can be found in the VxComponent, VyComponent, and VzComponent. Alternatively, if the ExtractToFieldData flag is set, the filter will put all the components in the field data. The first component will be the scalar and the others will be non-attribute arrays.

Warning:
This filter is unusual in that it creates multiple outputs. If you use the GetOutput() method, you will be retrieving the x vector component.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (44%)
  • Geveci, Berk (22%)
  • Martin, Ken (16%)
  • Lorensen, Bill (6%)
Tests:
vtkExtractVectorComponents (Tests)

Definition at line 55 of file vtkExtractVectorComponents.h.

Constructor & Destructor Documentation

vtkExtractVectorComponents::vtkExtractVectorComponents ( ) [protected]

vtkExtractVectorComponents::~vtkExtractVectorComponents ( ) [protected]

Member Function Documentation

vtkExtractVectorComponents* vtkExtractVectorComponents::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkExtractVectorComponents::vtkTypeRevisionMacro | ( | vtkExtractVectorComponents | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkExtractVectorComponents::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkExtractVectorComponents::SetInput ( vtkDataSet * input ) [virtual]

Specify the input data or filter.

vtkDataSet* vtkExtractVectorComponents::GetInput ( )

Get the input data or filter.

vtkDataSet* vtkExtractVectorComponents::GetVxComponent ( )

Get the output dataset representing velocity x-component. If output is NULL then input hasn't been set, which is necessary for abstract objects. (Note: this method returns the same information as the GetOutput() method with an index of 0.)

vtkDataSet* vtkExtractVectorComponents::GetVyComponent ( )

Get the output dataset representing velocity y-component. If output is NULL then input hasn't been set, which is necessary for abstract objects. (Note: this method returns the same information as the GetOutput() method with an index of 1.) Note that if ExtractToFieldData is true, this output will be empty.

vtkDataSet* vtkExtractVectorComponents::GetVzComponent ( )

Get the output dataset representing velocity z-component. If output is NULL then input hasn't been set, which is necessary for abstract objects. (Note: this method returns the same information as the GetOutput() method with an index of 2.) Note that if ExtractToFieldData is true, this output will be empty.

vtkDataSet* vtkExtractVectorComponents::GetOutput ( int i = 0 )

Get the output dataset containing the indicated component. The component is specified by an index between (0,2) corresponding to the x, y, or z vector component. By default, the x component is extracted.

Reimplemented from vtkSource.

virtual void vtkExtractVectorComponents::SetExtractToFieldData ( int ) [virtual]

Determines whether the vector components will be put in separate outputs or in the first output's field data

virtual int vtkExtractVectorComponents::GetExtractToFieldData ( ) [virtual]

Determines whether the vector components will be put in separate outputs or in the first output's field data

virtual void vtkExtractVectorComponents::ExtractToFieldDataOn ( ) [virtual]

Determines whether the vector components will be put in separate outputs or in the first output's field data

virtual void vtkExtractVectorComponents::ExtractToFieldDataOff ( ) [virtual]

Determines whether the vector components will be put in separate outputs or in the first output's field data

void vtkExtractVectorComponents::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkExtractVectorComponents::ExtractToFieldData [protected]

Definition at line 107 of file vtkExtractVectorComponents.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkExtractVectorComponents.h
Generated on Mon Mar 25 01:17:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkExtractVOI Class Reference

select piece (e.g., volume of interest) and/or subsample structured points dataset. More...

#include <vtkExtractVOI.h>

Inheritance diagram for vtkExtractVOI:

[legend]
Collaboration diagram for vtkExtractVOI:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkExtractVOI, vtkStructuredPointsToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetVOI (int, int, int, int, int, int)
virtual void | SetVOI (int[6])
virtual int * | GetVOI ()
virtual void | GetVOI (int data[6])
virtual void | SetSampleRate (int, int, int)
virtual void | SetSampleRate (int[3])
virtual int * | GetSampleRate ()
virtual void | GetSampleRate (int data[3])

Static Public Methods

vtkExtractVOI * | New ()

Protected Methods

vtkExtractVOI ()
~vtkExtractVOI ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

int | VOI [6]
int | SampleRate [3]

Detailed Description

select piece (e.g., volume of interest) and/or subsample structured points dataset.

Date:
2002/01/22 15:31:45
Revision:
1.29

vtkExtractVOI is a filter that selects a portion of an input structured points dataset, or subsamples an input dataset. (The selected portion of interested is referred to as the Volume Of Interest, or VOI.) The output of this filter is a structured points dataset. The filter treats input data of any topological dimension (i.e., point, line, image, or volume) and can generate output data of any topological dimension.

To use this filter set the VOI ivar which are i-j-k min/max indices that specify a rectangular region in the data. (Note that these are 0-offset.) You can also specify a sampling rate to subsample the data.

Typical applications of this filter are to extract a slice from a volume for image processing, subsampling large volumes to reduce data size, or extracting regions of a volume with interesting data.

See also:
vtkGeometryFilter vtkExtractGeometry vtkExtractGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (57%)
  • Lorensen, Bill (19%)
  • Avila, Lisa (12%)
  • Martin, Ken (6%)
Examples:
vtkExtractVOI (Examples)
Tests:
vtkExtractVOI (Tests)

Definition at line 62 of file vtkExtractVOI.h.

Constructor & Destructor Documentation

vtkExtractVOI::vtkExtractVOI ( ) [protected]

vtkExtractVOI::~vtkExtractVOI ( ) [inline, protected]

Definition at line 90 of file vtkExtractVOI.h.

Member Function Documentation

vtkExtractVOI::vtkTypeRevisionMacro | ( | vtkExtractVOI | ,
 |  | vtkStructuredPointsToStructuredPointsFilter |
 | ) |

Reimplemented from vtkStructuredPointsToStructuredPointsFilter.

void vtkExtractVOI::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkExtractVOI* vtkExtractVOI::New ( ) [static]

Construct object to extract all of the input data.

Reimplemented from vtkStructuredPointsSource.

virtual void vtkExtractVOI::SetVOI | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured points dataset can be of any topological dimension (i.e., point, line, image, or volume).

virtual void vtkExtractVOI::SetVOI ( int [6] ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured points dataset can be of any topological dimension (i.e., point, line, image, or volume).

virtual int* vtkExtractVOI::GetVOI ( ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured points dataset can be of any topological dimension (i.e., point, line, image, or volume).

virtual void vtkExtractVOI::GetVOI ( int data[6] ) [virtual]

Specify i-j-k (min,max) pairs to extract. The resulting structured points dataset can be of any topological dimension (i.e., point, line, image, or volume).

virtual void vtkExtractVOI::SetSampleRate | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual void vtkExtractVOI::SetSampleRate ( int [3] ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual int* vtkExtractVOI::GetSampleRate ( ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

virtual void vtkExtractVOI::GetSampleRate ( int data[3] ) [virtual]

Set the sampling rate in the i, j, and k directions. If the rate is > 1, then the resulting VOI will be subsampled representation of the input. For example, if the SampleRate=(2,2,2), every other point will be selected, resulting in a volume 1/8th the original size.

void vtkExtractVOI::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkExtractVOI::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsToStructuredPointsFilter.

Member Data Documentation

int vtkExtractVOI::VOI[6] [protected]

Definition at line 95 of file vtkExtractVOI.h.

int vtkExtractVOI::SampleRate[3] [protected]

Definition at line 96 of file vtkExtractVOI.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkExtractVOI.h
Generated on Mon Mar 25 01:17:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Face Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Face:

[legend]
List of all members.

Public Attributes

int | a
int | b
int | c

Member Data Documentation

int Face::a

Definition at line 42 of file vtk3DS.h.

int Face::b

Definition at line 42 of file vtk3DS.h.

int Face::c

Definition at line 42 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:17:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFeatureEdges Class Reference

extract boundary, non-manifold, and/or sharp edges from polygonal data. More...

#include <vtkFeatureEdges.h>

Inheritance diagram for vtkFeatureEdges:

[legend]
Collaboration diagram for vtkFeatureEdges:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFeatureEdges, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetBoundaryEdges (int)
virtual int | GetBoundaryEdges ()
virtual void | BoundaryEdgesOn ()
virtual void | BoundaryEdgesOff ()
virtual void | SetFeatureEdges (int)
virtual int | GetFeatureEdges ()
virtual void | FeatureEdgesOn ()
virtual void | FeatureEdgesOff ()
virtual void | SetFeatureAngle (float)
virtual float | GetFeatureAngle ()
virtual void | SetNonManifoldEdges (int)
virtual int | GetNonManifoldEdges ()
virtual void | NonManifoldEdgesOn ()
virtual void | NonManifoldEdgesOff ()
virtual void | SetManifoldEdges (int)
virtual int | GetManifoldEdges ()
virtual void | ManifoldEdgesOn ()
virtual void | ManifoldEdgesOff ()
virtual void | SetColoring (int)
virtual int | GetColoring ()
virtual void | ColoringOn ()
virtual void | ColoringOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkFeatureEdges * | New ()

Protected Methods

vtkFeatureEdges ()
~vtkFeatureEdges ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

float | FeatureAngle
int | BoundaryEdges
int | FeatureEdges
int | NonManifoldEdges
int | ManifoldEdges
int | Coloring
vtkPointLocator * Locator

Detailed Description

extract boundary, non-manifold, and/or sharp edges from polygonal data.

Date:
2002/01/22 15:29:21
Revision:
1.37

vtkFeatureEdges is a filter to extract special types of edges from input polygonal data. These edges are either 1) boundary (used by one polygon) or a line cell; 2) non-manifold (used by three or more polygons); 3) feature edges (edges used by two triangles and whose dihedral angle > FeatureAngle); or 4) manifold edges (edges used by exactly two polygons). These edges may be extracted in any combination. Edges may also be "colored" (i.e., scalar values assigned) based on edge type. The cell coloring is assigned to the cell data of the extracted edges.

Warning:
To see the coloring of the liens you may have to set the ScalarMode instance variable of the mapper to SetScalarModeToUseCellData(). (This is only a problem if there are point data scalars.)
See also:
vtkFeatureVertices
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Henderson, Amy (9%)
  • Geveci, Berk (5%)
Examples:
vtkFeatureEdges (Examples)
Tests:
vtkFeatureEdges (Tests)

Definition at line 60 of file vtkFeatureEdges.h.

Constructor & Destructor Documentation

vtkFeatureEdges::vtkFeatureEdges ( ) [protected]

vtkFeatureEdges::~vtkFeatureEdges ( ) [protected]

Member Function Documentation

vtkFeatureEdges::vtkTypeRevisionMacro | ( | vtkFeatureEdges | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkFeatureEdges::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkFeatureEdges* vtkFeatureEdges::New ( ) [static]

Construct object with feature angle = 30; all types of edges extracted and colored.

Reimplemented from vtkPolyDataSource.

virtual void vtkFeatureEdges::SetBoundaryEdges ( int ) [virtual]

Turn on/off the extraction of boundary edges.

virtual int vtkFeatureEdges::GetBoundaryEdges ( ) [virtual]

Turn on/off the extraction of boundary edges.

virtual void vtkFeatureEdges::BoundaryEdgesOn ( ) [virtual]

Turn on/off the extraction of boundary edges.

virtual void vtkFeatureEdges::BoundaryEdgesOff ( ) [virtual]

Turn on/off the extraction of boundary edges.

virtual void vtkFeatureEdges::SetFeatureEdges ( int ) [virtual]

Turn on/off the extraction of feature edges.

virtual int vtkFeatureEdges::GetFeatureEdges ( ) [virtual]

Turn on/off the extraction of feature edges.

virtual void vtkFeatureEdges::FeatureEdgesOn ( ) [virtual]

Turn on/off the extraction of feature edges.

virtual void vtkFeatureEdges::FeatureEdgesOff ( ) [virtual]

Turn on/off the extraction of feature edges.

virtual void vtkFeatureEdges::SetFeatureAngle ( float ) [virtual]

Specify the feature angle for extracting feature edges.

virtual float vtkFeatureEdges::GetFeatureAngle ( ) [virtual]

Specify the feature angle for extracting feature edges.

virtual void vtkFeatureEdges::SetNonManifoldEdges ( int ) [virtual]

Turn on/off the extraction of non-manifold edges.

virtual int vtkFeatureEdges::GetNonManifoldEdges ( ) [virtual]

Turn on/off the extraction of non-manifold edges.

virtual void vtkFeatureEdges::NonManifoldEdgesOn ( ) [virtual]

Turn on/off the extraction of non-manifold edges.

virtual void vtkFeatureEdges::NonManifoldEdgesOff ( ) [virtual]

Turn on/off the extraction of non-manifold edges.

virtual void vtkFeatureEdges::SetManifoldEdges ( int ) [virtual]

Turn on/off the extraction of manifold edges.

virtual int vtkFeatureEdges::GetManifoldEdges ( ) [virtual]

Turn on/off the extraction of manifold edges.

virtual void vtkFeatureEdges::ManifoldEdgesOn ( ) [virtual]

Turn on/off the extraction of manifold edges.

virtual void vtkFeatureEdges::ManifoldEdgesOff ( ) [virtual]

Turn on/off the extraction of manifold edges.

virtual void vtkFeatureEdges::SetColoring ( int ) [virtual]

Turn on/off the coloring of edges by type.

virtual int vtkFeatureEdges::GetColoring ( ) [virtual]

Turn on/off the coloring of edges by type.

virtual void vtkFeatureEdges::ColoringOn ( ) [virtual]

Turn on/off the coloring of edges by type.

virtual void vtkFeatureEdges::ColoringOff ( ) [virtual]

Turn on/off the coloring of edges by type.

void vtkFeatureEdges::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkFeatureEdges::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkFeatureEdges::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

unsigned long vtkFeatureEdges::GetMTime ( ) [virtual]

Return MTime also considering the locator.

Reimplemented from vtkObject.

void vtkFeatureEdges::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkFeatureEdges::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

float vtkFeatureEdges::FeatureAngle [protected]

Definition at line 132 of file vtkFeatureEdges.h.

int vtkFeatureEdges::BoundaryEdges [protected]

Definition at line 133 of file vtkFeatureEdges.h.

int vtkFeatureEdges::FeatureEdges [protected]

Definition at line 134 of file vtkFeatureEdges.h.

int vtkFeatureEdges::NonManifoldEdges [protected]

Definition at line 135 of file vtkFeatureEdges.h.

int vtkFeatureEdges::ManifoldEdges [protected]

Definition at line 136 of file vtkFeatureEdges.h.

int vtkFeatureEdges::Coloring [protected]

Definition at line 137 of file vtkFeatureEdges.h.

vtkPointLocator* vtkFeatureEdges::Locator [protected]

Definition at line 138 of file vtkFeatureEdges.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkFeatureEdges.h
Generated on Mon Mar 25 01:17:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldData Class Reference

represent and manipulate fields of data. More...

#include <vtkFieldData.h>

Inheritance diagram for vtkFieldData:

[legend]
Collaboration diagram for vtkFieldData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFieldData, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
vtkFieldData * | MakeObject ()
void | AllocateArrays (int num)
void | SetNumberOfArrays (int num)
int | GetNumberOfArrays ()
int | AddArray (vtkDataArray *array)
vtkDataArray * | GetArray (int i)
vtkDataArray * | GetArray (const char *arrayName, int &index)
vtkDataArray * | GetArray (const char *arrayName)
virtual void | PassData (vtkFieldData *fd)
virtual void | CopyAllOn ()
virtual void | CopyAllOff ()
virtual void | DeepCopy (vtkFieldData *da)
virtual void | ShallowCopy (vtkFieldData *da)
void | Squeeze ()
void | Reset ()
virtual unsigned long | GetActualMemorySize ()
unsigned long int | GetMTime ()
void | GetField (vtkIdList *ptId, vtkFieldData *f)
int | GetArrayContainingComponent (int i, int &arrayComp)
int | GetNumberOfComponents ()
vtkIdType GetNumberOfTuples ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | GetTuple (const vtkIdType i, float *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
virtual void | RemoveArray (const char *name)
const char * | GetArrayName (int i)
void | CopyFieldOn (const char *name)
void | CopyFieldOff (const char *name)

Static Public Methods

vtkFieldData * | New ()

Protected Methods

vtkFieldData ()
~vtkFieldData ()
void | SetArray (int i, vtkDataArray *array)
virtual void | RemoveArray (int index)
virtual void | InitializeFields ()
void | CopyFieldOnOff (const char *name, int onOff)
void | ClearFieldFlags ()
int | FindFlag (const char *field)
int | GetFlag (const char *field)
void | CopyFlags (const vtkFieldData *source)

Protected Attributes

int | NumberOfArrays
int | NumberOfActiveArrays
vtkDataArray ** Data
int | TupleSize
float * | Tuple
CopyFieldFlag * CopyFieldFlags
int | NumberOfFieldFlags
int | DoCopyAllOn
int | DoCopyAllOff

Detailed Description

represent and manipulate fields of data.

Date:
2002/01/22 15:25:22
Revision:
1.41

vtkFieldData represents and manipulates fields of data. The model of a field is a m x n matrix of data values, where m is the number of tuples, and n is the number of components. (A tuple is a row of n components in the matrix.) The field is assumed to be composed of a set of one or more data arrays, where the data in the arrays are of different types (e.g., int, float, char, etc.), and there may be variable numbers of components in each array. Note that each data array is assumed to be "m" in length (i.e., number of tuples), which typically corresponds to the number of points or cells in a dataset. Also, each data array must have a character-string name. (This is used to manipulate data.)

There are two ways of manipulating and interfacing to fields. You can do it generically by manipulating components/tuples via a float-type data exchange, or you can do it by grabbing the arrays and manipulating them directly. The former is simpler but performs type conversion, which is bad if your data has non-castable types like (void) pointers, or you lose information as a result of the cast. The, more efficient method means managing each array in the field. Using this method you can create faster, more efficient algorithms that do not lose information.

See also:
vtkDataArray vtkAttribueData vtkPointData vtkCellData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Geveci, Berk (45%)
  • Schroeder, Will (31%)
  • Martin, Ken (5%)
Tests:
vtkFieldData (Tests)

Definition at line 63 of file vtkFieldData.h.

Constructor & Destructor Documentation

vtkFieldData::vtkFieldData ( ) [protected]

vtkFieldData::~vtkFieldData ( ) [protected]

Member Function Documentation

vtkFieldData* vtkFieldData::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkCellData, vtkDataSetAttributes, and vtkPointData.

vtkFieldData::vtkTypeRevisionMacro | ( | vtkFieldData | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkCellData, vtkDataSetAttributes, and vtkPointData.

void vtkFieldData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkCellData, vtkDataSetAttributes, and vtkPointData.

virtual void vtkFieldData::Initialize ( ) [virtual]

Release all data but do not delete object. Also, clear the copy flags.

Reimplemented in vtkDataSetAttributes.

int vtkFieldData::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) |

Allocate data for each array. Note that ext is no longer used.

vtkFieldData* vtkFieldData::MakeObject ( )

Virtual constructor creates a field with the same number of data arrays and types of data arrays, but the arrays contain nothing.

void vtkFieldData::AllocateArrays ( int num )

AllocateOfArrays actually sets the number of vtkDataArray pointers in the vtkFieldData object, not the number of used pointers (arrays). Adding more arrays will cause the object to dynamically adjust the number of pointers if it needs to extend. Although AllocateArrays can be used if the number of arrays which will be added is known, it can be omitted with a small computation cost.

void vtkFieldData::SetNumberOfArrays ( int num ) [inline]

Definition at line 91 of file vtkFieldData.h.

int vtkFieldData::GetNumberOfArrays ( )

Get the number of arrays of data available. This does not include NULL array pointers therefore after fd->AllocateArray(n); nArrays = GetNumberOfArrays() nArrays is not necessarily equal to n.

int vtkFieldData::AddArray ( vtkDataArray * array )

Add an array to the array list. If an array with the same name already exists - then the added array will replace it.

virtual void vtkFieldData::RemoveArray ( const char * name ) [inline, virtual]

Remove an array (with the given name) from the list of arrays.

Reimplemented in vtkDataSetAttributes.

Definition at line 110 of file vtkFieldData.h.

vtkDataArray* vtkFieldData::GetArray ( int i )

Return the ith array in the field. A NULL is returned if the index i is out of range.

vtkDataArray* vtkFieldData::GetArray | ( | const char * | arrayName,
 |  | int & | index
 | ) |

Return the array with the name given. Returns NULL is array not found. Also returns index of array if found, -1 otherwise

vtkDataArray* vtkFieldData::GetArray ( const char * arrayName )

const char* vtkFieldData::GetArrayName ( int i ) [inline]

Get the name of ith array. Note that this is equivalent to: GetArray(i)->GetName() if ith array pointer is not NULL

Definition at line 132 of file vtkFieldData.h.

virtual void vtkFieldData::PassData ( vtkFieldData * fd ) [virtual]

Pass entire arrays of input data through to output. Obey the "copy" flags.

Reimplemented in vtkDataSetAttributes.

void vtkFieldData::CopyFieldOn ( const char * name ) [inline]

Turn on/off the copying of the field specified by name. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Definition at line 156 of file vtkFieldData.h.

void vtkFieldData::CopyFieldOff ( const char * name ) [inline]

Turn on/off the copying of the field specified by name. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Definition at line 157 of file vtkFieldData.h.

virtual void vtkFieldData::CopyAllOn ( ) [virtual]

Turn on copying of all data. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Reimplemented in vtkDataSetAttributes.

virtual void vtkFieldData::CopyAllOff ( ) [virtual]

Turn off copying of all data. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

Reimplemented in vtkDataSetAttributes.

virtual void vtkFieldData::DeepCopy ( vtkFieldData * pd ) [virtual]

Copy a field by creating new data arrays (i.e., duplicate storage).

Reimplemented in vtkDataSetAttributes.

virtual void vtkFieldData::ShallowCopy ( vtkFieldData * pd ) [virtual]

Copy a field by reference counting the data arrays.

Reimplemented in vtkDataSetAttributes.

void vtkFieldData::Squeeze ( )

Squeezes each data array in the field (Squeeze() reclaims unused memory.)

void vtkFieldData::Reset ( )

Resets each data array in the field (Reset() does not release memory but it makes the arrays look like they are empty.)

virtual unsigned long vtkFieldData::GetActualMemorySize ( ) [virtual]

Return the memory in kilobytes consumed by this field data. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object.

unsigned long int vtkFieldData::GetMTime ( ) [virtual]

Check object's components for modified times.

Reimplemented from vtkObject.

void vtkFieldData::GetField | ( | vtkIdList * | ptId,
 |  | vtkFieldData * | f
 | ) |

Get a field from a list of ids. Supplied field f should have same types and number of data arrays as this one (i.e., like MakeObject() returns). This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

int vtkFieldData::GetArrayContainingComponent | ( | int | i,
 |  | int & | arrayComp
 | ) |

Return the array containing the ith component of the field. The return value is an integer number n 0<=n<this->NumberOfArrays. Also, an integer value is returned indicating the component in the array is returned. Method returns -1 if specified component is not in the field. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

int vtkFieldData::GetNumberOfComponents ( )

Get the number of components in the field. This is determined by adding up the components in each non-NULL array. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

vtkIdType vtkFieldData::GetNumberOfTuples ( )

Get the number of tuples in the field. Note: some fields have arrays with different numbers of tuples; this method returns the number of tuples in the first array. Mixed-length arrays may have to be treated specially. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::SetNumberOfTuples ( const vtkIdType number )

Set the number of tuples for each data array in the field. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

float* vtkFieldData::GetTuple ( const vtkIdType i )

Return a tuple consisting of a concatenation of all data from all the different arrays. Note that everything is converted to and from float values. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) |

Copy the ith tuple value into a user provided tuple array. Make sure that you've allocated enough space for the copy. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) |

Set the tuple value at the ith location. Set operations mean that no range checking is performed, so they're faster. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) |

Insert the tuple value at the ith location. Range checking is performed and memory allocates as necessary. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

vtkIdType vtkFieldData::InsertNextTuple ( const float * tuple )

Insert the tuple value at the end of the tuple matrix. Range checking is performed and memory is allocated as necessary. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

float vtkFieldData::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) |

Get the component value at the ith tuple (or row) and jth component (or column). This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) |

Set the component value at the ith tuple (or row) and jth component (or column). Range checking is not performed, so set the object up properly before invoking. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) |

Insert the component value at the ith tuple (or row) and jth component (or column). Range checking is performed and memory allocated as necessary o hold data. This method should not be used if the instance is from a subclass of vtkFieldData (vtkPointData or vtkCellData). This is because in those cases, the attribute data is stored with the other fields and will cause the method to behave in an unexpected way.

void vtkFieldData::SetArray | ( | int | i,
 |  | vtkDataArray * | array
 | ) | [protected]

Set an array to define the field.

virtual void vtkFieldData::RemoveArray ( int index ) [protected, virtual]

Reimplemented in vtkDataSetAttributes.

virtual void vtkFieldData::InitializeFields ( ) [protected, virtual]

Release all data but do not delete object.

Reimplemented in vtkDataSetAttributes.

void vtkFieldData::CopyFieldOnOff | ( | const char * | name,
 |  | int | onOff
 | ) | [protected]

void vtkFieldData::ClearFieldFlags ( ) [protected]

int vtkFieldData::FindFlag ( const char * field ) [protected]

int vtkFieldData::GetFlag ( const char * field ) [protected]

void vtkFieldData::CopyFlags ( const vtkFieldData * source ) [protected]

Member Data Documentation

int vtkFieldData::NumberOfArrays [protected]

Definition at line 309 of file vtkFieldData.h.

int vtkFieldData::NumberOfActiveArrays [protected]

Definition at line 310 of file vtkFieldData.h.

vtkDataArray** vtkFieldData::Data [protected]

Definition at line 311 of file vtkFieldData.h.

int vtkFieldData::TupleSize [protected]

Definition at line 313 of file vtkFieldData.h.

float* vtkFieldData::Tuple [protected]

Definition at line 314 of file vtkFieldData.h.

CopyFieldFlag* vtkFieldData::CopyFieldFlags [protected]

Definition at line 332 of file vtkFieldData.h.

int vtkFieldData::NumberOfFieldFlags [protected]

Definition at line 333 of file vtkFieldData.h.

int vtkFieldData::DoCopyAllOn [protected]

Definition at line 339 of file vtkFieldData.h.

int vtkFieldData::DoCopyAllOff [protected]

Definition at line 340 of file vtkFieldData.h.

The documentation for this class was generated from the following file:
  • Common/vtkFieldData.h
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldData::BasicIterator Class Reference

#include <vtkFieldData.h>

Inheritance diagram for vtkFieldData::BasicIterator:

[legend]
Collaboration diagram for vtkFieldData::BasicIterator:

[legend]
List of all members.

Public Methods

BasicIterator ()
BasicIterator (const BasicIterator &source)
BasicIterator (const int *list, unsigned int listSize)
BasicIterator & | operator= (const BasicIterator &source)
virtual | ~BasicIterator ()
int | GetListSize () const
int | GetCurrentIndex ()
int | BeginIndex ()
int | End () const
int | NextIndex ()

Protected Attributes

int * | List
int | ListSize
int | Position

Constructor & Destructor Documentation

vtkFieldData::BasicIterator::BasicIterator ( )

vtkFieldData::BasicIterator::BasicIterator ( const BasicIterator & source )

vtkFieldData::BasicIterator::BasicIterator | ( | const int * | list,
 |  | unsigned int | listSize
 | ) |

virtual vtkFieldData::BasicIterator::~BasicIterator ( ) [virtual]

Member Function Documentation

BasicIterator& vtkFieldData::BasicIterator::operator= ( const BasicIterator & source )

int vtkFieldData::BasicIterator::GetListSize ( ) const [inline]

Definition at line 358 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::GetCurrentIndex ( ) [inline]

Definition at line 362 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::BeginIndex ( ) [inline]

Definition at line 366 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::End ( ) const [inline]

Definition at line 371 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::NextIndex ( ) [inline]

Definition at line 375 of file vtkFieldData.h.

Member Data Documentation

int* vtkFieldData::BasicIterator::List [protected]

Definition at line 383 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::ListSize [protected]

Definition at line 384 of file vtkFieldData.h.

int vtkFieldData::BasicIterator::Position [protected]

Definition at line 385 of file vtkFieldData.h.

The documentation for this class was generated from the following file:
  • Common/vtkFieldData.h
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldData::CopyFieldFlag Struct Reference

#include <vtkFieldData.h>

Collaboration diagram for vtkFieldData::CopyFieldFlag:

[legend]
List of all members.

Public Attributes

char * | ArrayName
int | IsCopied

Member Data Documentation

char* vtkFieldData::CopyFieldFlag::ArrayName

Definition at line 328 of file vtkFieldData.h.

int vtkFieldData::CopyFieldFlag::IsCopied

Definition at line 329 of file vtkFieldData.h.

The documentation for this struct was generated from the following file:
  • Common/vtkFieldData.h
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldData::Iterator Class Reference

#include <vtkFieldData.h>

Inheritance diagram for vtkFieldData::Iterator:

[legend]
Collaboration diagram for vtkFieldData::Iterator:

[legend]
List of all members.

Public Methods

Iterator (const Iterator &source)
Iterator & | operator= (const Iterator &source)
virtual | ~Iterator ()
Iterator (vtkFieldData *dsa, const int *list=0, unsigned int listSize=0)
vtkDataArray * Begin ()
vtkDataArray * Next ()
void | DetachFieldData ()

Protected Attributes

vtkFieldData * Fields
int | Detached

Constructor & Destructor Documentation

vtkFieldData::Iterator::Iterator ( const Iterator & source )

virtual vtkFieldData::Iterator::~Iterator ( ) [virtual]

vtkFieldData::Iterator::Iterator | ( | vtkFieldData * | dsa,
 |  | const int * | list = 0,
 |  | unsigned int | listSize = 0
 | ) |

Member Function Documentation

Iterator& vtkFieldData::Iterator::operator= ( const Iterator & source )

vtkDataArray* vtkFieldData::Iterator::Begin ( ) [inline]

Definition at line 398 of file vtkFieldData.h.

vtkDataArray* vtkFieldData::Iterator::Next ( ) [inline]

Definition at line 404 of file vtkFieldData.h.

void vtkFieldData::Iterator::DetachFieldData ( )

Member Data Documentation

vtkFieldData* vtkFieldData::Iterator::Fields [protected]

Definition at line 414 of file vtkFieldData.h.

int vtkFieldData::Iterator::Detached [protected]

Definition at line 415 of file vtkFieldData.h.

The documentation for this class was generated from the following file:
  • Common/vtkFieldData.h
Generated on Mon Mar 25 01:17:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFieldDataToAttributeDataFilter Class Reference

map field data to dataset attribute data. More...

#include <vtkFieldDataToAttributeDataFilter.h>

Inheritance diagram for vtkFieldDataToAttributeDataFilter:

[legend]
Collaboration diagram for vtkFieldDataToAttributeDataFilter:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkFieldDataToAttributeDataFilter, vtkDataSetToDataSetFilter)
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | SetInputField (int)
virtual int | GetInputField ()
void | SetInputFieldToDataObjectField ()
void | SetInputFieldToPointDataField ()
void | SetInputFieldToCellDataField ()
virtual void | SetOutputAttributeData (int)
virtual int | GetOutputAttributeData ()
void | SetOutputAttributeDataToCellData ()
void | SetOutputAttributeDataToPointData ()
void | SetScalarComponent (int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetScalarComponent (int comp, const char *arrayName, int arrayComp)
const char * | GetScalarComponentArrayName (int comp)
int | GetScalarComponentArrayComponent (int comp)
int | GetScalarComponentMinRange (int comp)
int | GetScalarComponentMaxRange (int comp)
int | GetScalarComponentNormalizeFlag (int comp)
void | SetVectorComponent (int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetVectorComponent (int comp, const char *arrayName, int arrayComp)
const char * | GetVectorComponentArrayName (int comp)
int | GetVectorComponentArrayComponent (int comp)
int | GetVectorComponentMinRange (int comp)
int | GetVectorComponentMaxRange (int comp)
int | GetVectorComponentNormalizeFlag (int comp)
void | SetNormalComponent (int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetNormalComponent (int comp, const char *arrayName, int arrayComp)
const char * | GetNormalComponentArrayName (int comp)
int | GetNormalComponentArrayComponent (int comp)
int | GetNormalComponentMinRange (int comp)
int | GetNormalComponentMaxRange (int comp)
int | GetNormalComponentNormalizeFlag (int comp)
void | SetTensorComponent (int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetTensorComponent (int comp, const char *arrayName, int arrayComp)
const char * | GetTensorComponentArrayName (int comp)
int | GetTensorComponentArrayComponent (int comp)
int | GetTensorComponentMinRange (int comp)
int | GetTensorComponentMaxRange (int comp)
int | GetTensorComponentNormalizeFlag (int comp)
void | SetTCoordComponent (int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
void | SetTCoordComponent (int comp, const char *arrayName, int arrayComp)
const char * | GetTCoordComponentArrayName (int comp)
int | GetTCoordComponentArrayComponent (int comp)
int | GetTCoordComponentMinRange (int comp)
int | GetTCoordComponentMaxRange (int comp)
int | GetTCoordComponentNormalizeFlag (int comp)
virtual void | SetDefaultNormalize (int)
virtual int | GetDefaultNormalize ()
virtual void | DefaultNormalizeOn ()
virtual void | DefaultNormalizeOff ()

Static Public Methods

vtkFieldDataToAttributeDataFilter * | New ()
int | GetComponentsType (int numComp, vtkDataArray **arrays)
vtkDataArray * | GetFieldArray (vtkFieldData *fd, char *name, int comp)
void | SetArrayName (vtkObject *self, char *&name, const char *newName)
int | UpdateComponentRange (vtkDataArray *da, vtkIdType compRange[2])
int | ConstructArray (vtkDataArray *da, int comp, vtkDataArray *frray, int fieldComp, vtkIdType min, vtkIdType max, int normalize)

Protected Methods

vtkFieldDataToAttributeDataFilter ()
~vtkFieldDataToAttributeDataFilter ()
void | Execute ()
void | ConstructScalars (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[4][2], char *arrays[4], int arrayComponents[4], int normalize[4], int numComp)
void | ConstructVectors (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3])
void | ConstructGhostLevels (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[2], char *array, int arrayComponent, int normalize)
void | ConstructNormals (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3])
void | ConstructTCoords (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3], int numComp)
void | ConstructTensors (int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[9][2], char *arrays[9], int arrayComponents[9], int normalize[9])
void | ConstructFieldData (int num, vtkDataSetAttributes *attr)

Protected Attributes

int | InputField
int | OutputAttributeData
int | NumberOfScalarComponents
char * | ScalarArrays [4]
int | ScalarArrayComponents [4]
vtkIdType | ScalarComponentRange [4][2]
int | ScalarNormalize [4]
char * | VectorArrays [3]
int | VectorArrayComponents [3]
vtkIdType | VectorComponentRange [3][2]
int | VectorNormalize [3]
char * | GhostLevelArray
int | GhostLevelArrayComponent
vtkIdType | GhostLevelComponentRange [2]
int | GhostLevelNormalize
char * | NormalArrays [3]
int | NormalArrayComponents [3]
vtkIdType | NormalComponentRange [3][2]
int | NormalNormalize [3]
char * | TensorArrays [9]
int | TensorArrayComponents [9]
vtkIdType | TensorComponentRange [9][2]
int | TensorNormalize [9]
int | NumberOfTCoordComponents
char * | TCoordArrays [3]
int | TCoordArrayComponents [3]
vtkIdType | TCoordComponentRange [3][2]
int | TCoordNormalize [3]
int | DefaultNormalize

Detailed Description

map field data to dataset attribute data.

Date:
2002/01/22 15:29:21
Revision:
1.28

vtkFieldDataToAttributeDataFilter is a class that maps field data into dataset attributes. The input to this filter is any type of dataset and the output is the same dataset (geometry/topology) with new attribute data (attribute data is passed through if not replaced during filter execution).

To use this filter you must specify which field data from the input dataset to use. There are three possibilities: the cell field data, the point field data, or the field data associated with the data object superclass. Then you specify which attribute data to create: either cell attribute data or point attribute data. Finally, you must define how to construct the various attribute data types (e.g., scalars, vectors, normals, etc.) from the arrays and the components of the arrays from the field data. This is done by associating components in the input field with components making up the attribute data. For example, you would specify a scalar with three components (RGB) by assigning components from the field for the R, then G, then B values of the scalars. You may also have to specify component ranges (for each R-G-B) to make sure that the number of R, G, and B values is the same. Also, you may want to normalize the components which helps distribute the data uniformly.

This filter is often used in conjunction with vtkDataObjectToDataSetFilter. vtkDataObjectToDataSetFilter filter generates dataset topology and geometry and passes its input field data along to its output. Then this filter is used to generate the attribute data to go along with the dataset.

Warning:
Make sure that the data you extract is consistent. That is, if you have N points, extract N point attributes (scalars, vectors, etc.).
See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Henderson, Amy (10%)
  • Geveci, Berk (8%)
  • Lorensen, Bill (5%)
Tests:
vtkFieldDataToAttributeDataFilter (Tests)

Definition at line 82 of file vtkFieldDataToAttributeDataFilter.h.

Constructor & Destructor Documentation

vtkFieldDataToAttributeDataFilter::vtkFieldDataToAttributeDataFilter ( ) [protected]

vtkFieldDataToAttributeDataFilter::~vtkFieldDataToAttributeDataFilter ( ) [protected]

Member Function Documentation

void vtkFieldDataToAttributeDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkFieldDataToAttributeDataFilter::vtkTypeRevisionMacro | ( | vtkFieldDataToAttributeDataFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

vtkFieldDataToAttributeDataFilter* vtkFieldDataToAttributeDataFilter::New ( ) [static]

Construct object with input field set to the data object field, and the output attribute data set to generate point data.

Reimplemented from vtkDataSetSource.

virtual void vtkFieldDataToAttributeDataFilter::SetInputField ( int ) [virtual]

Specify which field data to use to generate the output attribute data. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

virtual int vtkFieldDataToAttributeDataFilter::GetInputField ( ) [virtual]

Specify which field data to use to generate the output attribute data. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

void vtkFieldDataToAttributeDataFilter::SetInputFieldToDataObjectField ( ) [inline]

Specify which field data to use to generate the output attribute data. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 99 of file vtkFieldDataToAttributeDataFilter.h.

void vtkFieldDataToAttributeDataFilter::SetInputFieldToPointDataField ( ) [inline]

Specify which field data to use to generate the output attribute data. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 101 of file vtkFieldDataToAttributeDataFilter.h.

void vtkFieldDataToAttributeDataFilter::SetInputFieldToCellDataField ( ) [inline]

Specify which field data to use to generate the output attribute data. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 103 of file vtkFieldDataToAttributeDataFilter.h.

virtual void vtkFieldDataToAttributeDataFilter::SetOutputAttributeData ( int ) [virtual]

Specify which attribute data to output: point or cell data attributes.

virtual int vtkFieldDataToAttributeDataFilter::GetOutputAttributeData ( ) [virtual]

Specify which attribute data to output: point or cell data attributes.

void vtkFieldDataToAttributeDataFilter::SetOutputAttributeDataToCellData ( ) [inline]

Specify which attribute data to output: point or cell data attributes.

Definition at line 112 of file vtkFieldDataToAttributeDataFilter.h.

void vtkFieldDataToAttributeDataFilter::SetOutputAttributeDataToPointData ( ) [inline]

Specify which attribute data to output: point or cell data attributes.

Definition at line 114 of file vtkFieldDataToAttributeDataFilter.h.

void vtkFieldDataToAttributeDataFilter::SetScalarComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetScalarComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

Definition at line 126 of file vtkFieldDataToAttributeDataFilter.h.

const char* vtkFieldDataToAttributeDataFilter::GetScalarComponentArrayName ( int comp )

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetScalarComponentArrayComponent ( int comp )

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetScalarComponentMinRange ( int comp )

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetScalarComponentMaxRange ( int comp )

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetScalarComponentNormalizeFlag ( int comp )

Define the component(s) of the field to be used for the scalar components. Note that the parameter comp must lie between (0,4). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetVectorComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetVectorComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

Definition at line 143 of file vtkFieldDataToAttributeDataFilter.h.

const char* vtkFieldDataToAttributeDataFilter::GetVectorComponentArrayName ( int comp )

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetVectorComponentArrayComponent ( int comp )

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetVectorComponentMinRange ( int comp )

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetVectorComponentMaxRange ( int comp )

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetVectorComponentNormalizeFlag ( int comp )

Define the component(s) of the field to be used for the vector components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetNormalComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetNormalComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

Definition at line 160 of file vtkFieldDataToAttributeDataFilter.h.

const char* vtkFieldDataToAttributeDataFilter::GetNormalComponentArrayName ( int comp )

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetNormalComponentArrayComponent ( int comp )

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetNormalComponentMinRange ( int comp )

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetNormalComponentMaxRange ( int comp )

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetNormalComponentNormalizeFlag ( int comp )

Define the component(s) of the field to be used for the normal components. Note that the parameter comp must lie between (0,3). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetTensorComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetTensorComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

Definition at line 177 of file vtkFieldDataToAttributeDataFilter.h.

const char* vtkFieldDataToAttributeDataFilter::GetTensorComponentArrayName ( int comp )

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTensorComponentArrayComponent ( int comp )

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTensorComponentMinRange ( int comp )

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTensorComponentMaxRange ( int comp )

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTensorComponentNormalizeFlag ( int comp )

Define the components of the field to be used for the tensor components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetTCoordComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp,
 |  | int | min,
 |  | int | max,
 |  | int | normalize
 | ) |

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

void vtkFieldDataToAttributeDataFilter::SetTCoordComponent | ( | int | comp,
 |  | const char * | arrayName,
 |  | int | arrayComp
 | ) | [inline]

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

Definition at line 194 of file vtkFieldDataToAttributeDataFilter.h.

const char* vtkFieldDataToAttributeDataFilter::GetTCoordComponentArrayName ( int comp )

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTCoordComponentArrayComponent ( int comp )

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTCoordComponentMinRange ( int comp )

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTCoordComponentMaxRange ( int comp )

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

int vtkFieldDataToAttributeDataFilter::GetTCoordComponentNormalizeFlag ( int comp )

Define the components of the field to be used for the cell texture coord components. Note that the parameter comp must lie between (0,9). To define the field component to use you specify an array name and the component in that array. The (min,max) values are the range of data in the component you wish to extract.

virtual void vtkFieldDataToAttributeDataFilter::SetDefaultNormalize ( int ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetScalarComponents).

virtual int vtkFieldDataToAttributeDataFilter::GetDefaultNormalize ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetScalarComponents).

virtual void vtkFieldDataToAttributeDataFilter::DefaultNormalizeOn ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetScalarComponents).

virtual void vtkFieldDataToAttributeDataFilter::DefaultNormalizeOff ( ) [virtual]

Set the default Normalize() flag for those methods setting a default Normalize value (e.g., SetScalarComponents).

int vtkFieldDataToAttributeDataFilter::GetComponentsType | ( | int | numComp,
 |  | vtkDataArray ** | arrays
 | ) | [static]

Given an array of names of arrays in field data, return the common type for these arrays. For example, if a vector is constructed of the three type (char,int,float), the return type is float.

int vtkFieldDataToAttributeDataFilter::ConstructArray | ( | vtkDataArray * | da,
 |  | int | comp,
 |  | vtkDataArray * | frray,
 |  | int | fieldComp,
 |  | vtkIdType | min,
 |  | vtkIdType | max,
 |  | int | normalize
 | ) | [static]

Construct a portion of a data array (the comp portion) from another data array and its component. The variables min and max control the range of the data to use from the other data array; normalize is a flag that when set will normalize the data between (0,1).

vtkDataArray* vtkFieldDataToAttributeDataFilter::GetFieldArray | ( | vtkFieldData * | fd,
 |  | char * | name,
 |  | int | comp
 | ) | [static]

Return an array of a particular name from field data and do error checking.

void vtkFieldDataToAttributeDataFilter::SetArrayName | ( | vtkObject * | self,
 |  | char *& | name,
 |  | const char * | newName
 | ) | [static]

Specify an array name for one of the components.

int vtkFieldDataToAttributeDataFilter::UpdateComponentRange | ( | vtkDataArray * | da,
 |  | vtkIdType | compRange[2]
 | ) | [static]

Update the maximum and minimum component range values. Returns a flag indicating whether the range was updated.

virtual void vtkFieldDataToAttributeDataFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

If output does not need exact extent, the I do not either.

Reimplemented from vtkDataSetToDataSetFilter.

void vtkFieldDataToAttributeDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkFieldDataToAttributeDataFilter::ConstructScalars | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[4][2],
 |  | char * | arrays[4],
 |  | int | arrayComponents[4],
 |  | int | normalize[4],
 |  | int | numComp
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructVectors | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[3][2],
 |  | char * | arrays[3],
 |  | int | arrayComponents[3],
 |  | int | normalize[3]
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructGhostLevels | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[2],
 |  | char * | array,
 |  | int | arrayComponent,
 |  | int | normalize
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructNormals | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[3][2],
 |  | char * | arrays[3],
 |  | int | arrayComponents[3],
 |  | int | normalize[3]
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructTCoords | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[3][2],
 |  | char * | arrays[3],
 |  | int | arrayComponents[3],
 |  | int | normalize[3],
 |  | int | numComp
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructTensors | ( | int | num,
 |  | vtkFieldData * | fd,
 |  | vtkDataSetAttributes * | attr,
 |  | vtkIdType | componentRange[9][2],
 |  | char * | arrays[9],
 |  | int | arrayComponents[9],
 |  | int | normalize[9]
 | ) | [protected]

void vtkFieldDataToAttributeDataFilter::ConstructFieldData | ( | int | num,
 |  | vtkDataSetAttributes * | attr
 | ) | [protected]

Member Data Documentation

int vtkFieldDataToAttributeDataFilter::InputField [protected]

Definition at line 250 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::OutputAttributeData [protected]

Definition at line 251 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::NumberOfScalarComponents [protected]

Definition at line 253 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::ScalarArrays[4] [protected]

Definition at line 254 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::ScalarArrayComponents[4] [protected]

Definition at line 255 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::ScalarComponentRange[4][2] [protected]

Definition at line 256 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::ScalarNormalize[4] [protected]

Definition at line 257 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::VectorArrays[3] [protected]

Definition at line 259 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::VectorArrayComponents[3] [protected]

Definition at line 260 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::VectorComponentRange[3][2] [protected]

Definition at line 261 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::VectorNormalize[3] [protected]

Definition at line 262 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::GhostLevelArray [protected]

Definition at line 264 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::GhostLevelArrayComponent [protected]

Definition at line 265 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::GhostLevelComponentRange[2] [protected]

Definition at line 266 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::GhostLevelNormalize [protected]

Definition at line 267 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::NormalArrays[3] [protected]

Definition at line 269 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::NormalArrayComponents[3] [protected]

Definition at line 270 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::NormalComponentRange[3][2] [protected]

Definition at line 271 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::NormalNormalize[3] [protected]

Definition at line 272 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::TensorArrays[9] [protected]

Definition at line 274 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::TensorArrayComponents[9] [protected]

Definition at line 275 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::TensorComponentRange[9][2] [protected]

Definition at line 276 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::TensorNormalize[9] [protected]

Definition at line 277 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::NumberOfTCoordComponents [protected]

Definition at line 279 of file vtkFieldDataToAttributeDataFilter.h.

char* vtkFieldDataToAttributeDataFilter::TCoordArrays[3] [protected]

Definition at line 280 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::TCoordArrayComponents[3] [protected]

Definition at line 281 of file vtkFieldDataToAttributeDataFilter.h.

vtkIdType vtkFieldDataToAttributeDataFilter::TCoordComponentRange[3][2] [protected]

Definition at line 282 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::TCoordNormalize[3] [protected]

Definition at line 283 of file vtkFieldDataToAttributeDataFilter.h.

int vtkFieldDataToAttributeDataFilter::DefaultNormalize [protected]

Definition at line 285 of file vtkFieldDataToAttributeDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkFieldDataToAttributeDataFilter.h
Generated on Mon Mar 25 01:17:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFileOutputWindow Class Reference

File Specific output window class. More...

#include <vtkFileOutputWindow.h>

Inheritance diagram for vtkFileOutputWindow:

[legend]
Collaboration diagram for vtkFileOutputWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFileOutputWindow, vtkOutputWindow)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | DisplayText (const char *)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetFlush (int)
virtual int | GetFlush ()
virtual void | FlushOn ()
virtual void | FlushOff ()
virtual void | SetAppend (int)
virtual int | GetAppend ()
virtual void | AppendOn ()
virtual void | AppendOff ()

Static Public Methods

vtkFileOutputWindow * | New ()

Protected Methods

vtkFileOutputWindow ()
virtual | ~vtkFileOutputWindow ()
void | Initialize ()

Protected Attributes

char * | FileName
ofstream * OStream
int | Flush
int | Append

Detailed Description

File Specific output window class.

Date:
2002/01/22 15:25:23
Revision:
1.10

Writes debug/warning/error output to a log file instead of the console. To use this class, instantiate it and then call SetInstance(this).

Created by:
  • Turek, Matt
Contributed by (if > 5%):
  • Turek, Matt (92%)
  • Lorensen, Bill (5%)
Tests:
vtkFileOutputWindow (Tests)

Definition at line 43 of file vtkFileOutputWindow.h.

Constructor & Destructor Documentation

vtkFileOutputWindow::vtkFileOutputWindow ( ) [protected]

virtual vtkFileOutputWindow::~vtkFileOutputWindow ( ) [protected, virtual]

Member Function Documentation

vtkFileOutputWindow::vtkTypeRevisionMacro | ( | vtkFileOutputWindow | ,
 |  | vtkOutputWindow |
 | ) |

Reimplemented from vtkOutputWindow.

Reimplemented in vtkXMLFileOutputWindow.

vtkFileOutputWindow* vtkFileOutputWindow::New ( ) [static]

This is a singleton pattern New. There will only be ONE reference to a vtkOutputWindow object per process. Clients that call this must call Delete on the object so that the reference counting will work. The single instance will be unreferenced when the program exits.

Reimplemented from vtkOutputWindow.

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkFileOutputWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactor to stream.

Reimplemented from vtkOutputWindow.

virtual void vtkFileOutputWindow::DisplayText ( const char * ) [virtual]

New lines are converted to carriage return new lines.

Reimplemented from vtkOutputWindow.

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkFileOutputWindow::SetFileName ( const char * ) [virtual]

virtual char* vtkFileOutputWindow::GetFileName ( ) [virtual]

virtual void vtkFileOutputWindow::SetFlush ( int ) [virtual]

to the log file.

virtual int vtkFileOutputWindow::GetFlush ( ) [virtual]

to the log file.

virtual void vtkFileOutputWindow::FlushOn ( ) [virtual]

to the log file.

virtual void vtkFileOutputWindow::FlushOff ( ) [virtual]

to the log file.

virtual void vtkFileOutputWindow::SetAppend ( int ) [virtual]

opened in append mode. Otherwise, if the log file exists, it will be overwritten each time the vtkFileOutputWindow is created.

virtual int vtkFileOutputWindow::GetAppend ( ) [virtual]

opened in append mode. Otherwise, if the log file exists, it will be overwritten each time the vtkFileOutputWindow is created.

virtual void vtkFileOutputWindow::AppendOn ( ) [virtual]

opened in append mode. Otherwise, if the log file exists, it will be overwritten each time the vtkFileOutputWindow is created.

virtual void vtkFileOutputWindow::AppendOff ( ) [virtual]

opened in append mode. Otherwise, if the log file exists, it will be overwritten each time the vtkFileOutputWindow is created.

void vtkFileOutputWindow::Initialize ( ) [protected]

Reimplemented in vtkXMLFileOutputWindow.

Member Data Documentation

char* vtkFileOutputWindow::FileName [protected]

Definition at line 79 of file vtkFileOutputWindow.h.

ofstream* vtkFileOutputWindow::OStream [protected]

Definition at line 80 of file vtkFileOutputWindow.h.

int vtkFileOutputWindow::Flush [protected]

Definition at line 81 of file vtkFileOutputWindow.h.

int vtkFileOutputWindow::Append [protected]

Definition at line 82 of file vtkFileOutputWindow.h.

The documentation for this class was generated from the following file:
  • Common/vtkFileOutputWindow.h
Generated on Mon Mar 25 01:17:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFiniteDifferenceGradientEstimator Class Reference

Use finite differences to estimate gradient. More...

#include <vtkFiniteDifferenceGradientEstimator.h>

Inheritance diagram for vtkFiniteDifferenceGradientEstimator:

[legend]
Collaboration diagram for vtkFiniteDifferenceGradientEstimator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFiniteDifferenceGradientEstimator, vtkEncodedGradientEstimator)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | SetSampleSpacingInVoxels (int)
virtual int | GetSampleSpacingInVoxels ()

Static Public Methods

vtkFiniteDifferenceGradientEstimator * | New ()

Public Attributes

int | SampleSpacingInVoxels

Protected Methods

vtkFiniteDifferenceGradientEstimator ()
~vtkFiniteDifferenceGradientEstimator ()
void | UpdateNormals (void)

Detailed Description

Use finite differences to estimate gradient.

Date:
2002/01/22 15:38:31
Revision:
1.18

vtkFiniteDifferenceGradientEstimator is a concrete subclass of vtkEncodedGradientEstimator that uses a central differences technique to estimate the gradient. The gradient at some sample location (x,y,z) would be estimated by:

nx = (f(x-dx,y,z) - f(x+dx,y,z)) / 2*dx; ny = (f(x,y-dy,z) - f(x,y+dy,z)) / 2*dy; nz = (f(x,y,z-dz) - f(x,y,z+dz)) / 2*dz;

This value is normalized to determine a unit direction vector and a magnitude. The normal is computed in voxel space, and dx = dy = dz = SampleSpacingInVoxels. A scaling factor is applied to convert this normal from voxel space to world coordinates.

See also:
vtkEncodedGradientEstimator
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (77%)
  • Lorensen, Bill (6%)
  • Martin, Ken (5%)
Tests:
vtkFiniteDifferenceGradientEstimator (Tests)

Definition at line 58 of file vtkFiniteDifferenceGradientEstimator.h.

Constructor & Destructor Documentation

vtkFiniteDifferenceGradientEstimator::vtkFiniteDifferenceGradientEstimator ( ) [protected]

vtkFiniteDifferenceGradientEstimator::~vtkFiniteDifferenceGradientEstimator ( ) [protected]

Member Function Documentation

vtkFiniteDifferenceGradientEstimator::vtkTypeRevisionMacro | ( | vtkFiniteDifferenceGradientEstimator | ,
 |  | vtkEncodedGradientEstimator |
 | ) |

Reimplemented from vtkEncodedGradientEstimator.

void vtkFiniteDifferenceGradientEstimator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkEncodedGradientEstimator.

vtkFiniteDifferenceGradientEstimator* vtkFiniteDifferenceGradientEstimator::New ( ) [static]

Construct a vtkFiniteDifferenceGradientEstimator with a SampleSpacingInVoxels of 1.

Reimplemented from vtkObject.

virtual void vtkFiniteDifferenceGradientEstimator::SetSampleSpacingInVoxels ( int ) [virtual]

Set/Get the spacing between samples for the finite differences method used to compute the normal. This spacing is in voxel units.

virtual int vtkFiniteDifferenceGradientEstimator::GetSampleSpacingInVoxels ( ) [virtual]

Set/Get the spacing between samples for the finite differences method used to compute the normal. This spacing is in voxel units.

void vtkFiniteDifferenceGradientEstimator::UpdateNormals ( void ) [protected, virtual]

Recompute the encoded normals and gradient magnitudes.

Reimplemented from vtkEncodedGradientEstimator.

Member Data Documentation

int vtkFiniteDifferenceGradientEstimator::SampleSpacingInVoxels

Definition at line 76 of file vtkFiniteDifferenceGradientEstimator.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkFiniteDifferenceGradientEstimator.h
Generated on Mon Mar 25 01:17:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFloatArray Class Reference

dynamic, self-adjusting floating point array. More...

#include <vtkFloatArray.h>

Inheritance diagram for vtkFloatArray:

[legend]
Collaboration diagram for vtkFloatArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFloatArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const float f)
vtkIdType | InsertNextValue (const float f)
float * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *fa)
int | GetDataType ()
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
float | GetValue (const vtkIdType id)
void | SetValue (const vtkIdType id, const float value)
void * | GetVoidPointer (const vtkIdType id)
float * | GetPointer (const vtkIdType id)
void | SetArray (float *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkFloatArray * | New ()

Protected Methods

vtkFloatArray (vtkIdType numComp=1)
~vtkFloatArray ()
float * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

float * | Array
int | SaveUserArray

Detailed Description

dynamic, self-adjusting floating point array.

Date:
2002/02/13 22:46:29
Revision:
1.69

vtkFloatArray is an array of floating point numbers. It provides methods for insertion and retrieval of floating point values, and will automatically resize itself to hold new data.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (41%)
  • Martin, Ken (31%)
  • Henderson, Amy (6%)
  • Geveci, Berk (6%)
  • Kelly, Ann (5%)
Examples:
vtkFloatArray (Examples)
Tests:
vtkFloatArray (Tests)

Definition at line 48 of file vtkFloatArray.h.

Constructor & Destructor Documentation

vtkFloatArray::vtkFloatArray ( vtkIdType numComp = 1 ) [protected]

vtkFloatArray::~vtkFloatArray ( ) [protected]

Member Function Documentation

vtkFloatArray* vtkFloatArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkFloatArray::vtkTypeRevisionMacro | ( | vtkFloatArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkFloatArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkFloatArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkFloatArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkFloatArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkFloatArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 67 of file vtkFloatArray.h.

int vtkFloatArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 72 of file vtkFloatArray.h.

void vtkFloatArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkFloatArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location.

Reimplemented from vtkDataArray.

void vtkFloatArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkFloatArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkFloatArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkFloatArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkFloatArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkFloatArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkFloatArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkFloatArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkFloatArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 107 of file vtkFloatArray.h.

virtual void vtkFloatArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

float vtkFloatArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkFloatArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkFloatArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

float vtkFloatArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 130 of file vtkFloatArray.h.

void vtkFloatArray::SetValue | ( | const vtkIdType | id,
 |  | const float | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 137 of file vtkFloatArray.h.

void vtkFloatArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 196 of file vtkFloatArray.h.

void vtkFloatArray::InsertValue | ( | const vtkIdType | id,
 |  | const float | f
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 218 of file vtkFloatArray.h.

Referenced by InsertNextValue().

vtkIdType vtkFloatArray::InsertNextValue ( const float f ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 231 of file vtkFloatArray.h.

float * vtkFloatArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 203 of file vtkFloatArray.h.

void* vtkFloatArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 161 of file vtkFloatArray.h.

float* vtkFloatArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 163 of file vtkFloatArray.h.

void vtkFloatArray::DeepCopy ( vtkDataArray * fa ) [virtual]

Deep copy of another float array.

Reimplemented from vtkDataArray.

void vtkFloatArray::SetArray | ( | float * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkFloatArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 178 of file vtkFloatArray.h.

float* vtkFloatArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

float* vtkFloatArray::Array [protected]

Definition at line 187 of file vtkFloatArray.h.

int vtkFloatArray::SaveUserArray [protected]

Definition at line 190 of file vtkFloatArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkFloatArray.h
Generated on Mon Mar 25 01:17:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFollower Class Reference

a subclass of actor that always faces the camera. More...

#include <vtkFollower.h>

Inheritance diagram for vtkFollower:

[legend]
Collaboration diagram for vtkFollower:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFollower, vtkActor)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ShallowCopy (vtkProp *prop)
virtual void | SetCamera (vtkCamera *)
virtual vtkCamera * | GetCamera ()
virtual int | RenderOpaqueGeometry (vtkViewport *viewport)
virtual int | RenderTranslucentGeometry (vtkViewport *viewport)
virtual void | Render (vtkRenderer *ren)
virtual void | GetMatrix (vtkMatrix4x4 *m)
virtual void | GetMatrix (double m[16])
virtual vtkMatrix4x4 * | GetMatrix ()

Static Public Methods

vtkFollower * | New ()

Protected Methods

vtkFollower ()
~vtkFollower ()

Protected Attributes

vtkCamera * Camera
vtkActor * Device

Detailed Description

a subclass of actor that always faces the camera.

Date:
2002/01/22 15:38:31
Revision:
1.49

vtkFollower is a subclass of vtkActor that always follows its specified camera. More specifically it will not change its position or scale, but it will continually update its orientation so that it is right side up and facing the camera. This is typically used for text labels in a scene. All of the adjustments that can be made to an actor also will take effect with a follower. So, if you change the orientation of the follower by 90 degrees, then it will follow the camera, but be off by 90 degrees.

See also:
vtkActor vtkCamera
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (79%)
  • Schroeder, Will (6%)
Examples:
vtkFollower (Examples)
Tests:
vtkFollower (Tests)

Definition at line 54 of file vtkFollower.h.

Constructor & Destructor Documentation

vtkFollower::vtkFollower ( ) [protected]

vtkFollower::~vtkFollower ( ) [protected]

Member Function Documentation

vtkFollower::vtkTypeRevisionMacro | ( | vtkFollower | ,
 |  | vtkActor |
 | ) |

Reimplemented from vtkActor.

void vtkFollower::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor.

vtkFollower* vtkFollower::New ( ) [static]

Creates a follower with no camera set

Reimplemented from vtkActor.

virtual void vtkFollower::SetCamera ( vtkCamera * ) [virtual]

Set/Get the camera to follow. If this is not set, then the follower won't know who to follow.

virtual vtkCamera* vtkFollower::GetCamera ( ) [virtual]

Set/Get the camera to follow. If this is not set, then the follower won't know who to follow.

virtual int vtkFollower::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

This causes the actor to be rendered. It in turn will render the actor's property, texture map and then mapper. If a property hasn't been assigned, then the actor will create one automatically.

Reimplemented from vtkActor.

virtual int vtkFollower::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

This causes the actor to be rendered. It in turn will render the actor's property, texture map and then mapper. If a property hasn't been assigned, then the actor will create one automatically.

Reimplemented from vtkActor.

virtual void vtkFollower::Render ( vtkRenderer * ren ) [virtual]

This causes the actor to be rendered. It in turn will render the actor's property, texture map and then mapper. If a property hasn't been assigned, then the actor will create one automatically.

virtual void vtkFollower::GetMatrix ( vtkMatrix4x4 * m ) [virtual]

Copy the follower's composite 4x4 matrix into the matrix provided.

Reimplemented from vtkProp3D.

virtual void vtkFollower::GetMatrix ( double m[16] ) [inline, virtual]

Copy the follower's composite 4x4 matrix into the matrix provided.

Reimplemented from vtkProp3D.

Definition at line 82 of file vtkFollower.h.

virtual vtkMatrix4x4* vtkFollower::GetMatrix ( ) [inline, virtual]

Copy the follower's composite 4x4 matrix into the matrix provided.

Reimplemented from vtkProp3D.

Definition at line 84 of file vtkFollower.h.

void vtkFollower::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of a follower. Overloads the virtual vtkProp method.

Reimplemented from vtkActor.

Member Data Documentation

vtkCamera* vtkFollower::Camera [protected]

Definition at line 95 of file vtkFollower.h.

vtkActor* vtkFollower::Device [protected]

Definition at line 96 of file vtkFollower.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkFollower.h
Generated on Mon Mar 25 01:17:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFrustumCoverageCuller Class Reference

cull props based on frustum coverage. More...

#include <vtkFrustumCoverageCuller.h>

Inheritance diagram for vtkFrustumCoverageCuller:

[legend]
Collaboration diagram for vtkFrustumCoverageCuller:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFrustumCoverageCuller, vtkCuller)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMinimumCoverage (float)
virtual float | GetMinimumCoverage ()
virtual void | SetMaximumCoverage (float)
virtual float | GetMaximumCoverage ()
virtual void | SetSortingStyle (int)
virtual int | GetSortingStyle ()
void | SetSortingStyleToNone ()
void | SetSortingStyleToBackToFront ()
void | SetSortingStyleToFrontToBack ()
const char * | GetSortingStyleAsString (void)
float | Cull (vtkRenderer *ren, vtkProp **propList, int &listLength, int &initialized)

Static Public Methods

vtkFrustumCoverageCuller * | New ()

Protected Methods

vtkFrustumCoverageCuller ()
~vtkFrustumCoverageCuller ()

Protected Attributes

float | MinimumCoverage
float | MaximumCoverage
int | SortingStyle

Detailed Description

cull props based on frustum coverage.

Date:
2002/01/22 15:38:32
Revision:
1.24

vtkFrustumCoverageCuller will cull props based on the coverage in the view frustum. The coverage is computed by enclosing the prop in a bounding sphere, projecting that to the viewing coordinate system, then taking a slice through the view frustum at the center of the sphere. This results in a circle on the plane slice through the view frustum. This circle is enclosed in a squared, and the fraction of the plane slice that this square covers is the coverage. This is a number between 0 and 1. If the number is less than the MinumumCoverage, the allocated render time for that prop is set to zero. If it is greater than the MaximumCoverage, the allocated render time is set to 1.0. In between, a linear ramp is used to convert coverage into allocated render time.

See also:
vtkCuller
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (64%)
  • Biddiscombe, John (17%)
  • Martin, Ken (12%)

Definition at line 58 of file vtkFrustumCoverageCuller.h.

Constructor & Destructor Documentation

vtkFrustumCoverageCuller::vtkFrustumCoverageCuller ( ) [protected]

vtkFrustumCoverageCuller::~vtkFrustumCoverageCuller ( ) [inline, protected]

Definition at line 107 of file vtkFrustumCoverageCuller.h.

Member Function Documentation

vtkFrustumCoverageCuller* vtkFrustumCoverageCuller::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkFrustumCoverageCuller::vtkTypeRevisionMacro | ( | vtkFrustumCoverageCuller | ,
 |  | vtkCuller |
 | ) |

Reimplemented from vtkCuller.

void vtkFrustumCoverageCuller::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

virtual void vtkFrustumCoverageCuller::SetMinimumCoverage ( float ) [virtual]

Set/Get the minimum coverage - props with less coverage than this are given no time to render (they are culled)

virtual float vtkFrustumCoverageCuller::GetMinimumCoverage ( ) [virtual]

Set/Get the minimum coverage - props with less coverage than this are given no time to render (they are culled)

virtual void vtkFrustumCoverageCuller::SetMaximumCoverage ( float ) [virtual]

Set/Get the maximum coverage - props with more coverage than this are given an allocated render time of 1.0 (the maximum)

virtual float vtkFrustumCoverageCuller::GetMaximumCoverage ( ) [virtual]

Set/Get the maximum coverage - props with more coverage than this are given an allocated render time of 1.0 (the maximum)

virtual void vtkFrustumCoverageCuller::SetSortingStyle ( int ) [virtual]

Set the sorting style - none, front-to-back or back-to-front The default is none

virtual int vtkFrustumCoverageCuller::GetSortingStyle ( ) [virtual]

Set the sorting style - none, front-to-back or back-to-front The default is none

void vtkFrustumCoverageCuller::SetSortingStyleToNone ( ) [inline]

Set the sorting style - none, front-to-back or back-to-front The default is none

Definition at line 85 of file vtkFrustumCoverageCuller.h.

void vtkFrustumCoverageCuller::SetSortingStyleToBackToFront ( ) [inline]

Set the sorting style - none, front-to-back or back-to-front The default is none

Definition at line 87 of file vtkFrustumCoverageCuller.h.

void vtkFrustumCoverageCuller::SetSortingStyleToFrontToBack ( ) [inline]

Set the sorting style - none, front-to-back or back-to-front The default is none

Definition at line 89 of file vtkFrustumCoverageCuller.h.

const char* vtkFrustumCoverageCuller::GetSortingStyleAsString ( void )

Set the sorting style - none, front-to-back or back-to-front The default is none

float vtkFrustumCoverageCuller::Cull | ( | vtkRenderer * | ren,
 |  | vtkProp ** | propList,
 |  | int & | listLength,
 |  | int & | initialized
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS Perform the cull operation This method should only be called by vtkRenderer as part of the render process

Reimplemented from vtkCuller.

Member Data Documentation

float vtkFrustumCoverageCuller::MinimumCoverage [protected]

Definition at line 109 of file vtkFrustumCoverageCuller.h.

float vtkFrustumCoverageCuller::MaximumCoverage [protected]

Definition at line 110 of file vtkFrustumCoverageCuller.h.

int vtkFrustumCoverageCuller::SortingStyle [protected]

Definition at line 111 of file vtkFrustumCoverageCuller.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkFrustumCoverageCuller.h
Generated on Mon Mar 25 01:17:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFunctionParser Class Reference

Parse and evaluate a mathematical expression. More...

#include <vtkFunctionParser.h>

Inheritance diagram for vtkFunctionParser:

[legend]
Collaboration diagram for vtkFunctionParser:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFunctionParser, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
int | IsScalarResult ()
int | IsVectorResult ()
double | GetScalarResult ()
char * | GetScalarVariableName (int i)
char * | GetVectorVariableName (int i)
void | RemoveAllVariables ()
void | SetFunction (const char *function)
virtual char * | GetFunction ()
double * | GetVectorResult ()
void | GetVectorResult (double result[3])
void | SetScalarVariableValue (const char *variableName, double value)
void | SetScalarVariableValue (int i, double value)
double | GetScalarVariableValue (const char *variableName)
double | GetScalarVariableValue (int i)
void | SetVectorVariableValue (const char *variableName, double xValue, double yValue, double zValue)
void | SetVectorVariableValue (const char *variableName, const double values[3])
void | SetVectorVariableValue (int i, double xValue, double yValue, double zValue)
void | SetVectorVariableValue (int i, const double values[3])
double * | GetVectorVariableValue (const char *variableName)
void | GetVectorVariableValue (const char *variableName, double value[3])
double * | GetVectorVariableValue (int i)
void | GetVectorVariableValue (int i, double value[3])
virtual int | GetNumberOfScalarVariables ()
virtual int | GetNumberOfVectorVariables ()

Static Public Methods

vtkFunctionParser * | New ()

Protected Methods

vtkFunctionParser ()
~vtkFunctionParser ()
int | Parse ()
void | Evaluate ()
int | CheckSyntax ()
void | RemoveSpaces ()
int | BuildInternalFunctionStructure ()
void | BuildInternalSubstringStructure (int beginIndex, int endIndex)
void | AddInternalByte (unsigned char newByte)
int | IsSubstringCompletelyEnclosed (int beginIndex, int endIndex)
int | FindEndOfMathFunction (int beginIndex)
int | IsVariableName (int currentIndex)
int | IsElementaryOperator (int op)
int | GetMathFunctionNumber (int currentIndex)
int | GetMathFunctionStringLength (int mathFunctionNumber)
int | GetElementaryOperatorNumber (char op)
int | GetOperandNumber (int currentIndex)
int | GetVariableNameLength (int variableNumber)
int | DisambiguateOperators ()

Protected Attributes

char * | Function
int | FunctionLength
int | NumberOfScalarVariables
int | NumberOfVectorVariables
char ** | ScalarVariableNames
char ** | VectorVariableNames
double * | ScalarVariableValues
double ** | VectorVariableValues
unsigned char * | ByteCode
int | ByteCodeSize
double * | Immediates
int | ImmediatesSize
double * | Stack
int | StackSize
int | StackPointer
vtkTimeStamp FunctionMTime
vtkTimeStamp ParseMTime
vtkTimeStamp VariableMTime
vtkTimeStamp EvaluateMTime

Detailed Description

Parse and evaluate a mathematical expression.

Date:
2002/01/25 19:25:05
Revision:
1.13

vtkFunctionParser is a class that takes in a mathematical expression as a char string, parses it, and evaluates it at the specified values of the variables in the input string.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (82%)
  • Gobbi, David (16%)

Definition at line 79 of file vtkFunctionParser.h.

Constructor & Destructor Documentation

vtkFunctionParser::vtkFunctionParser ( ) [protected]

vtkFunctionParser::~vtkFunctionParser ( ) [protected]

Member Function Documentation

vtkFunctionParser* vtkFunctionParser::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkFunctionParser::vtkTypeRevisionMacro | ( | vtkFunctionParser | ,
 |  | vtkObject |
 | ) |

void vtkFunctionParser::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkFunctionParser::SetFunction ( const char * function )

Set/Get input string to evaluate.

virtual char* vtkFunctionParser::GetFunction ( ) [virtual]

Set/Get input string to evaluate.

int vtkFunctionParser::IsScalarResult ( )

Check whether the result is a scalar result. If it isn't, then either the result is a vector or an error has occurred.

int vtkFunctionParser::IsVectorResult ( )

Check whether the result is a vector result. If it isn't, then either the result is scalar or an error has occurred.

double vtkFunctionParser::GetScalarResult ( )

Get a scalar result from evaluating the input function.

double* vtkFunctionParser::GetVectorResult ( )

Get a vector result from evaluating the input function.

void vtkFunctionParser::GetVectorResult ( double result[3] ) [inline]

Get a vector result from evaluating the input function.

Definition at line 106 of file vtkFunctionParser.h.

void vtkFunctionParser::SetScalarVariableValue | ( | const char * | variableName,
 |  | double | value
 | ) |

Set the value of a scalar variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

void vtkFunctionParser::SetScalarVariableValue | ( | int | i,
 |  | double | value
 | ) |

Set the value of a scalar variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

double vtkFunctionParser::GetScalarVariableValue ( const char * variableName )

Get the value of a scalar variable.

double vtkFunctionParser::GetScalarVariableValue ( int i )

Get the value of a scalar variable.

void vtkFunctionParser::SetVectorVariableValue | ( | const char * | variableName,
 |  | double | xValue,
 |  | double | yValue,
 |  | double | zValue
 | ) |

Set the value of a vector variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

void vtkFunctionParser::SetVectorVariableValue | ( | const char * | variableName,
 |  | const double | values[3]
 | ) | [inline]

Set the value of a vector variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

Definition at line 133 of file vtkFunctionParser.h.

void vtkFunctionParser::SetVectorVariableValue | ( | int | i,
 |  | double | xValue,
 |  | double | yValue,
 |  | double | zValue
 | ) |

Set the value of a vector variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

void vtkFunctionParser::SetVectorVariableValue | ( | int | i,
 |  | const double | values[3]
 | ) | [inline]

Set the value of a vector variable. If a variable with this name exists, then its value will be set to the new value. If there is not already a variable with this name, variableName will be added to the list of variables, and its value will be set to the new value.

Definition at line 138 of file vtkFunctionParser.h.

double* vtkFunctionParser::GetVectorVariableValue ( const char * variableName )

Get the value of a vector variable.

void vtkFunctionParser::GetVectorVariableValue | ( | const char * | variableName,
 |  | double | value[3]
 | ) | [inline]

Get the value of a vector variable.

Definition at line 145 of file vtkFunctionParser.h.

double* vtkFunctionParser::GetVectorVariableValue ( int i )

Get the value of a vector variable.

void vtkFunctionParser::GetVectorVariableValue | ( | int | i,
 |  | double | value[3]
 | ) | [inline]

Get the value of a vector variable.

Definition at line 149 of file vtkFunctionParser.h.

virtual int vtkFunctionParser::GetNumberOfScalarVariables ( ) [virtual]

Get the number of scalar variables.

virtual int vtkFunctionParser::GetNumberOfVectorVariables ( ) [virtual]

Get the number of vector variables.

char* vtkFunctionParser::GetScalarVariableName ( int i )

Get the ith scalar variable name.

char* vtkFunctionParser::GetVectorVariableName ( int i )

Get the ith vector variable name.

void vtkFunctionParser::RemoveAllVariables ( )

Remove all the current variables.

int vtkFunctionParser::Parse ( ) [protected]

void vtkFunctionParser::Evaluate ( ) [protected]

int vtkFunctionParser::CheckSyntax ( ) [protected]

void vtkFunctionParser::RemoveSpaces ( ) [protected]

int vtkFunctionParser::BuildInternalFunctionStructure ( ) [protected]

void vtkFunctionParser::BuildInternalSubstringStructure | ( | int | beginIndex,
 |  | int | endIndex
 | ) | [protected]

void vtkFunctionParser::AddInternalByte ( unsigned char newByte ) [protected]

int vtkFunctionParser::IsSubstringCompletelyEnclosed | ( | int | beginIndex,
 |  | int | endIndex
 | ) | [protected]

int vtkFunctionParser::FindEndOfMathFunction ( int beginIndex ) [protected]

int vtkFunctionParser::IsVariableName ( int currentIndex ) [protected]

int vtkFunctionParser::IsElementaryOperator ( int op ) [protected]

int vtkFunctionParser::GetMathFunctionNumber ( int currentIndex ) [protected]

int vtkFunctionParser::GetMathFunctionStringLength ( int mathFunctionNumber ) [protected]

int vtkFunctionParser::GetElementaryOperatorNumber ( char op ) [protected]

int vtkFunctionParser::GetOperandNumber ( int currentIndex ) [protected]

int vtkFunctionParser::GetVariableNameLength ( int variableNumber ) [protected]

int vtkFunctionParser::DisambiguateOperators ( ) [protected]

Member Data Documentation

char* vtkFunctionParser::Function [protected]

Definition at line 201 of file vtkFunctionParser.h.

int vtkFunctionParser::FunctionLength [protected]

Definition at line 202 of file vtkFunctionParser.h.

int vtkFunctionParser::NumberOfScalarVariables [protected]

Definition at line 203 of file vtkFunctionParser.h.

int vtkFunctionParser::NumberOfVectorVariables [protected]

Definition at line 204 of file vtkFunctionParser.h.

char** vtkFunctionParser::ScalarVariableNames [protected]

Definition at line 205 of file vtkFunctionParser.h.

char** vtkFunctionParser::VectorVariableNames [protected]

Definition at line 206 of file vtkFunctionParser.h.

double* vtkFunctionParser::ScalarVariableValues [protected]

Definition at line 207 of file vtkFunctionParser.h.

double** vtkFunctionParser::VectorVariableValues [protected]

Definition at line 208 of file vtkFunctionParser.h.

unsigned char* vtkFunctionParser::ByteCode [protected]

Definition at line 209 of file vtkFunctionParser.h.

int vtkFunctionParser::ByteCodeSize [protected]

Definition at line 210 of file vtkFunctionParser.h.

double* vtkFunctionParser::Immediates [protected]

Definition at line 211 of file vtkFunctionParser.h.

int vtkFunctionParser::ImmediatesSize [protected]

Definition at line 212 of file vtkFunctionParser.h.

double* vtkFunctionParser::Stack [protected]

Definition at line 213 of file vtkFunctionParser.h.

int vtkFunctionParser::StackSize [protected]

Definition at line 214 of file vtkFunctionParser.h.

int vtkFunctionParser::StackPointer [protected]

Definition at line 215 of file vtkFunctionParser.h.

vtkTimeStamp vtkFunctionParser::FunctionMTime [protected]

Definition at line 217 of file vtkFunctionParser.h.

vtkTimeStamp vtkFunctionParser::ParseMTime [protected]

Definition at line 218 of file vtkFunctionParser.h.

vtkTimeStamp vtkFunctionParser::VariableMTime [protected]

Definition at line 219 of file vtkFunctionParser.h.

vtkTimeStamp vtkFunctionParser::EvaluateMTime [protected]

Definition at line 220 of file vtkFunctionParser.h.

The documentation for this class was generated from the following file:
  • Common/vtkFunctionParser.h
Generated on Mon Mar 25 01:17:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkFunctionSet Class Reference

Abstract inteface for sets of functions. More...

#include <vtkFunctionSet.h>

Inheritance diagram for vtkFunctionSet:

[legend]
Collaboration diagram for vtkFunctionSet:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkFunctionSet, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | FunctionValues (float *x, float *f)=0
virtual int | GetNumberOfFunctions ()
virtual int | GetNumberOfIndependentVariables ()

Protected Methods

vtkFunctionSet ()
~vtkFunctionSet ()

Protected Attributes

int | NumFuncs
int | NumIndepVars

Detailed Description

Abstract inteface for sets of functions.

Date:
2002/01/22 15:25:24
Revision:
1.8

vtkFunctionSet specifies an abstract interface for set of functions of the form F_i = F_i(x_j) where F (with i=1..m) are the functions and x (with j=1..n) are the independent variables. The only supported operation is the function evaluation at x_j.

See also:
vtkImplicitDataSet vtkInterpolatedVelocityField vtkInitialValueProblemSolver
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (97%)

Definition at line 43 of file vtkFunctionSet.h.

Constructor & Destructor Documentation

vtkFunctionSet::vtkFunctionSet ( ) [protected]

vtkFunctionSet::~vtkFunctionSet ( ) [inline, protected]

Definition at line 71 of file vtkFunctionSet.h.

Member Function Documentation

vtkFunctionSet::vtkTypeRevisionMacro | ( | vtkFunctionSet | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkInterpolatedVelocityField.

virtual void vtkFunctionSet::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkInterpolatedVelocityField.

virtual int vtkFunctionSet::FunctionValues | ( | float * | x,
 |  | float * | f
 | ) | [pure virtual]

Evaluate functions at x_j. x and f have to point to valid float arrays of appropriate sizes obtained with GetNumberOfFunctions() and GetNumberOfIndependentVariables.

Reimplemented in vtkInterpolatedVelocityField.

virtual int vtkFunctionSet::GetNumberOfFunctions ( ) [inline, virtual]

Return the number of functions. Note that this is constant for a given type of set of functions and can not be changed at run time.

Definition at line 57 of file vtkFunctionSet.h.

virtual int vtkFunctionSet::GetNumberOfIndependentVariables ( ) [inline, virtual]

Return the number of independent variables. Note that this is constant for a given type of set of functions and can not be changed at run time.

Definition at line 65 of file vtkFunctionSet.h.

Member Data Documentation

int vtkFunctionSet::NumFuncs [protected]

Definition at line 73 of file vtkFunctionSet.h.

int vtkFunctionSet::NumIndepVars [protected]

Definition at line 74 of file vtkFunctionSet.h.

The documentation for this class was generated from the following file:
  • Common/vtkFunctionSet.h
Generated on Mon Mar 25 01:17:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGaussianSplatter Class Reference

splat points into a volume with an elliptical, Gaussian distribution. More...

#include <vtkGaussianSplatter.h>

Inheritance diagram for vtkGaussianSplatter:

[legend]
Collaboration diagram for vtkGaussianSplatter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGaussianSplatter, vtkDataSetToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ComputeModelBounds ()
void | SetSampleDimensions (int i, int j, int k)
void | SetSampleDimensions (int dim[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetModelBounds (float, float, float, float, float, float)
virtual void | SetModelBounds (float[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetExponentFactor (float)
virtual float | GetExponentFactor ()
virtual void | SetNormalWarping (int)
virtual int | GetNormalWarping ()
virtual void | NormalWarpingOn ()
virtual void | NormalWarpingOff ()
virtual void | SetEccentricity (float)
virtual float | GetEccentricity ()
virtual void | SetScalarWarping (int)
virtual int | GetScalarWarping ()
virtual void | ScalarWarpingOn ()
virtual void | ScalarWarpingOff ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetCapValue (float)
virtual float | GetCapValue ()
virtual void | SetAccumulationMode (int)
virtual int | GetAccumulationMode ()
void | SetAccumulationModeToMin ()
void | SetAccumulationModeToMax ()
void | SetAccumulationModeToSum ()
const char * | GetAccumulationModeAsString ()
virtual void | SetNullValue (float)
virtual float | GetNullValue ()

Static Public Methods

vtkGaussianSplatter * | New ()

Protected Methods

vtkGaussianSplatter ()
~vtkGaussianSplatter ()
void | Execute ()
void | Cap (vtkFloatArray *s)
float | Gaussian (float x[3])
float | EccentricGaussian (float x[3])
float | ScalarSampling (float s)
float | PositionSampling (float)
void | SetScalar (int idx, float dist2)

Protected Attributes

int | SampleDimensions [3]
float | Radius
float | ExponentFactor
float | ModelBounds [6]
int | NormalWarping
float | Eccentricity
int | ScalarWarping
float | ScaleFactor
int | Capping
float | CapValue
int | AccumulationMode

Detailed Description

splat points into a volume with an elliptical, Gaussian distribution.

Date:
2002/01/22 15:31:46
Revision:
1.43

vtkGaussianSplatter is a filter that injects input points into a structured points (volume) dataset. As each point is injected, it "splats" or distributes values to nearby voxels. Data is distributed using an elliptical, Gaussian distribution function. The distribution function is modified using scalar values (expands distribution) or normals (creates ellipsoidal distribution rather than spherical).

In general, the Gaussian distribution function f(x) around a given splat point p is given by

f(x) = ScaleFactor * exp( ExponentFactor*((r/Radius)**2) )

where x is the current voxel sample point; r is the distance |x-p| ExponentFactor <= 0.0, and ScaleFactor can be multiplied by the scalar value of the point p that is currently being splatted.

If points normals are present (and NormalWarping is on), then the splat function becomes elliptical (as compared to the spherical one described by the previous equation). The Gaussian distribution function then becomes:

f(x) = ScaleFactor * exp( ExponentFactor*( ((rxy/E)**2 + z**2)/R**2) )

where E is a user-defined eccentricity factor that controls the elliptical shape of the splat; z is the distance of the current voxel sample point along normal N; and rxy is the distance of x in the direction prependicular to N.

This class is typically used to convert point-valued distributions into a volume representation. The volume is then usually iso-surfaced or volume rendered to generate a visualization. It can be used to create surfaces from point distributions, or to create structure (i.e., topology) when none exists.

Warning:
The input to this filter is any dataset type. This filter can be used to resample any form of data, i.e., the input data need not be unstructured.
Warning:
Some voxels may never receive a contribution during the splatting process. The final value of these points can be specified with the "NullValue" instance variable.
See also:
vtkShepardMethod
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (78%)
  • Lorensen, Bill (10%)
  • Martin, Ken (6%)
Examples:
vtkGaussianSplatter (Examples)
Tests:
vtkGaussianSplatter (Tests)

Definition at line 96 of file vtkGaussianSplatter.h.

Constructor & Destructor Documentation

vtkGaussianSplatter::vtkGaussianSplatter ( ) [protected]

vtkGaussianSplatter::~vtkGaussianSplatter ( ) [inline, protected]

Definition at line 220 of file vtkGaussianSplatter.h.

Member Function Documentation

vtkGaussianSplatter::vtkTypeRevisionMacro | ( | vtkGaussianSplatter | ,
 |  | vtkDataSetToStructuredPointsFilter |
 | ) |

Reimplemented from vtkDataSetToStructuredPointsFilter.

void vtkGaussianSplatter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkGaussianSplatter* vtkGaussianSplatter::New ( ) [static]

Construct object with dimensions=(50,50,50); automatic computation of bounds; a splat radius of 0.1; an exponent factor of -5; and normal and scalar warping turned on.

Reimplemented from vtkStructuredPointsSource.

void vtkGaussianSplatter::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set / get the dimensions of the sampling structured point set. Higher values produce better results but are much slower.

void vtkGaussianSplatter::SetSampleDimensions ( int dim[3] )

Set / get the dimensions of the sampling structured point set. Higher values produce better results but are much slower.

virtual int* vtkGaussianSplatter::GetSampleDimensions ( ) [virtual]

Set / get the dimensions of the sampling structured point set. Higher values produce better results but are much slower.

virtual void vtkGaussianSplatter::GetSampleDimensions ( int data[3] ) [virtual]

Set / get the dimensions of the sampling structured point set. Higher values produce better results but are much slower.

virtual void vtkGaussianSplatter::SetModelBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the (xmin,xmax, ymin,ymax, zmin,zmax) bounding box in which the sampling is performed. If any of the (min,max) bounds values are min >= max, then the bounds will be computed automatically from the input data. Otherwise, the user-specified bounds will be used.

virtual void vtkGaussianSplatter::SetModelBounds ( float [6] ) [virtual]

Set / get the (xmin,xmax, ymin,ymax, zmin,zmax) bounding box in which the sampling is performed. If any of the (min,max) bounds values are min >= max, then the bounds will be computed automatically from the input data. Otherwise, the user-specified bounds will be used.

virtual float* vtkGaussianSplatter::GetModelBounds ( ) [virtual]

Set / get the (xmin,xmax, ymin,ymax, zmin,zmax) bounding box in which the sampling is performed. If any of the (min,max) bounds values are min >= max, then the bounds will be computed automatically from the input data. Otherwise, the user-specified bounds will be used.

virtual void vtkGaussianSplatter::GetModelBounds ( float data[6] ) [virtual]

Set / get the (xmin,xmax, ymin,ymax, zmin,zmax) bounding box in which the sampling is performed. If any of the (min,max) bounds values are min >= max, then the bounds will be computed automatically from the input data. Otherwise, the user-specified bounds will be used.

virtual void vtkGaussianSplatter::SetRadius ( float ) [virtual]

Set / get the radius of propagation of the splat. This value is expressed as a percentage of the length of the longest side of the sampling volume. Smaller numbers greatly reduce execution time.

virtual float vtkGaussianSplatter::GetRadius ( ) [virtual]

Set / get the radius of propagation of the splat. This value is expressed as a percentage of the length of the longest side of the sampling volume. Smaller numbers greatly reduce execution time.

virtual void vtkGaussianSplatter::SetScaleFactor ( float ) [virtual]

Multiply Gaussian splat distribution by this value. If ScalarWarping is on, then the Scalar value will be multiplied by the ScaleFactor times the Gaussian function.

virtual float vtkGaussianSplatter::GetScaleFactor ( ) [virtual]

Multiply Gaussian splat distribution by this value. If ScalarWarping is on, then the Scalar value will be multiplied by the ScaleFactor times the Gaussian function.

virtual void vtkGaussianSplatter::SetExponentFactor ( float ) [virtual]

Set / get the sharpness of decay of the splats. This is the exponent constant in the Gaussian equation. Normally this is a negative value.

virtual float vtkGaussianSplatter::GetExponentFactor ( ) [virtual]

Set / get the sharpness of decay of the splats. This is the exponent constant in the Gaussian equation. Normally this is a negative value.

virtual void vtkGaussianSplatter::SetNormalWarping ( int ) [virtual]

Turn on/off the generation of elliptical splats. If normal warping is on, then the input normals affect the distribution of the splat. This boolean is used in combination with the Eccentricity ivar.

virtual int vtkGaussianSplatter::GetNormalWarping ( ) [virtual]

Turn on/off the generation of elliptical splats. If normal warping is on, then the input normals affect the distribution of the splat. This boolean is used in combination with the Eccentricity ivar.

virtual void vtkGaussianSplatter::NormalWarpingOn ( ) [virtual]

Turn on/off the generation of elliptical splats. If normal warping is on, then the input normals affect the distribution of the splat. This boolean is used in combination with the Eccentricity ivar.

virtual void vtkGaussianSplatter::NormalWarpingOff ( ) [virtual]

Turn on/off the generation of elliptical splats. If normal warping is on, then the input normals affect the distribution of the splat. This boolean is used in combination with the Eccentricity ivar.

virtual void vtkGaussianSplatter::SetEccentricity ( float ) [virtual]

Control the shape of elliptical splatting. Eccentricity is the ratio of the major axis (aligned along normal) to the minor (axes) aligned along other two axes. So Eccentricity > 1 creates needles with the long axis in the direction of the normal; Eccentricity<1 creates pancakes perpendicular to the normal vector.

virtual float vtkGaussianSplatter::GetEccentricity ( ) [virtual]

Control the shape of elliptical splatting. Eccentricity is the ratio of the major axis (aligned along normal) to the minor (axes) aligned along other two axes. So Eccentricity > 1 creates needles with the long axis in the direction of the normal; Eccentricity<1 creates pancakes perpendicular to the normal vector.

virtual void vtkGaussianSplatter::SetScalarWarping ( int ) [virtual]

Turn on/off the scaling of splats by scalar value.

virtual int vtkGaussianSplatter::GetScalarWarping ( ) [virtual]

Turn on/off the scaling of splats by scalar value.

virtual void vtkGaussianSplatter::ScalarWarpingOn ( ) [virtual]

Turn on/off the scaling of splats by scalar value.

virtual void vtkGaussianSplatter::ScalarWarpingOff ( ) [virtual]

Turn on/off the scaling of splats by scalar value.

virtual void vtkGaussianSplatter::SetCapping ( int ) [virtual]

Turn on/off the capping of the outer boundary of the volume to a specified cap value. This can be used to close surfaces (after iso-surfacing) and create other effects.

virtual int vtkGaussianSplatter::GetCapping ( ) [virtual]

Turn on/off the capping of the outer boundary of the volume to a specified cap value. This can be used to close surfaces (after iso-surfacing) and create other effects.

virtual void vtkGaussianSplatter::CappingOn ( ) [virtual]

Turn on/off the capping of the outer boundary of the volume to a specified cap value. This can be used to close surfaces (after iso-surfacing) and create other effects.

virtual void vtkGaussianSplatter::CappingOff ( ) [virtual]

Turn on/off the capping of the outer boundary of the volume to a specified cap value. This can be used to close surfaces (after iso-surfacing) and create other effects.

virtual void vtkGaussianSplatter::SetCapValue ( float ) [virtual]

Specify the cap value to use. (This instance variable only has effect if the ivar Capping is on.)

virtual float vtkGaussianSplatter::GetCapValue ( ) [virtual]

Specify the cap value to use. (This instance variable only has effect if the ivar Capping is on.)

virtual void vtkGaussianSplatter::SetAccumulationMode ( int ) [virtual]

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

virtual int vtkGaussianSplatter::GetAccumulationMode ( ) [virtual]

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

void vtkGaussianSplatter::SetAccumulationModeToMin ( ) [inline]

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

Definition at line 197 of file vtkGaussianSplatter.h.

void vtkGaussianSplatter::SetAccumulationModeToMax ( ) [inline]

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

Definition at line 199 of file vtkGaussianSplatter.h.

void vtkGaussianSplatter::SetAccumulationModeToSum ( ) [inline]

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

Definition at line 201 of file vtkGaussianSplatter.h.

const char* vtkGaussianSplatter::GetAccumulationModeAsString ( )

Specify the scalar accumulation mode. This mode expresses how scalar values are combined when splats are overlapped. The Max mode acts like a set union operation and is the most commonly used; the Min mode acts like a set intersection, and the sum is just weird.

virtual void vtkGaussianSplatter::SetNullValue ( float ) [virtual]

Set the Null value for output points not receiving a contribution from the input points. (This is the initial value of the voxel samples.)

virtual float vtkGaussianSplatter::GetNullValue ( ) [virtual]

Set the Null value for output points not receiving a contribution from the input points. (This is the initial value of the voxel samples.)

void vtkGaussianSplatter::ComputeModelBounds ( )

Compute the size of the sample bounding box automatically from the input data. This is an internal helper function.

void vtkGaussianSplatter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkGaussianSplatter::Cap ( vtkFloatArray * s ) [protected]

float vtkGaussianSplatter::Gaussian ( float x[3] ) [protected]

float vtkGaussianSplatter::EccentricGaussian ( float x[3] ) [protected]

float vtkGaussianSplatter::ScalarSampling ( float s ) [inline, protected]

Definition at line 239 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::PositionSampling ( float ) [inline, protected]

Definition at line 241 of file vtkGaussianSplatter.h.

void vtkGaussianSplatter::SetScalar | ( | int | idx,
 |  | float | dist2
 | ) | [protected]

Member Data Documentation

int vtkGaussianSplatter::SampleDimensions[3] [protected]

Definition at line 225 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::Radius [protected]

Definition at line 226 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::ExponentFactor [protected]

Definition at line 227 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::ModelBounds[6] [protected]

Definition at line 228 of file vtkGaussianSplatter.h.

int vtkGaussianSplatter::NormalWarping [protected]

Definition at line 229 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::Eccentricity [protected]

Definition at line 230 of file vtkGaussianSplatter.h.

int vtkGaussianSplatter::ScalarWarping [protected]

Definition at line 231 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::ScaleFactor [protected]

Definition at line 232 of file vtkGaussianSplatter.h.

int vtkGaussianSplatter::Capping [protected]

Definition at line 233 of file vtkGaussianSplatter.h.

float vtkGaussianSplatter::CapValue [protected]

Definition at line 234 of file vtkGaussianSplatter.h.

int vtkGaussianSplatter::AccumulationMode [protected]

Definition at line 235 of file vtkGaussianSplatter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkGaussianSplatter.h
Generated on Mon Mar 25 01:17:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGeneralTransform Class Reference

allows operations on any transforms. More...

#include <vtkGeneralTransform.h>

Inheritance diagram for vtkGeneralTransform:

[legend]
Collaboration diagram for vtkGeneralTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGeneralTransform, vtkAbstractTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Identity ()
void | Inverse ()
void | Concatenate (vtkAbstractTransform *transform)
int | CircuitCheck (vtkAbstractTransform *transform)
vtkAbstractTransform * MakeTransform ()
unsigned long | GetMTime ()
void | Translate (double x, double y, double z)
void | Translate (const double x[3])
void | Translate (const float x[3])
void | RotateWXYZ (double angle, double x, double y, double z)
void | RotateWXYZ (double angle, const double axis[3])
void | RotateWXYZ (double angle, const float axis[3])
void | RotateX (double angle)
void | RotateY (double angle)
void | RotateZ (double angle)
void | Scale (double x, double y, double z)
void | Scale (const double s[3])
void | Scale (const float s[3])
void | Concatenate (vtkMatrix4x4 *matrix)
void | Concatenate (const double elements[16])
void | PreMultiply ()
void | PostMultiply ()
int | GetNumberOfConcatenatedTransforms ()
vtkAbstractTransform * | GetConcatenatedTransform (int i)
void | SetInput (vtkAbstractTransform *input)
vtkAbstractTransform * GetInput ()
int | GetInverseFlag ()
void | Push ()
void | Pop ()
void | InternalTransformPoint (const float in[3], float out[3])
void | InternalTransformPoint (const double in[3], double out[3])
void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Static Public Methods

vtkGeneralTransform * | New ()

Protected Methods

vtkGeneralTransform ()
~vtkGeneralTransform ()
void | InternalDeepCopy (vtkAbstractTransform *t)
void | InternalUpdate ()

Protected Attributes

vtkAbstractTransform * Input
vtkTransformConcatenation * Concatenation
vtkTransformConcatenationStack * Stack

Detailed Description

allows operations on any transforms.

Date:
2002/01/22 15:25:24
Revision:
1.39

vtkGeneralTransform is like vtkTransform and vtkPerspectiveTransform, but it will work with any vtkAbstractTransform as input. It is not as efficient as the other two, however, because arbitrary transformations cannot be concatenated by matrix multiplication. Transform concatenation is simulated by passing each input point through each transform in turn.

See also:
vtkTransform vtkPerspectiveTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)
Tests:
vtkGeneralTransform (Tests)

Definition at line 46 of file vtkGeneralTransform.h.

Constructor & Destructor Documentation

vtkGeneralTransform::vtkGeneralTransform ( ) [protected]

vtkGeneralTransform::~vtkGeneralTransform ( ) [protected]

Member Function Documentation

vtkGeneralTransform* vtkGeneralTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkGeneralTransform::vtkTypeRevisionMacro | ( | vtkGeneralTransform | ,
 |  | vtkAbstractTransform |
 | ) |

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::Identity ( ) [inline]

Set this transformation to the identity transformation. If the transform has an Input, then the transformation will be reset so that it is the same as the Input.

Reimplemented from vtkAbstractTransform.

Definition at line 57 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Inverse ( ) [inline, virtual]

Invert the transformation. This will also set a flag so that the transformation will use the inverse of its Input, if an Input has been set.

Reimplemented from vtkAbstractTransform.

Definition at line 62 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 67 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Translate ( const double x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 69 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Translate ( const float x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 70 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateWXYZ | ( | double | angle,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 78 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateWXYZ | ( | double | angle,
 |  | const double | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 80 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateWXYZ | ( | double | angle,
 |  | const float | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 82 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateX ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 90 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateY ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 91 of file vtkGeneralTransform.h.

void vtkGeneralTransform::RotateZ ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 92 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Scale | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 99 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Scale ( const double s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 101 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Scale ( const float s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 102 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Concatenate ( vtkMatrix4x4 * matrix ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 108 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Concatenate ( const double elements[16] ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 110 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Concatenate ( vtkAbstractTransform * transform )

Concatenate the specified transform with the current transformation according to PreMultiply or PostMultiply semantics. The concatenation is pipelined, meaning that if any of the transformations are changed, even after Concatenate() is called, those changes will be reflected when you call TransformPoint().

void vtkGeneralTransform::PreMultiply ( ) [inline]

Sets the internal state of the transform to PreMultiply. All subsequent operations will occur before those already represented in the current transformation. In homogeneous matrix notation, M = M*A where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 127 of file vtkGeneralTransform.h.

void vtkGeneralTransform::PostMultiply ( ) [inline]

Sets the internal state of the transform to PostMultiply. All subsequent operations will occur after those already represented in the current transformation. In homogeneous matrix notation, M = A*M where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 138 of file vtkGeneralTransform.h.

int vtkGeneralTransform::GetNumberOfConcatenatedTransforms ( ) [inline]

Get the total number of transformations that are linked into this one via Concatenate() operations or via SetInput().

Definition at line 146 of file vtkGeneralTransform.h.

vtkAbstractTransform* vtkGeneralTransform::GetConcatenatedTransform ( int i ) [inline]

Get one of the concatenated transformations as a vtkAbstractTransform. These transformations are applied, in series, every time the transformation of a coordinate occurs. This method is provided to make it possible to decompose a transformation into its constituents, for example to save a transformation to a file.

Definition at line 157 of file vtkGeneralTransform.h.

void vtkGeneralTransform::SetInput ( vtkAbstractTransform * input )

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

vtkAbstractTransform* vtkGeneralTransform::GetInput ( ) [inline]

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

Definition at line 178 of file vtkGeneralTransform.h.

int vtkGeneralTransform::GetInverseFlag ( ) [inline]

Get the inverse flag of the transformation. This controls whether it is the Input or the inverse of the Input that is used as the base transformation. The InverseFlag is flipped every time Inverse() is called. The InverseFlag is off when a transform is first created.

Definition at line 186 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Push ( ) [inline]

Pushes the current transformation onto the transformation stack.

Definition at line 192 of file vtkGeneralTransform.h.

void vtkGeneralTransform::Pop ( ) [inline]

Deletes the transformation on the top of the stack and sets the top to the next transformation on the stack.

Definition at line 201 of file vtkGeneralTransform.h.

void vtkGeneralTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

int vtkGeneralTransform::CircuitCheck ( vtkAbstractTransform * transform ) [virtual]

Check for self-reference. Will return true if concatenating with the specified transform, setting it to be our inverse, or setting it to be our input will create a circular reference. CircuitCheck is automatically called by SetInput(), SetInverse(), and Concatenate(vtkXTransform *). Avoid using this function, it is experimental.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkGeneralTransform::MakeTransform ( ) [virtual]

Make another transform of the same type.

Reimplemented from vtkAbstractTransform.

unsigned long vtkGeneralTransform::GetMTime ( ) [virtual]

Override GetMTime to account for input and concatenation.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkAbstractTransform.

void vtkGeneralTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

Member Data Documentation

vtkAbstractTransform* vtkGeneralTransform::Input [protected]

Definition at line 243 of file vtkGeneralTransform.h.

vtkTransformConcatenation* vtkGeneralTransform::Concatenation [protected]

Definition at line 244 of file vtkGeneralTransform.h.

vtkTransformConcatenationStack* vtkGeneralTransform::Stack [protected]

Definition at line 245 of file vtkGeneralTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkGeneralTransform.h
Generated on Mon Mar 25 01:17:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGenericCell Class Reference

provides thread-safe access to cells. More...

#include <vtkGenericCell.h>

Inheritance diagram for vtkGenericCell:

[legend]
Collaboration diagram for vtkGenericCell:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGenericCell, vtkCell)
vtkCell * MakeObject ()
void | ShallowCopy (vtkCell *c)
void | DeepCopy (vtkCell *c)
int | GetCellType ()
int | GetCellDimension ()
int | IsLinear ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
int | GetParametricCenter (float pcoords[3])
void | SetCellType (int cellType)
void | SetCellTypeToEmptyCell ()
void | SetCellTypeToVertex ()
void | SetCellTypeToPolyVertex ()
void | SetCellTypeToLine ()
void | SetCellTypeToPolyLine ()
void | SetCellTypeToTriangle ()
void | SetCellTypeToTriangleStrip ()
void | SetCellTypeToPolygon ()
void | SetCellTypeToPixel ()
void | SetCellTypeToQuad ()
void | SetCellTypeToTetra ()
void | SetCellTypeToVoxel ()
void | SetCellTypeToHexahedron ()
void | SetCellTypeToWedge ()
void | SetCellTypeToPyramid ()
void | SetCellTypeToQuadraticEdge ()
void | SetCellTypeToQuadraticTriangle ()
void | SetCellTypeToQuadraticTetra ()

Static Public Methods

vtkGenericCell * | New ()

Protected Methods

vtkGenericCell ()
~vtkGenericCell ()

Protected Attributes

vtkCell * Cell

Detailed Description

provides thread-safe access to cells.

Date:
2002/03/06 15:39:59
Revision:
1.22

vtkGenericCell is a class that provides access to concrete types of cells. It's main purpose is to allow thread-safe access to cells, supporting the vtkDataSet::GetCell(vtkGenericCell *) method. vtkGenericCell acts like any type of cell, it just dereferences an internal representation.

See also:
vtkCell vtkDataSet
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Geveci, Berk (9%)
  • Henderson, Amy (5%)
Tests:
vtkGenericCell (Tests)

Definition at line 46 of file vtkGenericCell.h.

Constructor & Destructor Documentation

vtkGenericCell::vtkGenericCell ( ) [protected]

vtkGenericCell::~vtkGenericCell ( ) [protected]

Member Function Documentation

vtkGenericCell* vtkGenericCell::New ( ) [static]

Create handle to any type of cell; by default a vtkEmptyCell.

Reimplemented from vtkObject.

vtkGenericCell::vtkTypeRevisionMacro | ( | vtkGenericCell | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkGenericCell::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::ShallowCopy ( vtkCell * c ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::DeepCopy ( vtkCell * c ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::GetCellType ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::GetCellDimension ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::IsLinear ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::GetNumberOfEdges ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::GetNumberOfFaces ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkGenericCell::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkGenericCell::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | connectivity,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkGenericCell::GetParametricCenter ( float pcoords[3] ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkGenericCell::SetCellType ( int cellType )

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

void vtkGenericCell::SetCellTypeToEmptyCell ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 97 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToVertex ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 98 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToPolyVertex ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 99 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToLine ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 100 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToPolyLine ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 101 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToTriangle ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 102 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToTriangleStrip ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 103 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToPolygon ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 104 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToPixel ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 105 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToQuad ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 106 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToTetra ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 107 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToVoxel ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 108 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToHexahedron ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 109 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToWedge ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 110 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToPyramid ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 111 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToQuadraticEdge ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 112 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToQuadraticTriangle ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 113 of file vtkGenericCell.h.

void vtkGenericCell::SetCellTypeToQuadraticTetra ( ) [inline]

This method is used to support the vtkDataSet::GetCell(vtkGenericCell ) method. It allows vtkGenericCell to act like any cell type by dereferencing an internal instance of a concrete cell type. When you set the cell type, you are resetting a pointer to an internal cell which is then used for computation.

Definition at line 114 of file vtkGenericCell.h.

Member Data Documentation

vtkCell* vtkGenericCell::Cell [protected]

Definition at line 121 of file vtkGenericCell.h.

The documentation for this class was generated from the following file:
  • Common/vtkGenericCell.h
Generated on Mon Mar 25 01:17:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGenericEnSightReader Class Reference

class to read any type of EnSight files. More...

#include <vtkGenericEnSightReader.h>

Inheritance diagram for vtkGenericEnSightReader:

[legend]
Collaboration diagram for vtkGenericEnSightReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGenericEnSightReader, vtkDataSetSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Update ()
char * | GetDescription (int n)
char * | GetComplexDescription (int n)
char * | GetDescription (int n, int type)
void | SetCaseFileName (char *fileName)
virtual char * | GetCaseFileName ()
virtual void | SetFilePath (const char *)
virtual char * | GetFilePath ()
int | GetNumberOfVariables (int type)
virtual int | GetNumberOfScalarsPerNode ()
virtual int | GetNumberOfVectorsPerNode ()
virtual int | GetNumberOfTensorsSymmPerNode ()
virtual int | GetNumberOfScalarsPerElement ()
virtual int | GetNumberOfVectorsPerElement ()
virtual int | GetNumberOfTensorsSymmPerElement ()
virtual int | GetNumberOfScalarsPerMeasuredNode ()
virtual int | GetNumberOfVectorsPerMeasuredNode ()
virtual int | GetNumberOfComplexScalarsPerNode ()
virtual int | GetNumberOfComplexVectorsPerNode ()
virtual int | GetNumberOfComplexScalarsPerElement ()
virtual int | GetNumberOfComplexVectorsPerElement ()
int | GetVariableType (int n)
int | GetComplexVariableType (int n)
virtual void | SetTimeValue (float)
virtual float | GetTimeValue ()
virtual float | GetMinimumTimeValue ()
virtual float | GetMaximumTimeValue ()

Static Public Methods

vtkGenericEnSightReader * | New ()

Protected Methods

vtkGenericEnSightReader ()
~vtkGenericEnSightReader ()
void | Execute ()
int | DetermineEnSightVersion ()
int | ReadLine (char result[256])
int | ReadBinaryLine (char result[80])
int | ReadNextDataLine (char result[256])
virtual void | SetGeometryFileName (const char *)
virtual char * | GetGeometryFileName ()
void | AddVariableDescription (char *description)
void | AddComplexVariableDescription (char *description)
void | AddVariableType (int variableType)
void | AddComplexVariableType (int variableType)
void | ReplaceWildcards (char *fileName, int timeSet, int fileSet)
void | ReplaceWildcardsHelper (char *fileName, int num)

Protected Attributes

istream * IS
FILE * | IFile
vtkEnSightReader * Reader
char * | CaseFileName
char * | GeometryFileName
char * | FilePath
int * | VariableTypes
int * | ComplexVariableTypes
char ** | VariableDescriptions
char ** | ComplexVariableDescriptions
int | NumberOfVariables
int | NumberOfComplexVariables
int | NumberOfScalarsPerNode
int | NumberOfVectorsPerNode
int | NumberOfTensorsSymmPerNode
int | NumberOfScalarsPerElement
int | NumberOfVectorsPerElement
int | NumberOfTensorsSymmPerElement
int | NumberOfScalarsPerMeasuredNode
int | NumberOfVectorsPerMeasuredNode
int | NumberOfComplexScalarsPerNode
int | NumberOfComplexVectorsPerNode
int | NumberOfComplexScalarsPerElement
int | NumberOfComplexVectorsPerElement
float | TimeValue
float | MinimumTimeValue
float | MaximumTimeValue

Detailed Description

class to read any type of EnSight files.

Date:
2002/01/22 15:38:13
Revision:
1.12

The class vtkGenericEnSightReader allows the user to read an EnSight data set without a priori knowledge of what type of EnSight data set it is.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (97%)
Tests:
vtkGenericEnSightReader (Tests)

Definition at line 45 of file vtkGenericEnSightReader.h.

Constructor & Destructor Documentation

vtkGenericEnSightReader::vtkGenericEnSightReader ( ) [protected]

vtkGenericEnSightReader::~vtkGenericEnSightReader ( ) [protected]

Member Function Documentation

vtkGenericEnSightReader* vtkGenericEnSightReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkGenericEnSightReader::vtkTypeRevisionMacro | ( | vtkGenericEnSightReader | ,
 |  | vtkDataSetSource |
 | ) |

Reimplemented from vtkDataSetSource.

void vtkGenericEnSightReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkGenericEnSightReader::SetCaseFileName ( char * fileName )

Set/Get the Case file name.

virtual char* vtkGenericEnSightReader::GetCaseFileName ( ) [virtual]

Set/Get the Case file name.

virtual void vtkGenericEnSightReader::SetFilePath ( const char * ) [virtual]

Set/Get the file path.

virtual char* vtkGenericEnSightReader::GetFilePath ( ) [virtual]

Set/Get the file path.

void vtkGenericEnSightReader::Update ( ) [virtual]

Bring object up-to-date before execution. Update() checks modified time against last execution time, and re-executes object if necessary.

Reimplemented from vtkSource.

int vtkGenericEnSightReader::GetNumberOfVariables ( int type )

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfScalarsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfVectorsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfTensorsSymmPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfScalarsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfVectorsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfTensorsSymmPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfScalarsPerMeasuredNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfVectorsPerMeasuredNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfComplexScalarsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfComplexVectorsPerNode ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfComplexScalarsPerElement ( ) [virtual]

Get the number of variables of a particular type.

virtual int vtkGenericEnSightReader::GetNumberOfComplexVectorsPerElement ( ) [virtual]

Get the number of variables of a particular type.

char* vtkGenericEnSightReader::GetDescription ( int n )

Get the nth description for a non-complex variable.

char* vtkGenericEnSightReader::GetComplexDescription ( int n )

Get the nth description for a complex variable.

char* vtkGenericEnSightReader::GetDescription | ( | int | n,
 |  | int | type
 | ) |

Get the nth description of a particular variable type. Returns NULL if no variable of this type exists in this data set. VTK_SCALAR_PER_NODE = 0; VTK_VECTOR_PER_NODE = 1; VTK_TENSOR_SYMM_PER_NODE = 2; VTK_SCALAR_PER_ELEMENT = 3; VTK_VECTOR_PER_ELEMENT = 4; VTK_TENSOR_SYMM_PER_ELEMENT = 5; VTK_SCALAR_PER_MEASURED_NODE = 6; VTK_VECTOR_PER_MEASURED_NODE = 7; VTK_COMPLEX_SCALAR_PER_NODE = 8; VTK_COMPLEX_VECTOR_PER_NODE 9; VTK_COMPLEX_SCALAR_PER_ELEMENT = 10; VTK_COMPLEX_VECTOR_PER_ELEMENT = 11

int vtkGenericEnSightReader::GetVariableType ( int n )

Get the variable type of variable n.

int vtkGenericEnSightReader::GetComplexVariableType ( int n )

Get the variable type of variable n.

virtual void vtkGenericEnSightReader::SetTimeValue ( float ) [virtual]

Set/Get the time value at which to get the value.

virtual float vtkGenericEnSightReader::GetTimeValue ( ) [virtual]

Set/Get the time value at which to get the value.

virtual float vtkGenericEnSightReader::GetMinimumTimeValue ( ) [virtual]

Get the minimum or maximum time value for this data set.

virtual float vtkGenericEnSightReader::GetMaximumTimeValue ( ) [virtual]

Get the minimum or maximum time value for this data set.

void vtkGenericEnSightReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkGenericEnSightReader::DetermineEnSightVersion ( ) [protected]

Reads the FORMAT part of the case file to determine whether this is an EnSight6 or EnSightGold data set. Returns 0 if the format is EnSight6, 1 if it is EnSightGold, and -1 otherwise (meaning an error occurred).

int vtkGenericEnSightReader::ReadLine ( char result[256] ) [protected]

Internal function to read in a line up to 256 characters. Returns zero if there was an error.

int vtkGenericEnSightReader::ReadBinaryLine ( char result[80] ) [protected]

Internal function to read up to 80 characters from a binary file. Returns zero if there was an error.

int vtkGenericEnSightReader::ReadNextDataLine ( char result[256] ) [protected]

virtual void vtkGenericEnSightReader::SetGeometryFileName ( const char * ) [protected, virtual]

Set/Get the geometry file name.

virtual char* vtkGenericEnSightReader::GetGeometryFileName ( ) [protected, virtual]

Set/Get the geometry file name.

void vtkGenericEnSightReader::AddVariableDescription ( char * description ) [protected]

Add a variable description to the appropriate array.

void vtkGenericEnSightReader::AddComplexVariableDescription ( char * description ) [protected]

Add a variable description to the appropriate array.

void vtkGenericEnSightReader::AddVariableType ( int variableType ) [protected]

Add a variable type to the appropriate array.

void vtkGenericEnSightReader::AddComplexVariableType ( int variableType ) [protected]

Add a variable type to the appropriate array.

void vtkGenericEnSightReader::ReplaceWildcards | ( | char * | fileName,
 |  | int | timeSet,
 |  | int | fileSet
 | ) | [protected]

Replace the wildcards in the geometry file name with appropriate filename numbers as specified in the time set or file set.

void vtkGenericEnSightReader::ReplaceWildcardsHelper | ( | char * | fileName,
 |  | int | num
 | ) | [protected]

Replace the wildcards in the geometry file name with appropriate filename numbers as specified in the time set or file set.

Member Data Documentation

istream* vtkGenericEnSightReader::IS [protected]

Definition at line 168 of file vtkGenericEnSightReader.h.

FILE* vtkGenericEnSightReader::IFile [protected]

Definition at line 169 of file vtkGenericEnSightReader.h.

vtkEnSightReader* vtkGenericEnSightReader::Reader [protected]

Definition at line 170 of file vtkGenericEnSightReader.h.

char* vtkGenericEnSightReader::CaseFileName [protected]

Definition at line 172 of file vtkGenericEnSightReader.h.

char* vtkGenericEnSightReader::GeometryFileName [protected]

Definition at line 173 of file vtkGenericEnSightReader.h.

char* vtkGenericEnSightReader::FilePath [protected]

Definition at line 174 of file vtkGenericEnSightReader.h.

int* vtkGenericEnSightReader::VariableTypes [protected]

Definition at line 176 of file vtkGenericEnSightReader.h.

int* vtkGenericEnSightReader::ComplexVariableTypes [protected]

Definition at line 177 of file vtkGenericEnSightReader.h.

char** vtkGenericEnSightReader::VariableDescriptions [protected]

Definition at line 179 of file vtkGenericEnSightReader.h.

char** vtkGenericEnSightReader::ComplexVariableDescriptions [protected]

Definition at line 180 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfVariables [protected]

Definition at line 182 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfComplexVariables [protected]

Definition at line 183 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfScalarsPerNode [protected]

Definition at line 186 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfVectorsPerNode [protected]

Definition at line 187 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfTensorsSymmPerNode [protected]

Definition at line 188 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfScalarsPerElement [protected]

Definition at line 189 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfVectorsPerElement [protected]

Definition at line 190 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfTensorsSymmPerElement [protected]

Definition at line 191 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfScalarsPerMeasuredNode [protected]

Definition at line 192 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfVectorsPerMeasuredNode [protected]

Definition at line 193 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfComplexScalarsPerNode [protected]

Definition at line 194 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfComplexVectorsPerNode [protected]

Definition at line 195 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfComplexScalarsPerElement [protected]

Definition at line 196 of file vtkGenericEnSightReader.h.

int vtkGenericEnSightReader::NumberOfComplexVectorsPerElement [protected]

Definition at line 197 of file vtkGenericEnSightReader.h.

float vtkGenericEnSightReader::TimeValue [protected]

Definition at line 199 of file vtkGenericEnSightReader.h.

float vtkGenericEnSightReader::MinimumTimeValue [protected]

Definition at line 200 of file vtkGenericEnSightReader.h.

float vtkGenericEnSightReader::MaximumTimeValue [protected]

Definition at line 201 of file vtkGenericEnSightReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkGenericEnSightReader.h
Generated on Mon Mar 25 01:17:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGeometryFilter Class Reference

extract geometry from data (or convert data to polygonal type). More...

#include <vtkGeometryFilter.h>

Inheritance diagram for vtkGeometryFilter:

[legend]
Collaboration diagram for vtkGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGeometryFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetPointClipping (int)
virtual int | GetPointClipping ()
virtual void | PointClippingOn ()
virtual void | PointClippingOff ()
virtual void | SetCellClipping (int)
virtual int | GetCellClipping ()
virtual void | CellClippingOn ()
virtual void | CellClippingOff ()
virtual void | SetExtentClipping (int)
virtual int | GetExtentClipping ()
virtual void | ExtentClippingOn ()
virtual void | ExtentClippingOff ()
virtual void | SetPointMinimum (vtkIdType)
virtual vtkIdType | GetPointMinimum ()
virtual void | SetPointMaximum (vtkIdType)
virtual vtkIdType | GetPointMaximum ()
virtual void | SetCellMinimum (vtkIdType)
virtual vtkIdType | GetCellMinimum ()
virtual void | SetCellMaximum (vtkIdType)
virtual vtkIdType | GetCellMaximum ()
void | SetExtent (float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
void | SetExtent (float extent[6])
float * | GetExtent ()
virtual void | SetMerging (int)
virtual int | GetMerging ()
virtual void | MergingOn ()
virtual void | MergingOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkGeometryFilter * | New ()

Protected Methods

vtkGeometryFilter ()
~vtkGeometryFilter ()
void | Execute ()
void | PolyDataExecute ()
void | UnstructuredGridExecute ()
void | StructuredGridExecute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | ExecuteInformation ()

Protected Attributes

vtkIdType PointMaximum
vtkIdType PointMinimum
vtkIdType CellMinimum
vtkIdType CellMaximum
float | Extent [6]
int | PointClipping
int | CellClipping
int | ExtentClipping
int | Merging
vtkPointLocator * Locator

Detailed Description

extract geometry from data (or convert data to polygonal type).

Date:
2002/01/22 15:29:21
Revision:
1.55

vtkGeometryFilter is a general-purpose filter to extract geometry (and associated data) from any type of dataset. Geometry is obtained as follows: all 0D, 1D, and 2D cells are extracted. All 2D faces that are used by only one 3D cell (i.e., boundary faces) are extracted. It also is possible to specify conditions on point ids, cell ids, and on bounding box (referred to as "Extent") to control the extraction process.

This filter also may be used to convert any type of data to polygonal type. The conversion process may be less than satisfactory for some 3D datasets. For example, this filter will extract the outer surface of a volume or structured grid dataset. (For structured data you may want to use vtkImageDataGeometryFilter, vtkStructuredGridGeometryFilter, vtkExtractUnstructuredGrid, vtkRectilinearGridGeometryFilter, or vtkExtractVOI.)

Warning:
When vtkGeometryFilter extracts cells (or boundaries of cells) it will (by default) merge duplicate vertices. This may cause problems in some cases. For example, if you've run vtkPolyDataNormals to generate normals, which may split meshes and create duplicate vertices, vtkGeometryFilter will merge these points back together. Turn merging off to prevent this from occurring.
See also:
vtkImageDataGeometryFilter vtkStructuredGridGeometryFilter vtkExtractGeometry vtkExtractVOI
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (50%)
  • Martin, Ken (23%)
  • Law, Charles (10%)
  • Geveci, Berk (7%)
Examples:
vtkGeometryFilter (Examples)
Tests:
vtkGeometryFilter (Tests)

Definition at line 70 of file vtkGeometryFilter.h.

Constructor & Destructor Documentation

vtkGeometryFilter::vtkGeometryFilter ( ) [protected]

vtkGeometryFilter::~vtkGeometryFilter ( ) [protected]

Member Function Documentation

vtkGeometryFilter* vtkGeometryFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkGeometryFilter::vtkTypeRevisionMacro | ( | vtkGeometryFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkGeometryFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkGeometryFilter::SetPointClipping ( int ) [virtual]

Turn on/off selection of geometry by point id.

virtual int vtkGeometryFilter::GetPointClipping ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkGeometryFilter::PointClippingOn ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkGeometryFilter::PointClippingOff ( ) [virtual]

Turn on/off selection of geometry by point id.

virtual void vtkGeometryFilter::SetCellClipping ( int ) [virtual]

Turn on/off selection of geometry by cell id.

virtual int vtkGeometryFilter::GetCellClipping ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkGeometryFilter::CellClippingOn ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkGeometryFilter::CellClippingOff ( ) [virtual]

Turn on/off selection of geometry by cell id.

virtual void vtkGeometryFilter::SetExtentClipping ( int ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual int vtkGeometryFilter::GetExtentClipping ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkGeometryFilter::ExtentClippingOn ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkGeometryFilter::ExtentClippingOff ( ) [virtual]

Turn on/off selection of geometry via bounding box.

virtual void vtkGeometryFilter::SetPointMinimum ( vtkIdType ) [virtual]

Specify the minimum point id for point id selection.

virtual vtkIdType vtkGeometryFilter::GetPointMinimum ( ) [virtual]

Specify the minimum point id for point id selection.

virtual void vtkGeometryFilter::SetPointMaximum ( vtkIdType ) [virtual]

Specify the maximum point id for point id selection.

virtual vtkIdType vtkGeometryFilter::GetPointMaximum ( ) [virtual]

Specify the maximum point id for point id selection.

virtual void vtkGeometryFilter::SetCellMinimum ( vtkIdType ) [virtual]

Specify the minimum cell id for point id selection.

virtual vtkIdType vtkGeometryFilter::GetCellMinimum ( ) [virtual]

Specify the minimum cell id for point id selection.

virtual void vtkGeometryFilter::SetCellMaximum ( vtkIdType ) [virtual]

Specify the maximum cell id for point id selection.

virtual vtkIdType vtkGeometryFilter::GetCellMaximum ( ) [virtual]

Specify the maximum cell id for point id selection.

void vtkGeometryFilter::SetExtent | ( | float | xMin,
 |  | float | xMax,
 |  | float | yMin,
 |  | float | yMax,
 |  | float | zMin,
 |  | float | zMax
 | ) |

Specify a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

void vtkGeometryFilter::SetExtent ( float extent[6] )

Set / get a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

float* vtkGeometryFilter::GetExtent ( ) [inline]

Set / get a (xmin,xmax, ymin,ymax, zmin,zmax) bounding box to clip data.

Definition at line 133 of file vtkGeometryFilter.h.

virtual void vtkGeometryFilter::SetMerging ( int ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual int vtkGeometryFilter::GetMerging ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual void vtkGeometryFilter::MergingOn ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

virtual void vtkGeometryFilter::MergingOff ( ) [virtual]

Turn on/off merging of coincident points. Note that is merging is on, points with different point attributes (e.g., normals) are merged, which may cause rendering artifacts.

void vtkGeometryFilter::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkGeometryFilter::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkGeometryFilter::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

unsigned long vtkGeometryFilter::GetMTime ( ) [virtual]

Return the MTime also considering the locator.

Reimplemented from vtkObject.

void vtkGeometryFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkGeometryFilter::PolyDataExecute ( ) [protected]

void vtkGeometryFilter::UnstructuredGridExecute ( ) [protected]

void vtkGeometryFilter::StructuredGridExecute ( ) [protected]

void vtkGeometryFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

Do not let images return more than requested.

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkGeometryFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

vtkIdType vtkGeometryFilter::PointMaximum [protected]

Definition at line 169 of file vtkGeometryFilter.h.

vtkIdType vtkGeometryFilter::PointMinimum [protected]

Definition at line 170 of file vtkGeometryFilter.h.

vtkIdType vtkGeometryFilter::CellMinimum [protected]

Definition at line 171 of file vtkGeometryFilter.h.

vtkIdType vtkGeometryFilter::CellMaximum [protected]

Definition at line 172 of file vtkGeometryFilter.h.

float vtkGeometryFilter::Extent[6] [protected]

Definition at line 173 of file vtkGeometryFilter.h.

int vtkGeometryFilter::PointClipping [protected]

Definition at line 174 of file vtkGeometryFilter.h.

int vtkGeometryFilter::CellClipping [protected]

Definition at line 175 of file vtkGeometryFilter.h.

int vtkGeometryFilter::ExtentClipping [protected]

Definition at line 176 of file vtkGeometryFilter.h.

int vtkGeometryFilter::Merging [protected]

Definition at line 178 of file vtkGeometryFilter.h.

vtkPointLocator* vtkGeometryFilter::Locator [protected]

Definition at line 179 of file vtkGeometryFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkGeometryFilter.h
Generated on Mon Mar 25 01:18:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGESignaReader Class Reference

read GE Signa ximg files. More...

#include <vtkGESignaReader.h>

Inheritance diagram for vtkGESignaReader:

[legend]
Collaboration diagram for vtkGESignaReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGESignaReader, vtkImageReader2)
virtual vtkImageReader2 * | MakeObject ()
virtual int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkGESignaReader * | New ()

Protected Methods

vtkGESignaReader ()
~vtkGESignaReader ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)

Detailed Description

read GE Signa ximg files.

Date:
2002/02/14 17:03:45
Revision:
1.7

vtkGESignaReader is a source object that reads some GE Signa ximg files It does support reading in pixel spacing, slice spacing and it computes an origin for the image in millimeters. It always produces greyscale unsigned short data and it supports reading in rectangular, packed, compressed, and packed&compressed. It does not read in slice orientation, or position right now. To use it you just need to specify a filename or a file prefix and pattern.

See also:
vtkImageReader2
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (92%)
  • Hoffman, Bill (6%)
Tests:
vtkGESignaReader (Tests)

Definition at line 51 of file vtkGESignaReader.h.

Constructor & Destructor Documentation

vtkGESignaReader::vtkGESignaReader ( ) [inline, protected]

Definition at line 79 of file vtkGESignaReader.h.

vtkGESignaReader::~vtkGESignaReader ( ) [inline, protected]

Definition at line 80 of file vtkGESignaReader.h.

Member Function Documentation

vtkGESignaReader* vtkGESignaReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkMedicalImageReader2.

Referenced by MakeObject().

vtkGESignaReader::vtkTypeRevisionMacro | ( | vtkGESignaReader | ,
 |  | vtkImageReader2 |
 | ) |

Reimplemented from vtkMedicalImageReader2.

virtual vtkImageReader2* vtkGESignaReader::MakeObject ( ) [inline, virtual]

Set/Get the internal file name

Reimplemented from vtkImageReader2.

Definition at line 57 of file vtkGESignaReader.h.

virtual int vtkGESignaReader::CanReadFile ( const char * fname ) [virtual]

virtual const char* vtkGESignaReader::GetFileExensions ( ) [inline, virtual]

Valid extentsions

Reimplemented from vtkImageReader2.

Definition at line 64 of file vtkGESignaReader.h.

virtual const char* vtkGESignaReader::GetDescriptiveName ( ) [inline, virtual]

A descriptive name for this format

Reimplemented from vtkImageReader2.

Definition at line 72 of file vtkGESignaReader.h.

virtual void vtkGESignaReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

virtual void vtkGESignaReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

The documentation for this class was generated from the following file:
  • IO/vtkGESignaReader.h
Generated on Mon Mar 25 01:18:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGLUTesselatorTriangleFilter Class Reference

create triangle polygons from input polygons and triangle strips. More...

#include <vtkGLUTesselatorTriangleFilter.h>

Inheritance diagram for vtkGLUTesselatorTriangleFilter:

[legend]
Collaboration diagram for vtkGLUTesselatorTriangleFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGLUTesselatorTriangleFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | PassVertsOn ()
virtual void | PassVertsOff ()
virtual void | SetPassVerts (int)
virtual int | GetPassVerts ()
virtual void | PassLinesOn ()
virtual void | PassLinesOff ()
virtual void | SetPassLines (int)
virtual int | GetPassLines ()

Static Public Methods

vtkGLUTesselatorTriangleFilter * | New ()

Protected Methods

vtkGLUTesselatorTriangleFilter ()
~vtkGLUTesselatorTriangleFilter ()
void | Execute ()

Protected Attributes

int | PassVerts
int | PassLines
GLUtesselator * | GLUTesselator

Detailed Description

create triangle polygons from input polygons and triangle strips.

Date:
2002/01/22 15:30:29
Revision:
1.6

vtkGLUTesselatorTriangleFilter generates triangles from input polygons and triangle strips. The filter also will pass through vertices and lines, if requested.

This filter is a specialized version of vtkTriangleFilter. It uses glu code to perform the tessellation. To use this filter, you will have to link against a GLU library.

See also:
vtkTriangleFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (97%)

Definition at line 46 of file vtkGLUTesselatorTriangleFilter.h.

Constructor & Destructor Documentation

vtkGLUTesselatorTriangleFilter::vtkGLUTesselatorTriangleFilter ( ) [protected]

vtkGLUTesselatorTriangleFilter::~vtkGLUTesselatorTriangleFilter ( ) [protected]

Member Function Documentation

vtkGLUTesselatorTriangleFilter* vtkGLUTesselatorTriangleFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkGLUTesselatorTriangleFilter::vtkTypeRevisionMacro | ( | vtkGLUTesselatorTriangleFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkGLUTesselatorTriangleFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkGLUTesselatorTriangleFilter::PassVertsOn ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkGLUTesselatorTriangleFilter::PassVertsOff ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkGLUTesselatorTriangleFilter::SetPassVerts ( int ) [virtual]

Turn on/off passing vertices through filter.

virtual int vtkGLUTesselatorTriangleFilter::GetPassVerts ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkGLUTesselatorTriangleFilter::PassLinesOn ( ) [virtual]

Turn on/off passing lines through filter.

virtual void vtkGLUTesselatorTriangleFilter::PassLinesOff ( ) [virtual]

Turn on/off passing lines through filter.

virtual void vtkGLUTesselatorTriangleFilter::SetPassLines ( int ) [virtual]

Turn on/off passing lines through filter.

virtual int vtkGLUTesselatorTriangleFilter::GetPassLines ( ) [virtual]

Turn on/off passing lines through filter.

void vtkGLUTesselatorTriangleFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkGLUTesselatorTriangleFilter::PassVerts [protected]

Definition at line 75 of file vtkGLUTesselatorTriangleFilter.h.

int vtkGLUTesselatorTriangleFilter::PassLines [protected]

Definition at line 76 of file vtkGLUTesselatorTriangleFilter.h.

GLUtesselator* vtkGLUTesselatorTriangleFilter::GLUTesselator [protected]

Definition at line 77 of file vtkGLUTesselatorTriangleFilter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkGLUTesselatorTriangleFilter.h
Generated on Mon Mar 25 01:18:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyph2D Class Reference

copy oriented and scaled glyph geometry to every input point (2D specialization). More...

#include <vtkGlyph2D.h>

Inheritance diagram for vtkGlyph2D:

[legend]
Collaboration diagram for vtkGlyph2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGlyph2D, vtkGlyph3D)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkGlyph2D * | New ()

Protected Methods

vtkGlyph2D ()
~vtkGlyph2D ()
void | Execute ()

Detailed Description

copy oriented and scaled glyph geometry to every input point (2D specialization).

Date:
2002/01/22 15:29:22
Revision:
1.7

This subclass of vtkGlyph3D is a specialization to 2D. Transformations (i.e., translation, scaling, and rotation) are constrained to the plane. For example, rotations due to a vector are computed from the x-y coordinates of the vector only, and are assumed to occur around the z-axis. (See vtkGlyph3D for documentation on the interface to this class.)

See also:
vtkTensorGlyph vtkGlyph3D vtkProgrammableGlyphFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Geveci, Berk (13%)
Tests:
vtkGlyph2D (Tests)

Definition at line 48 of file vtkGlyph2D.h.

Constructor & Destructor Documentation

vtkGlyph2D::vtkGlyph2D ( ) [inline, protected]

Definition at line 61 of file vtkGlyph2D.h.

vtkGlyph2D::~vtkGlyph2D ( ) [inline, protected]

Definition at line 62 of file vtkGlyph2D.h.

Member Function Documentation

vtkGlyph2D::vtkTypeRevisionMacro | ( | vtkGlyph2D | ,
 |  | vtkGlyph3D |
 | ) |

Reimplemented from vtkGlyph3D.

void vtkGlyph2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkGlyph3D.

vtkGlyph2D* vtkGlyph2D::New ( ) [static]

Construct object with scaling on, scaling mode is by scalar value, scale factor = 1.0, the range is (0,1), orient geometry is on, and orientation is by vector. Clamping and indexing are turned off. No initial sources are defined.

Reimplemented from vtkGlyph3D.

void vtkGlyph2D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkGlyph3D.

The documentation for this class was generated from the following file:
  • Graphics/vtkGlyph2D.h
Generated on Mon Mar 25 01:18:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyph3D Class Reference

copy oriented and scaled glyph geometry to every input point. More...

#include <vtkGlyph3D.h>

Inheritance diagram for vtkGlyph3D:

[legend]
Collaboration diagram for vtkGlyph3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGlyph3D, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSource (vtkPolyData *pd)
void | SetSource (int id, vtkPolyData *pd)
vtkPolyData * | GetSource (int id=0)
void | SetNumberOfSources (int num)
int | GetNumberOfSources ()
virtual void | SetScaling (int)
virtual void | ScalingOn ()
virtual void | ScalingOff ()
virtual int | GetScaling ()
virtual void | SetScaleMode (int)
virtual int | GetScaleMode ()
void | SetScaleModeToScaleByScalar ()
void | SetScaleModeToScaleByVector ()
void | SetScaleModeToScaleByVectorComponents ()
void | SetScaleModeToDataScalingOff ()
const char * | GetScaleModeAsString ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToColorByScale ()
void | SetColorModeToColorByScalar ()
void | SetColorModeToColorByVector ()
const char * | GetColorModeAsString ()
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetRange (float, float)
void | SetRange (float[2])
virtual float * | GetRange ()
virtual void | GetRange (float data[2])
virtual void | SetOrient (int)
virtual void | OrientOn ()
virtual void | OrientOff ()
virtual int | GetOrient ()
virtual void | SetClamping (int)
virtual void | ClampingOn ()
virtual void | ClampingOff ()
virtual int | GetClamping ()
virtual void | SetVectorMode (int)
virtual int | GetVectorMode ()
void | SetVectorModeToUseVector ()
void | SetVectorModeToUseNormal ()
void | SetVectorModeToVectorRotationOff ()
const char * | GetVectorModeAsString ()
virtual void | SetIndexMode (int)
virtual int | GetIndexMode ()
void | SetIndexModeToScalar ()
void | SetIndexModeToVector ()
void | SetIndexModeToOff ()
const char * | GetIndexModeAsString ()
virtual void | SetGeneratePointIds (int)
virtual int | GetGeneratePointIds ()
virtual void | GeneratePointIdsOn ()
virtual void | GeneratePointIdsOff ()
virtual void | SetPointIdsName (const char *)
virtual char * | GetPointIdsName ()

Static Public Methods

vtkGlyph3D * | New ()

Protected Methods

vtkGlyph3D ()
~vtkGlyph3D ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | NumberOfSources
vtkPolyData ** Source
int | Scaling
int | ScaleMode
int | ColorMode
float | ScaleFactor
float | Range [2]
int | Orient
int | VectorMode
int | Clamping
int | IndexMode
int | GeneratePointIds
char * | PointIdsName

Detailed Description

copy oriented and scaled glyph geometry to every input point.

Date:
2002/01/22 15:29:22
Revision:
1.54

vtkGlyph3D is a filter that copies a geometric representation (called a glyph) to every point in the input dataset. The glyph is defined with polygonal data from a source filter input. The glyph may be oriented along the input vectors or normals, and it may be scaled according to scalar data or vector magnitude. More than one glyph may be used by creating a table of source objects, each defining a different glyph. If a table of glyphs is defined, then the table can be indexed into by using either scalar value or vector magnitude.

To use this object you'll have to provide an input dataset and a source to define the glyph. Then decide whether you want to scale the glyph and how to scale the glyph (using scalar value or vector magnitude). Next decide whether you want to orient the glyph, and whether to use the vector data or normal data to orient it. Finally, decide whether to use a table of glyphs, or just a single glyph. If you use a table of glyphs, you'll have to decide whether to index into it with scalar value or with vector magnitude.

Warning:
The scaling of the glyphs is controlled by the ScaleFactor ivar multiplied by the scalar value at each point (if VTK_SCALE_BY_SCALAR is set), or multiplied by the vector magnitude (if VTK_SCALE_BY_VECTOR is set), Alternatively (if VTK_SCALE_BY_VECTORCOMPONENTS is set), the scaling may be specified for x,y,z using the vector components. The scale factor can be further controlled by enabling clamping using the Clamping ivar. If clamping is enabled, the scale is normalized by the Range ivar, and then multiplied by the scale factor. The normalization process includes clamping the scale value between (0,1).
Warning:
Typically this object operates on input data with scalar and/or vector data. However, scalar and/or vector aren't necessary, and it can be used to copy data from a single source to each point. In this case the scale factor can be used to uniformly scale the glyphs.
Warning:
The object uses "vector" data to scale glyphs, orient glyphs, and/or index into a table of glyphs. You can choose to use either the vector or normal data at each input point. Use the method SetVectorModeToUseVector() to use the vector input data, and SetVectorModeToUseNormal() to use the normal input data.
Warning:
If you do use a table of glyphs, make sure to set the Range ivar to make sure the index into the glyph table is computed correctly.
Warning:
You can turn off scaling of the glyphs completely by using the Scaling ivar. You can also turn off scaling due to data (either vector or scalar) by using the SetScaleModeToDataScalingOff() method.
See also:
vtkTensorGlyph
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Lorensen, Bill (11%)
  • Martin, Ken (8%)
  • Law, Charles (5%)
Examples:
vtkGlyph3D (Examples)
Tests:
vtkGlyph3D (Tests)

Definition at line 114 of file vtkGlyph3D.h.

Constructor & Destructor Documentation

vtkGlyph3D::vtkGlyph3D ( ) [protected]

vtkGlyph3D::~vtkGlyph3D ( ) [protected]

Member Function Documentation

vtkGlyph3D::vtkTypeRevisionMacro | ( | vtkGlyph3D | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

Reimplemented in vtkGlyph2D.

void vtkGlyph3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkGlyph2D.

vtkGlyph3D* vtkGlyph3D::New ( ) [static]

Construct object with scaling on, scaling mode is by scalar value, scale factor = 1.0, the range is (0,1), orient geometry is on, and orientation is by vector. Clamping and indexing are turned off. No initial sources are defined.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkGlyph2D.

void vtkGlyph3D::SetNumberOfSources ( int num )

Get the number of source objects used to define the glyph table. Specify the number of sources before defining a table of glyphs.

int vtkGlyph3D::GetNumberOfSources ( )

Get the number of source objects used to define the glyph table. Specify the number of sources before defining a table of glyphs.

void vtkGlyph3D::SetSource ( vtkPolyData * pd ) [inline]

Set the source to use for he glyph.

Definition at line 134 of file vtkGlyph3D.h.

void vtkGlyph3D::SetSource | ( | int | id,
 |  | vtkPolyData * | pd
 | ) |

Specify a source object at a specified table location.

vtkPolyData* vtkGlyph3D::GetSource ( int id = 0 )

Get a pointer to a source object at a specified table location.

virtual void vtkGlyph3D::SetScaling ( int ) [virtual]

Turn on/off scaling of source geometry.

virtual void vtkGlyph3D::ScalingOn ( ) [virtual]

Turn on/off scaling of source geometry.

virtual void vtkGlyph3D::ScalingOff ( ) [virtual]

Turn on/off scaling of source geometry.

virtual int vtkGlyph3D::GetScaling ( ) [virtual]

Turn on/off scaling of source geometry.

virtual void vtkGlyph3D::SetScaleMode ( int ) [virtual]

Either scale by scalar or by vector/normal magnitude.

virtual int vtkGlyph3D::GetScaleMode ( ) [virtual]

Either scale by scalar or by vector/normal magnitude.

void vtkGlyph3D::SetScaleModeToScaleByScalar ( ) [inline]

Either scale by scalar or by vector/normal magnitude.

Definition at line 153 of file vtkGlyph3D.h.

void vtkGlyph3D::SetScaleModeToScaleByVector ( ) [inline]

Either scale by scalar or by vector/normal magnitude.

Definition at line 155 of file vtkGlyph3D.h.

void vtkGlyph3D::SetScaleModeToScaleByVectorComponents ( ) [inline]

Either scale by scalar or by vector/normal magnitude.

Definition at line 157 of file vtkGlyph3D.h.

void vtkGlyph3D::SetScaleModeToDataScalingOff ( ) [inline]

Either scale by scalar or by vector/normal magnitude.

Definition at line 159 of file vtkGlyph3D.h.

const char * vtkGlyph3D::GetScaleModeAsString ( void ) [inline]

Return the method of scaling as a descriptive character string.

Definition at line 272 of file vtkGlyph3D.h.

virtual void vtkGlyph3D::SetColorMode ( int ) [virtual]

Either color by scale, scalar or by vector/normal magnitude.

virtual int vtkGlyph3D::GetColorMode ( ) [virtual]

Either color by scale, scalar or by vector/normal magnitude.

void vtkGlyph3D::SetColorModeToColorByScale ( ) [inline]

Either color by scale, scalar or by vector/normal magnitude.

Definition at line 168 of file vtkGlyph3D.h.

void vtkGlyph3D::SetColorModeToColorByScalar ( ) [inline]

Either color by scale, scalar or by vector/normal magnitude.

Definition at line 170 of file vtkGlyph3D.h.

void vtkGlyph3D::SetColorModeToColorByVector ( ) [inline]

Either color by scale, scalar or by vector/normal magnitude.

Definition at line 172 of file vtkGlyph3D.h.

const char * vtkGlyph3D::GetColorModeAsString ( void ) [inline]

Return the method of coloring as a descriptive character string.

Definition at line 289 of file vtkGlyph3D.h.

virtual void vtkGlyph3D::SetScaleFactor ( float ) [virtual]

Specify scale factor to scale object by.

virtual float vtkGlyph3D::GetScaleFactor ( ) [virtual]

Specify scale factor to scale object by.

virtual void vtkGlyph3D::SetRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify range to map scalar values into.

void vtkGlyph3D::SetRange ( float [2] )

Specify range to map scalar values into.

virtual float* vtkGlyph3D::GetRange ( ) [virtual]

Specify range to map scalar values into.

virtual void vtkGlyph3D::GetRange ( float data[2] ) [virtual]

Specify range to map scalar values into.

virtual void vtkGlyph3D::SetOrient ( int ) [virtual]

Turn on/off orienting of input geometry along vector/normal.

virtual void vtkGlyph3D::OrientOn ( ) [virtual]

Turn on/off orienting of input geometry along vector/normal.

virtual void vtkGlyph3D::OrientOff ( ) [virtual]

Turn on/off orienting of input geometry along vector/normal.

virtual int vtkGlyph3D::GetOrient ( ) [virtual]

Turn on/off orienting of input geometry along vector/normal.

virtual void vtkGlyph3D::SetClamping ( int ) [virtual]

Turn on/off clamping of "scalar" values to range. (Scalar value may be vector magnitude if ScaleByVector() is enabled.)

virtual void vtkGlyph3D::ClampingOn ( ) [virtual]

Turn on/off clamping of "scalar" values to range. (Scalar value may be vector magnitude if ScaleByVector() is enabled.)

virtual void vtkGlyph3D::ClampingOff ( ) [virtual]

Turn on/off clamping of "scalar" values to range. (Scalar value may be vector magnitude if ScaleByVector() is enabled.)

virtual int vtkGlyph3D::GetClamping ( ) [virtual]

Turn on/off clamping of "scalar" values to range. (Scalar value may be vector magnitude if ScaleByVector() is enabled.)

virtual void vtkGlyph3D::SetVectorMode ( int ) [virtual]

Specify whether to use vector or normal to perform vector operations.

virtual int vtkGlyph3D::GetVectorMode ( ) [virtual]

Specify whether to use vector or normal to perform vector operations.

void vtkGlyph3D::SetVectorModeToUseVector ( ) [inline]

Specify whether to use vector or normal to perform vector operations.

Definition at line 208 of file vtkGlyph3D.h.

void vtkGlyph3D::SetVectorModeToUseNormal ( ) [inline]

Specify whether to use vector or normal to perform vector operations.

Definition at line 209 of file vtkGlyph3D.h.

void vtkGlyph3D::SetVectorModeToVectorRotationOff ( ) [inline]

Specify whether to use vector or normal to perform vector operations.

Definition at line 210 of file vtkGlyph3D.h.

const char * vtkGlyph3D::GetVectorModeAsString ( void ) [inline]

Return the vector mode as a character string.

Definition at line 306 of file vtkGlyph3D.h.

virtual void vtkGlyph3D::SetIndexMode ( int ) [virtual]

Index into table of sources by scalar, by vector/normal magnitude, or no indexing. If indexing is turned off, then the first source glyph in the table of glyphs is used.

virtual int vtkGlyph3D::GetIndexMode ( ) [virtual]

Index into table of sources by scalar, by vector/normal magnitude, or no indexing. If indexing is turned off, then the first source glyph in the table of glyphs is used.

void vtkGlyph3D::SetIndexModeToScalar ( ) [inline]

Index into table of sources by scalar, by vector/normal magnitude, or no indexing. If indexing is turned off, then the first source glyph in the table of glyphs is used.

Definition at line 221 of file vtkGlyph3D.h.

void vtkGlyph3D::SetIndexModeToVector ( ) [inline]

Index into table of sources by scalar, by vector/normal magnitude, or no indexing. If indexing is turned off, then the first source glyph in the table of glyphs is used.

Definition at line 222 of file vtkGlyph3D.h.

void vtkGlyph3D::SetIndexModeToOff ( ) [inline]

Index into table of sources by scalar, by vector/normal magnitude, or no indexing. If indexing is turned off, then the first source glyph in the table of glyphs is used.

Definition at line 223 of file vtkGlyph3D.h.

const char * vtkGlyph3D::GetIndexModeAsString ( void ) [inline]

Return the index mode as a character string.

Definition at line 323 of file vtkGlyph3D.h.

virtual void vtkGlyph3D::SetGeneratePointIds ( int ) [virtual]

Enable/disable the generation of point ids as part of the output. The point ids are the id of the input generating point. The point ids are stored in the output point field data and named "InputPointIds". Point generation is useful for debugging and pick operations.

virtual int vtkGlyph3D::GetGeneratePointIds ( ) [virtual]

Enable/disable the generation of point ids as part of the output. The point ids are the id of the input generating point. The point ids are stored in the output point field data and named "InputPointIds". Point generation is useful for debugging and pick operations.

virtual void vtkGlyph3D::GeneratePointIdsOn ( ) [virtual]

Enable/disable the generation of point ids as part of the output. The point ids are the id of the input generating point. The point ids are stored in the output point field data and named "InputPointIds". Point generation is useful for debugging and pick operations.

virtual void vtkGlyph3D::GeneratePointIdsOff ( ) [virtual]

Enable/disable the generation of point ids as part of the output. The point ids are the id of the input generating point. The point ids are stored in the output point field data and named "InputPointIds". Point generation is useful for debugging and pick operations.

virtual void vtkGlyph3D::SetPointIdsName ( const char * ) [virtual]

Set/Get the name of the PointIds array if generated. By default the Ids are named "InputPointIds", but this can be changed with this function.

virtual char* vtkGlyph3D::GetPointIdsName ( ) [virtual]

Set/Get the name of the PointIds array if generated. By default the Ids are named "InputPointIds", but this can be changed with this function.

void vtkGlyph3D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkGlyph2D.

void vtkGlyph3D::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkGlyph3D::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

Do not let images return more than requested.

Reimplemented from vtkDataSetToPolyDataFilter.

Member Data Documentation

int vtkGlyph3D::NumberOfSources [protected]

Definition at line 252 of file vtkGlyph3D.h.

vtkPolyData** vtkGlyph3D::Source [protected]

Definition at line 253 of file vtkGlyph3D.h.

int vtkGlyph3D::Scaling [protected]

Definition at line 254 of file vtkGlyph3D.h.

int vtkGlyph3D::ScaleMode [protected]

Definition at line 255 of file vtkGlyph3D.h.

int vtkGlyph3D::ColorMode [protected]

Definition at line 256 of file vtkGlyph3D.h.

float vtkGlyph3D::ScaleFactor [protected]

Definition at line 257 of file vtkGlyph3D.h.

float vtkGlyph3D::Range[2] [protected]

Definition at line 258 of file vtkGlyph3D.h.

int vtkGlyph3D::Orient [protected]

Definition at line 259 of file vtkGlyph3D.h.

int vtkGlyph3D::VectorMode [protected]

Definition at line 260 of file vtkGlyph3D.h.

int vtkGlyph3D::Clamping [protected]

Definition at line 261 of file vtkGlyph3D.h.

int vtkGlyph3D::IndexMode [protected]

Definition at line 262 of file vtkGlyph3D.h.

int vtkGlyph3D::GeneratePointIds [protected]

Definition at line 263 of file vtkGlyph3D.h.

char* vtkGlyph3D::PointIdsName [protected]

Definition at line 264 of file vtkGlyph3D.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkGlyph3D.h
Generated on Mon Mar 25 01:18:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGlyphSource2D Class Reference

create 2D glyphs represented by vtkPolyData. More...

#include <vtkGlyphSource2D.h>

Inheritance diagram for vtkGlyphSource2D:

[legend]
Collaboration diagram for vtkGlyphSource2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGlyphSource2D, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetScale (float)
virtual float | GetScale ()
virtual void | SetScale2 (float)
virtual float | GetScale2 ()
virtual void | SetColor (float, float, float)
virtual void | SetColor (float[3])
virtual float * | GetColor ()
virtual void | GetColor (float data[3])
virtual void | SetFilled (int)
virtual int | GetFilled ()
virtual void | FilledOn ()
virtual void | FilledOff ()
virtual void | SetDash (int)
virtual int | GetDash ()
virtual void | DashOn ()
virtual void | DashOff ()
virtual void | SetCross (int)
virtual int | GetCross ()
virtual void | CrossOn ()
virtual void | CrossOff ()
virtual void | SetRotationAngle (float)
virtual float | GetRotationAngle ()
virtual void | SetGlyphType (int)
virtual int | GetGlyphType ()
void | SetGlyphTypeToNone ()
void | SetGlyphTypeToVertex ()
void | SetGlyphTypeToDash ()
void | SetGlyphTypeToCross ()
void | SetGlyphTypeToThickCross ()
void | SetGlyphTypeToTriangle ()
void | SetGlyphTypeToSquare ()
void | SetGlyphTypeToCircle ()
void | SetGlyphTypeToDiamond ()
void | SetGlyphTypeToArrow ()
void | SetGlyphTypeToThickArrow ()
void | SetGlyphTypeToHookedArrow ()

Static Public Methods

vtkGlyphSource2D * | New ()

Protected Methods

vtkGlyphSource2D ()
~vtkGlyphSource2D ()
void | Execute ()
void | TransformGlyph (vtkPoints *pts)
void | ConvertColor ()
void | CreateVertex (vtkPoints *pts, vtkCellArray *verts, vtkUnsignedCharArray *colors)
void | CreateDash (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale)
void | CreateCross (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale)
void | CreateThickCross (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateTriangle (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateSquare (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateCircle (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateDiamond (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateArrow (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateThickArrow (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)
void | CreateHookedArrow (vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors)

Protected Attributes

float | Center [3]
float | Scale
float | Scale2
float | Color [3]
int | Filled
int | Dash
int | Cross
int | GlyphType
float | RotationAngle
unsigned char | RGB [3]

Detailed Description

create 2D glyphs represented by vtkPolyData.

Date:
2002/01/22 15:29:22
Revision:
1.11

vtkGlyphSource2D can generate a family of 2D glyphs each of which lies in the x-y plane (i.e., the z-coordinate is zero). The class is a helper class to be used with vtkGlyph2D and vtkXYPlotActor.

To use this class, specify the glyph type to use and its attributes. Attributes include its position (i.e., center point), scale, color, and whether the symbol is filled or not (a polygon or closed line sequence). You can also put a short line through the glyph running from -x to +x (the glyph looks like it's on a line), or a cross.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (90%)
Examples:
vtkGlyphSource2D (Examples)
Tests:
vtkGlyphSource2D (Tests)

Definition at line 63 of file vtkGlyphSource2D.h.

Constructor & Destructor Documentation

vtkGlyphSource2D::vtkGlyphSource2D ( ) [protected]

vtkGlyphSource2D::~vtkGlyphSource2D ( ) [inline, protected]

Definition at line 154 of file vtkGlyphSource2D.h.

Member Function Documentation

vtkGlyphSource2D::vtkTypeRevisionMacro | ( | vtkGlyphSource2D | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkGlyphSource2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkGlyphSource2D* vtkGlyphSource2D::New ( ) [static]

Construct a vertex glyph centered at the origin, scale 1.0, white in color, filled, with line segment passing through the point.

Reimplemented from vtkPolyDataSource.

virtual void vtkGlyphSource2D::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the glyph. By default the center is (0,0,0).

virtual void vtkGlyphSource2D::SetCenter ( float [3] ) [virtual]

Set the center of the glyph. By default the center is (0,0,0).

virtual float* vtkGlyphSource2D::GetCenter ( ) [virtual]

Set the center of the glyph. By default the center is (0,0,0).

virtual void vtkGlyphSource2D::GetCenter ( float data[3] ) [virtual]

Set the center of the glyph. By default the center is (0,0,0).

virtual void vtkGlyphSource2D::SetScale ( float ) [virtual]

Set the scale of the glyph. Note that the glyphs are designed to fit in the (1,1) rectangle.

virtual float vtkGlyphSource2D::GetScale ( ) [virtual]

Set the scale of the glyph. Note that the glyphs are designed to fit in the (1,1) rectangle.

virtual void vtkGlyphSource2D::SetScale2 ( float ) [virtual]

Set the scale of optional portions of the glyph (e.g., the dash and cross is DashOn() and CrossOn()).

virtual float vtkGlyphSource2D::GetScale2 ( ) [virtual]

Set the scale of optional portions of the glyph (e.g., the dash and cross is DashOn() and CrossOn()).

virtual void vtkGlyphSource2D::SetColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the color of the glyph. The default color is white.

virtual void vtkGlyphSource2D::SetColor ( float [3] ) [virtual]

Set the color of the glyph. The default color is white.

virtual float* vtkGlyphSource2D::GetColor ( ) [virtual]

Set the color of the glyph. The default color is white.

virtual void vtkGlyphSource2D::GetColor ( float data[3] ) [virtual]

Set the color of the glyph. The default color is white.

virtual void vtkGlyphSource2D::SetFilled ( int ) [virtual]

Specify whether the glyph is filled (a polygon) or not (a closed polygon defined by line segments). This only applies to 2D closed glyphs.

virtual int vtkGlyphSource2D::GetFilled ( ) [virtual]

Specify whether the glyph is filled (a polygon) or not (a closed polygon defined by line segments). This only applies to 2D closed glyphs.

virtual void vtkGlyphSource2D::FilledOn ( ) [virtual]

Specify whether the glyph is filled (a polygon) or not (a closed polygon defined by line segments). This only applies to 2D closed glyphs.

virtual void vtkGlyphSource2D::FilledOff ( ) [virtual]

Specify whether the glyph is filled (a polygon) or not (a closed polygon defined by line segments). This only applies to 2D closed glyphs.

virtual void vtkGlyphSource2D::SetDash ( int ) [virtual]

Specify whether a short line segment is drawn through the glyph. (This is in addition to the glyph. If the glyph type is set to "Dash" there is no need to enable this flag.)

virtual int vtkGlyphSource2D::GetDash ( ) [virtual]

Specify whether a short line segment is drawn through the glyph. (This is in addition to the glyph. If the glyph type is set to "Dash" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::DashOn ( ) [virtual]

Specify whether a short line segment is drawn through the glyph. (This is in addition to the glyph. If the glyph type is set to "Dash" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::DashOff ( ) [virtual]

Specify whether a short line segment is drawn through the glyph. (This is in addition to the glyph. If the glyph type is set to "Dash" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::SetCross ( int ) [virtual]

Specify whether a cross is drawn as part of the glyph. (This is in addition to the glyph. If the glyph type is set to "Cross" there is no need to enable this flag.)

virtual int vtkGlyphSource2D::GetCross ( ) [virtual]

Specify whether a cross is drawn as part of the glyph. (This is in addition to the glyph. If the glyph type is set to "Cross" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::CrossOn ( ) [virtual]

Specify whether a cross is drawn as part of the glyph. (This is in addition to the glyph. If the glyph type is set to "Cross" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::CrossOff ( ) [virtual]

Specify whether a cross is drawn as part of the glyph. (This is in addition to the glyph. If the glyph type is set to "Cross" there is no need to enable this flag.)

virtual void vtkGlyphSource2D::SetRotationAngle ( float ) [virtual]

Specify an angle (in degrees) to rotate the glyph around the z-axis. Using this ivar, it is possible to generate rotated glyphs (e.g., crosses, arrows, etc.)

virtual float vtkGlyphSource2D::GetRotationAngle ( ) [virtual]

Specify an angle (in degrees) to rotate the glyph around the z-axis. Using this ivar, it is possible to generate rotated glyphs (e.g., crosses, arrows, etc.)

virtual void vtkGlyphSource2D::SetGlyphType ( int ) [virtual]

Specify the type of glyph to generate.

virtual int vtkGlyphSource2D::GetGlyphType ( ) [virtual]

Specify the type of glyph to generate.

void vtkGlyphSource2D::SetGlyphTypeToNone ( ) [inline]

Specify the type of glyph to generate.

Definition at line 138 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToVertex ( ) [inline]

Specify the type of glyph to generate.

Definition at line 139 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToDash ( ) [inline]

Specify the type of glyph to generate.

Definition at line 140 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToCross ( ) [inline]

Specify the type of glyph to generate.

Definition at line 141 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToThickCross ( ) [inline]

Specify the type of glyph to generate.

Definition at line 142 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToTriangle ( ) [inline]

Specify the type of glyph to generate.

Definition at line 143 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToSquare ( ) [inline]

Specify the type of glyph to generate.

Definition at line 144 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToCircle ( ) [inline]

Specify the type of glyph to generate.

Definition at line 145 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToDiamond ( ) [inline]

Specify the type of glyph to generate.

Definition at line 146 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToArrow ( ) [inline]

Specify the type of glyph to generate.

Definition at line 147 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToThickArrow ( ) [inline]

Specify the type of glyph to generate.

Definition at line 148 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::SetGlyphTypeToHookedArrow ( ) [inline]

Specify the type of glyph to generate.

Definition at line 149 of file vtkGlyphSource2D.h.

void vtkGlyphSource2D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkGlyphSource2D::TransformGlyph ( vtkPoints * pts ) [protected]

void vtkGlyphSource2D::ConvertColor ( ) [protected]

void vtkGlyphSource2D::CreateVertex | ( | vtkPoints * | pts,
 |  | vtkCellArray * | verts,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateDash | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors,
 |  | float | scale
 | ) | [protected]

void vtkGlyphSource2D::CreateCross | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors,
 |  | float | scale
 | ) | [protected]

void vtkGlyphSource2D::CreateThickCross | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateTriangle | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateSquare | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateCircle | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateDiamond | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateArrow | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateThickArrow | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

void vtkGlyphSource2D::CreateHookedArrow | ( | vtkPoints * | pts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkUnsignedCharArray * | colors
 | ) | [protected]

Member Data Documentation

float vtkGlyphSource2D::Center[3] [protected]

Definition at line 158 of file vtkGlyphSource2D.h.

float vtkGlyphSource2D::Scale [protected]

Definition at line 159 of file vtkGlyphSource2D.h.

float vtkGlyphSource2D::Scale2 [protected]

Definition at line 160 of file vtkGlyphSource2D.h.

float vtkGlyphSource2D::Color[3] [protected]

Definition at line 161 of file vtkGlyphSource2D.h.

int vtkGlyphSource2D::Filled [protected]

Definition at line 162 of file vtkGlyphSource2D.h.

int vtkGlyphSource2D::Dash [protected]

Definition at line 163 of file vtkGlyphSource2D.h.

int vtkGlyphSource2D::Cross [protected]

Definition at line 164 of file vtkGlyphSource2D.h.

int vtkGlyphSource2D::GlyphType [protected]

Definition at line 165 of file vtkGlyphSource2D.h.

float vtkGlyphSource2D::RotationAngle [protected]

Definition at line 166 of file vtkGlyphSource2D.h.

unsigned char vtkGlyphSource2D::RGB[3] [protected]

Definition at line 170 of file vtkGlyphSource2D.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkGlyphSource2D.h
Generated on Mon Mar 25 01:18:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGraphicsFactory Class Reference

#include <vtkGraphicsFactory.h>

Inheritance diagram for vtkGraphicsFactory:

[legend]
Collaboration diagram for vtkGraphicsFactory:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGraphicsFactory, vtkObject)

Static Public Methods

vtkGraphicsFactory * | New ()
vtkObject * | CreateInstance (const char *vtkclassname)
const char * | GetRenderLibrary ()

Protected Methods

vtkGraphicsFactory ()

Detailed Description

Date:
2002/01/22 15:38:32
Revision:
1.11
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (74%)
  • Hoffman, Bill (10%)
  • Starreveld, Yves (6%)

Definition at line 36 of file vtkGraphicsFactory.h.

Constructor & Destructor Documentation

vtkGraphicsFactory::vtkGraphicsFactory ( ) [inline, protected]

Definition at line 50 of file vtkGraphicsFactory.h.

Member Function Documentation

vtkGraphicsFactory* vtkGraphicsFactory::New ( ) [inline, static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Definition at line 39 of file vtkGraphicsFactory.h.

vtkGraphicsFactory::vtkTypeRevisionMacro | ( | vtkGraphicsFactory | ,
 |  | vtkObject |
 | ) |

vtkObject* vtkGraphicsFactory::CreateInstance ( const char * vtkclassname ) [static]

Create and return an instance of the named vtk object. This method first checks the vtkObjectFactory to support dynamic loading.

const char* vtkGraphicsFactory::GetRenderLibrary ( ) [static]

What rendering library has the user requested

Referenced by vtkRenderWindow::GetRenderLibrary().

The documentation for this class was generated from the following file:
  • Rendering/vtkGraphicsFactory.h
Generated on Mon Mar 25 01:18:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGraphLayoutFilter Class Reference

nice layout of undirected graphs in 3D. More...

#include <vtkGraphLayoutFilter.h>

Inheritance diagram for vtkGraphLayoutFilter:

[legend]
Collaboration diagram for vtkGraphLayoutFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGraphLayoutFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetThreeDimensionalLayout (int)
virtual int | GetThreeDimensionalLayout ()
virtual void | ThreeDimensionalLayoutOn ()
virtual void | ThreeDimensionalLayoutOff ()
virtual void | SetGraphBounds (float, float, float, float, float, float)
virtual void | SetGraphBounds (float[6])
virtual float * | GetGraphBounds ()
virtual void | GetGraphBounds (float data[6])
virtual void | SetAutomaticBoundsComputation (int)
virtual int | GetAutomaticBoundsComputation ()
virtual void | AutomaticBoundsComputationOn ()
virtual void | AutomaticBoundsComputationOff ()
virtual void | SetMaxNumberOfIterations (int)
virtual int | GetMaxNumberOfIterations ()
virtual void | SetCoolDownRate (float)
virtual float | GetCoolDownRate ()

Static Public Methods

vtkGraphLayoutFilter * | New ()

Protected Methods

vtkGraphLayoutFilter ()
~vtkGraphLayoutFilter ()
void | Execute ()

Protected Attributes

float | GraphBounds [6]
int | AutomaticBoundsComputation
int | MaxNumberOfIterations
float | CoolDownRate
int | ThreeDimensionalLayout

Detailed Description

nice layout of undirected graphs in 3D.

Date:
2002/01/22 15:29:22
Revision:
1.7

vtkGraphLayoutFilter will reposition a network of nodes, connected by lines or polylines, into a more pleasing arrangement. The class implements a simple force-directed placement algorithm (Fruchterman & Reingold "Graph Drawing by Force-directed Placement" Software-Practice and Experience 21(11) 1991).

The input to the filter is a vtkPolyData representing the undirected graphs. A graph is represented by a set of polylines and/or lines. The output is also a vtkPolyData, where the point positions have been modified. To use the filter, specify whether you wish the layout to occur in 2D or 3D; the bounds in which the graph should lie (note that you can just use automatic bounds computation); and modify the cool down rate (controls the final process of simulated annealing).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (99%)
Tests:
vtkGraphLayoutFilter (Tests)

Definition at line 51 of file vtkGraphLayoutFilter.h.

Constructor & Destructor Documentation

vtkGraphLayoutFilter::vtkGraphLayoutFilter ( ) [protected]

vtkGraphLayoutFilter::~vtkGraphLayoutFilter ( ) [inline, protected]

Definition at line 101 of file vtkGraphLayoutFilter.h.

Member Function Documentation

vtkGraphLayoutFilter* vtkGraphLayoutFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkGraphLayoutFilter::vtkTypeRevisionMacro | ( | vtkGraphLayoutFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkGraphLayoutFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkGraphLayoutFilter::SetGraphBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the region in space in which to place the final graph. The GraphBounds only affects the results if AutomaticBoundsComputation is off.

virtual void vtkGraphLayoutFilter::SetGraphBounds ( float [6] ) [virtual]

Set / get the region in space in which to place the final graph. The GraphBounds only affects the results if AutomaticBoundsComputation is off.

virtual float* vtkGraphLayoutFilter::GetGraphBounds ( ) [virtual]

Set / get the region in space in which to place the final graph. The GraphBounds only affects the results if AutomaticBoundsComputation is off.

virtual void vtkGraphLayoutFilter::GetGraphBounds ( float data[6] ) [virtual]

Set / get the region in space in which to place the final graph. The GraphBounds only affects the results if AutomaticBoundsComputation is off.

virtual void vtkGraphLayoutFilter::SetAutomaticBoundsComputation ( int ) [virtual]

Turn on/off automatic graph bounds calculation. If this boolean is off, then the manually specified GraphBounds is used. If on, then the input's bounds us used as the graph bounds.

virtual int vtkGraphLayoutFilter::GetAutomaticBoundsComputation ( ) [virtual]

Turn on/off automatic graph bounds calculation. If this boolean is off, then the manually specified GraphBounds is used. If on, then the input's bounds us used as the graph bounds.

virtual void vtkGraphLayoutFilter::AutomaticBoundsComputationOn ( ) [virtual]

Turn on/off automatic graph bounds calculation. If this boolean is off, then the manually specified GraphBounds is used. If on, then the input's bounds us used as the graph bounds.

virtual void vtkGraphLayoutFilter::AutomaticBoundsComputationOff ( ) [virtual]

Turn on/off automatic graph bounds calculation. If this boolean is off, then the manually specified GraphBounds is used. If on, then the input's bounds us used as the graph bounds.

virtual void vtkGraphLayoutFilter::SetMaxNumberOfIterations ( int ) [virtual]

Set/Get the maximum number of iterations to be used. The higher this number, the more iterations through the algorithm is possible, and thus, the more the graph gets modified.

virtual int vtkGraphLayoutFilter::GetMaxNumberOfIterations ( ) [virtual]

Set/Get the maximum number of iterations to be used. The higher this number, the more iterations through the algorithm is possible, and thus, the more the graph gets modified.

virtual void vtkGraphLayoutFilter::SetCoolDownRate ( float ) [virtual]

Set/Get the Cool-down rate. The higher this number is, the longer it will take to "cool-down", and thus, the more the graph will be modified.

virtual float vtkGraphLayoutFilter::GetCoolDownRate ( ) [virtual]

Set/Get the Cool-down rate. The higher this number is, the longer it will take to "cool-down", and thus, the more the graph will be modified.

virtual void vtkGraphLayoutFilter::SetThreeDimensionalLayout ( int ) [virtual]

virtual int vtkGraphLayoutFilter::GetThreeDimensionalLayout ( ) [virtual]

virtual void vtkGraphLayoutFilter::ThreeDimensionalLayoutOn ( ) [virtual]

virtual void vtkGraphLayoutFilter::ThreeDimensionalLayoutOff ( ) [virtual]

void vtkGraphLayoutFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkGraphLayoutFilter::GraphBounds[6] [protected]

Definition at line 105 of file vtkGraphLayoutFilter.h.

int vtkGraphLayoutFilter::AutomaticBoundsComputation [protected]

Definition at line 106 of file vtkGraphLayoutFilter.h.

int vtkGraphLayoutFilter::MaxNumberOfIterations [protected]

Definition at line 107 of file vtkGraphLayoutFilter.h.

float vtkGraphLayoutFilter::CoolDownRate [protected]

Definition at line 108 of file vtkGraphLayoutFilter.h.

int vtkGraphLayoutFilter::ThreeDimensionalLayout [protected]

Definition at line 109 of file vtkGraphLayoutFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkGraphLayoutFilter.h
Generated on Mon Mar 25 01:18:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGridSynchronizedTemplates3D Class Reference

generate isosurface from structured grids. More...

#include <vtkGridSynchronizedTemplates3D.h>

Inheritance diagram for vtkGridSynchronizedTemplates3D:

[legend]
Collaboration diagram for vtkGridSynchronizedTemplates3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGridSynchronizedTemplates3D, vtkStructuredGridToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | SetInputMemoryLimit (long limit)
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
int * | GetExecuteExtent ()
void | ThreadedExecute (int *exExt, int threadId)
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkGridSynchronizedTemplates3D * | New ()

Protected Methods

vtkGridSynchronizedTemplates3D ()
~vtkGridSynchronizedTemplates3D ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkContourValues * ContourValues
int | NumberOfThreads
vtkMultiThreader * Threader
int | MinimumPieceSize [3]
int | ExecuteExtent [6]
vtkPolyData * | Threads [VTK_MAX_THREADS]
char * | InputScalarsSelection

Friends

class VTK_PATENTED_EXPORT | vtkKitwareContourFilter

Detailed Description

generate isosurface from structured grids.

Date:
2002/01/22 22:02:19
Revision:
1.29

vtkGridSynchronizedTemplates3D is a 3D implementation of the synchronized template algorithm.

Warning:
This filter is specialized to 3D grids.
See also:
vtkContourFilter vtkSynchronizedTemplates3D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (71%)
  • Schroeder, Will (11%)
  • Geveci, Berk (5%)

Definition at line 62 of file vtkGridSynchronizedTemplates3D.h.

Constructor & Destructor Documentation

vtkGridSynchronizedTemplates3D::vtkGridSynchronizedTemplates3D ( ) [protected]

vtkGridSynchronizedTemplates3D::~vtkGridSynchronizedTemplates3D ( ) [protected]

Member Function Documentation

vtkGridSynchronizedTemplates3D* vtkGridSynchronizedTemplates3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkGridSynchronizedTemplates3D::vtkTypeRevisionMacro | ( | vtkGridSynchronizedTemplates3D | ,
 |  | vtkStructuredGridToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredGridToPolyDataFilter.

void vtkGridSynchronizedTemplates3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

unsigned long int vtkGridSynchronizedTemplates3D::GetMTime ( ) [virtual]

Because we delegate to vtkContourValues

Reimplemented from vtkObject.

virtual void vtkGridSynchronizedTemplates3D::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkGridSynchronizedTemplates3D::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkGridSynchronizedTemplates3D::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkGridSynchronizedTemplates3D::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkGridSynchronizedTemplates3D::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkGridSynchronizedTemplates3D::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkGridSynchronizedTemplates3D::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

void vtkGridSynchronizedTemplates3D::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 103 of file vtkGridSynchronizedTemplates3D.h.

float vtkGridSynchronizedTemplates3D::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 106 of file vtkGridSynchronizedTemplates3D.h.

float* vtkGridSynchronizedTemplates3D::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 110 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 116 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 124 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 130 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 137 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 144 of file vtkGridSynchronizedTemplates3D.h.

int* vtkGridSynchronizedTemplates3D::GetExecuteExtent ( ) [inline]

Needed by templated functions.

Definition at line 150 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::ThreadedExecute | ( | int * | exExt,
 |  | int | threadId
 | ) |

Needed by templated functions.

virtual void vtkGridSynchronizedTemplates3D::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create when rendering

virtual int vtkGridSynchronizedTemplates3D::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create when rendering

void vtkGridSynchronizedTemplates3D::SetInputMemoryLimit ( long limit )

This filter will initiate streaming so that no piece requested from the input will be larger than this value (KiloBytes).

virtual char* vtkGridSynchronizedTemplates3D::GetInputScalarsSelection ( ) [virtual]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkGridSynchronizedTemplates3D::SelectInputScalars ( const char * fieldName ) [inline]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 169 of file vtkGridSynchronizedTemplates3D.h.

void vtkGridSynchronizedTemplates3D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkGridSynchronizedTemplates3D::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkGridSynchronizedTemplates3D::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

virtual void vtkGridSynchronizedTemplates3D::SetInputScalarsSelection ( const char * ) [protected, virtual]

Friends And Related Function Documentation

friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter [friend]

Definition at line 199 of file vtkGridSynchronizedTemplates3D.h.

Member Data Documentation

int vtkGridSynchronizedTemplates3D::ComputeNormals [protected]

Definition at line 182 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::ComputeGradients [protected]

Definition at line 183 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::ComputeScalars [protected]

Definition at line 184 of file vtkGridSynchronizedTemplates3D.h.

vtkContourValues* vtkGridSynchronizedTemplates3D::ContourValues [protected]

Definition at line 185 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::NumberOfThreads [protected]

Definition at line 187 of file vtkGridSynchronizedTemplates3D.h.

vtkMultiThreader* vtkGridSynchronizedTemplates3D::Threader [protected]

Definition at line 188 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::MinimumPieceSize[3] [protected]

Definition at line 189 of file vtkGridSynchronizedTemplates3D.h.

int vtkGridSynchronizedTemplates3D::ExecuteExtent[6] [protected]

Definition at line 190 of file vtkGridSynchronizedTemplates3D.h.

vtkPolyData* vtkGridSynchronizedTemplates3D::Threads[VTK_MAX_THREADS] [protected]

Definition at line 192 of file vtkGridSynchronizedTemplates3D.h.

char* vtkGridSynchronizedTemplates3D::InputScalarsSelection [protected]

Definition at line 194 of file vtkGridSynchronizedTemplates3D.h.

The documentation for this class was generated from the following file:
  • Patented/vtkGridSynchronizedTemplates3D.h
Generated on Mon Mar 25 01:18:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkGridTransform Class Reference

a nonlinear warp transformation. More...

#include <vtkGridTransform.h>

Inheritance diagram for vtkGridTransform:

[legend]
Collaboration diagram for vtkGridTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkGridTransform, vtkWarpTransform)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
vtkAbstractTransform * MakeTransform ()
unsigned long | GetMTime ()
virtual void | SetDisplacementGrid (vtkImageData *)
virtual vtkImageData * | GetDisplacementGrid ()
virtual void | SetDisplacementScale (float)
virtual float | GetDisplacementScale ()
virtual void | SetDisplacementShift (float)
virtual float | GetDisplacementShift ()
void | SetInterpolationMode (int mode)
virtual int | GetInterpolationMode ()
void | SetInterpolationModeToNearestNeighbor ()
void | SetInterpolationModeToLinear ()
void | SetInterpolationModeToCubic ()
const char * | GetInterpolationModeAsString ()

Static Public Methods

vtkGridTransform * | New ()

Protected Methods

vtkGridTransform ()
~vtkGridTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)
void | ForwardTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | ForwardTransformDerivative (const double in[3], double out[3], double derivative[3][3])
void | InverseTransformPoint (const float in[3], float out[3])
void | InverseTransformPoint (const double in[3], double out[3])
void | InverseTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InverseTransformDerivative (const double in[3], double out[3], double derivative[3][3])
void | ForwardTransformPoint (const float in[3], float out[3])
void | ForwardTransformPoint (const double in[3], double out[3])

Protected Attributes

void(* | InterpolationFunction )(float point[3], float displacement[3], float derivatives[3][3], void *gridPtr, int gridType, int inExt[6], int inInc[3])
int | InterpolationMode
vtkImageData * DisplacementGrid
float | DisplacementScale
float | DisplacementShift

Detailed Description

a nonlinear warp transformation.

Date:
2002/01/22 15:30:30
Revision:
1.11

vtkGridTransform describes a nonlinear warp transformation as a set of displacement vectors sampled along a uniform 3D grid.

Warning:
The inverse grid transform is calculated using an iterative method, and is several times more expensive than the forward transform.
See also:
vtkThinPlateSplineTransform vtkGeneralTransform vtkTransformToGrid
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)
Tests:
vtkGridTransform (Tests)

Definition at line 50 of file vtkGridTransform.h.

Constructor & Destructor Documentation

vtkGridTransform::vtkGridTransform ( ) [protected]

vtkGridTransform::~vtkGridTransform ( ) [protected]

Member Function Documentation

vtkGridTransform* vtkGridTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkGridTransform::vtkTypeRevisionMacro | ( | vtkGridTransform | ,
 |  | vtkWarpTransform |
 | ) |

Reimplemented from vtkWarpTransform.

virtual void vtkGridTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWarpTransform.

virtual void vtkGridTransform::SetDisplacementGrid ( vtkImageData * ) [virtual]

Set/Get the grid transform (the grid transform must have three components for displacement in x, y, and z respectively). The vtkGridTransform class will never modify the data.

virtual vtkImageData* vtkGridTransform::GetDisplacementGrid ( ) [virtual]

Set/Get the grid transform (the grid transform must have three components for displacement in x, y, and z respectively). The vtkGridTransform class will never modify the data.

virtual void vtkGridTransform::SetDisplacementScale ( float ) [virtual]

Set scale factor to be applied to the displacements. This is used primarily for grids which contain integer data types. Default: 1

virtual float vtkGridTransform::GetDisplacementScale ( ) [virtual]

Set scale factor to be applied to the displacements. This is used primarily for grids which contain integer data types. Default: 1

virtual void vtkGridTransform::SetDisplacementShift ( float ) [virtual]

Set a shift to be applied to the displacements. The shift is applied after the scale, i.e. x = scale*y + shift. Default: 0

virtual float vtkGridTransform::GetDisplacementShift ( ) [virtual]

Set a shift to be applied to the displacements. The shift is applied after the scale, i.e. x = scale*y + shift. Default: 0

void vtkGridTransform::SetInterpolationMode ( int mode )

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

virtual int vtkGridTransform::GetInterpolationMode ( ) [virtual]

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

void vtkGridTransform::SetInterpolationModeToNearestNeighbor ( ) [inline]

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

Definition at line 84 of file vtkGridTransform.h.

void vtkGridTransform::SetInterpolationModeToLinear ( ) [inline]

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

Definition at line 86 of file vtkGridTransform.h.

void vtkGridTransform::SetInterpolationModeToCubic ( ) [inline]

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

Definition at line 88 of file vtkGridTransform.h.

const char * vtkGridTransform::GetInterpolationModeAsString ( ) [inline]

Set interpolation mode for sampling the grid. Higher-order interpolation allows you to use a sparser grid. Default: Linear.

Definition at line 146 of file vtkGridTransform.h.

vtkAbstractTransform* vtkGridTransform::MakeTransform ( ) [virtual]

Make another transform of the same type.

Reimplemented from vtkAbstractTransform.

unsigned long vtkGridTransform::GetMTime ( ) [virtual]

Get the MTime.

Reimplemented from vtkAbstractTransform.

void vtkGridTransform::InternalUpdate ( ) [protected, virtual]

Update the displacement grid.

Reimplemented from vtkAbstractTransform.

void vtkGridTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

Copy this transform from another of the same type.

Reimplemented from vtkAbstractTransform.

void vtkGridTransform::ForwardTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [protected, virtual]

Internal functions for calculating the transformation.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::ForwardTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [protected, virtual]

Internal functions for calculating the transformation.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::ForwardTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [protected, virtual]

Calculate the forward transform as well as the derivative.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::ForwardTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [protected, virtual]

Calculate the forward transform as well as the derivative.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::InverseTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 1, then a call to InternalTransformPoint results in a call to InverseTransformPoint. The inverse transformation is calculated from using Newton's method.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::InverseTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 1, then a call to InternalTransformPoint results in a call to InverseTransformPoint. The inverse transformation is calculated from using Newton's method.

Reimplemented from vtkWarpTransform.

void vtkGridTransform::InverseTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [protected, virtual]

Calculate the inverse transform as well as the derivative of the forward transform (that's correct: the derivative of the forward transform, not of the inverse transform)

Reimplemented from vtkWarpTransform.

void vtkGridTransform::InverseTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [protected, virtual]

Calculate the inverse transform as well as the derivative of the forward transform (that's correct: the derivative of the forward transform, not of the inverse transform)

Reimplemented from vtkWarpTransform.

Member Data Documentation

void(* vtkGridTransform::InterpolationFunction)(float point[3], float displacement[3], float derivatives[3][3], void *gridPtr, int gridType, int inExt[6], int inInc[3]) [protected]

int vtkGridTransform::InterpolationMode [protected]

Definition at line 134 of file vtkGridTransform.h.

vtkImageData* vtkGridTransform::DisplacementGrid [protected]

Definition at line 135 of file vtkGridTransform.h.

float vtkGridTransform::DisplacementScale [protected]

Definition at line 136 of file vtkGridTransform.h.

float vtkGridTransform::DisplacementShift [protected]

Definition at line 137 of file vtkGridTransform.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkGridTransform.h
Generated on Mon Mar 25 01:18:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHeap Class Reference

replacement for malloc/free and new/delete. More...

#include <vtkHeap.h>

Inheritance diagram for vtkHeap:

[legend]
Collaboration diagram for vtkHeap:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHeap, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void * | AllocateMemory (size_t n)
char * | vtkStrDup (const char *str)
virtual int | GetNumberOfAllocations ()

Static Public Methods

vtkHeap * | New ()

Protected Methods

vtkHeap ()
~vtkHeap ()
void | Add (vtkHeapNode *node)
void | CleanAll ()
vtkHeapNode * DeleteAndNext ()

Protected Attributes

vtkHeapNode * First
vtkHeapNode * Last
vtkHeapNode * Current
int | NumberOfAllocations

Detailed Description

replacement for malloc/free and new/delete.

Date:
2002/01/22 15:25:25
Revision:
1.8

This class is a replacement for malloc/free and new/delete for software that has inherent memory leak problems. For example, external software such as the PLY library (vtkPLY) and VRML importer (vtkVRMLImporter) are often written with lots of malloc() calls but without the corresponding free() invocations. This class allows the replacement of malloc() with the method AllocateMemory(). Memory is then deleted with an invocation of CleanUp().

Warning:
Do not use this method as a replacement for system memory allocation. This class should be used only as a last resort if memory leaks cannot be tracked down and eliminated by conventional means.
See also:
vtkVRMLImporter vtkPLY
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (89%)

Definition at line 60 of file vtkHeap.h.

Constructor & Destructor Documentation

vtkHeap::vtkHeap ( ) [protected]

vtkHeap::~vtkHeap ( ) [protected]

Member Function Documentation

vtkHeap* vtkHeap::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkHeap::vtkTypeRevisionMacro | ( | vtkHeap | ,
 |  | vtkObject |
 | ) |

void vtkHeap::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void* vtkHeap::AllocateMemory ( size_t n )

Allocate the memory requested.

char* vtkHeap::vtkStrDup ( const char * str )

Convenience method performs string duplication.

virtual int vtkHeap::GetNumberOfAllocations ( ) [virtual]

Get the number of allocations thus far.

void vtkHeap::Add ( vtkHeapNode * node ) [protected]

void vtkHeap::CleanAll ( ) [protected]

vtkHeapNode* vtkHeap::DeleteAndNext ( ) [protected]

Member Data Documentation

vtkHeapNode* vtkHeap::First [protected]

Definition at line 86 of file vtkHeap.h.

vtkHeapNode* vtkHeap::Last [protected]

Definition at line 87 of file vtkHeap.h.

vtkHeapNode* vtkHeap::Current [protected]

Definition at line 88 of file vtkHeap.h.

int vtkHeap::NumberOfAllocations [protected]

Definition at line 90 of file vtkHeap.h.

The documentation for this class was generated from the following file:
  • Common/vtkHeap.h
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHeapNode Class Reference

#include <vtkHeap.h>

Collaboration diagram for vtkHeapNode:

[legend]
List of all members.

Public Methods

vtkHeapNode ()

Public Attributes

void * | Ptr
vtkHeapNode * | Next

Constructor & Destructor Documentation

vtkHeapNode::vtkHeapNode ( ) [inline]

Definition at line 56 of file vtkHeap.h.

Member Data Documentation

void* vtkHeapNode::Ptr

Definition at line 54 of file vtkHeap.h.

vtkHeapNode* vtkHeapNode::Next

Definition at line 55 of file vtkHeap.h.

The documentation for this class was generated from the following file:
  • Common/vtkHeap.h
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHedgeHog Class Reference

create oriented lines from vector data. More...

#include <vtkHedgeHog.h>

Inheritance diagram for vtkHedgeHog:

[legend]
Collaboration diagram for vtkHedgeHog:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHedgeHog, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetVectorMode (int)
virtual int | GetVectorMode ()
void | SetVectorModeToUseVector ()
void | SetVectorModeToUseNormal ()
const char * | GetVectorModeAsString ()

Static Public Methods

vtkHedgeHog * | New ()

Protected Methods

vtkHedgeHog ()
~vtkHedgeHog ()
void | Execute ()

Protected Attributes

float | ScaleFactor
int | VectorMode

Detailed Description

create oriented lines from vector data.

Date:
2002/01/22 15:29:23
Revision:
1.34

vtkHedgeHog creates oriented lines from the input data set. Line length is controlled by vector (or normal) magnitude times scale factor. If VectorMode is UseNormal, normals determine the orientation of the lines. Lines are colored by scalar data, if available.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (57%)
  • Lorensen, Bill (21%)
  • Martin, Ken (9%)
  • Geveci, Berk (6%)
Examples:
vtkHedgeHog (Examples)
Tests:
vtkHedgeHog (Tests)

Definition at line 51 of file vtkHedgeHog.h.

Constructor & Destructor Documentation

vtkHedgeHog::vtkHedgeHog ( ) [protected]

vtkHedgeHog::~vtkHedgeHog ( ) [inline, protected]

Definition at line 75 of file vtkHedgeHog.h.

Member Function Documentation

vtkHedgeHog* vtkHedgeHog::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkHedgeHog::vtkTypeRevisionMacro | ( | vtkHedgeHog | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkHedgeHog::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkHedgeHog::SetScaleFactor ( float ) [virtual]

Set scale factor to control size of oriented lines.

virtual float vtkHedgeHog::GetScaleFactor ( ) [virtual]

Set scale factor to control size of oriented lines.

virtual void vtkHedgeHog::SetVectorMode ( int ) [virtual]

Specify whether to use vector or normal to perform vector operations.

virtual int vtkHedgeHog::GetVectorMode ( ) [virtual]

Specify whether to use vector or normal to perform vector operations.

void vtkHedgeHog::SetVectorModeToUseVector ( ) [inline]

Specify whether to use vector or normal to perform vector operations.

Definition at line 68 of file vtkHedgeHog.h.

void vtkHedgeHog::SetVectorModeToUseNormal ( ) [inline]

Specify whether to use vector or normal to perform vector operations.

Definition at line 69 of file vtkHedgeHog.h.

const char * vtkHedgeHog::GetVectorModeAsString ( void ) [inline]

Return the vector mode as a character string.

Definition at line 87 of file vtkHedgeHog.h.

void vtkHedgeHog::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkHedgeHog::ScaleFactor [protected]

Definition at line 78 of file vtkHedgeHog.h.

int vtkHedgeHog::VectorMode [protected]

Definition at line 79 of file vtkHedgeHog.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkHedgeHog.h
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHexahedron Class Reference

a cell that represents a 3D rectangular hexahedron. More...

#include <vtkHexahedron.h>

Inheritance diagram for vtkHexahedron:

[legend]
Collaboration diagram for vtkHexahedron:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHexahedron, vtkCell)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
void | JacobianInverse (float pcoords[3], double **inverse, float derivs[24])
virtual void | GetEdgePoints (int edgeId, int *&pts)
virtual void | GetFacePoints (int faceId, int *&pts)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)

Static Public Methods

vtkHexahedron * | New ()
void | InterpolationFunctions (float pcoords[3], float weights[8])
void | InterpolationDerivs (float pcoords[3], float derivs[24])
int * | GetEdgeArray (int edgeId)
int * | GetFaceArray (int faceId)

Protected Methods

vtkHexahedron ()
~vtkHexahedron ()

Protected Attributes

vtkLine * Line
vtkQuad * Quad

Detailed Description

a cell that represents a 3D rectangular hexahedron.

Date:
2002/01/22 15:25:25
Revision:
1.60

vtkHexahedron is a concrete implementation of vtkCell to represent a 3D rectangular hexahedron (e.g., "brick" topology).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Miller, Jim (7%)
  • Geveci, Berk (7%)
  • Law, Charles (5%)
Examples:
vtkHexahedron (Examples)
Tests:
vtkHexahedron (Tests)

Definition at line 48 of file vtkHexahedron.h.

Constructor & Destructor Documentation

vtkHexahedron::vtkHexahedron ( ) [protected]

vtkHexahedron::~vtkHexahedron ( ) [protected]

Member Function Documentation

vtkHexahedron* vtkHexahedron::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkHexahedron::vtkTypeRevisionMacro | ( | vtkHexahedron | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell3D.

virtual void vtkHexahedron::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

virtual void vtkHexahedron::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

vtkCell* vtkHexahedron::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkHexahedron::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 63 of file vtkHexahedron.h.

int vtkHexahedron::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 64 of file vtkHexahedron.h.

int vtkHexahedron::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 65 of file vtkHexahedron.h.

vtkCell* vtkHexahedron::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkHexahedron::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkHexahedron::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkHexahedron::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkHexahedron::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

Given a point x[3] return inside(=1) or outside(=0) cell; evaluate parametric coordinates, sub-cell id (!=0 only if cell is composite), distance squared of point x[3] to cell (in particular, the sub-cell indicated), closest point on cell to x[3] (unless closestPoint is null, in which case, the closest point and dist2 are not found), and interpolation weights in cell. (The number of weights is equal to the number of points defining the cell). Note: on rare occasions a -1 is returned from the method. This means that numerical error has occurred and all data returned from this method should be ignored. Also, inside/outside is determine parametrically. That is, a point is inside if it satisfies parametric limits. This can cause problems for cells of topological dimension 2 or less, since a point in 3D can project onto the cell within parametric limits but be "far" from the cell. Thus the value dist2 may be checked to determine true in/out.

Reimplemented from vtkCell.

void vtkHexahedron::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

Determine global coordinate (x[3]) from subId and parametric coordinates. Also returns interpolation weights. (The number of weights is equal to the number of points in the cell.)

Reimplemented from vtkCell.

int vtkHexahedron::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Intersect with a ray. Return parametric coordinates (both line and cell) and global intersection coordinates, given ray definition and tolerance. The method returns non-zero value if intersection occurs.

Reimplemented from vtkCell.

int vtkHexahedron::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

Generate simplices of proper dimension. If cell is 3D, tetrahedron are generated; if 2D triangles; if 1D lines; if 0D points. The form of the output is a sequence of points, each n+1 points (where n is topological cell dimension) defining a simplex. The index is a parameter that controls which triangulation to use (if more than one is possible). If numerical degeneracy encountered, 0 is returned, otherwise 1 is returned.

Reimplemented from vtkCell.

void vtkHexahedron::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

Compute derivatives given cell subId and parametric coordinates. The values array is a series of data value(s) at the cell points. There is a one-to-one correspondence between cell point and data value(s). Dim is the number of data values per cell point. Derivs are derivatives in the x-y-z coordinate directions for each data value. Thus, if computing derivatives for a scalar function in a hexahedron, dim=1, 8 values are supplied, and 3 deriv values are returned (i.e., derivatives in x-y-z directions). On the other hand, if computing derivatives of velocity (vx,vy,vz) dim=3, 24 values are supplied ((vx,vy,vz)1, (vx,vy,vz)2, ....()8), and 9 deriv values are returned ((d(vx)/dx),(d(vx)/dy),(d(vx)/dz), (d(vy)/dx),(d(vy)/dy), (d(vy)/dz), (d(vz)/dx),(d(vz)/dy),(d(vz)/dz)).

Reimplemented from vtkCell.

void vtkHexahedron::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[8]
 | ) | [static]

Hexahedron specific

void vtkHexahedron::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[24]
 | ) | [static]

Hexahedron specific

int* vtkHexahedron::GetEdgeArray ( int edgeId ) [static]

Hexahedron specific

int* vtkHexahedron::GetFaceArray ( int faceId ) [static]

Hexahedron specific

void vtkHexahedron::JacobianInverse | ( | float | pcoords[3],
 |  | double ** | inverse,
 |  | float | derivs[24]
 | ) |

Given parametric coordinates compute inverse Jacobian transformation matrix. Returns 9 elements of 3x3 inverse Jacobian plus interpolation function derivatives.

Member Data Documentation

vtkLine* vtkHexahedron::Line [protected]

Definition at line 104 of file vtkHexahedron.h.

vtkQuad* vtkHexahedron::Quad [protected]

Definition at line 105 of file vtkHexahedron.h.

The documentation for this class was generated from the following file:
  • Common/vtkHexahedron.h
Generated on Mon Mar 25 01:18:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHomogeneousTransform Class Reference

superclass for homogeneous transformations. More...

#include <vtkHomogeneousTransform.h>

Inheritance diagram for vtkHomogeneousTransform:

[legend]
Collaboration diagram for vtkHomogeneousTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHomogeneousTransform, vtkAbstractTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | TransformPoints (vtkPoints *inPts, vtkPoints *outPts)
void | GetMatrix (vtkMatrix4x4 *m)
vtkMatrix4x4 * GetMatrix ()
virtual void | TransformPointsNormalsVectors (vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs)
vtkHomogeneousTransform * | GetHomogeneousInverse ()
void | InternalTransformPoint (const float in[3], float out[3])
void | InternalTransformPoint (const double in[3], double out[3])
void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Protected Methods

vtkHomogeneousTransform ()
~vtkHomogeneousTransform ()
void | InternalDeepCopy (vtkAbstractTransform *transform)

Protected Attributes

vtkMatrix4x4 * Matrix

Detailed Description

superclass for homogeneous transformations.

Date:
2002/01/22 15:25:26
Revision:
1.14

vtkHomogeneousTransform provides a generic interface for homogeneous transformations, i.e. transformations which can be represented by multiplying a 4x4 matrix with a homogeneous coordinate.

See also:
vtkPerspectiveTransform vtkLinearTransform vtkIdentityTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (84%)
  • Geveci, Berk (10%)

Definition at line 42 of file vtkHomogeneousTransform.h.

Constructor & Destructor Documentation

vtkHomogeneousTransform::vtkHomogeneousTransform ( ) [protected]

vtkHomogeneousTransform::~vtkHomogeneousTransform ( ) [protected]

Member Function Documentation

vtkHomogeneousTransform::vtkTypeRevisionMacro | ( | vtkHomogeneousTransform | ,
 |  | vtkAbstractTransform |
 | ) |

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, vtkLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

void vtkHomogeneousTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, vtkLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

void vtkHomogeneousTransform::TransformPoints | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts
 | ) | [virtual]

Apply the transformation to a series of points, and append the results to outPts.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

virtual void vtkHomogeneousTransform::TransformPointsNormalsVectors | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts,
 |  | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms,
 |  | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a combination of points, normals and vectors.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

void vtkHomogeneousTransform::GetMatrix ( vtkMatrix4x4 * m )

Get a copy of the internal transformation matrix. The transform is Updated first, to guarantee that the matrix is valid.

vtkMatrix4x4* vtkHomogeneousTransform::GetMatrix ( ) [inline]

Get a pointer to an internal vtkMatrix4x4 that represents the transformation. An Update() is called on the transform to ensure that the matrix is up-to-date when you get it. You should not store the matrix pointer anywhere because it might become stale.

Definition at line 72 of file vtkHomogeneousTransform.h.

Referenced by vtkTransform::MultiplyPoint().

vtkHomogeneousTransform* vtkHomogeneousTransform::GetHomogeneousInverse ( ) [inline]

Just like GetInverse(), but includes typecast to vtkHomogeneousTransform.

Definition at line 77 of file vtkHomogeneousTransform.h.

void vtkHomogeneousTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

void vtkHomogeneousTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

void vtkHomogeneousTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

void vtkHomogeneousTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, and vtkLinearTransform.

void vtkHomogeneousTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkIdentityTransform, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

Member Data Documentation

vtkMatrix4x4* vtkHomogeneousTransform::Matrix [protected]

Definition at line 103 of file vtkHomogeneousTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkHomogeneousTransform.h
Generated on Mon Mar 25 01:18:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHull Class Reference

produce an n-sided convex hull. More...

#include <vtkHull.h>

Inheritance diagram for vtkHull:

[legend]
Collaboration diagram for vtkHull:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHull, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RemoveAllPlanes (void)
void | SetPlanes (vtkPlanes *planes)
void | AddCubeVertexPlanes ()
void | AddCubeEdgePlanes ()
void | AddCubeFacePlanes ()
void | AddRecursiveSpherePlanes (int level)
int | AddPlane (float A, float B, float C)
int | AddPlane (float plane[3])
void | SetPlane (int i, float A, float B, float C)
void | SetPlane (int i, float plane[3])
int | AddPlane (float A, float B, float C, float D)
int | AddPlane (float plane[3], float D)
void | SetPlane (int i, float A, float B, float C, float D)
void | SetPlane (int i, float plane[3], float D)
virtual int | GetNumberOfPlanes ()
void | GenerateHull (vtkPolyData *pd, float *bounds)
void | GenerateHull (vtkPolyData *pd, float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)

Static Public Methods

vtkHull * | New ()

Protected Methods

vtkHull ()
~vtkHull ()
void | ComputePlaneDistances ()
void | ClipPolygonsFromPlanes (vtkPoints *points, vtkCellArray *polys, float *bounds)
void | CreateInitialPolygon (double *, int, float *)
void | Execute ()

Protected Attributes

double * | Planes
int | PlanesStorageSize
int | NumberOfPlanes

Detailed Description

produce an n-sided convex hull.

Date:
2002/01/22 15:29:23
Revision:
1.19

vtkHull is a filter which will produce an n-sided convex hull given a set of n planes. (The convex hull bounds the input polygonal data.) The hull is generated by squeezing the planes towards the input vtkPolyData, until the planes just touch the vtkPolyData. Then, the resulting planes are used to generate a polyhedron (i.e., hull) that is represented by triangles.

The n planes can be defined in a number of ways including 1) manually specifying each plane; 2) choosing the six face planes of the input's bounding box; 3) choosing the eight vertex planes of the input's bounding box; 4) choosing the twelve edge planes of the input's bounding box; and/or 5) using a recursively subdivided octahedron. Note that when specifying planes, the plane normals should point outside of the convex region.

The output of this filter can be used in combination with vtkLODActor to represent a levels-of-detail in the LOD hierarchy. Another use of this class is to manually specify the planes, and then generate the polyhedron from the planes (without squeezing the planes towards the input). The method GenerateHull() is used to do this.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (48%)
  • Schroeder, Will (44%)
Tests:
vtkHull (Tests)

Definition at line 61 of file vtkHull.h.

Constructor & Destructor Documentation

vtkHull::vtkHull ( ) [protected]

vtkHull::~vtkHull ( ) [protected]

Member Function Documentation

vtkHull* vtkHull::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkHull::vtkTypeRevisionMacro | ( | vtkHull | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkHull::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkHull::RemoveAllPlanes ( void )

Remove all planes from the current set of planes.

int vtkHull::AddPlane | ( | float | A,
 |  | float | B,
 |  | float | C
 | ) |

Add a plane to the current set of planes. It will be added at the end of the list, and an index that can later be used to set this plane's normal will be returned. The values A, B, C are from the plane equation Ax + By + Cz + D = 0. This vector does not have to have unit length (but it must have a non-zero length!). If a value 0 > i >= -NumberOfPlanes is returned, then the plane is parallel with a previously inserted plane, and |-i-1| is the index of the plane that was previously inserted. If a value i < -NumberOfPlanes is returned, then the plane normal is zero length.

int vtkHull::AddPlane ( float plane[3] )

Add a plane to the current set of planes. It will be added at the end of the list, and an index that can later be used to set this plane's normal will be returned. The values A, B, C are from the plane equation Ax + By + Cz + D = 0. This vector does not have to have unit length (but it must have a non-zero length!). If a value 0 > i >= -NumberOfPlanes is returned, then the plane is parallel with a previously inserted plane, and |-i-1| is the index of the plane that was previously inserted. If a value i < -NumberOfPlanes is returned, then the plane normal is zero length.

void vtkHull::SetPlane | ( | int | i,
 |  | float | A,
 |  | float | B,
 |  | float | C
 | ) |

Set the normal values for plane i. This is a plane that was already added to the current set of planes with AddPlane(), and is now being modified. The values A, B, C are from the plane equation Ax + By + Cz + D = 0. This vector does not have to have unit length. Note that D is set to zero, except in the case of the method taking a vtkPlanes* argument, where it is set to the D value defined there.

void vtkHull::SetPlane | ( | int | i,
 |  | float | plane[3]
 | ) |

Set the normal values for plane i. This is a plane that was already added to the current set of planes with AddPlane(), and is now being modified. The values A, B, C are from the plane equation Ax + By + Cz + D = 0. This vector does not have to have unit length. Note that D is set to zero, except in the case of the method taking a vtkPlanes* argument, where it is set to the D value defined there.

int vtkHull::AddPlane | ( | float | A,
 |  | float | B,
 |  | float | C,
 |  | float | D
 | ) |

Variations of AddPlane()/SetPlane() that allow D to be set. These methods are used when GenerateHull() is used.

int vtkHull::AddPlane | ( | float | plane[3],
 |  | float | D
 | ) |

Variations of AddPlane()/SetPlane() that allow D to be set. These methods are used when GenerateHull() is used.

void vtkHull::SetPlane | ( | int | i,
 |  | float | A,
 |  | float | B,
 |  | float | C,
 |  | float | D
 | ) |

Variations of AddPlane()/SetPlane() that allow D to be set. These methods are used when GenerateHull() is used.

void vtkHull::SetPlane | ( | int | i,
 |  | float | plane[3],
 |  | float | D
 | ) |

Variations of AddPlane()/SetPlane() that allow D to be set. These methods are used when GenerateHull() is used.

void vtkHull::SetPlanes ( vtkPlanes * planes )

Set all the planes at once using a vtkPlanes implicit function. This also sets the D value, so it can be used with GenerateHull().

virtual int vtkHull::GetNumberOfPlanes ( ) [virtual]

Get the number of planes in the current set of planes.

void vtkHull::AddCubeVertexPlanes ( )

Add the 8 planes that represent the vertices of a cube - the combination of the three face planes connecting to a vertex - (1,1,1), (1,1,-1), (1,-1,1), (1,-1,1), (-1,1,1), (-1,1,-1), (-1,-1,1), (-1,-1-1).

void vtkHull::AddCubeEdgePlanes ( )

Add the 12 planes that represent the edges of a cube - halfway between the two connecting face planes - (1,1,0), (-1,-1,0), (-1,1,0), (1,-1,0), (0,1,1), (0,-1,-1), (0,1,-1), (0,-1,1), (1,0,1), (-1,0,-1), (1,0,-1), (-1,0,1)

void vtkHull::AddCubeFacePlanes ( )

Add the six planes that make up the faces of a cube - (1,0,0), (-1, 0, 0), (0,1,0), (0,-1,0), (0,0,1), (0,0,-1)

void vtkHull::AddRecursiveSpherePlanes ( int level )

Add the planes that represent the normals of the vertices of a polygonal sphere formed by recursively subdividing the triangles in an octahedron. Each triangle is subdivided by connecting the midpoints of the edges thus forming 4 smaller triangles. The level indicates how many subdivisions to do with a level of 0 used to add the 6 planes from the original octahedron, level 1 will add 18 planes, and so on.

void vtkHull::GenerateHull | ( | vtkPolyData * | pd,
 |  | float * | bounds
 | ) |

A special method that is used to generate a polyhedron directly from a set of n planes. The planes that are supplied by the user are not squeezed towards the input data (in fact the user need not specify an input). To use this method, you must provide an instance of vtkPolyData into which the points and cells defining the polyhedron are placed. You must also provide a bounding box where you expect the resulting polyhedron to lie. This can be a very generous fit, it's only used to create the initial polygons that are eventually clipped.

void vtkHull::GenerateHull | ( | vtkPolyData * | pd,
 |  | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

A special method that is used to generate a polyhedron directly from a set of n planes. The planes that are supplied by the user are not squeezed towards the input data (in fact the user need not specify an input). To use this method, you must provide an instance of vtkPolyData into which the points and cells defining the polyhedron are placed. You must also provide a bounding box where you expect the resulting polyhedron to lie. This can be a very generous fit, it's only used to create the initial polygons that are eventually clipped.

void vtkHull::ComputePlaneDistances ( ) [protected]

void vtkHull::ClipPolygonsFromPlanes | ( | vtkPoints * | points,
 |  | vtkCellArray * | polys,
 |  | float * | bounds
 | ) | [protected]

void vtkHull::CreateInitialPolygon | ( | double * | ,
 |  | int | ,
 |  | float * |
 | ) | [protected]

void vtkHull::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

double* vtkHull::Planes [protected]

Definition at line 158 of file vtkHull.h.

int vtkHull::PlanesStorageSize [protected]

Definition at line 163 of file vtkHull.h.

int vtkHull::NumberOfPlanes [protected]

Definition at line 166 of file vtkHull.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkHull.h
Generated on Mon Mar 25 01:18:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkHyperStreamline Class Reference

generate hyperstreamline in arbitrary dataset. More...

#include <vtkHyperStreamline.h>

Inheritance diagram for vtkHyperStreamline:

[legend]
Collaboration diagram for vtkHyperStreamline:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkHyperStreamline, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetStartLocation (vtkIdType cellId, int subId, float pcoords[3])
vtkIdType | GetStartLocation (int &subId, float pcoords[3])
void | SetStartPosition (float x[3])
void | SetStartPosition (float x, float y, float z)
float * | GetStartPosition ()
void | IntegrateMajorEigenvector ()
void | IntegrateMediumEigenvector ()
void | IntegrateMinorEigenvector ()
void | SetStartLocation (vtkIdType cellId, int subId, float r, float s, float t)
virtual void | SetMaximumPropagationDistance (float)
virtual float | GetMaximumPropagationDistance ()
virtual void | SetIntegrationStepLength (float)
virtual float | GetIntegrationStepLength ()
virtual void | SetStepLength (float)
virtual float | GetStepLength ()
virtual void | SetIntegrationDirection (int)
virtual int | GetIntegrationDirection ()
void | SetIntegrationDirectionToForward ()
void | SetIntegrationDirectionToBackward ()
void | SetIntegrationDirectionToIntegrateBothDirections ()
virtual void | SetTerminalEigenvalue (float)
virtual float | GetTerminalEigenvalue ()
virtual void | SetNumberOfSides (int)
virtual int | GetNumberOfSides ()
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetLogScaling (int)
virtual int | GetLogScaling ()
virtual void | LogScalingOn ()
virtual void | LogScalingOff ()

Static Public Methods

vtkHyperStreamline * | New ()

Protected Methods

vtkHyperStreamline ()
~vtkHyperStreamline ()
void | Execute ()
void | BuildTube ()

Protected Attributes

int | StartFrom
vtkIdType StartCell
int | StartSubId
float | StartPCoords [3]
float | StartPosition [3]
vtkHyperArray * | Streamers
int | NumberOfStreamers
float | MaximumPropagationDistance
int | IntegrationDirection
float | IntegrationStepLength
float | StepLength
float | TerminalEigenvalue
int | NumberOfSides
float | Radius
int | LogScaling
int | IntegrationEigenvector

Detailed Description

generate hyperstreamline in arbitrary dataset.

Date:
2002/01/22 15:29:23
Revision:
1.41

vtkHyperStreamline is a filter that integrates through a tensor field to generate a hyperstreamline. The integration is along the maximum eigenvector and the cross section of the hyperstreamline is defined by the two other eigenvectors. Thus the shape of the hyperstreamline is "tube-like", with the cross section being elliptical. Hyperstreamlines are used to visualize tensor fields.

The starting point of a hyperstreamline can be defined in one of two ways. First, you may specify an initial position. This is a x-y-z global coordinate. The second option is to specify a starting location. This is cellId, subId, and cell parametric coordinates.

The integration of the hyperstreamline occurs through the major eigenvector field. IntegrationStepLength controls the step length within each cell (i.e., this is the fraction of the cell length). The length of the hyperstreamline is controlled by MaximumPropagationDistance. This parameter is the length of the hyperstreamline in units of distance. The tube itself is composed of many small sub-tubes - NumberOfSides controls the number of sides in the tube, and StepLength controls the length of the sub-tubes.

Because hyperstreamlines are often created near regions of singularities, it is possible to control the scaling of the tube cross section by using a logarithmic scale. Use LogScalingOn to turn this capability on. The Radius value controls the initial radius of the tube.

See also:
vtkTensorGlyph vtkStreamer
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Lorensen, Bill (14%)
  • Martin, Ken (6%)
Tests:
vtkHyperStreamline (Tests)

Definition at line 73 of file vtkHyperStreamline.h.

Constructor & Destructor Documentation

vtkHyperStreamline::vtkHyperStreamline ( ) [protected]

vtkHyperStreamline::~vtkHyperStreamline ( ) [protected]

Member Function Documentation

vtkHyperStreamline::vtkTypeRevisionMacro | ( | vtkHyperStreamline | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkHyperStreamline::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkHyperStreamline* vtkHyperStreamline::New ( ) [static]

Construct object with initial starting position (0,0,0); integration step length 0.2; step length 0.01; forward integration; terminal eigenvalue 0.0; number of sides 6; radius 0.5; and logarithmic scaling off.

Reimplemented from vtkPolyDataSource.

void vtkHyperStreamline::SetStartLocation | ( | vtkIdType | cellId,
 |  | int | subId,
 |  | float | pcoords[3]
 | ) |

Specify the start of the hyperstreamline in the cell coordinate system. That is, cellId and subId (if composite cell), and parametric coordinates.

void vtkHyperStreamline::SetStartLocation | ( | vtkIdType | cellId,
 |  | int | subId,
 |  | float | r,
 |  | float | s,
 |  | float | t
 | ) |

Specify the start of the hyperstreamline in the cell coordinate system. That is, cellId and subId (if composite cell), and parametric coordinates.

vtkIdType vtkHyperStreamline::GetStartLocation | ( | int & | subId,
 |  | float | pcoords[3]
 | ) |

Get the starting location of the hyperstreamline in the cell coordinate system. Returns the cell that the starting point is in.

void vtkHyperStreamline::SetStartPosition ( float x[3] )

Specify the start of the hyperstreamline in the global coordinate system. Starting from position implies that a search must be performed to find initial cell to start integration from.

void vtkHyperStreamline::SetStartPosition | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Specify the start of the hyperstreamline in the global coordinate system. Starting from position implies that a search must be performed to find initial cell to start integration from.

float* vtkHyperStreamline::GetStartPosition ( )

Get the start position of the hyperstreamline in global x-y-z coordinates.

virtual void vtkHyperStreamline::SetMaximumPropagationDistance ( float ) [virtual]

Set / get the maximum length of the hyperstreamline expressed as absolute distance (i.e., arc length) value.

virtual float vtkHyperStreamline::GetMaximumPropagationDistance ( ) [virtual]

Set / get the maximum length of the hyperstreamline expressed as absolute distance (i.e., arc length) value.

void vtkHyperStreamline::IntegrateMajorEigenvector ( )

Use the major eigenvector field as the vector field through which to integrate. The major eigenvector is the eigenvector whose corresponding eigenvalue is closest to positive infinity.

void vtkHyperStreamline::IntegrateMediumEigenvector ( )

Use the major eigenvector field as the vector field through which to integrate. The major eigenvector is the eigenvector whose corresponding eigenvalue is between the major and minor eigenvalues.

void vtkHyperStreamline::IntegrateMinorEigenvector ( )

Use the major eigenvector field as the vector field through which to integrate. The major eigenvector is the eigenvector whose corresponding eigenvalue is closest to negative infinity.

virtual void vtkHyperStreamline::SetIntegrationStepLength ( float ) [virtual]

Set / get a nominal integration step size (expressed as a fraction of the size of each cell).

virtual float vtkHyperStreamline::GetIntegrationStepLength ( ) [virtual]

Set / get a nominal integration step size (expressed as a fraction of the size of each cell).

virtual void vtkHyperStreamline::SetStepLength ( float ) [virtual]

Set / get the length of a tube segment composing the hyperstreamline. The length is specified as a fraction of the diagonal length of the input bounding box.

virtual float vtkHyperStreamline::GetStepLength ( ) [virtual]

Set / get the length of a tube segment composing the hyperstreamline. The length is specified as a fraction of the diagonal length of the input bounding box.

virtual void vtkHyperStreamline::SetIntegrationDirection ( int ) [virtual]

Specify the direction in which to integrate the hyperstreamline.

virtual int vtkHyperStreamline::GetIntegrationDirection ( ) [virtual]

Specify the direction in which to integrate the hyperstreamline.

void vtkHyperStreamline::SetIntegrationDirectionToForward ( ) [inline]

Specify the direction in which to integrate the hyperstreamline.

Definition at line 158 of file vtkHyperStreamline.h.

void vtkHyperStreamline::SetIntegrationDirectionToBackward ( ) [inline]

Specify the direction in which to integrate the hyperstreamline.

Definition at line 160 of file vtkHyperStreamline.h.

void vtkHyperStreamline::SetIntegrationDirectionToIntegrateBothDirections ( ) [inline]

Specify the direction in which to integrate the hyperstreamline.

Definition at line 162 of file vtkHyperStreamline.h.

virtual void vtkHyperStreamline::SetTerminalEigenvalue ( float ) [virtual]

Set/get terminal eigenvalue. If major eigenvalue falls below this value, hyperstreamline terminates propagation.

virtual float vtkHyperStreamline::GetTerminalEigenvalue ( ) [virtual]

Set/get terminal eigenvalue. If major eigenvalue falls below this value, hyperstreamline terminates propagation.

virtual void vtkHyperStreamline::SetNumberOfSides ( int ) [virtual]

Set / get the number of sides for the hyperstreamlines. At a minimum, number of sides is 3.

virtual int vtkHyperStreamline::GetNumberOfSides ( ) [virtual]

Set / get the number of sides for the hyperstreamlines. At a minimum, number of sides is 3.

virtual void vtkHyperStreamline::SetRadius ( float ) [virtual]

Set / get the initial tube radius. This is the maximum "elliptical" radius at the beginning of the tube. Radius varies based on ratio of eigenvalues. Note that tube section is actually elliptical and may become a point or line in cross section in some cases.

virtual float vtkHyperStreamline::GetRadius ( ) [virtual]

Set / get the initial tube radius. This is the maximum "elliptical" radius at the beginning of the tube. Radius varies based on ratio of eigenvalues. Note that tube section is actually elliptical and may become a point or line in cross section in some cases.

virtual void vtkHyperStreamline::SetLogScaling ( int ) [virtual]

Turn on/off logarithmic scaling. If scaling is on, the log base 10 of the computed eigenvalues are used to scale the cross section radii.

virtual int vtkHyperStreamline::GetLogScaling ( ) [virtual]

Turn on/off logarithmic scaling. If scaling is on, the log base 10 of the computed eigenvalues are used to scale the cross section radii.

virtual void vtkHyperStreamline::LogScalingOn ( ) [virtual]

Turn on/off logarithmic scaling. If scaling is on, the log base 10 of the computed eigenvalues are used to scale the cross section radii.

virtual void vtkHyperStreamline::LogScalingOff ( ) [virtual]

Turn on/off logarithmic scaling. If scaling is on, the log base 10 of the computed eigenvalues are used to scale the cross section radii.

void vtkHyperStreamline::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkHyperStreamline::BuildTube ( ) [protected]

Member Data Documentation

int vtkHyperStreamline::StartFrom [protected]

Definition at line 206 of file vtkHyperStreamline.h.

vtkIdType vtkHyperStreamline::StartCell [protected]

Definition at line 209 of file vtkHyperStreamline.h.

int vtkHyperStreamline::StartSubId [protected]

Definition at line 210 of file vtkHyperStreamline.h.

float vtkHyperStreamline::StartPCoords[3] [protected]

Definition at line 211 of file vtkHyperStreamline.h.

float vtkHyperStreamline::StartPosition[3] [protected]

Definition at line 214 of file vtkHyperStreamline.h.

vtkHyperArray* vtkHyperStreamline::Streamers [protected]

Definition at line 217 of file vtkHyperStreamline.h.

int vtkHyperStreamline::NumberOfStreamers [protected]

Definition at line 218 of file vtkHyperStreamline.h.

float vtkHyperStreamline::MaximumPropagationDistance [protected]

Definition at line 221 of file vtkHyperStreamline.h.

int vtkHyperStreamline::IntegrationDirection [protected]

Definition at line 224 of file vtkHyperStreamline.h.

float vtkHyperStreamline::IntegrationStepLength [protected]

Definition at line 227 of file vtkHyperStreamline.h.

float vtkHyperStreamline::StepLength [protected]

Definition at line 230 of file vtkHyperStreamline.h.

float vtkHyperStreamline::TerminalEigenvalue [protected]

Definition at line 233 of file vtkHyperStreamline.h.

int vtkHyperStreamline::NumberOfSides [protected]

Definition at line 236 of file vtkHyperStreamline.h.

float vtkHyperStreamline::Radius [protected]

Definition at line 239 of file vtkHyperStreamline.h.

int vtkHyperStreamline::LogScaling [protected]

Definition at line 242 of file vtkHyperStreamline.h.

int vtkHyperStreamline::IntegrationEigenvector [protected]

Definition at line 245 of file vtkHyperStreamline.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkHyperStreamline.h
Generated on Mon Mar 25 01:18:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdentityTransform Class Reference

a transform that doesn't do anything. More...

#include <vtkIdentityTransform.h>

Inheritance diagram for vtkIdentityTransform:

[legend]
Collaboration diagram for vtkIdentityTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIdentityTransform, vtkLinearTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | TransformPoints (vtkPoints *inPts, vtkPoints *outPts)
void | TransformNormals (vtkDataArray *inNms, vtkDataArray *outNms)
void | TransformVectors (vtkDataArray *inVrs, vtkDataArray *outVrs)
void | Inverse ()
vtkAbstractTransform * MakeTransform ()
void | TransformPointsNormalsVectors (vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs)
void | InternalTransformPoint (const float in[3], float out[3])
void | InternalTransformPoint (const double in[3], double out[3])
void | InternalTransformNormal (const float in[3], float out[3])
void | InternalTransformNormal (const double in[3], double out[3])
void | InternalTransformVector (const float in[3], float out[3])
void | InternalTransformVector (const double in[3], double out[3])
void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Static Public Methods

vtkIdentityTransform * | New ()

Protected Methods

vtkIdentityTransform ()
~vtkIdentityTransform ()
void | InternalDeepCopy (vtkAbstractTransform *t)

Detailed Description

a transform that doesn't do anything.

Date:
2002/01/22 15:25:27
Revision:
1.25

vtkIdentityTransform is a transformation which will simply pass coordinate data unchanged. All other transform types can also do this, however, the vtkIdentityTransform does so with much greater efficiency.

See also:
vtkLinearTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (88%)
  • Geveci, Berk (10%)
Tests:
vtkIdentityTransform (Tests)

Definition at line 44 of file vtkIdentityTransform.h.

Constructor & Destructor Documentation

vtkIdentityTransform::vtkIdentityTransform ( ) [protected]

vtkIdentityTransform::~vtkIdentityTransform ( ) [protected]

Member Function Documentation

vtkIdentityTransform* vtkIdentityTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkIdentityTransform::vtkTypeRevisionMacro | ( | vtkIdentityTransform | ,
 |  | vtkLinearTransform |
 | ) |

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::TransformPoints | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts
 | ) | [virtual]

Apply the transformation to a series of points, and append the results to outPts.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::TransformNormals | ( | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms
 | ) | [virtual]

Apply the transformation to a series of normals, and append the results to outNms.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::TransformVectors | ( | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a series of vectors, and append the results to outVrs.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::TransformPointsNormalsVectors | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts,
 |  | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms,
 |  | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a combination of points, normals and vectors.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::Inverse ( ) [inline, virtual]

Invert the transformation.

Reimplemented from vtkAbstractTransform.

Definition at line 77 of file vtkIdentityTransform.h.

void vtkIdentityTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformNormal | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformNormal | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformVector | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformVector | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

void vtkIdentityTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkLinearTransform.

vtkAbstractTransform* vtkIdentityTransform::MakeTransform ( ) [virtual]

Make a transform of the same type. This will actually return the same transform.

Reimplemented from vtkAbstractTransform.

void vtkIdentityTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkHomogeneousTransform.

The documentation for this class was generated from the following file:
  • Common/vtkIdentityTransform.h
Generated on Mon Mar 25 01:18:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdFilter Class Reference

generate scalars or field data from point and cell ids. More...

#include <vtkIdFilter.h>

Inheritance diagram for vtkIdFilter:

[legend]
Collaboration diagram for vtkIdFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIdFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPointIds (int)
virtual int | GetPointIds ()
virtual void | PointIdsOn ()
virtual void | PointIdsOff ()
virtual void | SetCellIds (int)
virtual int | GetCellIds ()
virtual void | CellIdsOn ()
virtual void | CellIdsOff ()
virtual void | SetFieldData (int)
virtual int | GetFieldData ()
virtual void | FieldDataOn ()
virtual void | FieldDataOff ()
virtual void | SetIdsArrayName (const char *)
virtual char * | GetIdsArrayName ()

Static Public Methods

vtkIdFilter * | New ()

Protected Methods

vtkIdFilter ()
~vtkIdFilter ()
void | Execute ()

Protected Attributes

int | PointIds
int | CellIds
int | FieldData
char * | IdsArrayName

Detailed Description

generate scalars or field data from point and cell ids.

Date:
2002/01/22 15:29:23
Revision:
1.18

vtkIdFilter is a filter to that generates scalars or field data using cell and point ids. That is, the point attribute data scalars or field data are generated from the point ids, and the cell attribute data scalars or field data are generated from the the cell ids.

Typically this filter is used with vtkLabeledDataMapper (and possibly vtkSelectVisiblePoints) to create labels for points and cells, or labels for the point or cell data scalar values.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Biddiscombe, John (11%)
  • Geveci, Berk (7%)
Examples:
vtkIdFilter (Examples)
Tests:
vtkIdFilter (Tests)

Definition at line 52 of file vtkIdFilter.h.

Constructor & Destructor Documentation

vtkIdFilter::vtkIdFilter ( ) [protected]

vtkIdFilter::~vtkIdFilter ( ) [protected]

Member Function Documentation

vtkIdFilter::vtkTypeRevisionMacro | ( | vtkIdFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkIdFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkIdFilter* vtkIdFilter::New ( ) [static]

Construct object with PointIds and CellIds on; and ids being generated as scalars.

Reimplemented from vtkDataSetSource.

virtual void vtkIdFilter::SetPointIds ( int ) [virtual]

Enable/disable the generation of point ids.

virtual int vtkIdFilter::GetPointIds ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::PointIdsOn ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::PointIdsOff ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::SetCellIds ( int ) [virtual]

Enable/disable the generation of point ids.

virtual int vtkIdFilter::GetCellIds ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::CellIdsOn ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::CellIdsOff ( ) [virtual]

Enable/disable the generation of point ids.

virtual void vtkIdFilter::SetFieldData ( int ) [virtual]

Set/Get the flag which controls whether to generate scalar data or field data. If this flag is off, scalar data is generated. Otherwise, field data is generated.

virtual int vtkIdFilter::GetFieldData ( ) [virtual]

Set/Get the flag which controls whether to generate scalar data or field data. If this flag is off, scalar data is generated. Otherwise, field data is generated.

virtual void vtkIdFilter::FieldDataOn ( ) [virtual]

Set/Get the flag which controls whether to generate scalar data or field data. If this flag is off, scalar data is generated. Otherwise, field data is generated.

virtual void vtkIdFilter::FieldDataOff ( ) [virtual]

Set/Get the flag which controls whether to generate scalar data or field data. If this flag is off, scalar data is generated. Otherwise, field data is generated.

virtual void vtkIdFilter::SetIdsArrayName ( const char * ) [virtual]

Set/Get the name of the Ids array if generated. By default the Ids are named "vtkIdFilter_Ids", but this can be changed with this function.

virtual char* vtkIdFilter::GetIdsArrayName ( ) [virtual]

Set/Get the name of the Ids array if generated. By default the Ids are named "vtkIdFilter_Ids", but this can be changed with this function.

void vtkIdFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkIdFilter::PointIds [protected]

Definition at line 99 of file vtkIdFilter.h.

int vtkIdFilter::CellIds [protected]

Definition at line 100 of file vtkIdFilter.h.

int vtkIdFilter::FieldData [protected]

Definition at line 101 of file vtkIdFilter.h.

char* vtkIdFilter::IdsArrayName [protected]

Definition at line 102 of file vtkIdFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkIdFilter.h
Generated on Mon Mar 25 01:18:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdList Class Reference

list of point or cell ids. More...

#include <vtkIdList.h>

Inheritance diagram for vtkIdList:

[legend]
Collaboration diagram for vtkIdList:

[legend]
List of all members.

Public Methods

void | Initialize ()
int | Allocate (const int sz, const int strategy=0)
vtkTypeRevisionMacro (vtkIdList, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkIdType GetNumberOfIds ()
vtkIdType | GetId (const int i)
void | SetNumberOfIds (const vtkIdType number)
void | SetId (const vtkIdType i, const vtkIdType id)
void | InsertId (const vtkIdType i, const vtkIdType id)
vtkIdType | InsertNextId (const vtkIdType id)
vtkIdType | InsertUniqueId (const vtkIdType id)
vtkIdType * | GetPointer (const vtkIdType i)
vtkIdType * | WritePointer (const vtkIdType i, const vtkIdType number)
void | Reset ()
void | Squeeze ()
void | DeepCopy (vtkIdList *ids)
void | DeleteId (vtkIdType id)
vtkIdType | IsId (vtkIdType id)
void | IntersectWith (vtkIdList &otherIds)

Static Public Methods

vtkIdList * | New ()

Protected Methods

vtkIdList ()
~vtkIdList ()
vtkIdType * | Resize (const vtkIdType sz)

Protected Attributes

vtkIdType NumberOfIds
vtkIdType Size
vtkIdType * Ids

Detailed Description

list of point or cell ids.

Date:
2002/01/22 15:25:26
Revision:
1.69

vtkIdList is used to represent and pass data id's between objects. vtkIdList may represent any type of integer id, but usually represents point and cell ids.

Created by:
  • Martin, Ken
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (60%)
  • Martin, Ken (15%)
  • Law, Charles (6%)
  • Henderson, Amy (6%)
Examples:
vtkIdList (Examples)
Tests:
vtkIdList (Tests)

Definition at line 48 of file vtkIdList.h.

Constructor & Destructor Documentation

vtkIdList::vtkIdList ( ) [protected]

vtkIdList::~vtkIdList ( ) [protected]

Member Function Documentation

vtkIdList* vtkIdList::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

void vtkIdList::Initialize ( )

int vtkIdList::Allocate | ( | const int | sz,
 |  | const int | strategy = 0
 | ) |

vtkIdList::vtkTypeRevisionMacro | ( | vtkIdList | ,
 |  | vtkObject |
 | ) |

void vtkIdList::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkIdType vtkIdList::GetNumberOfIds ( ) [inline]

Return the number of id's in the list.

Definition at line 59 of file vtkIdList.h.

Referenced by vtkCellArray::InsertNextCell().

vtkIdType vtkIdList::GetId ( const int i ) [inline]

Return the id at location i.

Definition at line 62 of file vtkIdList.h.

Referenced by vtkCellArray::InsertNextCell().

void vtkIdList::SetNumberOfIds ( const vtkIdType number )

Specify the number of ids for this object to hold. Does an allocation as well as setting the number of ids.

void vtkIdList::SetId | ( | const vtkIdType | i,
 |  | const vtkIdType | id
 | ) | [inline]

Set the id at location i. Doesn't do range checking so it's a bit faster than InsertId. Make sure you use SetNumberOfIds() to allocate memory prior to using SetId().

Definition at line 71 of file vtkIdList.h.

void vtkIdList::InsertId | ( | const vtkIdType | i,
 |  | const vtkIdType | id
 | ) |

Set the id at location i. Does range checking and allocates memory as necessary.

vtkIdType vtkIdList::InsertNextId ( const vtkIdType id ) [inline]

Add the id specified to the end of the list. Range checking is performed.

Definition at line 129 of file vtkIdList.h.

vtkIdType vtkIdList::InsertUniqueId ( const vtkIdType id )

If id is not already in list, insert it and return location in list. Otherwise return just location in list.

vtkIdType* vtkIdList::GetPointer ( const vtkIdType i ) [inline]

Get a pointer to a particular data index.

Definition at line 86 of file vtkIdList.h.

vtkIdType* vtkIdList::WritePointer | ( | const vtkIdType | i,
 |  | const vtkIdType | number
 | ) |

Get a pointer to a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

void vtkIdList::Reset ( ) [inline]

Reset to an empty state.

Definition at line 94 of file vtkIdList.h.

void vtkIdList::Squeeze ( ) [inline]

Free any unused memory.

Definition at line 97 of file vtkIdList.h.

void vtkIdList::DeepCopy ( vtkIdList * ids )

Copy an id list by explicitly copying the internal array.

void vtkIdList::DeleteId ( vtkIdType id )

Delete specified id from list. Will remove all occurrences of id in list.

vtkIdType vtkIdList::IsId ( vtkIdType id ) [inline]

Return -1 if id specified is not contained in the list; otherwise return the position in the list.

Definition at line 139 of file vtkIdList.h.

void vtkIdList::IntersectWith ( vtkIdList & otherIds )

Intersect this list with another vtkIdList. Updates current list according to result of intersection operation.

vtkIdType* vtkIdList::Resize ( const vtkIdType sz ) [protected]

Referenced by InsertNextId().

Member Data Documentation

vtkIdType vtkIdList::NumberOfIds [protected]

Definition at line 118 of file vtkIdList.h.

vtkIdType vtkIdList::Size [protected]

Definition at line 119 of file vtkIdList.h.

vtkIdType* vtkIdList::Ids [protected]

Definition at line 120 of file vtkIdList.h.

The documentation for this class was generated from the following file:
  • Common/vtkIdList.h
Generated on Mon Mar 25 01:18:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIdTypeArray Class Reference

dynamic, self-adjusting integer array. More...

#include <vtkIdTypeArray.h>

Inheritance diagram for vtkIdTypeArray:

[legend]
Collaboration diagram for vtkIdTypeArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIdTypeArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataTypeSize ()
virtual void | Resize (vtkIdType numTuples)
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const vtkIdType i)
vtkIdType | InsertNextValue (const vtkIdType i)
vtkIdType * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *ia)
int | GetDataType ()
void | Squeeze ()
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
vtkIdType | GetValue (const vtkIdType id)
void | SetValue (const vtkIdType id, const vtkIdType value)
vtkIdType * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (vtkIdType *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkIdTypeArray * | New ()

Protected Methods

vtkIdTypeArray (vtkIdType numComp=1)
~vtkIdTypeArray ()
vtkIdType * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

vtkIdType * Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting integer array.

Date:
2002/02/13 22:46:29
Revision:
1.7

vtkIdTypeArray is an array of integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (95%)
Tests:
vtkIdTypeArray (Tests)

Definition at line 41 of file vtkIdTypeArray.h.

Constructor & Destructor Documentation

vtkIdTypeArray::vtkIdTypeArray ( vtkIdType numComp = 1 ) [protected]

vtkIdTypeArray::~vtkIdTypeArray ( ) [protected]

Member Function Documentation

vtkIdTypeArray* vtkIdTypeArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkIdTypeArray::vtkTypeRevisionMacro | ( | vtkIdTypeArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkIdTypeArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkIdTypeArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkIdTypeArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkIdTypeArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkIdTypeArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 61 of file vtkIdTypeArray.h.

int vtkIdTypeArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 66 of file vtkIdTypeArray.h.

void vtkIdTypeArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 70 of file vtkIdTypeArray.h.

virtual void vtkIdTypeArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkIdTypeArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkIdTypeArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkIdTypeArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkIdTypeArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkIdTypeArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 112 of file vtkIdTypeArray.h.

Referenced by vtkPriorityQueue::DeleteId(), vtkCellArray::GetCell(), vtkCellArray::GetNextCell(), vtkPriorityQueue::GetPriority(), and vtkCellArray::ReverseCell().

void vtkIdTypeArray::SetValue | ( | const vtkIdType | id,
 |  | const vtkIdType | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 119 of file vtkIdTypeArray.h.

Referenced by vtkCellArray::UpdateCellCount().

void vtkIdTypeArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 181 of file vtkIdTypeArray.h.

void vtkIdTypeArray::InsertValue | ( | const vtkIdType | id,
 |  | const vtkIdType | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 202 of file vtkIdTypeArray.h.

Referenced by vtkCellArray::InsertCellPoint(), and InsertNextValue().

vtkIdType vtkIdTypeArray::InsertNextValue ( const vtkIdType i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 215 of file vtkIdTypeArray.h.

Referenced by vtkCellArray::InsertNextCell().

vtkIdType* vtkIdTypeArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 138 of file vtkIdTypeArray.h.

Referenced by vtkCellArray::GetCell(), vtkCellArray::GetNextCell(), vtkCellArray::ReplaceCell(), and vtkCellArray::ReverseCell().

void* vtkIdTypeArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 140 of file vtkIdTypeArray.h.

vtkIdType * vtkIdTypeArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 187 of file vtkIdTypeArray.h.

Referenced by vtkCellArray::InsertNextCell(), and vtkCellArray::WritePointer().

void vtkIdTypeArray::DeepCopy ( vtkDataArray * ia ) [virtual]

Deep copy of another integer array.

Reimplemented from vtkDataArray.

void vtkIdTypeArray::SetArray | ( | vtkIdType * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkIdTypeArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 160 of file vtkIdTypeArray.h.

vtkIdType* vtkIdTypeArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

vtkIdType* vtkIdTypeArray::Array [protected]

Definition at line 168 of file vtkIdTypeArray.h.

int vtkIdTypeArray::TupleSize [protected]

Definition at line 171 of file vtkIdTypeArray.h.

float* vtkIdTypeArray::Tuple [protected]

Definition at line 172 of file vtkIdTypeArray.h.

int vtkIdTypeArray::SaveUserArray [protected]

Definition at line 174 of file vtkIdTypeArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkIdTypeArray.h
Generated on Mon Mar 25 01:18:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAccumulate Class Reference

Generalized histograms up to 4 dimensions. More...

#include <vtkImageAccumulate.h>

Inheritance diagram for vtkImageAccumulate:

[legend]
Collaboration diagram for vtkImageAccumulate:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageAccumulate, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetComponentSpacing (float, float, float)
virtual void | SetComponentSpacing (float[3])
virtual float * | GetComponentSpacing ()
virtual void | GetComponentSpacing (float &, float &, float &)
virtual void | GetComponentSpacing (float[3])
virtual void | SetComponentOrigin (float, float, float)
virtual void | SetComponentOrigin (float[3])
virtual float * | GetComponentOrigin ()
virtual void | GetComponentOrigin (float &, float &, float &)
virtual void | GetComponentOrigin (float[3])
void | SetComponentExtent (int extent[6])
void | SetComponentExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
void | GetComponentExtent (int extent[6])
int * | GetComponentExtent ()
void | SetStencil (vtkImageStencilData *stencil)
vtkImageStencilData * GetStencil ()
virtual void | SetReverseStencil (int)
virtual void | ReverseStencilOn ()
virtual void | ReverseStencilOff ()
virtual int | GetReverseStencil ()
virtual double * | GetMin ()
virtual void | GetMin (double &, double &, double &)
virtual void | GetMin (double[3])
virtual double * | GetMax ()
virtual void | GetMax (double &, double &, double &)
virtual void | GetMax (double[3])
virtual double * | GetMean ()
virtual void | GetMean (double &, double &, double &)
virtual void | GetMean (double[3])
virtual double * | GetStandardDeviation ()
virtual void | GetStandardDeviation (double &, double &, double &)
virtual void | GetStandardDeviation (double[3])
virtual long int | GetVoxelCount ()

Static Public Methods

vtkImageAccumulate * | New ()

Protected Methods

vtkImageAccumulate ()
~vtkImageAccumulate ()
void | ExecuteInformation (vtkImageData *input, vtkImageData *output)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *out)

Protected Attributes

float | ComponentSpacing [3]
float | ComponentOrigin [3]
int | ComponentExtent [6]
double | Min [3]
double | Max [3]
double | Mean [3]
double | StandardDeviation [3]
long int | VoxelCount
int | ReverseStencil

Detailed Description

Generalized histograms up to 4 dimensions.

Date:
2002/01/22 15:31:47
Revision:
1.31

vtkImageAccumulate - This filter divides component space into discrete bins. It then counts the number of pixels associated with each bin. The output is this "scatter plot" (histogram values for 1D). The dimensionality of the output depends on how many components the input pixels have. Input pixels with one component generate a 1D histogram. This filter can only handle images with 1 to 3 scalar components. The input can be any type, but the output is always int. Some statistics are computed on the pixel values at the same time. The SetStencilFunction, SetClippingExtents and ReverseStencil functions allow the statistics to be computed on an arbitrary portion of the input data. See the documentation for vtkImageStencil for more information.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (43%)
  • Starreveld, Yves (17%)
  • Gobbi, David (13%)
  • Lorensen, Bill (10%)
  • Schroeder, Will (6%)
Examples:
vtkImageAccumulate (Examples)
Tests:
vtkImageAccumulate (Tests)

Definition at line 59 of file vtkImageAccumulate.h.

Constructor & Destructor Documentation

vtkImageAccumulate::vtkImageAccumulate ( ) [protected]

vtkImageAccumulate::~vtkImageAccumulate ( ) [protected]

Member Function Documentation

vtkImageAccumulate* vtkImageAccumulate::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageAccumulate::vtkTypeRevisionMacro | ( | vtkImageAccumulate | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageAccumulate::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageAccumulate::SetComponentSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get - The component spacing is the dimension of each bin. This ends up being the spacing of the output "image". If the number of input scalar components are less than three, then some of these spacing values are ignored. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this spacing should be set to 100, 0, 0

virtual void vtkImageAccumulate::SetComponentSpacing ( float [3] ) [virtual]

Set/Get - The component spacing is the dimension of each bin. This ends up being the spacing of the output "image". If the number of input scalar components are less than three, then some of these spacing values are ignored. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this spacing should be set to 100, 0, 0

virtual float* vtkImageAccumulate::GetComponentSpacing ( ) [virtual]

Set/Get - The component spacing is the dimension of each bin. This ends up being the spacing of the output "image". If the number of input scalar components are less than three, then some of these spacing values are ignored. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this spacing should be set to 100, 0, 0

virtual void vtkImageAccumulate::GetComponentSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get - The component spacing is the dimension of each bin. This ends up being the spacing of the output "image". If the number of input scalar components are less than three, then some of these spacing values are ignored. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this spacing should be set to 100, 0, 0

virtual void vtkImageAccumulate::GetComponentSpacing ( float [3] ) [virtual]

Set/Get - The component spacing is the dimension of each bin. This ends up being the spacing of the output "image". If the number of input scalar components are less than three, then some of these spacing values are ignored. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this spacing should be set to 100, 0, 0

virtual void vtkImageAccumulate::SetComponentOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get - The component origin is the location of bin (0, 0, 0). Note that if the Component extent does not include the value (0,0,0), then this origin bin will not actually be in the output. The origin of the output ends up being the same as the componenet origin. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this origin should be set to 1000, 0, 0

virtual void vtkImageAccumulate::SetComponentOrigin ( float [3] ) [virtual]

Set/Get - The component origin is the location of bin (0, 0, 0). Note that if the Component extent does not include the value (0,0,0), then this origin bin will not actually be in the output. The origin of the output ends up being the same as the componenet origin. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this origin should be set to 1000, 0, 0

virtual float* vtkImageAccumulate::GetComponentOrigin ( ) [virtual]

Set/Get - The component origin is the location of bin (0, 0, 0). Note that if the Component extent does not include the value (0,0,0), then this origin bin will not actually be in the output. The origin of the output ends up being the same as the componenet origin. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this origin should be set to 1000, 0, 0

virtual void vtkImageAccumulate::GetComponentOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get - The component origin is the location of bin (0, 0, 0). Note that if the Component extent does not include the value (0,0,0), then this origin bin will not actually be in the output. The origin of the output ends up being the same as the componenet origin. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this origin should be set to 1000, 0, 0

virtual void vtkImageAccumulate::GetComponentOrigin ( float [3] ) [virtual]

Set/Get - The component origin is the location of bin (0, 0, 0). Note that if the Component extent does not include the value (0,0,0), then this origin bin will not actually be in the output. The origin of the output ends up being the same as the componenet origin. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this origin should be set to 1000, 0, 0

void vtkImageAccumulate::SetComponentExtent ( int extent[6] )

Set/Get - The component extent sets the number/extent of the bins. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this extent should be set to 0, 9, 0, 0, 0, 0. The extent specifies inclusive min/max values. This implies the the top extent should be set to the number of bins - 1.

void vtkImageAccumulate::SetComponentExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

Set/Get - The component extent sets the number/extent of the bins. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this extent should be set to 0, 9, 0, 0, 0, 0. The extent specifies inclusive min/max values. This implies the the top extent should be set to the number of bins - 1.

void vtkImageAccumulate::GetComponentExtent ( int extent[6] )

Set/Get - The component extent sets the number/extent of the bins. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this extent should be set to 0, 9, 0, 0, 0, 0. The extent specifies inclusive min/max values. This implies the the top extent should be set to the number of bins - 1.

int* vtkImageAccumulate::GetComponentExtent ( ) [inline]

Set/Get - The component extent sets the number/extent of the bins. For a 1D histogram with 10 bins spanning the values 1000 to 2000, this extent should be set to 0, 9, 0, 0, 0, 0. The extent specifies inclusive min/max values. This implies the the top extent should be set to the number of bins - 1.

Definition at line 97 of file vtkImageAccumulate.h.

void vtkImageAccumulate::SetStencil ( vtkImageStencilData * stencil )

Use a stencil to specify which voxels to accumulate.

vtkImageStencilData* vtkImageAccumulate::GetStencil ( )

Use a stencil to specify which voxels to accumulate.

virtual void vtkImageAccumulate::SetReverseStencil ( int ) [virtual]

Reverse the stencil.

virtual void vtkImageAccumulate::ReverseStencilOn ( ) [virtual]

Reverse the stencil.

virtual void vtkImageAccumulate::ReverseStencilOff ( ) [virtual]

Reverse the stencil.

virtual int vtkImageAccumulate::GetReverseStencil ( ) [virtual]

Reverse the stencil.

virtual double* vtkImageAccumulate::GetMin ( ) [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMin | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMin ( double [3] ) [virtual]

Get the statistics information for the data.

virtual double* vtkImageAccumulate::GetMax ( ) [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMax | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMax ( double [3] ) [virtual]

Get the statistics information for the data.

virtual double* vtkImageAccumulate::GetMean ( ) [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMean | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetMean ( double [3] ) [virtual]

Get the statistics information for the data.

virtual double* vtkImageAccumulate::GetStandardDeviation ( ) [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetStandardDeviation | ( | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Get the statistics information for the data.

virtual void vtkImageAccumulate::GetStandardDeviation ( double [3] ) [virtual]

Get the statistics information for the data.

virtual long int vtkImageAccumulate::GetVoxelCount ( ) [virtual]

Get the statistics information for the data.

void vtkImageAccumulate::ExecuteInformation | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageAccumulate::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageAccumulate::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 134 of file vtkImageAccumulate.h.

void vtkImageAccumulate::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageAccumulate::ComponentSpacing[3] [protected]

Definition at line 128 of file vtkImageAccumulate.h.

float vtkImageAccumulate::ComponentOrigin[3] [protected]

Definition at line 129 of file vtkImageAccumulate.h.

int vtkImageAccumulate::ComponentExtent[6] [protected]

Definition at line 130 of file vtkImageAccumulate.h.

double vtkImageAccumulate::Min[3] [protected]

Definition at line 137 of file vtkImageAccumulate.h.

double vtkImageAccumulate::Max[3] [protected]

Definition at line 138 of file vtkImageAccumulate.h.

double vtkImageAccumulate::Mean[3] [protected]

Definition at line 139 of file vtkImageAccumulate.h.

double vtkImageAccumulate::StandardDeviation[3] [protected]

Definition at line 140 of file vtkImageAccumulate.h.

long int vtkImageAccumulate::VoxelCount [protected]

Definition at line 141 of file vtkImageAccumulate.h.

int vtkImageAccumulate::ReverseStencil [protected]

Definition at line 143 of file vtkImageAccumulate.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageAccumulate.h
Generated on Mon Mar 25 01:18:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageActor Class Reference

draw an image (data & properties) in a rendered 3D scene. More...

#include <vtkImageActor.h>

Inheritance diagram for vtkImageActor:

[legend]
Collaboration diagram for vtkImageActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageActor, vtkProp)
void | PrintSelf (ostream &os, vtkIndent indent)
int | GetSliceNumber ()
int | GetZSlice ()
int | GetWholeZMin ()
int | GetWholeZMax ()
virtual void | SetInput (vtkImageData *)
virtual vtkImageData * | GetInput ()
virtual int | GetInterpolate ()
virtual void | SetInterpolate (int)
virtual void | InterpolateOn ()
virtual void | InterpolateOff ()
void | SetDisplayExtent (int extent[6])
void | SetDisplayExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
void | GetDisplayExtent (int extent[6])
int * | GetDisplayExtent ()
float * | GetBounds ()
void | GetBounds (float bounds[6])
int | RenderOpaqueGeometry (vtkViewport *viewport)
virtual void | Load (vtkRenderer *)
void | SetZSlice (int z)

Static Public Methods

vtkImageActor * | New ()

Protected Methods

vtkImageActor ()
~vtkImageActor ()

Protected Attributes

int | Interpolate
vtkImageData * Input
int | DisplayExtent [6]
float | Bounds [6]

Detailed Description

draw an image (data & properties) in a rendered 3D scene.

Date:
2002/02/14 19:21:40
Revision:
1.14

vtkImageActor is used to render an image in a 3D scene. The image is placed at the origin of the image, and its size is controlled by the image dimensions and image spacing. The orientation of the image is orthogonal to one of the x-y-z axes depending on which plane the image is defined in. vtkImageActor duplicates the functionality of combinations of other VTK classes in a convenient, single class.

Warning:
vtkImageData requires the image to be of type unsigned char. Use a filter like vtkImageShiftScale to convert to unsigned char (the method to use is SetOutputTypeToUnsignedChar()).
See also:
vtkImageData vtkProp vtkImageShiftScale
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (86%)
  • Schroeder, Will (11%)
Examples:
vtkImageActor (Examples)
Tests:
vtkImageActor (Tests)

Definition at line 60 of file vtkImageActor.h.

Constructor & Destructor Documentation

vtkImageActor::vtkImageActor ( ) [protected]

vtkImageActor::~vtkImageActor ( ) [protected]

Member Function Documentation

vtkImageActor::vtkTypeRevisionMacro | ( | vtkImageActor | ,
 |  | vtkProp |
 | ) |

Reimplemented from vtkProp.

Reimplemented in vtkMesaImageActor, and vtkOpenGLImageActor.

void vtkImageActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp.

vtkImageActor* vtkImageActor::New ( ) [static]

Instantiate the image actor.

Reimplemented from vtkProp.

Reimplemented in vtkMesaImageActor, and vtkOpenGLImageActor.

virtual void vtkImageActor::SetInput ( vtkImageData * ) [virtual]

Set/Get the image data input for the image actor.

virtual vtkImageData* vtkImageActor::GetInput ( ) [virtual]

Set/Get the image data input for the image actor.

virtual int vtkImageActor::GetInterpolate ( ) [virtual]

Turn on/off linear interpolation of the image when rendering.

virtual void vtkImageActor::SetInterpolate ( int ) [virtual]

Turn on/off linear interpolation of the image when rendering.

virtual void vtkImageActor::InterpolateOn ( ) [virtual]

Turn on/off linear interpolation of the image when rendering.

virtual void vtkImageActor::InterpolateOff ( ) [virtual]

Turn on/off linear interpolation of the image when rendering.

void vtkImageActor::SetDisplayExtent ( int extent[6] )

The image extent is generally set explicitly, but if not set it will be determined from the input image data.

void vtkImageActor::SetDisplayExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

The image extent is generally set explicitly, but if not set it will be determined from the input image data.

void vtkImageActor::GetDisplayExtent ( int extent[6] )

The image extent is generally set explicitly, but if not set it will be determined from the input image data.

int* vtkImageActor::GetDisplayExtent ( ) [inline]

The image extent is generally set explicitly, but if not set it will be determined from the input image data.

Definition at line 89 of file vtkImageActor.h.

float* vtkImageActor::GetBounds ( ) [virtual]

Get the bounds of this image actor. Either copy the bounds into a user provided array or return a pointer to an array. In either case the boudns is expressed as a 6-vector (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkProp.

void vtkImageActor::GetBounds ( float bounds[6] )

Get the bounds of this image actor. Either copy the bounds into a user provided array or return a pointer to an array. In either case the boudns is expressed as a 6-vector (xmin,xmax, ymin,ymax, zmin,zmax).

int vtkImageActor::GetSliceNumber ( )

Return a slice number computed from the display extent.

int vtkImageActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Support the standard render methods. int RenderTranslucentGeometry(vtkViewport *viewport);

Reimplemented from vtkProp.

virtual void vtkImageActor::Load ( vtkRenderer * ren ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Support the standard render methods. int RenderTranslucentGeometry(vtkViewport *viewport);

Reimplemented in vtkMesaImageActor, and vtkOpenGLImageActor.

Definition at line 110 of file vtkImageActor.h.

void vtkImageActor::SetZSlice ( int z ) [inline]

Set/Get the current slice number. The axis Z in ZSlice does not necessarily have any relation to the z axis of the data on disk. It is simply the axis orthogonal to the x,y, display plane. GetWholeZMax and Min are convenience methods for obtaining the number of slices that can be displayed. Again the number of slices is in reference to the display z axis, which is not necessarily the z axis on disk. (due to reformatting etc)

Definition at line 122 of file vtkImageActor.h.

int vtkImageActor::GetZSlice ( ) [inline]

Definition at line 128 of file vtkImageActor.h.

int vtkImageActor::GetWholeZMin ( )

int vtkImageActor::GetWholeZMax ( )

Member Data Documentation

int vtkImageActor::Interpolate [protected]

Definition at line 136 of file vtkImageActor.h.

vtkImageData* vtkImageActor::Input [protected]

Definition at line 137 of file vtkImageActor.h.

int vtkImageActor::DisplayExtent[6] [protected]

Definition at line 138 of file vtkImageActor.h.

float vtkImageActor::Bounds[6] [protected]

Definition at line 139 of file vtkImageActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImageActor.h
Generated on Mon Mar 25 01:18:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAnisotropicDiffusion2D Class Reference

edge preserving smoothing. More...

#include <vtkImageAnisotropicDiffusion2D.h>

Inheritance diagram for vtkImageAnisotropicDiffusion2D:

[legend]
Collaboration diagram for vtkImageAnisotropicDiffusion2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageAnisotropicDiffusion2D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfIterations (int num)
virtual int | GetNumberOfIterations ()
virtual void | SetDiffusionThreshold (float)
virtual float | GetDiffusionThreshold ()
virtual void | SetDiffusionFactor (float)
virtual float | GetDiffusionFactor ()
virtual void | SetFaces (int)
virtual int | GetFaces ()
virtual void | FacesOn ()
virtual void | FacesOff ()
virtual void | SetEdges (int)
virtual int | GetEdges ()
virtual void | EdgesOn ()
virtual void | EdgesOff ()
virtual void | SetCorners (int)
virtual int | GetCorners ()
virtual void | CornersOn ()
virtual void | CornersOff ()
virtual void | SetGradientMagnitudeThreshold (int)
virtual int | GetGradientMagnitudeThreshold ()
virtual void | GradientMagnitudeThresholdOn ()
virtual void | GradientMagnitudeThresholdOff ()

Static Public Methods

vtkImageAnisotropicDiffusion2D * | New ()

Protected Methods

vtkImageAnisotropicDiffusion2D ()
~vtkImageAnisotropicDiffusion2D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)
void | Iterate (vtkImageData *in, vtkImageData *out, float ar0, float ar1, int *coreExtent, int count)

Protected Attributes

int | NumberOfIterations
float | DiffusionThreshold
float | DiffusionFactor
int | Faces
int | Edges
int | Corners
int | GradientMagnitudeThreshold

Detailed Description

edge preserving smoothing.

Date:
2002/01/22 15:31:48
Revision:
1.31

vtkImageAnisotropicDiffusion2D diffuses a 2d image iteratively. The neighborhood of the diffusion is determined by the instance flags. If "Edges" is on the 4 edge connected voxels are included, and if "Corners" is on, the 4 corner connected voxels are included. "DiffusionFactor" determines how far a pixel value moves toward its neighbors, and is insensitive to the number of neighbors chosen. The diffusion is anisotropic because it only occurs when a gradient measure is below "GradientThreshold". Two gradient measures exist and are toggled by the "GradientMagnitudeThreshold" flag. When "GradientMagnitudeThreshold" is on, the magnitude of the gradient, computed by central differences, above "DiffusionThreshold" a voxel is not modified. The alternative measure examines each neighbor independently. The gradient between the voxel and the neighbor must be below the "DiffusionThreshold" for diffusion to occur with THAT neighbor.

See also:
vtkImageAnisotropicDiffusion3D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (67%)
  • Martin, Ken (25%)
Tests:
vtkImageAnisotropicDiffusion2D (Tests)

Definition at line 58 of file vtkImageAnisotropicDiffusion2D.h.

Constructor & Destructor Documentation

vtkImageAnisotropicDiffusion2D::vtkImageAnisotropicDiffusion2D ( ) [protected]

vtkImageAnisotropicDiffusion2D::~vtkImageAnisotropicDiffusion2D ( ) [inline, protected]

Definition at line 119 of file vtkImageAnisotropicDiffusion2D.h.

Member Function Documentation

vtkImageAnisotropicDiffusion2D* vtkImageAnisotropicDiffusion2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageAnisotropicDiffusion2D::vtkTypeRevisionMacro | ( | vtkImageAnisotropicDiffusion2D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageAnisotropicDiffusion2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageAnisotropicDiffusion2D::SetNumberOfIterations ( int num )

This method sets the number of interations which also affects the input neighborhood needed to compute one output pixel. Each iterations requires an extra pixel layer on the neighborhood. This is only relavent when you are trying to stream or are requesting a sub extent of the "wholeExtent".

virtual int vtkImageAnisotropicDiffusion2D::GetNumberOfIterations ( ) [virtual]

Get the number of iterations.

virtual void vtkImageAnisotropicDiffusion2D::SetDiffusionThreshold ( float ) [virtual]

Set/Get the difference threshold that stops diffusion. when the difference between two pixel is greater than this threshold, the pixels are not diffused. This causes diffusion to avoid sharp edges. If the GradientMagnitudeThreshold is set, then gradient magnitude is used for comparison instead of pixel differences.

virtual float vtkImageAnisotropicDiffusion2D::GetDiffusionThreshold ( ) [virtual]

Set/Get the difference threshold that stops diffusion. when the difference between two pixel is greater than this threshold, the pixels are not diffused. This causes diffusion to avoid sharp edges. If the GradientMagnitudeThreshold is set, then gradient magnitude is used for comparison instead of pixel differences.

virtual void vtkImageAnisotropicDiffusion2D::SetDiffusionFactor ( float ) [virtual]

The diffusion factor specifies how much neighboring pixels effect each other. No diffusion occurs with a factor of 0, and a diffusion factor of 1 causes the pixel to become the average of all its neighbors.

virtual float vtkImageAnisotropicDiffusion2D::GetDiffusionFactor ( ) [virtual]

The diffusion factor specifies how much neighboring pixels effect each other. No diffusion occurs with a factor of 0, and a diffusion factor of 1 causes the pixel to become the average of all its neighbors.

virtual void vtkImageAnisotropicDiffusion2D::SetFaces ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion2D::GetFaces ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::FacesOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::FacesOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::SetEdges ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion2D::GetEdges ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::EdgesOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::EdgesOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::SetCorners ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion2D::GetCorners ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::CornersOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::CornersOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion2D::SetGradientMagnitudeThreshold ( int ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual int vtkImageAnisotropicDiffusion2D::GetGradientMagnitudeThreshold ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual void vtkImageAnisotropicDiffusion2D::GradientMagnitudeThresholdOn ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual void vtkImageAnisotropicDiffusion2D::GradientMagnitudeThresholdOff ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

void vtkImageAnisotropicDiffusion2D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

void vtkImageAnisotropicDiffusion2D::Iterate | ( | vtkImageData * | in,
 |  | vtkImageData * | out,
 |  | float | ar0,
 |  | float | ar1,
 |  | int * | coreExtent,
 |  | int | count
 | ) | [protected]

Member Data Documentation

int vtkImageAnisotropicDiffusion2D::NumberOfIterations [protected]

Definition at line 121 of file vtkImageAnisotropicDiffusion2D.h.

float vtkImageAnisotropicDiffusion2D::DiffusionThreshold [protected]

Definition at line 122 of file vtkImageAnisotropicDiffusion2D.h.

float vtkImageAnisotropicDiffusion2D::DiffusionFactor [protected]

Definition at line 123 of file vtkImageAnisotropicDiffusion2D.h.

int vtkImageAnisotropicDiffusion2D::Faces [protected]

Definition at line 125 of file vtkImageAnisotropicDiffusion2D.h.

int vtkImageAnisotropicDiffusion2D::Edges [protected]

Definition at line 126 of file vtkImageAnisotropicDiffusion2D.h.

int vtkImageAnisotropicDiffusion2D::Corners [protected]

Definition at line 127 of file vtkImageAnisotropicDiffusion2D.h.

int vtkImageAnisotropicDiffusion2D::GradientMagnitudeThreshold [protected]

Definition at line 129 of file vtkImageAnisotropicDiffusion2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageAnisotropicDiffusion2D.h
Generated on Mon Mar 25 01:18:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAnisotropicDiffusion3D Class Reference

edge preserving smoothing. More...

#include <vtkImageAnisotropicDiffusion3D.h>

Inheritance diagram for vtkImageAnisotropicDiffusion3D:

[legend]
Collaboration diagram for vtkImageAnisotropicDiffusion3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageAnisotropicDiffusion3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfIterations (int num)
virtual int | GetNumberOfIterations ()
virtual void | SetDiffusionThreshold (float)
virtual float | GetDiffusionThreshold ()
virtual void | SetDiffusionFactor (float)
virtual float | GetDiffusionFactor ()
virtual void | SetFaces (int)
virtual int | GetFaces ()
virtual void | FacesOn ()
virtual void | FacesOff ()
virtual void | SetEdges (int)
virtual int | GetEdges ()
virtual void | EdgesOn ()
virtual void | EdgesOff ()
virtual void | SetCorners (int)
virtual int | GetCorners ()
virtual void | CornersOn ()
virtual void | CornersOff ()
virtual void | SetGradientMagnitudeThreshold (int)
virtual int | GetGradientMagnitudeThreshold ()
virtual void | GradientMagnitudeThresholdOn ()
virtual void | GradientMagnitudeThresholdOff ()

Static Public Methods

vtkImageAnisotropicDiffusion3D * | New ()

Protected Methods

vtkImageAnisotropicDiffusion3D ()
~vtkImageAnisotropicDiffusion3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)
void | Iterate (vtkImageData *in, vtkImageData *out, float ar0, float ar1, float ar3, int *coreExtent, int count)

Protected Attributes

int | NumberOfIterations
float | DiffusionThreshold
float | DiffusionFactor
int | Faces
int | Edges
int | Corners
int | GradientMagnitudeThreshold

Detailed Description

edge preserving smoothing.

Date:
2002/01/22 15:31:49
Revision:
1.30

vtkImageAnisotropicDiffusion3D diffuses an volume iteratively. The neighborhood of the diffusion is determined by the instance flags. if "Faces" is on, the 6 voxels adjoined by faces are included in the neighborhood. If "Edges" is on the 12 edge connected voxels are included, and if "Corners" is on, the 8 corner connected voxels are included. "DiffusionFactor" determines how far a pixel value moves toward its neighbors, and is insensitive to the number of neighbors chosen. The diffusion is anisotropic because it only occurs when a gradient measure is below "GradientThreshold". Two gradient measures exist and are toggled by the "GradientMagnitudeThreshold" flag. When "GradientMagnitudeThreshold" is on, the magnitude of the gradient, computed by central differences, above "DiffusionThreshold" a voxel is not modified. The alternative measure examines each neighbor independently. The gradient between the voxel and the neighbor must be below the "DiffusionThreshold" for diffusion to occur with THAT neighbor.

See also:
vtkImageAnisotropicDiffusion2D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (71%)
  • Martin, Ken (25%)
Tests:
vtkImageAnisotropicDiffusion3D (Tests)

Definition at line 60 of file vtkImageAnisotropicDiffusion3D.h.

Constructor & Destructor Documentation

vtkImageAnisotropicDiffusion3D::vtkImageAnisotropicDiffusion3D ( ) [protected]

vtkImageAnisotropicDiffusion3D::~vtkImageAnisotropicDiffusion3D ( ) [inline, protected]

Definition at line 119 of file vtkImageAnisotropicDiffusion3D.h.

Member Function Documentation

vtkImageAnisotropicDiffusion3D* vtkImageAnisotropicDiffusion3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageAnisotropicDiffusion3D::vtkTypeRevisionMacro | ( | vtkImageAnisotropicDiffusion3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageAnisotropicDiffusion3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageAnisotropicDiffusion3D::SetNumberOfIterations ( int num )

This method sets the number of interations which also affects the input neighborhood needed to compute one output pixel. Each iterations requires an extra pixel layer on the neighborhood. This is only relavent when you are trying to stream or are requesting a sub extent of the "wholeExtent".

virtual int vtkImageAnisotropicDiffusion3D::GetNumberOfIterations ( ) [virtual]

Get the number of iterations.

virtual void vtkImageAnisotropicDiffusion3D::SetDiffusionThreshold ( float ) [virtual]

Set/Get the difference threshold that stops diffusion. when the difference between two pixel is greater than this threshold, the pixels are not diffused. This causes diffusion to avoid sharp edges. If the GradientMagnitudeThreshold is set, then gradient magnitude is used for comparison instead of pixel differences.

virtual float vtkImageAnisotropicDiffusion3D::GetDiffusionThreshold ( ) [virtual]

Set/Get the difference threshold that stops diffusion. when the difference between two pixel is greater than this threshold, the pixels are not diffused. This causes diffusion to avoid sharp edges. If the GradientMagnitudeThreshold is set, then gradient magnitude is used for comparison instead of pixel differences.

virtual void vtkImageAnisotropicDiffusion3D::SetDiffusionFactor ( float ) [virtual]

Set/Get the difference factor

virtual float vtkImageAnisotropicDiffusion3D::GetDiffusionFactor ( ) [virtual]

Set/Get the difference factor

virtual void vtkImageAnisotropicDiffusion3D::SetFaces ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion3D::GetFaces ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::FacesOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::FacesOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::SetEdges ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion3D::GetEdges ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::EdgesOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::EdgesOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::SetCorners ( int ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual int vtkImageAnisotropicDiffusion3D::GetCorners ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::CornersOn ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::CornersOff ( ) [virtual]

Choose neighbors to diffuse (6 faces, 12 edges, 8 corners).

virtual void vtkImageAnisotropicDiffusion3D::SetGradientMagnitudeThreshold ( int ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual int vtkImageAnisotropicDiffusion3D::GetGradientMagnitudeThreshold ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual void vtkImageAnisotropicDiffusion3D::GradientMagnitudeThresholdOn ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

virtual void vtkImageAnisotropicDiffusion3D::GradientMagnitudeThresholdOff ( ) [virtual]

Switch between gradient magnitude threshold and pixel gradient threshold.

void vtkImageAnisotropicDiffusion3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

void vtkImageAnisotropicDiffusion3D::Iterate | ( | vtkImageData * | in,
 |  | vtkImageData * | out,
 |  | float | ar0,
 |  | float | ar1,
 |  | float | ar3,
 |  | int * | coreExtent,
 |  | int | count
 | ) | [protected]

Member Data Documentation

int vtkImageAnisotropicDiffusion3D::NumberOfIterations [protected]

Definition at line 121 of file vtkImageAnisotropicDiffusion3D.h.

float vtkImageAnisotropicDiffusion3D::DiffusionThreshold [protected]

Definition at line 122 of file vtkImageAnisotropicDiffusion3D.h.

float vtkImageAnisotropicDiffusion3D::DiffusionFactor [protected]

Definition at line 123 of file vtkImageAnisotropicDiffusion3D.h.

int vtkImageAnisotropicDiffusion3D::Faces [protected]

Definition at line 125 of file vtkImageAnisotropicDiffusion3D.h.

int vtkImageAnisotropicDiffusion3D::Edges [protected]

Definition at line 126 of file vtkImageAnisotropicDiffusion3D.h.

int vtkImageAnisotropicDiffusion3D::Corners [protected]

Definition at line 127 of file vtkImageAnisotropicDiffusion3D.h.

int vtkImageAnisotropicDiffusion3D::GradientMagnitudeThreshold [protected]

Definition at line 129 of file vtkImageAnisotropicDiffusion3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageAnisotropicDiffusion3D.h
Generated on Mon Mar 25 01:18:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAppend Class Reference

Collects data from multiple inputs into one image. More...

#include <vtkImageAppend.h>

Inheritance diagram for vtkImageAppend:

[legend]
Collaboration diagram for vtkImageAppend:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageAppend, vtkImageMultipleInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetAppendAxis (int)
virtual int | GetAppendAxis ()
virtual void | SetPreserveExtents (int)
virtual int | GetPreserveExtents ()
virtual void | PreserveExtentsOn ()
virtual void | PreserveExtentsOff ()

Static Public Methods

vtkImageAppend * | New ()

Protected Methods

vtkImageAppend ()
~vtkImageAppend ()
void | ExecuteInformation (vtkImageData **inputs, vtkImageData *output)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)
void | InitOutput (int outExt[6], vtkImageData *outData)

Protected Attributes

int | PreserveExtents
int | AppendAxis
int * | Shifts

Detailed Description

Collects data from multiple inputs into one image.

Date:
2002/01/22 15:31:50
Revision:
1.26

vtkImageAppend takes the components from multiple inputs and merges them into one output. The output images are append along the "AppendAxis". Except for the append axis, all inputs must have the same extent. All inputs must have the same number of scalar components. A future extension might be to pad or clip inputs to have the same extent. The output has the same origin and spacing as the first input. The origin and spacing of all other inputs are ignored. All inputs must have the same scalar type.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (88%)
Tests:
vtkImageAppend (Tests)

Definition at line 47 of file vtkImageAppend.h.

Constructor & Destructor Documentation

vtkImageAppend::vtkImageAppend ( ) [protected]

vtkImageAppend::~vtkImageAppend ( ) [protected]

Member Function Documentation

vtkImageAppend* vtkImageAppend::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMultipleInputFilter.

vtkImageAppend::vtkTypeRevisionMacro | ( | vtkImageAppend | ,
 |  | vtkImageMultipleInputFilter |
 | ) |

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageAppend::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageAppend::SetAppendAxis ( int ) [virtual]

This axis is expanded to hold the multiple images. The default AppendAxis is the X axis. If you want to create a volue from a series of XY images, then you should set the AppendAxis to 2 (Z axis).

virtual int vtkImageAppend::GetAppendAxis ( ) [virtual]

This axis is expanded to hold the multiple images. The default AppendAxis is the X axis. If you want to create a volue from a series of XY images, then you should set the AppendAxis to 2 (Z axis).

virtual void vtkImageAppend::SetPreserveExtents ( int ) [virtual]

By default "PreserveExtents" is off and the append axis is used. When "PreseveExtents" is on, the extent of the inputs is used to place the image in the output. The whole extent of the output is the union of the input whole extents. Any portion of the output not covered by the inputs is set to zero. The origin and spacing is taken from the first input.

virtual int vtkImageAppend::GetPreserveExtents ( ) [virtual]

By default "PreserveExtents" is off and the append axis is used. When "PreseveExtents" is on, the extent of the inputs is used to place the image in the output. The whole extent of the output is the union of the input whole extents. Any portion of the output not covered by the inputs is set to zero. The origin and spacing is taken from the first input.

virtual void vtkImageAppend::PreserveExtentsOn ( ) [virtual]

By default "PreserveExtents" is off and the append axis is used. When "PreseveExtents" is on, the extent of the inputs is used to place the image in the output. The whole extent of the output is the union of the input whole extents. Any portion of the output not covered by the inputs is set to zero. The origin and spacing is taken from the first input.

virtual void vtkImageAppend::PreserveExtentsOff ( ) [virtual]

By default "PreserveExtents" is off and the append axis is used. When "PreseveExtents" is on, the extent of the inputs is used to place the image in the output. The whole extent of the output is the union of the input whole extents. Any portion of the output not covered by the inputs is set to zero. The origin and spacing is taken from the first input.

void vtkImageAppend::ExecuteInformation | ( | vtkImageData ** | inputs,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageAppend::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageAppend::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 85 of file vtkImageAppend.h.

void vtkImageAppend::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageAppend::InitOutput | ( | int | outExt[6],
 |  | vtkImageData * | outData
 | ) | [protected]

Member Data Documentation

int vtkImageAppend::PreserveExtents [protected]

Definition at line 78 of file vtkImageAppend.h.

int vtkImageAppend::AppendAxis [protected]

Definition at line 79 of file vtkImageAppend.h.

int* vtkImageAppend::Shifts [protected]

Definition at line 81 of file vtkImageAppend.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageAppend.h
Generated on Mon Mar 25 01:18:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageAppendComponents Class Reference

Collects components from two inputs into. More...

#include <vtkImageAppendComponents.h>

Inheritance diagram for vtkImageAppendComponents:

[legend]
Collaboration diagram for vtkImageAppendComponents:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageAppendComponents, vtkImageMultipleInputFilter)
virtual void | SetInput1 (vtkImageData *input)
virtual void | SetInput2 (vtkImageData *input)

Static Public Methods

vtkImageAppendComponents * | New ()

Protected Methods

vtkImageAppendComponents ()
~vtkImageAppendComponents ()
void | ExecuteInformation (vtkImageData **inputs, vtkImageData *output)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Detailed Description

Collects components from two inputs into.

Date:
2002/01/22 15:31:51
Revision:
1.27
one output.

vtkImageAppendComponents takes the components from two inputs and merges them into one output. If Input1 has M components, and Input2 has N components, the output will have M+N components with input1 components coming first.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (61%)
  • Martin, Ken (27%)
  • Schroeder, Will (6%)
Tests:
vtkImageAppendComponents (Tests)

Definition at line 46 of file vtkImageAppendComponents.h.

Constructor & Destructor Documentation

vtkImageAppendComponents::vtkImageAppendComponents ( ) [inline, protected]

Definition at line 64 of file vtkImageAppendComponents.h.

vtkImageAppendComponents::~vtkImageAppendComponents ( ) [inline, protected]

Definition at line 65 of file vtkImageAppendComponents.h.

Member Function Documentation

vtkImageAppendComponents* vtkImageAppendComponents::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMultipleInputFilter.

vtkImageAppendComponents::vtkTypeRevisionMacro | ( | vtkImageAppendComponents | ,
 |  | vtkImageMultipleInputFilter |
 | ) |

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageAppendComponents::SetInput1 ( vtkImageData * input ) [inline, virtual]

Do not use these: They are for legacy compatibility back when this was a two input filter.

Definition at line 56 of file vtkImageAppendComponents.h.

virtual void vtkImageAppendComponents::SetInput2 ( vtkImageData * input ) [inline, virtual]

Do not use these: They are for legacy compatibility back when this was a two input filter.

Definition at line 58 of file vtkImageAppendComponents.h.

void vtkImageAppendComponents::ExecuteInformation | ( | vtkImageData ** | inputs,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageAppendComponents::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 68 of file vtkImageAppendComponents.h.

void vtkImageAppendComponents::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageAppendComponents.h
Generated on Mon Mar 25 01:18:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlend Class Reference

blend images together using alpha or opacity. More...

#include <vtkImageBlend.h>

Inheritance diagram for vtkImageBlend:

[legend]
Collaboration diagram for vtkImageBlend:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageBlend, vtkImageMultipleInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOpacity (int idx, double opacity)
double | GetOpacity (int idx)
virtual void | SetStencil (vtkImageStencilData *)
virtual vtkImageStencilData * | GetStencil ()
virtual void | SetBlendMode (int)
virtual int | GetBlendMode ()
void | SetBlendModeToNormal ()
void | SetBlendModeToCompound ()
const char * | GetBlendModeAsString (void)
virtual void | SetCompoundThreshold (float)
virtual float | GetCompoundThreshold ()

Static Public Methods

vtkImageBlend * | New ()

Protected Methods

vtkImageBlend ()
~vtkImageBlend ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteInformation ()
void | ExecuteInformation (vtkImageData **, vtkImageData *)
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)
void | ExecuteData (vtkDataObject *output)

Protected Attributes

vtkImageStencilData * Stencil
double * | Opacity
int | OpacityArrayLength
int | BlendMode
float | CompoundThreshold
int | DataWasPassed

Detailed Description

blend images together using alpha or opacity.

Date:
2002/01/22 15:31:52
Revision:
1.19

vtkImageBlend takes L, LA, RGB, or RGBA images as input and blends them according to the alpha values and/or the opacity setting for each input.

The spacing, origin, extent, and number of components of the output are the same as those for the first input. If the input has an alpha component, then this component is copied unchanged into the output. In addition, if the first input has either one component or two components i.e. if it is either L (greyscale) or LA (greyscale + alpha) then all other inputs must also be L or LA.

Different blending modes are available:

Normal (default) : This is the standard blending mode used by OpenGL and other graphics packages. The output always has the same number of components and the same extent as the first input. The alpha value of the first input is not used in the blending computation, instead it is copied directly to the output.

 output <- input[0]
 foreach input i {
   foreach pixel px {
     r <- input[i](px)(alpha) * opacity[i]
     f <- (255 - r)
     output(px) <- output(px) * f + input(px) * r
   }
 }

Compound : Images are compounded together and each component is scaled by the sum of the alpha/opacity values. Use the CompoundThreshold method to set specify a threshold in compound mode. Pixels with opacity*alpha less or equal than this threshold are ignored. The alpha value of the first input, if present, is NOT copied to the alpha value of the output. The output always has the same number of components and the same extent as the first input.

 output <- 0
 foreach pixel px {
   sum <- 0
   foreach input i {
     r <- input[i](px)(alpha) * opacity(i)
     sum <- sum + r
     if r > threshold {
       output(px) <- output(px) + input(px) * r
     }
   }
   output(px) <- output(px) / sum
 }
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (60%)
  • Barre, Sebastien (34%)
Tests:
vtkImageBlend (Tests)

Definition at line 97 of file vtkImageBlend.h.

Constructor & Destructor Documentation

vtkImageBlend::vtkImageBlend ( ) [protected]

vtkImageBlend::~vtkImageBlend ( ) [protected]

Member Function Documentation

vtkImageBlend* vtkImageBlend::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMultipleInputFilter.

vtkImageBlend::vtkTypeRevisionMacro | ( | vtkImageBlend | ,
 |  | vtkImageMultipleInputFilter |
 | ) |

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageBlend::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageBlend::SetOpacity | ( | int | idx,
 |  | double | opacity
 | ) |

Set the opacity of an input image: the alpha values of the image are multiplied by the opacity. The opacity of image idx=0 is ignored.

double vtkImageBlend::GetOpacity ( int idx )

Set the opacity of an input image: the alpha values of the image are multiplied by the opacity. The opacity of image idx=0 is ignored.

virtual void vtkImageBlend::SetStencil ( vtkImageStencilData * ) [virtual]

Set a stencil to apply when blending the data.

virtual vtkImageStencilData* vtkImageBlend::GetStencil ( ) [virtual]

Set a stencil to apply when blending the data.

virtual void vtkImageBlend::SetBlendMode ( int ) [virtual]

Set the blend mode

virtual int vtkImageBlend::GetBlendMode ( ) [virtual]

Set the blend mode

void vtkImageBlend::SetBlendModeToNormal ( ) [inline]

Set the blend mode

Definition at line 123 of file vtkImageBlend.h.

void vtkImageBlend::SetBlendModeToCompound ( ) [inline]

Set the blend mode

Definition at line 125 of file vtkImageBlend.h.

const char * vtkImageBlend::GetBlendModeAsString ( void ) [inline]

Get the blending mode as a descriptive string

Definition at line 168 of file vtkImageBlend.h.

virtual void vtkImageBlend::SetCompoundThreshold ( float ) [virtual]

Specify a threshold in compound mode. Pixels with opacity*alpha less or equal the threshold are ignored.

virtual float vtkImageBlend::GetCompoundThreshold ( ) [virtual]

Specify a threshold in compound mode. Pixels with opacity*alpha less or equal the threshold are ignored.

void vtkImageBlend::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageBlend::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 144 of file vtkImageBlend.h.

void vtkImageBlend::ExecuteInformation | ( | vtkImageData ** | inputs,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageBlend::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageBlend::ExecuteData ( vtkDataObject * output ) [protected]

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

vtkImageStencilData* vtkImageBlend::Stencil [protected]

Definition at line 156 of file vtkImageBlend.h.

double* vtkImageBlend::Opacity [protected]

Definition at line 157 of file vtkImageBlend.h.

int vtkImageBlend::OpacityArrayLength [protected]

Definition at line 158 of file vtkImageBlend.h.

int vtkImageBlend::BlendMode [protected]

Definition at line 159 of file vtkImageBlend.h.

float vtkImageBlend::CompoundThreshold [protected]

Definition at line 160 of file vtkImageBlend.h.

int vtkImageBlend::DataWasPassed [protected]

Definition at line 161 of file vtkImageBlend.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageBlend.h
Generated on Mon Mar 25 01:18:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlockReader Class Reference

Breaks up image into blocks and save in files. More...

#include <vtkImageBlockReader.h>

Inheritance diagram for vtkImageBlockReader:

[legend]
Collaboration diagram for vtkImageBlockReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageBlockReader, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDivisions (int, int, int)
virtual void | SetDivisions (int[3])
virtual int * | GetDivisions ()
virtual void | GetDivisions (int &, int &, int &)
virtual void | GetDivisions (int[3])
virtual void | SetOverlap (int)
virtual int | GetOverlap ()
virtual void | SetWholeExtent (int, int, int, int, int, int)
virtual void | SetWholeExtent (int[6])
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetNumberOfScalarComponents (int)
virtual int | GetNumberOfScalarComponents ()
virtual void | SetScalarType (int)
virtual int | GetScalarType ()
virtual void | SetFilePattern (const char *)
virtual char * | GetFilePattern ()

Static Public Methods

vtkImageBlockReader * | New ()

Protected Methods

vtkImageBlockReader ()
~vtkImageBlockReader ()
void | ComputeBlockExtents ()
void | DeleteBlockExtents ()
void | Read (vtkImageData *data, int *ext)
void | ReadRemainder (vtkImageData *data, int *ext, int *doneExt)
void | ReadBlock (int xIdx, int yIdx, int zIdx, vtkImageData *data, int *ext)
void | ModifyOutputUpdateExtent ()
void | Execute (vtkImageData *data)
void | ExecuteInformation ()

Protected Attributes

char * | FilePattern
int | WholeExtent [6]
int | NumberOfScalarComponents
int | ScalarType
int | Divisions [3]
int | Overlap
int * | XExtents
int * | YExtents
int * | ZExtents

Detailed Description

Breaks up image into blocks and save in files.

Date:
2002/01/22 15:34:32
Revision:
1.16

Experimenting with different file formats. This one saves an image in multiple files. I am allowing overlap between file for efficiency.

See also:
vtkImageBlockReader.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (94%)

Definition at line 41 of file vtkImageBlockReader.h.

Constructor & Destructor Documentation

vtkImageBlockReader::vtkImageBlockReader ( ) [protected]

vtkImageBlockReader::~vtkImageBlockReader ( ) [protected]

Member Function Documentation

vtkImageBlockReader* vtkImageBlockReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageBlockReader::vtkTypeRevisionMacro | ( | vtkImageBlockReader | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageBlockReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkImageBlockReader::SetDivisions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockReader::SetDivisions ( int [3] ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual int* vtkImageBlockReader::GetDivisions ( ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockReader::GetDivisions | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockReader::GetDivisions ( int [3] ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockReader::SetOverlap ( int ) [virtual]

The number of points along any axis that belong to more than one piece.

virtual int vtkImageBlockReader::GetOverlap ( ) [virtual]

The number of points along any axis that belong to more than one piece.

virtual void vtkImageBlockReader::SetWholeExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::SetWholeExtent ( int [6] ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual int* vtkImageBlockReader::GetWholeExtent ( ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::GetWholeExtent ( int [6] ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::SetNumberOfScalarComponents ( int ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual int vtkImageBlockReader::GetNumberOfScalarComponents ( ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::SetScalarType ( int ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual int vtkImageBlockReader::GetScalarType ( ) [virtual]

Although this information could be gotten from the files, this is easy.

virtual void vtkImageBlockReader::SetFilePattern ( const char * ) [virtual]

This printf pattern should take three integers, one for each axis.

virtual char* vtkImageBlockReader::GetFilePattern ( ) [virtual]

This printf pattern should take three integers, one for each axis.

void vtkImageBlockReader::Execute ( vtkImageData * data ) [protected, virtual]

Write the files.

Reimplemented from vtkImageSource.

void vtkImageBlockReader::ExecuteInformation ( ) [protected, virtual]

Write the files.

Reimplemented from vtkSource.

void vtkImageBlockReader::ComputeBlockExtents ( ) [protected]

void vtkImageBlockReader::DeleteBlockExtents ( ) [protected]

void vtkImageBlockReader::Read | ( | vtkImageData * | data,
 |  | int * | ext
 | ) | [protected]

void vtkImageBlockReader::ReadRemainder | ( | vtkImageData * | data,
 |  | int * | ext,
 |  | int * | doneExt
 | ) | [protected]

void vtkImageBlockReader::ReadBlock | ( | int | xIdx,
 |  | int | yIdx,
 |  | int | zIdx,
 |  | vtkImageData * | data,
 |  | int * | ext
 | ) | [protected]

void vtkImageBlockReader::ModifyOutputUpdateExtent ( ) [protected]

Generate more than requested. Called by the superclass before an execute, and before output memory is allocated.

Member Data Documentation

char* vtkImageBlockReader::FilePattern [protected]

Definition at line 95 of file vtkImageBlockReader.h.

int vtkImageBlockReader::WholeExtent[6] [protected]

Definition at line 97 of file vtkImageBlockReader.h.

int vtkImageBlockReader::NumberOfScalarComponents [protected]

Definition at line 98 of file vtkImageBlockReader.h.

int vtkImageBlockReader::ScalarType [protected]

Definition at line 99 of file vtkImageBlockReader.h.

int vtkImageBlockReader::Divisions[3] [protected]

Definition at line 100 of file vtkImageBlockReader.h.

int vtkImageBlockReader::Overlap [protected]

Definition at line 101 of file vtkImageBlockReader.h.

int* vtkImageBlockReader::XExtents [protected]

Definition at line 125 of file vtkImageBlockReader.h.

int* vtkImageBlockReader::YExtents [protected]

Definition at line 126 of file vtkImageBlockReader.h.

int* vtkImageBlockReader::ZExtents [protected]

Definition at line 127 of file vtkImageBlockReader.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkImageBlockReader.h
Generated on Mon Mar 25 01:18:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageBlockWriter Class Reference

Breaks up image into blocks and save in files. More...

#include <vtkImageBlockWriter.h>

Inheritance diagram for vtkImageBlockWriter:

[legend]
Collaboration diagram for vtkImageBlockWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageBlockWriter, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Write ()
virtual void | SetDivisions (int, int, int)
virtual void | SetDivisions (int[3])
virtual int * | GetDivisions ()
virtual void | GetDivisions (int &, int &, int &)
virtual void | GetDivisions (int[3])
virtual void | SetOverlap (int)
virtual int | GetOverlap ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | SetFilePattern (const char *)
virtual char * | GetFilePattern ()

Static Public Methods

vtkImageBlockWriter * | New ()

Protected Methods

vtkImageBlockWriter ()
~vtkImageBlockWriter ()

Protected Attributes

char * | FilePattern
int | Divisions [3]
int | Overlap

Detailed Description

Breaks up image into blocks and save in files.

Date:
2002/01/22 15:34:33
Revision:
1.15

Experimenting with different file formats. This one saves an image in multiple files. I am allowing overlap between file for efficiency.

See also:
vtkImageBlockReader.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (95%)

Definition at line 41 of file vtkImageBlockWriter.h.

Constructor & Destructor Documentation

vtkImageBlockWriter::vtkImageBlockWriter ( ) [protected]

vtkImageBlockWriter::~vtkImageBlockWriter ( ) [protected]

Member Function Documentation

vtkImageBlockWriter* vtkImageBlockWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkImageBlockWriter::vtkTypeRevisionMacro | ( | vtkImageBlockWriter | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

void vtkImageBlockWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

virtual void vtkImageBlockWriter::SetDivisions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockWriter::SetDivisions ( int [3] ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual int* vtkImageBlockWriter::GetDivisions ( ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockWriter::GetDivisions | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockWriter::GetDivisions ( int [3] ) [virtual]

The whole extent is broken up into this many divisions along each axis.

virtual void vtkImageBlockWriter::SetOverlap ( int ) [virtual]

The number of points along any axis that belong to more than one piece.

virtual int vtkImageBlockWriter::GetOverlap ( ) [virtual]

The number of points along any axis that belong to more than one piece.

void vtkImageBlockWriter::SetInput ( vtkImageData * input )

This writer takes images as input.

vtkImageData* vtkImageBlockWriter::GetInput ( )

This writer takes images as input.

virtual void vtkImageBlockWriter::SetFilePattern ( const char * ) [virtual]

This printf pattern should take three integers, one for each axis.

virtual char* vtkImageBlockWriter::GetFilePattern ( ) [virtual]

This printf pattern should take three integers, one for each axis.

void vtkImageBlockWriter::Write ( )

Write the files.

Member Data Documentation

char* vtkImageBlockWriter::FilePattern [protected]

Definition at line 82 of file vtkImageBlockWriter.h.

int vtkImageBlockWriter::Divisions[3] [protected]

Definition at line 84 of file vtkImageBlockWriter.h.

int vtkImageBlockWriter::Overlap [protected]

Definition at line 85 of file vtkImageBlockWriter.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkImageBlockWriter.h
Generated on Mon Mar 25 01:18:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageButterworthHighPass Class Reference

Frequency domain high pass. More...

#include <vtkImageButterworthHighPass.h>

Inheritance diagram for vtkImageButterworthHighPass:

[legend]
Collaboration diagram for vtkImageButterworthHighPass:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageButterworthHighPass, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCutOff (float, float, float)
virtual void | SetCutOff (float[3])
void | SetCutOff (float v)
void | SetXCutOff (float v)
void | SetYCutOff (float v)
void | SetZCutOff (float v)
virtual float * | GetCutOff ()
virtual void | GetCutOff (float &, float &, float &)
virtual void | GetCutOff (float[3])
float | GetXCutOff ()
float | GetYCutOff ()
float | GetZCutOff ()
virtual void | SetOrder (int)
virtual int | GetOrder ()

Static Public Methods

vtkImageButterworthHighPass * | New ()

Protected Methods

vtkImageButterworthHighPass ()
~vtkImageButterworthHighPass ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

int | Order
float | CutOff [3]

Detailed Description

Frequency domain high pass.

Date:
2002/01/22 15:31:54
Revision:
1.21

This filter only works on an image after it has been converted to frequency domain by a vtkImageFFT filter. A vtkImageRFFT filter can be used to convert the output back into the spatial domain. vtkImageButterworthHighPass the frequency components around 0 are attenuated. Input and output are in floats, with two components (complex numbers). out(i, j) = 1 / (1 + pow(CutOff/Freq(i,j), 2*Order));

See also:
vtkImageButterworthLowPass
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (77%)
  • Lorensen, Bill (11%)
  • Martin, Ken (5%)
Tests:
vtkImageButterworthHighPass (Tests)

Definition at line 51 of file vtkImageButterworthHighPass.h.

Constructor & Destructor Documentation

vtkImageButterworthHighPass::vtkImageButterworthHighPass ( ) [protected]

vtkImageButterworthHighPass::~vtkImageButterworthHighPass ( ) [inline, protected]

Definition at line 81 of file vtkImageButterworthHighPass.h.

Member Function Documentation

vtkImageButterworthHighPass* vtkImageButterworthHighPass::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageButterworthHighPass::vtkTypeRevisionMacro | ( | vtkImageButterworthHighPass | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageButterworthHighPass::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageButterworthHighPass::SetCutOff | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthHighPass::SetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthHighPass::SetCutOff ( float v ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 63 of file vtkImageButterworthHighPass.h.

void vtkImageButterworthHighPass::SetXCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthHighPass::SetYCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthHighPass::SetZCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual float* vtkImageButterworthHighPass::GetCutOff ( ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthHighPass::GetCutOff | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthHighPass::GetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

float vtkImageButterworthHighPass::GetXCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 68 of file vtkImageButterworthHighPass.h.

float vtkImageButterworthHighPass::GetYCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 69 of file vtkImageButterworthHighPass.h.

float vtkImageButterworthHighPass::GetZCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 70 of file vtkImageButterworthHighPass.h.

virtual void vtkImageButterworthHighPass::SetOrder ( int ) [virtual]

The order determines sharpness of the cutoff curve.

virtual int vtkImageButterworthHighPass::GetOrder ( ) [virtual]

The order determines sharpness of the cutoff curve.

void vtkImageButterworthHighPass::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageButterworthHighPass::Order [protected]

Definition at line 83 of file vtkImageButterworthHighPass.h.

float vtkImageButterworthHighPass::CutOff[3] [protected]

Definition at line 84 of file vtkImageButterworthHighPass.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageButterworthHighPass.h
Generated on Mon Mar 25 01:18:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageButterworthLowPass Class Reference

Frequency domain Low pass. More...

#include <vtkImageButterworthLowPass.h>

Inheritance diagram for vtkImageButterworthLowPass:

[legend]
Collaboration diagram for vtkImageButterworthLowPass:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageButterworthLowPass, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCutOff (float, float, float)
virtual void | SetCutOff (float[3])
void | SetCutOff (float v)
void | SetXCutOff (float v)
void | SetYCutOff (float v)
void | SetZCutOff (float v)
virtual float * | GetCutOff ()
virtual void | GetCutOff (float &, float &, float &)
virtual void | GetCutOff (float[3])
float | GetXCutOff ()
float | GetYCutOff ()
float | GetZCutOff ()
virtual void | SetOrder (int)
virtual int | GetOrder ()

Static Public Methods

vtkImageButterworthLowPass * | New ()

Protected Methods

vtkImageButterworthLowPass ()
~vtkImageButterworthLowPass ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

int | Order
float | CutOff [3]

Detailed Description

Frequency domain Low pass.

Date:
2002/01/22 15:31:55
Revision:
1.21

This filter only works on an image after it has been converted to frequency domain by a vtkImageFFT filter. A vtkImageRFFT filter can be used to convert the output back into the spatial domain. vtkImageButterworthLowPass the high frequency components are attenuated. Input and output are in floats, with two components (complex numbers). out(i, j) = (1 + pow(CutOff/Freq(i,j), 2*Order));

See also:
vtkImageButterworthHighPass vtkImageFFT vtkImageRFFT
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (78%)
  • Lorensen, Bill (10%)
  • Martin, Ken (5%)
Tests:
vtkImageButterworthLowPass (Tests)

Definition at line 51 of file vtkImageButterworthLowPass.h.

Constructor & Destructor Documentation

vtkImageButterworthLowPass::vtkImageButterworthLowPass ( ) [protected]

vtkImageButterworthLowPass::~vtkImageButterworthLowPass ( ) [inline, protected]

Definition at line 82 of file vtkImageButterworthLowPass.h.

Member Function Documentation

vtkImageButterworthLowPass* vtkImageButterworthLowPass::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageButterworthLowPass::vtkTypeRevisionMacro | ( | vtkImageButterworthLowPass | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageButterworthLowPass::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageButterworthLowPass::SetCutOff | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthLowPass::SetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthLowPass::SetCutOff ( float v ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 63 of file vtkImageButterworthLowPass.h.

void vtkImageButterworthLowPass::SetXCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthLowPass::SetYCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageButterworthLowPass::SetZCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual float* vtkImageButterworthLowPass::GetCutOff ( ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthLowPass::GetCutOff | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageButterworthLowPass::GetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

float vtkImageButterworthLowPass::GetXCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 68 of file vtkImageButterworthLowPass.h.

float vtkImageButterworthLowPass::GetYCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 69 of file vtkImageButterworthLowPass.h.

float vtkImageButterworthLowPass::GetZCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 70 of file vtkImageButterworthLowPass.h.

virtual void vtkImageButterworthLowPass::SetOrder ( int ) [virtual]

The order determines sharpness of the cutoff curve.

virtual int vtkImageButterworthLowPass::GetOrder ( ) [virtual]

The order determines sharpness of the cutoff curve.

void vtkImageButterworthLowPass::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageButterworthLowPass::Order [protected]

Definition at line 84 of file vtkImageButterworthLowPass.h.

float vtkImageButterworthLowPass::CutOff[3] [protected]

Definition at line 85 of file vtkImageButterworthLowPass.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageButterworthLowPass.h
Generated on Mon Mar 25 01:18:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCacheFilter Class Reference

Caches multiple vtkImageData objects. More...

#include <vtkImageCacheFilter.h>

Inheritance diagram for vtkImageCacheFilter:

[legend]
Collaboration diagram for vtkImageCacheFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCacheFilter, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | UpdateData (vtkDataObject *outData)
void | SetCacheSize (int size)
virtual int | GetCacheSize ()

Static Public Methods

vtkImageCacheFilter * | New ()

Protected Methods

vtkImageCacheFilter ()
~vtkImageCacheFilter ()

Protected Attributes

int | CacheSize
vtkImageData ** Data
unsigned long * | Times

Detailed Description

Caches multiple vtkImageData objects.

Date:
2002/01/22 15:31:56
Revision:
1.17

vtkImageCacheFilter keep a number of vtkImageDataObjects from previous updates to satisfy future updates without needing to update the input. It does not change the data at all. It just makes the pipeline more efficient at the expense of using extra memory.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (92%)
Tests:
vtkImageCacheFilter (Tests)

Definition at line 42 of file vtkImageCacheFilter.h.

Constructor & Destructor Documentation

vtkImageCacheFilter::vtkImageCacheFilter ( ) [protected]

vtkImageCacheFilter::~vtkImageCacheFilter ( ) [protected]

Member Function Documentation

vtkImageCacheFilter* vtkImageCacheFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageCacheFilter::vtkTypeRevisionMacro | ( | vtkImageCacheFilter | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageCacheFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageCacheFilter::SetCacheSize ( int size )

This is the maximum number of images that can be retained in memory. it defaults to 10.

virtual int vtkImageCacheFilter::GetCacheSize ( ) [virtual]

This is the maximum number of images that can be retained in memory. it defaults to 10.

void vtkImageCacheFilter::UpdateData ( vtkDataObject * outData ) [virtual]

This is an internal method that you should not call.

Reimplemented from vtkSource.

Member Data Documentation

int vtkImageCacheFilter::CacheSize [protected]

Definition at line 63 of file vtkImageCacheFilter.h.

vtkImageData** vtkImageCacheFilter::Data [protected]

Definition at line 65 of file vtkImageCacheFilter.h.

unsigned long* vtkImageCacheFilter::Times [protected]

Definition at line 67 of file vtkImageCacheFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCacheFilter.h
Generated on Mon Mar 25 01:18:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCanvasSource2D Class Reference

Paints on a canvas. More...

#include <vtkImageCanvasSource2D.h>

Inheritance diagram for vtkImageCanvasSource2D:

[legend]
Collaboration diagram for vtkImageCanvasSource2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCanvasSource2D, vtkStructuredPoints)
void | PrintSelf (ostream &os, vtkIndent indent)
void | FillBox (int min0, int max0, int min1, int max1)
void | FillTube (int x0, int y0, int x1, int y1, float radius)
void | FillTriangle (int x0, int y0, int x1, int y1, int x2, int y2)
void | DrawCircle (int c0, int c1, float radius)
void | DrawPoint (int p0, int p1)
void | DrawSegment (int x0, int y0, int x1, int y1)
void | DrawSegment3D (float *p0, float *p1)
void | DrawSegment3D (float x1, float y1, float z1, float x2, float y2, float z2)
void | FillPixel (int x, int y)
vtkImageData * GetOutput ()
void | SetImageData (vtkImageData *image)
virtual vtkImageData * | GetImageData ()
virtual void | SetDrawColor (float, float, float, float)
virtual void | SetDrawColor (float[4])
virtual float * | GetDrawColor ()
virtual void | GetDrawColor (float &, float &, float &, float &)
virtual void | GetDrawColor (float[4])
void | SetDrawColor (float a)
void | SetDrawColor (float a, float b)
void | SetDrawColor (float a, float b, float c)
void | SetExtent (int *extent)
void | SetExtent (int x1, int x2, int y1, int y2, int z1, int z2)
virtual void | SetDefaultZ (int)
virtual int | GetDefaultZ ()
virtual void | SetRatio (float, float, float)
virtual void | SetRatio (float[3])
virtual float * | GetRatio ()
virtual void | GetRatio (float &, float &, float &)
virtual void | GetRatio (float[3])

Static Public Methods

vtkImageCanvasSource2D * | New ()

Protected Methods

vtkImageCanvasSource2D ()
~vtkImageCanvasSource2D ()
int | ClipSegment (int &a0, int &a1, int &b0, int &b1)

Protected Attributes

vtkImageData * ImageData
float | DrawColor [4]
int | DefaultZ
float | Ratio [3]

Detailed Description

Paints on a canvas.

Date:
2002/03/11 20:10:45
Revision:
1.29

vtkImageCanvasSource2D is a source that starts as a blank image. you may add to the image with two-dimensional drawing routines. It can paint multi-spectral images. This object is unusual because it is a data object itself and not a source.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (64%)
  • Martin, Ken (15%)
  • Barre, Sebastien (8%)
  • Lorensen, Bill (8%)
Examples:
vtkImageCanvasSource2D (Examples)
Tests:
vtkImageCanvasSource2D (Tests)

Definition at line 68 of file vtkImageCanvasSource2D.h.

Constructor & Destructor Documentation

vtkImageCanvasSource2D::vtkImageCanvasSource2D ( ) [protected]

vtkImageCanvasSource2D::~vtkImageCanvasSource2D ( ) [protected]

Member Function Documentation

vtkImageCanvasSource2D* vtkImageCanvasSource2D::New ( ) [static]

Construct an instance of vtkImageCanvasSource2D with no data.

Reimplemented from vtkStructuredPoints.

vtkImageCanvasSource2D::vtkTypeRevisionMacro | ( | vtkImageCanvasSource2D | ,
 |  | vtkStructuredPoints |
 | ) |

Reimplemented from vtkStructuredPoints.

void vtkImageCanvasSource2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageData.

void vtkImageCanvasSource2D::SetImageData ( vtkImageData * image )

To draw into a different image, set it with this method.

virtual vtkImageData* vtkImageCanvasSource2D::GetImageData ( ) [virtual]

To draw into a different image, set it with this method.

virtual void vtkImageCanvasSource2D::SetDrawColor | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

virtual void vtkImageCanvasSource2D::SetDrawColor ( float [4] ) [virtual]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

virtual float* vtkImageCanvasSource2D::GetDrawColor ( ) [virtual]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

virtual void vtkImageCanvasSource2D::GetDrawColor | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

virtual void vtkImageCanvasSource2D::GetDrawColor ( float [4] ) [virtual]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

void vtkImageCanvasSource2D::SetDrawColor ( float a ) [inline]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

Definition at line 88 of file vtkImageCanvasSource2D.h.

void vtkImageCanvasSource2D::SetDrawColor | ( | float | a,
 |  | float | b
 | ) | [inline]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

Definition at line 89 of file vtkImageCanvasSource2D.h.

void vtkImageCanvasSource2D::SetDrawColor | ( | float | a,
 |  | float | b,
 |  | float | c
 | ) | [inline]

Set/Get DrawValue. This is the value that is used when filling data or drawing lines.

Definition at line 90 of file vtkImageCanvasSource2D.h.

void vtkImageCanvasSource2D::FillBox | ( | int | min0,
 |  | int | max0,
 |  | int | min1,
 |  | int | max1
 | ) |

void vtkImageCanvasSource2D::FillTube | ( | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | float | radius
 | ) |

void vtkImageCanvasSource2D::FillTriangle | ( | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) |

void vtkImageCanvasSource2D::DrawCircle | ( | int | c0,
 |  | int | c1,
 |  | float | radius
 | ) |

void vtkImageCanvasSource2D::DrawPoint | ( | int | p0,
 |  | int | p1
 | ) |

void vtkImageCanvasSource2D::DrawSegment | ( | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1
 | ) |

void vtkImageCanvasSource2D::DrawSegment3D | ( | float * | p0,
 |  | float * | p1
 | ) |

void vtkImageCanvasSource2D::DrawSegment3D | ( | float | x1,
 |  | float | y1,
 |  | float | z1,
 |  | float | x2,
 |  | float | y2,
 |  | float | z2
 | ) | [inline]

Definition at line 100 of file vtkImageCanvasSource2D.h.

void vtkImageCanvasSource2D::FillPixel | ( | int | x,
 |  | int | y
 | ) |

Fill a colored area with another color. (like connectivity) All pixels connected (and with the same value) to pixel (x, y) get replaced by the current "DrawColor".

vtkImageData* vtkImageCanvasSource2D::GetOutput ( ) [inline]

To make Canvas source more like other sources, this get output method should be used.

Definition at line 112 of file vtkImageCanvasSource2D.h.

void vtkImageCanvasSource2D::SetExtent ( int * extent )

These methods also set the WholeExtent of this "DataObject". This is just like vtkImageData. It sets the size of the canvas. Extent is a min max 3D box. Minimums and maximums are inclusive.

void vtkImageCanvasSource2D::SetExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) |

These methods also set the WholeExtent of this "DataObject". This is just like vtkImageData. It sets the size of the canvas. Extent is a min max 3D box. Minimums and maximums are inclusive.

Reimplemented from vtkImageData.

virtual void vtkImageCanvasSource2D::SetDefaultZ ( int ) [virtual]

The drawing operations can only draw into one 2D XY plane at a time. If the canvas is a 3D volume, then this z value is used as the default for 2D operations.

virtual int vtkImageCanvasSource2D::GetDefaultZ ( ) [virtual]

The drawing operations can only draw into one 2D XY plane at a time. If the canvas is a 3D volume, then this z value is used as the default for 2D operations.

virtual void vtkImageCanvasSource2D::SetRatio | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get Ratio. This is the value that is used to pre-multiply each (x, y, z) drawing coordinates (including DefaultZ).

virtual void vtkImageCanvasSource2D::SetRatio ( float [3] ) [virtual]

Set/Get Ratio. This is the value that is used to pre-multiply each (x, y, z) drawing coordinates (including DefaultZ).

virtual float* vtkImageCanvasSource2D::GetRatio ( ) [virtual]

Set/Get Ratio. This is the value that is used to pre-multiply each (x, y, z) drawing coordinates (including DefaultZ).

virtual void vtkImageCanvasSource2D::GetRatio | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get Ratio. This is the value that is used to pre-multiply each (x, y, z) drawing coordinates (including DefaultZ).

virtual void vtkImageCanvasSource2D::GetRatio ( float [3] ) [virtual]

Set/Get Ratio. This is the value that is used to pre-multiply each (x, y, z) drawing coordinates (including DefaultZ).

int vtkImageCanvasSource2D::ClipSegment | ( | int & | a0,
 |  | int & | a1,
 |  | int & | b0,
 |  | int & | b1
 | ) | [protected]

Member Data Documentation

vtkImageData* vtkImageCanvasSource2D::ImageData [protected]

Definition at line 144 of file vtkImageCanvasSource2D.h.

float vtkImageCanvasSource2D::DrawColor[4] [protected]

Definition at line 145 of file vtkImageCanvasSource2D.h.

int vtkImageCanvasSource2D::DefaultZ [protected]

Definition at line 146 of file vtkImageCanvasSource2D.h.

float vtkImageCanvasSource2D::Ratio[3] [protected]

Definition at line 147 of file vtkImageCanvasSource2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCanvasSource2D.h
Generated on Mon Mar 25 01:18:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCanvasSource2DPixel Class Reference

#include <vtkImageCanvasSource2D.h>

Collaboration diagram for vtkImageCanvasSource2DPixel:

[legend]
List of all members.

Static Public Methods

vtkImageCanvasSource2DPixel * | New ()

Public Attributes

int | X
int | Y
void * | Pointer
vtkImageCanvasSource2DPixel * | Next

Member Function Documentation

vtkImageCanvasSource2DPixel* vtkImageCanvasSource2DPixel::New ( ) [inline, static]

Definition at line 57 of file vtkImageCanvasSource2D.h.

Member Data Documentation

int vtkImageCanvasSource2DPixel::X

Definition at line 59 of file vtkImageCanvasSource2D.h.

int vtkImageCanvasSource2DPixel::Y

Definition at line 60 of file vtkImageCanvasSource2D.h.

void* vtkImageCanvasSource2DPixel::Pointer

Definition at line 61 of file vtkImageCanvasSource2D.h.

vtkImageCanvasSource2DPixel* vtkImageCanvasSource2DPixel::Next

Definition at line 62 of file vtkImageCanvasSource2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCanvasSource2D.h
Generated on Mon Mar 25 01:18:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCast Class Reference

Image Data type Casting Filter. More...

#include <vtkImageCast.h>

Inheritance diagram for vtkImageCast:

[legend]
Collaboration diagram for vtkImageCast:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCast, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOutputScalarType (int)
virtual int | GetOutputScalarType ()
void | SetOutputScalarTypeToFloat ()
void | SetOutputScalarTypeToDouble ()
void | SetOutputScalarTypeToInt ()
void | SetOutputScalarTypeToUnsignedInt ()
void | SetOutputScalarTypeToLong ()
void | SetOutputScalarTypeToUnsignedLong ()
void | SetOutputScalarTypeToShort ()
void | SetOutputScalarTypeToUnsignedShort ()
void | SetOutputScalarTypeToUnsignedChar ()
void | SetOutputScalarTypeToChar ()
virtual void | SetClampOverflow (int)
virtual int | GetClampOverflow ()
virtual void | ClampOverflowOn ()
virtual void | ClampOverflowOff ()

Static Public Methods

vtkImageCast * | New ()

Protected Methods

vtkImageCast ()
~vtkImageCast ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | UpdateData (vtkDataObject *data)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

int | ClampOverflow
int | OutputScalarType

Detailed Description

Image Data type Casting Filter.

Date:
2002/01/22 15:31:58
Revision:
1.37

vtkImageCast filter casts the input type to match the output type in the image processing pipeline. The filter does nothing if the input already has the correct type. To specify the "CastTo" type, use "SetOutputScalarType" method.

See also:
vtkImageThreshold vtkImageShiftScale
Created by:
  • Alyassin, Majeid
Contributed by (if > 5%):
  • Alyassin, Majeid (27%)
  • Martin, Ken (27%)
  • Law, Charles (21%)
  • Lorensen, Bill (12%)
Tests:
vtkImageCast (Tests)

Definition at line 49 of file vtkImageCast.h.

Constructor & Destructor Documentation

vtkImageCast::vtkImageCast ( ) [protected]

vtkImageCast::~vtkImageCast ( ) [inline, protected]

Definition at line 89 of file vtkImageCast.h.

Member Function Documentation

vtkImageCast* vtkImageCast::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageCast::vtkTypeRevisionMacro | ( | vtkImageCast | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageCast::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageCast::SetOutputScalarType ( int ) [virtual]

Set the desired output scalar type to cast to.

virtual int vtkImageCast::GetOutputScalarType ( ) [virtual]

Set the desired output scalar type to cast to.

void vtkImageCast::SetOutputScalarTypeToFloat ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 60 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToDouble ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 61 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToInt ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 62 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToUnsignedInt ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 63 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToLong ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 65 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToUnsignedLong ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 66 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToShort ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 68 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToUnsignedShort ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 69 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToUnsignedChar ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 71 of file vtkImageCast.h.

void vtkImageCast::SetOutputScalarTypeToChar ( ) [inline]

Set the desired output scalar type to cast to.

Definition at line 73 of file vtkImageCast.h.

virtual void vtkImageCast::SetClampOverflow ( int ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default ClampOverflow is off.

virtual int vtkImageCast::GetClampOverflow ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default ClampOverflow is off.

virtual void vtkImageCast::ClampOverflowOn ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default ClampOverflow is off.

virtual void vtkImageCast::ClampOverflowOff ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default ClampOverflow is off.

void vtkImageCast::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageCast::UpdateData ( vtkDataObject * data ) [protected, virtual]

Reimplemented from vtkSource.

void vtkImageCast::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 95 of file vtkImageCast.h.

void vtkImageCast::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageCast::ClampOverflow [protected]

Definition at line 91 of file vtkImageCast.h.

int vtkImageCast::OutputScalarType [protected]

Definition at line 92 of file vtkImageCast.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCast.h
Generated on Mon Mar 25 01:18:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageChangeInformation Class Reference

modify spacing, origin and extent. More...

#include <vtkImageChangeInformation.h>

Inheritance diagram for vtkImageChangeInformation:

[legend]
Collaboration diagram for vtkImageChangeInformation:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageChangeInformation, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInformationInput (vtkImageData *)
virtual vtkImageData * | GetInformationInput ()
virtual void | SetOutputExtentStart (int, int, int)
virtual void | SetOutputExtentStart (int[3])
virtual int * | GetOutputExtentStart ()
virtual void | GetOutputExtentStart (int &, int &, int &)
virtual void | GetOutputExtentStart (int[3])
virtual void | SetOutputSpacing (float, float, float)
virtual void | SetOutputSpacing (float[3])
virtual float * | GetOutputSpacing ()
virtual void | GetOutputSpacing (float &, float &, float &)
virtual void | GetOutputSpacing (float[3])
virtual void | SetOutputOrigin (float, float, float)
virtual void | SetOutputOrigin (float[3])
virtual float * | GetOutputOrigin ()
virtual void | GetOutputOrigin (float &, float &, float &)
virtual void | GetOutputOrigin (float[3])
virtual void | SetCenterImage (int)
virtual void | CenterImageOn ()
virtual void | CenterImageOff ()
virtual int | GetCenterImage ()
virtual void | SetExtentTranslation (int, int, int)
virtual void | SetExtentTranslation (int[3])
virtual int * | GetExtentTranslation ()
virtual void | GetExtentTranslation (int &, int &, int &)
virtual void | GetExtentTranslation (int[3])
virtual void | SetSpacingScale (float, float, float)
virtual void | SetSpacingScale (float[3])
virtual float * | GetSpacingScale ()
virtual void | GetSpacingScale (float &, float &, float &)
virtual void | GetSpacingScale (float[3])
virtual void | SetOriginTranslation (float, float, float)
virtual void | SetOriginTranslation (float[3])
virtual float * | GetOriginTranslation ()
virtual void | GetOriginTranslation (float &, float &, float &)
virtual void | GetOriginTranslation (float[3])
virtual void | SetOriginScale (float, float, float)
virtual void | SetOriginScale (float[3])
virtual float * | GetOriginScale ()
virtual void | GetOriginScale (float &, float &, float &)
virtual void | GetOriginScale (float[3])

Static Public Methods

vtkImageChangeInformation * | New ()

Protected Methods

vtkImageChangeInformation ()
~vtkImageChangeInformation ()
void | ComputeInputUpdateExtent (int extent[6], int wholeExtent[6])
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *data)

Protected Attributes

vtkImageData * InformationInput
int | CenterImage
int | OutputExtentStart [3]
int | ExtentTranslation [3]
int | FinalExtentTranslation [3]
float | OutputSpacing [3]
float | SpacingScale [3]
float | OutputOrigin [3]
float | OriginScale [3]
float | OriginTranslation [3]

Detailed Description

modify spacing, origin and extent.

Date:
2002/01/22 15:31:59
Revision:
1.6

vtkImageChangeInformation modify the spacing, origin, or extent of the data without changing the data itself. The data is not resampled by this filter, only the information accompanying the data is modified.

Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)
Tests:
vtkImageChangeInformation (Tests)

Definition at line 41 of file vtkImageChangeInformation.h.

Constructor & Destructor Documentation

vtkImageChangeInformation::vtkImageChangeInformation ( ) [protected]

vtkImageChangeInformation::~vtkImageChangeInformation ( ) [protected]

Member Function Documentation

vtkImageChangeInformation* vtkImageChangeInformation::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageChangeInformation::vtkTypeRevisionMacro | ( | vtkImageChangeInformation | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageChangeInformation::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageChangeInformation::SetInformationInput ( vtkImageData * ) [virtual]

Copy the information from another data set. By default, the information is copied from the input.

virtual vtkImageData* vtkImageChangeInformation::GetInformationInput ( ) [virtual]

Copy the information from another data set. By default, the information is copied from the input.

virtual void vtkImageChangeInformation::SetOutputExtentStart | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify new starting values for the extent explicitly. These values are used as WholeExtent[0], WholeExtent[2] and WholeExtent[4] of the output. The default is to the use the extent start of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetOutputExtentStart ( int [3] ) [virtual]

Specify new starting values for the extent explicitly. These values are used as WholeExtent[0], WholeExtent[2] and WholeExtent[4] of the output. The default is to the use the extent start of the Input, or of the InformationInput if InformationInput is set.

virtual int* vtkImageChangeInformation::GetOutputExtentStart ( ) [virtual]

Specify new starting values for the extent explicitly. These values are used as WholeExtent[0], WholeExtent[2] and WholeExtent[4] of the output. The default is to the use the extent start of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputExtentStart | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Specify new starting values for the extent explicitly. These values are used as WholeExtent[0], WholeExtent[2] and WholeExtent[4] of the output. The default is to the use the extent start of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputExtentStart ( int [3] ) [virtual]

Specify new starting values for the extent explicitly. These values are used as WholeExtent[0], WholeExtent[2] and WholeExtent[4] of the output. The default is to the use the extent start of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetOutputSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a new data spacing explicitly. The default is to use the spacing of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetOutputSpacing ( float [3] ) [virtual]

Specify a new data spacing explicitly. The default is to use the spacing of the Input, or of the InformationInput if InformationInput is set.

virtual float* vtkImageChangeInformation::GetOutputSpacing ( ) [virtual]

Specify a new data spacing explicitly. The default is to use the spacing of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Specify a new data spacing explicitly. The default is to use the spacing of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputSpacing ( float [3] ) [virtual]

Specify a new data spacing explicitly. The default is to use the spacing of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetOutputOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a new data origin explicitly. The default is to use the origin of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetOutputOrigin ( float [3] ) [virtual]

Specify a new data origin explicitly. The default is to use the origin of the Input, or of the InformationInput if InformationInput is set.

virtual float* vtkImageChangeInformation::GetOutputOrigin ( ) [virtual]

Specify a new data origin explicitly. The default is to use the origin of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Specify a new data origin explicitly. The default is to use the origin of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::GetOutputOrigin ( float [3] ) [virtual]

Specify a new data origin explicitly. The default is to use the origin of the Input, or of the InformationInput if InformationInput is set.

virtual void vtkImageChangeInformation::SetCenterImage ( int ) [virtual]

Set the Origin of the output so that image coordinate (0,0,0) lies at the Center of the data set. This will override SetOutputOrigin. This is often a useful operation to apply before using vtkImageReslice to apply a transformation to an image.

virtual void vtkImageChangeInformation::CenterImageOn ( ) [virtual]

Set the Origin of the output so that image coordinate (0,0,0) lies at the Center of the data set. This will override SetOutputOrigin. This is often a useful operation to apply before using vtkImageReslice to apply a transformation to an image.

virtual void vtkImageChangeInformation::CenterImageOff ( ) [virtual]

Set the Origin of the output so that image coordinate (0,0,0) lies at the Center of the data set. This will override SetOutputOrigin. This is often a useful operation to apply before using vtkImageReslice to apply a transformation to an image.

virtual int vtkImageChangeInformation::GetCenterImage ( ) [virtual]

Set the Origin of the output so that image coordinate (0,0,0) lies at the Center of the data set. This will override SetOutputOrigin. This is often a useful operation to apply before using vtkImageReslice to apply a transformation to an image.

virtual void vtkImageChangeInformation::SetExtentTranslation | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Apply a translation to the extent.

virtual void vtkImageChangeInformation::SetExtentTranslation ( int [3] ) [virtual]

Apply a translation to the extent.

virtual int* vtkImageChangeInformation::GetExtentTranslation ( ) [virtual]

Apply a translation to the extent.

virtual void vtkImageChangeInformation::GetExtentTranslation | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Apply a translation to the extent.

virtual void vtkImageChangeInformation::GetExtentTranslation ( int [3] ) [virtual]

Apply a translation to the extent.

virtual void vtkImageChangeInformation::SetSpacingScale | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Apply a scale factor to the spacing.

virtual void vtkImageChangeInformation::SetSpacingScale ( float [3] ) [virtual]

Apply a scale factor to the spacing.

virtual float* vtkImageChangeInformation::GetSpacingScale ( ) [virtual]

Apply a scale factor to the spacing.

virtual void vtkImageChangeInformation::GetSpacingScale | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Apply a scale factor to the spacing.

virtual void vtkImageChangeInformation::GetSpacingScale ( float [3] ) [virtual]

Apply a scale factor to the spacing.

virtual void vtkImageChangeInformation::SetOriginTranslation | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Apply a translation to the origin.

virtual void vtkImageChangeInformation::SetOriginTranslation ( float [3] ) [virtual]

Apply a translation to the origin.

virtual float* vtkImageChangeInformation::GetOriginTranslation ( ) [virtual]

Apply a translation to the origin.

virtual void vtkImageChangeInformation::GetOriginTranslation | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Apply a translation to the origin.

virtual void vtkImageChangeInformation::GetOriginTranslation ( float [3] ) [virtual]

Apply a translation to the origin.

virtual void vtkImageChangeInformation::SetOriginScale | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Apply a scale to the origin. The scale is applied before the translation.

virtual void vtkImageChangeInformation::SetOriginScale ( float [3] ) [virtual]

Apply a scale to the origin. The scale is applied before the translation.

virtual float* vtkImageChangeInformation::GetOriginScale ( ) [virtual]

Apply a scale to the origin. The scale is applied before the translation.

virtual void vtkImageChangeInformation::GetOriginScale | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Apply a scale to the origin. The scale is applied before the translation.

virtual void vtkImageChangeInformation::GetOriginScale ( float [3] ) [virtual]

Apply a scale to the origin. The scale is applied before the translation.

void vtkImageChangeInformation::ComputeInputUpdateExtent | ( | int | extent[6],
 |  | int | wholeExtent[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageChangeInformation::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageChangeInformation::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 135 of file vtkImageChangeInformation.h.

void vtkImageChangeInformation::ExecuteData ( vtkDataObject * data ) [protected]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageData* vtkImageChangeInformation::InformationInput [protected]

Definition at line 119 of file vtkImageChangeInformation.h.

int vtkImageChangeInformation::CenterImage [protected]

Definition at line 120 of file vtkImageChangeInformation.h.

int vtkImageChangeInformation::OutputExtentStart[3] [protected]

Definition at line 122 of file vtkImageChangeInformation.h.

int vtkImageChangeInformation::ExtentTranslation[3] [protected]

Definition at line 123 of file vtkImageChangeInformation.h.

int vtkImageChangeInformation::FinalExtentTranslation[3] [protected]

Definition at line 124 of file vtkImageChangeInformation.h.

float vtkImageChangeInformation::OutputSpacing[3] [protected]

Definition at line 126 of file vtkImageChangeInformation.h.

float vtkImageChangeInformation::SpacingScale[3] [protected]

Definition at line 127 of file vtkImageChangeInformation.h.

float vtkImageChangeInformation::OutputOrigin[3] [protected]

Definition at line 129 of file vtkImageChangeInformation.h.

float vtkImageChangeInformation::OriginScale[3] [protected]

Definition at line 130 of file vtkImageChangeInformation.h.

float vtkImageChangeInformation::OriginTranslation[3] [protected]

Definition at line 131 of file vtkImageChangeInformation.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageChangeInformation.h
Generated on Mon Mar 25 01:18:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCheckerboard Class Reference

show two images at once using a checkboard pattern. More...

#include <vtkImageCheckerboard.h>

Inheritance diagram for vtkImageCheckerboard:

[legend]
Collaboration diagram for vtkImageCheckerboard:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCheckerboard, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNumberOfDivisions (int, int, int)
virtual void | SetNumberOfDivisions (int[3])
virtual int * | GetNumberOfDivisions ()
virtual void | GetNumberOfDivisions (int data[3])

Static Public Methods

vtkImageCheckerboard * | New ()

Protected Methods

vtkImageCheckerboard ()
~vtkImageCheckerboard ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | NumberOfDivisions [3]

Detailed Description

show two images at once using a checkboard pattern.

Date:
2002/01/22 15:31:59
Revision:
1.6

vtkImageCheckerboard displays two images as one using a checkerboard pattern. This filter can be used to compare two images. The checkerboard pattern is controlled by the NumberOfDivisions ivar. This controls the number of checkerboard divisions in the whole extent of the image.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (98%)
Tests:
vtkImageCheckerboard (Tests)

Definition at line 43 of file vtkImageCheckerboard.h.

Constructor & Destructor Documentation

vtkImageCheckerboard::vtkImageCheckerboard ( ) [protected]

vtkImageCheckerboard::~vtkImageCheckerboard ( ) [inline, protected]

Definition at line 58 of file vtkImageCheckerboard.h.

Member Function Documentation

vtkImageCheckerboard* vtkImageCheckerboard::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageCheckerboard::vtkTypeRevisionMacro | ( | vtkImageCheckerboard | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageCheckerboard::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageCheckerboard::SetNumberOfDivisions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the number of divisions along each axis.

virtual void vtkImageCheckerboard::SetNumberOfDivisions ( int [3] ) [virtual]

Set/Get the number of divisions along each axis.

virtual int* vtkImageCheckerboard::GetNumberOfDivisions ( ) [virtual]

Set/Get the number of divisions along each axis.

virtual void vtkImageCheckerboard::GetNumberOfDivisions ( int data[3] ) [virtual]

Set/Get the number of divisions along each axis.

void vtkImageCheckerboard::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

int vtkImageCheckerboard::NumberOfDivisions[3] [protected]

Definition at line 62 of file vtkImageCheckerboard.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCheckerboard.h
Generated on Mon Mar 25 01:18:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCityBlockDistance Class Reference

1,2 or 3D distance map. More...

#include <vtkImageCityBlockDistance.h>

Inheritance diagram for vtkImageCityBlockDistance:

[legend]
Collaboration diagram for vtkImageCityBlockDistance:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCityBlockDistance, vtkImageDecomposeFilter)

Static Public Methods

vtkImageCityBlockDistance * | New ()

Protected Methods

vtkImageCityBlockDistance ()
~vtkImageCityBlockDistance ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | IterativeExecuteData (vtkImageData *inData, vtkImageData *outData)
void | AllocateOutputScalars (vtkImageData *outData)

Detailed Description

1,2 or 3D distance map.

Date:
2002/01/22 15:32:00
Revision:
1.27

vtkImageCityBlockDistance creates a distance map using the city block (Manhatten) distance measure. The input is a mask. Zero values are considered boundaries. The output pixel is the minimum of the input pixel and the distance to a boundary (or neighbor value + 1 unit). distance values are calculated in pixels. The filter works by taking 6 passes (for 3d distance map): 2 along each axis (forward and backward). Each pass keeps a running minimum distance. For some reason, I preserve the sign if the distance. If the input mask is initially negative, the output distances will be negative. Distances maps can have inside (negative regions) and outsides (positive regions).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Martin, Ken (8%)
Tests:
vtkImageCityBlockDistance (Tests)

Definition at line 51 of file vtkImageCityBlockDistance.h.

Constructor & Destructor Documentation

vtkImageCityBlockDistance::vtkImageCityBlockDistance ( ) [protected]

vtkImageCityBlockDistance::~vtkImageCityBlockDistance ( ) [inline, protected]

Definition at line 59 of file vtkImageCityBlockDistance.h.

Member Function Documentation

vtkImageCityBlockDistance* vtkImageCityBlockDistance::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageCityBlockDistance::vtkTypeRevisionMacro | ( | vtkImageCityBlockDistance | ,
 |  | vtkImageDecomposeFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

void vtkImageCityBlockDistance::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageCityBlockDistance::IterativeExecuteData | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageCityBlockDistance::AllocateOutputScalars ( vtkImageData * outData ) [protected, virtual]

Reimplemented from vtkImageIterateFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCityBlockDistance.h
Generated on Mon Mar 25 01:18:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageClip Class Reference

Reduces the image extent of the input. More...

#include <vtkImageClip.h>

Inheritance diagram for vtkImageClip:

[legend]
Collaboration diagram for vtkImageClip:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageClip, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ResetOutputWholeExtent ()
void | SetOutputWholeExtent (int piece, int numPieces)
void | SetOutputWholeExtent (int extent[6])
void | SetOutputWholeExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
void | GetOutputWholeExtent (int extent[6])
int * | GetOutputWholeExtent ()
virtual void | SetClipData (int)
virtual int | GetClipData ()
virtual void | ClipDataOn ()
virtual void | ClipDataOff ()

Static Public Methods

vtkImageClip * | New ()

Protected Methods

vtkImageClip ()
~vtkImageClip ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | CopyData (vtkImageData *inData, vtkImageData *outData, int *ext)
int | SplitExtentTmp (int piece, int numPieces, int *ext)
virtual void | ExecuteData (vtkDataObject *out)

Protected Attributes

vtkTimeStamp CTime
int | Initialized
int | OutputWholeExtent [6]
int | ClipData

Detailed Description

Reduces the image extent of the input.

Date:
2002/01/22 15:32:02
Revision:
1.35

vtkImageClip will make an image smaller. The output must have an image extent which is the subset of the input. The filter has two modes of operation: 1: By default, the data is not copied in this filter. Only the whole extent is modified. 2: If ClipDataOn is set, then you will get no more that the clipped extent.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (76%)
  • Martin, Ken (17%)
Examples:
vtkImageClip (Examples)
Tests:
vtkImageClip (Tests)

Definition at line 52 of file vtkImageClip.h.

Constructor & Destructor Documentation

vtkImageClip::vtkImageClip ( ) [protected]

vtkImageClip::~vtkImageClip ( ) [inline, protected]

Definition at line 84 of file vtkImageClip.h.

Member Function Documentation

vtkImageClip* vtkImageClip::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageClip::vtkTypeRevisionMacro | ( | vtkImageClip | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageClip::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageClip::SetOutputWholeExtent ( int extent[6] )

The whole extent of the output has to be set explicitly.

void vtkImageClip::SetOutputWholeExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

The whole extent of the output has to be set explicitly.

void vtkImageClip::GetOutputWholeExtent ( int extent[6] )

The whole extent of the output has to be set explicitly.

int* vtkImageClip::GetOutputWholeExtent ( ) [inline]

The whole extent of the output has to be set explicitly.

Definition at line 65 of file vtkImageClip.h.

void vtkImageClip::ResetOutputWholeExtent ( )

virtual void vtkImageClip::SetClipData ( int ) [virtual]

By default, ClipData is off, and only the WholeExtent is modified. the data's extent may actually be larger. When this flag is on, the data extent will be no more than the OutputWholeExtent.

virtual int vtkImageClip::GetClipData ( ) [virtual]

By default, ClipData is off, and only the WholeExtent is modified. the data's extent may actually be larger. When this flag is on, the data extent will be no more than the OutputWholeExtent.

virtual void vtkImageClip::ClipDataOn ( ) [virtual]

By default, ClipData is off, and only the WholeExtent is modified. the data's extent may actually be larger. When this flag is on, the data extent will be no more than the OutputWholeExtent.

virtual void vtkImageClip::ClipDataOff ( ) [virtual]

By default, ClipData is off, and only the WholeExtent is modified. the data's extent may actually be larger. When this flag is on, the data extent will be no more than the OutputWholeExtent.

void vtkImageClip::SetOutputWholeExtent | ( | int | piece,
 |  | int | numPieces
 | ) |

Hack set output by piece

void vtkImageClip::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageClip::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 94 of file vtkImageClip.h.

void vtkImageClip::CopyData | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int * | ext
 | ) | [protected]

int vtkImageClip::SplitExtentTmp | ( | int | piece,
 |  | int | numPieces,
 |  | int * | ext
 | ) | [protected]

virtual void vtkImageClip::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkTimeStamp vtkImageClip::CTime [protected]

Definition at line 87 of file vtkImageClip.h.

int vtkImageClip::Initialized [protected]

Definition at line 88 of file vtkImageClip.h.

int vtkImageClip::OutputWholeExtent[6] [protected]

Definition at line 89 of file vtkImageClip.h.

int vtkImageClip::ClipData [protected]

Definition at line 91 of file vtkImageClip.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageClip.h
Generated on Mon Mar 25 01:18:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConnector Class Reference

Create a binary image of a sphere. More...

#include <vtkImageConnector.h>

Inheritance diagram for vtkImageConnector:

[legend]
Collaboration diagram for vtkImageConnector:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageConnector, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageConnectorSeed * | NewSeed (int index[3], void *ptr)
void | AddSeed (vtkImageConnectorSeed *seed)
void | AddSeedToEnd (vtkImageConnectorSeed *seed)
void | RemoveAllSeeds ()
void | MarkData (vtkImageData *data, int dimensionality, int ext[6])
virtual void | SetConnectedValue (unsigned char)
virtual unsigned char | GetConnectedValue ()
virtual void | SetUnconnectedValue (unsigned char)
virtual unsigned char | GetUnconnectedValue ()

Static Public Methods

vtkImageConnector * | New ()

Protected Methods

vtkImageConnector ()
~vtkImageConnector ()
vtkImageConnectorSeed * PopSeed ()

Protected Attributes

unsigned char | ConnectedValue
unsigned char | UnconnectedValue
vtkImageConnectorSeed * Seeds
vtkImageConnectorSeed * LastSeed

Detailed Description

Create a binary image of a sphere.

Date:
2002/01/22 15:32:03
Revision:
1.21

vtkImageConnector is a helper class for connectivity filters. It is not meant to be used directly. It implements a stack and breadth first search necessary for some connectivity filters. Filtered axes sets the dimensionality of the neighbor comparison, and cannot be more than three dimensions. As implemented, only voxels which share faces are considered neighbors.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (81%)
  • Martin, Ken (8%)
  • Avila, Lisa (6%)

Definition at line 63 of file vtkImageConnector.h.

Constructor & Destructor Documentation

vtkImageConnector::vtkImageConnector ( ) [protected]

vtkImageConnector::~vtkImageConnector ( ) [protected]

Member Function Documentation

vtkImageConnector* vtkImageConnector::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkImageConnector::vtkTypeRevisionMacro | ( | vtkImageConnector | ,
 |  | vtkObject |
 | ) |

void vtkImageConnector::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkImageConnectorSeed* vtkImageConnector::NewSeed | ( | int | index[3],
 |  | void * | ptr
 | ) |

void vtkImageConnector::AddSeed ( vtkImageConnectorSeed * seed )

void vtkImageConnector::AddSeedToEnd ( vtkImageConnectorSeed * seed )

void vtkImageConnector::RemoveAllSeeds ( )

virtual void vtkImageConnector::SetConnectedValue ( unsigned char ) [virtual]

Values used by the MarkRegion method

virtual unsigned char vtkImageConnector::GetConnectedValue ( ) [virtual]

Values used by the MarkRegion method

virtual void vtkImageConnector::SetUnconnectedValue ( unsigned char ) [virtual]

Values used by the MarkRegion method

virtual unsigned char vtkImageConnector::GetUnconnectedValue ( ) [virtual]

Values used by the MarkRegion method

void vtkImageConnector::MarkData | ( | vtkImageData * | data,
 |  | int | dimensionality,
 |  | int | ext[6]
 | ) |

Input a data of 0's and "UnconnectedValue"s. Seeds of this object are used to find connected pixels. All pixels connected to seeds are set to ConnectedValue. The data has to be unsigned char.

vtkImageConnectorSeed* vtkImageConnector::PopSeed ( ) [protected]

Member Data Documentation

unsigned char vtkImageConnector::ConnectedValue [protected]

Definition at line 97 of file vtkImageConnector.h.

unsigned char vtkImageConnector::UnconnectedValue [protected]

Definition at line 98 of file vtkImageConnector.h.

vtkImageConnectorSeed* vtkImageConnector::Seeds [protected]

Definition at line 102 of file vtkImageConnector.h.

vtkImageConnectorSeed* vtkImageConnector::LastSeed [protected]

Definition at line 103 of file vtkImageConnector.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageConnector.h
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConnectorSeed Class Reference

#include <vtkImageConnector.h>

Collaboration diagram for vtkImageConnectorSeed:

[legend]
List of all members.

Static Public Methods

vtkImageConnectorSeed * | New ()

Public Attributes

void * | Pointer
int | Index [3]
vtkImageConnectorSeed * | Next

Member Function Documentation

vtkImageConnectorSeed* vtkImageConnectorSeed::New ( ) [inline, static]

Definition at line 54 of file vtkImageConnector.h.

Member Data Documentation

void* vtkImageConnectorSeed::Pointer

Definition at line 55 of file vtkImageConnector.h.

int vtkImageConnectorSeed::Index[3]

Definition at line 56 of file vtkImageConnector.h.

vtkImageConnectorSeed* vtkImageConnectorSeed::Next

Definition at line 57 of file vtkImageConnector.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageConnector.h
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConstantPad Class Reference

Makes image larger by padding with constant. More...

#include <vtkImageConstantPad.h>

Inheritance diagram for vtkImageConstantPad:

[legend]
Collaboration diagram for vtkImageConstantPad:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageConstantPad, vtkImagePadFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetConstant (float)
virtual float | GetConstant ()

Static Public Methods

vtkImageConstantPad * | New ()

Protected Methods

vtkImageConstantPad ()
~vtkImageConstantPad ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

float | Constant

Detailed Description

Makes image larger by padding with constant.

Date:
2002/01/22 15:32:06
Revision:
1.26

vtkImageConstantPad changes the image extent of its input. Any pixels outside of the original image extent are filled with a constant value.

See also:
vtkImageWrapPad vtkImageMirrorPad
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (51%)
  • Martin, Ken (36%)
Tests:
vtkImageConstantPad (Tests)

Definition at line 46 of file vtkImageConstantPad.h.

Constructor & Destructor Documentation

vtkImageConstantPad::vtkImageConstantPad ( ) [protected]

vtkImageConstantPad::~vtkImageConstantPad ( ) [inline, protected]

Definition at line 63 of file vtkImageConstantPad.h.

Member Function Documentation

vtkImageConstantPad* vtkImageConstantPad::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImagePadFilter.

vtkImageConstantPad::vtkTypeRevisionMacro | ( | vtkImageConstantPad | ,
 |  | vtkImagePadFilter |
 | ) |

Reimplemented from vtkImagePadFilter.

void vtkImageConstantPad::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImagePadFilter.

virtual void vtkImageConstantPad::SetConstant ( float ) [virtual]

Set/Get the pad value.

virtual float vtkImageConstantPad::GetConstant ( ) [virtual]

Set/Get the pad value.

void vtkImageConstantPad::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageConstantPad::Constant [protected]

Definition at line 65 of file vtkImageConstantPad.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageConstantPad.h
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageContinuousDilate3D Class Reference

Dilate implemented as a maximum. More...

#include <vtkImageContinuousDilate3D.h>

Inheritance diagram for vtkImageContinuousDilate3D:

[legend]
Collaboration diagram for vtkImageContinuousDilate3D:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageContinuousDilate3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageContinuousDilate3D * | New ()

Public Methods

void | SetKernelSize (int size0, int size1, int size2)

Protected Methods

vtkImageContinuousDilate3D ()
~vtkImageContinuousDilate3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

vtkImageEllipsoidSource * Ellipse

Detailed Description

Dilate implemented as a maximum.

Date:
2002/01/22 15:32:08
Revision:
1.20

vtkImageContinuousDilate3D replaces a pixel with the maximum over an ellipsoidal neighborhood. If KernelSize of an axis is 1, no processing is done on that axis.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (81%)
  • Martin, Ken (9%)
Tests:
vtkImageContinuousDilate3D (Tests)

Definition at line 45 of file vtkImageContinuousDilate3D.h.

Constructor & Destructor Documentation

vtkImageContinuousDilate3D::vtkImageContinuousDilate3D ( ) [protected]

vtkImageContinuousDilate3D::~vtkImageContinuousDilate3D ( ) [protected]

Member Function Documentation

vtkImageContinuousDilate3D* vtkImageContinuousDilate3D::New ( ) [static]

Construct an instance of vtkImageContinuousDilate3D filter. By default zero values are dilated.

Reimplemented from vtkImageSpatialFilter.

vtkImageContinuousDilate3D::vtkTypeRevisionMacro | ( | vtkImageContinuousDilate3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageContinuousDilate3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageContinuousDilate3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood and computes the elliptical foot print.

void vtkImageContinuousDilate3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageEllipsoidSource* vtkImageContinuousDilate3D::Ellipse [protected]

Definition at line 67 of file vtkImageContinuousDilate3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageContinuousDilate3D.h
Generated on Mon Mar 25 01:18:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageContinuousErode3D Class Reference

Erosion implemented as a minimum. More...

#include <vtkImageContinuousErode3D.h>

Inheritance diagram for vtkImageContinuousErode3D:

[legend]
Collaboration diagram for vtkImageContinuousErode3D:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageContinuousErode3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageContinuousErode3D * | New ()

Public Methods

void | SetKernelSize (int size0, int size1, int size2)

Protected Methods

vtkImageContinuousErode3D ()
~vtkImageContinuousErode3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

vtkImageEllipsoidSource * Ellipse

Detailed Description

Erosion implemented as a minimum.

Date:
2002/01/22 15:32:10
Revision:
1.20

vtkImageContinuousErode3D replaces a pixel with the minimum over an ellipsoidal neighborhood. If KernelSize of an axis is 1, no processing is done on that axis.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Martin, Ken (9%)
Tests:
vtkImageContinuousErode3D (Tests)

Definition at line 45 of file vtkImageContinuousErode3D.h.

Constructor & Destructor Documentation

vtkImageContinuousErode3D::vtkImageContinuousErode3D ( ) [protected]

vtkImageContinuousErode3D::~vtkImageContinuousErode3D ( ) [protected]

Member Function Documentation

vtkImageContinuousErode3D* vtkImageContinuousErode3D::New ( ) [static]

Construct an instance of vtkImageContinuousErode3D filter. By default zero values are eroded.

Reimplemented from vtkImageSpatialFilter.

vtkImageContinuousErode3D::vtkTypeRevisionMacro | ( | vtkImageContinuousErode3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageContinuousErode3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageContinuousErode3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood and computes the elliptical foot print.

void vtkImageContinuousErode3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageEllipsoidSource* vtkImageContinuousErode3D::Ellipse [protected]

Definition at line 66 of file vtkImageContinuousErode3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageContinuousErode3D.h
Generated on Mon Mar 25 01:18:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageConvolve Class Reference

Convolution of an image with a kernel. More...

#include <vtkImageConvolve.h>

Inheritance diagram for vtkImageConvolve:

[legend]
Collaboration diagram for vtkImageConvolve:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageConvolve, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageConvolve * | New ()

Public Methods

void | SetKernel7x7 (float kernel[49])
float * | GetKernel7x7 ()
void | GetKernel7x7 (float kernel[49])
void | SetKernel3x3x3 (const float kernel[27])
void | SetKernel5x5x5 (float kernel[125])
void | SetKernel7x7x7 (float kernel[343])
float * | GetKernel5x5x5 ()
void | GetKernel5x5x5 (float kernel[125])
float * | GetKernel7x7x7 ()
void | GetKernel7x7x7 (float kernel[343])
virtual int * | GetKernelSize ()
virtual void | GetKernelSize (int &, int &, int &)
virtual void | GetKernelSize (int[3])
void | SetKernel3x3 (const float kernel[9])
void | SetKernel5x5 (const float kernel[25])
float * | GetKernel3x3 ()
void | GetKernel3x3 (float kernel[9])
float * | GetKernel5x5 ()
void | GetKernel5x5 (float kernel[25])
float * | GetKernel3x3x3 ()
void | GetKernel3x3x3 (float kernel[27])

Protected Methods

vtkImageConvolve ()
~vtkImageConvolve ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)
void | GetKernel (float *kernel)
float * | GetKernel ()
void | SetKernel (const float *kernel, int sizeX, int sizeY, int sizeZ)

Protected Attributes

int | KernelSize [3]
float | Kernel [343]

Detailed Description

Convolution of an image with a kernel.

Date:
2002/01/22 15:32:11
Revision:
1.11

vtkImageConvolve convolves the image with a 3D NxNxN kernel or a 2D NxN kernal. The output image is cropped to the same size as the input.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Gobbi, David (57%)
  • Schroeder, Will (41%)
Tests:
vtkImageConvolve (Tests)

Definition at line 42 of file vtkImageConvolve.h.

Constructor & Destructor Documentation

vtkImageConvolve::vtkImageConvolve ( ) [protected]

vtkImageConvolve::~vtkImageConvolve ( ) [protected]

Member Function Documentation

vtkImageConvolve* vtkImageConvolve::New ( ) [static]

Construct an instance of vtkImageConvolve filter.

Reimplemented from vtkImageToImageFilter.

vtkImageConvolve::vtkTypeRevisionMacro | ( | vtkImageConvolve | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageConvolve::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual int* vtkImageConvolve::GetKernelSize ( ) [virtual]

Get the kernel size

virtual void vtkImageConvolve::GetKernelSize | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get the kernel size

virtual void vtkImageConvolve::GetKernelSize ( int [3] ) [virtual]

Get the kernel size

void vtkImageConvolve::SetKernel3x3 ( const float kernel[9] )

Set the kernel to be a given 3x3 or 5x5 or 7x7 kernel.

void vtkImageConvolve::SetKernel5x5 ( const float kernel[25] )

Set the kernel to be a given 3x3 or 5x5 or 7x7 kernel.

void vtkImageConvolve::SetKernel7x7 ( float kernel[49] )

float* vtkImageConvolve::GetKernel3x3 ( )

Return an array that contains the kernel.

void vtkImageConvolve::GetKernel3x3 ( float kernel[9] )

Return an array that contains the kernel.

float* vtkImageConvolve::GetKernel5x5 ( )

Return an array that contains the kernel.

void vtkImageConvolve::GetKernel5x5 ( float kernel[25] )

Return an array that contains the kernel.

float* vtkImageConvolve::GetKernel7x7 ( )

void vtkImageConvolve::GetKernel7x7 ( float kernel[49] )

void vtkImageConvolve::SetKernel3x3x3 ( const float kernel[27] )

Set the kernel to be a 3x3x3 or 5x5x5 or 7x7x7 kernel.

void vtkImageConvolve::SetKernel5x5x5 ( float kernel[125] )

void vtkImageConvolve::SetKernel7x7x7 ( float kernel[343] )

float* vtkImageConvolve::GetKernel3x3x3 ( )

Return an array that contains the kernel

void vtkImageConvolve::GetKernel3x3x3 ( float kernel[27] )

Return an array that contains the kernel

float* vtkImageConvolve::GetKernel5x5x5 ( )

void vtkImageConvolve::GetKernel5x5x5 ( float kernel[125] )

float* vtkImageConvolve::GetKernel7x7x7 ( )

void vtkImageConvolve::GetKernel7x7x7 ( float kernel[343] )

void vtkImageConvolve::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

void vtkImageConvolve::GetKernel ( float * kernel ) [protected]

float* vtkImageConvolve::GetKernel ( ) [protected]

void vtkImageConvolve::SetKernel | ( | const float * | kernel,
 |  | int | sizeX,
 |  | int | sizeY,
 |  | int | sizeZ
 | ) | [protected]

Member Data Documentation

int vtkImageConvolve::KernelSize[3] [protected]

Definition at line 110 of file vtkImageConvolve.h.

float vtkImageConvolve::Kernel[343] [protected]

Definition at line 111 of file vtkImageConvolve.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageConvolve.h
Generated on Mon Mar 25 01:18:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCorrelation Class Reference

Correlation imageof the two inputs. More...

#include <vtkImageCorrelation.h>

Inheritance diagram for vtkImageCorrelation:

[legend]
Collaboration diagram for vtkImageCorrelation:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCorrelation, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageCorrelation * | New ()

Protected Methods

vtkImageCorrelation ()
~vtkImageCorrelation ()
void | ExecuteInformation (vtkImageData **inDatas, vtkImageData *outData)
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | Dimensionality

Detailed Description

Correlation imageof the two inputs.

Date:
2002/01/22 15:32:13
Revision:
1.24

vtkImageCorrelation finds the correlation between two data sets. SetDimensionality determines whether the Correlation will be 3D, 2D or 1D. The default is a 2D Correlation. The Output type will be float. The output size will match the size of the first input. The second input is considered the correlation kernel.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Martin, Ken (46%)
  • Law, Charles (40%)
Tests:
vtkImageCorrelation (Tests)

Definition at line 47 of file vtkImageCorrelation.h.

Constructor & Destructor Documentation

vtkImageCorrelation::vtkImageCorrelation ( ) [protected]

vtkImageCorrelation::~vtkImageCorrelation ( ) [inline, protected]

Definition at line 62 of file vtkImageCorrelation.h.

Member Function Documentation

vtkImageCorrelation* vtkImageCorrelation::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageCorrelation::vtkTypeRevisionMacro | ( | vtkImageCorrelation | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageCorrelation::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageCorrelation::SetDimensionality ( int ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

virtual int vtkImageCorrelation::GetDimensionality ( ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

void vtkImageCorrelation::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageCorrelation::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageCorrelation::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 68 of file vtkImageCorrelation.h.

void vtkImageCorrelation::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

int vtkImageCorrelation::Dimensionality [protected]

Definition at line 64 of file vtkImageCorrelation.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCorrelation.h
Generated on Mon Mar 25 01:18:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageCursor3D Class Reference

Paints a cursor on top of an image or volume. More...

#include <vtkImageCursor3D.h>

Inheritance diagram for vtkImageCursor3D:

[legend]
Collaboration diagram for vtkImageCursor3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageCursor3D, vtkImageInPlaceFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCursorPosition (float, float, float)
virtual void | SetCursorPosition (float[3])
virtual float * | GetCursorPosition ()
virtual void | GetCursorPosition (float &, float &, float &)
virtual void | GetCursorPosition (float[3])
virtual void | SetCursorValue (float)
virtual float | GetCursorValue ()
virtual void | SetCursorRadius (int)
virtual int | GetCursorRadius ()

Static Public Methods

vtkImageCursor3D * | New ()

Protected Methods

vtkImageCursor3D ()
~vtkImageCursor3D ()
void | ExecuteData (vtkDataObject *outData)

Protected Attributes

float | CursorPosition [3]
float | CursorValue
int | CursorRadius

Detailed Description

Paints a cursor on top of an image or volume.

Date:
2002/01/22 15:32:14
Revision:
1.20

vtkImageCursor3D will draw a cursor on a 2d image or 3d volume.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (62%)
  • Martin, Ken (31%)
  • Schroeder, Will (6%)
Tests:
vtkImageCursor3D (Tests)

Definition at line 41 of file vtkImageCursor3D.h.

Constructor & Destructor Documentation

vtkImageCursor3D::vtkImageCursor3D ( ) [protected]

vtkImageCursor3D::~vtkImageCursor3D ( ) [inline, protected]

Definition at line 71 of file vtkImageCursor3D.h.

Member Function Documentation

vtkImageCursor3D* vtkImageCursor3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageInPlaceFilter.

vtkImageCursor3D::vtkTypeRevisionMacro | ( | vtkImageCursor3D | ,
 |  | vtkImageInPlaceFilter |
 | ) |

Reimplemented from vtkImageInPlaceFilter.

void vtkImageCursor3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageCursor3D::SetCursorPosition | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Sets/Gets the center point of the 3d cursor.

virtual void vtkImageCursor3D::SetCursorPosition ( float [3] ) [virtual]

Sets/Gets the center point of the 3d cursor.

virtual float* vtkImageCursor3D::GetCursorPosition ( ) [virtual]

Sets/Gets the center point of the 3d cursor.

virtual void vtkImageCursor3D::GetCursorPosition | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Sets/Gets the center point of the 3d cursor.

virtual void vtkImageCursor3D::GetCursorPosition ( float [3] ) [virtual]

Sets/Gets the center point of the 3d cursor.

virtual void vtkImageCursor3D::SetCursorValue ( float ) [virtual]

Sets/Gets what pixel value to draw the cursor in.

virtual float vtkImageCursor3D::GetCursorValue ( ) [virtual]

Sets/Gets what pixel value to draw the cursor in.

virtual void vtkImageCursor3D::SetCursorRadius ( int ) [virtual]

Sets/Gets the radius of the cursor. The radius determines how far the axis lines project out from the cursors center.

virtual int vtkImageCursor3D::GetCursorRadius ( ) [virtual]

Sets/Gets the radius of the cursor. The radius determines how far the axis lines project out from the cursors center.

void vtkImageCursor3D::ExecuteData ( vtkDataObject * outData ) [protected, virtual]

Reimplemented from vtkImageInPlaceFilter.

Member Data Documentation

float vtkImageCursor3D::CursorPosition[3] [protected]

Definition at line 73 of file vtkImageCursor3D.h.

float vtkImageCursor3D::CursorValue [protected]

Definition at line 74 of file vtkImageCursor3D.h.

int vtkImageCursor3D::CursorRadius [protected]

Definition at line 75 of file vtkImageCursor3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageCursor3D.h
Generated on Mon Mar 25 01:18:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageData Class Reference

topologically and geometrically regular array of data. More...

#include <vtkImageData.h>

Inheritance diagram for vtkImageData:

[legend]
Collaboration diagram for vtkImageData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageData, vtkDataSet)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * MakeObject ()
void | CopyStructure (vtkDataSet *ds)
int | GetDataObjectType ()
void | UpdateData ()
void | SetDimensions (int i, int j, int k)
void | SetDimensions (int dims[3])
int | ComputeStructuredCoordinates (float x[3], int ijk[3], float pcoords[3])
void | GetVoxelGradient (int i, int j, int k, vtkDataArray *s, vtkDataArray *g)
void | GetPointGradient (int i, int j, int k, vtkDataArray *s, float g[3])
int | GetDataDimension ()
virtual unsigned long | GetEstimatedMemorySize ()
int | GetScalarSize ()
void | GetContinuousIncrements (int extent[6], int &incX, int &incY, int &incZ)
float | GetScalarComponentAsFloat (int x, int y, int z, int component)
void | AllocateScalars ()
virtual void | Crop ()
unsigned long | GetActualMemorySize ()
void | CopyTypeSpecificInformation (vtkDataObject *image)
virtual void | PrepareForNewData ()
void | GetArrayIncrements (vtkDataArray *array, int increments[3])
vtkIdType GetNumberOfCells ()
vtkIdType GetNumberOfPoints ()
float * | GetPoint (vtkIdType ptId)
void | GetPoint (vtkIdType id, float x[3])
vtkCell * | GetCell (vtkIdType cellId)
void | GetCell (vtkIdType cellId, vtkGenericCell *cell)
void | GetCellBounds (vtkIdType cellId, float bounds[6])
vtkIdType | FindPoint (float x, float y, float z)
vtkIdType | FindPoint (float x[3])
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
vtkCell * | FindAndGetCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
int | GetCellType (vtkIdType cellId)
void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)
void | ComputeBounds ()
int | GetMaxCellSize ()
int * | GetDimensions ()
void | GetDimensions (int dims[3])
vtkIdType | ComputePointId (int ijk[3])
vtkIdType | ComputeCellId (int ijk[3])
void | SetAxisUpdateExtent (int axis, int min, int max)
void | GetAxisUpdateExtent (int axis, int &min, int &max)
void | SetUpdateExtent (int piece, int numPieces, int ghostLevel)
void | SetUpdateExtent (int piece, int numPieces)
void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
void | SetUpdateExtent (int ext[6])
void | SetExtent (int extent[6])
void | SetExtent (int x1, int x2, int y1, int y2, int z1, int z2)
virtual int * | GetExtent ()
virtual void | GetExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetExtent (int[6])
double | GetScalarTypeMin ()
double | GetScalarTypeMax ()
int * | GetIncrements ()
void | GetIncrements (int &incX, int &incY, int &incZ)
void | GetIncrements (int inc[3])
void * | GetScalarPointerForExtent (int extent[6])
void * | GetScalarPointer (int coordinates[3])
void * | GetScalarPointer (int x, int y, int z)
void * | GetScalarPointer ()
void | CopyAndCastFrom (vtkImageData *inData, int extent[6])
void | CopyAndCastFrom (vtkImageData *inData, int x0, int x1, int y0, int y1, int z0, int z1)
virtual void | SetSpacing (float, float, float)
virtual void | SetSpacing (float[3])
virtual float * | GetSpacing ()
virtual void | GetSpacing (float &, float &, float &)
virtual void | GetSpacing (float[3])
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float &, float &, float &)
virtual void | GetOrigin (float[3])
void | SetScalarTypeToFloat ()
void | SetScalarTypeToDouble ()
void | SetScalarTypeToInt ()
void | SetScalarTypeToUnsignedInt ()
void | SetScalarTypeToLong ()
void | SetScalarTypeToUnsignedLong ()
void | SetScalarTypeToShort ()
void | SetScalarTypeToUnsignedShort ()
void | SetScalarTypeToUnsignedChar ()
void | SetScalarTypeToChar ()
virtual void | SetScalarType (int)
int | GetScalarType ()
const char * | GetScalarTypeAsString ()
void | SetNumberOfScalarComponents (int n)
virtual int | GetNumberOfScalarComponents ()
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)
void * | GetArrayPointerForExtent (vtkDataArray *array, int extent[6])
void * | GetArrayPointer (vtkDataArray *array, int coordinates[3])

Static Public Methods

vtkImageData * | New ()

Protected Methods

vtkImageData ()
~vtkImageData ()
int | GetExtentType ()
void | ComputeIncrements ()

Protected Attributes

vtkVertex * Vertex
vtkLine * Line
vtkPixel * Pixel
vtkVoxel * Voxel
int | Dimensions [3]
int | DataDescription
int | Increments [3]
float | Origin [3]
float | Spacing [3]
int | ScalarType
int | NumberOfScalarComponents

Detailed Description

topologically and geometrically regular array of data.

Date:
2002/01/30 19:13:41
Revision:
1.98

vtkImageData is a data object that is a concrete implementation of vtkDataSet. vtkImageData represents a geometric structure that is a topological and geometrical regular array of points. Examples include volumes (voxel data) and pixmaps.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (72%)
  • Martin, Ken (15%)
Examples:
vtkImageData (Examples)
Tests:
vtkImageData (Tests)

Definition at line 52 of file vtkImageData.h.

Constructor & Destructor Documentation

vtkImageData::vtkImageData ( ) [protected]

vtkImageData::~vtkImageData ( ) [protected]

Member Function Documentation

vtkImageData* vtkImageData::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

Reimplemented in vtkStructuredPoints, and vtkImageCanvasSource2D.

Referenced by MakeObject().

vtkImageData::vtkTypeRevisionMacro | ( | vtkImageData | ,
 |  | vtkDataSet |
 | ) |

Reimplemented from vtkDataSet.

Reimplemented in vtkStructuredPoints, and vtkImageCanvasSource2D.

void vtkImageData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSet.

Reimplemented in vtkImageCanvasSource2D.

vtkDataObject* vtkImageData::MakeObject ( ) [inline, virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataObject.

Reimplemented in vtkStructuredPoints.

Definition at line 61 of file vtkImageData.h.

void vtkImageData::CopyStructure ( vtkDataSet * ds ) [virtual]

Copy the geometric and topological structure of an input image data object.

Reimplemented from vtkDataSet.

int vtkImageData::GetDataObjectType ( ) [inline, virtual]

Return what type of dataset this is.

Reimplemented from vtkDataSet.

Reimplemented in vtkStructuredPoints.

Definition at line 68 of file vtkImageData.h.

void vtkImageData::UpdateData ( ) [virtual]

This update method will supply the ghost level arrays if they are requested.

Reimplemented from vtkDataObject.

vtkIdType vtkImageData::GetNumberOfCells ( ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkImageData::GetNumberOfPoints ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 379 of file vtkImageData.h.

float* vtkImageData::GetPoint ( vtkIdType ptId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Referenced by GetPoint().

void vtkImageData::GetPoint | ( | vtkIdType | id,
 |  | float | x[3]
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 371 of file vtkImageData.h.

vtkCell* vtkImageData::GetCell ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkImageData::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkImageData::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkImageData::FindPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 83 of file vtkImageData.h.

vtkIdType vtkImageData::FindPoint ( float x[3] ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkImageData::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkImageData::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkGenericCell * | gencell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkCell* vtkImageData::FindAndGetCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkImageData::GetCellType ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkImageData::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 94 of file vtkImageData.h.

void vtkImageData::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 97 of file vtkImageData.h.

void vtkImageData::ComputeBounds ( ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkImageData::GetMaxCellSize ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 100 of file vtkImageData.h.

void vtkImageData::SetDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set dimensions of structured points dataset.

void vtkImageData::SetDimensions ( int dims[3] )

Set dimensions of structured points dataset.

int* vtkImageData::GetDimensions ( )

Get dimensions of this structured points dataset. Dimensions are computed from Extents during this call.

Referenced by GetNumberOfPoints().

void vtkImageData::GetDimensions ( int dims[3] )

Get dimensions of this structured points dataset. Dimensions are computed from Extents during this call.

int vtkImageData::ComputeStructuredCoordinates | ( | float | x[3],
 |  | int | ijk[3],
 |  | float | pcoords[3]
 | ) |

Convenience function computes the structured coordinates for a point x[3]. The voxel is specified by the array ijk[3], and the parametric coordinates in the cell are specified with pcoords[3]. The function returns a 0 if the point x is outside of the volume, and a 1 if inside the volume.

void vtkImageData::GetVoxelGradient | ( | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkDataArray * | s,
 |  | vtkDataArray * | g
 | ) |

Given structured coordinates (i,j,k) for a voxel cell, compute the eight gradient values for the voxel corners. The order in which the gradient vectors are arranged corresponds to the ordering of the voxel points. Gradient vector is computed by central differences (except on edges of volume where forward difference is used). The scalars s are the scalars from which the gradient is to be computed. This method will treat only 3D structured point datasets (i.e., volumes).

void vtkImageData::GetPointGradient | ( | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkDataArray * | s,
 |  | float | g[3]
 | ) |

Given structured coordinates (i,j,k) for a point in a structured point dataset, compute the gradient vector from the scalar data at that point. The scalars s are the scalars from which the gradient is to be computed. This method will treat structured point datasets of any dimension.

int vtkImageData::GetDataDimension ( ) [inline]

Return the dimensionality of the data.

Definition at line 385 of file vtkImageData.h.

vtkIdType vtkImageData::ComputePointId ( int ijk[3] ) [inline]

Given a location in structured coordinates (i-j-k), return the point id.

Definition at line 146 of file vtkImageData.h.

vtkIdType vtkImageData::ComputeCellId ( int ijk[3] ) [inline]

Given a location in structured coordinates (i-j-k), return the cell id.

Definition at line 153 of file vtkImageData.h.

void vtkImageData::SetAxisUpdateExtent | ( | int | axis,
 |  | int | min,
 |  | int | max
 | ) |

Set / Get the extent on just one axis

void vtkImageData::GetAxisUpdateExtent | ( | int | axis,
 |  | int & | min,
 |  | int & | max
 | ) |

Set / Get the extent on just one axis

void vtkImageData::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel
 | ) |

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

void vtkImageData::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

Reimplemented from vtkDataObject.

Definition at line 168 of file vtkImageData.h.

void vtkImageData::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [inline, virtual]

Call superclass method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 174 of file vtkImageData.h.

void vtkImageData::SetUpdateExtent ( int ext[6] ) [inline, virtual]

Call superclass method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 176 of file vtkImageData.h.

void vtkImageData::SetExtent ( int extent[6] )

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

void vtkImageData::SetExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) |

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

Reimplemented in vtkImageCanvasSource2D.

virtual int* vtkImageData::GetExtent ( ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkImageData::GetExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkImageData::GetExtent ( int [6] ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual unsigned long vtkImageData::GetEstimatedMemorySize ( ) [virtual]

Get the estimated size of this data object itself. Should be called after UpdateInformation() and PropagateUpdateExtent() have both been called. This estimate should be fairly accurate since this is structured data.

Reimplemented from vtkDataObject.

double vtkImageData::GetScalarTypeMin ( )

These returns the minimum and maximum values the ScalarType can hold without overflowing.

double vtkImageData::GetScalarTypeMax ( )

These returns the minimum and maximum values the ScalarType can hold without overflowing.

int vtkImageData::GetScalarSize ( )

Set the size of the scalar type in bytes.

int* vtkImageData::GetIncrements ( )

Different ways to get the increments for moving around the data. GetIncrements() calls ComputeIncrements() to ensure the increments are up to date.

void vtkImageData::GetIncrements | ( | int & | incX,
 |  | int & | incY,
 |  | int & | incZ
 | ) |

Different ways to get the increments for moving around the data. GetIncrements() calls ComputeIncrements() to ensure the increments are up to date.

void vtkImageData::GetIncrements ( int inc[3] )

Different ways to get the increments for moving around the data. GetIncrements() calls ComputeIncrements() to ensure the increments are up to date.

void vtkImageData::GetContinuousIncrements | ( | int | extent[6],
 |  | int & | incX,
 |  | int & | incY,
 |  | int & | incZ
 | ) |

Different ways to get the increments for moving around the data. incX is always returned with 0. incY is returned with the increment needed to move from the end of one X scanline of data to the start of the next line. incZ is filled in with the increment needed to move from the end of one image to the start of the next. The proper way to use these values is to for a loop over Z, Y, X, C, incrementing the pointer by 1 after each component. When the end of the component is reached, the pointer is set to the beginning of the next pixel, thus incX is properly set to 0.

void* vtkImageData::GetScalarPointerForExtent ( int extent[6] )

Access the native pointer for the scalar data

void* vtkImageData::GetScalarPointer ( int coordinates[3] )

Access the native pointer for the scalar data

void* vtkImageData::GetScalarPointer | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |

Access the native pointer for the scalar data

void* vtkImageData::GetScalarPointer ( )

Access the native pointer for the scalar data

float vtkImageData::GetScalarComponentAsFloat | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | component
 | ) |

For access to data from tcl

void vtkImageData::AllocateScalars ( )

Allocate the vtkScalars object associated with this object.

void vtkImageData::CopyAndCastFrom | ( | vtkImageData * | inData,
 |  | int | extent[6]
 | ) |

This method is passed a input and output region, and executes the filter algorithm to fill the output from the input. It just executes a switch statement to call the correct function for the regions data types.

void vtkImageData::CopyAndCastFrom | ( | vtkImageData * | inData,
 |  | int | x0,
 |  | int | x1,
 |  | int | y0,
 |  | int | y1,
 |  | int | z0,
 |  | int | z1
 | ) | [inline]

This method is passed a input and output region, and executes the filter algorithm to fill the output from the input. It just executes a switch statement to call the correct function for the regions data types.

Definition at line 245 of file vtkImageData.h.

virtual void vtkImageData::Crop ( ) [virtual]

Reallocates and copies to set the Extent to the UpdateExtent. This is used internally when the exact extent is requested, and the source generated more than the update extent.

Reimplemented from vtkDataObject.

unsigned long vtkImageData::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkDataSet.

virtual void vtkImageData::SetSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the spacing (width,height,length) of the cubical cells that compose the data set.

virtual void vtkImageData::SetSpacing ( float [3] ) [virtual]

Set the spacing (width,height,length) of the cubical cells that compose the data set.

virtual float* vtkImageData::GetSpacing ( ) [virtual]

Set the spacing (width,height,length) of the cubical cells that compose the data set.

virtual void vtkImageData::GetSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the spacing (width,height,length) of the cubical cells that compose the data set.

virtual void vtkImageData::GetSpacing ( float [3] ) [virtual]

Set the spacing (width,height,length) of the cubical cells that compose the data set.

virtual void vtkImageData::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the origin of the data. The origin plus spacing determine the position in space of the points.

virtual void vtkImageData::SetOrigin ( float [3] ) [virtual]

Set the origin of the data. The origin plus spacing determine the position in space of the points.

virtual float* vtkImageData::GetOrigin ( ) [virtual]

Set the origin of the data. The origin plus spacing determine the position in space of the points.

virtual void vtkImageData::GetOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the origin of the data. The origin plus spacing determine the position in space of the points.

virtual void vtkImageData::GetOrigin ( float [3] ) [virtual]

Set the origin of the data. The origin plus spacing determine the position in space of the points.

void vtkImageData::SetScalarTypeToFloat ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 279 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToDouble ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 280 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToInt ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 281 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToUnsignedInt ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 282 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToLong ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 284 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToUnsignedLong ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 285 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToShort ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 287 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToUnsignedShort ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 288 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToUnsignedChar ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 290 of file vtkImageData.h.

void vtkImageData::SetScalarTypeToChar ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 292 of file vtkImageData.h.

virtual void vtkImageData::SetScalarType ( int ) [virtual]

Set/Get the data scalar type (i.e VTK_FLOAT).

int vtkImageData::GetScalarType ( )

Set/Get the data scalar type (i.e VTK_FLOAT).

const char* vtkImageData::GetScalarTypeAsString ( ) [inline]

Set/Get the data scalar type (i.e VTK_FLOAT).

Definition at line 296 of file vtkImageData.h.

void vtkImageData::SetNumberOfScalarComponents ( int n )

Set/Get the number of scalar components for points.

virtual int vtkImageData::GetNumberOfScalarComponents ( ) [virtual]

Set/Get the number of scalar components for points.

void vtkImageData::CopyTypeSpecificInformation ( vtkDataObject * image ) [virtual]

By default, there is no type specific information

Reimplemented from vtkDataObject.

virtual void vtkImageData::PrepareForNewData ( ) [virtual]

make the output data ready for new data to be inserted. For most objects we just call Initialize. But for image data we leave the old data in case the memory can be reused.

Reimplemented from vtkDataObject.

void vtkImageData::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

void vtkImageData::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

void* vtkImageData::GetArrayPointerForExtent | ( | vtkDataArray * | array,
 |  | int | extent[6]
 | ) |

These are convienence methods for getting a pointer from any filed array. It is a start at expanding image filters to process any array (not just scalars).

void* vtkImageData::GetArrayPointer | ( | vtkDataArray * | array,
 |  | int | coordinates[3]
 | ) |

These are convienence methods for getting a pointer from any filed array. It is a start at expanding image filters to process any array (not just scalars).

void vtkImageData::GetArrayIncrements | ( | vtkDataArray * | array,
 |  | int | increments[3]
 | ) |

Since various arrays have different number of components, the will have different increments.

int vtkImageData::GetExtentType ( ) [inline, protected, virtual]

Reimplemented from vtkDataObject.

Definition at line 347 of file vtkImageData.h.

void vtkImageData::ComputeIncrements ( ) [protected]

Member Data Documentation

vtkVertex* vtkImageData::Vertex [protected]

Definition at line 341 of file vtkImageData.h.

vtkLine* vtkImageData::Line [protected]

Definition at line 342 of file vtkImageData.h.

vtkPixel* vtkImageData::Pixel [protected]

Definition at line 343 of file vtkImageData.h.

vtkVoxel* vtkImageData::Voxel [protected]

Definition at line 344 of file vtkImageData.h.

int vtkImageData::Dimensions[3] [protected]

Definition at line 352 of file vtkImageData.h.

int vtkImageData::DataDescription [protected]

Definition at line 353 of file vtkImageData.h.

int vtkImageData::Increments[3] [protected]

Definition at line 354 of file vtkImageData.h.

float vtkImageData::Origin[3] [protected]

Definition at line 356 of file vtkImageData.h.

float vtkImageData::Spacing[3] [protected]

Definition at line 357 of file vtkImageData.h.

int vtkImageData::ScalarType [protected]

Definition at line 358 of file vtkImageData.h.

int vtkImageData::NumberOfScalarComponents [protected]

Definition at line 359 of file vtkImageData.h.

The documentation for this class was generated from the following file:
  • Common/vtkImageData.h
Generated on Mon Mar 25 01:18:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDataGeometryFilter Class Reference

extract geometry for structured points. More...

#include <vtkImageDataGeometryFilter.h>

Inheritance diagram for vtkImageDataGeometryFilter:

[legend]
Collaboration diagram for vtkImageDataGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDataGeometryFilter, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetExtent (int extent[6])
void | SetExtent (int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
int * | GetExtent ()

Static Public Methods

vtkImageDataGeometryFilter * | New ()

Protected Methods

vtkImageDataGeometryFilter ()
~vtkImageDataGeometryFilter ()
void | Execute ()

Protected Attributes

int | Extent [6]

Detailed Description

extract geometry for structured points.

Date:
2002/01/22 15:29:24
Revision:
1.3

vtkImageDataGeometryFilter is a filter that extracts geometry from a structured points dataset. By specifying appropriate i-j-k indices (via the "Extent" instance variable), it is possible to extract a point, a line, a plane (i.e., image), or a "volume" from dataset. (Since the output is of type polydata, the volume is actually a (n x m x o) region of points.)

The extent specification is zero-offset. That is, the first k-plane in a 50x50x50 volume is given by (0,49, 0,49, 0,0).

Warning:
If you don't know the dimensions of the input dataset, you can use a large number to specify extent (the number will be clamped appropriately). For example, if the dataset dimensions are 50x50x50, and you want a the fifth k-plane, you can use the extents (0,100, 0,100, 4,4). The 100 will automatically be clamped to 49.
See also:
vtkGeometryFilter vtkStructuredGridFilter
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (100%)
Examples:
vtkImageDataGeometryFilter (Examples)
Tests:
vtkImageDataGeometryFilter (Tests)

Definition at line 58 of file vtkImageDataGeometryFilter.h.

Constructor & Destructor Documentation

vtkImageDataGeometryFilter::vtkImageDataGeometryFilter ( ) [protected]

vtkImageDataGeometryFilter::~vtkImageDataGeometryFilter ( ) [inline, protected]

Definition at line 77 of file vtkImageDataGeometryFilter.h.

Member Function Documentation

vtkImageDataGeometryFilter::vtkTypeRevisionMacro | ( | vtkImageDataGeometryFilter | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

Reimplemented in vtkStructuredPointsGeometryFilter.

void vtkImageDataGeometryFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkImageDataGeometryFilter* vtkImageDataGeometryFilter::New ( ) [static]

Construct with initial extent of all the data

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkStructuredPointsGeometryFilter.

void vtkImageDataGeometryFilter::SetExtent ( int extent[6] )

Set / get the extent (imin,imax, jmin,jmax, kmin,kmax) indices.

void vtkImageDataGeometryFilter::SetExtent | ( | int | iMin,
 |  | int | iMax,
 |  | int | jMin,
 |  | int | jMax,
 |  | int | kMin,
 |  | int | kMax
 | ) |

Set / get the extent (imin,imax, jmin,jmax, kmin,kmax) indices.

int* vtkImageDataGeometryFilter::GetExtent ( ) [inline]

Set / get the extent (imin,imax, jmin,jmax, kmin,kmax) indices.

Definition at line 72 of file vtkImageDataGeometryFilter.h.

void vtkImageDataGeometryFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkImageDataGeometryFilter::Extent[6] [protected]

Definition at line 80 of file vtkImageDataGeometryFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkImageDataGeometryFilter.h
Generated on Mon Mar 25 01:18:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDataStreamer Class Reference

Initiates streaming on image data. More...

#include <vtkImageDataStreamer.h>

Inheritance diagram for vtkImageDataStreamer:

[legend]
Collaboration diagram for vtkImageDataStreamer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDataStreamer, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | UpdateData (vtkDataObject *out)
virtual void | SetNumberOfStreamDivisions (int)
virtual int | GetNumberOfStreamDivisions ()
virtual vtkExtentTranslator * | GetExtentTranslator ()
virtual void | SetExtentTranslator (vtkExtentTranslator *)

Static Public Methods

vtkImageDataStreamer * | New ()

Protected Methods

vtkImageDataStreamer ()
~vtkImageDataStreamer ()

Protected Attributes

vtkExtentTranslator * ExtentTranslator
int | NumberOfStreamDivisions

Detailed Description

Initiates streaming on image data.

Date:
2002/01/22 15:32:15
Revision:
1.23

To satisfy a request, this filter calls update on its input many times with smaller update extents. All processing up stream streams smaller pieces.

Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Avila, Lisa (47%)
  • Law, Charles (24%)
  • Martin, Ken (22%)
Tests:
vtkImageDataStreamer (Tests)

Definition at line 47 of file vtkImageDataStreamer.h.

Constructor & Destructor Documentation

vtkImageDataStreamer::vtkImageDataStreamer ( ) [protected]

vtkImageDataStreamer::~vtkImageDataStreamer ( ) [protected]

Member Function Documentation

vtkImageDataStreamer* vtkImageDataStreamer::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkMemoryLimitImageDataStreamer.

vtkImageDataStreamer::vtkTypeRevisionMacro | ( | vtkImageDataStreamer | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkMemoryLimitImageDataStreamer.

void vtkImageDataStreamer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkMemoryLimitImageDataStreamer.

virtual void vtkImageDataStreamer::SetNumberOfStreamDivisions ( int ) [virtual]

Set how many pieces to divide the input into. void SetNumberOfStreamDivisions(int num); int GetNumberOfStreamDivisions();

virtual int vtkImageDataStreamer::GetNumberOfStreamDivisions ( ) [virtual]

Set how many pieces to divide the input into. void SetNumberOfStreamDivisions(int num); int GetNumberOfStreamDivisions();

void vtkImageDataStreamer::UpdateData ( vtkDataObject * out ) [virtual]

Need to override since this is where streaming will be done

Reimplemented from vtkSource.

Reimplemented in vtkMemoryLimitImageDataStreamer.

virtual vtkExtentTranslator* vtkImageDataStreamer::GetExtentTranslator ( ) [virtual]

Get the extent translator that will be used to split the requests

virtual void vtkImageDataStreamer::SetExtentTranslator ( vtkExtentTranslator * ) [virtual]

Get the extent translator that will be used to split the requests

Member Data Documentation

vtkExtentTranslator* vtkImageDataStreamer::ExtentTranslator [protected]

Definition at line 75 of file vtkImageDataStreamer.h.

int vtkImageDataStreamer::NumberOfStreamDivisions [protected]

Definition at line 76 of file vtkImageDataStreamer.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDataStreamer.h
Generated on Mon Mar 25 01:18:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDecomposeFilter Class Reference

Filters that execute axes in series. More...

#include <vtkImageDecomposeFilter.h>

Inheritance diagram for vtkImageDecomposeFilter:

[legend]
Collaboration diagram for vtkImageDecomposeFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDecomposeFilter, vtkImageIterateFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetDimensionality (int dim)
virtual int | GetDimensionality ()
void | SetFilteredAxes (int axis0)
void | SetFilteredAxes (int axis0, int axis2)
void | SetFilteredAxes (int axis0, int axis2, int axis3)
void | PermuteIncrements (int *increments, int &inc0, int &inc1, int &inc2)
void | PermuteExtent (int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)

Protected Methods

vtkImageDecomposeFilter ()
~vtkImageDecomposeFilter ()

Protected Attributes

int | Dimensionality

Detailed Description

Filters that execute axes in series.

Date:
2002/01/22 15:32:17
Revision:
1.23

This superclass molds the vtkImageIterateFilter superclass so it iterates over the axes. The filter uses dimensionality to determine how many axes to execute (starting from x). The filter also provides convenience methods for permuting information retrieved from input, output and vtkImageData.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (70%)
  • Lorensen, Bill (12%)
  • Schroeder, Will (8%)

Definition at line 43 of file vtkImageDecomposeFilter.h.

Constructor & Destructor Documentation

vtkImageDecomposeFilter::vtkImageDecomposeFilter ( ) [protected]

vtkImageDecomposeFilter::~vtkImageDecomposeFilter ( ) [inline, protected]

Definition at line 78 of file vtkImageDecomposeFilter.h.

Member Function Documentation

vtkImageDecomposeFilter::vtkTypeRevisionMacro | ( | vtkImageDecomposeFilter | ,
 |  | vtkImageIterateFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageIterateFilter.

Reimplemented in vtkImageCityBlockDistance, vtkImageEuclideanDistance, vtkImageFFT, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageRFFT, and vtkImageSeparableConvolution.

void vtkImageDecomposeFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageIterateFilter.

Reimplemented in vtkImageEuclideanDistance, and vtkImageSeparableConvolution.

void vtkImageDecomposeFilter::SetDimensionality ( int dim )

Dimensionality is the number of axes which are considered during execution. To process images dimensionality would be set to 2.

virtual int vtkImageDecomposeFilter::GetDimensionality ( ) [virtual]

Dimensionality is the number of axes which are considered during execution. To process images dimensionality would be set to 2.

void vtkImageDecomposeFilter::SetFilteredAxes ( int axis0 )

Obsolete legacy methods.

void vtkImageDecomposeFilter::SetFilteredAxes | ( | int | axis0,
 |  | int | axis2
 | ) |

Obsolete legacy methods.

void vtkImageDecomposeFilter::SetFilteredAxes | ( | int | axis0,
 |  | int | axis2,
 |  | int | axis3
 | ) |

Obsolete legacy methods.

void vtkImageDecomposeFilter::PermuteIncrements | ( | int * | increments,
 |  | int & | inc0,
 |  | int & | inc1,
 |  | int & | inc2
 | ) |

Private methods kept public for template execute functions.

void vtkImageDecomposeFilter::PermuteExtent | ( | int * | extent,
 |  | int & | min0,
 |  | int & | max0,
 |  | int & | min1,
 |  | int & | max1,
 |  | int & | min2,
 |  | int & | max2
 | ) |

Private methods kept public for template execute functions.

Member Data Documentation

int vtkImageDecomposeFilter::Dimensionality [protected]

Definition at line 80 of file vtkImageDecomposeFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDecomposeFilter.h
Generated on Mon Mar 25 01:18:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDifference Class Reference

Compares images for regression tests. More...

#include <vtkImageDifference.h>

Inheritance diagram for vtkImageDifference:

[legend]
Collaboration diagram for vtkImageDifference:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDifference, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetImage (vtkImageData *image)
vtkImageData * GetImage ()
void | SetInput (vtkImageData *input)
void | SetInput (int num, vtkImageData *input)
float | GetError (void)
void | GetError (float *e)
float | GetThresholdedError (void)
void | GetThresholdedError (float *e)
virtual void | SetThreshold (int)
virtual int | GetThreshold ()
virtual void | SetAllowShift (int)
virtual int | GetAllowShift ()
virtual void | AllowShiftOn ()
virtual void | AllowShiftOff ()
virtual void | SetAveraging (int)
virtual int | GetAveraging ()
virtual void | AveragingOn ()
virtual void | AveragingOff ()

Static Public Methods

vtkImageDifference * | New ()

Protected Methods

vtkImageDifference ()
~vtkImageDifference ()
void | ExecuteInformation (vtkImageData **inputs, vtkImageData *output)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

float | ErrorPerThread [VTK_MAX_THREADS]
float | ThresholdedErrorPerThread [VTK_MAX_THREADS]
int | AllowShift
int | Threshold
int | Averaging

Detailed Description

Compares images for regression tests.

Date:
2002/01/22 15:32:19
Revision:
1.27

vtkImageDifference takes two rgb unsigned char images and compares them. It allows the images to be slightly different. If AllowShift is on, then each pixel can be shifted by one pixel. Threshold is the allowable error for each pixel.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (53%)
  • Lorensen, Bill (17%)
  • Martin, Ken (15%)
  • Avila, Lisa (10%)
Tests:
vtkImageDifference (Tests)

Definition at line 45 of file vtkImageDifference.h.

Constructor & Destructor Documentation

vtkImageDifference::vtkImageDifference ( ) [protected]

vtkImageDifference::~vtkImageDifference ( ) [inline, protected]

Definition at line 108 of file vtkImageDifference.h.

Member Function Documentation

vtkImageDifference* vtkImageDifference::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageDifference::vtkTypeRevisionMacro | ( | vtkImageDifference | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageDifference::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageDifference::SetImage ( vtkImageData * image ) [inline]

Specify the Image to compare the input to.

Definition at line 54 of file vtkImageDifference.h.

vtkImageData* vtkImageDifference::GetImage ( ) [inline]

Specify the Image to compare the input to.

Definition at line 55 of file vtkImageDifference.h.

void vtkImageDifference::SetInput ( vtkImageData * input ) [inline]

Specify the Input for comparison.

Definition at line 60 of file vtkImageDifference.h.

void vtkImageDifference::SetInput | ( | int | num,
 |  | vtkImageData * | input
 | ) | [inline, virtual]

Specify the Input for comparison.

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 61 of file vtkImageDifference.h.

float vtkImageDifference::GetError ( void )

Return the total error in comparing the two images.

void vtkImageDifference::GetError ( float * e ) [inline]

Return the total error in comparing the two images.

Definition at line 68 of file vtkImageDifference.h.

float vtkImageDifference::GetThresholdedError ( void )

Return the total thresholded error in comparing the two images. The thresholded error is the error for a given pixel minus the threshold and clamped at a minimum of zero.

void vtkImageDifference::GetThresholdedError ( float * e ) [inline]

Return the total thresholded error in comparing the two images. The thresholded error is the error for a given pixel minus the threshold and clamped at a minimum of zero.

Definition at line 76 of file vtkImageDifference.h.

virtual void vtkImageDifference::SetThreshold ( int ) [virtual]

Specify a threshold tolerance for pixel differences.

virtual int vtkImageDifference::GetThreshold ( ) [virtual]

Specify a threshold tolerance for pixel differences.

virtual void vtkImageDifference::SetAllowShift ( int ) [virtual]

Specify whether the comparison will allow a shift of one pixel between the images. If set, then the minimum difference between input images will be used to determine the difference. Otherwise, the difference is computed directly between pixels of identical row/column values.

virtual int vtkImageDifference::GetAllowShift ( ) [virtual]

Specify whether the comparison will allow a shift of one pixel between the images. If set, then the minimum difference between input images will be used to determine the difference. Otherwise, the difference is computed directly between pixels of identical row/column values.

virtual void vtkImageDifference::AllowShiftOn ( ) [virtual]

Specify whether the comparison will allow a shift of one pixel between the images. If set, then the minimum difference between input images will be used to determine the difference. Otherwise, the difference is computed directly between pixels of identical row/column values.

virtual void vtkImageDifference::AllowShiftOff ( ) [virtual]

Specify whether the comparison will allow a shift of one pixel between the images. If set, then the minimum difference between input images will be used to determine the difference. Otherwise, the difference is computed directly between pixels of identical row/column values.

virtual void vtkImageDifference::SetAveraging ( int ) [virtual]

Specify whether the comparison will include comparison of averaged 3x3 data between the images. For graphics renderings you normally would leave this on. For imaging operations it should be off.

virtual int vtkImageDifference::GetAveraging ( ) [virtual]

Specify whether the comparison will include comparison of averaged 3x3 data between the images. For graphics renderings you normally would leave this on. For imaging operations it should be off.

virtual void vtkImageDifference::AveragingOn ( ) [virtual]

Specify whether the comparison will include comparison of averaged 3x3 data between the images. For graphics renderings you normally would leave this on. For imaging operations it should be off.

virtual void vtkImageDifference::AveragingOff ( ) [virtual]

Specify whether the comparison will include comparison of averaged 3x3 data between the images. For graphics renderings you normally would leave this on. For imaging operations it should be off.

void vtkImageDifference::ExecuteInformation | ( | vtkImageData ** | inputs,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageDifference::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageDifference::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 119 of file vtkImageDifference.h.

void vtkImageDifference::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

float vtkImageDifference::ErrorPerThread[VTK_MAX_THREADS] [protected]

Definition at line 110 of file vtkImageDifference.h.

float vtkImageDifference::ThresholdedErrorPerThread[VTK_MAX_THREADS] [protected]

Definition at line 111 of file vtkImageDifference.h.

int vtkImageDifference::AllowShift [protected]

Definition at line 112 of file vtkImageDifference.h.

int vtkImageDifference::Threshold [protected]

Definition at line 113 of file vtkImageDifference.h.

int vtkImageDifference::Averaging [protected]

Definition at line 114 of file vtkImageDifference.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDifference.h
Generated on Mon Mar 25 01:18:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDilateErode3D Class Reference

Dilates one value and erodes another. More...

#include <vtkImageDilateErode3D.h>

Inheritance diagram for vtkImageDilateErode3D:

[legend]
Collaboration diagram for vtkImageDilateErode3D:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageDilateErode3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageDilateErode3D * | New ()

Public Methods

void | SetKernelSize (int size0, int size1, int size2)
virtual void | SetDilateValue (float)
virtual float | GetDilateValue ()
virtual void | SetErodeValue (float)
virtual float | GetErodeValue ()

Protected Methods

vtkImageDilateErode3D ()
~vtkImageDilateErode3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

vtkImageEllipsoidSource * Ellipse
float | DilateValue
float | ErodeValue

Detailed Description

Dilates one value and erodes another.

Date:
2002/01/22 15:32:20
Revision:
1.31

vtkImageDilateErode3D will dilate one value and erode another. It uses an elliptical foot print, and only erodes/dilates on the boundary of the two values. The filter is restricted to the X, Y, and Z axes for now. It can degenerate to a 2 or 1 dimensional filter by setting the kernel size to 1 for a specific axis.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (86%)
  • Martin, Ken (7%)

Definition at line 44 of file vtkImageDilateErode3D.h.

Constructor & Destructor Documentation

vtkImageDilateErode3D::vtkImageDilateErode3D ( ) [protected]

vtkImageDilateErode3D::~vtkImageDilateErode3D ( ) [protected]

Member Function Documentation

vtkImageDilateErode3D* vtkImageDilateErode3D::New ( ) [static]

Construct an instance of vtkImageDilateErode3D filter. By default zero values are dilated.

Reimplemented from vtkImageSpatialFilter.

vtkImageDilateErode3D::vtkTypeRevisionMacro | ( | vtkImageDilateErode3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageDilateErode3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageDilateErode3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood and computes the elliptical foot print.

virtual void vtkImageDilateErode3D::SetDilateValue ( float ) [virtual]

Set/Get the Dilate and Erode values to be used by this filter.

virtual float vtkImageDilateErode3D::GetDilateValue ( ) [virtual]

Set/Get the Dilate and Erode values to be used by this filter.

virtual void vtkImageDilateErode3D::SetErodeValue ( float ) [virtual]

Set/Get the Dilate and Erode values to be used by this filter.

virtual float vtkImageDilateErode3D::GetErodeValue ( ) [virtual]

Set/Get the Dilate and Erode values to be used by this filter.

void vtkImageDilateErode3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageEllipsoidSource* vtkImageDilateErode3D::Ellipse [protected]

Definition at line 73 of file vtkImageDilateErode3D.h.

float vtkImageDilateErode3D::DilateValue [protected]

Definition at line 74 of file vtkImageDilateErode3D.h.

float vtkImageDilateErode3D::ErodeValue [protected]

Definition at line 75 of file vtkImageDilateErode3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDilateErode3D.h
Generated on Mon Mar 25 01:18:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDivergence Class Reference

Divergence of a vector field. More...

#include <vtkImageDivergence.h>

Inheritance diagram for vtkImageDivergence:

[legend]
Collaboration diagram for vtkImageDivergence:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDivergence, vtkImageToImageFilter)

Static Public Methods

vtkImageDivergence * | New ()

Protected Methods

vtkImageDivergence ()
~vtkImageDivergence ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Detailed Description

Divergence of a vector field.

Date:
2002/01/22 15:32:21
Revision:
1.29

vtkImageDivergence takes a 3D vector field and creates a scalar field which which represents the rate of change of the vector field. The definition of Divergence: Given V = P(x,y,z), Q(x,y,z), R(x,y,z), Divergence = dP/dx + dQ/dy + dR/dz.

Created by:
  • Law, Charles
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (53%)
  • Law, Charles (27%)
  • Lorensen, Bill (8%)
Tests:
vtkImageDivergence (Tests)

Definition at line 47 of file vtkImageDivergence.h.

Constructor & Destructor Documentation

vtkImageDivergence::vtkImageDivergence ( ) [inline, protected]

Definition at line 54 of file vtkImageDivergence.h.

vtkImageDivergence::~vtkImageDivergence ( ) [inline, protected]

Definition at line 55 of file vtkImageDivergence.h.

Member Function Documentation

vtkImageDivergence* vtkImageDivergence::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageDivergence::vtkTypeRevisionMacro | ( | vtkImageDivergence | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageDivergence::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageDivergence::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageDivergence::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 59 of file vtkImageDivergence.h.

void vtkImageDivergence::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDivergence.h
Generated on Mon Mar 25 01:18:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageDotProduct Class Reference

Dot product of two vector images. More...

#include <vtkImageDotProduct.h>

Inheritance diagram for vtkImageDotProduct:

[legend]
Collaboration diagram for vtkImageDotProduct:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageDotProduct, vtkImageTwoInputFilter)

Static Public Methods

vtkImageDotProduct * | New ()

Protected Methods

vtkImageDotProduct ()
~vtkImageDotProduct ()
void | ExecuteInformation (vtkImageData **inDatas, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Detailed Description

Dot product of two vector images.

Date:
2002/01/22 15:32:23
Revision:
1.26

vtkImageDotProduct interprets the scalar components of two images as vectors and takes the dot product vector by vector (pixel by pixel).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (52%)
  • Martin, Ken (30%)
  • Lorensen, Bill (8%)
  • Schroeder, Will (5%)
Tests:
vtkImageDotProduct (Tests)

Definition at line 45 of file vtkImageDotProduct.h.

Constructor & Destructor Documentation

vtkImageDotProduct::vtkImageDotProduct ( ) [inline, protected]

Definition at line 52 of file vtkImageDotProduct.h.

vtkImageDotProduct::~vtkImageDotProduct ( ) [inline, protected]

Definition at line 53 of file vtkImageDotProduct.h.

Member Function Documentation

vtkImageDotProduct* vtkImageDotProduct::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageDotProduct::vtkTypeRevisionMacro | ( | vtkImageDotProduct | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageDotProduct::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageDotProduct::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 56 of file vtkImageDotProduct.h.

void vtkImageDotProduct::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageDotProduct.h
Generated on Mon Mar 25 01:18:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEllipsoidSource Class Reference

Create a binary image of an ellipsoid. More...

#include <vtkImageEllipsoidSource.h>

Inheritance diagram for vtkImageEllipsoidSource:

[legend]
Collaboration diagram for vtkImageEllipsoidSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageEllipsoidSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetWholeExtent (int extent[6])
void | SetWholeExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
void | GetWholeExtent (int extent[6])
int * | GetWholeExtent ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float &, float &, float &)
virtual void | GetCenter (float[3])
virtual void | SetRadius (float, float, float)
virtual void | SetRadius (float[3])
virtual float * | GetRadius ()
virtual void | GetRadius (float &, float &, float &)
virtual void | GetRadius (float[3])
virtual void | SetInValue (float)
virtual float | GetInValue ()
virtual void | SetOutValue (float)
virtual float | GetOutValue ()
virtual void | SetOutputScalarType (int)
virtual int | GetOutputScalarType ()
void | SetOutputScalarTypeToDouble ()
void | SetOutputScalarTypeToFloat ()
void | SetOutputScalarTypeToLong ()
void | SetOutputScalarTypeToUnsignedLong ()
void | SetOutputScalarTypeToInt ()
void | SetOutputScalarTypeToUnsignedInt ()
void | SetOutputScalarTypeToShort ()
void | SetOutputScalarTypeToUnsignedShort ()
void | SetOutputScalarTypeToChar ()
void | SetOutputScalarTypeToUnsignedChar ()

Static Public Methods

vtkImageEllipsoidSource * | New ()

Protected Methods

vtkImageEllipsoidSource ()
~vtkImageEllipsoidSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *outData)

Protected Attributes

int | WholeExtent [6]
float | Center [3]
float | Radius [3]
float | InValue
float | OutValue
int | OutputScalarType

Detailed Description

Create a binary image of an ellipsoid.

Date:
2002/01/22 15:32:24
Revision:
1.25

vtkImageEllipsoidSource creates a binary image of a ellipsoid. It was created as an example of a simple source, and to test the mask filter. It is also used internally in vtkImageDilateErode3D.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (64%)
  • Law, Charles (18%)
  • Martin, Ken (13%)
Tests:
vtkImageEllipsoidSource (Tests)

Definition at line 43 of file vtkImageEllipsoidSource.h.

Constructor & Destructor Documentation

vtkImageEllipsoidSource::vtkImageEllipsoidSource ( ) [protected]

vtkImageEllipsoidSource::~vtkImageEllipsoidSource ( ) [protected]

Member Function Documentation

vtkImageEllipsoidSource* vtkImageEllipsoidSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageEllipsoidSource::vtkTypeRevisionMacro | ( | vtkImageEllipsoidSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageEllipsoidSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageEllipsoidSource::SetWholeExtent ( int extent[6] )

Set/Get the extent of the whole output image.

void vtkImageEllipsoidSource::SetWholeExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

Set/Get the extent of the whole output image.

void vtkImageEllipsoidSource::GetWholeExtent ( int extent[6] )

Set/Get the extent of the whole output image.

int* vtkImageEllipsoidSource::GetWholeExtent ( ) [inline]

Set/Get the extent of the whole output image.

Definition at line 56 of file vtkImageEllipsoidSource.h.

virtual void vtkImageEllipsoidSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the center of the ellipsoid.

virtual void vtkImageEllipsoidSource::SetCenter ( float [3] ) [virtual]

Set/Get the center of the ellipsoid.

virtual float* vtkImageEllipsoidSource::GetCenter ( ) [virtual]

Set/Get the center of the ellipsoid.

virtual void vtkImageEllipsoidSource::GetCenter | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the center of the ellipsoid.

virtual void vtkImageEllipsoidSource::GetCenter ( float [3] ) [virtual]

Set/Get the center of the ellipsoid.

virtual void vtkImageEllipsoidSource::SetRadius | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the radius of the ellipsoid.

virtual void vtkImageEllipsoidSource::SetRadius ( float [3] ) [virtual]

Set/Get the radius of the ellipsoid.

virtual float* vtkImageEllipsoidSource::GetRadius ( ) [virtual]

Set/Get the radius of the ellipsoid.

virtual void vtkImageEllipsoidSource::GetRadius | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the radius of the ellipsoid.

virtual void vtkImageEllipsoidSource::GetRadius ( float [3] ) [virtual]

Set/Get the radius of the ellipsoid.

virtual void vtkImageEllipsoidSource::SetInValue ( float ) [virtual]

Set/Get the inside pixel values.

virtual float vtkImageEllipsoidSource::GetInValue ( ) [virtual]

Set/Get the inside pixel values.

virtual void vtkImageEllipsoidSource::SetOutValue ( float ) [virtual]

Set/Get the outside pixel values.

virtual float vtkImageEllipsoidSource::GetOutValue ( ) [virtual]

Set/Get the outside pixel values.

virtual void vtkImageEllipsoidSource::SetOutputScalarType ( int ) [virtual]

Set what type of scalar data this source should generate.

virtual int vtkImageEllipsoidSource::GetOutputScalarType ( ) [virtual]

Set what type of scalar data this source should generate.

void vtkImageEllipsoidSource::SetOutputScalarTypeToDouble ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 87 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToFloat ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 89 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToLong ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 91 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToUnsignedLong ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 93 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToInt ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 95 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToUnsignedInt ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 97 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToShort ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 99 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToUnsignedShort ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 101 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToChar ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 103 of file vtkImageEllipsoidSource.h.

void vtkImageEllipsoidSource::SetOutputScalarTypeToUnsignedChar ( ) [inline]

Set what type of scalar data this source should generate.

Definition at line 105 of file vtkImageEllipsoidSource.h.

virtual void vtkImageEllipsoidSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkImageEllipsoidSource::ExecuteData ( vtkDataObject * outData ) [protected, virtual]

Member Data Documentation

int vtkImageEllipsoidSource::WholeExtent[6] [protected]

Definition at line 113 of file vtkImageEllipsoidSource.h.

float vtkImageEllipsoidSource::Center[3] [protected]

Definition at line 114 of file vtkImageEllipsoidSource.h.

float vtkImageEllipsoidSource::Radius[3] [protected]

Definition at line 115 of file vtkImageEllipsoidSource.h.

float vtkImageEllipsoidSource::InValue [protected]

Definition at line 116 of file vtkImageEllipsoidSource.h.

float vtkImageEllipsoidSource::OutValue [protected]

Definition at line 117 of file vtkImageEllipsoidSource.h.

int vtkImageEllipsoidSource::OutputScalarType [protected]

Definition at line 118 of file vtkImageEllipsoidSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageEllipsoidSource.h
Generated on Mon Mar 25 01:18:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEuclideanDistance Class Reference

computes 3D Euclidean DT. More...

#include <vtkImageEuclideanDistance.h>

Inheritance diagram for vtkImageEuclideanDistance:

[legend]
Collaboration diagram for vtkImageEuclideanDistance:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageEuclideanDistance, vtkImageDecomposeFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)
int | SplitExtent (int splitExt[6], int startExt[6], int num, int total)
virtual void | SetInitialize (int)
virtual int | GetInitialize ()
virtual void | InitializeOn ()
virtual void | InitializeOff ()
virtual void | SetConsiderAnisotropy (int)
virtual int | GetConsiderAnisotropy ()
virtual void | ConsiderAnisotropyOn ()
virtual void | ConsiderAnisotropyOff ()
virtual void | SetMaximumDistance (float)
virtual float | GetMaximumDistance ()
virtual void | SetAlgorithm (int)
virtual int | GetAlgorithm ()
void | SetAlgorithmToSaito ()
void | SetAlgorithmToSaitoCached ()

Static Public Methods

vtkImageEuclideanDistance * | New ()

Protected Methods

vtkImageEuclideanDistance ()
~vtkImageEuclideanDistance ()
virtual void | AllocateOutputScalars (vtkImageData *outData)
void | ExecuteInformation (vtkImageData *input, vtkImageData *output)
void | ExecuteInformation ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])

Protected Attributes

float | MaximumDistance
int | Initialize
int | ConsiderAnisotropy
int | Algorithm

Detailed Description

computes 3D Euclidean DT.

Date:
2002/01/22 15:32:25
Revision:
1.11

vtkImageEuclideanDistance implements the Euclidean DT using Saito's algorithm. The distance map produced contains the square of the Euclidean distance values.

The algorithm has a o(n^(D+1)) complexity over nxnx...xn images in D dimensions. It is very efficient on relatively small images. Cuisenaire's algorithms should be used instead if n >> 500. These are not implemented yet.

For the special case of images where the slice-size is a multiple of 2^N with a large N (typically for 256x256 slices), Saito's algorithm encounters a lot of cache conflicts during the 3rd iteration which can slow it very significantly. In that case, one should use SetAlgorithmToSaitoCached() instead for better performance.

References:

T. Saito and J.I. Toriwaki. New algorithms for Euclidean distance transformations of an n-dimensional digitised picture with applications. Pattern Recognition, 27(11). pp. 1551--1565, 1994.

O. Cuisenaire. Distance Transformation: fast algorithms and applications to medical image processing. PhD Thesis, Universite catholique de Louvain, October 1999. http://ltswww.epfl.ch/~cuisenai/papers/oc_thesis.pdf

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (89%)
  • Avila, Lisa (5%)
Tests:
vtkImageEuclideanDistance (Tests)

Definition at line 66 of file vtkImageEuclideanDistance.h.

Constructor & Destructor Documentation

vtkImageEuclideanDistance::vtkImageEuclideanDistance ( ) [protected]

vtkImageEuclideanDistance::~vtkImageEuclideanDistance ( ) [inline, protected]

Definition at line 124 of file vtkImageEuclideanDistance.h.

Member Function Documentation

vtkImageEuclideanDistance* vtkImageEuclideanDistance::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageEuclideanDistance::vtkTypeRevisionMacro | ( | vtkImageEuclideanDistance | ,
 |  | vtkImageDecomposeFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

void vtkImageEuclideanDistance::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

int vtkImageEuclideanDistance::SplitExtent | ( | int | splitExt[6],
 |  | int | startExt[6],
 |  | int | num,
 |  | int | total
 | ) | [virtual]

Used internally for streaming and threads. Splits output update extent into num pieces. This method needs to be called num times. Results must not overlap for consistent starting extent. Subclass can override this method. This method returns the number of peices resulting from a successful split. This can be from 1 to "total". If 1 is returned, the extent cannot be split.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageEuclideanDistance::SetInitialize ( int ) [virtual]

Used to set all non-zero voxels to MaximumDistance before starting the distance transformation. Setting Initialize off keeps the current value in the input image as starting point. This allows to superimpose several distance maps.

virtual int vtkImageEuclideanDistance::GetInitialize ( ) [virtual]

Used to set all non-zero voxels to MaximumDistance before starting the distance transformation. Setting Initialize off keeps the current value in the input image as starting point. This allows to superimpose several distance maps.

virtual void vtkImageEuclideanDistance::InitializeOn ( ) [virtual]

Used to set all non-zero voxels to MaximumDistance before starting the distance transformation. Setting Initialize off keeps the current value in the input image as starting point. This allows to superimpose several distance maps.

virtual void vtkImageEuclideanDistance::InitializeOff ( ) [virtual]

Used to set all non-zero voxels to MaximumDistance before starting the distance transformation. Setting Initialize off keeps the current value in the input image as starting point. This allows to superimpose several distance maps.

virtual void vtkImageEuclideanDistance::SetConsiderAnisotropy ( int ) [virtual]

Used to define whether Spacing should be used in the computation of the distances

virtual int vtkImageEuclideanDistance::GetConsiderAnisotropy ( ) [virtual]

Used to define whether Spacing should be used in the computation of the distances

virtual void vtkImageEuclideanDistance::ConsiderAnisotropyOn ( ) [virtual]

Used to define whether Spacing should be used in the computation of the distances

virtual void vtkImageEuclideanDistance::ConsiderAnisotropyOff ( ) [virtual]

Used to define whether Spacing should be used in the computation of the distances

virtual void vtkImageEuclideanDistance::SetMaximumDistance ( float ) [virtual]

Any distance bigger than this->MaximumDistance will not ne computed but set to this->MaximumDistance instead.

virtual float vtkImageEuclideanDistance::GetMaximumDistance ( ) [virtual]

Any distance bigger than this->MaximumDistance will not ne computed but set to this->MaximumDistance instead.

virtual void vtkImageEuclideanDistance::SetAlgorithm ( int ) [virtual]

Selects a Euclidean DT algorithm. 1. Saito 2. Saito-cached More algorithms will be added later on.

virtual int vtkImageEuclideanDistance::GetAlgorithm ( ) [virtual]

Selects a Euclidean DT algorithm. 1. Saito 2. Saito-cached More algorithms will be added later on.

void vtkImageEuclideanDistance::SetAlgorithmToSaito ( ) [inline]

Selects a Euclidean DT algorithm. 1. Saito 2. Saito-cached More algorithms will be added later on.

Definition at line 114 of file vtkImageEuclideanDistance.h.

void vtkImageEuclideanDistance::SetAlgorithmToSaitoCached ( ) [inline]

Selects a Euclidean DT algorithm. 1. Saito 2. Saito-cached More algorithms will be added later on.

Definition at line 116 of file vtkImageEuclideanDistance.h.

void vtkImageEuclideanDistance::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [virtual]

Reimplemented from vtkImageIterateFilter.

virtual void vtkImageEuclideanDistance::AllocateOutputScalars ( vtkImageData * outData ) [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageEuclideanDistance::ExecuteInformation | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageEuclideanDistance::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 135 of file vtkImageEuclideanDistance.h.

void vtkImageEuclideanDistance::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

Member Data Documentation

float vtkImageEuclideanDistance::MaximumDistance [protected]

Definition at line 126 of file vtkImageEuclideanDistance.h.

int vtkImageEuclideanDistance::Initialize [protected]

Definition at line 127 of file vtkImageEuclideanDistance.h.

int vtkImageEuclideanDistance::ConsiderAnisotropy [protected]

Definition at line 128 of file vtkImageEuclideanDistance.h.

int vtkImageEuclideanDistance::Algorithm [protected]

Definition at line 129 of file vtkImageEuclideanDistance.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageEuclideanDistance.h
Generated on Mon Mar 25 01:18:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageEuclideanToPolar Class Reference

Converts 2D Euclidean coordinates to polar. More...

#include <vtkImageEuclideanToPolar.h>

Inheritance diagram for vtkImageEuclideanToPolar:

[legend]
Collaboration diagram for vtkImageEuclideanToPolar:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageEuclideanToPolar, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetThetaMaximum (float)
virtual float | GetThetaMaximum ()

Static Public Methods

vtkImageEuclideanToPolar * | New ()

Protected Methods

vtkImageEuclideanToPolar ()
~vtkImageEuclideanToPolar ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

float | ThetaMaximum

Detailed Description

Converts 2D Euclidean coordinates to polar.

Date:
2002/01/22 15:32:27
Revision:
1.21

For each pixel with vector components x,y, this filter outputs theta in component0, and radius in component1.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (49%)
  • Martin, Ken (35%)
  • Schroeder, Will (5%)
  • Miller, Jim (5%)
Tests:
vtkImageEuclideanToPolar (Tests)

Definition at line 44 of file vtkImageEuclideanToPolar.h.

Constructor & Destructor Documentation

vtkImageEuclideanToPolar::vtkImageEuclideanToPolar ( ) [protected]

vtkImageEuclideanToPolar::~vtkImageEuclideanToPolar ( ) [inline, protected]

Definition at line 61 of file vtkImageEuclideanToPolar.h.

Member Function Documentation

vtkImageEuclideanToPolar* vtkImageEuclideanToPolar::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageEuclideanToPolar::vtkTypeRevisionMacro | ( | vtkImageEuclideanToPolar | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageEuclideanToPolar::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageEuclideanToPolar::SetThetaMaximum ( float ) [virtual]

Theta is an angle. Maximum specifies when it maps back to 0. ThetaMaximum defaults to 255 instead of 2PI, because unsigned char is expected as input. The output type must be the same as input type.

virtual float vtkImageEuclideanToPolar::GetThetaMaximum ( ) [virtual]

Theta is an angle. Maximum specifies when it maps back to 0. ThetaMaximum defaults to 255 instead of 2PI, because unsigned char is expected as input. The output type must be the same as input type.

void vtkImageEuclideanToPolar::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageEuclideanToPolar::ThetaMaximum [protected]

Definition at line 63 of file vtkImageEuclideanToPolar.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageEuclideanToPolar.h
Generated on Mon Mar 25 01:18:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageExport Class Reference

Export VTK images to third-party systems. More...

#include <vtkImageExport.h>

Inheritance diagram for vtkImageExport:

[legend]
Collaboration diagram for vtkImageExport:

[legend]
List of all members.

Public Types

typedef void(* | UpdateInformationCallbackType )(void *)
typedef int(* | PipelineModifiedCallbackType )(void *)
typedef int *(* | WholeExtentCallbackType )(void *)
typedef float *(* | SpacingCallbackType )(void *)
typedef float *(* | OriginCallbackType )(void *)
typedef const char *(* | ScalarTypeCallbackType )(void *)
typedef int(* | NumberOfComponentsCallbackType )(void *)
typedef void(* | PropagateUpdateExtentCallbackType )(void *, int *)
typedef void(* | UpdateDataCallbackType )(void *)
typedef int *(* | DataExtentCallbackType )(void *)
typedef void *(* | BufferPointerCallbackType )(void *)

Public Methods

vtkTypeRevisionMacro (vtkImageExport, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
int | GetDataMemorySize ()
void * | GetPointerToData ()
void * | GetCallbackUserData ()
void | GetDataDimensions (int *ptr)
int * | GetDataDimensions ()
int | GetDataNumberOfScalarComponents ()
int | GetDataScalarType ()
const char * | GetDataScalarTypeAsString ()
int * | GetDataExtent ()
void | GetDataExtent (int *ptr)
float * | GetDataSpacing ()
void | GetDataSpacing (float *ptr)
float * | GetDataOrigin ()
void | GetDataOrigin (float *ptr)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | ImageLowerLeftOn ()
virtual void | ImageLowerLeftOff ()
virtual int | GetImageLowerLeft ()
virtual void | SetImageLowerLeft (int)
void | SetExportVoidPointer (void *)
void * | GetExportVoidPointer ()
void | Export ()
virtual void | Export (void *)
UpdateInformationCallbackType | GetUpdateInformationCallback () const
PipelineModifiedCallbackType | GetPipelineModifiedCallback () const
WholeExtentCallbackType | GetWholeExtentCallback () const
SpacingCallbackType | GetSpacingCallback () const
OriginCallbackType | GetOriginCallback () const
ScalarTypeCallbackType | GetScalarTypeCallback () const
NumberOfComponentsCallbackType | GetNumberOfComponentsCallback () const
PropagateUpdateExtentCallbackType | GetPropagateUpdateExtentCallback () const
UpdateDataCallbackType | GetUpdateDataCallback () const
DataExtentCallbackType | GetDataExtentCallback () const
BufferPointerCallbackType | GetBufferPointerCallback () const

Static Public Methods

vtkImageExport * | New ()

Protected Methods

vtkImageExport ()
~vtkImageExport ()
virtual void | UpdateInformationCallback ()
virtual int | PipelineModifiedCallback ()
virtual void | UpdateDataCallback ()
virtual int * | WholeExtentCallback ()
virtual float * | SpacingCallback ()
virtual float * | OriginCallback ()
virtual const char * | ScalarTypeCallback ()
virtual int | NumberOfComponentsCallback ()
virtual void | PropagateUpdateExtentCallback (int *)
virtual int * | DataExtentCallback ()
virtual void * | BufferPointerCallback ()

Protected Attributes

int | ImageLowerLeft
int | DataDimensions [3]
void * | ExportVoidPointer
unsigned long | LastPipelineMTime

Detailed Description

Export VTK images to third-party systems.

Date:
2002/01/22 15:32:28
Revision:
1.29

vtkImageExport provides a way of exporting image data at the end of a pipeline to a third-party system or to a simple C array. Applications can use this to get direct access to the image data in memory. A callback interface is provided to allow connection of the VTK pipeline to a third-party pipeline. This interface conforms to the interface of vtkImageImport. In Python it is possible to use this class to write the image data into a python string that has been pre-allocated to be the correct size.

See also:
vtkImageImport
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Gobbi, David (49%)
  • Law, Charles (29%)
  • King, Brad (18%)
Tests:
vtkImageExport (Tests)

Definition at line 52 of file vtkImageExport.h.

Member Typedef Documentation

typedef void(* vtkImageExport::UpdateInformationCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef int(* vtkImageExport::PipelineModifiedCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef int*(* vtkImageExport::WholeExtentCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef float*(* vtkImageExport::SpacingCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef float*(* vtkImageExport::OriginCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef const char*(* vtkImageExport::ScalarTypeCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef int(* vtkImageExport::NumberOfComponentsCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef void(* vtkImageExport::PropagateUpdateExtentCallbackType)(void*, int*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef void(* vtkImageExport::UpdateDataCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef int*(* vtkImageExport::DataExtentCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

typedef void*(* vtkImageExport::BufferPointerCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation in vtkImageImport.h.

Constructor & Destructor Documentation

vtkImageExport::vtkImageExport ( ) [protected]

vtkImageExport::~vtkImageExport ( ) [protected]

Member Function Documentation

vtkImageExport* vtkImageExport::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkImageExport::vtkTypeRevisionMacro | ( | vtkImageExport | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

void vtkImageExport::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

int vtkImageExport::GetDataMemorySize ( )

Get the number of bytes required for the output C array.

void vtkImageExport::GetDataDimensions ( int * ptr )

Get the (x,y,z) index dimensions of the data. Please note that C arrays are indexed in decreasing order, i.e. array[z][y][x].

int* vtkImageExport::GetDataDimensions ( ) [inline]

Get the (x,y,z) index dimensions of the data. Please note that C arrays are indexed in decreasing order, i.e. array[z][y][x].

Definition at line 66 of file vtkImageExport.h.

int vtkImageExport::GetDataNumberOfScalarComponents ( ) [inline]

Get the number of scalar components of the data. Please note that when you index into a C array, the scalar component index comes last, i.e. array[z][y][x][c].

Definition at line 75 of file vtkImageExport.h.

int vtkImageExport::GetDataScalarType ( ) [inline]

Get the scalar type of the data. The scalar type of the C array must match the scalar type of the data.

Definition at line 84 of file vtkImageExport.h.

const char* vtkImageExport::GetDataScalarTypeAsString ( ) [inline]

Get the scalar type of the data. The scalar type of the C array must match the scalar type of the data.

Definition at line 88 of file vtkImageExport.h.

int* vtkImageExport::GetDataExtent ( ) [inline]

Get miscellaneous additional information about the data.

Definition at line 94 of file vtkImageExport.h.

void vtkImageExport::GetDataExtent ( int * ptr ) [inline]

Get miscellaneous additional information about the data.

Definition at line 99 of file vtkImageExport.h.

float* vtkImageExport::GetDataSpacing ( ) [inline]

Get miscellaneous additional information about the data.

Definition at line 104 of file vtkImageExport.h.

void vtkImageExport::GetDataSpacing ( float * ptr ) [inline]

Get miscellaneous additional information about the data.

Definition at line 109 of file vtkImageExport.h.

float* vtkImageExport::GetDataOrigin ( ) [inline]

Get miscellaneous additional information about the data.

Definition at line 113 of file vtkImageExport.h.

void vtkImageExport::GetDataOrigin ( float * ptr ) [inline]

Get miscellaneous additional information about the data.

Definition at line 118 of file vtkImageExport.h.

void vtkImageExport::SetInput ( vtkImageData * input )

Set/Get the input object from the image pipeline.

vtkImageData* vtkImageExport::GetInput ( )

Set/Get the input object from the image pipeline.

virtual void vtkImageExport::ImageLowerLeftOn ( ) [virtual]

Set/Get whether the data goes to the exported memory starting in the lower left corner or upper left corner. Default: On. When this flag is Off, the image will be flipped vertically before it is exported. WARNING: this flag is used only with the Export() method, it is ignored by GetPointerToData().

virtual void vtkImageExport::ImageLowerLeftOff ( ) [virtual]

Set/Get whether the data goes to the exported memory starting in the lower left corner or upper left corner. Default: On. When this flag is Off, the image will be flipped vertically before it is exported. WARNING: this flag is used only with the Export() method, it is ignored by GetPointerToData().

virtual int vtkImageExport::GetImageLowerLeft ( ) [virtual]

Set/Get whether the data goes to the exported memory starting in the lower left corner or upper left corner. Default: On. When this flag is Off, the image will be flipped vertically before it is exported. WARNING: this flag is used only with the Export() method, it is ignored by GetPointerToData().

virtual void vtkImageExport::SetImageLowerLeft ( int ) [virtual]

Set/Get whether the data goes to the exported memory starting in the lower left corner or upper left corner. Default: On. When this flag is Off, the image will be flipped vertically before it is exported. WARNING: this flag is used only with the Export() method, it is ignored by GetPointerToData().

void vtkImageExport::SetExportVoidPointer ( void * )

Set the void pointer of the C array to export the data to. From python, you can specify a pointer to a string that is large enough to hold the data.

void* vtkImageExport::GetExportVoidPointer ( ) [inline]

Set the void pointer of the C array to export the data to. From python, you can specify a pointer to a string that is large enough to hold the data.

Definition at line 146 of file vtkImageExport.h.

void vtkImageExport::Export ( ) [inline]

The main interface: update the pipeline and export the image to the memory pointed to by SetExportVoidPointer(). You can also specify a void pointer when you call Export().

Definition at line 153 of file vtkImageExport.h.

virtual void vtkImageExport::Export ( void * ) [virtual]

The main interface: update the pipeline and export the image to the memory pointed to by SetExportVoidPointer(). You can also specify a void pointer when you call Export().

void* vtkImageExport::GetPointerToData ( )

An alternative to Export(): Use with caution. Update the pipeline and return a pointer to the image memory. The pointer is only valid until the next time that the pipeline is updated. WARNING: This method ignores the ImageLowerLeft flag.

void* vtkImageExport::GetCallbackUserData ( )

Get the user data that should be passed to the callback functions.

UpdateInformationCallbackType vtkImageExport::GetUpdateInformationCallback ( ) const

Get pointers to the pipeline interface callbacks.

PipelineModifiedCallbackType vtkImageExport::GetPipelineModifiedCallback ( ) const

Get pointers to the pipeline interface callbacks.

WholeExtentCallbackType vtkImageExport::GetWholeExtentCallback ( ) const

Get pointers to the pipeline interface callbacks.

SpacingCallbackType vtkImageExport::GetSpacingCallback ( ) const

Get pointers to the pipeline interface callbacks.

OriginCallbackType vtkImageExport::GetOriginCallback ( ) const

Get pointers to the pipeline interface callbacks.

ScalarTypeCallbackType vtkImageExport::GetScalarTypeCallback ( ) const

Get pointers to the pipeline interface callbacks.

NumberOfComponentsCallbackType vtkImageExport::GetNumberOfComponentsCallback ( ) const

Get pointers to the pipeline interface callbacks.

PropagateUpdateExtentCallbackType vtkImageExport::GetPropagateUpdateExtentCallback ( ) const

Get pointers to the pipeline interface callbacks.

UpdateDataCallbackType vtkImageExport::GetUpdateDataCallback ( ) const

Get pointers to the pipeline interface callbacks.

DataExtentCallbackType vtkImageExport::GetDataExtentCallback ( ) const

Get pointers to the pipeline interface callbacks.

BufferPointerCallbackType vtkImageExport::GetBufferPointerCallback ( ) const

Get pointers to the pipeline interface callbacks.

virtual void vtkImageExport::UpdateInformationCallback ( ) [protected, virtual]

virtual int vtkImageExport::PipelineModifiedCallback ( ) [protected, virtual]

virtual void vtkImageExport::UpdateDataCallback ( ) [protected, virtual]

virtual int* vtkImageExport::WholeExtentCallback ( ) [protected, virtual]

virtual float* vtkImageExport::SpacingCallback ( ) [protected, virtual]

virtual float* vtkImageExport::OriginCallback ( ) [protected, virtual]

virtual const char* vtkImageExport::ScalarTypeCallback ( ) [protected, virtual]

virtual int vtkImageExport::NumberOfComponentsCallback ( ) [protected, virtual]

virtual void vtkImageExport::PropagateUpdateExtentCallback ( int * ) [protected, virtual]

virtual int* vtkImageExport::DataExtentCallback ( ) [protected, virtual]

virtual void* vtkImageExport::BufferPointerCallback ( ) [protected, virtual]

Member Data Documentation

int vtkImageExport::ImageLowerLeft [protected]

Definition at line 215 of file vtkImageExport.h.

int vtkImageExport::DataDimensions[3] [protected]

Definition at line 216 of file vtkImageExport.h.

void* vtkImageExport::ExportVoidPointer [protected]

Definition at line 217 of file vtkImageExport.h.

unsigned long vtkImageExport::LastPipelineMTime [protected]

Definition at line 219 of file vtkImageExport.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageExport.h
Generated on Mon Mar 25 01:18:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageExtractComponents Class Reference

Outputs a single component. More...

#include <vtkImageExtractComponents.h>

Inheritance diagram for vtkImageExtractComponents:

[legend]
Collaboration diagram for vtkImageExtractComponents:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageExtractComponents, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetComponents (int c1)
void | SetComponents (int c1, int c2)
void | SetComponents (int c1, int c2, int c3)
virtual int * | GetComponents ()
virtual void | GetComponents (int &, int &, int &)
virtual void | GetComponents (int[3])
virtual int | GetNumberOfComponents ()

Static Public Methods

vtkImageExtractComponents * | New ()

Protected Methods

vtkImageExtractComponents ()
~vtkImageExtractComponents ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

int | NumberOfComponents
int | Components [3]

Detailed Description

Outputs a single component.

Date:
2002/01/22 15:32:29
Revision:
1.26

vtkImageExtractComponents takes an input with any number of components and outputs some of them. It does involve a copy of the data.

See also:
vtkImageAppendComponents
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (47%)
  • Martin, Ken (39%)
Tests:
vtkImageExtractComponents (Tests)

Definition at line 45 of file vtkImageExtractComponents.h.

Constructor & Destructor Documentation

vtkImageExtractComponents::vtkImageExtractComponents ( ) [protected]

vtkImageExtractComponents::~vtkImageExtractComponents ( ) [inline, protected]

Definition at line 68 of file vtkImageExtractComponents.h.

Member Function Documentation

vtkImageExtractComponents* vtkImageExtractComponents::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageExtractComponents::vtkTypeRevisionMacro | ( | vtkImageExtractComponents | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageExtractComponents::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageExtractComponents::SetComponents ( int c1 )

Set/Get the components to extract.

void vtkImageExtractComponents::SetComponents | ( | int | c1,
 |  | int | c2
 | ) |

Set/Get the components to extract.

void vtkImageExtractComponents::SetComponents | ( | int | c1,
 |  | int | c2,
 |  | int | c3
 | ) |

Set/Get the components to extract.

virtual int* vtkImageExtractComponents::GetComponents ( ) [virtual]

Set/Get the components to extract.

virtual void vtkImageExtractComponents::GetComponents | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the components to extract.

virtual void vtkImageExtractComponents::GetComponents ( int [3] ) [virtual]

Set/Get the components to extract.

virtual int vtkImageExtractComponents::GetNumberOfComponents ( ) [virtual]

Get the number of components to extract. This is set implicitly by the SetComponents() method.

void vtkImageExtractComponents::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageExtractComponents::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 74 of file vtkImageExtractComponents.h.

void vtkImageExtractComponents::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageExtractComponents::NumberOfComponents [protected]

Definition at line 70 of file vtkImageExtractComponents.h.

int vtkImageExtractComponents::Components[3] [protected]

Definition at line 71 of file vtkImageExtractComponents.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageExtractComponents.h
Generated on Mon Mar 25 01:18:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFFT Class Reference

Fast Fourier Transform. More...

#include <vtkImageFFT.h>

Inheritance diagram for vtkImageFFT:

[legend]
Collaboration diagram for vtkImageFFT:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageFFT, vtkImageFourierFilter)
virtual void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)
int | SplitExtent (int splitExt[6], int startExt[6], int num, int total)

Static Public Methods

vtkImageFFT * | New ()

Protected Methods

vtkImageFFT ()
~vtkImageFFT ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId)

Detailed Description

Fast Fourier Transform.

Date:
2002/01/22 15:32:31
Revision:
1.33

vtkImageFFT implements a fast Fourier transform. The input can have real or complex data in any components and data types, but the output is always complex floats with real values in component0, and imaginary values in component1. The filter is fastest for images that have power of two sizes. The filter uses a butterfly fitlers for each prime factor of the dimension. This makes images with prime number dimensions (i.e. 17x17) much slower to compute. Multi dimensional (i.e volumes) FFT's are decomposed so that each axis executes in series.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (87%)
  • Martin, Ken (6%)
Tests:
vtkImageFFT (Tests)

Definition at line 48 of file vtkImageFFT.h.

Constructor & Destructor Documentation

vtkImageFFT::vtkImageFFT ( ) [inline, protected]

Definition at line 71 of file vtkImageFFT.h.

vtkImageFFT::~vtkImageFFT ( ) [inline, protected]

Definition at line 72 of file vtkImageFFT.h.

Member Function Documentation

vtkImageFFT* vtkImageFFT::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageFFT::vtkTypeRevisionMacro | ( | vtkImageFFT | ,
 |  | vtkImageFourierFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageFourierFilter.

int vtkImageFFT::SplitExtent | ( | int | splitExt[6],
 |  | int | startExt[6],
 |  | int | num,
 |  | int | total
 | ) | [virtual]

Used internally for streaming and threads. Splits output update extent into num pieces. This method needs to be called num times. Results must not overlap for consistent starting extent. Subclass can override this method. This method returns the number of pieces resulting from a successful split. This can be from 1 to "total". If 1 is returned, the extent cannot be split.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageFFT::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [inline, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 66 of file vtkImageFFT.h.

void vtkImageFFT::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageFFT::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageFFT::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 76 of file vtkImageFFT.h.

void vtkImageFFT::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | threadId
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageFFT.h
Generated on Mon Mar 25 01:18:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFlip Class Reference

This flips an axis of an image. Right becomes left ... More...

#include <vtkImageFlip.h>

Inheritance diagram for vtkImageFlip:

[legend]
Collaboration diagram for vtkImageFlip:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageFlip, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetFilteredAxes (int axis)
virtual void | SetFilteredAxis (int)
virtual int | GetFilteredAxis ()
virtual void | SetPreserveImageExtent (int)
virtual int | GetPreserveImageExtent ()
virtual void | PreserveImageExtentOn ()
virtual void | PreserveImageExtentOff ()

Static Public Methods

vtkImageFlip * | New ()

Protected Methods

vtkImageFlip ()
~vtkImageFlip ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

int | FilteredAxis
int | PreserveImageExtent

Detailed Description

This flips an axis of an image. Right becomes left ...

Date:
2002/01/22 15:32:32
Revision:
1.32

vtkImageFlip will reflect the data along the filtered axis. If PreserveImageExtent is "On", then the image is shifted so that it has the same image extent, and the origin is shifted appropriately. When PreserveImageExtent is "off", The Origin is not changed, min and max of extent (of filtered axis) are negated, and are swapped. The default preserves the extent of the input.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (86%)
  • Martin, Ken (5%)
Tests:
vtkImageFlip (Tests)

Definition at line 46 of file vtkImageFlip.h.

Constructor & Destructor Documentation

vtkImageFlip::vtkImageFlip ( ) [protected]

vtkImageFlip::~vtkImageFlip ( ) [inline, protected]

Definition at line 75 of file vtkImageFlip.h.

Member Function Documentation

vtkImageFlip* vtkImageFlip::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageFlip::vtkTypeRevisionMacro | ( | vtkImageFlip | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageFlip::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageFlip::SetFilteredAxis ( int ) [virtual]

Specify which axes will be flipped.

virtual int vtkImageFlip::GetFilteredAxis ( ) [virtual]

Specify which axes will be flipped.

void vtkImageFlip::SetFilteredAxes ( int axis ) [inline]

Specify which axes will be flipped. For compatibility with old scripts

Definition at line 62 of file vtkImageFlip.h.

virtual void vtkImageFlip::SetPreserveImageExtent ( int ) [virtual]

If PreseveImageExtent is off, then extent of axis0 is simply multiplied by -1. If it is on, then the new image min (-imageMax0) is shifted to old image min (imageMin0).

virtual int vtkImageFlip::GetPreserveImageExtent ( ) [virtual]

If PreseveImageExtent is off, then extent of axis0 is simply multiplied by -1. If it is on, then the new image min (-imageMax0) is shifted to old image min (imageMin0).

virtual void vtkImageFlip::PreserveImageExtentOn ( ) [virtual]

If PreseveImageExtent is off, then extent of axis0 is simply multiplied by -1. If it is on, then the new image min (-imageMax0) is shifted to old image min (imageMin0).

virtual void vtkImageFlip::PreserveImageExtentOff ( ) [virtual]

If PreseveImageExtent is off, then extent of axis0 is simply multiplied by -1. If it is on, then the new image min (-imageMax0) is shifted to old image min (imageMin0).

void vtkImageFlip::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageFlip::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageFlip::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 82 of file vtkImageFlip.h.

void vtkImageFlip::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageFlip::FilteredAxis [protected]

Definition at line 77 of file vtkImageFlip.h.

int vtkImageFlip::PreserveImageExtent [protected]

Definition at line 78 of file vtkImageFlip.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageFlip.h
Generated on Mon Mar 25 01:18:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFourierCenter Class Reference

Shifts constant frequency to center for. More...

#include <vtkImageFourierCenter.h>

Inheritance diagram for vtkImageFourierCenter:

[legend]
Collaboration diagram for vtkImageFourierCenter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageFourierCenter, vtkImageDecomposeFilter)
virtual void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)

Static Public Methods

vtkImageFourierCenter * | New ()

Protected Methods

vtkImageFourierCenter ()
~vtkImageFourierCenter ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId)

Detailed Description

Shifts constant frequency to center for.

Date:
2002/01/22 15:32:33
Revision:
1.24
display.

Is used for dispaying images in frequency space. FFT converts spatial images into frequency space, but puts the zero frequency at the origin. This filter shifts the zero frequency to the center of the image. Input and output are assumed to be floats.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (90%)
  • Martin, Ken (5%)
Tests:
vtkImageFourierCenter (Tests)

Definition at line 45 of file vtkImageFourierCenter.h.

Constructor & Destructor Documentation

vtkImageFourierCenter::vtkImageFourierCenter ( ) [protected]

vtkImageFourierCenter::~vtkImageFourierCenter ( ) [inline, protected]

Definition at line 59 of file vtkImageFourierCenter.h.

Member Function Documentation

vtkImageFourierCenter* vtkImageFourierCenter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageFourierCenter::vtkTypeRevisionMacro | ( | vtkImageFourierCenter | ,
 |  | vtkImageDecomposeFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

virtual void vtkImageFourierCenter::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [inline, virtual]

This is an internal method that should not be called by the user.

Reimplemented from vtkImageIterateFilter.

Definition at line 53 of file vtkImageFourierCenter.h.

void vtkImageFourierCenter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageFourierCenter::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | threadId
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageFourierCenter.h
Generated on Mon Mar 25 01:18:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageFourierFilter Class Reference

Superclass that implements complex numbers. More...

#include <vtkImageFourierFilter.h>

Inheritance diagram for vtkImageFourierFilter:

[legend]
Collaboration diagram for vtkImageFourierFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageFourierFilter, vtkImageDecomposeFilter)
void | ExecuteFft (vtkImageComplex *in, vtkImageComplex *out, int N)
void | ExecuteRfft (vtkImageComplex *in, vtkImageComplex *out, int N)

Protected Methods

vtkImageFourierFilter ()
~vtkImageFourierFilter ()
void | ExecuteFftStep2 (vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int fb)
void | ExecuteFftStepN (vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int n, int fb)
void | ExecuteFftForwardBackward (vtkImageComplex *in, vtkImageComplex *out, int N, int fb)

Detailed Description

Superclass that implements complex numbers.

Date:
2002/01/22 15:32:35
Revision:
1.32

vtkImageFourierFilter is a class of filters that use complex numbers this superclass is a container for methods that manipulate these structure including fast Fourier transforms. Complex numbers may become a class. This should really be a helper class.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Martin, Ken (11%)

Definition at line 100 of file vtkImageFourierFilter.h.

Constructor & Destructor Documentation

vtkImageFourierFilter::vtkImageFourierFilter ( ) [inline, protected]

Definition at line 121 of file vtkImageFourierFilter.h.

vtkImageFourierFilter::~vtkImageFourierFilter ( ) [inline, protected]

Definition at line 122 of file vtkImageFourierFilter.h.

Member Function Documentation

vtkImageFourierFilter::vtkTypeRevisionMacro | ( | vtkImageFourierFilter | ,
 |  | vtkImageDecomposeFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

Reimplemented in vtkImageFFT, and vtkImageRFFT.

void vtkImageFourierFilter::ExecuteFft | ( | vtkImageComplex * | in,
 |  | vtkImageComplex * | out,
 |  | int | N
 | ) |

This function calculates the whole fft of an array. The contents of the input array are changed. (It is engineered for no decimation)

void vtkImageFourierFilter::ExecuteRfft | ( | vtkImageComplex * | in,
 |  | vtkImageComplex * | out,
 |  | int | N
 | ) |

This function calculates the whole fft of an array. The contents of the input array are changed. (It is engineered for no decimation)

void vtkImageFourierFilter::ExecuteFftStep2 | ( | vtkImageComplex * | p_in,
 |  | vtkImageComplex * | p_out,
 |  | int | N,
 |  | int | bsize,
 |  | int | fb
 | ) | [protected]

void vtkImageFourierFilter::ExecuteFftStepN | ( | vtkImageComplex * | p_in,
 |  | vtkImageComplex * | p_out,
 |  | int | N,
 |  | int | bsize,
 |  | int | n,
 |  | int | fb
 | ) | [protected]

void vtkImageFourierFilter::ExecuteFftForwardBackward | ( | vtkImageComplex * | in,
 |  | vtkImageComplex * | out,
 |  | int | N,
 |  | int | fb
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Imaging/vtkImageFourierFilter.h
Generated on Mon Mar 25 01:18:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGaussianSmooth Class Reference

Performs a gaussian convolution. More...

#include <vtkImageGaussianSmooth.h>

Inheritance diagram for vtkImageGaussianSmooth:

[legend]
Collaboration diagram for vtkImageGaussianSmooth:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageGaussianSmooth, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetStandardDeviations (float, float, float)
virtual void | SetStandardDeviations (float[3])
void | SetStandardDeviation (float std)
void | SetStandardDeviations (float a, float b)
virtual float * | GetStandardDeviations ()
virtual void | GetStandardDeviations (float &, float &, float &)
virtual void | GetStandardDeviations (float[3])
void | SetStandardDeviation (float a, float b)
void | SetStandardDeviation (float a, float b, float c)
virtual void | SetRadiusFactors (float, float, float)
virtual void | SetRadiusFactors (float[3])
void | SetRadiusFactors (float f, float f2)
void | SetRadiusFactor (float f)
virtual float * | GetRadiusFactors ()
virtual void | GetRadiusFactors (float &, float &, float &)
virtual void | GetRadiusFactors (float[3])
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageGaussianSmooth * | New ()

Protected Methods

vtkImageGaussianSmooth ()
~vtkImageGaussianSmooth ()
void | ComputeKernel (double *kernel, int min, int max, double std)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteAxis (int axis, vtkImageData *inData, int inExt[6], vtkImageData *outData, int outExt[6], int *pcycle, int target, int *pcount, int total)
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

int | Dimensionality
float | StandardDeviations [3]
float | RadiusFactors [3]

Detailed Description

Performs a gaussian convolution.

Date:
2002/01/22 15:32:36
Revision:
1.37

vtkImageGaussianSmooth implements a convolution of the input image with a gaussian. Supports from one to three dimensional convolutions.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (87%)
Tests:
vtkImageGaussianSmooth (Tests)

Definition at line 41 of file vtkImageGaussianSmooth.h.

Constructor & Destructor Documentation

vtkImageGaussianSmooth::vtkImageGaussianSmooth ( ) [protected]

vtkImageGaussianSmooth::~vtkImageGaussianSmooth ( ) [protected]

Member Function Documentation

vtkImageGaussianSmooth::vtkTypeRevisionMacro | ( | vtkImageGaussianSmooth | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageGaussianSmooth::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

vtkImageGaussianSmooth* vtkImageGaussianSmooth::New ( ) [static]

Creates an instance of vtkImageGaussianSmmoth with the following defaults: Dimensioonality 3, StandardDeviations( 2, 2, 2), Radius Factors ( 1.5, 1.5, 1.5)

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageGaussianSmooth::SetStandardDeviations | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Sets/Gets the Standard deviation of the gaussian in pixel units.

virtual void vtkImageGaussianSmooth::SetStandardDeviations ( float [3] ) [virtual]

Sets/Gets the Standard deviation of the gaussian in pixel units.

void vtkImageGaussianSmooth::SetStandardDeviation ( float std ) [inline]

Sets/Gets the Standard deviation of the gaussian in pixel units.

Definition at line 56 of file vtkImageGaussianSmooth.h.

void vtkImageGaussianSmooth::SetStandardDeviations | ( | float | a,
 |  | float | b
 | ) | [inline]

Sets/Gets the Standard deviation of the gaussian in pixel units.

Definition at line 58 of file vtkImageGaussianSmooth.h.

virtual float* vtkImageGaussianSmooth::GetStandardDeviations ( ) [virtual]

Sets/Gets the Standard deviation of the gaussian in pixel units.

virtual void vtkImageGaussianSmooth::GetStandardDeviations | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Sets/Gets the Standard deviation of the gaussian in pixel units.

virtual void vtkImageGaussianSmooth::GetStandardDeviations ( float [3] ) [virtual]

Sets/Gets the Standard deviation of the gaussian in pixel units.

void vtkImageGaussianSmooth::SetStandardDeviation | ( | float | a,
 |  | float | b
 | ) | [inline]

Sets/Gets the Standard deviation of the gaussian in pixel units. These methods are provided for compatibility with old scripts

Definition at line 66 of file vtkImageGaussianSmooth.h.

void vtkImageGaussianSmooth::SetStandardDeviation | ( | float | a,
 |  | float | b,
 |  | float | c
 | ) | [inline]

Sets/Gets the Standard deviation of the gaussian in pixel units. These methods are provided for compatibility with old scripts

Definition at line 68 of file vtkImageGaussianSmooth.h.

virtual void vtkImageGaussianSmooth::SetRadiusFactors | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

virtual void vtkImageGaussianSmooth::SetRadiusFactors ( float [3] ) [virtual]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

void vtkImageGaussianSmooth::SetRadiusFactors | ( | float | f,
 |  | float | f2
 | ) | [inline]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

Definition at line 77 of file vtkImageGaussianSmooth.h.

void vtkImageGaussianSmooth::SetRadiusFactor ( float f ) [inline]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

Definition at line 78 of file vtkImageGaussianSmooth.h.

virtual float* vtkImageGaussianSmooth::GetRadiusFactors ( ) [virtual]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

virtual void vtkImageGaussianSmooth::GetRadiusFactors | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

virtual void vtkImageGaussianSmooth::GetRadiusFactors ( float [3] ) [virtual]

Sets/Gets the Radius Factors of the gaussian in pixel units. The radius factors determine how far out the gaussian kernel will go before being clamped to zero.

virtual void vtkImageGaussianSmooth::SetDimensionality ( int ) [virtual]

Set/Get the dimensionality of this filter. This determines whether a one, two, or three dimensional gaussian is performed.

virtual int vtkImageGaussianSmooth::GetDimensionality ( ) [virtual]

Set/Get the dimensionality of this filter. This determines whether a one, two, or three dimensional gaussian is performed.

void vtkImageGaussianSmooth::ComputeKernel | ( | double * | kernel,
 |  | int | min,
 |  | int | max,
 |  | double | std
 | ) | [protected]

void vtkImageGaussianSmooth::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageGaussianSmooth::ExecuteAxis | ( | int | axis,
 |  | vtkImageData * | inData,
 |  | int | inExt[6],
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int * | pcycle,
 |  | int | target,
 |  | int * | pcount,
 |  | int | total
 | ) | [protected]

void vtkImageGaussianSmooth::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageGaussianSmooth::Dimensionality [protected]

Definition at line 93 of file vtkImageGaussianSmooth.h.

float vtkImageGaussianSmooth::StandardDeviations[3] [protected]

Definition at line 94 of file vtkImageGaussianSmooth.h.

float vtkImageGaussianSmooth::RadiusFactors[3] [protected]

Definition at line 95 of file vtkImageGaussianSmooth.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageGaussianSmooth.h
Generated on Mon Mar 25 01:18:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGaussianSource Class Reference

Create an image with Gaussian pixel values. More...

#include <vtkImageGaussianSource.h>

Inheritance diagram for vtkImageGaussianSource:

[legend]
Collaboration diagram for vtkImageGaussianSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageGaussianSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetWholeExtent (int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float &, float &, float &)
virtual void | GetCenter (float[3])
virtual void | SetMaximum (float)
virtual float | GetMaximum ()
virtual void | SetStandardDeviation (float)
virtual float | GetStandardDeviation ()

Static Public Methods

vtkImageGaussianSource * | New ()

Protected Methods

vtkImageGaussianSource ()
~vtkImageGaussianSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)

Protected Attributes

float | StandardDeviation
int | WholeExtent [6]
float | Center [3]
float | Maximum

Detailed Description

Create an image with Gaussian pixel values.

Date:
2002/01/22 15:32:37
Revision:
1.25

vtkImageGaussianSource just produces images with pixel values determined by a Gaussian.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (56%)
  • Martin, Ken (36%)
  • Avila, Lisa (5%)
Tests:
vtkImageGaussianSource (Tests)

Definition at line 42 of file vtkImageGaussianSource.h.

Constructor & Destructor Documentation

vtkImageGaussianSource::vtkImageGaussianSource ( ) [protected]

vtkImageGaussianSource::~vtkImageGaussianSource ( ) [inline, protected]

Definition at line 75 of file vtkImageGaussianSource.h.

Member Function Documentation

vtkImageGaussianSource* vtkImageGaussianSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageGaussianSource::vtkTypeRevisionMacro | ( | vtkImageGaussianSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageGaussianSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageGaussianSource::SetWholeExtent | ( | int | xMinx,
 |  | int | xMax,
 |  | int | yMin,
 |  | int | yMax,
 |  | int | zMin,
 |  | int | zMax
 | ) |

Set/Get the extent of the whole output image.

virtual void vtkImageGaussianSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the center of the Gaussian.

virtual void vtkImageGaussianSource::SetCenter ( float [3] ) [virtual]

Set/Get the center of the Gaussian.

virtual float* vtkImageGaussianSource::GetCenter ( ) [virtual]

Set/Get the center of the Gaussian.

virtual void vtkImageGaussianSource::GetCenter | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the center of the Gaussian.

virtual void vtkImageGaussianSource::GetCenter ( float [3] ) [virtual]

Set/Get the center of the Gaussian.

virtual void vtkImageGaussianSource::SetMaximum ( float ) [virtual]

Set/Get the Maximum value of the gaussian

virtual float vtkImageGaussianSource::GetMaximum ( ) [virtual]

Set/Get the Maximum value of the gaussian

virtual void vtkImageGaussianSource::SetStandardDeviation ( float ) [virtual]

Set/Get the standard deviation of the gaussian

virtual float vtkImageGaussianSource::GetStandardDeviation ( ) [virtual]

Set/Get the standard deviation of the gaussian

virtual void vtkImageGaussianSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkImageGaussianSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

Member Data Documentation

float vtkImageGaussianSource::StandardDeviation [protected]

Definition at line 77 of file vtkImageGaussianSource.h.

int vtkImageGaussianSource::WholeExtent[6] [protected]

Definition at line 78 of file vtkImageGaussianSource.h.

float vtkImageGaussianSource::Center[3] [protected]

Definition at line 79 of file vtkImageGaussianSource.h.

float vtkImageGaussianSource::Maximum [protected]

Definition at line 80 of file vtkImageGaussianSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageGaussianSource.h
Generated on Mon Mar 25 01:18:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGradient Class Reference

Computes the gradient vector. More...

#include <vtkImageGradient.h>

Inheritance diagram for vtkImageGradient:

[legend]
Collaboration diagram for vtkImageGradient:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageGradient, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()
virtual void | SetHandleBoundaries (int)
virtual int | GetHandleBoundaries ()
virtual void | HandleBoundariesOn ()
virtual void | HandleBoundariesOff ()

Static Public Methods

vtkImageGradient * | New ()

Protected Methods

vtkImageGradient ()
~vtkImageGradient ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | HandleBoundaries
int | Dimensionality

Detailed Description

Computes the gradient vector.

Date:
2002/01/22 15:32:38
Revision:
1.34

vtkImageGradient computes the gradient vector of an image. The vector results are stored as scalar components. The Dimensionality determines whether to perform a 2d or 3d gradient. The default is two dimensional XY gradient. OutputScalarType is always float. Gradient is computed using central differences.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (72%)
  • Martin, Ken (21%)
Examples:
vtkImageGradient (Examples)
Tests:
vtkImageGradient (Tests)

Definition at line 48 of file vtkImageGradient.h.

Constructor & Destructor Documentation

vtkImageGradient::vtkImageGradient ( ) [protected]

vtkImageGradient::~vtkImageGradient ( ) [inline, protected]

Definition at line 71 of file vtkImageGradient.h.

Member Function Documentation

vtkImageGradient* vtkImageGradient::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageGradient::vtkTypeRevisionMacro | ( | vtkImageGradient | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageGradient::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageGradient::SetDimensionality ( int ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

virtual int vtkImageGradient::GetDimensionality ( ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

virtual void vtkImageGradient::SetHandleBoundaries ( int ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual int vtkImageGradient::GetHandleBoundaries ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageGradient::HandleBoundariesOn ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageGradient::HandleBoundariesOff ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

void vtkImageGradient::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageGradient::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageGradient::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 78 of file vtkImageGradient.h.

void vtkImageGradient::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageGradient::HandleBoundaries [protected]

Definition at line 73 of file vtkImageGradient.h.

int vtkImageGradient::Dimensionality [protected]

Definition at line 74 of file vtkImageGradient.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageGradient.h
Generated on Mon Mar 25 01:18:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGradientMagnitude Class Reference

Computes magnitude of the gradient. More...

#include <vtkImageGradientMagnitude.h>

Inheritance diagram for vtkImageGradientMagnitude:

[legend]
Collaboration diagram for vtkImageGradientMagnitude:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageGradientMagnitude, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetHandleBoundaries (int)
virtual int | GetHandleBoundaries ()
virtual void | HandleBoundariesOn ()
virtual void | HandleBoundariesOff ()
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageGradientMagnitude * | New ()

Protected Methods

vtkImageGradientMagnitude ()
~vtkImageGradientMagnitude ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | HandleBoundaries
int | Dimensionality

Detailed Description

Computes magnitude of the gradient.

Date:
2002/03/04 16:59:54
Revision:
1.33

vtkImageGradientMagnitude computes the gradient magnitude of an image. Setting the dimensionality determines whether the gradient is computed on 2D images, or 3D volumes. The default is two dimensional XY images.

See also:
vtkImageGradient vtkImageMagnitude
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (61%)
  • Martin, Ken (30%)
Examples:
vtkImageGradientMagnitude (Examples)
Tests:
vtkImageGradientMagnitude (Tests)

Definition at line 50 of file vtkImageGradientMagnitude.h.

Constructor & Destructor Documentation

vtkImageGradientMagnitude::vtkImageGradientMagnitude ( ) [protected]

vtkImageGradientMagnitude::~vtkImageGradientMagnitude ( ) [inline, protected]

Definition at line 73 of file vtkImageGradientMagnitude.h.

Member Function Documentation

vtkImageGradientMagnitude* vtkImageGradientMagnitude::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageGradientMagnitude::vtkTypeRevisionMacro | ( | vtkImageGradientMagnitude | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageGradientMagnitude::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageGradientMagnitude::SetHandleBoundaries ( int ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual int vtkImageGradientMagnitude::GetHandleBoundaries ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageGradientMagnitude::HandleBoundariesOn ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageGradientMagnitude::HandleBoundariesOff ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageGradientMagnitude::SetDimensionality ( int ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

virtual int vtkImageGradientMagnitude::GetDimensionality ( ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

void vtkImageGradientMagnitude::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageGradientMagnitude::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageGradientMagnitude::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 80 of file vtkImageGradientMagnitude.h.

void vtkImageGradientMagnitude::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageGradientMagnitude::HandleBoundaries [protected]

Definition at line 75 of file vtkImageGradientMagnitude.h.

int vtkImageGradientMagnitude::Dimensionality [protected]

Definition at line 76 of file vtkImageGradientMagnitude.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageGradientMagnitude.h
Generated on Mon Mar 25 01:18:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageGridSource Class Reference

Create an image of a grid. More...

#include <vtkImageGridSource.h>

Inheritance diagram for vtkImageGridSource:

[legend]
Collaboration diagram for vtkImageGridSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageGridSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetGridSpacing (int, int, int)
virtual void | SetGridSpacing (int[3])
virtual int * | GetGridSpacing ()
virtual void | GetGridSpacing (int &, int &, int &)
virtual void | GetGridSpacing (int[3])
virtual void | SetGridOrigin (int, int, int)
virtual void | SetGridOrigin (int[3])
virtual int * | GetGridOrigin ()
virtual void | GetGridOrigin (int &, int &, int &)
virtual void | GetGridOrigin (int[3])
virtual void | SetLineValue (float)
virtual float | GetLineValue ()
virtual void | SetFillValue (float)
virtual float | GetFillValue ()
virtual void | SetDataScalarType (int)
void | SetDataScalarTypeToFloat ()
void | SetDataScalarTypeToInt ()
void | SetDataScalarTypeToShort ()
void | SetDataScalarTypeToUnsignedShort ()
void | SetDataScalarTypeToUnsignedChar ()
virtual int | GetDataScalarType ()
const char * | GetDataScalarTypeAsString ()
virtual void | SetDataExtent (int, int, int, int, int, int)
virtual void | SetDataExtent (int[6])
virtual int * | GetDataExtent ()
virtual void | GetDataExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetDataExtent (int[6])
virtual void | SetDataSpacing (float, float, float)
virtual void | SetDataSpacing (float[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float &, float &, float &)
virtual void | GetDataSpacing (float[3])
virtual void | SetDataOrigin (float, float, float)
virtual void | SetDataOrigin (float[3])
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float &, float &, float &)
virtual void | GetDataOrigin (float[3])

Static Public Methods

vtkImageGridSource * | New ()

Protected Methods

vtkImageGridSource ()
~vtkImageGridSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)

Protected Attributes

int | GridSpacing [3]
int | GridOrigin [3]
float | LineValue
float | FillValue
int | DataScalarType
int | DataExtent [6]
float | DataSpacing [3]
float | DataOrigin [3]

Detailed Description

Create an image of a grid.

Date:
2002/01/22 15:32:41
Revision:
1.10

vtkImageGridSource produces an image of a grid. The default output type is float.

Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (93%)
  • Martin, Ken (5%)
Tests:
vtkImageGridSource (Tests)

Definition at line 41 of file vtkImageGridSource.h.

Constructor & Destructor Documentation

vtkImageGridSource::vtkImageGridSource ( ) [protected]

vtkImageGridSource::~vtkImageGridSource ( ) [inline, protected]

Definition at line 110 of file vtkImageGridSource.h.

Member Function Documentation

vtkImageGridSource* vtkImageGridSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageGridSource::vtkTypeRevisionMacro | ( | vtkImageGridSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageGridSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkImageGridSource::SetGridSpacing | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the grid spacing in pixel units. Default (10,10,0). A value of zero means no grid.

virtual void vtkImageGridSource::SetGridSpacing ( int [3] ) [virtual]

Set/Get the grid spacing in pixel units. Default (10,10,0). A value of zero means no grid.

virtual int* vtkImageGridSource::GetGridSpacing ( ) [virtual]

Set/Get the grid spacing in pixel units. Default (10,10,0). A value of zero means no grid.

virtual void vtkImageGridSource::GetGridSpacing | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the grid spacing in pixel units. Default (10,10,0). A value of zero means no grid.

virtual void vtkImageGridSource::GetGridSpacing ( int [3] ) [virtual]

Set/Get the grid spacing in pixel units. Default (10,10,0). A value of zero means no grid.

virtual void vtkImageGridSource::SetGridOrigin | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the grid origin, in ijk integer values. Default (0,0,0).

virtual void vtkImageGridSource::SetGridOrigin ( int [3] ) [virtual]

Set/Get the grid origin, in ijk integer values. Default (0,0,0).

virtual int* vtkImageGridSource::GetGridOrigin ( ) [virtual]

Set/Get the grid origin, in ijk integer values. Default (0,0,0).

virtual void vtkImageGridSource::GetGridOrigin | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the grid origin, in ijk integer values. Default (0,0,0).

virtual void vtkImageGridSource::GetGridOrigin ( int [3] ) [virtual]

Set/Get the grid origin, in ijk integer values. Default (0,0,0).

virtual void vtkImageGridSource::SetLineValue ( float ) [virtual]

Set the grey level of the lines. Default 1.0.

virtual float vtkImageGridSource::GetLineValue ( ) [virtual]

Set the grey level of the lines. Default 1.0.

virtual void vtkImageGridSource::SetFillValue ( float ) [virtual]

Set the grey level of the fill. Default 0.0.

virtual float vtkImageGridSource::GetFillValue ( ) [virtual]

Set the grey level of the fill. Default 0.0.

virtual void vtkImageGridSource::SetDataScalarType ( int ) [virtual]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

void vtkImageGridSource::SetDataScalarTypeToFloat ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 77 of file vtkImageGridSource.h.

void vtkImageGridSource::SetDataScalarTypeToInt ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 78 of file vtkImageGridSource.h.

void vtkImageGridSource::SetDataScalarTypeToShort ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 79 of file vtkImageGridSource.h.

void vtkImageGridSource::SetDataScalarTypeToUnsignedShort ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 80 of file vtkImageGridSource.h.

void vtkImageGridSource::SetDataScalarTypeToUnsignedChar ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 82 of file vtkImageGridSource.h.

virtual int vtkImageGridSource::GetDataScalarType ( ) [virtual]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

const char* vtkImageGridSource::GetDataScalarTypeAsString ( ) [inline]

Set/Get the data type of pixels in the imported data. As a convenience, the OutputScalarType is set to the same value.

Definition at line 85 of file vtkImageGridSource.h.

virtual void vtkImageGridSource::SetDataExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the extent of the whole output image, Default: (0,255,0,255,0,0)

virtual void vtkImageGridSource::SetDataExtent ( int [6] ) [virtual]

Set/Get the extent of the whole output image, Default: (0,255,0,255,0,0)

virtual int* vtkImageGridSource::GetDataExtent ( ) [virtual]

Set/Get the extent of the whole output image, Default: (0,255,0,255,0,0)

virtual void vtkImageGridSource::GetDataExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the extent of the whole output image, Default: (0,255,0,255,0,0)

virtual void vtkImageGridSource::GetDataExtent ( int [6] ) [virtual]

Set/Get the extent of the whole output image, Default: (0,255,0,255,0,0)

virtual void vtkImageGridSource::SetDataSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the pixel spacing.

virtual void vtkImageGridSource::SetDataSpacing ( float [3] ) [virtual]

Set/Get the pixel spacing.

virtual float* vtkImageGridSource::GetDataSpacing ( ) [virtual]

Set/Get the pixel spacing.

virtual void vtkImageGridSource::GetDataSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the pixel spacing.

virtual void vtkImageGridSource::GetDataSpacing ( float [3] ) [virtual]

Set/Get the pixel spacing.

virtual void vtkImageGridSource::SetDataOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the origin of the data.

virtual void vtkImageGridSource::SetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data.

virtual float* vtkImageGridSource::GetDataOrigin ( ) [virtual]

Set/Get the origin of the data.

virtual void vtkImageGridSource::GetDataOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the origin of the data.

virtual void vtkImageGridSource::GetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data.

virtual void vtkImageGridSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkImageGridSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

Member Data Documentation

int vtkImageGridSource::GridSpacing[3] [protected]

Definition at line 112 of file vtkImageGridSource.h.

int vtkImageGridSource::GridOrigin[3] [protected]

Definition at line 113 of file vtkImageGridSource.h.

float vtkImageGridSource::LineValue [protected]

Definition at line 115 of file vtkImageGridSource.h.

float vtkImageGridSource::FillValue [protected]

Definition at line 116 of file vtkImageGridSource.h.

int vtkImageGridSource::DataScalarType [protected]

Definition at line 118 of file vtkImageGridSource.h.

int vtkImageGridSource::DataExtent[6] [protected]

Definition at line 120 of file vtkImageGridSource.h.

float vtkImageGridSource::DataSpacing[3] [protected]

Definition at line 121 of file vtkImageGridSource.h.

float vtkImageGridSource::DataOrigin[3] [protected]

Definition at line 122 of file vtkImageGridSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageGridSource.h
Generated on Mon Mar 25 01:18:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageHSVToRGB Class Reference

Converts HSV components to RGB. More...

#include <vtkImageHSVToRGB.h>

Inheritance diagram for vtkImageHSVToRGB:

[legend]
Collaboration diagram for vtkImageHSVToRGB:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageHSVToRGB, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMaximum (float)
virtual float | GetMaximum ()

Static Public Methods

vtkImageHSVToRGB * | New ()

Protected Methods

vtkImageHSVToRGB ()
~vtkImageHSVToRGB ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

float | Maximum

Detailed Description

Converts HSV components to RGB.

Date:
2002/01/22 15:32:42
Revision:
1.21

For each pixel with hue, saturation and value components this filter outputs the color coded as red, green, blue. Output type must be the same as input type.

See also:
vtkImageRGBToHSV
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (51%)
  • Martin, Ken (34%)
Tests:
vtkImageHSVToRGB (Tests)

Definition at line 46 of file vtkImageHSVToRGB.h.

Constructor & Destructor Documentation

vtkImageHSVToRGB::vtkImageHSVToRGB ( ) [protected]

vtkImageHSVToRGB::~vtkImageHSVToRGB ( ) [inline, protected]

Definition at line 65 of file vtkImageHSVToRGB.h.

Member Function Documentation

vtkImageHSVToRGB* vtkImageHSVToRGB::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageHSVToRGB::vtkTypeRevisionMacro | ( | vtkImageHSVToRGB | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageHSVToRGB::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageHSVToRGB::SetMaximum ( float ) [virtual]

Hue is an angle. Maximum specifies when it maps back to 0. HueMaximum defaults to 255 instead of 2PI, because unsigned char is expected as input. Maximum also specifies the maximum of the Saturation, and R, G, B.

virtual float vtkImageHSVToRGB::GetMaximum ( ) [virtual]

Hue is an angle. Maximum specifies when it maps back to 0. HueMaximum defaults to 255 instead of 2PI, because unsigned char is expected as input. Maximum also specifies the maximum of the Saturation, and R, G, B.

void vtkImageHSVToRGB::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageHSVToRGB::Maximum [protected]

Definition at line 67 of file vtkImageHSVToRGB.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageHSVToRGB.h
Generated on Mon Mar 25 01:18:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageHybridMedian2D Class Reference

Median filter that preserves lines and. More...

#include <vtkImageHybridMedian2D.h>

Inheritance diagram for vtkImageHybridMedian2D:

[legend]
Collaboration diagram for vtkImageHybridMedian2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageHybridMedian2D, vtkImageSpatialFilter)

Static Public Methods

vtkImageHybridMedian2D * | New ()

Protected Methods

vtkImageHybridMedian2D ()
~vtkImageHybridMedian2D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)
float | ComputeMedian (float *array, int size)

Detailed Description

Median filter that preserves lines and.

Date:
2002/01/22 15:32:43
Revision:
1.18
corners.

vtkImageHybridMedian2D is a median filter that preserves thin lines and corners. It operates on a 5x5 pixel neighborhood. It computes two values initially: the median of the + neighbors and the median of the x neighbors. It the computes the median of these two values plus the center pixel. This result of this second median is the output pixel value.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (89%)
  • Martin, Ken (9%)
Tests:
vtkImageHybridMedian2D (Tests)

Definition at line 46 of file vtkImageHybridMedian2D.h.

Constructor & Destructor Documentation

vtkImageHybridMedian2D::vtkImageHybridMedian2D ( ) [protected]

vtkImageHybridMedian2D::~vtkImageHybridMedian2D ( ) [inline, protected]

Definition at line 54 of file vtkImageHybridMedian2D.h.

Member Function Documentation

vtkImageHybridMedian2D* vtkImageHybridMedian2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageHybridMedian2D::vtkTypeRevisionMacro | ( | vtkImageHybridMedian2D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageHybridMedian2D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

float vtkImageHybridMedian2D::ComputeMedian | ( | float * | array,
 |  | int | size
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Imaging/vtkImageHybridMedian2D.h
Generated on Mon Mar 25 01:18:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIdealHighPass Class Reference

Simple frequency domain band pass. More...

#include <vtkImageIdealHighPass.h>

Inheritance diagram for vtkImageIdealHighPass:

[legend]
Collaboration diagram for vtkImageIdealHighPass:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageIdealHighPass, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCutOff (float, float, float)
virtual void | SetCutOff (float[3])
void | SetCutOff (float v)
void | SetXCutOff (float v)
void | SetYCutOff (float v)
void | SetZCutOff (float v)
virtual float * | GetCutOff ()
virtual void | GetCutOff (float &, float &, float &)
virtual void | GetCutOff (float[3])
float | GetXCutOff ()
float | GetYCutOff ()
float | GetZCutOff ()

Static Public Methods

vtkImageIdealHighPass * | New ()

Protected Methods

vtkImageIdealHighPass ()
~vtkImageIdealHighPass ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

float | CutOff [3]

Detailed Description

Simple frequency domain band pass.

Date:
2002/01/22 15:32:44
Revision:
1.21

This filter only works on an image after it has been converted to frequency domain by a vtkImageFFT filter. A vtkImageRFFT filter can be used to convert the output back into the spatial domain. vtkImageIdealHighPass just sets a portion of the image to zero. The sharp cutoff in the frequence domain produces ringing in the spatial domain. Input and Output must be floats. Dimensionality is set when the axes are set. Defaults to 2D on X and Y axes.

See also:
vtkImageButterworthHighPass vtkImageIdealLowPass vtkImageFFT vtkImageRFFT
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (77%)
  • Lorensen, Bill (10%)
  • Martin, Ken (5%)
Tests:
vtkImageIdealHighPass (Tests)

Definition at line 51 of file vtkImageIdealHighPass.h.

Constructor & Destructor Documentation

vtkImageIdealHighPass::vtkImageIdealHighPass ( ) [protected]

vtkImageIdealHighPass::~vtkImageIdealHighPass ( ) [inline, protected]

Definition at line 75 of file vtkImageIdealHighPass.h.

Member Function Documentation

vtkImageIdealHighPass* vtkImageIdealHighPass::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageIdealHighPass::vtkTypeRevisionMacro | ( | vtkImageIdealHighPass | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageIdealHighPass::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageIdealHighPass::SetCutOff | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealHighPass::SetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealHighPass::SetCutOff ( float v ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 63 of file vtkImageIdealHighPass.h.

void vtkImageIdealHighPass::SetXCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealHighPass::SetYCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealHighPass::SetZCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual float* vtkImageIdealHighPass::GetCutOff ( ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealHighPass::GetCutOff | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealHighPass::GetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

float vtkImageIdealHighPass::GetXCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 68 of file vtkImageIdealHighPass.h.

float vtkImageIdealHighPass::GetYCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 69 of file vtkImageIdealHighPass.h.

float vtkImageIdealHighPass::GetZCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 70 of file vtkImageIdealHighPass.h.

void vtkImageIdealHighPass::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageIdealHighPass::CutOff[3] [protected]

Definition at line 77 of file vtkImageIdealHighPass.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageIdealHighPass.h
Generated on Mon Mar 25 01:18:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIdealLowPass Class Reference

Simple frequency domain band pass. More...

#include <vtkImageIdealLowPass.h>

Inheritance diagram for vtkImageIdealLowPass:

[legend]
Collaboration diagram for vtkImageIdealLowPass:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageIdealLowPass, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCutOff (float, float, float)
virtual void | SetCutOff (float[3])
void | SetCutOff (float v)
void | SetXCutOff (float v)
void | SetYCutOff (float v)
void | SetZCutOff (float v)
virtual float * | GetCutOff ()
virtual void | GetCutOff (float &, float &, float &)
virtual void | GetCutOff (float[3])
float | GetXCutOff ()
float | GetYCutOff ()
float | GetZCutOff ()

Static Public Methods

vtkImageIdealLowPass * | New ()

Protected Methods

vtkImageIdealLowPass ()
~vtkImageIdealLowPass ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

float | CutOff [3]

Detailed Description

Simple frequency domain band pass.

Date:
2002/01/22 15:32:46
Revision:
1.21

This filter only works on an image after it has been converted to frequency domain by a vtkImageFFT filter. A vtkImageRFFT filter can be used to convert the output back into the spatial domain. vtkImageIdealLowPass just sets a portion of the image to zero. The result is an image with a lot of ringing. Input and Output must be floats. Dimensionality is set when the axes are set. Defaults to 2D on X and Y axes.

See also:
vtkImageButterworthLowPass vtkImageIdealHighPass vtkImageFFT vtkImageRFFT
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (77%)
  • Lorensen, Bill (10%)
  • Martin, Ken (5%)
Tests:
vtkImageIdealLowPass (Tests)

Definition at line 51 of file vtkImageIdealLowPass.h.

Constructor & Destructor Documentation

vtkImageIdealLowPass::vtkImageIdealLowPass ( ) [protected]

vtkImageIdealLowPass::~vtkImageIdealLowPass ( ) [inline, protected]

Definition at line 75 of file vtkImageIdealLowPass.h.

Member Function Documentation

vtkImageIdealLowPass* vtkImageIdealLowPass::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageIdealLowPass::vtkTypeRevisionMacro | ( | vtkImageIdealLowPass | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageIdealLowPass::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageIdealLowPass::SetCutOff | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealLowPass::SetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealLowPass::SetCutOff ( float v ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 63 of file vtkImageIdealLowPass.h.

void vtkImageIdealLowPass::SetXCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealLowPass::SetYCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

void vtkImageIdealLowPass::SetZCutOff ( float v )

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual float* vtkImageIdealLowPass::GetCutOff ( ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealLowPass::GetCutOff | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

virtual void vtkImageIdealLowPass::GetCutOff ( float [3] ) [virtual]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

float vtkImageIdealLowPass::GetXCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 68 of file vtkImageIdealLowPass.h.

float vtkImageIdealLowPass::GetYCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 69 of file vtkImageIdealLowPass.h.

float vtkImageIdealLowPass::GetZCutOff ( ) [inline]

Set/Get the cutoff frequency for each axis. The values are specified in the order X, Y, Z, Time. Units: Cycles per world unit (as defined by the data spacing).

Definition at line 70 of file vtkImageIdealLowPass.h.

void vtkImageIdealLowPass::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageIdealLowPass::CutOff[3] [protected]

Definition at line 77 of file vtkImageIdealLowPass.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageIdealLowPass.h
Generated on Mon Mar 25 01:18:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageImport Class Reference

Import data from a C array. More...

#include <vtkImageImport.h>

Inheritance diagram for vtkImageImport:

[legend]
Collaboration diagram for vtkImageImport:

[legend]
List of all members.

Public Types

typedef void(* | UpdateInformationCallbackType )(void *)
typedef int(* | PipelineModifiedCallbackType )(void *)
typedef int *(* | WholeExtentCallbackType )(void *)
typedef float *(* | SpacingCallbackType )(void *)
typedef float *(* | OriginCallbackType )(void *)
typedef const char *(* | ScalarTypeCallbackType )(void *)
typedef int(* | NumberOfComponentsCallbackType )(void *)
typedef void(* | PropagateUpdateExtentCallbackType )(void *, int *)
typedef void(* | UpdateDataCallbackType )(void *)
typedef int *(* | DataExtentCallbackType )(void *)
typedef void *(* | BufferPointerCallbackType )(void *)

Public Methods

vtkTypeRevisionMacro (vtkImageImport, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CopyImportVoidPointer (void *ptr, int size)
void | SetImportVoidPointer (void *ptr, int save)
virtual void | PropagateUpdateExtent (vtkDataObject *output)
void | SetImportVoidPointer (void *ptr)
void * | GetImportVoidPointer ()
virtual void | SetDataScalarType (int)
void | SetDataScalarTypeToDouble ()
void | SetDataScalarTypeToFloat ()
void | SetDataScalarTypeToInt ()
void | SetDataScalarTypeToShort ()
void | SetDataScalarTypeToUnsignedShort ()
void | SetDataScalarTypeToUnsignedChar ()
virtual int | GetDataScalarType ()
const char * | GetDataScalarTypeAsString ()
virtual void | SetNumberOfScalarComponents (int)
virtual int | GetNumberOfScalarComponents ()
virtual void | SetDataExtent (int, int, int, int, int, int)
virtual void | SetDataExtent (int[6])
virtual int * | GetDataExtent ()
virtual void | GetDataExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetDataExtent (int[6])
void | SetDataExtentToWholeExtent ()
virtual void | SetDataSpacing (float, float, float)
virtual void | SetDataSpacing (float[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float &, float &, float &)
virtual void | GetDataSpacing (float[3])
virtual void | SetDataOrigin (float, float, float)
virtual void | SetDataOrigin (float[3])
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float &, float &, float &)
virtual void | GetDataOrigin (float[3])
virtual void | SetWholeExtent (int, int, int, int, int, int)
virtual void | SetWholeExtent (int[6])
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetUpdateInformationCallback (UpdateInformationCallbackType)
virtual UpdateInformationCallbackType | GetUpdateInformationCallback ()
virtual void | SetPipelineModifiedCallback (PipelineModifiedCallbackType)
virtual PipelineModifiedCallbackType | GetPipelineModifiedCallback ()
virtual void | SetWholeExtentCallback (WholeExtentCallbackType)
virtual WholeExtentCallbackType | GetWholeExtentCallback ()
virtual void | SetSpacingCallback (SpacingCallbackType)
virtual SpacingCallbackType | GetSpacingCallback ()
virtual void | SetOriginCallback (OriginCallbackType)
virtual OriginCallbackType | GetOriginCallback ()
virtual void | SetScalarTypeCallback (ScalarTypeCallbackType)
virtual ScalarTypeCallbackType | GetScalarTypeCallback ()
virtual void | SetNumberOfComponentsCallback (NumberOfComponentsCallbackType)
virtual NumberOfComponentsCallbackType | GetNumberOfComponentsCallback ()
virtual void | SetPropagateUpdateExtentCallback (PropagateUpdateExtentCallbackType)
virtual PropagateUpdateExtentCallbackType | GetPropagateUpdateExtentCallback ()
virtual void | SetUpdateDataCallback (UpdateDataCallbackType)
virtual UpdateDataCallbackType | GetUpdateDataCallback ()
virtual void | SetDataExtentCallback (DataExtentCallbackType)
virtual DataExtentCallbackType | GetDataExtentCallback ()
virtual void | SetBufferPointerCallback (BufferPointerCallbackType)
virtual BufferPointerCallbackType | GetBufferPointerCallback ()
virtual void | SetCallbackUserData (void *)
virtual void * | GetCallbackUserData ()

Static Public Methods

vtkImageImport * | New ()

Protected Methods

vtkImageImport ()
~vtkImageImport ()
virtual void | UpdateInformation ()
virtual void | ExecuteInformation ()
void | InvokeUpdateInformationCallbacks ()
void | InvokeExecuteInformationCallbacks ()
void | InvokeExecuteDataCallbacks ()
void | LegacyCheckWholeExtent ()
virtual void | ExecuteData (vtkDataObject *d)

Protected Attributes

void * | ImportVoidPointer
int | SaveUserArray
int | NumberOfScalarComponents
int | DataScalarType
int | WholeExtent [6]
int | DataExtent [6]
float | DataSpacing [3]
float | DataOrigin [3]
void * | CallbackUserData
UpdateInformationCallbackType UpdateInformationCallback
PipelineModifiedCallbackType PipelineModifiedCallback
WholeExtentCallbackType WholeExtentCallback
SpacingCallbackType SpacingCallback
OriginCallbackType OriginCallback
ScalarTypeCallbackType ScalarTypeCallback
NumberOfComponentsCallbackType NumberOfComponentsCallback
PropagateUpdateExtentCallbackType PropagateUpdateExtentCallback
UpdateDataCallbackType UpdateDataCallback
DataExtentCallbackType DataExtentCallback
BufferPointerCallbackType BufferPointerCallback

Detailed Description

Import data from a C array.

Date:
2002/01/22 15:32:47
Revision:
1.35

vtkImageImport provides methods needed to import image data from a source independent of VTK, such as a simple C array or a third-party pipeline. Note that the VTK convention is for the image voxel index (0,0,0) to be the lower-left corner of the image, while most 2D image formats use the upper-left corner. You can use vtkImageFlip to correct the orientation after the image has been loaded into VTK. Note that is also possible to import the raw data from a Python string instead of from a C array.

See also:
vtkImageExport
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (35%)
  • King, Brad (24%)
  • Gobbi, David (23%)
  • Martin, Ken (13%)
Tests:
vtkImageImport (Tests)

Definition at line 52 of file vtkImageImport.h.

Member Typedef Documentation

typedef void(* vtkImageImport::UpdateInformationCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef int(* vtkImageImport::PipelineModifiedCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef int*(* vtkImageImport::WholeExtentCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef float*(* vtkImageImport::SpacingCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef float*(* vtkImageImport::OriginCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef const char*(* vtkImageImport::ScalarTypeCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef int(* vtkImageImport::NumberOfComponentsCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef void(* vtkImageImport::PropagateUpdateExtentCallbackType)(void*, int*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef void(* vtkImageImport::UpdateDataCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef int*(* vtkImageImport::DataExtentCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

typedef void*(* vtkImageImport::BufferPointerCallbackType)(void*)

These are function pointer types for the pipeline connection callbacks. See furhter documentation on each individual callback.

Constructor & Destructor Documentation

vtkImageImport::vtkImageImport ( ) [protected]

vtkImageImport::~vtkImageImport ( ) [protected]

Member Function Documentation

vtkImageImport* vtkImageImport::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageImport::vtkTypeRevisionMacro | ( | vtkImageImport | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageImport::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageImport::CopyImportVoidPointer | ( | void * | ptr,
 |  | int | size
 | ) |

Import data and make an internal copy of it. If you do not want VTK to copy the data, then use SetImportVoidPointer instead (do not use both). Give the size of the data array in bytes.

void vtkImageImport::SetImportVoidPointer ( void * ptr )

Set the pointer from which the image data is imported. VTK will not make its own copy of the data, it will access the data directly from the supplied array. VTK will not attempt to delete the data nor modify the data.

void* vtkImageImport::GetImportVoidPointer ( ) [inline]

Set the pointer from which the image data is imported. VTK will not make its own copy of the data, it will access the data directly from the supplied array. VTK will not attempt to delete the data nor modify the data.

Definition at line 70 of file vtkImageImport.h.

void vtkImageImport::SetImportVoidPointer | ( | void * | ptr,
 |  | int | save
 | ) |

Set the pointer from which the image data is imported. Set save to 1 (the default) unless you want VTK to delete the array via C++ delete when the vtkImageImport object is deallocated. VTK will not make its own copy of the data, it will access the data directly from the supplied array.

virtual void vtkImageImport::SetDataScalarType ( int ) [virtual]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

void vtkImageImport::SetDataScalarTypeToDouble ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 84 of file vtkImageImport.h.

void vtkImageImport::SetDataScalarTypeToFloat ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 85 of file vtkImageImport.h.

void vtkImageImport::SetDataScalarTypeToInt ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 86 of file vtkImageImport.h.

void vtkImageImport::SetDataScalarTypeToShort ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 87 of file vtkImageImport.h.

void vtkImageImport::SetDataScalarTypeToUnsignedShort ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 88 of file vtkImageImport.h.

void vtkImageImport::SetDataScalarTypeToUnsignedChar ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 90 of file vtkImageImport.h.

virtual int vtkImageImport::GetDataScalarType ( ) [virtual]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

const char* vtkImageImport::GetDataScalarTypeAsString ( ) [inline]

Set/Get the data type of pixels in the imported data. This is used as the scalar type of the Output. Default: Short.

Definition at line 93 of file vtkImageImport.h.

virtual void vtkImageImport::SetNumberOfScalarComponents ( int ) [virtual]

Set/Get the number of scalar components, for RGB images this must be 3. Default: 1.

virtual int vtkImageImport::GetNumberOfScalarComponents ( ) [virtual]

Set/Get the number of scalar components, for RGB images this must be 3. Default: 1.

virtual void vtkImageImport::SetDataExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

virtual void vtkImageImport::SetDataExtent ( int [6] ) [virtual]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

virtual int* vtkImageImport::GetDataExtent ( ) [virtual]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

virtual void vtkImageImport::GetDataExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

virtual void vtkImageImport::GetDataExtent ( int [6] ) [virtual]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

void vtkImageImport::SetDataExtentToWholeExtent ( ) [inline]

Get/Set the extent of the data buffer. The dimensions of your data must be equal to (extent[1]-extent[0]+1) * (extent[3]-extent[2]+1) * (extent[5]-DataExtent[4]+1). For example, for a 2D image use (0,width-1, 0,height-1, 0,0).

Definition at line 111 of file vtkImageImport.h.

virtual void vtkImageImport::SetDataSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the spacing (typically in mm) between image voxels. Default: (1.0, 1.0, 1.0).

virtual void vtkImageImport::SetDataSpacing ( float [3] ) [virtual]

Set/Get the spacing (typically in mm) between image voxels. Default: (1.0, 1.0, 1.0).

virtual float* vtkImageImport::GetDataSpacing ( ) [virtual]

Set/Get the spacing (typically in mm) between image voxels. Default: (1.0, 1.0, 1.0).

virtual void vtkImageImport::GetDataSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the spacing (typically in mm) between image voxels. Default: (1.0, 1.0, 1.0).

virtual void vtkImageImport::GetDataSpacing ( float [3] ) [virtual]

Set/Get the spacing (typically in mm) between image voxels. Default: (1.0, 1.0, 1.0).

virtual void vtkImageImport::SetDataOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the origin of the data, i.e. the coordinates (usually in mm) of voxel (0,0,0). Default: (0.0, 0.0, 0.0).

virtual void vtkImageImport::SetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data, i.e. the coordinates (usually in mm) of voxel (0,0,0). Default: (0.0, 0.0, 0.0).

virtual float* vtkImageImport::GetDataOrigin ( ) [virtual]

Set/Get the origin of the data, i.e. the coordinates (usually in mm) of voxel (0,0,0). Default: (0.0, 0.0, 0.0).

virtual void vtkImageImport::GetDataOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the origin of the data, i.e. the coordinates (usually in mm) of voxel (0,0,0). Default: (0.0, 0.0, 0.0).

virtual void vtkImageImport::GetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data, i.e. the coordinates (usually in mm) of voxel (0,0,0). Default: (0.0, 0.0, 0.0).

virtual void vtkImageImport::SetWholeExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Get/Set the whole extent of the image. This is the largest possible extent. Set the DataExtent to the extent of the image in the buffer pointed to by the ImportVoidPointer.

virtual void vtkImageImport::SetWholeExtent ( int [6] ) [virtual]

Get/Set the whole extent of the image. This is the largest possible extent. Set the DataExtent to the extent of the image in the buffer pointed to by the ImportVoidPointer.

virtual int* vtkImageImport::GetWholeExtent ( ) [virtual]

Get/Set the whole extent of the image. This is the largest possible extent. Set the DataExtent to the extent of the image in the buffer pointed to by the ImportVoidPointer.

virtual void vtkImageImport::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get/Set the whole extent of the image. This is the largest possible extent. Set the DataExtent to the extent of the image in the buffer pointed to by the ImportVoidPointer.

virtual void vtkImageImport::GetWholeExtent ( int [6] ) [virtual]

Get/Set the whole extent of the image. This is the largest possible extent. Set the DataExtent to the extent of the image in the buffer pointed to by the ImportVoidPointer.

virtual void vtkImageImport::PropagateUpdateExtent ( vtkDataObject * output ) [virtual]

Propagates the update extent through the callback if it is set.

Reimplemented from vtkSource.

virtual void vtkImageImport::SetUpdateInformationCallback ( UpdateInformationCallbackType ) [virtual]

Set/Get the callback for propagating UpdateInformation calls to a third-party pipeline. The callback should make sure that the third-party pipeline information is up to date.

virtual UpdateInformationCallbackType vtkImageImport::GetUpdateInformationCallback ( ) [virtual]

Set/Get the callback for propagating UpdateInformation calls to a third-party pipeline. The callback should make sure that the third-party pipeline information is up to date.

virtual void vtkImageImport::SetPipelineModifiedCallback ( PipelineModifiedCallbackType ) [virtual]

Set/Get the callback for checking whether the third-party pipeline has been modified since the last invocation of the callback. The callback should return 1 for modified, and 0 for not modified. The first call should always return modified.

virtual PipelineModifiedCallbackType vtkImageImport::GetPipelineModifiedCallback ( ) [virtual]

Set/Get the callback for checking whether the third-party pipeline has been modified since the last invocation of the callback. The callback should return 1 for modified, and 0 for not modified. The first call should always return modified.

virtual void vtkImageImport::SetWholeExtentCallback ( WholeExtentCallbackType ) [virtual]

Set/Get the callback for getting the whole extent of the input image from a third-party pipeline. The callback should return a vector of six integers describing the extent of the whole image (x1 x2 y1 y2 z1 z2).

virtual WholeExtentCallbackType vtkImageImport::GetWholeExtentCallback ( ) [virtual]

Set/Get the callback for getting the whole extent of the input image from a third-party pipeline. The callback should return a vector of six integers describing the extent of the whole image (x1 x2 y1 y2 z1 z2).

virtual void vtkImageImport::SetSpacingCallback ( SpacingCallbackType ) [virtual]

Set/Get the callback for getting the spacing of the input image from a third-party pipeline. The callback should return a vector of three float values describing the spacing (dx dy dz).

virtual SpacingCallbackType vtkImageImport::GetSpacingCallback ( ) [virtual]

Set/Get the callback for getting the spacing of the input image from a third-party pipeline. The callback should return a vector of three float values describing the spacing (dx dy dz).

virtual void vtkImageImport::SetOriginCallback ( OriginCallbackType ) [virtual]

Set/Get the callback for getting the origin of the input image from a third-party pipeline. The callback should return a vector of three float values describing the origin (x0 y0 z0).

virtual OriginCallbackType vtkImageImport::GetOriginCallback ( ) [virtual]

Set/Get the callback for getting the origin of the input image from a third-party pipeline. The callback should return a vector of three float values describing the origin (x0 y0 z0).

virtual void vtkImageImport::SetScalarTypeCallback ( ScalarTypeCallbackType ) [virtual]

Set/Get the callback for getting the scalar value type of the input image from a third-party pipeline. The callback should return a string with the name of the type.

virtual ScalarTypeCallbackType vtkImageImport::GetScalarTypeCallback ( ) [virtual]

Set/Get the callback for getting the scalar value type of the input image from a third-party pipeline. The callback should return a string with the name of the type.

virtual void vtkImageImport::SetNumberOfComponentsCallback ( NumberOfComponentsCallbackType ) [virtual]

Set/Get the callback for getting the number of components of the input image from a third-party pipeline. The callback should return an integer with the number of components.

virtual NumberOfComponentsCallbackType vtkImageImport::GetNumberOfComponentsCallback ( ) [virtual]

Set/Get the callback for getting the number of components of the input image from a third-party pipeline. The callback should return an integer with the number of components.

virtual void vtkImageImport::SetPropagateUpdateExtentCallback ( PropagateUpdateExtentCallbackType ) [virtual]

Set/Get the callback for propagating the pipeline update extent to a third-party pipeline. The callback should take a vector of six integers describing the extent. This should cause the third-party pipeline to provide data which contains at least this extent after the next UpdateData callback.

virtual PropagateUpdateExtentCallbackType vtkImageImport::GetPropagateUpdateExtentCallback ( ) [virtual]

Set/Get the callback for propagating the pipeline update extent to a third-party pipeline. The callback should take a vector of six integers describing the extent. This should cause the third-party pipeline to provide data which contains at least this extent after the next UpdateData callback.

virtual void vtkImageImport::SetUpdateDataCallback ( UpdateDataCallbackType ) [virtual]

Set/Get the callback for propagating UpdateData calls to a third-party pipeline. The callback should make sure the third-party pipeline is up to date.

virtual UpdateDataCallbackType vtkImageImport::GetUpdateDataCallback ( ) [virtual]

Set/Get the callback for propagating UpdateData calls to a third-party pipeline. The callback should make sure the third-party pipeline is up to date.

virtual void vtkImageImport::SetDataExtentCallback ( DataExtentCallbackType ) [virtual]

Set/Get the callback for getting the data extent of the input image from a third-party pipeline. The callback should return a vector of six integers describing the extent of the buffered portion of the image (x1 x2 y1 y2 z1 z2). The buffer location should be set with the BufferPointerCallback.

virtual DataExtentCallbackType vtkImageImport::GetDataExtentCallback ( ) [virtual]

Set/Get the callback for getting the data extent of the input image from a third-party pipeline. The callback should return a vector of six integers describing the extent of the buffered portion of the image (x1 x2 y1 y2 z1 z2). The buffer location should be set with the BufferPointerCallback.

virtual void vtkImageImport::SetBufferPointerCallback ( BufferPointerCallbackType ) [virtual]

Set/Get the callback for getting a pointer to the data buffer of an image from a third-party pipeline. The callback should return a pointer to the beginning of the buffer. The extent of the buffer should be set with the DataExtentCallback.

virtual BufferPointerCallbackType vtkImageImport::GetBufferPointerCallback ( ) [virtual]

Set/Get the callback for getting a pointer to the data buffer of an image from a third-party pipeline. The callback should return a pointer to the beginning of the buffer. The extent of the buffer should be set with the DataExtentCallback.

virtual void vtkImageImport::SetCallbackUserData ( void * ) [virtual]

Set/Get the user data which will be passed as the first argument to all of the third-party pipeline callbacks.

virtual void* vtkImageImport::GetCallbackUserData ( ) [virtual]

Set/Get the user data which will be passed as the first argument to all of the third-party pipeline callbacks.

virtual void vtkImageImport::UpdateInformation ( ) [protected, virtual]

Updates any global information about the data (like spacing for images)

Reimplemented from vtkSource.

virtual void vtkImageImport::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkImageImport::InvokeUpdateInformationCallbacks ( ) [protected]

void vtkImageImport::InvokeExecuteInformationCallbacks ( ) [protected]

void vtkImageImport::InvokeExecuteDataCallbacks ( ) [protected]

void vtkImageImport::LegacyCheckWholeExtent ( ) [protected]

virtual void vtkImageImport::ExecuteData ( vtkDataObject * d ) [protected, virtual]

Member Data Documentation

void* vtkImageImport::ImportVoidPointer [protected]

Definition at line 273 of file vtkImageImport.h.

int vtkImageImport::SaveUserArray [protected]

Definition at line 274 of file vtkImageImport.h.

int vtkImageImport::NumberOfScalarComponents [protected]

Definition at line 276 of file vtkImageImport.h.

int vtkImageImport::DataScalarType [protected]

Definition at line 277 of file vtkImageImport.h.

int vtkImageImport::WholeExtent[6] [protected]

Definition at line 279 of file vtkImageImport.h.

int vtkImageImport::DataExtent[6] [protected]

Definition at line 280 of file vtkImageImport.h.

float vtkImageImport::DataSpacing[3] [protected]

Definition at line 281 of file vtkImageImport.h.

float vtkImageImport::DataOrigin[3] [protected]

Definition at line 282 of file vtkImageImport.h.

void* vtkImageImport::CallbackUserData [protected]

Definition at line 284 of file vtkImageImport.h.

UpdateInformationCallbackType vtkImageImport::UpdateInformationCallback [protected]

Definition at line 287 of file vtkImageImport.h.

PipelineModifiedCallbackType vtkImageImport::PipelineModifiedCallback [protected]

Definition at line 288 of file vtkImageImport.h.

WholeExtentCallbackType vtkImageImport::WholeExtentCallback [protected]

Definition at line 289 of file vtkImageImport.h.

SpacingCallbackType vtkImageImport::SpacingCallback [protected]

Definition at line 290 of file vtkImageImport.h.

OriginCallbackType vtkImageImport::OriginCallback [protected]

Definition at line 291 of file vtkImageImport.h.

ScalarTypeCallbackType vtkImageImport::ScalarTypeCallback [protected]

Definition at line 292 of file vtkImageImport.h.

NumberOfComponentsCallbackType vtkImageImport::NumberOfComponentsCallback [protected]

Definition at line 293 of file vtkImageImport.h.

PropagateUpdateExtentCallbackType vtkImageImport::PropagateUpdateExtentCallback [protected]

Definition at line 294 of file vtkImageImport.h.

UpdateDataCallbackType vtkImageImport::UpdateDataCallback [protected]

Definition at line 295 of file vtkImageImport.h.

DataExtentCallbackType vtkImageImport::DataExtentCallback [protected]

Definition at line 296 of file vtkImageImport.h.

BufferPointerCallbackType vtkImageImport::BufferPointerCallback [protected]

Definition at line 297 of file vtkImageImport.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageImport.h
Generated on Mon Mar 25 01:18:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageInPlaceFilter Class Reference

Filter that operates in place. More...

#include <vtkImageInPlaceFilter.h>

Inheritance diagram for vtkImageInPlaceFilter:

[legend]
Collaboration diagram for vtkImageInPlaceFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageInPlaceFilter, vtkImageToImageFilter)

Static Public Methods

vtkImageInPlaceFilter * | New ()

Protected Methods

vtkImageInPlaceFilter ()
~vtkImageInPlaceFilter ()
virtual void | ExecuteData (vtkDataObject *out)
void | CopyData (vtkImageData *in, vtkImageData *out)

Detailed Description

Filter that operates in place.

Date:
2002/01/22 15:28:05
Revision:
1.31

vtkImageInPlaceFilter is a filter super class that operates directly on the input region. The data is copied if the requested region has different extent than the input region or some other object is referencing the input region.

See also:
vtkImageToImageFilter vtkImageMultipleInputFilter vtkImageTwoInputFilter vtkImageTwoOutputFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (67%)
  • Martin, Ken (28%)

Definition at line 44 of file vtkImageInPlaceFilter.h.

Constructor & Destructor Documentation

vtkImageInPlaceFilter::vtkImageInPlaceFilter ( ) [inline, protected]

Definition at line 52 of file vtkImageInPlaceFilter.h.

vtkImageInPlaceFilter::~vtkImageInPlaceFilter ( ) [inline, protected]

Definition at line 53 of file vtkImageInPlaceFilter.h.

Member Function Documentation

vtkImageInPlaceFilter* vtkImageInPlaceFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageCursor3D.

vtkImageInPlaceFilter::vtkTypeRevisionMacro | ( | vtkImageInPlaceFilter | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageCursor3D.

virtual void vtkImageInPlaceFilter::ExecuteData ( vtkDataObject * outData ) [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageCursor3D.

void vtkImageInPlaceFilter::CopyData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Filtering/vtkImageInPlaceFilter.h
Generated on Mon Mar 25 01:19:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIslandRemoval2D Class Reference

Removes small clusters in masks. More...

#include <vtkImageIslandRemoval2D.h>

Inheritance diagram for vtkImageIslandRemoval2D:

[legend]
Collaboration diagram for vtkImageIslandRemoval2D:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageIslandRemoval2D, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageIslandRemoval2D * | New ()

Public Methods

virtual void | SetAreaThreshold (int)
virtual int | GetAreaThreshold ()
virtual void | SetSquareNeighborhood (int)
virtual int | GetSquareNeighborhood ()
virtual void | SquareNeighborhoodOn ()
virtual void | SquareNeighborhoodOff ()
virtual void | SetIslandValue (float)
virtual float | GetIslandValue ()
virtual void | SetReplaceValue (float)
virtual float | GetReplaceValue ()

Protected Methods

vtkImageIslandRemoval2D ()
~vtkImageIslandRemoval2D ()
void | ExecuteData (vtkDataObject *output)

Protected Attributes

int | AreaThreshold
int | SquareNeighborhood
float | IslandValue
float | ReplaceValue

Detailed Description

Removes small clusters in masks.

Date:
2002/01/22 15:32:48
Revision:
1.36

vtkImageIslandRemoval2D computes the area of separate islands in a mask image. It removes any island that has less than AreaThreshold pixels. Output has the same ScalarType as input. It generates the whole 2D output image for any output request.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (58%)
  • Martin, Ken (37%)
Tests:
vtkImageIslandRemoval2D (Tests)

Definition at line 53 of file vtkImageIslandRemoval2D.h.

Constructor & Destructor Documentation

vtkImageIslandRemoval2D::vtkImageIslandRemoval2D ( ) [protected]

vtkImageIslandRemoval2D::~vtkImageIslandRemoval2D ( ) [inline, protected]

Definition at line 90 of file vtkImageIslandRemoval2D.h.

Member Function Documentation

vtkImageIslandRemoval2D* vtkImageIslandRemoval2D::New ( ) [static]

Constructor: Sets default filter to be identity.

Reimplemented from vtkImageToImageFilter.

vtkImageIslandRemoval2D::vtkTypeRevisionMacro | ( | vtkImageIslandRemoval2D | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageIslandRemoval2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageIslandRemoval2D::SetAreaThreshold ( int ) [virtual]

Set/Get the cutoff area for removal

virtual int vtkImageIslandRemoval2D::GetAreaThreshold ( ) [virtual]

Set/Get the cutoff area for removal

virtual void vtkImageIslandRemoval2D::SetSquareNeighborhood ( int ) [virtual]

Set/Get whether to use 4 or 8 neighbors

virtual int vtkImageIslandRemoval2D::GetSquareNeighborhood ( ) [virtual]

Set/Get whether to use 4 or 8 neighbors

virtual void vtkImageIslandRemoval2D::SquareNeighborhoodOn ( ) [virtual]

Set/Get whether to use 4 or 8 neighbors

virtual void vtkImageIslandRemoval2D::SquareNeighborhoodOff ( ) [virtual]

Set/Get whether to use 4 or 8 neighbors

virtual void vtkImageIslandRemoval2D::SetIslandValue ( float ) [virtual]

Set/Get the value to remove.

virtual float vtkImageIslandRemoval2D::GetIslandValue ( ) [virtual]

Set/Get the value to remove.

virtual void vtkImageIslandRemoval2D::SetReplaceValue ( float ) [virtual]

Set/Get the value to put in the place of removed pixels.

virtual float vtkImageIslandRemoval2D::GetReplaceValue ( ) [virtual]

Set/Get the value to put in the place of removed pixels.

void vtkImageIslandRemoval2D::ExecuteData ( vtkDataObject * output ) [protected]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageIslandRemoval2D::AreaThreshold [protected]

Definition at line 92 of file vtkImageIslandRemoval2D.h.

int vtkImageIslandRemoval2D::SquareNeighborhood [protected]

Definition at line 93 of file vtkImageIslandRemoval2D.h.

float vtkImageIslandRemoval2D::IslandValue [protected]

Definition at line 94 of file vtkImageIslandRemoval2D.h.

float vtkImageIslandRemoval2D::ReplaceValue [protected]

Definition at line 95 of file vtkImageIslandRemoval2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageIslandRemoval2D.h
Generated on Mon Mar 25 01:19:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageIterateFilter Class Reference

Multiple executes per update. More...

#include <vtkImageIterateFilter.h>

Inheritance diagram for vtkImageIterateFilter:

[legend]
Collaboration diagram for vtkImageIterateFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageIterateFilter, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | ComputeInputUpdateExtent (int[6], int[6])
virtual int | GetIteration ()
virtual int | GetNumberOfIterations ()

Protected Methods

vtkImageIterateFilter ()
~vtkImageIterateFilter ()
void | ExecuteInformation ()
virtual void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteData (vtkDataObject *output)
virtual void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)=0
virtual void | AllocateOutputScalars (vtkImageData *outData)
virtual void | SetNumberOfIterations (int num)
vtkImageData * GetIterationInput ()
vtkImageData * GetIterationOutput ()

Protected Attributes

int | NumberOfIterations
int | Iteration
vtkImageData ** IterationData

Detailed Description

Multiple executes per update.

Date:
2002/01/22 15:32:49
Revision:
1.32

vtkImageIterateFilter is a filter superclass that supports calling execute multiple times per update. The largest hack/open issue is that the input and output caches are temporarily changed to "fool" the subclasses. I believe the correct solution is to pass the in and out cache to the subclasses methods as arguments. Now the data is passes. Can the caches be passed, and data retrieved from the cache?

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (89%)

Definition at line 42 of file vtkImageIterateFilter.h.

Constructor & Destructor Documentation

vtkImageIterateFilter::vtkImageIterateFilter ( ) [protected]

vtkImageIterateFilter::~vtkImageIterateFilter ( ) [protected]

Member Function Documentation

vtkImageIterateFilter::vtkTypeRevisionMacro | ( | vtkImageIterateFilter | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageCityBlockDistance, vtkImageDecomposeFilter, vtkImageEuclideanDistance, vtkImageFFT, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageRFFT, vtkImageSeparableConvolution, and vtkImageSkeleton2D.

void vtkImageIterateFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageDecomposeFilter, vtkImageEuclideanDistance, vtkImageSeparableConvolution, and vtkImageSkeleton2D.

virtual int vtkImageIterateFilter::GetIteration ( ) [virtual]

Get which iteration is current being performed. Normally the user will not access this method.

virtual int vtkImageIterateFilter::GetNumberOfIterations ( ) [virtual]

Get which iteration is current being performed. Normally the user will not access this method.

void vtkImageIterateFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkImageToImageFilter.

void vtkImageIterateFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [inline, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageCityBlockDistance, vtkImageEuclideanDistance, vtkImageFFT, vtkImageFourierCenter, vtkImageRFFT, vtkImageSeparableConvolution, and vtkImageSkeleton2D.

Definition at line 57 of file vtkImageIterateFilter.h.

void vtkImageIterateFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageEuclideanDistance, vtkImageFFT, vtkImageRFFT, and vtkImageSeparableConvolution.

Referenced by vtkImageSeparableConvolution::ExecuteInformation(), vtkImageRFFT::ExecuteInformation(), vtkImageFFT::ExecuteInformation(), and vtkImageEuclideanDistance::ExecuteInformation().

virtual void vtkImageIterateFilter::ExecuteInformation | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageEuclideanDistance, vtkImageFFT, vtkImageRFFT, and vtkImageSeparableConvolution.

void vtkImageIterateFilter::ExecuteData ( vtkDataObject * output ) [protected]

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageIterateFilter::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [protected, pure virtual]

Reimplemented in vtkImageCityBlockDistance, vtkImageEuclideanDistance, vtkImageFFT, vtkImageFourierCenter, vtkImageRFFT, vtkImageSeparableConvolution, and vtkImageSkeleton2D.

virtual void vtkImageIterateFilter::AllocateOutputScalars ( vtkImageData * outData ) [protected, virtual]

Reimplemented in vtkImageCityBlockDistance, and vtkImageEuclideanDistance.

virtual void vtkImageIterateFilter::SetNumberOfIterations ( int num ) [protected, virtual]

Reimplemented in vtkImageSkeleton2D.

vtkImageData* vtkImageIterateFilter::GetIterationInput ( ) [protected]

vtkImageData* vtkImageIterateFilter::GetIterationOutput ( ) [protected]

Member Data Documentation

int vtkImageIterateFilter::NumberOfIterations [protected]

Definition at line 85 of file vtkImageIterateFilter.h.

int vtkImageIterateFilter::Iteration [protected]

Definition at line 86 of file vtkImageIterateFilter.h.

vtkImageData** vtkImageIterateFilter::IterationData [protected]

Definition at line 89 of file vtkImageIterateFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageIterateFilter.h
Generated on Mon Mar 25 01:19:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplatevtkImageIterator class Reference

vtkImageIterator Class Template Reference

a simple image iterator. More...

#include <vtkImageIterator.h>

Inheritance diagram for vtkImageIterator:

[legend]
Collaboration diagram for vtkImageIterator:

[legend]
List of all members.

Public Types

typedef DType * | SpanIterator

Public Methods

vtkImageIterator (vtkImageData *id, int *ext)
void | NextSpan ()
SpanIterator BeginSpan ()
SpanIterator EndSpan ()
int | IsAtEnd ()

Protected Attributes

DType * | Pointer
DType * | SpanEndPointer
DType * | SliceEndPointer
DType * | EndPointer
int | Increments [3]
int | ContinuousIncrements [3]

Detailed Description

template<class DType>
class vtkImageIterator< DType >

a simple image iterator.

Date:
2002/03/12 15:27:45
Revision:
1.7

This is a simple image iterator that can be used to iterate over an image. This should be used internally by Filter writers.

See also:
vtkImage vtkImageProgressIterator
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (84%)
  • Cedilnik, Andy (10%)
Tests:
vtkImageIterator (Tests)

Definition at line 46 of file vtkImageIterator.h.

Member Typedef Documentation

template<class DType>
typedef DType* vtkImageIterator::SpanIterator

Definition at line 49 of file vtkImageIterator.h.

Constructor & Destructor Documentation

template<class DType>
vtkImageIterator< DType >::vtkImageIterator | ( | vtkImageData * | id,
 |  | int * | ext
 | ) |

Create an image iterator fora given image data and a given extent

Member Function Documentation

template<class DType>
void vtkImageIterator< DType >::NextSpan ( )

Move the iterator to the next span

Reimplemented in vtkImageProgressIterator.

template<class DType>
SpanIterator vtkImageIterator< DType >::BeginSpan ( ) [inline]

Return an iterator (pointer) for the span

Definition at line 59 of file vtkImageIterator.h.

template<class DType>
SpanIterator vtkImageIterator< DType >::EndSpan ( ) [inline]

Return an iterator (pointer) for the end of the span

Definition at line 67 of file vtkImageIterator.h.

template<class DType>
int vtkImageIterator< DType >::IsAtEnd ( ) [inline]

tets if the end of the extent has been reached

Definition at line 75 of file vtkImageIterator.h.

Member Data Documentation

template<class DType>
DType* vtkImageIterator::Pointer [protected]

Definition at line 82 of file vtkImageIterator.h.

template<class DType>
DType* vtkImageIterator::SpanEndPointer [protected]

Definition at line 83 of file vtkImageIterator.h.

template<class DType>
DType* vtkImageIterator::SliceEndPointer [protected]

Definition at line 84 of file vtkImageIterator.h.

template<class DType>
DType* vtkImageIterator::EndPointer [protected]

Definition at line 85 of file vtkImageIterator.h.

template<class DType>
int vtkImageIterator::Increments[3] [protected]

Definition at line 86 of file vtkImageIterator.h.

template<class DType>
int vtkImageIterator::ContinuousIncrements[3] [protected]

Definition at line 87 of file vtkImageIterator.h.

The documentation for this class was generated from the following file:
  • Common/vtkImageIterator.h
Generated on Mon Mar 25 01:19:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLaplacian Class Reference

Computes divergence of gradient. More...

#include <vtkImageLaplacian.h>

Inheritance diagram for vtkImageLaplacian:

[legend]
Collaboration diagram for vtkImageLaplacian:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageLaplacian, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageLaplacian * | New ()

Protected Methods

vtkImageLaplacian ()
~vtkImageLaplacian ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

int | Dimensionality

Detailed Description

Computes divergence of gradient.

Date:
2002/03/04 19:01:03
Revision:
1.31

vtkimageLaplacian computes the Laplacian (like a second derivative) of a scalar image. The operation is the same as taking the divergence after a gradient. Boundaries are handled, so the input is the same as the output. Dimensionality determines how the input regions are interpreted. (images, or volumes). The Dimensionality defaults to two.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (55%)
  • Martin, Ken (35%)
Tests:
vtkImageLaplacian (Tests)

Definition at line 46 of file vtkImageLaplacian.h.

Constructor & Destructor Documentation

vtkImageLaplacian::vtkImageLaplacian ( ) [protected]

vtkImageLaplacian::~vtkImageLaplacian ( ) [inline, protected]

Definition at line 61 of file vtkImageLaplacian.h.

Member Function Documentation

vtkImageLaplacian* vtkImageLaplacian::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageLaplacian::vtkTypeRevisionMacro | ( | vtkImageLaplacian | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageLaplacian::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageLaplacian::SetDimensionality ( int ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

virtual int vtkImageLaplacian::GetDimensionality ( ) [virtual]

Determines how the input is interpreted (set of 2d slices ...)

void vtkImageLaplacian::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageLaplacian::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageLaplacian::Dimensionality [protected]

Definition at line 63 of file vtkImageLaplacian.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageLaplacian.h
Generated on Mon Mar 25 01:19:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLogarithmicScale Class Reference

Passes each pixel through log function. More...

#include <vtkImageLogarithmicScale.h>

Inheritance diagram for vtkImageLogarithmicScale:

[legend]
Collaboration diagram for vtkImageLogarithmicScale:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageLogarithmicScale, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetConstant (float)
virtual float | GetConstant ()

Static Public Methods

vtkImageLogarithmicScale * | New ()

Protected Methods

vtkImageLogarithmicScale ()
~vtkImageLogarithmicScale ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

float | Constant

Detailed Description

Passes each pixel through log function.

Date:
2002/01/22 15:32:53
Revision:
1.22

vtkImageLogarithmicScale passes each pixel through the function c*log(1+x). It also handles negative values with the function -c*log(1-x).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (75%)
  • Martin, Ken (9%)
  • Schroeder, Will (5%)
  • Avila, Lisa (5%)
Tests:
vtkImageLogarithmicScale (Tests)

Definition at line 45 of file vtkImageLogarithmicScale.h.

Constructor & Destructor Documentation

vtkImageLogarithmicScale::vtkImageLogarithmicScale ( ) [protected]

vtkImageLogarithmicScale::~vtkImageLogarithmicScale ( ) [inline, protected]

Definition at line 60 of file vtkImageLogarithmicScale.h.

Member Function Documentation

vtkImageLogarithmicScale* vtkImageLogarithmicScale::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageLogarithmicScale::vtkTypeRevisionMacro | ( | vtkImageLogarithmicScale | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageLogarithmicScale::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageLogarithmicScale::SetConstant ( float ) [virtual]

Set/Get the scale factor for the logarithmic function.

virtual float vtkImageLogarithmicScale::GetConstant ( ) [virtual]

Set/Get the scale factor for the logarithmic function.

void vtkImageLogarithmicScale::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageLogarithmicScale::Constant [protected]

Definition at line 62 of file vtkImageLogarithmicScale.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageLogarithmicScale.h
Generated on Mon Mar 25 01:19:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLogic Class Reference

And, or, xor, nand, nor, not. More...

#include <vtkImageLogic.h>

Inheritance diagram for vtkImageLogic:

[legend]
Collaboration diagram for vtkImageLogic:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageLogic, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOperation (int)
virtual int | GetOperation ()
void | SetOperationToAnd ()
void | SetOperationToOr ()
void | SetOperationToXor ()
void | SetOperationToNand ()
void | SetOperationToNor ()
void | SetOperationToNot ()
virtual void | SetOutputTrueValue (float)
virtual float | GetOutputTrueValue ()

Static Public Methods

vtkImageLogic * | New ()

Protected Methods

vtkImageLogic ()
~vtkImageLogic ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | Operation
float | OutputTrueValue

Detailed Description

And, or, xor, nand, nor, not.

Date:
2002/01/22 15:32:54
Revision:
1.21

vtkImageLogic implements basic logic operations. SetOperation is used to select the filter's behavior. The filter can take two or one input. Inputs must have the same type.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (44%)
  • Martin, Ken (42%)
Tests:
vtkImageLogic (Tests)

Definition at line 54 of file vtkImageLogic.h.

Constructor & Destructor Documentation

vtkImageLogic::vtkImageLogic ( ) [protected]

vtkImageLogic::~vtkImageLogic ( ) [inline, protected]

Definition at line 81 of file vtkImageLogic.h.

Member Function Documentation

vtkImageLogic* vtkImageLogic::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageLogic::vtkTypeRevisionMacro | ( | vtkImageLogic | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageLogic::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageLogic::SetOperation ( int ) [virtual]

Set/Get the Operation to perform.

virtual int vtkImageLogic::GetOperation ( ) [virtual]

Set/Get the Operation to perform.

void vtkImageLogic::SetOperationToAnd ( ) [inline]

Set/Get the Operation to perform.

Definition at line 65 of file vtkImageLogic.h.

void vtkImageLogic::SetOperationToOr ( ) [inline]

Set/Get the Operation to perform.

Definition at line 66 of file vtkImageLogic.h.

void vtkImageLogic::SetOperationToXor ( ) [inline]

Set/Get the Operation to perform.

Definition at line 67 of file vtkImageLogic.h.

void vtkImageLogic::SetOperationToNand ( ) [inline]

Set/Get the Operation to perform.

Definition at line 68 of file vtkImageLogic.h.

void vtkImageLogic::SetOperationToNor ( ) [inline]

Set/Get the Operation to perform.

Definition at line 69 of file vtkImageLogic.h.

void vtkImageLogic::SetOperationToNot ( ) [inline]

Set/Get the Operation to perform.

Definition at line 70 of file vtkImageLogic.h.

virtual void vtkImageLogic::SetOutputTrueValue ( float ) [virtual]

Set the value to use for true in the output.

virtual float vtkImageLogic::GetOutputTrueValue ( ) [virtual]

Set the value to use for true in the output.

void vtkImageLogic::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

int vtkImageLogic::Operation [protected]

Definition at line 83 of file vtkImageLogic.h.

float vtkImageLogic::OutputTrueValue [protected]

Definition at line 84 of file vtkImageLogic.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageLogic.h
Generated on Mon Mar 25 01:19:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageLuminance Class Reference

Computes the luminance of the input. More...

#include <vtkImageLuminance.h>

Inheritance diagram for vtkImageLuminance:

[legend]
Collaboration diagram for vtkImageLuminance:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageLuminance, vtkImageToImageFilter)

Static Public Methods

vtkImageLuminance * | New ()

Protected Methods

vtkImageLuminance ()
~vtkImageLuminance ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Detailed Description

Computes the luminance of the input.

Date:
2002/01/22 15:32:55
Revision:
1.20

vtkImageLuminance calculates luminance from an rgb input.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (70%)
  • Martin, Ken (13%)
  • Schroeder, Will (7%)
  • Law, Charles (5%)
Examples:
vtkImageLuminance (Examples)
Tests:
vtkImageLuminance (Tests)

Definition at line 46 of file vtkImageLuminance.h.

Constructor & Destructor Documentation

vtkImageLuminance::vtkImageLuminance ( ) [inline, protected]

Definition at line 53 of file vtkImageLuminance.h.

vtkImageLuminance::~vtkImageLuminance ( ) [inline, protected]

Definition at line 54 of file vtkImageLuminance.h.

Member Function Documentation

vtkImageLuminance* vtkImageLuminance::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageLuminance::vtkTypeRevisionMacro | ( | vtkImageLuminance | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageLuminance::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageLuminance::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 57 of file vtkImageLuminance.h.

void vtkImageLuminance::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageLuminance.h
Generated on Mon Mar 25 01:19:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMagnify Class Reference

magnify an image by an integer value. More...

#include <vtkImageMagnify.h>

Inheritance diagram for vtkImageMagnify:

[legend]
Collaboration diagram for vtkImageMagnify:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMagnify, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMagnificationFactors (int, int, int)
virtual void | SetMagnificationFactors (int[3])
virtual int * | GetMagnificationFactors ()
virtual void | GetMagnificationFactors (int &, int &, int &)
virtual void | GetMagnificationFactors (int[3])
virtual void | SetInterpolate (int)
virtual int | GetInterpolate ()
virtual void | InterpolateOn ()
virtual void | InterpolateOff ()

Static Public Methods

vtkImageMagnify * | New ()

Protected Methods

vtkImageMagnify ()
~vtkImageMagnify ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | MagnificationFactors [3]
int | Interpolate

Detailed Description

magnify an image by an integer value.

Date:
2002/01/22 15:32:56
Revision:
1.33

vtkImageMagnify maps each pixel of the input onto a nxmx... region of the output. Location (0,0,...) remains in the same place. The magnification occurs via pixel replication, or if Interpolate is on, by bilinear interpolation.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (53%)
  • Martin, Ken (28%)
  • Lorensen, Bill (11%)
Tests:
vtkImageMagnify (Tests)

Definition at line 44 of file vtkImageMagnify.h.

Constructor & Destructor Documentation

vtkImageMagnify::vtkImageMagnify ( ) [protected]

vtkImageMagnify::~vtkImageMagnify ( ) [inline, protected]

Definition at line 67 of file vtkImageMagnify.h.

Member Function Documentation

vtkImageMagnify* vtkImageMagnify::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageMagnify::vtkTypeRevisionMacro | ( | vtkImageMagnify | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageMagnify::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageMagnify::SetMagnificationFactors | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the integer magnification factors in the i-j-k directions.

virtual void vtkImageMagnify::SetMagnificationFactors ( int [3] ) [virtual]

Set/Get the integer magnification factors in the i-j-k directions.

virtual int* vtkImageMagnify::GetMagnificationFactors ( ) [virtual]

Set/Get the integer magnification factors in the i-j-k directions.

virtual void vtkImageMagnify::GetMagnificationFactors | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the integer magnification factors in the i-j-k directions.

virtual void vtkImageMagnify::GetMagnificationFactors ( int [3] ) [virtual]

Set/Get the integer magnification factors in the i-j-k directions.

virtual void vtkImageMagnify::SetInterpolate ( int ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual int vtkImageMagnify::GetInterpolate ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual void vtkImageMagnify::InterpolateOn ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual void vtkImageMagnify::InterpolateOff ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

void vtkImageMagnify::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageMagnify::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageMagnify::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 73 of file vtkImageMagnify.h.

void vtkImageMagnify::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageMagnify::MagnificationFactors[3] [protected]

Definition at line 69 of file vtkImageMagnify.h.

int vtkImageMagnify::Interpolate [protected]

Definition at line 70 of file vtkImageMagnify.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMagnify.h
Generated on Mon Mar 25 01:19:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMagnitude Class Reference

Colapses components with magnitude function.. More...

#include <vtkImageMagnitude.h>

Inheritance diagram for vtkImageMagnitude:

[legend]
Collaboration diagram for vtkImageMagnitude:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMagnitude, vtkImageToImageFilter)

Static Public Methods

vtkImageMagnitude * | New ()

Protected Methods

vtkImageMagnitude ()
~vtkImageMagnitude ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Detailed Description

Colapses components with magnitude function..

Date:
2002/01/22 15:32:58
Revision:
1.24

vtkImageMagnitude takes the magnitude of the components.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (63%)
  • Martin, Ken (27%)
Tests:
vtkImageMagnitude (Tests)

Definition at line 41 of file vtkImageMagnitude.h.

Constructor & Destructor Documentation

vtkImageMagnitude::vtkImageMagnitude ( ) [inline, protected]

Definition at line 48 of file vtkImageMagnitude.h.

vtkImageMagnitude::~vtkImageMagnitude ( ) [inline, protected]

Definition at line 49 of file vtkImageMagnitude.h.

Member Function Documentation

vtkImageMagnitude* vtkImageMagnitude::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageMagnitude::vtkTypeRevisionMacro | ( | vtkImageMagnitude | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageMagnitude::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageMagnitude::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 52 of file vtkImageMagnitude.h.

void vtkImageMagnitude::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMagnitude.h
Generated on Mon Mar 25 01:19:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMandelbrotSource Class Reference

Mandelbrot image. More...

#include <vtkImageMandelbrotSource.h>

Inheritance diagram for vtkImageMandelbrotSource:

[legend]
Collaboration diagram for vtkImageMandelbrotSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMandelbrotSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CopyOriginAndSample (vtkImageMandelbrotSource *source)
void | SetWholeExtent (int extent[6])
void | SetWholeExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetConstantSize (int)
virtual int | GetConstantSize ()
virtual void | ConstantSizeOn ()
virtual void | ConstantSizeOff ()
void | SetProjectionAxes (int x, int y, int z)
void | SetProjectionAxes (int *a)
virtual int * | GetProjectionAxes ()
virtual void | GetProjectionAxes (int &, int &, int &)
virtual void | GetProjectionAxes (int[3])
virtual void | SetOriginCX (double, double, double, double)
virtual void | SetOriginCX (double[4])
virtual double * | GetOriginCX ()
virtual void | GetOriginCX (double &, double &, double &, double &)
virtual void | GetOriginCX (double[4])
virtual void | SetSampleCX (double, double, double, double)
virtual void | SetSampleCX (double[4])
virtual double * | GetSampleCX ()
virtual void | GetSampleCX (double &, double &, double &, double &)
virtual void | GetSampleCX (double[4])
void | SetSizeCX (double cReal, double cImag, double xReal, double xImag)
double * | GetSizeCX ()
void | GetSizeCX (double s[4])
virtual void | SetMaximumNumberOfIterations (unsigned short)
virtual unsigned short | GetMaximumNumberOfIterations ()
void | Zoom (double factor)
void | Pan (double x, double y, double z)
void | SetSample (double v)

Static Public Methods

vtkImageMandelbrotSource * | New ()

Protected Methods

vtkImageMandelbrotSource ()
~vtkImageMandelbrotSource ()
virtual void | ExecuteData (vtkDataObject *outData)
virtual void | ExecuteInformation ()
float | EvaluateSet (double p[4])

Protected Attributes

int | ProjectionAxes [3]
int | WholeExtent [6]
double | OriginCX [4]
double | SampleCX [4]
unsigned short | MaximumNumberOfIterations
double | SizeCX [4]
int | ConstantSize

Detailed Description

Mandelbrot image.

Date:
2002/01/31 14:38:52
Revision:
1.30

vtkImageMandelbrotSource creates an unsigned char image of the Mandelbrot set. The values in the image are the number of iterations it takes for the magnitude of the value to get over 2. The equation repeated is z = z^2 + C (z and C are complex). Initial value of z is zero, and the real value of C is mapped onto the x axis, and the imaginary value of C is mapped onto the Y Axis. I was thinking of extending this source to generate Julia Sets (initial value of Z varies). This would be 4 possible parameters to vary, but there are no more 4d images :( The third dimension (z axis) is the imaginary value of the initial value.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (92%)
Examples:
vtkImageMandelbrotSource (Examples)
Tests:
vtkImageMandelbrotSource (Tests)

Definition at line 50 of file vtkImageMandelbrotSource.h.

Constructor & Destructor Documentation

vtkImageMandelbrotSource::vtkImageMandelbrotSource ( ) [protected]

vtkImageMandelbrotSource::~vtkImageMandelbrotSource ( ) [protected]

Member Function Documentation

vtkImageMandelbrotSource* vtkImageMandelbrotSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageMandelbrotSource::vtkTypeRevisionMacro | ( | vtkImageMandelbrotSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageMandelbrotSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageMandelbrotSource::SetWholeExtent ( int extent[6] )

Set/Get the extent of the whole output Volume.

void vtkImageMandelbrotSource::SetWholeExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

Set/Get the extent of the whole output Volume.

virtual int* vtkImageMandelbrotSource::GetWholeExtent ( ) [virtual]

Set/Get the extent of the whole output Volume.

virtual void vtkImageMandelbrotSource::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the extent of the whole output Volume.

virtual void vtkImageMandelbrotSource::GetWholeExtent ( int [6] ) [virtual]

Set/Get the extent of the whole output Volume.

virtual void vtkImageMandelbrotSource::SetConstantSize ( int ) [virtual]

This flag determines whether the Size or spacing of a data set remain constant (when extent is changed). By default, size remains constant.

virtual int vtkImageMandelbrotSource::GetConstantSize ( ) [virtual]

This flag determines whether the Size or spacing of a data set remain constant (when extent is changed). By default, size remains constant.

virtual void vtkImageMandelbrotSource::ConstantSizeOn ( ) [virtual]

This flag determines whether the Size or spacing of a data set remain constant (when extent is changed). By default, size remains constant.

virtual void vtkImageMandelbrotSource::ConstantSizeOff ( ) [virtual]

This flag determines whether the Size or spacing of a data set remain constant (when extent is changed). By default, size remains constant.

void vtkImageMandelbrotSource::SetProjectionAxes | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |

Set the projection from the 4D space (4 parameters / 2 imaginary numbers) to the axes of the 3D Volume. 0=C_Real, 1=C_Imaginary, 2=X_Real, 4=X_Imaginary

void vtkImageMandelbrotSource::SetProjectionAxes ( int * a ) [inline]

Set the projection from the 4D space (4 parameters / 2 imaginary numbers) to the axes of the 3D Volume. 0=C_Real, 1=C_Imaginary, 2=X_Real, 4=X_Imaginary

Definition at line 78 of file vtkImageMandelbrotSource.h.

virtual int* vtkImageMandelbrotSource::GetProjectionAxes ( ) [virtual]

Set the projection from the 4D space (4 parameters / 2 imaginary numbers) to the axes of the 3D Volume. 0=C_Real, 1=C_Imaginary, 2=X_Real, 4=X_Imaginary

virtual void vtkImageMandelbrotSource::GetProjectionAxes | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the projection from the 4D space (4 parameters / 2 imaginary numbers) to the axes of the 3D Volume. 0=C_Real, 1=C_Imaginary, 2=X_Real, 4=X_Imaginary

virtual void vtkImageMandelbrotSource::GetProjectionAxes ( int [3] ) [virtual]

Set the projection from the 4D space (4 parameters / 2 imaginary numbers) to the axes of the 3D Volume. 0=C_Real, 1=C_Imaginary, 2=X_Real, 4=X_Imaginary

virtual void vtkImageMandelbrotSource::SetOriginCX | ( | double | ,
 |  | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::SetOriginCX ( double [4] ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual double* vtkImageMandelbrotSource::GetOriginCX ( ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::GetOriginCX | ( | double & | ,
 |  | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::GetOriginCX ( double [4] ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::SetSampleCX | ( | double | ,
 |  | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::SetSampleCX ( double [4] ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual double* vtkImageMandelbrotSource::GetSampleCX ( ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::GetSampleCX | ( | double & | ,
 |  | double & | ,
 |  | double & | ,
 |  | double & |
 | ) | [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

virtual void vtkImageMandelbrotSource::GetSampleCX ( double [4] ) [virtual]

Imaginary and real value for C (constant in equation) and X (initial value).

void vtkImageMandelbrotSource::SetSizeCX | ( | double | cReal,
 |  | double | cImag,
 |  | double | xReal,
 |  | double | xImag
 | ) |

Just a different way of setting the sample. This sets the size of the 4D volume. SampleCX is computed from size and extent. Size is ignored when a dimension i 0 (collapsed).

double* vtkImageMandelbrotSource::GetSizeCX ( )

Just a different way of setting the sample. This sets the size of the 4D volume. SampleCX is computed from size and extent. Size is ignored when a dimension i 0 (collapsed).

void vtkImageMandelbrotSource::GetSizeCX ( double s[4] )

Just a different way of setting the sample. This sets the size of the 4D volume. SampleCX is computed from size and extent. Size is ignored when a dimension i 0 (collapsed).

virtual void vtkImageMandelbrotSource::SetMaximumNumberOfIterations ( unsigned short ) [virtual]

The maximum number of cycles run to see if the value goes over 2

virtual unsigned short vtkImageMandelbrotSource::GetMaximumNumberOfIterations ( ) [virtual]

The maximum number of cycles run to see if the value goes over 2

void vtkImageMandelbrotSource::Zoom ( double factor )

Convienence for Viewer. Pan 3D volume relative to spacing. Zoom constant factor.

void vtkImageMandelbrotSource::Pan | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

Convienence for Viewer. Pan 3D volume relative to spacing. Zoom constant factor.

void vtkImageMandelbrotSource::CopyOriginAndSample ( vtkImageMandelbrotSource * source )

Convienence for Viewer. Copy the OriginCX and the SpacingCX. What about other parameters ???

void vtkImageMandelbrotSource::SetSample ( double v ) [inline]

Convienence/Legacy - set all the spacing values the same.

Definition at line 127 of file vtkImageMandelbrotSource.h.

virtual void vtkImageMandelbrotSource::ExecuteData ( vtkDataObject * outData ) [protected, virtual]

virtual void vtkImageMandelbrotSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

float vtkImageMandelbrotSource::EvaluateSet ( double p[4] ) [protected]

Member Data Documentation

int vtkImageMandelbrotSource::ProjectionAxes[3] [protected]

Definition at line 136 of file vtkImageMandelbrotSource.h.

int vtkImageMandelbrotSource::WholeExtent[6] [protected]

Definition at line 139 of file vtkImageMandelbrotSource.h.

double vtkImageMandelbrotSource::OriginCX[4] [protected]

Definition at line 142 of file vtkImageMandelbrotSource.h.

double vtkImageMandelbrotSource::SampleCX[4] [protected]

Definition at line 144 of file vtkImageMandelbrotSource.h.

unsigned short vtkImageMandelbrotSource::MaximumNumberOfIterations [protected]

Definition at line 145 of file vtkImageMandelbrotSource.h.

double vtkImageMandelbrotSource::SizeCX[4] [protected]

Definition at line 149 of file vtkImageMandelbrotSource.h.

int vtkImageMandelbrotSource::ConstantSize [protected]

Definition at line 152 of file vtkImageMandelbrotSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMandelbrotSource.h
Generated on Mon Mar 25 01:19:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapper Class Reference

2D image display. More...

#include <vtkImageMapper.h>

Inheritance diagram for vtkImageMapper:

[legend]
Collaboration diagram for vtkImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMapper, vtkMapper2D)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
void | RenderStart (vtkViewport *viewport, vtkActor2D *actor)
virtual void | RenderData (vtkViewport *, vtkImageData *, vtkActor2D *)=0
virtual void | SetColorWindow (float)
virtual float | GetColorWindow ()
virtual void | SetColorLevel (float)
virtual float | GetColorLevel ()
virtual void | SetZSlice (int)
virtual int | GetZSlice ()
int | GetWholeZMin ()
int | GetWholeZMax ()
float | GetColorShift ()
float | GetColorScale ()
virtual void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | SetRenderToRectangle (int)
virtual int | GetRenderToRectangle ()
virtual void | RenderToRectangleOn ()
virtual void | RenderToRectangleOff ()
virtual void | SetUseCustomExtents (int)
virtual int | GetUseCustomExtents ()
virtual void | UseCustomExtentsOn ()
virtual void | UseCustomExtentsOff ()
virtual void | SetCustomDisplayExtents (int data[])
virtual int * | GetCustomDisplayExtents ()
virtual void | GetCustomDisplayExtents (int data[4])

Static Public Methods

vtkImageMapper * | New ()

Public Attributes

int | DisplayExtent [6]

Protected Methods

vtkImageMapper ()
~vtkImageMapper ()

Protected Attributes

float | ColorWindow
float | ColorLevel
int | PositionAdjustment [2]
int | ZSlice
int | UseCustomExtents
int | CustomDisplayExtents [4]
int | RenderToRectangle

Detailed Description

2D image display.

Date:
2002/01/22 15:38:33
Revision:
1.30

vtkImageMapper provides 2D image display support for vtk. It is a Mapper2D subclass that can be associated with an Actor2D and placed within a RenderWindow or ImageWindow.

See also:
vtkMapper2D vtkActor2D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (55%)
  • Biddiscombe, John (22%)
  • Yamrom, Boris (10%)
  • Law, Charles (6%)
Tests:
vtkImageMapper (Tests)

Definition at line 52 of file vtkImageMapper.h.

Constructor & Destructor Documentation

vtkImageMapper::vtkImageMapper ( ) [protected]

vtkImageMapper::~vtkImageMapper ( ) [protected]

Member Function Documentation

vtkImageMapper::vtkTypeRevisionMacro | ( | vtkImageMapper | ,
 |  | vtkMapper2D |
 | ) |

Reimplemented from vtkMapper2D.

Reimplemented in vtkMesaImageMapper, vtkOpenGLImageMapper, vtkQuartzImageMapper, vtkWin32ImageMapper, and vtkXImageMapper.

vtkImageMapper* vtkImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkMapper2D.

Reimplemented in vtkMesaImageMapper, vtkOpenGLImageMapper, vtkQuartzImageMapper, vtkWin32ImageMapper, and vtkXImageMapper.

void vtkImageMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper2D.

Reimplemented in vtkWin32ImageMapper, and vtkXImageMapper.

unsigned long int vtkImageMapper::GetMTime ( ) [virtual]

Override Modifiedtime as we have added a lookuptable

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkWin32ImageMapper.

virtual void vtkImageMapper::SetColorWindow ( float ) [virtual]

Set/Get the window value for window/level

virtual float vtkImageMapper::GetColorWindow ( ) [virtual]

Set/Get the window value for window/level

virtual void vtkImageMapper::SetColorLevel ( float ) [virtual]

Set/Get the level value for window/level

virtual float vtkImageMapper::GetColorLevel ( ) [virtual]

Set/Get the level value for window/level

virtual void vtkImageMapper::SetZSlice ( int ) [virtual]

Set/Get the current slice number. The axis Z in ZSlice does not necessarily have any relation to the z axis of the data on disk. It is simply the axis orthogonal to the x,y, display plane. GetWholeZMax and Min are convenience methods for obtaining the number of slices that can be displayed. Again the number of slices is in reference to the display z axis, which is not necessarily the z axis on disk. (due to reformatting etc)

virtual int vtkImageMapper::GetZSlice ( ) [virtual]

Set/Get the current slice number. The axis Z in ZSlice does not necessarily have any relation to the z axis of the data on disk. It is simply the axis orthogonal to the x,y, display plane. GetWholeZMax and Min are convenience methods for obtaining the number of slices that can be displayed. Again the number of slices is in reference to the display z axis, which is not necessarily the z axis on disk. (due to reformatting etc)

int vtkImageMapper::GetWholeZMin ( )

Set/Get the current slice number. The axis Z in ZSlice does not necessarily have any relation to the z axis of the data on disk. It is simply the axis orthogonal to the x,y, display plane. GetWholeZMax and Min are convenience methods for obtaining the number of slices that can be displayed. Again the number of slices is in reference to the display z axis, which is not necessarily the z axis on disk. (due to reformatting etc)

int vtkImageMapper::GetWholeZMax ( )

Set/Get the current slice number. The axis Z in ZSlice does not necessarily have any relation to the z axis of the data on disk. It is simply the axis orthogonal to the x,y, display plane. GetWholeZMax and Min are convenience methods for obtaining the number of slices that can be displayed. Again the number of slices is in reference to the display z axis, which is not necessarily the z axis on disk. (due to reformatting etc)

void vtkImageMapper::RenderStart | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) |

Draw the image to the screen.

Referenced by vtkOpenGLImageMapper::RenderOpaqueGeometry(), vtkMesaImageMapper::RenderOpaqueGeometry(), vtkXImageMapper::RenderOverlay(), vtkWin32ImageMapper::RenderOverlay(), and vtkQuartzImageMapper::RenderOverlay().

virtual void vtkImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [pure virtual]

Function called by Render to actually draw the image to to the screen

Reimplemented in vtkMesaImageMapper, vtkOpenGLImageMapper, vtkQuartzImageMapper, vtkWin32ImageMapper, and vtkXImageMapper.

float vtkImageMapper::GetColorShift ( )

Methods used internally for performing the Window/Level mapping.

float vtkImageMapper::GetColorScale ( )

Methods used internally for performing the Window/Level mapping.

virtual void vtkImageMapper::SetInput ( vtkImageData * input ) [virtual]

Set the Input of a filter.

vtkImageData* vtkImageMapper::GetInput ( )

Set the Input of a filter.

virtual void vtkImageMapper::SetRenderToRectangle ( int ) [virtual]

If RenderToRectangle is set (by default not), then the imagemapper will render the image into the rectangle supplied by the Actor2D's PositionCoordinate and Position2Coordinate

virtual int vtkImageMapper::GetRenderToRectangle ( ) [virtual]

If RenderToRectangle is set (by default not), then the imagemapper will render the image into the rectangle supplied by the Actor2D's PositionCoordinate and Position2Coordinate

virtual void vtkImageMapper::RenderToRectangleOn ( ) [virtual]

If RenderToRectangle is set (by default not), then the imagemapper will render the image into the rectangle supplied by the Actor2D's PositionCoordinate and Position2Coordinate

virtual void vtkImageMapper::RenderToRectangleOff ( ) [virtual]

If RenderToRectangle is set (by default not), then the imagemapper will render the image into the rectangle supplied by the Actor2D's PositionCoordinate and Position2Coordinate

virtual void vtkImageMapper::SetUseCustomExtents ( int ) [virtual]

Usually, the entire image is displayed, if UseCustomExtents is set (by default not), then the region supplied in the CustomDisplayExtents is used in preference. Note that the Custom extents are x,y only and the zslice is still applied

virtual int vtkImageMapper::GetUseCustomExtents ( ) [virtual]

Usually, the entire image is displayed, if UseCustomExtents is set (by default not), then the region supplied in the CustomDisplayExtents is used in preference. Note that the Custom extents are x,y only and the zslice is still applied

virtual void vtkImageMapper::UseCustomExtentsOn ( ) [virtual]

Usually, the entire image is displayed, if UseCustomExtents is set (by default not), then the region supplied in the CustomDisplayExtents is used in preference. Note that the Custom extents are x,y only and the zslice is still applied

virtual void vtkImageMapper::UseCustomExtentsOff ( ) [virtual]

Usually, the entire image is displayed, if UseCustomExtents is set (by default not), then the region supplied in the CustomDisplayExtents is used in preference. Note that the Custom extents are x,y only and the zslice is still applied

virtual void vtkImageMapper::SetCustomDisplayExtents ( int data[] ) [virtual]

The image extents which should be displayed with UseCustomExtents Note that the Custom extents are x,y only and the zslice is still applied

virtual int* vtkImageMapper::GetCustomDisplayExtents ( ) [virtual]

The image extents which should be displayed with UseCustomExtents Note that the Custom extents are x,y only and the zslice is still applied

virtual void vtkImageMapper::GetCustomDisplayExtents ( int data[4] ) [virtual]

The image extents which should be displayed with UseCustomExtents Note that the Custom extents are x,y only and the zslice is still applied

Member Data Documentation

int vtkImageMapper::DisplayExtent[6]

Definition at line 101 of file vtkImageMapper.h.

float vtkImageMapper::ColorWindow [protected]

Definition at line 140 of file vtkImageMapper.h.

float vtkImageMapper::ColorLevel [protected]

Definition at line 141 of file vtkImageMapper.h.

int vtkImageMapper::PositionAdjustment[2] [protected]

Definition at line 143 of file vtkImageMapper.h.

int vtkImageMapper::ZSlice [protected]

Definition at line 144 of file vtkImageMapper.h.

int vtkImageMapper::UseCustomExtents [protected]

Definition at line 145 of file vtkImageMapper.h.

int vtkImageMapper::CustomDisplayExtents[4] [protected]

Definition at line 146 of file vtkImageMapper.h.

int vtkImageMapper::RenderToRectangle [protected]

Definition at line 147 of file vtkImageMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImageMapper.h
Generated on Mon Mar 25 01:19:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToColors Class Reference

map the input image through a lookup table. More...

#include <vtkImageMapToColors.h>

Inheritance diagram for vtkImageMapToColors:

[legend]
Collaboration diagram for vtkImageMapToColors:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMapToColors, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetLookupTable (vtkScalarsToColors *)
virtual vtkScalarsToColors * | GetLookupTable ()
virtual void | SetOutputFormat (int)
virtual int | GetOutputFormat ()
void | SetOutputFormatToRGBA ()
void | SetOutputFormatToRGB ()
void | SetOutputFormatToLuminanceAlpha ()
void | SetOutputFormatToLuminance ()
virtual void | SetActiveComponent (int)
virtual int | GetActiveComponent ()
virtual void | SetPassAlphaToOutput (int)
virtual void | PassAlphaToOutputOn ()
virtual void | PassAlphaToOutputOff ()
virtual int | GetPassAlphaToOutput ()

Static Public Methods

vtkImageMapToColors * | New ()

Protected Methods

vtkImageMapToColors ()
~vtkImageMapToColors ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)
void | ExecuteData (vtkDataObject *output)

Protected Attributes

vtkScalarsToColors * LookupTable
int | OutputFormat
int | ActiveComponent
int | PassAlphaToOutput
int | DataWasPassed

Detailed Description

map the input image through a lookup table.

Date:
2002/01/22 15:33:00
Revision:
1.18

The vtkImageMapToColors filter will take an input image of any valid scalar type, and map the first component of the image through a lookup table. The result is an image of type VTK_UNSIGNED_CHAR. If the lookup table is not set, or is set to NULL, then the input data will be passed through if it is already of type UNSIGNED_CHAR.

See also:
vtkLookupTable vtkScalarsToColors
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (94%)
Tests:
vtkImageMapToColors (Tests)

Definition at line 48 of file vtkImageMapToColors.h.

Constructor & Destructor Documentation

vtkImageMapToColors::vtkImageMapToColors ( ) [protected]

vtkImageMapToColors::~vtkImageMapToColors ( ) [protected]

Member Function Documentation

vtkImageMapToColors* vtkImageMapToColors::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToRGBA, and vtkImageMapToWindowLevelColors.

vtkImageMapToColors::vtkTypeRevisionMacro | ( | vtkImageMapToColors | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToRGBA, and vtkImageMapToWindowLevelColors.

void vtkImageMapToColors::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToWindowLevelColors.

virtual void vtkImageMapToColors::SetLookupTable ( vtkScalarsToColors * ) [virtual]

Set the lookup table.

virtual vtkScalarsToColors* vtkImageMapToColors::GetLookupTable ( ) [virtual]

Set the lookup table.

virtual void vtkImageMapToColors::SetOutputFormat ( int ) [virtual]

Set the output format, the default is RGBA.

virtual int vtkImageMapToColors::GetOutputFormat ( ) [virtual]

Set the output format, the default is RGBA.

void vtkImageMapToColors::SetOutputFormatToRGBA ( ) [inline]

Set the output format, the default is RGBA.

Definition at line 65 of file vtkImageMapToColors.h.

void vtkImageMapToColors::SetOutputFormatToRGB ( ) [inline]

Set the output format, the default is RGBA.

Definition at line 66 of file vtkImageMapToColors.h.

void vtkImageMapToColors::SetOutputFormatToLuminanceAlpha ( ) [inline]

Set the output format, the default is RGBA.

Definition at line 67 of file vtkImageMapToColors.h.

void vtkImageMapToColors::SetOutputFormatToLuminance ( ) [inline]

Set the output format, the default is RGBA.

Definition at line 68 of file vtkImageMapToColors.h.

virtual void vtkImageMapToColors::SetActiveComponent ( int ) [virtual]

Set the component to map for multi-component images (default: 0)

virtual int vtkImageMapToColors::GetActiveComponent ( ) [virtual]

Set the component to map for multi-component images (default: 0)

virtual void vtkImageMapToColors::SetPassAlphaToOutput ( int ) [virtual]

Use the alpha component of the input when computing the alpha component of the output (useful when converting monochrome+alpha data to RGBA)

virtual void vtkImageMapToColors::PassAlphaToOutputOn ( ) [virtual]

Use the alpha component of the input when computing the alpha component of the output (useful when converting monochrome+alpha data to RGBA)

virtual void vtkImageMapToColors::PassAlphaToOutputOff ( ) [virtual]

Use the alpha component of the input when computing the alpha component of the output (useful when converting monochrome+alpha data to RGBA)

virtual int vtkImageMapToColors::GetPassAlphaToOutput ( ) [virtual]

Use the alpha component of the input when computing the alpha component of the output (useful when converting monochrome+alpha data to RGBA)

unsigned long vtkImageMapToColors::GetMTime ( ) [virtual]

We need to check the modified time of the lookup table too.

Reimplemented from vtkObject.

void vtkImageMapToColors::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToWindowLevelColors.

void vtkImageMapToColors::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToWindowLevelColors.

Definition at line 94 of file vtkImageMapToColors.h.

Referenced by vtkImageMapToWindowLevelColors::ExecuteInformation().

void vtkImageMapToColors::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToWindowLevelColors.

void vtkImageMapToColors::ExecuteData ( vtkDataObject * output ) [protected]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMapToWindowLevelColors.

Member Data Documentation

vtkScalarsToColors* vtkImageMapToColors::LookupTable [protected]

Definition at line 101 of file vtkImageMapToColors.h.

int vtkImageMapToColors::OutputFormat [protected]

Definition at line 102 of file vtkImageMapToColors.h.

int vtkImageMapToColors::ActiveComponent [protected]

Definition at line 104 of file vtkImageMapToColors.h.

int vtkImageMapToColors::PassAlphaToOutput [protected]

Definition at line 105 of file vtkImageMapToColors.h.

int vtkImageMapToColors::DataWasPassed [protected]

Definition at line 107 of file vtkImageMapToColors.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMapToColors.h
Generated on Mon Mar 25 01:19:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToRGBA Class Reference

map the input image through a lookup table. More...

#include <vtkImageMapToRGBA.h>

Inheritance diagram for vtkImageMapToRGBA:

[legend]
Collaboration diagram for vtkImageMapToRGBA:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMapToRGBA, vtkImageMapToColors)

Static Public Methods

vtkImageMapToRGBA * New ()

Protected Methods

vtkImageMapToRGBA ()
~vtkImageMapToRGBA ()

Detailed Description

map the input image through a lookup table.

Date:
2002/01/22 15:33:01
Revision:
1.20

This filter has been replaced by vtkImageMapToColors, which provided additional features. Use vtkImageMapToColors instead.

See also:
vtkLookupTable
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (77%)
  • Law, Charles (10%)
  • Lorensen, Bill (6%)
  • Martin, Ken (5%)
Examples:
vtkImageMapToRGBA (Examples)
Tests:
vtkImageMapToRGBA (Tests)

Definition at line 50 of file vtkImageMapToRGBA.h.

Constructor & Destructor Documentation

vtkImageMapToRGBA::vtkImageMapToRGBA ( ) [inline, protected]

Definition at line 57 of file vtkImageMapToRGBA.h.

vtkImageMapToRGBA::~vtkImageMapToRGBA ( ) [inline, protected]

Definition at line 58 of file vtkImageMapToRGBA.h.

Member Function Documentation

vtkImageMapToRGBA* vtkImageMapToRGBA::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapToColors.

vtkImageMapToRGBA::vtkTypeRevisionMacro | ( | vtkImageMapToRGBA | ,
 |  | vtkImageMapToColors |
 | ) |

Reimplemented from vtkImageMapToColors.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMapToRGBA.h
Generated on Mon Mar 25 01:19:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMapToWindowLevelColors Class Reference

map the input image through a lookup table and window / level it. More...

#include <vtkImageMapToWindowLevelColors.h>

Inheritance diagram for vtkImageMapToWindowLevelColors:

[legend]
Collaboration diagram for vtkImageMapToWindowLevelColors:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMapToWindowLevelColors, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetWindow (float)
virtual float | GetWindow ()
virtual void | SetLevel (float)
virtual float | GetLevel ()

Static Public Methods

vtkImageMapToWindowLevelColors * | New ()

Protected Methods

vtkImageMapToWindowLevelColors ()
~vtkImageMapToWindowLevelColors ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)
void | ExecuteData (vtkDataObject *output)

Protected Attributes

float | Window
float | Level

Detailed Description

map the input image through a lookup table and window / level it.

Date:
2002/01/22 15:33:02
Revision:
1.9

The vtkImageMapToWindowLevelColors filter will take an input image of any valid scalar type, and map the first component of the image through a lookup table. This resulting color will be modulated with value obtained by a window / level operation. The result is an image of type VTK_UNSIGNED_CHAR. If the lookup table is not set, or is set to NULL, then the input data will be passed through if it is already of type UNSIGNED_CHAR.

See also:
vtkLookupTable vtkScalarsToColors
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (68%)
  • Martin, Ken (25%)
Tests:
vtkImageMapToWindowLevelColors (Tests)

Definition at line 50 of file vtkImageMapToWindowLevelColors.h.

Constructor & Destructor Documentation

vtkImageMapToWindowLevelColors::vtkImageMapToWindowLevelColors ( ) [protected]

vtkImageMapToWindowLevelColors::~vtkImageMapToWindowLevelColors ( ) [protected]

Member Function Documentation

vtkImageMapToWindowLevelColors* vtkImageMapToWindowLevelColors::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapToColors.

vtkImageMapToWindowLevelColors::vtkTypeRevisionMacro | ( | vtkImageMapToWindowLevelColors | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageMapToColors.

void vtkImageMapToWindowLevelColors::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMapToColors.

virtual void vtkImageMapToWindowLevelColors::SetWindow ( float ) [virtual]

Set / Get the Window to use -> modulation will be performed on the color based on (S - (L - W/2))/W where S is the scalar value, L is the level and W is the window.

virtual float vtkImageMapToWindowLevelColors::GetWindow ( ) [virtual]

Set / Get the Window to use -> modulation will be performed on the color based on (S - (L - W/2))/W where S is the scalar value, L is the level and W is the window.

virtual void vtkImageMapToWindowLevelColors::SetLevel ( float ) [virtual]

Set / Get the Level to use -> modulation will be performed on the color based on (S - (L - W/2))/W where S is the scalar value, L is the level and W is the window.

virtual float vtkImageMapToWindowLevelColors::GetLevel ( ) [virtual]

Set / Get the Level to use -> modulation will be performed on the color based on (S - (L - W/2))/W where S is the scalar value, L is the level and W is the window.

void vtkImageMapToWindowLevelColors::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMapToColors.

void vtkImageMapToWindowLevelColors::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMapToColors.

Definition at line 78 of file vtkImageMapToWindowLevelColors.h.

void vtkImageMapToWindowLevelColors::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageMapToColors.

void vtkImageMapToWindowLevelColors::ExecuteData ( vtkDataObject * output ) [protected]

Reimplemented from vtkImageMapToColors.

Member Data Documentation

float vtkImageMapToWindowLevelColors::Window [protected]

Definition at line 83 of file vtkImageMapToWindowLevelColors.h.

float vtkImageMapToWindowLevelColors::Level [protected]

Definition at line 84 of file vtkImageMapToWindowLevelColors.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMapToWindowLevelColors.h
Generated on Mon Mar 25 01:19:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMarchingCubes Class Reference

generate isosurface(s) from volume/images. More...

#include <vtkImageMarchingCubes.h>

Inheritance diagram for vtkImageMarchingCubes:

[legend]
Collaboration diagram for vtkImageMarchingCubes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMarchingCubes, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetValue (int i, float value)
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
unsigned long int | GetMTime ()
int | GetLocatorPoint (int cellX, int cellY, int edge)
void | AddLocatorPoint (int cellX, int cellY, int edge, int ptId)
void | IncrementLocatorZ ()
void | Update ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
float | GetValue (int i)
float * | GetValues ()
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetInputMemoryLimit (int)
virtual int | GetInputMemoryLimit ()

Static Public Methods

vtkImageMarchingCubes * | New ()

Public Attributes

int | ComputeScalars
int | ComputeNormals
int | ComputeGradients
int | NeedGradients
vtkCellArray * Triangles
vtkFloatArray * Scalars
vtkPoints * Points
vtkFloatArray * Normals
vtkFloatArray * Gradients

Protected Methods

vtkImageMarchingCubes ()
~vtkImageMarchingCubes ()
void | Execute ()
void | March (vtkImageData *inData, int chunkMin, int chunkMax, int numContours, float *values)
void | InitializeLocator (int min0, int max0, int min1, int max1)
void | DeleteLocator ()
int * | GetLocatorPointer (int cellX, int cellY, int edge)

Protected Attributes

int | NumberOfSlicesPerChunk
int | InputMemoryLimit
vtkContourValues * ContourValues
int * | LocatorPointIds
int | LocatorDimX
int | LocatorDimY
int | LocatorMinX
int | LocatorMinY

Detailed Description

generate isosurface(s) from volume/images.

Date:
2002/01/22 22:02:21
Revision:
1.33

vtkImageMarchingCubes is a filter that takes as input images (e.g., 3D image region) and generates on output one or more isosurfaces. One or more contour values must be specified to generate the isosurfaces. Alternatively, you can specify a min/max scalar range and the number of contours to generate a series of evenly spaced contour values. This filter can stream, so that the entire volume need not be loaded at once. Streaming is controlled using the instance variable InputMemoryLimit, which has units KBytes.

Warning:
This filter is specialized to volumes. If you are interested in contouring other types of data, use the general vtkContourFilter. If you want to contour an image (i.e., a volume slice), use vtkMarchingSquares.
See also:
vtkContourFilter vtkSliceCubes vtkMarchingSquares vtkDividingCubes
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (69%)
  • Lorensen, Bill (9%)
  • Schroeder, Will (7%)
Tests:
vtkImageMarchingCubes (Tests)

Definition at line 77 of file vtkImageMarchingCubes.h.

Constructor & Destructor Documentation

vtkImageMarchingCubes::vtkImageMarchingCubes ( ) [protected]

vtkImageMarchingCubes::~vtkImageMarchingCubes ( ) [protected]

Member Function Documentation

vtkImageMarchingCubes* vtkImageMarchingCubes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkImageMarchingCubes::vtkTypeRevisionMacro | ( | vtkImageMarchingCubes | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkImageMarchingCubes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageMarchingCubes::SetInput ( vtkImageData * input )

Set/Get the source for the scalar data to contour.

vtkImageData* vtkImageMarchingCubes::GetInput ( )

Set/Get the source for the scalar data to contour.

void vtkImageMarchingCubes::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 187 of file vtkImageMarchingCubes.h.

float vtkImageMarchingCubes::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 192 of file vtkImageMarchingCubes.h.

float * vtkImageMarchingCubes::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 199 of file vtkImageMarchingCubes.h.

void vtkImageMarchingCubes::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 206 of file vtkImageMarchingCubes.h.

void vtkImageMarchingCubes::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 212 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 217 of file vtkImageMarchingCubes.h.

void vtkImageMarchingCubes::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 224 of file vtkImageMarchingCubes.h.

void vtkImageMarchingCubes::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 231 of file vtkImageMarchingCubes.h.

unsigned long int vtkImageMarchingCubes::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented from vtkObject.

virtual void vtkImageMarchingCubes::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkImageMarchingCubes::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkImageMarchingCubes::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkImageMarchingCubes::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkImageMarchingCubes::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkImageMarchingCubes::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkImageMarchingCubes::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkImageMarchingCubes::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkImageMarchingCubes::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkImageMarchingCubes::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkImageMarchingCubes::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkImageMarchingCubes::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

int vtkImageMarchingCubes::GetLocatorPoint | ( | int | cellX,
 |  | int | cellY,
 |  | int | edge
 | ) |

void vtkImageMarchingCubes::AddLocatorPoint | ( | int | cellX,
 |  | int | cellY,
 |  | int | edge,
 |  | int | ptId
 | ) |

void vtkImageMarchingCubes::IncrementLocatorZ ( )

void vtkImageMarchingCubes::Update ( ) [virtual]

Bring object up-to-date before execution. Update() checks modified time against last execution time, and re-executes object if necessary.

Reimplemented from vtkSource.

virtual void vtkImageMarchingCubes::SetInputMemoryLimit ( int ) [virtual]

The InputMemoryLimit determines the chunk size (the number of slices requested at each iteration). The units of this limit is KiloBytes. For now, only the Z axis is split.

virtual int vtkImageMarchingCubes::GetInputMemoryLimit ( ) [virtual]

The InputMemoryLimit determines the chunk size (the number of slices requested at each iteration). The units of this limit is KiloBytes. For now, only the Z axis is split.

void vtkImageMarchingCubes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkImageMarchingCubes::March | ( | vtkImageData * | inData,
 |  | int | chunkMin,
 |  | int | chunkMax,
 |  | int | numContours,
 |  | float * | values
 | ) | [protected]

void vtkImageMarchingCubes::InitializeLocator | ( | int | min0,
 |  | int | max0,
 |  | int | min1,
 |  | int | max1
 | ) | [protected]

void vtkImageMarchingCubes::DeleteLocator ( ) [protected]

int* vtkImageMarchingCubes::GetLocatorPointer | ( | int | cellX,
 |  | int | cellY,
 |  | int | edge
 | ) | [protected]

Member Data Documentation

int vtkImageMarchingCubes::ComputeScalars

Definition at line 133 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::ComputeNormals

Definition at line 134 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::ComputeGradients

Definition at line 135 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::NeedGradients

Definition at line 136 of file vtkImageMarchingCubes.h.

vtkCellArray* vtkImageMarchingCubes::Triangles

Definition at line 138 of file vtkImageMarchingCubes.h.

vtkFloatArray* vtkImageMarchingCubes::Scalars

Definition at line 139 of file vtkImageMarchingCubes.h.

vtkPoints* vtkImageMarchingCubes::Points

Definition at line 140 of file vtkImageMarchingCubes.h.

vtkFloatArray* vtkImageMarchingCubes::Normals

Definition at line 141 of file vtkImageMarchingCubes.h.

vtkFloatArray* vtkImageMarchingCubes::Gradients

Definition at line 142 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::NumberOfSlicesPerChunk [protected]

Definition at line 162 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::InputMemoryLimit [protected]

Definition at line 163 of file vtkImageMarchingCubes.h.

vtkContourValues* vtkImageMarchingCubes::ContourValues [protected]

Definition at line 165 of file vtkImageMarchingCubes.h.

int* vtkImageMarchingCubes::LocatorPointIds [protected]

Definition at line 167 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::LocatorDimX [protected]

Definition at line 168 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::LocatorDimY [protected]

Definition at line 169 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::LocatorMinX [protected]

Definition at line 170 of file vtkImageMarchingCubes.h.

int vtkImageMarchingCubes::LocatorMinY [protected]

Definition at line 171 of file vtkImageMarchingCubes.h.

The documentation for this class was generated from the following file:
  • Patented/vtkImageMarchingCubes.h
Generated on Mon Mar 25 01:19:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMask Class Reference

Combines a mask and an image. More...

#include <vtkImageMask.h>

Inheritance diagram for vtkImageMask:

[legend]
Collaboration diagram for vtkImageMask:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMask, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetImageInput (vtkImageData *in)
void | SetMaskInput (vtkImageData *in)
void | SetMaskedOutputValue (int num, float *v)
void | SetMaskedOutputValue (float v)
void | SetMaskedOutputValue (float v1, float v2)
void | SetMaskedOutputValue (float v1, float v2, float v3)
float * | GetMaskedOutputValue ()
int | GetMaskedOutputValueLength ()
virtual void | SetMaskAlpha (float)
virtual float | GetMaskAlpha ()
virtual void | SetNotMask (int)
virtual int | GetNotMask ()
virtual void | NotMaskOn ()
virtual void | NotMaskOff ()

Static Public Methods

vtkImageMask * | New ()

Protected Methods

vtkImageMask ()
~vtkImageMask ()
void | ExecuteInformation (vtkImageData **inDatas, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

float * | MaskedOutputValue
int | MaskedOutputValueLength
int | NotMask
float | MaskAlpha

Detailed Description

Combines a mask and an image.

Date:
2002/02/13 15:46:18
Revision:
1.33

vtkImageMask combines a mask with an image. Non zero mask implies the output pixel will be the same as the image. If a mask pixel is zero, the the output pixel is set to "MaskedValue". The filter also has the option to pass the mask through a boolean not operation before processing the image. This reverses the passed and replaced pixels. The two inputs should have the same "WholeExtent". The mask input should be unsigned char, and the image scalar type is the same as the output scalar type.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (68%)
  • Martin, Ken (8%)
  • Blezek, Dan (8%)
  • Lorensen, Bill (6%)
Tests:
vtkImageMask (Tests)

Definition at line 51 of file vtkImageMask.h.

Constructor & Destructor Documentation

vtkImageMask::vtkImageMask ( ) [protected]

vtkImageMask::~vtkImageMask ( ) [protected]

Member Function Documentation

vtkImageMask* vtkImageMask::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageMask::vtkTypeRevisionMacro | ( | vtkImageMask | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageMask::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageMask::SetMaskedOutputValue | ( | int | num,
 |  | float * | v
 | ) |

SetGet the value of the output pixel replaced by mask.

void vtkImageMask::SetMaskedOutputValue ( float v ) [inline]

SetGet the value of the output pixel replaced by mask.

Definition at line 61 of file vtkImageMask.h.

void vtkImageMask::SetMaskedOutputValue | ( | float | v1,
 |  | float | v2
 | ) | [inline]

SetGet the value of the output pixel replaced by mask.

Definition at line 62 of file vtkImageMask.h.

void vtkImageMask::SetMaskedOutputValue | ( | float | v1,
 |  | float | v2,
 |  | float | v3
 | ) | [inline]

SetGet the value of the output pixel replaced by mask.

Definition at line 64 of file vtkImageMask.h.

float* vtkImageMask::GetMaskedOutputValue ( ) [inline]

SetGet the value of the output pixel replaced by mask.

Definition at line 66 of file vtkImageMask.h.

int vtkImageMask::GetMaskedOutputValueLength ( ) [inline]

SetGet the value of the output pixel replaced by mask.

Definition at line 67 of file vtkImageMask.h.

virtual void vtkImageMask::SetMaskAlpha ( float ) [virtual]

Set/Get the alpha blending value for the mask The input image is assumed to be at alpha = 1.0 and the mask image uses this alpha to blend using an over operator.

virtual float vtkImageMask::GetMaskAlpha ( ) [virtual]

Set/Get the alpha blending value for the mask The input image is assumed to be at alpha = 1.0 and the mask image uses this alpha to blend using an over operator.

void vtkImageMask::SetImageInput ( vtkImageData * in ) [inline]

Set the input to be masked.

Definition at line 79 of file vtkImageMask.h.

void vtkImageMask::SetMaskInput ( vtkImageData * in ) [inline]

Set the mask to be used.

Definition at line 82 of file vtkImageMask.h.

virtual void vtkImageMask::SetNotMask ( int ) [virtual]

When Not Mask is on, the mask is passed through a boolean not before it is used to mask the image. The effect is to pass the pixels where the input mask is zero, and replace the pixels where the input value is non zero.

virtual int vtkImageMask::GetNotMask ( ) [virtual]

When Not Mask is on, the mask is passed through a boolean not before it is used to mask the image. The effect is to pass the pixels where the input mask is zero, and replace the pixels where the input value is non zero.

virtual void vtkImageMask::NotMaskOn ( ) [virtual]

When Not Mask is on, the mask is passed through a boolean not before it is used to mask the image. The effect is to pass the pixels where the input mask is zero, and replace the pixels where the input value is non zero.

virtual void vtkImageMask::NotMaskOff ( ) [virtual]

When Not Mask is on, the mask is passed through a boolean not before it is used to mask the image. The effect is to pass the pixels where the input mask is zero, and replace the pixels where the input value is non zero.

void vtkImageMask::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageMask::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 104 of file vtkImageMask.h.

void vtkImageMask::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

float* vtkImageMask::MaskedOutputValue [protected]

Definition at line 98 of file vtkImageMask.h.

int vtkImageMask::MaskedOutputValueLength [protected]

Definition at line 99 of file vtkImageMask.h.

int vtkImageMask::NotMask [protected]

Definition at line 100 of file vtkImageMask.h.

float vtkImageMask::MaskAlpha [protected]

Definition at line 101 of file vtkImageMask.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMask.h
Generated on Mon Mar 25 01:19:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMaskBits Class Reference

applies a bit-mask pattern to each component. More...

#include <vtkImageMaskBits.h>

Inheritance diagram for vtkImageMaskBits:

[legend]
Collaboration diagram for vtkImageMaskBits:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMaskBits, vtkImageToImageFilter)
void | PrintSelf (ostream &, vtkIndent)
virtual void | SetMasks (unsigned int, unsigned int, unsigned int, unsigned int)
virtual void | SetMasks (unsigned int[4])
void | SetMask (unsigned int mask)
void | SetMasks (unsigned int mask1, unsigned int mask2)
void | SetMasks (unsigned int mask1, unsigned int mask2, unsigned int mask3)
virtual unsigned int * | GetMasks ()
virtual void | GetMasks (unsigned int &, unsigned int &, unsigned int &, unsigned int &)
virtual void | GetMasks (unsigned int[4])
virtual void | SetOperation (int)
virtual int | GetOperation ()
void | SetOperationToAnd ()
void | SetOperationToOr ()
void | SetOperationToXor ()
void | SetOperationToNand ()
void | SetOperationToNor ()

Static Public Methods

vtkImageMaskBits * | New ()

Protected Methods

vtkImageMaskBits ()
~vtkImageMaskBits ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

unsigned int | Masks [4]
int | Operation

Detailed Description

applies a bit-mask pattern to each component.

Date:
2002/01/22 15:33:04
Revision:
1.17

vtkImageMaskBits applies a bit-mask pattern to each component. The bit-mask can be applied using a variety of boolean bitwise operators.

Created by:
  • Miller, Jim
Contributed by (if > 5%):
  • Miller, Jim (98%)
Tests:
vtkImageMaskBits (Tests)

Definition at line 43 of file vtkImageMaskBits.h.

Constructor & Destructor Documentation

vtkImageMaskBits::vtkImageMaskBits ( ) [protected]

vtkImageMaskBits::~vtkImageMaskBits ( ) [inline, protected]

Definition at line 76 of file vtkImageMaskBits.h.

Member Function Documentation

vtkImageMaskBits* vtkImageMaskBits::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageMaskBits::vtkTypeRevisionMacro | ( | vtkImageMaskBits | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageMaskBits::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageMaskBits::SetMasks | ( | unsigned | int,
 |  | unsigned | int,
 |  | unsigned | int,
 |  | unsigned | int
 | ) | [virtual]

Set/Get the bit-masks. Default is 0xffffffff.

virtual void vtkImageMaskBits::SetMasks ( unsigned int[4] ) [virtual]

Set/Get the bit-masks. Default is 0xffffffff.

void vtkImageMaskBits::SetMask ( unsigned int mask ) [inline]

Set/Get the bit-masks. Default is 0xffffffff.

Definition at line 53 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetMasks | ( | unsigned int | mask1,
 |  | unsigned int | mask2
 | ) | [inline]

Set/Get the bit-masks. Default is 0xffffffff.

Definition at line 55 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetMasks | ( | unsigned int | mask1,
 |  | unsigned int | mask2,
 |  | unsigned int | mask3
 | ) | [inline]

Set/Get the bit-masks. Default is 0xffffffff.

Definition at line 57 of file vtkImageMaskBits.h.

virtual unsigned int* vtkImageMaskBits::GetMasks ( ) [virtual]

Set/Get the bit-masks. Default is 0xffffffff.

virtual void vtkImageMaskBits::GetMasks | ( | unsigned int & | ,
 |  | unsigned int & | ,
 |  | unsigned int & | ,
 |  | unsigned int & |
 | ) | [virtual]

Set/Get the bit-masks. Default is 0xffffffff.

virtual void vtkImageMaskBits::GetMasks ( unsigned int[4] ) [virtual]

Set/Get the bit-masks. Default is 0xffffffff.

virtual void vtkImageMaskBits::SetOperation ( int ) [virtual]

Set/Get the boolean operator. Default is AND.

virtual int vtkImageMaskBits::GetOperation ( ) [virtual]

Set/Get the boolean operator. Default is AND.

void vtkImageMaskBits::SetOperationToAnd ( ) [inline]

Set/Get the boolean operator. Default is AND.

Definition at line 66 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetOperationToOr ( ) [inline]

Set/Get the boolean operator. Default is AND.

Definition at line 67 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetOperationToXor ( ) [inline]

Set/Get the boolean operator. Default is AND.

Definition at line 68 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetOperationToNand ( ) [inline]

Set/Get the boolean operator. Default is AND.

Definition at line 69 of file vtkImageMaskBits.h.

void vtkImageMaskBits::SetOperationToNor ( ) [inline]

Set/Get the boolean operator. Default is AND.

Definition at line 70 of file vtkImageMaskBits.h.

void vtkImageMaskBits::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

unsigned int vtkImageMaskBits::Masks[4] [protected]

Definition at line 81 of file vtkImageMaskBits.h.

int vtkImageMaskBits::Operation [protected]

Definition at line 82 of file vtkImageMaskBits.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMaskBits.h
Generated on Mon Mar 25 01:19:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMathematics Class Reference

Add, subtract, multiply, divide, invert, sin, cos, exp, log. More...

#include <vtkImageMathematics.h>

Inheritance diagram for vtkImageMathematics:

[legend]
Collaboration diagram for vtkImageMathematics:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMathematics, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOperationToInvert ()
void | SetOperationToSin ()
void | SetOperationToCos ()
void | SetOperationToExp ()
void | SetOperationToLog ()
void | SetOperationToAbsoluteValue ()
void | SetOperationToSquare ()
void | SetOperationToSquareRoot ()
void | SetOperationToMin ()
void | SetOperationToMax ()
void | SetOperationToATAN ()
void | SetOperationToATAN2 ()
void | SetOperationToMultiplyByK ()
void | SetOperationToAddConstant ()
void | SetOperationToReplaceCByK ()
virtual void | SetConstantK (double)
virtual double | GetConstantK ()
virtual void | SetConstantC (double)
virtual double | GetConstantC ()
virtual void | SetDivideByZeroToC (int)
virtual int | GetDivideByZeroToC ()
virtual void | DivideByZeroToCOn ()
virtual void | DivideByZeroToCOff ()
virtual void | SetOperation (int)
virtual int | GetOperation ()
void | SetOperationToAdd ()
void | SetOperationToSubtract ()
void | SetOperationToMultiply ()
void | SetOperationToDivide ()
void | SetOperationToConjugate ()
void | SetOperationToComplexMultiply ()

Static Public Methods

vtkImageMathematics * | New ()

Protected Methods

vtkImageMathematics ()
~vtkImageMathematics ()
void | ExecuteInformation (vtkImageData **inDatas, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | Operation
double | ConstantK
double | ConstantC
int | DivideByZeroToC

Detailed Description

Add, subtract, multiply, divide, invert, sin, cos, exp, log.

Date:
2002/01/30 19:14:31
Revision:
1.30

vtkImageMathematics implements basic mathematic operations SetOperation is used to select the filters behavior. The filter can take two or one input.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (44%)
  • Martin, Ken (32%)
  • Lorensen, Bill (5%)
  • Schroeder, Will (5%)
Tests:
vtkImageMathematics (Tests)

Definition at line 68 of file vtkImageMathematics.h.

Constructor & Destructor Documentation

vtkImageMathematics::vtkImageMathematics ( ) [protected]

vtkImageMathematics::~vtkImageMathematics ( ) [inline, protected]

Definition at line 116 of file vtkImageMathematics.h.

Member Function Documentation

vtkImageMathematics* vtkImageMathematics::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageMathematics::vtkTypeRevisionMacro | ( | vtkImageMathematics | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageMathematics::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageMathematics::SetOperation ( int ) [virtual]

Set/Get the Operation to perform.

virtual int vtkImageMathematics::GetOperation ( ) [virtual]

Set/Get the Operation to perform.

void vtkImageMathematics::SetOperationToAdd ( ) [inline]

Set/Get the Operation to perform.

Definition at line 79 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToSubtract ( ) [inline]

Set/Get the Operation to perform.

Definition at line 80 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToMultiply ( ) [inline]

Set/Get the Operation to perform.

Definition at line 81 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToDivide ( ) [inline]

Set/Get the Operation to perform.

Definition at line 82 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToConjugate ( ) [inline]

Set/Get the Operation to perform.

Definition at line 83 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToComplexMultiply ( ) [inline]

Set/Get the Operation to perform.

Definition at line 84 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToInvert ( ) [inline]

Definition at line 88 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToSin ( ) [inline]

Definition at line 89 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToCos ( ) [inline]

Definition at line 90 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToExp ( ) [inline]

Definition at line 91 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToLog ( ) [inline]

Definition at line 92 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToAbsoluteValue ( ) [inline]

Definition at line 93 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToSquare ( ) [inline]

Definition at line 94 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToSquareRoot ( ) [inline]

Definition at line 95 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToMin ( ) [inline]

Definition at line 96 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToMax ( ) [inline]

Definition at line 97 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToATAN ( ) [inline]

Definition at line 99 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToATAN2 ( ) [inline]

Definition at line 100 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToMultiplyByK ( ) [inline]

Definition at line 101 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToAddConstant ( ) [inline]

Definition at line 102 of file vtkImageMathematics.h.

void vtkImageMathematics::SetOperationToReplaceCByK ( ) [inline]

Definition at line 103 of file vtkImageMathematics.h.

virtual void vtkImageMathematics::SetConstantK ( double ) [virtual]

virtual double vtkImageMathematics::GetConstantK ( ) [virtual]

virtual void vtkImageMathematics::SetConstantC ( double ) [virtual]

virtual double vtkImageMathematics::GetConstantC ( ) [virtual]

virtual void vtkImageMathematics::SetDivideByZeroToC ( int ) [virtual]

virtual int vtkImageMathematics::GetDivideByZeroToC ( ) [virtual]

virtual void vtkImageMathematics::DivideByZeroToCOn ( ) [virtual]

virtual void vtkImageMathematics::DivideByZeroToCOff ( ) [virtual]

void vtkImageMathematics::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageMathematics::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 124 of file vtkImageMathematics.h.

void vtkImageMathematics::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

int vtkImageMathematics::Operation [protected]

Definition at line 118 of file vtkImageMathematics.h.

double vtkImageMathematics::ConstantK [protected]

Definition at line 119 of file vtkImageMathematics.h.

double vtkImageMathematics::ConstantC [protected]

Definition at line 120 of file vtkImageMathematics.h.

int vtkImageMathematics::DivideByZeroToC [protected]

Definition at line 121 of file vtkImageMathematics.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMathematics.h
Generated on Mon Mar 25 01:19:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMedian3D Class Reference

Median Filter. More...

#include <vtkImageMedian3D.h>

Inheritance diagram for vtkImageMedian3D:

[legend]
Collaboration diagram for vtkImageMedian3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMedian3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetKernelSize (int size0, int size1, int size2)
virtual int | GetNumberOfElements ()

Static Public Methods

vtkImageMedian3D * | New ()

Protected Methods

vtkImageMedian3D ()
~vtkImageMedian3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | NumberOfElements

Detailed Description

Median Filter.

Date:
2002/01/22 15:33:07
Revision:
1.24

vtkImageMedian3D a Median filter that replaces each pixel with the median value from a rectangular neighborhood around that pixel. Neighborhoods can be no more than 3 dimensional. Setting one axis of the neighborhood kernelSize to 1 changes the filter into a 2D median.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (53%)
  • Martin, Ken (28%)
  • Lorensen, Bill (12%)
Tests:
vtkImageMedian3D (Tests)

Definition at line 46 of file vtkImageMedian3D.h.

Constructor & Destructor Documentation

vtkImageMedian3D::vtkImageMedian3D ( ) [protected]

vtkImageMedian3D::~vtkImageMedian3D ( ) [inline, protected]

Definition at line 64 of file vtkImageMedian3D.h.

Member Function Documentation

vtkImageMedian3D* vtkImageMedian3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageMedian3D::vtkTypeRevisionMacro | ( | vtkImageMedian3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageMedian3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageMedian3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood

virtual int vtkImageMedian3D::GetNumberOfElements ( ) [virtual]

Return the number of elements in the median mask

void vtkImageMedian3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageMedian3D::NumberOfElements [protected]

Definition at line 66 of file vtkImageMedian3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMedian3D.h
Generated on Mon Mar 25 01:19:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMirrorPad Class Reference

Extra pixels are filled by mirror images. More...

#include <vtkImageMirrorPad.h>

Inheritance diagram for vtkImageMirrorPad:

[legend]
Collaboration diagram for vtkImageMirrorPad:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMirrorPad, vtkImagePadFilter)

Static Public Methods

vtkImageMirrorPad * | New ()

Protected Methods

vtkImageMirrorPad ()
~vtkImageMirrorPad ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outRegion, int ext[6], int id)

Detailed Description

Extra pixels are filled by mirror images.

Date:
2002/01/22 15:33:08
Revision:
1.26

vtkImageMirrorPad makes an image larger by filling extra pixels with a mirror image of the original image (mirror at image boundaries).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Martin, Ken (49%)
  • Law, Charles (44%)
Tests:
vtkImageMirrorPad (Tests)

Definition at line 42 of file vtkImageMirrorPad.h.

Constructor & Destructor Documentation

vtkImageMirrorPad::vtkImageMirrorPad ( ) [inline, protected]

Definition at line 49 of file vtkImageMirrorPad.h.

vtkImageMirrorPad::~vtkImageMirrorPad ( ) [inline, protected]

Definition at line 50 of file vtkImageMirrorPad.h.

Member Function Documentation

vtkImageMirrorPad* vtkImageMirrorPad::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImagePadFilter.

vtkImageMirrorPad::vtkTypeRevisionMacro | ( | vtkImageMirrorPad | ,
 |  | vtkImagePadFilter |
 | ) |

Reimplemented from vtkImagePadFilter.

void vtkImageMirrorPad::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImagePadFilter.

void vtkImageMirrorPad::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outRegion,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageMirrorPad.h
Generated on Mon Mar 25 01:19:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMultipleInputFilter Class Reference

Generic filter that has N inputs. More...

#include <vtkImageMultipleInputFilter.h>

Inheritance diagram for vtkImageMultipleInputFilter:

[legend]
Collaboration diagram for vtkImageMultipleInputFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMultipleInputFilter, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInput (int num, vtkImageData *input)
virtual void | AddInput (vtkImageData *input)
virtual void | RemoveInput (vtkImageData *input)
vtkImageData * | GetInput (int num)
vtkImageData * GetInput ()
virtual void | SetBypass (int)
virtual int | GetBypass ()
virtual void | BypassOn ()
virtual void | BypassOff ()
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
virtual int | SplitExtent (int splitExt[6], int startExt[6], int num, int total)
virtual void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int threadId)

Static Public Methods

vtkImageMultipleInputFilter * | New ()

Protected Methods

vtkImageMultipleInputFilter ()
~vtkImageMultipleInputFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteData (vtkDataObject *output)
void | ExecuteInformation ()
virtual void | ExecuteInformation (vtkImageData **, vtkImageData *)

Protected Attributes

vtkMultiThreader * Threader
int | Bypass
int | NumberOfThreads

Detailed Description

Generic filter that has N inputs.

Date:
2002/01/22 15:28:05
Revision:
1.51

vtkImageMultipleInputFilter is a super class for filters that have any number of inputs. Steaming is not available in this class yet.

See also:
vtkImageToImageFilter vtkImageInPlaceFilter vtkImageTwoInputFilter vtkImageTwoOutputFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (69%)
  • Martin, Ken (22%)

Definition at line 45 of file vtkImageMultipleInputFilter.h.

Constructor & Destructor Documentation

vtkImageMultipleInputFilter::vtkImageMultipleInputFilter ( ) [protected]

vtkImageMultipleInputFilter::~vtkImageMultipleInputFilter ( ) [protected]

Member Function Documentation

vtkImageMultipleInputFilter* vtkImageMultipleInputFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageTwoInputFilter, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

vtkImageMultipleInputFilter::vtkTypeRevisionMacro | ( | vtkImageMultipleInputFilter | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageTwoInputFilter, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

void vtkImageMultipleInputFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageAppend, vtkImageBlend, vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

virtual void vtkImageMultipleInputFilter::SetInput | ( | int | num,
 |  | vtkImageData * | input
 | ) | [virtual]

Set an Input of this filter.

Reimplemented in vtkImageDifference.

Referenced by vtkImageDifference::SetInput(), vtkImageAppendComponents::SetInput1(), and vtkImageAppendComponents::SetInput2().

virtual void vtkImageMultipleInputFilter::AddInput ( vtkImageData * input ) [virtual]

Adds an input to the first null position in the input list. Expands the list memory if necessary

virtual void vtkImageMultipleInputFilter::RemoveInput ( vtkImageData * input ) [virtual]

Adds an input to the first null position in the input list. Expands the list memory if necessary

vtkImageData* vtkImageMultipleInputFilter::GetInput ( int num )

Get one input to this filter.

vtkImageData* vtkImageMultipleInputFilter::GetInput ( )

Get one input to this filter.

virtual void vtkImageMultipleInputFilter::SetBypass ( int ) [virtual]

Turning bypass on will cause the filter to turn off and simply pass the data from the first input (input0) through. It is implemented for consistency with vtkImageToImageFilter.

virtual int vtkImageMultipleInputFilter::GetBypass ( ) [virtual]

Turning bypass on will cause the filter to turn off and simply pass the data from the first input (input0) through. It is implemented for consistency with vtkImageToImageFilter.

virtual void vtkImageMultipleInputFilter::BypassOn ( ) [virtual]

Turning bypass on will cause the filter to turn off and simply pass the data from the first input (input0) through. It is implemented for consistency with vtkImageToImageFilter.

virtual void vtkImageMultipleInputFilter::BypassOff ( ) [virtual]

Turning bypass on will cause the filter to turn off and simply pass the data from the first input (input0) through. It is implemented for consistency with vtkImageToImageFilter.

virtual void vtkImageMultipleInputFilter::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create when rendering

virtual int vtkImageMultipleInputFilter::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create when rendering

virtual int vtkImageMultipleInputFilter::SplitExtent | ( | int | splitExt[6],
 |  | int | startExt[6],
 |  | int | num,
 |  | int | total
 | ) | [virtual]

Putting this here until I merge graphics and imaging streaming.

virtual void vtkImageMultipleInputFilter::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

void vtkImageMultipleInputFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Reimplemented in vtkImageMultipleInputOutputFilter.

virtual void vtkImageMultipleInputFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageAppend, vtkImageBlend, vtkImageCorrelation, vtkImageDifference, and vtkImageNonMaximumSuppression.

void vtkImageMultipleInputFilter::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented in vtkImageMultipleInputOutputFilter, and vtkImageBlend.

void vtkImageMultipleInputFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

Referenced by vtkImageNonMaximumSuppression::ExecuteInformation(), vtkImageMathematics::ExecuteInformation(), vtkImageMask::ExecuteInformation(), vtkImageDotProduct::ExecuteInformation(), vtkImageDifference::ExecuteInformation(), vtkImageCorrelation::ExecuteInformation(), vtkImageBlend::ExecuteInformation(), vtkImageAppendComponents::ExecuteInformation(), and vtkImageAppend::ExecuteInformation().

virtual void vtkImageMultipleInputFilter::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [inline, protected, virtual]

Reimplemented in vtkImageMultipleInputOutputFilter, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

Definition at line 120 of file vtkImageMultipleInputFilter.h.

Member Data Documentation

vtkMultiThreader* vtkImageMultipleInputFilter::Threader [protected]

Definition at line 104 of file vtkImageMultipleInputFilter.h.

int vtkImageMultipleInputFilter::Bypass [protected]

Definition at line 105 of file vtkImageMultipleInputFilter.h.

int vtkImageMultipleInputFilter::NumberOfThreads [protected]

Definition at line 106 of file vtkImageMultipleInputFilter.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImageMultipleInputFilter.h
Generated on Mon Mar 25 01:19:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageMultipleInputOutputFilter Class Reference

Generic filter that has N inputs. More...

#include <vtkImageMultipleInputOutputFilter.h>

Inheritance diagram for vtkImageMultipleInputOutputFilter:

[legend]
Collaboration diagram for vtkImageMultipleInputOutputFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageMultipleInputOutputFilter, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageData * | GetOutput (int num)
vtkImageData * GetOutput ()
virtual void | ThreadedExecute (vtkImageData **inDatas, vtkImageData **outDatas, int extent[6], int threadId)

Static Public Methods

vtkImageMultipleInputOutputFilter * | New ()

Protected Methods

vtkImageMultipleInputOutputFilter ()
~vtkImageMultipleInputOutputFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteData (vtkDataObject *out)
virtual void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int threadId)
virtual void | ExecuteInformation (vtkImageData **, vtkImageData *)
void | ExecuteInformation ()
virtual void | ExecuteInformation (vtkImageData **, vtkImageData **)

Detailed Description

Generic filter that has N inputs.

Date:
2002/01/22 15:28:05
Revision:
1.10

vtkImageMultipleInputOutputFilter is a super class for filters that have any number of inputs. Steaming is not available in this class yet.

See also:
vtkImageToImageFilter vtkImageInPlaceFilter vtkImageTwoInputFilter vtkImageTwoOutputFilter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (100%)

Definition at line 43 of file vtkImageMultipleInputOutputFilter.h.

Constructor & Destructor Documentation

vtkImageMultipleInputOutputFilter::vtkImageMultipleInputOutputFilter ( ) [protected]

vtkImageMultipleInputOutputFilter::~vtkImageMultipleInputOutputFilter ( ) [protected]

Member Function Documentation

vtkImageMultipleInputOutputFilter* vtkImageMultipleInputOutputFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMultipleInputFilter.

vtkImageMultipleInputOutputFilter::vtkTypeRevisionMacro | ( | vtkImageMultipleInputOutputFilter | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageMultipleInputOutputFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

vtkImageData* vtkImageMultipleInputOutputFilter::GetOutput ( int num )

Get one input to this filter.

Reimplemented from vtkImageSource.

vtkImageData* vtkImageMultipleInputOutputFilter::GetOutput ( )

Get one input to this filter.

Reimplemented from vtkImageSource.

virtual void vtkImageMultipleInputOutputFilter::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData ** | outDatas,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

void vtkImageMultipleInputOutputFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageMultipleInputOutputFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageMultipleInputOutputFilter::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageMultipleInputOutputFilter::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageMultipleInputOutputFilter::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 82 of file vtkImageMultipleInputOutputFilter.h.

void vtkImageMultipleInputOutputFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageMultipleInputOutputFilter::ExecuteInformation | ( | vtkImageData ** | ,
 |  | vtkImageData ** |
 | ) | [inline, protected, virtual]

Definition at line 87 of file vtkImageMultipleInputOutputFilter.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImageMultipleInputOutputFilter.h
Generated on Mon Mar 25 01:19:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNoiseSource Class Reference

Create an image filled with noise. More...

#include <vtkImageNoiseSource.h>

Inheritance diagram for vtkImageNoiseSource:

[legend]
Collaboration diagram for vtkImageNoiseSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageNoiseSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMinimum (float)
virtual float | GetMinimum ()
virtual void | SetMaximum (float)
virtual float | GetMaximum ()
void | SetWholeExtent (int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)

Static Public Methods

vtkImageNoiseSource * | New ()

Protected Methods

vtkImageNoiseSource ()
~vtkImageNoiseSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)

Protected Attributes

float | Minimum
float | Maximum
int | WholeExtent [6]

Detailed Description

Create an image filled with noise.

Date:
2002/01/22 15:33:09
Revision:
1.25

vtkImageNoiseSource just produces images filled with noise. The only option now is uniform noise specified by a min and a max. There is one major problem with this source. Every time it executes, it will output different pixel values. This has important implications when a stream requests overlapping regions. The same pixels will have different values on different updates.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (63%)
  • Martin, Ken (29%)
Tests:
vtkImageNoiseSource (Tests)

Definition at line 47 of file vtkImageNoiseSource.h.

Constructor & Destructor Documentation

vtkImageNoiseSource::vtkImageNoiseSource ( ) [protected]

vtkImageNoiseSource::~vtkImageNoiseSource ( ) [inline, protected]

Definition at line 70 of file vtkImageNoiseSource.h.

Member Function Documentation

vtkImageNoiseSource* vtkImageNoiseSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageNoiseSource::vtkTypeRevisionMacro | ( | vtkImageNoiseSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageNoiseSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkImageNoiseSource::SetMinimum ( float ) [virtual]

Set/Get the minimum and maximum values for the generated noise.

virtual float vtkImageNoiseSource::GetMinimum ( ) [virtual]

Set/Get the minimum and maximum values for the generated noise.

virtual void vtkImageNoiseSource::SetMaximum ( float ) [virtual]

Set/Get the minimum and maximum values for the generated noise.

virtual float vtkImageNoiseSource::GetMaximum ( ) [virtual]

Set/Get the minimum and maximum values for the generated noise.

void vtkImageNoiseSource::SetWholeExtent | ( | int | xMinx,
 |  | int | xMax,
 |  | int | yMin,
 |  | int | yMax,
 |  | int | zMin,
 |  | int | zMax
 | ) |

Set how large of an image to generate.

virtual void vtkImageNoiseSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkImageNoiseSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

Member Data Documentation

float vtkImageNoiseSource::Minimum [protected]

Definition at line 72 of file vtkImageNoiseSource.h.

float vtkImageNoiseSource::Maximum [protected]

Definition at line 73 of file vtkImageNoiseSource.h.

int vtkImageNoiseSource::WholeExtent[6] [protected]

Definition at line 74 of file vtkImageNoiseSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageNoiseSource.h
Generated on Mon Mar 25 01:19:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNonMaximumSuppression Class Reference

Performs non-maximum suppression. More...

#include <vtkImageNonMaximumSuppression.h>

Inheritance diagram for vtkImageNonMaximumSuppression:

[legend]
Collaboration diagram for vtkImageNonMaximumSuppression:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageNonMaximumSuppression, vtkImageTwoInputFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetMagnitudeInput (vtkImageData *input)
void | SetVectorInput (vtkImageData *input)
virtual void | SetHandleBoundaries (int)
virtual int | GetHandleBoundaries ()
virtual void | HandleBoundariesOn ()
virtual void | HandleBoundariesOff ()
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageNonMaximumSuppression * | New ()

Protected Methods

vtkImageNonMaximumSuppression ()
~vtkImageNonMaximumSuppression ()
void | ExecuteInformation (vtkImageData **inDatas, vtkImageData *outData)
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6], int whichInput)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | HandleBoundaries
int | Dimensionality

Detailed Description

Performs non-maximum suppression.

Date:
2002/01/22 15:33:10
Revision:
1.35

vtkImageNonMaximumSuppression Sets to zero any pixel that is not a peak. If a pixel has a neighbor along the vector that has larger magnitude, the smaller pixel is set to zero. The filter takes two inputs: a magnitude and a vector. Output is magnitude information and is always in floats. Typically this filter is used with vtkImageGradient and vtkImageGradientMagnitude as inputs.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (59%)
  • Martin, Ken (31%)
Tests:
vtkImageNonMaximumSuppression (Tests)

Definition at line 48 of file vtkImageNonMaximumSuppression.h.

Constructor & Destructor Documentation

vtkImageNonMaximumSuppression::vtkImageNonMaximumSuppression ( ) [protected]

vtkImageNonMaximumSuppression::~vtkImageNonMaximumSuppression ( ) [inline, protected]

Definition at line 78 of file vtkImageNonMaximumSuppression.h.

Member Function Documentation

vtkImageNonMaximumSuppression* vtkImageNonMaximumSuppression::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageTwoInputFilter.

vtkImageNonMaximumSuppression::vtkTypeRevisionMacro | ( | vtkImageNonMaximumSuppression | ,
 |  | vtkImageTwoInputFilter |
 | ) |

Reimplemented from vtkImageTwoInputFilter.

void vtkImageNonMaximumSuppression::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageNonMaximumSuppression::SetMagnitudeInput ( vtkImageData * input ) [inline]

Set the magnitude and vector inputs.

Definition at line 57 of file vtkImageNonMaximumSuppression.h.

void vtkImageNonMaximumSuppression::SetVectorInput ( vtkImageData * input ) [inline]

Set the magnitude and vector inputs.

Definition at line 58 of file vtkImageNonMaximumSuppression.h.

virtual void vtkImageNonMaximumSuppression::SetHandleBoundaries ( int ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual int vtkImageNonMaximumSuppression::GetHandleBoundaries ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageNonMaximumSuppression::HandleBoundariesOn ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageNonMaximumSuppression::HandleBoundariesOff ( ) [virtual]

If "HandleBoundariesOn" then boundary pixels are duplicated So central differences can get values.

virtual void vtkImageNonMaximumSuppression::SetDimensionality ( int ) [virtual]

Determines how the input is interpreted (set of 2d slices or a 3D volume)

virtual int vtkImageNonMaximumSuppression::GetDimensionality ( ) [virtual]

Determines how the input is interpreted (set of 2d slices or a 3D volume)

void vtkImageNonMaximumSuppression::ExecuteInformation | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

virtual void vtkImageNonMaximumSuppression::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6],
 |  | int | whichInput
 | ) | [protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

void vtkImageNonMaximumSuppression::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageMultipleInputFilter.

Definition at line 86 of file vtkImageNonMaximumSuppression.h.

void vtkImageNonMaximumSuppression::ThreadedExecute | ( | vtkImageData ** | inDatas,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

The execute method created by the subclass. This is kept public instead of protected since it is called from a non-member thread function.

Reimplemented from vtkImageMultipleInputFilter.

Member Data Documentation

int vtkImageNonMaximumSuppression::HandleBoundaries [protected]

Definition at line 80 of file vtkImageNonMaximumSuppression.h.

int vtkImageNonMaximumSuppression::Dimensionality [protected]

Definition at line 81 of file vtkImageNonMaximumSuppression.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageNonMaximumSuppression.h
Generated on Mon Mar 25 01:19:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageNormalize Class Reference

Normalizes that scalar components for each point. More...

#include <vtkImageNormalize.h>

Inheritance diagram for vtkImageNormalize:

[legend]
Collaboration diagram for vtkImageNormalize:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageNormalize, vtkImageToImageFilter)

Static Public Methods

vtkImageNormalize * | New ()

Protected Methods

vtkImageNormalize ()
~vtkImageNormalize ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Detailed Description

Normalizes that scalar components for each point.

Date:
2002/01/22 15:33:11
Revision:
1.15

For each point, vtkImageNormalize normalizes the vector defined by the scalar components. If the magnitude of this vector is zero, the output vector is zero also.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (89%)
  • Martin, Ken (10%)
Tests:
vtkImageNormalize (Tests)

Definition at line 43 of file vtkImageNormalize.h.

Constructor & Destructor Documentation

vtkImageNormalize::vtkImageNormalize ( ) [inline, protected]

Definition at line 50 of file vtkImageNormalize.h.

vtkImageNormalize::~vtkImageNormalize ( ) [inline, protected]

Definition at line 51 of file vtkImageNormalize.h.

Member Function Documentation

vtkImageNormalize* vtkImageNormalize::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageNormalize::vtkTypeRevisionMacro | ( | vtkImageNormalize | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageNormalize::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageNormalize::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 54 of file vtkImageNormalize.h.

void vtkImageNormalize::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageNormalize.h
Generated on Mon Mar 25 01:19:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageOpenClose3D Class Reference

Will perform opening or closing. More...

#include <vtkImageOpenClose3D.h>

Inheritance diagram for vtkImageOpenClose3D:

[legend]
Collaboration diagram for vtkImageOpenClose3D:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkImageOpenClose3D, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkImageOpenClose3D * | New ()

Public Methods

unsigned long int | GetMTime ()
void | Modified ()
void | SetInput (vtkImageData *Input)
void | SetKernelSize (int size0, int size1, int size2)
void | DebugOn ()
void | DebugOff ()
vtkImageData * GetOutput ()
vtkImageData * | GetOutput (int idx)
void | SetOpenValue (float value)
float | GetOpenValue ()
void | SetCloseValue (float value)
float | GetCloseValue ()
virtual vtkImageDilateErode3D * | GetFilter0 ()
virtual vtkImageDilateErode3D * | GetFilter1 ()

Protected Methods

vtkImageOpenClose3D ()
~vtkImageOpenClose3D ()

Protected Attributes

vtkImageDilateErode3D * Filter0
vtkImageDilateErode3D * Filter1

Detailed Description

Will perform opening or closing.

Date:
2002/01/22 15:33:12
Revision:
1.25

vtkImageOpenClose3D performs opening or closing by having two vtkImageErodeDilates in series. The size of operation is determined by the method SetKernelSize, and the operator is an ellipse. OpenValue and CloseValue determine how the filter behaves. For binary images Opening and closing behaves as expected. Close value is first dilated, and then eroded. Open value is first eroded, and then dilated. Degenerate two dimensional opening/closing can be achieved by setting the one axis the 3D KernelSize to 1. Values other than open value and close value are not touched. This enables the filter to processes segmented images containing more than two tags.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (89%)
  • Kelly, Ann (7%)
Tests:
vtkImageOpenClose3D (Tests)

Definition at line 53 of file vtkImageOpenClose3D.h.

Constructor & Destructor Documentation

vtkImageOpenClose3D::vtkImageOpenClose3D ( ) [protected]

vtkImageOpenClose3D::~vtkImageOpenClose3D ( ) [protected]

Member Function Documentation

vtkImageOpenClose3D* vtkImageOpenClose3D::New ( ) [static]

Default open value is 0, and default close value is 255.

Reimplemented from vtkImageToImageFilter.

vtkImageOpenClose3D::vtkTypeRevisionMacro | ( | vtkImageOpenClose3D | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageOpenClose3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

unsigned long int vtkImageOpenClose3D::GetMTime ( ) [virtual]

This method considers the sub filters MTimes when computing this objects modified time.

Reimplemented from vtkObject.

void vtkImageOpenClose3D::DebugOn ( ) [virtual]

Turn debugging output on. (in sub filters also)

Reimplemented from vtkObject.

void vtkImageOpenClose3D::DebugOff ( ) [virtual]

Turn debugging output on. (in sub filters also)

Reimplemented from vtkObject.

void vtkImageOpenClose3D::Modified ( ) [virtual]

Pass modified message to sub filters.

Reimplemented from vtkObject.

vtkImageData* vtkImageOpenClose3D::GetOutput ( )

This method returns the cache to make a connection It justs feeds the request to the sub filter.

Reimplemented from vtkImageSource.

vtkImageData* vtkImageOpenClose3D::GetOutput ( int idx ) [inline]

This method returns the cache to make a connection It justs feeds the request to the sub filter.

Reimplemented from vtkImageSource.

Definition at line 82 of file vtkImageOpenClose3D.h.

void vtkImageOpenClose3D::SetInput ( vtkImageData * Input ) [virtual]

Set the Input of the filter.

Reimplemented from vtkImageToImageFilter.

void vtkImageOpenClose3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

Selects the size of gaps or objects removed.

void vtkImageOpenClose3D::SetOpenValue ( float value )

Determines the value that will opened. Open value is first eroded, and then dilated.

float vtkImageOpenClose3D::GetOpenValue ( )

Determines the value that will opened. Open value is first eroded, and then dilated.

void vtkImageOpenClose3D::SetCloseValue ( float value )

Determines the value that will closed. Close value is first dilated, and then eroded

float vtkImageOpenClose3D::GetCloseValue ( )

Determines the value that will closed. Close value is first dilated, and then eroded

virtual vtkImageDilateErode3D* vtkImageOpenClose3D::GetFilter0 ( ) [virtual]

Needed for Progress functions

virtual vtkImageDilateErode3D* vtkImageOpenClose3D::GetFilter1 ( ) [virtual]

Needed for Progress functions

Member Data Documentation

vtkImageDilateErode3D* vtkImageOpenClose3D::Filter0 [protected]

Definition at line 121 of file vtkImageOpenClose3D.h.

vtkImageDilateErode3D* vtkImageOpenClose3D::Filter1 [protected]

Definition at line 122 of file vtkImageOpenClose3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageOpenClose3D.h
Generated on Mon Mar 25 01:19:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagePadFilter Class Reference

Super class for filters that fill in extra pixels. More...

#include <vtkImagePadFilter.h>

Inheritance diagram for vtkImagePadFilter:

[legend]
Collaboration diagram for vtkImagePadFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImagePadFilter, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOutputWholeExtent (int extent[6])
void | SetOutputWholeExtent (int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
void | GetOutputWholeExtent (int extent[6])
int * | GetOutputWholeExtent ()
virtual void | SetOutputNumberOfScalarComponents (int)
virtual int | GetOutputNumberOfScalarComponents ()

Static Public Methods

vtkImagePadFilter * | New ()

Protected Methods

vtkImagePadFilter ()
~vtkImagePadFilter ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()

Protected Attributes

int | OutputWholeExtent [6]
int | OutputNumberOfScalarComponents

Detailed Description

Super class for filters that fill in extra pixels.

Date:
2002/01/22 15:33:13
Revision:
1.33

vtkImagePadFilter Changes the image extent of an image. If the image extent is larger than the input image extent, the extra pixels are filled by an algorithm determined by the subclass. The image extent of the output has to be specified.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (80%)
  • Martin, Ken (12%)

Definition at line 40 of file vtkImagePadFilter.h.

Constructor & Destructor Documentation

vtkImagePadFilter::vtkImagePadFilter ( ) [protected]

vtkImagePadFilter::~vtkImagePadFilter ( ) [inline, protected]

Definition at line 64 of file vtkImagePadFilter.h.

Member Function Documentation

vtkImagePadFilter* vtkImagePadFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageConstantPad, vtkImageMirrorPad, and vtkImageWrapPad.

vtkImagePadFilter::vtkTypeRevisionMacro | ( | vtkImagePadFilter | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageConstantPad, vtkImageMirrorPad, and vtkImageWrapPad.

void vtkImagePadFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageConstantPad.

void vtkImagePadFilter::SetOutputWholeExtent ( int extent[6] )

The image extent of the output has to be set explicitly.

void vtkImagePadFilter::SetOutputWholeExtent | ( | int | minX,
 |  | int | maxX,
 |  | int | minY,
 |  | int | maxY,
 |  | int | minZ,
 |  | int | maxZ
 | ) |

The image extent of the output has to be set explicitly.

void vtkImagePadFilter::GetOutputWholeExtent ( int extent[6] )

The image extent of the output has to be set explicitly.

int* vtkImagePadFilter::GetOutputWholeExtent ( ) [inline]

The image extent of the output has to be set explicitly.

Definition at line 53 of file vtkImagePadFilter.h.

virtual void vtkImagePadFilter::SetOutputNumberOfScalarComponents ( int ) [virtual]

Set/Get the number of output scalar components.

virtual int vtkImagePadFilter::GetOutputNumberOfScalarComponents ( ) [virtual]

Set/Get the number of output scalar components.

void vtkImagePadFilter::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImagePadFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageMirrorPad, and vtkImageWrapPad.

void vtkImagePadFilter::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 71 of file vtkImagePadFilter.h.

Member Data Documentation

int vtkImagePadFilter::OutputWholeExtent[6] [protected]

Definition at line 66 of file vtkImagePadFilter.h.

int vtkImagePadFilter::OutputNumberOfScalarComponents [protected]

Definition at line 67 of file vtkImagePadFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImagePadFilter.h
Generated on Mon Mar 25 01:19:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagePermute Class Reference

Permutes axes of input. More...

#include <vtkImagePermute.h>

Inheritance diagram for vtkImagePermute:

[legend]
Collaboration diagram for vtkImagePermute:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImagePermute, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFilteredAxes (int, int, int)
virtual void | SetFilteredAxes (int[3])
virtual int * | GetFilteredAxes ()
virtual void | GetFilteredAxes (int &, int &, int &)
virtual void | GetFilteredAxes (int[3])

Static Public Methods

vtkImagePermute * | New ()

Protected Methods

vtkImagePermute ()
~vtkImagePermute ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

int | FilteredAxes [3]

Detailed Description

Permutes axes of input.

Date:
2002/01/22 15:33:14
Revision:
1.28

vtkImagePermute reorders the axes of the input. Filtered axes specify the input axes which become X, Y, Z. The input has to have the same scalar type of the output. The filter does copy the data when it executes.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (50%)
  • Martin, Ken (34%)
Tests:
vtkImagePermute (Tests)

Definition at line 44 of file vtkImagePermute.h.

Constructor & Destructor Documentation

vtkImagePermute::vtkImagePermute ( ) [protected]

vtkImagePermute::~vtkImagePermute ( ) [inline, protected]

Definition at line 59 of file vtkImagePermute.h.

Member Function Documentation

vtkImagePermute* vtkImagePermute::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImagePermute::vtkTypeRevisionMacro | ( | vtkImagePermute | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImagePermute::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImagePermute::SetFilteredAxes | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

The filtered axes are the input axes that get relabeled to X,Y,Z.

virtual void vtkImagePermute::SetFilteredAxes ( int [3] ) [virtual]

The filtered axes are the input axes that get relabeled to X,Y,Z.

virtual int* vtkImagePermute::GetFilteredAxes ( ) [virtual]

The filtered axes are the input axes that get relabeled to X,Y,Z.

virtual void vtkImagePermute::GetFilteredAxes | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

The filtered axes are the input axes that get relabeled to X,Y,Z.

virtual void vtkImagePermute::GetFilteredAxes ( int [3] ) [virtual]

The filtered axes are the input axes that get relabeled to X,Y,Z.

void vtkImagePermute::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImagePermute::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImagePermute::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 64 of file vtkImagePermute.h.

void vtkImagePermute::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImagePermute::FilteredAxes[3] [protected]

Definition at line 61 of file vtkImagePermute.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImagePermute.h
Generated on Mon Mar 25 01:19:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplatevtkImageProgressIterator class Reference

vtkImageProgressIterator Class Template Reference

a simple image iterator with progress. More...

#include <vtkImageProgressIterator.h>

Inheritance diagram for vtkImageProgressIterator:

[legend]
Collaboration diagram for vtkImageProgressIterator:

[legend]
List of all members.

Public Methods

void | NextSpan ()
vtkImageProgressIterator (vtkImageData *imgd, int *ext, vtkProcessObject *po, int id)

Protected Attributes

vtkProcessObject * ProcessObject
unsigned long | Count
unsigned long | Count2
unsigned long | Target
int | ID

Detailed Description

template<class DType>
class vtkImageProgressIterator< DType >

a simple image iterator with progress.

Date:
2002/03/12 15:27:45
Revision:
1.7

This is a simple image iterator that can be used to iterate over an image. Typically used to iterate over the output image

See also:
vtkImage vtkImageIterator
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (79%)
  • Cedilnik, Andy (12%)
  • King, Brad (8%)
Tests:
vtkImageProgressIterator (Tests)

Definition at line 47 of file vtkImageProgressIterator.h.

Constructor & Destructor Documentation

template<class DType>
vtkImageProgressIterator< DType >::vtkImageProgressIterator | ( | vtkImageData * | imgd,
 |  | int * | ext,
 |  | vtkProcessObject * | po,
 |  | int | id
 | ) |

Create a progress iterator for the provided image data and extent to iterate over. The passes progress object will receive any UpdateProgress calls if the thread id is zero

Member Function Documentation

template<class DType>
void vtkImageProgressIterator< DType >::NextSpan ( )

Move the iterator to the next span, may call UpdateProgress on the filter (vtkProcessObject)

Reimplemented from vtkImageIterator.

Member Data Documentation

template<class DType>
vtkProcessObject* vtkImageProgressIterator::ProcessObject [protected]

Definition at line 64 of file vtkImageProgressIterator.h.

template<class DType>
unsigned long vtkImageProgressIterator::Count [protected]

Definition at line 65 of file vtkImageProgressIterator.h.

template<class DType>
unsigned long vtkImageProgressIterator::Count2 [protected]

Definition at line 66 of file vtkImageProgressIterator.h.

template<class DType>
unsigned long vtkImageProgressIterator::Target [protected]

Definition at line 67 of file vtkImageProgressIterator.h.

template<class DType>
int vtkImageProgressIterator::ID [protected]

Definition at line 68 of file vtkImageProgressIterator.h.

The documentation for this class was generated from the following file:
  • Common/vtkImageProgressIterator.h
Generated on Mon Mar 25 01:19:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageQuantizeRGBToIndex Class Reference

generalized histograms up to 4 dimensions. More...

#include <vtkImageQuantizeRGBToIndex.h>

Inheritance diagram for vtkImageQuantizeRGBToIndex:

[legend]
Collaboration diagram for vtkImageQuantizeRGBToIndex:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageQuantizeRGBToIndex, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual float | GetInitializeExecuteTime ()
virtual float | GetBuildTreeExecuteTime ()
virtual float | GetLookupIndexExecuteTime ()
virtual void | SetNumberOfColors (int)
virtual int | GetNumberOfColors ()
virtual vtkLookupTable * | GetLookupTable ()
virtual int | GetInputType ()
virtual void | SetInitializeExecuteTime (float)
virtual void | SetBuildTreeExecuteTime (float)
virtual void | SetLookupIndexExecuteTime (float)

Static Public Methods

vtkImageQuantizeRGBToIndex * | New ()

Protected Methods

vtkImageQuantizeRGBToIndex ()
~vtkImageQuantizeRGBToIndex ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)

Protected Attributes

vtkLookupTable * LookupTable
int | NumberOfColors
int | InputType
float | InitializeExecuteTime
float | BuildTreeExecuteTime
float | LookupIndexExecuteTime

Detailed Description

generalized histograms up to 4 dimensions.

Date:
2002/01/22 15:33:15
Revision:
1.26

vtkImageQuantizeRGBToIndex takes a 3 component RGB image as input and produces a one component index image as output, along with a lookup table that contains the color definitions for the index values. This filter works on the entire input extent - it does not perform streaming, and it does not supported threaded execution (because it has to process the entire image).

To use this filter, you typically set the number of colors (between 2 and 65536), execute it, and then retrieve the lookup table. The colors can then be using the lookup table and the image index.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (66%)
  • Lorensen, Bill (15%)
  • Law, Charles (7%)
Tests:
vtkImageQuantizeRGBToIndex (Tests)

Definition at line 51 of file vtkImageQuantizeRGBToIndex.h.

Constructor & Destructor Documentation

vtkImageQuantizeRGBToIndex::vtkImageQuantizeRGBToIndex ( ) [protected]

vtkImageQuantizeRGBToIndex::~vtkImageQuantizeRGBToIndex ( ) [protected]

Member Function Documentation

vtkImageQuantizeRGBToIndex* vtkImageQuantizeRGBToIndex::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageQuantizeRGBToIndex::vtkTypeRevisionMacro | ( | vtkImageQuantizeRGBToIndex | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageQuantizeRGBToIndex::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageQuantizeRGBToIndex::SetNumberOfColors ( int ) [virtual]

Set / Get the number of color index values to produce - must be a number between 2 and 65536.

virtual int vtkImageQuantizeRGBToIndex::GetNumberOfColors ( ) [virtual]

Set / Get the number of color index values to produce - must be a number between 2 and 65536.

virtual vtkLookupTable* vtkImageQuantizeRGBToIndex::GetLookupTable ( ) [virtual]

Get the resulting lookup table that contains the color definitions corresponding to the index values in the output image.

virtual float vtkImageQuantizeRGBToIndex::GetInitializeExecuteTime ( ) [virtual]

virtual float vtkImageQuantizeRGBToIndex::GetBuildTreeExecuteTime ( ) [virtual]

virtual float vtkImageQuantizeRGBToIndex::GetLookupIndexExecuteTime ( ) [virtual]

virtual int vtkImageQuantizeRGBToIndex::GetInputType ( ) [virtual]

For internal use only - get the type of the image

virtual void vtkImageQuantizeRGBToIndex::SetInitializeExecuteTime ( float ) [virtual]

For internal use only - set the times for execution

virtual void vtkImageQuantizeRGBToIndex::SetBuildTreeExecuteTime ( float ) [virtual]

For internal use only - set the times for execution

virtual void vtkImageQuantizeRGBToIndex::SetLookupIndexExecuteTime ( float ) [virtual]

For internal use only - set the times for execution

void vtkImageQuantizeRGBToIndex::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageQuantizeRGBToIndex::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageQuantizeRGBToIndex::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 103 of file vtkImageQuantizeRGBToIndex.h.

virtual void vtkImageQuantizeRGBToIndex::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkLookupTable* vtkImageQuantizeRGBToIndex::LookupTable [protected]

Definition at line 93 of file vtkImageQuantizeRGBToIndex.h.

int vtkImageQuantizeRGBToIndex::NumberOfColors [protected]

Definition at line 94 of file vtkImageQuantizeRGBToIndex.h.

int vtkImageQuantizeRGBToIndex::InputType [protected]

Definition at line 95 of file vtkImageQuantizeRGBToIndex.h.

float vtkImageQuantizeRGBToIndex::InitializeExecuteTime [protected]

Definition at line 97 of file vtkImageQuantizeRGBToIndex.h.

float vtkImageQuantizeRGBToIndex::BuildTreeExecuteTime [protected]

Definition at line 98 of file vtkImageQuantizeRGBToIndex.h.

float vtkImageQuantizeRGBToIndex::LookupIndexExecuteTime [protected]

Definition at line 99 of file vtkImageQuantizeRGBToIndex.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageQuantizeRGBToIndex.h
Generated on Mon Mar 25 01:19:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImager Class Reference

Renders into part of a ImageWindow. More...

#include <vtkImager.h>

Inheritance diagram for vtkImager:

[legend]
Collaboration diagram for vtkImager:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImager, vtkViewport)
virtual vtkAssemblyPath * | PickProp (float selectionX, float selectionY)
virtual float | GetPickedZ ()
virtual int | RenderOpaqueGeometry ()
virtual int | RenderTranslucentGeometry ()
virtual int | RenderOverlay ()
vtkImageWindow * GetImageWindow ()
vtkWindow * GetVTKWindow ()
void | SetImageWindow (vtkImageWindow *win)
void | SetVTKWindow (vtkWindow *win)
virtual void | Erase ()

Static Public Methods

vtkImager * | New ()

Protected Methods

vtkImager ()
~vtkImager ()
virtual void | StartPick (unsigned int pickFromSize)
virtual void | UpdatePickId ()
virtual void | DonePick ()
virtual unsigned int | GetPickedId ()
virtual void | DevicePickRender ()

Detailed Description

Renders into part of a ImageWindow.

Date:
2002/01/22 15:38:34
Revision:
1.24

vtkImager is the 2D counterpart to vtkRenderer. An Imager renders 2D actors into a viewport of an image window.

See also:
vtkImageWindow vtkViewport
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (68%)
  • Hoffman, Bill (8%)
  • Law, Charles (7%)
  • Avila, Lisa (6%)

Definition at line 52 of file vtkImager.h.

Constructor & Destructor Documentation

vtkImager::vtkImager ( ) [protected]

vtkImager::~vtkImager ( ) [protected]

Member Function Documentation

vtkImager* vtkImager::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkMesaImager, and vtkOpenGLImager.

vtkImager::vtkTypeRevisionMacro | ( | vtkImager | ,
 |  | vtkViewport |
 | ) |

Reimplemented from vtkViewport.

Reimplemented in vtkMesaImager, and vtkOpenGLImager.

virtual int vtkImager::RenderOpaqueGeometry ( ) [virtual]

Renders an imager. Passes Render message on the the imager's actor2D collection.

Reimplemented in vtkMesaImager, and vtkOpenGLImager.

virtual int vtkImager::RenderTranslucentGeometry ( ) [virtual]

Renders an imager. Passes Render message on the the imager's actor2D collection.

virtual int vtkImager::RenderOverlay ( ) [virtual]

Renders an imager. Passes Render message on the the imager's actor2D collection.

vtkImageWindow* vtkImager::GetImageWindow ( )

Get the image window that an imager is attached to.

vtkWindow* vtkImager::GetVTKWindow ( ) [inline, virtual]

Get the image window that an imager is attached to.

Reimplemented from vtkViewport.

Definition at line 69 of file vtkImager.h.

void vtkImager::SetImageWindow ( vtkImageWindow * win )

These set methods are used by the image window, and should not be used by anyone else. They do not reference count the window.

void vtkImager::SetVTKWindow ( vtkWindow * win )

These set methods are used by the image window, and should not be used by anyone else. They do not reference count the window.

virtual void vtkImager::Erase ( ) [inline, virtual]

Erase the contents of the imager in the window.

Reimplemented in vtkMesaImager, and vtkOpenGLImager.

Definition at line 84 of file vtkImager.h.

virtual vtkAssemblyPath* vtkImager::PickProp | ( | float | selectionX,
 |  | float | selectionY
 | ) | [virtual]

Return the Prop that has the highest z value at the given x, y position in the viewport. Basically, the top most prop that renders the pixel at selectionX, selectionY will be returned. If no Props are there NULL is returned. This method selects from the Viewports Prop list.

Reimplemented from vtkViewport.

virtual float vtkImager::GetPickedZ ( ) [virtual]

Return the Z value for the last picked Prop.

Reimplemented from vtkViewport.

virtual void vtkImager::StartPick ( unsigned int pickFromSize ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkImager::UpdatePickId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkImager::DonePick ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual unsigned int vtkImager::GetPickedId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkImager::DevicePickRender ( ) [protected, virtual]

Reimplemented from vtkViewport.

The documentation for this class was generated from the following file:
  • Rendering/vtkImager.h
Generated on Mon Mar 25 01:19:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRange3D Class Reference

Max - min of a circular neighborhood. More...

#include <vtkImageRange3D.h>

Inheritance diagram for vtkImageRange3D:

[legend]
Collaboration diagram for vtkImageRange3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageRange3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetKernelSize (int size0, int size1, int size2)

Static Public Methods

vtkImageRange3D * | New ()

Protected Methods

vtkImageRange3D ()
~vtkImageRange3D ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

vtkImageEllipsoidSource * Ellipse

Detailed Description

Max - min of a circular neighborhood.

Date:
2002/01/22 15:33:19
Revision:
1.24

vtkImageRange3D replaces a pixel with the maximum minus minimum over an ellipsoidal neighborhood. If KernelSize of an axis is 1, no processing is done on that axis.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (84%)
  • Martin, Ken (8%)
Tests:
vtkImageRange3D (Tests)

Definition at line 45 of file vtkImageRange3D.h.

Constructor & Destructor Documentation

vtkImageRange3D::vtkImageRange3D ( ) [protected]

vtkImageRange3D::~vtkImageRange3D ( ) [protected]

Member Function Documentation

vtkImageRange3D* vtkImageRange3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageRange3D::vtkTypeRevisionMacro | ( | vtkImageRange3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageRange3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageRange3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood and computes the elliptical foot print.

void vtkImageRange3D::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageSpatialFilter.

void vtkImageRange3D::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageSpatialFilter.

Definition at line 64 of file vtkImageRange3D.h.

void vtkImageRange3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageEllipsoidSource* vtkImageRange3D::Ellipse [protected]

Definition at line 61 of file vtkImageRange3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageRange3D.h
Generated on Mon Mar 25 01:19:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagerCollection Class Reference

a collection of imagers. More...

#include <vtkImagerCollection.h>

Inheritance diagram for vtkImagerCollection:

[legend]
Collaboration diagram for vtkImagerCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImagerCollection, vtkCollection)
void | AddItem (vtkImager *a)
vtkImager * GetNextItem ()
vtkImager * GetLastItem ()

Static Public Methods

vtkImagerCollection * | New ()

Protected Methods

vtkImagerCollection ()
~vtkImagerCollection ()

Detailed Description

a collection of imagers.

Date:
2002/01/22 15:38:34
Revision:
1.21

Simple collection class for vtkImagers

See also:
vtkCollection vtkImager
Created by:
  • Hoffman, Bill
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (64%)
  • Hoffman, Bill (25%)
  • Miller, Jim (5%)

Definition at line 44 of file vtkImagerCollection.h.

Constructor & Destructor Documentation

vtkImagerCollection::vtkImagerCollection ( ) [inline, protected]

Definition at line 58 of file vtkImagerCollection.h.

vtkImagerCollection::~vtkImagerCollection ( ) [inline, protected]

Definition at line 59 of file vtkImagerCollection.h.

Member Function Documentation

vtkImagerCollection* vtkImagerCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkImagerCollection::vtkTypeRevisionMacro | ( | vtkImagerCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkImagerCollection::AddItem ( vtkImager * a ) [inline]

Standard methods for manipulating the collection.

Definition at line 70 of file vtkImagerCollection.h.

vtkImager * vtkImagerCollection::GetNextItem ( ) [inline]

Standard methods for manipulating the collection.

Definition at line 75 of file vtkImagerCollection.h.

vtkImager * vtkImagerCollection::GetLastItem ( ) [inline]

Standard methods for manipulating the collection.

Definition at line 80 of file vtkImagerCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImagerCollection.h
Generated on Mon Mar 25 01:19:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader Class Reference

Superclass of transformable binary file readers. More...

#include <vtkImageReader.h>

Inheritance diagram for vtkImageReader:

[legend]
Collaboration diagram for vtkImageReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageReader, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ComputeInverseTransformedExtent (int inExtent[6], int outExtent[6])
void | ComputeInverseTransformedIncrements (int inIncr[3], int outIncr[3])
int | OpenAndSeekFile (int extent[6], int slice)
virtual void | SetDataVOI (int, int, int, int, int, int)
virtual void | SetDataVOI (int[6])
virtual int * | GetDataVOI ()
virtual void | GetDataVOI (int &, int &, int &, int &, int &, int &)
virtual void | GetDataVOI (int[6])
virtual unsigned short | GetDataMask ()
void | SetDataMask (int val)
virtual void | SetTransform (vtkTransform *)
virtual vtkTransform * | GetTransform ()

Static Public Methods

vtkImageReader * | New ()

Protected Methods

vtkImageReader ()
~vtkImageReader ()
void | ComputeTransformedSpacing (float Spacing[3])
void | ComputeTransformedOrigin (float origin[3])
void | ComputeTransformedExtent (int inExtent[6], int outExtent[6])
void | ComputeTransformedIncrements (int inIncr[3], int outIncr[3])
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *data)

Protected Attributes

unsigned short | DataMask
vtkTransform * Transform
int | DataVOI [6]

Detailed Description

Superclass of transformable binary file readers.

Date:
2002/02/19 15:15:45
Revision:
1.64

vtkImageReader provides methods needed to read a region from a file. It supports both transforms and masks on the input data, but as a result is more complicated and slower than its parent class vtkImageReader2.

See also:
vtkBMPReader vtkPNMReader vtkTIFFReader
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Martin, Ken (39%)
  • Law, Charles (36%)
  • Hoffman, Bill (7%)
Examples:
vtkImageReader (Examples)
Tests:
vtkImageReader (Tests)

Definition at line 53 of file vtkImageReader.h.

Constructor & Destructor Documentation

vtkImageReader::vtkImageReader ( ) [protected]

vtkImageReader::~vtkImageReader ( ) [protected]

Member Function Documentation

vtkImageReader* vtkImageReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Reimplemented in vtkBMPReader, and vtkPNMReader.

vtkImageReader::vtkTypeRevisionMacro | ( | vtkImageReader | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageReader2.

Reimplemented in vtkBMPReader, and vtkPNMReader.

void vtkImageReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageReader2.

Reimplemented in vtkBMPReader.

virtual void vtkImageReader::SetDataVOI | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/get the data VOI. You can limit the reader to only read a subset of the data.

virtual void vtkImageReader::SetDataVOI ( int [6] ) [virtual]

Set/get the data VOI. You can limit the reader to only read a subset of the data.

virtual int* vtkImageReader::GetDataVOI ( ) [virtual]

Set/get the data VOI. You can limit the reader to only read a subset of the data.

virtual void vtkImageReader::GetDataVOI | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/get the data VOI. You can limit the reader to only read a subset of the data.

virtual void vtkImageReader::GetDataVOI ( int [6] ) [virtual]

Set/get the data VOI. You can limit the reader to only read a subset of the data.

virtual unsigned short vtkImageReader::GetDataMask ( ) [virtual]

Set/Get the Data mask.

void vtkImageReader::SetDataMask ( int val ) [inline]

Set/Get the Data mask.

Definition at line 70 of file vtkImageReader.h.

virtual void vtkImageReader::SetTransform ( vtkTransform * ) [virtual]

Set/Get transformation matrix to transform the data from slice space into world space. This matrix must be a permutation matrix. To qualify, the sums of the rows must be + or - 1.

virtual vtkTransform* vtkImageReader::GetTransform ( ) [virtual]

Set/Get transformation matrix to transform the data from slice space into world space. This matrix must be a permutation matrix. To qualify, the sums of the rows must be + or - 1.

void vtkImageReader::ComputeInverseTransformedExtent | ( | int | inExtent[6],
 |  | int | outExtent[6]
 | ) |

void vtkImageReader::ComputeInverseTransformedIncrements | ( | int | inIncr[3],
 |  | int | outIncr[3]
 | ) |

int vtkImageReader::OpenAndSeekFile | ( | int | extent[6],
 |  | int | slice
 | ) |

void vtkImageReader::ComputeTransformedSpacing ( float Spacing[3] ) [protected]

void vtkImageReader::ComputeTransformedOrigin ( float origin[3] ) [protected]

void vtkImageReader::ComputeTransformedExtent | ( | int | inExtent[6],
 |  | int | outExtent[6]
 | ) | [protected]

void vtkImageReader::ComputeTransformedIncrements | ( | int | inIncr[3],
 |  | int | outIncr[3]
 | ) | [protected]

void vtkImageReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

Reimplemented in vtkBMPReader, and vtkPNMReader.

void vtkImageReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

Reimplemented in vtkBMPReader.

Member Data Documentation

unsigned short vtkImageReader::DataMask [protected]

Definition at line 95 of file vtkImageReader.h.

vtkTransform* vtkImageReader::Transform [protected]

Definition at line 97 of file vtkImageReader.h.

int vtkImageReader::DataVOI[6] [protected]

Definition at line 106 of file vtkImageReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkImageReader.h
Generated on Mon Mar 25 01:19:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2 Class Reference

Superclass of binary file readers. More...

#include <vtkImageReader2.h>

Inheritance diagram for vtkImageReader2:

[legend]
Collaboration diagram for vtkImageReader2:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageReader2, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetHeaderSize (unsigned long size)
ifstream * | GetFile ()
virtual unsigned long * | GetDataIncrements ()
virtual void | GetDataIncrements (unsigned long data[4])
int | OpenFile ()
void | SeekFile (int i, int j, int k)
void | SetFileName (const char *)
virtual char * | GetFileName ()
void | SetFilePrefix (const char *)
virtual char * | GetFilePrefix ()
void | SetFilePattern (const char *)
virtual char * | GetFilePattern ()
void | SetDataScalarType (int type)
void | SetDataScalarTypeToFloat ()
void | SetDataScalarTypeToDouble ()
void | SetDataScalarTypeToInt ()
void | SetDataScalarTypeToShort ()
void | SetDataScalarTypeToUnsignedShort ()
void | SetDataScalarTypeToUnsignedChar ()
virtual int | GetDataScalarType ()
virtual void | SetNumberOfScalarComponents (int)
virtual int | GetNumberOfScalarComponents ()
virtual void | SetDataExtent (int, int, int, int, int, int)
virtual void | SetDataExtent (int[6])
virtual int * | GetDataExtent ()
virtual void | GetDataExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetDataExtent (int[6])
virtual void | SetFileDimensionality (int)
int | GetFileDimensionality ()
virtual void | SetDataSpacing (float, float, float)
virtual void | SetDataSpacing (float[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float &, float &, float &)
virtual void | GetDataSpacing (float[3])
virtual void | SetDataOrigin (float, float, float)
virtual void | SetDataOrigin (float[3])
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float &, float &, float &)
virtual void | GetDataOrigin (float[3])
unsigned long | GetHeaderSize ()
unsigned long | GetHeaderSize (unsigned long slice)
void | SetDataByteOrderToBigEndian ()
void | SetDataByteOrderToLittleEndian ()
int | GetDataByteOrder ()
void | SetDataByteOrder (int)
const char * | GetDataByteOrderAsString ()
virtual void | SetFileNameSliceOffset (int)
virtual int | GetFileNameSliceOffset ()
virtual void | SetFileNameSliceSpacing (int)
virtual int | GetFileNameSliceSpacing ()
virtual void | SetSwapBytes (int)
int | GetSwapBytes ()
virtual void | SwapBytesOn ()
virtual void | SwapBytesOff ()
virtual void | FileLowerLeftOn ()
virtual void | FileLowerLeftOff ()
virtual int | GetFileLowerLeft ()
virtual void | SetFileLowerLeft (int)
void | ComputeInternalFileName (int slice)
virtual char * | GetInternalFileName ()
virtual vtkImageReader2 * | MakeObject ()
virtual int | CanReadFile (const char *vtkNotUsed(fname))
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkImageReader2 * | New ()

Protected Methods

vtkImageReader2 ()
~vtkImageReader2 ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)
virtual void | ComputeDataIncrements ()

Protected Attributes

char * | InternalFileName
char * | FileName
char * | FilePrefix
char * | FilePattern
int | NumberOfScalarComponents
int | FileLowerLeft
ifstream * | File
unsigned long | DataIncrements [4]
int | DataExtent [6]
int | SwapBytes
int | FileDimensionality
unsigned long | HeaderSize
int | DataScalarType
unsigned long | ManualHeaderSize
float | DataSpacing [3]
float | DataOrigin [3]
int | FileNameSliceOffset
int | FileNameSliceSpacing

Detailed Description

Superclass of binary file readers.

Date:
2002/02/19 16:30:42
Revision:
1.15

vtkImageReader2 is the parent class for vtkImageReader. It is a good super class for streaming readers that do not require a mask or transform on the data. vtkImageReader was implemented before vtkImageReader2, vtkImageReader2 is intended to have a simpler interface.

See also:
vtkJPEGReader vtkPNGReader vtkImageReader vtkGESignaReader
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (78%)
  • Hoffman, Bill (11%)

Definition at line 47 of file vtkImageReader2.h.

Constructor & Destructor Documentation

vtkImageReader2::vtkImageReader2 ( ) [protected]

vtkImageReader2::~vtkImageReader2 ( ) [protected]

Member Function Documentation

vtkImageReader2* vtkImageReader2::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkImageReader, vtkJPEGReader, vtkMedicalImageReader2, vtkPNGReader, vtkPNMReader, vtkSLCReader, and vtkTIFFReader.

Referenced by MakeObject().

vtkImageReader2::vtkTypeRevisionMacro | ( | vtkImageReader2 | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkImageReader, vtkJPEGReader, vtkMedicalImageReader2, vtkPNGReader, vtkPNMReader, and vtkSLCReader.

void vtkImageReader2::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkBMPReader, vtkImageReader, vtkMedicalImageReader2, and vtkSLCReader.

void vtkImageReader2::SetFileName ( const char * )

Specify file name for the image file. You should specify either a FileName or a FilePrefix. Use FilePrefix if the data is stored in multiple files.

Reimplemented in vtkSLCReader.

virtual char* vtkImageReader2::GetFileName ( ) [virtual]

Specify file name for the image file. You should specify either a FileName or a FilePrefix. Use FilePrefix if the data is stored in multiple files.

Reimplemented in vtkSLCReader.

void vtkImageReader2::SetFilePrefix ( const char * )

Specify file prefix for the image file(s).You should specify either a FileName or FilePrefix. Use FilePrefix if the data is stored in multiple files.

virtual char* vtkImageReader2::GetFilePrefix ( ) [virtual]

Specify file prefix for the image file(s).You should specify either a FileName or FilePrefix. Use FilePrefix if the data is stored in multiple files.

void vtkImageReader2::SetFilePattern ( const char * )

The sprintf format used to build filename from FilePrefix and number.

virtual char* vtkImageReader2::GetFilePattern ( ) [virtual]

The sprintf format used to build filename from FilePrefix and number.

void vtkImageReader2::SetDataScalarType ( int type )

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

void vtkImageReader2::SetDataScalarTypeToFloat ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 81 of file vtkImageReader2.h.

void vtkImageReader2::SetDataScalarTypeToDouble ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 82 of file vtkImageReader2.h.

void vtkImageReader2::SetDataScalarTypeToInt ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 83 of file vtkImageReader2.h.

void vtkImageReader2::SetDataScalarTypeToShort ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 84 of file vtkImageReader2.h.

void vtkImageReader2::SetDataScalarTypeToUnsignedShort ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 85 of file vtkImageReader2.h.

void vtkImageReader2::SetDataScalarTypeToUnsignedChar ( ) [inline]

Set the data type of pixels in the file. If you want the output scalar type to have a different value, set it after this method is called.

Definition at line 87 of file vtkImageReader2.h.

virtual int vtkImageReader2::GetDataScalarType ( ) [virtual]

Get the file format. Pixels are this type in the file.

virtual void vtkImageReader2::SetNumberOfScalarComponents ( int ) [virtual]

Set/Get the number of scalar components

virtual int vtkImageReader2::GetNumberOfScalarComponents ( ) [virtual]

Set/Get the number of scalar components

virtual void vtkImageReader2::SetDataExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Get/Set the extent of the data on disk.

virtual void vtkImageReader2::SetDataExtent ( int [6] ) [virtual]

Get/Set the extent of the data on disk.

virtual int* vtkImageReader2::GetDataExtent ( ) [virtual]

Get/Set the extent of the data on disk.

virtual void vtkImageReader2::GetDataExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get/Set the extent of the data on disk.

virtual void vtkImageReader2::GetDataExtent ( int [6] ) [virtual]

Get/Set the extent of the data on disk.

virtual void vtkImageReader2::SetFileDimensionality ( int ) [virtual]

The number of dimensions stored in a file. This defaults to two.

int vtkImageReader2::GetFileDimensionality ( ) [inline]

The number of dimensions stored in a file. This defaults to two.

Definition at line 111 of file vtkImageReader2.h.

virtual void vtkImageReader2::SetDataSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the spacing of the data in the file.

virtual void vtkImageReader2::SetDataSpacing ( float [3] ) [virtual]

Set/Get the spacing of the data in the file.

virtual float* vtkImageReader2::GetDataSpacing ( ) [virtual]

Set/Get the spacing of the data in the file.

virtual void vtkImageReader2::GetDataSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the spacing of the data in the file.

virtual void vtkImageReader2::GetDataSpacing ( float [3] ) [virtual]

Set/Get the spacing of the data in the file.

virtual void vtkImageReader2::SetDataOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the origin of the data (location of first pixel in the file).

virtual void vtkImageReader2::SetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data (location of first pixel in the file).

virtual float* vtkImageReader2::GetDataOrigin ( ) [virtual]

Set/Get the origin of the data (location of first pixel in the file).

virtual void vtkImageReader2::GetDataOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the origin of the data (location of first pixel in the file).

virtual void vtkImageReader2::GetDataOrigin ( float [3] ) [virtual]

Set/Get the origin of the data (location of first pixel in the file).

unsigned long vtkImageReader2::GetHeaderSize ( )

Get the size of the header computed by this object.

unsigned long vtkImageReader2::GetHeaderSize ( unsigned long slice )

Get the size of the header computed by this object.

void vtkImageReader2::SetHeaderSize ( unsigned long size )

If there is a tail on the file, you want to explicitly set the header size.

void vtkImageReader2::SetDataByteOrderToBigEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkImageReader2::SetDataByteOrderToLittleEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

int vtkImageReader2::GetDataByteOrder ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkImageReader2::SetDataByteOrder ( int )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

const char* vtkImageReader2::GetDataByteOrderAsString ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

virtual void vtkImageReader2::SetFileNameSliceOffset ( int ) [virtual]

When reading files which start at an unusual index, this can be added to the slice number when generating the file name (default = 0)

virtual int vtkImageReader2::GetFileNameSliceOffset ( ) [virtual]

When reading files which start at an unusual index, this can be added to the slice number when generating the file name (default = 0)

virtual void vtkImageReader2::SetFileNameSliceSpacing ( int ) [virtual]

When reading files which have regular, but non contiguous slices (eg filename.1,filename.3,filename.5) a spacing can be specified to skip missing files (default = 1)

virtual int vtkImageReader2::GetFileNameSliceSpacing ( ) [virtual]

When reading files which have regular, but non contiguous slices (eg filename.1,filename.3,filename.5) a spacing can be specified to skip missing files (default = 1)

virtual void vtkImageReader2::SetSwapBytes ( int ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

int vtkImageReader2::GetSwapBytes ( ) [inline]

Set/Get the byte swapping to explicitly swap the bytes of a file.

Definition at line 173 of file vtkImageReader2.h.

virtual void vtkImageReader2::SwapBytesOn ( ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

virtual void vtkImageReader2::SwapBytesOff ( ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

ifstream* vtkImageReader2::GetFile ( ) [inline]

Definition at line 178 of file vtkImageReader2.h.

virtual unsigned long* vtkImageReader2::GetDataIncrements ( ) [virtual]

virtual void vtkImageReader2::GetDataIncrements ( unsigned long data[4] ) [virtual]

int vtkImageReader2::OpenFile ( )

void vtkImageReader2::SeekFile | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

virtual void vtkImageReader2::FileLowerLeftOn ( ) [virtual]

Set/Get whether the data comes from the file starting in the lower left corner or upper left corner.

virtual void vtkImageReader2::FileLowerLeftOff ( ) [virtual]

Set/Get whether the data comes from the file starting in the lower left corner or upper left corner.

virtual int vtkImageReader2::GetFileLowerLeft ( ) [virtual]

Set/Get whether the data comes from the file starting in the lower left corner or upper left corner.

virtual void vtkImageReader2::SetFileLowerLeft ( int ) [virtual]

Set/Get whether the data comes from the file starting in the lower left corner or upper left corner.

void vtkImageReader2::ComputeInternalFileName ( int slice )

Set/Get the internal file name

virtual char* vtkImageReader2::GetInternalFileName ( ) [virtual]

Set/Get the internal file name

virtual vtkImageReader2* vtkImageReader2::MakeObject ( ) [inline, virtual]

Set/Get the internal file name

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkJPEGReader, vtkPNGReader, vtkPNMReader, vtkSLCReader, and vtkTIFFReader.

Definition at line 200 of file vtkImageReader2.h.

virtual int vtkImageReader2::CanReadFile ( const char *vtkNotUsed(fname) ) [inline, virtual]

Set/Get the internal file name

Definition at line 204 of file vtkImageReader2.h.

virtual const char* vtkImageReader2::GetFileExensions ( ) [inline, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkJPEGReader, vtkPNGReader, vtkPNMReader, vtkSLCReader, and vtkTIFFReader.

Definition at line 213 of file vtkImageReader2.h.

virtual const char* vtkImageReader2::GetDescriptiveName ( ) [inline, virtual]

Return a descriptive name for the file format that might be useful in a GUI.

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkJPEGReader, vtkPNGReader, vtkPNMReader, vtkSLCReader, and vtkTIFFReader.

Definition at line 222 of file vtkImageReader2.h.

virtual void vtkImageReader2::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkImageReader, vtkJPEGReader, vtkPNGReader, vtkPNMReader, vtkSLCReader, and vtkTIFFReader.

virtual void vtkImageReader2::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented in vtkBMPReader, vtkGESignaReader, vtkImageReader, vtkJPEGReader, vtkPNGReader, vtkSLCReader, and vtkTIFFReader.

virtual void vtkImageReader2::ComputeDataIncrements ( ) [protected, virtual]

Reimplemented in vtkBMPReader.

Member Data Documentation

char* vtkImageReader2::InternalFileName [protected]

Definition at line 231 of file vtkImageReader2.h.

char* vtkImageReader2::FileName [protected]

Definition at line 232 of file vtkImageReader2.h.

char* vtkImageReader2::FilePrefix [protected]

Definition at line 233 of file vtkImageReader2.h.

char* vtkImageReader2::FilePattern [protected]

Definition at line 234 of file vtkImageReader2.h.

int vtkImageReader2::NumberOfScalarComponents [protected]

Definition at line 235 of file vtkImageReader2.h.

int vtkImageReader2::FileLowerLeft [protected]

Definition at line 236 of file vtkImageReader2.h.

ifstream* vtkImageReader2::File [protected]

Definition at line 238 of file vtkImageReader2.h.

unsigned long vtkImageReader2::DataIncrements[4] [protected]

Definition at line 239 of file vtkImageReader2.h.

int vtkImageReader2::DataExtent[6] [protected]

Definition at line 240 of file vtkImageReader2.h.

int vtkImageReader2::SwapBytes [protected]

Definition at line 241 of file vtkImageReader2.h.

int vtkImageReader2::FileDimensionality [protected]

Definition at line 243 of file vtkImageReader2.h.

unsigned long vtkImageReader2::HeaderSize [protected]

Definition at line 244 of file vtkImageReader2.h.

int vtkImageReader2::DataScalarType [protected]

Definition at line 245 of file vtkImageReader2.h.

unsigned long vtkImageReader2::ManualHeaderSize [protected]

Definition at line 246 of file vtkImageReader2.h.

float vtkImageReader2::DataSpacing[3] [protected]

Definition at line 248 of file vtkImageReader2.h.

float vtkImageReader2::DataOrigin[3] [protected]

Definition at line 249 of file vtkImageReader2.h.

int vtkImageReader2::FileNameSliceOffset [protected]

Definition at line 251 of file vtkImageReader2.h.

int vtkImageReader2::FileNameSliceSpacing [protected]

Definition at line 252 of file vtkImageReader2.h.

The documentation for this class was generated from the following file:
  • IO/vtkImageReader2.h
Generated on Mon Mar 25 01:19:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2Collection Class Reference

maintain a list of implicit functions. More...

#include <vtkImageReader2Collection.h>

Inheritance diagram for vtkImageReader2Collection:

[legend]
Collaboration diagram for vtkImageReader2Collection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageReader2Collection, vtkCollection)
void | AddItem (vtkImageReader2 *)
vtkImageReader2 * GetNextItem ()

Static Public Methods

vtkImageReader2Collection * | New ()

Protected Methods

vtkImageReader2Collection ()
~vtkImageReader2Collection ()

Detailed Description

maintain a list of implicit functions.

Date:
2002/01/22 15:38:14
Revision:
1.3

vtkImageReader2Collection is an object that creates and manipulates lists of objects of type vtkImplicitFunction.

See also:
vtkCollection vtkPlaneCollection
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (100%)

Definition at line 40 of file vtkImageReader2Collection.h.

Constructor & Destructor Documentation

vtkImageReader2Collection::vtkImageReader2Collection ( ) [inline, protected]

Definition at line 53 of file vtkImageReader2Collection.h.

vtkImageReader2Collection::~vtkImageReader2Collection ( ) [inline, protected]

Definition at line 54 of file vtkImageReader2Collection.h.

Member Function Documentation

vtkImageReader2Collection::vtkTypeRevisionMacro | ( | vtkImageReader2Collection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkImageReader2Collection* vtkImageReader2Collection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkImageReader2Collection::AddItem ( vtkImageReader2 * f ) [inline]

Add an implicit function to the list.

Definition at line 66 of file vtkImageReader2Collection.h.

vtkImageReader2 * vtkImageReader2Collection::GetNextItem ( ) [inline]

Get the next implicit function in the list.

Definition at line 71 of file vtkImageReader2Collection.h.

The documentation for this class was generated from the following file:
  • IO/vtkImageReader2Collection.h
Generated on Mon Mar 25 01:19:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReader2Factory Class Reference

Superclass of binary file readers. More...

#include <vtkImageReader2Factory.h>

Inheritance diagram for vtkImageReader2Factory:

[legend]
Collaboration diagram for vtkImageReader2Factory:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageReader2Factory, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkImageReader2Factory * | New ()
void | RegisterReader (vtkImageReader2 *r)
vtkImageReader2 * | CreateImageReader2 (const char *path)
void | GetRegisteredReaders (vtkImageReader2Collection *)

Protected Methods

vtkImageReader2Factory ()
~vtkImageReader2Factory ()

Static Protected Methods

void | InitializeReaders ()

Friends

class | vtkCleanUpImageReader2Factory

Detailed Description

Superclass of binary file readers.

Date:
2002/01/22 15:38:15
Revision:
1.4

vtkImageReader2Factory: This class is used to create a vtkImageReader2 object given a path name to a file. It calls CanReadFile on all availiable readers until one of them returns ture. The availiable reader list comes from three places. In the InitializeReaders function of this class, built-in VTK classes are added to the list, users can call RegisterReader, or users can create a vtkObjectFactory that has CreateObject method that returns a new vtkImageReader2 sub class when given the string "vtkImageReaderObject". This way applications can be extened with new readers via a plugin dll or by calling RegisterReader. Of course all of the readers that are part of the vtk release are made automatically availiable.

See also:
vtkImageReader2
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (100%)
Examples:
vtkImageReader2Factory (Examples)
Tests:
vtkImageReader2Factory (Tests)

Definition at line 58 of file vtkImageReader2Factory.h.

Constructor & Destructor Documentation

vtkImageReader2Factory::vtkImageReader2Factory ( ) [protected]

vtkImageReader2Factory::~vtkImageReader2Factory ( ) [protected]

Member Function Documentation

vtkImageReader2Factory* vtkImageReader2Factory::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkImageReader2Factory::vtkTypeRevisionMacro | ( | vtkImageReader2Factory | ,
 |  | vtkObject |
 | ) |

void vtkImageReader2Factory::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkImageReader2Factory::RegisterReader ( vtkImageReader2 * r ) [static]

registered readers will be queried in CreateImageReader2 to see if they can load a given file.

vtkImageReader2* vtkImageReader2Factory::CreateImageReader2 ( const char * path ) [static]

open the image file, it is the callers responsibility to call Delete on the returned object. If no reader is found, null is returned.

void vtkImageReader2Factory::GetRegisteredReaders ( vtkImageReader2Collection * ) [static]

The caller must allocate the vtkImageReader2Collection and pass in the pointer to this method.

void vtkImageReader2Factory::InitializeReaders ( ) [static, protected]

Friends And Related Function Documentation

friend class vtkCleanUpImageReader2Factory [friend]

Definition at line 87 of file vtkImageReader2Factory.h.

The documentation for this class was generated from the following file:
  • IO/vtkImageReader2Factory.h
Generated on Mon Mar 25 01:19:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageResample Class Reference

Resamples an image to be larger or smaller. More...

#include <vtkImageResample.h>

Inheritance diagram for vtkImageResample:

[legend]
Collaboration diagram for vtkImageResample:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageResample, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetAxisOutputSpacing (int axis, float spacing)
void | SetAxisMagnificationFactor (int axis, float factor)
float | GetAxisMagnificationFactor (int axis)
virtual void | SetInterpolate (int)
virtual int | GetInterpolate ()
virtual void | InterpolateOn ()
virtual void | InterpolateOff ()
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageResample * | New ()

Protected Methods

vtkImageResample ()
~vtkImageResample ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

float | MagnificationFactors [3]
float | OutputSpacing [3]
int | Interpolate
int | Dimensionality

Detailed Description

Resamples an image to be larger or smaller.

Date:
2002/01/22 15:33:20
Revision:
1.32

This filter produces an output with different spacing (and extent) than the input. Linear interpolation can be used to resample the data. The Output spacing can be set explicitly or relative to input spacing with the SetAxisMagnificationFactor method.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Martin, Ken (48%)
  • Law, Charles (47%)
Tests:
vtkImageResample (Tests)

Definition at line 44 of file vtkImageResample.h.

Constructor & Destructor Documentation

vtkImageResample::vtkImageResample ( ) [protected]

vtkImageResample::~vtkImageResample ( ) [inline, protected]

Definition at line 80 of file vtkImageResample.h.

Member Function Documentation

vtkImageResample* vtkImageResample::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageResample::vtkTypeRevisionMacro | ( | vtkImageResample | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageResample::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageResample::SetAxisOutputSpacing | ( | int | axis,
 |  | float | spacing
 | ) |

Set desired spacing. Zero is a reserved value indicating spacing has not been set.

void vtkImageResample::SetAxisMagnificationFactor | ( | int | axis,
 |  | float | factor
 | ) |

Set/Get Magnification factors. Zero is a reserved value indicating values have not been computed.

float vtkImageResample::GetAxisMagnificationFactor ( int axis )

Set/Get Magnification factors. Zero is a reserved value indicating values have not been computed.

virtual void vtkImageResample::SetInterpolate ( int ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual int vtkImageResample::GetInterpolate ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual void vtkImageResample::InterpolateOn ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual void vtkImageResample::InterpolateOff ( ) [virtual]

Turn interpolation on and off (pixel replication is used when off).

virtual void vtkImageResample::SetDimensionality ( int ) [virtual]

Dimensionality is the number of axes which are considered during execution. To process images dimensionality would be set to 2. This has the same effect as setting the output spacing of the third axis to 1.0

virtual int vtkImageResample::GetDimensionality ( ) [virtual]

Dimensionality is the number of axes which are considered during execution. To process images dimensionality would be set to 2. This has the same effect as setting the output spacing of the third axis to 1.0

void vtkImageResample::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageResample::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageResample::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 89 of file vtkImageResample.h.

void vtkImageResample::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageResample::MagnificationFactors[3] [protected]

Definition at line 82 of file vtkImageResample.h.

float vtkImageResample::OutputSpacing[3] [protected]

Definition at line 83 of file vtkImageResample.h.

int vtkImageResample::Interpolate [protected]

Definition at line 84 of file vtkImageResample.h.

int vtkImageResample::Dimensionality [protected]

Definition at line 85 of file vtkImageResample.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageResample.h
Generated on Mon Mar 25 01:19:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageReslice Class Reference

Reslices a volume along a new set of axes. More...

#include <vtkImageReslice.h>

Inheritance diagram for vtkImageReslice:

[legend]
Collaboration diagram for vtkImageReslice:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageReslice, vtkImageToImageFilter)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
virtual void | SetResliceAxes (vtkMatrix4x4 *)
virtual vtkMatrix4x4 * | GetResliceAxes ()
void | SetResliceAxesDirectionCosines (double x0, double x1, double x2, double y0, double y1, double y2, double z0, double z1, double z2)
void | SetResliceAxesDirectionCosines (const double x[3], const double y[3], const double z[3])
void | SetResliceAxesDirectionCosines (const double xyz[9])
void | GetResliceAxesDirectionCosines (double x[3], double y[3], double z[3])
void | GetResliceAxesDirectionCosines (double xyz[9])
double * | GetResliceAxesDirectionCosines ()
void | SetResliceAxesOrigin (double x, double y, double z)
void | SetResliceAxesOrigin (const double xyz[3])
void | GetResliceAxesOrigin (double xyz[3])
double * | GetResliceAxesOrigin ()
virtual void | SetResliceTransform (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetResliceTransform ()
virtual void | SetInformationInput (vtkImageData *)
virtual vtkImageData * | GetInformationInput ()
virtual void | SetTransformInputSampling (int)
virtual void | TransformInputSamplingOn ()
virtual void | TransformInputSamplingOff ()
virtual int | GetTransformInputSampling ()
virtual void | SetAutoCropOutput (int)
virtual void | AutoCropOutputOn ()
virtual void | AutoCropOutputOff ()
virtual int | GetAutoCropOutput ()
virtual void | SetWrap (int)
virtual int | GetWrap ()
virtual void | WrapOn ()
virtual void | WrapOff ()
virtual void | SetMirror (int)
virtual int | GetMirror ()
virtual void | MirrorOn ()
virtual void | MirrorOff ()
virtual void | SetInterpolationMode (int)
virtual int | GetInterpolationMode ()
void | SetInterpolationModeToNearestNeighbor ()
void | SetInterpolationModeToLinear ()
void | SetInterpolationModeToCubic ()
const char * | GetInterpolationModeAsString ()
virtual void | SetOptimization (int)
virtual int | GetOptimization ()
virtual void | OptimizationOn ()
virtual void | OptimizationOff ()
virtual void | SetBackgroundColor (float, float, float, float)
virtual void | SetBackgroundColor (float[4])
virtual float * | GetBackgroundColor ()
virtual void | GetBackgroundColor (float &, float &, float &, float &)
virtual void | GetBackgroundColor (float[4])
void | SetBackgroundLevel (float v)
float | GetBackgroundLevel ()
virtual void | SetOutputSpacing (float, float, float)
virtual void | SetOutputSpacing (float[3])
virtual float * | GetOutputSpacing ()
virtual void | GetOutputSpacing (float &, float &, float &)
virtual void | GetOutputSpacing (float[3])
void | SetOutputSpacingToDefault ()
virtual void | SetOutputOrigin (float, float, float)
virtual void | SetOutputOrigin (float[3])
virtual float * | GetOutputOrigin ()
virtual void | GetOutputOrigin (float &, float &, float &)
virtual void | GetOutputOrigin (float[3])
void | SetOutputOriginToDefault ()
virtual void | SetOutputExtent (int, int, int, int, int, int)
virtual void | SetOutputExtent (int[6])
virtual int * | GetOutputExtent ()
virtual void | GetOutputExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetOutputExtent (int[6])
void | SetOutputExtentToDefault ()
virtual void | SetOutputDimensionality (int)
virtual int | GetOutputDimensionality ()
void | SetInterpolate (int t)
void | InterpolateOn ()
void | InterpolateOff ()
int | GetInterpolate ()
void | SetStencil (vtkImageStencilData *stencil)
vtkImageStencilData * GetStencil ()

Static Public Methods

vtkImageReslice * | New ()

Protected Methods

vtkImageReslice ()
~vtkImageReslice ()
void | GetAutoCroppedOutputBounds (vtkImageData *input, float bounds[6])
void | ExecuteInformation (vtkImageData *input, vtkImageData *output)
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)
vtkMatrix4x4 * GetIndexMatrix ()
vtkAbstractTransform * GetOptimizedTransform ()
void | OptimizedComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | OptimizedThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

vtkMatrix4x4 * ResliceAxes
double | ResliceAxesDirectionCosines [9]
double | ResliceAxesOrigin [3]
vtkAbstractTransform * ResliceTransform
vtkImageData * InformationInput
int | Wrap
int | Mirror
int | InterpolationMode
int | Optimization
float | BackgroundColor [4]
float | OutputOrigin [3]
float | OutputSpacing [3]
int | OutputExtent [6]
int | OutputDimensionality
int | TransformInputSampling
int | AutoCropOutput
vtkMatrix4x4 * IndexMatrix
vtkAbstractTransform * OptimizedTransform

Detailed Description

Reslices a volume along a new set of axes.

Date:
2002/01/22 15:33:22
Revision:
1.7

vtkImageReslice is the swiss-army-knife of image geometry filters: It can permute, rotate, flip, scale, resample, deform, and pad image data in any combination with reasonably high efficiency. Simple operations such as permutation, resampling and padding are done with similar efficiently to the specialized vtkImagePermute, vtkImageResample, and vtkImagePad filters. There are a number of tasks that vtkImageReslice is well suited for:

1) Application of simple rotations, scales, and translations to an image. It is often a good idea to use vtkImageChangeInformation to center the image first, so that scales and rotations occur around the center rather than around the lower-left corner of the image.

2) Resampling of one data set to match the voxel sampling of a second data set via the SetInformationInput() method, e.g. for the purpose of comparing two images or combining two images. A transformation, either linear or nonlinear, can be applied at the same time via the SetResliceTransform method if the two images are not in the same coordinate space.

3) Extraction of slices from an image volume. The most convenient way to do this is to use SetResliceAxesDirectionCosines() to specify the orientation of the slice. The direction cosines give the x, y, and z axes for the output volume. The method SetOutputDimensionality(2) is used to specify that want to output a slice rather than a volume. The SetResliceAxesOrigin() command is used to provide an (x,y,z) point that the slice will pass through. You can use both the ResliceAxes and the ResliceTransform at the same time, in order to extract slices from a volume that you have applied a transformation to.

Warning:
This filter is very inefficient if the output X dimension is 1.
See also:
vtkAbstractTransform vtkMatrix4x4
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)
Tests:
vtkImageReslice (Tests)

Definition at line 78 of file vtkImageReslice.h.

Constructor & Destructor Documentation

vtkImageReslice::vtkImageReslice ( ) [protected]

vtkImageReslice::~vtkImageReslice ( ) [protected]

Member Function Documentation

vtkImageReslice* vtkImageReslice::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageReslice::vtkTypeRevisionMacro | ( | vtkImageReslice | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageReslice::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageReslice::SetResliceAxes ( vtkMatrix4x4 * ) [virtual]

This method is used to set up the axes for the output voxels. The output Spacing, Origin, and Extent specify the locations of the voxels within the coordinate system defined by the axes. The ResliceAxes are used most often to permute the data, e.g. to extract ZY or XZ slices of a volume as 2D XY images.

The first column of the matrix specifies the x-axis vector (the fourth element must be set to zero), the second column specifies the y-axis, and the third column the z-axis. The fourth column is the origin of the axes (the fourth element must be set to one).

An alternative to SetResliceAxes() is to use SetResliceAxesDirectionCosines() to set the directions of the axes and SetResliceAxesOrigin() to set the origin of the axes.

virtual vtkMatrix4x4* vtkImageReslice::GetResliceAxes ( ) [virtual]

This method is used to set up the axes for the output voxels. The output Spacing, Origin, and Extent specify the locations of the voxels within the coordinate system defined by the axes. The ResliceAxes are used most often to permute the data, e.g. to extract ZY or XZ slices of a volume as 2D XY images.

The first column of the matrix specifies the x-axis vector (the fourth element must be set to zero), the second column specifies the y-axis, and the third column the z-axis. The fourth column is the origin of the axes (the fourth element must be set to one).

An alternative to SetResliceAxes() is to use SetResliceAxesDirectionCosines() to set the directions of the axes and SetResliceAxesOrigin() to set the origin of the axes.

void vtkImageReslice::SetResliceAxesDirectionCosines | ( | double | x0,
 |  | double | x1,
 |  | double | x2,
 |  | double | y0,
 |  | double | y1,
 |  | double | y2,
 |  | double | z0,
 |  | double | z1,
 |  | double | z2
 | ) |

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

void vtkImageReslice::SetResliceAxesDirectionCosines | ( | const double | x[3],
 |  | const double | y[3],
 |  | const double | z[3]
 | ) | [inline]

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

Definition at line 111 of file vtkImageReslice.h.

void vtkImageReslice::SetResliceAxesDirectionCosines ( const double xyz[9] ) [inline]

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

Definition at line 117 of file vtkImageReslice.h.

void vtkImageReslice::GetResliceAxesDirectionCosines | ( | double | x[3],
 |  | double | y[3],
 |  | double | z[3]
 | ) |

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

void vtkImageReslice::GetResliceAxesDirectionCosines ( double xyz[9] ) [inline]

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

Definition at line 122 of file vtkImageReslice.h.

double* vtkImageReslice::GetResliceAxesDirectionCosines ( ) [inline]

Specify the direction cosines for the ResliceAxes (i.e. the first three elements of each of the first three columns of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create a new matrix if none exists.

Definition at line 124 of file vtkImageReslice.h.

void vtkImageReslice::SetResliceAxesOrigin | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

Specify the origin for the ResliceAxes (i.e. the first three elements of the final column of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create new matrix if none exists.

void vtkImageReslice::SetResliceAxesOrigin ( const double xyz[3] ) [inline]

Specify the origin for the ResliceAxes (i.e. the first three elements of the final column of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create new matrix if none exists.

Definition at line 134 of file vtkImageReslice.h.

void vtkImageReslice::GetResliceAxesOrigin ( double xyz[3] )

Specify the origin for the ResliceAxes (i.e. the first three elements of the final column of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create new matrix if none exists.

double* vtkImageReslice::GetResliceAxesOrigin ( ) [inline]

Specify the origin for the ResliceAxes (i.e. the first three elements of the final column of the ResliceAxes matrix). This will modify the current ResliceAxes matrix, or create new matrix if none exists.

Definition at line 137 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetResliceTransform ( vtkAbstractTransform * ) [virtual]

Set a transform to be applied to the resampling grid that has been defined via the ResliceAxes and the output Origin, Spacing and Extent. Note that applying a transform to the resampling grid (which lies in the output coordinate system) is equivalent to applying the inverse of that transform to the input volume. Nonlinear transforms such as vtkGridTransform and vtkThinPlateSplineTransform can be used here.

virtual vtkAbstractTransform* vtkImageReslice::GetResliceTransform ( ) [virtual]

Set a transform to be applied to the resampling grid that has been defined via the ResliceAxes and the output Origin, Spacing and Extent. Note that applying a transform to the resampling grid (which lies in the output coordinate system) is equivalent to applying the inverse of that transform to the input volume. Nonlinear transforms such as vtkGridTransform and vtkThinPlateSplineTransform can be used here.

virtual void vtkImageReslice::SetInformationInput ( vtkImageData * ) [virtual]

Set a vtkImageData from which the default Spacing, Origin, and WholeExtent of the output will be copied. The spacing, origin, and extent will be permuted according to the ResliceAxes. Any values set via SetOutputSpacing, SetOutputOrigin, and SetOutputExtent will override these values. By default, the Spacing, Origin, and WholeExtent of the Input are used.

virtual vtkImageData* vtkImageReslice::GetInformationInput ( ) [virtual]

Set a vtkImageData from which the default Spacing, Origin, and WholeExtent of the output will be copied. The spacing, origin, and extent will be permuted according to the ResliceAxes. Any values set via SetOutputSpacing, SetOutputOrigin, and SetOutputExtent will override these values. By default, the Spacing, Origin, and WholeExtent of the Input are used.

virtual void vtkImageReslice::SetTransformInputSampling ( int ) [virtual]

Specify whether to transform the spacing, origin and extent of the Input (or the InformationInput) according to the direction cosines and origin of the ResliceAxes before applying them as the default output spacing, origin and extent. Default: On.

virtual void vtkImageReslice::TransformInputSamplingOn ( ) [virtual]

Specify whether to transform the spacing, origin and extent of the Input (or the InformationInput) according to the direction cosines and origin of the ResliceAxes before applying them as the default output spacing, origin and extent. Default: On.

virtual void vtkImageReslice::TransformInputSamplingOff ( ) [virtual]

Specify whether to transform the spacing, origin and extent of the Input (or the InformationInput) according to the direction cosines and origin of the ResliceAxes before applying them as the default output spacing, origin and extent. Default: On.

virtual int vtkImageReslice::GetTransformInputSampling ( ) [virtual]

Specify whether to transform the spacing, origin and extent of the Input (or the InformationInput) according to the direction cosines and origin of the ResliceAxes before applying them as the default output spacing, origin and extent. Default: On.

virtual void vtkImageReslice::SetAutoCropOutput ( int ) [virtual]

Turn this on if you want to guarantee that the extent of the output will be large enough to ensure that none of the data will be cropped.

virtual void vtkImageReslice::AutoCropOutputOn ( ) [virtual]

Turn this on if you want to guarantee that the extent of the output will be large enough to ensure that none of the data will be cropped.

virtual void vtkImageReslice::AutoCropOutputOff ( ) [virtual]

Turn this on if you want to guarantee that the extent of the output will be large enough to ensure that none of the data will be cropped.

virtual int vtkImageReslice::GetAutoCropOutput ( ) [virtual]

Turn this on if you want to guarantee that the extent of the output will be large enough to ensure that none of the data will be cropped.

virtual void vtkImageReslice::SetWrap ( int ) [virtual]

Turn on wrap-pad feature (default: off).

virtual int vtkImageReslice::GetWrap ( ) [virtual]

Turn on wrap-pad feature (default: off).

virtual void vtkImageReslice::WrapOn ( ) [virtual]

Turn on wrap-pad feature (default: off).

virtual void vtkImageReslice::WrapOff ( ) [virtual]

Turn on wrap-pad feature (default: off).

virtual void vtkImageReslice::SetMirror ( int ) [virtual]

Turn on mirror-pad feature (default: off). This will override the wrap-pad.

virtual int vtkImageReslice::GetMirror ( ) [virtual]

Turn on mirror-pad feature (default: off). This will override the wrap-pad.

virtual void vtkImageReslice::MirrorOn ( ) [virtual]

Turn on mirror-pad feature (default: off). This will override the wrap-pad.

virtual void vtkImageReslice::MirrorOff ( ) [virtual]

Turn on mirror-pad feature (default: off). This will override the wrap-pad.

virtual void vtkImageReslice::SetInterpolationMode ( int ) [virtual]

Set interpolation mode (default: nearest neighbor).

virtual int vtkImageReslice::GetInterpolationMode ( ) [virtual]

Set interpolation mode (default: nearest neighbor).

void vtkImageReslice::SetInterpolationModeToNearestNeighbor ( ) [inline]

Set interpolation mode (default: nearest neighbor).

Definition at line 202 of file vtkImageReslice.h.

void vtkImageReslice::SetInterpolationModeToLinear ( ) [inline]

Set interpolation mode (default: nearest neighbor).

Definition at line 204 of file vtkImageReslice.h.

void vtkImageReslice::SetInterpolationModeToCubic ( ) [inline]

Set interpolation mode (default: nearest neighbor).

Definition at line 206 of file vtkImageReslice.h.

const char * vtkImageReslice::GetInterpolationModeAsString ( ) [inline]

Set interpolation mode (default: nearest neighbor).

Definition at line 347 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetOptimization ( int ) [virtual]

Turn on and off optimizations (default on, they should only be turned off for testing purposes).

virtual int vtkImageReslice::GetOptimization ( ) [virtual]

Turn on and off optimizations (default on, they should only be turned off for testing purposes).

virtual void vtkImageReslice::OptimizationOn ( ) [virtual]

Turn on and off optimizations (default on, they should only be turned off for testing purposes).

virtual void vtkImageReslice::OptimizationOff ( ) [virtual]

Turn on and off optimizations (default on, they should only be turned off for testing purposes).

virtual void vtkImageReslice::SetBackgroundColor | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the background color (for multi-component images).

virtual void vtkImageReslice::SetBackgroundColor ( float [4] ) [virtual]

Set the background color (for multi-component images).

virtual float* vtkImageReslice::GetBackgroundColor ( ) [virtual]

Set the background color (for multi-component images).

virtual void vtkImageReslice::GetBackgroundColor | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the background color (for multi-component images).

virtual void vtkImageReslice::GetBackgroundColor ( float [4] ) [virtual]

Set the background color (for multi-component images).

void vtkImageReslice::SetBackgroundLevel ( float v ) [inline]

Set background grey level (for single-component images).

Definition at line 227 of file vtkImageReslice.h.

float vtkImageReslice::GetBackgroundLevel ( ) [inline]

Set background grey level (for single-component images).

Definition at line 228 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetOutputSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

virtual void vtkImageReslice::SetOutputSpacing ( float [3] ) [virtual]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

virtual float* vtkImageReslice::GetOutputSpacing ( ) [virtual]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputSpacing ( float [3] ) [virtual]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

void vtkImageReslice::SetOutputSpacingToDefault ( ) [inline]

Set the voxel spacing for the output data. The default output spacing is the input spacing permuted through the ResliceAxes.

Definition at line 236 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetOutputOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

virtual void vtkImageReslice::SetOutputOrigin ( float [3] ) [virtual]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

virtual float* vtkImageReslice::GetOutputOrigin ( ) [virtual]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputOrigin ( float [3] ) [virtual]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

void vtkImageReslice::SetOutputOriginToDefault ( ) [inline]

Set the origin for the output data. The default output origin is the input origin permuted through the ResliceAxes.

Definition at line 245 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetOutputExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

virtual void vtkImageReslice::SetOutputExtent ( int [6] ) [virtual]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

virtual int* vtkImageReslice::GetOutputExtent ( ) [virtual]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

virtual void vtkImageReslice::GetOutputExtent ( int [6] ) [virtual]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

void vtkImageReslice::SetOutputExtentToDefault ( ) [inline]

Set the extent for the output data. The default output extent is the input extent permuted through the ResliceAxes.

Definition at line 254 of file vtkImageReslice.h.

virtual void vtkImageReslice::SetOutputDimensionality ( int ) [virtual]

Force the dimensionality of the output to either 1, 2, 3 or 0 (default: 3). If the dimensionality is 2D, then the Z extent of the output is forced to (0,0) and the Z origin of the output is forced to 0.0 (i.e. the output extent is confined to the xy plane). If the dimensionality is 1D, the output extent is confined to the x axis. For 0D, the output extent consists of a single voxel at (0,0,0).

virtual int vtkImageReslice::GetOutputDimensionality ( ) [virtual]

Force the dimensionality of the output to either 1, 2, 3 or 0 (default: 3). If the dimensionality is 2D, then the Z extent of the output is forced to (0,0) and the Z origin of the output is forced to 0.0 (i.e. the output extent is confined to the xy plane). If the dimensionality is 1D, the output extent is confined to the x axis. For 0D, the output extent consists of a single voxel at (0,0,0).

unsigned long int vtkImageReslice::GetMTime ( ) [virtual]

When determining the modified time of the filter, this check the modified time of the transform and matrix.

Reimplemented from vtkObject.

void vtkImageReslice::SetInterpolate ( int t ) [inline]

Convenient methods for switching between nearest-neighbor and linear interpolation. InterpolateOn() is equivalent to SetInterpolationModeToLinear() and InterpolateOff() is equivalent to SetInterpolationModeToNearestNeighbor(). You should not use these methods if you use the SetInterpolationMode methods.

Definition at line 281 of file vtkImageReslice.h.

void vtkImageReslice::InterpolateOn ( ) [inline]

Convenient methods for switching between nearest-neighbor and linear interpolation. InterpolateOn() is equivalent to SetInterpolationModeToLinear() and InterpolateOff() is equivalent to SetInterpolationModeToNearestNeighbor(). You should not use these methods if you use the SetInterpolationMode methods.

Definition at line 286 of file vtkImageReslice.h.

void vtkImageReslice::InterpolateOff ( ) [inline]

Convenient methods for switching between nearest-neighbor and linear interpolation. InterpolateOn() is equivalent to SetInterpolationModeToLinear() and InterpolateOff() is equivalent to SetInterpolationModeToNearestNeighbor(). You should not use these methods if you use the SetInterpolationMode methods.

Definition at line 288 of file vtkImageReslice.h.

int vtkImageReslice::GetInterpolate ( ) [inline]

Convenient methods for switching between nearest-neighbor and linear interpolation. InterpolateOn() is equivalent to SetInterpolationModeToLinear() and InterpolateOff() is equivalent to SetInterpolationModeToNearestNeighbor(). You should not use these methods if you use the SetInterpolationMode methods.

Definition at line 290 of file vtkImageReslice.h.

void vtkImageReslice::SetStencil ( vtkImageStencilData * stencil )

Use a stencil to limit the calculations to a specific region of the output. Portions of the output that are 'outside' the stencil will be cleared to the background color.

vtkImageStencilData* vtkImageReslice::GetStencil ( )

Use a stencil to limit the calculations to a specific region of the output. Portions of the output that are 'outside' the stencil will be cleared to the background color.

void vtkImageReslice::GetAutoCroppedOutputBounds | ( | vtkImageData * | input,
 |  | float | bounds[6]
 | ) | [protected]

void vtkImageReslice::ExecuteInformation | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageReslice::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 328 of file vtkImageReslice.h.

void vtkImageReslice::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkImageToImageFilter.

void vtkImageReslice::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageReslice::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

vtkMatrix4x4* vtkImageReslice::GetIndexMatrix ( ) [protected]

vtkAbstractTransform* vtkImageReslice::GetOptimizedTransform ( ) [inline, protected]

Definition at line 336 of file vtkImageReslice.h.

void vtkImageReslice::OptimizedComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected]

void vtkImageReslice::OptimizedThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected]

Member Data Documentation

vtkMatrix4x4* vtkImageReslice::ResliceAxes [protected]

Definition at line 306 of file vtkImageReslice.h.

double vtkImageReslice::ResliceAxesDirectionCosines[9] [protected]

Definition at line 307 of file vtkImageReslice.h.

double vtkImageReslice::ResliceAxesOrigin[3] [protected]

Definition at line 308 of file vtkImageReslice.h.

vtkAbstractTransform* vtkImageReslice::ResliceTransform [protected]

Definition at line 309 of file vtkImageReslice.h.

vtkImageData* vtkImageReslice::InformationInput [protected]

Definition at line 310 of file vtkImageReslice.h.

int vtkImageReslice::Wrap [protected]

Definition at line 311 of file vtkImageReslice.h.

int vtkImageReslice::Mirror [protected]

Definition at line 312 of file vtkImageReslice.h.

int vtkImageReslice::InterpolationMode [protected]

Definition at line 313 of file vtkImageReslice.h.

int vtkImageReslice::Optimization [protected]

Definition at line 314 of file vtkImageReslice.h.

float vtkImageReslice::BackgroundColor[4] [protected]

Definition at line 315 of file vtkImageReslice.h.

float vtkImageReslice::OutputOrigin[3] [protected]

Definition at line 316 of file vtkImageReslice.h.

float vtkImageReslice::OutputSpacing[3] [protected]

Definition at line 317 of file vtkImageReslice.h.

int vtkImageReslice::OutputExtent[6] [protected]

Definition at line 318 of file vtkImageReslice.h.

int vtkImageReslice::OutputDimensionality [protected]

Definition at line 319 of file vtkImageReslice.h.

int vtkImageReslice::TransformInputSampling [protected]

Definition at line 320 of file vtkImageReslice.h.

int vtkImageReslice::AutoCropOutput [protected]

Definition at line 321 of file vtkImageReslice.h.

vtkMatrix4x4* vtkImageReslice::IndexMatrix [protected]

Definition at line 323 of file vtkImageReslice.h.

vtkAbstractTransform* vtkImageReslice::OptimizedTransform [protected]

Definition at line 324 of file vtkImageReslice.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageReslice.h
Generated on Mon Mar 25 01:19:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRFFT Class Reference

Reverse Fast Fourier Transform. More...

#include <vtkImageRFFT.h>

Inheritance diagram for vtkImageRFFT:

[legend]
Collaboration diagram for vtkImageRFFT:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageRFFT, vtkImageFourierFilter)
virtual void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)
int | SplitExtent (int splitExt[6], int startExt[6], int num, int total)

Static Public Methods

vtkImageRFFT * | New ()

Protected Methods

vtkImageRFFT ()
~vtkImageRFFT ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId)

Detailed Description

Reverse Fast Fourier Transform.

Date:
2002/01/22 15:33:16
Revision:
1.32

vtkImageRFFT implements the reverse fast Fourier transform. The input can have real or complex data in any components and data types, but the output is always complex floats with real values in component0, and imaginary values in component1. The filter is fastest for images that have power of two sizes. The filter uses a butterfly fitlers for each prime factor of the dimension. This makes images with prime number dimensions (i.e. 17x17) much slower to compute. Multi dimensional (i.e volumes) FFT's are decomposed so that each axis executes in series. In most cases the RFFT will produce an image whose imaginary values are all zero's. In this case vtkImageExtractComponents can be used to remove this imaginary components leaving only the real image.

See also:
vtkImageExtractComponenents
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (84%)
  • Martin, Ken (8%)
Tests:
vtkImageRFFT (Tests)

Definition at line 54 of file vtkImageRFFT.h.

Constructor & Destructor Documentation

vtkImageRFFT::vtkImageRFFT ( ) [inline, protected]

Definition at line 76 of file vtkImageRFFT.h.

vtkImageRFFT::~vtkImageRFFT ( ) [inline, protected]

Definition at line 77 of file vtkImageRFFT.h.

Member Function Documentation

vtkImageRFFT* vtkImageRFFT::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageRFFT::vtkTypeRevisionMacro | ( | vtkImageRFFT | ,
 |  | vtkImageFourierFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageFourierFilter.

int vtkImageRFFT::SplitExtent | ( | int | splitExt[6],
 |  | int | startExt[6],
 |  | int | num,
 |  | int | total
 | ) | [virtual]

For streaming and threads. Splits output update extent into num pieces. This method needs to be called num times. Results must not overlap for consistent starting extent. Subclass can override this method. This method returns the number of pieces resulting from a successful split. This can be from 1 to "total". If 1 is returned, the extent cannot be split.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageRFFT::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [inline, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 72 of file vtkImageRFFT.h.

void vtkImageRFFT::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageRFFT::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageRFFT::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 81 of file vtkImageRFFT.h.

void vtkImageRFFT::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | threadId
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageRFFT.h
Generated on Mon Mar 25 01:19:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageRGBToHSV Class Reference

Converts RGB components to HSV. More...

#include <vtkImageRGBToHSV.h>

Inheritance diagram for vtkImageRGBToHSV:

[legend]
Collaboration diagram for vtkImageRGBToHSV:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageRGBToHSV, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMaximum (float)
virtual float | GetMaximum ()

Static Public Methods

vtkImageRGBToHSV * | New ()

Protected Methods

vtkImageRGBToHSV ()
~vtkImageRGBToHSV ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

float | Maximum

Detailed Description

Converts RGB components to HSV.

Date:
2002/01/22 15:33:17
Revision:
1.22

For each pixel with red, blue, and green components this filter output the color coded as hue, saturation and value. Output type must be the same as input type.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (42%)
  • Martin, Ken (31%)
  • Lorensen, Bill (13%)
Tests:
vtkImageRGBToHSV (Tests)

Definition at line 44 of file vtkImageRGBToHSV.h.

Constructor & Destructor Documentation

vtkImageRGBToHSV::vtkImageRGBToHSV ( ) [protected]

vtkImageRGBToHSV::~vtkImageRGBToHSV ( ) [inline, protected]

Definition at line 60 of file vtkImageRGBToHSV.h.

Member Function Documentation

vtkImageRGBToHSV* vtkImageRGBToHSV::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageRGBToHSV::vtkTypeRevisionMacro | ( | vtkImageRGBToHSV | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageRGBToHSV::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageRGBToHSV::SetMaximum ( float ) [virtual]

virtual float vtkImageRGBToHSV::GetMaximum ( ) [virtual]

void vtkImageRGBToHSV::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageRGBToHSV::Maximum [protected]

Definition at line 62 of file vtkImageRGBToHSV.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageRGBToHSV.h
Generated on Mon Mar 25 01:19:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSeedConnectivity Class Reference

SeedConnectivity with user defined seeds. More...

#include <vtkImageSeedConnectivity.h>

Inheritance diagram for vtkImageSeedConnectivity:

[legend]
Collaboration diagram for vtkImageSeedConnectivity:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSeedConnectivity, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RemoveAllSeeds ()
void | AddSeed (int num, int *index)
void | AddSeed (int i0, int i1, int i2)
void | AddSeed (int i0, int i1)
virtual void | SetInputConnectValue (int)
virtual int | GetInputConnectValue ()
virtual void | SetOutputConnectedValue (int)
virtual int | GetOutputConnectedValue ()
virtual void | SetOutputUnconnectedValue (int)
virtual int | GetOutputUnconnectedValue ()
virtual vtkImageConnector * | GetConnector ()
virtual void | SetDimensionality (int)
virtual int | GetDimensionality ()

Static Public Methods

vtkImageSeedConnectivity * | New ()

Protected Methods

vtkImageSeedConnectivity ()
~vtkImageSeedConnectivity ()
void | ComputeInputUpdateExtents (vtkDataObject *out)
void | ExecuteData (vtkDataObject *out)

Protected Attributes

unsigned char | InputConnectValue
unsigned char | OutputConnectedValue
unsigned char | OutputUnconnectedValue
vtkImageConnectorSeed * Seeds
vtkImageConnector * Connector
int | Dimensionality

Detailed Description

SeedConnectivity with user defined seeds.

Date:
2002/01/22 15:33:23
Revision:
1.29

vtkImageSeedConnectivity marks pixels connected to user supplied seeds. The input must be unsigned char, and the output is also unsigned char. If a seed supplied by the user does not have pixel value "InputTrueValue", then the image is scanned +x, +y, +z until a pixel is encountered with value "InputTrueValue". This new pixel is used as the seed . Any pixel with out value "InputTrueValue" is consider off. The output pixels values are 0 for any off pixel in input, "OutputTrueValue" for any pixels connected to seeds, and "OutputUnconnectedValue" for any on pixels not connected to seeds. The same seeds are used for all images in the image set.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (73%)
  • Martin, Ken (18%)
Tests:
vtkImageSeedConnectivity (Tests)

Definition at line 51 of file vtkImageSeedConnectivity.h.

Constructor & Destructor Documentation

vtkImageSeedConnectivity::vtkImageSeedConnectivity ( ) [protected]

vtkImageSeedConnectivity::~vtkImageSeedConnectivity ( ) [protected]

Member Function Documentation

vtkImageSeedConnectivity* vtkImageSeedConnectivity::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageSeedConnectivity::vtkTypeRevisionMacro | ( | vtkImageSeedConnectivity | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageSeedConnectivity::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageSeedConnectivity::RemoveAllSeeds ( )

Methods for manipulating the seed pixels.

void vtkImageSeedConnectivity::AddSeed | ( | int | num,
 |  | int * | index
 | ) |

Methods for manipulating the seed pixels.

void vtkImageSeedConnectivity::AddSeed | ( | int | i0,
 |  | int | i1,
 |  | int | i2
 | ) |

Methods for manipulating the seed pixels.

void vtkImageSeedConnectivity::AddSeed | ( | int | i0,
 |  | int | i1
 | ) |

Methods for manipulating the seed pixels.

virtual void vtkImageSeedConnectivity::SetInputConnectValue ( int ) [virtual]

Set/Get what value is considered as connecting pixels.

virtual int vtkImageSeedConnectivity::GetInputConnectValue ( ) [virtual]

Set/Get what value is considered as connecting pixels.

virtual void vtkImageSeedConnectivity::SetOutputConnectedValue ( int ) [virtual]

Set/Get the value to set connected pixels to.

virtual int vtkImageSeedConnectivity::GetOutputConnectedValue ( ) [virtual]

Set/Get the value to set connected pixels to.

virtual void vtkImageSeedConnectivity::SetOutputUnconnectedValue ( int ) [virtual]

Set/Get the value to set unconnected pixels to.

virtual int vtkImageSeedConnectivity::GetOutputUnconnectedValue ( ) [virtual]

Set/Get the value to set unconnected pixels to.

virtual vtkImageConnector* vtkImageSeedConnectivity::GetConnector ( ) [virtual]

Get the vtkImageCOnnector used by this filter.

virtual void vtkImageSeedConnectivity::SetDimensionality ( int ) [virtual]

Set the number of axes to use in connectivity.

virtual int vtkImageSeedConnectivity::GetDimensionality ( ) [virtual]

Set the number of axes to use in connectivity.

void vtkImageSeedConnectivity::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkImageToImageFilter.

void vtkImageSeedConnectivity::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

unsigned char vtkImageSeedConnectivity::InputConnectValue [protected]

Definition at line 99 of file vtkImageSeedConnectivity.h.

unsigned char vtkImageSeedConnectivity::OutputConnectedValue [protected]

Definition at line 100 of file vtkImageSeedConnectivity.h.

unsigned char vtkImageSeedConnectivity::OutputUnconnectedValue [protected]

Definition at line 101 of file vtkImageSeedConnectivity.h.

vtkImageConnectorSeed* vtkImageSeedConnectivity::Seeds [protected]

Definition at line 102 of file vtkImageSeedConnectivity.h.

vtkImageConnector* vtkImageSeedConnectivity::Connector [protected]

Definition at line 103 of file vtkImageSeedConnectivity.h.

int vtkImageSeedConnectivity::Dimensionality [protected]

Definition at line 104 of file vtkImageSeedConnectivity.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSeedConnectivity.h
Generated on Mon Mar 25 01:19:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSeparableConvolution Class Reference

3 1D convolutions on an image. More...

#include <vtkImageSeparableConvolution.h>

Inheritance diagram for vtkImageSeparableConvolution:

[legend]
Collaboration diagram for vtkImageSeparableConvolution:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSeparableConvolution, vtkImageDecomposeFilter)
virtual void | SetXKernel (vtkFloatArray *)
virtual vtkFloatArray * | GetXKernel ()
virtual void | SetYKernel (vtkFloatArray *)
virtual vtkFloatArray * | GetYKernel ()
virtual void | SetZKernel (vtkFloatArray *)
virtual vtkFloatArray * | GetZKernel ()
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()

Static Public Methods

vtkImageSeparableConvolution * | New ()

Protected Methods

vtkImageSeparableConvolution ()
~vtkImageSeparableConvolution ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | IterativeExecuteData (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation (vtkImageData *input, vtkImageData *output)
void | ExecuteInformation ()

Protected Attributes

vtkFloatArray * XKernel
vtkFloatArray * YKernel
vtkFloatArray * ZKernel

Detailed Description

3 1D convolutions on an image.

Date:
2002/01/22 15:33:24
Revision:
1.5

vtkImageSeparableConvolution performs a convolution along the X, Y, and Z axes of an image, based on the three different 1D convolution kernels. The kernels must be of odd size, and are considered to be centered at (int)((kernelsize - 1) / 2.0 ). If a kernel is NULL, that dimension is skipped. This filter is designed to efficiently convolve separable filters that can be decomposed into 1 or more 1D convolutions. It also handles arbitrarly large kernel sizes, and uses edge replication to handle boundaries.

Created by:
  • Blezek, Dan
Contributed by (if > 5%):
  • Blezek, Dan (98%)
Tests:
vtkImageSeparableConvolution (Tests)

Definition at line 48 of file vtkImageSeparableConvolution.h.

Constructor & Destructor Documentation

vtkImageSeparableConvolution::vtkImageSeparableConvolution ( ) [protected]

vtkImageSeparableConvolution::~vtkImageSeparableConvolution ( ) [protected]

Member Function Documentation

vtkImageSeparableConvolution* vtkImageSeparableConvolution::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageSeparableConvolution::vtkTypeRevisionMacro | ( | vtkImageSeparableConvolution | ,
 |  | vtkImageDecomposeFilter |
 | ) |

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

virtual void vtkImageSeparableConvolution::SetXKernel ( vtkFloatArray * ) [virtual]

virtual vtkFloatArray* vtkImageSeparableConvolution::GetXKernel ( ) [virtual]

virtual void vtkImageSeparableConvolution::SetYKernel ( vtkFloatArray * ) [virtual]

virtual vtkFloatArray* vtkImageSeparableConvolution::GetYKernel ( ) [virtual]

virtual void vtkImageSeparableConvolution::SetZKernel ( vtkFloatArray * ) [virtual]

virtual vtkFloatArray* vtkImageSeparableConvolution::GetZKernel ( ) [virtual]

void vtkImageSeparableConvolution::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Construct an instance of vtkImageDecomposeFilter filter with default dimensionality 3.

Reimplemented from vtkImageDecomposeFilter.

unsigned long int vtkImageSeparableConvolution::GetMTime ( ) [virtual]

Overload standard modified time function. If kernel arrays are modified, then this object is modified as well.

Reimplemented from vtkObject.

void vtkImageSeparableConvolution::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageSeparableConvolution::IterativeExecuteData | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageSeparableConvolution::ExecuteInformation | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageSeparableConvolution::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 88 of file vtkImageSeparableConvolution.h.

Member Data Documentation

vtkFloatArray* vtkImageSeparableConvolution::XKernel [protected]

Definition at line 80 of file vtkImageSeparableConvolution.h.

vtkFloatArray* vtkImageSeparableConvolution::YKernel [protected]

Definition at line 81 of file vtkImageSeparableConvolution.h.

vtkFloatArray* vtkImageSeparableConvolution::ZKernel [protected]

Definition at line 82 of file vtkImageSeparableConvolution.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSeparableConvolution.h
Generated on Mon Mar 25 01:19:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageShiftScale Class Reference

shift and scale an input image. More...

#include <vtkImageShiftScale.h>

Inheritance diagram for vtkImageShiftScale:

[legend]
Collaboration diagram for vtkImageShiftScale:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageShiftScale, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetShift (float)
virtual float | GetShift ()
virtual void | SetScale (float)
virtual float | GetScale ()
virtual void | SetOutputScalarType (int)
virtual int | GetOutputScalarType ()
void | SetOutputScalarTypeToDouble ()
void | SetOutputScalarTypeToFloat ()
void | SetOutputScalarTypeToLong ()
void | SetOutputScalarTypeToUnsignedLong ()
void | SetOutputScalarTypeToInt ()
void | SetOutputScalarTypeToUnsignedInt ()
void | SetOutputScalarTypeToShort ()
void | SetOutputScalarTypeToUnsignedShort ()
void | SetOutputScalarTypeToChar ()
void | SetOutputScalarTypeToUnsignedChar ()
virtual void | SetClampOverflow (int)
virtual int | GetClampOverflow ()
virtual void | ClampOverflowOn ()
virtual void | ClampOverflowOff ()

Static Public Methods

vtkImageShiftScale * | New ()

Protected Methods

vtkImageShiftScale ()
~vtkImageShiftScale ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

float | Shift
float | Scale
int | OutputScalarType
int | ClampOverflow

Detailed Description

shift and scale an input image.

Date:
2002/01/22 15:33:25
Revision:
1.41

With vtkImageShiftScale Pixels are shifted and then scaled. As a convenience, this class allows you to set the output scalar type similar to vtkImageCast. This is because shift scale operations frequently convert data types.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (62%)
  • Martin, Ken (18%)
  • Lorensen, Bill (8%)
  • Schroeder, Will (5%)
Examples:
vtkImageShiftScale (Examples)
Tests:
vtkImageShiftScale (Tests)

Definition at line 49 of file vtkImageShiftScale.h.

Constructor & Destructor Documentation

vtkImageShiftScale::vtkImageShiftScale ( ) [protected]

vtkImageShiftScale::~vtkImageShiftScale ( ) [inline, protected]

Definition at line 106 of file vtkImageShiftScale.h.

Member Function Documentation

vtkImageShiftScale* vtkImageShiftScale::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageShiftScale::vtkTypeRevisionMacro | ( | vtkImageShiftScale | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageShiftScale::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageShiftScale::SetShift ( float ) [virtual]

Set/Get the shift value.

virtual float vtkImageShiftScale::GetShift ( ) [virtual]

Set/Get the shift value.

virtual void vtkImageShiftScale::SetScale ( float ) [virtual]

Set/Get the scale value.

virtual float vtkImageShiftScale::GetScale ( ) [virtual]

Set/Get the scale value.

virtual void vtkImageShiftScale::SetOutputScalarType ( int ) [virtual]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

virtual int vtkImageShiftScale::GetOutputScalarType ( ) [virtual]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

void vtkImageShiftScale::SetOutputScalarTypeToDouble ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 73 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToFloat ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 75 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToLong ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 77 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToUnsignedLong ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 79 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToInt ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 81 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToUnsignedInt ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 83 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToShort ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 85 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToUnsignedShort ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 87 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToChar ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 89 of file vtkImageShiftScale.h.

void vtkImageShiftScale::SetOutputScalarTypeToUnsignedChar ( ) [inline]

Set the desired output scalar type. The result of the shift and scale operations is cast to the type specified.

Definition at line 91 of file vtkImageShiftScale.h.

virtual void vtkImageShiftScale::SetClampOverflow ( int ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default, ClampOverflow is off.

virtual int vtkImageShiftScale::GetClampOverflow ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default, ClampOverflow is off.

virtual void vtkImageShiftScale::ClampOverflowOn ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default, ClampOverflow is off.

virtual void vtkImageShiftScale::ClampOverflowOff ( ) [virtual]

When the ClampOverflow flag is on, the data is thresholded so that the output value does not exceed the max or min of the data type. By default, ClampOverflow is off.

void vtkImageShiftScale::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageShiftScale::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 114 of file vtkImageShiftScale.h.

void vtkImageShiftScale::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageShiftScale::Shift [protected]

Definition at line 108 of file vtkImageShiftScale.h.

float vtkImageShiftScale::Scale [protected]

Definition at line 109 of file vtkImageShiftScale.h.

int vtkImageShiftScale::OutputScalarType [protected]

Definition at line 110 of file vtkImageShiftScale.h.

int vtkImageShiftScale::ClampOverflow [protected]

Definition at line 111 of file vtkImageShiftScale.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageShiftScale.h
Generated on Mon Mar 25 01:19:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageShrink3D Class Reference

Subsamples an image. More...

#include <vtkImageShrink3D.h>

Inheritance diagram for vtkImageShrink3D:

[legend]
Collaboration diagram for vtkImageShrink3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageShrink3D, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetMean (int)
virtual int | GetMean ()
virtual void | MeanOn ()
virtual void | MeanOff ()
void | SetMinimum (int)
virtual int | GetMinimum ()
virtual void | MinimumOn ()
virtual void | MinimumOff ()
void | SetMaximum (int)
virtual int | GetMaximum ()
virtual void | MaximumOn ()
virtual void | MaximumOff ()
void | SetMedian (int)
virtual int | GetMedian ()
virtual void | MedianOn ()
virtual void | MedianOff ()
virtual void | SetShrinkFactors (int, int, int)
virtual void | SetShrinkFactors (int[3])
virtual int * | GetShrinkFactors ()
virtual void | GetShrinkFactors (int &, int &, int &)
virtual void | GetShrinkFactors (int[3])
virtual void | SetShift (int, int, int)
virtual void | SetShift (int[3])
virtual int * | GetShift ()
virtual void | GetShift (int &, int &, int &)
virtual void | GetShift (int[3])
void | SetAveraging (int)
int | GetAveraging ()
virtual void | AveragingOn ()
virtual void | AveragingOff ()

Static Public Methods

vtkImageShrink3D * | New ()

Protected Methods

vtkImageShrink3D ()
~vtkImageShrink3D ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int ext[6], int id)

Protected Attributes

int | ShrinkFactors [3]
int | Shift [3]
int | Mean
int | Minimum
int | Maximum
int | Median

Detailed Description

Subsamples an image.

Date:
2002/01/22 15:33:26
Revision:
1.38

vtkImageShrink3D shrinks an image by sub sampling on a uniform grid (integer multiples).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (47%)
  • Lorensen, Bill (26%)
  • Martin, Ken (19%)
Examples:
vtkImageShrink3D (Examples)
Tests:
vtkImageShrink3D (Tests)

Definition at line 46 of file vtkImageShrink3D.h.

Constructor & Destructor Documentation

vtkImageShrink3D::vtkImageShrink3D ( ) [protected]

vtkImageShrink3D::~vtkImageShrink3D ( ) [inline, protected]

Definition at line 95 of file vtkImageShrink3D.h.

Member Function Documentation

vtkImageShrink3D* vtkImageShrink3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageShrink3D::vtkTypeRevisionMacro | ( | vtkImageShrink3D | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageShrink3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageShrink3D::SetShrinkFactors | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the shrink factors

virtual void vtkImageShrink3D::SetShrinkFactors ( int [3] ) [virtual]

Set/Get the shrink factors

virtual int* vtkImageShrink3D::GetShrinkFactors ( ) [virtual]

Set/Get the shrink factors

virtual void vtkImageShrink3D::GetShrinkFactors | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the shrink factors

virtual void vtkImageShrink3D::GetShrinkFactors ( int [3] ) [virtual]

Set/Get the shrink factors

virtual void vtkImageShrink3D::SetShift | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the pixel to use as origin.

virtual void vtkImageShrink3D::SetShift ( int [3] ) [virtual]

Set/Get the pixel to use as origin.

virtual int* vtkImageShrink3D::GetShift ( ) [virtual]

Set/Get the pixel to use as origin.

virtual void vtkImageShrink3D::GetShift | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the pixel to use as origin.

virtual void vtkImageShrink3D::GetShift ( int [3] ) [virtual]

Set/Get the pixel to use as origin.

void vtkImageShrink3D::SetAveraging ( int )

Choose Mean, Minimum, Maximum, Median or sub sampling. The neighborhood operations are not centered on the sampled pixel. This may cause a half pixel shift in your output image. You can changed "Shift" to get around this. vtkImageGaussianSmooth or vtkImageMean with strides.

int vtkImageShrink3D::GetAveraging ( ) [inline]

Choose Mean, Minimum, Maximum, Median or sub sampling. The neighborhood operations are not centered on the sampled pixel. This may cause a half pixel shift in your output image. You can changed "Shift" to get around this. vtkImageGaussianSmooth or vtkImageMean with strides.

Definition at line 72 of file vtkImageShrink3D.h.

virtual void vtkImageShrink3D::AveragingOn ( ) [virtual]

Choose Mean, Minimum, Maximum, Median or sub sampling. The neighborhood operations are not centered on the sampled pixel. This may cause a half pixel shift in your output image. You can changed "Shift" to get around this. vtkImageGaussianSmooth or vtkImageMean with strides.

virtual void vtkImageShrink3D::AveragingOff ( ) [virtual]

Choose Mean, Minimum, Maximum, Median or sub sampling. The neighborhood operations are not centered on the sampled pixel. This may cause a half pixel shift in your output image. You can changed "Shift" to get around this. vtkImageGaussianSmooth or vtkImageMean with strides.

void vtkImageShrink3D::SetMean ( int )

virtual int vtkImageShrink3D::GetMean ( ) [virtual]

virtual void vtkImageShrink3D::MeanOn ( ) [virtual]

virtual void vtkImageShrink3D::MeanOff ( ) [virtual]

void vtkImageShrink3D::SetMinimum ( int )

virtual int vtkImageShrink3D::GetMinimum ( ) [virtual]

virtual void vtkImageShrink3D::MinimumOn ( ) [virtual]

virtual void vtkImageShrink3D::MinimumOff ( ) [virtual]

void vtkImageShrink3D::SetMaximum ( int )

virtual int vtkImageShrink3D::GetMaximum ( ) [virtual]

virtual void vtkImageShrink3D::MaximumOn ( ) [virtual]

virtual void vtkImageShrink3D::MaximumOff ( ) [virtual]

void vtkImageShrink3D::SetMedian ( int )

virtual int vtkImageShrink3D::GetMedian ( ) [virtual]

virtual void vtkImageShrink3D::MedianOn ( ) [virtual]

virtual void vtkImageShrink3D::MedianOff ( ) [virtual]

void vtkImageShrink3D::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageShrink3D::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageShrink3D::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 106 of file vtkImageShrink3D.h.

void vtkImageShrink3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageShrink3D::ShrinkFactors[3] [protected]

Definition at line 97 of file vtkImageShrink3D.h.

int vtkImageShrink3D::Shift[3] [protected]

Definition at line 98 of file vtkImageShrink3D.h.

int vtkImageShrink3D::Mean [protected]

Definition at line 99 of file vtkImageShrink3D.h.

int vtkImageShrink3D::Minimum [protected]

Definition at line 100 of file vtkImageShrink3D.h.

int vtkImageShrink3D::Maximum [protected]

Definition at line 101 of file vtkImageShrink3D.h.

int vtkImageShrink3D::Median [protected]

Definition at line 102 of file vtkImageShrink3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageShrink3D.h
Generated on Mon Mar 25 01:19:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSinusoidSource Class Reference

Create an image with sinusoidal pixel values. More...

#include <vtkImageSinusoidSource.h>

Inheritance diagram for vtkImageSinusoidSource:

[legend]
Collaboration diagram for vtkImageSinusoidSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSinusoidSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetWholeExtent (int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
void | SetDirection (float, float, float)
void | SetDirection (float dir[3])
virtual float * | GetDirection ()
virtual void | GetDirection (float &, float &, float &)
virtual void | GetDirection (float[3])
virtual void | SetPeriod (float)
virtual float | GetPeriod ()
virtual void | SetPhase (float)
virtual float | GetPhase ()
virtual void | SetAmplitude (float)
virtual float | GetAmplitude ()

Static Public Methods

vtkImageSinusoidSource * | New ()

Protected Methods

vtkImageSinusoidSource ()
~vtkImageSinusoidSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)

Protected Attributes

int | WholeExtent [6]
float | Direction [3]
float | Period
float | Phase
float | Amplitude

Detailed Description

Create an image with sinusoidal pixel values.

Date:
2002/01/22 15:33:28
Revision:
1.28

vtkImageSinusoidSource just produces images with pixel values determined by a sinusoid.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (60%)
  • Martin, Ken (31%)
Tests:
vtkImageSinusoidSource (Tests)

Definition at line 41 of file vtkImageSinusoidSource.h.

Constructor & Destructor Documentation

vtkImageSinusoidSource::vtkImageSinusoidSource ( ) [protected]

vtkImageSinusoidSource::~vtkImageSinusoidSource ( ) [inline, protected]

Definition at line 82 of file vtkImageSinusoidSource.h.

Member Function Documentation

vtkImageSinusoidSource* vtkImageSinusoidSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkImageSinusoidSource::vtkTypeRevisionMacro | ( | vtkImageSinusoidSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkImageSinusoidSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageSinusoidSource::SetWholeExtent | ( | int | xMinx,
 |  | int | xMax,
 |  | int | yMin,
 |  | int | yMax,
 |  | int | zMin,
 |  | int | zMax
 | ) |

Set/Get the extent of the whole output image.

void vtkImageSinusoidSource::SetDirection | ( | float | ,
 |  | float | ,
 |  | float |
 | ) |

Set/Get the direction vector which determines the sinusoidal orientation. The magnitude is ignored.

void vtkImageSinusoidSource::SetDirection ( float dir[3] )

Set/Get the direction vector which determines the sinusoidal orientation. The magnitude is ignored.

virtual float* vtkImageSinusoidSource::GetDirection ( ) [virtual]

Set/Get the direction vector which determines the sinusoidal orientation. The magnitude is ignored.

virtual void vtkImageSinusoidSource::GetDirection | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the direction vector which determines the sinusoidal orientation. The magnitude is ignored.

virtual void vtkImageSinusoidSource::GetDirection ( float [3] ) [virtual]

Set/Get the direction vector which determines the sinusoidal orientation. The magnitude is ignored.

virtual void vtkImageSinusoidSource::SetPeriod ( float ) [virtual]

Set/Get the period of the sinusoid in pixels.

virtual float vtkImageSinusoidSource::GetPeriod ( ) [virtual]

Set/Get the period of the sinusoid in pixels.

virtual void vtkImageSinusoidSource::SetPhase ( float ) [virtual]

Set/Get the phase: 0->2Pi. 0 => Cosine, pi/2 => Sine.

virtual float vtkImageSinusoidSource::GetPhase ( ) [virtual]

Set/Get the phase: 0->2Pi. 0 => Cosine, pi/2 => Sine.

virtual void vtkImageSinusoidSource::SetAmplitude ( float ) [virtual]

Set/Get the magnitude of the sinusoid.

virtual float vtkImageSinusoidSource::GetAmplitude ( ) [virtual]

Set/Get the magnitude of the sinusoid.

virtual void vtkImageSinusoidSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkImageSinusoidSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

Member Data Documentation

int vtkImageSinusoidSource::WholeExtent[6] [protected]

Definition at line 84 of file vtkImageSinusoidSource.h.

float vtkImageSinusoidSource::Direction[3] [protected]

Definition at line 85 of file vtkImageSinusoidSource.h.

float vtkImageSinusoidSource::Period [protected]

Definition at line 86 of file vtkImageSinusoidSource.h.

float vtkImageSinusoidSource::Phase [protected]

Definition at line 87 of file vtkImageSinusoidSource.h.

float vtkImageSinusoidSource::Amplitude [protected]

Definition at line 88 of file vtkImageSinusoidSource.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSinusoidSource.h
Generated on Mon Mar 25 01:19:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSkeleton2D Class Reference

Skeleton of 2D images. More...

#include <vtkImageSkeleton2D.h>

Inheritance diagram for vtkImageSkeleton2D:

[legend]
Collaboration diagram for vtkImageSkeleton2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSkeleton2D, vtkImageIterateFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfIterations (int num)
virtual void | IterativeExecuteData (vtkImageData *in, vtkImageData *out)
virtual void | SetPrune (int)
virtual int | GetPrune ()
virtual void | PruneOn ()
virtual void | PruneOff ()

Static Public Methods

vtkImageSkeleton2D * | New ()

Protected Methods

vtkImageSkeleton2D ()
~vtkImageSkeleton2D ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)

Protected Attributes

int | Prune

Detailed Description

Skeleton of 2D images.

Date:
2002/01/22 15:33:29
Revision:
1.27

vtkImageSkeleton2D should leave only single pixel width lines of non-zero-valued pixels (values of 1 are not allowed). It works by erosion on a 3x3 neighborhood with special rules. The number of iterations determines how far the filter can erode. There are three pruning levels: prune == 0 will leave traces on all angles... prune == 1 will not leave traces on 135 degree angles, but will on 90. prune == 2 does not leave traces on any angles leaving only closed loops. Prune defaults to zero. The output scalar type is the same as the input.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (86%)
  • Martin, Ken (7%)
Tests:
vtkImageSkeleton2D (Tests)

Definition at line 48 of file vtkImageSkeleton2D.h.

Constructor & Destructor Documentation

vtkImageSkeleton2D::vtkImageSkeleton2D ( ) [protected]

vtkImageSkeleton2D::~vtkImageSkeleton2D ( ) [inline, protected]

Definition at line 70 of file vtkImageSkeleton2D.h.

Member Function Documentation

vtkImageSkeleton2D* vtkImageSkeleton2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageSkeleton2D::vtkTypeRevisionMacro | ( | vtkImageSkeleton2D | ,
 |  | vtkImageIterateFilter |
 | ) |

Reimplemented from vtkImageIterateFilter.

void vtkImageSkeleton2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageIterateFilter.

virtual void vtkImageSkeleton2D::SetPrune ( int ) [virtual]

When prune is on, only closed loops are left unchanged.

virtual int vtkImageSkeleton2D::GetPrune ( ) [virtual]

When prune is on, only closed loops are left unchanged.

virtual void vtkImageSkeleton2D::PruneOn ( ) [virtual]

When prune is on, only closed loops are left unchanged.

virtual void vtkImageSkeleton2D::PruneOff ( ) [virtual]

When prune is on, only closed loops are left unchanged.

void vtkImageSkeleton2D::SetNumberOfIterations ( int num ) [virtual]

Sets the number of cycles in the erosion.

Reimplemented from vtkImageIterateFilter.

virtual void vtkImageSkeleton2D::IterativeExecuteData | ( | vtkImageData * | in,
 |  | vtkImageData * | out
 | ) | [inline, virtual]

Reimplemented from vtkImageIterateFilter.

Definition at line 65 of file vtkImageSkeleton2D.h.

void vtkImageSkeleton2D::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageIterateFilter.

void vtkImageSkeleton2D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageSkeleton2D::Prune [protected]

Definition at line 72 of file vtkImageSkeleton2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSkeleton2D.h
Generated on Mon Mar 25 01:19:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSobel2D Class Reference

Computes a vector field using sobel functions. More...

#include <vtkImageSobel2D.h>

Inheritance diagram for vtkImageSobel2D:

[legend]
Collaboration diagram for vtkImageSobel2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSobel2D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkImageSobel2D * | New ()

Protected Methods

vtkImageSobel2D ()
~vtkImageSobel2D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()

Detailed Description

Computes a vector field using sobel functions.

Date:
2002/01/22 15:33:30
Revision:
1.23

vtkImageSobel2D computes a vector field from a scalar field by using Sobel functions. The number of vector components is 2 because the input is an image. Output is always floats.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (84%)
  • Martin, Ken (9%)
Tests:
vtkImageSobel2D (Tests)

Definition at line 43 of file vtkImageSobel2D.h.

Constructor & Destructor Documentation

vtkImageSobel2D::vtkImageSobel2D ( ) [protected]

vtkImageSobel2D::~vtkImageSobel2D ( ) [inline, protected]

Definition at line 52 of file vtkImageSobel2D.h.

Member Function Documentation

vtkImageSobel2D* vtkImageSobel2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageSobel2D::vtkTypeRevisionMacro | ( | vtkImageSobel2D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel2D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

void vtkImageSobel2D::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel2D::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageSpatialFilter.

Definition at line 57 of file vtkImageSobel2D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSobel2D.h
Generated on Mon Mar 25 01:19:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSobel3D Class Reference

Computes a vector field using sobel functions. More...

#include <vtkImageSobel3D.h>

Inheritance diagram for vtkImageSobel3D:

[legend]
Collaboration diagram for vtkImageSobel3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSobel3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkImageSobel3D * | New ()

Protected Methods

vtkImageSobel3D ()
~vtkImageSobel3D ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int outExt[6], int id)
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()

Detailed Description

Computes a vector field using sobel functions.

Date:
2002/01/22 15:33:31
Revision:
1.28

vtkImageSobel3D computes a vector field from a scalar field by using Sobel functions. The number of vector components is 3 because the input is a volume. Output is always floats. A little creative liberty was used to extend the 2D sobel kernels into 3D.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (85%)
  • Martin, Ken (8%)
Tests:
vtkImageSobel3D (Tests)

Definition at line 44 of file vtkImageSobel3D.h.

Constructor & Destructor Documentation

vtkImageSobel3D::vtkImageSobel3D ( ) [protected]

vtkImageSobel3D::~vtkImageSobel3D ( ) [inline, protected]

Definition at line 53 of file vtkImageSobel3D.h.

Member Function Documentation

vtkImageSobel3D* vtkImageSobel3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageSobel3D::vtkTypeRevisionMacro | ( | vtkImageSobel3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | outExt[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

void vtkImageSobel3D::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageSpatialFilter.

void vtkImageSobel3D::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageSpatialFilter.

Definition at line 58 of file vtkImageSobel3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSobel3D.h
Generated on Mon Mar 25 01:19:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSource Class Reference

Source of data for the imaging pipeline. More...

#include <vtkImageSource.h>

Inheritance diagram for vtkImageSource:

[legend]
Collaboration diagram for vtkImageSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSource, vtkSource)
void | SetOutput (vtkImageData *output)
vtkImageData * GetOutput ()
vtkImageData * | GetOutput (int idx)

Static Public Methods

vtkImageSource * | New ()

Protected Methods

vtkImageSource ()
~vtkImageSource ()
void | Execute ()
virtual void | Execute (vtkImageData *data)
vtkImageData * | AllocateOutputData (vtkDataObject *out)
void | ComputeRequiredInputUpdateExtent (int *vtkNotUsed(in), int *vtkNotUsed(out))

Detailed Description

Source of data for the imaging pipeline.

Date:
2002/01/22 15:28:06
Revision:
1.55

vtkImageSource is the superclass for all imaging sources and filters. The method Update(), called by the cache, is the major interface to the source.

See also:
vtkImageToImageFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (67%)
  • Martin, Ken (20%)

Definition at line 43 of file vtkImageSource.h.

Constructor & Destructor Documentation

vtkImageSource::vtkImageSource ( ) [protected]

vtkImageSource::~vtkImageSource ( ) [inline, protected]

Definition at line 59 of file vtkImageSource.h.

Member Function Documentation

vtkImageSource::vtkTypeRevisionMacro | ( | vtkImageSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageTwoInputFilter, vtkSimpleImageToImageFilter, vtkMILVideoSource, vtkRenderLargeImage, vtkTransformToGrid, vtkVideoSource, vtkWin32VideoSource, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkSimpleImageFilterExample, vtkBMPReader, vtkDEMReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkJPEGReader, vtkMedicalImageReader2, vtkPNGReader, vtkPNMReader, vtkSLCReader, vtkImageBlockReader, vtkMemoryLimitImageDataStreamer, vtkRTAnalyticSource, and vtkWindowToImageFilter.

vtkImageSource* vtkImageSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageTwoInputFilter, vtkMILVideoSource, vtkRenderLargeImage, vtkTransformToGrid, vtkVideoSource, vtkWin32VideoSource, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkSimpleImageFilterExample, vtkBMPReader, vtkDEMReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkJPEGReader, vtkMedicalImageReader2, vtkPNGReader, vtkPNMReader, vtkSLCReader, vtkTIFFReader, vtkImageBlockReader, vtkMemoryLimitImageDataStreamer, vtkRTAnalyticSource, and vtkWindowToImageFilter.

void vtkImageSource::SetOutput ( vtkImageData * output )

Get the output of this source.

vtkImageData* vtkImageSource::GetOutput ( )

Get the output of this source.

Reimplemented in vtkImageMultipleInputOutputFilter, and vtkImageOpenClose3D.

Referenced by vtkImageOpenClose3D::GetOutput().

vtkImageData* vtkImageSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Reimplemented in vtkImageMultipleInputOutputFilter, and vtkImageOpenClose3D.

Definition at line 53 of file vtkImageSource.h.

void vtkImageSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkImageSource::Execute ( vtkImageData * data ) [protected, virtual]

Reimplemented in vtkImageBlockReader.

vtkImageData* vtkImageSource::AllocateOutputData ( vtkDataObject * out ) [protected]

void vtkImageSource::ComputeRequiredInputUpdateExtent | ( | int *vtkNotUsed(in) | ,
 |  | int *vtkNotUsed(out) |
 | ) | [inline, protected]

Definition at line 68 of file vtkImageSource.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImageSource.h
Generated on Mon Mar 25 01:19:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageSpatialFilter Class Reference

Filters that operate on pixel neighborhoods. More...

#include <vtkImageSpatialFilter.h>

Inheritance diagram for vtkImageSpatialFilter:

[legend]
Collaboration diagram for vtkImageSpatialFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageSpatialFilter, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
int * | GetKernelSize ()
int * | GetKernelMiddle ()

Static Public Methods

vtkImageSpatialFilter * | New ()

Protected Methods

vtkImageSpatialFilter ()
~vtkImageSpatialFilter ()
void | ExecuteInformation ()
virtual void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ComputeOutputWholeExtent (int extent[6], int handleBoundaries)
void | ComputeInputUpdateExtent (int extent[6], int wholeExtent[6])

Protected Attributes

int | KernelSize [3]
int | KernelMiddle [3]
int | Strides [3]
int | HandleBoundaries

Detailed Description

Filters that operate on pixel neighborhoods.

Date:
2002/01/22 15:33:32
Revision:
1.46

vtkImageSpatialFilter is a super class for filters that operate on an input neighborhood for each output pixel. It handles even sized neighborhoods, but their can be a half pixel shift associated with processing. This superclass has some logic for handling boundaries. It can split regions into boundary and non-boundary pieces and call different execute methods.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Martin, Ken (12%)

Definition at line 43 of file vtkImageSpatialFilter.h.

Constructor & Destructor Documentation

vtkImageSpatialFilter::vtkImageSpatialFilter ( ) [protected]

vtkImageSpatialFilter::~vtkImageSpatialFilter ( ) [inline, protected]

Definition at line 58 of file vtkImageSpatialFilter.h.

Member Function Documentation

vtkImageSpatialFilter* vtkImageSpatialFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageDilateErode3D, vtkImageHybridMedian2D, vtkImageMedian3D, vtkImageRange3D, vtkImageSobel2D, vtkImageSobel3D, and vtkImageVariance3D.

vtkImageSpatialFilter::vtkTypeRevisionMacro | ( | vtkImageSpatialFilter | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageDilateErode3D, vtkImageHybridMedian2D, vtkImageMedian3D, vtkImageRange3D, vtkImageSobel2D, vtkImageSobel3D, and vtkImageVariance3D.

void vtkImageSpatialFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageDilateErode3D, vtkImageMedian3D, vtkImageRange3D, vtkImageSobel2D, vtkImageSobel3D, and vtkImageVariance3D.

int* vtkImageSpatialFilter::GetKernelSize ( ) [inline]

Get the Kernel size.

Definition at line 51 of file vtkImageSpatialFilter.h.

int* vtkImageSpatialFilter::GetKernelMiddle ( ) [inline]

Get the Kernel middle.

Definition at line 54 of file vtkImageSpatialFilter.h.

void vtkImageSpatialFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageRange3D, vtkImageSobel2D, vtkImageSobel3D, and vtkImageVariance3D.

virtual void vtkImageSpatialFilter::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Reimplemented in vtkImageRange3D, vtkImageSobel2D, vtkImageSobel3D, and vtkImageVariance3D.

void vtkImageSpatialFilter::ComputeOutputWholeExtent | ( | int | extent[6],
 |  | int | handleBoundaries
 | ) | [protected]

void vtkImageSpatialFilter::ComputeInputUpdateExtent | ( | int | extent[6],
 |  | int | wholeExtent[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageSpatialFilter::KernelSize[3] [protected]

Definition at line 60 of file vtkImageSpatialFilter.h.

int vtkImageSpatialFilter::KernelMiddle[3] [protected]

Definition at line 61 of file vtkImageSpatialFilter.h.

int vtkImageSpatialFilter::Strides[3] [protected]

Definition at line 62 of file vtkImageSpatialFilter.h.

int vtkImageSpatialFilter::HandleBoundaries [protected]

Definition at line 63 of file vtkImageSpatialFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageSpatialFilter.h
Generated on Mon Mar 25 01:19:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencil Class Reference

combine images via a cookie-cutter operation. More...

#include <vtkImageStencil.h>

Inheritance diagram for vtkImageStencil:

[legend]
Collaboration diagram for vtkImageStencil:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageStencil, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetStencil (vtkImageStencilData *stencil)
vtkImageStencilData * GetStencil ()
virtual void | SetReverseStencil (int)
virtual void | ReverseStencilOn ()
virtual void | ReverseStencilOff ()
virtual int | GetReverseStencil ()
virtual void | SetBackgroundInput (vtkImageData *input)
vtkImageData * GetBackgroundInput ()
void | SetBackgroundValue (float val)
float | GetBackgroundValue ()
virtual void | SetBackgroundColor (float, float, float, float)
virtual void | SetBackgroundColor (float[4])
virtual float * | GetBackgroundColor ()
virtual void | GetBackgroundColor (float &, float &, float &, float &)
virtual void | GetBackgroundColor (float[4])

Static Public Methods

vtkImageStencil * | New ()

Protected Methods

vtkImageStencil ()
~vtkImageStencil ()
void | ExecuteInformation ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

int | ReverseStencil
float | BackgroundColor [4]

Detailed Description

combine images via a cookie-cutter operation.

Date:
2002/01/22 15:33:33
Revision:
1.6

vtkImageStencil will combine two images together using a stencil. The stencil should be provided in the form of a vtkImageStencilData,

Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)
Tests:
vtkImageStencil (Tests)

Definition at line 41 of file vtkImageStencil.h.

Constructor & Destructor Documentation

vtkImageStencil::vtkImageStencil ( ) [protected]

vtkImageStencil::~vtkImageStencil ( ) [protected]

Member Function Documentation

vtkImageStencil* vtkImageStencil::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageStencil::vtkTypeRevisionMacro | ( | vtkImageStencil | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageStencil::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageStencil::SetStencil ( vtkImageStencilData * stencil ) [virtual]

Specify the stencil to use. The stencil can be created from a vtkImplicitFunction or a vtkPolyData.

vtkImageStencilData* vtkImageStencil::GetStencil ( )

Specify the stencil to use. The stencil can be created from a vtkImplicitFunction or a vtkPolyData.

virtual void vtkImageStencil::SetReverseStencil ( int ) [virtual]

Reverse the stencil.

virtual void vtkImageStencil::ReverseStencilOn ( ) [virtual]

Reverse the stencil.

virtual void vtkImageStencil::ReverseStencilOff ( ) [virtual]

Reverse the stencil.

virtual int vtkImageStencil::GetReverseStencil ( ) [virtual]

Reverse the stencil.

virtual void vtkImageStencil::SetBackgroundInput ( vtkImageData * input ) [virtual]

NOTE: Not yet implemented, use SetBackgroundValue instead. Set the second input. This image will be used for the 'outside' of the stencil. If not set, the output voxels will be filled with BackgroundValue instead.

vtkImageData* vtkImageStencil::GetBackgroundInput ( )

NOTE: Not yet implemented, use SetBackgroundValue instead. Set the second input. This image will be used for the 'outside' of the stencil. If not set, the output voxels will be filled with BackgroundValue instead.

void vtkImageStencil::SetBackgroundValue ( float val ) [inline]

Set the default output value to use when the second input is not set.

Definition at line 73 of file vtkImageStencil.h.

float vtkImageStencil::GetBackgroundValue ( ) [inline]

Set the default output value to use when the second input is not set.

Definition at line 75 of file vtkImageStencil.h.

virtual void vtkImageStencil::SetBackgroundColor | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the default color to use when the second input is not set. This is like SetBackgroundValue, but for multi-component images.

virtual void vtkImageStencil::SetBackgroundColor ( float [4] ) [virtual]

Set the default color to use when the second input is not set. This is like SetBackgroundValue, but for multi-component images.

virtual float* vtkImageStencil::GetBackgroundColor ( ) [virtual]

Set the default color to use when the second input is not set. This is like SetBackgroundValue, but for multi-component images.

virtual void vtkImageStencil::GetBackgroundColor | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the default color to use when the second input is not set. This is like SetBackgroundValue, but for multi-component images.

virtual void vtkImageStencil::GetBackgroundColor ( float [4] ) [virtual]

Set the default color to use when the second input is not set. This is like SetBackgroundValue, but for multi-component images.

void vtkImageStencil::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 90 of file vtkImageStencil.h.

void vtkImageStencil::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageStencil::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageStencil::ReverseStencil [protected]

Definition at line 97 of file vtkImageStencil.h.

float vtkImageStencil::BackgroundColor[4] [protected]

Definition at line 98 of file vtkImageStencil.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageStencil.h
Generated on Mon Mar 25 01:19:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencilData Class Reference

efficient description of an image stencil. More...

#include <vtkImageStencilData.h>

Inheritance diagram for vtkImageStencilData:

[legend]
Collaboration diagram for vtkImageStencilData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageStencilData, vtkDataObject)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * MakeObject ()
void | Initialize ()
void | DeepCopy (vtkDataObject *o)
void | ShallowCopy (vtkDataObject *f)
void | InternalImageStencilDataCopy (vtkImageStencilData *s)
int | GetDataObjectType ()
int | GetExtentType ()
void | InsertNextExtent (int r1, int r2, int yIdx, int zIdx)
void | AllocateExtents ()
void | UpdateData ()
void | PropagateUpdateExtent ()
void | TriggerAsynchronousUpdate ()
int | GetNextExtent (int &r1, int &r2, int xMin, int xMax, int yIdx, int zIdx, int &iter)
virtual void | SetSpacing (float, float, float)
virtual void | SetSpacing (float[3])
virtual float * | GetSpacing ()
virtual void | GetSpacing (float &, float &, float &)
virtual void | GetSpacing (float[3])
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float &, float &, float &)
virtual void | GetOrigin (float[3])
virtual void | SetExtent (int, int, int, int, int, int)
virtual void | SetExtent (int[6])
virtual int * | GetExtent ()
virtual void | GetExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetExtent (int[6])
virtual void | SetOldSpacing (float, float, float)
virtual void | SetOldSpacing (float[3])
virtual float * | GetOldSpacing ()
virtual void | GetOldSpacing (float &, float &, float &)
virtual void | GetOldSpacing (float[3])
virtual void | SetOldOrigin (float, float, float)
virtual void | SetOldOrigin (float[3])
virtual float * | GetOldOrigin ()
virtual void | GetOldOrigin (float &, float &, float &)
virtual void | GetOldOrigin (float[3])

Static Public Methods

vtkImageStencilData * | New ()

Protected Methods

vtkImageStencilData ()
~vtkImageStencilData ()
int | SpacingOrOriginHasChanged ()

Protected Attributes

float | OldSpacing [3]
float | OldOrigin [3]
float | Spacing [3]
float | Origin [3]
int | NumberOfExtentEntries
int * | ExtentListLengths
int ** | ExtentLists

Detailed Description

efficient description of an image stencil.

Date:
2002/01/22 15:33:35
Revision:
1.7

vtkImageStencilData describes an image stencil in a manner which is efficient both in terms of speed and storage space. The stencil extents are stored for each x-row across the image (multiple extents per row if necessary) and can be retrieved via the GetNextExtent() method.

See also:
vtkImageStencilSource vtkImageStencil
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)

Definition at line 42 of file vtkImageStencilData.h.

Constructor & Destructor Documentation

vtkImageStencilData::vtkImageStencilData ( ) [protected]

vtkImageStencilData::~vtkImageStencilData ( ) [protected]

Member Function Documentation

vtkImageStencilData* vtkImageStencilData::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

vtkImageStencilData::vtkTypeRevisionMacro | ( | vtkImageStencilData | ,
 |  | vtkDataObject |
 | ) |

Reimplemented from vtkDataObject.

void vtkImageStencilData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataObject.

vtkDataObject* vtkImageStencilData::MakeObject ( ) [virtual]

Create concrete instance of this data object.

Reimplemented from vtkDataObject.

void vtkImageStencilData::Initialize ( ) [virtual]

Reimplemented from vtkDataObject.

void vtkImageStencilData::DeepCopy ( vtkDataObject * o ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented from vtkDataObject.

void vtkImageStencilData::ShallowCopy ( vtkDataObject * f ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented from vtkDataObject.

void vtkImageStencilData::InternalImageStencilDataCopy ( vtkImageStencilData * s )

int vtkImageStencilData::GetDataObjectType ( ) [inline, virtual]

Get the data type as an integer (this will return VTK_DATA_OBJECT for now, maybe a proper type constant will be reserved later).

Reimplemented from vtkDataObject.

Definition at line 57 of file vtkImageStencilData.h.

int vtkImageStencilData::GetExtentType ( ) [inline, virtual]

The extent type is 3D, just like vtkImageData.

Reimplemented from vtkDataObject.

Definition at line 60 of file vtkImageStencilData.h.

int vtkImageStencilData::GetNextExtent | ( | int & | r1,
 |  | int & | r2,
 |  | int | xMin,
 |  | int | xMax,
 |  | int | yIdx,
 |  | int | zIdx,
 |  | int & | iter
 | ) |

Given the total output x extent [xMin,xMax] and the current y, z indices, return each sub-extent [r1,r2] that lies within within the unclipped region in sequence. A value of '0' is returned if no more sub-extents are available. The variable 'iter' must be initialized to zero before the first call, unless you want the complementary sub-extents in which case you must initialize 'iter' to -1. The variable 'iter' is used internally to keep track of which sub-extent should be returned next.

void vtkImageStencilData::InsertNextExtent | ( | int | r1,
 |  | int | r2,
 |  | int | yIdx,
 |  | int | zIdx
 | ) |

This method is used by vtkImageStencilDataSource to add an x sub extent [r1,r2] for the x row (yIdx,zIdx). The specified sub extent must not intersect any other sub extents along the same x row. As well, r1 and r2 must both be within the total x extent [Extent[0],Extent[1]].

virtual void vtkImageStencilData::SetSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the desired spacing for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::SetSpacing ( float [3] ) [virtual]

Set the desired spacing for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual float* vtkImageStencilData::GetSpacing ( ) [virtual]

Set the desired spacing for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::GetSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the desired spacing for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::GetSpacing ( float [3] ) [virtual]

Set the desired spacing for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the desired origin for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::SetOrigin ( float [3] ) [virtual]

Set the desired origin for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual float* vtkImageStencilData::GetOrigin ( ) [virtual]

Set the desired origin for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::GetOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the desired origin for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::GetOrigin ( float [3] ) [virtual]

Set the desired origin for the stencil. This must be called before the stencil is Updated, ideally in the ExecuteInformation method of the imaging filter that is using the stencil.

virtual void vtkImageStencilData::SetExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the extent of the data. This is should be called only by vtkImageStencilSource, as it is part of the basic pipeline functionality.

virtual void vtkImageStencilData::SetExtent ( int [6] ) [virtual]

Set the extent of the data. This is should be called only by vtkImageStencilSource, as it is part of the basic pipeline functionality.

virtual int* vtkImageStencilData::GetExtent ( ) [virtual]

Set the extent of the data. This is should be called only by vtkImageStencilSource, as it is part of the basic pipeline functionality.

virtual void vtkImageStencilData::GetExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the extent of the data. This is should be called only by vtkImageStencilSource, as it is part of the basic pipeline functionality.

virtual void vtkImageStencilData::GetExtent ( int [6] ) [virtual]

Set the extent of the data. This is should be called only by vtkImageStencilSource, as it is part of the basic pipeline functionality.

virtual void vtkImageStencilData::SetOldSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Save the previous data spacing. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::SetOldSpacing ( float [3] ) [virtual]

Save the previous data spacing. This should be called only by vtkImageStencilSource.

virtual float* vtkImageStencilData::GetOldSpacing ( ) [virtual]

Save the previous data spacing. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::GetOldSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Save the previous data spacing. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::GetOldSpacing ( float [3] ) [virtual]

Save the previous data spacing. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::SetOldOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Save the previous data origin. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::SetOldOrigin ( float [3] ) [virtual]

Save the previous data origin. This should be called only by vtkImageStencilSource.

virtual float* vtkImageStencilData::GetOldOrigin ( ) [virtual]

Save the previous data origin. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::GetOldOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Save the previous data origin. This should be called only by vtkImageStencilSource.

virtual void vtkImageStencilData::GetOldOrigin ( float [3] ) [virtual]

Save the previous data origin. This should be called only by vtkImageStencilSource.

void vtkImageStencilData::AllocateExtents ( )

Allocate space for the sub-extents. This is called by vtkImageStencilSource.

void vtkImageStencilData::UpdateData ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. Propagate the update back up the pipeline, and perform the actual work of updating on the way down. When the propagate arrives at a port, block and wait for the asynchronous update to finish on the other side. This propagation may early terminate based on the PipelineMTime.

Reimplemented from vtkDataObject.

void vtkImageStencilData::PropagateUpdateExtent ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. The update extent for this object is propagated up the pipeline. This propagation may early terminate based on the PipelineMTime.

Reimplemented from vtkDataObject.

void vtkImageStencilData::TriggerAsynchronousUpdate ( ) [virtual]

WARNING: INTERNAL METHOD - NOT FOR GENERAL USE. THIS METHOD IS PART OF THE PIPELINE UPDATE FUNCTIONALITY. Propagate back up the pipeline for ports and trigger the update on the other side of the port to allow for asynchronous parallel processing in the pipeline. This propagation may early terminate based on the PipelineMTime.

Reimplemented from vtkDataObject.

int vtkImageStencilData::SpacingOrOriginHasChanged ( ) [protected]

Check to see of the Spacing and Origin are different from the OldSpacing and OldOrigin.

Member Data Documentation

float vtkImageStencilData::OldSpacing[3] [protected]

Previous Spacing and Origin values, so that it is possible to know when an update is required because they have changed.

Definition at line 156 of file vtkImageStencilData.h.

float vtkImageStencilData::OldOrigin[3] [protected]

Previous Spacing and Origin values, so that it is possible to know when an update is required because they have changed.

Definition at line 157 of file vtkImageStencilData.h.

float vtkImageStencilData::Spacing[3] [protected]

The Spacing and Origin of the data.

Definition at line 162 of file vtkImageStencilData.h.

float vtkImageStencilData::Origin[3] [protected]

The Spacing and Origin of the data.

Definition at line 163 of file vtkImageStencilData.h.

int vtkImageStencilData::NumberOfExtentEntries [protected]

The actual 'data' is stored here.

Definition at line 168 of file vtkImageStencilData.h.

int* vtkImageStencilData::ExtentListLengths [protected]

The actual 'data' is stored here.

Definition at line 169 of file vtkImageStencilData.h.

int** vtkImageStencilData::ExtentLists [protected]

The actual 'data' is stored here.

Definition at line 170 of file vtkImageStencilData.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageStencilData.h
Generated on Mon Mar 25 01:19:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageStencilSource Class Reference

helper class for clipping images. More...

#include <vtkImageStencilSource.h>

Inheritance diagram for vtkImageStencilSource:

[legend]
Collaboration diagram for vtkImageStencilSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageStencilSource, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOutput (vtkImageStencilData *output)
vtkImageStencilData * GetOutput ()

Static Public Methods

vtkImageStencilSource * | New ()

Protected Methods

vtkImageStencilSource ()
~vtkImageStencilSource ()
void | ExecuteData (vtkDataObject *out)
vtkImageStencilData * | AllocateOutputData (vtkDataObject *out)
virtual void | ThreadedExecute (vtkImageStencilData *output, int extent[6], int threadId)

Detailed Description

helper class for clipping images.

Date:
2002/01/22 15:33:36
Revision:
1.7

vtkImageStencilSource is a helper class for vtkImageToImageFilter classes. Given a clipping object such as a vtkImplicitFunction, it will set up a list of clipping extents for each x-row through the image data. The extents for each x-row can be retrieved via the GetNextExtent() method after the extent lists have been built with the BuildExtents() method. For large images, using clipping extents is much more memory efficient (and slightly more time-efficient) than building a mask. This class can be subclassed to allow clipping with objects other than vtkImplicitFunction.

See also:
vtkImplicitFunction vtkImageStencil vtkImagePolyDataStencilSource
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)

Definition at line 48 of file vtkImageStencilSource.h.

Constructor & Destructor Documentation

vtkImageStencilSource::vtkImageStencilSource ( ) [protected]

vtkImageStencilSource::~vtkImageStencilSource ( ) [protected]

Member Function Documentation

vtkImageStencilSource* vtkImageStencilSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkPolyDataToImageStencil, vtkImageToImageStencil, and vtkImplicitFunctionToImageStencil.

vtkImageStencilSource::vtkTypeRevisionMacro | ( | vtkImageStencilSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkPolyDataToImageStencil, vtkImageToImageStencil, and vtkImplicitFunctionToImageStencil.

void vtkImageStencilSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkPolyDataToImageStencil, vtkImageToImageStencil, and vtkImplicitFunctionToImageStencil.

void vtkImageStencilSource::SetOutput ( vtkImageStencilData * output )

Get or set the output for this source.

vtkImageStencilData* vtkImageStencilSource::GetOutput ( )

Get or set the output for this source.

void vtkImageStencilSource::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented in vtkPolyDataToImageStencil.

vtkImageStencilData* vtkImageStencilSource::AllocateOutputData ( vtkDataObject * out ) [protected]

virtual void vtkImageStencilSource::ThreadedExecute | ( | vtkImageStencilData * | output,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [protected, virtual]

Override this method to support clipping with different kinds of objects. Eventually the extent could be split up and handled by multiple threads, but it isn't for now. But please ensure that all code inside this method is thread-safe.

Reimplemented in vtkPolyDataToImageStencil, vtkImageToImageStencil, and vtkImplicitFunctionToImageStencil.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageStencilSource.h
Generated on Mon Mar 25 01:19:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageThreshold Class Reference

Flexible threshold. More...

#include <vtkImageThreshold.h>

Inheritance diagram for vtkImageThreshold:

[legend]
Collaboration diagram for vtkImageThreshold:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageThreshold, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ThresholdByUpper (float thresh)
void | ThresholdByLower (float thresh)
void | ThresholdBetween (float lower, float upper)
virtual void | SetReplaceIn (int)
virtual int | GetReplaceIn ()
virtual void | ReplaceInOn ()
virtual void | ReplaceInOff ()
void | SetInValue (float val)
virtual float | GetInValue ()
virtual void | SetReplaceOut (int)
virtual int | GetReplaceOut ()
virtual void | ReplaceOutOn ()
virtual void | ReplaceOutOff ()
void | SetOutValue (float val)
virtual float | GetOutValue ()
virtual float | GetUpperThreshold ()
virtual float | GetLowerThreshold ()
virtual void | SetOutputScalarType (int)
virtual int | GetOutputScalarType ()
void | SetOutputScalarTypeToDouble ()
void | SetOutputScalarTypeToFloat ()
void | SetOutputScalarTypeToLong ()
void | SetOutputScalarTypeToUnsignedLong ()
void | SetOutputScalarTypeToInt ()
void | SetOutputScalarTypeToUnsignedInt ()
void | SetOutputScalarTypeToShort ()
void | SetOutputScalarTypeToUnsignedShort ()
void | SetOutputScalarTypeToChar ()
void | SetOutputScalarTypeToUnsignedChar ()

Static Public Methods

vtkImageThreshold * | New ()

Protected Methods

vtkImageThreshold ()
~vtkImageThreshold ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

float | UpperThreshold
float | LowerThreshold
int | ReplaceIn
float | InValue
int | ReplaceOut
float | OutValue
int | OutputScalarType

Detailed Description

Flexible threshold.

Date:
2002/01/22 15:33:37
Revision:
1.33

vtkImageThreshold Can do binary or continuous thresholding for lower, upper or a range of data. The output data type may be different than the output, but defaults to the same type.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (50%)
  • Martin, Ken (24%)
  • Blezek, Dan (9%)
  • Lorensen, Bill (6%)
Tests:
vtkImageThreshold (Tests)

Definition at line 45 of file vtkImageThreshold.h.

Constructor & Destructor Documentation

vtkImageThreshold::vtkImageThreshold ( ) [protected]

vtkImageThreshold::~vtkImageThreshold ( ) [inline, protected]

Definition at line 121 of file vtkImageThreshold.h.

Member Function Documentation

vtkImageThreshold* vtkImageThreshold::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageThreshold::vtkTypeRevisionMacro | ( | vtkImageThreshold | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageThreshold::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

void vtkImageThreshold::ThresholdByUpper ( float thresh )

The values greater than or equal to the value match.

void vtkImageThreshold::ThresholdByLower ( float thresh )

The values less than or equal to the value match.

void vtkImageThreshold::ThresholdBetween | ( | float | lower,
 |  | float | upper
 | ) |

The values in a range (inclusive) match

virtual void vtkImageThreshold::SetReplaceIn ( int ) [virtual]

Determines whether to replace the pixel in range with InValue

virtual int vtkImageThreshold::GetReplaceIn ( ) [virtual]

Determines whether to replace the pixel in range with InValue

virtual void vtkImageThreshold::ReplaceInOn ( ) [virtual]

Determines whether to replace the pixel in range with InValue

virtual void vtkImageThreshold::ReplaceInOff ( ) [virtual]

Determines whether to replace the pixel in range with InValue

void vtkImageThreshold::SetInValue ( float val )

Replace the in range pixels with this value.

virtual float vtkImageThreshold::GetInValue ( ) [virtual]

Replace the in range pixels with this value.

virtual void vtkImageThreshold::SetReplaceOut ( int ) [virtual]

Determines whether to replace the pixel out of range with OutValue

virtual int vtkImageThreshold::GetReplaceOut ( ) [virtual]

Determines whether to replace the pixel out of range with OutValue

virtual void vtkImageThreshold::ReplaceOutOn ( ) [virtual]

Determines whether to replace the pixel out of range with OutValue

virtual void vtkImageThreshold::ReplaceOutOff ( ) [virtual]

Determines whether to replace the pixel out of range with OutValue

void vtkImageThreshold::SetOutValue ( float val )

Replace the in range pixels with this value.

virtual float vtkImageThreshold::GetOutValue ( ) [virtual]

Replace the in range pixels with this value.

virtual float vtkImageThreshold::GetUpperThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

virtual float vtkImageThreshold::GetLowerThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

virtual void vtkImageThreshold::SetOutputScalarType ( int ) [virtual]

Set the desired output scalar type to cast to

virtual int vtkImageThreshold::GetOutputScalarType ( ) [virtual]

Set the desired output scalar type to cast to

void vtkImageThreshold::SetOutputScalarTypeToDouble ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 97 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToFloat ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 99 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToLong ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 101 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToUnsignedLong ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 103 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToInt ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 105 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToUnsignedInt ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 107 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToShort ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 109 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToUnsignedShort ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 111 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToChar ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 113 of file vtkImageThreshold.h.

void vtkImageThreshold::SetOutputScalarTypeToUnsignedChar ( ) [inline]

Set the desired output scalar type to cast to

Definition at line 115 of file vtkImageThreshold.h.

void vtkImageThreshold::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageThreshold::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 133 of file vtkImageThreshold.h.

void vtkImageThreshold::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

float vtkImageThreshold::UpperThreshold [protected]

Definition at line 123 of file vtkImageThreshold.h.

float vtkImageThreshold::LowerThreshold [protected]

Definition at line 124 of file vtkImageThreshold.h.

int vtkImageThreshold::ReplaceIn [protected]

Definition at line 125 of file vtkImageThreshold.h.

float vtkImageThreshold::InValue [protected]

Definition at line 126 of file vtkImageThreshold.h.

int vtkImageThreshold::ReplaceOut [protected]

Definition at line 127 of file vtkImageThreshold.h.

float vtkImageThreshold::OutValue [protected]

Definition at line 128 of file vtkImageThreshold.h.

int vtkImageThreshold::OutputScalarType [protected]

Definition at line 130 of file vtkImageThreshold.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageThreshold.h
Generated on Mon Mar 25 01:19:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToImageFilter Class Reference

Generic filter that has one input.. More...

#include <vtkImageToImageFilter.h>

Inheritance diagram for vtkImageToImageFilter:

[legend]
Collaboration diagram for vtkImageToImageFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageToImageFilter, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInputMemoryLimit (int)
long | GetInputMemoryLimit ()
virtual void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
void | SetBypass (int)
void | BypassOn ()
void | BypassOff ()
virtual int | GetBypass ()
virtual void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId)
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
virtual int | SplitExtent (int splitExt[6], int startExt[6], int num, int total)

Static Public Methods

vtkImageToImageFilter * | New ()

Protected Methods

vtkImageToImageFilter ()
~vtkImageToImageFilter ()
void | ExecuteInformation ()
virtual void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteData (vtkDataObject *output)
void | MultiThread (vtkImageData *input, vtkImageData *output)
void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])

Protected Attributes

vtkMultiThreader * Threader
int | Bypass
int | BypassWasOn
int | NumberOfThreads

Detailed Description

Generic filter that has one input..

Date:
2002/01/22 15:28:06
Revision:
1.35

vtkImageToImageFilter is a filter superclass that hides much of the pipeline complexity. It handles breaking the pipeline execution into smaller extents so that the vtkImageData limits are observed. It also provides support for multithreading. If you don't need any of this functionality, consider using vtkSimpleImageToImageFilter instead.

See also:
vtkSimpleImageToImageFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (78%)
  • Lorensen, Bill (7%)
Examples:
vtkImageToImageFilter (Examples)

Definition at line 48 of file vtkImageToImageFilter.h.

Constructor & Destructor Documentation

vtkImageToImageFilter::vtkImageToImageFilter ( ) [protected]

vtkImageToImageFilter::~vtkImageToImageFilter ( ) [protected]

Member Function Documentation

vtkImageToImageFilter* vtkImageToImageFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

Reimplemented in vtkImageInPlaceFilter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDilateErode3D, vtkImageDivergence, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGradient, vtkImageGradientMagnitude, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageIslandRemoval2D, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMaskBits, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, and vtkMemoryLimitImageDataStreamer.

vtkImageToImageFilter::vtkTypeRevisionMacro | ( | vtkImageToImageFilter | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

Reimplemented in vtkImageInPlaceFilter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDilateErode3D, vtkImageDivergence, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageGaussianSmooth, vtkImageGradient, vtkImageGradientMagnitude, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMaskBits, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, and vtkMemoryLimitImageDataStreamer.

void vtkImageToImageFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDilateErode3D, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFlip, vtkImageGaussianSmooth, vtkImageGradient, vtkImageGradientMagnitude, vtkImageHSVToRGB, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageMagnify, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMaskBits, vtkImageMedian3D, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, and vtkMemoryLimitImageDataStreamer.

virtual void vtkImageToImageFilter::SetInput ( vtkImageData * Input ) [virtual]

Set the Input of a filter.

Reimplemented in vtkImageOpenClose3D.

vtkImageData* vtkImageToImageFilter::GetInput ( )

Set the Input of a filter.

void vtkImageToImageFilter::SetBypass ( int ) [inline]

Obsolete feature - do not use.

Definition at line 63 of file vtkImageToImageFilter.h.

void vtkImageToImageFilter::BypassOn ( ) [inline]

Obsolete feature - do not use.

Definition at line 64 of file vtkImageToImageFilter.h.

void vtkImageToImageFilter::BypassOff ( ) [inline]

Obsolete feature - do not use.

Definition at line 65 of file vtkImageToImageFilter.h.

virtual int vtkImageToImageFilter::GetBypass ( ) [virtual]

Obsolete feature - do not use.

virtual void vtkImageToImageFilter::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outRegion,
 |  | int | ext[6],
 |  | int | id
 | ) | [virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented in vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCast, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageDilateErode3D, vtkImageDivergence, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGradient, vtkImageGradientMagnitude, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMaskBits, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNormalize, vtkImagePermute, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageShiftScale, vtkImageShrink3D, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageStencil, vtkImageThreshold, vtkImageVariance3D, and vtkImageWrapPad.

virtual void vtkImageToImageFilter::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create when rendering

virtual int vtkImageToImageFilter::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create when rendering

void vtkImageToImageFilter::SetInputMemoryLimit ( int ) [inline]

Definition at line 85 of file vtkImageToImageFilter.h.

long vtkImageToImageFilter::GetInputMemoryLimit ( ) [inline]

Definition at line 87 of file vtkImageToImageFilter.h.

virtual int vtkImageToImageFilter::SplitExtent | ( | int | splitExt[6],
 |  | int | startExt[6],
 |  | int | num,
 |  | int | total
 | ) | [virtual]

Putting this here until I merge graphics and imaging streaming.

Reimplemented in vtkImageEuclideanDistance, vtkImageFFT, and vtkImageRFFT.

void vtkImageToImageFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Reimplemented in vtkImageAccumulate, vtkImageCast, vtkImageChangeInformation, vtkImageClip, vtkImageDivergence, vtkImageEuclideanDistance, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageGradient, vtkImageGradientMagnitude, vtkImageIterateFilter, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageNormalize, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, and vtkImageVariance3D.

Referenced by vtkImageVariance3D::ExecuteInformation(), vtkImageTranslateExtent::ExecuteInformation(), vtkImageThreshold::ExecuteInformation(), vtkImageStencil::ExecuteInformation(), vtkImageSobel3D::ExecuteInformation(), vtkImageSobel2D::ExecuteInformation(), vtkImageShrink3D::ExecuteInformation(), vtkImageShiftScale::ExecuteInformation(), vtkImageReslice::ExecuteInformation(), vtkImageResample::ExecuteInformation(), vtkImageRange3D::ExecuteInformation(), vtkImageQuantizeRGBToIndex::ExecuteInformation(), vtkImagePermute::ExecuteInformation(), vtkImagePadFilter::ExecuteInformation(), vtkImageNormalize::ExecuteInformation(), vtkImageMapToColors::ExecuteInformation(), vtkImageMagnitude::ExecuteInformation(), vtkImageMagnify::ExecuteInformation(), vtkImageLuminance::ExecuteInformation(), vtkImageGradientMagnitude::ExecuteInformation(), vtkImageGradient::ExecuteInformation(), vtkImageFlip::ExecuteInformation(), vtkImageExtractComponents::ExecuteInformation(), vtkImageDivergence::ExecuteInformation(), vtkImageClip::ExecuteInformation(), vtkImageChangeInformation::ExecuteInformation(), vtkImageCast::ExecuteInformation(), and vtkImageAccumulate::ExecuteInformation().

virtual void vtkImageToImageFilter::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented in vtkImageAccumulate, vtkImageCast, vtkImageChangeInformation, vtkImageClip, vtkImageDivergence, vtkImageEuclideanDistance, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageGradient, vtkImageGradientMagnitude, vtkImageIterateFilter, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageNormalize, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, and vtkImageVariance3D.

void vtkImageToImageFilter::ExecuteData ( vtkDataObject * data ) [protected]

Reimplemented in vtkImageInPlaceFilter, vtkImageAccumulate, vtkImageChangeInformation, vtkImageClip, vtkImageCursor3D, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageQuantizeRGBToIndex, vtkImageSeedConnectivity, and vtkImageTranslateExtent.

void vtkImageToImageFilter::MultiThread | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected]

Referenced by vtkImageSkeleton2D::IterativeExecuteData(), vtkImageRFFT::IterativeExecuteData(), vtkImageFourierCenter::IterativeExecuteData(), and vtkImageFFT::IterativeExecuteData().

void vtkImageToImageFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Reimplemented in vtkImageIterateFilter, vtkImageReslice, and vtkImageSeedConnectivity.

virtual void vtkImageToImageFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented in vtkImageAccumulate, vtkImageChangeInformation, vtkImageCityBlockDistance, vtkImageDivergence, vtkImageEuclideanDistance, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGradient, vtkImageGradientMagnitude, vtkImageIterateFilter, vtkImageLaplacian, vtkImageMagnify, vtkImageMirrorPad, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageSeparableConvolution, vtkImageShrink3D, vtkImageSkeleton2D, vtkImageSpatialFilter, vtkImageTranslateExtent, and vtkImageWrapPad.

Member Data Documentation

vtkMultiThreader* vtkImageToImageFilter::Threader [protected]

Definition at line 100 of file vtkImageToImageFilter.h.

int vtkImageToImageFilter::Bypass [protected]

Definition at line 101 of file vtkImageToImageFilter.h.

int vtkImageToImageFilter::BypassWasOn [protected]

Definition at line 102 of file vtkImageToImageFilter.h.

int vtkImageToImageFilter::NumberOfThreads [protected]

Definition at line 103 of file vtkImageToImageFilter.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImageToImageFilter.h
Generated on Mon Mar 25 01:19:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToImageStencil Class Reference

clip an image with a mask image. More...

#include <vtkImageToImageStencil.h>

Inheritance diagram for vtkImageToImageStencil:

[legend]
Collaboration diagram for vtkImageToImageStencil:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageToImageStencil, vtkImageStencilSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ThresholdByUpper (float thresh)
void | ThresholdByLower (float thresh)
void | ThresholdBetween (float lower, float upper)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | SetUpperThreshold (float)
virtual float | GetUpperThreshold ()
virtual void | SetLowerThreshold (float)
virtual float | GetLowerThreshold ()

Static Public Methods

vtkImageToImageStencil * | New ()

Protected Methods

vtkImageToImageStencil ()
~vtkImageToImageStencil ()
void | ThreadedExecute (vtkImageStencilData *output, int extent[6], int threadId)

Protected Attributes

float | UpperThreshold
float | LowerThreshold
float | Threshold

Detailed Description

clip an image with a mask image.

Date:
2002/01/22 15:33:37
Revision:
1.8

vtkImageToImageStencil will convert a vtkImageData into an stencil that can be used with vtkImageStecil or other vtk classes that apply a stencil to an image.

See also:
vtkImageStencil vtkImplicitFunctionToImageStencil vtkPolyDataToImageStencil
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (95%)
Tests:
vtkImageToImageStencil (Tests)

Definition at line 45 of file vtkImageToImageStencil.h.

Constructor & Destructor Documentation

vtkImageToImageStencil::vtkImageToImageStencil ( ) [protected]

vtkImageToImageStencil::~vtkImageToImageStencil ( ) [protected]

Member Function Documentation

vtkImageToImageStencil* vtkImageToImageStencil::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageStencilSource.

vtkImageToImageStencil::vtkTypeRevisionMacro | ( | vtkImageToImageStencil | ,
 |  | vtkImageStencilSource |
 | ) |

Reimplemented from vtkImageStencilSource.

void vtkImageToImageStencil::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageStencilSource.

void vtkImageToImageStencil::SetInput ( vtkImageData * input )

Specify the image data to convert into a stencil.

vtkImageData* vtkImageToImageStencil::GetInput ( )

Specify the image data to convert into a stencil.

void vtkImageToImageStencil::ThresholdByUpper ( float thresh )

The values greater than or equal to the value match.

void vtkImageToImageStencil::ThresholdByLower ( float thresh )

The values less than or equal to the value match.

void vtkImageToImageStencil::ThresholdBetween | ( | float | lower,
 |  | float | upper
 | ) |

The values in a range (inclusive) match

virtual void vtkImageToImageStencil::SetUpperThreshold ( float ) [virtual]

Get the Upper and Lower thresholds.

virtual float vtkImageToImageStencil::GetUpperThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

virtual void vtkImageToImageStencil::SetLowerThreshold ( float ) [virtual]

Get the Upper and Lower thresholds.

virtual float vtkImageToImageStencil::GetLowerThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

void vtkImageToImageStencil::ThreadedExecute | ( | vtkImageStencilData * | output,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [protected, virtual]

Override this method to support clipping with different kinds of objects. Eventually the extent could be split up and handled by multiple threads, but it isn't for now. But please ensure that all code inside this method is thread-safe.

Reimplemented from vtkImageStencilSource.

Member Data Documentation

float vtkImageToImageStencil::UpperThreshold [protected]

Definition at line 82 of file vtkImageToImageStencil.h.

float vtkImageToImageStencil::LowerThreshold [protected]

Definition at line 83 of file vtkImageToImageStencil.h.

float vtkImageToImageStencil::Threshold [protected]

Definition at line 84 of file vtkImageToImageStencil.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageToImageStencil.h
Generated on Mon Mar 25 01:19:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToPolyDataFilter Class Reference

generate linear primitives (vtkPolyData) from an image. More...

#include <vtkImageToPolyDataFilter.h>

Inheritance diagram for vtkImageToPolyDataFilter:

[legend]
Collaboration diagram for vtkImageToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageToPolyDataFilter, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOutputStyle (int)
virtual int | GetOutputStyle ()
void | SetOutputStyleToPixelize ()
void | SetOutputStyleToPolygonalize ()
void | SetOutputStyleToRunLength ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToLUT ()
void | SetColorModeToLinear256 ()
virtual void | SetLookupTable (vtkScalarsToColors *)
virtual vtkScalarsToColors * | GetLookupTable ()
virtual void | SetSmoothing (int)
virtual int | GetSmoothing ()
virtual void | SmoothingOn ()
virtual void | SmoothingOff ()
virtual void | SetNumberOfSmoothingIterations (int)
virtual int | GetNumberOfSmoothingIterations ()
virtual void | SetDecimation (int)
virtual int | GetDecimation ()
virtual void | DecimationOn ()
virtual void | DecimationOff ()
virtual void | SetDecimationError (float)
virtual float | GetDecimationError ()
virtual void | SetError (int)
virtual int | GetError ()
virtual void | SetSubImageSize (int)
virtual int | GetSubImageSize ()

Static Public Methods

vtkImageToPolyDataFilter * | New ()

Protected Methods

vtkImageToPolyDataFilter ()
~vtkImageToPolyDataFilter ()
void | Execute ()
virtual void | PixelizeImage (vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output)
virtual void | PolygonalizeImage (vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output)
virtual void | RunLengthImage (vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output)

Protected Attributes

int | OutputStyle
int | ColorMode
int | Smoothing
int | NumberOfSmoothingIterations
int | Decimation
float | DecimationError
int | Error
int | SubImageSize
vtkScalarsToColors * LookupTable

Detailed Description

generate linear primitives (vtkPolyData) from an image.

Date:
2002/01/22 15:30:30
Revision:
1.10

vtkImageToPolyDataFilter converts raster data (i.e., an image) into polygonal data (i.e., quads or n-sided polygons), with each polygon assigned a constant color. This is useful for writers that generate vector formats (i.e., CGM or PostScript). To use this filter, you specify how to quantize the color (or whether to use an image with a lookup table), and what style the output should be. The output is always polygons, but the choice is n x m quads (where n and m define the input image dimensions) "Pixelize" option; arbitrary polygons "Polygonalize" option; or variable number of quads of constant color generated along scan lines "RunLength" option.

The algorithm quantizes color in order to create coherent regions that the polygons can represent with good compression. By default, the input image is quantized to 256 colors using a 3-3-2 bits for red-green-blue. However, you can also supply a single component image and a lookup table, with the single component assumed to be an index into the table. (Note: a quantized image can be generated with the filter vtkImageQuantizeRGBToIndex.) The number of colors on output is equal to the number of colors in the input lookup table (or 256 if the built in linear ramp is used).

The output of the filter is polygons with a single color per polygon cell. If the output style is set to "Polygonalize", the polygons may have an large number of points (bounded by something like 2*(n+m)); and the polygon may not be convex which may cause rendering problems on some systems (use vtkTriangleFilter). Otherwise, each polygon will have four vertices. The output also contains scalar data defining RGB color in unsigned char form.

Warning:
The input linear lookup table must be of the form of 3-component unsigned char.
Warning:
This filter defines constant cell colors. If you have a plotting device that supports Gouraud shading (linear interpolation of color), then superior algorithms are available for generating polygons from images.
Warning:
Note that many plotting devices/formats support only a limited number of colors.
See also:
vtkCGMWriter vtkImageQuantizeRGBToIndex vtkTriangleFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (88%)
Tests:
vtkImageToPolyDataFilter (Tests)

Definition at line 93 of file vtkImageToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkImageToPolyDataFilter::vtkImageToPolyDataFilter ( ) [protected]

vtkImageToPolyDataFilter::~vtkImageToPolyDataFilter ( ) [protected]

Member Function Documentation

vtkImageToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkImageToPolyDataFilter | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

void vtkImageToPolyDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkImageToPolyDataFilter* vtkImageToPolyDataFilter::New ( ) [inline, static]

Instantiate object with initial number of colors 256.

Reimplemented from vtkPolyDataSource.

Definition at line 101 of file vtkImageToPolyDataFilter.h.

virtual void vtkImageToPolyDataFilter::SetOutputStyle ( int ) [virtual]

Specify how to create the output. Pixelize means converting the image to quad polygons with a constant color per quad. Polygonalize means merging colors together into polygonal regions, and then smoothing the regions (if smoothing is turned on). RunLength means creating quad polygons that may encompass several pixels on a scan line. The default behavior is Polygonalize.

virtual int vtkImageToPolyDataFilter::GetOutputStyle ( ) [virtual]

Specify how to create the output. Pixelize means converting the image to quad polygons with a constant color per quad. Polygonalize means merging colors together into polygonal regions, and then smoothing the regions (if smoothing is turned on). RunLength means creating quad polygons that may encompass several pixels on a scan line. The default behavior is Polygonalize.

void vtkImageToPolyDataFilter::SetOutputStyleToPixelize ( ) [inline]

Specify how to create the output. Pixelize means converting the image to quad polygons with a constant color per quad. Polygonalize means merging colors together into polygonal regions, and then smoothing the regions (if smoothing is turned on). RunLength means creating quad polygons that may encompass several pixels on a scan line. The default behavior is Polygonalize.

Definition at line 114 of file vtkImageToPolyDataFilter.h.

void vtkImageToPolyDataFilter::SetOutputStyleToPolygonalize ( ) [inline]

Specify how to create the output. Pixelize means converting the image to quad polygons with a constant color per quad. Polygonalize means merging colors together into polygonal regions, and then smoothing the regions (if smoothing is turned on). RunLength means creating quad polygons that may encompass several pixels on a scan line. The default behavior is Polygonalize.

Definition at line 116 of file vtkImageToPolyDataFilter.h.

void vtkImageToPolyDataFilter::SetOutputStyleToRunLength ( ) [inline]

Specify how to create the output. Pixelize means converting the image to quad polygons with a constant color per quad. Polygonalize means merging colors together into polygonal regions, and then smoothing the regions (if smoothing is turned on). RunLength means creating quad polygons that may encompass several pixels on a scan line. The default behavior is Polygonalize.

Definition at line 118 of file vtkImageToPolyDataFilter.h.

virtual void vtkImageToPolyDataFilter::SetColorMode ( int ) [virtual]

Specify how to quantize color.

virtual int vtkImageToPolyDataFilter::GetColorMode ( ) [virtual]

Specify how to quantize color.

void vtkImageToPolyDataFilter::SetColorModeToLUT ( ) [inline]

Specify how to quantize color.

Definition at line 126 of file vtkImageToPolyDataFilter.h.

void vtkImageToPolyDataFilter::SetColorModeToLinear256 ( ) [inline]

Specify how to quantize color.

Definition at line 128 of file vtkImageToPolyDataFilter.h.

virtual void vtkImageToPolyDataFilter::SetLookupTable ( vtkScalarsToColors * ) [virtual]

Set/Get the vtkLookupTable to use. The lookup table is used when the color mode is set to LUT and a single component scalar is input.

virtual vtkScalarsToColors* vtkImageToPolyDataFilter::GetLookupTable ( ) [virtual]

Set/Get the vtkLookupTable to use. The lookup table is used when the color mode is set to LUT and a single component scalar is input.

virtual void vtkImageToPolyDataFilter::SetSmoothing ( int ) [virtual]

If the output style is set to polygonalize, then you can control whether to smooth boundaries.

virtual int vtkImageToPolyDataFilter::GetSmoothing ( ) [virtual]

If the output style is set to polygonalize, then you can control whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::SmoothingOn ( ) [virtual]

If the output style is set to polygonalize, then you can control whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::SmoothingOff ( ) [virtual]

If the output style is set to polygonalize, then you can control whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::SetNumberOfSmoothingIterations ( int ) [virtual]

Specify the number of smoothing iterations to smooth polygons. (Only in effect if output style is Polygonalize and smoothing is on.)

virtual int vtkImageToPolyDataFilter::GetNumberOfSmoothingIterations ( ) [virtual]

Specify the number of smoothing iterations to smooth polygons. (Only in effect if output style is Polygonalize and smoothing is on.)

virtual void vtkImageToPolyDataFilter::SetDecimation ( int ) [virtual]

Turn on/off whether the final polygons should be decimated. whether to smooth boundaries.

virtual int vtkImageToPolyDataFilter::GetDecimation ( ) [virtual]

Turn on/off whether the final polygons should be decimated. whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::DecimationOn ( ) [virtual]

Turn on/off whether the final polygons should be decimated. whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::DecimationOff ( ) [virtual]

Turn on/off whether the final polygons should be decimated. whether to smooth boundaries.

virtual void vtkImageToPolyDataFilter::SetDecimationError ( float ) [virtual]

Specify the error to use for decimation (if decimation is on).

virtual float vtkImageToPolyDataFilter::GetDecimationError ( ) [virtual]

Specify the error to use for decimation (if decimation is on).

virtual void vtkImageToPolyDataFilter::SetError ( int ) [virtual]

Specify the error value between two colors where the colors are considered the same. Only use this if the color mode uses the default 256 table.

virtual int vtkImageToPolyDataFilter::GetError ( ) [virtual]

Specify the error value between two colors where the colors are considered the same. Only use this if the color mode uses the default 256 table.

virtual void vtkImageToPolyDataFilter::SetSubImageSize ( int ) [virtual]

Specify the size (n by n pixels) of the largest region to polygonalize. When the OutputStyle is set to VTK_STYLE_POLYGONALIZE, large amounts of memory are used. In order to process large images, the image is broken into pieces that are at most Size pixels in width and height.

virtual int vtkImageToPolyDataFilter::GetSubImageSize ( ) [virtual]

Specify the size (n by n pixels) of the largest region to polygonalize. When the OutputStyle is set to VTK_STYLE_POLYGONALIZE, large amounts of memory are used. In order to process large images, the image is broken into pieces that are at most Size pixels in width and height.

void vtkImageToPolyDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkImageToPolyDataFilter::PixelizeImage | ( | vtkUnsignedCharArray * | pixels,
 |  | int | dims[3],
 |  | float | origin[3],
 |  | float | spacing[3],
 |  | vtkPolyData * | output
 | ) | [protected, virtual]

virtual void vtkImageToPolyDataFilter::PolygonalizeImage | ( | vtkUnsignedCharArray * | pixels,
 |  | int | dims[3],
 |  | float | origin[3],
 |  | float | spacing[3],
 |  | vtkPolyData * | output
 | ) | [protected, virtual]

virtual void vtkImageToPolyDataFilter::RunLengthImage | ( | vtkUnsignedCharArray * | pixels,
 |  | int | dims[3],
 |  | float | origin[3],
 |  | float | spacing[3],
 |  | vtkPolyData * | output
 | ) | [protected, virtual]

Member Data Documentation

int vtkImageToPolyDataFilter::OutputStyle [protected]

Definition at line 192 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::ColorMode [protected]

Definition at line 193 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::Smoothing [protected]

Definition at line 194 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::NumberOfSmoothingIterations [protected]

Definition at line 195 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::Decimation [protected]

Definition at line 196 of file vtkImageToPolyDataFilter.h.

float vtkImageToPolyDataFilter::DecimationError [protected]

Definition at line 197 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::Error [protected]

Definition at line 198 of file vtkImageToPolyDataFilter.h.

int vtkImageToPolyDataFilter::SubImageSize [protected]

Definition at line 199 of file vtkImageToPolyDataFilter.h.

vtkScalarsToColors* vtkImageToPolyDataFilter::LookupTable [protected]

Definition at line 200 of file vtkImageToPolyDataFilter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkImageToPolyDataFilter.h
Generated on Mon Mar 25 01:19:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageToStructuredPoints Class Reference

Attaches image pipeline to VTK. More...

#include <vtkImageToStructuredPoints.h>

Inheritance diagram for vtkImageToStructuredPoints:

[legend]
Collaboration diagram for vtkImageToStructuredPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageToStructuredPoints, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
void | SetVectorInput (vtkImageData *input)
vtkImageData * GetVectorInput ()
vtkStructuredPoints * GetOutput ()
vtkStructuredPoints * | GetOutput (int idx)

Static Public Methods

vtkImageToStructuredPoints * | New ()

Protected Methods

vtkImageToStructuredPoints ()
~vtkImageToStructuredPoints ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *data)

Protected Attributes

int | Translate [3]

Detailed Description

Attaches image pipeline to VTK.

Date:
2002/01/22 15:28:06
Revision:
1.36

vtkImageToStructuredPoints changes an image cache format to a structured points dataset. It takes an Input plus an optional VectorInput. The VectorInput converts the RGB scalar components of the VectorInput to vector pointdata attributes. This filter will try to reference count the data but in some cases it must make a copy.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (72%)
  • Martin, Ken (19%)
Tests:
vtkImageToStructuredPoints (Tests)

Definition at line 46 of file vtkImageToStructuredPoints.h.

Constructor & Destructor Documentation

vtkImageToStructuredPoints::vtkImageToStructuredPoints ( ) [protected]

vtkImageToStructuredPoints::~vtkImageToStructuredPoints ( ) [protected]

Member Function Documentation

vtkImageToStructuredPoints* vtkImageToStructuredPoints::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkImageToStructuredPoints::vtkTypeRevisionMacro | ( | vtkImageToStructuredPoints | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkImageToStructuredPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkImageToStructuredPoints::SetInput ( vtkImageData * input )

Set/Get the input object from the image pipeline.

vtkImageData* vtkImageToStructuredPoints::GetInput ( )

Set/Get the input object from the image pipeline.

void vtkImageToStructuredPoints::SetVectorInput ( vtkImageData * input )

Set/Get the input object from the image pipeline.

vtkImageData* vtkImageToStructuredPoints::GetVectorInput ( )

Set/Get the input object from the image pipeline.

vtkStructuredPoints* vtkImageToStructuredPoints::GetOutput ( )

Get the output of this source.

vtkStructuredPoints* vtkImageToStructuredPoints::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Definition at line 69 of file vtkImageToStructuredPoints.h.

void vtkImageToStructuredPoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkImageToStructuredPoints::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkImageToStructuredPoints::ComputeInputUpdateExtents ( vtkDataObject * data ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Member Data Documentation

int vtkImageToStructuredPoints::Translate[3] [protected]

Definition at line 78 of file vtkImageToStructuredPoints.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImageToStructuredPoints.h
Generated on Mon Mar 25 01:19:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageTranslateExtent Class Reference

Changes extent, nothing else. More...

#include <vtkImageTranslateExtent.h>

Inheritance diagram for vtkImageTranslateExtent:

[legend]
Collaboration diagram for vtkImageTranslateExtent:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageTranslateExtent, vtkImageToImageFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetTranslation (int, int, int)
virtual void | SetTranslation (int[3])
virtual int * | GetTranslation ()
virtual void | GetTranslation (int &, int &, int &)
virtual void | GetTranslation (int[3])

Static Public Methods

vtkImageTranslateExtent * | New ()

Protected Methods

vtkImageTranslateExtent ()
~vtkImageTranslateExtent ()
void | ComputeInputUpdateExtent (int extent[6], int wholeExtent[6])
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *data)

Protected Attributes

int | Translation [3]

Detailed Description

Changes extent, nothing else.

Date:
2002/01/22 15:33:38
Revision:
1.23

vtkImageTranslateExtent shift the whole extent, but does not change the data.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (82%)
  • Gobbi, David (10%)
Tests:
vtkImageTranslateExtent (Tests)

Definition at line 41 of file vtkImageTranslateExtent.h.

Constructor & Destructor Documentation

vtkImageTranslateExtent::vtkImageTranslateExtent ( ) [protected]

vtkImageTranslateExtent::~vtkImageTranslateExtent ( ) [inline, protected]

Definition at line 56 of file vtkImageTranslateExtent.h.

Member Function Documentation

vtkImageTranslateExtent* vtkImageTranslateExtent::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageToImageFilter.

vtkImageTranslateExtent::vtkTypeRevisionMacro | ( | vtkImageTranslateExtent | ,
 |  | vtkImageToImageFilter |
 | ) |

Reimplemented from vtkImageToImageFilter.

void vtkImageTranslateExtent::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageToImageFilter.

virtual void vtkImageTranslateExtent::SetTranslation | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Delta to change "WholeExtent". -1 changes 0->10 to -1->9.

virtual void vtkImageTranslateExtent::SetTranslation ( int [3] ) [virtual]

Delta to change "WholeExtent". -1 changes 0->10 to -1->9.

virtual int* vtkImageTranslateExtent::GetTranslation ( ) [virtual]

Delta to change "WholeExtent". -1 changes 0->10 to -1->9.

virtual void vtkImageTranslateExtent::GetTranslation | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Delta to change "WholeExtent". -1 changes 0->10 to -1->9.

virtual void vtkImageTranslateExtent::GetTranslation ( int [3] ) [virtual]

Delta to change "WholeExtent". -1 changes 0->10 to -1->9.

void vtkImageTranslateExtent::ComputeInputUpdateExtent | ( | int | extent[6],
 |  | int | wholeExtent[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageTranslateExtent::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageToImageFilter.

void vtkImageTranslateExtent::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageToImageFilter.

Definition at line 62 of file vtkImageTranslateExtent.h.

void vtkImageTranslateExtent::ExecuteData ( vtkDataObject * data ) [protected]

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

int vtkImageTranslateExtent::Translation[3] [protected]

Definition at line 58 of file vtkImageTranslateExtent.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageTranslateExtent.h
Generated on Mon Mar 25 01:19:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageTwoInputFilter Class Reference

Generic superclass for filters that have. More...

#include <vtkImageTwoInputFilter.h>

Inheritance diagram for vtkImageTwoInputFilter:

[legend]
Collaboration diagram for vtkImageTwoInputFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageTwoInputFilter, vtkImageMultipleInputFilter)
virtual void | SetInput1 (vtkImageData *input)
virtual void | SetInput2 (vtkImageData *input)
vtkImageData * GetInput1 ()
vtkImageData * GetInput2 ()

Static Public Methods

vtkImageTwoInputFilter * | New ()

Protected Methods

vtkImageTwoInputFilter ()
~vtkImageTwoInputFilter ()

Detailed Description

Generic superclass for filters that have.

Date:
2002/01/22 15:28:06
Revision:
1.27
two inputs.

vtkImageTwoInputFilter handles two inputs. It is just a subclass of vtkImageMultipleInputFilter with some methods that are specific to two inputs. Although the inputs are labeled input1 and input2, they are stored in an array indexed starting at 0.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (92%)
  • Martin, Ken (6%)

Definition at line 41 of file vtkImageTwoInputFilter.h.

Constructor & Destructor Documentation

vtkImageTwoInputFilter::vtkImageTwoInputFilter ( ) [protected]

vtkImageTwoInputFilter::~vtkImageTwoInputFilter ( ) [inline, protected]

Definition at line 63 of file vtkImageTwoInputFilter.h.

Member Function Documentation

vtkImageTwoInputFilter* vtkImageTwoInputFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMultipleInputFilter.

Reimplemented in vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

vtkImageTwoInputFilter::vtkTypeRevisionMacro | ( | vtkImageTwoInputFilter | ,
 |  | vtkImageMultipleInputFilter |
 | ) |

Reimplemented from vtkImageMultipleInputFilter.

Reimplemented in vtkImageCheckerboard, vtkImageCorrelation, vtkImageDifference, vtkImageDotProduct, vtkImageLogic, vtkImageMask, vtkImageMathematics, and vtkImageNonMaximumSuppression.

virtual void vtkImageTwoInputFilter::SetInput1 ( vtkImageData * input ) [virtual]

Set the Input1 of this filter. If a ScalarType has not been set, then the ScalarType of the input is used.

Referenced by vtkImageMask::SetImageInput(), vtkImageDifference::SetInput(), and vtkImageNonMaximumSuppression::SetMagnitudeInput().

virtual void vtkImageTwoInputFilter::SetInput2 ( vtkImageData * input ) [virtual]

Set the Input2 of this filter. If a ScalarType has not been set, then the ScalarType of the input is used.

Referenced by vtkImageDifference::SetImage(), vtkImageMask::SetMaskInput(), and vtkImageNonMaximumSuppression::SetVectorInput().

vtkImageData* vtkImageTwoInputFilter::GetInput1 ( ) [inline]

Get the inputs to this filter.

Definition at line 57 of file vtkImageTwoInputFilter.h.

vtkImageData* vtkImageTwoInputFilter::GetInput2 ( ) [inline]

Get the inputs to this filter.

Definition at line 58 of file vtkImageTwoInputFilter.h.

Referenced by vtkImageDifference::GetImage().

The documentation for this class was generated from the following file:
  • Filtering/vtkImageTwoInputFilter.h
Generated on Mon Mar 25 01:19:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageVariance3D Class Reference

Variance in a neighborhood. More...

#include <vtkImageVariance3D.h>

Inheritance diagram for vtkImageVariance3D:

[legend]
Collaboration diagram for vtkImageVariance3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageVariance3D, vtkImageSpatialFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetKernelSize (int size0, int size1, int size2)

Static Public Methods

vtkImageVariance3D * | New ()

Protected Methods

vtkImageVariance3D ()
~vtkImageVariance3D ()
void | ExecuteInformation (vtkImageData *inData, vtkImageData *outData)
void | ExecuteInformation ()
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outData, int extent[6], int id)

Protected Attributes

vtkImageEllipsoidSource * Ellipse

Detailed Description

Variance in a neighborhood.

Date:
2002/01/22 15:33:40
Revision:
1.23

vtkImageVariance3D replaces each pixel with a measurement of pixel variance in a elliptical neighborhood centered on that pixel. The value computed is not exactly the variance. The difference between the neighbor values and center value is computed and squared for each neighbor. These values are summed and divided by the total number of neighbors to produce the output value.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (84%)
  • Martin, Ken (8%)
Tests:
vtkImageVariance3D (Tests)

Definition at line 48 of file vtkImageVariance3D.h.

Constructor & Destructor Documentation

vtkImageVariance3D::vtkImageVariance3D ( ) [protected]

vtkImageVariance3D::~vtkImageVariance3D ( ) [protected]

Member Function Documentation

vtkImageVariance3D* vtkImageVariance3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSpatialFilter.

vtkImageVariance3D::vtkTypeRevisionMacro | ( | vtkImageVariance3D | ,
 |  | vtkImageSpatialFilter |
 | ) |

Reimplemented from vtkImageSpatialFilter.

void vtkImageVariance3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageSpatialFilter.

void vtkImageVariance3D::SetKernelSize | ( | int | size0,
 |  | int | size1,
 |  | int | size2
 | ) |

This method sets the size of the neighborhood. It also sets the default middle of the neighborhood and computes the Elliptical foot print.

void vtkImageVariance3D::ExecuteInformation | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData
 | ) | [protected, virtual]

Reimplemented from vtkImageSpatialFilter.

void vtkImageVariance3D::ExecuteInformation ( ) [inline, protected, virtual]

Reimplemented from vtkImageSpatialFilter.

Definition at line 67 of file vtkImageVariance3D.h.

void vtkImageVariance3D::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outData,
 |  | int | extent[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

Member Data Documentation

vtkImageEllipsoidSource* vtkImageVariance3D::Ellipse [protected]

Definition at line 64 of file vtkImageVariance3D.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageVariance3D.h
Generated on Mon Mar 25 01:19:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageViewer Class Reference

Display a 2d image. More...

#include <vtkImageViewer.h>

Inheritance diagram for vtkImageViewer:

[legend]
Collaboration diagram for vtkImageViewer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageViewer, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
char * | GetWindowName ()
virtual void | Render (void)
vtkImageMapper * GetImageMapper ()
vtkActor2D * GetActor2D ()
vtkRenderWindow * GetRenderWindow ()
vtkRenderer * GetRenderer ()
void | SetInput (vtkImageData *in)
vtkImageData * GetInput ()
int | GetWholeZMin ()
int | GetWholeZMax ()
int | GetZSlice ()
void | SetZSlice (int s)
float | GetColorWindow ()
float | GetColorLevel ()
void | SetColorWindow (float s)
void | SetColorLevel (float s)
void | SetDisplayId (void *a)
void | SetWindowId (void *a)
void | SetParentId (void *a)
int | GetGrayScaleHint ()
void | SetGrayScaleHint (int vtkNotUsed(a))
void | GrayScaleHintOn ()
void | GrayScaleHintOff ()
int * | GetPosition ()
void | SetPosition (int a, int b)
virtual void | SetPosition (int a[2])
int * | GetSize ()
void | SetSize (int a, int b)
virtual void | SetSize (int a[2])
vtkImageWindow * GetImageWindow ()
vtkImager * GetImager ()

Static Public Methods

vtkImageViewer * | New ()

Protected Methods

vtkImageViewer ()
~vtkImageViewer ()

Protected Attributes

vtkRenderWindow * RenderWindow
vtkRenderer * Renderer
vtkImageMapper * ImageMapper
vtkActor2D * Actor2D

Detailed Description

Display a 2d image.

Date:
2002/02/07 19:28:52
Revision:
1.47

vtkImageViewer is a convenience class for displaying a 2d image. It packages up the functionality found in vtkImageWindow, vtkImager, vtkActor2D and vtkImageMapper into a single easy to use class. Behind the scenes these four classes are actually used to to provide the required functionality. vtkImageViewer is simply a wrapper around them.

See also:
vtkImageWindow vtkImager vtkImageMapper vtkActor2D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (49%)
  • Martin, Ken (44%)
Examples:
vtkImageViewer (Examples)
Tests:
vtkImageViewer (Tests)

Definition at line 52 of file vtkImageViewer.h.

Constructor & Destructor Documentation

vtkImageViewer::vtkImageViewer ( ) [protected]

vtkImageViewer::~vtkImageViewer ( ) [protected]

Member Function Documentation

vtkImageViewer* vtkImageViewer::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkImageViewer::vtkTypeRevisionMacro | ( | vtkImageViewer | ,
 |  | vtkObject |
 | ) |

void vtkImageViewer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

char* vtkImageViewer::GetWindowName ( ) [inline]

Get name of rendering window

Definition at line 61 of file vtkImageViewer.h.

virtual void vtkImageViewer::Render ( void ) [virtual]

Render the resulting image.

void vtkImageViewer::SetInput ( vtkImageData * in ) [inline]

Set/Get the input to the viewer.

Definition at line 68 of file vtkImageViewer.h.

vtkImageData* vtkImageViewer::GetInput ( ) [inline]

Set/Get the input to the viewer.

Definition at line 69 of file vtkImageViewer.h.

int vtkImageViewer::GetWholeZMin ( ) [inline]

What is the possible Min/ Max z slices available.

Definition at line 74 of file vtkImageViewer.h.

int vtkImageViewer::GetWholeZMax ( ) [inline]

What is the possible Min/ Max z slices available.

Definition at line 75 of file vtkImageViewer.h.

int vtkImageViewer::GetZSlice ( ) [inline]

Set/Get the current Z Slice to display

Definition at line 80 of file vtkImageViewer.h.

void vtkImageViewer::SetZSlice ( int s ) [inline]

Set/Get the current Z Slice to display

Definition at line 81 of file vtkImageViewer.h.

float vtkImageViewer::GetColorWindow ( ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 86 of file vtkImageViewer.h.

float vtkImageViewer::GetColorLevel ( ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 87 of file vtkImageViewer.h.

void vtkImageViewer::SetColorWindow ( float s ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 88 of file vtkImageViewer.h.

void vtkImageViewer::SetColorLevel ( float s ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 89 of file vtkImageViewer.h.

void vtkImageViewer::SetDisplayId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 94 of file vtkImageViewer.h.

void vtkImageViewer::SetWindowId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 95 of file vtkImageViewer.h.

void vtkImageViewer::SetParentId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 96 of file vtkImageViewer.h.

int vtkImageViewer::GetGrayScaleHint ( ) [inline]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

Definition at line 102 of file vtkImageViewer.h.

void vtkImageViewer::SetGrayScaleHint ( int vtkNotUsed(a) ) [inline]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

Definition at line 104 of file vtkImageViewer.h.

void vtkImageViewer::GrayScaleHintOn ( ) [inline]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

Definition at line 106 of file vtkImageViewer.h.

void vtkImageViewer::GrayScaleHintOff ( ) [inline]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

Definition at line 108 of file vtkImageViewer.h.

int* vtkImageViewer::GetPosition ( ) [inline]

Set/Get the position in screen coordinates of the rendering window.

Definition at line 114 of file vtkImageViewer.h.

void vtkImageViewer::SetPosition | ( | int | a,
 |  | int | b
 | ) | [inline]

Set/Get the position in screen coordinates of the rendering window.

Definition at line 115 of file vtkImageViewer.h.

virtual void vtkImageViewer::SetPosition ( int a[2] ) [virtual]

Set/Get the position in screen coordinates of the rendering window.

int* vtkImageViewer::GetSize ( ) [inline]

Set/Get the size of the window in screen coordinates.

Definition at line 121 of file vtkImageViewer.h.

void vtkImageViewer::SetSize | ( | int | a,
 |  | int | b
 | ) | [inline]

Set/Get the size of the window in screen coordinates.

Definition at line 122 of file vtkImageViewer.h.

virtual void vtkImageViewer::SetSize ( int a[2] ) [virtual]

Set/Get the size of the window in screen coordinates.

vtkImageWindow* vtkImageViewer::GetImageWindow ( ) [inline]

Get the internal Window Imager and Mapper

Definition at line 128 of file vtkImageViewer.h.

vtkImager* vtkImageViewer::GetImager ( ) [inline]

Get the internal Window Imager and Mapper

Definition at line 130 of file vtkImageViewer.h.

vtkImageMapper* vtkImageViewer::GetImageMapper ( ) [inline]

Definition at line 134 of file vtkImageViewer.h.

vtkActor2D* vtkImageViewer::GetActor2D ( ) [inline]

Definition at line 135 of file vtkImageViewer.h.

vtkRenderWindow* vtkImageViewer::GetRenderWindow ( ) [inline]

Definition at line 136 of file vtkImageViewer.h.

vtkRenderer* vtkImageViewer::GetRenderer ( ) [inline]

Definition at line 137 of file vtkImageViewer.h.

Member Data Documentation

vtkRenderWindow* vtkImageViewer::RenderWindow [protected]

Definition at line 143 of file vtkImageViewer.h.

vtkRenderer* vtkImageViewer::Renderer [protected]

Definition at line 144 of file vtkImageViewer.h.

vtkImageMapper* vtkImageViewer::ImageMapper [protected]

Definition at line 145 of file vtkImageViewer.h.

vtkActor2D* vtkImageViewer::Actor2D [protected]

Definition at line 146 of file vtkImageViewer.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImageViewer.h
Generated on Mon Mar 25 01:20:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageViewer2 Class Reference

#include <vtkImageViewer2.h>

Inheritance diagram for vtkImageViewer2:

[legend]
Collaboration diagram for vtkImageViewer2:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageViewer2, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
char * | GetWindowName ()
virtual void | Render (void)
void | SetupInteractor (vtkRenderWindowInteractor *)
void | SetInput (vtkImageData *in)
vtkImageData * GetInput ()
int | GetWholeZMin ()
int | GetWholeZMax ()
int | GetZSlice ()
void | SetZSlice (int s)
float | GetColorWindow ()
float | GetColorLevel ()
void | SetColorWindow (float s)
void | SetColorLevel (float s)
void | SetDisplayId (void *a)
void | SetWindowId (void *a)
void | SetParentId (void *a)
int * | GetPosition ()
void | SetPosition (int a, int b)
virtual void | SetPosition (int a[2])
int * | GetSize ()
void | SetSize (int a, int b)
virtual void | SetSize (int a[2])
virtual vtkRenderWindow * | GetRenderWindow ()
virtual vtkRenderer * | GetRenderer ()
virtual vtkImageActor * | GetImageActor ()
virtual vtkImageMapToWindowLevelColors * | GetWindowLevel ()

Static Public Methods

vtkImageViewer2 * | New ()

Protected Methods

vtkImageViewer2 ()
~vtkImageViewer2 ()

Protected Attributes

vtkImageMapToWindowLevelColors * WindowLevel
vtkRenderWindow * RenderWindow
vtkRenderer * Renderer
vtkImageActor * ImageActor
int | FirstRender
vtkRenderWindowInteractor * Interactor
vtkInteractorStyleImage * InteractorStyle

Constructor & Destructor Documentation

vtkImageViewer2::vtkImageViewer2 ( ) [protected]

vtkImageViewer2::~vtkImageViewer2 ( ) [protected]

Member Function Documentation

vtkImageViewer2* vtkImageViewer2::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkImageViewer2::vtkTypeRevisionMacro | ( | vtkImageViewer2 | ,
 |  | vtkObject |
 | ) |

void vtkImageViewer2::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

char* vtkImageViewer2::GetWindowName ( ) [inline]

Get name of rendering window

Definition at line 58 of file vtkImageViewer2.h.

virtual void vtkImageViewer2::Render ( void ) [virtual]

Render the resulting image.

void vtkImageViewer2::SetInput ( vtkImageData * in ) [inline]

Set/Get the input to the viewer.

Definition at line 65 of file vtkImageViewer2.h.

vtkImageData* vtkImageViewer2::GetInput ( ) [inline]

Set/Get the input to the viewer.

Definition at line 66 of file vtkImageViewer2.h.

int vtkImageViewer2::GetWholeZMin ( ) [inline]

What is the possible Min/ Max z slices available.

Definition at line 71 of file vtkImageViewer2.h.

int vtkImageViewer2::GetWholeZMax ( ) [inline]

What is the possible Min/ Max z slices available.

Definition at line 72 of file vtkImageViewer2.h.

int vtkImageViewer2::GetZSlice ( ) [inline]

Set/Get the current Z Slice to display

Definition at line 77 of file vtkImageViewer2.h.

void vtkImageViewer2::SetZSlice ( int s ) [inline]

Set/Get the current Z Slice to display

Definition at line 78 of file vtkImageViewer2.h.

float vtkImageViewer2::GetColorWindow ( ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 83 of file vtkImageViewer2.h.

float vtkImageViewer2::GetColorLevel ( ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 84 of file vtkImageViewer2.h.

void vtkImageViewer2::SetColorWindow ( float s ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 85 of file vtkImageViewer2.h.

void vtkImageViewer2::SetColorLevel ( float s ) [inline]

Sets window/level for mapping pixels to colors.

Definition at line 86 of file vtkImageViewer2.h.

void vtkImageViewer2::SetDisplayId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 91 of file vtkImageViewer2.h.

void vtkImageViewer2::SetWindowId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 92 of file vtkImageViewer2.h.

void vtkImageViewer2::SetParentId ( void * a ) [inline]

These are here for using a tk window.

Definition at line 93 of file vtkImageViewer2.h.

int* vtkImageViewer2::GetPosition ( ) [inline]

Set/Get the position in screen coordinates of the rendering window.

Definition at line 98 of file vtkImageViewer2.h.

void vtkImageViewer2::SetPosition | ( | int | a,
 |  | int | b
 | ) | [inline]

Set/Get the position in screen coordinates of the rendering window.

Definition at line 99 of file vtkImageViewer2.h.

virtual void vtkImageViewer2::SetPosition ( int a[2] ) [virtual]

Set/Get the position in screen coordinates of the rendering window.

int* vtkImageViewer2::GetSize ( ) [inline]

Set/Get the size of the window in screen coordinates.

Definition at line 105 of file vtkImageViewer2.h.

void vtkImageViewer2::SetSize | ( | int | a,
 |  | int | b
 | ) | [inline]

Set/Get the size of the window in screen coordinates.

Definition at line 106 of file vtkImageViewer2.h.

virtual void vtkImageViewer2::SetSize ( int a[2] ) [virtual]

Set/Get the size of the window in screen coordinates.

virtual vtkRenderWindow* vtkImageViewer2::GetRenderWindow ( ) [virtual]

Get the internal Window Imager and Mapper

virtual vtkRenderer* vtkImageViewer2::GetRenderer ( ) [virtual]

Get the internal Window Imager and Mapper

virtual vtkImageActor* vtkImageViewer2::GetImageActor ( ) [virtual]

Get the internal Window Imager and Mapper

virtual vtkImageMapToWindowLevelColors* vtkImageViewer2::GetWindowLevel ( ) [virtual]

Get the internal Window Imager and Mapper

void vtkImageViewer2::SetupInteractor ( vtkRenderWindowInteractor * )

Create and attach an interactor for this window

Member Data Documentation

vtkImageMapToWindowLevelColors* vtkImageViewer2::WindowLevel [protected]

Definition at line 125 of file vtkImageViewer2.h.

vtkRenderWindow* vtkImageViewer2::RenderWindow [protected]

Definition at line 126 of file vtkImageViewer2.h.

vtkRenderer* vtkImageViewer2::Renderer [protected]

Definition at line 127 of file vtkImageViewer2.h.

vtkImageActor* vtkImageViewer2::ImageActor [protected]

Definition at line 128 of file vtkImageViewer2.h.

int vtkImageViewer2::FirstRender [protected]

Definition at line 129 of file vtkImageViewer2.h.

vtkRenderWindowInteractor* vtkImageViewer2::Interactor [protected]

Definition at line 130 of file vtkImageViewer2.h.

vtkInteractorStyleImage* vtkImageViewer2::InteractorStyle [protected]

Definition at line 131 of file vtkImageViewer2.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImageViewer2.h
Generated on Mon Mar 25 01:20:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWindow Class Reference

a 2D display window. More...

#include <vtkImageWindow.h>

Inheritance diagram for vtkImageWindow:

[legend]
Collaboration diagram for vtkImageWindow:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkImageWindow, vtkWindow)
virtual void | SwapBuffers ()=0
virtual void | Frame ()=0
void | AddImager (vtkImager *im)
vtkImagerCollection * GetImagers ()
void | RemoveImager (vtkImager *im)
virtual void | Render ()
virtual void | EraseWindow ()
virtual void | SaveImageAsPPM ()
virtual void | MakeCurrent ()
virtual void | SetPosition (int x, int y)=0
virtual void | SetPosition (int a[2])
virtual int * | GetPosition ()=0
virtual void | GetPosition (int *x, int *y)
virtual void | SetSize (int, int)=0
virtual void | SetSize (int a[2])
virtual int * | GetSize ()=0
virtual void | GetSize (int *x, int *y)
virtual void | SetDisplayId (void *)=0
virtual void | SetWindowId (void *)=0
virtual void | SetParentId (void *)=0
virtual void * | GetGenericDisplayId ()=0
virtual void * | GetGenericWindowId ()=0
virtual void * | GetGenericParentId ()=0
virtual void * | GetGenericContext ()=0
virtual void * | GetGenericDrawable ()
virtual void | SetWindowInfo (char *)
virtual void | SetParentInfo (char *)
virtual void | SetGrayScaleHint (int)
virtual int | GetGrayScaleHint ()
virtual void | GrayScaleHintOn ()
virtual void | GrayScaleHintOff ()
virtual int | OpenPPMImageFile ()
virtual void | WritePPMImageFile ()
virtual void | ClosePPMImageFile ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkImageWindow * | New ()

Protected Methods

vtkImageWindow ()
~vtkImageWindow ()
virtual void | MakeDefaultWindow ()=0

Protected Attributes

vtkImagerCollection * Imagers
int | WindowCreated
int | GrayScaleHint
char * | FileName
FILE * | PPMImageFilePtr

Detailed Description

a 2D display window.

Date:
2002/01/22 15:38:34
Revision:
1.30

vtkImageWindow contains 2D rendering in vtk. Typically a vtkImageWindow has some vtkImagers within it. The imagers in turn display images, Text etc. The concept is very similar to that of a RenderWindow for 3d.

See also:
vtkImager vtkWindow vtkRenderWindow
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (80%)
  • Avila, Lisa (6%)
  • Law, Charles (5%)

Definition at line 49 of file vtkImageWindow.h.

Constructor & Destructor Documentation

vtkImageWindow::vtkImageWindow ( ) [protected]

vtkImageWindow::~vtkImageWindow ( ) [protected]

Member Function Documentation

vtkImageWindow* vtkImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkObject.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

void vtkImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

vtkImageWindow::vtkTypeRevisionMacro | ( | vtkImageWindow | ,
 |  | vtkWindow |
 | ) |

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [pure virtual]

Set the position of the window on the screen

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkXImageWindow::SetPosition(), and vtkWin32OpenGLImageWindow::SetPosition().

virtual void vtkImageWindow::SetPosition ( int a[2] ) [inline, virtual]

Set the position of the window on the screen

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Definition at line 62 of file vtkImageWindow.h.

virtual int* vtkImageWindow::GetPosition ( ) [pure virtual]

Get the position of the window on the screen

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkXImageWindow::GetPosition(), and vtkWin32OpenGLImageWindow::GetPosition().

virtual void vtkImageWindow::GetPosition | ( | int * | x,
 |  | int * | y
 | ) | [virtual]

Get the position of the window on the screen

Reimplemented in vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [pure virtual]

Sets the size of a window in pixels.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkXImageWindow::SetSize(), and vtkWin32OpenGLImageWindow::SetSize().

virtual void vtkImageWindow::SetSize ( int a[2] ) [inline, virtual]

Sets the size of a window in pixels.

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Definition at line 74 of file vtkImageWindow.h.

virtual int* vtkImageWindow::GetSize ( ) [pure virtual]

Returns the size of a window in pixels

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkXImageWindow::GetSize(), and vtkWin32OpenGLImageWindow::GetSize().

virtual void vtkImageWindow::GetSize | ( | int * | x,
 |  | int * | y
 | ) | [virtual]

Returns the size of a window in pixels

Reimplemented in vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::SetDisplayId ( void * foo ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::SetWindowId ( void * foo ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkWin32OpenGLImageWindow::SetWindowId().

virtual void vtkImageWindow::SetParentId ( void * foo ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Referenced by vtkWin32OpenGLImageWindow::SetParentId().

virtual void* vtkImageWindow::GetGenericDisplayId ( ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void* vtkImageWindow::GetGenericWindowId ( ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void* vtkImageWindow::GetGenericParentId ( ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void* vtkImageWindow::GetGenericContext ( ) [pure virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void* vtkImageWindow::GetGenericDrawable ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, and vtkXImageWindow.

Definition at line 92 of file vtkImageWindow.h.

virtual void vtkImageWindow::SwapBuffers ( ) [pure virtual]

Swap the front and back buffers. This function is used to implement double buffering. The user shouldn't need to call this function. To enable double buffering, invoke DoubleBufferOn

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::Frame ( ) [pure virtual]

Flush the buffer and swap if necessary.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

virtual void vtkImageWindow::SetWindowInfo ( char * info ) [inline, virtual]

useful for scripting languages

Reimplemented from vtkWindow.

Reimplemented in vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Definition at line 105 of file vtkImageWindow.h.

virtual void vtkImageWindow::SetParentInfo ( char * info ) [inline, virtual]

useful for scripting languages

Reimplemented from vtkWindow.

Reimplemented in vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Definition at line 107 of file vtkImageWindow.h.

virtual void vtkImageWindow::SetGrayScaleHint ( int ) [virtual]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

virtual int vtkImageWindow::GetGrayScaleHint ( ) [virtual]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

virtual void vtkImageWindow::GrayScaleHintOn ( ) [virtual]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

virtual void vtkImageWindow::GrayScaleHintOff ( ) [virtual]

By default this is a color viewer. GrayScaleHintOn will improve the appearance of gray scale images on some systems.

void vtkImageWindow::AddImager ( vtkImager * im )

Add an imager to the window's list of imagers to be rendered.

vtkImagerCollection* vtkImageWindow::GetImagers ( ) [inline]

Return the collection of imagers for this window.

Definition at line 123 of file vtkImageWindow.h.

void vtkImageWindow::RemoveImager ( vtkImager * im )

Remove an imager from the window

virtual void vtkImageWindow::Render ( void ) [virtual]

Draw the contents of the window

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, and vtkWin32OpenGLImageWindow.

virtual void vtkImageWindow::EraseWindow ( ) [virtual]

Erase the window contents

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkWin32ImageWindow, and vtkXImageWindow.

Referenced by vtkOpenGLImageWindow::EraseWindow(), and vtkMesaImageWindow::EraseWindow().

virtual void vtkImageWindow::SaveImageAsPPM ( ) [virtual]

Save the current image as a PPM file.

virtual int vtkImageWindow::OpenPPMImageFile ( ) [virtual]

Open/Write/Close a PPM file

virtual void vtkImageWindow::WritePPMImageFile ( ) [virtual]

Open/Write/Close a PPM file

virtual void vtkImageWindow::ClosePPMImageFile ( ) [virtual]

Open/Write/Close a PPM file

virtual void vtkImageWindow::SetFileName ( const char * ) [virtual]

Set/Get the FileName used for saving images. See the SaveImageAsPPM method.

virtual char* vtkImageWindow::GetFileName ( ) [virtual]

Set/Get the FileName used for saving images. See the SaveImageAsPPM method.

virtual void vtkImageWindow::MakeCurrent ( ) [inline, virtual]

Make this window current. Overridden in subclasses to do, for example, glXMakeCurrent or wglMakeCurrent

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, and vtkWin32OpenGLImageWindow.

Definition at line 153 of file vtkImageWindow.h.

virtual void vtkImageWindow::MakeDefaultWindow ( ) [protected, pure virtual]

Reimplemented in vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Member Data Documentation

vtkImagerCollection* vtkImageWindow::Imagers [protected]

Definition at line 159 of file vtkImageWindow.h.

int vtkImageWindow::WindowCreated [protected]

Definition at line 160 of file vtkImageWindow.h.

int vtkImageWindow::GrayScaleHint [protected]

Definition at line 161 of file vtkImageWindow.h.

char* vtkImageWindow::FileName [protected]

Definition at line 163 of file vtkImageWindow.h.

FILE* vtkImageWindow::PPMImageFilePtr [protected]

Definition at line 164 of file vtkImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImageWindow.h
Generated on Mon Mar 25 01:20:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWrapPad Class Reference

Makes an image larger by wrapping existing data. More...

#include <vtkImageWrapPad.h>

Inheritance diagram for vtkImageWrapPad:

[legend]
Collaboration diagram for vtkImageWrapPad:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageWrapPad, vtkImagePadFilter)

Static Public Methods

vtkImageWrapPad * | New ()

Protected Methods

vtkImageWrapPad ()
~vtkImageWrapPad ()
void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
void | ThreadedExecute (vtkImageData *inData, vtkImageData *outRegion, int ext[6], int id)

Detailed Description

Makes an image larger by wrapping existing data.

Date:
2002/01/22 15:33:41
Revision:
1.24

vtkImageWrapPad performs a modulo operation on the output pixel index to determine the source input index. The new image extent of the output has to be specified. Input has to be the same scalar type as output.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (62%)
  • Martin, Ken (30%)
Tests:
vtkImageWrapPad (Tests)

Definition at line 44 of file vtkImageWrapPad.h.

Constructor & Destructor Documentation

vtkImageWrapPad::vtkImageWrapPad ( ) [inline, protected]

Definition at line 51 of file vtkImageWrapPad.h.

vtkImageWrapPad::~vtkImageWrapPad ( ) [inline, protected]

Definition at line 52 of file vtkImageWrapPad.h.

Member Function Documentation

vtkImageWrapPad* vtkImageWrapPad::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImagePadFilter.

vtkImageWrapPad::vtkTypeRevisionMacro | ( | vtkImageWrapPad | ,
 |  | vtkImagePadFilter |
 | ) |

Reimplemented from vtkImagePadFilter.

void vtkImageWrapPad::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

Reimplemented from vtkImagePadFilter.

void vtkImageWrapPad::ThreadedExecute | ( | vtkImageData * | inData,
 |  | vtkImageData * | outRegion,
 |  | int | ext[6],
 |  | int | id
 | ) | [protected, virtual]

If the subclass does not define an Execute method, then the task will be broken up, multiple threads will be spawned, and each thread will call this method. It is public so that the thread functions can call this method.

Reimplemented from vtkImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkImageWrapPad.h
Generated on Mon Mar 25 01:20:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImageWriter Class Reference

Writes images to files. More...

#include <vtkImageWriter.h>

Inheritance diagram for vtkImageWriter:

[legend]
Collaboration diagram for vtkImageWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImageWriter, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Write ()
void | SetFileName (const char *)
virtual char * | GetFileName ()
void | SetFilePrefix (char *filePrefix)
virtual char * | GetFilePrefix ()
void | SetFilePattern (const char *filePattern)
virtual char * | GetFilePattern ()
virtual void | SetFileDimensionality (int)
virtual int | GetFileDimensionality ()
virtual void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Static Public Methods

vtkImageWriter * | New ()

Protected Methods

vtkImageWriter ()
~vtkImageWriter ()
virtual void | RecursiveWrite (int dim, vtkImageData *region, ofstream *file)
virtual void | RecursiveWrite (int dim, vtkImageData *cache, vtkImageData *data, ofstream *file)
virtual void | WriteFile (ofstream *file, vtkImageData *data, int extent[6])
virtual void | WriteFileHeader (ofstream *, vtkImageData *)
virtual void | WriteFileTrailer (ofstream *, vtkImageData *)

Protected Attributes

int | FileDimensionality
char * | FilePrefix
char * | FilePattern
char * | FileName
int | FileNumber
int | FileLowerLeft
char * | InternalFileName

Detailed Description

Writes images to files.

Date:
2002/01/22 15:38:15
Revision:
1.31

vtkImageWriter writes images to files with any data type. The data type of the file is the same scalar type as the input. The dimensionality determines whether the data will be written in one or multiple files. This class is used as the superclass of most image writing classes such as vtkBMPWriter etc. It supports streaming.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Martin, Ken (50%)
  • Law, Charles (33%)
  • Lorensen, Bill (5%)

Definition at line 43 of file vtkImageWriter.h.

Constructor & Destructor Documentation

vtkImageWriter::vtkImageWriter ( ) [protected]

vtkImageWriter::~vtkImageWriter ( ) [protected]

Member Function Documentation

vtkImageWriter* vtkImageWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkBMPWriter, vtkJPEGWriter, vtkPNGWriter, vtkPNMWriter, vtkPostScriptWriter, vtkTIFFWriter, and vtkPImageWriter.

vtkImageWriter::vtkTypeRevisionMacro | ( | vtkImageWriter | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

Reimplemented in vtkBMPWriter, vtkJPEGWriter, vtkPNGWriter, vtkPNMWriter, vtkPostScriptWriter, vtkTIFFWriter, and vtkPImageWriter.

void vtkImageWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

Reimplemented in vtkJPEGWriter, and vtkPImageWriter.

void vtkImageWriter::SetFileName ( const char * )

Specify file name for the image file. You should specify either a FileName or a FilePrefix. Use FilePrefix if the data is stored in multiple files.

virtual char* vtkImageWriter::GetFileName ( ) [virtual]

Specify file name for the image file. You should specify either a FileName or a FilePrefix. Use FilePrefix if the data is stored in multiple files.

void vtkImageWriter::SetFilePrefix ( char * filePrefix )

Specify file prefix for the image file(s).You should specify either a FileName or FilePrefix. Use FilePrefix if the data is stored in multiple files.

virtual char* vtkImageWriter::GetFilePrefix ( ) [virtual]

Specify file prefix for the image file(s).You should specify either a FileName or FilePrefix. Use FilePrefix if the data is stored in multiple files.

void vtkImageWriter::SetFilePattern ( const char * filePattern )

The sprintf format used to build filename from FilePrefix and number.

virtual char* vtkImageWriter::GetFilePattern ( ) [virtual]

The sprintf format used to build filename from FilePrefix and number.

virtual void vtkImageWriter::SetFileDimensionality ( int ) [virtual]

What dimension are the files to be written. Usually this is 2, or 3. If it is 2 and the input is a volume then the volume will be written as a series of 2d slices.

virtual int vtkImageWriter::GetFileDimensionality ( ) [virtual]

What dimension are the files to be written. Usually this is 2, or 3. If it is 2 and the input is a volume then the volume will be written as a series of 2d slices.

virtual void vtkImageWriter::SetInput ( vtkImageData * input ) [virtual]

Set/Get the input object from the image pipeline.

vtkImageData* vtkImageWriter::GetInput ( )

Set/Get the input object from the image pipeline.

virtual void vtkImageWriter::Write ( ) [virtual]

The main interface which triggers the writer to start.

Reimplemented in vtkJPEGWriter, and vtkPNGWriter.

virtual void vtkImageWriter::RecursiveWrite | ( | int | dim,
 |  | vtkImageData * | region,
 |  | ofstream * | file
 | ) | [protected, virtual]

Reimplemented in vtkPImageWriter.

Referenced by vtkPImageWriter::RecursiveWrite().

virtual void vtkImageWriter::RecursiveWrite | ( | int | dim,
 |  | vtkImageData * | cache,
 |  | vtkImageData * | data,
 |  | ofstream * | file
 | ) | [protected, virtual]

Reimplemented in vtkPImageWriter.

virtual void vtkImageWriter::WriteFile | ( | ofstream * | file,
 |  | vtkImageData * | data,
 |  | int | ext[6]
 | ) | [protected, virtual]

Reimplemented in vtkBMPWriter, vtkPNMWriter, vtkPostScriptWriter, and vtkTIFFWriter.

virtual void vtkImageWriter::WriteFileHeader | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [inline, protected, virtual]

Reimplemented in vtkBMPWriter, vtkPNMWriter, vtkPostScriptWriter, and vtkTIFFWriter.

Definition at line 105 of file vtkImageWriter.h.

virtual void vtkImageWriter::WriteFileTrailer | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [inline, protected, virtual]

Reimplemented in vtkPostScriptWriter.

Definition at line 106 of file vtkImageWriter.h.

Member Data Documentation

int vtkImageWriter::FileDimensionality [protected]

Definition at line 93 of file vtkImageWriter.h.

char* vtkImageWriter::FilePrefix [protected]

Definition at line 94 of file vtkImageWriter.h.

char* vtkImageWriter::FilePattern [protected]

Definition at line 95 of file vtkImageWriter.h.

char* vtkImageWriter::FileName [protected]

Definition at line 96 of file vtkImageWriter.h.

int vtkImageWriter::FileNumber [protected]

Definition at line 97 of file vtkImageWriter.h.

int vtkImageWriter::FileLowerLeft [protected]

Definition at line 98 of file vtkImageWriter.h.

char* vtkImageWriter::InternalFileName [protected]

Definition at line 99 of file vtkImageWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkImageWriter.h
Generated on Mon Mar 25 01:20:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImagingFactory Class Reference

#include <vtkImagingFactory.h>

Inheritance diagram for vtkImagingFactory:

[legend]
Collaboration diagram for vtkImagingFactory:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImagingFactory, vtkObject)

Static Public Methods

vtkImagingFactory * | New ()
vtkObject * | CreateInstance (const char *vtkclassname)

Protected Methods

vtkImagingFactory ()

Detailed Description

Date:
2002/01/22 15:38:35
Revision:
1.10
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (76%)
  • Starreveld, Yves (12%)
  • Lorensen, Bill (5%)

Definition at line 36 of file vtkImagingFactory.h.

Constructor & Destructor Documentation

vtkImagingFactory::vtkImagingFactory ( ) [inline, protected]

Definition at line 47 of file vtkImagingFactory.h.

Member Function Documentation

vtkImagingFactory* vtkImagingFactory::New ( ) [inline, static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Definition at line 39 of file vtkImagingFactory.h.

vtkImagingFactory::vtkTypeRevisionMacro | ( | vtkImagingFactory | ,
 |  | vtkObject |
 | ) |

vtkObject* vtkImagingFactory::CreateInstance ( const char * vtkclassname ) [static]

Create and return an instance of the named vtk object. This method first checks the vtkObjectFactory to support dynamic loading.

The documentation for this class was generated from the following file:
  • Rendering/vtkImagingFactory.h
Generated on Mon Mar 25 01:20:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitBoolean Class Reference

implicit function consisting of boolean combinations of implicit functions. More...

#include <vtkImplicitBoolean.h>

Inheritance diagram for vtkImplicitBoolean:

[legend]
Collaboration diagram for vtkImplicitBoolean:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitBoolean, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
unsigned long | GetMTime ()
void | AddFunction (vtkImplicitFunction *in)
void | RemoveFunction (vtkImplicitFunction *in)
vtkImplicitFunctionCollection * GetFunction ()
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetOperationType (int)
virtual int | GetOperationType ()
void | SetOperationTypeToUnion ()
void | SetOperationTypeToIntersection ()
void | SetOperationTypeToDifference ()
void | SetOperationTypeToUnionOfMagnitudes ()
const char * | GetOperationTypeAsString ()

Static Public Methods

vtkImplicitBoolean * | New ()

Protected Methods

vtkImplicitBoolean ()
~vtkImplicitBoolean ()

Protected Attributes

vtkImplicitFunctionCollection * FunctionList
int | OperationType

Detailed Description

implicit function consisting of boolean combinations of implicit functions.

Date:
2002/01/22 15:28:07
Revision:
1.44

vtkImplicitBoolean is an implicit function consisting of boolean combinations of implicit functions. The class has a list of functions (FunctionList) that are combined according to a specified operator (VTK_UNION or VTK_INTERSECTION or VTK_DIFFERENCE). You can use nested combinations of vtkImplicitFunction's (and/or vtkImplicitBoolean) to create elaborate implicit functions. vtkImplicitBoolean is a concrete implementation of vtkImplicitFunction.

The operators work as follows. The VTK_UNION operator takes the minimum value of all implicit functions. The VTK_INTERSECTION operator takes the maximum value of all implicit functions. The VTK_DIFFERENCE operator subtracts the 2nd through last implicit functions from the first. The VTK_UNION_OF_MAGNITUDES takes the minimum absolute value of the implicit functions.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Martin, Ken (17%)
  • Lorensen, Bill (8%)
Examples:
vtkImplicitBoolean (Examples)
Tests:
vtkImplicitBoolean (Tests)

Definition at line 63 of file vtkImplicitBoolean.h.

Constructor & Destructor Documentation

vtkImplicitBoolean::vtkImplicitBoolean ( ) [protected]

vtkImplicitBoolean::~vtkImplicitBoolean ( ) [protected]

Member Function Documentation

vtkImplicitBoolean::vtkTypeRevisionMacro | ( | vtkImplicitBoolean | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitBoolean::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkImplicitBoolean* vtkImplicitBoolean::New ( ) [static]

Default boolean method is union.

Reimplemented from vtkObject.

float vtkImplicitBoolean::EvaluateFunction ( float x[3] ) [virtual]

Evaluate boolean combinations of implicit function using current operator.

Reimplemented from vtkImplicitFunction.

float vtkImplicitBoolean::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate boolean combinations of implicit function using current operator.

Reimplemented from vtkImplicitFunction.

Definition at line 76 of file vtkImplicitBoolean.h.

void vtkImplicitBoolean::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate gradient of boolean combination.

Reimplemented from vtkImplicitFunction.

unsigned long vtkImplicitBoolean::GetMTime ( ) [virtual]

Override modified time retrieval because of object dependencies.

Reimplemented from vtkImplicitFunction.

void vtkImplicitBoolean::AddFunction ( vtkImplicitFunction * in )

Add another implicit function to the list of functions.

void vtkImplicitBoolean::RemoveFunction ( vtkImplicitFunction * in )

Remove a function from the list of implicit functions to boolean.

vtkImplicitFunctionCollection* vtkImplicitBoolean::GetFunction ( ) [inline]

Return the collection of implicit functions.

Definition at line 93 of file vtkImplicitBoolean.h.

virtual void vtkImplicitBoolean::SetOperationType ( int ) [virtual]

Specify the type of boolean operation.

virtual int vtkImplicitBoolean::GetOperationType ( ) [virtual]

Specify the type of boolean operation.

void vtkImplicitBoolean::SetOperationTypeToUnion ( ) [inline]

Specify the type of boolean operation.

Definition at line 99 of file vtkImplicitBoolean.h.

void vtkImplicitBoolean::SetOperationTypeToIntersection ( ) [inline]

Specify the type of boolean operation.

Definition at line 101 of file vtkImplicitBoolean.h.

void vtkImplicitBoolean::SetOperationTypeToDifference ( ) [inline]

Specify the type of boolean operation.

Definition at line 103 of file vtkImplicitBoolean.h.

void vtkImplicitBoolean::SetOperationTypeToUnionOfMagnitudes ( ) [inline]

Specify the type of boolean operation.

Definition at line 105 of file vtkImplicitBoolean.h.

const char * vtkImplicitBoolean::GetOperationTypeAsString ( void ) [inline]

Return the boolean operation type as a descriptive character string.

Definition at line 124 of file vtkImplicitBoolean.h.

Member Data Documentation

vtkImplicitFunctionCollection* vtkImplicitBoolean::FunctionList [protected]

Definition at line 114 of file vtkImplicitBoolean.h.

int vtkImplicitBoolean::OperationType [protected]

Definition at line 116 of file vtkImplicitBoolean.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitBoolean.h
Generated on Mon Mar 25 01:20:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitDataSet Class Reference

treat a dataset as if it were an implicit function. More...

#include <vtkImplicitDataSet.h>

Inheritance diagram for vtkImplicitDataSet:

[legend]
Collaboration diagram for vtkImplicitDataSet:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitDataSet, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | EvaluateGradient (float x[3], float n[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetDataSet (vtkDataSet *)
virtual vtkDataSet * | GetDataSet ()
virtual void | SetOutValue (float)
virtual float | GetOutValue ()
virtual void | SetOutGradient (float, float, float)
virtual void | SetOutGradient (float[3])
virtual float * | GetOutGradient ()
virtual void | GetOutGradient (float &, float &, float &)
virtual void | GetOutGradient (float[3])

Static Public Methods

vtkImplicitDataSet * | New ()

Protected Methods

vtkImplicitDataSet ()
~vtkImplicitDataSet ()

Protected Attributes

vtkDataSet * DataSet
float | OutValue
float | OutGradient [3]
float * | Weights
int | Size

Detailed Description

treat a dataset as if it were an implicit function.

Date:
2002/01/22 15:28:07
Revision:
1.25

vtkImplicitDataSet treats any type of dataset as if it were an implicit function. This means it computes a function value and gradient. vtkImplicitDataSet is a concrete implementation of vtkImplicitFunction.

vtkImplicitDataSet computes the function (at the point x) by performing cell interpolation. That is, it finds the cell containing x, and then uses the cell's interpolation functions to compute an interpolated scalar value at x. (A similar approach is used to find the gradient, if requested.) Points outside of the dataset are assigned the value of the ivar OutValue, and the gradient value OutGradient.

Warning:
Any type of dataset can be used as an implicit function as long as it has scalar data associated with it.
See also:
vtkImplicitFunction vtkImplicitVolume vtkClipPolyData vtkCutter vtkImplicitWindowFunction
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Lorensen, Bill (7%)
  • Martin, Ken (5%)
  • Kelly, Ann (5%)
Tests:
vtkImplicitDataSet (Tests)

Definition at line 61 of file vtkImplicitDataSet.h.

Constructor & Destructor Documentation

vtkImplicitDataSet::vtkImplicitDataSet ( ) [protected]

vtkImplicitDataSet::~vtkImplicitDataSet ( ) [protected]

Member Function Documentation

vtkImplicitDataSet::vtkTypeRevisionMacro | ( | vtkImplicitDataSet | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitDataSet::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkImplicitDataSet* vtkImplicitDataSet::New ( ) [static]

Construct an vtkImplicitDataSet with no initial dataset; the OutValue set to a large negative number; and the OutGradient set to (0,0,1).

Reimplemented from vtkObject.

unsigned long vtkImplicitDataSet::GetMTime ( ) [virtual]

Return the MTime also considering the DataSet dependency.

Reimplemented from vtkImplicitFunction.

float vtkImplicitDataSet::EvaluateFunction ( float x[3] ) [virtual]

Evaluate the implicit function. This returns the interpolated scalar value at x[3].

Reimplemented from vtkImplicitFunction.

float vtkImplicitDataSet::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate the implicit function. This returns the interpolated scalar value at x[3].

Reimplemented from vtkImplicitFunction.

Definition at line 78 of file vtkImplicitDataSet.h.

void vtkImplicitDataSet::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate implicit function gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkImplicitDataSet::SetDataSet ( vtkDataSet * ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual vtkDataSet* vtkImplicitDataSet::GetDataSet ( ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual void vtkImplicitDataSet::SetOutValue ( float ) [virtual]

Set / get the function value to use for points outside of the dataset.

virtual float vtkImplicitDataSet::GetOutValue ( ) [virtual]

Set / get the function value to use for points outside of the dataset.

virtual void vtkImplicitDataSet::SetOutGradient | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the function gradient to use for points outside of the dataset.

virtual void vtkImplicitDataSet::SetOutGradient ( float [3] ) [virtual]

Set / get the function gradient to use for points outside of the dataset.

virtual float* vtkImplicitDataSet::GetOutGradient ( ) [virtual]

Set / get the function gradient to use for points outside of the dataset.

virtual void vtkImplicitDataSet::GetOutGradient | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set / get the function gradient to use for points outside of the dataset.

virtual void vtkImplicitDataSet::GetOutGradient ( float [3] ) [virtual]

Set / get the function gradient to use for points outside of the dataset.

Member Data Documentation

vtkDataSet* vtkImplicitDataSet::DataSet [protected]

Definition at line 109 of file vtkImplicitDataSet.h.

float vtkImplicitDataSet::OutValue [protected]

Definition at line 110 of file vtkImplicitDataSet.h.

float vtkImplicitDataSet::OutGradient[3] [protected]

Definition at line 111 of file vtkImplicitDataSet.h.

float* vtkImplicitDataSet::Weights [protected]

Definition at line 113 of file vtkImplicitDataSet.h.

int vtkImplicitDataSet::Size [protected]

Definition at line 114 of file vtkImplicitDataSet.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitDataSet.h
Generated on Mon Mar 25 01:20:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunction Class Reference

abstract interface for implicit functions. More...

#include <vtkImplicitFunction.h>

Inheritance diagram for vtkImplicitFunction:

[legend]
Collaboration diagram for vtkImplicitFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitFunction, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | EvaluateGradient (float x[3], float g[3])=0
float | FunctionValue (const float x[3])
float | FunctionValue (float x, float y, float z)
void | FunctionGradient (const float x[3], float g[3])
float * | FunctionGradient (const float x[3])
float * | FunctionGradient (float x, float y, float z)
virtual void | SetTransform (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetTransform ()
virtual float | EvaluateFunction (float x[3])=0
float | EvaluateFunction (float x, float y, float z)

Protected Methods

vtkImplicitFunction ()
~vtkImplicitFunction ()

Protected Attributes

vtkAbstractTransform * Transform
float | ReturnValue [3]

Detailed Description

abstract interface for implicit functions.

Date:
2002/01/22 15:25:29
Revision:
1.49

vtkImplicitFunction specifies an abstract interface for implicit functions. Implicit functions are real valued functions defined in 3D space, w = F(x,y,z). Two primitive operations are required: the ability to evaluate the function, and the function gradient at a given point.

Implicit functions are very powerful. It is possible to represent almost any type of geometry with the level sets w = const, especially if you use boolean combinations of implicit functions (see vtkImplicitBoolean).

vtkImplicitFunction provides a mechanism to transform the implicit function(s) via a vtkAbstractTransform. This capability can be used to translate, orient, scale, or warp implicit functions. For example, a sphere implicit function can be transformed into an oriented ellipse.

Warning:
The transformation transforms a point into the space of the implicit function (i.e., the model space). Typically we want to transform the implicit model into world coordinates. In this case the inverse of the transformation is required.
See also:
vtkAbstractTransform vtkSphere vtkCylinder vtkImplicitBoolean vtkPlane vtkPlanes vtkQuadric vtkImplicitVolume vtkSampleFunction vtkCutter vtkClipPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Gobbi, David (35%)
  • Schroeder, Will (34%)
  • Lorensen, Bill (13%)
  • Martin, Ken (6%)

Definition at line 64 of file vtkImplicitFunction.h.

Constructor & Destructor Documentation

vtkImplicitFunction::vtkImplicitFunction ( ) [protected]

vtkImplicitFunction::~vtkImplicitFunction ( ) [protected]

Member Function Documentation

vtkImplicitFunction::vtkTypeRevisionMacro | ( | vtkImplicitFunction | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkPlane, vtkPlanes, vtkQuadric, vtkCone, vtkCylinder, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPerlinNoise, vtkSphere, and vtkSuperquadric.

void vtkImplicitFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkPlane, vtkPlanes, vtkQuadric, vtkCone, vtkCylinder, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPerlinNoise, vtkSphere, and vtkSuperquadric.

unsigned long vtkImplicitFunction::GetMTime ( ) [virtual]

Overload standard modified time function. If Transform is modified, then this object is modified as well.

Reimplemented from vtkObject.

Reimplemented in vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, and vtkImplicitWindowFunction.

float vtkImplicitFunction::FunctionValue ( const float x[3] )

Evaluate function at position x-y-z and return value. Point x[3] is transformed through transform (if provided).

float vtkImplicitFunction::FunctionValue | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate function at position x-y-z and return value. Point x[3] is transformed through transform (if provided).

Definition at line 78 of file vtkImplicitFunction.h.

void vtkImplicitFunction::FunctionGradient | ( | const float | x[3],
 |  | float | g[3]
 | ) |

Evaluate function gradient at position x-y-z and pass back vector. Point x[3] is transformed through transform (if provided).

float* vtkImplicitFunction::FunctionGradient ( const float x[3] ) [inline]

Evaluate function gradient at position x-y-z and pass back vector. Point x[3] is transformed through transform (if provided).

Definition at line 86 of file vtkImplicitFunction.h.

float* vtkImplicitFunction::FunctionGradient | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate function gradient at position x-y-z and pass back vector. Point x[3] is transformed through transform (if provided).

Definition at line 89 of file vtkImplicitFunction.h.

virtual void vtkImplicitFunction::SetTransform ( vtkAbstractTransform * ) [virtual]

Set/Get a transformation to apply to input points before executing the implicit function.

virtual vtkAbstractTransform* vtkImplicitFunction::GetTransform ( ) [virtual]

Set/Get a transformation to apply to input points before executing the implicit function.

virtual float vtkImplicitFunction::EvaluateFunction ( float x[3] ) [pure virtual]

Evaluate function at position x-y-z and return value. You should generally not call this method directly, you should use FunctionValue() instead. This method must be implemented by any derived class.

Reimplemented in vtkPlane, vtkPlanes, vtkQuadric, vtkCone, vtkCylinder, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPerlinNoise, vtkSphere, and vtkSuperquadric.

Referenced by vtkSuperquadric::EvaluateFunction(), vtkSphere::EvaluateFunction(), vtkPerlinNoise::EvaluateFunction(), vtkImplicitWindowFunction::EvaluateFunction(), vtkImplicitVolume::EvaluateFunction(), vtkImplicitSum::EvaluateFunction(), vtkImplicitSelectionLoop::EvaluateFunction(), vtkImplicitDataSet::EvaluateFunction(), vtkImplicitBoolean::EvaluateFunction(), vtkCylinder::EvaluateFunction(), vtkCone::EvaluateFunction(), vtkQuadric::EvaluateFunction(), vtkPlanes::EvaluateFunction(), and vtkPlane::EvaluateFunction().

float vtkImplicitFunction::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate function at position x-y-z and return value. You should generally not call this method directly, you should use FunctionValue() instead. This method must be implemented by any derived class.

Reimplemented in vtkPlane, vtkPlanes, vtkQuadric, vtkCone, vtkCylinder, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPerlinNoise, vtkSphere, and vtkSuperquadric.

Definition at line 106 of file vtkImplicitFunction.h.

virtual void vtkImplicitFunction::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [pure virtual]

Evaluate function gradient at position x-y-z and pass back vector. You should generally not call this method directly, you should use FunctionGradient() instead. This method must be implemented by any derived class.

Reimplemented in vtkPlane, vtkPlanes, vtkQuadric, vtkCone, vtkCylinder, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPerlinNoise, vtkSphere, and vtkSuperquadric.

Member Data Documentation

vtkAbstractTransform* vtkImplicitFunction::Transform [protected]

Definition at line 120 of file vtkImplicitFunction.h.

float vtkImplicitFunction::ReturnValue[3] [protected]

Definition at line 121 of file vtkImplicitFunction.h.

The documentation for this class was generated from the following file:
  • Common/vtkImplicitFunction.h
Generated on Mon Mar 25 01:20:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunctionCollection Class Reference

maintain a list of implicit functions. More...

#include <vtkImplicitFunctionCollection.h>

Inheritance diagram for vtkImplicitFunctionCollection:

[legend]
Collaboration diagram for vtkImplicitFunctionCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitFunctionCollection, vtkCollection)
void | AddItem (vtkImplicitFunction *)
vtkImplicitFunction * GetNextItem ()

Static Public Methods

vtkImplicitFunctionCollection * | New ()

Protected Methods

vtkImplicitFunctionCollection ()
~vtkImplicitFunctionCollection ()

Detailed Description

maintain a list of implicit functions.

Date:
2002/01/22 15:25:29
Revision:
1.33

vtkImplicitFunctionCollection is an object that creates and manipulates lists of objects of type vtkImplicitFunction.

See also:
vtkCollection vtkPlaneCollection
Created by:
  • Hoffman, Bill
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (38%)
  • Hoffman, Bill (30%)
  • Martin, Ken (25%)

Definition at line 43 of file vtkImplicitFunctionCollection.h.

Constructor & Destructor Documentation

vtkImplicitFunctionCollection::vtkImplicitFunctionCollection ( ) [inline, protected]

Definition at line 56 of file vtkImplicitFunctionCollection.h.

vtkImplicitFunctionCollection::~vtkImplicitFunctionCollection ( ) [inline, protected]

Definition at line 57 of file vtkImplicitFunctionCollection.h.

Member Function Documentation

vtkImplicitFunctionCollection::vtkTypeRevisionMacro | ( | vtkImplicitFunctionCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkImplicitFunctionCollection* vtkImplicitFunctionCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkImplicitFunctionCollection::AddItem ( vtkImplicitFunction * f ) [inline]

Add an implicit function to the list.

Definition at line 69 of file vtkImplicitFunctionCollection.h.

vtkImplicitFunction * vtkImplicitFunctionCollection::GetNextItem ( ) [inline]

Get the next implicit function in the list.

Definition at line 74 of file vtkImplicitFunctionCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkImplicitFunctionCollection.h
Generated on Mon Mar 25 01:20:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitFunctionToImageStencil Class Reference

clip an image with a function. More...

#include <vtkImplicitFunctionToImageStencil.h>

Inheritance diagram for vtkImplicitFunctionToImageStencil:

[legend]
Collaboration diagram for vtkImplicitFunctionToImageStencil:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitFunctionToImageStencil, vtkImageStencilSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInput (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetInput ()
virtual void | SetThreshold (float)
virtual float | GetThreshold ()

Static Public Methods

vtkImplicitFunctionToImageStencil * | New ()

Protected Methods

vtkImplicitFunctionToImageStencil ()
~vtkImplicitFunctionToImageStencil ()
void | operator= (const vtkImplicitFunctionToImageStencil &)
void | ThreadedExecute (vtkImageStencilData *output, int extent[6], int threadId)

Protected Attributes

vtkImplicitFunction * Input
float | Threshold

Detailed Description

clip an image with a function.

Date:
2002/01/22 15:33:42
Revision:
1.8

vtkImplicitFunctionToImageStencil will convert a vtkImplicitFunction into a stencil that can be used with vtkImageStencil or with other classes that apply a stencil to an image.

See also:
vtkImplicitFunction vtkImageStencil vtkPolyDataToImageStencil
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (96%)
Tests:
vtkImplicitFunctionToImageStencil (Tests)

Definition at line 45 of file vtkImplicitFunctionToImageStencil.h.

Constructor & Destructor Documentation

vtkImplicitFunctionToImageStencil::vtkImplicitFunctionToImageStencil ( ) [protected]

vtkImplicitFunctionToImageStencil::~vtkImplicitFunctionToImageStencil ( ) [protected]

Member Function Documentation

vtkImplicitFunctionToImageStencil* vtkImplicitFunctionToImageStencil::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageStencilSource.

vtkImplicitFunctionToImageStencil::vtkTypeRevisionMacro | ( | vtkImplicitFunctionToImageStencil | ,
 |  | vtkImageStencilSource |
 | ) |

Reimplemented from vtkImageStencilSource.

void vtkImplicitFunctionToImageStencil::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageStencilSource.

virtual void vtkImplicitFunctionToImageStencil::SetInput ( vtkImplicitFunction * ) [virtual]

Specify the implicit function to convert into a stencil.

virtual vtkImplicitFunction* vtkImplicitFunctionToImageStencil::GetInput ( ) [virtual]

Specify the implicit function to convert into a stencil.

virtual void vtkImplicitFunctionToImageStencil::SetThreshold ( float ) [virtual]

Set the threshold value for the implicit function.

virtual float vtkImplicitFunctionToImageStencil::GetThreshold ( ) [virtual]

Set the threshold value for the implicit function.

void vtkImplicitFunctionToImageStencil::operator= ( const vtkImplicitFunctionToImageStencil & ) [protected]

void vtkImplicitFunctionToImageStencil::ThreadedExecute | ( | vtkImageStencilData * | output,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [protected, virtual]

Override this method to support clipping with different kinds of objects. Eventually the extent could be split up and handled by multiple threads, but it isn't for now. But please ensure that all code inside this method is thread-safe.

Reimplemented from vtkImageStencilSource.

Member Data Documentation

vtkImplicitFunction* vtkImplicitFunctionToImageStencil::Input [protected]

Definition at line 72 of file vtkImplicitFunctionToImageStencil.h.

float vtkImplicitFunctionToImageStencil::Threshold [protected]

Definition at line 73 of file vtkImplicitFunctionToImageStencil.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkImplicitFunctionToImageStencil.h
Generated on Mon Mar 25 01:20:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitModeller Class Reference

compute distance from input geometry on structured point dataset. More...

#include <vtkImplicitModeller.h>

Inheritance diagram for vtkImplicitModeller:

[legend]
Collaboration diagram for vtkImplicitModeller:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitModeller, vtkDataSetToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
float | ComputeModelBounds (vtkDataSet *input=NULL)
void | StartAppend ()
void | Append (vtkDataSet *input)
void | EndAppend ()
virtual void | UpdateData (vtkDataObject *output)
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
void | SetSampleDimensions (int i, int j, int k)
void | SetSampleDimensions (int dim[3])
virtual void | SetMaximumDistance (float)
virtual float | GetMaximumDistance ()
virtual void | SetModelBounds (float, float, float, float, float, float)
virtual void | SetModelBounds (float[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetAdjustBounds (int)
virtual int | GetAdjustBounds ()
virtual void | AdjustBoundsOn ()
virtual void | AdjustBoundsOff ()
virtual void | SetAdjustDistance (float)
virtual float | GetAdjustDistance ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetCapValue (float)
virtual float | GetCapValue ()
virtual void | SetProcessMode (int)
virtual int | GetProcessMode ()
void | SetProcessModeToPerVoxel ()
void | SetProcessModeToPerCell ()
const char * | GetProcessModeAsString (void)
virtual void | SetLocatorMaxLevel (int)
virtual int | GetLocatorMaxLevel ()
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()

Static Public Methods

vtkImplicitModeller * | New ()

Protected Methods

vtkImplicitModeller ()
~vtkImplicitModeller ()
void | Execute ()
void | ExecuteInformation ()
void | Cap (vtkDataArray *s)

Protected Attributes

vtkMultiThreader * Threader
int | NumberOfThreads
int | SampleDimensions [3]
float | MaximumDistance
float | ModelBounds [6]
int | Capping
float | CapValue
int | DataAppended
int | AdjustBounds
float | AdjustDistance
int | ProcessMode
int | LocatorMaxLevel
int | BoundsComputed
float | InternalMaxDistance

Detailed Description

compute distance from input geometry on structured point dataset.

Date:
2002/01/22 15:30:31
Revision:
1.55

vtkImplicitModeller is a filter that computes the distance from the input geometry to the points of an output structured point set. This distance function can then be "contoured" to generate new, offset surfaces from the original geometry. An important feature of this object is "capping". If capping is turned on, after the implicit model is created, the values on the boundary of the structured points dataset are set to the cap value. This is used to force closure of the resulting contoured surface. Note, however, that large cap values can generate weird surface normals in those cells adjacent to the boundary of the dataset. Using smaller cap value will reduce this effect.

Another important ivar is MaximumDistance. This controls how far into the volume the distance function is computed from the input geometry. Small values give significant increases in performance. However, there can strange sampling effects at the extreme range of the MaximumDistance.

In order to properly execute and sample the input data, a rectangular region in space must be defined (this is the ivar ModelBounds). If not explicitly defined, the model bounds will be computed. Note that to avoid boundary effects, it is possible to adjust the model bounds (i.e., using the AdjustBounds and AdjustDistance ivars) to strictly contain the sampled data.

This filter has one other unusual capability: it is possible to append data in a sequence of operations to generate a single output. This is useful when you have multiple datasets and want to create a conglomeration of all the data. However, the user must be careful to either specify the ModelBounds or specify the first item such that its bounds completely contain all other items. This is because the rectangular region of the output can not be changed after the 1st Append.

The ProcessMode ivar controls the method used within the Append function (where the actual work is done regardless if the Append function is explicitly called) to compute the implicit model. If set to work in voxel mode, each voxel is visited once. If set to cell mode, each cell is visited once. Tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode. Also, if explicitly using the Append feature many times, the cell mode will probably be better because each voxel will be visited each Append. Append the data before input if possible when using the voxel mode.

Further performance improvement is now possible using the PerVoxel process mode on multi-processor machines (the mode is now multithreaded). Each thread processes a different "slab" of the output. Also, if the input is vtkPolyData, it is appropriately clipped for each thread; that is, each thread only considers the input which could affect its slab of the output.

See also:
vtkSampleFunction vtkContourFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (39%)
  • Blue, Rusty (35%)
  • Lorensen, Bill (13%)
Examples:
vtkImplicitModeller (Examples)
Tests:
vtkImplicitModeller (Tests)

Definition at line 100 of file vtkImplicitModeller.h.

Constructor & Destructor Documentation

vtkImplicitModeller::vtkImplicitModeller ( ) [protected]

vtkImplicitModeller::~vtkImplicitModeller ( ) [protected]

Member Function Documentation

vtkImplicitModeller::vtkTypeRevisionMacro | ( | vtkImplicitModeller | ,
 |  | vtkDataSetToStructuredPointsFilter |
 | ) |

Reimplemented from vtkDataSetToStructuredPointsFilter.

void vtkImplicitModeller::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkImplicitModeller* vtkImplicitModeller::New ( ) [static]

Construct with sample dimensions=(50,50,50), and so that model bounds are automatically computed from the input. Capping is turned on with CapValue equal to a large positive number.

Reimplemented from vtkStructuredPointsSource.

float vtkImplicitModeller::ComputeModelBounds ( vtkDataSet * input = NULL )

Compute ModelBounds from input geometry. If input is not specified, the input of the filter will be used.

virtual int* vtkImplicitModeller::GetSampleDimensions ( ) [virtual]

Set/Get the i-j-k dimensions on which to sample distance function.

virtual void vtkImplicitModeller::GetSampleDimensions ( int data[3] ) [virtual]

Set/Get the i-j-k dimensions on which to sample distance function.

void vtkImplicitModeller::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set/Get the i-j-k dimensions on which to sample distance function.

void vtkImplicitModeller::SetSampleDimensions ( int dim[3] )

Set/Get the i-j-k dimensions on which to sample distance function.

virtual void vtkImplicitModeller::SetMaximumDistance ( float ) [virtual]

Set / get the distance away from surface of input geometry to sample. Smaller values make large increases in performance.

virtual float vtkImplicitModeller::GetMaximumDistance ( ) [virtual]

Set / get the distance away from surface of input geometry to sample. Smaller values make large increases in performance.

virtual void vtkImplicitModeller::SetModelBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the region in space in which to perform the sampling. If not specified, it will be computed automatically.

virtual void vtkImplicitModeller::SetModelBounds ( float [6] ) [virtual]

Set / get the region in space in which to perform the sampling. If not specified, it will be computed automatically.

virtual float* vtkImplicitModeller::GetModelBounds ( ) [virtual]

Set / get the region in space in which to perform the sampling. If not specified, it will be computed automatically.

virtual void vtkImplicitModeller::GetModelBounds ( float data[6] ) [virtual]

Set / get the region in space in which to perform the sampling. If not specified, it will be computed automatically.

virtual void vtkImplicitModeller::SetAdjustBounds ( int ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual int vtkImplicitModeller::GetAdjustBounds ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkImplicitModeller::AdjustBoundsOn ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkImplicitModeller::AdjustBoundsOff ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkImplicitModeller::SetAdjustDistance ( float ) [virtual]

Specify the amount to grow the model bounds (if the ivar AdjustBounds is set). The value is a fraction of the maximum length of the sides of the box specified by the model bounds.

virtual float vtkImplicitModeller::GetAdjustDistance ( ) [virtual]

Specify the amount to grow the model bounds (if the ivar AdjustBounds is set). The value is a fraction of the maximum length of the sides of the box specified by the model bounds.

virtual void vtkImplicitModeller::SetCapping ( int ) [virtual]

The outer boundary of the structured point set can be assigned a particular value. This can be used to close or "cap" all surfaces.

virtual int vtkImplicitModeller::GetCapping ( ) [virtual]

The outer boundary of the structured point set can be assigned a particular value. This can be used to close or "cap" all surfaces.

virtual void vtkImplicitModeller::CappingOn ( ) [virtual]

The outer boundary of the structured point set can be assigned a particular value. This can be used to close or "cap" all surfaces.

virtual void vtkImplicitModeller::CappingOff ( ) [virtual]

The outer boundary of the structured point set can be assigned a particular value. This can be used to close or "cap" all surfaces.

virtual void vtkImplicitModeller::SetCapValue ( float ) [virtual]

Specify the capping value to use. The CapValue is also used as an initial distance value at each point in the dataset.

virtual float vtkImplicitModeller::GetCapValue ( ) [virtual]

Specify the capping value to use. The CapValue is also used as an initial distance value at each point in the dataset.

virtual void vtkImplicitModeller::SetProcessMode ( int ) [virtual]

Specify whether to visit each cell once per append or each voxel once per append. Some tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode.

virtual int vtkImplicitModeller::GetProcessMode ( ) [virtual]

Specify whether to visit each cell once per append or each voxel once per append. Some tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode.

void vtkImplicitModeller::SetProcessModeToPerVoxel ( ) [inline]

Specify whether to visit each cell once per append or each voxel once per append. Some tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode.

Definition at line 177 of file vtkImplicitModeller.h.

void vtkImplicitModeller::SetProcessModeToPerCell ( ) [inline]

Specify whether to visit each cell once per append or each voxel once per append. Some tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode.

Definition at line 178 of file vtkImplicitModeller.h.

const char* vtkImplicitModeller::GetProcessModeAsString ( void )

Specify whether to visit each cell once per append or each voxel once per append. Some tests have shown once per voxel to be faster when there are a lot of cells (at least a thousand?); relative performance improvement increases with addition cells. Primitives should not be stripped for best performance of the voxel mode.

virtual void vtkImplicitModeller::SetLocatorMaxLevel ( int ) [virtual]

Specify the level of the locator to use when using the per voxel process mode.

virtual int vtkImplicitModeller::GetLocatorMaxLevel ( ) [virtual]

Specify the level of the locator to use when using the per voxel process mode.

virtual void vtkImplicitModeller::SetNumberOfThreads ( int ) [virtual]

Set / Get the number of threads used during Per-Voxel processing mode

virtual int vtkImplicitModeller::GetNumberOfThreads ( ) [virtual]

Set / Get the number of threads used during Per-Voxel processing mode

void vtkImplicitModeller::StartAppend ( )

Initialize the filter for appending data. You must invoke the StartAppend() method before doing successive Appends(). It's also a good idea to manually specify the model bounds; otherwise the input bounds for the data will be used.

void vtkImplicitModeller::Append ( vtkDataSet * input )

Append a data set to the existing output. To use this function, you'll have to invoke the StartAppend() method before doing successive appends. It's also a good idea to specify the model bounds; otherwise the input model bounds is used. When you've finished appending, use the EndAppend() method.

void vtkImplicitModeller::EndAppend ( )

Method completes the append process.

virtual void vtkImplicitModeller::UpdateData ( vtkDataObject * output ) [virtual]

Reimplemented from vtkSource.

void vtkImplicitModeller::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkImplicitModeller::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsSource.

void vtkImplicitModeller::Cap ( vtkDataArray * s ) [protected]

Member Data Documentation

vtkMultiThreader* vtkImplicitModeller::Threader [protected]

Definition at line 222 of file vtkImplicitModeller.h.

int vtkImplicitModeller::NumberOfThreads [protected]

Definition at line 223 of file vtkImplicitModeller.h.

int vtkImplicitModeller::SampleDimensions[3] [protected]

Definition at line 225 of file vtkImplicitModeller.h.

float vtkImplicitModeller::MaximumDistance [protected]

Definition at line 226 of file vtkImplicitModeller.h.

float vtkImplicitModeller::ModelBounds[6] [protected]

Definition at line 227 of file vtkImplicitModeller.h.

int vtkImplicitModeller::Capping [protected]

Definition at line 228 of file vtkImplicitModeller.h.

float vtkImplicitModeller::CapValue [protected]

Definition at line 229 of file vtkImplicitModeller.h.

int vtkImplicitModeller::DataAppended [protected]

Definition at line 230 of file vtkImplicitModeller.h.

int vtkImplicitModeller::AdjustBounds [protected]

Definition at line 231 of file vtkImplicitModeller.h.

float vtkImplicitModeller::AdjustDistance [protected]

Definition at line 232 of file vtkImplicitModeller.h.

int vtkImplicitModeller::ProcessMode [protected]

Definition at line 233 of file vtkImplicitModeller.h.

int vtkImplicitModeller::LocatorMaxLevel [protected]

Definition at line 234 of file vtkImplicitModeller.h.

int vtkImplicitModeller::BoundsComputed [protected]

Definition at line 236 of file vtkImplicitModeller.h.

float vtkImplicitModeller::InternalMaxDistance [protected]

Definition at line 237 of file vtkImplicitModeller.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkImplicitModeller.h
Generated on Mon Mar 25 01:20:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitSelectionLoop Class Reference

implicit function for a selection loop. More...

#include <vtkImplicitSelectionLoop.h>

Inheritance diagram for vtkImplicitSelectionLoop:

[legend]
Collaboration diagram for vtkImplicitSelectionLoop:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitSelectionLoop, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float n[3])
unsigned long | GetMTime ()
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetLoop (vtkPoints *)
virtual vtkPoints * | GetLoop ()
virtual void | SetAutomaticNormalGeneration (int)
virtual int | GetAutomaticNormalGeneration ()
virtual void | AutomaticNormalGenerationOn ()
virtual void | AutomaticNormalGenerationOff ()
virtual void | SetNormal (float, float, float)
virtual void | SetNormal (float[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float data[3])

Static Public Methods

vtkImplicitSelectionLoop * | New ()

Protected Methods

vtkImplicitSelectionLoop ()
~vtkImplicitSelectionLoop ()

Protected Attributes

vtkPoints * Loop
float | Normal [3]
int | AutomaticNormalGeneration

Detailed Description

implicit function for a selection loop.

Date:
2002/01/22 15:28:07
Revision:
1.19

vtkImplicitSelectionLoop computes the implicit function value and function gradient for a irregular, cylinder-like object whose cross section is defined by a set of points forming a loop. The loop need not be convex nor its points coplanar. However, the loop must be non-self-intersecting when projected onto the plane defined by the accumulated cross product around the loop (i.e., the axis of the loop). (Alternatively, you can specify the normal to use.)

The following procedure is used to compute the implicit function value for a point x. Each point of the loop is first projected onto the plane defined by the loop normal. This forms a polygon. Then, to evaluate the implicit function value, inside/outside tests are used to determine if x is inside the polygon, and the distance to the loop boundary is computed (negative values are inside the loop).

One example application of this implicit function class is to draw a loop on the surface of a mesh, and use the loop to clip or extract cells from within the loop. Remember, the selection loop is "infinite" in length, you can use a plane (in boolean combination) to cap the extent of the selection loop. Another trick is to use a connectivity filter to extract the closest region to a given point (i.e., one of the points used to define the selection loop).

See also:
vtkImplicitFunction vtkImplicitBoolean vtkExtractGeometry vtkClipPolyData vtkConnectivityFilter vtkPolyDataConnectivityFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)
  • Martin, Ken (5%)
Tests:
vtkImplicitSelectionLoop (Tests)

Definition at line 67 of file vtkImplicitSelectionLoop.h.

Constructor & Destructor Documentation

vtkImplicitSelectionLoop::vtkImplicitSelectionLoop ( ) [protected]

vtkImplicitSelectionLoop::~vtkImplicitSelectionLoop ( ) [protected]

Member Function Documentation

vtkImplicitSelectionLoop::vtkTypeRevisionMacro | ( | vtkImplicitSelectionLoop | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitSelectionLoop::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkImplicitSelectionLoop* vtkImplicitSelectionLoop::New ( ) [static]

Instantiate object with no initial loop.

Reimplemented from vtkObject.

float vtkImplicitSelectionLoop::EvaluateFunction ( float x[3] ) [virtual]

Evaluate selection loop returning a signed distance.

Reimplemented from vtkImplicitFunction.

float vtkImplicitSelectionLoop::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate selection loop returning a signed distance.

Reimplemented from vtkImplicitFunction.

Definition at line 79 of file vtkImplicitSelectionLoop.h.

void vtkImplicitSelectionLoop::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate selection loop returning the gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkImplicitSelectionLoop::SetLoop ( vtkPoints * ) [virtual]

Set/Get the array of point coordinates defining the loop. There must be at least three points used to define a loop.

virtual vtkPoints* vtkImplicitSelectionLoop::GetLoop ( ) [virtual]

Set/Get the array of point coordinates defining the loop. There must be at least three points used to define a loop.

virtual void vtkImplicitSelectionLoop::SetAutomaticNormalGeneration ( int ) [virtual]

Turn on/off automatic normal generation. By default, the normal is computed from the accumulated cross product of the edges. You can also specify the normal to use.

virtual int vtkImplicitSelectionLoop::GetAutomaticNormalGeneration ( ) [virtual]

Turn on/off automatic normal generation. By default, the normal is computed from the accumulated cross product of the edges. You can also specify the normal to use.

virtual void vtkImplicitSelectionLoop::AutomaticNormalGenerationOn ( ) [virtual]

Turn on/off automatic normal generation. By default, the normal is computed from the accumulated cross product of the edges. You can also specify the normal to use.

virtual void vtkImplicitSelectionLoop::AutomaticNormalGenerationOff ( ) [virtual]

Turn on/off automatic normal generation. By default, the normal is computed from the accumulated cross product of the edges. You can also specify the normal to use.

virtual void vtkImplicitSelectionLoop::SetNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the normal used to determine what is inside and what is outside.

virtual void vtkImplicitSelectionLoop::SetNormal ( float [3] ) [virtual]

Set / get the normal used to determine what is inside and what is outside.

virtual float* vtkImplicitSelectionLoop::GetNormal ( ) [virtual]

Set / get the normal used to determine what is inside and what is outside.

virtual void vtkImplicitSelectionLoop::GetNormal ( float data[3] ) [virtual]

Set / get the normal used to determine what is inside and what is outside.

unsigned long vtkImplicitSelectionLoop::GetMTime ( ) [virtual]

Overload GetMTime() because we depend on the Loop

Reimplemented from vtkImplicitFunction.

Member Data Documentation

vtkPoints* vtkImplicitSelectionLoop::Loop [protected]

Definition at line 116 of file vtkImplicitSelectionLoop.h.

float vtkImplicitSelectionLoop::Normal[3] [protected]

Definition at line 117 of file vtkImplicitSelectionLoop.h.

int vtkImplicitSelectionLoop::AutomaticNormalGeneration [protected]

Definition at line 118 of file vtkImplicitSelectionLoop.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitSelectionLoop.h
Generated on Mon Mar 25 01:20:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitSum Class Reference

implicit sum of other implicit functions. More...

#include <vtkImplicitSum.h>

Inheritance diagram for vtkImplicitSum:

[legend]
Collaboration diagram for vtkImplicitSum:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitSum, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
unsigned long | GetMTime ()
void | AddFunction (vtkImplicitFunction *in, float weight)
void | AddFunction (vtkImplicitFunction *in)
void | RemoveAllFunctions ()
void | SetFunctionWeight (vtkImplicitFunction *f, float weight)
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetNormalizeByWeight (int)
virtual int | GetNormalizeByWeight ()
virtual void | NormalizeByWeightOn ()
virtual void | NormalizeByWeightOff ()

Static Public Methods

vtkImplicitSum * | New ()

Protected Methods

vtkImplicitSum ()
~vtkImplicitSum ()
void | CalculateTotalWeight (void)

Protected Attributes

vtkImplicitFunctionCollection * FunctionList
vtkFloatArray * Weights
float | TotalWeight
int | NormalizeByWeight

Detailed Description

implicit sum of other implicit functions.

Date:
2002/03/05 20:34:00
Revision:
1.3

vtkImplicitSum produces a linear combination of other implicit functions. The contribution of each function is weighted by a scalar coefficient. The NormalizeByWeight option normalizes the output so that the scalar weights add up to 1. Note that this function gives accurate sums and gradients only if the input functions are linear.

Created by:
  • Halle, Michael
Contributed by (if > 5%):
  • Halle, Michael (92%)
  • Schroeder, Will (7%)
Examples:
vtkImplicitSum (Examples)
Tests:
vtkImplicitSum (Tests)

Definition at line 72 of file vtkImplicitSum.h.

Constructor & Destructor Documentation

vtkImplicitSum::vtkImplicitSum ( ) [protected]

vtkImplicitSum::~vtkImplicitSum ( ) [protected]

Member Function Documentation

vtkImplicitSum* vtkImplicitSum::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkImplicitSum::vtkTypeRevisionMacro | ( | vtkImplicitSum | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitSum::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

float vtkImplicitSum::EvaluateFunction ( float x[3] ) [virtual]

Evaluate implicit function using current functions and weights.

Reimplemented from vtkImplicitFunction.

float vtkImplicitSum::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate implicit function using current functions and weights.

Reimplemented from vtkImplicitFunction.

Definition at line 83 of file vtkImplicitSum.h.

void vtkImplicitSum::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate gradient of the weighted sum of functions. Input functions should be linear.

Reimplemented from vtkImplicitFunction.

unsigned long vtkImplicitSum::GetMTime ( ) [virtual]

Override modified time retrieval because of object dependencies.

Reimplemented from vtkImplicitFunction.

void vtkImplicitSum::AddFunction | ( | vtkImplicitFunction * | in,
 |  | float | weight
 | ) |

Add another implicit function to the list of functions, along with a weighting factor.

void vtkImplicitSum::AddFunction ( vtkImplicitFunction * in ) [inline]

Add another implicit function to the list of functions, weighting it by a factor of 1.

Definition at line 100 of file vtkImplicitSum.h.

void vtkImplicitSum::RemoveAllFunctions ( )

Remove all functions from the list.

void vtkImplicitSum::SetFunctionWeight | ( | vtkImplicitFunction * | f,
 |  | float | weight
 | ) |

Set the weight (coefficient) of the given function to be weight.

virtual void vtkImplicitSum::SetNormalizeByWeight ( int ) [virtual]

When calculating the function and gradient values of the composite function, setting NormalizeByWeight on will divide the final result by the total weight of the component functions. This process does not otherwise normalize the gradient vector. By default, NormalizeByWeight is off.

virtual int vtkImplicitSum::GetNormalizeByWeight ( ) [virtual]

When calculating the function and gradient values of the composite function, setting NormalizeByWeight on will divide the final result by the total weight of the component functions. This process does not otherwise normalize the gradient vector. By default, NormalizeByWeight is off.

virtual void vtkImplicitSum::NormalizeByWeightOn ( ) [virtual]

When calculating the function and gradient values of the composite function, setting NormalizeByWeight on will divide the final result by the total weight of the component functions. This process does not otherwise normalize the gradient vector. By default, NormalizeByWeight is off.

virtual void vtkImplicitSum::NormalizeByWeightOff ( ) [virtual]

When calculating the function and gradient values of the composite function, setting NormalizeByWeight on will divide the final result by the total weight of the component functions. This process does not otherwise normalize the gradient vector. By default, NormalizeByWeight is off.

void vtkImplicitSum::CalculateTotalWeight ( void ) [protected]

Member Data Documentation

vtkImplicitFunctionCollection* vtkImplicitSum::FunctionList [protected]

Definition at line 123 of file vtkImplicitSum.h.

vtkFloatArray* vtkImplicitSum::Weights [protected]

Definition at line 124 of file vtkImplicitSum.h.

float vtkImplicitSum::TotalWeight [protected]

Definition at line 125 of file vtkImplicitSum.h.

int vtkImplicitSum::NormalizeByWeight [protected]

Definition at line 128 of file vtkImplicitSum.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitSum.h
Generated on Mon Mar 25 01:20:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitTextureCoords Class Reference

generate 1D, 2D, or 3D texture coordinates based on implicit function(s). More...

#include <vtkImplicitTextureCoords.h>

Inheritance diagram for vtkImplicitTextureCoords:

[legend]
Collaboration diagram for vtkImplicitTextureCoords:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitTextureCoords, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetRFunction ()
virtual void | SetSFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetSFunction ()
virtual void | SetTFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetTFunction ()
virtual void | SetFlipTexture (int)
virtual int | GetFlipTexture ()
virtual void | FlipTextureOn ()
virtual void | FlipTextureOff ()

Static Public Methods

vtkImplicitTextureCoords * | New ()

Protected Methods

vtkImplicitTextureCoords ()
~vtkImplicitTextureCoords ()
void | Execute ()

Protected Attributes

vtkImplicitFunction * RFunction
vtkImplicitFunction * SFunction
vtkImplicitFunction * TFunction
int | FlipTexture

Detailed Description

generate 1D, 2D, or 3D texture coordinates based on implicit function(s).

Date:
2002/01/22 15:29:24
Revision:
1.39

vtkImplicitTextureCoords is a filter to generate 1D, 2D, or 3D texture coordinates from one, two, or three implicit functions, respectively. In combinations with a vtkBooleanTexture map (or another texture map of your own creation), the texture coordinates can be used to highlight (via color or intensity) or cut (via transparency) dataset geometry without any complex geometric processing. (Note: the texture coordinates are referred to as r-s-t coordinates.)

The texture coordinates are automatically normalized to lie between (0,1). Thus, no matter what the implicit functions evaluate to, the resulting texture coordinates lie between (0,1), with the zero implicit function value mapped to the 0.5 texture coordinates value. Depending upon the maximum negative/positive implicit function values, the full (0,1) range may not be occupied (i.e., the positive/negative ranges are mapped using the same scale factor).

A boolean variable InvertTexture is available to flip the texture coordinates around 0.5 (value 1.0 becomes 0.0, 0.25->0.75). This is equivalent to flipping the texture map (but a whole lot easier).

Warning:
You can use the transformation capabilities of vtkImplicitFunction to orient, translate, and scale the implicit functions. Also, the dimension of the texture coordinates is implicitly defined by the number of implicit functions defined.
See also:
vtkImplicitFunction vtkTexture vtkBooleanTexture vtkTransformTexture
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Martin, Ken (16%)
  • Lorensen, Bill (9%)
Tests:
vtkImplicitTextureCoords (Tests)

Definition at line 69 of file vtkImplicitTextureCoords.h.

Constructor & Destructor Documentation

vtkImplicitTextureCoords::vtkImplicitTextureCoords ( ) [protected]

vtkImplicitTextureCoords::~vtkImplicitTextureCoords ( ) [protected]

Member Function Documentation

vtkImplicitTextureCoords::vtkTypeRevisionMacro | ( | vtkImplicitTextureCoords | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkImplicitTextureCoords::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkImplicitTextureCoords* vtkImplicitTextureCoords::New ( ) [static]

Create object with texture dimension=2 and no r-s-t implicit functions defined and FlipTexture turned off.

Reimplemented from vtkDataSetSource.

virtual void vtkImplicitTextureCoords::SetRFunction ( vtkImplicitFunction * ) [virtual]

Specify an implicit function to compute the r texture coordinate.

virtual vtkImplicitFunction* vtkImplicitTextureCoords::GetRFunction ( ) [virtual]

Specify an implicit function to compute the r texture coordinate.

virtual void vtkImplicitTextureCoords::SetSFunction ( vtkImplicitFunction * ) [virtual]

Specify an implicit function to compute the s texture coordinate.

virtual vtkImplicitFunction* vtkImplicitTextureCoords::GetSFunction ( ) [virtual]

Specify an implicit function to compute the s texture coordinate.

virtual void vtkImplicitTextureCoords::SetTFunction ( vtkImplicitFunction * ) [virtual]

Specify an implicit function to compute the t texture coordinate.

virtual vtkImplicitFunction* vtkImplicitTextureCoords::GetTFunction ( ) [virtual]

Specify an implicit function to compute the t texture coordinate.

virtual void vtkImplicitTextureCoords::SetFlipTexture ( int ) [virtual]

If enabled, this will flip the sense of inside and outside the implicit function (i.e., a rotation around the r-s-t=0.5 axis).

virtual int vtkImplicitTextureCoords::GetFlipTexture ( ) [virtual]

If enabled, this will flip the sense of inside and outside the implicit function (i.e., a rotation around the r-s-t=0.5 axis).

virtual void vtkImplicitTextureCoords::FlipTextureOn ( ) [virtual]

If enabled, this will flip the sense of inside and outside the implicit function (i.e., a rotation around the r-s-t=0.5 axis).

virtual void vtkImplicitTextureCoords::FlipTextureOff ( ) [virtual]

If enabled, this will flip the sense of inside and outside the implicit function (i.e., a rotation around the r-s-t=0.5 axis).

void vtkImplicitTextureCoords::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkImplicitFunction* vtkImplicitTextureCoords::RFunction [protected]

Definition at line 111 of file vtkImplicitTextureCoords.h.

vtkImplicitFunction* vtkImplicitTextureCoords::SFunction [protected]

Definition at line 112 of file vtkImplicitTextureCoords.h.

vtkImplicitFunction* vtkImplicitTextureCoords::TFunction [protected]

Definition at line 113 of file vtkImplicitTextureCoords.h.

int vtkImplicitTextureCoords::FlipTexture [protected]

Definition at line 114 of file vtkImplicitTextureCoords.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkImplicitTextureCoords.h
Generated on Mon Mar 25 01:20:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitVolume Class Reference

treat a volume as if it were an implicit function. More...

#include <vtkImplicitVolume.h>

Inheritance diagram for vtkImplicitVolume:

[legend]
Collaboration diagram for vtkImplicitVolume:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitVolume, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | EvaluateGradient (float x[3], float n[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetVolume (vtkImageData *)
virtual vtkImageData * | GetVolume ()
virtual void | SetOutValue (float)
virtual float | GetOutValue ()
virtual void | SetOutGradient (float, float, float)
virtual void | SetOutGradient (float[3])
virtual float * | GetOutGradient ()
virtual void | GetOutGradient (float &, float &, float &)
virtual void | GetOutGradient (float[3])

Static Public Methods

vtkImplicitVolume * | New ()

Protected Methods

vtkImplicitVolume ()
~vtkImplicitVolume ()

Protected Attributes

vtkImageData * Volume
float | OutValue
float | OutGradient [3]
vtkIdList * PointIds

Detailed Description

treat a volume as if it were an implicit function.

Date:
2002/01/22 15:28:07
Revision:
1.31

vtkImplicitVolume treats a volume (e.g., structured point dataset) as if it were an implicit function. This means it computes a function value and gradient. vtkImplicitVolume is a concrete implementation of vtkImplicitFunction.

vtkImplicitDataSet computes the function (at the point x) by performing cell interpolation. That is, it finds the cell containing x, and then uses the cell's interpolation functions to compute an interpolated scalar value at x. (A similar approach is used to find the gradient, if requested.) Points outside of the dataset are assigned the value of the ivar OutValue, and the gradient value OutGradient.

Warning:
The input volume data is only updated when GetMTime() is called. Works for 3D structured points datasets, 0D-2D datasets won't work properly.
See also:
vtkImplicitFunction vtkImplicitDataSet vtkClipPolyData vtkCutter vtkImplicitWindowFunction
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (39%)
  • Schroeder, Will (22%)
  • Gobbi, David (13%)
  • Law, Charles (7%)
  • Martin, Ken (5%)
Tests:
vtkImplicitVolume (Tests)

Definition at line 62 of file vtkImplicitVolume.h.

Constructor & Destructor Documentation

vtkImplicitVolume::vtkImplicitVolume ( ) [protected]

vtkImplicitVolume::~vtkImplicitVolume ( ) [protected]

Member Function Documentation

vtkImplicitVolume::vtkTypeRevisionMacro | ( | vtkImplicitVolume | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitVolume::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkImplicitVolume* vtkImplicitVolume::New ( ) [static]

Construct an vtkImplicitVolume with no initial volume; the OutValue set to a large negative number; and the OutGradient set to (0,0,1).

Reimplemented from vtkObject.

unsigned long vtkImplicitVolume::GetMTime ( ) [virtual]

Returns the mtime also considering the volume. This also calls Update on the volume, and it therefore must be called before the function is evaluated.

Reimplemented from vtkImplicitFunction.

float vtkImplicitVolume::EvaluateFunction ( float x[3] ) [virtual]

Evaluate the ImplicitVolume. This returns the interpolated scalar value at x[3].

Reimplemented from vtkImplicitFunction.

float vtkImplicitVolume::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate the ImplicitVolume. This returns the interpolated scalar value at x[3].

Reimplemented from vtkImplicitFunction.

Definition at line 81 of file vtkImplicitVolume.h.

void vtkImplicitVolume::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate ImplicitVolume gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkImplicitVolume::SetVolume ( vtkImageData * ) [virtual]

Specify the volume for the implicit function.

virtual vtkImageData* vtkImplicitVolume::GetVolume ( ) [virtual]

Specify the volume for the implicit function.

virtual void vtkImplicitVolume::SetOutValue ( float ) [virtual]

Set the function value to use for points outside of the dataset.

virtual float vtkImplicitVolume::GetOutValue ( ) [virtual]

Set the function value to use for points outside of the dataset.

virtual void vtkImplicitVolume::SetOutGradient | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the function gradient to use for points outside of the dataset.

virtual void vtkImplicitVolume::SetOutGradient ( float [3] ) [virtual]

Set the function gradient to use for points outside of the dataset.

virtual float* vtkImplicitVolume::GetOutGradient ( ) [virtual]

Set the function gradient to use for points outside of the dataset.

virtual void vtkImplicitVolume::GetOutGradient | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the function gradient to use for points outside of the dataset.

virtual void vtkImplicitVolume::GetOutGradient ( float [3] ) [virtual]

Set the function gradient to use for points outside of the dataset.

Member Data Documentation

vtkImageData* vtkImplicitVolume::Volume [protected]

Definition at line 110 of file vtkImplicitVolume.h.

float vtkImplicitVolume::OutValue [protected]

Definition at line 111 of file vtkImplicitVolume.h.

float vtkImplicitVolume::OutGradient[3] [protected]

Definition at line 112 of file vtkImplicitVolume.h.

vtkIdList* vtkImplicitVolume::PointIds [protected]

Definition at line 114 of file vtkImplicitVolume.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitVolume.h
Generated on Mon Mar 25 01:20:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImplicitWindowFunction Class Reference

implicit function maps another implicit function to lie within a specified range. More...

#include <vtkImplicitWindowFunction.h>

Inheritance diagram for vtkImplicitWindowFunction:

[legend]
Collaboration diagram for vtkImplicitWindowFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImplicitWindowFunction, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float n[3])
unsigned long | GetMTime ()
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetImplicitFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetImplicitFunction ()
virtual void | SetWindowRange (float, float)
void | SetWindowRange (float[2])
virtual float * | GetWindowRange ()
virtual void | GetWindowRange (float data[2])
virtual void | SetWindowValues (float, float)
void | SetWindowValues (float[2])
virtual float * | GetWindowValues ()
virtual void | GetWindowValues (float data[2])

Static Public Methods

vtkImplicitWindowFunction * | New ()

Protected Methods

vtkImplicitWindowFunction ()
~vtkImplicitWindowFunction ()

Protected Attributes

vtkImplicitFunction * ImplicitFunction
float | WindowRange [2]
float | WindowValues [2]

Detailed Description

implicit function maps another implicit function to lie within a specified range.

Date:
2002/01/22 15:28:08
Revision:
1.26

vtkImplicitWindowFunction is used to modify the output of another implicit function to lie within a specified "window", or function range. This can be used to add "thickness" to cutting or clipping functions.

This class works as follows. First, it evaluates the function value of the user-specified implicit function. Then, based on the window range specified, it maps the function value into the window values specified.

See also:
vtkImplicitFunction
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Martin, Ken (8%)
  • Lorensen, Bill (7%)
  • Kelly, Ann (5%)
Tests:
vtkImplicitWindowFunction (Tests)

Definition at line 54 of file vtkImplicitWindowFunction.h.

Constructor & Destructor Documentation

vtkImplicitWindowFunction::vtkImplicitWindowFunction ( ) [protected]

vtkImplicitWindowFunction::~vtkImplicitWindowFunction ( ) [protected]

Member Function Documentation

vtkImplicitWindowFunction::vtkTypeRevisionMacro | ( | vtkImplicitWindowFunction | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkImplicitWindowFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkImplicitWindowFunction* vtkImplicitWindowFunction::New ( ) [static]

Construct object with window range (0,1) and window values (0,1).

Reimplemented from vtkObject.

float vtkImplicitWindowFunction::EvaluateFunction ( float x[3] ) [virtual]

Evaluate window function.

Reimplemented from vtkImplicitFunction.

float vtkImplicitWindowFunction::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate window function.

Reimplemented from vtkImplicitFunction.

Definition at line 66 of file vtkImplicitWindowFunction.h.

void vtkImplicitWindowFunction::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate window function gradient. Just return implicit function gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkImplicitWindowFunction::SetImplicitFunction ( vtkImplicitFunction * ) [virtual]

Specify an implicit function to operate on.

virtual vtkImplicitFunction* vtkImplicitWindowFunction::GetImplicitFunction ( ) [virtual]

Specify an implicit function to operate on.

virtual void vtkImplicitWindowFunction::SetWindowRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify the range of function values which are considered to lie within the window. WindowRange[0] is assumed to be less than WindowRange[1].

void vtkImplicitWindowFunction::SetWindowRange ( float [2] )

Specify the range of function values which are considered to lie within the window. WindowRange[0] is assumed to be less than WindowRange[1].

virtual float* vtkImplicitWindowFunction::GetWindowRange ( ) [virtual]

Specify the range of function values which are considered to lie within the window. WindowRange[0] is assumed to be less than WindowRange[1].

virtual void vtkImplicitWindowFunction::GetWindowRange ( float data[2] ) [virtual]

Specify the range of function values which are considered to lie within the window. WindowRange[0] is assumed to be less than WindowRange[1].

virtual void vtkImplicitWindowFunction::SetWindowValues | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify the range of output values that the window range is mapped into. This is effectively a scaling and shifting of the original function values.

void vtkImplicitWindowFunction::SetWindowValues ( float [2] )

Specify the range of output values that the window range is mapped into. This is effectively a scaling and shifting of the original function values.

virtual float* vtkImplicitWindowFunction::GetWindowValues ( ) [virtual]

Specify the range of output values that the window range is mapped into. This is effectively a scaling and shifting of the original function values.

virtual void vtkImplicitWindowFunction::GetWindowValues ( float data[2] ) [virtual]

Specify the range of output values that the window range is mapped into. This is effectively a scaling and shifting of the original function values.

unsigned long vtkImplicitWindowFunction::GetMTime ( ) [virtual]

Override modified time retrieval because of object dependencies.

Reimplemented from vtkImplicitFunction.

Member Data Documentation

vtkImplicitFunction* vtkImplicitWindowFunction::ImplicitFunction [protected]

Definition at line 103 of file vtkImplicitWindowFunction.h.

float vtkImplicitWindowFunction::WindowRange[2] [protected]

Definition at line 104 of file vtkImplicitWindowFunction.h.

float vtkImplicitWindowFunction::WindowValues[2] [protected]

Definition at line 105 of file vtkImplicitWindowFunction.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkImplicitWindowFunction.h
Generated on Mon Mar 25 01:20:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkImporter Class Reference

importer abstract class. More...

#include <vtkImporter.h>

Inheritance diagram for vtkImporter:

[legend]
Collaboration diagram for vtkImporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkImporter, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkRenderer * | GetRenderer ()
virtual void | SetRenderWindow (vtkRenderWindow *)
virtual vtkRenderWindow * | GetRenderWindow ()
void | Read ()
void | Update ()

Protected Methods

vtkImporter ()
~vtkImporter ()
virtual int | ImportBegin ()
virtual void | ImportEnd ()
virtual void | ImportActors (vtkRenderer *vtkNotUsed(renderer))
virtual void | ImportCameras (vtkRenderer *vtkNotUsed(renderer))
virtual void | ImportLights (vtkRenderer *vtkNotUsed(renderer))
virtual void | ImportProperties (vtkRenderer *vtkNotUsed(renderer))
virtual void | ReadData ()

Protected Attributes

vtkRenderer * Renderer
vtkRenderWindow * RenderWindow

Detailed Description

importer abstract class.

Date:
2002/01/22 15:38:35
Revision:
1.23

vtkImporter is an abstract class that specifies the protocol for importing actors, cameras, lights and properties into a vtkRenderWindow. The following takes place: 1) Create a RenderWindow and Renderer if none is provided. 2) Call ImportBegin, if ImportBegin returns False, return 3) Call ReadData, which calls: a) Import the Actors b) Import the cameras c) Import the lights d) Import the Properties 7) Call ImportEnd

Subclasses optionally implement the ImportActors, ImportCameras, ImportLights and ImportProperties or ReadData methods. An ImportBegin and ImportEnd can optionally be provided to perform Importer-specific initialization and termination. The Read method initiates the import process. If a RenderWindow is provided, its Renderer will contained the imported objects. If the RenderWindow has no Renderer, one is created. If no RenderWindow is provided, both a RenderWindow and Renderer will be created. Both the RenderWindow and Renderer can be accessed using Get methods.

See also:
vtk3DSImporter vtkExporter
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (66%)
  • Geveci, Berk (14%)
  • Martin, Ken (7%)
  • Schroeder, Will (7%)

Definition at line 68 of file vtkImporter.h.

Constructor & Destructor Documentation

vtkImporter::vtkImporter ( ) [protected]

vtkImporter::~vtkImporter ( ) [protected]

Member Function Documentation

vtkImporter::vtkTypeRevisionMacro | ( | vtkImporter | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtk3DSImporter, and vtkVRMLImporter.

void vtkImporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtk3DSImporter, and vtkVRMLImporter.

virtual vtkRenderer* vtkImporter::GetRenderer ( ) [virtual]

Get the renderer that contains the imported actors, cameras and lights.

virtual void vtkImporter::SetRenderWindow ( vtkRenderWindow * ) [virtual]

Set the vtkRenderWindow to contain the imported actors, cameras and lights, If no vtkRenderWindow is set, one will be created and can be obtained with the GetRenderWindow method. If the vtkRenderWindow has been specified, the first vtkRenderer it has will be used to import the objects. If the vtkRenderWindow has no Renderer, one will be created and can be accessed using GetRenderer.

virtual vtkRenderWindow* vtkImporter::GetRenderWindow ( ) [virtual]

Set the vtkRenderWindow to contain the imported actors, cameras and lights, If no vtkRenderWindow is set, one will be created and can be obtained with the GetRenderWindow method. If the vtkRenderWindow has been specified, the first vtkRenderer it has will be used to import the objects. If the vtkRenderWindow has no Renderer, one will be created and can be accessed using GetRenderer.

void vtkImporter::Read ( )

Import the actors, cameras, lights and properties into a vtkRenderWindow.

void vtkImporter::Update ( void ) [inline]

Import the actors, cameras, lights and properties into a vtkRenderWindow.

Definition at line 97 of file vtkImporter.h.

virtual int vtkImporter::ImportBegin ( ) [inline, protected, virtual]

Reimplemented in vtk3DSImporter, and vtkVRMLImporter.

Definition at line 105 of file vtkImporter.h.

virtual void vtkImporter::ImportEnd ( ) [inline, protected, virtual]

Reimplemented in vtk3DSImporter, and vtkVRMLImporter.

Definition at line 106 of file vtkImporter.h.

virtual void vtkImporter::ImportActors ( vtkRenderer *vtkNotUsed(renderer) ) [inline, protected, virtual]

Definition at line 107 of file vtkImporter.h.

virtual void vtkImporter::ImportCameras ( vtkRenderer *vtkNotUsed(renderer) ) [inline, protected, virtual]

Definition at line 108 of file vtkImporter.h.

virtual void vtkImporter::ImportLights ( vtkRenderer *vtkNotUsed(renderer) ) [inline, protected, virtual]

Definition at line 109 of file vtkImporter.h.

virtual void vtkImporter::ImportProperties ( vtkRenderer *vtkNotUsed(renderer) ) [inline, protected, virtual]

Definition at line 110 of file vtkImporter.h.

virtual void vtkImporter::ReadData ( ) [protected, virtual]

Member Data Documentation

vtkRenderer* vtkImporter::Renderer [protected]

Definition at line 112 of file vtkImporter.h.

vtkRenderWindow* vtkImporter::RenderWindow [protected]

Definition at line 113 of file vtkImporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkImporter.h
Generated on Mon Mar 25 01:20:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIndent Class Reference

a simple class to control print indentation. More...

#include <vtkIndent.h>

Collaboration diagram for vtkIndent:

[legend]
List of all members.

Public Methods

void | Delete ()
vtkIndent (int ind=0)
virtual const char * | GetClassName ()
vtkIndent | GetNextIndent ()

Static Public Methods

vtkIndent * | New ()

Protected Attributes

int | Indent

Friends

VTK_COMMON_EXPORT ostream & | operator<< (ostream &os, vtkIndent &o)

Detailed Description

a simple class to control print indentation.

Date:
2002/01/22 15:25:30
Revision:
1.30

vtkIndent is used to control indentation during the chaining print process. This way nested objects can correctly indent themselves.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (37%)
  • Martin, Ken (36%)
  • Miller, Jim (11%)
  • Kelly, Ann (7%)
  • Lorensen, Bill (6%)
Examples:
vtkIndent (Examples)
Tests:
vtkIndent (Tests)

Definition at line 49 of file vtkIndent.h.

Constructor & Destructor Documentation

vtkIndent::vtkIndent ( int ind = 0 ) [inline]

Definition at line 53 of file vtkIndent.h.

Member Function Documentation

void vtkIndent::Delete ( ) [inline]

Definition at line 52 of file vtkIndent.h.

vtkIndent* vtkIndent::New ( ) [static]

virtual const char* vtkIndent::GetClassName ( ) [inline, virtual]

Definition at line 56 of file vtkIndent.h.

vtkIndent vtkIndent::GetNextIndent ( )

Determine the next indentation level. Keep indenting by two until the max of forty.

Friends And Related Function Documentation

VTK_COMMON_EXPORT ostream& operator<< | ( | ostream & | os,
 |  | vtkIndent & | o
 | ) | [friend]

Print out the indentation. Basically output a bunch of spaces.

Member Data Documentation

int vtkIndent::Indent [protected]

Definition at line 70 of file vtkIndent.h.

The documentation for this class was generated from the following file:
  • Common/vtkIndent.h
Generated on Mon Mar 25 01:20:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInitialValueProblemSolver Class Reference

Integrate a set of ordinary. More...

#include <vtkInitialValueProblemSolver.h>

Inheritance diagram for vtkInitialValueProblemSolver:

[legend]
Collaboration diagram for vtkInitialValueProblemSolver:

[legend]
List of all members.

Public Types

enum | ErrorCodes { OUT_OF_DOMAIN = 1, NOT_INITIALIZED = 2, UNEXPECTED_VALUE = 3 }

Public Methods

vtkTypeRevisionMacro (vtkInitialValueProblemSolver, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkInitialValueProblemSolver * | MakeObject ()=0
virtual int | IsAdaptive ()
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)=0
virtual void | SetFunctionSet (vtkFunctionSet *functionset)
virtual vtkFunctionSet * | GetFunctionSet ()

Protected Methods

vtkInitialValueProblemSolver ()
~vtkInitialValueProblemSolver ()
virtual void | Initialize ()

Protected Attributes

vtkFunctionSet * FunctionSet
float * | Vals
float * | Derivs
int | Initialized
int | Adaptive

Detailed Description

Integrate a set of ordinary.

Date:
2002/02/21 18:15:36
Revision:
1.11
differential equations (initial value problem) in time.

Given a vtkFunctionSet which returns dF_i(x_j, t)/dt given x_j and t, vtkInitialValueProblemSolver computes the value of F_i at t+deltat.

Warning:
vtkInitialValueProblemSolver and it's subclasses are not thread-safe. You should create a new integrator for each thread.
See also:
vtkRungeKutta2 vtkRungeKutta4
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (96%)

Definition at line 46 of file vtkInitialValueProblemSolver.h.

Member Enumeration Documentation

enum vtkInitialValueProblemSolver::ErrorCodes

Enumeration values:
OUT_OF_DOMAIN
NOT_INITIALIZED
UNEXPECTED_VALUE

Definition at line 114 of file vtkInitialValueProblemSolver.h.

Constructor & Destructor Documentation

vtkInitialValueProblemSolver::vtkInitialValueProblemSolver ( ) [protected]

vtkInitialValueProblemSolver::~vtkInitialValueProblemSolver ( ) [protected]

Member Function Documentation

vtkInitialValueProblemSolver::vtkTypeRevisionMacro | ( | vtkInitialValueProblemSolver | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

virtual void vtkInitialValueProblemSolver::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkRungeKutta4.

virtual int vtkInitialValueProblemSolver::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). For certain concrete sub-classes delTActual != delT. This occurs when the solver supports adaptive stepsize control. If this is the case, the solver tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep. Also note that delT is an in/out argument. Adaptive solvers will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. Note that only some concrete sub-classes support this. Otherwise, the error is set to 0. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

Definition at line 67 of file vtkInitialValueProblemSolver.h.

Referenced by vtkRungeKutta45::ComputeNextStep(), vtkRungeKutta4::ComputeNextStep(), and vtkRungeKutta2::ComputeNextStep().

virtual int vtkInitialValueProblemSolver::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). For certain concrete sub-classes delTActual != delT. This occurs when the solver supports adaptive stepsize control. If this is the case, the solver tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep. Also note that delT is an in/out argument. Adaptive solvers will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. Note that only some concrete sub-classes support this. Otherwise, the error is set to 0. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

Definition at line 77 of file vtkInitialValueProblemSolver.h.

virtual int vtkInitialValueProblemSolver::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). For certain concrete sub-classes delTActual != delT. This occurs when the solver supports adaptive stepsize control. If this is the case, the solver tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep. Also note that delT is an in/out argument. Adaptive solvers will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. Note that only some concrete sub-classes support this. Otherwise, the error is set to 0. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

Definition at line 87 of file vtkInitialValueProblemSolver.h.

virtual int vtkInitialValueProblemSolver::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [pure virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). For certain concrete sub-classes delTActual != delT. This occurs when the solver supports adaptive stepsize control. If this is the case, the solver tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep. Also note that delT is an in/out argument. Adaptive solvers will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. Note that only some concrete sub-classes support this. Otherwise, the error is set to 0. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

virtual vtkInitialValueProblemSolver* vtkInitialValueProblemSolver::MakeObject ( ) [pure virtual]

Create concrete instance of the object.

Reimplemented in vtkRungeKutta2, vtkRungeKutta4, and vtkRungeKutta45.

virtual void vtkInitialValueProblemSolver::SetFunctionSet ( vtkFunctionSet * functionset ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual vtkFunctionSet* vtkInitialValueProblemSolver::GetFunctionSet ( ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual int vtkInitialValueProblemSolver::IsAdaptive ( ) [inline, virtual]

Returns 1 if the solver uses adaptive stepsize control, 0 otherwise

Definition at line 111 of file vtkInitialValueProblemSolver.h.

virtual void vtkInitialValueProblemSolver::Initialize ( ) [protected, virtual]

Reimplemented in vtkRungeKutta4, and vtkRungeKutta45.

Member Data Documentation

vtkFunctionSet* vtkInitialValueProblemSolver::FunctionSet [protected]

Definition at line 128 of file vtkInitialValueProblemSolver.h.

float* vtkInitialValueProblemSolver::Vals [protected]

Definition at line 130 of file vtkInitialValueProblemSolver.h.

float* vtkInitialValueProblemSolver::Derivs [protected]

Definition at line 131 of file vtkInitialValueProblemSolver.h.

int vtkInitialValueProblemSolver::Initialized [protected]

Definition at line 132 of file vtkInitialValueProblemSolver.h.

int vtkInitialValueProblemSolver::Adaptive [protected]

Definition at line 133 of file vtkInitialValueProblemSolver.h.

The documentation for this class was generated from the following file:
  • Common/vtkInitialValueProblemSolver.h
Generated on Mon Mar 25 01:20:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInputPort Class Reference

Receives data from another process. More...

#include <vtkInputPort.h>

Inheritance diagram for vtkInputPort:

[legend]
Collaboration diagram for vtkInputPort:

[legend]
List of all members.

Public Types

enum Tags {
DOWN_DATA_TIME_TAG = 98970, UPDATE_EXTENT_TAG = 98971, TRANSFER_NEEDED_TAG = 98972, INFORMATION_TRANSFER_TAG = 98973,
DATA_TRANSFER_TAG = 98974, NEW_DATA_TIME_TAG = 98975
}

Public Methods

vtkTypeRevisionMacro (vtkInputPort, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | UpdateInformation ()
void | PropagateUpdateExtent (vtkDataObject *vtkNotUsed(output))
void | UpdateData (vtkDataObject *out)
void | TriggerAsynchronousUpdate ()
vtkPolyData * GetPolyDataOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkRectilinearGrid * GetRectilinearGridOutput ()
vtkStructuredPoints * GetStructuredPointsOutput ()
vtkImageData * GetImageDataOutput ()
virtual void | SetRemoteProcessId (int)
virtual int | GetRemoteProcessId ()
virtual void | SetTag (int)
virtual int | GetTag ()
vtkMultiProcessController * GetController ()
virtual void | SetController (vtkMultiProcessController *)
virtual void | SetDoUpdateInformation (int)
virtual int | GetDoUpdateInformation ()

Static Public Methods

vtkInputPort * | New ()

Protected Methods

vtkInputPort ()
~vtkInputPort ()

Protected Attributes

vtkMultiProcessController * Controller
int | RemoteProcessId
int | Tag
unsigned long | DataTime
unsigned long | UpStreamMTime
int | TransferNeeded
int | DoUpdateInformation

Detailed Description

Receives data from another process.

Date:
2002/01/22 15:34:34
Revision:
1.7

InputPort connects the pipeline in this process to one in another processes. It communicates all the pipeline protocol so that the fact you are running in multiple processes is transparent. An input port is used as a source (input to a process). One is placed at the start of a pipeline, and has a single corresponding output port in another process (specified by RemoteProcessId).

See also:
vtkOutputPort vtkMultiProcessController
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (98%)
Examples:
vtkInputPort (Examples)
Tests:
vtkInputPort (Tests)

Definition at line 63 of file vtkInputPort.h.

Member Enumeration Documentation

enum vtkInputPort::Tags

Enumeration values:
DOWN_DATA_TIME_TAG
UPDATE_EXTENT_TAG
TRANSFER_NEEDED_TAG
INFORMATION_TRANSFER_TAG
DATA_TRANSFER_TAG
NEW_DATA_TIME_TAG

Definition at line 125 of file vtkInputPort.h.

Constructor & Destructor Documentation

vtkInputPort::vtkInputPort ( ) [protected]

vtkInputPort::~vtkInputPort ( ) [protected]

Member Function Documentation

vtkInputPort* vtkInputPort::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkInputPort::vtkTypeRevisionMacro | ( | vtkInputPort | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkInputPort::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPolyData* vtkInputPort::GetPolyDataOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

vtkUnstructuredGrid* vtkInputPort::GetUnstructuredGridOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

vtkStructuredGrid* vtkInputPort::GetStructuredGridOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

vtkRectilinearGrid* vtkInputPort::GetRectilinearGridOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

vtkStructuredPoints* vtkInputPort::GetStructuredPointsOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

vtkImageData* vtkInputPort::GetImageDataOutput ( )

Note: You have to ask for the right type, and it has to match the type of the up stream port input, or you will get an error. We have to live with the fact that the error will not occur until an update is called.

virtual void vtkInputPort::SetRemoteProcessId ( int ) [virtual]

The matching OutputPort is specified by the output port's process and a tag. There can be more than one output port per process. THE TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

virtual int vtkInputPort::GetRemoteProcessId ( ) [virtual]

The matching OutputPort is specified by the output port's process and a tag. There can be more than one output port per process. THE TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

virtual void vtkInputPort::SetTag ( int ) [virtual]

The matching OutputPort is specified by the output port's process and a tag. There can be more than one output port per process. THE TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

virtual int vtkInputPort::GetTag ( ) [virtual]

The matching OutputPort is specified by the output port's process and a tag. There can be more than one output port per process. THE TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

void vtkInputPort::UpdateInformation ( ) [virtual]

Need to override to propagate across port.

Reimplemented from vtkSource.

void vtkInputPort::PropagateUpdateExtent ( vtkDataObject *vtkNotUsed(output) ) [inline]

Need to override to propagate across port.

Definition at line 97 of file vtkInputPort.h.

void vtkInputPort::UpdateData ( vtkDataObject * out ) [virtual]

Need to override to propagate across port

Reimplemented from vtkSource.

void vtkInputPort::TriggerAsynchronousUpdate ( ) [virtual]

Need to override to trigger the update across the port

Reimplemented from vtkSource.

vtkMultiProcessController* vtkInputPort::GetController ( ) [inline]

Access to the controller used for communication. By default, the global controller is used.

Definition at line 108 of file vtkInputPort.h.

virtual void vtkInputPort::SetController ( vtkMultiProcessController * ) [virtual]

Access to the controller used for communication. By default, the global controller is used.

virtual void vtkInputPort::SetDoUpdateInformation ( int ) [virtual]

If DoUpdateInformation if false (it is true by default), UpdateInformation is not performed during Update. This can be used to avoid unnecessary communication once the data has been transferred. However, if the pipeline changes upstream, DoUpdateInformation has to be set to true again. Otherwise, Updata will not occur.

virtual int vtkInputPort::GetDoUpdateInformation ( ) [virtual]

If DoUpdateInformation if false (it is true by default), UpdateInformation is not performed during Update. This can be used to avoid unnecessary communication once the data has been transferred. However, if the pipeline changes upstream, DoUpdateInformation has to be set to true again. Otherwise, Updata will not occur.

Member Data Documentation

vtkMultiProcessController* vtkInputPort::Controller [protected]

Definition at line 140 of file vtkInputPort.h.

int vtkInputPort::RemoteProcessId [protected]

Definition at line 141 of file vtkInputPort.h.

int vtkInputPort::Tag [protected]

Definition at line 142 of file vtkInputPort.h.

unsigned long vtkInputPort::DataTime [protected]

Definition at line 144 of file vtkInputPort.h.

unsigned long vtkInputPort::UpStreamMTime [protected]

Definition at line 145 of file vtkInputPort.h.

int vtkInputPort::TransferNeeded [protected]

Definition at line 146 of file vtkInputPort.h.

int vtkInputPort::DoUpdateInformation [protected]

Definition at line 147 of file vtkInputPort.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkInputPort.h
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInstantiator Class Reference

create an instance of any VTK class from its name. More...

#include <vtkInstantiator.h>

Inheritance diagram for vtkInstantiator:

[legend]
Collaboration diagram for vtkInstantiator:

[legend]
List of all members.

Public Types

typedef vtkObject *(* | CreateFunction )()

Public Methods

vtkTypeRevisionMacro (vtkInstantiator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkInstantiator * | New ()
vtkObject * | CreateInstance (const char *className)
void | RegisterInstantiator (const char *className, CreateFunction createFunction)
void | UnRegisterInstantiator (const char *className, CreateFunction createFunction)

Protected Methods

vtkInstantiator ()
~vtkInstantiator ()

Static Protected Methods

void | ClassInitialize ()
void | ClassFinalize ()

Static Protected Attributes

vtkInstantiatorHashTable * | CreatorTable

Friends

class | vtkInstantiatorInitialize

Detailed Description

create an instance of any VTK class from its name.

Date:
2002/01/22 15:25:31
Revision:
1.3

vtkInstantiator provides an interface to create an instance of any VTK class from its name. Instances are created through registered pointers to functions returning the objects. New classes can also be registered with the creator. VTK libraries automatically register their classes with the creator when they are loaded. Instances are created using the static New() method, so the normal vtkObjectFactory mechanism is still invoked.

When using this class from language wrappers (Tcl, Python, or Java), the vtkInstantiator should be able to create any class from any kit that has been loaded.

In C++ code, one should include the header for each kit from which one wishes to create instances through vtkInstantiator. This is necessary to ensure proper linking when building static libraries. Be careful, though, because including each kit's header means every class from that kit will be linked into your executable whether or not the class is used. The headers are:

vtkCommon - vtkCommonInstantiator.h vtkFiltering - vtkFilteringInstantiator.h vtkIO - vtkIOInstantiator.h vtkImaging - vtkImagingInstantiator.h vtkGraphics - vtkGraphicsInstantiator.h vtkRendering - vtkRenderingInstantiator.h vtkHybrid - vtkHybridInstantiator.h vtkParallel - vtkParallelInstantiator.h vtkPatented - vtkPatentedInstantiator.h

The VTK_MAKE_INSTANTIATOR() command in CMake is used to automatically generate the creator registration for each VTK library. It can also be used to create registration code for VTK-style user libraries that are linked to vtkCommon. After using this command to register classes from a new library, the generated header must be included.

Created by:
  • King, Brad
Contributed by (if > 5%):
  • King, Brad (100%)

Definition at line 73 of file vtkInstantiator.h.

Member Typedef Documentation

typedef vtkObject*(* vtkInstantiator::CreateFunction)()

Constructor & Destructor Documentation

vtkInstantiator::vtkInstantiator ( ) [protected]

vtkInstantiator::~vtkInstantiator ( ) [protected]

Member Function Documentation

vtkInstantiator* vtkInstantiator::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkInstantiator::vtkTypeRevisionMacro | ( | vtkInstantiator | ,
 |  | vtkObject |
 | ) |

void vtkInstantiator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkObject* vtkInstantiator::CreateInstance ( const char * className ) [static]

Create an instance of the class whose name is given. If creation fails, a NULL pointer is returned.

void vtkInstantiator::RegisterInstantiator | ( | const char * | className,
 |  | CreateFunction | createFunction
 | ) | [static]

Register a function to create instances of the class whose name is given. This allows more than one create function to be registered for the same class. The first one registered is used until it is unregistered.

void vtkInstantiator::UnRegisterInstantiator | ( | const char * | className,
 |  | CreateFunction | createFunction
 | ) | [static]

Unregister the instance creation of the class whose name is given. This will unregister the function given, but any other function registered for the same class will be left untouched.

void vtkInstantiator::ClassInitialize ( ) [static, protected]

void vtkInstantiator::ClassFinalize ( ) [static, protected]

Friends And Related Function Documentation

friend class vtkInstantiatorInitialize [friend]

Definition at line 116 of file vtkInstantiator.h.

Member Data Documentation

vtkInstantiatorHashTable* vtkInstantiator::CreatorTable [static, protected]

Definition at line 110 of file vtkInstantiator.h.

The documentation for this class was generated from the following file:
  • Common/vtkInstantiator.h
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInstantiatorInitialize Class Reference

#include <vtkInstantiator.h>

Collaboration diagram for vtkInstantiatorInitialize:

[legend]
List of all members.

Public Methods

vtkInstantiatorInitialize ()
~vtkInstantiatorInitialize ()

Constructor & Destructor Documentation

vtkInstantiatorInitialize::vtkInstantiatorInitialize ( )

vtkInstantiatorInitialize::~vtkInstantiatorInitialize ( )

The documentation for this class was generated from the following file:
  • Common/vtkInstantiator.h
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIntArray Class Reference

dynamic, self-adjusting integer array. More...

#include <vtkIntArray.h>

Inheritance diagram for vtkIntArray:

[legend]
Collaboration diagram for vtkIntArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIntArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataTypeSize ()
virtual void | Resize (vtkIdType numTuples)
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const int i)
vtkIdType | InsertNextValue (const int i)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
int * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *ia)
int | GetDataType ()
void | Squeeze ()
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
int | GetValue (const vtkIdType id)
void | SetValue (const vtkIdType id, const int value)
int * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (int *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkIntArray * | New ()

Protected Methods

vtkIntArray (vtkIdType numComp=1)
~vtkIntArray ()
int * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

int * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting integer array.

Date:
2002/02/13 22:46:29
Revision:
1.72

vtkIntArray is an array of integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (41%)
  • Martin, Ken (31%)
  • Geveci, Berk (6%)
  • Henderson, Amy (5%)
Examples:
vtkIntArray (Examples)
Tests:
vtkIntArray (Tests)

Definition at line 47 of file vtkIntArray.h.

Constructor & Destructor Documentation

vtkIntArray::vtkIntArray ( vtkIdType numComp = 1 ) [protected]

vtkIntArray::~vtkIntArray ( ) [protected]

Member Function Documentation

vtkIntArray* vtkIntArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkIntArray::vtkTypeRevisionMacro | ( | vtkIntArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkIntArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkIntArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkIntArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkIntArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkIntArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 67 of file vtkIntArray.h.

int vtkIntArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 72 of file vtkIntArray.h.

void vtkIntArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 76 of file vtkIntArray.h.

virtual void vtkIntArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void vtkIntArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkIntArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkIntArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkIntArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkIntArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIntArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIntArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkIntArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkIntArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkIntArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

int vtkIntArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 118 of file vtkIntArray.h.

void vtkIntArray::SetValue | ( | const vtkIdType | id,
 |  | const int | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 125 of file vtkIntArray.h.

void vtkIntArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 203 of file vtkIntArray.h.

void vtkIntArray::InsertValue | ( | const vtkIdType | id,
 |  | const int | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 224 of file vtkIntArray.h.

Referenced by InsertNextValue().

vtkIdType vtkIntArray::InsertNextValue ( const int i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 237 of file vtkIntArray.h.

float vtkIntArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkIntArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

virtual void vtkIntArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

int* vtkIntArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 160 of file vtkIntArray.h.

void* vtkIntArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 162 of file vtkIntArray.h.

int * vtkIntArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 209 of file vtkIntArray.h.

void vtkIntArray::DeepCopy ( vtkDataArray * ia ) [virtual]

Deep copy of another integer array.

Reimplemented from vtkDataArray.

void vtkIntArray::SetArray | ( | int * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkIntArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 182 of file vtkIntArray.h.

int* vtkIntArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

int* vtkIntArray::Array [protected]

Definition at line 190 of file vtkIntArray.h.

int vtkIntArray::TupleSize [protected]

Definition at line 193 of file vtkIntArray.h.

float* vtkIntArray::Tuple [protected]

Definition at line 194 of file vtkIntArray.h.

int vtkIntArray::SaveUserArray [protected]

Definition at line 196 of file vtkIntArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkIntArray.h
Generated on Mon Mar 25 01:20:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyle Class Reference

provide event-driven interface to the rendering window (defines trackball mode). More...

#include <vtkInteractorStyle.h>

Inheritance diagram for vtkInteractorStyle:

[legend]
Collaboration diagram for vtkInteractorStyle:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyle, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | OnTimer ()
virtual void | SetInteractor (vtkRenderWindowInteractor *interactor)
virtual vtkRenderWindowInteractor * | GetInteractor ()
virtual void | SetAutoAdjustCameraClippingRange (int)
virtual int | GetAutoAdjustCameraClippingRange ()
virtual void | AutoAdjustCameraClippingRangeOn ()
virtual void | AutoAdjustCameraClippingRangeOff ()
void | FindPokedCamera (int, int)
void | FindPokedRenderer (int, int)
virtual void | HighlightProp (vtkProp *prop)
virtual void | HighlightActor2D (vtkActor2D *actor2D)
virtual void | HighlightProp3D (vtkProp3D *prop3D)
virtual void | SetPickColor (float, float, float)
virtual void | SetPickColor (float[3])
virtual float * | GetPickColor ()
virtual void | GetPickColor (float data[3])
virtual void | OnMouseMove (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnRightButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnRightButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
virtual void | OnKeyDown (int ctrl, int shift, char keycode, int repeatcount)
virtual void | OnKeyUp (int ctrl, int shift, char keycode, int repeatcount)
virtual void | OnKeyPress (int ctrl, int shift, char keycode, char *keysym, int repeatcount)
virtual void | OnKeyRelease (int ctrl, int shift, char keycode, char *keysym, int repeatcount)
virtual void | OnConfigure (int width, int height)
virtual void | OnEnter (int ctrl, int shift, int x, int y)
virtual void | OnLeave (int ctrl, int shift, int x, int y)
void | SetLeftButtonPressMethod (void(*f)(void *), void *arg)
void | SetLeftButtonPressMethodArgDelete (void(*f)(void *))
void | SetLeftButtonReleaseMethod (void(*f)(void *), void *arg)
void | SetLeftButtonReleaseMethodArgDelete (void(*f)(void *))
void | SetMiddleButtonPressMethod (void(*f)(void *), void *arg)
void | SetMiddleButtonPressMethodArgDelete (void(*f)(void *))
void | SetMiddleButtonReleaseMethod (void(*f)(void *), void *arg)
void | SetMiddleButtonReleaseMethodArgDelete (void(*f)(void *))
void | SetRightButtonPressMethod (void(*f)(void *), void *arg)
void | SetRightButtonPressMethodArgDelete (void(*f)(void *))
void | SetRightButtonReleaseMethod (void(*f)(void *), void *arg)
void | SetRightButtonReleaseMethodArgDelete (void(*f)(void *))

Static Public Methods

vtkInteractorStyle * | New ()

Protected Methods

vtkInteractorStyle ()
~vtkInteractorStyle ()
virtual void | SetHandleObservers (int)
virtual int | GetHandleObservers ()
virtual void | HandleObserversOn ()
virtual void | HandleObserversOff ()
void | ResetCameraClippingRange ()
virtual void | ComputeDisplayToWorld (double x, double y, double z, double *worldPt)
virtual void | ComputeWorldToDisplay (double x, double y, double z, double *displayPt)
virtual void | ComputeDisplayToWorld (double x, double y, double z, float *worldPt)
virtual void | ComputeWorldToDisplay (double x, double y, double z, float *displayPt)
virtual void | UpdateInternalState (int ctrl, int shift, int X, int Y)
virtual void | RotateCamera (int x, int y)
virtual void | SpinCamera (int x, int y)
virtual void | PanCamera (int x, int y)
virtual void | DollyCamera (int x, int y)
virtual void | StartState (int newstate)
virtual void | StopState ()
virtual void | StartAnimate ()
virtual void | StopAnimate ()
virtual void | StartRotate ()
virtual void | EndRotate ()
virtual void | StartZoom ()
virtual void | EndZoom ()
virtual void | StartPan ()
virtual void | EndPan ()
virtual void | StartSpin ()
virtual void | EndSpin ()
virtual void | StartDolly ()
virtual void | EndDolly ()
virtual void | StartUniformScale ()
virtual void | EndUniformScale ()
virtual void | StartTimer ()
virtual void | EndTimer ()

Static Protected Methods

void | ProcessEvents (vtkObject *object, unsigned long event, void *clientdata, void *calldata)

Protected Attributes

int | AutoAdjustCameraClippingRange
vtkRenderWindowInteractor * Interactor
vtkCamera * CurrentCamera
vtkLight * CurrentLight
vtkRenderer * CurrentRenderer
float | Center [2]
float | DeltaAzimuth
float | DeltaElevation
int | CtrlKey
int | ShiftKey
int | LastPos [2]
int | State
int | AnimState
float | FocalDepth
vtkOutlineSource * Outline
vtkPolyDataMapper * OutlineMapper
vtkActor * OutlineActor
vtkRenderer * PickedRenderer
vtkProp * CurrentProp
int | PropPicked
float | PickColor [3]
vtkActor2D * PickedActor2D
vtkCallbackCommand * EventCallbackCommand
int | HandleObservers
unsigned long | LeftButtonPressTag
unsigned long | LeftButtonReleaseTag
unsigned long | MiddleButtonPressTag
unsigned long | MiddleButtonReleaseTag
unsigned long | RightButtonPressTag
unsigned long | RightButtonReleaseTag

Detailed Description

provide event-driven interface to the rendering window (defines trackball mode).

Date:
2002/03/22 19:05:26
Revision:
1.32

vtkInteractorStyle is a base class implementing the majority of motion control routines and defines an event driven interface to support vtkRenderWindowInteractor. vtkRenderWindowInteractor implements platform dependent key/mouse routing and timer control, which forwards events in a neutral form to vtkInteractorStyle.

vtkInteractorStyle implements the "joystick" style of interaction. That is, holding down the mouse keys generates a stream of events that cause continuous actions (e.g., rotate, translate, pan, zoom). (The class vtkInteractorStyleTrackball implements a grab and move style.) The event bindings for this class include the following:

  • Keypress j / Keypress t: toggle between joystick (position sensitive) and trackball (motion sensitive) styles. In joystick style, motion occurs continuously as long as a mouse button is pressed. In trackball style, motion occurs when the mouse button is pressed and the mouse pointer moves.
  • Keypress c / Keypress o: toggle between camera and object (actor) modes. In camera mode, mouse events affect the camera position and focal point. In object mode, mouse events affect the actor that is under the mouse pointer.
  • Button 1: rotate the camera around its focal point (if camera mode) or rotate the actor around its origin (if actor mode). The rotation is in the direction defined from the center of the renderer's viewport towards the mouse position. In joystick mode, the magnitude of the rotation is determined by the distance the mouse is from the center of the render window.
  • Button 2: pan the camera (if camera mode) or translate the actor (if object mode). In joystick mode, the direction of pan or translation is from the center of the viewport towards the mouse position. In trackball mode, the direction of motion is the direction the mouse moves. (Note: with 2-button mice, pan is defined as <Shift>-Button 1.)
  • Button 3: zoom the camera (if camera mode) or scale the actor (if object mode). Zoom in/increase scale if the mouse position is in the top half of the viewport; zoom out/decrease scale if the mouse position is in the bottom half. In joystick mode, the amount of zoom is controlled by the distance of the mouse pointer from the horizontal centerline of the window.
  • Keypress 3: toggle the render window into and out of stereo mode. By default, red-blue stereo pairs are created. Some systems support Crystal Eyes LCD stereo glasses; you have to invoke SetStereoTypeToCrystalEyes() on the rendering window.
  • Keypress e: exit the application.
  • Keypress f: fly to the picked point
  • Keypress p: perform a pick operation. The render window interactor has an internal instance of vtkCellPicker that it uses to pick.
  • Keypress r: reset the camera view along the current view direction. Centers the actors and moves the camera so that all actors are visible.
  • Keypress s: modify the representation of all actors so that they are surfaces.
  • Keypress u: invoke the user-defined function. Typically, this keypress will bring up an interactor that you can type commands in.
  • Keypress w: modify the representation of all actors so that they are wireframe.
vtkInteractorStyle can be subclassed to provide new interaction styles and a facility to override any of the default mouse/key operations which currently handle trackball or joystick styles is provided.

See also:
vtkInteractorStyleTrackball
Events:
vtkCommand::LeftButtonReleaseEvent vtkCommand::RightButtonPressEvent vtkCommand::MiddleButtonReleaseEvent vtkCommand::MouseMoveEvent vtkCommand::EnterEvent vtkCommand::TimerEvent vtkCommand::KeyPressEvent vtkCommand::MiddleButtonPressEvent vtkCommand::RightButtonReleaseEvent vtkCommand::ConfigureEvent vtkCommand::LeaveEvent vtkCommand::LeftButtonPressEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (55%)
  • Schroeder, Will (14%)
  • Hoffman, Bill (13%)
  • Avila, Lisa (6%)

Definition at line 119 of file vtkInteractorStyle.h.

Constructor & Destructor Documentation

vtkInteractorStyle::vtkInteractorStyle ( ) [protected]

vtkInteractorStyle::~vtkInteractorStyle ( ) [protected]

Member Function Documentation

vtkInteractorStyle* vtkInteractorStyle::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkObject.

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

vtkInteractorStyle::vtkTypeRevisionMacro | ( | vtkInteractorStyle | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

void vtkInteractorStyle::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::SetInteractor ( vtkRenderWindowInteractor * iren ) [virtual]

Set/Get the Interactor wrapper being controlled by this object.

Reimplemented in vtkInteractorStyleSwitch.

virtual vtkRenderWindowInteractor* vtkInteractorStyle::GetInteractor ( ) [virtual]

Set/Get the Interactor wrapper being controlled by this object.

virtual void vtkInteractorStyle::SetAutoAdjustCameraClippingRange ( int value ) [virtual]

If AutoAdjustCameraClippingRange is on, then before each render the camera clipping range will be adjusted to "fit" the whole scene. Clipping will still occur if objects in the scene are behind the camera or come very close. If AutoAdjustCameraClippingRange is off, no adjustment will be made per render, but the camera clipping range will still be reset when the camera is reset.

Reimplemented in vtkInteractorStyleSwitch.

virtual int vtkInteractorStyle::GetAutoAdjustCameraClippingRange ( ) [virtual]

If AutoAdjustCameraClippingRange is on, then before each render the camera clipping range will be adjusted to "fit" the whole scene. Clipping will still occur if objects in the scene are behind the camera or come very close. If AutoAdjustCameraClippingRange is off, no adjustment will be made per render, but the camera clipping range will still be reset when the camera is reset.

virtual void vtkInteractorStyle::AutoAdjustCameraClippingRangeOn ( ) [virtual]

If AutoAdjustCameraClippingRange is on, then before each render the camera clipping range will be adjusted to "fit" the whole scene. Clipping will still occur if objects in the scene are behind the camera or come very close. If AutoAdjustCameraClippingRange is off, no adjustment will be made per render, but the camera clipping range will still be reset when the camera is reset.

virtual void vtkInteractorStyle::AutoAdjustCameraClippingRangeOff ( ) [virtual]

If AutoAdjustCameraClippingRange is on, then before each render the camera clipping range will be adjusted to "fit" the whole scene. Clipping will still occur if objects in the scene are behind the camera or come very close. If AutoAdjustCameraClippingRange is off, no adjustment will be made per render, but the camera clipping range will still be reset when the camera is reset.

void vtkInteractorStyle::FindPokedCamera | ( | int | ,
 |  | int |
 | ) |

When an event occurs, we must determine which Renderer the event occurred within, since one RenderWindow may contain multiple renderers. We also need to know what camera to operate on. This is just the ActiveCamera of the poked renderer.

void vtkInteractorStyle::FindPokedRenderer | ( | int | ,
 |  | int |
 | ) |

When an event occurs, we must determine which Renderer the event occurred within, since one RenderWindow may contain multiple renderers. We also need to know what camera to operate on. This is just the ActiveCamera of the poked renderer.

virtual void vtkInteractorStyle::HighlightProp ( vtkProp * prop ) [virtual]

When picking successfully selects an actor, this method highlights the picked prop appropriately. Currently this is done by placing a bounding box around a picked vtkProp3D, and using the PickColor to highlight a vtkProp2D.

virtual void vtkInteractorStyle::HighlightActor2D ( vtkActor2D * actor2D ) [virtual]

When picking successfully selects an actor, this method highlights the picked prop appropriately. Currently this is done by placing a bounding box around a picked vtkProp3D, and using the PickColor to highlight a vtkProp2D.

virtual void vtkInteractorStyle::HighlightProp3D ( vtkProp3D * prop3D ) [virtual]

When picking successfully selects an actor, this method highlights the picked prop appropriately. Currently this is done by placing a bounding box around a picked vtkProp3D, and using the PickColor to highlight a vtkProp2D.

virtual void vtkInteractorStyle::SetPickColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the pick color (used by default to color vtkActor2D's). The color is expressed as red/green/blue values between (0.0,1.0).

virtual void vtkInteractorStyle::SetPickColor ( float [3] ) [virtual]

Set/Get the pick color (used by default to color vtkActor2D's). The color is expressed as red/green/blue values between (0.0,1.0).

virtual float* vtkInteractorStyle::GetPickColor ( ) [virtual]

Set/Get the pick color (used by default to color vtkActor2D's). The color is expressed as red/green/blue values between (0.0,1.0).

virtual void vtkInteractorStyle::GetPickColor ( float data[3] ) [virtual]

Set/Get the pick color (used by default to color vtkActor2D's). The color is expressed as red/green/blue values between (0.0,1.0).

virtual void vtkInteractorStyle::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Generic event bindings must be overridden in subclasses

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, and vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnKeyDown | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented in vtkInteractorStyleFlight.

virtual void vtkInteractorStyle::OnKeyUp | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented in vtkInteractorStyleFlight.

virtual void vtkInteractorStyle::OnKeyPress | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | char * | keysym,
 |  | int | repeatcount
 | ) | [virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented in vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnKeyRelease | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | char * | keysym,
 |  | int | repeatcount
 | ) | [virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented in vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnConfigure | ( | int | width,
 |  | int | height
 | ) | [virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented in vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnEnter | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented in vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnLeave | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented in vtkInteractorStyleUser.

virtual void vtkInteractorStyle::OnTimer ( void ) [virtual]

OnTimer calls RotateCamera, RotateActor etc which should be overridden by style subclasses.

Reimplemented in vtkInteractorStyleFlight, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackball, vtkInteractorStyleUnicam, and vtkInteractorStyleUser.

void vtkInteractorStyle::SetLeftButtonPressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetLeftButtonPressMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetLeftButtonReleaseMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetLeftButtonReleaseMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetMiddleButtonPressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetMiddleButtonPressMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetMiddleButtonReleaseMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetMiddleButtonReleaseMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetRightButtonPressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetRightButtonPressMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetRightButtonReleaseMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Callbacks so that the application can override the default behaviour.

void vtkInteractorStyle::SetRightButtonReleaseMethodArgDelete ( void(* f)(void *) )

Callbacks so that the application can override the default behaviour.

virtual void vtkInteractorStyle::SetHandleObservers ( int ) [protected, virtual]

virtual int vtkInteractorStyle::GetHandleObservers ( ) [protected, virtual]

virtual void vtkInteractorStyle::HandleObserversOn ( ) [protected, virtual]

virtual void vtkInteractorStyle::HandleObserversOff ( ) [protected, virtual]

void vtkInteractorStyle::ResetCameraClippingRange ( ) [protected]

virtual void vtkInteractorStyle::ComputeDisplayToWorld | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | double * | worldPt
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::ComputeWorldToDisplay | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | double * | displayPt
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::ComputeDisplayToWorld | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | float * | worldPt
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::ComputeWorldToDisplay | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | float * | displayPt
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::UpdateInternalState | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::RotateCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::SpinCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::PanCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::DollyCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyle::StartState ( int newstate ) [protected, virtual]

virtual void vtkInteractorStyle::StopState ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartAnimate ( ) [protected, virtual]

virtual void vtkInteractorStyle::StopAnimate ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartRotate ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndRotate ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartZoom ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndZoom ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartPan ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndPan ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartSpin ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndSpin ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartDolly ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndDolly ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartUniformScale ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndUniformScale ( ) [protected, virtual]

virtual void vtkInteractorStyle::StartTimer ( ) [protected, virtual]

virtual void vtkInteractorStyle::EndTimer ( ) [protected, virtual]

void vtkInteractorStyle::ProcessEvents | ( | vtkObject * | object,
 |  | unsigned long | event,
 |  | void * | clientdata,
 |  | void * | calldata
 | ) | [static, protected]

Member Data Documentation

int vtkInteractorStyle::AutoAdjustCameraClippingRange [protected]

Definition at line 233 of file vtkInteractorStyle.h.

vtkRenderWindowInteractor* vtkInteractorStyle::Interactor [protected]

Definition at line 283 of file vtkInteractorStyle.h.

vtkCamera* vtkInteractorStyle::CurrentCamera [protected]

Definition at line 285 of file vtkInteractorStyle.h.

vtkLight* vtkInteractorStyle::CurrentLight [protected]

Definition at line 286 of file vtkInteractorStyle.h.

vtkRenderer* vtkInteractorStyle::CurrentRenderer [protected]

Definition at line 287 of file vtkInteractorStyle.h.

float vtkInteractorStyle::Center[2] [protected]

Reimplemented in vtkInteractorStyleUnicam.

Definition at line 289 of file vtkInteractorStyle.h.

float vtkInteractorStyle::DeltaAzimuth [protected]

Definition at line 290 of file vtkInteractorStyle.h.

float vtkInteractorStyle::DeltaElevation [protected]

Definition at line 291 of file vtkInteractorStyle.h.

int vtkInteractorStyle::CtrlKey [protected]

Definition at line 292 of file vtkInteractorStyle.h.

int vtkInteractorStyle::ShiftKey [protected]

Definition at line 293 of file vtkInteractorStyle.h.

int vtkInteractorStyle::LastPos[2] [protected]

Reimplemented in vtkInteractorStyleUnicam.

Definition at line 294 of file vtkInteractorStyle.h.

int vtkInteractorStyle::State [protected]

Reimplemented in vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleTrackballActor, and vtkInteractorStyleTrackballCamera.

Definition at line 295 of file vtkInteractorStyle.h.

int vtkInteractorStyle::AnimState [protected]

Definition at line 296 of file vtkInteractorStyle.h.

float vtkInteractorStyle::FocalDepth [protected]

Definition at line 297 of file vtkInteractorStyle.h.

vtkOutlineSource* vtkInteractorStyle::Outline [protected]

Definition at line 300 of file vtkInteractorStyle.h.

vtkPolyDataMapper* vtkInteractorStyle::OutlineMapper [protected]

Definition at line 301 of file vtkInteractorStyle.h.

vtkActor* vtkInteractorStyle::OutlineActor [protected]

Definition at line 302 of file vtkInteractorStyle.h.

vtkRenderer* vtkInteractorStyle::PickedRenderer [protected]

Definition at line 303 of file vtkInteractorStyle.h.

vtkProp* vtkInteractorStyle::CurrentProp [protected]

Definition at line 304 of file vtkInteractorStyle.h.

int vtkInteractorStyle::PropPicked [protected]

Reimplemented in vtkInteractorStyleTrackball.

Definition at line 305 of file vtkInteractorStyle.h.

float vtkInteractorStyle::PickColor[3] [protected]

Definition at line 306 of file vtkInteractorStyle.h.

vtkActor2D* vtkInteractorStyle::PickedActor2D [protected]

Definition at line 307 of file vtkInteractorStyle.h.

vtkCallbackCommand* vtkInteractorStyle::EventCallbackCommand [protected]

Definition at line 308 of file vtkInteractorStyle.h.

int vtkInteractorStyle::HandleObservers [protected]

Definition at line 309 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::LeftButtonPressTag [protected]

Definition at line 311 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::LeftButtonReleaseTag [protected]

Definition at line 312 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::MiddleButtonPressTag [protected]

Definition at line 313 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::MiddleButtonReleaseTag [protected]

Definition at line 314 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::RightButtonPressTag [protected]

Definition at line 315 of file vtkInteractorStyle.h.

unsigned long vtkInteractorStyle::RightButtonReleaseTag [protected]

Definition at line 316 of file vtkInteractorStyle.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyle.h
Generated on Mon Mar 25 01:20:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleFlight Class Reference

provides flight motion routines. More...

#include <vtkInteractorStyleFlight.h>

Inheritance diagram for vtkInteractorStyleFlight:

[legend]
Collaboration diagram for vtkInteractorStyleFlight:

[legend]
List of all members.

[NOHEADER]

void | DoTimerStart (void)
void | DoTimerStop (void)
void | UpdateMouseSteering (int x, int y)
void | FlyByMouse (void)
void | FlyByKey (void)
void | ComputeLRVector (double vector[3])
void | MotionAlongVector (double vector[3], double amount)
void | SetupMotionVars (void)
void | AzimuthScan (void)
unsigned char | KeysDown
int | Flying
int | Reversing
int | TimerRunning
int | AzimuthScanning
int | DisableMotion
int | FixUpVector
double | OldX
double | OldY
double | X2
double | Y2
double | DiagonalLength
double | MotionStepSize
double | MotionUserScale
double | MotionAccelerationFactor
double | AngleStepSize
double | AngleAccelerationFactor
double | YawAngle
double | PitchAngle
double | FixedUpVector [3]
double | AzimuthStepSize

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleFlight, vtkInteractorStyle)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | OnTimer (void)
void | JumpTo (double campos[3], double focpos[3])
void | PerformAzimuthalScan (int numsteps)
virtual double * | GetFixedUpVector ()
virtual void | GetFixedUpVector (double data[3])
virtual void | SetFixedUpVector (double data[])
virtual void | OnRightButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnRightButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnMouseMove (int ctrl, int shift, int X, int Y)
virtual void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
virtual void | OnKeyDown (int ctrl, int shift, char keycode, int repeatcount)
virtual void | OnKeyUp (int ctrl, int shift, char keycode, int repeatcount)
virtual void | SetMotionStepSize (double)
virtual double | GetMotionStepSize ()
virtual void | SetMotionAccelerationFactor (double)
virtual double | GetMotionAccelerationFactor ()
virtual void | SetAngleStepSize (double)
virtual double | GetAngleStepSize ()
virtual void | SetAngleAccelerationFactor (double)
virtual double | GetAngleAccelerationFactor ()
virtual void | SetDisableMotion (int)
virtual int | GetDisableMotion ()
virtual void | DisableMotionOn ()
virtual void | DisableMotionOff ()
virtual void | SetFixUpVector (int)
virtual int | GetFixUpVector ()
virtual void | FixUpVectorOn ()
virtual void | FixUpVectorOff ()

Static Public Methods

vtkInteractorStyleFlight * | New ()

Protected Methods

vtkInteractorStyleFlight ()
~vtkInteractorStyleFlight ()

Detailed Description

provides flight motion routines.

Date:
2002/01/22 15:38:36
Revision:
1.13

Left mouse button press produces forward motion. Right mouse button press produces reverse motion. Moving mouse during motion steers user in desired direction. Keyboard controls are: Left/Right/Up/Down Arrows for steering direction 'A' forward, 'Z' reverse motion Ctrl Key causes sidestep instead of steering in mouse and key modes Shift key is accelerator in mouse and key modes Ctrl and Shift together causes Roll in mouse and key modes

Stationary 'look' can be achieved by holding both mouse buttons down and steering with the mouse. Stationary 'look' can also be achieved by holding 'Z' (or 'A') and steering with mouse in forward (or reverse) motion mode. By default, one "step" of motion corresponds to 1/250th of the diagonal of bounding box of visible actors, '+' and '-' keys allow user to increase or decrease step size.

Created by:
  • Biddiscombe, John
Contributed by (if > 5%):
  • Biddiscombe, John (68%)
  • Davis, Jon (23%)

Definition at line 55 of file vtkInteractorStyleFlight.h.

Constructor & Destructor Documentation

vtkInteractorStyleFlight::vtkInteractorStyleFlight ( ) [protected]

vtkInteractorStyleFlight::~vtkInteractorStyleFlight ( ) [protected]

Member Function Documentation

vtkInteractorStyleFlight* vtkInteractorStyleFlight::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleFlight::vtkTypeRevisionMacro | ( | vtkInteractorStyleFlight | ,
 |  | vtkInteractorStyle |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleFlight::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of Mouse event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Concrete implementation of Keyboard event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnKeyDown | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Concrete implementation of Keyboard event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnKeyUp | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Concrete implementation of Keyboard event bindings for flight

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleFlight::OnTimer ( void ) [virtual]

Mouse and key events set correct motion states, OnTimer performs the motion

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleFlight::JumpTo | ( | double | campos[3],
 |  | double | focpos[3]
 | ) |

Move the Eye/Camera to a specific location (no intermediate steps are taken

void vtkInteractorStyleFlight::PerformAzimuthalScan ( int numsteps )

rotate the camera round z axis by 360 degrees for viewing scene this routine starts a timer and disables key/mouse events preventing user interaction until finished (not fully implemented yet) the number of steps can be supplied.

virtual void vtkInteractorStyleFlight::SetMotionStepSize ( double ) [virtual]

Set the basic unit step size : by default 1/250 of bounding diagonal

virtual double vtkInteractorStyleFlight::GetMotionStepSize ( ) [virtual]

Set the basic unit step size : by default 1/250 of bounding diagonal

virtual void vtkInteractorStyleFlight::SetMotionAccelerationFactor ( double ) [virtual]

Set acceleration factor when shift key is applied : default 10

virtual double vtkInteractorStyleFlight::GetMotionAccelerationFactor ( ) [virtual]

Set acceleration factor when shift key is applied : default 10

virtual void vtkInteractorStyleFlight::SetAngleStepSize ( double ) [virtual]

Set the basic angular unit for turning : default 1 degree

virtual double vtkInteractorStyleFlight::GetAngleStepSize ( ) [virtual]

Set the basic angular unit for turning : default 1 degree

virtual void vtkInteractorStyleFlight::SetAngleAccelerationFactor ( double ) [virtual]

Set angular acceleration when shift key is applied : default 5

virtual double vtkInteractorStyleFlight::GetAngleAccelerationFactor ( ) [virtual]

Set angular acceleration when shift key is applied : default 5

virtual void vtkInteractorStyleFlight::SetDisableMotion ( int ) [virtual]

Disable motion (temporarily - for viewing etc)

virtual int vtkInteractorStyleFlight::GetDisableMotion ( ) [virtual]

Disable motion (temporarily - for viewing etc)

virtual void vtkInteractorStyleFlight::DisableMotionOn ( ) [virtual]

Disable motion (temporarily - for viewing etc)

virtual void vtkInteractorStyleFlight::DisableMotionOff ( ) [virtual]

Disable motion (temporarily - for viewing etc)

virtual void vtkInteractorStyleFlight::SetFixUpVector ( int ) [virtual]

Fix the "up" vector: also use FixedUpVector

virtual int vtkInteractorStyleFlight::GetFixUpVector ( ) [virtual]

Fix the "up" vector: also use FixedUpVector

virtual void vtkInteractorStyleFlight::FixUpVectorOn ( ) [virtual]

Fix the "up" vector: also use FixedUpVector

virtual void vtkInteractorStyleFlight::FixUpVectorOff ( ) [virtual]

Fix the "up" vector: also use FixedUpVector

virtual double* vtkInteractorStyleFlight::GetFixedUpVector ( ) [virtual]

virtual void vtkInteractorStyleFlight::GetFixedUpVector ( double data[3] ) [virtual]

virtual void vtkInteractorStyleFlight::SetFixedUpVector ( double data[] ) [virtual]

void vtkInteractorStyleFlight::DoTimerStart ( void ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::DoTimerStop ( void ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::UpdateMouseSteering | ( | int | x,
 |  | int | y
 | ) | [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::FlyByMouse ( void ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::FlyByKey ( void ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::ComputeLRVector ( double vector[3] ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::MotionAlongVector | ( | double | vector[3],
 |  | double | amount
 | ) | [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::SetupMotionVars ( void ) [protected]

Routines used internally for computing motion and steering

void vtkInteractorStyleFlight::AzimuthScan ( void ) [protected]

Routines used internally for computing motion and steering

Member Data Documentation

unsigned char vtkInteractorStyleFlight::KeysDown [protected]

Routines used internally for computing motion and steering

Definition at line 153 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::Flying [protected]

Routines used internally for computing motion and steering

Definition at line 154 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::Reversing [protected]

Routines used internally for computing motion and steering

Definition at line 155 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::TimerRunning [protected]

Routines used internally for computing motion and steering

Definition at line 156 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::AzimuthScanning [protected]

Routines used internally for computing motion and steering

Definition at line 157 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::DisableMotion [protected]

Routines used internally for computing motion and steering

Definition at line 158 of file vtkInteractorStyleFlight.h.

int vtkInteractorStyleFlight::FixUpVector [protected]

Routines used internally for computing motion and steering

Definition at line 159 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::OldX [protected]

Routines used internally for computing motion and steering

Definition at line 160 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::OldY [protected]

Routines used internally for computing motion and steering

Definition at line 161 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::X2 [protected]

Routines used internally for computing motion and steering

Definition at line 162 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::Y2 [protected]

Routines used internally for computing motion and steering

Definition at line 163 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::DiagonalLength [protected]

Routines used internally for computing motion and steering

Definition at line 164 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::MotionStepSize [protected]

Routines used internally for computing motion and steering

Definition at line 165 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::MotionUserScale [protected]

Routines used internally for computing motion and steering

Definition at line 166 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::MotionAccelerationFactor [protected]

Routines used internally for computing motion and steering

Definition at line 167 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::AngleStepSize [protected]

Routines used internally for computing motion and steering

Definition at line 168 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::AngleAccelerationFactor [protected]

Routines used internally for computing motion and steering

Definition at line 169 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::YawAngle [protected]

Routines used internally for computing motion and steering

Definition at line 170 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::PitchAngle [protected]

Routines used internally for computing motion and steering

Definition at line 171 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::FixedUpVector[3] [protected]

Routines used internally for computing motion and steering

Definition at line 172 of file vtkInteractorStyleFlight.h.

double vtkInteractorStyleFlight::AzimuthStepSize [protected]

Routines used internally for computing motion and steering

Definition at line 173 of file vtkInteractorStyleFlight.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleFlight.h
Generated on Mon Mar 25 01:20:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleImage Class Reference

interactive manipulation of the camera specialized for images. More...

#include <vtkInteractorStyleImage.h>

Inheritance diagram for vtkInteractorStyleImage:

[legend]
Collaboration diagram for vtkInteractorStyleImage:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleImage, vtkInteractorStyle)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
void | OnMouseMove (int ctrl, int shift, int x, int y)
void | OnLeftButtonDown (int ctrl, int shift, int x, int y)
void | OnLeftButtonUp (int ctrl, int shift, int x, int y)
void | OnMiddleButtonDown (int ctrl, int shift, int x, int y)
void | OnMiddleButtonUp (int ctrl, int shift, int x, int y)
void | OnRightButtonDown (int ctrl, int shift, int x, int y)
void | OnRightButtonUp (int ctrl, int shift, int x, int y)
virtual int * | GetWindowLevelStartPosition ()
virtual void | GetWindowLevelStartPosition (int &, int &)
virtual void | GetWindowLevelStartPosition (int[2])
virtual int * | GetWindowLevelCurrentPosition ()
virtual void | GetWindowLevelCurrentPosition (int &, int &)
virtual void | GetWindowLevelCurrentPosition (int[2])

Static Public Methods

vtkInteractorStyleImage * | New ()

Protected Methods

vtkInteractorStyleImage ()
~vtkInteractorStyleImage ()
void | WindowLevelXY (int dx, int dy)
void | PanXY (int x, int y, int oldX, int oldY)
void | DollyXY (int dx, int dy)
void | SpinXY (int dx, int dy, int oldX, int oldY)

Protected Attributes

int | WindowLevelStartPosition [2]
int | WindowLevelCurrentPosition [2]
int | State
float | MotionFactor
float | RadianToDegree

Detailed Description

interactive manipulation of the camera specialized for images.

Date:
2002/01/24 17:57:53
Revision:
1.7

vtkInteractorStyleImage allows the user to interactively manipulate (rotate, pan, zoomm etc.) the camera. vtkInteractorStyleImage is specially designed to work with images that are being rendered with vtkImageActor. Several events are overloaded from its superclass vtkInteractorStyle, hence the mouse bindings are different. (The bindings keep the camera's view plane normal perpendicular to the x-y plane.) In summary the mouse events are as follows: + CTRL Left Mouse spins the camera around its view plane normal + SHIFT Left Mouse pans the camera + CTRL SHIFT Left Mouse dollys (a positional zoom) the camera + Middle mouse button pans the camera + Right mouse button dollys the camera.

Note that the renderer's actors are not moved; instead the camera is moved.

See also:
vtkInteractorStyle vtkInteractorStyleTrackballActor vtkInteractorStyleJoystickCamera vtkInteractorStyleJoystickActor
Events:
vtkCommand::WindowLevelEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (73%)
  • Schroeder, Will (19%)
Examples:
vtkInteractorStyleImage (Examples)

Definition at line 67 of file vtkInteractorStyleImage.h.

Constructor & Destructor Documentation

vtkInteractorStyleImage::vtkInteractorStyleImage ( ) [protected]

vtkInteractorStyleImage::~vtkInteractorStyleImage ( ) [protected]

Member Function Documentation

vtkInteractorStyleImage* vtkInteractorStyleImage::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleImage::vtkTypeRevisionMacro | ( | vtkInteractorStyleImage | ,
 |  | vtkInteractorStyle |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleImage::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Override the "fly-to" (f keypress) for images.

Reimplemented from vtkInteractorStyle.

virtual int* vtkInteractorStyleImage::GetWindowLevelStartPosition ( ) [virtual]

Some useful information for handling window level

virtual void vtkInteractorStyleImage::GetWindowLevelStartPosition | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Some useful information for handling window level

virtual void vtkInteractorStyleImage::GetWindowLevelStartPosition ( int [2] ) [virtual]

Some useful information for handling window level

virtual int* vtkInteractorStyleImage::GetWindowLevelCurrentPosition ( ) [virtual]

Some useful information for handling window level

virtual void vtkInteractorStyleImage::GetWindowLevelCurrentPosition | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Some useful information for handling window level

virtual void vtkInteractorStyleImage::GetWindowLevelCurrentPosition ( int [2] ) [virtual]

Some useful information for handling window level

void vtkInteractorStyleImage::WindowLevelXY | ( | int | dx,
 |  | int | dy
 | ) | [protected]

void vtkInteractorStyleImage::PanXY | ( | int | x,
 |  | int | y,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleImage::DollyXY | ( | int | dx,
 |  | int | dy
 | ) | [protected]

void vtkInteractorStyleImage::SpinXY | ( | int | dx,
 |  | int | dy,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

Member Data Documentation

int vtkInteractorStyleImage::WindowLevelStartPosition[2] [protected]

Definition at line 104 of file vtkInteractorStyleImage.h.

int vtkInteractorStyleImage::WindowLevelCurrentPosition[2] [protected]

Definition at line 105 of file vtkInteractorStyleImage.h.

int vtkInteractorStyleImage::State [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 106 of file vtkInteractorStyleImage.h.

float vtkInteractorStyleImage::MotionFactor [protected]

Definition at line 107 of file vtkInteractorStyleImage.h.

float vtkInteractorStyleImage::RadianToDegree [protected]

Definition at line 108 of file vtkInteractorStyleImage.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleImage.h
Generated on Mon Mar 25 01:21:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleJoystickActor Class Reference

manipulate objects in the scene independently of one another. More...

#include <vtkInteractorStyleJoystickActor.h>

Inheritance diagram for vtkInteractorStyleJoystickActor:

[legend]
Collaboration diagram for vtkInteractorStyleJoystickActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleJoystickActor, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnMouseMove (int ctrl, int shift, int x, int y)
void | OnLeftButtonDown (int ctrl, int shift, int x, int y)
void | OnLeftButtonUp (int ctrl, int shift, int x, int y)
void | OnMiddleButtonDown (int ctrl, int shift, int x, int y)
void | OnMiddleButtonUp (int ctrl, int shift, int x, int y)
void | OnRightButtonDown (int ctrl, int shift, int x, int y)
void | OnRightButtonUp (int ctrl, int shift, int x, int y)
void | OnTimer (void)

Static Public Methods

vtkInteractorStyleJoystickActor * | New ()

Protected Methods

vtkInteractorStyleJoystickActor ()
~vtkInteractorStyleJoystickActor ()
void | RotateXY (int x, int y)
void | PanXY (int x, int y)
void | DollyXY (int x, int y)
void | SpinXY (int x, int y)
void | ScaleXY (int x, int y)
void | FindPickedActor (int x, int y)
void | Prop3DTransform (vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale)
void | Prop3DTransform (vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale)

Protected Attributes

int | State
float | MotionFactor
float | RadianToDegree
vtkProp3D * InteractionProp
double | ViewUp [3]
double | ViewLook [3]
double | ViewRight [3]
float | ObjCenter [3]
float | DispObjCenter [3]
float | Radius
float | NewPickPoint [4]
float | OldPickPoint [4]
float | MotionVector [3]
double | ViewPoint [3]
double | ViewFocus [3]
vtkCellPicker * InteractionPicker

Detailed Description

manipulate objects in the scene independently of one another.

Date:
2002/01/22 15:38:36
Revision:
1.9

The class vtkInteractorStyleJoystickActor allows the user to interact with (rotate, zoom, etc.) separate objects in the scene independent of each other. The position of the mouse relative to the center of the object determines the speed of the object's motion. The mouse's velocity detemines the acceleration of the object's motion, so the object will continue moving even when the mouse is not moving. For a 3-button mouse, the left button is for rotation, the right button for zooming, the middle button for panning, and ctrl + left button for spinning. (With fewer mouse buttons, ctrl + shift + left button is for zooming, and shift + left button is for panning.)

See also:
vtkInteractorStyleJoystickCamera vtkInteractorStyleTrackballActor vtkInteractorStyleTrackballCamera
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (90%)

Definition at line 57 of file vtkInteractorStyleJoystickActor.h.

Constructor & Destructor Documentation

vtkInteractorStyleJoystickActor::vtkInteractorStyleJoystickActor ( ) [protected]

vtkInteractorStyleJoystickActor::~vtkInteractorStyleJoystickActor ( ) [protected]

Member Function Documentation

vtkInteractorStyleJoystickActor* vtkInteractorStyleJoystickActor::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleJoystickActor::vtkTypeRevisionMacro | ( | vtkInteractorStyleJoystickActor | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::OnTimer ( void ) [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickActor::RotateXY | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::PanXY | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::DollyXY | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::SpinXY | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::ScaleXY | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::FindPickedActor | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleJoystickActor::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | double * | boxCenter,
 |  | int | numRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

void vtkInteractorStyleJoystickActor::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | float * | boxCenter,
 |  | int | NumRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

Member Data Documentation

int vtkInteractorStyleJoystickActor::State [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 95 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::MotionFactor [protected]

Definition at line 96 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::RadianToDegree [protected]

Definition at line 97 of file vtkInteractorStyleJoystickActor.h.

vtkProp3D* vtkInteractorStyleJoystickActor::InteractionProp [protected]

Definition at line 98 of file vtkInteractorStyleJoystickActor.h.

double vtkInteractorStyleJoystickActor::ViewUp[3] [protected]

Definition at line 99 of file vtkInteractorStyleJoystickActor.h.

double vtkInteractorStyleJoystickActor::ViewLook[3] [protected]

Definition at line 100 of file vtkInteractorStyleJoystickActor.h.

double vtkInteractorStyleJoystickActor::ViewRight[3] [protected]

Definition at line 101 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::ObjCenter[3] [protected]

Definition at line 102 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::DispObjCenter[3] [protected]

Definition at line 103 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::Radius [protected]

Definition at line 104 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::NewPickPoint[4] [protected]

Definition at line 105 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::OldPickPoint[4] [protected]

Definition at line 106 of file vtkInteractorStyleJoystickActor.h.

float vtkInteractorStyleJoystickActor::MotionVector[3] [protected]

Definition at line 107 of file vtkInteractorStyleJoystickActor.h.

double vtkInteractorStyleJoystickActor::ViewPoint[3] [protected]

Definition at line 108 of file vtkInteractorStyleJoystickActor.h.

double vtkInteractorStyleJoystickActor::ViewFocus[3] [protected]

Definition at line 109 of file vtkInteractorStyleJoystickActor.h.

vtkCellPicker* vtkInteractorStyleJoystickActor::InteractionPicker [protected]

Definition at line 111 of file vtkInteractorStyleJoystickActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleJoystickActor.h
Generated on Mon Mar 25 01:21:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleJoystickCamera Class Reference

interactive manipulation of the camera. More...

#include <vtkInteractorStyleJoystickCamera.h>

Inheritance diagram for vtkInteractorStyleJoystickCamera:

[legend]
Collaboration diagram for vtkInteractorStyleJoystickCamera:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleJoystickCamera, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnMouseMove (int ctrl, int shift, int x, int y)
void | OnLeftButtonDown (int ctrl, int shift, int x, int y)
void | OnLeftButtonUp (int ctrl, int shift, int x, int y)
void | OnMiddleButtonDown (int ctrl, int shift, int x, int y)
void | OnMiddleButtonUp (int ctrl, int shift, int x, int y)
void | OnRightButtonDown (int ctrl, int shift, int x, int y)
void | OnRightButtonUp (int ctrl, int shift, int x, int y)
void | OnTimer (void)

Static Public Methods

vtkInteractorStyleJoystickCamera * | New ()

Protected Methods

vtkInteractorStyleJoystickCamera ()
~vtkInteractorStyleJoystickCamera ()

Protected Attributes

int | State
float | MotionFactor

Detailed Description

interactive manipulation of the camera.

Date:
2002/01/22 15:38:36
Revision:
1.9

vtkInteractorStyleJoystickCamera allows the user to move (rotate, pan, etc.) the camera, the point of view for the scene. The position of the mouse relative to the center of the scene determines the speed at which the camera moves, and the speed of the mouse movement determines the acceleration of the camera, so the camera continues to move even if the mouse if not moving. For a 3-button mouse, the left button is for rotation, the right button for zooming, the middle button for panning, and ctrl + left button for spinning. (With fewer mouse buttons, ctrl + shift + left button is for zooming, and shift + left button is for panning.)

See also:
vtkInteractorStyleJoystickActor vtkInteractorStyleTrackballCamera vtkInteractorStyleTrackballActor
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (87%)

Definition at line 57 of file vtkInteractorStyleJoystickCamera.h.

Constructor & Destructor Documentation

vtkInteractorStyleJoystickCamera::vtkInteractorStyleJoystickCamera ( ) [protected]

vtkInteractorStyleJoystickCamera::~vtkInteractorStyleJoystickCamera ( ) [protected]

Member Function Documentation

vtkInteractorStyleJoystickCamera* vtkInteractorStyleJoystickCamera::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleJoystickCamera::vtkTypeRevisionMacro | ( | vtkInteractorStyleJoystickCamera | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleJoystickCamera::OnTimer ( void ) [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

Member Data Documentation

int vtkInteractorStyleJoystickCamera::State [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 81 of file vtkInteractorStyleJoystickCamera.h.

float vtkInteractorStyleJoystickCamera::MotionFactor [protected]

Definition at line 82 of file vtkInteractorStyleJoystickCamera.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleJoystickCamera.h
Generated on Mon Mar 25 01:21:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleSwitch Class Reference

class to swap between interactory styles. More...

#include <vtkInteractorStyleSwitch.h>

Inheritance diagram for vtkInteractorStyleSwitch:

[legend]
Collaboration diagram for vtkInteractorStyleSwitch:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleSwitch, vtkInteractorStyle)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
void | SetInteractor (vtkRenderWindowInteractor *iren)
void | SetAutoAdjustCameraClippingRange (int value)
virtual vtkInteractorStyle * | GetCurrentStyle ()

Static Public Methods

vtkInteractorStyleSwitch * | New ()

Protected Methods

vtkInteractorStyleSwitch ()
~vtkInteractorStyleSwitch ()
void | SetCurrentStyle ()

Protected Attributes

vtkInteractorStyleJoystickActor * JoystickActor
vtkInteractorStyleJoystickCamera * JoystickCamera
vtkInteractorStyleTrackballActor * TrackballActor
vtkInteractorStyleTrackballCamera * TrackballCamera
vtkInteractorStyle * CurrentStyle
int | JoystickOrTrackball
int | CameraOrActor

Detailed Description

class to swap between interactory styles.

Date:
2002/03/21 21:27:34
Revision:
1.14

The class vtkInteractorStyleSwitch allows handles interactively switching between four interactor styles -- joystick actor, joystick camera, trackball actor, and trackball camera. Type 'j' or 't' to select joystick or trackball, and type 'c' or 'a' to select camera or actor. The default interactor style is joystick camera.

See also:
vtkInteractorStyleJoystickActor vtkInteractorStyleJoystickCamera vtkInteractorStyleTrackballActor vtkInteractorStyleTrackballCamera
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (56%)
  • Hoffman, Bill (26%)
Tests:
vtkInteractorStyleSwitch (Tests)

Definition at line 56 of file vtkInteractorStyleSwitch.h.

Constructor & Destructor Documentation

vtkInteractorStyleSwitch::vtkInteractorStyleSwitch ( ) [protected]

vtkInteractorStyleSwitch::~vtkInteractorStyleSwitch ( ) [protected]

Member Function Documentation

vtkInteractorStyleSwitch* vtkInteractorStyleSwitch::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

Reimplemented in vtkInteractorStyleUser.

vtkInteractorStyleSwitch::vtkTypeRevisionMacro | ( | vtkInteractorStyleSwitch | ,
 |  | vtkInteractorStyle |
 | ) |

Reimplemented from vtkInteractorStyle.

Reimplemented in vtkInteractorStyleUser.

void vtkInteractorStyleSwitch::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

Reimplemented in vtkInteractorStyleUser.

void vtkInteractorStyleSwitch::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Only care about the char event, which is used to switch between different styles.

Reimplemented from vtkInteractorStyle.

Reimplemented in vtkInteractorStyleUser.

void vtkInteractorStyleSwitch::SetInteractor ( vtkRenderWindowInteractor * iren ) [virtual]

The sub styles need the interactor too.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleSwitch::SetAutoAdjustCameraClippingRange ( int value ) [virtual]

We must override this method in order to pass the setting down to the underlying styles

Reimplemented from vtkInteractorStyle.

virtual vtkInteractorStyle* vtkInteractorStyleSwitch::GetCurrentStyle ( ) [virtual]

void vtkInteractorStyleSwitch::SetCurrentStyle ( ) [protected]

Member Data Documentation

vtkInteractorStyleJoystickActor* vtkInteractorStyleSwitch::JoystickActor [protected]

Definition at line 80 of file vtkInteractorStyleSwitch.h.

vtkInteractorStyleJoystickCamera* vtkInteractorStyleSwitch::JoystickCamera [protected]

Definition at line 81 of file vtkInteractorStyleSwitch.h.

vtkInteractorStyleTrackballActor* vtkInteractorStyleSwitch::TrackballActor [protected]

Definition at line 82 of file vtkInteractorStyleSwitch.h.

vtkInteractorStyleTrackballCamera* vtkInteractorStyleSwitch::TrackballCamera [protected]

Definition at line 83 of file vtkInteractorStyleSwitch.h.

vtkInteractorStyle* vtkInteractorStyleSwitch::CurrentStyle [protected]

Definition at line 84 of file vtkInteractorStyleSwitch.h.

int vtkInteractorStyleSwitch::JoystickOrTrackball [protected]

Definition at line 85 of file vtkInteractorStyleSwitch.h.

int vtkInteractorStyleSwitch::CameraOrActor [protected]

Definition at line 86 of file vtkInteractorStyleSwitch.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleSwitch.h
Generated on Mon Mar 25 01:21:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackball Class Reference

provides trackball motion control. More...

#include <vtkInteractorStyleTrackball.h>

Inheritance diagram for vtkInteractorStyleTrackball:

[legend]
Collaboration diagram for vtkInteractorStyleTrackball:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleTrackball, vtkInteractorStyle)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | OnTimer (void)
virtual void | OnRightButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnRightButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
virtual void | SetActorModeToCamera ()
virtual void | SetActorModeToActor ()
virtual int | GetActorMode ()
virtual void | SetTrackballModeToTrackball ()
virtual void | SetTrackballModeToJoystick ()
virtual int | GetTrackballMode ()

Static Public Methods

vtkInteractorStyleTrackball * | New ()

Protected Methods

vtkInteractorStyleTrackball ()
~vtkInteractorStyleTrackball ()
virtual void | TrackballRotateCamera (int x, int y)
virtual void | TrackballSpinCamera (int x, int y)
virtual void | TrackballPanCamera (int x, int y)
virtual void | TrackballDollyCamera (int x, int y)
virtual void | JoystickRotateActor (int x, int y)
virtual void | JoystickSpinActor (int x, int y)
virtual void | JoystickPanActor (int x, int y)
virtual void | JoystickDollyActor (int x, int y)
virtual void | JoystickScaleActor (int x, int y)
virtual void | TrackballRotateActor (int x, int y)
virtual void | TrackballSpinActor (int x, int y)
virtual void | TrackballPanActor (int x, int y)
virtual void | TrackballDollyActor (int x, int y)
virtual void | TrackballScaleActor (int x, int y)
void | Prop3DTransform (vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale)
void | Prop3DTransform (vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale)
void | FindPickedActor (int X, int Y)

Protected Attributes

vtkAbstractPropPicker * InteractionPicker
int | PropPicked
vtkProp3D * InteractionProp
int | ActorMode
int | TrackballMode
int | ControlMode
float | MotionFactor
int | Preprocess
float | RadianToDegree
float | NewPickPoint [4]
float | OldPickPoint [4]
float | MotionVector [3]
float | OldX
float | OldY
double | ViewLook [3]
double | ViewPoint [3]
double | ViewFocus [3]
double | ViewUp [3]
double | ViewRight [3]
float | Origin [3]
float | Position [3]
float | ObjCenter [3]
float | DispObjCenter [3]
float | Radius

Detailed Description

provides trackball motion control.

Date:
2002/01/22 15:38:37
Revision:
1.19

vtkInteractorStyleTrackball is an implementation of vtkInteractorStyle that defines the trackball style. The trackball style can be thought of as a "grab and move" approach. That is, on mouse down a point on the object is grabbed, and then moving the mouse cause motion in proportion to the amount of motion. Note that the events that are bound by this class are the same as vtkInteractorStyle (which implements joystick mode), just the behavior is modified consistent with the trackball style of interaction.

See also:
vtkInteractorStyle
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (81%)
  • Schroeder, Will (11%)
  • Hoffman, Bill (6%)
Tests:
vtkInteractorStyleTrackball (Tests)

Definition at line 60 of file vtkInteractorStyleTrackball.h.

Constructor & Destructor Documentation

vtkInteractorStyleTrackball::vtkInteractorStyleTrackball ( ) [protected]

vtkInteractorStyleTrackball::~vtkInteractorStyleTrackball ( ) [protected]

Member Function Documentation

vtkInteractorStyleTrackball* vtkInteractorStyleTrackball::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleTrackball::vtkTypeRevisionMacro | ( | vtkInteractorStyleTrackball | ,
 |  | vtkInteractorStyle |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackball::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::SetActorModeToCamera ( ) [virtual]

External switching between actor and camera mode.

virtual void vtkInteractorStyleTrackball::SetActorModeToActor ( ) [virtual]

External switching between actor and camera mode.

virtual int vtkInteractorStyleTrackball::GetActorMode ( ) [virtual]

External switching between actor and camera mode.

virtual void vtkInteractorStyleTrackball::SetTrackballModeToTrackball ( ) [virtual]

External switching between joystick and trackball mode.

virtual void vtkInteractorStyleTrackball::SetTrackballModeToJoystick ( ) [virtual]

External switching between joystick and trackball mode.

virtual int vtkInteractorStyleTrackball::GetTrackballMode ( ) [virtual]

External switching between joystick and trackball mode.

virtual void vtkInteractorStyleTrackball::OnTimer ( void ) [virtual]

OnTimer calls RotateCamera, RotateActor etc which should be overridden by style subclasses.

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleTrackball::TrackballRotateCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballSpinCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballPanCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballDollyCamera | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::JoystickRotateActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::JoystickSpinActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::JoystickPanActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::JoystickDollyActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::JoystickScaleActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballRotateActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballSpinActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballPanActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballDollyActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

virtual void vtkInteractorStyleTrackball::TrackballScaleActor | ( | int | x,
 |  | int | y
 | ) | [protected, virtual]

void vtkInteractorStyleTrackball::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | double * | boxCenter,
 |  | int | numRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

void vtkInteractorStyleTrackball::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | float * | boxCenter,
 |  | int | NumRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

void vtkInteractorStyleTrackball::FindPickedActor | ( | int | X,
 |  | int | Y
 | ) | [protected]

Member Data Documentation

vtkAbstractPropPicker* vtkInteractorStyleTrackball::InteractionPicker [protected]

Definition at line 103 of file vtkInteractorStyleTrackball.h.

int vtkInteractorStyleTrackball::PropPicked [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 104 of file vtkInteractorStyleTrackball.h.

vtkProp3D* vtkInteractorStyleTrackball::InteractionProp [protected]

Definition at line 105 of file vtkInteractorStyleTrackball.h.

int vtkInteractorStyleTrackball::ActorMode [protected]

Definition at line 108 of file vtkInteractorStyleTrackball.h.

int vtkInteractorStyleTrackball::TrackballMode [protected]

Definition at line 109 of file vtkInteractorStyleTrackball.h.

int vtkInteractorStyleTrackball::ControlMode [protected]

Definition at line 110 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::MotionFactor [protected]

Definition at line 111 of file vtkInteractorStyleTrackball.h.

int vtkInteractorStyleTrackball::Preprocess [protected]

Definition at line 112 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::RadianToDegree [protected]

Definition at line 113 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::NewPickPoint[4] [protected]

Definition at line 116 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::OldPickPoint[4] [protected]

Definition at line 117 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::MotionVector[3] [protected]

Definition at line 118 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::OldX [protected]

Definition at line 119 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::OldY [protected]

Definition at line 120 of file vtkInteractorStyleTrackball.h.

double vtkInteractorStyleTrackball::ViewLook[3] [protected]

Definition at line 123 of file vtkInteractorStyleTrackball.h.

double vtkInteractorStyleTrackball::ViewPoint[3] [protected]

Definition at line 124 of file vtkInteractorStyleTrackball.h.

double vtkInteractorStyleTrackball::ViewFocus[3] [protected]

Definition at line 125 of file vtkInteractorStyleTrackball.h.

double vtkInteractorStyleTrackball::ViewUp[3] [protected]

Definition at line 126 of file vtkInteractorStyleTrackball.h.

double vtkInteractorStyleTrackball::ViewRight[3] [protected]

Definition at line 127 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::Origin[3] [protected]

Definition at line 130 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::Position[3] [protected]

Definition at line 131 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::ObjCenter[3] [protected]

Definition at line 132 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::DispObjCenter[3] [protected]

Definition at line 133 of file vtkInteractorStyleTrackball.h.

float vtkInteractorStyleTrackball::Radius [protected]

Definition at line 134 of file vtkInteractorStyleTrackball.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleTrackball.h
Generated on Mon Mar 25 01:21:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackballActor Class Reference

manipulate objects in the scene independent of each other. More...

#include <vtkInteractorStyleTrackballActor.h>

Inheritance diagram for vtkInteractorStyleTrackballActor:

[legend]
Collaboration diagram for vtkInteractorStyleTrackballActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleTrackballActor, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnMouseMove (int ctrl, int shift, int x, int y)
void | OnLeftButtonDown (int ctrl, int shift, int x, int y)
void | OnLeftButtonUp (int ctrl, int shift, int x, int y)
void | OnMiddleButtonDown (int ctrl, int shift, int x, int y)
void | OnMiddleButtonUp (int ctrl, int shift, int x, int y)
void | OnRightButtonDown (int ctrl, int shift, int x, int y)
void | OnRightButtonUp (int ctrl, int shift, int x, int y)

Static Public Methods

vtkInteractorStyleTrackballActor * | New ()

Protected Methods

vtkInteractorStyleTrackballActor ()
~vtkInteractorStyleTrackballActor ()
void | RotateXY (int x, int y, int oldX, int oldY)
void | PanXY (int x, int y, int oldX, int oldY)
void | DollyXY (int dx, int dy)
void | SpinXY (int dx, int dy, int oldX, int oldY)
void | ScaleXY (int x, int y, int oldX, int oldY)
void | FindPickedActor (int x, int y)
void | Prop3DTransform (vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale)
void | Prop3DTransform (vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale)

Protected Attributes

int | State
float | MotionFactor
float | RadianToDegree
vtkProp3D * InteractionProp
double | ViewUp [3]
double | ViewLook [3]
double | ViewRight [3]
float | ObjCenter [3]
float | DispObjCenter [3]
float | Radius
float | NewPickPoint [4]
float | OldPickPoint [4]
float | MotionVector [3]
double | ViewPoint [3]
double | ViewFocus [3]
vtkCellPicker * InteractionPicker

Detailed Description

manipulate objects in the scene independent of each other.

Date:
2002/01/22 15:38:37
Revision:
1.10

vtkInteractorStyleTrackballActor allows the user to interact with (rotate, pan, etc.) objects in the scene indendent of each other. The position of the mouse relative to the center of the object determine's the speed at which the object moves. When the mouse stops moving, so does the object being manipulated. For a 3-button mouse, the left button is for rotation, the right button for zooming, the middle button for panning, and ctrl + left button for spinning. (With fewer mouse buttons, ctrl + shift + left button is for zooming, and shift + left button is for panning.)

See also:
vtkInteractorStyleTrackballCamera vtkInteractorStyleJoystickActor vtkInteractorStyleJoystickCamera
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (86%)

Definition at line 56 of file vtkInteractorStyleTrackballActor.h.

Constructor & Destructor Documentation

vtkInteractorStyleTrackballActor::vtkInteractorStyleTrackballActor ( ) [protected]

vtkInteractorStyleTrackballActor::~vtkInteractorStyleTrackballActor ( ) [protected]

Member Function Documentation

vtkInteractorStyleTrackballActor* vtkInteractorStyleTrackballActor::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleTrackballActor::vtkTypeRevisionMacro | ( | vtkInteractorStyleTrackballActor | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballActor::RotateXY | ( | int | x,
 |  | int | y,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleTrackballActor::PanXY | ( | int | x,
 |  | int | y,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleTrackballActor::DollyXY | ( | int | dx,
 |  | int | dy
 | ) | [protected]

void vtkInteractorStyleTrackballActor::SpinXY | ( | int | dx,
 |  | int | dy,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleTrackballActor::ScaleXY | ( | int | x,
 |  | int | y,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleTrackballActor::FindPickedActor | ( | int | x,
 |  | int | y
 | ) | [protected]

void vtkInteractorStyleTrackballActor::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | double * | boxCenter,
 |  | int | numRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

void vtkInteractorStyleTrackballActor::Prop3DTransform | ( | vtkProp3D * | prop3D,
 |  | float * | boxCenter,
 |  | int | NumRotation,
 |  | double ** | rotate,
 |  | double * | scale
 | ) | [protected]

Member Data Documentation

int vtkInteractorStyleTrackballActor::State [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 92 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::MotionFactor [protected]

Definition at line 93 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::RadianToDegree [protected]

Definition at line 94 of file vtkInteractorStyleTrackballActor.h.

vtkProp3D* vtkInteractorStyleTrackballActor::InteractionProp [protected]

Definition at line 95 of file vtkInteractorStyleTrackballActor.h.

double vtkInteractorStyleTrackballActor::ViewUp[3] [protected]

Definition at line 96 of file vtkInteractorStyleTrackballActor.h.

double vtkInteractorStyleTrackballActor::ViewLook[3] [protected]

Definition at line 97 of file vtkInteractorStyleTrackballActor.h.

double vtkInteractorStyleTrackballActor::ViewRight[3] [protected]

Definition at line 98 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::ObjCenter[3] [protected]

Definition at line 99 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::DispObjCenter[3] [protected]

Definition at line 100 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::Radius [protected]

Definition at line 101 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::NewPickPoint[4] [protected]

Definition at line 102 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::OldPickPoint[4] [protected]

Definition at line 103 of file vtkInteractorStyleTrackballActor.h.

float vtkInteractorStyleTrackballActor::MotionVector[3] [protected]

Definition at line 104 of file vtkInteractorStyleTrackballActor.h.

double vtkInteractorStyleTrackballActor::ViewPoint[3] [protected]

Definition at line 105 of file vtkInteractorStyleTrackballActor.h.

double vtkInteractorStyleTrackballActor::ViewFocus[3] [protected]

Definition at line 106 of file vtkInteractorStyleTrackballActor.h.

vtkCellPicker* vtkInteractorStyleTrackballActor::InteractionPicker [protected]

Definition at line 108 of file vtkInteractorStyleTrackballActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleTrackballActor.h
Generated on Mon Mar 25 01:22:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleTrackballCamera Class Reference

interactive manipulation of the camera. More...

#include <vtkInteractorStyleTrackballCamera.h>

Inheritance diagram for vtkInteractorStyleTrackballCamera:

[legend]
Collaboration diagram for vtkInteractorStyleTrackballCamera:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleTrackballCamera, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | OnMouseMove (int ctrl, int shift, int x, int y)
void | OnLeftButtonDown (int ctrl, int shift, int x, int y)
void | OnLeftButtonUp (int ctrl, int shift, int x, int y)
void | OnMiddleButtonDown (int ctrl, int shift, int x, int y)
void | OnMiddleButtonUp (int ctrl, int shift, int x, int y)
void | OnRightButtonDown (int ctrl, int shift, int x, int y)
void | OnRightButtonUp (int ctrl, int shift, int x, int y)

Static Public Methods

vtkInteractorStyleTrackballCamera * | New ()

Protected Methods

vtkInteractorStyleTrackballCamera ()
~vtkInteractorStyleTrackballCamera ()
void | RotateXY (int dx, int dy)
void | PanXY (int x, int y, int oldX, int oldY)
void | DollyXY (int dx, int dy)
void | SpinXY (int dx, int dy, int oldX, int oldY)

Protected Attributes

int | State
float | MotionFactor
float | RadianToDegree

Detailed Description

interactive manipulation of the camera.

Date:
2002/01/22 15:38:38
Revision:
1.9

vtkInteractorStyleTrackballCamera allows the user to interactively manipulate (rotate, pan, etc.) the camera, the viewpoint of the scene. The position of the mouse relative to the center of the scene determines the speed at which the camera moves. When the mouse stops moving, so does the camera. For a 3-button mouse, the left button is for rotation, the right button for zooming, the middle button for panning, and ctrl + left button for spinning. (With fewer mouse buttons, ctrl + shift + left button is for zooming, and shift + left button is for panning.)

See also:
vtkInteractorStyleTrackballActor vtkInteractorStyleJoystickCamera vtkInteractorStyleJoystickActor
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (78%)
  • Martin, Ken (7%)
  • Hoffman, Bill (5%)
  • Ramachandran, Prabhu (5%)

Definition at line 58 of file vtkInteractorStyleTrackballCamera.h.

Constructor & Destructor Documentation

vtkInteractorStyleTrackballCamera::vtkInteractorStyleTrackballCamera ( ) [protected]

vtkInteractorStyleTrackballCamera::~vtkInteractorStyleTrackballCamera ( ) [protected]

Member Function Documentation

vtkInteractorStyleTrackballCamera* vtkInteractorStyleTrackballCamera::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleTrackballCamera::vtkTypeRevisionMacro | ( | vtkInteractorStyleTrackballCamera | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | x,
 |  | int | y
 | ) | [virtual]

Event bindings controlling the effects of pressing mouse buttons or moving the mouse.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleTrackballCamera::RotateXY | ( | int | dx,
 |  | int | dy
 | ) | [protected]

void vtkInteractorStyleTrackballCamera::PanXY | ( | int | x,
 |  | int | y,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

void vtkInteractorStyleTrackballCamera::DollyXY | ( | int | dx,
 |  | int | dy
 | ) | [protected]

void vtkInteractorStyleTrackballCamera::SpinXY | ( | int | dx,
 |  | int | dy,
 |  | int | oldX,
 |  | int | oldY
 | ) | [protected]

Member Data Documentation

int vtkInteractorStyleTrackballCamera::State [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 86 of file vtkInteractorStyleTrackballCamera.h.

float vtkInteractorStyleTrackballCamera::MotionFactor [protected]

Definition at line 87 of file vtkInteractorStyleTrackballCamera.h.

float vtkInteractorStyleTrackballCamera::RadianToDegree [protected]

Definition at line 88 of file vtkInteractorStyleTrackballCamera.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleTrackballCamera.h
Generated on Mon Mar 25 01:22:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleUnicam Class Reference

provides Unicam navigation style. More...

#include <vtkInteractorStyleUnicam.h>

Inheritance diagram for vtkInteractorStyleUnicam:

[legend]
Collaboration diagram for vtkInteractorStyleUnicam:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleUnicam, vtkInteractorStyle)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | OnLeftButtonMove (int ctrl, int shift, int X, int Y)
virtual void | OnMiddleButtonMove (int, int, int, int)
virtual void | OnRightButtonMove (int, int, int, int)
virtual void | OnTimer (void)
void | SetWorldUpVector (double a[3])
void | SetWorldUpVector (float a[3])
void | SetWorldUpVector (float x, float y, float z)
virtual float * | GetWorldUpVector ()
virtual void | GetWorldUpVector (float data[3])
virtual void | OnLeftButtonDown (int ctrl, int shift, int X, int Y)
virtual void | OnLeftButtonUp (int ctrl, int shift, int X, int Y)
virtual void | OnMouseMove (int ctrl, int shift, int X, int Y)

Static Public Methods

vtkInteractorStyleUnicam * | New ()

Protected Methods

vtkInteractorStyleUnicam ()
virtual | ~vtkInteractorStyleUnicam ()
void | Choose (int X, int Y)
void | Rotate (int X, int Y)
void | Dolly (int X, int Y)
void | Pan (int X, int Y)
void | MyTranslateCamera (float v[3])
void | MyRotateCamera (float cx, float cy, float cz, float ax, float ay, float az, float angle)
void | GetRightVandUpV (float *p, vtkCamera *cam, float *rightV, float *upV)
void | NormalizeMouseXY (int X, int Y, float *NX, float *NY)
float | WindowAspect ()

Protected Attributes

vtkWorldPointPicker * InteractionPicker
int | ButtonDown
double | DTime
double | Dist
float | StartPix [2]
float | LastPos [2]
float | LastPix [2]
float | DownPt [3]
float | Center [3]
float | WorldUpVector [3]
vtkActor * FocusSphere
int | IsDot
vtkRenderer * FocusSphereRenderer
int | state

Detailed Description

provides Unicam navigation style.

Date:
2002/01/22 15:38:38
Revision:
1.14

UniCam is a camera interactor. Here, just the primary features of the UniCam technique are implemented. UniCam requires just one mouse button and supports context sensitive dollying, panning, and rotation. (In this implementation, it uses the right mouse button, leaving the middle and left available for other functions.) For more information, see the paper at:

ftp://ftp.cs.brown.edu/pub/papers/graphics/research/unicam.pdf

The following is a brief description of the UniCam Camera Controls. You can perform 3 operations on the camera: rotate, pan, and dolly the camera. All operations are reached through the right mouse button & mouse movements.

IMPORTANT: UniCam assumes there is an axis that makes sense as a "up" vector for the world. By default, this axis is defined to be the vector <0,0,1>. You can set it explicitly for the data you are viewing with the 'SetWorldUpVector(..)' method in C++, or similarly in Tcl/Tk (or other interpreted languages).

1. ROTATE:

Position the cursor over the point you wish to rotate around and press and release the left mouse button. A 'focus dot' appears indicating the point that will be the center of rotation. To rotate, press and hold the left mouse button and drag the mouse.. release the button to complete the rotation.

Rotations can be done without placing a focus dot first by moving the mouse cursor to within 10% of the window border & pressing and holding the left button followed by dragging the mouse. The last focus dot position will be re-used.

2. PAN:

Click and hold the left mouse button, and initially move the mouse left or right. The point under the initial pick will pick correlate w/ the mouse tip-- (i.e., direct manipulation).

3. DOLLY (+ PAN):

Click and hold the left mouse button, and initially move the mouse up or down. Moving the mouse down will dolly towards the picked point, and moving the mouse up will dolly away from it. Dollying occurs relative to the picked point which simplifies the task of dollying towards a region of interest. Left and right mouse movements will pan the camera left and right.

Warning:
(NOTE: This implementation of Unicam assumes a perspective camera. It could be modified relatively easily to also support an orthographic projection.)
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)

Definition at line 134 of file vtkInteractorStyleUnicam.h.

Constructor & Destructor Documentation

vtkInteractorStyleUnicam::vtkInteractorStyleUnicam ( ) [protected]

virtual vtkInteractorStyleUnicam::~vtkInteractorStyleUnicam ( ) [protected, virtual]

Member Function Documentation

vtkInteractorStyleUnicam* vtkInteractorStyleUnicam::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyle.

vtkInteractorStyleUnicam::vtkTypeRevisionMacro | ( | vtkInteractorStyleUnicam | ,
 |  | vtkInteractorStyle |
 | ) |

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUnicam::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleUnicam::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleUnicam::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleUnicam::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Concrete implementation of event bindings

Reimplemented from vtkInteractorStyle.

virtual void vtkInteractorStyleUnicam::OnLeftButtonMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

virtual void vtkInteractorStyleUnicam::OnMiddleButtonMove | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [inline, virtual]

Definition at line 149 of file vtkInteractorStyleUnicam.h.

virtual void vtkInteractorStyleUnicam::OnRightButtonMove | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [inline, virtual]

Definition at line 150 of file vtkInteractorStyleUnicam.h.

virtual void vtkInteractorStyleUnicam::OnTimer ( void ) [virtual]

OnTimer calls RotateCamera, RotateActor etc which should be overridden by style subclasses.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUnicam::SetWorldUpVector ( double a[3] ) [inline]

Definition at line 156 of file vtkInteractorStyleUnicam.h.

void vtkInteractorStyleUnicam::SetWorldUpVector ( float a[3] ) [inline]

Definition at line 157 of file vtkInteractorStyleUnicam.h.

void vtkInteractorStyleUnicam::SetWorldUpVector | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

virtual float* vtkInteractorStyleUnicam::GetWorldUpVector ( ) [virtual]

virtual void vtkInteractorStyleUnicam::GetWorldUpVector ( float data[3] ) [virtual]

void vtkInteractorStyleUnicam::Choose | ( | int | X,
 |  | int | Y
 | ) | [protected]

void vtkInteractorStyleUnicam::Rotate | ( | int | X,
 |  | int | Y
 | ) | [protected]

void vtkInteractorStyleUnicam::Dolly | ( | int | X,
 |  | int | Y
 | ) | [protected]

void vtkInteractorStyleUnicam::Pan | ( | int | X,
 |  | int | Y
 | ) | [protected]

void vtkInteractorStyleUnicam::MyTranslateCamera ( float v[3] ) [protected]

void vtkInteractorStyleUnicam::MyRotateCamera | ( | float | cx,
 |  | float | cy,
 |  | float | cz,
 |  | float | ax,
 |  | float | ay,
 |  | float | az,
 |  | float | angle
 | ) | [protected]

void vtkInteractorStyleUnicam::GetRightVandUpV | ( | float * | p,
 |  | vtkCamera * | cam,
 |  | float * | rightV,
 |  | float * | upV
 | ) | [protected]

void vtkInteractorStyleUnicam::NormalizeMouseXY | ( | int | X,
 |  | int | Y,
 |  | float * | NX,
 |  | float * | NY
 | ) | [protected]

float vtkInteractorStyleUnicam::WindowAspect ( ) [protected]

Member Data Documentation

vtkWorldPointPicker* vtkInteractorStyleUnicam::InteractionPicker [protected]

Definition at line 165 of file vtkInteractorStyleUnicam.h.

int vtkInteractorStyleUnicam::ButtonDown [protected]

Definition at line 167 of file vtkInteractorStyleUnicam.h.

double vtkInteractorStyleUnicam::DTime [protected]

Definition at line 168 of file vtkInteractorStyleUnicam.h.

double vtkInteractorStyleUnicam::Dist [protected]

Definition at line 169 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::StartPix[2] [protected]

Definition at line 170 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::LastPos[2] [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 171 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::LastPix[2] [protected]

Definition at line 172 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::DownPt[3] [protected]

Definition at line 173 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::Center[3] [protected]

Reimplemented from vtkInteractorStyle.

Definition at line 174 of file vtkInteractorStyleUnicam.h.

float vtkInteractorStyleUnicam::WorldUpVector[3] [protected]

Definition at line 176 of file vtkInteractorStyleUnicam.h.

vtkActor* vtkInteractorStyleUnicam::FocusSphere [protected]

Definition at line 178 of file vtkInteractorStyleUnicam.h.

int vtkInteractorStyleUnicam::IsDot [protected]

Definition at line 179 of file vtkInteractorStyleUnicam.h.

vtkRenderer* vtkInteractorStyleUnicam::FocusSphereRenderer [protected]

Definition at line 180 of file vtkInteractorStyleUnicam.h.

int vtkInteractorStyleUnicam::state [protected]

Definition at line 182 of file vtkInteractorStyleUnicam.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleUnicam.h
Generated on Mon Mar 25 01:22:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInteractorStyleUser Class Reference

provides customizable interaction routines. More...

#include <vtkInteractorStyleUser.h>

Inheritance diagram for vtkInteractorStyleUser:

[legend]
Collaboration diagram for vtkInteractorStyleUser:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInteractorStyleUser, vtkInteractorStyleSwitch)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetMouseMoveMethod (void(*f)(void *), void *arg)
void | SetMouseMoveMethodArgDelete (void(*f)(void *))
void | SetButtonPressMethod (void(*f)(void *), void *arg)
void | SetButtonPressMethodArgDelete (void(*f)(void *))
void | SetButtonReleaseMethod (void(*f)(void *), void *arg)
void | SetButtonReleaseMethodArgDelete (void(*f)(void *))
void | SetKeyPressMethod (void(*f)(void *), void *arg)
void | SetKeyPressMethodArgDelete (void(*f)(void *))
void | SetKeyReleaseMethod (void(*f)(void *), void *arg)
void | SetKeyReleaseMethodArgDelete (void(*f)(void *))
void | SetCharMethod (void(*f)(void *), void *arg)
void | SetCharMethodArgDelete (void(*f)(void *))
void | SetConfigureMethod (void(*f)(void *), void *arg)
void | SetConfigureMethodArgDelete (void(*f)(void *))
void | SetEnterMethod (void(*f)(void *), void *arg)
void | SetEnterMethodArgDelete (void(*f)(void *))
void | SetLeaveMethod (void(*f)(void *), void *arg)
void | SetLeaveMethodArgDelete (void(*f)(void *))
void | SetTimerMethod (void(*f)(void *), void *arg)
void | SetTimerMethodArgDelete (void(*f)(void *))
virtual int * | GetLastPos ()
virtual void | GetLastPos (int &, int &)
virtual void | GetLastPos (int[2])
virtual int * | GetOldPos ()
virtual void | GetOldPos (int &, int &)
virtual void | GetOldPos (int[2])
virtual int | GetShiftKey ()
virtual int | GetCtrlKey ()
virtual int | GetChar ()
virtual char * | GetKeySym ()
virtual int | GetButton ()
void | SetUserInteractionMethod (void(*f)(void *), void *arg)
void | SetUserInteractionMethodArgDelete (void(*f)(void *))
void | StartUserInteraction ()
void | EndUserInteraction ()

Static Public Methods

vtkInteractorStyleUser * | New ()

Protected Methods

vtkInteractorStyleUser ()
~vtkInteractorStyleUser ()
void | OnChar (int ctrl, int shift, char keycode, int repeatcount)
void | OnKeyPress (int ctrl, int shift, char keycode, char *keysym, int repeatcount)
void | OnKeyRelease (int ctrl, int shift, char keycode, char *keysym, int repeatcount)
void | OnLeftButtonDown (int ctrl, int shift, int X, int Y)
void | OnLeftButtonUp (int ctrl, int shift, int X, int Y)
void | OnMiddleButtonDown (int ctrl, int shift, int X, int Y)
void | OnMiddleButtonUp (int ctrl, int shift, int X, int Y)
void | OnRightButtonDown (int ctrl, int shift, int X, int Y)
void | OnRightButtonUp (int ctrl, int shift, int X, int Y)
void | OnMouseMove (int ctrl, int shift, int X, int Y)
void | OnConfigure (int width, int height)
void | OnEnter (int ctrl, int shift, int X, int Y)
void | OnLeave (int ctrl, int shift, int X, int Y)
void | OnTimer (void)
void | vtkSetOldCallback (unsigned long &tag, unsigned long event, void(*f)(void *), void *arg)
void | vtkSetOldDelete (unsigned long tag, void(*f)(void *))

Protected Attributes

int | OldPos [2]
int | Char
char * | KeySym
int | Button
unsigned long | MouseMoveTag
unsigned long | KeyPressTag
unsigned long | KeyReleaseTag
unsigned long | CharTag
unsigned long | EnterTag
unsigned long | LeaveTag
unsigned long | ConfigureTag
unsigned long | TimerTag
unsigned long | UserTag

Detailed Description

provides customizable interaction routines.

Date:
2002/01/22 15:38:38
Revision:
1.22

The most common way to customize user interaction is to write a subclass of vtkInteractorStyle: vtkInteractorStyleUser allows you to customize the interaction to without subclassing vtkInteractorStyle. This is particularly useful for setting up custom interaction modes in scripting languages such as Tcl and Python. This class allows you to hook into the MouseMove, ButtonPress/Release, KeyPress/Release, etc. events. If you want to hook into just a single mouse button, but leave the interaction modes for the others unchanged, you must use e.g. SetMiddleButtonPressMethod() instead of the more general SetButtonPressMethod().

Events:
vtkCommand::LeftButtonReleaseEvent vtkCommand::RightButtonPressEvent vtkCommand::UserEvent vtkCommand::MouseMoveEvent vtkCommand::MiddleButtonReleaseEvent vtkCommand::EnterEvent vtkCommand::TimerEvent vtkCommand::ConfigureEvent vtkCommand::KeyPressEvent vtkCommand::RightButtonReleaseEvent vtkCommand::MiddleButtonPressEvent vtkCommand::CharEvent vtkCommand::LeaveEvent vtkCommand::LeftButtonPressEvent vtkCommand::KeyReleaseEvent
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (80%)
  • Martin, Ken (16%)

Definition at line 54 of file vtkInteractorStyleUser.h.

Constructor & Destructor Documentation

vtkInteractorStyleUser::vtkInteractorStyleUser ( ) [protected]

vtkInteractorStyleUser::~vtkInteractorStyleUser ( ) [protected]

Member Function Documentation

vtkInteractorStyleUser* vtkInteractorStyleUser::New ( ) [static]

This class must be supplied with a vtkRenderWindowInteractor wrapper or parent. This class should not normally be instantiated by application programmers.

Reimplemented from vtkInteractorStyleSwitch.

vtkInteractorStyleUser::vtkTypeRevisionMacro | ( | vtkInteractorStyleUser | ,
 |  | vtkInteractorStyleSwitch |
 | ) |

Reimplemented from vtkInteractorStyleSwitch.

void vtkInteractorStyleUser::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInteractorStyleSwitch.

void vtkInteractorStyleUser::SetMouseMoveMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called every time the mouse is moved. You can use GetLastPos() to determine the position of the cursor in display coordinates, and GetOldPos() to determine the previous position. Use GetButton() to query which mouse button is being held down. This should be used in conjunction with SetButtonPressMethod()/SetButtonReleaseMethod() or with the individual SetXXButtonPressMethods in vtkInteractorStyle.

void vtkInteractorStyleUser::SetMouseMoveMethodArgDelete ( void(* f)(void *) )

Set a method that will be called every time the mouse is moved. You can use GetLastPos() to determine the position of the cursor in display coordinates, and GetOldPos() to determine the previous position. Use GetButton() to query which mouse button is being held down. This should be used in conjunction with SetButtonPressMethod()/SetButtonReleaseMethod() or with the individual SetXXButtonPressMethods in vtkInteractorStyle.

void vtkInteractorStyleUser::SetButtonPressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called whenever a mouse button is pressed. Use GetButton() to query which button was pressed. This simply calls SetLeftButtonPressMethod(method), SetMiddleButtonPressMethod(method), SetRightButtonPressMethod(method).

void vtkInteractorStyleUser::SetButtonPressMethodArgDelete ( void(* f)(void *) )

Set a method that will be called whenever a mouse button is pressed. Use GetButton() to query which button was pressed. This simply calls SetLeftButtonPressMethod(method), SetMiddleButtonPressMethod(method), SetRightButtonPressMethod(method).

void vtkInteractorStyleUser::SetButtonReleaseMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called whenever a mouse button is released. Use GetButton() to query which button was released. This simply calls SetLeftButtonReleaseMethod(method), SetMiddleButtonReleaseMethod(method), SetRightButtonReleaseMethod(method).

void vtkInteractorStyleUser::SetButtonReleaseMethodArgDelete ( void(* f)(void *) )

Set a method that will be called whenever a mouse button is released. Use GetButton() to query which button was released. This simply calls SetLeftButtonReleaseMethod(method), SetMiddleButtonReleaseMethod(method), SetRightButtonReleaseMethod(method).

void vtkInteractorStyleUser::SetKeyPressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called every time a key is pressed. Use GetKeySym() to find out which key was pressed. They keystroke is also converted into a character, which can be retrieved using GetChar().

void vtkInteractorStyleUser::SetKeyPressMethodArgDelete ( void(* f)(void *) )

Set a method that will be called every time a key is pressed. Use GetKeySym() to find out which key was pressed. They keystroke is also converted into a character, which can be retrieved using GetChar().

void vtkInteractorStyleUser::SetKeyReleaseMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called every time a key is released. Use GetKeySym to find out which key was released. They keystroke is also converted into a character, which can be retrieved using GetChar().

void vtkInteractorStyleUser::SetKeyReleaseMethodArgDelete ( void(* f)(void *) )

Set a method that will be called every time a key is released. Use GetKeySym to find out which key was released. They keystroke is also converted into a character, which can be retrieved using GetChar().

void vtkInteractorStyleUser::SetCharMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called every time a character is received. This is not the same as the KeyPress method, which is called when any key (including shift or control) is pressed. Use GetChar() to find out which char was received.

void vtkInteractorStyleUser::SetCharMethodArgDelete ( void(* f)(void *) )

Set a method that will be called every time a character is received. This is not the same as the KeyPress method, which is called when any key (including shift or control) is pressed. Use GetChar() to find out which char was received.

void vtkInteractorStyleUser::SetConfigureMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set methods that will be called when the size of the render window changes (this method is called just before the window re-renders after the size change). Call GetSize() on the interactor to find out the new size.

void vtkInteractorStyleUser::SetConfigureMethodArgDelete ( void(* f)(void *) )

Set methods that will be called when the size of the render window changes (this method is called just before the window re-renders after the size change). Call GetSize() on the interactor to find out the new size.

void vtkInteractorStyleUser::SetEnterMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set methods to be called when the mouse enters or leaves the window. Use GetLastPos() to determine where the mouse pointer was when the event occurred.

void vtkInteractorStyleUser::SetEnterMethodArgDelete ( void(* f)(void *) )

Set methods to be called when the mouse enters or leaves the window. Use GetLastPos() to determine where the mouse pointer was when the event occurred.

void vtkInteractorStyleUser::SetLeaveMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set methods to be called when the mouse enters or leaves the window. Use GetLastPos() to determine where the mouse pointer was when the event occurred.

void vtkInteractorStyleUser::SetLeaveMethodArgDelete ( void(* f)(void *) )

Set methods to be called when the mouse enters or leaves the window. Use GetLastPos() to determine where the mouse pointer was when the event occurred.

void vtkInteractorStyleUser::SetTimerMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set a method that will be called continuously at a fairly rapid rate (fast enough to be used for interaction). For this method to work, it must be called after the RenderWindowInteractor has been Initialized.

void vtkInteractorStyleUser::SetTimerMethodArgDelete ( void(* f)(void *) )

Set a method that will be called continuously at a fairly rapid rate (fast enough to be used for interaction). For this method to work, it must be called after the RenderWindowInteractor has been Initialized.

virtual int* vtkInteractorStyleUser::GetLastPos ( ) [virtual]

Get the most recent mouse position during mouse motion. In your user interaction method, you must use this to track the mouse movement. Do not use GetEventPosition(), which records the last position where a mouse button was pressed.

virtual void vtkInteractorStyleUser::GetLastPos | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Get the most recent mouse position during mouse motion. In your user interaction method, you must use this to track the mouse movement. Do not use GetEventPosition(), which records the last position where a mouse button was pressed.

virtual void vtkInteractorStyleUser::GetLastPos ( int [2] ) [virtual]

Get the most recent mouse position during mouse motion. In your user interaction method, you must use this to track the mouse movement. Do not use GetEventPosition(), which records the last position where a mouse button was pressed.

virtual int* vtkInteractorStyleUser::GetOldPos ( ) [virtual]

Get the previous mouse position during mouse motion, or after a key press. This can be used to calculate the relative displacement of the mouse.

virtual void vtkInteractorStyleUser::GetOldPos | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Get the previous mouse position during mouse motion, or after a key press. This can be used to calculate the relative displacement of the mouse.

virtual void vtkInteractorStyleUser::GetOldPos ( int [2] ) [virtual]

Get the previous mouse position during mouse motion, or after a key press. This can be used to calculate the relative displacement of the mouse.

virtual int vtkInteractorStyleUser::GetShiftKey ( ) [virtual]

Test whether modifiers were held down when mouse button or key was pressed

virtual int vtkInteractorStyleUser::GetCtrlKey ( ) [virtual]

Test whether modifiers were held down when mouse button or key was pressed

virtual int vtkInteractorStyleUser::GetChar ( ) [virtual]

Get the character for a Char event.

virtual char* vtkInteractorStyleUser::GetKeySym ( ) [virtual]

Get the KeySym (in the same format as Tk KeySyms) for a KeyPress or KeyRelease method.

virtual int vtkInteractorStyleUser::GetButton ( ) [virtual]

Get the mouse button that was last pressed inside the window (returns zero when the button is released).

void vtkInteractorStyleUser::SetUserInteractionMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

This method behaves just like OnTimer, but is only called if StartUserInteraction has been called. This method cannot be used in conjunction with SetMouseMoveMethod. Deprecated, do not use.

void vtkInteractorStyleUser::SetUserInteractionMethodArgDelete ( void(* f)(void *) )

This method behaves just like OnTimer, but is only called if StartUserInteraction has been called. This method cannot be used in conjunction with SetMouseMoveMethod. Deprecated, do not use.

void vtkInteractorStyleUser::StartUserInteraction ( )

Start/Stop user interaction mode. You must not call these methods before you have Initialized the vtkRenderWindowInteractor. Deprecated, do not use.

void vtkInteractorStyleUser::EndUserInteraction ( )

Start/Stop user interaction mode. You must not call these methods before you have Initialized the vtkRenderWindowInteractor. Deprecated, do not use.

void vtkInteractorStyleUser::OnChar | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | int | repeatcount
 | ) | [protected, virtual]

Only care about the char event, which is used to switch between different styles.

Reimplemented from vtkInteractorStyleSwitch.

void vtkInteractorStyleUser::OnKeyPress | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | char * | keysym,
 |  | int | repeatcount
 | ) | [protected, virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnKeyRelease | ( | int | ctrl,
 |  | int | shift,
 |  | char | keycode,
 |  | char * | keysym,
 |  | int | repeatcount
 | ) | [protected, virtual]

OnChar implements keyboard functions, but subclasses can override this behavior

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnLeftButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnLeftButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnMiddleButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnMiddleButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnRightButtonDown | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnRightButtonUp | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnMouseMove | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

Generic event bindings must be overridden in subclasses

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnConfigure | ( | int | width,
 |  | int | height
 | ) | [protected, virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnEnter | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnLeave | ( | int | ctrl,
 |  | int | shift,
 |  | int | X,
 |  | int | Y
 | ) | [protected, virtual]

These are more esoteric events, but are useful in some cases.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::OnTimer ( void ) [protected, virtual]

OnTimer calls RotateCamera, RotateActor etc which should be overridden by style subclasses.

Reimplemented from vtkInteractorStyle.

void vtkInteractorStyleUser::vtkSetOldCallback | ( | unsigned long & | tag,
 |  | unsigned long | event,
 |  | void(* | f)(void *),
 |  | void * | arg
 | ) | [protected]

void vtkInteractorStyleUser::vtkSetOldDelete | ( | unsigned long | tag,
 |  | void(* | f)(void *)
 | ) | [protected]

Member Data Documentation

int vtkInteractorStyleUser::OldPos[2] [protected]

Definition at line 227 of file vtkInteractorStyleUser.h.

int vtkInteractorStyleUser::Char [protected]

Definition at line 229 of file vtkInteractorStyleUser.h.

char* vtkInteractorStyleUser::KeySym [protected]

Definition at line 230 of file vtkInteractorStyleUser.h.

int vtkInteractorStyleUser::Button [protected]

Definition at line 231 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::MouseMoveTag [protected]

Definition at line 233 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::KeyPressTag [protected]

Definition at line 234 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::KeyReleaseTag [protected]

Definition at line 235 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::CharTag [protected]

Definition at line 236 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::EnterTag [protected]

Definition at line 237 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::LeaveTag [protected]

Definition at line 238 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::ConfigureTag [protected]

Definition at line 239 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::TimerTag [protected]

Definition at line 240 of file vtkInteractorStyleUser.h.

unsigned long vtkInteractorStyleUser::UserTag [protected]

Definition at line 241 of file vtkInteractorStyleUser.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkInteractorStyleUser.h
Generated on Mon Mar 25 01:22:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolateDataSetAttributes Class Reference

interpolate scalars, vectors, etc. and other dataset attributes. More...

#include <vtkInterpolateDataSetAttributes.h>

Inheritance diagram for vtkInterpolateDataSetAttributes:

[legend]
Collaboration diagram for vtkInterpolateDataSetAttributes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInterpolateDataSetAttributes, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddInput (vtkDataSet *in)
vtkDataSetCollection * GetInputList ()
virtual void | SetT (float)
virtual float | GetT ()

Static Public Methods

vtkInterpolateDataSetAttributes * | New ()

Protected Methods

vtkInterpolateDataSetAttributes ()
~vtkInterpolateDataSetAttributes ()
void | Execute ()

Protected Attributes

vtkDataSetCollection * InputList
float | T

Detailed Description

interpolate scalars, vectors, etc. and other dataset attributes.

Date:
2002/01/22 15:29:24
Revision:
1.20

vtkInterpolateDataSetAttributes is a filter that interpolates data set attribute values between input data sets. The input to the filter must be datasets of the same type, same number of cells, and same number of points. The output of the filter is a data set of the same type as the input dataset and whose attribute values have been interpolated at the parametric value specified.

The filter is used by specifying two or more input data sets (total of N), and a parametric value t (0 <= t <= N-1). The output will contain interpolated data set attributes common to all input data sets. (For example, if one input has scalars and vectors, and another has just scalars, then only scalars will be interpolated and output.)

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Martin, Ken (18%)
Tests:
vtkInterpolateDataSetAttributes (Tests)

Definition at line 52 of file vtkInterpolateDataSetAttributes.h.

Constructor & Destructor Documentation

vtkInterpolateDataSetAttributes::vtkInterpolateDataSetAttributes ( ) [protected]

vtkInterpolateDataSetAttributes::~vtkInterpolateDataSetAttributes ( ) [protected]

Member Function Documentation

vtkInterpolateDataSetAttributes* vtkInterpolateDataSetAttributes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkInterpolateDataSetAttributes::vtkTypeRevisionMacro | ( | vtkInterpolateDataSetAttributes | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkInterpolateDataSetAttributes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkInterpolateDataSetAttributes::AddInput ( vtkDataSet * in )

Add a dataset to the list of data to interpolate.

vtkDataSetCollection* vtkInterpolateDataSetAttributes::GetInputList ( )

Return the list of inputs to this filter.

virtual void vtkInterpolateDataSetAttributes::SetT ( float ) [virtual]

Specify interpolation parameter t.

virtual float vtkInterpolateDataSetAttributes::GetT ( ) [virtual]

Specify interpolation parameter t.

void vtkInterpolateDataSetAttributes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkDataSetCollection* vtkInterpolateDataSetAttributes::InputList [protected]

Definition at line 77 of file vtkInterpolateDataSetAttributes.h.

float vtkInterpolateDataSetAttributes::T [protected]

Definition at line 78 of file vtkInterpolateDataSetAttributes.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkInterpolateDataSetAttributes.h
Generated on Mon Mar 25 01:22:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolatedVelocityField Class Reference

Interface for obtaining. More...

#include <vtkInterpolatedVelocityField.h>

Inheritance diagram for vtkInterpolatedVelocityField:

[legend]
Collaboration diagram for vtkInterpolatedVelocityField:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInterpolatedVelocityField, vtkFunctionSet)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | FunctionValues (float *x, float *f)
void | ClearLastCellId ()
virtual void | SetDataSet (vtkDataSet *dataset)
virtual vtkDataSet * | GetDataSet ()
virtual vtkIdType | GetLastCellId ()
virtual void | SetLastCellId (vtkIdType)
int | GetLastWeights (float *w)
int | GetLastLocalCoordinates (float pcoords[3])
virtual int | GetCaching ()
virtual void | SetCaching (int)
virtual void | CachingOn ()
virtual void | CachingOff ()
virtual int | GetCacheHit ()
virtual int | GetCacheMiss ()

Static Public Methods

vtkInterpolatedVelocityField * | New ()

Protected Methods

vtkInterpolatedVelocityField ()
~vtkInterpolatedVelocityField ()

Protected Attributes

vtkDataSet * DataSet
vtkGenericCell * GenCell
vtkGenericCell * Cell
float * | Weights
float | LastPCoords [3]
vtkIdType LastCellId
int | CacheHit
int | CacheMiss
int | Caching

Detailed Description

Interface for obtaining.

Date:
2002/01/22 15:25:32
Revision:
1.12
interpolated velocity values

vtkInterpolatedVelocityField acts as a continuous velocity field by performing cell interpolation on the underlying vtkDataSet. This is a concrete sub-class of vtkFunctionSet with NumberOfIndependentVariables = 4 (x,y,z,t) and NumberOfFunctions = 3 (u,v,w). Normally, every time an evaluation is performed, the cell which contains the point (x,y,z) has to be found by calling FindCell. This is a computationally expansive operation. In certain cases, the cell search can be avoided or shortened by providing a guess for the cell id. For example, in streamline integration, the next evaluation is usually in the same or a neighbour cell. For this reason, vtkInterpolatedVelocityField stores the last cell id. If caching is turned on, it uses this id as the starting point.

Warning:
vtkInterpolatedVelocityField is not thread safe. A new instance should be created by each thread.
See also:
vtkFunctionSet vtkStreamer
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (98%)

Definition at line 57 of file vtkInterpolatedVelocityField.h.

Constructor & Destructor Documentation

vtkInterpolatedVelocityField::vtkInterpolatedVelocityField ( ) [protected]

vtkInterpolatedVelocityField::~vtkInterpolatedVelocityField ( ) [protected]

Member Function Documentation

vtkInterpolatedVelocityField::vtkTypeRevisionMacro | ( | vtkInterpolatedVelocityField | ,
 |  | vtkFunctionSet |
 | ) |

Reimplemented from vtkFunctionSet.

virtual void vtkInterpolatedVelocityField::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkFunctionSet.

vtkInterpolatedVelocityField* vtkInterpolatedVelocityField::New ( ) [static]

Construct a vtkInterpolatedVelocityField with no initial data set. Caching is on. LastCellId is set to -1.

Reimplemented from vtkObject.

virtual int vtkInterpolatedVelocityField::FunctionValues | ( | float * | x,
 |  | float * | f
 | ) | [virtual]

Evaluate the velocity field, f, at (x, y, z, t). For now, t is ignored.

Reimplemented from vtkFunctionSet.

virtual void vtkInterpolatedVelocityField::SetDataSet ( vtkDataSet * dataset ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual vtkDataSet* vtkInterpolatedVelocityField::GetDataSet ( ) [virtual]

Set / get the dataset used for the implicit function evaluation.

virtual vtkIdType vtkInterpolatedVelocityField::GetLastCellId ( ) [virtual]

Return the cell id cached from last evaluation.

virtual void vtkInterpolatedVelocityField::SetLastCellId ( vtkIdType ) [virtual]

Return the cell id cached from last evaluation.

void vtkInterpolatedVelocityField::ClearLastCellId ( ) [inline]

Set the last cell id to -1 so that the next search does not start from the previous cell

Definition at line 85 of file vtkInterpolatedVelocityField.h.

int vtkInterpolatedVelocityField::GetLastWeights ( float * w )

Returns the interpolation weights cached from last evaluation if the cached cell is valid (returns 1). Otherwise, it does not change w and returns 0.

int vtkInterpolatedVelocityField::GetLastLocalCoordinates ( float pcoords[3] )

Returns the interpolation weights cached from last evaluation if the cached cell is valid (returns 1). Otherwise, it does not change w and returns 0.

virtual int vtkInterpolatedVelocityField::GetCaching ( ) [virtual]

Turn caching on/off.

virtual void vtkInterpolatedVelocityField::SetCaching ( int ) [virtual]

Turn caching on/off.

virtual void vtkInterpolatedVelocityField::CachingOn ( ) [virtual]

Turn caching on/off.

virtual void vtkInterpolatedVelocityField::CachingOff ( ) [virtual]

Turn caching on/off.

virtual int vtkInterpolatedVelocityField::GetCacheHit ( ) [virtual]

Caching statistics.

virtual int vtkInterpolatedVelocityField::GetCacheMiss ( ) [virtual]

Caching statistics.

Member Data Documentation

vtkDataSet* vtkInterpolatedVelocityField::DataSet [protected]

Definition at line 112 of file vtkInterpolatedVelocityField.h.

vtkGenericCell* vtkInterpolatedVelocityField::GenCell [protected]

Definition at line 113 of file vtkInterpolatedVelocityField.h.

vtkGenericCell* vtkInterpolatedVelocityField::Cell [protected]

Definition at line 114 of file vtkInterpolatedVelocityField.h.

float* vtkInterpolatedVelocityField::Weights [protected]

Definition at line 115 of file vtkInterpolatedVelocityField.h.

float vtkInterpolatedVelocityField::LastPCoords[3] [protected]

Definition at line 116 of file vtkInterpolatedVelocityField.h.

vtkIdType vtkInterpolatedVelocityField::LastCellId [protected]

Definition at line 117 of file vtkInterpolatedVelocityField.h.

int vtkInterpolatedVelocityField::CacheHit [protected]

Definition at line 118 of file vtkInterpolatedVelocityField.h.

int vtkInterpolatedVelocityField::CacheMiss [protected]

Definition at line 119 of file vtkInterpolatedVelocityField.h.

int vtkInterpolatedVelocityField::Caching [protected]

Definition at line 120 of file vtkInterpolatedVelocityField.h.

The documentation for this class was generated from the following file:
  • Common/vtkInterpolatedVelocityField.h
Generated on Mon Mar 25 01:22:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkInterpolatingSubdivisionFilter Class Reference

generate a subdivision surface using an Interpolating Scheme. More...

#include <vtkInterpolatingSubdivisionFilter.h>

Inheritance diagram for vtkInterpolatingSubdivisionFilter:

[legend]
Collaboration diagram for vtkInterpolatingSubdivisionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkInterpolatingSubdivisionFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNumberOfSubdivisions (int)
virtual int | GetNumberOfSubdivisions ()

Protected Methods

vtkInterpolatingSubdivisionFilter ()
~vtkInterpolatingSubdivisionFilter ()
void | Execute ()
virtual void | GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)=0
void | GenerateSubdivisionCells (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD)
int | FindEdge (vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds)
vtkIdType | InterpolatePosition (vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights)

Protected Attributes

int | NumberOfSubdivisions

Detailed Description

generate a subdivision surface using an Interpolating Scheme.

Date:
2002/01/22 15:29:25
Revision:
1.14

vtkInterpolatingSubdivisionFilter is an abstract class that defines the protocol for interpolating subdivision surface filters.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (86%)
  • Henderson, Amy (11%)

Definition at line 42 of file vtkInterpolatingSubdivisionFilter.h.

Constructor & Destructor Documentation

vtkInterpolatingSubdivisionFilter::vtkInterpolatingSubdivisionFilter ( ) [protected]

vtkInterpolatingSubdivisionFilter::~vtkInterpolatingSubdivisionFilter ( ) [inline, protected]

Definition at line 56 of file vtkInterpolatingSubdivisionFilter.h.

Member Function Documentation

vtkInterpolatingSubdivisionFilter::vtkTypeRevisionMacro | ( | vtkInterpolatingSubdivisionFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

Reimplemented in vtkButterflySubdivisionFilter, and vtkLinearSubdivisionFilter.

void vtkInterpolatingSubdivisionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkInterpolatingSubdivisionFilter::SetNumberOfSubdivisions ( int ) [virtual]

Set/get the number of subdivisions.

virtual int vtkInterpolatingSubdivisionFilter::GetNumberOfSubdivisions ( ) [virtual]

Set/get the number of subdivisions.

void vtkInterpolatingSubdivisionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkInterpolatingSubdivisionFilter::GenerateSubdivisionPoints | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkPoints * | outputPts,
 |  | vtkPointData * | outputPD
 | ) | [protected, pure virtual]

Reimplemented in vtkLinearSubdivisionFilter.

void vtkInterpolatingSubdivisionFilter::GenerateSubdivisionCells | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkCellArray * | outputPolys,
 |  | vtkCellData * | outputCD
 | ) | [protected]

int vtkInterpolatingSubdivisionFilter::FindEdge | ( | vtkPolyData * | mesh,
 |  | vtkIdType | cellId,
 |  | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | vtkIntArray * | edgeData,
 |  | vtkIdList * | cellIds
 | ) | [protected]

vtkIdType vtkInterpolatingSubdivisionFilter::InterpolatePosition | ( | vtkPoints * | inputPts,
 |  | vtkPoints * | outputPts,
 |  | vtkIdList * | stencil,
 |  | float * | weights
 | ) | [protected]

Member Data Documentation

int vtkInterpolatingSubdivisionFilter::NumberOfSubdivisions [protected]

Definition at line 65 of file vtkInterpolatingSubdivisionFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkInterpolatingSubdivisionFilter.h
Generated on Mon Mar 25 01:22:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


istream Struct Reference

#include <vtkWinCE.h>

List of all members.

Public Methods

int | get (char &c)
int | putback (char &c)
istream & | operator>> (char *str)
istream & | operator>> (int &x)
istream & | operator>> (char &ch)
istream & | operator>> (float &fl)
istream & | operator>> (double &dbl)

Member Function Documentation

int istream::get ( char & c ) [inline]

Definition at line 94 of file vtkWinCE.h.

int istream::putback ( char & c ) [inline]

Definition at line 95 of file vtkWinCE.h.

istream& istream::operator>> ( char * str )

istream& istream::operator>> ( int & x )

istream& istream::operator>> ( char & ch )

istream& istream::operator>> ( float & fl )

istream& istream::operator>> ( double & dbl )

The documentation for this struct was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:22:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIterativeClosestPointTransform Class Reference

Implementation of the ICP algorithm. More...

#include <vtkIterativeClosestPointTransform.h>

Inheritance diagram for vtkIterativeClosestPointTransform:

[legend]
Collaboration diagram for vtkIterativeClosestPointTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIterativeClosestPointTransform, vtkLinearTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Inverse ()
vtkAbstractTransform * MakeTransform ()
void | SetSource (vtkDataSet *source)
void | SetTarget (vtkDataSet *target)
virtual vtkDataSet * | GetSource ()
virtual vtkDataSet * | GetTarget ()
void | SetLocator (vtkCellLocator *locator)
virtual vtkCellLocator * | GetLocator ()
virtual void | SetMaximumNumberOfIterations (int)
virtual int | GetMaximumNumberOfIterations ()
virtual int | GetNumberOfIterations ()
virtual void | SetCheckMeanDistance (int)
virtual int | GetCheckMeanDistance ()
virtual void | CheckMeanDistanceOn ()
virtual void | CheckMeanDistanceOff ()
virtual void | SetMeanDistanceMode (int)
virtual int | GetMeanDistanceMode ()
void | SetMeanDistanceModeToRMS ()
void | SetMeanDistanceModeToAbsoluteValue ()
const char * | GetMeanDistanceModeAsString ()
virtual void | SetMaximumMeanDistance (float)
virtual float | GetMaximumMeanDistance ()
virtual float | GetMeanDistance ()
virtual void | SetMaximumNumberOfLandmarks (int)
virtual int | GetMaximumNumberOfLandmarks ()
virtual void | SetStartByMatchingCentroids (int)
virtual int | GetStartByMatchingCentroids ()
virtual void | StartByMatchingCentroidsOn ()
virtual void | StartByMatchingCentroidsOff ()
virtual vtkLandmarkTransform * | GetLandmarkTransform ()

Static Public Methods

vtkIterativeClosestPointTransform * | New ()

Protected Methods

void | ReleaseLocator (void)
void | CreateDefaultLocator (void)
unsigned long int | GetMTime ()
vtkIterativeClosestPointTransform ()
~vtkIterativeClosestPointTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)
void | ReleaseSource (void)
void | ReleaseTarget (void)

Protected Attributes

vtkDataSet * Source
vtkDataSet * Target
vtkCellLocator * Locator
int | MaximumNumberOfIterations
int | CheckMeanDistance
int | MeanDistanceMode
float | MaximumMeanDistance
int | MaximumNumberOfLandmarks
int | StartByMatchingCentroids
int | NumberOfIterations
float | MeanDistance
vtkLandmarkTransform * LandmarkTransform

Detailed Description

Implementation of the ICP algorithm.

Date:
2002/01/22 15:30:32
Revision:
1.8

Match two surfaces using the iterative closest point (ICP) algorithm. The core of the algorithm is to match each vertex in one surface with the closest surface point on the other, then apply the transformation that modify one surface to best match the other (in a least square sense). This has to be iterated to get proper convergence of the surfaces.

Attention:
Use vtkTransformPolyDataFilter to apply the resulting ICP transform to your data. You might also set it to your actor's user transform.
This class makes use of vtkLandmarkTransform internally to compute the best fit. Use the GetLandmarkTransform member to get a pointer to that transform and set its parameters. You might, for example, constrain the number of degrees of freedom of the solution (i.e. rigid body, similarity, etc.) by checking the vtkLandmarkTransform documentation for its SetMode member.
See also:
vtkLandmarkTransform
Created by:
  • Barre, Sebastien
Contributed by (if > 5%):
  • Barre, Sebastien (96%)
Tests:
vtkIterativeClosestPointTransform (Tests)

Definition at line 63 of file vtkIterativeClosestPointTransform.h.

Constructor & Destructor Documentation

vtkIterativeClosestPointTransform::vtkIterativeClosestPointTransform ( ) [protected]

vtkIterativeClosestPointTransform::~vtkIterativeClosestPointTransform ( ) [protected]

Member Function Documentation

vtkIterativeClosestPointTransform* vtkIterativeClosestPointTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkIterativeClosestPointTransform::vtkTypeRevisionMacro | ( | vtkIterativeClosestPointTransform | ,
 |  | vtkLinearTransform |
 | ) |

Reimplemented from vtkLinearTransform.

void vtkIterativeClosestPointTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearTransform.

void vtkIterativeClosestPointTransform::SetSource ( vtkDataSet * source )

Specify the source and target data sets.

void vtkIterativeClosestPointTransform::SetTarget ( vtkDataSet * target )

Specify the source and target data sets.

virtual vtkDataSet* vtkIterativeClosestPointTransform::GetSource ( ) [virtual]

Specify the source and target data sets.

virtual vtkDataSet* vtkIterativeClosestPointTransform::GetTarget ( ) [virtual]

Specify the source and target data sets.

void vtkIterativeClosestPointTransform::SetLocator ( vtkCellLocator * locator )

Set/Get a spatial locator for speeding up the search process. An instance of vtkCellLocator is used by default.

virtual vtkCellLocator* vtkIterativeClosestPointTransform::GetLocator ( ) [virtual]

Set/Get a spatial locator for speeding up the search process. An instance of vtkCellLocator is used by default.

virtual void vtkIterativeClosestPointTransform::SetMaximumNumberOfIterations ( int ) [virtual]

Set/Get the maximum number of iterations

virtual int vtkIterativeClosestPointTransform::GetMaximumNumberOfIterations ( ) [virtual]

Set/Get the maximum number of iterations

virtual int vtkIterativeClosestPointTransform::GetNumberOfIterations ( ) [virtual]

Get the number of iterations since the last update

virtual void vtkIterativeClosestPointTransform::SetCheckMeanDistance ( int ) [virtual]

Force the algorithm to check the mean distance between two iteration.

virtual int vtkIterativeClosestPointTransform::GetCheckMeanDistance ( ) [virtual]

Force the algorithm to check the mean distance between two iteration.

virtual void vtkIterativeClosestPointTransform::CheckMeanDistanceOn ( ) [virtual]

Force the algorithm to check the mean distance between two iteration.

virtual void vtkIterativeClosestPointTransform::CheckMeanDistanceOff ( ) [virtual]

Force the algorithm to check the mean distance between two iteration.

virtual void vtkIterativeClosestPointTransform::SetMeanDistanceMode ( int ) [virtual]

Specify the mean distance mode. This mode expresses how the mean distance is computed. The RMS mode is the square root of the average of the sum of squares of the closest point distances. The Absolute Value mode is the mean of the sum of absolute values of the closest point distances.

virtual int vtkIterativeClosestPointTransform::GetMeanDistanceMode ( ) [virtual]

Specify the mean distance mode. This mode expresses how the mean distance is computed. The RMS mode is the square root of the average of the sum of squares of the closest point distances. The Absolute Value mode is the mean of the sum of absolute values of the closest point distances.

void vtkIterativeClosestPointTransform::SetMeanDistanceModeToRMS ( ) [inline]

Specify the mean distance mode. This mode expresses how the mean distance is computed. The RMS mode is the square root of the average of the sum of squares of the closest point distances. The Absolute Value mode is the mean of the sum of absolute values of the closest point distances.

Definition at line 112 of file vtkIterativeClosestPointTransform.h.

void vtkIterativeClosestPointTransform::SetMeanDistanceModeToAbsoluteValue ( ) [inline]

Specify the mean distance mode. This mode expresses how the mean distance is computed. The RMS mode is the square root of the average of the sum of squares of the closest point distances. The Absolute Value mode is the mean of the sum of absolute values of the closest point distances.

Definition at line 114 of file vtkIterativeClosestPointTransform.h.

const char* vtkIterativeClosestPointTransform::GetMeanDistanceModeAsString ( )

Specify the mean distance mode. This mode expresses how the mean distance is computed. The RMS mode is the square root of the average of the sum of squares of the closest point distances. The Absolute Value mode is the mean of the sum of absolute values of the closest point distances.

virtual void vtkIterativeClosestPointTransform::SetMaximumMeanDistance ( float ) [virtual]

Set/Get the maximum mean distance between two iteration. If the mean distance is lower than this, the convergence stops.

virtual float vtkIterativeClosestPointTransform::GetMaximumMeanDistance ( ) [virtual]

Set/Get the maximum mean distance between two iteration. If the mean distance is lower than this, the convergence stops.

virtual float vtkIterativeClosestPointTransform::GetMeanDistance ( ) [virtual]

Get the mean distance between the last two iterations.

virtual void vtkIterativeClosestPointTransform::SetMaximumNumberOfLandmarks ( int ) [virtual]

Set/Get the maximum number of landmarks sampled in your dataset. If your dataset is dense, then you will typically not need all the points to compute the ICP transform.

virtual int vtkIterativeClosestPointTransform::GetMaximumNumberOfLandmarks ( ) [virtual]

Set/Get the maximum number of landmarks sampled in your dataset. If your dataset is dense, then you will typically not need all the points to compute the ICP transform.

virtual void vtkIterativeClosestPointTransform::SetStartByMatchingCentroids ( int ) [virtual]

Starts the process by translating source centroid to target centroid.

virtual int vtkIterativeClosestPointTransform::GetStartByMatchingCentroids ( ) [virtual]

Starts the process by translating source centroid to target centroid.

virtual void vtkIterativeClosestPointTransform::StartByMatchingCentroidsOn ( ) [virtual]

Starts the process by translating source centroid to target centroid.

virtual void vtkIterativeClosestPointTransform::StartByMatchingCentroidsOff ( ) [virtual]

Starts the process by translating source centroid to target centroid.

virtual vtkLandmarkTransform* vtkIterativeClosestPointTransform::GetLandmarkTransform ( ) [virtual]

Get the internal landmark transform. Use it to constrain the number of degrees of freedom of the solution (i.e. rigid body, similarity, etc.).

void vtkIterativeClosestPointTransform::Inverse ( ) [virtual]

Invert the transformation. This is done by switching the source and target.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkIterativeClosestPointTransform::MakeTransform ( ) [virtual]

Make another transform of the same type.

Reimplemented from vtkAbstractTransform.

void vtkIterativeClosestPointTransform::ReleaseSource ( void ) [protected]

Release source and target

void vtkIterativeClosestPointTransform::ReleaseTarget ( void ) [protected]

Release source and target

void vtkIterativeClosestPointTransform::ReleaseLocator ( void ) [protected]

Release locator

void vtkIterativeClosestPointTransform::CreateDefaultLocator ( void ) [protected]

Create default locator. Used to create one when none is specified.

unsigned long int vtkIterativeClosestPointTransform::GetMTime ( ) [protected, virtual]

Get the MTime of this object also considering the locator.

Reimplemented from vtkAbstractTransform.

void vtkIterativeClosestPointTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

void vtkIterativeClosestPointTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

This method does no type checking, use DeepCopy instead.

Reimplemented from vtkHomogeneousTransform.

Member Data Documentation

vtkDataSet* vtkIterativeClosestPointTransform::Source [protected]

Definition at line 185 of file vtkIterativeClosestPointTransform.h.

vtkDataSet* vtkIterativeClosestPointTransform::Target [protected]

Definition at line 186 of file vtkIterativeClosestPointTransform.h.

vtkCellLocator* vtkIterativeClosestPointTransform::Locator [protected]

Definition at line 187 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::MaximumNumberOfIterations [protected]

Definition at line 188 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::CheckMeanDistance [protected]

Definition at line 189 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::MeanDistanceMode [protected]

Definition at line 190 of file vtkIterativeClosestPointTransform.h.

float vtkIterativeClosestPointTransform::MaximumMeanDistance [protected]

Definition at line 191 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::MaximumNumberOfLandmarks [protected]

Definition at line 192 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::StartByMatchingCentroids [protected]

Definition at line 193 of file vtkIterativeClosestPointTransform.h.

int vtkIterativeClosestPointTransform::NumberOfIterations [protected]

Definition at line 195 of file vtkIterativeClosestPointTransform.h.

float vtkIterativeClosestPointTransform::MeanDistance [protected]

Definition at line 196 of file vtkIterativeClosestPointTransform.h.

vtkLandmarkTransform* vtkIterativeClosestPointTransform::LandmarkTransform [protected]

Definition at line 197 of file vtkIterativeClosestPointTransform.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkIterativeClosestPointTransform.h
Generated on Mon Mar 25 01:22:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIVExporter Class Reference

export a scene into OpenInventor 2.0 format. More...

#include <vtkIVExporter.h>

Inheritance diagram for vtkIVExporter:

[legend]
Collaboration diagram for vtkIVExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIVExporter, vtkExporter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkIVExporter * | New ()

Protected Methods

vtkIVExporter ()
~vtkIVExporter ()
void | WriteData ()
void | WriteALight (vtkLight *aLight, FILE *fp)
void | WriteAnActor (vtkActor *anActor, FILE *fp)
void | WritePointData (vtkPoints *points, vtkDataArray *normals, vtkDataArray *tcoords, vtkUnsignedCharArray *colors, FILE *fp)

Protected Attributes

char * | FileName

Detailed Description

export a scene into OpenInventor 2.0 format.

Date:
2002/01/22 15:38:32
Revision:
1.23

vtkIVExporter is a concrete subclass of vtkExporter that writes OpenInventor 2.0 files.

See also:
vtkExporter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (69%)
  • Lorensen, Bill (16%)
Tests:
vtkIVExporter (Tests)

Definition at line 45 of file vtkIVExporter.h.

Constructor & Destructor Documentation

vtkIVExporter::vtkIVExporter ( ) [protected]

vtkIVExporter::~vtkIVExporter ( ) [protected]

Member Function Documentation

vtkIVExporter* vtkIVExporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkIVExporter::vtkTypeRevisionMacro | ( | vtkIVExporter | ,
 |  | vtkExporter |
 | ) |

Reimplemented from vtkExporter.

void vtkIVExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExporter.

virtual void vtkIVExporter::SetFileName ( const char * ) [virtual]

Specify the name of the OpenInventor file to write.

virtual char* vtkIVExporter::GetFileName ( ) [virtual]

Specify the name of the OpenInventor file to write.

void vtkIVExporter::WriteData ( ) [protected, virtual]

Reimplemented from vtkExporter.

void vtkIVExporter::WriteALight | ( | vtkLight * | aLight,
 |  | FILE * | fp
 | ) | [protected]

void vtkIVExporter::WriteAnActor | ( | vtkActor * | anActor,
 |  | FILE * | fp
 | ) | [protected]

void vtkIVExporter::WritePointData | ( | vtkPoints * | points,
 |  | vtkDataArray * | normals,
 |  | vtkDataArray * | tcoords,
 |  | vtkUnsignedCharArray * | colors,
 |  | FILE * | fp
 | ) | [protected]

Member Data Documentation

char* vtkIVExporter::FileName [protected]

Definition at line 68 of file vtkIVExporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkIVExporter.h
Generated on Mon Mar 25 01:22:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkIVWriter Class Reference

export polydata into OpenInventor 2.0 format. More...

#include <vtkIVWriter.h>

Inheritance diagram for vtkIVWriter:

[legend]
Collaboration diagram for vtkIVWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkIVWriter, vtkPolyDataWriter)

Static Public Methods

vtkIVWriter * | New ()

Protected Methods

vtkIVWriter ()
~vtkIVWriter ()
void | WriteData ()
void | WritePolyData (vtkPolyData *polyData, FILE *fp)

Detailed Description

export polydata into OpenInventor 2.0 format.

Date:
2002/01/22 15:38:14
Revision:
1.20

vtkIVWriter is a concrete subclass of vtkWriter that writes OpenInventor 2.0 files.

See also:
vtkPolyDataWriter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (62%)
  • Schroeder, Will (25%)
  • Lorensen, Bill (6%)
  • Henderson, Amy (5%)
Tests:
vtkIVWriter (Tests)

Definition at line 46 of file vtkIVWriter.h.

Constructor & Destructor Documentation

vtkIVWriter::vtkIVWriter ( ) [inline, protected]

Definition at line 53 of file vtkIVWriter.h.

vtkIVWriter::~vtkIVWriter ( ) [inline, protected]

Definition at line 54 of file vtkIVWriter.h.

Member Function Documentation

vtkIVWriter* vtkIVWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkPolyDataWriter.

vtkIVWriter::vtkTypeRevisionMacro | ( | vtkIVWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkIVWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

void vtkIVWriter::WritePolyData | ( | vtkPolyData * | polyData,
 |  | FILE * | fp
 | ) | [protected]

The documentation for this class was generated from the following file:
  • IO/vtkIVWriter.h
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJavaCommand Class Reference

#include <vtkJavaUtil.h>

Inheritance diagram for vtkJavaCommand:

[legend]
Collaboration diagram for vtkJavaCommand:

[legend]
List of all members.

Public Methods

void | SetGlobalRef (jobject obj)
void | SetMethodID (jmethodID id)
void | AssignJavaVM (JNIEnv *env)
void | Execute (vtkObject *, unsigned long, void *)

Static Public Methods

vtkJavaCommand * | New ()

Public Attributes

JavaVM * | vm
jobject | uobj
jmethodID | mid

Protected Methods

vtkJavaCommand ()
~vtkJavaCommand ()

Constructor & Destructor Documentation

vtkJavaCommand::vtkJavaCommand ( ) [protected]

vtkJavaCommand::~vtkJavaCommand ( ) [protected]

Member Function Documentation

vtkJavaCommand* vtkJavaCommand::New ( ) [inline, static]

Definition at line 63 of file vtkJavaUtil.h.

void vtkJavaCommand::SetGlobalRef ( jobject obj ) [inline]

Definition at line 65 of file vtkJavaUtil.h.

void vtkJavaCommand::SetMethodID ( jmethodID id ) [inline]

Definition at line 66 of file vtkJavaUtil.h.

void vtkJavaCommand::AssignJavaVM ( JNIEnv * env ) [inline]

Definition at line 67 of file vtkJavaUtil.h.

void vtkJavaCommand::Execute | ( | vtkObject * | caller,
 |  | unsigned long | event,
 |  | void * | callData
 | ) | [virtual]

Reimplemented from vtkCommand.

Member Data Documentation

JavaVM* vtkJavaCommand::vm

Definition at line 71 of file vtkJavaUtil.h.

jobject vtkJavaCommand::uobj

Definition at line 72 of file vtkJavaUtil.h.

jmethodID vtkJavaCommand::mid

Definition at line 73 of file vtkJavaUtil.h.

The documentation for this class was generated from the following file:
  • Common/vtkJavaUtil.h
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJavaVoidFuncArg Struct Reference

#include <vtkJavaUtil.h>

Collaboration diagram for vtkJavaVoidFuncArg:

[legend]
List of all members.

Public Attributes

JavaVM * | vm
jobject | uobj
jmethodID | mid

Member Data Documentation

JavaVM* vtkJavaVoidFuncArg::vm

Definition at line 52 of file vtkJavaUtil.h.

jobject vtkJavaVoidFuncArg::uobj

Definition at line 53 of file vtkJavaUtil.h.

jmethodID vtkJavaVoidFuncArg::mid

Definition at line 54 of file vtkJavaUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkJavaUtil.h
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJPEGReader Class Reference

read JPEG files. More...

#include <vtkJPEGReader.h>

Inheritance diagram for vtkJPEGReader:

[legend]
Collaboration diagram for vtkJPEGReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkJPEGReader, vtkImageReader2)
virtual vtkImageReader2 * | MakeObject ()
int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkJPEGReader * | New ()

Protected Methods

vtkJPEGReader ()
~vtkJPEGReader ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)

Detailed Description

read JPEG files.

Date:
2002/01/31 23:53:13
Revision:
1.8

vtkJPEGReader is a source object that reads JPEG files. It should be able to read most any JPEG file

See also:
vtkJPEGWriter
Created by:
  • Miller, Jim
Contributed by (if > 5%):
  • Miller, Jim (50%)
  • Hoffman, Bill (41%)
  • Cedilnik, Andy (5%)
Tests:
vtkJPEGReader (Tests)

Definition at line 46 of file vtkJPEGReader.h.

Constructor & Destructor Documentation

vtkJPEGReader::vtkJPEGReader ( ) [inline, protected]

Definition at line 75 of file vtkJPEGReader.h.

vtkJPEGReader::~vtkJPEGReader ( ) [inline, protected]

Definition at line 76 of file vtkJPEGReader.h.

Member Function Documentation

vtkJPEGReader* vtkJPEGReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Referenced by MakeObject().

vtkJPEGReader::vtkTypeRevisionMacro | ( | vtkJPEGReader | ,
 |  | vtkImageReader2 |
 | ) |

Reimplemented from vtkImageReader2.

virtual vtkImageReader2* vtkJPEGReader::MakeObject ( ) [inline, virtual]

Set/Get the internal file name

Reimplemented from vtkImageReader2.

Definition at line 52 of file vtkJPEGReader.h.

int vtkJPEGReader::CanReadFile ( const char * fname )

Is the given file a JPEG file?

virtual const char* vtkJPEGReader::GetFileExensions ( ) [inline, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented from vtkImageReader2.

Definition at line 60 of file vtkJPEGReader.h.

virtual const char* vtkJPEGReader::GetDescriptiveName ( ) [inline, virtual]

Return a descriptive name for the file format that might be useful in a GUI.

Reimplemented from vtkImageReader2.

Definition at line 69 of file vtkJPEGReader.h.

virtual void vtkJPEGReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

virtual void vtkJPEGReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

The documentation for this class was generated from the following file:
  • IO/vtkJPEGReader.h
Generated on Mon Mar 25 01:22:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkJPEGWriter Class Reference

Writes JPEG files. More...

#include <vtkJPEGWriter.h>

Inheritance diagram for vtkJPEGWriter:

[legend]
Collaboration diagram for vtkJPEGWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkJPEGWriter, vtkImageWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Write ()
virtual void | SetQuality (int)
virtual int | GetQuality ()
virtual void | SetProgressive (unsigned int)
virtual unsigned int | GetProgressive ()
virtual void | ProgressiveOn ()
virtual void | ProgressiveOff ()

Static Public Methods

vtkJPEGWriter * | New ()

Protected Methods

vtkJPEGWriter ()
~vtkJPEGWriter ()
void | WriteSlice (vtkImageData *data)

Detailed Description

Writes JPEG files.

Date:
2002/01/22 15:38:16
Revision:
1.6

vtkJPEGWriter writes JPEG files. It supports 1 and 3 component data of unsigned char. It relies on the IJG's libjpeg. Thanks to IJG for supplying a public jpeg IO library.

See also:
vtkJPEGReader
Created by:
  • Miller, Jim
Contributed by (if > 5%):
  • Miller, Jim (93%)
Tests:
vtkJPEGWriter (Tests)

Definition at line 44 of file vtkJPEGWriter.h.

Constructor & Destructor Documentation

vtkJPEGWriter::vtkJPEGWriter ( ) [protected]

vtkJPEGWriter::~vtkJPEGWriter ( ) [inline, protected]

Definition at line 69 of file vtkJPEGWriter.h.

Member Function Documentation

vtkJPEGWriter* vtkJPEGWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkJPEGWriter::vtkTypeRevisionMacro | ( | vtkJPEGWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

void vtkJPEGWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWriter.

virtual void vtkJPEGWriter::Write ( ) [virtual]

The main interface which triggers the writer to start.

Reimplemented from vtkImageWriter.

virtual void vtkJPEGWriter::SetQuality ( int ) [virtual]

Compression quality. 0 = Low quality, 100 = High quality

virtual int vtkJPEGWriter::GetQuality ( ) [virtual]

Compression quality. 0 = Low quality, 100 = High quality

virtual void vtkJPEGWriter::SetProgressive ( unsigned int ) [virtual]

Progressive JPEG generation.

virtual unsigned int vtkJPEGWriter::GetProgressive ( ) [virtual]

Progressive JPEG generation.

virtual void vtkJPEGWriter::ProgressiveOn ( ) [virtual]

Progressive JPEG generation.

virtual void vtkJPEGWriter::ProgressiveOff ( ) [virtual]

Progressive JPEG generation.

void vtkJPEGWriter::WriteSlice ( vtkImageData * data ) [protected]

The documentation for this class was generated from the following file:
  • IO/vtkJPEGWriter.h
Generated on Mon Mar 25 01:22:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKitwareContourFilter Class Reference

generate isosurfaces/isolines from scalar values. More...

#include <vtkKitwareContourFilter.h>

Inheritance diagram for vtkKitwareContourFilter:

[legend]
Collaboration diagram for vtkKitwareContourFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkKitwareContourFilter, vtkContourFilter)

Static Public Methods

vtkKitwareContourFilter * | New ()

Protected Methods

vtkKitwareContourFilter ()
~vtkKitwareContourFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *data)
void | Execute ()
void | ExecuteInformation ()
void | StructuredPointsContour (int dim)
void | StructuredGridContour (int dim)
void | DataSetContour ()

Detailed Description

generate isosurfaces/isolines from scalar values.

Date:
2002/01/22 15:35:27
Revision:
1.16

vtkKitwareContourFilter is a filter that takes as input any dataset and generates on output isosurfaces and/or isolines. The exact form of the output depends upon the dimensionality of the input data. Data consisting of 3D cells will generate isosurfaces, data consisting of 2D cells will generate isolines, and data with 1D or 0D cells will generate isopoints. Combinations of output type are possible if the input dimension is mixed.

This filter will identify special dataset types (e.g., structured points) and use the appropriate specialized filter to process the data. For examples, if the input dataset type is a volume, this filter will create an internal vtkSyncronizedTemplates3D instance and use it. This gives much better performance on StructuredPoints and StructuredGrids.

To use this filter you must specify one or more contour values. You can either use the method SetValue() to specify each contour value, or use GenerateValues() to generate a series of evenly spaced contours. It is also possible to accelerate the operation of this filter (at the cost of extra memory) by using a vtkScalarTree. A scalar tree is used to quickly locate cells that contain a contour surface. This is especially effective if multiple contours are being extracted. If you want to use a scalar tree, invoke the method UseScalarTreeOn().

Warning:
For StructuredPoints And StructuredGrids, normals are computed by default, but it is an expensive computation. Processing for other data set types has not been extended to include normal computation. In the mean time, use vtkPolyDataNormals to compute the surface normals.
See also:
vtkSynchronizedTemplates3D vtkSynchronizedTemplates2D vtkGridSynchronizedTemplates3D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (66%)
  • Martin, Ken (21%)
  • Geveci, Berk (8%)
Tests:
vtkKitwareContourFilter (Tests)

Definition at line 75 of file vtkKitwareContourFilter.h.

Constructor & Destructor Documentation

vtkKitwareContourFilter::vtkKitwareContourFilter ( ) [protected]

vtkKitwareContourFilter::~vtkKitwareContourFilter ( ) [protected]

Member Function Documentation

vtkKitwareContourFilter::vtkTypeRevisionMacro | ( | vtkKitwareContourFilter | ,
 |  | vtkContourFilter |
 | ) |

Reimplemented from vtkContourFilter.

vtkKitwareContourFilter* vtkKitwareContourFilter::New ( ) [static]

Construct object with initial range (0,1) and single contour value of 0.0.

Reimplemented from vtkContourFilter.

void vtkKitwareContourFilter::ComputeInputUpdateExtents ( vtkDataObject * data ) [protected, virtual]

Do not let images return more than requested.

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkKitwareContourFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkContourFilter.

void vtkKitwareContourFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkKitwareContourFilter::StructuredPointsContour ( int dim ) [protected]

void vtkKitwareContourFilter::StructuredGridContour ( int dim ) [protected]

void vtkKitwareContourFilter::DataSetContour ( ) [protected]

The documentation for this class was generated from the following file:
  • Patented/vtkKitwareContourFilter.h
Generated on Mon Mar 25 01:22:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKitwareObjectFactory Class Reference

Object Factory for Kitware patented objects. More...

#include <vtkKitwareObjectFactory.h>

Inheritance diagram for vtkKitwareObjectFactory:

[legend]
Collaboration diagram for vtkKitwareObjectFactory:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkKitwareObjectFactory, vtkObjectFactory)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual const char * | GetVTKSourceVersion ()

Static Public Methods

vtkKitwareObjectFactory * | New ()

Protected Methods

vtkKitwareObjectFactory ()
virtual vtkObject * | CreateObject (const char *vtkclassname)

Detailed Description

Object Factory for Kitware patented objects.

Date:
2002/01/22 15:35:28
Revision:
1.12

This is an object factory used to create Kitware patented objects. There is a KitwareFactory.dsp and KitwareFactory.dsw file to create the factory dll with the microsoft compiler. Once the Factory is created, put the resulting dll in VTK_AUTOLOAD_PATH.

See also:
vtkObjectFactory
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (92%)
  • Martin, Ken (8%)

Definition at line 43 of file vtkKitwareObjectFactory.h.

Constructor & Destructor Documentation

vtkKitwareObjectFactory::vtkKitwareObjectFactory ( ) [inline, protected]

Definition at line 51 of file vtkKitwareObjectFactory.h.

Member Function Documentation

vtkKitwareObjectFactory* vtkKitwareObjectFactory::New ( ) [inline, static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Definition at line 46 of file vtkKitwareObjectFactory.h.

vtkKitwareObjectFactory::vtkTypeRevisionMacro | ( | vtkKitwareObjectFactory | ,
 |  | vtkObjectFactory |
 | ) |

Reimplemented from vtkObjectFactory.

void vtkKitwareObjectFactory::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactory to stream.

Reimplemented from vtkObjectFactory.

virtual const char* vtkKitwareObjectFactory::GetVTKSourceVersion ( ) [virtual]

All sub-classes of vtkObjectFactory should must return the version of VTK they were built with. This should be implemented with the macro VTK_SOURCE_VERSION and NOT a call to vtkVersion::GetVTKSourceVersion. As the version needs to be compiled into the file as a string constant. This is critical to determine possible incompatible dynamic factory loads.

Reimplemented from vtkObjectFactory.

virtual vtkObject* vtkKitwareObjectFactory::CreateObject ( const char * vtkclassname ) [protected, virtual]

This method is provided by sub-classes of vtkObjectFactory. It should create the named vtk object or return 0 if that object is not supported by the factory implementation.

Reimplemented from vtkObjectFactory.

The documentation for this class was generated from the following file:
  • Patented/vtkKitwareObjectFactory.h
Generated on Mon Mar 25 01:22:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkKochanekSpline Class Reference

computes an interpolating spline using a Kochanek basis. More...

#include <vtkKochanekSpline.h>

Inheritance diagram for vtkKochanekSpline:

[legend]
Collaboration diagram for vtkKochanekSpline:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkKochanekSpline, vtkSpline)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Compute ()
float | Evaluate (float t)
virtual void | SetDefaultBias (float)
virtual float | GetDefaultBias ()
virtual void | SetDefaultTension (float)
virtual float | GetDefaultTension ()
virtual void | SetDefaultContinuity (float)
virtual float | GetDefaultContinuity ()

Static Public Methods

vtkKochanekSpline * | New ()

Protected Methods

vtkKochanekSpline ()
~vtkKochanekSpline ()
void | Fit1D (int n, float *x, float *y, float tension, float bias, float continuity, float coefficients[][4], int leftConstraint, float leftValue, int rightConstraint, float rightValue)

Protected Attributes

float | DefaultBias
float | DefaultTension
float | DefaultContinuity

Detailed Description

computes an interpolating spline using a Kochanek basis.

Date:
2002/01/22 15:28:08
Revision:
1.22

Implements the Kochenek interpolating spline described in: Kochanek, D., Bartels, R., "Interpolating Splines with Local Tension, Continuity, and Bias Control," Computer Graphics, vol. 18, no. 3, pp. 33-41, July 1984. These splines give the user more control over the shape of the curve than the cardinal splines implemented in vtkCardinalSpline. Three parameters can be specified. All have a range from -1 to 1.

Tension controls how sharply the curve bends at an input point. A value of -1 produces more slack in the curve. A value of 1 tightens the curve.

Continuity controls the continuity of the first derivative at input points.

Bias controls the direction of the curve at it passes through an input point. A value of -1 undershoots the point while a value of 1 overshoots the point.

These three parameters give the user broad control over the shape of the interpolating spline. The original Kochanek paper describes the effects nicely and is recommended reading.

See also:
vtkSpline vtkCardinalSpline
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (93%)
Examples:
vtkKochanekSpline (Examples)
Tests:
vtkKochanekSpline (Tests)

Definition at line 66 of file vtkKochanekSpline.h.

Constructor & Destructor Documentation

vtkKochanekSpline::vtkKochanekSpline ( ) [protected]

vtkKochanekSpline::~vtkKochanekSpline ( ) [inline, protected]

Definition at line 102 of file vtkKochanekSpline.h.

Member Function Documentation

vtkKochanekSpline::vtkTypeRevisionMacro | ( | vtkKochanekSpline | ,
 |  | vtkSpline |
 | ) |

Reimplemented from vtkSpline.

void vtkKochanekSpline::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSpline.

vtkKochanekSpline* vtkKochanekSpline::New ( ) [static]

Construct a KochanekSpline with the following defaults: DefaultBias = 0, DefaultTension = 0, DefaultContinuity = 0.

Reimplemented from vtkObject.

void vtkKochanekSpline::Compute ( ) [virtual]

Compute Kochanek Spline coefficients.

Reimplemented from vtkSpline.

float vtkKochanekSpline::Evaluate ( float t )

Evaluate a 1D Kochanek spline.

virtual void vtkKochanekSpline::SetDefaultBias ( float ) [virtual]

Set the bias for all points. Default is 0.

virtual float vtkKochanekSpline::GetDefaultBias ( ) [virtual]

Set the bias for all points. Default is 0.

virtual void vtkKochanekSpline::SetDefaultTension ( float ) [virtual]

Set the tension for all points. Default is 0.

virtual float vtkKochanekSpline::GetDefaultTension ( ) [virtual]

Set the tension for all points. Default is 0.

virtual void vtkKochanekSpline::SetDefaultContinuity ( float ) [virtual]

Set the continuity for all points. Default is 0.

virtual float vtkKochanekSpline::GetDefaultContinuity ( ) [virtual]

Set the continuity for all points. Default is 0.

void vtkKochanekSpline::Fit1D | ( | int | n,
 |  | float * | x,
 |  | float * | y,
 |  | float | tension,
 |  | float | bias,
 |  | float | continuity,
 |  | float | coefficients[][4],
 |  | int | leftConstraint,
 |  | float | leftValue,
 |  | int | rightConstraint,
 |  | float | rightValue
 | ) | [protected]

Member Data Documentation

float vtkKochanekSpline::DefaultBias [protected]

Definition at line 108 of file vtkKochanekSpline.h.

float vtkKochanekSpline::DefaultTension [protected]

Definition at line 109 of file vtkKochanekSpline.h.

float vtkKochanekSpline::DefaultContinuity [protected]

Definition at line 110 of file vtkKochanekSpline.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkKochanekSpline.h
Generated on Mon Mar 25 01:22:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLabeledDataMapper Class Reference

draw text labels at dataset points. More...

#include <vtkLabeledDataMapper.h>

Inheritance diagram for vtkLabeledDataMapper:

[legend]
Collaboration diagram for vtkLabeledDataMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLabeledDataMapper, vtkMapper2D)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)
virtual void | SetInput (vtkDataSet *)
virtual vtkDataSet * | GetInput ()
virtual void | SetLabelMode (int)
virtual int | GetLabelMode ()
void | SetLabelModeToLabelIds ()
void | SetLabelModeToLabelScalars ()
void | SetLabelModeToLabelVectors ()
void | SetLabelModeToLabelNormals ()
void | SetLabelModeToLabelTCoords ()
void | SetLabelModeToLabelTensors ()
void | SetLabelModeToLabelFieldData ()
virtual void | SetFontSize (int)
virtual int | GetFontSize ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
virtual void | SetLabeledComponent (int)
virtual int | GetLabeledComponent ()
virtual void | SetFieldDataArray (int)
virtual int | GetFieldDataArray ()

Static Public Methods

vtkLabeledDataMapper * | New ()

Protected Methods

vtkLabeledDataMapper ()
~vtkLabeledDataMapper ()

Protected Attributes

vtkDataSet * Input
int | LabelMode
int | FontSize
int | Bold
int | Italic
int | Shadow
int | FontFamily
char * | LabelFormat
int | LabeledComponent
int | FieldDataArray
vtkTimeStamp BuildTime

Detailed Description

draw text labels at dataset points.

Date:
2002/01/22 15:38:39
Revision:
1.27

vtkLabeledDataMapper is a mapper that renders text at dataset points. Various items can be labeled including point ids, scalars, vectors, normals, texture coordinates, tensors, and field data components.

The format with which the label is drawn is specified using a printf style format string. The font attributes of the text can also be set (font style, size, bold, italic, shadow). The color of the text is controlled by the actor2D's color property (i.e., the actor associated with this mapper).

By default, all the components of multi-component data such as vectors, normals, texture coordinates, tensors, and multi-component scalars are labeled. However, you can specify a single component if you prefer. (Note: the label format specifies the format to use for a single component. The label is creating by looping over all components and using the label format to render each component.)

Warning:
Use this filter in combination with vtkSelectVisiblePoints if you want to label only points that are visible. If you want to label cells rather than points, use the filter vtkCellCenters to generate points at the center of the cells. Also, you can use the class vtkIdFilter to generate ids as scalars or field data, which can then be labeled.
See also:
vtkMapper2D vtkActor2D vtkTextMapper vtkSelectVisiblePoints vtkIdFilter vtkCellCenters
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (61%)
  • Miller, Jim (14%)
  • Martin, Ken (12%)
Examples:
vtkLabeledDataMapper (Examples)
Tests:
vtkLabeledDataMapper (Tests)

Definition at line 80 of file vtkLabeledDataMapper.h.

Constructor & Destructor Documentation

vtkLabeledDataMapper::vtkLabeledDataMapper ( ) [protected]

vtkLabeledDataMapper::~vtkLabeledDataMapper ( ) [protected]

Member Function Documentation

vtkLabeledDataMapper* vtkLabeledDataMapper::New ( ) [static]

Instantiate object with font size 12 of font Arial (bolding, italic, shadows on) and %-#6.3g label format. By default, point ids are labeled.

Reimplemented from vtkMapper2D.

vtkLabeledDataMapper::vtkTypeRevisionMacro | ( | vtkLabeledDataMapper | ,
 |  | vtkMapper2D |
 | ) |

Reimplemented from vtkMapper2D.

void vtkLabeledDataMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper2D.

void vtkLabeledDataMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Draw the text to the screen at each input point.

Reimplemented from vtkMapper2D.

void vtkLabeledDataMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Draw the text to the screen at each input point.

Reimplemented from vtkMapper2D.

virtual void vtkLabeledDataMapper::SetInput ( vtkDataSet * ) [virtual]

Set the input dataset to the mapper.

virtual vtkDataSet* vtkLabeledDataMapper::GetInput ( ) [virtual]

Set the input dataset to the mapper.

virtual void vtkLabeledDataMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

virtual void vtkLabeledDataMapper::SetLabelMode ( int ) [virtual]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

virtual int vtkLabeledDataMapper::GetLabelMode ( ) [virtual]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

void vtkLabeledDataMapper::SetLabelModeToLabelIds ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 115 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelScalars ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 116 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelVectors ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 117 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelNormals ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 118 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelTCoords ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 119 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelTensors ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 120 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetLabelModeToLabelFieldData ( ) [inline]

Specify which data to plot: scalars, vectors, normals, texture coords, tensors, or field data. If the data has more than one component, use the method SetLabeledComponent to control which components to plot.

Definition at line 121 of file vtkLabeledDataMapper.h.

virtual void vtkLabeledDataMapper::SetFontSize ( int ) [virtual]

Set/Get the suggested font size used to label the data. (Suggested because not all font sizes may be available.) The value is expressed in points.

virtual int vtkLabeledDataMapper::GetFontSize ( ) [virtual]

Set/Get the suggested font size used to label the data. (Suggested because not all font sizes may be available.) The value is expressed in points.

virtual void vtkLabeledDataMapper::SetBold ( int ) [virtual]

Enable/Disable bolding labels.

virtual int vtkLabeledDataMapper::GetBold ( ) [virtual]

Enable/Disable bolding labels.

virtual void vtkLabeledDataMapper::BoldOn ( ) [virtual]

Enable/Disable bolding labels.

virtual void vtkLabeledDataMapper::BoldOff ( ) [virtual]

Enable/Disable bolding labels.

virtual void vtkLabeledDataMapper::SetItalic ( int ) [virtual]

Enable/Disable italicizing labels.

virtual int vtkLabeledDataMapper::GetItalic ( ) [virtual]

Enable/Disable italicizing labels.

virtual void vtkLabeledDataMapper::ItalicOn ( ) [virtual]

Enable/Disable italicizing labels.

virtual void vtkLabeledDataMapper::ItalicOff ( ) [virtual]

Enable/Disable italicizing labels.

virtual void vtkLabeledDataMapper::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the labels. Shadows make the text easier to read.

virtual int vtkLabeledDataMapper::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the labels. Shadows make the text easier to read.

virtual void vtkLabeledDataMapper::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the labels. Shadows make the text easier to read.

virtual void vtkLabeledDataMapper::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the labels. Shadows make the text easier to read.

virtual void vtkLabeledDataMapper::SetFontFamily ( int ) [virtual]

Set/Get the font family for the labels. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkLabeledDataMapper::GetFontFamily ( ) [virtual]

Set/Get the font family for the labels. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkLabeledDataMapper::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the labels. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 161 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the labels. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 162 of file vtkLabeledDataMapper.h.

void vtkLabeledDataMapper::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the labels. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 163 of file vtkLabeledDataMapper.h.

virtual void vtkLabeledDataMapper::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels. The format needs to change depending on what you're trying to print. For example, if you're printing a vector, 3 values are printed, whereas when printing an id only one value is printed. See also the ivar LabeledComponent which can be used to specify the component to print if you want to only print one of several.

virtual char* vtkLabeledDataMapper::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels. The format needs to change depending on what you're trying to print. For example, if you're printing a vector, 3 values are printed, whereas when printing an id only one value is printed. See also the ivar LabeledComponent which can be used to specify the component to print if you want to only print one of several.

virtual void vtkLabeledDataMapper::SetLabeledComponent ( int ) [virtual]

Set/Get the component number to label if the data to print has more than one component. For example, all the components of scalars, vectors, normals, etc. are labeled by default (LabeledComponent=(-1)). However, if this ivar is nonnegative, then only the one component specified is labeled.

virtual int vtkLabeledDataMapper::GetLabeledComponent ( ) [virtual]

Set/Get the component number to label if the data to print has more than one component. For example, all the components of scalars, vectors, normals, etc. are labeled by default (LabeledComponent=(-1)). However, if this ivar is nonnegative, then only the one component specified is labeled.

virtual void vtkLabeledDataMapper::SetFieldDataArray ( int ) [virtual]

Set/Get the field data array to label. This instance variable is only applicable if field data is labeled.

virtual int vtkLabeledDataMapper::GetFieldDataArray ( ) [virtual]

Set/Get the field data array to label. This instance variable is only applicable if field data is labeled.

Member Data Documentation

vtkDataSet* vtkLabeledDataMapper::Input [protected]

Definition at line 198 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::LabelMode [protected]

Definition at line 199 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::FontSize [protected]

Definition at line 201 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::Bold [protected]

Definition at line 202 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::Italic [protected]

Definition at line 203 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::Shadow [protected]

Definition at line 204 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::FontFamily [protected]

Definition at line 205 of file vtkLabeledDataMapper.h.

char* vtkLabeledDataMapper::LabelFormat [protected]

Definition at line 207 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::LabeledComponent [protected]

Definition at line 208 of file vtkLabeledDataMapper.h.

int vtkLabeledDataMapper::FieldDataArray [protected]

Definition at line 209 of file vtkLabeledDataMapper.h.

vtkTimeStamp vtkLabeledDataMapper::BuildTime [protected]

Definition at line 211 of file vtkLabeledDataMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkLabeledDataMapper.h
Generated on Mon Mar 25 01:22:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLandmarkTransform Class Reference

a linear transform specified by two corresponding point sets. More...

#include <vtkLandmarkTransform.h>

Inheritance diagram for vtkLandmarkTransform:

[legend]
Collaboration diagram for vtkLandmarkTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLandmarkTransform, vtkLinearTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Inverse ()
unsigned long | GetMTime ()
vtkAbstractTransform * MakeTransform ()
void | SetSourceLandmarks (vtkPoints *points)
void | SetTargetLandmarks (vtkPoints *points)
virtual vtkPoints * | GetSourceLandmarks ()
virtual vtkPoints * | GetTargetLandmarks ()
virtual void | SetMode (int)
void | SetModeToRigidBody ()
void | SetModeToSimilarity ()
void | SetModeToAffine ()
virtual int | GetMode ()
const char * | GetModeAsString ()

Static Public Methods

vtkLandmarkTransform * | New ()

Protected Methods

vtkLandmarkTransform ()
~vtkLandmarkTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)

Protected Attributes

vtkPoints * SourceLandmarks
vtkPoints * TargetLandmarks
int | Mode

Detailed Description

a linear transform specified by two corresponding point sets.

Date:
2002/01/22 15:30:33
Revision:
1.17

A vtkLandmarkTransform is defined by two sets of landmarks, the transform computed gives the best fit mapping one onto the other, in a least squares sense. The indices are taken to correspond, so point 1 in the first set will get mapped close to point 1 in the second set, etc. Call SetSourceLandmarks and SetTargetLandmarks to specify the two sets of landmarks, ensure they have the same number of points.

Warning:
Whenever you add, subtract, or set points you must call Modified() on the vtkPoints object, or the transformation might not update.
See also:
vtkLinearTransform
Created by:
  • Hutton, Tim
Contributed by (if > 5%):
  • Hutton, Tim (52%)
  • Gobbi, David (42%)

Definition at line 52 of file vtkLandmarkTransform.h.

Constructor & Destructor Documentation

vtkLandmarkTransform::vtkLandmarkTransform ( ) [protected]

vtkLandmarkTransform::~vtkLandmarkTransform ( ) [protected]

Member Function Documentation

vtkLandmarkTransform* vtkLandmarkTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkLandmarkTransform::vtkTypeRevisionMacro | ( | vtkLandmarkTransform | ,
 |  | vtkLinearTransform |
 | ) |

Reimplemented from vtkLinearTransform.

void vtkLandmarkTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearTransform.

void vtkLandmarkTransform::SetSourceLandmarks ( vtkPoints * points )

Specify the source and target landmark sets. The two sets must have the same number of points. If you add or change points in these objects, you must call Modified() on them or the transformation might not update.

void vtkLandmarkTransform::SetTargetLandmarks ( vtkPoints * points )

Specify the source and target landmark sets. The two sets must have the same number of points. If you add or change points in these objects, you must call Modified() on them or the transformation might not update.

virtual vtkPoints* vtkLandmarkTransform::GetSourceLandmarks ( ) [virtual]

Specify the source and target landmark sets. The two sets must have the same number of points. If you add or change points in these objects, you must call Modified() on them or the transformation might not update.

virtual vtkPoints* vtkLandmarkTransform::GetTargetLandmarks ( ) [virtual]

Specify the source and target landmark sets. The two sets must have the same number of points. If you add or change points in these objects, you must call Modified() on them or the transformation might not update.

virtual void vtkLandmarkTransform::SetMode ( int ) [virtual]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

void vtkLandmarkTransform::SetModeToRigidBody ( ) [inline]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

Definition at line 76 of file vtkLandmarkTransform.h.

void vtkLandmarkTransform::SetModeToSimilarity ( ) [inline]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

Definition at line 77 of file vtkLandmarkTransform.h.

void vtkLandmarkTransform::SetModeToAffine ( ) [inline]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

Definition at line 78 of file vtkLandmarkTransform.h.

virtual int vtkLandmarkTransform::GetMode ( ) [virtual]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

const char * vtkLandmarkTransform::GetModeAsString ( ) [inline]

Set the number of degrees of freedom to constrain the solution to. Rigidbody: rotation and translation only. Similarity: rotation, translation and isotropic scaling. The default is similarity.

Definition at line 113 of file vtkLandmarkTransform.h.

void vtkLandmarkTransform::Inverse ( ) [virtual]

Invert the transformation. This is done by switching the source and target landmarks.

Reimplemented from vtkAbstractTransform.

unsigned long vtkLandmarkTransform::GetMTime ( ) [virtual]

Get the MTime.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkLandmarkTransform::MakeTransform ( ) [virtual]

Make another transform of the same type.

Reimplemented from vtkAbstractTransform.

void vtkLandmarkTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

void vtkLandmarkTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

This method does no type checking, use DeepCopy instead.

Reimplemented from vtkHomogeneousTransform.

Member Data Documentation

vtkPoints* vtkLandmarkTransform::SourceLandmarks [protected]

Definition at line 103 of file vtkLandmarkTransform.h.

vtkPoints* vtkLandmarkTransform::TargetLandmarks [protected]

Definition at line 104 of file vtkLandmarkTransform.h.

int vtkLandmarkTransform::Mode [protected]

Definition at line 106 of file vtkLandmarkTransform.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkLandmarkTransform.h
Generated on Mon Mar 25 01:22:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLargeInteger Class Reference

class for arbitrarily large ints. More...

#include <vtkLargeInteger.h>

Collaboration diagram for vtkLargeInteger:

[legend]
List of all members.

Public Methods

vtkLargeInteger (void)
vtkLargeInteger (long n)
vtkLargeInteger (unsigned long n)
vtkLargeInteger (int n)
vtkLargeInteger (unsigned int n)
vtkLargeInteger (const vtkLargeInteger &n)
~vtkLargeInteger (void)
char | CastToChar (void) const
short | CastToShort (void) const
int | CastToInt (void) const
long | CastToLong (void) const
unsigned long | CastToUnsignedLong (void) const
int | IsEven (void) const
int | IsOdd (void) const
int | GetLength (void) const
int | GetBit (unsigned int p) const
int | IsZero () const
int | GetSign (void) const
void | Truncate (unsigned int n)
void | Complement (void)
int | operator== (const vtkLargeInteger &n) const
int | operator!= (const vtkLargeInteger &n) const
int | operator< (const vtkLargeInteger &n) const
int | operator<= (const vtkLargeInteger &n) const
int | operator> (const vtkLargeInteger &n) const
int | operator>= (const vtkLargeInteger &n) const
vtkLargeInteger & | operator= (const vtkLargeInteger &n)
vtkLargeInteger & | operator+= (const vtkLargeInteger &n)
vtkLargeInteger & | operator-= (const vtkLargeInteger &n)
vtkLargeInteger & | operator<<= (int n)
vtkLargeInteger & | operator>>= (int n)
vtkLargeInteger & | operator++ (void)
vtkLargeInteger & | operator-- (void)
vtkLargeInteger | operator++ (int)
vtkLargeInteger | operator-- (int)
vtkLargeInteger & | operator *= (const vtkLargeInteger &n)
vtkLargeInteger & | operator/= (const vtkLargeInteger &n)
vtkLargeInteger & | operator%= (const vtkLargeInteger &n)
vtkLargeInteger & | operator &= (const vtkLargeInteger &n)
vtkLargeInteger & | operator|= (const vtkLargeInteger &n)
vtkLargeInteger & | operator^= (const vtkLargeInteger &n)
vtkLargeInteger | operator+ (const vtkLargeInteger &n) const
vtkLargeInteger | operator- (const vtkLargeInteger &n) const
vtkLargeInteger | operator * (const vtkLargeInteger &n) const
vtkLargeInteger | operator/ (const vtkLargeInteger &n) const
vtkLargeInteger | operator% (const vtkLargeInteger &n) const
vtkLargeInteger | operator & (const vtkLargeInteger &n) const
vtkLargeInteger | operator| (const vtkLargeInteger &n) const
vtkLargeInteger | operator^ (const vtkLargeInteger &n) const
vtkLargeInteger | operator<< (int n) const
vtkLargeInteger | operator>> (int n) const

Friends

ostream & | operator<< (ostream &s, const vtkLargeInteger &n)
istream & | operator>> (istream &s, vtkLargeInteger &n)

Detailed Description

class for arbitrarily large ints.

Date:
2002/01/22 15:25:33
Revision:
1.6
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (95%)

Definition at line 34 of file vtkLargeInteger.h.

Constructor & Destructor Documentation

vtkLargeInteger::vtkLargeInteger ( void )

vtkLargeInteger::vtkLargeInteger ( long n )

vtkLargeInteger::vtkLargeInteger ( unsigned long n )

vtkLargeInteger::vtkLargeInteger ( int n )

vtkLargeInteger::vtkLargeInteger ( unsigned int n )

vtkLargeInteger::vtkLargeInteger ( const vtkLargeInteger & n )

vtkLargeInteger::~vtkLargeInteger ( void )

Member Function Documentation

char vtkLargeInteger::CastToChar ( void ) const

short vtkLargeInteger::CastToShort ( void ) const

int vtkLargeInteger::CastToInt ( void ) const

long vtkLargeInteger::CastToLong ( void ) const

unsigned long vtkLargeInteger::CastToUnsignedLong ( void ) const

int vtkLargeInteger::IsEven ( void ) const

int vtkLargeInteger::IsOdd ( void ) const

int vtkLargeInteger::GetLength ( void ) const

int vtkLargeInteger::GetBit ( unsigned int p ) const

int vtkLargeInteger::IsZero ( ) const

int vtkLargeInteger::GetSign ( void ) const

void vtkLargeInteger::Truncate ( unsigned int n )

void vtkLargeInteger::Complement ( void )

int vtkLargeInteger::operator== ( const vtkLargeInteger & n ) const

int vtkLargeInteger::operator!= ( const vtkLargeInteger & n ) const

int vtkLargeInteger::operator< ( const vtkLargeInteger & n ) const

int vtkLargeInteger::operator<= ( const vtkLargeInteger & n ) const

int vtkLargeInteger::operator> ( const vtkLargeInteger & n ) const

int vtkLargeInteger::operator>= ( const vtkLargeInteger & n ) const

vtkLargeInteger& vtkLargeInteger::operator= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator+= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator-= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator<<= ( int n )

vtkLargeInteger& vtkLargeInteger::operator>>= ( int n )

vtkLargeInteger& vtkLargeInteger::operator++ ( void )

vtkLargeInteger& vtkLargeInteger::operator-- ( void )

vtkLargeInteger vtkLargeInteger::operator++ ( int )

vtkLargeInteger vtkLargeInteger::operator-- ( int )

vtkLargeInteger& vtkLargeInteger::operator *= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator/= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator%= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator &= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator|= ( const vtkLargeInteger & n )

vtkLargeInteger& vtkLargeInteger::operator^= ( const vtkLargeInteger & n )

vtkLargeInteger vtkLargeInteger::operator+ ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator- ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator * ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator/ ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator% ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator & ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator| ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator^ ( const vtkLargeInteger & n ) const

vtkLargeInteger vtkLargeInteger::operator<< ( int n ) const

vtkLargeInteger vtkLargeInteger::operator>> ( int n ) const

Friends And Related Function Documentation

ostream& operator<< | ( | ostream & | s,
 |  | const vtkLargeInteger & | n
 | ) | [friend]

istream& operator>> | ( | istream & | s,
 |  | vtkLargeInteger & | n
 | ) | [friend]

The documentation for this class was generated from the following file:
  • Common/vtkLargeInteger.h
Generated on Mon Mar 25 01:23:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLegendBoxActor Class Reference

draw symbols with text. More...

#include <vtkLegendBoxActor.h>

Inheritance diagram for vtkLegendBoxActor:

[legend]
Collaboration diagram for vtkLegendBoxActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLegendBoxActor, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ShallowCopy (vtkProp *prop)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | SetNumberOfEntries (int num)
int | GetNumberOfEntries ()
void | SetEntry (int i, vtkPolyData *symbol, const char *string, float color[3])
void | SetEntrySymbol (int i, vtkPolyData *symbol)
void | SetEntryString (int i, const char *string)
void | SetEntryColor (int i, float color[3])
void | SetEntryColor (int i, float r, float g, float b)
vtkPolyData * | GetEntrySymbol (int i)
const char * | GetEntryString (int i)
float * | GetEntryColor (int i)
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetBorder (int)
virtual int | GetBorder ()
virtual void | BorderOn ()
virtual void | BorderOff ()
virtual void | SetLockBorder (int)
virtual int | GetLockBorder ()
virtual void | LockBorderOn ()
virtual void | LockBorderOff ()
virtual void | SetPadding (int)
virtual int | GetPadding ()
virtual void | SetScalarVisibility (int)
virtual int | GetScalarVisibility ()
virtual void | ScalarVisibilityOn ()
virtual void | ScalarVisibilityOff ()
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *viewport)

Static Public Methods

vtkLegendBoxActor * | New ()

Protected Methods

vtkLegendBoxActor ()
~vtkLegendBoxActor ()
void | InitializeEntries ()

Protected Attributes

int | Bold
int | Italic
int | Shadow
int | FontFamily
int | Border
int | Padding
int | LockBorder
int | ScalarVisibility
int | NumberOfEntries
int | Size
vtkFloatArray * Colors
vtkTextMapper ** TextMapper
vtkActor2D ** TextActor
vtkPolyData ** Symbol
vtkTransform ** Transform
vtkTransformPolyDataFilter ** SymbolTransform
vtkPolyDataMapper2D ** SymbolMapper
vtkActor2D ** SymbolActor
vtkPolyData * BorderPolyData
vtkPolyDataMapper2D * BorderMapper
vtkActor2D * BorderActor
int | LegendEntriesVisible
int | CachedSize [2]
vtkTimeStamp BuildTime

Detailed Description

draw symbols with text.

Date:
2002/01/22 15:30:34
Revision:
1.11

vtkLegendBoxActor is used to associate a symbol with a text string. The user specifies a vtkPolyData to use as the symbol, and a string associated with the symbol. The actor can then be placed in the scene in the same way that any other vtkActor2D can be used.

To use this class, you must define the position of the legend box by using the superclasses' vtkActor2D::Position coordinate and Position2 coordinate. Then define the set of symbols and text strings that make up the menu box (as well as properties such as font). The class will scale the symbols and text to fit in the legend box defined by (Position,Position2). Optional features like turning on a border line and setting the spacing between the border and the symbols/text can also be set.

See also:
vtkXYPlotActor vtkActor2D vtkGlyphSource2D
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (90%)

Definition at line 59 of file vtkLegendBoxActor.h.

Constructor & Destructor Documentation

vtkLegendBoxActor::vtkLegendBoxActor ( ) [protected]

vtkLegendBoxActor::~vtkLegendBoxActor ( ) [protected]

Member Function Documentation

vtkLegendBoxActor::vtkTypeRevisionMacro | ( | vtkLegendBoxActor | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkLegendBoxActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkLegendBoxActor* vtkLegendBoxActor::New ( ) [static]

Instantiate object with a rectangle in normaled view coordinates of (0.2,0.85, 0.8, 0.95).

Reimplemented from vtkActor2D.

void vtkLegendBoxActor::SetNumberOfEntries ( int num )

Specify the number of entries in the legend box.

int vtkLegendBoxActor::GetNumberOfEntries ( ) [inline]

Specify the number of entries in the legend box.

Definition at line 72 of file vtkLegendBoxActor.h.

void vtkLegendBoxActor::SetEntry | ( | int | i,
 |  | vtkPolyData * | symbol,
 |  | const char * | string,
 |  | float | color[3]
 | ) |

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

void vtkLegendBoxActor::SetEntrySymbol | ( | int | i,
 |  | vtkPolyData * | symbol
 | ) |

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

void vtkLegendBoxActor::SetEntryString | ( | int | i,
 |  | const char * | string
 | ) |

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

void vtkLegendBoxActor::SetEntryColor | ( | int | i,
 |  | float | color[3]
 | ) |

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

void vtkLegendBoxActor::SetEntryColor | ( | int | i,
 |  | float | r,
 |  | float | g,
 |  | float | b
 | ) |

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

vtkPolyData* vtkLegendBoxActor::GetEntrySymbol ( int i )

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

const char* vtkLegendBoxActor::GetEntryString ( int i )

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

float* vtkLegendBoxActor::GetEntryColor ( int i )

Add an entry to the legend box. You must supply a vtkPolyData to be used as a symbol (it can be NULL) and a text string (which also can be NULL). The vtkPolyData is assumed to be defined in the x-y plane, and the text is assumed to be a single line in height. Note that when this method is invoked previous entries are deleted. Also supply a text string and optionally a color. (If a color is not specified, then the entry color is the same as this actor's color.) (Note: use the set methods when you use SetNumberOfEntries().)

virtual void vtkLegendBoxActor::SetBold ( int ) [virtual]

Enable/Disable bolding legend entries.

virtual int vtkLegendBoxActor::GetBold ( ) [virtual]

Enable/Disable bolding legend entries.

virtual void vtkLegendBoxActor::BoldOn ( ) [virtual]

Enable/Disable bolding legend entries.

virtual void vtkLegendBoxActor::BoldOff ( ) [virtual]

Enable/Disable bolding legend entries.

virtual void vtkLegendBoxActor::SetItalic ( int ) [virtual]

Enable/Disable italicizing legend entries.

virtual int vtkLegendBoxActor::GetItalic ( ) [virtual]

Enable/Disable italicizing legend entries.

virtual void vtkLegendBoxActor::ItalicOn ( ) [virtual]

Enable/Disable italicizing legend entries.

virtual void vtkLegendBoxActor::ItalicOff ( ) [virtual]

Enable/Disable italicizing legend entries.

virtual void vtkLegendBoxActor::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the legend entries. Shadows make the text easier to read.

virtual int vtkLegendBoxActor::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the legend entries. Shadows make the text easier to read.

virtual void vtkLegendBoxActor::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the legend entries. Shadows make the text easier to read.

virtual void vtkLegendBoxActor::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the legend entries. Shadows make the text easier to read.

virtual void vtkLegendBoxActor::SetFontFamily ( int ) [virtual]

Set/Get the font family for the legend entries. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkLegendBoxActor::GetFontFamily ( ) [virtual]

Set/Get the font family for the legend entries. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkLegendBoxActor::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the legend entries. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 123 of file vtkLegendBoxActor.h.

void vtkLegendBoxActor::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the legend entries. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 124 of file vtkLegendBoxActor.h.

void vtkLegendBoxActor::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the legend entries. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 125 of file vtkLegendBoxActor.h.

virtual void vtkLegendBoxActor::SetBorder ( int ) [virtual]

Set/Get the flag that controls whether a border will be drawn around the legend box.

virtual int vtkLegendBoxActor::GetBorder ( ) [virtual]

Set/Get the flag that controls whether a border will be drawn around the legend box.

virtual void vtkLegendBoxActor::BorderOn ( ) [virtual]

Set/Get the flag that controls whether a border will be drawn around the legend box.

virtual void vtkLegendBoxActor::BorderOff ( ) [virtual]

Set/Get the flag that controls whether a border will be drawn around the legend box.

virtual void vtkLegendBoxActor::SetLockBorder ( int ) [virtual]

Set/Get the flag that controls whether the border and legend placement is locked into the rectangle defined by (Position,Position2). If off, then the legend box will adjust its size so that the border fits nicely around the text and symbols. (The ivar is off by default.) Note: the legend box is guaranteed to lie within the original border definition.

virtual int vtkLegendBoxActor::GetLockBorder ( ) [virtual]

Set/Get the flag that controls whether the border and legend placement is locked into the rectangle defined by (Position,Position2). If off, then the legend box will adjust its size so that the border fits nicely around the text and symbols. (The ivar is off by default.) Note: the legend box is guaranteed to lie within the original border definition.

virtual void vtkLegendBoxActor::LockBorderOn ( ) [virtual]

Set/Get the flag that controls whether the border and legend placement is locked into the rectangle defined by (Position,Position2). If off, then the legend box will adjust its size so that the border fits nicely around the text and symbols. (The ivar is off by default.) Note: the legend box is guaranteed to lie within the original border definition.

virtual void vtkLegendBoxActor::LockBorderOff ( ) [virtual]

Set/Get the flag that controls whether the border and legend placement is locked into the rectangle defined by (Position,Position2). If off, then the legend box will adjust its size so that the border fits nicely around the text and symbols. (The ivar is off by default.) Note: the legend box is guaranteed to lie within the original border definition.

virtual void vtkLegendBoxActor::SetPadding ( int ) [virtual]

Set/Get the padding between the legend entries and the border. The value is specified in pixels.

virtual int vtkLegendBoxActor::GetPadding ( ) [virtual]

Set/Get the padding between the legend entries and the border. The value is specified in pixels.

virtual void vtkLegendBoxActor::SetScalarVisibility ( int ) [virtual]

Turn on/off flag to control whether the symbol's scalar data is used to color the symbol. If off, the color of the vtkLegendBoxActor is used.

virtual int vtkLegendBoxActor::GetScalarVisibility ( ) [virtual]

Turn on/off flag to control whether the symbol's scalar data is used to color the symbol. If off, the color of the vtkLegendBoxActor is used.

virtual void vtkLegendBoxActor::ScalarVisibilityOn ( ) [virtual]

Turn on/off flag to control whether the symbol's scalar data is used to color the symbol. If off, the color of the vtkLegendBoxActor is used.

virtual void vtkLegendBoxActor::ScalarVisibilityOff ( ) [virtual]

Turn on/off flag to control whether the symbol's scalar data is used to color the symbol. If off, the color of the vtkLegendBoxActor is used.

void vtkLegendBoxActor::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this scaled text actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor2D.

virtual void vtkLegendBoxActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

int vtkLegendBoxActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

int vtkLegendBoxActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

Definition at line 180 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::RenderOverlay ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the legend box to the screen.

Reimplemented from vtkActor2D.

void vtkLegendBoxActor::InitializeEntries ( ) [protected]

Member Data Documentation

int vtkLegendBoxActor::Bold [protected]

Definition at line 191 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::Italic [protected]

Definition at line 192 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::Shadow [protected]

Definition at line 193 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::FontFamily [protected]

Definition at line 194 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::Border [protected]

Definition at line 195 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::Padding [protected]

Definition at line 196 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::LockBorder [protected]

Definition at line 197 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::ScalarVisibility [protected]

Definition at line 198 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::NumberOfEntries [protected]

Definition at line 201 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::Size [protected]

Definition at line 202 of file vtkLegendBoxActor.h.

vtkFloatArray* vtkLegendBoxActor::Colors [protected]

Definition at line 203 of file vtkLegendBoxActor.h.

vtkTextMapper** vtkLegendBoxActor::TextMapper [protected]

Definition at line 204 of file vtkLegendBoxActor.h.

vtkActor2D** vtkLegendBoxActor::TextActor [protected]

Definition at line 205 of file vtkLegendBoxActor.h.

vtkPolyData** vtkLegendBoxActor::Symbol [protected]

Definition at line 206 of file vtkLegendBoxActor.h.

vtkTransform** vtkLegendBoxActor::Transform [protected]

Definition at line 207 of file vtkLegendBoxActor.h.

vtkTransformPolyDataFilter** vtkLegendBoxActor::SymbolTransform [protected]

Definition at line 208 of file vtkLegendBoxActor.h.

vtkPolyDataMapper2D** vtkLegendBoxActor::SymbolMapper [protected]

Definition at line 209 of file vtkLegendBoxActor.h.

vtkActor2D** vtkLegendBoxActor::SymbolActor [protected]

Definition at line 210 of file vtkLegendBoxActor.h.

vtkPolyData* vtkLegendBoxActor::BorderPolyData [protected]

Definition at line 211 of file vtkLegendBoxActor.h.

vtkPolyDataMapper2D* vtkLegendBoxActor::BorderMapper [protected]

Definition at line 212 of file vtkLegendBoxActor.h.

vtkActor2D* vtkLegendBoxActor::BorderActor [protected]

Definition at line 213 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::LegendEntriesVisible [protected]

Definition at line 216 of file vtkLegendBoxActor.h.

int vtkLegendBoxActor::CachedSize[2] [protected]

Definition at line 217 of file vtkLegendBoxActor.h.

vtkTimeStamp vtkLegendBoxActor::BuildTime [protected]

Definition at line 218 of file vtkLegendBoxActor.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkLegendBoxActor.h
Generated on Mon Mar 25 01:23:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLight Class Reference

a virtual light for 3D rendering. More...

#include <vtkLight.h>

Inheritance diagram for vtkLight:

[legend]
Collaboration diagram for vtkLight:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLight, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Render (vtkRenderer *, int)
void | DeepCopy (vtkLight *light)
virtual void | SetLightType (int)
virtual int | GetLightType ()
void | SetLightTypeToHeadlight ()
void | SetLightTypeToSceneLight ()
void | SetLightTypeToCameraLight ()
void | ReadSelf (istream &is)
void | WriteSelf (ostream &os)
virtual void | SetColor (float, float, float)
virtual void | SetColor (float[3])
virtual float * | GetColor ()
virtual void | GetColor (float data[3])
virtual void | SetPosition (float, float, float)
virtual void | SetPosition (float[3])
virtual float * | GetPosition ()
virtual void | GetPosition (float data[3])
void | SetPosition (double *a)
virtual void | SetFocalPoint (float, float, float)
virtual void | SetFocalPoint (float[3])
virtual float * | GetFocalPoint ()
virtual void | GetFocalPoint (float data[3])
void | SetFocalPoint (double *a)
virtual void | SetIntensity (float)
virtual float | GetIntensity ()
virtual void | SetSwitch (int)
virtual int | GetSwitch ()
virtual void | SwitchOn ()
virtual void | SwitchOff ()
virtual void | SetPositional (int)
virtual int | GetPositional ()
virtual void | PositionalOn ()
virtual void | PositionalOff ()
virtual void | SetExponent (float)
virtual float | GetExponent ()
virtual void | SetConeAngle (float)
virtual float | GetConeAngle ()
virtual void | SetAttenuationValues (float, float, float)
virtual void | SetAttenuationValues (float[3])
virtual float * | GetAttenuationValues ()
virtual void | GetAttenuationValues (float data[3])
virtual void | SetTransformMatrix (vtkMatrix4x4 *)
virtual vtkMatrix4x4 * | GetTransformMatrix ()
void | GetTransformedPosition (float &a0, float &a1, float &a2)
void | GetTransformedPosition (float a[3])
float * | GetTransformedPosition ()
void | GetTransformedFocalPoint (float &a0, float &a1, float &a2)
void | GetTransformedFocalPoint (float a[3])
float * | GetTransformedFocalPoint ()
void | SetDirectionAngle (float elevation, float azimuth)
void | SetDirectionAngle (float ang[2])
int | LightTypeIsHeadlight ()
int | LightTypeIsSceneLight ()
int | LightTypeIsCameraLight ()

Static Public Methods

vtkLight * | New ()

Protected Methods

vtkLight ()
~vtkLight ()

Protected Attributes

float | FocalPoint [3]
float | Position [3]
float | Intensity
float | Color [3]
int | Switch
int | Positional
float | Exponent
float | ConeAngle
float | AttenuationValues [3]
vtkMatrix4x4 * TransformMatrix
float | TransformedFocalPointReturn [3]
float | TransformedPositionReturn [3]
int | LightType

Detailed Description

a virtual light for 3D rendering.

Date:
2002/01/22 15:38:39
Revision:
1.51

vtkLight is a virtual light for 3D rendering. It provides methods to locate and point the light, turn it on and off, and set its brightness and color. In addition to the basic infinite distance point light source attributes, you also can specify the light attenuation values and cone angle. These attributes are only used if the light is a positional light. The default is a directional light (e.g. infinite point light source).

Lights have a type that describes how the light should move with respect to the camera. A Headlight is always located at the current camera position and shines on the camera's focal point. A CameraLight also moves with the camera, but may not be coincident to it. CameraLights are defined in a normalized coordinate space where the camera is located at (0, 0, 1), the camera is looking at (0, 0, 0), and up is (0, 1, 0). Finally, a SceneLight is part of the scene itself and does not move with the camera. (Renderers are responsible for moving the light based on its type.)

Lights have a transformation matrix that describes the space in which they are positioned. A light's world space position and focal point are defined by their local position and focal point, transformed by their transformation matrix (if it exists).

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (51%)
  • Halle, Michael (32%)
  • Schroeder, Will (9%)
Examples:
vtkLight (Examples)
Tests:
vtkLight (Tests)

Definition at line 71 of file vtkLight.h.

Constructor & Destructor Documentation

vtkLight::vtkLight ( ) [protected]

vtkLight::~vtkLight ( ) [protected]

Member Function Documentation

vtkLight::vtkTypeRevisionMacro | ( | vtkLight | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkRIBLight, vtkMesaLight, and vtkOpenGLLight.

void vtkLight::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkRIBLight.

vtkLight* vtkLight::New ( ) [static]

Create a light with the focal point at the origin and its position set to (0,0,1). The light is a SceneLight, its color is white, intensity=1, and the light is turned on.

Reimplemented from vtkObject.

Reimplemented in vtkRIBLight, vtkMesaLight, and vtkOpenGLLight.

virtual void vtkLight::Render | ( | vtkRenderer * | ren,
 |  | int | index
 | ) | [inline, virtual]

Abstract interface to renderer. Each concrete subclass of vtkLight will load its data into the graphics system in response to this method invocation. The actual loading is performed by a vtkLightDevice subclass, which will get created automatically.

Reimplemented in vtkRIBLight, vtkMesaLight, and vtkOpenGLLight.

Definition at line 86 of file vtkLight.h.

virtual void vtkLight::SetColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the color of the light.

virtual void vtkLight::SetColor ( float [3] ) [virtual]

Set/Get the color of the light.

virtual float* vtkLight::GetColor ( ) [virtual]

Set/Get the color of the light.

virtual void vtkLight::GetColor ( float data[3] ) [virtual]

Set/Get the color of the light.

virtual void vtkLight::SetPosition | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the position of the light. Note: The position of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space position, use vtkGetTransformedPosition() instead of vtkGetPosition().

virtual void vtkLight::SetPosition ( float [3] ) [virtual]

Set/Get the position of the light. Note: The position of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space position, use vtkGetTransformedPosition() instead of vtkGetPosition().

virtual float* vtkLight::GetPosition ( ) [virtual]

Set/Get the position of the light. Note: The position of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space position, use vtkGetTransformedPosition() instead of vtkGetPosition().

virtual void vtkLight::GetPosition ( float data[3] ) [virtual]

Set/Get the position of the light. Note: The position of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space position, use vtkGetTransformedPosition() instead of vtkGetPosition().

void vtkLight::SetPosition ( double * a ) [inline]

Set/Get the position of the light. Note: The position of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space position, use vtkGetTransformedPosition() instead of vtkGetPosition().

Definition at line 101 of file vtkLight.h.

virtual void vtkLight::SetFocalPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the point at which the light is shining. Note: The focal point of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space focal point, use vtkGetTransformedFocalPoint() instead of vtkGetFocalPoint().

virtual void vtkLight::SetFocalPoint ( float [3] ) [virtual]

Set/Get the point at which the light is shining. Note: The focal point of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space focal point, use vtkGetTransformedFocalPoint() instead of vtkGetFocalPoint().

virtual float* vtkLight::GetFocalPoint ( ) [virtual]

Set/Get the point at which the light is shining. Note: The focal point of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space focal point, use vtkGetTransformedFocalPoint() instead of vtkGetFocalPoint().

virtual void vtkLight::GetFocalPoint ( float data[3] ) [virtual]

Set/Get the point at which the light is shining. Note: The focal point of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space focal point, use vtkGetTransformedFocalPoint() instead of vtkGetFocalPoint().

void vtkLight::SetFocalPoint ( double * a ) [inline]

Set/Get the point at which the light is shining. Note: The focal point of the light is defined in the coordinate space indicated by its transformation matrix (if it exists). Thus, to get the light's world space focal point, use vtkGetTransformedFocalPoint() instead of vtkGetFocalPoint().

Definition at line 112 of file vtkLight.h.

virtual void vtkLight::SetIntensity ( float ) [virtual]

Set/Get the brightness of the light (from one to zero).

virtual float vtkLight::GetIntensity ( ) [virtual]

Set/Get the brightness of the light (from one to zero).

virtual void vtkLight::SetSwitch ( int ) [virtual]

Turn the light on or off.

virtual int vtkLight::GetSwitch ( ) [virtual]

Turn the light on or off.

virtual void vtkLight::SwitchOn ( ) [virtual]

Turn the light on or off.

virtual void vtkLight::SwitchOff ( ) [virtual]

Turn the light on or off.

virtual void vtkLight::SetPositional ( int ) [virtual]

Turn positional lighting on or off.

virtual int vtkLight::GetPositional ( ) [virtual]

Turn positional lighting on or off.

virtual void vtkLight::PositionalOn ( ) [virtual]

Turn positional lighting on or off.

virtual void vtkLight::PositionalOff ( ) [virtual]

Turn positional lighting on or off.

virtual void vtkLight::SetExponent ( float ) [virtual]

Set/Get the exponent of the cosine used in positional lighting.

virtual float vtkLight::GetExponent ( ) [virtual]

Set/Get the exponent of the cosine used in positional lighting.

virtual void vtkLight::SetConeAngle ( float ) [virtual]

Set/Get the lighting cone angle of a positional light in degrees. A value of 180 indicates that you want no spot lighting effects just a positional light.

virtual float vtkLight::GetConeAngle ( ) [virtual]

Set/Get the lighting cone angle of a positional light in degrees. A value of 180 indicates that you want no spot lighting effects just a positional light.

virtual void vtkLight::SetAttenuationValues | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the quadratic attenuation constants. They are specified as constant, linear, and quadratic, in that order.

virtual void vtkLight::SetAttenuationValues ( float [3] ) [virtual]

Set/Get the quadratic attenuation constants. They are specified as constant, linear, and quadratic, in that order.

virtual float* vtkLight::GetAttenuationValues ( ) [virtual]

Set/Get the quadratic attenuation constants. They are specified as constant, linear, and quadratic, in that order.

virtual void vtkLight::GetAttenuationValues ( float data[3] ) [virtual]

Set/Get the quadratic attenuation constants. They are specified as constant, linear, and quadratic, in that order.

virtual void vtkLight::SetTransformMatrix ( vtkMatrix4x4 * ) [virtual]

Set/Get the light's transformation matrix. If a matrix is set for a light, the light's parameters (position and focal point) are transformed by the matrix before being rendered.

virtual vtkMatrix4x4* vtkLight::GetTransformMatrix ( ) [virtual]

Set/Get the light's transformation matrix. If a matrix is set for a light, the light's parameters (position and focal point) are transformed by the matrix before being rendered.

void vtkLight::GetTransformedPosition | ( | float & | a0,
 |  | float & | a1,
 |  | float & | a2
 | ) |

Get the position of the light, modified by the transformation matrix (if it exists).

void vtkLight::GetTransformedPosition ( float a[3] )

Get the position of the light, modified by the transformation matrix (if it exists).

float* vtkLight::GetTransformedPosition ( )

Get the position of the light, modified by the transformation matrix (if it exists).

void vtkLight::GetTransformedFocalPoint | ( | float & | a0,
 |  | float & | a1,
 |  | float & | a2
 | ) |

Get the focal point of the light, modified by the transformation matrix (if it exists).

void vtkLight::GetTransformedFocalPoint ( float a[3] )

Get the focal point of the light, modified by the transformation matrix (if it exists).

float* vtkLight::GetTransformedFocalPoint ( )

Get the focal point of the light, modified by the transformation matrix (if it exists).

void vtkLight::SetDirectionAngle | ( | float | elevation,
 |  | float | azimuth
 | ) |

Set the position and focal point of a light based on elevation and azimuth. The light is moved so it is shining from the given angle. Angles are given in degrees. If the light is a positional light, it is made directional instead.

void vtkLight::SetDirectionAngle ( float ang[2] ) [inline]

Set the position and focal point of a light based on elevation and azimuth. The light is moved so it is shining from the given angle. Angles are given in degrees. If the light is a positional light, it is made directional instead.

Definition at line 186 of file vtkLight.h.

void vtkLight::DeepCopy ( vtkLight * light )

Perform deep copy of this light.

virtual void vtkLight::SetLightType ( int ) [virtual]

Set/Get the type of the light. A SceneLight is a light located in the world coordinate space. A light is initially created as a scene light. A Headlight is always located at the camera and is pointed at the camera's focal point. The renderer is free to modify the position and focal point of the camera at any time. A CameraLight is also attached to the camera, but is not necessarily located at the camera's position. CameraLights are defined in a coordinate space where the camera is located at (0, 0, 1), looking towards (0, 0, 0) at a distance of 1, with up being (0, 1, 0).

virtual int vtkLight::GetLightType ( ) [virtual]

void vtkLight::SetLightTypeToHeadlight ( )

void vtkLight::SetLightTypeToSceneLight ( )

void vtkLight::SetLightTypeToCameraLight ( )

int vtkLight::LightTypeIsHeadlight ( )

Query the type of the light.

int vtkLight::LightTypeIsSceneLight ( )

Query the type of the light.

int vtkLight::LightTypeIsCameraLight ( )

Query the type of the light.

void vtkLight::ReadSelf ( istream & is )

void vtkLight::WriteSelf ( ostream & os )

Member Data Documentation

float vtkLight::FocalPoint[3] [protected]

Definition at line 223 of file vtkLight.h.

float vtkLight::Position[3] [protected]

Definition at line 224 of file vtkLight.h.

float vtkLight::Intensity [protected]

Definition at line 225 of file vtkLight.h.

float vtkLight::Color[3] [protected]

Definition at line 226 of file vtkLight.h.

int vtkLight::Switch [protected]

Definition at line 227 of file vtkLight.h.

int vtkLight::Positional [protected]

Definition at line 228 of file vtkLight.h.

float vtkLight::Exponent [protected]

Definition at line 229 of file vtkLight.h.

float vtkLight::ConeAngle [protected]

Definition at line 230 of file vtkLight.h.

float vtkLight::AttenuationValues[3] [protected]

Definition at line 231 of file vtkLight.h.

vtkMatrix4x4* vtkLight::TransformMatrix [protected]

Definition at line 232 of file vtkLight.h.

float vtkLight::TransformedFocalPointReturn[3] [protected]

Definition at line 233 of file vtkLight.h.

float vtkLight::TransformedPositionReturn[3] [protected]

Definition at line 234 of file vtkLight.h.

int vtkLight::LightType [protected]

Definition at line 235 of file vtkLight.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkLight.h
Generated on Mon Mar 25 01:23:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLightCollection Class Reference

a list of lights. More...

#include <vtkLightCollection.h>

Inheritance diagram for vtkLightCollection:

[legend]
Collaboration diagram for vtkLightCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLightCollection, vtkCollection)
void | AddItem (vtkLight *a)
vtkLight * GetNextItem ()

Static Public Methods

vtkLightCollection * | New ()

Protected Methods

vtkLightCollection ()
~vtkLightCollection ()

Detailed Description

a list of lights.

Date:
2002/01/22 15:38:40
Revision:
1.41

vtkLightCollection represents and provides methods to manipulate a list of lights (i.e., vtkLight and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkCollection vtkLight
Created by:
  • Law, Charles
  • Martin, Ken
Contributed by (if > 5%):
  • Law, Charles (39%)
  • Martin, Ken (34%)
  • Schroeder, Will (15%)
  • Kelly, Ann (8%)

Definition at line 46 of file vtkLightCollection.h.

Constructor & Destructor Documentation

vtkLightCollection::vtkLightCollection ( ) [inline, protected]

Definition at line 60 of file vtkLightCollection.h.

vtkLightCollection::~vtkLightCollection ( ) [inline, protected]

Definition at line 61 of file vtkLightCollection.h.

Member Function Documentation

vtkLightCollection* vtkLightCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkLightCollection::vtkTypeRevisionMacro | ( | vtkLightCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkLightCollection::AddItem ( vtkLight * a )

Add a light to the list.

vtkLight* vtkLightCollection::GetNextItem ( )

Get the next light in the list. NULL is returned when the collection is exhausted.

The documentation for this class was generated from the following file:
  • Rendering/vtkLightCollection.h
Generated on Mon Mar 25 01:23:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLightKit Class Reference

a simple but quality lighting kit. More...

#include <vtkLightKit.h>

Inheritance diagram for vtkLightKit:

[legend]
Collaboration diagram for vtkLightKit:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLightKit, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFillLightWarmth (float)
virtual float | GetFillLightWarmth ()
virtual void | SetHeadlightWarmth (float)
virtual float | GetHeadlightWarmth ()
void | SetKeyLightElevation (float x)
void | SetKeyLightAzimuth (float x)
virtual float * | GetKeyLightAngle ()
virtual void | GetKeyLightAngle (float data[2])
float | GetKeyLightElevation ()
float | GetKeyLightAzimuth ()
void | SetFillLightAngle (float elevation, float azimuth)
void | SetFillLightAngle (float angle[2])
void | SetFillLightElevation (float x)
void | SetFillLightAzimuth (float x)
virtual float * | GetFillLightAngle ()
virtual void | GetFillLightAngle (float data[2])
float | GetFillLightElevation ()
float | GetFillLightAzimuth ()
void | DeepCopy (vtkLightKit *kit)
void | Modified ()
void | Update ()
virtual void | SetKeyLightIntensity (float)
virtual float | GetKeyLightIntensity ()
virtual void | SetKeyToFillRatio (float)
virtual float | GetKeyToFillRatio ()
virtual void | SetKeyToHeadRatio (float)
virtual float | GetKeyToHeadRatio ()
virtual void | SetKeyLightWarmth (float)
virtual float | GetKeyLightWarmth ()
virtual float * | GetKeyLightColor ()
virtual void | GetKeyLightColor (float data[3])
virtual float * | GetFillLightColor ()
virtual void | GetFillLightColor (float data[3])
virtual float * | GetHeadlightColor ()
virtual void | GetHeadlightColor (float data[3])
virtual void | MaintainLuminanceOn ()
virtual void | MaintainLuminanceOff ()
virtual int | GetMaintainLuminance ()
virtual void | SetMaintainLuminance (int)
void | SetKeyLightAngle (float elevation, float azimuth)
void | SetKeyLightAngle (float angle[2])
void | AddLightsToRenderer (vtkRenderer *renderer)
void | RemoveLightsFromRenderer (vtkRenderer *renderer)

Static Public Methods

vtkLightKit * | New ()

Protected Methods

vtkLightKit ()
~vtkLightKit ()
void | WarmthToRGBI (float w, float rgb[3], float &i)
void | WarmthToRGB (float w, float rgb[3])
void | InitializeWarmthFunctions ()
float | WarmthToIntensity (float w)

Protected Attributes

float | KeyLightIntensity
float | KeyToFillRatio
float | KeyToHeadRatio
vtkLight * KeyLight
float | KeyLightWarmth
float | KeyLightAngle [2]
float | KeyLightColor [3]
vtkLight * FillLight
float | FillLightWarmth
float | FillLightAngle [2]
float | FillLightColor [3]
vtkLight * Headlight
float | HeadlightWarmth
float | HeadlightColor [3]
int | MaintainLuminance
vtkPiecewiseFunction * | WarmthFunction [4]

Detailed Description

a simple but quality lighting kit.

Date:
2002/01/22 15:38:40
Revision:
1.10

vtkLightKit is designed to make general purpose lighting of vtk scenes simple, flexible, and attractive (or at least not horribly ugly without significant effort). Use a LightKit when you want more control over your lighting than you can get with the default vtk light, which is a headlight located at the camera. (Headlights are very simple to use, but they don't show the shape of objects very well, don't give a good sense of "up" and "down", and don't evenly light the object.)

A LightKit consists of three lights, a key light, a fill light, and a headlight. The main light is the key light. It is usually positioned so that it appears like an overhead light (like the sun, or a ceiling light). It is generally positioned to shine down on the scene from about a 45 degree angle vertically and at least a little offset side to side. The key light usually at least about twice as bright as the total of all other lights in the scene to provide good modeling of object features.

The other two lights in the kit, the fill light and headlight, are weaker sources that provide extra illumination to fill in the spots that the key light misses. The fill light is usually positioned across from or opposite from the key light (though still on the same side of the object as the camera) in order to simulate diffuse reflections from other objects in the scene. The headlight, always located at the position of the camera, reduces the contrast between areas lit by the key and fill light. To enforce the relationship between the three lights, the intensity of the fill and headlights are set as a ratio to the key light brightness. Thus, the brightness of all the lights in the scene can be changed by changing the key light intensity.

All lights are directional lights (infinitely far away with no falloff). Lights move with the camera.

For simplicity, the position of lights in the LightKit can only be specified using angles: the elevation (latitude) and azimuth (longitude) of each light with respect to the camera, expressed in degrees. (Lights always shine on the camera's lookat point.) For example, a light at (elevation=0, azimuth=0) is located at the camera (a headlight). A light at (elevation=90, azimuth=0) is above the lookat point, shining down. Negative azimuth values move the lights clockwise as seen above, positive values counter-clockwise. So, a light at (elevation=45, azimuth=-20) is above and in front of the object and shining slightly from the left side.

vtkLightKit limits the colors that can be assigned to any light to those of incandescent sources such as light bulbs and sunlight. It defines a special color spectrum called "warmth" from which light colors can be chosen, where 0 is cold blue, 0.5 is neutral white, and 1 is deep sunset red. Colors close to 0.5 are "cool whites" and "warm whites," respectively.

Since colors far from white on the warmth scale appear less bright, key-to-fill and key-to-headlight ratios are skewed by key, fill, and headlight colors. If the flag MaintainLuminance is set, vtkLightKit will attempt to compensate for these perceptual differences by increasing the brightness of more saturated colors.

A LightKit is not explicitly part of the vtk pipeline. Rather, it is a composite object that controls the behavior of lights using a unified user interface. Every time a parameter of vtkLightKit is adjusted, the properties of its lights are modified.

Credits:
vtkLightKit was originally written and contributed to vtk by Michael Halle (mhalle@bwh.harvard.edu) at the Surgical Planning Lab, Brigham and Women's Hospital.
Created by:
  • Halle, Michael
Contributed by (if > 5%):
  • Halle, Michael (96%)

Definition at line 106 of file vtkLightKit.h.

Constructor & Destructor Documentation

vtkLightKit::vtkLightKit ( ) [protected]

vtkLightKit::~vtkLightKit ( ) [protected]

Member Function Documentation

vtkLightKit* vtkLightKit::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkLightKit::vtkTypeRevisionMacro | ( | vtkLightKit | ,
 |  | vtkObject |
 | ) |

void vtkLightKit::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

virtual void vtkLightKit::SetKeyLightIntensity ( float ) [virtual]

Set/Get the intensity of the key light. The key light is the brightest light in the scene. The intensities of the other two lights are ratios of the key light's intensity.

virtual float vtkLightKit::GetKeyLightIntensity ( ) [virtual]

Set/Get the intensity of the key light. The key light is the brightest light in the scene. The intensities of the other two lights are ratios of the key light's intensity.

virtual void vtkLightKit::SetKeyToFillRatio ( float ) [virtual]

Set/Get the key-to-fill ratio. This ratio controls how bright the fill light is compared to the key light: larger values correspond to a dimmer fill light. The purpose of the fill light is to light parts of the object not lit by the key light, while still maintaining constrast. This type of lighting may correspond to indirect illumination from the key light, bounced off a wall, floor, or other object. The fill light should never be brighter than the key light: a good range for the key-to-fill ratio is between 3 and 10.

virtual float vtkLightKit::GetKeyToFillRatio ( ) [virtual]

Set/Get the key-to-fill ratio. This ratio controls how bright the fill light is compared to the key light: larger values correspond to a dimmer fill light. The purpose of the fill light is to light parts of the object not lit by the key light, while still maintaining constrast. This type of lighting may correspond to indirect illumination from the key light, bounced off a wall, floor, or other object. The fill light should never be brighter than the key light: a good range for the key-to-fill ratio is between 3 and 10.

virtual void vtkLightKit::SetKeyToHeadRatio ( float ) [virtual]

Set/Get the key-to-headlight ratio. Similar to the key-to-fill ratio, this ratio controls how bright the headlight light is compared to the key light: larger values correspond to a dimmer headlight light. The headlight is special kind of fill light, lighting only the parts of the object that the camera can see. As such, a headlight tends to reduce the contrast of a scene. It can be used to fill in "shadows" of the object missed by the key and fill lights. The headlight should always be significantly dimmer than the key light: ratios of 3 to 15 are typical.

virtual float vtkLightKit::GetKeyToHeadRatio ( ) [virtual]

Set/Get the key-to-headlight ratio. Similar to the key-to-fill ratio, this ratio controls how bright the headlight light is compared to the key light: larger values correspond to a dimmer headlight light. The headlight is special kind of fill light, lighting only the parts of the object that the camera can see. As such, a headlight tends to reduce the contrast of a scene. It can be used to fill in "shadows" of the object missed by the key and fill lights. The headlight should always be significantly dimmer than the key light: ratios of 3 to 15 are typical.

virtual void vtkLightKit::SetKeyLightWarmth ( float ) [virtual]

Set the warmth of each the lights. Warmth is a parameter that varies from 0 to 1, where 0 is "cold" (looks icy or lit by a very blue sky), 1 is "warm" (the red of a very red sunset, or the embers of a campfire), and 0.5 is a neutral white. The warmth scale is non-linear. Warmth values close to 0.5 are subtly "warmer" or "cooler," much like a warmer tungsten incandescent bulb, a cooler halogen, or daylight (cooler still). Moving further away from 0.5, colors become more quickly varying towards blues and reds. With regards to aesthetics, extremes of warmth should be used sparingly.

virtual float vtkLightKit::GetKeyLightWarmth ( ) [virtual]

Set the warmth of each the lights. Warmth is a parameter that varies from 0 to 1, where 0 is "cold" (looks icy or lit by a very blue sky), 1 is "warm" (the red of a very red sunset, or the embers of a campfire), and 0.5 is a neutral white. The warmth scale is non-linear. Warmth values close to 0.5 are subtly "warmer" or "cooler," much like a warmer tungsten incandescent bulb, a cooler halogen, or daylight (cooler still). Moving further away from 0.5, colors become more quickly varying towards blues and reds. With regards to aesthetics, extremes of warmth should be used sparingly.

virtual void vtkLightKit::SetFillLightWarmth ( float ) [virtual]

virtual float vtkLightKit::GetFillLightWarmth ( ) [virtual]

virtual void vtkLightKit::SetHeadlightWarmth ( float ) [virtual]

virtual float vtkLightKit::GetHeadlightWarmth ( ) [virtual]

virtual float* vtkLightKit::GetKeyLightColor ( ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual void vtkLightKit::GetKeyLightColor ( float data[3] ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual float* vtkLightKit::GetFillLightColor ( ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual void vtkLightKit::GetFillLightColor ( float data[3] ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual float* vtkLightKit::GetHeadlightColor ( ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual void vtkLightKit::GetHeadlightColor ( float data[3] ) [virtual]

Returns the floating-point RGB values of each of the light's color.

virtual void vtkLightKit::MaintainLuminanceOn ( ) [virtual]

If MaintainLuminance is set, the LightKit will attempt to maintain the apparent intensity of lights based on their perceptual brightnesses. By default, MaintainLuminance is off.

virtual void vtkLightKit::MaintainLuminanceOff ( ) [virtual]

If MaintainLuminance is set, the LightKit will attempt to maintain the apparent intensity of lights based on their perceptual brightnesses. By default, MaintainLuminance is off.

virtual int vtkLightKit::GetMaintainLuminance ( ) [virtual]

If MaintainLuminance is set, the LightKit will attempt to maintain the apparent intensity of lights based on their perceptual brightnesses. By default, MaintainLuminance is off.

virtual void vtkLightKit::SetMaintainLuminance ( int ) [virtual]

If MaintainLuminance is set, the LightKit will attempt to maintain the apparent intensity of lights based on their perceptual brightnesses. By default, MaintainLuminance is off.

void vtkLightKit::SetKeyLightAngle | ( | float | elevation,
 |  | float | azimuth
 | ) |

Get/Set the position of the key light and fill light, using angular methods. Elevation corresponds to latitude, azimuth to longitude. It is recommended that the key light always be on the viewer's side of the object and above the object, while the fill light generally lights the part of the object not lit by the fill light. The headlight, which is always located at the viewer, can then be used to reduce the contrast in the image.

void vtkLightKit::SetKeyLightAngle ( float angle[2] ) [inline]

Get/Set the position of the key light and fill light, using angular methods. Elevation corresponds to latitude, azimuth to longitude. It is recommended that the key light always be on the viewer's side of the object and above the object, while the fill light generally lights the part of the object not lit by the fill light. The headlight, which is always located at the viewer, can then be used to reduce the contrast in the image.

Definition at line 193 of file vtkLightKit.h.

void vtkLightKit::SetKeyLightElevation ( float x ) [inline]

Definition at line 197 of file vtkLightKit.h.

void vtkLightKit::SetKeyLightAzimuth ( float x ) [inline]

Definition at line 200 of file vtkLightKit.h.

virtual float* vtkLightKit::GetKeyLightAngle ( ) [virtual]

virtual void vtkLightKit::GetKeyLightAngle ( float data[2] ) [virtual]

float vtkLightKit::GetKeyLightElevation ( ) [inline]

Definition at line 204 of file vtkLightKit.h.

float vtkLightKit::GetKeyLightAzimuth ( ) [inline]

Definition at line 207 of file vtkLightKit.h.

void vtkLightKit::SetFillLightAngle | ( | float | elevation,
 |  | float | azimuth
 | ) |

void vtkLightKit::SetFillLightAngle ( float angle[2] ) [inline]

Definition at line 211 of file vtkLightKit.h.

void vtkLightKit::SetFillLightElevation ( float x ) [inline]

Definition at line 214 of file vtkLightKit.h.

void vtkLightKit::SetFillLightAzimuth ( float x ) [inline]

Definition at line 217 of file vtkLightKit.h.

virtual float* vtkLightKit::GetFillLightAngle ( ) [virtual]

virtual void vtkLightKit::GetFillLightAngle ( float data[2] ) [virtual]

float vtkLightKit::GetFillLightElevation ( ) [inline]

Definition at line 221 of file vtkLightKit.h.

float vtkLightKit::GetFillLightAzimuth ( ) [inline]

Definition at line 224 of file vtkLightKit.h.

void vtkLightKit::AddLightsToRenderer ( vtkRenderer * renderer )

Add lights to, or remove lights from, a renderer. Lights may be added to more than one renderer, if desired.

void vtkLightKit::RemoveLightsFromRenderer ( vtkRenderer * renderer )

Add lights to, or remove lights from, a renderer. Lights may be added to more than one renderer, if desired.

void vtkLightKit::DeepCopy ( vtkLightKit * kit )

void vtkLightKit::Modified ( ) [virtual]

Update the modification time for this object. Many filters rely on the modification time to determine if they need to recompute their data. The modification time is a unique monotonically increasing unsigned long integer.

Reimplemented from vtkObject.

void vtkLightKit::Update ( void )

void vtkLightKit::WarmthToRGBI | ( | float | w,
 |  | float | rgb[3],
 |  | float & | i
 | ) | [protected]

void vtkLightKit::WarmthToRGB | ( | float | w,
 |  | float | rgb[3]
 | ) | [protected]

void vtkLightKit::InitializeWarmthFunctions ( ) [protected]

float vtkLightKit::WarmthToIntensity ( float w ) [protected]

Member Data Documentation

float vtkLightKit::KeyLightIntensity [protected]

Definition at line 249 of file vtkLightKit.h.

float vtkLightKit::KeyToFillRatio [protected]

Definition at line 250 of file vtkLightKit.h.

float vtkLightKit::KeyToHeadRatio [protected]

Definition at line 251 of file vtkLightKit.h.

vtkLight* vtkLightKit::KeyLight [protected]

Definition at line 253 of file vtkLightKit.h.

float vtkLightKit::KeyLightWarmth [protected]

Definition at line 254 of file vtkLightKit.h.

float vtkLightKit::KeyLightAngle[2] [protected]

Definition at line 255 of file vtkLightKit.h.

float vtkLightKit::KeyLightColor[3] [protected]

Definition at line 256 of file vtkLightKit.h.

vtkLight* vtkLightKit::FillLight [protected]

Definition at line 258 of file vtkLightKit.h.

float vtkLightKit::FillLightWarmth [protected]

Definition at line 259 of file vtkLightKit.h.

float vtkLightKit::FillLightAngle[2] [protected]

Definition at line 260 of file vtkLightKit.h.

float vtkLightKit::FillLightColor[3] [protected]

Definition at line 261 of file vtkLightKit.h.

vtkLight* vtkLightKit::Headlight [protected]

Definition at line 263 of file vtkLightKit.h.

float vtkLightKit::HeadlightWarmth [protected]

Definition at line 264 of file vtkLightKit.h.

float vtkLightKit::HeadlightColor[3] [protected]

Definition at line 265 of file vtkLightKit.h.

int vtkLightKit::MaintainLuminance [protected]

Definition at line 267 of file vtkLightKit.h.

vtkPiecewiseFunction* vtkLightKit::WarmthFunction[4] [protected]

Definition at line 269 of file vtkLightKit.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkLightKit.h
Generated on Mon Mar 25 01:23:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLine Class Reference

cell represents a 1D line. More...

#include <vtkLine.h>

Inheritance diagram for vtkLine:

[legend]
Collaboration diagram for vtkLine:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLine, vtkCell)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int)
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)

Static Public Methods

vtkLine * | New ()
float | DistanceToLine (float x[3], float p1[3], float p2[3])
void | InterpolationFunctions (float pcoords[3], float weights[2])
int | Intersection (float p1[3], float p2[3], float x1[3], float x2[3], float &u, float &v)
float | DistanceToLine (float x[3], float p1[3], float p2[3], float &t, float closestPoint[3])

Protected Methods

vtkLine ()
~vtkLine ()

Detailed Description

cell represents a 1D line.

Date:
2002/01/22 15:25:34
Revision:
1.61

vtkLine is a concrete implementation of vtkCell to represent a 1D line.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (64%)
  • Miller, Jim (12%)
  • Martin, Ken (7%)
  • Geveci, Berk (5%)
Examples:
vtkLine (Examples)
Tests:
vtkLine (Tests)

Definition at line 45 of file vtkLine.h.

Constructor & Destructor Documentation

vtkLine::vtkLine ( ) [protected]

vtkLine::~vtkLine ( ) [inline, protected]

Definition at line 123 of file vtkLine.h.

Member Function Documentation

vtkLine* vtkLine::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkLine::vtkTypeRevisionMacro | ( | vtkLine | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkLine::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkLine::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 54 of file vtkLine.h.

int vtkLine::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 55 of file vtkLine.h.

int vtkLine::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 56 of file vtkLine.h.

int vtkLine::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 57 of file vtkLine.h.

vtkCell* vtkLine::GetEdge ( int edgeId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkLine.h.

vtkCell* vtkLine::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkLine.h.

int vtkLine::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkLine::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkLine::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkLine::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkLine::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkLine::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkLine::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | lines,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

Clip this line using scalar value provided. Like contouring, except that it cuts the line to produce other lines.

Reimplemented from vtkCell.

int vtkLine::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Line-line intersection. Intersection has to occur within [0,1] parametric coordinates and with specified tolerance.

Reimplemented from vtkCell.

int vtkLine::Intersection | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | x1[3],
 |  | float | x2[3],
 |  | float & | u,
 |  | float & | v
 | ) | [static]

Performs intersection of two finite 3D lines. An intersection is found if the projection of the two lines onto the plane perpendicular to the cross product of the two lines intersect. The parameters (u,v) are the parametric coordinates of the lines at the position of closest approach.

float vtkLine::DistanceToLine | ( | float | x[3],
 |  | float | p1[3],
 |  | float | p2[3],
 |  | float & | t,
 |  | float | closestPoint[3]
 | ) | [static]

Compute distance to finite line. Returns parametric coordinate t and point location on line.

float vtkLine::DistanceToLine | ( | float | x[3],
 |  | float | p1[3],
 |  | float | p2[3]
 | ) | [static]

Determine the distance of the current vertex to the edge defined by the vertices provided. Returns distance squared. Note: line is assumed infinite in extent.

void vtkLine::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[2]
 | ) | [static]

Line specific methods.

The documentation for this class was generated from the following file:
  • Common/vtkLine.h
Generated on Mon Mar 25 01:23:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearExtrusionFilter Class Reference

sweep polygonal data creating a "skirt" from free edges and lines, and lines from vertices. More...

#include <vtkLinearExtrusionFilter.h>

Inheritance diagram for vtkLinearExtrusionFilter:

[legend]
Collaboration diagram for vtkLinearExtrusionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLinearExtrusionFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetExtrusionType (int)
virtual int | GetExtrusionType ()
void | SetExtrusionTypeToVectorExtrusion ()
void | SetExtrusionTypeToNormalExtrusion ()
void | SetExtrusionTypeToPointExtrusion ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetVector (float, float, float)
virtual void | SetVector (float[3])
virtual float * | GetVector ()
virtual void | GetVector (float data[3])
virtual void | SetExtrusionPoint (float, float, float)
virtual void | SetExtrusionPoint (float[3])
virtual float * | GetExtrusionPoint ()
virtual void | GetExtrusionPoint (float data[3])

Static Public Methods

vtkLinearExtrusionFilter * | New ()

Protected Methods

vtkLinearExtrusionFilter ()
~vtkLinearExtrusionFilter ()
void | Execute ()
float * | ViaNormal (float x[3], vtkIdType id, vtkDataArray *normals)
float * | ViaVector (float x[3], vtkIdType id, vtkDataArray *normals=0)
float * | ViaPoint (float x[3], vtkIdType id, vtkDataArray *normals=0)

Protected Attributes

int | ExtrusionType
int | Capping
float | ScaleFactor
float | Vector [3]
float | ExtrusionPoint [3]
float *(vtkLinearExtrusionFilter::* | ExtrudePoint )(float x[3], vtkIdType id, vtkDataArray *normals)

Detailed Description

sweep polygonal data creating a "skirt" from free edges and lines, and lines from vertices.

Date:
2002/01/22 15:29:26
Revision:
1.40

vtkLinearExtrusionFilter is a modeling filter. It takes polygonal data as input and generates polygonal data on output. The input dataset is swept according to some extrusion function and creates new polygonal primitives. These primitives form a "skirt" or swept surface. For example, sweeping a line results in a quadrilateral, and sweeping a triangle creates a "wedge".

There are a number of control parameters for this filter. You can control whether the sweep of a 2D object (i.e., polygon or triangle strip) is capped with the generating geometry via the "Capping" ivar. Also, you can extrude in the direction of a user specified vector, towards a point, or in the direction of vertex normals (normals must be provided - use vtkPolyDataNormals if necessary). The amount of extrusion is controlled by the "ScaleFactor" instance variable.

The skirt is generated by locating certain topological features. Free edges (edges of polygons or triangle strips only used by one polygon or triangle strips) generate surfaces. This is true also of lines or polylines. Vertices generate lines.

This filter can be used to create 3D fonts, 3D irregular bar charts, or to model 2 1/2D objects like punched plates. It also can be used to create solid objects from 2D polygonal meshes.

Warning:
Some polygonal objects have no free edges (e.g., sphere). When swept, this will result in two separate surfaces if capping is on, or no surface if capping is off.
See also:
vtkRotationalExtrusionFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Martin, Ken (12%)
  • Law, Charles (12%)
Tests:
vtkLinearExtrusionFilter (Tests)

Definition at line 74 of file vtkLinearExtrusionFilter.h.

Constructor & Destructor Documentation

vtkLinearExtrusionFilter::vtkLinearExtrusionFilter ( ) [protected]

vtkLinearExtrusionFilter::~vtkLinearExtrusionFilter ( ) [inline, protected]

Definition at line 125 of file vtkLinearExtrusionFilter.h.

Member Function Documentation

vtkLinearExtrusionFilter::vtkTypeRevisionMacro | ( | vtkLinearExtrusionFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

Reimplemented in vtkPLinearExtrusionFilter.

void vtkLinearExtrusionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkPLinearExtrusionFilter.

vtkLinearExtrusionFilter* vtkLinearExtrusionFilter::New ( ) [static]

Create object with normal extrusion type, capping on, scale factor=1.0, vector (0,0,1), and extrusion point (0,0,0).

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkPLinearExtrusionFilter.

virtual void vtkLinearExtrusionFilter::SetExtrusionType ( int ) [virtual]

Set/Get the type of extrusion.

virtual int vtkLinearExtrusionFilter::GetExtrusionType ( ) [virtual]

Set/Get the type of extrusion.

void vtkLinearExtrusionFilter::SetExtrusionTypeToVectorExtrusion ( ) [inline]

Set/Get the type of extrusion.

Definition at line 88 of file vtkLinearExtrusionFilter.h.

void vtkLinearExtrusionFilter::SetExtrusionTypeToNormalExtrusion ( ) [inline]

Set/Get the type of extrusion.

Definition at line 90 of file vtkLinearExtrusionFilter.h.

void vtkLinearExtrusionFilter::SetExtrusionTypeToPointExtrusion ( ) [inline]

Set/Get the type of extrusion.

Definition at line 92 of file vtkLinearExtrusionFilter.h.

virtual void vtkLinearExtrusionFilter::SetCapping ( int ) [virtual]

Turn on/off the capping of the skirt.

virtual int vtkLinearExtrusionFilter::GetCapping ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkLinearExtrusionFilter::CappingOn ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkLinearExtrusionFilter::CappingOff ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkLinearExtrusionFilter::SetScaleFactor ( float ) [virtual]

Set/Get extrusion scale factor,

virtual float vtkLinearExtrusionFilter::GetScaleFactor ( ) [virtual]

Set/Get extrusion scale factor,

virtual void vtkLinearExtrusionFilter::SetVector | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get extrusion vector. Only needs to be set if VectorExtrusion is turned on.

virtual void vtkLinearExtrusionFilter::SetVector ( float [3] ) [virtual]

Set/Get extrusion vector. Only needs to be set if VectorExtrusion is turned on.

virtual float* vtkLinearExtrusionFilter::GetVector ( ) [virtual]

Set/Get extrusion vector. Only needs to be set if VectorExtrusion is turned on.

virtual void vtkLinearExtrusionFilter::GetVector ( float data[3] ) [virtual]

Set/Get extrusion vector. Only needs to be set if VectorExtrusion is turned on.

virtual void vtkLinearExtrusionFilter::SetExtrusionPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get extrusion point. Only needs to be set if PointExtrusion is turned on. This is the point towards which extrusion occurs.

virtual void vtkLinearExtrusionFilter::SetExtrusionPoint ( float [3] ) [virtual]

Set/Get extrusion point. Only needs to be set if PointExtrusion is turned on. This is the point towards which extrusion occurs.

virtual float* vtkLinearExtrusionFilter::GetExtrusionPoint ( ) [virtual]

Set/Get extrusion point. Only needs to be set if PointExtrusion is turned on. This is the point towards which extrusion occurs.

virtual void vtkLinearExtrusionFilter::GetExtrusionPoint ( float data[3] ) [virtual]

Set/Get extrusion point. Only needs to be set if PointExtrusion is turned on. This is the point towards which extrusion occurs.

void vtkLinearExtrusionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkPLinearExtrusionFilter.

float* vtkLinearExtrusionFilter::ViaNormal | ( | float | x[3],
 |  | vtkIdType | id,
 |  | vtkDataArray * | normals
 | ) | [protected]

float* vtkLinearExtrusionFilter::ViaVector | ( | float | x[3],
 |  | vtkIdType | id,
 |  | vtkDataArray * | normals = 0
 | ) | [protected]

float* vtkLinearExtrusionFilter::ViaPoint | ( | float | x[3],
 |  | vtkIdType | id,
 |  | vtkDataArray * | normals = 0
 | ) | [protected]

Member Data Documentation

int vtkLinearExtrusionFilter::ExtrusionType [protected]

Definition at line 128 of file vtkLinearExtrusionFilter.h.

int vtkLinearExtrusionFilter::Capping [protected]

Definition at line 129 of file vtkLinearExtrusionFilter.h.

float vtkLinearExtrusionFilter::ScaleFactor [protected]

Definition at line 130 of file vtkLinearExtrusionFilter.h.

float vtkLinearExtrusionFilter::Vector[3] [protected]

Definition at line 131 of file vtkLinearExtrusionFilter.h.

float vtkLinearExtrusionFilter::ExtrusionPoint[3] [protected]

Definition at line 132 of file vtkLinearExtrusionFilter.h.

float*(vtkLinearExtrusionFilter::* vtkLinearExtrusionFilter::ExtrudePoint)(float x[3], vtkIdType id, vtkDataArray *normals) [protected]

The documentation for this class was generated from the following file:
  • Graphics/vtkLinearExtrusionFilter.h
Generated on Mon Mar 25 01:23:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearSubdivisionFilter Class Reference

generate a subdivision surface using the Linear Scheme. More...

#include <vtkLinearSubdivisionFilter.h>

Inheritance diagram for vtkLinearSubdivisionFilter:

[legend]
Collaboration diagram for vtkLinearSubdivisionFilter:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkLinearSubdivisionFilter, vtkInterpolatingSubdivisionFilter)
vtkLinearSubdivisionFilter * | New ()

Protected Methods

vtkLinearSubdivisionFilter ()
~vtkLinearSubdivisionFilter ()
void | GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)

Detailed Description

generate a subdivision surface using the Linear Scheme.

Date:
2002/01/22 15:29:26
Revision:
1.12

vtkLinearSubdivisionFilter is a filter that generates output by subdividing its input polydata. Each subdivision iteration create 4 new triangles for each triangle in the polydata.

See also:
vtkInterpolatingSubdivisionFilter vtkButterflySubdivisionFilter
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (90%)
  • Henderson, Amy (8%)
Tests:
vtkLinearSubdivisionFilter (Tests)

Definition at line 46 of file vtkLinearSubdivisionFilter.h.

Constructor & Destructor Documentation

vtkLinearSubdivisionFilter::vtkLinearSubdivisionFilter ( ) [inline, protected]

Definition at line 56 of file vtkLinearSubdivisionFilter.h.

vtkLinearSubdivisionFilter::~vtkLinearSubdivisionFilter ( ) [inline, protected]

Definition at line 57 of file vtkLinearSubdivisionFilter.h.

Member Function Documentation

vtkLinearSubdivisionFilter* vtkLinearSubdivisionFilter::New ( ) [static]

Construct object with NumberOfSubdivisions set to 1.

Reimplemented from vtkPolyDataSource.

vtkLinearSubdivisionFilter::vtkTypeRevisionMacro | ( | vtkLinearSubdivisionFilter | ,
 |  | vtkInterpolatingSubdivisionFilter |
 | ) |

Reimplemented from vtkInterpolatingSubdivisionFilter.

void vtkLinearSubdivisionFilter::GenerateSubdivisionPoints | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkPoints * | outputPts,
 |  | vtkPointData * | outputPD
 | ) | [protected, virtual]

Reimplemented from vtkInterpolatingSubdivisionFilter.

The documentation for this class was generated from the following file:
  • Graphics/vtkLinearSubdivisionFilter.h
Generated on Mon Mar 25 01:23:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinearTransform Class Reference

abstract superclass for linear transformations. More...

#include <vtkLinearTransform.h>

Inheritance diagram for vtkLinearTransform:

[legend]
Collaboration diagram for vtkLinearTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLinearTransform, vtkHomogeneousTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | TransformPoints (vtkPoints *inPts, vtkPoints *outPts)
virtual void | TransformNormals (vtkDataArray *inNms, vtkDataArray *outNms)
virtual void | TransformVectors (vtkDataArray *inVrs, vtkDataArray *outVrs)
void | TransformNormal (const float in[3], float out[3])
void | TransformNormal (const double in[3], double out[3])
double * | TransformNormal (double x, double y, double z)
double * | TransformNormal (const double normal[3])
float * | TransformFloatNormal (float x, float y, float z)
float * | TransformFloatNormal (const float normal[3])
double * | TransformDoubleNormal (double x, double y, double z)
double * | TransformDoubleNormal (const double normal[3])
double * | TransformVector (double x, double y, double z)
double * | TransformVector (const double normal[3])
void | TransformVector (const float in[3], float out[3])
void | TransformVector (const double in[3], double out[3])
float * | TransformFloatVector (float x, float y, float z)
float * | TransformFloatVector (const float vec[3])
double * | TransformDoubleVector (double x, double y, double z)
double * | TransformDoubleVector (const double vec[3])
void | TransformPointsNormalsVectors (vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs)
vtkLinearTransform * | GetLinearInverse ()
void | InternalTransformPoint (const float in[3], float out[3])
void | InternalTransformPoint (const double in[3], double out[3])
virtual void | InternalTransformNormal (const float in[3], float out[3])
virtual void | InternalTransformNormal (const double in[3], double out[3])
virtual void | InternalTransformVector (const float in[3], float out[3])
virtual void | InternalTransformVector (const double in[3], double out[3])
void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Protected Methods

vtkLinearTransform ()
~vtkLinearTransform ()

Detailed Description

abstract superclass for linear transformations.

Date:
2002/01/22 15:25:34
Revision:
1.33

vtkLinearTransform provides a generic interface for linear (affine or 12 degree-of-freedom) geometric transformations.

See also:
vtkTransform vtkIdentityTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (87%)
  • Geveci, Berk (7%)

Definition at line 40 of file vtkLinearTransform.h.

Constructor & Destructor Documentation

vtkLinearTransform::vtkLinearTransform ( ) [inline, protected]

Definition at line 206 of file vtkLinearTransform.h.

vtkLinearTransform::~vtkLinearTransform ( ) [inline, protected]

Definition at line 207 of file vtkLinearTransform.h.

Member Function Documentation

vtkLinearTransform::vtkTypeRevisionMacro | ( | vtkLinearTransform | ,
 |  | vtkHomogeneousTransform |
 | ) |

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform, vtkMatrixToLinearTransform, vtkTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

void vtkLinearTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform, vtkMatrixToLinearTransform, vtkTransform, vtkIterativeClosestPointTransform, and vtkLandmarkTransform.

void vtkLinearTransform::TransformNormal | ( | const float | in[3],
 |  | float | out[3]
 | ) | [inline]

Apply the transformation to a normal. You can use the same array to store both the input and output.

Definition at line 50 of file vtkLinearTransform.h.

void vtkLinearTransform::TransformNormal | ( | const double | in[3],
 |  | double | out[3]
 | ) | [inline]

Apply the transformation to a double-precision normal. You can use the same array to store both the input and output.

Definition at line 57 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformNormal | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Synonymous with TransformDoubleNormal(x,y,z). Use this if you are programming in python, tcl or Java.

Definition at line 64 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformNormal ( const double normal[3] ) [inline]

Synonymous with TransformDoubleNormal(x,y,z). Use this if you are programming in python, tcl or Java.

Definition at line 66 of file vtkLinearTransform.h.

float* vtkLinearTransform::TransformFloatNormal | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Apply the transformation to an (x,y,z) normal. Use this if you are programming in python, tcl or Java.

Definition at line 73 of file vtkLinearTransform.h.

float* vtkLinearTransform::TransformFloatNormal ( const float normal[3] ) [inline]

Apply the transformation to an (x,y,z) normal. Use this if you are programming in python, tcl or Java.

Definition at line 79 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformDoubleNormal | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Apply the transformation to a double-precision (x,y,z) normal. Use this if you are programming in python, tcl or Java.

Definition at line 86 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformDoubleNormal ( const double normal[3] ) [inline]

Apply the transformation to a double-precision (x,y,z) normal. Use this if you are programming in python, tcl or Java.

Definition at line 92 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformVector | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Synonymous with TransformDoubleVector(x,y,z). Use this if you are programming in python, tcl or Java.

Definition at line 99 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformVector ( const double normal[3] ) [inline]

Synonymous with TransformDoubleVector(x,y,z). Use this if you are programming in python, tcl or Java.

Definition at line 101 of file vtkLinearTransform.h.

void vtkLinearTransform::TransformVector | ( | const float | in[3],
 |  | float | out[3]
 | ) | [inline]

Apply the transformation to a vector. You can use the same array to store both the input and output.

Definition at line 108 of file vtkLinearTransform.h.

void vtkLinearTransform::TransformVector | ( | const double | in[3],
 |  | double | out[3]
 | ) | [inline]

Apply the transformation to a double-precision vector. You can use the same array to store both the input and output.

Definition at line 115 of file vtkLinearTransform.h.

float* vtkLinearTransform::TransformFloatVector | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Apply the transformation to an (x,y,z) vector. Use this if you are programming in python, tcl or Java.

Definition at line 122 of file vtkLinearTransform.h.

float* vtkLinearTransform::TransformFloatVector ( const float vec[3] ) [inline]

Apply the transformation to an (x,y,z) vector. Use this if you are programming in python, tcl or Java.

Definition at line 128 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformDoubleVector | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Apply the transformation to a double-precision (x,y,z) vector. Use this if you are programming in python, tcl or Java.

Definition at line 135 of file vtkLinearTransform.h.

double* vtkLinearTransform::TransformDoubleVector ( const double vec[3] ) [inline]

Apply the transformation to a double-precision (x,y,z) vector. Use this if you are programming in python, tcl or Java.

Definition at line 141 of file vtkLinearTransform.h.

void vtkLinearTransform::TransformPoints | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts
 | ) | [virtual]

Apply the transformation to a series of points, and append the results to outPts.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::TransformNormals | ( | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms
 | ) | [virtual]

Apply the transformation to a series of normals, and append the results to outNms.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::TransformVectors | ( | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a series of vectors, and append the results to outVrs.

Reimplemented in vtkIdentityTransform.

void vtkLinearTransform::TransformPointsNormalsVectors | ( | vtkPoints * | inPts,
 |  | vtkPoints * | outPts,
 |  | vtkDataArray * | inNms,
 |  | vtkDataArray * | outNms,
 |  | vtkDataArray * | inVrs,
 |  | vtkDataArray * | outVrs
 | ) | [virtual]

Apply the transformation to a combination of points, normals and vectors.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

vtkLinearTransform* vtkLinearTransform::GetLinearInverse ( ) [inline]

Just like GetInverse, but it includes a typecast to vtkLinearTransform.

Definition at line 171 of file vtkLinearTransform.h.

void vtkLinearTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

void vtkLinearTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::InternalTransformNormal | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::InternalTransformNormal | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::InternalTransformVector | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkIdentityTransform.

virtual void vtkLinearTransform::InternalTransformVector | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented in vtkIdentityTransform.

void vtkLinearTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

void vtkLinearTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkHomogeneousTransform.

Reimplemented in vtkIdentityTransform.

The documentation for this class was generated from the following file:
  • Common/vtkLinearTransform.h
Generated on Mon Mar 25 01:23:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLineSource Class Reference

create a line defined by two end points. More...

#include <vtkLineSource.h>

Inheritance diagram for vtkLineSource:

[legend]
Collaboration diagram for vtkLineSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLineSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPoint1 (float, float, float)
virtual void | SetPoint1 (float[3])
virtual float * | GetPoint1 ()
virtual void | GetPoint1 (float data[3])
virtual void | SetPoint2 (float, float, float)
virtual void | SetPoint2 (float[3])
virtual float * | GetPoint2 ()
virtual void | GetPoint2 (float data[3])
virtual void | SetResolution (int)
virtual int | GetResolution ()

Static Public Methods

vtkLineSource * | New ()

Protected Methods

vtkLineSource (int res=1)
~vtkLineSource ()
void | Execute ()

Protected Attributes

float | Point1 [3]
float | Point2 [3]
int | Resolution

Detailed Description

create a line defined by two end points.

Date:
2002/01/22 15:29:25
Revision:
1.41

vtkLineSource is a source object that creates a polyline defined by two endpoints. The number of segments composing the polyline is controlled by setting the object resolution.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (86%)
  • Martin, Ken (5%)
Examples:
vtkLineSource (Examples)
Tests:
vtkLineSource (Tests)

Definition at line 45 of file vtkLineSource.h.

Constructor & Destructor Documentation

vtkLineSource::vtkLineSource ( int res = 1 ) [protected]

vtkLineSource::~vtkLineSource ( ) [inline, protected]

Definition at line 72 of file vtkLineSource.h.

Member Function Documentation

vtkLineSource* vtkLineSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkLineSource::vtkTypeRevisionMacro | ( | vtkLineSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkLineSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkLineSource::SetPoint1 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set position of first end point.

virtual void vtkLineSource::SetPoint1 ( float [3] ) [virtual]

Set position of first end point.

virtual float* vtkLineSource::GetPoint1 ( ) [virtual]

Set position of first end point.

virtual void vtkLineSource::GetPoint1 ( float data[3] ) [virtual]

Set position of first end point.

virtual void vtkLineSource::SetPoint2 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set position of other end point.

virtual void vtkLineSource::SetPoint2 ( float [3] ) [virtual]

Set position of other end point.

virtual float* vtkLineSource::GetPoint2 ( ) [virtual]

Set position of other end point.

virtual void vtkLineSource::GetPoint2 ( float data[3] ) [virtual]

Set position of other end point.

virtual void vtkLineSource::SetResolution ( int ) [virtual]

Divide line into resolution number of pieces.

virtual int vtkLineSource::GetResolution ( ) [virtual]

Divide line into resolution number of pieces.

void vtkLineSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkLineSource::Point1[3] [protected]

Definition at line 75 of file vtkLineSource.h.

float vtkLineSource::Point2[3] [protected]

Definition at line 76 of file vtkLineSource.h.

int vtkLineSource::Resolution [protected]

Definition at line 77 of file vtkLineSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkLineSource.h
Generated on Mon Mar 25 01:23:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLinkEdgels Class Reference

links edgels together to form digital curves. More...

#include <vtkLinkEdgels.h>

Inheritance diagram for vtkLinkEdgels:

[legend]
Collaboration diagram for vtkLinkEdgels:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLinkEdgels, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetLinkThreshold (float)
virtual float | GetLinkThreshold ()
virtual void | SetPhiThreshold (float)
virtual float | GetPhiThreshold ()
virtual void | SetGradientThreshold (float)
virtual float | GetGradientThreshold ()

Static Public Methods

vtkLinkEdgels * | New ()

Protected Methods

vtkLinkEdgels ()
~vtkLinkEdgels ()
void | Execute ()
void | LinkEdgels (int xdim, int ydim, float *image, vtkDataArray *inVectors, vtkCellArray *newLines, vtkPoints *newPts, vtkFloatArray *outScalars, vtkFloatArray *outVectors, int z)

Protected Attributes

float | GradientThreshold
float | PhiThreshold
float | LinkThreshold

Detailed Description

links edgels together to form digital curves.

Date:
2002/01/22 15:29:27
Revision:
1.27

vtkLinkEdgels links edgels into digital curves which are then stored as polylines. The algorithm works one pixel at a time only looking at its immediate neighbors. There is a GradientThreshold that can be set that eliminates any pixels with a smaller gradient value. This can be used as the lower threshold of a two value edgel thresholding.

For the remaining edgels, links are first tried for the four connected neighbors. A successful neighbor will satisfy three tests. First both edgels must be above the gradient threshold. Second, the difference between the orientation between the two edgels (Alpha) and each edgels orientation (Phi) must be less than LinkThreshold. Third, the difference between the two edgels Phi values must be less than PhiThreshold. The most successful link is selected. The measure is simply the sum of the three angle differences (actually stored as the sum of the cosines). If none of the four connect neighbors succeeds, then the eight connect neighbors are examined using the same method.

This filter requires gradient information so you will need to use a vtkImageGradient at some point prior to this filter. Typically a vtkNonMaximumSuppression filter is also used. vtkThresholdEdgels can be used to complete the two value edgel thresholding as used in a Canny edge detector. The vtkSubpixelPositionEdgels filter can also be used after this filter to adjust the edgel locations.

See also:
vtkImage vtkImageGradient vtkNonMaximumSuppression
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (81%)
  • Law, Charles (9%)
  • Geveci, Berk (5%)
Tests:
vtkLinkEdgels (Tests)

Definition at line 67 of file vtkLinkEdgels.h.

Constructor & Destructor Documentation

vtkLinkEdgels::vtkLinkEdgels ( ) [protected]

vtkLinkEdgels::~vtkLinkEdgels ( ) [inline, protected]

Definition at line 98 of file vtkLinkEdgels.h.

Member Function Documentation

vtkLinkEdgels::vtkTypeRevisionMacro | ( | vtkLinkEdgels | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

void vtkLinkEdgels::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkLinkEdgels* vtkLinkEdgels::New ( ) [static]

Construct instance of vtkLinkEdgels with GradientThreshold set to 0.1, PhiThreshold set to 90 degrees and LinkThreshold set to 90 degrees.

Reimplemented from vtkPolyDataSource.

virtual void vtkLinkEdgels::SetLinkThreshold ( float ) [virtual]

Set/Get the threshold for Phi vs. Alpha link thresholding.

virtual float vtkLinkEdgels::GetLinkThreshold ( ) [virtual]

Set/Get the threshold for Phi vs. Alpha link thresholding.

virtual void vtkLinkEdgels::SetPhiThreshold ( float ) [virtual]

Set/get the threshold for Phi vs. Phi link thresholding.

virtual float vtkLinkEdgels::GetPhiThreshold ( ) [virtual]

Set/get the threshold for Phi vs. Phi link thresholding.

virtual void vtkLinkEdgels::SetGradientThreshold ( float ) [virtual]

Set/Get the threshold for image gradient thresholding.

virtual float vtkLinkEdgels::GetGradientThreshold ( ) [virtual]

Set/Get the threshold for image gradient thresholding.

void vtkLinkEdgels::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkLinkEdgels::LinkEdgels | ( | int | xdim,
 |  | int | ydim,
 |  | float * | image,
 |  | vtkDataArray * | inVectors,
 |  | vtkCellArray * | newLines,
 |  | vtkPoints * | newPts,
 |  | vtkFloatArray * | outScalars,
 |  | vtkFloatArray * | outVectors,
 |  | int | z
 | ) | [protected]

Member Data Documentation

float vtkLinkEdgels::GradientThreshold [protected]

Definition at line 105 of file vtkLinkEdgels.h.

float vtkLinkEdgels::PhiThreshold [protected]

Definition at line 106 of file vtkLinkEdgels.h.

float vtkLinkEdgels::LinkThreshold [protected]

Definition at line 107 of file vtkLinkEdgels.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkLinkEdgels.h
Generated on Mon Mar 25 01:23:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


List Struct Reference

#include <vtk3DS.h>

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:23:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLocator Class Reference

abstract base class for objects that accelerate spatial searches. More...

#include <vtkLocator.h>

Inheritance diagram for vtkLocator:

[legend]
Collaboration diagram for vtkLocator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLocator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Update ()
virtual void | Initialize ()
virtual void | BuildLocator ()=0
virtual void | FreeSearchStructure ()=0
virtual void | GenerateRepresentation (int level, vtkPolyData *pd)=0
virtual void | SetDataSet (vtkDataSet *)
virtual vtkDataSet * | GetDataSet ()
virtual void | SetMaxLevel (int)
virtual int | GetMaxLevel ()
virtual int | GetLevel ()
virtual void | SetAutomatic (int)
virtual int | GetAutomatic ()
virtual void | AutomaticOn ()
virtual void | AutomaticOff ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()
virtual void | SetRetainCellLists (int)
virtual int | GetRetainCellLists ()
virtual void | RetainCellListsOn ()
virtual void | RetainCellListsOff ()
virtual unsigned long | GetBuildTime ()

Protected Methods

vtkLocator ()
~vtkLocator ()

Protected Attributes

vtkDataSet * DataSet
int | Automatic
float | Tolerance
int | MaxLevel
int | Level
int | RetainCellLists
vtkTimeStamp BuildTime

Detailed Description

abstract base class for objects that accelerate spatial searches.

Date:
2002/01/22 15:25:34
Revision:
1.47

vtkLocator is an abstract base class for spatial search objects, or locators. The principle behind locators is that they divide 3-space into small pieces (or "buckets") that can be quickly found in response to queries like point location, line intersection, or object-object intersection.

The purpose of this base class is to provide ivars and methods shared by all locators. The GenerateRepresentation() is one such interesting method. This method works in conjunction with vtkLocatorFilter to create polygonal representations for the locator. For example, if the locator is an OBB tree (i.e., vtkOBBTree.h), then the representation is a set of one or more oriented bounding boxes, depending upon the specified level.

Locators typically work as follows. One or more "entities", such as points or cells, are inserted into the tree. These entities are associated with one or more buckets. Then, when performing geometric operations, the operations are performed first on the buckets, and then if the operation tests positive, then on the entities in the bucket. For example, during collision tests, the locators are collided first to identify intersecting buckets. If an intersection is found, more expensive operations are then carried out on the entities in the bucket.

To obtain good performance, locators are often organized in a tree structure. In such a structure, there are frequently multiple "levels" corresponding to different nodes in the tree. So the word level (in the context of the locator) can be used to specify a particular representation in the tree. For example, in an octree (which is a tree with 8 children), level 0 is the bounding box, or root octant, and level 1 consists of its eight children.

See also:
vtkPointLocator vtkCellLocator vtkOBBTree vtkLocatorFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (94%)

Definition at line 69 of file vtkLocator.h.

Constructor & Destructor Documentation

vtkLocator::vtkLocator ( ) [protected]

vtkLocator::~vtkLocator ( ) [protected]

Member Function Documentation

vtkLocator::vtkTypeRevisionMacro | ( | vtkLocator | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkPointLocator, vtkPointLocator2D, vtkCellLocator, vtkMergePoints, vtkMergePoints2D, and vtkOBBTree.

void vtkLocator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkPointLocator, vtkPointLocator2D, and vtkCellLocator.

virtual void vtkLocator::SetDataSet ( vtkDataSet * ) [virtual]

Build the locator from the points/cells defining this dataset.

virtual vtkDataSet* vtkLocator::GetDataSet ( ) [virtual]

Build the locator from the points/cells defining this dataset.

virtual void vtkLocator::SetMaxLevel ( int ) [virtual]

Set the maximum allowable level for the tree. If the Automatic ivar is off, this will be the target depth of the locator.

virtual int vtkLocator::GetMaxLevel ( ) [virtual]

Set the maximum allowable level for the tree. If the Automatic ivar is off, this will be the target depth of the locator.

virtual int vtkLocator::GetLevel ( ) [virtual]

Get the level of the locator (determined automatically if Automatic is true). The value of this ivar may change each time the locator is built.

virtual void vtkLocator::SetAutomatic ( int ) [virtual]

Boolean controls whether locator depth/resolution of locator is computed automatically from average number of entities in bucket. If not set, there will be an explicit method to control the construction of the locator (found in the subclass).

virtual int vtkLocator::GetAutomatic ( ) [virtual]

Boolean controls whether locator depth/resolution of locator is computed automatically from average number of entities in bucket. If not set, there will be an explicit method to control the construction of the locator (found in the subclass).

virtual void vtkLocator::AutomaticOn ( ) [virtual]

Boolean controls whether locator depth/resolution of locator is computed automatically from average number of entities in bucket. If not set, there will be an explicit method to control the construction of the locator (found in the subclass).

virtual void vtkLocator::AutomaticOff ( ) [virtual]

Boolean controls whether locator depth/resolution of locator is computed automatically from average number of entities in bucket. If not set, there will be an explicit method to control the construction of the locator (found in the subclass).

virtual void vtkLocator::SetTolerance ( float ) [virtual]

Specify absolute tolerance (in world coordinates) for performing geometric operations.

virtual float vtkLocator::GetTolerance ( ) [virtual]

Specify absolute tolerance (in world coordinates) for performing geometric operations.

virtual void vtkLocator::SetRetainCellLists ( int ) [virtual]

Boolean controls whether to maintain list of entities in each bucket. Normally the lists are maintained, but if the locator is being used as a geometry simplification technique, there is no need to keep them.

virtual int vtkLocator::GetRetainCellLists ( ) [virtual]

Boolean controls whether to maintain list of entities in each bucket. Normally the lists are maintained, but if the locator is being used as a geometry simplification technique, there is no need to keep them.

virtual void vtkLocator::RetainCellListsOn ( ) [virtual]

Boolean controls whether to maintain list of entities in each bucket. Normally the lists are maintained, but if the locator is being used as a geometry simplification technique, there is no need to keep them.

virtual void vtkLocator::RetainCellListsOff ( ) [virtual]

Boolean controls whether to maintain list of entities in each bucket. Normally the lists are maintained, but if the locator is being used as a geometry simplification technique, there is no need to keep them.

virtual void vtkLocator::Update ( ) [virtual]

Cause the locator to rebuild itself if it or its input dataset has changed.

virtual void vtkLocator::Initialize ( ) [virtual]

Initialize locator. Frees memory and resets object as appropriate.

Reimplemented in vtkPointLocator, and vtkPointLocator2D.

virtual void vtkLocator::BuildLocator ( ) [pure virtual]

Build the locator from the input dataset.

Reimplemented in vtkPointLocator, vtkPointLocator2D, vtkCellLocator, and vtkOBBTree.

virtual void vtkLocator::FreeSearchStructure ( ) [pure virtual]

Free the memory required for the spatial data structure.

Reimplemented in vtkPointLocator, vtkPointLocator2D, vtkCellLocator, and vtkOBBTree.

virtual void vtkLocator::GenerateRepresentation | ( | int | level,
 |  | vtkPolyData * | pd
 | ) | [pure virtual]

Method to build a representation at a particular level. Note that the method GetLevel() returns the maximum number of levels available for the tree. You must provide a vtkPolyData object into which to place the data.

Reimplemented in vtkPointLocator, vtkPointLocator2D, vtkCellLocator, and vtkOBBTree.

virtual unsigned long vtkLocator::GetBuildTime ( ) [virtual]

Return the time of the last data structure build.

Member Data Documentation

vtkDataSet* vtkLocator::DataSet [protected]

Definition at line 150 of file vtkLocator.h.

int vtkLocator::Automatic [protected]

Definition at line 151 of file vtkLocator.h.

float vtkLocator::Tolerance [protected]

Definition at line 152 of file vtkLocator.h.

int vtkLocator::MaxLevel [protected]

Definition at line 153 of file vtkLocator.h.

int vtkLocator::Level [protected]

Definition at line 154 of file vtkLocator.h.

int vtkLocator::RetainCellLists [protected]

Definition at line 155 of file vtkLocator.h.

vtkTimeStamp vtkLocator::BuildTime [protected]

Definition at line 157 of file vtkLocator.h.

The documentation for this class was generated from the following file:
  • Common/vtkLocator.h
Generated on Mon Mar 25 01:23:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLODActor Class Reference

an actor that supports multiple levels of detail. More...

#include <vtkLODActor.h>

Inheritance diagram for vtkLODActor:

[legend]
Collaboration diagram for vtkLODActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLODActor, vtkActor)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Render (vtkRenderer *, vtkMapper *)
int | RenderOpaqueGeometry (vtkViewport *viewport)
void | ReleaseGraphicsResources (vtkWindow *)
void | AddLODMapper (vtkMapper *mapper)
void | Modified ()
void | ShallowCopy (vtkProp *prop)
virtual int | GetNumberOfCloudPoints ()
virtual void | SetNumberOfCloudPoints (int)
virtual vtkMapperCollection * | GetLODMappers ()

Static Public Methods

vtkLODActor * | New ()

Protected Methods

vtkLODActor ()
~vtkLODActor ()
void | CreateOwnLODs ()
void | UpdateOwnLODs ()
void | DeleteOwnLODs ()

Protected Attributes

vtkActor * Device
vtkMapperCollection * LODMappers
vtkMaskPoints * MaskPoints
vtkOutlineFilter * OutlineFilter
vtkTimeStamp BuildTime
int | NumberOfCloudPoints
vtkPolyDataMapper * LowMapper
vtkPolyDataMapper * MediumMapper

Detailed Description

an actor that supports multiple levels of detail.

Date:
2002/01/22 15:38:38
Revision:
1.44

vtkLODActor is an actor that stores multiple levels of detail (LOD) and can automatically switch between them. It selects which level of detail to use based on how much time it has been allocated to render. Currently a very simple method of TotalTime/NumberOfActors is used. (In the future this should be modified to dynamically allocate the rendering time between different actors based on their needs.)

There are three levels of detail by default. The top level is just the normal data. The lowest level of detail is a simple bounding box outline of the actor. The middle level of detail is a point cloud of a fixed number of points that have been randomly sampled from the mapper's input data. Point attributes are copied over to the point cloud. These two lower levels of detail are accomplished by creating instances of a vtkOutlineFilter (low-res) and vtkMaskPoints (medium-res). Additional levels of detail can be add using the AddLODMapper() method.

To control the frame rate, you typically set the vtkRenderWindowInteractor DesiredUpdateRate and StillUpdateRate. This then will cause vtkLODActor to adjust its LOD to fulfill the requested update rate.

For greater control on levels of detail, see also vtkLODProp3D. That class allows arbitrary definition of each LOD.

Warning:
If you provide your own mappers, you are responsible for setting its ivars correctly, such as ScalarRange, LookupTable, and so on.
Warning:
On some systems the point cloud rendering (the default, medium level of detail) can result in points so small that they can hardly be seen. In this case, use the GetProperty()->SetPointSize() method to increase the rendered size of the points.
See also:
vtkActor vtkRenderer vtkLODProp3D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Law, Charles (52%)
  • Martin, Ken (30%)
  • Schroeder, Will (10%)
Examples:
vtkLODActor (Examples)
Tests:
vtkLODActor (Tests)

Definition at line 82 of file vtkLODActor.h.

Constructor & Destructor Documentation

vtkLODActor::vtkLODActor ( ) [protected]

vtkLODActor::~vtkLODActor ( ) [protected]

Member Function Documentation

vtkLODActor::vtkTypeRevisionMacro | ( | vtkLODActor | ,
 |  | vtkActor |
 | ) |

Reimplemented from vtkActor.

void vtkLODActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor.

vtkLODActor* vtkLODActor::New ( ) [static]

Creates a vtkLODActor with the following defaults: origin(0,0,0) position=(0,0,0) scale=(1,1,1) visibility=1 pickable=1 dragable=1 orientation=(0,0,0). NumberOfCloudPoints is set to 150.

Reimplemented from vtkActor.

virtual void vtkLODActor::Render | ( | vtkRenderer * | ren,
 |  | vtkMapper * | mapper
 | ) | [virtual]

This causes the actor to be rendered. It, in turn, will render the actor's property and then mapper.

Reimplemented from vtkActor.

int vtkLODActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

This method is used internally by the rendering process. We overide the superclass method to properly set the estimated render time.

Reimplemented from vtkActor.

void vtkLODActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor.

void vtkLODActor::AddLODMapper ( vtkMapper * mapper )

Add another level of detail. They do not have to be in any order of complexity.

virtual int vtkLODActor::GetNumberOfCloudPoints ( ) [virtual]

Set/Get the number of random points for the point cloud.

virtual void vtkLODActor::SetNumberOfCloudPoints ( int ) [virtual]

Set/Get the number of random points for the point cloud.

virtual vtkMapperCollection* vtkLODActor::GetLODMappers ( ) [virtual]

All the mappers for different LODs are stored here. The order is not important.

void vtkLODActor::Modified ( ) [virtual]

When this objects gets modified, this method also modifies the object.

Reimplemented from vtkObject.

void vtkLODActor::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of an LOD actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor.

void vtkLODActor::CreateOwnLODs ( ) [protected]

void vtkLODActor::UpdateOwnLODs ( ) [protected]

void vtkLODActor::DeleteOwnLODs ( ) [protected]

Member Data Documentation

vtkActor* vtkLODActor::Device [protected]

Definition at line 133 of file vtkLODActor.h.

vtkMapperCollection* vtkLODActor::LODMappers [protected]

Definition at line 134 of file vtkLODActor.h.

vtkMaskPoints* vtkLODActor::MaskPoints [protected]

Definition at line 137 of file vtkLODActor.h.

vtkOutlineFilter* vtkLODActor::OutlineFilter [protected]

Definition at line 138 of file vtkLODActor.h.

vtkTimeStamp vtkLODActor::BuildTime [protected]

Definition at line 139 of file vtkLODActor.h.

int vtkLODActor::NumberOfCloudPoints [protected]

Definition at line 140 of file vtkLODActor.h.

vtkPolyDataMapper* vtkLODActor::LowMapper [protected]

Definition at line 141 of file vtkLODActor.h.

vtkPolyDataMapper* vtkLODActor::MediumMapper [protected]

Definition at line 142 of file vtkLODActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkLODActor.h
Generated on Mon Mar 25 01:23:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLODProp3D Class Reference

level of detail 3D prop. More...

#include <vtkLODProp3D.h>

Inheritance diagram for vtkLODProp3D:

[legend]
Collaboration diagram for vtkLODProp3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLODProp3D, vtkProp3D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RemoveLOD (int id)
vtkAbstractMapper3D * | GetLODMapper (int id)
int | GetLastRenderedLODID ()
int | GetPickLODID (void)
virtual void | GetActors (vtkPropCollection *)
void | ShallowCopy (vtkProp *prop)
void | ReleaseGraphicsResources (vtkWindow *)
void | SetAllocatedRenderTime (float t, vtkViewport *vp)
void | RestoreEstimatedRenderTime ()
virtual void | AddEstimatedRenderTime (float t, vtkViewport *vp)
float * | GetBounds ()
void | GetBounds (float bounds[6])
int | AddLOD (vtkMapper *m, vtkProperty *p, vtkProperty *back, vtkTexture *t, float time)
int | AddLOD (vtkMapper *m, vtkProperty *p, vtkTexture *t, float time)
int | AddLOD (vtkMapper *m, vtkProperty *p, vtkProperty *back, float time)
int | AddLOD (vtkMapper *m, vtkProperty *p, float time)
int | AddLOD (vtkMapper *m, vtkTexture *t, float time)
int | AddLOD (vtkMapper *m, float time)
int | AddLOD (vtkVolumeMapper *m, vtkVolumeProperty *p, float time)
int | AddLOD (vtkVolumeMapper *m, float time)
void | SetLODProperty (int id, vtkProperty *p)
void | GetLODProperty (int id, vtkProperty **p)
void | SetLODProperty (int id, vtkVolumeProperty *p)
void | GetLODProperty (int id, vtkVolumeProperty **p)
void | SetLODMapper (int id, vtkMapper *m)
void | GetLODMapper (int id, vtkMapper **m)
void | SetLODMapper (int id, vtkVolumeMapper *m)
void | GetLODMapper (int id, vtkVolumeMapper **m)
void | SetLODBackfaceProperty (int id, vtkProperty *t)
void | GetLODBackfaceProperty (int id, vtkProperty **t)
void | SetLODTexture (int id, vtkTexture *t)
void | GetLODTexture (int id, vtkTexture **t)
void | EnableLOD (int id)
void | DisableLOD (int id)
void | SetLODLevel (int id, float level)
float | GetLODLevel (int id)
float | GetLODIndexLevel (int index)
float | GetLODEstimatedRenderTime (int id)
float | GetLODIndexEstimatedRenderTime (int index)
virtual void | SetAutomaticLODSelection (int)
virtual int | GetAutomaticLODSelection ()
virtual void | AutomaticLODSelectionOn ()
virtual void | AutomaticLODSelectionOff ()
virtual void | SetSelectedLODID (int)
virtual int | GetSelectedLODID ()
void | SetPickMethod (void(*f)(void *), void *arg)
void | SetPickMethodArgDelete (void(*f)(void *))
void | SetSelectedPickLODID (int id)
virtual int | GetSelectedPickLODID ()
virtual void | SetAutomaticPickLODSelection (int)
virtual int | GetAutomaticPickLODSelection ()
virtual void | AutomaticPickLODSelectionOn ()
virtual void | AutomaticPickLODSelectionOff ()
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *viewport)

Static Public Methods

vtkLODProp3D * | New ()

Protected Methods

vtkLODProp3D ()
~vtkLODProp3D ()
int | GetAutomaticPickPropIndex (void)
int | GetNextEntryIndex ()
int | ConvertIDToIndex (int id)

Protected Attributes

vtkLODProp3DEntry * LODs
int | NumberOfEntries
int | NumberOfLODs
int | CurrentIndex
int | SelectedLODIndex
int | AutomaticLODSelection
int | SelectedLODID
int | SelectedPickLODID
int | AutomaticPickLODSelection
vtkProp * PreviousPickProp
void(* | PreviousPickMethod )(void *)
void * | PreviousPickMethodArg

Detailed Description

level of detail 3D prop.

Date:
2002/01/22 15:38:39
Revision:
1.27

vtkLODProp3D is a class to support level of detail rendering for Prop3D. Any number of mapper/property/texture items can be added to this object. Render time will be measured, and will be used to select a LOD based on the AllocatedRenderTime of this Prop3D. Depending on the type of the mapper/property, a vtkActor or a vtkVolume will be created behind the scenes.

See also:
vtkProp3D vtkActor vtkVolume vtkLODActor
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (75%)
  • Turner, Wes (10%)
  • Turek, Matt (9%)
Examples:
vtkLODProp3D (Examples)
Tests:
vtkLODProp3D (Tests)

Definition at line 71 of file vtkLODProp3D.h.

Constructor & Destructor Documentation

vtkLODProp3D::vtkLODProp3D ( ) [protected]

vtkLODProp3D::~vtkLODProp3D ( ) [protected]

Member Function Documentation

vtkLODProp3D* vtkLODProp3D::New ( ) [static]

Create an instance of this class.

Reimplemented from vtkProp.

vtkLODProp3D::vtkTypeRevisionMacro | ( | vtkLODProp3D | ,
 |  | vtkProp3D |
 | ) |

Reimplemented from vtkProp3D.

void vtkLODProp3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp3D.

float* vtkLODProp3D::GetBounds ( ) [virtual]

Standard vtkProp method to get 3D bounds of a 3D prop

Reimplemented from vtkProp3D.

void vtkLODProp3D::GetBounds ( float bounds[6] ) [inline]

Standard vtkProp method to get 3D bounds of a 3D prop

Reimplemented from vtkProp3D.

Definition at line 83 of file vtkLODProp3D.h.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | vtkProperty * | p,
 |  | vtkProperty * | back,
 |  | vtkTexture * | t,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | vtkProperty * | p,
 |  | vtkTexture * | t,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | vtkProperty * | p,
 |  | vtkProperty * | back,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | vtkProperty * | p,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | vtkTexture * | t,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkMapper * | m,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkVolumeMapper * | m,
 |  | vtkVolumeProperty * | p,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

int vtkLODProp3D::AddLOD | ( | vtkVolumeMapper * | m,
 |  | float | time
 | ) |

Add a level of detail with a given mapper, property, backface property, texture, and guess of rendering time. The property and texture fields can be set to NULL (the other methods are included for script access where null variables are not allowed). The time field can be set to 0.0 indicating that no initial guess for rendering time is being supplied. The returned integer value is an ID that can be used later to delete this LOD, or set it as the selected LOD.

void vtkLODProp3D::RemoveLOD ( int id )

Delete a level of detail given an ID. This is the ID returned by the AddLOD method

void vtkLODProp3D::SetLODProperty | ( | int | id,
 |  | vtkProperty * | p
 | ) |

Methods to set / get the property of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the property to get it. The returned property will be NULL if the id is not valid, or the property is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::GetLODProperty | ( | int | id,
 |  | vtkProperty ** | p
 | ) |

Methods to set / get the property of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the property to get it. The returned property will be NULL if the id is not valid, or the property is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::SetLODProperty | ( | int | id,
 |  | vtkVolumeProperty * | p
 | ) |

Methods to set / get the property of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the property to get it. The returned property will be NULL if the id is not valid, or the property is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::GetLODProperty | ( | int | id,
 |  | vtkVolumeProperty ** | p
 | ) |

Methods to set / get the property of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the property to get it. The returned property will be NULL if the id is not valid, or the property is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::SetLODMapper | ( | int | id,
 |  | vtkMapper * | m
 | ) |

Methods to set / get the mapper of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the mapper to get it. The returned mapper will be NULL if the id is not valid, or the mapper is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::GetLODMapper | ( | int | id,
 |  | vtkMapper ** | m
 | ) |

Methods to set / get the mapper of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the mapper to get it. The returned mapper will be NULL if the id is not valid, or the mapper is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::SetLODMapper | ( | int | id,
 |  | vtkVolumeMapper * | m
 | ) |

Methods to set / get the mapper of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the mapper to get it. The returned mapper will be NULL if the id is not valid, or the mapper is of the wrong type for the corresponding Prop3D.

void vtkLODProp3D::GetLODMapper | ( | int | id,
 |  | vtkVolumeMapper ** | m
 | ) |

Methods to set / get the mapper of an LOD. Since the LOD could be a volume or an actor, you have to pass in the pointer to the mapper to get it. The returned mapper will be NULL if the id is not valid, or the mapper is of the wrong type for the corresponding Prop3D.

vtkAbstractMapper3D* vtkLODProp3D::GetLODMapper ( int id )

Get the LODMapper as an vtkAbstractMapper3D. It is the user's respondibility to safe down cast this to a vtkMapper or vtkVolumeMapper as appropriate.

void vtkLODProp3D::SetLODBackfaceProperty | ( | int | id,
 |  | vtkProperty * | t
 | ) |

Methods to set / get the backface property of an LOD. This method is only valid for LOD ids that are Actors (not Volumes)

void vtkLODProp3D::GetLODBackfaceProperty | ( | int | id,
 |  | vtkProperty ** | t
 | ) |

Methods to set / get the backface property of an LOD. This method is only valid for LOD ids that are Actors (not Volumes)

void vtkLODProp3D::SetLODTexture | ( | int | id,
 |  | vtkTexture * | t
 | ) |

Methods to set / get the texture of an LOD. This method is only valid for LOD ids that are Actors (not Volumes)

void vtkLODProp3D::GetLODTexture | ( | int | id,
 |  | vtkTexture ** | t
 | ) |

Methods to set / get the texture of an LOD. This method is only valid for LOD ids that are Actors (not Volumes)

void vtkLODProp3D::EnableLOD ( int id )

Enable / disable a particular LOD. If it is disabled, it will not be used during automatic selection, but can be selected as the LOD if automatic LOD selection is off.

void vtkLODProp3D::DisableLOD ( int id )

Enable / disable a particular LOD. If it is disabled, it will not be used during automatic selection, but can be selected as the LOD if automatic LOD selection is off.

void vtkLODProp3D::SetLODLevel | ( | int | id,
 |  | float | level
 | ) |

Set the level of a particular LOD. When a LOD is selected for rendering because it has the largest render time that fits within the allocated time, all LOD are then checked to see if any one can render faster but has a lower (more resolution/better) level. This quantity is a float to ensure that a level can be inserted between 2 and 3.

float vtkLODProp3D::GetLODLevel ( int id )

Set the level of a particular LOD. When a LOD is selected for rendering because it has the largest render time that fits within the allocated time, all LOD are then checked to see if any one can render faster but has a lower (more resolution/better) level. This quantity is a float to ensure that a level can be inserted between 2 and 3.

float vtkLODProp3D::GetLODIndexLevel ( int index )

Set the level of a particular LOD. When a LOD is selected for rendering because it has the largest render time that fits within the allocated time, all LOD are then checked to see if any one can render faster but has a lower (more resolution/better) level. This quantity is a float to ensure that a level can be inserted between 2 and 3.

float vtkLODProp3D::GetLODEstimatedRenderTime ( int id )

Access method that can be used to find out the estimated render time (the thing used to select an LOD) for a given LOD ID or index. Value is returned in seconds.

float vtkLODProp3D::GetLODIndexEstimatedRenderTime ( int index )

Access method that can be used to find out the estimated render time (the thing used to select an LOD) for a given LOD ID or index. Value is returned in seconds.

virtual void vtkLODProp3D::SetAutomaticLODSelection ( int ) [virtual]

Turn on / off automatic selection of LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual int vtkLODProp3D::GetAutomaticLODSelection ( ) [virtual]

Turn on / off automatic selection of LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual void vtkLODProp3D::AutomaticLODSelectionOn ( ) [virtual]

Turn on / off automatic selection of LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual void vtkLODProp3D::AutomaticLODSelectionOff ( ) [virtual]

Turn on / off automatic selection of LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual void vtkLODProp3D::SetSelectedLODID ( int ) [virtual]

Set the id of the LOD that is to be drawn when automatic LOD selection is turned off.

virtual int vtkLODProp3D::GetSelectedLODID ( ) [virtual]

Set the id of the LOD that is to be drawn when automatic LOD selection is turned off.

int vtkLODProp3D::GetLastRenderedLODID ( )

Get the ID of the previously (during the last render) selected LOD index

int vtkLODProp3D::GetPickLODID ( void )

Get the ID of the appropriate pick LOD index

virtual void vtkLODProp3D::GetActors ( vtkPropCollection * ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented from vtkProp.

void vtkLODProp3D::SetPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

This method is invoked when an instance of vtkProp (or subclass, e.g., vtkActor) is picked by vtkPicker.

Reimplemented from vtkProp.

void vtkLODProp3D::SetPickMethodArgDelete ( void(* f)(void *) )

This method is invoked when an instance of vtkProp (or subclass, e.g., vtkActor) is picked by vtkPicker.

Reimplemented from vtkProp.

void vtkLODProp3D::SetSelectedPickLODID ( int id )

Set the id of the LOD that is to be used for picking when automatic LOD pick selection is turned off.

virtual int vtkLODProp3D::GetSelectedPickLODID ( ) [virtual]

Set the id of the LOD that is to be used for picking when automatic LOD pick selection is turned off.

virtual void vtkLODProp3D::SetAutomaticPickLODSelection ( int ) [virtual]

Turn on / off automatic selection of picking LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual int vtkLODProp3D::GetAutomaticPickLODSelection ( ) [virtual]

Turn on / off automatic selection of picking LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual void vtkLODProp3D::AutomaticPickLODSelectionOn ( ) [virtual]

Turn on / off automatic selection of picking LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

virtual void vtkLODProp3D::AutomaticPickLODSelectionOff ( ) [virtual]

Turn on / off automatic selection of picking LOD. This is on by default. If it is off, then the SelectedLODID is rendered regardless of rendering time or desired update rate.

void vtkLODProp3D::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this vtkLODProp3D.

Reimplemented from vtkProp3D.

int vtkLODProp3D::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

int vtkLODProp3D::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

Support the standard render methods.

Reimplemented from vtkProp.

void vtkLODProp3D::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

void vtkLODProp3D::SetAllocatedRenderTime | ( | float | t,
 |  | vtkViewport * | vp
 | ) |

Used by the culler / renderer to set the allocated render time for this prop. This is based on the desired update rate, and possibly some other properties such as potential screen coverage of this prop.

void vtkLODProp3D::RestoreEstimatedRenderTime ( ) [virtual]

Used when the render process is aborted to restore the previous estimated render time. Overridden here to allow previous time for a particular LOD to be restored - otherwise the time for the last rendered LOD will be copied into the currently selected LOD.

Reimplemented from vtkProp.

virtual void vtkLODProp3D::AddEstimatedRenderTime | ( | float | t,
 |  | vtkViewport * | vp
 | ) | [virtual]

Override method from vtkProp in order to push this call down to the selected LOD as well.

int vtkLODProp3D::GetAutomaticPickPropIndex ( void ) [protected]

int vtkLODProp3D::GetNextEntryIndex ( ) [protected]

int vtkLODProp3D::ConvertIDToIndex ( int id ) [protected]

Member Data Documentation

vtkLODProp3DEntry* vtkLODProp3D::LODs [protected]

Definition at line 266 of file vtkLODProp3D.h.

int vtkLODProp3D::NumberOfEntries [protected]

Definition at line 267 of file vtkLODProp3D.h.

int vtkLODProp3D::NumberOfLODs [protected]

Definition at line 268 of file vtkLODProp3D.h.

int vtkLODProp3D::CurrentIndex [protected]

Definition at line 269 of file vtkLODProp3D.h.

int vtkLODProp3D::SelectedLODIndex [protected]

Definition at line 273 of file vtkLODProp3D.h.

int vtkLODProp3D::AutomaticLODSelection [protected]

Definition at line 275 of file vtkLODProp3D.h.

int vtkLODProp3D::SelectedLODID [protected]

Definition at line 276 of file vtkLODProp3D.h.

int vtkLODProp3D::SelectedPickLODID [protected]

Definition at line 277 of file vtkLODProp3D.h.

int vtkLODProp3D::AutomaticPickLODSelection [protected]

Definition at line 278 of file vtkLODProp3D.h.

vtkProp* vtkLODProp3D::PreviousPickProp [protected]

Definition at line 279 of file vtkLODProp3D.h.

void(* vtkLODProp3D::PreviousPickMethod)(void *) [protected]

void* vtkLODProp3D::PreviousPickMethodArg [protected]

Definition at line 281 of file vtkLODProp3D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkLODProp3D.h
Generated on Mon Mar 25 01:23:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLODProp3DEntry Struct Reference

#include <vtkLODProp3D.h>

Collaboration diagram for vtkLODProp3DEntry:

[legend]
List of all members.

Public Attributes

vtkProp3D * Prop3D
int | Prop3DType
int | ID
float | EstimatedTime
int | State
float | Level

Member Data Documentation

vtkProp3D* vtkLODProp3DEntry::Prop3D

Definition at line 63 of file vtkLODProp3D.h.

int vtkLODProp3DEntry::Prop3DType

Definition at line 64 of file vtkLODProp3D.h.

int vtkLODProp3DEntry::ID

Definition at line 65 of file vtkLODProp3D.h.

float vtkLODProp3DEntry::EstimatedTime

Definition at line 66 of file vtkLODProp3D.h.

int vtkLODProp3DEntry::State

Definition at line 67 of file vtkLODProp3D.h.

float vtkLODProp3DEntry::Level

Definition at line 68 of file vtkLODProp3D.h.

The documentation for this struct was generated from the following file:
  • Rendering/vtkLODProp3D.h
Generated on Mon Mar 25 01:23:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLogLookupTable Class Reference

map scalars into colors using log (base 10) scale. More...

#include <vtkLogLookupTable.h>

Inheritance diagram for vtkLogLookupTable:

[legend]
Collaboration diagram for vtkLogLookupTable:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLogLookupTable, vtkLookupTable)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkLogLookupTable * | New ()

Protected Methods

vtkLogLookupTable (int sze=256, int ext=256)
~vtkLogLookupTable ()

Detailed Description

map scalars into colors using log (base 10) scale.

Date:
2002/01/22 15:25:35
Revision:
1.35

This class is an empty shell. Use vtkLookupTable with SetScaleToLog10() instead.

See also:
vtkLookupTable
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Gobbi, David (50%)
  • Schroeder, Will (34%)
  • Martin, Ken (5%)
Tests:
vtkLogLookupTable (Tests)

Definition at line 45 of file vtkLogLookupTable.h.

Constructor & Destructor Documentation

vtkLogLookupTable::vtkLogLookupTable | ( | int | sze = 256,
 |  | int | ext = 256
 | ) | [protected]

vtkLogLookupTable::~vtkLogLookupTable ( ) [inline, protected]

Definition at line 55 of file vtkLogLookupTable.h.

Member Function Documentation

vtkLogLookupTable* vtkLogLookupTable::New ( ) [static]

Construct with range=[0,1]; and hsv ranges set up for rainbow color table (from red to blue).

Reimplemented from vtkLookupTable.

vtkLogLookupTable::vtkTypeRevisionMacro | ( | vtkLogLookupTable | ,
 |  | vtkLookupTable |
 | ) |

Reimplemented from vtkLookupTable.

void vtkLogLookupTable::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLookupTable.

The documentation for this class was generated from the following file:
  • Common/vtkLogLookupTable.h
Generated on Mon Mar 25 01:23:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLongArray Class Reference

dynamic, self-adjusting long integer array. More...

#include <vtkLongArray.h>

Inheritance diagram for vtkLongArray:

[legend]
Collaboration diagram for vtkLongArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLongArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
long | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const long i)
vtkIdType | InsertNextValue (const long)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
long * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const long value)
long * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (long *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkLongArray * | New ()

Protected Methods

vtkLongArray (vtkIdType numComp=1)
~vtkLongArray ()
long * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

long * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting long integer array.

Date:
2002/02/13 22:46:29
Revision:
1.35

vtkLongArray is an array of long integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (25%)
  • Henderson, Amy (8%)
  • Geveci, Berk (6%)
  • Miller, Jim (5%)
  • Kelly, Ann (5%)
Tests:
vtkLongArray (Tests)

Definition at line 46 of file vtkLongArray.h.

Constructor & Destructor Documentation

vtkLongArray::vtkLongArray ( vtkIdType numComp = 1 ) [protected]

vtkLongArray::~vtkLongArray ( ) [protected]

Member Function Documentation

vtkLongArray* vtkLongArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkLongArray::vtkTypeRevisionMacro | ( | vtkLongArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkLongArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkLongArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkLongArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

void vtkLongArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 62 of file vtkLongArray.h.

virtual void vtkLongArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

vtkDataArray* vtkLongArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkLongArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 71 of file vtkLongArray.h.

int vtkLongArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 74 of file vtkLongArray.h.

void vtkLongArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkLongArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkLongArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkLongArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkLongArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkLongArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkLongArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkLongArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkLongArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkLongArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

long vtkLongArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 110 of file vtkLongArray.h.

void vtkLongArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 191 of file vtkLongArray.h.

void vtkLongArray::SetValue | ( | const vtkIdType | id,
 |  | const long | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 120 of file vtkLongArray.h.

void vtkLongArray::InsertValue | ( | const vtkIdType | id,
 |  | const long | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 212 of file vtkLongArray.h.

Referenced by InsertNextValue().

vtkIdType vtkLongArray::InsertNextValue ( const long i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 225 of file vtkLongArray.h.

float vtkLongArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkLongArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

virtual void vtkLongArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

long* vtkLongArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 150 of file vtkLongArray.h.

void* vtkLongArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 151 of file vtkLongArray.h.

long * vtkLongArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 197 of file vtkLongArray.h.

void vtkLongArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another long array.

Reimplemented from vtkDataArray.

void vtkLongArray::SetArray | ( | long * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkLongArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 171 of file vtkLongArray.h.

long* vtkLongArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

long* vtkLongArray::Array [protected]

Definition at line 179 of file vtkLongArray.h.

int vtkLongArray::TupleSize [protected]

Definition at line 182 of file vtkLongArray.h.

float* vtkLongArray::Tuple [protected]

Definition at line 183 of file vtkLongArray.h.

int vtkLongArray::SaveUserArray [protected]

Definition at line 185 of file vtkLongArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkLongArray.h
Generated on Mon Mar 25 01:23:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLookupTable Class Reference

map scalar values into colors via a lookup table. More...

#include <vtkLookupTable.h>

Inheritance diagram for vtkLookupTable:

[legend]
Collaboration diagram for vtkLookupTable:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkLookupTable, vtkScalarsToColors)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (int sz=256, int ext=256)
virtual void | Build ()
virtual void | ForceBuild ()
unsigned char * | MapValue (float v)
float | GetOpacity (float v)
virtual vtkIdType | GetIndex (float v)
void | SetTableValue (vtkIdType indx, float rgba[4])
void | SetTableValue (vtkIdType indx, float r, float g, float b, float a=1.0)
float * | GetTableValue (vtkIdType id)
void | GetTableValue (vtkIdType id, float rgba[4])
unsigned char * | WritePointer (const vtkIdType id, const int number)
virtual void | SetRamp (int)
void | SetRampToLinear ()
void | SetRampToSCurve ()
virtual int | GetRamp ()
void | SetScale (int scale)
void | SetScaleToLinear ()
void | SetScaleToLog10 ()
virtual int | GetScale ()
void | SetTableRange (float r[2])
virtual void | SetTableRange (float min, float max)
virtual float * | GetTableRange ()
virtual void | GetTableRange (float data[2])
virtual void | SetHueRange (float, float)
void | SetHueRange (float[2])
virtual float * | GetHueRange ()
virtual void | GetHueRange (float &, float &)
virtual void | GetHueRange (float[2])
virtual void | SetSaturationRange (float, float)
void | SetSaturationRange (float[2])
virtual float * | GetSaturationRange ()
virtual void | GetSaturationRange (float &, float &)
virtual void | GetSaturationRange (float[2])
virtual void | SetValueRange (float, float)
void | SetValueRange (float[2])
virtual float * | GetValueRange ()
virtual void | GetValueRange (float &, float &)
virtual void | GetValueRange (float[2])
virtual void | SetAlphaRange (float, float)
void | SetAlphaRange (float[2])
virtual float * | GetAlphaRange ()
virtual void | GetAlphaRange (float &, float &)
virtual void | GetAlphaRange (float[2])
float * | GetColor (float x)
void | GetColor (float x, float rgb[3])
void | SetNumberOfTableValues (vtkIdType number)
vtkIdType GetNumberOfTableValues ()
unsigned char * | GetPointer (const vtkIdType id)
float * | GetRange ()
void | SetRange (float min, float max)
void | SetRange (float rng[2])
virtual void | SetNumberOfColors (vtkIdType)
virtual vtkIdType | GetNumberOfColors ()
void | MapScalarsThroughTable2 (void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement)

Static Public Methods

vtkLookupTable * | New ()

Protected Methods

vtkLookupTable (int sze=256, int ext=256)
~vtkLookupTable ()

Protected Attributes

vtkIdType NumberOfColors
vtkUnsignedCharArray * Table
float | TableRange [2]
float | HueRange [2]
float | SaturationRange [2]
float | ValueRange [2]
float | AlphaRange [2]
int | Scale
int | Ramp
vtkTimeStamp InsertTime
vtkTimeStamp BuildTime
float | RGBA [4]

Detailed Description

map scalar values into colors via a lookup table.

Date:
2002/02/18 16:47:59
Revision:
1.66

vtkLookupTable is an object that is used by mapper objects to map scalar values into rgba (red-green-blue-alpha transparency) color specification, or rgba into scalar values. The color table can be created by direct insertion of color values, or by specifying hue, saturation, value, and alpha range and generating a table.

See also:
vtkLogLookupTable vtkWindowLevelLookupTable
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (42%)
  • Gobbi, David (29%)
  • Martin, Ken (13%)
  • Miller, Jim (5%)
Examples:
vtkLookupTable (Examples)
Tests:
vtkLookupTable (Tests)

Definition at line 57 of file vtkLookupTable.h.

Constructor & Destructor Documentation

vtkLookupTable::vtkLookupTable | ( | int | sze = 256,
 |  | int | ext = 256
 | ) | [protected]

vtkLookupTable::~vtkLookupTable ( ) [protected]

Member Function Documentation

vtkLookupTable* vtkLookupTable::New ( ) [static]

Construct with range=[0,1]; and hsv ranges set up for rainbow color table (from red to blue).

Reimplemented from vtkObject.

Reimplemented in vtkLogLookupTable, and vtkWindowLevelLookupTable.

vtkLookupTable::vtkTypeRevisionMacro | ( | vtkLookupTable | ,
 |  | vtkScalarsToColors |
 | ) |

Reimplemented from vtkScalarsToColors.

Reimplemented in vtkLogLookupTable, and vtkWindowLevelLookupTable.

void vtkLookupTable::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkScalarsToColors.

Reimplemented in vtkLogLookupTable, and vtkWindowLevelLookupTable.

int vtkLookupTable::Allocate | ( | int | sz = 256,
 |  | int | ext = 256
 | ) |

Allocate a color table of specified size.

virtual void vtkLookupTable::Build ( ) [virtual]

Generate lookup table from hue, saturation, value, alpha min/max values. Table is built from linear ramp of each value.

Reimplemented from vtkScalarsToColors.

Reimplemented in vtkWindowLevelLookupTable.

virtual void vtkLookupTable::ForceBuild ( ) [virtual]

Force the lookup table to regenerate from hue, saturation, value, and alpha min/max values. Table is built from a linear ramp of each value. ForceBuild() is useful if a lookup table has been defined manually (using SetTableValue) and then an application decides to rebuild the lookup table using the implicit process.

virtual void vtkLookupTable::SetRamp ( int ) [virtual]

Set the shape of the table ramp to either linear or S-curve. The default is S-curve, which tails off gradually at either end. The equation used for the S-curve is y = (sin((x - 1/2)*pi) + 1)/2, while the equation for the linear ramp is simply y = x. For an S-curve greyscale ramp, you should set NumberOfTableValues to 402 (which is 256*pi/2) to provide room for the tails of the ramp.

void vtkLookupTable::SetRampToLinear ( ) [inline]

Set the shape of the table ramp to either linear or S-curve. The default is S-curve, which tails off gradually at either end. The equation used for the S-curve is y = (sin((x - 1/2)*pi) + 1)/2, while the equation for the linear ramp is simply y = x. For an S-curve greyscale ramp, you should set NumberOfTableValues to 402 (which is 256*pi/2) to provide room for the tails of the ramp.

Definition at line 89 of file vtkLookupTable.h.

void vtkLookupTable::SetRampToSCurve ( ) [inline]

Set the shape of the table ramp to either linear or S-curve. The default is S-curve, which tails off gradually at either end. The equation used for the S-curve is y = (sin((x - 1/2)*pi) + 1)/2, while the equation for the linear ramp is simply y = x. For an S-curve greyscale ramp, you should set NumberOfTableValues to 402 (which is 256*pi/2) to provide room for the tails of the ramp.

Definition at line 90 of file vtkLookupTable.h.

virtual int vtkLookupTable::GetRamp ( ) [virtual]

Set the shape of the table ramp to either linear or S-curve. The default is S-curve, which tails off gradually at either end. The equation used for the S-curve is y = (sin((x - 1/2)*pi) + 1)/2, while the equation for the linear ramp is simply y = x. For an S-curve greyscale ramp, you should set NumberOfTableValues to 402 (which is 256*pi/2) to provide room for the tails of the ramp.

void vtkLookupTable::SetScale ( int scale )

Set the type of scale to use, linear or logarithmic. The default is linear. If the scale is logarithmic, then the TableRange must not cross the value zero.

void vtkLookupTable::SetScaleToLinear ( ) [inline]

Set the type of scale to use, linear or logarithmic. The default is linear. If the scale is logarithmic, then the TableRange must not cross the value zero.

Definition at line 99 of file vtkLookupTable.h.

void vtkLookupTable::SetScaleToLog10 ( ) [inline]

Set the type of scale to use, linear or logarithmic. The default is linear. If the scale is logarithmic, then the TableRange must not cross the value zero.

Definition at line 100 of file vtkLookupTable.h.

virtual int vtkLookupTable::GetScale ( ) [virtual]

Set the type of scale to use, linear or logarithmic. The default is linear. If the scale is logarithmic, then the TableRange must not cross the value zero.

void vtkLookupTable::SetTableRange ( float r[2] )

Set/Get the minimum/maximum scalar values for scalar mapping. Scalar values less than minimum range value are clamped to minimum range value. Scalar values greater than maximum range value are clamped to maximum range value.

Referenced by vtkWindowLevelLookupTable::SetLevel(), and vtkWindowLevelLookupTable::SetWindow().

virtual void vtkLookupTable::SetTableRange | ( | float | min,
 |  | float | max
 | ) | [virtual]

Set/Get the minimum/maximum scalar values for scalar mapping. Scalar values less than minimum range value are clamped to minimum range value. Scalar values greater than maximum range value are clamped to maximum range value.

virtual float* vtkLookupTable::GetTableRange ( ) [virtual]

Set/Get the minimum/maximum scalar values for scalar mapping. Scalar values less than minimum range value are clamped to minimum range value. Scalar values greater than maximum range value are clamped to maximum range value.

virtual void vtkLookupTable::GetTableRange ( float data[2] ) [virtual]

Set/Get the minimum/maximum scalar values for scalar mapping. Scalar values less than minimum range value are clamped to minimum range value. Scalar values greater than maximum range value are clamped to maximum range value.

virtual void vtkLookupTable::SetHueRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the range in hue (using automatic generation). Hue ranges between [0,1].

void vtkLookupTable::SetHueRange ( float [2] )

Set the range in hue (using automatic generation). Hue ranges between [0,1].

virtual float* vtkLookupTable::GetHueRange ( ) [virtual]

Set the range in hue (using automatic generation). Hue ranges between [0,1].

virtual void vtkLookupTable::GetHueRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set the range in hue (using automatic generation). Hue ranges between [0,1].

virtual void vtkLookupTable::GetHueRange ( float [2] ) [virtual]

Set the range in hue (using automatic generation). Hue ranges between [0,1].

virtual void vtkLookupTable::SetSaturationRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the range in saturation (using automatic generation). Saturation ranges between [0,1].

void vtkLookupTable::SetSaturationRange ( float [2] )

Set the range in saturation (using automatic generation). Saturation ranges between [0,1].

virtual float* vtkLookupTable::GetSaturationRange ( ) [virtual]

Set the range in saturation (using automatic generation). Saturation ranges between [0,1].

virtual void vtkLookupTable::GetSaturationRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set the range in saturation (using automatic generation). Saturation ranges between [0,1].

virtual void vtkLookupTable::GetSaturationRange ( float [2] ) [virtual]

Set the range in saturation (using automatic generation). Saturation ranges between [0,1].

virtual void vtkLookupTable::SetValueRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the range in value (using automatic generation). Value ranges between [0,1].

void vtkLookupTable::SetValueRange ( float [2] )

Set the range in value (using automatic generation). Value ranges between [0,1].

virtual float* vtkLookupTable::GetValueRange ( ) [virtual]

Set the range in value (using automatic generation). Value ranges between [0,1].

virtual void vtkLookupTable::GetValueRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set the range in value (using automatic generation). Value ranges between [0,1].

virtual void vtkLookupTable::GetValueRange ( float [2] ) [virtual]

Set the range in value (using automatic generation). Value ranges between [0,1].

virtual void vtkLookupTable::SetAlphaRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the range in alpha (using automatic generation). Alpha ranges from [0,1].

void vtkLookupTable::SetAlphaRange ( float [2] )

Set the range in alpha (using automatic generation). Alpha ranges from [0,1].

virtual float* vtkLookupTable::GetAlphaRange ( ) [virtual]

Set the range in alpha (using automatic generation). Alpha ranges from [0,1].

virtual void vtkLookupTable::GetAlphaRange | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Set the range in alpha (using automatic generation). Alpha ranges from [0,1].

virtual void vtkLookupTable::GetAlphaRange ( float [2] ) [virtual]

Set the range in alpha (using automatic generation). Alpha ranges from [0,1].

unsigned char* vtkLookupTable::MapValue ( float v ) [virtual]

Map one value through the lookup table.

Reimplemented from vtkScalarsToColors.

float* vtkLookupTable::GetColor ( float x ) [inline]

Map one value through the lookup table and return the color as an RGB array of floats between 0 and 1.

Reimplemented from vtkScalarsToColors.

Definition at line 148 of file vtkLookupTable.h.

void vtkLookupTable::GetColor | ( | float | x,
 |  | float | rgb[3]
 | ) | [virtual]

Map one value through the lookup table and return the color as an RGB array of floats between 0 and 1.

Reimplemented from vtkScalarsToColors.

float vtkLookupTable::GetOpacity ( float v )

Map one value through the lookup table and return the alpha value (the opacity) as a float between 0 and 1.

virtual vtkIdType vtkLookupTable::GetIndex ( float v ) [virtual]

Return the table index associated with a particular value.

void vtkLookupTable::SetNumberOfTableValues ( vtkIdType number )

Specify the number of values (i.e., colors) in the lookup table.

vtkIdType vtkLookupTable::GetNumberOfTableValues ( ) [inline]

Specify the number of values (i.e., colors) in the lookup table.

Definition at line 162 of file vtkLookupTable.h.

void vtkLookupTable::SetTableValue | ( | vtkIdType | indx,
 |  | float | rgba[4]
 | ) |

Directly load color into lookup table. Use [0,1] float values for color component specification. Make sure that you've either used the Build() method or used SetNumberOfTableValues() prior to using this method.

void vtkLookupTable::SetTableValue | ( | vtkIdType | indx,
 |  | float | r,
 |  | float | g,
 |  | float | b,
 |  | float | a = 1.0
 | ) |

Directly load color into lookup table. Use [0,1] float values for color component specification.

float* vtkLookupTable::GetTableValue ( vtkIdType id )

Return a rgba color value for the given index into the lookup table. Color components are expressed as [0,1] float values.

void vtkLookupTable::GetTableValue | ( | vtkIdType | id,
 |  | float | rgba[4]
 | ) |

Return a rgba color value for the given index into the lookup table. Color components are expressed as [0,1] float values.

unsigned char* vtkLookupTable::GetPointer ( const vtkIdType id ) [inline]

Get pointer to color table data. Format is array of unsigned char r-g-b-a-r-g-b-a...

Definition at line 186 of file vtkLookupTable.h.

unsigned char* vtkLookupTable::WritePointer | ( | const vtkIdType | id,
 |  | const int | number
 | ) |

Get pointer to data. Useful for direct writes into object. MaxId is bumped by number (and memory allocated if necessary). Id is the location you wish to write into; number is the number of rgba values to write.

float* vtkLookupTable::GetRange ( ) [inline, virtual]

Sets/Gets the range of scalars which will be mapped. This is a duplicate of Get/SetTableRange.

Reimplemented from vtkScalarsToColors.

Definition at line 199 of file vtkLookupTable.h.

void vtkLookupTable::SetRange | ( | float | min,
 |  | float | max
 | ) | [inline, virtual]

Sets/Gets the range of scalars which will be mapped. This is a duplicate of Get/SetTableRange.

Reimplemented from vtkScalarsToColors.

Definition at line 200 of file vtkLookupTable.h.

void vtkLookupTable::SetRange ( float rng[2] ) [inline]

Sets/Gets the range of scalars which will be mapped. This is a duplicate of Get/SetTableRange.

Reimplemented from vtkScalarsToColors.

Definition at line 201 of file vtkLookupTable.h.

virtual void vtkLookupTable::SetNumberOfColors ( vtkIdType ) [virtual]

Set the number of colors in the lookup table. Use SetNumberOfTableValues() instead, it can be used both before and after the table has been built whereas SetNumberOfColors() has no effect after the table has been built.

virtual vtkIdType vtkLookupTable::GetNumberOfColors ( ) [virtual]

Set the number of colors in the lookup table. Use SetNumberOfTableValues() instead, it can be used both before and after the table has been built whereas SetNumberOfColors() has no effect after the table has been built.

void vtkLookupTable::MapScalarsThroughTable2 | ( | void * | input,
 |  | unsigned char * | output,
 |  | int | inputDataType,
 |  | int | numberOfValues,
 |  | int | inputIncrement,
 |  | int | outputIncrement
 | ) | [virtual]

map a set of scalars through the lookup table

Reimplemented from vtkScalarsToColors.

Member Data Documentation

vtkIdType vtkLookupTable::NumberOfColors [protected]

Definition at line 224 of file vtkLookupTable.h.

vtkUnsignedCharArray* vtkLookupTable::Table [protected]

Definition at line 225 of file vtkLookupTable.h.

float vtkLookupTable::TableRange[2] [protected]

Definition at line 226 of file vtkLookupTable.h.

float vtkLookupTable::HueRange[2] [protected]

Definition at line 227 of file vtkLookupTable.h.

float vtkLookupTable::SaturationRange[2] [protected]

Definition at line 228 of file vtkLookupTable.h.

float vtkLookupTable::ValueRange[2] [protected]

Definition at line 229 of file vtkLookupTable.h.

float vtkLookupTable::AlphaRange[2] [protected]

Definition at line 230 of file vtkLookupTable.h.

int vtkLookupTable::Scale [protected]

Definition at line 231 of file vtkLookupTable.h.

int vtkLookupTable::Ramp [protected]

Definition at line 232 of file vtkLookupTable.h.

vtkTimeStamp vtkLookupTable::InsertTime [protected]

Definition at line 233 of file vtkLookupTable.h.

vtkTimeStamp vtkLookupTable::BuildTime [protected]

Definition at line 234 of file vtkLookupTable.h.

float vtkLookupTable::RGBA[4] [protected]

Definition at line 235 of file vtkLookupTable.h.

The documentation for this class was generated from the following file:
  • Common/vtkLookupTable.h
Generated on Mon Mar 25 01:23:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkLoopSubdivisionFilter Class Reference

generate a subdivision surface using the Loop Scheme. More...

#include <vtkLoopSubdivisionFilter.h>

Inheritance diagram for vtkLoopSubdivisionFilter:

[legend]
Collaboration diagram for vtkLoopSubdivisionFilter:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkLoopSubdivisionFilter, vtkApproximatingSubdivisionFilter)
vtkLoopSubdivisionFilter * | New ()

Protected Methods

vtkLoopSubdivisionFilter ()
~vtkLoopSubdivisionFilter ()
void | GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)
void | GenerateEvenStencil (vtkIdType p1, vtkPolyData *polys, vtkIdList *stencilIds, float *weights)
void | GenerateOddStencil (vtkIdType p1, vtkIdType p2, vtkPolyData *polys, vtkIdList *stencilIds, float *weights)
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

generate a subdivision surface using the Loop Scheme.

Date:
2002/01/22 15:29:27
Revision:
1.13

vtkLoopSubdivisionFilter is an approximating subdivision scheme that creates four new triangles for each triangle in the mesh. The user can specify the NumberOfSubdivisions. Loop's subdivision scheme is described in: Loop, C., "Smooth Subdivision surfaces based on triangles,", Masters Thesis, University of Utah, August 1987. For a nice summary of the technique see, Hoppe, H., et. al, "Piecewise Smooth Surface Reconstruction,:, Proceedings of Siggraph 94 (Orlando, Florida, July 24-29, 1994). In COmputer Graphics Proceedings, Annual COnference Series, 1994, ACM SIGGRAPH, pp. 295-302.

The filter only operates on triangles. Users should use the vtkTriangleFilter to triangulate meshes that contain polygons or triangle strips.

The filter approximates point data using the same scheme. New triangles create at a subdivision step will have the cell data of their parent cell.

See also:
vtkApproximatingSubdivisionFilter
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (81%)
  • Henderson, Amy (9%)
  • Law, Charles (5%)
Tests:
vtkLoopSubdivisionFilter (Tests)

Definition at line 64 of file vtkLoopSubdivisionFilter.h.

Constructor & Destructor Documentation

vtkLoopSubdivisionFilter::vtkLoopSubdivisionFilter ( ) [inline, protected]

Definition at line 74 of file vtkLoopSubdivisionFilter.h.

vtkLoopSubdivisionFilter::~vtkLoopSubdivisionFilter ( ) [inline, protected]

Definition at line 75 of file vtkLoopSubdivisionFilter.h.

Member Function Documentation

vtkLoopSubdivisionFilter* vtkLoopSubdivisionFilter::New ( ) [static]

Construct object with NumberOfSubdivisions set to 1.

Reimplemented from vtkPolyDataSource.

vtkLoopSubdivisionFilter::vtkTypeRevisionMacro | ( | vtkLoopSubdivisionFilter | ,
 |  | vtkApproximatingSubdivisionFilter |
 | ) |

Reimplemented from vtkApproximatingSubdivisionFilter.

void vtkLoopSubdivisionFilter::GenerateSubdivisionPoints | ( | vtkPolyData * | inputDS,
 |  | vtkIntArray * | edgeData,
 |  | vtkPoints * | outputPts,
 |  | vtkPointData * | outputPD
 | ) | [protected, virtual]

Reimplemented from vtkApproximatingSubdivisionFilter.

void vtkLoopSubdivisionFilter::GenerateEvenStencil | ( | vtkIdType | p1,
 |  | vtkPolyData * | polys,
 |  | vtkIdList * | stencilIds,
 |  | float * | weights
 | ) | [protected]

void vtkLoopSubdivisionFilter::GenerateOddStencil | ( | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | vtkPolyData * | polys,
 |  | vtkIdList * | stencilIds,
 |  | float * | weights
 | ) | [protected]

void vtkLoopSubdivisionFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

The documentation for this class was generated from the following file:
  • Graphics/vtkLoopSubdivisionFilter.h
Generated on Mon Mar 25 01:23:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapper Class Reference

abstract class specifies interface to map data to graphics primitives. More...

#include <vtkMapper.h>

Inheritance diagram for vtkMapper:

[legend]
Collaboration diagram for vtkMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMapper, vtkAbstractMapper3D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ShallowCopy (vtkAbstractMapper *m)
unsigned long | GetMTime ()
virtual void | Render (vtkRenderer *ren, vtkActor *a)=0
virtual void | ReleaseGraphicsResources (vtkWindow *)
virtual void | CreateDefaultLookupTable ()
const char * | GetColorModeAsString ()
const char * | GetScalarModeAsString ()
vtkUnsignedCharArray * | MapScalars (float alpha)
virtual void | Update ()
void | SetLookupTable (vtkScalarsToColors *lut)
vtkScalarsToColors * GetLookupTable ()
virtual void | SetScalarVisibility (int)
virtual int | GetScalarVisibility ()
virtual void | ScalarVisibilityOn ()
virtual void | ScalarVisibilityOff ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToDefault ()
void | SetColorModeToMapScalars ()
virtual void | SetUseLookupTableScalarRange (int)
virtual int | GetUseLookupTableScalarRange ()
virtual void | UseLookupTableScalarRangeOn ()
virtual void | UseLookupTableScalarRangeOff ()
virtual void | SetScalarRange (float, float)
void | SetScalarRange (float[2])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float data[2])
virtual void | SetImmediateModeRendering (int)
virtual int | GetImmediateModeRendering ()
virtual void | ImmediateModeRenderingOn ()
virtual void | ImmediateModeRenderingOff ()
virtual void | SetScalarMode (int)
virtual int | GetScalarMode ()
void | SetScalarModeToDefault ()
void | SetScalarModeToUsePointData ()
void | SetScalarModeToUseCellData ()
void | SetScalarModeToUsePointFieldData ()
void | SetScalarModeToUseCellFieldData ()
void | ColorByArrayComponent (int arrayNum, int component)
void | ColorByArrayComponent (const char *arrayName, int component)
char * | GetArrayName ()
int | GetArrayId ()
int | GetArrayAccessMode ()
int | GetArrayComponent ()
virtual float * | GetBounds ()
virtual void | GetBounds (float bounds[6])
void | SetRenderTime (float time)
virtual float | GetRenderTime ()
vtkDataSet * GetInput ()
vtkDataSet * GetInputAsDataSet ()

Static Public Methods

void | SetGlobalImmediateModeRendering (int val)
void | GlobalImmediateModeRenderingOn ()
void | GlobalImmediateModeRenderingOff ()
int | GetGlobalImmediateModeRendering ()
void | SetResolveCoincidentTopology (int val)
int | GetResolveCoincidentTopology ()
void | SetResolveCoincidentTopologyToDefault ()
void | SetResolveCoincidentTopologyToOff ()
void | SetResolveCoincidentTopologyToPolygonOffset ()
void | SetResolveCoincidentTopologyToShiftZBuffer ()
void | SetResolveCoincidentTopologyPolygonOffsetParameters (float factor, float units)
void | GetResolveCoincidentTopologyPolygonOffsetParameters (float &factor, float &units)
void | SetResolveCoincidentTopologyZShift (double val)
double | GetResolveCoincidentTopologyZShift ()

Protected Methods

vtkMapper ()
~vtkMapper ()

Protected Attributes

vtkUnsignedCharArray * Colors
vtkScalarsToColors * LookupTable
int | ScalarVisibility
vtkTimeStamp BuildTime
float | ScalarRange [2]
int | UseLookupTableScalarRange
int | ImmediateModeRendering
int | ColorMode
int | ScalarMode
float | RenderTime
int | ArrayId
char | ArrayName [256]
int | ArrayComponent
int | ArrayAccessMode

Detailed Description

abstract class specifies interface to map data to graphics primitives.

Date:
2002/03/03 03:01:36
Revision:
1.80

vtkMapper is an abstract class to specify interface between data and graphics primitives. Subclasses of vtkMapper map data through a lookuptable and control the creation of rendering primitives that interface to the graphics library. The mapping can be controlled by supplying a lookup table and specifying a scalar range to map data through.

There are several important control mechanisms affecting the behavior of this object. The ScalarVisibility flag controls whether scalar data (if any) controls the color of the associated actor(s) that refer to the mapper. The ScalarMode ivar is used to determine whether scalar point data or cell data is used to color the object. By default, point data scalars are used unless there are none, in which cell scalars are used. Or you can explicitly control whether to use point or cell scalar data. Finally, the mapping of scalars through the lookup table varies depending on the setting of the ColorMode flag. See the documentation for the appropriate methods for an explanation.

Another important feature of this class is whether to use immediate mode rendering (ImmediateModeRenderingOn) or display list rendering (ImmediateModeRenderingOff). If display lists are used, a data structure is constructed (generally in the rendering library) which can then be rapidly traversed and rendered by the rendering library. The disadvantage of display lists is that they require additionally memory which may affect the performance of the system.

Another important feature of the mapper is the ability to shift the z-buffer to resolve coincident topology. For example, if you'd like to draw a mesh with some edges a different color, and the edges lie on the mesh, this feature can be useful to get nice looking lines. (See the ResolveCoincidentTopology-related methods.)

See also:
vtkDataSetMapper vtkPolyDataMapper
Created by:
  • Martin, Ken
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (48%)
  • Martin, Ken (19%)
  • Avila, Lisa (6%)
  • Henderson, Amy (6%)

Definition at line 86 of file vtkMapper.h.

Constructor & Destructor Documentation

vtkMapper::vtkMapper ( ) [protected]

vtkMapper::~vtkMapper ( ) [protected]

Member Function Documentation

vtkMapper::vtkTypeRevisionMacro | ( | vtkMapper | ,
 |  | vtkAbstractMapper3D |
 | ) |

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkDataSetMapper, vtkMesaPolyDataMapper, vtkOpenGLPolyDataMapper, and vtkPolyDataMapper.

void vtkMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkDataSetMapper, and vtkPolyDataMapper.

void vtkMapper::ShallowCopy ( vtkAbstractMapper * m )

Make a shallow copy of this mapper.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkPolyDataMapper.

unsigned long vtkMapper::GetMTime ( ) [virtual]

Overload standard modified time function. If lookup table is modified, then this object is modified as well.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkDataSetMapper.

virtual void vtkMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkActor * | act
 | ) | [pure virtual]

Method initiates the mapping process. Generally sent by the actor as each frame is rendered.

Reimplemented in vtkDataSetMapper, and vtkPolyDataMapper.

virtual void vtkMapper::ReleaseGraphicsResources ( vtkWindow * ) [inline, virtual]

Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkDataSetMapper, vtkMesaPolyDataMapper, and vtkOpenGLPolyDataMapper.

Definition at line 106 of file vtkMapper.h.

void vtkMapper::SetLookupTable ( vtkScalarsToColors * lut )

Specify a lookup table for the mapper to use.

vtkScalarsToColors* vtkMapper::GetLookupTable ( )

Specify a lookup table for the mapper to use.

virtual void vtkMapper::CreateDefaultLookupTable ( ) [virtual]

Create default lookup table. Generally used to create one when none is available with the scalar data.

virtual void vtkMapper::SetScalarVisibility ( int ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual int vtkMapper::GetScalarVisibility ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkMapper::ScalarVisibilityOn ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkMapper::ScalarVisibilityOff ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkMapper::SetColorMode ( int ) [virtual]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

virtual int vtkMapper::GetColorMode ( ) [virtual]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

void vtkMapper::SetColorModeToDefault ( ) [inline]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

Definition at line 136 of file vtkMapper.h.

void vtkMapper::SetColorModeToMapScalars ( ) [inline]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

Definition at line 138 of file vtkMapper.h.

const char* vtkMapper::GetColorModeAsString ( void )

Return the method of coloring scalar data.

virtual void vtkMapper::SetUseLookupTableScalarRange ( int ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual int vtkMapper::GetUseLookupTableScalarRange ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkMapper::UseLookupTableScalarRangeOn ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkMapper::UseLookupTableScalarRangeOff ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkMapper::SetScalarRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

void vtkMapper::SetScalarRange ( float [2] )

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual float* vtkMapper::GetScalarRange ( ) [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual void vtkMapper::GetScalarRange ( float data[2] ) [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual void vtkMapper::SetImmediateModeRendering ( int ) [virtual]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

virtual int vtkMapper::GetImmediateModeRendering ( ) [virtual]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

virtual void vtkMapper::ImmediateModeRenderingOn ( ) [virtual]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

virtual void vtkMapper::ImmediateModeRenderingOff ( ) [virtual]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

void vtkMapper::SetGlobalImmediateModeRendering ( int val ) [static]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

Referenced by GlobalImmediateModeRenderingOff(), and GlobalImmediateModeRenderingOn().

void vtkMapper::GlobalImmediateModeRenderingOn ( ) [inline, static]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

Definition at line 183 of file vtkMapper.h.

void vtkMapper::GlobalImmediateModeRenderingOff ( ) [inline, static]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

Definition at line 185 of file vtkMapper.h.

int vtkMapper::GetGlobalImmediateModeRendering ( ) [static]

Turn on/off flag to control whether data is rendered using immediate mode or note. Immediate mode rendering tends to be slower but it can handle larger datasets. The default value is immediate mode off. If you are having problems rendering a large dataset you might want to consider using immediate more rendering.

virtual void vtkMapper::SetScalarMode ( int ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

virtual int vtkMapper::GetScalarMode ( ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

void vtkMapper::SetScalarModeToDefault ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 203 of file vtkMapper.h.

void vtkMapper::SetScalarModeToUsePointData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 205 of file vtkMapper.h.

void vtkMapper::SetScalarModeToUseCellData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 207 of file vtkMapper.h.

void vtkMapper::SetScalarModeToUsePointFieldData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 209 of file vtkMapper.h.

void vtkMapper::SetScalarModeToUseCellFieldData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 211 of file vtkMapper.h.

void vtkMapper::ColorByArrayComponent | ( | int | arrayNum,
 |  | int | component
 | ) |

Choose which component of which field data array to color by.

void vtkMapper::ColorByArrayComponent | ( | const char * | arrayName,
 |  | int | component
 | ) |

Choose which component of which field data array to color by.

char* vtkMapper::GetArrayName ( ) [inline]

Get the array name or number and component to color by.

Definition at line 223 of file vtkMapper.h.

int vtkMapper::GetArrayId ( ) [inline]

Get the array name or number and component to color by.

Definition at line 224 of file vtkMapper.h.

int vtkMapper::GetArrayAccessMode ( ) [inline]

Get the array name or number and component to color by.

Definition at line 225 of file vtkMapper.h.

int vtkMapper::GetArrayComponent ( ) [inline]

Get the array name or number and component to color by.

Definition at line 226 of file vtkMapper.h.

const char* vtkMapper::GetScalarModeAsString ( )

Return the method for obtaining scalar data.

void vtkMapper::SetResolveCoincidentTopology ( int val ) [static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

int vtkMapper::GetResolveCoincidentTopology ( ) [static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

void vtkMapper::SetResolveCoincidentTopologyToDefault ( ) [static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

void vtkMapper::SetResolveCoincidentTopologyToOff ( ) [inline, static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

Definition at line 246 of file vtkMapper.h.

void vtkMapper::SetResolveCoincidentTopologyToPolygonOffset ( ) [inline, static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

Definition at line 248 of file vtkMapper.h.

void vtkMapper::SetResolveCoincidentTopologyToShiftZBuffer ( ) [inline, static]

Set/Get a global flag that controls whether coincident topology (e.g., a line on top of a polygon) is shifted to avoid z-buffer resolution (and hence rendering problems). If not off, there are two methods to choose from. PolygonOffset uses graphics systems calls to shift polygons, but does not distinguish vertices and lines from one another. ShiftZBuffer remaps the z-buffer to distinguish vertices, lines, and polygons, but does not always produce acceptable results. If you use the ShiftZBuffer approach, you may also want to set the ResolveCoincidentTopologyZShift value. (Note: not all mappers/graphics systems implement this functionality.)

Definition at line 250 of file vtkMapper.h.

void vtkMapper::SetResolveCoincidentTopologyPolygonOffsetParameters | ( | float | factor,
 |  | float | units
 | ) | [static]

Used to set the polygon offset scale factor and units. Used when ResolveCoincidentTopology is set to PolygonOffset. These are global variables.

void vtkMapper::GetResolveCoincidentTopologyPolygonOffsetParameters | ( | float & | factor,
 |  | float & | units
 | ) | [static]

Used to set the polygon offset scale factor and units. Used when ResolveCoincidentTopology is set to PolygonOffset. These are global variables.

void vtkMapper::SetResolveCoincidentTopologyZShift ( double val ) [static]

Used to set the z-shift if ResolveCoincidentTopology is set to ShiftZBuffer. This is a global variable.

double vtkMapper::GetResolveCoincidentTopologyZShift ( ) [static]

Used to set the z-shift if ResolveCoincidentTopology is set to ShiftZBuffer. This is a global variable.

virtual float* vtkMapper::GetBounds ( ) [virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkPolyDataMapper.

Referenced by vtkPolyDataMapper::GetBounds().

virtual void vtkMapper::GetBounds ( float bounds[6] ) [inline, virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkPolyDataMapper.

Definition at line 275 of file vtkMapper.h.

void vtkMapper::SetRenderTime ( float time ) [inline]

This instance variable is used by vtkLODActor to determine which mapper to use. It is an estimate of the time necessary to render. Setting the render time does not modify the mapper.

Definition at line 283 of file vtkMapper.h.

virtual float vtkMapper::GetRenderTime ( ) [virtual]

This instance variable is used by vtkLODActor to determine which mapper to use. It is an estimate of the time necessary to render. Setting the render time does not modify the mapper.

vtkDataSet* vtkMapper::GetInput ( )

Get the input as a vtkDataSet. This method is overridden in the specialized mapper classes to return more specific data types.

Reimplemented in vtkDataSetMapper, and vtkPolyDataMapper.

vtkDataSet* vtkMapper::GetInputAsDataSet ( ) [inline]

Get the input to this mapper as a vtkDataSet, instead of as a more specialized data type that the subclass may return from GetInput(). This method is provided for use in the wrapper languages, C++ programmers should use GetInput() instead.

Definition at line 300 of file vtkMapper.h.

vtkUnsignedCharArray* vtkMapper::MapScalars ( float alpha )

Map the scalars (if there are any scalars and ScalarVisibility is on) through the lookup table, returning an unsigned char RGBA array. This is typically done as part of the rendering process. The alpha parameter allows the blending of the scalars with an additional alpha (typically which comes from a vtkActor, etc.)

virtual void vtkMapper::Update ( void ) [virtual]

Update the input to the Mapper.

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkPolyDataMapper.

Member Data Documentation

vtkUnsignedCharArray* vtkMapper::Colors [protected]

Definition at line 318 of file vtkMapper.h.

vtkScalarsToColors* vtkMapper::LookupTable [protected]

Definition at line 320 of file vtkMapper.h.

int vtkMapper::ScalarVisibility [protected]

Definition at line 321 of file vtkMapper.h.

vtkTimeStamp vtkMapper::BuildTime [protected]

Definition at line 322 of file vtkMapper.h.

float vtkMapper::ScalarRange[2] [protected]

Definition at line 323 of file vtkMapper.h.

int vtkMapper::UseLookupTableScalarRange [protected]

Definition at line 324 of file vtkMapper.h.

int vtkMapper::ImmediateModeRendering [protected]

Definition at line 325 of file vtkMapper.h.

int vtkMapper::ColorMode [protected]

Definition at line 326 of file vtkMapper.h.

int vtkMapper::ScalarMode [protected]

Definition at line 327 of file vtkMapper.h.

float vtkMapper::RenderTime [protected]

Definition at line 329 of file vtkMapper.h.

int vtkMapper::ArrayId [protected]

Definition at line 332 of file vtkMapper.h.

char vtkMapper::ArrayName[256] [protected]

Definition at line 333 of file vtkMapper.h.

int vtkMapper::ArrayComponent [protected]

Definition at line 334 of file vtkMapper.h.

int vtkMapper::ArrayAccessMode [protected]

Definition at line 335 of file vtkMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMapper.h
Generated on Mon Mar 25 01:23:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapper2D Class Reference

#include <vtkMapper2D.h>

Inheritance diagram for vtkMapper2D:

[legend]
Collaboration diagram for vtkMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMapper2D, vtkAbstractMapper)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | RenderOverlay (vtkViewport *, vtkActor2D *)
virtual void | RenderOpaqueGeometry (vtkViewport *, vtkActor2D *)
virtual void | RenderTranslucentGeometry (vtkViewport *, vtkActor2D *)

Static Public Methods

vtkMapper2D * | New ()

Protected Methods

vtkMapper2D ()
~vtkMapper2D ()

Detailed Description

Date:
2002/01/22 15:25:38
Revision:
1.26

vtkMapper2D is an abstract class which defines the interface for objects which render two dimensional actors (vtkActor2D).

See also:
vtkActor2D
Created by:
  • Turek, Matt
Contributed by (if > 5%):
  • Turek, Matt (65%)
  • Martin, Ken (21%)
  • Schroeder, Will (6%)

Definition at line 45 of file vtkMapper2D.h.

Constructor & Destructor Documentation

vtkMapper2D::vtkMapper2D ( ) [inline, protected]

Definition at line 58 of file vtkMapper2D.h.

vtkMapper2D::~vtkMapper2D ( ) [inline, protected]

Definition at line 59 of file vtkMapper2D.h.

Member Function Documentation

vtkMapper2D* vtkMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkImageMapper, vtkLabeledDataMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper2D, vtkPolyDataMapper2D, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkTextMapper, vtkWin32ImageMapper, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32TextMapper, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, and vtkXTextMapper.

vtkMapper2D::vtkTypeRevisionMacro | ( | vtkMapper2D | ,
 |  | vtkAbstractMapper |
 | ) |

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkImageMapper, vtkLabeledDataMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper2D, vtkPolyDataMapper2D, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkTextMapper, vtkWin32ImageMapper, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32TextMapper, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, and vtkXTextMapper.

void vtkMapper2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkImageMapper, vtkLabeledDataMapper, vtkPolyDataMapper2D, vtkTextMapper, vtkWin32ImageMapper, and vtkXImageMapper.

virtual void vtkMapper2D::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Reimplemented in vtkLabeledDataMapper, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkWin32ImageMapper, vtkWin32PolyDataMapper2D, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, and vtkXPolyDataMapper2D.

Definition at line 53 of file vtkMapper2D.h.

virtual void vtkMapper2D::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Reimplemented in vtkLabeledDataMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper2D, vtkWin32OpenGLTextMapper, vtkXMesaTextMapper, and vtkXOpenGLTextMapper.

Definition at line 54 of file vtkMapper2D.h.

virtual void vtkMapper2D::RenderTranslucentGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Reimplemented in vtkWin32OpenGLTextMapper, and vtkXOpenGLTextMapper.

Definition at line 55 of file vtkMapper2D.h.

The documentation for this class was generated from the following file:
  • Common/vtkMapper2D.h
Generated on Mon Mar 25 01:23:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMapperCollection Class Reference

a list of mappers. More...

#include <vtkMapperCollection.h>

Inheritance diagram for vtkMapperCollection:

[legend]
Collaboration diagram for vtkMapperCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMapperCollection, vtkCollection)
vtkMapper * GetLastItem ()
void | AddItem (vtkMapper *a)
vtkMapper * GetNextItem ()

Static Public Methods

vtkMapperCollection * | New ()

Protected Methods

vtkMapperCollection ()
~vtkMapperCollection ()

Detailed Description

a list of mappers.

Date:
2002/01/22 15:38:41
Revision:
1.19

vtkMapperCollection represents and provides methods to manipulate a list of mappers (i.e., vtkMapper and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkMapper vtkCollection
Created by:
  • Hoffman, Bill
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (43%)
  • Martin, Ken (24%)
  • Hoffman, Bill (23%)

Definition at line 45 of file vtkMapperCollection.h.

Constructor & Destructor Documentation

vtkMapperCollection::vtkMapperCollection ( ) [inline, protected]

Definition at line 67 of file vtkMapperCollection.h.

vtkMapperCollection::~vtkMapperCollection ( ) [inline, protected]

Definition at line 68 of file vtkMapperCollection.h.

Member Function Documentation

vtkMapperCollection* vtkMapperCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkMapperCollection::vtkTypeRevisionMacro | ( | vtkMapperCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkMapperCollection::AddItem ( vtkMapper * a ) [inline]

Add an mapper to the list.

Definition at line 53 of file vtkMapperCollection.h.

vtkMapper* vtkMapperCollection::GetNextItem ( ) [inline]

Get the next mapper in the list.

Definition at line 59 of file vtkMapperCollection.h.

vtkMapper * vtkMapperCollection::GetLastItem ( ) [inline]

Get the last mapper in the list.

Definition at line 80 of file vtkMapperCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMapperCollection.h
Generated on Mon Mar 25 01:23:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingContourFilter Class Reference

generate isosurfaces/isolines from scalar values. More...

#include <vtkMarchingContourFilter.h>

Inheritance diagram for vtkMarchingContourFilter:

[legend]
Collaboration diagram for vtkMarchingContourFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMarchingContourFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | CreateDefaultLocator ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
virtual void | SetUseScalarTree (int)
virtual int | GetUseScalarTree ()
virtual void | UseScalarTreeOn ()
virtual void | UseScalarTreeOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkMarchingContourFilter * | New ()

Protected Methods

vtkMarchingContourFilter ()
~vtkMarchingContourFilter ()
void | Execute ()
void | StructuredPointsContour (int dim)
void | ImageContour (int dim)
void | DataSetContour ()

Protected Attributes

vtkContourValues * ContourValues
int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkPointLocator * Locator
int | UseScalarTree
vtkScalarTree * ScalarTree

Detailed Description

generate isosurfaces/isolines from scalar values.

Date:
2002/01/22 22:02:23
Revision:
1.19

vtkMarchingContourFilter is a filter that takes as input any dataset and generates on output isosurfaces and/or isolines. The exact form of the output depends upon the dimensionality of the input data. Data consisting of 3D cells will generate isosurfaces, data consisting of 2D cells will generate isolines, and data with 1D or 0D cells will generate isopoints. Combinations of output type are possible if the input dimension is mixed.

This filter will identify special dataset types (e.g., structured points) and use the appropriate specialized filter to process the data. For examples, if the input dataset type is a volume, this filter will create an internal vtkMarchingCubes instance and use it. This gives much better performance.

To use this filter you must specify one or more contour values. You can either use the method SetValue() to specify each contour value, or use GenerateValues() to generate a series of evenly spaced contours. It is also possible to accelerate the operation of this filter (at the cost of extra memory) by using a vtkScalarTree. A scalar tree is used to quickly locate cells that contain a contour surface. This is especially effective if multiple contours are being extracted. If you want to use a scalar tree, invoke the method UseScalarTreeOn().

Warning:
For unstructured data or structured grids, normals and gradients are not computed. This calculation will be implemented in the future. In the mean time, use vtkPolyDataNormals to compute the surface normals.
See also:
vtkMarchingCubes vtkSliceCubes vtkDividingCubes vtkMarchingSquares vtkImageMarchingCubes
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (75%)
  • Schroeder, Will (10%)
  • Henderson, Amy (5%)
Tests:
vtkMarchingContourFilter (Tests)

Definition at line 91 of file vtkMarchingContourFilter.h.

Constructor & Destructor Documentation

vtkMarchingContourFilter::vtkMarchingContourFilter ( ) [protected]

vtkMarchingContourFilter::~vtkMarchingContourFilter ( ) [protected]

Member Function Documentation

vtkMarchingContourFilter::vtkTypeRevisionMacro | ( | vtkMarchingContourFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkMarchingContourFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkMarchingContourFilter* vtkMarchingContourFilter::New ( ) [static]

Construct object with initial range (0,1) and single contour value of 0.0.

Reimplemented from vtkPolyDataSource.

void vtkMarchingContourFilter::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Methods to set / get contour values.

Definition at line 190 of file vtkMarchingContourFilter.h.

float vtkMarchingContourFilter::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 196 of file vtkMarchingContourFilter.h.

float * vtkMarchingContourFilter::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 203 of file vtkMarchingContourFilter.h.

void vtkMarchingContourFilter::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 211 of file vtkMarchingContourFilter.h.

void vtkMarchingContourFilter::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 219 of file vtkMarchingContourFilter.h.

int vtkMarchingContourFilter::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 225 of file vtkMarchingContourFilter.h.

void vtkMarchingContourFilter::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 233 of file vtkMarchingContourFilter.h.

void vtkMarchingContourFilter::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 243 of file vtkMarchingContourFilter.h.

unsigned long vtkMarchingContourFilter::GetMTime ( ) [virtual]

Modified GetMTime Because we delegate to vtkContourValues

Reimplemented from vtkObject.

virtual void vtkMarchingContourFilter::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkMarchingContourFilter::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkMarchingContourFilter::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingContourFilter::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkMarchingContourFilter::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkMarchingContourFilter::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkMarchingContourFilter::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkMarchingContourFilter::SetUseScalarTree ( int ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual int vtkMarchingContourFilter::GetUseScalarTree ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkMarchingContourFilter::UseScalarTreeOn ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

virtual void vtkMarchingContourFilter::UseScalarTreeOff ( ) [virtual]

Enable the use of a scalar tree to accelerate contour extraction.

void vtkMarchingContourFilter::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkMarchingContourFilter::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkMarchingContourFilter::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

void vtkMarchingContourFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkMarchingContourFilter::StructuredPointsContour ( int dim ) [protected]

void vtkMarchingContourFilter::ImageContour ( int dim ) [protected]

void vtkMarchingContourFilter::DataSetContour ( ) [protected]

Member Data Documentation

vtkContourValues* vtkMarchingContourFilter::ContourValues [protected]

Definition at line 169 of file vtkMarchingContourFilter.h.

int vtkMarchingContourFilter::ComputeNormals [protected]

Definition at line 170 of file vtkMarchingContourFilter.h.

int vtkMarchingContourFilter::ComputeGradients [protected]

Definition at line 171 of file vtkMarchingContourFilter.h.

int vtkMarchingContourFilter::ComputeScalars [protected]

Definition at line 172 of file vtkMarchingContourFilter.h.

vtkPointLocator* vtkMarchingContourFilter::Locator [protected]

Definition at line 173 of file vtkMarchingContourFilter.h.

int vtkMarchingContourFilter::UseScalarTree [protected]

Definition at line 174 of file vtkMarchingContourFilter.h.

vtkScalarTree* vtkMarchingContourFilter::ScalarTree [protected]

Definition at line 175 of file vtkMarchingContourFilter.h.

The documentation for this class was generated from the following file:
  • Patented/vtkMarchingContourFilter.h
Generated on Mon Mar 25 01:23:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingCubes Class Reference

generate isosurface(s) from volume. More...

#include <vtkMarchingCubes.h>

Inheritance diagram for vtkMarchingCubes:

[legend]
Collaboration diagram for vtkMarchingCubes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMarchingCubes, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetValue (int i, float value)
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
unsigned long int | GetMTime ()
void | CreateDefaultLocator ()
float | GetValue (int i)
float * | GetValues ()
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkMarchingCubes * | New ()

Protected Methods

vtkMarchingCubes ()
~vtkMarchingCubes ()
void | Execute ()

Protected Attributes

vtkContourValues * ContourValues
int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkPointLocator * Locator

Detailed Description

generate isosurface(s) from volume.

Date:
2002/01/22 22:02:25
Revision:
1.60

vtkMarchingCubes is a filter that takes as input a volume (e.g., 3D structured point set) and generates on output one or more isosurfaces. One or more contour values must be specified to generate the isosurfaces. Alternatively, you can specify a min/max scalar range and the number of contours to generate a series of evenly spaced contour values.

Warning:
This filter is specialized to volumes. If you are interested in contouring other types of data, use the general vtkContourFilter. If you want to contour an image (i.e., a volume slice), use vtkMarchingSquares.
See also:
vtkContourFilter vtkSliceCubes vtkMarchingSquares vtkDividingCubes
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (49%)
  • Lorensen, Bill (32%)
  • Martin, Ken (8%)
Tests:
vtkMarchingCubes (Tests)

Definition at line 68 of file vtkMarchingCubes.h.

Constructor & Destructor Documentation

vtkMarchingCubes::vtkMarchingCubes ( ) [protected]

vtkMarchingCubes::~vtkMarchingCubes ( ) [protected]

Member Function Documentation

vtkMarchingCubes* vtkMarchingCubes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkMarchingCubes::vtkTypeRevisionMacro | ( | vtkMarchingCubes | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

void vtkMarchingCubes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkMarchingCubes::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 146 of file vtkMarchingCubes.h.

float vtkMarchingCubes::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 151 of file vtkMarchingCubes.h.

float * vtkMarchingCubes::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 158 of file vtkMarchingCubes.h.

void vtkMarchingCubes::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 165 of file vtkMarchingCubes.h.

void vtkMarchingCubes::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 171 of file vtkMarchingCubes.h.

int vtkMarchingCubes::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 176 of file vtkMarchingCubes.h.

void vtkMarchingCubes::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 183 of file vtkMarchingCubes.h.

void vtkMarchingCubes::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 190 of file vtkMarchingCubes.h.

unsigned long int vtkMarchingCubes::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented from vtkObject.

virtual void vtkMarchingCubes::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkMarchingCubes::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkMarchingCubes::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkMarchingCubes::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkMarchingCubes::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkMarchingCubes::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkMarchingCubes::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

void vtkMarchingCubes::SetLocator ( vtkPointLocator * locator )

Overide the default locator. Useful for changing the number of bins for performance or specifying a more aggressive locator.

virtual vtkPointLocator* vtkMarchingCubes::GetLocator ( ) [virtual]

Overide the default locator. Useful for changing the number of bins for performance or specifying a more aggressive locator.

void vtkMarchingCubes::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

void vtkMarchingCubes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkContourValues* vtkMarchingCubes::ContourValues [protected]

Definition at line 134 of file vtkMarchingCubes.h.

int vtkMarchingCubes::ComputeNormals [protected]

Definition at line 135 of file vtkMarchingCubes.h.

int vtkMarchingCubes::ComputeGradients [protected]

Definition at line 136 of file vtkMarchingCubes.h.

int vtkMarchingCubes::ComputeScalars [protected]

Definition at line 137 of file vtkMarchingCubes.h.

vtkPointLocator* vtkMarchingCubes::Locator [protected]

Definition at line 138 of file vtkMarchingCubes.h.

The documentation for this class was generated from the following file:
  • Patented/vtkMarchingCubes.h
Generated on Mon Mar 25 01:23:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMarchingSquares Class Reference

generate isoline(s) from structured points set. More...

#include <vtkMarchingSquares.h>

Inheritance diagram for vtkMarchingSquares:

[legend]
Collaboration diagram for vtkMarchingSquares:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMarchingSquares, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetValue (int i, float value)
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
unsigned long int | GetMTime ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()
void | CreateDefaultLocator ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | SetImageRange (int data[])
virtual int * | GetImageRange ()
virtual void | GetImageRange (int data[6])
void | SetImageRange (int imin, int imax, int jmin, int jmax, int kmin, int kmax)
float | GetValue (int i)
float * | GetValues ()
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)

Static Public Methods

vtkMarchingSquares * | New ()

Protected Methods

vtkMarchingSquares ()
~vtkMarchingSquares ()
void | Execute ()

Protected Attributes

vtkContourValues * ContourValues
int | ImageRange [6]
vtkPointLocator * Locator

Detailed Description

generate isoline(s) from structured points set.

Date:
2002/01/22 22:02:28
Revision:
1.38

vtkMarchingSquares is a filter that takes as input a structured points set and generates on output one or more isolines. One or more contour values must be specified to generate the isolines. Alternatively, you can specify a min/max scalar range and the number of contours to generate a series of evenly spaced contour values.

To generate contour lines the input data must be of topological dimension 2 (i.e., an image). If not, you can use the ImageRange ivar to select an image plane from an input volume. This avoids having to extract a plane first (using vtkExtractSubVolume). The filter deals with this by first trying to use the input data directly, and if not a 2D image, then uses the ImageRange ivar to reduce it to an image.

Warning:
This filter is specialized to images. If you are interested in contouring other types of data, use the general vtkContourFilter.
See also:
vtkContourFilter vtkMarchingCubes vtkSliceCubes vtkDividingCubes
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Lorensen, Bill (8%)
  • Law, Charles (7%)
  • Martin, Ken (7%)
Tests:
vtkMarchingSquares (Tests)

Definition at line 76 of file vtkMarchingSquares.h.

Constructor & Destructor Documentation

vtkMarchingSquares::vtkMarchingSquares ( ) [protected]

vtkMarchingSquares::~vtkMarchingSquares ( ) [protected]

Member Function Documentation

vtkMarchingSquares* vtkMarchingSquares::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkMarchingSquares::vtkTypeRevisionMacro | ( | vtkMarchingSquares | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkMarchingSquares::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkMarchingSquares::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkMarchingSquares::GetInput ( )

Set / get the input data or filter.

virtual void vtkMarchingSquares::SetImageRange ( int data[] ) [virtual]

Set/Get the i-j-k index range which define a plane on which to generate contour lines. Using this ivar it is possible to input a 3D volume directly and then generate contour lines on one of the i-j-k planes, or a portion of a plane.

virtual int* vtkMarchingSquares::GetImageRange ( ) [virtual]

Set/Get the i-j-k index range which define a plane on which to generate contour lines. Using this ivar it is possible to input a 3D volume directly and then generate contour lines on one of the i-j-k planes, or a portion of a plane.

virtual void vtkMarchingSquares::GetImageRange ( int data[6] ) [virtual]

Set/Get the i-j-k index range which define a plane on which to generate contour lines. Using this ivar it is possible to input a 3D volume directly and then generate contour lines on one of the i-j-k planes, or a portion of a plane.

void vtkMarchingSquares::SetImageRange | ( | int | imin,
 |  | int | imax,
 |  | int | jmin,
 |  | int | jmax,
 |  | int | kmin,
 |  | int | kmax
 | ) |

Set/Get the i-j-k index range which define a plane on which to generate contour lines. Using this ivar it is possible to input a 3D volume directly and then generate contour lines on one of the i-j-k planes, or a portion of a plane.

void vtkMarchingSquares::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 136 of file vtkMarchingSquares.h.

float vtkMarchingSquares::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 141 of file vtkMarchingSquares.h.

float * vtkMarchingSquares::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 148 of file vtkMarchingSquares.h.

void vtkMarchingSquares::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 155 of file vtkMarchingSquares.h.

void vtkMarchingSquares::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 161 of file vtkMarchingSquares.h.

int vtkMarchingSquares::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 166 of file vtkMarchingSquares.h.

void vtkMarchingSquares::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 173 of file vtkMarchingSquares.h.

void vtkMarchingSquares::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 180 of file vtkMarchingSquares.h.

unsigned long int vtkMarchingSquares::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented from vtkObject.

void vtkMarchingSquares::SetLocator ( vtkPointLocator * locator )

virtual vtkPointLocator* vtkMarchingSquares::GetLocator ( ) [virtual]

void vtkMarchingSquares::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified. The locator is used to merge coincident points.

void vtkMarchingSquares::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkContourValues* vtkMarchingSquares::ContourValues [protected]

Definition at line 126 of file vtkMarchingSquares.h.

int vtkMarchingSquares::ImageRange[6] [protected]

Definition at line 127 of file vtkMarchingSquares.h.

vtkPointLocator* vtkMarchingSquares::Locator [protected]

Definition at line 128 of file vtkMarchingSquares.h.

The documentation for this class was generated from the following file:
  • Patented/vtkMarchingSquares.h
Generated on Mon Mar 25 01:23:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskFields Class Reference

Allow control of which fields get passed. More...

#include <vtkMaskFields.h>

Inheritance diagram for vtkMaskFields:

[legend]
Collaboration diagram for vtkMaskFields:

[legend]
List of all members.

Public Types

enum | FieldLocation { OBJECT_DATA = 0, POINT_DATA = 1, CELL_DATA = 2 }

Public Methods

vtkTypeRevisionMacro (vtkMaskFields, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CopyFieldsOn ()
void | CopyAttributesOn ()
virtual void | CopyAllOn ()
virtual void | CopyAllOff ()
vtkMaskFields ()
virtual | ~vtkMaskFields ()
void | CopyFieldOn (int fieldLocation, const char *name)
void | CopyFieldOff (int fieldLocation, const char *name)
void | CopyAttributeOn (int attributeLocation, int attributeType)
void | CopyAttributeOff (int attributeLocation, int attributeType)
void | CopyFieldsOff ()
void | CopyAttributesOff ()
void | CopyAttributeOn (const char *attributeLoc, const char *attributeType)
void | CopyAttributeOff (const char *attributeLoc, const char *attributeType)
void | CopyFieldOn (const char *fieldLoc, const char *name)
void | CopyFieldOff (const char *fieldLoc, const char *name)

Static Public Methods

vtkMaskFields * | New ()

Protected Methods

void | Execute ()
void | CopyFieldOnOff (int fieldLocation, const char *name, int onOff)
void | CopyAttributeOnOff (int attributeLocation, int attributeType, int onOff)
void | ClearFieldFlags ()
int | FindFlag (const char *field, int location)
int | FindFlag (int arrayType, int location)
int | GetFlag (const char *field, int location)
int | GetFlag (int arrayType, int location)
int | GetAttributeLocation (const char *loc)
int | GetAttributeType (const char *type)

Protected Attributes

CopyFieldFlag * CopyFieldFlags
int | NumberOfFieldFlags
int | CopyFields
int | CopyAttributes

Static Protected Attributes

char | FieldLocationNames [3][12]
char | AttributeNames [vtkDataSetAttributes::NUM_ATTRIBUTES][10]

Detailed Description

Allow control of which fields get passed.

Date:
2002/01/22 15:29:28
Revision:
1.3
to the output

vtkMaskFields is used to mark which fields in the input dataset get copied to the output. The output will contain only those fields marked as on by the filter.

See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray vtkRearrangeFields vtkSplitField vtkMergeFields vtkAssignAttribute
Created by:
  • Lee, Jeff
Contributed by (if > 5%):
  • Lee, Jeff (100%)

Definition at line 46 of file vtkMaskFields.h.

Member Enumeration Documentation

enum vtkMaskFields::FieldLocation

Enumeration values:
OBJECT_DATA
POINT_DATA
CELL_DATA

Definition at line 126 of file vtkMaskFields.h.

Constructor & Destructor Documentation

vtkMaskFields::vtkMaskFields ( )

virtual vtkMaskFields::~vtkMaskFields ( ) [virtual]

Member Function Documentation

vtkMaskFields::vtkTypeRevisionMacro | ( | vtkMaskFields | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkMaskFields::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkMaskFields* vtkMaskFields::New ( ) [static]

Create a new vtkMaskFields.

Reimplemented from vtkDataSetSource.

void vtkMaskFields::CopyFieldOn | ( | int | fieldLocation,
 |  | const char * | name
 | ) | [inline]

Turn on/off the copying of the field or specified by name. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array A field name and a location must be specified. For example:

      maskFields->CopyFieldOff(vtkMaskFields::CELL_DATA, "foo");
causes the field "foo" on the input cell data to not get copied to the output.

Definition at line 65 of file vtkMaskFields.h.

void vtkMaskFields::CopyFieldOff | ( | int | fieldLocation,
 |  | const char * | name
 | ) | [inline]

Turn on/off the copying of the field or specified by name. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array A field name and a location must be specified. For example:

      maskFields->CopyFieldOff(vtkMaskFields::CELL_DATA, "foo");
causes the field "foo" on the input cell data to not get copied to the output.

Definition at line 66 of file vtkMaskFields.h.

void vtkMaskFields::CopyAttributeOn | ( | int | attributeLocation,
 |  | int | attributeType
 | ) | [inline]

Turn on/off the copying of the attribute or specified by vtkDataSetAttributes:AttributeTypes. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array An attribute type and a location must be specified. For example:

      maskFields->CopyAttributeOff(vtkMaskFields::POINT_DATA,
      vtkDataSetAttributes::SCALARS);
causes the scalars on the input point data to not get copied to the output.

Definition at line 81 of file vtkMaskFields.h.

void vtkMaskFields::CopyAttributeOff | ( | int | attributeLocation,
 |  | int | attributeType
 | ) | [inline]

Turn on/off the copying of the attribute or specified by vtkDataSetAttributes:AttributeTypes. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array An attribute type and a location must be specified. For example:

      maskFields->CopyAttributeOff(vtkMaskFields::POINT_DATA,
      vtkDataSetAttributes::SCALARS);
causes the scalars on the input point data to not get copied to the output.

Definition at line 82 of file vtkMaskFields.h.

void vtkMaskFields::CopyFieldsOff ( ) [inline]

Convenience methods which operate on all field data or attribute data. More specific than CopyAllOn or CopyAllOff

Definition at line 88 of file vtkMaskFields.h.

void vtkMaskFields::CopyAttributesOff ( ) [inline]

Convenience methods which operate on all field data or attribute data. More specific than CopyAllOn or CopyAllOff

Definition at line 89 of file vtkMaskFields.h.

void vtkMaskFields::CopyFieldsOn ( ) [inline]

Definition at line 92 of file vtkMaskFields.h.

void vtkMaskFields::CopyAttributesOn ( ) [inline]

Definition at line 93 of file vtkMaskFields.h.

void vtkMaskFields::CopyAttributeOn | ( | const char * | attributeLoc,
 |  | const char * | attributeType
 | ) |

Helper methods used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

void vtkMaskFields::CopyAttributeOff | ( | const char * | attributeLoc,
 |  | const char * | attributeType
 | ) |

Helper methods used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

void vtkMaskFields::CopyFieldOn | ( | const char * | fieldLoc,
 |  | const char * | name
 | ) |

Helper methods used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

void vtkMaskFields::CopyFieldOff | ( | const char * | fieldLoc,
 |  | const char * | name
 | ) |

Helper methods used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

virtual void vtkMaskFields::CopyAllOn ( ) [virtual]

Turn on copying of all data. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

virtual void vtkMaskFields::CopyAllOff ( ) [virtual]

Turn off copying of all data. During the copying/passing, the following rules are followed for each array: 1. If the copy flag for an array is set (on or off), it is applied This overrides rule 2. 2. If CopyAllOn is set, copy the array. If CopyAllOff is set, do not copy the array

void vtkMaskFields::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkMaskFields::CopyFieldOnOff | ( | int | fieldLocation,
 |  | const char * | name,
 |  | int | onOff
 | ) | [protected]

void vtkMaskFields::CopyAttributeOnOff | ( | int | attributeLocation,
 |  | int | attributeType,
 |  | int | onOff
 | ) | [protected]

void vtkMaskFields::ClearFieldFlags ( ) [protected]

int vtkMaskFields::FindFlag | ( | const char * | field,
 |  | int | location
 | ) | [protected]

int vtkMaskFields::FindFlag | ( | int | arrayType,
 |  | int | location
 | ) | [protected]

int vtkMaskFields::GetFlag | ( | const char * | field,
 |  | int | location
 | ) | [protected]

int vtkMaskFields::GetFlag | ( | int | arrayType,
 |  | int | location
 | ) | [protected]

int vtkMaskFields::GetAttributeLocation ( const char * loc ) [protected]

int vtkMaskFields::GetAttributeType ( const char * type ) [protected]

Member Data Documentation

CopyFieldFlag* vtkMaskFields::CopyFieldFlags [protected]

Definition at line 148 of file vtkMaskFields.h.

int vtkMaskFields::NumberOfFieldFlags [protected]

Definition at line 149 of file vtkMaskFields.h.

int vtkMaskFields::CopyFields [protected]

Definition at line 160 of file vtkMaskFields.h.

int vtkMaskFields::CopyAttributes [protected]

Definition at line 161 of file vtkMaskFields.h.

char vtkMaskFields::FieldLocationNames[3][12] [static, protected]

Definition at line 163 of file vtkMaskFields.h.

char vtkMaskFields::AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10] [static, protected]

Definition at line 164 of file vtkMaskFields.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMaskFields.h
Generated on Mon Mar 25 01:23:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskFields::CopyFieldFlag Struct Reference

#include <vtkMaskFields.h>

Collaboration diagram for vtkMaskFields::CopyFieldFlag:

[legend]
List of all members.

Public Attributes

char * | Name
int | Type
int | Location
int | IsCopied

Member Data Documentation

char* vtkMaskFields::CopyFieldFlag::Name

Definition at line 141 of file vtkMaskFields.h.

int vtkMaskFields::CopyFieldFlag::Type

Definition at line 142 of file vtkMaskFields.h.

int vtkMaskFields::CopyFieldFlag::Location

Definition at line 143 of file vtkMaskFields.h.

int vtkMaskFields::CopyFieldFlag::IsCopied

Definition at line 144 of file vtkMaskFields.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkMaskFields.h
Generated on Mon Mar 25 01:23:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskPoints Class Reference

selectively filter points. More...

#include <vtkMaskPoints.h>

Inheritance diagram for vtkMaskPoints:

[legend]
Collaboration diagram for vtkMaskPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMaskPoints, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOnRatio (int)
virtual int | GetOnRatio ()
virtual void | SetMaximumNumberOfPoints (vtkIdType)
virtual vtkIdType | GetMaximumNumberOfPoints ()
virtual void | SetOffset (vtkIdType)
virtual vtkIdType | GetOffset ()
virtual void | SetRandomMode (int)
virtual int | GetRandomMode ()
virtual void | RandomModeOn ()
virtual void | RandomModeOff ()
virtual void | SetGenerateVertices (int)
virtual int | GetGenerateVertices ()
virtual void | GenerateVerticesOn ()
virtual void | GenerateVerticesOff ()

Static Public Methods

vtkMaskPoints * | New ()

Protected Methods

vtkMaskPoints ()
~vtkMaskPoints ()
void | Execute ()

Protected Attributes

int | OnRatio
vtkIdType Offset
int | RandomMode
vtkIdType MaximumNumberOfPoints
int | GenerateVertices

Detailed Description

selectively filter points.

Date:
2002/01/22 15:29:29
Revision:
1.44

vtkMaskPoints is a filter that passes through points and point attributes from input dataset. (Other geometry is not passed through.) It is possible to mask every nth point, and to specify an initial offset to begin masking from. A special random mode feature enables random selection of points. The filter can also generate vertices (topological primitives) as well as points. This is useful because vertices are rendered while points are not.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Martin, Ken (22%)
  • Henderson, Amy (5%)
Examples:
vtkMaskPoints (Examples)
Tests:
vtkMaskPoints (Tests)

Definition at line 50 of file vtkMaskPoints.h.

Constructor & Destructor Documentation

vtkMaskPoints::vtkMaskPoints ( ) [protected]

vtkMaskPoints::~vtkMaskPoints ( ) [inline, protected]

Definition at line 95 of file vtkMaskPoints.h.

Member Function Documentation

vtkMaskPoints* vtkMaskPoints::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkMaskPoints::vtkTypeRevisionMacro | ( | vtkMaskPoints | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkMaskPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkMaskPoints::SetOnRatio ( int ) [virtual]

Turn on every nth point.

virtual int vtkMaskPoints::GetOnRatio ( ) [virtual]

Turn on every nth point.

virtual void vtkMaskPoints::SetMaximumNumberOfPoints ( vtkIdType ) [virtual]

Limit the number of points that can be passed through.

virtual vtkIdType vtkMaskPoints::GetMaximumNumberOfPoints ( ) [virtual]

Limit the number of points that can be passed through.

virtual void vtkMaskPoints::SetOffset ( vtkIdType ) [virtual]

Start with this point.

virtual vtkIdType vtkMaskPoints::GetOffset ( ) [virtual]

Start with this point.

virtual void vtkMaskPoints::SetRandomMode ( int ) [virtual]

Special flag causes randomization of point selection. If this mode is on, statistically every nth point (i.e., OnRatio) will be displayed.

virtual int vtkMaskPoints::GetRandomMode ( ) [virtual]

Special flag causes randomization of point selection. If this mode is on, statistically every nth point (i.e., OnRatio) will be displayed.

virtual void vtkMaskPoints::RandomModeOn ( ) [virtual]

Special flag causes randomization of point selection. If this mode is on, statistically every nth point (i.e., OnRatio) will be displayed.

virtual void vtkMaskPoints::RandomModeOff ( ) [virtual]

Special flag causes randomization of point selection. If this mode is on, statistically every nth point (i.e., OnRatio) will be displayed.

virtual void vtkMaskPoints::SetGenerateVertices ( int ) [virtual]

Generate output polydata vertices as well as points. A useful convenience method because vertices are drawn (they are topology) while points are not (they are geometry). By default this method is off.

virtual int vtkMaskPoints::GetGenerateVertices ( ) [virtual]

Generate output polydata vertices as well as points. A useful convenience method because vertices are drawn (they are topology) while points are not (they are geometry). By default this method is off.

virtual void vtkMaskPoints::GenerateVerticesOn ( ) [virtual]

Generate output polydata vertices as well as points. A useful convenience method because vertices are drawn (they are topology) while points are not (they are geometry). By default this method is off.

virtual void vtkMaskPoints::GenerateVerticesOff ( ) [virtual]

Generate output polydata vertices as well as points. A useful convenience method because vertices are drawn (they are topology) while points are not (they are geometry). By default this method is off.

void vtkMaskPoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkMaskPoints::OnRatio [protected]

Definition at line 99 of file vtkMaskPoints.h.

vtkIdType vtkMaskPoints::Offset [protected]

Definition at line 100 of file vtkMaskPoints.h.

int vtkMaskPoints::RandomMode [protected]

Definition at line 101 of file vtkMaskPoints.h.

vtkIdType vtkMaskPoints::MaximumNumberOfPoints [protected]

Definition at line 102 of file vtkMaskPoints.h.

int vtkMaskPoints::GenerateVertices [protected]

Definition at line 103 of file vtkMaskPoints.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMaskPoints.h
Generated on Mon Mar 25 01:23:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMaskPolyData Class Reference

sample subset of input polygonal data. More...

#include <vtkMaskPolyData.h>

Inheritance diagram for vtkMaskPolyData:

[legend]
Collaboration diagram for vtkMaskPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMaskPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOnRatio (int)
virtual int | GetOnRatio ()
virtual void | SetOffset (vtkIdType)
virtual vtkIdType | GetOffset ()

Static Public Methods

vtkMaskPolyData * | New ()

Protected Methods

vtkMaskPolyData ()
~vtkMaskPolyData ()
void | Execute ()

Protected Attributes

int | OnRatio
vtkIdType Offset

Detailed Description

sample subset of input polygonal data.

Date:
2002/01/22 15:29:29
Revision:
1.37

vtkMaskPolyData is a filter that sub-samples input polygonal data. The user specifies every nth item, with an initial offset to begin sampling.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (80%)
  • Martin, Ken (12%)
  • Henderson, Amy (6%)
Tests:
vtkMaskPolyData (Tests)

Definition at line 42 of file vtkMaskPolyData.h.

Constructor & Destructor Documentation

vtkMaskPolyData::vtkMaskPolyData ( ) [protected]

vtkMaskPolyData::~vtkMaskPolyData ( ) [inline, protected]

Definition at line 63 of file vtkMaskPolyData.h.

Member Function Documentation

vtkMaskPolyData* vtkMaskPolyData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkMaskPolyData::vtkTypeRevisionMacro | ( | vtkMaskPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkMaskPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkMaskPolyData::SetOnRatio ( int ) [virtual]

Turn on every nth entity (cell).

virtual int vtkMaskPolyData::GetOnRatio ( ) [virtual]

Turn on every nth entity (cell).

virtual void vtkMaskPolyData::SetOffset ( vtkIdType ) [virtual]

Start with this entity (cell).

virtual vtkIdType vtkMaskPolyData::GetOffset ( ) [virtual]

Start with this entity (cell).

void vtkMaskPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkMaskPolyData::OnRatio [protected]

Definition at line 66 of file vtkMaskPolyData.h.

vtkIdType vtkMaskPolyData::Offset [protected]

Definition at line 67 of file vtkMaskPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMaskPolyData.h
Generated on Mon Mar 25 01:23:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMassProperties Class Reference

estimate volume, area, shape index of triangle mesh. More...

#include <vtkMassProperties.h>

Inheritance diagram for vtkMassProperties:

[legend]
Collaboration diagram for vtkMassProperties:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMassProperties, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
double | GetVolume ()
double | GetSurfaceArea ()
void | Update ()
void | SetInput (vtkPolyData *input)
vtkPolyData * GetInput ()
double | GetVolumeX ()
double | GetVolumeY ()
double | GetVolumeZ ()
double | GetKx ()
double | GetKy ()
double | GetKz ()
double | GetNormalizedShapeIndex ()

Static Public Methods

vtkMassProperties * | New ()

Protected Methods

vtkMassProperties ()
~vtkMassProperties ()
void | Execute ()

Protected Attributes

double | SurfaceArea
double | Volume
double | VolumeX
double | VolumeY
double | VolumeZ
double | Kx
double | Ky
double | Kz
double | NormalizedShapeIndex
vtkTimeStamp ExecuteTime

Detailed Description

estimate volume, area, shape index of triangle mesh.

Date:
2002/01/22 15:29:29
Revision:
1.21

vtkMassProperties estimates the volume, the surface area, and the normalized shape index of a triangle mesh. The algorithm implemented here is based on the discrete form of the divergence theorem. The general assumption here is that the model is of closed surface. For more details see the following reference (Alyassin A.M. et al, "Evaluation of new algorithms for the interactive measurement of surface area and volume", Med Phys 21(6) 1994.).

Warning:
Currently only triangles are processed. Use vtkTriangleFilter to convert any strips or polygons to triangles.
See also:
vtkTriangleFilter
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Alyassin, Majeid
Contributed by (if > 5%):
  • Alyassin, Majeid (51%)
  • Lorensen, Bill (29%)
  • Schroeder, Will (12%)
Tests:
vtkMassProperties (Tests)

Definition at line 59 of file vtkMassProperties.h.

Constructor & Destructor Documentation

vtkMassProperties::vtkMassProperties ( ) [protected]

vtkMassProperties::~vtkMassProperties ( ) [protected]

Member Function Documentation

vtkMassProperties* vtkMassProperties::New ( ) [static]

Constructs with initial values of zero.

Reimplemented from vtkProcessObject.

vtkMassProperties::vtkTypeRevisionMacro | ( | vtkMassProperties | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

void vtkMassProperties::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

double vtkMassProperties::GetVolume ( ) [inline]

Compute and return the volume.

Definition at line 69 of file vtkMassProperties.h.

double vtkMassProperties::GetVolumeX ( ) [inline]

Compute and return the volume projected on to each axis aligned plane.

Definition at line 74 of file vtkMassProperties.h.

double vtkMassProperties::GetVolumeY ( ) [inline]

Compute and return the volume projected on to each axis aligned plane.

Definition at line 75 of file vtkMassProperties.h.

double vtkMassProperties::GetVolumeZ ( ) [inline]

Compute and return the volume projected on to each axis aligned plane.

Definition at line 76 of file vtkMassProperties.h.

double vtkMassProperties::GetKx ( ) [inline]

Compute and return the weighting factors for the maximum unit normal component (MUNC).

Definition at line 82 of file vtkMassProperties.h.

double vtkMassProperties::GetKy ( ) [inline]

Compute and return the weighting factors for the maximum unit normal component (MUNC).

Definition at line 83 of file vtkMassProperties.h.

double vtkMassProperties::GetKz ( ) [inline]

Compute and return the weighting factors for the maximum unit normal component (MUNC).

Definition at line 84 of file vtkMassProperties.h.

double vtkMassProperties::GetSurfaceArea ( ) [inline]

Compute and return the area.

Definition at line 88 of file vtkMassProperties.h.

double vtkMassProperties::GetNormalizedShapeIndex ( ) [inline]

Compute and return the normalized shape index. This characterizes the deviation of the shape of an object from a sphere. A sphere's NSI is one. This number is always >= 1.0.

Definition at line 94 of file vtkMassProperties.h.

void vtkMassProperties::Update ( )

void vtkMassProperties::SetInput ( vtkPolyData * input )

vtkPolyData* vtkMassProperties::GetInput ( )

void vtkMassProperties::Execute ( ) [protected]

Member Data Documentation

double vtkMassProperties::SurfaceArea [protected]

Definition at line 109 of file vtkMassProperties.h.

double vtkMassProperties::Volume [protected]

Definition at line 110 of file vtkMassProperties.h.

double vtkMassProperties::VolumeX [protected]

Definition at line 111 of file vtkMassProperties.h.

double vtkMassProperties::VolumeY [protected]

Definition at line 112 of file vtkMassProperties.h.

double vtkMassProperties::VolumeZ [protected]

Definition at line 113 of file vtkMassProperties.h.

double vtkMassProperties::Kx [protected]

Definition at line 114 of file vtkMassProperties.h.

double vtkMassProperties::Ky [protected]

Definition at line 115 of file vtkMassProperties.h.

double vtkMassProperties::Kz [protected]

Definition at line 116 of file vtkMassProperties.h.

double vtkMassProperties::NormalizedShapeIndex [protected]

Definition at line 117 of file vtkMassProperties.h.

vtkTimeStamp vtkMassProperties::ExecuteTime [protected]

Definition at line 118 of file vtkMassProperties.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMassProperties.h
Generated on Mon Mar 25 01:23:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Material Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Material:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS int external

Member Data Documentation

VTK_LIST_FIELDS int Material::external

Definition at line 91 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:23:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMath Class Reference

performs common math operations. More...

#include <vtkMath.h>

Inheritance diagram for vtkMath:

[legend]
Collaboration diagram for vtkMath:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMath, vtkObject)

Static Public Methods

vtkMath * | New ()
double | DoubleDegreesToRadians ()
void | Cross (const float x[3], const float y[3], float z[3])
void | Cross (const double x[3], const double y[3], double z[3])
float | Norm (const float *x, int n)
float | Normalize (float x[3])
double | Normalize (double x[3])
float | Distance2BetweenPoints (const float x[3], const float y[3])
double | Distance2BetweenPoints (const double x[3], const double y[3])
float | Normalize2D (float x[3])
double | Normalize2D (double x[3])
int | SolveLinearSystem (double **A, double *x, int size)
int | InvertMatrix (double **A, double **AI, int size)
int | LUFactorLinearSystem (double **A, int *index, int size)
double | EstimateMatrixCondition (double **A, int size)
void | RandomSeed (long s)
float | Random ()
float | Random (float min, float max)
double * | SolveCubic (double c0, double c1, double c2, double c3)
double * | SolveQuadratic (double c0, double c1, double c2)
double * | SolveLinear (double c0, double c1)
int | SolveLinear (double c0, double c1, double *r1, int *num_roots)
float | Pi ()
float | DegreesToRadians ()
int | Round (float f)
int | Round (double f)
float | Dot (const float x[3], const float y[3])
double | Dot (const double x[3], const double y[3])
float | Norm (const float x[3])
double | Norm (const double x[3])
void | Perpendiculars (const double x[3], double y[3], double z[3], double theta)
void | Perpendiculars (const float x[3], float y[3], float z[3], double theta)
float | Dot2D (const float x[3], const float y[3])
double | Dot2D (const double x[3], const double y[3])
float | Norm2D (const float x[3])
double | Norm2D (const double x[3])
float | Determinant2x2 (const float c1[2], const float c2[2])
double | Determinant2x2 (double a, double b, double c, double d)
void | LUFactor3x3 (float A[3][3], int index[3])
void | LUFactor3x3 (double A[3][3], int index[3])
void | LUSolve3x3 (const float A[3][3], const int index[3], float x[3])
void | LUSolve3x3 (const double A[3][3], const int index[3], double x[3])
void | LinearSolve3x3 (const float A[3][3], const float x[3], float y[3])
void | LinearSolve3x3 (const double A[3][3], const double x[3], double y[3])
void | Multiply3x3 (const float A[3][3], const float in[3], float out[3])
void | Multiply3x3 (const double A[3][3], const double in[3], double out[3])
void | Multiply3x3 (const float A[3][3], const float B[3][3], float C[3][3])
void | Multiply3x3 (const double A[3][3], const double B[3][3], double C[3][3])
void | Transpose3x3 (const float A[3][3], float AT[3][3])
void | Transpose3x3 (const double A[3][3], double AT[3][3])
void | Invert3x3 (const float A[3][3], float AI[3][3])
void | Invert3x3 (const double A[3][3], double AI[3][3])
void | Identity3x3 (float A[3][3])
void | Identity3x3 (double A[3][3])
double | Determinant3x3 (float A[3][3])
double | Determinant3x3 (double A[3][3])
float | Determinant3x3 (const float c1[3], const float c2[3], const float c3[3])
double | Determinant3x3 (double a1, double a2, double a3, double b1, double b2, double b3, double c1, double c2, double c3)
void | QuaternionToMatrix3x3 (const float quat[4], float A[3][3])
void | QuaternionToMatrix3x3 (const double quat[4], double A[3][3])
void | Matrix3x3ToQuaternion (const float A[3][3], float quat[4])
void | Matrix3x3ToQuaternion (const double A[3][3], double quat[4])
void | Orthogonalize3x3 (const float A[3][3], float B[3][3])
void | Orthogonalize3x3 (const double A[3][3], double B[3][3])
void | Diagonalize3x3 (const float A[3][3], float w[3], float V[3][3])
void | Diagonalize3x3 (const double A[3][3], double w[3], double V[3][3])
void | SingularValueDecomposition3x3 (const float A[3][3], float U[3][3], float w[3], float VT[3][3])
void | SingularValueDecomposition3x3 (const double A[3][3], double U[3][3], double w[3], double VT[3][3])
int | InvertMatrix (double **A, double **AI, int size, int *tmp1Size, double *tmp2Size)
int | LUFactorLinearSystem (double **A, int *index, int size, double *tmpSize)
void | LUSolveLinearSystem (double **A, int *index, double *x, int size)
int | Jacobi (float **a, float *w, float **v)
int | Jacobi (double **a, double *w, double **v)
int | JacobiN (float **a, int n, float *w, float **v)
int | JacobiN (double **a, int n, double *w, double **v)
int | SolveCubic (double c0, double c1, double c2, double c3, double *r1, double *r2, double *r3, int *num_roots)
int | SolveQuadratic (double c0, double c1, double c2, double *r1, double *r2, int *num_roots)
int | SolveLeastSquares (int numberOfSamples, double **xt, int xOrder, double **yt, int yOrder, double **mt)

Protected Methods

vtkMath ()
~vtkMath ()

Static Protected Attributes

long | Seed

Detailed Description

performs common math operations.

Date:
2002/01/22 15:25:41
Revision:
1.79

vtkMath is provides methods to perform common math operations. These include providing constants such as Pi; conversion from degrees to radians; vector operations such as dot and cross products and vector norm; matrix determinant for 2x2 and 3x3 matrices; and random number generation.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (35%)
  • Gobbi, David (30%)
  • Martin, Ken (7%)
  • Henderson, Amy (6%)
Examples:
vtkMath (Examples)
Tests:
vtkMath (Tests)

Definition at line 49 of file vtkMath.h.

Constructor & Destructor Documentation

vtkMath::vtkMath ( ) [inline, protected]

Definition at line 457 of file vtkMath.h.

vtkMath::~vtkMath ( ) [inline, protected]

Definition at line 458 of file vtkMath.h.

Member Function Documentation

vtkMath* vtkMath::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkMath::vtkTypeRevisionMacro | ( | vtkMath | ,
 |  | vtkObject |
 | ) |

float vtkMath::Pi ( ) [inline, static]

Useful constants.

Definition at line 57 of file vtkMath.h.

float vtkMath::DegreesToRadians ( ) [inline, static]

Useful constants.

Definition at line 58 of file vtkMath.h.

double vtkMath::DoubleDegreesToRadians ( ) [inline, static]

Useful constants. (double-precision version)

Definition at line 62 of file vtkMath.h.

int vtkMath::Round ( float f ) [inline, static]

Rounds a float to the nearest integer.

Definition at line 66 of file vtkMath.h.

int vtkMath::Round ( double f ) [inline, static]

Rounds a float to the nearest integer.

Definition at line 68 of file vtkMath.h.

float vtkMath::Dot | ( | const float | x[3],
 |  | const float | y[3]
 | ) | [inline, static]

Dot product of two 3-vectors (float version).

Definition at line 74 of file vtkMath.h.

double vtkMath::Dot | ( | const double | x[3],
 |  | const double | y[3]
 | ) | [inline, static]

Dot product of two 3-vectors (double-precision version).

Definition at line 80 of file vtkMath.h.

void vtkMath::Cross | ( | const float | x[3],
 |  | const float | y[3],
 |  | float | z[3]
 | ) | [inline, static]

Cross product of two 3-vectors. Result vector in z[3].

Definition at line 553 of file vtkMath.h.

void vtkMath::Cross | ( | const double | x[3],
 |  | const double | y[3],
 |  | double | z[3]
 | ) | [inline, static]

Cross product of two 3-vectors. Result vector in z[3]. (double-precision version)

Definition at line 562 of file vtkMath.h.

float vtkMath::Norm | ( | const float * | x,
 |  | int | n
 | ) | [static]

Compute the norm of n-vector.

Referenced by Normalize().

float vtkMath::Norm ( const float x[3] ) [inline, static]

Compute the norm of 3-vector.

Definition at line 96 of file vtkMath.h.

double vtkMath::Norm ( const double x[3] ) [inline, static]

Compute the norm of 3-vector (double-precision version).

Definition at line 102 of file vtkMath.h.

float vtkMath::Normalize ( float x[3] ) [inline, static]

Normalize (in place) a 3-vector. Returns norm of vector.

Definition at line 466 of file vtkMath.h.

double vtkMath::Normalize ( double x[3] ) [inline, static]

Normalize (in place) a 3-vector. Returns norm of vector (double-precision version).

Definition at line 478 of file vtkMath.h.

void vtkMath::Perpendiculars | ( | const double | x[3],
 |  | double | y[3],
 |  | double | z[3],
 |  | double | theta
 | ) | [static]

Given a unit vector x, find two unit vectors y and z such that x cross y = z (i.e. the vectors are perpendicular to each other). There is an infinite number of such vectors, specify an angle theta to choose one set. If you want only one perpendicular vector, specify NULL for z.

void vtkMath::Perpendiculars | ( | const float | x[3],
 |  | float | y[3],
 |  | float | z[3],
 |  | double | theta
 | ) | [static]

Given a unit vector x, find two unit vectors y and z such that x cross y = z (i.e. the vectors are perpendicular to each other). There is an infinite number of such vectors, specify an angle theta to choose one set. If you want only one perpendicular vector, specify NULL for z.

float vtkMath::Distance2BetweenPoints | ( | const float | x[3],
 |  | const float | y[3]
 | ) | [inline, static]

Compute distance squared between two points.

Definition at line 534 of file vtkMath.h.

Referenced by vtkTriangle::TriangleArea().

double vtkMath::Distance2BetweenPoints | ( | const double | x[3],
 |  | const double | y[3]
 | ) | [inline, static]

Compute distance squared between two points (double precision version).

Definition at line 540 of file vtkMath.h.

float vtkMath::Dot2D | ( | const float | x[3],
 |  | const float | y[3]
 | ) | [inline, static]

Dot product of two 2-vectors. The third (z) component is ignored.

Definition at line 134 of file vtkMath.h.

double vtkMath::Dot2D | ( | const double | x[3],
 |  | const double | y[3]
 | ) | [inline, static]

Dot product of two 2-vectors. The third (z) component is ignored (double-precision version).

Definition at line 141 of file vtkMath.h.

float vtkMath::Norm2D ( const float x[3] ) [inline, static]

Compute the norm of a 2-vector. Ignores z-component.

Definition at line 147 of file vtkMath.h.

Referenced by Normalize2D().

double vtkMath::Norm2D ( const double x[3] ) [inline, static]

Compute the norm of a 2-vector. Ignores z-component (double-precision version).

Definition at line 154 of file vtkMath.h.

float vtkMath::Normalize2D ( float x[3] ) [inline, static]

Normalize (in place) a 2-vector. Returns norm of vector. Ignores z-component.

Definition at line 491 of file vtkMath.h.

double vtkMath::Normalize2D ( double x[3] ) [inline, static]

Normalize (in place) a 2-vector. Returns norm of vector. Ignores z-component (double-precision version).

Definition at line 504 of file vtkMath.h.

float vtkMath::Determinant2x2 | ( | const float | c1[2],
 |  | const float | c2[2]
 | ) | [inline, static]

Compute determinant of 2x2 matrix. Two columns of matrix are input.

Definition at line 168 of file vtkMath.h.

Referenced by Determinant3x3().

double vtkMath::Determinant2x2 | ( | double | a,
 |  | double | b,
 |  | double | c,
 |  | double | d
 | ) | [inline, static]

Calculate the determinant of a 2x2 matrix: | a b | | c d |

Definition at line 174 of file vtkMath.h.

void vtkMath::LUFactor3x3 | ( | float | A[3][3],
 |  | int | index[3]
 | ) | [static]

LU Factorization of a 3x3 matrix. The diagonal elements are the multiplicative inverse of those in the standard LU factorization.

void vtkMath::LUFactor3x3 | ( | double | A[3][3],
 |  | int | index[3]
 | ) | [static]

LU Factorization of a 3x3 matrix. The diagonal elements are the multiplicative inverse of those in the standard LU factorization.

void vtkMath::LUSolve3x3 | ( | const float | A[3][3],
 |  | const int | index[3],
 |  | float | x[3]
 | ) | [static]

LU back substitution for a 3x3 matrix. The diagonal elements are the multiplicative inverse of those in the standard LU factorization.

void vtkMath::LUSolve3x3 | ( | const double | A[3][3],
 |  | const int | index[3],
 |  | double | x[3]
 | ) | [static]

LU back substitution for a 3x3 matrix. The diagonal elements are the multiplicative inverse of those in the standard LU factorization.

void vtkMath::LinearSolve3x3 | ( | const float | A[3][3],
 |  | const float | x[3],
 |  | float | y[3]
 | ) | [static]

Solve Ay = x for y and place the result in y. The matrix A is destroyed in the process.

void vtkMath::LinearSolve3x3 | ( | const double | A[3][3],
 |  | const double | x[3],
 |  | double | y[3]
 | ) | [static]

Solve Ay = x for y and place the result in y. The matrix A is destroyed in the process.

void vtkMath::Multiply3x3 | ( | const float | A[3][3],
 |  | const float | in[3],
 |  | float | out[3]
 | ) | [static]

Multiply a vector by a 3x3 matrix. The result is placed in out.

void vtkMath::Multiply3x3 | ( | const double | A[3][3],
 |  | const double | in[3],
 |  | double | out[3]
 | ) | [static]

Multiply a vector by a 3x3 matrix. The result is placed in out.

void vtkMath::Multiply3x3 | ( | const float | A[3][3],
 |  | const float | B[3][3],
 |  | float | C[3][3]
 | ) | [static]

Mutltiply one 3x3 matrix by another according to C = AB.

void vtkMath::Multiply3x3 | ( | const double | A[3][3],
 |  | const double | B[3][3],
 |  | double | C[3][3]
 | ) | [static]

Mutltiply one 3x3 matrix by another according to C = AB.

void vtkMath::Transpose3x3 | ( | const float | A[3][3],
 |  | float | AT[3][3]
 | ) | [static]

Transpose a 3x3 matrix.

void vtkMath::Transpose3x3 | ( | const double | A[3][3],
 |  | double | AT[3][3]
 | ) | [static]

Transpose a 3x3 matrix.

void vtkMath::Invert3x3 | ( | const float | A[3][3],
 |  | float | AI[3][3]
 | ) | [static]

Invert a 3x3 matrix.

void vtkMath::Invert3x3 | ( | const double | A[3][3],
 |  | double | AI[3][3]
 | ) | [static]

Invert a 3x3 matrix.

void vtkMath::Identity3x3 ( float A[3][3] ) [static]

Set A to the identity matrix.

void vtkMath::Identity3x3 ( double A[3][3] ) [static]

Set A to the identity matrix.

double vtkMath::Determinant3x3 ( float A[3][3] ) [inline, static]

Return the determinant of a 3x3 matrix.

Definition at line 581 of file vtkMath.h.

double vtkMath::Determinant3x3 ( double A[3][3] ) [inline, static]

Return the determinant of a 3x3 matrix.

Definition at line 586 of file vtkMath.h.

float vtkMath::Determinant3x3 | ( | const float | c1[3],
 |  | const float | c2[3],
 |  | const float | c3[3]
 | ) | [inline, static]

Compute determinant of 3x3 matrix. Three columns of matrix are input.

Definition at line 517 of file vtkMath.h.

double vtkMath::Determinant3x3 | ( | double | a1,
 |  | double | a2,
 |  | double | a3,
 |  | double | b1,
 |  | double | b2,
 |  | double | b3,
 |  | double | c1,
 |  | double | c2,
 |  | double | c3
 | ) | [inline, static]

Calculate the determinant of a 3x3 matrix in the form: | a1, b1, c1 | | a2, b2, c2 | | a3, b3, c3 |

Definition at line 525 of file vtkMath.h.

void vtkMath::QuaternionToMatrix3x3 | ( | const float | quat[4],
 |  | float | A[3][3]
 | ) | [static]

Convert a quaternion to a 3x3 rotation matrix. The quaternion does not have to be normalized beforehand.

void vtkMath::QuaternionToMatrix3x3 | ( | const double | quat[4],
 |  | double | A[3][3]
 | ) | [static]

Convert a quaternion to a 3x3 rotation matrix. The quaternion does not have to be normalized beforehand.

void vtkMath::Matrix3x3ToQuaternion | ( | const float | A[3][3],
 |  | float | quat[4]
 | ) | [static]

Convert a 3x3 matrix into a quaternion. This will provide the best possible answer even if the matrix is not a pure rotation matrix. The method used is that of B.K.P. Horn.

void vtkMath::Matrix3x3ToQuaternion | ( | const double | A[3][3],
 |  | double | quat[4]
 | ) | [static]

Convert a 3x3 matrix into a quaternion. This will provide the best possible answer even if the matrix is not a pure rotation matrix. The method used is that of B.K.P. Horn.

void vtkMath::Orthogonalize3x3 | ( | const float | A[3][3],
 |  | float | B[3][3]
 | ) | [static]

Orthogonalize a 3x3 matrix and put the result in B. If matrix A has a negative determinant, then B will be a rotation plus a flip i.e. it will have a determinant of -1.

void vtkMath::Orthogonalize3x3 | ( | const double | A[3][3],
 |  | double | B[3][3]
 | ) | [static]

Orthogonalize a 3x3 matrix and put the result in B. If matrix A has a negative determinant, then B will be a rotation plus a flip i.e. it will have a determinant of -1.

void vtkMath::Diagonalize3x3 | ( | const float | A[3][3],
 |  | float | w[3],
 |  | float | V[3][3]
 | ) | [static]

Diagonalize a symmetric 3x3 matrix and return the eigenvalues in w and the eigenvectors in the columns of V. The matrix V will have a positive determinant, and the three eigenvectors will be aligned as closely as possible with the x, y, and z axes.

void vtkMath::Diagonalize3x3 | ( | const double | A[3][3],
 |  | double | w[3],
 |  | double | V[3][3]
 | ) | [static]

Diagonalize a symmetric 3x3 matrix and return the eigenvalues in w and the eigenvectors in the columns of V. The matrix V will have a positive determinant, and the three eigenvectors will be aligned as closely as possible with the x, y, and z axes.

void vtkMath::SingularValueDecomposition3x3 | ( | const float | A[3][3],
 |  | float | U[3][3],
 |  | float | w[3],
 |  | float | VT[3][3]
 | ) | [static]

Perform singular value decomposition on a 3x3 matrix. This is not done using a conventional SVD algorithm, instead it is done using Orthogonalize3x3 and Diagonalize3x3. Both output matrices U and VT will have positive determinants, and the w values will be arranged such that the three rows of VT are aligned as closely as possible with the x, y, and z axes respectively. If the determinant of A is negative, then the three w values will be negative.

void vtkMath::SingularValueDecomposition3x3 | ( | const double | A[3][3],
 |  | double | U[3][3],
 |  | double | w[3],
 |  | double | VT[3][3]
 | ) | [static]

Perform singular value decomposition on a 3x3 matrix. This is not done using a conventional SVD algorithm, instead it is done using Orthogonalize3x3 and Diagonalize3x3. Both output matrices U and VT will have positive determinants, and the w values will be arranged such that the three rows of VT are aligned as closely as possible with the x, y, and z axes respectively. If the determinant of A is negative, then the three w values will be negative.

int vtkMath::SolveLinearSystem | ( | double ** | A,
 |  | double * | x,
 |  | int | size
 | ) | [static]

Solve linear equations Ax = b using Crout's method. Input is square matrix A and load vector x. Solution x is written over load vector. The dimension of the matrix is specified in size. If error is found, method returns a 0.

int vtkMath::InvertMatrix | ( | double ** | A,
 |  | double ** | AI,
 |  | int | size
 | ) | [static]

Invert input square matrix A into matrix AI. Note that A is modified during the inversion. The size variable is the dimension of the matrix. Returns 0 if inverse not computed.

int vtkMath::InvertMatrix | ( | double ** | A,
 |  | double ** | AI,
 |  | int | size,
 |  | int * | tmp1Size,
 |  | double * | tmp2Size
 | ) | [static]

Thread safe version of InvertMatrix method. Working memory arrays tmp1SIze and tmp2Size of length size must be passed in.

int vtkMath::LUFactorLinearSystem | ( | double ** | A,
 |  | int * | index,
 |  | int | size
 | ) | [static]

Factor linear equations Ax = b using LU decomposition A = LU where L is lower triangular matrix and U is upper triangular matrix. Input is square matrix A, integer array of pivot indices index[0->n-1], and size of square matrix n. Output factorization LU is in matrix A. If error is found, method returns 0.

int vtkMath::LUFactorLinearSystem | ( | double ** | A,
 |  | int * | index,
 |  | int | size,
 |  | double * | tmpSize
 | ) | [static]

Thread safe version of LUFactorLinearSystem method. Working memory array tmpSize of length size must be passed in.

void vtkMath::LUSolveLinearSystem | ( | double ** | A,
 |  | int * | index,
 |  | double * | x,
 |  | int | size
 | ) | [static]

Solve linear equations Ax = b using LU decomposition A = LU where L is lower triangular matrix and U is upper triangular matrix. Input is factored matrix A=LU, integer array of pivot indices index[0->n-1], load vector x[0->n-1], and size of square matrix n. Note that A=LU and index[] are generated from method LUFactorLinearSystem). Also, solution vector is written directly over input load vector.

double vtkMath::EstimateMatrixCondition | ( | double ** | A,
 |  | int | size
 | ) | [static]

Estimate the condition number of a LU factored matrix. Used to judge the accuracy of the solution. The matrix A must have been previously factored using the method LUFactorLinearSystem. The condition number is the ratio of the infinity matrix norm (i.e., maximum value of matrix component) divided by the minimum diagonal value. (This works for triangular matrices only: see Conte and de Boor, Elementary Numerical Analysis.)

void vtkMath::RandomSeed ( long s ) [static]

Initialize seed value. NOTE: Random() has the bad property that the first random number returned after RandomSeed() is called is proportional to the seed value! To help solve this, call RandomSeed() a few times inside seed. This doesn't ruin the repeatability of Random().

float vtkMath::Random ( ) [static]

Generate random numbers between 0.0 and 1.0. This is used to provide portability across different systems.

Referenced by Random().

float vtkMath::Random | ( | float | min,
 |  | float | max
 | ) | [inline, static]

Generate random number between (min,max).

Definition at line 547 of file vtkMath.h.

int vtkMath::Jacobi | ( | float ** | a,
 |  | float * | w,
 |  | float ** | v
 | ) | [static]

Jacobi iteration for the solution of eigenvectors/eigenvalues of a 3x3 real symmetric matrix. Square 3x3 matrix a; output eigenvalues in w; and output eigenvectors in v. Resulting eigenvalues/vectors are sorted in decreasing order; eigenvectors are normalized.

int vtkMath::Jacobi | ( | double ** | a,
 |  | double * | w,
 |  | double ** | v
 | ) | [static]

Jacobi iteration for the solution of eigenvectors/eigenvalues of a 3x3 real symmetric matrix. Square 3x3 matrix a; output eigenvalues in w; and output eigenvectors in v. Resulting eigenvalues/vectors are sorted in decreasing order; eigenvectors are normalized.

int vtkMath::JacobiN | ( | float ** | a,
 |  | int | n,
 |  | float * | w,
 |  | float ** | v
 | ) | [static]

JacobiN iteration for the solution of eigenvectors/eigenvalues of a nxn real symmetric matrix. Square nxn matrix a; size of matrix in n; output eigenvalues in w; and output eigenvectors in v. Resulting eigenvalues/vectors are sorted in decreasing order; eigenvectors are normalized. w and v need to be allocated previously

int vtkMath::JacobiN | ( | double ** | a,
 |  | int | n,
 |  | double * | w,
 |  | double ** | v
 | ) | [static]

JacobiN iteration for the solution of eigenvectors/eigenvalues of a nxn real symmetric matrix. Square nxn matrix a; size of matrix in n; output eigenvalues in w; and output eigenvectors in v. Resulting eigenvalues/vectors are sorted in decreasing order; eigenvectors are normalized. w and v need to be allocated previously

double* vtkMath::SolveCubic | ( | double | c0,
 |  | double | c1,
 |  | double | c2,
 |  | double | c3
 | ) | [static]

Solves a cubic equation c0*t^3 + c1*t^2 + c2*t + c3 = 0 when c0, c1, c2, and c3 are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Return array contains number of (real) roots (counting multiple roots as one) followed by roots themselves. The value in roots[4] is a integer giving further information about the roots (see return codes for int SolveCubic()).

double* vtkMath::SolveQuadratic | ( | double | c0,
 |  | double | c1,
 |  | double | c2
 | ) | [static]

Solves a quadratic equation c1*t^2 + c2*t + c3 = 0 when c1, c2, and c3 are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Return array contains number of (real) roots (counting multiple roots as one) followed by roots themselves. Note that roots[3] contains a return code further describing solution - see documentation for SolveCubic() for meaning of return codes.

double* vtkMath::SolveLinear | ( | double | c0,
 |  | double | c1
 | ) | [static]

Solves a linear equation c2*t + c3 = 0 when c2 and c3 are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Return array contains number of roots followed by roots themselves.

int vtkMath::SolveCubic | ( | double | c0,
 |  | double | c1,
 |  | double | c2,
 |  | double | c3,
 |  | double * | r1,
 |  | double * | r2,
 |  | double * | r3,
 |  | int * | num_roots
 | ) | [static]

Solves a cubic equation when c0, c1, c2, And c3 Are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Roots and number of real roots are stored in user provided variables r1, r2, r3, and num_roots. Note that the function can return the following integer values describing the roots: (0)-no solution; (-1)-infinite number of solutions; (1)-one distinct real root of multiplicity 3 (stored in r1); (2)-two distinct real roots, one of multiplicity 2 (stored in r1 & r2); (3)-three distinct real roots; (-2)-quadratic equation with complex conjugate solution (real part of root returned in r1, imaginary in r2); (-3)-one real root and a complex conjugate pair (real root in r1 and real part of pair in r2 and imaginary in r3).

int vtkMath::SolveQuadratic | ( | double | c0,
 |  | double | c1,
 |  | double | c2,
 |  | double * | r1,
 |  | double * | r2,
 |  | int * | num_roots
 | ) | [static]

Solves A Quadratic Equation c1*t^2 + c2*t + c3 = 0 when c1, c2, and c3 are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Roots and number of roots are stored in user provided variables r1, r2, num_roots

int vtkMath::SolveLinear | ( | double | c0,
 |  | double | c1,
 |  | double * | r1,
 |  | int * | num_roots
 | ) | [static]

Solves a linear equation c2*t + c3 = 0 when c2 and c3 are REAL. Solution is motivated by Numerical Recipes In C 2nd Ed. Root and number of (real) roots are stored in user provided variables r2 and num_roots.

int vtkMath::SolveLeastSquares | ( | int | numberOfSamples,
 |  | double ** | xt,
 |  | int | xOrder,
 |  | double ** | yt,
 |  | int | yOrder,
 |  | double ** | mt
 | ) | [static]

Solves for the least squares best fit matrix for the equation X'M' = Y'. Uses pseudoinverse to get the ordinary least squares. The inputs and output are transposed matrices. Dimensions: X' is numberOfSamples by xOrder, Y' is numberOfSamples by yOrder, M' dimension is xOrder by yOrder. M' should be pre-allocated. All matrices are row major. The resultant matrix M' should be pre-multiplied to X' to get Y', or transposed and then post multiplied to X to get Y

Member Data Documentation

long vtkMath::Seed [static, protected]

Definition at line 460 of file vtkMath.h.

The documentation for this class was generated from the following file:
  • Common/vtkMath.h
Generated on Mon Mar 25 01:23:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


MatProp Struct Reference

#include <vtk3DS.h>

Collaboration diagram for MatProp:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS Colour | ambient
Colour diffuse
Colour specular
float | shininess
float | transparency
float | reflection
int | self_illum
char | tex_map [40]
float | tex_strength
char | bump_map [40]
float | bump_strength
vtkProperty * aProperty

Member Data Documentation

VTK_LIST_FIELDS Colour MatProp::ambient

Definition at line 108 of file vtk3DS.h.

Colour MatProp::diffuse

Definition at line 109 of file vtk3DS.h.

Colour MatProp::specular

Definition at line 110 of file vtk3DS.h.

float MatProp::shininess

Definition at line 111 of file vtk3DS.h.

float MatProp::transparency

Definition at line 112 of file vtk3DS.h.

float MatProp::reflection

Definition at line 113 of file vtk3DS.h.

int MatProp::self_illum

Definition at line 114 of file vtk3DS.h.

char MatProp::tex_map[40]

Definition at line 115 of file vtk3DS.h.

float MatProp::tex_strength

Definition at line 116 of file vtk3DS.h.

char MatProp::bump_map[40]

Definition at line 117 of file vtk3DS.h.

float MatProp::bump_strength

Definition at line 118 of file vtk3DS.h.

vtkProperty* MatProp::aProperty

Definition at line 119 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:23:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrix4x4 Class Reference

represent and manipulate 4x4 transformation matrices. More...

#include <vtkMatrix4x4.h>

Inheritance diagram for vtkMatrix4x4:

[legend]
Collaboration diagram for vtkMatrix4x4:

[legend]
List of all members.

[NOHEADER]

void | Invert ()
void | Invert (vtkMatrix4x4 *in, vtkMatrix4x4 *out)

[NOHEADER]

void | Transpose ()
void | Transpose (vtkMatrix4x4 *in, vtkMatrix4x4 *out)

Public Methods

vtkTypeRevisionMacro (vtkMatrix4x4, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
double | Determinant ()
void | SetElement (int i, int j, double value)
double * | operator[] (const unsigned int i)
const double * | operator[] (unsigned int i) const
void | operator= (double element)
void | Adjoint (vtkMatrix4x4 &in, vtkMatrix4x4 &out)
double | Determinant (vtkMatrix4x4 &in)
double | Determinant (vtkMatrix4x4 *in)
void | Invert (vtkMatrix4x4 &in, vtkMatrix4x4 &out)
void | Transpose (vtkMatrix4x4 &in, vtkMatrix4x4 &out)
void | DeepCopy (vtkMatrix4x4 *source)
void | DeepCopy (const double Elements[16])
void | Zero ()
void | Identity ()
void | MultiplyPoint (const float in[4], float out[4])
void | MultiplyPoint (const double in[4], double out[4])
float * | MultiplyPoint (const float in[4])
float * | MultiplyFloatPoint (const float in[4])
double * | MultiplyDoublePoint (const double in[4])
void | Adjoint (vtkMatrix4x4 *in, vtkMatrix4x4 *out)
double | GetElement (int i, int j) const

Static Public Methods

vtkMatrix4x4 * | New ()
void | DeepCopy (double Elements[16], vtkMatrix4x4 *source)
void | DeepCopy (double Elements[16], const double newElements[16])
void | Zero (double Elements[16])
void | Identity (double Elements[16])
void | Invert (const double inElements[16], double outElements[16])
void | Transpose (const double inElements[16], double outElements[16])
void | MultiplyPoint (const double Elements[16], const float in[4], float out[4])
void | MultiplyPoint (const double Elements[16], const double in[4], double out[4])
void | Multiply4x4 (const double a[16], const double b[16], double c[16])
void | Adjoint (const double inElements[16], double outElements[16])
double | Determinant (const double Elements[16])
void | PointMultiply (const double Elements[16], const float in[4], float out[4])
void | PointMultiply (const double Elements[16], const double in[4], double out[4])
void | Multiply4x4 (vtkMatrix4x4 *a, vtkMatrix4x4 *b, vtkMatrix4x4 *c)

Public Attributes

double | Element [4][4]

Protected Methods

vtkMatrix4x4 ()
~vtkMatrix4x4 ()

Protected Attributes

float | FloatPoint [4]
double | DoublePoint [4]

Detailed Description

represent and manipulate 4x4 transformation matrices.

Date:
2002/01/22 15:25:42
Revision:
1.62

vtkMatrix4x4 is a class to represent and manipulate 4x4 matrices. Specifically, it is designed to work on 4x4 transformation matrices found in 3D rendering using homogeneous coordinates [x y z w].

See also:
vtkTransform
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Gobbi, David (22%)
  • Martin, Ken (18%)
  • Schroeder, Will (16%)
  • Lorensen, Bill (15%)
  • Volpe, Christopher (11%)
Tests:
vtkMatrix4x4 (Tests)

Definition at line 48 of file vtkMatrix4x4.h.

Constructor & Destructor Documentation

vtkMatrix4x4::vtkMatrix4x4 ( ) [inline, protected]

Definition at line 212 of file vtkMatrix4x4.h.

vtkMatrix4x4::~vtkMatrix4x4 ( ) [inline, protected]

Definition at line 213 of file vtkMatrix4x4.h.

Member Function Documentation

vtkMatrix4x4* vtkMatrix4x4::New ( ) [static]

Construct a 4x4 identity matrix.

Reimplemented from vtkObject.

vtkMatrix4x4::vtkTypeRevisionMacro | ( | vtkMatrix4x4 | ,
 |  | vtkObject |
 | ) |

void vtkMatrix4x4::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkMatrix4x4::DeepCopy ( vtkMatrix4x4 * source ) [inline]

Set the elements of the matrix to the same values as the elements of the source Matrix.

Definition at line 71 of file vtkMatrix4x4.h.

Referenced by DeepCopy(), and vtkFollower::GetMatrix().

void vtkMatrix4x4::DeepCopy | ( | double | Elements[16],
 |  | vtkMatrix4x4 * | source
 | ) | [inline, static]

Definition at line 75 of file vtkMatrix4x4.h.

void vtkMatrix4x4::DeepCopy | ( | double | Elements[16],
 |  | const double | newElements[16]
 | ) | [static]

void vtkMatrix4x4::DeepCopy ( const double Elements[16] ) [inline]

Non-static member function. Assigns *from* elements array

Definition at line 82 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Zero ( ) [inline]

Set all of the elements to zero.

Definition at line 88 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Zero ( double Elements[16] ) [static]

void vtkMatrix4x4::Identity ( ) [inline]

Set equal to Identity matrix

Definition at line 97 of file vtkMatrix4x4.h.

Referenced by vtkMatrix4x4().

void vtkMatrix4x4::Identity ( double Elements[16] ) [static]

void vtkMatrix4x4::Invert | ( | vtkMatrix4x4 * | in,
 |  | vtkMatrix4x4 * | out
 | ) | [inline, static]

Matrix Inversion (adapted from Richard Carling in "Graphics Gems," Academic Press, 1990).

Definition at line 107 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Invert ( ) [inline]

Definition at line 109 of file vtkMatrix4x4.h.

Referenced by Invert().

void vtkMatrix4x4::Invert | ( | const double | inElements[16],
 |  | double | outElements[16]
 | ) | [static]

void vtkMatrix4x4::Transpose | ( | vtkMatrix4x4 * | in,
 |  | vtkMatrix4x4 * | out
 | ) | [inline, static]

Transpose the matrix and put it into out.

Definition at line 119 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Transpose ( ) [inline]

Definition at line 121 of file vtkMatrix4x4.h.

Referenced by Transpose().

void vtkMatrix4x4::Transpose | ( | const double | inElements[16],
 |  | double | outElements[16]
 | ) | [static]

void vtkMatrix4x4::MultiplyPoint | ( | const float | in[4],
 |  | float | out[4]
 | ) | [inline]

Multiply a homogeneous coordinate by this matrix, i.e. out = A*in. The in[4] and out[4] can be the same array.

Definition at line 131 of file vtkMatrix4x4.h.

Referenced by MultiplyPoint().

void vtkMatrix4x4::MultiplyPoint | ( | const double | in[4],
 |  | double | out[4]
 | ) | [inline]

Multiply a homogeneous coordinate by this matrix, i.e. out = A*in. The in[4] and out[4] can be the same array.

Definition at line 133 of file vtkMatrix4x4.h.

void vtkMatrix4x4::MultiplyPoint | ( | const double | Elements[16],
 |  | const float | in[4],
 |  | float | out[4]
 | ) | [static]

void vtkMatrix4x4::MultiplyPoint | ( | const double | Elements[16],
 |  | const double | in[4],
 |  | double | out[4]
 | ) | [static]

float* vtkMatrix4x4::MultiplyPoint ( const float in[4] ) [inline]

For use in Java, Python or Tcl. The default MultiplyPoint() uses a single-precision point.

Definition at line 147 of file vtkMatrix4x4.h.

float* vtkMatrix4x4::MultiplyFloatPoint ( const float in[4] ) [inline]

For use in Java, Python or Tcl. The default MultiplyPoint() uses a single-precision point.

Definition at line 149 of file vtkMatrix4x4.h.

double* vtkMatrix4x4::MultiplyDoublePoint ( const double in[4] ) [inline]

For use in Java, Python or Tcl. The default MultiplyPoint() uses a single-precision point.

Definition at line 151 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Multiply4x4 | ( | vtkMatrix4x4 * | a,
 |  | vtkMatrix4x4 * | b,
 |  | vtkMatrix4x4 * | c
 | ) | [inline, static]

Multiplies matrices a and b and stores the result in c.

Definition at line 157 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Multiply4x4 | ( | const double | a[16],
 |  | const double | b[16],
 |  | double | c[16]
 | ) | [static]

void vtkMatrix4x4::Adjoint | ( | vtkMatrix4x4 * | in,
 |  | vtkMatrix4x4 * | out
 | ) | [inline]

Compute adjoint of the matrix and put it into out.

Definition at line 167 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Adjoint | ( | const double | inElements[16],
 |  | double | outElements[16]
 | ) | [static]

double vtkMatrix4x4::Determinant ( ) [inline]

Compute the determinant of the matrix and return it.

Definition at line 175 of file vtkMatrix4x4.h.

Referenced by Determinant().

double vtkMatrix4x4::Determinant ( const double Elements[16] ) [static]

void vtkMatrix4x4::SetElement | ( | int | i,
 |  | int | j,
 |  | double | value
 | ) | [inline]

Sets the element i,j in the matrix.

Definition at line 222 of file vtkMatrix4x4.h.

double vtkMatrix4x4::GetElement | ( | int | i,
 |  | int | j
 | ) | const [inline]

Returns the element i,j from the matrix.

Definition at line 185 of file vtkMatrix4x4.h.

double* vtkMatrix4x4::operator[] ( const unsigned int i ) [inline]

Definition at line 190 of file vtkMatrix4x4.h.

const double* vtkMatrix4x4::operator[] ( unsigned int i ) const [inline]

Definition at line 192 of file vtkMatrix4x4.h.

void vtkMatrix4x4::operator= ( double element )

void vtkMatrix4x4::Adjoint | ( | vtkMatrix4x4 & | in,
 |  | vtkMatrix4x4 & | out
 | ) | [inline]

Definition at line 195 of file vtkMatrix4x4.h.

double vtkMatrix4x4::Determinant ( vtkMatrix4x4 & in ) [inline]

Definition at line 197 of file vtkMatrix4x4.h.

double vtkMatrix4x4::Determinant ( vtkMatrix4x4 * in ) [inline]

Definition at line 199 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Invert | ( | vtkMatrix4x4 & | in,
 |  | vtkMatrix4x4 & | out
 | ) | [inline]

Definition at line 201 of file vtkMatrix4x4.h.

void vtkMatrix4x4::Transpose | ( | vtkMatrix4x4 & | in,
 |  | vtkMatrix4x4 & | out
 | ) | [inline]

Definition at line 203 of file vtkMatrix4x4.h.

void vtkMatrix4x4::PointMultiply | ( | const double | Elements[16],
 |  | const float | in[4],
 |  | float | out[4]
 | ) | [static]

void vtkMatrix4x4::PointMultiply | ( | const double | Elements[16],
 |  | const double | in[4],
 |  | double | out[4]
 | ) | [static]

Member Data Documentation

double vtkMatrix4x4::Element[4][4]

Definition at line 60 of file vtkMatrix4x4.h.

Referenced by Adjoint(), vtkTransform::Concatenate(), vtkPerspectiveTransform::Concatenate(), vtkGeneralTransform::Concatenate(), DeepCopy(), Determinant(), Invert(), Multiply4x4(), vtkTransform::SetMatrix(), vtkPerspectiveTransform::SetMatrix(), and Transpose().

float vtkMatrix4x4::FloatPoint[4] [protected]

Definition at line 215 of file vtkMatrix4x4.h.

double vtkMatrix4x4::DoublePoint[4] [protected]

Definition at line 216 of file vtkMatrix4x4.h.

The documentation for this class was generated from the following file:
  • Common/vtkMatrix4x4.h
Generated on Mon Mar 25 01:23:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrixToHomogeneousTransform Class Reference

convert a matrix to a transform. More...

#include <vtkMatrixToHomogeneousTransform.h>

Inheritance diagram for vtkMatrixToHomogeneousTransform:

[legend]
Collaboration diagram for vtkMatrixToHomogeneousTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMatrixToHomogeneousTransform, vtkHomogeneousTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInput (vtkMatrix4x4 *)
virtual vtkMatrix4x4 * | GetInput ()
void | Inverse ()
unsigned long | GetMTime ()
vtkAbstractTransform * MakeTransform ()
void | SetMatrix (vtkMatrix4x4 *matrix)

Static Public Methods

vtkMatrixToHomogeneousTransform * | New ()

Protected Methods

vtkMatrixToHomogeneousTransform ()
~vtkMatrixToHomogeneousTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)

Protected Attributes

int | InverseFlag
vtkMatrix4x4 * Input

Detailed Description

convert a matrix to a transform.

Date:
2002/01/22 15:25:43
Revision:
1.7

This is a very simple class which allows a vtkMatrix4x4 to be used in place of a vtkHomogeneousTransform or vtkAbstractTransform. For example, if you use it as a proxy between a matrix and vtkTransformPolyDataFilter then any modifications to the matrix will automatically be reflected in the output of the filter.

See also:
vtkPerspectiveTransform vtkMatrix4x4 vtkMatrixToLinearTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)
Tests:
vtkMatrixToHomogeneousTransform (Tests)

Definition at line 47 of file vtkMatrixToHomogeneousTransform.h.

Constructor & Destructor Documentation

vtkMatrixToHomogeneousTransform::vtkMatrixToHomogeneousTransform ( ) [protected]

vtkMatrixToHomogeneousTransform::~vtkMatrixToHomogeneousTransform ( ) [protected]

Member Function Documentation

vtkMatrixToHomogeneousTransform* vtkMatrixToHomogeneousTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkMatrixToHomogeneousTransform::vtkTypeRevisionMacro | ( | vtkMatrixToHomogeneousTransform | ,
 |  | vtkHomogeneousTransform |
 | ) |

Reimplemented from vtkHomogeneousTransform.

void vtkMatrixToHomogeneousTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkHomogeneousTransform.

virtual void vtkMatrixToHomogeneousTransform::SetInput ( vtkMatrix4x4 * ) [virtual]

virtual vtkMatrix4x4* vtkMatrixToHomogeneousTransform::GetInput ( ) [virtual]

void vtkMatrixToHomogeneousTransform::Inverse ( ) [virtual]

The input matrix is left as-is, but the transformation matrix is inverted.

Reimplemented from vtkAbstractTransform.

unsigned long vtkMatrixToHomogeneousTransform::GetMTime ( ) [virtual]

Get the MTime: this is the bit of magic that makes everything work.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkMatrixToHomogeneousTransform::MakeTransform ( ) [virtual]

Make a new transform of the same type.

Reimplemented from vtkAbstractTransform.

void vtkMatrixToHomogeneousTransform::SetMatrix ( vtkMatrix4x4 * matrix ) [inline]

This method is deprecated.

Definition at line 72 of file vtkMatrixToHomogeneousTransform.h.

void vtkMatrixToHomogeneousTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

void vtkMatrixToHomogeneousTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkHomogeneousTransform.

Member Data Documentation

int vtkMatrixToHomogeneousTransform::InverseFlag [protected]

Definition at line 84 of file vtkMatrixToHomogeneousTransform.h.

vtkMatrix4x4* vtkMatrixToHomogeneousTransform::Input [protected]

Definition at line 85 of file vtkMatrixToHomogeneousTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkMatrixToHomogeneousTransform.h
Generated on Mon Mar 25 01:23:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMatrixToLinearTransform Class Reference

convert a matrix to a transform. More...

#include <vtkMatrixToLinearTransform.h>

Inheritance diagram for vtkMatrixToLinearTransform:

[legend]
Collaboration diagram for vtkMatrixToLinearTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMatrixToLinearTransform, vtkLinearTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Inverse ()
unsigned long | GetMTime ()
vtkAbstractTransform * MakeTransform ()
virtual void | SetInput (vtkMatrix4x4 *)
virtual vtkMatrix4x4 * | GetInput ()
void | SetMatrix (vtkMatrix4x4 *matrix)

Static Public Methods

vtkMatrixToLinearTransform * | New ()

Protected Methods

vtkMatrixToLinearTransform ()
~vtkMatrixToLinearTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)

Protected Attributes

int | InverseFlag
vtkMatrix4x4 * Input

Detailed Description

convert a matrix to a transform.

Date:
2002/01/22 15:25:44
Revision:
1.15

This is a very simple class which allows a vtkMatrix4x4 to be used in place of a vtkLinearTransform or vtkAbstractTransform. For example, if you use it as a proxy between a matrix and vtkTransformPolyDataFilter then any modifications to the matrix will automatically be reflected in the output of the filter.

See also:
vtkTransform vtkMatrix4x4 vtkMatrixToHomogeneousTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)
Tests:
vtkMatrixToLinearTransform (Tests)

Definition at line 47 of file vtkMatrixToLinearTransform.h.

Constructor & Destructor Documentation

vtkMatrixToLinearTransform::vtkMatrixToLinearTransform ( ) [protected]

vtkMatrixToLinearTransform::~vtkMatrixToLinearTransform ( ) [protected]

Member Function Documentation

vtkMatrixToLinearTransform* vtkMatrixToLinearTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkMatrixToLinearTransform::vtkTypeRevisionMacro | ( | vtkMatrixToLinearTransform | ,
 |  | vtkLinearTransform |
 | ) |

Reimplemented from vtkLinearTransform.

void vtkMatrixToLinearTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearTransform.

virtual void vtkMatrixToLinearTransform::SetInput ( vtkMatrix4x4 * ) [virtual]

Set the input matrix. Any modifications to the matrix will be reflected in the transformation.

virtual vtkMatrix4x4* vtkMatrixToLinearTransform::GetInput ( ) [virtual]

Set the input matrix. Any modifications to the matrix will be reflected in the transformation.

void vtkMatrixToLinearTransform::Inverse ( ) [virtual]

The input matrix is left as-is, but the transformation matrix is inverted.

Reimplemented from vtkAbstractTransform.

unsigned long vtkMatrixToLinearTransform::GetMTime ( ) [virtual]

Get the MTime: this is the bit of magic that makes everything work.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkMatrixToLinearTransform::MakeTransform ( ) [virtual]

Make a new transform of the same type.

Reimplemented from vtkAbstractTransform.

void vtkMatrixToLinearTransform::SetMatrix ( vtkMatrix4x4 * matrix ) [inline]

This method is deprecated.

Definition at line 73 of file vtkMatrixToLinearTransform.h.

void vtkMatrixToLinearTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

void vtkMatrixToLinearTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkHomogeneousTransform.

Member Data Documentation

int vtkMatrixToLinearTransform::InverseFlag [protected]

Definition at line 85 of file vtkMatrixToLinearTransform.h.

vtkMatrix4x4* vtkMatrixToLinearTransform::Input [protected]

Definition at line 86 of file vtkMatrixToLinearTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkMatrixToLinearTransform.h
Generated on Mon Mar 25 01:23:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMCubesReader Class Reference

read binary marching cubes file. More...

#include <vtkMCubesReader.h>

Inheritance diagram for vtkMCubesReader:

[legend]
Collaboration diagram for vtkMCubesReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMCubesReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | CreateDefaultLocator ()
unsigned long | GetMTime ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetLimitsFileName (const char *)
virtual char * | GetLimitsFileName ()
virtual void | SetHeaderSize (int)
virtual int | GetHeaderSize ()
virtual void | SetFlipNormals (int)
virtual int | GetFlipNormals ()
virtual void | FlipNormalsOn ()
virtual void | FlipNormalsOff ()
virtual void | SetNormals (int)
virtual int | GetNormals ()
virtual void | NormalsOn ()
virtual void | NormalsOff ()
void | SetDataByteOrderToBigEndian ()
void | SetDataByteOrderToLittleEndian ()
int | GetDataByteOrder ()
void | SetDataByteOrder (int)
const char * | GetDataByteOrderAsString ()
virtual void | SetSwapBytes (int)
virtual int | GetSwapBytes ()
virtual void | SwapBytesOn ()
virtual void | SwapBytesOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkMCubesReader * | New ()

Protected Methods

vtkMCubesReader ()
~vtkMCubesReader ()
void | Execute ()

Protected Attributes

char * | FileName
char * | LimitsFileName
vtkPointLocator * Locator
int | SwapBytes
int | HeaderSize
int | FlipNormals
int | Normals

Detailed Description

read binary marching cubes file.

Date:
2002/01/22 15:38:16
Revision:
1.51

vtkMCubesReader is a source object that reads binary marching cubes files. (Marching cubes is an isosurfacing technique that generates many triangles.) The binary format is supported by W. Lorensen's marching cubes program (and the vtkSliceCubes object). The format repeats point coordinates, so this object will merge the points with a vtkLocator object. You can choose to supply the vtkLocator or use the default.

Warning:
Binary files assumed written in sun/hp/sgi (i.e., Big Endian) form.
Warning:
Because points are merged when read, degenerate triangles may be removed. Thus the number of triangles read may be fewer than the number of triangles actually created.
Warning:
The point merging does not take into account that the same point may have different normals. For example, running vtkPolyDataNormals after vtkContourFilter may split triangles because of the FeatureAngle ivar. Subsequent reading with vtkMCubesReader will merge the points and use the first point's normal. For the most part, this is undesirable.
Warning:
Normals are generated from the gradient of the data scalar values. Hence the normals may on occasion point in a direction inconsistent with the ordering of the triangle vertices. If this happens, the resulting surface may be "black". Reverse the sense of the FlipNormals boolean flag to correct this.
See also:
vtkContourFilter vtkMarchingCubes vtkSliceCubes vtkLocator
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (47%)
  • Lorensen, Bill (23%)
  • Martin, Ken (14%)
  • Law, Charles (7%)
Tests:
vtkMCubesReader (Tests)

Definition at line 79 of file vtkMCubesReader.h.

Constructor & Destructor Documentation

vtkMCubesReader::vtkMCubesReader ( ) [protected]

vtkMCubesReader::~vtkMCubesReader ( ) [protected]

Member Function Documentation

vtkMCubesReader::vtkTypeRevisionMacro | ( | vtkMCubesReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkMCubesReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkMCubesReader* vtkMCubesReader::New ( ) [static]

Construct object with FlipNormals turned off and Normals set to true.

Reimplemented from vtkPolyDataSource.

virtual void vtkMCubesReader::SetFileName ( const char * ) [virtual]

Specify file name of marching cubes file.

virtual char* vtkMCubesReader::GetFileName ( ) [virtual]

Specify file name of marching cubes file.

virtual void vtkMCubesReader::SetLimitsFileName ( const char * ) [virtual]

Set / get the file name of the marching cubes limits file.

virtual char* vtkMCubesReader::GetLimitsFileName ( ) [virtual]

Set / get the file name of the marching cubes limits file.

virtual void vtkMCubesReader::SetHeaderSize ( int ) [virtual]

Specify a header size if one exists. The header is skipped and not used at this time.

virtual int vtkMCubesReader::GetHeaderSize ( ) [virtual]

Specify a header size if one exists. The header is skipped and not used at this time.

virtual void vtkMCubesReader::SetFlipNormals ( int ) [virtual]

Specify whether to flip normals in opposite direction. Flipping ONLY changes the direction of the normal vector. Contrast this with flipping in vtkPolyDataNormals which flips both the normal and the cell point order.

virtual int vtkMCubesReader::GetFlipNormals ( ) [virtual]

Specify whether to flip normals in opposite direction. Flipping ONLY changes the direction of the normal vector. Contrast this with flipping in vtkPolyDataNormals which flips both the normal and the cell point order.

virtual void vtkMCubesReader::FlipNormalsOn ( ) [virtual]

Specify whether to flip normals in opposite direction. Flipping ONLY changes the direction of the normal vector. Contrast this with flipping in vtkPolyDataNormals which flips both the normal and the cell point order.

virtual void vtkMCubesReader::FlipNormalsOff ( ) [virtual]

Specify whether to flip normals in opposite direction. Flipping ONLY changes the direction of the normal vector. Contrast this with flipping in vtkPolyDataNormals which flips both the normal and the cell point order.

virtual void vtkMCubesReader::SetNormals ( int ) [virtual]

Specify whether to read normals.

virtual int vtkMCubesReader::GetNormals ( ) [virtual]

Specify whether to read normals.

virtual void vtkMCubesReader::NormalsOn ( ) [virtual]

Specify whether to read normals.

virtual void vtkMCubesReader::NormalsOff ( ) [virtual]

Specify whether to read normals.

void vtkMCubesReader::SetDataByteOrderToBigEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkMCubesReader::SetDataByteOrderToLittleEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

int vtkMCubesReader::GetDataByteOrder ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkMCubesReader::SetDataByteOrder ( int )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

const char* vtkMCubesReader::GetDataByteOrderAsString ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

virtual void vtkMCubesReader::SetSwapBytes ( int ) [virtual]

Turn on/off byte swapping.

virtual int vtkMCubesReader::GetSwapBytes ( ) [virtual]

Turn on/off byte swapping.

virtual void vtkMCubesReader::SwapBytesOn ( ) [virtual]

Turn on/off byte swapping.

virtual void vtkMCubesReader::SwapBytesOff ( ) [virtual]

Turn on/off byte swapping.

void vtkMCubesReader::SetLocator ( vtkPointLocator * locator )

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkMCubesReader::GetLocator ( ) [virtual]

Set / get a spatial locator for merging points. By default, an instance of vtkMergePoints is used.

void vtkMCubesReader::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

unsigned long vtkMCubesReader::GetMTime ( ) [virtual]

Return the mtime also considering the locator.

Reimplemented from vtkObject.

void vtkMCubesReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkMCubesReader::FileName [protected]

Definition at line 168 of file vtkMCubesReader.h.

char* vtkMCubesReader::LimitsFileName [protected]

Definition at line 169 of file vtkMCubesReader.h.

vtkPointLocator* vtkMCubesReader::Locator [protected]

Definition at line 170 of file vtkMCubesReader.h.

int vtkMCubesReader::SwapBytes [protected]

Definition at line 171 of file vtkMCubesReader.h.

int vtkMCubesReader::HeaderSize [protected]

Definition at line 172 of file vtkMCubesReader.h.

int vtkMCubesReader::FlipNormals [protected]

Definition at line 173 of file vtkMCubesReader.h.

int vtkMCubesReader::Normals [protected]

Definition at line 174 of file vtkMCubesReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkMCubesReader.h
Generated on Mon Mar 25 01:23:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMCubesWriter Class Reference

write binary marching cubes file. More...

#include <vtkMCubesWriter.h>

Inheritance diagram for vtkMCubesWriter:

[legend]
Collaboration diagram for vtkMCubesWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMCubesWriter, vtkPolyDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetLimitsFileName (const char *)
virtual char * | GetLimitsFileName ()

Static Public Methods

vtkMCubesWriter * | New ()

Protected Methods

vtkMCubesWriter ()
~vtkMCubesWriter ()
void | WriteData ()

Protected Attributes

char * | LimitsFileName

Detailed Description

write binary marching cubes file.

Date:
2002/01/22 15:38:16
Revision:
1.31

vtkMCubesWriter is a polydata writer that writes binary marching cubes files. (Marching cubes is an isosurfacing technique that generates many triangles.) The binary format is supported by W. Lorensen's marching cubes program (and the vtkSliceCubes object). Each triangle is represented by three records, with each record consisting of six single precision floating point numbers representing the a triangle vertex coordinate and vertex normal.

Warning:
Binary files are written in sun/hp/sgi (i.e., Big Endian) form.
See also:
vtkMarchingCubes vtkSliceCubes vtkMCubesReader
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (63%)
  • Schroeder, Will (17%)
  • Martin, Ken (10%)
Tests:
vtkMCubesWriter (Tests)

Definition at line 54 of file vtkMCubesWriter.h.

Constructor & Destructor Documentation

vtkMCubesWriter::vtkMCubesWriter ( ) [protected]

vtkMCubesWriter::~vtkMCubesWriter ( ) [protected]

Member Function Documentation

vtkMCubesWriter* vtkMCubesWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkPolyDataWriter.

vtkMCubesWriter::vtkTypeRevisionMacro | ( | vtkMCubesWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkMCubesWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPolyDataWriter.

virtual void vtkMCubesWriter::SetLimitsFileName ( const char * ) [virtual]

Set/get file name of marching cubes limits file.

virtual char* vtkMCubesWriter::GetLimitsFileName ( ) [virtual]

Set/get file name of marching cubes limits file.

void vtkMCubesWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

Member Data Documentation

char* vtkMCubesWriter::LimitsFileName [protected]

Definition at line 72 of file vtkMCubesWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkMCubesWriter.h
Generated on Mon Mar 25 01:23:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMedicalImageReader2 Class Reference

vtkImageReader2 with medical meta data. More...

#include <vtkMedicalImageReader2.h>

Inheritance diagram for vtkMedicalImageReader2:

[legend]
Collaboration diagram for vtkMedicalImageReader2:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMedicalImageReader2, vtkImageReader2)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPatientName (const char *)
virtual char * | GetPatientName ()
virtual void | SetPatientID (const char *)
virtual char * | GetPatientID ()
virtual void | SetDate (const char *)
virtual char * | GetDate ()
virtual void | SetSeries (const char *)
virtual char * | GetSeries ()
virtual void | SetStudy (const char *)
virtual char * | GetStudy ()
virtual void | SetImageNumber (const char *)
virtual char * | GetImageNumber ()

Static Public Methods

vtkMedicalImageReader2 * | New ()

Protected Methods

vtkMedicalImageReader2 ()
~vtkMedicalImageReader2 ()

Protected Attributes

char * | PatientName
char * | PatientID
char * | Date
char * | ImageNumber
char * | Study
char * | Series

Detailed Description

vtkImageReader2 with medical meta data.

Date:
2002/01/22 15:38:17
Revision:
1.2

vtkMedicalImageReader2 is a parent class for medical image readers. It provides a place to store patient information that may be stored in the image header.

See also:
vtkImageReader2 vtkGESignaReader
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (100%)

Definition at line 42 of file vtkMedicalImageReader2.h.

Constructor & Destructor Documentation

vtkMedicalImageReader2::vtkMedicalImageReader2 ( ) [protected]

vtkMedicalImageReader2::~vtkMedicalImageReader2 ( ) [protected]

Member Function Documentation

vtkMedicalImageReader2* vtkMedicalImageReader2::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Reimplemented in vtkGESignaReader.

vtkMedicalImageReader2::vtkTypeRevisionMacro | ( | vtkMedicalImageReader2 | ,
 |  | vtkImageReader2 |
 | ) |

Reimplemented from vtkImageReader2.

Reimplemented in vtkGESignaReader.

void vtkMedicalImageReader2::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageReader2.

virtual void vtkMedicalImageReader2::SetPatientName ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetPatientName ( ) [virtual]

Methods to set/get the patient information data.

virtual void vtkMedicalImageReader2::SetPatientID ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetPatientID ( ) [virtual]

Methods to set/get the patient information data.

virtual void vtkMedicalImageReader2::SetDate ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetDate ( ) [virtual]

Methods to set/get the patient information data.

virtual void vtkMedicalImageReader2::SetSeries ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetSeries ( ) [virtual]

Methods to set/get the patient information data.

virtual void vtkMedicalImageReader2::SetStudy ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetStudy ( ) [virtual]

Methods to set/get the patient information data.

virtual void vtkMedicalImageReader2::SetImageNumber ( const char * ) [virtual]

Methods to set/get the patient information data.

virtual char* vtkMedicalImageReader2::GetImageNumber ( ) [virtual]

Methods to set/get the patient information data.

Member Data Documentation

char* vtkMedicalImageReader2::PatientName [protected]

Definition at line 70 of file vtkMedicalImageReader2.h.

char* vtkMedicalImageReader2::PatientID [protected]

Definition at line 71 of file vtkMedicalImageReader2.h.

char* vtkMedicalImageReader2::Date [protected]

Definition at line 72 of file vtkMedicalImageReader2.h.

char* vtkMedicalImageReader2::ImageNumber [protected]

Definition at line 73 of file vtkMedicalImageReader2.h.

char* vtkMedicalImageReader2::Study [protected]

Definition at line 74 of file vtkMedicalImageReader2.h.

char* vtkMedicalImageReader2::Series [protected]

Definition at line 75 of file vtkMedicalImageReader2.h.

The documentation for this class was generated from the following file:
  • IO/vtkMedicalImageReader2.h
Generated on Mon Mar 25 01:23:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMemoryLimitImageDataStreamer Class Reference

#include <vtkMemoryLimitImageDataStreamer.h>

Inheritance diagram for vtkMemoryLimitImageDataStreamer:

[legend]
Collaboration diagram for vtkMemoryLimitImageDataStreamer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMemoryLimitImageDataStreamer, vtkImageDataStreamer)
void | PrintSelf (ostream &os, vtkIndent indent)
void | UpdateData (vtkDataObject *out)
virtual void | SetMemoryLimit (unsigned long)
virtual unsigned long | GetMemoryLimit ()

Static Public Methods

vtkMemoryLimitImageDataStreamer * | New ()

Protected Methods

vtkMemoryLimitImageDataStreamer ()
~vtkMemoryLimitImageDataStreamer ()

Protected Attributes

unsigned long | MemoryLimit

Constructor & Destructor Documentation

vtkMemoryLimitImageDataStreamer::vtkMemoryLimitImageDataStreamer ( ) [protected]

vtkMemoryLimitImageDataStreamer::~vtkMemoryLimitImageDataStreamer ( ) [inline, protected]

Definition at line 57 of file vtkMemoryLimitImageDataStreamer.h.

Member Function Documentation

vtkMemoryLimitImageDataStreamer* vtkMemoryLimitImageDataStreamer::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageDataStreamer.

vtkMemoryLimitImageDataStreamer::vtkTypeRevisionMacro | ( | vtkMemoryLimitImageDataStreamer | ,
 |  | vtkImageDataStreamer |
 | ) |

Reimplemented from vtkImageDataStreamer.

void vtkMemoryLimitImageDataStreamer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageDataStreamer.

virtual void vtkMemoryLimitImageDataStreamer::SetMemoryLimit ( unsigned long ) [virtual]

Set / Get the memory limit in kilobytes.

virtual unsigned long vtkMemoryLimitImageDataStreamer::GetMemoryLimit ( ) [virtual]

Set / Get the memory limit in kilobytes.

void vtkMemoryLimitImageDataStreamer::UpdateData ( vtkDataObject * out ) [virtual]

Need to override since this is where streaming will be done

Reimplemented from vtkImageDataStreamer.

Member Data Documentation

unsigned long vtkMemoryLimitImageDataStreamer::MemoryLimit [protected]

Definition at line 59 of file vtkMemoryLimitImageDataStreamer.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMemoryLimitImageDataStreamer.h
Generated on Mon Mar 25 01:23:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeDataObjectFilter Class Reference

merge dataset and data object field to create dataset with attribute data. More...

#include <vtkMergeDataObjectFilter.h>

Inheritance diagram for vtkMergeDataObjectFilter:

[legend]
Collaboration diagram for vtkMergeDataObjectFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMergeDataObjectFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetDataObject (vtkDataObject *object)
vtkDataObject * GetDataObject ()
virtual void | SetOutputField (int)
virtual int | GetOutputField ()
void | SetOutputFieldToDataObjectField ()
void | SetOutputFieldToPointDataField ()
void | SetOutputFieldToCellDataField ()

Static Public Methods

vtkMergeDataObjectFilter * | New ()

Protected Methods

vtkMergeDataObjectFilter ()
~vtkMergeDataObjectFilter ()
void | Execute ()

Protected Attributes

int | OutputField

Detailed Description

merge dataset and data object field to create dataset with attribute data.

Date:
2002/01/22 15:29:30
Revision:
1.17

vtkMergeDataObjectFilter is a filter that merges the field from a vtkDataObject with a vtkDataSet. The resulting combined dataset can then be processed by other filters (e.g., vtkFieldDataToAttributeDataFilter) to create attribute data like scalars, vectors, etc.

The filter operates as follows. The field data from the vtkDataObject is merged with the input's vtkDataSet and then placed in the output. You can choose to place the field data into the cell data field, the point data field, or the datasets field (i.e., the one inherited from vtkDataSet's superclass vtkDataObject). All this data shuffling occurs via reference counting, therefore memory is not copied.

One of the uses of this filter is to allow you to read/generate the structure of a dataset independent of the attributes. So, for example, you could store the dataset geometry/topology in one file, and field data in another. Then use this filter in combination with vtkFieldDataToAttributeData to create a dataset ready for processing in the visualization pipeline.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (86%)
  • Lorensen, Bill (6%)
  • Geveci, Berk (5%)

Definition at line 56 of file vtkMergeDataObjectFilter.h.

Constructor & Destructor Documentation

vtkMergeDataObjectFilter::vtkMergeDataObjectFilter ( ) [protected]

vtkMergeDataObjectFilter::~vtkMergeDataObjectFilter ( ) [protected]

Member Function Documentation

vtkMergeDataObjectFilter* vtkMergeDataObjectFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkMergeDataObjectFilter::vtkTypeRevisionMacro | ( | vtkMergeDataObjectFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkMergeDataObjectFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkMergeDataObjectFilter::SetDataObject ( vtkDataObject * object )

Specify the data object to merge with the input dataset.

vtkDataObject* vtkMergeDataObjectFilter::GetDataObject ( )

Specify the data object to merge with the input dataset.

virtual void vtkMergeDataObjectFilter::SetOutputField ( int ) [virtual]

Specify where to place the field data during the merge process. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

virtual int vtkMergeDataObjectFilter::GetOutputField ( ) [virtual]

Specify where to place the field data during the merge process. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

void vtkMergeDataObjectFilter::SetOutputFieldToDataObjectField ( ) [inline]

Specify where to place the field data during the merge process. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 76 of file vtkMergeDataObjectFilter.h.

void vtkMergeDataObjectFilter::SetOutputFieldToPointDataField ( ) [inline]

Specify where to place the field data during the merge process. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 78 of file vtkMergeDataObjectFilter.h.

void vtkMergeDataObjectFilter::SetOutputFieldToCellDataField ( ) [inline]

Specify where to place the field data during the merge process. There are three choices: the field data associated with the vtkDataObject superclass; the point field attribute data; and the cell field attribute data.

Definition at line 80 of file vtkMergeDataObjectFilter.h.

void vtkMergeDataObjectFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkMergeDataObjectFilter::OutputField [protected]

Definition at line 91 of file vtkMergeDataObjectFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMergeDataObjectFilter.h
Generated on Mon Mar 25 01:23:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeFields Class Reference

Merge multiple fields into one. More...

#include <vtkMergeFields.h>

Inheritance diagram for vtkMergeFields:

[legend]
Collaboration diagram for vtkMergeFields:

[legend]
List of all members.

Public Types

enum | FieldLocations { DATA_OBJECT = 0, POINT_DATA = 1, CELL_DATA = 2 }

Public Methods

vtkTypeRevisionMacro (vtkMergeFields, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOutputField (const char *name, int fieldLoc)
void | SetOutputField (const char *name, const char *fieldLoc)
void | Merge (int component, const char *arrayName, int sourceComp)
virtual void | SetNumberOfComponents (int)

Static Public Methods

vtkMergeFields * | New ()

Protected Types

enum | FieldType { NAME, ATTRIBUTE }

Protected Methods

vtkMergeFields ()
virtual | ~vtkMergeFields ()
void | Execute ()
int | MergeArray (vtkDataArray *in, vtkDataArray *out, int inComp, int outComp)
Component * | GetNextComponent (Component *op)
Component * GetFirst ()
void | AddComponent (Component *op)
Component * | FindComponent (int index)
void | DeleteAllComponents ()
void | PrintComponent (Component *op, ostream &os, vtkIndent indent)
void | PrintAllComponents (ostream &os, vtkIndent indent)

Protected Attributes

char * | FieldName
int | FieldLocation
int | NumberOfComponents
int | OutputDataType
Component * Head
Component * Tail

Static Protected Attributes

char | FieldLocationNames [3][12]

Detailed Description

Merge multiple fields into one.

Date:
2002/01/22 15:29:30
Revision:
1.8

vtkMergeFields is used to merge mutliple field into one. The new field is put in the same field data as the original field. For example

 mf->SetOutputField("foo", vtkMergeFields::POINT_DATA);
 mf->SetNumberOfComponents(2);
 mf->Merge(0, "array1", 1);
 mf->Merge(1, "array2", 0);
will tell vtkMergeFields to use the 2nd component of array1 and the 1st component of array2 to create a 2 component field called foo. The same can be done using Tcl:
 mf SetOutputField foo POINT_DATA
 mf Merge 0 array1 1
 mf Merge 1 array2 0

 Field locations: DATA_OBJECT, POINT_DATA, CELL_DATA

See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray vtkRearrangeFields vtkSplitField vtkAssignAttribute
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (92%)
Tests:
vtkMergeFields (Tests)

Definition at line 64 of file vtkMergeFields.h.

Member Enumeration Documentation

enum vtkMergeFields::FieldLocations

Enumeration values:
DATA_OBJECT
POINT_DATA
CELL_DATA

Definition at line 92 of file vtkMergeFields.h.

enum vtkMergeFields::FieldType [protected]

Enumeration values:
NAME
ATTRIBUTE

Definition at line 125 of file vtkMergeFields.h.

Constructor & Destructor Documentation

vtkMergeFields::vtkMergeFields ( ) [protected]

virtual vtkMergeFields::~vtkMergeFields ( ) [protected, virtual]

Member Function Documentation

vtkMergeFields::vtkTypeRevisionMacro | ( | vtkMergeFields | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkMergeFields::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkMergeFields* vtkMergeFields::New ( ) [static]

Create a new vtkMergeFields.

Reimplemented from vtkDataSetSource.

void vtkMergeFields::SetOutputField | ( | const char * | name,
 |  | int | fieldLoc
 | ) |

The output field will have the given name and it will be in fieldLoc (the input fields also have to be in fieldLoc).

void vtkMergeFields::SetOutputField | ( | const char * | name,
 |  | const char * | fieldLoc
 | ) |

Helper method used by the other language bindings. Allows the caller to specify arguments as strings instead of enums.Returns an operation id which can later be used to remove the operation.

void vtkMergeFields::Merge | ( | int | component,
 |  | const char * | arrayName,
 |  | int | sourceComp
 | ) |

Add a component (arrayName,sourceComp) to the output field.

virtual void vtkMergeFields::SetNumberOfComponents ( int ) [virtual]

Set the number of the components in the output field. This has to be set before execution. Default value is 0.

void vtkMergeFields::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkMergeFields::MergeArray | ( | vtkDataArray * | in,
 |  | vtkDataArray * | out,
 |  | int | inComp,
 |  | int | outComp
 | ) | [protected]

Component* vtkMergeFields::GetNextComponent ( Component * op ) [inline, protected]

Definition at line 152 of file vtkMergeFields.h.

Component* vtkMergeFields::GetFirst ( ) [inline, protected]

Definition at line 154 of file vtkMergeFields.h.

void vtkMergeFields::AddComponent ( Component * op ) [protected]

Component* vtkMergeFields::FindComponent ( int index ) [protected]

void vtkMergeFields::DeleteAllComponents ( ) [protected]

void vtkMergeFields::PrintComponent | ( | Component * | op,
 |  | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 160 of file vtkMergeFields.h.

void vtkMergeFields::PrintAllComponents | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 167 of file vtkMergeFields.h.

Member Data Documentation

char* vtkMergeFields::FieldName [protected]

Definition at line 137 of file vtkMergeFields.h.

int vtkMergeFields::FieldLocation [protected]

Definition at line 138 of file vtkMergeFields.h.

int vtkMergeFields::NumberOfComponents [protected]

Definition at line 139 of file vtkMergeFields.h.

int vtkMergeFields::OutputDataType [protected]

Definition at line 140 of file vtkMergeFields.h.

char vtkMergeFields::FieldLocationNames[3][12] [static, protected]

Definition at line 142 of file vtkMergeFields.h.

Component* vtkMergeFields::Head [protected]

Definition at line 148 of file vtkMergeFields.h.

Component* vtkMergeFields::Tail [protected]

Definition at line 149 of file vtkMergeFields.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMergeFields.h
Generated on Mon Mar 25 01:23:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeFields::Component Struct Reference

#include <vtkMergeFields.h>

Collaboration diagram for vtkMergeFields::Component:

[legend]
List of all members.

Public Methods

void | SetName (const char *name)
Component ()
~Component ()

Public Attributes

int | Index
int | SourceIndex
char * | FieldName
Component * | Next

Constructor & Destructor Documentation

vtkMergeFields::Component::Component ( ) [inline]

Definition at line 117 of file vtkMergeFields.h.

vtkMergeFields::Component::~Component ( ) [inline]

Definition at line 118 of file vtkMergeFields.h.

Member Function Documentation

void vtkMergeFields::Component::SetName ( const char * name ) [inline]

Definition at line 107 of file vtkMergeFields.h.

Member Data Documentation

int vtkMergeFields::Component::Index

Definition at line 103 of file vtkMergeFields.h.

int vtkMergeFields::Component::SourceIndex

Definition at line 104 of file vtkMergeFields.h.

char* vtkMergeFields::Component::FieldName

Definition at line 105 of file vtkMergeFields.h.

Component* vtkMergeFields::Component::Next

Definition at line 106 of file vtkMergeFields.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkMergeFields.h
Generated on Mon Mar 25 01:23:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergeFilter Class Reference

extract separate components of data from different datasets. More...

#include <vtkMergeFilter.h>

Inheritance diagram for vtkMergeFilter:

[legend]
Collaboration diagram for vtkMergeFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMergeFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddField (const char *name, vtkDataSet *input)
void | SetGeometry (vtkDataSet *input)
vtkDataSet * GetGeometry ()
void | SetScalars (vtkDataSet *)
vtkDataSet * GetScalars ()
void | SetVectors (vtkDataSet *)
vtkDataSet * GetVectors ()
void | SetNormals (vtkDataSet *)
vtkDataSet * GetNormals ()
void | SetTCoords (vtkDataSet *)
vtkDataSet * GetTCoords ()
void | SetTensors (vtkDataSet *)
vtkDataSet * GetTensors ()

Static Public Methods

vtkMergeFilter * | New ()

Protected Methods

vtkMergeFilter ()
~vtkMergeFilter ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *data)

Protected Attributes

vtkFieldList * | FieldList

Detailed Description

extract separate components of data from different datasets.

Date:
2002/01/22 15:29:30
Revision:
1.54

vtkMergeFilter is a filter that extracts separate components of data from different datasets and merges them into a single dataset. The output from this filter is of the same type as the input (i.e., vtkDataSet.) It treats both cell and point data set attributes.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (49%)
  • Martin, Ken (17%)
  • Geveci, Berk (15%)
  • Lorensen, Bill (13%)
Examples:
vtkMergeFilter (Examples)
Tests:
vtkMergeFilter (Tests)

Definition at line 50 of file vtkMergeFilter.h.

Constructor & Destructor Documentation

vtkMergeFilter::vtkMergeFilter ( ) [protected]

vtkMergeFilter::~vtkMergeFilter ( ) [protected]

Member Function Documentation

vtkMergeFilter* vtkMergeFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkMergeFilter::vtkTypeRevisionMacro | ( | vtkMergeFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkMergeFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkMergeFilter::SetGeometry ( vtkDataSet * input ) [inline]

Specify object from which to extract geometry information.

Definition at line 59 of file vtkMergeFilter.h.

vtkDataSet* vtkMergeFilter::GetGeometry ( ) [inline]

Specify object from which to extract geometry information.

Definition at line 60 of file vtkMergeFilter.h.

void vtkMergeFilter::SetScalars ( vtkDataSet * )

Specify object from which to extract scalar information.

vtkDataSet* vtkMergeFilter::GetScalars ( )

Specify object from which to extract scalar information.

void vtkMergeFilter::SetVectors ( vtkDataSet * )

Set / get the object from which to extract vector information.

vtkDataSet* vtkMergeFilter::GetVectors ( )

Set / get the object from which to extract vector information.

void vtkMergeFilter::SetNormals ( vtkDataSet * )

Set / get the object from which to extract normal information.

vtkDataSet* vtkMergeFilter::GetNormals ( )

Set / get the object from which to extract normal information.

void vtkMergeFilter::SetTCoords ( vtkDataSet * )

Set / get the object from which to extract texture coordinates information.

vtkDataSet* vtkMergeFilter::GetTCoords ( )

Set / get the object from which to extract texture coordinates information.

void vtkMergeFilter::SetTensors ( vtkDataSet * )

Set / get the object from which to extract tensor data.

vtkDataSet* vtkMergeFilter::GetTensors ( )

Set / get the object from which to extract tensor data.

void vtkMergeFilter::AddField | ( | const char * | name,
 |  | vtkDataSet * | input
 | ) |

Set the object from which to extract a field and the name of the field

void vtkMergeFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkMergeFilter::ComputeInputUpdateExtents ( vtkDataObject * data ) [protected, virtual]

By default copy the output update extent to the input

Reimplemented from vtkDataSetToDataSetFilter.

Member Data Documentation

vtkFieldList* vtkMergeFilter::FieldList [protected]

Definition at line 106 of file vtkMergeFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkMergeFilter.h
Generated on Mon Mar 25 01:23:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergePoints Class Reference

merge exactly coincident points. More...

#include <vtkMergePoints.h>

Inheritance diagram for vtkMergePoints:

[legend]
Collaboration diagram for vtkMergePoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMergePoints, vtkPointLocator)
int | InsertUniquePoint (const float x[3], vtkIdType &ptId)
vtkIdType | IsInsertedPoint (const float x[3])
vtkIdType | IsInsertedPoint (float x, float y, float z)

Static Public Methods

vtkMergePoints * | New ()

Protected Methods

vtkMergePoints ()
~vtkMergePoints ()

Detailed Description

merge exactly coincident points.

Date:
2002/01/22 15:28:08
Revision:
1.42

vtkMergePoints is a locator object to quickly locate points in 3D. The primary difference between vtkMergePoints and its superclass vtkPointLocator is that vtkMergePoints merges precisely coincident points and is therefore much faster.

See also:
vtkCleanPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (50%)
  • Miller, Jim (19%)
  • Lorensen, Bill (15%)
  • Henderson, Amy (5%)
Tests:
vtkMergePoints (Tests)

Definition at line 47 of file vtkMergePoints.h.

Constructor & Destructor Documentation

vtkMergePoints::vtkMergePoints ( ) [inline, protected]

Definition at line 71 of file vtkMergePoints.h.

vtkMergePoints::~vtkMergePoints ( ) [inline, protected]

Definition at line 72 of file vtkMergePoints.h.

Member Function Documentation

vtkMergePoints* vtkMergePoints::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 points per bucket.

Reimplemented from vtkPointLocator.

vtkMergePoints::vtkTypeRevisionMacro | ( | vtkMergePoints | ,
 |  | vtkPointLocator |
 | ) |

Reimplemented from vtkPointLocator.

vtkIdType vtkMergePoints::IsInsertedPoint ( const float x[3] ) [virtual]

Determine whether point given by x[3] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1.

Reimplemented from vtkPointLocator.

vtkIdType vtkMergePoints::IsInsertedPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Determine whether point given by x[3] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1.

Reimplemented from vtkPointLocator.

Definition at line 58 of file vtkMergePoints.h.

int vtkMergePoints::InsertUniquePoint | ( | const float | x[3],
 |  | vtkIdType & | ptId
 | ) | [virtual]

Determine whether point given by x[3] has been inserted into points list. Return 0 if point was already in the list, otherwise return 1. If the point was not in the list, it will be ADDED. In either case, the id of the point (newly inserted or not) is returned in the ptId argument. Note this combines the functionality of IsInsertedPoint() followed by a call to InsertNextPoint().

Reimplemented from vtkPointLocator.

The documentation for this class was generated from the following file:
  • Filtering/vtkMergePoints.h
Generated on Mon Mar 25 01:23:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMergePoints2D Class Reference

merge exactly coincident points. More...

#include <vtkMergePoints2D.h>

Inheritance diagram for vtkMergePoints2D:

[legend]
Collaboration diagram for vtkMergePoints2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMergePoints2D, vtkPointLocator2D)
int | IsInsertedPoint (float x[2])

Static Public Methods

vtkMergePoints2D * | New ()

Protected Methods

vtkMergePoints2D ()
~vtkMergePoints2D ()

Detailed Description

merge exactly coincident points.

Date:
2002/01/22 15:28:09
Revision:
1.13

vtkMergePoints2D is a locator object to quickly locate points in 3D. The primary difference between vtkMergePoints2D and its superclass vtkPointLocator is that vtkMergePoints2D merges precisely coincident points and is therefore much faster.

See also:
vtkCleanPolyData
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (93%)

Definition at line 41 of file vtkMergePoints2D.h.

Constructor & Destructor Documentation

vtkMergePoints2D::vtkMergePoints2D ( ) [inline, protected]

Definition at line 53 of file vtkMergePoints2D.h.

vtkMergePoints2D::~vtkMergePoints2D ( ) [inline, protected]

Definition at line 54 of file vtkMergePoints2D.h.

Member Function Documentation

vtkMergePoints2D* vtkMergePoints2D::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 points per bucket.

Reimplemented from vtkPointLocator2D.

vtkMergePoints2D::vtkTypeRevisionMacro | ( | vtkMergePoints2D | ,
 |  | vtkPointLocator2D |
 | ) |

Reimplemented from vtkPointLocator2D.

int vtkMergePoints2D::IsInsertedPoint ( float x[2] ) [virtual]

Determine whether point given by x[] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1.

Reimplemented from vtkPointLocator2D.

The documentation for this class was generated from the following file:
  • Filtering/vtkMergePoints2D.h
Generated on Mon Mar 25 01:23:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaActor Class Reference

Mesa actor. More...

#include <vtkMesaActor.h>

Inheritance diagram for vtkMesaActor:

[legend]
Collaboration diagram for vtkMesaActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaActor, vtkActor)
void | Render (vtkRenderer *ren, vtkMapper *mapper)
vtkProperty * MakeProperty ()

Static Public Methods

vtkMesaActor * | New ()

Protected Methods

vtkMesaActor ()
~vtkMesaActor ()

Detailed Description

Mesa actor.

Date:
2002/01/22 15:38:41
Revision:
1.12

vtkMesaActor is a concrete implementation of the abstract class vtkActor. vtkMesaActor interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (61%)
  • Hoffman, Bill (32%)
Examples:
vtkMesaActor (Examples)
Tests:
vtkMesaActor (Tests)

Definition at line 46 of file vtkMesaActor.h.

Constructor & Destructor Documentation

vtkMesaActor::vtkMesaActor ( ) [inline, protected]

Definition at line 61 of file vtkMesaActor.h.

vtkMesaActor::~vtkMesaActor ( ) [inline, protected]

Definition at line 62 of file vtkMesaActor.h.

Member Function Documentation

vtkMesaActor* vtkMesaActor::New ( ) [static]

Creates an actor with the following defaults: origin(0,0,0) position=(0,0,0) scale=(1,1,1) visibility=1 pickable=1 dragable=1 orientation=(0,0,0). No user defined matrix and no texture map.

Reimplemented from vtkActor.

vtkMesaActor::vtkTypeRevisionMacro | ( | vtkMesaActor | ,
 |  | vtkActor |
 | ) |

Reimplemented from vtkActor.

void vtkMesaActor::Render | ( | vtkRenderer * | ren,
 |  | vtkMapper * | mapper
 | ) | [virtual]

Actual actor render method.

Reimplemented from vtkActor.

vtkProperty* vtkMesaActor::MakeProperty ( ) [virtual]

Create a vtkMesaProperty, used by the super class to create a compatible class with the vtkMesaActor.

Reimplemented from vtkActor.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaActor.h
Generated on Mon Mar 25 01:23:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaCamera Class Reference

Mesa camera. More...

#include <vtkMesaCamera.h>

Inheritance diagram for vtkMesaCamera:

[legend]
Collaboration diagram for vtkMesaCamera:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaCamera, vtkCamera)
void | Render (vtkRenderer *ren)
void | UpdateViewport (vtkRenderer *ren)

Static Public Methods

vtkMesaCamera * | New ()

Protected Methods

vtkMesaCamera ()
~vtkMesaCamera ()

Detailed Description

Mesa camera.

Date:
2002/01/22 15:38:41
Revision:
1.14

vtkMesaCamera is a concrete implementation of the abstract class vtkCamera. vtkMesaCamera interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (63%)
  • Hoffman, Bill (28%)

Definition at line 40 of file vtkMesaCamera.h.

Constructor & Destructor Documentation

vtkMesaCamera::vtkMesaCamera ( ) [inline, protected]

Definition at line 52 of file vtkMesaCamera.h.

vtkMesaCamera::~vtkMesaCamera ( ) [inline, protected]

Definition at line 53 of file vtkMesaCamera.h.

Member Function Documentation

vtkMesaCamera* vtkMesaCamera::New ( ) [static]

Construct camera instance with its focal point at the origin, and position=(0,0,1). The view up is along the y-axis, view angle is 30 degrees, and the clipping range is (.1,1000).

Reimplemented from vtkCamera.

vtkMesaCamera::vtkTypeRevisionMacro | ( | vtkMesaCamera | ,
 |  | vtkCamera |
 | ) |

Reimplemented from vtkCamera.

void vtkMesaCamera::Render ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkCamera.

void vtkMesaCamera::UpdateViewport ( vtkRenderer * ren )

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaCamera.h
Generated on Mon Mar 25 01:23:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageActor Class Reference

Mesa texture map. More...

#include <vtkMesaImageActor.h>

Inheritance diagram for vtkMesaImageActor:

[legend]
Collaboration diagram for vtkMesaImageActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaImageActor, vtkImageActor)
void | Load (vtkRenderer *ren)
void | ReleaseGraphicsResources (vtkWindow *)

Static Public Methods

vtkMesaImageActor * | New ()

Protected Methods

vtkMesaImageActor ()
~vtkMesaImageActor ()
unsigned char * | MakeDataSuitable (int &xsize, int &ysize, int &release)

Protected Attributes

vtkTimeStamp LoadTime
long | Index
vtkRenderWindow * RenderWindow
float | Coords [12]
float | TCoords [8]

Static Protected Attributes

long | GlobalIndex

Detailed Description

Mesa texture map.

Date:
2002/01/22 15:38:42
Revision:
1.7

vtkMesaImageActor is a concrete implementation of the abstract class vtkImageActor. vtkMesaImageActor interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (81%)
  • Hoffman, Bill (10%)

Definition at line 42 of file vtkMesaImageActor.h.

Constructor & Destructor Documentation

vtkMesaImageActor::vtkMesaImageActor ( ) [protected]

vtkMesaImageActor::~vtkMesaImageActor ( ) [protected]

Member Function Documentation

vtkMesaImageActor* vtkMesaImageActor::New ( ) [static]

Instantiate the image actor.

Reimplemented from vtkImageActor.

vtkMesaImageActor::vtkTypeRevisionMacro | ( | vtkMesaImageActor | ,
 |  | vtkImageActor |
 | ) |

Reimplemented from vtkImageActor.

void vtkMesaImageActor::Load ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkImageActor.

void vtkMesaImageActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this texture. The parameter window could be used to determine which graphic resources to release. Using the same texture object in multiple render windows is NOT currently supported.

Reimplemented from vtkProp.

unsigned char* vtkMesaImageActor::MakeDataSuitable | ( | int & | xsize,
 |  | int & | ysize,
 |  | int & | release
 | ) | [protected]

Member Data Documentation

vtkTimeStamp vtkMesaImageActor::LoadTime [protected]

Definition at line 63 of file vtkMesaImageActor.h.

long vtkMesaImageActor::Index [protected]

Definition at line 64 of file vtkMesaImageActor.h.

long vtkMesaImageActor::GlobalIndex [static, protected]

Definition at line 65 of file vtkMesaImageActor.h.

vtkRenderWindow* vtkMesaImageActor::RenderWindow [protected]

Definition at line 66 of file vtkMesaImageActor.h.

float vtkMesaImageActor::Coords[12] [protected]

Definition at line 67 of file vtkMesaImageActor.h.

float vtkMesaImageActor::TCoords[8] [protected]

Definition at line 68 of file vtkMesaImageActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaImageActor.h
Generated on Mon Mar 25 01:24:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageMapper Class Reference

2D image display support for Mesa. More...

#include <vtkMesaImageMapper.h>

Inheritance diagram for vtkMesaImageMapper:

[legend]
Collaboration diagram for vtkMesaImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaImageMapper, vtkImageMapper)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderData (vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor)

Static Public Methods

vtkMesaImageMapper * | New ()

Protected Methods

vtkMesaImageMapper ()
~vtkMesaImageMapper ()

Detailed Description

2D image display support for Mesa.

Date:
2002/01/22 15:38:42
Revision:
1.11

vtkMesaImageMapper is a concrete subclass of vtkImageMapper that renders images under Mesa

See also:
vtkImageMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (64%)
  • Hoffman, Bill (30%)

Definition at line 44 of file vtkMesaImageMapper.h.

Constructor & Destructor Documentation

vtkMesaImageMapper::vtkMesaImageMapper ( ) [protected]

vtkMesaImageMapper::~vtkMesaImageMapper ( ) [protected]

Member Function Documentation

vtkMesaImageMapper* vtkMesaImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapper.

vtkMesaImageMapper::vtkTypeRevisionMacro | ( | vtkMesaImageMapper | ,
 |  | vtkImageMapper |
 | ) |

Reimplemented from vtkImageMapper.

void vtkMesaImageMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Handle the render method.

Reimplemented from vtkMapper2D.

Definition at line 52 of file vtkMesaImageMapper.h.

void vtkMesaImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Called by the Render function in vtkImageMapper. Actually draws the image to the screen.

Reimplemented from vtkImageMapper.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaImageMapper.h
Generated on Mon Mar 25 01:24:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImager Class Reference

#include <vtkMesaImager.h>

Inheritance diagram for vtkMesaImager:

[legend]
Collaboration diagram for vtkMesaImager:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaImager, vtkImager)
int | RenderOpaqueGeometry ()
void | Erase ()

Static Public Methods

vtkMesaImager * | New ()

Protected Methods

vtkMesaImager ()
~vtkMesaImager ()

Constructor & Destructor Documentation

vtkMesaImager::vtkMesaImager ( ) [inline, protected]

Definition at line 55 of file vtkMesaImager.h.

vtkMesaImager::~vtkMesaImager ( ) [inline, protected]

Definition at line 56 of file vtkMesaImager.h.

Member Function Documentation

vtkMesaImager* vtkMesaImager::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkImager.

vtkMesaImager::vtkTypeRevisionMacro | ( | vtkMesaImager | ,
 |  | vtkImager |
 | ) |

Reimplemented from vtkImager.

int vtkMesaImager::RenderOpaqueGeometry ( ) [virtual]

Renders an imager. Passes Render message on the the imager's actor2D collection.

Reimplemented from vtkImager.

void vtkMesaImager::Erase ( ) [virtual]

Erase the contents of the imager in the window.

Reimplemented from vtkImager.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaImager.h
Generated on Mon Mar 25 01:24:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaImageWindow Class Reference

Mesa Imageing window. More...

#include <vtkMesaImageWindow.h>

Inheritance diagram for vtkMesaImageWindow:

[legend]
Collaboration diagram for vtkMesaImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaImageWindow, vtkXImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | MakeDefaultWindow ()
void | SwapBuffers ()
void | Frame ()
void | Render ()
void | MakeCurrent ()
virtual void | EraseWindow ()
virtual void | SetOffScreenRendering (int i)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void * | GetGenericDrawable ()
virtual Colormap | GetDesiredColormap ()
virtual Visual * | GetDesiredVisual ()
XVisualInfo * | GetDesiredVisualInfo ()
virtual int | GetDesiredDepth ()
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)

Static Public Methods

vtkMesaImageWindow * | New ()

Protected Methods

vtkMesaImageWindow ()
~vtkMesaImageWindow ()

Protected Attributes

GLXContext | ContextId
OSMesaContext | OffScreenContextId
void * | OffScreenWindow
int | ScreenDoubleBuffer
int | ScreenMapped

Detailed Description

Mesa Imageing window.

Date:
2002/01/22 15:38:42
Revision:
1.19

vtkMesaImageWindow is a concrete implementation of the abstract class vtkImageWindow. vtkMesaImageer interfaces to the standard Mesa graphics library in the Windows/NT environment..

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (92%)

Definition at line 49 of file vtkMesaImageWindow.h.

Constructor & Destructor Documentation

vtkMesaImageWindow::vtkMesaImageWindow ( ) [protected]

vtkMesaImageWindow::~vtkMesaImageWindow ( ) [protected]

Member Function Documentation

vtkMesaImageWindow* vtkMesaImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkXImageWindow.

vtkMesaImageWindow::vtkTypeRevisionMacro | ( | vtkMesaImageWindow | ,
 |  | vtkXImageWindow |
 | ) |

Reimplemented from vtkXImageWindow.

void vtkMesaImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkXImageWindow.

virtual void vtkMesaImageWindow::MakeDefaultWindow ( ) [virtual]

Initialize the window for rendering.

Reimplemented from vtkXImageWindow.

void vtkMesaImageWindow::SwapBuffers ( ) [virtual]

Swap the front and back buffers if double buffering is being used.

Reimplemented from vtkXImageWindow.

void vtkMesaImageWindow::Frame ( ) [virtual]

Flush the buffer and swap if necessary.

Reimplemented from vtkXImageWindow.

void vtkMesaImageWindow::Render ( void ) [virtual]

Draw the contents of the window

Reimplemented from vtkImageWindow.

virtual void* vtkMesaImageWindow::GetGenericDisplayId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 70 of file vtkMesaImageWindow.h.

virtual void* vtkMesaImageWindow::GetGenericWindowId ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

virtual void* vtkMesaImageWindow::GetGenericParentId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 72 of file vtkMesaImageWindow.h.

virtual void* vtkMesaImageWindow::GetGenericContext ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

virtual void* vtkMesaImageWindow::GetGenericDrawable ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 74 of file vtkMesaImageWindow.h.

virtual Colormap vtkMesaImageWindow::GetDesiredColormap ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

virtual Visual* vtkMesaImageWindow::GetDesiredVisual ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

XVisualInfo* vtkMesaImageWindow::GetDesiredVisualInfo ( )

Get the X properties of an ideal rendering window.

virtual int vtkMesaImageWindow::GetDesiredDepth ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

virtual unsigned char* vtkMesaImageWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkXImageWindow.

virtual void vtkMesaImageWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

virtual float* vtkMesaImageWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkMesaImageWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

void vtkMesaImageWindow::MakeCurrent ( ) [virtual]

Make this windows Mesa context the current context.

Reimplemented from vtkImageWindow.

virtual void vtkMesaImageWindow::EraseWindow ( ) [inline, virtual]

Erase the window contents

Reimplemented from vtkXImageWindow.

Definition at line 103 of file vtkMesaImageWindow.h.

virtual void vtkMesaImageWindow::SetOffScreenRendering ( int i ) [virtual]

Override the default implementation so that we can actively switch between on and offscreen rendering.

Reimplemented from vtkWindow.

Member Data Documentation

GLXContext vtkMesaImageWindow::ContextId [protected]

Definition at line 113 of file vtkMesaImageWindow.h.

OSMesaContext vtkMesaImageWindow::OffScreenContextId [protected]

Definition at line 114 of file vtkMesaImageWindow.h.

void* vtkMesaImageWindow::OffScreenWindow [protected]

Definition at line 115 of file vtkMesaImageWindow.h.

int vtkMesaImageWindow::ScreenDoubleBuffer [protected]

Definition at line 116 of file vtkMesaImageWindow.h.

int vtkMesaImageWindow::ScreenMapped [protected]

Definition at line 117 of file vtkMesaImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaImageWindow.h
Generated on Mon Mar 25 01:24:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaLight Class Reference

Mesa light. More...

#include <vtkMesaLight.h>

Inheritance diagram for vtkMesaLight:

[legend]
Collaboration diagram for vtkMesaLight:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaLight, vtkLight)
void | Render (vtkRenderer *ren, int light_index)

Static Public Methods

vtkMesaLight * | New ()

Protected Methods

vtkMesaLight ()
~vtkMesaLight ()

Detailed Description

Mesa light.

Date:
2002/01/22 15:38:43
Revision:
1.11

vtkMesaLight is a concrete implementation of the abstract class vtkLight. vtkMesaLight interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (65%)
  • Hoffman, Bill (28%)

Definition at line 40 of file vtkMesaLight.h.

Constructor & Destructor Documentation

vtkMesaLight::vtkMesaLight ( ) [inline, protected]

Definition at line 50 of file vtkMesaLight.h.

vtkMesaLight::~vtkMesaLight ( ) [inline, protected]

Definition at line 51 of file vtkMesaLight.h.

Member Function Documentation

vtkMesaLight* vtkMesaLight::New ( ) [static]

Create a light with the focal point at the origin and its position set to (0,0,1). The light is a SceneLight, its color is white, intensity=1, and the light is turned on.

Reimplemented from vtkLight.

vtkMesaLight::vtkTypeRevisionMacro | ( | vtkMesaLight | ,
 |  | vtkLight |
 | ) |

Reimplemented from vtkLight.

void vtkMesaLight::Render | ( | vtkRenderer * | ren,
 |  | int | light_index
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkLight.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaLight.h
Generated on Mon Mar 25 01:24:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaPolyDataMapper Class Reference

a PolyDataMapper for the Mesa library. More...

#include <vtkMesaPolyDataMapper.h>

Inheritance diagram for vtkMesaPolyDataMapper:

[legend]
Collaboration diagram for vtkMesaPolyDataMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaPolyDataMapper, vtkPolyDataMapper)
virtual void | RenderPiece (vtkRenderer *ren, vtkActor *a)
void | ReleaseGraphicsResources (vtkWindow *)
virtual int | Draw (vtkRenderer *ren, vtkActor *a)
GLenum | GetLmcolorMode (vtkProperty *prop)

Static Public Methods

vtkMesaPolyDataMapper * | New ()

Protected Methods

vtkMesaPolyDataMapper ()
~vtkMesaPolyDataMapper ()

Protected Attributes

int | ListId
vtkRenderWindow * RenderWindow

Detailed Description

a PolyDataMapper for the Mesa library.

Date:
2002/02/28 21:01:25
Revision:
1.18

vtkMesaPolyDataMapper is a subclass of vtkPolyDataMapper. vtkMesaPolyDataMapper is a geometric PolyDataMapper for the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (66%)
  • Hoffman, Bill (32%)
Examples:
vtkMesaPolyDataMapper (Examples)
Tests:
vtkMesaPolyDataMapper (Tests)

Definition at line 56 of file vtkMesaPolyDataMapper.h.

Constructor & Destructor Documentation

vtkMesaPolyDataMapper::vtkMesaPolyDataMapper ( ) [protected]

vtkMesaPolyDataMapper::~vtkMesaPolyDataMapper ( ) [protected]

Member Function Documentation

vtkMesaPolyDataMapper* vtkMesaPolyDataMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper.

vtkMesaPolyDataMapper::vtkTypeRevisionMacro | ( | vtkMesaPolyDataMapper | ,
 |  | vtkPolyDataMapper |
 | ) |

Reimplemented from vtkPolyDataMapper.

virtual void vtkMesaPolyDataMapper::RenderPiece | ( | vtkRenderer * | ren,
 |  | vtkActor * | a
 | ) | [virtual]

Implement superclass render method.

Reimplemented from vtkPolyDataMapper.

void vtkMesaPolyDataMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkMapper.

virtual int vtkMesaPolyDataMapper::Draw | ( | vtkRenderer * | ren,
 |  | vtkActor * | a
 | ) | [virtual]

Draw method for Mesa.

GLenum vtkMesaPolyDataMapper::GetLmcolorMode ( vtkProperty * prop )

Get the lmcolor property, this is a pretty important little function. It determines how vertex colors will be handled in gl. When a PolyDataMapper has vertex colors it will use this method to determine what lmcolor mode to set.

Member Data Documentation

int vtkMesaPolyDataMapper::ListId [protected]

Definition at line 88 of file vtkMesaPolyDataMapper.h.

vtkRenderWindow* vtkMesaPolyDataMapper::RenderWindow [protected]

Definition at line 89 of file vtkMesaPolyDataMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaPolyDataMapper.h
Generated on Mon Mar 25 01:24:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaPolyDataMapper2D Class Reference

#include <vtkMesaPolyDataMapper2D.h>

Inheritance diagram for vtkMesaPolyDataMapper2D:

[legend]
Collaboration diagram for vtkMesaPolyDataMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaPolyDataMapper2D, vtkPolyDataMapper2D)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)

Static Public Methods

vtkMesaPolyDataMapper2D * | New ()

Protected Methods

vtkMesaPolyDataMapper2D ()
~vtkMesaPolyDataMapper2D ()

Constructor & Destructor Documentation

vtkMesaPolyDataMapper2D::vtkMesaPolyDataMapper2D ( ) [inline, protected]

Definition at line 52 of file vtkMesaPolyDataMapper2D.h.

vtkMesaPolyDataMapper2D::~vtkMesaPolyDataMapper2D ( ) [inline, protected]

Definition at line 53 of file vtkMesaPolyDataMapper2D.h.

Member Function Documentation

vtkMesaPolyDataMapper2D::vtkTypeRevisionMacro | ( | vtkMesaPolyDataMapper2D | ,
 |  | vtkPolyDataMapper2D |
 | ) |

Reimplemented from vtkPolyDataMapper2D.

vtkMesaPolyDataMapper2D* vtkMesaPolyDataMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper2D.

void vtkMesaPolyDataMapper2D::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actually draw the poly data.

Reimplemented from vtkMapper2D.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaPolyDataMapper2D.h
Generated on Mon Mar 25 01:24:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaProperty Class Reference

Mesa property. More...

#include <vtkMesaProperty.h>

Inheritance diagram for vtkMesaProperty:

[legend]
Collaboration diagram for vtkMesaProperty:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaProperty, vtkProperty)
void | Render (vtkActor *a, vtkRenderer *ren)
void | BackfaceRender (vtkActor *a, vtkRenderer *ren)

Static Public Methods

vtkMesaProperty * | New ()

Protected Methods

vtkMesaProperty ()
~vtkMesaProperty ()

Detailed Description

Mesa property.

Date:
2002/01/22 15:38:45
Revision:
1.11

vtkMesaProperty is a concrete implementation of the abstract class vtkProperty. vtkMesaProperty interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (62%)
  • Hoffman, Bill (33%)

Definition at line 40 of file vtkMesaProperty.h.

Constructor & Destructor Documentation

vtkMesaProperty::vtkMesaProperty ( ) [inline, protected]

Definition at line 53 of file vtkMesaProperty.h.

vtkMesaProperty::~vtkMesaProperty ( ) [inline, protected]

Definition at line 54 of file vtkMesaProperty.h.

Member Function Documentation

vtkMesaProperty* vtkMesaProperty::New ( ) [static]

Construct object with object color, ambient color, diffuse color, specular color, and edge color white; ambient coefficient=0; diffuse coefficient=0; specular coefficient=0; specular power=1; Gouraud shading; and surface representation. Backface and frontface culling are off.

Reimplemented from vtkProperty.

vtkMesaProperty::vtkTypeRevisionMacro | ( | vtkMesaProperty | ,
 |  | vtkProperty |
 | ) |

Reimplemented from vtkProperty.

void vtkMesaProperty::Render | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkProperty.

void vtkMesaProperty::BackfaceRender | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkProperty.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaProperty.h
Generated on Mon Mar 25 01:24:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaRenderer Class Reference

OpenGL renderer. More...

#include <vtkMesaRenderer.h>

Inheritance diagram for vtkMesaRenderer:

[legend]
Collaboration diagram for vtkMesaRenderer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaRenderer, vtkRenderer)
void | PrintSelf (ostream &os, vtkIndent indent)
void | DeviceRender (void)
void | ClearLights (void)
void | Clear (void)
int | UpdateLights (void)
virtual vtkCamera * | MakeCamera ()
virtual vtkLight * | MakeLight ()

Static Public Methods

vtkMesaRenderer * | New ()

Protected Methods

vtkMesaRenderer ()
~vtkMesaRenderer ()
virtual void | DevicePickRender ()
virtual void | StartPick (unsigned int pickFromSize)
virtual void | UpdatePickId ()
virtual void | DonePick ()
virtual unsigned int | GetPickedId ()
virtual float | GetPickedZ ()

Protected Attributes

int | NumberOfLightsBound
vtkGLPickInfo * | PickInfo
float | PickedZ

Detailed Description

OpenGL renderer.

Date:
2002/01/22 15:38:46
Revision:
1.17

vtkMesaRenderer is a concrete implementation of the abstract class vtkRenderer. vtkMesaRenderer interfaces to the mesa graphics library. This file is created, by a copy of vtkOpenGLRenderer

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (60%)
  • Hoffman, Bill (36%)
Examples:
vtkMesaRenderer (Examples)
Tests:
vtkMesaRenderer (Tests)

Definition at line 46 of file vtkMesaRenderer.h.

Constructor & Destructor Documentation

vtkMesaRenderer::vtkMesaRenderer ( ) [protected]

vtkMesaRenderer::~vtkMesaRenderer ( ) [protected]

Member Function Documentation

vtkMesaRenderer* vtkMesaRenderer::New ( ) [static]

Create a vtkRenderer with a black background, a white ambient light, two-sided lighting turned on, a viewport of (0,0,1,1), and backface culling turned off.

Reimplemented from vtkRenderer.

vtkMesaRenderer::vtkTypeRevisionMacro | ( | vtkMesaRenderer | ,
 |  | vtkRenderer |
 | ) |

Reimplemented from vtkRenderer.

void vtkMesaRenderer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderer.

void vtkMesaRenderer::DeviceRender ( void ) [virtual]

Concrete open gl render method.

Reimplemented from vtkRenderer.

void vtkMesaRenderer::ClearLights ( void )

Internal method temporarily removes lights before reloading them into graphics pipeline.

void vtkMesaRenderer::Clear ( void ) [virtual]

Clear the image to the background color.

Reimplemented from vtkRenderer.

int vtkMesaRenderer::UpdateLights ( void ) [virtual]

Ask lights to load themselves into graphics pipeline.

Reimplemented from vtkRenderer.

virtual vtkCamera* vtkMesaRenderer::MakeCamera ( ) [virtual]

Create a new Camera sutible for use with this type of Renderer. For example, a vtkMesaRenderer should create a vtkMesaCamera in this function. The default is to just call vtkCamera::New.

Reimplemented from vtkRenderer.

virtual vtkLight* vtkMesaRenderer::MakeLight ( ) [virtual]

Create a new Light sutible for use with this type of Renderer. For example, a vtkMesaRenderer should create a vtkMesaLight in this function. The default is to just call vtkLight::New.

Reimplemented from vtkRenderer.

virtual void vtkMesaRenderer::DevicePickRender ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkMesaRenderer::StartPick ( unsigned int pickFromSize ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkMesaRenderer::UpdatePickId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkMesaRenderer::DonePick ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual unsigned int vtkMesaRenderer::GetPickedId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual float vtkMesaRenderer::GetPickedZ ( ) [protected, virtual]

Return the Z value for the last picked Prop.

Reimplemented from vtkViewport.

Member Data Documentation

int vtkMesaRenderer::NumberOfLightsBound [protected]

Definition at line 49 of file vtkMesaRenderer.h.

class vtkGLPickInfo* vtkMesaRenderer::PickInfo [protected]

Definition at line 91 of file vtkMesaRenderer.h.

float vtkMesaRenderer::PickedZ [protected]

Definition at line 93 of file vtkMesaRenderer.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaRenderer.h
Generated on Mon Mar 25 01:24:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaRenderWindow Class Reference

Mesa rendering window. More...

#include <vtkMesaRenderWindow.h>

Inheritance diagram for vtkMesaRenderWindow:

[legend]
Collaboration diagram for vtkMesaRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaRenderWindow, vtkRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | StereoUpdate ()
void | MakeCurrent ()=0
void | RegisterTextureResource (GLuint id)
int | GetDepthBufferSize ()
virtual void | OpenGLInit ()
virtual void | SetMultiSamples (int)
virtual int | GetMultiSamples ()
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)
virtual void | ReleaseRGBAPixelData (float *data)
virtual unsigned char * | GetRGBACharPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBACharPixelData (int x, int y, int x2, int y2, unsigned char *, int front, int blend=0)
virtual float * | GetZbufferData (int x1, int y1, int x2, int y2)
virtual void | SetZbufferData (int x1, int y1, int x2, int y2, float *buffer)

Static Public Methods

void | SetGlobalMaximumNumberOfMultiSamples (int val)
int | GetGlobalMaximumNumberOfMultiSamples ()

Protected Methods

vtkMesaRenderWindow ()
~vtkMesaRenderWindow ()

Protected Attributes

int | MultiSamples
long | OldMonitorSetting
vtkIdList * TextureResourceIds

Detailed Description

Mesa rendering window.

Date:
2002/03/13 18:34:48
Revision:
1.27

vtkMesaRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. It uses the mangle openGL namespace mgl, so Mesa render windows can be created in the same program as openGL render windows.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (67%)
  • Law, Charles (26%)
Examples:
vtkMesaRenderWindow (Examples)

Definition at line 50 of file vtkMesaRenderWindow.h.

Constructor & Destructor Documentation

vtkMesaRenderWindow::vtkMesaRenderWindow ( ) [protected]

vtkMesaRenderWindow::~vtkMesaRenderWindow ( ) [protected]

Member Function Documentation

vtkMesaRenderWindow::vtkTypeRevisionMacro | ( | vtkMesaRenderWindow | ,
 |  | vtkRenderWindow |
 | ) |

Reimplemented from vtkRenderWindow.

Reimplemented in vtkXMesaRenderWindow.

void vtkMesaRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindow.

Reimplemented in vtkXMesaRenderWindow.

void vtkMesaRenderWindow::SetGlobalMaximumNumberOfMultiSamples ( int val ) [static]

Set/Get the maximum number of multisamples

int vtkMesaRenderWindow::GetGlobalMaximumNumberOfMultiSamples ( ) [static]

Set/Get the maximum number of multisamples

virtual void vtkMesaRenderWindow::SetMultiSamples ( int ) [virtual]

Set / Get the number of multisamples to use for hardware antialiasing.

virtual int vtkMesaRenderWindow::GetMultiSamples ( ) [virtual]

Set / Get the number of multisamples to use for hardware antialiasing.

virtual void vtkMesaRenderWindow::StereoUpdate ( ) [virtual]

Update system if needed due to stereo rendering.

Reimplemented from vtkRenderWindow.

virtual unsigned char* vtkMesaRenderWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkWindow.

virtual void vtkMesaRenderWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkRenderWindow.

virtual float* vtkMesaRenderWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkMesaRenderWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkMesaRenderWindow::ReleaseRGBAPixelData ( float * data ) [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual unsigned char* vtkMesaRenderWindow::GetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkMesaRenderWindow::SetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual float* vtkMesaRenderWindow::GetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

virtual void vtkMesaRenderWindow::SetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | float * | buffer
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

void vtkMesaRenderWindow::MakeCurrent ( ) [pure virtual]

Make this window the current Mesa context.

Reimplemented from vtkRenderWindow.

Reimplemented in vtkXMesaRenderWindow.

void vtkMesaRenderWindow::RegisterTextureResource ( GLuint id )

Register a texture name with this render window.

int vtkMesaRenderWindow::GetDepthBufferSize ( ) [virtual]

Get the size of the depth buffer.

Reimplemented from vtkRenderWindow.

virtual void vtkMesaRenderWindow::OpenGLInit ( ) [virtual]

Initialize OpenGL for this window.

Member Data Documentation

int vtkMesaRenderWindow::MultiSamples [protected]

Definition at line 53 of file vtkMesaRenderWindow.h.

long vtkMesaRenderWindow::OldMonitorSetting [protected]

Definition at line 54 of file vtkMesaRenderWindow.h.

vtkIdList* vtkMesaRenderWindow::TextureResourceIds [protected]

Definition at line 117 of file vtkMesaRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaRenderWindow.h
Generated on Mon Mar 25 01:24:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaTexture Class Reference

Mesa texture map. More...

#include <vtkMesaTexture.h>

Inheritance diagram for vtkMesaTexture:

[legend]
Collaboration diagram for vtkMesaTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaTexture, vtkTexture)
void | Load (vtkRenderer *ren)
void | ReleaseGraphicsResources (vtkWindow *)

Static Public Methods

vtkMesaTexture * | New ()

Protected Methods

vtkMesaTexture ()
~vtkMesaTexture ()
unsigned char * | ResampleToPowerOfTwo (int &xsize, int &ysize, unsigned char *dptr, int bpp)

Protected Attributes

vtkTimeStamp LoadTime
long | Index
vtkRenderWindow * RenderWindow

Static Protected Attributes

long | GlobalIndex

Detailed Description

Mesa texture map.

Date:
2002/01/22 15:38:46
Revision:
1.11

vtkMesaTexture is a concrete implementation of the abstract class vtkTexture. vtkMesaTexture interfaces to the Mesa rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (66%)
  • Hoffman, Bill (30%)

Definition at line 42 of file vtkMesaTexture.h.

Constructor & Destructor Documentation

vtkMesaTexture::vtkMesaTexture ( ) [protected]

vtkMesaTexture::~vtkMesaTexture ( ) [protected]

Member Function Documentation

vtkMesaTexture* vtkMesaTexture::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkTexture.

vtkMesaTexture::vtkTypeRevisionMacro | ( | vtkMesaTexture | ,
 |  | vtkTexture |
 | ) |

Reimplemented from vtkTexture.

void vtkMesaTexture::Load ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkTexture.

void vtkMesaTexture::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this texture. The parameter window could be used to determine which graphic resources to release. Using the same texture object in multiple render windows is NOT currently supported.

Reimplemented from vtkTexture.

unsigned char* vtkMesaTexture::ResampleToPowerOfTwo | ( | int & | xsize,
 |  | int & | ysize,
 |  | unsigned char * | dptr,
 |  | int | bpp
 | ) | [protected]

Member Data Documentation

vtkTimeStamp vtkMesaTexture::LoadTime [protected]

Definition at line 64 of file vtkMesaTexture.h.

long vtkMesaTexture::Index [protected]

Definition at line 65 of file vtkMesaTexture.h.

long vtkMesaTexture::GlobalIndex [static, protected]

Definition at line 66 of file vtkMesaTexture.h.

vtkRenderWindow* vtkMesaTexture::RenderWindow [protected]

Definition at line 67 of file vtkMesaTexture.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaTexture.h
Generated on Mon Mar 25 01:24:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaVolumeRayCastMapper Class Reference

Mesa subclass that draws the image to the screen. More...

#include <vtkMesaVolumeRayCastMapper.h>

Inheritance diagram for vtkMesaVolumeRayCastMapper:

[legend]
Collaboration diagram for vtkMesaVolumeRayCastMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaVolumeRayCastMapper, vtkVolumeRayCastMapper)

Static Public Methods

vtkMesaVolumeRayCastMapper * | New ()

Protected Methods

vtkMesaVolumeRayCastMapper ()
~vtkMesaVolumeRayCastMapper ()
void | RenderTexture (vtkVolume *vol, vtkRenderer *ren)

Detailed Description

Mesa subclass that draws the image to the screen.

Date:
2002/01/22 15:38:46
Revision:
1.7

This is the concrete implementation of a ray cast mapper - it is responsible for drawing the image to the screen. The remaining functionality all comes from vtkVolumeRayCastMapper

See also:
vtkVolumeRayCastMapper vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (79%)
  • Law, Charles (12%)
  • Hoffman, Bill (5%)

Definition at line 50 of file vtkMesaVolumeRayCastMapper.h.

Constructor & Destructor Documentation

vtkMesaVolumeRayCastMapper::vtkMesaVolumeRayCastMapper ( ) [protected]

vtkMesaVolumeRayCastMapper::~vtkMesaVolumeRayCastMapper ( ) [protected]

Member Function Documentation

vtkMesaVolumeRayCastMapper* vtkMesaVolumeRayCastMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVolumeRayCastMapper.

vtkMesaVolumeRayCastMapper::vtkTypeRevisionMacro | ( | vtkMesaVolumeRayCastMapper | ,
 |  | vtkVolumeRayCastMapper |
 | ) |

Reimplemented from vtkVolumeRayCastMapper.

void vtkMesaVolumeRayCastMapper::RenderTexture | ( | vtkVolume * | vol,
 |  | vtkRenderer * | ren
 | ) | [protected, virtual]

Reimplemented from vtkVolumeRayCastMapper.

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaVolumeRayCastMapper.h
Generated on Mon Mar 25 01:24:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMesaVolumeTextureMapper2D Class Reference

Abstract class for a volume mapper. More...

#include <vtkMesaVolumeTextureMapper2D.h>

Inheritance diagram for vtkMesaVolumeTextureMapper2D:

[legend]
Collaboration diagram for vtkMesaVolumeTextureMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMesaVolumeTextureMapper2D, vtkVolumeTextureMapper2D)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Render (vtkRenderer *ren, vtkVolume *vol)
void | RenderQuads (int count, float *v, float *t, unsigned char *texture, int size[2], int reverseFlag)

Static Public Methods

vtkMesaVolumeTextureMapper2D * | New ()

Protected Methods

vtkMesaVolumeTextureMapper2D ()
~vtkMesaVolumeTextureMapper2D ()

Detailed Description

Abstract class for a volume mapper.

Date:
2002/01/22 15:38:46
Revision:
1.15

vtkMesaVolumeTextureMapper2D renders a volume using 2D texture mapping.

See also:
vtkVolumeMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (60%)
  • Hoffman, Bill (31%)

Definition at line 41 of file vtkMesaVolumeTextureMapper2D.h.

Constructor & Destructor Documentation

vtkMesaVolumeTextureMapper2D::vtkMesaVolumeTextureMapper2D ( ) [protected]

vtkMesaVolumeTextureMapper2D::~vtkMesaVolumeTextureMapper2D ( ) [protected]

Member Function Documentation

vtkMesaVolumeTextureMapper2D::vtkTypeRevisionMacro | ( | vtkMesaVolumeTextureMapper2D | ,
 |  | vtkVolumeTextureMapper2D |
 | ) |

Reimplemented from vtkVolumeTextureMapper2D.

void vtkMesaVolumeTextureMapper2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeTextureMapper2D.

vtkMesaVolumeTextureMapper2D* vtkMesaVolumeTextureMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVolumeTextureMapper2D.

virtual void vtkMesaVolumeTextureMapper2D::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Render the volume

Reimplemented from vtkVolumeTextureMapper2D.

void vtkMesaVolumeTextureMapper2D::RenderQuads | ( | int | count,
 |  | float * | v,
 |  | float * | t,
 |  | unsigned char * | texture,
 |  | int | size[2],
 |  | int | reverseFlag
 | ) |

The documentation for this class was generated from the following file:
  • Rendering/vtkMesaVolumeTextureMapper2D.h
Generated on Mon Mar 25 01:25:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Mesh Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Mesh:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS int | vertices
Vector * vertex
int | faces
Face * face
Material ** mtl
int | hidden
int | shadow
vtkActor * anActor
vtkPolyDataMapper * aMapper
vtkPolyDataNormals * aNormals
vtkStripper * aStripper
vtkPoints * aPoints
vtkCellArray * aCellArray
vtkPolyData * aPolyData

Member Data Documentation

VTK_LIST_FIELDS int Mesh::vertices

Definition at line 136 of file vtk3DS.h.

Vector* Mesh::vertex

Definition at line 137 of file vtk3DS.h.

int Mesh::faces

Definition at line 139 of file vtk3DS.h.

Face* Mesh::face

Definition at line 140 of file vtk3DS.h.

Material** Mesh::mtl

Definition at line 141 of file vtk3DS.h.

int Mesh::hidden

Definition at line 143 of file vtk3DS.h.

int Mesh::shadow

Definition at line 144 of file vtk3DS.h.

vtkActor* Mesh::anActor

Definition at line 145 of file vtk3DS.h.

vtkPolyDataMapper* Mesh::aMapper

Definition at line 146 of file vtk3DS.h.

vtkPolyDataNormals* Mesh::aNormals

Definition at line 147 of file vtk3DS.h.

vtkStripper* Mesh::aStripper

Definition at line 148 of file vtk3DS.h.

vtkPoints* Mesh::aPoints

Definition at line 149 of file vtk3DS.h.

vtkCellArray* Mesh::aCellArray

Definition at line 150 of file vtk3DS.h.

vtkPolyData* Mesh::aPolyData

Definition at line 151 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:25:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMILVideoSource Class Reference

Matrox Imaging Library frame grabbers. More...

#include <vtkMILVideoSource.h>

Inheritance diagram for vtkMILVideoSource:

[legend]
Collaboration diagram for vtkMILVideoSource:

[legend]
List of all members.

[NOHEADER]

void | InternalGrab ()
void * | OldHookFunction
void * | OldUserDataPtr
int | FrameCounter
int | ForceGrab

Public Methods

vtkTypeRevisionMacro (vtkMILVideoSource, vtkVideoSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Record ()
void | Play ()
void | Stop ()
void | Grab ()
void | SetFrameSize (int x, int y, int z)
void | SetOutputFormat (int format)
void | Initialize ()
void | ReleaseSystemResources ()
virtual void | SetVideoChannel (int channel)
virtual int | GetVideoChannel ()
virtual void | SetVideoFormat (int format)
void | SetVideoFormatToNTSC ()
void | SetVideoFormatToPAL ()
void | SetVideoFormatToSECAM ()
void | SetVideoFormatToRS170 ()
void | SetVideoFormatToCCIR ()
void | SetVideoFormatToNonStandard ()
virtual int | GetVideoFormat ()
virtual void | SetVideoInput (int input)
void | SetVideoInputToMono ()
void | SetVideoInputToComposite ()
void | SetVideoInputToYC ()
void | SetVideoInputToRGB ()
void | SetVideoInputToDigital ()
virtual int | GetVideoInput ()
virtual void | SetContrastLevel (float contrast)
virtual float | GetContrastLevel ()
virtual void | SetBrightnessLevel (float brightness)
virtual float | GetBrightnessLevel ()
virtual void | SetHueLevel (float hue)
virtual float | GetHueLevel ()
virtual void | SetSaturationLevel (float saturation)
virtual float | GetSaturationLevel ()
virtual void | SetMILSystemType (int)
virtual int | GetMILSystemType ()
void | SetMILSystemTypeToMeteor ()
void | SetMILSystemTypeToMeteorII ()
void | SetMILSystemTypeToCorona ()
void | SetMILSystemTypeToPulsar ()
void | SetMILSystemTypeToMeteorIIDig ()
void | SetMILSystemTypeToGenesis ()
virtual void | SetMILSystemNumber (int)
virtual int | GetMILSystemNumber ()
virtual void | SetMILDigitizerDCF (const char *)
virtual char * | GetMILDigitizerDCF ()
virtual void | SetMILDigitizerNumber (int)
virtual int | GetMILDigitizerNumber ()
virtual void | SetMILErrorMessages (int yesno)
virtual void | MILErrorMessagesOn ()
virtual void | MILErrorMessagesOff ()
virtual int | GetMILErrorMessages ()
virtual void | SetMILAppID (long)
virtual long | GetMILAppID ()
virtual void | SetMILSysID (long)
virtual long | GetMILSysID ()
virtual long | GetMILDigID ()
virtual long | GetMILBufID ()

Static Public Methods

vtkMILVideoSource * | New ()

Protected Methods

vtkMILVideoSource ()
~vtkMILVideoSource ()
virtual void | AllocateMILDigitizer ()
virtual void | AllocateMILBuffer ()
virtual void * | MILInterpreterForSystem (int system)

Protected Attributes

char * | MILInterpreterDLL
int | VideoChannel
int | VideoInput
int | VideoInputForColor
int | VideoFormat
float | ContrastLevel
float | BrightnessLevel
float | HueLevel
float | SaturationLevel
int | FrameMaxSize [2]
long | MILAppID
long | MILSysID
long | MILDigID
long | MILBufID
int | MILSystemType
int | MILSystemNumber
int | MILDigitizerNumber
char * | MILDigitizerDCF
int | MILErrorMessages
int | MILAppInternallyAllocated
int | MILSysInternallyAllocated
int | FatalMILError

Detailed Description

Matrox Imaging Library frame grabbers.

Date:
2002/01/22 15:30:35
Revision:
1.16

vtkMILVideoSource provides an interface to Matrox Meteor, MeteorII and Corona video digitizers through the Matrox Imaging Library interface. In order to use this class, you must link VTK with mil.lib, MIL version 5.0 or higher is required.

See also:
vtkWin32VideoSource vtkVideoSource
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (99%)

Definition at line 66 of file vtkMILVideoSource.h.

Constructor & Destructor Documentation

vtkMILVideoSource::vtkMILVideoSource ( ) [protected]

vtkMILVideoSource::~vtkMILVideoSource ( ) [protected]

Member Function Documentation

vtkMILVideoSource* vtkMILVideoSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVideoSource.

vtkMILVideoSource::vtkTypeRevisionMacro | ( | vtkMILVideoSource | ,
 |  | vtkVideoSource |
 | ) |

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::Record ( ) [virtual]

Standard VCR functionality: Record incoming video.

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::Play ( ) [virtual]

Standard VCR functionality: Play recorded video.

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::Stop ( ) [virtual]

Standard VCR functionality: Stop recording or playing.

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::Grab ( ) [virtual]

Grab a single video frame.

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::SetFrameSize | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) | [virtual]

Request a particular frame size (set the third value to 1).

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::SetOutputFormat ( int format ) [virtual]

Request a particular output format (default: VTK_RGB).

Reimplemented from vtkVideoSource.

virtual void vtkMILVideoSource::SetVideoChannel ( int channel ) [virtual]

Set/Get the video channel

virtual int vtkMILVideoSource::GetVideoChannel ( ) [virtual]

Set/Get the video channel

virtual void vtkMILVideoSource::SetVideoFormat ( int format ) [virtual]

Set/Get the video format

void vtkMILVideoSource::SetVideoFormatToNTSC ( ) [inline]

Set/Get the video format

Definition at line 100 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoFormatToPAL ( ) [inline]

Set/Get the video format

Definition at line 101 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoFormatToSECAM ( ) [inline]

Set/Get the video format

Definition at line 102 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoFormatToRS170 ( ) [inline]

Set/Get the video format

Definition at line 103 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoFormatToCCIR ( ) [inline]

Set/Get the video format

Definition at line 104 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoFormatToNonStandard ( ) [inline]

Set/Get the video format

Definition at line 105 of file vtkMILVideoSource.h.

virtual int vtkMILVideoSource::GetVideoFormat ( ) [virtual]

Set/Get the video format

virtual void vtkMILVideoSource::SetVideoInput ( int input ) [virtual]

Set/Get the video input

void vtkMILVideoSource::SetVideoInputToMono ( ) [inline]

Set/Get the video input

Definition at line 113 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoInputToComposite ( ) [inline]

Set/Get the video input

Definition at line 114 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoInputToYC ( ) [inline]

Set/Get the video input

Definition at line 115 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoInputToRGB ( ) [inline]

Set/Get the video input

Definition at line 116 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetVideoInputToDigital ( ) [inline]

Set/Get the video input

Definition at line 117 of file vtkMILVideoSource.h.

virtual int vtkMILVideoSource::GetVideoInput ( ) [virtual]

Set/Get the video input

virtual void vtkMILVideoSource::SetContrastLevel ( float contrast ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual float vtkMILVideoSource::GetContrastLevel ( ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual void vtkMILVideoSource::SetBrightnessLevel ( float brightness ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual float vtkMILVideoSource::GetBrightnessLevel ( ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual void vtkMILVideoSource::SetHueLevel ( float hue ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual float vtkMILVideoSource::GetHueLevel ( ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual void vtkMILVideoSource::SetSaturationLevel ( float saturation ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual float vtkMILVideoSource::GetSaturationLevel ( ) [virtual]

Set/Get the video levels: the valid ranges are: Contrast [0.0,2.0] Brighness [0.0,255.0] Hue [-0.5,0.5] Saturation [0.0,2.0]

virtual void vtkMILVideoSource::SetMILSystemType ( int ) [virtual]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

virtual int vtkMILVideoSource::GetMILSystemType ( ) [virtual]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

void vtkMILVideoSource::SetMILSystemTypeToMeteor ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 139 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetMILSystemTypeToMeteorII ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 140 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetMILSystemTypeToCorona ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 141 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetMILSystemTypeToPulsar ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 142 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetMILSystemTypeToMeteorIIDig ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 143 of file vtkMILVideoSource.h.

void vtkMILVideoSource::SetMILSystemTypeToGenesis ( ) [inline]

Set the system which you want use. If you don't specify a system, then an attempt will be made to autodetect your system.

Definition at line 144 of file vtkMILVideoSource.h.

virtual void vtkMILVideoSource::SetMILSystemNumber ( int ) [virtual]

Set the system number if you have multiple systems of the same type

virtual int vtkMILVideoSource::GetMILSystemNumber ( ) [virtual]

Set the system number if you have multiple systems of the same type

virtual void vtkMILVideoSource::SetMILDigitizerDCF ( const char * ) [virtual]

Set the DCF filename for non-standard video formats

virtual char* vtkMILVideoSource::GetMILDigitizerDCF ( ) [virtual]

Set the DCF filename for non-standard video formats

virtual void vtkMILVideoSource::SetMILDigitizerNumber ( int ) [virtual]

Set the digitizer number for systems with multiple digitizers

virtual int vtkMILVideoSource::GetMILDigitizerNumber ( ) [virtual]

Set the digitizer number for systems with multiple digitizers

virtual void vtkMILVideoSource::SetMILErrorMessages ( int yesno ) [virtual]

Set whether to display MIL error messages (default on)

virtual void vtkMILVideoSource::MILErrorMessagesOn ( ) [virtual]

Set whether to display MIL error messages (default on)

virtual void vtkMILVideoSource::MILErrorMessagesOff ( ) [virtual]

Set whether to display MIL error messages (default on)

virtual int vtkMILVideoSource::GetMILErrorMessages ( ) [virtual]

Set whether to display MIL error messages (default on)

virtual void vtkMILVideoSource::SetMILAppID ( long ) [virtual]

Allows fine-grained control

virtual long vtkMILVideoSource::GetMILAppID ( ) [virtual]

Allows fine-grained control

virtual void vtkMILVideoSource::SetMILSysID ( long ) [virtual]

Allows fine-grained control

virtual long vtkMILVideoSource::GetMILSysID ( ) [virtual]

Allows fine-grained control

virtual long vtkMILVideoSource::GetMILDigID ( ) [virtual]

Allows fine-grained control

virtual long vtkMILVideoSource::GetMILBufID ( ) [virtual]

Allows fine-grained control

void vtkMILVideoSource::Initialize ( ) [virtual]

Initialize the driver (this is called automatically when the first grab is done).

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::ReleaseSystemResources ( ) [virtual]

Free the driver (this is called automatically inside the destructor).

Reimplemented from vtkVideoSource.

void vtkMILVideoSource::InternalGrab ( ) [virtual]

The internal function which actually does the grab. You will definitely want to override this if you develop a vtkVideoSource subclass.

Reimplemented from vtkVideoSource.

virtual void vtkMILVideoSource::AllocateMILDigitizer ( ) [protected, virtual]

virtual void vtkMILVideoSource::AllocateMILBuffer ( ) [protected, virtual]

virtual void* vtkMILVideoSource::MILInterpreterForSystem ( int system ) [protected, virtual]

Member Data Documentation

void* vtkMILVideoSource::OldHookFunction

For internal use only

Definition at line 191 of file vtkMILVideoSource.h.

void* vtkMILVideoSource::OldUserDataPtr

Definition at line 192 of file vtkMILVideoSource.h.

int vtkMILVideoSource::FrameCounter

Definition at line 193 of file vtkMILVideoSource.h.

int vtkMILVideoSource::ForceGrab

Definition at line 194 of file vtkMILVideoSource.h.

char* vtkMILVideoSource::MILInterpreterDLL [protected]

Definition at line 206 of file vtkMILVideoSource.h.

int vtkMILVideoSource::VideoChannel [protected]

Definition at line 208 of file vtkMILVideoSource.h.

int vtkMILVideoSource::VideoInput [protected]

Definition at line 209 of file vtkMILVideoSource.h.

int vtkMILVideoSource::VideoInputForColor [protected]

Definition at line 210 of file vtkMILVideoSource.h.

int vtkMILVideoSource::VideoFormat [protected]

Definition at line 211 of file vtkMILVideoSource.h.

float vtkMILVideoSource::ContrastLevel [protected]

Definition at line 213 of file vtkMILVideoSource.h.

float vtkMILVideoSource::BrightnessLevel [protected]

Definition at line 214 of file vtkMILVideoSource.h.

float vtkMILVideoSource::HueLevel [protected]

Definition at line 215 of file vtkMILVideoSource.h.

float vtkMILVideoSource::SaturationLevel [protected]

Definition at line 216 of file vtkMILVideoSource.h.

int vtkMILVideoSource::FrameMaxSize[2] [protected]

Definition at line 218 of file vtkMILVideoSource.h.

long vtkMILVideoSource::MILAppID [protected]

Definition at line 220 of file vtkMILVideoSource.h.

long vtkMILVideoSource::MILSysID [protected]

Definition at line 221 of file vtkMILVideoSource.h.

long vtkMILVideoSource::MILDigID [protected]

Definition at line 222 of file vtkMILVideoSource.h.

long vtkMILVideoSource::MILBufID [protected]

Definition at line 223 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILSystemType [protected]

Definition at line 227 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILSystemNumber [protected]

Definition at line 228 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILDigitizerNumber [protected]

Definition at line 230 of file vtkMILVideoSource.h.

char* vtkMILVideoSource::MILDigitizerDCF [protected]

Definition at line 231 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILErrorMessages [protected]

Definition at line 233 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILAppInternallyAllocated [protected]

Definition at line 235 of file vtkMILVideoSource.h.

int vtkMILVideoSource::MILSysInternallyAllocated [protected]

Definition at line 236 of file vtkMILVideoSource.h.

int vtkMILVideoSource::FatalMILError [protected]

Definition at line 238 of file vtkMILVideoSource.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkMILVideoSource.h
Generated on Mon Mar 25 01:25:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPICommunicator Class Reference

Class for creating user defined MPI communicators. More...

#include <vtkMPICommunicator.h>

Inheritance diagram for vtkMPICommunicator:

[legend]
Collaboration diagram for vtkMPICommunicator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMPICommunicator, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
int | Initialize (vtkMPICommunicator *mpiComm, vtkMPIGroup *group)
virtual int | Send (int *data, int length, int remoteProcessId, int tag)
virtual int | Send (unsigned long *data, int length, int remoteProcessId, int tag)
virtual int | Send (char *data, int length, int remoteProcessId, int tag)
virtual int | Send (unsigned char *data, int length, int remoteProcessId, int tag)
virtual int | Send (float *data, int length, int remoteProcessId, int tag)
virtual int | Send (double *data, int length, int remoteProcessId, int tag)
virtual int | Send (vtkDataObject *data, int remoteProcessId, int tag)
virtual int | Send (vtkDataArray *data, int remoteProcessId, int tag)
int | NoBlockSend (int *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockSend (unsigned long *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockSend (char *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockSend (float *data, int length, int remoteProcessId, int tag, Request &req)
virtual int | Receive (int *data, int length, int remoteProcessId, int tag)
virtual int | Receive (unsigned long *data, int length, int remoteProcessId, int tag)
virtual int | Receive (char *data, int length, int remoteProcessId, int tag)
virtual int | Receive (unsigned char *data, int length, int remoteProcessId, int tag)
virtual int | Receive (float *data, int length, int remoteProcessId, int tag)
virtual int | Receive (double *data, int length, int remoteProcessId, int tag)
virtual int | Receive (vtkDataObject *data, int remoteProcessId, int tag)
virtual int | Receive (vtkDataArray *data, int remoteProcessId, int tag)
int | NoBlockReceive (int *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockReceive (unsigned long *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockReceive (char *data, int length, int remoteProcessId, int tag, Request &req)
int | NoBlockReceive (float *data, int length, int remoteProcessId, int tag, Request &req)

Static Public Methods

vtkMPICommunicator * | New ()
vtkMPICommunicator * | GetWorldCommunicator ()

Protected Methods

virtual void | SetGroup (vtkMPIGroup *)
void | InitializeCopy (vtkMPICommunicator *source)
void | CopyFrom (vtkMPICommunicator *source)
void | Duplicate (vtkMPICommunicator *source)
vtkMPICommunicator ()
~vtkMPICommunicator ()
virtual void | SetKeepHandle (int)
virtual void | KeepHandleOn ()
virtual void | KeepHandleOff ()

Protected Attributes

MPI_Comm * | Handle
vtkMPIGroup * Group
int | Initialized
int | KeepHandle

Static Protected Attributes

vtkMPICommunicator * | WorldCommunicator

Friends

class | vtkMPIController

Detailed Description

Class for creating user defined MPI communicators.

Date:
2002/01/22 15:34:35
Revision:
1.16

This class can be used to create user defined MPI communicators. The actual creation (with MPI_Comm_create) occurs in Initialize which takes as arguments a super-communicator and a group of process ids. The new communicator is created by including the processes contained in the group. The global communicator (equivalent to MPI_COMM_WORLD) can be obtained using the class method GetWorldCommunicator. It is important to note that this communicator should not be used on the processes not contained in the group. For example, if the group contains processes 0 and 1, controller->SetCommunicator(communicator) would cause an MPI error on any other process.

See also:
vtkMPIController vtkMPIGroup
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (92%)
Tests:
vtkMPICommunicator (Tests)

Definition at line 57 of file vtkMPICommunicator.h.

Constructor & Destructor Documentation

vtkMPICommunicator::vtkMPICommunicator ( ) [protected]

vtkMPICommunicator::~vtkMPICommunicator ( ) [protected]

Member Function Documentation

vtkMPICommunicator::vtkTypeRevisionMacro | ( | vtkMPICommunicator | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkCommunicator.

vtkMPICommunicator* vtkMPICommunicator::New ( ) [static]

Creates an empty communicator.

Reimplemented from vtkObject.

vtkMPICommunicator* vtkMPICommunicator::GetWorldCommunicator ( ) [static]

Returns the singleton which behaves as the global communicator (MPI_COMM_WORLD)

virtual void vtkMPICommunicator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCommunicator.

int vtkMPICommunicator::Initialize | ( | vtkMPICommunicator * | mpiComm,
 |  | vtkMPIGroup * | group
 | ) |

Used to initialize (i.e. create the underlying MPI_Comm) the communicator. Note that group is also stored in an instance variable (the reference count of group is increased by 1). group->Delete() can be safely invoked after this.

virtual int vtkMPICommunicator::Send | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Send | ( | vtkDataObject * | data,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [inline, virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

Definition at line 96 of file vtkMPICommunicator.h.

virtual int vtkMPICommunicator::Send | ( | vtkDataArray * | data,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [inline, virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

Definition at line 98 of file vtkMPICommunicator.h.

int vtkMPICommunicator::NoBlockSend | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method sends data to another process (non-blocking). Tag eliminates ambiguity when multiple sends or receives exist in the same process. The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message.

int vtkMPICommunicator::NoBlockSend | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

int vtkMPICommunicator::NoBlockSend | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

int vtkMPICommunicator::NoBlockSend | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

virtual int vtkMPICommunicator::Receive | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkMPICommunicator::Receive | ( | vtkDataObject * | data,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [inline, virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

Definition at line 149 of file vtkMPICommunicator.h.

virtual int vtkMPICommunicator::Receive | ( | vtkDataArray * | data,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [inline, virtual]

This method receives data from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

Definition at line 151 of file vtkMPICommunicator.h.

int vtkMPICommunicator::NoBlockReceive | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method receives data from a corresponding send (non-blocking). The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message.

int vtkMPICommunicator::NoBlockReceive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method receives data from a corresponding send. It blocks until the receive is finished.

int vtkMPICommunicator::NoBlockReceive | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method receives data from a corresponding send. It blocks until the receive is finished.

int vtkMPICommunicator::NoBlockReceive | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | Request & | req
 | ) |

This method receives data from a corresponding send. It blocks until the receive is finished.

virtual void vtkMPICommunicator::SetGroup ( vtkMPIGroup * ) [protected, virtual]

virtual void vtkMPICommunicator::SetKeepHandle ( int ) [protected, virtual]

KeepHandle is normally off. This means that the MPI communicator handle will be freed at the destruction of the object. However, if the handle was copied from another object (via CopyFrom() not Duplicate()), this has to be turned on otherwise the handle will be freed multiple times causing MPI failure. The alternative to this is using reference counting but it is unnecessarily complicated for this case.

virtual void vtkMPICommunicator::KeepHandleOn ( ) [protected, virtual]

KeepHandle is normally off. This means that the MPI communicator handle will be freed at the destruction of the object. However, if the handle was copied from another object (via CopyFrom() not Duplicate()), this has to be turned on otherwise the handle will be freed multiple times causing MPI failure. The alternative to this is using reference counting but it is unnecessarily complicated for this case.

virtual void vtkMPICommunicator::KeepHandleOff ( ) [protected, virtual]

KeepHandle is normally off. This means that the MPI communicator handle will be freed at the destruction of the object. However, if the handle was copied from another object (via CopyFrom() not Duplicate()), this has to be turned on otherwise the handle will be freed multiple times causing MPI failure. The alternative to this is using reference counting but it is unnecessarily complicated for this case.

void vtkMPICommunicator::InitializeCopy ( vtkMPICommunicator * source ) [protected]

void vtkMPICommunicator::CopyFrom ( vtkMPICommunicator * source ) [protected]

Copies all the attributes of source, deleting previously stored data. The MPI communicator handle is also copied. Normally, this should not be needed. It is used during the construction of a new communicator for copying the world communicator, keeping the same context.

void vtkMPICommunicator::Duplicate ( vtkMPICommunicator * source ) [protected]

Copies all the attributes of source, deleting previously stored data EXCEPT the MPI communicator handle which is duplicated with MPI_Comm_dup(). Therefore, although the processes in the communicator remain the same, a new context is created. This prevents the two communicators from intefering with each other during message send/receives even if the tags are the same.

Friends And Related Function Documentation

friend class vtkMPIController [friend]

Definition at line 170 of file vtkMPICommunicator.h.

Member Data Documentation

vtkMPICommunicator* vtkMPICommunicator::WorldCommunicator [static, protected]

Definition at line 190 of file vtkMPICommunicator.h.

MPI_Comm* vtkMPICommunicator::Handle [protected]

Definition at line 208 of file vtkMPICommunicator.h.

vtkMPIGroup* vtkMPICommunicator::Group [protected]

Definition at line 209 of file vtkMPICommunicator.h.

int vtkMPICommunicator::Initialized [protected]

Definition at line 211 of file vtkMPICommunicator.h.

int vtkMPICommunicator::KeepHandle [protected]

Definition at line 212 of file vtkMPICommunicator.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMPICommunicator.h
Generated on Mon Mar 25 01:25:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPICommunicator::Request Class Reference

#include <vtkMPICommunicator.h>

Collaboration diagram for vtkMPICommunicator::Request:

[legend]
List of all members.

Public Methods

int | Test ()
void | Cancel ()
void | Wait ()

Public Attributes

MPI_Request | Req

Member Function Documentation

int vtkMPICommunicator::Request::Test ( )

void vtkMPICommunicator::Request::Cancel ( )

void vtkMPICommunicator::Request::Wait ( )

Member Data Documentation

MPI_Request vtkMPICommunicator::Request::Req

Definition at line 109 of file vtkMPICommunicator.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMPICommunicator.h
Generated on Mon Mar 25 01:25:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIController Class Reference

Process communication using MPI. More...

#include <vtkMPIController.h>

Inheritance diagram for vtkMPIController:

[legend]
Collaboration diagram for vtkMPIController:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMPIController, vtkMultiProcessController)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize (int *argc, char ***arcv)
virtual void | Finalize ()
virtual void | SingleMethodExecute ()
virtual void | MultipleMethodExecute ()
void | Barrier ()
virtual void | CreateOutputWindow ()
void | SetCommunicator (vtkMPICommunicator *comm)
int | NoBlockSend (int *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockSend (unsigned long *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockSend (char *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockSend (float *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockReceive (int *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockReceive (unsigned long *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockReceive (char *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)
int | NoBlockReceive (float *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req)

Static Public Methods

vtkMPIController * | New ()
char * | ErrorString (int err)
const char * | GetProcessorName ()

Protected Methods

vtkMPIController ()
~vtkMPIController ()
int | InitializeNumberOfProcesses ()
void | InitializeCommunicator (vtkMPICommunicator *comm)
void | InitializeRMICommunicator ()

Static Protected Attributes

vtkMPICommunicator * WorldRMICommunicator
int | Initialized
char | ProcessorName [MPI_MAX_PROCESSOR_NAME]

Detailed Description

Process communication using MPI.

Date:
2002/01/28 18:37:10
Revision:
1.10

vtkMPIController is a concrete class which implements the abstract multi-process control methods defined in vtkMultiProcessController using MPI (Message Passing Interface) cf. Using MPI / Portable Parallel Programming with the Message-Passing Interface, Gropp et al, MIT Press. It also provide functionality specific to MPI and not present in vtkMultiProcessController. Before any MPI communication can occur Initialize() must be called by all processes. It is required to be called once, controllers created after this need not call Initialize(). At the end of the program Finalize() must be called by all processes. The use of user-defined communicators are supported with vtkMPICommunicator and vtkMPIGroup. Note that a duplicate of the user defined communicator is used for internal communications (RMIs). This communicator has the same properties as the user one except that it has a new context which prevents the two communicators from interfering with each other.

See also:
vtkOutputPort vtkInputPort vtkMultiProcessController vtkMPICommunicator vtkMPIGroup
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (96%)
Examples:
vtkMPIController (Examples)
Tests:
vtkMPIController (Tests)

Definition at line 67 of file vtkMPIController.h.

Constructor & Destructor Documentation

vtkMPIController::vtkMPIController ( ) [protected]

vtkMPIController::~vtkMPIController ( ) [protected]

Member Function Documentation

vtkMPIController* vtkMPIController::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkMultiProcessController.

vtkMPIController::vtkTypeRevisionMacro | ( | vtkMPIController | ,
 |  | vtkMultiProcessController |
 | ) |

Reimplemented from vtkMultiProcessController.

void vtkMPIController::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMultiProcessController.

virtual void vtkMPIController::Initialize | ( | int * | argc,
 |  | char *** | arcv
 | ) | [virtual]

This method is for setting up the processes. It needs to be called only once during program execution. Calling it more than once will have no effect. Controllers created after this call will be initialized automatically (i.e. they will have the proper LocalProcessId and NumberOfProcesses). The addresses of argc and argv should be passed to this method otherwise command line arguments will not be correct (because usually MPI implementations add their own arguments during startup).

virtual void vtkMPIController::Finalize ( ) [virtual]

This method is for cleaning up and has to be called before the end of the program if MPI was initialized with Initialize()

Reimplemented from vtkMultiProcessController.

virtual void vtkMPIController::SingleMethodExecute ( ) [virtual]

Execute the SingleMethod (as define by SetSingleMethod) using this->NumberOfProcesses processes.

Reimplemented from vtkMultiProcessController.

virtual void vtkMPIController::MultipleMethodExecute ( ) [virtual]

Execute the MultipleMethods (as define by calling SetMultipleMethod for each of the required this->NumberOfProcesses methods) using this->NumberOfProcesses processes.

Reimplemented from vtkMultiProcessController.

void vtkMPIController::Barrier ( ) [virtual]

This method can be used to synchronize MPI processes in the current communicator. This uses the user communicator.

Reimplemented from vtkMultiProcessController.

virtual void vtkMPIController::CreateOutputWindow ( ) [virtual]

This method can be used to tell the controller to create a special output window in which all messages are preceded by the process id.

Reimplemented from vtkMultiProcessController.

char* vtkMPIController::ErrorString ( int err ) [static]

Given an MPI error code, return a string which contains an error message. This string has to be freed by the user.

void vtkMPIController::SetCommunicator ( vtkMPICommunicator * comm )

MPIController uses this communicator in all sends and receives. By default, MPI_COMM_WORLD is used. THIS SHOULD ONLY BE CALLED ON THE PROCESSES INCLUDED IN THE COMMUNICATOR. FOR EXAMPLE, IF THE COMMUNICATOR CONTAINES PROCESSES 0 AND 1, INVOKING THIS METHOD ON ANY OTHER PROCESS WILL CAUSE AN MPI ERROR AND POSSIBLY LEAD TO A CRASH.

int vtkMPIController::NoBlockSend | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method sends data to another process (non-blocking). Tag eliminates ambiguity when multiple sends or receives exist in the same process. The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 127 of file vtkMPIController.h.

int vtkMPIController::NoBlockSend | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method sends data to another process (non-blocking). Tag eliminates ambiguity when multiple sends or receives exist in the same process. The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 131 of file vtkMPIController.h.

int vtkMPIController::NoBlockSend | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method sends data to another process (non-blocking). Tag eliminates ambiguity when multiple sends or receives exist in the same process. The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 135 of file vtkMPIController.h.

int vtkMPIController::NoBlockSend | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method sends data to another process (non-blocking). Tag eliminates ambiguity when multiple sends or receives exist in the same process. The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 139 of file vtkMPIController.h.

int vtkMPIController::NoBlockReceive | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method receives data from a corresponding send (non-blocking). The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 150 of file vtkMPIController.h.

int vtkMPIController::NoBlockReceive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method receives data from a corresponding send (non-blocking). The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 154 of file vtkMPIController.h.

int vtkMPIController::NoBlockReceive | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method receives data from a corresponding send (non-blocking). The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 159 of file vtkMPIController.h.

int vtkMPIController::NoBlockReceive | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag,
 |  | vtkMPICommunicator::Request & | req
 | ) | [inline]

This method receives data from a corresponding send (non-blocking). The last argument, vtkMPICommunicator::Request& req can later be used (with req.Test() ) to test the success of the message. Note: These methods delegate to the communicator

Definition at line 163 of file vtkMPIController.h.

const char* vtkMPIController::GetProcessorName ( ) [static]

int vtkMPIController::InitializeNumberOfProcesses ( ) [protected]

void vtkMPIController::InitializeCommunicator ( vtkMPICommunicator * comm ) [protected]

void vtkMPIController::InitializeRMICommunicator ( ) [protected]

Member Data Documentation

vtkMPICommunicator* vtkMPIController::WorldRMICommunicator [static, protected]

Definition at line 195 of file vtkMPIController.h.

int vtkMPIController::Initialized [static, protected]

Definition at line 198 of file vtkMPIController.h.

char vtkMPIController::ProcessorName[MPI_MAX_PROCESSOR_NAME] [static, protected]

Definition at line 200 of file vtkMPIController.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMPIController.h
Generated on Mon Mar 25 01:25:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIEventLog Class Reference

Class for logging and timing. More...

#include <vtkMPIEventLog.h>

Inheritance diagram for vtkMPIEventLog:

[legend]
Collaboration diagram for vtkMPIEventLog:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMPIEventLog, vtkObject)
int | SetDescription (const char *name, const char *desc)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
void | StartLogging ()
void | StopLogging ()

Static Public Methods

vtkMPIEventLog * | New ()
void | InitializeLogging ()
void | FinalizeLogging (const char *fileName)

Protected Methods

vtkMPIEventLog ()
~vtkMPIEventLog ()

Protected Attributes

int | Active
int | BeginId
int | EndId

Static Protected Attributes

int | LastEventId

Detailed Description

Class for logging and timing.

Date:
2002/01/22 15:34:37
Revision:
1.8

This class is wrapper around MPE event logging functions (available from Argonne National Lab/Missippi State University). It allows users to create events with names and log them. Different log file formats can be generated by changing MPE's configuration. Some of these formats are binary (for examples SLOG and CLOG) and can be analyzed with viewers from ANL. ALOG is particularly useful since it is text based and can be processed with simple scripts.

See also:
vtkTimerLog vtkMPIController vtkMPICommunicator
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (98%)

Definition at line 48 of file vtkMPIEventLog.h.

Constructor & Destructor Documentation

vtkMPIEventLog::vtkMPIEventLog ( ) [protected]

vtkMPIEventLog::~vtkMPIEventLog ( ) [protected]

Member Function Documentation

vtkMPIEventLog::vtkTypeRevisionMacro | ( | vtkMPIEventLog | ,
 |  | vtkObject |
 | ) |

vtkMPIEventLog* vtkMPIEventLog::New ( ) [static]

Construct a vtkMPIEventLog with the following initial state: Processes = 0, MaximumNumberOfProcesses = 0.

Reimplemented from vtkObject.

int vtkMPIEventLog::SetDescription | ( | const char * | name,
 |  | const char * | desc
 | ) |

Used to initialize the underlying mpe event. HAS TO BE CALLED BY ALL PROCESSES before any event logging is done. It takes a name and a description for the graphical representation, for example, "red:vlines3". See mpe documentation for details. Returns 0 on MPI failure (or aborts depending on MPI error handlers)

void vtkMPIEventLog::InitializeLogging ( ) [static]

These methods have to be called once on all processors before and after invoking any logging events. The name of the logfile is given by fileName. See mpe documentation for file formats.

void vtkMPIEventLog::FinalizeLogging ( const char * fileName ) [static]

These methods have to be called once on all processors before and after invoking any logging events. The name of the logfile is given by fileName. See mpe documentation for file formats.

void vtkMPIEventLog::StartLogging ( )

Issue start and stop events for this log entry.

void vtkMPIEventLog::StopLogging ( )

Issue start and stop events for this log entry.

virtual void vtkMPIEventLog::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Member Data Documentation

int vtkMPIEventLog::LastEventId [static, protected]

Definition at line 87 of file vtkMPIEventLog.h.

int vtkMPIEventLog::Active [protected]

Definition at line 88 of file vtkMPIEventLog.h.

int vtkMPIEventLog::BeginId [protected]

Definition at line 89 of file vtkMPIEventLog.h.

int vtkMPIEventLog::EndId [protected]

Definition at line 90 of file vtkMPIEventLog.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMPIEventLog.h
Generated on Mon Mar 25 01:25:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMPIGroup Class Reference

Class for creating MPI groups. More...

#include <vtkMPIGroup.h>

Inheritance diagram for vtkMPIGroup:

[legend]
Collaboration diagram for vtkMPIGroup:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMPIGroup, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
void | Initialize (vtkMPIController *controller)
int | AddProcessId (int processId)
void | RemoveProcessId (int processId)
int | FindProcessId (int processId)
int | GetProcessId (int pos)
void | CopyProcessIdsFrom (vtkMPIGroup *group)
int | GetNumberOfProcessIds ()

Static Public Methods

vtkMPIGroup * | New ()

Protected Methods

void | CopyFrom (vtkMPIGroup *group)
void | Initialize (int numProcIds)
vtkMPIGroup ()
~vtkMPIGroup ()

Protected Attributes

int * | ProcessIds
int | MaximumNumberOfProcessIds
int | Initialized
int | CurrentPosition

Friends

class | vtkMPICommunicator

Detailed Description

Class for creating MPI groups.

Date:
2002/01/22 15:34:38
Revision:
1.7

This class is used to create MPI groups. A vtkMPIGroup object has to be initialized by passing the controller. Then the group can be modified by adding, removing ids and copying the contents of another group.

See also:
vtkMPIController vtkMPICommunicator
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (97%)
Tests:
vtkMPIGroup (Tests)

Definition at line 49 of file vtkMPIGroup.h.

Constructor & Destructor Documentation

vtkMPIGroup::vtkMPIGroup ( ) [protected]

vtkMPIGroup::~vtkMPIGroup ( ) [protected]

Member Function Documentation

vtkMPIGroup::vtkTypeRevisionMacro | ( | vtkMPIGroup | ,
 |  | vtkObject |
 | ) |

vtkMPIGroup* vtkMPIGroup::New ( ) [static]

Construct a vtkMPIGroup with the following initial state: Processes = 0, MaximumNumberOfProcesses = 0.

Reimplemented from vtkObject.

virtual void vtkMPIGroup::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkMPIGroup::Initialize ( vtkMPIController * controller )

Allocate memory for N process ids where N = controller->NumberOfProcesses

int vtkMPIGroup::AddProcessId ( int processId )

Add a process id to the end of the list (if it is not already in the group). Returns non-zero on success. This will not add a process id >= MaximumNumberOfProcessIds.

void vtkMPIGroup::RemoveProcessId ( int processId )

Remove the given process id from the list and shift all ids, starting from the position of the removed id, left by one.

int vtkMPIGroup::FindProcessId ( int processId )

Find the location of a process id in the group. Returns -1 if the process id is not on the list.

int vtkMPIGroup::GetProcessId ( int pos )

Get the process id at position pos. Returns -1 if pos >= max. available pos.

void vtkMPIGroup::CopyProcessIdsFrom ( vtkMPIGroup * group )

Copy the process ids from a given group. This will copy N ids, where N is the smallest MaximumNumberOfProcessIds.

int vtkMPIGroup::GetNumberOfProcessIds ( ) [inline]

Returns the number of ids currently stored.

Definition at line 89 of file vtkMPIGroup.h.

void vtkMPIGroup::CopyFrom ( vtkMPIGroup * group ) [protected]

Copies all the information from group, erasing previously stored data. Similar to copy constructor

void vtkMPIGroup::Initialize ( int numProcIds ) [protected]

Allocate memory for numProcIds process ids

Friends And Related Function Documentation

friend class vtkMPICommunicator [friend]

Definition at line 97 of file vtkMPIGroup.h.

Member Data Documentation

int* vtkMPIGroup::ProcessIds [protected]

Definition at line 110 of file vtkMPIGroup.h.

int vtkMPIGroup::MaximumNumberOfProcessIds [protected]

Definition at line 111 of file vtkMPIGroup.h.

int vtkMPIGroup::Initialized [protected]

Definition at line 112 of file vtkMPIGroup.h.

int vtkMPIGroup::CurrentPosition [protected]

Definition at line 113 of file vtkMPIGroup.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMPIGroup.h
Generated on Mon Mar 25 01:25:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiProcessController Class Reference

Multiprocessing communication superclass. More...

#include <vtkMultiProcessController.h>

Inheritance diagram for vtkMultiProcessController:

[legend]
Collaboration diagram for vtkMultiProcessController:

[legend]
List of all members.

Public Types

enum Consts {
MAX_PROCESSES = 8192, ANY_SOURCE = -1, INVALID_SOURCE = -2, RMI_TAG = 315167,
RMI_ARG_TAG = 315168, BREAK_RMI_TAG = 239954
}

Public Methods

vtkTypeRevisionMacro (vtkMultiProcessController, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize (int *vtkNotUsed(argc), char ***vtkNotUsed(arcv))=0
virtual void | Finalize ()=0
virtual void | SingleMethodExecute ()=0
virtual void | MultipleMethodExecute ()=0
virtual int | GetLocalProcessId ()
virtual void | CreateOutputWindow ()=0
void | AddRMI (vtkRMIFunctionType, void *localArg, int tag)
void | TriggerRMI (int remoteProcessId, void *arg, int argLength, int tag)
void | TriggerBreakRMIs ()
void | ProcessRMIs ()
virtual void | Barrier ()=0
int | Send (int *data, int length, int remoteProcessId, int tag)
int | Send (unsigned long *data, int length, int remoteProcessId, int tag)
int | Send (char *data, int length, int remoteProcessId, int tag)
int | Send (unsigned char *data, int length, int remoteProcessId, int tag)
int | Send (float *data, int length, int remoteProcessId, int tag)
int | Send (double *data, int length, int remoteProcessId, int tag)
int | Send (vtkDataObject *data, int remoteId, int tag)
int | Send (vtkDataArray *data, int remoteId, int tag)
int | Receive (int *data, int length, int remoteProcessId, int tag)
int | Receive (unsigned long *data, int length, int remoteProcessId, int tag)
int | Receive (char *data, int length, int remoteProcessId, int tag)
int | Receive (unsigned char *data, int length, int remoteProcessId, int tag)
int | Receive (float *data, int length, int remoteProcessId, int tag)
int | Receive (double *data, int length, int remoteProcessId, int tag)
int | Receive (vtkDataObject *data, int remoteId, int tag)
int | Receive (vtkDataArray *data, int remoteId, int tag)
virtual void | SetNumberOfProcesses (int num)
virtual int | GetNumberOfProcesses ()
void | SetSingleMethod (vtkProcessFunctionType, void *data)
void | SetMultipleMethod (int index, vtkProcessFunctionType, void *data)
virtual void | SetForceDeepCopy (int)
virtual int | GetForceDeepCopy ()
virtual void | ForceDeepCopyOn ()
virtual void | ForceDeepCopyOff ()
void | RemoveRMI (vtkRMIFunctionType f, void *arg, int tag)
void | TriggerRMI (int remoteProcessId, char *arg, int tag)
void | TriggerRMI (int remoteProcessId, int tag)
virtual void | SetBreakFlag (int)
virtual int | GetBreakFlag ()
virtual vtkCommunicator * | GetCommunicator ()

Static Public Methods

vtkMultiProcessController * | New ()
vtkMultiProcessController * | GetGlobalController ()
void | SetGlobalController (vtkMultiProcessController *controller)

Protected Methods

vtkMultiProcessController ()
~vtkMultiProcessController ()
void | ProcessRMI (int remoteProcessId, void *arg, int argLength, int rmiTag)
virtual vtkMultiProcessController * | GetLocalController ()

Protected Attributes

int | MaximumNumberOfProcesses
int | NumberOfProcesses
int | LocalProcessId
vtkProcessFunctionType SingleMethod
void * | SingleData
vtkProcessFunctionType | MultipleMethod [MAX_PROCESSES]
void * | MultipleData [MAX_PROCESSES]
vtkCollection * RMIs
int | BreakFlag
int | ForceDeepCopy
vtkOutputWindow * OutputWindow
vtkCommunicator * Communicator
vtkCommunicator * RMICommunicator

Detailed Description

Multiprocessing communication superclass.

Date:
2002/03/18 20:47:40
Revision:
1.14

vtkMultiProcessController is used to control multiple processes/threads in a shared memory/distributed computing environment. It has methods for executing single/multiple method(s) on multiple processors, triggering registered callbacks (Remote Methods) (AddRMI(), TriggerRMI()) and communication. Please note that the communication is done using the communicator which is accessible to the user. Therefore it is possible to get the communicator with GetCommunicator() and use it to send and receive data. This is the encoured communication method. The internal (RMI) communications are done using a second internal communicator (called RMICommunicator). For the threaded controllers, this is identical to the user communicator. However, for the MPI controller, this is a communicator which shares the same process group as the user communicator but uses a different context. Therefore, the user and the internal communications can not interfere with each other (even if the same message tag is used).

See also:
vtkMPIController vtkThreadedController vtkInputPort vtkOutputPort vtkCommunicator vtkSharedMemoryCommunicator vtkMPICommunicator
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Lee, Jeff (10%)
  • Henderson, Amy (5%)
Examples:
vtkMultiProcessController (Examples)
Tests:
vtkMultiProcessController (Tests)

Definition at line 84 of file vtkMultiProcessController.h.

Member Enumeration Documentation

enum vtkMultiProcessController::Consts

Enumeration values:
MAX_PROCESSES
ANY_SOURCE
INVALID_SOURCE
RMI_TAG
RMI_ARG_TAG
BREAK_RMI_TAG

Reimplemented in vtkSocketController.

Definition at line 215 of file vtkMultiProcessController.h.

Constructor & Destructor Documentation

vtkMultiProcessController::vtkMultiProcessController ( ) [protected]

vtkMultiProcessController::~vtkMultiProcessController ( ) [protected]

Member Function Documentation

vtkMultiProcessController* vtkMultiProcessController::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

vtkMultiProcessController::vtkTypeRevisionMacro | ( | vtkMultiProcessController | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

void vtkMultiProcessController::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

virtual void vtkMultiProcessController::Initialize | ( | int *vtkNotUsed(argc) | ,
 |  | char ***vtkNotUsed(arcv) |
 | ) | [pure virtual]

This method is for setting up the processes. If a subclass needs to initialize process communication (i.e. MPI) it would over ride this method.

Referenced by vtkSocketController::Initialize().

virtual void vtkMultiProcessController::Finalize ( ) [pure virtual]

This method is for cleaning up. If a subclass needs to clean up process communication (i.e. MPI) it would over ride this method.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

virtual void vtkMultiProcessController::SetNumberOfProcesses ( int num ) [virtual]

Set the number of processes you will be using. This defaults to the maximum number available. If you set this to a value higher than the default, you will get an error.

Reimplemented in vtkSocketController.

virtual int vtkMultiProcessController::GetNumberOfProcesses ( ) [virtual]

Set the number of processes you will be using. This defaults to the maximum number available. If you set this to a value higher than the default, you will get an error.

void vtkMultiProcessController::SetSingleMethod | ( | vtkProcessFunctionType | ,
 |  | void * | data
 | ) |

Set the SingleMethod to f() and the UserData of the for the method to be executed by all of the processes when SingleMethodExecute is called. All the processes will start by calling this function.

virtual void vtkMultiProcessController::SingleMethodExecute ( ) [pure virtual]

Execute the SingleMethod (as define by SetSingleMethod) using this->NumberOfProcesses processes. This will only return when all the processes finish executing their methods.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

void vtkMultiProcessController::SetMultipleMethod | ( | int | index,
 |  | vtkProcessFunctionType | ,
 |  | void * | data
 | ) |

Set the MultipleMethod to f() and the UserData of the for the method to be executed by the process index when MultipleMethodExecute is called. This is for having each process start with a different function and data argument.

virtual void vtkMultiProcessController::MultipleMethodExecute ( ) [pure virtual]

Execute the MultipleMethods (as define by calling SetMultipleMethod for each of the required this->NumberOfProcesses methods) using this->NumberOfProcesses processes.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

virtual int vtkMultiProcessController::GetLocalProcessId ( ) [inline, virtual]

Tells you which process [0, NumProcess) you are in.

Reimplemented in vtkThreadedController.

Definition at line 138 of file vtkMultiProcessController.h.

vtkMultiProcessController* vtkMultiProcessController::GetGlobalController ( ) [static]

This convenience method returns the controller associated with the local process. It returns NULL until the processes are spawned. It is better if you hang on to the controller passed as an argument to the SingleMethod or MultipleMethod functions.

virtual void vtkMultiProcessController::CreateOutputWindow ( ) [pure virtual]

This method can be used to tell the controller to create a special output window in which all messages are preceded by the process id.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

virtual void vtkMultiProcessController::SetForceDeepCopy ( int ) [virtual]

By default, sending objects use shallow copy whenever possible. This flag forces the controller to use deep copies instead. This is necessary when asynchronous processing occurs (i.e. pipeline parallelism). This is only important when using vtkThreadedController.

virtual int vtkMultiProcessController::GetForceDeepCopy ( ) [virtual]

By default, sending objects use shallow copy whenever possible. This flag forces the controller to use deep copies instead. This is necessary when asynchronous processing occurs (i.e. pipeline parallelism). This is only important when using vtkThreadedController.

virtual void vtkMultiProcessController::ForceDeepCopyOn ( ) [virtual]

By default, sending objects use shallow copy whenever possible. This flag forces the controller to use deep copies instead. This is necessary when asynchronous processing occurs (i.e. pipeline parallelism). This is only important when using vtkThreadedController.

virtual void vtkMultiProcessController::ForceDeepCopyOff ( ) [virtual]

By default, sending objects use shallow copy whenever possible. This flag forces the controller to use deep copies instead. This is necessary when asynchronous processing occurs (i.e. pipeline parallelism). This is only important when using vtkThreadedController.

void vtkMultiProcessController::AddRMI | ( | vtkRMIFunctionType | ,
 |  | void * | localArg,
 |  | int | tag
 | ) |

Register remote method invocation in the receiving process which makes the call. It must have a unique tag as an RMI id. The vtkRMIFunctionType has several arguments: localArg (same as passed in), remoteArg, remoteArgLength (memory passed by process triggering the RMI), remoteProcessId.

void vtkMultiProcessController::RemoveRMI | ( | vtkRMIFunctionType | f,
 |  | void * | arg,
 |  | int | tag
 | ) | [inline]

Take an RMI away.

Definition at line 173 of file vtkMultiProcessController.h.

void vtkMultiProcessController::TriggerRMI | ( | int | remoteProcessId,
 |  | void * | arg,
 |  | int | argLength,
 |  | int | tag
 | ) |

A method to trigger a method invocation in another process.

void vtkMultiProcessController::TriggerBreakRMIs ( )

A conveniance method. Called on process 0 to break "ProcessRMIs" loop on all other processes.

void vtkMultiProcessController::TriggerRMI | ( | int | remoteProcessId,
 |  | char * | arg,
 |  | int | tag
 | ) | [inline]

Convenience method when the arg is a string.

Definition at line 187 of file vtkMultiProcessController.h.

void vtkMultiProcessController::TriggerRMI | ( | int | remoteProcessId,
 |  | int | tag
 | ) | [inline]

Convenience method when there is no argument.

Definition at line 193 of file vtkMultiProcessController.h.

void vtkMultiProcessController::ProcessRMIs ( )

Calling this method gives control to the controller to start processing RMIs.

virtual void vtkMultiProcessController::SetBreakFlag ( int ) [virtual]

Setting this flag to 1 will cause the ProcessRMIs loop to return. This also causes vtkUpStreamPorts to return from their WaitForUpdate loops.

virtual int vtkMultiProcessController::GetBreakFlag ( ) [virtual]

Setting this flag to 1 will cause the ProcessRMIs loop to return. This also causes vtkUpStreamPorts to return from their WaitForUpdate loops.

virtual vtkCommunicator* vtkMultiProcessController::GetCommunicator ( ) [virtual]

virtual void vtkMultiProcessController::Barrier ( ) [pure virtual]

This method can be used to synchronize processes/threads.

Reimplemented in vtkMPIController, vtkSocketController, and vtkThreadedController.

void vtkMultiProcessController::SetGlobalController ( vtkMultiProcessController * controller ) [static]

int vtkMultiProcessController::Send | ( | int * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Definition at line 349 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 362 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 376 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 389 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | float * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 402 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | double * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 415 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | vtkDataObject * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 323 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Send | ( | vtkDataArray * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 336 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | int * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

This method receives data from a corresponding send. It blocks until the receive is finished. It calls methods in "data" to communicate the sending data.

Definition at line 469 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 482 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 496 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 509 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | float * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 522 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | double * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 535 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | vtkDataObject * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 443 of file vtkMultiProcessController.h.

int vtkMultiProcessController::Receive | ( | vtkDataArray * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [inline]

Definition at line 456 of file vtkMultiProcessController.h.

void vtkMultiProcessController::ProcessRMI | ( | int | remoteProcessId,
 |  | void * | arg,
 |  | int | argLength,
 |  | int | rmiTag
 | ) | [protected]

virtual vtkMultiProcessController* vtkMultiProcessController::GetLocalController ( ) [protected, virtual]

Reimplemented in vtkThreadedController.

Member Data Documentation

int vtkMultiProcessController::MaximumNumberOfProcesses [protected]

Definition at line 274 of file vtkMultiProcessController.h.

int vtkMultiProcessController::NumberOfProcesses [protected]

Definition at line 275 of file vtkMultiProcessController.h.

int vtkMultiProcessController::LocalProcessId [protected]

Definition at line 277 of file vtkMultiProcessController.h.

vtkProcessFunctionType vtkMultiProcessController::SingleMethod [protected]

Definition at line 279 of file vtkMultiProcessController.h.

void* vtkMultiProcessController::SingleData [protected]

Definition at line 280 of file vtkMultiProcessController.h.

vtkProcessFunctionType vtkMultiProcessController::MultipleMethod[MAX_PROCESSES] [protected]

Definition at line 281 of file vtkMultiProcessController.h.

void* vtkMultiProcessController::MultipleData[MAX_PROCESSES] [protected]

Definition at line 282 of file vtkMultiProcessController.h.

vtkCollection* vtkMultiProcessController::RMIs [protected]

Definition at line 284 of file vtkMultiProcessController.h.

int vtkMultiProcessController::BreakFlag [protected]

Definition at line 288 of file vtkMultiProcessController.h.

int vtkMultiProcessController::ForceDeepCopy [protected]

Definition at line 298 of file vtkMultiProcessController.h.

vtkOutputWindow* vtkMultiProcessController::OutputWindow [protected]

Definition at line 300 of file vtkMultiProcessController.h.

vtkCommunicator* vtkMultiProcessController::Communicator [protected]

Definition at line 305 of file vtkMultiProcessController.h.

vtkCommunicator* vtkMultiProcessController::RMICommunicator [protected]

Definition at line 315 of file vtkMultiProcessController.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkMultiProcessController.h
Generated on Mon Mar 25 01:25:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiProcessLog Class Reference

Manages logs for multiple threads/processes. More...

#include <vtkMultiProcessLog.h>

Inheritance diagram for vtkMultiProcessLog:

[legend]
Collaboration diagram for vtkMultiProcessLog:

[legend]
List of all members.

Public Methods

const char * | GetClassName ()

Static Public Methods

vtkMultiProcessLog * | New ()
void | DumpLog (char *filename)
void | SetTimerLog (vtkThreadSafeLog *log)
vtkThreadSafeLog * GetTimerLog ()

Protected Methods

vtkMultiProcessLog ()
~vtkMultiProcessLog ()

Detailed Description

Manages logs for multiple threads/processes.

Date:
2002/01/22 15:34:41
Revision:
1.5

Needs to be thread safe in the future (vtkTimerLog is not).

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (98%)

Definition at line 41 of file vtkMultiProcessLog.h.

Constructor & Destructor Documentation

vtkMultiProcessLog::vtkMultiProcessLog ( ) [inline, protected]

Definition at line 60 of file vtkMultiProcessLog.h.

vtkMultiProcessLog::~vtkMultiProcessLog ( ) [inline, protected]

Definition at line 61 of file vtkMultiProcessLog.h.

Member Function Documentation

vtkMultiProcessLog* vtkMultiProcessLog::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

const char* vtkMultiProcessLog::GetClassName ( ) [inline, virtual]

Return the class name as a string. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

Definition at line 45 of file vtkMultiProcessLog.h.

void vtkMultiProcessLog::SetTimerLog ( vtkThreadSafeLog * log ) [static]

I want all the events in one process to share a log. Note: Each process must set its own log. Since I cannot initialize the array in a thread safe manner, the logs are not reference counted.

vtkThreadSafeLog* vtkMultiProcessLog::GetTimerLog ( ) [static]

I want all the events in one process to share a log. Note: Each process must set its own log. Since I cannot initialize the array in a thread safe manner, the logs are not reference counted.

void vtkMultiProcessLog::DumpLog ( char * filename ) [static]

Dumps logs sequentially into a file. Each process should call this.

The documentation for this class was generated from the following file:
  • Parallel/vtkMultiProcessLog.h
Generated on Mon Mar 25 01:25:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMultiThreader Class Reference

A class for performing multithreaded execution. More...

#include <vtkMultiThreader.h>

Inheritance diagram for vtkMultiThreader:

[legend]
Collaboration diagram for vtkMultiThreader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMultiThreader, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SingleMethodExecute ()
void | MultipleMethodExecute ()
void | SetSingleMethod (vtkThreadFunctionType, void *data)
void | SetMultipleMethod (int index, vtkThreadFunctionType, void *data)
int | SpawnThread (vtkThreadFunctionType, void *data)
void | TerminateThread (int thread_id)
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()

Static Public Methods

vtkMultiThreader * | New ()
void | SetGlobalMaximumNumberOfThreads (int val)
int | GetGlobalMaximumNumberOfThreads ()
void | SetGlobalDefaultNumberOfThreads (int val)
int | GetGlobalDefaultNumberOfThreads ()

Protected Methods

vtkMultiThreader ()
~vtkMultiThreader ()

Protected Attributes

int | NumberOfThreads
ThreadInfoStruct | ThreadInfoArray [VTK_MAX_THREADS]
vtkThreadFunctionType SingleMethod
vtkThreadFunctionType | MultipleMethod [VTK_MAX_THREADS]
int | SpawnedThreadActiveFlag [VTK_MAX_THREADS]
vtkMutexLock * | SpawnedThreadActiveFlagLock [VTK_MAX_THREADS]
vtkThreadProcessIDType | SpawnedThreadProcessID [VTK_MAX_THREADS]
ThreadInfoStruct | SpawnedThreadInfoArray [VTK_MAX_THREADS]
void * | SingleData
void * | MultipleData [VTK_MAX_THREADS]

Detailed Description

A class for performing multithreaded execution.

Date:
2002/01/22 15:25:45
Revision:
1.38

vtkMultithreader is a class that provides support for multithreaded execution using sproc() on an SGI, or pthread_create on any platform supporting POSIX threads. This class can be used to execute a single method on multiple threads, or to specify a method per thread.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (52%)
  • Martin, Ken (30%)
  • Law, Charles (6%)

Definition at line 131 of file vtkMultiThreader.h.

Constructor & Destructor Documentation

vtkMultiThreader::vtkMultiThreader ( ) [protected]

vtkMultiThreader::~vtkMultiThreader ( ) [protected]

Member Function Documentation

vtkMultiThreader* vtkMultiThreader::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkMultiThreader::vtkTypeRevisionMacro | ( | vtkMultiThreader | ,
 |  | vtkObject |
 | ) |

void vtkMultiThreader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

virtual void vtkMultiThreader::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create. It will be clamped to the range 1 - VTK_MAX_THREADS, so the caller of this method should check that the requested number of threads was accepted.

virtual int vtkMultiThreader::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create. It will be clamped to the range 1 - VTK_MAX_THREADS, so the caller of this method should check that the requested number of threads was accepted.

void vtkMultiThreader::SetGlobalMaximumNumberOfThreads ( int val ) [static]

Set/Get the maximum number of threads to use when multithreading. This limits and overrides any other settings for multithreading. A value of zero indicates no limit.

int vtkMultiThreader::GetGlobalMaximumNumberOfThreads ( ) [static]

Set/Get the maximum number of threads to use when multithreading. This limits and overrides any other settings for multithreading. A value of zero indicates no limit.

void vtkMultiThreader::SetGlobalDefaultNumberOfThreads ( int val ) [static]

Set/Get the value which is used to initialize the NumberOfThreads in the constructor. Initially this default is set to the number of processors or 8 (which ever is less).

int vtkMultiThreader::GetGlobalDefaultNumberOfThreads ( ) [static]

Set/Get the value which is used to initialize the NumberOfThreads in the constructor. Initially this default is set to the number of processors or 8 (which ever is less).

void vtkMultiThreader::SingleMethodExecute ( )

Execute the SingleMethod (as define by SetSingleMethod) using this->NumberOfThreads threads.

void vtkMultiThreader::MultipleMethodExecute ( )

Execute the MultipleMethods (as define by calling SetMultipleMethod for each of the required this->NumberOfThreads methods) using this->NumberOfThreads threads.

void vtkMultiThreader::SetSingleMethod | ( | vtkThreadFunctionType | ,
 |  | void * | data
 | ) |

Set the SingleMethod to f() and the UserData field of the ThreadInfoStruct that is passed to it will be data. This method (and all the methods passed to SetMultipleMethod) must be of type vtkThreadFunctionType and must take a single argument of type void *.

void vtkMultiThreader::SetMultipleMethod | ( | int | index,
 |  | vtkThreadFunctionType | ,
 |  | void * | data
 | ) |

Set the MultipleMethod at the given index to f() and the UserData field of the ThreadInfoStruct that is passed to it will be data.

int vtkMultiThreader::SpawnThread | ( | vtkThreadFunctionType | ,
 |  | void * | data
 | ) |

Create a new thread for the given function. Return a thread id which is a number between 0 and VTK_MAX_THREADS - 1. This id should be used to kill the thread at a later time.

void vtkMultiThreader::TerminateThread ( int thread_id )

Terminate the thread that was created with a SpawnThreadExecute()

Member Data Documentation

int vtkMultiThreader::NumberOfThreads [protected]

Definition at line 201 of file vtkMultiThreader.h.

ThreadInfoStruct vtkMultiThreader::ThreadInfoArray[VTK_MAX_THREADS] [protected]

Definition at line 206 of file vtkMultiThreader.h.

vtkThreadFunctionType vtkMultiThreader::SingleMethod [protected]

Definition at line 209 of file vtkMultiThreader.h.

vtkThreadFunctionType vtkMultiThreader::MultipleMethod[VTK_MAX_THREADS] [protected]

Definition at line 210 of file vtkMultiThreader.h.

int vtkMultiThreader::SpawnedThreadActiveFlag[VTK_MAX_THREADS] [protected]

Definition at line 214 of file vtkMultiThreader.h.

vtkMutexLock* vtkMultiThreader::SpawnedThreadActiveFlagLock[VTK_MAX_THREADS] [protected]

Definition at line 215 of file vtkMultiThreader.h.

vtkThreadProcessIDType vtkMultiThreader::SpawnedThreadProcessID[VTK_MAX_THREADS] [protected]

Definition at line 216 of file vtkMultiThreader.h.

ThreadInfoStruct vtkMultiThreader::SpawnedThreadInfoArray[VTK_MAX_THREADS] [protected]

Definition at line 217 of file vtkMultiThreader.h.

void* vtkMultiThreader::SingleData [protected]

Definition at line 222 of file vtkMultiThreader.h.

void* vtkMultiThreader::MultipleData[VTK_MAX_THREADS] [protected]

Definition at line 223 of file vtkMultiThreader.h.

The documentation for this class was generated from the following file:
  • Common/vtkMultiThreader.h
Generated on Mon Mar 25 01:25:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkMutexLock Class Reference

mutual exclusion locking class. More...

#include <vtkMutexLock.h>

Inheritance diagram for vtkMutexLock:

[legend]
Collaboration diagram for vtkMutexLock:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkMutexLock, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Lock (void)
void | Unlock (void)

Static Public Methods

vtkMutexLock * | New ()

Protected Methods

vtkMutexLock ()

Protected Attributes

vtkSimpleMutexLock SimpleMutexLock

Detailed Description

mutual exclusion locking class.

Date:
2002/01/22 15:25:46
Revision:
1.23

vtkMutexLock allows the locking of variables which are accessed through different threads. This header file also defines vtkSimpleMutexLock which is not a subclass of vtkObject.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (47%)
  • Law, Charles (22%)
  • Kelly, Ann (8%)
  • Martin, Ken (7%)

Definition at line 95 of file vtkMutexLock.h.

Constructor & Destructor Documentation

vtkMutexLock::vtkMutexLock ( ) [inline, protected]

Definition at line 111 of file vtkMutexLock.h.

Member Function Documentation

vtkMutexLock* vtkMutexLock::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkMutexLock::vtkTypeRevisionMacro | ( | vtkMutexLock | ,
 |  | vtkObject |
 | ) |

void vtkMutexLock::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkMutexLock::Lock ( void ) [inline]

Lock the vtkMutexLock

Definition at line 118 of file vtkMutexLock.h.

void vtkMutexLock::Unlock ( void ) [inline]

Unlock the vtkMutexLock

Definition at line 123 of file vtkMutexLock.h.

Member Data Documentation

vtkSimpleMutexLock vtkMutexLock::SimpleMutexLock [protected]

Definition at line 110 of file vtkMutexLock.h.

The documentation for this class was generated from the following file:
  • Common/vtkMutexLock.h
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkNonLinearCell Class Reference

abstract superclass for non-linear cells. More...

#include <vtkNonLinearCell.h>

Inheritance diagram for vtkNonLinearCell:

[legend]
Collaboration diagram for vtkNonLinearCell:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkNonLinearCell, vtkCell)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | IsLinear ()
virtual void | SetError (float)
virtual float | GetError ()
virtual void | Tesselate (vtkIdType cellId, vtkDataSet *input, vtkPolyData *output, vtkPointLocator *locator=NULL)
virtual void | Tesselate (vtkIdType cellId, vtkDataSet *input, vtkUnstructuredGrid *output, vtkPointLocator *locator=NULL)

Protected Methods

vtkNonLinearCell ()
~vtkNonLinearCell ()
vtkIdType | InsertPoint (vtkPointLocator *locator, vtkPoints *pts, float *x)

Protected Attributes

float | Error

Detailed Description

abstract superclass for non-linear cells.

Date:
2002/03/07 15:33:04
Revision:
1.2

vtkNonLinearCell is an abstract superclass for non-linear cell types. Cells that are a direct subclass of vtkCell or vtkCell3D are linear; cells that are a subclass of vtkNonLinearCell have non-linear interpolation functions. Non-linear cells require special treatment when tessellating or converting to graphics primitives. Note that the linearity of the cell is a function of whether the cell needs tessellation, which does not strictly correlate with interpolation order (e.g., vtkHexahedron has non-linear interpolation functions (a product of three linear functions in r-s-t) even thought vtkHexahedron is considered linear.)

The Error instance variable is used to control the tessellation of the cell. Error is normalized between (0.001,1) and typically measures the chordal deviation of linear (tessellated) primitives from the actual cell boundary. Each cell may have its own interpretation of this error measure.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)
  • Cedilnik, Andy (7%)

Definition at line 57 of file vtkNonLinearCell.h.

Constructor & Destructor Documentation

vtkNonLinearCell::vtkNonLinearCell ( ) [protected]

vtkNonLinearCell::~vtkNonLinearCell ( ) [inline, protected]

Definition at line 110 of file vtkNonLinearCell.h.

Member Function Documentation

vtkNonLinearCell::vtkTypeRevisionMacro | ( | vtkNonLinearCell | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

Reimplemented in vtkExplicitCell, and vtkQuadraticEdge.

void vtkNonLinearCell::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCell.

Reimplemented in vtkExplicitCell.

virtual void vtkNonLinearCell::SetError ( float ) [virtual]

Set/Get the normalized error measure used to control the tessellation of the cell.

virtual float vtkNonLinearCell::GetError ( ) [virtual]

Set/Get the normalized error measure used to control the tessellation of the cell.

virtual int vtkNonLinearCell::IsLinear ( ) [inline, virtual]

Non-linear cells require special treatment (tessellation) when converting to graphics primitives (during mapping). The vtkCell API IsLinear() is modified to indicate this requirement.

Reimplemented from vtkCell.

Definition at line 73 of file vtkNonLinearCell.h.

virtual void vtkNonLinearCell::Tesselate | ( | vtkIdType | cellId,
 |  | vtkDataSet * | input,
 |  | vtkPolyData * | output,
 |  | vtkPointLocator * | locator = NULL
 | ) | [virtual]

This method tessellates the cell returning polydata. (The Error ivar controls the tessellation depth.) The new dataset will contain polydata primitives, possibly new points as well as interpolated point and cell data. The user must provide (the output) polydata which is filled in by the method. If the optional PointLocator is supplied, then any new points that are created are inserted through the vtkPointLocator, rather than directly in the vtkPolyData. (Note: the input dataset and cellId are used if the cell requires access to its owning dataset.) This method is called when the topological dimension of the cell is 2D or less.

Reimplemented in vtkQuadraticEdge.

virtual void vtkNonLinearCell::Tesselate | ( | vtkIdType | cellId,
 |  | vtkDataSet * | input,
 |  | vtkUnstructuredGrid * | output,
 |  | vtkPointLocator * | locator = NULL
 | ) | [virtual]

This method tessellates the cell returning unstructured grid. (The Error ivar controls the tessellation depth.) The new dataset will contain unstructured grid primitives, possibly new points as well as interpolated point and cell data. The user must provide (the output) unstructured grid which is filled in by the method. If the optional PointLocator is supplied, then any new points that are created are inserted through the vtkPointLocator, rather than directly in the vtkUnstructuredGrid. (Note: the input dataset and cellId are used if the cell requires access to its owning dataset.) This method is called when the topological dimension of the cell is 3D.

vtkIdType vtkNonLinearCell::InsertPoint | ( | vtkPointLocator * | locator,
 |  | vtkPoints * | pts,
 |  | float * | x
 | ) | [inline, protected]

Definition at line 115 of file vtkNonLinearCell.h.

Member Data Documentation

float vtkNonLinearCell::Error [protected]

Definition at line 112 of file vtkNonLinearCell.h.

The documentation for this class was generated from the following file:
  • Common/vtkNonLinearCell.h
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


NSOpenGLView Class Reference

Inheritance diagram for NSOpenGLView:

[legend]
The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzGLView.h
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


NSWindow Class Reference

Inheritance diagram for NSWindow:

[legend]
The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzWindow.h
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBBDicer Class Reference

divide dataset into spatially aggregated pieces. More...

#include <vtkOBBDicer.h>

Inheritance diagram for vtkOBBDicer:

[legend]
Collaboration diagram for vtkOBBDicer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOBBDicer, vtkDicer)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkOBBDicer * | New ()

Protected Methods

vtkOBBDicer ()
~vtkOBBDicer ()
void | Execute ()
void | BuildTree (vtkIdList *ptIds, vtkOBBNode *OBBptr)
void | MarkPoints (vtkOBBNode *OBBptr, vtkShortArray *groupIds)
void | DeleteTree (vtkOBBNode *OBBptr)

Protected Attributes

vtkPoints * PointsList

Detailed Description

divide dataset into spatially aggregated pieces.

Date:
2002/01/22 15:29:30
Revision:
1.14

vtkOBBDicer separates the cells of a dataset into spatially aggregated pieces using a Oriented Bounding Box (OBB). These pieces can then be operated on by other filters (e.g., vtkThreshold). One application is to break very large polygonal models into pieces and performing viewing and occlusion culling on the pieces.

Refer to the superclass documentation (vtkDicer) for more information.

See also:
vtkDicer vtkConnectedDicer
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)
  • Geveci, Berk (8%)
Tests:
vtkOBBDicer (Tests)

Definition at line 51 of file vtkOBBDicer.h.

Constructor & Destructor Documentation

vtkOBBDicer::vtkOBBDicer ( ) [inline, protected]

Definition at line 61 of file vtkOBBDicer.h.

vtkOBBDicer::~vtkOBBDicer ( ) [inline, protected]

Definition at line 62 of file vtkOBBDicer.h.

Member Function Documentation

vtkOBBDicer::vtkTypeRevisionMacro | ( | vtkOBBDicer | ,
 |  | vtkDicer |
 | ) |

Reimplemented from vtkDicer.

void vtkOBBDicer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDicer.

vtkOBBDicer* vtkOBBDicer::New ( ) [static]

Instantiate an object.

Reimplemented from vtkDataSetSource.

void vtkOBBDicer::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkOBBDicer::BuildTree | ( | vtkIdList * | ptIds,
 |  | vtkOBBNode * | OBBptr
 | ) | [protected]

void vtkOBBDicer::MarkPoints | ( | vtkOBBNode * | OBBptr,
 |  | vtkShortArray * | groupIds
 | ) | [protected]

void vtkOBBDicer::DeleteTree ( vtkOBBNode * OBBptr ) [protected]

Member Data Documentation

vtkPoints* vtkOBBDicer::PointsList [protected]

Definition at line 71 of file vtkOBBDicer.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOBBDicer.h
Generated on Mon Mar 25 01:25:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBBNode Class Reference

#include <vtkOBBTree.h>

Collaboration diagram for vtkOBBNode:

[legend]
List of all members.

Public Methods

vtkOBBNode ()
~vtkOBBNode ()
void | DebugPrintTree (int level, double *leaf_vol, int *minCells, int *maxCells)

Public Attributes

float | Corner [3]
float | Axes [3][3]
vtkOBBNode * | Parent
vtkOBBNode ** | Kids
vtkIdList * Cells

Constructor & Destructor Documentation

vtkOBBNode::vtkOBBNode ( )

vtkOBBNode::~vtkOBBNode ( )

Member Function Documentation

void vtkOBBNode::DebugPrintTree | ( | int | level,
 |  | double * | leaf_vol,
 |  | int * | minCells,
 |  | int * | maxCells
 | ) |

Member Data Documentation

float vtkOBBNode::Corner[3]

Definition at line 82 of file vtkOBBTree.h.

float vtkOBBNode::Axes[3][3]

Definition at line 83 of file vtkOBBTree.h.

vtkOBBNode* vtkOBBNode::Parent

Definition at line 84 of file vtkOBBTree.h.

vtkOBBNode** vtkOBBNode::Kids

Definition at line 85 of file vtkOBBTree.h.

vtkIdList* vtkOBBNode::Cells

Definition at line 86 of file vtkOBBTree.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOBBTree.h
Generated on Mon Mar 25 01:25:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBBTree Class Reference

generate oriented bounding box (OBB) tree. More...

#include <vtkOBBTree.h>

Inheritance diagram for vtkOBBTree:

[legend]
Collaboration diagram for vtkOBBTree:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOBBTree, vtkCellLocator)
int | InsideOrOutside (const float point[3])
int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId)
int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId, vtkGenericCell *cell)
int | LineIntersectsNode (vtkOBBNode *pA, float B0[3], float B1[3])
void | GenerateRepresentation (int level, vtkPolyData *pd)
void | ComputeOBB (vtkPoints *pts, float corner[3], float max[3], float mid[3], float min[3], float size[3])
void | ComputeOBB (vtkDataSet *input, float corner[3], float max[3], float mid[3], float min[3], float size[3])
int | IntersectWithLine (const float a0[3], const float a1[3], vtkPoints *points, vtkIdList *cellIds)
int | IntersectWithLine (float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | DisjointOBBNodes (vtkOBBNode *nodeA, vtkOBBNode *nodeB, vtkMatrix4x4 *XformBtoA)
int | TriangleIntersectsNode (vtkOBBNode *pA, float p0[3], float p1[3], float p2[3], vtkMatrix4x4 *XformBtoA)
int | IntersectWithOBBTree (vtkOBBTree *OBBTreeB, vtkMatrix4x4 *XformBtoA, int(*function)(vtkOBBNode *nodeA, vtkOBBNode *nodeB, vtkMatrix4x4 *Xform, void *arg), void *data_arg)
void | FreeSearchStructure ()
void | BuildLocator ()

Static Public Methods

vtkOBBTree * | New ()

Protected Methods

vtkOBBTree ()
~vtkOBBTree ()
void | ComputeOBB (vtkIdList *cells, float corner[3], float max[3], float mid[3], float min[3], float size[3])
void | BuildTree (vtkIdList *cells, vtkOBBNode *parent, int level)
void | DeleteTree (vtkOBBNode *OBBptr)
void | GeneratePolygons (vtkOBBNode *OBBptr, int level, int repLevel, vtkPoints *pts, vtkCellArray *polys)

Protected Attributes

vtkOBBNode * Tree
vtkPoints * PointsList
int * | InsertedPoints
int | OBBCount
int | DeepestLevel

Detailed Description

generate oriented bounding box (OBB) tree.

Date:
2002/01/22 15:29:31
Revision:
1.39

vtkOBBTree is an object to generate oriented bounding box (OBB) trees. An oriented bounding box is a bounding box that does not necessarily line up along coordinate axes. The OBB tree is a hierarchical tree structure of such boxes, where deeper levels of OBB confine smaller regions of space.

To build the OBB, a recursive, top-down process is used. First, the root OBB is constructed by finding the mean and covariance matrix of the cells (and their points) that define the dataset. The eigenvectors of the covariance matrix are extracted, giving a set of three orthogonal vectors that define the tightest-fitting OBB. To create the two children OBB's, a split plane is found that (approximately) divides the number cells in half. These are then assigned to the children OBB's. This process then continues until the MaxLevel ivar limits the recursion, or no split plane can be found.

A good reference for OBB-trees is Gottschalk & Manocha in Proceedings of Siggraph `96.

Warning:
Since this algorithms works from a list of cells, the OBB tree will only bound the "geometry" attached to the cells if the convex hull of the cells bounds the geometry.
Warning:
Long, skinny cells (i.e., cells with poor aspect ratio) may cause unsatisfactory results. This is due to the fact that this is a top-down implementation of the OBB tree, requiring that one or more complete cells are contained in each OBB. This requirement makes it hard to find good split planes during the recursion process. A bottom-up implementation would go a long way to correcting this problem.
See also:
vtkLocator vtkCellLocator vtkLocatorFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (35%)
  • Warfield, Simon (27%)
  • Gobbi, David (21%)
Tests:
vtkOBBTree (Tests)

Definition at line 93 of file vtkOBBTree.h.

Constructor & Destructor Documentation

vtkOBBTree::vtkOBBTree ( ) [protected]

vtkOBBTree::~vtkOBBTree ( ) [protected]

Member Function Documentation

vtkOBBTree::vtkTypeRevisionMacro | ( | vtkOBBTree | ,
 |  | vtkCellLocator |
 | ) |

Reimplemented from vtkCellLocator.

vtkOBBTree* vtkOBBTree::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 cells per octant.

Reimplemented from vtkCellLocator.

void vtkOBBTree::ComputeOBB | ( | vtkPoints * | pts,
 |  | float | corner[3],
 |  | float | max[3],
 |  | float | mid[3],
 |  | float | min[3],
 |  | float | size[3]
 | ) |

Compute an OBB from the list of points given. Return the corner point and the three axes defining the orientation of the OBB. Also return a sorted list of relative "sizes" of axes for comparison purposes.

void vtkOBBTree::ComputeOBB | ( | vtkDataSet * | input,
 |  | float | corner[3],
 |  | float | max[3],
 |  | float | mid[3],
 |  | float | min[3],
 |  | float | size[3]
 | ) |

Compute an OBB for the input dataset using the cells in the data. Return the corner point and the three axes defining the orientation of the OBB. Also return a sorted list of relative "sizes" of axes for comparison purposes.

int vtkOBBTree::InsideOrOutside ( const float point[3] )

Determine whether a point is inside or outside the data used to build this OBB tree. The data must be a closed surface vtkPolyData data set. The return value is +1 if outside, -1 if inside, and 0 if undecided.

int vtkOBBTree::IntersectWithLine | ( | const float | a0[3],
 |  | const float | a1[3],
 |  | vtkPoints * | points,
 |  | vtkIdList * | cellIds
 | ) |

Take the passed line segment and intersect it with the data set. This method assumes that the data set is a vtkPolyData that describes a closed surface, and the intersection points that are returned in 'points' alternate between entrance points and exit points. The return value of the function is 0 if no intersections were found, -1 if point 'a0' lies inside the closed surface, or +1 if point 'a0' lies outside the closed surface. Either 'points' or 'cellIds' can be set to NULL if you don't want to receive that information.

int vtkOBBTree::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Return the first intersection of the specified line segment with the OBB tree, as well as information about the cell which the line segment intersected.

Reimplemented from vtkCellLocator.

int vtkOBBTree::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId,
 |  | vtkIdType & | cellId
 | ) | [virtual]

Return intersection point (if any) AND the cell which was intersected by the finite line.

Reimplemented from vtkCellLocator.

int vtkOBBTree::IntersectWithLine | ( | float | a0[3],
 |  | float | a1[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId,
 |  | vtkIdType & | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Return intersection point (if any) AND the cell which was intersected by the finite line. The cell is returned as a cell id and as a generic cell.

Reimplemented from vtkCellLocator.

int vtkOBBTree::DisjointOBBNodes | ( | vtkOBBNode * | nodeA,
 |  | vtkOBBNode * | nodeB,
 |  | vtkMatrix4x4 * | XformBtoA
 | ) |

Returns true if nodeB and nodeA are disjoint after optional transformation of nodeB with matrix XformBtoA

int vtkOBBTree::LineIntersectsNode | ( | vtkOBBNode * | pA,
 |  | float | B0[3],
 |  | float | B1[3]
 | ) |

Returns true if line intersects node.

int vtkOBBTree::TriangleIntersectsNode | ( | vtkOBBNode * | pA,
 |  | float | p0[3],
 |  | float | p1[3],
 |  | float | p2[3],
 |  | vtkMatrix4x4 * | XformBtoA
 | ) |

Returns true if triangle (optionally transformed) intersects node.

int vtkOBBTree::IntersectWithOBBTree | ( | vtkOBBTree * | OBBTreeB,
 |  | vtkMatrix4x4 * | XformBtoA,
 |  | int(* | function)(vtkOBBNode *nodeA, vtkOBBNode *nodeB, vtkMatrix4x4 *Xform, void *arg),
 |  | void * | data_arg
 | ) |

For each intersecting leaf node pair, call function. OBBTreeB is optionally transformed by XformBtoA before testing.

void vtkOBBTree::FreeSearchStructure ( ) [virtual]

Satisfy locator's abstract interface, see vtkLocator.

Reimplemented from vtkCellLocator.

void vtkOBBTree::BuildLocator ( ) [virtual]

Satisfy locator's abstract interface, see vtkLocator.

Reimplemented from vtkCellLocator.

void vtkOBBTree::GenerateRepresentation | ( | int | level,
 |  | vtkPolyData * | pd
 | ) | [virtual]

Create polygonal representation for OBB tree at specified level. If level < 0, then the leaf OBB nodes will be gathered. The aspect ratio (ar) and line diameter (d) are used to control the building of the representation. If a OBB node edge ratio's are greater than ar, then the dimension of the OBB is collapsed (OBB->plane->line). A "line" OBB will be represented either as two crossed polygons, or as a line, depending on the relative diameter of the OBB compared to the diameter (d).

Reimplemented from vtkCellLocator.

void vtkOBBTree::ComputeOBB | ( | vtkIdList * | cells,
 |  | float | corner[3],
 |  | float | max[3],
 |  | float | mid[3],
 |  | float | min[3],
 |  | float | size[3]
 | ) | [protected]

void vtkOBBTree::BuildTree | ( | vtkIdList * | cells,
 |  | vtkOBBNode * | parent,
 |  | int | level
 | ) | [protected]

void vtkOBBTree::DeleteTree ( vtkOBBNode * OBBptr ) [protected]

void vtkOBBTree::GeneratePolygons | ( | vtkOBBNode * | OBBptr,
 |  | int | level,
 |  | int | repLevel,
 |  | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

Member Data Documentation

vtkOBBNode* vtkOBBTree::Tree [protected]

Reimplemented from vtkCellLocator.

Definition at line 213 of file vtkOBBTree.h.

vtkPoints* vtkOBBTree::PointsList [protected]

Definition at line 215 of file vtkOBBTree.h.

int* vtkOBBTree::InsertedPoints [protected]

Definition at line 216 of file vtkOBBTree.h.

int vtkOBBTree::OBBCount [protected]

Definition at line 217 of file vtkOBBTree.h.

int vtkOBBTree::DeepestLevel [protected]

Definition at line 218 of file vtkOBBTree.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOBBTree.h
Generated on Mon Mar 25 01:25:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObject Class Reference

abstract base class for most VTK objects. More...

#include <vtkObject.h>

Inheritance diagram for vtkObject:

[legend]
Collaboration diagram for vtkObject:

[legend]
List of all members.

Public Methods

virtual const char * | GetClassName ()
virtual int | IsA (const char *name)
virtual void | Delete ()
virtual void | DebugOn ()
virtual void | DebugOff ()
unsigned char | GetDebug ()
void | SetDebug (unsigned char debugFlag)
virtual void | Modified ()
virtual unsigned long | GetMTime ()
void | Print (ostream &os)
void | Register (vtkObject *o)
virtual void | UnRegister (vtkObject *o)
void | SetReferenceCount (int)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | PrintHeader (ostream &os, vtkIndent indent)
virtual void | PrintTrailer (ostream &os, vtkIndent indent)
int | GetReferenceCount ()
unsigned long | AddObserver (unsigned long event, vtkCommand *, float priority=0.0)
unsigned long | AddObserver (const char *event, vtkCommand *, float priority=0.0)
vtkCommand * | GetCommand (unsigned long tag)
void | InvokeEvent (unsigned long event, void *callData)
void | InvokeEvent (const char *event, void *callData)
void | RemoveObserver (vtkCommand *)
void | RemoveObserver (unsigned long tag)
int | HasObserver (unsigned long event)
int | HasObserver (const char *event)

Static Public Methods

int | IsTypeOf (const char *name)
vtkObject * | SafeDownCast (vtkObject *o)
void | BreakOnError ()
vtkObject * | New ()
void | SetGlobalWarningDisplay (int val)
void | GlobalWarningDisplayOn ()
void | GlobalWarningDisplayOff ()
int | GetGlobalWarningDisplay ()

Protected Methods

vtkObject ()
virtual | ~vtkObject ()
virtual void | CollectRevisions (ostream &os)

Protected Attributes

unsigned char | Debug
vtkTimeStamp MTime
int | ReferenceCount
vtkSubjectHelper * | SubjectHelper

Friends

VTK_COMMON_EXPORT ostream & | operator<< (ostream &os, vtkObject &o)

Detailed Description

abstract base class for most VTK objects.

Date:
2002/03/20 17:26:15
Revision:
1.84

vtkObject is the base class for most objects in the visualization toolkit. vtkObject provides methods for tracking modification time, debugging, printing, and event callbacks. Most objects created within the VTK framework should be a subclass of vtkObject or one of its children. The few exceptions tend to be very small helper classes that usually never get instantiated or situations where multiple inheritance gets in the way. vtkObject also performs reference counting: objects that are reference counted exist as long as another object uses them. Once the last reference to a reference counted object is removed, the object will spontaneously destruct.

Warning:
Note: in VTK objects should always be created with the New() method and deleted with the Delete() method. VTK objects cannot be allocated off the stack (i.e., automatic objects) because the constructor is a protected method.
See also:
vtkCommand vtkTimeStamp
Events:
vtkCommand::ModifiedEvent vtkCommand::DeleteEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Martin, Ken (41%)
  • Schroeder, Will (37%)
  • Hoffman, Bill (7%)
  • Law, Charles (5%)
Examples:
vtkObject (Examples)
Tests:
vtkObject (Tests)

Definition at line 71 of file vtkObject.h.

Constructor & Destructor Documentation

vtkObject::vtkObject ( ) [protected]

virtual vtkObject::~vtkObject ( ) [protected, virtual]

Member Function Documentation

virtual const char* vtkObject::GetClassName ( ) [inline, virtual]

Return the class name as a string. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented in vtkTIFFReader, vtkMultiProcessLog, and vtkThreadSafeLog.

Definition at line 77 of file vtkObject.h.

int vtkObject::IsTypeOf ( const char * type ) [static]

Return 1 if this class type is the same type of (or a subclass of) the named class. Returns 0 otherwise. This method works in combination with vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented in vtkTIFFReader.

virtual int vtkObject::IsA ( const char * type ) [virtual]

Return 1 if this class is the same type of (or a subclass of) the named class. Returns 0 otherwise. This method works in combination with vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented in vtkTIFFReader.

vtkObject* vtkObject::SafeDownCast ( vtkObject * o ) [static]

Will cast the supplied object to vtkObject* is this is a safe operation (i.e., a safe downcast); otherwise NULL is returned. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented in vtkTIFFReader.

Referenced by vtkSocketController::CloseConnection(), vtkSocketController::ConnectTo(), vtkSocketController::GetSwapBytesInReceivedData(), and vtkSocketController::WaitForConnection().

virtual void vtkObject::Delete ( ) [virtual]

Delete a VTK object. This method should always be used to delete an object when the New() method was used to create it. Using the C++ delete method will not work with reference counting.

vtkObject* vtkObject::New ( ) [inline, static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented in vtkActor2D, vtkActor2DCollection, vtkAssemblyNode, vtkAssemblyPath, vtkAssemblyPaths, vtkBitArray, vtkByteSwap, vtkCellArray, vtkCellData, vtkCellLinks, vtkCellTypes, vtkCharArray, vtkCollection, vtkContourValues, vtkCoordinate, vtkCriticalSection, vtkDataObject, vtkDataObjectCollection, vtkDataSetAttributes, vtkDataSetCollection, vtkDebugLeaks, vtkDirectory, vtkDoubleArray, vtkDynamicLoader, vtkEdgeTable, vtkEmptyCell, vtkExtentTranslator, vtkFieldData, vtkFileOutputWindow, vtkFloatArray, vtkFunctionParser, vtkGeneralTransform, vtkGenericCell, vtkHeap, vtkHexahedron, vtkIdentityTransform, vtkIdList, vtkIdTypeArray, vtkImageData, vtkImplicitFunctionCollection, vtkInstantiator, vtkIntArray, vtkInterpolatedVelocityField, vtkLine, vtkLogLookupTable, vtkLongArray, vtkLookupTable, vtkMapper2D, vtkMath, vtkMatrix4x4, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkMultiThreader, vtkMutexLock, vtkObjectFactoryCollection, vtkOrderedTriangulator, vtkOutputWindow, vtkOverrideInformation, vtkOverrideInformationCollection, vtkPerspectiveTransform, vtkPixel, vtkPlane, vtkPlaneCollection, vtkPlanes, vtkPointData, vtkPointLocator, vtkPointLocator2D, vtkPoints, vtkPolyData, vtkPolygon, vtkPolyLine, vtkPolyVertex, vtkPriorityQueue, vtkProcessObject, vtkProcessStatistics, vtkProp, vtkPropAssembly, vtkPropCollection, vtkProperty2D, vtkPyramid, vtkQuad, vtkQuadraticEdge, vtkQuadric, vtkRectilinearGrid, vtkReferenceCount, vtkRungeKutta2, vtkRungeKutta4, vtkRungeKutta45, vtkShortArray, vtkStructuredData, vtkStructuredGrid, vtkStructuredPoints, vtkTensor, vtkTetra, vtkTimerLog, vtkTransform, vtkTransformCollection, vtkTriangle, vtkTriangleStrip, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, vtkUnstructuredGrid, vtkVersion, vtkVertex, vtkVoidArray, vtkVoxel, vtkWedge, vtkWin32OutputWindow, vtkWindowLevelLookupTable, vtkXMLFileOutputWindow, vtkCardinalSpline, vtkCastToConcrete, vtkCellLocator, vtkColorTransferFunction, vtkCone, vtkCylinder, vtkDataObjectSource, vtkDataSetSource, vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageSource, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkImageTwoInputFilter, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkKochanekSpline, vtkMergePoints, vtkMergePoints2D, vtkPerlinNoise, vtkPiecewiseFunction, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionSource, vtkPointSetSource, vtkPolyDataCollection, vtkPolyDataSource, vtkRectilinearGridSource, vtkSimpleScalarTree, vtkSphere, vtkStructuredGridSource, vtkStructuredPointsCollection, vtkStructuredPointsSource, vtkSuperquadric, vtkUnstructuredGridSource, vtkAppendFilter, vtkAppendPolyData, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMassProperties, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOBBTree, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableFilter, vtkProgrammableGlyphFilter, vtkProgrammableSource, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtk3DSImporter, vtkArcPlotter, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkGridTransform, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkIterativeClosestPointTransform, vtkLandmarkTransform, vtkLegendBoxActor, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkRIBExporter, vtkRIBLight, vtkRIBProperty, vtkThinPlateSplineTransform, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkVRMLImporter, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkXYPlotActor, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCanvasSource2D, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConnector, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExport, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilData, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSimpleImageFilterExample, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBMPWriter, vtkBYUReader, vtkBYUWriter, vtkCGMWriter, vtkDataObjectReader, vtkDataObjectWriter, vtkDataReader, vtkDataSetReader, vtkDataSetWriter, vtkDataWriter, vtkDEMReader, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkGenericEnSightReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkImageReader2Collection, vtkImageReader2Factory, vtkImageWriter, vtkIVWriter, vtkJPEGReader, vtkJPEGWriter, vtkMCubesReader, vtkMCubesWriter, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPLYWriter, vtkPNGReader, vtkPNGWriter, vtkPNMReader, vtkPNMWriter, vtkPolyDataReader, vtkPolyDataWriter, vtkPostScriptWriter, vtkRectilinearGridReader, vtkRectilinearGridWriter, vtkSLCReader, vtkSTLReader, vtkSTLWriter, vtkStructuredGridReader, vtkStructuredGridWriter, vtkStructuredPointsReader, vtkStructuredPointsWriter, vtkTIFFReader, vtkTIFFWriter, vtkUGFacetReader, vtkUnstructuredGridReader, vtkUnstructuredGridWriter, vtkVolume16Reader, vtkXMLParser, vtkBranchExtentTranslator, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkImageBlockWriter, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkMPICommunicator, vtkMPIController, vtkMPIEventLog, vtkMPIGroup, vtkMultiProcessController, vtkMultiProcessLog, vtkOutputPort, vtkParallelFactory, vtkPCellDataToPointData, vtkPDataSetReader, vtkPDataSetWriter, vtkPieceScalars, vtkPImageWriter, vtkPipelineSize, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkRTAnalyticSource, vtkSharedMemoryCommunicator, vtkSocketCommunicator, vtkSocketController, vtkThreadedController, vtkThreadSafeLog, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkTreeComposite, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkKitwareObjectFactory, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSliceCubes, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkActor, vtkActorCollection, vtkAssembly, vtkAxisActor2D, vtkCamera, vtkCellPicker, vtkCullerCollection, vtkDataSetMapper, vtkEncodedGradientShader, vtkFiniteDifferenceGradientEstimator, vtkFollower, vtkFrustumCoverageCuller, vtkGraphicsFactory, vtkImageActor, vtkImageMapper, vtkImager, vtkImagerCollection, vtkImageViewer, vtkImageViewer2, vtkImageWindow, vtkImagingFactory, vtkInteractorStyle, vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, vtkInteractorStyleUser, vtkIVExporter, vtkLabeledDataMapper, vtkLight, vtkLightCollection, vtkLightKit, vtkLODActor, vtkLODProp3D, vtkMapperCollection, vtkMesaActor, vtkMesaCamera, vtkMesaImageActor, vtkMesaImageMapper, vtkMesaImager, vtkMesaImageWindow, vtkMesaLight, vtkMesaPolyDataMapper, vtkMesaPolyDataMapper2D, vtkMesaProperty, vtkMesaRenderer, vtkMesaTexture, vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOBJExporter, vtkOOGLExporter, vtkOpenGLActor, vtkOpenGLCamera, vtkOpenGLImageActor, vtkOpenGLImageMapper, vtkOpenGLImager, vtkOpenGLImageWindow, vtkOpenGLLight, vtkOpenGLPolyDataMapper, vtkOpenGLPolyDataMapper2D, vtkOpenGLProperty, vtkOpenGLRenderer, vtkOpenGLTexture, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkParallelCoordinatesActor, vtkPicker, vtkPointPicker, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkProp3DCollection, vtkProperty, vtkPropPicker, vtkQuartzImageMapper, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkQuartzRenderWindowInteractor, vtkQuartzTextMapper, vtkRayCaster, vtkRecursiveSphereDirectionEncoder, vtkRenderer, vtkRendererCollection, vtkRendererSource, vtkRenderWindow, vtkRenderWindowCollection, vtkRenderWindowInteractor, vtkScalarBarActor, vtkScaledTextActor, vtkSelectVisiblePoints, vtkTextMapper, vtkTexture, vtkVolume, vtkVolumeCollection, vtkVolumeProMapper, vtkVolumeProperty, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastMIPFunction, vtkVolumeTextureMapper2D, vtkVRMLExporter, vtkWin32ImageMapper, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32RenderWindowInteractor, vtkWin32TextMapper, vtkWinCEOpenGLRenderWindow, vtkWindowToImageFilter, vtkWorldPointPicker, vtkXImageMapper, vtkXImageWindow, vtkXMesaRenderWindow, vtkXMesaTextMapper, vtkXOpenGLRenderWindow, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor, and vtkXTextMapper.

Definition at line 103 of file vtkObject.h.

virtual void vtkObject::DebugOn ( ) [virtual]

Turn debugging output on.

Reimplemented in vtkImageOpenClose3D.

virtual void vtkObject::DebugOff ( ) [virtual]

Turn debugging output off.

Reimplemented in vtkImageOpenClose3D.

unsigned char vtkObject::GetDebug ( )

Get the value of the debug flag.

void vtkObject::SetDebug ( unsigned char debugFlag )

Set the value of the debug flag. A non-zero value turns debugging on.

void vtkObject::BreakOnError ( ) [static]

This method is called when vtkErrorMacro executes. It allows the debugger to break on error.

virtual void vtkObject::Modified ( ) [virtual]

Update the modification time for this object. Many filters rely on the modification time to determine if they need to recompute their data. The modification time is a unique monotonically increasing unsigned long integer.

Reimplemented in vtkImageOpenClose3D, vtkLightKit, and vtkLODActor.

Referenced by vtkMatrix4x4::DeepCopy(), vtkRenderWindowInteractor::Disable(), vtkRenderWindowInteractor::Enable(), vtkPerspectiveTransform::Identity(), vtkMatrix4x4::Identity(), vtkGeneralTransform::Identity(), vtkPerspectiveTransform::Inverse(), vtkGeneralTransform::Inverse(), vtkMatrix4x4::Invert(), vtkTransform::Pop(), vtkPerspectiveTransform::Pop(), vtkGeneralTransform::Pop(), vtkTransform::PostMultiply(), vtkPerspectiveTransform::PostMultiply(), vtkGeneralTransform::PostMultiply(), vtkTransform::PreMultiply(), vtkPerspectiveTransform::PreMultiply(), vtkGeneralTransform::PreMultiply(), vtkTransform::Push(), vtkPerspectiveTransform::Push(), vtkGeneralTransform::Push(), vtkRearrangeFields::RemoveAllOperations(), vtkThinPlateSplineTransform::SetBasisDerivative(), vtkThinPlateSplineTransform::SetBasisFunction(), vtkImageReader::SetDataMask(), vtkMatrix4x4::SetElement(), vtkRenderWindowInteractor::SetEventInformation(), vtkProp3D::SetOrigin(), vtkProp3D::SetPosition(), vtkSelectVisiblePoints::SetRenderer(), vtkProp3D::SetScale(), vtkMatrix4x4::Transpose(), and vtkMatrix4x4::Zero().

virtual unsigned long vtkObject::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented in vtkAbstractMapper, vtkAbstractTransform, vtkActor2D, vtkAssemblyNode, vtkAssemblyPath, vtkAssemblyPaths, vtkDataObject, vtkDataSet, vtkFieldData, vtkGeneralTransform, vtkImplicitFunction, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkPerspectiveTransform, vtkPointSet, vtkPropAssembly, vtkTransform, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkPiecewiseFunction, vtkSpline, vtkBandedPolyDataContourFilter, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkContourFilter, vtkContourGrid, vtkCutter, vtkDelaunay3D, vtkExtractEdges, vtkExtractGeometry, vtkExtractPolyDataGeometry, vtkExtractUnstructuredGrid, vtkFeatureEdges, vtkGeometryFilter, vtkSelectPolyData, vtkTransformFilter, vtkTransformPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkGridTransform, vtkIterativeClosestPointTransform, vtkLandmarkTransform, vtkThinPlateSplineTransform, vtkTransformToGrid, vtkWeightedTransformFilter, vtkXYPlotActor, vtkImageMapToColors, vtkImageOpenClose3D, vtkImageReslice, vtkImageSeparableConvolution, vtkSampleFunction, vtkMCubesReader, vtkSTLReader, vtkUGFacetReader, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkActor, vtkAssembly, vtkDataSetMapper, vtkExporter, vtkImageMapper, vtkMapper, vtkPolyDataMapper2D, vtkRenderer, vtkRendererSource, vtkSelectVisiblePoints, vtkVolume, vtkVolumeProperty, and vtkWin32ImageMapper.

Referenced by vtkProp::GetRedrawMTime().

void vtkObject::Print ( ostream & os )

Print an object to an ostream. This is the method to call when you wish to see print the internal state of an object.

virtual void vtkObject::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented in vtkAbstractMapper, vtkAbstractTransform, vtkActor2D, vtkAssemblyNode, vtkAssemblyPath, vtkBitArray, vtkCell, vtkCell3D, vtkCellData, vtkCharArray, vtkCollection, vtkContourValues, vtkCoordinate, vtkCriticalSection, vtkDataArray, vtkDataObject, vtkDataSet, vtkDataSetAttributes, vtkDirectory, vtkDoubleArray, vtkEdgeTable, vtkExplicitCell, vtkExtentTranslator, vtkFieldData, vtkFileOutputWindow, vtkFloatArray, vtkFunctionParser, vtkFunctionSet, vtkGeneralTransform, vtkHeap, vtkHomogeneousTransform, vtkIdentityTransform, vtkIdList, vtkIdTypeArray, vtkImageData, vtkImplicitFunction, vtkInitialValueProblemSolver, vtkInstantiator, vtkIntArray, vtkInterpolatedVelocityField, vtkLinearTransform, vtkLocator, vtkLogLookupTable, vtkLongArray, vtkLookupTable, vtkMapper2D, vtkMatrix4x4, vtkMatrixToHomogeneousTransform, vtkMatrixToLinearTransform, vtkMultiThreader, vtkMutexLock, vtkNonLinearCell, vtkObjectFactory, vtkOrderedTriangulator, vtkOutputWindow, vtkOverrideInformation, vtkPerspectiveTransform, vtkPlane, vtkPlanes, vtkPointData, vtkPointLocator, vtkPointLocator2D, vtkPoints, vtkPointSet, vtkPolyData, vtkPriorityQueue, vtkProcessObject, vtkProp, vtkPropAssembly, vtkProperty2D, vtkQuadric, vtkRectilinearGrid, vtkReferenceCount, vtkRungeKutta4, vtkScalarsToColors, vtkShortArray, vtkSource, vtkStructuredGrid, vtkTimerLog, vtkTransform, vtkUnsignedCharArray, vtkUnsignedIntArray, vtkUnsignedLongArray, vtkUnsignedShortArray, vtkUnstructuredGrid, vtkViewport, vtkVoidArray, vtkWarpTransform, vtkWindow, vtkWindowLevelLookupTable, vtkCardinalSpline, vtkCellLocator, vtkColorTransferFunction, vtkCone, vtkCylinder, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkImplicitBoolean, vtkImplicitDataSet, vtkImplicitSelectionLoop, vtkImplicitSum, vtkImplicitVolume, vtkImplicitWindowFunction, vtkKochanekSpline, vtkPerlinNoise, vtkPiecewiseFunction, vtkPiecewiseFunctionShiftScale, vtkScalarTree, vtkSimpleScalarTree, vtkSphere, vtkSpline, vtkSuperquadric, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDicer, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLineSource, vtkLinkEdgels, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMassProperties, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableGlyphFilter, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtk3DSImporter, vtkArcPlotter, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkGridTransform, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkIterativeClosestPointTransform, vtkLandmarkTransform, vtkLegendBoxActor, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkRIBExporter, vtkRIBLight, vtkRIBProperty, vtkThinPlateSplineTransform, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkVRMLImporter, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkXYPlotActor, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCanvasSource2D, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageClip, vtkImageConnector, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExport, vtkImageExtractComponents, vtkImageFlip, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageMagnify, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilData, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBYUReader, vtkBYUWriter, vtkCGMWriter, vtkDataObjectReader, vtkDataObjectWriter, vtkDataReader, vtkDataSetReader, vtkDataSetWriter, vtkDataWriter, vtkDEMReader, vtkEnSightReader, vtkGenericEnSightReader, vtkImageReader, vtkImageReader2, vtkImageReader2Factory, vtkImageWriter, vtkJPEGWriter, vtkMCubesReader, vtkMCubesWriter, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPLYWriter, vtkPolyDataReader, vtkPolyDataWriter, vtkRectilinearGridReader, vtkRectilinearGridWriter, vtkSLCReader, vtkSTLReader, vtkStructuredGridReader, vtkStructuredGridWriter, vtkStructuredPointsReader, vtkStructuredPointsWriter, vtkUGFacetReader, vtkUnstructuredGridReader, vtkUnstructuredGridWriter, vtkVolume16Reader, vtkVolumeReader, vtkWriter, vtkXMLParser, vtkBranchExtentTranslator, vtkCommunicator, vtkCompositeManager, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkImageBlockWriter, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkMPICommunicator, vtkMPIController, vtkMPIEventLog, vtkMPIGroup, vtkMultiProcessController, vtkOutputPort, vtkParallelFactory, vtkPCellDataToPointData, vtkPDataSetReader, vtkPDataSetWriter, vtkPieceScalars, vtkPImageWriter, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPVGeometryFilter, vtkRTAnalyticSource, vtkSharedMemoryCommunicator, vtkSocketCommunicator, vtkSocketController, vtkThreadedController, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkTreeComposite, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareObjectFactory, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSliceCubes, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkAbstractMapper3D, vtkAbstractPicker, vtkAbstractPropPicker, vtkActor, vtkAssembly, vtkAxisActor2D, vtkCamera, vtkCellPicker, vtkDataSetMapper, vtkEncodedGradientEstimator, vtkEncodedGradientShader, vtkExporter, vtkFiniteDifferenceGradientEstimator, vtkFollower, vtkFrustumCoverageCuller, vtkImageActor, vtkImageMapper, vtkImageViewer, vtkImageViewer2, vtkImageWindow, vtkImporter, vtkInteractorStyle, vtkInteractorStyleFlight, vtkInteractorStyleImage, vtkInteractorStyleJoystickActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleSwitch, vtkInteractorStyleTrackball, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackballCamera, vtkInteractorStyleUnicam, vtkInteractorStyleUser, vtkIVExporter, vtkLabeledDataMapper, vtkLight, vtkLightKit, vtkLODActor, vtkLODProp3D, vtkMapper, vtkMesaImageWindow, vtkMesaRenderer, vtkMesaRenderWindow, vtkMesaVolumeTextureMapper2D, vtkOBJExporter, vtkOOGLExporter, vtkOpenGLImageWindow, vtkOpenGLRenderer, vtkOpenGLRenderWindow, vtkOpenGLVolumeTextureMapper2D, vtkParallelCoordinatesActor, vtkPicker, vtkPointPicker, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkProp3D, vtkProperty, vtkPropPicker, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkQuartzRenderWindowInteractor, vtkRecursiveSphereDirectionEncoder, vtkRenderer, vtkRendererSource, vtkRenderWindow, vtkRenderWindowInteractor, vtkScalarBarActor, vtkScaledTextActor, vtkSelectVisiblePoints, vtkTextMapper, vtkTexture, vtkVolume, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeProperty, vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastMIPFunction, vtkVolumeTextureMapper, vtkVolumeTextureMapper2D, vtkVRMLExporter, vtkWin32ImageMapper, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWin32RenderWindowInteractor, vtkWinCEOpenGLRenderWindow, vtkWindowToImageFilter, vtkWorldPointPicker, vtkXImageMapper, vtkXImageWindow, vtkXMesaRenderWindow, vtkXOpenGLRenderWindow, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

virtual void vtkObject::PrintHeader | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

virtual void vtkObject::PrintTrailer | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

void vtkObject::SetGlobalWarningDisplay ( int val ) [static]

This is a global flag that controls whether any debug, warning or error messages are displayed.

Referenced by GlobalWarningDisplayOff(), and GlobalWarningDisplayOn().

void vtkObject::GlobalWarningDisplayOn ( ) [inline, static]

This is a global flag that controls whether any debug, warning or error messages are displayed.

Definition at line 156 of file vtkObject.h.

void vtkObject::GlobalWarningDisplayOff ( ) [inline, static]

This is a global flag that controls whether any debug, warning or error messages are displayed.

Definition at line 157 of file vtkObject.h.

int vtkObject::GetGlobalWarningDisplay ( ) [static]

This is a global flag that controls whether any debug, warning or error messages are displayed.

void vtkObject::Register ( vtkObject * o )

Increase the reference count (mark as used by another object).

virtual void vtkObject::UnRegister ( vtkObject * o ) [virtual]

Decrease the reference count (release by another object). This has the same effect as invoking Delete() (i.e., it reduces the reference count by 1).

Reimplemented in vtkAbstractTransform, vtkDataObject, vtkPointSet, vtkSource, vtkSelectPolyData, vtkRenderWindow, and vtkRenderWindowInteractor.

int vtkObject::GetReferenceCount ( ) [inline]

Return the current reference count of this object.

Definition at line 172 of file vtkObject.h.

void vtkObject::SetReferenceCount ( int )

Sets the reference count. (This is very dangerous, use with care.)

unsigned long vtkObject::AddObserver | ( | unsigned long | event,
 |  | vtkCommand * | ,
 |  | float | priority = 0.0
 | ) |

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

unsigned long vtkObject::AddObserver | ( | const char * | event,
 |  | vtkCommand * | ,
 |  | float | priority = 0.0
 | ) |

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

vtkCommand* vtkObject::GetCommand ( unsigned long tag )

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

void vtkObject::InvokeEvent | ( | unsigned long | event,
 |  | void * | callData
 | ) |

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

void vtkObject::InvokeEvent | ( | const char * | event,
 |  | void * | callData
 | ) |

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

void vtkObject::RemoveObserver ( vtkCommand * )

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

void vtkObject::RemoveObserver ( unsigned long tag )

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

int vtkObject::HasObserver ( unsigned long event )

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

int vtkObject::HasObserver ( const char * event )

Allow people to add/remove/invoke observers (callbacks) to any VTK object. This is an implementation of the subject/observer design pattern. An observer is added by specifying an event to respond to and a vtkCommand to execute. It returns an unsigned long tag which can be used later to remove the event or retrieve the command. When events are invoked, the observers are called in the order they were added. If a priority value is specified, then the higher priority commands are called first. A command may set an abort flag to stop processing of the event. BTX

virtual void vtkObject::CollectRevisions ( ostream & os ) [protected, virtual]

Friends And Related Function Documentation

VTK_COMMON_EXPORT ostream& operator<< | ( | ostream & | os,
 |  | vtkObject & | o
 | ) | [friend]

Member Data Documentation

unsigned char vtkObject::Debug [protected]

Definition at line 207 of file vtkObject.h.

vtkTimeStamp vtkObject::MTime [protected]

Definition at line 208 of file vtkObject.h.

int vtkObject::ReferenceCount [protected]

Definition at line 209 of file vtkObject.h.

vtkSubjectHelper* vtkObject::SubjectHelper [protected]

Definition at line 210 of file vtkObject.h.

The documentation for this class was generated from the following file:
  • Common/vtkObject.h
Generated on Mon Mar 25 01:25:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObjectFactory Class Reference

abstract base class for vtkObjectFactories. More...

#include <vtkObjectFactory.h>

Inheritance diagram for vtkObjectFactory:

[legend]
Collaboration diagram for vtkObjectFactory:

[legend]
List of all members.

Public Types

typedef vtkObject *(* | CreateFunction )()

Public Methods

vtkTypeRevisionMacro (vtkObjectFactory, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual const char * | GetVTKSourceVersion ()=0
virtual const char * | GetDescription ()=0
virtual int | GetNumberOfOverrides ()
virtual const char * | GetClassOverrideName (int index)
virtual const char * | GetClassOverrideWithName (int index)
virtual int | GetEnableFlag (int index)
virtual const char * | GetOverrideDescription (int index)
virtual void | Disable (const char *className)
virtual void | SetEnableFlag (int flag, const char *className, const char *subclassName)
virtual int | GetEnableFlag (const char *className, const char *subclassName)
virtual int | HasOverride (const char *className)
virtual int | HasOverride (const char *className, const char *subclassName)
virtual char * | GetLibraryPath ()

Static Public Methods

vtkObject * | CreateInstance (const char *vtkclassname)
vtkObjectFactoryCollection * GetRegisteredFactories ()
int | HasOverrideAny (const char *className)
void | CreateAllInstance (const char *vtkclassname, vtkCollection *retList)
void | ReHash ()
void | RegisterFactory (vtkObjectFactory *)
void | UnRegisterFactory (vtkObjectFactory *)
void | UnRegisterAllFactories ()
void | GetOverrideInformation (const char *name, vtkOverrideInformationCollection *)
void | SetAllEnableFlags (int flag, const char *className)
void | SetAllEnableFlags (int flag, const char *className, const char *subclassName)

Protected Methods

virtual vtkObject * | CreateObject (const char *vtkclassname)
vtkObjectFactory ()
~vtkObjectFactory ()
void | RegisterOverride (const char *classOverride, const char *overrideClassName, const char *description, int enableFlag, CreateFunction createFunction)

Protected Attributes

OverrideInformation * OverrideArray
char ** | OverrideClassNames
int | SizeOverrideArray
int | OverrideArrayLength

Detailed Description

abstract base class for vtkObjectFactories.

Date:
2002/01/22 15:25:48
Revision:
1.23

vtkObjectFactory is used to create vtk objects. The base class vtkObjectFactory contains a static method CreateInstance which is used to create vtk objects from the list of registered vtkObjectFactory sub-classes. The first time CreateInstance is called, all dll's or shared libraries in the environment variable VTK_AUTOLOAD_PATH are loaded into the current process. The C functions vtkLoad, vtkGetFactoryCompilerUsed, and vtkGetFactoryVersion are called on each dll. To implement these functions in a shared library or dll, use the macro: VTK_FACTORY_INTERFACE_IMPLEMENT. VTK_AUTOLOAD_PATH is an environment variable containing a colon separated (semi-colon on win32) list of paths.

The vtkObjectFactory can be use to override the creation of any object in VTK with a sub-class of that object. The factories can be registered either at run time with the VTK_AUTOLOAD_PATH, or at compile time with the vtkObjectFactory::RegisterFactory method.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (94%)
Tests:
vtkObjectFactory (Tests)

Definition at line 62 of file vtkObjectFactory.h.

Member Typedef Documentation

typedef vtkObject*(* vtkObjectFactory::CreateFunction)()

Constructor & Destructor Documentation

vtkObjectFactory::vtkObjectFactory ( ) [protected]

vtkObjectFactory::~vtkObjectFactory ( ) [protected]

Member Function Documentation

vtkObject* vtkObjectFactory::CreateInstance ( const char * vtkclassname ) [static]

Create and return an instance of the named vtk object. Each loaded vtkObjectFactory will be asked in the order the factory was in the VTK_AUTOLOAD_PATH. After the first factory returns the object no other factories are asked.

void vtkObjectFactory::CreateAllInstance | ( | const char * | vtkclassname,
 |  | vtkCollection * | retList
 | ) | [static]

Create all possible instances of the named vtk object. Each registered vtkObjectFactory will be asked, and the result will be stored in the user allocated vtkCollection passed in to the function.

void vtkObjectFactory::ReHash ( ) [static]

Create all possible instances of the named vtk object. Each registered vtkObjectFactory will be asked, and the result will be stored in the user allocated vtkCollection passed in to the function.

void vtkObjectFactory::RegisterFactory ( vtkObjectFactory * ) [static]

Create all possible instances of the named vtk object. Each registered vtkObjectFactory will be asked, and the result will be stored in the user allocated vtkCollection passed in to the function.

void vtkObjectFactory::UnRegisterFactory ( vtkObjectFactory * ) [static]

Create all possible instances of the named vtk object. Each registered vtkObjectFactory will be asked, and the result will be stored in the user allocated vtkCollection passed in to the function.

void vtkObjectFactory::UnRegisterAllFactories ( ) [static]

Create all possible instances of the named vtk object. Each registered vtkObjectFactory will be asked, and the result will be stored in the user allocated vtkCollection passed in to the function.

vtkObjectFactoryCollection* vtkObjectFactory::GetRegisteredFactories ( ) [static]

Return the list of all registered factories. This is NOT a copy, do not remove items from this list!

int vtkObjectFactory::HasOverrideAny ( const char * className ) [static]

return 1 if one of the registered factories overrides the given class name

void vtkObjectFactory::GetOverrideInformation | ( | const char * | name,
 |  | vtkOverrideInformationCollection * |
 | ) | [static]

Fill the given collection with all the overrides for the class with the given name.

void vtkObjectFactory::SetAllEnableFlags | ( | int | flag,
 |  | const char * | className
 | ) | [static]

Set the enable flag for a given named class for all registered factories.

void vtkObjectFactory::SetAllEnableFlags | ( | int | flag,
 |  | const char * | className,
 |  | const char * | subclassName
 | ) | [static]

Set the enable flag for a given named class for all registered factories.

vtkObjectFactory::vtkTypeRevisionMacro | ( | vtkObjectFactory | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkParallelFactory, and vtkKitwareObjectFactory.

virtual void vtkObjectFactory::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactory to stream.

Reimplemented from vtkObject.

Reimplemented in vtkParallelFactory, and vtkKitwareObjectFactory.

virtual const char* vtkObjectFactory::GetVTKSourceVersion ( ) [pure virtual]

All sub-classes of vtkObjectFactory should must return the version of VTK they were built with. This should be implemented with the macro VTK_SOURCE_VERSION and NOT a call to vtkVersion::GetVTKSourceVersion. As the version needs to be compiled into the file as a string constant. This is critical to determine possible incompatible dynamic factory loads.

Reimplemented in vtkParallelFactory, and vtkKitwareObjectFactory.

virtual const char* vtkObjectFactory::GetDescription ( ) [pure virtual]

Return a descriptive string describing the factory.

Reimplemented in vtkParallelFactory.

virtual int vtkObjectFactory::GetNumberOfOverrides ( ) [virtual]

Return number of overrides this factory can create.

virtual const char* vtkObjectFactory::GetClassOverrideName ( int index ) [virtual]

Return the name of a class override at the given index.

virtual const char* vtkObjectFactory::GetClassOverrideWithName ( int index ) [virtual]

Return the name of the class that will override the class at the given index

virtual int vtkObjectFactory::GetEnableFlag ( int index ) [virtual]

Return the enable flag for the class at the given index.

virtual const char* vtkObjectFactory::GetOverrideDescription ( int index ) [virtual]

Return the description for a the class override at the given index.

virtual void vtkObjectFactory::SetEnableFlag | ( | int | flag,
 |  | const char * | className,
 |  | const char * | subclassName
 | ) | [virtual]

Set and Get the Enable flag for the specific override of className. if subclassName is null, then it is ignored.

virtual int vtkObjectFactory::GetEnableFlag | ( | const char * | className,
 |  | const char * | subclassName
 | ) | [virtual]

Set and Get the Enable flag for the specific override of className. if subclassName is null, then it is ignored.

virtual int vtkObjectFactory::HasOverride ( const char * className ) [virtual]

Return 1 if this factory overrides the given class name, 0 otherwise.

virtual int vtkObjectFactory::HasOverride | ( | const char * | className,
 |  | const char * | subclassName
 | ) | [virtual]

Return 1 if this factory overrides the given class name, 0 otherwise.

virtual void vtkObjectFactory::Disable ( const char * className ) [virtual]

Set all enable flags for the given class to 0. This will mean that the factory will stop producing class with the given name.

virtual char* vtkObjectFactory::GetLibraryPath ( ) [virtual]

This returns the path to a dynamically loaded factory.

void vtkObjectFactory::RegisterOverride | ( | const char * | classOverride,
 |  | const char * | overrideClassName,
 |  | const char * | description,
 |  | int | enableFlag,
 |  | CreateFunction | createFunction
 | ) | [protected]

Register object creation information with the factory.

virtual vtkObject* vtkObjectFactory::CreateObject ( const char * vtkclassname ) [protected, virtual]

This method is provided by sub-classes of vtkObjectFactory. It should create the named vtk object or return 0 if that object is not supported by the factory implementation.

Reimplemented in vtkKitwareObjectFactory.

Member Data Documentation

OverrideInformation* vtkObjectFactory::OverrideArray [protected]

Definition at line 217 of file vtkObjectFactory.h.

char** vtkObjectFactory::OverrideClassNames [protected]

Definition at line 218 of file vtkObjectFactory.h.

int vtkObjectFactory::SizeOverrideArray [protected]

Definition at line 219 of file vtkObjectFactory.h.

int vtkObjectFactory::OverrideArrayLength [protected]

Definition at line 220 of file vtkObjectFactory.h.

The documentation for this class was generated from the following file:
  • Common/vtkObjectFactory.h
Generated on Mon Mar 25 01:25:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObjectFactory::OverrideInformation Struct Reference

#include <vtkObjectFactory.h>

Collaboration diagram for vtkObjectFactory::OverrideInformation:

[legend]
List of all members.

Public Attributes

char * | Description
char * | OverrideWithName
int | EnabledFlag
CreateFunction CreateCallback

Member Data Documentation

char* vtkObjectFactory::OverrideInformation::Description

Definition at line 211 of file vtkObjectFactory.h.

char* vtkObjectFactory::OverrideInformation::OverrideWithName

Definition at line 212 of file vtkObjectFactory.h.

int vtkObjectFactory::OverrideInformation::EnabledFlag

Definition at line 213 of file vtkObjectFactory.h.

CreateFunction vtkObjectFactory::OverrideInformation::CreateCallback

Definition at line 214 of file vtkObjectFactory.h.

The documentation for this struct was generated from the following file:
  • Common/vtkObjectFactory.h
Generated on Mon Mar 25 01:25:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkObjectFactoryCollection Class Reference

maintain a list of object factories. More...

#include <vtkObjectFactoryCollection.h>

Inheritance diagram for vtkObjectFactoryCollection:

[legend]
Collaboration diagram for vtkObjectFactoryCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkObjectFactoryCollection, vtkCollection)
void | AddItem (vtkObjectFactory *t)
vtkObjectFactory * GetNextItem ()

Static Public Methods

vtkObjectFactoryCollection * | New ()

Protected Methods

vtkObjectFactoryCollection ()
~vtkObjectFactoryCollection ()

Detailed Description

maintain a list of object factories.

Date:
2002/01/22 15:25:49
Revision:
1.18

vtkObjectFactoryCollection is an object that creates and manipulates lists of object of type vtkObjectFactory.

See also:
vtkCollection vtkObjectFactory
Created by:
  • Hoffman, Bill
  • King, Brad
Contributed by (if > 5%):
  • Hoffman, Bill (44%)
  • King, Brad (20%)
  • Schroeder, Will (16%)
  • Martin, Ken (14%)

Definition at line 46 of file vtkObjectFactoryCollection.h.

Constructor & Destructor Documentation

vtkObjectFactoryCollection::vtkObjectFactoryCollection ( ) [inline, protected]

Definition at line 60 of file vtkObjectFactoryCollection.h.

vtkObjectFactoryCollection::~vtkObjectFactoryCollection ( ) [inline, protected]

Definition at line 61 of file vtkObjectFactoryCollection.h.

Member Function Documentation

vtkObjectFactoryCollection::vtkTypeRevisionMacro | ( | vtkObjectFactoryCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkObjectFactoryCollection* vtkObjectFactoryCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkObjectFactoryCollection::AddItem ( vtkObjectFactory * t ) [inline]

Add an ObjectFactory from the list.

Definition at line 53 of file vtkObjectFactoryCollection.h.

vtkObjectFactory* vtkObjectFactoryCollection::GetNextItem ( ) [inline]

Get the next ObjectFactory in the list. Return NULL when the end of the list is reached.

Definition at line 57 of file vtkObjectFactoryCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkObjectFactoryCollection.h
Generated on Mon Mar 25 01:25:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBJExporter Class Reference

export a scene into Wavefront format. More...

#include <vtkOBJExporter.h>

Inheritance diagram for vtkOBJExporter:

[legend]
Collaboration diagram for vtkOBJExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOBJExporter, vtkExporter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFilePrefix (const char *)
virtual char * | GetFilePrefix ()

Static Public Methods

vtkOBJExporter * | New ()

Protected Methods

vtkOBJExporter ()
~vtkOBJExporter ()
void | WriteData ()
void | WriteAnActor (vtkActor *anActor, FILE *fpObj, FILE *fpMat, int &id)

Protected Attributes

char * | FilePrefix

Detailed Description

export a scene into Wavefront format.

Date:
2002/01/22 15:38:47
Revision:
1.25

vtkOBJExporter is a concrete subclass of vtkExporter that writes wavefront .OBJ files in ASCII form. It also writes out a mtl file that contains the material properties. The filenames are derived by appending the .obj and .mtl suffix onto the user specified FilePrefix.

See also:
vtkExporter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (70%)
  • Henderson, Amy (10%)
  • Lorensen, Bill (8%)
Tests:
vtkOBJExporter (Tests)

Definition at line 48 of file vtkOBJExporter.h.

Constructor & Destructor Documentation

vtkOBJExporter::vtkOBJExporter ( ) [protected]

vtkOBJExporter::~vtkOBJExporter ( ) [protected]

Member Function Documentation

vtkOBJExporter* vtkOBJExporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkOBJExporter::vtkTypeRevisionMacro | ( | vtkOBJExporter | ,
 |  | vtkExporter |
 | ) |

Reimplemented from vtkExporter.

void vtkOBJExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExporter.

virtual void vtkOBJExporter::SetFilePrefix ( const char * ) [virtual]

Specify the prefix of the files to write out. The resulting filenames will have .obj and .mtl appended to them.

virtual char* vtkOBJExporter::GetFilePrefix ( ) [virtual]

Specify the prefix of the files to write out. The resulting filenames will have .obj and .mtl appended to them.

void vtkOBJExporter::WriteData ( ) [protected, virtual]

Reimplemented from vtkExporter.

void vtkOBJExporter::WriteAnActor | ( | vtkActor * | anActor,
 |  | FILE * | fpObj,
 |  | FILE * | fpMat,
 |  | int & | id
 | ) | [protected]

Member Data Documentation

char* vtkOBJExporter::FilePrefix [protected]

Definition at line 68 of file vtkOBJExporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOBJExporter.h
Generated on Mon Mar 25 01:25:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOBJReader Class Reference

read Wavefront .obj files. More...

#include <vtkOBJReader.h>

Inheritance diagram for vtkOBJReader:

[legend]
Collaboration diagram for vtkOBJReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOBJReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkOBJReader * | New ()

Protected Methods

vtkOBJReader ()
~vtkOBJReader ()
void | Execute ()

Protected Attributes

char * | FileName

Detailed Description

read Wavefront .obj files.

Date:
2002/01/22 15:38:17
Revision:
1.19

vtkOBJReader is a source object that reads Wavefront .obj files. The output of this source object is polygonal data.

See also:
vtkOBJImporter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (52%)
  • Lorensen, Bill (31%)
  • Geveci, Berk (6%)
Tests:
vtkOBJReader (Tests)

Definition at line 45 of file vtkOBJReader.h.

Constructor & Destructor Documentation

vtkOBJReader::vtkOBJReader ( ) [protected]

vtkOBJReader::~vtkOBJReader ( ) [protected]

Member Function Documentation

vtkOBJReader* vtkOBJReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkOBJReader::vtkTypeRevisionMacro | ( | vtkOBJReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkOBJReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkOBJReader::SetFileName ( const char * ) [virtual]

Specify file name of Wavefront .obj file.

virtual char* vtkOBJReader::GetFileName ( ) [virtual]

Specify file name of Wavefront .obj file.

void vtkOBJReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkOBJReader::FileName [protected]

Definition at line 64 of file vtkOBJReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkOBJReader.h
Generated on Mon Mar 25 01:25:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ofstream Struct Reference

#include <vtkWinCE.h>

List of all members.

Public Methods

ofstream & | operator<< (const char *str)
ofstream & | operator<< (void *str)
ofstream & | operator<< (short x)
ofstream & | operator<< (unsigned short x)
ofstream & | operator<< (int x)
ofstream & | operator<< (long l)
ofstream & | operator<< (unsigned long l)
ofstream & | operator<< (char ch)
ofstream & | operator<< (float fl)
ofstream & | operator<< (double dbl)
write (void *data, size_t size)

Member Function Documentation

ofstream& ofstream::operator<< ( const char * str )

ofstream& ofstream::operator<< ( void * str )

ofstream& ofstream::operator<< ( short x )

ofstream& ofstream::operator<< ( unsigned short x )

ofstream& ofstream::operator<< ( int x )

ofstream& ofstream::operator<< ( long l )

ofstream& ofstream::operator<< ( unsigned long l )

ofstream& ofstream::operator<< ( char ch )

ofstream& ofstream::operator<< ( float fl )

ofstream& ofstream::operator<< ( double dbl )

ofstream::write | ( | void * | data,
 |  | size_t | size
 | ) |

The documentation for this struct was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:25:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOldStyleCallbackCommand Class Reference

old syntax for callbacks. More...

#include <vtkOldStyleCallbackCommand.h>

Inheritance diagram for vtkOldStyleCallbackCommand:

[legend]
Collaboration diagram for vtkOldStyleCallbackCommand:

[legend]
List of all members.

Public Methods

void | SetClientData (void *cd)
void | SetCallback (void(*f)(void *))
void | SetClientDataDeleteCallback (void(*f)(void *))
void | Execute (vtkObject *, unsigned long, void *)

Static Public Methods

vtkOldStyleCallbackCommand * | New ()

Public Attributes

void * | ClientData
void(* | Callback )(void *)
void(* | ClientDataDeleteCallback )(void *)

Protected Methods

vtkOldStyleCallbackCommand ()
~vtkOldStyleCallbackCommand ()

Detailed Description

old syntax for callbacks.

Date:
2002/01/22 15:25:49
Revision:
1.2
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (100%)

Definition at line 35 of file vtkOldStyleCallbackCommand.h.

Constructor & Destructor Documentation

vtkOldStyleCallbackCommand::vtkOldStyleCallbackCommand ( ) [protected]

vtkOldStyleCallbackCommand::~vtkOldStyleCallbackCommand ( ) [protected]

Member Function Documentation

vtkOldStyleCallbackCommand* vtkOldStyleCallbackCommand::New ( ) [inline, static]

Definition at line 38 of file vtkOldStyleCallbackCommand.h.

void vtkOldStyleCallbackCommand::SetClientData ( void * cd ) [inline]

Definition at line 41 of file vtkOldStyleCallbackCommand.h.

void vtkOldStyleCallbackCommand::SetCallback ( void(* f)(void *) ) [inline]

Definition at line 43 of file vtkOldStyleCallbackCommand.h.

void vtkOldStyleCallbackCommand::SetClientDataDeleteCallback ( void(* f)(void *) ) [inline]

Definition at line 45 of file vtkOldStyleCallbackCommand.h.

void vtkOldStyleCallbackCommand::Execute | ( | vtkObject * | caller,
 |  | unsigned long | event,
 |  | void * | callData
 | ) | [virtual]

Reimplemented from vtkCommand.

Member Data Documentation

void* vtkOldStyleCallbackCommand::ClientData

Definition at line 50 of file vtkOldStyleCallbackCommand.h.

void(* vtkOldStyleCallbackCommand::Callback)(void *)

void(* vtkOldStyleCallbackCommand::ClientDataDeleteCallback)(void *)

The documentation for this class was generated from the following file:
  • Common/vtkOldStyleCallbackCommand.h
Generated on Mon Mar 25 01:25:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


OmniLight Struct Reference

#include <vtk3DS.h>

Collaboration diagram for OmniLight:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS Vector pos
Colour col
vtkLight * aLight

Member Data Documentation

VTK_LIST_FIELDS Vector OmniLight::pos

Definition at line 55 of file vtk3DS.h.

Colour OmniLight::col

Definition at line 56 of file vtk3DS.h.

vtkLight* OmniLight::aLight

Definition at line 57 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:25:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOOGLExporter Class Reference

export a scene into Geomview OOGL format. More...

#include <vtkOOGLExporter.h>

Inheritance diagram for vtkOOGLExporter:

[legend]
Collaboration diagram for vtkOOGLExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOOGLExporter, vtkExporter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkOOGLExporter * | New ()

Protected Methods

vtkOOGLExporter ()
~vtkOOGLExporter ()
void | WriteData ()
void | WriteALight (vtkLight *aLight, FILE *fp)
void | WriteAnActor (vtkActor *anActor, FILE *fp, int count)

Protected Attributes

char * | FileName

Detailed Description

export a scene into Geomview OOGL format.

Date:
2002/01/22 15:38:47
Revision:
1.5

vtkOOGLExporter is a concrete subclass of vtkExporter that writes Geomview OOGL files.

See also:
vtkExporter
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (93%)
Tests:
vtkOOGLExporter (Tests)

Definition at line 45 of file vtkOOGLExporter.h.

Constructor & Destructor Documentation

vtkOOGLExporter::vtkOOGLExporter ( ) [protected]

vtkOOGLExporter::~vtkOOGLExporter ( ) [protected]

Member Function Documentation

vtkOOGLExporter* vtkOOGLExporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkOOGLExporter::vtkTypeRevisionMacro | ( | vtkOOGLExporter | ,
 |  | vtkExporter |
 | ) |

Reimplemented from vtkExporter.

void vtkOOGLExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExporter.

virtual void vtkOOGLExporter::SetFileName ( const char * ) [virtual]

Specify the name of the Geomview file to write.

virtual char* vtkOOGLExporter::GetFileName ( ) [virtual]

Specify the name of the Geomview file to write.

void vtkOOGLExporter::WriteData ( ) [protected, virtual]

Reimplemented from vtkExporter.

void vtkOOGLExporter::WriteALight | ( | vtkLight * | aLight,
 |  | FILE * | fp
 | ) | [protected]

void vtkOOGLExporter::WriteAnActor | ( | vtkActor * | anActor,
 |  | FILE * | fp,
 |  | int | count
 | ) | [protected]

Member Data Documentation

char* vtkOOGLExporter::FileName [protected]

Definition at line 65 of file vtkOOGLExporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOOGLExporter.h
Generated on Mon Mar 25 01:25:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLActor Class Reference

OpenGL actor. More...

#include <vtkOpenGLActor.h>

Inheritance diagram for vtkOpenGLActor:

[legend]
Collaboration diagram for vtkOpenGLActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLActor, vtkActor)
void | Render (vtkRenderer *ren, vtkMapper *mapper)

Static Public Methods

vtkOpenGLActor * | New ()

Protected Methods

vtkOpenGLActor ()
~vtkOpenGLActor ()

Detailed Description

OpenGL actor.

Date:
2002/01/22 15:38:48
Revision:
1.17

vtkOpenGLActor is a concrete implementation of the abstract class vtkActor. vtkOpenGLActor interfaces to the OpenGL rendering library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (44%)
  • Martin, Ken (28%)
  • Avila, Lisa (7%)
  • Lorensen, Bill (6%)

Definition at line 42 of file vtkOpenGLActor.h.

Constructor & Destructor Documentation

vtkOpenGLActor::vtkOpenGLActor ( ) [inline, protected]

Definition at line 54 of file vtkOpenGLActor.h.

vtkOpenGLActor::~vtkOpenGLActor ( ) [inline, protected]

Definition at line 55 of file vtkOpenGLActor.h.

Member Function Documentation

vtkOpenGLActor* vtkOpenGLActor::New ( ) [static]

Creates an actor with the following defaults: origin(0,0,0) position=(0,0,0) scale=(1,1,1) visibility=1 pickable=1 dragable=1 orientation=(0,0,0). No user defined matrix and no texture map.

Reimplemented from vtkActor.

vtkOpenGLActor::vtkTypeRevisionMacro | ( | vtkOpenGLActor | ,
 |  | vtkActor |
 | ) |

Reimplemented from vtkActor.

void vtkOpenGLActor::Render | ( | vtkRenderer * | ren,
 |  | vtkMapper * | mapper
 | ) | [virtual]

Actual actor render method.

Reimplemented from vtkActor.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLActor.h
Generated on Mon Mar 25 01:25:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLCamera Class Reference

OpenGL camera. More...

#include <vtkOpenGLCamera.h>

Inheritance diagram for vtkOpenGLCamera:

[legend]
Collaboration diagram for vtkOpenGLCamera:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLCamera, vtkCamera)
void | Render (vtkRenderer *ren)
void | UpdateViewport (vtkRenderer *ren)

Static Public Methods

vtkOpenGLCamera * | New ()

Protected Methods

vtkOpenGLCamera ()
~vtkOpenGLCamera ()

Detailed Description

OpenGL camera.

Date:
2002/01/22 15:38:48
Revision:
1.20

vtkOpenGLCamera is a concrete implementation of the abstract class vtkCamera. vtkOpenGLCamera interfaces to the OpenGL rendering library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Martin, Ken (44%)
  • Schroeder, Will (30%)
  • Hoffman, Bill (5%)

Definition at line 41 of file vtkOpenGLCamera.h.

Constructor & Destructor Documentation

vtkOpenGLCamera::vtkOpenGLCamera ( ) [inline, protected]

Definition at line 53 of file vtkOpenGLCamera.h.

vtkOpenGLCamera::~vtkOpenGLCamera ( ) [inline, protected]

Definition at line 54 of file vtkOpenGLCamera.h.

Member Function Documentation

vtkOpenGLCamera* vtkOpenGLCamera::New ( ) [static]

Construct camera instance with its focal point at the origin, and position=(0,0,1). The view up is along the y-axis, view angle is 30 degrees, and the clipping range is (.1,1000).

Reimplemented from vtkCamera.

vtkOpenGLCamera::vtkTypeRevisionMacro | ( | vtkOpenGLCamera | ,
 |  | vtkCamera |
 | ) |

Reimplemented from vtkCamera.

void vtkOpenGLCamera::Render ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkCamera.

void vtkOpenGLCamera::UpdateViewport ( vtkRenderer * ren )

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLCamera.h
Generated on Mon Mar 25 01:25:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageActor Class Reference

OpenGL texture map. More...

#include <vtkOpenGLImageActor.h>

Inheritance diagram for vtkOpenGLImageActor:

[legend]
Collaboration diagram for vtkOpenGLImageActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLImageActor, vtkImageActor)
void | Load (vtkRenderer *ren)
void | ReleaseGraphicsResources (vtkWindow *)

Static Public Methods

vtkOpenGLImageActor * | New ()

Protected Methods

vtkOpenGLImageActor ()
~vtkOpenGLImageActor ()
unsigned char * | MakeDataSuitable (int &xsize, int &ysize, int &release)

Protected Attributes

vtkTimeStamp LoadTime
long | Index
vtkRenderWindow * RenderWindow
float | Coords [12]
float | TCoords [8]

Detailed Description

OpenGL texture map.

Date:
2002/01/22 15:38:48
Revision:
1.8

vtkOpenGLImageActor is a concrete implementation of the abstract class vtkImageActor. vtkOpenGLImageActor interfaces to the OpenGL rendering library.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (90%)

Definition at line 41 of file vtkOpenGLImageActor.h.

Constructor & Destructor Documentation

vtkOpenGLImageActor::vtkOpenGLImageActor ( ) [protected]

vtkOpenGLImageActor::~vtkOpenGLImageActor ( ) [protected]

Member Function Documentation

vtkOpenGLImageActor* vtkOpenGLImageActor::New ( ) [static]

Instantiate the image actor.

Reimplemented from vtkImageActor.

vtkOpenGLImageActor::vtkTypeRevisionMacro | ( | vtkOpenGLImageActor | ,
 |  | vtkImageActor |
 | ) |

Reimplemented from vtkImageActor.

void vtkOpenGLImageActor::Load ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkImageActor.

void vtkOpenGLImageActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this texture. The parameter window could be used to determine which graphic resources to release. Using the same texture object in multiple render windows is NOT currently supported.

Reimplemented from vtkProp.

unsigned char* vtkOpenGLImageActor::MakeDataSuitable | ( | int & | xsize,
 |  | int & | ysize,
 |  | int & | release
 | ) | [protected]

Member Data Documentation

vtkTimeStamp vtkOpenGLImageActor::LoadTime [protected]

Definition at line 62 of file vtkOpenGLImageActor.h.

long vtkOpenGLImageActor::Index [protected]

Definition at line 63 of file vtkOpenGLImageActor.h.

vtkRenderWindow* vtkOpenGLImageActor::RenderWindow [protected]

Definition at line 64 of file vtkOpenGLImageActor.h.

float vtkOpenGLImageActor::Coords[12] [protected]

Definition at line 65 of file vtkOpenGLImageActor.h.

float vtkOpenGLImageActor::TCoords[8] [protected]

Definition at line 66 of file vtkOpenGLImageActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLImageActor.h
Generated on Mon Mar 25 01:25:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageMapper Class Reference

2D image display support for OpenGL. More...

#include <vtkOpenGLImageMapper.h>

Inheritance diagram for vtkOpenGLImageMapper:

[legend]
Collaboration diagram for vtkOpenGLImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLImageMapper, vtkImageMapper)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderData (vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor)

Static Public Methods

vtkOpenGLImageMapper * | New ()

Protected Methods

vtkOpenGLImageMapper ()
~vtkOpenGLImageMapper ()

Detailed Description

2D image display support for OpenGL.

Date:
2002/01/22 15:38:48
Revision:
1.17

vtkOpenGLImageMapper is a concrete subclass of vtkImageMapper that renders images under OpenGL

See also:
vtkImageMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Gobbi, David (45%)
  • Martin, Ken (37%)
  • Biddiscombe, John (7%)

Definition at line 45 of file vtkOpenGLImageMapper.h.

Constructor & Destructor Documentation

vtkOpenGLImageMapper::vtkOpenGLImageMapper ( ) [protected]

vtkOpenGLImageMapper::~vtkOpenGLImageMapper ( ) [protected]

Member Function Documentation

vtkOpenGLImageMapper* vtkOpenGLImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapper.

vtkOpenGLImageMapper::vtkTypeRevisionMacro | ( | vtkOpenGLImageMapper | ,
 |  | vtkImageMapper |
 | ) |

Reimplemented from vtkImageMapper.

void vtkOpenGLImageMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Handle the render method.

Reimplemented from vtkMapper2D.

Definition at line 53 of file vtkOpenGLImageMapper.h.

void vtkOpenGLImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Called by the Render function in vtkImageMapper. Actually draws the image to the screen.

Reimplemented from vtkImageMapper.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLImageMapper.h
Generated on Mon Mar 25 01:25:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImager Class Reference

#include <vtkOpenGLImager.h>

Inheritance diagram for vtkOpenGLImager:

[legend]
Collaboration diagram for vtkOpenGLImager:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLImager, vtkImager)
int | RenderOpaqueGeometry ()
void | Erase ()

Static Public Methods

vtkOpenGLImager * | New ()

Protected Methods

vtkOpenGLImager ()
~vtkOpenGLImager ()

Constructor & Destructor Documentation

vtkOpenGLImager::vtkOpenGLImager ( ) [inline, protected]

Definition at line 54 of file vtkOpenGLImager.h.

vtkOpenGLImager::~vtkOpenGLImager ( ) [inline, protected]

Definition at line 55 of file vtkOpenGLImager.h.

Member Function Documentation

vtkOpenGLImager* vtkOpenGLImager::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkImager.

vtkOpenGLImager::vtkTypeRevisionMacro | ( | vtkOpenGLImager | ,
 |  | vtkImager |
 | ) |

Reimplemented from vtkImager.

int vtkOpenGLImager::RenderOpaqueGeometry ( ) [virtual]

Renders an imager. Passes Render message on the the imager's actor2D collection.

Reimplemented from vtkImager.

void vtkOpenGLImager::Erase ( ) [virtual]

Erase the contents of the imager in the window.

Reimplemented from vtkImager.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLImager.h
Generated on Mon Mar 25 01:25:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLImageWindow Class Reference

OpenGL Imageing window. More...

#include <vtkOpenGLImageWindow.h>

Inheritance diagram for vtkOpenGLImageWindow:

[legend]
Collaboration diagram for vtkOpenGLImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLImageWindow, vtkXImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | MakeDefaultWindow ()
void | SwapBuffers ()
void | Frame ()
void | Render ()
void | MakeCurrent ()
virtual void | EraseWindow ()
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void * | GetGenericDrawable ()
virtual Colormap | GetDesiredColormap ()
virtual Visual * | GetDesiredVisual ()
XVisualInfo * | GetDesiredVisualInfo ()
virtual int | GetDesiredDepth ()
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)

Static Public Methods

vtkOpenGLImageWindow * | New ()

Public Attributes

GLXContext | ContextId

Protected Methods

vtkOpenGLImageWindow ()
~vtkOpenGLImageWindow ()

Detailed Description

OpenGL Imageing window.

Date:
2002/01/22 15:38:49
Revision:
1.21

vtkOpenGLImageWindow is a concrete implementation of the abstract class vtkImageWindow. vtkOpenGLImageer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (89%)

Definition at line 44 of file vtkOpenGLImageWindow.h.

Constructor & Destructor Documentation

vtkOpenGLImageWindow::vtkOpenGLImageWindow ( ) [protected]

vtkOpenGLImageWindow::~vtkOpenGLImageWindow ( ) [protected]

Member Function Documentation

vtkOpenGLImageWindow* vtkOpenGLImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkXImageWindow.

vtkOpenGLImageWindow::vtkTypeRevisionMacro | ( | vtkOpenGLImageWindow | ,
 |  | vtkXImageWindow |
 | ) |

Reimplemented from vtkXImageWindow.

void vtkOpenGLImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkXImageWindow.

virtual void vtkOpenGLImageWindow::MakeDefaultWindow ( ) [virtual]

Initialize the window for rendering.

Reimplemented from vtkXImageWindow.

void vtkOpenGLImageWindow::SwapBuffers ( ) [virtual]

Swap the front and back buffers if double buffering is being used.

Reimplemented from vtkXImageWindow.

void vtkOpenGLImageWindow::Frame ( ) [virtual]

Flush the buffers and swap if necessary

Reimplemented from vtkXImageWindow.

void vtkOpenGLImageWindow::Render ( void ) [virtual]

Draw the contents of the window

Reimplemented from vtkImageWindow.

virtual void* vtkOpenGLImageWindow::GetGenericDisplayId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 65 of file vtkOpenGLImageWindow.h.

virtual void* vtkOpenGLImageWindow::GetGenericWindowId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 66 of file vtkOpenGLImageWindow.h.

virtual void* vtkOpenGLImageWindow::GetGenericParentId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 67 of file vtkOpenGLImageWindow.h.

virtual void* vtkOpenGLImageWindow::GetGenericContext ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

virtual void* vtkOpenGLImageWindow::GetGenericDrawable ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkXImageWindow.

Definition at line 69 of file vtkOpenGLImageWindow.h.

virtual Colormap vtkOpenGLImageWindow::GetDesiredColormap ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

virtual Visual* vtkOpenGLImageWindow::GetDesiredVisual ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

XVisualInfo* vtkOpenGLImageWindow::GetDesiredVisualInfo ( )

Get the X properties of an ideal rendering window.

virtual int vtkOpenGLImageWindow::GetDesiredDepth ( ) [virtual]

Get the X properties of an ideal rendering window.

Reimplemented from vtkXImageWindow.

virtual unsigned char* vtkOpenGLImageWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkXImageWindow.

virtual void vtkOpenGLImageWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

virtual float* vtkOpenGLImageWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkOpenGLImageWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

void vtkOpenGLImageWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkImageWindow.

virtual void vtkOpenGLImageWindow::EraseWindow ( ) [inline, virtual]

Erase the window contents

Reimplemented from vtkXImageWindow.

Definition at line 98 of file vtkOpenGLImageWindow.h.

Member Data Documentation

GLXContext vtkOpenGLImageWindow::ContextId

Definition at line 100 of file vtkOpenGLImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLImageWindow.h
Generated on Mon Mar 25 01:25:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLLight Class Reference

OpenGL light. More...

#include <vtkOpenGLLight.h>

Inheritance diagram for vtkOpenGLLight:

[legend]
Collaboration diagram for vtkOpenGLLight:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLLight, vtkLight)
void | Render (vtkRenderer *ren, int light_index)

Static Public Methods

vtkOpenGLLight * | New ()

Protected Methods

vtkOpenGLLight ()
~vtkOpenGLLight ()

Detailed Description

OpenGL light.

Date:
2002/01/22 15:38:50
Revision:
1.17

vtkOpenGLLight is a concrete implementation of the abstract class vtkLight. vtkOpenGLLight interfaces to the OpenGL rendering library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Halle, Michael (7%)
  • Martin, Ken (5%)

Definition at line 41 of file vtkOpenGLLight.h.

Constructor & Destructor Documentation

vtkOpenGLLight::vtkOpenGLLight ( ) [inline, protected]

Definition at line 51 of file vtkOpenGLLight.h.

vtkOpenGLLight::~vtkOpenGLLight ( ) [inline, protected]

Definition at line 52 of file vtkOpenGLLight.h.

Member Function Documentation

vtkOpenGLLight* vtkOpenGLLight::New ( ) [static]

Create a light with the focal point at the origin and its position set to (0,0,1). The light is a SceneLight, its color is white, intensity=1, and the light is turned on.

Reimplemented from vtkLight.

vtkOpenGLLight::vtkTypeRevisionMacro | ( | vtkOpenGLLight | ,
 |  | vtkLight |
 | ) |

Reimplemented from vtkLight.

void vtkOpenGLLight::Render | ( | vtkRenderer * | ren,
 |  | int | light_index
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkLight.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLLight.h
Generated on Mon Mar 25 01:25:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLPolyDataMapper Class Reference

a PolyDataMapper for the OpenGL library. More...

#include <vtkOpenGLPolyDataMapper.h>

Inheritance diagram for vtkOpenGLPolyDataMapper:

[legend]
Collaboration diagram for vtkOpenGLPolyDataMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLPolyDataMapper, vtkPolyDataMapper)
virtual void | RenderPiece (vtkRenderer *ren, vtkActor *a)
void | ReleaseGraphicsResources (vtkWindow *)
virtual int | Draw (vtkRenderer *ren, vtkActor *a)
GLenum | GetLmcolorMode (vtkProperty *prop)

Static Public Methods

vtkOpenGLPolyDataMapper * | New ()

Protected Methods

vtkOpenGLPolyDataMapper ()
~vtkOpenGLPolyDataMapper ()

Protected Attributes

int | ListId

Detailed Description

a PolyDataMapper for the OpenGL library.

Date:
2002/02/28 16:58:59
Revision:
1.29

vtkOpenGLPolyDataMapper is a subclass of vtkPolyDataMapper. vtkOpenGLPolyDataMapper is a geometric PolyDataMapper for the OpenGL rendering library.

Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Martin, Ken (37%)
  • Schroeder, Will (28%)
  • Lorensen, Bill (13%)
  • Geveci, Berk (6%)
  • Henderson, Amy (6%)

Definition at line 57 of file vtkOpenGLPolyDataMapper.h.

Constructor & Destructor Documentation

vtkOpenGLPolyDataMapper::vtkOpenGLPolyDataMapper ( ) [protected]

vtkOpenGLPolyDataMapper::~vtkOpenGLPolyDataMapper ( ) [protected]

Member Function Documentation

vtkOpenGLPolyDataMapper* vtkOpenGLPolyDataMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper.

vtkOpenGLPolyDataMapper::vtkTypeRevisionMacro | ( | vtkOpenGLPolyDataMapper | ,
 |  | vtkPolyDataMapper |
 | ) |

Reimplemented from vtkPolyDataMapper.

virtual void vtkOpenGLPolyDataMapper::RenderPiece | ( | vtkRenderer * | ren,
 |  | vtkActor * | a
 | ) | [virtual]

Implement superclass render method.

Reimplemented from vtkPolyDataMapper.

void vtkOpenGLPolyDataMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkMapper.

virtual int vtkOpenGLPolyDataMapper::Draw | ( | vtkRenderer * | ren,
 |  | vtkActor * | a
 | ) | [virtual]

Draw method for OpenGL.

GLenum vtkOpenGLPolyDataMapper::GetLmcolorMode ( vtkProperty * prop )

Get the lmcolor property, this is a pretty important little function. It determines how vertex colors will be handled in gl. When a PolyDataMapper has vertex colors it will use this method to determine what lmcolor mode to set.

Member Data Documentation

int vtkOpenGLPolyDataMapper::ListId [protected]

Definition at line 89 of file vtkOpenGLPolyDataMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLPolyDataMapper.h
Generated on Mon Mar 25 01:25:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLPolyDataMapper2D Class Reference

#include <vtkOpenGLPolyDataMapper2D.h>

Inheritance diagram for vtkOpenGLPolyDataMapper2D:

[legend]
Collaboration diagram for vtkOpenGLPolyDataMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLPolyDataMapper2D, vtkPolyDataMapper2D)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)

Static Public Methods

vtkOpenGLPolyDataMapper2D * | New ()

Protected Methods

vtkOpenGLPolyDataMapper2D ()
~vtkOpenGLPolyDataMapper2D ()

Constructor & Destructor Documentation

vtkOpenGLPolyDataMapper2D::vtkOpenGLPolyDataMapper2D ( ) [inline, protected]

Definition at line 54 of file vtkOpenGLPolyDataMapper2D.h.

vtkOpenGLPolyDataMapper2D::~vtkOpenGLPolyDataMapper2D ( ) [inline, protected]

Definition at line 55 of file vtkOpenGLPolyDataMapper2D.h.

Member Function Documentation

vtkOpenGLPolyDataMapper2D::vtkTypeRevisionMacro | ( | vtkOpenGLPolyDataMapper2D | ,
 |  | vtkPolyDataMapper2D |
 | ) |

Reimplemented from vtkPolyDataMapper2D.

vtkOpenGLPolyDataMapper2D* vtkOpenGLPolyDataMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper2D.

void vtkOpenGLPolyDataMapper2D::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actually draw the poly data.

Reimplemented from vtkMapper2D.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLPolyDataMapper2D.h
Generated on Mon Mar 25 01:26:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLProperty Class Reference

OpenGL property. More...

#include <vtkOpenGLProperty.h>

Inheritance diagram for vtkOpenGLProperty:

[legend]
Collaboration diagram for vtkOpenGLProperty:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLProperty, vtkProperty)
void | Render (vtkActor *a, vtkRenderer *ren)
void | BackfaceRender (vtkActor *a, vtkRenderer *ren)

Static Public Methods

vtkOpenGLProperty * | New ()

Protected Methods

vtkOpenGLProperty ()
~vtkOpenGLProperty ()

Detailed Description

OpenGL property.

Date:
2002/01/22 15:38:53
Revision:
1.18

vtkOpenGLProperty is a concrete implementation of the abstract class vtkProperty. vtkOpenGLProperty interfaces to the OpenGL rendering library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (50%)
  • Lorensen, Bill (18%)
  • Hoffman, Bill (13%)

Definition at line 41 of file vtkOpenGLProperty.h.

Constructor & Destructor Documentation

vtkOpenGLProperty::vtkOpenGLProperty ( ) [inline, protected]

Definition at line 54 of file vtkOpenGLProperty.h.

vtkOpenGLProperty::~vtkOpenGLProperty ( ) [inline, protected]

Definition at line 55 of file vtkOpenGLProperty.h.

Member Function Documentation

vtkOpenGLProperty* vtkOpenGLProperty::New ( ) [static]

Construct object with object color, ambient color, diffuse color, specular color, and edge color white; ambient coefficient=0; diffuse coefficient=0; specular coefficient=0; specular power=1; Gouraud shading; and surface representation. Backface and frontface culling are off.

Reimplemented from vtkProperty.

vtkOpenGLProperty::vtkTypeRevisionMacro | ( | vtkOpenGLProperty | ,
 |  | vtkProperty |
 | ) |

Reimplemented from vtkProperty.

void vtkOpenGLProperty::Render | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkProperty.

void vtkOpenGLProperty::BackfaceRender | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [virtual]

Implement base class method.

Reimplemented from vtkProperty.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLProperty.h
Generated on Mon Mar 25 01:26:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLRenderer Class Reference

OpenGL renderer. More...

#include <vtkOpenGLRenderer.h>

Inheritance diagram for vtkOpenGLRenderer:

[legend]
Collaboration diagram for vtkOpenGLRenderer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLRenderer, vtkRenderer)
void | PrintSelf (ostream &os, vtkIndent indent)
void | DeviceRender (void)
void | ClearLights (void)
void | Clear (void)
int | UpdateLights (void)

Static Public Methods

vtkOpenGLRenderer * | New ()

Protected Methods

vtkOpenGLRenderer ()
~vtkOpenGLRenderer ()
virtual void | DevicePickRender ()
virtual void | StartPick (unsigned int pickFromSize)
virtual void | UpdatePickId ()
virtual void | DonePick ()
virtual unsigned int | GetPickedId ()
virtual float | GetPickedZ ()

Protected Attributes

int | NumberOfLightsBound
vtkGLPickInfo * | PickInfo
float | PickedZ

Detailed Description

OpenGL renderer.

Date:
2002/01/22 15:38:55
Revision:
1.28

vtkOpenGLRenderer is a concrete implementation of the abstract class vtkRenderer. vtkOpenGLRenderer interfaces to the OpenGL graphics library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (52%)
  • Hoffman, Bill (18%)
  • Avila, Lisa (13%)
  • Martin, Ken (5%)

Definition at line 41 of file vtkOpenGLRenderer.h.

Constructor & Destructor Documentation

vtkOpenGLRenderer::vtkOpenGLRenderer ( ) [protected]

vtkOpenGLRenderer::~vtkOpenGLRenderer ( ) [protected]

Member Function Documentation

vtkOpenGLRenderer* vtkOpenGLRenderer::New ( ) [static]

Create a vtkRenderer with a black background, a white ambient light, two-sided lighting turned on, a viewport of (0,0,1,1), and backface culling turned off.

Reimplemented from vtkRenderer.

vtkOpenGLRenderer::vtkTypeRevisionMacro | ( | vtkOpenGLRenderer | ,
 |  | vtkRenderer |
 | ) |

Reimplemented from vtkRenderer.

void vtkOpenGLRenderer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderer.

void vtkOpenGLRenderer::DeviceRender ( void ) [virtual]

Concrete open gl render method.

Reimplemented from vtkRenderer.

void vtkOpenGLRenderer::ClearLights ( void )

Internal method temporarily removes lights before reloading them into graphics pipeline.

void vtkOpenGLRenderer::Clear ( void ) [virtual]

Clear the image to the background color.

Reimplemented from vtkRenderer.

int vtkOpenGLRenderer::UpdateLights ( void ) [virtual]

Ask lights to load themselves into graphics pipeline.

Reimplemented from vtkRenderer.

virtual void vtkOpenGLRenderer::DevicePickRender ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkOpenGLRenderer::StartPick ( unsigned int pickFromSize ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkOpenGLRenderer::UpdatePickId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual void vtkOpenGLRenderer::DonePick ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual unsigned int vtkOpenGLRenderer::GetPickedId ( ) [protected, virtual]

Reimplemented from vtkViewport.

virtual float vtkOpenGLRenderer::GetPickedZ ( ) [protected, virtual]

Return the Z value for the last picked Prop.

Reimplemented from vtkViewport.

Member Data Documentation

int vtkOpenGLRenderer::NumberOfLightsBound [protected]

Definition at line 44 of file vtkOpenGLRenderer.h.

class vtkGLPickInfo* vtkOpenGLRenderer::PickInfo [protected]

Definition at line 76 of file vtkOpenGLRenderer.h.

float vtkOpenGLRenderer::PickedZ [protected]

Definition at line 78 of file vtkOpenGLRenderer.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLRenderer.h
Generated on Mon Mar 25 01:26:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLRenderWindow Class Reference

OpenGL rendering window. More...

#include <vtkOpenGLRenderWindow.h>

Inheritance diagram for vtkOpenGLRenderWindow:

[legend]
Collaboration diagram for vtkOpenGLRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLRenderWindow, vtkRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | StereoUpdate ()
void | MakeCurrent ()=0
void | RegisterTextureResource (GLuint id)
int | GetDepthBufferSize ()
virtual void | OpenGLInit ()
virtual void | SetMultiSamples (int)
virtual int | GetMultiSamples ()
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)
virtual void | ReleaseRGBAPixelData (float *data)
virtual unsigned char * | GetRGBACharPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBACharPixelData (int x, int y, int x2, int y2, unsigned char *, int front, int blend=0)
virtual float * | GetZbufferData (int x1, int y1, int x2, int y2)
virtual void | SetZbufferData (int x1, int y1, int x2, int y2, float *buffer)

Static Public Methods

void | SetGlobalMaximumNumberOfMultiSamples (int val)
int | GetGlobalMaximumNumberOfMultiSamples ()

Protected Methods

vtkOpenGLRenderWindow ()
~vtkOpenGLRenderWindow ()

Protected Attributes

int | MultiSamples
long | OldMonitorSetting
vtkIdList * TextureResourceIds

Detailed Description

OpenGL rendering window.

Date:
2002/01/22 15:38:54
Revision:
1.32

vtkOpenGLRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkOpenGLRenderer interfaces to the OpenGL graphics library. Application programmers should normally use vtkRenderWindow instead of the OpenGL specific version.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (41%)
  • Martin, Ken (24%)
  • Miller, Jim (13%)
  • Lorensen, Bill (8%)
  • Geveci, Berk (5%)

Definition at line 51 of file vtkOpenGLRenderWindow.h.

Constructor & Destructor Documentation

vtkOpenGLRenderWindow::vtkOpenGLRenderWindow ( ) [protected]

vtkOpenGLRenderWindow::~vtkOpenGLRenderWindow ( ) [protected]

Member Function Documentation

vtkOpenGLRenderWindow::vtkTypeRevisionMacro | ( | vtkOpenGLRenderWindow | ,
 |  | vtkRenderWindow |
 | ) |

Reimplemented from vtkRenderWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, and vtkXOpenGLRenderWindow.

void vtkOpenGLRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, and vtkXOpenGLRenderWindow.

void vtkOpenGLRenderWindow::SetGlobalMaximumNumberOfMultiSamples ( int val ) [static]

Set/Get the maximum number of multisamples

int vtkOpenGLRenderWindow::GetGlobalMaximumNumberOfMultiSamples ( ) [static]

Set/Get the maximum number of multisamples

virtual void vtkOpenGLRenderWindow::SetMultiSamples ( int ) [virtual]

Set / Get the number of multisamples to use for hardware antialiasing.

virtual int vtkOpenGLRenderWindow::GetMultiSamples ( ) [virtual]

Set / Get the number of multisamples to use for hardware antialiasing.

virtual void vtkOpenGLRenderWindow::StereoUpdate ( ) [virtual]

Update system if needed due to stereo rendering.

Reimplemented from vtkRenderWindow.

virtual unsigned char* vtkOpenGLRenderWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkWindow.

virtual void vtkOpenGLRenderWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkRenderWindow.

virtual float* vtkOpenGLRenderWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkOpenGLRenderWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkOpenGLRenderWindow::ReleaseRGBAPixelData ( float * data ) [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual unsigned char* vtkOpenGLRenderWindow::GetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkOpenGLRenderWindow::SetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual float* vtkOpenGLRenderWindow::GetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

virtual void vtkOpenGLRenderWindow::SetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | float * | buffer
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

void vtkOpenGLRenderWindow::MakeCurrent ( ) [pure virtual]

Make this window the current OpenGL context.

Reimplemented from vtkRenderWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, and vtkXOpenGLRenderWindow.

void vtkOpenGLRenderWindow::RegisterTextureResource ( GLuint id )

Register a texture name with this render window.

int vtkOpenGLRenderWindow::GetDepthBufferSize ( ) [virtual]

Get the size of the depth buffer.

Reimplemented from vtkRenderWindow.

virtual void vtkOpenGLRenderWindow::OpenGLInit ( ) [virtual]

Initialize OpenGL for this window.

Member Data Documentation

int vtkOpenGLRenderWindow::MultiSamples [protected]

Definition at line 54 of file vtkOpenGLRenderWindow.h.

long vtkOpenGLRenderWindow::OldMonitorSetting [protected]

Definition at line 55 of file vtkOpenGLRenderWindow.h.

vtkIdList* vtkOpenGLRenderWindow::TextureResourceIds [protected]

Definition at line 118 of file vtkOpenGLRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLRenderWindow.h
Generated on Mon Mar 25 01:26:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLStateCache Class Reference

#include <vtkOpenGLStateCache.h>

Collaboration diagram for vtkOpenGLStateCache:

[legend]
List of all members.

Public Methods

vtkOpenGLStateCache ()
~vtkOpenGLStateCache ()
void | Initialize ()
void | glEnable (GLenum e)
void | glDisable (GLenum e)
void | glAlphaFunc (GLenum e, GLclampf cf)
void | glBlendFunc (GLenum e, GLenum e1)
void | glDepthFunc (GLenum e)
void | glTexEnvf (GLenum e, GLenum e1, GLfloat f)
void | glLightModeli (GLenum e, GLint i)
void | glLightModelfv (GLenum e, GLfloat *fv)
void | glLightfv (GLenum light, GLenum pname, const GLfloat *params)
void | glLightf (GLenum light, GLenum pname, GLfloat f)
void | glLighti (GLenum light, GLenum pname, GLint f)
void | glMaterialfv (GLenum face, GLenum pname, const GLfloat *params)
void | glShadeModel (GLenum e)
void | glClearColor (GLclampf r, GLclampf g, GLclampf b, GLclampf a)
void | glClearDepth (GLclampd d)
void | glDepthMask (GLenum e)
void | glCullFace (GLenum e)
void | glClear (GLbitfield b)
void | glDrawBuffer (GLenum e)
void | glMatrixMode (GLenum e)
void | glViewport (GLint llx, GLint lly, GLint u, GLint v)
void | glScissor (GLint llx, GLint lly, GLint u, GLint v)
void | glClipPlane (GLenum e, const GLdouble *eqn)
void | glColorMaterial (GLenum face, GLenum mode)
void | glPointSize (GLfloat f)
void | glLineWidth (GLfloat f)
void | glLineStipple (GLint factor, GLushort pattern)
void | glDepthRange (GLclampd nearval, GLclampd farval)

Public Attributes

char | Enable_buckets [0xDE1-0xB10+1]
char | Enable_GL_LIGHT_buckets [8]
char | Enable_GL_CLIP_PLANE_buckets [8]
GLclampf | AlphaFunc_bucket
GLenum | BlendFunc_bucket
GLenum | DepthFunc_bucket
GLfloat | TexEnvf_MODE_bucket
GLint | LightModeli_LIGHT_MODEL_TWO_SIDE_bucket
GLfloat | LightModelfv_LIGHT_MODEL_AMBIENT_bucket [3]
GLfloat | Lightfv_buckets [8 *4 *8]
GLfloat | Lightf_buckets [8 *8]
GLint | Lighti_SPOT_CUTOFF_buckets [8]
GLfloat | Materialfv_buckets [8 *8 *4]
GLenum | ShadeModel_bucket
GLclampf | ClearColor_buckets [4]
GLclampd | ClearDepth_bucket
GLclampf | DepthMask_bucket
GLenum | CullFace_bucket
GLenum | DrawBuffer_bucket
GLenum | MatrixMode_bucket
GLint | Viewport_bucket [4]
GLint | Scissor_bucket [4]
GLdouble | ClipPlane_bucket [4 *GL_MAX_CLIP_PLANES]
GLenum | ColorMaterial_bucket [8]
GLfloat | PointSize_bucket
GLfloat | LineWidth_bucket
GLint | LineStipple_FACTOR_bucket
GLushort | LineStipple_PATTERN_bucket
GLclampd | DepthRange_NEAR_bucket
GLclampd | DepthRange_FAR_bucket

Static Public Attributes

vtkOpenGLStateCache * | CurrentGLCache

Constructor & Destructor Documentation

vtkOpenGLStateCache::vtkOpenGLStateCache ( )

vtkOpenGLStateCache::~vtkOpenGLStateCache ( )

Member Function Documentation

void vtkOpenGLStateCache::Initialize ( )

void vtkOpenGLStateCache::glEnable ( GLenum e ) [inline]

Definition at line 133 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glDisable ( GLenum e ) [inline]

Definition at line 168 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glAlphaFunc | ( | GLenum | e,
 |  | GLclampf | cf
 | ) | [inline]

Definition at line 206 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glBlendFunc | ( | GLenum | e,
 |  | GLenum | e1
 | ) | [inline]

Definition at line 217 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glDepthFunc ( GLenum e ) [inline]

Definition at line 230 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glTexEnvf | ( | GLenum | e,
 |  | GLenum | e1,
 |  | GLfloat | f
 | ) | [inline]

Definition at line 241 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLightModeli | ( | GLenum | e,
 |  | GLint | i
 | ) | [inline]

Definition at line 256 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLightModelfv | ( | GLenum | e,
 |  | GLfloat * | fv
 | ) | [inline]

Definition at line 267 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLightfv | ( | GLenum | light,
 |  | GLenum | pname,
 |  | const GLfloat * | params
 | ) | [inline]

Definition at line 287 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLightf | ( | GLenum | light,
 |  | GLenum | pname,
 |  | GLfloat | f
 | ) | [inline]

Definition at line 312 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLighti | ( | GLenum | light,
 |  | GLenum | pname,
 |  | GLint | f
 | ) | [inline]

Definition at line 327 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glMaterialfv | ( | GLenum | face,
 |  | GLenum | pname,
 |  | const GLfloat * | params
 | ) | [inline]

Definition at line 349 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glShadeModel ( GLenum e ) [inline]

Definition at line 390 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glClearColor | ( | GLclampf | r,
 |  | GLclampf | g,
 |  | GLclampf | b,
 |  | GLclampf | a
 | ) | [inline]

Definition at line 400 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glClearDepth ( GLclampd d ) [inline]

Definition at line 417 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glDepthMask ( GLenum e ) [inline]

Definition at line 427 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glCullFace ( GLenum e ) [inline]

Definition at line 439 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glClear ( GLbitfield b ) [inline]

Definition at line 449 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glDrawBuffer ( GLenum e ) [inline]

Definition at line 455 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glMatrixMode ( GLenum e ) [inline]

Definition at line 465 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glViewport | ( | GLint | llx,
 |  | GLint | lly,
 |  | GLint | u,
 |  | GLint | v
 | ) | [inline]

Definition at line 473 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glScissor | ( | GLint | llx,
 |  | GLint | lly,
 |  | GLint | u,
 |  | GLint | v
 | ) | [inline]

Definition at line 488 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glClipPlane | ( | GLenum | e,
 |  | const GLdouble * | eqn
 | ) | [inline]

Definition at line 505 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glColorMaterial | ( | GLenum | face,
 |  | GLenum | mode
 | ) | [inline]

Definition at line 524 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glPointSize ( GLfloat f ) [inline]

Definition at line 532 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLineWidth ( GLfloat f ) [inline]

Definition at line 539 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glLineStipple | ( | GLint | factor,
 |  | GLushort | pattern
 | ) | [inline]

Definition at line 547 of file vtkOpenGLStateCache.h.

void vtkOpenGLStateCache::glDepthRange | ( | GLclampd | nearval,
 |  | GLclampd | farval
 | ) | [inline]

Definition at line 560 of file vtkOpenGLStateCache.h.

Member Data Documentation

vtkOpenGLStateCache* vtkOpenGLStateCache::CurrentGLCache [static]

Definition at line 103 of file vtkOpenGLStateCache.h.

char vtkOpenGLStateCache::Enable_buckets[0xDE1-0xB10+1]

Definition at line 125 of file vtkOpenGLStateCache.h.

char vtkOpenGLStateCache::Enable_GL_LIGHT_buckets[8]

Definition at line 126 of file vtkOpenGLStateCache.h.

char vtkOpenGLStateCache::Enable_GL_CLIP_PLANE_buckets[8]

Definition at line 127 of file vtkOpenGLStateCache.h.

GLclampf vtkOpenGLStateCache::AlphaFunc_bucket

Definition at line 205 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::BlendFunc_bucket

Definition at line 216 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::DepthFunc_bucket

Definition at line 229 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::TexEnvf_MODE_bucket

Definition at line 240 of file vtkOpenGLStateCache.h.

GLint vtkOpenGLStateCache::LightModeli_LIGHT_MODEL_TWO_SIDE_bucket

Definition at line 255 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::LightModelfv_LIGHT_MODEL_AMBIENT_bucket[3]

Definition at line 266 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::Lightfv_buckets[8*4*8]

Definition at line 286 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::Lightf_buckets[8*8]

Definition at line 310 of file vtkOpenGLStateCache.h.

GLint vtkOpenGLStateCache::Lighti_SPOT_CUTOFF_buckets[8]

Definition at line 311 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::Materialfv_buckets[8*8*4]

Definition at line 348 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::ShadeModel_bucket

Definition at line 389 of file vtkOpenGLStateCache.h.

GLclampf vtkOpenGLStateCache::ClearColor_buckets[4]

Definition at line 399 of file vtkOpenGLStateCache.h.

GLclampd vtkOpenGLStateCache::ClearDepth_bucket

Definition at line 416 of file vtkOpenGLStateCache.h.

GLclampf vtkOpenGLStateCache::DepthMask_bucket

Definition at line 426 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::CullFace_bucket

Definition at line 438 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::DrawBuffer_bucket

Definition at line 454 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::MatrixMode_bucket

Definition at line 464 of file vtkOpenGLStateCache.h.

GLint vtkOpenGLStateCache::Viewport_bucket[4]

Definition at line 472 of file vtkOpenGLStateCache.h.

GLint vtkOpenGLStateCache::Scissor_bucket[4]

Definition at line 487 of file vtkOpenGLStateCache.h.

GLdouble vtkOpenGLStateCache::ClipPlane_bucket[4*GL_MAX_CLIP_PLANES]

Definition at line 504 of file vtkOpenGLStateCache.h.

GLenum vtkOpenGLStateCache::ColorMaterial_bucket[8]

Definition at line 523 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::PointSize_bucket

Definition at line 531 of file vtkOpenGLStateCache.h.

GLfloat vtkOpenGLStateCache::LineWidth_bucket

Definition at line 538 of file vtkOpenGLStateCache.h.

GLint vtkOpenGLStateCache::LineStipple_FACTOR_bucket

Definition at line 545 of file vtkOpenGLStateCache.h.

GLushort vtkOpenGLStateCache::LineStipple_PATTERN_bucket

Definition at line 546 of file vtkOpenGLStateCache.h.

GLclampd vtkOpenGLStateCache::DepthRange_NEAR_bucket

Definition at line 558 of file vtkOpenGLStateCache.h.

GLclampd vtkOpenGLStateCache::DepthRange_FAR_bucket

Definition at line 559 of file vtkOpenGLStateCache.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLStateCache.h
Generated on Mon Mar 25 01:26:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLTexture Class Reference

OpenGL texture map. More...

#include <vtkOpenGLTexture.h>

Inheritance diagram for vtkOpenGLTexture:

[legend]
Collaboration diagram for vtkOpenGLTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLTexture, vtkTexture)
void | Load (vtkRenderer *ren)
void | ReleaseGraphicsResources (vtkWindow *)

Static Public Methods

vtkOpenGLTexture * | New ()

Protected Methods

vtkOpenGLTexture ()
~vtkOpenGLTexture ()
unsigned char * | ResampleToPowerOfTwo (int &xsize, int &ysize, unsigned char *dptr, int bpp)

Protected Attributes

vtkTimeStamp LoadTime
long | Index
vtkRenderWindow * RenderWindow

Detailed Description

OpenGL texture map.

Date:
2002/01/22 15:38:58
Revision:
1.22

vtkOpenGLTexture is a concrete implementation of the abstract class vtkTexture. vtkOpenGLTexture interfaces to the OpenGL rendering library.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (48%)
  • Miller, Jim (21%)
  • Martin, Ken (6%)
  • Lorensen, Bill (5%)

Definition at line 44 of file vtkOpenGLTexture.h.

Constructor & Destructor Documentation

vtkOpenGLTexture::vtkOpenGLTexture ( ) [protected]

vtkOpenGLTexture::~vtkOpenGLTexture ( ) [protected]

Member Function Documentation

vtkOpenGLTexture* vtkOpenGLTexture::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkTexture.

vtkOpenGLTexture::vtkTypeRevisionMacro | ( | vtkOpenGLTexture | ,
 |  | vtkTexture |
 | ) |

Reimplemented from vtkTexture.

void vtkOpenGLTexture::Load ( vtkRenderer * ren ) [virtual]

Implement base class method.

Reimplemented from vtkTexture.

void vtkOpenGLTexture::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this texture. The parameter window could be used to determine which graphic resources to release. Using the same texture object in multiple render windows is NOT currently supported.

Reimplemented from vtkTexture.

unsigned char* vtkOpenGLTexture::ResampleToPowerOfTwo | ( | int & | xsize,
 |  | int & | ysize,
 |  | unsigned char * | dptr,
 |  | int | bpp
 | ) | [protected]

Member Data Documentation

vtkTimeStamp vtkOpenGLTexture::LoadTime [protected]

Definition at line 66 of file vtkOpenGLTexture.h.

long vtkOpenGLTexture::Index [protected]

Definition at line 67 of file vtkOpenGLTexture.h.

vtkRenderWindow* vtkOpenGLTexture::RenderWindow [protected]

Definition at line 68 of file vtkOpenGLTexture.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLTexture.h
Generated on Mon Mar 25 01:26:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeProVG500Mapper Class Reference

Concrete class for VolumePRO mapper. More...

#include <vtkOpenGLVolumeProVG500Mapper.h>

Inheritance diagram for vtkOpenGLVolumeProVG500Mapper:

[legend]
Collaboration diagram for vtkOpenGLVolumeProVG500Mapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLVolumeProVG500Mapper, vtkVolumeProVG500Mapper)

Static Public Methods

vtkOpenGLVolumeProVG500Mapper * | New ()

Protected Methods

vtkOpenGLVolumeProVG500Mapper ()
~vtkOpenGLVolumeProVG500Mapper ()
void | RenderHexagon (vtkRenderer *ren, vtkVolume *vol, VLIPixel *basePlane, int size[2], VLIVector3D hexagon[6], VLIVector2D textureCoords[6])

Detailed Description

Concrete class for VolumePRO mapper.

Date:
2002/01/22 15:38:59
Revision:
1.19

vtkOpenGLVolumeProVG500Mapper is the concrete implementation of a vtkVolumeProMapper based on the VG500 chip running with OpenGL. Users should not create this class directly - a vtkVolumeProMapper will automatically create the object of the right type.

This class is not included in the Rendering CMakeLists by default. If you want to add this class to your vtk build, you need to have the vli header and library files. Please see the vtkVolumeProVG500Mapper.h file for instructions on how to use the vli library with vtk.

For more information on the VolumePRO hardware, please see:

http://www.terarecon.com/3d_products.shtml

If you encounter any problems with this class, please inform Kitware, Inc. at kitware@kitware.com.

See also:
vtkVolumeMapper vtkVolumeProMapper vtkVolumeProVG500Mapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (80%)
  • Hoffman, Bill (5%)

Definition at line 58 of file vtkOpenGLVolumeProVG500Mapper.h.

Constructor & Destructor Documentation

vtkOpenGLVolumeProVG500Mapper::vtkOpenGLVolumeProVG500Mapper ( ) [inline, protected]

Definition at line 65 of file vtkOpenGLVolumeProVG500Mapper.h.

vtkOpenGLVolumeProVG500Mapper::~vtkOpenGLVolumeProVG500Mapper ( ) [inline, protected]

Definition at line 66 of file vtkOpenGLVolumeProVG500Mapper.h.

Member Function Documentation

vtkOpenGLVolumeProVG500Mapper::vtkTypeRevisionMacro | ( | vtkOpenGLVolumeProVG500Mapper | ,
 |  | vtkVolumeProVG500Mapper |
 | ) |

Reimplemented from vtkVolumeProVG500Mapper.

vtkOpenGLVolumeProVG500Mapper* vtkOpenGLVolumeProVG500Mapper::New ( ) [static]

Automatically create the proper subclass

Reimplemented from vtkVolumeProVG500Mapper.

void vtkOpenGLVolumeProVG500Mapper::RenderHexagon | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VLIPixel * | basePlane,
 |  | int | size[2],
 |  | VLIVector3D | hexagon[6],
 |  | VLIVector2D | textureCoords[6]
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLVolumeProVG500Mapper.h
Generated on Mon Mar 25 01:26:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeProVP1000Mapper Class Reference

Concrete class for VolumePRO mapper. More...

#include <vtkOpenGLVolumeProVP1000Mapper.h>

Inheritance diagram for vtkOpenGLVolumeProVP1000Mapper:

[legend]
Collaboration diagram for vtkOpenGLVolumeProVP1000Mapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLVolumeProVP1000Mapper, vtkVolumeProVP1000Mapper)

Static Public Methods

vtkOpenGLVolumeProVP1000Mapper * | New ()

Protected Methods

vtkOpenGLVolumeProVP1000Mapper ()
~vtkOpenGLVolumeProVP1000Mapper ()
vtkOpenGLVolumeProVP1000Mapper (const vtkOpenGLVolumeProVP1000Mapper &)
void | operator= (const vtkOpenGLVolumeProVP1000Mapper &)
void | RenderImageBuffer (vtkRenderer *ren, vtkVolume *vol, int size[2], unsigned int *outData)
virtual void | GetDepthBufferValues (vtkRenderer *ren, int size[2], unsigned int *outData)
virtual void | RenderBoundingBox (vtkRenderer *ren, vtkVolume *vol)

Detailed Description

Concrete class for VolumePRO mapper.

Date:
2002/02/01 16:31:06
Revision:
1.5

vtkOpenGLVolumeProVP1000Mapper is the concrete implementation of a vtkVolumeProMapper based on the VP1000 chip running with OpenGL. Users should not create this class directly - a vtkVolumeProMapper will automatically create the object of the right type.

This class is not included in the Rendering CMakeLists by default. If you want to add this class to your vtk build, you need to have the vli header and library files. Please see the vtkVolumeProVP1000Mapper.h file for instructions on how to use the vli library with vtk.

For more information on the VolumePRO hardware, please see:

http://www.terarecon.com/3d_products.shtml

If you encounter any problems with this class, please inform Kitware, Inc. at kitware@kitware.com.

See also:
vtkVolumeMapper vtkVolumeProMapper vtkVolumeProVP1000Mapper
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (98%)

Definition at line 57 of file vtkOpenGLVolumeProVP1000Mapper.h.

Constructor & Destructor Documentation

vtkOpenGLVolumeProVP1000Mapper::vtkOpenGLVolumeProVP1000Mapper ( ) [inline, protected]

Definition at line 64 of file vtkOpenGLVolumeProVP1000Mapper.h.

vtkOpenGLVolumeProVP1000Mapper::~vtkOpenGLVolumeProVP1000Mapper ( ) [inline, protected]

Definition at line 65 of file vtkOpenGLVolumeProVP1000Mapper.h.

vtkOpenGLVolumeProVP1000Mapper::vtkOpenGLVolumeProVP1000Mapper ( const vtkOpenGLVolumeProVP1000Mapper & ) [protected]

Member Function Documentation

vtkOpenGLVolumeProVP1000Mapper::vtkTypeRevisionMacro | ( | vtkOpenGLVolumeProVP1000Mapper | ,
 |  | vtkVolumeProVP1000Mapper |
 | ) |

Reimplemented from vtkVolumeProVP1000Mapper.

vtkOpenGLVolumeProVP1000Mapper* vtkOpenGLVolumeProVP1000Mapper::New ( ) [static]

Automatically create the proper subclass

Reimplemented from vtkVolumeProVP1000Mapper.

void vtkOpenGLVolumeProVP1000Mapper::operator= ( const vtkOpenGLVolumeProVP1000Mapper & ) [protected]

void vtkOpenGLVolumeProVP1000Mapper::RenderImageBuffer | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | int | size[2],
 |  | unsigned int * | outData
 | ) | [protected]

virtual void vtkOpenGLVolumeProVP1000Mapper::GetDepthBufferValues | ( | vtkRenderer * | ren,
 |  | int | size[2],
 |  | unsigned int * | outData
 | ) | [protected, virtual]

virtual void vtkOpenGLVolumeProVP1000Mapper::RenderBoundingBox | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [protected, virtual]

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLVolumeProVP1000Mapper.h
Generated on Mon Mar 25 01:26:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeRayCastMapper Class Reference

OpenGL subclass that draws the image to the screen. More...

#include <vtkOpenGLVolumeRayCastMapper.h>

Inheritance diagram for vtkOpenGLVolumeRayCastMapper:

[legend]
Collaboration diagram for vtkOpenGLVolumeRayCastMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLVolumeRayCastMapper, vtkVolumeRayCastMapper)

Static Public Methods

vtkOpenGLVolumeRayCastMapper * | New ()

Protected Methods

vtkOpenGLVolumeRayCastMapper ()
~vtkOpenGLVolumeRayCastMapper ()
void | RenderTexture (vtkVolume *vol, vtkRenderer *ren)

Detailed Description

OpenGL subclass that draws the image to the screen.

Date:
2002/01/22 15:39:01
Revision:
1.5

This is the concrete implementation of a ray cast mapper - it is responsible for drawing the image to the screen. The remaining functionality all comes from vtkVolumeRayCastMapper

See also:
vtkVolumeRayCastMapper vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (93%)

Definition at line 50 of file vtkOpenGLVolumeRayCastMapper.h.

Constructor & Destructor Documentation

vtkOpenGLVolumeRayCastMapper::vtkOpenGLVolumeRayCastMapper ( ) [protected]

vtkOpenGLVolumeRayCastMapper::~vtkOpenGLVolumeRayCastMapper ( ) [protected]

Member Function Documentation

vtkOpenGLVolumeRayCastMapper* vtkOpenGLVolumeRayCastMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVolumeRayCastMapper.

vtkOpenGLVolumeRayCastMapper::vtkTypeRevisionMacro | ( | vtkOpenGLVolumeRayCastMapper | ,
 |  | vtkVolumeRayCastMapper |
 | ) |

Reimplemented from vtkVolumeRayCastMapper.

void vtkOpenGLVolumeRayCastMapper::RenderTexture | ( | vtkVolume * | vol,
 |  | vtkRenderer * | ren
 | ) | [protected, virtual]

Reimplemented from vtkVolumeRayCastMapper.

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLVolumeRayCastMapper.h
Generated on Mon Mar 25 01:26:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOpenGLVolumeTextureMapper2D Class Reference

Abstract class for a volume mapper. More...

#include <vtkOpenGLVolumeTextureMapper2D.h>

Inheritance diagram for vtkOpenGLVolumeTextureMapper2D:

[legend]
Collaboration diagram for vtkOpenGLVolumeTextureMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOpenGLVolumeTextureMapper2D, vtkVolumeTextureMapper2D)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Render (vtkRenderer *ren, vtkVolume *vol)
void | RenderQuads (int count, float *v, float *t, unsigned char *texture, int size[2], int reverseFlag)

Static Public Methods

vtkOpenGLVolumeTextureMapper2D * | New ()

Protected Methods

vtkOpenGLVolumeTextureMapper2D ()
~vtkOpenGLVolumeTextureMapper2D ()

Detailed Description

Abstract class for a volume mapper.

Date:
2002/01/22 15:39:02
Revision:
1.17

vtkOpenGLVolumeTextureMapper2D renders a volume using 2D texture mapping.

See also:
vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (88%)

Definition at line 40 of file vtkOpenGLVolumeTextureMapper2D.h.

Constructor & Destructor Documentation

vtkOpenGLVolumeTextureMapper2D::vtkOpenGLVolumeTextureMapper2D ( ) [protected]

vtkOpenGLVolumeTextureMapper2D::~vtkOpenGLVolumeTextureMapper2D ( ) [protected]

Member Function Documentation

vtkOpenGLVolumeTextureMapper2D::vtkTypeRevisionMacro | ( | vtkOpenGLVolumeTextureMapper2D | ,
 |  | vtkVolumeTextureMapper2D |
 | ) |

Reimplemented from vtkVolumeTextureMapper2D.

void vtkOpenGLVolumeTextureMapper2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeTextureMapper2D.

vtkOpenGLVolumeTextureMapper2D* vtkOpenGLVolumeTextureMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVolumeTextureMapper2D.

virtual void vtkOpenGLVolumeTextureMapper2D::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Render the volume

Reimplemented from vtkVolumeTextureMapper2D.

void vtkOpenGLVolumeTextureMapper2D::RenderQuads | ( | int | count,
 |  | float * | v,
 |  | float * | t,
 |  | unsigned char * | texture,
 |  | int | size[2],
 |  | int | reverseFlag
 | ) |

The documentation for this class was generated from the following file:
  • Rendering/vtkOpenGLVolumeTextureMapper2D.h
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOrderedTriangulator Class Reference

helper class to generate triangulations. More...

#include <vtkOrderedTriangulator.h>

Inheritance diagram for vtkOrderedTriangulator:

[legend]
Collaboration diagram for vtkOrderedTriangulator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOrderedTriangulator, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | InitTriangulation (float bounds[6], int numPts)
void | Triangulate ()
void | UpdatePointType (vtkIdType internalId, int type)
vtkIdType | GetTetras (int classification, vtkUnstructuredGrid *ugrid)
vtkIdType | AddTetras (int classification, vtkUnstructuredGrid *ugrid)
vtkIdType | AddTetras (int classification, vtkCellArray *connectivity)
vtkIdType | InsertPoint (vtkIdType id, float x[3], int type)
vtkIdType | InsertPoint (vtkIdType id, vtkIdType sortid, float x[3], int type)
vtkIdType | InsertPoint (vtkIdType id, vtkIdType sortid, vtkIdType sortid2, float x[3], int type)
virtual void | SetPreSorted (int)
virtual int | GetPreSorted ()
virtual void | PreSortedOn ()
virtual void | PreSortedOff ()
virtual void | SetUseTwoSortIds (int)
virtual int | GetUseTwoSortIds ()
virtual void | UseTwoSortIdsOn ()
virtual void | UseTwoSortIdsOff ()

Static Public Methods

vtkOrderedTriangulator * | New ()

Protected Methods

vtkOrderedTriangulator ()
~vtkOrderedTriangulator ()

Detailed Description

helper class to generate triangulations.

Date:
2002/01/22 15:25:50
Revision:
1.17

This class is used to generate unique triangulations of points. The uniqueness of the triangulation is controlled by the id of the inserted points in combination with a Delaunay criterion. The class is designed to be very fast and uses block memory allocations to support rapid triangulation generation. Also, the assumption behind the class is that a maximum of hundreds of points are to be triangulated. If you desire more robust triangulation methods use vtkPolygon::Triangulate(), vtkDelaunay2D, or vtkDelaunay3D.

Background: Delaunay triangulations are unique assuming a random distribution of input points. The 3D Delaunay criterion is as follows: the circumsphere of each tetrahedron contains no other points of the triangulation except for the four points defining the tetrahedron. In application this property is hard to satisfy because objects like cubes are defined by eight points all sharing the same circumsphere (center and radius); hence the Delaunay triangulation is not unique. These so-called degenerate situations are typically resolved by arbitrary selecting a triangulation. This code does something different: it resolves degenerate triangulations by modifying the "InCircumsphere" method to use a slightly smaller radius. Hence, degenerate points are always considered "out" of the circumsphere. This, in combination with an ordering (based on id) of the input points, guarantees a unique triangulation.

There is another related characteristic of Delaunay triangulations. Given a N-dimensional Delaunay triangulation, points lying on a (N-1) dimensional plane also form a (N-1) Delaunay triangulation. This means for example, that if a 3D cell is defined by a set of (2D) planar faces, then the face triangulations are Delaunay. Combinaing this with the method to generate unique triangulations described previously, the triangulations on the face are guaranteed unique. This fact can be used to triangulate 3D objects in such a way to guarantee compatible face triangulations. This is a very useful fact for parallel processing, or performing operations like clipping that require compatible triangulations across 3D cell faces. (See vtkClipVolume for an example.)

Warning:
Duplicate vertices will be ignored, i.e., if two points have the same coordinates the second one is discarded. The implications are that the user of this class most prevent duplicate points. Because the precision of this algorithm is double, it's also a good idea to merge points that are within some epsilon of one another.
See also:
vtkDelaunay2D vtkDelaunay3D vtkPolygon
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (76%)
  • Geveci, Berk (16%)

Definition at line 86 of file vtkOrderedTriangulator.h.

Constructor & Destructor Documentation

vtkOrderedTriangulator::vtkOrderedTriangulator ( ) [protected]

vtkOrderedTriangulator::~vtkOrderedTriangulator ( ) [protected]

Member Function Documentation

vtkOrderedTriangulator::vtkTypeRevisionMacro | ( | vtkOrderedTriangulator | ,
 |  | vtkObject |
 | ) |

void vtkOrderedTriangulator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkOrderedTriangulator* vtkOrderedTriangulator::New ( ) [static]

Construct object.

Reimplemented from vtkObject.

void vtkOrderedTriangulator::InitTriangulation | ( | float | bounds[6],
 |  | int | numPts
 | ) |

Initialize the triangulation process. Provide a bounding box and the maximum number of points to be inserted.

vtkIdType vtkOrderedTriangulator::InsertPoint | ( | vtkIdType | id,
 |  | float | x[3],
 |  | int | type
 | ) |

For each point to be inserted, provide an id, a position x, and whether the point is inside (type=0), outside (type=1), or on the boundary (type=2). You must call InitTriangulation() prior to invoking this method. Make sure that the number of points inserted does not exceed the numPts specified in InitTriangulation(). Also note that the "id" can be any integer and can be greater than numPts. It is used to create tetras (in AddTetras() with the appropriate connectivity ids. The method returns an internal id that can be used prior to the Triangulate() method to update the type of the point with UpdatePointType().

vtkIdType vtkOrderedTriangulator::InsertPoint | ( | vtkIdType | id,
 |  | vtkIdType | sortid,
 |  | float | x[3],
 |  | int | type
 | ) |

For each point to be inserted, provide an id, a position x, and whether the point is inside (type=0), outside (type=1), or on the boundary (type=2). You must call InitTriangulation() prior to invoking this method. Make sure that the number of points inserted does not exceed the numPts specified in InitTriangulation(). Also note that the "id" can be any integer and can be greater than numPts. It is used to create tetras (in AddTetras() with the appropriate connectivity ids. The method returns an internal id that can be used prior to the Triangulate() method to update the type of the point with UpdatePointType().

vtkIdType vtkOrderedTriangulator::InsertPoint | ( | vtkIdType | id,
 |  | vtkIdType | sortid,
 |  | vtkIdType | sortid2,
 |  | float | x[3],
 |  | int | type
 | ) |

For each point to be inserted, provide an id, a position x, and whether the point is inside (type=0), outside (type=1), or on the boundary (type=2). You must call InitTriangulation() prior to invoking this method. Make sure that the number of points inserted does not exceed the numPts specified in InitTriangulation(). Also note that the "id" can be any integer and can be greater than numPts. It is used to create tetras (in AddTetras() with the appropriate connectivity ids. The method returns an internal id that can be used prior to the Triangulate() method to update the type of the point with UpdatePointType().

void vtkOrderedTriangulator::Triangulate ( )

Perform the triangulation. (Complete all calls to InsertPoint() prior to invoking this method.)

void vtkOrderedTriangulator::UpdatePointType | ( | vtkIdType | internalId,
 |  | int | type
 | ) |

Update the point type. This is useful when the merging of nearly coincident points is performed. The id is the internal id returned from InsertPoint(). The method should be invoked prior to the Triangulate method. The type is specified as inside (type=0), outside (type=1), or on the boundary (type=2).

virtual void vtkOrderedTriangulator::SetPreSorted ( int ) [virtual]

Boolean indicates whether the points have been pre-sorted. If pre-sorted is enabled, the points are not sorted on point id. By default, presorted is off. (The point id is defined in InsertPoint().)

virtual int vtkOrderedTriangulator::GetPreSorted ( ) [virtual]

Boolean indicates whether the points have been pre-sorted. If pre-sorted is enabled, the points are not sorted on point id. By default, presorted is off. (The point id is defined in InsertPoint().)

virtual void vtkOrderedTriangulator::PreSortedOn ( ) [virtual]

Boolean indicates whether the points have been pre-sorted. If pre-sorted is enabled, the points are not sorted on point id. By default, presorted is off. (The point id is defined in InsertPoint().)

virtual void vtkOrderedTriangulator::PreSortedOff ( ) [virtual]

Boolean indicates whether the points have been pre-sorted. If pre-sorted is enabled, the points are not sorted on point id. By default, presorted is off. (The point id is defined in InsertPoint().)

virtual void vtkOrderedTriangulator::SetUseTwoSortIds ( int ) [virtual]

Tells the triangulator that a second sort id is provided for each point and should also be considered when sorting

virtual int vtkOrderedTriangulator::GetUseTwoSortIds ( ) [virtual]

Tells the triangulator that a second sort id is provided for each point and should also be considered when sorting

virtual void vtkOrderedTriangulator::UseTwoSortIdsOn ( ) [virtual]

Tells the triangulator that a second sort id is provided for each point and should also be considered when sorting

virtual void vtkOrderedTriangulator::UseTwoSortIdsOff ( ) [virtual]

Tells the triangulator that a second sort id is provided for each point and should also be considered when sorting

vtkIdType vtkOrderedTriangulator::GetTetras | ( | int | classification,
 |  | vtkUnstructuredGrid * | ugrid
 | ) |

Initialize and add the tetras and points from the triangulation to the unstructured grid provided. New points are created and the mesh is allocated. (This method differs from AddTetras() in that it inserts points and cells; AddTetras only adds the tetra cells.) The tetrahdera added are of the type specified (0=inside,1=outside,2=all). Inside tetrahedron are those whose points are classified "inside" or on the "boundary." Outside tetrahedron have at least one point classified "outside." The method returns the number of tetrahedrahedron of the type requested.

vtkIdType vtkOrderedTriangulator::AddTetras | ( | int | classification,
 |  | vtkUnstructuredGrid * | ugrid
 | ) |

Add the tetras to the unstructured grid provided. The unstructured grid is assumed to have been initialized (with Allocate()) and points set (with SetPoints()). The tetrahdera added are of the type specified (0=inside,1=outside,2=all). Inside tetrahedron are those whose points are classified "inside" or on the "boundary." Outside tetrahedron have at least one point classified "outside." The method returns the number of tetrahedrahedron of the type requested.

vtkIdType vtkOrderedTriangulator::AddTetras | ( | int | classification,
 |  | vtkCellArray * | connectivity
 | ) |

Add the tetrahedra classified (0=inside,1=outside) to the connectivity list provided. Inside tetrahedron are those whose points are all classified "inside." Outside tetrahedron have at least one point classified "outside." The method returns the number of tetrahedron of the type requested.

The documentation for this class was generated from the following file:
  • Common/vtkOrderedTriangulator.h
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ostream Struct Reference

#include <vtkWinCE.h>

List of all members.

Public Methods

ostream & | operator<< (const char *str)
ostream & | operator<< (void *str)
ostream & | operator<< (short x)
ostream & | operator<< (unsigned short x)
ostream & | operator<< (int x)
ostream & | operator<< (unsigned int x)
ostream & | operator<< (long l)
ostream & | operator<< (unsigned long l)
ostream & | operator<< (char ch)
ostream & | operator<< (float fl)
ostream & | operator<< (double dbl)
write (void *data, size_t size)
void | flush ()

Member Function Documentation

ostream& ostream::operator<< ( const char * str )

ostream& ostream::operator<< ( void * str )

ostream& ostream::operator<< ( short x )

ostream& ostream::operator<< ( unsigned short x )

ostream& ostream::operator<< ( int x )

ostream& ostream::operator<< ( unsigned int x )

ostream& ostream::operator<< ( long l )

ostream& ostream::operator<< ( unsigned long l )

ostream& ostream::operator<< ( char ch )

ostream& ostream::operator<< ( float fl )

ostream& ostream::operator<< ( double dbl )

ostream::write | ( | void * | data,
 |  | size_t | size
 | ) |

void ostream::flush ( ) [inline]

Definition at line 53 of file vtkWinCE.h.

The documentation for this struct was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ostrhelp Struct Reference

#include <vtkWinCE.h>

List of all members.

Public Methods

freeze (int i)

Member Function Documentation

ostrhelp::freeze ( int i )

The documentation for this struct was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ostrstream Struct Reference

#include <vtkWinCE.h>

List of all members.

Public Methods

ostrstream & | operator<< (char *str)
ostrstream & | operator<< (void *str)
ostrstream & | operator<< (int x)
ostrstream & | operator<< (long l)
ostrstream & | operator<< (char ch)
ostrstream & | operator<< (float fl)
ostrstream & | operator<< (double dbl)
char * | str ()
ostrhelp * rdbuf ()

Member Function Documentation

ostrstream& ostrstream::operator<< ( char * str )

ostrstream& ostrstream::operator<< ( void * str )

ostrstream& ostrstream::operator<< ( int x )

ostrstream& ostrstream::operator<< ( long l )

ostrstream& ostrstream::operator<< ( char ch )

ostrstream& ostrstream::operator<< ( float fl )

ostrstream& ostrstream::operator<< ( double dbl )

char* ostrstream::str ( )

ostrhelp* ostrstream::rdbuf ( )

The documentation for this struct was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


OtherData Struct Reference

#include <vtkPLY.h>

Collaboration diagram for OtherData:

[legend]
List of all members.

Public Attributes

void * other_props

Member Data Documentation

void* OtherData::other_props

Definition at line 137 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


OtherElem Struct Reference

#include <vtkPLY.h>

Collaboration diagram for OtherElem:

[legend]
List of all members.

Public Attributes

char * | elem_name
int | elem_count
OtherData ** other_data
PlyOtherProp * other_props

Member Data Documentation

char* OtherElem::elem_name

Definition at line 141 of file vtkPLY.h.

int OtherElem::elem_count

Definition at line 142 of file vtkPLY.h.

OtherData** OtherElem::other_data

Definition at line 143 of file vtkPLY.h.

PlyOtherProp* OtherElem::other_props

Definition at line 144 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineCornerFilter Class Reference

create wireframe outline corners for arbitrary data set. More...

#include <vtkOutlineCornerFilter.h>

Inheritance diagram for vtkOutlineCornerFilter:

[legend]
Collaboration diagram for vtkOutlineCornerFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOutlineCornerFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCornerFactor (float)
virtual float | GetCornerFactor ()

Static Public Methods

vtkOutlineCornerFilter * | New ()

Protected Methods

vtkOutlineCornerFilter ()
~vtkOutlineCornerFilter ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

vtkOutlineCornerSource * OutlineCornerSource
float | CornerFactor

Detailed Description

create wireframe outline corners for arbitrary data set.

Date:
2002/01/22 15:29:31
Revision:
1.9

vtkOutlineCornerFilter is a filter that generates wireframe outline corners of any data set. The outline consists of the eight corners of the dataset bounding box.

Created by:
  • Barre, Sebastien
Contributed by (if > 5%):
  • Barre, Sebastien (94%)
Tests:
vtkOutlineCornerFilter (Tests)

Definition at line 42 of file vtkOutlineCornerFilter.h.

Constructor & Destructor Documentation

vtkOutlineCornerFilter::vtkOutlineCornerFilter ( ) [protected]

vtkOutlineCornerFilter::~vtkOutlineCornerFilter ( ) [protected]

Member Function Documentation

vtkOutlineCornerFilter::vtkTypeRevisionMacro | ( | vtkOutlineCornerFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkOutlineCornerFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkOutlineCornerFilter* vtkOutlineCornerFilter::New ( ) [static]

Construct outline corner filter with default corner factor = 0.2

Reimplemented from vtkPolyDataSource.

virtual void vtkOutlineCornerFilter::SetCornerFactor ( float ) [virtual]

Set/Get the factor that controls the relative size of the corners to the length of the corresponding bounds

virtual float vtkOutlineCornerFilter::GetCornerFactor ( ) [virtual]

Set/Get the factor that controls the relative size of the corners to the length of the corresponding bounds

void vtkOutlineCornerFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkOutlineCornerFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

vtkOutlineCornerSource* vtkOutlineCornerFilter::OutlineCornerSource [protected]

Definition at line 62 of file vtkOutlineCornerFilter.h.

float vtkOutlineCornerFilter::CornerFactor [protected]

Definition at line 66 of file vtkOutlineCornerFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOutlineCornerFilter.h
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineCornerSource Class Reference

create wireframe outline corners around bounding box. More...

#include <vtkOutlineCornerSource.h>

Inheritance diagram for vtkOutlineCornerSource:

[legend]
Collaboration diagram for vtkOutlineCornerSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOutlineCornerSource, vtkOutlineSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCornerFactor (float)
virtual float | GetCornerFactor ()

Static Public Methods

vtkOutlineCornerSource * | New ()

Protected Methods

vtkOutlineCornerSource ()
~vtkOutlineCornerSource ()
void | Execute ()

Protected Attributes

float | CornerFactor

Detailed Description

create wireframe outline corners around bounding box.

Date:
2002/01/22 15:29:31
Revision:
1.9

vtkOutlineCornerSource creates wireframe outline corners around a user-specified bounding box.

Created by:
  • Barre, Sebastien
Contributed by (if > 5%):
  • Barre, Sebastien (94%)

Definition at line 37 of file vtkOutlineCornerSource.h.

Constructor & Destructor Documentation

vtkOutlineCornerSource::vtkOutlineCornerSource ( ) [protected]

vtkOutlineCornerSource::~vtkOutlineCornerSource ( ) [inline, protected]

Definition at line 55 of file vtkOutlineCornerSource.h.

Member Function Documentation

vtkOutlineCornerSource::vtkTypeRevisionMacro | ( | vtkOutlineCornerSource | ,
 |  | vtkOutlineSource |
 | ) |

Reimplemented from vtkOutlineSource.

void vtkOutlineCornerSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkOutlineSource.

vtkOutlineCornerSource* vtkOutlineCornerSource::New ( ) [static]

Construct outline corner source with default corner factor = 0.2

Reimplemented from vtkOutlineSource.

virtual void vtkOutlineCornerSource::SetCornerFactor ( float ) [virtual]

Set/Get the factor that controls the relative size of the corners to the length of the corresponding bounds

virtual float vtkOutlineCornerSource::GetCornerFactor ( ) [virtual]

Set/Get the factor that controls the relative size of the corners to the length of the corresponding bounds

void vtkOutlineCornerSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkOutlineSource.

Member Data Documentation

float vtkOutlineCornerSource::CornerFactor [protected]

Definition at line 59 of file vtkOutlineCornerSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOutlineCornerSource.h
Generated on Mon Mar 25 01:26:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineFilter Class Reference

create wireframe outline for arbitrary data set. More...

#include <vtkOutlineFilter.h>

Inheritance diagram for vtkOutlineFilter:

[legend]
Collaboration diagram for vtkOutlineFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOutlineFilter, vtkDataSetToPolyDataFilter)

Static Public Methods

vtkOutlineFilter * | New ()

Protected Methods

vtkOutlineFilter ()
~vtkOutlineFilter ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

vtkOutlineSource * OutlineSource

Detailed Description

create wireframe outline for arbitrary data set.

Date:
2002/01/22 15:29:32
Revision:
1.32

vtkOutlineFilter is a filter that generates a wireframe outline of any data set. The outline consists of the twelve edges of the dataset bounding box.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (60%)
  • Lorensen, Bill (24%)
  • Martin, Ken (12%)
Examples:
vtkOutlineFilter (Examples)
Tests:
vtkOutlineFilter (Tests)

Definition at line 47 of file vtkOutlineFilter.h.

Constructor & Destructor Documentation

vtkOutlineFilter::vtkOutlineFilter ( ) [protected]

vtkOutlineFilter::~vtkOutlineFilter ( ) [protected]

Member Function Documentation

vtkOutlineFilter* vtkOutlineFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkOutlineFilter::vtkTypeRevisionMacro | ( | vtkOutlineFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkOutlineFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkOutlineFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

vtkOutlineSource* vtkOutlineFilter::OutlineSource [protected]

Definition at line 57 of file vtkOutlineFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOutlineFilter.h
Generated on Mon Mar 25 01:26:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutlineSource Class Reference

create wireframe outline around bounding box. More...

#include <vtkOutlineSource.h>

Inheritance diagram for vtkOutlineSource:

[legend]
Collaboration diagram for vtkOutlineSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOutlineSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetBounds (float, float, float, float, float, float)
virtual void | SetBounds (float[6])
virtual float * | GetBounds ()
virtual void | GetBounds (float data[6])

Static Public Methods

vtkOutlineSource * | New ()

Protected Methods

vtkOutlineSource ()
~vtkOutlineSource ()
void | Execute ()

Protected Attributes

float | Bounds [6]

Detailed Description

create wireframe outline around bounding box.

Date:
2002/01/22 15:29:32
Revision:
1.34

vtkOutlineSource creates a wireframe outline around a user-specified bounding box.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Martin, Ken (24%)

Definition at line 38 of file vtkOutlineSource.h.

Constructor & Destructor Documentation

vtkOutlineSource::vtkOutlineSource ( ) [protected]

vtkOutlineSource::~vtkOutlineSource ( ) [inline, protected]

Definition at line 53 of file vtkOutlineSource.h.

Member Function Documentation

vtkOutlineSource* vtkOutlineSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkOutlineCornerSource.

vtkOutlineSource::vtkTypeRevisionMacro | ( | vtkOutlineSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkOutlineCornerSource.

void vtkOutlineSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkOutlineCornerSource.

virtual void vtkOutlineSource::SetBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the bounding box for this object.

virtual void vtkOutlineSource::SetBounds ( float [6] ) [virtual]

Specify the bounding box for this object.

virtual float* vtkOutlineSource::GetBounds ( ) [virtual]

Specify the bounding box for this object.

virtual void vtkOutlineSource::GetBounds ( float data[6] ) [virtual]

Specify the bounding box for this object.

void vtkOutlineSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkOutlineCornerSource.

Member Data Documentation

float vtkOutlineSource::Bounds[6] [protected]

Definition at line 56 of file vtkOutlineSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkOutlineSource.h
Generated on Mon Mar 25 01:26:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutputPort Class Reference

Connects pipelines in different processes. More...

#include <vtkOutputPort.h>

Inheritance diagram for vtkOutputPort:

[legend]
Collaboration diagram for vtkOutputPort:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOutputPort, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | WaitForUpdate ()
void | SetParameterMethod (void(*f)(void *), void *arg)
void | SetParameterMethodArgDelete (void(*f)(void *))
void | SetInput (vtkDataObject *input)
vtkDataObject * GetInput ()
void | SetTag (int tag)
virtual int | GetTag ()
vtkMultiProcessController * GetController ()
virtual void | SetController (vtkMultiProcessController *)
void | TriggerUpdateInformation (int remoteProcessId)
void | TriggerUpdate (int remoteProcessId)
virtual void | SetPipelineFlag (int)
virtual int | GetPipelineFlag ()
virtual void | PipelineFlagOn ()
virtual void | PipelineFlagOff ()

Static Public Methods

vtkOutputPort * | New ()

Protected Methods

vtkOutputPort ()
~vtkOutputPort ()

Protected Attributes

int | Tag
vtkMultiProcessController * Controller
vtkTimeStamp UpdateTime
int | PipelineFlag
void(* | ParameterMethod )(void *)
void(* | ParameterMethodArgDelete )(void *)
void * | ParameterMethodArg

Detailed Description

Connects pipelines in different processes.

Date:
2002/01/22 15:34:42
Revision:
1.6

OutputPort Connects the pipeline in this process to one in another processes. It communicates all the pipeline protocol so that the fact you are running in multiple processes is transparent. The output port is placed at the end of the pipeline (an output for a process). It can have multiple corresponding input ports in other processes that receive its data. Updates in a port are triggered asynchronously, so filter with multiple inputs will take advantage of task parallelism.

See also:
vtkInputPort vtkMultiProcessController
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (99%)
Examples:
vtkOutputPort (Examples)
Tests:
vtkOutputPort (Tests)

Definition at line 57 of file vtkOutputPort.h.

Constructor & Destructor Documentation

vtkOutputPort::vtkOutputPort ( ) [protected]

vtkOutputPort::~vtkOutputPort ( ) [protected]

Member Function Documentation

vtkOutputPort* vtkOutputPort::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkOutputPort::vtkTypeRevisionMacro | ( | vtkOutputPort | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

void vtkOutputPort::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

void vtkOutputPort::SetInput ( vtkDataObject * input )

Should accept vtkDataObjects in the future.

vtkDataObject* vtkOutputPort::GetInput ( )

Should accept vtkDataObjects in the future.

void vtkOutputPort::SetTag ( int tag )

Output is specified by the process the output port is in, and a tag so there can be more than one output port per process. Tag must be set before this port can be used. THIS TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

virtual int vtkOutputPort::GetTag ( ) [virtual]

Output is specified by the process the output port is in, and a tag so there can be more than one output port per process. Tag must be set before this port can be used. THIS TAG MUST BE EVEN BECAUSE TWO RMIs ARE CREATED FROM IT!!!

void vtkOutputPort::WaitForUpdate ( ) [inline]

This just forwards the wait onto the controller, which will wait for a message for any of its ports (or any RMI). Since this method is implemented in the controller, multiple output ports can be waiting at once (as long as they share a controller). This method will only return if the BreakFlag is turned on in the controller. The controller automatically creates a break rmi with the vtkMultiProcessController::BREAK_RMI_TAG for doing this remotely.

Definition at line 86 of file vtkOutputPort.h.

vtkMultiProcessController* vtkOutputPort::GetController ( ) [inline]

Access to the global controller.

Definition at line 90 of file vtkOutputPort.h.

virtual void vtkOutputPort::SetController ( vtkMultiProcessController * ) [virtual]

Access to the global controller.

void vtkOutputPort::TriggerUpdateInformation ( int remoteProcessId )

RMI function needs to call this. Should make function a friend. No one else should call it.

void vtkOutputPort::TriggerUpdate ( int remoteProcessId )

RMI function needs to call this. Should make function a friend. No one else should call it.

virtual void vtkOutputPort::SetPipelineFlag ( int ) [virtual]

Trying to get pipeline parallelism working.

virtual int vtkOutputPort::GetPipelineFlag ( ) [virtual]

Trying to get pipeline parallelism working.

virtual void vtkOutputPort::PipelineFlagOn ( ) [virtual]

Trying to get pipeline parallelism working.

virtual void vtkOutputPort::PipelineFlagOff ( ) [virtual]

Trying to get pipeline parallelism working.

void vtkOutputPort::SetParameterMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

This method is called after the port updates. It is meant to change a parameter if a series is being processed (for pipeline parallelism).

void vtkOutputPort::SetParameterMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

Member Data Documentation

int vtkOutputPort::Tag [protected]

Definition at line 120 of file vtkOutputPort.h.

vtkMultiProcessController* vtkOutputPort::Controller [protected]

Definition at line 122 of file vtkOutputPort.h.

vtkTimeStamp vtkOutputPort::UpdateTime [protected]

Definition at line 123 of file vtkOutputPort.h.

int vtkOutputPort::PipelineFlag [protected]

Definition at line 126 of file vtkOutputPort.h.

void(* vtkOutputPort::ParameterMethod)(void *) [protected]

void(* vtkOutputPort::ParameterMethodArgDelete)(void *) [protected]

void* vtkOutputPort::ParameterMethodArg [protected]

Definition at line 129 of file vtkOutputPort.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkOutputPort.h
Generated on Mon Mar 25 01:27:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutputWindow Class Reference

base class for writing debug output to a console. More...

#include <vtkOutputWindow.h>

Inheritance diagram for vtkOutputWindow:

[legend]
Collaboration diagram for vtkOutputWindow:

[legend]
List of all members.

[NOHEADER]

virtual void | DisplayText (const char *)
virtual void | DisplayErrorText (const char *)
virtual void | DisplayWarningText (const char *)
virtual void | DisplayGenericWarningText (const char *)
vtkOutputWindow * | New ()
vtkOutputWindow * | GetInstance ()
void | SetInstance (vtkOutputWindow *instance)

Public Methods

vtkTypeRevisionMacro (vtkOutputWindow, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | DisplayDebugText (const char *)
virtual void | PromptUserOn ()
virtual void | PromptUserOff ()
virtual void | SetPromptUser (int)

Static Public Attributes

vtkOutputWindowSmartPointer SmartPointer

Protected Methods

vtkOutputWindow ()
virtual | ~vtkOutputWindow ()

Protected Attributes

int | PromptUser

Detailed Description

base class for writing debug output to a console.

Date:
2002/01/22 15:25:51
Revision:
1.20

This class is used to encapsulate all text output, so that it will work with operating systems that have a stdout and stderr, and ones that do not. (i.e windows does not). Sub-classes can be provided which can redirect the output to a window.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (47%)
  • Biddiscombe, John (26%)
  • Lorensen, Bill (17%)
Tests:
vtkOutputWindow (Tests)

Definition at line 62 of file vtkOutputWindow.h.

Constructor & Destructor Documentation

vtkOutputWindow::vtkOutputWindow ( ) [protected]

virtual vtkOutputWindow::~vtkOutputWindow ( ) [protected, virtual]

Member Function Documentation

vtkOutputWindow::vtkTypeRevisionMacro | ( | vtkOutputWindow | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkFileOutputWindow, vtkWin32OutputWindow, and vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactor to stream.

Reimplemented from vtkObject.

Reimplemented in vtkFileOutputWindow.

vtkOutputWindow* vtkOutputWindow::New ( ) [static]

This is a singleton pattern New. There will only be ONE reference to a vtkOutputWindow object per process. Clients that call this must call Delete on the object so that the reference counting will work. The single instance will be unreferenced when the program exits.

Reimplemented from vtkObject.

Reimplemented in vtkFileOutputWindow, vtkWin32OutputWindow, and vtkXMLFileOutputWindow.

vtkOutputWindow* vtkOutputWindow::GetInstance ( ) [static]

void vtkOutputWindow::SetInstance ( vtkOutputWindow * instance ) [static]

virtual void vtkOutputWindow::DisplayText ( const char * ) [virtual]

Reimplemented in vtkFileOutputWindow, vtkWin32OutputWindow, and vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::DisplayErrorText ( const char * ) [virtual]

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::DisplayWarningText ( const char * ) [virtual]

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::DisplayGenericWarningText ( const char * ) [virtual]

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::DisplayDebugText ( const char * ) [virtual]

Reimplemented in vtkXMLFileOutputWindow.

virtual void vtkOutputWindow::PromptUserOn ( ) [virtual]

If PromptUser is set to true then each time a line of text is displayed, the user is asked if they want to keep getting messages.

virtual void vtkOutputWindow::PromptUserOff ( ) [virtual]

If PromptUser is set to true then each time a line of text is displayed, the user is asked if they want to keep getting messages.

virtual void vtkOutputWindow::SetPromptUser ( int ) [virtual]

If PromptUser is set to true then each time a line of text is displayed, the user is asked if they want to keep getting messages.

Member Data Documentation

vtkOutputWindowSmartPointer vtkOutputWindow::SmartPointer [static]

Definition at line 104 of file vtkOutputWindow.h.

int vtkOutputWindow::PromptUser [protected]

Definition at line 109 of file vtkOutputWindow.h.

The documentation for this class was generated from the following file:
  • Common/vtkOutputWindow.h
Generated on Mon Mar 25 01:27:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOutputWindowSmartPointer Class Reference

#include <vtkOutputWindow.h>

Collaboration diagram for vtkOutputWindowSmartPointer:

[legend]
List of all members.

Public Methods

vtkOutputWindowSmartPointer (vtkOutputWindow *p)
void SetPointer (vtkOutputWindow *obj)
~vtkOutputWindowSmartPointer ()

Constructor & Destructor Documentation

vtkOutputWindowSmartPointer::vtkOutputWindowSmartPointer ( vtkOutputWindow * p ) [inline]

Definition at line 51 of file vtkOutputWindow.h.

vtkOutputWindowSmartPointer::~vtkOutputWindowSmartPointer ( )

Member Function Documentation

void vtkOutputWindowSmartPointer::SetPointer ( vtkOutputWindow * obj ) [inline]

Definition at line 52 of file vtkOutputWindow.h.

The documentation for this class was generated from the following file:
  • Common/vtkOutputWindow.h
Generated on Mon Mar 25 01:27:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOverrideInformation Class Reference

Factory object override information. More...

#include <vtkOverrideInformation.h>

Inheritance diagram for vtkOverrideInformation:

[legend]
Collaboration diagram for vtkOverrideInformation:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOverrideInformation, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
const char * | GetClassOverrideName ()
const char * | GetClassOverrideWithName ()
const char * | GetDescription ()
vtkObjectFactory * GetObjectFactory ()
virtual void | SetClassOverrideName (const char *)
virtual void | SetClassOverrideWithName (const char *)
virtual void | SetDescription (const char *)

Static Public Methods

vtkOverrideInformation * | New ()

Protected Methods

virtual void | SetObjectFactory (vtkObjectFactory *)

Friends

class | vtkObjectFactory

Detailed Description

Factory object override information.

Date:
2002/01/22 15:25:52
Revision:
1.6

vtkOverrideInformation is used to represent the information about a class which is overriden in a vtkObjectFactory.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (98%)
Tests:
vtkOverrideInformation (Tests)

Definition at line 44 of file vtkOverrideInformation.h.

Member Function Documentation

vtkOverrideInformation* vtkOverrideInformation::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkOverrideInformation::vtkTypeRevisionMacro | ( | vtkOverrideInformation | ,
 |  | vtkObject |
 | ) |

virtual void vtkOverrideInformation::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactor to stream.

Reimplemented from vtkObject.

const char* vtkOverrideInformation::GetClassOverrideName ( ) [inline]

Returns the name of the class being overriden. For example, if you had a factory that provided an override for vtkVertex, then this funciton would return "vtkVertex"

Definition at line 56 of file vtkOverrideInformation.h.

const char* vtkOverrideInformation::GetClassOverrideWithName ( ) [inline]

Returns the name of the class that will override the class. For example, if you had a factory that provided an override for vtkVertex called vtkMyVertex, then this would return "vtkMyVertex"

Definition at line 66 of file vtkOverrideInformation.h.

const char* vtkOverrideInformation::GetDescription ( ) [inline]

Return a human readable or GUI displayable description of this override.

Definition at line 75 of file vtkOverrideInformation.h.

vtkObjectFactory* vtkOverrideInformation::GetObjectFactory ( ) [inline]

Return the specific object factory that this override occurs in.

Definition at line 83 of file vtkOverrideInformation.h.

virtual void vtkOverrideInformation::SetClassOverrideName ( const char * ) [virtual]

Return the specific object factory that this override occurs in.

virtual void vtkOverrideInformation::SetClassOverrideWithName ( const char * ) [virtual]

Return the specific object factory that this override occurs in.

virtual void vtkOverrideInformation::SetDescription ( const char * ) [virtual]

Return the specific object factory that this override occurs in.

virtual void vtkOverrideInformation::SetObjectFactory ( vtkObjectFactory * ) [protected, virtual]

Friends And Related Function Documentation

friend class vtkObjectFactory [friend]

Definition at line 103 of file vtkOverrideInformation.h.

The documentation for this class was generated from the following file:
  • Common/vtkOverrideInformation.h
Generated on Mon Mar 25 01:27:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkOverrideInformationCollection Class Reference

maintain a list of override information objects. More...

#include <vtkOverrideInformationCollection.h>

Inheritance diagram for vtkOverrideInformationCollection:

[legend]
Collaboration diagram for vtkOverrideInformationCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkOverrideInformationCollection, vtkCollection)
void | AddItem (vtkOverrideInformation *)
vtkOverrideInformation * GetNextItem ()

Static Public Methods

vtkOverrideInformationCollection * | New ()

Protected Methods

vtkOverrideInformationCollection ()
~vtkOverrideInformationCollection ()

Detailed Description

maintain a list of override information objects.

Date:
2002/01/22 15:25:52
Revision:
1.8

vtkOverrideInformationCollection is an object that creates and manipulates lists of objects of type vtkOverrideInformation.

See also:
vtkCollection
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (91%)
  • Martin, Ken (5%)
Tests:
vtkOverrideInformationCollection (Tests)

Definition at line 44 of file vtkOverrideInformationCollection.h.

Constructor & Destructor Documentation

vtkOverrideInformationCollection::vtkOverrideInformationCollection ( ) [inline, protected]

Definition at line 57 of file vtkOverrideInformationCollection.h.

vtkOverrideInformationCollection::~vtkOverrideInformationCollection ( ) [inline, protected]

Definition at line 58 of file vtkOverrideInformationCollection.h.

Member Function Documentation

vtkOverrideInformationCollection::vtkTypeRevisionMacro | ( | vtkOverrideInformationCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkOverrideInformationCollection* vtkOverrideInformationCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkOverrideInformationCollection::AddItem ( vtkOverrideInformation * f ) [inline]

Add a OverrideInformation to the list.

Definition at line 70 of file vtkOverrideInformationCollection.h.

vtkOverrideInformation * vtkOverrideInformationCollection::GetNextItem ( ) [inline]

Get the next OverrideInformation in the list.

Definition at line 75 of file vtkOverrideInformationCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkOverrideInformationCollection.h
Generated on Mon Mar 25 01:27:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParallelCoordinatesActor Class Reference

create parallel coordinate display from input field. More...

#include <vtkParallelCoordinatesActor.h>

Inheritance diagram for vtkParallelCoordinatesActor:

[legend]
Collaboration diagram for vtkParallelCoordinatesActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkParallelCoordinatesActor, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ReleaseGraphicsResources (vtkWindow *)
virtual void | SetIndependentVariables (int)
virtual int | GetIndependentVariables ()
void | SetIndependentVariablesToColumns ()
void | SetIndependentVariablesToRows ()
virtual void | SetTitle (const char *)
virtual char * | GetTitle ()
virtual void | SetNumberOfLabels (int)
virtual int | GetNumberOfLabels ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
int | RenderOpaqueGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *)
int | RenderTranslucentGeometry (vtkViewport *)
virtual void | SetInput (vtkDataObject *)
virtual vtkDataObject * | GetInput ()

Static Public Methods

vtkParallelCoordinatesActor * | New ()

Protected Methods

vtkParallelCoordinatesActor ()
~vtkParallelCoordinatesActor ()

Detailed Description

create parallel coordinate display from input field.

Date:
2002/01/22 15:39:03
Revision:
1.16

vtkParallelCoordinatesActor generates a parallel coordinates plot from an input field (i.e., vtkDataObject). Parallel coordinates represent N-dimensional data by using a set of N parallel axes (not orthogonal like the usual x-y-z Cartesian axes). Each N-dimensional point is plotted as a polyline, were each of the N components of the point lie on one of the N axes, and the components are connected by straight lines.

To use this class, you must specify an input data object. You'll probably also want to specify the position of the plot be setting the Position and Position2 instance variables, which define a rectangle in which the plot lies. Another important parameter is the IndependentVariables ivar, which tells the instance how to interpret the field data (independent variables as the rows or columns of the field). There are also many other instance variables that control the look of the plot includes its title, font attributes, number of ticks on the axes, etc.

Warning:
Field data is not necessarily "rectangular" in shape. In these cases, some of the data may not be plotted.
Warning:
The early implementation lacks many features that could be added in the future. This includes the ability to "brush" data (choose regions along an axis and highlight any points/lines passing through the region); efficiency is really bad; more control over the properties of the plot (separate properties for each axes,title,etc.; and using the labels found in the field to label each of the axes.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (91%)
Tests:
vtkParallelCoordinatesActor (Tests)

Definition at line 69 of file vtkParallelCoordinatesActor.h.

Constructor & Destructor Documentation

vtkParallelCoordinatesActor::vtkParallelCoordinatesActor ( ) [protected]

vtkParallelCoordinatesActor::~vtkParallelCoordinatesActor ( ) [protected]

Member Function Documentation

vtkParallelCoordinatesActor::vtkTypeRevisionMacro | ( | vtkParallelCoordinatesActor | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkParallelCoordinatesActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkParallelCoordinatesActor* vtkParallelCoordinatesActor::New ( ) [static]

Instantiate object with autorange computation; bold, italic, and shadows on; arial font family; the number of labels set to 5 for the x and y axes; a label format of "-#6.3g"; and x coordinates computed from point ids.

Reimplemented from vtkActor2D.

virtual void vtkParallelCoordinatesActor::SetIndependentVariables ( int ) [virtual]

Specify whether to use the rows or columns as independent variables. If columns, then each row represents a separate point. If rows, then each column represents a separate point.

virtual int vtkParallelCoordinatesActor::GetIndependentVariables ( ) [virtual]

Specify whether to use the rows or columns as independent variables. If columns, then each row represents a separate point. If rows, then each column represents a separate point.

void vtkParallelCoordinatesActor::SetIndependentVariablesToColumns ( ) [inline]

Specify whether to use the rows or columns as independent variables. If columns, then each row represents a separate point. If rows, then each column represents a separate point.

Definition at line 87 of file vtkParallelCoordinatesActor.h.

void vtkParallelCoordinatesActor::SetIndependentVariablesToRows ( ) [inline]

Specify whether to use the rows or columns as independent variables. If columns, then each row represents a separate point. If rows, then each column represents a separate point.

Definition at line 89 of file vtkParallelCoordinatesActor.h.

virtual void vtkParallelCoordinatesActor::SetTitle ( const char * ) [virtual]

Set/Get the title of the parallel coordinates plot.

virtual char* vtkParallelCoordinatesActor::GetTitle ( ) [virtual]

Set/Get the title of the parallel coordinates plot.

virtual void vtkParallelCoordinatesActor::SetNumberOfLabels ( int ) [virtual]

Set/Get the number of annotation labels to show along each axis. This values is a suggestion: the number of labels may vary depending on the particulars of the data.

virtual int vtkParallelCoordinatesActor::GetNumberOfLabels ( ) [virtual]

Set/Get the number of annotation labels to show along each axis. This values is a suggestion: the number of labels may vary depending on the particulars of the data.

virtual void vtkParallelCoordinatesActor::SetBold ( int ) [virtual]

Enable/Disable bolding annotation text.

virtual int vtkParallelCoordinatesActor::GetBold ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkParallelCoordinatesActor::BoldOn ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkParallelCoordinatesActor::BoldOff ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkParallelCoordinatesActor::SetItalic ( int ) [virtual]

Enable/Disable italicizing annotation text.

virtual int vtkParallelCoordinatesActor::GetItalic ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkParallelCoordinatesActor::ItalicOn ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkParallelCoordinatesActor::ItalicOff ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkParallelCoordinatesActor::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual int vtkParallelCoordinatesActor::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkParallelCoordinatesActor::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkParallelCoordinatesActor::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkParallelCoordinatesActor::SetFontFamily ( int ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkParallelCoordinatesActor::GetFontFamily ( ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkParallelCoordinatesActor::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 135 of file vtkParallelCoordinatesActor.h.

void vtkParallelCoordinatesActor::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 136 of file vtkParallelCoordinatesActor.h.

void vtkParallelCoordinatesActor::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 137 of file vtkParallelCoordinatesActor.h.

virtual void vtkParallelCoordinatesActor::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels on the axes.

virtual char* vtkParallelCoordinatesActor::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels on the axes.

int vtkParallelCoordinatesActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Draw the parallel coordinates plot.

Reimplemented from vtkActor2D.

int vtkParallelCoordinatesActor::RenderOverlay ( vtkViewport * viewport ) [virtual]

Draw the parallel coordinates plot.

Reimplemented from vtkActor2D.

int vtkParallelCoordinatesActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

Draw the parallel coordinates plot.

Reimplemented from vtkActor2D.

Definition at line 150 of file vtkParallelCoordinatesActor.h.

virtual void vtkParallelCoordinatesActor::SetInput ( vtkDataObject * ) [virtual]

Set the input to the parallel coordinates actor.

virtual vtkDataObject* vtkParallelCoordinatesActor::GetInput ( ) [virtual]

Remove a dataset from the list of data to append.

void vtkParallelCoordinatesActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

The documentation for this class was generated from the following file:
  • Rendering/vtkParallelCoordinatesActor.h
Generated on Mon Mar 25 01:27:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParallelFactory Class Reference

#include <vtkParallelFactory.h>

Inheritance diagram for vtkParallelFactory:

[legend]
Collaboration diagram for vtkParallelFactory:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkParallelFactory, vtkObjectFactory)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual const char * | GetVTKSourceVersion ()
virtual const char * | GetDescription ()

Static Public Methods

vtkParallelFactory * | New ()

Protected Methods

vtkParallelFactory ()
~vtkParallelFactory ()

Detailed Description

Date:
2002/01/22 15:34:52
Revision:
1.8
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Geveci, Berk (19%)
Tests:
vtkParallelFactory (Tests)

Definition at line 38 of file vtkParallelFactory.h.

Constructor & Destructor Documentation

vtkParallelFactory::vtkParallelFactory ( ) [protected]

vtkParallelFactory::~vtkParallelFactory ( ) [inline, protected]

Definition at line 49 of file vtkParallelFactory.h.

Member Function Documentation

vtkParallelFactory::vtkTypeRevisionMacro | ( | vtkParallelFactory | ,
 |  | vtkObjectFactory |
 | ) |

Reimplemented from vtkObjectFactory.

vtkParallelFactory* vtkParallelFactory::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

void vtkParallelFactory::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Print ObjectFactory to stream.

Reimplemented from vtkObjectFactory.

virtual const char* vtkParallelFactory::GetVTKSourceVersion ( ) [virtual]

All sub-classes of vtkObjectFactory should must return the version of VTK they were built with. This should be implemented with the macro VTK_SOURCE_VERSION and NOT a call to vtkVersion::GetVTKSourceVersion. As the version needs to be compiled into the file as a string constant. This is critical to determine possible incompatible dynamic factory loads.

Reimplemented from vtkObjectFactory.

virtual const char* vtkParallelFactory::GetDescription ( ) [virtual]

Return a descriptive string describing the factory.

Reimplemented from vtkObjectFactory.

The documentation for this class was generated from the following file:
  • Parallel/vtkParallelFactory.h
Generated on Mon Mar 25 01:27:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkParticleReader Class Reference

Read raw particle data and one array. More...

#include <vtkParticleReader.h>

Inheritance diagram for vtkParticleReader:

[legend]
Collaboration diagram for vtkParticleReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkParticleReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
void | SetDataByteOrderToBigEndian ()
void | SetDataByteOrderToLittleEndian ()
int | GetDataByteOrder ()
void | SetDataByteOrder (int)
const char * | GetDataByteOrderAsString ()
virtual void | SetSwapBytes (int)
int | GetSwapBytes ()
virtual void | SwapBytesOn ()
virtual void | SwapBytesOff ()

Static Public Methods

vtkParticleReader * | New ()

Protected Methods

vtkParticleReader ()
~vtkParticleReader ()
void | OpenFile ()
void | ExecuteInformation ()
void | Execute ()

Protected Attributes

char * | FileName
ifstream * | File
int | SwapBytes
unsigned long | NumberOfPoints

Detailed Description

Read raw particle data and one array.

Date:
2002/01/22 15:38:19
Revision:
1.5

vtkParticleReader reads a raw file with particles. It supports random access into the file to read pieces. The format is: x, y, z, value (all floats). This class was developed with a specific file in mind, but may be made more general in the future. Here are a couple of features I am considering: any data types could be used, arbitrary list of arrays to read (extended to vectors as well), and time serries based on file names.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (97%)
Tests:
vtkParticleReader (Tests)

Definition at line 49 of file vtkParticleReader.h.

Constructor & Destructor Documentation

vtkParticleReader::vtkParticleReader ( ) [protected]

vtkParticleReader::~vtkParticleReader ( ) [protected]

Member Function Documentation

vtkParticleReader* vtkParticleReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkParticleReader::vtkTypeRevisionMacro | ( | vtkParticleReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkParticleReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkParticleReader::SetFileName ( const char * ) [virtual]

Specify file name.

virtual char* vtkParticleReader::GetFileName ( ) [virtual]

Specify file name.

void vtkParticleReader::SetDataByteOrderToBigEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkParticleReader::SetDataByteOrderToLittleEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

int vtkParticleReader::GetDataByteOrder ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkParticleReader::SetDataByteOrder ( int )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

const char* vtkParticleReader::GetDataByteOrderAsString ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

virtual void vtkParticleReader::SetSwapBytes ( int ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

int vtkParticleReader::GetSwapBytes ( ) [inline]

Set/Get the byte swapping to explicitly swap the bytes of a file.

Definition at line 83 of file vtkParticleReader.h.

virtual void vtkParticleReader::SwapBytesOn ( ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

virtual void vtkParticleReader::SwapBytesOff ( ) [virtual]

Set/Get the byte swapping to explicitly swap the bytes of a file.

void vtkParticleReader::OpenFile ( ) [protected]

void vtkParticleReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkParticleReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkParticleReader::FileName [protected]

Definition at line 93 of file vtkParticleReader.h.

ifstream* vtkParticleReader::File [protected]

Definition at line 94 of file vtkParticleReader.h.

int vtkParticleReader::SwapBytes [protected]

Definition at line 95 of file vtkParticleReader.h.

unsigned long vtkParticleReader::NumberOfPoints [protected]

Definition at line 97 of file vtkParticleReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkParticleReader.h
Generated on Mon Mar 25 01:27:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPCAAnalysisFilter Class Reference

Performs principal component analysis of a set of aligned pointsets. More...

#include <vtkPCAAnalysisFilter.h>

Inheritance diagram for vtkPCAAnalysisFilter:

[legend]
Collaboration diagram for vtkPCAAnalysisFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPCAAnalysisFilter, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfInputs (int n)
void | SetInput (int idx, vtkPointSet *p)
vtkPointSet * | GetOutput (int idx)
void | GetParameterisedShape (vtkFloatArray *b, vtkPointSet *shape)
void | GetShapeParameters (vtkPointSet *shape, vtkFloatArray *b, int bsize)
vtkPointSet * | GetInput (int idx)
int | GetModesRequiredFor (float proportion)
virtual vtkFloatArray * | GetEvals ()

Static Public Methods

vtkPCAAnalysisFilter * | New ()

Protected Methods

vtkPCAAnalysisFilter ()
~vtkPCAAnalysisFilter ()
void | Execute ()

Detailed Description

Performs principal component analysis of a set of aligned pointsets.

Date:
2002/02/13 10:08:35
Revision:
1.2

vtkPCAAnalysisFilter is a filter that takes as input a set of aligned pointsets (any object derived from vtkPointSet) and performs a principal component analysis of the coordinates. This can be used to visualise the major or minor modes of variation seen in a set of similar biological objects with corresponding landmarks. vtkPCAAnalysisFilter is designed to work with the output from the vtkProcrustesAnalysisFilter

Call SetNumberOfInputs(n) before calling SetInput(0) ... SetInput(n-1). Retrieve the outputs using GetOutput(0) ... GetOutput(n-1).

vtkPCAAnalysisFilter is an implementation of (for example):

T. Cootes et al. : Active Shape Models - their training and application. Computer Vision and Image Understanding, 61(1):38-59, 1995.

The material can also be found in Tim Cootes' ever-changing online report published at his website: http://www.isbe.man.ac.uk/~bim/

Warning:
All of the input pointsets must have the same number of points.
Thanks:
Rasmus Paulsen and Tim Hutton who developed and contributed this class
See also:
vtkProcrustesAlignmentFilter
Created by:
  • Paulsen, Rasmus Reinhold
Contributed by (if > 5%):
  • Paulsen, Rasmus Reinhold (90%)
  • Hutton, Tim (9%)

Definition at line 69 of file vtkPCAAnalysisFilter.h.

Constructor & Destructor Documentation

vtkPCAAnalysisFilter::vtkPCAAnalysisFilter ( ) [protected]

vtkPCAAnalysisFilter::~vtkPCAAnalysisFilter ( ) [protected]

Member Function Documentation

vtkPCAAnalysisFilter::vtkTypeRevisionMacro | ( | vtkPCAAnalysisFilter | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkPCAAnalysisFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Prints information about the state of the filter.

Reimplemented from vtkSource.

vtkPCAAnalysisFilter* vtkPCAAnalysisFilter::New ( ) [static]

Creates with similarity transform.

Reimplemented from vtkProcessObject.

virtual vtkFloatArray* vtkPCAAnalysisFilter::GetEvals ( ) [virtual]

Get the vector of eigenvalues sorted in descending order

void vtkPCAAnalysisFilter::SetNumberOfInputs ( int n )

Specify how many pointsets are going to be given as input.

Reimplemented from vtkProcessObject.

void vtkPCAAnalysisFilter::SetInput | ( | int | idx,
 |  | vtkPointSet * | p
 | ) |

Specify the input pointset with index idx. Call SetNumberOfInputs before calling this function.

vtkPointSet* vtkPCAAnalysisFilter::GetOutput ( int idx )

Retrieve the output point set with index idx. The output is the eigenvector sorted according to their eigenvalues (descending order)

Reimplemented from vtkSource.

void vtkPCAAnalysisFilter::GetParameterisedShape | ( | vtkFloatArray * | b,
 |  | vtkPointSet * | shape
 | ) |

Fills the shape with: mean + b[0] * sqrt(eigenvalue[0]) * eigenvector[0] + b[1] * sqrt(eigenvalue[1]) * eigenvector[1] ... + b[sizeb-1] * sqrt(eigenvalue[bsize-1]) * eigenvector[bsize-1] here b are the parameters expressed in standard deviations bsize is the number of parameters in the b vector This function assumes that shape is allready allocated with the right size, it just moves the points.

void vtkPCAAnalysisFilter::GetShapeParameters | ( | vtkPointSet * | shape,
 |  | vtkFloatArray * | b,
 |  | int | bsize
 | ) |

Return the bsize parameters b that best model the given shape (in standard deviations). That is that the given shape will be approximated by: shape ~ mean + b[0] * sqrt(eigenvalue[0]) * eigenvector[0] + b[1] * sqrt(eigenvalue[1]) * eigenvector[1] ... + b[bsize-1] * sqrt(eigenvalue[bsize-1]) * eigenvector[bsize-1]

vtkPointSet* vtkPCAAnalysisFilter::GetInput ( int idx )

Retrieve the input with index idx (usually only used for pipeline tracing).

int vtkPCAAnalysisFilter::GetModesRequiredFor ( float proportion )

Retrieve how many modes are necessary to model the given proportion of the variation. proportion should be between 0 and 1

void vtkPCAAnalysisFilter::Execute ( ) [protected, virtual]

Usual data generation method.

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Hybrid/vtkPCAAnalysisFilter.h
Generated on Mon Mar 25 01:27:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPCellDataToPointData Class Reference

Compute point arrays from cell arrays. More...

#include <vtkPCellDataToPointData.h>

Inheritance diagram for vtkPCellDataToPointData:

[legend]
Collaboration diagram for vtkPCellDataToPointData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPCellDataToPointData, vtkCellDataToPointData)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPieceInvariant (int)
virtual int | GetPieceInvariant ()
virtual void | PieceInvariantOn ()
virtual void | PieceInvariantOff ()

Static Public Methods

vtkPCellDataToPointData * | New ()

Protected Methods

vtkPCellDataToPointData ()
~vtkPCellDataToPointData ()
virtual void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | PieceInvariant

Detailed Description

Compute point arrays from cell arrays.

Date:
2002/03/12 18:22:33
Revision:
1.1

Like it super class, this filter averages the cell data around a point to get new point data. This subclass requests a layer of ghost cells to make the results invariant to pieces. There is a "PieceInvariant" flag that lets the user change the behavior of the filter to that of its superclass.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (100%)

Definition at line 40 of file vtkPCellDataToPointData.h.

Constructor & Destructor Documentation

vtkPCellDataToPointData::vtkPCellDataToPointData ( ) [protected]

vtkPCellDataToPointData::~vtkPCellDataToPointData ( ) [inline, protected]

Definition at line 58 of file vtkPCellDataToPointData.h.

Member Function Documentation

vtkPCellDataToPointData::vtkTypeRevisionMacro | ( | vtkPCellDataToPointData | ,
 |  | vtkCellDataToPointData |
 | ) |

Reimplemented from vtkCellDataToPointData.

void vtkPCellDataToPointData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCellDataToPointData.

vtkPCellDataToPointData* vtkPCellDataToPointData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkCellDataToPointData.

virtual void vtkPCellDataToPointData::SetPieceInvariant ( int ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual int vtkPCellDataToPointData::GetPieceInvariant ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPCellDataToPointData::PieceInvariantOn ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPCellDataToPointData::PieceInvariantOff ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPCellDataToPointData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkCellDataToPointData.

void vtkPCellDataToPointData::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

By default copy the output update extent to the input

Reimplemented from vtkDataSetToDataSetFilter.

Member Data Documentation

int vtkPCellDataToPointData::PieceInvariant [protected]

Definition at line 64 of file vtkPCellDataToPointData.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPCellDataToPointData.h
Generated on Mon Mar 25 01:27:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPDataSetReader Class Reference

Manages writing pieces of a data set. More...

#include <vtkPDataSetReader.h>

Inheritance diagram for vtkPDataSetReader:

[legend]
Collaboration diagram for vtkPDataSetReader:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkPDataSetReader, vtkSource)
virtual void | Update ()
virtual int | ReadOutputType ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
void | SetOutput (vtkDataSet *output)
virtual vtkDataSet * | GetOutput ()
virtual int | GetDataType ()

Static Public Methods

vtkPDataSetReader * | New ()

Protected Methods

vtkPDataSetReader ()
~vtkPDataSetReader ()
vtkPDataSetReader (const vtkPDataSetReader &)
void | operator= (const vtkPDataSetReader &)
virtual void | ExecuteInformation ()
void | ReadPVTKFileInformation (ifstream *fp)
void | ReadVTKFileInformation (ifstream *fp)
virtual void | Execute ()
void | PolyDataExecute ()
void | UnstructuredGridExecute ()
void | ImageDataExecute ()
void | StructuredGridExecute ()
void | CoverExtent (int ext[6], int *pieceMask)
vtkDataSet * CheckOutput ()
void | SetNumberOfPieces (int num)
ifstream * | OpenFile ()
int | ReadXML (ifstream *file, char **block, char **param, char **value)

Protected Attributes

int | VTKFileFlag
int | StructuredFlag
char * | FileName
int | DataType
int | NumberOfPieces
char ** | PieceFileNames
int ** | PieceExtents

Detailed Description

Manages writing pieces of a data set.

Date:
2002/03/07 02:12:45
Revision:
1.9

vtkPDataSetReader will write a piece of a file, and will also create a metadata file that lists all of the files in a data set.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (63%)
  • Hoffman, Bill (35%)
Tests:
vtkPDataSetReader (Tests)

Definition at line 44 of file vtkPDataSetReader.h.

Constructor & Destructor Documentation

vtkPDataSetReader::vtkPDataSetReader ( ) [protected]

vtkPDataSetReader::~vtkPDataSetReader ( ) [protected]

vtkPDataSetReader::vtkPDataSetReader ( const vtkPDataSetReader & ) [protected]

Member Function Documentation

void vtkPDataSetReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPDataSetReader::vtkTypeRevisionMacro | ( | vtkPDataSetReader | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

vtkPDataSetReader* vtkPDataSetReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

virtual void vtkPDataSetReader::SetFileName ( const char * ) [virtual]

This file to open and read.

virtual char* vtkPDataSetReader::GetFileName ( ) [virtual]

This file to open and read.

void vtkPDataSetReader::SetOutput ( vtkDataSet * output )

The output of this reader depends on the file choosen. You cannot get the output until the filename is set.

virtual vtkDataSet* vtkPDataSetReader::GetOutput ( ) [virtual]

The output of this reader depends on the file choosen. You cannot get the output until the filename is set.

virtual void vtkPDataSetReader::Update ( ) [virtual]

We need to define this so that the output gets created.

Reimplemented from vtkSource.

virtual int vtkPDataSetReader::GetDataType ( ) [virtual]

This is set when UpdateInformation is called. It shows the type of the output.

virtual int vtkPDataSetReader::ReadOutputType ( ) [virtual]

This method can be used to find out the type of output expected without needing to read the whole file.

void vtkPDataSetReader::operator= ( const vtkPDataSetReader & ) [protected]

virtual void vtkPDataSetReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkPDataSetReader::ReadPVTKFileInformation ( ifstream * fp ) [protected]

void vtkPDataSetReader::ReadVTKFileInformation ( ifstream * fp ) [protected]

virtual void vtkPDataSetReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPDataSetReader::PolyDataExecute ( ) [protected]

void vtkPDataSetReader::UnstructuredGridExecute ( ) [protected]

void vtkPDataSetReader::ImageDataExecute ( ) [protected]

void vtkPDataSetReader::StructuredGridExecute ( ) [protected]

void vtkPDataSetReader::CoverExtent | ( | int | ext[6],
 |  | int * | pieceMask
 | ) | [protected]

vtkDataSet* vtkPDataSetReader::CheckOutput ( ) [protected]

void vtkPDataSetReader::SetNumberOfPieces ( int num ) [protected]

ifstream* vtkPDataSetReader::OpenFile ( ) [protected]

int vtkPDataSetReader::ReadXML | ( | ifstream * | file,
 |  | char ** | block,
 |  | char ** | param,
 |  | char ** | value
 | ) | [protected]

Member Data Documentation

int vtkPDataSetReader::VTKFileFlag [protected]

Definition at line 103 of file vtkPDataSetReader.h.

int vtkPDataSetReader::StructuredFlag [protected]

Definition at line 104 of file vtkPDataSetReader.h.

char* vtkPDataSetReader::FileName [protected]

Definition at line 105 of file vtkPDataSetReader.h.

int vtkPDataSetReader::DataType [protected]

Definition at line 106 of file vtkPDataSetReader.h.

int vtkPDataSetReader::NumberOfPieces [protected]

Definition at line 107 of file vtkPDataSetReader.h.

char** vtkPDataSetReader::PieceFileNames [protected]

Definition at line 108 of file vtkPDataSetReader.h.

int** vtkPDataSetReader::PieceExtents [protected]

Definition at line 109 of file vtkPDataSetReader.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPDataSetReader.h
Generated on Mon Mar 25 01:27:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPDataSetWriter Class Reference

Manages writing pieces of a data set. More...

#include <vtkPDataSetWriter.h>

Inheritance diagram for vtkPDataSetWriter:

[legend]
Collaboration diagram for vtkPDataSetWriter:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkPDataSetWriter, vtkDataSetWriter)
virtual void | Write ()
void | SetNumberOfPieces (int num)
virtual int | GetNumberOfPieces ()
virtual void | SetGhostLevel (int)
virtual int | GetGhostLevel ()
virtual void | SetStartPiece (int)
virtual int | GetStartPiece ()
virtual void | SetEndPiece (int)
virtual int | GetEndPiece ()
virtual void | SetFilePattern (const char *)
virtual char * | GetFilePattern ()
virtual void | SetUseRelativeFileNames (int)
virtual int | GetUseRelativeFileNames ()
virtual void | UseRelativeFileNamesOn ()
virtual void | UseRelativeFileNamesOff ()

Static Public Methods

vtkPDataSetWriter * | New ()

Protected Methods

vtkPDataSetWriter ()
~vtkPDataSetWriter ()
vtkPDataSetWriter (const vtkPDataSetWriter &)
void | operator= (const vtkPDataSetWriter &)
ostream * OpenFile ()
void | WriteUnstructuredMetaData (vtkDataSet *input, char *root, char *str, ostream *fptr)
void | WriteImageMetaData (vtkImageData *input, char *root, char *str, ostream *fptr)
void | WriteRectilinearGridMetaData (vtkRectilinearGrid *input, char *root, char *str, ostream *fptr)
void | WriteStructuredGridMetaData (vtkStructuredGrid *input, char *root, char *str, ostream *fptr)

Protected Attributes

int | StartPiece
int | EndPiece
int | NumberOfPieces
int | GhostLevel
int | UseRelativeFileNames
char * | FilePattern

Detailed Description

Manages writing pieces of a data set.

Date:
2002/01/22 15:34:45
Revision:
1.6

vtkPDataSetWriter will write a piece of a file, and will also create a metadata file that lists all of the files in a data set.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Hoffman, Bill (56%)
  • Law, Charles (42%)
Tests:
vtkPDataSetWriter (Tests)

Definition at line 45 of file vtkPDataSetWriter.h.

Constructor & Destructor Documentation

vtkPDataSetWriter::vtkPDataSetWriter ( ) [protected]

vtkPDataSetWriter::~vtkPDataSetWriter ( ) [protected]

vtkPDataSetWriter::vtkPDataSetWriter ( const vtkPDataSetWriter & ) [protected]

Member Function Documentation

void vtkPDataSetWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSetWriter.

vtkPDataSetWriter::vtkTypeRevisionMacro | ( | vtkPDataSetWriter | ,
 |  | vtkDataSetWriter |
 | ) |

Reimplemented from vtkDataSetWriter.

vtkPDataSetWriter* vtkPDataSetWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataSetWriter.

virtual void vtkPDataSetWriter::Write ( ) [virtual]

Write the pvtk file and cooresponding vtk files.

Reimplemented from vtkWriter.

void vtkPDataSetWriter::SetNumberOfPieces ( int num )

This is how many pieces the whole data set will be divided into.

virtual int vtkPDataSetWriter::GetNumberOfPieces ( ) [virtual]

This is how many pieces the whole data set will be divided into.

virtual void vtkPDataSetWriter::SetGhostLevel ( int ) [virtual]

Extra ghost cells will be written out to each piece file if this value is larger than 0.

virtual int vtkPDataSetWriter::GetGhostLevel ( ) [virtual]

Extra ghost cells will be written out to each piece file if this value is larger than 0.

virtual void vtkPDataSetWriter::SetStartPiece ( int ) [virtual]

This is the range of pieces that that this writer is responsible for writing. All pieces must be written by some process. The process that writes piece 0 also writes the pvtk file that lists all the piece file names.

virtual int vtkPDataSetWriter::GetStartPiece ( ) [virtual]

This is the range of pieces that that this writer is responsible for writing. All pieces must be written by some process. The process that writes piece 0 also writes the pvtk file that lists all the piece file names.

virtual void vtkPDataSetWriter::SetEndPiece ( int ) [virtual]

This is the range of pieces that that this writer is responsible for writing. All pieces must be written by some process. The process that writes piece 0 also writes the pvtk file that lists all the piece file names.

virtual int vtkPDataSetWriter::GetEndPiece ( ) [virtual]

This is the range of pieces that that this writer is responsible for writing. All pieces must be written by some process. The process that writes piece 0 also writes the pvtk file that lists all the piece file names.

virtual void vtkPDataSetWriter::SetFilePattern ( const char * ) [virtual]

This file pattern uses the file name and piece number to contruct a file name for the piece file.

virtual char* vtkPDataSetWriter::GetFilePattern ( ) [virtual]

This file pattern uses the file name and piece number to contruct a file name for the piece file.

virtual void vtkPDataSetWriter::SetUseRelativeFileNames ( int ) [virtual]

This flag determines whether to use absolute paths for the piece files. By default the pieces are put in the main directory, and the piece file names in the meta data pvtk file are relative to this directory. This should make moving the whole lot to another directory, an easier task.

virtual int vtkPDataSetWriter::GetUseRelativeFileNames ( ) [virtual]

This flag determines whether to use absolute paths for the piece files. By default the pieces are put in the main directory, and the piece file names in the meta data pvtk file are relative to this directory. This should make moving the whole lot to another directory, an easier task.

virtual void vtkPDataSetWriter::UseRelativeFileNamesOn ( ) [virtual]

This flag determines whether to use absolute paths for the piece files. By default the pieces are put in the main directory, and the piece file names in the meta data pvtk file are relative to this directory. This should make moving the whole lot to another directory, an easier task.

virtual void vtkPDataSetWriter::UseRelativeFileNamesOff ( ) [virtual]

This flag determines whether to use absolute paths for the piece files. By default the pieces are put in the main directory, and the piece file names in the meta data pvtk file are relative to this directory. This should make moving the whole lot to another directory, an easier task.

void vtkPDataSetWriter::operator= ( const vtkPDataSetWriter & ) [protected]

ostream* vtkPDataSetWriter::OpenFile ( ) [protected]

void vtkPDataSetWriter::WriteUnstructuredMetaData | ( | vtkDataSet * | input,
 |  | char * | root,
 |  | char * | str,
 |  | ostream * | fptr
 | ) | [protected]

void vtkPDataSetWriter::WriteImageMetaData | ( | vtkImageData * | input,
 |  | char * | root,
 |  | char * | str,
 |  | ostream * | fptr
 | ) | [protected]

void vtkPDataSetWriter::WriteRectilinearGridMetaData | ( | vtkRectilinearGrid * | input,
 |  | char * | root,
 |  | char * | str,
 |  | ostream * | fptr
 | ) | [protected]

void vtkPDataSetWriter::WriteStructuredGridMetaData | ( | vtkStructuredGrid * | input,
 |  | char * | root,
 |  | char * | str,
 |  | ostream * | fptr
 | ) | [protected]

Member Data Documentation

int vtkPDataSetWriter::StartPiece [protected]

Definition at line 115 of file vtkPDataSetWriter.h.

int vtkPDataSetWriter::EndPiece [protected]

Definition at line 116 of file vtkPDataSetWriter.h.

int vtkPDataSetWriter::NumberOfPieces [protected]

Definition at line 117 of file vtkPDataSetWriter.h.

int vtkPDataSetWriter::GhostLevel [protected]

Definition at line 118 of file vtkPDataSetWriter.h.

int vtkPDataSetWriter::UseRelativeFileNames [protected]

Definition at line 120 of file vtkPDataSetWriter.h.

char* vtkPDataSetWriter::FilePattern [protected]

Definition at line 122 of file vtkPDataSetWriter.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPDataSetWriter.h
Generated on Mon Mar 25 01:27:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPerlinNoise Class Reference

an implicit function that implements Perlin noise. More...

#include <vtkPerlinNoise.h>

Inheritance diagram for vtkPerlinNoise:

[legend]
Collaboration diagram for vtkPerlinNoise:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPerlinNoise, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float n[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetFrequency (float, float, float)
virtual void | SetFrequency (float[3])
virtual float * | GetFrequency ()
virtual void | GetFrequency (float data[3])
virtual void | SetPhase (float, float, float)
virtual void | SetPhase (float[3])
virtual float * | GetPhase ()
virtual void | GetPhase (float data[3])
virtual void | SetAmplitude (float)
virtual float | GetAmplitude ()

Static Public Methods

vtkPerlinNoise * | New ()

Protected Methods

vtkPerlinNoise ()
~vtkPerlinNoise ()

Protected Attributes

float | Frequency [3]
float | Phase [3]
float | Amplitude

Detailed Description

an implicit function that implements Perlin noise.

Date:
2002/03/05 20:29:03
Revision:
1.3

vtkPerlinNoise computes a Perlin noise field as an implicit function. vtkPerlinNoise is a concrete implementation of vtkImplicitFunction. Perlin noise, originally described by Ken Perlin, is a non-periodic and continuous noise function useful for modeling real-world objects.

The amplitude and frequency of the noise pattern are adjustable. This implementation of Perlin noise is derived closely from Greg Ward's version in Graphics Gems II.

See also:
vtkImplicitFunction
Created by:
  • Halle, Michael
Contributed by (if > 5%):
  • Halle, Michael (80%)
  • Schroeder, Will (17%)
Examples:
vtkPerlinNoise (Examples)
Tests:
vtkPerlinNoise (Tests)

Definition at line 53 of file vtkPerlinNoise.h.

Constructor & Destructor Documentation

vtkPerlinNoise::vtkPerlinNoise ( ) [protected]

vtkPerlinNoise::~vtkPerlinNoise ( ) [inline, protected]

Definition at line 99 of file vtkPerlinNoise.h.

Member Function Documentation

vtkPerlinNoise::vtkTypeRevisionMacro | ( | vtkPerlinNoise | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkPerlinNoise::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkPerlinNoise* vtkPerlinNoise::New ( ) [static]

Instantiate the class.

Reimplemented from vtkObject.

float vtkPerlinNoise::EvaluateFunction ( float x[3] ) [virtual]

Evaluate PerlinNoise function.

Reimplemented from vtkImplicitFunction.

float vtkPerlinNoise::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate PerlinNoise function.

Reimplemented from vtkImplicitFunction.

Definition at line 65 of file vtkPerlinNoise.h.

void vtkPerlinNoise::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate PerlinNoise gradient. Currently, the method returns a 0 gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkPerlinNoise::SetFrequency | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get the frequency, or physical scale, of the noise function (higher is finer scale). The frequency can be adjusted per axis, or the same for all axes.

virtual void vtkPerlinNoise::SetFrequency ( float [3] ) [virtual]

Set/get the frequency, or physical scale, of the noise function (higher is finer scale). The frequency can be adjusted per axis, or the same for all axes.

virtual float* vtkPerlinNoise::GetFrequency ( ) [virtual]

Set/get the frequency, or physical scale, of the noise function (higher is finer scale). The frequency can be adjusted per axis, or the same for all axes.

virtual void vtkPerlinNoise::GetFrequency ( float data[3] ) [virtual]

Set/get the frequency, or physical scale, of the noise function (higher is finer scale). The frequency can be adjusted per axis, or the same for all axes.

virtual void vtkPerlinNoise::SetPhase | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get the phase of the noise function. This parameter can be used to shift the noise function within space (perhaps to avoid a beat with a noise pattern at another scale). Phase tends to repeat about every unit, so a phase of 0.5 is a half-cycle shift.

virtual void vtkPerlinNoise::SetPhase ( float [3] ) [virtual]

Set/get the phase of the noise function. This parameter can be used to shift the noise function within space (perhaps to avoid a beat with a noise pattern at another scale). Phase tends to repeat about every unit, so a phase of 0.5 is a half-cycle shift.

virtual float* vtkPerlinNoise::GetPhase ( ) [virtual]

Set/get the phase of the noise function. This parameter can be used to shift the noise function within space (perhaps to avoid a beat with a noise pattern at another scale). Phase tends to repeat about every unit, so a phase of 0.5 is a half-cycle shift.

virtual void vtkPerlinNoise::GetPhase ( float data[3] ) [virtual]

Set/get the phase of the noise function. This parameter can be used to shift the noise function within space (perhaps to avoid a beat with a noise pattern at another scale). Phase tends to repeat about every unit, so a phase of 0.5 is a half-cycle shift.

virtual void vtkPerlinNoise::SetAmplitude ( float ) [virtual]

Set/get the amplitude of the noise function. By default, the amplitude is 1.

virtual float vtkPerlinNoise::GetAmplitude ( ) [virtual]

Set/get the amplitude of the noise function. By default, the amplitude is 1.

Member Data Documentation

float vtkPerlinNoise::Frequency[3] [protected]

Definition at line 101 of file vtkPerlinNoise.h.

float vtkPerlinNoise::Phase[3] [protected]

Definition at line 102 of file vtkPerlinNoise.h.

float vtkPerlinNoise::Amplitude [protected]

Definition at line 103 of file vtkPerlinNoise.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkPerlinNoise.h
Generated on Mon Mar 25 01:27:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPerspectiveTransform Class Reference

describes a 4x4 matrix transformation. More...

#include <vtkPerspectiveTransform.h>

Inheritance diagram for vtkPerspectiveTransform:

[legend]
Collaboration diagram for vtkPerspectiveTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPerspectiveTransform, vtkHomogeneousTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Identity ()
void | Inverse ()
void | Perspective (double angle, double aspect, double znear, double zfar)
void | Shear (double dxdz, double dydz, double zplane)
void | Stereo (double angle, double focaldistance)
void | Concatenate (vtkHomogeneousTransform *transform)
vtkAbstractTransform * MakeTransform ()
int | CircuitCheck (vtkAbstractTransform *transform)
unsigned long | GetMTime ()
void | AdjustViewport (double oldXMin, double oldXMax, double oldYMin, double oldYMax, double newXMin, double newXMax, double newYMin, double newYMax)
void | AdjustZBuffer (double oldNearZ, double oldFarZ, double newNearZ, double newFarZ)
void | Ortho (double xmin, double xmax, double ymin, double ymax, double znear, double zfar)
void | Frustum (double xmin, double xmax, double ymin, double ymax, double znear, double zfar)
void | SetupCamera (const double position[3], const double focalpoint[3], const double viewup[3])
void | Translate (double x, double y, double z)
void | Translate (const double x[3])
void | Translate (const float x[3])
void | RotateWXYZ (double angle, double x, double y, double z)
void | RotateWXYZ (double angle, const double axis[3])
void | RotateWXYZ (double angle, const float axis[3])
void | RotateX (double angle)
void | RotateY (double angle)
void | RotateZ (double angle)
void | Scale (double x, double y, double z)
void | Scale (const double s[3])
void | Scale (const float s[3])
void | SetMatrix (vtkMatrix4x4 *matrix)
void | SetMatrix (const double elements[16])
void | Concatenate (vtkMatrix4x4 *matrix)
void | Concatenate (const double elements[16])
void | PreMultiply ()
void | PostMultiply ()
int | GetNumberOfConcatenatedTransforms ()
vtkHomogeneousTransform * | GetConcatenatedTransform (int i)
void | SetInput (vtkHomogeneousTransform *input)
vtkHomogeneousTransform * GetInput ()
int | GetInverseFlag ()
void | Push ()
void | Pop ()

Static Public Methods

vtkPerspectiveTransform * | New ()

Protected Methods

vtkPerspectiveTransform ()
~vtkPerspectiveTransform ()
void | InternalDeepCopy (vtkAbstractTransform *t)
void | InternalUpdate ()

Protected Attributes

vtkHomogeneousTransform * Input
vtkTransformConcatenation * Concatenation
vtkTransformConcatenationStack * Stack

Detailed Description

describes a 4x4 matrix transformation.

Date:
2002/01/22 15:25:53
Revision:
1.28

A vtkPerspectiveTransform can be used to describe the full range of homogeneous transformations. It was designed in particular to describe a camera-view of a scene.

The order in which you set up the display coordinates (via AdjustZBuffer() and AdjustViewport()), the projection (via Perspective(), Frustum(), or Ortho()) and the camera view (via SetupCamera()) are important. If the transform is in PreMultiply mode, which is the default, set the Viewport and ZBuffer first, then the projection, and finally the camera view. Once the view is set up, the Translate and Rotate methods can be used to move the camera around in world coordinates. If the Oblique() or Stereo() methods are used, they should be called just before SetupCamera().

In PostMultiply mode, you must perform all transformations in the opposite order. This is necessary, for example, if you already have a perspective transformation set up but must adjust the viewport. Another example is if you have a view transformation, and wish to perform translations and rotations in the camera's coordinate system rather than in world coordinates.

The SetInput and Concatenate methods can be used to create a transformation pipeline with vtkPerspectiveTransform. See vtkTransform for more information on the transformation pipeline.

See also:
vtkGeneralTransform vtkTransform vtkMatrix4x4 vtkCamera
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (96%)
Tests:
vtkPerspectiveTransform (Tests)

Definition at line 62 of file vtkPerspectiveTransform.h.

Constructor & Destructor Documentation

vtkPerspectiveTransform::vtkPerspectiveTransform ( ) [protected]

vtkPerspectiveTransform::~vtkPerspectiveTransform ( ) [protected]

Member Function Documentation

vtkPerspectiveTransform* vtkPerspectiveTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPerspectiveTransform::vtkTypeRevisionMacro | ( | vtkPerspectiveTransform | ,
 |  | vtkHomogeneousTransform |
 | ) |

Reimplemented from vtkHomogeneousTransform.

void vtkPerspectiveTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkHomogeneousTransform.

void vtkPerspectiveTransform::Identity ( ) [inline]

Set this transformation to the identity transformation. If the transform has an Input, then the transformation will be reset so that it is the same as the Input.

Reimplemented from vtkAbstractTransform.

Definition at line 72 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Inverse ( ) [inline, virtual]

Invert the transformation. This will also set a flag so that the transformation will use the inverse of its Input, if an Input has been set.

Reimplemented from vtkAbstractTransform.

Definition at line 77 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::AdjustViewport | ( | double | oldXMin,
 |  | double | oldXMax,
 |  | double | oldYMin,
 |  | double | oldYMax,
 |  | double | newXMin,
 |  | double | newXMax,
 |  | double | newYMin,
 |  | double | newYMax
 | ) |

Perform an adjustment to the viewport coordinates. By default Ortho, Frustum, and Perspective provide a window of ([-1,+1],[-1,+1]). In PreMultiply mode, you call this method before calling Ortho, Frustum, or Perspective. In PostMultiply mode you can call it after. Note that if you must apply both AdjustZBuffer and AdjustViewport, it makes no difference which order you apply them in.

void vtkPerspectiveTransform::AdjustZBuffer | ( | double | oldNearZ,
 |  | double | oldFarZ,
 |  | double | newNearZ,
 |  | double | newFarZ
 | ) |

Perform an adjustment to the Z-Buffer range that the near and far clipping planes map to. By default Ortho, Frustum, and Perspective map the near clipping plane to -1 and the far clipping plane to +1. In PreMultiply mode, you call this method before calling Ortho, Frustum, or Perspective. In PostMultiply mode you can call it after.

void vtkPerspectiveTransform::Ortho | ( | double | xmin,
 |  | double | xmax,
 |  | double | ymin,
 |  | double | ymax,
 |  | double | znear,
 |  | double | zfar
 | ) |

Create an orthogonal projection matrix and concatenate it by the current transformation. The matrix maps [xmin,xmax], [ymin,ymax], [-znear,-zfar] to [-1,+1], [-1,+1], [+1,-1].

void vtkPerspectiveTransform::Frustum | ( | double | xmin,
 |  | double | xmax,
 |  | double | ymin,
 |  | double | ymax,
 |  | double | znear,
 |  | double | zfar
 | ) |

Create an perspective projection matrix and concatenate it by the current transformation. The matrix maps a frustum with a back plane at -zfar and a front plane at -znear with extent [xmin,xmax],[ymin,ymax] to [-1,+1], [-1,+1], [+1,-1].

void vtkPerspectiveTransform::Perspective | ( | double | angle,
 |  | double | aspect,
 |  | double | znear,
 |  | double | zfar
 | ) |

Create a perspective projection matrix by specifying the view angle (this angle is in the y direction), the aspect ratio, and the near and far clipping range. The projection matrix is concatenated with the current transformation. This method works via Frustum.

void vtkPerspectiveTransform::Shear | ( | double | dxdz,
 |  | double | dydz,
 |  | double | zplane
 | ) |

Create a shear transformation about a plane at distance z from the camera. The values dxdz (i.e. dx/dz) and dydz specify the amount of shear in the x and y directions. The 'zplane' specifies the distance from the camera to the plane at which the shear causes zero displacement. Generally you want this plane to be the focal plane. This transformation can be used in combination with Ortho to create an oblique projection. It can also be used in combination with Perspective to provide correct stereo views when the eye is at arbitrary but known positions relative to the center of a flat viewing screen.

void vtkPerspectiveTransform::Stereo | ( | double | angle,
 |  | double | focaldistance
 | ) |

Create a stereo shear matrix and concatenate it with the current transformation. This can be applied in conjunction with either a perspective transformation (via Frustum or Projection) or an orthographic projection. You must specify the distance from the camera plane to the focal plane, and the angle between the distance vector and the eye. The angle should be negative for the left eye, and positive for the right. This method works via Oblique.

void vtkPerspectiveTransform::SetupCamera | ( | const double | position[3],
 |  | const double | focalpoint[3],
 |  | const double | viewup[3]
 | ) |

Set a view transformation matrix for the camera (this matrix does not contain any perspective) and concatenate it with the current transformation.

void vtkPerspectiveTransform::Translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 157 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Translate ( const double x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 159 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Translate ( const float x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 160 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateWXYZ | ( | double | angle,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 168 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateWXYZ | ( | double | angle,
 |  | const double | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 170 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateWXYZ | ( | double | angle,
 |  | const float | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 172 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateX ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 180 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateY ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 181 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::RotateZ ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 182 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Scale | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 189 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Scale ( const double s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 191 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Scale ( const float s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 192 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::SetMatrix ( vtkMatrix4x4 * matrix ) [inline]

Set the current matrix directly. This actually calls Identity(), followed by Concatenate(matrix).

Definition at line 198 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::SetMatrix ( const double elements[16] ) [inline]

Set the current matrix directly. This actually calls Identity(), followed by Concatenate(matrix).

Definition at line 200 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Concatenate ( vtkMatrix4x4 * matrix ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 207 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Concatenate ( const double elements[16] ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 209 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Concatenate ( vtkHomogeneousTransform * transform )

Concatenate the specified transform with the current transformation according to PreMultiply or PostMultiply semantics. The concatenation is pipelined, meaning that if any of the transformations are changed, even after Concatenate() is called, those changes will be reflected when you call TransformPoint().

void vtkPerspectiveTransform::PreMultiply ( ) [inline]

Sets the internal state of the transform to PreMultiply. All subsequent operations will occur before those already represented in the current transformation. In homogeneous matrix notation, M = M*A where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 226 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::PostMultiply ( ) [inline]

Sets the internal state of the transform to PostMultiply. All subsequent operations will occur after those already represented in the current transformation. In homogeneous matrix notation, M = A*M where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 237 of file vtkPerspectiveTransform.h.

int vtkPerspectiveTransform::GetNumberOfConcatenatedTransforms ( ) [inline]

Get the total number of transformations that are linked into this one via Concatenate() operations or via SetInput().

Definition at line 245 of file vtkPerspectiveTransform.h.

vtkHomogeneousTransform* vtkPerspectiveTransform::GetConcatenatedTransform ( int i ) [inline]

Get one of the concatenated transformations as a vtkAbstractTransform. These transformations are applied, in series, every time the transformation of a coordinate occurs. This method is provided to make it possible to decompose a transformation into its constituents, for example to save a transformation to a file.

Definition at line 256 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::SetInput ( vtkHomogeneousTransform * input )

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

vtkHomogeneousTransform* vtkPerspectiveTransform::GetInput ( ) [inline]

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

Definition at line 277 of file vtkPerspectiveTransform.h.

int vtkPerspectiveTransform::GetInverseFlag ( ) [inline]

Get the inverse flag of the transformation. This controls whether it is the Input or the inverse of the Input that is used as the base transformation. The InverseFlag is flipped every time Inverse() is called. The InverseFlag is off when a transform is first created.

Definition at line 285 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Push ( ) [inline]

Pushes the current transformation onto the transformation stack.

Definition at line 291 of file vtkPerspectiveTransform.h.

void vtkPerspectiveTransform::Pop ( ) [inline]

Deletes the transformation on the top of the stack and sets the top to the next transformation on the stack.

Definition at line 300 of file vtkPerspectiveTransform.h.

vtkAbstractTransform* vtkPerspectiveTransform::MakeTransform ( ) [virtual]

Make a new transform of the same type -- you are responsible for deleting the transform when you are done with it.

Reimplemented from vtkAbstractTransform.

int vtkPerspectiveTransform::CircuitCheck ( vtkAbstractTransform * transform ) [virtual]

Check for self-reference. Will return true if concatenating with the specified transform, setting it to be our inverse, or setting it to be our input will create a circular reference. CircuitCheck is automatically called by SetInput(), SetInverse(), and Concatenate(vtkXTransform *). Avoid using this function, it is experimental.

Reimplemented from vtkAbstractTransform.

unsigned long vtkPerspectiveTransform::GetMTime ( ) [virtual]

Override GetMTime to account for input and concatenation.

Reimplemented from vtkAbstractTransform.

void vtkPerspectiveTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkHomogeneousTransform.

void vtkPerspectiveTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

Member Data Documentation

vtkHomogeneousTransform* vtkPerspectiveTransform::Input [protected]

Definition at line 327 of file vtkPerspectiveTransform.h.

vtkTransformConcatenation* vtkPerspectiveTransform::Concatenation [protected]

Definition at line 328 of file vtkPerspectiveTransform.h.

vtkTransformConcatenationStack* vtkPerspectiveTransform::Stack [protected]

Definition at line 329 of file vtkPerspectiveTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkPerspectiveTransform.h
Generated on Mon Mar 25 01:27:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPicker Class Reference

superclass for 3D geometric pickers (uses ray cast). More...

#include <vtkPicker.h>

Inheritance diagram for vtkPicker:

[legend]
Collaboration diagram for vtkPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPicker, vtkAbstractPropPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkProp3DCollection * GetProp3Ds ()
vtkPoints * GetPickedPositions ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()
virtual float * | GetMapperPosition ()
virtual void | GetMapperPosition (float data[3])
virtual vtkAbstractMapper3D * | GetMapper ()
virtual vtkDataSet * | GetDataSet ()
vtkActorCollection * GetActors ()
virtual int | Pick (float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)
int | Pick (float selectionPt[3], vtkRenderer *ren)

Static Public Methods

vtkPicker * | New ()

Protected Methods

vtkPicker ()
~vtkPicker ()
void | MarkPicked (vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m, float tMin, float mapperPos[3])
virtual float | IntersectWithLine (float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m)
virtual void | Initialize ()

Protected Attributes

float | Tolerance
float | MapperPosition [3]
vtkAbstractMapper3D * Mapper
vtkDataSet * DataSet
float | GlobalTMin
vtkTransform * Transform
vtkActorCollection * Actors
vtkProp3DCollection * Prop3Ds
vtkPoints * PickedPositions

Detailed Description

superclass for 3D geometric pickers (uses ray cast).

Date:
2002/01/22 15:39:04
Revision:
1.47

vtkPicker is used to select instances of vtkProp3D by shooting a ray into a graphics window and intersecting with the actor's bounding box. The ray is defined from a point defined in window (or pixel) coordinates, and a point located from the camera's position.

vtkPicker may return more than one vtkProp3D, since more than one bounding box may be intersected. vtkPicker returns the list of props that were hit, the pick coordinates in world and untransformed mapper space, and the prop (vtkProp3D) and mapper that are "closest" to the camera. The closest prop is the one whose center point (i.e., center of bounding box) projected on the ray is closest to the camera.

See also:
vtkPicker is used for quick geometric picking. If you desire to pick points or cells, use the subclass vtkPointPicker or vtkCellPicker, respectively. Or you may use hardware picking to pick any type of vtkProp
  • see vtkPropPicker or vtkWorldPointPicker.
Events:
vtkCommand::EndPickEvent vtkCommand::StartPickEvent vtkCommand::PickEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Martin, Ken (9%)
  • Lorensen, Bill (7%)

Definition at line 64 of file vtkPicker.h.

Constructor & Destructor Documentation

vtkPicker::vtkPicker ( ) [protected]

vtkPicker::~vtkPicker ( ) [protected]

Member Function Documentation

vtkPicker* vtkPicker::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkCellPicker, and vtkPointPicker.

vtkPicker::vtkTypeRevisionMacro | ( | vtkPicker | ,
 |  | vtkAbstractPropPicker |
 | ) |

Reimplemented from vtkAbstractPropPicker.

Reimplemented in vtkCellPicker, and vtkPointPicker.

void vtkPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractPropPicker.

Reimplemented in vtkCellPicker, and vtkPointPicker.

virtual void vtkPicker::SetTolerance ( float ) [virtual]

Specify tolerance for performing pick operation. Tolerance is specified as fraction of rendering window size. (Rendering window size is measured across diagonal.)

virtual float vtkPicker::GetTolerance ( ) [virtual]

Specify tolerance for performing pick operation. Tolerance is specified as fraction of rendering window size. (Rendering window size is measured across diagonal.)

virtual float* vtkPicker::GetMapperPosition ( ) [virtual]

Return position in mapper (i.e., non-transformed) coordinates of pick point.

virtual void vtkPicker::GetMapperPosition ( float data[3] ) [virtual]

Return position in mapper (i.e., non-transformed) coordinates of pick point.

virtual vtkAbstractMapper3D* vtkPicker::GetMapper ( void ) [virtual]

Return mapper that was picked (if any).

virtual vtkDataSet* vtkPicker::GetDataSet ( ) [virtual]

Get a pointer to the dataset that was picked (if any). If nothing was picked then NULL is returned.

vtkProp3DCollection* vtkPicker::GetProp3Ds ( ) [inline]

Return a collection of all the prop 3D's that were intersected by the pick ray. This collection is not sorted.

Definition at line 98 of file vtkPicker.h.

vtkActorCollection* vtkPicker::GetActors ( ) [inline]

Return a collection of all the actors that were intersected. This collection is not sorted. (This is a convenience method to maintain backward compatibility.)

Definition at line 104 of file vtkPicker.h.

vtkPoints* vtkPicker::GetPickedPositions ( ) [inline]

Return a list of the points the the actors returned by GetActors were intersected at. The order of this list will match the order of GetActors.

Definition at line 114 of file vtkPicker.h.

virtual int vtkPicker::Pick | ( | float | selectionX,
 |  | float | selectionY,
 |  | float | selectionZ,
 |  | vtkRenderer * | renderer
 | ) | [virtual]

Perform pick operation with selection point provided. Normally the first two values for the selection point are x-y pixel coordinate, and the third value is =0. Return non-zero if something was successfully picked.

Reimplemented from vtkAbstractPicker.

int vtkPicker::Pick | ( | float | selectionPt[3],
 |  | vtkRenderer * | ren
 | ) | [inline]

Perform pick operation with selection point provided. Normally the first two values for the selection point are x-y pixel coordinate, and the third value is =0. Return non-zero if something was successfully picked.

Reimplemented from vtkAbstractPicker.

Definition at line 130 of file vtkPicker.h.

void vtkPicker::MarkPicked | ( | vtkAssemblyPath * | path,
 |  | vtkProp3D * | p,
 |  | vtkAbstractMapper3D * | m,
 |  | float | tMin,
 |  | float | mapperPos[3]
 | ) | [protected]

virtual float vtkPicker::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | vtkAssemblyPath * | path,
 |  | vtkProp3D * | p,
 |  | vtkAbstractMapper3D * | m
 | ) | [protected, virtual]

Reimplemented in vtkCellPicker, and vtkPointPicker.

virtual void vtkPicker::Initialize ( ) [protected, virtual]

Reimplemented from vtkAbstractPropPicker.

Reimplemented in vtkCellPicker, and vtkPointPicker.

Member Data Documentation

float vtkPicker::Tolerance [protected]

Definition at line 145 of file vtkPicker.h.

float vtkPicker::MapperPosition[3] [protected]

Definition at line 146 of file vtkPicker.h.

vtkAbstractMapper3D* vtkPicker::Mapper [protected]

Definition at line 148 of file vtkPicker.h.

vtkDataSet* vtkPicker::DataSet [protected]

Definition at line 149 of file vtkPicker.h.

float vtkPicker::GlobalTMin [protected]

Definition at line 151 of file vtkPicker.h.

vtkTransform* vtkPicker::Transform [protected]

Definition at line 152 of file vtkPicker.h.

vtkActorCollection* vtkPicker::Actors [protected]

Definition at line 153 of file vtkPicker.h.

vtkProp3DCollection* vtkPicker::Prop3Ds [protected]

Definition at line 154 of file vtkPicker.h.

vtkPoints* vtkPicker::PickedPositions [protected]

Definition at line 155 of file vtkPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkPicker.h
Generated on Mon Mar 25 01:27:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPieceScalars Class Reference

Sets all cell scalars from the update piece. More...

#include <vtkPieceScalars.h>

Inheritance diagram for vtkPieceScalars:

[legend]
Collaboration diagram for vtkPieceScalars:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPieceScalars, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRandomMode (int)
virtual int | GetRandomMode ()
virtual void | RandomModeOn ()
virtual void | RandomModeOff ()
void | SetScalarModeToCellData ()
void | SetScalarModeToPointData ()
int | GetScalarMode ()

Static Public Methods

vtkPieceScalars * | New ()

Protected Methods

vtkPieceScalars ()
~vtkPieceScalars ()
void | Execute ()
vtkIntArray * | MakePieceScalars (int piece, vtkIdType numScalars)
vtkFloatArray * | MakeRandomScalars (int piece, vtkIdType numScalars)
virtual void | SetCellScalarsFlag (int)

Protected Attributes

int | CellScalarsFlag
int | RandomMode

Detailed Description

Sets all cell scalars from the update piece.

Date:
2002/01/22 15:34:53
Revision:
1.10

vtkPieceScalars is meant to display which piece is being requested as scalar values. It is usefull for visualizing the partioning for streaming or distributed pipelines.

See also:
vtkPolyDataStreamer
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (56%)
  • Law, Charles (35%)
  • Henderson, Amy (6%)
Tests:
vtkPieceScalars (Tests)

Definition at line 45 of file vtkPieceScalars.h.

Constructor & Destructor Documentation

vtkPieceScalars::vtkPieceScalars ( ) [protected]

vtkPieceScalars::~vtkPieceScalars ( ) [protected]

Member Function Documentation

vtkPieceScalars* vtkPieceScalars::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkPieceScalars::vtkTypeRevisionMacro | ( | vtkPieceScalars | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkPieceScalars::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkPieceScalars::SetScalarModeToCellData ( ) [inline]

Option to centerate cell scalars of poi9nts scalars. Default is point scalars.

Definition at line 56 of file vtkPieceScalars.h.

void vtkPieceScalars::SetScalarModeToPointData ( ) [inline]

Option to centerate cell scalars of poi9nts scalars. Default is point scalars.

Definition at line 57 of file vtkPieceScalars.h.

int vtkPieceScalars::GetScalarMode ( ) [inline]

Option to centerate cell scalars of poi9nts scalars. Default is point scalars.

Definition at line 58 of file vtkPieceScalars.h.

virtual void vtkPieceScalars::SetRandomMode ( int ) [virtual]

virtual int vtkPieceScalars::GetRandomMode ( ) [virtual]

virtual void vtkPieceScalars::RandomModeOn ( ) [virtual]

virtual void vtkPieceScalars::RandomModeOff ( ) [virtual]

void vtkPieceScalars::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

vtkIntArray* vtkPieceScalars::MakePieceScalars | ( | int | piece,
 |  | vtkIdType | numScalars
 | ) | [protected]

vtkFloatArray* vtkPieceScalars::MakeRandomScalars | ( | int | piece,
 |  | vtkIdType | numScalars
 | ) | [protected]

virtual void vtkPieceScalars::SetCellScalarsFlag ( int ) [protected, virtual]

Member Data Documentation

int vtkPieceScalars::CellScalarsFlag [protected]

Definition at line 79 of file vtkPieceScalars.h.

int vtkPieceScalars::RandomMode [protected]

Definition at line 80 of file vtkPieceScalars.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPieceScalars.h
Generated on Mon Mar 25 01:27:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunction Class Reference

Defines a 1D piecewise function. More...

#include <vtkPiecewiseFunction.h>

Inheritance diagram for vtkPiecewiseFunction:

[legend]
Collaboration diagram for vtkPiecewiseFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPiecewiseFunction, vtkDataObject)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * MakeObject ()
void | Initialize ()
void | DeepCopy (vtkDataObject *f)
void | ShallowCopy (vtkDataObject *f)
int | GetDataObjectType ()
int | GetSize ()
void | RemoveAllPoints ()
void | AddSegment (float x1, float val1, float x2, float val2)
float | GetValue (float x)
float * | GetDataPointer ()
float * | GetRange ()
void | GetTable (float x1, float x2, int size, float *table, int stride=1)
const char * | GetType ()
unsigned long | GetMTime ()
float | GetFirstNonZeroValue ()
void | AddPoint (float x, float val)
void | RemovePoint (float x)
void | BuildFunctionFromTable (float x1, float x2, int size, float *table, int stride=1)
virtual void | SetClamping (int)
virtual int | GetClamping ()
virtual void | ClampingOn ()
virtual void | ClampingOff ()

Static Public Methods

vtkPiecewiseFunction * | New ()

Protected Methods

vtkPiecewiseFunction ()
~vtkPiecewiseFunction ()
void | IncreaseArraySize ()
int | InsertPoint (float x, float val)
void | MovePoints (int index, int down)

Protected Attributes

int | ArraySize
int | Clamping
float * | Function
int | FunctionSize
float | FunctionRange [2]

Detailed Description

Defines a 1D piecewise function.

Date:
2002/01/22 15:28:09
Revision:
1.30

Defines a piecewise linear function mapping. Used for transfer functions in volume rendering.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (57%)
  • Avila, Lisa (14%)
  • Miller, Jim (13%)
  • Martin, Ken (8%)
Examples:
vtkPiecewiseFunction (Examples)
Tests:
vtkPiecewiseFunction (Tests)

Definition at line 48 of file vtkPiecewiseFunction.h.

Constructor & Destructor Documentation

vtkPiecewiseFunction::vtkPiecewiseFunction ( ) [protected]

vtkPiecewiseFunction::~vtkPiecewiseFunction ( ) [protected]

Member Function Documentation

vtkPiecewiseFunction* vtkPiecewiseFunction::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

vtkPiecewiseFunction::vtkTypeRevisionMacro | ( | vtkPiecewiseFunction | ,
 |  | vtkDataObject |
 | ) |

Reimplemented from vtkDataObject.

void vtkPiecewiseFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataObject.

vtkDataObject* vtkPiecewiseFunction::MakeObject ( ) [virtual]

Create concrete instance of this data object.

Reimplemented from vtkDataObject.

void vtkPiecewiseFunction::Initialize ( ) [virtual]

Reimplemented from vtkDataObject.

void vtkPiecewiseFunction::DeepCopy ( vtkDataObject * f ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented from vtkDataObject.

void vtkPiecewiseFunction::ShallowCopy ( vtkDataObject * f ) [virtual]

Shallow and Deep copy. These copy the data, but not any of the pipeline connections.

Reimplemented from vtkDataObject.

int vtkPiecewiseFunction::GetDataObjectType ( ) [inline, virtual]

Return what type of dataset this is.

Reimplemented from vtkDataObject.

Definition at line 61 of file vtkPiecewiseFunction.h.

int vtkPiecewiseFunction::GetSize ( )

Get the number of points used to specify the function

void vtkPiecewiseFunction::AddPoint | ( | float | x,
 |  | float | val
 | ) |

Add/Remove points to/from the function. If a duplicate point is added then the function value is changed at that location.

void vtkPiecewiseFunction::RemovePoint ( float x )

Add/Remove points to/from the function. If a duplicate point is added then the function value is changed at that location.

void vtkPiecewiseFunction::RemoveAllPoints ( )

Removes all points from the function.

void vtkPiecewiseFunction::AddSegment | ( | float | x1,
 |  | float | val1,
 |  | float | x2,
 |  | float | val2
 | ) |

Add a line segment to the function. All points defined between the two points specified are removed from the function.

float vtkPiecewiseFunction::GetValue ( float x )

Returns the value of the function at the specified location using the specified interpolation. Returns zero if the specified location is outside the min and max points of the function.

float* vtkPiecewiseFunction::GetDataPointer ( ) [inline]

Returns a pointer to the data stored in the table.

Definition at line 86 of file vtkPiecewiseFunction.h.

float* vtkPiecewiseFunction::GetRange ( )

Returns the min and max point locations of the function.

void vtkPiecewiseFunction::GetTable | ( | float | x1,
 |  | float | x2,
 |  | int | size,
 |  | float * | table,
 |  | int | stride = 1
 | ) |

Fills in an array of function values evaluated at regular intervals. Parameter "stride" is used to step through the output "table". It is used by vtkColorTransferFunction to fill in an rgb table using three separate piecewise functions and three separate calls to GetTable().

void vtkPiecewiseFunction::BuildFunctionFromTable | ( | float | x1,
 |  | float | x2,
 |  | int | size,
 |  | float * | table,
 |  | int | stride = 1
 | ) |

Constructs a piecewise function from a table. Function range is is set to [x1, x2], function size is set to size, and function points are regularly spaced between x1 and x2. Parameter "stride" is is step through the input table. It is used by vtkColorTransferFunction to construct 3 piecewise functions from an rgb table.

virtual void vtkPiecewiseFunction::SetClamping ( int ) [virtual]

When zero range clamping is Off, GetValue() returns 0.0 when a value is requested outside of the points specified. When zero range clamping is On, GetValue() returns the value at the value at the lowest point for a request below all points specified and returns the value at the highest point for a request above all points specified. On is the default.

virtual int vtkPiecewiseFunction::GetClamping ( ) [virtual]

When zero range clamping is Off, GetValue() returns 0.0 when a value is requested outside of the points specified. When zero range clamping is On, GetValue() returns the value at the value at the lowest point for a request below all points specified and returns the value at the highest point for a request above all points specified. On is the default.

virtual void vtkPiecewiseFunction::ClampingOn ( ) [virtual]

When zero range clamping is Off, GetValue() returns 0.0 when a value is requested outside of the points specified. When zero range clamping is On, GetValue() returns the value at the value at the lowest point for a request below all points specified and returns the value at the highest point for a request above all points specified. On is the default.

virtual void vtkPiecewiseFunction::ClampingOff ( ) [virtual]

When zero range clamping is Off, GetValue() returns 0.0 when a value is requested outside of the points specified. When zero range clamping is On, GetValue() returns the value at the value at the lowest point for a request below all points specified and returns the value at the highest point for a request above all points specified. On is the default.

const char* vtkPiecewiseFunction::GetType ( )

Return the type of function: Function Types: 0 : Constant (No change in slope between end points) 1 : NonDecreasing (Always increasing or zero slope) 2 : NonIncreasing (Always decreasing or zero slope) 3 : Varied (Contains both decreasing and increasing slopes)

unsigned long vtkPiecewiseFunction::GetMTime ( ) [virtual]

Get the mtime of this object - override to consider the mtime of the source as well.

Reimplemented from vtkDataObject.

float vtkPiecewiseFunction::GetFirstNonZeroValue ( )

Returns the first point location which precedes a non-zero segment of the function. Note that the value at this point may be zero.

void vtkPiecewiseFunction::IncreaseArraySize ( ) [protected]

int vtkPiecewiseFunction::InsertPoint | ( | float | x,
 |  | float | val
 | ) | [protected]

void vtkPiecewiseFunction::MovePoints | ( | int | index,
 |  | int | down
 | ) | [protected]

Member Data Documentation

int vtkPiecewiseFunction::ArraySize [protected]

Definition at line 139 of file vtkPiecewiseFunction.h.

int vtkPiecewiseFunction::Clamping [protected]

Definition at line 145 of file vtkPiecewiseFunction.h.

float* vtkPiecewiseFunction::Function [protected]

Definition at line 148 of file vtkPiecewiseFunction.h.

int vtkPiecewiseFunction::FunctionSize [protected]

Definition at line 151 of file vtkPiecewiseFunction.h.

float vtkPiecewiseFunction::FunctionRange[2] [protected]

Definition at line 154 of file vtkPiecewiseFunction.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkPiecewiseFunction.h
Generated on Mon Mar 25 01:27:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionShiftScale Class Reference

#include <vtkPiecewiseFunctionShiftScale.h>

Inheritance diagram for vtkPiecewiseFunctionShiftScale:

[legend]
Collaboration diagram for vtkPiecewiseFunctionShiftScale:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionToPiecewiseFunctionFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPositionShift (float)
virtual void | SetPositionScale (float)
virtual void | SetValueShift (float)
virtual void | SetValueScale (float)
virtual float | GetPositionShift ()
virtual float | GetPositionScale ()
virtual float | GetValueShift ()
virtual float | GetValueScale ()

Static Public Methods

vtkPiecewiseFunctionShiftScale * | New ()

Protected Methods

vtkPiecewiseFunctionShiftScale ()
~vtkPiecewiseFunctionShiftScale ()
void | Execute ()

Protected Attributes

vtkPiecewiseFunction * Input
float | PositionShift
float | PositionScale
float | ValueShift
float | ValueScale

Detailed Description

Date:
2002/02/22 15:08:47
Revision:
1.2
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (100%)

Definition at line 37 of file vtkPiecewiseFunctionShiftScale.h.

Constructor & Destructor Documentation

vtkPiecewiseFunctionShiftScale::vtkPiecewiseFunctionShiftScale ( ) [protected]

vtkPiecewiseFunctionShiftScale::~vtkPiecewiseFunctionShiftScale ( ) [protected]

Member Function Documentation

vtkPiecewiseFunctionShiftScale* vtkPiecewiseFunctionShiftScale::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPiecewiseFunctionSource.

vtkPiecewiseFunctionShiftScale::vtkTypeRevisionMacro | ( | vtkPiecewiseFunctionShiftScale | ,
 |  | vtkPiecewiseFunctionToPiecewiseFunctionFilter |
 | ) |

Reimplemented from vtkPiecewiseFunctionToPiecewiseFunctionFilter.

void vtkPiecewiseFunctionShiftScale::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkPiecewiseFunctionShiftScale::SetPositionShift ( float ) [virtual]

virtual void vtkPiecewiseFunctionShiftScale::SetPositionScale ( float ) [virtual]

virtual void vtkPiecewiseFunctionShiftScale::SetValueShift ( float ) [virtual]

virtual void vtkPiecewiseFunctionShiftScale::SetValueScale ( float ) [virtual]

virtual float vtkPiecewiseFunctionShiftScale::GetPositionShift ( ) [virtual]

virtual float vtkPiecewiseFunctionShiftScale::GetPositionScale ( ) [virtual]

virtual float vtkPiecewiseFunctionShiftScale::GetValueShift ( ) [virtual]

virtual float vtkPiecewiseFunctionShiftScale::GetValueScale ( ) [virtual]

void vtkPiecewiseFunctionShiftScale::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkPiecewiseFunction* vtkPiecewiseFunctionShiftScale::Input [protected]

Definition at line 60 of file vtkPiecewiseFunctionShiftScale.h.

float vtkPiecewiseFunctionShiftScale::PositionShift [protected]

Definition at line 62 of file vtkPiecewiseFunctionShiftScale.h.

float vtkPiecewiseFunctionShiftScale::PositionScale [protected]

Definition at line 63 of file vtkPiecewiseFunctionShiftScale.h.

float vtkPiecewiseFunctionShiftScale::ValueShift [protected]

Definition at line 64 of file vtkPiecewiseFunctionShiftScale.h.

float vtkPiecewiseFunctionShiftScale::ValueScale [protected]

Definition at line 65 of file vtkPiecewiseFunctionShiftScale.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkPiecewiseFunctionShiftScale.h
Generated on Mon Mar 25 01:27:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionSource Class Reference

abstract class whose subclasses generate piecewise functions. More...

#include <vtkPiecewiseFunctionSource.h>

Inheritance diagram for vtkPiecewiseFunctionSource:

[legend]
Collaboration diagram for vtkPiecewiseFunctionSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPiecewiseFunctionSource, vtkSource)
vtkPiecewiseFunction * GetOutput ()
vtkPiecewiseFunction * | GetOutput (int idx)
void | SetOutput (vtkPiecewiseFunction *output)

Static Public Methods

vtkPiecewiseFunctionSource * | New ()

Protected Methods

vtkPiecewiseFunctionSource ()
~vtkPiecewiseFunctionSource ()

Detailed Description

abstract class whose subclasses generate piecewise functions.

Date:
2002/02/15 16:19:51
Revision:
1.1

vtkPiecewiseFunctionSource is an abstract class whose subclasses generate piecewise functions

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (100%)

Definition at line 38 of file vtkPiecewiseFunctionSource.h.

Constructor & Destructor Documentation

vtkPiecewiseFunctionSource::vtkPiecewiseFunctionSource ( ) [protected]

vtkPiecewiseFunctionSource::~vtkPiecewiseFunctionSource ( ) [inline, protected]

Definition at line 54 of file vtkPiecewiseFunctionSource.h.

Member Function Documentation

vtkPiecewiseFunctionSource* vtkPiecewiseFunctionSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkPiecewiseFunctionShiftScale.

vtkPiecewiseFunctionSource::vtkTypeRevisionMacro | ( | vtkPiecewiseFunctionSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkPiecewiseFunctionShiftScale, and vtkPiecewiseFunctionToPiecewiseFunctionFilter.

vtkPiecewiseFunction* vtkPiecewiseFunctionSource::GetOutput ( )

Get the output of this source.

vtkPiecewiseFunction* vtkPiecewiseFunctionSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Definition at line 47 of file vtkPiecewiseFunctionSource.h.

void vtkPiecewiseFunctionSource::SetOutput ( vtkPiecewiseFunction * output )

Get the output of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkPiecewiseFunctionSource.h
Generated on Mon Mar 25 01:27:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPiecewiseFunctionToPiecewiseFunctionFilter Class Reference

abstract filter class. More...

#include <vtkPiecewiseFunctionToPiecewiseFunctionFilter.h>

Inheritance diagram for vtkPiecewiseFunctionToPiecewiseFunctionFilter:

[legend]
Collaboration diagram for vtkPiecewiseFunctionToPiecewiseFunctionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkPiecewiseFunctionSource)
virtual void SetInput (vtkPiecewiseFunction *input)
vtkPiecewiseFunction * GetInput ()

Protected Methods

vtkPiecewiseFunctionToPiecewiseFunctionFilter ()
~vtkPiecewiseFunctionToPiecewiseFunctionFilter ()

Detailed Description

abstract filter class.

Date:
2002/02/15 16:19:52
Revision:
1.1

vtkPiecewiseFunctionToPiecewiseFunctionFilter is an abstract filter class whose subclasses take as input a piecewise function and generate a piecewise function on output.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (100%)

Definition at line 39 of file vtkPiecewiseFunctionToPiecewiseFunctionFilter.h.

Constructor & Destructor Documentation

vtkPiecewiseFunctionToPiecewiseFunctionFilter::vtkPiecewiseFunctionToPiecewiseFunctionFilter ( ) [protected]

vtkPiecewiseFunctionToPiecewiseFunctionFilter::~vtkPiecewiseFunctionToPiecewiseFunctionFilter ( ) [inline, protected]

Definition at line 52 of file vtkPiecewiseFunctionToPiecewiseFunctionFilter.h.

Member Function Documentation

vtkPiecewiseFunctionToPiecewiseFunctionFilter::vtkTypeRevisionMacro | ( | vtkPiecewiseFunctionToPiecewiseFunctionFilter | ,
 |  | vtkPiecewiseFunctionSource |
 | ) |

Reimplemented from vtkPiecewiseFunctionSource.

Reimplemented in vtkPiecewiseFunctionShiftScale.

virtual void vtkPiecewiseFunctionToPiecewiseFunctionFilter::SetInput ( vtkPiecewiseFunction * input ) [virtual]

Set / get the input data or filter.

vtkPiecewiseFunction* vtkPiecewiseFunctionToPiecewiseFunctionFilter::GetInput ( )

Set / get the input data or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkPiecewiseFunctionToPiecewiseFunctionFilter.h
Generated on Mon Mar 25 01:27:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPImageWriter Class Reference

#include <vtkPImageWriter.h>

Inheritance diagram for vtkPImageWriter:

[legend]
Collaboration diagram for vtkPImageWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPImageWriter, vtkImageWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMemoryLimit (unsigned long)
virtual unsigned long | GetMemoryLimit ()

Static Public Methods

vtkPImageWriter * | New ()

Protected Methods

vtkPImageWriter ()
~vtkPImageWriter ()
virtual void | RecursiveWrite (int dim, vtkImageData *region, ofstream *file)
virtual void | RecursiveWrite (int dim, vtkImageData *cache, vtkImageData *data, ofstream *file)

Protected Attributes

unsigned long | MemoryLimit
vtkPipelineSize * SizeEstimator

Constructor & Destructor Documentation

vtkPImageWriter::vtkPImageWriter ( ) [protected]

vtkPImageWriter::~vtkPImageWriter ( ) [protected]

Member Function Documentation

vtkPImageWriter* vtkPImageWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkPImageWriter::vtkTypeRevisionMacro | ( | vtkPImageWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

void vtkPImageWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWriter.

virtual void vtkPImageWriter::SetMemoryLimit ( unsigned long ) [virtual]

Set / Get the memory limit in kilobytes. The writer will stream to attempt to keep the pipeline size within this limit

virtual unsigned long vtkPImageWriter::GetMemoryLimit ( ) [virtual]

Set / Get the memory limit in kilobytes. The writer will stream to attempt to keep the pipeline size within this limit

virtual void vtkPImageWriter::RecursiveWrite | ( | int | dim,
 |  | vtkImageData * | region,
 |  | ofstream * | file
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkPImageWriter::RecursiveWrite | ( | int | dim,
 |  | vtkImageData * | cache,
 |  | vtkImageData * | data,
 |  | ofstream * | file
 | ) | [inline, protected, virtual]

Reimplemented from vtkImageWriter.

Definition at line 63 of file vtkPImageWriter.h.

Member Data Documentation

unsigned long vtkPImageWriter::MemoryLimit [protected]

Definition at line 60 of file vtkPImageWriter.h.

vtkPipelineSize* vtkPImageWriter::SizeEstimator [protected]

Definition at line 67 of file vtkPImageWriter.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPImageWriter.h
Generated on Mon Mar 25 01:27:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPipelineSize Class Reference

compute the memory required by a pipeline. More...

#include <vtkPipelineSize.h>

Inheritance diagram for vtkPipelineSize:

[legend]
Collaboration diagram for vtkPipelineSize:

[legend]
List of all members.

[NOHEADER]

vtkTypeRevisionMacro (vtkPipelineSize, vtkObject)
vtkPipelineSize * | New ()

Public Methods

unsigned long | GetEstimatedSize (vtkDataObject *input)
unsigned long | GetNumberOfSubPieces (unsigned long memoryLimit, vtkPolyDataMapper *mapper)

Protected Methods

vtkPipelineSize ()
void | GenericComputeSourcePipelineSize (vtkSource *src, vtkDataObject *output, unsigned long size[3])
void | ComputeSourcePipelineSize (vtkSource *src, vtkDataObject *output, unsigned long size[3])
void | ComputeOutputMemorySize (vtkSource *src, vtkDataObject *output, unsigned long *inputSize, unsigned long size[2])
void | GenericComputeOutputMemorySize (vtkSource *src, vtkDataObject *output, unsigned long *inputSize, unsigned long size[2])
void | ComputeDataPipelineSize (vtkDataObject *input, unsigned long sizes[3])

Detailed Description

compute the memory required by a pipeline.

Date:
2002/01/22 15:34:54
Revision:
1.7
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (96%)
Tests:
vtkPipelineSize (Tests)

Definition at line 40 of file vtkPipelineSize.h.

Constructor & Destructor Documentation

vtkPipelineSize::vtkPipelineSize ( ) [inline, protected]

Definition at line 63 of file vtkPipelineSize.h.

Member Function Documentation

vtkPipelineSize* vtkPipelineSize::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPipelineSize::vtkTypeRevisionMacro | ( | vtkPipelineSize | ,
 |  | vtkObject |
 | ) |

unsigned long vtkPipelineSize::GetEstimatedSize ( vtkDataObject * input )

Compute an estimate of how much memory a pipline will require in kilobytes (1024 bytes not 1000) This is only an estimate and the calculations in here do not take into account the specifics of many sources and filters.

unsigned long vtkPipelineSize::GetNumberOfSubPieces | ( | unsigned long | memoryLimit,
 |  | vtkPolyDataMapper * | mapper
 | ) |

Determine how many subpieces a mapper should use to fit a target memory limit. This takes into account the mapper's Piece and NumberOfPieces.

void vtkPipelineSize::GenericComputeSourcePipelineSize | ( | vtkSource * | src,
 |  | vtkDataObject * | output,
 |  | unsigned long | size[3]
 | ) | [protected]

void vtkPipelineSize::ComputeSourcePipelineSize | ( | vtkSource * | src,
 |  | vtkDataObject * | output,
 |  | unsigned long | size[3]
 | ) | [protected]

void vtkPipelineSize::ComputeOutputMemorySize | ( | vtkSource * | src,
 |  | vtkDataObject * | output,
 |  | unsigned long * | inputSize,
 |  | unsigned long | size[2]
 | ) | [protected]

void vtkPipelineSize::GenericComputeOutputMemorySize | ( | vtkSource * | src,
 |  | vtkDataObject * | output,
 |  | unsigned long * | inputSize,
 |  | unsigned long | size[2]
 | ) | [protected]

void vtkPipelineSize::ComputeDataPipelineSize | ( | vtkDataObject * | input,
 |  | unsigned long | sizes[3]
 | ) | [protected]

The documentation for this class was generated from the following file:
  • Parallel/vtkPipelineSize.h
Generated on Mon Mar 25 01:27:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPixel Class Reference

a cell that represents an orthogonal quadrilateral. More...

#include <vtkPixel.h>

Inheritance diagram for vtkPixel:

[legend]
Collaboration diagram for vtkPixel:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPixel, vtkCell)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkPixel * | New ()
void | InterpolationFunctions (float pcoords[3], float weights[4])
void | InterpolationDerivs (float pcoords[3], float derivs[8])

Protected Methods

vtkPixel ()
~vtkPixel ()

Protected Attributes

vtkLine * Line

Detailed Description

a cell that represents an orthogonal quadrilateral.

Date:
2002/01/22 15:25:54
Revision:
1.60

vtkPixel is a concrete implementation of vtkCell to represent a 2D orthogonal quadrilateral. Unlike vtkQuad, the corners are at right angles, and aligned along x-y-z coordinate axes leading to large increases in computational efficiency.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Geveci, Berk (7%)
  • Martin, Ken (6%)
  • Law, Charles (5%)
Examples:
vtkPixel (Examples)
Tests:
vtkPixel (Tests)

Definition at line 49 of file vtkPixel.h.

Constructor & Destructor Documentation

vtkPixel::vtkPixel ( ) [protected]

vtkPixel::~vtkPixel ( ) [protected]

Member Function Documentation

vtkPixel* vtkPixel::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPixel::vtkTypeRevisionMacro | ( | vtkPixel | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkPixel::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPixel::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkPixel.h.

int vtkPixel::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkPixel.h.

int vtkPixel::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 60 of file vtkPixel.h.

int vtkPixel::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 61 of file vtkPixel.h.

vtkCell* vtkPixel::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkPixel::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 63 of file vtkPixel.h.

int vtkPixel::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPixel::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPixel::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPixel::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPixel::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPixel::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPixel::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPixel::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPixel::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[4]
 | ) | [static]

Pixel specific methods.

void vtkPixel::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[8]
 | ) | [static]

Pixel specific methods.

Member Data Documentation

vtkLine* vtkPixel::Line [protected]

Definition at line 98 of file vtkPixel.h.

The documentation for this class was generated from the following file:
  • Common/vtkPixel.h
Generated on Mon Mar 25 01:27:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlane Class Reference

perform various plane computations. More...

#include <vtkPlane.h>

Inheritance diagram for vtkPlane:

[legend]
Collaboration diagram for vtkPlane:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPlane, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetNormal (float, float, float)
virtual void | SetNormal (float[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float data[3])
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])

Static Public Methods

vtkPlane * | New ()
float | DistanceToPlane (float x[3], float n[3], float p0[3])
void | ProjectPoint (float x[3], float origin[3], float normal[3], float xproj[3])
void | ProjectPoint (double x[3], double origin[3], double normal[3], double xproj[3])
void | GeneralizedProjectPoint (float x[3], float origin[3], float normal[3], float xproj[3])
float | Evaluate (float normal[3], float origin[3], float x[3])
float | Evaluate (double normal[3], double origin[3], double x[3])
int | IntersectWithLine (float p1[3], float p2[3], float n[3], float p0[3], float &t, float x[3])

Protected Methods

vtkPlane ()
~vtkPlane ()

Protected Attributes

float | Normal [3]
float | Origin [3]

Detailed Description

perform various plane computations.

Date:
2002/01/22 15:25:55
Revision:
1.47

vtkPlane provides methods for various plane computations. These include projecting points onto a plane, evaluating the plane equation, and returning plane normal. vtkPlane is a concrete implementation of the abstract class vtkImplicitFunction.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (54%)
  • Miller, Jim (27%)
  • Martin, Ken (11%)
  • Kelly, Ann (6%)
Examples:
vtkPlane (Examples)
Tests:
vtkPlane (Tests)

Definition at line 49 of file vtkPlane.h.

Constructor & Destructor Documentation

vtkPlane::vtkPlane ( ) [protected]

vtkPlane::~vtkPlane ( ) [inline, protected]

Definition at line 122 of file vtkPlane.h.

Member Function Documentation

vtkPlane* vtkPlane::New ( ) [static]

Construct plane passing through origin and normal to z-axis.

Reimplemented from vtkObject.

vtkPlane::vtkTypeRevisionMacro | ( | vtkPlane | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkPlane::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

float vtkPlane::EvaluateFunction ( float x[3] ) [virtual]

Evaluate plane equation for point x[3].

Reimplemented from vtkImplicitFunction.

float vtkPlane::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate plane equation for point x[3].

Reimplemented from vtkImplicitFunction.

Definition at line 61 of file vtkPlane.h.

void vtkPlane::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate function gradient at point x[3].

Reimplemented from vtkImplicitFunction.

virtual void vtkPlane::SetNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get plane normal. Plane is defined by point and normal.

virtual void vtkPlane::SetNormal ( float [3] ) [virtual]

Set/get plane normal. Plane is defined by point and normal.

virtual float* vtkPlane::GetNormal ( ) [virtual]

Set/get plane normal. Plane is defined by point and normal.

virtual void vtkPlane::GetNormal ( float data[3] ) [virtual]

Set/get plane normal. Plane is defined by point and normal.

virtual void vtkPlane::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get point through which plane passes. Plane is defined by point and normal.

virtual void vtkPlane::SetOrigin ( float [3] ) [virtual]

Set/get point through which plane passes. Plane is defined by point and normal.

virtual float* vtkPlane::GetOrigin ( ) [virtual]

Set/get point through which plane passes. Plane is defined by point and normal.

virtual void vtkPlane::GetOrigin ( float data[3] ) [virtual]

Set/get point through which plane passes. Plane is defined by point and normal.

void vtkPlane::ProjectPoint | ( | float | x[3],
 |  | float | origin[3],
 |  | float | normal[3],
 |  | float | xproj[3]
 | ) | [static]

Project a point x onto plane defined by origin and normal. The projected point is returned in xproj. NOTE : normal assumed to have magnitude 1.

void vtkPlane::ProjectPoint | ( | double | x[3],
 |  | double | origin[3],
 |  | double | normal[3],
 |  | double | xproj[3]
 | ) | [static]

Project a point x onto plane defined by origin and normal. The projected point is returned in xproj. NOTE : normal assumed to have magnitude 1.

void vtkPlane::GeneralizedProjectPoint | ( | float | x[3],
 |  | float | origin[3],
 |  | float | normal[3],
 |  | float | xproj[3]
 | ) | [static]

Project a point x onto plane defined by origin and normal. The projected point is returned in xproj. NOTE : normal does NOT have to have magnitude 1.

float vtkPlane::Evaluate | ( | float | normal[3],
 |  | float | origin[3],
 |  | float | x[3]
 | ) | [inline, static]

Quick evaluation of plane equation n(x-origin)=0.

Definition at line 132 of file vtkPlane.h.

float vtkPlane::Evaluate | ( | double | normal[3],
 |  | double | origin[3],
 |  | double | x[3]
 | ) | [inline, static]

Quick evaluation of plane equation n(x-origin)=0.

Definition at line 137 of file vtkPlane.h.

float vtkPlane::DistanceToPlane | ( | float | x[3],
 |  | float | n[3],
 |  | float | p0[3]
 | ) | [inline, static]

Return the distance of a point x to a plane defined by n(x-p0) = 0. The normal n[3] must be magnitude=1.

Definition at line 143 of file vtkPlane.h.

int vtkPlane::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | n[3],
 |  | float | p0[3],
 |  | float & | t,
 |  | float | x[3]
 | ) | [static]

Given a line defined by the two points p1,p2; and a plane defined by the normal n and point p0, compute an intersection. The parametric coordinate along the line is returned in t, and the coordinates of intersection are returned in x. A zero is returned if the plane and line are parallel.

Member Data Documentation

float vtkPlane::Normal[3] [protected]

Definition at line 124 of file vtkPlane.h.

float vtkPlane::Origin[3] [protected]

Definition at line 125 of file vtkPlane.h.

The documentation for this class was generated from the following file:
  • Common/vtkPlane.h
Generated on Mon Mar 25 01:27:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlaneCollection Class Reference

maintain a list of planes. More...

#include <vtkPlaneCollection.h>

Inheritance diagram for vtkPlaneCollection:

[legend]
Collaboration diagram for vtkPlaneCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPlaneCollection, vtkCollection)
void | AddItem (vtkPlane *)
vtkPlane * GetNextItem ()

Static Public Methods

vtkPlaneCollection * | New ()

Protected Methods

vtkPlaneCollection ()
~vtkPlaneCollection ()

Detailed Description

maintain a list of planes.

Date:
2002/01/22 15:25:55
Revision:
1.18

vtkPlaneCollection is an object that creates and manipulates lists of objects of type vtkPlane.

See also:
vtkCollection
Created by:
  • Gobbi, David
  • Hoffman, Bill
Contributed by (if > 5%):
  • Gobbi, David (51%)
  • Hoffman, Bill (31%)
  • Martin, Ken (11%)

Definition at line 43 of file vtkPlaneCollection.h.

Constructor & Destructor Documentation

vtkPlaneCollection::vtkPlaneCollection ( ) [inline, protected]

Definition at line 56 of file vtkPlaneCollection.h.

vtkPlaneCollection::~vtkPlaneCollection ( ) [inline, protected]

Definition at line 57 of file vtkPlaneCollection.h.

Member Function Documentation

vtkPlaneCollection::vtkTypeRevisionMacro | ( | vtkPlaneCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkPlaneCollection* vtkPlaneCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkPlaneCollection::AddItem ( vtkPlane * f ) [inline]

Add a plane to the list.

Definition at line 69 of file vtkPlaneCollection.h.

vtkPlane * vtkPlaneCollection::GetNextItem ( ) [inline]

Get the next plane in the list.

Definition at line 74 of file vtkPlaneCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkPlaneCollection.h
Generated on Mon Mar 25 01:27:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlanes Class Reference

implicit function for convex set of planes. More...

#include <vtkPlanes.h>

Inheritance diagram for vtkPlanes:

[legend]
Collaboration diagram for vtkPlanes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPlanes, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float n[3])
void | SetFrustumPlanes (float planes[24])
int | GetNumberOfPlanes ()
vtkPlane * | GetPlane (int i)
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetPoints (vtkPoints *)
virtual vtkPoints * | GetPoints ()
void | SetNormals (vtkDataArray *normals)
virtual vtkDataArray * | GetNormals ()
void | SetBounds (float bounds[6])
void | SetBounds (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)

Static Public Methods

vtkPlanes * | New ()

Protected Methods

vtkPlanes ()
~vtkPlanes ()

Protected Attributes

vtkPoints * Points
vtkDataArray * Normals
vtkPlane * Plane

Detailed Description

implicit function for convex set of planes.

Date:
2002/01/22 15:25:56
Revision:
1.10

vtkPlanes computes the implicit function and function gradient for a set of planes. The planes must define a convex space.

The function value is the closest first order distance of a point to the convex region defined by the planes. The function gradient is the plane normal at the function value. Note that the normals must point outside of the convex region. Thus, a negative function value means that a point is inside the convex region.

There are several methods to define the set of planes. The most general is to supply an instance of vtkPoints and an instance of vtkDataArray. (The points define a point on the plane, and the normals corresponding plane normals.) Two other specialized ways are to 1) supply six planes defining the view frustrum of a camera, and 2) provide a bounding box.

See also:
vtkCamera
Created by:
  • Biddiscombe, John
Contributed by (if > 5%):
  • Biddiscombe, John (66%)
  • Schroeder, Will (24%)
  • Geveci, Berk (8%)
Tests:
vtkPlanes (Tests)

Definition at line 59 of file vtkPlanes.h.

Constructor & Destructor Documentation

vtkPlanes::vtkPlanes ( ) [protected]

vtkPlanes::~vtkPlanes ( ) [protected]

Member Function Documentation

vtkPlanes* vtkPlanes::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPlanes::vtkTypeRevisionMacro | ( | vtkPlanes | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkPlanes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

float vtkPlanes::EvaluateFunction ( float x[3] ) [virtual]

Evaluate plane equations. Return smallest absolute value.

Reimplemented from vtkImplicitFunction.

float vtkPlanes::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate plane equations. Return smallest absolute value.

Reimplemented from vtkImplicitFunction.

Definition at line 69 of file vtkPlanes.h.

void vtkPlanes::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate planes gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkPlanes::SetPoints ( vtkPoints * ) [virtual]

Specify a list of points defining points through which the planes pass.

virtual vtkPoints* vtkPlanes::GetPoints ( ) [virtual]

Specify a list of points defining points through which the planes pass.

void vtkPlanes::SetNormals ( vtkDataArray * normals )

Specify a list of normal vectors for the planes. There is a one-to-one correspondence between plane points and plane normals.

virtual vtkDataArray* vtkPlanes::GetNormals ( ) [virtual]

Specify a list of normal vectors for the planes. There is a one-to-one correspondence between plane points and plane normals.

void vtkPlanes::SetFrustumPlanes ( float planes[24] )

An alternative method to specify six planes defined by the camera view frustrum. See vtkCamera::GetFrustumPlanes() documentation.

void vtkPlanes::SetBounds ( float bounds[6] )

An alternative method to specify six planes defined by a bounding box. The bounding box is a six-vector defined as (xmin,xmax,ymin,ymax,zmin,zmax). It defines six planes orthogonal to the x-y-z coordinate axes.

void vtkPlanes::SetBounds | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

An alternative method to specify six planes defined by a bounding box. The bounding box is a six-vector defined as (xmin,xmax,ymin,ymax,zmin,zmax). It defines six planes orthogonal to the x-y-z coordinate axes.

int vtkPlanes::GetNumberOfPlanes ( )

Return the number of planes in the set of planes.

vtkPlane* vtkPlanes::GetPlane ( int i )

Create and return a pointer to a vtkPlane object at the ith position. It is your responsibility to delete the vtkPlane when done with it. Asking for a plane outside the allowable range returns NULL.

Member Data Documentation

vtkPoints* vtkPlanes::Points [protected]

Definition at line 116 of file vtkPlanes.h.

vtkDataArray* vtkPlanes::Normals [protected]

Definition at line 117 of file vtkPlanes.h.

vtkPlane* vtkPlanes::Plane [protected]

Definition at line 118 of file vtkPlanes.h.

The documentation for this class was generated from the following file:
  • Common/vtkPlanes.h
Generated on Mon Mar 25 01:27:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPlaneSource Class Reference

create an array of quadrilaterals located in a plane. More...

#include <vtkPlaneSource.h>

Inheritance diagram for vtkPlaneSource:

[legend]
Collaboration diagram for vtkPlaneSource:

[legend]
List of all members.

Public Methods

void | PrintSelf (ostream &os, vtkIndent indent)
vtkTypeRevisionMacro (vtkPlaneSource, vtkPolyDataSource)
void | Push (float distance)
virtual void | SetXResolution (int)
virtual int | GetXResolution ()
virtual void | SetYResolution (int)
virtual int | GetYResolution ()
void | SetResolution (const int xR, const int yR)
void | GetResolution (int &xR, int &yR)
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
void | SetPoint1 (float x, float y, float z)
void | SetPoint1 (float pnt[3])
virtual float * | GetPoint1 ()
virtual void | GetPoint1 (float data[3])
void | SetPoint2 (float x, float y, float z)
void | SetPoint2 (float pnt[3])
virtual float * | GetPoint2 ()
virtual void | GetPoint2 (float data[3])
void | SetCenter (float x, float y, float z)
void | SetCenter (float center[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
void | SetNormal (float nx, float ny, float nz)
void | SetNormal (float n[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float data[3])

Static Public Methods

vtkPlaneSource * | New ()

Protected Methods

vtkPlaneSource ()
~vtkPlaneSource ()
void | Execute ()
int | UpdatePlane (float v1[3], float v2[3])

Protected Attributes

int | XResolution
int | YResolution
float | Origin [3]
float | Point1 [3]
float | Point2 [3]
float | Normal [3]
float | Center [3]

Detailed Description

create an array of quadrilaterals located in a plane.

Date:
2002/01/22 15:29:33
Revision:
1.50

vtkPlaneSource creates an m x n array of quadrilaterals arranged as a regular tiling in a plane. The plane is defined by specifying an origin point, and then two other points that, together with the origin, define two axes for the plane. These axes do not have to be orthogonal - so you can create a parallelogram. (The axes must not be parallel.) By default, the plane is centered at the origin and perpendicular to the z-axis, with width and height of length 1. The resolution of the plane (i.e., number of subdivisions) is controlled by the ivars XResolution and YResolution.

There are three convenience methods that allow you to easily move the plane. The first, SetNormal(), allows you to specify the plane normal. The effect of this method is to rotate the plane around the center of the plane, aligning the plane normal with the specified normal. The second, SetCenter(), translates the center of the plane to the specified center point. The third method, Push(), allows you to translate the plane along the plane normal by the distance specified. (Negative Push values translate the plane in the negative normal direction.) Note that the SetNormal(), SetCenter() and Push() methods modify the Origin, Point1, and/or Point2 ivars.

Warning:
The normal to the plane will point in the direction of the cross product of the first axis (Origin->Point1) with the second (Origin->Point2). This also affects the normals to the generated polygons.
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Martin, Ken (23%)
Examples:
vtkPlaneSource (Examples)
Tests:
vtkPlaneSource (Tests)

Definition at line 67 of file vtkPlaneSource.h.

Constructor & Destructor Documentation

vtkPlaneSource::vtkPlaneSource ( ) [protected]

vtkPlaneSource::~vtkPlaneSource ( ) [inline, protected]

Definition at line 140 of file vtkPlaneSource.h.

Member Function Documentation

void vtkPlaneSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPlaneSource::vtkTypeRevisionMacro | ( | vtkPlaneSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

vtkPlaneSource* vtkPlaneSource::New ( ) [static]

Construct plane perpendicular to z-axis, resolution 1x1, width and height 1.0, and centered at the origin.

Reimplemented from vtkPolyDataSource.

virtual void vtkPlaneSource::SetXResolution ( int ) [virtual]

Specify the resolution of the plane along the first axes.

virtual int vtkPlaneSource::GetXResolution ( ) [virtual]

Specify the resolution of the plane along the first axes.

virtual void vtkPlaneSource::SetYResolution ( int ) [virtual]

Specify the resolution of the plane along the second axes.

virtual int vtkPlaneSource::GetYResolution ( ) [virtual]

Specify the resolution of the plane along the second axes.

void vtkPlaneSource::SetResolution | ( | const int | xR,
 |  | const int | yR
 | ) |

Set the number of x-y subdivisions in the plane.

void vtkPlaneSource::GetResolution | ( | int & | xR,
 |  | int & | yR
 | ) | [inline]

Set the number of x-y subdivisions in the plane.

Definition at line 92 of file vtkPlaneSource.h.

virtual void vtkPlaneSource::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the origin of the plane.

virtual void vtkPlaneSource::SetOrigin ( float [3] ) [virtual]

Specify a point defining the origin of the plane.

virtual float* vtkPlaneSource::GetOrigin ( ) [virtual]

Specify a point defining the origin of the plane.

virtual void vtkPlaneSource::GetOrigin ( float data[3] ) [virtual]

Specify a point defining the origin of the plane.

void vtkPlaneSource::SetPoint1 | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Specify a point defining the first axis of the plane.

void vtkPlaneSource::SetPoint1 ( float pnt[3] )

Specify a point defining the first axis of the plane.

virtual float* vtkPlaneSource::GetPoint1 ( ) [virtual]

Specify a point defining the first axis of the plane.

virtual void vtkPlaneSource::GetPoint1 ( float data[3] ) [virtual]

Specify a point defining the first axis of the plane.

void vtkPlaneSource::SetPoint2 | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Specify a point defining the second axis of the plane.

void vtkPlaneSource::SetPoint2 ( float pnt[3] )

Specify a point defining the second axis of the plane.

virtual float* vtkPlaneSource::GetPoint2 ( ) [virtual]

Specify a point defining the second axis of the plane.

virtual void vtkPlaneSource::GetPoint2 ( float data[3] ) [virtual]

Specify a point defining the second axis of the plane.

void vtkPlaneSource::SetCenter | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Set/Get the center of the plane. Works in conjunction with the plane normal to position the plane. Don't use this method to define the plane. Instead, use it to move the plane to a new center point.

void vtkPlaneSource::SetCenter ( float center[3] )

Set/Get the center of the plane. Works in conjunction with the plane normal to position the plane. Don't use this method to define the plane. Instead, use it to move the plane to a new center point.

virtual float* vtkPlaneSource::GetCenter ( ) [virtual]

Set/Get the center of the plane. Works in conjunction with the plane normal to position the plane. Don't use this method to define the plane. Instead, use it to move the plane to a new center point.

virtual void vtkPlaneSource::GetCenter ( float data[3] ) [virtual]

Set/Get the center of the plane. Works in conjunction with the plane normal to position the plane. Don't use this method to define the plane. Instead, use it to move the plane to a new center point.

void vtkPlaneSource::SetNormal | ( | float | nx,
 |  | float | ny,
 |  | float | nz
 | ) |

Set/Get the plane normal. Works in conjunction with the plane center to orient the plane. Don't use this method to define the plane. Instead, use it to rotate the plane around the current center point.

void vtkPlaneSource::SetNormal ( float n[3] )

Set/Get the plane normal. Works in conjunction with the plane center to orient the plane. Don't use this method to define the plane. Instead, use it to rotate the plane around the current center point.

virtual float* vtkPlaneSource::GetNormal ( ) [virtual]

Set/Get the plane normal. Works in conjunction with the plane center to orient the plane. Don't use this method to define the plane. Instead, use it to rotate the plane around the current center point.

virtual void vtkPlaneSource::GetNormal ( float data[3] ) [virtual]

Set/Get the plane normal. Works in conjunction with the plane center to orient the plane. Don't use this method to define the plane. Instead, use it to rotate the plane around the current center point.

void vtkPlaneSource::Push ( float distance )

Translate the plane in the direction of the normal by the distance specified. Negative values move the plane in the opposite direction.

void vtkPlaneSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkPlaneSource::UpdatePlane | ( | float | v1[3],
 |  | float | v2[3]
 | ) | [protected]

Member Data Documentation

int vtkPlaneSource::XResolution [protected]

Definition at line 144 of file vtkPlaneSource.h.

int vtkPlaneSource::YResolution [protected]

Definition at line 145 of file vtkPlaneSource.h.

float vtkPlaneSource::Origin[3] [protected]

Definition at line 146 of file vtkPlaneSource.h.

float vtkPlaneSource::Point1[3] [protected]

Definition at line 147 of file vtkPlaneSource.h.

float vtkPlaneSource::Point2[3] [protected]

Definition at line 148 of file vtkPlaneSource.h.

float vtkPlaneSource::Normal[3] [protected]

Definition at line 149 of file vtkPlaneSource.h.

float vtkPlaneSource::Center[3] [protected]

Definition at line 150 of file vtkPlaneSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPlaneSource.h
Generated on Mon Mar 25 01:27:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLinearExtrusionFilter Class Reference

Subclass that handles piece invariance. More...

#include <vtkPLinearExtrusionFilter.h>

Inheritance diagram for vtkPLinearExtrusionFilter:

[legend]
Collaboration diagram for vtkPLinearExtrusionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPLinearExtrusionFilter, vtkLinearExtrusionFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPieceInvariant (int)
virtual int | GetPieceInvariant ()
virtual void | PieceInvariantOn ()
virtual void | PieceInvariantOff ()

Static Public Methods

vtkPLinearExtrusionFilter * | New ()

Protected Methods

vtkPLinearExtrusionFilter ()
~vtkPLinearExtrusionFilter ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | PieceInvariant

Detailed Description

Subclass that handles piece invariance.

Date:
2002/01/22 15:34:47
Revision:
1.5

vtkPLinearExtrusionFilter is a parallel version of vtkLinearExtrusionFilter.

See also:
vtkLinearExtrusionFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (97%)
Tests:
vtkPLinearExtrusionFilter (Tests)

Definition at line 42 of file vtkPLinearExtrusionFilter.h.

Constructor & Destructor Documentation

vtkPLinearExtrusionFilter::vtkPLinearExtrusionFilter ( ) [protected]

vtkPLinearExtrusionFilter::~vtkPLinearExtrusionFilter ( ) [inline, protected]

Definition at line 63 of file vtkPLinearExtrusionFilter.h.

Member Function Documentation

vtkPLinearExtrusionFilter::vtkTypeRevisionMacro | ( | vtkPLinearExtrusionFilter | ,
 |  | vtkLinearExtrusionFilter |
 | ) |

Reimplemented from vtkLinearExtrusionFilter.

void vtkPLinearExtrusionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearExtrusionFilter.

vtkPLinearExtrusionFilter* vtkPLinearExtrusionFilter::New ( ) [static]

Create an object with PieceInvariant off.

Reimplemented from vtkLinearExtrusionFilter.

virtual void vtkPLinearExtrusionFilter::SetPieceInvariant ( int ) [virtual]

virtual int vtkPLinearExtrusionFilter::GetPieceInvariant ( ) [virtual]

virtual void vtkPLinearExtrusionFilter::PieceInvariantOn ( ) [virtual]

virtual void vtkPLinearExtrusionFilter::PieceInvariantOff ( ) [virtual]

void vtkPLinearExtrusionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkLinearExtrusionFilter.

void vtkPLinearExtrusionFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

int vtkPLinearExtrusionFilter::PieceInvariant [protected]

Definition at line 68 of file vtkPLinearExtrusionFilter.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPLinearExtrusionFilter.h
Generated on Mon Mar 25 01:27:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLOT3DReader Class Reference

read PLOT3D data files. More...

#include <vtkPLOT3DReader.h>

Inheritance diagram for vtkPLOT3DReader:

[legend]
Collaboration diagram for vtkPLOT3DReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPLOT3DReader, vtkStructuredGridSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileFormat (int)
virtual int | GetFileFormat ()
virtual void | SetXYZFileName (const char *)
virtual char * | GetXYZFileName ()
virtual void | SetQFileName (const char *)
virtual char * | GetQFileName ()
virtual void | SetFunctionFileName (const char *)
virtual char * | GetFunctionFileName ()
virtual void | SetVectorFunctionFileName (const char *)
virtual char * | GetVectorFunctionFileName ()
virtual void | SetGridNumber (int)
virtual int | GetGridNumber ()
virtual void | SetScalarFunctionNumber (int)
virtual int | GetScalarFunctionNumber ()
virtual void | SetVectorFunctionNumber (int)
virtual int | GetVectorFunctionNumber ()
void | AddFunction (int functionNumber)
void | RemoveFunction (int)
void | RemoveAllFunctions ()
virtual float | GetFsmach ()
virtual float | GetAlpha ()
virtual float | GetRe ()
virtual float | GetTime ()
virtual void | SetR (float)
virtual float | GetR ()
virtual void | SetGamma (float)
virtual float | GetGamma ()
virtual void | SetUvinf (float)
virtual float | GetUvinf ()
virtual void | SetVvinf (float)
virtual float | GetVvinf ()
virtual void | SetWvinf (float)
virtual float | GetWvinf ()
virtual int | GetNumberOfGrids ()

Static Public Methods

vtkPLOT3DReader * | New ()

Protected Methods

vtkPLOT3DReader ()
~vtkPLOT3DReader ()
void | ExecuteInformation ()
void | Execute ()
int | GetFileType (FILE *fp)
void | MapFunction (int fNumber, vtkPointData *outputPD)
int | ReadBinaryGrid (FILE *fp, vtkStructuredGrid *output)
int | ReadBinaryGridDimensions (FILE *fp, vtkStructuredGrid *output)
int | ReadBinarySolution (FILE *fp, vtkStructuredGrid *output)
int | ReadBinaryFunctionFile (FILE *fp, vtkStructuredGrid *output)
int | ReadBinaryVectorFunctionFile (FILE *fp, vtkStructuredGrid *output)
void | ComputeDensity (vtkPointData *outputPD)
void | ComputePressure (vtkPointData *outputPD)
void | ComputeTemperature (vtkPointData *outputPD)
void | ComputeEnthalpy (vtkPointData *outputPD)
void | ComputeInternalEnergy (vtkPointData *outputPD)
void | ComputeKineticEnergy (vtkPointData *outputPD)
void | ComputeVelocityMagnitude (vtkPointData *outputPD)
void | ComputeStagnationEnergy (vtkPointData *outputPD)
void | ComputeEntropy (vtkPointData *outputPD)
void | ComputeSwirl (vtkPointData *outputPD)
void | ComputeVelocity (vtkPointData *outputPD)
void | ComputeVorticity (vtkPointData *outputPD)
void | ComputeMomentum (vtkPointData *outputPD)
void | ComputePressureGradient (vtkPointData *outputPD)

Protected Attributes

int | FileFormat
char * | XYZFileName
char * | QFileName
char * | FunctionFileName
char * | VectorFunctionFileName
int | GridNumber
int | ScalarFunctionNumber
int | VectorFunctionNumber
int | FunctionFileFunctionNumber
vtkIntArray * FunctionList
float * | TempStorage
int | NumberOfPoints
int | NumberOfGrids
float | Fsmach
float | Alpha
float | Re
float | Time
float | R
float | Gamma
float | Uvinf
float | Vvinf
float | Wvinf
vtkPoints * Grid
vtkFloatArray * Density
vtkFloatArray * Energy
vtkFloatArray * Momentum

Detailed Description

read PLOT3D data files.

Date:
2002/01/22 15:38:17
Revision:
1.48

vtkPLOT3DReader is a reader object that reads PLOT3D formatted files and generates a structured grid on output. PLOT3D is a computer graphics program designed to visualize the grids and solutions of computational fluid dynamics. Please see the "PLOT3D User's Manual" available from NASA Ames Research Center, Moffett Field CA.

PLOT3D files consist of a grid file (also known as XYZ file), an optional solution file (also known as a Q file), and an optional function file that contains user created data. The Q file contains solution information as follows: the four parameters free stream mach number (Fsmach), angle of attack (Alpha), Reynolds number (Re), and total integration time (Time). In addition, the solution file contains the flow density (scalar), flow momentum (vector), and flow energy (scalar).

The reader can generate additional scalars and vectors (or "functions") from this information. To use vtkPLOT3DReader, you must specify the particular function number for the scalar and vector you want to visualize. This implementation of the reader provides the following functions. The scalar functions are: -1 - don't read or compute any scalars 100 - density 110 - pressure 120 - temperature 130 - enthalpy 140 - internal energy 144 - kinetic energy 153 - velocity magnitude 163 - stagnation energy 170 - entropy 184 - swirl.

The vector functions are: -1 - don't read or compute any vectors 200 - velocity 201 - vorticity 202 - momentum 210 - pressure gradient.

(Other functions are described in the PLOT3D spec, but only those listed are implemented here.) Note that by default, this reader creates the density scalar (100) and momentum vector (202) as output. (These are just read in from the solution file.) Please note that the validity of computation is a function of this class's gas constants (R, Gamma) and the equations used. They may not be suitable for your computational domain.

Additionally, you can read other data and associate it as a vtkDataArray into the output's point attribute data. Use the method AddFunction() to list all the functions that you'd like to read. AddFunction() accepts an integer parameter that defines the function number.

The format of the function file is as follows. An integer indicating number of grids, then an integer specifying number of functions per each grid. This is followed by the (integer) dimensions of each grid in the file. Finally, for each grid, and for each function, a float value per each point in the current grid. Note: if both a function from the function file is specified, as well as a scalar from the solution file (or derived from the solution file), the function file takes precedence.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Martin, Ken (11%)
  • Geveci, Berk (6%)
  • Lorensen, Bill (5%)
Examples:
vtkPLOT3DReader (Examples)
Tests:
vtkPLOT3DReader (Tests)

Definition at line 109 of file vtkPLOT3DReader.h.

Constructor & Destructor Documentation

vtkPLOT3DReader::vtkPLOT3DReader ( ) [protected]

vtkPLOT3DReader::~vtkPLOT3DReader ( ) [protected]

Member Function Documentation

vtkPLOT3DReader* vtkPLOT3DReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredGridSource.

vtkPLOT3DReader::vtkTypeRevisionMacro | ( | vtkPLOT3DReader | ,
 |  | vtkStructuredGridSource |
 | ) |

Reimplemented from vtkStructuredGridSource.

void vtkPLOT3DReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkPLOT3DReader::SetFileFormat ( int ) [virtual]

Specify the PLOT3D file format to use

virtual int vtkPLOT3DReader::GetFileFormat ( ) [virtual]

Specify the PLOT3D file format to use

virtual void vtkPLOT3DReader::SetXYZFileName ( const char * ) [virtual]

Set/Get the PLOT3D geometry FileName.

virtual char* vtkPLOT3DReader::GetXYZFileName ( ) [virtual]

Set/Get the PLOT3D geometry FileName.

virtual void vtkPLOT3DReader::SetQFileName ( const char * ) [virtual]

Set/Get the PLOT3D solution FileName.

virtual char* vtkPLOT3DReader::GetQFileName ( ) [virtual]

Set/Get the PLOT3D solution FileName.

virtual void vtkPLOT3DReader::SetFunctionFileName ( const char * ) [virtual]

Set/Get the PLOT3D function FileName.

virtual char* vtkPLOT3DReader::GetFunctionFileName ( ) [virtual]

Set/Get the PLOT3D function FileName.

virtual void vtkPLOT3DReader::SetVectorFunctionFileName ( const char * ) [virtual]

Set/Get the PLOT3D vector FileName.

virtual char* vtkPLOT3DReader::GetVectorFunctionFileName ( ) [virtual]

Set/Get the PLOT3D vector FileName.

virtual void vtkPLOT3DReader::SetGridNumber ( int ) [virtual]

Specify the grid to read.

virtual int vtkPLOT3DReader::GetGridNumber ( ) [virtual]

Specify the grid to read.

virtual void vtkPLOT3DReader::SetScalarFunctionNumber ( int ) [virtual]

Specify the scalar function to extract. If ==(-1), then no scalar function is extracted.

virtual int vtkPLOT3DReader::GetScalarFunctionNumber ( ) [virtual]

Specify the scalar function to extract. If ==(-1), then no scalar function is extracted.

virtual void vtkPLOT3DReader::SetVectorFunctionNumber ( int ) [virtual]

Specify the vector function to extract. If ==(-1), then no vector function is extracted.

virtual int vtkPLOT3DReader::GetVectorFunctionNumber ( ) [virtual]

Specify the vector function to extract. If ==(-1), then no vector function is extracted.

void vtkPLOT3DReader::AddFunction ( int functionNumber ) [inline]

Specify additional functions to read. These are placed into the point data as data arrays. Later on they can be used by labeling them as scalars, etc.

Definition at line 170 of file vtkPLOT3DReader.h.

void vtkPLOT3DReader::RemoveFunction ( int )

Specify additional functions to read. These are placed into the point data as data arrays. Later on they can be used by labeling them as scalars, etc.

void vtkPLOT3DReader::RemoveAllFunctions ( ) [inline]

Specify additional functions to read. These are placed into the point data as data arrays. Later on they can be used by labeling them as scalars, etc.

Definition at line 173 of file vtkPLOT3DReader.h.

virtual float vtkPLOT3DReader::GetFsmach ( ) [virtual]

Get the free-stream mach number.

virtual float vtkPLOT3DReader::GetAlpha ( ) [virtual]

Get the angle of attack.

virtual float vtkPLOT3DReader::GetRe ( ) [virtual]

Get the Reynold's number.

virtual float vtkPLOT3DReader::GetTime ( ) [virtual]

Get the total integration time.

virtual void vtkPLOT3DReader::SetR ( float ) [virtual]

Set/Get the gas constant.

virtual float vtkPLOT3DReader::GetR ( ) [virtual]

Set/Get the gas constant.

virtual void vtkPLOT3DReader::SetGamma ( float ) [virtual]

Set/Get the ratio of specific heats.

virtual float vtkPLOT3DReader::GetGamma ( ) [virtual]

Set/Get the ratio of specific heats.

virtual void vtkPLOT3DReader::SetUvinf ( float ) [virtual]

Set/Get the x-component of the free-stream velocity.

virtual float vtkPLOT3DReader::GetUvinf ( ) [virtual]

Set/Get the x-component of the free-stream velocity.

virtual void vtkPLOT3DReader::SetVvinf ( float ) [virtual]

Set/Get the y-component of the free-stream velocity.

virtual float vtkPLOT3DReader::GetVvinf ( ) [virtual]

Set/Get the y-component of the free-stream velocity.

virtual void vtkPLOT3DReader::SetWvinf ( float ) [virtual]

Set/Get the z-component of the free-stream velocity.

virtual float vtkPLOT3DReader::GetWvinf ( ) [virtual]

Set/Get the z-component of the free-stream velocity.

virtual int vtkPLOT3DReader::GetNumberOfGrids ( ) [virtual]

Get the number of grids. This is valid only after a read has been performed.

void vtkPLOT3DReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkPLOT3DReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkPLOT3DReader::GetFileType ( FILE * fp ) [protected]

void vtkPLOT3DReader::MapFunction | ( | int | fNumber,
 |  | vtkPointData * | outputPD
 | ) | [protected]

int vtkPLOT3DReader::ReadBinaryGrid | ( | FILE * | fp,
 |  | vtkStructuredGrid * | output
 | ) | [protected]

int vtkPLOT3DReader::ReadBinaryGridDimensions | ( | FILE * | fp,
 |  | vtkStructuredGrid * | output
 | ) | [protected]

int vtkPLOT3DReader::ReadBinarySolution | ( | FILE * | fp,
 |  | vtkStructuredGrid * | output
 | ) | [protected]

int vtkPLOT3DReader::ReadBinaryFunctionFile | ( | FILE * | fp,
 |  | vtkStructuredGrid * | output
 | ) | [protected]

int vtkPLOT3DReader::ReadBinaryVectorFunctionFile | ( | FILE * | fp,
 |  | vtkStructuredGrid * | output
 | ) | [protected]

void vtkPLOT3DReader::ComputeDensity ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputePressure ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeTemperature ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeEnthalpy ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeInternalEnergy ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeKineticEnergy ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeVelocityMagnitude ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeStagnationEnergy ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeEntropy ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeSwirl ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeVelocity ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeVorticity ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputeMomentum ( vtkPointData * outputPD ) [protected]

void vtkPLOT3DReader::ComputePressureGradient ( vtkPointData * outputPD ) [protected]

Member Data Documentation

int vtkPLOT3DReader::FileFormat [protected]

Definition at line 243 of file vtkPLOT3DReader.h.

char* vtkPLOT3DReader::XYZFileName [protected]

Definition at line 244 of file vtkPLOT3DReader.h.

char* vtkPLOT3DReader::QFileName [protected]

Definition at line 245 of file vtkPLOT3DReader.h.

char* vtkPLOT3DReader::FunctionFileName [protected]

Definition at line 246 of file vtkPLOT3DReader.h.

char* vtkPLOT3DReader::VectorFunctionFileName [protected]

Definition at line 247 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::GridNumber [protected]

Definition at line 250 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::ScalarFunctionNumber [protected]

Definition at line 251 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::VectorFunctionNumber [protected]

Definition at line 252 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::FunctionFileFunctionNumber [protected]

Definition at line 253 of file vtkPLOT3DReader.h.

vtkIntArray* vtkPLOT3DReader::FunctionList [protected]

Definition at line 257 of file vtkPLOT3DReader.h.

float* vtkPLOT3DReader::TempStorage [protected]

Definition at line 260 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::NumberOfPoints [protected]

Definition at line 261 of file vtkPLOT3DReader.h.

int vtkPLOT3DReader::NumberOfGrids [protected]

Definition at line 262 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Fsmach [protected]

Definition at line 265 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Alpha [protected]

Definition at line 266 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Re [protected]

Definition at line 267 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Time [protected]

Definition at line 268 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::R [protected]

Definition at line 271 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Gamma [protected]

Definition at line 272 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Uvinf [protected]

Definition at line 273 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Vvinf [protected]

Definition at line 274 of file vtkPLOT3DReader.h.

float vtkPLOT3DReader::Wvinf [protected]

Definition at line 275 of file vtkPLOT3DReader.h.

vtkPoints* vtkPLOT3DReader::Grid [protected]

Definition at line 284 of file vtkPLOT3DReader.h.

vtkFloatArray* vtkPLOT3DReader::Density [protected]

Definition at line 285 of file vtkPLOT3DReader.h.

vtkFloatArray* vtkPLOT3DReader::Energy [protected]

Definition at line 286 of file vtkPLOT3DReader.h.

vtkFloatArray* vtkPLOT3DReader::Momentum [protected]

Definition at line 287 of file vtkPLOT3DReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkPLOT3DReader.h
Generated on Mon Mar 25 01:27:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLY Class Reference

a modified version of the PLY 1.1 library. More...

#include <vtkPLY.h>

List of all members.

Static Public Methods

PlyFile * | ply_write (FILE *, int, const char **, int)
PlyFile * | ply_open_for_writing (char *, int, const char **, int, float *)
void | ply_describe_element (PlyFile *, char *, int, int, PlyProperty *)
void | ply_describe_property (PlyFile *, char *, PlyProperty *)
void | ply_element_count (PlyFile *, char *, int)
void | ply_header_complete (PlyFile *)
void | ply_put_element_setup (PlyFile *, char *)
void | ply_put_element (PlyFile *, void *)
void | ply_put_comment (PlyFile *, char *)
void | ply_put_obj_info (PlyFile *, char *)
PlyFile * | ply_read (FILE *, int *, char ***)
PlyFile * | ply_open_for_reading (char *, int *, char ***, int *, float *)
PlyElement * | ply_get_element_description (PlyFile *, char *, int *, int *)
void | ply_get_element_setup (PlyFile *, char *, int, PlyProperty *)
void | ply_get_property (PlyFile *, char *, PlyProperty *)
PlyOtherProp * | ply_get_other_properties (PlyFile *, char *, int)
void | ply_get_element (PlyFile *, void *)
char ** | ply_get_comments (PlyFile *, int *)
char ** | ply_get_obj_info (PlyFile *, int *)
void | ply_close (PlyFile *)
void | ply_get_info (PlyFile *, float *, int *)
PlyOtherElems * | ply_get_other_element (PlyFile *, char *, int)
void | ply_describe_other_elements (PlyFile *, PlyOtherElems *)
void | ply_put_other_elements (PlyFile *)
void | ply_free_other_elements (PlyOtherElems *)
void | ply_describe_other_properties (PlyFile *, PlyOtherProp *, int)
int | equal_strings (const char *, const char *)
PlyElement * | find_element (PlyFile *, char *)
PlyProperty * | find_property (PlyElement *, const char *, int *)
void | write_scalar_type (FILE *, int)
char ** | get_words (FILE *, int *, char **)
char ** | old_get_words (FILE *, int *)
void | write_binary_item (FILE *, int, unsigned int, double, int)
void | write_ascii_item (FILE *, int, unsigned int, double, int)
double | old_write_ascii_item (FILE *, char *, int)
void | add_element (PlyFile *, char **, int)
void | add_property (PlyFile *, char **, int)
void | add_comment (PlyFile *, char *)
void | add_obj_info (PlyFile *, char *)
void | copy_property (PlyProperty *, PlyProperty *)
void | store_item (char *, int, int, unsigned int, double)
void | get_stored_item (void *, int, int *, unsigned int *, double *)
double | get_item_value (char *, int)
void | get_ascii_item (char *, int, int *, unsigned int *, double *)
void | get_binary_item (FILE *, int, int *, unsigned int *, double *)
void | ascii_get_element (PlyFile *, char *)
void | binary_get_element (PlyFile *, char *)
char * | my_alloc (int, int, char *)
int | get_prop_type (char *)

Detailed Description

a modified version of the PLY 1.1 library.

Date:
2002/01/22 15:38:17
Revision:
1.8

vtkPLY is a modified version of the PLY 1.1 library. The library has been modified by wrapping in a class (to minimize global symbols); to take advantage of functionality generally not available through the PLY library API; and to correct problems with the PLY library.

The original distribution was taken from the Stanford University PLY file format release 1.1 (see http://graphics.stanford.edu/data/3Dscanrep/).

See also:
vtkPLYWriter vtkPLYReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (97%)

Definition at line 169 of file vtkPLY.h.

Member Function Documentation

PlyFile* vtkPLY::ply_write | ( | FILE * | ,
 |  | int | ,
 |  | const char ** | ,
 |  | int |
 | ) | [static]

PlyFile* vtkPLY::ply_open_for_writing | ( | char * | ,
 |  | int | ,
 |  | const char ** | ,
 |  | int | ,
 |  | float * |
 | ) | [static]

void vtkPLY::ply_describe_element | ( | PlyFile * | ,
 |  | char * | ,
 |  | int | ,
 |  | int | ,
 |  | PlyProperty * |
 | ) | [static]

void vtkPLY::ply_describe_property | ( | PlyFile * | ,
 |  | char * | ,
 |  | PlyProperty * |
 | ) | [static]

void vtkPLY::ply_element_count | ( | PlyFile * | ,
 |  | char * | ,
 |  | int |
 | ) | [static]

void vtkPLY::ply_header_complete ( PlyFile * ) [static]

void vtkPLY::ply_put_element_setup | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

void vtkPLY::ply_put_element | ( | PlyFile * | ,
 |  | void * |
 | ) | [static]

void vtkPLY::ply_put_comment | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

void vtkPLY::ply_put_obj_info | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

PlyFile* vtkPLY::ply_read | ( | FILE * | ,
 |  | int * | ,
 |  | char *** |
 | ) | [static]

PlyFile* vtkPLY::ply_open_for_reading | ( | char * | ,
 |  | int * | ,
 |  | char *** | ,
 |  | int * | ,
 |  | float * |
 | ) | [static]

PlyElement* vtkPLY::ply_get_element_description | ( | PlyFile * | ,
 |  | char * | ,
 |  | int * | ,
 |  | int * |
 | ) | [static]

void vtkPLY::ply_get_element_setup | ( | PlyFile * | ,
 |  | char * | ,
 |  | int | ,
 |  | PlyProperty * |
 | ) | [static]

void vtkPLY::ply_get_property | ( | PlyFile * | ,
 |  | char * | ,
 |  | PlyProperty * |
 | ) | [static]

PlyOtherProp* vtkPLY::ply_get_other_properties | ( | PlyFile * | ,
 |  | char * | ,
 |  | int |
 | ) | [static]

void vtkPLY::ply_get_element | ( | PlyFile * | ,
 |  | void * |
 | ) | [static]

char** vtkPLY::ply_get_comments | ( | PlyFile * | ,
 |  | int * |
 | ) | [static]

char** vtkPLY::ply_get_obj_info | ( | PlyFile * | ,
 |  | int * |
 | ) | [static]

void vtkPLY::ply_close ( PlyFile * ) [static]

void vtkPLY::ply_get_info | ( | PlyFile * | ,
 |  | float * | ,
 |  | int * |
 | ) | [static]

PlyOtherElems* vtkPLY::ply_get_other_element | ( | PlyFile * | ,
 |  | char * | ,
 |  | int |
 | ) | [static]

void vtkPLY::ply_describe_other_elements | ( | PlyFile * | ,
 |  | PlyOtherElems * |
 | ) | [static]

void vtkPLY::ply_put_other_elements ( PlyFile * ) [static]

void vtkPLY::ply_free_other_elements ( PlyOtherElems * ) [static]

void vtkPLY::ply_describe_other_properties | ( | PlyFile * | ,
 |  | PlyOtherProp * | ,
 |  | int |
 | ) | [static]

int vtkPLY::equal_strings | ( | const char * | ,
 |  | const char * |
 | ) | [static]

PlyElement* vtkPLY::find_element | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

PlyProperty* vtkPLY::find_property | ( | PlyElement * | ,
 |  | const char * | ,
 |  | int * |
 | ) | [static]

void vtkPLY::write_scalar_type | ( | FILE * | ,
 |  | int |
 | ) | [static]

char** vtkPLY::get_words | ( | FILE * | ,
 |  | int * | ,
 |  | char ** |
 | ) | [static]

char** vtkPLY::old_get_words | ( | FILE * | ,
 |  | int * |
 | ) | [static]

void vtkPLY::write_binary_item | ( | FILE * | ,
 |  | int | ,
 |  | unsigned | int,
 |  | double | ,
 |  | int |
 | ) | [static]

void vtkPLY::write_ascii_item | ( | FILE * | ,
 |  | int | ,
 |  | unsigned | int,
 |  | double | ,
 |  | int |
 | ) | [static]

double vtkPLY::old_write_ascii_item | ( | FILE * | ,
 |  | char * | ,
 |  | int |
 | ) | [static]

void vtkPLY::add_element | ( | PlyFile * | ,
 |  | char ** | ,
 |  | int |
 | ) | [static]

void vtkPLY::add_property | ( | PlyFile * | ,
 |  | char ** | ,
 |  | int |
 | ) | [static]

void vtkPLY::add_comment | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

void vtkPLY::add_obj_info | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

void vtkPLY::copy_property | ( | PlyProperty * | ,
 |  | PlyProperty * |
 | ) | [static]

void vtkPLY::store_item | ( | char * | ,
 |  | int | ,
 |  | int | ,
 |  | unsigned | int,
 |  | double |
 | ) | [static]

void vtkPLY::get_stored_item | ( | void * | ,
 |  | int | ,
 |  | int * | ,
 |  | unsigned int * | ,
 |  | double * |
 | ) | [static]

double vtkPLY::get_item_value | ( | char * | ,
 |  | int |
 | ) | [static]

void vtkPLY::get_ascii_item | ( | char * | ,
 |  | int | ,
 |  | int * | ,
 |  | unsigned int * | ,
 |  | double * |
 | ) | [static]

void vtkPLY::get_binary_item | ( | FILE * | ,
 |  | int | ,
 |  | int * | ,
 |  | unsigned int * | ,
 |  | double * |
 | ) | [static]

void vtkPLY::ascii_get_element | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

void vtkPLY::binary_get_element | ( | PlyFile * | ,
 |  | char * |
 | ) | [static]

char* vtkPLY::my_alloc | ( | int | ,
 |  | int | ,
 |  | char * |
 | ) | [static]

int vtkPLY::get_prop_type ( char * ) [static]

The documentation for this class was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PlyElement Struct Reference

#include <vtkPLY.h>

Collaboration diagram for PlyElement:

[legend]
List of all members.

Public Attributes

char * | name
int | num
int | size
int | nprops
PlyProperty ** props
char * | store_prop
int | other_offset
int | other_size

Member Data Documentation

char* PlyElement::name

Definition at line 119 of file vtkPLY.h.

int PlyElement::num

Definition at line 120 of file vtkPLY.h.

int PlyElement::size

Definition at line 121 of file vtkPLY.h.

int PlyElement::nprops

Definition at line 122 of file vtkPLY.h.

PlyProperty** PlyElement::props

Definition at line 123 of file vtkPLY.h.

char* PlyElement::store_prop

Definition at line 124 of file vtkPLY.h.

int PlyElement::other_offset

Definition at line 125 of file vtkPLY.h.

int PlyElement::other_size

Definition at line 126 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PlyFile Struct Reference

#include <vtkPLY.h>

Collaboration diagram for PlyFile:

[legend]
List of all members.

Public Attributes

FILE * | fp
int | file_type
float | version
int | nelems
PlyElement ** elems
int | num_comments
char ** | comments
int | num_obj_info
char ** | obj_info
PlyElement * which_elem
PlyOtherElems * other_elems

Member Data Documentation

FILE* PlyFile::fp

Definition at line 153 of file vtkPLY.h.

int PlyFile::file_type

Definition at line 154 of file vtkPLY.h.

float PlyFile::version

Definition at line 155 of file vtkPLY.h.

int PlyFile::nelems

Definition at line 156 of file vtkPLY.h.

PlyElement** PlyFile::elems

Definition at line 157 of file vtkPLY.h.

int PlyFile::num_comments

Definition at line 158 of file vtkPLY.h.

char** PlyFile::comments

Definition at line 159 of file vtkPLY.h.

int PlyFile::num_obj_info

Definition at line 160 of file vtkPLY.h.

char** PlyFile::obj_info

Definition at line 161 of file vtkPLY.h.

PlyElement* PlyFile::which_elem

Definition at line 162 of file vtkPLY.h.

PlyOtherElems* PlyFile::other_elems

Definition at line 163 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PlyOtherElems Struct Reference

#include <vtkPLY.h>

Collaboration diagram for PlyOtherElems:

[legend]
List of all members.

Public Attributes

int num_elems
OtherElem * other_list

Member Data Documentation

int PlyOtherElems::num_elems

Definition at line 148 of file vtkPLY.h.

OtherElem* PlyOtherElems::other_list

Definition at line 149 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PlyOtherProp Struct Reference

#include <vtkPLY.h>

Collaboration diagram for PlyOtherProp:

[legend]
List of all members.

Public Attributes

char * | name
int | size
int | nprops
PlyProperty ** props

Member Data Documentation

char* PlyOtherProp::name

Definition at line 130 of file vtkPLY.h.

int PlyOtherProp::size

Definition at line 131 of file vtkPLY.h.

int PlyOtherProp::nprops

Definition at line 132 of file vtkPLY.h.

PlyProperty** PlyOtherProp::props

Definition at line 133 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PlyProperty Struct Reference

#include <vtkPLY.h>

Collaboration diagram for PlyProperty:

[legend]
List of all members.

Public Attributes

const char * | name
int | external_type
int | internal_type
int | offset
int | is_list
int | count_external
int | count_internal
int | count_offset

Member Data Documentation

const char* PlyProperty::name

Definition at line 106 of file vtkPLY.h.

int PlyProperty::external_type

Definition at line 107 of file vtkPLY.h.

int PlyProperty::internal_type

Definition at line 108 of file vtkPLY.h.

int PlyProperty::offset

Definition at line 109 of file vtkPLY.h.

int PlyProperty::is_list

Definition at line 111 of file vtkPLY.h.

int PlyProperty::count_external

Definition at line 112 of file vtkPLY.h.

int PlyProperty::count_internal

Definition at line 113 of file vtkPLY.h.

int PlyProperty::count_offset

Definition at line 114 of file vtkPLY.h.

The documentation for this struct was generated from the following file:
  • IO/vtkPLY.h
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLYReader Class Reference

read Stanford University PLY polygonal file format. More...

#include <vtkPLYReader.h>

Inheritance diagram for vtkPLYReader:

[legend]
Collaboration diagram for vtkPLYReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPLYReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkPLYReader * | New ()

Protected Methods

vtkPLYReader ()
~vtkPLYReader ()
void | Execute ()

Protected Attributes

char * | FileName

Detailed Description

read Stanford University PLY polygonal file format.

Date:
2002/01/22 15:38:18
Revision:
1.6

vtkPLYReader is a source object that reads polygonal data in Stanford University PLY file format (see http://graphics.stanford.edu/data/3Dscanrep/). It requires that the elements "vertex" and "face" are defined. The "vertex" element must have the properties "x", "y", and "z". The "face" element must have the property "vertex_indices" defined. Optionally, if the "face" element has the properties "intensity" and/or the triplet "red", "green", and "blue"; these are read and added as scalars to the output data.

See also:
vtkPLYWriter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (90%)
  • Cedilnik, Andy (6%)
Tests:
vtkPLYReader (Tests)

Definition at line 51 of file vtkPLYReader.h.

Constructor & Destructor Documentation

vtkPLYReader::vtkPLYReader ( ) [protected]

vtkPLYReader::~vtkPLYReader ( ) [protected]

Member Function Documentation

vtkPLYReader::vtkTypeRevisionMacro | ( | vtkPLYReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkPLYReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPLYReader* vtkPLYReader::New ( ) [static]

Construct object with merging set to true.

Reimplemented from vtkPolyDataSource.

virtual void vtkPLYReader::SetFileName ( const char * ) [virtual]

Specify file name of stereo lithography file.

virtual char* vtkPLYReader::GetFileName ( ) [virtual]

Specify file name of stereo lithography file.

void vtkPLYReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkPLYReader::FileName [protected]

Definition at line 70 of file vtkPLYReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkPLYReader.h
Generated on Mon Mar 25 01:27:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPLYWriter Class Reference

write Stanford PLY file format. More...

#include <vtkPLYWriter.h>

Inheritance diagram for vtkPLYWriter:

[legend]
Collaboration diagram for vtkPLYWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPLYWriter, vtkPolyDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDataByteOrder (int)
virtual int | GetDataByteOrder ()
void | SetDataByteOrderToBigEndian ()
void | SetDataByteOrderToLittleEndian ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToDefault ()
void | SetColorModeToUniformCellColor ()
void | SetColorModeToUniformPointColor ()
void | SetColorModeToUniformColor ()
void | SetColorModeToOff ()
virtual void | SetArrayName (const char *)
virtual char * | GetArrayName ()
virtual void | SetComponent (int)
virtual int | GetComponent ()
virtual void | SetLookupTable (vtkScalarsToColors *)
virtual vtkScalarsToColors * | GetLookupTable ()
virtual void | SetColor (unsigned char, unsigned char, unsigned char)
virtual void | SetColor (unsigned char[3])
virtual unsigned char * | GetColor ()
virtual void | GetColor (unsigned char &, unsigned char &, unsigned char &)
virtual void | GetColor (unsigned char[3])

Static Public Methods

vtkPLYWriter * | New ()

Protected Methods

vtkPLYWriter ()
~vtkPLYWriter ()
void | WriteData ()
unsigned char * | GetColors (vtkIdType num, vtkDataSetAttributes *dsa)

Protected Attributes

int | DataByteOrder
char * | ArrayName
int | Component
int | ColorMode
vtkScalarsToColors * LookupTable
unsigned char | Color [3]

Detailed Description

write Stanford PLY file format.

Date:
2002/01/22 15:38:18
Revision:
1.7

vtkPLYWriter writes polygonal data in Stanford University PLY format (see http://graphics.stanford.edu/data/3Dscanrep/). The data can be written in either binary (little or big endian) or ASCII representation.

Warning:
PLY does not handle big endian versus little endian correctly. Also, this class is compiled into VTK only if the PLY library is found during the make process (using CMake).
See also:
vtkPLYReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (91%)
Tests:
vtkPLYWriter (Tests)

Definition at line 61 of file vtkPLYWriter.h.

Constructor & Destructor Documentation

vtkPLYWriter::vtkPLYWriter ( ) [protected]

vtkPLYWriter::~vtkPLYWriter ( ) [protected]

Member Function Documentation

vtkPLYWriter* vtkPLYWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkPolyDataWriter.

vtkPLYWriter::vtkTypeRevisionMacro | ( | vtkPLYWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkPLYWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPolyDataWriter.

virtual void vtkPLYWriter::SetDataByteOrder ( int ) [virtual]

If the file type is binary, then the user can specify which byte order to use (little versus big endian).

virtual int vtkPLYWriter::GetDataByteOrder ( ) [virtual]

If the file type is binary, then the user can specify which byte order to use (little versus big endian).

void vtkPLYWriter::SetDataByteOrderToBigEndian ( ) [inline]

If the file type is binary, then the user can specify which byte order to use (little versus big endian).

Definition at line 73 of file vtkPLYWriter.h.

void vtkPLYWriter::SetDataByteOrderToLittleEndian ( ) [inline]

If the file type is binary, then the user can specify which byte order to use (little versus big endian).

Definition at line 75 of file vtkPLYWriter.h.

virtual void vtkPLYWriter::SetColorMode ( int ) [virtual]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

virtual int vtkPLYWriter::GetColorMode ( ) [virtual]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

void vtkPLYWriter::SetColorModeToDefault ( ) [inline]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

Definition at line 95 of file vtkPLYWriter.h.

void vtkPLYWriter::SetColorModeToUniformCellColor ( ) [inline]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

Definition at line 97 of file vtkPLYWriter.h.

void vtkPLYWriter::SetColorModeToUniformPointColor ( ) [inline]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

Definition at line 99 of file vtkPLYWriter.h.

void vtkPLYWriter::SetColorModeToUniformColor ( ) [inline]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

Definition at line 101 of file vtkPLYWriter.h.

void vtkPLYWriter::SetColorModeToOff ( ) [inline]

These methods enable the user to control how to add color into the PLY output file. The default behavior is as follows. The user provides the name of an array and a component number. If the type of the array is three components, unsigned char, then the data is written as three separate "red", "green" and "blue" properties. If the type is not unsigned char, and a lookup table is provided, then the array/component are mapped through the table to generate three separate "red", "green" and "blue" properties in the PLY file. The user can also set the ColorMode to specify a uniform color for the whole part (on a vertex colors, face colors, or both. (Note: vertex colors or cell colors may be written, depending on where the named array is found. If points and cells have the arrays with the same name, then both colors will be written.)

Definition at line 103 of file vtkPLYWriter.h.

virtual void vtkPLYWriter::SetArrayName ( const char * ) [virtual]

Specify the array name to use to color the data.

virtual char* vtkPLYWriter::GetArrayName ( ) [virtual]

Specify the array name to use to color the data.

virtual void vtkPLYWriter::SetComponent ( int ) [virtual]

Specify the array component to use to color the data.

virtual int vtkPLYWriter::GetComponent ( ) [virtual]

Specify the array component to use to color the data.

virtual void vtkPLYWriter::SetLookupTable ( vtkScalarsToColors * ) [virtual]

A lookup table can be specified in order to convert data arrays to RGBA colors.

virtual vtkScalarsToColors* vtkPLYWriter::GetLookupTable ( ) [virtual]

A lookup table can be specified in order to convert data arrays to RGBA colors.

virtual void vtkPLYWriter::SetColor | ( | unsigned | char,
 |  | unsigned | char,
 |  | unsigned | char
 | ) | [virtual]

Set the color to use when using a uniform color (either point or cells, or both). The color is specified as a triplet of three unsigned chars between (0,255). This only takes effect when the ColorMode is set to uniform point, uniform cell, or uniform color.

virtual void vtkPLYWriter::SetColor ( unsigned char[3] ) [virtual]

Set the color to use when using a uniform color (either point or cells, or both). The color is specified as a triplet of three unsigned chars between (0,255). This only takes effect when the ColorMode is set to uniform point, uniform cell, or uniform color.

virtual unsigned char* vtkPLYWriter::GetColor ( ) [virtual]

Set the color to use when using a uniform color (either point or cells, or both). The color is specified as a triplet of three unsigned chars between (0,255). This only takes effect when the ColorMode is set to uniform point, uniform cell, or uniform color.

virtual void vtkPLYWriter::GetColor | ( | unsigned char & | ,
 |  | unsigned char & | ,
 |  | unsigned char & |
 | ) | [virtual]

Set the color to use when using a uniform color (either point or cells, or both). The color is specified as a triplet of three unsigned chars between (0,255). This only takes effect when the ColorMode is set to uniform point, uniform cell, or uniform color.

virtual void vtkPLYWriter::GetColor ( unsigned char[3] ) [virtual]

Set the color to use when using a uniform color (either point or cells, or both). The color is specified as a triplet of three unsigned chars between (0,255). This only takes effect when the ColorMode is set to uniform point, uniform cell, or uniform color.

void vtkPLYWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

unsigned char* vtkPLYWriter::GetColors | ( | vtkIdType | num,
 |  | vtkDataSetAttributes * | dsa
 | ) | [protected]

Member Data Documentation

int vtkPLYWriter::DataByteOrder [protected]

Definition at line 142 of file vtkPLYWriter.h.

char* vtkPLYWriter::ArrayName [protected]

Definition at line 143 of file vtkPLYWriter.h.

int vtkPLYWriter::Component [protected]

Definition at line 144 of file vtkPLYWriter.h.

int vtkPLYWriter::ColorMode [protected]

Definition at line 145 of file vtkPLYWriter.h.

vtkScalarsToColors* vtkPLYWriter::LookupTable [protected]

Definition at line 146 of file vtkPLYWriter.h.

unsigned char vtkPLYWriter::Color[3] [protected]

Definition at line 147 of file vtkPLYWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkPLYWriter.h
Generated on Mon Mar 25 01:27:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNGReader Class Reference

read PNG files. More...

#include <vtkPNGReader.h>

Inheritance diagram for vtkPNGReader:

[legend]
Collaboration diagram for vtkPNGReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPNGReader, vtkImageReader2)

Static Public Methods

vtkPNGReader * | New ()

Protected Methods

vtkPNGReader ()
~vtkPNGReader ()
virtual vtkImageReader2 * | MakeObject ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)
virtual int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Detailed Description

read PNG files.

Date:
2002/01/31 23:53:13
Revision:
1.9

vtkPNGReader is a source object that reads PNG files. It should be able to read most any PNG file

See also:
vtkPNGWriter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (80%)
  • Hoffman, Bill (18%)
Tests:
vtkPNGReader (Tests)

Definition at line 45 of file vtkPNGReader.h.

Constructor & Destructor Documentation

vtkPNGReader::vtkPNGReader ( ) [inline, protected]

Definition at line 52 of file vtkPNGReader.h.

vtkPNGReader::~vtkPNGReader ( ) [inline, protected]

Definition at line 53 of file vtkPNGReader.h.

Member Function Documentation

vtkPNGReader* vtkPNGReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Referenced by MakeObject().

vtkPNGReader::vtkTypeRevisionMacro | ( | vtkPNGReader | ,
 |  | vtkImageReader2 |
 | ) |

Reimplemented from vtkImageReader2.

virtual vtkImageReader2* vtkPNGReader::MakeObject ( ) [inline, protected, virtual]

Set/Get the internal file name

Reimplemented from vtkImageReader2.

Definition at line 54 of file vtkPNGReader.h.

virtual int vtkPNGReader::CanReadFile ( const char * fname ) [protected, virtual]

virtual const char* vtkPNGReader::GetFileExensions ( ) [inline, protected, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented from vtkImageReader2.

Definition at line 62 of file vtkPNGReader.h.

virtual const char* vtkPNGReader::GetDescriptiveName ( ) [inline, protected, virtual]

Return a descriptive name for the file format that might be useful in a GUI.

Reimplemented from vtkImageReader2.

Definition at line 71 of file vtkPNGReader.h.

virtual void vtkPNGReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

virtual void vtkPNGReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

The documentation for this class was generated from the following file:
  • IO/vtkPNGReader.h
Generated on Mon Mar 25 01:27:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNGWriter Class Reference

Writes PNG files. More...

#include <vtkPNGWriter.h>

Inheritance diagram for vtkPNGWriter:

[legend]
Collaboration diagram for vtkPNGWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPNGWriter, vtkImageWriter)
virtual void | Write ()

Static Public Methods

vtkPNGWriter * | New ()

Protected Methods

vtkPNGWriter ()
~vtkPNGWriter ()
void | WriteSlice (vtkImageData *data)

Detailed Description

Writes PNG files.

Date:
2002/01/22 15:38:19
Revision:
1.6

vtkPNGWriter writes PNG files. It supports 1 to 4 component data of unsigned char or unsigned short

See also:
vtkPNGReader
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (97%)
Examples:
vtkPNGWriter (Examples)
Tests:
vtkPNGWriter (Tests)

Definition at line 46 of file vtkPNGWriter.h.

Constructor & Destructor Documentation

vtkPNGWriter::vtkPNGWriter ( ) [protected]

vtkPNGWriter::~vtkPNGWriter ( ) [inline, protected]

Definition at line 57 of file vtkPNGWriter.h.

Member Function Documentation

vtkPNGWriter* vtkPNGWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkPNGWriter::vtkTypeRevisionMacro | ( | vtkPNGWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

virtual void vtkPNGWriter::Write ( ) [virtual]

The main interface which triggers the writer to start.

Reimplemented from vtkImageWriter.

void vtkPNGWriter::WriteSlice ( vtkImageData * data ) [protected]

The documentation for this class was generated from the following file:
  • IO/vtkPNGWriter.h
Generated on Mon Mar 25 01:27:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNMReader Class Reference

read pnm (i.e., portable anymap) files. More...

#include <vtkPNMReader.h>

Inheritance diagram for vtkPNMReader:

[legend]
Collaboration diagram for vtkPNMReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPNMReader, vtkImageReader)
virtual vtkImageReader2 * | MakeObject ()
int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkPNMReader * | New ()

Protected Methods

vtkPNMReader ()
~vtkPNMReader ()
void | ExecuteInformation ()

Detailed Description

read pnm (i.e., portable anymap) files.

Date:
2002/01/31 23:53:14
Revision:
1.19

vtkPNMReader is a source object that reads pnm (portable anymap) files. This includes .pbm (bitmap), .pgm (grayscale), and .ppm (pixmap) files. (Currently this object only reads binary versions of these files.)

PNMReader creates structured point datasets. The dimension of the dataset depends upon the number of files read. Reading a single file results in a 2D image, while reading more than one file results in a 3D volume.

To read a volume, files must be of the form "FileName.<number>" (e.g., foo.ppm.0, foo.ppm.1, ...). You must also specify the DataExtent. The fifth and sixth values of the DataExtent specify the beginning and ending files to read.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (64%)
  • Hoffman, Bill (15%)
  • Miller, Jim (12%)
Tests:
vtkPNMReader (Tests)

Definition at line 55 of file vtkPNMReader.h.

Constructor & Destructor Documentation

vtkPNMReader::vtkPNMReader ( ) [inline, protected]

Definition at line 80 of file vtkPNMReader.h.

vtkPNMReader::~vtkPNMReader ( ) [inline, protected]

Definition at line 81 of file vtkPNMReader.h.

Member Function Documentation

vtkPNMReader* vtkPNMReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader.

Referenced by MakeObject().

vtkPNMReader::vtkTypeRevisionMacro | ( | vtkPNMReader | ,
 |  | vtkImageReader |
 | ) |

Reimplemented from vtkImageReader.

virtual vtkImageReader2* vtkPNMReader::MakeObject ( ) [inline, virtual]

Set/Get the internal file name

Reimplemented from vtkImageReader2.

Definition at line 61 of file vtkPNMReader.h.

int vtkPNMReader::CanReadFile ( const char * fname )

virtual const char* vtkPNMReader::GetFileExensions ( ) [inline, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented from vtkImageReader2.

Definition at line 65 of file vtkPNMReader.h.

virtual const char* vtkPNMReader::GetDescriptiveName ( ) [inline, virtual]

PNM

Reimplemented from vtkImageReader2.

Definition at line 73 of file vtkPNMReader.h.

void vtkPNMReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader.

The documentation for this class was generated from the following file:
  • IO/vtkPNMReader.h
Generated on Mon Mar 25 01:27:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPNMWriter Class Reference

Writes PNM (portable any map) files. More...

#include <vtkPNMWriter.h>

Inheritance diagram for vtkPNMWriter:

[legend]
Collaboration diagram for vtkPNMWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPNMWriter, vtkImageWriter)

Static Public Methods

vtkPNMWriter * | New ()

Protected Methods

vtkPNMWriter ()
~vtkPNMWriter ()
virtual void | WriteFile (ofstream *file, vtkImageData *data, int extent[6])
virtual void | WriteFileHeader (ofstream *, vtkImageData *)

Detailed Description

Writes PNM (portable any map) files.

Date:
2002/01/22 15:38:19
Revision:
1.18

vtkPNMWriter writes PNM file. The data type of the file is unsigned char regardless of the input type.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (96%)
Tests:
vtkPNMWriter (Tests)

Definition at line 40 of file vtkPNMWriter.h.

Constructor & Destructor Documentation

vtkPNMWriter::vtkPNMWriter ( ) [inline, protected]

Definition at line 47 of file vtkPNMWriter.h.

vtkPNMWriter::~vtkPNMWriter ( ) [inline, protected]

Definition at line 48 of file vtkPNMWriter.h.

Member Function Documentation

vtkPNMWriter* vtkPNMWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkPNMWriter::vtkTypeRevisionMacro | ( | vtkPNMWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

virtual void vtkPNMWriter::WriteFile | ( | ofstream * | file,
 |  | vtkImageData * | data,
 |  | int | extent[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkPNMWriter::WriteFileHeader | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

The documentation for this class was generated from the following file:
  • IO/vtkPNMWriter.h
Generated on Mon Mar 25 01:27:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointData Class Reference

represent and manipulate point attribute data. More...

#include <vtkPointData.h>

Inheritance diagram for vtkPointData:

[legend]
Collaboration diagram for vtkPointData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointData, vtkDataSetAttributes)
void | PrintSelf (ostream &os, vtkIndent indent)
void | NullPoint (vtkIdType ptId)

Static Public Methods

vtkPointData * | New ()

Protected Methods

vtkPointData ()
~vtkPointData ()

Detailed Description

represent and manipulate point attribute data.

Date:
2002/01/22 15:25:57
Revision:
1.56

vtkPointData is a class that is used to represent and manipulate point attribute data (e.g., scalars, vectors, normals, texture coordinates, etc.) Most of the functionality is handled by vtkDataSetAttributes

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (83%)
  • Martin, Ken (13%)
Tests:
vtkPointData (Tests)

Definition at line 43 of file vtkPointData.h.

Constructor & Destructor Documentation

vtkPointData::vtkPointData ( ) [inline, protected]

Definition at line 53 of file vtkPointData.h.

vtkPointData::~vtkPointData ( ) [inline, protected]

Definition at line 54 of file vtkPointData.h.

Member Function Documentation

vtkPointData* vtkPointData::New ( ) [static]

Construct object with copying turned on for all data.

Reimplemented from vtkDataSetAttributes.

vtkPointData::vtkTypeRevisionMacro | ( | vtkPointData | ,
 |  | vtkDataSetAttributes |
 | ) |

Reimplemented from vtkDataSetAttributes.

void vtkPointData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSetAttributes.

void vtkPointData::NullPoint ( vtkIdType ptId )

The documentation for this class was generated from the following file:
  • Common/vtkPointData.h
Generated on Mon Mar 25 01:27:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointDataToCellData Class Reference

map point data to cell data. More...

#include <vtkPointDataToCellData.h>

Inheritance diagram for vtkPointDataToCellData:

[legend]
Collaboration diagram for vtkPointDataToCellData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointDataToCellData, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPassPointData (int)
virtual int | GetPassPointData ()
virtual void | PassPointDataOn ()
virtual void | PassPointDataOff ()

Static Public Methods

vtkPointDataToCellData * | New ()

Protected Methods

vtkPointDataToCellData ()
~vtkPointDataToCellData ()
void | Execute ()

Protected Attributes

int | PassPointData

Detailed Description

map point data to cell data.

Date:
2002/01/22 15:29:34
Revision:
1.17

vtkPointDataToCellData is a filter that transforms point data (i.e., data specified per point) into cell data (i.e., data specified per cell). The method of transformation is based on averaging the data values of all points defining a particular cell. Optionally, the input point data can be passed through to the output as well.

Warning:
This filter is an abstract filter, that is, the output is an abstract type (i.e., vtkDataSet). Use the convenience methods (e.g., vtkGetPolyDataOutput(), GetStructuredPointsOutput(), etc.) to get the type of output you want.
See also:
vtkDataSetToDataSetFilter vtkPointData vtkCellData vtkCellDataToPointData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Law, Charles (6%)
  • Geveci, Berk (5%)
Examples:
vtkPointDataToCellData (Examples)
Tests:
vtkPointDataToCellData (Tests)

Definition at line 57 of file vtkPointDataToCellData.h.

Constructor & Destructor Documentation

vtkPointDataToCellData::vtkPointDataToCellData ( ) [protected]

vtkPointDataToCellData::~vtkPointDataToCellData ( ) [inline, protected]

Definition at line 75 of file vtkPointDataToCellData.h.

Member Function Documentation

vtkPointDataToCellData* vtkPointDataToCellData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkPointDataToCellData::vtkTypeRevisionMacro | ( | vtkPointDataToCellData | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkPointDataToCellData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkPointDataToCellData::SetPassPointData ( int ) [virtual]

Control whether the input point data is to be passed to the output. If on, then the input point data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual int vtkPointDataToCellData::GetPassPointData ( ) [virtual]

Control whether the input point data is to be passed to the output. If on, then the input point data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual void vtkPointDataToCellData::PassPointDataOn ( ) [virtual]

Control whether the input point data is to be passed to the output. If on, then the input point data is passed through to the output; otherwise, only generated point data is placed into the output.

virtual void vtkPointDataToCellData::PassPointDataOff ( ) [virtual]

Control whether the input point data is to be passed to the output. If on, then the input point data is passed through to the output; otherwise, only generated point data is placed into the output.

void vtkPointDataToCellData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkPointDataToCellData::PassPointData [protected]

Definition at line 79 of file vtkPointDataToCellData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPointDataToCellData.h
Generated on Mon Mar 25 01:27:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLoad Class Reference

compute stress tensors given point load on semi-infinite domain. More...

#include <vtkPointLoad.h>

Inheritance diagram for vtkPointLoad:

[legend]
Collaboration diagram for vtkPointLoad:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointLoad, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSampleDimensions (int i, int j, int k)
virtual void | SetLoadValue (float)
virtual float | GetLoadValue ()
void | SetSampleDimensions (int dim[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetModelBounds (float, float, float, float, float, float)
virtual void | SetModelBounds (float[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetPoissonsRatio (float)
virtual float | GetPoissonsRatio ()
virtual void | SetComputeEffectiveStress (int)
virtual int | GetComputeEffectiveStress ()
virtual void | ComputeEffectiveStressOn ()
virtual void | ComputeEffectiveStressOff ()

Static Public Methods

vtkPointLoad * | New ()

Protected Methods

vtkPointLoad ()
~vtkPointLoad ()
void | Execute ()

Protected Attributes

float | LoadValue
float | PoissonsRatio
int | SampleDimensions [3]
float | ModelBounds [6]
int | ComputeEffectiveStress

Detailed Description

compute stress tensors given point load on semi-infinite domain.

Date:
2002/01/22 15:33:43
Revision:
1.35

vtkPointLoad is a source object that computes stress tensors on a volume. The tensors are computed from the application of a point load on a semi-infinite domain. (The analytical results are adapted from Saada - see text.) It also is possible to compute effective stress scalars if desired. This object serves as a specialized data generator for some of the examples in the text.

See also:
vtkTensorGlyph, vtkHyperStreamline
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Martin, Ken (11%)
  • Geveci, Berk (7%)
Tests:
vtkPointLoad (Tests)

Definition at line 49 of file vtkPointLoad.h.

Constructor & Destructor Documentation

vtkPointLoad::vtkPointLoad ( ) [protected]

vtkPointLoad::~vtkPointLoad ( ) [inline, protected]

Definition at line 98 of file vtkPointLoad.h.

Member Function Documentation

vtkPointLoad::vtkTypeRevisionMacro | ( | vtkPointLoad | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

void vtkPointLoad::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPointLoad* vtkPointLoad::New ( ) [static]

Construct with ModelBounds=(-1,1,-1,1,-1,1), SampleDimensions=(50,50,50), and LoadValue = 1.

Reimplemented from vtkStructuredPointsSource.

virtual void vtkPointLoad::SetLoadValue ( float ) [virtual]

Set/Get value of applied load.

virtual float vtkPointLoad::GetLoadValue ( ) [virtual]

Set/Get value of applied load.

void vtkPointLoad::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Specify the dimensions of the volume. A stress tensor will be computed for each point in the volume.

void vtkPointLoad::SetSampleDimensions ( int dim[3] )

Specify the dimensions of the volume. A stress tensor will be computed for each point in the volume.

virtual int* vtkPointLoad::GetSampleDimensions ( ) [virtual]

Specify the dimensions of the volume. A stress tensor will be computed for each point in the volume.

virtual void vtkPointLoad::GetSampleDimensions ( int data[3] ) [virtual]

Specify the dimensions of the volume. A stress tensor will be computed for each point in the volume.

virtual void vtkPointLoad::SetModelBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the region in space over which the tensors are computed. The point load is assumed to be applied at top center of the volume.

virtual void vtkPointLoad::SetModelBounds ( float [6] ) [virtual]

Specify the region in space over which the tensors are computed. The point load is assumed to be applied at top center of the volume.

virtual float* vtkPointLoad::GetModelBounds ( ) [virtual]

Specify the region in space over which the tensors are computed. The point load is assumed to be applied at top center of the volume.

virtual void vtkPointLoad::GetModelBounds ( float data[6] ) [virtual]

Specify the region in space over which the tensors are computed. The point load is assumed to be applied at top center of the volume.

virtual void vtkPointLoad::SetPoissonsRatio ( float ) [virtual]

Set/Get Poisson's ratio.

virtual float vtkPointLoad::GetPoissonsRatio ( ) [virtual]

Set/Get Poisson's ratio.

virtual void vtkPointLoad::SetComputeEffectiveStress ( int ) [virtual]

Turn on/off computation of effective stress scalar.

virtual int vtkPointLoad::GetComputeEffectiveStress ( ) [virtual]

Turn on/off computation of effective stress scalar.

virtual void vtkPointLoad::ComputeEffectiveStressOn ( ) [virtual]

Turn on/off computation of effective stress scalar.

virtual void vtkPointLoad::ComputeEffectiveStressOff ( ) [virtual]

Turn on/off computation of effective stress scalar.

void vtkPointLoad::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkPointLoad::LoadValue [protected]

Definition at line 102 of file vtkPointLoad.h.

float vtkPointLoad::PoissonsRatio [protected]

Definition at line 103 of file vtkPointLoad.h.

int vtkPointLoad::SampleDimensions[3] [protected]

Definition at line 104 of file vtkPointLoad.h.

float vtkPointLoad::ModelBounds[6] [protected]

Definition at line 105 of file vtkPointLoad.h.

int vtkPointLoad::ComputeEffectiveStress [protected]

Definition at line 106 of file vtkPointLoad.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkPointLoad.h
Generated on Mon Mar 25 01:27:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLocator Class Reference

quickly locate points in 3-space. More...

#include <vtkPointLocator.h>

Inheritance diagram for vtkPointLocator:

[legend]
Collaboration diagram for vtkPointLocator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointLocator, vtkLocator)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | InitPointInsertion (vtkPoints *newPts, const float bounds[6])
virtual void | InsertPoint (vtkIdType ptId, const float x[3])
virtual vtkIdType | InsertNextPoint (const float x[3])
virtual int | InsertUniquePoint (const float x[3], vtkIdType &ptId)
virtual vtkIdType | FindClosestInsertedPoint (const float x[3])
virtual vtkIdList * | GetPointsInBucket (const float x[3], int ijk[3])
virtual void | SetDivisions (int, int, int)
virtual void | SetDivisions (int[3])
virtual int * | GetDivisions ()
virtual void | GetDivisions (int data[3])
virtual void | SetNumberOfPointsPerBucket (int)
virtual int | GetNumberOfPointsPerBucket ()
virtual vtkIdType | FindClosestPoint (const float x[3])
vtkIdType | FindClosestPoint (float x, float y, float z)
vtkIdType | FindClosestPointWithinRadius (float radius, const float x[3], float &dist2)
vtkIdType | FindClosestPointWithinRadius (float radius, const float x[3], float inputDataLength, float &dist2)
virtual int | InitPointInsertion (vtkPoints *newPts, const float bounds[6], vtkIdType estSize)
vtkIdType | IsInsertedPoint (float x, float y, float z)
virtual vtkIdType | IsInsertedPoint (const float x[3])
virtual void | FindClosestNPoints (int N, const float x[3], vtkIdList *result)
virtual void | FindClosestNPoints (int N, float x, float y, float z, vtkIdList *result)
virtual void | FindDistributedPoints (int N, const float x[3], vtkIdList *result, int M)
virtual void | FindDistributedPoints (int N, float x, float y, float z, vtkIdList *result, int M)
virtual void | FindPointsWithinRadius (float R, const float x[3], vtkIdList *result)
virtual void | FindPointsWithinRadius (float R, float x, float y, float z, vtkIdList *result)
void | Initialize ()
void | FreeSearchStructure ()
void | BuildLocator ()
void | GenerateRepresentation (int level, vtkPolyData *pd)

Static Public Methods

vtkPointLocator * | New ()

Protected Methods

vtkPointLocator ()
~vtkPointLocator ()
void | GetBucketNeighbors (vtkNeighborPoints *buckets, const int ijk[3], const int ndivs[3], int level)
void | GetOverlappingBuckets (vtkNeighborPoints *buckets, const float x[3], const int ijk[3], float dist, int level)
void | GetOverlappingBuckets (vtkNeighborPoints *buckets, const float x[3], float dist, int prevMinLevel[3], int prevMaxLevel[3])
void | GenerateFace (int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys)
float | Distance2ToBucket (const float x[3], const int nei[3])
float | Distance2ToBounds (const float x[3], const float bounds[6])

Protected Attributes

vtkPoints * Points
int | Divisions [3]
int | NumberOfPointsPerBucket
float | Bounds [6]
vtkIdList ** HashTable
vtkIdType NumberOfBuckets
float | H [3]
float | InsertionTol2
vtkIdType InsertionPointId
float | InsertionLevel

Detailed Description

quickly locate points in 3-space.

Date:
2002/01/22 15:25:58
Revision:
1.49

vtkPointLocator is a spatial search object to quickly locate points in 3D. vtkPointLocator works by dividing a specified region of space into a regular array of "rectangular" buckets, and then keeping a list of points that lie in each bucket. Typical operation involves giving a position in 3D and finding the closest point.

vtkPointLocator has two distinct methods of interaction. In the first method, you supply it with a dataset, and it operates on the points in the dataset. In the second method, you supply it with an array of points, and the object operates on the array.

Warning:
Many other types of spatial locators have been developed such as octrees and kd-trees. These are often more efficient for the operations described here.
See also:
vtkCellPicker vtkPointPicker
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (18%)
  • Blue, Rusty (12%)
  • Lorensen, Bill (9%)
  • Miller, Jim (7%)
  • Geveci, Berk (5%)
Tests:
vtkPointLocator (Tests)

Definition at line 65 of file vtkPointLocator.h.

Constructor & Destructor Documentation

vtkPointLocator::vtkPointLocator ( ) [protected]

vtkPointLocator::~vtkPointLocator ( ) [protected]

Member Function Documentation

vtkPointLocator* vtkPointLocator::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 points per bucket.

Reimplemented from vtkObject.

Reimplemented in vtkMergePoints.

vtkPointLocator::vtkTypeRevisionMacro | ( | vtkPointLocator | ,
 |  | vtkLocator |
 | ) |

Reimplemented from vtkLocator.

Reimplemented in vtkMergePoints.

void vtkPointLocator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLocator.

virtual void vtkPointLocator::SetDivisions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the number of divisions in x-y-z directions.

virtual void vtkPointLocator::SetDivisions ( int [3] ) [virtual]

Set the number of divisions in x-y-z directions.

virtual int* vtkPointLocator::GetDivisions ( ) [virtual]

Set the number of divisions in x-y-z directions.

virtual void vtkPointLocator::GetDivisions ( int data[3] ) [virtual]

Set the number of divisions in x-y-z directions.

virtual void vtkPointLocator::SetNumberOfPointsPerBucket ( int ) [virtual]

Specify the average number of points in each bucket.

virtual int vtkPointLocator::GetNumberOfPointsPerBucket ( ) [virtual]

Specify the average number of points in each bucket.

virtual vtkIdType vtkPointLocator::FindClosestPoint ( const float x[3] ) [virtual]

Given a position x, return the id of the point closest to it. Alternative method requires separate x-y-z values. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

vtkIdType vtkPointLocator::FindClosestPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Given a position x, return the id of the point closest to it. Alternative method requires separate x-y-z values. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

vtkIdType vtkPointLocator::FindClosestPointWithinRadius | ( | float | radius,
 |  | const float | x[3],
 |  | float & | dist2
 | ) |

Given a position x and a radius r, return the id of the point closest to the point in that radius. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

vtkIdType vtkPointLocator::FindClosestPointWithinRadius | ( | float | radius,
 |  | const float | x[3],
 |  | float | inputDataLength,
 |  | float & | dist2
 | ) |

Given a position x and a radius r, return the id of the point closest to the point in that radius. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual int vtkPointLocator::InitPointInsertion | ( | vtkPoints * | newPts,
 |  | const float | bounds[6]
 | ) | [virtual]

Initialize the point insertion process. The newPts is an object representing point coordinates into which incremental insertion methods place their data. Bounds are the box that the points lie in. Not thread safe.

virtual int vtkPointLocator::InitPointInsertion | ( | vtkPoints * | newPts,
 |  | const float | bounds[6],
 |  | vtkIdType | estSize
 | ) | [virtual]

Initialize the point insertion process. The newPts is an object representing point coordinates into which incremental insertion methods place their data. Bounds are the box that the points lie in. Not thread safe.

virtual void vtkPointLocator::InsertPoint | ( | vtkIdType | ptId,
 |  | const float | x[3]
 | ) | [virtual]

Incrementally insert a point into search structure with a particular index value. You should use the method IsInsertedPoint() to see whether this point has already been inserted (that is, if you desire to prevent duplicate points). Before using this method you must make sure that newPts have been supplied, the bounds has been set properly, and that divs are properly set. (See InitPointInsertion().) Not thread safe.

virtual vtkIdType vtkPointLocator::InsertNextPoint ( const float x[3] ) [virtual]

Incrementally insert a point into search structure. The method returns the insertion location (i.e., point id). You should use the method IsInsertedPoint() to see whether this point has already been inserted (that is, if you desire to prevent duplicate points). Before using this method you must make sure that newPts have been supplied, the bounds has been set properly, and that divs are properly set. (See InitPointInsertion().) Not thread safe.

vtkIdType vtkPointLocator::IsInsertedPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Determine whether point given by x[3] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1. This method is thread safe.

Reimplemented in vtkMergePoints.

Definition at line 144 of file vtkPointLocator.h.

Referenced by vtkMergePoints::IsInsertedPoint().

virtual vtkIdType vtkPointLocator::IsInsertedPoint ( const float x[3] ) [virtual]

Determine whether point given by x[3] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1. This method is thread safe.

Reimplemented in vtkMergePoints.

virtual int vtkPointLocator::InsertUniquePoint | ( | const float | x[3],
 |  | vtkIdType & | ptId
 | ) | [virtual]

Determine whether point given by x[3] has been inserted into points list. Return 0 if point was already in the list, otherwise return 1. If the point was not in the list, it will be ADDED. In either case, the id of the point (newly inserted or not) is returned in the ptId argument. Note this combines the functionality of IsInsertedPoint() followed by a call to InsertNextPoint(). This method is not thread safe.

Reimplemented in vtkMergePoints.

Referenced by vtkNonLinearCell::InsertPoint().

virtual vtkIdType vtkPointLocator::FindClosestInsertedPoint ( const float x[3] ) [virtual]

Given a position x, return the id of the point closest to it. This method is used when performing incremental point insertion. Note that -1 indicates that no point was found. This method is thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindClosestNPoints | ( | int | N,
 |  | const float | x[3],
 |  | vtkIdList * | result
 | ) | [virtual]

Find the closest N points to a position. This returns the closest N points to a position. A faster method could be created that returned N close points to a position, but necessarily the exact N closest. The returned points are sorted from closest to farthest. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindClosestNPoints | ( | int | N,
 |  | float | x,
 |  | float | y,
 |  | float | z,
 |  | vtkIdList * | result
 | ) | [virtual]

Find the closest N points to a position. This returns the closest N points to a position. A faster method could be created that returned N close points to a position, but necessarily the exact N closest. The returned points are sorted from closest to farthest. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindDistributedPoints | ( | int | N,
 |  | const float | x[3],
 |  | vtkIdList * | result,
 |  | int | M
 | ) | [virtual]

Find the closest points to a position such that each octant of space around the position contains at least N points. Loosely limit the search to a maximum number of points evaluated, M. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindDistributedPoints | ( | int | N,
 |  | float | x,
 |  | float | y,
 |  | float | z,
 |  | vtkIdList * | result,
 |  | int | M
 | ) | [virtual]

Find the closest points to a position such that each octant of space around the position contains at least N points. Loosely limit the search to a maximum number of points evaluated, M. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindPointsWithinRadius | ( | float | R,
 |  | const float | x[3],
 |  | vtkIdList * | result
 | ) | [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual void vtkPointLocator::FindPointsWithinRadius | ( | float | R,
 |  | float | x,
 |  | float | y,
 |  | float | z,
 |  | vtkIdList * | result
 | ) | [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner. These methods are thread safe if BuildLocator() is directly or indirectly called from a single thread first.

virtual vtkIdList* vtkPointLocator::GetPointsInBucket | ( | const float | x[3],
 |  | int | ijk[3]
 | ) | [virtual]

Given a position x, return the list of points in the bucket that contains the point. It is possible that NULL is returned. The user provides an ijk array that is the indices into the locator. This method is thread safe.

void vtkPointLocator::Initialize ( ) [virtual]

See vtkLocator interface documentation. These methods are not thread safe.

Reimplemented from vtkLocator.

void vtkPointLocator::FreeSearchStructure ( ) [virtual]

See vtkLocator interface documentation. These methods are not thread safe.

Reimplemented from vtkLocator.

void vtkPointLocator::BuildLocator ( ) [virtual]

See vtkLocator interface documentation. These methods are not thread safe.

Reimplemented from vtkLocator.

void vtkPointLocator::GenerateRepresentation | ( | int | level,
 |  | vtkPolyData * | pd
 | ) | [virtual]

See vtkLocator interface documentation. These methods are not thread safe.

Reimplemented from vtkLocator.

void vtkPointLocator::GetBucketNeighbors | ( | vtkNeighborPoints * | buckets,
 |  | const int | ijk[3],
 |  | const int | ndivs[3],
 |  | int | level
 | ) | [protected]

void vtkPointLocator::GetOverlappingBuckets | ( | vtkNeighborPoints * | buckets,
 |  | const float | x[3],
 |  | const int | ijk[3],
 |  | float | dist,
 |  | int | level
 | ) | [protected]

void vtkPointLocator::GetOverlappingBuckets | ( | vtkNeighborPoints * | buckets,
 |  | const float | x[3],
 |  | float | dist,
 |  | int | prevMinLevel[3],
 |  | int | prevMaxLevel[3]
 | ) | [protected]

void vtkPointLocator::GenerateFace | ( | int | face,
 |  | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

float vtkPointLocator::Distance2ToBucket | ( | const float | x[3],
 |  | const int | nei[3]
 | ) | [protected]

float vtkPointLocator::Distance2ToBounds | ( | const float | x[3],
 |  | const float | bounds[6]
 | ) | [protected]

Member Data Documentation

vtkPoints* vtkPointLocator::Points [protected]

Definition at line 238 of file vtkPointLocator.h.

int vtkPointLocator::Divisions[3] [protected]

Definition at line 239 of file vtkPointLocator.h.

int vtkPointLocator::NumberOfPointsPerBucket [protected]

Definition at line 240 of file vtkPointLocator.h.

float vtkPointLocator::Bounds[6] [protected]

Definition at line 241 of file vtkPointLocator.h.

vtkIdList** vtkPointLocator::HashTable [protected]

Definition at line 242 of file vtkPointLocator.h.

vtkIdType vtkPointLocator::NumberOfBuckets [protected]

Definition at line 243 of file vtkPointLocator.h.

float vtkPointLocator::H[3] [protected]

Definition at line 244 of file vtkPointLocator.h.

float vtkPointLocator::InsertionTol2 [protected]

Definition at line 246 of file vtkPointLocator.h.

vtkIdType vtkPointLocator::InsertionPointId [protected]

Definition at line 247 of file vtkPointLocator.h.

float vtkPointLocator::InsertionLevel [protected]

Definition at line 249 of file vtkPointLocator.h.

The documentation for this class was generated from the following file:
  • Common/vtkPointLocator.h
Generated on Mon Mar 25 01:27:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointLocator2D Class Reference

quickly locate points in 2-space. More...

#include <vtkPointLocator2D.h>

Inheritance diagram for vtkPointLocator2D:

[legend]
Collaboration diagram for vtkPointLocator2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointLocator2D, vtkLocator)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | FindClosestPoint (float x[2])
virtual int | IsInsertedPoint (float x[2])
virtual void | SetDivisions (int, int)
void | SetDivisions (int[2])
virtual int * | GetDivisions ()
virtual void | GetDivisions (int data[2])
virtual void | SetNumberOfPointsPerBucket (int)
virtual int | GetNumberOfPointsPerBucket ()
virtual void | FindClosestNPoints (int N, float x[2], vtkIdList *result)
virtual void | FindClosestNPoints (int N, float x, float y, vtkIdList *result)
virtual void | FindDistributedPoints (int N, float x[2], vtkIdList *result, int M)
virtual void | FindDistributedPoints (int N, float x, float y, vtkIdList *result, int M)
virtual void | FindPointsWithinRadius (float R, float x[2], vtkIdList *result)
virtual void | FindPointsWithinRadius (float R, float x, float y, vtkIdList *result)
void | Initialize ()
void | FreeSearchStructure ()
void | BuildLocator ()
void | GenerateRepresentation (int level, vtkPolyData *pd)
virtual void | SetPoints (vtkPoints *)
virtual vtkPoints * | GetPoints ()

Static Public Methods

vtkPointLocator2D * | New ()

Protected Methods

vtkPointLocator2D ()
~vtkPointLocator2D ()
void | GetBucketNeighbors (int ijk[2], int ndivs[2], int level)
void | GetOverlappingBuckets (float x[2], int ijk[2], float dist, int level)
void | GenerateFace (int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys)

Protected Attributes

vtkPoints * Points
int | Divisions [2]
int | NumberOfPointsPerBucket
float | Bounds [4]
vtkIdList ** HashTable
int | NumberOfBuckets
float | H [2]
vtkNeighborPoints2D * | Buckets
float | InsertionTol2

Detailed Description

quickly locate points in 2-space.

Date:
2002/01/22 15:25:59
Revision:
1.19

vtkPointLocator2D is a spatial search object to quickly locate points in 2D. vtkPointLocator2D works by dividing a specified region of space into a regular array of "rectangular" buckets, and then keeping a list of points that lie in each bucket. Typical operation involves giving a position in 2D and finding the closest point.

vtkPointLocator2D has two distinct methods of interaction. In the first method, you supply it with a dataset, and it operates on the points in the dataset. In the second method, you supply it with an array of points, and the object operates on the array.

This class is similar to vtkPointLocator except that it assumes the points are located in 2D (or at least that the z-coordinate is ignored).

Warning:
Many other types of spatial locators have been developed such as octrees and kd-trees. These are often more efficient for the operations described here.
See also:
vtkPointLocator vtkCellPicker vtkPointPicker
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (78%)
  • Lorensen, Bill (15%)
  • Miller, Jim (5%)

Definition at line 62 of file vtkPointLocator2D.h.

Constructor & Destructor Documentation

vtkPointLocator2D::vtkPointLocator2D ( ) [protected]

vtkPointLocator2D::~vtkPointLocator2D ( ) [protected]

Member Function Documentation

vtkPointLocator2D* vtkPointLocator2D::New ( ) [static]

Construct with automatic computation of divisions, averaging 25 points per bucket.

Reimplemented from vtkObject.

Reimplemented in vtkMergePoints2D.

vtkPointLocator2D::vtkTypeRevisionMacro | ( | vtkPointLocator2D | ,
 |  | vtkLocator |
 | ) |

Reimplemented from vtkLocator.

Reimplemented in vtkMergePoints2D.

void vtkPointLocator2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLocator.

virtual void vtkPointLocator2D::SetDivisions | ( | int | ,
 |  | int |
 | ) | [virtual]

Set the number of divisions in x-y directions.

void vtkPointLocator2D::SetDivisions ( int [2] )

Set the number of divisions in x-y directions.

virtual int* vtkPointLocator2D::GetDivisions ( ) [virtual]

Set the number of divisions in x-y directions.

virtual void vtkPointLocator2D::GetDivisions ( int data[2] ) [virtual]

Set the number of divisions in x-y directions.

virtual void vtkPointLocator2D::SetNumberOfPointsPerBucket ( int ) [virtual]

Specify the average number of points in each bucket.

virtual int vtkPointLocator2D::GetNumberOfPointsPerBucket ( ) [virtual]

Specify the average number of points in each bucket.

virtual int vtkPointLocator2D::FindClosestPoint ( float x[2] ) [virtual]

Given a position x, return the id of the point closest to it.

virtual int vtkPointLocator2D::IsInsertedPoint ( float x[2] ) [virtual]

Determine whether point given by x[2] has been inserted into points list. Return id of previously inserted point if this is true, otherwise return -1.

Reimplemented in vtkMergePoints2D.

virtual void vtkPointLocator2D::FindClosestNPoints | ( | int | N,
 |  | float | x[2],
 |  | vtkIdList * | result
 | ) | [virtual]

Find the closest N points to a position. This returns the closest N points to a position. A faster method could be created that returned N close points to a position, but necessarily the exact N closest. The returned points are sorted from closest to farthest.

virtual void vtkPointLocator2D::FindClosestNPoints | ( | int | N,
 |  | float | x,
 |  | float | y,
 |  | vtkIdList * | result
 | ) | [virtual]

Find the closest N points to a position. This returns the closest N points to a position. A faster method could be created that returned N close points to a position, but necessarily the exact N closest. The returned points are sorted from closest to farthest.

virtual void vtkPointLocator2D::FindDistributedPoints | ( | int | N,
 |  | float | x[2],
 |  | vtkIdList * | result,
 |  | int | M
 | ) | [virtual]

Find the closest points to a position such that each quadrant of space around the position contains at least N points. Loosely limit the search to a maximum number of points evaluated, M.

virtual void vtkPointLocator2D::FindDistributedPoints | ( | int | N,
 |  | float | x,
 |  | float | y,
 |  | vtkIdList * | result,
 |  | int | M
 | ) | [virtual]

Find the closest points to a position such that each quadrant of space around the position contains at least N points. Loosely limit the search to a maximum number of points evaluated, M.

virtual void vtkPointLocator2D::FindPointsWithinRadius | ( | float | R,
 |  | float | x[2],
 |  | vtkIdList * | result
 | ) | [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

virtual void vtkPointLocator2D::FindPointsWithinRadius | ( | float | R,
 |  | float | x,
 |  | float | y,
 |  | vtkIdList * | result
 | ) | [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

void vtkPointLocator2D::Initialize ( ) [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

Reimplemented from vtkLocator.

void vtkPointLocator2D::FreeSearchStructure ( ) [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

Reimplemented from vtkLocator.

void vtkPointLocator2D::BuildLocator ( ) [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

Reimplemented from vtkLocator.

void vtkPointLocator2D::GenerateRepresentation | ( | int | level,
 |  | vtkPolyData * | pd
 | ) | [virtual]

Find all points within a specified radius R of position x. The result is not sorted in any specific manner.

Reimplemented from vtkLocator.

virtual void vtkPointLocator2D::SetPoints ( vtkPoints * ) [virtual]

set the points to use when looking up a coordinate

virtual vtkPoints* vtkPointLocator2D::GetPoints ( ) [virtual]

set the points to use when looking up a coordinate

void vtkPointLocator2D::GetBucketNeighbors | ( | int | ijk[2],
 |  | int | ndivs[2],
 |  | int | level
 | ) | [protected]

void vtkPointLocator2D::GetOverlappingBuckets | ( | float | x[2],
 |  | int | ijk[2],
 |  | float | dist,
 |  | int | level
 | ) | [protected]

void vtkPointLocator2D::GenerateFace | ( | int | face,
 |  | int | i,
 |  | int | j,
 |  | int | k,
 |  | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

Member Data Documentation

vtkPoints* vtkPointLocator2D::Points [protected]

Definition at line 142 of file vtkPointLocator2D.h.

int vtkPointLocator2D::Divisions[2] [protected]

Definition at line 143 of file vtkPointLocator2D.h.

int vtkPointLocator2D::NumberOfPointsPerBucket [protected]

Definition at line 144 of file vtkPointLocator2D.h.

float vtkPointLocator2D::Bounds[4] [protected]

Definition at line 145 of file vtkPointLocator2D.h.

vtkIdList** vtkPointLocator2D::HashTable [protected]

Definition at line 146 of file vtkPointLocator2D.h.

int vtkPointLocator2D::NumberOfBuckets [protected]

Definition at line 147 of file vtkPointLocator2D.h.

float vtkPointLocator2D::H[2] [protected]

Definition at line 148 of file vtkPointLocator2D.h.

vtkNeighborPoints2D* vtkPointLocator2D::Buckets [protected]

Definition at line 149 of file vtkPointLocator2D.h.

float vtkPointLocator2D::InsertionTol2 [protected]

Definition at line 150 of file vtkPointLocator2D.h.

The documentation for this class was generated from the following file:
  • Common/vtkPointLocator2D.h
Generated on Mon Mar 25 01:27:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointPicker Class Reference

select a point by shooting a ray into a graphics window. More...

#include <vtkPointPicker.h>

Inheritance diagram for vtkPointPicker:

[legend]
Collaboration diagram for vtkPointPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointPicker, vtkPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkIdType | GetPointId ()

Static Public Methods

vtkPointPicker * | New ()

Protected Methods

vtkPointPicker ()
~vtkPointPicker ()
float | IntersectWithLine (float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m)
void | Initialize ()

Protected Attributes

vtkIdType PointId

Detailed Description

select a point by shooting a ray into a graphics window.

Date:
2002/01/22 15:39:05
Revision:
1.35

vtkPointPicker is used to select a point by shooting a ray into a graphics window and intersecting with actor's defining geometry - specifically its points. Beside returning coordinates, actor, and mapper, vtkPointPicker returns the id of the closest point within the tolerance along the pick ray.

See also:
vtkPicker vtkCellPicker.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Martin, Ken (10%)
  • Lorensen, Bill (8%)
Tests:
vtkPointPicker (Tests)

Definition at line 47 of file vtkPointPicker.h.

Constructor & Destructor Documentation

vtkPointPicker::vtkPointPicker ( ) [protected]

vtkPointPicker::~vtkPointPicker ( ) [inline, protected]

Definition at line 61 of file vtkPointPicker.h.

Member Function Documentation

vtkPointPicker* vtkPointPicker::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkPicker.

vtkPointPicker::vtkTypeRevisionMacro | ( | vtkPointPicker | ,
 |  | vtkPicker |
 | ) |

Reimplemented from vtkPicker.

void vtkPointPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPicker.

virtual vtkIdType vtkPointPicker::GetPointId ( ) [virtual]

Get the id of the picked point. If PointId = -1, nothing was picked.

float vtkPointPicker::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | vtkAssemblyPath * | path,
 |  | vtkProp3D * | p,
 |  | vtkAbstractMapper3D * | m
 | ) | [protected, virtual]

Reimplemented from vtkPicker.

void vtkPointPicker::Initialize ( ) [protected, virtual]

Reimplemented from vtkPicker.

Member Data Documentation

vtkIdType vtkPointPicker::PointId [protected]

Definition at line 63 of file vtkPointPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkPointPicker.h
Generated on Mon Mar 25 01:27:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPoints Class Reference

represent and manipulate 3D points. More...

#include <vtkPoints.h>

Inheritance diagram for vtkPoints:

[legend]
Collaboration diagram for vtkPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPoints, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
virtual void | Initialize ()
vtkPoints * | MakeObject ()
virtual int | GetDataType ()
void * | GetVoidPointer (const int id)
virtual void | Squeeze ()
virtual void | Reset ()
unsigned long | GetActualMemorySize ()
vtkIdType GetNumberOfPoints ()
float * | GetPoint (vtkIdType id)
void | SetNumberOfPoints (vtkIdType number)
void | GetPoints (vtkIdList *ptId, vtkPoints *fp)
virtual void | ComputeBounds ()
float * | GetBounds ()
void | GetBounds (float bounds[6])
virtual void | SetData (vtkDataArray *)
vtkDataArray * GetData ()
virtual void | SetDataType (int dataType)
void | SetDataTypeToBit ()
void | SetDataTypeToChar ()
void | SetDataTypeToUnsignedChar ()
void | SetDataTypeToShort ()
void | SetDataTypeToUnsignedShort ()
void | SetDataTypeToInt ()
void | SetDataTypeToUnsignedInt ()
void | SetDataTypeToLong ()
void | SetDataTypeToUnsignedLong ()
void | SetDataTypeToFloat ()
void | SetDataTypeToDouble ()
virtual void | DeepCopy (vtkPoints *ad)
virtual void | ShallowCopy (vtkPoints *ad)
void | GetPoint (vtkIdType id, float x[3])
void | GetPoint (vtkIdType id, double x[3])
void | SetPoint (vtkIdType id, const float x[3])
void | SetPoint (vtkIdType id, const double x[3])
void | SetPoint (vtkIdType id, double x, double y, double z)
void | InsertPoint (vtkIdType id, const float x[3])
void | InsertPoint (vtkIdType id, const double x[3])
void | InsertPoint (vtkIdType id, double x, double y, double z)
vtkIdType | InsertNextPoint (const float x[3])
vtkIdType | InsertNextPoint (const double x[3])
vtkIdType | InsertNextPoint (double x, double y, double z)

Static Public Methods

vtkPoints * | New (int dataType)
vtkPoints * | New ()

Protected Methods

vtkPoints (int dataType=VTK_FLOAT)
~vtkPoints ()

Protected Attributes

float | Bounds [6]
vtkTimeStamp ComputeTime
vtkDataArray * Data

Detailed Description

represent and manipulate 3D points.

Date:
2002/01/22 15:26:00
Revision:
1.61

vtkPoints represents 3D points. The data model for vtkPoints is an array of vx-vy-vz triplets accessible by (point or cell) id.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (39%)
  • Geveci, Berk (29%)
  • Martin, Ken (11%)
Examples:
vtkPoints (Examples)
Tests:
vtkPoints (Tests)

Definition at line 49 of file vtkPoints.h.

Constructor & Destructor Documentation

vtkPoints::vtkPoints ( int dataType = VTK_FLOAT ) [protected]

vtkPoints::~vtkPoints ( ) [protected]

Member Function Documentation

vtkPoints* vtkPoints::New ( int dataType ) [static]

vtkPoints* vtkPoints::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPoints::vtkTypeRevisionMacro | ( | vtkPoints | ,
 |  | vtkObject |
 | ) |

void vtkPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

virtual int vtkPoints::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate initial memory size.

virtual void vtkPoints::Initialize ( ) [virtual]

Return object to instantiated state.

vtkPoints* vtkPoints::MakeObject ( )

Creates object of same type as this object.

virtual void vtkPoints::SetData ( vtkDataArray * ) [virtual]

Set/Get the underlying data array. This function must be implemented in a concrete subclass to check for consistency. (The tuple size must match the type of data. For example, 3-tuple data array can be assigned to a vector, normal, or points object, but not a tensor object, which has a tuple dimension of 9. Scalars, on the other hand, can have tuple dimension from 1-4, depending on the type of scalar.)

vtkDataArray* vtkPoints::GetData ( ) [inline]

Set/Get the underlying data array. This function must be implemented in a concrete subclass to check for consistency. (The tuple size must match the type of data. For example, 3-tuple data array can be assigned to a vector, normal, or points object, but not a tensor object, which has a tuple dimension of 9. Scalars, on the other hand, can have tuple dimension from 1-4, depending on the type of scalar.)

Definition at line 77 of file vtkPoints.h.

virtual int vtkPoints::GetDataType ( ) [virtual]

Return the underlying data type. An integer indicating data type is returned as specified in vtkSetGet.h.

virtual void vtkPoints::SetDataType ( int dataType ) [virtual]

Specify the underlying data type of the object.

void vtkPoints::SetDataTypeToBit ( ) [inline]

Specify the underlying data type of the object.

Definition at line 87 of file vtkPoints.h.

void vtkPoints::SetDataTypeToChar ( ) [inline]

Specify the underlying data type of the object.

Definition at line 88 of file vtkPoints.h.

void vtkPoints::SetDataTypeToUnsignedChar ( ) [inline]

Specify the underlying data type of the object.

Definition at line 89 of file vtkPoints.h.

void vtkPoints::SetDataTypeToShort ( ) [inline]

Specify the underlying data type of the object.

Definition at line 90 of file vtkPoints.h.

void vtkPoints::SetDataTypeToUnsignedShort ( ) [inline]

Specify the underlying data type of the object.

Definition at line 91 of file vtkPoints.h.

void vtkPoints::SetDataTypeToInt ( ) [inline]

Specify the underlying data type of the object.

Definition at line 92 of file vtkPoints.h.

void vtkPoints::SetDataTypeToUnsignedInt ( ) [inline]

Specify the underlying data type of the object.

Definition at line 93 of file vtkPoints.h.

void vtkPoints::SetDataTypeToLong ( ) [inline]

Specify the underlying data type of the object.

Definition at line 94 of file vtkPoints.h.

void vtkPoints::SetDataTypeToUnsignedLong ( ) [inline]

Specify the underlying data type of the object.

Definition at line 95 of file vtkPoints.h.

void vtkPoints::SetDataTypeToFloat ( ) [inline]

Specify the underlying data type of the object.

Definition at line 96 of file vtkPoints.h.

void vtkPoints::SetDataTypeToDouble ( ) [inline]

Specify the underlying data type of the object.

Definition at line 97 of file vtkPoints.h.

void* vtkPoints::GetVoidPointer ( const int id ) [inline]

Return a void pointer. For image pipeline interface and other special pointer manipulation.

Definition at line 102 of file vtkPoints.h.

virtual void vtkPoints::Squeeze ( ) [inline, virtual]

Reclaim any extra memory.

Definition at line 105 of file vtkPoints.h.

virtual void vtkPoints::Reset ( ) [inline, virtual]

Make object look empty but do not delete memory.

Definition at line 108 of file vtkPoints.h.

virtual void vtkPoints::DeepCopy ( vtkPoints * ad ) [virtual]

Different ways to copy data. Shallow copy does reference count (i.e., assigns pointers and updates reference count); deep copy runs through entire data array assigning values.

virtual void vtkPoints::ShallowCopy ( vtkPoints * ad ) [virtual]

Different ways to copy data. Shallow copy does reference count (i.e., assigns pointers and updates reference count); deep copy runs through entire data array assigning values.

unsigned long vtkPoints::GetActualMemorySize ( )

Return the memory in kilobytes consumed by this attribute data. Used to support streaming and reading/writing data. The value returned is guaranteed to be greater than or equal to the memory required to actually represent the data represented by this object. The information returned is valid only after the pipeline has been updated.

vtkIdType vtkPoints::GetNumberOfPoints ( ) [inline]

Return number of points in array.

Definition at line 127 of file vtkPoints.h.

Referenced by vtkPointSet::GetNumberOfPoints().

float* vtkPoints::GetPoint ( vtkIdType id ) [inline]

Return a pointer to a float point x[3] for a specific id.

Definition at line 130 of file vtkPoints.h.

void vtkPoints::GetPoint | ( | vtkIdType | id,
 |  | float | x[3]
 | ) | [inline]

Copy point components into user provided array v[3] for specified id.

Definition at line 134 of file vtkPoints.h.

void vtkPoints::GetPoint | ( | vtkIdType | id,
 |  | double | x[3]
 | ) | [inline]

Copy point components into user provided array v[3] for specified id.

Definition at line 135 of file vtkPoints.h.

void vtkPoints::SetPoint | ( | vtkIdType | id,
 |  | const float | x[3]
 | ) | [inline]

Insert point into object. No range checking performed (fast!). Make sure you use SetNumberOfPoints() to allocate memory prior to using SetPoint().

Definition at line 142 of file vtkPoints.h.

void vtkPoints::SetPoint | ( | vtkIdType | id,
 |  | const double | x[3]
 | ) | [inline]

Insert point into object. No range checking performed (fast!). Make sure you use SetNumberOfPoints() to allocate memory prior to using SetPoint().

Definition at line 143 of file vtkPoints.h.

void vtkPoints::SetPoint | ( | vtkIdType | id,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Insert point into object. No range checking performed (fast!). Make sure you use SetNumberOfPoints() to allocate memory prior to using SetPoint().

Definition at line 202 of file vtkPoints.h.

void vtkPoints::InsertPoint | ( | vtkIdType | id,
 |  | const float | x[3]
 | ) | [inline]

Insert point into object. Range checking performed and memory allocated as necessary.

Definition at line 150 of file vtkPoints.h.

void vtkPoints::InsertPoint | ( | vtkIdType | id,
 |  | const double | x[3]
 | ) | [inline]

Insert point into object. Range checking performed and memory allocated as necessary.

Definition at line 152 of file vtkPoints.h.

void vtkPoints::InsertPoint | ( | vtkIdType | id,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Insert point into object. Range checking performed and memory allocated as necessary.

Definition at line 211 of file vtkPoints.h.

vtkIdType vtkPoints::InsertNextPoint ( const float x[3] ) [inline]

Insert point into next available slot. Returns id of slot.

Definition at line 159 of file vtkPoints.h.

Referenced by vtkNonLinearCell::InsertPoint().

vtkIdType vtkPoints::InsertNextPoint ( const double x[3] ) [inline]

Insert point into next available slot. Returns id of slot.

Definition at line 161 of file vtkPoints.h.

vtkIdType vtkPoints::InsertNextPoint | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Insert point into next available slot. Returns id of slot.

Definition at line 221 of file vtkPoints.h.

void vtkPoints::SetNumberOfPoints ( vtkIdType number ) [inline]

Specify the number of points for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetPoint() method for fast insertion.

Definition at line 196 of file vtkPoints.h.

void vtkPoints::GetPoints | ( | vtkIdList * | ptId,
 |  | vtkPoints * | fp
 | ) |

Given a list of pt ids, return an array of points.

virtual void vtkPoints::ComputeBounds ( ) [virtual]

Determine (xmin,xmax, ymin,ymax, zmin,zmax) bounds of points.

float* vtkPoints::GetBounds ( )

Return the bounds of the points.

void vtkPoints::GetBounds ( float bounds[6] )

Return the bounds of the points.

Member Data Documentation

float vtkPoints::Bounds[6] [protected]

Definition at line 187 of file vtkPoints.h.

vtkTimeStamp vtkPoints::ComputeTime [protected]

Definition at line 188 of file vtkPoints.h.

vtkDataArray* vtkPoints::Data [protected]

Definition at line 189 of file vtkPoints.h.

The documentation for this class was generated from the following file:
  • Common/vtkPoints.h
Generated on Mon Mar 25 01:27:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSet Class Reference

abstract class for specifying dataset behavior. More...

#include <vtkPointSet.h>

Inheritance diagram for vtkPointSet:

[legend]
Collaboration diagram for vtkPointSet:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointSet, vtkDataSet)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Initialize ()
void | CopyStructure (vtkDataSet *pd)
unsigned long | GetMTime ()
void | ComputeBounds ()
void | Squeeze ()
void | UnRegister (vtkObject *o)
virtual int | GetNetReferenceCount ()
unsigned long | GetActualMemorySize ()
vtkIdType GetNumberOfPoints ()
float * | GetPoint (vtkIdType ptId)
void | GetPoint (vtkIdType ptId, float x[3])
vtkIdType | FindPoint (float x[3])
vtkIdType | FindPoint (float x, float y, float z)
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
virtual void | SetPoints (vtkPoints *)
virtual vtkPoints * | GetPoints ()
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)

Protected Methods

vtkPointSet ()
~vtkPointSet ()

Protected Attributes

vtkPoints * Points
vtkPointLocator * Locator

Detailed Description

abstract class for specifying dataset behavior.

Date:
2002/01/22 15:26:00
Revision:
1.57

vtkPointSet is an abstract class that specifies the interface for datasets that explicitly use "point" arrays to represent geometry. For example, vtkPolyData and vtkUnstructuredGrid require point arrays to specify point position, while vtkStructuredPoints generates point positions implicitly.

See also:
vtkPolyData vtkStructuredGrid vtkUnstructuredGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (56%)
  • Law, Charles (11%)
  • Avila, Lisa (10%)
  • Martin, Ken (8%)

Definition at line 47 of file vtkPointSet.h.

Constructor & Destructor Documentation

vtkPointSet::vtkPointSet ( ) [protected]

vtkPointSet::~vtkPointSet ( ) [protected]

Member Function Documentation

vtkPointSet::vtkTypeRevisionMacro | ( | vtkPointSet | ,
 |  | vtkDataSet |
 | ) |

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkPointSet::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkPointSet::Initialize ( ) [virtual]

Reset to an empty state and free any memory.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkPointSet::CopyStructure ( vtkDataSet * ds ) [virtual]

Copy the geometric structure of an input point set object.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

vtkIdType vtkPointSet::GetNumberOfPoints ( ) [inline, virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

Reimplemented in vtkStructuredGrid.

Definition at line 121 of file vtkPointSet.h.

Referenced by vtkStructuredGrid::GetNumberOfPoints().

float* vtkPointSet::GetPoint ( vtkIdType ptId ) [inline, virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

Reimplemented in vtkStructuredGrid.

Definition at line 62 of file vtkPointSet.h.

Referenced by vtkStructuredGrid::GetPoint().

void vtkPointSet::GetPoint | ( | vtkIdType | ptId,
 |  | float | p[3]
 | ) | [inline, virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

Reimplemented in vtkStructuredGrid.

Definition at line 63 of file vtkPointSet.h.

vtkIdType vtkPointSet::FindPoint ( float x[3] ) [virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

vtkIdType vtkPointSet::FindPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

Definition at line 65 of file vtkPointSet.h.

vtkIdType vtkPointSet::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

vtkIdType vtkPointSet::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkGenericCell * | gencell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

See vtkDataSet for additional information.

Reimplemented from vtkDataSet.

unsigned long vtkPointSet::GetMTime ( ) [virtual]

Get MTime which also considers its vtkPoints MTime.

Reimplemented from vtkDataSet.

void vtkPointSet::ComputeBounds ( ) [virtual]

Compute the (X, Y, Z) bounds of the data.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData.

void vtkPointSet::Squeeze ( ) [virtual]

Reclaim any unused memory.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, and vtkUnstructuredGrid.

virtual void vtkPointSet::SetPoints ( vtkPoints * ) [virtual]

Specify point array to define point coordinates.

virtual vtkPoints* vtkPointSet::GetPoints ( ) [virtual]

Specify point array to define point coordinates.

void vtkPointSet::UnRegister ( vtkObject * o ) [virtual]

Detect reference loop PointSet <-> locator.

Reimplemented from vtkDataObject.

virtual int vtkPointSet::GetNetReferenceCount ( ) [virtual]

Get the net reference count. That is the count minus any self created loops. This is used in the Source/Data registration to properly free the objects.

Reimplemented from vtkDataObject.

unsigned long vtkPointSet::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkPointSet::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

void vtkPointSet::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

Reimplemented in vtkPolyData, vtkStructuredGrid, and vtkUnstructuredGrid.

Member Data Documentation

vtkPoints* vtkPointSet::Points [protected]

Definition at line 113 of file vtkPointSet.h.

vtkPointLocator* vtkPointSet::Locator [protected]

Definition at line 114 of file vtkPointSet.h.

The documentation for this class was generated from the following file:
  • Common/vtkPointSet.h
Generated on Mon Mar 25 01:27:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSetSource Class Reference

abstract class whose subclasses generate point data. More...

#include <vtkPointSetSource.h>

Inheritance diagram for vtkPointSetSource:

[legend]
Collaboration diagram for vtkPointSetSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointSetSource, vtkSource)
vtkPointSet * GetOutput ()
vtkPointSet * | GetOutput (int idx)
void | SetOutput (vtkPointSet *output)

Static Public Methods

vtkPointSetSource * | New ()

Protected Methods

vtkPointSetSource ()
~vtkPointSetSource ()

Detailed Description

abstract class whose subclasses generate point data.

Date:
2002/01/22 15:28:09
Revision:
1.14

vtkPointSetSource is an abstract class whose subclasses generate pointdata.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (96%)

Definition at line 37 of file vtkPointSetSource.h.

Constructor & Destructor Documentation

vtkPointSetSource::vtkPointSetSource ( ) [protected]

vtkPointSetSource::~vtkPointSetSource ( ) [inline, protected]

Definition at line 53 of file vtkPointSetSource.h.

Member Function Documentation

vtkPointSetSource* vtkPointSetSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkTransformFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, and vtkWeightedTransformFilter.

vtkPointSetSource::vtkTypeRevisionMacro | ( | vtkPointSetSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkPointSetToPointSetFilter, vtkTransformFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, and vtkWeightedTransformFilter.

vtkPointSet* vtkPointSetSource::GetOutput ( )

Get the output of this source.

Reimplemented in vtkPointSetToPointSetFilter.

Referenced by vtkPointSetToPointSetFilter::GetOutput().

vtkPointSet* vtkPointSetSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Reimplemented in vtkPointSetToPointSetFilter.

Definition at line 46 of file vtkPointSetSource.h.

void vtkPointSetSource::SetOutput ( vtkPointSet * output )

Get the output of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkPointSetSource.h
Generated on Mon Mar 25 01:27:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSetToPointSetFilter Class Reference

abstract filter class. More...

#include <vtkPointSetToPointSetFilter.h>

Inheritance diagram for vtkPointSetToPointSetFilter:

[legend]
Collaboration diagram for vtkPointSetToPointSetFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointSetToPointSetFilter, vtkPointSetSource)
void | SetInput (vtkPointSet *input)
vtkPointSet * GetInput ()
vtkPolyData * GetPolyDataOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
vtkPointSet * GetOutput ()
vtkPointSet * | GetOutput (int idx)

Protected Methods

vtkPointSetToPointSetFilter ()
~vtkPointSetToPointSetFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:09
Revision:
1.48

vtkPointSetToPointSetFilter is an abstract filter class whose subclasses take as input a point set and generates a point set on output. At a minimum, the concrete subclasses of vtkPointSetToPointSetFilter modify their point coordinates. They never modify their topological form, however.

This is an abstract filter type. What that means is that the output of the filter is an abstract type (i.e., vtkPointSet), no matter what the input of the filter is. This can cause problems connecting together filters due to the change in dataset type. (For example, in a series of filters processing vtkPolyData, when a vtkPointSetToPointSetFilter or subclass is introduced into the pipeline, if the filter downstream of it takes vtkPolyData as input, the pipeline connection cannot be made.) To get around this problem, use one of the convenience methods to return a concrete type (e.g., vtkGetPolyDataOutput(), GetStructuredGridOutput(), etc.).

See also:
vtkTransformFilter vtkWarpScalar vtkWarpTo vtkWarpVector
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (56%)
  • Martin, Ken (26%)
  • Lorensen, Bill (7%)

Definition at line 60 of file vtkPointSetToPointSetFilter.h.

Constructor & Destructor Documentation

vtkPointSetToPointSetFilter::vtkPointSetToPointSetFilter ( ) [protected]

vtkPointSetToPointSetFilter::~vtkPointSetToPointSetFilter ( ) [protected]

Member Function Documentation

vtkPointSetToPointSetFilter::vtkTypeRevisionMacro | ( | vtkPointSetToPointSetFilter | ,
 |  | vtkPointSetSource |
 | ) |

Reimplemented from vtkPointSetSource.

Reimplemented in vtkTransformFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, and vtkWeightedTransformFilter.

void vtkPointSetToPointSetFilter::SetInput ( vtkPointSet * input )

Specify the input data or filter.

vtkPointSet* vtkPointSetToPointSetFilter::GetInput ( )

Get the input data or filter.

vtkPointSet* vtkPointSetToPointSetFilter::GetOutput ( )

Get the output of this filter. If output is NULL, then input hasn't been set, which is necessary for abstract filter objects.

Reimplemented from vtkPointSetSource.

vtkPointSet* vtkPointSetToPointSetFilter::GetOutput ( int idx ) [inline]

Get the output of this filter. If output is NULL, then input hasn't been set, which is necessary for abstract filter objects.

Reimplemented from vtkPointSetSource.

Definition at line 75 of file vtkPointSetToPointSetFilter.h.

vtkPolyData* vtkPointSetToPointSetFilter::GetPolyDataOutput ( )

Get the output as vtkPolyData. Performs run-time checking.

vtkStructuredGrid* vtkPointSetToPointSetFilter::GetStructuredGridOutput ( )

Get the output as vtkStructuredGrid. Performs run-time checking.

vtkUnstructuredGrid* vtkPointSetToPointSetFilter::GetUnstructuredGridOutput ( )

Get the output as vtkUnstructuredGrid. Performs run-time checking.

virtual void vtkPointSetToPointSetFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

By default copy the output update extent to the input

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkPointSetToPointSetFilter.h
Generated on Mon Mar 25 01:27:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPointSource Class Reference

create a random cloud of points. More...

#include <vtkPointSource.h>

Inheritance diagram for vtkPointSource:

[legend]
Collaboration diagram for vtkPointSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPointSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNumberOfPoints (vtkIdType)
virtual vtkIdType | GetNumberOfPoints ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetDistribution (int)
void | SetDistributionToUniform ()
void | SetDistributionToShell ()
virtual int | GetDistribution ()

Static Public Methods

vtkPointSource * | New ()

Protected Methods

vtkPointSource (vtkIdType numPts=10)
~vtkPointSource ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

vtkIdType NumberOfPoints
float | Center [3]
float | Radius
int | Distribution

Detailed Description

create a random cloud of points.

Date:
2002/01/22 15:29:35
Revision:
1.41

vtkPointSource is a source object that creates a user-specified number of points within a specified radius about a specified center point. By default location of the points is random within the sphere.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Gobbi, David (27%)
  • Martin, Ken (7%)
  • Henderson, Amy (5%)
Examples:
vtkPointSource (Examples)
Tests:
vtkPointSource (Tests)

Definition at line 50 of file vtkPointSource.h.

Constructor & Destructor Documentation

vtkPointSource::vtkPointSource ( vtkIdType numPts = 10 ) [protected]

vtkPointSource::~vtkPointSource ( ) [inline, protected]

Definition at line 90 of file vtkPointSource.h.

Member Function Documentation

vtkPointSource* vtkPointSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkPointSource::vtkTypeRevisionMacro | ( | vtkPointSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkPointSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkPointSource::SetNumberOfPoints ( vtkIdType ) [virtual]

Set the number of points to generate.

virtual vtkIdType vtkPointSource::GetNumberOfPoints ( ) [virtual]

Set the number of points to generate.

virtual void vtkPointSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the point cloud.

virtual void vtkPointSource::SetCenter ( float [3] ) [virtual]

Set the center of the point cloud.

virtual float* vtkPointSource::GetCenter ( ) [virtual]

Set the center of the point cloud.

virtual void vtkPointSource::GetCenter ( float data[3] ) [virtual]

Set the center of the point cloud.

virtual void vtkPointSource::SetRadius ( float ) [virtual]

Set the radius of the point cloud. If you are generating a Gaussian distribution, then this is the standard deviation for each of x, y, and z.

virtual float vtkPointSource::GetRadius ( ) [virtual]

Set the radius of the point cloud. If you are generating a Gaussian distribution, then this is the standard deviation for each of x, y, and z.

virtual void vtkPointSource::SetDistribution ( int ) [virtual]

Specify the distribution to use. The default is a uniform distribution. The Shell distribution produces and empty sphere.

void vtkPointSource::SetDistributionToUniform ( ) [inline]

Specify the distribution to use. The default is a uniform distribution. The Shell distribution produces and empty sphere.

Definition at line 81 of file vtkPointSource.h.

void vtkPointSource::SetDistributionToShell ( ) [inline]

Specify the distribution to use. The default is a uniform distribution. The Shell distribution produces and empty sphere.

Definition at line 83 of file vtkPointSource.h.

virtual int vtkPointSource::GetDistribution ( ) [virtual]

Specify the distribution to use. The default is a uniform distribution. The Shell distribution produces and empty sphere.

void vtkPointSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPointSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

vtkIdType vtkPointSource::NumberOfPoints [protected]

Definition at line 95 of file vtkPointSource.h.

float vtkPointSource::Center[3] [protected]

Definition at line 96 of file vtkPointSource.h.

float vtkPointSource::Radius [protected]

Definition at line 97 of file vtkPointSource.h.

int vtkPointSource::Distribution [protected]

Definition at line 98 of file vtkPointSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPointSource.h
Generated on Mon Mar 25 01:27:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyData Class Reference

concrete dataset represents vertices, lines, polygons, and triangle strips. More...

#include <vtkPolyData.h>

Inheritance diagram for vtkPolyData:

[legend]
Collaboration diagram for vtkPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyData, vtkPointSet)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * MakeObject ()
int | GetDataObjectType ()
void | CopyStructure (vtkDataSet *ds)
void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)
void | ComputeBounds ()
void | Squeeze ()
int | GetMaxCellSize ()
void | SetVerts (vtkCellArray *v)
vtkCellArray * GetVerts ()
void | SetLines (vtkCellArray *l)
vtkCellArray * GetLines ()
void | SetPolys (vtkCellArray *p)
vtkCellArray * GetPolys ()
void | SetStrips (vtkCellArray *s)
vtkCellArray * GetStrips ()
void | Allocate (vtkIdType numCells=1000, int extSize=1000)
int | InsertNextCell (int type, int npts, vtkIdType *pts)
int | InsertNextCell (int type, vtkIdList *pts)
void | Reset ()
void | BuildCells ()
void | BuildLinks ()
void | DeleteCells ()
void | DeleteLinks ()
void | GetCellPoints (vtkIdType cellId, vtkIdType &npts, vtkIdType *&pts)
int | IsTriangle (int v1, int v2, int v3)
int | IsEdge (int v1, int v2)
int | IsPointUsedByCell (vtkIdType ptId, vtkIdType cellId)
void | ReplaceCell (vtkIdType cellId, int npts, vtkIdType *pts)
void | ReverseCell (vtkIdType cellId)
int | InsertNextLinkedPoint (float x[3], int numLinks)
int | InsertNextLinkedCell (int type, int npts, vtkIdType *pts)
void | ReplaceLinkedCell (vtkIdType cellId, int npts, vtkIdType *pts)
void | RemoveCellReference (vtkIdType cellId)
void | AddCellReference (vtkIdType cellId)
void | RemoveReferenceToCell (vtkIdType ptId, vtkIdType cellId)
void | AddReferenceToCell (vtkIdType ptId, vtkIdType cellId)
void | ResizeCellList (vtkIdType ptId, int size)
virtual void | Initialize ()
unsigned long | GetActualMemorySize ()
void | RemoveGhostCells (int level)
vtkIdType GetNumberOfCells ()
vtkCell * | GetCell (vtkIdType cellId)
void | GetCell (vtkIdType cellId, vtkGenericCell *cell)
int | GetCellType (vtkIdType cellId)
void | GetCellBounds (vtkIdType cellId, float bounds[6])
void | GetCellNeighbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds)
void | CopyCells (vtkPolyData *pd, vtkIdList *idList, vtkPointLocator *locator=NULL)
vtkIdType GetNumberOfVerts ()
vtkIdType GetNumberOfLines ()
vtkIdType GetNumberOfPolys ()
vtkIdType GetNumberOfStrips ()
void | Allocate (vtkPolyData *inPolyData, vtkIdType numCells=1000, int extSize=1000)
void | GetPointCells (vtkIdType ptId, unsigned short &ncells, vtkIdType *&cells)
void | GetCellEdgeNeighbors (vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIdList *cellIds)
void | ReplaceCellPoint (vtkIdType cellId, vtkIdType oldPtId, vtkIdType newPtId)
void | DeletePoint (vtkIdType ptId)
void | DeleteCell (vtkIdType cellId)
void | SetUpdateExtent (int piece, int numPieces, int ghostLevel)
void | SetUpdateExtent (int piece, int numPieces)
void | GetUpdateExtent (int &piece, int &numPieces, int &ghostLevel)
virtual int * | GetUpdateExtent ()
virtual void | GetUpdateExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetUpdateExtent (int[6])
void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
void | SetUpdateExtent (int ext[6])
virtual int | GetPiece ()
virtual int | GetNumberOfPieces ()
virtual int | GetGhostLevel ()
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)

Static Public Methods

vtkPolyData * | New ()

Protected Methods

vtkPolyData ()
~vtkPolyData ()
virtual void | Crop ()

Protected Attributes

vtkVertex * Vertex
vtkPolyVertex * PolyVertex
vtkLine * Line
vtkPolyLine * PolyLine
vtkTriangle * Triangle
vtkQuad * Quad
vtkPolygon * Polygon
vtkTriangleStrip * TriangleStrip
vtkEmptyCell * EmptyCell
vtkCellArray * Verts
vtkCellArray * Lines
vtkCellArray * Polys
vtkCellArray * Strips
vtkCellTypes * Cells
vtkCellLinks * Links

Static Protected Attributes

vtkCellArray * Dummy

Detailed Description

concrete dataset represents vertices, lines, polygons, and triangle strips.

Date:
2002/01/22 15:26:02
Revision:
1.120

vtkPolyData is a data object that is a concrete implementation of vtkDataSet. vtkPolyData represents a geometric structure consisting of vertices, lines, polygons, and triangle strips. Point attribute values (e.g., scalars, vectors, etc.) also are represented.

The actual cell types (CellType.h) supported by vtkPolyData are: vtkVertex, vtkPolyVertex, vtkLine, vtkPolyLine, vtkTriangle, vtkTriangleStrip, vtkPolygon, vtkPixel, and vtkQuad.

One important feature of vtkPolyData objects is that special traversal and data manipulation methods are available to process data. These methods are generally more efficient than vtkDataSet methods and should be used whenever possible. For example, traversing the cells in a dataset we would use GetCell(). To traverse cells with vtkPolyData we would retrieve the cell array object representing polygons (for example) and then use vtkCellArray's InitTraversal() and GetNextCell() methods.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Law, Charles (12%)
  • Martin, Ken (10%)
  • Miller, Jim (7%)
  • Henderson, Amy (5%)
Examples:
vtkPolyData (Examples)
Tests:
vtkPolyData (Tests)

Definition at line 77 of file vtkPolyData.h.

Constructor & Destructor Documentation

vtkPolyData::vtkPolyData ( ) [protected]

vtkPolyData::~vtkPolyData ( ) [protected]

Member Function Documentation

vtkPolyData* vtkPolyData::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

Referenced by MakeObject().

vtkPolyData::vtkTypeRevisionMacro | ( | vtkPolyData | ,
 |  | vtkPointSet |
 | ) |

Reimplemented from vtkPointSet.

void vtkPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPointSet.

vtkDataObject* vtkPolyData::MakeObject ( ) [inline, virtual]

Create a similar type object.

Reimplemented from vtkDataObject.

Definition at line 86 of file vtkPolyData.h.

int vtkPolyData::GetDataObjectType ( ) [inline, virtual]

Return what type of dataset this is.

Reimplemented from vtkDataSet.

Definition at line 89 of file vtkPolyData.h.

void vtkPolyData::CopyStructure ( vtkDataSet * ds ) [virtual]

Copy the geometric and topological structure of an input poly data object.

Reimplemented from vtkPointSet.

vtkIdType vtkPolyData::GetNumberOfCells ( ) [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

vtkCell* vtkPolyData::GetCell ( vtkIdType cellId ) [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

void vtkPolyData::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

int vtkPolyData::GetCellType ( vtkIdType cellId ) [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

void vtkPolyData::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

void vtkPolyData::GetCellNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Standard vtkDataSet interface.

Reimplemented from vtkDataSet.

void vtkPolyData::CopyCells | ( | vtkPolyData * | pd,
 |  | vtkIdList * | idList,
 |  | vtkPointLocator * | locator = NULL
 | ) |

Copy cells listed in idList from pd, including points, point data, and cell data. This method assumes that point and cell data have been allocated. If you pass in a point locator, then the points won't be duplicated in the output.

void vtkPolyData::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [virtual]

Copy a cells point ids into list provided. (Less efficient.)

Reimplemented from vtkDataSet.

Referenced by AddCellReference(), IsPointUsedByCell(), IsTriangle(), RemoveCellReference(), and ReplaceCellPoint().

void vtkPolyData::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Efficient method to obtain cells using a particular point. Make sure that routine BuildLinks() has been called.

Reimplemented from vtkDataSet.

Referenced by IsEdge(), and IsTriangle().

void vtkPolyData::ComputeBounds ( ) [virtual]

Compute the (X, Y, Z) bounds of the data.

Reimplemented from vtkPointSet.

void vtkPolyData::Squeeze ( ) [virtual]

Recover extra allocated memory when creating data whose initial size is unknown. Examples include using the InsertNextCell() method, or when using the CellArray::EstimateSize() method to create vertices, lines, polygons, or triangle strips.

Reimplemented from vtkPointSet.

int vtkPolyData::GetMaxCellSize ( ) [virtual]

Return the maximum cell size in this poly data.

Reimplemented from vtkDataSet.

void vtkPolyData::SetVerts ( vtkCellArray * v )

Set the cell array defining vertices.

vtkCellArray* vtkPolyData::GetVerts ( )

Get the cell array defining vertices. If there are no vertices, an empty array will be returned (convenience to simplify traversal).

void vtkPolyData::SetLines ( vtkCellArray * l )

Set the cell array defining lines.

vtkCellArray* vtkPolyData::GetLines ( )

Get the cell array defining lines. If there are no lines, an empty array will be returned (convenience to simplify traversal).

void vtkPolyData::SetPolys ( vtkCellArray * p )

Set the cell array defining polygons.

vtkCellArray* vtkPolyData::GetPolys ( )

Get the cell array defining polygons. If there are no polygons, an empty array will be returned (convenience to simplify traversal).

void vtkPolyData::SetStrips ( vtkCellArray * s )

Set the cell array defining triangle strips.

vtkCellArray* vtkPolyData::GetStrips ( )

Get the cell array defining triangle strips. If there are no triangle strips, an empty array will be returned (convenience to simplify traversal).

vtkIdType vtkPolyData::GetNumberOfVerts ( )

Return the number of primitives of a particular type held..

vtkIdType vtkPolyData::GetNumberOfLines ( )

Return the number of primitives of a particular type held..

vtkIdType vtkPolyData::GetNumberOfPolys ( )

Return the number of primitives of a particular type held..

vtkIdType vtkPolyData::GetNumberOfStrips ( )

Return the number of primitives of a particular type held..

void vtkPolyData::Allocate | ( | vtkIdType | numCells = 1000,
 |  | int | extSize = 1000
 | ) |

Method allocates initial storage for vertex, line, polygon, and triangle strip arrays. Use this method before the method PolyData::InsertNextCell(). (Or, provide vertex, line, polygon, and triangle strip cell arrays.)

void vtkPolyData::Allocate | ( | vtkPolyData * | inPolyData,
 |  | vtkIdType | numCells = 1000,
 |  | int | extSize = 1000
 | ) |

Similar to the method above, this method allocates initial storage for vertex, line, polygon, and triangle strip arrays. It does this more intelligently, examining the supplied inPolyData to determine whether to allocate the verts, lines, polys, and strips arrays. (These arrays are allocated only if there is data in the corresponding arrays in the inPolyData.) Caution: if the inPolyData has no verts, and after allocating with this method an PolyData::InsertNextCell() is invoked where a vertex is inserted, bad things will happen.

int vtkPolyData::InsertNextCell | ( | int | type,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

Insert a cell of type vtkVERTEX, vtkPOLY_VERTEX, vtkLINE, vtkPOLY_LINE, vtkTRIANGLE, vtkQUAD, vtkPOLYGON, or vtkTRIANGLE_STRIP. Make sure that the PolyData::Allocate() function has been called first or that vertex, line, polygon, and triangle strip arrays have been supplied. Note: will also insert vtkPIXEL, but converts it to vtkQUAD.

int vtkPolyData::InsertNextCell | ( | int | type,
 |  | vtkIdList * | pts
 | ) |

Insert a cell of type VTK_VERTEX, VTK_POLY_VERTEX, VTK_LINE, VTK_POLY_LINE, VTK_TRIANGLE, VTK_QUAD, VTK_POLYGON, or VTK_TRIANGLE_STRIP. Make sure that the PolyData::Allocate() function has been called first or that vertex, line, polygon, and triangle strip arrays have been supplied. Note: will also insert VTK_PIXEL, but converts it to VTK_QUAD.

void vtkPolyData::Reset ( )

Begin inserting data all over again. Memory is not freed but otherwise objects are returned to their initial state.

void vtkPolyData::BuildCells ( )

Create data structure that allows random access of cells.

void vtkPolyData::BuildLinks ( )

Create upward links from points to cells that use each point. Enables topologically complex queries.

void vtkPolyData::DeleteCells ( )

Release data structure that allows random access of the cells. This must be done before a 2nd call to BuildLinks(). DeleteCells implicitly deletes the links as well since they are no longer valid.

void vtkPolyData::DeleteLinks ( )

Release the upward links from point to cells that use each point.

void vtkPolyData::GetPointCells | ( | vtkIdType | ptId,
 |  | unsigned short & | ncells,
 |  | vtkIdType *& | cells
 | ) | [inline]

Special (efficient) operations on poly data. Use carefully.

Definition at line 437 of file vtkPolyData.h.

void vtkPolyData::GetCellEdgeNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdType | p1,
 |  | vtkIdType | p2,
 |  | vtkIdList * | cellIds
 | ) |

Get the neighbors at an edge. More efficient than the general GetCellNeighbors(). Assumes links have been built (with BuildLinks()), and looks specifically for edge neighbors.

void vtkPolyData::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdType & | npts,
 |  | vtkIdType *& | pts
 | ) |

Return a pointer to a list of point ids defining cell. (More efficient.) Assumes that cells have been built (with BuildCells()).

int vtkPolyData::IsTriangle | ( | int | v1,
 |  | int | v2,
 |  | int | v3
 | ) | [inline]

Given three vertices, determine whether it's a triangle. Make sure BuildLinks() has been called first.

Definition at line 444 of file vtkPolyData.h.

int vtkPolyData::IsEdge | ( | int | p1,
 |  | int | p2
 | ) | [inline]

Determine whether two points form an edge. If they do, return non-zero. Make sure BuildLinks() has been called first.

Definition at line 490 of file vtkPolyData.h.

int vtkPolyData::IsPointUsedByCell | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) | [inline]

Determine whether a point is used by a particular cell. If it is, return non-zero. Make sure BuildCells() has been called first.

Definition at line 474 of file vtkPolyData.h.

Referenced by IsEdge().

void vtkPolyData::ReplaceCell | ( | vtkIdType | cellId,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

Replace the points defining cell "cellId" with a new set of points. This operator is(typically) used when links from points to cells have not been built (i.e., BuildLinks() has not been executed). Use the operator ReplaceLinkedCell() to replace a cell when cell structure has been built.

void vtkPolyData::ReplaceCellPoint | ( | vtkIdType | cellId,
 |  | vtkIdType | oldPtId,
 |  | vtkIdType | newPtId
 | ) | [inline]

Replace a point in the cell connectivity list with a different point.

Definition at line 545 of file vtkPolyData.h.

void vtkPolyData::ReverseCell ( vtkIdType cellId )

Reverse the order of point ids defining the cell.

void vtkPolyData::DeletePoint ( vtkIdType ptId ) [inline]

Mark a point/cell as deleted from this vtkPolyData.

Definition at line 508 of file vtkPolyData.h.

void vtkPolyData::DeleteCell ( vtkIdType cellId ) [inline]

Mark a point/cell as deleted from this vtkPolyData.

Definition at line 513 of file vtkPolyData.h.

int vtkPolyData::InsertNextLinkedPoint | ( | float | x[3],
 |  | int | numLinks
 | ) |

Add a point to the cell data structure (after cell pointers have been built). This method adds the point and then allocates memory for the links to the cells. (To use this method, make sure points are available and BuildLinks() has been invoked.)

int vtkPolyData::InsertNextLinkedCell | ( | int | type,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

Add a new cell to the cell data structure (after cell pointers have been built). This method adds the cell and then updates the links from the points to the cells. (Memory is allocated as necessary.)

void vtkPolyData::ReplaceLinkedCell | ( | vtkIdType | cellId,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

Replace one cell with another in cell structure. This operator updates the connectivity list and the point's link list. It does not delete references to the old cell in the point's link list. Use the operator RemoveCellReference() to delete all references from points to (old) cell. You may also want to consider using the operator ResizeCellList() if the link list is changing size.

void vtkPolyData::RemoveCellReference ( vtkIdType cellId ) [inline]

Remove all references to cell in cell structure. This means the links from the cell's points to the cell are deleted. Memory is not reclaimed. Use the method ResizeCellList() to resize the link list from a point to its using cells. (This operator assumes BuildLinks() has been called.)

Definition at line 518 of file vtkPolyData.h.

void vtkPolyData::AddCellReference ( vtkIdType cellId ) [inline]

Add references to cell in cell structure. This means the links from the cell's points to the cell are modified. Memory is not extended. Use the method ResizeCellList() to resize the link list from a point to its using cells. (This operator assumes BuildLinks() has been called.)

Definition at line 529 of file vtkPolyData.h.

void vtkPolyData::RemoveReferenceToCell | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) |

Remove a reference to a cell in a particular point's link list. You may also consider using RemoveCellReference() to remove the references from all the cell's points to the cell. This operator does not reallocate memory; use the operator ResizeCellList() to do this if necessary.

void vtkPolyData::AddReferenceToCell | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) |

Add a reference to a cell in a particular point's link list. (You may also consider using AddCellReference() to add the references from all the cell's points to the cell.) This operator does not realloc memory; use the operator ResizeCellList() to do this if necessary.

void vtkPolyData::ResizeCellList | ( | vtkIdType | ptId,
 |  | int | size
 | ) | [inline]

Resize the list of cells using a particular point. (This operator assumes that BuildLinks() has been called.)

Definition at line 540 of file vtkPolyData.h.

virtual void vtkPolyData::Initialize ( ) [virtual]

Restore object to initial state. Release memory back to system.

Reimplemented from vtkPointSet.

void vtkPolyData::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel
 | ) |

For streaming. User/next filter specifies which piece they want updated. The source of this poly data has to return exactly this piece.

void vtkPolyData::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

For streaming. User/next filter specifies which piece they want updated. The source of this poly data has to return exactly this piece.

Reimplemented from vtkDataObject.

Definition at line 336 of file vtkPolyData.h.

void vtkPolyData::GetUpdateExtent | ( | int & | piece,
 |  | int & | numPieces,
 |  | int & | ghostLevel
 | ) |

For streaming. User/next filter specifies which piece they want updated. The source of this poly data has to return exactly this piece.

virtual int* vtkPolyData::GetUpdateExtent ( ) [virtual]

We need this here to avoid hiding superclass method

Reimplemented from vtkDataObject.

virtual void vtkPolyData::GetUpdateExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

We need this here to avoid hiding superclass method

Reimplemented from vtkDataObject.

virtual void vtkPolyData::GetUpdateExtent ( int [6] ) [virtual]

We need this here to avoid hiding superclass method

Reimplemented from vtkDataObject.

void vtkPolyData::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [inline, virtual]

Call superclass method to avoid hiding Since this data type does not use 3D extents, this set method is useless but necessary since vtkDataSetToDataSetFilter does not know what type of data it is working on.

Reimplemented from vtkDataObject.

Definition at line 351 of file vtkPolyData.h.

void vtkPolyData::SetUpdateExtent ( int ext[6] ) [inline, virtual]

Call superclass method to avoid hiding Since this data type does not use 3D extents, this set method is useless but necessary since vtkDataSetToDataSetFilter does not know what type of data it is working on.

Reimplemented from vtkDataObject.

Definition at line 353 of file vtkPolyData.h.

virtual int vtkPolyData::GetPiece ( ) [virtual]

Set / Get the piece and the number of pieces. Similar to extent in 3D.

virtual int vtkPolyData::GetNumberOfPieces ( ) [virtual]

Set / Get the piece and the number of pieces. Similar to extent in 3D.

virtual int vtkPolyData::GetGhostLevel ( ) [virtual]

Get the ghost level.

unsigned long vtkPolyData::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkPointSet.

void vtkPolyData::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

void vtkPolyData::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

void vtkPolyData::RemoveGhostCells ( int level )

This method will remove any cell that has a ghost level array value greater or equal to level. It does not remove unused points (yet).

virtual void vtkPolyData::Crop ( ) [protected, virtual]

Reimplemented from vtkDataObject.

Member Data Documentation

vtkVertex* vtkPolyData::Vertex [protected]

Definition at line 391 of file vtkPolyData.h.

vtkPolyVertex* vtkPolyData::PolyVertex [protected]

Definition at line 392 of file vtkPolyData.h.

vtkLine* vtkPolyData::Line [protected]

Definition at line 393 of file vtkPolyData.h.

vtkPolyLine* vtkPolyData::PolyLine [protected]

Definition at line 394 of file vtkPolyData.h.

vtkTriangle* vtkPolyData::Triangle [protected]

Definition at line 395 of file vtkPolyData.h.

vtkQuad* vtkPolyData::Quad [protected]

Definition at line 396 of file vtkPolyData.h.

vtkPolygon* vtkPolyData::Polygon [protected]

Definition at line 397 of file vtkPolyData.h.

vtkTriangleStrip* vtkPolyData::TriangleStrip [protected]

Definition at line 398 of file vtkPolyData.h.

vtkEmptyCell* vtkPolyData::EmptyCell [protected]

Definition at line 399 of file vtkPolyData.h.

vtkCellArray* vtkPolyData::Verts [protected]

Definition at line 403 of file vtkPolyData.h.

vtkCellArray* vtkPolyData::Lines [protected]

Definition at line 404 of file vtkPolyData.h.

vtkCellArray* vtkPolyData::Polys [protected]

Definition at line 405 of file vtkPolyData.h.

vtkCellArray* vtkPolyData::Strips [protected]

Definition at line 406 of file vtkPolyData.h.

vtkCellArray* vtkPolyData::Dummy [static, protected]

Definition at line 409 of file vtkPolyData.h.

vtkCellTypes* vtkPolyData::Cells [protected]

Definition at line 413 of file vtkPolyData.h.

vtkCellLinks* vtkPolyData::Links [protected]

Definition at line 414 of file vtkPolyData.h.

The documentation for this class was generated from the following file:
  • Common/vtkPolyData.h
Generated on Mon Mar 25 01:28:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataCollection Class Reference

maintain a list of polygonal data objects. More...

#include <vtkPolyDataCollection.h>

Inheritance diagram for vtkPolyDataCollection:

[legend]
Collaboration diagram for vtkPolyDataCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataCollection, vtkCollection)
void | AddItem (vtkPolyData *pd)
vtkPolyData * GetNextItem ()

Static Public Methods

vtkPolyDataCollection * | New ()

Protected Methods

vtkPolyDataCollection ()
~vtkPolyDataCollection ()

Detailed Description

maintain a list of polygonal data objects.

Date:
2002/01/22 15:28:10
Revision:
1.38

vtkPolyDataCollection is an object that creates and manipulates lists of datasets of type vtkPolyData.

See also:
vtkDataSetCollection vtkCollection
Created by:
  • Hoffman, Bill
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (57%)
  • Martin, Ken (21%)
  • Hoffman, Bill (20%)

Definition at line 44 of file vtkPolyDataCollection.h.

Constructor & Destructor Documentation

vtkPolyDataCollection::vtkPolyDataCollection ( ) [inline, protected]

Definition at line 62 of file vtkPolyDataCollection.h.

vtkPolyDataCollection::~vtkPolyDataCollection ( ) [inline, protected]

Definition at line 63 of file vtkPolyDataCollection.h.

Member Function Documentation

vtkPolyDataCollection* vtkPolyDataCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkPolyDataCollection::vtkTypeRevisionMacro | ( | vtkPolyDataCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkPolyDataCollection::AddItem ( vtkPolyData * pd ) [inline]

Add a poly data to the list.

Definition at line 52 of file vtkPolyDataCollection.h.

vtkPolyData* vtkPolyDataCollection::GetNextItem ( ) [inline]

Get the next poly data in the list.

Definition at line 58 of file vtkPolyDataCollection.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkPolyDataCollection.h
Generated on Mon Mar 25 01:28:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataConnectivityFilter Class Reference

extract polygonal data based on geometric connectivity. More...

#include <vtkPolyDataConnectivityFilter.h>

Inheritance diagram for vtkPolyDataConnectivityFilter:

[legend]
Collaboration diagram for vtkPolyDataConnectivityFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataConnectivityFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | InitializeSeedList ()
void | AddSeed (int id)
void | DeleteSeed (int id)
void | InitializeSpecifiedRegionList ()
void | AddSpecifiedRegion (int id)
void | DeleteSpecifiedRegion (int id)
int | GetNumberOfExtractedRegions ()
virtual void | SetScalarConnectivity (int)
virtual int | GetScalarConnectivity ()
virtual void | ScalarConnectivityOn ()
virtual void | ScalarConnectivityOff ()
virtual void | SetScalarRange (float data[])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float data[2])
virtual void | SetExtractionMode (int)
virtual int | GetExtractionMode ()
void | SetExtractionModeToPointSeededRegions ()
void | SetExtractionModeToCellSeededRegions ()
void | SetExtractionModeToLargestRegion ()
void | SetExtractionModeToSpecifiedRegions ()
void | SetExtractionModeToClosestPointRegion ()
void | SetExtractionModeToAllRegions ()
const char * | GetExtractionModeAsString ()
virtual void | SetClosestPoint (float, float, float)
virtual void | SetClosestPoint (float[3])
virtual float * | GetClosestPoint ()
virtual void | GetClosestPoint (float data[3])
virtual void | SetColorRegions (int)
virtual int | GetColorRegions ()
virtual void | ColorRegionsOn ()
virtual void | ColorRegionsOff ()

Static Public Methods

vtkPolyDataConnectivityFilter * | New ()

Protected Methods

vtkPolyDataConnectivityFilter ()
~vtkPolyDataConnectivityFilter ()
void | Execute ()
void | TraverseAndMark ()

Protected Attributes

int | ColorRegions
int | ExtractionMode
vtkIdList * Seeds
vtkIdList * SpecifiedRegionIds
vtkIdTypeArray * RegionSizes
float | ClosestPoint [3]
int | ScalarConnectivity
float | ScalarRange [2]

Detailed Description

extract polygonal data based on geometric connectivity.

Date:
2002/01/22 15:29:35
Revision:
1.30

vtkPolyDataConnectivityFilter is a filter that extracts cells that share common points and/or satisfy a scalar threshold criterion. (Such a group of cells is called a region.) The filter works in one of six ways: 1) extract the largest connected region in the dataset; 2) extract specified region numbers; 3) extract all regions sharing specified point ids; 4) extract all regions sharing specified cell ids; 5) extract the region closest to the specified point; or 6) extract all regions (used to color regions).

This filter is specialized for polygonal data. This means it runs a bit faster and is easier to construct visualization networks that process polygonal data.

The behavior of vtkPolyDataConnectivityFilter can be modified by turning on the boolean ivar ScalarConnectivity. If this flag is on, the connectivity algorithm is modified so that cells are considered connected only if 1) they are geometrically connected (share a point) and 2) the scalar values of one of the cell's points falls in the scalar range specified. This use of ScalarConnectivity is particularly useful for selecting cells for later processing.

See also:
vtkConnectivityFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Martin, Ken (17%)
  • Lorensen, Bill (6%)
Tests:
vtkPolyDataConnectivityFilter (Tests)

Definition at line 72 of file vtkPolyDataConnectivityFilter.h.

Constructor & Destructor Documentation

vtkPolyDataConnectivityFilter::vtkPolyDataConnectivityFilter ( ) [protected]

vtkPolyDataConnectivityFilter::~vtkPolyDataConnectivityFilter ( ) [protected]

Member Function Documentation

vtkPolyDataConnectivityFilter::vtkTypeRevisionMacro | ( | vtkPolyDataConnectivityFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkPolyDataConnectivityFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkPolyDataConnectivityFilter* vtkPolyDataConnectivityFilter::New ( ) [static]

Construct with default extraction mode to extract largest regions.

Reimplemented from vtkPolyDataSource.

virtual void vtkPolyDataConnectivityFilter::SetScalarConnectivity ( int ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual int vtkPolyDataConnectivityFilter::GetScalarConnectivity ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkPolyDataConnectivityFilter::ScalarConnectivityOn ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkPolyDataConnectivityFilter::ScalarConnectivityOff ( ) [virtual]

Turn on/off connectivity based on scalar value. If on, cells are connected only if they share points AND one of the cells scalar values falls in the scalar range specified.

virtual void vtkPolyDataConnectivityFilter::SetScalarRange ( float data[] ) [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual float* vtkPolyDataConnectivityFilter::GetScalarRange ( ) [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual void vtkPolyDataConnectivityFilter::GetScalarRange ( float data[2] ) [virtual]

Set the scalar range to use to extract cells based on scalar connectivity.

virtual void vtkPolyDataConnectivityFilter::SetExtractionMode ( int ) [virtual]

Control the extraction of connected surfaces.

virtual int vtkPolyDataConnectivityFilter::GetExtractionMode ( ) [virtual]

Control the extraction of connected surfaces.

void vtkPolyDataConnectivityFilter::SetExtractionModeToPointSeededRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 103 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::SetExtractionModeToCellSeededRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 105 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::SetExtractionModeToLargestRegion ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 107 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::SetExtractionModeToSpecifiedRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 109 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::SetExtractionModeToClosestPointRegion ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 111 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::SetExtractionModeToAllRegions ( ) [inline]

Control the extraction of connected surfaces.

Definition at line 113 of file vtkPolyDataConnectivityFilter.h.

const char * vtkPolyDataConnectivityFilter::GetExtractionModeAsString ( void ) [inline]

Return the method of extraction as a string.

Definition at line 195 of file vtkPolyDataConnectivityFilter.h.

void vtkPolyDataConnectivityFilter::InitializeSeedList ( )

Initialize list of point ids/cell ids used to seed regions.

void vtkPolyDataConnectivityFilter::AddSeed ( int id )

Add a seed id (point or cell id). Note: ids are 0-offset.

void vtkPolyDataConnectivityFilter::DeleteSeed ( int id )

Delete a seed id (point or cell id). Note: ids are 0-offset.

void vtkPolyDataConnectivityFilter::InitializeSpecifiedRegionList ( )

Initialize list of region ids to extract.

void vtkPolyDataConnectivityFilter::AddSpecifiedRegion ( int id )

Add a region id to extract. Note: ids are 0-offset.

void vtkPolyDataConnectivityFilter::DeleteSpecifiedRegion ( int id )

Delete a region id to extract. Note: ids are 0-offset.

virtual void vtkPolyDataConnectivityFilter::SetClosestPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual void vtkPolyDataConnectivityFilter::SetClosestPoint ( float [3] ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual float* vtkPolyDataConnectivityFilter::GetClosestPoint ( ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

virtual void vtkPolyDataConnectivityFilter::GetClosestPoint ( float data[3] ) [virtual]

Use to specify x-y-z point coordinates when extracting the region closest to a specified point.

int vtkPolyDataConnectivityFilter::GetNumberOfExtractedRegions ( )

Obtain the number of connected regions.

virtual void vtkPolyDataConnectivityFilter::SetColorRegions ( int ) [virtual]

Turn on/off the coloring of connected regions.

virtual int vtkPolyDataConnectivityFilter::GetColorRegions ( ) [virtual]

Turn on/off the coloring of connected regions.

virtual void vtkPolyDataConnectivityFilter::ColorRegionsOn ( ) [virtual]

Turn on/off the coloring of connected regions.

virtual void vtkPolyDataConnectivityFilter::ColorRegionsOff ( ) [virtual]

Turn on/off the coloring of connected regions.

void vtkPolyDataConnectivityFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPolyDataConnectivityFilter::TraverseAndMark ( ) [protected]

Member Data Documentation

int vtkPolyDataConnectivityFilter::ColorRegions [protected]

Definition at line 160 of file vtkPolyDataConnectivityFilter.h.

int vtkPolyDataConnectivityFilter::ExtractionMode [protected]

Definition at line 161 of file vtkPolyDataConnectivityFilter.h.

vtkIdList* vtkPolyDataConnectivityFilter::Seeds [protected]

Definition at line 162 of file vtkPolyDataConnectivityFilter.h.

vtkIdList* vtkPolyDataConnectivityFilter::SpecifiedRegionIds [protected]

Definition at line 163 of file vtkPolyDataConnectivityFilter.h.

vtkIdTypeArray* vtkPolyDataConnectivityFilter::RegionSizes [protected]

Definition at line 164 of file vtkPolyDataConnectivityFilter.h.

float vtkPolyDataConnectivityFilter::ClosestPoint[3] [protected]

Definition at line 166 of file vtkPolyDataConnectivityFilter.h.

int vtkPolyDataConnectivityFilter::ScalarConnectivity [protected]

Definition at line 168 of file vtkPolyDataConnectivityFilter.h.

float vtkPolyDataConnectivityFilter::ScalarRange[2] [protected]

Definition at line 169 of file vtkPolyDataConnectivityFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPolyDataConnectivityFilter.h
Generated on Mon Mar 25 01:28:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataMapper Class Reference

map vtkPolyData to graphics primitives. More...

#include <vtkPolyDataMapper.h>

Inheritance diagram for vtkPolyDataMapper:

[legend]
Collaboration diagram for vtkPolyDataMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataMapper, vtkMapper)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | RenderPiece (vtkRenderer *ren, vtkActor *act)=0
virtual void | Render (vtkRenderer *ren, vtkActor *act)
void | Update ()
void | ShallowCopy (vtkAbstractMapper *m)
void | SetInput (vtkPolyData *in)
vtkPolyData * GetInput ()
virtual void | SetPiece (int)
virtual int | GetPiece ()
virtual void | SetNumberOfPieces (int)
virtual int | GetNumberOfPieces ()
virtual void | SetNumberOfSubPieces (int)
virtual int | GetNumberOfSubPieces ()
virtual void | SetGhostLevel (int)
virtual int | GetGhostLevel ()
virtual float * | GetBounds ()
virtual void | GetBounds (float bounds[6])

Static Public Methods

vtkPolyDataMapper * | New ()

Protected Methods

vtkPolyDataMapper ()
~vtkPolyDataMapper ()

Protected Attributes

int | Piece
int | NumberOfPieces
int | NumberOfSubPieces
int | GhostLevel

Detailed Description

map vtkPolyData to graphics primitives.

Date:
2002/01/22 15:39:06
Revision:
1.30

vtkPolyDataMapper is a class that maps polygonal data (i.e., vtkPolyData) to graphics primitives. vtkPolyDataMapper serves as a superclass for device-specific poly data mappers, that actually do the mapping to the rendering/graphics hardware/software. It is now possible to set a memory limit for the pipeline in the mapper. If the total estimated memory usage of the pipeline is larger than this limit, the mapper will divide the data into pieces and render each in a for loop.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (32%)
  • Geveci, Berk (21%)
  • Law, Charles (17%)
  • Martin, Ken (15%)
  • Lorensen, Bill (6%)
Examples:
vtkPolyDataMapper (Examples)
Tests:
vtkPolyDataMapper (Tests)

Definition at line 55 of file vtkPolyDataMapper.h.

Constructor & Destructor Documentation

vtkPolyDataMapper::vtkPolyDataMapper ( ) [protected]

vtkPolyDataMapper::~vtkPolyDataMapper ( ) [inline, protected]

Definition at line 106 of file vtkPolyDataMapper.h.

Member Function Documentation

vtkPolyDataMapper* vtkPolyDataMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkMesaPolyDataMapper, and vtkOpenGLPolyDataMapper.

vtkPolyDataMapper::vtkTypeRevisionMacro | ( | vtkPolyDataMapper | ,
 |  | vtkMapper |
 | ) |

Reimplemented from vtkMapper.

Reimplemented in vtkMesaPolyDataMapper, and vtkOpenGLPolyDataMapper.

void vtkPolyDataMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper.

virtual void vtkPolyDataMapper::RenderPiece | ( | vtkRenderer * | ren,
 |  | vtkActor * | a
 | ) | [pure virtual]

Implemented by sub classes. Actual rendering is done here.

Reimplemented in vtkMesaPolyDataMapper, and vtkOpenGLPolyDataMapper.

virtual void vtkPolyDataMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkActor * | act
 | ) | [virtual]

This calls RenderPiece (in a for loop is streaming is necessary).

Reimplemented from vtkMapper.

void vtkPolyDataMapper::SetInput ( vtkPolyData * in )

Specify the input data to map.

vtkPolyData* vtkPolyDataMapper::GetInput ( )

Specify the input data to map.

Reimplemented from vtkMapper.

void vtkPolyDataMapper::Update ( void ) [virtual]

Update that sets the update piece first.

Reimplemented from vtkMapper.

virtual void vtkPolyDataMapper::SetPiece ( int ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual int vtkPolyDataMapper::GetPiece ( ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual void vtkPolyDataMapper::SetNumberOfPieces ( int ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual int vtkPolyDataMapper::GetNumberOfPieces ( ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual void vtkPolyDataMapper::SetNumberOfSubPieces ( int ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual int vtkPolyDataMapper::GetNumberOfSubPieces ( ) [virtual]

If you want only a part of the data, specify by setting the piece.

virtual void vtkPolyDataMapper::SetGhostLevel ( int ) [virtual]

Set the number of ghost cells to return.

virtual int vtkPolyDataMapper::GetGhostLevel ( ) [virtual]

Set the number of ghost cells to return.

virtual float* vtkPolyDataMapper::GetBounds ( ) [virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkMapper.

virtual void vtkPolyDataMapper::GetBounds ( float bounds[6] ) [inline, virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkMapper.

Definition at line 97 of file vtkPolyDataMapper.h.

void vtkPolyDataMapper::ShallowCopy ( vtkAbstractMapper * m )

Make a shallow copy of this mapper.

Reimplemented from vtkMapper.

Member Data Documentation

int vtkPolyDataMapper::Piece [protected]

Definition at line 108 of file vtkPolyDataMapper.h.

int vtkPolyDataMapper::NumberOfPieces [protected]

Definition at line 109 of file vtkPolyDataMapper.h.

int vtkPolyDataMapper::NumberOfSubPieces [protected]

Definition at line 110 of file vtkPolyDataMapper.h.

int vtkPolyDataMapper::GhostLevel [protected]

Definition at line 111 of file vtkPolyDataMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkPolyDataMapper.h
Generated on Mon Mar 25 01:28:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataMapper2D Class Reference

draw vtkPolyData onto the image plane. More...

#include <vtkPolyDataMapper2D.h>

Inheritance diagram for vtkPolyDataMapper2D:

[legend]
Collaboration diagram for vtkPolyDataMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataMapper2D, vtkMapper2D)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | CreateDefaultLookupTable ()
const char * | GetColorModeAsString ()
virtual unsigned long | GetMTime ()
vtkUnsignedCharArray * | MapScalars (float alpha)
void | ShallowCopy (vtkAbstractMapper *m)
virtual void | SetInput (vtkPolyData *)
virtual vtkPolyData * | GetInput ()
void | SetLookupTable (vtkScalarsToColors *lut)
vtkScalarsToColors * GetLookupTable ()
virtual void | SetScalarVisibility (int)
virtual int | GetScalarVisibility ()
virtual void | ScalarVisibilityOn ()
virtual void | ScalarVisibilityOff ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToDefault ()
void | SetColorModeToMapScalars ()
virtual void | SetUseLookupTableScalarRange (int)
virtual int | GetUseLookupTableScalarRange ()
virtual void | UseLookupTableScalarRangeOn ()
virtual void | UseLookupTableScalarRangeOff ()
virtual void | SetScalarRange (float, float)
void | SetScalarRange (float[2])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float data[2])
virtual void | SetScalarMode (int)
virtual int | GetScalarMode ()
void | SetScalarModeToDefault ()
void | SetScalarModeToUsePointData ()
void | SetScalarModeToUseCellData ()
void | SetScalarModeToUsePointFieldData ()
void | SetScalarModeToUseCellFieldData ()
void | ColorByArrayComponent (int arrayNum, int component)
void | ColorByArrayComponent (char *arrayName, int component)
char * | GetArrayName ()
int | GetArrayId ()
int | GetArrayAccessMode ()
int | GetArrayComponent ()
virtual void | SetTransformCoordinate (vtkCoordinate *)
virtual vtkCoordinate * | GetTransformCoordinate ()

Static Public Methods

vtkPolyDataMapper2D * | New ()

Protected Methods

vtkPolyDataMapper2D ()
~vtkPolyDataMapper2D ()

Protected Attributes

vtkPolyData * Input
vtkUnsignedCharArray * Colors
vtkScalarsToColors * LookupTable
int | ScalarVisibility
vtkTimeStamp BuildTime
float | ScalarRange [2]
int | UseLookupTableScalarRange
int | ColorMode
int | ScalarMode
vtkCoordinate * TransformCoordinate
int | ArrayId
char | ArrayName [256]
int | ArrayComponent
int | ArrayAccessMode

Detailed Description

draw vtkPolyData onto the image plane.

Date:
2002/01/22 15:39:08
Revision:
1.33

vtkPolyDataMapper2D is a mapper that renders 3D polygonal data (vtkPolyData) onto the 2D image plane (i.e., the renderer's viewport). By default, the 3D data is transformed into 2D data by ignoring the z-coordinate of the 3D points in vtkPolyData, and taking the x-y values as local display values (i.e., pixel coordinates). Alternatively, you can provide a vtkCoordinate object that will transform the data into local display coordinates (use the vtkCoordinate::SetCoordinateSystem() methods to indicate which coordinate system you are transforming the data from).

See also:
vtkMapper2D vtkActor2D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (51%)
  • Schroeder, Will (27%)
  • Biddiscombe, John (5%)
Examples:
vtkPolyDataMapper2D (Examples)
Tests:
vtkPolyDataMapper2D (Tests)

Definition at line 62 of file vtkPolyDataMapper2D.h.

Constructor & Destructor Documentation

vtkPolyDataMapper2D::vtkPolyDataMapper2D ( ) [protected]

vtkPolyDataMapper2D::~vtkPolyDataMapper2D ( ) [protected]

Member Function Documentation

vtkPolyDataMapper2D::vtkTypeRevisionMacro | ( | vtkPolyDataMapper2D | ,
 |  | vtkMapper2D |
 | ) |

Reimplemented from vtkMapper2D.

Reimplemented in vtkMesaPolyDataMapper2D, vtkOpenGLPolyDataMapper2D, vtkWin32PolyDataMapper2D, and vtkXPolyDataMapper2D.

vtkPolyDataMapper2D* vtkPolyDataMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkMapper2D.

Reimplemented in vtkMesaPolyDataMapper2D, vtkOpenGLPolyDataMapper2D, vtkWin32PolyDataMapper2D, and vtkXPolyDataMapper2D.

void vtkPolyDataMapper2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper2D.

virtual void vtkPolyDataMapper2D::SetInput ( vtkPolyData * ) [virtual]

Set the input to the mapper.

virtual vtkPolyData* vtkPolyDataMapper2D::GetInput ( ) [virtual]

Set the input to the mapper.

void vtkPolyDataMapper2D::SetLookupTable ( vtkScalarsToColors * lut )

Specify a lookup table for the mapper to use.

vtkScalarsToColors* vtkPolyDataMapper2D::GetLookupTable ( )

Specify a lookup table for the mapper to use.

virtual void vtkPolyDataMapper2D::CreateDefaultLookupTable ( ) [virtual]

Create default lookup table. Generally used to create one when none is available with the scalar data.

virtual void vtkPolyDataMapper2D::SetScalarVisibility ( int ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual int vtkPolyDataMapper2D::GetScalarVisibility ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkPolyDataMapper2D::ScalarVisibilityOn ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkPolyDataMapper2D::ScalarVisibilityOff ( ) [virtual]

Turn on/off flag to control whether scalar data is used to color objects.

virtual void vtkPolyDataMapper2D::SetColorMode ( int ) [virtual]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

virtual int vtkPolyDataMapper2D::GetColorMode ( ) [virtual]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

void vtkPolyDataMapper2D::SetColorModeToDefault ( ) [inline]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

Definition at line 103 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::SetColorModeToMapScalars ( ) [inline]

Control how the scalar data is mapped to colors. By default (ColorModeToDefault), unsigned char scalars are treated as colors, and NOT mapped through the lookup table, while everything else is. Setting ColorModeToMapScalars means that all scalar data will be mapped through the lookup table. (Note that for multi-component scalars, the particular component to use for mapping can be specified using the ColorByArrayComponent() method.)

Definition at line 105 of file vtkPolyDataMapper2D.h.

const char* vtkPolyDataMapper2D::GetColorModeAsString ( void )

Return the method of coloring scalar data.

virtual void vtkPolyDataMapper2D::SetUseLookupTableScalarRange ( int ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual int vtkPolyDataMapper2D::GetUseLookupTableScalarRange ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkPolyDataMapper2D::UseLookupTableScalarRangeOn ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkPolyDataMapper2D::UseLookupTableScalarRangeOff ( ) [virtual]

Control whether the mapper sets the lookuptable range based on its own ScalarRange, or whether it will use the LookupTable ScalarRange regardless of it's own setting. By default the Mapper is allowed to set the LookupTable range, but users who are sharing LookupTables between mappers/actors will probably wish to force the mapper to use the LookupTable unchanged.

virtual void vtkPolyDataMapper2D::SetScalarRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

void vtkPolyDataMapper2D::SetScalarRange ( float [2] )

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual float* vtkPolyDataMapper2D::GetScalarRange ( ) [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual void vtkPolyDataMapper2D::GetScalarRange ( float data[2] ) [virtual]

Specify range in terms of scalar minimum and maximum (smin,smax). These values are used to map scalars into lookup table. Has no effect when UseLookupTableScalarRange is true.

virtual void vtkPolyDataMapper2D::SetScalarMode ( int ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

virtual int vtkPolyDataMapper2D::GetScalarMode ( ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

void vtkPolyDataMapper2D::SetScalarModeToDefault ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 145 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::SetScalarModeToUsePointData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 147 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::SetScalarModeToUseCellData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 149 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::SetScalarModeToUsePointFieldData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 151 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::SetScalarModeToUseCellFieldData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (ScalarModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (ScalarModeToUsePointData) or cell data (ScalarModeToUseCellData). You can also choose to get the scalars from an array in point field data (ScalarModeToUsePointFieldData) or cell field data (ScalarModeToUseCellFieldData). If scalars are coming from a field data array, you must call ColorByArrayComponent before you call GetColors.

Definition at line 153 of file vtkPolyDataMapper2D.h.

void vtkPolyDataMapper2D::ColorByArrayComponent | ( | int | arrayNum,
 |  | int | component
 | ) |

Choose which component of which field data array to color by.

void vtkPolyDataMapper2D::ColorByArrayComponent | ( | char * | arrayName,
 |  | int | component
 | ) |

Choose which component of which field data array to color by.

char* vtkPolyDataMapper2D::GetArrayName ( ) [inline]

Get the array name or number and component to color by.

Definition at line 165 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::GetArrayId ( ) [inline]

Get the array name or number and component to color by.

Definition at line 166 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::GetArrayAccessMode ( ) [inline]

Get the array name or number and component to color by.

Definition at line 167 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::GetArrayComponent ( ) [inline]

Get the array name or number and component to color by.

Definition at line 168 of file vtkPolyDataMapper2D.h.

virtual unsigned long vtkPolyDataMapper2D::GetMTime ( ) [virtual]

Overload standard modified time function. If lookup table is modified, then this object is modified as well.

Reimplemented from vtkAbstractMapper.

virtual void vtkPolyDataMapper2D::SetTransformCoordinate ( vtkCoordinate * ) [virtual]

Specify a vtkCoordinate object to be used to transform the vtkPolyData point coordinates. By default (no vtkCoordinate specified), the point coordinates are taken as local display coordinates.

virtual vtkCoordinate* vtkPolyDataMapper2D::GetTransformCoordinate ( ) [virtual]

Specify a vtkCoordinate object to be used to transform the vtkPolyData point coordinates. By default (no vtkCoordinate specified), the point coordinates are taken as local display coordinates.

vtkUnsignedCharArray* vtkPolyDataMapper2D::MapScalars ( float alpha )

Map the scalars (if there are any scalars and ScalarVisibility is on) through the lookup table, returning an unsigned char RGBA array. This is typically done as part of the rendering process. The alpha parameter allows the blending of the scalars with an additional alpha (typically which comes from a vtkActor, etc.)

void vtkPolyDataMapper2D::ShallowCopy ( vtkAbstractMapper * m )

Make a shallow copy of this mapper.

Reimplemented from vtkAbstractMapper.

Member Data Documentation

vtkPolyData* vtkPolyDataMapper2D::Input [protected]

Definition at line 198 of file vtkPolyDataMapper2D.h.

vtkUnsignedCharArray* vtkPolyDataMapper2D::Colors [protected]

Definition at line 200 of file vtkPolyDataMapper2D.h.

vtkScalarsToColors* vtkPolyDataMapper2D::LookupTable [protected]

Definition at line 202 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ScalarVisibility [protected]

Definition at line 203 of file vtkPolyDataMapper2D.h.

vtkTimeStamp vtkPolyDataMapper2D::BuildTime [protected]

Definition at line 204 of file vtkPolyDataMapper2D.h.

float vtkPolyDataMapper2D::ScalarRange[2] [protected]

Definition at line 205 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::UseLookupTableScalarRange [protected]

Definition at line 206 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ColorMode [protected]

Definition at line 207 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ScalarMode [protected]

Definition at line 208 of file vtkPolyDataMapper2D.h.

vtkCoordinate* vtkPolyDataMapper2D::TransformCoordinate [protected]

Definition at line 210 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ArrayId [protected]

Definition at line 213 of file vtkPolyDataMapper2D.h.

char vtkPolyDataMapper2D::ArrayName[256] [protected]

Definition at line 214 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ArrayComponent [protected]

Definition at line 215 of file vtkPolyDataMapper2D.h.

int vtkPolyDataMapper2D::ArrayAccessMode [protected]

Definition at line 216 of file vtkPolyDataMapper2D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkPolyDataMapper2D.h
Generated on Mon Mar 25 01:28:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataNormals Class Reference

compute normals for polygonal mesh. More...

#include <vtkPolyDataNormals.h>

Inheritance diagram for vtkPolyDataNormals:

[legend]
Collaboration diagram for vtkPolyDataNormals:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataNormals, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFeatureAngle (float)
virtual float | GetFeatureAngle ()
virtual void | SetSplitting (int)
virtual int | GetSplitting ()
virtual void | SplittingOn ()
virtual void | SplittingOff ()
virtual void | SetConsistency (int)
virtual int | GetConsistency ()
virtual void | ConsistencyOn ()
virtual void | ConsistencyOff ()
virtual void | SetComputePointNormals (int)
virtual int | GetComputePointNormals ()
virtual void | ComputePointNormalsOn ()
virtual void | ComputePointNormalsOff ()
virtual void | SetComputeCellNormals (int)
virtual int | GetComputeCellNormals ()
virtual void | ComputeCellNormalsOn ()
virtual void | ComputeCellNormalsOff ()
virtual void | SetFlipNormals (int)
virtual int | GetFlipNormals ()
virtual void | FlipNormalsOn ()
virtual void | FlipNormalsOff ()
virtual void | SetNonManifoldTraversal (int)
virtual int | GetNonManifoldTraversal ()
virtual void | NonManifoldTraversalOn ()
virtual void | NonManifoldTraversalOff ()
void | SetMaxRecursionDepth (int)
int | GetMaxRecursionDepth ()

Static Public Methods

vtkPolyDataNormals * | New ()

Protected Methods

vtkPolyDataNormals ()
~vtkPolyDataNormals ()
void | Execute ()

Protected Attributes

float | FeatureAngle
int | Splitting
int | Consistency
int | FlipNormals
int | NonManifoldTraversal
int | ComputePointNormals
int | ComputeCellNormals
int | NumFlips

Detailed Description

compute normals for polygonal mesh.

Date:
2002/01/22 15:29:36
Revision:
1.28

vtkPolyDataNormals is a filter that computes point normals for a polygonal mesh. The filter can reorder polygons to insure consistent orientation across polygon neighbors. Sharp edges can be split and points duplicated with separate normals to give crisp (rendered) surface definition. It is also possible to globally flip the normal orientation.

The algorithm works by determining normals for each polygon and then averaging them at shared points. When sharp edges are present, the edges are split and new points generated to prevent blurry edges (due to Gouraud shading).

Warning:
Normals are computed only for polygons and triangle strips. Normals are not computed for lines or vertices.
Warning:
Triangle strips are broken up into triangle polygons. You may want to restrip the triangles.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Lorensen, Bill (16%)
  • Henderson, Amy (7%)
Examples:
vtkPolyDataNormals (Examples)
Tests:
vtkPolyDataNormals (Tests)

Definition at line 62 of file vtkPolyDataNormals.h.

Constructor & Destructor Documentation

vtkPolyDataNormals::vtkPolyDataNormals ( ) [protected]

vtkPolyDataNormals::~vtkPolyDataNormals ( ) [inline, protected]

Definition at line 142 of file vtkPolyDataNormals.h.

Member Function Documentation

vtkPolyDataNormals::vtkTypeRevisionMacro | ( | vtkPolyDataNormals | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

Reimplemented in vtkPPolyDataNormals.

void vtkPolyDataNormals::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkPPolyDataNormals.

vtkPolyDataNormals* vtkPolyDataNormals::New ( ) [static]

Construct with feature angle=30, splitting and consistency turned on, flipNormals turned off, and non-manifold traversal turned on. ComputePointNormals is on and ComputeCellNormals is off.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkPPolyDataNormals.

virtual void vtkPolyDataNormals::SetFeatureAngle ( float ) [virtual]

Specify the angle that defines a sharp edge. If the difference in angle across neighboring polygons is greater than this value, the shared edge is considered "sharp".

virtual float vtkPolyDataNormals::GetFeatureAngle ( ) [virtual]

Specify the angle that defines a sharp edge. If the difference in angle across neighboring polygons is greater than this value, the shared edge is considered "sharp".

virtual void vtkPolyDataNormals::SetSplitting ( int ) [virtual]

Turn on/off the splitting of sharp edges.

virtual int vtkPolyDataNormals::GetSplitting ( ) [virtual]

Turn on/off the splitting of sharp edges.

virtual void vtkPolyDataNormals::SplittingOn ( ) [virtual]

Turn on/off the splitting of sharp edges.

virtual void vtkPolyDataNormals::SplittingOff ( ) [virtual]

Turn on/off the splitting of sharp edges.

virtual void vtkPolyDataNormals::SetConsistency ( int ) [virtual]

Turn on/off the enforcement of consistent polygon ordering.

virtual int vtkPolyDataNormals::GetConsistency ( ) [virtual]

Turn on/off the enforcement of consistent polygon ordering.

virtual void vtkPolyDataNormals::ConsistencyOn ( ) [virtual]

Turn on/off the enforcement of consistent polygon ordering.

virtual void vtkPolyDataNormals::ConsistencyOff ( ) [virtual]

Turn on/off the enforcement of consistent polygon ordering.

virtual void vtkPolyDataNormals::SetComputePointNormals ( int ) [virtual]

Turn on/off the computation of point normals.

virtual int vtkPolyDataNormals::GetComputePointNormals ( ) [virtual]

Turn on/off the computation of point normals.

virtual void vtkPolyDataNormals::ComputePointNormalsOn ( ) [virtual]

Turn on/off the computation of point normals.

virtual void vtkPolyDataNormals::ComputePointNormalsOff ( ) [virtual]

Turn on/off the computation of point normals.

virtual void vtkPolyDataNormals::SetComputeCellNormals ( int ) [virtual]

Turn on/off the computation of cell normals.

virtual int vtkPolyDataNormals::GetComputeCellNormals ( ) [virtual]

Turn on/off the computation of cell normals.

virtual void vtkPolyDataNormals::ComputeCellNormalsOn ( ) [virtual]

Turn on/off the computation of cell normals.

virtual void vtkPolyDataNormals::ComputeCellNormalsOff ( ) [virtual]

Turn on/off the computation of cell normals.

virtual void vtkPolyDataNormals::SetFlipNormals ( int ) [virtual]

Turn on/off the global flipping of normal orientation. Flipping reverves the meaning of front and back for Frontface and Backface culling in vtkProperty. Flipping modifies both the normal direction and the order of a cell's points.

virtual int vtkPolyDataNormals::GetFlipNormals ( ) [virtual]

Turn on/off the global flipping of normal orientation. Flipping reverves the meaning of front and back for Frontface and Backface culling in vtkProperty. Flipping modifies both the normal direction and the order of a cell's points.

virtual void vtkPolyDataNormals::FlipNormalsOn ( ) [virtual]

Turn on/off the global flipping of normal orientation. Flipping reverves the meaning of front and back for Frontface and Backface culling in vtkProperty. Flipping modifies both the normal direction and the order of a cell's points.

virtual void vtkPolyDataNormals::FlipNormalsOff ( ) [virtual]

Turn on/off the global flipping of normal orientation. Flipping reverves the meaning of front and back for Frontface and Backface culling in vtkProperty. Flipping modifies both the normal direction and the order of a cell's points.

virtual void vtkPolyDataNormals::SetNonManifoldTraversal ( int ) [virtual]

Turn on/off traversal across non-manifold edges. This will prevent problems where the consistency of polygonal ordering is corrupted due to topological loops.

virtual int vtkPolyDataNormals::GetNonManifoldTraversal ( ) [virtual]

Turn on/off traversal across non-manifold edges. This will prevent problems where the consistency of polygonal ordering is corrupted due to topological loops.

virtual void vtkPolyDataNormals::NonManifoldTraversalOn ( ) [virtual]

Turn on/off traversal across non-manifold edges. This will prevent problems where the consistency of polygonal ordering is corrupted due to topological loops.

virtual void vtkPolyDataNormals::NonManifoldTraversalOff ( ) [virtual]

Turn on/off traversal across non-manifold edges. This will prevent problems where the consistency of polygonal ordering is corrupted due to topological loops.

void vtkPolyDataNormals::SetMaxRecursionDepth ( int ) [inline]

FOR LEGACY COMPATIBILITY ONLY, DO NOT USE. The connectivity extraction algorithm works recursively. In some systems the stack depth is limited. This methods specifies the maximum recursion depth.

Definition at line 133 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::GetMaxRecursionDepth ( ) [inline]

FOR LEGACY COMPATIBILITY ONLY, DO NOT USE. The connectivity extraction algorithm works recursively. In some systems the stack depth is limited. This methods specifies the maximum recursion depth.

Definition at line 135 of file vtkPolyDataNormals.h.

void vtkPolyDataNormals::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkPPolyDataNormals.

Member Data Documentation

float vtkPolyDataNormals::FeatureAngle [protected]

Definition at line 147 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::Splitting [protected]

Definition at line 148 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::Consistency [protected]

Definition at line 149 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::FlipNormals [protected]

Definition at line 150 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::NonManifoldTraversal [protected]

Definition at line 151 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::ComputePointNormals [protected]

Definition at line 152 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::ComputeCellNormals [protected]

Definition at line 153 of file vtkPolyDataNormals.h.

int vtkPolyDataNormals::NumFlips [protected]

Definition at line 154 of file vtkPolyDataNormals.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPolyDataNormals.h
Generated on Mon Mar 25 01:28:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataReader Class Reference

read vtk polygonal data file. More...

#include <vtkPolyDataReader.h>

Inheritance diagram for vtkPolyDataReader:

[legend]
Collaboration diagram for vtkPolyDataReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * GetOutput ()
vtkPolyData * | GetOutput (int idx)
void | SetOutput (vtkPolyData *output)

Static Public Methods

vtkPolyDataReader * | New ()

Protected Methods

vtkPolyDataReader ()
~vtkPolyDataReader ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | ExecutePiece
int | ExecuteNumberOfPieces
int | ExecuteGhostLevel

Detailed Description

read vtk polygonal data file.

Date:
2002/01/22 15:38:20
Revision:
1.29

vtkPolyDataReader is a source object that reads ASCII or binary polygonal data files in vtk format (see text for format details). The output of this reader is a single vtkPolyData data object. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkPolyData vtkDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (76%)
  • Lorensen, Bill (5%)
  • Kelly, Ann (5%)
Examples:
vtkPolyDataReader (Examples)
Tests:
vtkPolyDataReader (Tests)

Definition at line 54 of file vtkPolyDataReader.h.

Constructor & Destructor Documentation

vtkPolyDataReader::vtkPolyDataReader ( ) [protected]

vtkPolyDataReader::~vtkPolyDataReader ( ) [protected]

Member Function Documentation

vtkPolyDataReader* vtkPolyDataReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkPolyDataReader::vtkTypeRevisionMacro | ( | vtkPolyDataReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkPolyDataReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkPolyData* vtkPolyDataReader::GetOutput ( )

Get the output of this reader.

vtkPolyData* vtkPolyDataReader::GetOutput ( int idx ) [inline]

Get the output of this reader.

Reimplemented from vtkSource.

Definition at line 64 of file vtkPolyDataReader.h.

void vtkPolyDataReader::SetOutput ( vtkPolyData * output )

Get the output of this reader.

void vtkPolyDataReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPolyDataReader::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Member Data Documentation

int vtkPolyDataReader::ExecutePiece [protected]

Definition at line 82 of file vtkPolyDataReader.h.

int vtkPolyDataReader::ExecuteNumberOfPieces [protected]

Definition at line 83 of file vtkPolyDataReader.h.

int vtkPolyDataReader::ExecuteGhostLevel [protected]

Definition at line 84 of file vtkPolyDataReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkPolyDataReader.h
Generated on Mon Mar 25 01:28:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataSource Class Reference

abstract class whose subclasses generate polygonal data. More...

#include <vtkPolyDataSource.h>

Inheritance diagram for vtkPolyDataSource:

[legend]
Collaboration diagram for vtkPolyDataSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataSource, vtkSource)
vtkPolyData * GetOutput ()
vtkPolyData * | GetOutput (int idx)
void | SetOutput (vtkPolyData *output)

Static Public Methods

vtkPolyDataSource * | New ()

Protected Methods

vtkPolyDataSource ()
~vtkPolyDataSource ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | ExecutePiece
int | ExecuteNumberOfPieces
int | ExecuteGhostLevel

Detailed Description

abstract class whose subclasses generate polygonal data.

Date:
2002/01/22 15:28:10
Revision:
1.7

vtkPolyDataSource is an abstract class whose subclasses generate polygonal data.

See also:
vtkPolyDataReader vtkAxes vtkBYUReader vtkConeSource vtkCubeSource vtkCursor3D vtkCyberReader vtkCylinderSource vtkDiskSource vtkLineSource vtkMCubesReader vtkOutlineSource vtkPlaneSource vtkPointSource vtkSTLReader vtkSphereSource vtkTextSource vtkUGFacetReader vtkVectorText
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (98%)

Definition at line 44 of file vtkPolyDataSource.h.

Constructor & Destructor Documentation

vtkPolyDataSource::vtkPolyDataSource ( ) [protected]

vtkPolyDataSource::~vtkPolyDataSource ( ) [inline, protected]

Definition at line 60 of file vtkPolyDataSource.h.

Member Function Documentation

vtkPolyDataSource* vtkPolyDataSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkAppendPolyData, vtkArrowSource, vtkAxes, vtkBandedPolyDataContourFilter, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCleanPolyData, vtkClipPolyData, vtkConeSource, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataSetSurfaceFilter, vtkDecimatePro, vtkDelaunay2D, vtkDiskSource, vtkEdgePoints, vtkExtractEdges, vtkExtractPolyDataGeometry, vtkFeatureEdges, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkImageDataGeometryFilter, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskPoints, vtkMaskPolyData, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProgrammableGlyphFilter, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkPolyData, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkThresholdPoints, vtkTransformPolyDataFilter, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVoxelContoursToSurfaceFilter, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkVectorText, vtkBYUReader, vtkMCubesReader, vtkOBJReader, vtkParticleReader, vtkPLYReader, vtkSTLReader, vtkUGFacetReader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkPLinearExtrusionFilter, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkTransmitPolyDataPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, and vtkSelectVisiblePoints.

vtkPolyDataSource::vtkTypeRevisionMacro | ( | vtkPolyDataSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToPolyDataFilter, vtkPolyDataToPolyDataFilter, vtkRectilinearGridToPolyDataFilter, vtkStructuredGridToPolyDataFilter, vtkStructuredPointsToPolyDataFilter, vtkUnstructuredGridToPolyDataFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrowSource, vtkAxes, vtkBandedPolyDataContourFilter, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCleanPolyData, vtkClipPolyData, vtkConeSource, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataSetSurfaceFilter, vtkDecimatePro, vtkDelaunay2D, vtkDiskSource, vtkEdgePoints, vtkExtractEdges, vtkExtractPolyDataGeometry, vtkFeatureEdges, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkImageDataGeometryFilter, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskPoints, vtkMaskPolyData, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProgrammableGlyphFilter, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkPolyData, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkThresholdPoints, vtkTransformPolyDataFilter, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVoxelContoursToSurfaceFilter, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkVectorText, vtkBYUReader, vtkMCubesReader, vtkOBJReader, vtkParticleReader, vtkPLYReader, vtkSTLReader, vtkUGFacetReader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkPLinearExtrusionFilter, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkTransmitPolyDataPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, and vtkSelectVisiblePoints.

vtkPolyData* vtkPolyDataSource::GetOutput ( )

Get the output of this source.

Reimplemented in vtkSpatialRepresentationFilter.

Referenced by vtkQuadricDecimation::GetTestOutput().

vtkPolyData* vtkPolyDataSource::GetOutput ( int level ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Reimplemented in vtkSpatialRepresentationFilter.

Definition at line 53 of file vtkPolyDataSource.h.

void vtkPolyDataSource::SetOutput ( vtkPolyData * output )

Get the output of this source.

void vtkPolyDataSource::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToPolyDataFilter, vtkStructuredPointsToPolyDataFilter, vtkUnstructuredGridToPolyDataFilter, vtkAppendPolyData, vtkCleanPolyData, vtkDataSetSurfaceFilter, vtkFeatureEdges, vtkGeometryFilter, vtkGlyph3D, vtkLoopSubdivisionFilter, vtkPolyDataStreamer, vtkStructuredGridGeometryFilter, vtkExtractPolyDataPiece, vtkPLinearExtrusionFilter, vtkPPolyDataNormals, vtkTransmitPolyDataPiece, vtkGridSynchronizedTemplates3D, vtkKitwareContourFilter, and vtkSynchronizedTemplates3D.

Member Data Documentation

int vtkPolyDataSource::ExecutePiece [protected]

Definition at line 69 of file vtkPolyDataSource.h.

int vtkPolyDataSource::ExecuteNumberOfPieces [protected]

Definition at line 70 of file vtkPolyDataSource.h.

int vtkPolyDataSource::ExecuteGhostLevel [protected]

Definition at line 72 of file vtkPolyDataSource.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkPolyDataSource.h
Generated on Mon Mar 25 01:28:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataStreamer Class Reference

Stream appends input pieces to the output. More...

#include <vtkPolyDataStreamer.h>

Inheritance diagram for vtkPolyDataStreamer:

[legend]
Collaboration diagram for vtkPolyDataStreamer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataStreamer, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfStreamDivisions (int num)
virtual int | GetNumberOfStreamDivisions ()
virtual void | SetColorByPiece (int)
virtual int | GetColorByPiece ()
virtual void | ColorByPieceOn ()
virtual void | ColorByPieceOff ()

Static Public Methods

vtkPolyDataStreamer * | New ()

Protected Methods

vtkPolyDataStreamer ()
~vtkPolyDataStreamer ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | NumberOfStreamDivisions
int | ColorByPiece

Detailed Description

Stream appends input pieces to the output.

Date:
2002/01/22 15:29:37
Revision:
1.10

vtkPolyDataStreamer initiates streaming by requesting pieces from its single input it appends these pieces it to the requested output. Note that since vtkPolyDataStreamer uses an append filter, all the polygons generated have to be kept in memory before rendering. If these do not fit in the memory, it is possible to make the vtkPolyDataMapper stream. Since the mapper will render each piece separately, all the polygons do not have to stored in memory.

Attention:
The output may be slightly different if the pipeline does not handle ghost cells properly (i.e. you might see seames between the pieces).
See also:
vtkAppendFilter
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (68%)
  • Martin, Ken (20%)
  • Geveci, Berk (8%)
Tests:
vtkPolyDataStreamer (Tests)

Definition at line 52 of file vtkPolyDataStreamer.h.

Constructor & Destructor Documentation

vtkPolyDataStreamer::vtkPolyDataStreamer ( ) [protected]

vtkPolyDataStreamer::~vtkPolyDataStreamer ( ) [protected]

Member Function Documentation

vtkPolyDataStreamer* vtkPolyDataStreamer::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkPolyDataStreamer::vtkTypeRevisionMacro | ( | vtkPolyDataStreamer | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkPolyDataStreamer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkPolyDataStreamer::SetNumberOfStreamDivisions ( int num )

Set the number of pieces to divide the problem into.

virtual int vtkPolyDataStreamer::GetNumberOfStreamDivisions ( ) [virtual]

Set the number of pieces to divide the problem into.

virtual void vtkPolyDataStreamer::SetColorByPiece ( int ) [virtual]

By default, this option is off. When it is on, cell scalars are generated based on which piece they are in.

virtual int vtkPolyDataStreamer::GetColorByPiece ( ) [virtual]

By default, this option is off. When it is on, cell scalars are generated based on which piece they are in.

virtual void vtkPolyDataStreamer::ColorByPieceOn ( ) [virtual]

By default, this option is off. When it is on, cell scalars are generated based on which piece they are in.

virtual void vtkPolyDataStreamer::ColorByPieceOff ( ) [virtual]

By default, this option is off. When it is on, cell scalars are generated based on which piece they are in.

void vtkPolyDataStreamer::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPolyDataStreamer::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

int vtkPolyDataStreamer::NumberOfStreamDivisions [protected]

Definition at line 83 of file vtkPolyDataStreamer.h.

int vtkPolyDataStreamer::ColorByPiece [protected]

Definition at line 84 of file vtkPolyDataStreamer.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkPolyDataStreamer.h
Generated on Mon Mar 25 01:28:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataToImageStencil Class Reference

clip an image with polydata. More...

#include <vtkPolyDataToImageStencil.h>

Inheritance diagram for vtkPolyDataToImageStencil:

[legend]
Collaboration diagram for vtkPolyDataToImageStencil:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataToImageStencil, vtkImageStencilSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkPolyData *input)
vtkPolyData * GetInput ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()

Static Public Methods

vtkPolyDataToImageStencil * | New ()

Protected Methods

vtkPolyDataToImageStencil ()
~vtkPolyDataToImageStencil ()
void | operator= (const vtkPolyDataToImageStencil &)
void | ExecuteData (vtkDataObject *out)
void | ThreadedExecute (vtkImageStencilData *output, int extent[6], int threadId)

Protected Attributes

float | Tolerance
vtkOBBTree * OBBTree

Detailed Description

clip an image with polydata.

Date:
2002/01/22 15:30:35
Revision:
1.6

vtkPolyDataToImageStencil will convert a vtkPolyData into an image that can be used with vtkImageStecil or other vtk classes that apply a stencil to an image.

See also:
vtkPolyData vtkImageStencil vtkImplicitFunctionToImageStencil
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)
Tests:
vtkPolyDataToImageStencil (Tests)

Definition at line 46 of file vtkPolyDataToImageStencil.h.

Constructor & Destructor Documentation

vtkPolyDataToImageStencil::vtkPolyDataToImageStencil ( ) [protected]

vtkPolyDataToImageStencil::~vtkPolyDataToImageStencil ( ) [protected]

Member Function Documentation

vtkPolyDataToImageStencil* vtkPolyDataToImageStencil::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageStencilSource.

vtkPolyDataToImageStencil::vtkTypeRevisionMacro | ( | vtkPolyDataToImageStencil | ,
 |  | vtkImageStencilSource |
 | ) |

Reimplemented from vtkImageStencilSource.

void vtkPolyDataToImageStencil::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageStencilSource.

void vtkPolyDataToImageStencil::SetInput ( vtkPolyData * input )

Specify the polydata to convert into a stencil.

vtkPolyData* vtkPolyDataToImageStencil::GetInput ( )

Specify the polydata to convert into a stencil.

virtual void vtkPolyDataToImageStencil::SetTolerance ( float ) [virtual]

Set the tolerance for doing spatial searches of the polydata.

virtual float vtkPolyDataToImageStencil::GetTolerance ( ) [virtual]

Set the tolerance for doing spatial searches of the polydata.

void vtkPolyDataToImageStencil::operator= ( const vtkPolyDataToImageStencil & ) [protected]

void vtkPolyDataToImageStencil::ExecuteData ( vtkDataObject * out ) [protected]

Reimplemented from vtkImageStencilSource.

void vtkPolyDataToImageStencil::ThreadedExecute | ( | vtkImageStencilData * | output,
 |  | int | extent[6],
 |  | int | threadId
 | ) | [protected, virtual]

Override this method to support clipping with different kinds of objects. Eventually the extent could be split up and handled by multiple threads, but it isn't for now. But please ensure that all code inside this method is thread-safe.

Reimplemented from vtkImageStencilSource.

Member Data Documentation

float vtkPolyDataToImageStencil::Tolerance [protected]

Definition at line 74 of file vtkPolyDataToImageStencil.h.

vtkOBBTree* vtkPolyDataToImageStencil::OBBTree [protected]

Definition at line 75 of file vtkPolyDataToImageStencil.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkPolyDataToImageStencil.h
Generated on Mon Mar 25 01:28:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkPolyDataToPolyDataFilter.h>

Inheritance diagram for vtkPolyDataToPolyDataFilter:

[legend]
Collaboration diagram for vtkPolyDataToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataToPolyDataFilter, vtkPolyDataSource)
virtual void SetInput (vtkPolyData *input)
vtkPolyData * GetInput ()

Protected Methods

vtkPolyDataToPolyDataFilter ()
~vtkPolyDataToPolyDataFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:10
Revision:
1.21

vtkPolyDataToPolyDataFilter is an abstract filter class whose subclasses take as input polygonal data and generate polygonal data on output.

See also:
vtkCleanPolyData vtkDecimate vtkFeatureEdges vtkFeatureVertices vtkMaskPolyData vtkPolyDataNormals vtkSmoothPolyDataFilter vtkStripper vtkTransformPolyDataFilter vtkTriangleFilter vtkTubeFilter vtkLinearExtrusionFilter vtkRibbonFilter vtkRotationalExtrusionFilter vtkShrinkPolyData
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (68%)
  • Lorensen, Bill (11%)
  • Martin, Ken (10%)
  • Biddiscombe, John (8%)

Definition at line 48 of file vtkPolyDataToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkPolyDataToPolyDataFilter::vtkPolyDataToPolyDataFilter ( ) [protected]

vtkPolyDataToPolyDataFilter::~vtkPolyDataToPolyDataFilter ( ) [inline, protected]

Definition at line 61 of file vtkPolyDataToPolyDataFilter.h.

Member Function Documentation

vtkPolyDataToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkPolyDataToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkBandedPolyDataContourFilter, vtkButterflySubdivisionFilter, vtkCleanPolyData, vtkClipPolyData, vtkDecimatePro, vtkExtractPolyDataGeometry, vtkFeatureEdges, vtkGraphLayoutFilter, vtkHull, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLoopSubdivisionFilter, vtkMaskPolyData, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkPolyData, vtkSmoothPolyDataFilter, vtkStripper, vtkSubPixelPositionEdgels, vtkTransformPolyDataFilter, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVoxelContoursToSurfaceFilter, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkGLUTesselatorTriangleFilter, vtkExtractPolyDataPiece, vtkPLinearExtrusionFilter, vtkPPolyDataNormals, vtkTransmitPolyDataPiece, and vtkDecimate.

virtual void vtkPolyDataToPolyDataFilter::SetInput ( vtkPolyData * input ) [virtual]

Set / get the input data or filter.

vtkPolyData* vtkPolyDataToPolyDataFilter::GetInput ( )

Set / get the input data or filter.

Reimplemented in vtkAppendPolyData.

Referenced by vtkAppendPolyData::GetInput().

The documentation for this class was generated from the following file:
  • Filtering/vtkPolyDataToPolyDataFilter.h
Generated on Mon Mar 25 01:28:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyDataWriter Class Reference

write vtk polygonal data. More...

#include <vtkPolyDataWriter.h>

Inheritance diagram for vtkPolyDataWriter:

[legend]
Collaboration diagram for vtkPolyDataWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyDataWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkPolyData *input)
vtkPolyData * GetInput ()

Static Public Methods

vtkPolyDataWriter * | New ()

Protected Methods

vtkPolyDataWriter ()
~vtkPolyDataWriter ()
void | WriteData ()

Detailed Description

write vtk polygonal data.

Date:
2002/01/22 15:38:20
Revision:
1.22

vtkPolyDataWriter is a source object that writes ASCII or binary polygonal data files in vtk format. See text for format details.

Warning:
Binary files written on one system may not be readable on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Lorensen, Bill (11%)
Tests:
vtkPolyDataWriter (Tests)

Definition at line 44 of file vtkPolyDataWriter.h.

Constructor & Destructor Documentation

vtkPolyDataWriter::vtkPolyDataWriter ( ) [inline, protected]

Definition at line 58 of file vtkPolyDataWriter.h.

vtkPolyDataWriter::~vtkPolyDataWriter ( ) [inline, protected]

Definition at line 59 of file vtkPolyDataWriter.h.

Member Function Documentation

vtkPolyDataWriter* vtkPolyDataWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, and vtkSTLWriter.

vtkPolyDataWriter::vtkTypeRevisionMacro | ( | vtkPolyDataWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, and vtkSTLWriter.

void vtkPolyDataWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkMCubesWriter, and vtkPLYWriter.

void vtkPolyDataWriter::SetInput ( vtkPolyData * input )

Set / get the input data or filter.

vtkPolyData* vtkPolyDataWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkPolyDataWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, and vtkSTLWriter.

The documentation for this class was generated from the following file:
  • IO/vtkPolyDataWriter.h
Generated on Mon Mar 25 01:28:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolygon Class Reference

a cell that represents an n-sided polygon. More...

#include <vtkPolygon.h>

Inheritance diagram for vtkPolygon:

[legend]
Collaboration diagram for vtkPolygon:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolygon, vtkCell)
void | ComputeWeights (float x[3], float *weights)
int | Triangulate (vtkIdList *outTris)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *tris, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
int | ParameterizePolygon (float p0[3], float p10[3], float &l10, float p20[3], float &l20, float n[3])

Static Public Methods

vtkPolygon * | New ()
void | ComputeNormal (int numPts, float *pts, float n[3])
void | ComputeNormal (vtkPoints *p, int numPts, vtkIdType *pts, float n[3])
void | ComputeNormal (vtkPoints *p, float n[3])
int | PointInPolygon (float x[3], int numPts, float *pts, float bounds[6], float n[3])
int | IntersectPolygonWithPolygon (int npts, float *pts, float bounds[6], int npts2, float *pts2, float bounds2[3], float tol, float x[3])

Protected Methods

vtkPolygon ()
~vtkPolygon ()
int | EarCutTriangulation ()

Protected Attributes

float | Tolerance
int | SuccessfulTriangulation
float | Normal [3]
vtkIdList * Tris
vtkTriangle * Triangle
vtkQuad * Quad
vtkFloatArray * TriScalars
vtkLine * Line

Detailed Description

a cell that represents an n-sided polygon.

Date:
2002/01/22 15:26:05
Revision:
1.71

vtkPolygon is a concrete implementation of vtkCell to represent a 2D n-sided polygon. The polygons cannot have any internal holes, and cannot self-intersect.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Martin, Ken (10%)
  • Miller, Jim (7%)
Examples:
vtkPolygon (Examples)
Tests:
vtkPolygon (Tests)

Definition at line 50 of file vtkPolygon.h.

Constructor & Destructor Documentation

vtkPolygon::vtkPolygon ( ) [protected]

vtkPolygon::~vtkPolygon ( ) [protected]

Member Function Documentation

vtkPolygon* vtkPolygon::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPolygon::vtkTypeRevisionMacro | ( | vtkPolygon | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkPolygon::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolygon::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkPolygon.h.

int vtkPolygon::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 60 of file vtkPolygon.h.

int vtkPolygon::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 61 of file vtkPolygon.h.

int vtkPolygon::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 62 of file vtkPolygon.h.

vtkCell* vtkPolygon::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkPolygon::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 64 of file vtkPolygon.h.

int vtkPolygon::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolygon::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolygon::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | tris,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolygon::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolygon::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolygon::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolygon::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolygon::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolygon::ComputeNormal | ( | vtkPoints * | p,
 |  | int | numPts,
 |  | vtkIdType * | pts,
 |  | float | n[3]
 | ) | [static]

Polygon specific

void vtkPolygon::ComputeNormal | ( | vtkPoints * | p,
 |  | float | n[3]
 | ) | [static]

Polygon specific

void vtkPolygon::ComputeNormal | ( | int | numPts,
 |  | float * | pts,
 |  | float | n[3]
 | ) | [static]

Compute the polygon normal from an array of points. This version assumes that the polygon is convex, and looks for the first valid normal.

void vtkPolygon::ComputeWeights | ( | float | x[3],
 |  | float * | weights
 | ) |

Compute interpolation weights using 1/r**2 normalized sum.

int vtkPolygon::ParameterizePolygon | ( | float | p0[3],
 |  | float | p10[3],
 |  | float & | l10,
 |  | float | p20[3],
 |  | float & | l20,
 |  | float | n[3]
 | ) |

Create a local s-t coordinate system for a polygon. The point p0 is the origin of the local system, p10 is s-axis vector, and p20 is the t-axis vector. (These are expressed in the modeling coordinate system and are vectors of dimension [3].) The values l20 and l20 are the lengths of the vectors p10 and p20, and n is the polygon normal.

int vtkPolygon::PointInPolygon | ( | float | x[3],
 |  | int | numPts,
 |  | float * | pts,
 |  | float | bounds[6],
 |  | float | n[3]
 | ) | [static]

Determine whether point is inside polygon. Function uses ray-casting to determine if point is inside polygon. Works for arbitrary polygon shape (e.g., non-convex). Returns 0 if point is not in polygon; 1 if it is. Can also return -1 to indicate degenerate polygon.

int vtkPolygon::Triangulate ( vtkIdList * outTris )

Triangulate this polygon. The user must provide the vtkIdList outTris. On output, the outTris list contains the ids of the points defining the triangulation. The ids are ordered into groups of three: each three-group defines one triangle.

int vtkPolygon::IntersectPolygonWithPolygon | ( | int | npts,
 |  | float * | pts,
 |  | float | bounds[6],
 |  | int | npts2,
 |  | float * | pts2,
 |  | float | bounds2[3],
 |  | float | tol,
 |  | float | x[3]
 | ) | [static]

Method intersects two polygons. You must supply the number of points and point coordinates (npts, *pts) and the bounding box (bounds) of the two polygons. Also supply a tolerance squared for controlling error. The method returns 1 if there is an intersection, and 0 if not. A single point of intersection x[3] is also returned if there is an intersection.

int vtkPolygon::EarCutTriangulation ( ) [protected]

A fast triangulation method. Uses recursive divide and conquer based on plane splitting to reduce loop into triangles. The cell (e.g., triangle) is presumed properly initialized (i.e., Points and PointIds).

Member Data Documentation

float vtkPolygon::Tolerance [protected]

Definition at line 147 of file vtkPolygon.h.

int vtkPolygon::SuccessfulTriangulation [protected]

Definition at line 148 of file vtkPolygon.h.

float vtkPolygon::Normal[3] [protected]

Definition at line 149 of file vtkPolygon.h.

vtkIdList* vtkPolygon::Tris [protected]

Definition at line 150 of file vtkPolygon.h.

vtkTriangle* vtkPolygon::Triangle [protected]

Definition at line 151 of file vtkPolygon.h.

vtkQuad* vtkPolygon::Quad [protected]

Definition at line 152 of file vtkPolygon.h.

vtkFloatArray* vtkPolygon::TriScalars [protected]

Definition at line 153 of file vtkPolygon.h.

vtkLine* vtkPolygon::Line [protected]

Definition at line 154 of file vtkPolygon.h.

The documentation for this class was generated from the following file:
  • Common/vtkPolygon.h
Generated on Mon Mar 25 01:28:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyLine Class Reference

cell represents a set of 1D lines. More...

#include <vtkPolyLine.h>

Inheritance diagram for vtkPolyLine:

[legend]
Collaboration diagram for vtkPolyLine:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyLine, vtkCell)
int | GenerateSlidingNormals (vtkPoints *, vtkCellArray *, vtkDataArray *)
int | GetParametricCenter (float pcoords[3])
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int vtkNotUsed(edgeId))
vtkCell * | GetFace (int vtkNotUsed(faceId))
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkPolyLine * | New ()

Protected Methods

vtkPolyLine ()
~vtkPolyLine ()

Protected Attributes

vtkLine * Line

Detailed Description

cell represents a set of 1D lines.

Date:
2002/01/22 15:26:03
Revision:
1.63

vtkPolyLine is a concrete implementation of vtkCell to represent a set of 1D lines.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (39%)
  • Blezek, Dan (37%)
  • Martin, Ken (6%)
Examples:
vtkPolyLine (Examples)
Tests:
vtkPolyLine (Tests)

Definition at line 48 of file vtkPolyLine.h.

Constructor & Destructor Documentation

vtkPolyLine::vtkPolyLine ( ) [protected]

vtkPolyLine::~vtkPolyLine ( ) [protected]

Member Function Documentation

vtkPolyLine* vtkPolyLine::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPolyLine::vtkTypeRevisionMacro | ( | vtkPolyLine | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

int vtkPolyLine::GenerateSlidingNormals | ( | vtkPoints * | ,
 |  | vtkCellArray * | ,
 |  | vtkDataArray * |
 | ) |

Given points and lines, compute normals to lines. These are not true normals, they are "orientation" normals used by classes like vtkTubeFilter that control the rotation around the line. The normals try to stay pointing in the same direction as much as possible (i.e., minimal rotation).

vtkCell* vtkPolyLine::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyLine::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 64 of file vtkPolyLine.h.

int vtkPolyLine::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 65 of file vtkPolyLine.h.

int vtkPolyLine::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 66 of file vtkPolyLine.h.

int vtkPolyLine::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 67 of file vtkPolyLine.h.

vtkCell* vtkPolyLine::GetEdge ( int vtkNotUsed(edgeId) ) [inline]

See the vtkCell API for descriptions of these methods.

Definition at line 68 of file vtkPolyLine.h.

vtkCell* vtkPolyLine::GetFace ( int vtkNotUsed(faceId) ) [inline]

See the vtkCell API for descriptions of these methods.

Definition at line 69 of file vtkPolyLine.h.

int vtkPolyLine::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyLine::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyLine::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | lines,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyLine::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyLine::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyLine::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyLine::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyLine::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyLine::GetParametricCenter ( float pcoords[3] ) [virtual]

Return the center of the point cloud in parametric coordinates.

Reimplemented from vtkCell.

Member Data Documentation

vtkLine* vtkPolyLine::Line [protected]

Definition at line 101 of file vtkPolyLine.h.

The documentation for this class was generated from the following file:
  • Common/vtkPolyLine.h
Generated on Mon Mar 25 01:28:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPolyVertex Class Reference

cell represents a set of 0D vertices. More...

#include <vtkPolyVertex.h>

Inheritance diagram for vtkPolyVertex:

[legend]
Collaboration diagram for vtkPolyVertex:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPolyVertex, vtkCell)
int | GetParametricCenter (float pcoords[3])
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int vtkNotUsed(edgeId))
vtkCell * | GetFace (int vtkNotUsed(faceId))
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkPolyVertex * | New ()

Protected Methods

vtkPolyVertex ()
~vtkPolyVertex ()

Protected Attributes

vtkVertex * Vertex

Detailed Description

cell represents a set of 0D vertices.

Date:
2002/01/22 15:26:04
Revision:
1.58

vtkPolyVertex is a concrete implementation of vtkCell to represent a set of 3D vertices.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Geveci, Berk (9%)
  • Martin, Ken (6%)
  • Law, Charles (5%)
Examples:
vtkPolyVertex (Examples)
Tests:
vtkPolyVertex (Tests)

Definition at line 47 of file vtkPolyVertex.h.

Constructor & Destructor Documentation

vtkPolyVertex::vtkPolyVertex ( ) [protected]

vtkPolyVertex::~vtkPolyVertex ( ) [protected]

Member Function Documentation

vtkPolyVertex* vtkPolyVertex::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPolyVertex::vtkTypeRevisionMacro | ( | vtkPolyVertex | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkPolyVertex::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyVertex::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 56 of file vtkPolyVertex.h.

int vtkPolyVertex::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 57 of file vtkPolyVertex.h.

int vtkPolyVertex::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkPolyVertex.h.

int vtkPolyVertex::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkPolyVertex.h.

vtkCell* vtkPolyVertex::GetEdge ( int vtkNotUsed(edgeId) ) [inline]

See the vtkCell API for descriptions of these methods.

Definition at line 60 of file vtkPolyVertex.h.

vtkCell* vtkPolyVertex::GetFace ( int vtkNotUsed(faceId) ) [inline]

See the vtkCell API for descriptions of these methods.

Definition at line 61 of file vtkPolyVertex.h.

int vtkPolyVertex::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyVertex::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyVertex::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyVertex::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyVertex::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyVertex::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyVertex::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPolyVertex::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPolyVertex::GetParametricCenter ( float pcoords[3] ) [virtual]

Return the center of the point cloud in parametric coordinates.

Reimplemented from vtkCell.

Member Data Documentation

vtkVertex* vtkPolyVertex::Vertex [protected]

Definition at line 93 of file vtkPolyVertex.h.

The documentation for this class was generated from the following file:
  • Common/vtkPolyVertex.h
Generated on Mon Mar 25 01:28:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPOPReader Class Reference

read POP data files. More...

#include <vtkPOPReader.h>

Inheritance diagram for vtkPOPReader:

[legend]
Collaboration diagram for vtkPOPReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPOPReader, vtkStructuredGridSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int * | GetDimensions ()
virtual void | GetDimensions (int &, int &)
virtual void | GetDimensions (int[2])
virtual char * | GetGridFileName ()
virtual char * | GetUFlowFileName ()
virtual char * | GetVFlowFileName ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetClipExtent (int, int, int, int, int, int)
virtual void | SetClipExtent (int[6])
virtual int * | GetClipExtent ()
virtual void | GetClipExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetClipExtent (int[6])
virtual void | SetNumberOfGhostLevels (int)
virtual int | GetNumberOfGhostLevels ()

Static Public Methods

vtkPOPReader * | New ()

Protected Methods

vtkPOPReader ()
~vtkPOPReader ()
vtkPOPReader (const vtkPOPReader &)
void | operator= (const vtkPOPReader &)
void | ExecuteInformation ()
void | Execute ()
void | ReadInformationFile ()
vtkPoints * | ReadPoints (vtkImageData *image)
void | ReadFlow ()
vtkPoints * GeneratePoints ()
virtual void | SetGridFileName (const char *)
void | SetGridName (char *name)
void | DeleteArrays ()
void | AddArray (char *arrayName, char *fileName, unsigned long offset)
void | AddArrayName (char *arrayName, char *fileName, unsigned long offset)
virtual void | SetUFlowFileName (const char *)
virtual void | SetVFlowFileName (const char *)
int | IsFileName (char *name)
char * | MakeFileName (char *name)

Protected Attributes

char * | FileName
int | Dimensions [2]
char * | GridFileName
float | Radius
vtkFloatArray * DepthValues
int | NumberOfGhostLevels
int | NumberOfArrays
int | MaximumNumberOfArrays
char ** | ArrayNames
char ** | ArrayFileNames
unsigned long * | ArrayOffsets
int | ArrayFileDimensionality
char * | UFlowFileName
unsigned long | UFlowFileOffset
char * | VFlowFileName
unsigned long | VFlowFileOffset
int | ClipExtent [6]

Detailed Description

read POP data files.

Date:
2002/02/27 16:28:28
Revision:
1.5

vtkPOPReader Just converts from images to a structured grid for now.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Hoffman, Bill (91%)
  • Law, Charles (7%)

Definition at line 39 of file vtkPOPReader.h.

Constructor & Destructor Documentation

vtkPOPReader::vtkPOPReader ( ) [protected]

vtkPOPReader::~vtkPOPReader ( ) [protected]

vtkPOPReader::vtkPOPReader ( const vtkPOPReader & ) [inline, protected]

Definition at line 91 of file vtkPOPReader.h.

Member Function Documentation

vtkPOPReader* vtkPOPReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredGridSource.

vtkPOPReader::vtkTypeRevisionMacro | ( | vtkPOPReader | ,
 |  | vtkStructuredGridSource |
 | ) |

Reimplemented from vtkStructuredGridSource.

void vtkPOPReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual int* vtkPOPReader::GetDimensions ( ) [virtual]

This is the longitude and latitude dimensions of the structured grid.

virtual void vtkPOPReader::GetDimensions | ( | int & | ,
 |  | int & |
 | ) | [virtual]

This is the longitude and latitude dimensions of the structured grid.

virtual void vtkPOPReader::GetDimensions ( int [2] ) [virtual]

This is the longitude and latitude dimensions of the structured grid.

virtual char* vtkPOPReader::GetGridFileName ( ) [virtual]

This file contains the latitude and longitude of the grid. It must be double with no header.

virtual char* vtkPOPReader::GetUFlowFileName ( ) [virtual]

These files contains the u and v components of the flow.

virtual char* vtkPOPReader::GetVFlowFileName ( ) [virtual]

These files contains the u and v components of the flow.

virtual void vtkPOPReader::SetFileName ( const char * ) [virtual]

This file contains information about all the files.

virtual char* vtkPOPReader::GetFileName ( ) [virtual]

This file contains information about all the files.

virtual void vtkPOPReader::SetRadius ( float ) [virtual]

Radius of the earth.

virtual float vtkPOPReader::GetRadius ( ) [virtual]

Radius of the earth.

virtual void vtkPOPReader::SetClipExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Because the data can be so large, here is an option to clip while reading.

virtual void vtkPOPReader::SetClipExtent ( int [6] ) [virtual]

Because the data can be so large, here is an option to clip while reading.

virtual int* vtkPOPReader::GetClipExtent ( ) [virtual]

Because the data can be so large, here is an option to clip while reading.

virtual void vtkPOPReader::GetClipExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Because the data can be so large, here is an option to clip while reading.

virtual void vtkPOPReader::GetClipExtent ( int [6] ) [virtual]

Because the data can be so large, here is an option to clip while reading.

virtual void vtkPOPReader::SetNumberOfGhostLevels ( int ) [virtual]

Set the number of ghost levels to include in the data

virtual int vtkPOPReader::GetNumberOfGhostLevels ( ) [virtual]

Set the number of ghost levels to include in the data

void vtkPOPReader::operator= ( const vtkPOPReader & ) [inline, protected]

Definition at line 92 of file vtkPOPReader.h.

void vtkPOPReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkPOPReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkPOPReader::ReadInformationFile ( ) [protected]

vtkPoints* vtkPOPReader::ReadPoints ( vtkImageData * image ) [protected]

void vtkPOPReader::ReadFlow ( ) [protected]

vtkPoints* vtkPOPReader::GeneratePoints ( ) [protected]

virtual void vtkPOPReader::SetGridFileName ( const char * ) [protected, virtual]

void vtkPOPReader::SetGridName ( char * name ) [protected]

void vtkPOPReader::DeleteArrays ( ) [protected]

void vtkPOPReader::AddArray | ( | char * | arrayName,
 |  | char * | fileName,
 |  | unsigned long | offset
 | ) | [protected]

void vtkPOPReader::AddArrayName | ( | char * | arrayName,
 |  | char * | fileName,
 |  | unsigned long | offset
 | ) | [protected]

virtual void vtkPOPReader::SetUFlowFileName ( const char * ) [protected, virtual]

virtual void vtkPOPReader::SetVFlowFileName ( const char * ) [protected, virtual]

int vtkPOPReader::IsFileName ( char * name ) [protected]

char* vtkPOPReader::MakeFileName ( char * name ) [protected]

Member Data Documentation

char* vtkPOPReader::FileName [protected]

Definition at line 103 of file vtkPOPReader.h.

int vtkPOPReader::Dimensions[2] [protected]

Definition at line 105 of file vtkPOPReader.h.

char* vtkPOPReader::GridFileName [protected]

Definition at line 108 of file vtkPOPReader.h.

float vtkPOPReader::Radius [protected]

Definition at line 110 of file vtkPOPReader.h.

vtkFloatArray* vtkPOPReader::DepthValues [protected]

Definition at line 111 of file vtkPOPReader.h.

int vtkPOPReader::NumberOfGhostLevels [protected]

Definition at line 112 of file vtkPOPReader.h.

int vtkPOPReader::NumberOfArrays [protected]

Definition at line 117 of file vtkPOPReader.h.

int vtkPOPReader::MaximumNumberOfArrays [protected]

Definition at line 118 of file vtkPOPReader.h.

char** vtkPOPReader::ArrayNames [protected]

Definition at line 119 of file vtkPOPReader.h.

char** vtkPOPReader::ArrayFileNames [protected]

Definition at line 120 of file vtkPOPReader.h.

unsigned long* vtkPOPReader::ArrayOffsets [protected]

Definition at line 121 of file vtkPOPReader.h.

int vtkPOPReader::ArrayFileDimensionality [protected]

Definition at line 122 of file vtkPOPReader.h.

char* vtkPOPReader::UFlowFileName [protected]

Definition at line 125 of file vtkPOPReader.h.

unsigned long vtkPOPReader::UFlowFileOffset [protected]

Definition at line 127 of file vtkPOPReader.h.

char* vtkPOPReader::VFlowFileName [protected]

Definition at line 128 of file vtkPOPReader.h.

unsigned long vtkPOPReader::VFlowFileOffset [protected]

Definition at line 130 of file vtkPOPReader.h.

int vtkPOPReader::ClipExtent[6] [protected]

Definition at line 136 of file vtkPOPReader.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPOPReader.h
Generated on Mon Mar 25 01:28:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPostScriptWriter Class Reference

Writes an image as a PostScript file. More...

#include <vtkPostScriptWriter.h>

Inheritance diagram for vtkPostScriptWriter:

[legend]
Collaboration diagram for vtkPostScriptWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPostScriptWriter, vtkImageWriter)

Static Public Methods

vtkPostScriptWriter * | New ()

Protected Methods

vtkPostScriptWriter ()
~vtkPostScriptWriter ()
virtual void | WriteFile (ofstream *file, vtkImageData *data, int extent[6])
virtual void | WriteFileHeader (ofstream *, vtkImageData *)
virtual void | WriteFileTrailer (ofstream *, vtkImageData *)

Detailed Description

Writes an image as a PostScript file.

Date:
2002/01/22 15:38:20
Revision:
1.17

vtkPostScriptWriter writes an image as a PostScript file using some reasonable scalings and centered on the page which is assumed to be about 8.5 by 11 inches. This is based loosely off of the code from pnmtops.c. Right now there aren't any real options.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (86%)
  • Schroeder, Will (6%)
Tests:
vtkPostScriptWriter (Tests)

Definition at line 43 of file vtkPostScriptWriter.h.

Constructor & Destructor Documentation

vtkPostScriptWriter::vtkPostScriptWriter ( ) [inline, protected]

Definition at line 50 of file vtkPostScriptWriter.h.

vtkPostScriptWriter::~vtkPostScriptWriter ( ) [inline, protected]

Definition at line 51 of file vtkPostScriptWriter.h.

Member Function Documentation

vtkPostScriptWriter* vtkPostScriptWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkPostScriptWriter::vtkTypeRevisionMacro | ( | vtkPostScriptWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

virtual void vtkPostScriptWriter::WriteFile | ( | ofstream * | file,
 |  | vtkImageData * | data,
 |  | int | extent[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkPostScriptWriter::WriteFileHeader | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkPostScriptWriter::WriteFileTrailer | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

The documentation for this class was generated from the following file:
  • IO/vtkPostScriptWriter.h
Generated on Mon Mar 25 01:28:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPPolyDataNormals Class Reference

compute normals for polygonal mesh. More...

#include <vtkPPolyDataNormals.h>

Inheritance diagram for vtkPPolyDataNormals:

[legend]
Collaboration diagram for vtkPPolyDataNormals:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPPolyDataNormals, vtkPolyDataNormals)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPieceInvariant (int)
virtual int | GetPieceInvariant ()
virtual void | PieceInvariantOn ()
virtual void | PieceInvariantOff ()

Static Public Methods

vtkPPolyDataNormals * | New ()

Protected Methods

vtkPPolyDataNormals ()
~vtkPPolyDataNormals ()
virtual void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | PieceInvariant

Detailed Description

compute normals for polygonal mesh.

Date:
2002/01/22 15:34:49
Revision:
1.7
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (69%)
  • Law, Charles (28%)

Definition at line 36 of file vtkPPolyDataNormals.h.

Constructor & Destructor Documentation

vtkPPolyDataNormals::vtkPPolyDataNormals ( ) [protected]

vtkPPolyDataNormals::~vtkPPolyDataNormals ( ) [inline, protected]

Definition at line 54 of file vtkPPolyDataNormals.h.

Member Function Documentation

vtkPPolyDataNormals::vtkTypeRevisionMacro | ( | vtkPPolyDataNormals | ,
 |  | vtkPolyDataNormals |
 | ) |

Reimplemented from vtkPolyDataNormals.

void vtkPPolyDataNormals::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPolyDataNormals.

vtkPPolyDataNormals* vtkPPolyDataNormals::New ( ) [static]

Construct with feature angle=30, splitting and consistency turned on, flipNormals turned off, and non-manifold traversal turned on. ComputePointNormals is on and ComputeCellNormals is off.

Reimplemented from vtkPolyDataNormals.

virtual void vtkPPolyDataNormals::SetPieceInvariant ( int ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual int vtkPPolyDataNormals::GetPieceInvariant ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPPolyDataNormals::PieceInvariantOn ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPPolyDataNormals::PieceInvariantOff ( ) [virtual]

To get piece invariance, this filter has to request an extra ghost level. By default piece invariance is on.

virtual void vtkPPolyDataNormals::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkPolyDataNormals.

void vtkPPolyDataNormals::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

int vtkPPolyDataNormals::PieceInvariant [protected]

Definition at line 60 of file vtkPPolyDataNormals.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPPolyDataNormals.h
Generated on Mon Mar 25 01:28:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPriorityQueue Class Reference

an list of ids arranged in priority order. More...

#include <vtkPriorityQueue.h>

Inheritance diagram for vtkPriorityQueue:

[legend]
Collaboration diagram for vtkPriorityQueue:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPriorityQueue, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Insert (float priority, vtkIdType id)
vtkIdType | Pop (vtkIdType location, float &priority)
vtkIdType | Pop (vtkIdType location=0)
vtkIdType | Peek (vtkIdType location, float &priority)
vtkIdType | Peek (vtkIdType location=0)
float | DeleteId (vtkIdType id)
float | GetPriority (vtkIdType id)
vtkIdType GetNumberOfItems ()
void | Reset ()

Static Public Methods

vtkPriorityQueue * | New ()

Protected Methods

vtkPriorityQueue ()
~vtkPriorityQueue ()
vtkPriorityItem * | Resize (const vtkIdType sz)

Protected Attributes

vtkIdTypeArray * ItemLocation
vtkPriorityItem * Array
vtkIdType Size
vtkIdType MaxId
vtkIdType Extend

Detailed Description

an list of ids arranged in priority order.

Date:
2002/01/22 15:26:05
Revision:
1.34

vtkPriorityQueue is a general object for creating and manipulating lists of object ids (e.g., point or cell ids). Object ids are sorted according to a user-specified priority, where entries at the top of the queue have the smallest values.

This implementation provides a feature beyond the usual ability to insert and retrieve (or pop) values from the queue. It is also possible to pop any item in the queue given its id number. This allows you to delete entries in the queue which can useful for reinserting an item into the queue.

Warning:
This implementation is a variation of the priority queue described in "Data Structures & Algorithms" by Aho, Hopcroft, Ullman. It creates a balanced, partially ordered binary tree implemented as an ordered array. This avoids the overhead associated with parent/child pointers, and frequent memory allocation and deallocation.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (55%)
  • Miller, Jim (9%)
  • Martin, Ken (8%)
  • Henderson, Amy (6%)
  • Law, Charles (6%)

Definition at line 65 of file vtkPriorityQueue.h.

Constructor & Destructor Documentation

vtkPriorityQueue::vtkPriorityQueue ( ) [protected]

vtkPriorityQueue::~vtkPriorityQueue ( ) [protected]

Member Function Documentation

vtkPriorityQueue* vtkPriorityQueue::New ( ) [static]

Instantiate priority queue with default size and extension size of 1000.

Reimplemented from vtkObject.

vtkPriorityQueue::vtkTypeRevisionMacro | ( | vtkPriorityQueue | ,
 |  | vtkObject |
 | ) |

void vtkPriorityQueue::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkPriorityQueue::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) |

Allocate initial space for priority queue.

void vtkPriorityQueue::Insert | ( | float | priority,
 |  | vtkIdType | id
 | ) |

Insert id with priority specified. The id is generally an index like a point id or cell id.

vtkIdType vtkPriorityQueue::Pop | ( | vtkIdType | location,
 |  | float & | priority
 | ) |

Removes item at specified location from tree; then reorders and balances tree. The location == 0 is the root of the tree. If queue is exhausted, then a value < 0 is returned. (Note: the location is not the same as deleting an id; id is mapped to location.) BTX

Referenced by DeleteId().

vtkIdType vtkPriorityQueue::Pop ( vtkIdType location = 0 )

Same as above but simplified for easier wrapping into interpreted languages.

vtkIdType vtkPriorityQueue::Peek | ( | vtkIdType | location,
 |  | float & | priority
 | ) | [inline]

Peek into the queue without actually removing anything. Returns the id and the priority. BTX

Definition at line 158 of file vtkPriorityQueue.h.

vtkIdType vtkPriorityQueue::Peek ( vtkIdType location = 0 ) [inline]

Peek into the queue without actually removing anything. Returns the id.

Definition at line 171 of file vtkPriorityQueue.h.

float vtkPriorityQueue::DeleteId ( vtkIdType id ) [inline]

Delete entry in queue with specified id. Returns priority value associated with that id; or VTK_LARGE_FLOAT if not in queue.

Definition at line 133 of file vtkPriorityQueue.h.

float vtkPriorityQueue::GetPriority ( vtkIdType id ) [inline]

Get the priority of an entry in the queue with specified id. Returns priority value of that id or VTK_LARGE_FLOAT if not in queue.

Definition at line 146 of file vtkPriorityQueue.h.

vtkIdType vtkPriorityQueue::GetNumberOfItems ( ) [inline]

Return the number of items in this queue.

Definition at line 111 of file vtkPriorityQueue.h.

void vtkPriorityQueue::Reset ( )

Empty the queue but without releasing memory. This avoids the overhead of memory allocation/deletion.

vtkPriorityItem* vtkPriorityQueue::Resize ( const vtkIdType sz ) [protected]

Member Data Documentation

vtkIdTypeArray* vtkPriorityQueue::ItemLocation [protected]

Definition at line 123 of file vtkPriorityQueue.h.

vtkPriorityItem* vtkPriorityQueue::Array [protected]

Definition at line 124 of file vtkPriorityQueue.h.

vtkIdType vtkPriorityQueue::Size [protected]

Definition at line 125 of file vtkPriorityQueue.h.

vtkIdType vtkPriorityQueue::MaxId [protected]

Definition at line 126 of file vtkPriorityQueue.h.

vtkIdType vtkPriorityQueue::Extend [protected]

Definition at line 127 of file vtkPriorityQueue.h.

The documentation for this class was generated from the following file:
  • Common/vtkPriorityQueue.h
Generated on Mon Mar 25 01:28:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProbeFilter Class Reference

sample data values at specified point locations. More...

#include <vtkProbeFilter.h>

Inheritance diagram for vtkProbeFilter:

[legend]
Collaboration diagram for vtkProbeFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProbeFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSource (vtkDataSet *source)
vtkDataSet * GetSource ()
virtual void | SetSpatialMatch (int)
virtual int | GetSpatialMatch ()
virtual void | SpatialMatchOn ()
virtual void | SpatialMatchOff ()
virtual vtkIdTypeArray * | GetValidPoints ()

Static Public Methods

vtkProbeFilter * | New ()

Protected Methods

vtkProbeFilter ()
~vtkProbeFilter ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | SpatialMatch
vtkIdTypeArray * ValidPoints

Detailed Description

sample data values at specified point locations.

Date:
2002/01/22 15:29:38
Revision:
1.45

vtkProbeFilter is a filter that computes point attributes (e.g., scalars, vectors, etc.) at specified point positions. The filter has two inputs: the Input and Source. The Input geometric structure is passed through the filter. The point attributes are computed at the Input point positions by interpolating into the source data. For example, we can compute data values on a plane (plane specified as Input) from a volume (Source).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (38%)
  • Law, Charles (24%)
  • Martin, Ken (11%)
  • Lorensen, Bill (9%)
  • Biddiscombe, John (7%)
  • Henderson, Amy (5%)
Examples:
vtkProbeFilter (Examples)
Tests:
vtkProbeFilter (Tests)

Definition at line 53 of file vtkProbeFilter.h.

Constructor & Destructor Documentation

vtkProbeFilter::vtkProbeFilter ( ) [protected]

vtkProbeFilter::~vtkProbeFilter ( ) [protected]

Member Function Documentation

vtkProbeFilter* vtkProbeFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkProbeFilter::vtkTypeRevisionMacro | ( | vtkProbeFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkProbeFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkProbeFilter::SetSource ( vtkDataSet * source )

Specify the point locations used to probe input. Any geometry can be used.

vtkDataSet* vtkProbeFilter::GetSource ( )

Specify the point locations used to probe input. Any geometry can be used.

virtual void vtkProbeFilter::SetSpatialMatch ( int ) [virtual]

This flag is used only when a piece is requested to update. By default the flag is off. Because no spatial correspondence between input pieces and source pieces is known, all of the source has to be requested no matter what piece of the output is requested. When there is a spatial correspondence, the user/application can set this flag. This hint allows the breakup of the probe operation to be much more efficient. When piece m of n is requested for update by the user, then only n of m needs to be requested of the source.

virtual int vtkProbeFilter::GetSpatialMatch ( ) [virtual]

This flag is used only when a piece is requested to update. By default the flag is off. Because no spatial correspondence between input pieces and source pieces is known, all of the source has to be requested no matter what piece of the output is requested. When there is a spatial correspondence, the user/application can set this flag. This hint allows the breakup of the probe operation to be much more efficient. When piece m of n is requested for update by the user, then only n of m needs to be requested of the source.

virtual void vtkProbeFilter::SpatialMatchOn ( ) [virtual]

This flag is used only when a piece is requested to update. By default the flag is off. Because no spatial correspondence between input pieces and source pieces is known, all of the source has to be requested no matter what piece of the output is requested. When there is a spatial correspondence, the user/application can set this flag. This hint allows the breakup of the probe operation to be much more efficient. When piece m of n is requested for update by the user, then only n of m needs to be requested of the source.

virtual void vtkProbeFilter::SpatialMatchOff ( ) [virtual]

This flag is used only when a piece is requested to update. By default the flag is off. Because no spatial correspondence between input pieces and source pieces is known, all of the source has to be requested no matter what piece of the output is requested. When there is a spatial correspondence, the user/application can set this flag. This hint allows the breakup of the probe operation to be much more efficient. When piece m of n is requested for update by the user, then only n of m needs to be requested of the source.

virtual vtkIdTypeArray* vtkProbeFilter::GetValidPoints ( ) [virtual]

Get the list of point ids in the output that contain attribute data interpolated from the source.

void vtkProbeFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkProbeFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkDataSetToDataSetFilter.

void vtkProbeFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

By default copy the output update extent to the input

Reimplemented from vtkDataSetToDataSetFilter.

Member Data Documentation

int vtkProbeFilter::SpatialMatch [protected]

Definition at line 91 of file vtkProbeFilter.h.

vtkIdTypeArray* vtkProbeFilter::ValidPoints [protected]

Definition at line 97 of file vtkProbeFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProbeFilter.h
Generated on Mon Mar 25 01:28:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcessObject Class Reference

abstract class specifies interface for visualization filters. More...

#include <vtkProcessObject.h>

Inheritance diagram for vtkProcessObject:

[legend]
Collaboration diagram for vtkProcessObject:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProcessObject, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetStartMethod (void(*f)(void *), void *arg)
void | SetProgressMethod (void(*f)(void *), void *arg)
void | SetEndMethod (void(*f)(void *), void *arg)
void | SetStartMethodArgDelete (void(*f)(void *))
void | SetProgressMethodArgDelete (void(*f)(void *))
void | SetEndMethodArgDelete (void(*f)(void *))
void | UpdateProgress (float amount)
void | SqueezeInputArray ()
void | RemoveAllInputs ()
virtual void | SetAbortExecute (int)
virtual int | GetAbortExecute ()
virtual void | AbortExecuteOn ()
virtual void | AbortExecuteOff ()
virtual void | SetProgress (float)
virtual float | GetProgress ()
virtual void | SetProgressText (const char *)
virtual char * | GetProgressText ()
vtkDataObject ** GetInputs ()
virtual int | GetNumberOfInputs ()

Static Public Methods

vtkProcessObject * | New ()

Public Attributes

int | AbortExecute

Protected Methods

vtkProcessObject ()
~vtkProcessObject ()
void | SortInputsByLocality ()
void | SortMerge (vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results)
void | SetNumberOfInputs (int num)
virtual void | SetNthInput (int num, vtkDataObject *input)
virtual void | AddInput (vtkDataObject *input)
virtual void | RemoveInput (vtkDataObject *input)

Protected Attributes

unsigned long | StartTag
unsigned long | ProgressTag
unsigned long | EndTag
float | Progress
char * | ProgressText
int | NumberOfInputs
int | NumberOfRequiredInputs
vtkDataObject ** Inputs
vtkDataObject ** SortedInputs
vtkDataObject ** SortedInputs2

Detailed Description

abstract class specifies interface for visualization filters.

Date:
2002/01/22 15:26:06
Revision:
1.31

vtkProcessObject is an abstract object that specifies behavior and interface of visualization network process objects (sources, filters, mappers). Source objects are creators of visualization data; filters input, process, and output visualization data; and mappers transform data into another form (like rendering primitives or write data to a file).

vtkProcessObject provides a mechanism for invoking the methods StartMethod() and EndMethod() before and after object execution (via Execute()). These are convenience methods you can use for any purpose (e.g., debugging info, highlighting/notifying user interface, etc.) These methods accept a single void* pointer that can be used to send data to the methods. It is also possible to specify a function to delete the argument via StartMethodArgDelete and EndMethodArgDelete.

Another method, ProgressMethod() can be specified. Some filters invoke this method periodically during their execution. The use is similar to that of StartMethod() and EndMethod(). Filters may also check their AbortExecute flag to determine whether to prematurely end their execution.

An important feature of subclasses of vtkProcessObject is that it is possible to control the memory-management model (i.e., retain output versus delete output data). If enabled the ReleaseDataFlag enables the deletion of the output data once the downstream process object finishes processing the data (please see text).

See also:
vtkDataObject vtkSource vtkFilter vtkMapper vtkWriter
Events:
vtkCommand::ProgressEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (39%)
  • Martin, Ken (27%)
  • Law, Charles (13%)
  • Avila, Lisa (5%)

Definition at line 69 of file vtkProcessObject.h.

Constructor & Destructor Documentation

vtkProcessObject::vtkProcessObject ( ) [protected]

vtkProcessObject::~vtkProcessObject ( ) [protected]

Member Function Documentation

vtkProcessObject* vtkProcessObject::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkObject.

Reimplemented in vtkMapper2D, vtkCastToConcrete, vtkDataObjectSource, vtkDataSetSource, vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageSource, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkImageTwoInputFilter, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionSource, vtkPointSetSource, vtkPolyDataSource, vtkRectilinearGridSource, vtkStructuredGridSource, vtkStructuredPointsSource, vtkUnstructuredGridSource, vtkAppendFilter, vtkAppendPolyData, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMassProperties, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableFilter, vtkProgrammableGlyphFilter, vtkProgrammableSource, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExport, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSimpleImageFilterExample, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBMPWriter, vtkBYUReader, vtkBYUWriter, vtkCGMWriter, vtkDataObjectReader, vtkDataObjectWriter, vtkDataReader, vtkDataSetReader, vtkDataSetWriter, vtkDataWriter, vtkDEMReader, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkGenericEnSightReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkImageWriter, vtkIVWriter, vtkJPEGReader, vtkJPEGWriter, vtkMCubesReader, vtkMCubesWriter, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPLYWriter, vtkPNGReader, vtkPNGWriter, vtkPNMReader, vtkPNMWriter, vtkPolyDataReader, vtkPolyDataWriter, vtkPostScriptWriter, vtkRectilinearGridReader, vtkRectilinearGridWriter, vtkSLCReader, vtkSTLReader, vtkSTLWriter, vtkStructuredGridReader, vtkStructuredGridWriter, vtkStructuredPointsReader, vtkStructuredPointsWriter, vtkTIFFReader, vtkTIFFWriter, vtkUGFacetReader, vtkUnstructuredGridReader, vtkUnstructuredGridWriter, vtkVolume16Reader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkImageBlockWriter, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkOutputPort, vtkPCellDataToPointData, vtkPDataSetReader, vtkPDataSetWriter, vtkPieceScalars, vtkPImageWriter, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkDataSetMapper, vtkImageMapper, vtkLabeledDataMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper, vtkMesaPolyDataMapper2D, vtkMesaTexture, vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper, vtkOpenGLPolyDataMapper2D, vtkOpenGLTexture, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkRendererSource, vtkSelectVisiblePoints, vtkTextMapper, vtkTexture, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper2D, vtkWin32ImageMapper, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32TextMapper, vtkWindowToImageFilter, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, and vtkXTextMapper.

vtkProcessObject::vtkTypeRevisionMacro | ( | vtkProcessObject | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkAbstractMapper, vtkMapper2D, vtkSource, vtkCastToConcrete, vtkDataObjectSource, vtkDataSetSource, vtkDataSetToDataSetFilter, vtkDataSetToPolyDataFilter, vtkDataSetToStructuredGridFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToUnstructuredGridFilter, vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageSource, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkImageTwoInputFilter, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionSource, vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkPointSetSource, vtkPointSetToPointSetFilter, vtkPolyDataSource, vtkPolyDataToPolyDataFilter, vtkRectilinearGridSource, vtkRectilinearGridToPolyDataFilter, vtkSimpleImageToImageFilter, vtkStructuredGridSource, vtkStructuredGridToPolyDataFilter, vtkStructuredGridToStructuredGridFilter, vtkStructuredPointsSource, vtkStructuredPointsToPolyDataFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridSource, vtkUnstructuredGridToPolyDataFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDicer, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMassProperties, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableFilter, vtkProgrammableGlyphFilter, vtkProgrammableSource, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExport, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSimpleImageFilterExample, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBMPWriter, vtkBYUReader, vtkBYUWriter, vtkCGMWriter, vtkDataObjectReader, vtkDataObjectWriter, vtkDataReader, vtkDataSetReader, vtkDataSetWriter, vtkDataWriter, vtkDEMReader, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkEnSightReader, vtkGenericEnSightReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkImageWriter, vtkIVWriter, vtkJPEGReader, vtkJPEGWriter, vtkMCubesReader, vtkMCubesWriter, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPLYWriter, vtkPNGReader, vtkPNGWriter, vtkPNMReader, vtkPNMWriter, vtkPolyDataReader, vtkPolyDataWriter, vtkPostScriptWriter, vtkRectilinearGridReader, vtkRectilinearGridWriter, vtkSLCReader, vtkSTLReader, vtkSTLWriter, vtkStructuredGridReader, vtkStructuredGridWriter, vtkStructuredPointsReader, vtkStructuredPointsWriter, vtkTIFFWriter, vtkUGFacetReader, vtkUnstructuredGridReader, vtkUnstructuredGridWriter, vtkVolume16Reader, vtkVolumeReader, vtkWriter, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkImageBlockWriter, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkOutputPort, vtkPCellDataToPointData, vtkPDataSetReader, vtkPDataSetWriter, vtkPieceScalars, vtkPImageWriter, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkAbstractMapper3D, vtkDataSetMapper, vtkImageMapper, vtkLabeledDataMapper, vtkMapper, vtkMesaImageMapper, vtkMesaPolyDataMapper, vtkMesaPolyDataMapper2D, vtkMesaTexture, vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLImageMapper, vtkOpenGLPolyDataMapper, vtkOpenGLPolyDataMapper2D, vtkOpenGLTexture, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkQuartzImageMapper, vtkQuartzTextMapper, vtkRendererSource, vtkSelectVisiblePoints, vtkTextMapper, vtkTexture, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, vtkVolumeTextureMapper2D, vtkWin32ImageMapper, vtkWin32OpenGLTextMapper, vtkWin32PolyDataMapper2D, vtkWin32TextMapper, vtkWindowToImageFilter, vtkXImageMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, vtkXPolyDataMapper2D, and vtkXTextMapper.

void vtkProcessObject::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkAbstractMapper, vtkMapper2D, vtkSource, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkPiecewiseFunctionShiftScale, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDicer, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLineSource, vtkLinkEdgels, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMassProperties, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableGlyphFilter, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExport, vtkImageExtractComponents, vtkImageFlip, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageMagnify, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBYUReader, vtkBYUWriter, vtkCGMWriter, vtkDataObjectReader, vtkDataObjectWriter, vtkDataReader, vtkDataSetReader, vtkDataSetWriter, vtkDataWriter, vtkDEMReader, vtkEnSightReader, vtkGenericEnSightReader, vtkImageReader, vtkImageReader2, vtkImageWriter, vtkJPEGWriter, vtkMCubesReader, vtkMCubesWriter, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPLYWriter, vtkPolyDataReader, vtkPolyDataWriter, vtkRectilinearGridReader, vtkRectilinearGridWriter, vtkSLCReader, vtkSTLReader, vtkStructuredGridReader, vtkStructuredGridWriter, vtkStructuredPointsReader, vtkStructuredPointsWriter, vtkUGFacetReader, vtkUnstructuredGridReader, vtkUnstructuredGridWriter, vtkVolume16Reader, vtkVolumeReader, vtkWriter, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkImageBlockWriter, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkOutputPort, vtkPCellDataToPointData, vtkPDataSetReader, vtkPDataSetWriter, vtkPieceScalars, vtkPImageWriter, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPVGeometryFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkAbstractMapper3D, vtkDataSetMapper, vtkImageMapper, vtkLabeledDataMapper, vtkMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkPolyDataMapper, vtkPolyDataMapper2D, vtkRendererSource, vtkSelectVisiblePoints, vtkTextMapper, vtkTexture, vtkVolumeMapper, vtkVolumeProMapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, vtkVolumeTextureMapper2D, vtkWin32ImageMapper, vtkWindowToImageFilter, and vtkXImageMapper.

void vtkProcessObject::SetStartMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called before object executes.

void vtkProcessObject::SetProgressMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called to show progress of filter

void vtkProcessObject::SetEndMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called after object executes.

void vtkProcessObject::SetStartMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkProcessObject::SetProgressMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkProcessObject::SetEndMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

virtual void vtkProcessObject::SetAbortExecute ( int ) [virtual]

Set/Get the AbortExecute flag for the process object. Process objects may handle premature termination of execution in different ways.

virtual int vtkProcessObject::GetAbortExecute ( ) [virtual]

Set/Get the AbortExecute flag for the process object. Process objects may handle premature termination of execution in different ways.

virtual void vtkProcessObject::AbortExecuteOn ( ) [virtual]

Set/Get the AbortExecute flag for the process object. Process objects may handle premature termination of execution in different ways.

virtual void vtkProcessObject::AbortExecuteOff ( ) [virtual]

Set/Get the AbortExecute flag for the process object. Process objects may handle premature termination of execution in different ways.

virtual void vtkProcessObject::SetProgress ( float ) [virtual]

Set/Get the execution progress of a process object.

virtual float vtkProcessObject::GetProgress ( ) [virtual]

Set/Get the execution progress of a process object.

void vtkProcessObject::UpdateProgress ( float amount )

Update the progress of the process object. If a ProgressMethod exists, executes it. Then set the Progress ivar to amount. The parameter amount should range between (0,1).

virtual void vtkProcessObject::SetProgressText ( const char * ) [virtual]

Set the current text message associated with the progress state. This may be used by a calling process/GUI.

virtual char* vtkProcessObject::GetProgressText ( ) [virtual]

Set the current text message associated with the progress state. This may be used by a calling process/GUI.

vtkDataObject** vtkProcessObject::GetInputs ( ) [inline]

Return an array with all the inputs of this process object. This is useful for tracing back in the pipeline to construct graphs etc.

Definition at line 128 of file vtkProcessObject.h.

virtual int vtkProcessObject::GetNumberOfInputs ( ) [virtual]

Return an array with all the inputs of this process object. This is useful for tracing back in the pipeline to construct graphs etc.

void vtkProcessObject::SqueezeInputArray ( )

This method will rearrange the input array so that all NULL entries are removed.

void vtkProcessObject::RemoveAllInputs ( )

Remove all the input data.

void vtkProcessObject::SortInputsByLocality ( ) [protected]

void vtkProcessObject::SortMerge | ( | vtkDataObject ** | a1,
 |  | int | l1,
 |  | vtkDataObject ** | a2,
 |  | int | l2,
 |  | vtkDataObject ** | results
 | ) | [protected]

void vtkProcessObject::SetNumberOfInputs ( int n ) [protected]

Reimplemented in vtkAppendPolyData, vtkPCAAnalysisFilter, and vtkProcrustesAlignmentFilter.

virtual void vtkProcessObject::SetNthInput | ( | int | num,
 |  | vtkDataObject * | input
 | ) | [protected, virtual]

virtual void vtkProcessObject::AddInput ( vtkDataObject * input ) [protected, virtual]

virtual void vtkProcessObject::RemoveInput ( vtkDataObject * input ) [protected, virtual]

Member Data Documentation

int vtkProcessObject::AbortExecute

Definition at line 123 of file vtkProcessObject.h.

unsigned long vtkProcessObject::StartTag [protected]

Definition at line 144 of file vtkProcessObject.h.

unsigned long vtkProcessObject::ProgressTag [protected]

Definition at line 145 of file vtkProcessObject.h.

unsigned long vtkProcessObject::EndTag [protected]

Definition at line 146 of file vtkProcessObject.h.

float vtkProcessObject::Progress [protected]

Definition at line 147 of file vtkProcessObject.h.

char* vtkProcessObject::ProgressText [protected]

Definition at line 148 of file vtkProcessObject.h.

int vtkProcessObject::NumberOfInputs [protected]

Definition at line 150 of file vtkProcessObject.h.

int vtkProcessObject::NumberOfRequiredInputs [protected]

Definition at line 151 of file vtkProcessObject.h.

vtkDataObject** vtkProcessObject::Inputs [protected]

Definition at line 152 of file vtkProcessObject.h.

vtkDataObject** vtkProcessObject::SortedInputs [protected]

Definition at line 155 of file vtkProcessObject.h.

vtkDataObject** vtkProcessObject::SortedInputs2 [protected]

Definition at line 158 of file vtkProcessObject.h.

The documentation for this class was generated from the following file:
  • Common/vtkProcessObject.h
Generated on Mon Mar 25 01:28:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcessStatistics Class Reference

get statistics such as cpu and memory usage. More...

#include <vtkProcessStatistics.h>

Inheritance diagram for vtkProcessStatistics:

[legend]
Collaboration diagram for vtkProcessStatistics:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProcessStatistics, vtkObject)
int | GetProcessSizeInBytes ()
float | GetProcessCPUTimeInMilliseconds ()

Static Public Methods

vtkProcessStatistics * | New ()

Protected Methods

vtkProcessStatistics ()
~vtkProcessStatistics ()

Detailed Description

get statistics such as cpu and memory usage.

Date:
2002/01/22 15:26:07
Revision:
1.15
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (68%)
  • Lorensen, Bill (24%)

Definition at line 38 of file vtkProcessStatistics.h.

Constructor & Destructor Documentation

vtkProcessStatistics::vtkProcessStatistics ( ) [protected]

vtkProcessStatistics::~vtkProcessStatistics ( ) [inline, protected]

Definition at line 51 of file vtkProcessStatistics.h.

Member Function Documentation

vtkProcessStatistics* vtkProcessStatistics::New ( ) [static]

Construct the ProcessStatistics with eight points.

Reimplemented from vtkObject.

vtkProcessStatistics::vtkTypeRevisionMacro | ( | vtkProcessStatistics | ,
 |  | vtkObject |
 | ) |

int vtkProcessStatistics::GetProcessSizeInBytes ( )

float vtkProcessStatistics::GetProcessCPUTimeInMilliseconds ( )

The documentation for this class was generated from the following file:
  • Common/vtkProcessStatistics.h
Generated on Mon Mar 25 01:28:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProcrustesAlignmentFilter Class Reference

aligns a set of pointsets together. More...

#include <vtkProcrustesAlignmentFilter.h>

Inheritance diagram for vtkProcrustesAlignmentFilter:

[legend]
Collaboration diagram for vtkProcrustesAlignmentFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProcrustesAlignmentFilter, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetNumberOfInputs (int n)
void | SetInput (int idx, vtkPointSet *p)
vtkPointSet * | GetOutput (int idx)
vtkPointSet * | GetInput (int idx)
virtual vtkLandmarkTransform * | GetLandmarkTransform ()

Static Public Methods

vtkProcrustesAlignmentFilter * | New ()

Protected Methods

vtkProcrustesAlignmentFilter ()
~vtkProcrustesAlignmentFilter ()
void | Execute ()

Protected Attributes

vtkLandmarkTransform * LandmarkTransform

Detailed Description

aligns a set of pointsets together.

Date:
2002/02/05 17:36:04
Revision:
1.4

vtkProcrustesAlignmentFilter is a filter that takes a set of pointsets (any object derived from vtkPointSet) and aligns them in a least-squares sense to their mutual mean. The algorithm is iterated until convergence, as the mean must be recomputed after each alignment.

Call SetNumberOfInputs(n) before calling SetInput(0) ... SetInput(n-1).

Retrieve the outputs using GetOutput(0) ... GetOutput(n-1).

The default (in vtkLandmarkTransform) is for a similarity alignment. For a rigid-body alignment (to build a 'size-and-shape' model) use:

GetLandmarkTransform()->SetModeToRigidBody().

Affine alignments are not normally used but are left in for completeness:

GetLandmarkTransform()->SetModeToAffine().

vtkProcrustesAlignmentFilter is an implementation of:

J.C. Gower (1975) Generalized Procrustes Analysis. Psychometrika, 40:33-51.

Warning:
All of the input pointsets must have the same number of points.
Thanks:
Tim Hutton and Rasmus Paulsen who developed and contributed this class
See also:
vtkLandmarkTransform
Created by:
  • Hutton, Tim
Contributed by (if > 5%):
  • Hutton, Tim (100%)
Examples:
vtkProcrustesAlignmentFilter (Examples)
Tests:
vtkProcrustesAlignmentFilter (Tests)

Definition at line 76 of file vtkProcrustesAlignmentFilter.h.

Constructor & Destructor Documentation

vtkProcrustesAlignmentFilter::vtkProcrustesAlignmentFilter ( ) [protected]

vtkProcrustesAlignmentFilter::~vtkProcrustesAlignmentFilter ( ) [protected]

Member Function Documentation

vtkProcrustesAlignmentFilter::vtkTypeRevisionMacro | ( | vtkProcrustesAlignmentFilter | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkProcrustesAlignmentFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Prints information about the state of the filter.

Reimplemented from vtkSource.

vtkProcrustesAlignmentFilter* vtkProcrustesAlignmentFilter::New ( ) [static]

Creates with similarity transform.

Reimplemented from vtkProcessObject.

virtual vtkLandmarkTransform* vtkProcrustesAlignmentFilter::GetLandmarkTransform ( ) [virtual]

Get the internal landmark transform. Use it to constrain the number of degrees of freedom of the alignment (i.e. rigid body, similarity, etc.). The default is a similarity alignment.

void vtkProcrustesAlignmentFilter::SetNumberOfInputs ( int n )

Specify how many pointsets are going to be given as input.

Reimplemented from vtkProcessObject.

void vtkProcrustesAlignmentFilter::SetInput | ( | int | idx,
 |  | vtkPointSet * | p
 | ) |

Specify the input pointset with index idx. Call SetNumberOfInputs before calling this function.

vtkPointSet* vtkProcrustesAlignmentFilter::GetOutput ( int idx )

Retrieve the output point set with index idx.

Reimplemented from vtkSource.

vtkPointSet* vtkProcrustesAlignmentFilter::GetInput ( int idx )

Retrieve the input point set with index idx (usuall only for pipeline tracing).

void vtkProcrustesAlignmentFilter::Execute ( ) [protected, virtual]

Usual data generation method.

Reimplemented from vtkSource.

Member Data Documentation

vtkLandmarkTransform* vtkProcrustesAlignmentFilter::LandmarkTransform [protected]

Definition at line 115 of file vtkProcrustesAlignmentFilter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkProcrustesAlignmentFilter.h
Generated on Mon Mar 25 01:28:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableAttributeDataFilter Class Reference

manipulate attribute (cell and point) data via a user-specified function. More...

#include <vtkProgrammableAttributeDataFilter.h>

Inheritance diagram for vtkProgrammableAttributeDataFilter:

[legend]
Collaboration diagram for vtkProgrammableAttributeDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProgrammableAttributeDataFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddInput (vtkDataSet *in)
void | RemoveInput (vtkDataSet *in)
vtkDataSetCollection * GetInputList ()
void | SetExecuteMethod (void(*f)(void *), void *arg)
void | SetExecuteMethodArgDelete (void(*f)(void *))

Static Public Methods

vtkProgrammableAttributeDataFilter * | New ()

Protected Methods

vtkProgrammableAttributeDataFilter ()
~vtkProgrammableAttributeDataFilter ()
void | Execute ()

Protected Attributes

vtkDataSetCollection * InputList
void(* | ExecuteMethod )(void *)
void(* | ExecuteMethodArgDelete )(void *)
void * | ExecuteMethodArg

Detailed Description

manipulate attribute (cell and point) data via a user-specified function.

Date:
2002/01/22 15:29:39
Revision:
1.25

vtkProgrammableAttributeDataFilter is a filter that allows you to write a custom procedure to manipulate attribute data - either point or cell data. For example, you could generate scalars based on a complex formula; convert vectors to normals; compute scalar values as a function of vectors, texture coords, and/or any other point data attribute; and so on. The filter takes multiple inputs (input plus an auxiliary input list), so you can write procedures that combine several dataset point attributes. Note that the output of the filter is the same type (topology/geometry) as the input.

The filter works as follows. It operates like any other filter (i.e., checking and managing modified and execution times, processing Update() and Execute() methods, managing release of data, etc.), but the difference is that the Execute() method simply invokes a user-specified function with an optional (void *) argument (typically the "this" pointer in C++). It is also possible to specify a function to delete the argument via ExecuteMethodArgDelete.

To use the filter, you write a procedure to process the input datasets, process the data, and generate output data. Typically, this means grabbing the input point or cell data (using GetInput() and maybe GetInputList()), operating on it (creating new point and cell attributes such as scalars, vectors, etc.), and then setting the point and/or cell attributes in the output dataset (you'll need to use GetOutput() to access the output). (Note: besides C++, it is possible to do the same thing in Tcl, Java, or other languages that wrap the C++ core.) Remember, proper filter protocol requires that you don't modify the input data - you create new output data from the input.

Warning:
This filter operates on any combination of the filter input plus a list of additional inputs (at a minimum you must set the filter input via SetInput()). It is up to you check whether the input is valid, and to insure that the output is valid. Also, you have to write the control structure for the traversal and operation on the point and cell attribute data.
Warning:
By default the output point and cell data will be copied through from the input point data (using reference counting). You can control this using the output's CopyAllOff() flag, or by using individual flags for each point data field (i.e., scalars, vectors, etc.)
Warning:
The output of this filter is the abstract type vtkDataSet, even if your input is a concrete type like vtkPolyData. Thus you may need to use vtkCastToConcrete to obtain the output as a particular concrete type, or one of the special methods of the superclass (e.g., vtkDataSetToDataSetFilter::GetPolyDataOutput) to retrieve output of the correct type.
Warning:
The filter correctly manages modified time and network execution in most cases. However, if you change the definition of the filter function, you'll want to send a manual Modified() method to the filter to force it to reexecute.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (67%)
  • Martin, Ken (16%)
  • Lorensen, Bill (8%)
Tests:
vtkProgrammableAttributeDataFilter (Tests)

Definition at line 97 of file vtkProgrammableAttributeDataFilter.h.

Constructor & Destructor Documentation

vtkProgrammableAttributeDataFilter::vtkProgrammableAttributeDataFilter ( ) [protected]

vtkProgrammableAttributeDataFilter::~vtkProgrammableAttributeDataFilter ( ) [protected]

Member Function Documentation

vtkProgrammableAttributeDataFilter* vtkProgrammableAttributeDataFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkProgrammableAttributeDataFilter::vtkTypeRevisionMacro | ( | vtkProgrammableAttributeDataFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkProgrammableAttributeDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkProgrammableAttributeDataFilter::AddInput ( vtkDataSet * in )

Add a dataset to the list of data to process.

void vtkProgrammableAttributeDataFilter::RemoveInput ( vtkDataSet * in )

Remove a dataset from the list of data to process.

vtkDataSetCollection* vtkProgrammableAttributeDataFilter::GetInputList ( ) [inline]

Return the list of inputs.

Definition at line 111 of file vtkProgrammableAttributeDataFilter.h.

void vtkProgrammableAttributeDataFilter::SetExecuteMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify the function to use to operate on the point attribute data. Note that the function takes a single (void *) argument.

void vtkProgrammableAttributeDataFilter::SetExecuteMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkProgrammableAttributeDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkDataSetCollection* vtkProgrammableAttributeDataFilter::InputList [protected]

Definition at line 125 of file vtkProgrammableAttributeDataFilter.h.

void(* vtkProgrammableAttributeDataFilter::ExecuteMethod)(void *) [protected]

void(* vtkProgrammableAttributeDataFilter::ExecuteMethodArgDelete)(void *) [protected]

void* vtkProgrammableAttributeDataFilter::ExecuteMethodArg [protected]

Definition at line 128 of file vtkProgrammableAttributeDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProgrammableAttributeDataFilter.h
Generated on Mon Mar 25 01:28:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableDataObjectSource Class Reference

generate source data object via a user-specified function. More...

#include <vtkProgrammableDataObjectSource.h>

Inheritance diagram for vtkProgrammableDataObjectSource:

[legend]
Collaboration diagram for vtkProgrammableDataObjectSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProgrammableDataObjectSource, vtkSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetExecuteMethod (void(*f)(void *), void *arg)
void | SetExecuteMethodArgDelete (void(*f)(void *))
vtkDataObject * GetOutput ()
vtkDataObject * | GetOutput (int idx)

Static Public Methods

vtkProgrammableDataObjectSource * | New ()

Protected Methods

vtkProgrammableDataObjectSource ()
~vtkProgrammableDataObjectSource ()
void | Execute ()

Protected Attributes

void(* | ExecuteMethod )(void *)
void(* | ExecuteMethodArgDelete )(void *)
void * | ExecuteMethodArg

Detailed Description

generate source data object via a user-specified function.

Date:
2002/01/22 15:29:39
Revision:
1.18

vtkProgrammableDataObjectSource is a source object that is programmable by the user. The output of the filter is a data object (vtkDataObject) which represents data via an instance of field data. To use this object, you must specify a function that creates the output.

Example use of this filter includes reading tabular data and encoding it as vtkFieldData. You can then use filters like vtkDataObjectToDataSetFilter to convert the data object to a dataset and then visualize it. Another important use of this class is that it allows users of interpreters (e.g., Tcl or Java) the ability to write source objects without having to recompile C++ code or generate new libraries.

See also:
vtkProgrammableFilter vtkProgrammableAttributeDataFilter vtkProgrammableSource vtkDataObjectToDataSetFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (94%)
Examples:
vtkProgrammableDataObjectSource (Examples)
Tests:
vtkProgrammableDataObjectSource (Tests)

Definition at line 56 of file vtkProgrammableDataObjectSource.h.

Constructor & Destructor Documentation

vtkProgrammableDataObjectSource::vtkProgrammableDataObjectSource ( ) [protected]

vtkProgrammableDataObjectSource::~vtkProgrammableDataObjectSource ( ) [protected]

Member Function Documentation

vtkProgrammableDataObjectSource* vtkProgrammableDataObjectSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkProgrammableDataObjectSource::vtkTypeRevisionMacro | ( | vtkProgrammableDataObjectSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkProgrammableDataObjectSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkProgrammableDataObjectSource::SetExecuteMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify the function to use to generate the output data object. Note that the function takes a single (void *) argument.

void vtkProgrammableDataObjectSource::SetExecuteMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

vtkDataObject* vtkProgrammableDataObjectSource::GetOutput ( )

Get the output data object.

vtkDataObject* vtkProgrammableDataObjectSource::GetOutput ( int idx ) [inline]

Get the output data object.

Reimplemented from vtkSource.

Definition at line 73 of file vtkProgrammableDataObjectSource.h.

void vtkProgrammableDataObjectSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

void(* vtkProgrammableDataObjectSource::ExecuteMethod)(void *) [protected]

void(* vtkProgrammableDataObjectSource::ExecuteMethodArgDelete)(void *) [protected]

void* vtkProgrammableDataObjectSource::ExecuteMethodArg [protected]

Definition at line 85 of file vtkProgrammableDataObjectSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProgrammableDataObjectSource.h
Generated on Mon Mar 25 01:28:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableFilter Class Reference

a user-programmable filter. More...

#include <vtkProgrammableFilter.h>

Inheritance diagram for vtkProgrammableFilter:

[legend]
Collaboration diagram for vtkProgrammableFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProgrammableFilter, vtkDataSetToDataSetFilter)
void | SetExecuteMethod (void(*f)(void *), void *arg)
void | SetExecuteMethodArgDelete (void(*f)(void *))
vtkPolyData * GetPolyDataInput ()
vtkStructuredPoints * GetStructuredPointsInput ()
vtkStructuredGrid * GetStructuredGridInput ()
vtkUnstructuredGrid * GetUnstructuredGridInput ()
vtkRectilinearGrid * GetRectilinearGridInput ()

Static Public Methods

vtkProgrammableFilter * | New ()

Protected Methods

vtkProgrammableFilter ()
~vtkProgrammableFilter ()
void | Execute ()

Protected Attributes

void(* | ExecuteMethod )(void *)
void(* | ExecuteMethodArgDelete )(void *)
void * | ExecuteMethodArg

Detailed Description

a user-programmable filter.

Date:
2002/01/22 15:29:40
Revision:
1.20

vtkProgrammableFilter is a filter that can be programmed by the user. To use the filter you define a function that retrieves input of the correct type, creates data, and then manipulates the output of the filter. Using this filter avoids the need for subclassing - and the function can be defined in an interpreter wrapper language such as Tcl or Java.

The trickiest part of using this filter is that the input and output methods are unusual and cannot be compile-time type checked. Instead, as a user of this filter it is your responsibility to set and get the correct input and output types.

Warning:
The filter correctly manages modified time and network execution in most cases. However, if you change the definition of the filter function, you'll want to send a manual Modified() method to the filter to force it to reexecute.
See also:
vtkProgrammablePointDataFilter vtkProgrammableSource
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Martin, Ken (26%)
  • Kelly, Ann (12%)
Examples:
vtkProgrammableFilter (Examples)

Definition at line 59 of file vtkProgrammableFilter.h.

Constructor & Destructor Documentation

vtkProgrammableFilter::vtkProgrammableFilter ( ) [protected]

vtkProgrammableFilter::~vtkProgrammableFilter ( ) [protected]

Member Function Documentation

vtkProgrammableFilter* vtkProgrammableFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkProgrammableFilter::vtkTypeRevisionMacro | ( | vtkProgrammableFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkProgrammableFilter::SetExecuteMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify the function to use to operate on the point attribute data. Note that the function takes a single (void *) argument.

void vtkProgrammableFilter::SetExecuteMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

vtkPolyData* vtkProgrammableFilter::GetPolyDataInput ( )

Get the input as a concrete type. This method is typically used by the writer of the filter function to get the input as a particular type (i.e., it essentially does type casting). It is the users responsibility to know the correct type of the input data.

vtkStructuredPoints* vtkProgrammableFilter::GetStructuredPointsInput ( )

Get the input as a concrete type.

vtkStructuredGrid* vtkProgrammableFilter::GetStructuredGridInput ( )

Get the input as a concrete type.

vtkUnstructuredGrid* vtkProgrammableFilter::GetUnstructuredGridInput ( )

Get the input as a concrete type.

vtkRectilinearGrid* vtkProgrammableFilter::GetRectilinearGridInput ( )

Get the input as a concrete type.

void vtkProgrammableFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

void(* vtkProgrammableFilter::ExecuteMethod)(void *) [protected]

void(* vtkProgrammableFilter::ExecuteMethodArgDelete)(void *) [protected]

void* vtkProgrammableFilter::ExecuteMethodArg [protected]

Definition at line 98 of file vtkProgrammableFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProgrammableFilter.h
Generated on Mon Mar 25 01:28:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableGlyphFilter Class Reference

control the generation and placement of glyphs at input points. More...

#include <vtkProgrammableGlyphFilter.h>

Inheritance diagram for vtkProgrammableGlyphFilter:

[legend]
Collaboration diagram for vtkProgrammableGlyphFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProgrammableGlyphFilter, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetGlyphMethod (void(*f)(void *), void *arg)
void | SetGlyphMethodArgDelete (void(*f)(void *))
void | SetSource (vtkPolyData *source)
vtkPolyData * GetSource ()
virtual vtkIdType | GetPointId ()
virtual float * | GetPoint ()
virtual void | GetPoint (float &, float &, float &)
virtual void | GetPoint (float[3])
virtual vtkPointData * | GetPointData ()
virtual void | SetColorMode (int)
virtual int | GetColorMode ()
void | SetColorModeToColorByInput ()
void | SetColorModeToColorBySource ()
const char * | GetColorModeAsString ()

Static Public Methods

vtkProgrammableGlyphFilter * | New ()

Protected Methods

vtkProgrammableGlyphFilter ()
~vtkProgrammableGlyphFilter ()
void | Execute ()

Protected Attributes

float | Point [3]
vtkIdType PointId
vtkPointData * PointData
int | ColorMode
void(* | GlyphMethod )(void *)
void(* | GlyphMethodArgDelete )(void *)
void * | GlyphMethodArg

Detailed Description

control the generation and placement of glyphs at input points.

Date:
2002/01/22 15:29:40
Revision:
1.19

vtkProgrammableGlyphFilter is a filter that allows you to place a glyph at each input point in the dataset. In addition, the filter is programmable which means the user has control over the generation of the glyph. The glyphs can be controlled via the point data attributes (e.g., scalars, vectors, etc.) or any other information in the input dataset.

This is the way the filter works. You must define an input dataset which at a minimum contains points with associated attribute values. Also, the Source instance variable must be set which is of type vtkPolyData. Then, for each point in the input, the PointId is set to the current point id, and a user-defined function is called (i.e., GlyphMethod). In this method you can manipulate the Source data (including changing to a different Source object). After the GlyphMethod is called, vtkProgrammableGlyphFilter will invoke an Update() on its Source object, and then copy its data to the output of the vtkProgrammableGlyphFilter. Therefore the output of this filter is of type vtkPolyData.

Another option to this filter is the way you color the glyphs. You can use the scalar data from the input or the source. The instance variable ColorMode controls this behavior.

Warning:
This filter operates on point data attributes. If you want to use cell data attributes, use a filter like vtkCellCenters to generate points at the centers of cells, and then use these points.
Warning:
Note that the data attributes (cell and point) are passed to the output of this filter from the Source object. This works well as long as you are not changing the class of the Source object during execution. However, if the class of the Source object changes, then the potential exists that the data attributes might change during execution (e.g., scalars available from one source and not the next), possibly fouling up the copying of data attributes to the output. In this case, you may have to manually set the output's copy flags (e.g., CopyScalarsOn/Off(), CopyVectorsOn/Off(), etc.) to control what's being copied.
See also:
vtkGlyph3D vtkTensorGlyph vtkCellCenters
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Lorensen, Bill (16%)
  • Geveci, Berk (5%)
Tests:
vtkProgrammableGlyphFilter (Tests)

Definition at line 83 of file vtkProgrammableGlyphFilter.h.

Constructor & Destructor Documentation

vtkProgrammableGlyphFilter::vtkProgrammableGlyphFilter ( ) [protected]

vtkProgrammableGlyphFilter::~vtkProgrammableGlyphFilter ( ) [protected]

Member Function Documentation

vtkProgrammableGlyphFilter::vtkTypeRevisionMacro | ( | vtkProgrammableGlyphFilter | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkProgrammableGlyphFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkProgrammableGlyphFilter* vtkProgrammableGlyphFilter::New ( ) [static]

Construct object with NULL GlyphMethod and no source object. The ColorMode is set to color by the input.

Reimplemented from vtkPolyDataSource.

void vtkProgrammableGlyphFilter::SetSource ( vtkPolyData * source )

Set/Get the source to use for this glyph. Note: you can change the source during execution of this filter.

vtkPolyData* vtkProgrammableGlyphFilter::GetSource ( )

Set/Get the source to use for this glyph. Note: you can change the source during execution of this filter.

void vtkProgrammableGlyphFilter::SetGlyphMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify function to be called for each input point.

void vtkProgrammableGlyphFilter::SetGlyphMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory that might be associated with the GlyphMethod.

virtual vtkIdType vtkProgrammableGlyphFilter::GetPointId ( ) [virtual]

Get the current point id during processing. Value only valid during the Execute() method of this filter. (Meant to be called by the GlyphMethod.)

virtual float* vtkProgrammableGlyphFilter::GetPoint ( ) [virtual]

Get the current point coordinates during processing. Value only valid during the Execute() method of this filter. (Meant to be called by the GlyphMethod.)

virtual void vtkProgrammableGlyphFilter::GetPoint | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Get the current point coordinates during processing. Value only valid during the Execute() method of this filter. (Meant to be called by the GlyphMethod.)

virtual void vtkProgrammableGlyphFilter::GetPoint ( float [3] ) [virtual]

Get the current point coordinates during processing. Value only valid during the Execute() method of this filter. (Meant to be called by the GlyphMethod.)

virtual vtkPointData* vtkProgrammableGlyphFilter::GetPointData ( ) [virtual]

Get the set of point data attributes for the input. A convenience to the programmer to be used in the GlyphMethod. Only valid during the Execute() method of this filter.

virtual void vtkProgrammableGlyphFilter::SetColorMode ( int ) [virtual]

Either color by the input or source scalar data.

virtual int vtkProgrammableGlyphFilter::GetColorMode ( ) [virtual]

Either color by the input or source scalar data.

void vtkProgrammableGlyphFilter::SetColorModeToColorByInput ( ) [inline]

Either color by the input or source scalar data.

Definition at line 132 of file vtkProgrammableGlyphFilter.h.

void vtkProgrammableGlyphFilter::SetColorModeToColorBySource ( ) [inline]

Either color by the input or source scalar data.

Definition at line 134 of file vtkProgrammableGlyphFilter.h.

const char* vtkProgrammableGlyphFilter::GetColorModeAsString ( void )

Either color by the input or source scalar data.

void vtkProgrammableGlyphFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkProgrammableGlyphFilter::Point[3] [protected]

Definition at line 145 of file vtkProgrammableGlyphFilter.h.

vtkIdType vtkProgrammableGlyphFilter::PointId [protected]

Definition at line 146 of file vtkProgrammableGlyphFilter.h.

vtkPointData* vtkProgrammableGlyphFilter::PointData [protected]

Definition at line 147 of file vtkProgrammableGlyphFilter.h.

int vtkProgrammableGlyphFilter::ColorMode [protected]

Definition at line 148 of file vtkProgrammableGlyphFilter.h.

void(* vtkProgrammableGlyphFilter::GlyphMethod)(void *) [protected]

void(* vtkProgrammableGlyphFilter::GlyphMethodArgDelete)(void *) [protected]

void* vtkProgrammableGlyphFilter::GlyphMethodArg [protected]

Definition at line 152 of file vtkProgrammableGlyphFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProgrammableGlyphFilter.h
Generated on Mon Mar 25 01:28:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProgrammableSource Class Reference

generate source dataset via a user-specified function. More...

#include <vtkProgrammableSource.h>

Inheritance diagram for vtkProgrammableSource:

[legend]
Collaboration diagram for vtkProgrammableSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProgrammableSource, vtkSource)
void | SetExecuteMethod (void(*f)(void *), void *arg)
void | SetExecuteMethodArgDelete (void(*f)(void *))
vtkPolyData * GetPolyDataOutput ()
vtkStructuredPoints * GetStructuredPointsOutput ()
vtkStructuredGrid * GetStructuredGridOutput ()
vtkUnstructuredGrid * GetUnstructuredGridOutput ()
vtkRectilinearGrid * GetRectilinearGridOutput ()
void | UpdateInformation ()
void | UpdateData (vtkDataObject *output)

Static Public Methods

vtkProgrammableSource * | New ()

Protected Methods

vtkProgrammableSource ()
~vtkProgrammableSource ()
void | Execute ()

Protected Attributes

void(* | ExecuteMethod )(void *)
void(* | ExecuteMethodArgDelete )(void *)
void * | ExecuteMethodArg
vtkTimeStamp ExecuteTime

Detailed Description

generate source dataset via a user-specified function.

Date:
2002/01/22 15:29:41
Revision:
1.20

vtkProgrammableSource is a source object that is programmable by the user. To use this object, you must specify a function that creates the output. It is possible to generate an output dataset of any (concrete) type; it is up to the function to properly initialize and define the output. Typically, you use one of the methods to get a concrete output type (e.g., GetPolyDataOutput() or GetStructuredPointsOutput()), and then manipulate the output in the user-specified function.

Example use of this include writing a function to read a data file or interface to another system. (You might want to do this in favor of deriving a new class.) Another important use of this class is that it allows users of interpreters (e.g., Tcl or Java) the ability to write source objects without having to recompile C++ code or generate new libraries.

See also:
vtkProgrammableFilter vtkProgrammableAttributeDataFilter vtkProgrammableDataObjectSource
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (52%)
  • Martin, Ken (35%)
  • Kelly, Ann (8%)
Examples:
vtkProgrammableSource (Examples)
Tests:
vtkProgrammableSource (Tests)

Definition at line 69 of file vtkProgrammableSource.h.

Constructor & Destructor Documentation

vtkProgrammableSource::vtkProgrammableSource ( ) [protected]

vtkProgrammableSource::~vtkProgrammableSource ( ) [protected]

Member Function Documentation

vtkProgrammableSource* vtkProgrammableSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkProgrammableSource::vtkTypeRevisionMacro | ( | vtkProgrammableSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

void vtkProgrammableSource::SetExecuteMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify the function to use to generate the source data. Note that the function takes a single (void *) argument.

void vtkProgrammableSource::SetExecuteMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

vtkPolyData* vtkProgrammableSource::GetPolyDataOutput ( )

Get the output as a concrete type. This method is typically used by the writer of the source function to get the output as a particular type (i.e., it essentially does type casting). It is the users responsibility to know the correct type of the output data.

vtkStructuredPoints* vtkProgrammableSource::GetStructuredPointsOutput ( )

Get the output as a concrete type.

vtkStructuredGrid* vtkProgrammableSource::GetStructuredGridOutput ( )

Get the output as a concrete type.

vtkUnstructuredGrid* vtkProgrammableSource::GetUnstructuredGridOutput ( )

Get the output as a concrete type.

vtkRectilinearGrid* vtkProgrammableSource::GetRectilinearGridOutput ( )

Get the output as a concrete type.

void vtkProgrammableSource::UpdateInformation ( ) [virtual]

Updates any global information about the data (like spacing for images)

Reimplemented from vtkSource.

void vtkProgrammableSource::UpdateData ( vtkDataObject * output ) [virtual]

Reimplemented from vtkSource.

void vtkProgrammableSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

void(* vtkProgrammableSource::ExecuteMethod)(void *) [protected]

void(* vtkProgrammableSource::ExecuteMethodArgDelete)(void *) [protected]

void* vtkProgrammableSource::ExecuteMethodArg [protected]

Definition at line 111 of file vtkProgrammableSource.h.

vtkTimeStamp vtkProgrammableSource::ExecuteTime [protected]

Definition at line 113 of file vtkProgrammableSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProgrammableSource.h
Generated on Mon Mar 25 01:28:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProjectedTexture Class Reference

assign texture coordinates for a projected texture. More...

#include <vtkProjectedTexture.h>

Inheritance diagram for vtkProjectedTexture:

[legend]
Collaboration diagram for vtkProjectedTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProjectedTexture, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetUp (float, float, float)
virtual void | SetUp (float[3])
virtual float * | GetUp ()
virtual void | GetUp (float data[3])
virtual void | SetAspectRatio (float, float, float)
virtual void | SetAspectRatio (float[3])
virtual float * | GetAspectRatio ()
virtual void | GetAspectRatio (float data[3])
virtual void | SetPosition (float, float, float)
virtual void | SetPosition (float[3])
virtual float * | GetPosition ()
virtual void | GetPosition (float data[3])
void | SetFocalPoint (float focalPoint[3])
void | SetFocalPoint (float x, float y, float z)
virtual float * | GetFocalPoint ()
virtual void | GetFocalPoint (float data[3])
virtual float * | GetOrientation ()
virtual void | GetOrientation (float data[3])
virtual void | SetSRange (float, float)
void | SetSRange (float[2])
virtual float * | GetSRange ()
virtual void | GetSRange (float data[2])
virtual void | SetTRange (float, float)
void | SetTRange (float[2])
virtual float * | GetTRange ()
virtual void | GetTRange (float data[2])

Static Public Methods

vtkProjectedTexture * | New ()

Protected Methods

vtkProjectedTexture ()
~vtkProjectedTexture ()
void | Execute ()
void | ComputeNormal ()

Protected Attributes

float | Position [3]
float | Orientation [3]
float | FocalPoint [3]
float | Up [3]
float | AspectRatio [3]
float | SRange [2]
float | TRange [2]

Detailed Description

assign texture coordinates for a projected texture.

Date:
2002/01/22 15:29:41
Revision:
1.16

vtkProjectedTexture assigns texture coordinates to a dataset as if the texture was projected from a slide projected located somewhere in the scene. Methods are provided to position the projector and aim it at a location, to set the width of the projector's frustum, and to set the range of texture coordinates assigned to the dataset.

Objects in the scene that appear behind the projector are also assigned texture coordinates; the projected image is left-right and top-bottom flipped, much as a lens' focus flips the rays of light that pass through it. A warning is issued if a point in the dataset falls at the focus of the projector.

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (85%)
  • Schroeder, Will (5%)

Definition at line 47 of file vtkProjectedTexture.h.

Constructor & Destructor Documentation

vtkProjectedTexture::vtkProjectedTexture ( ) [protected]

vtkProjectedTexture::~vtkProjectedTexture ( ) [inline, protected]

Definition at line 99 of file vtkProjectedTexture.h.

Member Function Documentation

vtkProjectedTexture* vtkProjectedTexture::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkProjectedTexture::vtkTypeRevisionMacro | ( | vtkProjectedTexture | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkProjectedTexture::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkProjectedTexture::SetPosition | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the position of the focus of the projector.

virtual void vtkProjectedTexture::SetPosition ( float [3] ) [virtual]

Set/Get the position of the focus of the projector.

virtual float* vtkProjectedTexture::GetPosition ( ) [virtual]

Set/Get the position of the focus of the projector.

virtual void vtkProjectedTexture::GetPosition ( float data[3] ) [virtual]

Set/Get the position of the focus of the projector.

void vtkProjectedTexture::SetFocalPoint ( float focalPoint[3] )

Set/Get the focal point of the projector (a point that lies along the center axis of the projector's frustum).

void vtkProjectedTexture::SetFocalPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Set/Get the focal point of the projector (a point that lies along the center axis of the projector's frustum).

virtual float* vtkProjectedTexture::GetFocalPoint ( ) [virtual]

Set/Get the focal point of the projector (a point that lies along the center axis of the projector's frustum).

virtual void vtkProjectedTexture::GetFocalPoint ( float data[3] ) [virtual]

Set/Get the focal point of the projector (a point that lies along the center axis of the projector's frustum).

virtual float* vtkProjectedTexture::GetOrientation ( ) [virtual]

Get the normalized orientation vector of the projector.

virtual void vtkProjectedTexture::GetOrientation ( float data[3] ) [virtual]

Get the normalized orientation vector of the projector.

virtual void vtkProjectedTexture::SetUp | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

virtual void vtkProjectedTexture::SetUp ( float [3] ) [virtual]

virtual float* vtkProjectedTexture::GetUp ( ) [virtual]

virtual void vtkProjectedTexture::GetUp ( float data[3] ) [virtual]

virtual void vtkProjectedTexture::SetAspectRatio | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

virtual void vtkProjectedTexture::SetAspectRatio ( float [3] ) [virtual]

virtual float* vtkProjectedTexture::GetAspectRatio ( ) [virtual]

virtual void vtkProjectedTexture::GetAspectRatio ( float data[3] ) [virtual]

virtual void vtkProjectedTexture::SetSRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

void vtkProjectedTexture::SetSRange ( float [2] )

Specify s-coordinate range for texture s-t coordinate pair.

virtual float* vtkProjectedTexture::GetSRange ( ) [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

virtual void vtkProjectedTexture::GetSRange ( float data[2] ) [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

virtual void vtkProjectedTexture::SetTRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

void vtkProjectedTexture::SetTRange ( float [2] )

Specify t-coordinate range for texture s-t coordinate pair.

virtual float* vtkProjectedTexture::GetTRange ( ) [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

virtual void vtkProjectedTexture::GetTRange ( float data[2] ) [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

void vtkProjectedTexture::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkProjectedTexture::ComputeNormal ( ) [protected]

Member Data Documentation

float vtkProjectedTexture::Position[3] [protected]

Definition at line 104 of file vtkProjectedTexture.h.

float vtkProjectedTexture::Orientation[3] [protected]

Definition at line 105 of file vtkProjectedTexture.h.

float vtkProjectedTexture::FocalPoint[3] [protected]

Definition at line 106 of file vtkProjectedTexture.h.

float vtkProjectedTexture::Up[3] [protected]

Definition at line 107 of file vtkProjectedTexture.h.

float vtkProjectedTexture::AspectRatio[3] [protected]

Definition at line 108 of file vtkProjectedTexture.h.

float vtkProjectedTexture::SRange[2] [protected]

Definition at line 109 of file vtkProjectedTexture.h.

float vtkProjectedTexture::TRange[2] [protected]

Definition at line 110 of file vtkProjectedTexture.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkProjectedTexture.h
Generated on Mon Mar 25 01:28:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp Class Reference

abstract superclass for all actors, volumes and annotations. More...

#include <vtkProp.h>

Inheritance diagram for vtkProp:

[legend]
Collaboration diagram for vtkProp:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProp, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Pick ()
virtual unsigned long | GetRedrawMTime ()
virtual float * | GetBounds ()
virtual void | ShallowCopy (vtkProp *prop)
virtual void | ReleaseGraphicsResources (vtkWindow *)
virtual void | BuildPaths (vtkAssemblyPaths *paths, vtkAssemblyPath *path)
virtual void | GetActors (vtkPropCollection *)
virtual void | GetActors2D (vtkPropCollection *)
virtual void | GetVolumes (vtkPropCollection *)
virtual void | SetVisibility (int)
virtual int | GetVisibility ()
virtual void | VisibilityOn ()
virtual void | VisibilityOff ()
virtual void | SetPickable (int)
virtual int | GetPickable ()
virtual void | PickableOn ()
virtual void | PickableOff ()
void | SetPickMethod (void(*f)(void *), void *arg)
void | SetPickMethodArgDelete (void(*f)(void *))
virtual void | SetDragable (int)
virtual int | GetDragable ()
virtual void | DragableOn ()
virtual void | DragableOff ()
virtual void | InitPathTraversal ()
virtual vtkAssemblyPath * | GetNextPath ()
virtual int | GetNumberOfPaths ()
virtual void | PokeMatrix (vtkMatrix4x4 *vtkNotUsed(matrix))
virtual vtkMatrix4x4 * | GetMatrix ()
virtual int | RenderOpaqueGeometry (vtkViewport *)
virtual int | RenderTranslucentGeometry (vtkViewport *)
virtual int | RenderOverlay (vtkViewport *)
virtual float | GetEstimatedRenderTime (vtkViewport *)
virtual float | GetEstimatedRenderTime ()
virtual void | SetEstimatedRenderTime (float t)
virtual void | RestoreEstimatedRenderTime ()
virtual void | AddEstimatedRenderTime (float t, vtkViewport *vtkNotUsed(vp))
virtual void | SetAllocatedRenderTime (float t, vtkViewport *vtkNotUsed(v))
virtual float | GetAllocatedRenderTime ()
void | SetRenderTimeMultiplier (float t)
virtual float | GetRenderTimeMultiplier ()
virtual int | GetNumberOfConsumers ()
void | AddConsumer (vtkObject *c)
void | RemoveConsumer (vtkObject *c)
vtkObject * | GetConsumer (int i)
int | IsConsumer (vtkObject *c)

Static Public Methods

vtkProp * | New ()

Protected Methods

vtkProp ()
~vtkProp ()

Protected Attributes

int | Visibility
int | Pickable
unsigned long | PickTag
int | Dragable
float | AllocatedRenderTime
float | EstimatedRenderTime
float | SavedEstimatedRenderTime
float | RenderTimeMultiplier
int | NumberOfConsumers
vtkObject ** Consumers
vtkAssemblyPaths * Paths

Detailed Description

abstract superclass for all actors, volumes and annotations.

Date:
2002/02/21 18:51:08
Revision:
1.37

vtkProp is an abstract superclass for any objects that can exist in a rendered scene (either 2D or 3D). Instances of vtkProp may respond to various render methods (e.g., RenderOpaqueGeometry()). vtkProp also defines the API for picking, LOD manipulation, and common instance variables that control visibility, picking, and dragging.

See also:
vtkActor2D vtkActor vtkVolume vtkProp3D
Events:
vtkCommand::PickEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (38%)
  • Schroeder, Will (29%)
  • Avila, Lisa (27%)
Examples:
vtkProp (Examples)

Definition at line 56 of file vtkProp.h.

Constructor & Destructor Documentation

vtkProp::vtkProp ( ) [protected]

vtkProp::~vtkProp ( ) [protected]

Member Function Documentation

vtkProp* vtkProp::New ( ) [static]

Creates an instance with visibility=1, pickable=1, and dragable=1.

Reimplemented from vtkObject.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkImageActor, vtkLODActor, vtkLODProp3D, vtkMesaActor, vtkMesaImageActor, vtkOpenGLActor, vtkOpenGLImageActor, vtkParallelCoordinatesActor, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

vtkProp::vtkTypeRevisionMacro | ( | vtkProp | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkImageActor, vtkLODActor, vtkLODProp3D, vtkMesaActor, vtkMesaImageActor, vtkOpenGLActor, vtkOpenGLImageActor, vtkParallelCoordinatesActor, vtkProp3D, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

void vtkProp::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkImageActor, vtkLODActor, vtkLODProp3D, vtkParallelCoordinatesActor, vtkProp3D, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

virtual void vtkProp::GetActors ( vtkPropCollection * ) [inline, virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented in vtkActor, vtkAssembly, and vtkLODProp3D.

Definition at line 69 of file vtkProp.h.

virtual void vtkProp::GetActors2D ( vtkPropCollection * pc ) [inline, virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented in vtkActor2D.

Definition at line 70 of file vtkProp.h.

virtual void vtkProp::GetVolumes ( vtkPropCollection * vc ) [inline, virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. These methods are used in that process.

Reimplemented in vtkAssembly, and vtkVolume.

Definition at line 71 of file vtkProp.h.

virtual void vtkProp::SetVisibility ( int ) [virtual]

Set/Get visibility of this vtkProp.

virtual int vtkProp::GetVisibility ( ) [virtual]

Set/Get visibility of this vtkProp.

virtual void vtkProp::VisibilityOn ( ) [virtual]

Set/Get visibility of this vtkProp.

virtual void vtkProp::VisibilityOff ( ) [virtual]

Set/Get visibility of this vtkProp.

virtual void vtkProp::SetPickable ( int ) [virtual]

Set/Get the pickable instance variable. This determines if the vtkProp can be picked (typically using the mouse). Also see dragable.

virtual int vtkProp::GetPickable ( ) [virtual]

Set/Get the pickable instance variable. This determines if the vtkProp can be picked (typically using the mouse). Also see dragable.

virtual void vtkProp::PickableOn ( ) [virtual]

Set/Get the pickable instance variable. This determines if the vtkProp can be picked (typically using the mouse). Also see dragable.

virtual void vtkProp::PickableOff ( ) [virtual]

Set/Get the pickable instance variable. This determines if the vtkProp can be picked (typically using the mouse). Also see dragable.

void vtkProp::SetPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

This method is invoked when an instance of vtkProp (or subclass, e.g., vtkActor) is picked by vtkPicker.

Reimplemented in vtkLODProp3D.

void vtkProp::SetPickMethodArgDelete ( void(* f)(void *) )

This method is invoked when an instance of vtkProp (or subclass, e.g., vtkActor) is picked by vtkPicker.

Reimplemented in vtkLODProp3D.

virtual void vtkProp::Pick ( ) [virtual]

Method invokes PickMethod() if one defined and the prop is picked.

virtual void vtkProp::SetDragable ( int ) [virtual]

Set/Get the value of the dragable instance variable. This determines if an Prop, once picked, can be dragged (translated) through space. This is typically done through an interactive mouse interface. This does not affect methods such as SetPosition, which will continue to work. It is just intended to prevent some vtkProp'ss from being dragged from within a user interface.

virtual int vtkProp::GetDragable ( ) [virtual]

Set/Get the value of the dragable instance variable. This determines if an Prop, once picked, can be dragged (translated) through space. This is typically done through an interactive mouse interface. This does not affect methods such as SetPosition, which will continue to work. It is just intended to prevent some vtkProp'ss from being dragged from within a user interface.

virtual void vtkProp::DragableOn ( ) [virtual]

Set/Get the value of the dragable instance variable. This determines if an Prop, once picked, can be dragged (translated) through space. This is typically done through an interactive mouse interface. This does not affect methods such as SetPosition, which will continue to work. It is just intended to prevent some vtkProp'ss from being dragged from within a user interface.

virtual void vtkProp::DragableOff ( ) [virtual]

Set/Get the value of the dragable instance variable. This determines if an Prop, once picked, can be dragged (translated) through space. This is typically done through an interactive mouse interface. This does not affect methods such as SetPosition, which will continue to work. It is just intended to prevent some vtkProp'ss from being dragged from within a user interface.

virtual unsigned long vtkProp::GetRedrawMTime ( ) [inline, virtual]

Return the mtime of anything that would cause the rendered image to appear differently. Usually this involves checking the mtime of the prop plus anything else it depends on such as properties, textures etc.

Reimplemented in vtkActor, and vtkVolume.

Definition at line 115 of file vtkProp.h.

virtual float* vtkProp::GetBounds ( ) [inline, virtual]

Get the bounds for this Prop as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax). in world coordinates. NULL means that the bounds are not defined.

Reimplemented in vtkPropAssembly, vtkCubeAxesActor2D, vtkActor, vtkAssembly, vtkImageActor, vtkLODProp3D, vtkProp3D, and vtkVolume.

Definition at line 119 of file vtkProp.h.

virtual void vtkProp::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this vtkProp.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkLegendBoxActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkLODActor, vtkLODProp3D, vtkProp3D, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

virtual void vtkProp::InitPathTraversal ( ) [virtual]

vtkProp and its subclasses can be picked by subclasses of vtkAbstractPicker (e.g., vtkPropPicker). The following methods interface with the picking classes and return "pick paths". A pick path is a hierarchical, ordered list of props that form an assembly. Most often, when a vtkProp is picked, its path consists of a single node (i.e., the prop). However, classes like vtkAssembly and vtkPropAssembly can return more than one path, each path being several layers deep. (See vtkAssemblyPath for more information.) To use these methods - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented in vtkPropAssembly, vtkAssembly, and vtkProp3D.

virtual vtkAssemblyPath* vtkProp::GetNextPath ( ) [virtual]

vtkProp and its subclasses can be picked by subclasses of vtkAbstractPicker (e.g., vtkPropPicker). The following methods interface with the picking classes and return "pick paths". A pick path is a hierarchical, ordered list of props that form an assembly. Most often, when a vtkProp is picked, its path consists of a single node (i.e., the prop). However, classes like vtkAssembly and vtkPropAssembly can return more than one path, each path being several layers deep. (See vtkAssemblyPath for more information.) To use these methods - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented in vtkPropAssembly, and vtkAssembly.

virtual int vtkProp::GetNumberOfPaths ( ) [inline, virtual]

vtkProp and its subclasses can be picked by subclasses of vtkAbstractPicker (e.g., vtkPropPicker). The following methods interface with the picking classes and return "pick paths". A pick path is a hierarchical, ordered list of props that form an assembly. Most often, when a vtkProp is picked, its path consists of a single node (i.e., the prop). However, classes like vtkAssembly and vtkPropAssembly can return more than one path, each path being several layers deep. (See vtkAssemblyPath for more information.) To use these methods - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted.

Reimplemented in vtkPropAssembly, and vtkAssembly.

Definition at line 138 of file vtkProp.h.

virtual void vtkProp::PokeMatrix ( vtkMatrix4x4 *vtkNotUsed(matrix) ) [inline, virtual]

These methods are used by subclasses to place a matrix (if any) in the prop prior to rendering. Generally used only for picking. See vtkProp3D for more information.

Definition at line 145 of file vtkProp.h.

virtual vtkMatrix4x4* vtkProp::GetMatrix ( ) [inline, virtual]

These methods are used by subclasses to place a matrix (if any) in the prop prior to rendering. Generally used only for picking. See vtkProp3D for more information.

Reimplemented in vtkFollower, and vtkProp3D.

Definition at line 146 of file vtkProp.h.

virtual int vtkProp::RenderOpaqueGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS All concrete subclasses must be able to render themselves. There are three key render methods in vtk and they correspond to three different points in the rendering cycle. Any given prop may implement one or more of these methods. The first method is intended for rendering all opaque geometry. The second method is intended for rendering all translucent geometry. Most volume rendering mappers draw their results during this second method. The last method is to render any 2D annotation or overlays. Each of these methods return an integer value indicating whether or not this render method was applied to this data.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkImageActor, vtkLODActor, vtkLODProp3D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

Definition at line 162 of file vtkProp.h.

virtual int vtkProp::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS All concrete subclasses must be able to render themselves. There are three key render methods in vtk and they correspond to three different points in the rendering cycle. Any given prop may implement one or more of these methods. The first method is intended for rendering all opaque geometry. The second method is intended for rendering all translucent geometry. Most volume rendering mappers draw their results during this second method. The last method is to render any 2D annotation or overlays. Each of these methods return an integer value indicating whether or not this render method was applied to this data.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkFollower, vtkLODProp3D, vtkParallelCoordinatesActor, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

Definition at line 163 of file vtkProp.h.

virtual int vtkProp::RenderOverlay ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS All concrete subclasses must be able to render themselves. There are three key render methods in vtk and they correspond to three different points in the rendering cycle. Any given prop may implement one or more of these methods. The first method is intended for rendering all opaque geometry. The second method is intended for rendering all translucent geometry. Most volume rendering mappers draw their results during this second method. The last method is to render any 2D annotation or overlays. Each of these methods return an integer value indicating whether or not this render method was applied to this data.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkAxisActor2D, vtkParallelCoordinatesActor, vtkScalarBarActor, and vtkScaledTextActor.

Definition at line 164 of file vtkProp.h.

virtual void vtkProp::ReleaseGraphicsResources ( vtkWindow * ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented in vtkActor2D, vtkPropAssembly, vtkCaptionActor2D, vtkCubeAxesActor2D, vtkLegendBoxActor, vtkXYPlotActor, vtkActor, vtkAssembly, vtkAxisActor2D, vtkLODActor, vtkLODProp3D, vtkMesaImageActor, vtkOpenGLImageActor, vtkParallelCoordinatesActor, vtkScalarBarActor, vtkScaledTextActor, and vtkVolume.

Definition at line 171 of file vtkProp.h.

virtual float vtkProp::GetEstimatedRenderTime ( vtkViewport * ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS The EstimatedRenderTime may be used to select between different props, for example in LODProp it is used to select the level-of-detail. The value is returned in seconds. For simple geometry the accuracy may not be great due to buffering. For ray casting, which is already multi-resolution, the current resolution of the image is factored into the time. We need the viewport for viewing parameters that affect timing. The no-arguments version simply returns the value of the variable with no estimation.

Definition at line 184 of file vtkProp.h.

virtual float vtkProp::GetEstimatedRenderTime ( ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS The EstimatedRenderTime may be used to select between different props, for example in LODProp it is used to select the level-of-detail. The value is returned in seconds. For simple geometry the accuracy may not be great due to buffering. For ray casting, which is already multi-resolution, the current resolution of the image is factored into the time. We need the viewport for viewing parameters that affect timing. The no-arguments version simply returns the value of the variable with no estimation.

Definition at line 186 of file vtkProp.h.

virtual void vtkProp::SetEstimatedRenderTime ( float t ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS This method is used by, for example, the vtkLODProp3D in order to initialize the estimated render time at start-up to some user defined value.

Definition at line 194 of file vtkProp.h.

virtual void vtkProp::RestoreEstimatedRenderTime ( ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THESE METHODS OUTSIDE OF THE RENDERING PROCESS When the EstimatedRenderTime is first set to 0.0 (in the SetAllocatedRenderTime method) the old value is saved. This method is used to restore that old value should the render be aborted.

Reimplemented in vtkLODProp3D.

Definition at line 204 of file vtkProp.h.

virtual void vtkProp::AddEstimatedRenderTime | ( | float | t,
 |  | vtkViewport *vtkNotUsed(vp) |
 | ) | [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS This method is intended to allow the renderer to add to the EstimatedRenderTime in props that require information that the renderer has in order to do this. For example, props that are rendered with a ray casting method do not know themselves how long it took for them to render. We don't want to cause a this->Modified() when we set this value since it is not really a modification to the object. (For example, we don't want to rebuild matrices at every render because the estimated render time is changing)

Definition at line 220 of file vtkProp.h.

virtual void vtkProp::SetAllocatedRenderTime | ( | float | t,
 |  | vtkViewport *vtkNotUsed(v) |
 | ) | [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS The renderer may use the allocated rendering time to determine how to render this actor. Therefore it might need the information provided in the viewport. A side effect of this method is to reset the EstimatedRenderTime to 0.0. This way, each of the ways that this prop may be rendered can be timed and added together into this value.

Definition at line 232 of file vtkProp.h.

virtual float vtkProp::GetAllocatedRenderTime ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

void vtkProp::SetRenderTimeMultiplier ( float t ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Get/Set the multiplier for the render time. This is used for culling and is a number between 0 and 1. It is used to create the allocated render time value.

Definition at line 251 of file vtkProp.h.

virtual float vtkProp::GetRenderTimeMultiplier ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Get/Set the multiplier for the render time. This is used for culling and is a number between 0 and 1. It is used to create the allocated render time value.

virtual void vtkProp::BuildPaths | ( | vtkAssemblyPaths * | paths,
 |  | vtkAssemblyPath * | path
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Used to construct assembly paths and perform part traversal.

Reimplemented in vtkPropAssembly, and vtkAssembly.

virtual int vtkProp::GetNumberOfConsumers ( ) [virtual]

Get the number of consumers

void vtkProp::AddConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

void vtkProp::RemoveConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

vtkObject* vtkProp::GetConsumer ( int i )

Add or remove or get or check a consumer,

int vtkProp::IsConsumer ( vtkObject * c )

Add or remove or get or check a consumer,

Member Data Documentation

int vtkProp::Visibility [protected]

Definition at line 279 of file vtkProp.h.

int vtkProp::Pickable [protected]

Definition at line 280 of file vtkProp.h.

unsigned long vtkProp::PickTag [protected]

Definition at line 281 of file vtkProp.h.

int vtkProp::Dragable [protected]

Definition at line 282 of file vtkProp.h.

float vtkProp::AllocatedRenderTime [protected]

Definition at line 284 of file vtkProp.h.

float vtkProp::EstimatedRenderTime [protected]

Definition at line 285 of file vtkProp.h.

float vtkProp::SavedEstimatedRenderTime [protected]

Definition at line 286 of file vtkProp.h.

float vtkProp::RenderTimeMultiplier [protected]

Definition at line 287 of file vtkProp.h.

int vtkProp::NumberOfConsumers [protected]

Definition at line 290 of file vtkProp.h.

vtkObject** vtkProp::Consumers [protected]

Definition at line 291 of file vtkProp.h.

vtkAssemblyPaths* vtkProp::Paths [protected]

Definition at line 295 of file vtkProp.h.

The documentation for this class was generated from the following file:
  • Common/vtkProp.h
Generated on Mon Mar 25 01:28:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp3D Class Reference

represents an 3D object for placement in a rendered scene. More...

#include <vtkProp3D.h>

Inheritance diagram for vtkProp3D:

[legend]
Collaboration diagram for vtkProp3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProp3D, vtkProp)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ShallowCopy (vtkProp *prop)
void | SetScale (float s)
float * | GetCenter ()
float * | GetXRange ()
float * | GetYRange ()
float * | GetZRange ()
float | GetLength ()
void | RotateX (float)
void | RotateY (float)
void | RotateZ (float)
void | RotateWXYZ (float, float, float, float)
void | SetOrientation (float, float, float)
void | SetOrientation (float a[3])
float * | GetOrientationWXYZ ()
void | AddOrientation (float, float, float)
void | AddOrientation (float a[3])
void | PokeMatrix (vtkMatrix4x4 *matrix)
void | InitPathTraversal ()
virtual void | ComputeMatrix ()
virtual void | SetPosition (float _arg1, float _arg2, float _arg3)
virtual void | SetPosition (float _arg[3])
virtual float * | GetPosition ()
virtual void | GetPosition (float data[3])
void | AddPosition (float deltaPosition[3])
void | AddPosition (float deltaX, float deltaY, float deltaZ)
virtual void | SetOrigin (float _arg1, float _arg2, float _arg3)
virtual void | SetOrigin (float _arg[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetScale (float _arg1, float _arg2, float _arg3)
virtual void | SetScale (float _arg[3])
virtual float * | GetScale ()
virtual void | GetScale (float data[3])
void | SetUserTransform (vtkLinearTransform *transform)
virtual vtkLinearTransform * | GetUserTransform ()
void | SetUserMatrix (vtkMatrix4x4 *matrix)
vtkMatrix4x4 * GetUserMatrix ()
virtual void | GetMatrix (vtkMatrix4x4 *m)
virtual void | GetMatrix (double m[16])
void | GetBounds (float bounds[6])
virtual float * | GetBounds ()=0
float * | GetOrientation ()
void | GetOrientation (float o[3])
vtkMatrix4x4 * GetMatrix ()
virtual int | GetIsIdentity ()

Protected Methods

vtkProp3D ()
~vtkProp3D ()

Protected Attributes

vtkLinearTransform * UserTransform
vtkMatrix4x4 * UserMatrix
vtkMatrix4x4 * Matrix
vtkTimeStamp MatrixMTime
float | Origin [3]
float | Position [3]
float | Orientation [3]
float | Scale [3]
float | Center [3]
vtkTransform * Transform
float | Bounds [6]
vtkProp3D * | CachedProp3D
int | IsIdentity

Detailed Description

represents an 3D object for placement in a rendered scene.

Date:
2002/01/22 15:39:09
Revision:
1.34

vtkProp3D is an abstract class used to represent an entity in a rendering scene (i.e., vtkProp3D is a vtkProp with an associated transformation matrix). It handles functions related to the position, orientation and scaling. It combines these instance variables into one 4x4 transformation matrix as follows: [x y z 1] = [x y z 1] Translate(-origin) Scale(scale) Rot(y) Rot(x) Rot (z) Trans(origin) Trans(position). Both vtkActor and vtkVolume are specializations of class vtkProp. The constructor defaults to: origin(0,0,0) position=(0,0,0) orientation=(0,0,0), no user defined matrix or transform, and no texture map.

See also:
vtkProp vtkActor vtkAssembly vtkVolume
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (53%)
  • Schroeder, Will (22%)
  • Gobbi, David (13%)
  • Avila, Lisa (5%)

Definition at line 53 of file vtkProp3D.h.

Constructor & Destructor Documentation

vtkProp3D::vtkProp3D ( ) [protected]

vtkProp3D::~vtkProp3D ( ) [protected]

Member Function Documentation

vtkProp3D::vtkTypeRevisionMacro | ( | vtkProp3D | ,
 |  | vtkProp |
 | ) |

Reimplemented from vtkProp.

Reimplemented in vtkActor, vtkAssembly, vtkFollower, vtkLODActor, vtkLODProp3D, vtkMesaActor, vtkOpenGLActor, and vtkVolume.

void vtkProp3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp.

Reimplemented in vtkActor, vtkAssembly, vtkFollower, vtkLODActor, vtkLODProp3D, and vtkVolume.

void vtkProp3D::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this vtkProp3D.

Reimplemented from vtkProp.

Reimplemented in vtkActor, vtkAssembly, vtkFollower, vtkLODActor, vtkLODProp3D, and vtkVolume.

virtual void vtkProp3D::SetPosition | ( | float | _arg1,
 |  | float | _arg2,
 |  | float | _arg3
 | ) | [inline, virtual]

Set/Get/Add the position of the Prop3D in world coordinates.

Definition at line 64 of file vtkProp3D.h.

virtual void vtkProp3D::SetPosition ( float _arg[3] ) [inline, virtual]

Set/Get/Add the position of the Prop3D in world coordinates.

Definition at line 80 of file vtkProp3D.h.

virtual float* vtkProp3D::GetPosition ( ) [virtual]

Set/Get/Add the position of the Prop3D in world coordinates.

virtual void vtkProp3D::GetPosition ( float data[3] ) [virtual]

Set/Get/Add the position of the Prop3D in world coordinates.

void vtkProp3D::AddPosition ( float deltaPosition[3] )

Set/Get/Add the position of the Prop3D in world coordinates.

void vtkProp3D::AddPosition | ( | float | deltaX,
 |  | float | deltaY,
 |  | float | deltaZ
 | ) |

Set/Get/Add the position of the Prop3D in world coordinates.

virtual void vtkProp3D::SetOrigin | ( | float | _arg1,
 |  | float | _arg2,
 |  | float | _arg3
 | ) | [inline, virtual]

Set/Get the origin of the Prop3D. This is the point about which all rotations take place.

Definition at line 92 of file vtkProp3D.h.

virtual void vtkProp3D::SetOrigin ( float _arg[3] ) [inline, virtual]

Set/Get the origin of the Prop3D. This is the point about which all rotations take place.

Definition at line 108 of file vtkProp3D.h.

virtual float* vtkProp3D::GetOrigin ( ) [virtual]

Set/Get the origin of the Prop3D. This is the point about which all rotations take place.

virtual void vtkProp3D::GetOrigin ( float data[3] ) [virtual]

Set/Get the origin of the Prop3D. This is the point about which all rotations take place.

virtual void vtkProp3D::SetScale | ( | float | _arg1,
 |  | float | _arg2,
 |  | float | _arg3
 | ) | [inline, virtual]

Set/Get the scale of the actor. Scaling in performed independently on the X, Y and Z axis. A scale of zero is illegal and will be replaced with one.

Definition at line 119 of file vtkProp3D.h.

virtual void vtkProp3D::SetScale ( float _arg[3] ) [inline, virtual]

Set/Get the scale of the actor. Scaling in performed independently on the X, Y and Z axis. A scale of zero is illegal and will be replaced with one.

Definition at line 135 of file vtkProp3D.h.

virtual float* vtkProp3D::GetScale ( ) [virtual]

Set/Get the scale of the actor. Scaling in performed independently on the X, Y and Z axis. A scale of zero is illegal and will be replaced with one.

virtual void vtkProp3D::GetScale ( float data[3] ) [virtual]

Set/Get the scale of the actor. Scaling in performed independently on the X, Y and Z axis. A scale of zero is illegal and will be replaced with one.

void vtkProp3D::SetScale ( float s ) [inline]

Method to set the scale isotropically

Definition at line 143 of file vtkProp3D.h.

void vtkProp3D::SetUserTransform ( vtkLinearTransform * transform )

In addition to the instance variables such as position and orientation, you can add an additional transformation for your own use. This transformation is concatenated with the actor's internal transformation, which you implicitly create through the use of SetPosition(), SetOrigin() and SetOrientation().

If the internal transformation is identity (i.e. if you don't set the Position, Origin, or Orientation) then the actors final transformation will be the UserTransform, concatenated with the UserMatrix if the UserMatrix is present.

virtual vtkLinearTransform* vtkProp3D::GetUserTransform ( ) [virtual]

In addition to the instance variables such as position and orientation, you can add an additional transformation for your own use. This transformation is concatenated with the actor's internal transformation, which you implicitly create through the use of SetPosition(), SetOrigin() and SetOrientation().

If the internal transformation is identity (i.e. if you don't set the Position, Origin, or Orientation) then the actors final transformation will be the UserTransform, concatenated with the UserMatrix if the UserMatrix is present.

void vtkProp3D::SetUserMatrix ( vtkMatrix4x4 * matrix )

The UserMatrix can be used in place of UserTransform.

vtkMatrix4x4* vtkProp3D::GetUserMatrix ( ) [inline]

The UserMatrix can be used in place of UserTransform.

Definition at line 162 of file vtkProp3D.h.

virtual void vtkProp3D::GetMatrix ( vtkMatrix4x4 * m ) [virtual]

Return a reference to the Prop3D's 4x4 composite matrix. Get the matrix from the position, origin, scale and orientation This matrix is cached, so multiple GetMatrix() calls will be efficient.

Reimplemented in vtkFollower.

virtual void vtkProp3D::GetMatrix ( double m[16] ) [virtual]

Return a reference to the Prop3D's 4x4 composite matrix. Get the matrix from the position, origin, scale and orientation This matrix is cached, so multiple GetMatrix() calls will be efficient.

Reimplemented in vtkFollower.

void vtkProp3D::GetBounds ( float bounds[6] )

Get the bounds for this Prop3D as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax).

Reimplemented in vtkActor, vtkAssembly, vtkLODProp3D, and vtkVolume.

virtual float* vtkProp3D::GetBounds ( ) [pure virtual]

Get the bounds for this Prop3D as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax).

Reimplemented from vtkProp.

Reimplemented in vtkActor, vtkAssembly, vtkLODProp3D, and vtkVolume.

Referenced by vtkVolume::GetBounds(), vtkLODProp3D::GetBounds(), vtkAssembly::GetBounds(), and vtkActor::GetBounds().

float* vtkProp3D::GetCenter ( )

Get the center of the bounding box in world coordinates.

float* vtkProp3D::GetXRange ( )

Get the Prop3D's x range in world coordinates.

float* vtkProp3D::GetYRange ( )

Get the Prop3D's y range in world coordinates.

float* vtkProp3D::GetZRange ( )

Get the Prop3D's z range in world coordinates.

float vtkProp3D::GetLength ( void )

Get the length of the diagonal of the bounding box.

void vtkProp3D::RotateX ( float )

Rotate the Prop3D in degrees about the X axis using the right hand rule. The axis is the Prop3D's X axis, which can change as other rotations are performed. To rotate about the world X axis use RotateWXYZ (angle, 1, 0, 0). This rotation is applied before all others in the current transformation matrix.

void vtkProp3D::RotateY ( float )

Rotate the Prop3D in degrees about the Y axis using the right hand rule. The axis is the Prop3D's Y axis, which can change as other rotations are performed. To rotate about the world Y axis use RotateWXYZ (angle, 0, 1, 0). This rotation is applied before all others in the current transformation matrix.

void vtkProp3D::RotateZ ( float )

Rotate the Prop3D in degrees about the Z axis using the right hand rule. The axis is the Prop3D's Z axis, which can change as other rotations are performed. To rotate about the world Z axis use RotateWXYZ (angle, 0, 0, 1). This rotation is applied before all others in the current transformation matrix.

void vtkProp3D::RotateWXYZ | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) |

Rotate the Prop3D in degrees about an arbitrary axis specified by the last three arguments. The axis is specified in world coordinates. To rotate an about its model axes, use RotateX, RotateY, RotateZ.

void vtkProp3D::SetOrientation | ( | float | ,
 |  | float | ,
 |  | float |
 | ) |

Sets the orientation of the Prop3D. Orientation is specified as X,Y and Z rotations in that order, but they are performed as RotateZ, RotateX, and finally RotateY.

void vtkProp3D::SetOrientation ( float a[3] )

Sets the orientation of the Prop3D. Orientation is specified as X,Y and Z rotations in that order, but they are performed as RotateZ, RotateX, and finally RotateY.

float* vtkProp3D::GetOrientation ( )

Returns the orientation of the Prop3D as s vector of X,Y and Z rotation. The ordering in which these rotations must be done to generate the same matrix is RotateZ, RotateX, and finally RotateY. See also SetOrientation.

void vtkProp3D::GetOrientation ( float o[3] )

Returns the orientation of the Prop3D as s vector of X,Y and Z rotation. The ordering in which these rotations must be done to generate the same matrix is RotateZ, RotateX, and finally RotateY. See also SetOrientation.

float* vtkProp3D::GetOrientationWXYZ ( )

Returns the WXYZ orientation of the Prop3D.

void vtkProp3D::AddOrientation | ( | float | ,
 |  | float | ,
 |  | float |
 | ) |

Add to the current orientation. See SetOrientation and GetOrientation for more details. This basically does a GetOrientation, adds the passed in arguments, and then calls SetOrientation.

void vtkProp3D::AddOrientation ( float a[3] )

Add to the current orientation. See SetOrientation and GetOrientation for more details. This basically does a GetOrientation, adds the passed in arguments, and then calls SetOrientation.

void vtkProp3D::PokeMatrix ( vtkMatrix4x4 * matrix )

This method modifies the vtkProp3D so that its transformation state is set to the matrix specified. The method does this by setting appropriate transformation-related ivars to initial values (i.e., not transformed), and placing the user-supplied matrix into the UserMatrix of this vtkProp3D. If the method is called again with a NULL matrix, then the original state of the vtkProp3D will be restored. This method is used to support picking and assembly structures.

void vtkProp3D::InitPathTraversal ( ) [virtual]

Overload vtkProp's method for setting up assembly paths. See the documentation for vtkProp.

Reimplemented from vtkProp.

Reimplemented in vtkAssembly.

virtual void vtkProp3D::ComputeMatrix ( ) [virtual]

Generate the matrix based on ivars

vtkMatrix4x4* vtkProp3D::GetMatrix ( ) [inline, virtual]

Get a pointer to an internal vtkMatrix4x4. that represents

Reimplemented from vtkProp.

Reimplemented in vtkFollower.

Definition at line 276 of file vtkProp3D.h.

Referenced by vtkFollower::GetMatrix().

virtual int vtkProp3D::GetIsIdentity ( ) [virtual]

Is the matrix for this actor identity

Member Data Documentation

vtkLinearTransform* vtkProp3D::UserTransform [protected]

Definition at line 292 of file vtkProp3D.h.

vtkMatrix4x4* vtkProp3D::UserMatrix [protected]

Definition at line 293 of file vtkProp3D.h.

vtkMatrix4x4* vtkProp3D::Matrix [protected]

Definition at line 294 of file vtkProp3D.h.

vtkTimeStamp vtkProp3D::MatrixMTime [protected]

Definition at line 295 of file vtkProp3D.h.

float vtkProp3D::Origin[3] [protected]

Definition at line 296 of file vtkProp3D.h.

float vtkProp3D::Position[3] [protected]

Definition at line 297 of file vtkProp3D.h.

float vtkProp3D::Orientation[3] [protected]

Definition at line 298 of file vtkProp3D.h.

float vtkProp3D::Scale[3] [protected]

Definition at line 299 of file vtkProp3D.h.

float vtkProp3D::Center[3] [protected]

Definition at line 300 of file vtkProp3D.h.

vtkTransform* vtkProp3D::Transform [protected]

Definition at line 301 of file vtkProp3D.h.

float vtkProp3D::Bounds[6] [protected]

Definition at line 302 of file vtkProp3D.h.

vtkProp3D* vtkProp3D::CachedProp3D [protected]

Definition at line 303 of file vtkProp3D.h.

int vtkProp3D::IsIdentity [protected]

Definition at line 304 of file vtkProp3D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkProp3D.h
Generated on Mon Mar 25 01:28:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProp3DCollection Class Reference

a list of 3D props. More...

#include <vtkProp3DCollection.h>

Inheritance diagram for vtkProp3DCollection:

[legend]
Collaboration diagram for vtkProp3DCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProp3DCollection, vtkPropCollection)
void | AddItem (vtkProp3D *p)
vtkProp3D * GetNextProp3D ()
vtkProp3D * GetLastProp3D ()

Static Public Methods

vtkProp3DCollection * | New ()

Protected Methods

vtkProp3DCollection ()
~vtkProp3DCollection ()

Detailed Description

a list of 3D props.

Date:
2002/01/22 15:39:09
Revision:
1.11

vtkProp3DCollection represents and provides methods to manipulate a list of 3D props (i.e., vtkProp3D and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkProp3D vtkCollection
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)

Definition at line 42 of file vtkProp3DCollection.h.

Constructor & Destructor Documentation

vtkProp3DCollection::vtkProp3DCollection ( ) [inline, protected]

Definition at line 58 of file vtkProp3DCollection.h.

vtkProp3DCollection::~vtkProp3DCollection ( ) [inline, protected]

Definition at line 59 of file vtkProp3DCollection.h.

Member Function Documentation

vtkProp3DCollection* vtkProp3DCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkPropCollection.

vtkProp3DCollection::vtkTypeRevisionMacro | ( | vtkProp3DCollection | ,
 |  | vtkPropCollection |
 | ) |

Reimplemented from vtkPropCollection.

void vtkProp3DCollection::AddItem ( vtkProp3D * a ) [inline]

Add an actor to the list.

Definition at line 72 of file vtkProp3DCollection.h.

vtkProp3D * vtkProp3DCollection::GetNextProp3D ( ) [inline]

Get the next actor in the list.

Definition at line 77 of file vtkProp3DCollection.h.

vtkProp3D * vtkProp3DCollection::GetLastProp3D ( ) [inline]

Get the last actor in the list.

Definition at line 82 of file vtkProp3DCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkProp3DCollection.h
Generated on Mon Mar 25 01:28:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropAssembly Class Reference

create hierarchies of props. More...

#include <vtkPropAssembly.h>

Inheritance diagram for vtkPropAssembly:

[legend]
Collaboration diagram for vtkPropAssembly:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPropAssembly, vtkProp)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddPart (vtkProp *)
void | RemovePart (vtkProp *)
vtkPropCollection * GetParts ()
void | ReleaseGraphicsResources (vtkWindow *)
float * | GetBounds ()
void | ShallowCopy (vtkProp *Prop)
unsigned long int | GetMTime ()
void | BuildPaths (vtkAssemblyPaths *paths, vtkAssemblyPath *path)
int | RenderOpaqueGeometry (vtkViewport *ren)
int | RenderTranslucentGeometry (vtkViewport *ren)
int | RenderOverlay (vtkViewport *)
void | InitPathTraversal ()
vtkAssemblyPath * GetNextPath ()
int | GetNumberOfPaths ()

Static Public Methods

vtkPropAssembly * | New ()

Protected Methods

vtkPropAssembly ()
~vtkPropAssembly ()
void | UpdatePaths ()

Protected Attributes

vtkPropCollection * Parts
float | Bounds [6]
vtkTimeStamp PathTime

Detailed Description

create hierarchies of props.

Date:
2002/01/22 15:26:09
Revision:
1.20

vtkPropAssembly is an object that groups props and other prop assemblies into a tree-like hierarchy. The props can then be treated as a group (e.g., turning visibility on and off).

A vtkPropAssembly object can be used in place of an vtkProp since it is a subclass of vtkProp. The difference is that vtkPropAssembly maintains a list of other prop and prop assembly instances (its "parts") that form the assembly. Note that this process is recursive: you can create groups consisting of prop assemblies to arbitrary depth.

vtkPropAssembly's and vtkProp's that compose a prop assembly need not be added to a renderer's list of props, as long as the parent assembly is in the prop list. This is because they are automatically renderered during the hierarchical traversal process.

Warning:
vtkPropAssemblies can consist of hierarchies of assemblies, where one actor or assembly used in one hierarchy is also used in other hierarchies. However, make that there are no cycles (e.g., parent->child->parent), this will cause program failure.
See also:
vtkProp3D vtkActor vtkAssembly vtkActor2D vtkVolume
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (90%)
  • Avila, Lisa (5%)
Tests:
vtkPropAssembly (Tests)

Definition at line 62 of file vtkPropAssembly.h.

Constructor & Destructor Documentation

vtkPropAssembly::vtkPropAssembly ( ) [protected]

vtkPropAssembly::~vtkPropAssembly ( ) [protected]

Member Function Documentation

vtkPropAssembly::vtkTypeRevisionMacro | ( | vtkPropAssembly | ,
 |  | vtkProp |
 | ) |

Reimplemented from vtkProp.

void vtkPropAssembly::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp.

vtkPropAssembly* vtkPropAssembly::New ( ) [static]

Create with an empty parts list.

Reimplemented from vtkProp.

void vtkPropAssembly::AddPart ( vtkProp * )

Add a part to the list of parts.

void vtkPropAssembly::RemovePart ( vtkProp * )

Remove a part from the list of parts,

vtkPropCollection* vtkPropAssembly::GetParts ( )

Return the list of parts.

int vtkPropAssembly::RenderOpaqueGeometry ( vtkViewport * ren ) [virtual]

Render this assembly and all its parts. The rendering process is recursive. The parts of each assembly are rendered only if the visibility for the prop is turned on.

Reimplemented from vtkProp.

int vtkPropAssembly::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

Render this assembly and all its parts. The rendering process is recursive. The parts of each assembly are rendered only if the visibility for the prop is turned on.

Reimplemented from vtkProp.

int vtkPropAssembly::RenderOverlay ( vtkViewport * viewport ) [virtual]

Render this assembly and all its parts. The rendering process is recursive. The parts of each assembly are rendered only if the visibility for the prop is turned on.

Reimplemented from vtkProp.

void vtkPropAssembly::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

float* vtkPropAssembly::GetBounds ( ) [virtual]

Get the bounds for this prop assembly as (Xmin,Xmax,Ymin,Ymax,Zmin,Zmax). May return NULL in some cases (meaning the bounds is undefined).

Reimplemented from vtkProp.

void vtkPropAssembly::ShallowCopy ( vtkProp * Prop ) [virtual]

Shallow copy of this vtkPropAssembly.

Reimplemented from vtkProp.

unsigned long int vtkPropAssembly::GetMTime ( ) [virtual]

Override default GetMTime method to also consider all of the prop assembly's parts.

Reimplemented from vtkObject.

void vtkPropAssembly::InitPathTraversal ( ) [virtual]

Methods to traverse the paths (i.e., leaf nodes) of a prop assembly. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily the leaf nodes of the assembly. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted. (See the superclass vtkProp for more information about paths.)

Reimplemented from vtkProp.

vtkAssemblyPath* vtkPropAssembly::GetNextPath ( ) [virtual]

Methods to traverse the paths (i.e., leaf nodes) of a prop assembly. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily the leaf nodes of the assembly. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted. (See the superclass vtkProp for more information about paths.)

Reimplemented from vtkProp.

int vtkPropAssembly::GetNumberOfPaths ( ) [virtual]

Methods to traverse the paths (i.e., leaf nodes) of a prop assembly. These methods should be contrasted to those that traverse the list of parts using GetParts(). GetParts() returns a list of children of this assembly, not necessarily the leaf nodes of the assembly. To use the methods below - first invoke InitPathTraversal() followed by repeated calls to GetNextPath(). GetNextPath() returns a NULL pointer when the list is exhausted. (See the superclass vtkProp for more information about paths.)

Reimplemented from vtkProp.

void vtkPropAssembly::BuildPaths | ( | vtkAssemblyPaths * | paths,
 |  | vtkAssemblyPath * | path
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Overload the superclass' vtkProp BuildPaths() method.

Reimplemented from vtkProp.

void vtkPropAssembly::UpdatePaths ( ) [protected]

Member Data Documentation

vtkPropCollection* vtkPropAssembly::Parts [protected]

Definition at line 131 of file vtkPropAssembly.h.

float vtkPropAssembly::Bounds[6] [protected]

Definition at line 132 of file vtkPropAssembly.h.

vtkTimeStamp vtkPropAssembly::PathTime [protected]

Definition at line 135 of file vtkPropAssembly.h.

The documentation for this class was generated from the following file:
  • Common/vtkPropAssembly.h
Generated on Mon Mar 25 01:28:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropCollection Class Reference

a list of Props. More...

#include <vtkPropCollection.h>

Inheritance diagram for vtkPropCollection:

[legend]
Collaboration diagram for vtkPropCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPropCollection, vtkCollection)
void | AddItem (vtkProp *a)
vtkProp * GetNextProp ()
vtkProp * GetLastProp ()
int | GetNumberOfPaths ()

Static Public Methods

vtkPropCollection * | New ()

Protected Methods

vtkPropCollection ()
~vtkPropCollection ()

Detailed Description

a list of Props.

Date:
2002/01/22 15:26:10
Revision:
1.19

vtkPropCollection represents and provides methods to manipulate a list of Props (i.e., vtkProp and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkProp vtkCollection
Created by:
  • Hoffman, Bill
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (56%)
  • Hoffman, Bill (23%)
  • Schroeder, Will (10%)
Examples:
vtkPropCollection (Examples)

Definition at line 48 of file vtkPropCollection.h.

Constructor & Destructor Documentation

vtkPropCollection::vtkPropCollection ( ) [inline, protected]

Definition at line 70 of file vtkPropCollection.h.

vtkPropCollection::~vtkPropCollection ( ) [inline, protected]

Definition at line 71 of file vtkPropCollection.h.

Member Function Documentation

vtkPropCollection* vtkPropCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

Reimplemented in vtkActor2DCollection, vtkActorCollection, vtkProp3DCollection, and vtkVolumeCollection.

vtkPropCollection::vtkTypeRevisionMacro | ( | vtkPropCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

Reimplemented in vtkActor2DCollection, vtkActorCollection, vtkProp3DCollection, and vtkVolumeCollection.

void vtkPropCollection::AddItem ( vtkProp * o ) [inline]

Add an Prop to the list.

Definition at line 83 of file vtkPropCollection.h.

vtkProp * vtkPropCollection::GetNextProp ( ) [inline]

Get the next Prop in the list.

Definition at line 88 of file vtkPropCollection.h.

vtkProp * vtkPropCollection::GetLastProp ( ) [inline]

Get the last Prop in the list.

Definition at line 93 of file vtkPropCollection.h.

int vtkPropCollection::GetNumberOfPaths ( )

Get the number of paths contained in this list. (Recall that a vtkProp can consist of multiple parts.) Used in picking and other activities to get the parts of composite entities like vtkAssembly or vtkPropAssembly.

The documentation for this class was generated from the following file:
  • Common/vtkPropCollection.h
Generated on Mon Mar 25 01:28:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProperty Class Reference

represent surface properties of a geometric object. More...

#include <vtkProperty.h>

Inheritance diagram for vtkProperty:

[legend]
Collaboration diagram for vtkProperty:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProperty, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | DeepCopy (vtkProperty *p)
virtual void | Render (vtkActor *, vtkRenderer *)
virtual void | BackfaceRender (vtkActor *, vtkRenderer *)
virtual void | SetInterpolation (int)
virtual int | GetInterpolation ()
void | SetInterpolationToFlat ()
void | SetInterpolationToGouraud ()
void | SetInterpolationToPhong ()
char * | GetInterpolationAsString ()
virtual void | SetRepresentation (int)
virtual int | GetRepresentation ()
void | SetRepresentationToPoints ()
void | SetRepresentationToWireframe ()
void | SetRepresentationToSurface ()
char * | GetRepresentationAsString ()
void | SetColor (float r, float g, float b)
void | SetColor (float a[3])
float * | GetColor ()
void | GetColor (float rgb[3])
virtual void | SetAmbient (float)
virtual float | GetAmbient ()
virtual void | SetDiffuse (float)
virtual float | GetDiffuse ()
virtual void | SetSpecular (float)
virtual float | GetSpecular ()
virtual void | SetSpecularPower (float)
virtual float | GetSpecularPower ()
virtual void | SetOpacity (float)
virtual float | GetOpacity ()
virtual void | SetAmbientColor (float, float, float)
virtual void | SetAmbientColor (float[3])
virtual float * | GetAmbientColor ()
virtual void | GetAmbientColor (float data[3])
virtual void | SetDiffuseColor (float, float, float)
virtual void | SetDiffuseColor (float[3])
virtual float * | GetDiffuseColor ()
virtual void | GetDiffuseColor (float data[3])
virtual void | SetSpecularColor (float, float, float)
virtual void | SetSpecularColor (float[3])
virtual float * | GetSpecularColor ()
virtual void | GetSpecularColor (float data[3])
virtual int | GetEdgeVisibility ()
virtual void | SetEdgeVisibility (int)
virtual void | EdgeVisibilityOn ()
virtual void | EdgeVisibilityOff ()
virtual void | SetEdgeColor (float, float, float)
virtual void | SetEdgeColor (float[3])
virtual float * | GetEdgeColor ()
virtual void | GetEdgeColor (float data[3])
virtual void | SetLineWidth (float)
virtual float | GetLineWidth ()
virtual void | SetLineStipplePattern (int)
virtual int | GetLineStipplePattern ()
virtual void | SetLineStippleRepeatFactor (int)
virtual int | GetLineStippleRepeatFactor ()
virtual void | SetPointSize (float)
virtual float | GetPointSize ()
virtual int | GetBackfaceCulling ()
virtual void | SetBackfaceCulling (int)
virtual void | BackfaceCullingOn ()
virtual void | BackfaceCullingOff ()
virtual int | GetFrontfaceCulling ()
virtual void | SetFrontfaceCulling (int)
virtual void | FrontfaceCullingOn ()
virtual void | FrontfaceCullingOff ()

Static Public Methods

vtkProperty * | New ()

Protected Methods

vtkProperty ()
~vtkProperty ()

Protected Attributes

float | Color [3]
float | AmbientColor [3]
float | DiffuseColor [3]
float | SpecularColor [3]
float | EdgeColor [3]
float | Ambient
float | Diffuse
float | Specular
float | SpecularPower
float | Opacity
float | PointSize
float | LineWidth
int | LineStipplePattern
int | LineStippleRepeatFactor
int | Interpolation
int | Representation
int | EdgeVisibility
int | BackfaceCulling
int | FrontfaceCulling

Detailed Description

represent surface properties of a geometric object.

Date:
2002/01/22 15:39:11
Revision:
1.58

vtkProperty is an object that represents lighting and other surface properties of a geometric object. The primary properties that can be set are colors (overall, ambient, diffuse, specular, and edge color); specular power; opacity of the object; the representation of the object (points, wireframe, or surface); and the shading method to be used (flat, Gouraud, and Phong). Also, some special graphics features like backface properties can be set and manipulated with this object.

See also:
vtkActor vtkPropertyDevice
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (47%)
  • Schroeder, Will (38%)
  • Lorensen, Bill (7%)
Examples:
vtkProperty (Examples)
Tests:
vtkProperty (Tests)

Definition at line 58 of file vtkProperty.h.

Constructor & Destructor Documentation

vtkProperty::vtkProperty ( ) [protected]

vtkProperty::~vtkProperty ( ) [inline, protected]

Definition at line 236 of file vtkProperty.h.

Member Function Documentation

vtkProperty::vtkTypeRevisionMacro | ( | vtkProperty | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkRIBProperty, vtkMesaProperty, and vtkOpenGLProperty.

void vtkProperty::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkRIBProperty.

vtkProperty* vtkProperty::New ( ) [static]

Construct object with object color, ambient color, diffuse color, specular color, and edge color white; ambient coefficient=0; diffuse coefficient=0; specular coefficient=0; specular power=1; Gouraud shading; and surface representation. Backface and frontface culling are off.

Reimplemented from vtkObject.

Reimplemented in vtkRIBProperty, vtkMesaProperty, and vtkOpenGLProperty.

void vtkProperty::DeepCopy ( vtkProperty * p )

Assign one property to another.

virtual void vtkProperty::Render | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [inline, virtual]

This method causes the property to set up whatever is required for its instance variables. This is actually handled by a subclass of vtkProperty, which is created automatically. This method includes the invoking actor as an argument which can be used by property devices that require the actor.

Reimplemented in vtkRIBProperty, vtkMesaProperty, and vtkOpenGLProperty.

Definition at line 79 of file vtkProperty.h.

virtual void vtkProperty::BackfaceRender | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [inline, virtual]

This method renders the property as a backface property. TwoSidedLighting must be turned off to see any backface properties. Note that only colors and opacity are used for backface properties. Other properties such as Representation, Culling are specified by the Property.

Reimplemented in vtkMesaProperty, and vtkOpenGLProperty.

Definition at line 86 of file vtkProperty.h.

virtual void vtkProperty::SetInterpolation ( int ) [virtual]

Set the shading interpolation method for an object.

virtual int vtkProperty::GetInterpolation ( ) [virtual]

Set the shading interpolation method for an object.

void vtkProperty::SetInterpolationToFlat ( ) [inline]

Set the shading interpolation method for an object.

Definition at line 92 of file vtkProperty.h.

void vtkProperty::SetInterpolationToGouraud ( ) [inline]

Set the shading interpolation method for an object.

Definition at line 93 of file vtkProperty.h.

void vtkProperty::SetInterpolationToPhong ( ) [inline]

Set the shading interpolation method for an object.

Definition at line 94 of file vtkProperty.h.

char * vtkProperty::GetInterpolationAsString ( void ) [inline]

Return the method of shading as a descriptive character string.

Definition at line 263 of file vtkProperty.h.

virtual void vtkProperty::SetRepresentation ( int ) [virtual]

Control the surface geometry representation for the object.

virtual int vtkProperty::GetRepresentation ( ) [virtual]

Control the surface geometry representation for the object.

void vtkProperty::SetRepresentationToPoints ( ) [inline]

Control the surface geometry representation for the object.

Definition at line 102 of file vtkProperty.h.

void vtkProperty::SetRepresentationToWireframe ( ) [inline]

Control the surface geometry representation for the object.

Definition at line 103 of file vtkProperty.h.

void vtkProperty::SetRepresentationToSurface ( ) [inline]

Control the surface geometry representation for the object.

Definition at line 105 of file vtkProperty.h.

char * vtkProperty::GetRepresentationAsString ( void ) [inline]

Return the method of shading as a descriptive character string.

Definition at line 281 of file vtkProperty.h.

void vtkProperty::SetColor | ( | float | r,
 |  | float | g,
 |  | float | b
 | ) |

Set the color of the object. Has the side effect of setting the ambient diffuse and specular colors as well. This is basically a quick overall color setting method.

void vtkProperty::SetColor ( float a[3] ) [inline]

Set the color of the object. Has the side effect of setting the ambient diffuse and specular colors as well. This is basically a quick overall color setting method.

Definition at line 114 of file vtkProperty.h.

float* vtkProperty::GetColor ( )

Set the color of the object. Has the side effect of setting the ambient diffuse and specular colors as well. This is basically a quick overall color setting method.

void vtkProperty::GetColor ( float rgb[3] )

Set the color of the object. Has the side effect of setting the ambient diffuse and specular colors as well. This is basically a quick overall color setting method.

virtual void vtkProperty::SetAmbient ( float ) [virtual]

Set/Get the ambient lighting coefficient.

virtual float vtkProperty::GetAmbient ( ) [virtual]

Set/Get the ambient lighting coefficient.

virtual void vtkProperty::SetDiffuse ( float ) [virtual]

Set/Get the diffuse lighting coefficient.

virtual float vtkProperty::GetDiffuse ( ) [virtual]

Set/Get the diffuse lighting coefficient.

virtual void vtkProperty::SetSpecular ( float ) [virtual]

Set/Get the specular lighting coefficient.

virtual float vtkProperty::GetSpecular ( ) [virtual]

Set/Get the specular lighting coefficient.

virtual void vtkProperty::SetSpecularPower ( float ) [virtual]

Set/Get the specular power.

virtual float vtkProperty::GetSpecularPower ( ) [virtual]

Set/Get the specular power.

virtual void vtkProperty::SetOpacity ( float ) [virtual]

Set/Get the object's opacity. 1.0 is totally opaque and 0.0 is completely transparent.

virtual float vtkProperty::GetOpacity ( ) [virtual]

Set/Get the object's opacity. 1.0 is totally opaque and 0.0 is completely transparent.

virtual void vtkProperty::SetAmbientColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the ambient surface color. Not all renderers support separate ambient and diffuse colors. From a physical standpoint it really doesn't make too much sense to have both. For the rendering libraries that don't support both, the diffuse color is used.

virtual void vtkProperty::SetAmbientColor ( float [3] ) [virtual]

Set/Get the ambient surface color. Not all renderers support separate ambient and diffuse colors. From a physical standpoint it really doesn't make too much sense to have both. For the rendering libraries that don't support both, the diffuse color is used.

virtual float* vtkProperty::GetAmbientColor ( ) [virtual]

Set/Get the ambient surface color. Not all renderers support separate ambient and diffuse colors. From a physical standpoint it really doesn't make too much sense to have both. For the rendering libraries that don't support both, the diffuse color is used.

virtual void vtkProperty::GetAmbientColor ( float data[3] ) [virtual]

Set/Get the ambient surface color. Not all renderers support separate ambient and diffuse colors. From a physical standpoint it really doesn't make too much sense to have both. For the rendering libraries that don't support both, the diffuse color is used.

virtual void vtkProperty::SetDiffuseColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the diffuse surface color.

virtual void vtkProperty::SetDiffuseColor ( float [3] ) [virtual]

Set/Get the diffuse surface color.

virtual float* vtkProperty::GetDiffuseColor ( ) [virtual]

Set/Get the diffuse surface color.

virtual void vtkProperty::GetDiffuseColor ( float data[3] ) [virtual]

Set/Get the diffuse surface color.

virtual void vtkProperty::SetSpecularColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the specular surface color.

virtual void vtkProperty::SetSpecularColor ( float [3] ) [virtual]

Set/Get the specular surface color.

virtual float* vtkProperty::GetSpecularColor ( ) [virtual]

Set/Get the specular surface color.

virtual void vtkProperty::GetSpecularColor ( float data[3] ) [virtual]

Set/Get the specular surface color.

virtual int vtkProperty::GetEdgeVisibility ( ) [virtual]

Turn on/off the visibility of edges. On some renderers it is possible to render the edges of geometric primitives separately from the interior.

virtual void vtkProperty::SetEdgeVisibility ( int ) [virtual]

Turn on/off the visibility of edges. On some renderers it is possible to render the edges of geometric primitives separately from the interior.

virtual void vtkProperty::EdgeVisibilityOn ( ) [virtual]

Turn on/off the visibility of edges. On some renderers it is possible to render the edges of geometric primitives separately from the interior.

virtual void vtkProperty::EdgeVisibilityOff ( ) [virtual]

Turn on/off the visibility of edges. On some renderers it is possible to render the edges of geometric primitives separately from the interior.

virtual void vtkProperty::SetEdgeColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the color of primitive edges (if edge visibility is enabled).

virtual void vtkProperty::SetEdgeColor ( float [3] ) [virtual]

Set/Get the color of primitive edges (if edge visibility is enabled).

virtual float* vtkProperty::GetEdgeColor ( ) [virtual]

Set/Get the color of primitive edges (if edge visibility is enabled).

virtual void vtkProperty::GetEdgeColor ( float data[3] ) [virtual]

Set/Get the color of primitive edges (if edge visibility is enabled).

virtual void vtkProperty::SetLineWidth ( float ) [virtual]

Set/Get the width of a Line. The width is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual float vtkProperty::GetLineWidth ( ) [virtual]

Set/Get the width of a Line. The width is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual void vtkProperty::SetLineStipplePattern ( int ) [virtual]

Set/Get the stippling pattern of a Line, as a 16-bit binary pattern (1 = pixel on, 0 = pixel off). This is only implemented for OpenGL. The default is 0xFFFF.

virtual int vtkProperty::GetLineStipplePattern ( ) [virtual]

Set/Get the stippling pattern of a Line, as a 16-bit binary pattern (1 = pixel on, 0 = pixel off). This is only implemented for OpenGL. The default is 0xFFFF.

virtual void vtkProperty::SetLineStippleRepeatFactor ( int ) [virtual]

Set/Get the stippling repeat factor of a Line, which specifies how many times each bit in the pattern is to be repeated. This is only implemented for OpenGL. The default is 1.

virtual int vtkProperty::GetLineStippleRepeatFactor ( ) [virtual]

Set/Get the stippling repeat factor of a Line, which specifies how many times each bit in the pattern is to be repeated. This is only implemented for OpenGL. The default is 1.

virtual void vtkProperty::SetPointSize ( float ) [virtual]

Set/Get the diameter of a point. The size is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual float vtkProperty::GetPointSize ( ) [virtual]

Set/Get the diameter of a point. The size is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual int vtkProperty::GetBackfaceCulling ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If backface culling is on, polygons facing away from camera are not drawn.

virtual void vtkProperty::SetBackfaceCulling ( int ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If backface culling is on, polygons facing away from camera are not drawn.

virtual void vtkProperty::BackfaceCullingOn ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If backface culling is on, polygons facing away from camera are not drawn.

virtual void vtkProperty::BackfaceCullingOff ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If backface culling is on, polygons facing away from camera are not drawn.

virtual int vtkProperty::GetFrontfaceCulling ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If frontface culling is on, polygons facing towards camera are not drawn.

virtual void vtkProperty::SetFrontfaceCulling ( int ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If frontface culling is on, polygons facing towards camera are not drawn.

virtual void vtkProperty::FrontfaceCullingOn ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If frontface culling is on, polygons facing towards camera are not drawn.

virtual void vtkProperty::FrontfaceCullingOff ( ) [virtual]

Turn on/off fast culling of polygons based on orientation of normal with respect to camera. If frontface culling is on, polygons facing towards camera are not drawn.

Member Data Documentation

float vtkProperty::Color[3] [protected]

Definition at line 238 of file vtkProperty.h.

float vtkProperty::AmbientColor[3] [protected]

Definition at line 239 of file vtkProperty.h.

float vtkProperty::DiffuseColor[3] [protected]

Definition at line 240 of file vtkProperty.h.

float vtkProperty::SpecularColor[3] [protected]

Definition at line 241 of file vtkProperty.h.

float vtkProperty::EdgeColor[3] [protected]

Definition at line 242 of file vtkProperty.h.

float vtkProperty::Ambient [protected]

Definition at line 243 of file vtkProperty.h.

float vtkProperty::Diffuse [protected]

Definition at line 244 of file vtkProperty.h.

float vtkProperty::Specular [protected]

Definition at line 245 of file vtkProperty.h.

float vtkProperty::SpecularPower [protected]

Definition at line 246 of file vtkProperty.h.

float vtkProperty::Opacity [protected]

Definition at line 247 of file vtkProperty.h.

float vtkProperty::PointSize [protected]

Definition at line 248 of file vtkProperty.h.

float vtkProperty::LineWidth [protected]

Definition at line 249 of file vtkProperty.h.

int vtkProperty::LineStipplePattern [protected]

Definition at line 250 of file vtkProperty.h.

int vtkProperty::LineStippleRepeatFactor [protected]

Definition at line 251 of file vtkProperty.h.

int vtkProperty::Interpolation [protected]

Definition at line 252 of file vtkProperty.h.

int vtkProperty::Representation [protected]

Definition at line 253 of file vtkProperty.h.

int vtkProperty::EdgeVisibility [protected]

Definition at line 254 of file vtkProperty.h.

int vtkProperty::BackfaceCulling [protected]

Definition at line 255 of file vtkProperty.h.

int vtkProperty::FrontfaceCulling [protected]

Definition at line 256 of file vtkProperty.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkProperty.h
Generated on Mon Mar 25 01:28:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProperty2D Class Reference

#include <vtkProperty2D.h>

Inheritance diagram for vtkProperty2D:

[legend]
Collaboration diagram for vtkProperty2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkProperty2D, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | DeepCopy (vtkProperty2D *p)
virtual void | Render (vtkViewport *vtkNotUsed(viewport))
virtual void | SetColor (float, float, float)
virtual void | SetColor (float[3])
virtual float * | GetColor ()
virtual void | GetColor (float data[3])
virtual float | GetOpacity ()
virtual void | SetOpacity (float)
virtual void | SetPointSize (float)
virtual float | GetPointSize ()
virtual void | SetLineWidth (float)
virtual float | GetLineWidth ()
virtual void | SetLineStipplePattern (int)
virtual int | GetLineStipplePattern ()
virtual void | SetLineStippleRepeatFactor (int)
virtual int | GetLineStippleRepeatFactor ()
virtual void | SetDisplayLocation (int)
virtual int | GetDisplayLocation ()
void | SetDisplayLocationToBackground ()
void | SetDisplayLocationToForeground ()

Static Public Methods

vtkProperty2D * | New ()

Protected Methods

vtkProperty2D ()
~vtkProperty2D ()

Protected Attributes

float | Color [3]
float | Opacity
float | PointSize
float | LineWidth
int | LineStipplePattern
int | LineStippleRepeatFactor
int | DisplayLocation

Detailed Description

Date:
2002/01/22 15:26:11
Revision:
1.26

vtkProperty2D contains properties used to render two dimensional images and annotations.

See also:
vtkActor2D
Created by:
  • Turek, Matt
Contributed by (if > 5%):
  • Turek, Matt (58%)
  • Martin, Ken (16%)
  • Avila, Lisa (7%)
  • Miller, Jim (6%)

Definition at line 47 of file vtkProperty2D.h.

Constructor & Destructor Documentation

vtkProperty2D::vtkProperty2D ( ) [protected]

vtkProperty2D::~vtkProperty2D ( ) [protected]

Member Function Documentation

vtkProperty2D::vtkTypeRevisionMacro | ( | vtkProperty2D | ,
 |  | vtkObject |
 | ) |

void vtkProperty2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkProperty2D* vtkProperty2D::New ( ) [static]

Creates a vtkProperty2D with the following default values: Opacity 1, Color (1,1,1)

Reimplemented from vtkObject.

void vtkProperty2D::DeepCopy ( vtkProperty2D * p )

Assign one property to another.

virtual void vtkProperty2D::SetColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the RGB color of this property.

virtual void vtkProperty2D::SetColor ( float [3] ) [virtual]

Set/Get the RGB color of this property.

virtual float* vtkProperty2D::GetColor ( ) [virtual]

Set/Get the RGB color of this property.

virtual void vtkProperty2D::GetColor ( float data[3] ) [virtual]

Set/Get the RGB color of this property.

virtual float vtkProperty2D::GetOpacity ( ) [virtual]

Set/Get the Opacity of this property.

virtual void vtkProperty2D::SetOpacity ( float ) [virtual]

Set/Get the Opacity of this property.

virtual void vtkProperty2D::SetPointSize ( float ) [virtual]

Set/Get the diameter of a Point. The size is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual float vtkProperty2D::GetPointSize ( ) [virtual]

Set/Get the diameter of a Point. The size is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual void vtkProperty2D::SetLineWidth ( float ) [virtual]

Set/Get the width of a Line. The width is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual float vtkProperty2D::GetLineWidth ( ) [virtual]

Set/Get the width of a Line. The width is expressed in screen units. This is only implemented for OpenGL. The default is 1.0.

virtual void vtkProperty2D::SetLineStipplePattern ( int ) [virtual]

Set/Get the stippling pattern of a Line, as a 16-bit binary pattern (1 = pixel on, 0 = pixel off). This is only implemented for OpenGL. The default is 0xFFFF.

virtual int vtkProperty2D::GetLineStipplePattern ( ) [virtual]

Set/Get the stippling pattern of a Line, as a 16-bit binary pattern (1 = pixel on, 0 = pixel off). This is only implemented for OpenGL. The default is 0xFFFF.

virtual void vtkProperty2D::SetLineStippleRepeatFactor ( int ) [virtual]

Set/Get the stippling repeat factor of a Line, which specifies how many times each bit in the pattern is to be repeated. This is only implemented for OpenGL. The default is 1.

virtual int vtkProperty2D::GetLineStippleRepeatFactor ( ) [virtual]

Set/Get the stippling repeat factor of a Line, which specifies how many times each bit in the pattern is to be repeated. This is only implemented for OpenGL. The default is 1.

virtual void vtkProperty2D::SetDisplayLocation ( int ) [virtual]

The DisplayLocation is either background or foreground. If it is background, then this 2D actor will be drawn behind all 3D props or foreground 2D actors. If it is background, then this 2D actor will be drawn in front of all 3D props and background 2D actors. Within 2D actors of the same DisplayLocation type, order is determined by the order in which the 2D actors were added to the viewport.

virtual int vtkProperty2D::GetDisplayLocation ( ) [virtual]

The DisplayLocation is either background or foreground. If it is background, then this 2D actor will be drawn behind all 3D props or foreground 2D actors. If it is background, then this 2D actor will be drawn in front of all 3D props and background 2D actors. Within 2D actors of the same DisplayLocation type, order is determined by the order in which the 2D actors were added to the viewport.

void vtkProperty2D::SetDisplayLocationToBackground ( ) [inline]

The DisplayLocation is either background or foreground. If it is background, then this 2D actor will be drawn behind all 3D props or foreground 2D actors. If it is background, then this 2D actor will be drawn in front of all 3D props and background 2D actors. Within 2D actors of the same DisplayLocation type, order is determined by the order in which the 2D actors were added to the viewport.

Definition at line 112 of file vtkProperty2D.h.

void vtkProperty2D::SetDisplayLocationToForeground ( ) [inline]

The DisplayLocation is either background or foreground. If it is background, then this 2D actor will be drawn behind all 3D props or foreground 2D actors. If it is background, then this 2D actor will be drawn in front of all 3D props and background 2D actors. Within 2D actors of the same DisplayLocation type, order is determined by the order in which the 2D actors were added to the viewport.

Definition at line 114 of file vtkProperty2D.h.

virtual void vtkProperty2D::Render ( vtkViewport *vtkNotUsed(viewport) ) [inline, virtual]

Have the device specific subclass render this property.

Definition at line 120 of file vtkProperty2D.h.

Member Data Documentation

float vtkProperty2D::Color[3] [protected]

Definition at line 126 of file vtkProperty2D.h.

float vtkProperty2D::Opacity [protected]

Definition at line 127 of file vtkProperty2D.h.

float vtkProperty2D::PointSize [protected]

Definition at line 128 of file vtkProperty2D.h.

float vtkProperty2D::LineWidth [protected]

Definition at line 129 of file vtkProperty2D.h.

int vtkProperty2D::LineStipplePattern [protected]

Definition at line 130 of file vtkProperty2D.h.

int vtkProperty2D::LineStippleRepeatFactor [protected]

Definition at line 131 of file vtkProperty2D.h.

int vtkProperty2D::DisplayLocation [protected]

Definition at line 132 of file vtkProperty2D.h.

The documentation for this class was generated from the following file:
  • Common/vtkProperty2D.h
Generated on Mon Mar 25 01:28:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPropPicker Class Reference

pick an actor/prop using graphics hardware. More...

#include <vtkPropPicker.h>

Inheritance diagram for vtkPropPicker:

[legend]
Collaboration diagram for vtkPropPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPropPicker, vtkAbstractPropPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
int | PickProp (float selectionX, float selectionY, vtkRenderer *renderer)
int | PickProp (float selectionX, float selectionY, vtkRenderer *renderer, vtkPropCollection *pickfrom)
int | Pick (float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)
int | Pick (float selectionPt[3], vtkRenderer *renderer)

Static Public Methods

vtkPropPicker * | New ()

Protected Methods

vtkPropPicker ()
~vtkPropPicker ()
void | Initialize ()

Protected Attributes

vtkPropCollection * PickFromProps
vtkWorldPointPicker * WorldPointPicker

Detailed Description

pick an actor/prop using graphics hardware.

Date:
2002/01/22 15:39:10
Revision:
1.19

vtkPropPicker is used to pick an actor/prop given a selection point (in display coordinates) and a renderer. This class uses graphics hardware/rendering system to pick rapidly (as compared to using ray casting as does vtkCellPicker and vtkPointPicker). This class determines the actor/prop and pick position in world coordinates; point and cell ids are not determined.

See also:
vtkPicker vtkWorldPointPicker vtkCellPicker vtkPointPicker
Events:
vtkCommand::EndPickEvent vtkCommand::PickEvent vtkCommand::StartPickEvent
Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (58%)
  • Schroeder, Will (32%)
  • Lorensen, Bill (5%)

Definition at line 52 of file vtkPropPicker.h.

Constructor & Destructor Documentation

vtkPropPicker::vtkPropPicker ( ) [protected]

vtkPropPicker::~vtkPropPicker ( ) [protected]

Member Function Documentation

vtkPropPicker* vtkPropPicker::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkPropPicker::vtkTypeRevisionMacro | ( | vtkPropPicker | ,
 |  | vtkAbstractPropPicker |
 | ) |

Reimplemented from vtkAbstractPropPicker.

void vtkPropPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractPropPicker.

int vtkPropPicker::PickProp | ( | float | selectionX,
 |  | float | selectionY,
 |  | vtkRenderer * | renderer
 | ) |

Perform the pick and set the PickedProp ivar. If something is picked, a 1 is returned, otherwise 0 is returned. Use the GetProp() method to get the instance of vtkProp that was picked. Props are picked from the renderers list of pickable Props.

int vtkPropPicker::PickProp | ( | float | selectionX,
 |  | float | selectionY,
 |  | vtkRenderer * | renderer,
 |  | vtkPropCollection * | pickfrom
 | ) |

Perform a pick from the user-provided list of vtkProps and not from the list of vtkProps that the render maintains.

int vtkPropPicker::Pick | ( | float | selectionX,
 |  | float | selectionY,
 |  | float | selectionZ,
 |  | vtkRenderer * | renderer
 | ) | [virtual]

Overide superclasses' Pick() method.

Reimplemented from vtkAbstractPicker.

int vtkPropPicker::Pick | ( | float | selectionPt[3],
 |  | vtkRenderer * | renderer
 | ) | [inline]

Overide superclasses' Pick() method.

Reimplemented from vtkAbstractPicker.

Definition at line 77 of file vtkPropPicker.h.

void vtkPropPicker::Initialize ( ) [protected, virtual]

Reimplemented from vtkAbstractPropPicker.

Member Data Documentation

vtkPropCollection* vtkPropPicker::PickFromProps [protected]

Definition at line 88 of file vtkPropPicker.h.

vtkWorldPointPicker* vtkPropPicker::WorldPointPicker [protected]

Definition at line 91 of file vtkPropPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkPropPicker.h
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProTriArray Class Reference

#include <vtkDecimatePro.h>

Collaboration diagram for vtkProTriArray:

[legend]
List of all members.

Public Methods

vtkProTriArray (const vtkIdType sz)
~vtkProTriArray ()
vtkIdType GetNumberOfTriangles ()
void | InsertNextTriangle (vtkProLocalTri &t)
vtkProLocalTri & | GetTriangle (vtkIdType i)
void | Reset ()

Public Attributes

vtkProLocalTri * Array
vtkIdType MaxId

Constructor & Destructor Documentation

vtkProTriArray::vtkProTriArray ( const vtkIdType sz ) [inline]

Definition at line 147 of file vtkDecimatePro.h.

vtkProTriArray::~vtkProTriArray ( ) [inline]

Definition at line 149 of file vtkDecimatePro.h.

Member Function Documentation

vtkIdType vtkProTriArray::GetNumberOfTriangles ( ) [inline]

Definition at line 156 of file vtkDecimatePro.h.

void vtkProTriArray::InsertNextTriangle ( vtkProLocalTri & t ) [inline]

Definition at line 157 of file vtkDecimatePro.h.

vtkProLocalTri& vtkProTriArray::GetTriangle ( vtkIdType i ) [inline]

Definition at line 159 of file vtkDecimatePro.h.

void vtkProTriArray::Reset ( ) [inline]

Definition at line 160 of file vtkDecimatePro.h.

Member Data Documentation

vtkProLocalTri* vtkProTriArray::Array

Definition at line 162 of file vtkDecimatePro.h.

vtkIdType vtkProTriArray::MaxId

Definition at line 163 of file vtkDecimatePro.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDecimatePro.h
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkProVertexArray Class Reference

#include <vtkDecimatePro.h>

Collaboration diagram for vtkProVertexArray:

[legend]
List of all members.

Public Methods

vtkProVertexArray (const vtkIdType sz)
~vtkProVertexArray ()
vtkIdType GetNumberOfVertices ()
void | InsertNextVertex (vtkProLocalVertex &v)
vtkProLocalVertex & | GetVertex (vtkIdType i)
void | Reset ()

Public Attributes

vtkProLocalVertex * Array
vtkIdType MaxId

Constructor & Destructor Documentation

vtkProVertexArray::vtkProVertexArray ( const vtkIdType sz ) [inline]

Definition at line 126 of file vtkDecimatePro.h.

vtkProVertexArray::~vtkProVertexArray ( ) [inline]

Definition at line 128 of file vtkDecimatePro.h.

Member Function Documentation

vtkIdType vtkProVertexArray::GetNumberOfVertices ( ) [inline]

Definition at line 135 of file vtkDecimatePro.h.

void vtkProVertexArray::InsertNextVertex ( vtkProLocalVertex & v ) [inline]

Definition at line 136 of file vtkDecimatePro.h.

vtkProLocalVertex& vtkProVertexArray::GetVertex ( vtkIdType i ) [inline]

Definition at line 138 of file vtkDecimatePro.h.

void vtkProVertexArray::Reset ( ) [inline]

Definition at line 139 of file vtkDecimatePro.h.

Member Data Documentation

vtkProLocalVertex* vtkProVertexArray::Array

Definition at line 141 of file vtkDecimatePro.h.

vtkIdType vtkProVertexArray::MaxId

Definition at line 142 of file vtkDecimatePro.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkDecimatePro.h
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPSphereSource Class Reference

sphere source that supports pieces. More...

#include <vtkPSphereSource.h>

Inheritance diagram for vtkPSphereSource:

[legend]
Collaboration diagram for vtkPSphereSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPSphereSource, vtkSphereSource)
unsigned long | GetEstimatedMemorySize ()

Static Public Methods

vtkPSphereSource * | New ()

Protected Methods

vtkPSphereSource ()
~vtkPSphereSource ()
void | Execute ()

Detailed Description

sphere source that supports pieces.

Date:
2002/01/22 15:34:49
Revision:
1.8
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (90%)
  • Henderson, Amy (6%)

Definition at line 35 of file vtkPSphereSource.h.

Constructor & Destructor Documentation

vtkPSphereSource::vtkPSphereSource ( ) [inline, protected]

Definition at line 49 of file vtkPSphereSource.h.

vtkPSphereSource::~vtkPSphereSource ( ) [inline, protected]

Definition at line 50 of file vtkPSphereSource.h.

Member Function Documentation

vtkPSphereSource::vtkTypeRevisionMacro | ( | vtkPSphereSource | ,
 |  | vtkSphereSource |
 | ) |

Reimplemented from vtkSphereSource.

vtkPSphereSource* vtkPSphereSource::New ( ) [static]

Construct sphere with radius=0.5 and default resolution 8 in both Phi and Theta directions. Theta ranges from (0,360) and phi (0,180) degrees.

Reimplemented from vtkSphereSource.

unsigned long vtkPSphereSource::GetEstimatedMemorySize ( )

Get the estimated memory size in 1024 bytes

void vtkPSphereSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSphereSource.

The documentation for this class was generated from the following file:
  • Parallel/vtkPSphereSource.h
Generated on Mon Mar 25 01:28:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPVGeometryFilter Class Reference

Geometry filter that does outlines for volumes. More...

#include <vtkPVGeometryFilter.h>

Inheritance diagram for vtkPVGeometryFilter:

[legend]
Collaboration diagram for vtkPVGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkPVGeometryFilter, vtkDataSetSurfaceFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | GetOutlineFlag ()

Static Public Methods

vtkPVGeometryFilter * | New ()

Protected Methods

vtkPVGeometryFilter ()
~vtkPVGeometryFilter ()
vtkPVGeometryFilter (const vtkPVGeometryFilter &)
void | operator= (const vtkPVGeometryFilter &)
void | Execute ()
void | ImageDataExecute (vtkImageData *input)
void | StructuredGridExecute (vtkStructuredGrid *input)
void | RectilinearGridExecute (vtkRectilinearGrid *input)
void | UnstructuredGridExecute (vtkUnstructuredGrid *input)

Protected Attributes

int | OutlineFlag

Detailed Description

Geometry filter that does outlines for volumes.

Date:
2002/01/22 15:34:51
Revision:
1.5

This filter defaults to using the outline filter unless the input is a structured volume.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Hoffman, Bill (82%)
  • Law, Charles (17%)

Definition at line 42 of file vtkPVGeometryFilter.h.

Constructor & Destructor Documentation

vtkPVGeometryFilter::vtkPVGeometryFilter ( ) [protected]

vtkPVGeometryFilter::~vtkPVGeometryFilter ( ) [protected]

vtkPVGeometryFilter::vtkPVGeometryFilter ( const vtkPVGeometryFilter & ) [inline, protected]

Definition at line 58 of file vtkPVGeometryFilter.h.

Member Function Documentation

vtkPVGeometryFilter* vtkPVGeometryFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSurfaceFilter.

vtkPVGeometryFilter::vtkTypeRevisionMacro | ( | vtkPVGeometryFilter | ,
 |  | vtkDataSetSurfaceFilter |
 | ) |

Reimplemented from vtkDataSetSurfaceFilter.

void vtkPVGeometryFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSetSurfaceFilter.

virtual int vtkPVGeometryFilter::GetOutlineFlag ( ) [virtual]

This flag is set during the execute method. It indicates that the input was 3d and an outline representation was used.

void vtkPVGeometryFilter::operator= ( const vtkPVGeometryFilter & ) [inline, protected]

Definition at line 59 of file vtkPVGeometryFilter.h.

void vtkPVGeometryFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkDataSetSurfaceFilter.

void vtkPVGeometryFilter::ImageDataExecute ( vtkImageData * input ) [protected]

void vtkPVGeometryFilter::StructuredGridExecute ( vtkStructuredGrid * input ) [protected]

void vtkPVGeometryFilter::RectilinearGridExecute ( vtkRectilinearGrid * input ) [protected]

void vtkPVGeometryFilter::UnstructuredGridExecute ( vtkUnstructuredGrid * input ) [protected]

Member Data Documentation

int vtkPVGeometryFilter::OutlineFlag [protected]

Definition at line 67 of file vtkPVGeometryFilter.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkPVGeometryFilter.h
Generated on Mon Mar 25 01:28:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPyramid Class Reference

a 3D cell that represents a pyramid. More...

#include <vtkPyramid.h>

Inheritance diagram for vtkPyramid:

[legend]
Collaboration diagram for vtkPyramid:

[legend]
List of all members.

[NOHEADER]

int | JacobianInverse (float pcoords[3], double **inverse, float derivs[15])
void | InterpolationFunctions (float pcoords[3], float weights[5])
void | InterpolationDerivs (float pcoords[3], float derivs[15])
int * | GetEdgeArray (int edgeId)
int * | GetFaceArray (int faceId)

Public Methods

vtkTypeRevisionMacro (vtkPyramid, vtkCell)
int | GetParametricCenter (float pcoords[3])
virtual void | GetEdgePoints (int edgeId, int *&pts)
virtual void | GetFacePoints (int faceId, int *&pts)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkPyramid * | New ()

Protected Methods

vtkPyramid ()
~vtkPyramid ()

Protected Attributes

vtkLine * Line
vtkTriangle * Triangle
vtkQuad * Quad

Detailed Description

a 3D cell that represents a pyramid.

Date:
2002/01/22 15:26:12
Revision:
1.20

vtkPyramid is a concrete implementation of vtkCell to represent a 3D pyramid. A pyramid consists of a rectangular base with four triangular faces.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Geveci, Berk (8%)
  • Lorensen, Bill (5%)
Examples:
vtkPyramid (Examples)
Tests:
vtkPyramid (Tests)

Definition at line 51 of file vtkPyramid.h.

Constructor & Destructor Documentation

vtkPyramid::vtkPyramid ( ) [protected]

vtkPyramid::~vtkPyramid ( ) [protected]

Member Function Documentation

vtkPyramid::vtkTypeRevisionMacro | ( | vtkPyramid | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell3D.

vtkPyramid* vtkPyramid::New ( ) [static]

Create an instance of this class.

Reimplemented from vtkObject.

virtual void vtkPyramid::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

virtual void vtkPyramid::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

vtkCell* vtkPyramid::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 68 of file vtkPyramid.h.

int vtkPyramid::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell3D.

Definition at line 69 of file vtkPyramid.h.

int vtkPyramid::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 70 of file vtkPyramid.h.

int vtkPyramid::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 71 of file vtkPyramid.h.

vtkCell* vtkPyramid::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkPyramid::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPyramid::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPyramid::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkPyramid::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkPyramid::GetParametricCenter ( float pcoords[3] ) [inline, virtual]

Return the center of the pyramid in parametric coordinates.

Reimplemented from vtkCell.

Definition at line 118 of file vtkPyramid.h.

void vtkPyramid::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[5]
 | ) | [static]

Pyramid specific methods for computing interpolation functions and derivatives.

void vtkPyramid::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[15]
 | ) | [static]

int vtkPyramid::JacobianInverse | ( | float | pcoords[3],
 |  | double ** | inverse,
 |  | float | derivs[15]
 | ) |

int* vtkPyramid::GetEdgeArray ( int edgeId ) [static]

int* vtkPyramid::GetFaceArray ( int faceId ) [static]

Member Data Documentation

vtkLine* vtkPyramid::Line [protected]

Definition at line 109 of file vtkPyramid.h.

vtkTriangle* vtkPyramid::Triangle [protected]

Definition at line 110 of file vtkPyramid.h.

vtkQuad* vtkPyramid::Quad [protected]

Definition at line 111 of file vtkPyramid.h.

The documentation for this class was generated from the following file:
  • Common/vtkPyramid.h
Generated on Mon Mar 25 01:28:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkPythonCommand Class Reference

#include <vtkPythonUtil.h>

Inheritance diagram for vtkPythonCommand:

[legend]
Collaboration diagram for vtkPythonCommand:

[legend]
List of all members.

Public Methods

void | SetObject (PyObject *o)
void | Execute (vtkObject *ptr, unsigned long eventtype, void *)

Static Public Methods

vtkPythonCommand * | New ()

Public Attributes

PyObject * | obj

Protected Methods

vtkPythonCommand ()
~vtkPythonCommand ()

Constructor & Destructor Documentation

vtkPythonCommand::vtkPythonCommand ( ) [protected]

vtkPythonCommand::~vtkPythonCommand ( ) [protected]

Member Function Documentation

vtkPythonCommand* vtkPythonCommand::New ( ) [inline, static]

Definition at line 164 of file vtkPythonUtil.h.

void vtkPythonCommand::SetObject ( PyObject * o )

void vtkPythonCommand::Execute | ( | vtkObject * | ptr,
 |  | unsigned long | eventtype,
 |  | void * | callData
 | ) | [virtual]

Reimplemented from vtkCommand.

Member Data Documentation

PyObject* vtkPythonCommand::obj

Definition at line 169 of file vtkPythonUtil.h.

The documentation for this class was generated from the following file:
  • Common/vtkPythonUtil.h
Generated on Mon Mar 25 01:28:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PyVTKClass Struct Reference

#include <vtkPythonUtil.h>

Collaboration diagram for PyVTKClass:

[legend]
List of all members.

Public Attributes

PyObject_HEAD PyObject * | vtk_bases
PyObject * | vtk_dict
PyObject * | vtk_name
PyObject * | vtk_getattr
PyObject * | vtk_setattr
PyObject * | vtk_delattr
PyObject * | vtk_module
PyObject * | vtk_doc
PyMethodDef * | vtk_methods
vtknewfunc vtk_new

Member Data Documentation

PyObject_HEAD PyObject* PyVTKClass::vtk_bases

Definition at line 38 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_dict

Definition at line 39 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_name

Definition at line 40 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_getattr

Definition at line 41 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_setattr

Definition at line 42 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_delattr

Definition at line 43 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_module

Definition at line 45 of file vtkPythonUtil.h.

PyObject* PyVTKClass::vtk_doc

Definition at line 46 of file vtkPythonUtil.h.

PyMethodDef* PyVTKClass::vtk_methods

Definition at line 47 of file vtkPythonUtil.h.

vtknewfunc PyVTKClass::vtk_new

Definition at line 48 of file vtkPythonUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkPythonUtil.h
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PyVTKObject Struct Reference

#include <vtkPythonUtil.h>

Collaboration diagram for PyVTKObject:

[legend]
List of all members.

Public Attributes

PyObject_HEAD PyVTKClass * | vtk_class
PyObject * | vtk_dict
vtkObject * vtk_ptr

Member Data Documentation

PyObject_HEAD PyVTKClass* PyVTKObject::vtk_class

Definition at line 56 of file vtkPythonUtil.h.

PyObject* PyVTKObject::vtk_dict

Definition at line 57 of file vtkPythonUtil.h.

vtkObject* PyVTKObject::vtk_ptr

Definition at line 59 of file vtkPythonUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkPythonUtil.h
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


PyVTKSpecialObject Struct Reference

#include <vtkPythonUtil.h>

Collaboration diagram for PyVTKSpecialObject:

[legend]
List of all members.

Public Attributes

PyObject_HEAD void * | vtk_ptr
PyMethodDef * | vtk_methods
PyObject * | vtk_name
PyObject * | vtk_doc

Member Data Documentation

PyObject_HEAD void* PyVTKSpecialObject::vtk_ptr

Definition at line 65 of file vtkPythonUtil.h.

PyMethodDef* PyVTKSpecialObject::vtk_methods

Definition at line 66 of file vtkPythonUtil.h.

PyObject* PyVTKSpecialObject::vtk_name

Definition at line 67 of file vtkPythonUtil.h.

PyObject* PyVTKSpecialObject::vtk_doc

Definition at line 68 of file vtkPythonUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkPythonUtil.h
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuad Class Reference

a cell that represents a 2D quadrilateral. More...

#include <vtkQuad.h>

Inheritance diagram for vtkQuad:

[legend]
Collaboration diagram for vtkQuad:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuad, vtkCell)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)

Static Public Methods

vtkQuad * | New ()
void | InterpolationFunctions (float pcoords[3], float sf[4])
void | InterpolationDerivs (float pcoords[3], float derivs[8])

Protected Methods

vtkQuad ()
~vtkQuad ()

Protected Attributes

vtkLine * Line

Detailed Description

a cell that represents a 2D quadrilateral.

Date:
2002/01/22 15:26:14
Revision:
1.60

vtkQuad is a concrete implementation of vtkCell to represent a 2D quadrilateral.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (59%)
  • Miller, Jim (9%)
  • Geveci, Berk (9%)
  • Lorensen, Bill (9%)
  • Martin, Ken (5%)
Examples:
vtkQuad (Examples)
Tests:
vtkQuad (Tests)

Definition at line 48 of file vtkQuad.h.

Constructor & Destructor Documentation

vtkQuad::vtkQuad ( ) [protected]

vtkQuad::~vtkQuad ( ) [protected]

Member Function Documentation

vtkQuad* vtkQuad::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkQuad::vtkTypeRevisionMacro | ( | vtkQuad | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkQuad::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkQuad::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 57 of file vtkQuad.h.

int vtkQuad::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkQuad.h.

int vtkQuad::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkQuad.h.

int vtkQuad::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 60 of file vtkQuad.h.

vtkCell* vtkQuad::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkQuad::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 62 of file vtkQuad.h.

int vtkQuad::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkQuad::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkQuad::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkQuad::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkQuad::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkQuad::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkQuad::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkQuad::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

Clip this quad using scalar value provided. Like contouring, except that it cuts the quad to produce other quads and/or triangles.

Reimplemented from vtkCell.

void vtkQuad::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | sf[4]
 | ) | [static]

vtkQuad specific methods.

void vtkQuad::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[8]
 | ) | [static]

vtkQuad specific methods.

Member Data Documentation

vtkLine* vtkQuad::Line [protected]

Definition at line 102 of file vtkQuad.h.

The documentation for this class was generated from the following file:
  • Common/vtkQuad.h
Generated on Mon Mar 25 01:28:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadraticEdge Class Reference

cell represents a parabolic, isoparametric edge. More...

#include <vtkQuadraticEdge.h>

Inheritance diagram for vtkQuadraticEdge:

[legend]
Collaboration diagram for vtkQuadraticEdge:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuadraticEdge, vtkNonLinearCell)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int)
vtkCell * | GetFace (int)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
virtual void | Tesselate (vtkIdType cellId, vtkDataSet *input, vtkPolyData *output, vtkPointLocator *locator=NULL)
virtual void | Tesselate (vtkIdType vtkNotUsed(cellId), vtkDataSet *vtkNotUsed(input), vtkUnstructuredGrid *vtkNotUsed(output), vtkPointLocator *locator=NULL)

Static Public Methods

vtkQuadraticEdge * | New ()
void | InterpolationFunctions (float pcoords[3], float weights[3])
void | InterpolationDerivs (float pcoords[3], float derivs[3])

Protected Methods

vtkQuadraticEdge ()
~vtkQuadraticEdge ()
void | InternalTesselate ()

Protected Attributes

vtkPolyData * Tesselation
vtkPolyData * InternalDataSet

Detailed Description

cell represents a parabolic, isoparametric edge.

Date:
2002/03/08 21:14:12
Revision:
1.6

vtkQuadraticEdge is a concrete implementation of vtkNonLinearCell to represent a one-dimensional parabolic line. The interpolation is the standard finite element, quadratic isoparametric shape function. The cell includes a mid-edge node. The ordering of the three points defining the cell is point ids (1,2,3) where id #3 is the midedge node.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (85%)
  • Cedilnik, Andy (11%)

Definition at line 43 of file vtkQuadraticEdge.h.

Constructor & Destructor Documentation

vtkQuadraticEdge::vtkQuadraticEdge ( ) [protected]

vtkQuadraticEdge::~vtkQuadraticEdge ( ) [protected]

Member Function Documentation

vtkQuadraticEdge* vtkQuadraticEdge::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkQuadraticEdge::vtkTypeRevisionMacro | ( | vtkQuadraticEdge | ,
 |  | vtkNonLinearCell |
 | ) |

Reimplemented from vtkNonLinearCell.

vtkCell* vtkQuadraticEdge::MakeObject ( ) [virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkQuadraticEdge::GetCellType ( ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 53 of file vtkQuadraticEdge.h.

int vtkQuadraticEdge::GetCellDimension ( ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 54 of file vtkQuadraticEdge.h.

int vtkQuadraticEdge::GetNumberOfEdges ( ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 55 of file vtkQuadraticEdge.h.

int vtkQuadraticEdge::GetNumberOfFaces ( ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 56 of file vtkQuadraticEdge.h.

vtkCell* vtkQuadraticEdge::GetEdge ( int edgeId ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 57 of file vtkQuadraticEdge.h.

vtkCell* vtkQuadraticEdge::GetFace ( int faceId ) [inline, virtual]

Implement the vtkCell API. See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkQuadraticEdge.h.

int vtkQuadraticEdge::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

Given parametric coordinates of a point, return the closest cell boundary, and whether the point is inside or outside of the cell. The cell boundary is defined by a list of points (pts) that specify a face (3D cell), edge (2D cell), or vertex (1D cell). If the return value of the method is != 0, then the point is inside the cell.

Reimplemented from vtkCell.

void vtkQuadraticEdge::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

Generate contouring primitives. The scalar list cellScalars are scalar values at each cell point. The point locator is essentially a points list that merges points as they are inserted (i.e., prevents duplicates). Contouring primitives can be vertices, lines, or polygons. It is possible to interpolate point data along the edge by providing input and output point data - if outPd is NULL, then no interpolation is performed. Also, if the output cell data is non-NULL, the cell data from the contoured cell is passed to the generated contouring primitives. (Note: the CopyAllocate() method must be invoked on both the output cell and point data. The cellId refers to the cell from which the cell data is copied.)

Reimplemented from vtkCell.

int vtkQuadraticEdge::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

Given a point x[3] return inside(=1) or outside(=0) cell; evaluate parametric coordinates, sub-cell id (!=0 only if cell is composite), distance squared of point x[3] to cell (in particular, the sub-cell indicated), closest point on cell to x[3] (unless closestPoint is null, in which case, the closest point and dist2 are not found), and interpolation weights in cell. (The number of weights is equal to the number of points defining the cell). Note: on rare occasions a -1 is returned from the method. This means that numerical error has occurred and all data returned from this method should be ignored. Also, inside/outside is determine parametrically. That is, a point is inside if it satisfies parametric limits. This can cause problems for cells of topological dimension 2 or less, since a point in 3D can project onto the cell within parametric limits but be "far" from the cell. Thus the value dist2 may be checked to determine true in/out.

Reimplemented from vtkCell.

void vtkQuadraticEdge::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

Determine global coordinate (x[3]) from subId and parametric coordinates. Also returns interpolation weights. (The number of weights is equal to the number of points in the cell.)

Reimplemented from vtkCell.

int vtkQuadraticEdge::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

Generate simplices of proper dimension. If cell is 3D, tetrahedron are generated; if 2D triangles; if 1D lines; if 0D points. The form of the output is a sequence of points, each n+1 points (where n is topological cell dimension) defining a simplex. The index is a parameter that controls which triangulation to use (if more than one is possible). If numerical degeneracy encountered, 0 is returned, otherwise 1 is returned.

Reimplemented from vtkCell.

void vtkQuadraticEdge::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

Compute derivatives given cell subId and parametric coordinates. The values array is a series of data value(s) at the cell points. There is a one-to-one correspondence between cell point and data value(s). Dim is the number of data values per cell point. Derivs are derivatives in the x-y-z coordinate directions for each data value. Thus, if computing derivatives for a scalar function in a hexahedron, dim=1, 8 values are supplied, and 3 deriv values are returned (i.e., derivatives in x-y-z directions). On the other hand, if computing derivatives of velocity (vx,vy,vz) dim=3, 24 values are supplied ((vx,vy,vz)1, (vx,vy,vz)2, ....()8), and 9 deriv values are returned ((d(vx)/dx),(d(vx)/dy),(d(vx)/dz), (d(vy)/dx),(d(vy)/dy), (d(vy)/dz), (d(vz)/dx),(d(vz)/dy),(d(vz)/dz)).

Reimplemented from vtkCell.

void vtkQuadraticEdge::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | lines,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

Clip this edge using scalar value provided. Like contouring, except that it cuts the edge to produce linear line segments.

Reimplemented from vtkCell.

int vtkQuadraticEdge::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Line-edge intersection. Intersection has to occur within [0,1] parametric coordinates and with specified tolerance.

Reimplemented from vtkCell.

virtual void vtkQuadraticEdge::Tesselate | ( | vtkIdType | cellId,
 |  | vtkDataSet * | input,
 |  | vtkPolyData * | output,
 |  | vtkPointLocator * | locator = NULL
 | ) | [virtual]

Method required by superclass vtkNonLinearCell. Produces vtkPolyData as a function of the vtkNonLinearCell::Error instance variable. The second Tesselate() method is empty (intended only for 3D cells).

Reimplemented from vtkNonLinearCell.

virtual void vtkQuadraticEdge::Tesselate | ( | vtkIdType vtkNotUsed(cellId) | ,
 |  | vtkDataSet *vtkNotUsed(input) | ,
 |  | vtkUnstructuredGrid *vtkNotUsed(output) | ,
 |  | vtkPointLocator * | locator = NULL
 | ) | [virtual]

Method required by superclass vtkNonLinearCell. Produces vtkPolyData as a function of the vtkNonLinearCell::Error instance variable. The second Tesselate() method is empty (intended only for 3D cells).

void vtkQuadraticEdge::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[3]
 | ) | [static]

Quadratic edge specific methods.

void vtkQuadraticEdge::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[3]
 | ) | [static]

Quadratic edge specific methods.

void vtkQuadraticEdge::InternalTesselate ( ) [protected]

Member Data Documentation

vtkPolyData* vtkQuadraticEdge::Tesselation [protected]

Definition at line 117 of file vtkQuadraticEdge.h.

vtkPolyData* vtkQuadraticEdge::InternalDataSet [protected]

Definition at line 118 of file vtkQuadraticEdge.h.

The documentation for this class was generated from the following file:
  • Common/vtkQuadraticEdge.h
Generated on Mon Mar 25 01:28:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadric Class Reference

evaluate implicit quadric function. More...

#include <vtkQuadric.h>

Inheritance diagram for vtkQuadric:

[legend]
Collaboration diagram for vtkQuadric:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuadric, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float g[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
void | SetCoefficients (float a[10])
void | SetCoefficients (float a0, float a1, float a2, float a3, float a4, float a5, float a6, float a7, float a8, float a9)
virtual float * | GetCoefficients ()
virtual void | GetCoefficients (float data[10])

Static Public Methods

vtkQuadric * | New ()

Protected Methods

vtkQuadric ()
~vtkQuadric ()

Protected Attributes

float | Coefficients [10]

Detailed Description

evaluate implicit quadric function.

Date:
2002/01/22 15:26:15
Revision:
1.7

vtkQuadric evaluates the quadric function F(x,y,z) = a0*x^2 + a1*y^2 + a2*z^2 + a3*x*y + a4*y*z + a5*x*z + a6*x + a7*y + a8*z + a9. vtkQuadric is a concrete implementation of vtkImplicitFunction.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (98%)
Examples:
vtkQuadric (Examples)
Tests:
vtkQuadric (Tests)

Definition at line 44 of file vtkQuadric.h.

Constructor & Destructor Documentation

vtkQuadric::vtkQuadric ( ) [protected]

vtkQuadric::~vtkQuadric ( ) [inline, protected]

Definition at line 73 of file vtkQuadric.h.

Member Function Documentation

vtkQuadric::vtkTypeRevisionMacro | ( | vtkQuadric | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkQuadric::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkQuadric* vtkQuadric::New ( ) [static]

Construct quadric with all coefficients = 1.

Reimplemented from vtkObject.

float vtkQuadric::EvaluateFunction ( float x[3] ) [virtual]

Evaluate quadric equation.

Reimplemented from vtkImplicitFunction.

float vtkQuadric::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate quadric equation.

Reimplemented from vtkImplicitFunction.

Definition at line 56 of file vtkQuadric.h.

void vtkQuadric::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate the gradient to the quadric equation.

Reimplemented from vtkImplicitFunction.

void vtkQuadric::SetCoefficients ( float a[10] )

Set / get the 10 coefficients of the quadric equation.

void vtkQuadric::SetCoefficients | ( | float | a0,
 |  | float | a1,
 |  | float | a2,
 |  | float | a3,
 |  | float | a4,
 |  | float | a5,
 |  | float | a6,
 |  | float | a7,
 |  | float | a8,
 |  | float | a9
 | ) |

Set / get the 10 coefficients of the quadric equation.

virtual float* vtkQuadric::GetCoefficients ( ) [virtual]

Set / get the 10 coefficients of the quadric equation.

virtual void vtkQuadric::GetCoefficients ( float data[10] ) [virtual]

Set / get the 10 coefficients of the quadric equation.

Member Data Documentation

float vtkQuadric::Coefficients[10] [protected]

Definition at line 75 of file vtkQuadric.h.

The documentation for this class was generated from the following file:
  • Common/vtkQuadric.h
Generated on Mon Mar 25 01:28:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadricClustering Class Reference

reduce the number of triangles in a mesh. More...

#include <vtkQuadricClustering.h>

Inheritance diagram for vtkQuadricClustering:

[legend]
Collaboration diagram for vtkQuadricClustering:

[legend]
List of all members.

[NOHEADER]

void | EndAppendUsingPoints (vtkPolyData *input)
int | UseInputPoints

Public Methods

vtkTypeRevisionMacro (vtkQuadricClustering, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetUseFeatureEdges (int)
virtual int | GetUseFeatureEdges ()
virtual void | UseFeatureEdgesOn ()
virtual void | UseFeatureEdgesOff ()
vtkFeatureEdges * GetFeatureEdges ()
virtual void | SetUseFeaturePoints (int)
virtual int | GetUseFeaturePoints ()
virtual void | UseFeaturePointsOn ()
virtual void | UseFeaturePointsOff ()
virtual void | SetFeaturePointsAngle (float)
virtual float | GetFeaturePointsAngle ()
void | SetNumberOfXDivisions (int num)
void | SetNumberOfYDivisions (int num)
void | SetNumberOfZDivisions (int num)
virtual int | GetNumberOfXDivisions ()
virtual int | GetNumberOfYDivisions ()
virtual int | GetNumberOfZDivisions ()
void | SetNumberOfDivisions (int div[3])
int * | GetNumberOfDivisions ()
void | GetNumberOfDivisions (int div[3])
void | SetDivisionOrigin (float x, float y, float z)
void | SetDivisionOrigin (float o[3])
virtual float * | GetDivisionOrigin ()
virtual void | GetDivisionOrigin (float &, float &, float &)
virtual void | GetDivisionOrigin (float[3])
void | SetDivisionSpacing (float x, float y, float z)
void | SetDivisionSpacing (float s[3])
virtual float * | GetDivisionSpacing ()
virtual void | GetDivisionSpacing (float &, float &, float &)
virtual void | GetDivisionSpacing (float[3])
virtual void | SetUseInternalTriangles (int)
virtual int | GetUseInternalTriangles ()
virtual void | UseInternalTrianglesOn ()
virtual void | UseInternalTrianglesOff ()
virtual void | SetUseInputPoints (int)
virtual int | GetUseInputPoints ()
virtual void | UseInputPointsOn ()
virtual void | UseInputPointsOff ()
void | StartAppend (float *bounds)
void | StartAppend (float x0, float x1, float y0, float y1, float z0, float z1)
void | Append (vtkPolyData *piece)
void | EndAppend ()
virtual void | SetCopyCellData (int)
virtual int | GetCopyCellData ()
virtual void | CopyCellDataOn ()
virtual void | CopyCellDataOff ()

Static Public Methods

vtkQuadricClustering * | New ()

Protected Methods

vtkQuadricClustering ()
~vtkQuadricClustering ()
void | Execute ()
vtkIdType | HashPoint (float point[3])
void | InitializeQuadric (float quadric[9])
void | AddQuadric (vtkIdType binId, float quadric[9])
void | FindFeaturePoints (vtkCellArray *edges, vtkPoints *edgePts, float angle)
void | EndAppendVertexGeometry (vtkPolyData *input)
void | AppendFeatureQuadrics (vtkPolyData *pd)
void | ComputeRepresentativePoint (float quadric[9], vtkIdType binId, float point[3])
void | AddTriangles (vtkCellArray *tris, vtkPoints *points, int geometryFlag)
void | AddPolygons (vtkCellArray *polys, vtkPoints *points, int geometryFlag)
void | AddTriangle (vtkIdType *binIds, float *pt0, float *pt1, float *pt2, int geometeryFlag)
void | AddEdges (vtkCellArray *edges, vtkPoints *points, int geometryFlag)
void | AddEdge (vtkIdType *binIds, float *pt0, float *pt1, int geometeryFlag)
void | AddVertices (vtkCellArray *verts, vtkPoints *points, int geometryFlag)
void | AddVertex (vtkIdType binId, float *pt, int geometryFlag)

Protected Attributes

int | UseFeatureEdges
int | UseFeaturePoints
int | UseInternalTriangles
int | NumberOfXDivisions
int | NumberOfYDivisions
int | NumberOfZDivisions
int | ComputeNumberOfDivisions
float | DivisionOrigin [3]
float | DivisionSpacing [3]
float | Bounds [6]
float | XBinSize
float | YBinSize
float | ZBinSize
VTK_POINT_QUADRIC * QuadricArray
vtkIdType NumberOfBinsUsed
vtkCellArray * OutputTriangleArray
vtkCellArray * OutputLines
vtkFeatureEdges * FeatureEdges
vtkPoints * FeaturePoints
float | FeaturePointsAngle
int | CopyCellData
int | InCellCount
int | OutCellCount

Detailed Description

reduce the number of triangles in a mesh.

Date:
2002/01/22 15:29:41
Revision:
1.29

vtkQuadricClustering is a filter to reduce the number of triangles in a triangle mesh, forming a good approximation to the original geometry. The input to vtkQuadricClustering is a vtkPolyData object, and all types of polygonal data are handled.

The algorithm used is the one described by Peter Lindstrom in his Siggraph 2000 paper, "Out-of-Core Simplification of Large Polygonal Models." The general approach of the algorithm is to cluster vertices in a uniform binning of space, accumulating the quadric of each triangle (pushed out to the triangles vertices) within each bin, and then determining an optimal position for a single vertex in a bin by using the accumulated quadric. In more detail, the algorithm first gets the bounds of the input poly data. It then breaks this bounding volume into a user-specified number of spatial bins. It then reads each triangle from the input and hashes its vertices into these bins. (If this is the first time a bin has been visited, initialize its quadric to the 0 matrix.) The algorithm computes the error quadric for this triangle and adds it to the existing quadric of the bin in which each vertex is contained. Then, if 2 or more vertices of the triangle fall in the same bin, the triangle is dicarded. If the triangle is not discarded, it adds the triangle to the list of output triangles as a list of vertex identifiers. (There is one vertex id per bin.) After all the triangles have been read, the representative vertex for each bin is computed (an optimal location is found) using the quadric for that bin. This determines the spatial location of the vertices of each of the triangles in the output.

To use this filter, specify the divisions defining the spatial subdivision in the x, y, and z directions. You must also specify an input vtkPolyData.

This filter can take multiple inputs. To do this, the user must explicity call StartAppend, Append (once for each input), and EndAppend. StartAppend sets up the data structure to hold the quadric matrices. Append processes each triangle in the input poly data it was called on, hashes its vertices to the appropriate bins, determines whether to keep this triangle, and updates the appropriate quadric matrices. EndAppend determines the spatial location of each of the representative vertices for the visited bins.

Warning:
This filter can drastically affect topology, i.e., topology is not preserved.
See also:
vtkDecimatePro vtkDecimate
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Law, Charles (43%)
  • Henderson, Amy (37%)
  • Martin, Ken (9%)
Tests:
vtkQuadricClustering (Tests)

Definition at line 94 of file vtkQuadricClustering.h.

Constructor & Destructor Documentation

vtkQuadricClustering::vtkQuadricClustering ( ) [protected]

Use PolyVerticies will cause all of the points

vtkQuadricClustering::~vtkQuadricClustering ( ) [protected]

Member Function Documentation

vtkQuadricClustering::vtkTypeRevisionMacro | ( | vtkQuadricClustering | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkQuadricClustering::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkQuadricClustering* vtkQuadricClustering::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

virtual void vtkQuadricClustering::SetUseFeatureEdges ( int ) [virtual]

By default, this flag is off. When "UseFeatureEdges" is on, then quadrics are computed for boundary edges/feature edges. They influence the quadrics (position of points), but not the mesh. Which features to use can be controlled by the filter "FeatureEdges".

virtual int vtkQuadricClustering::GetUseFeatureEdges ( ) [virtual]

By default, this flag is off. When "UseFeatureEdges" is on, then quadrics are computed for boundary edges/feature edges. They influence the quadrics (position of points), but not the mesh. Which features to use can be controlled by the filter "FeatureEdges".

virtual void vtkQuadricClustering::UseFeatureEdgesOn ( ) [virtual]

By default, this flag is off. When "UseFeatureEdges" is on, then quadrics are computed for boundary edges/feature edges. They influence the quadrics (position of points), but not the mesh. Which features to use can be controlled by the filter "FeatureEdges".

virtual void vtkQuadricClustering::UseFeatureEdgesOff ( ) [virtual]

By default, this flag is off. When "UseFeatureEdges" is on, then quadrics are computed for boundary edges/feature edges. They influence the quadrics (position of points), but not the mesh. Which features to use can be controlled by the filter "FeatureEdges".

vtkFeatureEdges* vtkQuadricClustering::GetFeatureEdges ( ) [inline]

By default, this flag is off. When "UseFeatureEdges" is on, then quadrics are computed for boundary edges/feature edges. They influence the quadrics (position of points), but not the mesh. Which features to use can be controlled by the filter "FeatureEdges".

Definition at line 109 of file vtkQuadricClustering.h.

virtual void vtkQuadricClustering::SetUseFeaturePoints ( int ) [virtual]

By default, this flag is off. It only has an effect when "UseFeatureEdges" is also on. When "UseFeaturePoints" is on, then quadrics are computed for boundary / feature points used in the boundary / feature edges. They influence the quadrics (position of points), but not the mesh.

virtual int vtkQuadricClustering::GetUseFeaturePoints ( ) [virtual]

By default, this flag is off. It only has an effect when "UseFeatureEdges" is also on. When "UseFeaturePoints" is on, then quadrics are computed for boundary / feature points used in the boundary / feature edges. They influence the quadrics (position of points), but not the mesh.

virtual void vtkQuadricClustering::UseFeaturePointsOn ( ) [virtual]

By default, this flag is off. It only has an effect when "UseFeatureEdges" is also on. When "UseFeaturePoints" is on, then quadrics are computed for boundary / feature points used in the boundary / feature edges. They influence the quadrics (position of points), but not the mesh.

virtual void vtkQuadricClustering::UseFeaturePointsOff ( ) [virtual]

By default, this flag is off. It only has an effect when "UseFeatureEdges" is also on. When "UseFeaturePoints" is on, then quadrics are computed for boundary / feature points used in the boundary / feature edges. They influence the quadrics (position of points), but not the mesh.

virtual void vtkQuadricClustering::SetFeaturePointsAngle ( float ) [virtual]

Set/Get the angle to use in determining whether a point on a boundary / feature edge is a feature point.

virtual float vtkQuadricClustering::GetFeaturePointsAngle ( ) [virtual]

Set/Get the angle to use in determining whether a point on a boundary / feature edge is a feature point.

void vtkQuadricClustering::SetNumberOfXDivisions ( int num )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

void vtkQuadricClustering::SetNumberOfYDivisions ( int num )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

void vtkQuadricClustering::SetNumberOfZDivisions ( int num )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

virtual int vtkQuadricClustering::GetNumberOfXDivisions ( ) [virtual]

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

virtual int vtkQuadricClustering::GetNumberOfYDivisions ( ) [virtual]

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

virtual int vtkQuadricClustering::GetNumberOfZDivisions ( ) [virtual]

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

void vtkQuadricClustering::SetNumberOfDivisions ( int div[3] )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

int* vtkQuadricClustering::GetNumberOfDivisions ( )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

void vtkQuadricClustering::GetNumberOfDivisions ( int div[3] )

Set/Get the number of divisions along each axis for the spatial bins. The number of spatial bins is NumberOfXDivisions*NumberOfYDivisions* NumberOfZDivisions.

void vtkQuadricClustering::SetDivisionOrigin | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

void vtkQuadricClustering::SetDivisionOrigin ( float o[3] ) [inline]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

Definition at line 150 of file vtkQuadricClustering.h.

virtual float* vtkQuadricClustering::GetDivisionOrigin ( ) [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

virtual void vtkQuadricClustering::GetDivisionOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

virtual void vtkQuadricClustering::GetDivisionOrigin ( float [3] ) [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

void vtkQuadricClustering::SetDivisionSpacing | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

void vtkQuadricClustering::SetDivisionSpacing ( float s[3] ) [inline]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

Definition at line 153 of file vtkQuadricClustering.h.

virtual float* vtkQuadricClustering::GetDivisionSpacing ( ) [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

virtual void vtkQuadricClustering::GetDivisionSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

virtual void vtkQuadricClustering::GetDivisionSpacing ( float [3] ) [virtual]

This is an alternative way to set up the bins. If you are trying to match boundaries between pieces, then you should use these methods rather than SetNumberOfDivisions.

virtual void vtkQuadricClustering::SetUseInternalTriangles ( int ) [virtual]

When this flag is on (and it is on by default), then triangles that are completely contained in a bin are added to the bin quadrics. When the the flag is off the filter operates faster, but the surface may not be as well behaved.

virtual int vtkQuadricClustering::GetUseInternalTriangles ( ) [virtual]

When this flag is on (and it is on by default), then triangles that are completely contained in a bin are added to the bin quadrics. When the the flag is off the filter operates faster, but the surface may not be as well behaved.

virtual void vtkQuadricClustering::UseInternalTrianglesOn ( ) [virtual]

When this flag is on (and it is on by default), then triangles that are completely contained in a bin are added to the bin quadrics. When the the flag is off the filter operates faster, but the surface may not be as well behaved.

virtual void vtkQuadricClustering::UseInternalTrianglesOff ( ) [virtual]

When this flag is on (and it is on by default), then triangles that are completely contained in a bin are added to the bin quadrics. When the the flag is off the filter operates faster, but the surface may not be as well behaved.

virtual void vtkQuadricClustering::SetUseInputPoints ( int ) [virtual]

Normally the point that minimizes the quadric error function is used as the output of the bin. When this flag is on, the bin point is forced to be one of the points from the input (the one with the smallest error). This option does not work when the append methods are being called directly.

virtual int vtkQuadricClustering::GetUseInputPoints ( ) [virtual]

Normally the point that minimizes the quadric error function is used as the output of the bin. When this flag is on, the bin point is forced to be one of the points from the input (the one with the smallest error). This option does not work when the append methods are being called directly.

virtual void vtkQuadricClustering::UseInputPointsOn ( ) [virtual]

Normally the point that minimizes the quadric error function is used as the output of the bin. When this flag is on, the bin point is forced to be one of the points from the input (the one with the smallest error). This option does not work when the append methods are being called directly.

virtual void vtkQuadricClustering::UseInputPointsOff ( ) [virtual]

Normally the point that minimizes the quadric error function is used as the output of the bin. When this flag is on, the bin point is forced to be one of the points from the input (the one with the smallest error). This option does not work when the append methods are being called directly.

void vtkQuadricClustering::StartAppend ( float * bounds )

These methods provide an alternative way of executing the filter. PolyData can be added to the result in pieces (append). In this mode, the user must specify the bounds of the entire model as an argument to the "StartAppend" method.

void vtkQuadricClustering::StartAppend | ( | float | x0,
 |  | float | x1,
 |  | float | y0,
 |  | float | y1,
 |  | float | z0,
 |  | float | z1
 | ) | [inline]

These methods provide an alternative way of executing the filter. PolyData can be added to the result in pieces (append). In this mode, the user must specify the bounds of the entire model as an argument to the "StartAppend" method.

Definition at line 184 of file vtkQuadricClustering.h.

void vtkQuadricClustering::Append ( vtkPolyData * piece )

These methods provide an alternative way of executing the filter. PolyData can be added to the result in pieces (append). In this mode, the user must specify the bounds of the entire model as an argument to the "StartAppend" method.

void vtkQuadricClustering::EndAppend ( )

These methods provide an alternative way of executing the filter. PolyData can be added to the result in pieces (append). In this mode, the user must specify the bounds of the entire model as an argument to the "StartAppend" method.

virtual void vtkQuadricClustering::SetCopyCellData ( int ) [virtual]

This flag makes the filter copy cell data from input to output (the best it can). It uses input cells that trigger the addition of output cells (no averaging). This is off by default, and does not work when append is being called explicitely (non pipeline usage).

virtual int vtkQuadricClustering::GetCopyCellData ( ) [virtual]

This flag makes the filter copy cell data from input to output (the best it can). It uses input cells that trigger the addition of output cells (no averaging). This is off by default, and does not work when append is being called explicitely (non pipeline usage).

virtual void vtkQuadricClustering::CopyCellDataOn ( ) [virtual]

This flag makes the filter copy cell data from input to output (the best it can). It uses input cells that trigger the addition of output cells (no averaging). This is off by default, and does not work when append is being called explicitely (non pipeline usage).

virtual void vtkQuadricClustering::CopyCellDataOff ( ) [virtual]

This flag makes the filter copy cell data from input to output (the best it can). It uses input cells that trigger the addition of output cells (no averaging). This is off by default, and does not work when append is being called explicitely (non pipeline usage).

void vtkQuadricClustering::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

vtkIdType vtkQuadricClustering::HashPoint ( float point[3] ) [protected]

Given a point, determine what bin it falls into.

void vtkQuadricClustering::ComputeRepresentativePoint | ( | float | quadric[9],
 |  | vtkIdType | binId,
 |  | float | point[3]
 | ) | [protected]

Determine the representative point for this bin.

void vtkQuadricClustering::AddTriangles | ( | vtkCellArray * | tris,
 |  | vtkPoints * | points,
 |  | int | geometryFlag
 | ) | [protected]

Add triangles to the quadric array. If geometry flag is on then triangles are added to the output.

void vtkQuadricClustering::AddPolygons | ( | vtkCellArray * | polys,
 |  | vtkPoints * | points,
 |  | int | geometryFlag
 | ) | [protected]

Add triangles to the quadric array. If geometry flag is on then triangles are added to the output.

void vtkQuadricClustering::AddTriangle | ( | vtkIdType * | binIds,
 |  | float * | pt0,
 |  | float * | pt1,
 |  | float * | pt2,
 |  | int | geometeryFlag
 | ) | [protected]

Add triangles to the quadric array. If geometry flag is on then triangles are added to the output.

void vtkQuadricClustering::AddEdges | ( | vtkCellArray * | edges,
 |  | vtkPoints * | points,
 |  | int | geometryFlag
 | ) | [protected]

Add edges to the quadric array. If geometry flag is on then edges are added to the output.

void vtkQuadricClustering::AddEdge | ( | vtkIdType * | binIds,
 |  | float * | pt0,
 |  | float * | pt1,
 |  | int | geometeryFlag
 | ) | [protected]

Add edges to the quadric array. If geometry flag is on then edges are added to the output.

void vtkQuadricClustering::AddVertices | ( | vtkCellArray * | verts,
 |  | vtkPoints * | points,
 |  | int | geometryFlag
 | ) | [protected]

Add vertices to the quadric array. If geometry flag is on then vertices are added to the output.

void vtkQuadricClustering::AddVertex | ( | vtkIdType | binId,
 |  | float * | pt,
 |  | int | geometryFlag
 | ) | [protected]

Add vertices to the quadric array. If geometry flag is on then vertices are added to the output.

void vtkQuadricClustering::InitializeQuadric ( float quadric[9] ) [protected]

Initialize the quadric matrix to 0's.

void vtkQuadricClustering::AddQuadric | ( | vtkIdType | binId,
 |  | float | quadric[9]
 | ) | [protected]

Add this quadric to the quadric already associated with this bin.

void vtkQuadricClustering::FindFeaturePoints | ( | vtkCellArray * | edges,
 |  | vtkPoints * | edgePts,
 |  | float | angle
 | ) | [protected]

Find the feature points of a given set of edges. The points returned are (1) those used by only one edge, (2) those used by > 2 edges, and (3) those where the angle between 2 edges using this point is < angle.

void vtkQuadricClustering::EndAppendUsingPoints ( vtkPolyData * input ) [protected]

This method will rep[lace the quadric generated points with the input points with the lowest error.

void vtkQuadricClustering::EndAppendVertexGeometry ( vtkPolyData * input ) [protected]

This method sets the verticies of the output. It duplicates the structure of the input cells (but decimiated).

void vtkQuadricClustering::AppendFeatureQuadrics ( vtkPolyData * pd ) [protected]

Member Data Documentation

int vtkQuadricClustering::UseInputPoints [protected]

This method will rep[lace the quadric generated points with the input points with the lowest error.

Definition at line 260 of file vtkQuadricClustering.h.

int vtkQuadricClustering::UseFeatureEdges [protected]

Definition at line 269 of file vtkQuadricClustering.h.

int vtkQuadricClustering::UseFeaturePoints [protected]

Definition at line 270 of file vtkQuadricClustering.h.

int vtkQuadricClustering::UseInternalTriangles [protected]

Definition at line 271 of file vtkQuadricClustering.h.

int vtkQuadricClustering::NumberOfXDivisions [protected]

Definition at line 273 of file vtkQuadricClustering.h.

int vtkQuadricClustering::NumberOfYDivisions [protected]

Definition at line 274 of file vtkQuadricClustering.h.

int vtkQuadricClustering::NumberOfZDivisions [protected]

Definition at line 275 of file vtkQuadricClustering.h.

int vtkQuadricClustering::ComputeNumberOfDivisions [protected]

Definition at line 280 of file vtkQuadricClustering.h.

float vtkQuadricClustering::DivisionOrigin[3] [protected]

Definition at line 282 of file vtkQuadricClustering.h.

float vtkQuadricClustering::DivisionSpacing[3] [protected]

Definition at line 283 of file vtkQuadricClustering.h.

float vtkQuadricClustering::Bounds[6] [protected]

Definition at line 285 of file vtkQuadricClustering.h.

float vtkQuadricClustering::XBinSize [protected]

Definition at line 286 of file vtkQuadricClustering.h.

float vtkQuadricClustering::YBinSize [protected]

Definition at line 287 of file vtkQuadricClustering.h.

float vtkQuadricClustering::ZBinSize [protected]

Definition at line 288 of file vtkQuadricClustering.h.

VTK_POINT_QUADRIC* vtkQuadricClustering::QuadricArray [protected]

Definition at line 289 of file vtkQuadricClustering.h.

vtkIdType vtkQuadricClustering::NumberOfBinsUsed [protected]

Definition at line 290 of file vtkQuadricClustering.h.

vtkCellArray* vtkQuadricClustering::OutputTriangleArray [protected]

Definition at line 294 of file vtkQuadricClustering.h.

vtkCellArray* vtkQuadricClustering::OutputLines [protected]

Definition at line 295 of file vtkQuadricClustering.h.

vtkFeatureEdges* vtkQuadricClustering::FeatureEdges [protected]

Definition at line 297 of file vtkQuadricClustering.h.

vtkPoints* vtkQuadricClustering::FeaturePoints [protected]

Definition at line 298 of file vtkQuadricClustering.h.

float vtkQuadricClustering::FeaturePointsAngle [protected]

Definition at line 299 of file vtkQuadricClustering.h.

int vtkQuadricClustering::CopyCellData [protected]

Definition at line 301 of file vtkQuadricClustering.h.

int vtkQuadricClustering::InCellCount [protected]

Definition at line 302 of file vtkQuadricClustering.h.

int vtkQuadricClustering::OutCellCount [protected]

Definition at line 303 of file vtkQuadricClustering.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkQuadricClustering.h
Generated on Mon Mar 25 01:29:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuadricDecimation Class Reference

reduce the number of triangles in a mesh. More...

#include <vtkQuadricDecimation.h>

Inheritance diagram for vtkQuadricDecimation:

[legend]
Collaboration diagram for vtkQuadricDecimation:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuadricDecimation, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * GetTestOutput ()
virtual void | SetMaximumCost (float)
virtual float | GetMaximumCost ()
virtual void | SetMaximumCollapsedEdges (int)
virtual int | GetMaximumCollapsedEdges ()

Static Public Methods

vtkQuadricDecimation * | New ()

Protected Methods

vtkQuadricDecimation ()
~vtkQuadricDecimation ()
void | Execute ()
void | ComputeQuadric (vtkIdType pointId)
void | AddQuadric (vtkIdType oldPtId, vtkIdType newPtId)
float | ComputeCost (vtkIdType edgeId, float x[3], vtkPointData *pd)
void | FindAffectedEdges (vtkIdType p1Id, vtkIdType p2Id, vtkIdList *edges)
vtkIdType | GetEdgeCellId (vtkIdType p1Id, vtkIdType p2Id)
void | GetAttributeComponents ()

Protected Attributes

float | MaximumCost
int | MaximumCollapsedEdges
int | NumberOfCollapsedEdges
vtkEdgeTable * Edges
vtkIdList * EndPoint1List
vtkIdList * EndPoint2List
vtkPriorityQueue * EdgeCosts
VTK_ERROR_QUADRIC * ErrorQuadrics
int | AttributeComponents [6]
int | NumberOfComponents
vtkPolyData * Mesh

Detailed Description

reduce the number of triangles in a mesh.

Date:
2002/01/22 15:29:41
Revision:
1.10

vtkQuadricDecimation is a filter to reduce the number of triangles in a triangle mesh, forming a good approximation to the original geometry. The input to vtkQuadricDecimation is a vtkPolyData object, and only triangles are treated. If you desire to decimate polygonal meshes, first triangulate the polygons with vtkTriangleFilter object.

The quadric error metric used is the one outlined in Hughues Hoppe's Vis '99 paper, "New Quadric Metric for Simplifying Meshes with Appearance Attributes."

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (84%)
  • Law, Charles (10%)
Tests:
vtkQuadricDecimation (Tests)

Definition at line 55 of file vtkQuadricDecimation.h.

Constructor & Destructor Documentation

vtkQuadricDecimation::vtkQuadricDecimation ( ) [protected]

vtkQuadricDecimation::~vtkQuadricDecimation ( ) [protected]

Member Function Documentation

vtkQuadricDecimation::vtkTypeRevisionMacro | ( | vtkQuadricDecimation | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkQuadricDecimation::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkQuadricDecimation* vtkQuadricDecimation::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

virtual void vtkQuadricDecimation::SetMaximumCost ( float ) [virtual]

Set/Get the maximum allowable cost of collapsing an edge.

virtual float vtkQuadricDecimation::GetMaximumCost ( ) [virtual]

Set/Get the maximum allowable cost of collapsing an edge.

virtual void vtkQuadricDecimation::SetMaximumCollapsedEdges ( int ) [virtual]

Set/Get the maximum number of edges to collapse.

virtual int vtkQuadricDecimation::GetMaximumCollapsedEdges ( ) [virtual]

Set/Get the maximum number of edges to collapse.

vtkPolyData* vtkQuadricDecimation::GetTestOutput ( ) [inline]

For debugging: the last edge / triangles that were collapsed.

Definition at line 76 of file vtkQuadricDecimation.h.

void vtkQuadricDecimation::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkQuadricDecimation::ComputeQuadric ( vtkIdType pointId ) [protected]

Compute quadric for this vertex.

void vtkQuadricDecimation::AddQuadric | ( | vtkIdType | oldPtId,
 |  | vtkIdType | newPtId
 | ) | [protected]

Add the quadrics for these 2 points since the edge between them has been collapsed.

float vtkQuadricDecimation::ComputeCost | ( | vtkIdType | edgeId,
 |  | float | x[3],
 |  | vtkPointData * | pd
 | ) | [protected]

Compute cost for contracting this edge and the point that gives us this cost.

void vtkQuadricDecimation::FindAffectedEdges | ( | vtkIdType | p1Id,
 |  | vtkIdType | p2Id,
 |  | vtkIdList * | edges
 | ) | [protected]

Find all edges that will have an endpoint change ids because of an edge collapse. p1Id and p2Id are the endpoints of the edge. p2Id is the pointId being removed.

vtkIdType vtkQuadricDecimation::GetEdgeCellId | ( | vtkIdType | p1Id,
 |  | vtkIdType | p2Id
 | ) | [protected]

Find a cell that uses this edge.

void vtkQuadricDecimation::GetAttributeComponents ( ) [protected]

Find out how many components there are for each attribute for this poly data.

Member Data Documentation

float vtkQuadricDecimation::MaximumCost [protected]

Definition at line 107 of file vtkQuadricDecimation.h.

int vtkQuadricDecimation::MaximumCollapsedEdges [protected]

Definition at line 108 of file vtkQuadricDecimation.h.

int vtkQuadricDecimation::NumberOfCollapsedEdges [protected]

Definition at line 109 of file vtkQuadricDecimation.h.

vtkEdgeTable* vtkQuadricDecimation::Edges [protected]

Definition at line 110 of file vtkQuadricDecimation.h.

vtkIdList* vtkQuadricDecimation::EndPoint1List [protected]

Definition at line 111 of file vtkQuadricDecimation.h.

vtkIdList* vtkQuadricDecimation::EndPoint2List [protected]

Definition at line 112 of file vtkQuadricDecimation.h.

vtkPriorityQueue* vtkQuadricDecimation::EdgeCosts [protected]

Definition at line 113 of file vtkQuadricDecimation.h.

VTK_ERROR_QUADRIC* vtkQuadricDecimation::ErrorQuadrics [protected]

Definition at line 114 of file vtkQuadricDecimation.h.

int vtkQuadricDecimation::AttributeComponents[6] [protected]

Definition at line 115 of file vtkQuadricDecimation.h.

int vtkQuadricDecimation::NumberOfComponents [protected]

Definition at line 116 of file vtkQuadricDecimation.h.

vtkPolyData* vtkQuadricDecimation::Mesh [protected]

Definition at line 117 of file vtkQuadricDecimation.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkQuadricDecimation.h
Generated on Mon Mar 25 01:29:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuantizePolyDataPoints Class Reference

quantizes x,y,z coordinates of points. More...

#include <vtkQuantizePolyDataPoints.h>

Inheritance diagram for vtkQuantizePolyDataPoints:

[legend]
Collaboration diagram for vtkQuantizePolyDataPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuantizePolyDataPoints, vtkCleanPolyData)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | OperateOnPoint (float in[3], float out[3])
virtual void | OperateOnBounds (float in[6], float out[6])
virtual void | SetQFactor (float)
virtual float | GetQFactor ()

Static Public Methods

vtkQuantizePolyDataPoints * | New ()

Protected Methods

vtkQuantizePolyDataPoints ()
~vtkQuantizePolyDataPoints ()

Protected Attributes

float | QFactor

Detailed Description

quantizes x,y,z coordinates of points.

Date:
2002/01/22 15:29:42
Revision:
1.12

vtkQuantizePolyDataPoints is a subclass of vtkCleanPolyData and inherits the functionality of vtkCleanPolyData with the addition that it quantizes the point coordinates before inserting into the point list. The user should set QFactor to a positive value (0.25 by default) and all {x,y,z} coordinates will be quantized to that grain size.

A tolerance of zero is expected, though positive values may be used, the quantization will take place before the tolerance is applied.

Warning:
Merging points can alter topology, including introducing non-manifold forms. Handling of degenerate cells is controlled by switches in vtkCleanPolyData.
See also:
vtkCleanPolyData
Created by:
  • Biddiscombe, John
Contributed by (if > 5%):
  • Biddiscombe, John (82%)
  • Schroeder, Will (14%)

Definition at line 52 of file vtkQuantizePolyDataPoints.h.

Constructor & Destructor Documentation

vtkQuantizePolyDataPoints::vtkQuantizePolyDataPoints ( ) [protected]

vtkQuantizePolyDataPoints::~vtkQuantizePolyDataPoints ( ) [inline, protected]

Definition at line 73 of file vtkQuantizePolyDataPoints.h.

Member Function Documentation

vtkQuantizePolyDataPoints* vtkQuantizePolyDataPoints::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkCleanPolyData.

vtkQuantizePolyDataPoints::vtkTypeRevisionMacro | ( | vtkQuantizePolyDataPoints | ,
 |  | vtkCleanPolyData |
 | ) |

Reimplemented from vtkCleanPolyData.

void vtkQuantizePolyDataPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCleanPolyData.

virtual void vtkQuantizePolyDataPoints::SetQFactor ( float ) [virtual]

Specify quantization grain size

virtual float vtkQuantizePolyDataPoints::GetQFactor ( ) [virtual]

Specify quantization grain size

virtual void vtkQuantizePolyDataPoints::OperateOnPoint | ( | float | in[3],
 |  | float | out[3]
 | ) | [virtual]

Perform quantization on a point

Reimplemented from vtkCleanPolyData.

virtual void vtkQuantizePolyDataPoints::OperateOnBounds | ( | float | in[6],
 |  | float | out[6]
 | ) | [virtual]

Perform quantization on bounds

Reimplemented from vtkCleanPolyData.

Member Data Documentation

float vtkQuantizePolyDataPoints::QFactor [protected]

Definition at line 75 of file vtkQuantizePolyDataPoints.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkQuantizePolyDataPoints.h
Generated on Mon Mar 25 01:29:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzGLView Interface Reference

#include <vtkQuartzGLView.h>

Inheritance diagram for vtkQuartzGLView:

[legend]
Collaboration diagram for vtkQuartzGLView:

[legend]
List of all members.

Public Attributes

enum NSOpenGLPixelFormatAttribute
bitsPerPixel 		depthSize
private vtkQuartzRenderWindow * myVTKRenderWindow
vtkQuartzRenderWindowInteractor * myVTKRenderWindowInteractor

Member Data Documentation

enum NSOpenGLPixelFormatAttribute bitsPerPixel vtkQuartzGLView::depthSize

Definition at line 11 of file vtkQuartzGLView.h.

private vtkQuartzRenderWindow* vtkQuartzGLView::myVTKRenderWindow

Definition at line 14 of file vtkQuartzGLView.h.

vtkQuartzRenderWindowInteractor* vtkQuartzGLView::myVTKRenderWindowInteractor

Definition at line 15 of file vtkQuartzGLView.h.

The documentation for this interface was generated from the following file:
  • Rendering/vtkQuartzGLView.h
Generated on Mon Mar 25 01:29:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzImageMapper Class Reference

2D image display support for Quartz windows. More...

#include <vtkQuartzImageMapper.h>

Inheritance diagram for vtkQuartzImageMapper:

[legend]
Collaboration diagram for vtkQuartzImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuartzImageMapper, vtkImageMapper)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)
void | RenderData (vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor)

Static Public Methods

vtkQuartzImageMapper * | New ()

Public Attributes

unsigned char * | DataOut
void * | HBitmap

Protected Methods

vtkQuartzImageMapper ()
~vtkQuartzImageMapper ()

Detailed Description

2D image display support for Quartz windows.

Date:
2002/01/22 15:39:11
Revision:
1.6

vtkQuartzImageMapper is a concrete subclass of vtkImageMapper that renders images under Quartz.

See also:
vtkImageMapper
Created by:
  • Starreveld, Yves
Contributed by (if > 5%):
  • Starreveld, Yves (96%)

Definition at line 43 of file vtkQuartzImageMapper.h.

Constructor & Destructor Documentation

vtkQuartzImageMapper::vtkQuartzImageMapper ( ) [protected]

vtkQuartzImageMapper::~vtkQuartzImageMapper ( ) [protected]

Member Function Documentation

vtkQuartzImageMapper* vtkQuartzImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapper.

vtkQuartzImageMapper::vtkTypeRevisionMacro | ( | vtkQuartzImageMapper | ,
 |  | vtkImageMapper |
 | ) |

Reimplemented from vtkImageMapper.

void vtkQuartzImageMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Handle the render method.

Reimplemented from vtkMapper2D.

Definition at line 51 of file vtkQuartzImageMapper.h.

void vtkQuartzImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Called by the Render function in vtkImageMapper. Actually draws the image to the screen.

Reimplemented from vtkImageMapper.

Member Data Documentation

unsigned char* vtkQuartzImageMapper::DataOut

Definition at line 62 of file vtkQuartzImageMapper.h.

void* vtkQuartzImageMapper::HBitmap

Definition at line 63 of file vtkQuartzImageMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzImageMapper.h
Generated on Mon Mar 25 01:29:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzImageWindow Class Reference

OpenGL Imageing window. More...

#include <vtkQuartzImageWindow.h>

Inheritance diagram for vtkQuartzImageWindow:

[legend]
Collaboration diagram for vtkQuartzImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuartzImageWindow, vtkImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkQuartzImageWindow * | GetOutput ()
virtual void | MakeDefaultWindow ()
void | SwapBuffers ()
void | Frame ()
void | Render ()
virtual void | SetSize (int, int)
virtual int * | GetSize ()
virtual void | SetPosition (int, int)
virtual int * | GetPosition ()
virtual void | SetWindowName (char *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void | SetDisplayId (void *)
virtual void * | GetWindowId ()
virtual void | SetWindowId (void *)
virtual void | SetParentId (void *)
void | SetContextId (void *)
void | SetDeviceContext (void *)
void | MakeCurrent ()
void | Clean ()
virtual void | SetNextWindowId (void *)
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)
virtual void | ReleaseRGBAPixelData (float *data)
void | SetupMemoryRendering (int x, int y, void *prn)
void | ResumeScreenRendering ()
void * | GetMemoryDC ()
unsigned char * | GetMemoryData ()
virtual void | OpenGLInit ()
virtual void | SetupPalette (void *hDC)
virtual void | SetupPixelFormat (void *hDC, int dwFlags, int debug, int bpp=16, int zbpp=16)

Static Public Methods

vtkQuartzImageWindow * | New ()

Protected Methods

vtkQuartzImageWindow ()
~vtkQuartzImageWindow ()

Protected Attributes

void * | ApplicationInstance
void * | Palette
void * | OldPalette
void * | ContextId
void * | DeviceContext
void * | WindowId
void * | ParentId
void * | NextWindowId
int | OwnWindow
int | ScreenSize [2]
void * | MemoryDataHeader
void * | MemoryBuffer
unsigned char * | MemoryData
void * | MemoryHdc
int | ScreenMapped
int | ScreenWindowSize [2]
void * | ScreenDeviceContext
int | ScreenDoubleBuffer
void * | ScreenContextId

Detailed Description

OpenGL Imageing window.

Date:
2002/01/22 15:39:13
Revision:
1.6

vtkQuartzImageWindow is a concrete implementation of the abstract class vtkImageWindow. vtkWin32OpenGLImageer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Starreveld, Yves
Contributed by (if > 5%):
  • Starreveld, Yves (99%)

Definition at line 40 of file vtkQuartzImageWindow.h.

Constructor & Destructor Documentation

vtkQuartzImageWindow::vtkQuartzImageWindow ( ) [protected]

vtkQuartzImageWindow::~vtkQuartzImageWindow ( ) [protected]

Member Function Documentation

vtkQuartzImageWindow* vtkQuartzImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkImageWindow.

vtkQuartzImageWindow::vtkTypeRevisionMacro | ( | vtkQuartzImageWindow | ,
 |  | vtkImageWindow |
 | ) |

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWindow.

vtkQuartzImageWindow* vtkQuartzImageWindow::GetOutput ( ) [inline]

Definition at line 48 of file vtkQuartzImageWindow.h.

virtual void vtkQuartzImageWindow::MakeDefaultWindow ( ) [virtual]

Initialize the window for rendering.

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::SwapBuffers ( ) [virtual]

Swap the front and back buffers if double buffering is being used.

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::Frame ( ) [virtual]

Flush the buffer and swap if necessary

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::Render ( void ) [virtual]

Draw the contents of the window

Reimplemented from vtkImageWindow.

virtual void vtkQuartzImageWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the size of the window.

Reimplemented from vtkImageWindow.

virtual int* vtkQuartzImageWindow::GetSize ( ) [virtual]

Get the current size of the window.

Reimplemented from vtkImageWindow.

virtual void vtkQuartzImageWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the position of the window.

Reimplemented from vtkImageWindow.

virtual int* vtkQuartzImageWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkImageWindow.

virtual void vtkQuartzImageWindow::SetWindowName ( char * name ) [virtual]

Set the name of the window. This appears at the top of the window normally.

Reimplemented from vtkWindow.

virtual void* vtkQuartzImageWindow::GetGenericDisplayId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 79 of file vtkQuartzImageWindow.h.

virtual void* vtkQuartzImageWindow::GetGenericWindowId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 80 of file vtkQuartzImageWindow.h.

virtual void* vtkQuartzImageWindow::GetGenericParentId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 81 of file vtkQuartzImageWindow.h.

virtual void* vtkQuartzImageWindow::GetGenericContext ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 82 of file vtkQuartzImageWindow.h.

virtual void vtkQuartzImageWindow::SetDisplayId ( void * foo ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 83 of file vtkQuartzImageWindow.h.

virtual void* vtkQuartzImageWindow::GetWindowId ( ) [virtual]

Get the window id.

virtual void vtkQuartzImageWindow::SetWindowId ( void * foo ) [virtual]

Set the window id to a pre-existing window.

Reimplemented from vtkImageWindow.

virtual void vtkQuartzImageWindow::SetParentId ( void * foo ) [virtual]

Set the window's parent id to a pre-existing window.

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::SetContextId ( void * )

void vtkQuartzImageWindow::SetDeviceContext ( void * )

virtual void vtkQuartzImageWindow::SetNextWindowId ( void * ) [virtual]

Set the window id of the new window once a WindowRemap is done.

virtual unsigned char* vtkQuartzImageWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkWindow.

virtual void vtkQuartzImageWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

virtual float* vtkQuartzImageWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkQuartzImageWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkQuartzImageWindow::ReleaseRGBAPixelData ( float * data ) [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

void vtkQuartzImageWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkImageWindow.

void vtkQuartzImageWindow::SetupMemoryRendering | ( | int | x,
 |  | int | y,
 |  | void * | prn
 | ) |

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void vtkQuartzImageWindow::ResumeScreenRendering ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void* vtkQuartzImageWindow::GetMemoryDC ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

unsigned char* vtkQuartzImageWindow::GetMemoryData ( ) [inline]

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

Definition at line 127 of file vtkQuartzImageWindow.h.

virtual void vtkQuartzImageWindow::OpenGLInit ( ) [virtual]

Initialize OpenGL for this window.

virtual void vtkQuartzImageWindow::SetupPalette ( void * hDC ) [virtual]

Initialize OpenGL for this window.

virtual void vtkQuartzImageWindow::SetupPixelFormat | ( | void * | hDC,
 |  | int | dwFlags,
 |  | int | debug,
 |  | int | bpp = 16,
 |  | int | zbpp = 16
 | ) | [virtual]

Initialize OpenGL for this window.

void vtkQuartzImageWindow::Clean ( )

Clean up device contexts, rendering contexts, etc.

Member Data Documentation

void* vtkQuartzImageWindow::ApplicationInstance [protected]

Definition at line 145 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::Palette [protected]

Definition at line 146 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::OldPalette [protected]

Definition at line 147 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::ContextId [protected]

Definition at line 148 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::DeviceContext [protected]

Definition at line 149 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::WindowId [protected]

Definition at line 150 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::ParentId [protected]

Definition at line 151 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::NextWindowId [protected]

Definition at line 152 of file vtkQuartzImageWindow.h.

int vtkQuartzImageWindow::OwnWindow [protected]

Definition at line 153 of file vtkQuartzImageWindow.h.

int vtkQuartzImageWindow::ScreenSize[2] [protected]

Definition at line 154 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::MemoryDataHeader [protected]

Definition at line 157 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::MemoryBuffer [protected]

Definition at line 158 of file vtkQuartzImageWindow.h.

unsigned char* vtkQuartzImageWindow::MemoryData [protected]

Definition at line 159 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::MemoryHdc [protected]

Definition at line 160 of file vtkQuartzImageWindow.h.

int vtkQuartzImageWindow::ScreenMapped [protected]

Definition at line 162 of file vtkQuartzImageWindow.h.

int vtkQuartzImageWindow::ScreenWindowSize[2] [protected]

Definition at line 163 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::ScreenDeviceContext [protected]

Definition at line 164 of file vtkQuartzImageWindow.h.

int vtkQuartzImageWindow::ScreenDoubleBuffer [protected]

Definition at line 165 of file vtkQuartzImageWindow.h.

void* vtkQuartzImageWindow::ScreenContextId [protected]

Definition at line 166 of file vtkQuartzImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzImageWindow.h
Generated on Mon Mar 25 01:29:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzRenderWindow Class Reference

OpenGL rendering window. More...

#include <vtkQuartzRenderWindow.h>

Inheritance diagram for vtkQuartzRenderWindow:

[legend]
Collaboration diagram for vtkQuartzRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuartzRenderWindow, vtkRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Start (void)
void | Frame (void)
virtual void | WindowConfigure (void)
virtual void | WindowInitialize (void)
virtual void | Initialize (void)
virtual void | SetFullScreen (int)
virtual void | WindowRemap (void)
virtual void | PrefFullScreen (void)
virtual void | SetSize (int, int)
virtual int * | GetSize ()
virtual void | SetPosition (int, int)
virtual int * | GetScreenSize ()
virtual int * | GetPosition ()
virtual void | SetWindowName (char *)
void | SetWindowInfo (void *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericContext ()
virtual void | SetDisplayId (void *)
virtual void * | GetWindowId ()
virtual void | SetWindowId (void *)
void | SetContextId (void *)
void | SetDeviceContext (void *)
virtual void | SetMultiSamples (int)
virtual int | GetMultiSamples ()
virtual void | StereoUpdate ()
virtual void | SetStereoCapableWindow (int capable)
void | MakeCurrent ()
virtual int | GetEventPending ()
void | Clean ()
void | RegisterTextureResource (GLuint id)
int | GetDepthBufferSize ()
void | UpdateSizeAndPosition (int xPos, int yPos, int xSize, int ySize)
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)
virtual void | ReleaseRGBAPixelData (float *data)
virtual float * | GetZbufferData (int x1, int y1, int x2, int y2)
virtual void | SetZbufferData (int x1, int y1, int x2, int y2, float *buffer)
virtual void | OpenGLInit ()
virtual void | SetupPalette (void *hDC)
virtual void | SetupPixelFormat (void *hDC, void *dwFlags, int debug, int bpp=16, int zbpp=16)
void | HideCursor ()
void | ShowCursor ()

Static Public Methods

vtkQuartzRenderWindow * | New ()

Protected Methods

vtkQuartzRenderWindow ()
~vtkQuartzRenderWindow ()

Protected Attributes

int | ApplicationInitialized
void * | ContextId
void * | DeviceContext
void * | WindowId
void * | WindowController
int | OwnWindow
int | ScreenSize [2]
int | MultiSamples
vtkIdList * TextureResourceIds
int | ScreenMapped
int | ScreenWindowSize [2]
void * | ScreenDeviceContext
int | ScreenDoubleBuffer
void * | ScreenContextId
int | CursorHidden

Detailed Description

OpenGL rendering window.

Date:
2002/01/22 15:39:13
Revision:
1.9

vtkQuartzRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkQuartzRenderer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Starreveld, Yves
Contributed by (if > 5%):
  • Starreveld, Yves (98%)

Definition at line 44 of file vtkQuartzRenderWindow.h.

Constructor & Destructor Documentation

vtkQuartzRenderWindow::vtkQuartzRenderWindow ( ) [protected]

vtkQuartzRenderWindow::~vtkQuartzRenderWindow ( ) [protected]

Member Function Documentation

vtkQuartzRenderWindow* vtkQuartzRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkRenderWindow.

vtkQuartzRenderWindow::vtkTypeRevisionMacro | ( | vtkQuartzRenderWindow | ,
 |  | vtkRenderWindow |
 | ) |

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::Start ( void ) [virtual]

Begin the rendering process.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::Frame ( void ) [virtual]

End the rendering process and display the image.

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::WindowConfigure ( void ) [virtual]

Specify various window parameters.

virtual void vtkQuartzRenderWindow::WindowInitialize ( void ) [virtual]

Initialize the window for rendering.

virtual void vtkQuartzRenderWindow::Initialize ( void ) [virtual]

Initialize the rendering window.

virtual void vtkQuartzRenderWindow::SetFullScreen ( int ) [virtual]

Change the window to fill the entire screen.

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::WindowRemap ( void ) [virtual]

Remap the window.

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::PrefFullScreen ( void ) [virtual]

Set the preferred window size to full screen.

virtual void vtkQuartzRenderWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the size of the window.

Reimplemented from vtkWindow.

virtual int* vtkQuartzRenderWindow::GetSize ( ) [virtual]

Get the current size of the window.

Reimplemented from vtkWindow.

virtual void vtkQuartzRenderWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the position of the window.

Reimplemented from vtkWindow.

virtual int* vtkQuartzRenderWindow::GetScreenSize ( ) [virtual]

Return the scrren size.

virtual int* vtkQuartzRenderWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkWindow.

virtual void vtkQuartzRenderWindow::SetWindowName ( char * name ) [virtual]

Set the name of the window. This appears at the top of the window normally.

Reimplemented from vtkWindow.

void vtkQuartzRenderWindow::SetWindowInfo ( void * )

Set this RenderWindow's window id to a pre-existing window.

virtual void* vtkQuartzRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 98 of file vtkQuartzRenderWindow.h.

virtual void* vtkQuartzRenderWindow::GetGenericWindowId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 99 of file vtkQuartzRenderWindow.h.

virtual void* vtkQuartzRenderWindow::GetGenericContext ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 100 of file vtkQuartzRenderWindow.h.

virtual void vtkQuartzRenderWindow::SetDisplayId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 101 of file vtkQuartzRenderWindow.h.

virtual void* vtkQuartzRenderWindow::GetWindowId ( ) [virtual]

Get the window id.

virtual void vtkQuartzRenderWindow::SetWindowId ( void * foo ) [virtual]

Set the window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::SetContextId ( void * )

void vtkQuartzRenderWindow::SetDeviceContext ( void * )

virtual void vtkQuartzRenderWindow::SetMultiSamples ( int ) [virtual]

virtual int vtkQuartzRenderWindow::GetMultiSamples ( ) [virtual]

virtual void vtkQuartzRenderWindow::StereoUpdate ( ) [virtual]

Update system if needed due to stereo rendering.

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. This method overrrides the superclass method since this class can actually check whether the window has been realized yet.

Reimplemented from vtkRenderWindow.

virtual unsigned char* vtkQuartzRenderWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkWindow.

virtual void vtkQuartzRenderWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkRenderWindow.

virtual float* vtkQuartzRenderWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::ReleaseRGBAPixelData ( float * data ) [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual float* vtkQuartzRenderWindow::GetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::SetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | float * | buffer
 | ) | [virtual]

Set/Get the zbuffer data from an image

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkRenderWindow.

virtual int vtkQuartzRenderWindow::GetEventPending ( ) [virtual]

Check to see if an event is pending for this window. This is a useful check to abort a long render.

Reimplemented from vtkRenderWindow.

virtual void vtkQuartzRenderWindow::OpenGLInit ( ) [virtual]

Initialize OpenGL for this window.

virtual void vtkQuartzRenderWindow::SetupPalette ( void * hDC ) [virtual]

Initialize OpenGL for this window.

virtual void vtkQuartzRenderWindow::SetupPixelFormat | ( | void * | hDC,
 |  | void * | dwFlags,
 |  | int | debug,
 |  | int | bpp = 16,
 |  | int | zbpp = 16
 | ) | [virtual]

Initialize OpenGL for this window.

void vtkQuartzRenderWindow::Clean ( )

Clean up device contexts, rendering contexts, etc.

void vtkQuartzRenderWindow::RegisterTextureResource ( GLuint id )

Register a texture name with this render window

int vtkQuartzRenderWindow::GetDepthBufferSize ( ) [virtual]

Get the size of the depth buffer.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::HideCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::ShowCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkQuartzRenderWindow::UpdateSizeAndPosition | ( | int | xPos,
 |  | int | yPos,
 |  | int | xSize,
 |  | int | ySize
 | ) |

Member Data Documentation

int vtkQuartzRenderWindow::ApplicationInitialized [protected]

Definition at line 191 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::ContextId [protected]

Definition at line 192 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::DeviceContext [protected]

Definition at line 193 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::WindowId [protected]

Definition at line 194 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::WindowController [protected]

Definition at line 195 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::OwnWindow [protected]

Definition at line 196 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::ScreenSize[2] [protected]

Definition at line 197 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::MultiSamples [protected]

Definition at line 198 of file vtkQuartzRenderWindow.h.

vtkIdList* vtkQuartzRenderWindow::TextureResourceIds [protected]

Definition at line 199 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::ScreenMapped [protected]

Definition at line 207 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::ScreenWindowSize[2] [protected]

Definition at line 208 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::ScreenDeviceContext [protected]

Definition at line 209 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::ScreenDoubleBuffer [protected]

Definition at line 210 of file vtkQuartzRenderWindow.h.

void* vtkQuartzRenderWindow::ScreenContextId [protected]

Definition at line 211 of file vtkQuartzRenderWindow.h.

int vtkQuartzRenderWindow::CursorHidden [protected]

Definition at line 213 of file vtkQuartzRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzRenderWindow.h
Generated on Mon Mar 25 01:29:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzRenderWindowInteractor Class Reference

implements Quartz specific functions. More...

#include <vtkQuartzRenderWindowInteractor.h>

Inheritance diagram for vtkQuartzRenderWindowInteractor:

[legend]
Collaboration diagram for vtkQuartzRenderWindowInteractor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuartzRenderWindowInteractor, vtkRenderWindowInteractor)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
virtual void | Start ()
void | TerminateApp (void)
virtual void | ExitCallback ()
int | GetButtonDown ()
void | SetButtonDown (int button)
virtual void | Enable ()
virtual void | Disable ()
virtual void | SetInstallMessageProc (int)
virtual int | GetInstallMessageProc ()
virtual void | InstallMessageProcOn ()
virtual void | InstallMessageProcOff ()
int | CreateTimer (int timertype)
int | DestroyTimer (void)
virtual void | OnRButtonDown (void *wnd, int nFlags, int X, int Y)
virtual void | OnRButtonUp (void *wnd, int nFlags, int X, int Y)
virtual void | OnMButtonDown (void *wnd, int nFlags, int X, int Y)
virtual void | OnMButtonUp (void *wnd, int nFlags, int X, int Y)
virtual void | OnLButtonDown (void *wnd, int nFlags, int X, int Y)
virtual void | OnLButtonUp (void *wnd, int nFlags, int X, int Y)
virtual void | OnSize (void *wnd, int nType, int X, int Y)
virtual void | OnTimer (void *wnd, int nIDEvent)
virtual void | OnChar (void *wnd, int nChar, int nRepCnt, int nFlags)

Static Public Methods

vtkQuartzRenderWindowInteractor * | New ()
void | SetClassExitMethod (void(*f)(void *), void *arg)
void | SetClassExitMethodArgDelete (void(*f)(void *))

Protected Methods

vtkQuartzRenderWindowInteractor ()
~vtkQuartzRenderWindowInteractor ()

Protected Attributes

void * | WindowId
void * | ApplicationId
int | TimerId
void * | OldProc
int | InstallMessageProc
int | whichButtonDown

Static Protected Attributes

void(* | ClassExitMethod )(void *)
void(* | ClassExitMethodArgDelete )(void *)
void * | ClassExitMethodArg

Detailed Description

implements Quartz specific functions.

Date:
2002/01/22 15:39:14
Revision:
1.9
required by vtkRenderWindowInteractor.

By default the interactor installs a MessageProc callback which intercepts windows' messages to the window and controls interactions by routing them to the InteractoStyle classes. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessageProc to false. This provides a minimal "Mapped" mode of interaction

Created by:
  • Starreveld, Yves
Contributed by (if > 5%):
  • Starreveld, Yves (98%)

Definition at line 63 of file vtkQuartzRenderWindowInteractor.h.

Constructor & Destructor Documentation

vtkQuartzRenderWindowInteractor::vtkQuartzRenderWindowInteractor ( ) [protected]

vtkQuartzRenderWindowInteractor::~vtkQuartzRenderWindowInteractor ( ) [protected]

Member Function Documentation

vtkQuartzRenderWindowInteractor* vtkQuartzRenderWindowInteractor::New ( ) [static]

Construct object so that light follows camera motion.

Reimplemented from vtkRenderWindowInteractor.

vtkQuartzRenderWindowInteractor::vtkTypeRevisionMacro | ( | vtkQuartzRenderWindowInteractor | ,
 |  | vtkRenderWindowInteractor |
 | ) |

Reimplemented from vtkRenderWindowInteractor.

void vtkQuartzRenderWindowInteractor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::Initialize ( void ) [virtual]

Initialize the even handler

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::Enable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::Disable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::Start ( void ) [virtual]

This will start up the event loop and never return. If you call this method it will loop processing events until the application is exited.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::SetInstallMessageProc ( int ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual int vtkQuartzRenderWindowInteractor::GetInstallMessageProc ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual void vtkQuartzRenderWindowInteractor::InstallMessageProcOn ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual void vtkQuartzRenderWindowInteractor::InstallMessageProcOff ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

void vtkQuartzRenderWindowInteractor::TerminateApp ( void ) [virtual]

Quartz specific application terminate, calls ClassExitMethod then calls PostQuitMessage(0) to terminate app. An application can Specify ExitMethod for alternative behaviour (i.e. suppresion of keyboard exit)

Reimplemented from vtkRenderWindowInteractor.

int vtkQuartzRenderWindowInteractor::CreateTimer ( int timertype ) [virtual]

Quartz timer methods

Reimplemented from vtkRenderWindowInteractor.

int vtkQuartzRenderWindowInteractor::DestroyTimer ( void ) [virtual]

Quartz timer methods

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkQuartzRenderWindowInteractor::OnRButtonDown | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnRButtonUp | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnMButtonDown | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnMButtonUp | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnLButtonDown | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnLButtonUp | ( | void * | wnd,
 |  | int | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnSize | ( | void * | wnd,
 |  | int | nType,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnTimer | ( | void * | wnd,
 |  | int | nIDEvent
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

virtual void vtkQuartzRenderWindowInteractor::OnChar | ( | void * | wnd,
 |  | int | nChar,
 |  | int | nRepCnt,
 |  | int | nFlags
 | ) | [virtual]

Various methods that a Quartz window can redirect to this class to be handled. virtual void OnMouseMove (void *wnd, int nFlags, int X, int Y);

void vtkQuartzRenderWindowInteractor::SetClassExitMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) | [static]

Methods to set the default exit method for the class. This method is only used if no instance level ExitMethod has been defined. It is provided as a means to control how an interactor is exited given the various language bindings (tcl, Quartz, etc.).

void vtkQuartzRenderWindowInteractor::SetClassExitMethodArgDelete ( void(* f)(void *) ) [static]

Methods to set the default exit method for the class. This method is only used if no instance level ExitMethod has been defined. It is provided as a means to control how an interactor is exited given the various language bindings (tcl, Quartz, etc.).

virtual void vtkQuartzRenderWindowInteractor::ExitCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

Reimplemented from vtkRenderWindowInteractor.

int vtkQuartzRenderWindowInteractor::GetButtonDown ( )

void vtkQuartzRenderWindowInteractor::SetButtonDown ( int button )

Member Data Documentation

void* vtkQuartzRenderWindowInteractor::WindowId [protected]

Definition at line 151 of file vtkQuartzRenderWindowInteractor.h.

void* vtkQuartzRenderWindowInteractor::ApplicationId [protected]

Definition at line 152 of file vtkQuartzRenderWindowInteractor.h.

int vtkQuartzRenderWindowInteractor::TimerId [protected]

Definition at line 153 of file vtkQuartzRenderWindowInteractor.h.

void* vtkQuartzRenderWindowInteractor::OldProc [protected]

Definition at line 154 of file vtkQuartzRenderWindowInteractor.h.

int vtkQuartzRenderWindowInteractor::InstallMessageProc [protected]

Definition at line 155 of file vtkQuartzRenderWindowInteractor.h.

int vtkQuartzRenderWindowInteractor::whichButtonDown [protected]

Definition at line 156 of file vtkQuartzRenderWindowInteractor.h.

void(* vtkQuartzRenderWindowInteractor::ClassExitMethod)(void *) [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Quartz)

void(* vtkQuartzRenderWindowInteractor::ClassExitMethodArgDelete)(void *) [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Quartz)

void* vtkQuartzRenderWindowInteractor::ClassExitMethodArg [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Quartz)

Definition at line 165 of file vtkQuartzRenderWindowInteractor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzRenderWindowInteractor.h
Generated on Mon Mar 25 01:29:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzTextMapper Class Reference

2D Text annotation support for windows. More...

#include <vtkQuartzTextMapper.h>

Inheritance diagram for vtkQuartzTextMapper:

[legend]
Collaboration diagram for vtkQuartzTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkQuartzTextMapper, vtkTextMapper)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)
void | GetSize (vtkViewport *viewport, int size[2])

Static Public Methods

vtkQuartzTextMapper * | New ()

Protected Methods

vtkQuartzTextMapper ()
~vtkQuartzTextMapper ()

Protected Attributes

vtkTimeStamp BuildTime
int | LastSize [2]
void * | Font

Detailed Description

2D Text annotation support for windows.

Date:
2002/01/22 15:39:15
Revision:
1.5

vtkQuartzTextMapper provides 2D text annotation support for vtk under Xwindows. Normally the user should use vtktextMapper which in turn will use this class.

See also:
vtkTextMapper
Created by:
  • Starreveld, Yves
Contributed by (if > 5%):
  • Starreveld, Yves (99%)

Definition at line 41 of file vtkQuartzTextMapper.h.

Constructor & Destructor Documentation

vtkQuartzTextMapper::vtkQuartzTextMapper ( ) [protected]

vtkQuartzTextMapper::~vtkQuartzTextMapper ( ) [protected]

Member Function Documentation

vtkQuartzTextMapper::vtkTypeRevisionMacro | ( | vtkQuartzTextMapper | ,
 |  | vtkTextMapper |
 | ) |

Reimplemented from vtkTextMapper.

vtkQuartzTextMapper* vtkQuartzTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkTextMapper.

void vtkQuartzTextMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkQuartzTextMapper::GetSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [virtual]

What is the size of the rectangle required to draw this mapper ?

Reimplemented from vtkTextMapper.

Member Data Documentation

vtkTimeStamp vtkQuartzTextMapper::BuildTime [protected]

Definition at line 57 of file vtkQuartzTextMapper.h.

int vtkQuartzTextMapper::LastSize[2] [protected]

Definition at line 58 of file vtkQuartzTextMapper.h.

void* vtkQuartzTextMapper::Font [protected]

Definition at line 59 of file vtkQuartzTextMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkQuartzTextMapper.h
Generated on Mon Mar 25 01:29:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkQuartzWindow Interface Reference

#include <vtkQuartzWindow.h>

Inheritance diagram for vtkQuartzWindow:

[legend]
Collaboration diagram for vtkQuartzWindow:

[legend]
List of all members.

Public Attributes

private NSTimer * | MyNSTimer
IBOutlet vtkQuartzGLView * | myvtkQuartzGLView
void * | myVTKRenderWindow
void * | myVTKRenderWindowInteractor

Member Data Documentation

private NSTimer* vtkQuartzWindow::MyNSTimer

Definition at line 8 of file vtkQuartzWindow.h.

IBOutlet vtkQuartzGLView* vtkQuartzWindow::myvtkQuartzGLView

Definition at line 9 of file vtkQuartzWindow.h.

void* vtkQuartzWindow::myVTKRenderWindow

Definition at line 10 of file vtkQuartzWindow.h.

void* vtkQuartzWindow::myVTKRenderWindowInteractor

Definition at line 11 of file vtkQuartzWindow.h.

The documentation for this interface was generated from the following file:
  • Rendering/vtkQuartzWindow.h
Generated on Mon Mar 25 01:29:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRayCaster Class Reference

obsolete class. More...

#include <vtkRayCaster.h>

Inheritance diagram for vtkRayCaster:

[legend]
Collaboration diagram for vtkRayCaster:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRayCaster, vtkObject)
float * | GetPerspectiveViewRays ()
void | GetViewRaysSize (int *vtkNotUsed(size))
float * | GetParallelStartPosition (void)
float * | GetParallelIncrements (void)
void | SetImageScale (int vtkNotUsed(level), float vtkNotUsed(scale))
float | GetImageScale (int vtkNotUsed(level))
int | GetImageScaleCount (void)
void | SetSelectedImageScaleIndex (int vtkNotUsed(level), float vtkNotUsed(scale))
float | GetSelectedImageScaleIndex (int vtkNotUsed(level))
void | SetViewRaysStepSize (int vtkNotUsed(level), float vtkNotUsed(scale))
float | GetViewRaysStepSize (int vtkNotUsed(level))
int | GetAutomaticScaleAdjustment ()
void | AutomaticScaleAdjustmentOn (void)
void | AutomaticScaleAdjustmentOff (void)
void | SetAutomaticScaleLowerLimit (float vtkNotUsed(scale))
float | GetAutomaticScaleLowerLimit ()
void | SetBilinearImageZoom (int vtkNotUsed(val))
int | GetBilinearImageZoom ()
void | BilinearImageZoomOn ()
void | BilinearImageZoomOff ()
float | GetTotalRenderTime ()
void | SetNumberOfThreads (int vtkNotUsed(val))
int | GetNumberOfThreads ()
int | GetNumberOfSamplesTaken ()

Static Public Methods

vtkRayCaster * | New ()

Protected Methods

vtkRayCaster ()
~vtkRayCaster ()

Detailed Description

obsolete class.

Date:
2002/02/07 19:28:53
Revision:
1.36

vtkRayCaster is an obsolete class. All functionality has moved in vtkVolumeRayCastMapper.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (88%)
Tests:
vtkRayCaster (Tests)

Definition at line 42 of file vtkRayCaster.h.

Constructor & Destructor Documentation

vtkRayCaster::vtkRayCaster ( ) [inline, protected]

Definition at line 127 of file vtkRayCaster.h.

vtkRayCaster::~vtkRayCaster ( ) [inline, protected]

Definition at line 128 of file vtkRayCaster.h.

Member Function Documentation

vtkRayCaster* vtkRayCaster::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkRayCaster::vtkTypeRevisionMacro | ( | vtkRayCaster | ,
 |  | vtkObject |
 | ) |

float* vtkRayCaster::GetPerspectiveViewRays ( ) [inline]

Definition at line 50 of file vtkRayCaster.h.

void vtkRayCaster::GetViewRaysSize ( int *vtkNotUsed(size) ) [inline]

Definition at line 53 of file vtkRayCaster.h.

float* vtkRayCaster::GetParallelStartPosition ( void ) [inline]

Definition at line 57 of file vtkRayCaster.h.

float* vtkRayCaster::GetParallelIncrements ( void ) [inline]

Definition at line 60 of file vtkRayCaster.h.

void vtkRayCaster::SetImageScale | ( | int vtkNotUsed(level) | ,
 |  | float vtkNotUsed(scale) |
 | ) | [inline]

Definition at line 64 of file vtkRayCaster.h.

float vtkRayCaster::GetImageScale ( int vtkNotUsed(level) ) [inline]

Definition at line 67 of file vtkRayCaster.h.

int vtkRayCaster::GetImageScaleCount ( void ) [inline]

Definition at line 70 of file vtkRayCaster.h.

void vtkRayCaster::SetSelectedImageScaleIndex | ( | int vtkNotUsed(level) | ,
 |  | float vtkNotUsed(scale) |
 | ) | [inline]

Definition at line 73 of file vtkRayCaster.h.

float vtkRayCaster::GetSelectedImageScaleIndex ( int vtkNotUsed(level) ) [inline]

Definition at line 77 of file vtkRayCaster.h.

void vtkRayCaster::SetViewRaysStepSize | ( | int vtkNotUsed(level) | ,
 |  | float vtkNotUsed(scale) |
 | ) | [inline]

Definition at line 80 of file vtkRayCaster.h.

float vtkRayCaster::GetViewRaysStepSize ( int vtkNotUsed(level) ) [inline]

Definition at line 83 of file vtkRayCaster.h.

int vtkRayCaster::GetAutomaticScaleAdjustment ( ) [inline]

Definition at line 86 of file vtkRayCaster.h.

void vtkRayCaster::AutomaticScaleAdjustmentOn ( void ) [inline]

Definition at line 89 of file vtkRayCaster.h.

void vtkRayCaster::AutomaticScaleAdjustmentOff ( void ) [inline]

Definition at line 92 of file vtkRayCaster.h.

void vtkRayCaster::SetAutomaticScaleLowerLimit ( float vtkNotUsed(scale) ) [inline]

Definition at line 95 of file vtkRayCaster.h.

float vtkRayCaster::GetAutomaticScaleLowerLimit ( ) [inline]

Definition at line 98 of file vtkRayCaster.h.

void vtkRayCaster::SetBilinearImageZoom ( int vtkNotUsed(val) ) [inline]

Definition at line 101 of file vtkRayCaster.h.

int vtkRayCaster::GetBilinearImageZoom ( ) [inline]

Definition at line 104 of file vtkRayCaster.h.

void vtkRayCaster::BilinearImageZoomOn ( ) [inline]

Definition at line 107 of file vtkRayCaster.h.

void vtkRayCaster::BilinearImageZoomOff ( ) [inline]

Definition at line 110 of file vtkRayCaster.h.

float vtkRayCaster::GetTotalRenderTime ( ) [inline]

Definition at line 113 of file vtkRayCaster.h.

void vtkRayCaster::SetNumberOfThreads ( int vtkNotUsed(val) ) [inline]

Definition at line 116 of file vtkRayCaster.h.

int vtkRayCaster::GetNumberOfThreads ( ) [inline]

Definition at line 119 of file vtkRayCaster.h.

int vtkRayCaster::GetNumberOfSamplesTaken ( ) [inline]

Definition at line 122 of file vtkRayCaster.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRayCaster.h
Generated on Mon Mar 25 01:29:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRayCastStructures Class Reference

the structure definitions for ray casting. More...

#include <vtkRayCastStructures.h>

Detailed Description

the structure definitions for ray casting.

Date:
2002/01/22 15:26:15
Revision:
1.7

These are the structures required for ray casting.

See also:
vtkRayCaster
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (96%)

The documentation for this class was generated from the following file:
  • Common/vtkRayCastStructures.h
Generated on Mon Mar 25 01:29:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRearrangeFields Class Reference

Move/copy fields between field data, point data and cell data. More...

#include <vtkRearrangeFields.h>

Inheritance diagram for vtkRearrangeFields:

[legend]
Collaboration diagram for vtkRearrangeFields:

[legend]
List of all members.

Public Types

enum | OperationType { COPY = 0, MOVE = 1 }
enum | FieldLocation { DATA_OBJECT = 0, POINT_DATA = 1, CELL_DATA = 2 }
enum | FieldType { NAME, ATTRIBUTE }

Public Methods

vtkTypeRevisionMacro (vtkRearrangeFields, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
int | AddOperation (int operationType, int attributeType, int fromFieldLoc, int toFieldLoc)
int | AddOperation (int operationType, const char *name, int fromFieldLoc, int toFieldLoc)
int | AddOperation (const char *operationType, const char *attributeType, const char *fromFieldLoc, const char *toFieldLoc)
int | RemoveOperation (int operationId)
int | RemoveOperation (int operationType, int attributeType, int fromFieldLoc, int toFieldLoc)
int | RemoveOperation (int operationType, const char *name, int fromFieldLoc, int toFieldLoc)
int | RemoveOperation (const char *operationType, const char *attributeType, const char *fromFieldLoc, const char *toFieldLoc)
void | RemoveAllOperations ()

Static Public Methods

vtkRearrangeFields * | New ()

Protected Methods

vtkRearrangeFields ()
virtual | ~vtkRearrangeFields ()
void | Execute ()
Operation * | GetNextOperation (Operation *op)
Operation * GetFirst ()
void | AddOperation (Operation *op)
void | DeleteOperation (Operation *op, Operation *before)
Operation * | FindOperation (int id, Operation *&before)
Operation * | FindOperation (const char *name, Operation *&before)
Operation * | FindOperation (int operationType, const char *name, int fromFieldLoc, int toFieldLoc, Operation *&before)
Operation * | FindOperation (int operationType, int attributeType, int fromFieldLoc, int toFieldLoc, Operation *&before)
int | CompareOperationsByType (const Operation *op1, const Operation *op2)
int | CompareOperationsByName (const Operation *op1, const Operation *op2)
void | DeleteAllOperations ()
void | ApplyOperation (Operation *op, vtkDataSet *input, vtkDataSet *output)
vtkFieldData * | GetFieldDataFromLocation (vtkDataSet *ds, int fieldLoc)
void | PrintAllOperations (ostream &os, vtkIndent indent)
void | PrintOperation (Operation *op, ostream &os, vtkIndent indent)

Protected Attributes

Operation * Head
Operation * Tail
int | LastId

Static Protected Attributes

char | OperationTypeNames [2][5]
char | FieldLocationNames [3][12]
char | AttributeNames [vtkDataSetAttributes::NUM_ATTRIBUTES][10]

Detailed Description

Move/copy fields between field data, point data and cell data.

Date:
2002/01/22 15:29:42
Revision:
1.8

vtkRearrangeFields is used to copy/move fields (vtkDataArrays) between data object's field data, point data and cell data. To specify which fields are copied/moved, the user adds operations. There are two types of operations: 1. the type which copies/moves an attribute's data (i.e. the field will be copied but will not be an attribute in the target), 2. the type which copies/moves fields by name. For example:

 rf->AddOperation(vtkRearrangeFields::COPY, "foo",
                  vtkRearrangeFields::DATA_OBJECT,
                  vtkRearrangeFields::POINT_DATA);
adds an operation which copies a field (data array) called foo from the data object's field data to point data. From Tcl, the same operation can be added as follows:
 rf AddOperation COPY foo DATA_OBJECT POINT_DATA
The same can be done using Python and Java bindings by passing strings as arguments.
 Operation types: COPY, MOVE
 AttributeTypes: SCALARS, VECTORS, NORMALS, TCOORDS, TENSORS
 Field data locations: DATA_OBJECT, POINT_DATA, CELL_DATA

Warning:
When using Tcl, Java, Python or Visual Basic bindings, the array name can not be one of the AttributeTypes when calling AddOperation() which takes strings as arguments. The Tcl (Java etc.) command will always assume the string corresponds to an attribute type when the argument is one of the AttributeTypes. In this situation, use the AddOperation() which takes enums.
See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray vtkAssignAttribute vtkSplitField vtkMergeFields
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (97%)
Examples:
vtkRearrangeFields (Examples)
Tests:
vtkRearrangeFields (Tests)

Definition at line 80 of file vtkRearrangeFields.h.

Member Enumeration Documentation

enum vtkRearrangeFields::OperationType

Enumeration values:
COPY
MOVE

Definition at line 90 of file vtkRearrangeFields.h.

enum vtkRearrangeFields::FieldLocation

Enumeration values:
DATA_OBJECT
POINT_DATA
CELL_DATA

Definition at line 95 of file vtkRearrangeFields.h.

enum vtkRearrangeFields::FieldType

Enumeration values:
NAME
ATTRIBUTE

Definition at line 154 of file vtkRearrangeFields.h.

Constructor & Destructor Documentation

vtkRearrangeFields::vtkRearrangeFields ( ) [protected]

virtual vtkRearrangeFields::~vtkRearrangeFields ( ) [protected, virtual]

Member Function Documentation

vtkRearrangeFields::vtkTypeRevisionMacro | ( | vtkRearrangeFields | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkRearrangeFields::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkRearrangeFields* vtkRearrangeFields::New ( ) [static]

Create a new vtkRearrangeFields with an empty operation list.

Reimplemented from vtkDataSetSource.

int vtkRearrangeFields::AddOperation | ( | int | operationType,
 |  | int | attributeType,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc
 | ) |

Add an operation which copies an attribute's field (data array) from one field data to another. Returns an operation id which can later be used to remove the operation.

int vtkRearrangeFields::AddOperation | ( | int | operationType,
 |  | const char * | name,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc
 | ) |

Add an operation which copies an attribute's field (data array) from one field data to another. Returns an operation id which can later be used to remove the operation.

int vtkRearrangeFields::AddOperation | ( | const char * | operationType,
 |  | const char * | attributeType,
 |  | const char * | fromFieldLoc,
 |  | const char * | toFieldLoc
 | ) |

Add an operation which copies an attribute's field (data array) from one field data to another. Returns an operation id which can later be used to remove the operation.

int vtkRearrangeFields::RemoveOperation ( int operationId )

Remove an operation with the given id.

int vtkRearrangeFields::RemoveOperation | ( | int | operationType,
 |  | int | attributeType,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc
 | ) |

Remove an operation with the given id.

int vtkRearrangeFields::RemoveOperation | ( | int | operationType,
 |  | const char * | name,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc
 | ) |

Remove an operation with the given id.

int vtkRearrangeFields::RemoveOperation | ( | const char * | operationType,
 |  | const char * | attributeType,
 |  | const char * | fromFieldLoc,
 |  | const char * | toFieldLoc
 | ) |

Remove an operation with the given id.

void vtkRearrangeFields::RemoveAllOperations ( ) [inline]

Remove all operations.

Definition at line 145 of file vtkRearrangeFields.h.

void vtkRearrangeFields::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Operation* vtkRearrangeFields::GetNextOperation ( Operation * op ) [inline, protected]

Definition at line 191 of file vtkRearrangeFields.h.

Operation* vtkRearrangeFields::GetFirst ( ) [inline, protected]

Definition at line 193 of file vtkRearrangeFields.h.

void vtkRearrangeFields::AddOperation ( Operation * op ) [protected]

void vtkRearrangeFields::DeleteOperation | ( | Operation * | op,
 |  | Operation * | before
 | ) | [protected]

Operation* vtkRearrangeFields::FindOperation | ( | int | id,
 |  | Operation *& | before
 | ) | [protected]

Operation* vtkRearrangeFields::FindOperation | ( | const char * | name,
 |  | Operation *& | before
 | ) | [protected]

Operation* vtkRearrangeFields::FindOperation | ( | int | operationType,
 |  | const char * | name,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc,
 |  | Operation *& | before
 | ) | [protected]

Operation* vtkRearrangeFields::FindOperation | ( | int | operationType,
 |  | int | attributeType,
 |  | int | fromFieldLoc,
 |  | int | toFieldLoc,
 |  | Operation *& | before
 | ) | [protected]

int vtkRearrangeFields::CompareOperationsByType | ( | const Operation * | op1,
 |  | const Operation * | op2
 | ) | [protected]

int vtkRearrangeFields::CompareOperationsByName | ( | const Operation * | op1,
 |  | const Operation * | op2
 | ) | [protected]

void vtkRearrangeFields::DeleteAllOperations ( ) [protected]

void vtkRearrangeFields::ApplyOperation | ( | Operation * | op,
 |  | vtkDataSet * | input,
 |  | vtkDataSet * | output
 | ) | [protected]

vtkFieldData* vtkRearrangeFields::GetFieldDataFromLocation | ( | vtkDataSet * | ds,
 |  | int | fieldLoc
 | ) | [protected]

void vtkRearrangeFields::PrintAllOperations | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 221 of file vtkRearrangeFields.h.

void vtkRearrangeFields::PrintOperation | ( | Operation * | op,
 |  | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 236 of file vtkRearrangeFields.h.

Member Data Documentation

Operation* vtkRearrangeFields::Head [protected]

Definition at line 184 of file vtkRearrangeFields.h.

Operation* vtkRearrangeFields::Tail [protected]

Definition at line 185 of file vtkRearrangeFields.h.

int vtkRearrangeFields::LastId [protected]

Definition at line 188 of file vtkRearrangeFields.h.

char vtkRearrangeFields::OperationTypeNames[2][5] [static, protected]

Definition at line 217 of file vtkRearrangeFields.h.

char vtkRearrangeFields::FieldLocationNames[3][12] [static, protected]

Definition at line 218 of file vtkRearrangeFields.h.

char vtkRearrangeFields::AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10] [static, protected]

Definition at line 219 of file vtkRearrangeFields.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRearrangeFields.h
Generated on Mon Mar 25 01:29:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRearrangeFields::Operation Struct Reference

#include <vtkRearrangeFields.h>

Collaboration diagram for vtkRearrangeFields::Operation:

[legend]
List of all members.

Public Methods

Operation ()
~Operation ()

Public Attributes

int | OperationType
int | FieldType
char * | FieldName
int | AttributeType
int | FromFieldLoc
int | ToFieldLoc
int | Id
Operation * | Next

Constructor & Destructor Documentation

vtkRearrangeFields::Operation::Operation ( ) [inline]

Definition at line 170 of file vtkRearrangeFields.h.

vtkRearrangeFields::Operation::~Operation ( ) [inline]

Definition at line 171 of file vtkRearrangeFields.h.

Member Data Documentation

int vtkRearrangeFields::Operation::OperationType

Definition at line 162 of file vtkRearrangeFields.h.

int vtkRearrangeFields::Operation::FieldType

Definition at line 163 of file vtkRearrangeFields.h.

char* vtkRearrangeFields::Operation::FieldName

Definition at line 164 of file vtkRearrangeFields.h.

int vtkRearrangeFields::Operation::AttributeType

Definition at line 165 of file vtkRearrangeFields.h.

int vtkRearrangeFields::Operation::FromFieldLoc

Definition at line 166 of file vtkRearrangeFields.h.

int vtkRearrangeFields::Operation::ToFieldLoc

Definition at line 167 of file vtkRearrangeFields.h.

int vtkRearrangeFields::Operation::Id

Definition at line 168 of file vtkRearrangeFields.h.

Operation* vtkRearrangeFields::Operation::Next

Definition at line 169 of file vtkRearrangeFields.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkRearrangeFields.h
Generated on Mon Mar 25 01:29:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGrid Class Reference

a datset that is topologically regular with variable spacing in the three coordinate directions. More...

#include <vtkRectilinearGrid.h>

Inheritance diagram for vtkRectilinearGrid:

[legend]
Collaboration diagram for vtkRectilinearGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGrid, vtkDataSet)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkDataObject * MakeObject ()
int | GetDataObjectType ()
void | CopyStructure (vtkDataSet *ds)
void | Initialize ()
int | GetDataDimension ()
int | ComputeStructuredCoordinates (float x[3], int ijk[3], float pcoords[3])
vtkIdType | ComputePointId (int ijk[3])
vtkIdType | ComputeCellId (int ijk[3])
unsigned long | GetActualMemorySize ()
vtkIdType GetNumberOfCells ()
vtkIdType GetNumberOfPoints ()
float * | GetPoint (vtkIdType ptId)
void | GetPoint (vtkIdType id, float x[3])
vtkCell * | GetCell (vtkIdType cellId)
void | GetCell (vtkIdType cellId, vtkGenericCell *cell)
void | GetCellBounds (vtkIdType cellId, float bounds[6])
int | FindPoint (float x, float y, float z)
vtkIdType | FindPoint (float x[3])
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
vtkIdType | FindCell (float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
vtkCell * | FindAndGetCell (float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)
int | GetCellType (vtkIdType cellId)
void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)
void | ComputeBounds ()
int | GetMaxCellSize ()
void | GetCellNeighbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds)
void | SetDimensions (int i, int j, int k)
void | SetDimensions (int dim[3])
virtual int * | GetDimensions ()
virtual void | GetDimensions (int data[3])
virtual void | SetXCoordinates (vtkDataArray *)
virtual vtkDataArray * | GetXCoordinates ()
virtual void | SetYCoordinates (vtkDataArray *)
virtual vtkDataArray * | GetYCoordinates ()
virtual void | SetZCoordinates (vtkDataArray *)
virtual vtkDataArray * | GetZCoordinates ()
void | SetUpdateExtent (int piece, int numPieces, int ghostLevel)
void | SetUpdateExtent (int piece, int numPieces)
void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
void | SetUpdateExtent (int ext[6])
void | SetExtent (int extent[6])
void | SetExtent (int x1, int x2, int y1, int y2, int z1, int z2)
virtual int * | GetExtent ()
virtual void | GetExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetExtent (int[6])
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)

Static Public Methods

vtkRectilinearGrid * | New ()

Protected Methods

vtkRectilinearGrid ()
~vtkRectilinearGrid ()
int | GetExtentType ()
virtual void | Crop ()

Protected Attributes

vtkVertex * Vertex
vtkLine * Line
vtkPixel * Pixel
vtkVoxel * Voxel
int | Dimensions [3]
int | DataDescription
vtkDataArray * XCoordinates
vtkDataArray * YCoordinates
vtkDataArray * ZCoordinates
float | PointReturn [3]

Detailed Description

a datset that is topologically regular with variable spacing in the three coordinate directions.

Date:
2002/01/22 15:26:16
Revision:
1.56

vtkRectilinearGrid is a data object that is a concrete implementation of vtkDataSet. vtkRectilinearGrid represents a geometric structure that is topologically regular with variable spacing in the three coordinate directions x-y-z.

To define a vtkRectilinearGrid, you must specify the dimensions of the data and provide three arrays of values specifying the coordinates along the x-y-z axes. The coordinate arrays are specified using three vtkDataArray objects (one for x, one for y, one for z).

Warning:
Make sure that the dimensions of the grid match the number of coordinates in the x-y-z directions. If not, unpredictable results (including program failure) may result. Also, you must supply coordinates in all three directions, even if the dataset topology is 2D, 1D, or 0D.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (36%)
  • Law, Charles (35%)
  • Miller, Jim (5%)
  • Geveci, Berk (5%)
  • Henderson, Amy (5%)
Examples:
vtkRectilinearGrid (Examples)
Tests:
vtkRectilinearGrid (Tests)

Definition at line 66 of file vtkRectilinearGrid.h.

Constructor & Destructor Documentation

vtkRectilinearGrid::vtkRectilinearGrid ( ) [protected]

vtkRectilinearGrid::~vtkRectilinearGrid ( ) [protected]

Member Function Documentation

vtkRectilinearGrid* vtkRectilinearGrid::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

Referenced by MakeObject().

vtkRectilinearGrid::vtkTypeRevisionMacro | ( | vtkRectilinearGrid | ,
 |  | vtkDataSet |
 | ) |

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataSet.

vtkDataObject* vtkRectilinearGrid::MakeObject ( ) [inline, virtual]

Create a similar type object.

Reimplemented from vtkDataObject.

Definition at line 75 of file vtkRectilinearGrid.h.

int vtkRectilinearGrid::GetDataObjectType ( ) [inline, virtual]

Return what type of dataset this is.

Reimplemented from vtkDataSet.

Definition at line 78 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::CopyStructure ( vtkDataSet * ds ) [virtual]

Copy the geometric and topological structure of an input rectilinear grid object.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::Initialize ( ) [virtual]

Restore object to initial state. Release memory back to system.

Reimplemented from vtkDataSet.

vtkIdType vtkRectilinearGrid::GetNumberOfCells ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 247 of file vtkRectilinearGrid.h.

vtkIdType vtkRectilinearGrid::GetNumberOfPoints ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 267 of file vtkRectilinearGrid.h.

float* vtkRectilinearGrid::GetPoint ( vtkIdType ptId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::GetPoint | ( | vtkIdType | id,
 |  | float | x[3]
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkCell* vtkRectilinearGrid::GetCell ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkRectilinearGrid::FindPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 96 of file vtkRectilinearGrid.h.

vtkIdType vtkRectilinearGrid::FindPoint ( float x[3] ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkRectilinearGrid::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkRectilinearGrid::FindCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkGenericCell * | gencell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkCell* vtkRectilinearGrid::FindAndGetCell | ( | float | x[3],
 |  | vtkCell * | cell,
 |  | vtkIdType | cellId,
 |  | float | tol2,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float * | weights
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkRectilinearGrid::GetCellType ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 107 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 110 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::ComputeBounds ( ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkRectilinearGrid::GetMaxCellSize ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 113 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::GetCellNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::SetDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set dimensions of rectilinear grid dataset. This also sets the extent.

void vtkRectilinearGrid::SetDimensions ( int dim[3] )

Set dimensions of rectilinear grid dataset. This also sets the extent.

virtual int* vtkRectilinearGrid::GetDimensions ( ) [virtual]

Get dimensions of this rectilinear grid dataset.

virtual void vtkRectilinearGrid::GetDimensions ( int data[3] ) [virtual]

Get dimensions of this rectilinear grid dataset.

int vtkRectilinearGrid::GetDataDimension ( ) [inline]

Return the dimensionality of the data.

Definition at line 272 of file vtkRectilinearGrid.h.

int vtkRectilinearGrid::ComputeStructuredCoordinates | ( | float | x[3],
 |  | int | ijk[3],
 |  | float | pcoords[3]
 | ) |

Convenience function computes the structured coordinates for a point x[3]. The cell is specified by the array ijk[3], and the parametric coordinates in the cell are specified with pcoords[3]. The function returns a 0 if the point x is outside of the grid, and a 1 if inside the grid.

vtkIdType vtkRectilinearGrid::ComputePointId ( int ijk[3] ) [inline]

Given a location in structured coordinates (i-j-k), return the point id.

Definition at line 277 of file vtkRectilinearGrid.h.

vtkIdType vtkRectilinearGrid::ComputeCellId ( int ijk[3] ) [inline]

Given a location in structured coordinates (i-j-k), return the cell id.

Definition at line 282 of file vtkRectilinearGrid.h.

virtual void vtkRectilinearGrid::SetXCoordinates ( vtkDataArray * ) [virtual]

Specify the grid coordinates in the x-direction.

virtual vtkDataArray* vtkRectilinearGrid::GetXCoordinates ( ) [virtual]

Specify the grid coordinates in the x-direction.

virtual void vtkRectilinearGrid::SetYCoordinates ( vtkDataArray * ) [virtual]

Specify the grid coordinates in the y-direction.

virtual vtkDataArray* vtkRectilinearGrid::GetYCoordinates ( ) [virtual]

Specify the grid coordinates in the y-direction.

virtual void vtkRectilinearGrid::SetZCoordinates ( vtkDataArray * ) [virtual]

Specify the grid coordinates in the z-direction.

virtual vtkDataArray* vtkRectilinearGrid::GetZCoordinates ( ) [virtual]

Specify the grid coordinates in the z-direction.

void vtkRectilinearGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel
 | ) |

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

void vtkRectilinearGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

Reimplemented from vtkDataObject.

Definition at line 171 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [inline, virtual]

Call superclasses method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 177 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::SetUpdateExtent ( int ext[6] ) [inline, virtual]

Call superclasses method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 179 of file vtkRectilinearGrid.h.

void vtkRectilinearGrid::SetExtent ( int extent[6] )

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

void vtkRectilinearGrid::SetExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) |

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual int* vtkRectilinearGrid::GetExtent ( ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkRectilinearGrid::GetExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkRectilinearGrid::GetExtent ( int [6] ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

unsigned long vtkRectilinearGrid::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

void vtkRectilinearGrid::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkDataSet.

int vtkRectilinearGrid::GetExtentType ( ) [inline, protected, virtual]

Reimplemented from vtkDataObject.

Definition at line 216 of file vtkRectilinearGrid.h.

virtual void vtkRectilinearGrid::Crop ( ) [protected, virtual]

Reallocates and copies to set the Extent to the UpdateExtent. This is used internally when the exact extent is requested, and the source generated more than the update extent.

Reimplemented from vtkDataObject.

Member Data Documentation

vtkVertex* vtkRectilinearGrid::Vertex [protected]

Definition at line 210 of file vtkRectilinearGrid.h.

vtkLine* vtkRectilinearGrid::Line [protected]

Definition at line 211 of file vtkRectilinearGrid.h.

vtkPixel* vtkRectilinearGrid::Pixel [protected]

Definition at line 212 of file vtkRectilinearGrid.h.

vtkVoxel* vtkRectilinearGrid::Voxel [protected]

Definition at line 213 of file vtkRectilinearGrid.h.

int vtkRectilinearGrid::Dimensions[3] [protected]

Definition at line 223 of file vtkRectilinearGrid.h.

int vtkRectilinearGrid::DataDescription [protected]

Definition at line 224 of file vtkRectilinearGrid.h.

vtkDataArray* vtkRectilinearGrid::XCoordinates [protected]

Definition at line 226 of file vtkRectilinearGrid.h.

vtkDataArray* vtkRectilinearGrid::YCoordinates [protected]

Definition at line 227 of file vtkRectilinearGrid.h.

vtkDataArray* vtkRectilinearGrid::ZCoordinates [protected]

Definition at line 228 of file vtkRectilinearGrid.h.

float vtkRectilinearGrid::PointReturn[3] [protected]

Definition at line 231 of file vtkRectilinearGrid.h.

The documentation for this class was generated from the following file:
  • Common/vtkRectilinearGrid.h
Generated on Mon Mar 25 01:29:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridGeometryFilter Class Reference

extract geometry for a rectilinear grid. More...

#include <vtkRectilinearGridGeometryFilter.h>

Inheritance diagram for vtkRectilinearGridGeometryFilter:

[legend]
Collaboration diagram for vtkRectilinearGridGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridGeometryFilter, vtkRectilinearGridToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetExtent (int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
void | SetExtent (int extent[6])
virtual int * | GetExtent ()
virtual void | GetExtent (int data[6])

Static Public Methods

vtkRectilinearGridGeometryFilter * | New ()

Protected Methods

vtkRectilinearGridGeometryFilter ()
~vtkRectilinearGridGeometryFilter ()
void | Execute ()

Protected Attributes

int | Extent [6]

Detailed Description

extract geometry for a rectilinear grid.

Date:
2002/01/22 15:29:42
Revision:
1.22

vtkRectilinearGridGeometryFilter is a filter that extracts geometry from a rectilinear grid. By specifying appropriate i-j-k indices, it is possible to extract a point, a curve, a surface, or a "volume". The volume is actually a (n x m x o) region of points.

The extent specification is zero-offset. That is, the first k-plane in a 50x50x50 rectilinear grid is given by (0,49, 0,49, 0,0).

Warning:
If you don't know the dimensions of the input dataset, you can use a large number to specify extent (the number will be clamped appropriately). For example, if the dataset dimensions are 50x50x50, and you want a the fifth k-plane, you can use the extents (0,100, 0,100, 4,4). The 100 will automatically be clamped to 49.
See also:
vtkGeometryFilter vtkExtractGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (64%)
  • Lorensen, Bill (20%)
Examples:
vtkRectilinearGridGeometryFilter (Examples)
Tests:
vtkRectilinearGridGeometryFilter (Tests)

Definition at line 59 of file vtkRectilinearGridGeometryFilter.h.

Constructor & Destructor Documentation

vtkRectilinearGridGeometryFilter::vtkRectilinearGridGeometryFilter ( ) [protected]

vtkRectilinearGridGeometryFilter::~vtkRectilinearGridGeometryFilter ( ) [inline, protected]

Definition at line 82 of file vtkRectilinearGridGeometryFilter.h.

Member Function Documentation

vtkRectilinearGridGeometryFilter::vtkTypeRevisionMacro | ( | vtkRectilinearGridGeometryFilter | ,
 |  | vtkRectilinearGridToPolyDataFilter |
 | ) |

Reimplemented from vtkRectilinearGridToPolyDataFilter.

void vtkRectilinearGridGeometryFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkRectilinearGridGeometryFilter* vtkRectilinearGridGeometryFilter::New ( ) [static]

Construct with initial extent (0,100, 0,100, 0,0) (i.e., a k-plane).

Reimplemented from vtkPolyDataSource.

virtual int* vtkRectilinearGridGeometryFilter::GetExtent ( ) [virtual]

Get the extent in topological coordinate range (imin,imax, jmin,jmax, kmin,kmax).

virtual void vtkRectilinearGridGeometryFilter::GetExtent ( int data[6] ) [virtual]

Get the extent in topological coordinate range (imin,imax, jmin,jmax, kmin,kmax).

void vtkRectilinearGridGeometryFilter::SetExtent | ( | int | iMin,
 |  | int | iMax,
 |  | int | jMin,
 |  | int | jMax,
 |  | int | kMin,
 |  | int | kMax
 | ) |

Specify (imin,imax, jmin,jmax, kmin,kmax) indices.

void vtkRectilinearGridGeometryFilter::SetExtent ( int extent[6] )

Specify (imin,imax, jmin,jmax, kmin,kmax) indices in array form.

void vtkRectilinearGridGeometryFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkRectilinearGridGeometryFilter::Extent[6] [protected]

Definition at line 85 of file vtkRectilinearGridGeometryFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRectilinearGridGeometryFilter.h
Generated on Mon Mar 25 01:29:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridOutlineFilter Class Reference

create wireframe outline for a rectilinear grid. More...

#include <vtkRectilinearGridOutlineFilter.h>

Inheritance diagram for vtkRectilinearGridOutlineFilter:

[legend]
Collaboration diagram for vtkRectilinearGridOutlineFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridOutlineFilter, vtkRectilinearGridToPolyDataFilter)

Static Public Methods

vtkRectilinearGridOutlineFilter * | New ()

Protected Methods

vtkRectilinearGridOutlineFilter ()
~vtkRectilinearGridOutlineFilter ()
void | Execute ()
void | ExecuteInformation ()

Detailed Description

create wireframe outline for a rectilinear grid.

Date:
2002/03/12 18:20:17
Revision:
1.1

vtkRectilinearGridOutlineFilter works in parallel. There is no reason. to use this filter if you are not breaking the processing into pieces. With one piece you can simply use vtkOutlineFilter. This filter ignores internal edges when the extent is not the whole extent.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (100%)
Tests:
vtkRectilinearGridOutlineFilter (Tests)

Definition at line 42 of file vtkRectilinearGridOutlineFilter.h.

Constructor & Destructor Documentation

vtkRectilinearGridOutlineFilter::vtkRectilinearGridOutlineFilter ( ) [inline, protected]

Definition at line 49 of file vtkRectilinearGridOutlineFilter.h.

vtkRectilinearGridOutlineFilter::~vtkRectilinearGridOutlineFilter ( ) [inline, protected]

Definition at line 50 of file vtkRectilinearGridOutlineFilter.h.

Member Function Documentation

vtkRectilinearGridOutlineFilter* vtkRectilinearGridOutlineFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkRectilinearGridOutlineFilter::vtkTypeRevisionMacro | ( | vtkRectilinearGridOutlineFilter | ,
 |  | vtkRectilinearGridToPolyDataFilter |
 | ) |

Reimplemented from vtkRectilinearGridToPolyDataFilter.

void vtkRectilinearGridOutlineFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkRectilinearGridOutlineFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Parallel/vtkRectilinearGridOutlineFilter.h
Generated on Mon Mar 25 01:29:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridReader Class Reference

read vtk rectilinear grid data file. More...

#include <vtkRectilinearGridReader.h>

Inheritance diagram for vtkRectilinearGridReader:

[legend]
Collaboration diagram for vtkRectilinearGridReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkRectilinearGrid * GetOutput ()
vtkRectilinearGrid * | GetOutput (int idx)
void | SetOutput (vtkRectilinearGrid *output)

Static Public Methods

vtkRectilinearGridReader * | New ()

Protected Methods

vtkRectilinearGridReader ()
~vtkRectilinearGridReader ()
void | Execute ()
void | ExecuteInformation ()

Detailed Description

read vtk rectilinear grid data file.

Date:
2002/01/22 15:38:20
Revision:
1.30

vtkRectilinearGridReader is a source object that reads ASCII or binary rectilinear grid data files in vtk format (see text for format details). The output of this reader is a single vtkRectilinearGrid data object. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkRectilinearGrid vtkDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Law, Charles (10%)
  • Lorensen, Bill (6%)
  • Kelly, Ann (5%)
  • Martin, Ken (5%)
Tests:
vtkRectilinearGridReader (Tests)

Definition at line 53 of file vtkRectilinearGridReader.h.

Constructor & Destructor Documentation

vtkRectilinearGridReader::vtkRectilinearGridReader ( ) [protected]

vtkRectilinearGridReader::~vtkRectilinearGridReader ( ) [protected]

Member Function Documentation

vtkRectilinearGridReader* vtkRectilinearGridReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkRectilinearGridReader::vtkTypeRevisionMacro | ( | vtkRectilinearGridReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkRectilinearGridReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkRectilinearGrid* vtkRectilinearGridReader::GetOutput ( )

Get and set the output of this reader.

vtkRectilinearGrid* vtkRectilinearGridReader::GetOutput ( int idx ) [inline]

Get and set the output of this reader.

Reimplemented from vtkSource.

Definition at line 63 of file vtkRectilinearGridReader.h.

void vtkRectilinearGridReader::SetOutput ( vtkRectilinearGrid * output )

Get and set the output of this reader.

void vtkRectilinearGridReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkRectilinearGridReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • IO/vtkRectilinearGridReader.h
Generated on Mon Mar 25 01:29:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridSource Class Reference

Abstract class whose subclasses generates rectilinear grid data. More...

#include <vtkRectilinearGridSource.h>

Inheritance diagram for vtkRectilinearGridSource:

[legend]
Collaboration diagram for vtkRectilinearGridSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridSource, vtkSource)
vtkRectilinearGrid * GetOutput ()
vtkRectilinearGrid * | GetOutput (int idx)
void | SetOutput (vtkRectilinearGrid *output)

Static Public Methods

vtkRectilinearGridSource * | New ()

Protected Methods

vtkRectilinearGridSource ()
~vtkRectilinearGridSource ()

Detailed Description

Abstract class whose subclasses generates rectilinear grid data.

Date:
2002/01/22 15:28:10
Revision:
1.19

vtkRectilinearGridSource is an abstract class whose subclasses generate rectilinear grid data.

See also:
vtkRectilinearGridReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Martin, Ken (17%)

Definition at line 42 of file vtkRectilinearGridSource.h.

Constructor & Destructor Documentation

vtkRectilinearGridSource::vtkRectilinearGridSource ( ) [protected]

vtkRectilinearGridSource::~vtkRectilinearGridSource ( ) [inline, protected]

Definition at line 58 of file vtkRectilinearGridSource.h.

Member Function Documentation

vtkRectilinearGridSource* vtkRectilinearGridSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

vtkRectilinearGridSource::vtkTypeRevisionMacro | ( | vtkRectilinearGridSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

vtkRectilinearGrid* vtkRectilinearGridSource::GetOutput ( )

Get the output of this source.

vtkRectilinearGrid* vtkRectilinearGridSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Definition at line 51 of file vtkRectilinearGridSource.h.

void vtkRectilinearGridSource::SetOutput ( vtkRectilinearGrid * output )

Get the output of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkRectilinearGridSource.h
Generated on Mon Mar 25 01:29:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkRectilinearGridToPolyDataFilter.h>

Inheritance diagram for vtkRectilinearGridToPolyDataFilter:

[legend]
Collaboration diagram for vtkRectilinearGridToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridToPolyDataFilter, vtkPolyDataSource)
void SetInput (vtkRectilinearGrid *input)
vtkRectilinearGrid * GetInput ()

Protected Methods

vtkRectilinearGridToPolyDataFilter ()
~vtkRectilinearGridToPolyDataFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:11
Revision:
1.19

vtkRectilinearGridToPolyDataFilter is a filter whose subclasses take as input rectilinear grid datasets and generate polygonal data on output.

See also:
vtkRectilinearGridGeometryFilter vtkRectilinearGridOutlineFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Lorensen, Bill (13%)
  • Martin, Ken (8%)

Definition at line 43 of file vtkRectilinearGridToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkRectilinearGridToPolyDataFilter::vtkRectilinearGridToPolyDataFilter ( ) [inline, protected]

Definition at line 55 of file vtkRectilinearGridToPolyDataFilter.h.

vtkRectilinearGridToPolyDataFilter::~vtkRectilinearGridToPolyDataFilter ( ) [inline, protected]

Definition at line 56 of file vtkRectilinearGridToPolyDataFilter.h.

Member Function Documentation

vtkRectilinearGridToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkRectilinearGridToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkRectilinearGridGeometryFilter, and vtkRectilinearGridOutlineFilter.

void vtkRectilinearGridToPolyDataFilter::SetInput ( vtkRectilinearGrid * input )

Set / get the input Grid or filter.

vtkRectilinearGrid* vtkRectilinearGridToPolyDataFilter::GetInput ( )

Set / get the input Grid or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkRectilinearGridToPolyDataFilter.h
Generated on Mon Mar 25 01:29:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRectilinearGridWriter Class Reference

write vtk rectilinear grid data file. More...

#include <vtkRectilinearGridWriter.h>

Inheritance diagram for vtkRectilinearGridWriter:

[legend]
Collaboration diagram for vtkRectilinearGridWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRectilinearGridWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkRectilinearGrid *input)
vtkRectilinearGrid * GetInput ()

Static Public Methods

vtkRectilinearGridWriter * | New ()

Protected Methods

vtkRectilinearGridWriter ()
~vtkRectilinearGridWriter ()
void | WriteData ()

Detailed Description

write vtk rectilinear grid data file.

Date:
2002/01/22 15:38:21
Revision:
1.21

vtkRectilinearGridWriter is a source object that writes ASCII or binary rectilinear grid data files in vtk format. See text for format details.

Warning:
Binary files written on one system may not be readable on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Law, Charles (9%)
  • Martin, Ken (6%)

Definition at line 43 of file vtkRectilinearGridWriter.h.

Constructor & Destructor Documentation

vtkRectilinearGridWriter::vtkRectilinearGridWriter ( ) [inline, protected]

Definition at line 57 of file vtkRectilinearGridWriter.h.

vtkRectilinearGridWriter::~vtkRectilinearGridWriter ( ) [inline, protected]

Definition at line 58 of file vtkRectilinearGridWriter.h.

Member Function Documentation

vtkRectilinearGridWriter* vtkRectilinearGridWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

vtkRectilinearGridWriter::vtkTypeRevisionMacro | ( | vtkRectilinearGridWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

void vtkRectilinearGridWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

void vtkRectilinearGridWriter::SetInput ( vtkRectilinearGrid * input )

Set / get the input data or filter.

vtkRectilinearGrid* vtkRectilinearGridWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkRectilinearGridWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

The documentation for this class was generated from the following file:
  • IO/vtkRectilinearGridWriter.h
Generated on Mon Mar 25 01:29:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRecursiveDividingCubes Class Reference

create points lying on isosurface (using recursive approach). More...

#include <vtkRecursiveDividingCubes.h>

Inheritance diagram for vtkRecursiveDividingCubes:

[legend]
Collaboration diagram for vtkRecursiveDividingCubes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRecursiveDividingCubes, vtkStructuredPointsToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetDistance (float)
virtual float | GetDistance ()
virtual void | SetIncrement (int)
virtual int | GetIncrement ()

Static Public Methods

vtkRecursiveDividingCubes * | New ()

Protected Methods

vtkRecursiveDividingCubes ()
~vtkRecursiveDividingCubes ()
void | Execute ()
void | SubDivide (float origin[3], float h[3], float values[8])

Protected Attributes

float | Value
float | Distance
int | Increment
int | Count
vtkVoxel * Voxel

Detailed Description

create points lying on isosurface (using recursive approach).

Date:
2002/01/22 15:29:42
Revision:
1.35

vtkRecursiveDividingCubes is a filter that generates points lying on a surface of constant scalar value (i.e., an isosurface). Dense point clouds (i.e., at screen resolution) will appear as a surface. Less dense clouds can be used as a source to generate streamlines or to generate "transparent" surfaces.

This implementation differs from vtkDividingCubes in that it uses a recursive procedure. In many cases this can result in generating more points than the procedural implementation of vtkDividingCubes. This is because the recursive procedure divides voxels by multiples of powers of two. This can over-constrain subdivision. One of the advantages of the recursive technique is that the recursion is terminated earlier, which in some cases can be more efficient.

See also:
vtkDividingCubes vtkContourFilter vtkMarchingCubes
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Law, Charles (8%)
  • Lorensen, Bill (7%)
  • Geveci, Berk (5%)
  • Martin, Ken (5%)
Tests:
vtkRecursiveDividingCubes (Tests)

Definition at line 58 of file vtkRecursiveDividingCubes.h.

Constructor & Destructor Documentation

vtkRecursiveDividingCubes::vtkRecursiveDividingCubes ( ) [protected]

vtkRecursiveDividingCubes::~vtkRecursiveDividingCubes ( ) [protected]

Member Function Documentation

vtkRecursiveDividingCubes* vtkRecursiveDividingCubes::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkRecursiveDividingCubes::vtkTypeRevisionMacro | ( | vtkRecursiveDividingCubes | ,
 |  | vtkStructuredPointsToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredPointsToPolyDataFilter.

void vtkRecursiveDividingCubes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkRecursiveDividingCubes::SetValue ( float ) [virtual]

Set isosurface value.

virtual float vtkRecursiveDividingCubes::GetValue ( ) [virtual]

Set isosurface value.

virtual void vtkRecursiveDividingCubes::SetDistance ( float ) [virtual]

Specify sub-voxel size at which to generate point.

virtual float vtkRecursiveDividingCubes::GetDistance ( ) [virtual]

Specify sub-voxel size at which to generate point.

virtual void vtkRecursiveDividingCubes::SetIncrement ( int ) [virtual]

Every "Increment" point is added to the list of points. This parameter, if set to a large value, can be used to limit the number of points while retaining good accuracy.

virtual int vtkRecursiveDividingCubes::GetIncrement ( ) [virtual]

Every "Increment" point is added to the list of points. This parameter, if set to a large value, can be used to limit the number of points while retaining good accuracy.

void vtkRecursiveDividingCubes::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkRecursiveDividingCubes::SubDivide | ( | float | origin[3],
 |  | float | h[3],
 |  | float | values[8]
 | ) | [protected]

Member Data Documentation

float vtkRecursiveDividingCubes::Value [protected]

Definition at line 92 of file vtkRecursiveDividingCubes.h.

float vtkRecursiveDividingCubes::Distance [protected]

Definition at line 93 of file vtkRecursiveDividingCubes.h.

int vtkRecursiveDividingCubes::Increment [protected]

Definition at line 94 of file vtkRecursiveDividingCubes.h.

int vtkRecursiveDividingCubes::Count [protected]

Definition at line 97 of file vtkRecursiveDividingCubes.h.

vtkVoxel* vtkRecursiveDividingCubes::Voxel [protected]

Definition at line 100 of file vtkRecursiveDividingCubes.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRecursiveDividingCubes.h
Generated on Mon Mar 25 01:29:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRecursiveSphereDirectionEncoder Class Reference

A direction encoder based on the recursive subdivision of an octahedron. More...

#include <vtkRecursiveSphereDirectionEncoder.h>

Inheritance diagram for vtkRecursiveSphereDirectionEncoder:

[legend]
Collaboration diagram for vtkRecursiveSphereDirectionEncoder:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder)
void | PrintSelf (ostream &os, vtkIndent index)
int | GetEncodedDirection (float n[3])
float * | GetDecodedGradient (int value)
int | GetNumberOfEncodedDirections (void)
float * | GetDecodedGradientTable (void)
virtual void | SetRecursionDepth (int)
virtual int | GetRecursionDepth ()

Static Public Methods

vtkRecursiveSphereDirectionEncoder * | New ()

Protected Methods

vtkRecursiveSphereDirectionEncoder ()
~vtkRecursiveSphereDirectionEncoder ()
void | InitializeIndexTable (void)

Protected Attributes

int | RecursionDepth
int * | IndexTable
float * | DecodedNormal
int | IndexTableRecursionDepth
int | OuterSize
int | InnerSize
int | GridSize

Detailed Description

A direction encoder based on the recursive subdivision of an octahedron.

Date:
2002/01/22 15:39:17
Revision:
1.19

vtkRecursiveSphereDirectionEncoder is a direction encoder which uses the vertices of a recursive subdivision of an octahedron (with the vertices pushed out onto the surface of an enclosing sphere) to encode directions into a two byte value.

See also:
vtkDirectionEncoder
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (87%)
  • Lorensen, Bill (5%)

Definition at line 44 of file vtkRecursiveSphereDirectionEncoder.h.

Constructor & Destructor Documentation

vtkRecursiveSphereDirectionEncoder::vtkRecursiveSphereDirectionEncoder ( ) [protected]

vtkRecursiveSphereDirectionEncoder::~vtkRecursiveSphereDirectionEncoder ( ) [protected]

Member Function Documentation

vtkRecursiveSphereDirectionEncoder::vtkTypeRevisionMacro | ( | vtkRecursiveSphereDirectionEncoder | ,
 |  | vtkDirectionEncoder |
 | ) |

Get the name of this class

Reimplemented from vtkDirectionEncoder.

void vtkRecursiveSphereDirectionEncoder::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkRecursiveSphereDirectionEncoder* vtkRecursiveSphereDirectionEncoder::New ( ) [static]

Construct the object. Initialize the index table which will be used to map the normal into a patch on the recursively subdivided sphere.

Reimplemented from vtkObject.

int vtkRecursiveSphereDirectionEncoder::GetEncodedDirection ( float n[3] ) [virtual]

Given a normal vector n, return the encoded direction

Reimplemented from vtkDirectionEncoder.

float* vtkRecursiveSphereDirectionEncoder::GetDecodedGradient ( int value ) [virtual]

/ Given an encoded value, return a pointer to the normal vector

Reimplemented from vtkDirectionEncoder.

int vtkRecursiveSphereDirectionEncoder::GetNumberOfEncodedDirections ( void ) [virtual]

Return the number of encoded directions

Reimplemented from vtkDirectionEncoder.

float* vtkRecursiveSphereDirectionEncoder::GetDecodedGradientTable ( void ) [virtual]

Get the decoded gradient table. There are this->GetNumberOfEncodedDirections() entries in the table, each containing a normal (direction) vector. This is a flat structure - 3 times the number of directions floats in an array.

Reimplemented from vtkDirectionEncoder.

virtual void vtkRecursiveSphereDirectionEncoder::SetRecursionDepth ( int ) [virtual]

Set / Get the recursion depth for the subdivision. This indicates how many time one triangle on the initial 8-sided sphere model is replaced by four triangles formed by connecting triangle edge midpoints. A recursion level of 0 yields 8 triangles with 6 unique vertices. The normals are the vectors from the sphere center through the vertices. The number of directions will be 11 since the four normals with 0 z values will be duplicated in the table - once with +0 values and the other time with -0 values, and an addition index will be used to represent the (0,0,0) normal. If we instead choose a recursion level of 6 (the maximum that can fit within 2 bytes) the number of directions is 16643, with 16386 unique directions and a zero normal.

virtual int vtkRecursiveSphereDirectionEncoder::GetRecursionDepth ( ) [virtual]

Set / Get the recursion depth for the subdivision. This indicates how many time one triangle on the initial 8-sided sphere model is replaced by four triangles formed by connecting triangle edge midpoints. A recursion level of 0 yields 8 triangles with 6 unique vertices. The normals are the vectors from the sphere center through the vertices. The number of directions will be 11 since the four normals with 0 z values will be duplicated in the table - once with +0 values and the other time with -0 values, and an addition index will be used to represent the (0,0,0) normal. If we instead choose a recursion level of 6 (the maximum that can fit within 2 bytes) the number of directions is 16643, with 16386 unique directions and a zero normal.

void vtkRecursiveSphereDirectionEncoder::InitializeIndexTable ( void ) [protected]

Member Data Documentation

int vtkRecursiveSphereDirectionEncoder::RecursionDepth [protected]

Definition at line 92 of file vtkRecursiveSphereDirectionEncoder.h.

int* vtkRecursiveSphereDirectionEncoder::IndexTable [protected]

Definition at line 97 of file vtkRecursiveSphereDirectionEncoder.h.

float* vtkRecursiveSphereDirectionEncoder::DecodedNormal [protected]

Definition at line 103 of file vtkRecursiveSphereDirectionEncoder.h.

int vtkRecursiveSphereDirectionEncoder::IndexTableRecursionDepth [protected]

Definition at line 109 of file vtkRecursiveSphereDirectionEncoder.h.

int vtkRecursiveSphereDirectionEncoder::OuterSize [protected]

Definition at line 111 of file vtkRecursiveSphereDirectionEncoder.h.

int vtkRecursiveSphereDirectionEncoder::InnerSize [protected]

Definition at line 112 of file vtkRecursiveSphereDirectionEncoder.h.

int vtkRecursiveSphereDirectionEncoder::GridSize [protected]

Definition at line 113 of file vtkRecursiveSphereDirectionEncoder.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRecursiveSphereDirectionEncoder.h
Generated on Mon Mar 25 01:29:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReferenceCount Class Reference

Obsolete / empty subclass of object. More...

#include <vtkReferenceCount.h>

Inheritance diagram for vtkReferenceCount:

[legend]
Collaboration diagram for vtkReferenceCount:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkReferenceCount, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkReferenceCount * | New ()

Protected Methods

vtkReferenceCount ()
~vtkReferenceCount ()

Detailed Description

Obsolete / empty subclass of object.

Date:
2002/01/22 15:26:16
Revision:
1.24

vtkReferenceCount functionality has now been moved into vtkObject

See also:
vtkObject
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Martin, Ken (23%)
  • Kelly, Ann (11%)

Definition at line 40 of file vtkReferenceCount.h.

Constructor & Destructor Documentation

vtkReferenceCount::vtkReferenceCount ( ) [protected]

vtkReferenceCount::~vtkReferenceCount ( ) [protected]

Member Function Documentation

vtkReferenceCount* vtkReferenceCount::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkReferenceCount::vtkTypeRevisionMacro | ( | vtkReferenceCount | ,
 |  | vtkObject |
 | ) |

void vtkReferenceCount::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

The documentation for this class was generated from the following file:
  • Common/vtkReferenceCount.h
Generated on Mon Mar 25 01:29:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReflectionFilter Class Reference

reflects a data set across a plane. More...

#include <vtkReflectionFilter.h>

Inheritance diagram for vtkReflectionFilter:

[legend]
Collaboration diagram for vtkReflectionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkReflectionFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPlane (int)
virtual int | GetPlane ()
void | SetPlaneToXMin ()
void | SetPlaneToYMin ()
void | SetPlaneToZMin ()
void | SetPlaneToXMax ()
void | SetPlaneToYMax ()
void | SetPlaneToZMax ()

Static Public Methods

vtkReflectionFilter * | New ()

Protected Methods

vtkReflectionFilter ()
~vtkReflectionFilter ()
void | Execute ()

Protected Attributes

int | Plane

Detailed Description

reflects a data set across a plane.

Date:
2002/02/26 14:35:16
Revision:
1.1

The vtkReflectionFilter reflects a polygonal data set across one of the planes formed by the data set's bounding box.

Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (100%)
Tests:
vtkReflectionFilter (Tests)

Definition at line 47 of file vtkReflectionFilter.h.

Constructor & Destructor Documentation

vtkReflectionFilter::vtkReflectionFilter ( ) [protected]

vtkReflectionFilter::~vtkReflectionFilter ( ) [protected]

Member Function Documentation

vtkReflectionFilter* vtkReflectionFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkReflectionFilter::vtkTypeRevisionMacro | ( | vtkReflectionFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkReflectionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkReflectionFilter::SetPlane ( int ) [virtual]

virtual int vtkReflectionFilter::GetPlane ( ) [virtual]

void vtkReflectionFilter::SetPlaneToXMin ( ) [inline]

Definition at line 57 of file vtkReflectionFilter.h.

void vtkReflectionFilter::SetPlaneToYMin ( ) [inline]

Definition at line 58 of file vtkReflectionFilter.h.

void vtkReflectionFilter::SetPlaneToZMin ( ) [inline]

Definition at line 59 of file vtkReflectionFilter.h.

void vtkReflectionFilter::SetPlaneToXMax ( ) [inline]

Definition at line 60 of file vtkReflectionFilter.h.

void vtkReflectionFilter::SetPlaneToYMax ( ) [inline]

Definition at line 61 of file vtkReflectionFilter.h.

void vtkReflectionFilter::SetPlaneToZMax ( ) [inline]

Definition at line 62 of file vtkReflectionFilter.h.

void vtkReflectionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkReflectionFilter::Plane [protected]

Definition at line 70 of file vtkReflectionFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkReflectionFilter.h
Generated on Mon Mar 25 01:29:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderer Class Reference

abstract specification for renderers. More...

#include <vtkRenderer.h>

Inheritance diagram for vtkRenderer:

[legend]
Collaboration diagram for vtkRenderer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRenderer, vtkViewport)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddLight (vtkLight *)
void | RemoveLight (vtkLight *)
vtkLightCollection * GetLights ()
vtkVolumeCollection * GetVolumes ()
vtkActorCollection * GetActors ()
void | SetActiveCamera (vtkCamera *)
vtkCamera * GetActiveCamera ()
virtual vtkCamera * | MakeCamera ()
void | AddCuller (vtkCuller *)
void | RemoveCuller (vtkCuller *)
vtkCullerCollection * GetCullers ()
virtual float | GetTimeFactor ()
virtual void | Render ()
virtual void | DeviceRender ()=0
virtual void | Clear ()
int | VisibleActorCount ()
int | VisibleVolumeCount ()
void | CreateLight (void)
virtual vtkLight * | MakeLight ()
void | ComputeVisiblePropBounds (float bounds[6])
void | ResetCameraClippingRange ()
void | ResetCamera ()
void | ResetCamera (float bounds[6])
int | Transparent ()
void | WorldToView ()
virtual void | WorldToView (float &wx, float &wy, float &wz)
float | GetZ (int x, int y)
void | RenderOverlay ()
unsigned long | GetMTime ()
vtkAssemblyPath * | PickProp (float selectionX, float selectionY)
vtkRayCaster * GetRayCaster ()
void | AddActor (vtkProp *p)
void | AddVolume (vtkProp *p)
void | RemoveActor (vtkProp *p)
void | RemoveVolume (vtkProp *p)
virtual void | SetAmbient (float, float, float)
virtual void | SetAmbient (float[3])
virtual float * | GetAmbient ()
virtual void | GetAmbient (float data[3])
virtual void | SetAllocatedRenderTime (float)
virtual float | GetAllocatedRenderTime ()
void | ResetCameraClippingRange (float bounds[6])
void | ResetCameraClippingRange (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
void | ResetCamera (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
void | SetRenderWindow (vtkRenderWindow *)
vtkRenderWindow * GetRenderWindow ()
virtual vtkWindow * | GetVTKWindow ()
virtual int | GetTwoSidedLighting ()
virtual void | SetTwoSidedLighting (int)
virtual void | TwoSidedLightingOn ()
virtual void | TwoSidedLightingOff ()
virtual void | SetBackingStore (int)
virtual int | GetBackingStore ()
virtual void | BackingStoreOn ()
virtual void | BackingStoreOff ()
virtual void | SetInteractive (int)
virtual int | GetInteractive ()
virtual void | InteractiveOn ()
virtual void | InteractiveOff ()
virtual void | SetLayer (int)
virtual int | GetLayer ()
void | ViewToWorld ()
virtual void | ViewToWorld (float &wx, float &wy, float &wz)
virtual float | GetLastRenderTimeInSeconds ()
virtual int | GetNumberOfPropsRenderedAsGeometry ()
virtual void | SetLightFollowCamera (int)
virtual int | GetLightFollowCamera ()
virtual void | LightFollowCameraOn ()
virtual void | LightFollowCameraOff ()

Static Public Methods

vtkRenderer * | New ()

Protected Methods

vtkRenderer ()
~vtkRenderer ()
virtual void | PickRender (vtkPropCollection *props)
virtual void | PickGeometry ()
void | AllocateTime ()
virtual int | UpdateGeometry (void)
virtual int | UpdateCamera (void)
virtual int | UpdateLightGeometry (void)
virtual int | UpdateLights (void)

Protected Attributes

vtkCamera * ActiveCamera
vtkLight * CreatedLight
vtkLightCollection * Lights
vtkCullerCollection * Cullers
vtkActorCollection * Actors
vtkVolumeCollection * Volumes
float | Ambient [3]
vtkRenderWindow * RenderWindow
float | AllocatedRenderTime
float | TimeFactor
int | TwoSidedLighting
int | BackingStore
unsigned char * | BackingImage
vtkTimeStamp RenderTime
float | LastRenderTimeInSeconds
int | LightFollowCamera
int | NumberOfPropsRenderedAsGeometry
int | NumberOfPropsToRayCast
int | NumberOfPropsToRenderIntoImage
vtkProp ** PropArray
int | PropArrayCount
vtkAssemblyPath ** PathArray
int | PathArrayCount
int | Interactive
int | Layer
vtkRayCaster * RayCaster

Detailed Description

abstract specification for renderers.

Date:
2002/01/22 15:39:21
Revision:
1.103

vtkRenderer provides an abstract specification for renderers. A renderer is an object that controls the rendering process for objects. Rendering is the process of converting geometry, a specification for lights, and a camera view into an image. vtkRenderer also performs coordinate transformation between world coordinates, view coordinates (the computer graphics rendering coordinate system), and display coordinates (the actual screen coordinates on the display device). Certain advanced rendering features such as two-sided lighting can also be controlled.

See also:
vtkRenderWindow vtkActor vtkCamera vtkLight vtkVolume
Events:
vtkCommand::StartEvent vtkCommand::ResetCameraClippingRangeEvent vtkCommand::EndEvent vtkCommand::ResetCameraEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (31%)
  • Avila, Lisa (30%)
  • Schroeder, Will (15%)
Examples:
vtkRenderer (Examples)
Tests:
vtkRenderer (Tests)

Definition at line 70 of file vtkRenderer.h.

Constructor & Destructor Documentation

vtkRenderer::vtkRenderer ( ) [protected]

vtkRenderer::~vtkRenderer ( ) [protected]

Member Function Documentation

vtkRenderer::vtkTypeRevisionMacro | ( | vtkRenderer | ,
 |  | vtkViewport |
 | ) |

Reimplemented from vtkViewport.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

void vtkRenderer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkViewport.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

vtkRenderer* vtkRenderer::New ( ) [static]

Create a vtkRenderer with a black background, a white ambient light, two-sided lighting turned on, a viewport of (0,0,1,1), and backface culling turned off.

Reimplemented from vtkObject.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

void vtkRenderer::AddLight ( vtkLight * )

Add a light to the list of lights.

void vtkRenderer::AddActor ( vtkProp * p ) [inline]

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

Definition at line 88 of file vtkRenderer.h.

void vtkRenderer::AddVolume ( vtkProp * p ) [inline]

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

Definition at line 89 of file vtkRenderer.h.

void vtkRenderer::RemoveActor ( vtkProp * p ) [inline]

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

Definition at line 90 of file vtkRenderer.h.

void vtkRenderer::RemoveVolume ( vtkProp * p ) [inline]

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

Definition at line 91 of file vtkRenderer.h.

void vtkRenderer::RemoveLight ( vtkLight * )

Remove a light from the list of lights.

vtkLightCollection * vtkRenderer::GetLights ( ) [inline]

Return the collection of lights.

Definition at line 404 of file vtkRenderer.h.

vtkVolumeCollection* vtkRenderer::GetVolumes ( )

Return the collection of volumes.

vtkActorCollection* vtkRenderer::GetActors ( )

Return any actors in this renderer.

void vtkRenderer::SetActiveCamera ( vtkCamera * )

Specify the camera to use for this renderer.

vtkCamera* vtkRenderer::GetActiveCamera ( )

Get the current camera.

virtual vtkCamera* vtkRenderer::MakeCamera ( ) [virtual]

Create a new Camera sutible for use with this type of Renderer. For example, a vtkMesaRenderer should create a vtkMesaCamera in this function. The default is to just call vtkCamera::New.

Reimplemented in vtkMesaRenderer.

void vtkRenderer::AddCuller ( vtkCuller * )

Add an culler to the list of cullers.

void vtkRenderer::RemoveCuller ( vtkCuller * )

Remove an actor from the list of cullers.

vtkCullerCollection * vtkRenderer::GetCullers ( ) [inline]

Return the collection of cullers.

Definition at line 407 of file vtkRenderer.h.

virtual void vtkRenderer::SetAmbient | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the intensity of ambient lighting.

virtual void vtkRenderer::SetAmbient ( float [3] ) [virtual]

Set the intensity of ambient lighting.

virtual float* vtkRenderer::GetAmbient ( ) [virtual]

Set the intensity of ambient lighting.

virtual void vtkRenderer::GetAmbient ( float data[3] ) [virtual]

Set the intensity of ambient lighting.

virtual void vtkRenderer::SetAllocatedRenderTime ( float ) [virtual]

Set/Get the amount of time this renderer is allowed to spend rendering its scene. This is used by vtkLODActor's.

virtual float vtkRenderer::GetAllocatedRenderTime ( ) [virtual]

Set/Get the amount of time this renderer is allowed to spend rendering its scene. This is used by vtkLODActor's.

virtual float vtkRenderer::GetTimeFactor ( ) [virtual]

Get the ratio between allocated time and actual render time. TimeFactor has been taken out of the render process. It is still computed in case someone finds it useful. It may be taken away in the future.

virtual void vtkRenderer::Render ( void ) [virtual]

Create an image. This is a superclass method which will in turn call the DeviceRender method of Subclasses of vtkRenderer

virtual void vtkRenderer::DeviceRender ( void ) [pure virtual]

Create an image. Subclasses of vtkRenderer must implement this method.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

virtual void vtkRenderer::Clear ( void ) [inline, virtual]

Clear the image to the background color.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

Definition at line 155 of file vtkRenderer.h.

int vtkRenderer::VisibleActorCount ( )

Returns the number of visible actors.

int vtkRenderer::VisibleVolumeCount ( )

Returns the number of visible volumes.

void vtkRenderer::CreateLight ( void )

Create and add a light to renderer.

virtual vtkLight* vtkRenderer::MakeLight ( ) [virtual]

Create a new Light sutible for use with this type of Renderer. For example, a vtkMesaRenderer should create a vtkMesaLight in this function. The default is to just call vtkLight::New.

Reimplemented in vtkMesaRenderer.

void vtkRenderer::ComputeVisiblePropBounds ( float bounds[6] )

Compute the bounding box of all the visible props Used in ResetCamera() and ResetCameraClippingRange()

void vtkRenderer::ResetCameraClippingRange ( )

Reset the camera clipping range based on the bounds of the visible actors. This ensures that no props are cut off

void vtkRenderer::ResetCameraClippingRange ( float bounds[6] )

Reset the camera clipping range based on a bounding box. This method is called from ResetCameraClippingRange()

void vtkRenderer::ResetCameraClippingRange | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

Reset the camera clipping range based on a bounding box. This method is called from ResetCameraClippingRange()

void vtkRenderer::ResetCamera ( )

Automatically set up the camera based on the visible actors. The camera will reposition itself to view the center point of the actors, and move along its initial view plane normal (i.e., vector defined from camera position to focal point) so that all of the actors can be seen.

void vtkRenderer::ResetCamera ( float bounds[6] )

Automatically set up the camera based on a specified bounding box (xmin,xmax, ymin,ymax, zmin,zmax). Camera will reposition itself so that its focal point is the center of the bounding box, and adjust its distance and position to preserve its initial view plane normal (i.e., vector defined from camera position to focal point). Note: is the view plane is parallel to the view up axis, the view up axis will be reset to one of the three coordinate axes.

void vtkRenderer::ResetCamera | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

Alternative version of ResetCamera(bounds[6]);

void vtkRenderer::SetRenderWindow ( vtkRenderWindow * )

Specify the rendering window in which to draw. This is automatically set when the renderer is created by MakeRenderer. The user probably shouldn't ever need to call this method.

vtkRenderWindow* vtkRenderer::GetRenderWindow ( ) [inline]

Specify the rendering window in which to draw. This is automatically set when the renderer is created by MakeRenderer. The user probably shouldn't ever need to call this method.

Definition at line 215 of file vtkRenderer.h.

virtual vtkWindow* vtkRenderer::GetVTKWindow ( ) [virtual]

Specify the rendering window in which to draw. This is automatically set when the renderer is created by MakeRenderer. The user probably shouldn't ever need to call this method.

Reimplemented from vtkViewport.

virtual int vtkRenderer::GetTwoSidedLighting ( ) [virtual]

Turn on/off two-sided lighting of surfaces. If two-sided lighting is off, then only the side of the surface facing the light(s) will be lit, and the other side dark. If two-sided lighting on, both sides of the surface will be lit.

virtual void vtkRenderer::SetTwoSidedLighting ( int ) [virtual]

Turn on/off two-sided lighting of surfaces. If two-sided lighting is off, then only the side of the surface facing the light(s) will be lit, and the other side dark. If two-sided lighting on, both sides of the surface will be lit.

virtual void vtkRenderer::TwoSidedLightingOn ( ) [virtual]

Turn on/off two-sided lighting of surfaces. If two-sided lighting is off, then only the side of the surface facing the light(s) will be lit, and the other side dark. If two-sided lighting on, both sides of the surface will be lit.

virtual void vtkRenderer::TwoSidedLightingOff ( ) [virtual]

Turn on/off two-sided lighting of surfaces. If two-sided lighting is off, then only the side of the surface facing the light(s) will be lit, and the other side dark. If two-sided lighting on, both sides of the surface will be lit.

virtual void vtkRenderer::SetBackingStore ( int ) [virtual]

Turn on/off using backing store. This may cause the re-rendering time to be slightly slower when the view changes. But it is much faster when the image has not changed, such as during an expose event.

virtual int vtkRenderer::GetBackingStore ( ) [virtual]

Turn on/off using backing store. This may cause the re-rendering time to be slightly slower when the view changes. But it is much faster when the image has not changed, such as during an expose event.

virtual void vtkRenderer::BackingStoreOn ( ) [virtual]

Turn on/off using backing store. This may cause the re-rendering time to be slightly slower when the view changes. But it is much faster when the image has not changed, such as during an expose event.

virtual void vtkRenderer::BackingStoreOff ( ) [virtual]

Turn on/off using backing store. This may cause the re-rendering time to be slightly slower when the view changes. But it is much faster when the image has not changed, such as during an expose event.

virtual void vtkRenderer::SetInteractive ( int ) [virtual]

Turn on/off interactive status. An interactive renderer is one that can receive events from an interactor. Should only be set if there are multiple renderers in the same section of the viewport.

virtual int vtkRenderer::GetInteractive ( ) [virtual]

Turn on/off interactive status. An interactive renderer is one that can receive events from an interactor. Should only be set if there are multiple renderers in the same section of the viewport.

virtual void vtkRenderer::InteractiveOn ( ) [virtual]

Turn on/off interactive status. An interactive renderer is one that can receive events from an interactor. Should only be set if there are multiple renderers in the same section of the viewport.

virtual void vtkRenderer::InteractiveOff ( ) [virtual]

Turn on/off interactive status. An interactive renderer is one that can receive events from an interactor. Should only be set if there are multiple renderers in the same section of the viewport.

virtual void vtkRenderer::SetLayer ( int ) [virtual]

Set/Get the layer that this renderer belongs to. This is only used if there are layered renderers.

virtual int vtkRenderer::GetLayer ( ) [virtual]

Set/Get the layer that this renderer belongs to. This is only used if there are layered renderers.

int vtkRenderer::Transparent ( )

Returns a boolean indicating if this renderer is transparent. It is transparent if it is not in the deepest layer of its render window.

void vtkRenderer::WorldToView ( ) [virtual]

Convert world point coordinates to view coordinates.

Reimplemented from vtkViewport.

void vtkRenderer::ViewToWorld ( ) [virtual]

Convert view point coordinates to world coordinates.

Reimplemented from vtkViewport.

virtual void vtkRenderer::ViewToWorld | ( | float & | wx,
 |  | float & | wy,
 |  | float & | wz
 | ) | [virtual]

Convert view point coordinates to world coordinates.

Reimplemented from vtkViewport.

virtual void vtkRenderer::WorldToView | ( | float & | wx,
 |  | float & | wy,
 |  | float & | wz
 | ) | [virtual]

Convert world point coordinates to view coordinates.

Reimplemented from vtkViewport.

float vtkRenderer::GetZ | ( | int | x,
 |  | int | y
 | ) |

Given a pixel location, return the Z value

void vtkRenderer::RenderOverlay ( )

Render the overlay actors. This gets called from the RenderWindow because it may need to be synchronized to happen after the buffers have been swapped.

unsigned long vtkRenderer::GetMTime ( ) [virtual]

Return the MTime of the renderer also considering its ivars.

Reimplemented from vtkObject.

virtual float vtkRenderer::GetLastRenderTimeInSeconds ( ) [virtual]

Get the time required, in seconds, for the last Render call.

virtual int vtkRenderer::GetNumberOfPropsRenderedAsGeometry ( ) [virtual]

Should be used internally only during a render Get the number of props that were rendered using a RenderOpaqueGeometry or RenderTranslucentGeometry call. This is used to know if something is in the frame buffer.

vtkAssemblyPath* vtkRenderer::PickProp | ( | float | selectionX,
 |  | float | selectionY
 | ) | [virtual]

Return the prop (via a vtkAssemblyPath) that has the highest z value at the given x, y position in the viewport. Basically, the top most prop that renders the pixel at selectionX, selectionY will be returned. If nothing was picked then NULL is returned. This method selects from the renderers Prop list.

Reimplemented from vtkViewport.

virtual void vtkRenderer::SetLightFollowCamera ( int ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves. If LightFollowCamera is on, lights that are designated as Headlights or CameraLights will be adjusted to move with this renderer's camera. If LightFollowCamera is off, the lights will not be adjusted. (Note: In previous versions of vtk, this light-tracking functionality was part of the interactors, not the renderer. For backwards compatibility, the older, more limited interactor behavior is enabled by default. This mode has the possibly unexpected property of turning the first light into a headlight, no matter what its light type is. To disable this mode, turn the interactor's LightFollowCamera flag OFF, and leave the renderer's LightFollowCamera flag ON.)

virtual int vtkRenderer::GetLightFollowCamera ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves. If LightFollowCamera is on, lights that are designated as Headlights or CameraLights will be adjusted to move with this renderer's camera. If LightFollowCamera is off, the lights will not be adjusted. (Note: In previous versions of vtk, this light-tracking functionality was part of the interactors, not the renderer. For backwards compatibility, the older, more limited interactor behavior is enabled by default. This mode has the possibly unexpected property of turning the first light into a headlight, no matter what its light type is. To disable this mode, turn the interactor's LightFollowCamera flag OFF, and leave the renderer's LightFollowCamera flag ON.)

virtual void vtkRenderer::LightFollowCameraOn ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves. If LightFollowCamera is on, lights that are designated as Headlights or CameraLights will be adjusted to move with this renderer's camera. If LightFollowCamera is off, the lights will not be adjusted. (Note: In previous versions of vtk, this light-tracking functionality was part of the interactors, not the renderer. For backwards compatibility, the older, more limited interactor behavior is enabled by default. This mode has the possibly unexpected property of turning the first light into a headlight, no matter what its light type is. To disable this mode, turn the interactor's LightFollowCamera flag OFF, and leave the renderer's LightFollowCamera flag ON.)

virtual void vtkRenderer::LightFollowCameraOff ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves. If LightFollowCamera is on, lights that are designated as Headlights or CameraLights will be adjusted to move with this renderer's camera. If LightFollowCamera is off, the lights will not be adjusted. (Note: In previous versions of vtk, this light-tracking functionality was part of the interactors, not the renderer. For backwards compatibility, the older, more limited interactor behavior is enabled by default. This mode has the possibly unexpected property of turning the first light into a headlight, no matter what its light type is. To disable this mode, turn the interactor's LightFollowCamera flag OFF, and leave the renderer's LightFollowCamera flag ON.)

vtkRayCaster* vtkRenderer::GetRayCaster ( ) [inline]

Definition at line 319 of file vtkRenderer.h.

virtual void vtkRenderer::PickRender ( vtkPropCollection * props ) [protected, virtual]

virtual void vtkRenderer::PickGeometry ( ) [protected, virtual]

void vtkRenderer::AllocateTime ( ) [protected]

virtual int vtkRenderer::UpdateGeometry ( void ) [protected, virtual]

Ask all props to update and draw any opaque and translucent geometry. This includes both vtkActors and vtkVolumes Returns the number of props that rendered geometry.

virtual int vtkRenderer::UpdateCamera ( void ) [protected, virtual]

Ask the active camera to do whatever it needs to do prior to rendering. Creates a camera if none found active.

virtual int vtkRenderer::UpdateLightGeometry ( void ) [protected, virtual]

Update the geometry of the lights in the scene that are not in world space (for instance, Headlights or CameraLights that are attached to the camera).

virtual int vtkRenderer::UpdateLights ( void ) [inline, protected, virtual]

Ask all lights to load themselves into rendering pipeline. This method will return the actual number of lights that were on.

Reimplemented in vtkMesaRenderer, and vtkOpenGLRenderer.

Definition at line 395 of file vtkRenderer.h.

Member Data Documentation

vtkCamera* vtkRenderer::ActiveCamera [protected]

Definition at line 331 of file vtkRenderer.h.

vtkLight* vtkRenderer::CreatedLight [protected]

Definition at line 332 of file vtkRenderer.h.

vtkLightCollection* vtkRenderer::Lights [protected]

Definition at line 334 of file vtkRenderer.h.

vtkCullerCollection* vtkRenderer::Cullers [protected]

Definition at line 335 of file vtkRenderer.h.

vtkActorCollection* vtkRenderer::Actors [protected]

Definition at line 337 of file vtkRenderer.h.

vtkVolumeCollection* vtkRenderer::Volumes [protected]

Definition at line 338 of file vtkRenderer.h.

float vtkRenderer::Ambient[3] [protected]

Definition at line 340 of file vtkRenderer.h.

vtkRenderWindow* vtkRenderer::RenderWindow [protected]

Definition at line 341 of file vtkRenderer.h.

float vtkRenderer::AllocatedRenderTime [protected]

Definition at line 342 of file vtkRenderer.h.

float vtkRenderer::TimeFactor [protected]

Definition at line 343 of file vtkRenderer.h.

int vtkRenderer::TwoSidedLighting [protected]

Definition at line 344 of file vtkRenderer.h.

int vtkRenderer::BackingStore [protected]

Definition at line 345 of file vtkRenderer.h.

unsigned char* vtkRenderer::BackingImage [protected]

Definition at line 346 of file vtkRenderer.h.

vtkTimeStamp vtkRenderer::RenderTime [protected]

Definition at line 347 of file vtkRenderer.h.

float vtkRenderer::LastRenderTimeInSeconds [protected]

Definition at line 349 of file vtkRenderer.h.

int vtkRenderer::LightFollowCamera [protected]

Definition at line 351 of file vtkRenderer.h.

int vtkRenderer::NumberOfPropsRenderedAsGeometry [protected]

Definition at line 358 of file vtkRenderer.h.

int vtkRenderer::NumberOfPropsToRayCast [protected]

Definition at line 359 of file vtkRenderer.h.

int vtkRenderer::NumberOfPropsToRenderIntoImage [protected]

Definition at line 360 of file vtkRenderer.h.

vtkProp** vtkRenderer::PropArray [protected]

Definition at line 364 of file vtkRenderer.h.

int vtkRenderer::PropArrayCount [protected]

Definition at line 365 of file vtkRenderer.h.

vtkAssemblyPath** vtkRenderer::PathArray [protected]

Definition at line 368 of file vtkRenderer.h.

int vtkRenderer::PathArrayCount [protected]

Definition at line 369 of file vtkRenderer.h.

int vtkRenderer::Interactive [protected]

Definition at line 373 of file vtkRenderer.h.

int vtkRenderer::Layer [protected]

Definition at line 377 of file vtkRenderer.h.

vtkRayCaster* vtkRenderer::RayCaster [protected]

Definition at line 397 of file vtkRenderer.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRenderer.h
Generated on Mon Mar 25 01:29:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRendererCollection Class Reference

a list of renderers. More...

#include <vtkRendererCollection.h>

Inheritance diagram for vtkRendererCollection:

[legend]
Collaboration diagram for vtkRendererCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRendererCollection, vtkCollection)
void | AddItem (vtkRenderer *a)
vtkRenderer * GetNextItem ()
void | Render ()
void | RenderOverlay ()

Static Public Methods

vtkRendererCollection * | New ()

Protected Methods

vtkRendererCollection ()
~vtkRendererCollection ()

Detailed Description

a list of renderers.

Date:
2002/01/22 15:39:22
Revision:
1.41

vtkRendererCollection represents and provides methods to manipulate a list of renderers (i.e., vtkRenderer and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkRenderer vtkCollection
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (63%)
  • Childs, Hank (17%)
  • Schroeder, Will (11%)

Definition at line 44 of file vtkRendererCollection.h.

Constructor & Destructor Documentation

vtkRendererCollection::vtkRendererCollection ( ) [inline, protected]

Definition at line 70 of file vtkRendererCollection.h.

vtkRendererCollection::~vtkRendererCollection ( ) [inline, protected]

Definition at line 71 of file vtkRendererCollection.h.

Member Function Documentation

vtkRendererCollection* vtkRendererCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkRendererCollection::vtkTypeRevisionMacro | ( | vtkRendererCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkRendererCollection::AddItem ( vtkRenderer * a ) [inline]

Add a Renderer to the list.

Definition at line 52 of file vtkRendererCollection.h.

vtkRenderer* vtkRendererCollection::GetNextItem ( ) [inline]

Get the next Renderer in the list. Return NULL when at the end of the list.

Definition at line 59 of file vtkRendererCollection.h.

void vtkRendererCollection::Render ( void )

Forward the Render() method to each renderer in the list.

void vtkRendererCollection::RenderOverlay ( )

Forward the Render() method to each renderer in the list.

The documentation for this class was generated from the following file:
  • Rendering/vtkRendererCollection.h
Generated on Mon Mar 25 01:29:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRendererSource Class Reference

take a renderer into the pipeline. More...

#include <vtkRendererSource.h>

Inheritance diagram for vtkRendererSource:

[legend]
Collaboration diagram for vtkRendererSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRendererSource, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetInput (vtkRenderer *)
virtual vtkRenderer * | GetInput ()
virtual void | SetWholeWindow (int)
virtual int | GetWholeWindow ()
virtual void | WholeWindowOn ()
virtual void | WholeWindowOff ()
virtual void | SetRenderFlag (int)
virtual int | GetRenderFlag ()
virtual void | RenderFlagOn ()
virtual void | RenderFlagOff ()
virtual void | SetDepthValues (int)
virtual int | GetDepthValues ()
virtual void | DepthValuesOn ()
virtual void | DepthValuesOff ()

Static Public Methods

vtkRendererSource * | New ()

Protected Methods

vtkRendererSource ()
~vtkRendererSource ()
void | Execute ()
void | UpdateInformation ()

Protected Attributes

vtkRenderer * Input
int | WholeWindow
int | RenderFlag
int | DepthValues

Detailed Description

take a renderer into the pipeline.

Date:
2002/01/22 15:39:22
Revision:
1.37

vtkRendererSource is a source object that gets its input from a renderer and converts it to structured points. This can then be used in a visualization pipeline. You must explicitly send a Modify() to this object to get it to reload its data from the renderer. Consider using vtkWindowToImageFilter instead of this class.

The data placed into the output is the renderer's image rgb values. Optionally, you can also grab the image depth (e.g., z-buffer) values, and place then into the output (point) field data.

See also:
vtkWindowToImageFilter vtkRenderer vtkStructuredPoints
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (48%)
  • Law, Charles (29%)
  • Schroeder, Will (14%)
Tests:
vtkRendererSource (Tests)

Definition at line 54 of file vtkRendererSource.h.

Constructor & Destructor Documentation

vtkRendererSource::vtkRendererSource ( ) [protected]

vtkRendererSource::~vtkRendererSource ( ) [protected]

Member Function Documentation

vtkRendererSource* vtkRendererSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredPointsSource.

vtkRendererSource::vtkTypeRevisionMacro | ( | vtkRendererSource | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

void vtkRendererSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

unsigned long vtkRendererSource::GetMTime ( ) [virtual]

Return the MTime also considering the Renderer.

Reimplemented from vtkObject.

virtual void vtkRendererSource::SetInput ( vtkRenderer * ) [virtual]

Indicates what renderer to get the pixel data from.

virtual vtkRenderer* vtkRendererSource::GetInput ( ) [virtual]

Returns which renderer is being used as the source for the pixel data.

virtual void vtkRendererSource::SetWholeWindow ( int ) [virtual]

Use the entire RenderWindow as a data source or just the Renderer. The default is zero, just the Renderer.

virtual int vtkRendererSource::GetWholeWindow ( ) [virtual]

Use the entire RenderWindow as a data source or just the Renderer. The default is zero, just the Renderer.

virtual void vtkRendererSource::WholeWindowOn ( ) [virtual]

Use the entire RenderWindow as a data source or just the Renderer. The default is zero, just the Renderer.

virtual void vtkRendererSource::WholeWindowOff ( ) [virtual]

Use the entire RenderWindow as a data source or just the Renderer. The default is zero, just the Renderer.

virtual void vtkRendererSource::SetRenderFlag ( int ) [virtual]

If this flag is on, the Executing causes a render first.

virtual int vtkRendererSource::GetRenderFlag ( ) [virtual]

If this flag is on, the Executing causes a render first.

virtual void vtkRendererSource::RenderFlagOn ( ) [virtual]

If this flag is on, the Executing causes a render first.

virtual void vtkRendererSource::RenderFlagOff ( ) [virtual]

If this flag is on, the Executing causes a render first.

virtual void vtkRendererSource::SetDepthValues ( int ) [virtual]

A boolean value to control whether to grab z-buffer (i.e., depth values) along with the image data. The z-buffer data is placed into the field data attributes.

virtual int vtkRendererSource::GetDepthValues ( ) [virtual]

A boolean value to control whether to grab z-buffer (i.e., depth values) along with the image data. The z-buffer data is placed into the field data attributes.

virtual void vtkRendererSource::DepthValuesOn ( ) [virtual]

A boolean value to control whether to grab z-buffer (i.e., depth values) along with the image data. The z-buffer data is placed into the field data attributes.

virtual void vtkRendererSource::DepthValuesOff ( ) [virtual]

A boolean value to control whether to grab z-buffer (i.e., depth values) along with the image data. The z-buffer data is placed into the field data attributes.

void vtkRendererSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkRendererSource::UpdateInformation ( ) [protected, virtual]

Updates any global information about the data (like spacing for images)

Reimplemented from vtkSource.

Member Data Documentation

vtkRenderer* vtkRendererSource::Input [protected]

Definition at line 107 of file vtkRendererSource.h.

int vtkRendererSource::WholeWindow [protected]

Definition at line 108 of file vtkRendererSource.h.

int vtkRendererSource::RenderFlag [protected]

Definition at line 109 of file vtkRendererSource.h.

int vtkRendererSource::DepthValues [protected]

Definition at line 110 of file vtkRendererSource.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRendererSource.h
Generated on Mon Mar 25 01:29:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderLargeImage Class Reference

Use tiling to generate a large rendering. More...

#include <vtkRenderLargeImage.h>

Inheritance diagram for vtkRenderLargeImage:

[legend]
Collaboration diagram for vtkRenderLargeImage:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRenderLargeImage, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMagnification (int)
virtual int | GetMagnification ()
virtual void | SetInput (vtkRenderer *)
virtual vtkRenderer * | GetInput ()

Static Public Methods

vtkRenderLargeImage * | New ()

Protected Methods

vtkRenderLargeImage ()
~vtkRenderLargeImage ()
void | ExecuteData (vtkDataObject *data)
void | ExecuteInformation ()

Protected Attributes

int | Magnification
vtkRenderer * Input

Detailed Description

Use tiling to generate a large rendering.

Date:
2002/01/22 15:30:38
Revision:
1.22

vtkRenderLargeImage provides methods needed to read a region from a file.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (89%)
  • Gobbi, David (5%)
Examples:
vtkRenderLargeImage (Examples)
Tests:
vtkRenderLargeImage (Tests)

Definition at line 44 of file vtkRenderLargeImage.h.

Constructor & Destructor Documentation

vtkRenderLargeImage::vtkRenderLargeImage ( ) [protected]

vtkRenderLargeImage::~vtkRenderLargeImage ( ) [protected]

Member Function Documentation

vtkRenderLargeImage* vtkRenderLargeImage::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkRenderLargeImage::vtkTypeRevisionMacro | ( | vtkRenderLargeImage | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkRenderLargeImage::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkRenderLargeImage::SetMagnification ( int ) [virtual]

The magnification of the current render window

virtual int vtkRenderLargeImage::GetMagnification ( ) [virtual]

The magnification of the current render window

virtual void vtkRenderLargeImage::SetInput ( vtkRenderer * ) [virtual]

Indicates what renderer to get the pixel data from.

virtual vtkRenderer* vtkRenderLargeImage::GetInput ( ) [virtual]

Returns which renderer is being used as the source for the pixel data.

void vtkRenderLargeImage::ExecuteData ( vtkDataObject * data ) [protected]

void vtkRenderLargeImage::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

int vtkRenderLargeImage::Magnification [protected]

Definition at line 72 of file vtkRenderLargeImage.h.

vtkRenderer* vtkRenderLargeImage::Input [protected]

Definition at line 73 of file vtkRenderLargeImage.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkRenderLargeImage.h
Generated on Mon Mar 25 01:30:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindow Class Reference

create a window for renderers to draw into. More...

#include <vtkRenderWindow.h>

Inheritance diagram for vtkRenderWindow:

[legend]
Collaboration diagram for vtkRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRenderWindow, vtkWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddRenderer (vtkRenderer *)
void | RemoveRenderer (vtkRenderer *)
vtkRendererCollection * GetRenderers ()
virtual void | Render ()
virtual void | Start ()
virtual void | Frame ()
virtual void | CopyResultFrame ()
virtual vtkRenderWindowInteractor * | MakeRenderWindowInteractor ()
virtual void | StereoUpdate ()
virtual void | StereoMidpoint ()
virtual void | StereoRenderComplete ()
virtual void | WindowRemap ()
virtual void | SetPixelData (int, int, int, int, unsigned char *, int)
virtual int | CheckInRenderStatus ()
virtual void | ClearInRenderStatus ()
void | SetAbortCheckMethod (void(*f)(void *), void *arg)
void | SetAbortCheckMethodArgDelete (void(*f)(void *))
void | UnRegister (vtkObject *o)
virtual void | MakeCurrent ()
virtual int | GetDepthBufferSize ()
virtual void | HideCursor ()
virtual void | ShowCursor ()
virtual void | SetFullScreen (int)
virtual int | GetFullScreen ()
virtual void | FullScreenOn ()
virtual void | FullScreenOff ()
virtual void | SetBorders (int)
virtual int | GetBorders ()
virtual void | BordersOn ()
virtual void | BordersOff ()
virtual int | GetStereoCapableWindow ()
virtual void | StereoCapableWindowOn ()
virtual void | StereoCapableWindowOff ()
virtual void | SetStereoCapableWindow (int capable)
virtual int | GetStereoRender ()
void | SetStereoRender (int stereo)
virtual void | StereoRenderOn ()
virtual void | StereoRenderOff ()
virtual void | SetPointSmoothing (int)
virtual int | GetPointSmoothing ()
virtual void | PointSmoothingOn ()
virtual void | PointSmoothingOff ()
virtual void | SetLineSmoothing (int)
virtual int | GetLineSmoothing ()
virtual void | LineSmoothingOn ()
virtual void | LineSmoothingOff ()
virtual void | SetPolygonSmoothing (int)
virtual int | GetPolygonSmoothing ()
virtual void | PolygonSmoothingOn ()
virtual void | PolygonSmoothingOff ()
virtual int | GetStereoType ()
virtual void | SetStereoType (int)
void | SetStereoTypeToCrystalEyes ()
void | SetStereoTypeToRedBlue ()
void | SetStereoTypeToInterlaced ()
void | SetStereoTypeToLeft ()
void | SetStereoTypeToRight ()
void | SetStereoTypeToDresden ()
char * | GetStereoTypeAsString ()
virtual void | SetSwapBuffers (int)
virtual int | GetSwapBuffers ()
virtual void | SwapBuffersOn ()
virtual void | SwapBuffersOff ()
virtual float * | GetRGBAPixelData (int,int,int,int,int)
virtual void | SetRGBAPixelData (int,int,int,int,float *, int, int blend=0)
virtual unsigned char * | GetRGBACharPixelData (int,int,int,int,int)
virtual void | SetRGBACharPixelData (int,int,int,int,unsigned char *, int, int blend=0)
virtual float * | GetZbufferData (int, int, int, int)
virtual void | SetZbufferData (int, int, int, int, float *)
virtual int | GetAAFrames ()
virtual void | SetAAFrames (int)
virtual int | GetFDFrames ()
virtual void | SetFDFrames (int)
virtual int | GetSubFrames ()
virtual void | SetSubFrames (int)
virtual int | GetNeverRendered ()
virtual int | GetAbortRender ()
virtual void | SetAbortRender (int)
virtual int | GetInAbortCheck ()
virtual void | SetInAbortCheck (int)
virtual int | CheckAbortStatus ()
virtual int | GetEventPending ()
void | SetDesiredUpdateRate (float)
virtual float | GetDesiredUpdateRate ()
virtual int | GetNumberOfLayers ()
virtual void | SetNumberOfLayers (int)
virtual vtkRenderWindowInteractor * | GetInteractor ()
void | SetInteractor (vtkRenderWindowInteractor *)
virtual void | SetDisplayId (void *)
virtual void | SetWindowId (void *)
virtual void | SetParentId (void *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void * | GetGenericDrawable ()
virtual void | SetWindowInfo (char *)
virtual void | SetParentInfo (char *)

Static Public Methods

vtkRenderWindow * | New ()
const char * | GetRenderLibrary ()

Protected Methods

vtkRenderWindow ()
~vtkRenderWindow ()
virtual void | DoStereoRender ()
virtual void | DoFDRender ()
virtual void | DoAARender ()

Protected Attributes

vtkRendererCollection * Renderers
int | Borders
int | FullScreen
int | OldScreen [5]
int | PointSmoothing
int | LineSmoothing
int | PolygonSmoothing
int | StereoRender
int | StereoType
int | StereoStatus
int | StereoCapableWindow
vtkRenderWindowInteractor * Interactor
unsigned char * | StereoBuffer
float * | AccumulationBuffer
unsigned int | AccumulationBufferSize
int | AAFrames
int | FDFrames
int | SubFrames
int | CurrentSubFrame
unsigned char * | ResultFrame
int | SwapBuffers
float | DesiredUpdateRate
int | AbortRender
int | InAbortCheck
int | InRender
int | NeverRendered
int | NumberOfLayers
void(* | AbortCheckMethod )(void *)
void(* | AbortCheckMethodArgDelete )(void *)
void * | AbortCheckMethodArg

Detailed Description

create a window for renderers to draw into.

Date:
2002/02/21 22:15:16
Revision:
1.119

vtkRenderWindow is an abstract object to specify the behavior of a rendering window. A rendering window is a window in a graphical user interface where renderers draw their images. Methods are provided to synchronize the rendering process, set window size, and control double buffering. The window also allows rendering in stereo. The interlaced render stereo type is for output to a VRex stereo projector. All of the odd horizontal lines are from the left eye, and the even lines are from the right eye. The user has to make the render window aligned with the VRex projector, or the eye will be swapped.

Warning:
In VTK versions 4 and later, the vtkWindowToImageFilter class is part of the canonical way to output an image of a window to a file (replacing the obsolete SaveImageAsPPM method for vtkRenderWindows that existed in 3.2 and earlier). Connect one of these filters to the output of the window, and filter's output to a writer such as vtkPNGWriter.
See also:
vtkRenderer vtkRenderWindowInteractor vtkWindowToImageFilter
Events:
vtkCommand::StartEvent vtkCommand::EndEvent vtkCommand::AbortCheckEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (62%)
  • Schroeder, Will (9%)
  • Law, Charles (5%)
Examples:
vtkRenderWindow (Examples)
Tests:
vtkRenderWindow (Tests)

Definition at line 81 of file vtkRenderWindow.h.

Constructor & Destructor Documentation

vtkRenderWindow::vtkRenderWindow ( ) [protected]

vtkRenderWindow::~vtkRenderWindow ( ) [protected]

Member Function Documentation

vtkRenderWindow::vtkTypeRevisionMacro | ( | vtkRenderWindow | ,
 |  | vtkWindow |
 | ) |

Reimplemented from vtkWindow.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

void vtkRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

vtkRenderWindow* vtkRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkObject.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

void vtkRenderWindow::AddRenderer ( vtkRenderer * )

Add a renderer to the list of renderers.

void vtkRenderWindow::RemoveRenderer ( vtkRenderer * )

Remove a renderer from the list of renderers.

const char* vtkRenderWindow::GetRenderLibrary ( ) [inline, static]

What rendering library has the user requested

Definition at line 100 of file vtkRenderWindow.h.

vtkRendererCollection* vtkRenderWindow::GetRenderers ( ) [inline]

Return the collection of renderers in the render window.

Definition at line 105 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::Render ( void ) [virtual]

Ask each renderer owned by this RenderWindow to render its image and synchronize this process.

Reimplemented from vtkWindow.

Reimplemented in vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Referenced by Java_vtkPanel_RenderCreate().

virtual void vtkRenderWindow::Start ( void ) [inline, virtual]

Initialize the rendering process.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 112 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::Frame ( void ) [inline, virtual]

A termination method performed at the end of the rendering process to do things like swapping buffers (if necessary) or similar actions.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 116 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::CopyResultFrame ( ) [virtual]

Performed at the end of the rendering process to generate image. This is typically done right before swapping buffers.

virtual vtkRenderWindowInteractor* vtkRenderWindow::MakeRenderWindowInteractor ( ) [virtual]

Create an interactor to control renderers in this window. We need to know what type of interactor to create, because we might be in X Windows or MS Windows.

virtual void vtkRenderWindow::HideCursor ( ) [inline, virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 130 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::ShowCursor ( ) [inline, virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 131 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetFullScreen ( int ) [inline, virtual]

Turn on/off rendering full screen window size.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 136 of file vtkRenderWindow.h.

virtual int vtkRenderWindow::GetFullScreen ( ) [virtual]

Turn on/off rendering full screen window size.

virtual void vtkRenderWindow::FullScreenOn ( ) [virtual]

Turn on/off rendering full screen window size.

virtual void vtkRenderWindow::FullScreenOff ( ) [virtual]

Turn on/off rendering full screen window size.

virtual void vtkRenderWindow::SetBorders ( int ) [virtual]

Turn on/off window manager borders. Typically, you shouldn't turn the borders off, because that bypasses the window manager and can cause undesirable behavior.

virtual int vtkRenderWindow::GetBorders ( ) [virtual]

Turn on/off window manager borders. Typically, you shouldn't turn the borders off, because that bypasses the window manager and can cause undesirable behavior.

virtual void vtkRenderWindow::BordersOn ( ) [virtual]

Turn on/off window manager borders. Typically, you shouldn't turn the borders off, because that bypasses the window manager and can cause undesirable behavior.

virtual void vtkRenderWindow::BordersOff ( ) [virtual]

Turn on/off window manager borders. Typically, you shouldn't turn the borders off, because that bypasses the window manager and can cause undesirable behavior.

virtual int vtkRenderWindow::GetStereoCapableWindow ( ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. Default if off.

virtual void vtkRenderWindow::StereoCapableWindowOn ( ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. Default if off.

virtual void vtkRenderWindow::StereoCapableWindowOff ( ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. Default if off.

virtual void vtkRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. Default if off.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual int vtkRenderWindow::GetStereoRender ( ) [virtual]

Turn on/off stereo rendering.

void vtkRenderWindow::SetStereoRender ( int stereo )

Turn on/off stereo rendering.

virtual void vtkRenderWindow::StereoRenderOn ( ) [virtual]

Turn on/off stereo rendering.

virtual void vtkRenderWindow::StereoRenderOff ( ) [virtual]

Turn on/off stereo rendering.

virtual void vtkRenderWindow::SetPointSmoothing ( int ) [virtual]

Turn on/off point smoothing. Default is off. This must be applied before the first Render.

virtual int vtkRenderWindow::GetPointSmoothing ( ) [virtual]

Turn on/off point smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::PointSmoothingOn ( ) [virtual]

Turn on/off point smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::PointSmoothingOff ( ) [virtual]

Turn on/off point smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::SetLineSmoothing ( int ) [virtual]

Turn on/off line smoothing. Default is off. This must be applied before the first Render.

virtual int vtkRenderWindow::GetLineSmoothing ( ) [virtual]

Turn on/off line smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::LineSmoothingOn ( ) [virtual]

Turn on/off line smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::LineSmoothingOff ( ) [virtual]

Turn on/off line smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::SetPolygonSmoothing ( int ) [virtual]

Turn on/off polygon smoothing. Default is off. This must be applied before the first Render.

virtual int vtkRenderWindow::GetPolygonSmoothing ( ) [virtual]

Turn on/off polygon smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::PolygonSmoothingOn ( ) [virtual]

Turn on/off polygon smoothing. Default is off. This must be applied before the first Render.

virtual void vtkRenderWindow::PolygonSmoothingOff ( ) [virtual]

Turn on/off polygon smoothing. Default is off. This must be applied before the first Render.

virtual int vtkRenderWindow::GetStereoType ( ) [virtual]

Set/Get what type of stereo rendering to use.

virtual void vtkRenderWindow::SetStereoType ( int ) [virtual]

Set/Get what type of stereo rendering to use.

void vtkRenderWindow::SetStereoTypeToCrystalEyes ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 193 of file vtkRenderWindow.h.

void vtkRenderWindow::SetStereoTypeToRedBlue ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 195 of file vtkRenderWindow.h.

void vtkRenderWindow::SetStereoTypeToInterlaced ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 197 of file vtkRenderWindow.h.

void vtkRenderWindow::SetStereoTypeToLeft ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 199 of file vtkRenderWindow.h.

void vtkRenderWindow::SetStereoTypeToRight ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 201 of file vtkRenderWindow.h.

void vtkRenderWindow::SetStereoTypeToDresden ( ) [inline]

Set/Get what type of stereo rendering to use.

Definition at line 203 of file vtkRenderWindow.h.

char * vtkRenderWindow::GetStereoTypeAsString ( void ) [inline]

Return the stereo type as a character string.

Definition at line 417 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::StereoUpdate ( ) [virtual]

Update the system, if needed, due to stereo rendering. For some stereo methods, subclasses might need to switch some hardware settings here.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

virtual void vtkRenderWindow::StereoMidpoint ( ) [virtual]

Intermediate method performs operations required between the rendering of the left and right eye.

virtual void vtkRenderWindow::StereoRenderComplete ( ) [virtual]

Handles work required once both views have been rendered when using stereo rendering.

virtual void vtkRenderWindow::WindowRemap ( void ) [inline, virtual]

Remap the rendering window. This probably only works on UNIX right now. It is useful for changing properties that can't normally be changed once the window is up.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 224 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetSwapBuffers ( int ) [virtual]

Turn on/off buffer swapping between images.

virtual int vtkRenderWindow::GetSwapBuffers ( ) [virtual]

Turn on/off buffer swapping between images.

virtual void vtkRenderWindow::SwapBuffersOn ( ) [virtual]

Turn on/off buffer swapping between images.

virtual void vtkRenderWindow::SwapBuffersOff ( ) [virtual]

Turn on/off buffer swapping between images.

virtual void vtkRenderWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [inline, virtual]

Set/Get the pixel data of an image, transmitted as RGBRGBRGB. The front argument indicates if the front buffer should be used or the back buffer. It is the caller's responsibility to delete the resulting array. It is very important to realize that the memory in this array is organized from the bottom of the window to the top. The origin of the screen is in the lower left corner. The y axis increases as you go up the screen. So the storage of pixels is from left to right and from bottom to top.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 241 of file vtkRenderWindow.h.

virtual float* vtkRenderWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [inline, virtual]

Same as Get/SetPixelData except that the image also contains an alpha component. The image is transmitted as RGBARGBARGBA... each of which is a float value. The "blend" parameter controls whether the SetRGBAPixelData method blends the data with the previous contents of the frame buffer or completely replaces the frame buffer data.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 249 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [inline, virtual]

Same as Get/SetPixelData except that the image also contains an alpha component. The image is transmitted as RGBARGBARGBA... each of which is a float value. The "blend" parameter controls whether the SetRGBAPixelData method blends the data with the previous contents of the frame buffer or completely replaces the frame buffer data.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 251 of file vtkRenderWindow.h.

virtual unsigned char* vtkRenderWindow::GetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [inline, virtual]

Same as Get/SetPixelData except that the image also contains an alpha component. The image is transmitted as RGBARGBARGBA... each of which is a float value. The "blend" parameter controls whether the SetRGBAPixelData method blends the data with the previous contents of the frame buffer or completely replaces the frame buffer data.

Reimplemented in vtkMesaRenderWindow, and vtkOpenGLRenderWindow.

Definition at line 253 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetRGBACharPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [inline, virtual]

Same as Get/SetPixelData except that the image also contains an alpha component. The image is transmitted as RGBARGBARGBA... each of which is a float value. The "blend" parameter controls whether the SetRGBAPixelData method blends the data with the previous contents of the frame buffer or completely replaces the frame buffer data.

Reimplemented in vtkMesaRenderWindow, and vtkOpenGLRenderWindow.

Definition at line 255 of file vtkRenderWindow.h.

virtual float* vtkRenderWindow::GetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) | [inline, virtual]

Set/Get the zbuffer data from the frame buffer.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 262 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetZbufferData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | float * | buffer
 | ) | [inline, virtual]

Set/Get the zbuffer data from the frame buffer.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 263 of file vtkRenderWindow.h.

virtual int vtkRenderWindow::GetAAFrames ( ) [virtual]

Set the number of frames for doing antialiasing. The default is zero. Typically five or six will yield reasonable results without taking too long.

virtual void vtkRenderWindow::SetAAFrames ( int ) [virtual]

Set the number of frames for doing antialiasing. The default is zero. Typically five or six will yield reasonable results without taking too long.

virtual int vtkRenderWindow::GetFDFrames ( ) [virtual]

Set the number of frames for doing focal depth. The default is zero. Depending on how your scene is organized you can get away with as few as four frames for focal depth or you might need thirty. One thing to note is that if you are using focal depth frames, then you will not need many (if any) frames for antialiasing.

virtual void vtkRenderWindow::SetFDFrames ( int ) [virtual]

Set the number of frames for doing focal depth. The default is zero. Depending on how your scene is organized you can get away with as few as four frames for focal depth or you might need thirty. One thing to note is that if you are using focal depth frames, then you will not need many (if any) frames for antialiasing.

virtual int vtkRenderWindow::GetSubFrames ( ) [virtual]

Set the number of sub frames for doing motion blur. The default is zero. Once this is set greater than one, you will no longer see a new frame for every Render(). If you set this to five, you will need to do five Render() invocations before seeing the result. This isn't very impressive unless something is changing between the Renders.

virtual void vtkRenderWindow::SetSubFrames ( int ) [virtual]

Set the number of sub frames for doing motion blur. The default is zero. Once this is set greater than one, you will no longer see a new frame for every Render(). If you set this to five, you will need to do five Render() invocations before seeing the result. This isn't very impressive unless something is changing between the Renders.

virtual int vtkRenderWindow::GetNeverRendered ( ) [virtual]

This flag is set if the window hasn't rendered since it was created

virtual int vtkRenderWindow::GetAbortRender ( ) [virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

virtual void vtkRenderWindow::SetAbortRender ( int ) [virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

virtual int vtkRenderWindow::GetInAbortCheck ( ) [virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

virtual void vtkRenderWindow::SetInAbortCheck ( int ) [virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

virtual int vtkRenderWindow::CheckAbortStatus ( ) [virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

virtual int vtkRenderWindow::GetEventPending ( ) [inline, virtual]

This is a flag that can be set to interrupt a rendering that is in progress.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 307 of file vtkRenderWindow.h.

virtual int vtkRenderWindow::CheckInRenderStatus ( ) [inline, virtual]

Are we rendering at the moment

Definition at line 311 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::ClearInRenderStatus ( ) [inline, virtual]

Clear status (after an exception was thrown for example)

Definition at line 314 of file vtkRenderWindow.h.

void vtkRenderWindow::SetAbortCheckMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a function to be called to check and see if an abort of the rendering in progress is desired.

void vtkRenderWindow::SetAbortCheckMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkRenderWindow::SetDesiredUpdateRate ( float )

Set/Get the desired update rate. This is used with the vtkLODActor class. When using level of detail actors you need to specify what update rate you require. The LODActors then will pick the correct resolution to meet your desired update rate in frames per second. A value of zero indicates that they can use all the time they want to.

virtual float vtkRenderWindow::GetDesiredUpdateRate ( ) [virtual]

Set/Get the desired update rate. This is used with the vtkLODActor class. When using level of detail actors you need to specify what update rate you require. The LODActors then will pick the correct resolution to meet your desired update rate in frames per second. A value of zero indicates that they can use all the time they want to.

virtual int vtkRenderWindow::GetNumberOfLayers ( ) [virtual]

Get the number of layers for renderers. Each renderer should have its layer set individually. Some algorithms iterate through all layers, so it is not wise to set the number of layers to be exorbitantly large (say bigger than 100).

virtual void vtkRenderWindow::SetNumberOfLayers ( int ) [virtual]

Get the number of layers for renderers. Each renderer should have its layer set individually. Some algorithms iterate through all layers, so it is not wise to set the number of layers to be exorbitantly large (say bigger than 100).

virtual vtkRenderWindowInteractor* vtkRenderWindow::GetInteractor ( ) [virtual]

Get the interactor associated with this render window

void vtkRenderWindow::SetInteractor ( vtkRenderWindowInteractor * )

Get the interactor associated with this render window

void vtkRenderWindow::UnRegister ( vtkObject * o ) [virtual]

This Method detects loops of RenderWindow<->Interactor, so objects are freed properly.

Reimplemented from vtkObject.

virtual void vtkRenderWindow::SetDisplayId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 354 of file vtkRenderWindow.h.

Referenced by Java_vtkPanel_RenderCreate().

virtual void vtkRenderWindow::SetWindowId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 355 of file vtkRenderWindow.h.

Referenced by Java_vtkPanel_RenderCreate(), vtkWinCEOpenGLRenderWindow::SetWindowId(), and vtkWin32OpenGLRenderWindow::SetWindowId().

virtual void vtkRenderWindow::SetParentId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 356 of file vtkRenderWindow.h.

Referenced by vtkWinCEOpenGLRenderWindow::SetParentId(), and vtkWin32OpenGLRenderWindow::SetParentId().

virtual void* vtkRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 357 of file vtkRenderWindow.h.

virtual void* vtkRenderWindow::GetGenericWindowId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 358 of file vtkRenderWindow.h.

virtual void* vtkRenderWindow::GetGenericParentId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 359 of file vtkRenderWindow.h.

virtual void* vtkRenderWindow::GetGenericContext ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 360 of file vtkRenderWindow.h.

virtual void* vtkRenderWindow::GetGenericDrawable ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 361 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetWindowInfo ( char * info ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 362 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::SetParentInfo ( char * info ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkWindow.

Reimplemented in vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 363 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::MakeCurrent ( ) [inline, virtual]

Make this the current window.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, vtkQuartzRenderWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 367 of file vtkRenderWindow.h.

virtual int vtkRenderWindow::GetDepthBufferSize ( ) [inline, virtual]

This method should be defined by the subclass. How many bits of precision are there in the zbuffer?

Reimplemented in vtkMesaRenderWindow, vtkOpenGLRenderWindow, and vtkQuartzRenderWindow.

Definition at line 371 of file vtkRenderWindow.h.

virtual void vtkRenderWindow::DoStereoRender ( ) [protected, virtual]

virtual void vtkRenderWindow::DoFDRender ( ) [protected, virtual]

virtual void vtkRenderWindow::DoAARender ( ) [protected, virtual]

Member Data Documentation

vtkRendererCollection* vtkRenderWindow::Renderers [protected]

Definition at line 381 of file vtkRenderWindow.h.

int vtkRenderWindow::Borders [protected]

Definition at line 382 of file vtkRenderWindow.h.

int vtkRenderWindow::FullScreen [protected]

Definition at line 383 of file vtkRenderWindow.h.

int vtkRenderWindow::OldScreen[5] [protected]

Definition at line 384 of file vtkRenderWindow.h.

int vtkRenderWindow::PointSmoothing [protected]

Definition at line 385 of file vtkRenderWindow.h.

int vtkRenderWindow::LineSmoothing [protected]

Definition at line 386 of file vtkRenderWindow.h.

int vtkRenderWindow::PolygonSmoothing [protected]

Definition at line 387 of file vtkRenderWindow.h.

int vtkRenderWindow::StereoRender [protected]

Definition at line 388 of file vtkRenderWindow.h.

int vtkRenderWindow::StereoType [protected]

Definition at line 389 of file vtkRenderWindow.h.

int vtkRenderWindow::StereoStatus [protected]

Definition at line 390 of file vtkRenderWindow.h.

int vtkRenderWindow::StereoCapableWindow [protected]

Definition at line 391 of file vtkRenderWindow.h.

vtkRenderWindowInteractor* vtkRenderWindow::Interactor [protected]

Definition at line 392 of file vtkRenderWindow.h.

unsigned char* vtkRenderWindow::StereoBuffer [protected]

Definition at line 393 of file vtkRenderWindow.h.

float* vtkRenderWindow::AccumulationBuffer [protected]

Definition at line 394 of file vtkRenderWindow.h.

unsigned int vtkRenderWindow::AccumulationBufferSize [protected]

Definition at line 395 of file vtkRenderWindow.h.

int vtkRenderWindow::AAFrames [protected]

Definition at line 396 of file vtkRenderWindow.h.

int vtkRenderWindow::FDFrames [protected]

Definition at line 397 of file vtkRenderWindow.h.

int vtkRenderWindow::SubFrames [protected]

Definition at line 398 of file vtkRenderWindow.h.

int vtkRenderWindow::CurrentSubFrame [protected]

Definition at line 399 of file vtkRenderWindow.h.

unsigned char* vtkRenderWindow::ResultFrame [protected]

Definition at line 400 of file vtkRenderWindow.h.

int vtkRenderWindow::SwapBuffers [protected]

Definition at line 401 of file vtkRenderWindow.h.

float vtkRenderWindow::DesiredUpdateRate [protected]

Definition at line 402 of file vtkRenderWindow.h.

int vtkRenderWindow::AbortRender [protected]

Definition at line 403 of file vtkRenderWindow.h.

int vtkRenderWindow::InAbortCheck [protected]

Definition at line 404 of file vtkRenderWindow.h.

int vtkRenderWindow::InRender [protected]

Definition at line 405 of file vtkRenderWindow.h.

int vtkRenderWindow::NeverRendered [protected]

Definition at line 406 of file vtkRenderWindow.h.

int vtkRenderWindow::NumberOfLayers [protected]

Definition at line 407 of file vtkRenderWindow.h.

void(* vtkRenderWindow::AbortCheckMethod)(void *) [protected]

void(* vtkRenderWindow::AbortCheckMethodArgDelete)(void *) [protected]

void* vtkRenderWindow::AbortCheckMethodArg [protected]

Definition at line 410 of file vtkRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRenderWindow.h
Generated on Mon Mar 25 01:30:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindowCollection Class Reference

a list of RenderWindows. More...

#include <vtkRenderWindowCollection.h>

Inheritance diagram for vtkRenderWindowCollection:

[legend]
Collaboration diagram for vtkRenderWindowCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRenderWindowCollection, vtkCollection)
void | AddItem (vtkRenderWindow *a)
vtkRenderWindow * GetNextItem ()

Static Public Methods

vtkRenderWindowCollection * | New ()

Protected Methods

vtkRenderWindowCollection ()
~vtkRenderWindowCollection ()

Detailed Description

a list of RenderWindows.

Date:
2002/01/22 15:39:19
Revision:
1.25

vtkRenderWindowCollection represents and provides methods to manipulate a list of RenderWindows. The list is unsorted and duplicate entries are not prevented.

See also:
vtkRenderWindow vtkCollection
Created by:
  • Hoffman, Bill
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (71%)
  • Hoffman, Bill (26%)

Definition at line 44 of file vtkRenderWindowCollection.h.

Constructor & Destructor Documentation

vtkRenderWindowCollection::vtkRenderWindowCollection ( ) [inline, protected]

Definition at line 64 of file vtkRenderWindowCollection.h.

vtkRenderWindowCollection::~vtkRenderWindowCollection ( ) [inline, protected]

Definition at line 65 of file vtkRenderWindowCollection.h.

Member Function Documentation

vtkRenderWindowCollection* vtkRenderWindowCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkRenderWindowCollection::vtkTypeRevisionMacro | ( | vtkRenderWindowCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkRenderWindowCollection::AddItem ( vtkRenderWindow * a ) [inline]

Add a RenderWindow to the list.

Definition at line 52 of file vtkRenderWindowCollection.h.

vtkRenderWindow* vtkRenderWindowCollection::GetNextItem ( ) [inline]

Get the next RenderWindow in the list. Return NULL when at the end of the list.

Definition at line 59 of file vtkRenderWindowCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRenderWindowCollection.h
Generated on Mon Mar 25 01:30:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRenderWindowInteractor Class Reference

platform-independent render window interaction including picking and frame rate control. More...

#include <vtkRenderWindowInteractor.h>

Inheritance diagram for vtkRenderWindowInteractor:

[legend]
Collaboration diagram for vtkRenderWindowInteractor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRenderWindowInteractor, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | UnRegister (vtkObject *o)
virtual void | Start ()
virtual void | UpdateSize (int x, int y)
virtual void | TerminateApp (void)
virtual vtkAbstractPropPicker * | CreateDefaultPicker ()
void | SetStartPickMethod (void(*f)(void *), void *arg)
void | SetStartPickMethodArgDelete (void(*f)(void *))
void | SetEndPickMethod (void(*f)(void *), void *arg)
void | SetEndPickMethodArgDelete (void(*f)(void *))
void | SetUserMethod (void(*f)(void *), void *arg)
void | SetUserMethodArgDelete (void(*f)(void *))
void | SetExitMethod (void(*f)(void *), void *arg)
void | SetExitMethodArgDelete (void(*f)(void *))
virtual void | GetMousePosition (int *x, int *y)
void | Render ()
virtual void | Initialize ()
void | ReInitialize ()
virtual void | Enable ()
virtual void | Disable ()
virtual int | GetEnabled ()
void | SetRenderWindow (vtkRenderWindow *aren)
virtual vtkRenderWindow * | GetRenderWindow ()
virtual int | CreateTimer (int)
virtual int | DestroyTimer ()
virtual void | SetInteractorStyle (vtkInteractorStyle *)
virtual vtkInteractorStyle * | GetInteractorStyle ()
virtual void | SetLightFollowCamera (int)
virtual int | GetLightFollowCamera ()
virtual void | LightFollowCameraOn ()
virtual void | LightFollowCameraOff ()
virtual void | SetDesiredUpdateRate (float)
virtual float | GetDesiredUpdateRate ()
virtual void | SetStillUpdateRate (float)
virtual float | GetStillUpdateRate ()
virtual int | GetInitialized ()
virtual void | SetPicker (vtkAbstractPicker *)
virtual vtkAbstractPicker * | GetPicker ()
virtual void | ExitCallback ()
virtual void | UserCallback ()
virtual void | StartPickCallback ()
virtual void | EndPickCallback ()
void | HideCursor ()
void | ShowCursor ()
void | FlyTo (vtkRenderer *ren, float x, float y, float z)
void | FlyTo (vtkRenderer *ren, float *x)
void | FlyToImage (vtkRenderer *ren, float x, float y)
void | FlyToImage (vtkRenderer *ren, float *x)
virtual void | SetNumberOfFlyFrames (int)
virtual int | GetNumberOfFlyFrames ()
virtual void | SetDolly (float)
virtual float | GetDolly ()
virtual void | SetEventPosition (int, int)
void | SetEventPosition (int[2])
virtual int * | GetEventPosition ()
virtual void | GetEventPosition (int data[2])
virtual void | SetControlKey (int)
virtual int | GetControlKey ()
virtual void | SetShiftKey (int)
virtual int | GetShiftKey ()
virtual void | SetKeyCode (int)
virtual int | GetKeyCode ()
virtual void | SetRepeatCount (int)
virtual int | GetRepeatCount ()
virtual void | SetKeySym (const char *)
virtual char * | GetKeySym ()
void | SetEventInformation (int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0)
virtual void | SetSize (int, int)
void | SetSize (int[2])
virtual int * | GetSize ()
virtual void | GetSize (int &, int &)
virtual void | GetSize (int[2])

Static Public Methods

vtkRenderWindowInteractor * | New ()

Protected Methods

vtkRenderWindowInteractor ()
~vtkRenderWindowInteractor ()

Protected Attributes

vtkRenderWindow * RenderWindow
vtkInteractorStyle * InteractorStyle
vtkAbstractPicker * Picker
int | Initialized
int | Enabled
int | Style
int | LightFollowCamera
int | ActorMode
float | DesiredUpdateRate
float | StillUpdateRate
int | ControlKey
int | ShiftKey
char | KeyCode
int | RepeatCount
char * | KeySym
int | EventPosition [2]
int | Size [2]
unsigned long | StartPickTag
unsigned long | EndPickTag
unsigned long | UserTag
unsigned long | ExitTag
int | NumberOfFlyFrames
float | Dolly

Detailed Description

platform-independent render window interaction including picking and frame rate control.

Date:
2002/03/21 21:27:35
Revision:
1.86

vtkRenderWindowInteractor provides a platform-independent interaction mechanism for mouse/key/time events. It serves as a base class for platform-dependent implementations that handle routing of mouse/key/timer messages to vtkInterActorStyle and its subclasses. vtkRenderWindowInteractor also provides controls for picking, rendering frame rate, and headlights.

vtkRenderWindowInteractor has changed from previous implementations and now serves only as a shell to hold user preferences and route messages to vtkInteractorStyle. Callbacks are available for many Events. Platform specific subclasses should provide methods for CreateTimer/DestroyTimer, TerminateApp, and an event loop if required via Initialize/Start/Enable/Disable.

Events:
vtkCommand::UserEvent vtkCommand::ExitEvent vtkCommand::EndPickEvent vtkCommand::StartPickEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (37%)
  • Pan, Tony (27%)
  • Geveci, Berk (11%)
  • Law, Charles (10%)
  • Schroeder, Will (6%)
Examples:
vtkRenderWindowInteractor (Examples)
Tests:
vtkRenderWindowInteractor (Tests)

Definition at line 70 of file vtkRenderWindowInteractor.h.

Constructor & Destructor Documentation

vtkRenderWindowInteractor::vtkRenderWindowInteractor ( ) [protected]

vtkRenderWindowInteractor::~vtkRenderWindowInteractor ( ) [protected]

Member Function Documentation

vtkRenderWindowInteractor* vtkRenderWindowInteractor::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

vtkRenderWindowInteractor::vtkTypeRevisionMacro | ( | vtkRenderWindowInteractor | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

void vtkRenderWindowInteractor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

virtual void vtkRenderWindowInteractor::Initialize ( void ) [inline, virtual]

Prepare for handling events. This must be called before the interactor will work.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 80 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::ReInitialize ( ) [inline]

Prepare for handling events. This must be called before the interactor will work.

Definition at line 82 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::UnRegister ( vtkObject * o ) [virtual]

This Method detects loops of RenderWindow-Interactor, so objects are freed properly.

Reimplemented from vtkObject.

virtual void vtkRenderWindowInteractor::Start ( void ) [inline, virtual]

Start the event loop. This is provided so that you do not have to implement your own event loop. You still can use your own event loop if you want. Initialize should be called before Start.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 93 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::Enable ( ) [inline, virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 103 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::Disable ( ) [inline, virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 104 of file vtkRenderWindowInteractor.h.

virtual int vtkRenderWindowInteractor::GetEnabled ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

void vtkRenderWindowInteractor::SetRenderWindow ( vtkRenderWindow * aren )

Set/Get the rendering window being controlled by this object.

virtual vtkRenderWindow* vtkRenderWindowInteractor::GetRenderWindow ( ) [virtual]

Set/Get the rendering window being controlled by this object.

virtual void vtkRenderWindowInteractor::UpdateSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Event loop notification member for Window size change

Reimplemented in vtkXRenderWindowTclInteractor.

virtual int vtkRenderWindowInteractor::CreateTimer ( int timertype ) [inline, virtual]

Timer methods must be overridden by platform dependent subclasses. flag is passed to indicate if this is first timer set or an update as Win32 uses repeating timers, whereas X uses One shot more timer if flag==VTKXI_TIMER_FIRST Win32 and X should createtimer otherwise Win32 should exit and X should perform AddTimeOut()

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 123 of file vtkRenderWindowInteractor.h.

virtual int vtkRenderWindowInteractor::DestroyTimer ( void ) [inline, virtual]

Timer methods must be overridden by platform dependent subclasses. flag is passed to indicate if this is first timer set or an update as Win32 uses repeating timers, whereas X uses One shot more timer if flag==VTKXI_TIMER_FIRST Win32 and X should createtimer otherwise Win32 should exit and X should perform AddTimeOut()

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 124 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::TerminateApp ( void ) [inline, virtual]

This function is called on 'q','e' keypress if exitmethod is not specified and should be overridden by platform dependent subclasses to provide a termination procedure if one is required.

Reimplemented in vtkQuartzRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, and vtkXRenderWindowTclInteractor.

Definition at line 130 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::SetInteractorStyle ( vtkInteractorStyle * ) [virtual]

External switching between joystick/trackball/new? modes.

virtual vtkInteractorStyle* vtkRenderWindowInteractor::GetInteractorStyle ( ) [virtual]

External switching between joystick/trackball/new? modes.

virtual void vtkRenderWindowInteractor::SetLightFollowCamera ( int ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves.

virtual int vtkRenderWindowInteractor::GetLightFollowCamera ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves.

virtual void vtkRenderWindowInteractor::LightFollowCameraOn ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves.

virtual void vtkRenderWindowInteractor::LightFollowCameraOff ( ) [virtual]

Turn on/off the automatic repositioning of lights as the camera moves.

virtual void vtkRenderWindowInteractor::SetDesiredUpdateRate ( float ) [virtual]

Set/Get the desired update rate. This is used by vtkLODActor's to tell them how quickly they need to render. This update is in effect only when the camera is being rotated, or zoomed. When the interactor is still, the StillUpdateRate is used instead.

virtual float vtkRenderWindowInteractor::GetDesiredUpdateRate ( ) [virtual]

Set/Get the desired update rate. This is used by vtkLODActor's to tell them how quickly they need to render. This update is in effect only when the camera is being rotated, or zoomed. When the interactor is still, the StillUpdateRate is used instead.

virtual void vtkRenderWindowInteractor::SetStillUpdateRate ( float ) [virtual]

Set/Get the desired update rate when movement has stopped. See the SetDesiredUpdateRate method.

virtual float vtkRenderWindowInteractor::GetStillUpdateRate ( ) [virtual]

Set/Get the desired update rate when movement has stopped. See the SetDesiredUpdateRate method.

virtual int vtkRenderWindowInteractor::GetInitialized ( ) [virtual]

See whether interactor has been initialized yet.

virtual void vtkRenderWindowInteractor::SetPicker ( vtkAbstractPicker * ) [virtual]

Set/Get the object used to perform pick operations. In order to pick instances of vtkProp, the picker must be a subclass of vtkAbstractPropPicker, meaning that it can identify a particular instance of vtkProp.

virtual vtkAbstractPicker* vtkRenderWindowInteractor::GetPicker ( ) [virtual]

Set/Get the object used to perform pick operations. In order to pick instances of vtkProp, the picker must be a subclass of vtkAbstractPropPicker, meaning that it can identify a particular instance of vtkProp.

virtual vtkAbstractPropPicker* vtkRenderWindowInteractor::CreateDefaultPicker ( ) [virtual]

Create default picker. Used to create one when none is specified. Default is an instance of vtkPropPicker.

void vtkRenderWindowInteractor::SetStartPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a method to be executed prior to the pick operation.

void vtkRenderWindowInteractor::SetStartPickMethodArgDelete ( void(* f)(void *) )

Called when a void* argument is being discarded. Lets the user free it.

void vtkRenderWindowInteractor::SetEndPickMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a method to be executed after the pick operation.

void vtkRenderWindowInteractor::SetEndPickMethodArgDelete ( void(* f)(void *) )

Called when a void* argument is being discarded. Lets the user free it.

void vtkRenderWindowInteractor::SetUserMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set the user method. This method is invoked on a "u" keypress.

void vtkRenderWindowInteractor::SetUserMethodArgDelete ( void(* f)(void *) )

Called when a void* argument is being discarded. Lets the user free it.

void vtkRenderWindowInteractor::SetExitMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Set the exit method. This method is invoked on a "e" or "q" keypress.

void vtkRenderWindowInteractor::SetExitMethodArgDelete ( void(* f)(void *) )

Called when a void* argument is being discarded. Lets the user free it.

virtual void vtkRenderWindowInteractor::ExitCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

Reimplemented in vtkQuartzRenderWindowInteractor, and vtkWin32RenderWindowInteractor.

virtual void vtkRenderWindowInteractor::UserCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

virtual void vtkRenderWindowInteractor::StartPickCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

virtual void vtkRenderWindowInteractor::EndPickCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

virtual void vtkRenderWindowInteractor::GetMousePosition | ( | int * | x,
 |  | int * | y
 | ) | [inline, virtual]

Get the current position of the mouse.

Reimplemented in vtkXRenderWindowInteractor.

Definition at line 218 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::HideCursor ( ) [inline]

Hide or show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Definition at line 223 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::ShowCursor ( ) [inline]

Hide or show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Definition at line 224 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::Render ( void )

Render the scene. Just pass the render call on to the associated vtkRenderWindow.

void vtkRenderWindowInteractor::FlyTo | ( | vtkRenderer * | ren,
 |  | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Given a position x, move the current camera's focal point to x. The movement is animated over the number of frames specified in NumberOfFlyFrames. The LOD desired frame rate is used.

void vtkRenderWindowInteractor::FlyTo | ( | vtkRenderer * | ren,
 |  | float * | x
 | ) | [inline]

Given a position x, move the current camera's focal point to x. The movement is animated over the number of frames specified in NumberOfFlyFrames. The LOD desired frame rate is used.

Definition at line 236 of file vtkRenderWindowInteractor.h.

void vtkRenderWindowInteractor::FlyToImage | ( | vtkRenderer * | ren,
 |  | float | x,
 |  | float | y
 | ) |

Given a position x, move the current camera's focal point to x. The movement is animated over the number of frames specified in NumberOfFlyFrames. The LOD desired frame rate is used.

void vtkRenderWindowInteractor::FlyToImage | ( | vtkRenderer * | ren,
 |  | float * | x
 | ) | [inline]

Given a position x, move the current camera's focal point to x. The movement is animated over the number of frames specified in NumberOfFlyFrames. The LOD desired frame rate is used.

Definition at line 239 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::SetNumberOfFlyFrames ( int ) [virtual]

Set the number of frames to fly to when FlyTo is invoked.

virtual int vtkRenderWindowInteractor::GetNumberOfFlyFrames ( ) [virtual]

Set the number of frames to fly to when FlyTo is invoked.

virtual void vtkRenderWindowInteractor::SetDolly ( float ) [virtual]

Set the total Dolly value to use when flying to (FlyTo()) a specified point. Negative values fly away from the point.

virtual float vtkRenderWindowInteractor::GetDolly ( ) [virtual]

Set the total Dolly value to use when flying to (FlyTo()) a specified point. Negative values fly away from the point.

virtual void vtkRenderWindowInteractor::SetEventPosition | ( | int | ,
 |  | int |
 | ) | [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

void vtkRenderWindowInteractor::SetEventPosition ( int [2] )

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual int* vtkRenderWindowInteractor::GetEventPosition ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::GetEventPosition ( int data[2] ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::SetControlKey ( int ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual int vtkRenderWindowInteractor::GetControlKey ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::SetShiftKey ( int ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual int vtkRenderWindowInteractor::GetShiftKey ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::SetKeyCode ( int ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual int vtkRenderWindowInteractor::GetKeyCode ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::SetRepeatCount ( int ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual int vtkRenderWindowInteractor::GetRepeatCount ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual void vtkRenderWindowInteractor::SetKeySym ( const char * ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

virtual char* vtkRenderWindowInteractor::GetKeySym ( ) [virtual]

Set/Get information about the current event. The current x,y postion is in the EventPosition. The other information is about key board input.

void vtkRenderWindowInteractor::SetEventInformation | ( | int | x,
 |  | int | y,
 |  | int | ctrl = 0,
 |  | int | shift = 0,
 |  | int | keycode = 0,
 |  | int | repeatcount = 0,
 |  | const char * | keysym = 0
 | ) | [inline]

Set all the event information in one call. This should be called for each event to assure that the information from the last event has been cleared.

Definition at line 278 of file vtkRenderWindowInteractor.h.

virtual void vtkRenderWindowInteractor::SetSize | ( | int | ,
 |  | int |
 | ) | [virtual]

This methods sets the Size ivar of the interactor without actually changing the size of the window. Normally application programmers would use UpdateSize if anything. This is useful for letting someone else change the size of the rendering window and just letting the interactor know about the change.

void vtkRenderWindowInteractor::SetSize ( int [2] )

This methods sets the Size ivar of the interactor without actually changing the size of the window. Normally application programmers would use UpdateSize if anything. This is useful for letting someone else change the size of the rendering window and just letting the interactor know about the change.

virtual int* vtkRenderWindowInteractor::GetSize ( ) [virtual]

This methods sets the Size ivar of the interactor without actually changing the size of the window. Normally application programmers would use UpdateSize if anything. This is useful for letting someone else change the size of the rendering window and just letting the interactor know about the change.

virtual void vtkRenderWindowInteractor::GetSize | ( | int & | ,
 |  | int & |
 | ) | [virtual]

This methods sets the Size ivar of the interactor without actually changing the size of the window. Normally application programmers would use UpdateSize if anything. This is useful for letting someone else change the size of the rendering window and just letting the interactor know about the change.

virtual void vtkRenderWindowInteractor::GetSize ( int [2] ) [virtual]

This methods sets the Size ivar of the interactor without actually changing the size of the window. Normally application programmers would use UpdateSize if anything. This is useful for letting someone else change the size of the rendering window and just letting the interactor know about the change.

Member Data Documentation

vtkRenderWindow* vtkRenderWindowInteractor::RenderWindow [protected]

Definition at line 314 of file vtkRenderWindowInteractor.h.

vtkInteractorStyle* vtkRenderWindowInteractor::InteractorStyle [protected]

Definition at line 315 of file vtkRenderWindowInteractor.h.

vtkAbstractPicker* vtkRenderWindowInteractor::Picker [protected]

Definition at line 318 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::Initialized [protected]

Definition at line 321 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::Enabled [protected]

Definition at line 322 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::Style [protected]

Definition at line 323 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::LightFollowCamera [protected]

Definition at line 324 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::ActorMode [protected]

Definition at line 325 of file vtkRenderWindowInteractor.h.

float vtkRenderWindowInteractor::DesiredUpdateRate [protected]

Definition at line 326 of file vtkRenderWindowInteractor.h.

float vtkRenderWindowInteractor::StillUpdateRate [protected]

Definition at line 327 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::ControlKey [protected]

Definition at line 329 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::ShiftKey [protected]

Definition at line 330 of file vtkRenderWindowInteractor.h.

char vtkRenderWindowInteractor::KeyCode [protected]

Definition at line 331 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::RepeatCount [protected]

Definition at line 332 of file vtkRenderWindowInteractor.h.

char* vtkRenderWindowInteractor::KeySym [protected]

Definition at line 333 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::EventPosition[2] [protected]

Definition at line 334 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::Size[2] [protected]

Definition at line 335 of file vtkRenderWindowInteractor.h.

unsigned long vtkRenderWindowInteractor::StartPickTag [protected]

Definition at line 338 of file vtkRenderWindowInteractor.h.

unsigned long vtkRenderWindowInteractor::EndPickTag [protected]

Definition at line 339 of file vtkRenderWindowInteractor.h.

unsigned long vtkRenderWindowInteractor::UserTag [protected]

Definition at line 340 of file vtkRenderWindowInteractor.h.

unsigned long vtkRenderWindowInteractor::ExitTag [protected]

Definition at line 341 of file vtkRenderWindowInteractor.h.

int vtkRenderWindowInteractor::NumberOfFlyFrames [protected]

Definition at line 344 of file vtkRenderWindowInteractor.h.

float vtkRenderWindowInteractor::Dolly [protected]

Definition at line 345 of file vtkRenderWindowInteractor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkRenderWindowInteractor.h
Generated on Mon Mar 25 01:30:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkReverseSense Class Reference

reverse the ordering of polygonal cells and/or vertex normals. More...

#include <vtkReverseSense.h>

Inheritance diagram for vtkReverseSense:

[legend]
Collaboration diagram for vtkReverseSense:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkReverseSense, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetReverseCells (int)
virtual int | GetReverseCells ()
virtual void | ReverseCellsOn ()
virtual void | ReverseCellsOff ()
virtual void | SetReverseNormals (int)
virtual int | GetReverseNormals ()
virtual void | ReverseNormalsOn ()
virtual void | ReverseNormalsOff ()

Static Public Methods

vtkReverseSense * | New ()

Protected Methods

vtkReverseSense ()
~vtkReverseSense ()
void | Execute ()

Protected Attributes

int | ReverseCells
int | ReverseNormals

Detailed Description

reverse the ordering of polygonal cells and/or vertex normals.

Date:
2002/01/22 15:29:43
Revision:
1.23

vtkReverseSense is a filter that reverses the order of polygonal cells and/or reverses the direction of point and cell normals. Two flags are used to control these operations. Cell reversal means reversing the order of indices in the cell connectivity list. Normal reversal means multiplying the normal vector by -1 (both point and cell normals, if present).

Warning:
Normals can be operated on only if they are present in the data.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Geveci, Berk (6%)
Examples:
vtkReverseSense (Examples)
Tests:
vtkReverseSense (Tests)

Definition at line 52 of file vtkReverseSense.h.

Constructor & Destructor Documentation

vtkReverseSense::vtkReverseSense ( ) [protected]

vtkReverseSense::~vtkReverseSense ( ) [inline, protected]

Definition at line 79 of file vtkReverseSense.h.

Member Function Documentation

vtkReverseSense::vtkTypeRevisionMacro | ( | vtkReverseSense | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkReverseSense::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkReverseSense* vtkReverseSense::New ( ) [static]

Construct object so that behavior is to reverse cell ordering and leave normal orientation as is.

Reimplemented from vtkPolyDataSource.

virtual void vtkReverseSense::SetReverseCells ( int ) [virtual]

Flag controls whether to reverse cell ordering.

virtual int vtkReverseSense::GetReverseCells ( ) [virtual]

Flag controls whether to reverse cell ordering.

virtual void vtkReverseSense::ReverseCellsOn ( ) [virtual]

Flag controls whether to reverse cell ordering.

virtual void vtkReverseSense::ReverseCellsOff ( ) [virtual]

Flag controls whether to reverse cell ordering.

virtual void vtkReverseSense::SetReverseNormals ( int ) [virtual]

Flag controls whether to reverse normal orientation.

virtual int vtkReverseSense::GetReverseNormals ( ) [virtual]

Flag controls whether to reverse normal orientation.

virtual void vtkReverseSense::ReverseNormalsOn ( ) [virtual]

Flag controls whether to reverse normal orientation.

virtual void vtkReverseSense::ReverseNormalsOff ( ) [virtual]

Flag controls whether to reverse normal orientation.

void vtkReverseSense::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkReverseSense::ReverseCells [protected]

Definition at line 84 of file vtkReverseSense.h.

int vtkReverseSense::ReverseNormals [protected]

Definition at line 85 of file vtkReverseSense.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkReverseSense.h
Generated on Mon Mar 25 01:30:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRibbonFilter Class Reference

create oriented ribbons from lines defined in polygonal dataset. More...

#include <vtkRibbonFilter.h>

Inheritance diagram for vtkRibbonFilter:

[legend]
Collaboration diagram for vtkRibbonFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRibbonFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetWidth (float)
virtual float | GetWidth ()
virtual void | SetAngle (float)
virtual float | GetAngle ()
virtual void | SetVaryWidth (int)
virtual int | GetVaryWidth ()
virtual void | VaryWidthOn ()
virtual void | VaryWidthOff ()
virtual void | SetWidthFactor (float)
virtual float | GetWidthFactor ()
virtual void | SetDefaultNormal (float, float, float)
virtual void | SetDefaultNormal (float[3])
virtual float * | GetDefaultNormal ()
virtual void | GetDefaultNormal (float data[3])
virtual void | SetUseDefaultNormal (int)
virtual int | GetUseDefaultNormal ()
virtual void | UseDefaultNormalOn ()
virtual void | UseDefaultNormalOff ()

Static Public Methods

vtkRibbonFilter * | New ()

Protected Methods

vtkRibbonFilter ()
~vtkRibbonFilter ()
void | Execute ()

Protected Attributes

float | Width
float | Angle
int | VaryWidth
float | WidthFactor
float | DefaultNormal [3]
int | UseDefaultNormal

Detailed Description

create oriented ribbons from lines defined in polygonal dataset.

Date:
2002/01/22 15:29:43
Revision:
1.37

vtkRibbonFilter is a filter to create oriented ribbons from lines defined in polygonal dataset. The orientation of the ribbon is along the line segments and perpendicular to "projected" line normals. Projected line normals are the original line normals projected to be perpendicular to the local line segment. An offset angle can be specified to rotate the ribbon with respect to the normal.

The input line must not have duplicate points, or normals at points that are parallel to the incoming/outgoing line segments. (Duplicate points can be removed with vtkCleanPolyData.)

See also:
vtkTubeFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (61%)
  • Martin, Ken (13%)
  • Law, Charles (8%)
  • Lorensen, Bill (5%)
Tests:
vtkRibbonFilter (Tests)

Definition at line 54 of file vtkRibbonFilter.h.

Constructor & Destructor Documentation

vtkRibbonFilter::vtkRibbonFilter ( ) [protected]

vtkRibbonFilter::~vtkRibbonFilter ( ) [inline, protected]

Definition at line 108 of file vtkRibbonFilter.h.

Member Function Documentation

vtkRibbonFilter::vtkTypeRevisionMacro | ( | vtkRibbonFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkRibbonFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkRibbonFilter* vtkRibbonFilter::New ( ) [static]

Construct ribbon so that width is 0.1, the width does not vary with scalar values, and the width factor is 2.0.

Reimplemented from vtkPolyDataSource.

virtual void vtkRibbonFilter::SetWidth ( float ) [virtual]

Set the "half" width of the ribbon. If the width is allowed to vary, this is the minimum width.

virtual float vtkRibbonFilter::GetWidth ( ) [virtual]

Set the "half" width of the ribbon. If the width is allowed to vary, this is the minimum width.

virtual void vtkRibbonFilter::SetAngle ( float ) [virtual]

Set the offset angle of the ribbon from the line normal.

virtual float vtkRibbonFilter::GetAngle ( ) [virtual]

Set the offset angle of the ribbon from the line normal.

virtual void vtkRibbonFilter::SetVaryWidth ( int ) [virtual]

Turn on/off the variation of ribbon width with scalar value.

virtual int vtkRibbonFilter::GetVaryWidth ( ) [virtual]

Turn on/off the variation of ribbon width with scalar value.

virtual void vtkRibbonFilter::VaryWidthOn ( ) [virtual]

Turn on/off the variation of ribbon width with scalar value.

virtual void vtkRibbonFilter::VaryWidthOff ( ) [virtual]

Turn on/off the variation of ribbon width with scalar value.

virtual void vtkRibbonFilter::SetWidthFactor ( float ) [virtual]

Set the maximum ribbon width in terms of a multiple of the minimum width.

virtual float vtkRibbonFilter::GetWidthFactor ( ) [virtual]

Set the maximum ribbon width in terms of a multiple of the minimum width.

virtual void vtkRibbonFilter::SetDefaultNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkRibbonFilter::SetDefaultNormal ( float [3] ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual float* vtkRibbonFilter::GetDefaultNormal ( ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkRibbonFilter::GetDefaultNormal ( float data[3] ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkRibbonFilter::SetUseDefaultNormal ( int ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual int vtkRibbonFilter::GetUseDefaultNormal ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual void vtkRibbonFilter::UseDefaultNormalOn ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual void vtkRibbonFilter::UseDefaultNormalOff ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

void vtkRibbonFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkRibbonFilter::Width [protected]

Definition at line 111 of file vtkRibbonFilter.h.

float vtkRibbonFilter::Angle [protected]

Definition at line 112 of file vtkRibbonFilter.h.

int vtkRibbonFilter::VaryWidth [protected]

Definition at line 113 of file vtkRibbonFilter.h.

float vtkRibbonFilter::WidthFactor [protected]

Definition at line 114 of file vtkRibbonFilter.h.

float vtkRibbonFilter::DefaultNormal[3] [protected]

Definition at line 115 of file vtkRibbonFilter.h.

int vtkRibbonFilter::UseDefaultNormal [protected]

Definition at line 116 of file vtkRibbonFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRibbonFilter.h
Generated on Mon Mar 25 01:30:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBExporter Class Reference

export a scene into RenderMan RIB format. More...

#include <vtkRIBExporter.h>

Inheritance diagram for vtkRIBExporter:

[legend]
Collaboration diagram for vtkRIBExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRIBExporter, vtkExporter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetSize (int, int)
void | SetSize (int[2])
virtual int * | GetSize ()
virtual void | GetSize (int data[2])
virtual void | SetPixelSamples (int, int)
void | SetPixelSamples (int[2])
virtual int * | GetPixelSamples ()
virtual void | GetPixelSamples (int data[2])
virtual void | SetFilePrefix (const char *)
virtual char * | GetFilePrefix ()
virtual void | SetTexturePrefix (const char *)
virtual char * | GetTexturePrefix ()
virtual void | SetBackground (int)
virtual int | GetBackground ()
virtual void | BackgroundOn ()
virtual void | BackgroundOff ()
virtual void | SetExportArrays (int)
virtual void | ExportArraysOn ()
virtual void | ExportArraysOff ()
virtual int | GetExportArrays ()

Static Public Methods

vtkRIBExporter * | New ()

Protected Methods

vtkRIBExporter ()
~vtkRIBExporter ()
void | WriteData ()
void | WriteActor (vtkActor *anActor)
void | ModifyArrayName (char *newname, const char *name)
char * | GetTextureName (vtkTexture *aTexture)
char * | GetTIFFName (vtkTexture *aTexture)
void | WriteHeader (vtkRenderer *aRen)
void | WriteTrailer ()
void | WriteTexture (vtkTexture *aTexture)
void | WriteViewport (vtkRenderer *aRenderer, int size[2])
void | WriteCamera (vtkCamera *aCamera)
void | WriteLight (vtkLight *aLight, int count)
void | WriteAmbientLight (int count)
void | WriteProperty (vtkProperty *aProperty, vtkTexture *aTexture)
void | WritePolygons (vtkPolyData *pd, vtkUnsignedCharArray *colors, vtkProperty *aProperty)
void | WriteStrips (vtkPolyData *pd, vtkUnsignedCharArray *colors, vtkProperty *aProperty)

Protected Attributes

int | Background
int | Size [2]
int | PixelSamples [2]
int | ExportArrays
char * | FilePrefix
FILE * | FilePtr
char * | TexturePrefix

Detailed Description

export a scene into RenderMan RIB format.

Date:
2002/03/25 01:26:17
Revision:
1.21

vtkRIBExporter is a concrete subclass of vtkExporter that writes a Renderman .RIB files. The input specifies a vtkRenderWindow. All visible actors and lights will be included in the rib file. The following file naming conventions apply: rib file - FilePrefix.rib image file created by RenderMan - FilePrefix.tif texture files - TexturePrefix_0xADDR_MTIME.tif This object does NOT generate an image file. The user must run either RenderMan or a RenderMan emulator like Blue Moon Ray Tracer (BMRT). vtk properties are convert to Renderman shaders as follows: Normal property, no texture map - plastic.sl Normal property with texture map - txtplastic.sl These two shaders must be compiled by the rendering package being used. vtkRIBExporter also supports custom shaders. The shaders are written using the Renderman Shading Language. See "The Renderman Companion", ISBN 0-201-50868, 1989 for details on writing shaders. vtkRIBProperty specifies the declarations and parameter settings for custom shaders. Tcl Example: generate a rib file for the current rendering. vtkRIBExporter myRIB myRIB SetInput $renWin myRIB SetFIlePrefix mine myRIB Write This will create a file mine.rib. After running this file through a Renderman renderer a file mine.tif will contain the rendered image.

See also:
vtkExporter vtkRIBProperty
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (46%)
  • Schroeder, Will (23%)
  • Cedilnik, Andy (18%)
  • Lorensen, Bill (8%)
Tests:
vtkRIBExporter (Tests)

Definition at line 73 of file vtkRIBExporter.h.

Constructor & Destructor Documentation

vtkRIBExporter::vtkRIBExporter ( ) [protected]

vtkRIBExporter::~vtkRIBExporter ( ) [protected]

Member Function Documentation

vtkRIBExporter* vtkRIBExporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkRIBExporter::vtkTypeRevisionMacro | ( | vtkRIBExporter | ,
 |  | vtkExporter |
 | ) |

Reimplemented from vtkExporter.

void vtkRIBExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExporter.

virtual void vtkRIBExporter::SetSize | ( | int | ,
 |  | int |
 | ) | [virtual]

Specify the size of the image for RenderMan. If none is specified, the size of the render window will be used.

void vtkRIBExporter::SetSize ( int [2] )

Specify the size of the image for RenderMan. If none is specified, the size of the render window will be used.

virtual int* vtkRIBExporter::GetSize ( ) [virtual]

Specify the size of the image for RenderMan. If none is specified, the size of the render window will be used.

virtual void vtkRIBExporter::GetSize ( int data[2] ) [virtual]

Specify the size of the image for RenderMan. If none is specified, the size of the render window will be used.

virtual void vtkRIBExporter::SetPixelSamples | ( | int | ,
 |  | int |
 | ) | [virtual]

Specify the sampling rate for the rendering. Default is 2 2.

void vtkRIBExporter::SetPixelSamples ( int [2] )

Specify the sampling rate for the rendering. Default is 2 2.

virtual int* vtkRIBExporter::GetPixelSamples ( ) [virtual]

Specify the sampling rate for the rendering. Default is 2 2.

virtual void vtkRIBExporter::GetPixelSamples ( int data[2] ) [virtual]

Specify the sampling rate for the rendering. Default is 2 2.

virtual void vtkRIBExporter::SetFilePrefix ( const char * ) [virtual]

Specify the prefix of the files to write out. The resulting file names will have .RIB appended to them.

virtual char* vtkRIBExporter::GetFilePrefix ( ) [virtual]

Specify the prefix of the files to write out. The resulting file names will have .RIB appended to them.

virtual void vtkRIBExporter::SetTexturePrefix ( const char * ) [virtual]

Specify the prefix of any generated texture files.

virtual char* vtkRIBExporter::GetTexturePrefix ( ) [virtual]

Specify the prefix of any generated texture files.

virtual void vtkRIBExporter::SetBackground ( int ) [virtual]

Set/Get the background flag. Default is 0 (off). If set, the rib file will contain an image shader that will use the renderer window's background color. Normally, RenderMan does generate backgrounds. Backgrounds are composited into the scene with the tiffcomp program that comes with Pixar's RenderMan Toolkit. In fact, Pixar's Renderman will accept an image shader but only sets the alpha of the background. Images created this way will still have a black background but contain an alpha of 1 at all pixels and CANNOT be subsequently composited with other images using tiffcomp. However, other RenderMan compliant renderers like Blue Moon Ray Tracing (BMRT) do allow image shaders and properly set the background color. If this sounds too confusing, use the following rules: If you are using Pixar's Renderman, leave the Background off. Otherwise, try setting BackGroundOn and see if you get the desired results.

virtual int vtkRIBExporter::GetBackground ( ) [virtual]

Set/Get the background flag. Default is 0 (off). If set, the rib file will contain an image shader that will use the renderer window's background color. Normally, RenderMan does generate backgrounds. Backgrounds are composited into the scene with the tiffcomp program that comes with Pixar's RenderMan Toolkit. In fact, Pixar's Renderman will accept an image shader but only sets the alpha of the background. Images created this way will still have a black background but contain an alpha of 1 at all pixels and CANNOT be subsequently composited with other images using tiffcomp. However, other RenderMan compliant renderers like Blue Moon Ray Tracing (BMRT) do allow image shaders and properly set the background color. If this sounds too confusing, use the following rules: If you are using Pixar's Renderman, leave the Background off. Otherwise, try setting BackGroundOn and see if you get the desired results.

virtual void vtkRIBExporter::BackgroundOn ( ) [virtual]

Set/Get the background flag. Default is 0 (off). If set, the rib file will contain an image shader that will use the renderer window's background color. Normally, RenderMan does generate backgrounds. Backgrounds are composited into the scene with the tiffcomp program that comes with Pixar's RenderMan Toolkit. In fact, Pixar's Renderman will accept an image shader but only sets the alpha of the background. Images created this way will still have a black background but contain an alpha of 1 at all pixels and CANNOT be subsequently composited with other images using tiffcomp. However, other RenderMan compliant renderers like Blue Moon Ray Tracing (BMRT) do allow image shaders and properly set the background color. If this sounds too confusing, use the following rules: If you are using Pixar's Renderman, leave the Background off. Otherwise, try setting BackGroundOn and see if you get the desired results.

virtual void vtkRIBExporter::BackgroundOff ( ) [virtual]

Set/Get the background flag. Default is 0 (off). If set, the rib file will contain an image shader that will use the renderer window's background color. Normally, RenderMan does generate backgrounds. Backgrounds are composited into the scene with the tiffcomp program that comes with Pixar's RenderMan Toolkit. In fact, Pixar's Renderman will accept an image shader but only sets the alpha of the background. Images created this way will still have a black background but contain an alpha of 1 at all pixels and CANNOT be subsequently composited with other images using tiffcomp. However, other RenderMan compliant renderers like Blue Moon Ray Tracing (BMRT) do allow image shaders and properly set the background color. If this sounds too confusing, use the following rules: If you are using Pixar's Renderman, leave the Background off. Otherwise, try setting BackGroundOn and see if you get the desired results.

virtual void vtkRIBExporter::SetExportArrays ( int ) [virtual]

Set or get the ExportArrays. If ExportArrays is set, then all point data, field data, and cell data arrays will get exported together with polygons.

virtual void vtkRIBExporter::ExportArraysOn ( ) [virtual]

Set or get the ExportArrays. If ExportArrays is set, then all point data, field data, and cell data arrays will get exported together with polygons.

virtual void vtkRIBExporter::ExportArraysOff ( ) [virtual]

Set or get the ExportArrays. If ExportArrays is set, then all point data, field data, and cell data arrays will get exported together with polygons.

virtual int vtkRIBExporter::GetExportArrays ( ) [virtual]

Set or get the ExportArrays. If ExportArrays is set, then all point data, field data, and cell data arrays will get exported together with polygons.

void vtkRIBExporter::WriteHeader ( vtkRenderer * aRen ) [protected]

Write the RIB header.

void vtkRIBExporter::WriteTrailer ( ) [protected]

Write the RIB header.

void vtkRIBExporter::WriteTexture ( vtkTexture * aTexture ) [protected]

Write the RIB header.

void vtkRIBExporter::WriteViewport | ( | vtkRenderer * | aRenderer,
 |  | int | size[2]
 | ) | [protected]

Write the RIB header.

void vtkRIBExporter::WriteCamera ( vtkCamera * aCamera ) [protected]

Write the RIB header.

void vtkRIBExporter::WriteLight | ( | vtkLight * | aLight,
 |  | int | count
 | ) | [protected]

Write the RIB header.

void vtkRIBExporter::WriteAmbientLight ( int count ) [protected]

Write the RIB header.

void vtkRIBExporter::WriteProperty | ( | vtkProperty * | aProperty,
 |  | vtkTexture * | aTexture
 | ) | [protected]

Write the RIB header.

void vtkRIBExporter::WritePolygons | ( | vtkPolyData * | pd,
 |  | vtkUnsignedCharArray * | colors,
 |  | vtkProperty * | aProperty
 | ) | [protected]

Write the RIB header.

void vtkRIBExporter::WriteStrips | ( | vtkPolyData * | pd,
 |  | vtkUnsignedCharArray * | colors,
 |  | vtkProperty * | aProperty
 | ) | [protected]

Write the RIB header.

void vtkRIBExporter::WriteData ( ) [protected, virtual]

Reimplemented from vtkExporter.

void vtkRIBExporter::WriteActor ( vtkActor * anActor ) [protected]

void vtkRIBExporter::ModifyArrayName | ( | char * | newname,
 |  | const char * | name
 | ) | [protected]

Since additional variables are sent to the shader as variables, and their names are used in the shader, these names have to follow C naming convention. This method modifies array name so that you can use it in shader.

char* vtkRIBExporter::GetTextureName ( vtkTexture * aTexture ) [protected]

char* vtkRIBExporter::GetTIFFName ( vtkTexture * aTexture ) [protected]

Member Data Documentation

int vtkRIBExporter::Background [protected]

Definition at line 139 of file vtkRIBExporter.h.

int vtkRIBExporter::Size[2] [protected]

Definition at line 140 of file vtkRIBExporter.h.

int vtkRIBExporter::PixelSamples[2] [protected]

Definition at line 141 of file vtkRIBExporter.h.

int vtkRIBExporter::ExportArrays [protected]

This variable defines whether the arrays are exported or not.

Definition at line 144 of file vtkRIBExporter.h.

char* vtkRIBExporter::FilePrefix [protected]

Definition at line 173 of file vtkRIBExporter.h.

FILE* vtkRIBExporter::FilePtr [protected]

Definition at line 174 of file vtkRIBExporter.h.

char* vtkRIBExporter::TexturePrefix [protected]

Definition at line 175 of file vtkRIBExporter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkRIBExporter.h
Generated on Mon Mar 25 01:30:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBLight Class Reference

RIP Light. More...

#include <vtkRIBLight.h>

Inheritance diagram for vtkRIBLight:

[legend]
Collaboration diagram for vtkRIBLight:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRIBLight, vtkLight)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | ShadowsOn ()
virtual void | ShadowsOff ()
virtual void | SetShadows (int)
virtual int | GetShadows ()
void | Render (vtkRenderer *ren, int index)

Static Public Methods

vtkRIBLight * | New ()

Protected Methods

vtkRIBLight ()
~vtkRIBLight ()

Protected Attributes

vtkLight * Light
int | Shadows

Detailed Description

RIP Light.

Date:
2002/01/22 15:30:37
Revision:
1.15

vtkRIBLight is a subclass of vtkLight that allows the user to specify light source shaders and shadow casting lights for use with RenderMan.

See also:
vtkRIBExporter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (91%)
  • Lorensen, Bill (8%)
Tests:
vtkRIBLight (Tests)

Definition at line 47 of file vtkRIBLight.h.

Constructor & Destructor Documentation

vtkRIBLight::vtkRIBLight ( ) [protected]

vtkRIBLight::~vtkRIBLight ( ) [protected]

Member Function Documentation

vtkRIBLight* vtkRIBLight::New ( ) [static]

Create a light with the focal point at the origin and its position set to (0,0,1). The light is a SceneLight, its color is white, intensity=1, and the light is turned on.

Reimplemented from vtkLight.

vtkRIBLight::vtkTypeRevisionMacro | ( | vtkRIBLight | ,
 |  | vtkLight |
 | ) |

Reimplemented from vtkLight.

void vtkRIBLight::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLight.

virtual void vtkRIBLight::ShadowsOn ( ) [virtual]

virtual void vtkRIBLight::ShadowsOff ( ) [virtual]

virtual void vtkRIBLight::SetShadows ( int ) [virtual]

virtual int vtkRIBLight::GetShadows ( ) [virtual]

void vtkRIBLight::Render | ( | vtkRenderer * | ren,
 |  | int | index
 | ) | [virtual]

Abstract interface to renderer. Each concrete subclass of vtkLight will load its data into the graphics system in response to this method invocation. The actual loading is performed by a vtkLightDevice subclass, which will get created automatically.

Reimplemented from vtkLight.

Member Data Documentation

vtkLight* vtkRIBLight::Light [protected]

Definition at line 63 of file vtkRIBLight.h.

int vtkRIBLight::Shadows [protected]

Definition at line 64 of file vtkRIBLight.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkRIBLight.h
Generated on Mon Mar 25 01:30:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRIBProperty Class Reference

RIP Property. More...

#include <vtkRIBProperty.h>

Inheritance diagram for vtkRIBProperty:

[legend]
Collaboration diagram for vtkRIBProperty:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRIBProperty, vtkProperty)
void | PrintSelf (ostream &os, vtkIndent indent)
char * | GetDeclarations ()
char * | GetParameters ()
virtual void | SetSurfaceShader (const char *)
virtual char * | GetSurfaceShader ()
virtual void | SetDisplacementShader (const char *)
virtual char * | GetDisplacementShader ()
void | SetVariable (char *variable, char *declaration)
void | AddVariable (char *variable, char *declaration)
void | SetParameter (char *parameter, char *value)
void | AddParameter (char *parameter, char *value)

Static Public Methods

vtkRIBProperty * | New ()

Protected Methods

vtkRIBProperty ()
~vtkRIBProperty ()
void | Render (vtkActor *a, vtkRenderer *ren)

Protected Attributes

vtkProperty * Property
char * | SurfaceShader
char * | DisplacementShader
char * | Declarations
char * | Parameters

Detailed Description

RIP Property.

Date:
2002/01/22 15:30:38
Revision:
1.16

vtkRIBProperty is a subclass of vtkProperty that allows the user to specify named shaders for use with RenderMan. Both a surface shader and displacement shader can be specified. Parameters for the shaders can be declared and set.

See also:
vtkRIBExporter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (86%)
  • Lorensen, Bill (13%)
Tests:
vtkRIBProperty (Tests)

Definition at line 49 of file vtkRIBProperty.h.

Constructor & Destructor Documentation

vtkRIBProperty::vtkRIBProperty ( ) [protected]

vtkRIBProperty::~vtkRIBProperty ( ) [protected]

Member Function Documentation

vtkRIBProperty* vtkRIBProperty::New ( ) [static]

Construct object with object color, ambient color, diffuse color, specular color, and edge color white; ambient coefficient=0; diffuse coefficient=0; specular coefficient=0; specular power=1; Gouraud shading; and surface representation. Backface and frontface culling are off.

Reimplemented from vtkProperty.

vtkRIBProperty::vtkTypeRevisionMacro | ( | vtkRIBProperty | ,
 |  | vtkProperty |
 | ) |

Reimplemented from vtkProperty.

void vtkRIBProperty::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProperty.

virtual void vtkRIBProperty::SetSurfaceShader ( const char * ) [virtual]

Specify the name of a surface shader.

virtual char* vtkRIBProperty::GetSurfaceShader ( ) [virtual]

Specify the name of a surface shader.

virtual void vtkRIBProperty::SetDisplacementShader ( const char * ) [virtual]

Specify the name of a displacement shader.

virtual char* vtkRIBProperty::GetDisplacementShader ( ) [virtual]

Specify the name of a displacement shader.

void vtkRIBProperty::SetVariable | ( | char * | variable,
 |  | char * | declaration
 | ) |

Specify declarations for variables..

void vtkRIBProperty::AddVariable | ( | char * | variable,
 |  | char * | declaration
 | ) |

Specify declarations for variables..

char* vtkRIBProperty::GetDeclarations ( )

Get variable declarations

void vtkRIBProperty::SetParameter | ( | char * | parameter,
 |  | char * | value
 | ) |

Specify parameter values for variables.

void vtkRIBProperty::AddParameter | ( | char * | parameter,
 |  | char * | value
 | ) |

Specify parameter values for variables.

char* vtkRIBProperty::GetParameters ( )

Get parameters.

void vtkRIBProperty::Render | ( | vtkActor * | a,
 |  | vtkRenderer * | ren
 | ) | [protected, virtual]

This method causes the property to set up whatever is required for its instance variables. This is actually handled by a subclass of vtkProperty, which is created automatically. This method includes the invoking actor as an argument which can be used by property devices that require the actor.

Reimplemented from vtkProperty.

Member Data Documentation

vtkProperty* vtkRIBProperty::Property [protected]

Definition at line 91 of file vtkRIBProperty.h.

char* vtkRIBProperty::SurfaceShader [protected]

Definition at line 92 of file vtkRIBProperty.h.

char* vtkRIBProperty::DisplacementShader [protected]

Definition at line 93 of file vtkRIBProperty.h.

char* vtkRIBProperty::Declarations [protected]

Definition at line 94 of file vtkRIBProperty.h.

char* vtkRIBProperty::Parameters [protected]

Definition at line 95 of file vtkRIBProperty.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkRIBProperty.h
Generated on Mon Mar 25 01:30:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRotationalExtrusionFilter Class Reference

sweep polygonal data creating "skirt" from free edges and lines, and lines from vertices. More...

#include <vtkRotationalExtrusionFilter.h>

Inheritance diagram for vtkRotationalExtrusionFilter:

[legend]
Collaboration diagram for vtkRotationalExtrusionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRotationalExtrusionFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetResolution (int)
virtual int | GetResolution ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetAngle (float)
virtual float | GetAngle ()
virtual void | SetTranslation (float)
virtual float | GetTranslation ()
virtual void | SetDeltaRadius (float)
virtual float | GetDeltaRadius ()

Static Public Methods

vtkRotationalExtrusionFilter * | New ()

Protected Methods

vtkRotationalExtrusionFilter ()
~vtkRotationalExtrusionFilter ()
void | Execute ()

Protected Attributes

int | Resolution
int | Capping
float | Angle
float | Translation
float | DeltaRadius

Detailed Description

sweep polygonal data creating "skirt" from free edges and lines, and lines from vertices.

Date:
2002/01/22 15:29:43
Revision:
1.37

vtkRotationalExtrusionFilter is a modeling filter. It takes polygonal data as input and generates polygonal data on output. The input dataset is swept around the z-axis to create new polygonal primitives. These primitives form a "skirt" or swept surface. For example, sweeping a line results in a cylindrical shell, and sweeping a circle creates a torus.

There are a number of control parameters for this filter. You can control whether the sweep of a 2D object (i.e., polygon or triangle strip) is capped with the generating geometry via the "Capping" instance variable. Also, you can control the angle of rotation, and whether translation along the z-axis is performed along with the rotation. (Translation is useful for creating "springs".) You also can adjust the radius of the generating geometry using the "DeltaRotation" instance variable.

The skirt is generated by locating certain topological features. Free edges (edges of polygons or triangle strips only used by one polygon or triangle strips) generate surfaces. This is true also of lines or polylines. Vertices generate lines.

This filter can be used to model axisymmetric objects like cylinders, bottles, and wine glasses; or translational/rotational symmetric objects like springs or corkscrews.

Warning:
If the object sweeps 360 degrees, radius does not vary, and the object does not translate, capping is not performed. This is because the cap is unnecessary.
Warning:
Some polygonal objects have no free edges (e.g., sphere). When swept, this will result in two separate surfaces if capping is on, or no surface if capping is off.
See also:
vtkLinearExtrusionFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Martin, Ken (15%)
  • Lorensen, Bill (7%)
Examples:
vtkRotationalExtrusionFilter (Examples)
Tests:
vtkRotationalExtrusionFilter (Tests)

Definition at line 80 of file vtkRotationalExtrusionFilter.h.

Constructor & Destructor Documentation

vtkRotationalExtrusionFilter::vtkRotationalExtrusionFilter ( ) [protected]

vtkRotationalExtrusionFilter::~vtkRotationalExtrusionFilter ( ) [inline, protected]

Definition at line 124 of file vtkRotationalExtrusionFilter.h.

Member Function Documentation

vtkRotationalExtrusionFilter::vtkTypeRevisionMacro | ( | vtkRotationalExtrusionFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkRotationalExtrusionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkRotationalExtrusionFilter* vtkRotationalExtrusionFilter::New ( ) [static]

Create object with capping on, angle of 360 degrees, resolution = 12, and no translation along z-axis. vector (0,0,1), and point (0,0,0).

Reimplemented from vtkPolyDataSource.

virtual void vtkRotationalExtrusionFilter::SetResolution ( int ) [virtual]

Set/Get resolution of sweep operation. Resolution controls the number of intermediate node points.

virtual int vtkRotationalExtrusionFilter::GetResolution ( ) [virtual]

Set/Get resolution of sweep operation. Resolution controls the number of intermediate node points.

virtual void vtkRotationalExtrusionFilter::SetCapping ( int ) [virtual]

Turn on/off the capping of the skirt.

virtual int vtkRotationalExtrusionFilter::GetCapping ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkRotationalExtrusionFilter::CappingOn ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkRotationalExtrusionFilter::CappingOff ( ) [virtual]

Turn on/off the capping of the skirt.

virtual void vtkRotationalExtrusionFilter::SetAngle ( float ) [virtual]

Set/Get angle of rotation.

virtual float vtkRotationalExtrusionFilter::GetAngle ( ) [virtual]

Set/Get angle of rotation.

virtual void vtkRotationalExtrusionFilter::SetTranslation ( float ) [virtual]

Set/Get total amount of translation along the z-axis.

virtual float vtkRotationalExtrusionFilter::GetTranslation ( ) [virtual]

Set/Get total amount of translation along the z-axis.

virtual void vtkRotationalExtrusionFilter::SetDeltaRadius ( float ) [virtual]

Set/Get change in radius during sweep process.

virtual float vtkRotationalExtrusionFilter::GetDeltaRadius ( ) [virtual]

Set/Get change in radius during sweep process.

void vtkRotationalExtrusionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkRotationalExtrusionFilter::Resolution [protected]

Definition at line 127 of file vtkRotationalExtrusionFilter.h.

int vtkRotationalExtrusionFilter::Capping [protected]

Definition at line 128 of file vtkRotationalExtrusionFilter.h.

float vtkRotationalExtrusionFilter::Angle [protected]

Definition at line 129 of file vtkRotationalExtrusionFilter.h.

float vtkRotationalExtrusionFilter::Translation [protected]

Definition at line 130 of file vtkRotationalExtrusionFilter.h.

float vtkRotationalExtrusionFilter::DeltaRadius [protected]

Definition at line 131 of file vtkRotationalExtrusionFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRotationalExtrusionFilter.h
Generated on Mon Mar 25 01:30:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRTAnalyticSource Class Reference

Create an image for regression testing. More...

#include <vtkRTAnalyticSource.h>

Inheritance diagram for vtkRTAnalyticSource:

[legend]
Collaboration diagram for vtkRTAnalyticSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRTAnalyticSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetXMag (float)
virtual float | GetXMag ()
virtual void | SetYMag (float)
virtual float | GetYMag ()
virtual void | SetZMag (float)
virtual float | GetZMag ()
void | SetWholeExtent (int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
virtual int * | GetWholeExtent ()
virtual void | GetWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetWholeExtent (int[6])
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float &, float &, float &)
virtual void | GetCenter (float[3])
virtual void | SetMaximum (float)
virtual float | GetMaximum ()
virtual void | SetStandardDeviation (float)
virtual float | GetStandardDeviation ()
virtual void | SetXFreq (float)
virtual float | GetXFreq ()
virtual void | SetYFreq (float)
virtual float | GetYFreq ()
virtual void | SetZFreq (float)
virtual float | GetZFreq ()

Static Public Methods

vtkRTAnalyticSource * | New ()

Protected Methods

vtkRTAnalyticSource ()
~vtkRTAnalyticSource ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *data)

Protected Attributes

float | XFreq
float | YFreq
float | ZFreq
float | XMag
float | YMag
float | ZMag
float | StandardDeviation
int | WholeExtent [6]
float | Center [3]
float | Maximum

Detailed Description

Create an image for regression testing.

Date:
2002/01/22 15:34:55
Revision:
1.9

vtkRTAnalyticSource just produces images with pixel values determined by a Maximum*Gaussian*XMag*sin(XFreq*x)*sin(YFreq*y)*cos(ZFreq*z)

Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (86%)
  • Martin, Ken (6%)
Examples:
vtkRTAnalyticSource (Examples)
Tests:
vtkRTAnalyticSource (Tests)

Definition at line 44 of file vtkRTAnalyticSource.h.

Constructor & Destructor Documentation

vtkRTAnalyticSource::vtkRTAnalyticSource ( ) [protected]

vtkRTAnalyticSource::~vtkRTAnalyticSource ( ) [inline, protected]

Definition at line 95 of file vtkRTAnalyticSource.h.

Member Function Documentation

vtkRTAnalyticSource* vtkRTAnalyticSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkRTAnalyticSource::vtkTypeRevisionMacro | ( | vtkRTAnalyticSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkRTAnalyticSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkRTAnalyticSource::SetWholeExtent | ( | int | xMinx,
 |  | int | xMax,
 |  | int | yMin,
 |  | int | yMax,
 |  | int | zMin,
 |  | int | zMax
 | ) |

Set/Get the extent of the whole output image.

virtual int* vtkRTAnalyticSource::GetWholeExtent ( ) [virtual]

Set/Get the extent of the whole output image.

virtual void vtkRTAnalyticSource::GetWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the extent of the whole output image.

virtual void vtkRTAnalyticSource::GetWholeExtent ( int [6] ) [virtual]

Set/Get the extent of the whole output image.

virtual void vtkRTAnalyticSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the center of function.

virtual void vtkRTAnalyticSource::SetCenter ( float [3] ) [virtual]

Set/Get the center of function.

virtual float* vtkRTAnalyticSource::GetCenter ( ) [virtual]

Set/Get the center of function.

virtual void vtkRTAnalyticSource::GetCenter | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the center of function.

virtual void vtkRTAnalyticSource::GetCenter ( float [3] ) [virtual]

Set/Get the center of function.

virtual void vtkRTAnalyticSource::SetMaximum ( float ) [virtual]

Set/Get the Maximum value of the function.

virtual float vtkRTAnalyticSource::GetMaximum ( ) [virtual]

Set/Get the Maximum value of the function.

virtual void vtkRTAnalyticSource::SetStandardDeviation ( float ) [virtual]

Set/Get the standard deviation of the function.

virtual float vtkRTAnalyticSource::GetStandardDeviation ( ) [virtual]

Set/Get the standard deviation of the function.

virtual void vtkRTAnalyticSource::SetXFreq ( float ) [virtual]

Set the natural frequencies in x,y and z

virtual float vtkRTAnalyticSource::GetXFreq ( ) [virtual]

Set the natural frequencies in x,y and z

virtual void vtkRTAnalyticSource::SetYFreq ( float ) [virtual]

Set the natural frequencies in x,y and z

virtual float vtkRTAnalyticSource::GetYFreq ( ) [virtual]

Set the natural frequencies in x,y and z

virtual void vtkRTAnalyticSource::SetZFreq ( float ) [virtual]

Set the natural frequencies in x,y and z

virtual float vtkRTAnalyticSource::GetZFreq ( ) [virtual]

Set the natural frequencies in x,y and z

virtual void vtkRTAnalyticSource::SetXMag ( float ) [virtual]

virtual float vtkRTAnalyticSource::GetXMag ( ) [virtual]

virtual void vtkRTAnalyticSource::SetYMag ( float ) [virtual]

virtual float vtkRTAnalyticSource::GetYMag ( ) [virtual]

virtual void vtkRTAnalyticSource::SetZMag ( float ) [virtual]

virtual float vtkRTAnalyticSource::GetZMag ( ) [virtual]

virtual void vtkRTAnalyticSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkRTAnalyticSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

Member Data Documentation

float vtkRTAnalyticSource::XFreq [protected]

Definition at line 97 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::YFreq [protected]

Definition at line 98 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::ZFreq [protected]

Definition at line 99 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::XMag [protected]

Definition at line 100 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::YMag [protected]

Definition at line 101 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::ZMag [protected]

Definition at line 102 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::StandardDeviation [protected]

Definition at line 103 of file vtkRTAnalyticSource.h.

int vtkRTAnalyticSource::WholeExtent[6] [protected]

Definition at line 104 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::Center[3] [protected]

Definition at line 105 of file vtkRTAnalyticSource.h.

float vtkRTAnalyticSource::Maximum [protected]

Definition at line 106 of file vtkRTAnalyticSource.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkRTAnalyticSource.h
Generated on Mon Mar 25 01:30:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRuledSurfaceFilter Class Reference

generates a surface from a set of lines. More...

#include <vtkRuledSurfaceFilter.h>

Inheritance diagram for vtkRuledSurfaceFilter:

[legend]
Collaboration diagram for vtkRuledSurfaceFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRuledSurfaceFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetDistanceFactor (float)
virtual float | GetDistanceFactor ()
virtual void | SetOnRatio (int)
virtual int | GetOnRatio ()
virtual void | SetOffset (int)
virtual int | GetOffset ()
virtual void | SetCloseSurface (int)
virtual int | GetCloseSurface ()
virtual void | CloseSurfaceOn ()
virtual void | CloseSurfaceOff ()
virtual void | SetRuledMode (int)
virtual int | GetRuledMode ()
void | SetRuledModeToResample ()
void | SetRuledModeToPointWalk ()
const char * | GetRuledModeAsString ()
virtual void | SetResolution (int, int)
void | SetResolution (int[2])
virtual int * | GetResolution ()
virtual void | GetResolution (int data[2])
virtual void | SetPassLines (int)
virtual int | GetPassLines ()
virtual void | PassLinesOn ()
virtual void | PassLinesOff ()

Static Public Methods

vtkRuledSurfaceFilter * | New ()

Protected Methods

vtkRuledSurfaceFilter ()
~vtkRuledSurfaceFilter ()
void | Execute ()

Protected Attributes

float | DistanceFactor
int | OnRatio
int | Offset
int | CloseSurface
int | RuledMode
int | Resolution [2]
int | PassLines

Detailed Description

generates a surface from a set of lines.

Date:
2002/01/22 15:29:44
Revision:
1.9

vtkRuledSurfaceFilter is a filter that generates a surface from a set of lines. The lines are assumed to be "parallel" in the sense that they do not intersect and remain somewhat close to one another. A surface is generated by connecting the points defining each pair of lines with straight lines. This creates a strip for each pair of lines (i.e., a triangulation is created from two generating lines). The filter can handle an arbitrary number of lines, with lines i and i+1 assumed connected. Note that there are several different approaches for creating the ruled surface, the method for creating the surface can either use the input points or resample from the polylines (using a user-specified resolution).

This filter offers some other important features. A DistanceFactor ivar is used to decide when two lines are too far apart to connect. (The factor is a multiple of the distance between the first two points of the two lines defining the strip.) If the distance between the two generating lines becomes too great, then the surface is not generated in that region. (Note: if the lines separate and then merge, then a hole can be generated in the surface.) In addition, the Offset and OnRation ivars can be used to create nifty striped surfaces. Closed surfaces (e.g., tubes) can be created by setting the CloseSurface ivar. (The surface can be closed in the other direction by repeating the first and last point in the polylines defining the surface.)

An important use of this filter is to combine it with vtkStreamLine to generate stream surfaces. It can also be used to create surfaces from contours.

Warning:
The number of lines must be greater than two if a surface is to be generated. sides (i.e., a ribbon), use vtkRibbonFilter.
See also:
vtkRibbonFilter vtkStreamLine
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (92%)
Examples:
vtkRuledSurfaceFilter (Examples)
Tests:
vtkRuledSurfaceFilter (Tests)

Definition at line 77 of file vtkRuledSurfaceFilter.h.

Constructor & Destructor Documentation

vtkRuledSurfaceFilter::vtkRuledSurfaceFilter ( ) [protected]

vtkRuledSurfaceFilter::~vtkRuledSurfaceFilter ( ) [protected]

Member Function Documentation

vtkRuledSurfaceFilter::vtkTypeRevisionMacro | ( | vtkRuledSurfaceFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkRuledSurfaceFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkRuledSurfaceFilter* vtkRuledSurfaceFilter::New ( ) [static]

Construct object with OnRatio=1, Offset=0. DistanceFactor=3.0, CloseSurface off, and PassLines off.

Reimplemented from vtkPolyDataSource.

virtual void vtkRuledSurfaceFilter::SetDistanceFactor ( float ) [virtual]

Set/Get the factor that controls tearing of the surface.

virtual float vtkRuledSurfaceFilter::GetDistanceFactor ( ) [virtual]

Set/Get the factor that controls tearing of the surface.

virtual void vtkRuledSurfaceFilter::SetOnRatio ( int ) [virtual]

Control the striping of the ruled surface. If OnRatio is greater than 1, then every nth strip is turned on, beginning with the Offset strip.

virtual int vtkRuledSurfaceFilter::GetOnRatio ( ) [virtual]

Control the striping of the ruled surface. If OnRatio is greater than 1, then every nth strip is turned on, beginning with the Offset strip.

virtual void vtkRuledSurfaceFilter::SetOffset ( int ) [virtual]

Control the striping of the ruled surface. The offset sets the first stripe that is visible. Offset is generally used with OnRatio to create nifty striping effects.

virtual int vtkRuledSurfaceFilter::GetOffset ( ) [virtual]

Control the striping of the ruled surface. The offset sets the first stripe that is visible. Offset is generally used with OnRatio to create nifty striping effects.

virtual void vtkRuledSurfaceFilter::SetCloseSurface ( int ) [virtual]

Indicate whether the surface is to be closed. If this boolean is on, then the first and last polyline are used to generate a stripe that closes the surface. (Note: to close the surface in the other direction, repeat the first point in the polyline as the last point in the polyline.)

virtual int vtkRuledSurfaceFilter::GetCloseSurface ( ) [virtual]

Indicate whether the surface is to be closed. If this boolean is on, then the first and last polyline are used to generate a stripe that closes the surface. (Note: to close the surface in the other direction, repeat the first point in the polyline as the last point in the polyline.)

virtual void vtkRuledSurfaceFilter::CloseSurfaceOn ( ) [virtual]

Indicate whether the surface is to be closed. If this boolean is on, then the first and last polyline are used to generate a stripe that closes the surface. (Note: to close the surface in the other direction, repeat the first point in the polyline as the last point in the polyline.)

virtual void vtkRuledSurfaceFilter::CloseSurfaceOff ( ) [virtual]

Indicate whether the surface is to be closed. If this boolean is on, then the first and last polyline are used to generate a stripe that closes the surface. (Note: to close the surface in the other direction, repeat the first point in the polyline as the last point in the polyline.)

virtual void vtkRuledSurfaceFilter::SetRuledMode ( int ) [virtual]

Set the mode by which to create the ruled surface. (Dramatically different results are possible depending on the chosen mode.) The resample mode evenly resamples the polylines (based on length) and generates triangle strips. The

virtual int vtkRuledSurfaceFilter::GetRuledMode ( ) [virtual]

Set the mode by which to create the ruled surface. (Dramatically different results are possible depending on the chosen mode.) The resample mode evenly resamples the polylines (based on length) and generates triangle strips. The

void vtkRuledSurfaceFilter::SetRuledModeToResample ( ) [inline]

Set the mode by which to create the ruled surface. (Dramatically different results are possible depending on the chosen mode.) The resample mode evenly resamples the polylines (based on length) and generates triangle strips. The

Definition at line 128 of file vtkRuledSurfaceFilter.h.

void vtkRuledSurfaceFilter::SetRuledModeToPointWalk ( ) [inline]

Set the mode by which to create the ruled surface. (Dramatically different results are possible depending on the chosen mode.) The resample mode evenly resamples the polylines (based on length) and generates triangle strips. The

Definition at line 130 of file vtkRuledSurfaceFilter.h.

const char* vtkRuledSurfaceFilter::GetRuledModeAsString ( )

Set the mode by which to create the ruled surface. (Dramatically different results are possible depending on the chosen mode.) The resample mode evenly resamples the polylines (based on length) and generates triangle strips. The

virtual void vtkRuledSurfaceFilter::SetResolution | ( | int | ,
 |  | int |
 | ) | [virtual]

If the ruled surface generation mode is RESAMPLE, then these parameters are used to determine the resample rate. Resolution[0] defines the resolution in the direction of the polylines; Resolution[1] defines the resolution across the polylines (i.e., direction orthogonal to Resolution[0]).

void vtkRuledSurfaceFilter::SetResolution ( int [2] )

If the ruled surface generation mode is RESAMPLE, then these parameters are used to determine the resample rate. Resolution[0] defines the resolution in the direction of the polylines; Resolution[1] defines the resolution across the polylines (i.e., direction orthogonal to Resolution[0]).

virtual int* vtkRuledSurfaceFilter::GetResolution ( ) [virtual]

If the ruled surface generation mode is RESAMPLE, then these parameters are used to determine the resample rate. Resolution[0] defines the resolution in the direction of the polylines; Resolution[1] defines the resolution across the polylines (i.e., direction orthogonal to Resolution[0]).

virtual void vtkRuledSurfaceFilter::GetResolution ( int data[2] ) [virtual]

If the ruled surface generation mode is RESAMPLE, then these parameters are used to determine the resample rate. Resolution[0] defines the resolution in the direction of the polylines; Resolution[1] defines the resolution across the polylines (i.e., direction orthogonal to Resolution[0]).

virtual void vtkRuledSurfaceFilter::SetPassLines ( int ) [virtual]

Indicate whether the generating lines are to be passed to the output. By defualt lines are not passed to the output.

virtual int vtkRuledSurfaceFilter::GetPassLines ( ) [virtual]

Indicate whether the generating lines are to be passed to the output. By defualt lines are not passed to the output.

virtual void vtkRuledSurfaceFilter::PassLinesOn ( ) [virtual]

Indicate whether the generating lines are to be passed to the output. By defualt lines are not passed to the output.

virtual void vtkRuledSurfaceFilter::PassLinesOff ( ) [virtual]

Indicate whether the generating lines are to be passed to the output. By defualt lines are not passed to the output.

void vtkRuledSurfaceFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkRuledSurfaceFilter::DistanceFactor [protected]

Definition at line 160 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::OnRatio [protected]

Definition at line 161 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::Offset [protected]

Definition at line 162 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::CloseSurface [protected]

Definition at line 163 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::RuledMode [protected]

Definition at line 164 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::Resolution[2] [protected]

Definition at line 165 of file vtkRuledSurfaceFilter.h.

int vtkRuledSurfaceFilter::PassLines [protected]

Definition at line 166 of file vtkRuledSurfaceFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkRuledSurfaceFilter.h
Generated on Mon Mar 25 01:30:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta2 Class Reference

Integrate an initial value problem using 2nd. More...

#include <vtkRungeKutta2.h>

Inheritance diagram for vtkRungeKutta2:

[legend]
Collaboration diagram for vtkRungeKutta2:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRungeKutta2, vtkInitialValueProblemSolver)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual vtkInitialValueProblemSolver * | MakeObject ()

Static Public Methods

vtkRungeKutta2 * | New ()

Protected Methods

vtkRungeKutta2 ()
~vtkRungeKutta2 ()

Detailed Description

Integrate an initial value problem using 2nd.

Date:
2002/02/14 22:32:14
Revision:
1.11
order Runge-Kutta method.

This is a concrete sub-class of vtkInitialValueProblemSolver. It uses a 2nd order Runge-Kutta method to obtain the values of a set of functions at the next time step.

See also:
vtkInitialValueProblemSolver vtkRungeKutta4 vtkRungeKutta45 vtkFunctionSet
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (97%)

Definition at line 43 of file vtkRungeKutta2.h.

Constructor & Destructor Documentation

vtkRungeKutta2::vtkRungeKutta2 ( ) [protected]

vtkRungeKutta2::~vtkRungeKutta2 ( ) [protected]

Member Function Documentation

vtkRungeKutta2::vtkTypeRevisionMacro | ( | vtkRungeKutta2 | ,
 |  | vtkInitialValueProblemSolver |
 | ) |

Reimplemented from vtkInitialValueProblemSolver.

vtkRungeKutta2* vtkRungeKutta2::New ( ) [static]

Construct a vtkRungeKutta2 with no initial FunctionSet.

Reimplemented from vtkObject.

Referenced by MakeObject().

virtual int vtkRungeKutta2::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 58 of file vtkRungeKutta2.h.

virtual int vtkRungeKutta2::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 67 of file vtkRungeKutta2.h.

virtual int vtkRungeKutta2::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 77 of file vtkRungeKutta2.h.

virtual int vtkRungeKutta2::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

virtual vtkInitialValueProblemSolver* vtkRungeKutta2::MakeObject ( ) [inline, virtual]

Create concrete instance of this object.

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 93 of file vtkRungeKutta2.h.

The documentation for this class was generated from the following file:
  • Common/vtkRungeKutta2.h
Generated on Mon Mar 25 01:30:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta4 Class Reference

Integrate an initial value problem using 4th. More...

#include <vtkRungeKutta4.h>

Inheritance diagram for vtkRungeKutta4:

[legend]
Collaboration diagram for vtkRungeKutta4:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRungeKutta4, vtkInitialValueProblemSolver)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual vtkInitialValueProblemSolver * | MakeObject ()

Static Public Methods

vtkRungeKutta4 * | New ()

Protected Methods

vtkRungeKutta4 ()
~vtkRungeKutta4 ()
virtual void | Initialize ()

Protected Attributes

float * | NextDerivs [3]

Detailed Description

Integrate an initial value problem using 4th.

Date:
2002/02/14 22:32:15
Revision:
1.11
order Runge-Kutta method.

This is a concrete sub-class of vtkInitialValueProblemSolver. It uses a 4th order Runge-Kutta method to obtain the values of a set of functions at the next time step.

See also:
vtkInitialValueProblemSolver vtkRungeKutta45 vtkRungeKutta2 vtkFunctionSet
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (98%)
Examples:
vtkRungeKutta4 (Examples)
Tests:
vtkRungeKutta4 (Tests)

Definition at line 49 of file vtkRungeKutta4.h.

Constructor & Destructor Documentation

vtkRungeKutta4::vtkRungeKutta4 ( ) [protected]

vtkRungeKutta4::~vtkRungeKutta4 ( ) [protected]

Member Function Documentation

vtkRungeKutta4::vtkTypeRevisionMacro | ( | vtkRungeKutta4 | ,
 |  | vtkInitialValueProblemSolver |
 | ) |

Reimplemented from vtkInitialValueProblemSolver.

virtual void vtkRungeKutta4::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkInitialValueProblemSolver.

vtkRungeKutta4* vtkRungeKutta4::New ( ) [static]

Construct a vtkRungeKutta4 with no initial FunctionSet.

Reimplemented from vtkObject.

Referenced by MakeObject().

virtual int vtkRungeKutta4::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 66 of file vtkRungeKutta4.h.

virtual int vtkRungeKutta4::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 75 of file vtkRungeKutta4.h.

virtual int vtkRungeKutta4::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 85 of file vtkRungeKutta4.h.

virtual int vtkRungeKutta4::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delT (xnext). delTActual is always equal to delT. Since this class can not provide an estimate for the error error is set to 0. maxStep, minStep and maxError are unused. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

virtual vtkInitialValueProblemSolver* vtkRungeKutta4::MakeObject ( ) [inline, virtual]

Create concrete instance of this object.

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 101 of file vtkRungeKutta4.h.

virtual void vtkRungeKutta4::Initialize ( ) [protected, virtual]

Reimplemented from vtkInitialValueProblemSolver.

Member Data Documentation

float* vtkRungeKutta4::NextDerivs[3] [protected]

Definition at line 114 of file vtkRungeKutta4.h.

The documentation for this class was generated from the following file:
  • Common/vtkRungeKutta4.h
Generated on Mon Mar 25 01:30:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkRungeKutta45 Class Reference

Integrate an initial value problem using 5th. More...

#include <vtkRungeKutta45.h>

Inheritance diagram for vtkRungeKutta45:

[legend]
Collaboration diagram for vtkRungeKutta45:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkRungeKutta45, vtkInitialValueProblemSolver)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual int | ComputeNextStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)
virtual vtkInitialValueProblemSolver * | MakeObject ()

Static Public Methods

vtkRungeKutta45 * | New ()

Protected Methods

vtkRungeKutta45 ()
~vtkRungeKutta45 ()
virtual void | Initialize ()
int | ComputeAStep (float *xprev, float *dxprev, float *xnext, float t, float &delT, float &error)

Protected Attributes

float * | NextDerivs [6]

Static Protected Attributes

double | A [5]
double | B [5][5]
double | C [6]
double | DC [6]

Detailed Description

Integrate an initial value problem using 5th.

Date:
2002/02/14 22:32:15
Revision:
1.1
order Runge-Kutta method with adaptive stepsize control.

This is a concrete sub-class of vtkInitialValueProblemSolver. It uses a 5th order Runge-Kutta method with stepsize control to obtain the values of a set of functions at the next time step. The stepsize is adjusted by calculating an estimated error using an embedded 4th order Runge-Kutta formula: Press, W. H. et al., 1992, Numerical Recipes in Fortran, Second Edition, Cambridge University Press Cash, J.R. and Karp, A.H. 1990, ACM Transactions on Mathematical Software, vol 16, pp 201-222

See also:
vtkInitialValueProblemSolver vtkRungeKutta4 vtkRungeKutta2 vtkFunctionSet
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (86%)
  • Cedilnik, Andy (13%)

Definition at line 50 of file vtkRungeKutta45.h.

Constructor & Destructor Documentation

vtkRungeKutta45::vtkRungeKutta45 ( ) [protected]

vtkRungeKutta45::~vtkRungeKutta45 ( ) [protected]

Member Function Documentation

vtkRungeKutta45::vtkTypeRevisionMacro | ( | vtkRungeKutta45 | ,
 |  | vtkInitialValueProblemSolver |
 | ) |

Reimplemented from vtkInitialValueProblemSolver.

vtkRungeKutta45* vtkRungeKutta45::New ( ) [static]

Construct a vtkRungeKutta45 with no initial FunctionSet.

Reimplemented from vtkObject.

Referenced by MakeObject().

virtual int vtkRungeKutta45::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). Possibly delTActual != delT. This may occur because this solver supports adaptive stepsize control. It tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep (note that maxStep and minStep should both be positive, whereas delT can be negative). Also note that delT is an in/out argument. vtkRungeKutta45 will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. This is the norm of the error vector if there are more than one function to be integrated. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 74 of file vtkRungeKutta45.h.

virtual int vtkRungeKutta45::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). Possibly delTActual != delT. This may occur because this solver supports adaptive stepsize control. It tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep (note that maxStep and minStep should both be positive, whereas delT can be negative). Also note that delT is an in/out argument. vtkRungeKutta45 will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. This is the norm of the error vector if there are more than one function to be integrated. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 83 of file vtkRungeKutta45.h.

virtual int vtkRungeKutta45::ComputeNextStep | ( | float * | xprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [inline, virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). Possibly delTActual != delT. This may occur because this solver supports adaptive stepsize control. It tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep (note that maxStep and minStep should both be positive, whereas delT can be negative). Also note that delT is an in/out argument. vtkRungeKutta45 will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. This is the norm of the error vector if there are more than one function to be integrated. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 93 of file vtkRungeKutta45.h.

virtual int vtkRungeKutta45::ComputeNextStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | delTActual,
 |  | float | minStep,
 |  | float | maxStep,
 |  | float | maxError,
 |  | float & | error
 | ) | [virtual]

Given initial values, xprev , initial time, t and a requested time interval, delT calculate values of x at t+delTActual (xnext). Possibly delTActual != delT. This may occur because this solver supports adaptive stepsize control. It tries to change to stepsize such that the (estimated) error of the integration is less than maxError. The solver will not set the stepsize smaller than minStep or larger than maxStep (note that maxStep and minStep should both be positive, whereas delT can be negative). Also note that delT is an in/out argument. vtkRungeKutta45 will modify delT to reflect the best (estimated) size for the next integration step. An estimated value for the error is returned (by reference) in error. This is the norm of the error vector if there are more than one function to be integrated. This method returns an error code representing the nature of the failure: OutOfDomain = 1, NotInitialized = 2, UnexpectedValue = 3

Reimplemented from vtkInitialValueProblemSolver.

virtual vtkInitialValueProblemSolver* vtkRungeKutta45::MakeObject ( ) [inline, virtual]

Create concrete instance of this object.

Reimplemented from vtkInitialValueProblemSolver.

Definition at line 109 of file vtkRungeKutta45.h.

virtual void vtkRungeKutta45::Initialize ( ) [protected, virtual]

Reimplemented from vtkInitialValueProblemSolver.

int vtkRungeKutta45::ComputeAStep | ( | float * | xprev,
 |  | float * | dxprev,
 |  | float * | xnext,
 |  | float | t,
 |  | float & | delT,
 |  | float & | error
 | ) | [protected]

Member Data Documentation

double vtkRungeKutta45::A[5] [static, protected]

Definition at line 122 of file vtkRungeKutta45.h.

double vtkRungeKutta45::B[5][5] [static, protected]

Definition at line 123 of file vtkRungeKutta45.h.

double vtkRungeKutta45::C[6] [static, protected]

Definition at line 124 of file vtkRungeKutta45.h.

double vtkRungeKutta45::DC[6] [static, protected]

Definition at line 125 of file vtkRungeKutta45.h.

float* vtkRungeKutta45::NextDerivs[6] [protected]

Definition at line 127 of file vtkRungeKutta45.h.

The documentation for this class was generated from the following file:
  • Common/vtkRungeKutta45.h
Generated on Mon Mar 25 01:30:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSampleFunction Class Reference

sample an implicit function over a structured point set. More...

#include <vtkSampleFunction.h>

Inheritance diagram for vtkSampleFunction:

[legend]
Collaboration diagram for vtkSampleFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSampleFunction, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSampleDimensions (int i, int j, int k)
unsigned long | GetMTime ()
virtual void | SetImplicitFunction (vtkImplicitFunction *)
virtual vtkImplicitFunction * | GetImplicitFunction ()
virtual void | SetScalars (vtkDataArray *)
void | SetSampleDimensions (int dim[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetModelBounds (float, float, float, float, float, float)
virtual void | SetModelBounds (float[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetCapValue (float)
virtual float | GetCapValue ()
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()

Static Public Methods

vtkSampleFunction * | New ()

Protected Methods

vtkSampleFunction ()
~vtkSampleFunction ()
void | Execute ()
void | ExecuteInformation ()
void | Cap (vtkDataArray *s)

Protected Attributes

int | SampleDimensions [3]
float | ModelBounds [6]
vtkDataArray * Scalars
int | Capping
float | CapValue
vtkImplicitFunction * ImplicitFunction
int | ComputeNormals

Detailed Description

sample an implicit function over a structured point set.

Date:
2002/01/22 15:33:44
Revision:
1.43

vtkSampleFunction is a source object that evaluates an implicit function and normals at each point in a vtkStructuredPoints. The user can specify the sample dimensions and location in space to perform the sampling. To create closed surfaces (in conjunction with the vtkContourFilter), capping can be turned on to set a particular value on the boundaries of the sample space.

See also:
vtkImplicitModeller
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Martin, Ken (12%)
  • Lorensen, Bill (8%)
  • Geveci, Berk (5%)
Examples:
vtkSampleFunction (Examples)
Tests:
vtkSampleFunction (Tests)

Definition at line 54 of file vtkSampleFunction.h.

Constructor & Destructor Documentation

vtkSampleFunction::vtkSampleFunction ( ) [protected]

vtkSampleFunction::~vtkSampleFunction ( ) [protected]

Member Function Documentation

vtkSampleFunction::vtkTypeRevisionMacro | ( | vtkSampleFunction | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

void vtkSampleFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSampleFunction* vtkSampleFunction::New ( ) [static]

Construct with ModelBounds=(-1,1,-1,1,-1,1), SampleDimensions=(50,50,50), Capping turned off, and normal generation on.

Reimplemented from vtkStructuredPointsSource.

virtual void vtkSampleFunction::SetImplicitFunction ( vtkImplicitFunction * ) [virtual]

Specify the implicit function to use to generate data.

virtual vtkImplicitFunction* vtkSampleFunction::GetImplicitFunction ( ) [virtual]

Specify the implicit function to use to generate data.

virtual void vtkSampleFunction::SetScalars ( vtkDataArray * ) [virtual]

Control the type of the scalars object by explicitly providing a scalar object. vtkSampleFunction() will allocate space (as necessary) in the scalar object.

void vtkSampleFunction::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Specify the dimensions of the data on which to sample.

void vtkSampleFunction::SetSampleDimensions ( int dim[3] )

Specify the dimensions of the data on which to sample.

virtual int* vtkSampleFunction::GetSampleDimensions ( ) [virtual]

Specify the dimensions of the data on which to sample.

virtual void vtkSampleFunction::GetSampleDimensions ( int data[3] ) [virtual]

Specify the dimensions of the data on which to sample.

virtual void vtkSampleFunction::SetModelBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the region in space over which the sampling occurs.

virtual void vtkSampleFunction::SetModelBounds ( float [6] ) [virtual]

Specify the region in space over which the sampling occurs.

virtual float* vtkSampleFunction::GetModelBounds ( ) [virtual]

Specify the region in space over which the sampling occurs.

virtual void vtkSampleFunction::GetModelBounds ( float data[6] ) [virtual]

Specify the region in space over which the sampling occurs.

virtual void vtkSampleFunction::SetCapping ( int ) [virtual]

Turn on/off capping. If capping is on, then the outer boundaries of the structured point set are set to cap value. This can be used to insure surfaces are closed.

virtual int vtkSampleFunction::GetCapping ( ) [virtual]

Turn on/off capping. If capping is on, then the outer boundaries of the structured point set are set to cap value. This can be used to insure surfaces are closed.

virtual void vtkSampleFunction::CappingOn ( ) [virtual]

Turn on/off capping. If capping is on, then the outer boundaries of the structured point set are set to cap value. This can be used to insure surfaces are closed.

virtual void vtkSampleFunction::CappingOff ( ) [virtual]

Turn on/off capping. If capping is on, then the outer boundaries of the structured point set are set to cap value. This can be used to insure surfaces are closed.

virtual void vtkSampleFunction::SetCapValue ( float ) [virtual]

Set the cap value.

virtual float vtkSampleFunction::GetCapValue ( ) [virtual]

Set the cap value.

virtual void vtkSampleFunction::SetComputeNormals ( int ) [virtual]

Turn on/off the computation of normals.

virtual int vtkSampleFunction::GetComputeNormals ( ) [virtual]

Turn on/off the computation of normals.

virtual void vtkSampleFunction::ComputeNormalsOn ( ) [virtual]

Turn on/off the computation of normals.

virtual void vtkSampleFunction::ComputeNormalsOff ( ) [virtual]

Turn on/off the computation of normals.

unsigned long vtkSampleFunction::GetMTime ( ) [virtual]

Return the MTime also considering the implicit function.

Reimplemented from vtkObject.

void vtkSampleFunction::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSampleFunction::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsSource.

void vtkSampleFunction::Cap ( vtkDataArray * s ) [protected]

Member Data Documentation

int vtkSampleFunction::SampleDimensions[3] [protected]

Definition at line 126 of file vtkSampleFunction.h.

float vtkSampleFunction::ModelBounds[6] [protected]

Definition at line 127 of file vtkSampleFunction.h.

vtkDataArray* vtkSampleFunction::Scalars [protected]

Definition at line 128 of file vtkSampleFunction.h.

int vtkSampleFunction::Capping [protected]

Definition at line 129 of file vtkSampleFunction.h.

float vtkSampleFunction::CapValue [protected]

Definition at line 130 of file vtkSampleFunction.h.

vtkImplicitFunction* vtkSampleFunction::ImplicitFunction [protected]

Definition at line 131 of file vtkSampleFunction.h.

int vtkSampleFunction::ComputeNormals [protected]

Definition at line 132 of file vtkSampleFunction.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkSampleFunction.h
Generated on Mon Mar 25 01:30:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarBarActor Class Reference

Create a scalar bar with labels. More...

#include <vtkScalarBarActor.h>

Inheritance diagram for vtkScalarBarActor:

[legend]
Collaboration diagram for vtkScalarBarActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkScalarBarActor, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | ShallowCopy (vtkProp *prop)
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *viewport)
virtual void | SetLookupTable (vtkScalarsToColors *)
virtual vtkScalarsToColors * | GetLookupTable ()
virtual void | SetMaximumNumberOfColors (int)
virtual int | GetMaximumNumberOfColors ()
virtual void | SetNumberOfLabels (int)
virtual int | GetNumberOfLabels ()
virtual void | SetOrientation (int)
virtual int | GetOrientation ()
void | SetOrientationToHorizontal ()
void | SetOrientationToVertical ()
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
virtual void | SetTitle (const char *)
virtual char * | GetTitle ()

Static Public Methods

vtkScalarBarActor * | New ()

Protected Methods

vtkScalarBarActor ()
~vtkScalarBarActor ()

Protected Attributes

vtkScalarsToColors * LookupTable
int | MaximumNumberOfColors
int | NumberOfLabels
int | NumberOfLabelsBuilt
int | Orientation
char * | Title
int | Bold
int | Italic
int | Shadow
int | FontFamily
char * | LabelFormat

Detailed Description

Create a scalar bar with labels.

Date:
2002/01/22 15:39:23
Revision:
1.37

vtkScalarBarActor creates a scalar bar with annotation text. A scalar bar is a legend that indicates to the viewer the correspondence between color value and data value. The legend consists of a rectangular bar made of rectangular pieces each colored a constant value. Since vtkScalarBarActor is a subclass of vtkActor2D, it is drawn in the image plane (i.e., in the renderer's viewport) on top of the 3D graphics window.

To use vtkScalarBarActor you must associate a vtkScalarsToColors (or subclass) with it. The lookup table defines the colors and the range of scalar values used to map scalar data. Typically, the number of colors shown in the scalar bar is not equal to the number of colors in the lookup table, in which case sampling of the lookup table is performed.

Other optional capabilities include specifying the fraction of the viewport size (both x and y directions) which will control the size of the scalar bar, the number of annotation labels, and the font attributes of the annotation text. The actual position of the scalar bar on the screen is controlled by using the vtkActor2D::SetPosition() method (by default the scalar bar is centered in the viewport). Other features include the ability to orient the scalar bar horizontally of vertically and controlling the format (printf style) with which to print the labels on the scalar bar. Also, the vtkScalarBarActor's property is applied to the scalar bar and annotation (including color, layer, and compositing operator).

See also:
vtkActor2D vtkTextMapper vtkPolyDataMapper2D
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Martin, Ken (43%)
  • Schroeder, Will (36%)
  • Miller, Jim (5%)
Tests:
vtkScalarBarActor (Tests)

Definition at line 75 of file vtkScalarBarActor.h.

Constructor & Destructor Documentation

vtkScalarBarActor::vtkScalarBarActor ( ) [protected]

vtkScalarBarActor::~vtkScalarBarActor ( ) [protected]

Member Function Documentation

vtkScalarBarActor::vtkTypeRevisionMacro | ( | vtkScalarBarActor | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkScalarBarActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkScalarBarActor* vtkScalarBarActor::New ( ) [static]

Instantiate object with 64 maximum colors; 5 labels; font size 12 of font Arial (bolding, italic, shadows on); %-#6.3g label format, no title, and vertical orientation. The initial scalar bar size is (0.05 x 0.8) of the viewport size.

Reimplemented from vtkActor2D.

int vtkScalarBarActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

Draw the scalar bar and annotation text to the screen.

Reimplemented from vtkActor2D.

int vtkScalarBarActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

Draw the scalar bar and annotation text to the screen.

Reimplemented from vtkActor2D.

Definition at line 91 of file vtkScalarBarActor.h.

int vtkScalarBarActor::RenderOverlay ( vtkViewport * viewport ) [virtual]

Draw the scalar bar and annotation text to the screen.

Reimplemented from vtkActor2D.

virtual void vtkScalarBarActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

virtual void vtkScalarBarActor::SetLookupTable ( vtkScalarsToColors * ) [virtual]

Set/Get the vtkLookupTable to use. The lookup table specifies the number of colors to use in the table (if not overridden), as well as the scalar range.

virtual vtkScalarsToColors* vtkScalarBarActor::GetLookupTable ( ) [virtual]

Set/Get the vtkLookupTable to use. The lookup table specifies the number of colors to use in the table (if not overridden), as well as the scalar range.

virtual void vtkScalarBarActor::SetMaximumNumberOfColors ( int ) [virtual]

Set/Get the maximum number of scalar bar segments to show. This may differ from the number of colors in the lookup table, in which case the colors are samples from the lookup table.

virtual int vtkScalarBarActor::GetMaximumNumberOfColors ( ) [virtual]

Set/Get the maximum number of scalar bar segments to show. This may differ from the number of colors in the lookup table, in which case the colors are samples from the lookup table.

virtual void vtkScalarBarActor::SetNumberOfLabels ( int ) [virtual]

Set/Get the number of annotation labels to show.

virtual int vtkScalarBarActor::GetNumberOfLabels ( ) [virtual]

Set/Get the number of annotation labels to show.

virtual void vtkScalarBarActor::SetOrientation ( int ) [virtual]

Control the orientation of the scalar bar.

virtual int vtkScalarBarActor::GetOrientation ( ) [virtual]

Control the orientation of the scalar bar.

void vtkScalarBarActor::SetOrientationToHorizontal ( ) [inline]

Control the orientation of the scalar bar.

Definition at line 126 of file vtkScalarBarActor.h.

void vtkScalarBarActor::SetOrientationToVertical ( ) [inline]

Control the orientation of the scalar bar.

Definition at line 128 of file vtkScalarBarActor.h.

virtual void vtkScalarBarActor::SetBold ( int ) [virtual]

Enable/Disable bolding annotation text.

virtual int vtkScalarBarActor::GetBold ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkScalarBarActor::BoldOn ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkScalarBarActor::BoldOff ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkScalarBarActor::SetItalic ( int ) [virtual]

Enable/Disable italicizing annotation text.

virtual int vtkScalarBarActor::GetItalic ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkScalarBarActor::ItalicOn ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkScalarBarActor::ItalicOff ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkScalarBarActor::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual int vtkScalarBarActor::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkScalarBarActor::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkScalarBarActor::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkScalarBarActor::SetFontFamily ( int ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkScalarBarActor::GetFontFamily ( ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkScalarBarActor::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 159 of file vtkScalarBarActor.h.

void vtkScalarBarActor::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 160 of file vtkScalarBarActor.h.

void vtkScalarBarActor::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 161 of file vtkScalarBarActor.h.

virtual void vtkScalarBarActor::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual char* vtkScalarBarActor::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual void vtkScalarBarActor::SetTitle ( const char * ) [virtual]

Set/Get the title of the scalar bar actor,

virtual char* vtkScalarBarActor::GetTitle ( ) [virtual]

Set/Get the title of the scalar bar actor,

void vtkScalarBarActor::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of a scalar bar actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor2D.

Member Data Documentation

vtkScalarsToColors* vtkScalarBarActor::LookupTable [protected]

Definition at line 184 of file vtkScalarBarActor.h.

int vtkScalarBarActor::MaximumNumberOfColors [protected]

Definition at line 185 of file vtkScalarBarActor.h.

int vtkScalarBarActor::NumberOfLabels [protected]

Definition at line 186 of file vtkScalarBarActor.h.

int vtkScalarBarActor::NumberOfLabelsBuilt [protected]

Definition at line 187 of file vtkScalarBarActor.h.

int vtkScalarBarActor::Orientation [protected]

Definition at line 188 of file vtkScalarBarActor.h.

char* vtkScalarBarActor::Title [protected]

Definition at line 189 of file vtkScalarBarActor.h.

int vtkScalarBarActor::Bold [protected]

Definition at line 191 of file vtkScalarBarActor.h.

int vtkScalarBarActor::Italic [protected]

Definition at line 192 of file vtkScalarBarActor.h.

int vtkScalarBarActor::Shadow [protected]

Definition at line 193 of file vtkScalarBarActor.h.

int vtkScalarBarActor::FontFamily [protected]

Definition at line 194 of file vtkScalarBarActor.h.

char* vtkScalarBarActor::LabelFormat [protected]

Definition at line 195 of file vtkScalarBarActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkScalarBarActor.h
Generated on Mon Mar 25 01:30:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarsToColors Class Reference

map scalar values into colors. More...

#include <vtkScalarsToColors.h>

Inheritance diagram for vtkScalarsToColors:

[legend]
Collaboration diagram for vtkScalarsToColors:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkScalarsToColors, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Build ()
virtual unsigned char * | MapValue (float v)=0
virtual void | GetColor (float v, float rgb[3])=0
virtual float * | GetRange ()=0
virtual void | SetRange (float min, float max)=0
void | SetRange (float rng[2])
float * | GetColor (float v)
virtual float | GetOpacity (float vtkNotUsed(v))
float | GetLuminance (float x)
void | SetAlpha (float alpha)
virtual float | GetAlpha ()
vtkUnsignedCharArray * | MapScalars (vtkDataArray *scalars, int colorMode, int component)
void | MapScalarsThroughTable (vtkDataArray *scalars, unsigned char *output, int outputFormat)
void | MapScalarsThroughTable (vtkDataArray *scalars, unsigned char *output)
virtual void | MapScalarsThroughTable2 (void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputFormat)=0
virtual vtkUnsignedCharArray * | ConvertUnsignedCharToRGBA (vtkUnsignedCharArray *colors, int numComp, int numTuples)

Protected Methods

vtkScalarsToColors ()
~vtkScalarsToColors ()

Protected Attributes

float | Alpha

Detailed Description

map scalar values into colors.

Date:
2002/01/22 15:26:19
Revision:
1.23

vtkScalarsToColors is a general purpose superclass for objects that convert scalars to colors. This include vtkLookupTable classes and color transfer functions.

The scalars to color mapping can be augmented with an additional uniform alpha blend. This is used, for example, to blend a vtkActor's opacity with the lookup table values.

See also:
vtkLookupTable vtkColorTransferFunction
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Martin, Ken (29%)
  • Gobbi, David (18%)

Definition at line 58 of file vtkScalarsToColors.h.

Constructor & Destructor Documentation

vtkScalarsToColors::vtkScalarsToColors ( ) [inline, protected]

Definition at line 159 of file vtkScalarsToColors.h.

vtkScalarsToColors::~vtkScalarsToColors ( ) [inline, protected]

Definition at line 160 of file vtkScalarsToColors.h.

Member Function Documentation

vtkScalarsToColors::vtkTypeRevisionMacro | ( | vtkScalarsToColors | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkLogLookupTable, vtkLookupTable, vtkWindowLevelLookupTable, and vtkColorTransferFunction.

void vtkScalarsToColors::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkLogLookupTable, vtkLookupTable, vtkWindowLevelLookupTable, and vtkColorTransferFunction.

virtual void vtkScalarsToColors::Build ( ) [inline, virtual]

Perform any processing required (if any) before processing scalars.

Reimplemented in vtkLookupTable, and vtkWindowLevelLookupTable.

Definition at line 65 of file vtkScalarsToColors.h.

virtual float* vtkScalarsToColors::GetRange ( ) [pure virtual]

Sets/Gets the range of scalars which will be mapped.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

virtual void vtkScalarsToColors::SetRange | ( | float | min,
 |  | float | max
 | ) | [pure virtual]

Sets/Gets the range of scalars which will be mapped.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

Referenced by vtkColorTransferFunction::SetRange(), and vtkLookupTable::SetRange().

void vtkScalarsToColors::SetRange ( float rng[2] ) [inline]

Sets/Gets the range of scalars which will be mapped.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

Definition at line 71 of file vtkScalarsToColors.h.

virtual unsigned char* vtkScalarsToColors::MapValue ( float v ) [pure virtual]

Map one value through the lookup table and return a color defined as a RGBA unsigned char tuple (4 bytes).

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

virtual void vtkScalarsToColors::GetColor | ( | float | x,
 |  | float | rgb[3]
 | ) | [pure virtual]

Map one value through the lookup table and return the color as an RGB array of floats between 0 and 1.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

Referenced by vtkColorTransferFunction::GetColor(), and vtkLookupTable::GetColor().

float* vtkScalarsToColors::GetColor ( float x ) [inline]

Map one value through the lookup table and return the color as an RGB array of floats between 0 and 1.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

Definition at line 86 of file vtkScalarsToColors.h.

virtual float vtkScalarsToColors::GetOpacity ( float vtkNotUsed(v) ) [inline, virtual]

Map one value through the lookup table and return the alpha value (the opacity) as a float between 0 and 1.

Definition at line 93 of file vtkScalarsToColors.h.

float vtkScalarsToColors::GetLuminance ( float x ) [inline]

Map one value through the lookup table and return the luminance 0.3*red + 0.59*green + 0.11*blue as a float between 0 and 1. Returns the luminance value for the specified scalar value.

Definition at line 101 of file vtkScalarsToColors.h.

void vtkScalarsToColors::SetAlpha ( float alpha )

Specify an additional opacity (alpha) value to blend with. Values != 1 modify the resulting color consistent with the requested form of the output. This is typically used by an actor in order to blend its opacity.

virtual float vtkScalarsToColors::GetAlpha ( ) [virtual]

Specify an additional opacity (alpha) value to blend with. Values != 1 modify the resulting color consistent with the requested form of the output. This is typically used by an actor in order to blend its opacity.

vtkUnsignedCharArray* vtkScalarsToColors::MapScalars | ( | vtkDataArray * | scalars,
 |  | int | colorMode,
 |  | int | component
 | ) |

An internal method maps a data array into a 4-component, unsigned char RGBA array. The color mode determines the behavior of mapping. If VTK_COLOR_MODE_DEFAULT is set, then unsigned char data arrays are treated as colors (and converted to RGBA if necessary); otherwise, the data is mapped through this instance of ScalarsToColors. The offset is used for data arrays with more than one component; it indicates which component to use to do the blending.

void vtkScalarsToColors::MapScalarsThroughTable | ( | vtkDataArray * | scalars,
 |  | unsigned char * | output,
 |  | int | outputFormat
 | ) |

Map a set of scalars through the lookup table in a single operation. The output format can be set to VTK_RGBA (4 components), VTK_RGB (3 components), VTK_LUMINANCE (1 component, greyscale), or VTK_LUMINANCE_ALPHA (2 components) If not supplied, the output format defaults to RGBA.

void vtkScalarsToColors::MapScalarsThroughTable | ( | vtkDataArray * | scalars,
 |  | unsigned char * | output
 | ) | [inline]

Map a set of scalars through the lookup table in a single operation. The output format can be set to VTK_RGBA (4 components), VTK_RGB (3 components), VTK_LUMINANCE (1 component, greyscale), or VTK_LUMINANCE_ALPHA (2 components) If not supplied, the output format defaults to RGBA.

Definition at line 136 of file vtkScalarsToColors.h.

virtual void vtkScalarsToColors::MapScalarsThroughTable2 | ( | void * | input,
 |  | unsigned char * | output,
 |  | int | inputDataType,
 |  | int | numberOfValues,
 |  | int | inputIncrement,
 |  | int | outputIncrement
 | ) | [pure virtual]

An internal method typically not used in applications.

Reimplemented in vtkLookupTable, and vtkColorTransferFunction.

virtual vtkUnsignedCharArray* vtkScalarsToColors::ConvertUnsignedCharToRGBA | ( | vtkUnsignedCharArray * | colors,
 |  | int | numComp,
 |  | int | numTuples
 | ) | [virtual]

An internal method used to convert a color array to RGBA. The method instantiates a vtkUnsignedCharArray and returns it. The user is responsible for managing the memory.

Member Data Documentation

float vtkScalarsToColors::Alpha [protected]

Definition at line 162 of file vtkScalarsToColors.h.

The documentation for this class was generated from the following file:
  • Common/vtkScalarsToColors.h
Generated on Mon Mar 25 01:30:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScalarTree Class Reference

organize data according to scalar values (used to accelerate contouring operations). More...

#include <vtkScalarTree.h>

Inheritance diagram for vtkScalarTree:

[legend]
Collaboration diagram for vtkScalarTree:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkScalarTree, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | BuildTree ()=0
virtual void | Initialize ()=0
virtual void | InitTraversal (float scalarValue)=0
virtual void | SetDataSet (vtkDataSet *)
virtual vtkDataSet * | GetDataSet ()
virtual vtkCell * | GetNextCell (vtkIdType &cellId, vtkIdList *&ptIds, vtkDataArray *cellScalars)=0

Protected Methods

vtkScalarTree ()
~vtkScalarTree ()

Protected Attributes

vtkDataSet * DataSet
vtkDataArray * Scalars
vtkTimeStamp BuildTime
float | ScalarValue

Detailed Description

organize data according to scalar values (used to accelerate contouring operations).

Date:
2002/01/22 15:28:11
Revision:
1.31

vtkScalarTree is an abstract class that defines the API to concrete scalar tree subclasses. A scalar tree is a data structure that organizes data according to its scalar value. This allows rapid access to data for those algorithms that access the data based on scalar value. For example, isocontouring operates on cells based on the scalar (isocontour) value.

To use subclasses of this class, you must specify a dataset to operate on, and then specify a scalar value in the InitTraversal() method. Then calls to GetNextCell() return cells whose scalar data contains the scalar value specified.

See also:
vtkSimpleScalarTree vtkBONOScalarTree
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Geveci, Berk (6%)
  • Lorensen, Bill (6%)

Definition at line 52 of file vtkScalarTree.h.

Constructor & Destructor Documentation

vtkScalarTree::vtkScalarTree ( ) [protected]

vtkScalarTree::~vtkScalarTree ( ) [protected]

Member Function Documentation

vtkScalarTree::vtkTypeRevisionMacro | ( | vtkScalarTree | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkSimpleScalarTree.

void vtkScalarTree::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkSimpleScalarTree.

virtual void vtkScalarTree::SetDataSet ( vtkDataSet * ) [virtual]

Build the tree from the points/cells defining this dataset.

virtual vtkDataSet* vtkScalarTree::GetDataSet ( ) [virtual]

Build the tree from the points/cells defining this dataset.

virtual void vtkScalarTree::BuildTree ( ) [pure virtual]

Construct the scalar tree from the dataset provided. Checks build times and modified time from input and reconstructs the tree if necessary.

Reimplemented in vtkSimpleScalarTree.

virtual void vtkScalarTree::Initialize ( ) [pure virtual]

Initialize locator. Frees memory and resets object as appropriate.

Reimplemented in vtkSimpleScalarTree.

virtual void vtkScalarTree::InitTraversal ( float scalarValue ) [pure virtual]

Begin to traverse the cells based on a scalar value. Returned cells will have scalar values that span the scalar value specified.

Reimplemented in vtkSimpleScalarTree.

virtual vtkCell* vtkScalarTree::GetNextCell | ( | vtkIdType & | cellId,
 |  | vtkIdList *& | ptIds,
 |  | vtkDataArray * | cellScalars
 | ) | [pure virtual]

Return the next cell that may contain scalar value specified to initialize traversal. The value NULL is returned if the list is exhausted. Make sure that InitTraversal() has been invoked first or you'll get erratic behavior.

Reimplemented in vtkSimpleScalarTree.

Member Data Documentation

vtkDataSet* vtkScalarTree::DataSet [protected]

Definition at line 89 of file vtkScalarTree.h.

vtkDataArray* vtkScalarTree::Scalars [protected]

Reimplemented in vtkSimpleScalarTree.

Definition at line 90 of file vtkScalarTree.h.

vtkTimeStamp vtkScalarTree::BuildTime [protected]

Definition at line 92 of file vtkScalarTree.h.

float vtkScalarTree::ScalarValue [protected]

Definition at line 93 of file vtkScalarTree.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkScalarTree.h
Generated on Mon Mar 25 01:30:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkScaledTextActor Class Reference

create text that will scale as needed. More...

#include <vtkScaledTextActor.h>

Inheritance diagram for vtkScaledTextActor:

[legend]
Collaboration diagram for vtkScaledTextActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkScaledTextActor, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetMapper (vtkTextMapper *mapper)
void | SetMapper (vtkMapper2D *mapper)
vtkMapper2D * | GetMapper (void)
void | ShallowCopy (vtkProp *prop)
virtual void | ReleaseGraphicsResources (vtkWindow *)
virtual void | SetMinimumSize (int, int)
void | SetMinimumSize (int[2])
virtual int * | GetMinimumSize ()
virtual void | GetMinimumSize (int &, int &)
virtual void | GetMinimumSize (int[2])
virtual void | SetMaximumLineHeight (float)
virtual float | GetMaximumLineHeight ()
int | RenderOpaqueGeometry (vtkViewport *viewport)
int | RenderTranslucentGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *viewport)

Static Public Methods

vtkScaledTextActor * | New ()

Protected Methods

vtkScaledTextActor ()
~vtkScaledTextActor ()

Protected Attributes

int | MinimumSize [2]
float | MaximumLineHeight
vtkActor2D * TextActor
vtkTimeStamp BuildTime
int | LastSize [2]
int | LastOrigin [2]

Detailed Description

create text that will scale as needed.

Date:
2002/01/22 15:39:24
Revision:
1.24

vtkScaledTextActor can be used to place text annotation into a window and have the font size scale so that the text always bounded by a specified rectangle.

See also:
vtkActor2D vtkTextMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (64%)
  • Biddiscombe, John (12%)
  • Law, Charles (10%)
  • Schroeder, Will (9%)
Examples:
vtkScaledTextActor (Examples)

Definition at line 48 of file vtkScaledTextActor.h.

Constructor & Destructor Documentation

vtkScaledTextActor::vtkScaledTextActor ( ) [protected]

vtkScaledTextActor::~vtkScaledTextActor ( ) [protected]

Member Function Documentation

vtkScaledTextActor::vtkTypeRevisionMacro | ( | vtkScaledTextActor | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkScaledTextActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkScaledTextActor* vtkScaledTextActor::New ( ) [static]

Instantiate object with a rectangle in normaled view coordinates of (0.2,0.85, 0.8, 0.95).

Reimplemented from vtkActor2D.

void vtkScaledTextActor::SetMapper ( vtkTextMapper * mapper )

Set/Get the vtkTextMapper that defines the text to be drawn.

void vtkScaledTextActor::SetMapper ( vtkMapper2D * mapper ) [virtual]

Set/Get the vtkMapper2D which defines the data to be drawn.

Reimplemented from vtkActor2D.

vtkMapper2D* vtkScaledTextActor::GetMapper ( void ) [virtual]

Get the vtkTextMapper that defines the text to be drawn.

Reimplemented from vtkActor2D.

virtual void vtkScaledTextActor::SetMinimumSize | ( | int | ,
 |  | int |
 | ) | [virtual]

Set/Get the minimum size in pixels for this actor. Defaults to 10,10.

void vtkScaledTextActor::SetMinimumSize ( int [2] )

Set/Get the minimum size in pixels for this actor. Defaults to 10,10.

virtual int* vtkScaledTextActor::GetMinimumSize ( ) [virtual]

Set/Get the minimum size in pixels for this actor. Defaults to 10,10.

virtual void vtkScaledTextActor::GetMinimumSize | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Set/Get the minimum size in pixels for this actor. Defaults to 10,10.

virtual void vtkScaledTextActor::GetMinimumSize ( int [2] ) [virtual]

Set/Get the minimum size in pixels for this actor. Defaults to 10,10.

virtual void vtkScaledTextActor::SetMaximumLineHeight ( float ) [virtual]

Set/Get the maximum height of a line of text as a percentage of the vertical area allocated to this scaled text actor. Defaults to 1.0.

virtual float vtkScaledTextActor::GetMaximumLineHeight ( ) [virtual]

Set/Get the maximum height of a line of text as a percentage of the vertical area allocated to this scaled text actor. Defaults to 1.0.

void vtkScaledTextActor::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this scaled text actor. Overloads the virtual vtkProp method.

Reimplemented from vtkActor2D.

virtual void vtkScaledTextActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

int vtkScaledTextActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the scaled text actor to the screen.

Reimplemented from vtkActor2D.

int vtkScaledTextActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the scaled text actor to the screen.

Reimplemented from vtkActor2D.

Definition at line 97 of file vtkScaledTextActor.h.

int vtkScaledTextActor::RenderOverlay ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the scaled text actor to the screen.

Reimplemented from vtkActor2D.

Member Data Documentation

int vtkScaledTextActor::MinimumSize[2] [protected]

Definition at line 106 of file vtkScaledTextActor.h.

float vtkScaledTextActor::MaximumLineHeight [protected]

Definition at line 107 of file vtkScaledTextActor.h.

vtkActor2D* vtkScaledTextActor::TextActor [protected]

Definition at line 109 of file vtkScaledTextActor.h.

vtkTimeStamp vtkScaledTextActor::BuildTime [protected]

Definition at line 110 of file vtkScaledTextActor.h.

int vtkScaledTextActor::LastSize[2] [protected]

Definition at line 111 of file vtkScaledTextActor.h.

int vtkScaledTextActor::LastOrigin[2] [protected]

Definition at line 112 of file vtkScaledTextActor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkScaledTextActor.h
Generated on Mon Mar 25 01:30:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSelectPolyData Class Reference

select portion of polygonal mesh; generate selection scalars. More...

#include <vtkSelectPolyData.h>

Inheritance diagram for vtkSelectPolyData:

[legend]
Collaboration diagram for vtkSelectPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSelectPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * GetUnselectedOutput ()
vtkPolyData * GetSelectionEdges ()
unsigned long int | GetMTime ()
void | UnRegister (vtkObject *o)
virtual int | InRegisterLoop (vtkObject *)
virtual void | SetGenerateSelectionScalars (int)
virtual int | GetGenerateSelectionScalars ()
virtual void | GenerateSelectionScalarsOn ()
virtual void | GenerateSelectionScalarsOff ()
virtual void | SetInsideOut (int)
virtual int | GetInsideOut ()
virtual void | InsideOutOn ()
virtual void | InsideOutOff ()
virtual void | SetLoop (vtkPoints *)
virtual vtkPoints * | GetLoop ()
virtual void | SetSelectionMode (int)
virtual int | GetSelectionMode ()
void | SetSelectionModeToSmallestRegion ()
void | SetSelectionModeToLargestRegion ()
void | SetSelectionModeToClosestPointRegion ()
const char * | GetSelectionModeAsString ()
virtual void | SetGenerateUnselectedOutput (int)
virtual int | GetGenerateUnselectedOutput ()
virtual void | GenerateUnselectedOutputOn ()
virtual void | GenerateUnselectedOutputOff ()

Static Public Methods

vtkSelectPolyData * | New ()

Protected Methods

vtkSelectPolyData ()
~vtkSelectPolyData ()
void | Execute ()

Protected Attributes

int | GenerateSelectionScalars
int | InsideOut
vtkPoints * Loop
int | SelectionMode
float | ClosestPoint [3]
int | GenerateUnselectedOutput
vtkPolyData * UnselectedOutput
vtkPolyData * SelectionEdges

Detailed Description

select portion of polygonal mesh; generate selection scalars.

Date:
2002/01/22 15:29:44
Revision:
1.20

vtkSelectPolyData is a filter that selects polygonal data based on defining a "loop" and indicating the region inside of the loop. The mesh within the loop consists of complete cells (the cells are not cut). Alternatively, this filter can be used to generate scalars. These scalar values, which are a distance measure to the loop, can be used to clip, contour. or extract data (i.e., anything that an implicit function can do).

The loop is defined by an array of x-y-z point coordinates. (Coordinates should be in the same coordinate space as the input polygonal data.) The loop can be concave and non-planar, but not self-intersecting. The input to the filter is a polygonal mesh (only surface primitives such as triangle strips and polygons); the output is either a) a portion of the original mesh laying within the selection loop (GenerateSelectionScalarsOff); or b) the same polygonal mesh with the addition of scalar values (GenerateSelectionScalarsOn).

The algorithm works as follows. For each point coordinate in the loop, the closest point in the mesh is found. The result is a loop of closest point ids from the mesh. Then, the edges in the mesh connecting the closest points (and laying along the lines forming the loop) are found. A greedy edge tracking procedure is used as follows. At the current point, the mesh edge oriented in the direction of and whose end point is closest to the line is chosen. The edge is followed to the new end point, and the procedure is repeated. This process continues until the entire loop has been created.

To determine what portion of the mesh is inside and outside of the loop, three options are possible. 1) the smallest connected region, 2) the largest connected region, and 3) the connected region closest to a user specified point. (Set the ivar SelectionMode.)

Once the loop is computed as above, the GenerateSelectionScalars controls the output of the filter. If on, then scalar values are generated based on distance to the loop lines. Otherwise, the cells laying inside the selection loop are output. By default, the mesh lying within the loop is output; however, if InsideOut is on, then the portion of the mesh lying outside of the loop is output.

The filter can be configured to generate the unselected portions of the mesh as output by setting GenerateUnselectedOutput. Use the method GetUnselectedOutput to access this output. (Note: this flag is pertinent only when GenerateSelectionScalars is off.)

Warning:
Make sure that the points you pick are on a connected surface. If not, then the filter will generate an empty or partial result. Also, self-intersecting loops will generate unpredictable results.
Warning:
During processing of the data, non-triangular cells are converted to triangles if GenerateSelectionScalars is off.
See also:
vtkImplicitSelectionLoop
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (78%)
  • Martin, Ken (8%)
  • Lorensen, Bill (5%)
Tests:
vtkSelectPolyData (Tests)

Definition at line 103 of file vtkSelectPolyData.h.

Constructor & Destructor Documentation

vtkSelectPolyData::vtkSelectPolyData ( ) [protected]

vtkSelectPolyData::~vtkSelectPolyData ( ) [protected]

Member Function Documentation

vtkSelectPolyData* vtkSelectPolyData::New ( ) [static]

Instantiate object with InsideOut turned off, and GenerateSelectionScalars turned off. The unselected output is not generated, and the inside mode is the smallest region.

Reimplemented from vtkPolyDataSource.

vtkSelectPolyData::vtkTypeRevisionMacro | ( | vtkSelectPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkSelectPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkSelectPolyData::SetGenerateSelectionScalars ( int ) [virtual]

Set/Get the flag to control behavior of the filter. If GenerateSelectionScalars is on, then the output of the filter is the same as the input, except that scalars are generated. If off, the filter outputs the cells laying inside the loop, and does not generate scalars.

virtual int vtkSelectPolyData::GetGenerateSelectionScalars ( ) [virtual]

Set/Get the flag to control behavior of the filter. If GenerateSelectionScalars is on, then the output of the filter is the same as the input, except that scalars are generated. If off, the filter outputs the cells laying inside the loop, and does not generate scalars.

virtual void vtkSelectPolyData::GenerateSelectionScalarsOn ( ) [virtual]

Set/Get the flag to control behavior of the filter. If GenerateSelectionScalars is on, then the output of the filter is the same as the input, except that scalars are generated. If off, the filter outputs the cells laying inside the loop, and does not generate scalars.

virtual void vtkSelectPolyData::GenerateSelectionScalarsOff ( ) [virtual]

Set/Get the flag to control behavior of the filter. If GenerateSelectionScalars is on, then the output of the filter is the same as the input, except that scalars are generated. If off, the filter outputs the cells laying inside the loop, and does not generate scalars.

virtual void vtkSelectPolyData::SetInsideOut ( int ) [virtual]

Set/Get the InsideOut flag. When off, the mesh within the loop is extracted. When on, the mesh outside the loop is extracted.

virtual int vtkSelectPolyData::GetInsideOut ( ) [virtual]

Set/Get the InsideOut flag. When off, the mesh within the loop is extracted. When on, the mesh outside the loop is extracted.

virtual void vtkSelectPolyData::InsideOutOn ( ) [virtual]

Set/Get the InsideOut flag. When off, the mesh within the loop is extracted. When on, the mesh outside the loop is extracted.

virtual void vtkSelectPolyData::InsideOutOff ( ) [virtual]

Set/Get the InsideOut flag. When off, the mesh within the loop is extracted. When on, the mesh outside the loop is extracted.

virtual void vtkSelectPolyData::SetLoop ( vtkPoints * ) [virtual]

Set/Get the array of point coordinates defining the loop. There must be at least three points used to define a loop.

virtual vtkPoints* vtkSelectPolyData::GetLoop ( ) [virtual]

Set/Get the array of point coordinates defining the loop. There must be at least three points used to define a loop.

virtual void vtkSelectPolyData::SetSelectionMode ( int ) [virtual]

Control how inside/outside of loop is defined.

virtual int vtkSelectPolyData::GetSelectionMode ( ) [virtual]

Control how inside/outside of loop is defined.

void vtkSelectPolyData::SetSelectionModeToSmallestRegion ( ) [inline]

Control how inside/outside of loop is defined.

Definition at line 145 of file vtkSelectPolyData.h.

void vtkSelectPolyData::SetSelectionModeToLargestRegion ( ) [inline]

Control how inside/outside of loop is defined.

Definition at line 147 of file vtkSelectPolyData.h.

void vtkSelectPolyData::SetSelectionModeToClosestPointRegion ( ) [inline]

Control how inside/outside of loop is defined.

Definition at line 149 of file vtkSelectPolyData.h.

const char * vtkSelectPolyData::GetSelectionModeAsString ( void ) [inline]

Return the method of determining in/out of loop as a string.

Definition at line 202 of file vtkSelectPolyData.h.

virtual void vtkSelectPolyData::SetGenerateUnselectedOutput ( int ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's not been selected.

virtual int vtkSelectPolyData::GetGenerateUnselectedOutput ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's not been selected.

virtual void vtkSelectPolyData::GenerateUnselectedOutputOn ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's not been selected.

virtual void vtkSelectPolyData::GenerateUnselectedOutputOff ( ) [virtual]

Control whether a second output is generated. The second output contains the polygonal data that's not been selected.

vtkPolyData* vtkSelectPolyData::GetUnselectedOutput ( ) [inline]

Return output that hasn't been selected (if GenreateUnselectedOutput is enabled).

Definition at line 164 of file vtkSelectPolyData.h.

vtkPolyData* vtkSelectPolyData::GetSelectionEdges ( ) [inline]

Return the (mesh) edges of the selection region.

Definition at line 167 of file vtkSelectPolyData.h.

unsigned long int vtkSelectPolyData::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented from vtkObject.

void vtkSelectPolyData::UnRegister ( vtkObject * o ) [virtual]

Handle the source/data loop.

Reimplemented from vtkSource.

virtual int vtkSelectPolyData::InRegisterLoop ( vtkObject * ) [virtual]

Test to see if this object is in a reference counting loop.

Reimplemented from vtkSource.

void vtkSelectPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkSelectPolyData::GenerateSelectionScalars [protected]

Definition at line 184 of file vtkSelectPolyData.h.

int vtkSelectPolyData::InsideOut [protected]

Definition at line 185 of file vtkSelectPolyData.h.

vtkPoints* vtkSelectPolyData::Loop [protected]

Definition at line 186 of file vtkSelectPolyData.h.

int vtkSelectPolyData::SelectionMode [protected]

Definition at line 187 of file vtkSelectPolyData.h.

float vtkSelectPolyData::ClosestPoint[3] [protected]

Definition at line 188 of file vtkSelectPolyData.h.

int vtkSelectPolyData::GenerateUnselectedOutput [protected]

Definition at line 189 of file vtkSelectPolyData.h.

vtkPolyData* vtkSelectPolyData::UnselectedOutput [protected]

Definition at line 190 of file vtkSelectPolyData.h.

vtkPolyData* vtkSelectPolyData::SelectionEdges [protected]

Definition at line 191 of file vtkSelectPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSelectPolyData.h
Generated on Mon Mar 25 01:30:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSelectVisiblePoints Class Reference

extract points that are visible (based on z-buffer calculation). More...

#include <vtkSelectVisiblePoints.h>

Inheritance diagram for vtkSelectVisiblePoints:

[legend]
Collaboration diagram for vtkSelectVisiblePoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSelectVisiblePoints, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | SetRenderer (vtkRenderer *ren)
vtkRenderer * GetRenderer ()
virtual void | SetSelectionWindow (int)
virtual int | GetSelectionWindow ()
virtual void | SelectionWindowOn ()
virtual void | SelectionWindowOff ()
virtual void | SetSelection (int, int, int, int)
virtual void | SetSelection (int[4])
virtual int * | GetSelection ()
virtual void | GetSelection (int data[4])
virtual void | SetSelectInvisible (int)
virtual int | GetSelectInvisible ()
virtual void | SelectInvisibleOn ()
virtual void | SelectInvisibleOff ()
virtual void | SetTolerance (float)
virtual float | GetTolerance ()

Static Public Methods

vtkSelectVisiblePoints * | New ()

Protected Methods

vtkSelectVisiblePoints ()
~vtkSelectVisiblePoints ()
void | Execute ()

Protected Attributes

vtkRenderer * Renderer
int | SelectionWindow
int | Selection [4]
int | SelectInvisible
float | Tolerance

Detailed Description

extract points that are visible (based on z-buffer calculation).

Date:
2002/01/22 15:39:25
Revision:
1.22

vtkSelectVisiblePoints is a filter that selects points based on whether they are visible or not. Visibility is determined by accessing the z-buffer of a rendering window. (The position of each input point is converted into display coordinates, and then the z-value at that point is obtained. If within the user-specified tolerance, the point is considered visible.)

Points that are visible (or if the ivar SelectInvisible is on, invisible points) are passed to the output. Associated data attributes are passed to the output as well.

This filter also allows you to specify a rectangular window in display (pixel) coordinates in which the visible points must lie. This can be used as a sort of local "brushing" operation to select just data within a window.

Warning:
You must carefully synchronize the execution of this filter. The filter refers to a renderer, which is modified every time a render occurs. Therefore, the filter is always out of date, and always executes. You may have to perform two rendering passes, or if you are using this filter in conjunction with vtkLabeledPointMapper, things work out because 2D rendering occurs after the 3D rendering.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Miller, Jim (11%)
Examples:
vtkSelectVisiblePoints (Examples)
Tests:
vtkSelectVisiblePoints (Tests)

Definition at line 67 of file vtkSelectVisiblePoints.h.

Constructor & Destructor Documentation

vtkSelectVisiblePoints::vtkSelectVisiblePoints ( ) [protected]

vtkSelectVisiblePoints::~vtkSelectVisiblePoints ( ) [protected]

Member Function Documentation

vtkSelectVisiblePoints::vtkTypeRevisionMacro | ( | vtkSelectVisiblePoints | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkSelectVisiblePoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSelectVisiblePoints* vtkSelectVisiblePoints::New ( ) [static]

Instantiate object with no renderer; window selection turned off; tolerance set to 0.01; and select invisible off.

Reimplemented from vtkPolyDataSource.

void vtkSelectVisiblePoints::SetRenderer ( vtkRenderer * ren ) [inline]

Specify the renderer in which the visibility computation is to be performed.

Definition at line 80 of file vtkSelectVisiblePoints.h.

vtkRenderer* vtkSelectVisiblePoints::GetRenderer ( ) [inline]

Specify the renderer in which the visibility computation is to be performed.

Definition at line 88 of file vtkSelectVisiblePoints.h.

virtual void vtkSelectVisiblePoints::SetSelectionWindow ( int ) [virtual]

Set/Get the flag which enables selection in a rectangular display region.

virtual int vtkSelectVisiblePoints::GetSelectionWindow ( ) [virtual]

Set/Get the flag which enables selection in a rectangular display region.

virtual void vtkSelectVisiblePoints::SelectionWindowOn ( ) [virtual]

Set/Get the flag which enables selection in a rectangular display region.

virtual void vtkSelectVisiblePoints::SelectionWindowOff ( ) [virtual]

Set/Get the flag which enables selection in a rectangular display region.

virtual void vtkSelectVisiblePoints::SetSelection | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify the selection window in display coordinates. You must specify a rectangular region using (xmin,xmax,ymin,ymax).

virtual void vtkSelectVisiblePoints::SetSelection ( int [4] ) [virtual]

Specify the selection window in display coordinates. You must specify a rectangular region using (xmin,xmax,ymin,ymax).

virtual int* vtkSelectVisiblePoints::GetSelection ( ) [virtual]

Specify the selection window in display coordinates. You must specify a rectangular region using (xmin,xmax,ymin,ymax).

virtual void vtkSelectVisiblePoints::GetSelection ( int data[4] ) [virtual]

Specify the selection window in display coordinates. You must specify a rectangular region using (xmin,xmax,ymin,ymax).

virtual void vtkSelectVisiblePoints::SetSelectInvisible ( int ) [virtual]

Set/Get the flag which enables inverse selection; i.e., invisible points are selected.

virtual int vtkSelectVisiblePoints::GetSelectInvisible ( ) [virtual]

Set/Get the flag which enables inverse selection; i.e., invisible points are selected.

virtual void vtkSelectVisiblePoints::SelectInvisibleOn ( ) [virtual]

Set/Get the flag which enables inverse selection; i.e., invisible points are selected.

virtual void vtkSelectVisiblePoints::SelectInvisibleOff ( ) [virtual]

Set/Get the flag which enables inverse selection; i.e., invisible points are selected.

virtual void vtkSelectVisiblePoints::SetTolerance ( float ) [virtual]

Set/Get a tolerance to use to determine whether a point is visible. A tolerance is usually required because the conversion from world space to display space during rendering introduces numerical round-off.

virtual float vtkSelectVisiblePoints::GetTolerance ( ) [virtual]

Set/Get a tolerance to use to determine whether a point is visible. A tolerance is usually required because the conversion from world space to display space during rendering introduces numerical round-off.

unsigned long vtkSelectVisiblePoints::GetMTime ( ) [virtual]

Return MTime also considering the renderer.

Reimplemented from vtkObject.

void vtkSelectVisiblePoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkRenderer* vtkSelectVisiblePoints::Renderer [protected]

Definition at line 131 of file vtkSelectVisiblePoints.h.

int vtkSelectVisiblePoints::SelectionWindow [protected]

Definition at line 133 of file vtkSelectVisiblePoints.h.

int vtkSelectVisiblePoints::Selection[4] [protected]

Definition at line 134 of file vtkSelectVisiblePoints.h.

int vtkSelectVisiblePoints::SelectInvisible [protected]

Definition at line 135 of file vtkSelectVisiblePoints.h.

float vtkSelectVisiblePoints::Tolerance [protected]

Definition at line 136 of file vtkSelectVisiblePoints.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkSelectVisiblePoints.h
Generated on Mon Mar 25 01:30:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


SetGet Class Reference

#include <vtkSetGet.h>

Detailed Description

Date:
2002/03/22 15:37:58
Revision:
1.100

The SetGet macros are used to interface to instance variables in a standard fashion. This includes properly treating modified time and printing out debug information.

Macros are available for built-in types; for character strings; vector arrays of built-in types size 2,3,4; for setting objects; and debug, warning, and error printout information.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (52%)
  • Schroeder, Will (20%)
  • Cedilnik, Andy (11%)

The documentation for this class was generated from the following file:
  • Common/vtkSetGet.h
Generated on Mon Mar 25 01:30:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSharedMemoryCommunicator Class Reference

Provides communication using shared memory. More...

#include <vtkSharedMemoryCommunicator.h>

Inheritance diagram for vtkSharedMemoryCommunicator:

[legend]
Collaboration diagram for vtkSharedMemoryCommunicator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSharedMemoryCommunicator, vtkObject)
virtual void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | Send (int *data, int length, int remoteThreadId, int tag)
virtual int | Send (unsigned long *data, int length, int remoteThreadId, int tag)
virtual int | Send (char *data, int length, int remoteThreadId, int tag)
virtual int | Send (unsigned char *data, int length, int remoteThreadId, int tag)
virtual int | Send (float *data, int length, int remoteThreadId, int tag)
virtual int | Send (double *data, int length, int remoteThreadId, int tag)
virtual int | Send (vtkDataObject *data, int remoteThreadId, int tag)
virtual int | Send (vtkDataArray *data, int remoteThreadId, int tag)
virtual int | Receive (int *data, int length, int remoteThreadId, int tag)
virtual int | Receive (unsigned long *data, int length, int remoteThreadId, int tag)
virtual int | Receive (char *data, int length, int remoteThreadId, int tag)
virtual int | Receive (unsigned char *data, int length, int remoteThreadId, int tag)
virtual int | Receive (float *data, int length, int remoteThreadId, int tag)
virtual int | Receive (double *data, int length, int remoteThreadId, int tag)
virtual int | Receive (vtkDataObject *data, int remoteThreadId, int tag)
virtual int | Receive (vtkDataArray *data, int remoteThreadId, int tag)

Static Public Methods

vtkSharedMemoryCommunicator * | New ()

Protected Methods

void | Initialize (int nThreads, int forceDeepCopy)
vtkSharedMemoryCommunicator ()
~vtkSharedMemoryCommunicator ()
int | Send (vtkDataObject *object, void *data, int dataLength, int remoteThreadId, int tag)
int | Receive (vtkDataObject *object, void *data, int dataLength, int remoteThreadId, int tag)
int | Send (vtkDataArray *object, int dataLength, int remoteThreadId, int tag)
int | Receive (vtkDataArray *object, int dataLength, int remoteThreadId, int tag)
vtkSharedMemoryCommunicatorMessage * | NewMessage (vtkDataObject *object, void *data, int dataLength)
vtkSharedMemoryCommunicatorMessage * | NewMessage (vtkDataArray *object, void *data, int dataLength)
void | DeleteMessage (vtkSharedMemoryCommunicatorMessage *message)
void | AddMessage (vtkSharedMemoryCommunicatorMessage *message)
vtkSharedMemoryCommunicatorMessage * | FindMessage (int sendId, int tag)
void | SignalNewMessage (vtkSharedMemoryCommunicator *receiveCommunicator)
void | WaitForNewMessage ()

Protected Attributes

int | NumberOfThreads
int | Initialized
int | LocalThreadId
int | WaitingForId
int | ForceDeepCopy
vtkSimpleCriticalSection * MessageListLock
vtkSharedMemoryCommunicator ** | Communicators
vtkSharedMemoryCommunicator * | Parent
vtkSharedMemoryCommunicatorMessage * | MessageListStart
vtkSharedMemoryCommunicatorMessage * | MessageListEnd
vtkSimpleCriticalSection * Gate

Friends

class | vtkThreadedController

Detailed Description

Provides communication using shared memory.

Date:
2002/01/22 15:34:56
Revision:
1.12

This class is used together with vtkThreadedController for communication between threads. Once initialized, it creates one communicator per thread. The messages to be sent are copied to the message list of the appropriate communicator by the sending thread and then read by the receiving thread. Mutexes are used to ensure safe access to the data structures. By default, when an object is sent, it is copied with DeepCopy. This behavior can be changed by un-setting ForceDeepCopy.

See also:
vtkCommunicator vtkThreadedController
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (67%)
  • Geveci, Berk (23%)

Definition at line 53 of file vtkSharedMemoryCommunicator.h.

Constructor & Destructor Documentation

vtkSharedMemoryCommunicator::vtkSharedMemoryCommunicator ( ) [protected]

vtkSharedMemoryCommunicator::~vtkSharedMemoryCommunicator ( ) [protected]

Member Function Documentation

vtkSharedMemoryCommunicator::vtkTypeRevisionMacro | ( | vtkSharedMemoryCommunicator | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkCommunicator.

vtkSharedMemoryCommunicator* vtkSharedMemoryCommunicator::New ( ) [static]

Creates an empty communicator.

Reimplemented from vtkObject.

virtual void vtkSharedMemoryCommunicator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | int * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | float * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | double * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | vtkDataObject * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method sends a data object to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Send | ( | vtkDataArray * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method sends a data array to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | int * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished. It calls methods in "data" to communicate the sending data.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | float * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | double * | data,
 |  | int | length,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | vtkDataObject * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method receives a data object from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

virtual int vtkSharedMemoryCommunicator::Receive | ( | vtkDataArray * | data,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [virtual]

This method receives a data array from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

void vtkSharedMemoryCommunicator::Initialize | ( | int | nThreads,
 |  | int | forceDeepCopy
 | ) | [protected]

int vtkSharedMemoryCommunicator::Send | ( | vtkDataObject * | object,
 |  | void * | data,
 |  | int | dataLength,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [protected]

int vtkSharedMemoryCommunicator::Receive | ( | vtkDataObject * | object,
 |  | void * | data,
 |  | int | dataLength,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [protected]

int vtkSharedMemoryCommunicator::Send | ( | vtkDataArray * | object,
 |  | int | dataLength,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [protected]

int vtkSharedMemoryCommunicator::Receive | ( | vtkDataArray * | object,
 |  | int | dataLength,
 |  | int | remoteThreadId,
 |  | int | tag
 | ) | [protected]

vtkSharedMemoryCommunicatorMessage* vtkSharedMemoryCommunicator::NewMessage | ( | vtkDataObject * | object,
 |  | void * | data,
 |  | int | dataLength
 | ) | [protected]

vtkSharedMemoryCommunicatorMessage* vtkSharedMemoryCommunicator::NewMessage | ( | vtkDataArray * | object,
 |  | void * | data,
 |  | int | dataLength
 | ) | [protected]

void vtkSharedMemoryCommunicator::DeleteMessage ( vtkSharedMemoryCommunicatorMessage * message ) [protected]

void vtkSharedMemoryCommunicator::AddMessage ( vtkSharedMemoryCommunicatorMessage * message ) [protected]

vtkSharedMemoryCommunicatorMessage* vtkSharedMemoryCommunicator::FindMessage | ( | int | sendId,
 |  | int | tag
 | ) | [protected]

void vtkSharedMemoryCommunicator::SignalNewMessage ( vtkSharedMemoryCommunicator * receiveCommunicator ) [inline, protected]

Definition at line 172 of file vtkSharedMemoryCommunicator.h.

void vtkSharedMemoryCommunicator::WaitForNewMessage ( ) [inline, protected]

Definition at line 181 of file vtkSharedMemoryCommunicator.h.

Friends And Related Function Documentation

friend class vtkThreadedController [friend]

Definition at line 108 of file vtkSharedMemoryCommunicator.h.

Member Data Documentation

int vtkSharedMemoryCommunicator::NumberOfThreads [protected]

Definition at line 114 of file vtkSharedMemoryCommunicator.h.

int vtkSharedMemoryCommunicator::Initialized [protected]

Definition at line 115 of file vtkSharedMemoryCommunicator.h.

int vtkSharedMemoryCommunicator::LocalThreadId [protected]

Definition at line 118 of file vtkSharedMemoryCommunicator.h.

int vtkSharedMemoryCommunicator::WaitingForId [protected]

Definition at line 119 of file vtkSharedMemoryCommunicator.h.

int vtkSharedMemoryCommunicator::ForceDeepCopy [protected]

Definition at line 121 of file vtkSharedMemoryCommunicator.h.

vtkSimpleCriticalSection* vtkSharedMemoryCommunicator::MessageListLock [protected]

Definition at line 126 of file vtkSharedMemoryCommunicator.h.

vtkSharedMemoryCommunicator** vtkSharedMemoryCommunicator::Communicators [protected]

Definition at line 130 of file vtkSharedMemoryCommunicator.h.

vtkSharedMemoryCommunicator* vtkSharedMemoryCommunicator::Parent [protected]

Definition at line 132 of file vtkSharedMemoryCommunicator.h.

vtkSharedMemoryCommunicatorMessage* vtkSharedMemoryCommunicator::MessageListStart [protected]

Definition at line 135 of file vtkSharedMemoryCommunicator.h.

vtkSharedMemoryCommunicatorMessage* vtkSharedMemoryCommunicator::MessageListEnd [protected]

Definition at line 136 of file vtkSharedMemoryCommunicator.h.

vtkSimpleCriticalSection* vtkSharedMemoryCommunicator::Gate [protected]

Definition at line 169 of file vtkSharedMemoryCommunicator.h.

Referenced by SignalNewMessage().

The documentation for this class was generated from the following file:
  • Parallel/vtkSharedMemoryCommunicator.h
Generated on Mon Mar 25 01:30:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShepardMethod Class Reference

sample unstructured points onto structured points using the method of Shepard. More...

#include <vtkShepardMethod.h>

Inheritance diagram for vtkShepardMethod:

[legend]
Collaboration diagram for vtkShepardMethod:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkShepardMethod, vtkDataSetToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
float | ComputeModelBounds (float origin[3], float ar[3])
void | SetSampleDimensions (int i, int j, int k)
void | SetSampleDimensions (int dim[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetMaximumDistance (float)
virtual float | GetMaximumDistance ()
virtual void | SetModelBounds (float, float, float, float, float, float)
virtual void | SetModelBounds (float[6])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
virtual void | SetNullValue (float)
virtual float | GetNullValue ()

Static Public Methods

vtkShepardMethod * | New ()

Protected Methods

vtkShepardMethod ()
~vtkShepardMethod ()
void | Execute ()

Protected Attributes

int | SampleDimensions [3]
float | MaximumDistance
float | ModelBounds [6]
float | NullValue

Detailed Description

sample unstructured points onto structured points using the method of Shepard.

Date:
2002/01/22 15:33:45
Revision:
1.37

vtkShepardMethod is a filter used to visualize unstructured point data using Shepard's method. The method works by resampling the unstructured points onto a structured points set. The influence functions are described as "inverse distance weighted". Once the structured points are computed, the usual visualization techniques (e.g., iso-contouring or volume rendering) can be used visualize the structured points.

Warning:
The input to this filter is any dataset type. This filter can be used to resample any form of data, i.e., the input data need not be unstructured.
Warning:
The bounds of the data (i.e., the sample space) is automatically computed if not set by the user.
Warning:
If you use a maximum distance less than 1.0, some output points may never receive a contribution. The final value of these points can be specified with the "NullValue" instance variable.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Martin, Ken (10%)
  • Lorensen, Bill (9%)
Tests:
vtkShepardMethod (Tests)

Definition at line 59 of file vtkShepardMethod.h.

Constructor & Destructor Documentation

vtkShepardMethod::vtkShepardMethod ( ) [protected]

vtkShepardMethod::~vtkShepardMethod ( ) [inline, protected]

Definition at line 109 of file vtkShepardMethod.h.

Member Function Documentation

vtkShepardMethod::vtkTypeRevisionMacro | ( | vtkShepardMethod | ,
 |  | vtkDataSetToStructuredPointsFilter |
 | ) |

Reimplemented from vtkDataSetToStructuredPointsFilter.

void vtkShepardMethod::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkShepardMethod* vtkShepardMethod::New ( ) [static]

Construct with sample dimensions=(50,50,50) and so that model bounds are automatically computed from input. Null value for each unvisited output point is 0.0. Maximum distance is 0.25.

Reimplemented from vtkStructuredPointsSource.

float vtkShepardMethod::ComputeModelBounds | ( | float | origin[3],
 |  | float | ar[3]
 | ) |

Compute ModelBounds from input geometry.

virtual int* vtkShepardMethod::GetSampleDimensions ( ) [virtual]

Specify i-j-k dimensions on which to sample input points.

virtual void vtkShepardMethod::GetSampleDimensions ( int data[3] ) [virtual]

Specify i-j-k dimensions on which to sample input points.

void vtkShepardMethod::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set the i-j-k dimensions on which to sample the distance function.

void vtkShepardMethod::SetSampleDimensions ( int dim[3] )

Set the i-j-k dimensions on which to sample the distance function.

virtual void vtkShepardMethod::SetMaximumDistance ( float ) [virtual]

Specify influence distance of each input point. This distance is a fraction of the length of the diagonal of the sample space. Thus, values of 1.0 will cause each input point to influence all points in the structured point dataset. Values less than 1.0 can improve performance significantly.

virtual float vtkShepardMethod::GetMaximumDistance ( ) [virtual]

Specify influence distance of each input point. This distance is a fraction of the length of the diagonal of the sample space. Thus, values of 1.0 will cause each input point to influence all points in the structured point dataset. Values less than 1.0 can improve performance significantly.

virtual void vtkShepardMethod::SetModelBounds | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the position in space to perform the sampling.

virtual void vtkShepardMethod::SetModelBounds ( float [6] ) [virtual]

Specify the position in space to perform the sampling.

virtual float* vtkShepardMethod::GetModelBounds ( ) [virtual]

Specify the position in space to perform the sampling.

virtual void vtkShepardMethod::GetModelBounds ( float data[6] ) [virtual]

Specify the position in space to perform the sampling.

virtual void vtkShepardMethod::SetNullValue ( float ) [virtual]

Set the Null value for output points not receiving a contribution from the input points.

virtual float vtkShepardMethod::GetNullValue ( ) [virtual]

Set the Null value for output points not receiving a contribution from the input points.

void vtkShepardMethod::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkShepardMethod::SampleDimensions[3] [protected]

Definition at line 113 of file vtkShepardMethod.h.

float vtkShepardMethod::MaximumDistance [protected]

Definition at line 114 of file vtkShepardMethod.h.

float vtkShepardMethod::ModelBounds[6] [protected]

Definition at line 115 of file vtkShepardMethod.h.

float vtkShepardMethod::NullValue [protected]

Definition at line 116 of file vtkShepardMethod.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkShepardMethod.h
Generated on Mon Mar 25 01:30:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShortArray Class Reference

dynamic, self-adjusting short integer array. More...

#include <vtkShortArray.h>

Inheritance diagram for vtkShortArray:

[legend]
Collaboration diagram for vtkShortArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkShortArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
short | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const short i)
vtkIdType | InsertNextValue (const short)
short * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const short value)
void * | GetVoidPointer (const vtkIdType id)
short * | GetPointer (const vtkIdType id)
void | SetArray (short *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkShortArray * | New ()

Protected Methods

vtkShortArray (vtkIdType numComp=1)
~vtkShortArray ()
short * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

short * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting short integer array.

Date:
2002/02/13 22:46:29
Revision:
1.64

vtkShortArray is an array of short integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (42%)
  • Martin, Ken (21%)
  • Henderson, Amy (8%)
  • Miller, Jim (7%)
  • Geveci, Berk (7%)
  • Kelly, Ann (6%)
Tests:
vtkShortArray (Tests)

Definition at line 46 of file vtkShortArray.h.

Constructor & Destructor Documentation

vtkShortArray::vtkShortArray ( vtkIdType numComp = 1 ) [protected]

vtkShortArray::~vtkShortArray ( ) [protected]

Member Function Documentation

vtkShortArray* vtkShortArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkShortArray::vtkTypeRevisionMacro | ( | vtkShortArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkShortArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkShortArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkShortArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkShortArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkShortArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkShortArray.h.

int vtkShortArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkShortArray.h.

void vtkShortArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkShortArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkShortArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkShortArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkShortArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkShortArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkShortArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkShortArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkShortArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkShortArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkShortArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 104 of file vtkShortArray.h.

virtual void vtkShortArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

float vtkShortArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkShortArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkShortArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

short vtkShortArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 126 of file vtkShortArray.h.

void vtkShortArray::SetValue | ( | const vtkIdType | id,
 |  | const short | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 131 of file vtkShortArray.h.

void vtkShortArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 191 of file vtkShortArray.h.

void vtkShortArray::InsertValue | ( | const vtkIdType | id,
 |  | const short | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 213 of file vtkShortArray.h.

Referenced by InsertNextValue().

vtkIdType vtkShortArray::InsertNextValue ( const short i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 226 of file vtkShortArray.h.

short * vtkShortArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 198 of file vtkShortArray.h.

void* vtkShortArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 155 of file vtkShortArray.h.

short* vtkShortArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 157 of file vtkShortArray.h.

void vtkShortArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another short array.

Reimplemented from vtkDataArray.

void vtkShortArray::SetArray | ( | short * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkShortArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 171 of file vtkShortArray.h.

short* vtkShortArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

short* vtkShortArray::Array [protected]

Definition at line 179 of file vtkShortArray.h.

int vtkShortArray::TupleSize [protected]

Definition at line 182 of file vtkShortArray.h.

float* vtkShortArray::Tuple [protected]

Definition at line 183 of file vtkShortArray.h.

int vtkShortArray::SaveUserArray [protected]

Definition at line 185 of file vtkShortArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkShortArray.h
Generated on Mon Mar 25 01:30:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShrinkFilter Class Reference

shrink cells composing an arbitrary data set. More...

#include <vtkShrinkFilter.h>

Inheritance diagram for vtkShrinkFilter:

[legend]
Collaboration diagram for vtkShrinkFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkShrinkFilter, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetShrinkFactor (float)
virtual float | GetShrinkFactor ()

Static Public Methods

vtkShrinkFilter * | New ()

Protected Methods

vtkShrinkFilter (float sf=0.5)
~vtkShrinkFilter ()
void | Execute ()

Protected Attributes

float | ShrinkFactor

Detailed Description

shrink cells composing an arbitrary data set.

Date:
2002/01/22 15:29:44
Revision:
1.44

vtkShrinkFilter shrinks cells composing an arbitrary data set towards their centroid. The centroid of a cell is computed as the average position of the cell points. Shrinking results in disconnecting the cells from one another. The output of this filter is of general dataset type vtkUnstructuredGrid.

Warning:
It is possible to turn cells inside out or cause self intersection in special cases.
See also:
vtkShrinkPolyData
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Martin, Ken (22%)
  • Lee, Jeff (7%)
  • Lorensen, Bill (5%)
Examples:
vtkShrinkFilter (Examples)
Tests:
vtkShrinkFilter (Tests)

Definition at line 56 of file vtkShrinkFilter.h.

Constructor & Destructor Documentation

vtkShrinkFilter::vtkShrinkFilter ( float sf = 0.5 ) [protected]

vtkShrinkFilter::~vtkShrinkFilter ( ) [inline, protected]

Definition at line 75 of file vtkShrinkFilter.h.

Member Function Documentation

vtkShrinkFilter* vtkShrinkFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkShrinkFilter::vtkTypeRevisionMacro | ( | vtkShrinkFilter | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkShrinkFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkShrinkFilter::SetShrinkFactor ( float ) [virtual]

Set the fraction of shrink for each cell.

virtual float vtkShrinkFilter::GetShrinkFactor ( ) [virtual]

Get the fraction of shrink for each cell.

void vtkShrinkFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkShrinkFilter::ShrinkFactor [protected]

Definition at line 78 of file vtkShrinkFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkShrinkFilter.h
Generated on Mon Mar 25 01:31:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkShrinkPolyData Class Reference

shrink cells composing PolyData. More...

#include <vtkShrinkPolyData.h>

Inheritance diagram for vtkShrinkPolyData:

[legend]
Collaboration diagram for vtkShrinkPolyData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkShrinkPolyData, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetShrinkFactor (float)
virtual float | GetShrinkFactor ()

Static Public Methods

vtkShrinkPolyData * | New ()

Protected Methods

vtkShrinkPolyData (float sf=0.5)
~vtkShrinkPolyData ()
void | Execute ()

Protected Attributes

float | ShrinkFactor

Detailed Description

shrink cells composing PolyData.

Date:
2002/01/22 15:29:44
Revision:
1.48

vtkShrinkPolyData shrinks cells composing a polygonal dataset (e.g., vertices, lines, polygons, and triangle strips) towards their centroid. The centroid of a cell is computed as the average position of the cell points. Shrinking results in disconnecting the cells from one another. The output dataset type of this filter is polygonal data.

During execution the filter passes its input cell data to its output. Point data attributes are copied to the points created during the shrinking process.

Warning:
It is possible to turn cells inside out or cause self intersection in special cases.
See also:
vtkShrinkFilter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Schroeder, Will (50%)
  • Martin, Ken (39%)
  • Lorensen, Bill (6%)
Examples:
vtkShrinkPolyData (Examples)
Tests:
vtkShrinkPolyData (Tests)

Definition at line 59 of file vtkShrinkPolyData.h.

Constructor & Destructor Documentation

vtkShrinkPolyData::vtkShrinkPolyData ( float sf = 0.5 ) [protected]

vtkShrinkPolyData::~vtkShrinkPolyData ( ) [inline, protected]

Definition at line 78 of file vtkShrinkPolyData.h.

Member Function Documentation

vtkShrinkPolyData* vtkShrinkPolyData::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkShrinkPolyData::vtkTypeRevisionMacro | ( | vtkShrinkPolyData | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkShrinkPolyData::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkShrinkPolyData::SetShrinkFactor ( float ) [virtual]

Set the fraction of shrink for each cell.

virtual float vtkShrinkPolyData::GetShrinkFactor ( ) [virtual]

Get the fraction of shrink for each cell.

void vtkShrinkPolyData::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkShrinkPolyData::ShrinkFactor [protected]

Definition at line 81 of file vtkShrinkPolyData.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkShrinkPolyData.h
Generated on Mon Mar 25 01:31:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleCriticalSection Class Reference

#include <vtkCriticalSection.h>

Collaboration diagram for vtkSimpleCriticalSection:

[legend]
List of all members.

Public Methods

vtkSimpleCriticalSection ()
vtkSimpleCriticalSection (int isLocked)
void | Init ()
virtual | ~vtkSimpleCriticalSection ()
virtual const char * | GetClassName ()
virtual int | IsA (const char *name)
void | Delete ()
void | Lock (void)
void | Unlock (void)

Static Public Methods

vtkSimpleCriticalSection * | New ()
vtkSimpleCriticalSection * | SafeDownCast (vtkSimpleCriticalSection *o)

Protected Attributes

vtkCritSecType CritSec

Constructor & Destructor Documentation

vtkSimpleCriticalSection::vtkSimpleCriticalSection ( ) [inline]

Definition at line 80 of file vtkCriticalSection.h.

vtkSimpleCriticalSection::vtkSimpleCriticalSection ( int isLocked ) [inline]

Definition at line 85 of file vtkCriticalSection.h.

virtual vtkSimpleCriticalSection::~vtkSimpleCriticalSection ( ) [virtual]

Member Function Documentation

void vtkSimpleCriticalSection::Init ( )

vtkSimpleCriticalSection* vtkSimpleCriticalSection::New ( ) [static]

virtual const char* vtkSimpleCriticalSection::GetClassName ( ) [inline, virtual]

Definition at line 102 of file vtkCriticalSection.h.

virtual int vtkSimpleCriticalSection::IsA ( const char * name ) [virtual]

vtkSimpleCriticalSection* vtkSimpleCriticalSection::SafeDownCast ( vtkSimpleCriticalSection * o ) [static]

void vtkSimpleCriticalSection::Delete ( ) [inline]

Definition at line 106 of file vtkCriticalSection.h.

void vtkSimpleCriticalSection::Lock ( void )

Lock the vtkCriticalSection

Referenced by vtkCriticalSection::Lock(), and vtkSharedMemoryCommunicator::WaitForNewMessage().

void vtkSimpleCriticalSection::Unlock ( void )

Unlock the vtkCriticalSection

Referenced by vtkSharedMemoryCommunicator::SignalNewMessage(), and vtkCriticalSection::Unlock().

Member Data Documentation

vtkCritSecType vtkSimpleCriticalSection::CritSec [protected]

Definition at line 115 of file vtkCriticalSection.h.

The documentation for this class was generated from the following file:
  • Common/vtkCriticalSection.h
Generated on Mon Mar 25 01:31:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleElevationFilter Class Reference

generate scalars along a specified direction. More...

#include <vtkSimpleElevationFilter.h>

Inheritance diagram for vtkSimpleElevationFilter:

[legend]
Collaboration diagram for vtkSimpleElevationFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSimpleElevationFilter, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetVector (float, float, float)
virtual void | SetVector (float[3])
virtual float * | GetVector ()
virtual void | GetVector (float data[3])

Static Public Methods

vtkSimpleElevationFilter * | New ()

Protected Methods

vtkSimpleElevationFilter ()
~vtkSimpleElevationFilter ()
void | Execute ()

Protected Attributes

float | Vector [3]

Detailed Description

generate scalars along a specified direction.

Date:
2002/01/22 15:29:45
Revision:
1.12

vtkSimpleElevationFilter is a filter to generate scalar values from a dataset. The scalar values are generated by dotting a user-specified vector against a vector defined from the input dataset points to the origin.

See also:
vtkElevationFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (91%)
Tests:
vtkSimpleElevationFilter (Tests)

Definition at line 44 of file vtkSimpleElevationFilter.h.

Constructor & Destructor Documentation

vtkSimpleElevationFilter::vtkSimpleElevationFilter ( ) [protected]

vtkSimpleElevationFilter::~vtkSimpleElevationFilter ( ) [inline, protected]

Definition at line 61 of file vtkSimpleElevationFilter.h.

Member Function Documentation

vtkSimpleElevationFilter::vtkTypeRevisionMacro | ( | vtkSimpleElevationFilter | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkSimpleElevationFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSimpleElevationFilter* vtkSimpleElevationFilter::New ( ) [static]

Construct object with Vector=(0,0,1);

Reimplemented from vtkDataSetSource.

virtual void vtkSimpleElevationFilter::SetVector | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Define one end of the line (small scalar values).

virtual void vtkSimpleElevationFilter::SetVector ( float [3] ) [virtual]

Define one end of the line (small scalar values).

virtual float* vtkSimpleElevationFilter::GetVector ( ) [virtual]

Define one end of the line (small scalar values).

virtual void vtkSimpleElevationFilter::GetVector ( float data[3] ) [virtual]

Define one end of the line (small scalar values).

void vtkSimpleElevationFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkSimpleElevationFilter::Vector[3] [protected]

Definition at line 64 of file vtkSimpleElevationFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSimpleElevationFilter.h
Generated on Mon Mar 25 01:31:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleImageFilterExample Class Reference

Simple example of an image-image filter. More...

#include <vtkSimpleImageFilterExample.h>

Inheritance diagram for vtkSimpleImageFilterExample:

[legend]
Collaboration diagram for vtkSimpleImageFilterExample:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSimpleImageFilterExample, vtkSimpleImageToImageFilter)

Static Public Methods

vtkSimpleImageFilterExample * | New ()

Protected Methods

vtkSimpleImageFilterExample ()
~vtkSimpleImageFilterExample ()
virtual void | SimpleExecute (vtkImageData *input, vtkImageData *output)

Detailed Description

Simple example of an image-image filter.

Date:
2002/01/22 15:33:47
Revision:
1.11

This is an example of a simple image-image filter. It copies it's input to it's output (point by point). It shows how templates can be used to support various data types.

See also:
vtkSimpleImageFilterExample
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (81%)
  • Lorensen, Bill (10%)
  • Martin, Ken (7%)
Tests:
vtkSimpleImageFilterExample (Tests)

Definition at line 45 of file vtkSimpleImageFilterExample.h.

Constructor & Destructor Documentation

vtkSimpleImageFilterExample::vtkSimpleImageFilterExample ( ) [inline, protected]

Definition at line 53 of file vtkSimpleImageFilterExample.h.

vtkSimpleImageFilterExample::~vtkSimpleImageFilterExample ( ) [inline, protected]

Definition at line 54 of file vtkSimpleImageFilterExample.h.

Member Function Documentation

vtkSimpleImageFilterExample* vtkSimpleImageFilterExample::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkSimpleImageFilterExample::vtkTypeRevisionMacro | ( | vtkSimpleImageFilterExample | ,
 |  | vtkSimpleImageToImageFilter |
 | ) |

Reimplemented from vtkSimpleImageToImageFilter.

virtual void vtkSimpleImageFilterExample::SimpleExecute | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, virtual]

Reimplemented from vtkSimpleImageToImageFilter.

The documentation for this class was generated from the following file:
  • Imaging/vtkSimpleImageFilterExample.h
Generated on Mon Mar 25 01:31:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleImageToImageFilter Class Reference

Generic image filter with one input. More...

#include <vtkSimpleImageToImageFilter.h>

Inheritance diagram for vtkSimpleImageToImageFilter:

[legend]
Collaboration diagram for vtkSimpleImageToImageFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSimpleImageToImageFilter, vtkImageSource)
virtual void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Protected Methods

vtkSimpleImageToImageFilter ()
~vtkSimpleImageToImageFilter ()
virtual void | ExecuteInformation ()
virtual void | ComputeInputUpdateExtent (int inExt[6], int outExt[6])
virtual void | ExecuteData (vtkDataObject *output)
virtual void | SimpleExecute (vtkImageData *input, vtkImageData *output)=0

Detailed Description

Generic image filter with one input.

Date:
2002/01/22 15:28:12
Revision:
1.10

vtkSimpleImageToImageFilter is a filter which aims to avoid much of the complexity associated with vtkImageToImageFilter (i.e. support for pieces, multi-threaded operation). If you need to write a simple image-image filter which operates on the whole input, use this as the superclass. The subclass has to provide only an execute method which takes input and output as arguments. Memory allocation is handled in vtkSimpleImageToImageFilter. Also, you are guaranteed to have a valid input in the Execute(input, output) method. By default, this filter requests it's input's whole extent and copies the input's information (spacing, whole extent etc...) to the output. If the output's setup is different (for example, if it performs some sort of sub-sampling), ExecuteInformation has to be overwritten. As an example of how this can be done, you can look at vtkImageShrink3D::ExecuteInformation. For a complete example which uses templates to support generic data types, see vtkSimpleFilterExample.

See also:
vtkImageToImageFilter vtkSimpleImageFilterExample
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (87%)
  • Lorensen, Bill (6%)
  • Martin, Ken (6%)

Definition at line 56 of file vtkSimpleImageToImageFilter.h.

Constructor & Destructor Documentation

vtkSimpleImageToImageFilter::vtkSimpleImageToImageFilter ( ) [protected]

vtkSimpleImageToImageFilter::~vtkSimpleImageToImageFilter ( ) [protected]

Member Function Documentation

vtkSimpleImageToImageFilter::vtkTypeRevisionMacro | ( | vtkSimpleImageToImageFilter | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

Reimplemented in vtkSimpleImageFilterExample.

virtual void vtkSimpleImageToImageFilter::SetInput ( vtkImageData * input ) [virtual]

Set the Input of a filter.

vtkImageData* vtkSimpleImageToImageFilter::GetInput ( )

Set the Input of a filter.

virtual void vtkSimpleImageToImageFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkSimpleImageToImageFilter::ComputeInputUpdateExtent | ( | int | inExt[6],
 |  | int | outExt[6]
 | ) | [protected, virtual]

virtual void vtkSimpleImageToImageFilter::ExecuteData ( vtkDataObject * output ) [protected, virtual]

virtual void vtkSimpleImageToImageFilter::SimpleExecute | ( | vtkImageData * | input,
 |  | vtkImageData * | output
 | ) | [protected, pure virtual]

Reimplemented in vtkSimpleImageFilterExample.

The documentation for this class was generated from the following file:
  • Filtering/vtkSimpleImageToImageFilter.h
Generated on Mon Mar 25 01:31:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleMutexLock Class Reference

#include <vtkMutexLock.h>

Collaboration diagram for vtkSimpleMutexLock:

[legend]
List of all members.

Public Methods

vtkSimpleMutexLock ()
virtual | ~vtkSimpleMutexLock ()
virtual const char * | GetClassName ()
virtual int | IsA (const char *name)
void | Delete ()
void | Lock (void)
void | Unlock (void)

Static Public Methods

vtkSimpleMutexLock * | New ()
vtkSimpleMutexLock * | SafeDownCast (vtkSimpleMutexLock *o)

Protected Attributes

vtkMutexType MutexLock

Constructor & Destructor Documentation

vtkSimpleMutexLock::vtkSimpleMutexLock ( )

virtual vtkSimpleMutexLock::~vtkSimpleMutexLock ( ) [virtual]

Member Function Documentation

vtkSimpleMutexLock* vtkSimpleMutexLock::New ( ) [static]

virtual const char* vtkSimpleMutexLock::GetClassName ( ) [inline, virtual]

Definition at line 77 of file vtkMutexLock.h.

virtual int vtkSimpleMutexLock::IsA ( const char * name ) [virtual]

vtkSimpleMutexLock* vtkSimpleMutexLock::SafeDownCast ( vtkSimpleMutexLock * o ) [static]

void vtkSimpleMutexLock::Delete ( ) [inline]

Definition at line 81 of file vtkMutexLock.h.

void vtkSimpleMutexLock::Lock ( void )

Lock the vtkMutexLock

Referenced by vtkMutexLock::Lock().

void vtkSimpleMutexLock::Unlock ( void )

Unlock the vtkMutexLock

Referenced by vtkMutexLock::Unlock().

Member Data Documentation

vtkMutexType vtkSimpleMutexLock::MutexLock [protected]

Definition at line 90 of file vtkMutexLock.h.

The documentation for this class was generated from the following file:
  • Common/vtkMutexLock.h
Generated on Mon Mar 25 01:31:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSimpleScalarTree Class Reference

organize data according to scalar values (used to accelerate contouring operations). More...

#include <vtkSimpleScalarTree.h>

Inheritance diagram for vtkSimpleScalarTree:

[legend]
Collaboration diagram for vtkSimpleScalarTree:

[legend]
List of all members.

Public Methods

virtual void | BuildTree ()
virtual void | Initialize ()
virtual void | InitTraversal (float scalarValue)
vtkTypeRevisionMacro (vtkSimpleScalarTree, vtkScalarTree)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetBranchingFactor (int)
virtual int | GetBranchingFactor ()
virtual int | GetLevel ()
virtual void | SetMaxLevel (int)
virtual int | GetMaxLevel ()
virtual vtkCell * | GetNextCell (vtkIdType &cellId, vtkIdList *&ptIds, vtkDataArray *cellScalars)

Static Public Methods

vtkSimpleScalarTree * | New ()

Protected Methods

vtkSimpleScalarTree ()
~vtkSimpleScalarTree ()

Protected Attributes

vtkDataArray * Scalars
int | MaxLevel
int | Level
int | BranchingFactor
vtkScalarNode * | Tree
int | TreeSize

Detailed Description

organize data according to scalar values (used to accelerate contouring operations).

Date:
2002/01/22 15:28:12
Revision:
1.3

vtkSimpleScalarTree creates a pointerless binary tree that helps search for cells that lie within a particular scalar range. This object is used to accelerate some contouring (and other scalar-based techniques).

The tree consists of an array of (min,max) scalar range pairs per node in the tree. The (min,max) range is determined from looking at the range of the children of the tree node. If the node is a leaf, then the range is determined by scanning the range of scalar data in n cells in the dataset. The n cells are determined by arbitrary selecting cell ids from id(i) to id(i+n), and where n is specified using the BranchingFactor ivar. Note that leaf node i=0 contains the scalar range computed from cell ids (0,n-1); leaf node i=1 contains the range from cell ids (n,2n-1); and so on. The implication is that there are no direct lists of cell ids per leaf node, instead the cell ids are implicitly known.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (100%)

Definition at line 54 of file vtkSimpleScalarTree.h.

Constructor & Destructor Documentation

vtkSimpleScalarTree::vtkSimpleScalarTree ( ) [protected]

vtkSimpleScalarTree::~vtkSimpleScalarTree ( ) [protected]

Member Function Documentation

vtkSimpleScalarTree* vtkSimpleScalarTree::New ( ) [static]

Instantiate scalar tree with maximum level of 20 and branching factor of 5.

Reimplemented from vtkObject.

vtkSimpleScalarTree::vtkTypeRevisionMacro | ( | vtkSimpleScalarTree | ,
 |  | vtkScalarTree |
 | ) |

Standard type related macros and PrintSelf() method.

Reimplemented from vtkScalarTree.

void vtkSimpleScalarTree::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Standard type related macros and PrintSelf() method.

Reimplemented from vtkScalarTree.

virtual void vtkSimpleScalarTree::SetBranchingFactor ( int ) [virtual]

Set the branching factor for the tree. This is the number of children per tree node. Smaller values (minimum is 2) mean deeper trees and more memory overhead. Larger values mean shallower trees, less memory usage, but worse performance.

virtual int vtkSimpleScalarTree::GetBranchingFactor ( ) [virtual]

Set the branching factor for the tree. This is the number of children per tree node. Smaller values (minimum is 2) mean deeper trees and more memory overhead. Larger values mean shallower trees, less memory usage, but worse performance.

virtual int vtkSimpleScalarTree::GetLevel ( ) [virtual]

Get the level of the scalar tree. This value may change each time the scalar tree is built and the branching factor changes.

virtual void vtkSimpleScalarTree::SetMaxLevel ( int ) [virtual]

Set the maximum allowable level for the tree.

virtual int vtkSimpleScalarTree::GetMaxLevel ( ) [virtual]

Set the maximum allowable level for the tree.

virtual void vtkSimpleScalarTree::BuildTree ( ) [virtual]

Construct the scalar tree from the dataset provided. Checks build times and modified time from input and reconstructs the tree if necessary.

Reimplemented from vtkScalarTree.

virtual void vtkSimpleScalarTree::Initialize ( ) [virtual]

Initialize locator. Frees memory and resets object as appropriate.

Reimplemented from vtkScalarTree.

virtual void vtkSimpleScalarTree::InitTraversal ( float scalarValue ) [virtual]

Begin to traverse the cells based on a scalar value. Returned cells will have scalar values that span the scalar value specified.

Reimplemented from vtkScalarTree.

virtual vtkCell* vtkSimpleScalarTree::GetNextCell | ( | vtkIdType & | cellId,
 |  | vtkIdList *& | ptIds,
 |  | vtkDataArray * | cellScalars
 | ) | [virtual]

Return the next cell that may contain scalar value specified to initialize traversal. The value NULL is returned if the list is exhausted. Make sure that InitTraversal() has been invoked first or you'll get erratic behavior.

Reimplemented from vtkScalarTree.

Member Data Documentation

vtkDataArray* vtkSimpleScalarTree::Scalars [protected]

Reimplemented from vtkScalarTree.

Definition at line 113 of file vtkSimpleScalarTree.h.

int vtkSimpleScalarTree::MaxLevel [protected]

Definition at line 114 of file vtkSimpleScalarTree.h.

int vtkSimpleScalarTree::Level [protected]

Definition at line 115 of file vtkSimpleScalarTree.h.

int vtkSimpleScalarTree::BranchingFactor [protected]

Definition at line 116 of file vtkSimpleScalarTree.h.

vtkScalarNode* vtkSimpleScalarTree::Tree [protected]

Definition at line 117 of file vtkSimpleScalarTree.h.

int vtkSimpleScalarTree::TreeSize [protected]

Definition at line 118 of file vtkSimpleScalarTree.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkSimpleScalarTree.h
Generated on Mon Mar 25 01:31:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSLCReader Class Reference

read an SLC volume file. More...

#include <vtkSLCReader.h>

Inheritance diagram for vtkSLCReader:

[legend]
Collaboration diagram for vtkSLCReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSLCReader, vtkImageReader2)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual int | GetError ()
virtual vtkImageReader2 * | MakeObject ()
int | CanReadFile (const char *fname)
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkSLCReader * | New ()

Protected Methods

vtkSLCReader ()
~vtkSLCReader ()
virtual void | ExecuteData (vtkDataObject *)
void | ExecuteInformation ()
unsigned char * | Decode8BitData (unsigned char *in_ptr, int size)

Protected Attributes

int | Error

Detailed Description

read an SLC volume file.

Date:
2002/01/31 23:53:14
Revision:
1.37

vtkSLCReader reads an SLC file and creates a structured point dataset. The size of the volume and the data spacing is set from the SLC file header.

Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (35%)
  • Martin, Ken (19%)
  • Schroeder, Will (15%)
  • Hoffman, Bill (14%)
  • Lorensen, Bill (9%)
Examples:
vtkSLCReader (Examples)
Tests:
vtkSLCReader (Tests)

Definition at line 50 of file vtkSLCReader.h.

Constructor & Destructor Documentation

vtkSLCReader::vtkSLCReader ( ) [protected]

vtkSLCReader::~vtkSLCReader ( ) [protected]

Member Function Documentation

vtkSLCReader* vtkSLCReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Referenced by MakeObject().

vtkSLCReader::vtkTypeRevisionMacro | ( | vtkSLCReader | ,
 |  | vtkImageReader2 |
 | ) |

Reimplemented from vtkImageReader2.

void vtkSLCReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageReader2.

virtual void vtkSLCReader::SetFileName ( const char * ) [virtual]

Set/Get the name of the file to read.

Reimplemented from vtkImageReader2.

virtual char* vtkSLCReader::GetFileName ( ) [virtual]

Set/Get the name of the file to read.

Reimplemented from vtkImageReader2.

virtual int vtkSLCReader::GetError ( void ) [virtual]

Was there an error on the last read performed?

virtual vtkImageReader2* vtkSLCReader::MakeObject ( ) [inline, virtual]

Was there an error on the last read performed?

Reimplemented from vtkImageReader2.

Definition at line 67 of file vtkSLCReader.h.

int vtkSLCReader::CanReadFile ( const char * fname )

Is the given file an SLC file?

virtual const char* vtkSLCReader::GetFileExensions ( ) [inline, virtual]

Is the given file an SLC file?

Reimplemented from vtkImageReader2.

Definition at line 75 of file vtkSLCReader.h.

virtual const char* vtkSLCReader::GetDescriptiveName ( ) [inline, virtual]

SLC

Reimplemented from vtkImageReader2.

Definition at line 83 of file vtkSLCReader.h.

virtual void vtkSLCReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

void vtkSLCReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

unsigned char* vtkSLCReader::Decode8BitData | ( | unsigned char * | in_ptr,
 |  | int | size
 | ) | [protected]

Member Data Documentation

int vtkSLCReader::Error [protected]

Definition at line 104 of file vtkSLCReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkSLCReader.h
Generated on Mon Mar 25 01:31:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSliceCubes Class Reference

generate isosurface(s) from volume four slices at a time. More...

#include <vtkSliceCubes.h>

Inheritance diagram for vtkSliceCubes:

[legend]
Collaboration diagram for vtkSliceCubes:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSliceCubes, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Write ()
void | Update ()
virtual void | SetReader (vtkVolumeReader *)
virtual vtkVolumeReader * | GetReader ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetValue (float)
virtual float | GetValue ()
virtual void | SetLimitsFileName (const char *)
virtual char * | GetLimitsFileName ()

Static Public Methods

vtkSliceCubes * | New ()

Protected Methods

vtkSliceCubes ()
~vtkSliceCubes ()
void | Execute ()

Protected Attributes

vtkVolumeReader * Reader
char * | FileName
float | Value
char * | LimitsFileName

Detailed Description

generate isosurface(s) from volume four slices at a time.

Date:
2002/01/22 22:02:30
Revision:
1.36

vtkSliceCubes is a special version of the marching cubes filter. Instead of ingesting an entire volume at once it processes only four slices at a time. This way, it can generate isosurfaces from huge volumes. Also, the output of this object is written to a marching cubes triangle file. That way, output triangles do not need to be held in memory.

To use vtkSliceCubes you must specify an instance of vtkVolumeReader to read the data. Set this object up with the proper file prefix, image range, data origin, data dimensions, header size, data mask, and swap bytes flag. The vtkSliceCubes object will then take over and read slices as necessary. You also will need to specify the name of an output marching cubes triangle file.

Warning:
This process object is both a source and mapper (i.e., it reads and writes data to a file). This is different than the other marching cubes objects (and most process objects in the system). It's specialized to handle very large data.
Warning:
This object only extracts a single isosurface. This compares with the other contouring objects in vtk that generate multiple surfaces.
Warning:
To read the output file use vtkMCubesReader.
See also:
vtkMarchingCubes vtkContourFilter vtkMCubesReader vtkDividingCubes vtkVolumeReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (68%)
  • Lorensen, Bill (13%)
  • Martin, Ken (11%)
Tests:
vtkSliceCubes (Tests)

Definition at line 85 of file vtkSliceCubes.h.

Constructor & Destructor Documentation

vtkSliceCubes::vtkSliceCubes ( ) [protected]

vtkSliceCubes::~vtkSliceCubes ( ) [protected]

Member Function Documentation

vtkSliceCubes* vtkSliceCubes::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkSliceCubes::vtkTypeRevisionMacro | ( | vtkSliceCubes | ,
 |  | vtkObject |
 | ) |

void vtkSliceCubes::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkSliceCubes::Write ( ) [inline]

Definition at line 93 of file vtkSliceCubes.h.

void vtkSliceCubes::Update ( )

virtual void vtkSliceCubes::SetReader ( vtkVolumeReader * ) [virtual]

Set/get object to read slices.

virtual vtkVolumeReader* vtkSliceCubes::GetReader ( ) [virtual]

Set/get object to read slices.

virtual void vtkSliceCubes::SetFileName ( const char * ) [virtual]

Specify file name of marching cubes output file.

virtual char* vtkSliceCubes::GetFileName ( ) [virtual]

Specify file name of marching cubes output file.

virtual void vtkSliceCubes::SetValue ( float ) [virtual]

Set/get isosurface contour value.

virtual float vtkSliceCubes::GetValue ( ) [virtual]

Set/get isosurface contour value.

virtual void vtkSliceCubes::SetLimitsFileName ( const char * ) [virtual]

Specify file name of marching cubes limits file. The limits file speeds up subsequent reading of output triangle file.

virtual char* vtkSliceCubes::GetLimitsFileName ( ) [virtual]

Specify file name of marching cubes limits file. The limits file speeds up subsequent reading of output triangle file.

void vtkSliceCubes::Execute ( ) [protected]

Member Data Documentation

vtkVolumeReader* vtkSliceCubes::Reader [protected]

Definition at line 127 of file vtkSliceCubes.h.

char* vtkSliceCubes::FileName [protected]

Definition at line 128 of file vtkSliceCubes.h.

float vtkSliceCubes::Value [protected]

Definition at line 129 of file vtkSliceCubes.h.

char* vtkSliceCubes::LimitsFileName [protected]

Definition at line 130 of file vtkSliceCubes.h.

The documentation for this class was generated from the following file:
  • Patented/vtkSliceCubes.h
Generated on Mon Mar 25 01:31:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSmoothPolyDataFilter Class Reference

#include <vtkSmoothPolyDataFilter.h>

Inheritance diagram for vtkSmoothPolyDataFilter:

[legend]
Collaboration diagram for vtkSmoothPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSmoothPolyDataFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetConvergence (float)
virtual float | GetConvergence ()
virtual void | SetNumberOfIterations (int)
virtual int | GetNumberOfIterations ()
virtual void | SetRelaxationFactor (float)
virtual float | GetRelaxationFactor ()
virtual void | SetFeatureEdgeSmoothing (int)
virtual int | GetFeatureEdgeSmoothing ()
virtual void | FeatureEdgeSmoothingOn ()
virtual void | FeatureEdgeSmoothingOff ()
virtual void | SetFeatureAngle (float)
virtual float | GetFeatureAngle ()
virtual void | SetEdgeAngle (float)
virtual float | GetEdgeAngle ()
virtual void | SetBoundarySmoothing (int)
virtual int | GetBoundarySmoothing ()
virtual void | BoundarySmoothingOn ()
virtual void | BoundarySmoothingOff ()
virtual void | SetGenerateErrorScalars (int)
virtual int | GetGenerateErrorScalars ()
virtual void | GenerateErrorScalarsOn ()
virtual void | GenerateErrorScalarsOff ()
virtual void | SetGenerateErrorVectors (int)
virtual int | GetGenerateErrorVectors ()
virtual void | GenerateErrorVectorsOn ()
virtual void | GenerateErrorVectorsOff ()
void | SetSource (vtkPolyData *source)
vtkPolyData * GetSource ()

Static Public Methods

vtkSmoothPolyDataFilter * | New ()

Protected Methods

vtkSmoothPolyDataFilter ()
~vtkSmoothPolyDataFilter ()
void | Execute ()

Protected Attributes

float | Convergence
int | NumberOfIterations
float | RelaxationFactor
int | FeatureEdgeSmoothing
float | FeatureAngle
float | EdgeAngle
int | BoundarySmoothing
int | GenerateErrorScalars
int | GenerateErrorVectors
vtkSmoothPoints * | SmoothPoints

Detailed Description

Date:
2002/01/22 15:29:45
Revision:
1.23

vtkSmoothPolyDataFilter.h is a filter that adjusts point coordinates using Laplacian smoothing. The effect is to "relax" the mesh, making the cells better shaped and the vertices more evenly distributed. Note that this filter operates on the lines, polygons, and triangle strips composing an instance of vtkPolyData. Vertex or poly-vertex cells are never modified.

The algorithm proceeds as follows. For each vertex v, a topological and geometric analysis is performed to determine which vertices are connected to v, and which cells are connected to v. Then, a connectivity array is constructed for each vertex. (The connectivity array is a list of lists of vertices that directly attach to each vertex.) Next, an iteration phase begins over all vertices. For each vertex v, the coordinates of v are modified according to an average of the connected vertices. (A relaxation factor is available to control the amount of displacement of v). The process repeats for each vertex. This pass over the list of vertices is a single iteration. Many iterations (generally around 20 or so) are repeated until the desired result is obtained.

There are some special instance variables used to control the execution of this filter. (These ivars basically control what vertices can be smoothed, and the creation of the connectivity array.) The BoundarySmoothing ivar enables/disables the smoothing operation on vertices that are on the "boundary" of the mesh. A boundary vertex is one that is surrounded by a semi-cycle of polygons (or used by a single line).

Another important ivar is FeatureEdgeSmoothing. If this ivar is enabled, then interior vertices are classified as either "simple", "interior edge", or "fixed", and smoothed differently. (Interior vertices are manifold vertices surrounded by a cycle of polygons; or used by two line cells.) The classification is based on the number of feature edges attached to v. A feature edge occurs when the angle between the two surface normals of a polygon sharing an edge is greater than the FeatureAngle ivar. Then, vertices used by no feature edges are classified "simple", vertices used by exactly two feature edges are classified "interior edge", and all others are "fixed" vertices.

Once the classification is known, the vertices are smoothed differently. Corner (i.e., fixed) vertices are not smoothed at all. Simple vertices are smoothed as before (i.e., average of connected vertex coordinates). Interior edge vertices are smoothed only along their two connected edges, and only if the angle between the edges is less than the EdgeAngle ivar.

The total smoothing can be controlled by using two ivars. The NumberOfIterations is a cap on the maximum number of smoothing passes. The Convergence ivar is a limit on the maximum point motion. If the maximum motion during an iteration is less than Convergence, then the smoothing process terminates. (Convergence is expressed as a fraction of the diagonal of the bounding box.)

There are two instance variables that control the generation of error data. If the ivar GenerateErrorScalars is on, then a scalar value indicating the distance of each vertex from its original position is computed. If the ivar GenerateErrorVectors is on, then a vector representing change in position is computed.

Optionally you can further control the smoothing process by defining a second input: the Source. If defined, the input mesh is constrained to lie on the surface defined by the Source ivar.

Warning:
The Laplacian operation reduces high frequency information in the geometry of the mesh. With excessive smoothing important details may be lost, and the surface may shrink towards the centroid. Enabling FeatureEdgeSmoothing helps reduce this effect, but cannot entirely eliminate it. You may also wish to try vtkWindowedSincPolyDataFilter. It does a better job of minimizing shrinkage.
See also:
vtkWindowedSincPolyDataFilter vtkDecimate vtkDecimatePro
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (65%)
  • Schroeder, Will (25%)
Examples:
vtkSmoothPolyDataFilter (Examples)
Tests:
vtkSmoothPolyDataFilter (Tests)

Definition at line 115 of file vtkSmoothPolyDataFilter.h.

Constructor & Destructor Documentation

vtkSmoothPolyDataFilter::vtkSmoothPolyDataFilter ( ) [protected]

vtkSmoothPolyDataFilter::~vtkSmoothPolyDataFilter ( ) [inline, protected]

Definition at line 202 of file vtkSmoothPolyDataFilter.h.

Member Function Documentation

vtkSmoothPolyDataFilter::vtkTypeRevisionMacro | ( | vtkSmoothPolyDataFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkSmoothPolyDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSmoothPolyDataFilter* vtkSmoothPolyDataFilter::New ( ) [static]

Construct object with number of iterations 20; relaxation factor .01; feature edge smoothing turned off; feature angle 45 degrees; edge angle 15 degrees; and boundary smoothing turned on. Error scalars and vectors are not generated (by default). The convergence criterion is 0.0 of the bounding box diagonal.

Reimplemented from vtkPolyDataSource.

virtual void vtkSmoothPolyDataFilter::SetConvergence ( float ) [virtual]

Specify a convergence criterion for the iteration process. Smaller numbers result in more smoothing iterations.

virtual float vtkSmoothPolyDataFilter::GetConvergence ( ) [virtual]

Specify a convergence criterion for the iteration process. Smaller numbers result in more smoothing iterations.

virtual void vtkSmoothPolyDataFilter::SetNumberOfIterations ( int ) [virtual]

Specify the number of iterations for Laplacian smoothing,

virtual int vtkSmoothPolyDataFilter::GetNumberOfIterations ( ) [virtual]

Specify the number of iterations for Laplacian smoothing,

virtual void vtkSmoothPolyDataFilter::SetRelaxationFactor ( float ) [virtual]

Specify the relaxation factor for Laplacian smoothing. As in all iterative methods, the stability of the process is sensitive to this parameter. In general, small relaxation factors and large numbers of iterations are more stable than larger relaxation factors and smaller numbers of iterations.

virtual float vtkSmoothPolyDataFilter::GetRelaxationFactor ( ) [virtual]

Specify the relaxation factor for Laplacian smoothing. As in all iterative methods, the stability of the process is sensitive to this parameter. In general, small relaxation factors and large numbers of iterations are more stable than larger relaxation factors and smaller numbers of iterations.

virtual void vtkSmoothPolyDataFilter::SetFeatureEdgeSmoothing ( int ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual int vtkSmoothPolyDataFilter::GetFeatureEdgeSmoothing ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkSmoothPolyDataFilter::FeatureEdgeSmoothingOn ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkSmoothPolyDataFilter::FeatureEdgeSmoothingOff ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkSmoothPolyDataFilter::SetFeatureAngle ( float ) [virtual]

Specify the feature angle for sharp edge identification.

virtual float vtkSmoothPolyDataFilter::GetFeatureAngle ( ) [virtual]

Specify the feature angle for sharp edge identification.

virtual void vtkSmoothPolyDataFilter::SetEdgeAngle ( float ) [virtual]

Specify the edge angle to control smoothing along edges (either interior or boundary).

virtual float vtkSmoothPolyDataFilter::GetEdgeAngle ( ) [virtual]

Specify the edge angle to control smoothing along edges (either interior or boundary).

virtual void vtkSmoothPolyDataFilter::SetBoundarySmoothing ( int ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual int vtkSmoothPolyDataFilter::GetBoundarySmoothing ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkSmoothPolyDataFilter::BoundarySmoothingOn ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkSmoothPolyDataFilter::BoundarySmoothingOff ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkSmoothPolyDataFilter::SetGenerateErrorScalars ( int ) [virtual]

Turn on/off the generation of scalar distance values.

virtual int vtkSmoothPolyDataFilter::GetGenerateErrorScalars ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkSmoothPolyDataFilter::GenerateErrorScalarsOn ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkSmoothPolyDataFilter::GenerateErrorScalarsOff ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkSmoothPolyDataFilter::SetGenerateErrorVectors ( int ) [virtual]

Turn on/off the generation of error vectors.

virtual int vtkSmoothPolyDataFilter::GetGenerateErrorVectors ( ) [virtual]

Turn on/off the generation of error vectors.

virtual void vtkSmoothPolyDataFilter::GenerateErrorVectorsOn ( ) [virtual]

Turn on/off the generation of error vectors.

virtual void vtkSmoothPolyDataFilter::GenerateErrorVectorsOff ( ) [virtual]

Turn on/off the generation of error vectors.

void vtkSmoothPolyDataFilter::SetSource ( vtkPolyData * source )

Specify the source object which is used to constrain smoothing. The source defines a surface that the input (as it is smoothed) is constrained to lie upon.

vtkPolyData* vtkSmoothPolyDataFilter::GetSource ( )

Specify the source object which is used to constrain smoothing. The source defines a surface that the input (as it is smoothed) is constrained to lie upon.

void vtkSmoothPolyDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkSmoothPolyDataFilter::Convergence [protected]

Definition at line 206 of file vtkSmoothPolyDataFilter.h.

int vtkSmoothPolyDataFilter::NumberOfIterations [protected]

Definition at line 207 of file vtkSmoothPolyDataFilter.h.

float vtkSmoothPolyDataFilter::RelaxationFactor [protected]

Definition at line 208 of file vtkSmoothPolyDataFilter.h.

int vtkSmoothPolyDataFilter::FeatureEdgeSmoothing [protected]

Definition at line 209 of file vtkSmoothPolyDataFilter.h.

float vtkSmoothPolyDataFilter::FeatureAngle [protected]

Definition at line 210 of file vtkSmoothPolyDataFilter.h.

float vtkSmoothPolyDataFilter::EdgeAngle [protected]

Definition at line 211 of file vtkSmoothPolyDataFilter.h.

int vtkSmoothPolyDataFilter::BoundarySmoothing [protected]

Definition at line 212 of file vtkSmoothPolyDataFilter.h.

int vtkSmoothPolyDataFilter::GenerateErrorScalars [protected]

Definition at line 213 of file vtkSmoothPolyDataFilter.h.

int vtkSmoothPolyDataFilter::GenerateErrorVectors [protected]

Definition at line 214 of file vtkSmoothPolyDataFilter.h.

vtkSmoothPoints* vtkSmoothPolyDataFilter::SmoothPoints [protected]

Definition at line 216 of file vtkSmoothPolyDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSmoothPolyDataFilter.h
Generated on Mon Mar 25 01:31:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSocketCommunicator Class Reference

Process communication using Sockets. More...

#include <vtkSocketCommunicator.h>

Inheritance diagram for vtkSocketCommunicator:

[legend]
Collaboration diagram for vtkSocketCommunicator:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSocketCommunicator, vtkCommunicator)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | WaitForConnection (int port)
virtual void | CloseConnection ()
virtual int | ConnectTo (char *hostName, int port)
int | Send (int *data, int length, int remoteProcessId, int tag)
int | Send (unsigned long *data, int length, int remoteProcessId, int tag)
int | Send (char *data, int length, int remoteProcessId, int tag)
int | Send (unsigned char *data, int length, int remoteProcessId, int tag)
int | Send (float *data, int length, int remoteProcessId, int tag)
int | Send (double *data, int length, int remoteProcessId, int tag)
int | Send (vtkDataObject *data, int remoteId, int tag)
int | Send (vtkDataArray *data, int remoteId, int tag)
int | Receive (int *data, int length, int remoteProcessId, int tag)
int | Receive (unsigned long *data, int length, int remoteProcessId, int tag)
int | Receive (char *data, int length, int remoteProcessId, int tag)
int | Receive (unsigned char *data, int length, int remoteProcessId, int tag)
int | Receive (float *data, int length, int remoteProcessId, int tag)
int | Receive (double *data, int length, int remoteProcessId, int tag)
int | Receive (vtkDataObject *data, int remoteId, int tag)
int | Receive (vtkDataArray *data, int remoteId, int tag)
virtual int | GetSwapBytesInReceivedData ()
virtual int | GetIsConnected ()

Static Public Methods

vtkSocketCommunicator * | New ()

Protected Methods

vtkSocketCommunicator ()
~vtkSocketCommunicator ()
int | ReceiveMessage (char *data, int size, int length, int tag)

Protected Attributes

int | Socket
int | IsConnected
int | NumberOfProcesses
int | SwapBytesInReceivedData

Detailed Description

Process communication using Sockets.

Date:
2002/01/22 15:34:57
Revision:
1.22

This is a concrete implementation of vtkCommunicator which supports interprocess communication using BSD style sockets. It supports byte swapping for the communication of machines with different endianness.

Warning:
Communication between 32 bit and 64 bit systems is not fully supported. If a type does not have the same length on both systems, this communicator can not be used to transfer data of that type.
See also:
vtkCommunicator vtkSharedMemoryCommunicator vtkSocketController
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (76%)
  • Law, Charles (10%)
  • Lee, Jeff (8%)
Tests:
vtkSocketCommunicator (Tests)

Definition at line 76 of file vtkSocketCommunicator.h.

Constructor & Destructor Documentation

vtkSocketCommunicator::vtkSocketCommunicator ( ) [protected]

vtkSocketCommunicator::~vtkSocketCommunicator ( ) [protected]

Member Function Documentation

vtkSocketCommunicator* vtkSocketCommunicator::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkSocketCommunicator::vtkTypeRevisionMacro | ( | vtkSocketCommunicator | ,
 |  | vtkCommunicator |
 | ) |

Reimplemented from vtkCommunicator.

void vtkSocketCommunicator::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCommunicator.

virtual int vtkSocketCommunicator::WaitForConnection ( int port ) [virtual]

Wait for connection on a given port.

virtual void vtkSocketCommunicator::CloseConnection ( ) [virtual]

Close a connection.

virtual int vtkSocketCommunicator::ConnectTo | ( | char * | hostName,
 |  | int | port
 | ) | [virtual]

Open a connection to host.

virtual int vtkSocketCommunicator::GetSwapBytesInReceivedData ( ) [virtual]

Returns 1 if bytes must be swapped in received ints, floats, etc

virtual int vtkSocketCommunicator::GetIsConnected ( ) [virtual]

Is the communicator connected?.

int vtkSocketCommunicator::Send | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method sends data to another process. Tag eliminates ambiguity when multiple sends or receives exist in the same process.

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Send | ( | vtkDataObject * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [inline, virtual]

This method sends a data object to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented from vtkCommunicator.

Definition at line 117 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::Send | ( | vtkDataArray * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [inline, virtual]

This method sends a data array to a destination. Tag eliminates ambiguity and is used to match sends to receives.

Reimplemented from vtkCommunicator.

Definition at line 119 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::Receive | ( | int * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

This method receives data from a corresponding send. It blocks until the receive is finished. It calls methods in "data" to communicate the sending data.

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | unsigned long * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | unsigned char * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | float * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | double * | data,
 |  | int | length,
 |  | int | remoteProcessId,
 |  | int | tag
 | ) | [virtual]

Reimplemented from vtkCommunicator.

int vtkSocketCommunicator::Receive | ( | vtkDataObject * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [inline, virtual]

This method receives a data object from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

Definition at line 136 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::Receive | ( | vtkDataArray * | data,
 |  | int | remoteId,
 |  | int | tag
 | ) | [inline, virtual]

This method receives a data array from a corresponding send. It blocks until the receive is finished.

Reimplemented from vtkCommunicator.

Definition at line 138 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::ReceiveMessage | ( | char * | data,
 |  | int | size,
 |  | int | length,
 |  | int | tag
 | ) | [protected]

Member Data Documentation

int vtkSocketCommunicator::Socket [protected]

Definition at line 143 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::IsConnected [protected]

Definition at line 144 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::NumberOfProcesses [protected]

Definition at line 145 of file vtkSocketCommunicator.h.

int vtkSocketCommunicator::SwapBytesInReceivedData [protected]

Definition at line 146 of file vtkSocketCommunicator.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkSocketCommunicator.h
Generated on Mon Mar 25 01:31:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSocketController Class Reference

Process communication using Sockets. More...

#include <vtkSocketController.h>

Inheritance diagram for vtkSocketController:

[legend]
Collaboration diagram for vtkSocketController:

[legend]
List of all members.

Public Types

enum | Consts { ENDIAN_TAG = 1010580540 }

Public Methods

vtkTypeRevisionMacro (vtkSocketController, vtkMultiProcessController)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Finalize ()
void | SingleMethodExecute ()
void | MultipleMethodExecute ()
void | CreateOutputWindow ()
void | Barrier ()
virtual void | SetNumberOfProcesses (int num)
int | GetSwapBytesInReceivedData ()
void | SetCommunicator (vtkSocketCommunicator *comm)
virtual void | Initialize (int *, char ***)
virtual void | Initialize ()
virtual int | WaitForConnection (int port)
virtual void | CloseConnection ()
virtual int | ConnectTo (char *hostName, int port)

Static Public Methods

vtkSocketController * | New ()

Protected Methods

vtkSocketController ()
~vtkSocketController ()

Static Protected Attributes

int | Initialized

Detailed Description

Process communication using Sockets.

Date:
2002/01/22 15:34:58
Revision:
1.15

This is a concrete implementation of vtkMultiProcessController. It supports one-to-one communication using sockets. Note that process 0 will always correspond to self and process 1 to the remote process. This class is best used with ports.

See also:
vtkMultiProcessController vtkSocketCommunicator vtkInputPort vtkOutputPort
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (65%)
  • Geveci, Berk (26%)
Tests:
vtkSocketController (Tests)

Definition at line 57 of file vtkSocketController.h.

Member Enumeration Documentation

enum vtkSocketController::Consts

Enumeration values:
ENDIAN_TAG

Reimplemented from vtkMultiProcessController.

Definition at line 128 of file vtkSocketController.h.

Constructor & Destructor Documentation

vtkSocketController::vtkSocketController ( ) [protected]

vtkSocketController::~vtkSocketController ( ) [protected]

Member Function Documentation

vtkSocketController* vtkSocketController::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkMultiProcessController.

vtkSocketController::vtkTypeRevisionMacro | ( | vtkSocketController | ,
 |  | vtkMultiProcessController |
 | ) |

Reimplemented from vtkMultiProcessController.

void vtkSocketController::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMultiProcessController.

virtual void vtkSocketController::Initialize | ( | int * | ,
 |  | char *** |
 | ) | [virtual]

This method is for initialiazing sockets. One of these is REQUIRED for Windows.

virtual void vtkSocketController::Initialize ( ) [inline, virtual]

This method is for initialiazing sockets. One of these is REQUIRED for Windows.

Definition at line 68 of file vtkSocketController.h.

void vtkSocketController::Finalize ( ) [inline, virtual]

Does not apply to sockets. Does nothing.

Reimplemented from vtkMultiProcessController.

Definition at line 73 of file vtkSocketController.h.

void vtkSocketController::SingleMethodExecute ( ) [inline, virtual]

Does not apply to sockets. Does nothing.

Reimplemented from vtkMultiProcessController.

Definition at line 76 of file vtkSocketController.h.

void vtkSocketController::MultipleMethodExecute ( ) [inline, virtual]

Does not apply to sockets. Does nothing.

Reimplemented from vtkMultiProcessController.

Definition at line 79 of file vtkSocketController.h.

void vtkSocketController::CreateOutputWindow ( ) [inline, virtual]

Does not apply to sockets. Does nothing.

Reimplemented from vtkMultiProcessController.

Definition at line 82 of file vtkSocketController.h.

void vtkSocketController::Barrier ( ) [inline, virtual]

Does not apply to sockets. Does nothing.

Reimplemented from vtkMultiProcessController.

Definition at line 85 of file vtkSocketController.h.

virtual void vtkSocketController::SetNumberOfProcesses ( int num ) [virtual]

Set the number of processes you will be using.

Reimplemented from vtkMultiProcessController.

virtual int vtkSocketController::WaitForConnection ( int port ) [inline, virtual]

Wait for connection on a given port, forwarded to the communicator

Definition at line 92 of file vtkSocketController.h.

virtual void vtkSocketController::CloseConnection ( ) [inline, virtual]

Close a connection, forwarded to the communicator

Definition at line 101 of file vtkSocketController.h.

virtual int vtkSocketController::ConnectTo | ( | char * | hostName,
 |  | int | port
 | ) | [inline, virtual]

Open a connection to a give machine, forwarded to the communicator

Definition at line 110 of file vtkSocketController.h.

int vtkSocketController::GetSwapBytesInReceivedData ( ) [inline]

Definition at line 117 of file vtkSocketController.h.

void vtkSocketController::SetCommunicator ( vtkSocketCommunicator * comm )

Set the communicator used in normal and rmi communications.

Member Data Documentation

int vtkSocketController::Initialized [static, protected]

Definition at line 140 of file vtkSocketController.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkSocketController.h
Generated on Mon Mar 25 01:31:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSource Class Reference

abstract class specifies interface for visualization network source. More...

#include <vtkSource.h>

Inheritance diagram for vtkSource:

[legend]
Collaboration diagram for vtkSource:

[legend]
List of all members.

[NOHEADER]

virtual void | EnlargeOutputUpdateExtents (vtkDataObject *output)
int | LegacyHack

Public Methods

vtkTypeRevisionMacro (vtkSource, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Update ()
virtual void | UpdateWholeExtent ()
virtual void | UpdateInformation ()
virtual void | PropagateUpdateExtent (vtkDataObject *output)
virtual void | TriggerAsynchronousUpdate ()
virtual void | UpdateData (vtkDataObject *output)
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
void | UnRegister (vtkObject *o)
virtual int | InRegisterLoop (vtkObject *)
void | UnRegisterAllOutputs (void)
int | GetOutputIndex (vtkDataObject *out)
virtual void | SetReleaseDataFlag (int)
virtual int | GetReleaseDataFlag ()
virtual void | ReleaseDataFlagOn ()
virtual void | ReleaseDataFlagOff ()
vtkDataObject ** GetOutputs ()
virtual int | GetNumberOfOutputs ()
virtual unsigned long | GetErrorCode ()

Protected Methods

vtkSource ()
~vtkSource ()
virtual void | Execute ()
virtual void | ExecuteInformation ()
void | SetNumberOfOutputs (int num)
vtkDataObject * | GetOutput (int idx)
virtual void | SetNthOutput (int num, vtkDataObject *output)
virtual void | AddOutput (vtkDataObject *output)
virtual void | RemoveOutput (vtkDataObject *output)
virtual void | ExecuteData (vtkDataObject *vtkNotUsed(output))
virtual void | SetErrorCode (unsigned long)

Protected Attributes

vtkDataObject ** Outputs
int | NumberOfOutputs
int | Updating
vtkTimeStamp InformationTime

Detailed Description

abstract class specifies interface for visualization network source.

Date:
2002/01/22 15:26:20
Revision:
1.67

vtkSource is an abstract object that specifies behavior and interface of source objects. Source objects are objects that begin visualization pipeline. Sources include readers (read data from file or communications port) and procedural sources (generate data programmatically). vtkSource objects are also objects that generate output data. In this sense vtkSource is used as a superclass to vtkFilter.

Concrete subclasses of vtkSource must define Update() and Execute() methods. The public method Update() invokes network execution and will bring the network up-to-date. The protected Execute() method actually does the work of data creation/generation. The difference between the two methods is that Update() implements input consistency checks and modified time comparisons and then invokes the Execute() which is an implementation of a particular algorithm.

An important feature of subclasses of vtkSource is that it is possible to control the memory-management model (i.e., retain output versus delete output data). If enabled the ReleaseDataFlag enables the deletion of the output data once the downstream process object finishes processing the data (please see text).

See also:
vtkProcessObject vtkDataSetReader vtkFilter vtkPolyDataSource vtkStructuredGridSource vtkStructuredPointsSource vtkUnstructuredGridSource
Events:
vtkCommand::SetOutputEvent vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Martin, Ken
  • Schroeder, Will
Contributed by (if > 5%):
  • Law, Charles (28%)
  • Martin, Ken (26%)
  • Schroeder, Will (26%)
  • Lorensen, Bill (7%)

Definition at line 69 of file vtkSource.h.

Constructor & Destructor Documentation

vtkSource::vtkSource ( ) [protected]

vtkSource::~vtkSource ( ) [protected]

Member Function Documentation

vtkSource::vtkTypeRevisionMacro | ( | vtkSource | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

Reimplemented in vtkCastToConcrete, vtkDataObjectSource, vtkDataSetSource, vtkDataSetToDataSetFilter, vtkDataSetToPolyDataFilter, vtkDataSetToStructuredGridFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToUnstructuredGridFilter, vtkImageInPlaceFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageSource, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkImageTwoInputFilter, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionSource, vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkPointSetSource, vtkPointSetToPointSetFilter, vtkPolyDataSource, vtkPolyDataToPolyDataFilter, vtkRectilinearGridSource, vtkRectilinearGridToPolyDataFilter, vtkSimpleImageToImageFilter, vtkStructuredGridSource, vtkStructuredGridToPolyDataFilter, vtkStructuredGridToStructuredGridFilter, vtkStructuredPointsSource, vtkStructuredPointsToPolyDataFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridSource, vtkUnstructuredGridToPolyDataFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButterflySubdivisionFilter, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDicer, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLinearSubdivisionFilter, vtkLineSource, vtkLinkEdgels, vtkLoopSubdivisionFilter, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableFilter, vtkProgrammableGlyphFilter, vtkProgrammableSource, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredPointsGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageCityBlockDistance, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageFourierCenter, vtkImageFourierFilter, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageHybridMedian2D, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToRGBA, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageMirrorPad, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImageWrapPad, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSimpleImageFilterExample, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBYUReader, vtkDataObjectReader, vtkDataReader, vtkDataSetReader, vtkDEMReader, vtkEnSight6BinaryReader, vtkEnSight6Reader, vtkEnSightGoldBinaryReader, vtkEnSightGoldReader, vtkEnSightReader, vtkGenericEnSightReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkJPEGReader, vtkMCubesReader, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPNGReader, vtkPNMReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkSLCReader, vtkSTLReader, vtkStructuredGridReader, vtkStructuredPointsReader, vtkUGFacetReader, vtkUnstructuredGridReader, vtkVolume16Reader, vtkVolumeReader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkPCellDataToPointData, vtkPDataSetReader, vtkPieceScalars, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkRendererSource, vtkSelectVisiblePoints, and vtkWindowToImageFilter.

void vtkSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

Reimplemented in vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkPiecewiseFunctionShiftScale, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDicer, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLineSource, vtkLinkEdgels, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableGlyphFilter, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkQuantizePolyDataPoints, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamer, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkMILVideoSource, vtkPCAAnalysisFilter, vtkPolyDataToImageStencil, vtkProcrustesAlignmentFilter, vtkRenderLargeImage, vtkTransformToGrid, vtkVectorText, vtkVideoSource, vtkWeightedTransformFilter, vtkWin32VideoSource, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkImageAccumulate, vtkImageAnisotropicDiffusion2D, vtkImageAnisotropicDiffusion3D, vtkImageAppend, vtkImageBlend, vtkImageButterworthHighPass, vtkImageButterworthLowPass, vtkImageCacheFilter, vtkImageCast, vtkImageChangeInformation, vtkImageCheckerboard, vtkImageClip, vtkImageConstantPad, vtkImageContinuousDilate3D, vtkImageContinuousErode3D, vtkImageConvolve, vtkImageCorrelation, vtkImageCursor3D, vtkImageDataStreamer, vtkImageDecomposeFilter, vtkImageDifference, vtkImageDilateErode3D, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageEuclideanToPolar, vtkImageExtractComponents, vtkImageFlip, vtkImageGaussianSmooth, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageHSVToRGB, vtkImageIdealHighPass, vtkImageIdealLowPass, vtkImageImport, vtkImageIslandRemoval2D, vtkImageIterateFilter, vtkImageLaplacian, vtkImageLogarithmicScale, vtkImageLogic, vtkImageMagnify, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMaskBits, vtkImageMathematics, vtkImageMedian3D, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageOpenClose3D, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRGBToHSV, vtkImageSeedConnectivity, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSkeleton2D, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageStencilSource, vtkImageThreshold, vtkImageToImageStencil, vtkImageTranslateExtent, vtkImageVariance3D, vtkImplicitFunctionToImageStencil, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBMPReader, vtkBYUReader, vtkDataObjectReader, vtkDataReader, vtkDataSetReader, vtkDEMReader, vtkEnSightReader, vtkGenericEnSightReader, vtkImageReader, vtkImageReader2, vtkMCubesReader, vtkMedicalImageReader2, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkSLCReader, vtkSTLReader, vtkStructuredGridReader, vtkStructuredPointsReader, vtkUGFacetReader, vtkUnstructuredGridReader, vtkVolume16Reader, vtkVolumeReader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkInputPort, vtkMemoryLimitImageDataStreamer, vtkPCellDataToPointData, vtkPDataSetReader, vtkPieceScalars, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPVGeometryFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkRendererSource, vtkSelectVisiblePoints, and vtkWindowToImageFilter.

virtual void vtkSource::Update ( ) [virtual]

Bring object up-to-date before execution. Update() checks modified time against last execution time, and re-executes object if necessary.

Reimplemented in vtkDataSetReader, vtkEnSightReader, vtkGenericEnSightReader, vtkPDataSetReader, and vtkImageMarchingCubes.

virtual void vtkSource::UpdateWholeExtent ( ) [virtual]

Like update, but make sure the update extent is the whole extent in the output.

virtual void vtkSource::UpdateInformation ( ) [virtual]

Updates any global information about the data (like spacing for images)

Reimplemented in vtkProgrammableSource, vtkImageImport, vtkInputPort, and vtkRendererSource.

virtual void vtkSource::PropagateUpdateExtent ( vtkDataObject * output ) [virtual]

Reimplemented in vtkImageImport.

virtual void vtkSource::TriggerAsynchronousUpdate ( ) [virtual]

Reimplemented in vtkInputPort.

virtual void vtkSource::UpdateData ( vtkDataObject * output ) [virtual]

Reimplemented in vtkProgrammableSource, vtkImplicitModeller, vtkImageCacheFilter, vtkImageCast, vtkImageDataStreamer, vtkInputPort, and vtkMemoryLimitImageDataStreamer.

virtual void vtkSource::ComputeInputUpdateExtents ( vtkDataObject * out ) [virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented in vtkDataSetToDataSetFilter, vtkDataSetToPolyDataFilter, vtkDataSetToStructuredPointsFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkPointSetToPointSetFilter, vtkPolyDataSource, vtkStructuredPointsToPolyDataFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridSource, vtkUnstructuredGridToPolyDataFilter, vtkAppendPolyData, vtkCleanPolyData, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkExtractGrid, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph3D, vtkLoopSubdivisionFilter, vtkMergeFilter, vtkPolyDataStreamer, vtkProbeFilter, vtkStructuredGridGeometryFilter, vtkImageIterateFilter, vtkImageReslice, vtkImageSeedConnectivity, vtkPolyDataReader, vtkUnstructuredGridReader, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkPCellDataToPointData, vtkPLinearExtrusionFilter, vtkPPolyDataNormals, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkGridSynchronizedTemplates3D, vtkKitwareContourFilter, and vtkSynchronizedTemplates3D.

virtual void vtkSource::SetReleaseDataFlag ( int ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a source.

virtual int vtkSource::GetReleaseDataFlag ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a source.

virtual void vtkSource::ReleaseDataFlagOn ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a source.

virtual void vtkSource::ReleaseDataFlagOff ( ) [virtual]

Turn on/off flag to control whether this object's data is released after being used by a source.

void vtkSource::UnRegister ( vtkObject * o ) [virtual]

Handle the source/data loop.

Reimplemented from vtkObject.

Reimplemented in vtkSelectPolyData.

virtual int vtkSource::InRegisterLoop ( vtkObject * ) [virtual]

Test to see if this object is in a reference counting loop.

Reimplemented in vtkSelectPolyData.

vtkDataObject** vtkSource::GetOutputs ( )

Return an array with all the inputs of this process object. This is useful for tracing back in the pipeline to construct graphs etc.

virtual int vtkSource::GetNumberOfOutputs ( ) [virtual]

Return an array with all the inputs of this process object. This is useful for tracing back in the pipeline to construct graphs etc.

void vtkSource::UnRegisterAllOutputs ( void )

Release/disconnect all outputs of this source. This is intended to be called prior to Delete() if the user is concerned about outputs holding on to the filter/source.

int vtkSource::GetOutputIndex ( vtkDataObject * out )

Return what index output the passed in output is, return -1 if it does not match any of the outputs

virtual void vtkSource::EnlargeOutputUpdateExtents ( vtkDataObject * output ) [virtual]

Legacy method. This method was used by inmaging filters to change the UpdateExtent of their input so that the vtkImmageToImageFilter superclass would allocate a larger volume. Changing the UpdateExtent of your input is no longer allowed. The alternative method is to write your own "Execute()" method and allocate your own data.

virtual unsigned long vtkSource::GetErrorCode ( ) [virtual]

The reader should set this code at the end of the update. The error code contains a possible error that occured while reading the file.

virtual void vtkSource::ExecuteData ( vtkDataObject *vtkNotUsed(output) ) [inline, protected, virtual]

This method is the one that should be used by subclasses, right now the default implementation is to call the backwards compatibility method

Definition at line 153 of file vtkSource.h.

virtual void vtkSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented in vtkCastToConcrete, vtkImageSource, vtkImageToStructuredPoints, vtkPiecewiseFunctionShiftScale, vtkAppendFilter, vtkAppendPolyData, vtkApproximatingSubdivisionFilter, vtkArrayCalculator, vtkArrowSource, vtkAssignAttribute, vtkAttributeDataToFieldDataFilter, vtkAxes, vtkBandedPolyDataContourFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkBrownianPoints, vtkButtonSource, vtkCellCenters, vtkCellDataToPointData, vtkCellDerivatives, vtkCleanPolyData, vtkClipDataSet, vtkClipPolyData, vtkClipVolume, vtkConeSource, vtkConnectivityFilter, vtkContourFilter, vtkContourGrid, vtkCubeSource, vtkCursor3D, vtkCutter, vtkCylinderSource, vtkDashedStreamLine, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkDataSetToDataObjectFilter, vtkDataSetTriangleFilter, vtkDecimatePro, vtkDelaunay2D, vtkDelaunay3D, vtkDiskSource, vtkEdgePoints, vtkElevationFilter, vtkExtractEdges, vtkExtractGeometry, vtkExtractGrid, vtkExtractPolyDataGeometry, vtkExtractTensorComponents, vtkExtractUnstructuredGrid, vtkExtractVectorComponents, vtkFeatureEdges, vtkFieldDataToAttributeDataFilter, vtkGeometryFilter, vtkGlyph2D, vtkGlyph3D, vtkGlyphSource2D, vtkGraphLayoutFilter, vtkHedgeHog, vtkHull, vtkHyperStreamline, vtkIdFilter, vtkImageDataGeometryFilter, vtkImplicitTextureCoords, vtkInterpolateDataSetAttributes, vtkInterpolatingSubdivisionFilter, vtkLinearExtrusionFilter, vtkLineSource, vtkLinkEdgels, vtkMaskFields, vtkMaskPoints, vtkMaskPolyData, vtkMergeDataObjectFilter, vtkMergeFields, vtkMergeFilter, vtkOBBDicer, vtkOutlineCornerFilter, vtkOutlineCornerSource, vtkOutlineFilter, vtkOutlineSource, vtkPlaneSource, vtkPointDataToCellData, vtkPointSource, vtkPolyDataConnectivityFilter, vtkPolyDataNormals, vtkPolyDataStreamer, vtkProbeFilter, vtkProgrammableAttributeDataFilter, vtkProgrammableDataObjectSource, vtkProgrammableFilter, vtkProgrammableGlyphFilter, vtkProgrammableSource, vtkProjectedTexture, vtkQuadricClustering, vtkQuadricDecimation, vtkRearrangeFields, vtkRectilinearGridGeometryFilter, vtkRecursiveDividingCubes, vtkReflectionFilter, vtkReverseSense, vtkRibbonFilter, vtkRotationalExtrusionFilter, vtkRuledSurfaceFilter, vtkSelectPolyData, vtkShrinkFilter, vtkShrinkPolyData, vtkSimpleElevationFilter, vtkSmoothPolyDataFilter, vtkSpatialRepresentationFilter, vtkSpherePuzzle, vtkSpherePuzzleArrows, vtkSphereSource, vtkSplitField, vtkStreamLine, vtkStreamPoints, vtkStripper, vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, vtkSubdivideTetra, vtkSubPixelPositionEdgels, vtkSuperquadricSource, vtkTensorGlyph, vtkTextSource, vtkTexturedSphereSource, vtkTextureMapToCylinder, vtkTextureMapToPlane, vtkTextureMapToSphere, vtkThreshold, vtkThresholdPoints, vtkThresholdTextureCoords, vtkTransformFilter, vtkTransformPolyDataFilter, vtkTransformTextureCoords, vtkTriangleFilter, vtkTriangularTCoords, vtkTubeFilter, vtkVectorDot, vtkVectorNorm, vtkVoxelContoursToSurfaceFilter, vtkWarpLens, vtkWarpScalar, vtkWarpTo, vtkWarpVector, vtkWindowedSincPolyDataFilter, vtkArcPlotter, vtkDepthSortPolyData, vtkEarthSource, vtkGLUTesselatorTriangleFilter, vtkImageToPolyDataFilter, vtkImplicitModeller, vtkPCAAnalysisFilter, vtkProcrustesAlignmentFilter, vtkVectorText, vtkWeightedTransformFilter, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkBYUReader, vtkDataObjectReader, vtkDataSetReader, vtkEnSightReader, vtkGenericEnSightReader, vtkMCubesReader, vtkOBJReader, vtkParticleReader, vtkPLOT3DReader, vtkPLYReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkSTLReader, vtkStructuredGridReader, vtkStructuredPointsReader, vtkUGFacetReader, vtkUnstructuredGridReader, vtkVolume16Reader, vtkCutMaterial, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkPCellDataToPointData, vtkPDataSetReader, vtkPieceScalars, vtkPLinearExtrusionFilter, vtkPOPReader, vtkPPolyDataNormals, vtkPSphereSource, vtkPVGeometryFilter, vtkRectilinearGridOutlineFilter, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkDecimate, vtkDividingCubes, vtkGridSynchronizedTemplates3D, vtkImageMarchingCubes, vtkKitwareContourFilter, vtkMarchingContourFilter, vtkMarchingCubes, vtkMarchingSquares, vtkSweptSurface, vtkSynchronizedTemplates2D, vtkSynchronizedTemplates3D, vtkRendererSource, and vtkSelectVisiblePoints.

virtual void vtkSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented in vtkCastToConcrete, vtkDataSetToDataSetFilter, vtkImageMultipleInputFilter, vtkImageMultipleInputOutputFilter, vtkImageToImageFilter, vtkImageToStructuredPoints, vtkSimpleImageToImageFilter, vtkStructuredPointsSource, vtkStructuredPointsToStructuredPointsFilter, vtkCleanPolyData, vtkConeSource, vtkDataObjectToDataSetFilter, vtkDataSetSurfaceFilter, vtkExtractGrid, vtkGeometryFilter, vtkGlyph3D, vtkOutlineCornerFilter, vtkOutlineFilter, vtkPointSource, vtkProbeFilter, vtkSphereSource, vtkImplicitModeller, vtkRenderLargeImage, vtkTransformToGrid, vtkVideoSource, vtkExtractVOI, vtkImageAccumulate, vtkImageAppend, vtkImageAppendComponents, vtkImageBlend, vtkImageCast, vtkImageChangeInformation, vtkImageClip, vtkImageCorrelation, vtkImageDifference, vtkImageDivergence, vtkImageDotProduct, vtkImageEllipsoidSource, vtkImageEuclideanDistance, vtkImageExtractComponents, vtkImageFFT, vtkImageFlip, vtkImageGaussianSource, vtkImageGradient, vtkImageGradientMagnitude, vtkImageGridSource, vtkImageImport, vtkImageIterateFilter, vtkImageLuminance, vtkImageMagnify, vtkImageMagnitude, vtkImageMandelbrotSource, vtkImageMapToColors, vtkImageMapToWindowLevelColors, vtkImageMask, vtkImageMathematics, vtkImageNoiseSource, vtkImageNonMaximumSuppression, vtkImageNormalize, vtkImagePadFilter, vtkImagePermute, vtkImageQuantizeRGBToIndex, vtkImageRange3D, vtkImageResample, vtkImageReslice, vtkImageRFFT, vtkImageSeparableConvolution, vtkImageShiftScale, vtkImageShrink3D, vtkImageSinusoidSource, vtkImageSobel2D, vtkImageSobel3D, vtkImageSpatialFilter, vtkImageStencil, vtkImageThreshold, vtkImageTranslateExtent, vtkImageVariance3D, vtkSampleFunction, vtkBMPReader, vtkDEMReader, vtkGESignaReader, vtkImageReader, vtkImageReader2, vtkJPEGReader, vtkParticleReader, vtkPLOT3DReader, vtkPNGReader, vtkPNMReader, vtkRectilinearGridReader, vtkSLCReader, vtkStructuredGridReader, vtkStructuredPointsReader, vtkTIFFReader, vtkVolume16Reader, vtkExtractPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkImageBlockReader, vtkPDataSetReader, vtkPOPReader, vtkRectilinearGridOutlineFilter, vtkRTAnalyticSource, vtkTransmitPolyDataPiece, vtkTransmitUnstructuredGridPiece, vtkGridSynchronizedTemplates3D, vtkKitwareContourFilter, vtkSweptSurface, vtkSynchronizedTemplates3D, and vtkWindowToImageFilter.

void vtkSource::SetNumberOfOutputs ( int num ) [protected]

vtkDataObject* vtkSource::GetOutput ( int idx ) [protected]

Reimplemented in vtkDataObjectSource, vtkDataSetSource, vtkDataSetToDataSetFilter, vtkImageMultipleInputOutputFilter, vtkImageSource, vtkImageToStructuredPoints, vtkPiecewiseFunctionSource, vtkPointSetSource, vtkPointSetToPointSetFilter, vtkPolyDataSource, vtkRectilinearGridSource, vtkStructuredGridSource, vtkStructuredPointsSource, vtkUnstructuredGridSource, vtkDataObjectToDataSetFilter, vtkExtractVectorComponents, vtkProgrammableDataObjectSource, vtkSpatialRepresentationFilter, vtkPCAAnalysisFilter, vtkProcrustesAlignmentFilter, vtkImageOpenClose3D, vtkDataObjectReader, vtkDataSetReader, vtkPolyDataReader, vtkRectilinearGridReader, vtkStructuredGridReader, vtkStructuredPointsReader, and vtkUnstructuredGridReader.

Referenced by vtkUnstructuredGridReader::GetOutput(), vtkStructuredPointsReader::GetOutput(), vtkStructuredGridReader::GetOutput(), vtkRectilinearGridReader::GetOutput(), vtkPolyDataReader::GetOutput(), vtkDataSetReader::GetOutput(), vtkDataObjectReader::GetOutput(), vtkProgrammableDataObjectSource::GetOutput(), vtkDataObjectToDataSetFilter::GetOutput(), vtkUnstructuredGridSource::GetOutput(), vtkStructuredPointsSource::GetOutput(), vtkStructuredGridSource::GetOutput(), vtkRectilinearGridSource::GetOutput(), vtkPolyDataSource::GetOutput(), vtkPointSetSource::GetOutput(), vtkPiecewiseFunctionSource::GetOutput(), vtkImageToStructuredPoints::GetOutput(), vtkImageSource::GetOutput(), vtkDataSetSource::GetOutput(), and vtkDataObjectSource::GetOutput().

virtual void vtkSource::SetNthOutput | ( | int | num,
 |  | vtkDataObject * | output
 | ) | [protected, virtual]

virtual void vtkSource::AddOutput ( vtkDataObject * output ) [protected, virtual]

virtual void vtkSource::RemoveOutput ( vtkDataObject * output ) [protected, virtual]

virtual void vtkSource::SetErrorCode ( unsigned long ) [protected, virtual]

The reader should set this code at the end of the update. The error code contains a possible error that occured while reading the file.

Member Data Documentation

int vtkSource::LegacyHack

Legacy method. This method was used by inmaging filters to change the UpdateExtent of their input so that the vtkImmageToImageFilter superclass would allocate a larger volume. Changing the UpdateExtent of your input is no longer allowed. The alternative method is to write your own "Execute()" method and allocate your own data.

Definition at line 136 of file vtkSource.h.

vtkDataObject** vtkSource::Outputs [protected]

Definition at line 175 of file vtkSource.h.

int vtkSource::NumberOfOutputs [protected]

Definition at line 176 of file vtkSource.h.

int vtkSource::Updating [protected]

Reimplemented in vtkDataObjectToDataSetFilter.

Definition at line 177 of file vtkSource.h.

vtkTimeStamp vtkSource::InformationTime [protected]

Definition at line 179 of file vtkSource.h.

The documentation for this class was generated from the following file:
  • Common/vtkSource.h
Generated on Mon Mar 25 01:31:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpatialRepresentationFilter Class Reference

generate polygonal model of spatial search object (i.e., a vtkLocator). More...

#include <vtkSpatialRepresentationFilter.h>

Inheritance diagram for vtkSpatialRepresentationFilter:

[legend]
Collaboration diagram for vtkSpatialRepresentationFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSpatialRepresentationFilter, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkPolyData * | GetOutput (int level)
vtkPolyData * GetOutput ()
void | ResetOutput ()
virtual void | SetSpatialRepresentation (vtkLocator *)
virtual vtkLocator * | GetSpatialRepresentation ()
virtual int | GetLevel ()
virtual void | SetInput (vtkDataSet *input)
vtkDataSet * GetInput ()

Static Public Methods

vtkSpatialRepresentationFilter * | New ()

Protected Methods

vtkSpatialRepresentationFilter ()
~vtkSpatialRepresentationFilter ()
void | Execute ()
void | GenerateOutput ()

Protected Attributes

int | Level
int | TerminalNodesRequested
vtkLocator * SpatialRepresentation

Detailed Description

generate polygonal model of spatial search object (i.e., a vtkLocator).

Date:
2002/01/22 15:29:46
Revision:
1.26

vtkSpatialRepresentationFilter generates an polygonal representation of a spatial search (vtkLocator) object. The representation varies depending upon the nature of the spatial search object. For example, the representation for vtkOBBTree is a collection of oriented bounding boxes. Ths input to this filter is a dataset of any type, and the output is polygonal data. You must also specify the spatial search object to use.

Generally spatial search objects are used for collision detection and other geometric operations, but in this filter one or more levels of spatial searchers can be generated to form a geometric approximation to the input data. This is a form of data simplification, generally used to accelerate the rendering process. Or, this filter can be used as a debugging/ visualization aid for spatial search objects.

This filter can generate one or more output vtkPolyData corresponding to different levels in the spatial search tree. The output data is retrieved using the GetOutput(id) method, where id ranges from 0 (root level) to Level. Note that the output for level "id" is not computed unless a GetOutput(id) method is issued. Thus, if you desire three levels of output (say 2,4,7), you would have to invoke GetOutput(2), GetOutput(4), and GetOutput(7). (Also note that the Level ivar is computed automatically depending on the size and nature of the input data.) There is also another GetOutput() method that takes no parameters. This method returns the leafs of the spatial search tree, which may be at different levels.

Warning:
You can specify the number of levels of to generate with the MaxLevels ivar. However, when the spatial search tree is built, this number of levels may not actually be generated. The actual number available can be found in the Levels ivar. Note that the value of Levels may change after filter execution.
See also:
vtkLocator vtkPointLocator vtkCellLocator vtkOBBTree
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (54%)
  • Martin, Ken (16%)
  • Lorensen, Bill (9%)
  • Blue, Rusty (8%)
Tests:
vtkSpatialRepresentationFilter (Tests)

Definition at line 79 of file vtkSpatialRepresentationFilter.h.

Constructor & Destructor Documentation

vtkSpatialRepresentationFilter::vtkSpatialRepresentationFilter ( ) [protected]

vtkSpatialRepresentationFilter::~vtkSpatialRepresentationFilter ( ) [protected]

Member Function Documentation

vtkSpatialRepresentationFilter* vtkSpatialRepresentationFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkSpatialRepresentationFilter::vtkTypeRevisionMacro | ( | vtkSpatialRepresentationFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSpatialRepresentationFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkSpatialRepresentationFilter::SetSpatialRepresentation ( vtkLocator * ) [virtual]

Set/Get the locator that will be used to generate the representation.

virtual vtkLocator* vtkSpatialRepresentationFilter::GetSpatialRepresentation ( ) [virtual]

Set/Get the locator that will be used to generate the representation.

virtual int vtkSpatialRepresentationFilter::GetLevel ( ) [virtual]

Get the maximum number of outputs actually available.

vtkPolyData* vtkSpatialRepresentationFilter::GetOutput ( int level )

A special form of the GetOutput() method that returns multiple outputs.

Reimplemented from vtkPolyDataSource.

vtkPolyData* vtkSpatialRepresentationFilter::GetOutput ( )

Output of terminal nodes/leaves.

Reimplemented from vtkPolyDataSource.

void vtkSpatialRepresentationFilter::ResetOutput ( )

Reset requested output levels

virtual void vtkSpatialRepresentationFilter::SetInput ( vtkDataSet * input ) [virtual]

Set / get the input data or filter.

vtkDataSet* vtkSpatialRepresentationFilter::GetInput ( )

Set / get the input data or filter.

void vtkSpatialRepresentationFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSpatialRepresentationFilter::GenerateOutput ( ) [protected]

Member Data Documentation

int vtkSpatialRepresentationFilter::Level [protected]

Definition at line 120 of file vtkSpatialRepresentationFilter.h.

int vtkSpatialRepresentationFilter::TerminalNodesRequested [protected]

Definition at line 121 of file vtkSpatialRepresentationFilter.h.

vtkLocator* vtkSpatialRepresentationFilter::SpatialRepresentation [protected]

Definition at line 123 of file vtkSpatialRepresentationFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSpatialRepresentationFilter.h
Generated on Mon Mar 25 01:31:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSphere Class Reference

implicit function for a sphere. More...

#include <vtkSphere.h>

Inheritance diagram for vtkSphere:

[legend]
Collaboration diagram for vtkSphere:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSphere, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
void | EvaluateGradient (float x[3], float n[3])
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])

Static Public Methods

vtkSphere * | New ()

Protected Methods

vtkSphere ()
~vtkSphere ()

Protected Attributes

float | Radius
float | Center [3]

Detailed Description

implicit function for a sphere.

Date:
2002/01/22 15:28:12
Revision:
1.36

vtkSphere computes the implicit function and/or gradient for a sphere. vtkSphere is a concrete implementation of vtkImplicitFunction.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Martin, Ken (13%)
  • Kelly, Ann (8%)
Examples:
vtkSphere (Examples)
Tests:
vtkSphere (Tests)

Definition at line 45 of file vtkSphere.h.

Constructor & Destructor Documentation

vtkSphere::vtkSphere ( ) [protected]

vtkSphere::~vtkSphere ( ) [inline, protected]

Definition at line 78 of file vtkSphere.h.

Member Function Documentation

vtkSphere::vtkTypeRevisionMacro | ( | vtkSphere | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkSphere::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

vtkSphere* vtkSphere::New ( ) [static]

Construct sphere with center at (0,0,0) and radius=0.5.

Reimplemented from vtkObject.

float vtkSphere::EvaluateFunction ( float x[3] ) [virtual]

Evaluate sphere equation ((x-x0)^2 + (y-y0)^2 + (z-z0)^2) - R^2.

Reimplemented from vtkImplicitFunction.

float vtkSphere::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate sphere equation ((x-x0)^2 + (y-y0)^2 + (z-z0)^2) - R^2.

Reimplemented from vtkImplicitFunction.

Definition at line 57 of file vtkSphere.h.

void vtkSphere::EvaluateGradient | ( | float | x[3],
 |  | float | n[3]
 | ) | [virtual]

Evaluate sphere gradient.

Reimplemented from vtkImplicitFunction.

virtual void vtkSphere::SetRadius ( float ) [virtual]

Set / get the radius of the sphere.

virtual float vtkSphere::GetRadius ( ) [virtual]

Set / get the radius of the sphere.

virtual void vtkSphere::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set / get the center of the sphere.

virtual void vtkSphere::SetCenter ( float [3] ) [virtual]

Set / get the center of the sphere.

virtual float* vtkSphere::GetCenter ( ) [virtual]

Set / get the center of the sphere.

virtual void vtkSphere::GetCenter ( float data[3] ) [virtual]

Set / get the center of the sphere.

Member Data Documentation

float vtkSphere::Radius [protected]

Definition at line 80 of file vtkSphere.h.

float vtkSphere::Center[3] [protected]

Definition at line 81 of file vtkSphere.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkSphere.h
Generated on Mon Mar 25 01:31:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpherePuzzle Class Reference

create a polygonal sphere centered at the origin. More...

#include <vtkSpherePuzzle.h>

Inheritance diagram for vtkSpherePuzzle:

[legend]
Collaboration diagram for vtkSpherePuzzle:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSpherePuzzle, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Reset ()
void | MoveHorizontal (int section, int percentage, int rightFlag)
void | MoveVertical (int section, int percentage, int rightFlag)
int | SetPoint (float x, float y, float z)
void | MovePoint (int percentage)
int * | GetState ()

Static Public Methods

vtkSpherePuzzle * | New ()

Protected Methods

vtkSpherePuzzle ()
~vtkSpherePuzzle ()
vtkSpherePuzzle (const vtkSpherePuzzle &)
void | operator= (const vtkSpherePuzzle &)
void | Execute ()
void | MarkVertical (int section)
void | MarkHorizontal (int section)

Protected Attributes

int | State [32]
int | PieceMask [32]
vtkTransform * Transform
unsigned char | Colors [96]
int | Active
int | VerticalFlag
int | RightFlag
int | Section

Detailed Description

create a polygonal sphere centered at the origin.

Date:
2002/01/22 15:29:46
Revision:
1.3

vtkSpherePuzzle creates

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (99%)
Examples:
vtkSpherePuzzle (Examples)
Tests:
vtkSpherePuzzle (Tests)

Definition at line 45 of file vtkSpherePuzzle.h.

Constructor & Destructor Documentation

vtkSpherePuzzle::vtkSpherePuzzle ( ) [protected]

vtkSpherePuzzle::~vtkSpherePuzzle ( ) [protected]

vtkSpherePuzzle::vtkSpherePuzzle ( const vtkSpherePuzzle & ) [protected]

Member Function Documentation

vtkSpherePuzzle::vtkTypeRevisionMacro | ( | vtkSpherePuzzle | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSpherePuzzle::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSpherePuzzle* vtkSpherePuzzle::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

void vtkSpherePuzzle::Reset ( )

Reset the state of this puzzle back to its original state.

void vtkSpherePuzzle::MoveHorizontal | ( | int | section,
 |  | int | percentage,
 |  | int | rightFlag
 | ) |

Move the top/bottom half one segment either direction.

void vtkSpherePuzzle::MoveVertical | ( | int | section,
 |  | int | percentage,
 |  | int | rightFlag
 | ) |

Rotate vertical half of sphere along one of the longitude lines.

int vtkSpherePuzzle::SetPoint | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

SetPoint will be called as the mouse moves over the screen. The output will change to indicate the pending move. SetPoint returns zero if move is not activated by point. Otherwise it encodes the move into a unique integer so that the caller can determine if the move state has changed. This will answer the question, "Should I render."

void vtkSpherePuzzle::MovePoint ( int percentage )

Move actually implements the pending move. When percentage is 100, the pending move becomes inactive, and SetPoint will have to be called again to setup another move.

int* vtkSpherePuzzle::GetState ( ) [inline]

For drawing state as arrows.

Definition at line 75 of file vtkSpherePuzzle.h.

Referenced by vtkSpherePuzzleArrows::SetPermutation().

void vtkSpherePuzzle::operator= ( const vtkSpherePuzzle & ) [protected]

void vtkSpherePuzzle::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSpherePuzzle::MarkVertical ( int section ) [protected]

void vtkSpherePuzzle::MarkHorizontal ( int section ) [protected]

Member Data Documentation

int vtkSpherePuzzle::State[32] [protected]

Definition at line 87 of file vtkSpherePuzzle.h.

int vtkSpherePuzzle::PieceMask[32] [protected]

Definition at line 90 of file vtkSpherePuzzle.h.

vtkTransform* vtkSpherePuzzle::Transform [protected]

Definition at line 91 of file vtkSpherePuzzle.h.

unsigned char vtkSpherePuzzle::Colors[96] [protected]

Definition at line 94 of file vtkSpherePuzzle.h.

int vtkSpherePuzzle::Active [protected]

Definition at line 97 of file vtkSpherePuzzle.h.

int vtkSpherePuzzle::VerticalFlag [protected]

Definition at line 98 of file vtkSpherePuzzle.h.

int vtkSpherePuzzle::RightFlag [protected]

Definition at line 99 of file vtkSpherePuzzle.h.

int vtkSpherePuzzle::Section [protected]

Definition at line 100 of file vtkSpherePuzzle.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSpherePuzzle.h
Generated on Mon Mar 25 01:31:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpherePuzzleArrows Class Reference

Visualize permutation of the sphere puzzle. More...

#include <vtkSpherePuzzleArrows.h>

Inheritance diagram for vtkSpherePuzzleArrows:

[legend]
Collaboration diagram for vtkSpherePuzzleArrows:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSpherePuzzleArrows, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPermutation (int data[])
virtual int * | GetPermutation ()
virtual void | GetPermutation (int data[32])
void | SetPermutationComponent (int comp, int val)
void | SetPermutation (vtkSpherePuzzle *puz)

Static Public Methods

vtkSpherePuzzleArrows * | New ()

Protected Methods

vtkSpherePuzzleArrows ()
~vtkSpherePuzzleArrows ()
vtkSpherePuzzleArrows (const vtkSpherePuzzleArrows &)
void | operator= (const vtkSpherePuzzleArrows &)
void | Execute ()
void | AppendArrow (int id0, int id1, vtkPoints *pts, vtkCellArray *polys)

Protected Attributes

int | Permutation [32]
float | Radius

Detailed Description

Visualize permutation of the sphere puzzle.

Date:
2002/01/22 15:29:46
Revision:
1.3

vtkSpherePuzzleArrows creates

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (97%)
Examples:
vtkSpherePuzzleArrows (Examples)
Tests:
vtkSpherePuzzleArrows (Tests)

Definition at line 44 of file vtkSpherePuzzleArrows.h.

Constructor & Destructor Documentation

vtkSpherePuzzleArrows::vtkSpherePuzzleArrows ( ) [protected]

vtkSpherePuzzleArrows::~vtkSpherePuzzleArrows ( ) [protected]

vtkSpherePuzzleArrows::vtkSpherePuzzleArrows ( const vtkSpherePuzzleArrows & ) [protected]

Member Function Documentation

vtkSpherePuzzleArrows::vtkTypeRevisionMacro | ( | vtkSpherePuzzleArrows | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSpherePuzzleArrows::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSpherePuzzleArrows* vtkSpherePuzzleArrows::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

virtual void vtkSpherePuzzleArrows::SetPermutation ( int data[] ) [virtual]

virtual int* vtkSpherePuzzleArrows::GetPermutation ( ) [virtual]

virtual void vtkSpherePuzzleArrows::GetPermutation ( int data[32] ) [virtual]

void vtkSpherePuzzleArrows::SetPermutationComponent | ( | int | comp,
 |  | int | val
 | ) |

void vtkSpherePuzzleArrows::SetPermutation ( vtkSpherePuzzle * puz ) [inline]

Definition at line 56 of file vtkSpherePuzzleArrows.h.

void vtkSpherePuzzleArrows::operator= ( const vtkSpherePuzzleArrows & ) [protected]

void vtkSpherePuzzleArrows::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSpherePuzzleArrows::AppendArrow | ( | int | id0,
 |  | int | id1,
 |  | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

Member Data Documentation

int vtkSpherePuzzleArrows::Permutation[32] [protected]

Definition at line 69 of file vtkSpherePuzzleArrows.h.

float vtkSpherePuzzleArrows::Radius [protected]

Definition at line 71 of file vtkSpherePuzzleArrows.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSpherePuzzleArrows.h
Generated on Mon Mar 25 01:31:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSphereSource Class Reference

create a polygonal sphere centered at the origin. More...

#include <vtkSphereSource.h>

Inheritance diagram for vtkSphereSource:

[legend]
Collaboration diagram for vtkSphereSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSphereSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetThetaResolution (int)
virtual int | GetThetaResolution ()
virtual void | SetPhiResolution (int)
virtual int | GetPhiResolution ()
virtual void | SetStartTheta (float)
virtual float | GetStartTheta ()
virtual void | SetEndTheta (float)
virtual float | GetEndTheta ()
virtual void | SetStartPhi (float)
virtual float | GetStartPhi ()
virtual void | SetEndPhi (float)
virtual float | GetEndPhi ()
virtual void | SetLatLongTessellation (int)
virtual int | GetLatLongTessellation ()
virtual void | LatLongTessellationOn ()
virtual void | LatLongTessellationOff ()

Static Public Methods

vtkSphereSource * | New ()

Protected Methods

vtkSphereSource (int res=8)
~vtkSphereSource ()
void | Execute ()
void | ExecuteInformation ()

Protected Attributes

float | Radius
float | Center [3]
int | ThetaResolution
int | PhiResolution
float | StartTheta
float | EndTheta
float | StartPhi
float | EndPhi
int | LatLongTessellation

Detailed Description

create a polygonal sphere centered at the origin.

Date:
2002/01/22 15:29:47
Revision:
1.50

vtkSphereSource creates a sphere (represented by polygons) of specified radius centered at the origin. The resolution (polygonal discretization) in both the latitude (phi) and longitude (theta) directions can be specified. It also is possible to create partial spheres by specifying maximum phi and theta angles. By default, the surface tessellation of the sphere uses triangles; however you can set LatLongTessellation to produce a tessellation using quadrilaterals.

Warning:
Resolution means the number of latitude or longitude lines for a complete sphere. If you create partial spheres the number of latitude/longitude lines may be off by one.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Henderson, Amy (29%)
  • Lorensen, Bill (10%)
  • Martin, Ken (5%)
Examples:
vtkSphereSource (Examples)
Tests:
vtkSphereSource (Tests)

Definition at line 57 of file vtkSphereSource.h.

Constructor & Destructor Documentation

vtkSphereSource::vtkSphereSource ( int res = 8 ) [protected]

vtkSphereSource::~vtkSphereSource ( ) [inline, protected]

Definition at line 133 of file vtkSphereSource.h.

Member Function Documentation

vtkSphereSource::vtkTypeRevisionMacro | ( | vtkSphereSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkPSphereSource.

void vtkSphereSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSphereSource* vtkSphereSource::New ( ) [static]

Construct sphere with radius=0.5 and default resolution 8 in both Phi and Theta directions. Theta ranges from (0,360) and phi (0,180) degrees.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkPSphereSource.

virtual void vtkSphereSource::SetRadius ( float ) [virtual]

Set radius of sphere. Default is .5.

virtual float vtkSphereSource::GetRadius ( ) [virtual]

Set radius of sphere. Default is .5.

virtual void vtkSphereSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the sphere. Default is 0,0,0.

virtual void vtkSphereSource::SetCenter ( float [3] ) [virtual]

Set the center of the sphere. Default is 0,0,0.

virtual float* vtkSphereSource::GetCenter ( ) [virtual]

Set the center of the sphere. Default is 0,0,0.

virtual void vtkSphereSource::GetCenter ( float data[3] ) [virtual]

Set the center of the sphere. Default is 0,0,0.

virtual void vtkSphereSource::SetThetaResolution ( int ) [virtual]

Set the number of points in the longitude direction (ranging from StartTheta to EndTheta).

virtual int vtkSphereSource::GetThetaResolution ( ) [virtual]

Set the number of points in the longitude direction (ranging from StartTheta to EndTheta).

virtual void vtkSphereSource::SetPhiResolution ( int ) [virtual]

Set the number of points in the latitude direction (ranging from StartPhi to EndPhi).

virtual int vtkSphereSource::GetPhiResolution ( ) [virtual]

Set the number of points in the latitude direction (ranging from StartPhi to EndPhi).

virtual void vtkSphereSource::SetStartTheta ( float ) [virtual]

Set the starting longitude angle. By default StartTheta=0 degrees.

virtual float vtkSphereSource::GetStartTheta ( ) [virtual]

Set the starting longitude angle. By default StartTheta=0 degrees.

virtual void vtkSphereSource::SetEndTheta ( float ) [virtual]

Set the ending longitude angle. By default EndTheta=360 degrees.

virtual float vtkSphereSource::GetEndTheta ( ) [virtual]

Set the ending longitude angle. By default EndTheta=360 degrees.

virtual void vtkSphereSource::SetStartPhi ( float ) [virtual]

Set the starting latitude angle (0 is at north pole). By default StartPhi=0 degrees.

virtual float vtkSphereSource::GetStartPhi ( ) [virtual]

Set the starting latitude angle (0 is at north pole). By default StartPhi=0 degrees.

virtual void vtkSphereSource::SetEndPhi ( float ) [virtual]

Set the ending latitude angle. By default EndPhi=180 degrees.

virtual float vtkSphereSource::GetEndPhi ( ) [virtual]

Set the ending latitude angle. By default EndPhi=180 degrees.

virtual void vtkSphereSource::SetLatLongTessellation ( int ) [virtual]

Cause the sphere to be tessellated with edges along the latitude and longitude lines. If off, triangles are generated at non-polar regions, which results in edges that are not parallel to latitude and longitude lines. If on, quadrilaterals are generated everywhere except at the poles. This can be useful for generating a wireframe sphere with natural latitude and longitude lines.

virtual int vtkSphereSource::GetLatLongTessellation ( ) [virtual]

Cause the sphere to be tessellated with edges along the latitude and longitude lines. If off, triangles are generated at non-polar regions, which results in edges that are not parallel to latitude and longitude lines. If on, quadrilaterals are generated everywhere except at the poles. This can be useful for generating a wireframe sphere with natural latitude and longitude lines.

virtual void vtkSphereSource::LatLongTessellationOn ( ) [virtual]

Cause the sphere to be tessellated with edges along the latitude and longitude lines. If off, triangles are generated at non-polar regions, which results in edges that are not parallel to latitude and longitude lines. If on, quadrilaterals are generated everywhere except at the poles. This can be useful for generating a wireframe sphere with natural latitude and longitude lines.

virtual void vtkSphereSource::LatLongTessellationOff ( ) [virtual]

Cause the sphere to be tessellated with edges along the latitude and longitude lines. If off, triangles are generated at non-polar regions, which results in edges that are not parallel to latitude and longitude lines. If on, quadrilaterals are generated everywhere except at the poles. This can be useful for generating a wireframe sphere with natural latitude and longitude lines.

void vtkSphereSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkPSphereSource.

void vtkSphereSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Member Data Documentation

float vtkSphereSource::Radius [protected]

Definition at line 138 of file vtkSphereSource.h.

float vtkSphereSource::Center[3] [protected]

Definition at line 139 of file vtkSphereSource.h.

int vtkSphereSource::ThetaResolution [protected]

Definition at line 140 of file vtkSphereSource.h.

int vtkSphereSource::PhiResolution [protected]

Definition at line 141 of file vtkSphereSource.h.

float vtkSphereSource::StartTheta [protected]

Definition at line 142 of file vtkSphereSource.h.

float vtkSphereSource::EndTheta [protected]

Definition at line 143 of file vtkSphereSource.h.

float vtkSphereSource::StartPhi [protected]

Definition at line 144 of file vtkSphereSource.h.

float vtkSphereSource::EndPhi [protected]

Definition at line 145 of file vtkSphereSource.h.

int vtkSphereSource::LatLongTessellation [protected]

Definition at line 146 of file vtkSphereSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSphereSource.h
Generated on Mon Mar 25 01:31:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSpline Class Reference

spline abstract class. More...

#include <vtkSpline.h>

Inheritance diagram for vtkSpline:

[legend]
Collaboration diagram for vtkSpline:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSpline, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Compute ()=0
void | AddPoint (float t, float x)
void | RemovePoint (float t)
void | RemoveAllPoints ()
unsigned long | GetMTime ()
virtual void | SetClampValue (int)
virtual int | GetClampValue ()
virtual void | ClampValueOn ()
virtual void | ClampValueOff ()
virtual void | SetClosed (int)
virtual int | GetClosed ()
virtual void | ClosedOn ()
virtual void | ClosedOff ()
virtual void | SetLeftConstraint (int)
virtual int | GetLeftConstraint ()
virtual void | SetRightConstraint (int)
virtual int | GetRightConstraint ()
virtual void | SetLeftValue (float)
virtual float | GetLeftValue ()
virtual void | SetRightValue (float)
virtual float | GetRightValue ()

Protected Methods

vtkSpline ()
~vtkSpline ()

Protected Attributes

unsigned long | ComputeTime
int | ClampValue
float * | Intervals
float * | Coefficients
int | LeftConstraint
float | LeftValue
int | RightConstraint
float | RightValue
vtkPiecewiseFunction * PiecewiseFunction
int | Closed

Detailed Description

spline abstract class.

Date:
2002/01/22 15:28:13
Revision:
1.22

vtkSpline is used to create interpolated data points for specified data. vtkSpline is an abstract class: its subclasses vtkCardinalSpline and vtkKochenekSpline do the interpolation, The current implementation of splines is limited to data dimensions not exceeding four.

Typically a spline is used by adding a sequence of points followed by use of an evaluation function (e.g., vtkCardinalSpline::Evaluate()). Since these splines are 1D, a point in this context is a independent/ dependent variable pair. Note that the parameter space of the spline ranges from (0,N-1), where N is the number of points in the spline.

Splines can also be set up to be closed or open. Closed splines continue from the last point to the first point with continuous function and derivative values. (You don't need to duplicate the first point to close the spline, just set ClosedOn.) If the spline is closed, the parameter space of the spline becomes (0,N).

See also:
vtkCardinalSpline vtkKochenekSpline
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (90%)

Definition at line 56 of file vtkSpline.h.

Constructor & Destructor Documentation

vtkSpline::vtkSpline ( ) [protected]

vtkSpline::~vtkSpline ( ) [protected]

Member Function Documentation

vtkSpline::vtkTypeRevisionMacro | ( | vtkSpline | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkCardinalSpline, and vtkKochanekSpline.

void vtkSpline::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkCardinalSpline, and vtkKochanekSpline.

virtual void vtkSpline::SetClampValue ( int ) [virtual]

Set/Get ClampValue. If On, results of the interpolation will be clamped to the min/max of the input data.

virtual int vtkSpline::GetClampValue ( ) [virtual]

Set/Get ClampValue. If On, results of the interpolation will be clamped to the min/max of the input data.

virtual void vtkSpline::ClampValueOn ( ) [virtual]

Set/Get ClampValue. If On, results of the interpolation will be clamped to the min/max of the input data.

virtual void vtkSpline::ClampValueOff ( ) [virtual]

Set/Get ClampValue. If On, results of the interpolation will be clamped to the min/max of the input data.

virtual void vtkSpline::Compute ( ) [pure virtual]

Compute the coefficients for the spline.

Reimplemented in vtkCardinalSpline, and vtkKochanekSpline.

void vtkSpline::AddPoint | ( | float | t,
 |  | float | x
 | ) |

Add a pair of points to be fit with the spline.

void vtkSpline::RemovePoint ( float t )

Remove a point from the data to be fit with the spline.

void vtkSpline::RemoveAllPoints ( )

Remove all points from the data.

virtual void vtkSpline::SetClosed ( int ) [virtual]

Control whether the spline is open or closed. A closed spline forms a continuous loop: the first and last points are the same, and derivatives are continuous.

virtual int vtkSpline::GetClosed ( ) [virtual]

Control whether the spline is open or closed. A closed spline forms a continuous loop: the first and last points are the same, and derivatives are continuous.

virtual void vtkSpline::ClosedOn ( ) [virtual]

Control whether the spline is open or closed. A closed spline forms a continuous loop: the first and last points are the same, and derivatives are continuous.

virtual void vtkSpline::ClosedOff ( ) [virtual]

Control whether the spline is open or closed. A closed spline forms a continuous loop: the first and last points are the same, and derivatives are continuous.

virtual void vtkSpline::SetLeftConstraint ( int ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual int vtkSpline::GetLeftConstraint ( ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual void vtkSpline::SetRightConstraint ( int ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual int vtkSpline::GetRightConstraint ( ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual void vtkSpline::SetLeftValue ( float ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual float vtkSpline::GetLeftValue ( ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual void vtkSpline::SetRightValue ( float ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

virtual float vtkSpline::GetRightValue ( ) [virtual]

Set the type of constraint of the left(right) end points. Three constraints are available: 1: the first derivative at left(right)most point is set to Left(Right)Value. 2: the second derivative at left(right)most point is set to Left(Right)Value. 3: the second derivative at left(right)most points is Left(Right)Value times second derivative at first interior point.

unsigned long vtkSpline::GetMTime ( ) [virtual]

Return the MTime also considering the Piecewise function.

Reimplemented from vtkObject.

Member Data Documentation

unsigned long vtkSpline::ComputeTime [protected]

Definition at line 115 of file vtkSpline.h.

int vtkSpline::ClampValue [protected]

Definition at line 116 of file vtkSpline.h.

float* vtkSpline::Intervals [protected]

Definition at line 117 of file vtkSpline.h.

float* vtkSpline::Coefficients [protected]

Definition at line 118 of file vtkSpline.h.

int vtkSpline::LeftConstraint [protected]

Definition at line 119 of file vtkSpline.h.

float vtkSpline::LeftValue [protected]

Definition at line 120 of file vtkSpline.h.

int vtkSpline::RightConstraint [protected]

Definition at line 121 of file vtkSpline.h.

float vtkSpline::RightValue [protected]

Definition at line 122 of file vtkSpline.h.

vtkPiecewiseFunction* vtkSpline::PiecewiseFunction [protected]

Definition at line 123 of file vtkSpline.h.

int vtkSpline::Closed [protected]

Definition at line 124 of file vtkSpline.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkSpline.h
Generated on Mon Mar 25 01:31:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSplitField Class Reference

Split a field into single component fields. More...

#include <vtkSplitField.h>

Inheritance diagram for vtkSplitField:

[legend]
Collaboration diagram for vtkSplitField:

[legend]
List of all members.

Public Types

enum | FieldLocations { DATA_OBJECT = 0, POINT_DATA = 1, CELL_DATA = 2 }

Public Methods

vtkTypeRevisionMacro (vtkSplitField, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInputField (int attributeType, int fieldLoc)
void | SetInputField (const char *name, int fieldLoc)
void | SetInputField (const char *name, const char *fieldLoc)
void | Split (int component, const char *arrayName)

Static Public Methods

vtkSplitField * | New ()

Protected Types

enum | FieldTypes { NAME, ATTRIBUTE }

Protected Methods

vtkSplitField ()
virtual | ~vtkSplitField ()
void | Execute ()
vtkDataArray * | SplitArray (vtkDataArray *da, int component)
Component * | GetNextComponent (Component *op)
Component * GetFirst ()
void | AddComponent (Component *op)
Component * | FindComponent (int index)
void | DeleteAllComponents ()
void | PrintComponent (Component *op, ostream &os, vtkIndent indent)
void | PrintAllComponents (ostream &os, vtkIndent indent)

Protected Attributes

char * | FieldName
int | FieldType
int | AttributeType
int | FieldLocation
Component * Head
Component * Tail

Static Protected Attributes

char | FieldLocationNames [3][12]
char | AttributeNames [vtkDataSetAttributes::NUM_ATTRIBUTES][10]

Detailed Description

Split a field into single component fields.

Date:
2002/01/22 15:29:47
Revision:
1.8

vtkSplitField is used to split a multi-component field (vtkDataArray) into multiple single component fields. The new fields are put in the same field data as the original field. The output arrays are of the same type as the input array. Example:

 sf->SetInputField("gradient", vtkSplitField::POINT_DATA);
 sf->Split(0, "firstcomponent");
tells vtkSplitField to extract the first component of the field called gradient and create an array called firstcomponent (the new field will be in the output's point data). The same can be done from Tcl:
 sf SetInputField gradient POINT_DATA
 sf Split 0 firstcomponent

 AttributeTypes: SCALARS, VECTORS, NORMALS, TCOORDS, TENSORS
 Field locations: DATA_OBJECT, POINT_DATA, CELL_DATA
Note that, by default, the original array is also passed through.

Warning:
When using Tcl, Java, Python or Visual Basic bindings, the array name can not be one of the AttributeTypes when calling Split() which takes strings as arguments. The Tcl (Java etc.) command will always assume the string corresponds to an attribute type when the argument is one of the AttributeTypes. In this situation, use the Split() which takes enums.
See also:
vtkFieldData vtkDataSet vtkDataObjectToDataSetFilter vtkDataSetAttributes vtkDataArray vtkRearrangeFields vtkAssignAttribute vtkMergeFields
Created by:
  • Geveci, Berk
Contributed by (if > 5%):
  • Geveci, Berk (92%)
Tests:
vtkSplitField (Tests)

Definition at line 73 of file vtkSplitField.h.

Member Enumeration Documentation

enum vtkSplitField::FieldLocations

Enumeration values:
DATA_OBJECT
POINT_DATA
CELL_DATA

Definition at line 98 of file vtkSplitField.h.

enum vtkSplitField::FieldTypes [protected]

Enumeration values:
NAME
ATTRIBUTE

Definition at line 130 of file vtkSplitField.h.

Constructor & Destructor Documentation

vtkSplitField::vtkSplitField ( ) [protected]

virtual vtkSplitField::~vtkSplitField ( ) [protected, virtual]

Member Function Documentation

vtkSplitField::vtkTypeRevisionMacro | ( | vtkSplitField | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkSplitField::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSplitField* vtkSplitField::New ( ) [static]

Create a new vtkSplitField.

Reimplemented from vtkDataSetSource.

void vtkSplitField::SetInputField | ( | int | attributeType,
 |  | int | fieldLoc
 | ) |

Use the given attribute in the field data given by fieldLoc as input.

void vtkSplitField::SetInputField | ( | const char * | name,
 |  | int | fieldLoc
 | ) |

Use the array with given name in the field data given by fieldLoc as input.

void vtkSplitField::SetInputField | ( | const char * | name,
 |  | const char * | fieldLoc
 | ) |

Helper method used by other language bindings. Allows the caller to specify arguments as strings instead of enums.

void vtkSplitField::Split | ( | int | component,
 |  | const char * | arrayName
 | ) |

Create a new array with the given component.

void vtkSplitField::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

vtkDataArray* vtkSplitField::SplitArray | ( | vtkDataArray * | da,
 |  | int | component
 | ) | [protected]

Component* vtkSplitField::GetNextComponent ( Component * op ) [inline, protected]

Definition at line 158 of file vtkSplitField.h.

Component* vtkSplitField::GetFirst ( ) [inline, protected]

Definition at line 160 of file vtkSplitField.h.

void vtkSplitField::AddComponent ( Component * op ) [protected]

Component* vtkSplitField::FindComponent ( int index ) [protected]

void vtkSplitField::DeleteAllComponents ( ) [protected]

void vtkSplitField::PrintComponent | ( | Component * | op,
 |  | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 166 of file vtkSplitField.h.

void vtkSplitField::PrintAllComponents | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [inline, protected]

Definition at line 172 of file vtkSplitField.h.

Member Data Documentation

char* vtkSplitField::FieldName [protected]

Definition at line 142 of file vtkSplitField.h.

int vtkSplitField::FieldType [protected]

Definition at line 143 of file vtkSplitField.h.

int vtkSplitField::AttributeType [protected]

Definition at line 144 of file vtkSplitField.h.

int vtkSplitField::FieldLocation [protected]

Definition at line 145 of file vtkSplitField.h.

char vtkSplitField::FieldLocationNames[3][12] [static, protected]

Definition at line 147 of file vtkSplitField.h.

char vtkSplitField::AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10] [static, protected]

Definition at line 148 of file vtkSplitField.h.

Component* vtkSplitField::Head [protected]

Definition at line 154 of file vtkSplitField.h.

Component* vtkSplitField::Tail [protected]

Definition at line 155 of file vtkSplitField.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSplitField.h
Generated on Mon Mar 25 01:31:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSplitField::Component Struct Reference

#include <vtkSplitField.h>

Collaboration diagram for vtkSplitField::Component:

[legend]
List of all members.

Public Methods

void | SetName (const char *name)
Component ()
~Component ()

Public Attributes

int | Index
char * | FieldName
Component * | Next

Constructor & Destructor Documentation

vtkSplitField::Component::Component ( ) [inline]

Definition at line 122 of file vtkSplitField.h.

vtkSplitField::Component::~Component ( ) [inline]

Definition at line 123 of file vtkSplitField.h.

Member Function Documentation

void vtkSplitField::Component::SetName ( const char * name ) [inline]

Definition at line 112 of file vtkSplitField.h.

Member Data Documentation

int vtkSplitField::Component::Index

Definition at line 109 of file vtkSplitField.h.

char* vtkSplitField::Component::FieldName

Definition at line 110 of file vtkSplitField.h.

Component* vtkSplitField::Component::Next

Definition at line 111 of file vtkSplitField.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkSplitField.h
Generated on Mon Mar 25 01:31:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


SpotLight Struct Reference

#include <vtk3DS.h>

Collaboration diagram for SpotLight:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS Vector | pos
Vector target
Colour col
float | hotspot
float | falloff
int | shadow_flag
vtkLight * aLight

Member Data Documentation

VTK_LIST_FIELDS Vector SpotLight::pos

Definition at line 65 of file vtk3DS.h.

Vector SpotLight::target

Definition at line 66 of file vtk3DS.h.

Colour SpotLight::col

Definition at line 67 of file vtk3DS.h.

float SpotLight::hotspot

Definition at line 68 of file vtk3DS.h.

float SpotLight::falloff

Definition at line 69 of file vtk3DS.h.

int SpotLight::shadow_flag

Definition at line 70 of file vtk3DS.h.

vtkLight* SpotLight::aLight

Definition at line 71 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:31:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSTLReader Class Reference

read ASCII or binary stereo lithography files. More...

#include <vtkSTLReader.h>

Inheritance diagram for vtkSTLReader:

[legend]
Collaboration diagram for vtkSTLReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSTLReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | CreateDefaultLocator ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetMerging (int)
virtual int | GetMerging ()
virtual void | MergingOn ()
virtual void | MergingOff ()
virtual void | SetScalarTags (int)
virtual int | GetScalarTags ()
virtual void | ScalarTagsOn ()
virtual void | ScalarTagsOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkSTLReader * | New ()

Protected Methods

vtkSTLReader ()
~vtkSTLReader ()
void | Execute ()
int | ReadBinarySTL (FILE *fp, vtkPoints *, vtkCellArray *)
int | ReadASCIISTL (FILE *fp, vtkPoints *, vtkCellArray *, vtkFloatArray *scalars=0)
int | GetSTLFileType (FILE *fp)

Protected Attributes

char * | FileName
int | Merging
int | ScalarTags
vtkPointLocator * Locator

Detailed Description

read ASCII or binary stereo lithography files.

Date:
2002/01/22 15:38:21
Revision:
1.58

vtkSTLReader is a source object that reads ASCII or binary stereo lithography files (.stl files). The FileName must be specified to vtkSTLReader. The object automatically detects whether the file is ASCII or binary.

.stl files are quite inefficient since they duplicate vertex definitions. By setting the Merging boolean you can control whether the point data is merged after reading. Merging is performed by default, however, merging requires a large amount of temporary storage since a 3D hash table must be constructed.

Warning:
Binary files written on one system may not be readable on other systems. vtkSTLWriter uses VAX or PC byte ordering and swaps bytes on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Martin, Ken (11%)
  • Law, Charles (9%)
  • Geveci, Berk (9%)
  • Turner, Wes (8%)
Examples:
vtkSTLReader (Examples)
Tests:
vtkSTLReader (Tests)

Definition at line 62 of file vtkSTLReader.h.

Constructor & Destructor Documentation

vtkSTLReader::vtkSTLReader ( ) [protected]

vtkSTLReader::~vtkSTLReader ( ) [protected]

Member Function Documentation

vtkSTLReader::vtkTypeRevisionMacro | ( | vtkSTLReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSTLReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSTLReader* vtkSTLReader::New ( ) [static]

Construct object with merging set to true.

Reimplemented from vtkPolyDataSource.

unsigned long vtkSTLReader::GetMTime ( ) [virtual]

Overload standard modified time function. If locator is modified, then this object is modified as well.

Reimplemented from vtkObject.

virtual void vtkSTLReader::SetFileName ( const char * ) [virtual]

Specify file name of stereo lithography file.

virtual char* vtkSTLReader::GetFileName ( ) [virtual]

Specify file name of stereo lithography file.

virtual void vtkSTLReader::SetMerging ( int ) [virtual]

Turn on/off merging of points/triangles.

virtual int vtkSTLReader::GetMerging ( ) [virtual]

Turn on/off merging of points/triangles.

virtual void vtkSTLReader::MergingOn ( ) [virtual]

Turn on/off merging of points/triangles.

virtual void vtkSTLReader::MergingOff ( ) [virtual]

Turn on/off merging of points/triangles.

virtual void vtkSTLReader::SetScalarTags ( int ) [virtual]

Turn on/off tagging of solids with scalars.

virtual int vtkSTLReader::GetScalarTags ( ) [virtual]

Turn on/off tagging of solids with scalars.

virtual void vtkSTLReader::ScalarTagsOn ( ) [virtual]

Turn on/off tagging of solids with scalars.

virtual void vtkSTLReader::ScalarTagsOff ( ) [virtual]

Turn on/off tagging of solids with scalars.

void vtkSTLReader::SetLocator ( vtkPointLocator * locator )

Specify a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkSTLReader::GetLocator ( ) [virtual]

Specify a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkSTLReader::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

void vtkSTLReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkSTLReader::ReadBinarySTL | ( | FILE * | fp,
 |  | vtkPoints * | ,
 |  | vtkCellArray * |
 | ) | [protected]

int vtkSTLReader::ReadASCIISTL | ( | FILE * | fp,
 |  | vtkPoints * | ,
 |  | vtkCellArray * | ,
 |  | vtkFloatArray * | scalars = 0
 | ) | [protected]

int vtkSTLReader::GetSTLFileType ( FILE * fp ) [protected]

Member Data Documentation

char* vtkSTLReader::FileName [protected]

Definition at line 109 of file vtkSTLReader.h.

int vtkSTLReader::Merging [protected]

Definition at line 110 of file vtkSTLReader.h.

int vtkSTLReader::ScalarTags [protected]

Definition at line 111 of file vtkSTLReader.h.

vtkPointLocator* vtkSTLReader::Locator [protected]

Definition at line 112 of file vtkSTLReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkSTLReader.h
Generated on Mon Mar 25 01:31:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSTLWriter Class Reference

write stereo lithography files. More...

#include <vtkSTLWriter.h>

Inheritance diagram for vtkSTLWriter:

[legend]
Collaboration diagram for vtkSTLWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSTLWriter, vtkPolyDataWriter)

Static Public Methods

vtkSTLWriter * | New ()

Protected Methods

vtkSTLWriter ()
~vtkSTLWriter ()
void | WriteData ()
void | WriteBinarySTL (vtkPoints *pts, vtkCellArray *polys)
void | WriteAsciiSTL (vtkPoints *pts, vtkCellArray *polys)

Detailed Description

write stereo lithography files.

Date:
2002/01/22 15:38:22
Revision:
1.40

vtkSTLWriter writes stereo lithography (.stl) files in either ASCII or binary form. Stereo lithography files only contain triangles. If polygons with more than 3 vertices are present, only the first 3 vertices are written. Use vtkTriangleFilter to convert polygons to triangles.

Warning:
Binary files written on one system may not be readable on other systems. vtkSTLWriter uses VAX or PC byte ordering and swaps bytes on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Lorensen, Bill (14%)
  • Martin, Ken (11%)
Tests:
vtkSTLWriter (Tests)

Definition at line 50 of file vtkSTLWriter.h.

Constructor & Destructor Documentation

vtkSTLWriter::vtkSTLWriter ( ) [protected]

vtkSTLWriter::~vtkSTLWriter ( ) [inline, protected]

Definition at line 58 of file vtkSTLWriter.h.

Member Function Documentation

vtkSTLWriter* vtkSTLWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkPolyDataWriter.

vtkSTLWriter::vtkTypeRevisionMacro | ( | vtkSTLWriter | ,
 |  | vtkPolyDataWriter |
 | ) |

Reimplemented from vtkPolyDataWriter.

void vtkSTLWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkPolyDataWriter.

void vtkSTLWriter::WriteBinarySTL | ( | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

void vtkSTLWriter::WriteAsciiSTL | ( | vtkPoints * | pts,
 |  | vtkCellArray * | polys
 | ) | [protected]

The documentation for this class was generated from the following file:
  • IO/vtkSTLWriter.h
Generated on Mon Mar 25 01:31:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamArray Class Reference

#include <vtkStreamer.h>

Collaboration diagram for vtkStreamArray:

[legend]
List of all members.

Public Methods

vtkStreamArray ()
~vtkStreamArray ()
vtkIdType GetNumberOfPoints ()
vtkStreamPoint * | GetStreamPoint (vtkIdType i)
vtkIdType InsertNextStreamPoint ()
vtkStreamPoint * | Resize (vtkIdType sz)
void | Reset ()

Public Attributes

vtkStreamPoint * Array
vtkIdType MaxId
vtkIdType Size
vtkIdType Extend
float | Direction

Constructor & Destructor Documentation

vtkStreamArray::vtkStreamArray ( )

vtkStreamArray::~vtkStreamArray ( ) [inline]

Definition at line 98 of file vtkStreamer.h.

Member Function Documentation

vtkIdType vtkStreamArray::GetNumberOfPoints ( ) [inline]

Definition at line 105 of file vtkStreamer.h.

vtkStreamPoint* vtkStreamArray::GetStreamPoint ( vtkIdType i ) [inline]

Definition at line 106 of file vtkStreamer.h.

vtkIdType vtkStreamArray::InsertNextStreamPoint ( ) [inline]

Definition at line 107 of file vtkStreamer.h.

vtkStreamPoint* vtkStreamArray::Resize ( vtkIdType sz )

Referenced by InsertNextStreamPoint().

void vtkStreamArray::Reset ( ) [inline]

Definition at line 116 of file vtkStreamer.h.

Member Data Documentation

vtkStreamPoint* vtkStreamArray::Array

Definition at line 118 of file vtkStreamer.h.

vtkIdType vtkStreamArray::MaxId

Definition at line 119 of file vtkStreamer.h.

vtkIdType vtkStreamArray::Size

Definition at line 120 of file vtkStreamer.h.

vtkIdType vtkStreamArray::Extend

Definition at line 121 of file vtkStreamer.h.

float vtkStreamArray::Direction

Definition at line 122 of file vtkStreamer.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStreamer.h
Generated on Mon Mar 25 01:31:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamer Class Reference

abstract object implements integration of massless particle through vector field. More...

#include <vtkStreamer.h>

Inheritance diagram for vtkStreamer:

[legend]
Collaboration diagram for vtkStreamer:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStreamer, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetStartLocation (vtkIdType cellId, int subId, float pcoords[3])
vtkIdType | GetStartLocation (int &subId, float pcoords[3])
void | SetStartPosition (float x[3])
void | SetStartPosition (float x, float y, float z)
float * | GetStartPosition ()
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
virtual void | SetSavePointInterval (float)
virtual float | GetSavePointInterval ()
void | SetStartLocation (vtkIdType cellId, int subId, float r, float s, float t)
void | SetSource (vtkDataSet *source)
vtkDataSet * GetSource ()
virtual void | SetMaximumPropagationTime (float)
virtual float | GetMaximumPropagationTime ()
virtual void | SetIntegrationDirection (int)
virtual int | GetIntegrationDirection ()
void | SetIntegrationDirectionToForward ()
void | SetIntegrationDirectionToBackward ()
void | SetIntegrationDirectionToIntegrateBothDirections ()
const char * | GetIntegrationDirectionAsString ()
virtual void | SetIntegrationStepLength (float)
virtual float | GetIntegrationStepLength ()
virtual void | SetSpeedScalars (int)
virtual int | GetSpeedScalars ()
virtual void | SpeedScalarsOn ()
virtual void | SpeedScalarsOff ()
virtual void | SetOrientationScalars (int)
virtual int | GetOrientationScalars ()
virtual void | OrientationScalarsOn ()
virtual void | OrientationScalarsOff ()
virtual void | SetTerminalSpeed (float)
virtual float | GetTerminalSpeed ()
virtual void | SetVorticity (int)
virtual int | GetVorticity ()
virtual void | VorticityOn ()
virtual void | VorticityOff ()
virtual void | SetIntegrator (vtkInitialValueProblemSolver *)
virtual vtkInitialValueProblemSolver * | GetIntegrator ()

Static Public Methods

vtkStreamer * | New ()

Protected Methods

vtkStreamer ()
~vtkStreamer ()
void | Integrate ()
void | ComputeVorticity ()
void | InitializeThreadedIntegrate ()
virtual int | GetNumberOfStreamers ()
vtkStreamArray * GetStreamers ()

Static Protected Methods

VTK_THREAD_RETURN_TYPE | ThreadedIntegrate (void *arg)

Protected Attributes

int | StartFrom
vtkIdType StartCell
int | StartSubId
float | StartPCoords [3]
float | StartPosition [3]
vtkStreamArray * Streamers
vtkIdType NumberOfStreamers
float | MaximumPropagationTime
int | IntegrationDirection
float | IntegrationStepLength
int | Vorticity
float | TerminalSpeed
int | SpeedScalars
int | OrientationScalars
vtkInitialValueProblemSolver * Integrator
float | SavePointInterval
vtkMultiThreader * Threader
int | NumberOfThreads

Detailed Description

abstract object implements integration of massless particle through vector field.

Date:
2002/01/22 15:29:48
Revision:
1.53

vtkStreamer is a filter that integrates a massless particle through a vector field. The integration is performed using second order Runge-Kutta method. vtkStreamer often serves as a base class for other classes that perform numerical integration through a vector field (e.g., vtkStreamLine).

Note that vtkStreamer can integrate both forward and backward in time, or in both directions. The length of the streamer is controlled by specifying an elapsed time. (The elapsed time is the time each particle travels.) Otherwise, the integration terminates after exiting the dataset or if the particle speed is reduced to a value less than the terminal speed.

vtkStreamer integrates through any type of dataset. As a result, if the dataset contains 2D cells such as polygons or triangles, the integration is constrained to lie on the surface defined by the 2D cells.

The starting point of streamers may be defined in three different ways. Starting from global x-y-z "position" allows you to start a single streamer at a specified x-y-z coordinate. Starting from "location" allows you to start at a specified cell, subId, and parametric coordinate. Finally, you may specify a source object to start multiple streamers. If you start streamers using a source object, for each point in the source that is inside the dataset a streamer is created.

vtkStreamer implements the integration process in the Integrate() method. Because vtkStreamer does not implement the Execute() method that its superclass (i.e., Filter) requires, it is an abstract class. Its subclasses implement the execute method and use the Integrate() method, and then build their own representation of the integration path (i.e., lines, dashed lines, points, etc.).

See also:
vtkStreamLine vtkDashedStreamLine vtkStreamPoints
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (37%)
  • Geveci, Berk (29%)
  • Avila, Lisa (13%)
  • Lorensen, Bill (7%)

Definition at line 127 of file vtkStreamer.h.

Constructor & Destructor Documentation

vtkStreamer::vtkStreamer ( ) [protected]

vtkStreamer::~vtkStreamer ( ) [protected]

Member Function Documentation

vtkStreamer::vtkTypeRevisionMacro | ( | vtkStreamer | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

Reimplemented in vtkDashedStreamLine, vtkStreamLine, and vtkStreamPoints.

void vtkStreamer::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkDashedStreamLine, vtkStreamLine, and vtkStreamPoints.

vtkStreamer* vtkStreamer::New ( ) [static]

Construct object to start from position (0,0,0); integrate forward; terminal speed 0.0; vorticity computation off; integrations step length 0.2; and maximum propagation time 100.0.

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkDashedStreamLine, vtkStreamLine, and vtkStreamPoints.

void vtkStreamer::SetStartLocation | ( | vtkIdType | cellId,
 |  | int | subId,
 |  | float | pcoords[3]
 | ) |

Specify the start of the streamline in the cell coordinate system. That is, cellId and subId (if composite cell), and parametric coordinates.

void vtkStreamer::SetStartLocation | ( | vtkIdType | cellId,
 |  | int | subId,
 |  | float | r,
 |  | float | s,
 |  | float | t
 | ) |

Specify the start of the streamline in the cell coordinate system. That is, cellId and subId (if composite cell), and parametric coordinates.

vtkIdType vtkStreamer::GetStartLocation | ( | int & | subId,
 |  | float | pcoords[3]
 | ) |

Get the starting location of the streamline in the cell coordinate system.

void vtkStreamer::SetStartPosition ( float x[3] )

Specify the start of the streamline in the global coordinate system. Search must be performed to find initial cell to start integration from.

void vtkStreamer::SetStartPosition | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |

Specify the start of the streamline in the global coordinate system. Search must be performed to find initial cell to start integration from.

float* vtkStreamer::GetStartPosition ( )

Get the start position in global x-y-z coordinates.

void vtkStreamer::SetSource ( vtkDataSet * source )

Specify the source object used to generate starting points.

vtkDataSet* vtkStreamer::GetSource ( )

Specify the source object used to generate starting points.

virtual void vtkStreamer::SetMaximumPropagationTime ( float ) [virtual]

Specify the maximum length of the Streamer expressed in elapsed time.

virtual float vtkStreamer::GetMaximumPropagationTime ( ) [virtual]

Specify the maximum length of the Streamer expressed in elapsed time.

virtual void vtkStreamer::SetIntegrationDirection ( int ) [virtual]

Specify the direction in which to integrate the Streamer.

virtual int vtkStreamer::GetIntegrationDirection ( ) [virtual]

Specify the direction in which to integrate the Streamer.

void vtkStreamer::SetIntegrationDirectionToForward ( ) [inline]

Specify the direction in which to integrate the Streamer.

Definition at line 185 of file vtkStreamer.h.

void vtkStreamer::SetIntegrationDirectionToBackward ( ) [inline]

Specify the direction in which to integrate the Streamer.

Definition at line 187 of file vtkStreamer.h.

void vtkStreamer::SetIntegrationDirectionToIntegrateBothDirections ( ) [inline]

Specify the direction in which to integrate the Streamer.

Definition at line 189 of file vtkStreamer.h.

const char * vtkStreamer::GetIntegrationDirectionAsString ( void ) [inline]

Return the integration direction as a character string.

Definition at line 327 of file vtkStreamer.h.

virtual void vtkStreamer::SetIntegrationStepLength ( float ) [virtual]

Specify a nominal integration step size (expressed as a fraction of the size of each cell). This value can be larger than 1.

virtual float vtkStreamer::GetIntegrationStepLength ( ) [virtual]

Specify a nominal integration step size (expressed as a fraction of the size of each cell). This value can be larger than 1.

virtual void vtkStreamer::SetSpeedScalars ( int ) [virtual]

Turn on/off the creation of scalar data from velocity magnitude. If off, and input dataset has scalars, input dataset scalars are used.

virtual int vtkStreamer::GetSpeedScalars ( ) [virtual]

Turn on/off the creation of scalar data from velocity magnitude. If off, and input dataset has scalars, input dataset scalars are used.

virtual void vtkStreamer::SpeedScalarsOn ( ) [virtual]

Turn on/off the creation of scalar data from velocity magnitude. If off, and input dataset has scalars, input dataset scalars are used.

virtual void vtkStreamer::SpeedScalarsOff ( ) [virtual]

Turn on/off the creation of scalar data from velocity magnitude. If off, and input dataset has scalars, input dataset scalars are used.

virtual void vtkStreamer::SetOrientationScalars ( int ) [virtual]

Turn on/off the creation of scalar data from vorticity information. The scalar information is currently the orientation value "theta" used in rotating stream tubes. If off, and input dataset has scalars, then input dataset scalars are used, unless SpeedScalars is also on. SpeedScalars takes precedence over OrientationScalars.

virtual int vtkStreamer::GetOrientationScalars ( ) [virtual]

Turn on/off the creation of scalar data from vorticity information. The scalar information is currently the orientation value "theta" used in rotating stream tubes. If off, and input dataset has scalars, then input dataset scalars are used, unless SpeedScalars is also on. SpeedScalars takes precedence over OrientationScalars.

virtual void vtkStreamer::OrientationScalarsOn ( ) [virtual]

Turn on/off the creation of scalar data from vorticity information. The scalar information is currently the orientation value "theta" used in rotating stream tubes. If off, and input dataset has scalars, then input dataset scalars are used, unless SpeedScalars is also on. SpeedScalars takes precedence over OrientationScalars.

virtual void vtkStreamer::OrientationScalarsOff ( ) [virtual]

Turn on/off the creation of scalar data from vorticity information. The scalar information is currently the orientation value "theta" used in rotating stream tubes. If off, and input dataset has scalars, then input dataset scalars are used, unless SpeedScalars is also on. SpeedScalars takes precedence over OrientationScalars.

virtual void vtkStreamer::SetTerminalSpeed ( float ) [virtual]

Set/get terminal speed (i.e., speed is velocity magnitude). Terminal speed is speed at which streamer will terminate propagation.

virtual float vtkStreamer::GetTerminalSpeed ( ) [virtual]

Set/get terminal speed (i.e., speed is velocity magnitude). Terminal speed is speed at which streamer will terminate propagation.

virtual void vtkStreamer::SetVorticity ( int ) [virtual]

Turn on/off the computation of vorticity. Vorticity is an indication of the rotation of the flow. In combination with vtkStreamLine and vtkTubeFilter can be used to create rotated tubes. If vorticity is turned on, in the output, the velocity vectors are replaced by vorticity vectors.

virtual int vtkStreamer::GetVorticity ( ) [virtual]

Turn on/off the computation of vorticity. Vorticity is an indication of the rotation of the flow. In combination with vtkStreamLine and vtkTubeFilter can be used to create rotated tubes. If vorticity is turned on, in the output, the velocity vectors are replaced by vorticity vectors.

virtual void vtkStreamer::VorticityOn ( ) [virtual]

Turn on/off the computation of vorticity. Vorticity is an indication of the rotation of the flow. In combination with vtkStreamLine and vtkTubeFilter can be used to create rotated tubes. If vorticity is turned on, in the output, the velocity vectors are replaced by vorticity vectors.

virtual void vtkStreamer::VorticityOff ( ) [virtual]

Turn on/off the computation of vorticity. Vorticity is an indication of the rotation of the flow. In combination with vtkStreamLine and vtkTubeFilter can be used to create rotated tubes. If vorticity is turned on, in the output, the velocity vectors are replaced by vorticity vectors.

virtual void vtkStreamer::SetNumberOfThreads ( int ) [virtual]

virtual int vtkStreamer::GetNumberOfThreads ( ) [virtual]

virtual void vtkStreamer::SetSavePointInterval ( float ) [virtual]

virtual float vtkStreamer::GetSavePointInterval ( ) [virtual]

virtual void vtkStreamer::SetIntegrator ( vtkInitialValueProblemSolver * ) [virtual]

Set/get the integrator type to be used in the stream line calculation. The object passed is not actually used but is cloned with MakeObject by each thread/process in the process of integration (prototype pattern). The default is 2nd order Runge Kutta.

virtual vtkInitialValueProblemSolver* vtkStreamer::GetIntegrator ( ) [virtual]

Set/get the integrator type to be used in the stream line calculation. The object passed is not actually used but is cloned with MakeObject by each thread/process in the process of integration (prototype pattern). The default is 2nd order Runge Kutta.

void vtkStreamer::Integrate ( ) [protected]

void vtkStreamer::ComputeVorticity ( ) [protected]

VTK_THREAD_RETURN_TYPE vtkStreamer::ThreadedIntegrate ( void * arg ) [static, protected]

virtual int vtkStreamer::GetNumberOfStreamers ( ) [protected, virtual]

These methods were added to allow access to these variables from the threads.

vtkStreamArray* vtkStreamer::GetStreamers ( ) [inline, protected]

These methods were added to allow access to these variables from the threads.

Definition at line 314 of file vtkStreamer.h.

void vtkStreamer::InitializeThreadedIntegrate ( ) [protected]

Member Data Documentation

int vtkStreamer::StartFrom [protected]

Definition at line 265 of file vtkStreamer.h.

vtkIdType vtkStreamer::StartCell [protected]

Definition at line 268 of file vtkStreamer.h.

int vtkStreamer::StartSubId [protected]

Definition at line 269 of file vtkStreamer.h.

float vtkStreamer::StartPCoords[3] [protected]

Definition at line 270 of file vtkStreamer.h.

float vtkStreamer::StartPosition[3] [protected]

Definition at line 273 of file vtkStreamer.h.

vtkStreamArray* vtkStreamer::Streamers [protected]

Definition at line 276 of file vtkStreamer.h.

vtkIdType vtkStreamer::NumberOfStreamers [protected]

Definition at line 277 of file vtkStreamer.h.

float vtkStreamer::MaximumPropagationTime [protected]

Definition at line 280 of file vtkStreamer.h.

int vtkStreamer::IntegrationDirection [protected]

Definition at line 283 of file vtkStreamer.h.

float vtkStreamer::IntegrationStepLength [protected]

Definition at line 286 of file vtkStreamer.h.

int vtkStreamer::Vorticity [protected]

Definition at line 289 of file vtkStreamer.h.

float vtkStreamer::TerminalSpeed [protected]

Definition at line 292 of file vtkStreamer.h.

int vtkStreamer::SpeedScalars [protected]

Definition at line 295 of file vtkStreamer.h.

int vtkStreamer::OrientationScalars [protected]

Definition at line 298 of file vtkStreamer.h.

vtkInitialValueProblemSolver* vtkStreamer::Integrator [protected]

Definition at line 301 of file vtkStreamer.h.

float vtkStreamer::SavePointInterval [protected]

Definition at line 306 of file vtkStreamer.h.

vtkMultiThreader* vtkStreamer::Threader [protected]

Definition at line 318 of file vtkStreamer.h.

int vtkStreamer::NumberOfThreads [protected]

Definition at line 319 of file vtkStreamer.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStreamer.h
Generated on Mon Mar 25 01:31:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamLine Class Reference

generate streamline in arbitrary dataset. More...

#include <vtkStreamLine.h>

Inheritance diagram for vtkStreamLine:

[legend]
Collaboration diagram for vtkStreamLine:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStreamLine, vtkStreamer)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetStepLength (float)
virtual float | GetStepLength ()

Static Public Methods

vtkStreamLine * | New ()

Protected Methods

vtkStreamLine ()
~vtkStreamLine ()
void | Execute ()

Protected Attributes

float | StepLength

Detailed Description

generate streamline in arbitrary dataset.

Date:
2002/01/22 15:29:47
Revision:
1.38

vtkStreamLine is a filter that generates a streamline for an arbitrary dataset. A streamline is a line that is everywhere tangent to the vector field. Scalar values also are calculated along the streamline and can be used to color the line. Streamlines are calculated by integrating from a starting point through the vector field. Integration can be performed forward in time (see where the line goes), backward in time (see where the line came from), or in both directions. It also is possible to compute vorticity along the streamline. Vorticity is the projection (i.e., dot product) of the flow rotation on the velocity vector, i.e., the rotation of flow around the streamline.

vtkStreamLine defines the instance variable StepLength. This parameter controls the time increment used to generate individual points along the streamline(s). Smaller values result in more line primitives but smoother streamlines. The StepLength instance variable is defined in terms of time (i.e., the distance that the particle travels in the specified time period). Thus, the line segments will be smaller in areas of low velocity and larger in regions of high velocity. (NOTE: This is different than the IntegrationStepLength defined by the superclass vtkStreamer. IntegrationStepLength is used to control integration step size and is expressed as a fraction of the cell length.) The StepLength instance variable is important because subclasses of vtkStreamLine (e.g., vtkDashedStreamLine) depend on this value to build their representation.

See also:
vtkStreamer vtkDashedStreamLine vtkStreamPoints
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Geveci, Berk (14%)
Examples:
vtkStreamLine (Examples)
Tests:
vtkStreamLine (Tests)

Definition at line 68 of file vtkStreamLine.h.

Constructor & Destructor Documentation

vtkStreamLine::vtkStreamLine ( ) [protected]

vtkStreamLine::~vtkStreamLine ( ) [inline, protected]

Definition at line 87 of file vtkStreamLine.h.

Member Function Documentation

vtkStreamLine::vtkTypeRevisionMacro | ( | vtkStreamLine | ,
 |  | vtkStreamer |
 | ) |

Reimplemented from vtkStreamer.

Reimplemented in vtkDashedStreamLine.

void vtkStreamLine::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkStreamer.

Reimplemented in vtkDashedStreamLine.

vtkStreamLine* vtkStreamLine::New ( ) [static]

Construct object with step size set to 1.0.

Reimplemented from vtkStreamer.

Reimplemented in vtkDashedStreamLine.

virtual void vtkStreamLine::SetStepLength ( float ) [virtual]

Specify the length of a line segment. The length is expressed in terms of elapsed time. Smaller values result in smoother appearing streamlines, but greater numbers of line primitives.

virtual float vtkStreamLine::GetStepLength ( ) [virtual]

Specify the length of a line segment. The length is expressed in terms of elapsed time. Smaller values result in smoother appearing streamlines, but greater numbers of line primitives.

void vtkStreamLine::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Reimplemented in vtkDashedStreamLine.

Member Data Documentation

float vtkStreamLine::StepLength [protected]

Definition at line 93 of file vtkStreamLine.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStreamLine.h
Generated on Mon Mar 25 01:31:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStreamPoints Class Reference

generate points along streamer separated by constant time increment. More...

#include <vtkStreamPoints.h>

Inheritance diagram for vtkStreamPoints:

[legend]
Collaboration diagram for vtkStreamPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStreamPoints, vtkStreamer)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetTimeIncrement (float)
virtual float | GetTimeIncrement ()

Static Public Methods

vtkStreamPoints * | New ()

Protected Methods

vtkStreamPoints ()
~vtkStreamPoints ()
void | Execute ()

Protected Attributes

float | TimeIncrement

Detailed Description

generate points along streamer separated by constant time increment.

Date:
2002/01/22 15:29:47
Revision:
1.32

vtkStreamPoints is a filter that generates points along a streamer. The points are separated by a constant time increment. The resulting visual effect (especially when coupled with vtkGlyph3D) is an indication of particle speed.

See also:
vtkStreamer vtkStreamLine vtkDashedStreamLine
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (61%)
  • Geveci, Berk (12%)
  • Martin, Ken (8%)
  • Law, Charles (7%)
Tests:
vtkStreamPoints (Tests)

Definition at line 48 of file vtkStreamPoints.h.

Constructor & Destructor Documentation

vtkStreamPoints::vtkStreamPoints ( ) [protected]

vtkStreamPoints::~vtkStreamPoints ( ) [inline, protected]

Definition at line 65 of file vtkStreamPoints.h.

Member Function Documentation

vtkStreamPoints::vtkTypeRevisionMacro | ( | vtkStreamPoints | ,
 |  | vtkStreamer |
 | ) |

Reimplemented from vtkStreamer.

void vtkStreamPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkStreamer.

vtkStreamPoints* vtkStreamPoints::New ( ) [static]

Construct object with time increment set to 1.0.

Reimplemented from vtkStreamer.

virtual void vtkStreamPoints::SetTimeIncrement ( float ) [virtual]

Specify the separation of points in terms of absolute time.

virtual float vtkStreamPoints::GetTimeIncrement ( ) [virtual]

Specify the separation of points in terms of absolute time.

void vtkStreamPoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkStreamPoints::TimeIncrement [protected]

Definition at line 71 of file vtkStreamPoints.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStreamPoints.h
Generated on Mon Mar 25 01:31:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStripper Class Reference

create triangle strips and/or poly-lines. More...

#include <vtkStripper.h>

Inheritance diagram for vtkStripper:

[legend]
Collaboration diagram for vtkStripper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStripper, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetMaximumLength (int)
virtual int | GetMaximumLength ()

Static Public Methods

vtkStripper * | New ()

Protected Methods

vtkStripper ()
~vtkStripper ()
void | Execute ()

Protected Attributes

int | MaximumLength

Detailed Description

create triangle strips and/or poly-lines.

Date:
2002/03/02 23:21:23
Revision:
1.39

vtkStripper is a filter that generates triangle strips and/or poly-lines from input polygons, triangle strips, and lines. Input polygons are assembled into triangle strips only if they are triangles; other types of polygons are passed through to the output and not stripped. (Use vtkTriangleFilter to triangulate non-triangular polygons prior to running this filter if you need to strip all the data.) The filter will pass through (to the output) vertices if they are present in the input polydata.

The ivar MaximumLength can be used to control the maximum allowable triangle strip and poly-line length.

Warning:
If triangle strips or poly-lines exist in the input data they will be passed through to the output data. This filter will only construct triangle strips if triangle polygons are available; and will only construct poly-lines if lines are available.
See also:
vtkTriangleFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (77%)
  • Martin, Ken (8%)
Examples:
vtkStripper (Examples)
Tests:
vtkStripper (Tests)

Definition at line 63 of file vtkStripper.h.

Constructor & Destructor Documentation

vtkStripper::vtkStripper ( ) [protected]

vtkStripper::~vtkStripper ( ) [inline, protected]

Definition at line 81 of file vtkStripper.h.

Member Function Documentation

vtkStripper::vtkTypeRevisionMacro | ( | vtkStripper | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkStripper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkStripper* vtkStripper::New ( ) [static]

Construct object with MaximumLength set to 1000.

Reimplemented from vtkPolyDataSource.

virtual void vtkStripper::SetMaximumLength ( int ) [virtual]

Specify the maximum number of triangles in a triangle strip, and/or the maximum number of lines in a poly-line.

virtual int vtkStripper::GetMaximumLength ( ) [virtual]

Specify the maximum number of triangles in a triangle strip, and/or the maximum number of lines in a poly-line.

void vtkStripper::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkStripper::MaximumLength [protected]

Definition at line 86 of file vtkStripper.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStripper.h
Generated on Mon Mar 25 01:31:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredData Class Reference

abstract class for topologically regular data. More...

#include <vtkStructuredData.h>

Inheritance diagram for vtkStructuredData:

[legend]
Collaboration diagram for vtkStructuredData:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredData, vtkObject)

Static Public Methods

vtkStructuredData * | New ()
int | GetDataDimension (int dataDescription)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds, int dim[3])
int | SetDimensions (int inDim[3], int dim[3])
int | SetExtent (int inExt[6], int ext[6])
void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds, int dataDescription, int dim[3])
void | GetCellNeigbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds, int dim[3])
vtkIdType | ComputePointId (int dim[3], int ijk[3])
vtkIdType | ComputeCellId (int dim[3], int ijk[3])

Protected Methods

vtkStructuredData ()
~vtkStructuredData ()

Detailed Description

abstract class for topologically regular data.

Date:
2002/01/22 15:26:21
Revision:
1.55

vtkStructuredData is an abstract class that specifies an interface for topologically regular data. Regular data is data that can be accessed in rectangular fashion using an i-j-k index. A finite difference grid, a volume, or a pixmap are all considered regular.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (81%)
  • Martin, Ken (5%)

Definition at line 52 of file vtkStructuredData.h.

Constructor & Destructor Documentation

vtkStructuredData::vtkStructuredData ( ) [inline, protected]

Definition at line 102 of file vtkStructuredData.h.

vtkStructuredData::~vtkStructuredData ( ) [inline, protected]

Definition at line 103 of file vtkStructuredData.h.

Member Function Documentation

vtkStructuredData* vtkStructuredData::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkStructuredData::vtkTypeRevisionMacro | ( | vtkStructuredData | ,
 |  | vtkObject |
 | ) |

int vtkStructuredData::SetDimensions | ( | int | inDim[3],
 |  | int | dim[3]
 | ) | [static]

Specify the dimensions of a regular, rectangular dataset. The input is the new dimensions (inDim) and the current dimensions (dim). The function returns the dimension of the dataset (0-3D). If the dimensions are improperly specified a -1 is returned. If the dimensions are unchanged, a value of 100 is returned.

int vtkStructuredData::SetExtent | ( | int | inExt[6],
 |  | int | ext[6]
 | ) | [static]

Specify the dimensions of a regular, rectangular dataset. The input is the new dimensions (inDim) and the current dimensions (dim). The function returns the dimension of the dataset (0-3D). If the dimensions are improperly specified a -1 is returned. If the dimensions are unchanged, a value of 100 is returned.

int vtkStructuredData::GetDataDimension ( int dataDescription ) [static]

Return the topological dimension of the data (e.g., 0, 1, 2, or 3D).

Referenced by vtkStructuredGrid::GetDataDimension(), vtkRectilinearGrid::GetDataDimension(), and vtkImageData::GetDataDimension().

void vtkStructuredData::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | int | dataDescription,
 |  | int | dim[3]
 | ) | [static]

Get the points defining a cell. (See vtkDataSet for more info.)

Referenced by vtkRectilinearGrid::GetCellPoints(), and vtkImageData::GetCellPoints().

void vtkStructuredData::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds,
 |  | int | dim[3]
 | ) | [static]

Get the cells using a point. (See vtkDataSet for more info.)

Referenced by vtkStructuredGrid::GetPointCells(), vtkRectilinearGrid::GetPointCells(), and vtkImageData::GetPointCells().

void vtkStructuredData::GetCellNeigbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds,
 |  | int | dim[3]
 | ) | [static]

Get the cells using the points ptIds, exclusive of the cell cellId. (See vtkDataSet for more info.)

vtkIdType vtkStructuredData::ComputePointId | ( | int | dim[3],
 |  | int | ijk[3]
 | ) | [inline, static]

Given a location in structured coordinates (i-j-k), and the dimensions of the structured dataset, return the point id.

Definition at line 90 of file vtkStructuredData.h.

Referenced by vtkRectilinearGrid::ComputePointId(), and vtkImageData::ComputePointId().

vtkIdType vtkStructuredData::ComputeCellId | ( | int | dim[3],
 |  | int | ijk[3]
 | ) | [inline, static]

Given a location in structured coordinates (i-j-k), and the dimensions of the structured dataset, return the cell id.

Definition at line 97 of file vtkStructuredData.h.

Referenced by vtkRectilinearGrid::ComputeCellId(), and vtkImageData::ComputeCellId().

The documentation for this class was generated from the following file:
  • Common/vtkStructuredData.h
Generated on Mon Mar 25 01:31:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGrid Class Reference

topologically regular array of data. More...

#include <vtkStructuredGrid.h>

Inheritance diagram for vtkStructuredGrid:

[legend]
Collaboration diagram for vtkStructuredGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGrid, vtkPointSet)
void | PrintSelf (ostream &os, vtkIndent indent)
int | GetDataObjectType ()
vtkDataObject * MakeObject ()
void | CopyStructure (vtkDataSet *ds)
int | GetDataDimension ()
void | SetPointVisibility (vtkUnsignedCharArray *pointVisibility)
unsigned char | IsCellVisible (vtkIdType cellId)
unsigned long | GetActualMemorySize ()
vtkIdType GetNumberOfPoints ()
float * | GetPoint (vtkIdType ptId)
void | GetPoint (vtkIdType ptId, float p[3])
vtkCell * | GetCell (vtkIdType cellId)
void | GetCell (vtkIdType cellId, vtkGenericCell *cell)
void | GetCellBounds (vtkIdType cellId, float bounds[6])
int | GetCellType (vtkIdType cellId)
vtkIdType GetNumberOfCells ()
void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)
void | Initialize ()
int | GetMaxCellSize ()
void | GetCellNeighbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds)
virtual void | GetScalarRange (float range[2])
float * | GetScalarRange ()
void | SetDimensions (int i, int j, int k)
void | SetDimensions (int dim[3])
virtual int * | GetDimensions ()
virtual void | GetDimensions (int dim[3])
void | SetBlanking (int blanking)
int | GetBlanking ()
void | BlankingOn ()
void | BlankingOff ()
void | BlankPoint (vtkIdType ptId)
void | UnBlankPoint (vtkIdType ptId)
vtkUnsignedCharArray * GetPointVisibility ()
unsigned char | IsPointVisible (vtkIdType ptId)
void | SetUpdateExtent (int piece, int numPieces, int ghostLevel)
void | SetUpdateExtent (int piece, int numPieces)
void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
void | SetUpdateExtent (int ext[6])
void | SetExtent (int extent[6])
void | SetExtent (int x1, int x2, int y1, int y2, int z1, int z2)
virtual int * | GetExtent ()
virtual void | GetExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetExtent (int[6])
void | ShallowCopy (vtkDataObject *src)
void | DeepCopy (vtkDataObject *src)

Static Public Methods

vtkStructuredGrid * | New ()

Protected Methods

vtkStructuredGrid ()
~vtkStructuredGrid ()
int | GetExtentType ()
virtual void | Crop ()
void | AllocatePointVisibility ()

Protected Attributes

vtkVertex * Vertex
vtkLine * Line
vtkQuad * Quad
vtkHexahedron * Hexahedron
vtkEmptyCell * EmptyCell
int | Dimensions [3]
int | DataDescription
int | Blanking
vtkUnsignedCharArray * PointVisibility

Detailed Description

topologically regular array of data.

Date:
2002/01/22 15:26:22
Revision:
1.90

vtkStructuredGrid is a data object that is a concrete implementation of vtkDataSet. vtkStructuredGrid represents a geometric structure that is a topologically regular array of points. The topology is that of a cube that has been subdivided into a regular array of smaller cubes. Each point/cell can be addressed with i-j-k indices. Examples include finite difference grids.

A unusual feature of vtkStructuredGrid is the ability to blank, or "turn-off" points and cells in the dataset. This is controlled by defining a "blanking array" whose values (0,1) specify whether a point should be blanked or not.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Law, Charles (30%)
  • Miller, Jim (7%)
Examples:
vtkStructuredGrid (Examples)
Tests:
vtkStructuredGrid (Tests)

Definition at line 62 of file vtkStructuredGrid.h.

Constructor & Destructor Documentation

vtkStructuredGrid::vtkStructuredGrid ( ) [protected]

vtkStructuredGrid::~vtkStructuredGrid ( ) [protected]

Member Function Documentation

vtkStructuredGrid* vtkStructuredGrid::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

Referenced by MakeObject().

vtkStructuredGrid::vtkTypeRevisionMacro | ( | vtkStructuredGrid | ,
 |  | vtkPointSet |
 | ) |

Reimplemented from vtkPointSet.

void vtkStructuredGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPointSet.

int vtkStructuredGrid::GetDataObjectType ( ) [inline, virtual]

Return what type of dataset this is.

Reimplemented from vtkDataSet.

Definition at line 71 of file vtkStructuredGrid.h.

vtkDataObject* vtkStructuredGrid::MakeObject ( ) [inline, virtual]

Create a similar type object

Reimplemented from vtkDataObject.

Definition at line 74 of file vtkStructuredGrid.h.

void vtkStructuredGrid::CopyStructure ( vtkDataSet * ds ) [virtual]

Copy the geometric and topological structure of an input poly data object.

Reimplemented from vtkPointSet.

vtkIdType vtkStructuredGrid::GetNumberOfPoints ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkPointSet.

Definition at line 82 of file vtkStructuredGrid.h.

float* vtkStructuredGrid::GetPoint ( vtkIdType ptId ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkPointSet.

Definition at line 83 of file vtkStructuredGrid.h.

void vtkStructuredGrid::GetPoint | ( | vtkIdType | ptId,
 |  | float | p[3]
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkPointSet.

Definition at line 84 of file vtkStructuredGrid.h.

vtkCell* vtkStructuredGrid::GetCell ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkStructuredGrid::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkStructuredGrid::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkStructuredGrid::GetCellType ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

vtkIdType vtkStructuredGrid::GetNumberOfCells ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 232 of file vtkStructuredGrid.h.

void vtkStructuredGrid::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkStructuredGrid::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 92 of file vtkStructuredGrid.h.

void vtkStructuredGrid::Initialize ( ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkPointSet.

int vtkStructuredGrid::GetMaxCellSize ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 97 of file vtkStructuredGrid.h.

void vtkStructuredGrid::GetCellNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

virtual void vtkStructuredGrid::GetScalarRange ( float range[2] ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

float* vtkStructuredGrid::GetScalarRange ( ) [inline]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 101 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

following methods are specific to structured grid

void vtkStructuredGrid::SetDimensions ( int dim[3] )

following methods are specific to structured grid

virtual int* vtkStructuredGrid::GetDimensions ( ) [virtual]

Get dimensions of this structured points dataset.

Referenced by GetNumberOfCells().

virtual void vtkStructuredGrid::GetDimensions ( int dim[3] ) [virtual]

Get dimensions of this structured points dataset.

int vtkStructuredGrid::GetDataDimension ( ) [inline]

Return the dimensionality of the data.

Definition at line 254 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetBlanking ( int blanking )

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

int vtkStructuredGrid::GetBlanking ( ) [inline]

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

Definition at line 123 of file vtkStructuredGrid.h.

void vtkStructuredGrid::BlankingOn ( )

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

void vtkStructuredGrid::BlankingOff ( )

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

void vtkStructuredGrid::BlankPoint ( vtkIdType ptId )

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

void vtkStructuredGrid::UnBlankPoint ( vtkIdType ptId )

Methods for supporting blanking of cells. Blanking turns on or off points in the structured grid, and hence the cells connected to them.

vtkUnsignedCharArray* vtkStructuredGrid::GetPointVisibility ( ) [inline]

Get the array that defines the blanking (visibility) of each point.

Definition at line 132 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetPointVisibility ( vtkUnsignedCharArray * pointVisibility )

Set an array that defines the (blanking) visibility of the points in the grid. Make sure that length of the visibility array matches the number of points in the grid.

unsigned char vtkStructuredGrid::IsPointVisible ( vtkIdType ptId ) [inline]

Return non-zero value if specified point is visible. Use this method only if blanking has been enabled (with BlankingOn()).

Definition at line 144 of file vtkStructuredGrid.h.

unsigned char vtkStructuredGrid::IsCellVisible ( vtkIdType cellId )

Return non-zero value if specified point is visible. Use this method only if blanking has been enabled (with BlankingOn()).

void vtkStructuredGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel
 | ) |

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

void vtkStructuredGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

Required for the lowest common denominator for setting the UpdateExtent (i.e. vtkDataSetToStructuredPointsFilter). This assumes that WholeExtent is valid (UpdateInformation has been called).

Reimplemented from vtkDataObject.

Definition at line 157 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [inline, virtual]

Call superclass method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 163 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetUpdateExtent ( int ext[6] ) [inline, virtual]

Call superclass method to avoid hiding

Reimplemented from vtkDataObject.

Definition at line 165 of file vtkStructuredGrid.h.

void vtkStructuredGrid::SetExtent ( int extent[6] )

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

void vtkStructuredGrid::SetExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) |

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual int* vtkStructuredGrid::GetExtent ( ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkStructuredGrid::GetExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

virtual void vtkStructuredGrid::GetExtent ( int [6] ) [virtual]

Different ways to set the extent of the data array. The extent should be set before the "Scalars" are set or allocated. The Extent is stored in the order (X, Y, Z).

unsigned long vtkStructuredGrid::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkPointSet.

void vtkStructuredGrid::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

void vtkStructuredGrid::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

int vtkStructuredGrid::GetExtentType ( ) [inline, protected, virtual]

Reimplemented from vtkDataObject.

Definition at line 203 of file vtkStructuredGrid.h.

virtual void vtkStructuredGrid::Crop ( ) [protected, virtual]

Reallocates and copies to set the Extent to the UpdateExtent. This is used internally when the exact extent is requested, and the source generated more than the update extent.

Reimplemented from vtkDataObject.

void vtkStructuredGrid::AllocatePointVisibility ( ) [protected]

Member Data Documentation

vtkVertex* vtkStructuredGrid::Vertex [protected]

Definition at line 196 of file vtkStructuredGrid.h.

vtkLine* vtkStructuredGrid::Line [protected]

Definition at line 197 of file vtkStructuredGrid.h.

vtkQuad* vtkStructuredGrid::Quad [protected]

Definition at line 198 of file vtkStructuredGrid.h.

vtkHexahedron* vtkStructuredGrid::Hexahedron [protected]

Definition at line 199 of file vtkStructuredGrid.h.

vtkEmptyCell* vtkStructuredGrid::EmptyCell [protected]

Definition at line 200 of file vtkStructuredGrid.h.

int vtkStructuredGrid::Dimensions[3] [protected]

Definition at line 210 of file vtkStructuredGrid.h.

int vtkStructuredGrid::DataDescription [protected]

Definition at line 211 of file vtkStructuredGrid.h.

int vtkStructuredGrid::Blanking [protected]

Definition at line 212 of file vtkStructuredGrid.h.

vtkUnsignedCharArray* vtkStructuredGrid::PointVisibility [protected]

Definition at line 213 of file vtkStructuredGrid.h.

The documentation for this class was generated from the following file:
  • Common/vtkStructuredGrid.h
Generated on Mon Mar 25 01:31:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridGeometryFilter Class Reference

extract geometry for structured grid. More...

#include <vtkStructuredGridGeometryFilter.h>

Inheritance diagram for vtkStructuredGridGeometryFilter:

[legend]
Collaboration diagram for vtkStructuredGridGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridGeometryFilter, vtkStructuredGridToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetExtent (int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
void | SetExtent (int extent[6])
virtual int * | GetExtent ()
virtual void | GetExtent (int data[6])

Static Public Methods

vtkStructuredGridGeometryFilter * | New ()

Protected Methods

vtkStructuredGridGeometryFilter ()
~vtkStructuredGridGeometryFilter ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Protected Attributes

int | Extent [6]

Detailed Description

extract geometry for structured grid.

Date:
2002/01/22 15:29:49
Revision:
1.43

vtkStructuredGridGeometryFilter is a filter that extracts geometry from a structured grid. By specifying appropriate i-j-k indices, it is possible to extract a point, a curve, a surface, or a "volume". Depending upon the type of data, the curve and surface may be curved or planar. (The volume is actually a (n x m x o) region of points.)

The extent specification is zero-offset. That is, the first k-plane in a 50x50x50 structured grid is given by (0,49, 0,49, 0,0).

The output of this filter is affected by the structured grid blanking. If blanking is on, and a blanking array defined, then those cells attached to blanked points are not output. (Blanking is a property of the input vtkStructuredGrid.)

Warning:
If you don't know the dimensions of the input dataset, you can use a large number to specify extent (the number will be clamped appropriately). For example, if the dataset dimensions are 50x50x50, and you want a the fifth k-plane, you can use the extents (0,100, 0,100, 4,4). The 100 will automatically be clamped to 49.
See also:
vtkGeometryFilter vtkExtractGrid vtkStructuredGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (63%)
  • Lorensen, Bill (13%)
  • Law, Charles (11%)
  • Martin, Ken (5%)
Examples:
vtkStructuredGridGeometryFilter (Examples)
Tests:
vtkStructuredGridGeometryFilter (Tests)

Definition at line 67 of file vtkStructuredGridGeometryFilter.h.

Constructor & Destructor Documentation

vtkStructuredGridGeometryFilter::vtkStructuredGridGeometryFilter ( ) [protected]

vtkStructuredGridGeometryFilter::~vtkStructuredGridGeometryFilter ( ) [inline, protected]

Definition at line 88 of file vtkStructuredGridGeometryFilter.h.

Member Function Documentation

vtkStructuredGridGeometryFilter* vtkStructuredGridGeometryFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkStructuredGridGeometryFilter::vtkTypeRevisionMacro | ( | vtkStructuredGridGeometryFilter | ,
 |  | vtkStructuredGridToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredGridToPolyDataFilter.

void vtkStructuredGridGeometryFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual int* vtkStructuredGridGeometryFilter::GetExtent ( ) [virtual]

Get the extent in topological coordinate range (imin,imax, jmin,jmax, kmin,kmax).

virtual void vtkStructuredGridGeometryFilter::GetExtent ( int data[6] ) [virtual]

Get the extent in topological coordinate range (imin,imax, jmin,jmax, kmin,kmax).

void vtkStructuredGridGeometryFilter::SetExtent | ( | int | iMin,
 |  | int | iMax,
 |  | int | jMin,
 |  | int | jMax,
 |  | int | kMin,
 |  | int | kMax
 | ) |

Specify (imin,imax, jmin,jmax, kmin,kmax) indices.

void vtkStructuredGridGeometryFilter::SetExtent ( int extent[6] )

Specify (imin,imax, jmin,jmax, kmin,kmax) indices in array form.

void vtkStructuredGridGeometryFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkStructuredGridGeometryFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

int vtkStructuredGridGeometryFilter::Extent[6] [protected]

Definition at line 92 of file vtkStructuredGridGeometryFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkStructuredGridGeometryFilter.h
Generated on Mon Mar 25 01:31:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridOutlineFilter Class Reference

create wireframe outline for structured grid. More...

#include <vtkStructuredGridOutlineFilter.h>

Inheritance diagram for vtkStructuredGridOutlineFilter:

[legend]
Collaboration diagram for vtkStructuredGridOutlineFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridOutlineFilter, vtkStructuredGridToPolyDataFilter)

Static Public Methods

vtkStructuredGridOutlineFilter * | New ()

Protected Methods

vtkStructuredGridOutlineFilter ()
~vtkStructuredGridOutlineFilter ()
void | Execute ()

Detailed Description

create wireframe outline for structured grid.

Date:
2002/01/22 15:29:49
Revision:
1.33

vtkStructuredGridOutlineFilter is a filter that generates a wireframe outline of a structured grid (vtkStructuredGrid). Structured data is topologically a cube, so the outline will have 12 "edges".

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Hoffman, Bill (43%)
  • Schroeder, Will (36%)
  • Henderson, Amy (7%)
  • Lorensen, Bill (6%)
  • Martin, Ken (5%)
Examples:
vtkStructuredGridOutlineFilter (Examples)
Tests:
vtkStructuredGridOutlineFilter (Tests)

Definition at line 48 of file vtkStructuredGridOutlineFilter.h.

Constructor & Destructor Documentation

vtkStructuredGridOutlineFilter::vtkStructuredGridOutlineFilter ( ) [inline, protected]

Definition at line 55 of file vtkStructuredGridOutlineFilter.h.

vtkStructuredGridOutlineFilter::~vtkStructuredGridOutlineFilter ( ) [inline, protected]

Definition at line 56 of file vtkStructuredGridOutlineFilter.h.

Member Function Documentation

vtkStructuredGridOutlineFilter* vtkStructuredGridOutlineFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkStructuredGridOutlineFilter::vtkTypeRevisionMacro | ( | vtkStructuredGridOutlineFilter | ,
 |  | vtkStructuredGridToPolyDataFilter |
 | ) |

Reimplemented from vtkStructuredGridToPolyDataFilter.

void vtkStructuredGridOutlineFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Graphics/vtkStructuredGridOutlineFilter.h
Generated on Mon Mar 25 01:31:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridReader Class Reference

read vtk structured grid data file. More...

#include <vtkStructuredGridReader.h>

Inheritance diagram for vtkStructuredGridReader:

[legend]
Collaboration diagram for vtkStructuredGridReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkStructuredGrid * GetOutput ()
vtkStructuredGrid * | GetOutput (int idx)
void | SetOutput (vtkStructuredGrid *output)

Static Public Methods

vtkStructuredGridReader * | New ()

Protected Methods

vtkStructuredGridReader ()
~vtkStructuredGridReader ()
void | ExecuteInformation ()
void | Execute ()

Detailed Description

read vtk structured grid data file.

Date:
2002/01/22 15:38:22
Revision:
1.45

vtkStructuredGridReader is a source object that reads ASCII or binary structured grid data files in vtk format. (see text for format details). The output of this reader is a single vtkStructuredGrid data object. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkStructuredGrid vtkDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Martin, Ken (10%)
  • Lorensen, Bill (10%)
  • Law, Charles (8%)
Examples:
vtkStructuredGridReader (Examples)
Tests:
vtkStructuredGridReader (Tests)

Definition at line 55 of file vtkStructuredGridReader.h.

Constructor & Destructor Documentation

vtkStructuredGridReader::vtkStructuredGridReader ( ) [protected]

vtkStructuredGridReader::~vtkStructuredGridReader ( ) [protected]

Member Function Documentation

vtkStructuredGridReader* vtkStructuredGridReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkStructuredGridReader::vtkTypeRevisionMacro | ( | vtkStructuredGridReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkStructuredGridReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkStructuredGrid* vtkStructuredGridReader::GetOutput ( )

Get the output of this reader.

vtkStructuredGrid* vtkStructuredGridReader::GetOutput ( int idx ) [inline]

Get the output of this reader.

Reimplemented from vtkSource.

Definition at line 65 of file vtkStructuredGridReader.h.

void vtkStructuredGridReader::SetOutput ( vtkStructuredGrid * output )

Get the output of this reader.

void vtkStructuredGridReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkStructuredGridReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • IO/vtkStructuredGridReader.h
Generated on Mon Mar 25 01:31:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridSource Class Reference

Abstract class whose subclasses generates structured grid data. More...

#include <vtkStructuredGridSource.h>

Inheritance diagram for vtkStructuredGridSource:

[legend]
Collaboration diagram for vtkStructuredGridSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridSource, vtkSource)
vtkStructuredGrid * GetOutput ()
vtkStructuredGrid * | GetOutput (int idx)
void | SetOutput (vtkStructuredGrid *output)

Static Public Methods

vtkStructuredGridSource * | New ()

Protected Methods

vtkStructuredGridSource ()
~vtkStructuredGridSource ()

Detailed Description

Abstract class whose subclasses generates structured grid data.

Date:
2002/01/22 15:28:13
Revision:
1.37

vtkStructuredGridSource is an abstract class whose subclasses generate structured grid data.

See also:
vtkStructuredGridReader vtkPLOT3DReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Martin, Ken (31%)

Definition at line 42 of file vtkStructuredGridSource.h.

Constructor & Destructor Documentation

vtkStructuredGridSource::vtkStructuredGridSource ( ) [protected]

vtkStructuredGridSource::~vtkStructuredGridSource ( ) [inline, protected]

Definition at line 58 of file vtkStructuredGridSource.h.

Member Function Documentation

vtkStructuredGridSource* vtkStructuredGridSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkExtractGrid, vtkPLOT3DReader, and vtkPOPReader.

vtkStructuredGridSource::vtkTypeRevisionMacro | ( | vtkStructuredGridSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToStructuredGridFilter, vtkStructuredGridToStructuredGridFilter, vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, vtkExtractGrid, vtkPLOT3DReader, and vtkPOPReader.

vtkStructuredGrid* vtkStructuredGridSource::GetOutput ( )

Get the output of this source.

vtkStructuredGrid* vtkStructuredGridSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Definition at line 51 of file vtkStructuredGridSource.h.

void vtkStructuredGridSource::SetOutput ( vtkStructuredGrid * output )

Get the output of this source.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredGridSource.h
Generated on Mon Mar 25 01:31:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkStructuredGridToPolyDataFilter.h>

Inheritance diagram for vtkStructuredGridToPolyDataFilter:

[legend]
Collaboration diagram for vtkStructuredGridToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridToPolyDataFilter, vtkPolyDataSource)
void SetInput (vtkStructuredGrid *input)
vtkStructuredGrid * GetInput ()

Protected Methods

vtkStructuredGridToPolyDataFilter ()
~vtkStructuredGridToPolyDataFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:13
Revision:
1.19

vtkStructuredGridToPolyDataFilter is a filter whose subclasses take as input structured grid datasets and generate polygonal data on output.

See also:
vtkStructuredGridGeometryFilter vtkStructuredGridOutlineFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (79%)
  • Lorensen, Bill (13%)
  • Martin, Ken (6%)

Definition at line 43 of file vtkStructuredGridToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkStructuredGridToPolyDataFilter::vtkStructuredGridToPolyDataFilter ( ) [inline, protected]

Definition at line 55 of file vtkStructuredGridToPolyDataFilter.h.

vtkStructuredGridToPolyDataFilter::~vtkStructuredGridToPolyDataFilter ( ) [inline, protected]

Definition at line 56 of file vtkStructuredGridToPolyDataFilter.h.

Member Function Documentation

vtkStructuredGridToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkStructuredGridToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkStructuredGridGeometryFilter, vtkStructuredGridOutlineFilter, and vtkGridSynchronizedTemplates3D.

void vtkStructuredGridToPolyDataFilter::SetInput ( vtkStructuredGrid * input )

Set / get the input Grid or filter.

vtkStructuredGrid* vtkStructuredGridToPolyDataFilter::GetInput ( )

Set / get the input Grid or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredGridToPolyDataFilter.h
Generated on Mon Mar 25 01:31:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridToStructuredGridFilter Class Reference

abstract filter class. More...

#include <vtkStructuredGridToStructuredGridFilter.h>

Inheritance diagram for vtkStructuredGridToStructuredGridFilter:

[legend]
Collaboration diagram for vtkStructuredGridToStructuredGridFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridToStructuredGridFilter, vtkStructuredGridSource)
void SetInput (vtkStructuredGrid *input)
vtkStructuredGrid * GetInput ()

Protected Methods

vtkStructuredGridToStructuredGridFilter ()
~vtkStructuredGridToStructuredGridFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:13
Revision:
1.28

vtkStructuredPointsToStructuredPointsFilter is an abstract filter class whose subclasses take on input a structured grid and generate a structured grid on output.

See also:
vtkExtractGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (79%)
  • Lorensen, Bill (11%)
  • Martin, Ken (7%)

Definition at line 43 of file vtkStructuredGridToStructuredGridFilter.h.

Constructor & Destructor Documentation

vtkStructuredGridToStructuredGridFilter::vtkStructuredGridToStructuredGridFilter ( ) [inline, protected]

Definition at line 55 of file vtkStructuredGridToStructuredGridFilter.h.

vtkStructuredGridToStructuredGridFilter::~vtkStructuredGridToStructuredGridFilter ( ) [inline, protected]

Definition at line 56 of file vtkStructuredGridToStructuredGridFilter.h.

Member Function Documentation

vtkStructuredGridToStructuredGridFilter::vtkTypeRevisionMacro | ( | vtkStructuredGridToStructuredGridFilter | ,
 |  | vtkStructuredGridSource |
 | ) |

Reimplemented from vtkStructuredGridSource.

Reimplemented in vtkBlankStructuredGrid, vtkBlankStructuredGridWithImage, and vtkExtractGrid.

void vtkStructuredGridToStructuredGridFilter::SetInput ( vtkStructuredGrid * input )

Set / get the input Grid or filter.

vtkStructuredGrid* vtkStructuredGridToStructuredGridFilter::GetInput ( )

Set / get the input Grid or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredGridToStructuredGridFilter.h
Generated on Mon Mar 25 01:31:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredGridWriter Class Reference

write vtk structured grid data file. More...

#include <vtkStructuredGridWriter.h>

Inheritance diagram for vtkStructuredGridWriter:

[legend]
Collaboration diagram for vtkStructuredGridWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredGridWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkStructuredGrid *input)
vtkStructuredGrid * GetInput ()

Static Public Methods

vtkStructuredGridWriter * | New ()

Protected Methods

vtkStructuredGridWriter ()
~vtkStructuredGridWriter ()
void | WriteData ()
void | WriteBlanking (ostream *fp, vtkStructuredGrid *ds)

Detailed Description

write vtk structured grid data file.

Date:
2002/01/22 15:38:23
Revision:
1.36

vtkStructuredGridWriter is a source object that writes ASCII or binary structured grid data files in vtk format. See text for format details.

Warning:
Binary files written on one system may not be readable on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (80%)
  • Martin, Ken (7%)
Tests:
vtkStructuredGridWriter (Tests)

Definition at line 45 of file vtkStructuredGridWriter.h.

Constructor & Destructor Documentation

vtkStructuredGridWriter::vtkStructuredGridWriter ( ) [inline, protected]

Definition at line 59 of file vtkStructuredGridWriter.h.

vtkStructuredGridWriter::~vtkStructuredGridWriter ( ) [inline, protected]

Definition at line 60 of file vtkStructuredGridWriter.h.

Member Function Documentation

vtkStructuredGridWriter* vtkStructuredGridWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

vtkStructuredGridWriter::vtkTypeRevisionMacro | ( | vtkStructuredGridWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

void vtkStructuredGridWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

void vtkStructuredGridWriter::SetInput ( vtkStructuredGrid * input )

Set / get the input data or filter.

vtkStructuredGrid* vtkStructuredGridWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkStructuredGridWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

void vtkStructuredGridWriter::WriteBlanking | ( | ostream * | fp,
 |  | vtkStructuredGrid * | ds
 | ) | [protected]

The documentation for this class was generated from the following file:
  • IO/vtkStructuredGridWriter.h
Generated on Mon Mar 25 01:31:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPoints Class Reference

A subclass of ImageData. More...

#include <vtkStructuredPoints.h>

Inheritance diagram for vtkStructuredPoints:

[legend]
Collaboration diagram for vtkStructuredPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPoints, vtkImageData)
vtkDataObject * MakeObject ()
int | GetDataObjectType ()

Static Public Methods

vtkStructuredPoints * | New ()

Protected Methods

vtkStructuredPoints ()
~vtkStructuredPoints ()

Detailed Description

A subclass of ImageData.

Date:
2002/01/22 15:26:23
Revision:
1.78

StructuredPoints is a subclass of ImageData that requires the data extent to exactly match the update extent. Normall image data allows that the data extent may be larger than the update extent. StructuredPoints also defines the origin differently that vtkImageData. For structured points the origin is the location of first point. Whereas images define the origin as the location of point 0, 0, 0. Image Origin is stored in ivar, and structured points have special methods for setting/getting the origin/extents.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (61%)
  • Law, Charles (13%)
  • Martin, Ken (10%)
  • Miller, Jim (6%)
Tests:
vtkStructuredPoints (Tests)

Definition at line 50 of file vtkStructuredPoints.h.

Constructor & Destructor Documentation

vtkStructuredPoints::vtkStructuredPoints ( ) [protected]

vtkStructuredPoints::~vtkStructuredPoints ( ) [inline, protected]

Definition at line 64 of file vtkStructuredPoints.h.

Member Function Documentation

vtkStructuredPoints* vtkStructuredPoints::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkImageData.

Reimplemented in vtkImageCanvasSource2D.

Referenced by MakeObject().

vtkStructuredPoints::vtkTypeRevisionMacro | ( | vtkStructuredPoints | ,
 |  | vtkImageData |
 | ) |

Reimplemented from vtkImageData.

Reimplemented in vtkImageCanvasSource2D.

vtkDataObject* vtkStructuredPoints::MakeObject ( ) [inline, virtual]

Create a similar type object

Reimplemented from vtkImageData.

Definition at line 57 of file vtkStructuredPoints.h.

int vtkStructuredPoints::GetDataObjectType ( ) [inline, virtual]

To simplify filter superclasses,

Reimplemented from vtkImageData.

Definition at line 60 of file vtkStructuredPoints.h.

The documentation for this class was generated from the following file:
  • Common/vtkStructuredPoints.h
Generated on Mon Mar 25 01:31:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsCollection Class Reference

maintain a list of structured points data objects. More...

#include <vtkStructuredPointsCollection.h>

Inheritance diagram for vtkStructuredPointsCollection:

[legend]
Collaboration diagram for vtkStructuredPointsCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsCollection, vtkCollection)
void | AddItem (vtkStructuredPoints *ds)
vtkStructuredPoints * GetNextItem ()

Static Public Methods

vtkStructuredPointsCollection * | New ()

Protected Methods

vtkStructuredPointsCollection ()
~vtkStructuredPointsCollection ()

Detailed Description

maintain a list of structured points data objects.

Date:
2002/01/22 15:28:14
Revision:
1.35

vtkStructuredPointsCollection is an object that creates and manipulates lists of structured points datasets. See also vtkCollection and subclasses.

Created by:
  • Hoffman, Bill
  • Schroeder, Will
Contributed by (if > 5%):
  • Martin, Ken (41%)
  • Schroeder, Will (35%)
  • Hoffman, Bill (22%)

Definition at line 42 of file vtkStructuredPointsCollection.h.

Constructor & Destructor Documentation

vtkStructuredPointsCollection::vtkStructuredPointsCollection ( ) [inline, protected]

Definition at line 62 of file vtkStructuredPointsCollection.h.

vtkStructuredPointsCollection::~vtkStructuredPointsCollection ( ) [inline, protected]

Definition at line 63 of file vtkStructuredPointsCollection.h.

Member Function Documentation

vtkStructuredPointsCollection* vtkStructuredPointsCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

vtkStructuredPointsCollection::vtkTypeRevisionMacro | ( | vtkStructuredPointsCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

void vtkStructuredPointsCollection::AddItem ( vtkStructuredPoints * ds ) [inline]

Add a pointer to a vtkStructuredPoints to the list.

Definition at line 50 of file vtkStructuredPointsCollection.h.

vtkStructuredPoints* vtkStructuredPointsCollection::GetNextItem ( ) [inline]

Get the next item in the collection. NULL is returned if the collection is exhausted.

Definition at line 57 of file vtkStructuredPointsCollection.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredPointsCollection.h
Generated on Mon Mar 25 01:31:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsGeometryFilter Class Reference

obsolete class. More...

#include <vtkStructuredPointsGeometryFilter.h>

Inheritance diagram for vtkStructuredPointsGeometryFilter:

[legend]
Collaboration diagram for vtkStructuredPointsGeometryFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsGeometryFilter, vtkImageDataGeometryFilter)

Static Public Methods

vtkStructuredPointsGeometryFilter * | New ()

Protected Methods

vtkStructuredPointsGeometryFilter ()
~vtkStructuredPointsGeometryFilter ()
vtkStructuredPointsGeometryFilter (const vtkStructuredPointsGeometryFilter &)
void | operator= (const vtkStructuredPointsGeometryFilter &)

Detailed Description

obsolete class.

Date:
2002/02/07 19:41:56
Revision:
1.37

vtkStructuredPointsGeometryFilter has been renamed to vtkImageDataGeometryFilter

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Avila, Lisa (23%)
  • Lorensen, Bill (14%)
  • Martin, Ken (7%)

Definition at line 40 of file vtkStructuredPointsGeometryFilter.h.

Constructor & Destructor Documentation

vtkStructuredPointsGeometryFilter::vtkStructuredPointsGeometryFilter ( ) [protected]

vtkStructuredPointsGeometryFilter::~vtkStructuredPointsGeometryFilter ( ) [inline, protected]

Definition at line 50 of file vtkStructuredPointsGeometryFilter.h.

vtkStructuredPointsGeometryFilter::vtkStructuredPointsGeometryFilter ( const vtkStructuredPointsGeometryFilter & ) [protected]

Member Function Documentation

vtkStructuredPointsGeometryFilter::vtkTypeRevisionMacro | ( | vtkStructuredPointsGeometryFilter | ,
 |  | vtkImageDataGeometryFilter |
 | ) |

Reimplemented from vtkImageDataGeometryFilter.

vtkStructuredPointsGeometryFilter* vtkStructuredPointsGeometryFilter::New ( ) [static]

Construct with initial extent of all the data

Reimplemented from vtkImageDataGeometryFilter.

void vtkStructuredPointsGeometryFilter::operator= ( const vtkStructuredPointsGeometryFilter & ) [protected]

The documentation for this class was generated from the following file:
  • Graphics/vtkStructuredPointsGeometryFilter.h
Generated on Mon Mar 25 01:31:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsReader Class Reference

read vtk structured points data file. More...

#include <vtkStructuredPointsReader.h>

Inheritance diagram for vtkStructuredPointsReader:

[legend]
Collaboration diagram for vtkStructuredPointsReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetOutput (vtkStructuredPoints *output)
vtkStructuredPoints * | GetOutput (int idx)
vtkStructuredPoints * GetOutput ()

Static Public Methods

vtkStructuredPointsReader * | New ()

Protected Methods

vtkStructuredPointsReader ()
~vtkStructuredPointsReader ()
void | Execute ()
void | ExecuteInformation ()

Detailed Description

read vtk structured points data file.

Date:
2002/01/22 15:38:23
Revision:
1.46

vtkStructuredPointsReader is a source object that reads ASCII or binary structured points data files in vtk format (see text for format details). The output of this reader is a single vtkStructuredPoints data object. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkStructuredPoints vtkDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Martin, Ken (14%)
  • Lorensen, Bill (7%)
  • Kelly, Ann (5%)
Examples:
vtkStructuredPointsReader (Examples)
Tests:
vtkStructuredPointsReader (Tests)

Definition at line 55 of file vtkStructuredPointsReader.h.

Constructor & Destructor Documentation

vtkStructuredPointsReader::vtkStructuredPointsReader ( ) [protected]

vtkStructuredPointsReader::~vtkStructuredPointsReader ( ) [protected]

Member Function Documentation

vtkStructuredPointsReader* vtkStructuredPointsReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkStructuredPointsReader::vtkTypeRevisionMacro | ( | vtkStructuredPointsReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkStructuredPointsReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

void vtkStructuredPointsReader::SetOutput ( vtkStructuredPoints * output )

Set/Get the output of this reader.

vtkStructuredPoints* vtkStructuredPointsReader::GetOutput ( int idx ) [inline]

Set/Get the output of this reader.

Reimplemented from vtkSource.

Definition at line 65 of file vtkStructuredPointsReader.h.

vtkStructuredPoints* vtkStructuredPointsReader::GetOutput ( )

Set/Get the output of this reader.

void vtkStructuredPointsReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkStructuredPointsReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • IO/vtkStructuredPointsReader.h
Generated on Mon Mar 25 01:31:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsSource Class Reference

Abstract class whose subclasses generates structured Points data. More...

#include <vtkStructuredPointsSource.h>

Inheritance diagram for vtkStructuredPointsSource:

[legend]
Collaboration diagram for vtkStructuredPointsSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsSource, vtkSource)
void | SetOutput (vtkStructuredPoints *output)
vtkStructuredPoints * GetOutput ()
vtkStructuredPoints * | GetOutput (int idx)

Static Public Methods

vtkStructuredPointsSource * | New ()

Protected Methods

vtkStructuredPointsSource ()
~vtkStructuredPointsSource ()
void | ExecuteInformation ()

Detailed Description

Abstract class whose subclasses generates structured Points data.

Date:
2002/01/22 15:28:14
Revision:
1.36

vtkStructuredPointsSource is an abstract class whose subclasses generate structured Points data.

See also:
vtkStructuredPointsReader vtkPLOT3DReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (51%)
  • Martin, Ken (25%)
  • Law, Charles (16%)

Definition at line 43 of file vtkStructuredPointsSource.h.

Constructor & Destructor Documentation

vtkStructuredPointsSource::vtkStructuredPointsSource ( ) [protected]

vtkStructuredPointsSource::~vtkStructuredPointsSource ( ) [inline, protected]

Definition at line 59 of file vtkStructuredPointsSource.h.

Member Function Documentation

vtkStructuredPointsSource* vtkStructuredPointsSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkImplicitModeller, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkVolume16Reader, vtkSweptSurface, and vtkRendererSource.

vtkStructuredPointsSource::vtkTypeRevisionMacro | ( | vtkStructuredPointsSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToStructuredPointsFilter, vtkStructuredPointsToStructuredPointsFilter, vtkImplicitModeller, vtkBooleanTexture, vtkExtractVOI, vtkGaussianSplatter, vtkPointLoad, vtkSampleFunction, vtkShepardMethod, vtkSurfaceReconstructionFilter, vtkTriangularTexture, vtkVoxelModeller, vtkVolume16Reader, vtkVolumeReader, vtkSweptSurface, and vtkRendererSource.

void vtkStructuredPointsSource::SetOutput ( vtkStructuredPoints * output )

Set/Get the output of this source.

vtkStructuredPoints* vtkStructuredPointsSource::GetOutput ( )

Set/Get the output of this source.

vtkStructuredPoints* vtkStructuredPointsSource::GetOutput ( int idx ) [inline]

Set/Get the output of this source.

Reimplemented from vtkSource.

Definition at line 53 of file vtkStructuredPointsSource.h.

void vtkStructuredPointsSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

Reimplemented in vtkStructuredPointsToStructuredPointsFilter, vtkImplicitModeller, vtkExtractVOI, vtkSampleFunction, vtkVolume16Reader, and vtkSweptSurface.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredPointsSource.h
Generated on Mon Mar 25 01:31:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkStructuredPointsToPolyDataFilter.h>

Inheritance diagram for vtkStructuredPointsToPolyDataFilter:

[legend]
Collaboration diagram for vtkStructuredPointsToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsToPolyDataFilter, vtkPolyDataSource)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Protected Methods

vtkStructuredPointsToPolyDataFilter ()
~vtkStructuredPointsToPolyDataFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:14
Revision:
1.42

vtkStructuredPointsToPolyDataFilter is an abstract filter class whose subclasses take on input structured points and generate polygonal data on output.

See also:
vtkDividingCubes vtkMarchingCubes vtkMarchingSquares vtkRecursiveDividingCubes vtkImageDataGeometryFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (51%)
  • Martin, Ken (22%)
  • Lorensen, Bill (10%)
  • Law, Charles (10%)

Definition at line 47 of file vtkStructuredPointsToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkStructuredPointsToPolyDataFilter::vtkStructuredPointsToPolyDataFilter ( ) [inline, protected]

Definition at line 59 of file vtkStructuredPointsToPolyDataFilter.h.

vtkStructuredPointsToPolyDataFilter::~vtkStructuredPointsToPolyDataFilter ( ) [inline, protected]

Definition at line 60 of file vtkStructuredPointsToPolyDataFilter.h.

Member Function Documentation

vtkStructuredPointsToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkStructuredPointsToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkImageDataGeometryFilter, vtkLinkEdgels, vtkRecursiveDividingCubes, vtkStructuredPointsGeometryFilter, vtkImageToPolyDataFilter, vtkDividingCubes, and vtkMarchingCubes.

void vtkStructuredPointsToPolyDataFilter::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkStructuredPointsToPolyDataFilter::GetInput ( )

Set / get the input data or filter.

void vtkStructuredPointsToPolyDataFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredPointsToPolyDataFilter.h
Generated on Mon Mar 25 01:31:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToStructuredPointsFilter Class Reference

abstract filter class. More...

#include <vtkStructuredPointsToStructuredPointsFilter.h>

Inheritance diagram for vtkStructuredPointsToStructuredPointsFilter:

[legend]
Collaboration diagram for vtkStructuredPointsToStructuredPointsFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsSource)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Protected Methods

vtkStructuredPointsToStructuredPointsFilter ()
~vtkStructuredPointsToStructuredPointsFilter ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:14
Revision:
1.41

vtkStructuredPointsToStructuredPointsFilter is an abstract filter class whose subclasses take on input structured points and generate structured points on output.

See also:
vtkExtractVOI vtkImageDifference vtkSweptSurface vtkTransformStructuredPoints
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (51%)
  • Martin, Ken (22%)
  • Lorensen, Bill (15%)
  • Law, Charles (10%)

Definition at line 45 of file vtkStructuredPointsToStructuredPointsFilter.h.

Constructor & Destructor Documentation

vtkStructuredPointsToStructuredPointsFilter::vtkStructuredPointsToStructuredPointsFilter ( ) [inline, protected]

Definition at line 57 of file vtkStructuredPointsToStructuredPointsFilter.h.

vtkStructuredPointsToStructuredPointsFilter::~vtkStructuredPointsToStructuredPointsFilter ( ) [inline, protected]

Definition at line 58 of file vtkStructuredPointsToStructuredPointsFilter.h.

Member Function Documentation

vtkStructuredPointsToStructuredPointsFilter::vtkTypeRevisionMacro | ( | vtkStructuredPointsToStructuredPointsFilter | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

Reimplemented in vtkExtractVOI, and vtkSweptSurface.

void vtkStructuredPointsToStructuredPointsFilter::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkStructuredPointsToStructuredPointsFilter::GetInput ( )

Set / get the input data or filter.

void vtkStructuredPointsToStructuredPointsFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsSource.

Reimplemented in vtkExtractVOI, and vtkSweptSurface.

void vtkStructuredPointsToStructuredPointsFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredPointsToStructuredPointsFilter.h
Generated on Mon Mar 25 01:31:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsToUnstructuredGridFilter Class Reference

abstract filter class. More...

#include <vtkStructuredPointsToUnstructuredGridFilter.h>

Inheritance diagram for vtkStructuredPointsToUnstructuredGridFilter:

[legend]
Collaboration diagram for vtkStructuredPointsToUnstructuredGridFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridSource)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Protected Methods

vtkStructuredPointsToUnstructuredGridFilter ()
~vtkStructuredPointsToUnstructuredGridFilter ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:15
Revision:
1.19

vtkStructuredPointsToUnstructuredGridFilter is an abstract filter class whose subclasses take on input structured points and generate unstructured grid data on output.

See also:
vtkClipVolume
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (62%)
  • Law, Charles (18%)
  • Lorensen, Bill (10%)
  • Martin, Ken (7%)

Definition at line 45 of file vtkStructuredPointsToUnstructuredGridFilter.h.

Constructor & Destructor Documentation

vtkStructuredPointsToUnstructuredGridFilter::vtkStructuredPointsToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 57 of file vtkStructuredPointsToUnstructuredGridFilter.h.

vtkStructuredPointsToUnstructuredGridFilter::~vtkStructuredPointsToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 58 of file vtkStructuredPointsToUnstructuredGridFilter.h.

Member Function Documentation

vtkStructuredPointsToUnstructuredGridFilter::vtkTypeRevisionMacro | ( | vtkStructuredPointsToUnstructuredGridFilter | ,
 |  | vtkUnstructuredGridSource |
 | ) |

Reimplemented from vtkUnstructuredGridSource.

Reimplemented in vtkClipVolume.

void vtkStructuredPointsToUnstructuredGridFilter::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkStructuredPointsToUnstructuredGridFilter::GetInput ( )

Set / get the input data or filter.

void vtkStructuredPointsToUnstructuredGridFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkUnstructuredGridSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkStructuredPointsToUnstructuredGridFilter.h
Generated on Mon Mar 25 01:31:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkStructuredPointsWriter Class Reference

write vtk structured points data file. More...

#include <vtkStructuredPointsWriter.h>

Inheritance diagram for vtkStructuredPointsWriter:

[legend]
Collaboration diagram for vtkStructuredPointsWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkStructuredPointsWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()

Static Public Methods

vtkStructuredPointsWriter * | New ()

Protected Methods

vtkStructuredPointsWriter ()
~vtkStructuredPointsWriter ()
void | WriteData ()

Detailed Description

write vtk structured points data file.

Date:
2002/01/22 15:38:23
Revision:
1.41

vtkStructuredPointsWriter is a source object that writes ASCII or binary structured points data in vtk file format. See text for format details.

Warning:
Binary files written on one system may not be writable on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (63%)
  • Law, Charles (18%)
  • Martin, Ken (10%)

Definition at line 42 of file vtkStructuredPointsWriter.h.

Constructor & Destructor Documentation

vtkStructuredPointsWriter::vtkStructuredPointsWriter ( ) [inline, protected]

Definition at line 56 of file vtkStructuredPointsWriter.h.

vtkStructuredPointsWriter::~vtkStructuredPointsWriter ( ) [inline, protected]

Definition at line 57 of file vtkStructuredPointsWriter.h.

Member Function Documentation

vtkStructuredPointsWriter* vtkStructuredPointsWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

vtkStructuredPointsWriter::vtkTypeRevisionMacro | ( | vtkStructuredPointsWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

void vtkStructuredPointsWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

void vtkStructuredPointsWriter::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkStructuredPointsWriter::GetInput ( )

Set / get the input data or filter.

Reimplemented from vtkWriter.

void vtkStructuredPointsWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

The documentation for this class was generated from the following file:
  • IO/vtkStructuredPointsWriter.h
Generated on Mon Mar 25 01:31:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSubdivideTetra Class Reference

subdivide one tetrahedron into twelve for every tetra. More...

#include <vtkSubdivideTetra.h>

Inheritance diagram for vtkSubdivideTetra:

[legend]
Collaboration diagram for vtkSubdivideTetra:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSubdivideTetra, vtkUnstructuredGridToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkSubdivideTetra * | New ()

Protected Methods

vtkSubdivideTetra ()
~vtkSubdivideTetra ()
void | Execute ()

Detailed Description

subdivide one tetrahedron into twelve for every tetra.

Date:
2002/01/22 15:29:50
Revision:
1.16

This filter subdivides tetrahedra in an unstructured grid into twelve tetrahedra.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (75%)
  • Lorensen, Bill (13%)
Tests:
vtkSubdivideTetra (Tests)

Definition at line 40 of file vtkSubdivideTetra.h.

Constructor & Destructor Documentation

vtkSubdivideTetra::vtkSubdivideTetra ( ) [protected]

vtkSubdivideTetra::~vtkSubdivideTetra ( ) [inline, protected]

Definition at line 50 of file vtkSubdivideTetra.h.

Member Function Documentation

vtkSubdivideTetra* vtkSubdivideTetra::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkSubdivideTetra::vtkTypeRevisionMacro | ( | vtkSubdivideTetra | ,
 |  | vtkUnstructuredGridToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkUnstructuredGridToUnstructuredGridFilter.

void vtkSubdivideTetra::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkSubdivideTetra::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Graphics/vtkSubdivideTetra.h
Generated on Mon Mar 25 01:31:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSubPixelPositionEdgels Class Reference

adjust edgel locations based on gradients. More...

#include <vtkSubPixelPositionEdgels.h>

Inheritance diagram for vtkSubPixelPositionEdgels:

[legend]
Collaboration diagram for vtkSubPixelPositionEdgels:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSubPixelPositionEdgels, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetGradMaps (vtkStructuredPoints *gm)
vtkStructuredPoints * GetGradMaps ()
virtual void | SetTargetFlag (int)
virtual int | GetTargetFlag ()
virtual void | TargetFlagOn ()
virtual void | TargetFlagOff ()
virtual void | SetTargetValue (float)
virtual float | GetTargetValue ()

Static Public Methods

vtkSubPixelPositionEdgels * | New ()

Protected Methods

vtkSubPixelPositionEdgels ()
~vtkSubPixelPositionEdgels ()
void | Execute ()
void | Move (int xdim, int ydim, int zdim, int x, int y, float *img, vtkDataArray *inVecs, float *result, int z, float *aspect, float *resultNormal)

Protected Attributes

int | TargetFlag
float | TargetValue

Detailed Description

adjust edgel locations based on gradients.

Date:
2002/01/22 15:29:49
Revision:
1.33

vtkSubPixelPositionEdgels is a filter that takes a series of linked edgels (digital curves) and gradient maps as input. It then adjusts the edgel locations based on the gradient data. Specifically, the algorithm first determines the neighboring gradient magnitudes of an edgel using simple interpolation of its neighbors. It then fits the following three data points: negative gradient direction gradient magnitude, edgel gradient magnitude and positive gradient direction gradient magnitude to a quadratic function. It then solves this quadratic to find the maximum gradient location along the gradient orientation. It then modifies the edgels location along the gradient orientation to the calculated maximum location. This algorithm does not adjust an edgel in the direction orthogonal to its gradient vector.

See also:
vtkImage vtkImageGradient vtkLinkEdgels
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (66%)
  • Avila, Lisa (6%)
  • Geveci, Berk (6%)
  • Law, Charles (5%)
Tests:
vtkSubPixelPositionEdgels (Tests)

Definition at line 58 of file vtkSubPixelPositionEdgels.h.

Constructor & Destructor Documentation

vtkSubPixelPositionEdgels::vtkSubPixelPositionEdgels ( ) [protected]

vtkSubPixelPositionEdgels::~vtkSubPixelPositionEdgels ( ) [protected]

Member Function Documentation

vtkSubPixelPositionEdgels* vtkSubPixelPositionEdgels::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkSubPixelPositionEdgels::vtkTypeRevisionMacro | ( | vtkSubPixelPositionEdgels | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkSubPixelPositionEdgels::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkSubPixelPositionEdgels::SetGradMaps ( vtkStructuredPoints * gm )

Set/Get the gradient data for doing the position adjustments.

vtkStructuredPoints* vtkSubPixelPositionEdgels::GetGradMaps ( )

Set/Get the gradient data for doing the position adjustments.

virtual void vtkSubPixelPositionEdgels::SetTargetFlag ( int ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

virtual int vtkSubPixelPositionEdgels::GetTargetFlag ( ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

virtual void vtkSubPixelPositionEdgels::TargetFlagOn ( ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

virtual void vtkSubPixelPositionEdgels::TargetFlagOff ( ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

virtual void vtkSubPixelPositionEdgels::SetTargetValue ( float ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

virtual float vtkSubPixelPositionEdgels::GetTargetValue ( ) [virtual]

These methods can make the positioning look for a target scalar value instead of looking for a maximum.

void vtkSubPixelPositionEdgels::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSubPixelPositionEdgels::Move | ( | int | xdim,
 |  | int | ydim,
 |  | int | zdim,
 |  | int | x,
 |  | int | y,
 |  | float * | img,
 |  | vtkDataArray * | inVecs,
 |  | float * | result,
 |  | int | z,
 |  | float * | aspect,
 |  | float * | resultNormal
 | ) | [protected]

Member Data Documentation

int vtkSubPixelPositionEdgels::TargetFlag [protected]

Definition at line 91 of file vtkSubPixelPositionEdgels.h.

float vtkSubPixelPositionEdgels::TargetValue [protected]

Definition at line 92 of file vtkSubPixelPositionEdgels.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSubPixelPositionEdgels.h
Generated on Mon Mar 25 01:31:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Summary Struct Reference

#include <vtk3DS.h>

Collaboration diagram for Summary:

[legend]
List of all members.

Public Attributes

VTK_LIST_FIELDS Vector center
Vector lengths

Member Data Documentation

VTK_LIST_FIELDS Vector Summary::center

Definition at line 99 of file vtk3DS.h.

Vector Summary::lengths

Definition at line 100 of file vtk3DS.h.

The documentation for this struct was generated from the following file:
  • IO/vtk3DS.h
Generated on Mon Mar 25 01:31:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSuperquadric Class Reference

implicit function for a Superquadric. More...

#include <vtkSuperquadric.h>

Inheritance diagram for vtkSuperquadric:

[legend]
Collaboration diagram for vtkSuperquadric:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSuperquadric, vtkImplicitFunction)
void | PrintSelf (ostream &os, vtkIndent indent)
float | EvaluateFunction (float x[3])
float | EvaluateFunction (float x, float y, float z)
void | EvaluateGradient (float x[3], float g[3])
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetScale (float, float, float)
virtual void | SetScale (float[3])
virtual float * | GetScale ()
virtual void | GetScale (float data[3])
virtual float | GetThickness ()
virtual void | SetThickness (float)
virtual float | GetPhiRoundness ()
void | SetPhiRoundness (float e)
virtual float | GetThetaRoundness ()
void | SetThetaRoundness (float e)
virtual void | SetSize (float)
virtual float | GetSize ()
virtual void | ToroidalOn ()
virtual void | ToroidalOff ()
virtual int | GetToroidal ()
virtual void | SetToroidal (int)

Static Public Methods

vtkSuperquadric * | New ()

Protected Methods

vtkSuperquadric ()
~vtkSuperquadric ()

Protected Attributes

int | Toroidal
float | Thickness
float | Size
float | PhiRoundness
float | ThetaRoundness
float | Center [3]
float | Scale [3]

Detailed Description

implicit function for a Superquadric.

Date:
2002/01/22 15:28:15
Revision:
1.20

vtkSuperquadric computes the implicit function and function gradient for a superquadric. vtkSuperquadric is a concrete implementation of vtkImplicitFunction. The superquadric is centered at Center and axes of rotation is along the y-axis. (Use the superclass' vtkImplicitFunction transformation matrix if necessary to reposition.) Roundness parameters (PhiRoundness and ThetaRoundness) control the shape of the superquadric. The Toroidal boolean controls whether a toroidal superquadric is produced. If so, the Thickness parameter controls the thickness of the toroid: 0 is the thinnest allowable toroid, and 1 has a minimum sized hole. The Scale parameters allow the superquadric to be scaled in x, y, and z (normal vectors are correctly generated in any case). The Size parameter controls size of the superquadric.

This code is based on "Rigid physically based superquadrics", A. H. Barr, in "Graphics Gems III", David Kirk, ed., Academic Press, 1992.

Warning:
The Size and Thickness parameters control coefficients of superquadric generation, and may do not exactly describe the size of the superquadric.
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (91%)

Definition at line 58 of file vtkSuperquadric.h.

Constructor & Destructor Documentation

vtkSuperquadric::vtkSuperquadric ( ) [protected]

vtkSuperquadric::~vtkSuperquadric ( ) [inline, protected]

Definition at line 124 of file vtkSuperquadric.h.

Member Function Documentation

vtkSuperquadric* vtkSuperquadric::New ( ) [static]

Construct with superquadric radius of 0.5, toroidal off, center at 0.0, scale (1,1,1), size 0.5, phi roundness 1.0, and theta roundness 0.0.

Reimplemented from vtkObject.

vtkSuperquadric::vtkTypeRevisionMacro | ( | vtkSuperquadric | ,
 |  | vtkImplicitFunction |
 | ) |

Reimplemented from vtkImplicitFunction.

void vtkSuperquadric::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImplicitFunction.

float vtkSuperquadric::EvaluateFunction ( float x[3] ) [virtual]

Evaluate function at position x-y-z and return value. You should generally not call this method directly, you should use FunctionValue() instead. This method must be implemented by any derived class.

Reimplemented from vtkImplicitFunction.

float vtkSuperquadric::EvaluateFunction | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) | [inline]

Evaluate function at position x-y-z and return value. You should generally not call this method directly, you should use FunctionValue() instead. This method must be implemented by any derived class.

Reimplemented from vtkImplicitFunction.

Definition at line 71 of file vtkSuperquadric.h.

void vtkSuperquadric::EvaluateGradient | ( | float | x[3],
 |  | float | g[3]
 | ) | [virtual]

Evaluate function gradient at position x-y-z and pass back vector. You should generally not call this method directly, you should use FunctionGradient() instead. This method must be implemented by any derived class.

Reimplemented from vtkImplicitFunction.

virtual void vtkSuperquadric::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadric::SetCenter ( float [3] ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual float* vtkSuperquadric::GetCenter ( ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadric::GetCenter ( float data[3] ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadric::SetScale | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual void vtkSuperquadric::SetScale ( float [3] ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual float* vtkSuperquadric::GetScale ( ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual void vtkSuperquadric::GetScale ( float data[3] ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual float vtkSuperquadric::GetThickness ( ) [virtual]

Set/Get Superquadric ring thickness (toroids only). Changing thickness maintains the outside diameter of the toroid.

virtual void vtkSuperquadric::SetThickness ( float ) [virtual]

Set/Get Superquadric ring thickness (toroids only). Changing thickness maintains the outside diameter of the toroid.

virtual float vtkSuperquadric::GetPhiRoundness ( ) [virtual]

Set/Get Superquadric north/south roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

void vtkSuperquadric::SetPhiRoundness ( float e )

Set/Get Superquadric north/south roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

virtual float vtkSuperquadric::GetThetaRoundness ( ) [virtual]

Set/Get Superquadric east/west roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

void vtkSuperquadric::SetThetaRoundness ( float e )

Set/Get Superquadric east/west roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

virtual void vtkSuperquadric::SetSize ( float ) [virtual]

Set/Get Superquadric isotropic size.

virtual float vtkSuperquadric::GetSize ( ) [virtual]

Set/Get Superquadric isotropic size.

virtual void vtkSuperquadric::ToroidalOn ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual void vtkSuperquadric::ToroidalOff ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual int vtkSuperquadric::GetToroidal ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual void vtkSuperquadric::SetToroidal ( int ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

Member Data Documentation

int vtkSuperquadric::Toroidal [protected]

Definition at line 126 of file vtkSuperquadric.h.

float vtkSuperquadric::Thickness [protected]

Definition at line 127 of file vtkSuperquadric.h.

float vtkSuperquadric::Size [protected]

Definition at line 128 of file vtkSuperquadric.h.

float vtkSuperquadric::PhiRoundness [protected]

Definition at line 129 of file vtkSuperquadric.h.

float vtkSuperquadric::ThetaRoundness [protected]

Definition at line 130 of file vtkSuperquadric.h.

float vtkSuperquadric::Center[3] [protected]

Definition at line 131 of file vtkSuperquadric.h.

float vtkSuperquadric::Scale[3] [protected]

Definition at line 132 of file vtkSuperquadric.h.

The documentation for this class was generated from the following file:
  • Filtering/vtkSuperquadric.h
Generated on Mon Mar 25 01:31:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSuperquadricSource Class Reference

create a polygonal superquadric centered. More...

#include <vtkSuperquadricSource.h>

Inheritance diagram for vtkSuperquadricSource:

[legend]
Collaboration diagram for vtkSuperquadricSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSuperquadricSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetScale (float, float, float)
virtual void | SetScale (float[3])
virtual float * | GetScale ()
virtual void | GetScale (float data[3])
virtual int | GetThetaResolution ()
void | SetThetaResolution (int i)
virtual int | GetPhiResolution ()
void | SetPhiResolution (int i)
virtual float | GetThickness ()
virtual void | SetThickness (float)
virtual float | GetPhiRoundness ()
void | SetPhiRoundness (float e)
virtual float | GetThetaRoundness ()
void | SetThetaRoundness (float e)
virtual void | SetSize (float)
virtual float | GetSize ()
virtual void | ToroidalOn ()
virtual void | ToroidalOff ()
virtual int | GetToroidal ()
virtual void | SetToroidal (int)

Static Public Methods

vtkSuperquadricSource * | New ()

Protected Methods

vtkSuperquadricSource (int res=16)
~vtkSuperquadricSource ()
void | Execute ()

Protected Attributes

int | Toroidal
float | Thickness
float | Size
float | PhiRoundness
float | ThetaRoundness
float | Center [3]
float | Scale [3]
int | ThetaResolution
int | PhiResolution

Detailed Description

create a polygonal superquadric centered.

Date:
2002/01/22 15:29:50
Revision:
1.18
at the origin

vtkSuperquadricSource creates a superquadric (represented by polygons) of specified size centered at the origin. The resolution (polygonal discretization) in both the latitude (phi) and longitude (theta) directions can be specified. Roundness parameters (PhiRoundness and ThetaRoundness) control the shape of the superquadric. The Toroidal boolean controls whether a toroidal superquadric is produced. If so, the Thickness parameter controls the thickness of the toroid: 0 is the thinnest allowable toroid, and 1 has a minimum sized hole. The Scale parameters allow the superquadric to be scaled in x, y, and z (normal vectors are correctly generated in any case). The Size parameter controls size of the superquadric.

This code is based on "Rigid physically based superquadrics", A. H. Barr, in "Graphics Gems III", David Kirk, ed., Academic Press, 1992.

Warning:
Resolution means the number of latitude or longitude lines for a complete superquadric. The resolution parameters are rounded to the nearest 4 in phi and 8 in theta.
Warning:
Texture coordinates are not equally distributed around all superquadrics.
Warning:
The Size and Thickness parameters control coefficients of superquadric generation, and may do not exactly describe the size of the superquadric.
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (93%)
Tests:
vtkSuperquadricSource (Tests)

Definition at line 71 of file vtkSuperquadricSource.h.

Constructor & Destructor Documentation

vtkSuperquadricSource::vtkSuperquadricSource ( int res = 16 ) [protected]

vtkSuperquadricSource::~vtkSuperquadricSource ( ) [inline, protected]

Definition at line 142 of file vtkSuperquadricSource.h.

Member Function Documentation

vtkSuperquadricSource* vtkSuperquadricSource::New ( ) [static]

Create a default superquadric with a radius of 0.5, non-toroidal, spherical, and centered at the origin.

Reimplemented from vtkPolyDataSource.

vtkSuperquadricSource::vtkTypeRevisionMacro | ( | vtkSuperquadricSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSuperquadricSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkSuperquadricSource::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadricSource::SetCenter ( float [3] ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual float* vtkSuperquadricSource::GetCenter ( ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadricSource::GetCenter ( float data[3] ) [virtual]

Set the center of the superquadric. Default is 0,0,0.

virtual void vtkSuperquadricSource::SetScale | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual void vtkSuperquadricSource::SetScale ( float [3] ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual float* vtkSuperquadricSource::GetScale ( ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual void vtkSuperquadricSource::GetScale ( float data[3] ) [virtual]

Set the scale factors of the superquadric. Default is 1,1,1.

virtual int vtkSuperquadricSource::GetThetaResolution ( ) [virtual]

Set the number of points in the longitude direction.

void vtkSuperquadricSource::SetThetaResolution ( int i )

Set the number of points in the longitude direction.

virtual int vtkSuperquadricSource::GetPhiResolution ( ) [virtual]

Set the number of points in the latitude direction.

void vtkSuperquadricSource::SetPhiResolution ( int i )

Set the number of points in the latitude direction.

virtual float vtkSuperquadricSource::GetThickness ( ) [virtual]

Set/Get Superquadric ring thickness (toroids only). Changing thickness maintains the outside diameter of the toroid.

virtual void vtkSuperquadricSource::SetThickness ( float ) [virtual]

Set/Get Superquadric ring thickness (toroids only). Changing thickness maintains the outside diameter of the toroid.

virtual float vtkSuperquadricSource::GetPhiRoundness ( ) [virtual]

Set/Get Superquadric north/south roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

void vtkSuperquadricSource::SetPhiRoundness ( float e )

Set/Get Superquadric north/south roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

virtual float vtkSuperquadricSource::GetThetaRoundness ( ) [virtual]

Set/Get Superquadric east/west roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

void vtkSuperquadricSource::SetThetaRoundness ( float e )

Set/Get Superquadric east/west roundness. Values range from 0 (rectangular) to 1 (circular) to higher orders.

virtual void vtkSuperquadricSource::SetSize ( float ) [virtual]

Set/Get Superquadric isotropic size.

virtual float vtkSuperquadricSource::GetSize ( ) [virtual]

Set/Get Superquadric isotropic size.

virtual void vtkSuperquadricSource::ToroidalOn ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual void vtkSuperquadricSource::ToroidalOff ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual int vtkSuperquadricSource::GetToroidal ( ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

virtual void vtkSuperquadricSource::SetToroidal ( int ) [virtual]

Set/Get whether or not the superquadric is toroidal (1) or ellipsoidal (0).

void vtkSuperquadricSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkSuperquadricSource::Toroidal [protected]

Definition at line 144 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::Thickness [protected]

Definition at line 145 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::Size [protected]

Definition at line 146 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::PhiRoundness [protected]

Definition at line 147 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::ThetaRoundness [protected]

Definition at line 148 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::Center[3] [protected]

Definition at line 150 of file vtkSuperquadricSource.h.

float vtkSuperquadricSource::Scale[3] [protected]

Definition at line 151 of file vtkSuperquadricSource.h.

int vtkSuperquadricSource::ThetaResolution [protected]

Definition at line 152 of file vtkSuperquadricSource.h.

int vtkSuperquadricSource::PhiResolution [protected]

Definition at line 153 of file vtkSuperquadricSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkSuperquadricSource.h
Generated on Mon Mar 25 01:31:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSurfaceReconstructionFilter Class Reference

reconstructs a surface from unorganized points. More...

#include <vtkSurfaceReconstructionFilter.h>

Inheritance diagram for vtkSurfaceReconstructionFilter:

[legend]
Collaboration diagram for vtkSurfaceReconstructionFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSurfaceReconstructionFilter, vtkDataSetToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual int | GetNeighborhoodSize ()
virtual void | SetNeighborhoodSize (int)
virtual float | GetSampleSpacing ()
virtual void | SetSampleSpacing (float)

Static Public Methods

vtkSurfaceReconstructionFilter * | New ()

Protected Methods

vtkSurfaceReconstructionFilter ()
~vtkSurfaceReconstructionFilter ()
void | Execute ()

Protected Attributes

int | NeighborhoodSize
float | SampleSpacing

Detailed Description

reconstructs a surface from unorganized points.

Date:
2002/01/22 15:33:48
Revision:
1.15

vtkSurfaceReconstructionFilter takes a list of points assumed to lie on the surface of a solid 3D object. A signed measure of the distance to the surface is computed and sampled on a regular grid. The grid can then be contoured at zero to extract the surface. The default values for neighborhood size and sample spacing should give reasonable results for most uses but can be set if desired. This procedure is based on the PhD work of Hugues Hoppe: http://www.research.microsoft.com/-hoppe

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (90%)
Examples:
vtkSurfaceReconstructionFilter (Examples)
Tests:
vtkSurfaceReconstructionFilter (Tests)

Definition at line 49 of file vtkSurfaceReconstructionFilter.h.

Constructor & Destructor Documentation

vtkSurfaceReconstructionFilter::vtkSurfaceReconstructionFilter ( ) [protected]

vtkSurfaceReconstructionFilter::~vtkSurfaceReconstructionFilter ( ) [inline, protected]

Definition at line 78 of file vtkSurfaceReconstructionFilter.h.

Member Function Documentation

vtkSurfaceReconstructionFilter::vtkTypeRevisionMacro | ( | vtkSurfaceReconstructionFilter | ,
 |  | vtkDataSetToStructuredPointsFilter |
 | ) |

Reimplemented from vtkDataSetToStructuredPointsFilter.

void vtkSurfaceReconstructionFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkSurfaceReconstructionFilter* vtkSurfaceReconstructionFilter::New ( ) [static]

Construct with NeighborhoodSize=20.

Reimplemented from vtkStructuredPointsSource.

virtual int vtkSurfaceReconstructionFilter::GetNeighborhoodSize ( ) [virtual]

Specify the number of neighbors each point has, used for estimating the local surface orientation. The default value of 20 should be OK for most applications, higher values can be specified if the spread of points is uneven. Values as low as 10 may yield adequate results for some surfaces. Higher values cause the algorithm to take longer. Higher values will cause errors on sharp boundaries.

virtual void vtkSurfaceReconstructionFilter::SetNeighborhoodSize ( int ) [virtual]

Specify the number of neighbors each point has, used for estimating the local surface orientation. The default value of 20 should be OK for most applications, higher values can be specified if the spread of points is uneven. Values as low as 10 may yield adequate results for some surfaces. Higher values cause the algorithm to take longer. Higher values will cause errors on sharp boundaries.

virtual float vtkSurfaceReconstructionFilter::GetSampleSpacing ( ) [virtual]

Specify the spacing of the 3D sampling grid. If not set, a reasonable guess will be made.

virtual void vtkSurfaceReconstructionFilter::SetSampleSpacing ( float ) [virtual]

Specify the spacing of the 3D sampling grid. If not set, a reasonable guess will be made.

void vtkSurfaceReconstructionFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkSurfaceReconstructionFilter::NeighborhoodSize [protected]

Definition at line 82 of file vtkSurfaceReconstructionFilter.h.

float vtkSurfaceReconstructionFilter::SampleSpacing [protected]

Definition at line 83 of file vtkSurfaceReconstructionFilter.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkSurfaceReconstructionFilter.h
Generated on Mon Mar 25 01:31:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSweptSurface Class Reference

given a path and input geometry generate an (implicit) representation of a swept surface. More...

#include <vtkSweptSurface.h>

Inheritance diagram for vtkSweptSurface:

[legend]
Collaboration diagram for vtkSweptSurface:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSweptSurface, vtkStructuredPointsToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
virtual void | SetSampleDimensions (int, int, int)
virtual void | SetSampleDimensions (int[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetTransforms (vtkTransformCollection *)
virtual vtkTransformCollection * | GetTransforms ()
virtual void | SetFillValue (float)
virtual float | GetFillValue ()
virtual void | SetNumberOfInterpolationSteps (int)
virtual int | GetNumberOfInterpolationSteps ()
virtual void | SetMaximumNumberOfInterpolationSteps (int)
virtual int | GetMaximumNumberOfInterpolationSteps ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetModelBounds (float data[])
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])
void | SetModelBounds (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
virtual void | SetAdjustBounds (int)
virtual int | GetAdjustBounds ()
virtual void | AdjustBoundsOn ()
virtual void | AdjustBoundsOff ()
virtual void | SetAdjustDistance (float)
virtual float | GetAdjustDistance ()

Static Public Methods

vtkSweptSurface * | New ()

Protected Methods

vtkSweptSurface ()
~vtkSweptSurface ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeBounds (float origin[3], float ar[3], float bbox[24])
int | ComputeNumberOfSteps (vtkTransform *t1, vtkTransform *t2, float bbox[24])
void | SampleInput (vtkMatrix4x4 *m, int inDim[3], float inOrigin[3], float inAr[3], vtkDataArray *in, vtkDataArray *out)
void | ComputeFootprint (vtkMatrix4x4 *m, int inDim[3], float inOrigin[3], float inSpacing[3], int Indicies[6])
void | Cap (vtkDataArray *s)
void | GetRelativePosition (vtkTransform &t, float *origin, float *position)
vtkMatrix4x4 * | GetActorMatrixPointer (vtkTransform &t, float origin[3], float position[3], float orientation[3])
virtual void | InterpolateStates (float *pos1, float *pos2, float *euler1, float *euler2, float t, float *posOut, float *eulerOut)

Protected Attributes

int | SampleDimensions [3]
float | FillValue
float | ModelBounds [6]
int | NumberOfInterpolationSteps
int | MaximumNumberOfInterpolationSteps
int | Capping
int | AdjustBounds
float | AdjustDistance
vtkTransformCollection * Transforms

Detailed Description

given a path and input geometry generate an (implicit) representation of a swept surface.

Date:
2002/01/22 22:02:32
Revision:
1.49

vtkSweptSurface is a filter that is used to create a surface defined by moving a part along a path. In this implementation, the path is defined as a list of transformation matrices (vtkTransform), and the part geometry is implicitly defined using a volume (i.e., distance scalars in structured point dataset). The input to the filter is the geometry (i.e., a structured point dataset) and the output is a structured point dataset (i.e., an implicit representation of the swept surface). If you wish to generate a polygonal representation of swept surface you will have to use a contouring filter (e.g., vtkContourFilter). (You may also wish to use vtkDecimate to reduce mesh size.)

The swept surface algorithm can be summarized as follows. A geometry (i.e. the input) is swept along a path (list of transforms). At each point on the path the input is re-sampled into a volume using a union operation. (Union means that the minimum scalar value is retained - minimum distance value for example.) At the end, an implicit representation of the swept surface is defined.

See also:
vtkImplicitModeller vtkContourFilter vtkDecimate
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (52%)
  • Lorensen, Bill (24%)
  • Law, Charles (5%)
  • Blue, Rusty (5%)
Tests:
vtkSweptSurface (Tests)

Definition at line 75 of file vtkSweptSurface.h.

Constructor & Destructor Documentation

vtkSweptSurface::vtkSweptSurface ( ) [protected]

vtkSweptSurface::~vtkSweptSurface ( ) [protected]

Member Function Documentation

vtkSweptSurface* vtkSweptSurface::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkStructuredPointsSource.

vtkSweptSurface::vtkTypeRevisionMacro | ( | vtkSweptSurface | ,
 |  | vtkStructuredPointsToStructuredPointsFilter |
 | ) |

Reimplemented from vtkStructuredPointsToStructuredPointsFilter.

void vtkSweptSurface::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkSweptSurface::SetSampleDimensions | ( | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Specify i-j-k dimensions to sample input with. The higher the resolution the lower the error but the greater the processing time.

virtual void vtkSweptSurface::SetSampleDimensions ( int [3] ) [virtual]

Specify i-j-k dimensions to sample input with. The higher the resolution the lower the error but the greater the processing time.

virtual int* vtkSweptSurface::GetSampleDimensions ( ) [virtual]

Specify i-j-k dimensions to sample input with. The higher the resolution the lower the error but the greater the processing time.

virtual void vtkSweptSurface::GetSampleDimensions ( int data[3] ) [virtual]

Specify i-j-k dimensions to sample input with. The higher the resolution the lower the error but the greater the processing time.

virtual void vtkSweptSurface::SetTransforms ( vtkTransformCollection * ) [virtual]

Specify a path (i.e., list of transforms) that the input moves along. At least two transforms must be used to define a path.

virtual vtkTransformCollection* vtkSweptSurface::GetTransforms ( ) [virtual]

Specify a path (i.e., list of transforms) that the input moves along. At least two transforms must be used to define a path.

virtual void vtkSweptSurface::SetFillValue ( float ) [virtual]

Voxels are initialized to this value. By default a large floating point value is used, since the scalar values are assumed to be a distance function.

virtual float vtkSweptSurface::GetFillValue ( ) [virtual]

Voxels are initialized to this value. By default a large floating point value is used, since the scalar values are assumed to be a distance function.

virtual void vtkSweptSurface::SetNumberOfInterpolationSteps ( int ) [virtual]

Value specifies/controls interpolation between the nodes (i.e., transforms) defining the path. A positive value indicates the number of steps to take between transforms (i.e., interpolation is performed). A negative value indicates that no interpolation to be performed, that is, only the points defined at each transform are used (interpolation not performed). A zero value indicates that automatic interpolation is to be performed, that is, interpolation is computed so that potential errors fall below the error bounds defined in the text. By default, automatic computation is performed (Interpolation = 0).

virtual int vtkSweptSurface::GetNumberOfInterpolationSteps ( ) [virtual]

Value specifies/controls interpolation between the nodes (i.e., transforms) defining the path. A positive value indicates the number of steps to take between transforms (i.e., interpolation is performed). A negative value indicates that no interpolation to be performed, that is, only the points defined at each transform are used (interpolation not performed). A zero value indicates that automatic interpolation is to be performed, that is, interpolation is computed so that potential errors fall below the error bounds defined in the text. By default, automatic computation is performed (Interpolation = 0).

virtual void vtkSweptSurface::SetMaximumNumberOfInterpolationSteps ( int ) [virtual]

Set/get the maximum number of interpolation steps to take. This is useful if you are limited in computation time or just know that the number of computed steps should not exceed a certain value.

virtual int vtkSweptSurface::GetMaximumNumberOfInterpolationSteps ( ) [virtual]

Set/get the maximum number of interpolation steps to take. This is useful if you are limited in computation time or just know that the number of computed steps should not exceed a certain value.

virtual void vtkSweptSurface::SetCapping ( int ) [virtual]

The outer boundary of the sampling volume can be capped (i.e., assigned fill value). This will "close" the implicit model if the geometry approaches close to or passes through the boundary of the volume (i.e., defined by ModelBounds instance variable). Capping turns on/off this capability. By default capping is on.

virtual int vtkSweptSurface::GetCapping ( ) [virtual]

The outer boundary of the sampling volume can be capped (i.e., assigned fill value). This will "close" the implicit model if the geometry approaches close to or passes through the boundary of the volume (i.e., defined by ModelBounds instance variable). Capping turns on/off this capability. By default capping is on.

virtual void vtkSweptSurface::CappingOn ( ) [virtual]

The outer boundary of the sampling volume can be capped (i.e., assigned fill value). This will "close" the implicit model if the geometry approaches close to or passes through the boundary of the volume (i.e., defined by ModelBounds instance variable). Capping turns on/off this capability. By default capping is on.

virtual void vtkSweptSurface::CappingOff ( ) [virtual]

The outer boundary of the sampling volume can be capped (i.e., assigned fill value). This will "close" the implicit model if the geometry approaches close to or passes through the boundary of the volume (i.e., defined by ModelBounds instance variable). Capping turns on/off this capability. By default capping is on.

virtual void vtkSweptSurface::SetModelBounds ( float data[] ) [virtual]

Define the volume (in world coordinates) in which the sampling is to occur. Make sure that the volume is large enough to accommodate the motion of the geometry along the path. If the model bounds are set to all zero values, the model bounds will be computed automatically from the input geometry and path.

virtual float* vtkSweptSurface::GetModelBounds ( ) [virtual]

Define the volume (in world coordinates) in which the sampling is to occur. Make sure that the volume is large enough to accommodate the motion of the geometry along the path. If the model bounds are set to all zero values, the model bounds will be computed automatically from the input geometry and path.

virtual void vtkSweptSurface::GetModelBounds ( float data[6] ) [virtual]

Define the volume (in world coordinates) in which the sampling is to occur. Make sure that the volume is large enough to accommodate the motion of the geometry along the path. If the model bounds are set to all zero values, the model bounds will be computed automatically from the input geometry and path.

void vtkSweptSurface::SetModelBounds | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

Define the volume (in world coordinates) in which the sampling is to occur. Make sure that the volume is large enough to accommodate the motion of the geometry along the path. If the model bounds are set to all zero values, the model bounds will be computed automatically from the input geometry and path.

virtual void vtkSweptSurface::SetAdjustBounds ( int ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual int vtkSweptSurface::GetAdjustBounds ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkSweptSurface::AdjustBoundsOn ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkSweptSurface::AdjustBoundsOff ( ) [virtual]

Control how the model bounds are computed. If the ivar AdjustBounds is set, then the bounds specified (or computed automatically) is modified by the fraction given by AdjustDistance. This means that the model bounds is expanded in each of the x-y-z directions.

virtual void vtkSweptSurface::SetAdjustDistance ( float ) [virtual]

Specify the amount to grow the model bounds (if the ivar AdjustBounds is set). The value is a fraction of the maximum length of the sides of the box specified by the model bounds.

virtual float vtkSweptSurface::GetAdjustDistance ( ) [virtual]

Specify the amount to grow the model bounds (if the ivar AdjustBounds is set). The value is a fraction of the maximum length of the sides of the box specified by the model bounds.

unsigned long int vtkSweptSurface::GetMTime ( ) [virtual]

Return this object's modified time.

Reimplemented from vtkObject.

void vtkSweptSurface::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSweptSurface::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsToStructuredPointsFilter.

void vtkSweptSurface::ComputeBounds | ( | float | origin[3],
 |  | float | ar[3],
 |  | float | bbox[24]
 | ) | [protected]

int vtkSweptSurface::ComputeNumberOfSteps | ( | vtkTransform * | t1,
 |  | vtkTransform * | t2,
 |  | float | bbox[24]
 | ) | [protected]

void vtkSweptSurface::SampleInput | ( | vtkMatrix4x4 * | m,
 |  | int | inDim[3],
 |  | float | inOrigin[3],
 |  | float | inAr[3],
 |  | vtkDataArray * | in,
 |  | vtkDataArray * | out
 | ) | [protected]

void vtkSweptSurface::ComputeFootprint | ( | vtkMatrix4x4 * | m,
 |  | int | inDim[3],
 |  | float | inOrigin[3],
 |  | float | inSpacing[3],
 |  | int | Indicies[6]
 | ) | [protected]

void vtkSweptSurface::Cap ( vtkDataArray * s ) [protected]

void vtkSweptSurface::GetRelativePosition | ( | vtkTransform & | t,
 |  | float * | origin,
 |  | float * | position
 | ) | [protected]

vtkMatrix4x4* vtkSweptSurface::GetActorMatrixPointer | ( | vtkTransform & | t,
 |  | float | origin[3],
 |  | float | position[3],
 |  | float | orientation[3]
 | ) | [protected]

virtual void vtkSweptSurface::InterpolateStates | ( | float * | pos1,
 |  | float * | pos2,
 |  | float * | euler1,
 |  | float * | euler2,
 |  | float | t,
 |  | float * | posOut,
 |  | float * | eulerOut
 | ) | [protected, virtual]

Member Data Documentation

int vtkSweptSurface::SampleDimensions[3] [protected]

Definition at line 193 of file vtkSweptSurface.h.

float vtkSweptSurface::FillValue [protected]

Definition at line 194 of file vtkSweptSurface.h.

float vtkSweptSurface::ModelBounds[6] [protected]

Definition at line 195 of file vtkSweptSurface.h.

int vtkSweptSurface::NumberOfInterpolationSteps [protected]

Definition at line 196 of file vtkSweptSurface.h.

int vtkSweptSurface::MaximumNumberOfInterpolationSteps [protected]

Definition at line 197 of file vtkSweptSurface.h.

int vtkSweptSurface::Capping [protected]

Definition at line 198 of file vtkSweptSurface.h.

int vtkSweptSurface::AdjustBounds [protected]

Definition at line 199 of file vtkSweptSurface.h.

float vtkSweptSurface::AdjustDistance [protected]

Definition at line 200 of file vtkSweptSurface.h.

vtkTransformCollection* vtkSweptSurface::Transforms [protected]

Definition at line 202 of file vtkSweptSurface.h.

The documentation for this class was generated from the following file:
  • Patented/vtkSweptSurface.h
Generated on Mon Mar 25 01:31:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSynchronizedTemplates2D Class Reference

generate isoline(s) from a structured points set. More...

#include <vtkSynchronizedTemplates2D.h>

Inheritance diagram for vtkSynchronizedTemplates2D:

[legend]
Collaboration diagram for vtkSynchronizedTemplates2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSynchronizedTemplates2D, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkSynchronizedTemplates2D * | New ()

Protected Methods

vtkSynchronizedTemplates2D ()
~vtkSynchronizedTemplates2D ()
void | Execute ()
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

vtkContourValues * ContourValues
int | ComputeScalars
char * | InputScalarsSelection

Friends

class VTK_PATENTED_EXPORT | vtkKitwareContourFilter

Detailed Description

generate isoline(s) from a structured points set.

Date:
2002/01/22 22:02:33
Revision:
1.23

vtkSynchronizedTemplates2D is a 2D implementation of the synchronized template algorithm. Note that vtkContourFilter will automatically use this class when appropriate if vtk was built with patents.

Warning:
This filter is specialized to 2D images.
See also:
vtkContourFilter vtkSynchronizedTemplates3D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Martin, Ken (5%)

Definition at line 59 of file vtkSynchronizedTemplates2D.h.

Constructor & Destructor Documentation

vtkSynchronizedTemplates2D::vtkSynchronizedTemplates2D ( ) [protected]

vtkSynchronizedTemplates2D::~vtkSynchronizedTemplates2D ( ) [protected]

Member Function Documentation

vtkSynchronizedTemplates2D* vtkSynchronizedTemplates2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkSynchronizedTemplates2D::vtkTypeRevisionMacro | ( | vtkSynchronizedTemplates2D | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSynchronizedTemplates2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkSynchronizedTemplates2D::SetInput ( vtkImageData * input )

Set / get the input data or filter.

vtkImageData* vtkSynchronizedTemplates2D::GetInput ( )

Set / get the input data or filter.

unsigned long int vtkSynchronizedTemplates2D::GetMTime ( ) [virtual]

Because we delegate to vtkContourValues

Reimplemented from vtkObject.

void vtkSynchronizedTemplates2D::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 77 of file vtkSynchronizedTemplates2D.h.

float vtkSynchronizedTemplates2D::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 80 of file vtkSynchronizedTemplates2D.h.

float* vtkSynchronizedTemplates2D::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 84 of file vtkSynchronizedTemplates2D.h.

void vtkSynchronizedTemplates2D::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 90 of file vtkSynchronizedTemplates2D.h.

void vtkSynchronizedTemplates2D::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 98 of file vtkSynchronizedTemplates2D.h.

int vtkSynchronizedTemplates2D::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 104 of file vtkSynchronizedTemplates2D.h.

void vtkSynchronizedTemplates2D::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 111 of file vtkSynchronizedTemplates2D.h.

void vtkSynchronizedTemplates2D::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 118 of file vtkSynchronizedTemplates2D.h.

virtual void vtkSynchronizedTemplates2D::SetComputeScalars ( int ) [virtual]

Option to set the point scalars of the output. The scalars will be the iso value of course. By default this flag is on.

virtual int vtkSynchronizedTemplates2D::GetComputeScalars ( ) [virtual]

Option to set the point scalars of the output. The scalars will be the iso value of course. By default this flag is on.

virtual void vtkSynchronizedTemplates2D::ComputeScalarsOn ( ) [virtual]

Option to set the point scalars of the output. The scalars will be the iso value of course. By default this flag is on.

virtual void vtkSynchronizedTemplates2D::ComputeScalarsOff ( ) [virtual]

Option to set the point scalars of the output. The scalars will be the iso value of course. By default this flag is on.

virtual char* vtkSynchronizedTemplates2D::GetInputScalarsSelection ( ) [virtual]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkSynchronizedTemplates2D::SelectInputScalars ( const char * fieldName ) [inline]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 135 of file vtkSynchronizedTemplates2D.h.

void vtkSynchronizedTemplates2D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkSynchronizedTemplates2D::SetInputScalarsSelection ( const char * ) [protected, virtual]

Friends And Related Function Documentation

friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter [friend]

Definition at line 153 of file vtkSynchronizedTemplates2D.h.

Member Data Documentation

vtkContourValues* vtkSynchronizedTemplates2D::ContourValues [protected]

Definition at line 144 of file vtkSynchronizedTemplates2D.h.

int vtkSynchronizedTemplates2D::ComputeScalars [protected]

Definition at line 146 of file vtkSynchronizedTemplates2D.h.

char* vtkSynchronizedTemplates2D::InputScalarsSelection [protected]

Definition at line 148 of file vtkSynchronizedTemplates2D.h.

The documentation for this class was generated from the following file:
  • Patented/vtkSynchronizedTemplates2D.h
Generated on Mon Mar 25 01:31:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSynchronizedTemplates3D Class Reference

generate isosurface from structured points. More...

#include <vtkSynchronizedTemplates3D.h>

Inheritance diagram for vtkSynchronizedTemplates3D:

[legend]
Collaboration diagram for vtkSynchronizedTemplates3D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkSynchronizedTemplates3D, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long int | GetMTime ()
void | SetValue (int i, float value)
float | GetValue (int i)
float * | GetValues ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
virtual void | SetComputeNormals (int)
virtual int | GetComputeNormals ()
virtual void | ComputeNormalsOn ()
virtual void | ComputeNormalsOff ()
virtual void | SetComputeGradients (int)
virtual int | GetComputeGradients ()
virtual void | ComputeGradientsOn ()
virtual void | ComputeGradientsOff ()
virtual void | SetComputeScalars (int)
virtual int | GetComputeScalars ()
virtual void | ComputeScalarsOn ()
virtual void | ComputeScalarsOff ()
void | GetValues (float *contourValues)
void | SetNumberOfContours (int number)
int | GetNumberOfContours ()
void | GenerateValues (int numContours, float range[2])
void | GenerateValues (int numContours, float rangeStart, float rangeEnd)
int * | GetExecuteExtent ()
void | ThreadedExecute (vtkImageData *data, int *exExt, int threadId)
virtual void | SetNumberOfThreads (int)
virtual int | GetNumberOfThreads ()
void | SetInputMemoryLimit (unsigned long limit)
unsigned long | GetInputMemoryLimit ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkSynchronizedTemplates3D * | New ()

Protected Methods

vtkSynchronizedTemplates3D ()
~vtkSynchronizedTemplates3D ()
void | Execute ()
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

int | ComputeNormals
int | ComputeGradients
int | ComputeScalars
vtkContourValues * ContourValues
int | ExecuteExtent [6]
int | NumberOfThreads
vtkMultiThreader * Threader
vtkPolyData * | Threads [VTK_MAX_THREADS]
char * | InputScalarsSelection

Friends

class VTK_PATENTED_EXPORT | vtkKitwareContourFilter

Detailed Description

generate isosurface from structured points.

Date:
2002/01/22 22:02:34
Revision:
1.28

vtkSynchronizedTemplates3D is a 3D implementation of the synchronized template algorithm. Note that vtkContourFilter will automatically use this class when appropriate if vtk was built with patents.

Warning:
This filter is specialized to 3D images (aka volumes).
See also:
vtkContourFilter vtkSynchronizedTemplates2D
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (56%)
  • Geveci, Berk (36%)
Tests:
vtkSynchronizedTemplates3D (Tests)

Definition at line 64 of file vtkSynchronizedTemplates3D.h.

Constructor & Destructor Documentation

vtkSynchronizedTemplates3D::vtkSynchronizedTemplates3D ( ) [protected]

vtkSynchronizedTemplates3D::~vtkSynchronizedTemplates3D ( ) [protected]

Member Function Documentation

vtkSynchronizedTemplates3D* vtkSynchronizedTemplates3D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkSynchronizedTemplates3D::vtkTypeRevisionMacro | ( | vtkSynchronizedTemplates3D | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkSynchronizedTemplates3D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkSynchronizedTemplates3D::SetInput ( vtkImageData * input )

Set/Get the source for the scalar data to contour.

vtkImageData* vtkSynchronizedTemplates3D::GetInput ( )

Set/Get the source for the scalar data to contour.

unsigned long int vtkSynchronizedTemplates3D::GetMTime ( ) [virtual]

Because we delegate to vtkContourValues

Reimplemented from vtkObject.

virtual void vtkSynchronizedTemplates3D::SetComputeNormals ( int ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkSynchronizedTemplates3D::GetComputeNormals ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::ComputeNormalsOn ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::ComputeNormalsOff ( ) [virtual]

Set/Get the computation of normals. Normal computation is fairly expensive in both time and storage. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::SetComputeGradients ( int ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual int vtkSynchronizedTemplates3D::GetComputeGradients ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::ComputeGradientsOn ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::ComputeGradientsOff ( ) [virtual]

Set/Get the computation of gradients. Gradient computation is fairly expensive in both time and storage. Note that if ComputeNormals is on, gradients will have to be calculated, but will not be stored in the output dataset. If the output data will be processed by filters that modify topology or geometry, it may be wise to turn Normals and Gradients off.

virtual void vtkSynchronizedTemplates3D::SetComputeScalars ( int ) [virtual]

Set/Get the computation of scalars.

virtual int vtkSynchronizedTemplates3D::GetComputeScalars ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkSynchronizedTemplates3D::ComputeScalarsOn ( ) [virtual]

Set/Get the computation of scalars.

virtual void vtkSynchronizedTemplates3D::ComputeScalarsOff ( ) [virtual]

Set/Get the computation of scalars.

void vtkSynchronizedTemplates3D::SetValue | ( | int | i,
 |  | float | value
 | ) | [inline]

Set a particular contour value at contour number i. The index i ranges between 0<=i<NumberOfContours.

Definition at line 112 of file vtkSynchronizedTemplates3D.h.

float vtkSynchronizedTemplates3D::GetValue ( int i ) [inline]

Get the ith contour value.

Definition at line 115 of file vtkSynchronizedTemplates3D.h.

float* vtkSynchronizedTemplates3D::GetValues ( ) [inline]

Get a pointer to an array of contour values. There will be GetNumberOfContours() values in the list.

Definition at line 119 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::GetValues ( float * contourValues ) [inline]

Fill a supplied list with contour values. There will be GetNumberOfContours() values in the list. Make sure you allocate enough memory to hold the list.

Definition at line 125 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::SetNumberOfContours ( int number ) [inline]

Set the number of contours to place into the list. You only really need to use this method to reduce list size. The method SetValue() will automatically increase list size as needed.

Definition at line 133 of file vtkSynchronizedTemplates3D.h.

int vtkSynchronizedTemplates3D::GetNumberOfContours ( ) [inline]

Get the number of contours in the list of contour values.

Definition at line 139 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::GenerateValues | ( | int | numContours,
 |  | float | range[2]
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 146 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::GenerateValues | ( | int | numContours,
 |  | float | rangeStart,
 |  | float | rangeEnd
 | ) | [inline]

Generate numContours equally spaced contour values between specified range. Contour values will include min/max range values.

Definition at line 153 of file vtkSynchronizedTemplates3D.h.

int* vtkSynchronizedTemplates3D::GetExecuteExtent ( ) [inline]

Needed by templated functions.

Definition at line 159 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::ThreadedExecute | ( | vtkImageData * | data,
 |  | int * | exExt,
 |  | int | threadId
 | ) |

Needed by templated functions.

virtual void vtkSynchronizedTemplates3D::SetNumberOfThreads ( int ) [virtual]

Get/Set the number of threads to create when rendering

virtual int vtkSynchronizedTemplates3D::GetNumberOfThreads ( ) [virtual]

Get/Set the number of threads to create when rendering

void vtkSynchronizedTemplates3D::SetInputMemoryLimit ( unsigned long limit )

Determines the chunk size fro streaming. This filter will act like a collector: ask for many input pieces, but generate one output. Limit is in KBytes

unsigned long vtkSynchronizedTemplates3D::GetInputMemoryLimit ( )

Determines the chunk size fro streaming. This filter will act like a collector: ask for many input pieces, but generate one output. Limit is in KBytes

virtual char* vtkSynchronizedTemplates3D::GetInputScalarsSelection ( ) [virtual]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkSynchronizedTemplates3D::SelectInputScalars ( const char * fieldName ) [inline]

If you want to contour by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 182 of file vtkSynchronizedTemplates3D.h.

void vtkSynchronizedTemplates3D::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkSynchronizedTemplates3D::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkSynchronizedTemplates3D::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

virtual void vtkSynchronizedTemplates3D::SetInputScalarsSelection ( const char * ) [protected, virtual]

Friends And Related Function Documentation

friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter [friend]

Definition at line 212 of file vtkSynchronizedTemplates3D.h.

Member Data Documentation

int vtkSynchronizedTemplates3D::ComputeNormals [protected]

Definition at line 190 of file vtkSynchronizedTemplates3D.h.

int vtkSynchronizedTemplates3D::ComputeGradients [protected]

Definition at line 191 of file vtkSynchronizedTemplates3D.h.

int vtkSynchronizedTemplates3D::ComputeScalars [protected]

Definition at line 192 of file vtkSynchronizedTemplates3D.h.

vtkContourValues* vtkSynchronizedTemplates3D::ContourValues [protected]

Definition at line 193 of file vtkSynchronizedTemplates3D.h.

int vtkSynchronizedTemplates3D::ExecuteExtent[6] [protected]

Definition at line 200 of file vtkSynchronizedTemplates3D.h.

int vtkSynchronizedTemplates3D::NumberOfThreads [protected]

Definition at line 202 of file vtkSynchronizedTemplates3D.h.

vtkMultiThreader* vtkSynchronizedTemplates3D::Threader [protected]

Definition at line 203 of file vtkSynchronizedTemplates3D.h.

vtkPolyData* vtkSynchronizedTemplates3D::Threads[VTK_MAX_THREADS] [protected]

Definition at line 205 of file vtkSynchronizedTemplates3D.h.

char* vtkSynchronizedTemplates3D::InputScalarsSelection [protected]

Definition at line 207 of file vtkSynchronizedTemplates3D.h.

The documentation for this class was generated from the following file:
  • Patented/vtkSynchronizedTemplates3D.h
Generated on Mon Mar 25 01:31:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkSystemIncludes Class Reference

transition VTK to ANSI C++, centralize inclusion of system files. More...

#include <vtkSystemIncludes.h>

Detailed Description

transition VTK to ANSI C++, centralize inclusion of system files.

Date:
2002/01/22 15:26:23
Revision:
1.15

The vtkSystemIncludes centralizes the inclusion of system include files. (This is particularly important as VTK moves towards ANSI C++.) For example, this include file enables user's to build VTK with STL (i.e., use std::ostream and other standard ANSI C++ functionality). A compile-time flag (VTK_USE_ANSI_STDLIB) must be set to enable ANSI C++ compliance. You'll probably also need to set various compiler flags. For example, on WIndows for ANSI C++, use /D "VTK_USE_ANSI_STDLIB" /GX /Zm1000 .

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (47%)
  • Henderson, Amy (31%)
  • Martin, Ken (11%)
  • Hoffman, Bill (6%)

The documentation for this class was generated from the following file:
  • Common/vtkSystemIncludes.h
Generated on Mon Mar 25 01:31:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTclCommand Class Reference

#include <vtkTclUtil.h>

Inheritance diagram for vtkTclCommand:

[legend]
Collaboration diagram for vtkTclCommand:

[legend]
List of all members.

Public Methods

void | SetStringCommand (const char *arg)
void | SetInterp (Tcl_Interp *interp)
void | Execute (vtkObject *, unsigned long, void *)

Static Public Methods

vtkTclCommand * | New ()

Public Attributes

char * | StringCommand
Tcl_Interp * | Interp

Protected Methods

vtkTclCommand ()
~vtkTclCommand ()

Constructor & Destructor Documentation

vtkTclCommand::vtkTclCommand ( ) [protected]

vtkTclCommand::~vtkTclCommand ( ) [protected]

Member Function Documentation

vtkTclCommand* vtkTclCommand::New ( ) [inline, static]

Definition at line 64 of file vtkTclUtil.h.

void vtkTclCommand::SetStringCommand ( const char * arg )

void vtkTclCommand::SetInterp ( Tcl_Interp * interp ) [inline]

Definition at line 67 of file vtkTclUtil.h.

void vtkTclCommand::Execute | ( | vtkObject * | ptr,
 |  | unsigned long | eventtype,
 |  | void * | callData
 | ) | [virtual]

Reimplemented from vtkCommand.

Member Data Documentation

char* vtkTclCommand::StringCommand

Definition at line 71 of file vtkTclUtil.h.

Tcl_Interp* vtkTclCommand::Interp

Definition at line 72 of file vtkTclUtil.h.

The documentation for this class was generated from the following file:
  • Common/vtkTclUtil.h
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTclCommandArgStruct Struct Reference

#include <vtkTclUtil.h>

Collaboration diagram for vtkTclCommandArgStruct:

[legend]
List of all members.

Public Attributes

void * | Pointer
Tcl_Interp * | Interp
unsigned long | Tag

Member Data Documentation

void* vtkTclCommandArgStruct::Pointer

Definition at line 86 of file vtkTclUtil.h.

Tcl_Interp* vtkTclCommandArgStruct::Interp

Definition at line 87 of file vtkTclUtil.h.

unsigned long vtkTclCommandArgStruct::Tag

Definition at line 88 of file vtkTclUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkTclUtil.h
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTclCommandStruct Struct Reference

#include <vtkTclUtil.h>

Collaboration diagram for vtkTclCommandStruct:

[legend]
List of all members.

Public Attributes

ClientData(* | NewCommand )()
int(* | CommandFunction )(ClientData cd, Tcl_Interp *interp, int argc, char *argv[])

Member Data Documentation

ClientData(* vtkTclCommandStruct::NewCommand)()

int(* vtkTclCommandStruct::CommandFunction)(ClientData cd, Tcl_Interp *interp, int argc, char *argv[])

The documentation for this struct was generated from the following file:
  • Common/vtkTclUtil.h
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTclInterpStruct Struct Reference

#include <vtkTclUtil.h>

Collaboration diagram for vtkTclInterpStruct:

[legend]
List of all members.

Public Attributes

Tcl_HashTable | InstanceLookup
Tcl_HashTable | PointerLookup
Tcl_HashTable | CommandLookup
int | Number
int | DebugOn
int | InDelete

Member Data Documentation

Tcl_HashTable vtkTclInterpStruct::InstanceLookup

Definition at line 100 of file vtkTclUtil.h.

Tcl_HashTable vtkTclInterpStruct::PointerLookup

Definition at line 101 of file vtkTclUtil.h.

Tcl_HashTable vtkTclInterpStruct::CommandLookup

Definition at line 102 of file vtkTclUtil.h.

int vtkTclInterpStruct::Number

Definition at line 104 of file vtkTclUtil.h.

int vtkTclInterpStruct::DebugOn

Definition at line 105 of file vtkTclUtil.h.

int vtkTclInterpStruct::InDelete

Definition at line 106 of file vtkTclUtil.h.

The documentation for this struct was generated from the following file:
  • Common/vtkTclUtil.h
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTensor Class Reference

supporting class to enable assignment and referencing of tensors. More...

#include <vtkTensor.h>

Inheritance diagram for vtkTensor:

[legend]
Collaboration diagram for vtkTensor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTensor, vtkObject)
void | Initialize ()
float | GetComponent (int i, int j)
void | DeepCopy (vtkTensor *t)
operator float * ()
void | SetComponent (int i, int j, float v)
void | AddComponent (int i, int j, float v)
float * | GetColumn (int j)

Static Public Methods

vtkTensor * | New ()

Public Attributes

float * | T

Protected Methods

vtkTensor ()
~vtkTensor ()

Protected Attributes

float | Storage [9]

Detailed Description

supporting class to enable assignment and referencing of tensors.

Date:
2002/01/22 15:26:25
Revision:
1.37

vtkTensor is a floating point representation of an nxn tensor. vtkTensor provides methods for assignment and reference of tensor components. It does it in such a way as to minimize data copying.

Warning:
vtkTensor performs its operations using pointer reference. You are responsible for supplying data storage (if necessary) if local copies of data are being made.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (58%)
  • Martin, Ken (20%)
  • Lorensen, Bill (8%)
  • Law, Charles (5%)

Definition at line 46 of file vtkTensor.h.

Constructor & Destructor Documentation

vtkTensor::vtkTensor ( ) [protected]

vtkTensor::~vtkTensor ( ) [inline, protected]

Definition at line 85 of file vtkTensor.h.

Member Function Documentation

vtkTensor* vtkTensor::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTensor::vtkTypeRevisionMacro | ( | vtkTensor | ,
 |  | vtkObject |
 | ) |

void vtkTensor::Initialize ( ) [inline]

Initialize tensor components to 0.0.

Definition at line 93 of file vtkTensor.h.

float vtkTensor::GetComponent | ( | int | i,
 |  | int | j
 | ) | [inline]

Get the tensor component (i,j).

Definition at line 56 of file vtkTensor.h.

void vtkTensor::SetComponent | ( | int | i,
 |  | int | j,
 |  | float | v
 | ) | [inline]

Set the value of the tensor component (i,j).

Definition at line 60 of file vtkTensor.h.

void vtkTensor::AddComponent | ( | int | i,
 |  | int | j,
 |  | float | v
 | ) | [inline]

Add to the value of the tensor component at location (i,j).

Definition at line 65 of file vtkTensor.h.

float* vtkTensor::GetColumn ( int j ) [inline]

Return column vector from tensor. (Assumes 2D matrix form and 0-offset.)

Definition at line 71 of file vtkTensor.h.

void vtkTensor::DeepCopy ( vtkTensor * t ) [inline]

Deep copy of one tensor to another tensor.

Definition at line 104 of file vtkTensor.h.

vtkTensor::operator float * ( ) [inline]

Provide float * type conversion.

Definition at line 78 of file vtkTensor.h.

Member Data Documentation

float* vtkTensor::T

Data member left public for efficiency.

Definition at line 81 of file vtkTensor.h.

Referenced by DeepCopy().

float vtkTensor::Storage[9] [protected]

Definition at line 87 of file vtkTensor.h.

The documentation for this class was generated from the following file:
  • Common/vtkTensor.h
Generated on Mon Mar 25 01:31:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTensorGlyph Class Reference

scale and orient glyph according to tensor eigenvalues and eigenvectors. More...

#include <vtkTensorGlyph.h>

Inheritance diagram for vtkTensorGlyph:

[legend]
Collaboration diagram for vtkTensorGlyph:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTensorGlyph, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetSource (vtkPolyData *source)
vtkPolyData * GetSource ()
virtual void | SetScaling (int)
virtual int | GetScaling ()
virtual void | ScalingOn ()
virtual void | ScalingOff ()
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetExtractEigenvalues (int)
virtual void | ExtractEigenvaluesOn ()
virtual void | ExtractEigenvaluesOff ()
virtual int | GetExtractEigenvalues ()
virtual void | SetColorGlyphs (int)
virtual int | GetColorGlyphs ()
virtual void | ColorGlyphsOn ()
virtual void | ColorGlyphsOff ()
virtual void | SetClampScaling (int)
virtual int | GetClampScaling ()
virtual void | ClampScalingOn ()
virtual void | ClampScalingOff ()
virtual void | SetMaxScaleFactor (float)
virtual float | GetMaxScaleFactor ()

Static Public Methods

vtkTensorGlyph * | New ()

Protected Methods

vtkTensorGlyph ()
~vtkTensorGlyph ()
void | Execute ()

Protected Attributes

int | Scaling
float | ScaleFactor
int | ExtractEigenvalues
int | ColorGlyphs
int | ClampScaling
float | MaxScaleFactor

Detailed Description

scale and orient glyph according to tensor eigenvalues and eigenvectors.

Date:
2002/01/22 15:29:50
Revision:
1.38

vtkTensorGlyph is a filter that copies a geometric representation (specified as polygonal data) to every input point. The geometric representation, or glyph, can be scaled and/or rotated according to the tensor at the input point. Scaling and rotation is controlled by the eigenvalues/eigenvectors of the tensor as follows. For each tensor, the eigenvalues (and associated eigenvectors) are sorted to determine the major, medium, and minor eigenvalues/eigenvectors. The major eigenvalue scales the glyph in the x-direction, the medium in the y-direction, and the minor in the z-direction. Then, the glyph is rotated so that the glyph's local x-axis lies along the major eigenvector, y-axis along the medium eigenvector, and z-axis along the minor.

A scale factor is provided to control the amount of scaling. Also, you can turn off scaling completely if desired. The boolean variable ClampScaling controls the maximum scaling (in conjunction with MaxScaleFactor.) This is useful in certain applications where singularities or large order of magnitude differences exist in the eigenvalues.

Another instance variable, ExtractEigenvalues, has been provided to control extraction of eigenvalues/eigenvectors. If this boolean is false, then eigenvalues/eigenvectors are not extracted, and the columns of the tensor are taken as the eigenvectors (norm of column is eigenvalue). This allows additional capability over the vtkGlyph3D object. That is, the glyph can be oriented in three directions instead of one.

See also:
vtkGlyph3D vtkPointLoad vtkHyperStreamline
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Martin, Ken (11%)
  • Lorensen, Bill (10%)
Tests:
vtkTensorGlyph (Tests)

Definition at line 68 of file vtkTensorGlyph.h.

Constructor & Destructor Documentation

vtkTensorGlyph::vtkTensorGlyph ( ) [protected]

vtkTensorGlyph::~vtkTensorGlyph ( ) [protected]

Member Function Documentation

vtkTensorGlyph::vtkTypeRevisionMacro | ( | vtkTensorGlyph | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkTensorGlyph::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTensorGlyph* vtkTensorGlyph::New ( ) [static]

Construct object with scaling on and scale factor 1.0. Eigenvalues are extracted, glyphs are colored with input scalar data, and logarithmic scaling is turned off.

Reimplemented from vtkPolyDataSource.

void vtkTensorGlyph::SetSource ( vtkPolyData * source )

Specify the geometry to copy to each point.

vtkPolyData* vtkTensorGlyph::GetSource ( )

Specify the geometry to copy to each point.

virtual void vtkTensorGlyph::SetScaling ( int ) [virtual]

Turn on/off scaling of glyph with eigenvalues.

virtual int vtkTensorGlyph::GetScaling ( ) [virtual]

Turn on/off scaling of glyph with eigenvalues.

virtual void vtkTensorGlyph::ScalingOn ( ) [virtual]

Turn on/off scaling of glyph with eigenvalues.

virtual void vtkTensorGlyph::ScalingOff ( ) [virtual]

Turn on/off scaling of glyph with eigenvalues.

virtual void vtkTensorGlyph::SetScaleFactor ( float ) [virtual]

Specify scale factor to scale object by. (Scale factor always affects output even if scaling is off.)

virtual float vtkTensorGlyph::GetScaleFactor ( ) [virtual]

Specify scale factor to scale object by. (Scale factor always affects output even if scaling is off.)

virtual void vtkTensorGlyph::SetExtractEigenvalues ( int ) [virtual]

Turn on/off extraction of eigenvalues from tensor.

virtual void vtkTensorGlyph::ExtractEigenvaluesOn ( ) [virtual]

Turn on/off extraction of eigenvalues from tensor.

virtual void vtkTensorGlyph::ExtractEigenvaluesOff ( ) [virtual]

Turn on/off extraction of eigenvalues from tensor.

virtual int vtkTensorGlyph::GetExtractEigenvalues ( ) [virtual]

Turn on/off extraction of eigenvalues from tensor.

virtual void vtkTensorGlyph::SetColorGlyphs ( int ) [virtual]

Turn on/off coloring of glyph with input scalar data. If false, or input scalar data not present, then the scalars from the source object are passed through the filter.

virtual int vtkTensorGlyph::GetColorGlyphs ( ) [virtual]

Turn on/off coloring of glyph with input scalar data. If false, or input scalar data not present, then the scalars from the source object are passed through the filter.

virtual void vtkTensorGlyph::ColorGlyphsOn ( ) [virtual]

Turn on/off coloring of glyph with input scalar data. If false, or input scalar data not present, then the scalars from the source object are passed through the filter.

virtual void vtkTensorGlyph::ColorGlyphsOff ( ) [virtual]

Turn on/off coloring of glyph with input scalar data. If false, or input scalar data not present, then the scalars from the source object are passed through the filter.

virtual void vtkTensorGlyph::SetClampScaling ( int ) [virtual]

Turn on/off scalar clamping. If scalar clamping is on, the ivar MaxScaleFactor is used to control the maximum scale factor. (This is useful to prevent uncontrolled scaling near singularities.)

virtual int vtkTensorGlyph::GetClampScaling ( ) [virtual]

Turn on/off scalar clamping. If scalar clamping is on, the ivar MaxScaleFactor is used to control the maximum scale factor. (This is useful to prevent uncontrolled scaling near singularities.)

virtual void vtkTensorGlyph::ClampScalingOn ( ) [virtual]

Turn on/off scalar clamping. If scalar clamping is on, the ivar MaxScaleFactor is used to control the maximum scale factor. (This is useful to prevent uncontrolled scaling near singularities.)

virtual void vtkTensorGlyph::ClampScalingOff ( ) [virtual]

Turn on/off scalar clamping. If scalar clamping is on, the ivar MaxScaleFactor is used to control the maximum scale factor. (This is useful to prevent uncontrolled scaling near singularities.)

virtual void vtkTensorGlyph::SetMaxScaleFactor ( float ) [virtual]

Set/Get the maximum allowable scale factor. This value is compared to the combination of the scale factor times the eigenvalue. If less, the scale factor is reset to the MaxScaleFactor. The boolean ClampScaling has to be "on" for this to work.

virtual float vtkTensorGlyph::GetMaxScaleFactor ( ) [virtual]

Set/Get the maximum allowable scale factor. This value is compared to the combination of the scale factor times the eigenvalue. If less, the scale factor is reset to the MaxScaleFactor. The boolean ClampScaling has to be "on" for this to work.

void vtkTensorGlyph::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkTensorGlyph::Scaling [protected]

Definition at line 139 of file vtkTensorGlyph.h.

float vtkTensorGlyph::ScaleFactor [protected]

Definition at line 140 of file vtkTensorGlyph.h.

int vtkTensorGlyph::ExtractEigenvalues [protected]

Definition at line 141 of file vtkTensorGlyph.h.

int vtkTensorGlyph::ColorGlyphs [protected]

Definition at line 142 of file vtkTensorGlyph.h.

int vtkTensorGlyph::ClampScaling [protected]

Definition at line 143 of file vtkTensorGlyph.h.

float vtkTensorGlyph::MaxScaleFactor [protected]

Definition at line 144 of file vtkTensorGlyph.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTensorGlyph.h
Generated on Mon Mar 25 01:31:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTetra Class Reference

a 3D cell that represents a tetrahedron. More...

#include <vtkTetra.h>

Inheritance diagram for vtkTetra:

[legend]
Collaboration diagram for vtkTetra:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTetra, vtkCell)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
int | GetParametricCenter (float pcoords[3])
int | JacobianInverse (double **inverse, float derivs[12])
virtual void | GetEdgePoints (int edgeId, int *&pts)
virtual void | GetFacePoints (int faceId, int *&pts)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkTetra * | New ()
void | TetraCenter (float p1[3], float p2[3], float p3[3], float p4[3], float center[3])
double | Circumsphere (double p1[3], double p2[3], double p3[3], double p4[3], double center[3])
int | BarycentricCoords (double x[3], double x1[3], double x2[3], double x3[3], double x4[3], double bcoords[4])
double | ComputeVolume (double p1[3], double p2[3], double p3[3], double p4[3])
void | InterpolationFunctions (float pcoords[3], float weights[4])
void | InterpolationDerivs (float derivs[12])
int * | GetEdgeArray (int edgeId)
int * | GetFaceArray (int faceId)

Protected Methods

vtkTetra ()
~vtkTetra ()

Protected Attributes

vtkLine * Line
vtkTriangle * Triangle

Detailed Description

a 3D cell that represents a tetrahedron.

Date:
2002/01/22 15:26:26
Revision:
1.68

vtkTetra is a concrete implementation of vtkCell to represent a 3D tetrahedron.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Martin, Ken (13%)
Examples:
vtkTetra (Examples)
Tests:
vtkTetra (Tests)

Definition at line 48 of file vtkTetra.h.

Constructor & Destructor Documentation

vtkTetra::vtkTetra ( ) [protected]

vtkTetra::~vtkTetra ( ) [protected]

Member Function Documentation

vtkTetra* vtkTetra::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTetra::vtkTypeRevisionMacro | ( | vtkTetra | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell3D.

virtual void vtkTetra::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

virtual void vtkTetra::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

vtkCell* vtkTetra::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTetra::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 63 of file vtkTetra.h.

int vtkTetra::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 64 of file vtkTetra.h.

int vtkTetra::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 65 of file vtkTetra.h.

vtkCell* vtkTetra::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkTetra::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTetra::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTetra::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | connectivity,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell3D.

int vtkTetra::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTetra::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTetra::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTetra::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTetra::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTetra::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

Returns the set of points that are on the boundary of the tetrahedron that are closest parametrically to the point specified. This may include faces, edges, or vertices.

Reimplemented from vtkCell.

int vtkTetra::GetParametricCenter ( float pcoords[3] ) [inline, virtual]

Return the center of the tetrahedron in parametric coordinates.

Reimplemented from vtkCell.

Definition at line 159 of file vtkTetra.h.

void vtkTetra::TetraCenter | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | p3[3],
 |  | float | p4[3],
 |  | float | center[3]
 | ) | [static]

Compute the center of the tetrahedron,

double vtkTetra::Circumsphere | ( | double | p1[3],
 |  | double | p2[3],
 |  | double | p3[3],
 |  | double | p4[3],
 |  | double | center[3]
 | ) | [static]

Compute the circumcenter (center[3]) and radius (method return value) of a tetrahedron defined by the four points x1, x2, x3, and x4.

int vtkTetra::BarycentricCoords | ( | double | x[3],
 |  | double | x1[3],
 |  | double | x2[3],
 |  | double | x3[3],
 |  | double | x4[3],
 |  | double | bcoords[4]
 | ) | [static]

Given a 3D point x[3], determine the barycentric coordinates of the point. Barycentric coordinates are a natural coordinate system for simplices that express a position as a linear combination of the vertices. For a tetrahedron, there are four barycentric coordinates (because there are four vertices), and the sum of the coordinates must equal 1. If a point x is inside a simplex, then all four coordinates will be strictly positive. If three coordinates are zero (so the fourth =1), then the point x is on a vertex. If two coordinates are zero, the point x is on an edge (and so on). In this method, you must specify the vertex coordinates x1->x4. Returns 0 if tetrahedron is degenerate.

double vtkTetra::ComputeVolume | ( | double | p1[3],
 |  | double | p2[3],
 |  | double | p3[3],
 |  | double | p4[3]
 | ) | [static]

Compute the volume of a tetrahedron defined by the four points p1, p2, p3, and p4.

int vtkTetra::JacobianInverse | ( | double ** | inverse,
 |  | float | derivs[12]
 | ) |

Given parametric coordinates compute inverse Jacobian transformation matrix. Returns 9 elements of 3x3 inverse Jacobian plus interpolation function derivatives. Returns 0 if no inverse exists.

void vtkTetra::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[4]
 | ) | [static]

Tetra specific methods.

void vtkTetra::InterpolationDerivs ( float derivs[12] ) [static]

Tetra specific methods.

int* vtkTetra::GetEdgeArray ( int edgeId ) [static]

Tetra specific methods.

int* vtkTetra::GetFaceArray ( int faceId ) [static]

Tetra specific methods.

Member Data Documentation

vtkLine* vtkTetra::Line [protected]

Definition at line 151 of file vtkTetra.h.

vtkTriangle* vtkTetra::Triangle [protected]

Definition at line 152 of file vtkTetra.h.

The documentation for this class was generated from the following file:
  • Common/vtkTetra.h
Generated on Mon Mar 25 01:32:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextMapper Class Reference

2D text annotation. More...

#include <vtkTextMapper.h>

Inheritance diagram for vtkTextMapper:

[legend]
Collaboration diagram for vtkTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTextMapper, vtkMapper2D)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetFontSize (int size)
void | ShallowCopy (vtkTextMapper *tm)
int | GetNumberOfLines (const char *input)
virtual void | GetSize (vtkViewport *, int size[2])
int | GetWidth (vtkViewport *)
int | GetHeight (vtkViewport *)
void | SetInput (const char *inputString)
virtual char * | GetInput ()
virtual int | GetFontSize ()
void | SetBold (int val)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
void | SetItalic (int val)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
void | SetShadow (int val)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
void | SetFontFamily (int val)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetJustification (int)
virtual int | GetJustification ()
void | SetJustificationToLeft ()
void | SetJustificationToCentered ()
void | SetJustificationToRight ()
virtual void | SetVerticalJustification (int)
virtual int | GetVerticalJustification ()
void | SetVerticalJustificationToBottom ()
void | SetVerticalJustificationToCentered ()
void | SetVerticalJustificationToTop ()
virtual void | SetLineOffset (float)
virtual float | GetLineOffset ()
virtual void | SetLineSpacing (float)
virtual float | GetLineSpacing ()
virtual int | GetNumberOfLines ()

Static Public Methods

vtkTextMapper * | New ()

Protected Methods

vtkTextMapper ()
~vtkTextMapper ()
char * | NextLine (const char *input, int lineNum)
void | GetMultiLineSize (vtkViewport *viewport, int size[2])
void | RenderOverlayMultipleLines (vtkViewport *viewport, vtkActor2D *actor)
void | RenderOpaqueGeometryMultipleLines (vtkViewport *viewport, vtkActor2D *actor)

Protected Attributes

int | Italic
int | Bold
int | Shadow
int | FontSize
int | FontFamily
char * | Input
int | Justification
int | VerticalJustification
vtkTimeStamp FontMTime
int | LineSize
float | LineOffset
float | LineSpacing
int | NumberOfLines
int | NumberOfLinesAllocated
vtkTextMapper ** | TextLines

Detailed Description

2D text annotation.

Date:
2002/01/22 15:39:26
Revision:
1.39

vtkTextMapper provides 2D text annotation support for vtk. It is a vtkMapper2D that can be associated with a vtkActor2D and placed into a vtkRenderer or vtkImager.

To use vtkTextMapper, specify an input text string, a font size, a font name, and whether to turn on bold or shadows (shadows make the font more visible when on top of other objects). You'll also need to create a vtkActor2D and add it to the renderer or imager. You can create multiple lines by embedding "
" in the Input string.

The position of the text can be controlled by setting the justification to right, centered, or left. If you have specified multiple lines, all lines will be justified the same way.

See also:
vtkMapper2D vtkActor2D vtkLegendBoxActor vtkCaptionActor2D vtkVectorText
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (55%)
  • Schroeder, Will (30%)
  • Miller, Jim (5%)
Examples:
vtkTextMapper (Examples)
Tests:
vtkTextMapper (Tests)

Definition at line 74 of file vtkTextMapper.h.

Constructor & Destructor Documentation

vtkTextMapper::vtkTextMapper ( ) [protected]

vtkTextMapper::~vtkTextMapper ( ) [protected]

Member Function Documentation

vtkTextMapper::vtkTypeRevisionMacro | ( | vtkTextMapper | ,
 |  | vtkMapper2D |
 | ) |

Reimplemented from vtkMapper2D.

Reimplemented in vtkQuartzTextMapper, vtkWin32OpenGLTextMapper, vtkWin32TextMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, and vtkXTextMapper.

void vtkTextMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMapper2D.

vtkTextMapper* vtkTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkMapper2D.

Reimplemented in vtkQuartzTextMapper, vtkWin32OpenGLTextMapper, vtkWin32TextMapper, vtkXMesaTextMapper, vtkXOpenGLTextMapper, and vtkXTextMapper.

virtual void vtkTextMapper::GetSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [inline, virtual]

Return the size[2]/width/height of the rectangle required to draw this mapper (in pixels).

Reimplemented in vtkQuartzTextMapper, vtkWin32TextMapper, and vtkXTextMapper.

Definition at line 87 of file vtkTextMapper.h.

int vtkTextMapper::GetWidth ( vtkViewport * )

Return the size[2]/width/height of the rectangle required to draw this mapper (in pixels).

int vtkTextMapper::GetHeight ( vtkViewport * )

Return the size[2]/width/height of the rectangle required to draw this mapper (in pixels).

void vtkTextMapper::SetInput ( const char * inputString )

Set the input text string to the mapper. The mapper recognizes "
" as a carriage return/linefeed (line separator).

virtual char* vtkTextMapper::GetInput ( ) [virtual]

Set the input text string to the mapper. The mapper recognizes "
" as a carriage return/linefeed (line separator).

virtual void vtkTextMapper::SetFontSize ( int size ) [virtual]

Set the font size used by the mapper. The subclasses can override this function since all font sizes may not be available (especially in X).

Reimplemented in vtkXTextMapper.

virtual int vtkTextMapper::GetFontSize ( ) [virtual]

Return the font size actually in use by the mapper. This value may not match the value specified in the last SetFontSize if the last size was unavailable.

void vtkTextMapper::SetBold ( int val )

Enable/disable text bolding.

virtual int vtkTextMapper::GetBold ( ) [virtual]

Enable/disable text bolding.

virtual void vtkTextMapper::BoldOn ( ) [virtual]

Enable/disable text bolding.

virtual void vtkTextMapper::BoldOff ( ) [virtual]

Enable/disable text bolding.

void vtkTextMapper::SetItalic ( int val )

Enable/disable text italic.

virtual int vtkTextMapper::GetItalic ( ) [virtual]

Enable/disable text italic.

virtual void vtkTextMapper::ItalicOn ( ) [virtual]

Enable/disable text italic.

virtual void vtkTextMapper::ItalicOff ( ) [virtual]

Enable/disable text italic.

void vtkTextMapper::SetShadow ( int val )

Enable/disable text shadows.

virtual int vtkTextMapper::GetShadow ( ) [virtual]

Enable/disable text shadows.

virtual void vtkTextMapper::ShadowOn ( ) [virtual]

Enable/disable text shadows.

virtual void vtkTextMapper::ShadowOff ( ) [virtual]

Enable/disable text shadows.

void vtkTextMapper::SetFontFamily ( int val )

Set/Get the font family. Three font types are allowed: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkTextMapper::GetFontFamily ( ) [virtual]

Set/Get the font family. Three font types are allowed: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkTextMapper::SetFontFamilyToArial ( ) [inline]

Set/Get the font family. Three font types are allowed: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 137 of file vtkTextMapper.h.

void vtkTextMapper::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family. Three font types are allowed: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 138 of file vtkTextMapper.h.

void vtkTextMapper::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family. Three font types are allowed: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 139 of file vtkTextMapper.h.

virtual void vtkTextMapper::SetJustification ( int ) [virtual]

Set/Get the horizontal justification to left (default), centered, or right.

virtual int vtkTextMapper::GetJustification ( ) [virtual]

Set/Get the horizontal justification to left (default), centered, or right.

void vtkTextMapper::SetJustificationToLeft ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 147 of file vtkTextMapper.h.

void vtkTextMapper::SetJustificationToCentered ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 148 of file vtkTextMapper.h.

void vtkTextMapper::SetJustificationToRight ( ) [inline]

Set/Get the horizontal justification to left (default), centered, or right.

Definition at line 149 of file vtkTextMapper.h.

virtual void vtkTextMapper::SetVerticalJustification ( int ) [virtual]

Set/Get the vertical justification to bottom (default), middle, or top.

virtual int vtkTextMapper::GetVerticalJustification ( ) [virtual]

Set/Get the vertical justification to bottom (default), middle, or top.

void vtkTextMapper::SetVerticalJustificationToBottom ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 157 of file vtkTextMapper.h.

void vtkTextMapper::SetVerticalJustificationToCentered ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 159 of file vtkTextMapper.h.

void vtkTextMapper::SetVerticalJustificationToTop ( ) [inline]

Set/Get the vertical justification to bottom (default), middle, or top.

Definition at line 161 of file vtkTextMapper.h.

virtual void vtkTextMapper::SetLineOffset ( float ) [virtual]

These methods can be used to control the spacing and placement of text (in the vertical direction). LineOffset is a vertical offset (measured in lines); LineSpacing is the spacing between lines.

virtual float vtkTextMapper::GetLineOffset ( ) [virtual]

These methods can be used to control the spacing and placement of text (in the vertical direction). LineOffset is a vertical offset (measured in lines); LineSpacing is the spacing between lines.

virtual void vtkTextMapper::SetLineSpacing ( float ) [virtual]

These methods can be used to control the spacing and placement of text (in the vertical direction). LineOffset is a vertical offset (measured in lines); LineSpacing is the spacing between lines.

virtual float vtkTextMapper::GetLineSpacing ( ) [virtual]

These methods can be used to control the spacing and placement of text (in the vertical direction). LineOffset is a vertical offset (measured in lines); LineSpacing is the spacing between lines.

virtual int vtkTextMapper::GetNumberOfLines ( ) [virtual]

These methods can be used to control the spacing and placement of text (in the vertical direction). LineOffset is a vertical offset (measured in lines); LineSpacing is the spacing between lines.

void vtkTextMapper::ShallowCopy ( vtkTextMapper * tm )

Shallow copy of an actor.

int vtkTextMapper::GetNumberOfLines ( const char * input )

Determine the number of lines in the Input string (delimited by "
").

char* vtkTextMapper::NextLine | ( | const char * | input,
 |  | int | lineNum
 | ) | [protected]

void vtkTextMapper::GetMultiLineSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [protected]

void vtkTextMapper::RenderOverlayMultipleLines | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [protected]

void vtkTextMapper::RenderOpaqueGeometryMultipleLines | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [protected]

Member Data Documentation

int vtkTextMapper::Italic [protected]

Definition at line 187 of file vtkTextMapper.h.

int vtkTextMapper::Bold [protected]

Definition at line 188 of file vtkTextMapper.h.

int vtkTextMapper::Shadow [protected]

Definition at line 189 of file vtkTextMapper.h.

int vtkTextMapper::FontSize [protected]

Definition at line 190 of file vtkTextMapper.h.

int vtkTextMapper::FontFamily [protected]

Definition at line 191 of file vtkTextMapper.h.

char* vtkTextMapper::Input [protected]

Definition at line 192 of file vtkTextMapper.h.

int vtkTextMapper::Justification [protected]

Definition at line 193 of file vtkTextMapper.h.

int vtkTextMapper::VerticalJustification [protected]

Definition at line 194 of file vtkTextMapper.h.

vtkTimeStamp vtkTextMapper::FontMTime [protected]

Definition at line 195 of file vtkTextMapper.h.

int vtkTextMapper::LineSize [protected]

Definition at line 197 of file vtkTextMapper.h.

float vtkTextMapper::LineOffset [protected]

Definition at line 198 of file vtkTextMapper.h.

float vtkTextMapper::LineSpacing [protected]

Definition at line 199 of file vtkTextMapper.h.

int vtkTextMapper::NumberOfLines [protected]

Definition at line 200 of file vtkTextMapper.h.

int vtkTextMapper::NumberOfLinesAllocated [protected]

Definition at line 201 of file vtkTextMapper.h.

vtkTextMapper** vtkTextMapper::TextLines [protected]

Definition at line 202 of file vtkTextMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkTextMapper.h
Generated on Mon Mar 25 01:32:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextSource Class Reference

create polygonal text. More...

#include <vtkTextSource.h>

Inheritance diagram for vtkTextSource:

[legend]
Collaboration diagram for vtkTextSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTextSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetText (const char *)
virtual char * | GetText ()
virtual void | SetBacking (int)
virtual int | GetBacking ()
virtual void | BackingOn ()
virtual void | BackingOff ()
virtual void | SetForegroundColor (float, float, float)
virtual void | SetForegroundColor (float[3])
virtual float * | GetForegroundColor ()
virtual void | GetForegroundColor (float data[3])
virtual void | SetBackgroundColor (float, float, float)
virtual void | SetBackgroundColor (float[3])
virtual float * | GetBackgroundColor ()
virtual void | GetBackgroundColor (float data[3])

Static Public Methods

vtkTextSource * | New ()

Protected Methods

vtkTextSource ()
~vtkTextSource ()
void | Execute ()

Protected Attributes

char * | Text
int | Backing
float | ForegroundColor [4]
float | BackgroundColor [4]

Detailed Description

create polygonal text.

Date:
2002/01/22 15:29:51
Revision:
1.39

vtkTextSource converts a text string into polygons. This way you can insert text into your renderings. It uses the 9x15 font from X Windows. You can specify if you want the background to be drawn or not. The characters are formed by scan converting the raster font into quadrilaterals. Colors are assigned to the letters using scalar data. To set the color of the characters with the source's actor property, set BackingOff on the text source and ScalarVisibilityOff on the associated vtkPolyDataMapper. Then, the color can be set using the associated actor's property.

vtkVectorText generates higher quality polygonal representations of characters.

See also:
vtkVectorText
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (59%)
  • Lorensen, Bill (20%)
  • Geveci, Berk (12%)
Tests:
vtkTextSource (Tests)

Definition at line 55 of file vtkTextSource.h.

Constructor & Destructor Documentation

vtkTextSource::vtkTextSource ( ) [protected]

vtkTextSource::~vtkTextSource ( ) [protected]

Member Function Documentation

vtkTextSource::vtkTypeRevisionMacro | ( | vtkTextSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkTextSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTextSource* vtkTextSource::New ( ) [static]

Construct object with no string set and backing enabled.

Reimplemented from vtkPolyDataSource.

virtual void vtkTextSource::SetText ( const char * ) [virtual]

Set/Get the text to be drawn.

virtual char* vtkTextSource::GetText ( ) [virtual]

Set/Get the text to be drawn.

virtual void vtkTextSource::SetBacking ( int ) [virtual]

Controls whether or not a background is drawn with the text.

virtual int vtkTextSource::GetBacking ( ) [virtual]

Controls whether or not a background is drawn with the text.

virtual void vtkTextSource::BackingOn ( ) [virtual]

Controls whether or not a background is drawn with the text.

virtual void vtkTextSource::BackingOff ( ) [virtual]

Controls whether or not a background is drawn with the text.

virtual void vtkTextSource::SetForegroundColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the foreground color. Default is white (1,1,1). ALpha is always 1.

virtual void vtkTextSource::SetForegroundColor ( float [3] ) [virtual]

Set/Get the foreground color. Default is white (1,1,1). ALpha is always 1.

virtual float* vtkTextSource::GetForegroundColor ( ) [virtual]

Set/Get the foreground color. Default is white (1,1,1). ALpha is always 1.

virtual void vtkTextSource::GetForegroundColor ( float data[3] ) [virtual]

Set/Get the foreground color. Default is white (1,1,1). ALpha is always 1.

virtual void vtkTextSource::SetBackgroundColor | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the background color. Default is black (0,0,0). Alpha is always 1.

virtual void vtkTextSource::SetBackgroundColor ( float [3] ) [virtual]

Set/Get the background color. Default is black (0,0,0). Alpha is always 1.

virtual float* vtkTextSource::GetBackgroundColor ( ) [virtual]

Set/Get the background color. Default is black (0,0,0). Alpha is always 1.

virtual void vtkTextSource::GetBackgroundColor ( float data[3] ) [virtual]

Set/Get the background color. Default is black (0,0,0). Alpha is always 1.

void vtkTextSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkTextSource::Text [protected]

Definition at line 96 of file vtkTextSource.h.

int vtkTextSource::Backing [protected]

Definition at line 97 of file vtkTextSource.h.

float vtkTextSource::ForegroundColor[4] [protected]

Definition at line 98 of file vtkTextSource.h.

float vtkTextSource::BackgroundColor[4] [protected]

Definition at line 99 of file vtkTextSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTextSource.h
Generated on Mon Mar 25 01:32:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTexture Class Reference

handles properties associated with a texture map. More...

#include <vtkTexture.h>

Inheritance diagram for vtkTexture:

[legend]
Collaboration diagram for vtkTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTexture, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Render (vtkRenderer *ren)
virtual void | ReleaseGraphicsResources (vtkWindow *)
virtual void | Load (vtkRenderer *)
unsigned char * | MapScalarsToColors (vtkDataArray *scalars)
virtual int | GetRepeat ()
virtual void | SetRepeat (int)
virtual void | RepeatOn ()
virtual void | RepeatOff ()
virtual int | GetInterpolate ()
virtual void | SetInterpolate (int)
virtual void | InterpolateOn ()
virtual void | InterpolateOff ()
virtual void | SetQuality (int)
virtual int | GetQuality ()
void | SetQualityToDefault ()
void | SetQualityTo16Bit ()
void | SetQualityTo32Bit ()
virtual int | GetMapColorScalarsThroughLookupTable ()
virtual void | SetMapColorScalarsThroughLookupTable (int)
virtual void | MapColorScalarsThroughLookupTableOn ()
virtual void | MapColorScalarsThroughLookupTableOff ()
void | SetInput (vtkImageData *input)
vtkImageData * GetInput ()
void | SetLookupTable (vtkLookupTable *)
virtual vtkLookupTable * | GetLookupTable ()
virtual vtkUnsignedCharArray * | GetMappedScalars ()

Static Public Methods

vtkTexture * | New ()

Protected Methods

vtkTexture ()
~vtkTexture ()

Protected Attributes

int | Repeat
int | Interpolate
int | Quality
int | MapColorScalarsThroughLookupTable
vtkLookupTable * LookupTable
vtkUnsignedCharArray * MappedScalars
int | SelfAdjustingTableRange

Detailed Description

handles properties associated with a texture map.

Date:
2002/01/22 15:39:26
Revision:
1.55

vtkTexture is an object that handles loading and binding of texture maps. It obtains its data from an input image data dataset type. Thus you can create visualization pipelines to read, process, and construct textures. Note that textures will only work if texture coordinates are also defined, and if the rendering system supports texture.

Instances of vtkTexture are associated with actors via the actor's SetTexture() method. Actors can share texture maps (this is encouraged to save memory resources.)

Warning:
Currently only 2D texture maps are supported, even though the data pipeline supports 1,2, and 3D texture coordinates.
Warning:
Some renderers such as OpenGL require that the texture map dimensions are a power of two in each direction. Other renderers may have similar (ridiculous) restrictions, so be careful out there... (Note: a recent change to vtk allows use of non-power of two texture maps in OpenGL. The texture is automatically resampled to a power of two in one or more directions.)
See also:
vtkActor vtkRenderer vtkOpenGLTexture
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (48%)
  • Lorensen, Bill (20%)
  • Schroeder, Will (9%)
  • Law, Charles (6%)
  • Gobbi, David (6%)
Examples:
vtkTexture (Examples)
Tests:
vtkTexture (Tests)

Definition at line 79 of file vtkTexture.h.

Constructor & Destructor Documentation

vtkTexture::vtkTexture ( ) [protected]

vtkTexture::~vtkTexture ( ) [protected]

Member Function Documentation

vtkTexture* vtkTexture::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkMesaTexture, and vtkOpenGLTexture.

vtkTexture::vtkTypeRevisionMacro | ( | vtkTexture | ,
 |  | vtkObject |
 | ) |

Reimplemented from vtkProcessObject.

Reimplemented in vtkMesaTexture, and vtkOpenGLTexture.

void vtkTexture::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

virtual void vtkTexture::Render ( vtkRenderer * ren ) [virtual]

Renders a texture map. It first checks the object's modified time to make sure the texture maps Input is valid, then it invokes the Load() method.

virtual void vtkTexture::ReleaseGraphicsResources ( vtkWindow * ) [inline, virtual]

Release any graphics resources that are being consumed by this texture. The parameter window could be used to determine which graphic resources to release.

Reimplemented in vtkMesaTexture, and vtkOpenGLTexture.

Definition at line 94 of file vtkTexture.h.

virtual void vtkTexture::Load ( vtkRenderer * ren ) [inline, virtual]

Abstract interface to renderer. Each concrete subclass of vtkTexture will load its data into graphics system in response to this method invocation.

Reimplemented in vtkMesaTexture, and vtkOpenGLTexture.

Definition at line 99 of file vtkTexture.h.

virtual int vtkTexture::GetRepeat ( ) [virtual]

Turn on/off the repetition of the texture map when the texture coords extend beyond the [0,1] range.

virtual void vtkTexture::SetRepeat ( int ) [virtual]

Turn on/off the repetition of the texture map when the texture coords extend beyond the [0,1] range.

virtual void vtkTexture::RepeatOn ( ) [virtual]

Turn on/off the repetition of the texture map when the texture coords extend beyond the [0,1] range.

virtual void vtkTexture::RepeatOff ( ) [virtual]

Turn on/off the repetition of the texture map when the texture coords extend beyond the [0,1] range.

virtual int vtkTexture::GetInterpolate ( ) [virtual]

Turn on/off linear interpolation of the texture map when rendering.

virtual void vtkTexture::SetInterpolate ( int ) [virtual]

Turn on/off linear interpolation of the texture map when rendering.

virtual void vtkTexture::InterpolateOn ( ) [virtual]

Turn on/off linear interpolation of the texture map when rendering.

virtual void vtkTexture::InterpolateOff ( ) [virtual]

Turn on/off linear interpolation of the texture map when rendering.

virtual void vtkTexture::SetQuality ( int ) [virtual]

Force texture quality to 16-bit or 32-bit. This might not be supported on all machines.

virtual int vtkTexture::GetQuality ( ) [virtual]

Force texture quality to 16-bit or 32-bit. This might not be supported on all machines.

void vtkTexture::SetQualityToDefault ( ) [inline]

Force texture quality to 16-bit or 32-bit. This might not be supported on all machines.

Definition at line 121 of file vtkTexture.h.

void vtkTexture::SetQualityTo16Bit ( ) [inline]

Force texture quality to 16-bit or 32-bit. This might not be supported on all machines.

Definition at line 122 of file vtkTexture.h.

void vtkTexture::SetQualityTo32Bit ( ) [inline]

Force texture quality to 16-bit or 32-bit. This might not be supported on all machines.

Definition at line 123 of file vtkTexture.h.

virtual int vtkTexture::GetMapColorScalarsThroughLookupTable ( ) [virtual]

Turn on/off the mapping of color scalars through the lookup table. The default is Off. If Off, unsigned char scalars will be used directly as texture. If On, scalars will be mapped through the lookup table to generate 4-component unsigned char scalars. This ivar does not affect other scalars like unsigned short, float, etc. These scalars are always mapped through lookup tables.

virtual void vtkTexture::SetMapColorScalarsThroughLookupTable ( int ) [virtual]

Turn on/off the mapping of color scalars through the lookup table. The default is Off. If Off, unsigned char scalars will be used directly as texture. If On, scalars will be mapped through the lookup table to generate 4-component unsigned char scalars. This ivar does not affect other scalars like unsigned short, float, etc. These scalars are always mapped through lookup tables.

virtual void vtkTexture::MapColorScalarsThroughLookupTableOn ( ) [virtual]

Turn on/off the mapping of color scalars through the lookup table. The default is Off. If Off, unsigned char scalars will be used directly as texture. If On, scalars will be mapped through the lookup table to generate 4-component unsigned char scalars. This ivar does not affect other scalars like unsigned short, float, etc. These scalars are always mapped through lookup tables.

virtual void vtkTexture::MapColorScalarsThroughLookupTableOff ( ) [virtual]

Turn on/off the mapping of color scalars through the lookup table. The default is Off. If Off, unsigned char scalars will be used directly as texture. If On, scalars will be mapped through the lookup table to generate 4-component unsigned char scalars. This ivar does not affect other scalars like unsigned short, float, etc. These scalars are always mapped through lookup tables.

void vtkTexture::SetInput ( vtkImageData * input )

This process object accepts image data as input.

vtkImageData* vtkTexture::GetInput ( )

This process object accepts image data as input.

void vtkTexture::SetLookupTable ( vtkLookupTable * )

Specify the lookup table to convert scalars if necessary

virtual vtkLookupTable* vtkTexture::GetLookupTable ( ) [virtual]

Specify the lookup table to convert scalars if necessary

virtual vtkUnsignedCharArray* vtkTexture::GetMappedScalars ( ) [virtual]

Get Mapped Scalars

unsigned char* vtkTexture::MapScalarsToColors ( vtkDataArray * scalars )

Map scalar values into color scalars.

Member Data Documentation

int vtkTexture::Repeat [protected]

Definition at line 162 of file vtkTexture.h.

int vtkTexture::Interpolate [protected]

Definition at line 163 of file vtkTexture.h.

int vtkTexture::Quality [protected]

Definition at line 164 of file vtkTexture.h.

int vtkTexture::MapColorScalarsThroughLookupTable [protected]

Definition at line 165 of file vtkTexture.h.

vtkLookupTable* vtkTexture::LookupTable [protected]

Definition at line 166 of file vtkTexture.h.

vtkUnsignedCharArray* vtkTexture::MappedScalars [protected]

Definition at line 167 of file vtkTexture.h.

int vtkTexture::SelfAdjustingTableRange [protected]

Definition at line 170 of file vtkTexture.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkTexture.h
Generated on Mon Mar 25 01:32:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTexturedSphereSource Class Reference

create a sphere centered at the origin. More...

#include <vtkTexturedSphereSource.h>

Inheritance diagram for vtkTexturedSphereSource:

[legend]
Collaboration diagram for vtkTexturedSphereSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTexturedSphereSource, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetThetaResolution (int)
virtual int | GetThetaResolution ()
virtual void | SetPhiResolution (int)
virtual int | GetPhiResolution ()
virtual void | SetTheta (float)
virtual float | GetTheta ()
virtual void | SetPhi (float)
virtual float | GetPhi ()

Static Public Methods

vtkTexturedSphereSource * | New ()

Protected Methods

vtkTexturedSphereSource (int res=8)
~vtkTexturedSphereSource ()
void | Execute ()

Protected Attributes

float | Radius
float | Theta
float | Phi
int | ThetaResolution
int | PhiResolution

Detailed Description

create a sphere centered at the origin.

Date:
2002/01/22 15:29:52
Revision:
1.25

vtkTexturedSphereSource creates a polygonal sphere of specified radius centered at the origin. The resolution (polygonal discretization) in both the latitude (phi) and longitude (theta) directions can be specified. It also is possible to create partial sphere by specifying maximum phi and theta angles.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Schroeder, Will (5%)
Tests:
vtkTexturedSphereSource (Tests)

Definition at line 46 of file vtkTexturedSphereSource.h.

Constructor & Destructor Documentation

vtkTexturedSphereSource::vtkTexturedSphereSource ( int res = 8 ) [protected]

vtkTexturedSphereSource::~vtkTexturedSphereSource ( ) [inline, protected]

Definition at line 88 of file vtkTexturedSphereSource.h.

Member Function Documentation

vtkTexturedSphereSource::vtkTypeRevisionMacro | ( | vtkTexturedSphereSource | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkTexturedSphereSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTexturedSphereSource* vtkTexturedSphereSource::New ( ) [static]

Construct sphere with radius=0.5 and default resolution 8 in both Phi and Theta directions.

Reimplemented from vtkPolyDataSource.

virtual void vtkTexturedSphereSource::SetRadius ( float ) [virtual]

Set radius of sphere.

virtual float vtkTexturedSphereSource::GetRadius ( ) [virtual]

Set radius of sphere.

virtual void vtkTexturedSphereSource::SetThetaResolution ( int ) [virtual]

Set the number of points in the longitude direction.

virtual int vtkTexturedSphereSource::GetThetaResolution ( ) [virtual]

Set the number of points in the longitude direction.

virtual void vtkTexturedSphereSource::SetPhiResolution ( int ) [virtual]

Set the number of points in the latitude direction.

virtual int vtkTexturedSphereSource::GetPhiResolution ( ) [virtual]

Set the number of points in the latitude direction.

virtual void vtkTexturedSphereSource::SetTheta ( float ) [virtual]

Set the maximum longitude angle.

virtual float vtkTexturedSphereSource::GetTheta ( ) [virtual]

Set the maximum longitude angle.

virtual void vtkTexturedSphereSource::SetPhi ( float ) [virtual]

Set the maximum latitude angle (0 is at north pole).

virtual float vtkTexturedSphereSource::GetPhi ( ) [virtual]

Set the maximum latitude angle (0 is at north pole).

void vtkTexturedSphereSource::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkTexturedSphereSource::Radius [protected]

Definition at line 91 of file vtkTexturedSphereSource.h.

float vtkTexturedSphereSource::Theta [protected]

Definition at line 92 of file vtkTexturedSphereSource.h.

float vtkTexturedSphereSource::Phi [protected]

Definition at line 93 of file vtkTexturedSphereSource.h.

int vtkTexturedSphereSource::ThetaResolution [protected]

Definition at line 94 of file vtkTexturedSphereSource.h.

int vtkTexturedSphereSource::PhiResolution [protected]

Definition at line 95 of file vtkTexturedSphereSource.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTexturedSphereSource.h
Generated on Mon Mar 25 01:32:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToCylinder Class Reference

generate texture coordinates by mapping points to cylinder. More...

#include <vtkTextureMapToCylinder.h>

Inheritance diagram for vtkTextureMapToCylinder:

[legend]
Collaboration diagram for vtkTextureMapToCylinder:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTextureMapToCylinder, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPoint1 (float, float, float)
virtual void | SetPoint1 (float[3])
virtual float * | GetPoint1 ()
virtual void | GetPoint1 (float data[3])
virtual void | SetPoint2 (float, float, float)
virtual void | SetPoint2 (float[3])
virtual float * | GetPoint2 ()
virtual void | GetPoint2 (float data[3])
virtual void | SetAutomaticCylinderGeneration (int)
virtual int | GetAutomaticCylinderGeneration ()
virtual void | AutomaticCylinderGenerationOn ()
virtual void | AutomaticCylinderGenerationOff ()
virtual void | SetPreventSeam (int)
virtual int | GetPreventSeam ()
virtual void | PreventSeamOn ()
virtual void | PreventSeamOff ()

Static Public Methods

vtkTextureMapToCylinder * | New ()

Protected Methods

vtkTextureMapToCylinder ()
~vtkTextureMapToCylinder ()
void | Execute ()

Protected Attributes

float | Point1 [3]
float | Point2 [3]
int | AutomaticCylinderGeneration
int | PreventSeam

Detailed Description

generate texture coordinates by mapping points to cylinder.

Date:
2002/01/22 15:29:51
Revision:
1.28

vtkTextureMapToCylinder is a filter that generates 2D texture coordinates by mapping input dataset points onto a cylinder. The cylinder can either be user specified or generated automatically. (The cylinder is generated automatically by computing the axis of the cylinder.) Note that the generated texture coordinates for the s-coordinate ranges from (0-1) (corresponding to angle of 0->360 around axis), while the mapping of the t-coordinate is controlled by the projection of points along the axis.

To specify a cylinder manually, you must provide two points that define the axis of the cylinder. The length of the axis will affect the t-coordinates.

A special ivar controls how the s-coordinate is generated. If PreventSeam is set to true, the s-texture varies from 0->1 and then 1->0 (corresponding to angles of 0->180 and 180->360).

Warning:
Since the resulting texture s-coordinate will lie between (0,1), and the origin of the texture coordinates is not user-controllable, you may want to use the class vtkTransformTexture to linearly scale and shift the origin of the texture coordinates.
See also:
vtkTextureMapToPlane vtkTextureMapToSphere vtkTextureMapToBox vtkTransformTexture vtkThresholdTextureCoords
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (74%)
  • Martin, Ken (11%)
Examples:
vtkTextureMapToCylinder (Examples)
Tests:
vtkTextureMapToCylinder (Tests)

Definition at line 67 of file vtkTextureMapToCylinder.h.

Constructor & Destructor Documentation

vtkTextureMapToCylinder::vtkTextureMapToCylinder ( ) [protected]

vtkTextureMapToCylinder::~vtkTextureMapToCylinder ( ) [inline, protected]

Definition at line 110 of file vtkTextureMapToCylinder.h.

Member Function Documentation

vtkTextureMapToCylinder::vtkTypeRevisionMacro | ( | vtkTextureMapToCylinder | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkTextureMapToCylinder::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTextureMapToCylinder* vtkTextureMapToCylinder::New ( ) [static]

Create object with cylinder axis parallel to z-axis (points (0,0,-0.5) and (0,0,0.5)). The PreventSeam ivar is set to true. The cylinder is automatically generated.

Reimplemented from vtkDataSetSource.

virtual void vtkTextureMapToCylinder::SetPoint1 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the first point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::SetPoint1 ( float [3] ) [virtual]

Specify the first point defining the cylinder axis,

virtual float* vtkTextureMapToCylinder::GetPoint1 ( ) [virtual]

Specify the first point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::GetPoint1 ( float data[3] ) [virtual]

Specify the first point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::SetPoint2 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the second point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::SetPoint2 ( float [3] ) [virtual]

Specify the second point defining the cylinder axis,

virtual float* vtkTextureMapToCylinder::GetPoint2 ( ) [virtual]

Specify the second point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::GetPoint2 ( float data[3] ) [virtual]

Specify the second point defining the cylinder axis,

virtual void vtkTextureMapToCylinder::SetAutomaticCylinderGeneration ( int ) [virtual]

Turn on/off automatic cylinder generation. This means it automatically finds the cylinder center and axis.

virtual int vtkTextureMapToCylinder::GetAutomaticCylinderGeneration ( ) [virtual]

Turn on/off automatic cylinder generation. This means it automatically finds the cylinder center and axis.

virtual void vtkTextureMapToCylinder::AutomaticCylinderGenerationOn ( ) [virtual]

Turn on/off automatic cylinder generation. This means it automatically finds the cylinder center and axis.

virtual void vtkTextureMapToCylinder::AutomaticCylinderGenerationOff ( ) [virtual]

Turn on/off automatic cylinder generation. This means it automatically finds the cylinder center and axis.

virtual void vtkTextureMapToCylinder::SetPreventSeam ( int ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the angle variation from 0->180 and 180->0. Otherwise, the s-coordinate ranges from 0->1 from 0->360 degrees.

virtual int vtkTextureMapToCylinder::GetPreventSeam ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the angle variation from 0->180 and 180->0. Otherwise, the s-coordinate ranges from 0->1 from 0->360 degrees.

virtual void vtkTextureMapToCylinder::PreventSeamOn ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the angle variation from 0->180 and 180->0. Otherwise, the s-coordinate ranges from 0->1 from 0->360 degrees.

virtual void vtkTextureMapToCylinder::PreventSeamOff ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the angle variation from 0->180 and 180->0. Otherwise, the s-coordinate ranges from 0->1 from 0->360 degrees.

void vtkTextureMapToCylinder::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkTextureMapToCylinder::Point1[3] [protected]

Definition at line 114 of file vtkTextureMapToCylinder.h.

float vtkTextureMapToCylinder::Point2[3] [protected]

Definition at line 115 of file vtkTextureMapToCylinder.h.

int vtkTextureMapToCylinder::AutomaticCylinderGeneration [protected]

Definition at line 116 of file vtkTextureMapToCylinder.h.

int vtkTextureMapToCylinder::PreventSeam [protected]

Definition at line 117 of file vtkTextureMapToCylinder.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTextureMapToCylinder.h
Generated on Mon Mar 25 01:32:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToPlane Class Reference

generate texture coordinates by mapping points to plane. More...

#include <vtkTextureMapToPlane.h>

Inheritance diagram for vtkTextureMapToPlane:

[legend]
Collaboration diagram for vtkTextureMapToPlane:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTextureMapToPlane, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetPoint1 (float, float, float)
virtual void | SetPoint1 (float[3])
virtual float * | GetPoint1 ()
virtual void | GetPoint1 (float data[3])
virtual void | SetPoint2 (float, float, float)
virtual void | SetPoint2 (float[3])
virtual float * | GetPoint2 ()
virtual void | GetPoint2 (float data[3])
virtual void | SetNormal (float, float, float)
virtual void | SetNormal (float[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float data[3])
virtual void | SetSRange (float, float)
void | SetSRange (float[2])
virtual float * | GetSRange ()
virtual void | GetSRange (float data[2])
virtual void | SetTRange (float, float)
void | SetTRange (float[2])
virtual float * | GetTRange ()
virtual void | GetTRange (float data[2])
virtual void | SetAutomaticPlaneGeneration (int)
virtual int | GetAutomaticPlaneGeneration ()
virtual void | AutomaticPlaneGenerationOn ()
virtual void | AutomaticPlaneGenerationOff ()

Static Public Methods

vtkTextureMapToPlane * | New ()

Protected Methods

vtkTextureMapToPlane ()
~vtkTextureMapToPlane ()
void | Execute ()
void | ComputeNormal ()

Protected Attributes

float | Origin [3]
float | Point1 [3]
float | Point2 [3]
float | Normal [3]
float | SRange [2]
float | TRange [2]
int | AutomaticPlaneGeneration

Detailed Description

generate texture coordinates by mapping points to plane.

Date:
2002/01/22 15:29:51
Revision:
1.37

vtkTextureMapToPlane is a filter that generates 2D texture coordinates by mapping input dataset points onto a plane. The plane can either be user specified or generated automatically. (A least squares method is used to generate the plane automatically.)

There are two ways you can specify the plane. The first is to provide a plane normal. In this case the points are projected to a plane, and the points are then mapped into the user specified s-t coordinate range. For more control, you can specify a plane with three points: an origin and two points defining the two axes of the plane. (This is compatible with the vtkPlaneSource.) Using the second method, the SRange and TRange vectors are ignored, since the presumption is that the user does not want to scale the texture coordinates; and you can adjust the origin and axes points to achieve the texture coordinate scaling you need. Note also that using the three point method the axes do not have to be orthogonal.

See also:
vtkTextureMapToBox vtkPlaneSource vtkTextureMapToCylinder vtkTextureMapToSphere vtkThresholdTextureCoords
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (76%)
  • Martin, Ken (11%)
Examples:
vtkTextureMapToPlane (Examples)
Tests:
vtkTextureMapToPlane (Tests)

Definition at line 61 of file vtkTextureMapToPlane.h.

Constructor & Destructor Documentation

vtkTextureMapToPlane::vtkTextureMapToPlane ( ) [protected]

vtkTextureMapToPlane::~vtkTextureMapToPlane ( ) [inline, protected]

Definition at line 119 of file vtkTextureMapToPlane.h.

Member Function Documentation

vtkTextureMapToPlane::vtkTypeRevisionMacro | ( | vtkTextureMapToPlane | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkTextureMapToPlane::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTextureMapToPlane* vtkTextureMapToPlane::New ( ) [static]

Construct with s,t range=(0,1) and automatic plane generation turned on.

Reimplemented from vtkDataSetSource.

virtual void vtkTextureMapToPlane::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the origin of the plane. Used in conjunction with the Point1 and Point2 ivars to specify a map plane.

virtual void vtkTextureMapToPlane::SetOrigin ( float [3] ) [virtual]

Specify a point defining the origin of the plane. Used in conjunction with the Point1 and Point2 ivars to specify a map plane.

virtual float* vtkTextureMapToPlane::GetOrigin ( ) [virtual]

Specify a point defining the origin of the plane. Used in conjunction with the Point1 and Point2 ivars to specify a map plane.

virtual void vtkTextureMapToPlane::GetOrigin ( float data[3] ) [virtual]

Specify a point defining the origin of the plane. Used in conjunction with the Point1 and Point2 ivars to specify a map plane.

virtual void vtkTextureMapToPlane::SetPoint1 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the first axis of the plane.

virtual void vtkTextureMapToPlane::SetPoint1 ( float [3] ) [virtual]

Specify a point defining the first axis of the plane.

virtual float* vtkTextureMapToPlane::GetPoint1 ( ) [virtual]

Specify a point defining the first axis of the plane.

virtual void vtkTextureMapToPlane::GetPoint1 ( float data[3] ) [virtual]

Specify a point defining the first axis of the plane.

virtual void vtkTextureMapToPlane::SetPoint2 | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the second axis of the plane.

virtual void vtkTextureMapToPlane::SetPoint2 ( float [3] ) [virtual]

Specify a point defining the second axis of the plane.

virtual float* vtkTextureMapToPlane::GetPoint2 ( ) [virtual]

Specify a point defining the second axis of the plane.

virtual void vtkTextureMapToPlane::GetPoint2 ( float data[3] ) [virtual]

Specify a point defining the second axis of the plane.

virtual void vtkTextureMapToPlane::SetNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify plane normal. An alternative way to specify a map plane. Using this method, the object will scale the resulting texture coordinate between the SRange and TRange specified.

virtual void vtkTextureMapToPlane::SetNormal ( float [3] ) [virtual]

Specify plane normal. An alternative way to specify a map plane. Using this method, the object will scale the resulting texture coordinate between the SRange and TRange specified.

virtual float* vtkTextureMapToPlane::GetNormal ( ) [virtual]

Specify plane normal. An alternative way to specify a map plane. Using this method, the object will scale the resulting texture coordinate between the SRange and TRange specified.

virtual void vtkTextureMapToPlane::GetNormal ( float data[3] ) [virtual]

Specify plane normal. An alternative way to specify a map plane. Using this method, the object will scale the resulting texture coordinate between the SRange and TRange specified.

virtual void vtkTextureMapToPlane::SetSRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

void vtkTextureMapToPlane::SetSRange ( float [2] )

Specify s-coordinate range for texture s-t coordinate pair.

virtual float* vtkTextureMapToPlane::GetSRange ( ) [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

virtual void vtkTextureMapToPlane::GetSRange ( float data[2] ) [virtual]

Specify s-coordinate range for texture s-t coordinate pair.

virtual void vtkTextureMapToPlane::SetTRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

void vtkTextureMapToPlane::SetTRange ( float [2] )

Specify t-coordinate range for texture s-t coordinate pair.

virtual float* vtkTextureMapToPlane::GetTRange ( ) [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

virtual void vtkTextureMapToPlane::GetTRange ( float data[2] ) [virtual]

Specify t-coordinate range for texture s-t coordinate pair.

virtual void vtkTextureMapToPlane::SetAutomaticPlaneGeneration ( int ) [virtual]

Turn on/off automatic plane generation.

virtual int vtkTextureMapToPlane::GetAutomaticPlaneGeneration ( ) [virtual]

Turn on/off automatic plane generation.

virtual void vtkTextureMapToPlane::AutomaticPlaneGenerationOn ( ) [virtual]

Turn on/off automatic plane generation.

virtual void vtkTextureMapToPlane::AutomaticPlaneGenerationOff ( ) [virtual]

Turn on/off automatic plane generation.

void vtkTextureMapToPlane::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkTextureMapToPlane::ComputeNormal ( ) [protected]

Member Data Documentation

float vtkTextureMapToPlane::Origin[3] [protected]

Definition at line 124 of file vtkTextureMapToPlane.h.

float vtkTextureMapToPlane::Point1[3] [protected]

Definition at line 125 of file vtkTextureMapToPlane.h.

float vtkTextureMapToPlane::Point2[3] [protected]

Definition at line 126 of file vtkTextureMapToPlane.h.

float vtkTextureMapToPlane::Normal[3] [protected]

Definition at line 127 of file vtkTextureMapToPlane.h.

float vtkTextureMapToPlane::SRange[2] [protected]

Definition at line 128 of file vtkTextureMapToPlane.h.

float vtkTextureMapToPlane::TRange[2] [protected]

Definition at line 129 of file vtkTextureMapToPlane.h.

int vtkTextureMapToPlane::AutomaticPlaneGeneration [protected]

Definition at line 130 of file vtkTextureMapToPlane.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTextureMapToPlane.h
Generated on Mon Mar 25 01:32:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTextureMapToSphere Class Reference

generate texture coordinates by mapping points to sphere. More...

#include <vtkTextureMapToSphere.h>

Inheritance diagram for vtkTextureMapToSphere:

[legend]
Collaboration diagram for vtkTextureMapToSphere:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTextureMapToSphere, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetCenter (float, float, float)
virtual void | SetCenter (float[3])
virtual float * | GetCenter ()
virtual void | GetCenter (float data[3])
virtual void | SetAutomaticSphereGeneration (int)
virtual int | GetAutomaticSphereGeneration ()
virtual void | AutomaticSphereGenerationOn ()
virtual void | AutomaticSphereGenerationOff ()
virtual void | SetPreventSeam (int)
virtual int | GetPreventSeam ()
virtual void | PreventSeamOn ()
virtual void | PreventSeamOff ()

Static Public Methods

vtkTextureMapToSphere * | New ()

Protected Methods

vtkTextureMapToSphere ()
~vtkTextureMapToSphere ()
void | Execute ()

Protected Attributes

float | Center [3]
int | AutomaticSphereGeneration
int | PreventSeam

Detailed Description

generate texture coordinates by mapping points to sphere.

Date:
2002/01/22 15:29:51
Revision:
1.27

vtkTextureMapToSphere is a filter that generates 2D texture coordinates by mapping input dataset points onto a sphere. The sphere can either be user specified or generated automatically. (The sphere is generated automatically by computing the center (i.e., averaged coordinates) of the sphere.) Note that the generated texture coordinates range between (0,1). The s-coordinate lies in the angular direction around the z-axis, measured counter-clockwise from the x-axis. The t-coordinate lies in the angular direction measured down from the north pole towards the south pole.

A special ivar controls how the s-coordinate is generated. If PreventSeam is set to true, the s-texture varies from 0->1 and then 1->0 (corresponding to angles of 0->180 and 180->360).

Warning:
The resulting texture coordinates will lie between (0,1), and the texture coordinates are determined with respect to the modeler's x-y-z coordinate system. Use the class vtkTransformTextureCoords to linearly scale and shift the origin of the texture coordinates (if necessary).
See also:
vtkTextureMapToPlane vtkTextureMapToCylinder vtkTextureMapToBox vtkTransformTexture vtkThresholdTextureCoords
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (73%)
  • Martin, Ken (11%)
  • Lorensen, Bill (7%)
Examples:
vtkTextureMapToSphere (Examples)
Tests:
vtkTextureMapToSphere (Tests)

Definition at line 66 of file vtkTextureMapToSphere.h.

Constructor & Destructor Documentation

vtkTextureMapToSphere::vtkTextureMapToSphere ( ) [protected]

vtkTextureMapToSphere::~vtkTextureMapToSphere ( ) [inline, protected]

Definition at line 102 of file vtkTextureMapToSphere.h.

Member Function Documentation

vtkTextureMapToSphere::vtkTypeRevisionMacro | ( | vtkTextureMapToSphere | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkTextureMapToSphere::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTextureMapToSphere* vtkTextureMapToSphere::New ( ) [static]

Create object with Center (0,0,0) and the PreventSeam ivar is set to true. The sphere center is automatically computed.

Reimplemented from vtkDataSetSource.

virtual void vtkTextureMapToSphere::SetCenter | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point defining the center of the sphere.

virtual void vtkTextureMapToSphere::SetCenter ( float [3] ) [virtual]

Specify a point defining the center of the sphere.

virtual float* vtkTextureMapToSphere::GetCenter ( ) [virtual]

Specify a point defining the center of the sphere.

virtual void vtkTextureMapToSphere::GetCenter ( float data[3] ) [virtual]

Specify a point defining the center of the sphere.

virtual void vtkTextureMapToSphere::SetAutomaticSphereGeneration ( int ) [virtual]

Turn on/off automatic sphere generation. This means it automatically finds the sphere center.

virtual int vtkTextureMapToSphere::GetAutomaticSphereGeneration ( ) [virtual]

Turn on/off automatic sphere generation. This means it automatically finds the sphere center.

virtual void vtkTextureMapToSphere::AutomaticSphereGenerationOn ( ) [virtual]

Turn on/off automatic sphere generation. This means it automatically finds the sphere center.

virtual void vtkTextureMapToSphere::AutomaticSphereGenerationOff ( ) [virtual]

Turn on/off automatic sphere generation. This means it automatically finds the sphere center.

virtual void vtkTextureMapToSphere::SetPreventSeam ( int ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the theta angle variation between 0->180 and 180->0 degrees. Otherwise, the s-coordinate ranges from 0->1 between 0->360 degrees.

virtual int vtkTextureMapToSphere::GetPreventSeam ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the theta angle variation between 0->180 and 180->0 degrees. Otherwise, the s-coordinate ranges from 0->1 between 0->360 degrees.

virtual void vtkTextureMapToSphere::PreventSeamOn ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the theta angle variation between 0->180 and 180->0 degrees. Otherwise, the s-coordinate ranges from 0->1 between 0->360 degrees.

virtual void vtkTextureMapToSphere::PreventSeamOff ( ) [virtual]

Control how the texture coordinates are generated. If PreventSeam is set, the s-coordinate ranges from 0->1 and 1->0 corresponding to the theta angle variation between 0->180 and 180->0 degrees. Otherwise, the s-coordinate ranges from 0->1 between 0->360 degrees.

void vtkTextureMapToSphere::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkTextureMapToSphere::Center[3] [protected]

Definition at line 106 of file vtkTextureMapToSphere.h.

int vtkTextureMapToSphere::AutomaticSphereGeneration [protected]

Definition at line 107 of file vtkTextureMapToSphere.h.

int vtkTextureMapToSphere::PreventSeam [protected]

Definition at line 108 of file vtkTextureMapToSphere.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTextureMapToSphere.h
Generated on Mon Mar 25 01:32:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThinPlateSplineTransform Class Reference

a nonlinear warp transformation. More...

#include <vtkThinPlateSplineTransform.h>

Inheritance diagram for vtkThinPlateSplineTransform:

[legend]
Collaboration diagram for vtkThinPlateSplineTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkThinPlateSplineTransform, vtkWarpTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
vtkAbstractTransform * MakeTransform ()
virtual double | GetSigma ()
virtual void | SetSigma (double)
void | SetBasis (int basis)
virtual int | GetBasis ()
void | SetBasisToR ()
void | SetBasisToR2LogR ()
const char * | GetBasisAsString ()
void | SetBasisFunction (double(*U)(double r))
void | SetBasisDerivative (double(*dUdr)(double r, double &dU))
void | SetSourceLandmarks (vtkPoints *source)
virtual vtkPoints * | GetSourceLandmarks ()
void | SetTargetLandmarks (vtkPoints *target)
virtual vtkPoints * | GetTargetLandmarks ()

Static Public Methods

vtkThinPlateSplineTransform * | New ()

Protected Methods

vtkThinPlateSplineTransform ()
~vtkThinPlateSplineTransform ()
void | InternalUpdate ()
void | InternalDeepCopy (vtkAbstractTransform *transform)
void | ForwardTransformPoint (const float in[3], float out[3])
void | ForwardTransformPoint (const double in[3], double out[3])
void | ForwardTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | ForwardTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Protected Attributes

double | Sigma
vtkPoints * SourceLandmarks
vtkPoints * TargetLandmarks
double(* | BasisFunction )(double r)
double(* | BasisDerivative )(double r, double &dUdr)
int | Basis
int | NumberOfPoints
double ** | MatrixW

Detailed Description

a nonlinear warp transformation.

Date:
2002/01/22 15:30:39
Revision:
1.22

vtkThinPlateSplineTransform describes a nonlinear warp transform defined by a set of source and target landmarks. Any point on the mesh close to a source landmark will be moved to a place close to the corresponding target landmark. The points in between are interpolated smoothly using Bookstein's Thin Plate Spline algorithm.

Warning:
1) The inverse transform is calculated using an iterative method, and is several times more expensive than the forward transform. 2) Whenever you add, subtract, or set points you must call Modified() on the vtkPoints object, or the transformation might not update. 3) Collinear point configurations (except those that lie in the XY plane) result in an unstable transformation.
See also:
vtkGridTransform vtkGeneralTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (96%)
Tests:
vtkThinPlateSplineTransform (Tests)

Definition at line 56 of file vtkThinPlateSplineTransform.h.

Constructor & Destructor Documentation

vtkThinPlateSplineTransform::vtkThinPlateSplineTransform ( ) [protected]

vtkThinPlateSplineTransform::~vtkThinPlateSplineTransform ( ) [protected]

Member Function Documentation

vtkThinPlateSplineTransform::vtkTypeRevisionMacro | ( | vtkThinPlateSplineTransform | ,
 |  | vtkWarpTransform |
 | ) |

Reimplemented from vtkWarpTransform.

void vtkThinPlateSplineTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkWarpTransform.

vtkThinPlateSplineTransform* vtkThinPlateSplineTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

virtual double vtkThinPlateSplineTransform::GetSigma ( ) [virtual]

Specify the 'stiffness' of the spline. The default is 1.0.

virtual void vtkThinPlateSplineTransform::SetSigma ( double ) [virtual]

Specify the 'stiffness' of the spline. The default is 1.0.

void vtkThinPlateSplineTransform::SetBasis ( int basis )

Specify the radial basis function to use. The default is R2LogR which is what most people use as the thin plate spline.

virtual int vtkThinPlateSplineTransform::GetBasis ( ) [virtual]

Specify the radial basis function to use. The default is R2LogR which is what most people use as the thin plate spline.

void vtkThinPlateSplineTransform::SetBasisToR ( ) [inline]

Specify the radial basis function to use. The default is R2LogR which is what most people use as the thin plate spline.

Definition at line 74 of file vtkThinPlateSplineTransform.h.

void vtkThinPlateSplineTransform::SetBasisToR2LogR ( ) [inline]

Specify the radial basis function to use. The default is R2LogR which is what most people use as the thin plate spline.

Definition at line 75 of file vtkThinPlateSplineTransform.h.

const char* vtkThinPlateSplineTransform::GetBasisAsString ( )

Specify the radial basis function to use. The default is R2LogR which is what most people use as the thin plate spline.

void vtkThinPlateSplineTransform::SetBasisFunction ( double(* U)(double r) ) [inline]

Set the radial basis function to a custom function. You must supply both the function and its derivative with respect to r.

Definition at line 83 of file vtkThinPlateSplineTransform.h.

void vtkThinPlateSplineTransform::SetBasisDerivative ( double(* dUdr)(double r, double &dU) ) [inline]

Set the radial basis function to a custom function. You must supply both the function and its derivative with respect to r.

Definition at line 88 of file vtkThinPlateSplineTransform.h.

void vtkThinPlateSplineTransform::SetSourceLandmarks ( vtkPoints * source )

Set the source landmarks for the warp. If you add or change the vtkPoints object, you must call Modified() on it or the transformation might not update.

virtual vtkPoints* vtkThinPlateSplineTransform::GetSourceLandmarks ( ) [virtual]

Set the source landmarks for the warp. If you add or change the vtkPoints object, you must call Modified() on it or the transformation might not update.

void vtkThinPlateSplineTransform::SetTargetLandmarks ( vtkPoints * target )

Set the target landmarks for the warp. If you add or change the vtkPoints object, you must call Modified() on it or the transformation might not update.

virtual vtkPoints* vtkThinPlateSplineTransform::GetTargetLandmarks ( ) [virtual]

Set the target landmarks for the warp. If you add or change the vtkPoints object, you must call Modified() on it or the transformation might not update.

unsigned long vtkThinPlateSplineTransform::GetMTime ( ) [virtual]

Get the MTime.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkThinPlateSplineTransform::MakeTransform ( ) [virtual]

Make another transform of the same type.

Reimplemented from vtkAbstractTransform.

void vtkThinPlateSplineTransform::InternalUpdate ( ) [protected, virtual]

Prepare the transformation for application.

Reimplemented from vtkAbstractTransform.

void vtkThinPlateSplineTransform::InternalDeepCopy ( vtkAbstractTransform * transform ) [protected, virtual]

This method does no type checking, use DeepCopy instead.

Reimplemented from vtkAbstractTransform.

void vtkThinPlateSplineTransform::ForwardTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 0, then a call to InternalTransformPoint results in a call to ForwardTransformPoint.

Reimplemented from vtkWarpTransform.

void vtkThinPlateSplineTransform::ForwardTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 0, then a call to InternalTransformPoint results in a call to ForwardTransformPoint.

Reimplemented from vtkWarpTransform.

void vtkThinPlateSplineTransform::ForwardTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [protected, virtual]

Calculate the forward transform as well as the derivative.

Reimplemented from vtkWarpTransform.

void vtkThinPlateSplineTransform::ForwardTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [protected, virtual]

Calculate the forward transform as well as the derivative.

Reimplemented from vtkWarpTransform.

Member Data Documentation

double vtkThinPlateSplineTransform::Sigma [protected]

Definition at line 134 of file vtkThinPlateSplineTransform.h.

vtkPoints* vtkThinPlateSplineTransform::SourceLandmarks [protected]

Definition at line 135 of file vtkThinPlateSplineTransform.h.

vtkPoints* vtkThinPlateSplineTransform::TargetLandmarks [protected]

Definition at line 136 of file vtkThinPlateSplineTransform.h.

double(* vtkThinPlateSplineTransform::BasisFunction)(double r) [protected]

double(* vtkThinPlateSplineTransform::BasisDerivative)(double r, double& dUdr) [protected]

int vtkThinPlateSplineTransform::Basis [protected]

Definition at line 143 of file vtkThinPlateSplineTransform.h.

int vtkThinPlateSplineTransform::NumberOfPoints [protected]

Definition at line 145 of file vtkThinPlateSplineTransform.h.

double** vtkThinPlateSplineTransform::MatrixW [protected]

Definition at line 146 of file vtkThinPlateSplineTransform.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkThinPlateSplineTransform.h
Generated on Mon Mar 25 01:32:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreadedController Class Reference

Allows communication between running threads. More...

#include <vtkThreadedController.h>

Inheritance diagram for vtkThreadedController:

[legend]
Collaboration diagram for vtkThreadedController:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkThreadedController, vtkMultiProcessController)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SingleMethodExecute ()
virtual void | MultipleMethodExecute ()
virtual void | Barrier ()
virtual void | CreateOutputWindow ()
virtual void | Initialize (int *argc, char ***arcv)
virtual void | Finalize ()
virtual int | GetLocalProcessId ()

Static Public Methods

vtkThreadedController * | New ()

Protected Types

typedef int | ThreadIdType

Protected Methods

vtkThreadedController ()
~vtkThreadedController ()
void | CreateProcessControllers ()
void | Start (int threadIdx)
void | ResetControllers ()
vtkMultiProcessController * GetLocalController ()

Static Protected Methods

VTK_THREAD_RETURN_TYPE | vtkThreadedControllerStart (void *arg)
void | WaitForPreviousBarrierToEnd ()
void | BarrierStarted ()
void | BarrierEnded ()
void | SignalNextThread ()
void | InitializeBarrier ()
void | WaitForNextThread ()

Protected Attributes

vtkThreadedController ** | Controllers
ThreadIdType ThreadId
int | LastNumberOfProcesses
vtkMultiThreader * MultiThreader
int | MultipleMethodFlag

Static Protected Attributes

vtkSimpleCriticalSection CounterLock
int | Counter
int | IsBarrierInProgress
vtkSimpleCriticalSection BarrierLock
vtkSimpleCriticalSection BarrierInProgress

Detailed Description

Allows communication between running threads.

Date:
2002/02/15 19:29:36
Revision:
1.9

vtkThreadedController uses a vtkMultiThreader to spawn threads. The communication is accomplished using a vtkSharedMemoryCommunicator. The RMI communicator is identical to the user communicator. Note that each thread gets its own vtkThreadedController to accomplish thread safety.

See also:
vtkMultiProcessController vtkMultiThreader vtkSharedMemoryCommunicator vtkInputPort vtkOutputPort
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (87%)
  • Geveci, Berk (9%)
Tests:
vtkThreadedController (Tests)

Definition at line 52 of file vtkThreadedController.h.

Member Typedef Documentation

typedef int vtkThreadedController::ThreadIdType [protected]

Definition at line 119 of file vtkThreadedController.h.

Constructor & Destructor Documentation

vtkThreadedController::vtkThreadedController ( ) [protected]

vtkThreadedController::~vtkThreadedController ( ) [protected]

Member Function Documentation

vtkThreadedController* vtkThreadedController::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkMultiProcessController.

vtkThreadedController::vtkTypeRevisionMacro | ( | vtkThreadedController | ,
 |  | vtkMultiProcessController |
 | ) |

Reimplemented from vtkMultiProcessController.

void vtkThreadedController::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMultiProcessController.

virtual void vtkThreadedController::Initialize | ( | int * | argc,
 |  | char *** | arcv
 | ) | [virtual]

This method is for setting up the processes.

virtual void vtkThreadedController::Finalize ( ) [inline, virtual]

This method is for setting up the processes.

Reimplemented from vtkMultiProcessController.

Definition at line 62 of file vtkThreadedController.h.

virtual int vtkThreadedController::GetLocalProcessId ( ) [virtual]

This method returns an integer from 0 to (NumberOfProcesses-1) indicating which process we are in. Note: The correct controller is passed as an argument to the initial function (SingleMethod/MultipleMethod). Calling this method on another controller may give wrong results.

Reimplemented from vtkMultiProcessController.

virtual void vtkThreadedController::SingleMethodExecute ( ) [virtual]

Execute the SingleMethod (as define by SetSingleMethod) using this->NumberOfProcesses processes. This will only return when all the processes finish executing their methods.

Reimplemented from vtkMultiProcessController.

virtual void vtkThreadedController::MultipleMethodExecute ( ) [virtual]

Execute the MultipleMethods (as define by calling SetMultipleMethod for each of the required this->NumberOfProcesses methods) using this->NumberOfProcesses processes.

Reimplemented from vtkMultiProcessController.

virtual void vtkThreadedController::Barrier ( ) [virtual]

This method can be used to synchronize the threads.

Reimplemented from vtkMultiProcessController.

virtual void vtkThreadedController::CreateOutputWindow ( ) [virtual]

This method can be used to tell the controller to create a special output window in which all messages are preceded by the process id.

Reimplemented from vtkMultiProcessController.

void vtkThreadedController::CreateProcessControllers ( ) [protected]

void vtkThreadedController::Start ( int threadIdx ) [protected]

First method called after threads are spawned.

void vtkThreadedController::ResetControllers ( ) [protected]

VTK_THREAD_RETURN_TYPE vtkThreadedController::vtkThreadedControllerStart ( void * arg ) [static, protected]

void vtkThreadedController::WaitForPreviousBarrierToEnd ( ) [static, protected]

void vtkThreadedController::BarrierStarted ( ) [static, protected]

void vtkThreadedController::BarrierEnded ( ) [static, protected]

void vtkThreadedController::SignalNextThread ( ) [static, protected]

void vtkThreadedController::InitializeBarrier ( ) [static, protected]

void vtkThreadedController::WaitForNextThread ( ) [static, protected]

vtkMultiProcessController* vtkThreadedController::GetLocalController ( ) [protected, virtual]

Reimplemented from vtkMultiProcessController.

Member Data Documentation

vtkThreadedController** vtkThreadedController::Controllers [protected]

Definition at line 107 of file vtkThreadedController.h.

vtkSimpleCriticalSection vtkThreadedController::CounterLock [static, protected]

Definition at line 125 of file vtkThreadedController.h.

int vtkThreadedController::Counter [static, protected]

Definition at line 126 of file vtkThreadedController.h.

int vtkThreadedController::IsBarrierInProgress [static, protected]

Definition at line 127 of file vtkThreadedController.h.

vtkSimpleCriticalSection vtkThreadedController::BarrierLock [static, protected]

Definition at line 138 of file vtkThreadedController.h.

vtkSimpleCriticalSection vtkThreadedController::BarrierInProgress [static, protected]

Definition at line 139 of file vtkThreadedController.h.

ThreadIdType vtkThreadedController::ThreadId [protected]

Definition at line 142 of file vtkThreadedController.h.

int vtkThreadedController::LastNumberOfProcesses [protected]

Definition at line 144 of file vtkThreadedController.h.

vtkMultiThreader* vtkThreadedController::MultiThreader [protected]

Definition at line 146 of file vtkThreadedController.h.

int vtkThreadedController::MultipleMethodFlag [protected]

Definition at line 148 of file vtkThreadedController.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkThreadedController.h
Generated on Mon Mar 25 01:32:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


ThreadInfoStruct Struct Reference

#include <vtkMultiThreader.h>

Collaboration diagram for ThreadInfoStruct:

[legend]
List of all members.

Public Attributes

int | ThreadID
int | NumberOfThreads
int * | ActiveFlag
vtkMutexLock * ActiveFlagLock
void * | UserData

Detailed Description

This is the structure that is passed to the thread that is created from the SingleMethodExecute, MultipleMethodExecute or the SpawnThread method. It is passed in as a void *, and it is up to the method to cast correctly and extract the information. The ThreadID is a number between 0 and NumberOfThreads-1 that indicates the id of this thread. The NumberOfThreads is this->NumberOfThreads for threads created from SingleMethodExecute or MultipleMethodExecute, and it is 1 for threads created from SpawnThread. The UserData is the (void *)arg passed into the SetSingleMethod, SetMultipleMethod, or SpawnThread method.

Definition at line 121 of file vtkMultiThreader.h.

Member Data Documentation

int ThreadInfoStruct::ThreadID

Definition at line 123 of file vtkMultiThreader.h.

int ThreadInfoStruct::NumberOfThreads

Definition at line 124 of file vtkMultiThreader.h.

int* ThreadInfoStruct::ActiveFlag

Definition at line 125 of file vtkMultiThreader.h.

vtkMutexLock* ThreadInfoStruct::ActiveFlagLock

Definition at line 126 of file vtkMultiThreader.h.

void* ThreadInfoStruct::UserData

Definition at line 127 of file vtkMultiThreader.h.

The documentation for this struct was generated from the following file:
  • Common/vtkMultiThreader.h
Generated on Mon Mar 25 01:32:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreadSafeLog Class Reference

Saves tag/float entries. More...

#include <vtkThreadSafeLog.h>

Inheritance diagram for vtkThreadSafeLog:

[legend]
Collaboration diagram for vtkThreadSafeLog:

[legend]
List of all members.

Public Methods

const char * | GetClassName ()
void | AddEntry (char *tag, float value)
void | DumpLog (char *filename, int mode=ios::out)
void | StartTimer ()
void | StopTimer ()
double | GetElapsedTime ()

Static Public Methods

vtkThreadSafeLog * | New ()

Protected Methods

vtkThreadSafeLog ()
~vtkThreadSafeLog ()

Protected Attributes

char * | Tags [VTK_THREAD_SAFE_LOG_MAX]
float | Values [VTK_THREAD_SAFE_LOG_MAX]
int | NumberOfEntries
vtkTimerLog * Timer

Detailed Description

Saves tag/float entries.

Date:
2002/01/22 15:34:59
Revision:
1.5

For timing Port stuff. Float values are saved with associated string tags.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (98%)

Definition at line 41 of file vtkThreadSafeLog.h.

Constructor & Destructor Documentation

vtkThreadSafeLog::vtkThreadSafeLog ( ) [protected]

vtkThreadSafeLog::~vtkThreadSafeLog ( ) [protected]

Member Function Documentation

vtkThreadSafeLog* vtkThreadSafeLog::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

const char* vtkThreadSafeLog::GetClassName ( ) [inline, virtual]

Return the class name as a string. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

Definition at line 45 of file vtkThreadSafeLog.h.

void vtkThreadSafeLog::StartTimer ( ) [inline]

some of the timeing features of vtkTimerLog.

Definition at line 49 of file vtkThreadSafeLog.h.

void vtkThreadSafeLog::StopTimer ( ) [inline]

some of the timeing features of vtkTimerLog.

Definition at line 50 of file vtkThreadSafeLog.h.

double vtkThreadSafeLog::GetElapsedTime ( ) [inline]

some of the timeing features of vtkTimerLog.

Definition at line 51 of file vtkThreadSafeLog.h.

void vtkThreadSafeLog::AddEntry | ( | char * | tag,
 |  | float | value
 | ) |

Save a tag/value pair.

void vtkThreadSafeLog::DumpLog | ( | char * | filename,
 |  | int | mode = ios::out
 | ) |

Write the timing table out to a file. if mode is out, then two lines are printed: Tags on first, values on second. If mode is iso::app, then only the line with values is printed.

Member Data Documentation

char* vtkThreadSafeLog::Tags[VTK_THREAD_SAFE_LOG_MAX] [protected]

Definition at line 68 of file vtkThreadSafeLog.h.

float vtkThreadSafeLog::Values[VTK_THREAD_SAFE_LOG_MAX] [protected]

Definition at line 69 of file vtkThreadSafeLog.h.

int vtkThreadSafeLog::NumberOfEntries [protected]

Definition at line 70 of file vtkThreadSafeLog.h.

vtkTimerLog* vtkThreadSafeLog::Timer [protected]

Definition at line 72 of file vtkThreadSafeLog.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkThreadSafeLog.h
Generated on Mon Mar 25 01:32:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThreshold Class Reference

extracts cells where scalar value in cell satisfies threshold criterion. More...

#include <vtkThreshold.h>

Inheritance diagram for vtkThreshold:

[legend]
Collaboration diagram for vtkThreshold:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkThreshold, vtkDataSetToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ThresholdByLower (float lower)
void | ThresholdByUpper (float upper)
void | ThresholdBetween (float lower, float upper)
virtual float | GetUpperThreshold ()
virtual float | GetLowerThreshold ()
virtual void | SetAttributeMode (int)
virtual int | GetAttributeMode ()
void | SetAttributeModeToDefault ()
void | SetAttributeModeToUsePointData ()
void | SetAttributeModeToUseCellData ()
const char * | GetAttributeModeAsString ()
virtual void | SetAllScalars (int)
virtual int | GetAllScalars ()
virtual void | AllScalarsOn ()
virtual void | AllScalarsOff ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkThreshold * | New ()

Protected Methods

vtkThreshold ()
~vtkThreshold ()
void | Execute ()
int | Lower (float s)
int | Upper (float s)
int | Between (float s)
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

int | AllScalars
float | LowerThreshold
float | UpperThreshold
int | AttributeMode
int(vtkThreshold::* | ThresholdFunction )(float s)
char * | InputScalarsSelection

Detailed Description

extracts cells where scalar value in cell satisfies threshold criterion.

Date:
2002/01/22 15:29:52
Revision:
1.43

vtkThreshold is a filter that extracts cells from any dataset type that satisfy a threshold criterion. A cell satisfies the criterion if the scalar value of (every or any) point satisfies the criterion. The criterion can take three forms: 1) greater than a particular value; 2) less than a particular value; or 3) between two values. The output of this filter is an unstructured grid.

Note that scalar values are available from the point and cell attribute data. By default, point data is used to obtain scalars, but you can control this behavior. See the AttributeMode ivar below.

See also:
vtkThresholdPoints vtkThresholdTextureCoords
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Law, Charles (39%)
  • Schroeder, Will (38%)
  • Martin, Ken (13%)
Examples:
vtkThreshold (Examples)
Tests:
vtkThreshold (Tests)

Definition at line 60 of file vtkThreshold.h.

Constructor & Destructor Documentation

vtkThreshold::vtkThreshold ( ) [protected]

vtkThreshold::~vtkThreshold ( ) [protected]

Member Function Documentation

vtkThreshold* vtkThreshold::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkThreshold::vtkTypeRevisionMacro | ( | vtkThreshold | ,
 |  | vtkDataSetToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkDataSetToUnstructuredGridFilter.

void vtkThreshold::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkThreshold::ThresholdByLower ( float lower )

Criterion is cells whose scalars are less or equal to lower threshold.

void vtkThreshold::ThresholdByUpper ( float upper )

Criterion is cells whose scalars are greater or equal to upper threshold.

void vtkThreshold::ThresholdBetween | ( | float | lower,
 |  | float | upper
 | ) |

Criterion is cells whose scalars are between lower and upper thresholds.

virtual float vtkThreshold::GetUpperThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

virtual float vtkThreshold::GetLowerThreshold ( ) [virtual]

Get the Upper and Lower thresholds.

virtual void vtkThreshold::SetAttributeMode ( int ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

virtual int vtkThreshold::GetAttributeMode ( ) [virtual]

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

void vtkThreshold::SetAttributeModeToDefault ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 94 of file vtkThreshold.h.

void vtkThreshold::SetAttributeModeToUsePointData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 96 of file vtkThreshold.h.

void vtkThreshold::SetAttributeModeToUseCellData ( ) [inline]

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 98 of file vtkThreshold.h.

const char* vtkThreshold::GetAttributeModeAsString ( )

Control how the filter works with scalar point data and cell attribute data. By default (AttributeModeToDefault), the filter will use point data, and if no point data is available, then cell data is used. Alternatively you can explicitly set the filter to use point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

virtual void vtkThreshold::SetAllScalars ( int ) [virtual]

If using scalars from point data, all scalars for all points in a cell must satisfy the threshold criterion if AllScalars is set. Otherwise, just a single scalar value satisfying the threshold criterion enables will extract the cell.

virtual int vtkThreshold::GetAllScalars ( ) [virtual]

If using scalars from point data, all scalars for all points in a cell must satisfy the threshold criterion if AllScalars is set. Otherwise, just a single scalar value satisfying the threshold criterion enables will extract the cell.

virtual void vtkThreshold::AllScalarsOn ( ) [virtual]

If using scalars from point data, all scalars for all points in a cell must satisfy the threshold criterion if AllScalars is set. Otherwise, just a single scalar value satisfying the threshold criterion enables will extract the cell.

virtual void vtkThreshold::AllScalarsOff ( ) [virtual]

If using scalars from point data, all scalars for all points in a cell must satisfy the threshold criterion if AllScalars is set. Otherwise, just a single scalar value satisfying the threshold criterion enables will extract the cell.

virtual char* vtkThreshold::GetInputScalarsSelection ( ) [virtual]

If you want to threshold by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkThreshold::SelectInputScalars ( const char * fieldName ) [inline]

If you want to threshold by an arbitrary array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 118 of file vtkThreshold.h.

void vtkThreshold::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkThreshold::Lower ( float s ) [inline, protected]

Definition at line 138 of file vtkThreshold.h.

int vtkThreshold::Upper ( float s ) [inline, protected]

Definition at line 139 of file vtkThreshold.h.

int vtkThreshold::Between ( float s ) [inline, protected]

Definition at line 140 of file vtkThreshold.h.

virtual void vtkThreshold::SetInputScalarsSelection ( const char * ) [protected, virtual]

Member Data Documentation

int vtkThreshold::AllScalars [protected]

Definition at line 129 of file vtkThreshold.h.

float vtkThreshold::LowerThreshold [protected]

Definition at line 130 of file vtkThreshold.h.

float vtkThreshold::UpperThreshold [protected]

Definition at line 131 of file vtkThreshold.h.

int vtkThreshold::AttributeMode [protected]

Definition at line 132 of file vtkThreshold.h.

int(vtkThreshold::* vtkThreshold::ThresholdFunction)(float s) [protected]

char* vtkThreshold::InputScalarsSelection [protected]

Definition at line 143 of file vtkThreshold.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkThreshold.h
Generated on Mon Mar 25 01:32:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThresholdPoints Class Reference

extracts points whose scalar value satisfies threshold criterion. More...

#include <vtkThresholdPoints.h>

Inheritance diagram for vtkThresholdPoints:

[legend]
Collaboration diagram for vtkThresholdPoints:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkThresholdPoints, vtkDataSetToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ThresholdByLower (float lower)
void | ThresholdByUpper (float upper)
void | ThresholdBetween (float lower, float upper)
virtual float | GetUpperThreshold ()
virtual float | GetLowerThreshold ()

Static Public Methods

vtkThresholdPoints * | New ()

Protected Methods

vtkThresholdPoints ()
~vtkThresholdPoints ()
void | Execute ()
int | Lower (float s)
int | Upper (float s)
int | Between (float s)

Protected Attributes

float | LowerThreshold
float | UpperThreshold
int(vtkThresholdPoints::* | ThresholdFunction )(float s)

Detailed Description

extracts points whose scalar value satisfies threshold criterion.

Date:
2002/01/22 15:29:52
Revision:
1.33

vtkThresholdPoints is a filter that extracts points from a dataset that satisfy a threshold criterion. The criterion can take three forms: 1) greater than a particular value; 2) less than a particular value; or 3) between a particular value. The output of the filter is polygonal data.

See also:
vtkThreshold
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (69%)
  • Martin, Ken (14%)
  • Kelly, Ann (5%)
Examples:
vtkThresholdPoints (Examples)
Tests:
vtkThresholdPoints (Tests)

Definition at line 49 of file vtkThresholdPoints.h.

Constructor & Destructor Documentation

vtkThresholdPoints::vtkThresholdPoints ( ) [protected]

vtkThresholdPoints::~vtkThresholdPoints ( ) [inline, protected]

Definition at line 74 of file vtkThresholdPoints.h.

Member Function Documentation

vtkThresholdPoints* vtkThresholdPoints::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkThresholdPoints::vtkTypeRevisionMacro | ( | vtkThresholdPoints | ,
 |  | vtkDataSetToPolyDataFilter |
 | ) |

Reimplemented from vtkDataSetToPolyDataFilter.

void vtkThresholdPoints::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkThresholdPoints::ThresholdByLower ( float lower )

Criterion is cells whose scalars are less than lower threshold.

void vtkThresholdPoints::ThresholdByUpper ( float upper )

Criterion is cells whose scalars are less than upper threshold.

void vtkThresholdPoints::ThresholdBetween | ( | float | lower,
 |  | float | upper
 | ) |

Criterion is cells whose scalars are between lower and upper thresholds.

virtual float vtkThresholdPoints::GetUpperThreshold ( ) [virtual]

Get the upper and lower thresholds.

virtual float vtkThresholdPoints::GetLowerThreshold ( ) [virtual]

Get the upper and lower thresholds.

void vtkThresholdPoints::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkThresholdPoints::Lower ( float s ) [inline, protected]

Definition at line 86 of file vtkThresholdPoints.h.

int vtkThresholdPoints::Upper ( float s ) [inline, protected]

Definition at line 87 of file vtkThresholdPoints.h.

int vtkThresholdPoints::Between ( float s ) [inline, protected]

Definition at line 88 of file vtkThresholdPoints.h.

Member Data Documentation

float vtkThresholdPoints::LowerThreshold [protected]

Definition at line 79 of file vtkThresholdPoints.h.

float vtkThresholdPoints::UpperThreshold [protected]

Definition at line 80 of file vtkThresholdPoints.h.

int(vtkThresholdPoints::* vtkThresholdPoints::ThresholdFunction)(float s) [protected]

The documentation for this class was generated from the following file:
  • Graphics/vtkThresholdPoints.h
Generated on Mon Mar 25 01:32:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkThresholdTextureCoords Class Reference

compute 1D, 2D, or 3D texture coordinates based on scalar threshold. More...

#include <vtkThresholdTextureCoords.h>

Inheritance diagram for vtkThresholdTextureCoords:

[legend]
Collaboration diagram for vtkThresholdTextureCoords:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkThresholdTextureCoords, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | ThresholdByLower (float lower)
void | ThresholdByUpper (float upper)
void | ThresholdBetween (float lower, float upper)
virtual float | GetUpperThreshold ()
virtual float | GetLowerThreshold ()
virtual void | SetTextureDimension (int)
virtual int | GetTextureDimension ()
virtual void | SetInTextureCoord (float, float, float)
virtual void | SetInTextureCoord (float[3])
virtual float * | GetInTextureCoord ()
virtual void | GetInTextureCoord (float data[3])
virtual void | SetOutTextureCoord (float, float, float)
virtual void | SetOutTextureCoord (float[3])
virtual float * | GetOutTextureCoord ()
virtual void | GetOutTextureCoord (float data[3])

Static Public Methods

vtkThresholdTextureCoords * | New ()

Protected Methods

vtkThresholdTextureCoords ()
~vtkThresholdTextureCoords ()
void | Execute ()
int | Lower (float s)
int | Upper (float s)
int | Between (float s)

Protected Attributes

float | LowerThreshold
float | UpperThreshold
int | TextureDimension
float | InTextureCoord [3]
float | OutTextureCoord [3]
int(vtkThresholdTextureCoords::* | ThresholdFunction )(float s)

Detailed Description

compute 1D, 2D, or 3D texture coordinates based on scalar threshold.

Date:
2002/01/22 15:29:52
Revision:
1.34

vtkThresholdTextureCoords is a filter that generates texture coordinates for any input dataset type given a threshold criterion. The criterion can take three forms: 1) greater than a particular value (ThresholdByUpper()); 2) less than a particular value (ThresholdByLower(); or 3) between two values (ThresholdBetween(). If the threshold criterion is satisfied, the "in" texture coordinate will be set (this can be specified by the user). If the threshold criterion is not satisfied the "out" is set.

Warning:
There is a texture map - texThres.vtk - that can be used in conjunction with this filter. This map defines a "transparent" region for texture coordinates 0<=r<0.5, and an opaque full intensity map for texture coordinates 0.5<r<=1.0. There is a small transition region for r=0.5.
See also:
vtkThreshold vtkThresholdPoints vtkTextureMapToPlane vtkTextureMapToSphere vtkTextureMapToCylinder vtkTextureMapToBox
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (70%)
  • Martin, Ken (11%)
  • Geveci, Berk (6%)

Definition at line 54 of file vtkThresholdTextureCoords.h.

Constructor & Destructor Documentation

vtkThresholdTextureCoords::vtkThresholdTextureCoords ( ) [protected]

vtkThresholdTextureCoords::~vtkThresholdTextureCoords ( ) [inline, protected]

Definition at line 99 of file vtkThresholdTextureCoords.h.

Member Function Documentation

vtkThresholdTextureCoords* vtkThresholdTextureCoords::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataSetSource.

vtkThresholdTextureCoords::vtkTypeRevisionMacro | ( | vtkThresholdTextureCoords | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkThresholdTextureCoords::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkThresholdTextureCoords::ThresholdByLower ( float lower )

Criterion is cells whose scalars are less than lower threshold.

void vtkThresholdTextureCoords::ThresholdByUpper ( float upper )

Criterion is cells whose scalars are less than upper threshold.

void vtkThresholdTextureCoords::ThresholdBetween | ( | float | lower,
 |  | float | upper
 | ) |

Criterion is cells whose scalars are between lower and upper thresholds.

virtual float vtkThresholdTextureCoords::GetUpperThreshold ( ) [virtual]

Return the upper and lower thresholds.

virtual float vtkThresholdTextureCoords::GetLowerThreshold ( ) [virtual]

Return the upper and lower thresholds.

virtual void vtkThresholdTextureCoords::SetTextureDimension ( int ) [virtual]

Set the desired dimension of the texture map.

virtual int vtkThresholdTextureCoords::GetTextureDimension ( ) [virtual]

Set the desired dimension of the texture map.

virtual void vtkThresholdTextureCoords::SetInTextureCoord | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the texture coordinate value for point satisfying threshold criterion.

virtual void vtkThresholdTextureCoords::SetInTextureCoord ( float [3] ) [virtual]

Set the texture coordinate value for point satisfying threshold criterion.

virtual float* vtkThresholdTextureCoords::GetInTextureCoord ( ) [virtual]

Set the texture coordinate value for point satisfying threshold criterion.

virtual void vtkThresholdTextureCoords::GetInTextureCoord ( float data[3] ) [virtual]

Set the texture coordinate value for point satisfying threshold criterion.

virtual void vtkThresholdTextureCoords::SetOutTextureCoord | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the texture coordinate value for point NOT satisfying threshold criterion.

virtual void vtkThresholdTextureCoords::SetOutTextureCoord ( float [3] ) [virtual]

Set the texture coordinate value for point NOT satisfying threshold criterion.

virtual float* vtkThresholdTextureCoords::GetOutTextureCoord ( ) [virtual]

Set the texture coordinate value for point NOT satisfying threshold criterion.

virtual void vtkThresholdTextureCoords::GetOutTextureCoord ( float data[3] ) [virtual]

Set the texture coordinate value for point NOT satisfying threshold criterion.

void vtkThresholdTextureCoords::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

int vtkThresholdTextureCoords::Lower ( float s ) [inline, protected]

Definition at line 116 of file vtkThresholdTextureCoords.h.

int vtkThresholdTextureCoords::Upper ( float s ) [inline, protected]

Definition at line 117 of file vtkThresholdTextureCoords.h.

int vtkThresholdTextureCoords::Between ( float s ) [inline, protected]

Definition at line 118 of file vtkThresholdTextureCoords.h.

Member Data Documentation

float vtkThresholdTextureCoords::LowerThreshold [protected]

Definition at line 104 of file vtkThresholdTextureCoords.h.

float vtkThresholdTextureCoords::UpperThreshold [protected]

Definition at line 105 of file vtkThresholdTextureCoords.h.

int vtkThresholdTextureCoords::TextureDimension [protected]

Definition at line 107 of file vtkThresholdTextureCoords.h.

float vtkThresholdTextureCoords::InTextureCoord[3] [protected]

Definition at line 109 of file vtkThresholdTextureCoords.h.

float vtkThresholdTextureCoords::OutTextureCoord[3] [protected]

Definition at line 110 of file vtkThresholdTextureCoords.h.

int(vtkThresholdTextureCoords::* vtkThresholdTextureCoords::ThresholdFunction)(float s) [protected]

The documentation for this class was generated from the following file:
  • Graphics/vtkThresholdTextureCoords.h
Generated on Mon Mar 25 01:32:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTIFFReader Class Reference

read TIFF files. More...

#include <vtkTIFFReader.h>

Inheritance diagram for vtkTIFFReader:

[legend]
Collaboration diagram for vtkTIFFReader:

[legend]
List of all members.

Public Types

typedef vtkImageReader2 | Superclass
enum {
NOFORMAT, RGB, GRAYSCALE, PALETTE_RGB,
PALETTE_GRAYSCALE, OTHER
}

Public Methods

virtual const char * | GetClassName ()
virtual int | IsA (const char *type)
void | GetColor (int index, unsigned short *r, unsigned short *g, unsigned short *b)
unsigned int | GetFormat ()
void | InitializeColors ()
void | ReadImageInternal (void *, void *outPtr, int *outExt, unsigned int size)
virtual vtkImageReader2 * | MakeObject ()
virtual int | CanReadFile (const char *fname)
TIFFInternal * | GetInternalImage ()
virtual const char * | GetFileExensions ()
virtual const char * | GetDescriptiveName ()

Static Public Methods

vtkTIFFReader * | New ()
int | IsTypeOf (const char *type)
vtkTIFFReader * | SafeDownCast (vtkObject *o)

Protected Methods

vtkTIFFReader ()
~vtkTIFFReader ()
virtual void | ExecuteInformation ()
virtual void | ExecuteData (vtkDataObject *out)
void | ReadGenericImage (void *out, unsigned int width, unsigned int height, unsigned int size)
int | EvaluateImageAt (void *, void *)

Detailed Description

read TIFF files.

Date:
2002/03/25 01:28:39
Revision:
1.22

vtkTIFFReader is a source object that reads TIFF files. It should be able to read most any TIFF file

See also:
vtkTIFFWriter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Cedilnik, Andy (60%)
  • Martin, Ken (30%)
  • Miller, Jim (5%)
Tests:
vtkTIFFReader (Tests)

Definition at line 74 of file vtkTIFFReader.h.

Member Typedef Documentation

typedef vtkImageReader2 vtkTIFFReader::Superclass

Definition at line 78 of file vtkTIFFReader.h.

Member Enumeration Documentation

anonymous enum

Enumeration values:
NOFORMAT
RGB
GRAYSCALE
PALETTE_RGB
PALETTE_GRAYSCALE
OTHER

Definition at line 81 of file vtkTIFFReader.h.

Constructor & Destructor Documentation

vtkTIFFReader::vtkTIFFReader ( ) [protected]

vtkTIFFReader::~vtkTIFFReader ( ) [protected]

Member Function Documentation

vtkTIFFReader* vtkTIFFReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageReader2.

Referenced by MakeObject().

virtual const char* vtkTIFFReader::GetClassName ( ) [virtual]

Return the class name as a string. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

int vtkTIFFReader::IsTypeOf ( const char * type ) [static]

Return 1 if this class type is the same type of (or a subclass of) the named class. Returns 0 otherwise. This method works in combination with vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

virtual int vtkTIFFReader::IsA ( const char * type ) [virtual]

Return 1 if this class is the same type of (or a subclass of) the named class. Returns 0 otherwise. This method works in combination with vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

vtkTIFFReader* vtkTIFFReader::SafeDownCast ( vtkObject * o ) [static]

Will cast the supplied object to vtkObject* is this is a safe operation (i.e., a safe downcast); otherwise NULL is returned. This method is defined in all subclasses of vtkObject with the vtkTypeRevisionMacro found in vtkSetGet.h.

Reimplemented from vtkObject.

void vtkTIFFReader::GetColor | ( | int | index,
 |  | unsigned short * | r,
 |  | unsigned short * | g,
 |  | unsigned short * | b
 | ) |

unsigned int vtkTIFFReader::GetFormat ( )

void vtkTIFFReader::InitializeColors ( )

void vtkTIFFReader::ReadImageInternal | ( | void * | ,
 |  | void * | outPtr,
 |  | int * | outExt,
 |  | unsigned int | size
 | ) |

virtual vtkImageReader2* vtkTIFFReader::MakeObject ( ) [inline, virtual]

Set/Get the internal file name

Reimplemented from vtkImageReader2.

Definition at line 91 of file vtkTIFFReader.h.

virtual int vtkTIFFReader::CanReadFile ( const char * fname ) [virtual]

virtual const char* vtkTIFFReader::GetFileExensions ( ) [inline, virtual]

Get the file extensions for this format. Returns a string with a space separated list of extensions in the format .extension

Reimplemented from vtkImageReader2.

Definition at line 98 of file vtkTIFFReader.h.

virtual const char* vtkTIFFReader::GetDescriptiveName ( ) [inline, virtual]

Return a descriptive name for the file format that might be useful in a GUI.

Reimplemented from vtkImageReader2.

Definition at line 107 of file vtkTIFFReader.h.

TIFFInternal* vtkTIFFReader::GetInternalImage ( ) [inline]

Definition at line 113 of file vtkTIFFReader.h.

virtual void vtkTIFFReader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkImageReader2.

virtual void vtkTIFFReader::ExecuteData ( vtkDataObject * out ) [protected, virtual]

Reimplemented from vtkImageReader2.

void vtkTIFFReader::ReadGenericImage | ( | void * | out,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | size
 | ) | [protected]

int vtkTIFFReader::EvaluateImageAt | ( | void * | ,
 |  | void * |
 | ) | [protected]

The documentation for this class was generated from the following file:
  • IO/vtkTIFFReader.h
Generated on Mon Mar 25 01:32:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTIFFWriter Class Reference

write out structured points as a TIFF file. More...

#include <vtkTIFFWriter.h>

Inheritance diagram for vtkTIFFWriter:

[legend]
Collaboration diagram for vtkTIFFWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTIFFWriter, vtkImageWriter)

Static Public Methods

vtkTIFFWriter * | New ()

Protected Methods

vtkTIFFWriter ()
~vtkTIFFWriter ()
virtual void | WriteFile (ofstream *file, vtkImageData *data, int ext[6])
virtual void | WriteFileHeader (ofstream *, vtkImageData *)

Detailed Description

write out structured points as a TIFF file.

Date:
2002/01/22 15:38:24
Revision:
1.19

vtkTIFFWriter writes structured points as a non-compressed TIFF data file.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (87%)
  • Lorensen, Bill (8%)
Examples:
vtkTIFFWriter (Examples)
Tests:
vtkTIFFWriter (Tests)

Definition at line 44 of file vtkTIFFWriter.h.

Constructor & Destructor Documentation

vtkTIFFWriter::vtkTIFFWriter ( ) [inline, protected]

Definition at line 51 of file vtkTIFFWriter.h.

vtkTIFFWriter::~vtkTIFFWriter ( ) [inline, protected]

Definition at line 52 of file vtkTIFFWriter.h.

Member Function Documentation

vtkTIFFWriter* vtkTIFFWriter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageWriter.

vtkTIFFWriter::vtkTypeRevisionMacro | ( | vtkTIFFWriter | ,
 |  | vtkImageWriter |
 | ) |

Reimplemented from vtkImageWriter.

virtual void vtkTIFFWriter::WriteFile | ( | ofstream * | file,
 |  | vtkImageData * | data,
 |  | int | ext[6]
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

virtual void vtkTIFFWriter::WriteFileHeader | ( | ofstream * | ,
 |  | vtkImageData * |
 | ) | [protected, virtual]

Reimplemented from vtkImageWriter.

The documentation for this class was generated from the following file:
  • IO/vtkTIFFWriter.h
Generated on Mon Mar 25 01:32:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTimerLog Class Reference

Timer support and logging. More...

#include <vtkTimerLog.h>

Inheritance diagram for vtkTimerLog:

[legend]
Collaboration diagram for vtkTimerLog:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTimerLog, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | StartTimer ()
void | StopTimer ()
double | GetElapsedTime ()

Static Public Methods

vtkTimerLog * | New ()
void | FormatAndMarkEvent (char *EventString,...)
void | DumpLog (char *filename)
void | MarkEvent (char *EventString)
void | ResetLog ()
void | AllocateLog ()
double | GetCurrentTime ()
double | GetCPUTime ()
void | SetMaxEntries (int a)
int | GetMaxEntries ()

Protected Methods

vtkTimerLog ()
~vtkTimerLog ()

Static Protected Methods

void | DumpEntry (ostream &os, int index, float time, float deltatime, int tick, int deltatick, char *event)

Protected Attributes

double | StartTime
double | EndTime

Static Protected Attributes

int | MaxEntries
int | NextEntry
int | WrapFlag
int | TicksPerSecond
vtkTimerLogEntry * TimerLog
timeval | FirstWallTime
timeval | CurrentWallTime
tms | FirstCpuTicks
tms | CurrentCpuTicks

Detailed Description

Timer support and logging.

Date:
2002/01/22 15:26:28
Revision:
1.35

vtkTimerLog contains walltime and cputime measurements associated with a given event. These results can be later analyzed when "dumping out" the table.

In addition, vtkTimerLog allows the user to simply get the current time, and to start/stop a simple timer separate from the timing table logging.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (72%)
  • Miller, Jim (11%)
Examples:
vtkTimerLog (Examples)
Tests:
vtkTimerLog (Tests)

Definition at line 98 of file vtkTimerLog.h.

Constructor & Destructor Documentation

vtkTimerLog::vtkTimerLog ( ) [inline, protected]

Definition at line 151 of file vtkTimerLog.h.

vtkTimerLog::~vtkTimerLog ( ) [inline, protected]

Definition at line 152 of file vtkTimerLog.h.

Member Function Documentation

vtkTimerLog* vtkTimerLog::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTimerLog::vtkTypeRevisionMacro | ( | vtkTimerLog | ,
 |  | vtkObject |
 | ) |

void vtkTimerLog::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

void vtkTimerLog::SetMaxEntries ( int a ) [static]

Set/Get the maximum number of entries allowed in the timer log

int vtkTimerLog::GetMaxEntries ( ) [static]

Set/Get the maximum number of entries allowed in the timer log

void vtkTimerLog::FormatAndMarkEvent | ( | char * | EventString,
 |  | ... |
 | ) | [static]

Record a timing event. The event is represented by a formatted string.

void vtkTimerLog::DumpLog ( char * filename ) [static]

Write the timing table out to a file. Calculate some helpful statistics (deltas and percentages) in the process.

void vtkTimerLog::MarkEvent ( char * EventString ) [static]

Record a timing event and capture wall time and cpu ticks.

void vtkTimerLog::ResetLog ( ) [static]

Clear the timing table. walltime and cputime will also be set to zero when the first new event is recorded.

void vtkTimerLog::AllocateLog ( ) [static]

Allocate timing table with MaxEntries elements.

double vtkTimerLog::GetCurrentTime ( ) [static]

Returns the elapsed number of seconds since January 1, 1970. This is also called Universal Coordinated Time.

double vtkTimerLog::GetCPUTime ( ) [static]

Returns the CPU time for this process On Win32 platforms this actually returns wall time.

void vtkTimerLog::StartTimer ( )

Set the StartTime to the current time. Used with GetElapsedTime().

void vtkTimerLog::StopTimer ( )

Sets EndTime to the current time. Used with GetElapsedTime().

double vtkTimerLog::GetElapsedTime ( )

Returns the difference between StartTime and EndTime as a floating point value indicating the elapsed time in seconds.

void vtkTimerLog::DumpEntry | ( | ostream & | os,
 |  | int | index,
 |  | float | time,
 |  | float | deltatime,
 |  | int | tick,
 |  | int | deltatick,
 |  | char * | event
 | ) | [static, protected]

Member Data Documentation

int vtkTimerLog::MaxEntries [static, protected]

Definition at line 154 of file vtkTimerLog.h.

int vtkTimerLog::NextEntry [static, protected]

Definition at line 155 of file vtkTimerLog.h.

int vtkTimerLog::WrapFlag [static, protected]

Definition at line 156 of file vtkTimerLog.h.

int vtkTimerLog::TicksPerSecond [static, protected]

Definition at line 157 of file vtkTimerLog.h.

vtkTimerLogEntry* vtkTimerLog::TimerLog [static, protected]

Definition at line 158 of file vtkTimerLog.h.

timeval vtkTimerLog::FirstWallTime [static, protected]

Definition at line 169 of file vtkTimerLog.h.

timeval vtkTimerLog::CurrentWallTime [static, protected]

Definition at line 170 of file vtkTimerLog.h.

tms vtkTimerLog::FirstCpuTicks [static, protected]

Definition at line 171 of file vtkTimerLog.h.

tms vtkTimerLog::CurrentCpuTicks [static, protected]

Definition at line 172 of file vtkTimerLog.h.

double vtkTimerLog::StartTime [protected]

Definition at line 177 of file vtkTimerLog.h.

double vtkTimerLog::EndTime [protected]

Definition at line 178 of file vtkTimerLog.h.

The documentation for this class was generated from the following file:
  • Common/vtkTimerLog.h
Generated on Mon Mar 25 01:32:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTimerLogEntry Struct Reference

#include <vtkTimerLog.h>

Collaboration diagram for vtkTimerLogEntry:

[legend]
List of all members.

Public Attributes

float | WallTime
int | CpuTicks
char | Event [VTK_LOG_EVENT_LENGTH]

Member Data Documentation

float vtkTimerLogEntry::WallTime

Definition at line 88 of file vtkTimerLog.h.

int vtkTimerLogEntry::CpuTicks

Definition at line 89 of file vtkTimerLog.h.

char vtkTimerLogEntry::Event[VTK_LOG_EVENT_LENGTH]

Definition at line 90 of file vtkTimerLog.h.

The documentation for this struct was generated from the following file:
  • Common/vtkTimerLog.h
Generated on Mon Mar 25 01:32:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTimeStamp Class Reference

record modification and/or execution time. More...

#include <vtkTimeStamp.h>

Collaboration diagram for vtkTimeStamp:

[legend]
List of all members.

Public Methods

vtkTimeStamp ()
void | Delete ()
virtual const char * | GetClassName ()
void | Modified ()
unsigned long int | GetMTime ()
operator unsigned long ()
int | operator> (vtkTimeStamp &ts)
int | operator< (vtkTimeStamp &ts)

Static Public Methods

vtkTimeStamp * | New ()

Detailed Description

record modification and/or execution time.

Date:
2002/01/22 15:26:27
Revision:
1.43

vtkTimeStamp records a unique time when the method Modified() is executed. This time is guaranteed to be monotonically increasing. Classes use this object to record modified and/or execution time. There is built in support for the binary < and > comparison operators between two vtkTimeStamp objects.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (38%)
  • Schroeder, Will (36%)
  • Lorensen, Bill (9%)
  • Law, Charles (5%)
Tests:
vtkTimeStamp (Tests)

Definition at line 46 of file vtkTimeStamp.h.

Constructor & Destructor Documentation

vtkTimeStamp::vtkTimeStamp ( ) [inline]

Definition at line 49 of file vtkTimeStamp.h.

Member Function Documentation

vtkTimeStamp* vtkTimeStamp::New ( ) [static]

void vtkTimeStamp::Delete ( ) [inline]

Definition at line 51 of file vtkTimeStamp.h.

virtual const char* vtkTimeStamp::GetClassName ( ) [inline, virtual]

Definition at line 53 of file vtkTimeStamp.h.

void vtkTimeStamp::Modified ( )

Set this objects time to the current time. The current time is just a monotonically increasing unsigned long integer. It is possible for this number to wrap around back to zero. This should only happen for processes that have been running for a very long time, while constantly changing objects within the program. When this does occur, the typical consequence should be that some filters will update themselves when really they don't need to.

unsigned long int vtkTimeStamp::GetMTime ( ) [inline]

Return this object's Modified time.

Definition at line 65 of file vtkTimeStamp.h.

int vtkTimeStamp::operator> ( vtkTimeStamp & ts ) [inline]

Support comparisons of time stamp objects directly.

Definition at line 69 of file vtkTimeStamp.h.

int vtkTimeStamp::operator< ( vtkTimeStamp & ts ) [inline]

Support comparisons of time stamp objects directly.

Definition at line 71 of file vtkTimeStamp.h.

vtkTimeStamp::operator unsigned long ( ) [inline]

Allow for typecasting to unsigned long.

Definition at line 76 of file vtkTimeStamp.h.

The documentation for this class was generated from the following file:
  • Common/vtkTimeStamp.h
Generated on Mon Mar 25 01:32:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkImageViewerWidget Class Reference

a Tk Widget for viewing vtk images. More...

#include <vtkTkImageViewerWidget.h>

Collaboration diagram for vtkTkImageViewerWidget:

[legend]
List of all members.

Public Attributes

Tk_Window | TkWin
Tcl_Interp * | Interp
int | Width
int | Height
vtkImageViewer * ImageViewer
char * | IV

Detailed Description

a Tk Widget for viewing vtk images.

Date:
2002/01/22 15:39:27
Revision:
1.11

vtkTkImageViewerWidget is a Tk widget that you can render into. It has a GetImageViewer method that returns a vtkImageViewer. You can also specify a vtkImageViewer to be used when creating the widget by using the -iv option. It also takes -width and -height options. Events can be bound on this widget just like any other Tk widget.

See also:
vtkImageViewer
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (65%)
  • Blezek, Dan (10%)
  • Starreveld, Yves (8%)
  • Lorensen, Bill (6%)
Examples:
vtkTkImageViewerWidget (Examples)
Tests:
vtkTkImageViewerWidget (Tests)

Definition at line 58 of file vtkTkImageViewerWidget.h.

Member Data Documentation

Tk_Window vtkTkImageViewerWidget::TkWin

Definition at line 60 of file vtkTkImageViewerWidget.h.

Tcl_Interp* vtkTkImageViewerWidget::Interp

Definition at line 61 of file vtkTkImageViewerWidget.h.

int vtkTkImageViewerWidget::Width

Definition at line 62 of file vtkTkImageViewerWidget.h.

int vtkTkImageViewerWidget::Height

Definition at line 63 of file vtkTkImageViewerWidget.h.

vtkImageViewer* vtkTkImageViewerWidget::ImageViewer

Definition at line 64 of file vtkTkImageViewerWidget.h.

char* vtkTkImageViewerWidget::IV

Definition at line 65 of file vtkTkImageViewerWidget.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkTkImageViewerWidget.h
Generated on Mon Mar 25 01:32:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkImageWindowWidget Class Reference

a Tk Widget for viewing vtk images. More...

#include <vtkTkImageWindowWidget.h>

Collaboration diagram for vtkTkImageWindowWidget:

[legend]
List of all members.

Public Attributes

Tk_Window | TkWin
Tcl_Interp * | Interp
int | Width
int | Height
vtkImageWindow * ImageWindow
char * | IW

Detailed Description

a Tk Widget for viewing vtk images.

Date:
2002/01/22 15:39:29
Revision:
1.11

vtkTkImageWindowWidget is a Tk widget that you can render into. It has a GetImageWindow method that returns a vtkImageWindow. You can also specify a vtkImageWindow to be used when creating the widget by using the -iw option. It also takes -width and -height options. Events can be bound on this widget just like any other Tk widget.

See also:
vtkImageWindow
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (74%)
  • Starreveld, Yves (9%)
  • Blezek, Dan (7%)
Tests:
vtkTkImageWindowWidget (Tests)

Definition at line 53 of file vtkTkImageWindowWidget.h.

Member Data Documentation

Tk_Window vtkTkImageWindowWidget::TkWin

Definition at line 55 of file vtkTkImageWindowWidget.h.

Tcl_Interp* vtkTkImageWindowWidget::Interp

Definition at line 56 of file vtkTkImageWindowWidget.h.

int vtkTkImageWindowWidget::Width

Definition at line 57 of file vtkTkImageWindowWidget.h.

int vtkTkImageWindowWidget::Height

Definition at line 58 of file vtkTkImageWindowWidget.h.

vtkImageWindow* vtkTkImageWindowWidget::ImageWindow

Definition at line 59 of file vtkTkImageWindowWidget.h.

char* vtkTkImageWindowWidget::IW

Definition at line 60 of file vtkTkImageWindowWidget.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkTkImageWindowWidget.h
Generated on Mon Mar 25 01:32:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTkRenderWidget Class Reference

a Tk Widget for vtk renderering. More...

#include <vtkTkRenderWidget.h>

Collaboration diagram for vtkTkRenderWidget:

[legend]
List of all members.

Public Attributes

Tk_Window | TkWin
Tcl_Interp * | Interp
int | Width
int | Height
vtkRenderWindow * RenderWindow
char * | RW

Detailed Description

a Tk Widget for vtk renderering.

Date:
2002/01/22 15:39:30
Revision:
1.16

vtkTkRenderWidget is a Tk widget that you can render into. It has a GetRenderWindow method that returns a vtkRenderWindow. This can then be used to create a vtkRenderer and etc. You can also specify a vtkRenderWindow to be used when creating the widget by using the -rw option. It also takes -width and -height options. Events can be bound on this widget just like any other Tk widget.

See also:
vtkRenderWindow vtkRenderer
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (45%)
  • Martin, Ken (38%)
Examples:
vtkTkRenderWidget (Examples)
Tests:
vtkTkRenderWidget (Tests)

Definition at line 57 of file vtkTkRenderWidget.h.

Member Data Documentation

Tk_Window vtkTkRenderWidget::TkWin

Definition at line 59 of file vtkTkRenderWidget.h.

Tcl_Interp* vtkTkRenderWidget::Interp

Definition at line 60 of file vtkTkRenderWidget.h.

int vtkTkRenderWidget::Width

Definition at line 61 of file vtkTkRenderWidget.h.

int vtkTkRenderWidget::Height

Definition at line 62 of file vtkTkRenderWidget.h.

vtkRenderWindow* vtkTkRenderWidget::RenderWindow

Definition at line 63 of file vtkTkRenderWidget.h.

char* vtkTkRenderWidget::RW

Definition at line 64 of file vtkTkRenderWidget.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkTkRenderWidget.h
Generated on Mon Mar 25 01:32:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransform Class Reference

describes linear transformations via a 4x4 matrix. More...

#include <vtkTransform.h>

Inheritance diagram for vtkTransform:

[legend]
Collaboration diagram for vtkTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransform, vtkLinearTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Identity ()
void | Inverse ()
void | Concatenate (vtkLinearTransform *transform)
void | GetInverse (vtkMatrix4x4 *inverse)
void | GetTranspose (vtkMatrix4x4 *transpose)
int | CircuitCheck (vtkAbstractTransform *transform)
vtkAbstractTransform * GetInverse ()
vtkAbstractTransform * MakeTransform ()
unsigned long | GetMTime ()
void | Translate (double x, double y, double z)
void | Translate (const double x[3])
void | Translate (const float x[3])
void | RotateWXYZ (double angle, double x, double y, double z)
void | RotateWXYZ (double angle, const double axis[3])
void | RotateWXYZ (double angle, const float axis[3])
void | RotateX (double angle)
void | RotateY (double angle)
void | RotateZ (double angle)
void | Scale (double x, double y, double z)
void | Scale (const double s[3])
void | Scale (const float s[3])
void | SetMatrix (vtkMatrix4x4 *matrix)
void | SetMatrix (const double elements[16])
void | Concatenate (vtkMatrix4x4 *matrix)
void | Concatenate (const double elements[16])
void | PreMultiply ()
void | PostMultiply ()
int | GetNumberOfConcatenatedTransforms ()
vtkLinearTransform * | GetConcatenatedTransform (int i)
void | GetOrientation (double orient[3])
void | GetOrientation (float orient[3])
float * | GetOrientation ()
void | GetOrientationWXYZ (double wxyz[4])
void | GetOrientationWXYZ (float wxyz[3])
float * | GetOrientationWXYZ ()
void | GetPosition (double pos[3])
void | GetPosition (float pos[3])
float * | GetPosition ()
void | GetScale (double scale[3])
void | GetScale (float scale[3])
float * | GetScale ()
void | SetInput (vtkLinearTransform *input)
vtkLinearTransform * GetInput ()
int | GetInverseFlag ()
void | Push ()
void | Pop ()
void | MultiplyPoint (const float in[4], float out[4])
void | MultiplyPoint (const double in[4], double out[4])

Static Public Methods

vtkTransform * | New ()

Protected Methods

vtkTransform ()
~vtkTransform ()
void | InternalDeepCopy (vtkAbstractTransform *t)
void | InternalUpdate ()

Protected Attributes

vtkLinearTransform * Input
vtkTransformConcatenation * Concatenation
vtkTransformConcatenationStack * Stack
unsigned long | MatrixUpdateMTime
float | Point [4]
double | DoublePoint [4]
float | ReturnValue [4]

Detailed Description

describes linear transformations via a 4x4 matrix.

Date:
2002/01/22 15:26:29
Revision:
1.82

A vtkTransform can be used to describe the full range of linear (also known as affine) coordinate transformations in three dimensions, which are internally represented as a 4x4 homogeneous transformation matrix. When you create a new vtkTransform, it is always initialized to the identity transformation.

The SetInput() method allows you to set another transform, instead of the identity transform, to be the base transformation. There is a pipeline mechanism to ensure that when the input is modified, the current transformation will be updated accordingly. This pipeline mechanism is also supported by the Concatenate() method.

Most of the methods for manipulating this transformation, e.g. Translate, Rotate, and Concatenate, can operate in either PreMultiply (the default) or PostMultiply mode. In PreMultiply mode, the translation, concatenation, etc. will occur before any transformations which are represented by the current matrix. In PostMultiply mode, the additional transformation will occur after any transformations represented by the current matrix.

This class performs all of its operations in a right handed coordinate system with right handed rotations. Some other graphics libraries use left handed coordinate systems and rotations.

See also:
vtkPerspectiveTransform vtkGeneralTransform vtkMatrix4x4 vtkTransformCollection vtkTransformFilter vtkTransformPolyDataFilter vtkImageReslice
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Gobbi, David (39%)
  • Lorensen, Bill (16%)
  • Schroeder, Will (15%)
  • Martin, Ken (12%)
  • Volpe, Christopher (6%)
Examples:
vtkTransform (Examples)
Tests:
vtkTransform (Tests)

Definition at line 71 of file vtkTransform.h.

Constructor & Destructor Documentation

vtkTransform::vtkTransform ( ) [protected]

vtkTransform::~vtkTransform ( ) [protected]

Member Function Documentation

vtkTransform* vtkTransform::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTransform::vtkTypeRevisionMacro | ( | vtkTransform | ,
 |  | vtkLinearTransform |
 | ) |

Reimplemented from vtkLinearTransform.

void vtkTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLinearTransform.

void vtkTransform::Identity ( )

Set the transformation to the identity transformation. If the transform has an Input, then the transformation will be reset so that it is the same as the Input.

Reimplemented from vtkAbstractTransform.

void vtkTransform::Inverse ( ) [virtual]

Invert the transformation. This will also set a flag so that the transformation will use the inverse of its Input, if an Input has been set.

Reimplemented from vtkAbstractTransform.

void vtkTransform::Translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 91 of file vtkTransform.h.

void vtkTransform::Translate ( const double x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 93 of file vtkTransform.h.

void vtkTransform::Translate ( const float x[3] ) [inline]

Create a translation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 94 of file vtkTransform.h.

void vtkTransform::RotateWXYZ | ( | double | angle,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 102 of file vtkTransform.h.

void vtkTransform::RotateWXYZ | ( | double | angle,
 |  | const double | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 104 of file vtkTransform.h.

void vtkTransform::RotateWXYZ | ( | double | angle,
 |  | const float | axis[3]
 | ) | [inline]

Create a rotation matrix and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is in degrees, and (x,y,z) specifies the axis that the rotation will be performed around.

Definition at line 106 of file vtkTransform.h.

void vtkTransform::RotateX ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 114 of file vtkTransform.h.

void vtkTransform::RotateY ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 115 of file vtkTransform.h.

void vtkTransform::RotateZ ( double angle ) [inline]

Create a rotation matrix about the X, Y, or Z axis and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics. The angle is expressed in degrees.

Definition at line 116 of file vtkTransform.h.

void vtkTransform::Scale | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) | [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 123 of file vtkTransform.h.

void vtkTransform::Scale ( const double s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 125 of file vtkTransform.h.

void vtkTransform::Scale ( const float s[3] ) [inline]

Create a scale matrix (i.e. set the diagonal elements to x, y, z) and concatenate it with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 126 of file vtkTransform.h.

void vtkTransform::SetMatrix ( vtkMatrix4x4 * matrix ) [inline]

Set the current matrix directly. This actually calls Identity(), followed by Concatenate(matrix).

Definition at line 132 of file vtkTransform.h.

void vtkTransform::SetMatrix ( const double elements[16] ) [inline]

Set the current matrix directly. This actually calls Identity(), followed by Concatenate(matrix).

Definition at line 134 of file vtkTransform.h.

void vtkTransform::Concatenate ( vtkMatrix4x4 * matrix ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 141 of file vtkTransform.h.

void vtkTransform::Concatenate ( const double elements[16] ) [inline]

Concatenates the matrix with the current transformation according to PreMultiply or PostMultiply semantics.

Definition at line 143 of file vtkTransform.h.

void vtkTransform::Concatenate ( vtkLinearTransform * transform )

Concatenate the specified transform with the current transformation according to PreMultiply or PostMultiply semantics. The concatenation is pipelined, meaning that if any of the transformations are changed, even after Concatenate() is called, those changes will be reflected when you call TransformPoint().

void vtkTransform::PreMultiply ( ) [inline]

Sets the internal state of the transform to PreMultiply. All subsequent operations will occur before those already represented in the current transformation. In homogeneous matrix notation, M = M*A where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 160 of file vtkTransform.h.

void vtkTransform::PostMultiply ( ) [inline]

Sets the internal state of the transform to PostMultiply. All subsequent operations will occur after those already represented in the current transformation. In homogeneous matrix notation, M = A*M where M is the current transformation matrix and A is the applied matrix. The default is PreMultiply.

Definition at line 171 of file vtkTransform.h.

int vtkTransform::GetNumberOfConcatenatedTransforms ( ) [inline]

Get the total number of transformations that are linked into this one via Concatenate() operations or via SetInput().

Definition at line 179 of file vtkTransform.h.

vtkLinearTransform* vtkTransform::GetConcatenatedTransform ( int i ) [inline]

Get one of the concatenated transformations as a vtkAbstractTransform. These transformations are applied, in series, every time the transformation of a coordinate occurs. This method is provided to make it possible to decompose a transformation into its constituents, for example to save a transformation to a file.

Definition at line 190 of file vtkTransform.h.

void vtkTransform::GetOrientation ( double orient[3] )

Get the x, y, z orientation angles from the transformation matrix as an array of three floating point values.

void vtkTransform::GetOrientation ( float orient[3] ) [inline]

Get the x, y, z orientation angles from the transformation matrix as an array of three floating point values.

Definition at line 207 of file vtkTransform.h.

float* vtkTransform::GetOrientation ( ) [inline]

Get the x, y, z orientation angles from the transformation matrix as an array of three floating point values.

Definition at line 210 of file vtkTransform.h.

void vtkTransform::GetOrientationWXYZ ( double wxyz[4] )

Return the wxyz angle+axis representing the current orientation.

void vtkTransform::GetOrientationWXYZ ( float wxyz[3] ) [inline]

Return the wxyz angle+axis representing the current orientation.

Definition at line 217 of file vtkTransform.h.

float* vtkTransform::GetOrientationWXYZ ( ) [inline]

Return the wxyz angle+axis representing the current orientation.

Definition at line 220 of file vtkTransform.h.

void vtkTransform::GetPosition ( double pos[3] )

Return the position from the current transformation matrix as an array of three floating point numbers. This is simply returning the translation component of the 4x4 matrix.

void vtkTransform::GetPosition ( float pos[3] ) [inline]

Return the position from the current transformation matrix as an array of three floating point numbers. This is simply returning the translation component of the 4x4 matrix.

Definition at line 229 of file vtkTransform.h.

float* vtkTransform::GetPosition ( ) [inline]

Return the position from the current transformation matrix as an array of three floating point numbers. This is simply returning the translation component of the 4x4 matrix.

Definition at line 232 of file vtkTransform.h.

void vtkTransform::GetScale ( double scale[3] )

Return the scale factors of the current transformation matrix as an array of three float numbers. These scale factors are not necessarily about the x, y, and z axes unless unless the scale transformation was applied before any rotations.

void vtkTransform::GetScale ( float scale[3] ) [inline]

Return the scale factors of the current transformation matrix as an array of three float numbers. These scale factors are not necessarily about the x, y, and z axes unless unless the scale transformation was applied before any rotations.

Definition at line 242 of file vtkTransform.h.

float* vtkTransform::GetScale ( ) [inline]

Return the scale factors of the current transformation matrix as an array of three float numbers. These scale factors are not necessarily about the x, y, and z axes unless unless the scale transformation was applied before any rotations.

Definition at line 245 of file vtkTransform.h.

void vtkTransform::GetInverse ( vtkMatrix4x4 * inverse )

Return a matrix which is the inverse of the current transformation matrix.

void vtkTransform::GetTranspose ( vtkMatrix4x4 * transpose )

Return a matrix which is the transpose of the current transformation matrix. This is equivalent to the inverse if and only if the transformation is a pure rotation with no translation or scale.

void vtkTransform::SetInput ( vtkLinearTransform * input )

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

vtkLinearTransform* vtkTransform::GetInput ( ) [inline]

Set the input for this transformation. This will be used as the base transformation if it is set. This method allows you to build a transform pipeline: if the input is modified, then this transformation will automatically update accordingly. Note that the InverseFlag, controlled via Inverse(), determines whether this transformation will use the Input or the inverse of the Input.

Definition at line 266 of file vtkTransform.h.

int vtkTransform::GetInverseFlag ( ) [inline]

Get the inverse flag of the transformation. This controls whether it is the Input or the inverse of the Input that is used as the base transformation. The InverseFlag is flipped every time Inverse() is called. The InverseFlag is off when a transform is first created.

Definition at line 274 of file vtkTransform.h.

void vtkTransform::Push ( ) [inline]

Pushes the current transformation onto the transformation stack.

Definition at line 280 of file vtkTransform.h.

void vtkTransform::Pop ( ) [inline]

Deletes the transformation on the top of the stack and sets the top to the next transformation on the stack.

Definition at line 289 of file vtkTransform.h.

int vtkTransform::CircuitCheck ( vtkAbstractTransform * transform ) [virtual]

Check for self-reference. Will return true if concatenating with the specified transform, setting it to be our inverse, or setting it to be our input will create a circular reference. CircuitCheck is automatically called by SetInput(), SetInverse(), and Concatenate(vtkXTransform *). Avoid using this function, it is experimental.

Reimplemented from vtkAbstractTransform.

vtkAbstractTransform* vtkTransform::GetInverse ( ) [inline]

Get the inverse of this transform. If you modify this transform, the returned inverse transform will automatically update. If you want the inverse of a vtkTransform, you might want to use GetLinearInverse() instead which will type cast the result from vtkAbstractTransform to vtkLinearTransform.

Reimplemented from vtkAbstractTransform.

Definition at line 304 of file vtkTransform.h.

vtkAbstractTransform* vtkTransform::MakeTransform ( ) [virtual]

Make a new transform of the same type.

Reimplemented from vtkAbstractTransform.

unsigned long vtkTransform::GetMTime ( ) [virtual]

Override GetMTime to account for input and concatenation.

Reimplemented from vtkAbstractTransform.

void vtkTransform::MultiplyPoint | ( | const float | in[4],
 |  | float | out[4]
 | ) | [inline]

Use this method only if you wish to compute the transformation in homogeneous (x,y,z,w) coordinates, otherwise use TransformPoint(). This method calls this->GetMatrix()->MultiplyPoint().

Definition at line 317 of file vtkTransform.h.

void vtkTransform::MultiplyPoint | ( | const double | in[4],
 |  | double | out[4]
 | ) | [inline]

Use this method only if you wish to compute the transformation in homogeneous (x,y,z,w) coordinates, otherwise use TransformPoint(). This method calls this->GetMatrix()->MultiplyPoint().

Definition at line 319 of file vtkTransform.h.

void vtkTransform::InternalDeepCopy ( vtkAbstractTransform * t ) [protected, virtual]

Perform any subclass-specific DeepCopy.

Reimplemented from vtkHomogeneousTransform.

void vtkTransform::InternalUpdate ( ) [protected, virtual]

Perform any subclass-specific Update.

Reimplemented from vtkAbstractTransform.

Member Data Documentation

vtkLinearTransform* vtkTransform::Input [protected]

Definition at line 331 of file vtkTransform.h.

vtkTransformConcatenation* vtkTransform::Concatenation [protected]

Definition at line 332 of file vtkTransform.h.

vtkTransformConcatenationStack* vtkTransform::Stack [protected]

Definition at line 333 of file vtkTransform.h.

unsigned long vtkTransform::MatrixUpdateMTime [protected]

Definition at line 337 of file vtkTransform.h.

float vtkTransform::Point[4] [protected]

Definition at line 339 of file vtkTransform.h.

double vtkTransform::DoublePoint[4] [protected]

Definition at line 340 of file vtkTransform.h.

float vtkTransform::ReturnValue[4] [protected]

Definition at line 341 of file vtkTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkTransform.h
Generated on Mon Mar 25 01:32:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformCollection Class Reference

maintain a list of transforms. More...

#include <vtkTransformCollection.h>

Inheritance diagram for vtkTransformCollection:

[legend]
Collaboration diagram for vtkTransformCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransformCollection, vtkCollection)
void | AddItem (vtkTransform *)
vtkTransform * GetNextItem ()

Static Public Methods

vtkTransformCollection * | New ()

Protected Methods

vtkTransformCollection ()
~vtkTransformCollection ()

Detailed Description

maintain a list of transforms.

Date:
2002/01/22 15:26:30
Revision:
1.31

vtkTransformCollection is an object that creates and manipulates lists of objects of type vtkTransform.

See also:
vtkCollection vtkTransform
Created by:
  • Hoffman, Bill
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (35%)
  • Hoffman, Bill (31%)
  • Martin, Ken (30%)
Tests:
vtkTransformCollection (Tests)

Definition at line 48 of file vtkTransformCollection.h.

Constructor & Destructor Documentation

vtkTransformCollection::vtkTransformCollection ( ) [inline, protected]

Definition at line 62 of file vtkTransformCollection.h.

vtkTransformCollection::~vtkTransformCollection ( ) [inline, protected]

Definition at line 63 of file vtkTransformCollection.h.

Member Function Documentation

vtkTransformCollection::vtkTypeRevisionMacro | ( | vtkTransformCollection | ,
 |  | vtkCollection |
 | ) |

Reimplemented from vtkCollection.

vtkTransformCollection* vtkTransformCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkCollection.

void vtkTransformCollection::AddItem ( vtkTransform * t ) [inline]

Add a Transform to the list.

Definition at line 75 of file vtkTransformCollection.h.

vtkTransform * vtkTransformCollection::GetNextItem ( ) [inline]

Get the next Transform in the list. Return NULL when the end of the list is reached.

Definition at line 80 of file vtkTransformCollection.h.

The documentation for this class was generated from the following file:
  • Common/vtkTransformCollection.h
Generated on Mon Mar 25 01:32:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformConcatenation Class Reference

#include <vtkAbstractTransform.h>

Collaboration diagram for vtkTransformConcatenation:

[legend]
List of all members.

Public Methods

void | Delete ()
void | Concatenate (vtkAbstractTransform *transform)
void | Concatenate (const double elements[16])
void | SetPreMultiplyFlag (int flag)
int | GetPreMultiplyFlag ()
void | Translate (double x, double y, double z)
void | Rotate (double angle, double x, double y, double z)
void | Scale (double x, double y, double z)
void | Inverse ()
int | GetInverseFlag ()
void | Identity ()
void | DeepCopy (vtkTransformConcatenation *transform)
int | GetNumberOfTransforms ()
int | GetNumberOfPreTransforms ()
int | GetNumberOfPostTransforms ()
vtkAbstractTransform * | GetTransform (int i)
unsigned long | GetMaxMTime ()
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkTransformConcatenation * | New ()

Protected Methods

vtkTransformConcatenation ()
~vtkTransformConcatenation ()

Protected Attributes

int | InverseFlag
int | PreMultiplyFlag
vtkMatrix4x4 * PreMatrix
vtkMatrix4x4 * PostMatrix
vtkAbstractTransform * PreMatrixTransform
vtkAbstractTransform * PostMatrixTransform
int | NumberOfTransforms
int | NumberOfPreTransforms
int | MaxNumberOfTransforms
vtkTransformPair * TransformList

Constructor & Destructor Documentation

vtkTransformConcatenation::vtkTransformConcatenation ( ) [protected]

vtkTransformConcatenation::~vtkTransformConcatenation ( ) [protected]

Member Function Documentation

vtkTransformConcatenation* vtkTransformConcatenation::New ( ) [inline, static]

Definition at line 327 of file vtkAbstractTransform.h.

void vtkTransformConcatenation::Delete ( ) [inline]

Definition at line 329 of file vtkAbstractTransform.h.

void vtkTransformConcatenation::Concatenate ( vtkAbstractTransform * transform )

void vtkTransformConcatenation::Concatenate ( const double elements[16] )

void vtkTransformConcatenation::SetPreMultiplyFlag ( int flag ) [inline]

Definition at line 338 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::GetPreMultiplyFlag ( ) [inline]

Definition at line 339 of file vtkAbstractTransform.h.

void vtkTransformConcatenation::Translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

void vtkTransformConcatenation::Rotate | ( | double | angle,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) |

void vtkTransformConcatenation::Scale | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

void vtkTransformConcatenation::Inverse ( )

int vtkTransformConcatenation::GetInverseFlag ( ) [inline]

Definition at line 350 of file vtkAbstractTransform.h.

void vtkTransformConcatenation::Identity ( )

void vtkTransformConcatenation::DeepCopy ( vtkTransformConcatenation * transform )

int vtkTransformConcatenation::GetNumberOfTransforms ( ) [inline]

Definition at line 359 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::GetNumberOfPreTransforms ( ) [inline]

Definition at line 364 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::GetNumberOfPostTransforms ( ) [inline]

Definition at line 367 of file vtkAbstractTransform.h.

vtkAbstractTransform* vtkTransformConcatenation::GetTransform ( int i )

unsigned long vtkTransformConcatenation::GetMaxMTime ( )

void vtkTransformConcatenation::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) |

Member Data Documentation

int vtkTransformConcatenation::InverseFlag [protected]

Definition at line 382 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::PreMultiplyFlag [protected]

Definition at line 383 of file vtkAbstractTransform.h.

vtkMatrix4x4* vtkTransformConcatenation::PreMatrix [protected]

Definition at line 385 of file vtkAbstractTransform.h.

vtkMatrix4x4* vtkTransformConcatenation::PostMatrix [protected]

Definition at line 386 of file vtkAbstractTransform.h.

vtkAbstractTransform* vtkTransformConcatenation::PreMatrixTransform [protected]

Definition at line 387 of file vtkAbstractTransform.h.

vtkAbstractTransform* vtkTransformConcatenation::PostMatrixTransform [protected]

Definition at line 388 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::NumberOfTransforms [protected]

Definition at line 390 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::NumberOfPreTransforms [protected]

Definition at line 391 of file vtkAbstractTransform.h.

int vtkTransformConcatenation::MaxNumberOfTransforms [protected]

Definition at line 392 of file vtkAbstractTransform.h.

vtkTransformPair* vtkTransformConcatenation::TransformList [protected]

Definition at line 393 of file vtkAbstractTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractTransform.h
Generated on Mon Mar 25 01:32:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformConcatenationStack Class Reference

#include <vtkAbstractTransform.h>

Collaboration diagram for vtkTransformConcatenationStack:

[legend]
List of all members.

Public Methods

void | Delete ()
void | Pop (vtkTransformConcatenation **concat)
void | Push (vtkTransformConcatenation **concat)
void | DeepCopy (vtkTransformConcatenationStack *stack)

Static Public Methods

vtkTransformConcatenationStack * | New ()

Protected Methods

vtkTransformConcatenationStack ()
~vtkTransformConcatenationStack ()

Protected Attributes

int | StackSize
vtkTransformConcatenation ** Stack
vtkTransformConcatenation ** StackBottom

Constructor & Destructor Documentation

vtkTransformConcatenationStack::vtkTransformConcatenationStack ( ) [protected]

vtkTransformConcatenationStack::~vtkTransformConcatenationStack ( ) [protected]

Member Function Documentation

vtkTransformConcatenationStack* vtkTransformConcatenationStack::New ( ) [inline, static]

Definition at line 401 of file vtkAbstractTransform.h.

Referenced by vtkTransform::Push(), vtkPerspectiveTransform::Push(), and vtkGeneralTransform::Push().

void vtkTransformConcatenationStack::Delete ( ) [inline]

Definition at line 403 of file vtkAbstractTransform.h.

void vtkTransformConcatenationStack::Pop ( vtkTransformConcatenation ** concat )

void vtkTransformConcatenationStack::Push ( vtkTransformConcatenation ** concat )

void vtkTransformConcatenationStack::DeepCopy ( vtkTransformConcatenationStack * stack )

Member Data Documentation

int vtkTransformConcatenationStack::StackSize [protected]

Definition at line 419 of file vtkAbstractTransform.h.

vtkTransformConcatenation** vtkTransformConcatenationStack::Stack [protected]

Definition at line 420 of file vtkAbstractTransform.h.

vtkTransformConcatenation** vtkTransformConcatenationStack::StackBottom [protected]

Definition at line 421 of file vtkAbstractTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractTransform.h
Generated on Mon Mar 25 01:32:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformFilter Class Reference

transform points and associated normals and vectors. More...

#include <vtkTransformFilter.h>

Inheritance diagram for vtkTransformFilter:

[legend]
Collaboration diagram for vtkTransformFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransformFilter, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetTransform (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetTransform ()

Static Public Methods

vtkTransformFilter * | New ()

Protected Methods

vtkTransformFilter ()
~vtkTransformFilter ()
void | Execute ()

Protected Attributes

vtkAbstractTransform * Transform

Detailed Description

transform points and associated normals and vectors.

Date:
2002/01/22 15:29:53
Revision:
1.41

vtkTransformFilter is a filter to transform point coordinates, and associated point normals and vectors. Other point data is passed through the filter.

An alternative method of transformation is to use vtkActor's methods to scale, rotate, and translate objects. The difference between the two methods is that vtkActor's transformation simply effects where objects are rendered (via the graphics pipeline), whereas vtkTransformFilter actually modifies point coordinates in the visualization pipeline. This is necessary for some objects (e.g., vtkProbeFilter) that require point coordinates as input.

See also:
vtkAbstractTransform vtkTransformPolyDataFilter vtkActor
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (64%)
  • Gobbi, David (12%)
  • Geveci, Berk (9%)
  • Martin, Ken (7%)
Tests:
vtkTransformFilter (Tests)

Definition at line 56 of file vtkTransformFilter.h.

Constructor & Destructor Documentation

vtkTransformFilter::vtkTransformFilter ( ) [protected]

vtkTransformFilter::~vtkTransformFilter ( ) [protected]

Member Function Documentation

vtkTransformFilter* vtkTransformFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkTransformFilter::vtkTypeRevisionMacro | ( | vtkTransformFilter | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkTransformFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

unsigned long vtkTransformFilter::GetMTime ( ) [virtual]

Return the MTime also considering the transform.

Reimplemented from vtkObject.

virtual void vtkTransformFilter::SetTransform ( vtkAbstractTransform * ) [virtual]

Specify the transform object used to transform points.

virtual vtkAbstractTransform* vtkTransformFilter::GetTransform ( ) [virtual]

Specify the transform object used to transform points.

void vtkTransformFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkAbstractTransform* vtkTransformFilter::Transform [protected]

Definition at line 77 of file vtkTransformFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTransformFilter.h
Generated on Mon Mar 25 01:32:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformPair Class Reference

#include <vtkAbstractTransform.h>

Collaboration diagram for vtkTransformPair:

[legend]
List of all members.

Public Methods

void SwapForwardInverse ()

Public Attributes

vtkAbstractTransform * ForwardTransform
vtkAbstractTransform * InverseTransform

Member Function Documentation

void vtkTransformPair::SwapForwardInverse ( ) [inline]

Definition at line 316 of file vtkAbstractTransform.h.

Member Data Documentation

vtkAbstractTransform* vtkTransformPair::ForwardTransform

Definition at line 313 of file vtkAbstractTransform.h.

vtkAbstractTransform* vtkTransformPair::InverseTransform

Definition at line 314 of file vtkAbstractTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkAbstractTransform.h
Generated on Mon Mar 25 01:32:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformPolyDataFilter Class Reference

transform points and associated normals and vectors for polygonal dataset. More...

#include <vtkTransformPolyDataFilter.h>

Inheritance diagram for vtkTransformPolyDataFilter:

[legend]
Collaboration diagram for vtkTransformPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransformPolyDataFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetTransform (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetTransform ()

Static Public Methods

vtkTransformPolyDataFilter * | New ()

Protected Methods

vtkTransformPolyDataFilter ()
~vtkTransformPolyDataFilter ()
void | Execute ()

Protected Attributes

vtkAbstractTransform * Transform

Detailed Description

transform points and associated normals and vectors for polygonal dataset.

Date:
2002/01/22 15:29:53
Revision:
1.23

vtkTransformPolyDataFilter is a filter to transform point coordinates and associated point and cell normals and vectors. Other point and cell data is passed through the filter unchanged. This filter is specialized for polygonal data. See vtkTransformFilter for more general data.

An alternative method of transformation is to use vtkActor's methods to scale, rotate, and translate objects. The difference between the two methods is that vtkActor's transformation simply effects where objects are rendered (via the graphics pipeline), whereas vtkTransformPolyDataFilter actually modifies point coordinates in the visualization pipeline. This is necessary for some objects (e.g., vtkProbeFilter) that require point coordinates as input.

See also:
vtkTransform vtkTransformFilter vtkActor
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Gobbi, David (23%)
  • Geveci, Berk (10%)
Examples:
vtkTransformPolyDataFilter (Examples)
Tests:
vtkTransformPolyDataFilter (Tests)

Definition at line 60 of file vtkTransformPolyDataFilter.h.

Constructor & Destructor Documentation

vtkTransformPolyDataFilter::vtkTransformPolyDataFilter ( ) [protected]

vtkTransformPolyDataFilter::~vtkTransformPolyDataFilter ( ) [protected]

Member Function Documentation

vtkTransformPolyDataFilter* vtkTransformPolyDataFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkTransformPolyDataFilter::vtkTypeRevisionMacro | ( | vtkTransformPolyDataFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkTransformPolyDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

unsigned long vtkTransformPolyDataFilter::GetMTime ( ) [virtual]

Return the MTime also considering the transform.

Reimplemented from vtkObject.

virtual void vtkTransformPolyDataFilter::SetTransform ( vtkAbstractTransform * ) [virtual]

Specify the transform object used to transform points.

virtual vtkAbstractTransform* vtkTransformPolyDataFilter::GetTransform ( ) [virtual]

Specify the transform object used to transform points.

void vtkTransformPolyDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkAbstractTransform* vtkTransformPolyDataFilter::Transform [protected]

Definition at line 81 of file vtkTransformPolyDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTransformPolyDataFilter.h
Generated on Mon Mar 25 01:32:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformTextureCoords Class Reference

transform (scale, rotate, translate) texture coordinates. More...

#include <vtkTransformTextureCoords.h>

Inheritance diagram for vtkTransformTextureCoords:

[legend]
Collaboration diagram for vtkTransformTextureCoords:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransformTextureCoords, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetPosition (float, float, float)
virtual void | SetPosition (float[3])
virtual float * | GetPosition ()
virtual void | GetPosition (float data[3])
void | AddPosition (float deltaR, float deltaS, float deltaT)
void | AddPosition (float deltaPosition[3])
virtual void | SetScale (float, float, float)
virtual void | SetScale (float[3])
virtual float * | GetScale ()
virtual void | GetScale (float data[3])
virtual void | SetOrigin (float, float, float)
virtual void | SetOrigin (float[3])
virtual float * | GetOrigin ()
virtual void | GetOrigin (float data[3])
virtual void | SetFlipR (int)
virtual int | GetFlipR ()
virtual void | FlipROn ()
virtual void | FlipROff ()
virtual void | SetFlipS (int)
virtual int | GetFlipS ()
virtual void | FlipSOn ()
virtual void | FlipSOff ()
virtual void | SetFlipT (int)
virtual int | GetFlipT ()
virtual void | FlipTOn ()
virtual void | FlipTOff ()

Static Public Methods

vtkTransformTextureCoords * | New ()

Protected Methods

vtkTransformTextureCoords ()
~vtkTransformTextureCoords ()
void | Execute ()

Protected Attributes

float | Origin [3]
float | Position [3]
float | Scale [3]
int | FlipR
int | FlipS
int | FlipT

Detailed Description

transform (scale, rotate, translate) texture coordinates.

Date:
2002/01/22 15:29:53
Revision:
1.29

vtkTransformTextureCoords is a filter that operates on texture coordinates. It ingests any type of dataset, and outputs a dataset of the same type. The filter lets you scale, translate, and rotate texture coordinates. For example, by using the the Scale ivar, you can shift texture coordinates that range from (0->1) to range from (0->10) (useful for repeated patterns).

The filter operates on texture coordinates of dimension 1->3. The texture coordinates are referred to as r-s-t. If the texture map is two dimensional, the t-coordinate (and operations on the t-coordinate) are ignored.

See also:
vtkTextureMapToPlane vtkTextureMapToBox vtkTextureMapToCylinder vtkTextureMapToSphere vtkThresholdTextureCoords vtkTexture
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (75%)
  • Martin, Ken (6%)
Examples:
vtkTransformTextureCoords (Examples)
Tests:
vtkTransformTextureCoords (Tests)

Definition at line 56 of file vtkTransformTextureCoords.h.

Constructor & Destructor Documentation

vtkTransformTextureCoords::vtkTransformTextureCoords ( ) [protected]

vtkTransformTextureCoords::~vtkTransformTextureCoords ( ) [inline, protected]

Definition at line 123 of file vtkTransformTextureCoords.h.

Member Function Documentation

vtkTransformTextureCoords::vtkTypeRevisionMacro | ( | vtkTransformTextureCoords | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkTransformTextureCoords::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTransformTextureCoords* vtkTransformTextureCoords::New ( ) [static]

Create instance with Origin (0.5,0.5,0.5); Position (0,0,0); and Scale set to (1,1,1). Rotation of the texture coordinates is turned off.

Reimplemented from vtkDataSetSource.

virtual void vtkTransformTextureCoords::SetPosition | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the position of the texture map. Setting the position translates the texture map by the amount specified.

virtual void vtkTransformTextureCoords::SetPosition ( float [3] ) [virtual]

Set/Get the position of the texture map. Setting the position translates the texture map by the amount specified.

virtual float* vtkTransformTextureCoords::GetPosition ( ) [virtual]

Set/Get the position of the texture map. Setting the position translates the texture map by the amount specified.

virtual void vtkTransformTextureCoords::GetPosition ( float data[3] ) [virtual]

Set/Get the position of the texture map. Setting the position translates the texture map by the amount specified.

void vtkTransformTextureCoords::AddPosition | ( | float | deltaR,
 |  | float | deltaS,
 |  | float | deltaT
 | ) |

Incrementally change the position of the texture map (i.e., does a translate or shift of the texture coordinates).

void vtkTransformTextureCoords::AddPosition ( float deltaPosition[3] )

Incrementally change the position of the texture map (i.e., does a translate or shift of the texture coordinates).

virtual void vtkTransformTextureCoords::SetScale | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the scale of the texture map. Scaling in performed independently on the r, s and t axes.

virtual void vtkTransformTextureCoords::SetScale ( float [3] ) [virtual]

Set/Get the scale of the texture map. Scaling in performed independently on the r, s and t axes.

virtual float* vtkTransformTextureCoords::GetScale ( ) [virtual]

Set/Get the scale of the texture map. Scaling in performed independently on the r, s and t axes.

virtual void vtkTransformTextureCoords::GetScale ( float data[3] ) [virtual]

Set/Get the scale of the texture map. Scaling in performed independently on the r, s and t axes.

virtual void vtkTransformTextureCoords::SetOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the origin of the texture map. This is the point about which the texture map is flipped (e.g., rotated). Since a typical texture map ranges from (0,1) in the r-s-t coordinates, the default origin is set at (0.5,0.5,0.5).

virtual void vtkTransformTextureCoords::SetOrigin ( float [3] ) [virtual]

Set/Get the origin of the texture map. This is the point about which the texture map is flipped (e.g., rotated). Since a typical texture map ranges from (0,1) in the r-s-t coordinates, the default origin is set at (0.5,0.5,0.5).

virtual float* vtkTransformTextureCoords::GetOrigin ( ) [virtual]

Set/Get the origin of the texture map. This is the point about which the texture map is flipped (e.g., rotated). Since a typical texture map ranges from (0,1) in the r-s-t coordinates, the default origin is set at (0.5,0.5,0.5).

virtual void vtkTransformTextureCoords::GetOrigin ( float data[3] ) [virtual]

Set/Get the origin of the texture map. This is the point about which the texture map is flipped (e.g., rotated). Since a typical texture map ranges from (0,1) in the r-s-t coordinates, the default origin is set at (0.5,0.5,0.5).

virtual void vtkTransformTextureCoords::SetFlipR ( int ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual int vtkTransformTextureCoords::GetFlipR ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipROn ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipROff ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::SetFlipS ( int ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual int vtkTransformTextureCoords::GetFlipS ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipSOn ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipSOff ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the s-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::SetFlipT ( int ) [virtual]

Boolean indicates whether the texture map should be flipped around the t-axis. Note that the flips occur around the texture origin.

virtual int vtkTransformTextureCoords::GetFlipT ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the t-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipTOn ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the t-axis. Note that the flips occur around the texture origin.

virtual void vtkTransformTextureCoords::FlipTOff ( ) [virtual]

Boolean indicates whether the texture map should be flipped around the t-axis. Note that the flips occur around the texture origin.

void vtkTransformTextureCoords::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkTransformTextureCoords::Origin[3] [protected]

Definition at line 127 of file vtkTransformTextureCoords.h.

float vtkTransformTextureCoords::Position[3] [protected]

Definition at line 128 of file vtkTransformTextureCoords.h.

float vtkTransformTextureCoords::Scale[3] [protected]

Definition at line 129 of file vtkTransformTextureCoords.h.

int vtkTransformTextureCoords::FlipR [protected]

Definition at line 130 of file vtkTransformTextureCoords.h.

int vtkTransformTextureCoords::FlipS [protected]

Definition at line 131 of file vtkTransformTextureCoords.h.

int vtkTransformTextureCoords::FlipT [protected]

Definition at line 132 of file vtkTransformTextureCoords.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTransformTextureCoords.h
Generated on Mon Mar 25 01:32:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransformToGrid Class Reference

create a grid for a vtkGridTransform. More...

#include <vtkTransformToGrid.h>

Inheritance diagram for vtkTransformToGrid:

[legend]
Collaboration diagram for vtkTransformToGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransformToGrid, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetInput (vtkAbstractTransform *)
virtual vtkAbstractTransform * | GetInput ()
virtual void | SetGridExtent (int, int, int, int, int, int)
virtual void | SetGridExtent (int[6])
virtual int * | GetGridExtent ()
virtual void | GetGridExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetGridExtent (int[6])
virtual void | SetGridOrigin (float, float, float)
virtual void | SetGridOrigin (float[3])
virtual float * | GetGridOrigin ()
virtual void | GetGridOrigin (float &, float &, float &)
virtual void | GetGridOrigin (float[3])
virtual void | SetGridSpacing (float, float, float)
virtual void | SetGridSpacing (float[3])
virtual float * | GetGridSpacing ()
virtual void | GetGridSpacing (float &, float &, float &)
virtual void | GetGridSpacing (float[3])
virtual void | SetGridScalarType (int)
virtual int | GetGridScalarType ()
void | SetGridScalarTypeToFloat ()
void | SetGridScalarTypeToShort ()
void | SetGridScalarTypeToUnsignedShort ()
void | SetGridScalarTypeToUnsignedChar ()
void | SetGridScalarTypeToChar ()
float | GetDisplacementScale ()
float | GetDisplacementShift ()

Static Public Methods

vtkTransformToGrid * | New ()

Protected Methods

vtkTransformToGrid ()
~vtkTransformToGrid ()
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *data)
void | UpdateShiftScale ()
unsigned long | GetMTime ()

Protected Attributes

vtkAbstractTransform * Input
int | GridScalarType
int | GridExtent [6]
float | GridOrigin [3]
float | GridSpacing [3]
float | DisplacementScale
float | DisplacementShift
vtkTimeStamp ShiftScaleTime

Detailed Description

create a grid for a vtkGridTransform.

Date:
2002/01/22 15:30:40
Revision:
1.9

vtkTransformToGrid takes any transform as input and produces a grid for use by a vtkGridTransform. This can be used, for example, to invert a grid transform, concatenate two grid transforms, or to convert a thin plate spline transform into a grid transform.

See also:
vtkGridTransform vtkThinPlateSplineTransform vtkAbstractTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (96%)
Tests:
vtkTransformToGrid (Tests)

Definition at line 45 of file vtkTransformToGrid.h.

Constructor & Destructor Documentation

vtkTransformToGrid::vtkTransformToGrid ( ) [protected]

vtkTransformToGrid::~vtkTransformToGrid ( ) [protected]

Member Function Documentation

vtkTransformToGrid* vtkTransformToGrid::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkTransformToGrid::vtkTypeRevisionMacro | ( | vtkTransformToGrid | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkTransformToGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkTransformToGrid::SetInput ( vtkAbstractTransform * ) [virtual]

Set/Get the transform which will be converted into a grid.

virtual vtkAbstractTransform* vtkTransformToGrid::GetInput ( ) [virtual]

Set/Get the transform which will be converted into a grid.

virtual void vtkTransformToGrid::SetGridExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Get/Set the extent of the grid.

virtual void vtkTransformToGrid::SetGridExtent ( int [6] ) [virtual]

Get/Set the extent of the grid.

virtual int* vtkTransformToGrid::GetGridExtent ( ) [virtual]

Get/Set the extent of the grid.

virtual void vtkTransformToGrid::GetGridExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get/Set the extent of the grid.

virtual void vtkTransformToGrid::GetGridExtent ( int [6] ) [virtual]

Get/Set the extent of the grid.

virtual void vtkTransformToGrid::SetGridOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Get/Set the origin of the grid.

virtual void vtkTransformToGrid::SetGridOrigin ( float [3] ) [virtual]

Get/Set the origin of the grid.

virtual float* vtkTransformToGrid::GetGridOrigin ( ) [virtual]

Get/Set the origin of the grid.

virtual void vtkTransformToGrid::GetGridOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Get/Set the origin of the grid.

virtual void vtkTransformToGrid::GetGridOrigin ( float [3] ) [virtual]

Get/Set the origin of the grid.

virtual void vtkTransformToGrid::SetGridSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Get/Set the spacing between samples in the grid.

virtual void vtkTransformToGrid::SetGridSpacing ( float [3] ) [virtual]

Get/Set the spacing between samples in the grid.

virtual float* vtkTransformToGrid::GetGridSpacing ( ) [virtual]

Get/Set the spacing between samples in the grid.

virtual void vtkTransformToGrid::GetGridSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Get/Set the spacing between samples in the grid.

virtual void vtkTransformToGrid::GetGridSpacing ( float [3] ) [virtual]

Get/Set the spacing between samples in the grid.

virtual void vtkTransformToGrid::SetGridScalarType ( int ) [virtual]

Get/Set the scalar type of the grid. The default is float.

virtual int vtkTransformToGrid::GetGridScalarType ( ) [virtual]

Get/Set the scalar type of the grid. The default is float.

void vtkTransformToGrid::SetGridScalarTypeToFloat ( ) [inline]

Get/Set the scalar type of the grid. The default is float.

Definition at line 80 of file vtkTransformToGrid.h.

void vtkTransformToGrid::SetGridScalarTypeToShort ( ) [inline]

Get/Set the scalar type of the grid. The default is float.

Definition at line 81 of file vtkTransformToGrid.h.

void vtkTransformToGrid::SetGridScalarTypeToUnsignedShort ( ) [inline]

Get/Set the scalar type of the grid. The default is float.

Definition at line 82 of file vtkTransformToGrid.h.

void vtkTransformToGrid::SetGridScalarTypeToUnsignedChar ( ) [inline]

Get/Set the scalar type of the grid. The default is float.

Definition at line 84 of file vtkTransformToGrid.h.

void vtkTransformToGrid::SetGridScalarTypeToChar ( ) [inline]

Get/Set the scalar type of the grid. The default is float.

Definition at line 86 of file vtkTransformToGrid.h.

float vtkTransformToGrid::GetDisplacementScale ( ) [inline]

Get the scale and shift to convert integer grid elements into real values: dx = scale*di + shift. If the grid is of float type, then scale = 1 and shift = 0.

Definition at line 94 of file vtkTransformToGrid.h.

float vtkTransformToGrid::GetDisplacementShift ( ) [inline]

Get the scale and shift to convert integer grid elements into real values: dx = scale*di + shift. If the grid is of float type, then scale = 1 and shift = 0.

Definition at line 96 of file vtkTransformToGrid.h.

void vtkTransformToGrid::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkTransformToGrid::ExecuteData ( vtkDataObject * data ) [protected]

void vtkTransformToGrid::UpdateShiftScale ( ) [protected]

Internal method to calculate the shift and scale values which will provide maximum grid precision for a particular integer type.

unsigned long vtkTransformToGrid::GetMTime ( ) [protected, virtual]

Return this object's modified time.

Reimplemented from vtkObject.

Member Data Documentation

vtkAbstractTransform* vtkTransformToGrid::Input [protected]

Definition at line 114 of file vtkTransformToGrid.h.

int vtkTransformToGrid::GridScalarType [protected]

Definition at line 116 of file vtkTransformToGrid.h.

int vtkTransformToGrid::GridExtent[6] [protected]

Definition at line 117 of file vtkTransformToGrid.h.

float vtkTransformToGrid::GridOrigin[3] [protected]

Definition at line 118 of file vtkTransformToGrid.h.

float vtkTransformToGrid::GridSpacing[3] [protected]

Definition at line 119 of file vtkTransformToGrid.h.

float vtkTransformToGrid::DisplacementScale [protected]

Definition at line 121 of file vtkTransformToGrid.h.

float vtkTransformToGrid::DisplacementShift [protected]

Definition at line 122 of file vtkTransformToGrid.h.

vtkTimeStamp vtkTransformToGrid::ShiftScaleTime [protected]

Definition at line 123 of file vtkTransformToGrid.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkTransformToGrid.h
Generated on Mon Mar 25 01:32:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransmitPolyDataPiece Class Reference

Return specified piece, including specified. More...

#include <vtkTransmitPolyDataPiece.h>

Inheritance diagram for vtkTransmitPolyDataPiece:

[legend]
Collaboration diagram for vtkTransmitPolyDataPiece:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransmitPolyDataPiece, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetController (vtkMultiProcessController *)
virtual vtkMultiProcessController * | GetController ()
virtual void | SetCreateGhostCells (int)
virtual int | GetCreateGhostCells ()
virtual void | CreateGhostCellsOn ()
virtual void | CreateGhostCellsOff ()

Static Public Methods

vtkTransmitPolyDataPiece * | New ()

Protected Methods

vtkTransmitPolyDataPiece ()
~vtkTransmitPolyDataPiece ()
vtkTransmitPolyDataPiece (const vtkTransmitPolyDataPiece &)
void | operator= (const vtkTransmitPolyDataPiece &)
void | Execute ()
void | RootExecute ()
void | SatelliteExecute (int procId)
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *out)

Protected Attributes

vtkPolyData * Buffer
int | BufferPiece
int | BufferNumberOfPieces
int | BufferGhostLevel
int | CreateGhostCells
vtkMultiProcessController * Controller

Detailed Description

Return specified piece, including specified.

Date:
2002/01/22 15:35:01
Revision:
1.4
number of ghost levels. .DESCRIPTION This filter updates the appropriate piece by requesting the piece from process 0. Process 0 always updates all of the data. It is important that Execute get called on all processes, otherwise the filter will deadlock.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Hoffman, Bill (98%)

Definition at line 41 of file vtkTransmitPolyDataPiece.h.

Constructor & Destructor Documentation

vtkTransmitPolyDataPiece::vtkTransmitPolyDataPiece ( ) [protected]

vtkTransmitPolyDataPiece::~vtkTransmitPolyDataPiece ( ) [protected]

vtkTransmitPolyDataPiece::vtkTransmitPolyDataPiece ( const vtkTransmitPolyDataPiece & ) [protected]

Member Function Documentation

vtkTransmitPolyDataPiece* vtkTransmitPolyDataPiece::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkTransmitPolyDataPiece::vtkTypeRevisionMacro | ( | vtkTransmitPolyDataPiece | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkTransmitPolyDataPiece::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkTransmitPolyDataPiece::SetController ( vtkMultiProcessController * ) [virtual]

By defualt this filter uses the global controller, but this method can be used to set another instead.

virtual vtkMultiProcessController* vtkTransmitPolyDataPiece::GetController ( ) [virtual]

By defualt this filter uses the global controller, but this method can be used to set another instead.

virtual void vtkTransmitPolyDataPiece::SetCreateGhostCells ( int ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual int vtkTransmitPolyDataPiece::GetCreateGhostCells ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkTransmitPolyDataPiece::CreateGhostCellsOn ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkTransmitPolyDataPiece::CreateGhostCellsOff ( ) [virtual]

Turn on/off creating ghost cells (on by default).

void vtkTransmitPolyDataPiece::operator= ( const vtkTransmitPolyDataPiece & ) [protected]

void vtkTransmitPolyDataPiece::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkTransmitPolyDataPiece::RootExecute ( ) [protected]

void vtkTransmitPolyDataPiece::SatelliteExecute ( int procId ) [protected]

void vtkTransmitPolyDataPiece::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkTransmitPolyDataPiece::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkPolyDataSource.

Member Data Documentation

vtkPolyData* vtkTransmitPolyDataPiece::Buffer [protected]

Definition at line 75 of file vtkTransmitPolyDataPiece.h.

int vtkTransmitPolyDataPiece::BufferPiece [protected]

Definition at line 76 of file vtkTransmitPolyDataPiece.h.

int vtkTransmitPolyDataPiece::BufferNumberOfPieces [protected]

Definition at line 77 of file vtkTransmitPolyDataPiece.h.

int vtkTransmitPolyDataPiece::BufferGhostLevel [protected]

Definition at line 78 of file vtkTransmitPolyDataPiece.h.

int vtkTransmitPolyDataPiece::CreateGhostCells [protected]

Definition at line 80 of file vtkTransmitPolyDataPiece.h.

vtkMultiProcessController* vtkTransmitPolyDataPiece::Controller [protected]

Definition at line 81 of file vtkTransmitPolyDataPiece.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkTransmitPolyDataPiece.h
Generated on Mon Mar 25 01:32:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTransmitUnstructuredGridPiece Class Reference

Return specified piece, including specified. More...

#include <vtkTransmitUnstructuredGridPiece.h>

Inheritance diagram for vtkTransmitUnstructuredGridPiece:

[legend]
Collaboration diagram for vtkTransmitUnstructuredGridPiece:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTransmitUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetController (vtkMultiProcessController *)
virtual vtkMultiProcessController * | GetController ()
virtual void | SetCreateGhostCells (int)
virtual int | GetCreateGhostCells ()
virtual void | CreateGhostCellsOn ()
virtual void | CreateGhostCellsOff ()

Static Public Methods

vtkTransmitUnstructuredGridPiece * | New ()

Protected Methods

vtkTransmitUnstructuredGridPiece ()
~vtkTransmitUnstructuredGridPiece ()
vtkTransmitUnstructuredGridPiece (const vtkTransmitUnstructuredGridPiece &)
void | operator= (const vtkTransmitUnstructuredGridPiece &)
void | Execute ()
void | RootExecute ()
void | SatelliteExecute (int procId)
void | ExecuteInformation ()
void | ComputeInputUpdateExtents (vtkDataObject *out)

Protected Attributes

int | CreateGhostCells
vtkMultiProcessController * Controller

Detailed Description

Return specified piece, including specified.

Date:
2002/02/22 19:18:29
Revision:
1.5
number of ghost levels. .DESCRIPTION This filter updates the appropriate piece by requesting the piece from process 0. Process 0 always updates all of the data. It is important that Execute get called on all processes, otherwise the filter will deadlock.
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Hoffman, Bill (94%)
  • Law, Charles (5%)

Definition at line 42 of file vtkTransmitUnstructuredGridPiece.h.

Constructor & Destructor Documentation

vtkTransmitUnstructuredGridPiece::vtkTransmitUnstructuredGridPiece ( ) [protected]

vtkTransmitUnstructuredGridPiece::~vtkTransmitUnstructuredGridPiece ( ) [protected]

vtkTransmitUnstructuredGridPiece::vtkTransmitUnstructuredGridPiece ( const vtkTransmitUnstructuredGridPiece & ) [protected]

Member Function Documentation

vtkTransmitUnstructuredGridPiece* vtkTransmitUnstructuredGridPiece::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkUnstructuredGridSource.

vtkTransmitUnstructuredGridPiece::vtkTypeRevisionMacro | ( | vtkTransmitUnstructuredGridPiece | ,
 |  | vtkUnstructuredGridToUnstructuredGridFilter |
 | ) |

Reimplemented from vtkUnstructuredGridToUnstructuredGridFilter.

void vtkTransmitUnstructuredGridPiece::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkTransmitUnstructuredGridPiece::SetController ( vtkMultiProcessController * ) [virtual]

By defualt this filter uses the global controller, but this method can be used to set another instead.

virtual vtkMultiProcessController* vtkTransmitUnstructuredGridPiece::GetController ( ) [virtual]

By defualt this filter uses the global controller, but this method can be used to set another instead.

virtual void vtkTransmitUnstructuredGridPiece::SetCreateGhostCells ( int ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual int vtkTransmitUnstructuredGridPiece::GetCreateGhostCells ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkTransmitUnstructuredGridPiece::CreateGhostCellsOn ( ) [virtual]

Turn on/off creating ghost cells (on by default).

virtual void vtkTransmitUnstructuredGridPiece::CreateGhostCellsOff ( ) [virtual]

Turn on/off creating ghost cells (on by default).

void vtkTransmitUnstructuredGridPiece::operator= ( const vtkTransmitUnstructuredGridPiece & ) [protected]

void vtkTransmitUnstructuredGridPiece::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkTransmitUnstructuredGridPiece::RootExecute ( ) [protected]

void vtkTransmitUnstructuredGridPiece::SatelliteExecute ( int procId ) [protected]

void vtkTransmitUnstructuredGridPiece::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkTransmitUnstructuredGridPiece::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkUnstructuredGridSource.

Member Data Documentation

int vtkTransmitUnstructuredGridPiece::CreateGhostCells [protected]

Definition at line 76 of file vtkTransmitUnstructuredGridPiece.h.

vtkMultiProcessController* vtkTransmitUnstructuredGridPiece::Controller [protected]

Definition at line 77 of file vtkTransmitUnstructuredGridPiece.h.

The documentation for this class was generated from the following file:
  • Parallel/vtkTransmitUnstructuredGridPiece.h
Generated on Mon Mar 25 01:32:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTreeComposite Class Reference

Implements tree based compositing. More...

#include <vtkTreeComposite.h>

Inheritance diagram for vtkTreeComposite:

[legend]
Collaboration diagram for vtkTreeComposite:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTreeComposite, vtkCompositeManager)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkTreeComposite * | New ()

Protected Methods

vtkTreeComposite ()
~vtkTreeComposite ()
vtkTreeComposite (const vtkTreeComposite &)
void | operator= (const vtkTreeComposite &)
virtual void | CompositeBuffer (int width, int height, int useCharFlag, void *pBuf, float *zBuf, void *pTmp, float *zTmp)

Detailed Description

Implements tree based compositing.

Date:
2002/01/22 15:35:03
Revision:
1.18

vtkTreeComposite operates in multiple processes. Each compositer has a render window. They use vtkMultiProcessControllers to comunicate the color and depth buffer to process 0's render window. It will not handle transparency well. vtkCompositeManager.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (38%)
  • Law, Charles (26%)
  • Hoffman, Bill (21%)
  • Henderson, Amy (9%)
Examples:
vtkTreeComposite (Examples)
Tests:
vtkTreeComposite (Tests)

Definition at line 78 of file vtkTreeComposite.h.

Constructor & Destructor Documentation

vtkTreeComposite::vtkTreeComposite ( ) [protected]

vtkTreeComposite::~vtkTreeComposite ( ) [protected]

vtkTreeComposite::vtkTreeComposite ( const vtkTreeComposite & ) [protected]

Member Function Documentation

vtkTreeComposite* vtkTreeComposite::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTreeComposite::vtkTypeRevisionMacro | ( | vtkTreeComposite | ,
 |  | vtkCompositeManager |
 | ) |

Reimplemented from vtkCompositeManager.

void vtkTreeComposite::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkCompositeManager.

void vtkTreeComposite::operator= ( const vtkTreeComposite & ) [protected]

virtual void vtkTreeComposite::CompositeBuffer | ( | int | width,
 |  | int | height,
 |  | int | useCharFlag,
 |  | void * | pBuf,
 |  | float * | zBuf,
 |  | void * | pTmp,
 |  | float * | zTmp
 | ) | [protected, virtual]

Reimplemented from vtkCompositeManager.

The documentation for this class was generated from the following file:
  • Parallel/vtkTreeComposite.h
Generated on Mon Mar 25 01:32:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangle Class Reference

a cell that represents a triangle. More...

#include <vtkTriangle.h>

Inheritance diagram for vtkTriangle:

[legend]
Collaboration diagram for vtkTriangle:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTriangle, vtkCell)
vtkCell * MakeObject ()
vtkCell * | GetEdge (int edgeId)
int | GetParametricCenter (float pcoords[3])
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetFace (int)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)

Static Public Methods

vtkTriangle * | New ()
float | TriangleArea (float p1[3], float p2[3], float p3[3])
void | ComputeNormal (float v1[3], float v2[3], float v3[3], float n[3])
void | TriangleCenter (float p1[3], float p2[3], float p3[3], float center[3])
double | Circumcircle (double p1[2], double p2[2], double p3[2], double center[2])
int | BarycentricCoords (double x[2], double x1[2], double x2[2], double x3[2], double bcoords[3])
int | ProjectTo2D (double x1[3], double x2[3], double x3[3], double v1[2], double v2[2], double v3[2])
void | ComputeNormal (vtkPoints *p, int numPts, vtkIdType *pts, float n[3])
void | ComputeNormalDirection (float v1[3], float v2[3], float v3[3], float n[3])
void | ComputeNormal (double v1[3], double v2[3], double v3[3], double n[3])
void | ComputeNormalDirection (double v1[3], double v2[3], double v3[3], double n[3])
int | PointInTriangle (float x[3], float x1[3], float x2[3], float x3[3], float tol2)
void | ComputeQuadric (float x1[3], float x2[3], float x3[3], float quadric[4][4])
void | ComputeQuadric (float x1[3], float x2[3], float x3[3], vtkQuadric *quadric)

Protected Methods

vtkTriangle ()
~vtkTriangle ()

Protected Attributes

vtkLine * Line

Detailed Description

a cell that represents a triangle.

Date:
2002/01/22 15:26:31
Revision:
1.76

vtkTriangle is a concrete implementation of vtkCell to represent a triangle located in 3-space.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Lorensen, Bill (11%)
  • Miller, Jim (10%)
  • Geveci, Berk (7%)
  • Martin, Ken (7%)
Examples:
vtkTriangle (Examples)
Tests:
vtkTriangle (Tests)

Definition at line 50 of file vtkTriangle.h.

Constructor & Destructor Documentation

vtkTriangle::vtkTriangle ( ) [protected]

vtkTriangle::~vtkTriangle ( ) [protected]

Member Function Documentation

vtkTriangle* vtkTriangle::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTriangle::vtkTypeRevisionMacro | ( | vtkTriangle | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkTriangle::MakeObject ( ) [virtual]

Create a new cell and copy this triangle's information into the cell. Returns a pointer to the new cell created.

Reimplemented from vtkCell.

vtkCell* vtkTriangle::GetEdge ( int edgeId ) [virtual]

Get the edge specified by edgeId (range 0 to 2) and return that edge's coordinates.

Reimplemented from vtkCell.

int vtkTriangle::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 66 of file vtkTriangle.h.

int vtkTriangle::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 67 of file vtkTriangle.h.

int vtkTriangle::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 68 of file vtkTriangle.h.

int vtkTriangle::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 69 of file vtkTriangle.h.

vtkCell* vtkTriangle::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 70 of file vtkTriangle.h.

int vtkTriangle::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangle::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTriangle::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangle::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTriangle::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangle::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangle::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

Clip this triangle using scalar value provided. Like contouring, except that it cuts the triangle to produce other triangles.

Reimplemented from vtkCell.

int vtkTriangle::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Plane intersection plus in/out test on triangle. The in/out test is performed using tol as the tolerance.

Reimplemented from vtkCell.

int vtkTriangle::GetParametricCenter ( float pcoords[3] ) [inline, virtual]

Return the center of the triangle in parametric coordinates.

Reimplemented from vtkCell.

Definition at line 213 of file vtkTriangle.h.

void vtkTriangle::TriangleCenter | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | p3[3],
 |  | float | center[3]
 | ) | [inline, static]

Compute the center of the triangle.

Definition at line 277 of file vtkTriangle.h.

float vtkTriangle::TriangleArea | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | p3[3]
 | ) | [inline, static]

Compute the area of a triangle in 3D.

Definition at line 285 of file vtkTriangle.h.

double vtkTriangle::Circumcircle | ( | double | p1[2],
 |  | double | p2[2],
 |  | double | p3[2],
 |  | double | center[2]
 | ) | [static]

Compute the circumcenter (center[3]) and radius (method return value) of a triangle defined by the three points x1, x2, and x3. (Note that the coordinates are 2D. 3D points can be used but the z-component will be ignored.)

int vtkTriangle::BarycentricCoords | ( | double | x[2],
 |  | double | x1[2],
 |  | double | x2[2],
 |  | double | x3[2],
 |  | double | bcoords[3]
 | ) | [static]

Given a 2D point x[2], determine the barycentric coordinates of the point. Barycentric coordinates are a natural coordinate system for simplices that express a position as a linear combination of the vertices. For a triangle, there are three barycentric coordinates (because there are three vertices), and the sum of the coordinates must equal 1. If a point x is inside a simplex, then all three coordinates will be strictly positive. If two coordinates are zero (so the third =1), then the point x is on a vertex. If one coordinates are zero, the point x is on an edge. In this method, you must specify the vertex coordinates x1->x3. Returns 0 if triangle is degenerate.

int vtkTriangle::ProjectTo2D | ( | double | x1[3],
 |  | double | x2[3],
 |  | double | x3[3],
 |  | double | v1[2],
 |  | double | v2[2],
 |  | double | v3[2]
 | ) | [static]

Project triangle defined in 3D to 2D coordinates. Returns 0 if degenerate triangle; non-zero value otherwise. Input points are x1->x3; output 2D points are v1->v3.

void vtkTriangle::ComputeNormal | ( | vtkPoints * | p,
 |  | int | numPts,
 |  | vtkIdType * | pts,
 |  | float | n[3]
 | ) | [static]

Compute the triangle normal from a points list, and a list of point ids that index into the points list.

void vtkTriangle::ComputeNormal | ( | float | v1[3],
 |  | float | v2[3],
 |  | float | v3[3],
 |  | float | n[3]
 | ) | [inline, static]

Compute the triangle normal from three points.

Definition at line 233 of file vtkTriangle.h.

void vtkTriangle::ComputeNormalDirection | ( | float | v1[3],
 |  | float | v2[3],
 |  | float | v3[3],
 |  | float | n[3]
 | ) | [inline, static]

Compute the (unnormalized) triangle normal direction from three points.

Definition at line 219 of file vtkTriangle.h.

Referenced by ComputeNormal().

void vtkTriangle::ComputeNormal | ( | double | v1[3],
 |  | double | v2[3],
 |  | double | v3[3],
 |  | double | n[3]
 | ) | [inline, static]

Compute the triangle normal from three points (double-precision version).

Definition at line 262 of file vtkTriangle.h.

void vtkTriangle::ComputeNormalDirection | ( | double | v1[3],
 |  | double | v2[3],
 |  | double | v3[3],
 |  | double | n[3]
 | ) | [inline, static]

Compute the (unnormalized) triangle normal direction from three points (double precision version).

Definition at line 248 of file vtkTriangle.h.

int vtkTriangle::PointInTriangle | ( | float | x[3],
 |  | float | x1[3],
 |  | float | x2[3],
 |  | float | x3[3],
 |  | float | tol2
 | ) | [static]

Given a point x, determine whether it is inside (within the tolerance squared, tol2) the triangle defined by the three coordinate values p1, p2, p3. Method is via comparing dot products. (Note: in current implementation the tolerance only works in the neighborhood of the three vertices of the triangle.

void vtkTriangle::ComputeQuadric | ( | float | x1[3],
 |  | float | x2[3],
 |  | float | x3[3],
 |  | float | quadric[4][4]
 | ) | [static]

Calculate the error quadric for this triangle. Return the quadric as a 4x4 matrix or a vtkQuadric. (from Peter Lindstrom's Siggraph 2000 paper, "Out-of-Core Simplification of Large Polygonal Models")

void vtkTriangle::ComputeQuadric | ( | float | x1[3],
 |  | float | x2[3],
 |  | float | x3[3],
 |  | vtkQuadric * | quadric
 | ) | [static]

Calculate the error quadric for this triangle. Return the quadric as a 4x4 matrix or a vtkQuadric. (from Peter Lindstrom's Siggraph 2000 paper, "Out-of-Core Simplification of Large Polygonal Models")

Member Data Documentation

vtkLine* vtkTriangle::Line [protected]

Definition at line 206 of file vtkTriangle.h.

The documentation for this class was generated from the following file:
  • Common/vtkTriangle.h
Generated on Mon Mar 25 01:32:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangleFilter Class Reference

create triangle polygons from input polygons and triangle strips. More...

#include <vtkTriangleFilter.h>

Inheritance diagram for vtkTriangleFilter:

[legend]
Collaboration diagram for vtkTriangleFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTriangleFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | PassVertsOn ()
virtual void | PassVertsOff ()
virtual void | SetPassVerts (int)
virtual int | GetPassVerts ()
virtual void | PassLinesOn ()
virtual void | PassLinesOff ()
virtual void | SetPassLines (int)
virtual int | GetPassLines ()

Static Public Methods

vtkTriangleFilter * | New ()

Protected Methods

vtkTriangleFilter ()
~vtkTriangleFilter ()
void | Execute ()

Protected Attributes

int | PassVerts
int | PassLines

Detailed Description

create triangle polygons from input polygons and triangle strips.

Date:
2002/01/22 15:29:54
Revision:
1.34

vtkTriangleFilter generates triangles from input polygons and triangle strips. The filter also will pass through vertices and lines, if requested.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (87%)
Examples:
vtkTriangleFilter (Examples)
Tests:
vtkTriangleFilter (Tests)

Definition at line 44 of file vtkTriangleFilter.h.

Constructor & Destructor Documentation

vtkTriangleFilter::vtkTriangleFilter ( ) [inline, protected]

Definition at line 66 of file vtkTriangleFilter.h.

vtkTriangleFilter::~vtkTriangleFilter ( ) [inline, protected]

Definition at line 67 of file vtkTriangleFilter.h.

Member Function Documentation

vtkTriangleFilter* vtkTriangleFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkTriangleFilter::vtkTypeRevisionMacro | ( | vtkTriangleFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkTriangleFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkTriangleFilter::PassVertsOn ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkTriangleFilter::PassVertsOff ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkTriangleFilter::SetPassVerts ( int ) [virtual]

Turn on/off passing vertices through filter.

virtual int vtkTriangleFilter::GetPassVerts ( ) [virtual]

Turn on/off passing vertices through filter.

virtual void vtkTriangleFilter::PassLinesOn ( ) [virtual]

Turn on/off passing lines through filter.

virtual void vtkTriangleFilter::PassLinesOff ( ) [virtual]

Turn on/off passing lines through filter.

virtual void vtkTriangleFilter::SetPassLines ( int ) [virtual]

Turn on/off passing lines through filter.

virtual int vtkTriangleFilter::GetPassLines ( ) [virtual]

Turn on/off passing lines through filter.

void vtkTriangleFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkTriangleFilter::PassVerts [protected]

Definition at line 72 of file vtkTriangleFilter.h.

int vtkTriangleFilter::PassLines [protected]

Definition at line 73 of file vtkTriangleFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTriangleFilter.h
Generated on Mon Mar 25 01:32:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangleStrip Class Reference

a cell that represents a triangle strip. More...

#include <vtkTriangleStrip.h>

Inheritance diagram for vtkTriangleStrip:

[legend]
Collaboration diagram for vtkTriangleStrip:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTriangleStrip, vtkCell)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)
int | GetParametricCenter (float pcoords[3])
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int vtkNotUsed(faceId))
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)

Static Public Methods

vtkTriangleStrip * | New ()
void | DecomposeStrip (int npts, vtkIdType *pts, vtkCellArray *tris)

Protected Methods

vtkTriangleStrip ()
~vtkTriangleStrip ()

Protected Attributes

vtkLine * Line
vtkTriangle * Triangle

Detailed Description

a cell that represents a triangle strip.

Date:
2002/01/22 15:26:32
Revision:
1.61

vtkTriangleStrip is a concrete implementation of vtkCell to represent a 2D triangle strip. A triangle strip is a compact representation of triangles connected edge to edge in strip fashion. The connectivity of a triangle strip is three points defining an initial triangle, then for each additional triangle, a single point that, combined with the previous two points, defines the next triangle.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (68%)
  • Lorensen, Bill (10%)
  • Geveci, Berk (8%)
Examples:
vtkTriangleStrip (Examples)
Tests:
vtkTriangleStrip (Tests)

Definition at line 51 of file vtkTriangleStrip.h.

Constructor & Destructor Documentation

vtkTriangleStrip::vtkTriangleStrip ( ) [protected]

vtkTriangleStrip::~vtkTriangleStrip ( ) [protected]

Member Function Documentation

vtkTriangleStrip* vtkTriangleStrip::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkTriangleStrip::vtkTypeRevisionMacro | ( | vtkTriangleStrip | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkTriangleStrip::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTriangleStrip::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 60 of file vtkTriangleStrip.h.

int vtkTriangleStrip::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 61 of file vtkTriangleStrip.h.

int vtkTriangleStrip::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 62 of file vtkTriangleStrip.h.

int vtkTriangleStrip::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 63 of file vtkTriangleStrip.h.

vtkCell* vtkTriangleStrip::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkTriangleStrip::GetFace ( int vtkNotUsed(faceId) ) [inline]

See the vtkCell API for descriptions of these methods.

Definition at line 65 of file vtkTriangleStrip.h.

int vtkTriangleStrip::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangleStrip::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkTriangleStrip::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkTriangleStrip::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

Given a point x[3] return inside(=1) or outside(=0) cell; evaluate parametric coordinates, sub-cell id (!=0 only if cell is composite), distance squared of point x[3] to cell (in particular, the sub-cell indicated), closest point on cell to x[3] (unless closestPoint is null, in which case, the closest point and dist2 are not found), and interpolation weights in cell. (The number of weights is equal to the number of points defining the cell). Note: on rare occasions a -1 is returned from the method. This means that numerical error has occurred and all data returned from this method should be ignored. Also, inside/outside is determine parametrically. That is, a point is inside if it satisfies parametric limits. This can cause problems for cells of topological dimension 2 or less, since a point in 3D can project onto the cell within parametric limits but be "far" from the cell. Thus the value dist2 may be checked to determine true in/out.

Reimplemented from vtkCell.

void vtkTriangleStrip::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

Determine global coordinate (x[3]) from subId and parametric coordinates. Also returns interpolation weights. (The number of weights is equal to the number of points in the cell.)

Reimplemented from vtkCell.

int vtkTriangleStrip::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Intersect with a ray. Return parametric coordinates (both line and cell) and global intersection coordinates, given ray definition and tolerance. The method returns non-zero value if intersection occurs.

Reimplemented from vtkCell.

int vtkTriangleStrip::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

Generate simplices of proper dimension. If cell is 3D, tetrahedron are generated; if 2D triangles; if 1D lines; if 0D points. The form of the output is a sequence of points, each n+1 points (where n is topological cell dimension) defining a simplex. The index is a parameter that controls which triangulation to use (if more than one is possible). If numerical degeneracy encountered, 0 is returned, otherwise 1 is returned.

Reimplemented from vtkCell.

void vtkTriangleStrip::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

Compute derivatives given cell subId and parametric coordinates. The values array is a series of data value(s) at the cell points. There is a one-to-one correspondence between cell point and data value(s). Dim is the number of data values per cell point. Derivs are derivatives in the x-y-z coordinate directions for each data value. Thus, if computing derivatives for a scalar function in a hexahedron, dim=1, 8 values are supplied, and 3 deriv values are returned (i.e., derivatives in x-y-z directions). On the other hand, if computing derivatives of velocity (vx,vy,vz) dim=3, 24 values are supplied ((vx,vy,vz)1, (vx,vy,vz)2, ....()8), and 9 deriv values are returned ((d(vx)/dx),(d(vx)/dy),(d(vx)/dz), (d(vy)/dx),(d(vy)/dy), (d(vy)/dz), (d(vz)/dx),(d(vz)/dy),(d(vz)/dz)).

Reimplemented from vtkCell.

int vtkTriangleStrip::GetParametricCenter ( float pcoords[3] ) [virtual]

Return the center of the point cloud in parametric coordinates.

Reimplemented from vtkCell.

void vtkTriangleStrip::DecomposeStrip | ( | int | npts,
 |  | vtkIdType * | pts,
 |  | vtkCellArray * | tris
 | ) | [static]

Given a triangle strip, decompose it into a list of (triangle) polygons. The polygons are appended to the end of the list of triangles.

Member Data Documentation

vtkLine* vtkTriangleStrip::Line [protected]

Definition at line 103 of file vtkTriangleStrip.h.

vtkTriangle* vtkTriangleStrip::Triangle [protected]

Definition at line 104 of file vtkTriangleStrip.h.

The documentation for this class was generated from the following file:
  • Common/vtkTriangleStrip.h
Generated on Mon Mar 25 01:32:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangularTCoords Class Reference

2D texture coordinates based for triangles. More...

#include <vtkTriangularTCoords.h>

Inheritance diagram for vtkTriangularTCoords:

[legend]
Collaboration diagram for vtkTriangularTCoords:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTriangularTCoords, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)

Static Public Methods

vtkTriangularTCoords * | New ()

Protected Methods

vtkTriangularTCoords ()
~vtkTriangularTCoords ()
void | Execute ()

Detailed Description

2D texture coordinates based for triangles.

Date:
2002/01/22 15:29:54
Revision:
1.22

vtkTriangularTCoords is a filter that generates texture coordinates for triangles. Texture coordinates for each triangle are: (0,0), (1,0) and (.5,sqrt(3)/2). This filter assumes that the triangle texture map is symmetric about the center of the triangle. Thus the order Of the texture coordinates is not important. The procedural texture in vtkTriangularTexture is designed with this symmetry. For more information see the paper "Opacity-modulating Triangular Textures for Irregular Surfaces," by Penny Rheingans, IEEE Visualization '96, pp. 219-225.

See also:
vtkTriangularTexture vtkThresholdPoints vtkTextureMapToPlane vtkTextureMapToSphere vtkTextureMapToCylinder vtkTextureMapToBox
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (62%)
  • Schroeder, Will (25%)
Tests:
vtkTriangularTCoords (Tests)

Definition at line 50 of file vtkTriangularTCoords.h.

Constructor & Destructor Documentation

vtkTriangularTCoords::vtkTriangularTCoords ( ) [inline, protected]

Definition at line 58 of file vtkTriangularTCoords.h.

vtkTriangularTCoords::~vtkTriangularTCoords ( ) [inline, protected]

Definition at line 59 of file vtkTriangularTCoords.h.

Member Function Documentation

vtkTriangularTCoords* vtkTriangularTCoords::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkTriangularTCoords::vtkTypeRevisionMacro | ( | vtkTriangularTCoords | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkTriangularTCoords::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkTriangularTCoords::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • Graphics/vtkTriangularTCoords.h
Generated on Mon Mar 25 01:32:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriangularTexture Class Reference

generate 2D triangular texture map. More...

#include <vtkTriangularTexture.h>

Inheritance diagram for vtkTriangularTexture:

[legend]
Collaboration diagram for vtkTriangularTexture:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTriangularTexture, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetXSize (int)
virtual int | GetXSize ()
virtual void | SetYSize (int)
virtual int | GetYSize ()
virtual void | SetTexturePattern (int)
virtual int | GetTexturePattern ()

Static Public Methods

vtkTriangularTexture * | New ()

Protected Methods

vtkTriangularTexture ()
~vtkTriangularTexture ()
void | Execute ()

Protected Attributes

int | XSize
int | YSize
float | ScaleFactor
int | TexturePattern

Detailed Description

generate 2D triangular texture map.

Date:
2002/01/22 15:33:49
Revision:
1.23

vtkTriangularTexture is a filter that generates a 2D texture map based on the paper "Opacity-modulating Triangular Textures for Irregular Surfaces," by Penny Rheingans, IEEE Visualization '96, pp. 219-225. The textures assume texture coordinates of (0,0), (1.0) and (.5, sqrt(3)/2). The sequence of texture values is the same along each edge of the triangular texture map. So, the assignment order of texture coordinates is arbitrary.

See also:
vtkTriangularTCoords
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (66%)
  • Schroeder, Will (24%)
Tests:
vtkTriangularTexture (Tests)

Definition at line 49 of file vtkTriangularTexture.h.

Constructor & Destructor Documentation

vtkTriangularTexture::vtkTriangularTexture ( ) [protected]

vtkTriangularTexture::~vtkTriangularTexture ( ) [inline, protected]

Definition at line 86 of file vtkTriangularTexture.h.

Member Function Documentation

vtkTriangularTexture::vtkTypeRevisionMacro | ( | vtkTriangularTexture | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

void vtkTriangularTexture::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTriangularTexture* vtkTriangularTexture::New ( ) [static]

Instantiate object with XSize and YSize = 64; the texture pattern =1 (opaque at centroid); and the scale factor set to 1.0.

Reimplemented from vtkStructuredPointsSource.

virtual void vtkTriangularTexture::SetScaleFactor ( float ) [virtual]

Set a Scale Factor.

virtual float vtkTriangularTexture::GetScaleFactor ( ) [virtual]

Set a Scale Factor.

virtual void vtkTriangularTexture::SetXSize ( int ) [virtual]

Set the X texture map dimension. Default is 64.

virtual int vtkTriangularTexture::GetXSize ( ) [virtual]

Set the X texture map dimension. Default is 64.

virtual void vtkTriangularTexture::SetYSize ( int ) [virtual]

Set the Y texture map dimension. Default is 64.

virtual int vtkTriangularTexture::GetYSize ( ) [virtual]

Set the Y texture map dimension. Default is 64.

virtual void vtkTriangularTexture::SetTexturePattern ( int ) [virtual]

Set the texture pattern. 1 = opaque at centroid (default) 2 = opaque at vertices 3 = opaque in rings around vertices

virtual int vtkTriangularTexture::GetTexturePattern ( ) [virtual]

Set the texture pattern. 1 = opaque at centroid (default) 2 = opaque at vertices 3 = opaque in rings around vertices

void vtkTriangularTexture::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkTriangularTexture::XSize [protected]

Definition at line 90 of file vtkTriangularTexture.h.

int vtkTriangularTexture::YSize [protected]

Definition at line 91 of file vtkTriangularTexture.h.

float vtkTriangularTexture::ScaleFactor [protected]

Definition at line 92 of file vtkTriangularTexture.h.

int vtkTriangularTexture::TexturePattern [protected]

Definition at line 94 of file vtkTriangularTexture.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkTriangularTexture.h
Generated on Mon Mar 25 01:33:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTriArray Class Reference

#include <vtkDecimate.h>

Collaboration diagram for vtkTriArray:

[legend]
List of all members.

Public Methods

vtkTriArray (const vtkIdType sz)
~vtkTriArray ()
vtkIdType GetNumberOfTriangles ()
void | InsertNextTriangle (vtkLocalTri &t)
vtkLocalTri & | GetTriangle (vtkIdType i)
void | Reset ()

Public Attributes

vtkLocalTri * Array
vtkIdType MaxId

Constructor & Destructor Documentation

vtkTriArray::vtkTriArray ( const vtkIdType sz ) [inline]

Definition at line 165 of file vtkDecimate.h.

vtkTriArray::~vtkTriArray ( ) [inline]

Definition at line 167 of file vtkDecimate.h.

Member Function Documentation

vtkIdType vtkTriArray::GetNumberOfTriangles ( ) [inline]

Definition at line 168 of file vtkDecimate.h.

void vtkTriArray::InsertNextTriangle ( vtkLocalTri & t ) [inline]

Definition at line 169 of file vtkDecimate.h.

vtkLocalTri& vtkTriArray::GetTriangle ( vtkIdType i ) [inline]

Definition at line 171 of file vtkDecimate.h.

void vtkTriArray::Reset ( ) [inline]

Definition at line 172 of file vtkDecimate.h.

Member Data Documentation

vtkLocalTri* vtkTriArray::Array

Definition at line 174 of file vtkDecimate.h.

vtkIdType vtkTriArray::MaxId

Definition at line 175 of file vtkDecimate.h.

The documentation for this class was generated from the following file:
  • Patented/vtkDecimate.h
Generated on Mon Mar 25 01:33:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkTubeFilter Class Reference

filter that generates tubes around lines. More...

#include <vtkTubeFilter.h>

Inheritance diagram for vtkTubeFilter:

[legend]
Collaboration diagram for vtkTubeFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkTubeFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetRadius (float)
virtual float | GetRadius ()
virtual void | SetVaryRadius (int)
virtual int | GetVaryRadius ()
void | SetVaryRadiusToVaryRadiusOff ()
void | SetVaryRadiusToVaryRadiusByScalar ()
void | SetVaryRadiusToVaryRadiusByVector ()
const char * | GetVaryRadiusAsString ()
virtual void | SetNumberOfSides (int)
virtual int | GetNumberOfSides ()
virtual void | SetRadiusFactor (float)
virtual float | GetRadiusFactor ()
virtual void | SetDefaultNormal (float, float, float)
virtual void | SetDefaultNormal (float[3])
virtual float * | GetDefaultNormal ()
virtual void | GetDefaultNormal (float data[3])
virtual void | SetUseDefaultNormal (int)
virtual int | GetUseDefaultNormal ()
virtual void | UseDefaultNormalOn ()
virtual void | UseDefaultNormalOff ()
virtual void | SetSidesShareVertices (int)
virtual int | GetSidesShareVertices ()
virtual void | SidesShareVerticesOn ()
virtual void | SidesShareVerticesOff ()
virtual void | SetCapping (int)
virtual int | GetCapping ()
virtual void | CappingOn ()
virtual void | CappingOff ()
virtual void | SetOnRatio (int)
virtual int | GetOnRatio ()
virtual void | SetOffset (int)
virtual int | GetOffset ()

Static Public Methods

vtkTubeFilter * | New ()

Protected Methods

vtkTubeFilter ()
~vtkTubeFilter ()
void | Execute ()

Protected Attributes

float | Radius
int | VaryRadius
int | NumberOfSides
float | RadiusFactor
float | DefaultNormal [3]
int | UseDefaultNormal
int | SidesShareVertices
int | Capping
int | OnRatio
int | Offset

Detailed Description

filter that generates tubes around lines.

Date:
2002/02/05 21:48:46
Revision:
1.46

vtkTubeFilter is a filter that generates a tube around each input line. The tubes are made up of triangle strips and rotate around the tube with the rotation of the line normals. (If no normals are present, they are computed automatically.) The radius of the tube can be set to vary with scalar or vector value. If the radius varies with scalar value the radius is linearly adjusted. If the radius varies with vector value, a mass flux preserving variation is used. The number of sides for the tube also can be specified. You can also specify which of the sides are visible. This is useful for generating interesting striping effects.

This filter is typically used to create thick or dramatic lines. Another common use is to combine this filter with vtkStreamLine to generate streamtubes.

Warning:
The number of tube sides must be greater than 3. If you wish to use fewer sides (i.e., a ribbon), use vtkRibbonFilter.
Warning:
The input line must not have duplicate points, or normals at points that are parallel to the incoming/outgoing line segments. (Duplicate points can be removed with vtkCleanPolyData.)
See also:
vtkRibbonFilter vtkStreamLine
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (47%)
  • Law, Charles (18%)
  • Volpe, Christopher (8%)
  • Martin, Ken (7%)
  • Lorensen, Bill (6%)
  • Geveci, Berk (5%)
Examples:
vtkTubeFilter (Examples)
Tests:
vtkTubeFilter (Tests)

Definition at line 75 of file vtkTubeFilter.h.

Constructor & Destructor Documentation

vtkTubeFilter::vtkTubeFilter ( ) [protected]

vtkTubeFilter::~vtkTubeFilter ( ) [inline, protected]

Definition at line 166 of file vtkTubeFilter.h.

Member Function Documentation

vtkTubeFilter::vtkTypeRevisionMacro | ( | vtkTubeFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkTubeFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkTubeFilter* vtkTubeFilter::New ( ) [static]

Construct object with radius 0.5, radius variation turned off, the number of sides set to 3, and radius factor of 10.

Reimplemented from vtkPolyDataSource.

virtual void vtkTubeFilter::SetRadius ( float ) [virtual]

Set the minimum tube radius (minimum because the tube radius may vary).

virtual float vtkTubeFilter::GetRadius ( ) [virtual]

Set the minimum tube radius (minimum because the tube radius may vary).

virtual void vtkTubeFilter::SetVaryRadius ( int ) [virtual]

Turn on/off the variation of tube radius with scalar value.

virtual int vtkTubeFilter::GetVaryRadius ( ) [virtual]

Turn on/off the variation of tube radius with scalar value.

void vtkTubeFilter::SetVaryRadiusToVaryRadiusOff ( ) [inline]

Turn on/off the variation of tube radius with scalar value.

Definition at line 97 of file vtkTubeFilter.h.

void vtkTubeFilter::SetVaryRadiusToVaryRadiusByScalar ( ) [inline]

Turn on/off the variation of tube radius with scalar value.

Definition at line 99 of file vtkTubeFilter.h.

void vtkTubeFilter::SetVaryRadiusToVaryRadiusByVector ( ) [inline]

Turn on/off the variation of tube radius with scalar value.

Definition at line 101 of file vtkTubeFilter.h.

const char * vtkTubeFilter::GetVaryRadiusAsString ( void ) [inline]

Return the method of varying tube radius descriptive character string.

Definition at line 188 of file vtkTubeFilter.h.

virtual void vtkTubeFilter::SetNumberOfSides ( int ) [virtual]

Set the number of sides for the tube. At a minimum, number of sides is 3.

virtual int vtkTubeFilter::GetNumberOfSides ( ) [virtual]

Set the number of sides for the tube. At a minimum, number of sides is 3.

virtual void vtkTubeFilter::SetRadiusFactor ( float ) [virtual]

Set the maximum tube radius in terms of a multiple of the minimum radius.

virtual float vtkTubeFilter::GetRadiusFactor ( ) [virtual]

Set the maximum tube radius in terms of a multiple of the minimum radius.

virtual void vtkTubeFilter::SetDefaultNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkTubeFilter::SetDefaultNormal ( float [3] ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual float* vtkTubeFilter::GetDefaultNormal ( ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkTubeFilter::GetDefaultNormal ( float data[3] ) [virtual]

Set the default normal to use if no normals are supplied, and the DefaultNormalOn is set.

virtual void vtkTubeFilter::SetUseDefaultNormal ( int ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual int vtkTubeFilter::GetUseDefaultNormal ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual void vtkTubeFilter::UseDefaultNormalOn ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual void vtkTubeFilter::UseDefaultNormalOff ( ) [virtual]

Set a boolean to control whether to use default normals. DefaultNormalOn is set.

virtual void vtkTubeFilter::SetSidesShareVertices ( int ) [virtual]

Set a boolean to control whether tube sides should share vertices

virtual int vtkTubeFilter::GetSidesShareVertices ( ) [virtual]

Set a boolean to control whether tube sides should share vertices

virtual void vtkTubeFilter::SidesShareVerticesOn ( ) [virtual]

Set a boolean to control whether tube sides should share vertices

virtual void vtkTubeFilter::SidesShareVerticesOff ( ) [virtual]

Set a boolean to control whether tube sides should share vertices

virtual void vtkTubeFilter::SetCapping ( int ) [virtual]

Turn on/off whether to cap the ends with polygons.

virtual int vtkTubeFilter::GetCapping ( ) [virtual]

Turn on/off whether to cap the ends with polygons.

virtual void vtkTubeFilter::CappingOn ( ) [virtual]

Turn on/off whether to cap the ends with polygons.

virtual void vtkTubeFilter::CappingOff ( ) [virtual]

Turn on/off whether to cap the ends with polygons.

virtual void vtkTubeFilter::SetOnRatio ( int ) [virtual]

Control the striping of the tubes. If OnRatio is greater than 1, then every nth tube side is turned on, beginning with the Offset side.

virtual int vtkTubeFilter::GetOnRatio ( ) [virtual]

Control the striping of the tubes. If OnRatio is greater than 1, then every nth tube side is turned on, beginning with the Offset side.

virtual void vtkTubeFilter::SetOffset ( int ) [virtual]

Control the striping of the tubes. The offset sets the first tube side that is visible. Offset is generally used with OnRatio to create nifty striping effects.

virtual int vtkTubeFilter::GetOffset ( ) [virtual]

Control the striping of the tubes. The offset sets the first tube side that is visible. Offset is generally used with OnRatio to create nifty striping effects.

void vtkTubeFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkTubeFilter::Radius [protected]

Definition at line 171 of file vtkTubeFilter.h.

int vtkTubeFilter::VaryRadius [protected]

Definition at line 172 of file vtkTubeFilter.h.

int vtkTubeFilter::NumberOfSides [protected]

Definition at line 173 of file vtkTubeFilter.h.

float vtkTubeFilter::RadiusFactor [protected]

Definition at line 174 of file vtkTubeFilter.h.

float vtkTubeFilter::DefaultNormal[3] [protected]

Definition at line 175 of file vtkTubeFilter.h.

int vtkTubeFilter::UseDefaultNormal [protected]

Definition at line 176 of file vtkTubeFilter.h.

int vtkTubeFilter::SidesShareVertices [protected]

Definition at line 177 of file vtkTubeFilter.h.

int vtkTubeFilter::Capping [protected]

Definition at line 178 of file vtkTubeFilter.h.

int vtkTubeFilter::OnRatio [protected]

Definition at line 179 of file vtkTubeFilter.h.

int vtkTubeFilter::Offset [protected]

Definition at line 180 of file vtkTubeFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkTubeFilter.h
Generated on Mon Mar 25 01:33:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUGFacetReader Class Reference

read EDS Unigraphics facet files. More...

#include <vtkUGFacetReader.h>

Inheritance diagram for vtkUGFacetReader:

[legend]
Collaboration diagram for vtkUGFacetReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUGFacetReader, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
int | GetNumberOfParts ()
short | GetPartColorIndex (int partId)
void | CreateDefaultLocator ()
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetPartNumber (int)
virtual int | GetPartNumber ()
virtual void | SetMerging (int)
virtual int | GetMerging ()
virtual void | MergingOn ()
virtual void | MergingOff ()
void | SetLocator (vtkPointLocator *locator)
virtual vtkPointLocator * | GetLocator ()

Static Public Methods

vtkUGFacetReader * | New ()

Protected Methods

vtkUGFacetReader ()
~vtkUGFacetReader ()
void | Execute ()

Protected Attributes

char * | FileName
vtkShortArray * PartColors
int | PartNumber
int | Merging
vtkPointLocator * Locator

Detailed Description

read EDS Unigraphics facet files.

Date:
2002/01/22 15:38:24
Revision:
1.37

vtkUGFacetReader is a source object that reads Unigraphics facet files. Unigraphics is a solid modeling system; facet files are the polygonal plot files it uses to create 3D plots.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Law, Charles (10%)
  • Martin, Ken (9%)
Tests:
vtkUGFacetReader (Tests)

Definition at line 45 of file vtkUGFacetReader.h.

Constructor & Destructor Documentation

vtkUGFacetReader::vtkUGFacetReader ( ) [protected]

vtkUGFacetReader::~vtkUGFacetReader ( ) [protected]

Member Function Documentation

vtkUGFacetReader::vtkTypeRevisionMacro | ( | vtkUGFacetReader | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkUGFacetReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkUGFacetReader* vtkUGFacetReader::New ( ) [static]

Construct object to extract all parts, and with point merging turned on.

Reimplemented from vtkPolyDataSource.

unsigned long vtkUGFacetReader::GetMTime ( ) [virtual]

Overload standard modified time function. If locator is modified, then this object is modified as well.

Reimplemented from vtkObject.

virtual void vtkUGFacetReader::SetFileName ( const char * ) [virtual]

Specify Unigraphics file name.

virtual char* vtkUGFacetReader::GetFileName ( ) [virtual]

Specify Unigraphics file name.

int vtkUGFacetReader::GetNumberOfParts ( )

Special methods for interrogating the data file.

short vtkUGFacetReader::GetPartColorIndex ( int partId )

Retrieve color index for the parts in the file.

virtual void vtkUGFacetReader::SetPartNumber ( int ) [virtual]

Specify the desired part to extract. The part number must range between [0,NumberOfParts-1]. If the value is =(-1), then all parts will be extracted. If the value is <(-1), then no parts will be extracted but the part colors will be updated.

virtual int vtkUGFacetReader::GetPartNumber ( ) [virtual]

Specify the desired part to extract. The part number must range between [0,NumberOfParts-1]. If the value is =(-1), then all parts will be extracted. If the value is <(-1), then no parts will be extracted but the part colors will be updated.

virtual void vtkUGFacetReader::SetMerging ( int ) [virtual]

Turn on/off merging of points/triangles.

virtual int vtkUGFacetReader::GetMerging ( ) [virtual]

Turn on/off merging of points/triangles.

virtual void vtkUGFacetReader::MergingOn ( ) [virtual]

Turn on/off merging of points/triangles.

virtual void vtkUGFacetReader::MergingOff ( ) [virtual]

Turn on/off merging of points/triangles.

void vtkUGFacetReader::SetLocator ( vtkPointLocator * locator )

Specify a spatial locator for merging points. By default an instance of vtkMergePoints is used.

virtual vtkPointLocator* vtkUGFacetReader::GetLocator ( ) [virtual]

Specify a spatial locator for merging points. By default an instance of vtkMergePoints is used.

void vtkUGFacetReader::CreateDefaultLocator ( void )

Create default locator. Used to create one when none is specified.

void vtkUGFacetReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkUGFacetReader::FileName [protected]

Definition at line 103 of file vtkUGFacetReader.h.

vtkShortArray* vtkUGFacetReader::PartColors [protected]

Definition at line 104 of file vtkUGFacetReader.h.

int vtkUGFacetReader::PartNumber [protected]

Definition at line 105 of file vtkUGFacetReader.h.

int vtkUGFacetReader::Merging [protected]

Definition at line 106 of file vtkUGFacetReader.h.

vtkPointLocator* vtkUGFacetReader::Locator [protected]

Definition at line 107 of file vtkUGFacetReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkUGFacetReader.h
Generated on Mon Mar 25 01:33:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedCharArray Class Reference

dynamic, self-adjusting unsigned character array. More...

#include <vtkUnsignedCharArray.h>

Inheritance diagram for vtkUnsignedCharArray:

[legend]
Collaboration diagram for vtkUnsignedCharArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnsignedCharArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
unsigned char | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const unsigned char c)
vtkIdType | InsertNextValue (const unsigned char c)
unsigned char * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const unsigned char value)
unsigned char * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (unsigned char *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)

Static Public Methods

vtkUnsignedCharArray * | New ()

Protected Methods

vtkUnsignedCharArray (vtkIdType numComp=1)
~vtkUnsignedCharArray ()
unsigned char * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

unsigned char * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting unsigned character array.

Date:
2002/02/13 22:46:30
Revision:
1.66

vtkUnsignedCharArray is an array of unsigned character values. It provides methods for insertion and retrieval of characters, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (48%)
  • Martin, Ken (19%)
  • Henderson, Amy (7%)
  • Geveci, Berk (7%)
  • Kelly, Ann (5%)
  • Miller, Jim (5%)
Tests:
vtkUnsignedCharArray (Tests)

Definition at line 46 of file vtkUnsignedCharArray.h.

Constructor & Destructor Documentation

vtkUnsignedCharArray::vtkUnsignedCharArray ( vtkIdType numComp = 1 ) [protected]

vtkUnsignedCharArray::~vtkUnsignedCharArray ( ) [protected]

Member Function Documentation

vtkUnsignedCharArray* vtkUnsignedCharArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkUnsignedCharArray::vtkTypeRevisionMacro | ( | vtkUnsignedCharArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkUnsignedCharArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkUnsignedCharArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkUnsignedCharArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkUnsignedCharArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkUnsignedCharArray.h.

int vtkUnsignedCharArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkUnsignedCharArray.h.

void vtkUnsignedCharArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkUnsignedCharArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedCharArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedCharArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 104 of file vtkUnsignedCharArray.h.

virtual void vtkUnsignedCharArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

float vtkUnsignedCharArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

unsigned char vtkUnsignedCharArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 126 of file vtkUnsignedCharArray.h.

void vtkUnsignedCharArray::SetValue | ( | const vtkIdType | id,
 |  | const unsigned char | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 131 of file vtkUnsignedCharArray.h.

void vtkUnsignedCharArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 193 of file vtkUnsignedCharArray.h.

void vtkUnsignedCharArray::InsertValue | ( | const vtkIdType | id,
 |  | const unsigned char | c
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 214 of file vtkUnsignedCharArray.h.

Referenced by InsertNextValue().

vtkIdType vtkUnsignedCharArray::InsertNextValue ( const unsigned char c ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 228 of file vtkUnsignedCharArray.h.

unsigned char* vtkUnsignedCharArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 150 of file vtkUnsignedCharArray.h.

void* vtkUnsignedCharArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 151 of file vtkUnsignedCharArray.h.

unsigned char * vtkUnsignedCharArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 199 of file vtkUnsignedCharArray.h.

void vtkUnsignedCharArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another unsigned char array.

Reimplemented from vtkDataArray.

void vtkUnsignedCharArray::SetArray | ( | unsigned char * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkUnsignedCharArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 171 of file vtkUnsignedCharArray.h.

unsigned char* vtkUnsignedCharArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

unsigned char* vtkUnsignedCharArray::Array [protected]

Definition at line 180 of file vtkUnsignedCharArray.h.

int vtkUnsignedCharArray::TupleSize [protected]

Definition at line 184 of file vtkUnsignedCharArray.h.

float* vtkUnsignedCharArray::Tuple [protected]

Definition at line 185 of file vtkUnsignedCharArray.h.

int vtkUnsignedCharArray::SaveUserArray [protected]

Definition at line 187 of file vtkUnsignedCharArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkUnsignedCharArray.h
Generated on Mon Mar 25 01:33:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedIntArray Class Reference

dynamic, self-adjusting unsigned int integer array. More...

#include <vtkUnsignedIntArray.h>

Inheritance diagram for vtkUnsignedIntArray:

[legend]
Collaboration diagram for vtkUnsignedIntArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnsignedIntArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
unsigned int | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const unsigned int i)
vtkIdType | InsertNextValue (const unsigned int)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
unsigned int * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
virtual void | Resize (vtkIdType numTuples)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const unsigned int value)
unsigned int * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (unsigned int *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)
void | Squeeze ()
void | DeepCopy (vtkDataArray &da)

Static Public Methods

vtkUnsignedIntArray * | New ()

Protected Methods

vtkUnsignedIntArray (vtkIdType numComp=1)
~vtkUnsignedIntArray ()
unsigned int * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

unsigned int * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting unsigned int integer array.

Date:
2002/02/13 22:46:30
Revision:
1.32

vtkUnsignedIntArray is an array of unsigned int integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (25%)
  • Henderson, Amy (8%)
  • Geveci, Berk (6%)
  • Kelly, Ann (6%)
  • Miller, Jim (5%)
Tests:
vtkUnsignedIntArray (Tests)

Definition at line 46 of file vtkUnsignedIntArray.h.

Constructor & Destructor Documentation

vtkUnsignedIntArray::vtkUnsignedIntArray ( vtkIdType numComp = 1 ) [protected]

vtkUnsignedIntArray::~vtkUnsignedIntArray ( ) [protected]

Member Function Documentation

vtkUnsignedIntArray* vtkUnsignedIntArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkUnsignedIntArray::vtkTypeRevisionMacro | ( | vtkUnsignedIntArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkUnsignedIntArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkUnsignedIntArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkUnsignedIntArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkUnsignedIntArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkUnsignedIntArray.h.

int vtkUnsignedIntArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkUnsignedIntArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedIntArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedIntArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

unsigned int vtkUnsignedIntArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 104 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::SetValue | ( | const vtkIdType | id,
 |  | const unsigned int | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 109 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 205 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::InsertValue | ( | const vtkIdType | id,
 |  | const unsigned int | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 226 of file vtkUnsignedIntArray.h.

Referenced by InsertNextValue().

vtkIdType vtkUnsignedIntArray::InsertNextValue ( unsigned int i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 240 of file vtkUnsignedIntArray.h.

float vtkUnsignedIntArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

virtual void vtkUnsignedIntArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

unsigned int* vtkUnsignedIntArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 144 of file vtkUnsignedIntArray.h.

void* vtkUnsignedIntArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 145 of file vtkUnsignedIntArray.h.

unsigned int * vtkUnsignedIntArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 211 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another unsigned int array.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::SetArray | ( | unsigned int * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkUnsignedIntArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 165 of file vtkUnsignedIntArray.h.

void vtkUnsignedIntArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 171 of file vtkUnsignedIntArray.h.

virtual void vtkUnsignedIntArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void vtkUnsignedIntArray::DeepCopy ( vtkDataArray & da ) [inline]

For legacy compatibility. Do not use.

Definition at line 181 of file vtkUnsignedIntArray.h.

unsigned int* vtkUnsignedIntArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

unsigned int* vtkUnsignedIntArray::Array [protected]

Definition at line 191 of file vtkUnsignedIntArray.h.

int vtkUnsignedIntArray::TupleSize [protected]

Definition at line 195 of file vtkUnsignedIntArray.h.

float* vtkUnsignedIntArray::Tuple [protected]

Definition at line 196 of file vtkUnsignedIntArray.h.

int vtkUnsignedIntArray::SaveUserArray [protected]

Definition at line 198 of file vtkUnsignedIntArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkUnsignedIntArray.h
Generated on Mon Mar 25 01:33:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedLongArray Class Reference

dynamic, self-adjusting unsigned long integer array. More...

#include <vtkUnsignedLongArray.h>

Inheritance diagram for vtkUnsignedLongArray:

[legend]
Collaboration diagram for vtkUnsignedLongArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnsignedLongArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
unsigned long | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const unsigned long i)
vtkIdType | InsertNextValue (const unsigned long)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
virtual void | InsertComponent (const vtkIdType i, const int j, const float c)
unsigned long * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const unsigned long value)
unsigned long * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (unsigned long *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)
void | DeepCopy (vtkDataArray &da)

Static Public Methods

vtkUnsignedLongArray * | New ()

Protected Methods

vtkUnsignedLongArray (vtkIdType numComp=1)
~vtkUnsignedLongArray ()
unsigned long * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

unsigned long * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting unsigned long integer array.

Date:
2002/02/13 22:46:31
Revision:
1.32

vtkUnsignedLongArray is an array of unsigned long integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (40%)
  • Martin, Ken (25%)
  • Henderson, Amy (8%)
  • Geveci, Berk (6%)
  • Miller, Jim (5%)
  • Kelly, Ann (5%)
Tests:
vtkUnsignedLongArray (Tests)

Definition at line 46 of file vtkUnsignedLongArray.h.

Constructor & Destructor Documentation

vtkUnsignedLongArray::vtkUnsignedLongArray ( vtkIdType numComp = 1 ) [protected]

vtkUnsignedLongArray::~vtkUnsignedLongArray ( ) [protected]

Member Function Documentation

vtkUnsignedLongArray* vtkUnsignedLongArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkUnsignedLongArray::vtkTypeRevisionMacro | ( | vtkUnsignedLongArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkUnsignedLongArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkUnsignedLongArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkUnsignedLongArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkUnsignedLongArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkUnsignedLongArray.h.

int vtkUnsignedLongArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 68 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkUnsignedLongArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedLongArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedLongArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

unsigned long vtkUnsignedLongArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 104 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::SetValue | ( | const vtkIdType | id,
 |  | const unsigned long | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 109 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 201 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::InsertValue | ( | const vtkIdType | id,
 |  | const unsigned long | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 222 of file vtkUnsignedLongArray.h.

Referenced by InsertNextValue().

vtkIdType vtkUnsignedLongArray::InsertNextValue ( unsigned long i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 236 of file vtkUnsignedLongArray.h.

float vtkUnsignedLongArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less then NumberOfTuples and j is less then NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

virtual void vtkUnsignedLongArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

unsigned long* vtkUnsignedLongArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 144 of file vtkUnsignedLongArray.h.

void* vtkUnsignedLongArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 145 of file vtkUnsignedLongArray.h.

unsigned long * vtkUnsignedLongArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 207 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another unsigned long array.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::SetArray | ( | unsigned long * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkUnsignedLongArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 165 of file vtkUnsignedLongArray.h.

void vtkUnsignedLongArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 170 of file vtkUnsignedLongArray.h.

virtual void vtkUnsignedLongArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void vtkUnsignedLongArray::DeepCopy ( vtkDataArray & da ) [inline]

For legacy compatibility. Do not use.

Definition at line 178 of file vtkUnsignedLongArray.h.

unsigned long* vtkUnsignedLongArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

unsigned long* vtkUnsignedLongArray::Array [protected]

Definition at line 188 of file vtkUnsignedLongArray.h.

int vtkUnsignedLongArray::TupleSize [protected]

Definition at line 192 of file vtkUnsignedLongArray.h.

float* vtkUnsignedLongArray::Tuple [protected]

Definition at line 193 of file vtkUnsignedLongArray.h.

int vtkUnsignedLongArray::SaveUserArray [protected]

Definition at line 195 of file vtkUnsignedLongArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkUnsignedLongArray.h
Generated on Mon Mar 25 01:33:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnsignedShortArray Class Reference

dynamic, self-adjusting unsigned short integer array. More...

#include <vtkUnsignedShortArray.h>

Inheritance diagram for vtkUnsignedShortArray:

[legend]
Collaboration diagram for vtkUnsignedShortArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnsignedShortArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
float | GetComponent (const vtkIdType i, const int j)
void | SetComponent (const vtkIdType i, const int j, const float c)
void | InsertComponent (const vtkIdType i, const int j, const float c)
unsigned short | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | InsertValue (const vtkIdType id, const unsigned short i)
vtkIdType | InsertNextValue (const unsigned short)
unsigned short * | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *ia)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void | SetValue (const vtkIdType id, const unsigned short value)
unsigned short * | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)
void | SetArray (unsigned short *array, vtkIdType size, int save)
void | SetVoidArray (void *array, vtkIdType size, int save)
void | DeepCopy (vtkDataArray &ia)

Static Public Methods

vtkUnsignedShortArray * | New ()

Protected Methods

vtkUnsignedShortArray (vtkIdType numComp=1)
~vtkUnsignedShortArray ()
unsigned short * | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

unsigned short * | Array
int | TupleSize
float * | Tuple
int | SaveUserArray

Detailed Description

dynamic, self-adjusting unsigned short integer array.

Date:
2002/02/13 22:46:31
Revision:
1.50

vtkUnsignedShortArray is an array of unsigned short integer numbers. It provides methods for insertion and retrieval of integer values, and will automatically resize itself to hold new data.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (31%)
  • Martin, Ken (21%)
  • Schroeder, Will (11%)
  • Henderson, Amy (8%)
  • Geveci, Berk (7%)
  • Miller, Jim (7%)
  • Kelly, Ann (6%)
Tests:
vtkUnsignedShortArray (Tests)

Definition at line 47 of file vtkUnsignedShortArray.h.

Constructor & Destructor Documentation

vtkUnsignedShortArray::vtkUnsignedShortArray ( vtkIdType numComp = 1 ) [protected]

vtkUnsignedShortArray::~vtkUnsignedShortArray ( ) [protected]

Member Function Documentation

vtkUnsignedShortArray* vtkUnsignedShortArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkUnsignedShortArray::vtkTypeRevisionMacro | ( | vtkUnsignedShortArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkUnsignedShortArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkUnsignedShortArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkUnsignedShortArray::MakeObject ( ) [virtual]

Create the same type object as this (virtual constructor).

Reimplemented from vtkDataArray.

int vtkUnsignedShortArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 66 of file vtkUnsignedShortArray.h.

int vtkUnsignedShortArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 69 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkUnsignedShortArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location. This is a dangerous method (it is not thread safe since a pointer is returned).

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedShortArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkUnsignedShortArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

float vtkUnsignedShortArray::GetComponent | ( | const vtkIdType | i,
 |  | const int | j
 | ) | [virtual]

Return the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::SetComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Set the data component at the ith tuple and jth component location. Note that i is less than NumberOfTuples and j is less than NumberOfComponents. Make sure enough memory has been allocated (use SetNumberOfTuples() and SetNumberOfComponents()).

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::InsertComponent | ( | const vtkIdType | i,
 |  | const int | j,
 |  | const float | c
 | ) | [virtual]

Insert the data component at ith tuple and jth component location. Note that memory allocation is performed as necessary to hold the data.

Reimplemented from vtkDataArray.

unsigned short vtkUnsignedShortArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 121 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::SetValue | ( | const vtkIdType | id,
 |  | const unsigned short | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 126 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 202 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::InsertValue | ( | const vtkIdType | id,
 |  | const unsigned short | i
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 223 of file vtkUnsignedShortArray.h.

Referenced by InsertNextValue().

vtkIdType vtkUnsignedShortArray::InsertNextValue ( unsigned short i ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 237 of file vtkUnsignedShortArray.h.

unsigned short* vtkUnsignedShortArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 145 of file vtkUnsignedShortArray.h.

void* vtkUnsignedShortArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 146 of file vtkUnsignedShortArray.h.

unsigned short * vtkUnsignedShortArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 208 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::DeepCopy ( vtkDataArray * ia ) [virtual]

Deep copy of another unsigned short array.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::SetArray | ( | unsigned short * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) |

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

void vtkUnsignedShortArray::SetVoidArray | ( | void * | array,
 |  | vtkIdType | size,
 |  | int | save
 | ) | [inline]

This method lets the user specify data to be held by the array. The array argument is a pointer to the data. size is the size of the array supplied by the user. Set save to 1 to keep the class from deleting the array when it cleans up or reallocates memory. The class uses the actual array provided; it does not copy the data from the suppled array.

Definition at line 166 of file vtkUnsignedShortArray.h.

void vtkUnsignedShortArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 171 of file vtkUnsignedShortArray.h.

virtual void vtkUnsignedShortArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void vtkUnsignedShortArray::DeepCopy ( vtkDataArray & ia ) [inline]

For legacy compatibility. Do not use.

Definition at line 179 of file vtkUnsignedShortArray.h.

unsigned short* vtkUnsignedShortArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

unsigned short* vtkUnsignedShortArray::Array [protected]

Definition at line 189 of file vtkUnsignedShortArray.h.

int vtkUnsignedShortArray::TupleSize [protected]

Definition at line 193 of file vtkUnsignedShortArray.h.

float* vtkUnsignedShortArray::Tuple [protected]

Definition at line 194 of file vtkUnsignedShortArray.h.

int vtkUnsignedShortArray::SaveUserArray [protected]

Definition at line 196 of file vtkUnsignedShortArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkUnsignedShortArray.h
Generated on Mon Mar 25 01:33:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGrid Class Reference

dataset represents arbitrary combinations of all possible cell types. More...

#include <vtkUnstructuredGrid.h>

Inheritance diagram for vtkUnstructuredGrid:

[legend]
Collaboration diagram for vtkUnstructuredGrid:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGrid, vtkPointSet)
void | PrintSelf (ostream &os, vtkIndent indent)
int | GetCellType (vtkIdType cellId)
void | Squeeze ()
void | Initialize ()
int | GetMaxCellSize ()
void | BuildLinks ()
vtkCellLinks * GetCellLinks ()
virtual void | GetCellPoints (vtkIdType cellId, vtkIdType &npts, vtkIdType *&pts)
void | ReplaceCell (vtkIdType cellId, int npts, vtkIdType *pts)
int | InsertNextLinkedCell (int type, int npts, vtkIdType *pts)
void | RemoveReferenceToCell (vtkIdType ptId, vtkIdType cellId)
void | AddReferenceToCell (vtkIdType ptId, vtkIdType cellId)
void | ResizeCellList (vtkIdType ptId, int size)
unsigned long | GetActualMemorySize ()
void | GetListOfUniqueCellTypes (vtkUnsignedCharArray *uniqueTypes)
void | GetIdsOfCellsOfType (int type, vtkIntArray *array)
int | IsHomogeneous ()
void | RemoveGhostCells (int level)
int | GetDataObjectType ()
virtual void | Allocate (vtkIdType numCells=1000, int extSize=1000)
int | InsertNextCell (int type, int npts, vtkIdType *pts)
int | InsertNextCell (int type, vtkIdList *ptIds)
void | Reset ()
void | SetCells (int *types, vtkCellArray *cells)
void | SetCells (vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations, vtkCellArray *cells)
vtkCellArray * GetCells ()
vtkDataObject * MakeObject ()
virtual void | CopyStructure (vtkDataSet *ds)
vtkIdType GetNumberOfCells ()
virtual vtkCell * | GetCell (vtkIdType cellId)
virtual void | GetCell (vtkIdType cellId, vtkGenericCell *cell)
virtual void | GetCellBounds (vtkIdType cellId, float bounds[6])
virtual void | GetCellPoints (vtkIdType cellId, vtkIdList *ptIds)
void | GetPointCells (vtkIdType ptId, vtkIdList *cellIds)
virtual void | GetCellNeighbors (vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds)
void | SetUpdateExtent (int piece, int numPieces, int ghostLevel)
void | SetUpdateExtent (int piece, int numPieces)
void | GetUpdateExtent (int &piece, int &numPieces, int &ghostLevel)
virtual int * | GetUpdateExtent ()
virtual void | GetUpdateExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetUpdateExtent (int[6])
void | SetUpdateExtent (int x1, int x2, int y1, int y2, int z1, int z2)
void | SetUpdateExtent (int ext[6])
virtual int | GetPiece ()
virtual int | GetNumberOfPieces ()
virtual int | GetGhostLevel ()
virtual void | ShallowCopy (vtkDataObject *src)
virtual void | DeepCopy (vtkDataObject *src)

Static Public Methods

vtkUnstructuredGrid * | New ()

Protected Methods

vtkUnstructuredGrid ()
~vtkUnstructuredGrid ()

Protected Attributes

vtkVertex * Vertex
vtkPolyVertex * PolyVertex
vtkLine * Line
vtkPolyLine * PolyLine
vtkTriangle * Triangle
vtkTriangleStrip * TriangleStrip
vtkPixel * Pixel
vtkQuad * Quad
vtkPolygon * Polygon
vtkTetra * Tetra
vtkVoxel * Voxel
vtkHexahedron * Hexahedron
vtkWedge * Wedge
vtkPyramid * Pyramid
vtkQuadraticEdge * QuadraticEdge
vtkCellArray * Connectivity
vtkCellLinks * Links
vtkUnsignedCharArray * Types
vtkIntArray * Locations

Detailed Description

dataset represents arbitrary combinations of all possible cell types.

Date:
2002/03/12 18:18:02
Revision:
1.83

vtkUnstructuredGrid is a data object that is a concrete implementation of vtkDataSet. vtkUnstructuredGrid represents any combinations of any cell types. This includes 0D (e.g., points), 1D (e.g., lines, polylines), 2D (e.g., triangles, polygons), and 3D (e.g., hexahedron, tetrahedron).

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (38%)
  • Law, Charles (24%)
  • Lee, Jeff (16%)
  • Martin, Ken (5%)
  • Henderson, Amy (5%)
  • Miller, Jim (5%)
Examples:
vtkUnstructuredGrid (Examples)
Tests:
vtkUnstructuredGrid (Tests)

Definition at line 70 of file vtkUnstructuredGrid.h.

Constructor & Destructor Documentation

vtkUnstructuredGrid::vtkUnstructuredGrid ( ) [protected]

vtkUnstructuredGrid::~vtkUnstructuredGrid ( ) [protected]

Member Function Documentation

vtkUnstructuredGrid* vtkUnstructuredGrid::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkDataObject.

Referenced by MakeObject().

vtkUnstructuredGrid::vtkTypeRevisionMacro | ( | vtkUnstructuredGrid | ,
 |  | vtkPointSet |
 | ) |

Reimplemented from vtkPointSet.

void vtkUnstructuredGrid::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkPointSet.

int vtkUnstructuredGrid::GetDataObjectType ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

Definition at line 82 of file vtkUnstructuredGrid.h.

virtual void vtkUnstructuredGrid::Allocate | ( | vtkIdType | numCells = 1000,
 |  | int | extSize = 1000
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

int vtkUnstructuredGrid::InsertNextCell | ( | int | type,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

Standard vtkDataSet API methods. See vtkDataSet for more information.

int vtkUnstructuredGrid::InsertNextCell | ( | int | type,
 |  | vtkIdList * | ptIds
 | ) |

Standard vtkDataSet API methods. See vtkDataSet for more information.

void vtkUnstructuredGrid::Reset ( )

Standard vtkDataSet API methods. See vtkDataSet for more information.

void vtkUnstructuredGrid::SetCells | ( | int * | types,
 |  | vtkCellArray * | cells
 | ) |

Standard vtkDataSet API methods. See vtkDataSet for more information.

void vtkUnstructuredGrid::SetCells | ( | vtkUnsignedCharArray * | cellTypes,
 |  | vtkIntArray * | cellLocations,
 |  | vtkCellArray * | cells
 | ) |

Standard vtkDataSet API methods. See vtkDataSet for more information.

vtkCellArray* vtkUnstructuredGrid::GetCells ( ) [inline]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Definition at line 90 of file vtkUnstructuredGrid.h.

vtkDataObject* vtkUnstructuredGrid::MakeObject ( ) [inline, virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataObject.

Definition at line 91 of file vtkUnstructuredGrid.h.

virtual void vtkUnstructuredGrid::CopyStructure ( vtkDataSet * ds ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkPointSet.

vtkIdType vtkUnstructuredGrid::GetNumberOfCells ( ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

virtual vtkCell* vtkUnstructuredGrid::GetCell ( vtkIdType cellId ) [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

virtual void vtkUnstructuredGrid::GetCell | ( | vtkIdType | cellId,
 |  | vtkGenericCell * | cell
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

virtual void vtkUnstructuredGrid::GetCellBounds | ( | vtkIdType | cellId,
 |  | float | bounds[6]
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

virtual void vtkUnstructuredGrid::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

void vtkUnstructuredGrid::GetPointCells | ( | vtkIdType | ptId,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Standard vtkDataSet API methods. See vtkDataSet for more information.

Reimplemented from vtkDataSet.

int vtkUnstructuredGrid::GetCellType ( vtkIdType cellId ) [virtual]

Get type of cell with cellId such that: 0 <= cellId < NumberOfCells. THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented from vtkDataSet.

void vtkUnstructuredGrid::Squeeze ( ) [virtual]

Reclaim any unused memory.

Reimplemented from vtkPointSet.

void vtkUnstructuredGrid::Initialize ( ) [virtual]

Reset to an empty state and free any memory.

Reimplemented from vtkPointSet.

int vtkUnstructuredGrid::GetMaxCellSize ( ) [virtual]

Convenience method returns largest cell size in dataset. This is generally used to allocate memory for supporting data structures. THIS METHOD IS THREAD SAFE

Reimplemented from vtkDataSet.

void vtkUnstructuredGrid::BuildLinks ( )

vtkCellLinks* vtkUnstructuredGrid::GetCellLinks ( ) [inline]

Definition at line 106 of file vtkUnstructuredGrid.h.

virtual void vtkUnstructuredGrid::GetCellPoints | ( | vtkIdType | cellId,
 |  | vtkIdType & | npts,
 |  | vtkIdType *& | pts
 | ) | [virtual]

void vtkUnstructuredGrid::ReplaceCell | ( | vtkIdType | cellId,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

int vtkUnstructuredGrid::InsertNextLinkedCell | ( | int | type,
 |  | int | npts,
 |  | vtkIdType * | pts
 | ) |

void vtkUnstructuredGrid::RemoveReferenceToCell | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) |

void vtkUnstructuredGrid::AddReferenceToCell | ( | vtkIdType | ptId,
 |  | vtkIdType | cellId
 | ) |

void vtkUnstructuredGrid::ResizeCellList | ( | vtkIdType | ptId,
 |  | int | size
 | ) |

virtual void vtkUnstructuredGrid::GetCellNeighbors | ( | vtkIdType | cellId,
 |  | vtkIdList * | ptIds,
 |  | vtkIdList * | cellIds
 | ) | [virtual]

Topological inquiry to get all cells using list of points exclusive of cell specified (e.g., cellId). THIS METHOD IS THREAD SAFE IF FIRST CALLED FROM A SINGLE THREAD AND THE DATASET IS NOT MODIFIED

Reimplemented from vtkDataSet.

void vtkUnstructuredGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces,
 |  | int | ghostLevel
 | ) |

For streaming. User/next filter specifies which piece the want updated. The source of this poly data has to return exactly this piece.

void vtkUnstructuredGrid::SetUpdateExtent | ( | int | piece,
 |  | int | numPieces
 | ) | [inline]

For streaming. User/next filter specifies which piece the want updated. The source of this poly data has to return exactly this piece.

Reimplemented from vtkDataObject.

Definition at line 128 of file vtkUnstructuredGrid.h.

void vtkUnstructuredGrid::GetUpdateExtent | ( | int & | piece,
 |  | int & | numPieces,
 |  | int & | ghostLevel
 | ) |

For streaming. User/next filter specifies which piece the want updated. The source of this poly data has to return exactly this piece.

virtual int* vtkUnstructuredGrid::GetUpdateExtent ( ) [virtual]

We need this here to keep from hiding superclass method

Reimplemented from vtkDataObject.

virtual void vtkUnstructuredGrid::GetUpdateExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

We need this here to keep from hiding superclass method

Reimplemented from vtkDataObject.

virtual void vtkUnstructuredGrid::GetUpdateExtent ( int [6] ) [virtual]

We need this here to keep from hiding superclass method

Reimplemented from vtkDataObject.

void vtkUnstructuredGrid::SetUpdateExtent | ( | int | x1,
 |  | int | x2,
 |  | int | y1,
 |  | int | y2,
 |  | int | z1,
 |  | int | z2
 | ) | [inline, virtual]

Call superclass method to avoid hiding Since this data type does not use 3D extents, this set method is useless but necessary since vtkDataSetToDataSetFilter does not know what type of data it is working on.

Reimplemented from vtkDataObject.

Definition at line 143 of file vtkUnstructuredGrid.h.

void vtkUnstructuredGrid::SetUpdateExtent ( int ext[6] ) [inline, virtual]

Call superclass method to avoid hiding Since this data type does not use 3D extents, this set method is useless but necessary since vtkDataSetToDataSetFilter does not know what type of data it is working on.

Reimplemented from vtkDataObject.

Definition at line 145 of file vtkUnstructuredGrid.h.

virtual int vtkUnstructuredGrid::GetPiece ( ) [virtual]

Set / Get the piece and the number of pieces. Similar to extent in 3D.

virtual int vtkUnstructuredGrid::GetNumberOfPieces ( ) [virtual]

Set / Get the piece and the number of pieces. Similar to extent in 3D.

virtual int vtkUnstructuredGrid::GetGhostLevel ( ) [virtual]

Set / Get the ghost level.

unsigned long vtkUnstructuredGrid::GetActualMemorySize ( ) [virtual]

Return the actual size of the data in kilobytes. This number is valid only after the pipeline has updated. The memory size returned is guaranteed to be greater than or equal to the memory required to represent the data (e.g., extra space in arrays, etc. are not included in the return value). THIS METHOD IS THREAD SAFE.

Reimplemented from vtkPointSet.

virtual void vtkUnstructuredGrid::ShallowCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

virtual void vtkUnstructuredGrid::DeepCopy ( vtkDataObject * src ) [virtual]

Shallow and Deep copy.

Reimplemented from vtkPointSet.

void vtkUnstructuredGrid::GetListOfUniqueCellTypes ( vtkUnsignedCharArray * uniqueTypes )

Fill vtkUnsignedCharArray container with list of unique cell types. This method traverses all cells and, for each unique cell type it encounters, inserts the type into the container.

void vtkUnstructuredGrid::GetIdsOfCellsOfType | ( | int | type,
 |  | vtkIntArray * | array
 | ) |

Fill vtkIntArray container with list of cell Ids. This method traverses all cells and, for a particular cell type, inserts the cell Id into the container.

int vtkUnstructuredGrid::IsHomogeneous ( )

Traverse cells and determine if cells are all of the same type.

void vtkUnstructuredGrid::RemoveGhostCells ( int level )

This method will remove any cell that has a ghost level array value greater or equal to level.

Member Data Documentation

vtkVertex* vtkUnstructuredGrid::Vertex [protected]

Definition at line 197 of file vtkUnstructuredGrid.h.

vtkPolyVertex* vtkUnstructuredGrid::PolyVertex [protected]

Definition at line 198 of file vtkUnstructuredGrid.h.

vtkLine* vtkUnstructuredGrid::Line [protected]

Definition at line 199 of file vtkUnstructuredGrid.h.

vtkPolyLine* vtkUnstructuredGrid::PolyLine [protected]

Definition at line 200 of file vtkUnstructuredGrid.h.

vtkTriangle* vtkUnstructuredGrid::Triangle [protected]

Definition at line 201 of file vtkUnstructuredGrid.h.

vtkTriangleStrip* vtkUnstructuredGrid::TriangleStrip [protected]

Definition at line 202 of file vtkUnstructuredGrid.h.

vtkPixel* vtkUnstructuredGrid::Pixel [protected]

Definition at line 203 of file vtkUnstructuredGrid.h.

vtkQuad* vtkUnstructuredGrid::Quad [protected]

Definition at line 204 of file vtkUnstructuredGrid.h.

vtkPolygon* vtkUnstructuredGrid::Polygon [protected]

Definition at line 205 of file vtkUnstructuredGrid.h.

vtkTetra* vtkUnstructuredGrid::Tetra [protected]

Definition at line 206 of file vtkUnstructuredGrid.h.

vtkVoxel* vtkUnstructuredGrid::Voxel [protected]

Definition at line 207 of file vtkUnstructuredGrid.h.

vtkHexahedron* vtkUnstructuredGrid::Hexahedron [protected]

Definition at line 208 of file vtkUnstructuredGrid.h.

vtkWedge* vtkUnstructuredGrid::Wedge [protected]

Definition at line 209 of file vtkUnstructuredGrid.h.

vtkPyramid* vtkUnstructuredGrid::Pyramid [protected]

Definition at line 210 of file vtkUnstructuredGrid.h.

vtkQuadraticEdge* vtkUnstructuredGrid::QuadraticEdge [protected]

Definition at line 211 of file vtkUnstructuredGrid.h.

vtkCellArray* vtkUnstructuredGrid::Connectivity [protected]

Definition at line 215 of file vtkUnstructuredGrid.h.

vtkCellLinks* vtkUnstructuredGrid::Links [protected]

Definition at line 216 of file vtkUnstructuredGrid.h.

vtkUnsignedCharArray* vtkUnstructuredGrid::Types [protected]

Definition at line 217 of file vtkUnstructuredGrid.h.

vtkIntArray* vtkUnstructuredGrid::Locations [protected]

Definition at line 218 of file vtkUnstructuredGrid.h.

The documentation for this class was generated from the following file:
  • Common/vtkUnstructuredGrid.h
Generated on Mon Mar 25 01:33:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridReader Class Reference

read vtk unstructured grid data file. More...

#include <vtkUnstructuredGridReader.h>

Inheritance diagram for vtkUnstructuredGridReader:

[legend]
Collaboration diagram for vtkUnstructuredGridReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGridReader, vtkDataReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkUnstructuredGrid * GetOutput ()
vtkUnstructuredGrid * | GetOutput (int idx)
void | SetOutput (vtkUnstructuredGrid *output)

Static Public Methods

vtkUnstructuredGridReader * | New ()

Protected Methods

vtkUnstructuredGridReader ()
~vtkUnstructuredGridReader ()
void | Execute ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

read vtk unstructured grid data file.

Date:
2002/01/22 15:38:24
Revision:
1.46

vtkUnstructuredGridReader is a source object that reads ASCII or binary unstructured grid data files in vtk format. (see text for format details). The output of this reader is a single vtkUnstructuredGrid data object. The superclass of this class, vtkDataReader, provides many methods for controlling the reading of the data file, see vtkDataReader for more information.

Warning:
Binary files written on one system may not be readable on other systems.
See also:
vtkUnstructuredGrid vtkDataReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Martin, Ken (14%)
  • Lorensen, Bill (7%)
Examples:
vtkUnstructuredGridReader (Examples)
Tests:
vtkUnstructuredGridReader (Tests)

Definition at line 54 of file vtkUnstructuredGridReader.h.

Constructor & Destructor Documentation

vtkUnstructuredGridReader::vtkUnstructuredGridReader ( ) [protected]

vtkUnstructuredGridReader::~vtkUnstructuredGridReader ( ) [protected]

Member Function Documentation

vtkUnstructuredGridReader* vtkUnstructuredGridReader::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkDataReader.

vtkUnstructuredGridReader::vtkTypeRevisionMacro | ( | vtkUnstructuredGridReader | ,
 |  | vtkDataReader |
 | ) |

Reimplemented from vtkDataReader.

void vtkUnstructuredGridReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataReader.

vtkUnstructuredGrid* vtkUnstructuredGridReader::GetOutput ( )

Get the output of this reader.

vtkUnstructuredGrid* vtkUnstructuredGridReader::GetOutput ( int idx ) [inline]

Get the output of this reader.

Reimplemented from vtkSource.

Definition at line 64 of file vtkUnstructuredGridReader.h.

void vtkUnstructuredGridReader::SetOutput ( vtkUnstructuredGrid * output )

Get the output of this reader.

void vtkUnstructuredGridReader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkUnstructuredGridReader::ComputeInputUpdateExtents ( vtkDataObject * output ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

The documentation for this class was generated from the following file:
  • IO/vtkUnstructuredGridReader.h
Generated on Mon Mar 25 01:33:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridSource Class Reference

abstract class whose subclasses generate unstructured grid data. More...

#include <vtkUnstructuredGridSource.h>

Inheritance diagram for vtkUnstructuredGridSource:

[legend]
Collaboration diagram for vtkUnstructuredGridSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGridSource, vtkSource)
vtkUnstructuredGrid * GetOutput ()
vtkUnstructuredGrid * | GetOutput (int idx)
void | SetOutput (vtkUnstructuredGrid *output)

Static Public Methods

vtkUnstructuredGridSource * | New ()

Protected Methods

vtkUnstructuredGridSource ()
~vtkUnstructuredGridSource ()
void | ComputeInputUpdateExtents (vtkDataObject *output)

Detailed Description

abstract class whose subclasses generate unstructured grid data.

Date:
2002/01/22 15:28:15
Revision:
1.35

vtkUnstructuredGridSource is an abstract class whose subclasses generate unstructured grid data.

See also:
vtkUnstructuredGridReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (57%)
  • Martin, Ken (31%)

Definition at line 42 of file vtkUnstructuredGridSource.h.

Constructor & Destructor Documentation

vtkUnstructuredGridSource::vtkUnstructuredGridSource ( ) [protected]

vtkUnstructuredGridSource::~vtkUnstructuredGridSource ( ) [inline, protected]

Definition at line 58 of file vtkUnstructuredGridSource.h.

Member Function Documentation

vtkUnstructuredGridSource* vtkUnstructuredGridSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkAppendFilter, vtkClipDataSet, vtkClipVolume, vtkConnectivityFilter, vtkDataSetTriangleFilter, vtkDelaunay3D, vtkExtractGeometry, vtkExtractUnstructuredGrid, vtkShrinkFilter, vtkSubdivideTetra, vtkThreshold, vtkExtractUnstructuredGridPiece, and vtkTransmitUnstructuredGridPiece.

vtkUnstructuredGridSource::vtkTypeRevisionMacro | ( | vtkUnstructuredGridSource | ,
 |  | vtkSource |
 | ) |

Reimplemented from vtkSource.

Reimplemented in vtkDataSetToUnstructuredGridFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkAppendFilter, vtkClipDataSet, vtkClipVolume, vtkConnectivityFilter, vtkDataSetTriangleFilter, vtkDelaunay3D, vtkExtractGeometry, vtkExtractUnstructuredGrid, vtkShrinkFilter, vtkSubdivideTetra, vtkThreshold, vtkExtractUnstructuredGridPiece, and vtkTransmitUnstructuredGridPiece.

vtkUnstructuredGrid* vtkUnstructuredGridSource::GetOutput ( )

Get the output of this source.

vtkUnstructuredGrid* vtkUnstructuredGridSource::GetOutput ( int idx ) [inline]

Get the output of this source.

Reimplemented from vtkSource.

Definition at line 51 of file vtkUnstructuredGridSource.h.

void vtkUnstructuredGridSource::SetOutput ( vtkUnstructuredGrid * output )

Get the output of this source.

void vtkUnstructuredGridSource::ComputeInputUpdateExtents ( vtkDataObject * out ) [protected, virtual]

What is the input update extent that is required to produce the desired output? By default, the whole input is always required but this is overridden in many subclasses.

Reimplemented from vtkSource.

Reimplemented in vtkStructuredPointsToUnstructuredGridFilter, vtkExtractUnstructuredGridPiece, and vtkTransmitUnstructuredGridPiece.

The documentation for this class was generated from the following file:
  • Filtering/vtkUnstructuredGridSource.h
Generated on Mon Mar 25 01:33:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridToPolyDataFilter Class Reference

abstract filter class. More...

#include <vtkUnstructuredGridToPolyDataFilter.h>

Inheritance diagram for vtkUnstructuredGridToPolyDataFilter:

[legend]
Collaboration diagram for vtkUnstructuredGridToPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGridToPolyDataFilter, vtkPolyDataSource)
virtual void | ComputeInputUpdateExtents (vtkDataObject *output)
virtual void | SetInput (vtkUnstructuredGrid *input)
vtkUnstructuredGrid * GetInput ()

Protected Methods

vtkUnstructuredGridToPolyDataFilter ()
~vtkUnstructuredGridToPolyDataFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:15
Revision:
1.6

vtkUnstructuredGridToPolyDataFilter is an abstract filter class whose subclasses take as input datasets of type vtkUnstructuredGrid and generate polygonal data on output.

See also:
vtkContourGrid
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (91%)
  • Law, Charles (5%)

Definition at line 43 of file vtkUnstructuredGridToPolyDataFilter.h.

Constructor & Destructor Documentation

vtkUnstructuredGridToPolyDataFilter::vtkUnstructuredGridToPolyDataFilter ( ) [inline, protected]

Definition at line 58 of file vtkUnstructuredGridToPolyDataFilter.h.

vtkUnstructuredGridToPolyDataFilter::~vtkUnstructuredGridToPolyDataFilter ( ) [inline, protected]

Definition at line 59 of file vtkUnstructuredGridToPolyDataFilter.h.

Member Function Documentation

vtkUnstructuredGridToPolyDataFilter::vtkTypeRevisionMacro | ( | vtkUnstructuredGridToPolyDataFilter | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

Reimplemented in vtkContourGrid.

virtual void vtkUnstructuredGridToPolyDataFilter::SetInput ( vtkUnstructuredGrid * input ) [virtual]

Set / get the input data or filter.

vtkUnstructuredGrid* vtkUnstructuredGridToPolyDataFilter::GetInput ( )

Set / get the input data or filter.

virtual void vtkUnstructuredGridToPolyDataFilter::ComputeInputUpdateExtents ( vtkDataObject * output ) [virtual]

Do not let datasets return more than requested.

Reimplemented from vtkPolyDataSource.

The documentation for this class was generated from the following file:
  • Filtering/vtkUnstructuredGridToPolyDataFilter.h
Generated on Mon Mar 25 01:33:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridToUnstructuredGridFilter Class Reference

abstract filter class. More...

#include <vtkUnstructuredGridToUnstructuredGridFilter.h>

Inheritance diagram for vtkUnstructuredGridToUnstructuredGridFilter:

[legend]
Collaboration diagram for vtkUnstructuredGridToUnstructuredGridFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGridToUnstructuredGridFilter, vtkUnstructuredGridSource)
void SetInput (vtkUnstructuredGrid *input)
vtkUnstructuredGrid * GetInput ()

Protected Methods

vtkUnstructuredGridToUnstructuredGridFilter ()
~vtkUnstructuredGridToUnstructuredGridFilter ()

Detailed Description

abstract filter class.

Date:
2002/01/22 15:28:16
Revision:
1.15

See also:
vtkExtractGrid
Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (83%)
  • Lorensen, Bill (13%)

Definition at line 39 of file vtkUnstructuredGridToUnstructuredGridFilter.h.

Constructor & Destructor Documentation

vtkUnstructuredGridToUnstructuredGridFilter::vtkUnstructuredGridToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 51 of file vtkUnstructuredGridToUnstructuredGridFilter.h.

vtkUnstructuredGridToUnstructuredGridFilter::~vtkUnstructuredGridToUnstructuredGridFilter ( ) [inline, protected]

Definition at line 52 of file vtkUnstructuredGridToUnstructuredGridFilter.h.

Member Function Documentation

vtkUnstructuredGridToUnstructuredGridFilter::vtkTypeRevisionMacro | ( | vtkUnstructuredGridToUnstructuredGridFilter | ,
 |  | vtkUnstructuredGridSource |
 | ) |

Reimplemented from vtkUnstructuredGridSource.

Reimplemented in vtkExtractUnstructuredGrid, vtkSubdivideTetra, vtkExtractUnstructuredGridPiece, and vtkTransmitUnstructuredGridPiece.

void vtkUnstructuredGridToUnstructuredGridFilter::SetInput ( vtkUnstructuredGrid * input )

Set / get the input Grid or filter.

vtkUnstructuredGrid* vtkUnstructuredGridToUnstructuredGridFilter::GetInput ( )

Set / get the input Grid or filter.

The documentation for this class was generated from the following file:
  • Filtering/vtkUnstructuredGridToUnstructuredGridFilter.h
Generated on Mon Mar 25 01:33:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkUnstructuredGridWriter Class Reference

write vtk unstructured grid data file. More...

#include <vtkUnstructuredGridWriter.h>

Inheritance diagram for vtkUnstructuredGridWriter:

[legend]
Collaboration diagram for vtkUnstructuredGridWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkUnstructuredGridWriter, vtkDataWriter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkUnstructuredGrid *input)
vtkUnstructuredGrid * GetInput ()

Static Public Methods

vtkUnstructuredGridWriter * | New ()

Protected Methods

vtkUnstructuredGridWriter ()
~vtkUnstructuredGridWriter ()
void | WriteData ()

Detailed Description

write vtk unstructured grid data file.

Date:
2002/01/22 15:38:25
Revision:
1.35

vtkUnstructuredGridWriter is a source object that writes ASCII or binary unstructured grid data files in vtk format. See text for format details.

Warning:
Binary files written on one system may not be readable on other systems.
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (72%)
  • Martin, Ken (12%)
  • Law, Charles (5%)

Definition at line 42 of file vtkUnstructuredGridWriter.h.

Constructor & Destructor Documentation

vtkUnstructuredGridWriter::vtkUnstructuredGridWriter ( ) [inline, protected]

Definition at line 56 of file vtkUnstructuredGridWriter.h.

vtkUnstructuredGridWriter::~vtkUnstructuredGridWriter ( ) [inline, protected]

Definition at line 57 of file vtkUnstructuredGridWriter.h.

Member Function Documentation

vtkUnstructuredGridWriter* vtkUnstructuredGridWriter::New ( ) [static]

Created object with default header, ASCII format, and default names for scalars, vectors, tensors, normals, and texture coordinates.

Reimplemented from vtkDataWriter.

vtkUnstructuredGridWriter::vtkTypeRevisionMacro | ( | vtkUnstructuredGridWriter | ,
 |  | vtkDataWriter |
 | ) |

Reimplemented from vtkDataWriter.

void vtkUnstructuredGridWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataWriter.

void vtkUnstructuredGridWriter::SetInput ( vtkUnstructuredGrid * input )

Specify the input data or filter.

vtkUnstructuredGrid* vtkUnstructuredGridWriter::GetInput ( )

Specify the input data or filter.

Reimplemented from vtkWriter.

void vtkUnstructuredGridWriter::WriteData ( ) [protected, virtual]

Reimplemented from vtkDataWriter.

The documentation for this class was generated from the following file:
  • IO/vtkUnstructuredGridWriter.h
Generated on Mon Mar 25 01:33:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorDot Class Reference

generate scalars from dot product of vectors and normals (e.g., show displacement plot). More...

#include <vtkVectorDot.h>

Inheritance diagram for vtkVectorDot:

[legend]
Collaboration diagram for vtkVectorDot:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVectorDot, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScalarRange (float, float)
void | SetScalarRange (float[2])
virtual float * | GetScalarRange ()
virtual void | GetScalarRange (float data[2])

Static Public Methods

vtkVectorDot * | New ()

Protected Methods

vtkVectorDot ()
~vtkVectorDot ()
void | Execute ()

Protected Attributes

float | ScalarRange [2]

Detailed Description

generate scalars from dot product of vectors and normals (e.g., show displacement plot).

Date:
2002/01/22 15:29:55
Revision:
1.31

vtkVectorDot is a filter to generate scalar values from a dataset. The scalar value at a point is created by computing the dot product between the normal and vector at that point. Combined with the appropriate color map, this can show nodal lines/mode shapes of vibration, or a displacement plot.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (65%)
  • Martin, Ken (10%)
  • Geveci, Berk (9%)
  • Lorensen, Bill (6%)
Tests:
vtkVectorDot (Tests)

Definition at line 46 of file vtkVectorDot.h.

Constructor & Destructor Documentation

vtkVectorDot::vtkVectorDot ( ) [protected]

vtkVectorDot::~vtkVectorDot ( ) [inline, protected]

Definition at line 67 of file vtkVectorDot.h.

Member Function Documentation

vtkVectorDot::vtkTypeRevisionMacro | ( | vtkVectorDot | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkVectorDot::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkVectorDot* vtkVectorDot::New ( ) [static]

Construct object with scalar range is (-1,1).

Reimplemented from vtkDataSetSource.

virtual void vtkVectorDot::SetScalarRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify range to map scalars into.

void vtkVectorDot::SetScalarRange ( float [2] )

Specify range to map scalars into.

virtual float* vtkVectorDot::GetScalarRange ( ) [virtual]

Get the range that scalars map into.

virtual void vtkVectorDot::GetScalarRange ( float data[2] ) [virtual]

Get the range that scalars map into.

void vtkVectorDot::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkVectorDot::ScalarRange[2] [protected]

Definition at line 70 of file vtkVectorDot.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkVectorDot.h
Generated on Mon Mar 25 01:33:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorNorm Class Reference

generate scalars from Euclidean norm of vectors. More...

#include <vtkVectorNorm.h>

Inheritance diagram for vtkVectorNorm:

[legend]
Collaboration diagram for vtkVectorNorm:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVectorNorm, vtkDataSetToDataSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNormalize (int)
virtual int | GetNormalize ()
virtual void | NormalizeOn ()
virtual void | NormalizeOff ()
virtual void | SetAttributeMode (int)
virtual int | GetAttributeMode ()
void | SetAttributeModeToDefault ()
void | SetAttributeModeToUsePointData ()
void | SetAttributeModeToUseCellData ()
const char * | GetAttributeModeAsString ()

Static Public Methods

vtkVectorNorm * | New ()

Protected Methods

vtkVectorNorm ()
~vtkVectorNorm ()
void | Execute ()

Protected Attributes

int | Normalize
int | AttributeMode

Detailed Description

generate scalars from Euclidean norm of vectors.

Date:
2002/01/22 15:29:55
Revision:
1.35

vtkVectorNorm is a filter that generates scalar values by computing Euclidean norm of vector triplets. Scalars can be normalized 0<=s<=1 if desired.

Note that this filter operates on point or cell attribute data, or both. By default, the filter operates on both point and cell data if vector point and cell data, respectively, are available from the input. Alternatively, you can choose to generate scalar norm values for just cell or point data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (71%)
  • Geveci, Berk (9%)
  • Martin, Ken (9%)
Tests:
vtkVectorNorm (Tests)

Definition at line 53 of file vtkVectorNorm.h.

Constructor & Destructor Documentation

vtkVectorNorm::vtkVectorNorm ( ) [protected]

vtkVectorNorm::~vtkVectorNorm ( ) [inline, protected]

Definition at line 89 of file vtkVectorNorm.h.

Member Function Documentation

vtkVectorNorm::vtkTypeRevisionMacro | ( | vtkVectorNorm | ,
 |  | vtkDataSetToDataSetFilter |
 | ) |

Reimplemented from vtkDataSetToDataSetFilter.

void vtkVectorNorm::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkVectorNorm* vtkVectorNorm::New ( ) [static]

Construct with normalize flag off.

Reimplemented from vtkDataSetSource.

virtual void vtkVectorNorm::SetNormalize ( int ) [virtual]

Specify whether to normalize scalar values.

virtual int vtkVectorNorm::GetNormalize ( ) [virtual]

Specify whether to normalize scalar values.

virtual void vtkVectorNorm::NormalizeOn ( ) [virtual]

Specify whether to normalize scalar values.

virtual void vtkVectorNorm::NormalizeOff ( ) [virtual]

Specify whether to normalize scalar values.

virtual void vtkVectorNorm::SetAttributeMode ( int ) [virtual]

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

virtual int vtkVectorNorm::GetAttributeMode ( ) [virtual]

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

void vtkVectorNorm::SetAttributeModeToDefault ( ) [inline]

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 78 of file vtkVectorNorm.h.

void vtkVectorNorm::SetAttributeModeToUsePointData ( ) [inline]

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 80 of file vtkVectorNorm.h.

void vtkVectorNorm::SetAttributeModeToUseCellData ( ) [inline]

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

Definition at line 82 of file vtkVectorNorm.h.

const char* vtkVectorNorm::GetAttributeModeAsString ( )

Control how the filter works to generate scalar data from the input vector data. By default, (AttributeModeToDefault) the filter will generate the scalar norm for point and cell data (if vector data present in the input). Alternatively, you can explicitly set the filter to generate point data (AttributeModeToUsePointData) or cell data (AttributeModeToUseCellData).

void vtkVectorNorm::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkVectorNorm::Normalize [protected]

Definition at line 93 of file vtkVectorNorm.h.

int vtkVectorNorm::AttributeMode [protected]

Definition at line 94 of file vtkVectorNorm.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkVectorNorm.h
Generated on Mon Mar 25 01:33:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVectorText Class Reference

create polygonal text. More...

#include <vtkVectorText.h>

Inheritance diagram for vtkVectorText:

[legend]
Collaboration diagram for vtkVectorText:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVectorText, vtkPolyDataSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetText (const char *)
virtual char * | GetText ()

Static Public Methods

vtkVectorText * | New ()

Protected Methods

vtkVectorText ()
~vtkVectorText ()
void | Execute ()

Protected Attributes

char * | Text
char * | Letters [127]

Detailed Description

create polygonal text.

Date:
2002/01/22 15:30:43
Revision:
1.31

vtkVectorText generates vtkPolyData from an input text string. Besides the ASCII alphanumeric characters a-z, A-Z, 0-9, vtkVectorText also supports ASCII punctuation marks. (The supported ASCII character set are the codes (33-126) inclusive.) The only control character supported is the line feed character "
", which advances to a new line.

To use thie class, you normally couple it with a vtkPolyDataMapper and a vtkActor. In this case you would use the vtkActor's transformation methods to position, orient, and scale the text. You may also wish to use a vtkFollower to orient the text so that it always faces the camera.

See also:
vtkTextMapper vtkCaptionActor2D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (99%)
Examples:
vtkVectorText (Examples)
Tests:
vtkVectorText (Tests)

Definition at line 55 of file vtkVectorText.h.

Constructor & Destructor Documentation

vtkVectorText::vtkVectorText ( ) [protected]

vtkVectorText::~vtkVectorText ( ) [protected]

Member Function Documentation

vtkVectorText* vtkVectorText::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkVectorText::vtkTypeRevisionMacro | ( | vtkVectorText | ,
 |  | vtkPolyDataSource |
 | ) |

Reimplemented from vtkPolyDataSource.

void vtkVectorText::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkVectorText::SetText ( const char * ) [virtual]

Set/Get the text to be drawn.

virtual char* vtkVectorText::GetText ( ) [virtual]

Set/Get the text to be drawn.

void vtkVectorText::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

char* vtkVectorText::Text [protected]

Definition at line 73 of file vtkVectorText.h.

char* vtkVectorText::Letters[127] [protected]

Definition at line 74 of file vtkVectorText.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkVectorText.h
Generated on Mon Mar 25 01:33:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


TemplateVectorType class Reference

VectorType Class Template Reference

#include <vtkVRML.h>

Inheritance diagram for VectorType:

[legend]
Collaboration diagram for VectorType:

[legend]
List of all members.

Public Methods

void | Init ()
VectorType ()
VectorType (int usenew)
~VectorType (void)
void | Reserve (int newSize)
void | Demand (int newSize)
int | Count (void) const
T & | Get (int index) const
T & | operator[] (int index)
operator T * () const
VectorType< T > & | operator+= (T datum)
void | Push (T datum)
T & | Pop ()
T & | Top ()
void * | operator new (size_t n)
void | operator delete (void *)

Public Attributes

int | UseNew

Protected Attributes

T * | Data
int | Allocated
int | Used

template<class T>
class VectorType< T >

Constructor & Destructor Documentation

template<class T>
VectorType< T >::VectorType ( ) [inline]

Definition at line 99 of file vtkVRML.h.

template<class T>
VectorType< T >::VectorType ( int usenew ) [inline]

Definition at line 104 of file vtkVRML.h.

template<class T>
VectorType< T >::~VectorType ( void ) [inline]

Definition at line 108 of file vtkVRML.h.

Member Function Documentation

template<class T>
void VectorType< T >::Init ( ) [inline]

Definition at line 84 of file vtkVRML.h.

template<class T>
void VectorType< T >::Reserve ( int newSize ) [inline]

Definition at line 115 of file vtkVRML.h.

template<class T>
void VectorType< T >::Demand ( int newSize ) [inline]

Definition at line 145 of file vtkVRML.h.

template<class T>
int VectorType< T >::Count ( void ) const [inline]

Definition at line 150 of file vtkVRML.h.

template<class T>
T& VectorType< T >::Get ( int index ) const [inline]

Definition at line 154 of file vtkVRML.h.

template<class T>
T& VectorType< T >::operator[] ( int index ) [inline]

Definition at line 160 of file vtkVRML.h.

template<class T>
VectorType< T >::operator T * ( ) const [inline]

Definition at line 166 of file vtkVRML.h.

template<class T>
VectorType<T>& VectorType< T >::operator+= ( T datum ) [inline]

Definition at line 170 of file vtkVRML.h.

template<class T>
void VectorType< T >::Push ( T datum ) [inline]

Definition at line 177 of file vtkVRML.h.

template<class T>
T& VectorType< T >::Pop ( ) [inline]

Definition at line 183 of file vtkVRML.h.

template<class T>
T& VectorType< T >::Top ( ) [inline]

Definition at line 188 of file vtkVRML.h.

template<class T>
void* VectorType< T >::operator new ( size_t n ) [inline]

Definition at line 193 of file vtkVRML.h.

template<class T>
void VectorType< T >::operator delete ( void * ) [inline]

Definition at line 198 of file vtkVRML.h.

Member Data Documentation

template<class T>
T* VectorType::Data [protected]

Definition at line 80 of file vtkVRML.h.

template<class T>
int VectorType::Allocated [protected]

Definition at line 81 of file vtkVRML.h.

template<class T>
int VectorType::Used [protected]

Definition at line 82 of file vtkVRML.h.

template<class T>
int VectorType::UseNew

Definition at line 202 of file vtkVRML.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkVRML.h
Generated on Mon Mar 25 01:33:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVersion Class Reference

Versioning class for vtk. More...

#include <vtkVersion.h>

Inheritance diagram for vtkVersion:

[legend]
Collaboration diagram for vtkVersion:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVersion, vtkObject)

Static Public Methods

vtkVersion * | New ()
const char * | GetVTKVersion ()
int | GetVTKMajorVersion ()
int | GetVTKMinorVersion ()
int | GetVTKBuildVersion ()
const char * | GetVTKSourceVersion ()

Protected Methods

vtkVersion ()
~vtkVersion ()

Detailed Description

Versioning class for vtk.

Date:
2002/03/25 03:45:02
Revision:
1.1187

Holds methods for defining/determining the current vtk version (major, minor, build).

Warning:
This file will change frequently to update the VTKSourceVersion which timestamps a particular source release.

Definition at line 43 of file vtkVersion.h.

Constructor & Destructor Documentation

vtkVersion::vtkVersion ( ) [inline, protected]

Definition at line 61 of file vtkVersion.h.

vtkVersion::~vtkVersion ( ) [inline, protected]

Definition at line 62 of file vtkVersion.h.

Member Function Documentation

vtkVersion* vtkVersion::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVersion::vtkTypeRevisionMacro | ( | vtkVersion | ,
 |  | vtkObject |
 | ) |

const char* vtkVersion::GetVTKVersion ( ) [inline, static]

Return the version of vtk this object is a part of. A variety of methods are included. GetVTKSourceVersion returns a string with an identifier which timestamps a particular source tree.

Definition at line 53 of file vtkVersion.h.

int vtkVersion::GetVTKMajorVersion ( ) [inline, static]

Return the version of vtk this object is a part of. A variety of methods are included. GetVTKSourceVersion returns a string with an identifier which timestamps a particular source tree.

Definition at line 54 of file vtkVersion.h.

int vtkVersion::GetVTKMinorVersion ( ) [inline, static]

Return the version of vtk this object is a part of. A variety of methods are included. GetVTKSourceVersion returns a string with an identifier which timestamps a particular source tree.

Definition at line 55 of file vtkVersion.h.

int vtkVersion::GetVTKBuildVersion ( ) [inline, static]

Return the version of vtk this object is a part of. A variety of methods are included. GetVTKSourceVersion returns a string with an identifier which timestamps a particular source tree.

Definition at line 56 of file vtkVersion.h.

const char* vtkVersion::GetVTKSourceVersion ( ) [inline, static]

Return the version of vtk this object is a part of. A variety of methods are included. GetVTKSourceVersion returns a string with an identifier which timestamps a particular source tree.

Definition at line 57 of file vtkVersion.h.

The documentation for this class was generated from the following file:
  • Common/vtkVersion.h
Generated on Mon Mar 25 01:33:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVertex Class Reference

a cell that represents a 3D point. More...

#include <vtkVertex.h>

Inheritance diagram for vtkVertex:

[legend]
Collaboration diagram for vtkVertex:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVertex, vtkCell)
vtkCell * MakeObject ()
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int)
vtkCell * | GetFace (int)
void | Clip (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *pts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts1, vtkCellArray *lines, vtkCellArray *verts2, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkVertex * | New ()
void | InterpolationFunctions (float pcoords[3], float weights[1])

Protected Methods

vtkVertex ()
~vtkVertex ()

Detailed Description

a cell that represents a 3D point.

Date:
2002/01/22 15:26:38
Revision:
1.59

vtkVertex is a concrete implementation of vtkCell to represent a 3D point.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (55%)
  • Martin, Ken (11%)
  • Geveci, Berk (7%)
  • Kelly, Ann (7%)
Examples:
vtkVertex (Examples)
Tests:
vtkVertex (Tests)

Definition at line 45 of file vtkVertex.h.

Constructor & Destructor Documentation

vtkVertex::vtkVertex ( ) [protected]

vtkVertex::~vtkVertex ( ) [inline, protected]

Definition at line 117 of file vtkVertex.h.

Member Function Documentation

vtkVertex* vtkVertex::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVertex::vtkTypeRevisionMacro | ( | vtkVertex | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell.

vtkCell* vtkVertex::MakeObject ( ) [virtual]

Make a new vtkVertex object with the same information as this object.

Reimplemented from vtkCell.

int vtkVertex::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 56 of file vtkVertex.h.

int vtkVertex::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 57 of file vtkVertex.h.

int vtkVertex::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 58 of file vtkVertex.h.

int vtkVertex::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 59 of file vtkVertex.h.

vtkCell* vtkVertex::GetEdge ( int edgeId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 60 of file vtkVertex.h.

vtkCell* vtkVertex::GetFace ( int faceId ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 61 of file vtkVertex.h.

void vtkVertex::Clip | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | pts,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd,
 |  | int | insideOut
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVertex::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkVertex::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVertex::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

Given parametric coordinates of a point, return the closest cell boundary, and whether the point is inside or outside of the cell. The cell boundary is defined by a list of points (pts) that specify a vertex (1D cell). If the return value of the method is != 0, then the point is inside the cell.

Reimplemented from vtkCell.

void vtkVertex::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts1,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | verts2,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

Generate contouring primitives. The scalar list cellScalars are scalar values at each cell point. The point locator is essentially a points list that merges points as they are inserted (i.e., prevents duplicates).

Reimplemented from vtkCell.

int vtkVertex::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

Intersect with a ray. Return parametric coordinates (both line and cell) and global intersection coordinates, given ray definition and tolerance. The method returns non-zero value if intersection occurs.

Reimplemented from vtkCell.

int vtkVertex::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

Triangulate the vertex. This method fills pts and ptIds with information from the only point in the vertex.

Reimplemented from vtkCell.

void vtkVertex::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

Get the derivative of the vertex. Returns (0.0, 0.0, 0.0) for all dimensions.

Reimplemented from vtkCell.

void vtkVertex::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[1]
 | ) | [static]

Vertex specific methods.

The documentation for this class was generated from the following file:
  • Common/vtkVertex.h
Generated on Mon Mar 25 01:33:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVertexArray Class Reference

#include <vtkDecimate.h>

Collaboration diagram for vtkVertexArray:

[legend]
List of all members.

Public Methods

vtkVertexArray (const vtkIdType sz)
~vtkVertexArray ()
vtkIdType GetNumberOfVertices ()
void | InsertNextVertex (vtkLocalVertex &v)
vtkLocalVertex & | GetVertex (vtkIdType i)
void | Reset ()

Public Attributes

vtkLocalVertex * Array
vtkIdType MaxId

Constructor & Destructor Documentation

vtkVertexArray::vtkVertexArray ( const vtkIdType sz ) [inline]

Definition at line 150 of file vtkDecimate.h.

vtkVertexArray::~vtkVertexArray ( ) [inline]

Definition at line 152 of file vtkDecimate.h.

Member Function Documentation

vtkIdType vtkVertexArray::GetNumberOfVertices ( ) [inline]

Definition at line 153 of file vtkDecimate.h.

void vtkVertexArray::InsertNextVertex ( vtkLocalVertex & v ) [inline]

Definition at line 154 of file vtkDecimate.h.

vtkLocalVertex& vtkVertexArray::GetVertex ( vtkIdType i ) [inline]

Definition at line 156 of file vtkDecimate.h.

void vtkVertexArray::Reset ( ) [inline]

Definition at line 157 of file vtkDecimate.h.

Member Data Documentation

vtkLocalVertex* vtkVertexArray::Array

Definition at line 159 of file vtkDecimate.h.

vtkIdType vtkVertexArray::MaxId

Definition at line 160 of file vtkDecimate.h.

The documentation for this class was generated from the following file:
  • Patented/vtkDecimate.h
Generated on Mon Mar 25 01:33:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVideoSource Class Reference

Superclass of video input devices for VTK. More...

#include <vtkVideoSource.h>

Inheritance diagram for vtkVideoSource:

[legend]
Collaboration diagram for vtkVideoSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVideoSource, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Record ()
virtual void | Play ()
virtual void | Stop ()
virtual void | Rewind ()
virtual void | FastForward ()
virtual void | Seek (int n)
virtual void | Grab ()
virtual void | ReleaseSystemResources ()
virtual void | InternalGrab ()
virtual int | GetRecording ()
virtual int | GetPlaying ()
virtual void | SetFrameSize (int x, int y, int z)
virtual void | SetFrameSize (int dim[3])
virtual int * | GetFrameSize ()
virtual void | GetFrameSize (int &, int &, int &)
virtual void | GetFrameSize (int[3])
virtual void | SetFrameRate (float rate)
virtual float | GetFrameRate ()
virtual void | SetOutputFormat (int format)
void | SetOutputFormatToLuminance ()
void | SetOutputFormatToRGB ()
void | SetOutputFormatToRGBA ()
virtual int | GetOutputFormat ()
virtual void | SetFrameBufferSize (int FrameBufferSize)
virtual int | GetFrameBufferSize ()
virtual void | SetNumberOfOutputFrames (int)
virtual int | GetNumberOfOutputFrames ()
virtual void | AutoAdvanceOn ()
virtual void | AutoAdvanceOff ()
virtual void | SetAutoAdvance (int)
virtual int | GetAutoAdvance ()
virtual void | SetClipRegion (int r[6])
virtual void | SetClipRegion (int x0, int x1, int y0, int y1, int z0, int z1)
virtual int * | GetClipRegion ()
virtual void | GetClipRegion (int &, int &, int &, int &, int &, int &)
virtual void | GetClipRegion (int[6])
virtual void | SetOutputWholeExtent (int, int, int, int, int, int)
virtual void | SetOutputWholeExtent (int[6])
virtual int * | GetOutputWholeExtent ()
virtual void | GetOutputWholeExtent (int &, int &, int &, int &, int &, int &)
virtual void | GetOutputWholeExtent (int[6])
virtual void | SetDataSpacing (float, float, float)
virtual void | SetDataSpacing (float[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float &, float &, float &)
virtual void | GetDataSpacing (float[3])
virtual void | SetDataOrigin (float, float, float)
virtual void | SetDataOrigin (float[3])
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float &, float &, float &)
virtual void | GetDataOrigin (float[3])
virtual void | SetOpacity (float)
virtual float | GetOpacity ()
virtual int | GetFrameCount ()
virtual void | SetFrameCount (int)
virtual int | GetFrameIndex ()
virtual double | GetFrameTimeStamp (int frame)
virtual double | GetFrameTimeStamp ()
virtual void | Initialize ()
virtual int | GetInitialized ()
void | SetStartTimeStamp (double t)
double | GetStartTimeStamp ()

Static Public Methods

vtkVideoSource * | New ()

Protected Methods

vtkVideoSource ()
~vtkVideoSource ()
void | ExecuteInformation ()
virtual void | UpdateFrameBuffer ()
virtual void | AdvanceFrameBuffer (int n)
virtual void | ExecuteData (vtkDataObject *data)
virtual void | UnpackRasterLine (char *outPtr, char *rowPtr, int start, int count)

Protected Attributes

int | Initialized
int | FrameSize [3]
int | ClipRegion [6]
int | OutputWholeExtent [6]
float | DataSpacing [3]
float | DataOrigin [3]
int | OutputFormat
int | NumberOfScalarComponents
int | FrameOutputExtent [6]
int | LastNumberOfScalarComponents
int | LastOutputExtent [6]
int | Recording
int | Playing
float | FrameRate
int | FrameCount
int | FrameIndex
double | StartTimeStamp
int | AutoAdvance
int | NumberOfOutputFrames
float | Opacity
int | FlipFrames
int | OutputNeedsInitialization
vtkMultiThreader * PlayerThreader
int | PlayerThreadId
vtkCriticalSection * FrameBufferMutex
int | FrameBufferBitsPerPixel
int | FrameBufferRowAlignment
int | FrameBufferExtent [6]
int | FrameBufferSize
int | FrameBufferIndex
void ** | FrameBuffer
double * | FrameBufferTimeStamps

Detailed Description

Superclass of video input devices for VTK.

Date:
2002/01/22 15:30:44
Revision:
1.22

vtkVideoSource is a superclass for video input interfaces for VTK. The goal is to provide an interface which is very similar to the interface of a VCR, where the 'tape' is an internal frame buffer capable of holding a preset number of video frames. Specialized versions of this class record input from various video input sources. This base class records input from a noise source.

See also:
vtkWin32VideoSource vtkMILVideoSource
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (94%)

Definition at line 48 of file vtkVideoSource.h.

Constructor & Destructor Documentation

vtkVideoSource::vtkVideoSource ( ) [protected]

vtkVideoSource::~vtkVideoSource ( ) [protected]

Member Function Documentation

vtkVideoSource* vtkVideoSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

vtkVideoSource::vtkTypeRevisionMacro | ( | vtkVideoSource | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

void vtkVideoSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::Record ( ) [virtual]

Record incoming video at the specified FrameRate. The recording continues indefinitely until Stop() is called.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::Play ( ) [virtual]

Play through the 'tape' sequentially at the specified frame rate. If you have just finished Recoding, you should call Rewind() first.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::Stop ( ) [virtual]

Stop recording or playing.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::Rewind ( ) [virtual]

Rewind to the frame with the earliest timestamp. Record operations will start on the following frame, therefore if you want to re-record over this frame you must call Seek(-1) before calling Grab() or Record().

virtual void vtkVideoSource::FastForward ( ) [virtual]

FastForward to the last frame that was recorded (i.e. to the frame that has the most recent timestamp).

virtual void vtkVideoSource::Seek ( int n ) [virtual]

Seek forwards or backwards by the specified number of frames (positive is forward, negative is backward).

virtual void vtkVideoSource::Grab ( ) [virtual]

Grab a single video frame.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual int vtkVideoSource::GetRecording ( ) [virtual]

Are we in record mode? (record mode and play mode are mutually exclusive).

virtual int vtkVideoSource::GetPlaying ( ) [virtual]

Are we in play mode? (record mode and play mode are mutually exclusive).

virtual void vtkVideoSource::SetFrameSize | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) | [virtual]

Set the full-frame size. This must be an allowed size for the device, the device may either refuse a request for an illegal frame size or automatically choose a new frame size. The default is usually 320x240x1, but can be device specific. The 'depth' should always be 1 (unless you have a device that can handle 3D acquisition).

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::SetFrameSize ( int dim[3] ) [inline, virtual]

Set the full-frame size. This must be an allowed size for the device, the device may either refuse a request for an illegal frame size or automatically choose a new frame size. The default is usually 320x240x1, but can be device specific. The 'depth' should always be 1 (unless you have a device that can handle 3D acquisition).

Definition at line 102 of file vtkVideoSource.h.

virtual int* vtkVideoSource::GetFrameSize ( ) [virtual]

Set the full-frame size. This must be an allowed size for the device, the device may either refuse a request for an illegal frame size or automatically choose a new frame size. The default is usually 320x240x1, but can be device specific. The 'depth' should always be 1 (unless you have a device that can handle 3D acquisition).

virtual void vtkVideoSource::GetFrameSize | ( | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the full-frame size. This must be an allowed size for the device, the device may either refuse a request for an illegal frame size or automatically choose a new frame size. The default is usually 320x240x1, but can be device specific. The 'depth' should always be 1 (unless you have a device that can handle 3D acquisition).

virtual void vtkVideoSource::GetFrameSize ( int [3] ) [virtual]

Set the full-frame size. This must be an allowed size for the device, the device may either refuse a request for an illegal frame size or automatically choose a new frame size. The default is usually 320x240x1, but can be device specific. The 'depth' should always be 1 (unless you have a device that can handle 3D acquisition).

virtual void vtkVideoSource::SetFrameRate ( float rate ) [virtual]

Request a particular frame rate (default 30 frames per second).

Reimplemented in vtkWin32VideoSource.

virtual float vtkVideoSource::GetFrameRate ( ) [virtual]

Request a particular frame rate (default 30 frames per second).

virtual void vtkVideoSource::SetOutputFormat ( int format ) [virtual]

Set the output format. This must be appropriate for device, usually only VTK_LUMINANCE, VTK_RGB, and VTK_RGBA are supported.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

void vtkVideoSource::SetOutputFormatToLuminance ( ) [inline]

Set the output format. This must be appropriate for device, usually only VTK_LUMINANCE, VTK_RGB, and VTK_RGBA are supported.

Definition at line 117 of file vtkVideoSource.h.

void vtkVideoSource::SetOutputFormatToRGB ( ) [inline]

Set the output format. This must be appropriate for device, usually only VTK_LUMINANCE, VTK_RGB, and VTK_RGBA are supported.

Definition at line 118 of file vtkVideoSource.h.

void vtkVideoSource::SetOutputFormatToRGBA ( ) [inline]

Set the output format. This must be appropriate for device, usually only VTK_LUMINANCE, VTK_RGB, and VTK_RGBA are supported.

Definition at line 119 of file vtkVideoSource.h.

virtual int vtkVideoSource::GetOutputFormat ( ) [virtual]

Set the output format. This must be appropriate for device, usually only VTK_LUMINANCE, VTK_RGB, and VTK_RGBA are supported.

virtual void vtkVideoSource::SetFrameBufferSize ( int FrameBufferSize ) [virtual]

Set size of the frame buffer, i.e. the number of frames that the 'tape' can store.

virtual int vtkVideoSource::GetFrameBufferSize ( ) [virtual]

Set size of the frame buffer, i.e. the number of frames that the 'tape' can store.

virtual void vtkVideoSource::SetNumberOfOutputFrames ( int ) [virtual]

Set the number of frames to copy to the output on each execute. The frames will be concatenated along the Z dimension, with the most recent frame first. Default: 1

virtual int vtkVideoSource::GetNumberOfOutputFrames ( ) [virtual]

Set the number of frames to copy to the output on each execute. The frames will be concatenated along the Z dimension, with the most recent frame first. Default: 1

virtual void vtkVideoSource::AutoAdvanceOn ( ) [virtual]

Set whether to automatically advance the buffer before each grab. Default: on

virtual void vtkVideoSource::AutoAdvanceOff ( ) [virtual]

Set whether to automatically advance the buffer before each grab. Default: on

virtual void vtkVideoSource::SetAutoAdvance ( int ) [virtual]

Set whether to automatically advance the buffer before each grab. Default: on

virtual int vtkVideoSource::GetAutoAdvance ( ) [virtual]

Set whether to automatically advance the buffer before each grab. Default: on

virtual void vtkVideoSource::SetClipRegion ( int r[6] ) [inline, virtual]

Set the clip rectangle for the frames. The video will be clipped before it is copied into the framebuffer. Changing the ClipRegion will destroy the current contents of the framebuffer. The default ClipRegion is (0,VTK_INT_MAX,0,VTK_INT_MAX,0,VTK_INT_MAX).

Definition at line 151 of file vtkVideoSource.h.

virtual void vtkVideoSource::SetClipRegion | ( | int | x0,
 |  | int | x1,
 |  | int | y0,
 |  | int | y1,
 |  | int | z0,
 |  | int | z1
 | ) | [virtual]

Set the clip rectangle for the frames. The video will be clipped before it is copied into the framebuffer. Changing the ClipRegion will destroy the current contents of the framebuffer. The default ClipRegion is (0,VTK_INT_MAX,0,VTK_INT_MAX,0,VTK_INT_MAX).

virtual int* vtkVideoSource::GetClipRegion ( ) [virtual]

Set the clip rectangle for the frames. The video will be clipped before it is copied into the framebuffer. Changing the ClipRegion will destroy the current contents of the framebuffer. The default ClipRegion is (0,VTK_INT_MAX,0,VTK_INT_MAX,0,VTK_INT_MAX).

virtual void vtkVideoSource::GetClipRegion | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Set the clip rectangle for the frames. The video will be clipped before it is copied into the framebuffer. Changing the ClipRegion will destroy the current contents of the framebuffer. The default ClipRegion is (0,VTK_INT_MAX,0,VTK_INT_MAX,0,VTK_INT_MAX).

virtual void vtkVideoSource::GetClipRegion ( int [6] ) [virtual]

Set the clip rectangle for the frames. The video will be clipped before it is copied into the framebuffer. Changing the ClipRegion will destroy the current contents of the framebuffer. The default ClipRegion is (0,VTK_INT_MAX,0,VTK_INT_MAX,0,VTK_INT_MAX).

virtual void vtkVideoSource::SetOutputWholeExtent | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Get/Set the WholeExtent of the output. This can be used to either clip or pad the video frame. This clipping/padding is done when the frame is copied to the output, and does not change the contents of the framebuffer. This is useful e.g. for expanding the output size to a power of two for texture mapping. The default is (0,-1,0,-1,0,-1) which causes the entire frame to be copied to the output.

virtual void vtkVideoSource::SetOutputWholeExtent ( int [6] ) [virtual]

Get/Set the WholeExtent of the output. This can be used to either clip or pad the video frame. This clipping/padding is done when the frame is copied to the output, and does not change the contents of the framebuffer. This is useful e.g. for expanding the output size to a power of two for texture mapping. The default is (0,-1,0,-1,0,-1) which causes the entire frame to be copied to the output.

virtual int* vtkVideoSource::GetOutputWholeExtent ( ) [virtual]

Get/Set the WholeExtent of the output. This can be used to either clip or pad the video frame. This clipping/padding is done when the frame is copied to the output, and does not change the contents of the framebuffer. This is useful e.g. for expanding the output size to a power of two for texture mapping. The default is (0,-1,0,-1,0,-1) which causes the entire frame to be copied to the output.

virtual void vtkVideoSource::GetOutputWholeExtent | ( | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & | ,
 |  | int & |
 | ) | [virtual]

Get/Set the WholeExtent of the output. This can be used to either clip or pad the video frame. This clipping/padding is done when the frame is copied to the output, and does not change the contents of the framebuffer. This is useful e.g. for expanding the output size to a power of two for texture mapping. The default is (0,-1,0,-1,0,-1) which causes the entire frame to be copied to the output.

virtual void vtkVideoSource::GetOutputWholeExtent ( int [6] ) [virtual]

Get/Set the WholeExtent of the output. This can be used to either clip or pad the video frame. This clipping/padding is done when the frame is copied to the output, and does not change the contents of the framebuffer. This is useful e.g. for expanding the output size to a power of two for texture mapping. The default is (0,-1,0,-1,0,-1) which causes the entire frame to be copied to the output.

virtual void vtkVideoSource::SetDataSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the pixel spacing. Default: (1.0,1.0,1.0)

virtual void vtkVideoSource::SetDataSpacing ( float [3] ) [virtual]

Set/Get the pixel spacing. Default: (1.0,1.0,1.0)

virtual float* vtkVideoSource::GetDataSpacing ( ) [virtual]

Set/Get the pixel spacing. Default: (1.0,1.0,1.0)

virtual void vtkVideoSource::GetDataSpacing | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the pixel spacing. Default: (1.0,1.0,1.0)

virtual void vtkVideoSource::GetDataSpacing ( float [3] ) [virtual]

Set/Get the pixel spacing. Default: (1.0,1.0,1.0)

virtual void vtkVideoSource::SetDataOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the coordinates of the lower, left corner of the frame. Default: (0.0,0.0,0.0)

virtual void vtkVideoSource::SetDataOrigin ( float [3] ) [virtual]

Set/Get the coordinates of the lower, left corner of the frame. Default: (0.0,0.0,0.0)

virtual float* vtkVideoSource::GetDataOrigin ( ) [virtual]

Set/Get the coordinates of the lower, left corner of the frame. Default: (0.0,0.0,0.0)

virtual void vtkVideoSource::GetDataOrigin | ( | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set/Get the coordinates of the lower, left corner of the frame. Default: (0.0,0.0,0.0)

virtual void vtkVideoSource::GetDataOrigin ( float [3] ) [virtual]

Set/Get the coordinates of the lower, left corner of the frame. Default: (0.0,0.0,0.0)

virtual void vtkVideoSource::SetOpacity ( float ) [virtual]

For RGBA output only (4 scalar components), set the opacity. This will not modify the existing contents of the framebuffer, only subsequently grabbed frames.

virtual float vtkVideoSource::GetOpacity ( ) [virtual]

For RGBA output only (4 scalar components), set the opacity. This will not modify the existing contents of the framebuffer, only subsequently grabbed frames.

virtual int vtkVideoSource::GetFrameCount ( ) [virtual]

This value is incremented each time a frame is grabbed. reset it to zero (or any other value) at any time.

virtual void vtkVideoSource::SetFrameCount ( int ) [virtual]

This value is incremented each time a frame is grabbed. reset it to zero (or any other value) at any time.

virtual int vtkVideoSource::GetFrameIndex ( ) [virtual]

Get the frame index relative to the 'beginning of the tape'. This value wraps back to zero if it increases past the FrameBufferSize.

virtual double vtkVideoSource::GetFrameTimeStamp ( int frame ) [virtual]

Get a time stamp in seconds (resolution of milliseconds) for a video frame. Time began on Jan 1, 1970. You can specify a number (negative or positive) to specify the position of the video frame relative to the current frame.

virtual double vtkVideoSource::GetFrameTimeStamp ( ) [inline, virtual]

Get a time stamp in seconds (resolution of milliseconds) for a video frame. Time began on Jan 1, 1970. You can specify a number (negative or positive) to specify the position of the video frame relative to the current frame.

Definition at line 209 of file vtkVideoSource.h.

virtual void vtkVideoSource::Initialize ( ) [virtual]

Initialize the hardware. This is called automatically on the first Update or Grab.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual int vtkVideoSource::GetInitialized ( ) [inline, virtual]

Initialize the hardware. This is called automatically on the first Update or Grab.

Definition at line 216 of file vtkVideoSource.h.

virtual void vtkVideoSource::ReleaseSystemResources ( ) [virtual]

Release the video driver. This is called automatically when the vtkVideoSource is destroyed.

Reimplemented in vtkMILVideoSource, and vtkWin32VideoSource.

virtual void vtkVideoSource::InternalGrab ( ) [virtual]

The internal function which actually does the grab. You will definitely want to override this if you develop a vtkVideoSource subclass.

Reimplemented in vtkMILVideoSource.

void vtkVideoSource::SetStartTimeStamp ( double t ) [inline]

And internal variable which marks the beginning of a Record session. These methods are for internal use only.

Definition at line 231 of file vtkVideoSource.h.

double vtkVideoSource::GetStartTimeStamp ( ) [inline]

And internal variable which marks the beginning of a Record session. These methods are for internal use only.

Definition at line 232 of file vtkVideoSource.h.

void vtkVideoSource::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

virtual void vtkVideoSource::UpdateFrameBuffer ( ) [protected, virtual]

These methods can be overridden in subclasses

virtual void vtkVideoSource::AdvanceFrameBuffer ( int n ) [protected, virtual]

These methods can be overridden in subclasses

virtual void vtkVideoSource::ExecuteData ( vtkDataObject * data ) [protected, virtual]

These methods can be overridden in subclasses

virtual void vtkVideoSource::UnpackRasterLine | ( | char * | outptr,
 |  | char * | inptr,
 |  | int | start,
 |  | int | count
 | ) | [protected, virtual]

These methods can be overridden in subclasses

Reimplemented in vtkWin32VideoSource.

Member Data Documentation

int vtkVideoSource::Initialized [protected]

Definition at line 240 of file vtkVideoSource.h.

int vtkVideoSource::FrameSize[3] [protected]

Definition at line 242 of file vtkVideoSource.h.

int vtkVideoSource::ClipRegion[6] [protected]

Definition at line 243 of file vtkVideoSource.h.

int vtkVideoSource::OutputWholeExtent[6] [protected]

Definition at line 244 of file vtkVideoSource.h.

float vtkVideoSource::DataSpacing[3] [protected]

Definition at line 245 of file vtkVideoSource.h.

float vtkVideoSource::DataOrigin[3] [protected]

Definition at line 246 of file vtkVideoSource.h.

int vtkVideoSource::OutputFormat [protected]

Definition at line 247 of file vtkVideoSource.h.

int vtkVideoSource::NumberOfScalarComponents [protected]

Definition at line 249 of file vtkVideoSource.h.

int vtkVideoSource::FrameOutputExtent[6] [protected]

Definition at line 252 of file vtkVideoSource.h.

int vtkVideoSource::LastNumberOfScalarComponents [protected]

Definition at line 256 of file vtkVideoSource.h.

int vtkVideoSource::LastOutputExtent[6] [protected]

Definition at line 257 of file vtkVideoSource.h.

int vtkVideoSource::Recording [protected]

Definition at line 259 of file vtkVideoSource.h.

int vtkVideoSource::Playing [protected]

Definition at line 260 of file vtkVideoSource.h.

float vtkVideoSource::FrameRate [protected]

Definition at line 261 of file vtkVideoSource.h.

int vtkVideoSource::FrameCount [protected]

Definition at line 262 of file vtkVideoSource.h.

int vtkVideoSource::FrameIndex [protected]

Definition at line 263 of file vtkVideoSource.h.

double vtkVideoSource::StartTimeStamp [protected]

Definition at line 264 of file vtkVideoSource.h.

int vtkVideoSource::AutoAdvance [protected]

Definition at line 266 of file vtkVideoSource.h.

int vtkVideoSource::NumberOfOutputFrames [protected]

Definition at line 267 of file vtkVideoSource.h.

float vtkVideoSource::Opacity [protected]

Definition at line 269 of file vtkVideoSource.h.

int vtkVideoSource::FlipFrames [protected]

Definition at line 272 of file vtkVideoSource.h.

int vtkVideoSource::OutputNeedsInitialization [protected]

Definition at line 275 of file vtkVideoSource.h.

vtkMultiThreader* vtkVideoSource::PlayerThreader [protected]

Definition at line 278 of file vtkVideoSource.h.

int vtkVideoSource::PlayerThreadId [protected]

Definition at line 279 of file vtkVideoSource.h.

vtkCriticalSection* vtkVideoSource::FrameBufferMutex [protected]

Definition at line 283 of file vtkVideoSource.h.

int vtkVideoSource::FrameBufferBitsPerPixel [protected]

Definition at line 287 of file vtkVideoSource.h.

int vtkVideoSource::FrameBufferRowAlignment [protected]

Definition at line 289 of file vtkVideoSource.h.

int vtkVideoSource::FrameBufferExtent[6] [protected]

Definition at line 292 of file vtkVideoSource.h.

int vtkVideoSource::FrameBufferSize [protected]

Definition at line 294 of file vtkVideoSource.h.

int vtkVideoSource::FrameBufferIndex [protected]

Definition at line 295 of file vtkVideoSource.h.

void** vtkVideoSource::FrameBuffer [protected]

Definition at line 296 of file vtkVideoSource.h.

double* vtkVideoSource::FrameBufferTimeStamps [protected]

Definition at line 297 of file vtkVideoSource.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkVideoSource.h
Generated on Mon Mar 25 01:33:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkViewport Class Reference

abstract specification for Viewports. More...

#include <vtkViewport.h>

Inheritance diagram for vtkViewport:

[legend]
Collaboration diagram for vtkViewport:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkViewport, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
void | AddProp (vtkProp *)
vtkPropCollection * GetProps ()
void | RemoveProp (vtkProp *)
void | RemoveAllProps (void)
virtual float * | GetCenter ()
virtual int | IsInViewport (int x, int y)
virtual vtkWindow * | GetVTKWindow ()=0
void | SetStartRenderMethod (void(*f)(void *), void *arg)
void | SetEndRenderMethod (void(*f)(void *), void *arg)
void | SetStartRenderMethodArgDelete (void(*f)(void *))
void | SetEndRenderMethodArgDelete (void(*f)(void *))
virtual void | DisplayToView ()
virtual void | ViewToDisplay ()
virtual void | WorldToView ()
virtual void | ViewToWorld ()
void | DisplayToWorld ()
void | WorldToDisplay ()
virtual vtkAssemblyPath * | PickProp (float selectionX, float selectionY)=0
virtual float | GetPickedZ ()=0
void | AddActor2D (vtkProp *p)
void | RemoveActor2D (vtkProp *p)
vtkActor2DCollection * GetActors2D ()
virtual void | SetBackground (float, float, float)
virtual void | SetBackground (float[3])
virtual float * | GetBackground ()
virtual void | GetBackground (float data[3])
virtual void | SetAspect (float, float)
void | SetAspect (float[2])
virtual float * | GetAspect ()
virtual void | GetAspect (float data[2])
void | ComputeAspect ()
virtual void | SetPixelAspect (float, float)
void | SetPixelAspect (float[2])
virtual float * | GetPixelAspect ()
virtual void | GetPixelAspect (float data[2])
virtual void | SetViewport (float, float, float, float)
virtual void | SetViewport (float[4])
virtual float * | GetViewport ()
virtual void | GetViewport (float data[4])
virtual void | SetDisplayPoint (float, float, float)
virtual void | SetDisplayPoint (float[3])
virtual float * | GetDisplayPoint ()
virtual void | GetDisplayPoint (float data[3])
void | GetDisplayPoint (double *a)
virtual void | SetViewPoint (float, float, float)
virtual void | SetViewPoint (float[3])
virtual float * | GetViewPoint ()
virtual void | GetViewPoint (float data[3])
virtual void | SetWorldPoint (float, float, float, float)
virtual void | SetWorldPoint (float[4])
virtual float * | GetWorldPoint ()
virtual void | GetWorldPoint (float data[4])
void | GetWorldPoint (double *a)
virtual void | LocalDisplayToDisplay (float &x, float &y)
virtual void | DisplayToNormalizedDisplay (float &u, float &v)
virtual void | NormalizedDisplayToViewport (float &x, float &y)
virtual void | ViewportToNormalizedViewport (float &u, float &v)
virtual void | NormalizedViewportToView (float &x, float &y, float &z)
virtual void | ViewToWorld (float &, float &, float &)
virtual void | DisplayToLocalDisplay (float &x, float &y)
virtual void | NormalizedDisplayToDisplay (float &u, float &v)
virtual void | ViewportToNormalizedDisplay (float &x, float &y)
virtual void | NormalizedViewportToViewport (float &u, float &v)
virtual void | ViewToNormalizedViewport (float &x, float &y, float &z)
virtual void | WorldToView (float &, float &, float &)
int * | GetSize ()
int * | GetOrigin ()
void | GetTiledSize (int *width, int *height)
vtkAssemblyPath * | PickPropFrom (float selectionX, float selectionY, vtkPropCollection *)
virtual float | GetPickX ()
virtual float | GetPickY ()
virtual int | GetIsPicking ()

Protected Methods

vtkViewport ()
~vtkViewport ()
virtual void | DevicePickRender ()=0
virtual void | StartPick (unsigned int pickFromSize)=0
virtual void | UpdatePickId ()=0
virtual void | DonePick ()=0
virtual unsigned int | GetPickedId ()=0

Protected Attributes

vtkAssemblyPath * PickedProp
vtkPropCollection * PickFromProps
int | IsPicking
unsigned int | CurrentPickId
float | PickX
float | PickY
vtkPropCollection * Props
vtkActor2DCollection * Actors2D
vtkWindow * VTKWindow
float | Background [3]
float | Viewport [4]
float | Aspect [2]
float | PixelAspect [2]
float | Center [2]
unsigned long | StartTag
unsigned long | EndTag
int | Size [2]
int | Origin [2]
float | DisplayPoint [3]
float | ViewPoint [3]
float | WorldPoint [4]

Detailed Description

abstract specification for Viewports.

Date:
2002/03/05 20:16:08
Revision:
1.38

vtkViewport provides an abstract specification for Viewports. A Viewport is an object that controls the rendering process for objects. Rendering is the process of converting geometry, a specification for lights, and a camera view into an image. vtkViewport also performs coordinate transformation between world coordinates, view coordinates (the computer graphics rendering coordinate system), and display coordinates (the actual screen coordinates on the display device). Certain advanced rendering features such as two-sided lighting can also be controlled.

See also:
vtkWindow vtkImager vtkRenderer
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (51%)
  • Schroeder, Will (20%)
  • Turek, Matt (8%)
Tests:
vtkViewport (Tests)

Definition at line 56 of file vtkViewport.h.

Constructor & Destructor Documentation

vtkViewport::vtkViewport ( ) [protected]

vtkViewport::~vtkViewport ( ) [protected]

Member Function Documentation

vtkViewport::vtkTypeRevisionMacro | ( | vtkViewport | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkImager, vtkMesaImager, vtkMesaRenderer, vtkOpenGLImager, vtkOpenGLRenderer, and vtkRenderer.

void vtkViewport::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkMesaRenderer, vtkOpenGLRenderer, and vtkRenderer.

void vtkViewport::AddProp ( vtkProp * )

Add a prop to the list of props. Prop is the superclass of all actors, volumes, 2D actors, composite props etc.

Referenced by vtkRenderer::AddActor(), and vtkRenderer::AddVolume().

vtkPropCollection* vtkViewport::GetProps ( ) [inline]

Return any props in this viewport.

Definition at line 67 of file vtkViewport.h.

void vtkViewport::RemoveProp ( vtkProp * )

Remove an actor from the list of actors.

Referenced by vtkRenderer::RemoveActor(), and vtkRenderer::RemoveVolume().

void vtkViewport::RemoveAllProps ( void )

Remove all actors from the list of actors.

void vtkViewport::AddActor2D ( vtkProp * p ) [inline]

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

Definition at line 79 of file vtkViewport.h.

void vtkViewport::RemoveActor2D ( vtkProp * p )

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

vtkActor2DCollection* vtkViewport::GetActors2D ( )

Add/Remove different types of props to the renderer. These methods are all synonyms to AddProp and RemoveProp. They are here for convenience and backwards compatibility.

virtual void vtkViewport::SetBackground | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the background color of the rendering screen using an rgb color specification.

virtual void vtkViewport::SetBackground ( float [3] ) [virtual]

Set/Get the background color of the rendering screen using an rgb color specification.

virtual float* vtkViewport::GetBackground ( ) [virtual]

Set/Get the background color of the rendering screen using an rgb color specification.

virtual void vtkViewport::GetBackground ( float data[3] ) [virtual]

Set/Get the background color of the rendering screen using an rgb color specification.

virtual void vtkViewport::SetAspect | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the aspect ratio of the rendered image. This is computed automatically and should not be set by the user.

void vtkViewport::SetAspect ( float [2] )

Set the aspect ratio of the rendered image. This is computed automatically and should not be set by the user.

virtual float* vtkViewport::GetAspect ( ) [virtual]

Set the aspect ratio of the rendered image. This is computed automatically and should not be set by the user.

virtual void vtkViewport::GetAspect ( float data[2] ) [virtual]

Set the aspect ratio of the rendered image. This is computed automatically and should not be set by the user.

void vtkViewport::ComputeAspect ( )

Set the aspect ratio of the rendered image. This is computed automatically and should not be set by the user.

virtual void vtkViewport::SetPixelAspect | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the aspect ratio of a pixel in the rendered image. This factor permits the image to rendered anisotropically (i.e., stretched in one direction or the other).

void vtkViewport::SetPixelAspect ( float [2] )

Set the aspect ratio of a pixel in the rendered image. This factor permits the image to rendered anisotropically (i.e., stretched in one direction or the other).

virtual float* vtkViewport::GetPixelAspect ( ) [virtual]

Set the aspect ratio of a pixel in the rendered image. This factor permits the image to rendered anisotropically (i.e., stretched in one direction or the other).

virtual void vtkViewport::GetPixelAspect ( float data[2] ) [virtual]

Set the aspect ratio of a pixel in the rendered image. This factor permits the image to rendered anisotropically (i.e., stretched in one direction or the other).

virtual void vtkViewport::SetViewport | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the viewport for the Viewport to draw in the rendering window. Coordinates are expressed as (xmin,ymin,xmax,ymax), where each coordinate is 0 <= coordinate <= 1.0.

virtual void vtkViewport::SetViewport ( float [4] ) [virtual]

Specify the viewport for the Viewport to draw in the rendering window. Coordinates are expressed as (xmin,ymin,xmax,ymax), where each coordinate is 0 <= coordinate <= 1.0.

virtual float* vtkViewport::GetViewport ( ) [virtual]

Specify the viewport for the Viewport to draw in the rendering window. Coordinates are expressed as (xmin,ymin,xmax,ymax), where each coordinate is 0 <= coordinate <= 1.0.

virtual void vtkViewport::GetViewport ( float data[4] ) [virtual]

Specify the viewport for the Viewport to draw in the rendering window. Coordinates are expressed as (xmin,ymin,xmax,ymax), where each coordinate is 0 <= coordinate <= 1.0.

virtual void vtkViewport::SetDisplayPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/get a point location in display (or screen) coordinates. The lower left corner of the window is the origin and y increases as you go up the screen.

virtual void vtkViewport::SetDisplayPoint ( float [3] ) [virtual]

Set/get a point location in display (or screen) coordinates. The lower left corner of the window is the origin and y increases as you go up the screen.

virtual float* vtkViewport::GetDisplayPoint ( ) [virtual]

Set/get a point location in display (or screen) coordinates. The lower left corner of the window is the origin and y increases as you go up the screen.

virtual void vtkViewport::GetDisplayPoint ( float data[3] ) [virtual]

Set/get a point location in display (or screen) coordinates. The lower left corner of the window is the origin and y increases as you go up the screen.

void vtkViewport::GetDisplayPoint ( double * a ) [inline]

Set/get a point location in display (or screen) coordinates. The lower left corner of the window is the origin and y increases as you go up the screen.

Definition at line 121 of file vtkViewport.h.

virtual void vtkViewport::SetViewPoint | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point location in view coordinates. The origin is in the middle of the viewport and it extends from -1 to 1 in all three dimensions.

virtual void vtkViewport::SetViewPoint ( float [3] ) [virtual]

Specify a point location in view coordinates. The origin is in the middle of the viewport and it extends from -1 to 1 in all three dimensions.

virtual float* vtkViewport::GetViewPoint ( ) [virtual]

Specify a point location in view coordinates. The origin is in the middle of the viewport and it extends from -1 to 1 in all three dimensions.

virtual void vtkViewport::GetViewPoint ( float data[3] ) [virtual]

Specify a point location in view coordinates. The origin is in the middle of the viewport and it extends from -1 to 1 in all three dimensions.

virtual void vtkViewport::SetWorldPoint | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify a point location in world coordinates. This method takes homogeneous coordinates.

virtual void vtkViewport::SetWorldPoint ( float [4] ) [virtual]

Specify a point location in world coordinates. This method takes homogeneous coordinates.

virtual float* vtkViewport::GetWorldPoint ( ) [virtual]

Specify a point location in world coordinates. This method takes homogeneous coordinates.

virtual void vtkViewport::GetWorldPoint ( float data[4] ) [virtual]

Specify a point location in world coordinates. This method takes homogeneous coordinates.

void vtkViewport::GetWorldPoint ( double * a ) [inline]

Specify a point location in world coordinates. This method takes homogeneous coordinates.

Definition at line 143 of file vtkViewport.h.

virtual float* vtkViewport::GetCenter ( ) [virtual]

Return the center of this viewport in display coordinates.

virtual int vtkViewport::IsInViewport | ( | int | x,
 |  | int | y
 | ) | [virtual]

Is a given display point in this Viewport's viewport.

virtual vtkWindow* vtkViewport::GetVTKWindow ( ) [pure virtual]

Return the vtkWindow that owns this vtkViewport.

Reimplemented in vtkImager, and vtkRenderer.

void vtkViewport::SetStartRenderMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a function to be called before rendering process begins. Function will be called with argument provided.

void vtkViewport::SetEndRenderMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) |

Specify a function to be called when rendering process completes. Function will be called with argument provided.

void vtkViewport::SetStartRenderMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

void vtkViewport::SetEndRenderMethodArgDelete ( void(* f)(void *) )

Set the arg delete method. This is used to free user memory.

virtual void vtkViewport::DisplayToView ( ) [virtual]

Convert display coordinates to view coordinates.

virtual void vtkViewport::ViewToDisplay ( ) [virtual]

Convert view coordinates to display coordinates.

virtual void vtkViewport::WorldToView ( ) [virtual]

Convert world point coordinates to view coordinates.

Reimplemented in vtkRenderer.

virtual void vtkViewport::ViewToWorld ( ) [virtual]

Convert view point coordinates to world coordinates.

Reimplemented in vtkRenderer.

void vtkViewport::DisplayToWorld ( ) [inline]

Convert display (or screen) coordinates to world coordinates.

Definition at line 188 of file vtkViewport.h.

void vtkViewport::WorldToDisplay ( ) [inline]

Convert world point coordinates to display (or screen) coordinates.

Definition at line 191 of file vtkViewport.h.

virtual void vtkViewport::LocalDisplayToDisplay | ( | float & | x,
 |  | float & | y
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::DisplayToNormalizedDisplay | ( | float & | u,
 |  | float & | v
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::NormalizedDisplayToViewport | ( | float & | x,
 |  | float & | y
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::ViewportToNormalizedViewport | ( | float & | u,
 |  | float & | v
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::NormalizedViewportToView | ( | float & | x,
 |  | float & | y,
 |  | float & | z
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::ViewToWorld | ( | float & | wx,
 |  | float & | wy,
 |  | float & | wz
 | ) | [inline, virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

Reimplemented in vtkRenderer.

Definition at line 204 of file vtkViewport.h.

virtual void vtkViewport::DisplayToLocalDisplay | ( | float & | x,
 |  | float & | y
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::NormalizedDisplayToDisplay | ( | float & | u,
 |  | float & | v
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::ViewportToNormalizedDisplay | ( | float & | x,
 |  | float & | y
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::NormalizedViewportToViewport | ( | float & | u,
 |  | float & | v
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::ViewToNormalizedViewport | ( | float & | x,
 |  | float & | y,
 |  | float & | z
 | ) | [virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

virtual void vtkViewport::WorldToView | ( | float & | wx,
 |  | float & | wy,
 |  | float & | wz
 | ) | [inline, virtual]

These methods map from one coordinate system to another. They are primarily used by the vtkCoordinate object and are often strung together. These methods return valid information only if the window has been realized (e.g., GetSize() returns something other than (0,0)).

Reimplemented in vtkRenderer.

Definition at line 210 of file vtkViewport.h.

int* vtkViewport::GetSize ( )

Get the size and origin of the viewport in display coordinates. Note: if the window has not yet been realized, GetSize() and GetOrigin() return (0,0).

int* vtkViewport::GetOrigin ( )

Get the size and origin of the viewport in display coordinates. Note: if the window has not yet been realized, GetSize() and GetOrigin() return (0,0).

void vtkViewport::GetTiledSize | ( | int * | width,
 |  | int * | height
 | ) |

Get the size and origin of the viewport in display coordinates. Note: if the window has not yet been realized, GetSize() and GetOrigin() return (0,0).

virtual vtkAssemblyPath* vtkViewport::PickProp | ( | float | selectionX,
 |  | float | selectionY
 | ) | [pure virtual]

Return the Prop that has the highest z value at the given x, y position in the viewport. Basically, the top most prop that renders the pixel at selectionX, selectionY will be returned. If no Props are there NULL is returned. This method selects from the Viewports Prop list.

Reimplemented in vtkImager, and vtkRenderer.

vtkAssemblyPath* vtkViewport::PickPropFrom | ( | float | selectionX,
 |  | float | selectionY,
 |  | vtkPropCollection * |
 | ) |

Same as PickProp with two arguments, but selects from the given collection of Props instead of the Renderers props. Make sure the Props in the collection are in this renderer.

virtual float vtkViewport::GetPickX ( ) [virtual]

Methods used to return the pick (x,y) in local display coordinates (i.e., it's that same as selectionX and selectionY).

virtual float vtkViewport::GetPickY ( ) [virtual]

Methods used to return the pick (x,y) in local display coordinates (i.e., it's that same as selectionX and selectionY).

virtual int vtkViewport::GetIsPicking ( ) [virtual]

Methods used to return the pick (x,y) in local display coordinates (i.e., it's that same as selectionX and selectionY).

virtual float vtkViewport::GetPickedZ ( ) [pure virtual]

Return the Z value for the last picked Prop.

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

virtual void vtkViewport::DevicePickRender ( ) [protected, pure virtual]

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

virtual void vtkViewport::StartPick ( unsigned int pickFromSize ) [protected, pure virtual]

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

virtual void vtkViewport::UpdatePickId ( ) [protected, pure virtual]

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

virtual void vtkViewport::DonePick ( ) [protected, pure virtual]

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

virtual unsigned int vtkViewport::GetPickedId ( ) [protected, pure virtual]

Reimplemented in vtkImager, vtkMesaRenderer, and vtkOpenGLRenderer.

Member Data Documentation

vtkAssemblyPath* vtkViewport::PickedProp [protected]

Definition at line 274 of file vtkViewport.h.

vtkPropCollection* vtkViewport::PickFromProps [protected]

Definition at line 275 of file vtkViewport.h.

int vtkViewport::IsPicking [protected]

Definition at line 277 of file vtkViewport.h.

unsigned int vtkViewport::CurrentPickId [protected]

Definition at line 278 of file vtkViewport.h.

float vtkViewport::PickX [protected]

Definition at line 279 of file vtkViewport.h.

float vtkViewport::PickY [protected]

Definition at line 280 of file vtkViewport.h.

vtkPropCollection* vtkViewport::Props [protected]

Definition at line 283 of file vtkViewport.h.

vtkActor2DCollection* vtkViewport::Actors2D [protected]

Definition at line 284 of file vtkViewport.h.

vtkWindow* vtkViewport::VTKWindow [protected]

Definition at line 285 of file vtkViewport.h.

float vtkViewport::Background[3] [protected]

Definition at line 286 of file vtkViewport.h.

float vtkViewport::Viewport[4] [protected]

Definition at line 287 of file vtkViewport.h.

float vtkViewport::Aspect[2] [protected]

Definition at line 288 of file vtkViewport.h.

float vtkViewport::PixelAspect[2] [protected]

Definition at line 289 of file vtkViewport.h.

float vtkViewport::Center[2] [protected]

Definition at line 290 of file vtkViewport.h.

unsigned long vtkViewport::StartTag [protected]

Definition at line 292 of file vtkViewport.h.

unsigned long vtkViewport::EndTag [protected]

Definition at line 293 of file vtkViewport.h.

int vtkViewport::Size[2] [protected]

Definition at line 295 of file vtkViewport.h.

int vtkViewport::Origin[2] [protected]

Definition at line 296 of file vtkViewport.h.

float vtkViewport::DisplayPoint[3] [protected]

Definition at line 297 of file vtkViewport.h.

float vtkViewport::ViewPoint[3] [protected]

Definition at line 298 of file vtkViewport.h.

float vtkViewport::WorldPoint[4] [protected]

Definition at line 299 of file vtkViewport.h.

The documentation for this class was generated from the following file:
  • Common/vtkViewport.h
Generated on Mon Mar 25 01:33:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoidArray Class Reference

dynamic, self-adjusting array of void* pointers. More...

#include <vtkVoidArray.h>

Inheritance diagram for vtkVoidArray:

[legend]
Collaboration diagram for vtkVoidArray:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVoidArray, vtkDataArray)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Allocate (const vtkIdType sz, const vtkIdType ext=1000)
void | Initialize ()
vtkDataArray * MakeObject ()
int | GetDataType ()
int | GetDataTypeSize ()
void | SetNumberOfTuples (const vtkIdType number)
float * | GetTuple (const vtkIdType i)
void | Squeeze ()
virtual void | Resize (vtkIdType numTuples)
void * | GetValue (const vtkIdType id)
void | SetNumberOfValues (const vtkIdType number)
void | SetValue (const vtkIdType id, void *value)
void | InsertValue (const vtkIdType id, void *p)
vtkIdType | InsertNextValue (void *v)
void ** | WritePointer (const vtkIdType id, const vtkIdType number)
void | DeepCopy (vtkDataArray *da)
void | GetTuple (const vtkIdType i, float *tuple)
void | GetTuple (const vtkIdType i, double *tuple)
void | SetTuple (const vtkIdType i, const float *tuple)
void | SetTuple (const vtkIdType i, const double *tuple)
void | InsertTuple (const vtkIdType i, const float *tuple)
void | InsertTuple (const vtkIdType i, const double *tuple)
vtkIdType | InsertNextTuple (const float *tuple)
vtkIdType | InsertNextTuple (const double *tuple)
void ** | GetPointer (const vtkIdType id)
void * | GetVoidPointer (const vtkIdType id)

Static Public Methods

vtkVoidArray * | New ()

Protected Methods

vtkVoidArray ()
~vtkVoidArray ()
void ** | ResizeAndExtend (const vtkIdType sz)

Protected Attributes

void ** | Array
int | TupleSize
float * | Tuple

Detailed Description

dynamic, self-adjusting array of void* pointers.

Date:
2002/02/13 22:46:31
Revision:
1.51

vtkVoidArray is an array of pointers to void. It provides methods for insertion and retrieval of these pointers values, and will automatically resize itself to hold new data.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (47%)
  • Martin, Ken (13%)
  • Henderson, Amy (9%)
  • Geveci, Berk (7%)
  • Miller, Jim (7%)
  • Kelly, Ann (5%)

Definition at line 43 of file vtkVoidArray.h.

Constructor & Destructor Documentation

vtkVoidArray::vtkVoidArray ( ) [protected]

vtkVoidArray::~vtkVoidArray ( ) [protected]

Member Function Documentation

vtkVoidArray* vtkVoidArray::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

Referenced by MakeObject().

vtkVoidArray::vtkTypeRevisionMacro | ( | vtkVoidArray | ,
 |  | vtkDataArray |
 | ) |

Reimplemented from vtkDataArray.

void vtkVoidArray::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkDataArray.

int vtkVoidArray::Allocate | ( | const vtkIdType | sz,
 |  | const vtkIdType | ext = 1000
 | ) | [virtual]

Allocate memory for this array. Delete old storage only if necessary. Note that ext is no longer used.

Reimplemented from vtkDataArray.

Referenced by SetNumberOfValues().

void vtkVoidArray::Initialize ( ) [virtual]

Release storage and reset array to initial state.

Reimplemented from vtkDataArray.

vtkDataArray* vtkVoidArray::MakeObject ( ) [inline, virtual]

Create a similar type object

Reimplemented from vtkDataArray.

Definition at line 59 of file vtkVoidArray.h.

int vtkVoidArray::GetDataType ( ) [inline, virtual]

Get the data type.

Reimplemented from vtkDataArray.

Definition at line 62 of file vtkVoidArray.h.

int vtkVoidArray::GetDataTypeSize ( ) [inline, virtual]

Return the size of the data type.

Reimplemented from vtkDataArray.

Definition at line 65 of file vtkVoidArray.h.

void vtkVoidArray::SetNumberOfTuples ( const vtkIdType number ) [virtual]

Set the number of n-tuples in the array.

Reimplemented from vtkDataArray.

float* vtkVoidArray::GetTuple ( const vtkIdType i ) [virtual]

Get a pointer to a tuple at the ith location.

Reimplemented from vtkDataArray.

void vtkVoidArray::GetTuple | ( | const vtkIdType | i,
 |  | float * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkVoidArray::GetTuple | ( | const vtkIdType | i,
 |  | double * | tuple
 | ) | [virtual]

Copy the tuple value into a user-provided array.

Reimplemented from vtkDataArray.

void vtkVoidArray::SetTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkVoidArray::SetTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Set the tuple value at the ith location in the array.

Reimplemented from vtkDataArray.

void vtkVoidArray::InsertTuple | ( | const vtkIdType | i,
 |  | const float * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

void vtkVoidArray::InsertTuple | ( | const vtkIdType | i,
 |  | const double * | tuple
 | ) | [virtual]

Insert (memory allocation performed) the tuple into the ith location in the array.

Reimplemented from vtkDataArray.

vtkIdType vtkVoidArray::InsertNextTuple ( const float * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

vtkIdType vtkVoidArray::InsertNextTuple ( const double * tuple ) [virtual]

Insert (memory allocation performed) the tuple onto the end of the array.

Reimplemented from vtkDataArray.

void vtkVoidArray::Squeeze ( ) [inline, virtual]

Resize object to just fit data requirement. Reclaims extra memory.

Reimplemented from vtkDataArray.

Definition at line 100 of file vtkVoidArray.h.

virtual void vtkVoidArray::Resize ( vtkIdType numTuples ) [virtual]

Resize the array while conserving the data.

Reimplemented from vtkDataArray.

void* vtkVoidArray::GetValue ( const vtkIdType id ) [inline]

Get the data at a particular index.

Definition at line 106 of file vtkVoidArray.h.

void vtkVoidArray::SetNumberOfValues ( const vtkIdType number ) [inline]

Specify the number of values for this object to hold. Does an allocation as well as setting the MaxId ivar. Used in conjunction with SetValue() method for fast insertion.

Definition at line 155 of file vtkVoidArray.h.

void vtkVoidArray::SetValue | ( | const vtkIdType | id,
 |  | void * | value
 | ) | [inline]

Set the data at a particular index. Does not do range checking. Make sure you use the method SetNumberOfValues() before inserting data.

Definition at line 161 of file vtkVoidArray.h.

void vtkVoidArray::InsertValue | ( | const vtkIdType | id,
 |  | void * | p
 | ) | [inline]

Insert data at a specified position in the array.

Definition at line 181 of file vtkVoidArray.h.

Referenced by InsertNextValue().

vtkIdType vtkVoidArray::InsertNextValue ( void * p ) [inline]

Insert data at the end of the array. Return its location in the array.

Definition at line 194 of file vtkVoidArray.h.

void** vtkVoidArray::GetPointer ( const vtkIdType id ) [inline]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Definition at line 127 of file vtkVoidArray.h.

void* vtkVoidArray::GetVoidPointer ( const vtkIdType id ) [inline, virtual]

Get the address of a particular data index. Performs no checks to verify that the memory has been allocated etc.

Reimplemented from vtkDataArray.

Definition at line 128 of file vtkVoidArray.h.

void ** vtkVoidArray::WritePointer | ( | const vtkIdType | id,
 |  | const vtkIdType | number
 | ) | [inline]

Get the address of a particular data index. Make sure data is allocated for the number of items requested. Set MaxId according to the number of data values requested.

Definition at line 166 of file vtkVoidArray.h.

void vtkVoidArray::DeepCopy ( vtkDataArray * da ) [virtual]

Deep copy of another void array.

Reimplemented from vtkDataArray.

void** vtkVoidArray::ResizeAndExtend ( const vtkIdType sz ) [protected]

Referenced by InsertValue(), and WritePointer().

Member Data Documentation

void** vtkVoidArray::Array [protected]

Definition at line 144 of file vtkVoidArray.h.

int vtkVoidArray::TupleSize [protected]

Definition at line 147 of file vtkVoidArray.h.

float* vtkVoidArray::Tuple [protected]

Definition at line 148 of file vtkVoidArray.h.

The documentation for this class was generated from the following file:
  • Common/vtkVoidArray.h
Generated on Mon Mar 25 01:33:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolume Class Reference

represents a volume (data & properties) in a rendered scene. More...

#include <vtkVolume.h>

Inheritance diagram for vtkVolume:

[legend]
Collaboration diagram for vtkVolume:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolume, vtkProp3D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | GetVolumes (vtkPropCollection *vc)
void | Update ()
unsigned long int | GetMTime ()
unsigned long | GetRedrawMTime ()
void | ShallowCopy (vtkProp *prop)
int | RenderTranslucentGeometry (vtkViewport *viewport)
void | ReleaseGraphicsResources (vtkWindow *)
float * | GetCorrectedScalarOpacityArray ()
float * | GetScalarOpacityArray ()
float * | GetGradientOpacityArray ()
float * | GetGrayArray ()
float * | GetRGBArray ()
float | GetGradientOpacityConstant ()
float | GetArraySize ()
void | UpdateTransferFunctions (vtkRenderer *ren)
void | UpdateScalarOpacityforSampleSize (vtkRenderer *ren, float sample_distance)
void | SetMapper (vtkVolumeMapper *mapper)
virtual vtkVolumeMapper * | GetMapper ()
void | SetProperty (vtkVolumeProperty *property)
vtkVolumeProperty * GetProperty ()
float * | GetBounds ()
void | GetBounds (float bounds[6])
float | GetMinXBound ()
float | GetMaxXBound ()
float | GetMinYBound ()
float | GetMaxYBound ()
float | GetMinZBound ()
float | GetMaxZBound ()

Static Public Methods

vtkVolume * | New ()

Protected Methods

vtkVolume ()
~vtkVolume ()
float | ComputeScreenCoverage (vtkViewport *vp)

Protected Attributes

vtkVolumeMapper * Mapper
vtkVolumeProperty * Property
float * | RGBArray
vtkTimeStamp RGBArrayMTime
float * | GrayArray
vtkTimeStamp GrayArrayMTime
float * | ScalarOpacityArray
vtkTimeStamp ScalarOpacityArrayMTime
float * | CorrectedScalarOpacityArray
float | CorrectedStepSize
vtkTimeStamp CorrectedScalarOpacityArrayMTime
int | ArraySize
float | GradientOpacityArray [256]
float | GradientOpacityConstant
vtkTimeStamp GradientOpacityArrayMTime

Detailed Description

represents a volume (data & properties) in a rendered scene.

Date:
2002/01/22 15:39:32
Revision:
1.61

vtkVolume is used to represent a volumetric entity in a rendering scene. It inherits functions related to the volume's position, orientation and origin from vtkProp3D. The volume maintains a reference to the volumetric data (i.e., the volume mapper). The volume also contains a reference to a volume property which contains all common volume rendering parameters.

See also:
vtkVolumeMapper vtkVolumeProperty vtkProp3D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Avila, Lisa (57%)
  • Martin, Ken (26%)
Examples:
vtkVolume (Examples)
Tests:
vtkVolume (Tests)

Definition at line 60 of file vtkVolume.h.

Constructor & Destructor Documentation

vtkVolume::vtkVolume ( ) [protected]

vtkVolume::~vtkVolume ( ) [protected]

Member Function Documentation

vtkVolume::vtkTypeRevisionMacro | ( | vtkVolume | ,
 |  | vtkProp3D |
 | ) |

Reimplemented from vtkProp3D.

void vtkVolume::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProp3D.

vtkVolume* vtkVolume::New ( ) [static]

Creates a Volume with the following defaults: origin(0,0,0) position=(0,0,0) scale=1 visibility=1 pickable=1 dragable=1 orientation=(0,0,0).

Reimplemented from vtkProp.

void vtkVolume::SetMapper ( vtkVolumeMapper * mapper )

Set/Get the volume mapper.

virtual vtkVolumeMapper* vtkVolume::GetMapper ( void ) [virtual]

Set/Get the volume mapper.

void vtkVolume::SetProperty ( vtkVolumeProperty * property )

Set/Get the volume property.

vtkVolumeProperty* vtkVolume::GetProperty ( )

Set/Get the volume property.

void vtkVolume::GetVolumes ( vtkPropCollection * vc ) [virtual]

For some exporters and other other operations we must be able to collect all the actors or volumes. This method is used in that process.

Reimplemented from vtkProp.

void vtkVolume::Update ( void )

Update the volume rendering pipeline by updating the volume mapper

float* vtkVolume::GetBounds ( ) [virtual]

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

Reimplemented from vtkProp3D.

void vtkVolume::GetBounds ( float bounds[6] ) [inline]

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

Reimplemented from vtkProp3D.

Definition at line 95 of file vtkVolume.h.

float vtkVolume::GetMinXBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

float vtkVolume::GetMaxXBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

float vtkVolume::GetMinYBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

float vtkVolume::GetMaxYBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

float vtkVolume::GetMinZBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

float vtkVolume::GetMaxZBound ( )

Get the bounds - either all six at once (xmin, xmax, ymin, ymax, zmin, zmax) or one at a time.

unsigned long int vtkVolume::GetMTime ( ) [virtual]

Return the MTime also considering the property etc.

Reimplemented from vtkObject.

unsigned long vtkVolume::GetRedrawMTime ( ) [virtual]

Return the mtime of anything that would cause the rendered image to appear differently. Usually this involves checking the mtime of the prop plus anything else it depends on such as properties, mappers, etc.

Reimplemented from vtkProp.

void vtkVolume::ShallowCopy ( vtkProp * prop ) [virtual]

Shallow copy of this vtkVolume. Overloads the virtual vtkProp method.

Reimplemented from vtkProp3D.

int vtkVolume::RenderTranslucentGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Support the standard render methods. Depending on the mapper type, the volume may be rendered using this method (FRAMEBUFFER volume such as texture mapping will be rendered this way)

Reimplemented from vtkProp.

void vtkVolume::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Release any graphics resources that are being consumed by this volume. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkProp.

float* vtkVolume::GetCorrectedScalarOpacityArray ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 132 of file vtkVolume.h.

float* vtkVolume::GetScalarOpacityArray ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 136 of file vtkVolume.h.

float* vtkVolume::GetGradientOpacityArray ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 140 of file vtkVolume.h.

float* vtkVolume::GetGrayArray ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 144 of file vtkVolume.h.

float* vtkVolume::GetRGBArray ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 148 of file vtkVolume.h.

float vtkVolume::GetGradientOpacityConstant ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 152 of file vtkVolume.h.

float vtkVolume::GetArraySize ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

Definition at line 156 of file vtkVolume.h.

void vtkVolume::UpdateTransferFunctions ( vtkRenderer * ren )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

void vtkVolume::UpdateScalarOpacityforSampleSize | ( | vtkRenderer * | ren,
 |  | float | sample_distance
 | ) |

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS

float vtkVolume::ComputeScreenCoverage ( vtkViewport * vp ) [protected]

Member Data Documentation

vtkVolumeMapper* vtkVolume::Mapper [protected]

Definition at line 172 of file vtkVolume.h.

vtkVolumeProperty* vtkVolume::Property [protected]

Definition at line 173 of file vtkVolume.h.

float* vtkVolume::RGBArray [protected]

Definition at line 179 of file vtkVolume.h.

vtkTimeStamp vtkVolume::RGBArrayMTime [protected]

Definition at line 180 of file vtkVolume.h.

float* vtkVolume::GrayArray [protected]

Definition at line 186 of file vtkVolume.h.

vtkTimeStamp vtkVolume::GrayArrayMTime [protected]

Definition at line 187 of file vtkVolume.h.

float* vtkVolume::ScalarOpacityArray [protected]

Definition at line 193 of file vtkVolume.h.

vtkTimeStamp vtkVolume::ScalarOpacityArrayMTime [protected]

Definition at line 194 of file vtkVolume.h.

float* vtkVolume::CorrectedScalarOpacityArray [protected]

Definition at line 200 of file vtkVolume.h.

float vtkVolume::CorrectedStepSize [protected]

Definition at line 206 of file vtkVolume.h.

vtkTimeStamp vtkVolume::CorrectedScalarOpacityArrayMTime [protected]

Definition at line 209 of file vtkVolume.h.

int vtkVolume::ArraySize [protected]

Definition at line 212 of file vtkVolume.h.

float vtkVolume::GradientOpacityArray[256] [protected]

Definition at line 215 of file vtkVolume.h.

float vtkVolume::GradientOpacityConstant [protected]

Definition at line 216 of file vtkVolume.h.

vtkTimeStamp vtkVolume::GradientOpacityArrayMTime [protected]

Definition at line 217 of file vtkVolume.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolume.h
Generated on Mon Mar 25 01:33:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolume16Reader Class Reference

read 16 bit image files. More...

#include <vtkVolume16Reader.h>

Inheritance diagram for vtkVolume16Reader:

[legend]
Collaboration diagram for vtkVolume16Reader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolume16Reader, vtkVolumeReader)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkStructuredPoints * | GetImage (int ImageNumber)
virtual void | SetDataDimensions (int, int)
void | SetDataDimensions (int[2])
virtual int * | GetDataDimensions ()
virtual void | GetDataDimensions (int data[2])
virtual void | SetDataMask (unsigned short)
virtual unsigned short | GetDataMask ()
virtual void | SetHeaderSize (int)
virtual int | GetHeaderSize ()
void | SetDataByteOrderToBigEndian ()
void | SetDataByteOrderToLittleEndian ()
int | GetDataByteOrder ()
void | SetDataByteOrder (int)
const char * | GetDataByteOrderAsString ()
virtual void | SetSwapBytes (int)
virtual int | GetSwapBytes ()
virtual void | SwapBytesOn ()
virtual void | SwapBytesOff ()
virtual void | SetTransform (vtkTransform *)
virtual vtkTransform * | GetTransform ()

Static Public Methods

vtkVolume16Reader * | New ()

Protected Methods

vtkVolume16Reader ()
~vtkVolume16Reader ()
void | Execute ()
void | ExecuteInformation ()
void | TransformSlice (unsigned short *slice, unsigned short *pixels, int k, int dimensions[3], int bounds[3])
void | ComputeTransformedDimensions (int dimensions[3])
void | ComputeTransformedBounds (int bounds[6])
void | ComputeTransformedSpacing (float Spacing[3])
void | ComputeTransformedOrigin (float origin[3])
void | AdjustSpacingAndOrigin (int dimensions[3], float Spacing[3], float origin[3])
vtkUnsignedShortArray * | ReadImage (int ImageNumber)
vtkUnsignedShortArray * | ReadVolume (int FirstImage, int LastImage)
int | Read16BitImage (FILE *fp, unsigned short *pixels, int xsize, int ysize, int skip, int swapBytes)

Protected Attributes

int | DataDimensions [2]
unsigned short | DataMask
int | SwapBytes
int | HeaderSize
vtkTransform * Transform

Detailed Description

read 16 bit image files.

Date:
2002/01/22 15:38:25
Revision:
1.40

vtkVolume16Reader is a source object that reads 16 bit image files.

Volume16Reader creates structured point datasets. The dimension of the dataset depends upon the number of files read. Reading a single file results in a 2D image, while reading more than one file results in a 3D volume.

File names are created using FilePattern and FilePrefix as follows: sprintf (filename, FilePattern, FilePrefix, number); where number is in the range ImageRange[0] to ImageRange[1]. If ImageRange[1] <= ImageRange[0], then slice number ImageRange[0] is read. Thus to read an image set ImageRange[0] = ImageRange[1] = slice number. The default behavior is to read a single file (i.e., image slice 1).

The DataMask instance variable is used to read data files with imbedded connectivity or segmentation information. For example, some data has the high order bit set to indicate connected surface. The DataMask allows you to select this data. Other important ivars include HeaderSize, which allows you to skip over initial info, and SwapBytes, which turns on/off byte swapping.

The Transform instance variable specifies a permutation transformation to map slice space into world space. vtkImageReader has replaced the functionality of this class and should be used instead.

See also:
vtkSliceCubes vtkMarchingCubes vtkImageReader
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (44%)
  • Lorensen, Bill (35%)
  • Martin, Ken (13%)
Tests:
vtkVolume16Reader (Tests)

Definition at line 74 of file vtkVolume16Reader.h.

Constructor & Destructor Documentation

vtkVolume16Reader::vtkVolume16Reader ( ) [protected]

vtkVolume16Reader::~vtkVolume16Reader ( ) [protected]

Member Function Documentation

vtkVolume16Reader::vtkTypeRevisionMacro | ( | vtkVolume16Reader | ,
 |  | vtkVolumeReader |
 | ) |

Reimplemented from vtkVolumeReader.

void vtkVolume16Reader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeReader.

vtkVolume16Reader* vtkVolume16Reader::New ( ) [static]

Construct object with NULL file prefix; file pattern "s.d"; image range set to (1,1); data origin (0,0,0); data spacing (1,1,1); no data mask; header size 0; and byte swapping turned off.

Reimplemented from vtkStructuredPointsSource.

virtual void vtkVolume16Reader::SetDataDimensions | ( | int | ,
 |  | int |
 | ) | [virtual]

Specify the dimensions for the data.

void vtkVolume16Reader::SetDataDimensions ( int [2] )

Specify the dimensions for the data.

virtual int* vtkVolume16Reader::GetDataDimensions ( ) [virtual]

Specify the dimensions for the data.

virtual void vtkVolume16Reader::GetDataDimensions ( int data[2] ) [virtual]

Specify the dimensions for the data.

virtual void vtkVolume16Reader::SetDataMask ( unsigned short ) [virtual]

Specify a mask used to eliminate data in the data file (e.g., connectivity bits).

virtual unsigned short vtkVolume16Reader::GetDataMask ( ) [virtual]

Specify a mask used to eliminate data in the data file (e.g., connectivity bits).

virtual void vtkVolume16Reader::SetHeaderSize ( int ) [virtual]

Specify the number of bytes to seek over at start of image.

virtual int vtkVolume16Reader::GetHeaderSize ( ) [virtual]

Specify the number of bytes to seek over at start of image.

void vtkVolume16Reader::SetDataByteOrderToBigEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkVolume16Reader::SetDataByteOrderToLittleEndian ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

int vtkVolume16Reader::GetDataByteOrder ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

void vtkVolume16Reader::SetDataByteOrder ( int )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

const char* vtkVolume16Reader::GetDataByteOrderAsString ( )

These methods should be used instead of the SwapBytes methods. They indicate the byte ordering of the file you are trying to read in. These methods will then either swap or not swap the bytes depending on the byte ordering of the machine it is being run on. For example, reading in a BigEndian file on a BigEndian machine will result in no swapping. Trying to read the same file on a LittleEndian machine will result in swapping. As a quick note most UNIX machines are BigEndian while PC's and VAX tend to be LittleEndian. So if the file you are reading in was generated on a VAX or PC, SetDataByteOrderToLittleEndian otherwise SetDataByteOrderToBigEndian.

virtual void vtkVolume16Reader::SetSwapBytes ( int ) [virtual]

Turn on/off byte swapping.

virtual int vtkVolume16Reader::GetSwapBytes ( ) [virtual]

Turn on/off byte swapping.

virtual void vtkVolume16Reader::SwapBytesOn ( ) [virtual]

Turn on/off byte swapping.

virtual void vtkVolume16Reader::SwapBytesOff ( ) [virtual]

Turn on/off byte swapping.

virtual void vtkVolume16Reader::SetTransform ( vtkTransform * ) [virtual]

Set/Get transformation matrix to transform the data from slice space into world space. This matrix must be a permutation matrix. To qualify, the sums of the rows must be + or - 1.

virtual vtkTransform* vtkVolume16Reader::GetTransform ( ) [virtual]

Set/Get transformation matrix to transform the data from slice space into world space. This matrix must be a permutation matrix. To qualify, the sums of the rows must be + or - 1.

vtkStructuredPoints* vtkVolume16Reader::GetImage ( int ImageNumber ) [virtual]

Other objects make use of these methods

Reimplemented from vtkVolumeReader.

void vtkVolume16Reader::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkVolume16Reader::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkStructuredPointsSource.

void vtkVolume16Reader::TransformSlice | ( | unsigned short * | slice,
 |  | unsigned short * | pixels,
 |  | int | k,
 |  | int | dimensions[3],
 |  | int | bounds[3]
 | ) | [protected]

void vtkVolume16Reader::ComputeTransformedDimensions ( int dimensions[3] ) [protected]

void vtkVolume16Reader::ComputeTransformedBounds ( int bounds[6] ) [protected]

void vtkVolume16Reader::ComputeTransformedSpacing ( float Spacing[3] ) [protected]

void vtkVolume16Reader::ComputeTransformedOrigin ( float origin[3] ) [protected]

void vtkVolume16Reader::AdjustSpacingAndOrigin | ( | int | dimensions[3],
 |  | float | Spacing[3],
 |  | float | origin[3]
 | ) | [protected]

vtkUnsignedShortArray* vtkVolume16Reader::ReadImage ( int ImageNumber ) [protected]

vtkUnsignedShortArray* vtkVolume16Reader::ReadVolume | ( | int | FirstImage,
 |  | int | LastImage
 | ) | [protected]

int vtkVolume16Reader::Read16BitImage | ( | FILE * | fp,
 |  | unsigned short * | pixels,
 |  | int | xsize,
 |  | int | ysize,
 |  | int | skip,
 |  | int | swapBytes
 | ) | [protected]

Member Data Documentation

int vtkVolume16Reader::DataDimensions[2] [protected]

Definition at line 146 of file vtkVolume16Reader.h.

unsigned short vtkVolume16Reader::DataMask [protected]

Definition at line 147 of file vtkVolume16Reader.h.

int vtkVolume16Reader::SwapBytes [protected]

Definition at line 148 of file vtkVolume16Reader.h.

int vtkVolume16Reader::HeaderSize [protected]

Definition at line 149 of file vtkVolume16Reader.h.

vtkTransform* vtkVolume16Reader::Transform [protected]

Definition at line 150 of file vtkVolume16Reader.h.

The documentation for this class was generated from the following file:
  • IO/vtkVolume16Reader.h
Generated on Mon Mar 25 01:33:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeCollection Class Reference

a list of volumes. More...

#include <vtkVolumeCollection.h>

Inheritance diagram for vtkVolumeCollection:

[legend]
Collaboration diagram for vtkVolumeCollection:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeCollection, vtkPropCollection)
vtkVolume * GetNextItem ()
void | AddItem (vtkVolume *a)
vtkVolume * GetNextVolume ()

Static Public Methods

vtkVolumeCollection * | New ()

Protected Methods

vtkVolumeCollection ()
~vtkVolumeCollection ()

Detailed Description

a list of volumes.

Date:
2002/01/22 15:39:33
Revision:
1.38

vtkVolumeCollection represents and provides methods to manipulate a list of volumes (i.e., vtkVolume and subclasses). The list is unsorted and duplicate entries are not prevented.

See also:
vtkCollection vtkVolume
Created by:
  • Hoffman, Bill
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (46%)
  • Avila, Lisa (26%)
  • Hoffman, Bill (19%)
  • Miller, Jim (5%)

Definition at line 46 of file vtkVolumeCollection.h.

Constructor & Destructor Documentation

vtkVolumeCollection::vtkVolumeCollection ( ) [inline, protected]

Definition at line 71 of file vtkVolumeCollection.h.

vtkVolumeCollection::~vtkVolumeCollection ( ) [inline, protected]

Definition at line 72 of file vtkVolumeCollection.h.

Member Function Documentation

vtkVolumeCollection* vtkVolumeCollection::New ( ) [static]

Construct with empty list.

Reimplemented from vtkPropCollection.

vtkVolumeCollection::vtkTypeRevisionMacro | ( | vtkVolumeCollection | ,
 |  | vtkPropCollection |
 | ) |

Reimplemented from vtkPropCollection.

void vtkVolumeCollection::AddItem ( vtkVolume * a ) [inline]

Add a Volume to the list.

Definition at line 54 of file vtkVolumeCollection.h.

vtkVolume* vtkVolumeCollection::GetNextVolume ( ) [inline]

Get the next Volume in the list. Return NULL when at the end of the list.

Definition at line 61 of file vtkVolumeCollection.h.

vtkVolume* vtkVolumeCollection::GetNextItem ( ) [inline]

Access routine provided for compatibility with previous versions of VTK. Please use the GetNextVolume() variant where possible.

Definition at line 68 of file vtkVolumeCollection.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeCollection.h
Generated on Mon Mar 25 01:33:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeMapper Class Reference

Abstract class for a volume mapper. More...

#include <vtkVolumeMapper.h>

Inheritance diagram for vtkVolumeMapper:

[legend]
Collaboration diagram for vtkVolumeMapper:

[legend]
List of all members.

Public Types

enum | ComponentBlendModes { ComponentBlendAdd = 0, ComponentBlendMaxOpacity }

Public Methods

vtkTypeRevisionMacro (vtkVolumeMapper, vtkAbstractMapper3D)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Update ()
virtual void | Render (vtkRenderer *ren, vtkVolume *vol)=0
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | SetInput (vtkImageData *)
vtkImageData * GetInput ()
virtual void | SetIndependentComponents (int)
virtual int | GetIndependentComponents ()
virtual void | IndependentComponentsOn ()
virtual void | IndependentComponentsOff ()
virtual void | SetComponentBlendMode (int)
virtual int | GetComponentBlendMode ()
void | SetComponentBlendModeToAdd ()
void | SetComponentBlendModeToMaxOpacity ()
virtual void | SetCropping (int)
virtual int | GetCropping ()
virtual void | CroppingOn ()
virtual void | CroppingOff ()
virtual void | SetCroppingRegionPlanes (float, float, float, float, float, float)
virtual void | SetCroppingRegionPlanes (float[6])
virtual float * | GetCroppingRegionPlanes ()
virtual void | GetCroppingRegionPlanes (float data[6])
virtual float * | GetVoxelCroppingRegionPlanes ()
virtual void | GetVoxelCroppingRegionPlanes (float data[6])
virtual void | SetCroppingRegionFlags (int)
virtual int | GetCroppingRegionFlags ()
void | SetCroppingRegionFlagsToSubVolume ()
void | SetCroppingRegionFlagsToFence ()
void | SetCroppingRegionFlagsToInvertedFence ()
void | SetCroppingRegionFlagsToCross ()
void | SetCroppingRegionFlagsToInvertedCross ()
virtual float * | GetBounds ()
virtual void | GetBounds (float bounds[6])
virtual float | GetGradientMagnitudeScale ()
virtual float | GetGradientMagnitudeBias ()

Protected Methods

vtkVolumeMapper ()
~vtkVolumeMapper ()
void | ConvertCroppingRegionPlanesToVoxels ()

Protected Attributes

int | Cropping
float | CroppingRegionPlanes [6]
float | VoxelCroppingRegionPlanes [6]
int | CroppingRegionFlags
int | IndependentComponents
int | ComponentBlendMode
vtkTimeStamp BuildTime
vtkImageClip * ImageClipper

Detailed Description

Abstract class for a volume mapper.

Date:
2002/03/21 20:26:27
Revision:
1.56

vtkVolumeMapper is the abstract definition of a volume mapper. Several basic types of volume mappers are supported. There are ray casters, which produce an image that must be merged with geometry, there are hardware methods that blend with geometry, and some combinations of these.

See also:
vtkVolumeRayCastMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (72%)
  • Schroeder, Will (9%)
  • Martin, Ken (7%)
  • Miller, Jim (5%)

Definition at line 59 of file vtkVolumeMapper.h.

Member Enumeration Documentation

enum vtkVolumeMapper::ComponentBlendModes

Enumeration values:
ComponentBlendAdd
ComponentBlendMaxOpacity

Definition at line 185 of file vtkVolumeMapper.h.

Constructor & Destructor Documentation

vtkVolumeMapper::vtkVolumeMapper ( ) [protected]

vtkVolumeMapper::~vtkVolumeMapper ( ) [protected]

Member Function Documentation

vtkVolumeMapper::vtkTypeRevisionMacro | ( | vtkVolumeMapper | ,
 |  | vtkAbstractMapper3D |
 | ) |

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkMesaVolumeRayCastMapper, vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeTextureMapper2D, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, and vtkVolumeTextureMapper2D.

void vtkVolumeMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkVolumeProMapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, and vtkVolumeTextureMapper2D.

virtual void vtkVolumeMapper::Update ( void ) [virtual]

Update the volume rendering pipeline by updating the scalar input

Reimplemented from vtkAbstractMapper3D.

Reimplemented in vtkVolumeTextureMapper.

void vtkVolumeMapper::SetInput ( vtkImageData * )

Set/Get the input data

vtkImageData* vtkVolumeMapper::GetInput ( )

Set/Get the input data

virtual void vtkVolumeMapper::SetIndependentComponents ( int ) [virtual]

Does the data have independent components, or do some define color only? If IndependentComponents is On (the default) then each component will be independently passed through a lookup table to determine RGBA, shaded, and then combined with the other components using the ComponentBlendMode. Some volume Mappers can handle 1 to 4 component unsigned char or unsigned short data (see each mapper header file to determine functionality). If IndependentComponents is Off, then you must have either 2 or 4 componenet data. For 2 component data, the first is passed through the first color tranfser function and the second component is passed through the first opacity transfer function. Normals will be generated off of the second component. For 4 component data, the first three will directly represent RGB (no lookup table). The fourth component will be passed through the first scalar opacity transfer function for opacity. Normals will be generated from the fourth component.

virtual int vtkVolumeMapper::GetIndependentComponents ( ) [virtual]

Does the data have independent components, or do some define color only? If IndependentComponents is On (the default) then each component will be independently passed through a lookup table to determine RGBA, shaded, and then combined with the other components using the ComponentBlendMode. Some volume Mappers can handle 1 to 4 component unsigned char or unsigned short data (see each mapper header file to determine functionality). If IndependentComponents is Off, then you must have either 2 or 4 componenet data. For 2 component data, the first is passed through the first color tranfser function and the second component is passed through the first opacity transfer function. Normals will be generated off of the second component. For 4 component data, the first three will directly represent RGB (no lookup table). The fourth component will be passed through the first scalar opacity transfer function for opacity. Normals will be generated from the fourth component.

virtual void vtkVolumeMapper::IndependentComponentsOn ( ) [virtual]

Does the data have independent components, or do some define color only? If IndependentComponents is On (the default) then each component will be independently passed through a lookup table to determine RGBA, shaded, and then combined with the other components using the ComponentBlendMode. Some volume Mappers can handle 1 to 4 component unsigned char or unsigned short data (see each mapper header file to determine functionality). If IndependentComponents is Off, then you must have either 2 or 4 componenet data. For 2 component data, the first is passed through the first color tranfser function and the second component is passed through the first opacity transfer function. Normals will be generated off of the second component. For 4 component data, the first three will directly represent RGB (no lookup table). The fourth component will be passed through the first scalar opacity transfer function for opacity. Normals will be generated from the fourth component.

virtual void vtkVolumeMapper::IndependentComponentsOff ( ) [virtual]

Does the data have independent components, or do some define color only? If IndependentComponents is On (the default) then each component will be independently passed through a lookup table to determine RGBA, shaded, and then combined with the other components using the ComponentBlendMode. Some volume Mappers can handle 1 to 4 component unsigned char or unsigned short data (see each mapper header file to determine functionality). If IndependentComponents is Off, then you must have either 2 or 4 componenet data. For 2 component data, the first is passed through the first color tranfser function and the second component is passed through the first opacity transfer function. Normals will be generated off of the second component. For 4 component data, the first three will directly represent RGB (no lookup table). The fourth component will be passed through the first scalar opacity transfer function for opacity. Normals will be generated from the fourth component.

virtual void vtkVolumeMapper::SetComponentBlendMode ( int ) [virtual]

If we have more than 1 independent components, how will the resulting RGBA values be combined? Add: R = R1 + R2, G = G1 + G2, B = B1 + B2, A = A1 + A2 MaxOpacity: A1 >= A2 then R = R1, G = G1, B = B1, A = A1 A2 > A1 then R = R2, G = G2, B = B2, A = A2

virtual int vtkVolumeMapper::GetComponentBlendMode ( ) [virtual]

If we have more than 1 independent components, how will the resulting RGBA values be combined? Add: R = R1 + R2, G = G1 + G2, B = B1 + B2, A = A1 + A2 MaxOpacity: A1 >= A2 then R = R1, G = G1, B = B1, A = A1 A2 > A1 then R = R2, G = G2, B = B2, A = A2

void vtkVolumeMapper::SetComponentBlendModeToAdd ( ) [inline]

If we have more than 1 independent components, how will the resulting RGBA values be combined? Add: R = R1 + R2, G = G1 + G2, B = B1 + B2, A = A1 + A2 MaxOpacity: A1 >= A2 then R = R1, G = G1, B = B1, A = A1 A2 > A1 then R = R2, G = G2, B = B2, A = A2

Definition at line 104 of file vtkVolumeMapper.h.

void vtkVolumeMapper::SetComponentBlendModeToMaxOpacity ( ) [inline]

If we have more than 1 independent components, how will the resulting RGBA values be combined? Add: R = R1 + R2, G = G1 + G2, B = B1 + B2, A = A1 + A2 MaxOpacity: A1 >= A2 then R = R1, G = G1, B = B1, A = A1 A2 > A1 then R = R2, G = G2, B = B2, A = A2

Definition at line 106 of file vtkVolumeMapper.h.

virtual void vtkVolumeMapper::SetCropping ( int ) [virtual]

Turn On/Off orthogonal cropping. (Clipping planes are perpendicular to the coordinate axes.)

virtual int vtkVolumeMapper::GetCropping ( ) [virtual]

Turn On/Off orthogonal cropping. (Clipping planes are perpendicular to the coordinate axes.)

virtual void vtkVolumeMapper::CroppingOn ( ) [virtual]

Turn On/Off orthogonal cropping. (Clipping planes are perpendicular to the coordinate axes.)

virtual void vtkVolumeMapper::CroppingOff ( ) [virtual]

Turn On/Off orthogonal cropping. (Clipping planes are perpendicular to the coordinate axes.)

virtual void vtkVolumeMapper::SetCroppingRegionPlanes | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the Cropping Region Planes ( xmin, xmax, ymin, ymax, zmin, zmax ) These planes are defined in volume coordinates - spacing and origin are considered.

virtual void vtkVolumeMapper::SetCroppingRegionPlanes ( float [6] ) [virtual]

Set/Get the Cropping Region Planes ( xmin, xmax, ymin, ymax, zmin, zmax ) These planes are defined in volume coordinates - spacing and origin are considered.

virtual float* vtkVolumeMapper::GetCroppingRegionPlanes ( ) [virtual]

Set/Get the Cropping Region Planes ( xmin, xmax, ymin, ymax, zmin, zmax ) These planes are defined in volume coordinates - spacing and origin are considered.

virtual void vtkVolumeMapper::GetCroppingRegionPlanes ( float data[6] ) [virtual]

Set/Get the Cropping Region Planes ( xmin, xmax, ymin, ymax, zmin, zmax ) These planes are defined in volume coordinates - spacing and origin are considered.

virtual float* vtkVolumeMapper::GetVoxelCroppingRegionPlanes ( ) [virtual]

Get the cropping region planes in voxels. Only valid during the rendering process

virtual void vtkVolumeMapper::GetVoxelCroppingRegionPlanes ( float data[6] ) [virtual]

Get the cropping region planes in voxels. Only valid during the rendering process

virtual void vtkVolumeMapper::SetCroppingRegionFlags ( int ) [virtual]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

virtual int vtkVolumeMapper::GetCroppingRegionFlags ( ) [virtual]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

void vtkVolumeMapper::SetCroppingRegionFlagsToSubVolume ( ) [inline]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

Definition at line 146 of file vtkVolumeMapper.h.

void vtkVolumeMapper::SetCroppingRegionFlagsToFence ( ) [inline]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

Definition at line 148 of file vtkVolumeMapper.h.

void vtkVolumeMapper::SetCroppingRegionFlagsToInvertedFence ( ) [inline]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

Definition at line 150 of file vtkVolumeMapper.h.

void vtkVolumeMapper::SetCroppingRegionFlagsToCross ( ) [inline]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

Definition at line 152 of file vtkVolumeMapper.h.

void vtkVolumeMapper::SetCroppingRegionFlagsToInvertedCross ( ) [inline]

Set the flags for the cropping regions. The clipping planes divide the volume into 27 regions - there is one bit for each region. The regions start from the one containing voxel (0,0,0), moving along the x axis fastest, the y axis next, and the z axis slowest. These are represented from the lowest bit to bit number 27 in the integer containing the flags. There are several convenience functions to set some common configurations - subvolume (the default), fence (between any of the clip plane pairs), inverted fence, cross (between any two of the clip plane pairs) and inverted cross.

Definition at line 154 of file vtkVolumeMapper.h.

virtual float* vtkVolumeMapper::GetBounds ( ) [virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkAbstractMapper3D.

virtual void vtkVolumeMapper::GetBounds ( float bounds[6] ) [inline, virtual]

Return bounding box (array of six floats) of data expressed as (xmin,xmax, ymin,ymax, zmin,zmax).

Reimplemented from vtkAbstractMapper3D.

Definition at line 162 of file vtkVolumeMapper.h.

virtual float vtkVolumeMapper::GetGradientMagnitudeScale ( ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE

Reimplemented in vtkVolumeRayCastMapper, and vtkVolumeTextureMapper.

Definition at line 170 of file vtkVolumeMapper.h.

virtual float vtkVolumeMapper::GetGradientMagnitudeBias ( ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE

Reimplemented in vtkVolumeRayCastMapper, and vtkVolumeTextureMapper.

Definition at line 171 of file vtkVolumeMapper.h.

virtual void vtkVolumeMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [pure virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Render the volume

Reimplemented in vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkVolumeProMapper, vtkVolumeProVG500Mapper, vtkVolumeProVP1000Mapper, vtkVolumeRayCastMapper, vtkVolumeTextureMapper, and vtkVolumeTextureMapper2D.

virtual void vtkVolumeMapper::ReleaseGraphicsResources ( vtkWindow * ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

Reimplemented in vtkVolumeRayCastMapper.

Definition at line 183 of file vtkVolumeMapper.h.

void vtkVolumeMapper::ConvertCroppingRegionPlanesToVoxels ( ) [protected]

Member Data Documentation

int vtkVolumeMapper::Cropping [protected]

Definition at line 199 of file vtkVolumeMapper.h.

float vtkVolumeMapper::CroppingRegionPlanes[6] [protected]

Definition at line 200 of file vtkVolumeMapper.h.

float vtkVolumeMapper::VoxelCroppingRegionPlanes[6] [protected]

Definition at line 201 of file vtkVolumeMapper.h.

int vtkVolumeMapper::CroppingRegionFlags [protected]

Definition at line 202 of file vtkVolumeMapper.h.

int vtkVolumeMapper::IndependentComponents [protected]

Definition at line 206 of file vtkVolumeMapper.h.

int vtkVolumeMapper::ComponentBlendMode [protected]

Definition at line 209 of file vtkVolumeMapper.h.

vtkTimeStamp vtkVolumeMapper::BuildTime [protected]

Definition at line 211 of file vtkVolumeMapper.h.

vtkImageClip* vtkVolumeMapper::ImageClipper [protected]

Definition at line 214 of file vtkVolumeMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeMapper.h
Generated on Mon Mar 25 01:33:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProMapper Class Reference

Superclass for VolumePRO volume rendering mappers. More...

#include <vtkVolumeProMapper.h>

Inheritance diagram for vtkVolumeProMapper:

[legend]
Collaboration diagram for vtkVolumeProMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeProMapper, vtkVolumeMapper)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Render (vtkRenderer *, vtkVolume *)
virtual void | SetBlendMode (int)
virtual int | GetBlendMode ()
void | SetBlendModeToComposite ()
void | SetBlendModeToMaximumIntensity ()
void | SetBlendModeToMinimumIntensity ()
const char * | GetBlendModeAsString (void)
virtual void | SetSubVolume (int, int, int, int, int, int)
virtual void | SetSubVolume (int[6])
virtual int * | GetSubVolume ()
virtual void | GetSubVolume (int data[6])
virtual void | SetCursor (int)
virtual int | GetCursor ()
virtual void | CursorOn ()
virtual void | CursorOff ()
virtual void | SetCursorType (int)
virtual int | GetCursorType ()
void | SetCursorTypeToCrossHair ()
void | SetCursorTypeToPlane ()
const char * | GetCursorTypeAsString (void)
virtual void | SetCursorPosition (double, double, double)
virtual void | SetCursorPosition (double[3])
virtual double * | GetCursorPosition ()
virtual void | GetCursorPosition (double data[3])
virtual void | SetCursorXAxisColor (double, double, double)
virtual void | SetCursorXAxisColor (double[3])
virtual double * | GetCursorXAxisColor ()
virtual void | GetCursorXAxisColor (double data[3])
virtual void | SetCursorYAxisColor (double, double, double)
virtual void | SetCursorYAxisColor (double[3])
virtual double * | GetCursorYAxisColor ()
virtual void | GetCursorYAxisColor (double data[3])
virtual void | SetCursorZAxisColor (double, double, double)
virtual void | SetCursorZAxisColor (double[3])
virtual double * | GetCursorZAxisColor ()
virtual void | GetCursorZAxisColor (double data[3])
virtual void | SetSuperSampling (int)
virtual int | GetSuperSampling ()
virtual void | SuperSamplingOn ()
virtual void | SuperSamplingOff ()
void | SetSuperSamplingFactor (double x, double y, double z)
void | SetSuperSamplingFactor (double f[3])
virtual double * | GetSuperSamplingFactor ()
virtual void | GetSuperSamplingFactor (double data[3])
virtual void | SetCutPlane (int)
virtual int | GetCutPlane ()
virtual void | CutPlaneOn ()
virtual void | CutPlaneOff ()
virtual void | SetCutPlaneEquation (double, double, double, double)
virtual void | SetCutPlaneEquation (double[4])
virtual double * | GetCutPlaneEquation ()
virtual void | GetCutPlaneEquation (double data[4])
virtual void | SetCutPlaneThickness (double)
virtual double | GetCutPlaneThickness ()
virtual void | SetCutPlaneFallOffDistance (int)
virtual int | GetCutPlaneFallOffDistance ()
virtual void | SetGradientOpacityModulation (int)
virtual int | GetGradientOpacityModulation ()
virtual void | GradientOpacityModulationOn ()
virtual void | GradientOpacityModulationOff ()
virtual void | SetGradientDiffuseModulation (int)
virtual int | GetGradientDiffuseModulation ()
virtual void | GradientDiffuseModulationOn ()
virtual void | GradientDiffuseModulationOff ()
virtual void | SetGradientSpecularModulation (int)
virtual int | GetGradientSpecularModulation ()
virtual void | GradientSpecularModulationOn ()
virtual void | GradientSpecularModulationOff ()
virtual int | GetNoHardware ()
virtual int | GetWrongVLIVersion ()
virtual int | GetNumberOfBoards ()
virtual int | GetMajorBoardVersion ()
virtual int | GetMinorBoardVersion ()
virtual int | GetAvailableBoardMemory ()
virtual void | GetLockSizesForBoardMemory (unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize))
virtual void | SetIntermixIntersectingGeometry (int)
virtual int | GetIntermixIntersectingGeometry ()
virtual void | IntermixIntersectingGeometryOn ()
virtual void | IntermixIntersectingGeometryOff ()

Static Public Methods

vtkVolumeProMapper * | New ()

Protected Methods

vtkVolumeProMapper ()
~vtkVolumeProMapper ()
int | StatusOK ()

Protected Attributes

VLIContext * | Context
VLIVolume * | Volume
vtkImageData * VolumeInput
vtkTimeStamp * VolumeBuildTime
int | VolumeDataType
VLILookupTable * | LookupTable
int | BlendMode
VLILight ** | Lights
int | NumberOfLights
int | SubVolume [6]
int | Cursor
int | CursorType
double | CursorPosition [3]
double | CursorXAxisColor [3]
double | CursorYAxisColor [3]
double | CursorZAxisColor [3]
int | CutPlane
VLICutPlane * | Cut
double | CutPlaneEquation [4]
double | CutPlaneThickness
int | CutPlaneFallOffDistance
int | SuperSampling
double | SuperSamplingFactor [3]
int | GradientOpacityModulation
int | GradientDiffuseModulation
int | GradientSpecularModulation
int | NumberOfBoards
int | MajorBoardVersion
int | MinorBoardVersion
int | GradientTableSize
int | NoHardware
int | WrongVLIVersion
int | DisplayedMessage
int | IntermixIntersectingGeometry

Detailed Description

Superclass for VolumePRO volume rendering mappers.

Date:
2002/01/22 15:39:35
Revision:
1.29

vtkVolumeProMapper is the superclass for VolumePRO volume rendering mappers. Any functionality that is general across all VolumePRO implementations is placed here in this class. Subclasses of this class are for the specific board implementations. Subclasses of that are for underlying graphics languages. Users should not create subclasses directly - a vtkVolumeProMapper will automatically create the object of the right type.

If you do not have the VolumePRO libraries when building this object, then the New method will create a default renderer that will not render. You can check the NumberOfBoards ivar to see if it is a real rendering class. To build with the VolumePRO board see vtkVolumeProVG500Mapper.h or vtkVolumeProVP1000Mapper.h for instructions.

For more information on the VolumePRO hardware, please see:

http://www.terarecon.com/3d_products.shtml

If you encounter any problems with this class, please inform Kitware, Inc. at kitware@kitware.com.

See also:
vtkVolumeMapper vtkVolumeProVG500Mapper vtkOpenGLVolumeProVG500Mapper vtkVolumeProVP1000Mapper vtkOpenGLVolumeProVP1000Mapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (67%)
  • Hoffman, Bill (23%)

Definition at line 95 of file vtkVolumeProMapper.h.

Constructor & Destructor Documentation

vtkVolumeProMapper::vtkVolumeProMapper ( ) [protected]

vtkVolumeProMapper::~vtkVolumeProMapper ( ) [protected]

Member Function Documentation

vtkVolumeProMapper::vtkTypeRevisionMacro | ( | vtkVolumeProMapper | ,
 |  | vtkVolumeMapper |
 | ) |

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, and vtkVolumeProVP1000Mapper.

void vtkVolumeProMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeMapper.

vtkVolumeProMapper* vtkVolumeProMapper::New ( ) [static]

Automatically create the proper subclass

Reimplemented from vtkProcessObject.

Reimplemented in vtkOpenGLVolumeProVG500Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, and vtkVolumeProVP1000Mapper.

virtual void vtkVolumeProMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [inline, virtual]

Render the image using the hardware and place it in the frame buffer

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkVolumeProVG500Mapper, and vtkVolumeProVP1000Mapper.

Definition at line 106 of file vtkVolumeProMapper.h.

virtual void vtkVolumeProMapper::SetBlendMode ( int ) [virtual]

Set the blend mode

Referenced by SetBlendModeToComposite(), SetBlendModeToMaximumIntensity(), and SetBlendModeToMinimumIntensity().

virtual int vtkVolumeProMapper::GetBlendMode ( ) [virtual]

Set the blend mode

void vtkVolumeProMapper::SetBlendModeToComposite ( ) [inline]

Set the blend mode

Definition at line 113 of file vtkVolumeProMapper.h.

void vtkVolumeProMapper::SetBlendModeToMaximumIntensity ( ) [inline]

Set the blend mode

Definition at line 115 of file vtkVolumeProMapper.h.

void vtkVolumeProMapper::SetBlendModeToMinimumIntensity ( ) [inline]

Set the blend mode

Definition at line 117 of file vtkVolumeProMapper.h.

const char * vtkVolumeProMapper::GetBlendModeAsString ( void ) [inline]

Get the blending mode as a descriptive string

Definition at line 334 of file vtkVolumeProMapper.h.

virtual void vtkVolumeProMapper::SetSubVolume | ( | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int | ,
 |  | int |
 | ) | [virtual]

Set the subvolume

virtual void vtkVolumeProMapper::SetSubVolume ( int [6] ) [virtual]

Set the subvolume

virtual int* vtkVolumeProMapper::GetSubVolume ( ) [virtual]

Set the subvolume

virtual void vtkVolumeProMapper::GetSubVolume ( int data[6] ) [virtual]

Set the subvolume

virtual void vtkVolumeProMapper::SetCursor ( int ) [virtual]

Turn the cursor on / off

virtual int vtkVolumeProMapper::GetCursor ( ) [virtual]

Turn the cursor on / off

virtual void vtkVolumeProMapper::CursorOn ( ) [virtual]

Turn the cursor on / off

virtual void vtkVolumeProMapper::CursorOff ( ) [virtual]

Turn the cursor on / off

virtual void vtkVolumeProMapper::SetCursorType ( int ) [virtual]

Set the type of the cursor

Referenced by SetCursorTypeToCrossHair(), and SetCursorTypeToPlane().

virtual int vtkVolumeProMapper::GetCursorType ( ) [virtual]

Set the type of the cursor

void vtkVolumeProMapper::SetCursorTypeToCrossHair ( ) [inline]

Set the type of the cursor

Definition at line 140 of file vtkVolumeProMapper.h.

void vtkVolumeProMapper::SetCursorTypeToPlane ( ) [inline]

Set the type of the cursor

Definition at line 142 of file vtkVolumeProMapper.h.

const char * vtkVolumeProMapper::GetCursorTypeAsString ( void ) [inline]

Get the cursor type as a descriptive string

Definition at line 350 of file vtkVolumeProMapper.h.

virtual void vtkVolumeProMapper::SetCursorPosition | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the cursor position

virtual void vtkVolumeProMapper::SetCursorPosition ( double [3] ) [virtual]

Set/Get the cursor position

virtual double* vtkVolumeProMapper::GetCursorPosition ( ) [virtual]

Set/Get the cursor position

virtual void vtkVolumeProMapper::GetCursorPosition ( double data[3] ) [virtual]

Set/Get the cursor position

virtual void vtkVolumeProMapper::SetCursorXAxisColor | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetCursorXAxisColor ( double [3] ) [virtual]

Set/Get the cursor color

virtual double* vtkVolumeProMapper::GetCursorXAxisColor ( ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::GetCursorXAxisColor ( double data[3] ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetCursorYAxisColor | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetCursorYAxisColor ( double [3] ) [virtual]

Set/Get the cursor color

virtual double* vtkVolumeProMapper::GetCursorYAxisColor ( ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::GetCursorYAxisColor ( double data[3] ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetCursorZAxisColor | ( | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetCursorZAxisColor ( double [3] ) [virtual]

Set/Get the cursor color

virtual double* vtkVolumeProMapper::GetCursorZAxisColor ( ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::GetCursorZAxisColor ( double data[3] ) [virtual]

Set/Get the cursor color

virtual void vtkVolumeProMapper::SetSuperSampling ( int ) [virtual]

Turn supersampling on/off

virtual int vtkVolumeProMapper::GetSuperSampling ( ) [virtual]

Turn supersampling on/off

virtual void vtkVolumeProMapper::SuperSamplingOn ( ) [virtual]

Turn supersampling on/off

virtual void vtkVolumeProMapper::SuperSamplingOff ( ) [virtual]

Turn supersampling on/off

void vtkVolumeProMapper::SetSuperSamplingFactor | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |

Set the supersampling factors

Referenced by SetSuperSamplingFactor().

void vtkVolumeProMapper::SetSuperSamplingFactor ( double f[3] ) [inline]

Set the supersampling factors

Definition at line 173 of file vtkVolumeProMapper.h.

virtual double* vtkVolumeProMapper::GetSuperSamplingFactor ( ) [virtual]

Set the supersampling factors

virtual void vtkVolumeProMapper::GetSuperSamplingFactor ( double data[3] ) [virtual]

Set the supersampling factors

virtual void vtkVolumeProMapper::SetCutPlane ( int ) [virtual]

Turn on / off the cut plane

virtual int vtkVolumeProMapper::GetCutPlane ( ) [virtual]

Turn on / off the cut plane

virtual void vtkVolumeProMapper::CutPlaneOn ( ) [virtual]

Turn on / off the cut plane

virtual void vtkVolumeProMapper::CutPlaneOff ( ) [virtual]

Turn on / off the cut plane

virtual void vtkVolumeProMapper::SetCutPlaneEquation | ( | double | ,
 |  | double | ,
 |  | double | ,
 |  | double |
 | ) | [virtual]

Set/Get the cut plane equation

virtual void vtkVolumeProMapper::SetCutPlaneEquation ( double [4] ) [virtual]

Set/Get the cut plane equation

virtual double* vtkVolumeProMapper::GetCutPlaneEquation ( ) [virtual]

Set/Get the cut plane equation

virtual void vtkVolumeProMapper::GetCutPlaneEquation ( double data[4] ) [virtual]

Set/Get the cut plane equation

virtual void vtkVolumeProMapper::SetCutPlaneThickness ( double ) [virtual]

Set / Get the cut plane thickness

virtual double vtkVolumeProMapper::GetCutPlaneThickness ( ) [virtual]

Set / Get the cut plane thickness

virtual void vtkVolumeProMapper::SetCutPlaneFallOffDistance ( int ) [virtual]

Set / Get the cut plane falloff value for intensities

virtual int vtkVolumeProMapper::GetCutPlaneFallOffDistance ( ) [virtual]

Set / Get the cut plane falloff value for intensities

virtual void vtkVolumeProMapper::SetGradientOpacityModulation ( int ) [virtual]

Set/Get the gradient magnitude opacity modulation

virtual int vtkVolumeProMapper::GetGradientOpacityModulation ( ) [virtual]

Set/Get the gradient magnitude opacity modulation

virtual void vtkVolumeProMapper::GradientOpacityModulationOn ( ) [virtual]

Set/Get the gradient magnitude opacity modulation

virtual void vtkVolumeProMapper::GradientOpacityModulationOff ( ) [virtual]

Set/Get the gradient magnitude opacity modulation

virtual void vtkVolumeProMapper::SetGradientDiffuseModulation ( int ) [virtual]

Set/Get the gradient magnitude diffuse modulation

virtual int vtkVolumeProMapper::GetGradientDiffuseModulation ( ) [virtual]

Set/Get the gradient magnitude diffuse modulation

virtual void vtkVolumeProMapper::GradientDiffuseModulationOn ( ) [virtual]

Set/Get the gradient magnitude diffuse modulation

virtual void vtkVolumeProMapper::GradientDiffuseModulationOff ( ) [virtual]

Set/Get the gradient magnitude diffuse modulation

virtual void vtkVolumeProMapper::SetGradientSpecularModulation ( int ) [virtual]

Set/Get the gradient magnitude specular modulation

virtual int vtkVolumeProMapper::GetGradientSpecularModulation ( ) [virtual]

Set/Get the gradient magnitude specular modulation

virtual void vtkVolumeProMapper::GradientSpecularModulationOn ( ) [virtual]

Set/Get the gradient magnitude specular modulation

virtual void vtkVolumeProMapper::GradientSpecularModulationOff ( ) [virtual]

Set/Get the gradient magnitude specular modulation

virtual int vtkVolumeProMapper::GetNoHardware ( ) [virtual]

Conveniece methods for debugging

virtual int vtkVolumeProMapper::GetWrongVLIVersion ( ) [virtual]

Conveniece methods for debugging

virtual int vtkVolumeProMapper::GetNumberOfBoards ( ) [virtual]

Access methods for some board info

virtual int vtkVolumeProMapper::GetMajorBoardVersion ( ) [virtual]

Access methods for some board info

virtual int vtkVolumeProMapper::GetMinorBoardVersion ( ) [virtual]

Access methods for some board info

virtual int vtkVolumeProMapper::GetAvailableBoardMemory ( ) [inline, virtual]

Access methods for some board info

Reimplemented in vtkVolumeProVG500Mapper, and vtkVolumeProVP1000Mapper.

Definition at line 235 of file vtkVolumeProMapper.h.

virtual void vtkVolumeProMapper::GetLockSizesForBoardMemory | ( | unsigned int vtkNotUsed(type) | ,
 |  | unsigned int *vtkNotUsed(xSize) | ,
 |  | unsigned int *vtkNotUsed(ySize) | ,
 |  | unsigned int *vtkNotUsed(zSize) |
 | ) | [inline, virtual]

Access methods for some board info

Definition at line 236 of file vtkVolumeProMapper.h.

virtual void vtkVolumeProMapper::SetIntermixIntersectingGeometry ( int ) [virtual]

Specify whether any geometry intersects the volume. Does nothing with VG500

virtual int vtkVolumeProMapper::GetIntermixIntersectingGeometry ( ) [virtual]

Specify whether any geometry intersects the volume. Does nothing with VG500

virtual void vtkVolumeProMapper::IntermixIntersectingGeometryOn ( ) [virtual]

Specify whether any geometry intersects the volume. Does nothing with VG500

virtual void vtkVolumeProMapper::IntermixIntersectingGeometryOff ( ) [virtual]

Specify whether any geometry intersects the volume. Does nothing with VG500

int vtkVolumeProMapper::StatusOK ( ) [protected]

Member Data Documentation

VLIContext* vtkVolumeProMapper::Context [protected]

Definition at line 257 of file vtkVolumeProMapper.h.

VLIVolume* vtkVolumeProMapper::Volume [protected]

Definition at line 261 of file vtkVolumeProMapper.h.

vtkImageData* vtkVolumeProMapper::VolumeInput [protected]

Definition at line 262 of file vtkVolumeProMapper.h.

vtkTimeStamp* vtkVolumeProMapper::VolumeBuildTime [protected]

Definition at line 263 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::VolumeDataType [protected]

Definition at line 266 of file vtkVolumeProMapper.h.

VLILookupTable* vtkVolumeProMapper::LookupTable [protected]

Definition at line 270 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::BlendMode [protected]

Definition at line 273 of file vtkVolumeProMapper.h.

VLILight** vtkVolumeProMapper::Lights [protected]

Definition at line 277 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::NumberOfLights [protected]

Definition at line 278 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::SubVolume[6] [protected]

Definition at line 281 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::Cursor [protected]

Definition at line 284 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::CursorType [protected]

Definition at line 285 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CursorPosition[3] [protected]

Definition at line 286 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CursorXAxisColor[3] [protected]

Definition at line 287 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CursorYAxisColor[3] [protected]

Definition at line 288 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CursorZAxisColor[3] [protected]

Definition at line 289 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::CutPlane [protected]

Definition at line 292 of file vtkVolumeProMapper.h.

VLICutPlane* vtkVolumeProMapper::Cut [protected]

Definition at line 293 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CutPlaneEquation[4] [protected]

Definition at line 294 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::CutPlaneThickness [protected]

Definition at line 295 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::CutPlaneFallOffDistance [protected]

Definition at line 296 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::SuperSampling [protected]

Definition at line 299 of file vtkVolumeProMapper.h.

double vtkVolumeProMapper::SuperSamplingFactor[3] [protected]

Definition at line 300 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::GradientOpacityModulation [protected]

Definition at line 303 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::GradientDiffuseModulation [protected]

Definition at line 304 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::GradientSpecularModulation [protected]

Definition at line 305 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::NumberOfBoards [protected]

Definition at line 308 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::MajorBoardVersion [protected]

Definition at line 309 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::MinorBoardVersion [protected]

Definition at line 310 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::GradientTableSize [protected]

Definition at line 311 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::NoHardware [protected]

Definition at line 314 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::WrongVLIVersion [protected]

Definition at line 315 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::DisplayedMessage [protected]

Definition at line 316 of file vtkVolumeProMapper.h.

int vtkVolumeProMapper::IntermixIntersectingGeometry [protected]

Definition at line 319 of file vtkVolumeProMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeProMapper.h
Generated on Mon Mar 25 01:33:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProperty Class Reference

represents the common properties for rendering a volume. More...

#include <vtkVolumeProperty.h>

Inheritance diagram for vtkVolumeProperty:

[legend]
Collaboration diagram for vtkVolumeProperty:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeProperty, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
void | UpdateMTimes ()
virtual void | SetInterpolationType (int)
virtual int | GetInterpolationType ()
void | SetInterpolationTypeToNearest ()
void | SetInterpolationTypeToLinear ()
const char * | GetInterpolationTypeAsString (void)
void | SetColor (int index, vtkPiecewiseFunction *function)
void | SetColor (vtkPiecewiseFunction *f)
void | SetColor (int index, vtkColorTransferFunction *function)
void | SetColor (vtkColorTransferFunction *f)
int | GetColorChannels (int index)
int | GetColorChannels ()
vtkPiecewiseFunction * | GetGrayTransferFunction (int index)
vtkPiecewiseFunction * GetGrayTransferFunction ()
vtkColorTransferFunction * | GetRGBTransferFunction (int index)
vtkColorTransferFunction * GetRGBTransferFunction ()
void | SetScalarOpacity (int index, vtkPiecewiseFunction *function)
void | SetScalarOpacity (vtkPiecewiseFunction *f)
vtkPiecewiseFunction * | GetScalarOpacity (int index)
vtkPiecewiseFunction * GetScalarOpacity ()
void | SetGradientOpacity (int index, vtkPiecewiseFunction *function)
void | SetGradientOpacity (vtkPiecewiseFunction *function)
vtkPiecewiseFunction * | GetGradientOpacity (int index)
vtkPiecewiseFunction * GetGradientOpacity ()
void | SetShade (int index, int value)
void | SetShade (int value)
int | GetShade (int index)
int | GetShade ()
void | ShadeOn (int index)
void | ShadeOn ()
void | ShadeOff (int index)
void | ShadeOff ()
void | SetAmbient (int index, float value)
void | SetAmbient (float value)
float | GetAmbient (int index)
float | GetAmbient ()
void | SetDiffuse (int index, float value)
void | SetDiffuse (float value)
float | GetDiffuse (int index)
float | GetDiffuse ()
void | SetSpecular (int index, float value)
void | SetSpecular (float value)
float | GetSpecular (int index)
float | GetSpecular ()
void | SetSpecularPower (int index, float value)
void | SetSpecularPower (float value)
float | GetSpecularPower (int index)
float | GetSpecularPower ()
vtkTimeStamp | GetGradientOpacityMTime (int index)
vtkTimeStamp GetGradientOpacityMTime ()
vtkTimeStamp | GetScalarOpacityMTime (int index)
vtkTimeStamp GetScalarOpacityMTime ()
vtkTimeStamp | GetRGBTransferFunctionMTime (int index)
vtkTimeStamp GetRGBTransferFunctionMTime ()
vtkTimeStamp | GetGrayTransferFunctionMTime (int index)
vtkTimeStamp GetGrayTransferFunctionMTime ()

Static Public Methods

vtkVolumeProperty * | New ()

Protected Methods

vtkVolumeProperty ()
~vtkVolumeProperty ()

Protected Attributes

int | InterpolationType
int | ColorChannels [4]
vtkPiecewiseFunction * | GrayTransferFunction [4]
vtkTimeStamp | GrayTransferFunctionMTime [4]
vtkColorTransferFunction * | RGBTransferFunction [4]
vtkTimeStamp | RGBTransferFunctionMTime [4]
vtkPiecewiseFunction * | ScalarOpacity [4]
vtkTimeStamp | ScalarOpacityMTime [4]
vtkPiecewiseFunction * | GradientOpacity [4]
vtkTimeStamp | GradientOpacityMTime [4]
int | Shade [4]
float | Ambient [4]
float | Diffuse [4]
float | Specular [4]
float | SpecularPower [4]

Detailed Description

represents the common properties for rendering a volume.

Date:
2002/03/05 20:16:11
Revision:
1.35

vtkVolumeProperty is used to represent common properties associated with volume rendering. This includes properties for determining the type of interpolation to use when sampling a volume, the color of a volume, the scalar opacity of a volume, the gradient opacity of a volume, and the shading parameters of a volume.

When the scalar opacity or the gradient opacity of a volume is not set, then the function is defined to be a constant value of 1.0. When a scalar and gradient opacity are both set simultaneously, then the opacity is defined to be the product of the scalar opacity and gradient opacity transfer functions.

Most properties can be set per "component" for volume mappers that support multiple independent components. If you are using 2 component data as LV or 4 component data as RGBV (as specified in the mapper) only the first scalar opacity and gradient opacity transfer functions will be used (and all color functions will be ignored). Omitting the index parameter on the Set/Get methods will access index = 0.

See also:
vtkPiecewiseFunction vtkColorTransferFunction
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (81%)
  • Law, Charles (5%)
  • Martin, Ken (5%)
Examples:
vtkVolumeProperty (Examples)
Tests:
vtkVolumeProperty (Tests)

Definition at line 74 of file vtkVolumeProperty.h.

Constructor & Destructor Documentation

vtkVolumeProperty::vtkVolumeProperty ( ) [protected]

vtkVolumeProperty::~vtkVolumeProperty ( ) [protected]

Member Function Documentation

vtkVolumeProperty* vtkVolumeProperty::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVolumeProperty::vtkTypeRevisionMacro | ( | vtkVolumeProperty | ,
 |  | vtkObject |
 | ) |

void vtkVolumeProperty::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

unsigned long vtkVolumeProperty::GetMTime ( ) [virtual]

Get the modified time for this object (or the properties registered with this object).

Reimplemented from vtkObject.

virtual void vtkVolumeProperty::SetInterpolationType ( int ) [virtual]

Set the interpolation type for sampling a volume.

virtual int vtkVolumeProperty::GetInterpolationType ( ) [virtual]

Set the interpolation type for sampling a volume.

void vtkVolumeProperty::SetInterpolationTypeToNearest ( ) [inline]

Set the interpolation type for sampling a volume.

Definition at line 91 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetInterpolationTypeToLinear ( ) [inline]

Set the interpolation type for sampling a volume.

Definition at line 93 of file vtkVolumeProperty.h.

const char * vtkVolumeProperty::GetInterpolationTypeAsString ( void ) [inline]

Return the interpolation type as a descriptive character string.

Definition at line 294 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetColor | ( | int | index,
 |  | vtkPiecewiseFunction * | function
 | ) |

Set the color of a volume to a gray level transfer function for the component indicated by index. This will set the color channels for this component to 1.

void vtkVolumeProperty::SetColor ( vtkPiecewiseFunction * f ) [inline]

Set the color of a volume to a gray level transfer function for the component indicated by index. This will set the color channels for this component to 1.

Definition at line 103 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetColor | ( | int | index,
 |  | vtkColorTransferFunction * | function
 | ) |

Set the color of a volume to an RGB transfer function for the component indicated by index. This will set the color channels for this component to 3. This will also recompute the color channels

void vtkVolumeProperty::SetColor ( vtkColorTransferFunction * f ) [inline]

Set the color of a volume to an RGB transfer function for the component indicated by index. This will set the color channels for this component to 3. This will also recompute the color channels

Definition at line 112 of file vtkVolumeProperty.h.

int vtkVolumeProperty::GetColorChannels ( int index )

Get the number of color channels in the transfer function for the given component.

int vtkVolumeProperty::GetColorChannels ( ) [inline]

Get the number of color channels in the transfer function for the given component.

Definition at line 119 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::GetGrayTransferFunction ( int index )

Get the gray transfer function.

vtkPiecewiseFunction* vtkVolumeProperty::GetGrayTransferFunction ( ) [inline]

Get the gray transfer function.

Definition at line 125 of file vtkVolumeProperty.h.

vtkColorTransferFunction* vtkVolumeProperty::GetRGBTransferFunction ( int index )

Get the RGB transfer function for the given component.

vtkColorTransferFunction* vtkVolumeProperty::GetRGBTransferFunction ( ) [inline]

Get the RGB transfer function for the given component.

Definition at line 132 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetScalarOpacity | ( | int | index,
 |  | vtkPiecewiseFunction * | function
 | ) |

Set the opacity of a volume to an opacity transfer function based on scalar value for the component indicated by index.

void vtkVolumeProperty::SetScalarOpacity ( vtkPiecewiseFunction * f ) [inline]

Set the opacity of a volume to an opacity transfer function based on scalar value for the component indicated by index.

Definition at line 140 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::GetScalarOpacity ( int index )

Get the scalar opacity transfer function for the given component.

vtkPiecewiseFunction* vtkVolumeProperty::GetScalarOpacity ( ) [inline]

Get the scalar opacity transfer function for the given component.

Definition at line 147 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetGradientOpacity | ( | int | index,
 |  | vtkPiecewiseFunction * | function
 | ) |

Set the opacity of a volume to an opacity transfer function based on gradient magnitude for the given component.

void vtkVolumeProperty::SetGradientOpacity ( vtkPiecewiseFunction * function ) [inline]

Set the opacity of a volume to an opacity transfer function based on gradient magnitude for the given component.

Definition at line 156 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::GetGradientOpacity ( int index )

Get the gradient magnitude opacity transfer function for the given component.

vtkPiecewiseFunction* vtkVolumeProperty::GetGradientOpacity ( ) [inline]

Get the gradient magnitude opacity transfer function for the given component.

Definition at line 164 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetShade | ( | int | index,
 |  | int | value
 | ) |

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

void vtkVolumeProperty::SetShade ( int value ) [inline]

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

Definition at line 178 of file vtkVolumeProperty.h.

int vtkVolumeProperty::GetShade ( int index )

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

int vtkVolumeProperty::GetShade ( ) [inline]

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

Definition at line 180 of file vtkVolumeProperty.h.

void vtkVolumeProperty::ShadeOn ( int index )

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

void vtkVolumeProperty::ShadeOn ( ) [inline]

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

Definition at line 182 of file vtkVolumeProperty.h.

void vtkVolumeProperty::ShadeOff ( int index )

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

void vtkVolumeProperty::ShadeOff ( ) [inline]

Set/Get the shading of a volume. If shading is turned off, then the mapper for the volume will not perform shading calculations. If shading is turned on, the mapper may perform shading calculations - in some cases shading does not apply (for example, in a maximum intensity projection) and therefore shading will not be performed even if this flag is on. For a compositing type of mapper, turning shading off is generally the same as setting ambient=1, diffuse=0, specular=0. Shading can be independently turned on/off per component.

Definition at line 184 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetAmbient | ( | int | index,
 |  | float | value
 | ) |

Set/Get the ambient lighting coefficient.

void vtkVolumeProperty::SetAmbient ( float value ) [inline]

Set/Get the ambient lighting coefficient.

Definition at line 191 of file vtkVolumeProperty.h.

float vtkVolumeProperty::GetAmbient ( int index )

Set/Get the ambient lighting coefficient.

float vtkVolumeProperty::GetAmbient ( ) [inline]

Set/Get the ambient lighting coefficient.

Definition at line 193 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetDiffuse | ( | int | index,
 |  | float | value
 | ) |

Set/Get the diffuse lighting coefficient.

void vtkVolumeProperty::SetDiffuse ( float value ) [inline]

Set/Get the diffuse lighting coefficient.

Definition at line 200 of file vtkVolumeProperty.h.

float vtkVolumeProperty::GetDiffuse ( int index )

Set/Get the diffuse lighting coefficient.

float vtkVolumeProperty::GetDiffuse ( ) [inline]

Set/Get the diffuse lighting coefficient.

Definition at line 202 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetSpecular | ( | int | index,
 |  | float | value
 | ) |

Set/Get the specular lighting coefficient.

void vtkVolumeProperty::SetSpecular ( float value ) [inline]

Set/Get the specular lighting coefficient.

Definition at line 208 of file vtkVolumeProperty.h.

float vtkVolumeProperty::GetSpecular ( int index )

Set/Get the specular lighting coefficient.

float vtkVolumeProperty::GetSpecular ( ) [inline]

Set/Get the specular lighting coefficient.

Definition at line 210 of file vtkVolumeProperty.h.

void vtkVolumeProperty::SetSpecularPower | ( | int | index,
 |  | float | value
 | ) |

Set/Get the specular power.

void vtkVolumeProperty::SetSpecularPower ( float value ) [inline]

Set/Get the specular power.

Definition at line 216 of file vtkVolumeProperty.h.

float vtkVolumeProperty::GetSpecularPower ( int index )

Set/Get the specular power.

float vtkVolumeProperty::GetSpecularPower ( ) [inline]

Set/Get the specular power.

Definition at line 218 of file vtkVolumeProperty.h.

void vtkVolumeProperty::UpdateMTimes ( )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE UpdateMTimes performs a Modified() on all TimeStamps. This is used by vtkVolume when the property is set, so that any other object that might have been caching information for the property will rebuild.

vtkTimeStamp vtkVolumeProperty::GetGradientOpacityMTime ( int index )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the gradient opacity transfer function was set

vtkTimeStamp vtkVolumeProperty::GetGradientOpacityMTime ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the gradient opacity transfer function was set

Definition at line 232 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::GetScalarOpacityMTime ( int index )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the scalar opacity transfer function was set.

vtkTimeStamp vtkVolumeProperty::GetScalarOpacityMTime ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the scalar opacity transfer function was set.

Definition at line 240 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::GetRGBTransferFunctionMTime ( int index )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the RGBTransferFunction was set

vtkTimeStamp vtkVolumeProperty::GetRGBTransferFunctionMTime ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the RGBTransferFunction was set

Definition at line 248 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::GetGrayTransferFunctionMTime ( int index )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the GrayTransferFunction was set

vtkTimeStamp vtkVolumeProperty::GetGrayTransferFunctionMTime ( ) [inline]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Get the time that the GrayTransferFunction was set

Definition at line 256 of file vtkVolumeProperty.h.

Member Data Documentation

int vtkVolumeProperty::InterpolationType [protected]

Definition at line 266 of file vtkVolumeProperty.h.

int vtkVolumeProperty::ColorChannels[4] [protected]

Definition at line 268 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::GrayTransferFunction[4] [protected]

Definition at line 270 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::GrayTransferFunctionMTime[4] [protected]

Definition at line 271 of file vtkVolumeProperty.h.

vtkColorTransferFunction* vtkVolumeProperty::RGBTransferFunction[4] [protected]

Definition at line 273 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::RGBTransferFunctionMTime[4] [protected]

Definition at line 274 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::ScalarOpacity[4] [protected]

Definition at line 276 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::ScalarOpacityMTime[4] [protected]

Definition at line 277 of file vtkVolumeProperty.h.

vtkPiecewiseFunction* vtkVolumeProperty::GradientOpacity[4] [protected]

Definition at line 279 of file vtkVolumeProperty.h.

vtkTimeStamp vtkVolumeProperty::GradientOpacityMTime[4] [protected]

Definition at line 280 of file vtkVolumeProperty.h.

int vtkVolumeProperty::Shade[4] [protected]

Definition at line 282 of file vtkVolumeProperty.h.

float vtkVolumeProperty::Ambient[4] [protected]

Definition at line 283 of file vtkVolumeProperty.h.

float vtkVolumeProperty::Diffuse[4] [protected]

Definition at line 284 of file vtkVolumeProperty.h.

float vtkVolumeProperty::Specular[4] [protected]

Definition at line 285 of file vtkVolumeProperty.h.

float vtkVolumeProperty::SpecularPower[4] [protected]

Definition at line 286 of file vtkVolumeProperty.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeProperty.h
Generated on Mon Mar 25 01:33:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProVG500Mapper Class Reference

Superclass for VG500 board. More...

#include <vtkVolumeProVG500Mapper.h>

Inheritance diagram for vtkVolumeProVG500Mapper:

[legend]
Collaboration diagram for vtkVolumeProVG500Mapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeProVG500Mapper, vtkVolumeProMapper)
virtual void | Render (vtkRenderer *, vtkVolume *)
virtual int | GetAvailableBoardMemory ()
virtual void | GetLockSizesForBoardMemory (unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize)

Static Public Methods

vtkVolumeProVG500Mapper * | New ()

Protected Methods

vtkVolumeProVG500Mapper ()
~vtkVolumeProVG500Mapper ()
void | UpdateCamera (vtkRenderer *, vtkVolume *)
void | UpdateLights (vtkRenderer *, vtkVolume *)
void | UpdateProperties (vtkRenderer *, vtkVolume *)
void | UpdateVolume (vtkRenderer *, vtkVolume *)
void | UpdateCropping (vtkRenderer *, vtkVolume *)
void | UpdateCursor (vtkRenderer *, vtkVolume *)
void | UpdateCutPlane (vtkRenderer *, vtkVolume *)
virtual void | RenderHexagon (vtkRenderer *vtkNotUsed(ren), vtkVolume *vtkNotUsed(vol), VLIPixel *vtkNotUsed(basePlane), int size[2], VLIVector3D hexagon[6], VLIVector2D textureCoords[6])
void | CorrectBasePlaneSize (VLIPixel *inBase, int inSize[2], VLIPixel **outBase, int outSize[2], VLIVector2D textureCoords[6])

Protected Attributes

int | LoadedDataSize [3]

Detailed Description

Superclass for VG500 board.

Date:
2002/01/22 15:39:36
Revision:
1.19

vtkVolumeProVG500Mapper is the superclass for VolumePRO volume rendering mappers based on the VG500 chip. Subclasses are for underlying graphics languages. Users should not create subclasses directly - a vtkVolumeProMapper will automatically create the object of the right type.

This class is not included in the Rendering CMakeLists by default. If you want to add this class to your vtk build, you need to have the vli header and library files, and you will need to perform the following steps:

1. Run cmake, and set the VTK_USE_VOLUMEPRO flag to true. 2. If the libary file (VLI_LIBRARY_FOR_VG500) is not found by cmake, set the path to that file, and rerun cmake. 3. If the header file (VLI_INCLUDE_PATH_FOR_VG500) is not found by cmake, set the path to that file, and rerun cmake. 4. Rebuild VTK.

For more information on the VolumePRO hardware, please see:

http://www.terarecon.com/3d_products.shtml

If you encounter any problems with this class, please inform Kitware, Inc. at kitware@kitware.com.

See also:
vtkVolumeMapper vtkVolumeProMapper vtkOpenGLVolumeProVG500Mapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Hoffman, Bill (63%)
  • Avila, Lisa (26%)

Definition at line 77 of file vtkVolumeProVG500Mapper.h.

Constructor & Destructor Documentation

vtkVolumeProVG500Mapper::vtkVolumeProVG500Mapper ( ) [protected]

vtkVolumeProVG500Mapper::~vtkVolumeProVG500Mapper ( ) [protected]

Member Function Documentation

vtkVolumeProVG500Mapper::vtkTypeRevisionMacro | ( | vtkVolumeProVG500Mapper | ,
 |  | vtkVolumeProMapper |
 | ) |

Reimplemented from vtkVolumeProMapper.

Reimplemented in vtkOpenGLVolumeProVG500Mapper.

vtkVolumeProVG500Mapper* vtkVolumeProVG500Mapper::New ( ) [static]

Automatically create the proper subclass

Reimplemented from vtkVolumeProMapper.

Reimplemented in vtkOpenGLVolumeProVG500Mapper.

virtual void vtkVolumeProVG500Mapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [virtual]

Render the image using the hardware and place it in the frame buffer

Reimplemented from vtkVolumeProMapper.

virtual int vtkVolumeProVG500Mapper::GetAvailableBoardMemory ( ) [virtual]

Render the image using the hardware and place it in the frame buffer

Reimplemented from vtkVolumeProMapper.

virtual void vtkVolumeProVG500Mapper::GetLockSizesForBoardMemory | ( | unsigned int | type,
 |  | unsigned int * | xSize,
 |  | unsigned int * | ySize,
 |  | unsigned int * | zSize
 | ) | [virtual]

Render the image using the hardware and place it in the frame buffer

void vtkVolumeProVG500Mapper::UpdateCamera | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateLights | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateProperties | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateVolume | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateCropping | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateCursor | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVG500Mapper::UpdateCutPlane | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

virtual void vtkVolumeProVG500Mapper::RenderHexagon | ( | vtkRenderer *vtkNotUsed(ren) | ,
 |  | vtkVolume *vtkNotUsed(vol) | ,
 |  | VLIPixel *vtkNotUsed(basePlane) | ,
 |  | int | size[2],
 |  | VLIVector3D | hexagon[6],
 |  | VLIVector2D | textureCoords[6]
 | ) | [inline, protected, virtual]

Definition at line 120 of file vtkVolumeProVG500Mapper.h.

void vtkVolumeProVG500Mapper::CorrectBasePlaneSize | ( | VLIPixel * | inBase,
 |  | int | inSize[2],
 |  | VLIPixel ** | outBase,
 |  | int | outSize[2],
 |  | VLIVector2D | textureCoords[6]
 | ) | [protected]

Member Data Documentation

int vtkVolumeProVG500Mapper::LoadedDataSize[3] [protected]

Definition at line 136 of file vtkVolumeProVG500Mapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeProVG500Mapper.h
Generated on Mon Mar 25 01:33:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeProVP1000Mapper Class Reference

Superclass for VP1000 board. More...

#include <vtkVolumeProVP1000Mapper.h>

Inheritance diagram for vtkVolumeProVP1000Mapper:

[legend]
Collaboration diagram for vtkVolumeProVP1000Mapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeProVP1000Mapper, vtkVolumeProMapper)
virtual void | Render (vtkRenderer *, vtkVolume *)
virtual int | GetAvailableBoardMemory ()
virtual void | GetLockSizesForBoardMemory (unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize)

Static Public Methods

vtkVolumeProVP1000Mapper * | New ()

Protected Methods

vtkVolumeProVP1000Mapper ()
~vtkVolumeProVP1000Mapper ()
vtkVolumeProVP1000Mapper (const vtkVolumeProVP1000Mapper &)
void | operator= (const vtkVolumeProVP1000Mapper &)
void | UpdateCamera (vtkRenderer *, vtkVolume *)
void | UpdateLights (vtkRenderer *, vtkVolume *)
void | UpdateProperties (vtkRenderer *, vtkVolume *)
void | UpdateVolume (vtkRenderer *, vtkVolume *)
void | UpdateCropping (vtkRenderer *, vtkVolume *)
void | UpdateCursor (vtkRenderer *, vtkVolume *)
void | UpdateCutPlane (vtkRenderer *, vtkVolume *)
virtual void | RenderImageBuffer (vtkRenderer *vtkNotUsed(ren), vtkVolume *vol, int size[2], unsigned int *outData)
virtual void | RenderBoundingBox (vtkRenderer *vtkNotUsed(ren), vtkVolume *vol)
virtual void | GetDepthBufferValues (vtkRenderer *vtkNotUsed(ren), int size[2], unsigned int *outData)
VLIStatus | CheckSubSampling (const VLIVolume *inVolume, const VLIContext *inContext, int &outImageWidth, int &outImageHeight)

Protected Attributes

int | LoadedDataSize [3]
VLIImageBuffer * | ImageBuffer
VLIDepthBuffer * | DepthBuffer
int | DrawBoundingBox

Detailed Description

Superclass for VP1000 board.

Date:
2002/02/01 16:31:04
Revision:
1.7

vtkVolumeProVP1000Mapper is the superclass for VolumePRO volume rendering mappers based on the VP1000 chip. Subclasses are for underlying graphics languages. Users should not create subclasses directly - a vtkVolumeProMapper will automatically create the object of the right type.

This class is not included in the Rendering CMakeLists by default. If you want to add this class to your vtk build, you need to have the vli header and library files, and you will need to perform the following steps:

1. Run cmake, and set the VTK_USE_VOLUMEPRO flag to true. 2. If the libary file (VLI_LIBRARY_FOR_VP1000) is not found by cmake, set the path to that file, and rerun cmake. 3. If the header file (VLI_INCLUDE_PATH_FOR_VP1000) is not found by cmake, set the path to that file, and rerun cmake. 4. Rebuild VTK.

For more information on the VolumePRO hardware, please see:

http://www.terarecon.com/3d_products.shtml

If you encounter any problems with this class, please inform Kitware, Inc. at kitware@kitware.com.

See also:
vtkVolumeMapper vtkVolumeProMapper vtkOpenGLVolumeProVP1000Mapper
Created by:
  • Henderson, Amy
Contributed by (if > 5%):
  • Henderson, Amy (96%)

Definition at line 73 of file vtkVolumeProVP1000Mapper.h.

Constructor & Destructor Documentation

vtkVolumeProVP1000Mapper::vtkVolumeProVP1000Mapper ( ) [protected]

vtkVolumeProVP1000Mapper::~vtkVolumeProVP1000Mapper ( ) [protected]

vtkVolumeProVP1000Mapper::vtkVolumeProVP1000Mapper ( const vtkVolumeProVP1000Mapper & ) [protected]

Member Function Documentation

vtkVolumeProVP1000Mapper::vtkTypeRevisionMacro | ( | vtkVolumeProVP1000Mapper | ,
 |  | vtkVolumeProMapper |
 | ) |

Reimplemented from vtkVolumeProMapper.

Reimplemented in vtkOpenGLVolumeProVP1000Mapper.

vtkVolumeProVP1000Mapper* vtkVolumeProVP1000Mapper::New ( ) [static]

Automatically create the proper subclass

Reimplemented from vtkVolumeProMapper.

Reimplemented in vtkOpenGLVolumeProVP1000Mapper.

virtual void vtkVolumeProVP1000Mapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [virtual]

Render the image using the hardware and place it in the frame buffer

Reimplemented from vtkVolumeProMapper.

virtual int vtkVolumeProVP1000Mapper::GetAvailableBoardMemory ( ) [virtual]

Render the image using the hardware and place it in the frame buffer

Reimplemented from vtkVolumeProMapper.

virtual void vtkVolumeProVP1000Mapper::GetLockSizesForBoardMemory | ( | unsigned int | type,
 |  | unsigned int * | xSize,
 |  | unsigned int * | ySize,
 |  | unsigned int * | zSize
 | ) | [virtual]

Render the image using the hardware and place it in the frame buffer

void vtkVolumeProVP1000Mapper::operator= ( const vtkVolumeProVP1000Mapper & ) [protected]

void vtkVolumeProVP1000Mapper::UpdateCamera | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateLights | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateProperties | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateVolume | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateCropping | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateCursor | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

void vtkVolumeProVP1000Mapper::UpdateCutPlane | ( | vtkRenderer * | ,
 |  | vtkVolume * |
 | ) | [protected]

virtual void vtkVolumeProVP1000Mapper::RenderImageBuffer | ( | vtkRenderer *vtkNotUsed(ren) | ,
 |  | vtkVolume * | vol,
 |  | int | size[2],
 |  | unsigned int * | outData
 | ) | [inline, protected, virtual]

Definition at line 119 of file vtkVolumeProVP1000Mapper.h.

virtual void vtkVolumeProVP1000Mapper::RenderBoundingBox | ( | vtkRenderer *vtkNotUsed(ren) | ,
 |  | vtkVolume * | vol
 | ) | [inline, protected, virtual]

Definition at line 127 of file vtkVolumeProVP1000Mapper.h.

virtual void vtkVolumeProVP1000Mapper::GetDepthBufferValues | ( | vtkRenderer *vtkNotUsed(ren) | ,
 |  | int | size[2],
 |  | unsigned int * | outData
 | ) | [inline, protected, virtual]

Definition at line 132 of file vtkVolumeProVP1000Mapper.h.

VLIStatus vtkVolumeProVP1000Mapper::CheckSubSampling | ( | const VLIVolume * | inVolume,
 |  | const VLIContext * | inContext,
 |  | int & | outImageWidth,
 |  | int & | outImageHeight
 | ) | [protected]

Member Data Documentation

int vtkVolumeProVP1000Mapper::LoadedDataSize[3] [protected]

Definition at line 147 of file vtkVolumeProVP1000Mapper.h.

VLIImageBuffer* vtkVolumeProVP1000Mapper::ImageBuffer [protected]

Definition at line 149 of file vtkVolumeProVP1000Mapper.h.

VLIDepthBuffer* vtkVolumeProVP1000Mapper::DepthBuffer [protected]

Definition at line 150 of file vtkVolumeProVP1000Mapper.h.

int vtkVolumeProVP1000Mapper::DrawBoundingBox [protected]

Definition at line 156 of file vtkVolumeProVP1000Mapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeProVP1000Mapper.h
Generated on Mon Mar 25 01:33:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastCompositeFunction Class Reference

a ray function for compositing. More...

#include <vtkVolumeRayCastCompositeFunction.h>

Inheritance diagram for vtkVolumeRayCastCompositeFunction:

[legend]
Collaboration diagram for vtkVolumeRayCastCompositeFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastFunction)
void | PrintSelf (ostream &os, vtkIndent index)
void | CastRay (VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)
float | GetZeroOpacityThreshold (vtkVolume *vol)
virtual void | SetCompositeMethod (int)
virtual int | GetCompositeMethod ()
void | SetCompositeMethodToInterpolateFirst ()
void | SetCompositeMethodToClassifyFirst ()
const char * | GetCompositeMethodAsString (void)

Static Public Methods

vtkVolumeRayCastCompositeFunction * | New ()

Protected Methods

vtkVolumeRayCastCompositeFunction ()
~vtkVolumeRayCastCompositeFunction ()
void | SpecificFunctionInitialize (vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper)

Protected Attributes

int | CompositeMethod

Detailed Description

a ray function for compositing.

Date:
2002/01/22 15:39:38
Revision:
1.27

vtkVolumeRayCastCompositeFunction is a ray function that can be used within a vtkVolumeRayCastMapper. This function performs compositing along the ray according to the properties stored in the vtkVolumeProperty for the volume.

See also:
vtkVolumeRayCastMapper vtkVolumeProperty vtkVolume
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (94%)
Examples:
vtkVolumeRayCastCompositeFunction (Examples)
Tests:
vtkVolumeRayCastCompositeFunction (Tests)

Definition at line 52 of file vtkVolumeRayCastCompositeFunction.h.

Constructor & Destructor Documentation

vtkVolumeRayCastCompositeFunction::vtkVolumeRayCastCompositeFunction ( ) [protected]

vtkVolumeRayCastCompositeFunction::~vtkVolumeRayCastCompositeFunction ( ) [protected]

Member Function Documentation

vtkVolumeRayCastCompositeFunction* vtkVolumeRayCastCompositeFunction::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVolumeRayCastCompositeFunction::vtkTypeRevisionMacro | ( | vtkVolumeRayCastCompositeFunction | ,
 |  | vtkVolumeRayCastFunction |
 | ) |

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastCompositeFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

virtual void vtkVolumeRayCastCompositeFunction::SetCompositeMethod ( int ) [virtual]

Set the CompositeMethod to either Classify First or Interpolate First

virtual int vtkVolumeRayCastCompositeFunction::GetCompositeMethod ( ) [virtual]

Set the CompositeMethod to either Classify First or Interpolate First

void vtkVolumeRayCastCompositeFunction::SetCompositeMethodToInterpolateFirst ( ) [inline]

Set the CompositeMethod to either Classify First or Interpolate First

Definition at line 64 of file vtkVolumeRayCastCompositeFunction.h.

void vtkVolumeRayCastCompositeFunction::SetCompositeMethodToClassifyFirst ( ) [inline]

Set the CompositeMethod to either Classify First or Interpolate First

Definition at line 66 of file vtkVolumeRayCastCompositeFunction.h.

const char* vtkVolumeRayCastCompositeFunction::GetCompositeMethodAsString ( void )

Set the CompositeMethod to either Classify First or Interpolate First

void vtkVolumeRayCastCompositeFunction::CastRay | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) | [virtual]

Reimplemented from vtkVolumeRayCastFunction.

float vtkVolumeRayCastCompositeFunction::GetZeroOpacityThreshold ( vtkVolume * vol ) [virtual]

Get the value below which all scalar values are considered to have 0 opacity.

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastCompositeFunction::SpecificFunctionInitialize | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VTKVRCStaticInfo * | staticInfo,
 |  | vtkVolumeRayCastMapper * | mapper
 | ) | [protected, virtual]

This method gives the subclass a chance to do any special initialization that it may need to do BTX

Reimplemented from vtkVolumeRayCastFunction.

Member Data Documentation

int vtkVolumeRayCastCompositeFunction::CompositeMethod [protected]

Definition at line 89 of file vtkVolumeRayCastCompositeFunction.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastCompositeFunction.h
Generated on Mon Mar 25 01:33:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastFunction Class Reference

a superclass for ray casting functions. More...

#include <vtkVolumeRayCastFunction.h>

Inheritance diagram for vtkVolumeRayCastFunction:

[legend]
Collaboration diagram for vtkVolumeRayCastFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeRayCastFunction, vtkObject)
virtual void | CastRay (VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)=0
virtual float | GetZeroOpacityThreshold (vtkVolume *vol)=0
void | FunctionInitialize (vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo)

Protected Methods

vtkVolumeRayCastFunction ()
~vtkVolumeRayCastFunction ()
virtual void | SpecificFunctionInitialize (vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper)=0

Detailed Description

a superclass for ray casting functions.

Date:
2002/03/05 20:16:11
Revision:
1.27

vtkVolumeRayCastFunction is a superclass for ray casting functions that can be used within a vtkVolumeRayCastMapper. This includes for example, vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastMIPFunction, and vtkVolumeRayCastIsosurfaceFunction.

See also:
vtkVolumeRayCastCompositeFunction vtkVolumeRayCastMIPFunction vtkVolumeRayCastIsosurfaceFunction vtkVolumeRayCastMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (96%)

Definition at line 142 of file vtkVolumeRayCastFunction.h.

Constructor & Destructor Documentation

vtkVolumeRayCastFunction::vtkVolumeRayCastFunction ( ) [inline, protected]

Definition at line 167 of file vtkVolumeRayCastFunction.h.

vtkVolumeRayCastFunction::~vtkVolumeRayCastFunction ( ) [inline, protected]

Definition at line 168 of file vtkVolumeRayCastFunction.h.

Member Function Documentation

vtkVolumeRayCastFunction::vtkTypeRevisionMacro | ( | vtkVolumeRayCastFunction | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, and vtkVolumeRayCastMIPFunction.

void vtkVolumeRayCastFunction::FunctionInitialize | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) |

Do the basic initialization. This includes saving the parameters passed in into local variables, as well as grabbing some useful info from the volume property and normal encoder. This initialize routine is called once per render. It also calls the SpecificFunctionInitialize of the subclass function. BTX

virtual void vtkVolumeRayCastFunction::CastRay | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) | [pure virtual]

Reimplemented in vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, and vtkVolumeRayCastMIPFunction.

virtual float vtkVolumeRayCastFunction::GetZeroOpacityThreshold ( vtkVolume * vol ) [pure virtual]

Get the value below which all scalar values are considered to have 0 opacity.

Reimplemented in vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, and vtkVolumeRayCastMIPFunction.

virtual void vtkVolumeRayCastFunction::SpecificFunctionInitialize | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VTKVRCStaticInfo * | staticInfo,
 |  | vtkVolumeRayCastMapper * | mapper
 | ) | [protected, pure virtual]

This method gives the subclass a chance to do any special initialization that it may need to do BTX

Reimplemented in vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastIsosurfaceFunction, and vtkVolumeRayCastMIPFunction.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastFunction.h
Generated on Mon Mar 25 01:33:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastIsosurfaceFunction Class Reference

An isosurface ray caster for volumes. More...

#include <vtkVolumeRayCastIsosurfaceFunction.h>

Inheritance diagram for vtkVolumeRayCastIsosurfaceFunction:

[legend]
Collaboration diagram for vtkVolumeRayCastIsosurfaceFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction)
void | PrintSelf (ostream &os, vtkIndent index)
float | GetZeroOpacityThreshold (vtkVolume *vol)
void | CastRay (VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)
virtual void | SetIsoValue (float)
virtual float | GetIsoValue ()

Static Public Methods

vtkVolumeRayCastIsosurfaceFunction * | New ()

Public Attributes

float | IsoValue
float | Color [3]

Protected Methods

vtkVolumeRayCastIsosurfaceFunction ()
~vtkVolumeRayCastIsosurfaceFunction ()
void | SpecificFunctionInitialize (vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper)

Detailed Description

An isosurface ray caster for volumes.

Date:
2002/01/22 15:39:39
Revision:
1.25

vtkVolumeRayCastIsosurfaceFunction is a volume ray cast function that intersects a ray with an analytic isosurface in a scalar field. The color and shading parameters are defined in the vtkVolumeProperty of the vtkVolume, as well as the interpolation type to use when locating the surface (either a nearest neighbor approach or a tri-linear interpolation approach)

See also:
vtkVolumeRayCastFunction vtkVolumeRayCastMapper vtkVolumeProperty vtkVolumeRayCastCompositeFunction vtkVolumeRayCastMIPFunction vtkVolume vtkVolumeProperty
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (58%)
  • Avila, Lisa (38%)
Tests:
vtkVolumeRayCastIsosurfaceFunction (Tests)

Definition at line 51 of file vtkVolumeRayCastIsosurfaceFunction.h.

Constructor & Destructor Documentation

vtkVolumeRayCastIsosurfaceFunction::vtkVolumeRayCastIsosurfaceFunction ( ) [protected]

vtkVolumeRayCastIsosurfaceFunction::~vtkVolumeRayCastIsosurfaceFunction ( ) [protected]

Member Function Documentation

vtkVolumeRayCastIsosurfaceFunction::vtkTypeRevisionMacro | ( | vtkVolumeRayCastIsosurfaceFunction | ,
 |  | vtkVolumeRayCastFunction |
 | ) |

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastIsosurfaceFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkVolumeRayCastIsosurfaceFunction* vtkVolumeRayCastIsosurfaceFunction::New ( ) [static]

Construct a new vtkVolumeRayCastIsosurfaceFunction

Reimplemented from vtkObject.

float vtkVolumeRayCastIsosurfaceFunction::GetZeroOpacityThreshold ( vtkVolume * vol ) [virtual]

Get the scalar value below which all scalar values have 0 opacity

Reimplemented from vtkVolumeRayCastFunction.

virtual void vtkVolumeRayCastIsosurfaceFunction::SetIsoValue ( float ) [virtual]

Set/Get the value of IsoValue.

virtual float vtkVolumeRayCastIsosurfaceFunction::GetIsoValue ( ) [virtual]

Set/Get the value of IsoValue.

void vtkVolumeRayCastIsosurfaceFunction::CastRay | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) | [virtual]

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastIsosurfaceFunction::SpecificFunctionInitialize | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VTKVRCStaticInfo * | staticInfo,
 |  | vtkVolumeRayCastMapper * | mapper
 | ) | [protected, virtual]

This method gives the subclass a chance to do any special initialization that it may need to do BTX

Reimplemented from vtkVolumeRayCastFunction.

Member Data Documentation

float vtkVolumeRayCastIsosurfaceFunction::IsoValue

This is the isovalue at which to view a surface

Definition at line 71 of file vtkVolumeRayCastIsosurfaceFunction.h.

float vtkVolumeRayCastIsosurfaceFunction::Color[3]

These variables are filled in by SpecificFunctionInitialize

Definition at line 74 of file vtkVolumeRayCastIsosurfaceFunction.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastIsosurfaceFunction.h
Generated on Mon Mar 25 01:33:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastMapper Class Reference

A slow but accurate mapper for rendering volumes. More...

#include <vtkVolumeRayCastMapper.h>

Inheritance diagram for vtkVolumeRayCastMapper:

[legend]
Collaboration diagram for vtkVolumeRayCastMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeRayCastMapper, vtkVolumeMapper)
void | PrintSelf (ostream &os, vtkIndent index)
void | Render (vtkRenderer *, vtkVolume *)
void | ReleaseGraphicsResources (vtkWindow *)
float | GetZeroOpacityThreshold (vtkVolume *vol)
virtual void | SetSampleDistance (float)
virtual float | GetSampleDistance ()
virtual void | SetVolumeRayCastFunction (vtkVolumeRayCastFunction *)
virtual vtkVolumeRayCastFunction * | GetVolumeRayCastFunction ()
void | SetGradientEstimator (vtkEncodedGradientEstimator *gradest)
virtual vtkEncodedGradientEstimator * | GetGradientEstimator ()
virtual vtkEncodedGradientShader * | GetGradientShader ()
virtual void | SetImageSampleDistance (float)
virtual float | GetImageSampleDistance ()
virtual void | SetMinimumImageSampleDistance (float)
virtual float | GetMinimumImageSampleDistance ()
virtual void | SetMaximumImageSampleDistance (float)
virtual float | GetMaximumImageSampleDistance ()
virtual void | SetAutoAdjustSampleDistances (int)
virtual int | GetAutoAdjustSampleDistances ()
virtual void | AutoAdjustSampleDistancesOn ()
virtual void | AutoAdjustSampleDistancesOff ()
void | SetNumberOfThreads (int num)
virtual int | GetNumberOfThreads ()
virtual void | SetIntermixIntersectingGeometry (int)
virtual int | GetIntermixIntersectingGeometry ()
virtual void | IntermixIntersectingGeometryOn ()
virtual void | IntermixIntersectingGeometryOff ()
virtual float | GetGradientMagnitudeScale ()
virtual float | GetGradientMagnitudeBias ()

Static Public Methods

vtkVolumeRayCastMapper * | New ()

Protected Methods

vtkVolumeRayCastMapper ()
~vtkVolumeRayCastMapper ()
void | UpdateShadingTables (vtkRenderer *ren, vtkVolume *vol)
void | ComputeMatrices (vtkImageData *data, vtkVolume *vol)
virtual void | RenderTexture (vtkVolume *vol, vtkRenderer *ren)=0
int | ComputeRowBounds (vtkVolume *vol, vtkRenderer *ren)
void | StoreRenderTime (vtkRenderer *ren, vtkVolume *vol, float t)
float | RetrieveRenderTime (vtkRenderer *ren, vtkVolume *vol)
int | ClipRayAgainstVolume (VTKVRCDynamicInfo *dynamicInfo, float bounds[6])
void | InitializeClippingPlanes (VTKVRCStaticInfo *staticInfo, vtkPlaneCollection *planes)
int | ClipRayAgainstClippingPlanes (VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)
float | GetZBufferValue (int x, int y)

Protected Attributes

vtkVolumeRayCastFunction * VolumeRayCastFunction
vtkEncodedGradientEstimator * GradientEstimator
vtkEncodedGradientShader * GradientShader
float | SampleDistance
float | ImageSampleDistance
float | MinimumImageSampleDistance
float | MaximumImageSampleDistance
int | AutoAdjustSampleDistances
float | WorldSampleDistance
int | ScalarDataType
void * | ScalarDataPointer
vtkMultiThreader * Threader
int | NumberOfThreads
vtkMatrix4x4 * PerspectiveMatrix
vtkMatrix4x4 * ViewToWorldMatrix
vtkMatrix4x4 * ViewToVoxelsMatrix
vtkMatrix4x4 * VoxelsToViewMatrix
vtkMatrix4x4 * WorldToVoxelsMatrix
vtkMatrix4x4 * VoxelsToWorldMatrix
int | ImageViewportSize [2]
int | ImageMemorySize [2]
int | ImageInUseSize [2]
int | ImageOrigin [2]
unsigned char * | Image
int * | RowBounds
int * | OldRowBounds
float * | RenderTimeTable
vtkVolume ** RenderVolumeTable
vtkRenderer ** RenderRendererTable
int | RenderTableSize
int | RenderTableEntries
int | IntermixIntersectingGeometry
float * | ZBuffer
int | ZBufferSize [2]
int | ZBufferOrigin [2]
float | MinimumViewDistance

Friends

VTK_THREAD_RETURN_TYPE | VolumeRayCastMapper_CastRays (void *arg)

Detailed Description

A slow but accurate mapper for rendering volumes.

Date:
2002/03/05 20:16:13
Revision:
1.45

This is a software ray caster for rendering volumes in vtkImageData.

See also:
vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (94%)
Examples:
vtkVolumeRayCastMapper (Examples)
Tests:
vtkVolumeRayCastMapper (Tests)

Definition at line 75 of file vtkVolumeRayCastMapper.h.

Constructor & Destructor Documentation

vtkVolumeRayCastMapper::vtkVolumeRayCastMapper ( ) [protected]

vtkVolumeRayCastMapper::~vtkVolumeRayCastMapper ( ) [protected]

Member Function Documentation

vtkVolumeRayCastMapper* vtkVolumeRayCastMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkMesaVolumeRayCastMapper, and vtkOpenGLVolumeRayCastMapper.

vtkVolumeRayCastMapper::vtkTypeRevisionMacro | ( | vtkVolumeRayCastMapper | ,
 |  | vtkVolumeMapper |
 | ) |

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkMesaVolumeRayCastMapper, and vtkOpenGLVolumeRayCastMapper.

void vtkVolumeRayCastMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeMapper.

virtual void vtkVolumeRayCastMapper::SetSampleDistance ( float ) [virtual]

Set/Get the distance between samples. This variable is only used for sampling ray casting methods. Methods that compute a ray value by stepping cell-by-cell are not affected by this value.

virtual float vtkVolumeRayCastMapper::GetSampleDistance ( ) [virtual]

Set/Get the distance between samples. This variable is only used for sampling ray casting methods. Methods that compute a ray value by stepping cell-by-cell are not affected by this value.

virtual void vtkVolumeRayCastMapper::SetVolumeRayCastFunction ( vtkVolumeRayCastFunction * ) [virtual]

Get / Set the volume ray cast function. This is used to process values found along the ray to compute a final pixel value.

virtual vtkVolumeRayCastFunction* vtkVolumeRayCastMapper::GetVolumeRayCastFunction ( ) [virtual]

Get / Set the volume ray cast function. This is used to process values found along the ray to compute a final pixel value.

void vtkVolumeRayCastMapper::SetGradientEstimator ( vtkEncodedGradientEstimator * gradest )

Set / Get the gradient estimator used to estimate normals

virtual vtkEncodedGradientEstimator* vtkVolumeRayCastMapper::GetGradientEstimator ( ) [virtual]

Set / Get the gradient estimator used to estimate normals

virtual vtkEncodedGradientShader* vtkVolumeRayCastMapper::GetGradientShader ( ) [virtual]

Get the gradient shader.

virtual void vtkVolumeRayCastMapper::SetImageSampleDistance ( float ) [virtual]

Sampling distance in the XY image dimensions. Default value of 1 meaning 1 ray cast per pixel. If set to 0.5, 4 rays will be cast per pixel. If set to 2.0, 1 ray will be cast for every 4 (2 by 2) pixels.

virtual float vtkVolumeRayCastMapper::GetImageSampleDistance ( ) [virtual]

Sampling distance in the XY image dimensions. Default value of 1 meaning 1 ray cast per pixel. If set to 0.5, 4 rays will be cast per pixel. If set to 2.0, 1 ray will be cast for every 4 (2 by 2) pixels.

virtual void vtkVolumeRayCastMapper::SetMinimumImageSampleDistance ( float ) [virtual]

This is the minimum image sample distance allow when the image sample distance is being automatically adjusted

virtual float vtkVolumeRayCastMapper::GetMinimumImageSampleDistance ( ) [virtual]

This is the minimum image sample distance allow when the image sample distance is being automatically adjusted

virtual void vtkVolumeRayCastMapper::SetMaximumImageSampleDistance ( float ) [virtual]

This is the maximum image sample distance allow when the image sample distance is being automatically adjusted

virtual float vtkVolumeRayCastMapper::GetMaximumImageSampleDistance ( ) [virtual]

This is the maximum image sample distance allow when the image sample distance is being automatically adjusted

virtual void vtkVolumeRayCastMapper::SetAutoAdjustSampleDistances ( int ) [virtual]

If AutoAdjustSampleDistances is on, the the ImageSampleDistance will be varied to achieve the allocated render time of this prop (controlled by the desired update rate and any culling in use).

virtual int vtkVolumeRayCastMapper::GetAutoAdjustSampleDistances ( ) [virtual]

If AutoAdjustSampleDistances is on, the the ImageSampleDistance will be varied to achieve the allocated render time of this prop (controlled by the desired update rate and any culling in use).

virtual void vtkVolumeRayCastMapper::AutoAdjustSampleDistancesOn ( ) [virtual]

If AutoAdjustSampleDistances is on, the the ImageSampleDistance will be varied to achieve the allocated render time of this prop (controlled by the desired update rate and any culling in use).

virtual void vtkVolumeRayCastMapper::AutoAdjustSampleDistancesOff ( ) [virtual]

If AutoAdjustSampleDistances is on, the the ImageSampleDistance will be varied to achieve the allocated render time of this prop (controlled by the desired update rate and any culling in use).

void vtkVolumeRayCastMapper::SetNumberOfThreads ( int num )

Set/Get the number of threads to use. This by default is equal to the number of available processors detected.

virtual int vtkVolumeRayCastMapper::GetNumberOfThreads ( ) [virtual]

Set/Get the number of threads to use. This by default is equal to the number of available processors detected.

virtual void vtkVolumeRayCastMapper::SetIntermixIntersectingGeometry ( int ) [virtual]

If IntermixIntersectingGeometry is turned on, the zbuffer will be captured and used to limit the traversal of the rays.

virtual int vtkVolumeRayCastMapper::GetIntermixIntersectingGeometry ( ) [virtual]

If IntermixIntersectingGeometry is turned on, the zbuffer will be captured and used to limit the traversal of the rays.

virtual void vtkVolumeRayCastMapper::IntermixIntersectingGeometryOn ( ) [virtual]

If IntermixIntersectingGeometry is turned on, the zbuffer will be captured and used to limit the traversal of the rays.

virtual void vtkVolumeRayCastMapper::IntermixIntersectingGeometryOff ( ) [virtual]

If IntermixIntersectingGeometry is turned on, the zbuffer will be captured and used to limit the traversal of the rays.

void vtkVolumeRayCastMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Initialize rendering for this volume.

Reimplemented from vtkVolumeMapper.

void vtkVolumeRayCastMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Release any graphics resources that are being consumed by this mapper. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkVolumeMapper.

float vtkVolumeRayCastMapper::GetZeroOpacityThreshold ( vtkVolume * vol )

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Return the scalar value below which all opacities are zero

virtual float vtkVolumeRayCastMapper::GetGradientMagnitudeScale ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Values needed by the volume

Reimplemented from vtkVolumeMapper.

virtual float vtkVolumeRayCastMapper::GetGradientMagnitudeBias ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Values needed by the volume

Reimplemented from vtkVolumeMapper.

void vtkVolumeRayCastMapper::UpdateShadingTables | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [protected]

void vtkVolumeRayCastMapper::ComputeMatrices | ( | vtkImageData * | data,
 |  | vtkVolume * | vol
 | ) | [protected]

virtual void vtkVolumeRayCastMapper::RenderTexture | ( | vtkVolume * | vol,
 |  | vtkRenderer * | ren
 | ) | [protected, pure virtual]

Reimplemented in vtkMesaVolumeRayCastMapper, and vtkOpenGLVolumeRayCastMapper.

int vtkVolumeRayCastMapper::ComputeRowBounds | ( | vtkVolume * | vol,
 |  | vtkRenderer * | ren
 | ) | [protected]

void vtkVolumeRayCastMapper::StoreRenderTime | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | float | t
 | ) | [protected]

float vtkVolumeRayCastMapper::RetrieveRenderTime | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [protected]

int vtkVolumeRayCastMapper::ClipRayAgainstVolume | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | float | bounds[6]
 | ) | [protected]

void vtkVolumeRayCastMapper::InitializeClippingPlanes | ( | VTKVRCStaticInfo * | staticInfo,
 |  | vtkPlaneCollection * | planes
 | ) | [protected]

int vtkVolumeRayCastMapper::ClipRayAgainstClippingPlanes | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) | [protected]

float vtkVolumeRayCastMapper::GetZBufferValue | ( | int | x,
 |  | int | y
 | ) | [protected]

Friends And Related Function Documentation

VTK_THREAD_RETURN_TYPE VolumeRayCastMapper_CastRays ( void * arg ) [friend]

Member Data Documentation

vtkVolumeRayCastFunction* vtkVolumeRayCastMapper::VolumeRayCastFunction [protected]

Definition at line 182 of file vtkVolumeRayCastMapper.h.

vtkEncodedGradientEstimator* vtkVolumeRayCastMapper::GradientEstimator [protected]

Definition at line 183 of file vtkVolumeRayCastMapper.h.

vtkEncodedGradientShader* vtkVolumeRayCastMapper::GradientShader [protected]

Definition at line 184 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::SampleDistance [protected]

Definition at line 187 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::ImageSampleDistance [protected]

Definition at line 188 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::MinimumImageSampleDistance [protected]

Definition at line 189 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::MaximumImageSampleDistance [protected]

Definition at line 190 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::AutoAdjustSampleDistances [protected]

Definition at line 191 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::WorldSampleDistance [protected]

Definition at line 193 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ScalarDataType [protected]

Definition at line 194 of file vtkVolumeRayCastMapper.h.

void* vtkVolumeRayCastMapper::ScalarDataPointer [protected]

Definition at line 195 of file vtkVolumeRayCastMapper.h.

vtkMultiThreader* vtkVolumeRayCastMapper::Threader [protected]

Definition at line 206 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::NumberOfThreads [protected]

Definition at line 207 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::PerspectiveMatrix [protected]

Definition at line 209 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::ViewToWorldMatrix [protected]

Definition at line 210 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::ViewToVoxelsMatrix [protected]

Definition at line 211 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::VoxelsToViewMatrix [protected]

Definition at line 212 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::WorldToVoxelsMatrix [protected]

Definition at line 213 of file vtkVolumeRayCastMapper.h.

vtkMatrix4x4* vtkVolumeRayCastMapper::VoxelsToWorldMatrix [protected]

Definition at line 214 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ImageViewportSize[2] [protected]

Definition at line 217 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ImageMemorySize[2] [protected]

Definition at line 223 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ImageInUseSize[2] [protected]

Definition at line 229 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ImageOrigin[2] [protected]

Definition at line 233 of file vtkVolumeRayCastMapper.h.

unsigned char* vtkVolumeRayCastMapper::Image [protected]

Definition at line 236 of file vtkVolumeRayCastMapper.h.

int* vtkVolumeRayCastMapper::RowBounds [protected]

Definition at line 238 of file vtkVolumeRayCastMapper.h.

int* vtkVolumeRayCastMapper::OldRowBounds [protected]

Definition at line 239 of file vtkVolumeRayCastMapper.h.

float* vtkVolumeRayCastMapper::RenderTimeTable [protected]

Definition at line 241 of file vtkVolumeRayCastMapper.h.

vtkVolume** vtkVolumeRayCastMapper::RenderVolumeTable [protected]

Definition at line 242 of file vtkVolumeRayCastMapper.h.

vtkRenderer** vtkVolumeRayCastMapper::RenderRendererTable [protected]

Definition at line 243 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::RenderTableSize [protected]

Definition at line 244 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::RenderTableEntries [protected]

Definition at line 245 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::IntermixIntersectingGeometry [protected]

Definition at line 250 of file vtkVolumeRayCastMapper.h.

float* vtkVolumeRayCastMapper::ZBuffer [protected]

Definition at line 252 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ZBufferSize[2] [protected]

Definition at line 253 of file vtkVolumeRayCastMapper.h.

int vtkVolumeRayCastMapper::ZBufferOrigin[2] [protected]

Definition at line 254 of file vtkVolumeRayCastMapper.h.

float vtkVolumeRayCastMapper::MinimumViewDistance [protected]

Definition at line 256 of file vtkVolumeRayCastMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastMapper.h
Generated on Mon Mar 25 01:34:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastMIPFunction Class Reference

A maximum intensity projection ray caster for volumes. More...

#include <vtkVolumeRayCastMIPFunction.h>

Inheritance diagram for vtkVolumeRayCastMIPFunction:

[legend]
Collaboration diagram for vtkVolumeRayCastMIPFunction:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeRayCastMIPFunction, vtkVolumeRayCastFunction)
void | PrintSelf (ostream &os, vtkIndent index)
float | GetZeroOpacityThreshold (vtkVolume *vol)
void | CastRay (VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)
virtual void | SetMaximizeMethod (int)
virtual int | GetMaximizeMethod ()
void | SetMaximizeMethodToScalarValue ()
void | SetMaximizeMethodToOpacity ()
const char * | GetMaximizeMethodAsString (void)

Static Public Methods

vtkVolumeRayCastMIPFunction * | New ()

Protected Methods

vtkVolumeRayCastMIPFunction ()
~vtkVolumeRayCastMIPFunction ()
void | SpecificFunctionInitialize (vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper)

Protected Attributes

int | MaximizeMethod

Detailed Description

A maximum intensity projection ray caster for volumes.

Date:
2002/01/22 15:39:40
Revision:
1.26

vtkVolumeRayCastMIPFunction is a volume ray cast function that computes the maximum value encountered along the ray. This is either the maximum scalar value, or the maximum opacity, as defined by the MaximizeMethod. The color and opacity returned by this function is based on the color, scalar opacity, and gradient opacity transfer functions defined in the vtkVolumeProperty of the vtkVolume.

See also:
vtkVolumeRayCastFunction vtkVolumeRayCastMapper vtkVolumeProperty vtkVolumeRayCastCompositeFunction vtkVolumeRayCastIsosurfaceFunction vtkVolume vtkVolumeProperty
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (57%)
  • Avila, Lisa (34%)
Tests:
vtkVolumeRayCastMIPFunction (Tests)

Definition at line 55 of file vtkVolumeRayCastMIPFunction.h.

Constructor & Destructor Documentation

vtkVolumeRayCastMIPFunction::vtkVolumeRayCastMIPFunction ( ) [protected]

vtkVolumeRayCastMIPFunction::~vtkVolumeRayCastMIPFunction ( ) [protected]

Member Function Documentation

vtkVolumeRayCastMIPFunction* vtkVolumeRayCastMIPFunction::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVolumeRayCastMIPFunction::vtkTypeRevisionMacro | ( | vtkVolumeRayCastMIPFunction | ,
 |  | vtkVolumeRayCastFunction |
 | ) |

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastMIPFunction::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

float vtkVolumeRayCastMIPFunction::GetZeroOpacityThreshold ( vtkVolume * vol ) [virtual]

Get the scalar value below which all scalar values have zero opacity.

Reimplemented from vtkVolumeRayCastFunction.

virtual void vtkVolumeRayCastMIPFunction::SetMaximizeMethod ( int ) [virtual]

Set the MaximizeMethod to either ScalarValue or Opacity.

virtual int vtkVolumeRayCastMIPFunction::GetMaximizeMethod ( ) [virtual]

Set the MaximizeMethod to either ScalarValue or Opacity.

void vtkVolumeRayCastMIPFunction::SetMaximizeMethodToScalarValue ( ) [inline]

Set the MaximizeMethod to either ScalarValue or Opacity.

Definition at line 72 of file vtkVolumeRayCastMIPFunction.h.

void vtkVolumeRayCastMIPFunction::SetMaximizeMethodToOpacity ( ) [inline]

Set the MaximizeMethod to either ScalarValue or Opacity.

Definition at line 74 of file vtkVolumeRayCastMIPFunction.h.

const char* vtkVolumeRayCastMIPFunction::GetMaximizeMethodAsString ( void )

Set the MaximizeMethod to either ScalarValue or Opacity.

void vtkVolumeRayCastMIPFunction::CastRay | ( | VTKVRCDynamicInfo * | dynamicInfo,
 |  | VTKVRCStaticInfo * | staticInfo
 | ) | [virtual]

Reimplemented from vtkVolumeRayCastFunction.

void vtkVolumeRayCastMIPFunction::SpecificFunctionInitialize | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | VTKVRCStaticInfo * | staticInfo,
 |  | vtkVolumeRayCastMapper * | mapper
 | ) | [protected, virtual]

This method gives the subclass a chance to do any special initialization that it may need to do BTX

Reimplemented from vtkVolumeRayCastFunction.

Member Data Documentation

int vtkVolumeRayCastMIPFunction::MaximizeMethod [protected]

Definition at line 89 of file vtkVolumeRayCastMIPFunction.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastMIPFunction.h
Generated on Mon Mar 25 01:34:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeRayCastStructures Class Reference

structures for ray casting volumes. More...

#include <vtkVolumeRayCastStructures.h>

Detailed Description

structures for ray casting volumes.

Date:
2002/01/22 15:39:42
Revision:
1.6

These are the structures required for the ray casting of volumes

See also:
vtkRayCaster vtkRayCastStructures vtkVolumeRayCastMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (100%)

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeRayCastStructures.h
Generated on Mon Mar 25 01:34:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeReader Class Reference

read image files. More...

#include <vtkVolumeReader.h>

Inheritance diagram for vtkVolumeReader:

[legend]
Collaboration diagram for vtkVolumeReader:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeReader, vtkStructuredPointsSource)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual vtkStructuredPoints * | GetImage (int ImageNumber)=0
virtual void | SetFilePrefix (const char *)
virtual char * | GetFilePrefix ()
virtual void | SetFilePattern (const char *)
virtual char * | GetFilePattern ()
virtual void | SetImageRange (int, int)
void | SetImageRange (int[2])
virtual int * | GetImageRange ()
virtual void | GetImageRange (int data[2])
virtual void | SetDataSpacing (float, float, float)
virtual void | SetDataSpacing (float[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float data[3])
virtual void | SetDataOrigin (float, float, float)
virtual void | SetDataOrigin (float[3])
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float data[3])

Protected Methods

vtkVolumeReader ()
~vtkVolumeReader ()

Protected Attributes

char * | FilePrefix
char * | FilePattern
int | ImageRange [2]
float | DataSpacing [3]
float | DataOrigin [3]

Detailed Description

read image files.

Date:
2002/01/22 15:38:25
Revision:
1.28

vtkVolumeReader is a source object that reads image files.

VolumeReader creates structured point datasets. The dimension of the dataset depends upon the number of files read. Reading a single file results in a 2D image, while reading more than one file results in a 3D volume.

File names are created using FilePattern and FilePrefix as follows: sprintf (filename, FilePattern, FilePrefix, number); where number is in the range ImageRange[0] to ImageRange[1]. If ImageRange[1] <= ImageRange[0], then slice number ImageRange[0] is read. Thus to read an image set ImageRange[0] = ImageRange[1] = slice number. The default behavior is to read a single file (i.e., image slice 1).

The DataMask instance variable is used to read data files with imbedded connectivity or segmentation information. For example, some data has the high order bit set to indicate connected surface. The DataMask allows you to select this data. Other important ivars include HeaderSize, which allows you to skip over initial info, and SwapBytes, which turns on/off byte swapping. Consider using vtkImageReader as a replacement.

See also:
vtkSliceCubes vtkMarchingCubes vtkPNMReader vtkVolume16Reader vtkImageReader
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (78%)
  • Lorensen, Bill (12%)
  • Schroeder, Will (5%)

Definition at line 62 of file vtkVolumeReader.h.

Constructor & Destructor Documentation

vtkVolumeReader::vtkVolumeReader ( ) [protected]

vtkVolumeReader::~vtkVolumeReader ( ) [protected]

Member Function Documentation

vtkVolumeReader::vtkTypeRevisionMacro | ( | vtkVolumeReader | ,
 |  | vtkStructuredPointsSource |
 | ) |

Reimplemented from vtkStructuredPointsSource.

Reimplemented in vtkVolume16Reader.

void vtkVolumeReader::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

Reimplemented in vtkVolume16Reader.

virtual void vtkVolumeReader::SetFilePrefix ( const char * ) [virtual]

Specify file prefix for the image file(s).

virtual char* vtkVolumeReader::GetFilePrefix ( ) [virtual]

Specify file prefix for the image file(s).

virtual void vtkVolumeReader::SetFilePattern ( const char * ) [virtual]

The sprintf format used to build filename from FilePrefix and number.

virtual char* vtkVolumeReader::GetFilePattern ( ) [virtual]

The sprintf format used to build filename from FilePrefix and number.

virtual void vtkVolumeReader::SetImageRange | ( | int | ,
 |  | int |
 | ) | [virtual]

Set the range of files to read.

void vtkVolumeReader::SetImageRange ( int [2] )

Set the range of files to read.

virtual int* vtkVolumeReader::GetImageRange ( ) [virtual]

Set the range of files to read.

virtual void vtkVolumeReader::GetImageRange ( int data[2] ) [virtual]

Set the range of files to read.

virtual void vtkVolumeReader::SetDataSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the spacing for the data.

virtual void vtkVolumeReader::SetDataSpacing ( float [3] ) [virtual]

Specify the spacing for the data.

virtual float* vtkVolumeReader::GetDataSpacing ( ) [virtual]

Specify the spacing for the data.

virtual void vtkVolumeReader::GetDataSpacing ( float data[3] ) [virtual]

Specify the spacing for the data.

virtual void vtkVolumeReader::SetDataOrigin | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Specify the origin for the data.

virtual void vtkVolumeReader::SetDataOrigin ( float [3] ) [virtual]

Specify the origin for the data.

virtual float* vtkVolumeReader::GetDataOrigin ( ) [virtual]

Specify the origin for the data.

virtual void vtkVolumeReader::GetDataOrigin ( float data[3] ) [virtual]

Specify the origin for the data.

virtual vtkStructuredPoints* vtkVolumeReader::GetImage ( int ImageNumber ) [pure virtual]

Other objects make use of this method.

Reimplemented in vtkVolume16Reader.

Member Data Documentation

char* vtkVolumeReader::FilePrefix [protected]

Definition at line 105 of file vtkVolumeReader.h.

char* vtkVolumeReader::FilePattern [protected]

Definition at line 106 of file vtkVolumeReader.h.

int vtkVolumeReader::ImageRange[2] [protected]

Definition at line 107 of file vtkVolumeReader.h.

float vtkVolumeReader::DataSpacing[3] [protected]

Definition at line 108 of file vtkVolumeReader.h.

float vtkVolumeReader::DataOrigin[3] [protected]

Definition at line 109 of file vtkVolumeReader.h.

The documentation for this class was generated from the following file:
  • IO/vtkVolumeReader.h
Generated on Mon Mar 25 01:34:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeTextureMapper Class Reference

Abstract class for a volume mapper. More...

#include <vtkVolumeTextureMapper.h>

Inheritance diagram for vtkVolumeTextureMapper:

[legend]
Collaboration diagram for vtkVolumeTextureMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeTextureMapper, vtkVolumeMapper)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Update ()
virtual void | Render (vtkRenderer *ren, vtkVolume *vol)=0
void | SetGradientEstimator (vtkEncodedGradientEstimator *gradest)
virtual vtkEncodedGradientEstimator * | GetGradientEstimator ()
virtual vtkEncodedGradientShader * | GetGradientShader ()
float * | GetGradientOpacityArray ()
unsigned char * | GetRGBAArray ()
float * | GetRedDiffuseShadingTable ()
float * | GetGreenDiffuseShadingTable ()
float * | GetBlueDiffuseShadingTable ()
float * | GetRedSpecularShadingTable ()
float * | GetGreenSpecularShadingTable ()
float * | GetBlueSpecularShadingTable ()
unsigned short * | GetEncodedNormals ()
unsigned char * | GetGradientMagnitudes ()
virtual int | GetShade ()
virtual vtkRenderWindow * | GetRenderWindow ()
virtual float * | GetDataOrigin ()
virtual void | GetDataOrigin (float data[3])
virtual float * | GetDataSpacing ()
virtual void | GetDataSpacing (float data[3])
virtual float | GetGradientMagnitudeScale ()
virtual float | GetGradientMagnitudeBias ()

Protected Methods

vtkVolumeTextureMapper ()
~vtkVolumeTextureMapper ()
void | InitializeRender (vtkRenderer *ren, vtkVolume *vol)

Protected Attributes

vtkEncodedGradientEstimator * GradientEstimator
vtkEncodedGradientShader * GradientShader
int | Shade
float * | GradientOpacityArray
unsigned char * | RGBAArray
int | ArraySize
float * | RedDiffuseShadingTable
float * | GreenDiffuseShadingTable
float * | BlueDiffuseShadingTable
float * | RedSpecularShadingTable
float * | GreenSpecularShadingTable
float * | BlueSpecularShadingTable
float | DataOrigin [3]
float | DataSpacing [3]
unsigned short * | EncodedNormals
unsigned char * | GradientMagnitudes
float | SampleDistance
vtkRenderWindow * RenderWindow

Detailed Description

Abstract class for a volume mapper.

Date:
2002/01/22 15:39:42
Revision:
1.22

vtkVolumeTextureMapper is the abstract definition of a volume mapper that uses a texture mapping approach.

See also:
vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (94%)

Definition at line 47 of file vtkVolumeTextureMapper.h.

Constructor & Destructor Documentation

vtkVolumeTextureMapper::vtkVolumeTextureMapper ( ) [protected]

vtkVolumeTextureMapper::~vtkVolumeTextureMapper ( ) [protected]

Member Function Documentation

vtkVolumeTextureMapper::vtkTypeRevisionMacro | ( | vtkVolumeTextureMapper | ,
 |  | vtkVolumeMapper |
 | ) |

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, and vtkVolumeTextureMapper2D.

void vtkVolumeTextureMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, and vtkVolumeTextureMapper2D.

virtual void vtkVolumeTextureMapper::Update ( void ) [virtual]

Update the volume rendering pipeline by updating the scalar input

Reimplemented from vtkVolumeMapper.

void vtkVolumeTextureMapper::SetGradientEstimator ( vtkEncodedGradientEstimator * gradest )

Set / Get the gradient estimator used to estimate normals

virtual vtkEncodedGradientEstimator* vtkVolumeTextureMapper::GetGradientEstimator ( ) [virtual]

Set / Get the gradient estimator used to estimate normals

virtual vtkEncodedGradientShader* vtkVolumeTextureMapper::GetGradientShader ( ) [virtual]

Get the gradient shader.

float* vtkVolumeTextureMapper::GetGradientOpacityArray ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 71 of file vtkVolumeTextureMapper.h.

unsigned char* vtkVolumeTextureMapper::GetRGBAArray ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 72 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetRedDiffuseShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 73 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetGreenDiffuseShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 74 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetBlueDiffuseShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 75 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetRedSpecularShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 76 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetGreenSpecularShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 77 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GetBlueSpecularShadingTable ( ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 78 of file vtkVolumeTextureMapper.h.

unsigned short* vtkVolumeTextureMapper::GetEncodedNormals ( void ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 79 of file vtkVolumeTextureMapper.h.

unsigned char* vtkVolumeTextureMapper::GetGradientMagnitudes ( void ) [inline]

Allow access to the arrays / variables from the templated functions in the subclasses.

Definition at line 80 of file vtkVolumeTextureMapper.h.

virtual int vtkVolumeTextureMapper::GetShade ( ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual vtkRenderWindow* vtkVolumeTextureMapper::GetRenderWindow ( ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual float* vtkVolumeTextureMapper::GetDataOrigin ( ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual void vtkVolumeTextureMapper::GetDataOrigin ( float data[3] ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual float* vtkVolumeTextureMapper::GetDataSpacing ( ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual void vtkVolumeTextureMapper::GetDataSpacing ( float data[3] ) [virtual]

Allow access to the arrays / variables from the templated functions in the subclasses.

virtual void vtkVolumeTextureMapper::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [pure virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Render the volume

Reimplemented from vtkVolumeMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, and vtkVolumeTextureMapper2D.

virtual float vtkVolumeTextureMapper::GetGradientMagnitudeScale ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Values needed by the volume

Reimplemented from vtkVolumeMapper.

virtual float vtkVolumeTextureMapper::GetGradientMagnitudeBias ( ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE Values needed by the volume

Reimplemented from vtkVolumeMapper.

void vtkVolumeTextureMapper::InitializeRender | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [protected]

Reimplemented in vtkVolumeTextureMapper2D.

Referenced by vtkVolumeTextureMapper2D::InitializeRender().

Member Data Documentation

vtkEncodedGradientEstimator* vtkVolumeTextureMapper::GradientEstimator [protected]

Definition at line 109 of file vtkVolumeTextureMapper.h.

vtkEncodedGradientShader* vtkVolumeTextureMapper::GradientShader [protected]

Definition at line 110 of file vtkVolumeTextureMapper.h.

int vtkVolumeTextureMapper::Shade [protected]

Definition at line 111 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GradientOpacityArray [protected]

Definition at line 113 of file vtkVolumeTextureMapper.h.

unsigned char* vtkVolumeTextureMapper::RGBAArray [protected]

Definition at line 114 of file vtkVolumeTextureMapper.h.

int vtkVolumeTextureMapper::ArraySize [protected]

Definition at line 115 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::RedDiffuseShadingTable [protected]

Definition at line 117 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GreenDiffuseShadingTable [protected]

Definition at line 118 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::BlueDiffuseShadingTable [protected]

Definition at line 119 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::RedSpecularShadingTable [protected]

Definition at line 120 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::GreenSpecularShadingTable [protected]

Definition at line 121 of file vtkVolumeTextureMapper.h.

float* vtkVolumeTextureMapper::BlueSpecularShadingTable [protected]

Definition at line 122 of file vtkVolumeTextureMapper.h.

float vtkVolumeTextureMapper::DataOrigin[3] [protected]

Definition at line 124 of file vtkVolumeTextureMapper.h.

float vtkVolumeTextureMapper::DataSpacing[3] [protected]

Definition at line 125 of file vtkVolumeTextureMapper.h.

unsigned short* vtkVolumeTextureMapper::EncodedNormals [protected]

Definition at line 127 of file vtkVolumeTextureMapper.h.

unsigned char* vtkVolumeTextureMapper::GradientMagnitudes [protected]

Definition at line 128 of file vtkVolumeTextureMapper.h.

float vtkVolumeTextureMapper::SampleDistance [protected]

Definition at line 130 of file vtkVolumeTextureMapper.h.

vtkRenderWindow* vtkVolumeTextureMapper::RenderWindow [protected]

Definition at line 132 of file vtkVolumeTextureMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeTextureMapper.h
Generated on Mon Mar 25 01:34:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVolumeTextureMapper2D Class Reference

Abstract class for a volume mapper. More...

#include <vtkVolumeTextureMapper2D.h>

Inheritance diagram for vtkVolumeTextureMapper2D:

[legend]
Collaboration diagram for vtkVolumeTextureMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVolumeTextureMapper2D, vtkVolumeTextureMapper)
void | PrintSelf (ostream &os, vtkIndent index)
virtual void | Render (vtkRenderer *, vtkVolume *)
virtual void | RenderQuads (int vtkNotUsed(count), float *vtkNotUsed(v), float *vtkNotUsed(t), unsigned char *vtkNotUsed(texture), int vtkNotUsed(size)[2], int vtkNotUsed(reverseFlag))
int | GetInternalSkipFactor ()
int * | GetAxisTextureSize ()
int | GetSaveTextures ()
unsigned char * | GetTexture ()
virtual void | SetTargetTextureSize (int, int)
void | SetTargetTextureSize (int[2])
virtual int * | GetTargetTextureSize ()
virtual void | GetTargetTextureSize (int &, int &)
virtual void | GetTargetTextureSize (int[2])
virtual void | SetMaximumNumberOfPlanes (int)
virtual int | GetMaximumNumberOfPlanes ()
virtual void | SetMaximumStorageSize (int)
virtual int | GetMaximumStorageSize ()

Static Public Methods

vtkVolumeTextureMapper2D * | New ()

Protected Methods

vtkVolumeTextureMapper2D ()
~vtkVolumeTextureMapper2D ()
void | InitializeRender (vtkRenderer *ren, vtkVolume *vol)
void | InitializeRender (vtkRenderer *ren, vtkVolume *vol, int majorDirection)
void | GenerateTexturesAndRenderQuads (vtkRenderer *ren, vtkVolume *vol)
void | ComputeAxisTextureSize (int axis, int *size)
void | RenderSavedTexture ()

Protected Attributes

int | MajorDirection
int | TargetTextureSize [2]
int | MaximumNumberOfPlanes
int | InternalSkipFactor
int | MaximumStorageSize
unsigned char * | Texture
int | TextureSize
int | SaveTextures
vtkTimeStamp TextureMTime
int | AxisTextureSize [3][3]

Detailed Description

Abstract class for a volume mapper.

Date:
2002/01/22 15:39:43
Revision:
1.19

vtkVolumeTextureMapper2D renders a volume using 2D texture mapping.

See also:
vtkVolumeMapper
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (95%)
Examples:
vtkVolumeTextureMapper2D (Examples)
Tests:
vtkVolumeTextureMapper2D (Tests)

Definition at line 46 of file vtkVolumeTextureMapper2D.h.

Constructor & Destructor Documentation

vtkVolumeTextureMapper2D::vtkVolumeTextureMapper2D ( ) [protected]

vtkVolumeTextureMapper2D::~vtkVolumeTextureMapper2D ( ) [protected]

Member Function Documentation

vtkVolumeTextureMapper2D::vtkTypeRevisionMacro | ( | vtkVolumeTextureMapper2D | ,
 |  | vtkVolumeTextureMapper |
 | ) |

Reimplemented from vtkVolumeTextureMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, and vtkOpenGLVolumeTextureMapper2D.

void vtkVolumeTextureMapper2D::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | index
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVolumeTextureMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, and vtkOpenGLVolumeTextureMapper2D.

vtkVolumeTextureMapper2D* vtkVolumeTextureMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkProcessObject.

Reimplemented in vtkMesaVolumeTextureMapper2D, and vtkOpenGLVolumeTextureMapper2D.

virtual void vtkVolumeTextureMapper2D::SetTargetTextureSize | ( | int | ,
 |  | int |
 | ) | [virtual]

Target size in pixels of each size of the texture for downloading. Default is 512x512 - so a 512x512 texture will be tiled with as many slices of the volume as possible, then all the quads will be rendered. This can be set to optimize for a particular architecture. This must be set with numbers that are a power of two.

void vtkVolumeTextureMapper2D::SetTargetTextureSize ( int [2] )

Target size in pixels of each size of the texture for downloading. Default is 512x512 - so a 512x512 texture will be tiled with as many slices of the volume as possible, then all the quads will be rendered. This can be set to optimize for a particular architecture. This must be set with numbers that are a power of two.

virtual int* vtkVolumeTextureMapper2D::GetTargetTextureSize ( ) [virtual]

Target size in pixels of each size of the texture for downloading. Default is 512x512 - so a 512x512 texture will be tiled with as many slices of the volume as possible, then all the quads will be rendered. This can be set to optimize for a particular architecture. This must be set with numbers that are a power of two.

virtual void vtkVolumeTextureMapper2D::GetTargetTextureSize | ( | int & | ,
 |  | int & |
 | ) | [virtual]

Target size in pixels of each size of the texture for downloading. Default is 512x512 - so a 512x512 texture will be tiled with as many slices of the volume as possible, then all the quads will be rendered. This can be set to optimize for a particular architecture. This must be set with numbers that are a power of two.

virtual void vtkVolumeTextureMapper2D::GetTargetTextureSize ( int [2] ) [virtual]

Target size in pixels of each size of the texture for downloading. Default is 512x512 - so a 512x512 texture will be tiled with as many slices of the volume as possible, then all the quads will be rendered. This can be set to optimize for a particular architecture. This must be set with numbers that are a power of two.

virtual void vtkVolumeTextureMapper2D::SetMaximumNumberOfPlanes ( int ) [virtual]

This is the maximum number of planes that will be created for texture mapping the volume. If the volume has more voxels than this along the viewing direction, then planes of the volume will be skipped to ensure that this maximum is not violated. A skip factor is used, and is incremented until the maximum condition is satisfied.

virtual int vtkVolumeTextureMapper2D::GetMaximumNumberOfPlanes ( ) [virtual]

This is the maximum number of planes that will be created for texture mapping the volume. If the volume has more voxels than this along the viewing direction, then planes of the volume will be skipped to ensure that this maximum is not violated. A skip factor is used, and is incremented until the maximum condition is satisfied.

virtual void vtkVolumeTextureMapper2D::SetMaximumStorageSize ( int ) [virtual]

This is the maximum size of saved textures in bytes. If this size is large enough to hold the RGBA textures for all three directions (XxYxZx3x4 is the approximate value - it is actually a bit larger due to wasted space in the textures) then the textures will be saved.

virtual int vtkVolumeTextureMapper2D::GetMaximumStorageSize ( ) [virtual]

This is the maximum size of saved textures in bytes. If this size is large enough to hold the RGBA textures for all three directions (XxYxZx3x4 is the approximate value - it is actually a bit larger due to wasted space in the textures) then the textures will be saved.

virtual void vtkVolumeTextureMapper2D::Render | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS Render the volume

Reimplemented from vtkVolumeTextureMapper.

Reimplemented in vtkMesaVolumeTextureMapper2D, and vtkOpenGLVolumeTextureMapper2D.

Definition at line 87 of file vtkVolumeTextureMapper2D.h.

virtual void vtkVolumeTextureMapper2D::RenderQuads | ( | int vtkNotUsed(count) | ,
 |  | float *vtkNotUsed(v) | ,
 |  | float *vtkNotUsed(t) | ,
 |  | unsigned char *vtkNotUsed(texture) | ,
 |  | int vtkNotUsed(size) | [2],
 |  | int vtkNotUsed(reverseFlag) |
 | ) | [inline, virtual]

Definition at line 89 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::GetInternalSkipFactor ( ) [inline]

Made public only for access from the templated method. Not a vtkGetMacro to avoid the PrintSelf defect.

Definition at line 97 of file vtkVolumeTextureMapper2D.h.

int* vtkVolumeTextureMapper2D::GetAxisTextureSize ( ) [inline]

Definition at line 99 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::GetSaveTextures ( ) [inline]

Definition at line 101 of file vtkVolumeTextureMapper2D.h.

unsigned char* vtkVolumeTextureMapper2D::GetTexture ( ) [inline]

Definition at line 103 of file vtkVolumeTextureMapper2D.h.

void vtkVolumeTextureMapper2D::InitializeRender | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [inline, protected]

Reimplemented from vtkVolumeTextureMapper.

Definition at line 112 of file vtkVolumeTextureMapper2D.h.

void vtkVolumeTextureMapper2D::InitializeRender | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol,
 |  | int | majorDirection
 | ) | [protected]

void vtkVolumeTextureMapper2D::GenerateTexturesAndRenderQuads | ( | vtkRenderer * | ren,
 |  | vtkVolume * | vol
 | ) | [protected]

void vtkVolumeTextureMapper2D::ComputeAxisTextureSize | ( | int | axis,
 |  | int * | size
 | ) | [protected]

void vtkVolumeTextureMapper2D::RenderSavedTexture ( ) [protected]

Member Data Documentation

int vtkVolumeTextureMapper2D::MajorDirection [protected]

Definition at line 119 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::TargetTextureSize[2] [protected]

Definition at line 120 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::MaximumNumberOfPlanes [protected]

Definition at line 122 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::InternalSkipFactor [protected]

Definition at line 123 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::MaximumStorageSize [protected]

Definition at line 124 of file vtkVolumeTextureMapper2D.h.

unsigned char* vtkVolumeTextureMapper2D::Texture [protected]

Definition at line 126 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::TextureSize [protected]

Definition at line 127 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::SaveTextures [protected]

Definition at line 128 of file vtkVolumeTextureMapper2D.h.

vtkTimeStamp vtkVolumeTextureMapper2D::TextureMTime [protected]

Definition at line 129 of file vtkVolumeTextureMapper2D.h.

int vtkVolumeTextureMapper2D::AxisTextureSize[3][3] [protected]

Definition at line 131 of file vtkVolumeTextureMapper2D.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVolumeTextureMapper2D.h
Generated on Mon Mar 25 01:34:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxel Class Reference

a cell that represents a 3D orthogonal parallelepiped. More...

#include <vtkVoxel.h>

Inheritance diagram for vtkVoxel:

[legend]
Collaboration diagram for vtkVoxel:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVoxel, vtkCell)
virtual void | GetEdgePoints (int edgeId, int *&pts)
virtual void | GetFacePoints (int faceId, int *&pts)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkVoxel * | New ()
void | InterpolationFunctions (float pcoords[3], float weights[8])
void | InterpolationDerivs (float pcoords[3], float derivs[24])
int * | GetEdgeArray (int edgeId)
int * | GetFaceArray (int faceId)

Protected Methods

vtkVoxel ()
~vtkVoxel ()

Protected Attributes

vtkLine * Line
vtkPixel * Pixel

Detailed Description

a cell that represents a 3D orthogonal parallelepiped.

Date:
2002/01/22 15:26:41
Revision:
1.64

vtkVoxel is a concrete implementation of vtkCell to represent a 3D orthogonal parallelepiped. Unlike vtkHexahedron, vtkVoxel has interior angles of 90 degrees, and sides are parallel to coordinate axes. This results in large increases in computational performance.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (75%)
  • Law, Charles (6%)
Examples:
vtkVoxel (Examples)
Tests:
vtkVoxel (Tests)

Definition at line 48 of file vtkVoxel.h.

Constructor & Destructor Documentation

vtkVoxel::vtkVoxel ( ) [protected]

vtkVoxel::~vtkVoxel ( ) [protected]

Member Function Documentation

vtkVoxel* vtkVoxel::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVoxel::vtkTypeRevisionMacro | ( | vtkVoxel | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell3D.

virtual void vtkVoxel::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

virtual void vtkVoxel::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

vtkCell* vtkVoxel::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVoxel::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 63 of file vtkVoxel.h.

int vtkVoxel::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell3D.

Definition at line 64 of file vtkVoxel.h.

int vtkVoxel::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 65 of file vtkVoxel.h.

int vtkVoxel::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 66 of file vtkVoxel.h.

vtkCell* vtkVoxel::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkVoxel::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVoxel::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkVoxel::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVoxel::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkVoxel::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVoxel::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkVoxel::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkVoxel::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkVoxel::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[8]
 | ) | [static]

Voxel specific methods for interpolation and derivatives.

void vtkVoxel::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[24]
 | ) | [static]

Voxel specific methods for interpolation and derivatives.

int* vtkVoxel::GetEdgeArray ( int edgeId ) [static]

Voxel specific methods for interpolation and derivatives.

int* vtkVoxel::GetFaceArray ( int faceId ) [static]

Voxel specific methods for interpolation and derivatives.

Member Data Documentation

vtkLine* vtkVoxel::Line [protected]

Definition at line 99 of file vtkVoxel.h.

vtkPixel* vtkVoxel::Pixel [protected]

Definition at line 100 of file vtkVoxel.h.

The documentation for this class was generated from the following file:
  • Common/vtkVoxel.h
Generated on Mon Mar 25 01:34:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxelContoursToSurfaceFilter Class Reference

create surface from contours. More...

#include <vtkVoxelContoursToSurfaceFilter.h>

Inheritance diagram for vtkVoxelContoursToSurfaceFilter:

[legend]
Collaboration diagram for vtkVoxelContoursToSurfaceFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVoxelContoursToSurfaceFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetSpacing (float, float, float)
virtual void | SetSpacing (float[3])
virtual float * | GetSpacing ()
virtual void | GetSpacing (float data[3])
virtual void | SetMemoryLimitInBytes (int)
virtual int | GetMemoryLimitInBytes ()

Static Public Methods

vtkVoxelContoursToSurfaceFilter * | New ()

Protected Methods

vtkVoxelContoursToSurfaceFilter ()
~vtkVoxelContoursToSurfaceFilter ()
void | Execute ()
void | AddLineToLineList (float x1, float y1, float x2, float y2)
void | SortLineList ()
void | CastLines (float *slice, float gridOrigin[3], int gridSize[3], int type)
void | PushDistances (float *ptr, int gridSize[3], int chunkSize)

Protected Attributes

int | MemoryLimitInBytes
float | Spacing [3]
float * | LineList
int | LineListLength
int | LineListSize
float * | SortedXList
float * | SortedYList
int | SortedListSize
int * | WorkingList
int | WorkingListLength
float * | IntersectionList
int | IntersectionListLength

Detailed Description

create surface from contours.

Date:
2002/01/22 15:29:55
Revision:
1.18

vtkVoxelContoursToSurfaceFilter is a filter that takes contours and produces surfaces. There are some restrictions for the contours:

  • The contours are input as vtkPolyData, with the contours being polys in the vtkPolyData.
  • The contours lie on XY planes - each contour has a constant Z
  • The contours are ordered in the polys of the vtkPolyData such that all contours on the first (lowest) XY plane are first, then continuing in order of increasing Z value.
  • The X, Y and Z coordinates are all integer values.
  • The desired sampling of the contour data is 1x1x1 - Aspect can be used to control the aspect ratio in the output polygonal dataset.
This filter takes the contours and produces a structured points dataset of signed floating point number indicating distance from a contour. A contouring filter is then applied to generate 3D surfaces from a stack of 2D contour distance slices. This is done in a streaming fashion so as not to use to much memory.

See also:
vtkPolyDataToPolyDataFilter
Created by:
  • Avila, Lisa
Contributed by (if > 5%):
  • Avila, Lisa (96%)
Tests:
vtkVoxelContoursToSurfaceFilter (Tests)

Definition at line 60 of file vtkVoxelContoursToSurfaceFilter.h.

Constructor & Destructor Documentation

vtkVoxelContoursToSurfaceFilter::vtkVoxelContoursToSurfaceFilter ( ) [protected]

vtkVoxelContoursToSurfaceFilter::~vtkVoxelContoursToSurfaceFilter ( ) [protected]

Member Function Documentation

vtkVoxelContoursToSurfaceFilter* vtkVoxelContoursToSurfaceFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataSource.

vtkVoxelContoursToSurfaceFilter::vtkTypeRevisionMacro | ( | vtkVoxelContoursToSurfaceFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkVoxelContoursToSurfaceFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkVoxelContoursToSurfaceFilter::SetMemoryLimitInBytes ( int ) [virtual]

Set / Get the memory limit in bytes for this filter. This is the limit of the size of the structured points data set that is created for intermediate processing. The data will be streamed through this volume in as many pieces as necessary.

virtual int vtkVoxelContoursToSurfaceFilter::GetMemoryLimitInBytes ( ) [virtual]

Set / Get the memory limit in bytes for this filter. This is the limit of the size of the structured points data set that is created for intermediate processing. The data will be streamed through this volume in as many pieces as necessary.

virtual void vtkVoxelContoursToSurfaceFilter::SetSpacing | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

virtual void vtkVoxelContoursToSurfaceFilter::SetSpacing ( float [3] ) [virtual]

virtual float* vtkVoxelContoursToSurfaceFilter::GetSpacing ( ) [virtual]

virtual void vtkVoxelContoursToSurfaceFilter::GetSpacing ( float data[3] ) [virtual]

void vtkVoxelContoursToSurfaceFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

void vtkVoxelContoursToSurfaceFilter::AddLineToLineList | ( | float | x1,
 |  | float | y1,
 |  | float | x2,
 |  | float | y2
 | ) | [protected]

void vtkVoxelContoursToSurfaceFilter::SortLineList ( ) [protected]

void vtkVoxelContoursToSurfaceFilter::CastLines | ( | float * | slice,
 |  | float | gridOrigin[3],
 |  | int | gridSize[3],
 |  | int | type
 | ) | [protected]

void vtkVoxelContoursToSurfaceFilter::PushDistances | ( | float * | ptr,
 |  | int | gridSize[3],
 |  | int | chunkSize
 | ) | [protected]

Member Data Documentation

int vtkVoxelContoursToSurfaceFilter::MemoryLimitInBytes [protected]

Definition at line 85 of file vtkVoxelContoursToSurfaceFilter.h.

float vtkVoxelContoursToSurfaceFilter::Spacing[3] [protected]

Definition at line 87 of file vtkVoxelContoursToSurfaceFilter.h.

float* vtkVoxelContoursToSurfaceFilter::LineList [protected]

Definition at line 89 of file vtkVoxelContoursToSurfaceFilter.h.

int vtkVoxelContoursToSurfaceFilter::LineListLength [protected]

Definition at line 90 of file vtkVoxelContoursToSurfaceFilter.h.

int vtkVoxelContoursToSurfaceFilter::LineListSize [protected]

Definition at line 91 of file vtkVoxelContoursToSurfaceFilter.h.

float* vtkVoxelContoursToSurfaceFilter::SortedXList [protected]

Definition at line 93 of file vtkVoxelContoursToSurfaceFilter.h.

float* vtkVoxelContoursToSurfaceFilter::SortedYList [protected]

Definition at line 94 of file vtkVoxelContoursToSurfaceFilter.h.

int vtkVoxelContoursToSurfaceFilter::SortedListSize [protected]

Definition at line 95 of file vtkVoxelContoursToSurfaceFilter.h.

int* vtkVoxelContoursToSurfaceFilter::WorkingList [protected]

Definition at line 97 of file vtkVoxelContoursToSurfaceFilter.h.

int vtkVoxelContoursToSurfaceFilter::WorkingListLength [protected]

Definition at line 98 of file vtkVoxelContoursToSurfaceFilter.h.

float* vtkVoxelContoursToSurfaceFilter::IntersectionList [protected]

Definition at line 100 of file vtkVoxelContoursToSurfaceFilter.h.

int vtkVoxelContoursToSurfaceFilter::IntersectionListLength [protected]

Definition at line 101 of file vtkVoxelContoursToSurfaceFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkVoxelContoursToSurfaceFilter.h
Generated on Mon Mar 25 01:34:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVoxelModeller Class Reference

convert an arbitrary dataset to a voxel representation. More...

#include <vtkVoxelModeller.h>

Inheritance diagram for vtkVoxelModeller:

[legend]
Collaboration diagram for vtkVoxelModeller:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVoxelModeller, vtkDataSetToStructuredPointsFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
float | ComputeModelBounds (float origin[3], float ar[3])
void | SetSampleDimensions (int i, int j, int k)
void | Write (char *)
void | SetSampleDimensions (int dim[3])
virtual int * | GetSampleDimensions ()
virtual void | GetSampleDimensions (int data[3])
virtual void | SetMaximumDistance (float)
virtual float | GetMaximumDistance ()
void | SetModelBounds (float bounds[6])
void | SetModelBounds (float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
virtual float * | GetModelBounds ()
virtual void | GetModelBounds (float data[6])

Static Public Methods

vtkVoxelModeller * | New ()

Protected Methods

vtkVoxelModeller ()
~vtkVoxelModeller ()
void | Execute ()

Protected Attributes

int | SampleDimensions [3]
float | MaximumDistance
float | ModelBounds [6]

Detailed Description

convert an arbitrary dataset to a voxel representation.

Date:
2002/01/22 15:33:50
Revision:
1.41

vtkVoxelModeller is a filter that converts an arbitrary data set to a structured point (i.e., voxel) representation. It is very similar to vtkImplicitModeller, except that it doesn't record distance; instead it records occupancy. As such, it stores its results in the more compact form of 0/1 bits.

See also:
vtkImplicitModeller
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (55%)
  • Schroeder, Will (21%)
  • Lorensen, Bill (8%)
  • Henderson, Amy (6%)
Tests:
vtkVoxelModeller (Tests)

Definition at line 48 of file vtkVoxelModeller.h.

Constructor & Destructor Documentation

vtkVoxelModeller::vtkVoxelModeller ( ) [protected]

vtkVoxelModeller::~vtkVoxelModeller ( ) [inline, protected]

Definition at line 92 of file vtkVoxelModeller.h.

Member Function Documentation

vtkVoxelModeller::vtkTypeRevisionMacro | ( | vtkVoxelModeller | ,
 |  | vtkDataSetToStructuredPointsFilter |
 | ) |

Reimplemented from vtkDataSetToStructuredPointsFilter.

void vtkVoxelModeller::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkVoxelModeller* vtkVoxelModeller::New ( ) [static]

Construct an instance of vtkVoxelModeller with its sample dimensions set to (50,50,50), and so that the model bounds are automatically computed from its input. The maximum distance is set to examine the whole grid. This could be made much faster, and probably will be in the future.

Reimplemented from vtkStructuredPointsSource.

float vtkVoxelModeller::ComputeModelBounds | ( | float | origin[3],
 |  | float | ar[3]
 | ) |

Compute the ModelBounds based on the input geometry.

void vtkVoxelModeller::SetSampleDimensions | ( | int | i,
 |  | int | j,
 |  | int | k
 | ) |

Set the i-j-k dimensions on which to sample the distance function.

void vtkVoxelModeller::SetSampleDimensions ( int dim[3] )

Set the i-j-k dimensions on which to sample the distance function.

virtual int* vtkVoxelModeller::GetSampleDimensions ( ) [virtual]

Set the i-j-k dimensions on which to sample the distance function.

virtual void vtkVoxelModeller::GetSampleDimensions ( int data[3] ) [virtual]

Set the i-j-k dimensions on which to sample the distance function.

virtual void vtkVoxelModeller::SetMaximumDistance ( float ) [virtual]

Specify distance away from surface of input geometry to sample. Smaller values make large increases in performance.

virtual float vtkVoxelModeller::GetMaximumDistance ( ) [virtual]

Specify distance away from surface of input geometry to sample. Smaller values make large increases in performance.

void vtkVoxelModeller::SetModelBounds ( float bounds[6] )

Specify the position in space to perform the voxelization.

void vtkVoxelModeller::SetModelBounds | ( | float | xmin,
 |  | float | xmax,
 |  | float | ymin,
 |  | float | ymax,
 |  | float | zmin,
 |  | float | zmax
 | ) |

Specify the position in space to perform the voxelization.

virtual float* vtkVoxelModeller::GetModelBounds ( ) [virtual]

Specify the position in space to perform the voxelization.

virtual void vtkVoxelModeller::GetModelBounds ( float data[6] ) [virtual]

Specify the position in space to perform the voxelization.

void vtkVoxelModeller::Write ( char * )

The the volume out to a specified filename.

void vtkVoxelModeller::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkVoxelModeller::SampleDimensions[3] [protected]

Definition at line 95 of file vtkVoxelModeller.h.

float vtkVoxelModeller::MaximumDistance [protected]

Definition at line 96 of file vtkVoxelModeller.h.

float vtkVoxelModeller::ModelBounds[6] [protected]

Definition at line 97 of file vtkVoxelModeller.h.

The documentation for this class was generated from the following file:
  • Imaging/vtkVoxelModeller.h
Generated on Mon Mar 25 01:34:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRMLAllocator Struct Reference

#include <vtkVRML.h>

Collaboration diagram for vtkVRMLAllocator:

[legend]
List of all members.

Static Public Methods

void | Initialize ()
void * | AllocateMemory (size_t n)
void | CleanUp ()
char * | StrDup (const char *str)

Static Public Attributes

vtkHeap * Heap

Member Function Documentation

void vtkVRMLAllocator::Initialize ( ) [static]

Referenced by VectorType::Init().

void* vtkVRMLAllocator::AllocateMemory ( size_t n ) [static]

Referenced by VectorType::Init(), VectorType::Reserve(), and VectorType::operator new().

void vtkVRMLAllocator::CleanUp ( ) [static]

char* vtkVRMLAllocator::StrDup ( const char * str ) [static]

Member Data Documentation

vtkHeap* vtkVRMLAllocator::Heap [static]

Definition at line 71 of file vtkVRML.h.

The documentation for this struct was generated from the following file:
  • Hybrid/vtkVRML.h
Generated on Mon Mar 25 01:34:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRMLExporter Class Reference

export a scene into VRML 2.0 format. More...

#include <vtkVRMLExporter.h>

Inheritance diagram for vtkVRMLExporter:

[legend]
Collaboration diagram for vtkVRMLExporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVRMLExporter, vtkExporter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetFilePointer (FILE *)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()
virtual void | SetSpeed (float)
virtual float | GetSpeed ()

Static Public Methods

vtkVRMLExporter * | New ()

Protected Methods

vtkVRMLExporter ()
~vtkVRMLExporter ()
void | WriteData ()
void | WriteALight (vtkLight *aLight, FILE *fp)
void | WriteAnActor (vtkActor *anActor, FILE *fp)
void | WritePointData (vtkPoints *points, vtkDataArray *normals, vtkDataArray *tcoords, vtkUnsignedCharArray *colors, FILE *fp)

Protected Attributes

char * | FileName
FILE * | FilePointer
float | Speed

Detailed Description

export a scene into VRML 2.0 format.

Date:
2002/01/22 15:39:31
Revision:
1.33

vtkVRMLExporter is a concrete subclass of vtkExporter that writes VRML 2.0 files. This is based on the VRML 2.0 draft #3 but it should be pretty stable since we aren't using any of the newer features.

See also:
vtkExporter
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (69%)
  • Yamrom, Boris (7%)
  • Schroeder, Will (6%)
  • Lorensen, Bill (6%)
Tests:
vtkVRMLExporter (Tests)

Definition at line 48 of file vtkVRMLExporter.h.

Constructor & Destructor Documentation

vtkVRMLExporter::vtkVRMLExporter ( ) [protected]

vtkVRMLExporter::~vtkVRMLExporter ( ) [protected]

Member Function Documentation

vtkVRMLExporter* vtkVRMLExporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVRMLExporter::vtkTypeRevisionMacro | ( | vtkVRMLExporter | ,
 |  | vtkExporter |
 | ) |

Reimplemented from vtkExporter.

void vtkVRMLExporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkExporter.

virtual void vtkVRMLExporter::SetFileName ( const char * ) [virtual]

Specify the name of the VRML file to write.

virtual char* vtkVRMLExporter::GetFileName ( ) [virtual]

Specify the name of the VRML file to write.

virtual void vtkVRMLExporter::SetSpeed ( float ) [virtual]

Specify the Speed of navigation. Default is 4.

virtual float vtkVRMLExporter::GetSpeed ( ) [virtual]

Specify the Speed of navigation. Default is 4.

void vtkVRMLExporter::SetFilePointer ( FILE * )

Set the file pointer to write to. This will override a FileName if specified.

void vtkVRMLExporter::WriteData ( ) [protected, virtual]

Reimplemented from vtkExporter.

void vtkVRMLExporter::WriteALight | ( | vtkLight * | aLight,
 |  | FILE * | fp
 | ) | [protected]

void vtkVRMLExporter::WriteAnActor | ( | vtkActor * | anActor,
 |  | FILE * | fp
 | ) | [protected]

void vtkVRMLExporter::WritePointData | ( | vtkPoints * | points,
 |  | vtkDataArray * | normals,
 |  | vtkDataArray * | tcoords,
 |  | vtkUnsignedCharArray * | colors,
 |  | FILE * | fp
 | ) | [protected]

Member Data Documentation

char* vtkVRMLExporter::FileName [protected]

Definition at line 81 of file vtkVRMLExporter.h.

FILE* vtkVRMLExporter::FilePointer [protected]

Definition at line 82 of file vtkVRMLExporter.h.

float vtkVRMLExporter::Speed [protected]

Definition at line 83 of file vtkVRMLExporter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkVRMLExporter.h
Generated on Mon Mar 25 01:34:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkVRMLImporter Class Reference

imports VRML 2.0 files. More...

#include <vtkVRMLImporter.h>

Inheritance diagram for vtkVRMLImporter:

[legend]
Collaboration diagram for vtkVRMLImporter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkVRMLImporter, vtkImporter)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkObject * | GetVRMLDEFObject (const char *name)
FILE * | GetFileFD ()
void | enterNode (const char *)
void | exitNode ()
void | enterField (const char *)
void | exitField ()
void | useNode (const char *)
virtual void | SetFileName (const char *)
virtual char * | GetFileName ()

Static Public Methods

vtkVRMLImporter * | New ()

Protected Methods

vtkVRMLImporter ()
~vtkVRMLImporter ()
virtual int | ImportBegin ()
virtual void | ImportEnd ()
virtual void | ImportActors (vtkRenderer *)
virtual void | ImportCameras (vtkRenderer *)
virtual void | ImportLights (vtkRenderer *)
virtual void | ImportProperties (vtkRenderer *)
int | OpenImportFile ()

Protected Attributes

char * | FileName
FILE * | FileFD

Friends

int | yylex (vtkVRMLImporter *)

Detailed Description

imports VRML 2.0 files.

Date:
2002/01/22 15:30:42
Revision:
1.15

vtkVRMLImporter imports VRML 2.0 files into vtk.

Warning:
These nodes are currently supported: Appearance IndexedFaceSet Box IndexedLineSet Color Material Cone Shape Coordinate Sphere Cylinder Transform DirectionalLight
Warning:
As you can see this implementation focuses on getting the geometry translated. The routes and scripting nodes are ignored since they deal with directly accessing a nodes internal structure based on the VRML spec. Since this is a translation the internal data structures differ greatly from the VRML spec and the External Authoring Interface (see the VRML spec). The DEF/USE mechanism does allow the Vtk user to extract objects from the scene and directly manipulate them using the native language (Tcl, Python, Java, or whatever language Vtk is wrapped in). This, in a way, removes the need for the route and script mechanism (not completely though).
See also:
vtkImporter
Created by:
  • Citrini, Tom
Contributed by (if > 5%):
  • Citrini, Tom (35%)
  • Lorensen, Bill (32%)
  • Schroeder, Will (26%)
Tests:
vtkVRMLImporter (Tests)

Definition at line 80 of file vtkVRMLImporter.h.

Constructor & Destructor Documentation

vtkVRMLImporter::vtkVRMLImporter ( ) [protected]

vtkVRMLImporter::~vtkVRMLImporter ( ) [protected]

Member Function Documentation

vtkVRMLImporter* vtkVRMLImporter::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkVRMLImporter::vtkTypeRevisionMacro | ( | vtkVRMLImporter | ,
 |  | vtkImporter |
 | ) |

Reimplemented from vtkImporter.

void vtkVRMLImporter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImporter.

vtkObject* vtkVRMLImporter::GetVRMLDEFObject ( const char * name )

In the VRML spec you can DEF and USE nodes (name them), This routine will return the associated VTK object which was created as a result of the DEF mechanism Send in the name from the VRML file, get the VTK object. You will have to check and correctly cast the object since this only returns vtkObjects.

void vtkVRMLImporter::enterNode ( const char * )

Needed by the yacc/lex grammar used

void vtkVRMLImporter::exitNode ( )

Needed by the yacc/lex grammar used

void vtkVRMLImporter::enterField ( const char * )

Needed by the yacc/lex grammar used

void vtkVRMLImporter::exitField ( )

Needed by the yacc/lex grammar used

void vtkVRMLImporter::useNode ( const char * )

Needed by the yacc/lex grammar used

virtual void vtkVRMLImporter::SetFileName ( const char * ) [virtual]

Specify the name of the file to read.

virtual char* vtkVRMLImporter::GetFileName ( ) [virtual]

Specify the name of the file to read.

FILE* vtkVRMLImporter::GetFileFD ( ) [inline]

Return the file pointer to the open file.

Definition at line 111 of file vtkVRMLImporter.h.

virtual int vtkVRMLImporter::ImportBegin ( ) [protected, virtual]

Reimplemented from vtkImporter.

virtual void vtkVRMLImporter::ImportEnd ( ) [protected, virtual]

Reimplemented from vtkImporter.

virtual void vtkVRMLImporter::ImportActors ( vtkRenderer * ) [inline, protected, virtual]

Definition at line 125 of file vtkVRMLImporter.h.

virtual void vtkVRMLImporter::ImportCameras ( vtkRenderer * ) [inline, protected, virtual]

Definition at line 126 of file vtkVRMLImporter.h.

virtual void vtkVRMLImporter::ImportLights ( vtkRenderer * ) [inline, protected, virtual]

Definition at line 127 of file vtkVRMLImporter.h.

virtual void vtkVRMLImporter::ImportProperties ( vtkRenderer * ) [inline, protected, virtual]

Definition at line 128 of file vtkVRMLImporter.h.

int vtkVRMLImporter::OpenImportFile ( ) [protected]

Friends And Related Function Documentation

int yylex ( vtkVRMLImporter * ) [friend]

Member Data Documentation

char* vtkVRMLImporter::FileName [protected]

Definition at line 131 of file vtkVRMLImporter.h.

FILE* vtkVRMLImporter::FileFD [protected]

Definition at line 132 of file vtkVRMLImporter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkVRMLImporter.h
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTK_ERROR_QUADRIC Struct Reference

#include <vtkQuadricDecimation.h>

Collaboration diagram for VTK_ERROR_QUADRIC:

[legend]
List of all members.

Public Attributes

float * Quadric

Member Data Documentation

float* VTK_ERROR_QUADRIC::Quadric

Definition at line 52 of file vtkQuadricDecimation.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkQuadricDecimation.h
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTK_LINE_CASES Struct Reference

#include <vtkMarchingSquaresCases.h>

Collaboration diagram for VTK_LINE_CASES:

[legend]
List of all members.

Static Public Methods

VTK_LINE_CASES * | GetCases ()

Public Attributes

EDGE_LIST | edges [5]

Member Function Documentation

VTK_LINE_CASES* VTK_LINE_CASES::GetCases ( ) [static]

Member Data Documentation

EDGE_LIST VTK_LINE_CASES::edges[5]

Definition at line 25 of file vtkMarchingSquaresCases.h.

The documentation for this struct was generated from the following file:
  • Common/vtkMarchingSquaresCases.h
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTK_POINT_QUADRIC Struct Reference

#include <vtkQuadricClustering.h>

Collaboration diagram for VTK_POINT_QUADRIC:

[legend]
List of all members.

Public Attributes

vtkIdType VertexId
unsigned char | Dimension
float | Quadric [9]

Member Data Documentation

vtkIdType VTK_POINT_QUADRIC::VertexId

Definition at line 87 of file vtkQuadricClustering.h.

unsigned char VTK_POINT_QUADRIC::Dimension

Definition at line 90 of file vtkQuadricClustering.h.

float VTK_POINT_QUADRIC::Quadric[9]

Definition at line 91 of file vtkQuadricClustering.h.

The documentation for this struct was generated from the following file:
  • Graphics/vtkQuadricClustering.h
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTK_TRIANGLE_CASES Struct Reference

#include <vtkMarchingCubesCases.h>

Collaboration diagram for VTK_TRIANGLE_CASES:

[legend]
List of all members.

Static Public Methods

VTK_TRIANGLE_CASES * | GetCases ()

Public Attributes

EDGE_LIST | edges [16]

Member Function Documentation

VTK_TRIANGLE_CASES* VTK_TRIANGLE_CASES::GetCases ( ) [static]

Member Data Documentation

EDGE_LIST VTK_TRIANGLE_CASES::edges[16]

Definition at line 24 of file vtkMarchingCubesCases.h.

The documentation for this struct was generated from the following file:
  • Common/vtkMarchingCubesCases.h
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTKRayCastRayInfo Struct Reference

#include <vtkRayCastStructures.h>

Collaboration diagram for VTKRayCastRayInfo:

[legend]
List of all members.

Public Attributes

float | Origin [3]
float | Direction [3]
int | Pixel [2]
float | CameraPosition [3]
int | ImageSize [2]
float | NearClip
float | FarClip
float | Color [4]
float | Depth
float | TransformedStart [4]
float | TransformedEnd [4]
float | TransformedDirection [4]
float | TransformedIncrement [3]
int | NumberOfStepsToTake
int | NumberOfStepsTaken

Member Data Documentation

float VTKRayCastRayInfo::Origin[3]

Definition at line 44 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::Direction[3]

Definition at line 45 of file vtkRayCastStructures.h.

int VTKRayCastRayInfo::Pixel[2]

Definition at line 51 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::CameraPosition[3]

Definition at line 55 of file vtkRayCastStructures.h.

int VTKRayCastRayInfo::ImageSize[2]

Definition at line 58 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::NearClip

Definition at line 62 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::FarClip

Definition at line 63 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::Color[4]

Definition at line 66 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::Depth

Definition at line 67 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::TransformedStart[4]

Definition at line 76 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::TransformedEnd[4]

Definition at line 77 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::TransformedDirection[4]

Definition at line 78 of file vtkRayCastStructures.h.

float VTKRayCastRayInfo::TransformedIncrement[3]

Definition at line 79 of file vtkRayCastStructures.h.

int VTKRayCastRayInfo::NumberOfStepsToTake

Definition at line 83 of file vtkRayCastStructures.h.

int VTKRayCastRayInfo::NumberOfStepsTaken

Definition at line 87 of file vtkRayCastStructures.h.

The documentation for this struct was generated from the following file:
  • Common/vtkRayCastStructures.h
Generated on Mon Mar 25 01:35:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTKRayCastVolumeInfo Struct Reference

#include <vtkVolumeRayCastStructures.h>

Collaboration diagram for VTKRayCastVolumeInfo:

[legend]
List of all members.

Public Attributes

vtkVolume * Volume
float | WorldToVolumeMatrix [16]
float | VolumeToWorldMatrix [16]
float | ViewToVolumeMatrix [16]
float | CenterDistance
int | ScalarDataType
void * | ScalarDataPointer
int | DataIncrement [3]
int | DataSize [3]
float | DataSpacing [3]
float | DataOrigin [3]
int | Shading
int | ColorChannels
float | Color [3]
int | InterpolationType
float | RGBTextureCoefficient
float * | RedDiffuseShadingTable
float * | GreenDiffuseShadingTable
float * | BlueDiffuseShadingTable
float * | RedSpecularShadingTable
float * | GreenSpecularShadingTable
float * | BlueSpecularShadingTable
unsigned char * | RGBDataPointer
int | RGBDataIncrement [3]
int | RGBDataSize [3]
float | RGBDataSpacing [3]
float | RGBDataOrigin [3]
unsigned short * | EncodedNormals
unsigned char * | GradientMagnitudes

Member Data Documentation

vtkVolume* VTKRayCastVolumeInfo::Volume

Definition at line 44 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::WorldToVolumeMatrix[16]

Definition at line 47 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::VolumeToWorldMatrix[16]

Definition at line 48 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::ViewToVolumeMatrix[16]

Definition at line 49 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::CenterDistance

Definition at line 53 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::ScalarDataType

Definition at line 57 of file vtkVolumeRayCastStructures.h.

void* VTKRayCastVolumeInfo::ScalarDataPointer

Definition at line 58 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::DataIncrement[3]

Definition at line 59 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::DataSize[3]

Definition at line 60 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::DataSpacing[3]

Definition at line 61 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::DataOrigin[3]

Definition at line 62 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::Shading

Definition at line 65 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::ColorChannels

Definition at line 66 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::Color[3]

Definition at line 67 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::InterpolationType

Definition at line 68 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::RGBTextureCoefficient

Definition at line 69 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::RedDiffuseShadingTable

Definition at line 73 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::GreenDiffuseShadingTable

Definition at line 74 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::BlueDiffuseShadingTable

Definition at line 75 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::RedSpecularShadingTable

Definition at line 76 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::GreenSpecularShadingTable

Definition at line 77 of file vtkVolumeRayCastStructures.h.

float* VTKRayCastVolumeInfo::BlueSpecularShadingTable

Definition at line 78 of file vtkVolumeRayCastStructures.h.

unsigned char* VTKRayCastVolumeInfo::RGBDataPointer

Definition at line 83 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::RGBDataIncrement[3]

Definition at line 84 of file vtkVolumeRayCastStructures.h.

int VTKRayCastVolumeInfo::RGBDataSize[3]

Definition at line 85 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::RGBDataSpacing[3]

Definition at line 86 of file vtkVolumeRayCastStructures.h.

float VTKRayCastVolumeInfo::RGBDataOrigin[3]

Definition at line 87 of file vtkVolumeRayCastStructures.h.

unsigned short* VTKRayCastVolumeInfo::EncodedNormals

Definition at line 90 of file vtkVolumeRayCastStructures.h.

unsigned char* VTKRayCastVolumeInfo::GradientMagnitudes

Definition at line 91 of file vtkVolumeRayCastStructures.h.

The documentation for this struct was generated from the following file:
  • Rendering/vtkVolumeRayCastStructures.h
Generated on Mon Mar 25 01:35:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTKVRCDynamicInfo Struct Reference

#include <vtkVolumeRayCastFunction.h>

Collaboration diagram for VTKVRCDynamicInfo:

[legend]
List of all members.

Public Attributes

float | Color [4]
float | ScalarValue
float | TransformedStart [4]
float | TransformedEnd [4]
float | TransformedDirection [4]
float | TransformedIncrement [3]
int | NumberOfStepsToTake
int | NumberOfStepsTaken

Member Data Documentation

float VTKVRCDynamicInfo::Color[4]

Definition at line 55 of file vtkVolumeRayCastFunction.h.

float VTKVRCDynamicInfo::ScalarValue

Definition at line 56 of file vtkVolumeRayCastFunction.h.

float VTKVRCDynamicInfo::TransformedStart[4]

Definition at line 59 of file vtkVolumeRayCastFunction.h.

float VTKVRCDynamicInfo::TransformedEnd[4]

Definition at line 60 of file vtkVolumeRayCastFunction.h.

float VTKVRCDynamicInfo::TransformedDirection[4]

Definition at line 61 of file vtkVolumeRayCastFunction.h.

float VTKVRCDynamicInfo::TransformedIncrement[3]

Definition at line 62 of file vtkVolumeRayCastFunction.h.

int VTKVRCDynamicInfo::NumberOfStepsToTake

Definition at line 66 of file vtkVolumeRayCastFunction.h.

int VTKVRCDynamicInfo::NumberOfStepsTaken

Definition at line 70 of file vtkVolumeRayCastFunction.h.

The documentation for this struct was generated from the following file:
  • Rendering/vtkVolumeRayCastFunction.h
Generated on Mon Mar 25 01:35:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


VTKVRCStaticInfo Struct Reference

#include <vtkVolumeRayCastFunction.h>

Collaboration diagram for VTKVRCStaticInfo:

[legend]
List of all members.

Public Attributes

vtkVolume * Volume
vtkRenderer * Renderer
float | WorldToVoxelsMatrix [16]
float | VoxelsToWorldMatrix [16]
float | ViewToVoxelsMatrix [16]
float * | ClippingPlane
int | NumberOfClippingPlanes
float | CameraThickness
int | ScalarDataType
void * | ScalarDataPointer
int | DataIncrement [3]
int | DataSize [3]
float | DataSpacing [3]
float | DataOrigin [3]
int | Shading
int | ColorChannels
float | Color [3]
int | InterpolationType
float * | RedDiffuseShadingTable
float * | GreenDiffuseShadingTable
float * | BlueDiffuseShadingTable
float * | RedSpecularShadingTable
float * | GreenSpecularShadingTable
float * | BlueSpecularShadingTable
unsigned short * | EncodedNormals
unsigned char * | GradientMagnitudes
int | ImageInUseSize [2]
int | ImageMemorySize [2]
int | ImageViewportSize [2]
int | ImageOrigin [2]
unsigned char * | Image
int * | RowBounds
int | MIPFunction
int | MaximizeOpacity

Member Data Documentation

vtkVolume* VTKVRCStaticInfo::Volume

Definition at line 79 of file vtkVolumeRayCastFunction.h.

vtkRenderer* VTKVRCStaticInfo::Renderer

Definition at line 82 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::WorldToVoxelsMatrix[16]

Definition at line 85 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::VoxelsToWorldMatrix[16]

Definition at line 86 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::ViewToVoxelsMatrix[16]

Definition at line 87 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::ClippingPlane

Definition at line 89 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::NumberOfClippingPlanes

Definition at line 90 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::CameraThickness

Definition at line 94 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ScalarDataType

Definition at line 98 of file vtkVolumeRayCastFunction.h.

void* VTKVRCStaticInfo::ScalarDataPointer

Definition at line 99 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::DataIncrement[3]

Definition at line 100 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::DataSize[3]

Definition at line 101 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::DataSpacing[3]

Definition at line 102 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::DataOrigin[3]

Definition at line 103 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::Shading

Definition at line 106 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ColorChannels

Definition at line 107 of file vtkVolumeRayCastFunction.h.

float VTKVRCStaticInfo::Color[3]

Definition at line 108 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::InterpolationType

Definition at line 109 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::RedDiffuseShadingTable

Definition at line 113 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::GreenDiffuseShadingTable

Definition at line 114 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::BlueDiffuseShadingTable

Definition at line 115 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::RedSpecularShadingTable

Definition at line 116 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::GreenSpecularShadingTable

Definition at line 117 of file vtkVolumeRayCastFunction.h.

float* VTKVRCStaticInfo::BlueSpecularShadingTable

Definition at line 118 of file vtkVolumeRayCastFunction.h.

unsigned short* VTKVRCStaticInfo::EncodedNormals

Definition at line 121 of file vtkVolumeRayCastFunction.h.

unsigned char* VTKVRCStaticInfo::GradientMagnitudes

Definition at line 122 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ImageInUseSize[2]

Definition at line 125 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ImageMemorySize[2]

Definition at line 126 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ImageViewportSize[2]

Definition at line 127 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::ImageOrigin[2]

Definition at line 128 of file vtkVolumeRayCastFunction.h.

unsigned char* VTKVRCStaticInfo::Image

Definition at line 129 of file vtkVolumeRayCastFunction.h.

int* VTKVRCStaticInfo::RowBounds

Definition at line 131 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::MIPFunction

Definition at line 138 of file vtkVolumeRayCastFunction.h.

int VTKVRCStaticInfo::MaximizeOpacity

Definition at line 139 of file vtkVolumeRayCastFunction.h.

The documentation for this struct was generated from the following file:
  • Rendering/vtkVolumeRayCastFunction.h
Generated on Mon Mar 25 01:35:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpLens Class Reference

deform geometry by applying lens distortion. More...

#include <vtkWarpLens.h>

Inheritance diagram for vtkWarpLens:

[legend]
Collaboration diagram for vtkWarpLens:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWarpLens, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetKappa (float kappa)
float | GetKappa ()
void | SetCenter (float centerX, float centerY)
float * | GetCenter ()
virtual void | SetPrincipalPoint (float, float)
void | SetPrincipalPoint (float[2])
virtual float * | GetPrincipalPoint ()
virtual void | GetPrincipalPoint (float data[2])
virtual void | SetK1 (float)
virtual float | GetK1 ()
virtual void | SetK2 (float)
virtual float | GetK2 ()
virtual void | SetP1 (float)
virtual float | GetP1 ()
virtual void | SetP2 (float)
virtual float | GetP2 ()
virtual void | SetFormatWidth (float)
virtual float | GetFormatWidth ()
virtual void | SetFormatHeight (float)
virtual float | GetFormatHeight ()
virtual void | SetImageWidth (int)
virtual int | GetImageWidth ()
virtual void | SetImageHeight (int)
virtual int | GetImageHeight ()

Static Public Methods

vtkWarpLens * | New ()

Protected Methods

vtkWarpLens ()
~vtkWarpLens ()
void | Execute ()

Protected Attributes

float | PrincipalPoint [2]
float | K1
float | K2
float | P1
float | P2
float | FormatWidth
float | FormatHeight
int | ImageWidth
int | ImageHeight

Detailed Description

deform geometry by applying lens distortion.

Date:
2002/01/22 15:29:55
Revision:
1.23

vtkWarpLens is a filter that modifies point coordinates by moving in accord with a lens distortion model.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (47%)
  • Lorensen, Bill (43%)
Tests:
vtkWarpLens (Tests)

Definition at line 41 of file vtkWarpLens.h.

Constructor & Destructor Documentation

vtkWarpLens::vtkWarpLens ( ) [protected]

vtkWarpLens::~vtkWarpLens ( ) [inline, protected]

Definition at line 103 of file vtkWarpLens.h.

Member Function Documentation

vtkWarpLens* vtkWarpLens::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkWarpLens::vtkTypeRevisionMacro | ( | vtkWarpLens | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkWarpLens::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkWarpLens::SetKappa ( float kappa )

Specify second order symmetric radial lens distortion parameter. This is obsoleted by newer instance variables.

float vtkWarpLens::GetKappa ( )

Specify second order symmetric radial lens distortion parameter. This is obsoleted by newer instance variables.

void vtkWarpLens::SetCenter | ( | float | centerX,
 |  | float | centerY
 | ) |

Specify the center of radial distortion in pixels. This is obsoleted by newer instance variables.

float* vtkWarpLens::GetCenter ( )

Specify the center of radial distortion in pixels. This is obsoleted by newer instance variables.

virtual void vtkWarpLens::SetPrincipalPoint | ( | float | ,
 |  | float |
 | ) | [virtual]

Specify the calibrated principal point of the camera/lens

void vtkWarpLens::SetPrincipalPoint ( float [2] )

Specify the calibrated principal point of the camera/lens

virtual float* vtkWarpLens::GetPrincipalPoint ( ) [virtual]

Specify the calibrated principal point of the camera/lens

virtual void vtkWarpLens::GetPrincipalPoint ( float data[2] ) [virtual]

Specify the calibrated principal point of the camera/lens

virtual void vtkWarpLens::SetK1 ( float ) [virtual]

Specify the symmetric radial distortion parameters for the lens

virtual float vtkWarpLens::GetK1 ( ) [virtual]

Specify the symmetric radial distortion parameters for the lens

virtual void vtkWarpLens::SetK2 ( float ) [virtual]

Specify the symmetric radial distortion parameters for the lens

virtual float vtkWarpLens::GetK2 ( ) [virtual]

Specify the symmetric radial distortion parameters for the lens

virtual void vtkWarpLens::SetP1 ( float ) [virtual]

Specify the decentering distortion parameters for the lens

virtual float vtkWarpLens::GetP1 ( ) [virtual]

Specify the decentering distortion parameters for the lens

virtual void vtkWarpLens::SetP2 ( float ) [virtual]

Specify the decentering distortion parameters for the lens

virtual float vtkWarpLens::GetP2 ( ) [virtual]

Specify the decentering distortion parameters for the lens

virtual void vtkWarpLens::SetFormatWidth ( float ) [virtual]

Specify the imager format width / height in mm

virtual float vtkWarpLens::GetFormatWidth ( ) [virtual]

Specify the imager format width / height in mm

virtual void vtkWarpLens::SetFormatHeight ( float ) [virtual]

Specify the imager format width / height in mm

virtual float vtkWarpLens::GetFormatHeight ( ) [virtual]

Specify the imager format width / height in mm

virtual void vtkWarpLens::SetImageWidth ( int ) [virtual]

Specify the image width / height in pixels

virtual int vtkWarpLens::GetImageWidth ( ) [virtual]

Specify the image width / height in pixels

virtual void vtkWarpLens::SetImageHeight ( int ) [virtual]

Specify the image width / height in pixels

virtual int vtkWarpLens::GetImageHeight ( ) [virtual]

Specify the image width / height in pixels

void vtkWarpLens::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkWarpLens::PrincipalPoint[2] [protected]

Definition at line 107 of file vtkWarpLens.h.

float vtkWarpLens::K1 [protected]

Definition at line 108 of file vtkWarpLens.h.

float vtkWarpLens::K2 [protected]

Definition at line 109 of file vtkWarpLens.h.

float vtkWarpLens::P1 [protected]

Definition at line 110 of file vtkWarpLens.h.

float vtkWarpLens::P2 [protected]

Definition at line 111 of file vtkWarpLens.h.

float vtkWarpLens::FormatWidth [protected]

Definition at line 112 of file vtkWarpLens.h.

float vtkWarpLens::FormatHeight [protected]

Definition at line 113 of file vtkWarpLens.h.

int vtkWarpLens::ImageWidth [protected]

Definition at line 114 of file vtkWarpLens.h.

int vtkWarpLens::ImageHeight [protected]

Definition at line 115 of file vtkWarpLens.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkWarpLens.h
Generated on Mon Mar 25 01:35:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpScalar Class Reference

deform geometry with scalar data. More...

#include <vtkWarpScalar.h>

Inheritance diagram for vtkWarpScalar:

[legend]
Collaboration diagram for vtkWarpScalar:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWarpScalar, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual void | SetUseNormal (int)
virtual int | GetUseNormal ()
virtual void | UseNormalOn ()
virtual void | UseNormalOff ()
virtual void | SetNormal (float, float, float)
virtual void | SetNormal (float[3])
virtual float * | GetNormal ()
virtual void | GetNormal (float data[3])
virtual void | SetXYPlane (int)
virtual int | GetXYPlane ()
virtual void | XYPlaneOn ()
virtual void | XYPlaneOff ()
virtual char * | GetInputScalarsSelection ()
void | SelectInputScalars (const char *fieldName)

Static Public Methods

vtkWarpScalar * | New ()

Protected Methods

vtkWarpScalar ()
~vtkWarpScalar ()
void | Execute ()
float * | DataNormal (vtkIdType id, vtkDataArray *normals=NULL)
float * | InstanceNormal (vtkIdType id, vtkDataArray *normals=NULL)
float * | ZNormal (vtkIdType id, vtkDataArray *normals=NULL)
virtual void | SetInputScalarsSelection (const char *)

Protected Attributes

float | ScaleFactor
int | UseNormal
float | Normal [3]
int | XYPlane
float *(vtkWarpScalar::* | PointNormal )(vtkIdType id, vtkDataArray *normals)
char * | InputScalarsSelection

Detailed Description

deform geometry with scalar data.

Date:
2002/01/22 15:29:56
Revision:
1.37

vtkWarpScalar is a filter that modifies point coordinates by moving points along point normals by the scalar amount times the scale factor. Useful for creating carpet or x-y-z plots.

If normals are not present in data, the Normal instance variable will be used as the direction along which to warp the geometry. If normals are present but you would like to use the Normal instance variable, set the UseNormal boolean to true.

If XYPlane boolean is set true, then the z-value is considered to be a scalar value (still scaled by scale factor), and the displacement is along the z-axis. If scalars are also present, these are copied through and can be used to color the surface.

Note that the filter passes both its point data and cell data to its output, except for normals, since these are distorted by the warping.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (66%)
  • Law, Charles (8%)
  • Geveci, Berk (7%)
  • Martin, Ken (7%)
  • Henderson, Amy (5%)
Examples:
vtkWarpScalar (Examples)
Tests:
vtkWarpScalar (Tests)

Definition at line 62 of file vtkWarpScalar.h.

Constructor & Destructor Documentation

vtkWarpScalar::vtkWarpScalar ( ) [protected]

vtkWarpScalar::~vtkWarpScalar ( ) [protected]

Member Function Documentation

vtkWarpScalar* vtkWarpScalar::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkWarpScalar::vtkTypeRevisionMacro | ( | vtkWarpScalar | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkWarpScalar::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkWarpScalar::SetScaleFactor ( float ) [virtual]

Specify value to scale displacement.

virtual float vtkWarpScalar::GetScaleFactor ( ) [virtual]

Specify value to scale displacement.

virtual void vtkWarpScalar::SetUseNormal ( int ) [virtual]

Turn on/off use of user specified normal. If on, data normals will be ignored and instance variable Normal will be used instead.

virtual int vtkWarpScalar::GetUseNormal ( ) [virtual]

Turn on/off use of user specified normal. If on, data normals will be ignored and instance variable Normal will be used instead.

virtual void vtkWarpScalar::UseNormalOn ( ) [virtual]

Turn on/off use of user specified normal. If on, data normals will be ignored and instance variable Normal will be used instead.

virtual void vtkWarpScalar::UseNormalOff ( ) [virtual]

Turn on/off use of user specified normal. If on, data normals will be ignored and instance variable Normal will be used instead.

virtual void vtkWarpScalar::SetNormal | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Normal (i.e., direction) along which to warp geometry. Only used if UseNormal boolean set to true or no normals available in data.

virtual void vtkWarpScalar::SetNormal ( float [3] ) [virtual]

Normal (i.e., direction) along which to warp geometry. Only used if UseNormal boolean set to true or no normals available in data.

virtual float* vtkWarpScalar::GetNormal ( ) [virtual]

Normal (i.e., direction) along which to warp geometry. Only used if UseNormal boolean set to true or no normals available in data.

virtual void vtkWarpScalar::GetNormal ( float data[3] ) [virtual]

Normal (i.e., direction) along which to warp geometry. Only used if UseNormal boolean set to true or no normals available in data.

virtual void vtkWarpScalar::SetXYPlane ( int ) [virtual]

Turn on/off flag specifying that input data is x-y plane. If x-y plane, then the z value is used to warp the surface in the z-axis direction (times the scale factor) and scalars are used to color the surface.

virtual int vtkWarpScalar::GetXYPlane ( ) [virtual]

Turn on/off flag specifying that input data is x-y plane. If x-y plane, then the z value is used to warp the surface in the z-axis direction (times the scale factor) and scalars are used to color the surface.

virtual void vtkWarpScalar::XYPlaneOn ( ) [virtual]

Turn on/off flag specifying that input data is x-y plane. If x-y plane, then the z value is used to warp the surface in the z-axis direction (times the scale factor) and scalars are used to color the surface.

virtual void vtkWarpScalar::XYPlaneOff ( ) [virtual]

Turn on/off flag specifying that input data is x-y plane. If x-y plane, then the z value is used to warp the surface in the z-axis direction (times the scale factor) and scalars are used to color the surface.

virtual char* vtkWarpScalar::GetInputScalarsSelection ( ) [virtual]

If you want to warp by an arbitrary scalar array, then set its name here. By default this in NULL and the filter will use the active scalar array.

void vtkWarpScalar::SelectInputScalars ( const char * fieldName ) [inline]

If you want to warp by an arbitrary scalar array, then set its name here. By default this in NULL and the filter will use the active scalar array.

Definition at line 105 of file vtkWarpScalar.h.

void vtkWarpScalar::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

float* vtkWarpScalar::DataNormal | ( | vtkIdType | id,
 |  | vtkDataArray * | normals = NULL
 | ) | [protected]

float* vtkWarpScalar::InstanceNormal | ( | vtkIdType | id,
 |  | vtkDataArray * | normals = NULL
 | ) | [protected]

float* vtkWarpScalar::ZNormal | ( | vtkIdType | id,
 |  | vtkDataArray * | normals = NULL
 | ) | [protected]

virtual void vtkWarpScalar::SetInputScalarsSelection ( const char * ) [protected, virtual]

Member Data Documentation

float vtkWarpScalar::ScaleFactor [protected]

Definition at line 115 of file vtkWarpScalar.h.

int vtkWarpScalar::UseNormal [protected]

Definition at line 116 of file vtkWarpScalar.h.

float vtkWarpScalar::Normal[3] [protected]

Definition at line 117 of file vtkWarpScalar.h.

int vtkWarpScalar::XYPlane [protected]

Definition at line 118 of file vtkWarpScalar.h.

float*(vtkWarpScalar::* vtkWarpScalar::PointNormal)(vtkIdType id, vtkDataArray *normals) [protected]

char* vtkWarpScalar::InputScalarsSelection [protected]

Definition at line 127 of file vtkWarpScalar.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkWarpScalar.h
Generated on Mon Mar 25 01:35:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpTo Class Reference

deform geometry by warping towards a point. More...

#include <vtkWarpTo.h>

Inheritance diagram for vtkWarpTo:

[legend]
Collaboration diagram for vtkWarpTo:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWarpTo, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual float * | GetPosition ()
virtual void | GetPosition (float data[3])
virtual void | SetPosition (float, float, float)
virtual void | SetPosition (float[3])
virtual void | SetAbsolute (int)
virtual int | GetAbsolute ()
virtual void | AbsoluteOn ()
virtual void | AbsoluteOff ()

Static Public Methods

vtkWarpTo * | New ()

Protected Methods

vtkWarpTo ()
~vtkWarpTo ()
void | Execute ()

Protected Attributes

float | ScaleFactor
float | Position [3]
int | Absolute

Detailed Description

deform geometry by warping towards a point.

Date:
2002/01/22 15:29:56
Revision:
1.33

vtkWarpTo is a filter that modifies point coordinates by moving the points towards a user specified position.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Lorensen, Bill (7%)
  • Schroeder, Will (6%)
Tests:
vtkWarpTo (Tests)

Definition at line 42 of file vtkWarpTo.h.

Constructor & Destructor Documentation

vtkWarpTo::vtkWarpTo ( ) [protected]

vtkWarpTo::~vtkWarpTo ( ) [inline, protected]

Definition at line 71 of file vtkWarpTo.h.

Member Function Documentation

vtkWarpTo* vtkWarpTo::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkWarpTo::vtkTypeRevisionMacro | ( | vtkWarpTo | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkWarpTo::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkWarpTo::SetScaleFactor ( float ) [virtual]

Set/Get the value to scale displacement.

virtual float vtkWarpTo::GetScaleFactor ( ) [virtual]

Set/Get the value to scale displacement.

virtual float* vtkWarpTo::GetPosition ( ) [virtual]

Set/Get the position to warp towards.

virtual void vtkWarpTo::GetPosition ( float data[3] ) [virtual]

Set/Get the position to warp towards.

virtual void vtkWarpTo::SetPosition | ( | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set/Get the position to warp towards.

virtual void vtkWarpTo::SetPosition ( float [3] ) [virtual]

Set/Get the position to warp towards.

virtual void vtkWarpTo::SetAbsolute ( int ) [virtual]

Set/Get the Absolute ivar. Turning Absolute on causes scale factor of the new position to be one unit away from Position.

virtual int vtkWarpTo::GetAbsolute ( ) [virtual]

Set/Get the Absolute ivar. Turning Absolute on causes scale factor of the new position to be one unit away from Position.

virtual void vtkWarpTo::AbsoluteOn ( ) [virtual]

Set/Get the Absolute ivar. Turning Absolute on causes scale factor of the new position to be one unit away from Position.

virtual void vtkWarpTo::AbsoluteOff ( ) [virtual]

Set/Get the Absolute ivar. Turning Absolute on causes scale factor of the new position to be one unit away from Position.

void vtkWarpTo::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

float vtkWarpTo::ScaleFactor [protected]

Definition at line 74 of file vtkWarpTo.h.

float vtkWarpTo::Position[3] [protected]

Definition at line 75 of file vtkWarpTo.h.

int vtkWarpTo::Absolute [protected]

Definition at line 76 of file vtkWarpTo.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkWarpTo.h
Generated on Mon Mar 25 01:35:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpTransform Class Reference

superclass for nonlinear geometric transformations. More...

#include <vtkWarpTransform.h>

Inheritance diagram for vtkWarpTransform:

[legend]
Collaboration diagram for vtkWarpTransform:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWarpTransform, vtkAbstractTransform)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Inverse ()
virtual int | GetInverseFlag ()
virtual void | SetInverseTolerance (double)
virtual double | GetInverseTolerance ()
virtual void | SetInverseIterations (int)
virtual int | GetInverseIterations ()
void | InternalTransformPoint (const float in[3], float out[3])
void | InternalTransformPoint (const double in[3], double out[3])
void | InternalTransformDerivative (const float in[3], float out[3], float derivative[3][3])
void | InternalTransformDerivative (const double in[3], double out[3], double derivative[3][3])
void | TemplateTransformPoint (const float in[3], float out[3])
void | TemplateTransformPoint (const double in[3], double out[3])
void | TemplateTransformPoint (const float in[3], float out[3], float derivative[3][3])
void | TemplateTransformPoint (const double in[3], double out[3], double derivative[3][3])
void | TemplateTransformInverse (const float in[3], float out[3])
void | TemplateTransformInverse (const double in[3], double out[3])
void | TemplateTransformInverse (const float in[3], float out[3], float derivative[3][3])
void | TemplateTransformInverse (const double in[3], double out[3], double derivative[3][3])

Protected Methods

vtkWarpTransform ()
~vtkWarpTransform ()
virtual void | ForwardTransformPoint (const float in[3], float out[3])=0
virtual void | ForwardTransformPoint (const double in[3], double out[3])=0
virtual void | ForwardTransformDerivative (const float in[3], float out[3], float derivative[3][3])=0
virtual void | ForwardTransformDerivative (const double in[3], double out[3], double derivative[3][3])=0
virtual void | InverseTransformPoint (const float in[3], float out[3])
virtual void | InverseTransformPoint (const double in[3], double out[3])
virtual void | InverseTransformDerivative (const float in[3], float out[3], float derivative[3][3])
virtual void | InverseTransformDerivative (const double in[3], double out[3], double derivative[3][3])

Protected Attributes

int | InverseFlag
int | InverseIterations
double | InverseTolerance

Detailed Description

superclass for nonlinear geometric transformations.

Date:
2002/01/22 15:26:42
Revision:
1.11

vtkWarpTransform provides a generic interface for nonlinear warp transformations.

See also:
vtkThinPlateSplineTransform vtkGridTransform vtkGeneralTransform
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)

Definition at line 39 of file vtkWarpTransform.h.

Constructor & Destructor Documentation

vtkWarpTransform::vtkWarpTransform ( ) [protected]

vtkWarpTransform::~vtkWarpTransform ( ) [protected]

Member Function Documentation

vtkWarpTransform::vtkTypeRevisionMacro | ( | vtkWarpTransform | ,
 |  | vtkAbstractTransform |
 | ) |

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

void vtkWarpTransform::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractTransform.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

void vtkWarpTransform::Inverse ( ) [virtual]

Invert the transformation. Warp transformations are usually inverted using an iterative technique such as Newton's method. The inverse transform is usually around five or six times as computationally expensive as the forward transform.

Reimplemented from vtkAbstractTransform.

virtual int vtkWarpTransform::GetInverseFlag ( ) [virtual]

Get the inverse flag of the transformation. This flag is set to zero when the transformation is first created, and is flipped each time Inverse() is called.

virtual void vtkWarpTransform::SetInverseTolerance ( double ) [virtual]

Set the tolerance for inverse transformation. The default is 0.001.

virtual double vtkWarpTransform::GetInverseTolerance ( ) [virtual]

Set the tolerance for inverse transformation. The default is 0.001.

virtual void vtkWarpTransform::SetInverseIterations ( int ) [virtual]

Set the maximum number of iterations for the inverse transformation. The default is 500, but usually only 2 to 5 iterations are used. The inversion method is fairly robust, and it should converge for nearly all smooth transformations that do not fold back on themselves.

virtual int vtkWarpTransform::GetInverseIterations ( ) [virtual]

Set the maximum number of iterations for the inverse transformation. The default is 500, but usually only 2 to 5 iterations are used. The inversion method is fairly robust, and it should converge for nearly all smooth transformations that do not fold back on themselves.

void vtkWarpTransform::InternalTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkWarpTransform::InternalTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [virtual]

This will calculate the transformation without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkWarpTransform::InternalTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation, as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkWarpTransform::InternalTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [virtual]

This will calculate the transformation, as well as its derivative without calling Update. Meant for use only within other VTK classes.

Reimplemented from vtkAbstractTransform.

void vtkWarpTransform::TemplateTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 95 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 97 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformPoint | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 99 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformPoint | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 102 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformInverse | ( | const float | in[3],
 |  | float | out[3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 105 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformInverse | ( | const double | in[3],
 |  | double | out[3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 107 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformInverse | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 109 of file vtkWarpTransform.h.

void vtkWarpTransform::TemplateTransformInverse | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [inline]

Do not use these methods. They exists only as a work-around for internal templated functions (I really didn't want to make the Forward/Inverse methods public, is there a decent work around for this sort of thing?)

Definition at line 112 of file vtkWarpTransform.h.

virtual void vtkWarpTransform::ForwardTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [protected, pure virtual]

If the InverseFlag is set to 0, then a call to InternalTransformPoint results in a call to ForwardTransformPoint.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

virtual void vtkWarpTransform::ForwardTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [protected, pure virtual]

If the InverseFlag is set to 0, then a call to InternalTransformPoint results in a call to ForwardTransformPoint.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

virtual void vtkWarpTransform::ForwardTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [protected, pure virtual]

Calculate the forward transform as well as the derivative.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

virtual void vtkWarpTransform::ForwardTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [protected, pure virtual]

Calculate the forward transform as well as the derivative.

Reimplemented in vtkGridTransform, and vtkThinPlateSplineTransform.

virtual void vtkWarpTransform::InverseTransformPoint | ( | const float | in[3],
 |  | float | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 1, then a call to InternalTransformPoint results in a call to InverseTransformPoint. The inverse transformation is calculated from using Newton's method.

Reimplemented in vtkGridTransform.

virtual void vtkWarpTransform::InverseTransformPoint | ( | const double | in[3],
 |  | double | out[3]
 | ) | [protected, virtual]

If the InverseFlag is set to 1, then a call to InternalTransformPoint results in a call to InverseTransformPoint. The inverse transformation is calculated from using Newton's method.

Reimplemented in vtkGridTransform.

virtual void vtkWarpTransform::InverseTransformDerivative | ( | const float | in[3],
 |  | float | out[3],
 |  | float | derivative[3][3]
 | ) | [protected, virtual]

Calculate the inverse transform as well as the derivative of the forward transform (that's correct: the derivative of the forward transform, not of the inverse transform)

Reimplemented in vtkGridTransform.

virtual void vtkWarpTransform::InverseTransformDerivative | ( | const double | in[3],
 |  | double | out[3],
 |  | double | derivative[3][3]
 | ) | [protected, virtual]

Calculate the inverse transform as well as the derivative of the forward transform (that's correct: the derivative of the forward transform, not of the inverse transform)

Reimplemented in vtkGridTransform.

Member Data Documentation

int vtkWarpTransform::InverseFlag [protected]

Definition at line 154 of file vtkWarpTransform.h.

int vtkWarpTransform::InverseIterations [protected]

Definition at line 155 of file vtkWarpTransform.h.

double vtkWarpTransform::InverseTolerance [protected]

Definition at line 156 of file vtkWarpTransform.h.

The documentation for this class was generated from the following file:
  • Common/vtkWarpTransform.h
Generated on Mon Mar 25 01:35:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWarpVector Class Reference

deform geometry with vector data. More...

#include <vtkWarpVector.h>

Inheritance diagram for vtkWarpVector:

[legend]
Collaboration diagram for vtkWarpVector:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWarpVector, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetScaleFactor (float)
virtual float | GetScaleFactor ()
virtual char * | GetInputVectorsSelection ()
void | SelectInputVectors (const char *fieldName)

Static Public Methods

vtkWarpVector * | New ()

Protected Methods

vtkWarpVector ()
~vtkWarpVector ()
void | Execute ()
virtual void | SetInputVectorsSelection (const char *)

Protected Attributes

float | ScaleFactor
char * | InputVectorsSelection

Detailed Description

deform geometry with vector data.

Date:
2002/01/22 15:29:56
Revision:
1.36

vtkWarpVector is a filter that modifies point coordinates by moving points along vector times the scale factor. Useful for showing flow profiles or mechanical deformation.

The filter passes both its point data and cell data to its output.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (46%)
  • Martin, Ken (36%)
  • Law, Charles (10%)
Examples:
vtkWarpVector (Examples)
Tests:
vtkWarpVector (Tests)

Definition at line 48 of file vtkWarpVector.h.

Constructor & Destructor Documentation

vtkWarpVector::vtkWarpVector ( ) [protected]

vtkWarpVector::~vtkWarpVector ( ) [protected]

Member Function Documentation

vtkWarpVector* vtkWarpVector::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkWarpVector::vtkTypeRevisionMacro | ( | vtkWarpVector | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkWarpVector::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

virtual void vtkWarpVector::SetScaleFactor ( float ) [virtual]

Specify value to scale displacement.

virtual float vtkWarpVector::GetScaleFactor ( ) [virtual]

Specify value to scale displacement.

virtual char* vtkWarpVector::GetInputVectorsSelection ( ) [virtual]

If you want to warp by an arbitrary vector array, then set its name here. By default this in NULL and the filter will use the active vector array.

void vtkWarpVector::SelectInputVectors ( const char * fieldName ) [inline]

If you want to warp by an arbitrary vector array, then set its name here. By default this in NULL and the filter will use the active vector array.

Definition at line 66 of file vtkWarpVector.h.

void vtkWarpVector::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

virtual void vtkWarpVector::SetInputVectorsSelection ( const char * ) [protected, virtual]

Member Data Documentation

float vtkWarpVector::ScaleFactor [protected]

Definition at line 75 of file vtkWarpVector.h.

char* vtkWarpVector::InputVectorsSelection [protected]

Definition at line 77 of file vtkWarpVector.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkWarpVector.h
Generated on Mon Mar 25 01:35:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWedge Class Reference

a 3D cell that represents a wedge. More...

#include <vtkWedge.h>

Inheritance diagram for vtkWedge:

[legend]
Collaboration diagram for vtkWedge:

[legend]
List of all members.

[NOHEADER]

int | JacobianInverse (float pcoords[3], double **inverse, float derivs[18])
void | InterpolationFunctions (float pcoords[3], float weights[6])
void | InterpolationDerivs (float pcoords[3], float derivs[18])
int * | GetEdgeArray (int edgeId)
int * | GetFaceArray (int faceId)

Public Methods

vtkTypeRevisionMacro (vtkWedge, vtkCell)
int | GetParametricCenter (float pcoords[3])
virtual void | GetEdgePoints (int edgeId, int *&pts)
virtual void | GetFacePoints (int faceId, int *&pts)
vtkCell * MakeObject ()
int | GetCellType ()
int | GetCellDimension ()
int | GetNumberOfEdges ()
int | GetNumberOfFaces ()
vtkCell * | GetEdge (int edgeId)
vtkCell * | GetFace (int faceId)
int | CellBoundary (int subId, float pcoords[3], vtkIdList *pts)
void | Contour (float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)
int | EvaluatePosition (float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)
void | EvaluateLocation (int &subId, float pcoords[3], float x[3], float *weights)
int | IntersectWithLine (float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)
int | Triangulate (int index, vtkIdList *ptIds, vtkPoints *pts)
void | Derivatives (int subId, float pcoords[3], float *values, int dim, float *derivs)

Static Public Methods

vtkWedge * | New ()

Protected Methods

vtkWedge ()
~vtkWedge ()

Protected Attributes

vtkLine * Line
vtkTriangle * Triangle
vtkQuad * Quad

Detailed Description

a 3D cell that represents a wedge.

Date:
2002/01/22 15:26:43
Revision:
1.20

vtkWedge is a concrete implementation of vtkCell to represent a 3D wedge. A wedge consists of two triangular and three quadrilateral faces.

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (83%)
  • Geveci, Berk (8%)
Examples:
vtkWedge (Examples)
Tests:
vtkWedge (Tests)

Definition at line 50 of file vtkWedge.h.

Constructor & Destructor Documentation

vtkWedge::vtkWedge ( ) [protected]

vtkWedge::~vtkWedge ( ) [protected]

Member Function Documentation

vtkWedge* vtkWedge::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkWedge::vtkTypeRevisionMacro | ( | vtkWedge | ,
 |  | vtkCell |
 | ) |

Reimplemented from vtkCell3D.

virtual void vtkWedge::GetEdgePoints | ( | int | edgeId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

virtual void vtkWedge::GetFacePoints | ( | int | faceId,
 |  | int *& | pts
 | ) | [virtual]

See vtkCell3D API for description of these methods.

Reimplemented from vtkCell3D.

vtkCell* vtkWedge::MakeObject ( ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::GetCellType ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 65 of file vtkWedge.h.

int vtkWedge::GetCellDimension ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell3D.

Definition at line 66 of file vtkWedge.h.

int vtkWedge::GetNumberOfEdges ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 67 of file vtkWedge.h.

int vtkWedge::GetNumberOfFaces ( ) [inline, virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

Definition at line 68 of file vtkWedge.h.

vtkCell* vtkWedge::GetEdge ( int edgeId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

vtkCell* vtkWedge::GetFace ( int faceId ) [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::CellBoundary | ( | int | subId,
 |  | float | pcoords[3],
 |  | vtkIdList * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkWedge::Contour | ( | float | value,
 |  | vtkDataArray * | cellScalars,
 |  | vtkPointLocator * | locator,
 |  | vtkCellArray * | verts,
 |  | vtkCellArray * | lines,
 |  | vtkCellArray * | polys,
 |  | vtkPointData * | inPd,
 |  | vtkPointData * | outPd,
 |  | vtkCellData * | inCd,
 |  | vtkIdType | cellId,
 |  | vtkCellData * | outCd
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::EvaluatePosition | ( | float | x[3],
 |  | float * | closestPoint,
 |  | int & | subId,
 |  | float | pcoords[3],
 |  | float & | dist2,
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkWedge::EvaluateLocation | ( | int & | subId,
 |  | float | pcoords[3],
 |  | float | x[3],
 |  | float * | weights
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::IntersectWithLine | ( | float | p1[3],
 |  | float | p2[3],
 |  | float | tol,
 |  | float & | t,
 |  | float | x[3],
 |  | float | pcoords[3],
 |  | int & | subId
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::Triangulate | ( | int | index,
 |  | vtkIdList * | ptIds,
 |  | vtkPoints * | pts
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

void vtkWedge::Derivatives | ( | int | subId,
 |  | float | pcoords[3],
 |  | float * | values,
 |  | int | dim,
 |  | float * | derivs
 | ) | [virtual]

See the vtkCell API for descriptions of these methods.

Reimplemented from vtkCell.

int vtkWedge::GetParametricCenter ( float pcoords[3] ) [inline, virtual]

Return the center of the wedge in parametric coordinates.

Reimplemented from vtkCell.

Definition at line 115 of file vtkWedge.h.

void vtkWedge::InterpolationFunctions | ( | float | pcoords[3],
 |  | float | weights[6]
 | ) | [static]

Wedge specific methods for computing interpolation functions and derivatives.

void vtkWedge::InterpolationDerivs | ( | float | pcoords[3],
 |  | float | derivs[18]
 | ) | [static]

int vtkWedge::JacobianInverse | ( | float | pcoords[3],
 |  | double ** | inverse,
 |  | float | derivs[18]
 | ) |

int* vtkWedge::GetEdgeArray ( int edgeId ) [static]

int* vtkWedge::GetFaceArray ( int faceId ) [static]

Member Data Documentation

vtkLine* vtkWedge::Line [protected]

Definition at line 106 of file vtkWedge.h.

vtkTriangle* vtkWedge::Triangle [protected]

Definition at line 107 of file vtkWedge.h.

vtkQuad* vtkWedge::Quad [protected]

Definition at line 108 of file vtkWedge.h.

The documentation for this class was generated from the following file:
  • Common/vtkWedge.h
Generated on Mon Mar 25 01:35:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWeightedTransformFilter Class Reference

#include <vtkWeightedTransformFilter.h>

Inheritance diagram for vtkWeightedTransformFilter:

[legend]
Collaboration diagram for vtkWeightedTransformFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWeightedTransformFilter, vtkPointSetToPointSetFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
unsigned long | GetMTime ()
virtual void | SetWeightArray (const char *)
virtual char * | GetWeightArray ()
virtual void | SetCellDataWeightArray (const char *)
virtual char * | GetCellDataWeightArray ()
virtual void | SetTransform (vtkAbstractTransform *transform, int num)
virtual vtkAbstractTransform * | GetTransform (int num)
virtual void | SetNumberOfTransforms (int num)
virtual int | GetNumberOfTransforms ()
virtual void | AddInputValuesOn ()
virtual void | AddInputValuesOff ()
virtual void | SetAddInputValues (int)
virtual int | GetAddInputValues ()

Static Public Methods

vtkWeightedTransformFilter * | New ()

Protected Methods

vtkWeightedTransformFilter ()
~vtkWeightedTransformFilter ()
void | Execute ()

Protected Attributes

vtkAbstractTransform ** Transforms
int | NumberOfTransforms
int | AddInputValues
char * | CellDataWeightArray
char * | WeightArray

Detailed Description

Date:
2002/01/22 15:30:45
Revision:
1.7

vtkWeightedTransformFilter is a filter that can be used to "skin" structures and to create new and complex shapes. Unlike a traditional transform filter (which has one transform for a data set) or an assembly (which has one transform per part or group of parts), a weighted transform produces the weighted sum of transforms on a per-point or per-cell basis.

Each point or cell in the filter's input has an attached DataArray that contains tuples of weighting functions, one per point or cell. The filter also has a set of fixed transforms. When the filter executes, each input point/cell is transformed by each of the transforms. These results are weighted by the point/cell's weighting factors to produce final output data.

Linear transforms are performance-optimized. Using arbitrary transforms will work, but performance may suffer.

As an example of the utility of weighted transforms, here's how this filter can be used for "skinning." Skinning is the process of putting a mesh cover over an underlying structure, like skin over bone. Joints are difficult to skin because deformation is hard to do. Visualize skin over an elbow joint. Part of the skin moves with one bone, part of the skin moves with the other bone, and the skin in the middle moves a little with each.

Weighted filtering can be used for a simple and efficient kind of skinning. Begin with a cylindrical mesh. Create a FloatArray with two components per tuple, and one tuple for each point in the mesh. Assign transform weights that linear interpolate the distance along the cylinder (one component is the distance along the cylinder, the other is one minus that distance). Set the filter up to use two transforms, the two used to transform the two bones. Now, when the transforms change, the mesh will deform so as to, hopefully, continue to cover the bones.

vtkWeightedTransformFilter is also useful for creating "strange and complex" shapes using pinching, bending, and blending.

Warning:
Weighted combination of normals and vectors are probably not appropriate in many cases. Surface normals are treated somewhat specially, but in many cases you may need to regenerate the surface normals.
Warning:
Cell data can only be transformed if all transforms are linear.
See also:
vtkAbstractTransform vtkLinearTransform vtkTransformPolyDataFilter vtkActor
Created by:
  • Halle, Michael
Contributed by (if > 5%):
  • Halle, Michael (76%)
  • Geveci, Berk (22%)
Tests:
vtkWeightedTransformFilter (Tests)

Definition at line 89 of file vtkWeightedTransformFilter.h.

Constructor & Destructor Documentation

vtkWeightedTransformFilter::vtkWeightedTransformFilter ( ) [protected]

vtkWeightedTransformFilter::~vtkWeightedTransformFilter ( ) [protected]

Member Function Documentation

vtkWeightedTransformFilter* vtkWeightedTransformFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPointSetSource.

vtkWeightedTransformFilter::vtkTypeRevisionMacro | ( | vtkWeightedTransformFilter | ,
 |  | vtkPointSetToPointSetFilter |
 | ) |

Reimplemented from vtkPointSetToPointSetFilter.

void vtkWeightedTransformFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

unsigned long vtkWeightedTransformFilter::GetMTime ( ) [virtual]

Return the MTime also considering the filter's transforms.

Reimplemented from vtkObject.

virtual void vtkWeightedTransformFilter::SetWeightArray ( const char * ) [virtual]

WeightArray is the string name of the DataArray in the input's FieldData that holds the weighting coefficients for each point. The filter will first look for the array in the input's PointData FieldData. If the array isn't there, the filter looks in the input's FieldData. The WeightArray can have tuples of any length, but must have a tuple for every point in the input data set. This array transforms points, normals, and vectors.

virtual char* vtkWeightedTransformFilter::GetWeightArray ( ) [virtual]

WeightArray is the string name of the DataArray in the input's FieldData that holds the weighting coefficients for each point. The filter will first look for the array in the input's PointData FieldData. If the array isn't there, the filter looks in the input's FieldData. The WeightArray can have tuples of any length, but must have a tuple for every point in the input data set. This array transforms points, normals, and vectors.

virtual void vtkWeightedTransformFilter::SetCellDataWeightArray ( const char * ) [virtual]

The CellDataWeightArray is analogous to the WeightArray, except for CellData. The array is searched for first in the CellData FieldData, then in the input's FieldData. The data array must have a tuple for each cell. This array is used to transform only normals and vectors.

virtual char* vtkWeightedTransformFilter::GetCellDataWeightArray ( ) [virtual]

The CellDataWeightArray is analogous to the WeightArray, except for CellData. The array is searched for first in the CellData FieldData, then in the input's FieldData. The data array must have a tuple for each cell. This array is used to transform only normals and vectors.

virtual void vtkWeightedTransformFilter::SetTransform | ( | vtkAbstractTransform * | transform,
 |  | int | num
 | ) | [virtual]

Set or Get one of the filter's transforms. The transform number must be less than the number of transforms allocated for the object. Setting a transform slot to NULL is equivalent to assigning an overriding weight of zero to that filter slot.

virtual vtkAbstractTransform* vtkWeightedTransformFilter::GetTransform ( int num ) [virtual]

Set or Get one of the filter's transforms. The transform number must be less than the number of transforms allocated for the object. Setting a transform slot to NULL is equivalent to assigning an overriding weight of zero to that filter slot.

virtual void vtkWeightedTransformFilter::SetNumberOfTransforms ( int num ) [virtual]

Set the number of transforms for the filter. References to non-existent filter numbers in the data array is equivalent to a weight of zero (i.e., no contribution of that filter or weight).

virtual int vtkWeightedTransformFilter::GetNumberOfTransforms ( ) [virtual]

Set the number of transforms for the filter. References to non-existent filter numbers in the data array is equivalent to a weight of zero (i.e., no contribution of that filter or weight).

virtual void vtkWeightedTransformFilter::AddInputValuesOn ( ) [virtual]

If AddInputValues is true, the output values of this filter will be offset from the input values. The effect is exactly equivalent to having an identity transform of weight 1 added into each output point.

virtual void vtkWeightedTransformFilter::AddInputValuesOff ( ) [virtual]

If AddInputValues is true, the output values of this filter will be offset from the input values. The effect is exactly equivalent to having an identity transform of weight 1 added into each output point.

virtual void vtkWeightedTransformFilter::SetAddInputValues ( int ) [virtual]

If AddInputValues is true, the output values of this filter will be offset from the input values. The effect is exactly equivalent to having an identity transform of weight 1 added into each output point.

virtual int vtkWeightedTransformFilter::GetAddInputValues ( ) [virtual]

If AddInputValues is true, the output values of this filter will be offset from the input values. The effect is exactly equivalent to having an identity transform of weight 1 added into each output point.

void vtkWeightedTransformFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

vtkAbstractTransform** vtkWeightedTransformFilter::Transforms [protected]

Definition at line 148 of file vtkWeightedTransformFilter.h.

int vtkWeightedTransformFilter::NumberOfTransforms [protected]

Definition at line 149 of file vtkWeightedTransformFilter.h.

int vtkWeightedTransformFilter::AddInputValues [protected]

Definition at line 150 of file vtkWeightedTransformFilter.h.

char* vtkWeightedTransformFilter::CellDataWeightArray [protected]

Definition at line 152 of file vtkWeightedTransformFilter.h.

char* vtkWeightedTransformFilter::WeightArray [protected]

Definition at line 153 of file vtkWeightedTransformFilter.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkWeightedTransformFilter.h
Generated on Mon Mar 25 01:35:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32Header Class Reference

manage Windows system differences. More...

#include <vtkWin32Header.h>

Detailed Description

manage Windows system differences.

Date:
2002/03/05 18:33:15
Revision:
1.23

The vtkWin32Header captures some system differences between Unix and Windows operating systems.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (74%)
  • Cedilnik, Andy (7%)
  • Barre, Sebastien (5%)

The documentation for this class was generated from the following file:
  • Common/vtkWin32Header.h
Generated on Mon Mar 25 01:35:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32ImageMapper Class Reference

(obsolete) 2D image display support for Microsoft windows. More...

#include <vtkWin32ImageMapper.h>

Inheritance diagram for vtkWin32ImageMapper:

[legend]
Collaboration diagram for vtkWin32ImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32ImageMapper, vtkImageMapper)
unsigned long int | GetMTime ()
void | PrintSelf (ostream &os, vtkIndent indent)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)
void | RenderData (vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor)
virtual void | SetLookupTable (vtkLookupTable *)
virtual vtkLookupTable * | GetLookupTable ()

Static Public Methods

vtkWin32ImageMapper * | New ()
void | GenerateBitmapData (vtkImageData *data, void *inptr, unsigned char *DataOut, int dim, int DisplayExtent[6], float cwindow, float clevel, float cshift, float cscale, vtkLookupTable *lut)
HBITMAP | CreateBitmapObject (HBITMAP oldBitmap, BITMAPINFO &dataHeader, HDC windowDC, unsigned char *&DataOut, vtkImageData *data, int width, int height)

Public Attributes

unsigned char * | DataOut
HBITMAP | HBitmap

Protected Methods

vtkWin32ImageMapper ()
~vtkWin32ImageMapper ()

Protected Attributes

vtkLookupTable * LookupTable

Detailed Description

(obsolete) 2D image display support for Microsoft windows.

Date:
2002/01/22 15:39:44
Revision:
1.23

vtkWin32ImageMapper is a concrete subclass of vtkImageMapper that renders images under Microsoft windows.

See also:
vtkImageMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (50%)
  • Miller, Jim (26%)
  • Biddiscombe, John (17%)

Definition at line 47 of file vtkWin32ImageMapper.h.

Constructor & Destructor Documentation

vtkWin32ImageMapper::vtkWin32ImageMapper ( ) [protected]

vtkWin32ImageMapper::~vtkWin32ImageMapper ( ) [protected]

Member Function Documentation

vtkWin32ImageMapper* vtkWin32ImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapper.

vtkWin32ImageMapper::vtkTypeRevisionMacro | ( | vtkWin32ImageMapper | ,
 |  | vtkImageMapper |
 | ) |

Reimplemented from vtkImageMapper.

void vtkWin32ImageMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Handle the render method.

Reimplemented from vtkMapper2D.

Definition at line 55 of file vtkWin32ImageMapper.h.

void vtkWin32ImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Called by the Render function in vtkImageMapper. Actually draws the image to the screen.

Reimplemented from vtkImageMapper.

unsigned long int vtkWin32ImageMapper::GetMTime ( ) [virtual]

Compute modified time including lookuptable

Reimplemented from vtkImageMapper.

void vtkWin32ImageMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

standard Printself routine

Reimplemented from vtkImageMapper.

virtual void vtkWin32ImageMapper::SetLookupTable ( vtkLookupTable * ) [virtual]

The ImageMappers convert ImageData into a greyscale image when a single scalar component is present. If a lookuptable is supplied, values are mapped through the lookuptable to generate a colour image. If the number of scalar components is greater then one, the lookuptable is ignored. If the lookuptable is NULL, a default greyscale image is generated. Users should ensure that the range of the lookuptable is {0,255} for full colour effects

virtual vtkLookupTable* vtkWin32ImageMapper::GetLookupTable ( ) [virtual]

The ImageMappers convert ImageData into a greyscale image when a single scalar component is present. If a lookuptable is supplied, values are mapped through the lookuptable to generate a colour image. If the number of scalar components is greater then one, the lookuptable is ignored. If the lookuptable is NULL, a default greyscale image is generated. Users should ensure that the range of the lookuptable is {0,255} for full colour effects

HBITMAP vtkWin32ImageMapper::CreateBitmapObject | ( | HBITMAP | oldBitmap,
 |  | BITMAPINFO & | dataHeader,
 |  | HDC | windowDC,
 |  | unsigned char *& | DataOut,
 |  | vtkImageData * | data,
 |  | int | width,
 |  | int | height
 | ) | [static]

CreateBitmapObject and GenerateBitmapData are utility functions which allow one to hook into the display routines and provide the user with an easy way of converting an ImageData object into a windows bitmap object. They are also used internally by the mapper and should not be modified or used standalone alone without caution.

void vtkWin32ImageMapper::GenerateBitmapData | ( | vtkImageData * | data,
 |  | void * | inptr,
 |  | unsigned char * | DataOut,
 |  | int | dim,
 |  | int | DisplayExtent[6],
 |  | float | cwindow,
 |  | float | clevel,
 |  | float | cshift,
 |  | float | cscale,
 |  | vtkLookupTable * | lut
 | ) | [static]

Member Data Documentation

unsigned char* vtkWin32ImageMapper::DataOut

Definition at line 100 of file vtkWin32ImageMapper.h.

HBITMAP vtkWin32ImageMapper::HBitmap

Definition at line 101 of file vtkWin32ImageMapper.h.

vtkLookupTable* vtkWin32ImageMapper::LookupTable [protected]

Definition at line 104 of file vtkWin32ImageMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32ImageMapper.h
Generated on Mon Mar 25 01:35:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32ImageWindow Class Reference

(obsolete)2D display window for Windows. More...

#include <vtkWin32ImageWindow.h>

Inheritance diagram for vtkWin32ImageWindow:

[legend]
Collaboration diagram for vtkWin32ImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32ImageWindow, vtkImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SwapBuffers ()
void | Frame ()
vtkWin32ImageWindow * | GetOutput ()
void | SetWindowInfo (char *)
void | SetParentInfo (char *)
void | SetDeviceContext (void *dc)
void | SetDeviceContext (HDC)
void | SetDisplayId (void *foo)
void * | GetGenericDisplayId ()
void * | GetGenericWindowId ()
void * | GetGenericParentId ()
void * | GetGenericContext ()
void | SetBackgroundColor (float r, float g, float b)
void | EraseWindow ()
unsigned char * | GetDIBPtr ()
unsigned char * | GetPixelData (int x1, int y1, int x2, int y2, int)
void | MakeDefaultWindow ()
HWND | GetWindowId ()
void | SetWindowId (void *id)
void | SetParentId (void *id)
void | SetWindowId (HWND)
void | SetParentId (HWND)
void | SetSize (int, int)
int * | GetSize ()
int * | GetPosition ()
void | SetPosition (int, int)
void | SetupMemoryRendering (int x, int y, HDC prn)
void | ResumeScreenRendering ()
HDC | GetMemoryDC ()
unsigned char * | GetMemoryData ()

Static Public Methods

vtkWin32ImageWindow * | New ()

Public Attributes

HINSTANCE | ApplicationInstance
HPALETTE | Palette
HDC | DeviceContext
HWND | WindowId
HWND | ParentId

Protected Methods

vtkWin32ImageWindow ()
~vtkWin32ImageWindow ()

Protected Attributes

BITMAPINFO | MemoryDataHeader
HBITMAP | MemoryBuffer
unsigned char * | MemoryData
HDC | MemoryHdc
int | ScreenMapped
int | ScreenWindowSize [2]
HDC | ScreenDeviceContext
int | OwnWindow
unsigned char * | DIBPtr
int | SwapFlag
HDC | CompatHdc
HDC | OldHdc
HBITMAP | BackBuffer
BITMAPINFO | DataHeader

Detailed Description

(obsolete)2D display window for Windows.

Date:
2002/01/22 15:39:45
Revision:
1.28

vtkWin32ImageWindow is a concrete subclass of vtkImageWindow. It handles 2D rendering under windows.

See also:
vtkImageWindow
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (82%)
  • Miller, Jim (7%)

Definition at line 43 of file vtkWin32ImageWindow.h.

Constructor & Destructor Documentation

vtkWin32ImageWindow::vtkWin32ImageWindow ( ) [protected]

vtkWin32ImageWindow::~vtkWin32ImageWindow ( ) [protected]

Member Function Documentation

vtkWin32ImageWindow* vtkWin32ImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkImageWindow.

vtkWin32ImageWindow::vtkTypeRevisionMacro | ( | vtkWin32ImageWindow | ,
 |  | vtkImageWindow |
 | ) |

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::SwapBuffers ( ) [virtual]

Swap the front and back buffers. Normally not called by the user. Double buffering is not supported in this class.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::Frame ( void ) [virtual]

Flush and swap buffers if necessary. Double buffering is not supported in this class.

Reimplemented from vtkImageWindow.

vtkWin32ImageWindow* vtkWin32ImageWindow::GetOutput ( ) [inline]

Definition at line 65 of file vtkWin32ImageWindow.h.

void vtkWin32ImageWindow::SetWindowInfo ( char * info ) [virtual]

Set this ImageWindow's window id to a pre-existing window.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::SetParentInfo ( char * info ) [virtual]

Sets the HWND id of the window that WILL BE created.

Reimplemented from vtkImageWindow.

HWND vtkWin32ImageWindow::GetWindowId ( )

Set/Get the window id and parent window id.

void vtkWin32ImageWindow::SetWindowId ( void * id ) [inline, virtual]

Set/Get the window id and parent window id.

Reimplemented from vtkImageWindow.

Definition at line 78 of file vtkWin32ImageWindow.h.

void vtkWin32ImageWindow::SetParentId ( void * id ) [inline, virtual]

Set/Get the window id and parent window id.

Reimplemented from vtkImageWindow.

Definition at line 79 of file vtkWin32ImageWindow.h.

void vtkWin32ImageWindow::SetWindowId ( HWND )

Set/Get the window id and parent window id.

void vtkWin32ImageWindow::SetParentId ( HWND )

Set/Get the window id and parent window id.

void vtkWin32ImageWindow::SetDeviceContext ( void * dc ) [inline]

Definition at line 84 of file vtkWin32ImageWindow.h.

void vtkWin32ImageWindow::SetDeviceContext ( HDC )

void vtkWin32ImageWindow::SetDisplayId ( void * foo ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 86 of file vtkWin32ImageWindow.h.

void* vtkWin32ImageWindow::GetGenericDisplayId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 88 of file vtkWin32ImageWindow.h.

void* vtkWin32ImageWindow::GetGenericWindowId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 90 of file vtkWin32ImageWindow.h.

void* vtkWin32ImageWindow::GetGenericParentId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 91 of file vtkWin32ImageWindow.h.

void* vtkWin32ImageWindow::GetGenericContext ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 92 of file vtkWin32ImageWindow.h.

void vtkWin32ImageWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the current size of the window.

Reimplemented from vtkImageWindow.

int* vtkWin32ImageWindow::GetSize ( ) [virtual]

Set/Get the current size of the window.

Reimplemented from vtkImageWindow.

int* vtkWin32ImageWindow::GetPosition ( ) [virtual]

Set/Get the position in screen coordinates of the window.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the position in screen coordinates of the window.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::SetBackgroundColor | ( | float | r,
 |  | float | g,
 |  | float | b
 | ) |

Set the desired background color for the window.

void vtkWin32ImageWindow::EraseWindow ( ) [virtual]

Erase the window. Normally nor called by the user.

Reimplemented from vtkImageWindow.

unsigned char* vtkWin32ImageWindow::GetDIBPtr ( )

unsigned char* vtkWin32ImageWindow::GetPixelData | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Get the pixel data of an image, transmitted as RGBRGBRGB. The front argument indicates if the front buffer should be used or the back buffer. It is the caller's responsibility to delete the resulting array. It is very important to realize that the memory in this array is organized from the bottom of the window to the top. The origin of the screen is in the lower left corner. The y axis increases as you go up the screen. So the storage of pixels is from left to right and from bottom to top.

Reimplemented from vtkWindow.

void vtkWin32ImageWindow::MakeDefaultWindow ( ) [virtual]

Creates a Win32 window or sets up an existing window.

Reimplemented from vtkImageWindow.

void vtkWin32ImageWindow::SetupMemoryRendering | ( | int | x,
 |  | int | y,
 |  | HDC | prn
 | ) |

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void vtkWin32ImageWindow::ResumeScreenRendering ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

HDC vtkWin32ImageWindow::GetMemoryDC ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

unsigned char* vtkWin32ImageWindow::GetMemoryData ( ) [inline]

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

Definition at line 125 of file vtkWin32ImageWindow.h.

Member Data Documentation

HINSTANCE vtkWin32ImageWindow::ApplicationInstance

Definition at line 46 of file vtkWin32ImageWindow.h.

HPALETTE vtkWin32ImageWindow::Palette

Definition at line 47 of file vtkWin32ImageWindow.h.

HDC vtkWin32ImageWindow::DeviceContext

Definition at line 48 of file vtkWin32ImageWindow.h.

HWND vtkWin32ImageWindow::WindowId

Definition at line 49 of file vtkWin32ImageWindow.h.

HWND vtkWin32ImageWindow::ParentId

Definition at line 50 of file vtkWin32ImageWindow.h.

BITMAPINFO vtkWin32ImageWindow::MemoryDataHeader [protected]

Definition at line 133 of file vtkWin32ImageWindow.h.

HBITMAP vtkWin32ImageWindow::MemoryBuffer [protected]

Definition at line 134 of file vtkWin32ImageWindow.h.

unsigned char* vtkWin32ImageWindow::MemoryData [protected]

Definition at line 135 of file vtkWin32ImageWindow.h.

HDC vtkWin32ImageWindow::MemoryHdc [protected]

Definition at line 136 of file vtkWin32ImageWindow.h.

int vtkWin32ImageWindow::ScreenMapped [protected]

Definition at line 137 of file vtkWin32ImageWindow.h.

int vtkWin32ImageWindow::ScreenWindowSize[2] [protected]

Definition at line 138 of file vtkWin32ImageWindow.h.

HDC vtkWin32ImageWindow::ScreenDeviceContext [protected]

Definition at line 139 of file vtkWin32ImageWindow.h.

int vtkWin32ImageWindow::OwnWindow [protected]

Definition at line 141 of file vtkWin32ImageWindow.h.

unsigned char* vtkWin32ImageWindow::DIBPtr [protected]

Definition at line 143 of file vtkWin32ImageWindow.h.

int vtkWin32ImageWindow::SwapFlag [protected]

Definition at line 144 of file vtkWin32ImageWindow.h.

HDC vtkWin32ImageWindow::CompatHdc [protected]

Definition at line 145 of file vtkWin32ImageWindow.h.

HDC vtkWin32ImageWindow::OldHdc [protected]

Definition at line 146 of file vtkWin32ImageWindow.h.

HBITMAP vtkWin32ImageWindow::BackBuffer [protected]

Definition at line 147 of file vtkWin32ImageWindow.h.

BITMAPINFO vtkWin32ImageWindow::DataHeader [protected]

Definition at line 148 of file vtkWin32ImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32ImageWindow.h
Generated on Mon Mar 25 01:35:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLImageWindow Class Reference

OpenGL Imageing window. More...

#include <vtkWin32OpenGLImageWindow.h>

Inheritance diagram for vtkWin32OpenGLImageWindow:

[legend]
Collaboration diagram for vtkWin32OpenGLImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32OpenGLImageWindow, vtkImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
vtkWin32OpenGLImageWindow * | GetOutput ()
virtual void | MakeDefaultWindow ()
void | SwapBuffers ()
void | Frame ()
void | Render ()
virtual void | SetWindowName (char *)
void | SetWindowInfo (char *)
void | SetParentInfo (char *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void | SetDisplayId (void *)
virtual void | SetWindowId (HWND)
void | SetContextId (HGLRC)
void | SetDeviceContext (HDC)
void | MakeCurrent ()
void | Clean ()
virtual void | SetSize (int, int)
virtual void | SetSize (int a[2])
virtual int * | GetSize ()
virtual void | GetSize (int *x, int *y)
virtual void | SetPosition (int, int)
virtual void | SetPosition (int a[2])
virtual int * | GetPosition ()
virtual void | GetPosition (int *x, int *y)
virtual HWND | GetWindowId ()
void | SetWindowId (void *foo)
virtual void | SetParentId (HWND)
void | SetParentId (void *foo)
virtual void | SetNextWindowId (HWND)
virtual unsigned char * | GetPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetPixelData (int x, int y, int x2, int y2, unsigned char *, int front)
virtual float * | GetRGBAPixelData (int x, int y, int x2, int y2, int front)
virtual void | SetRGBAPixelData (int x, int y, int x2, int y2, float *, int front, int blend=0)
virtual void | ReleaseRGBAPixelData (float *data)
void | SetupMemoryRendering (int x, int y, HDC prn)
void | ResumeScreenRendering ()
HDC | GetMemoryDC ()
unsigned char * | GetMemoryData ()
virtual void | OpenGLInit ()
virtual void | SetupPalette (HDC hDC)
virtual void | SetupPixelFormat (HDC hDC, DWORD dwFlags, int debug, int bpp=16, int zbpp=16)

Static Public Methods

vtkWin32OpenGLImageWindow * | New ()

Protected Methods

vtkWin32OpenGLImageWindow ()
~vtkWin32OpenGLImageWindow ()
virtual LRESULT | MessageProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)

Static Protected Methods

LRESULT APIENTRY | WndProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

HINSTANCE | ApplicationInstance
HPALETTE | Palette
HPALETTE | OldPalette
HGLRC | ContextId
HDC | DeviceContext
HWND | WindowId
HWND | ParentId
HWND | NextWindowId
int | OwnWindow
int | ScreenSize [2]
BITMAPINFO | MemoryDataHeader
HBITMAP | MemoryBuffer
unsigned char * | MemoryData
HDC | MemoryHdc
int | ScreenMapped
int | ScreenWindowSize [2]
HDC | ScreenDeviceContext
int | ScreenDoubleBuffer
HGLRC | ScreenContextId

Detailed Description

OpenGL Imageing window.

Date:
2002/01/22 15:39:46
Revision:
1.23

vtkWin32OpenGLImageWindow is a concrete implementation of the abstract class vtkImageWindow. vtkWin32OpenGLImageer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (87%)
  • Hoffman, Bill (7%)

Definition at line 41 of file vtkWin32OpenGLImageWindow.h.

Constructor & Destructor Documentation

vtkWin32OpenGLImageWindow::vtkWin32OpenGLImageWindow ( ) [protected]

vtkWin32OpenGLImageWindow::~vtkWin32OpenGLImageWindow ( ) [protected]

Member Function Documentation

vtkWin32OpenGLImageWindow* vtkWin32OpenGLImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkImageWindow.

vtkWin32OpenGLImageWindow::vtkTypeRevisionMacro | ( | vtkWin32OpenGLImageWindow | ,
 |  | vtkImageWindow |
 | ) |

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWindow.

vtkWin32OpenGLImageWindow* vtkWin32OpenGLImageWindow::GetOutput ( ) [inline]

Definition at line 49 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::MakeDefaultWindow ( ) [virtual]

Initialize the window for rendering.

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::SwapBuffers ( ) [virtual]

Swap the front and back buffers if double buffering is being used.

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::Frame ( void ) [virtual]

Flush the buffer and swap if necessary

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::Render ( void ) [virtual]

Draw the contents of the window

Reimplemented from vtkImageWindow.

virtual void vtkWin32OpenGLImageWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the size of the window.

Reimplemented from vtkImageWindow.

virtual void vtkWin32OpenGLImageWindow::SetSize ( int a[2] ) [inline, virtual]

Set the size of the window.

Reimplemented from vtkImageWindow.

Definition at line 66 of file vtkWin32OpenGLImageWindow.h.

virtual int* vtkWin32OpenGLImageWindow::GetSize ( ) [virtual]

Get the current size of the window.

Reimplemented from vtkImageWindow.

virtual void vtkWin32OpenGLImageWindow::GetSize | ( | int * | x,
 |  | int * | y
 | ) | [inline, virtual]

Get the current size of the window.

Reimplemented from vtkImageWindow.

Definition at line 72 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the position of the window.

Reimplemented from vtkImageWindow.

virtual void vtkWin32OpenGLImageWindow::SetPosition ( int a[2] ) [inline, virtual]

Set the position of the window.

Reimplemented from vtkImageWindow.

Definition at line 78 of file vtkWin32OpenGLImageWindow.h.

virtual int* vtkWin32OpenGLImageWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkImageWindow.

virtual void vtkWin32OpenGLImageWindow::GetPosition | ( | int * | x,
 |  | int * | y
 | ) | [inline, virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkImageWindow.

Definition at line 84 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::SetWindowName ( char * name ) [virtual]

Set the name of the window. This appears at the top of the window normally.

Reimplemented from vtkWindow.

void vtkWin32OpenGLImageWindow::SetWindowInfo ( char * info ) [virtual]

Set this ImageWindow's window id to a pre-existing window.

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::SetParentInfo ( char * info ) [virtual]

Sets the HWND id of the window that WILL BE created.

Reimplemented from vtkImageWindow.

virtual void* vtkWin32OpenGLImageWindow::GetGenericDisplayId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 98 of file vtkWin32OpenGLImageWindow.h.

virtual void* vtkWin32OpenGLImageWindow::GetGenericWindowId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 99 of file vtkWin32OpenGLImageWindow.h.

virtual void* vtkWin32OpenGLImageWindow::GetGenericParentId ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 100 of file vtkWin32OpenGLImageWindow.h.

virtual void* vtkWin32OpenGLImageWindow::GetGenericContext ( ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 101 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::SetDisplayId ( void * foo ) [inline, virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Definition at line 102 of file vtkWin32OpenGLImageWindow.h.

virtual HWND vtkWin32OpenGLImageWindow::GetWindowId ( ) [virtual]

Get the window id.

void vtkWin32OpenGLImageWindow::SetWindowId ( void * foo ) [inline, virtual]

Get the window id.

Reimplemented from vtkImageWindow.

Definition at line 107 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::SetWindowId ( HWND ) [virtual]

Set the window id to a pre-existing window.

virtual void vtkWin32OpenGLImageWindow::SetParentId ( HWND ) [virtual]

Set the window's parent id to a pre-existing window.

void vtkWin32OpenGLImageWindow::SetParentId ( void * foo ) [inline, virtual]

Set the window's parent id to a pre-existing window.

Reimplemented from vtkImageWindow.

Definition at line 116 of file vtkWin32OpenGLImageWindow.h.

void vtkWin32OpenGLImageWindow::SetContextId ( HGLRC )

void vtkWin32OpenGLImageWindow::SetDeviceContext ( HDC )

virtual void vtkWin32OpenGLImageWindow::SetNextWindowId ( HWND ) [virtual]

Set the window id of the new window once a WindowRemap is done.

virtual unsigned char* vtkWin32OpenGLImageWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

Reimplemented from vtkWindow.

virtual void vtkWin32OpenGLImageWindow::SetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | unsigned char * | ,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBRGB...

virtual float* vtkWin32OpenGLImageWindow::GetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkWin32OpenGLImageWindow::SetRGBAPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | float * | ,
 |  | int | front,
 |  | int | blend = 0
 | ) | [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

virtual void vtkWin32OpenGLImageWindow::ReleaseRGBAPixelData ( float * data ) [virtual]

Set/Get the pixel data of an image, transmitted as RGBARGBA...

void vtkWin32OpenGLImageWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkImageWindow.

void vtkWin32OpenGLImageWindow::SetupMemoryRendering | ( | int | x,
 |  | int | y,
 |  | HDC | prn
 | ) |

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void vtkWin32OpenGLImageWindow::ResumeScreenRendering ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

HDC vtkWin32OpenGLImageWindow::GetMemoryDC ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

unsigned char* vtkWin32OpenGLImageWindow::GetMemoryData ( ) [inline]

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

Definition at line 152 of file vtkWin32OpenGLImageWindow.h.

virtual void vtkWin32OpenGLImageWindow::OpenGLInit ( ) [virtual]

Initialize OpenGL for this window.

virtual void vtkWin32OpenGLImageWindow::SetupPalette ( HDC hDC ) [virtual]

Initialize OpenGL for this window.

virtual void vtkWin32OpenGLImageWindow::SetupPixelFormat | ( | HDC | hDC,
 |  | DWORD | dwFlags,
 |  | int | debug,
 |  | int | bpp = 16,
 |  | int | zbpp = 16
 | ) | [virtual]

Initialize OpenGL for this window.

void vtkWin32OpenGLImageWindow::Clean ( )

Clean up device contexts, rendering contexts, etc.

virtual LRESULT vtkWin32OpenGLImageWindow::MessageProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [protected, virtual]

LRESULT APIENTRY vtkWin32OpenGLImageWindow::WndProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [static, protected]

Member Data Documentation

HINSTANCE vtkWin32OpenGLImageWindow::ApplicationInstance [protected]

Definition at line 170 of file vtkWin32OpenGLImageWindow.h.

HPALETTE vtkWin32OpenGLImageWindow::Palette [protected]

Definition at line 171 of file vtkWin32OpenGLImageWindow.h.

HPALETTE vtkWin32OpenGLImageWindow::OldPalette [protected]

Definition at line 172 of file vtkWin32OpenGLImageWindow.h.

HGLRC vtkWin32OpenGLImageWindow::ContextId [protected]

Definition at line 173 of file vtkWin32OpenGLImageWindow.h.

HDC vtkWin32OpenGLImageWindow::DeviceContext [protected]

Definition at line 174 of file vtkWin32OpenGLImageWindow.h.

HWND vtkWin32OpenGLImageWindow::WindowId [protected]

Definition at line 175 of file vtkWin32OpenGLImageWindow.h.

HWND vtkWin32OpenGLImageWindow::ParentId [protected]

Definition at line 176 of file vtkWin32OpenGLImageWindow.h.

HWND vtkWin32OpenGLImageWindow::NextWindowId [protected]

Definition at line 177 of file vtkWin32OpenGLImageWindow.h.

int vtkWin32OpenGLImageWindow::OwnWindow [protected]

Definition at line 178 of file vtkWin32OpenGLImageWindow.h.

int vtkWin32OpenGLImageWindow::ScreenSize[2] [protected]

Definition at line 179 of file vtkWin32OpenGLImageWindow.h.

BITMAPINFO vtkWin32OpenGLImageWindow::MemoryDataHeader [protected]

Definition at line 182 of file vtkWin32OpenGLImageWindow.h.

HBITMAP vtkWin32OpenGLImageWindow::MemoryBuffer [protected]

Definition at line 183 of file vtkWin32OpenGLImageWindow.h.

unsigned char* vtkWin32OpenGLImageWindow::MemoryData [protected]

Definition at line 184 of file vtkWin32OpenGLImageWindow.h.

HDC vtkWin32OpenGLImageWindow::MemoryHdc [protected]

Definition at line 185 of file vtkWin32OpenGLImageWindow.h.

int vtkWin32OpenGLImageWindow::ScreenMapped [protected]

Definition at line 187 of file vtkWin32OpenGLImageWindow.h.

int vtkWin32OpenGLImageWindow::ScreenWindowSize[2] [protected]

Definition at line 188 of file vtkWin32OpenGLImageWindow.h.

HDC vtkWin32OpenGLImageWindow::ScreenDeviceContext [protected]

Definition at line 189 of file vtkWin32OpenGLImageWindow.h.

int vtkWin32OpenGLImageWindow::ScreenDoubleBuffer [protected]

Definition at line 190 of file vtkWin32OpenGLImageWindow.h.

HGLRC vtkWin32OpenGLImageWindow::ScreenContextId [protected]

Definition at line 191 of file vtkWin32OpenGLImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32OpenGLImageWindow.h
Generated on Mon Mar 25 01:35:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLRenderWindow Class Reference

OpenGL rendering window. More...

#include <vtkWin32OpenGLRenderWindow.h>

Inheritance diagram for vtkWin32OpenGLRenderWindow:

[legend]
Collaboration diagram for vtkWin32OpenGLRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32OpenGLRenderWindow, vtkOpenGLRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Start (void)
void | Frame (void)
virtual void | WindowInitialize (void)
virtual void | Initialize (void)
virtual void | SetFullScreen (int)
virtual void | WindowRemap (void)
virtual void | PrefFullScreen (void)
virtual int * | GetSize ()
virtual int * | GetScreenSize ()
virtual int * | GetPosition ()
virtual void | SetWindowName (char *)
void | SetWindowInfo (char *)
void | SetParentInfo (char *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void | SetDisplayId (void *)
virtual void | SetWindowId (HWND)
void | SetContextId (HGLRC)
void | SetDeviceContext (HDC)
virtual void | SetStereoCapableWindow (int capable)
void | MakeCurrent ()
virtual int | GetEventPending ()
void | Clean ()
virtual void | SetOffScreenRendering (int offscreen)
virtual void | SetSize (int, int)
virtual void | SetSize (int a[2])
virtual void | SetPosition (int, int)
virtual void | SetPosition (int a[2])
virtual HWND | GetWindowId ()
void | SetWindowId (void *foo)
virtual void | SetParentId (HWND)
void | SetParentId (void *foo)
virtual void | SetNextWindowId (HWND)
void | SetupMemoryRendering (int x, int y, HDC prn)
void | SetupMemoryRendering (HBITMAP hbmp)
void | ResumeScreenRendering (void)
HDC | GetMemoryDC ()
unsigned char * | GetMemoryData ()
virtual void | SetupPalette (HDC hDC)
virtual void | SetupPixelFormat (HDC hDC, DWORD dwFlags, int debug, int bpp=16, int zbpp=16)
void | HideCursor ()
void | ShowCursor ()

Static Public Methods

vtkWin32OpenGLRenderWindow * | New ()

Protected Methods

vtkWin32OpenGLRenderWindow ()
~vtkWin32OpenGLRenderWindow ()
virtual LRESULT | MessageProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)
void | ResizeWhileOffscreen (int xsize, int ysize)
void | CreateAWindow (int x, int y, int width, int height)
void | InitializeApplication ()
void | CleanUpOffScreenRendering (void)
void | CreateOffScreenDC (int xsize, int ysize, HDC aHdc)
void | CreateOffScreenDC (HBITMAP hbmp, HDC aHdc)

Static Protected Methods

LRESULT APIENTRY | WndProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

HINSTANCE | ApplicationInstance
HPALETTE | Palette
HPALETTE | OldPalette
HGLRC | ContextId
HDC | DeviceContext
BOOL | MFChandledWindow
HWND | WindowId
HWND | ParentId
HWND | NextWindowId
int | OwnWindow
int | ScreenSize [2]
BITMAPINFO | MemoryDataHeader
HBITMAP | MemoryBuffer
unsigned char * | MemoryData
HDC | MemoryHdc
int | ScreenMapped
int | ScreenWindowSize [2]
HDC | ScreenDeviceContext
int | ScreenDoubleBuffer
HGLRC | ScreenContextId
int | CursorHidden

Detailed Description

OpenGL rendering window.

Date:
2002/01/22 15:39:47
Revision:
1.51

vtkWin32OpenGLRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkWin32OpenGLRenderer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Geveci, Berk (60%)
  • Martin, Ken (15%)
  • Schroeder, Will (14%)
Examples:
vtkWin32OpenGLRenderWindow (Examples)

Definition at line 49 of file vtkWin32OpenGLRenderWindow.h.

Constructor & Destructor Documentation

vtkWin32OpenGLRenderWindow::vtkWin32OpenGLRenderWindow ( ) [protected]

vtkWin32OpenGLRenderWindow::~vtkWin32OpenGLRenderWindow ( ) [protected]

Member Function Documentation

vtkWin32OpenGLRenderWindow* vtkWin32OpenGLRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkRenderWindow.

vtkWin32OpenGLRenderWindow::vtkTypeRevisionMacro | ( | vtkWin32OpenGLRenderWindow | ,
 |  | vtkOpenGLRenderWindow |
 | ) |

Reimplemented from vtkOpenGLRenderWindow.

void vtkWin32OpenGLRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkOpenGLRenderWindow.

virtual void vtkWin32OpenGLRenderWindow::Start ( void ) [virtual]

Begin the rendering process.

Reimplemented from vtkRenderWindow.

void vtkWin32OpenGLRenderWindow::Frame ( void ) [virtual]

End the rendering process and display the image.

Reimplemented from vtkRenderWindow.

virtual void vtkWin32OpenGLRenderWindow::WindowInitialize ( void ) [virtual]

Create the window

virtual void vtkWin32OpenGLRenderWindow::Initialize ( void ) [virtual]

Initialize the rendering window.

virtual void vtkWin32OpenGLRenderWindow::SetFullScreen ( int ) [virtual]

Change the window to fill the entire screen.

Reimplemented from vtkRenderWindow.

virtual void vtkWin32OpenGLRenderWindow::WindowRemap ( void ) [virtual]

Remap the window.

Reimplemented from vtkRenderWindow.

virtual void vtkWin32OpenGLRenderWindow::PrefFullScreen ( void ) [virtual]

Set the preferred window size to full screen.

virtual void vtkWin32OpenGLRenderWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the size of the window.

Reimplemented from vtkWindow.

virtual void vtkWin32OpenGLRenderWindow::SetSize ( int a[2] ) [inline, virtual]

Set the size of the window.

Reimplemented from vtkWindow.

Definition at line 80 of file vtkWin32OpenGLRenderWindow.h.

virtual int* vtkWin32OpenGLRenderWindow::GetSize ( ) [virtual]

Get the current size of the window.

Reimplemented from vtkWindow.

virtual void vtkWin32OpenGLRenderWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the position of the window.

Reimplemented from vtkWindow.

virtual void vtkWin32OpenGLRenderWindow::SetPosition ( int a[2] ) [inline, virtual]

Set the position of the window.

Reimplemented from vtkWindow.

Definition at line 89 of file vtkWin32OpenGLRenderWindow.h.

virtual int* vtkWin32OpenGLRenderWindow::GetScreenSize ( ) [virtual]

Return the screen size.

virtual int* vtkWin32OpenGLRenderWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkWindow.

virtual void vtkWin32OpenGLRenderWindow::SetWindowName ( char * name ) [virtual]

Set the name of the window. This appears at the top of the window normally.

Reimplemented from vtkWindow.

void vtkWin32OpenGLRenderWindow::SetWindowInfo ( char * info ) [virtual]

Set this RenderWindow's window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkWin32OpenGLRenderWindow::SetParentInfo ( char * info ) [virtual]

Sets the HWND id of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

virtual void* vtkWin32OpenGLRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 109 of file vtkWin32OpenGLRenderWindow.h.

virtual void* vtkWin32OpenGLRenderWindow::GetGenericWindowId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 110 of file vtkWin32OpenGLRenderWindow.h.

virtual void* vtkWin32OpenGLRenderWindow::GetGenericParentId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 111 of file vtkWin32OpenGLRenderWindow.h.

virtual void* vtkWin32OpenGLRenderWindow::GetGenericContext ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 112 of file vtkWin32OpenGLRenderWindow.h.

virtual void vtkWin32OpenGLRenderWindow::SetDisplayId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 113 of file vtkWin32OpenGLRenderWindow.h.

virtual HWND vtkWin32OpenGLRenderWindow::GetWindowId ( ) [virtual]

Get the window id.

void vtkWin32OpenGLRenderWindow::SetWindowId ( void * foo ) [inline, virtual]

Get the window id.

Reimplemented from vtkRenderWindow.

Definition at line 118 of file vtkWin32OpenGLRenderWindow.h.

virtual void vtkWin32OpenGLRenderWindow::SetWindowId ( HWND ) [virtual]

Set the window id to a pre-existing window.

virtual void vtkWin32OpenGLRenderWindow::SetParentId ( HWND ) [virtual]

Set the window's parent id to a pre-existing window.

void vtkWin32OpenGLRenderWindow::SetParentId ( void * foo ) [inline, virtual]

Set the window's parent id to a pre-existing window.

Reimplemented from vtkRenderWindow.

Definition at line 127 of file vtkWin32OpenGLRenderWindow.h.

void vtkWin32OpenGLRenderWindow::SetContextId ( HGLRC )

void vtkWin32OpenGLRenderWindow::SetDeviceContext ( HDC )

virtual void vtkWin32OpenGLRenderWindow::SetNextWindowId ( HWND ) [virtual]

Set the window id of the new window once a WindowRemap is done.

virtual void vtkWin32OpenGLRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. This method overrides the superclass method since this class can actually check whether the window has been realized yet.

Reimplemented from vtkRenderWindow.

void vtkWin32OpenGLRenderWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkOpenGLRenderWindow.

virtual int vtkWin32OpenGLRenderWindow::GetEventPending ( ) [virtual]

Check to see if an event is pending for this window. This is a useful check to abort a long render.

Reimplemented from vtkRenderWindow.

void vtkWin32OpenGLRenderWindow::SetupMemoryRendering | ( | int | x,
 |  | int | y,
 |  | HDC | prn
 | ) |

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void vtkWin32OpenGLRenderWindow::SetupMemoryRendering ( HBITMAP hbmp )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

void vtkWin32OpenGLRenderWindow::ResumeScreenRendering ( void )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

HDC vtkWin32OpenGLRenderWindow::GetMemoryDC ( )

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

unsigned char* vtkWin32OpenGLRenderWindow::GetMemoryData ( ) [inline]

These methods can be used by MFC applications to support print preview and printing, or more general rendering into memory.

Definition at line 159 of file vtkWin32OpenGLRenderWindow.h.

virtual void vtkWin32OpenGLRenderWindow::SetupPalette ( HDC hDC ) [virtual]

Initialize OpenGL for this window.

virtual void vtkWin32OpenGLRenderWindow::SetupPixelFormat | ( | HDC | hDC,
 |  | DWORD | dwFlags,
 |  | int | debug,
 |  | int | bpp = 16,
 |  | int | zbpp = 16
 | ) | [virtual]

Initialize OpenGL for this window.

void vtkWin32OpenGLRenderWindow::Clean ( )

Clean up device contexts, rendering contexts, etc.

void vtkWin32OpenGLRenderWindow::HideCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkWin32OpenGLRenderWindow::ShowCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

virtual void vtkWin32OpenGLRenderWindow::SetOffScreenRendering ( int offscreen ) [virtual]

Override the default implementation so that we can actively switch between on and off screen rendering.

Reimplemented from vtkWindow.

virtual LRESULT vtkWin32OpenGLRenderWindow::MessageProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [protected, virtual]

LRESULT APIENTRY vtkWin32OpenGLRenderWindow::WndProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [static, protected]

void vtkWin32OpenGLRenderWindow::ResizeWhileOffscreen | ( | int | xsize,
 |  | int | ysize
 | ) | [protected]

void vtkWin32OpenGLRenderWindow::CreateAWindow | ( | int | x,
 |  | int | y,
 |  | int | width,
 |  | int | height
 | ) | [protected]

void vtkWin32OpenGLRenderWindow::InitializeApplication ( ) [protected]

void vtkWin32OpenGLRenderWindow::CleanUpOffScreenRendering ( void ) [protected]

void vtkWin32OpenGLRenderWindow::CreateOffScreenDC | ( | int | xsize,
 |  | int | ysize,
 |  | HDC | aHdc
 | ) | [protected]

void vtkWin32OpenGLRenderWindow::CreateOffScreenDC | ( | HBITMAP | hbmp,
 |  | HDC | aHdc
 | ) | [protected]

Member Data Documentation

HINSTANCE vtkWin32OpenGLRenderWindow::ApplicationInstance [protected]

Definition at line 187 of file vtkWin32OpenGLRenderWindow.h.

HPALETTE vtkWin32OpenGLRenderWindow::Palette [protected]

Definition at line 188 of file vtkWin32OpenGLRenderWindow.h.

HPALETTE vtkWin32OpenGLRenderWindow::OldPalette [protected]

Definition at line 189 of file vtkWin32OpenGLRenderWindow.h.

HGLRC vtkWin32OpenGLRenderWindow::ContextId [protected]

Definition at line 190 of file vtkWin32OpenGLRenderWindow.h.

HDC vtkWin32OpenGLRenderWindow::DeviceContext [protected]

Definition at line 191 of file vtkWin32OpenGLRenderWindow.h.

BOOL vtkWin32OpenGLRenderWindow::MFChandledWindow [protected]

Definition at line 192 of file vtkWin32OpenGLRenderWindow.h.

HWND vtkWin32OpenGLRenderWindow::WindowId [protected]

Definition at line 193 of file vtkWin32OpenGLRenderWindow.h.

HWND vtkWin32OpenGLRenderWindow::ParentId [protected]

Definition at line 194 of file vtkWin32OpenGLRenderWindow.h.

HWND vtkWin32OpenGLRenderWindow::NextWindowId [protected]

Definition at line 195 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::OwnWindow [protected]

Definition at line 196 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::ScreenSize[2] [protected]

Definition at line 197 of file vtkWin32OpenGLRenderWindow.h.

BITMAPINFO vtkWin32OpenGLRenderWindow::MemoryDataHeader [protected]

Definition at line 200 of file vtkWin32OpenGLRenderWindow.h.

HBITMAP vtkWin32OpenGLRenderWindow::MemoryBuffer [protected]

Definition at line 201 of file vtkWin32OpenGLRenderWindow.h.

unsigned char* vtkWin32OpenGLRenderWindow::MemoryData [protected]

Definition at line 202 of file vtkWin32OpenGLRenderWindow.h.

HDC vtkWin32OpenGLRenderWindow::MemoryHdc [protected]

Definition at line 203 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::ScreenMapped [protected]

Definition at line 205 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::ScreenWindowSize[2] [protected]

Definition at line 206 of file vtkWin32OpenGLRenderWindow.h.

HDC vtkWin32OpenGLRenderWindow::ScreenDeviceContext [protected]

Definition at line 207 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::ScreenDoubleBuffer [protected]

Definition at line 208 of file vtkWin32OpenGLRenderWindow.h.

HGLRC vtkWin32OpenGLRenderWindow::ScreenContextId [protected]

Definition at line 209 of file vtkWin32OpenGLRenderWindow.h.

int vtkWin32OpenGLRenderWindow::CursorHidden [protected]

Definition at line 219 of file vtkWin32OpenGLRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32OpenGLRenderWindow.h
Generated on Mon Mar 25 01:35:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OpenGLTextMapper Class Reference

2D Text annotation support for windows. More...

#include <vtkWin32OpenGLTextMapper.h>

Inheritance diagram for vtkWin32OpenGLTextMapper:

[legend]
Collaboration diagram for vtkWin32OpenGLTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32OpenGLTextMapper, vtkWin32TextMapper)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderTranslucentGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderOverlay (vtkViewport *vtkNotUsed(viewport), vtkActor2D *vtkNotUsed(actor))

Static Public Methods

vtkWin32OpenGLTextMapper * | New ()
int | GetListBaseForFont (vtkTextMapper *tm, vtkViewport *vp)

Protected Methods

vtkWin32OpenGLTextMapper ()
~vtkWin32OpenGLTextMapper ()

Detailed Description

2D Text annotation support for windows.

Date:
2002/02/07 19:28:53
Revision:
1.18

vtkWin32OpenGLTextMapper provides 2D text annotation support for vtk under Xwindows. Normally the user should use vtktextMapper which in turn will use this class.

See also:
vtkTextMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (73%)
  • Schroeder, Will (9%)
  • Avila, Lisa (8%)

Definition at line 43 of file vtkWin32OpenGLTextMapper.h.

Constructor & Destructor Documentation

vtkWin32OpenGLTextMapper::vtkWin32OpenGLTextMapper ( ) [protected]

vtkWin32OpenGLTextMapper::~vtkWin32OpenGLTextMapper ( ) [protected]

Member Function Documentation

vtkWin32OpenGLTextMapper::vtkTypeRevisionMacro | ( | vtkWin32OpenGLTextMapper | ,
 |  | vtkWin32TextMapper |
 | ) |

Reimplemented from vtkWin32TextMapper.

vtkWin32OpenGLTextMapper* vtkWin32OpenGLTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkWin32TextMapper.

void vtkWin32OpenGLTextMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkWin32OpenGLTextMapper::RenderTranslucentGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkWin32OpenGLTextMapper::RenderGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) |

Actally draw the text.

void vtkWin32OpenGLTextMapper::RenderOverlay | ( | vtkViewport *vtkNotUsed(viewport) | ,
 |  | vtkActor2D *vtkNotUsed(actor) |
 | ) | [inline]

Actally draw the text.

Definition at line 54 of file vtkWin32OpenGLTextMapper.h.

virtual void vtkWin32OpenGLTextMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

int vtkWin32OpenGLTextMapper::GetListBaseForFont | ( | vtkTextMapper * | tm,
 |  | vtkViewport * | vp
 | ) | [static]

An internal function used for caching font display lists.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32OpenGLTextMapper.h
Generated on Mon Mar 25 01:35:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32OutputWindow Class Reference

Win32 Specific output window class. More...

#include <vtkWin32OutputWindow.h>

Inheritance diagram for vtkWin32OutputWindow:

[legend]
Collaboration diagram for vtkWin32OutputWindow:

[legend]
List of all members.

[NOHEADER]

virtual void | DisplayText (const char *)
vtkWin32OutputWindow * | New ()
LRESULT APIENTRY | WndProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)

Public Methods

vtkTypeRevisionMacro (vtkWin32OutputWindow, vtkOutputWindow)

Protected Methods

vtkWin32OutputWindow ()
virtual | ~vtkWin32OutputWindow ()
void | PromptText (const char *text)

Static Protected Methods

void | AddText (const char *)
int | Initialize ()

Static Protected Attributes

HWND | OutputWindow

Detailed Description

Win32 Specific output window class.

Date:
2002/01/22 15:26:44
Revision:
1.14

This class is used for error and debug message output on the windows platform. It creates a read only EDIT control to display the output. This class should not be used directly. It should only be used through the interface of vtkOutputWindow. This class only handles one output window per process. If the window is destroyed, the vtkObject::GlobalWarningDisplayOff() function is called. The window is created the next time text is written to the window.

Created by:
  • Hoffman, Bill
Contributed by (if > 5%):
  • Hoffman, Bill (65%)
  • Martin, Ken (16%)
  • Schroeder, Will (8%)
Tests:
vtkWin32OutputWindow (Tests)

Definition at line 48 of file vtkWin32OutputWindow.h.

Constructor & Destructor Documentation

vtkWin32OutputWindow::vtkWin32OutputWindow ( ) [inline, protected]

Definition at line 65 of file vtkWin32OutputWindow.h.

virtual vtkWin32OutputWindow::~vtkWin32OutputWindow ( ) [inline, protected, virtual]

Definition at line 66 of file vtkWin32OutputWindow.h.

Member Function Documentation

vtkWin32OutputWindow::vtkTypeRevisionMacro | ( | vtkWin32OutputWindow | ,
 |  | vtkOutputWindow |
 | ) |

Reimplemented from vtkOutputWindow.

vtkWin32OutputWindow* vtkWin32OutputWindow::New ( ) [static]

Create a vtkWin32OutputWindow.

Reimplemented from vtkOutputWindow.

virtual void vtkWin32OutputWindow::DisplayText ( const char * ) [virtual]

Reimplemented from vtkOutputWindow.

LRESULT APIENTRY vtkWin32OutputWindow::WndProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [static]

void vtkWin32OutputWindow::PromptText ( const char * text ) [protected]

void vtkWin32OutputWindow::AddText ( const char * ) [static, protected]

int vtkWin32OutputWindow::Initialize ( ) [static, protected]

Member Data Documentation

HWND vtkWin32OutputWindow::OutputWindow [static, protected]

Definition at line 71 of file vtkWin32OutputWindow.h.

The documentation for this class was generated from the following file:
  • Common/vtkWin32OutputWindow.h
Generated on Mon Mar 25 01:35:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32PolyDataMapper2D Class Reference

2D PolyData support for windows. More...

#include <vtkMesaPolyDataMapper2D.h>

Inheritance diagram for vtkWin32PolyDataMapper2D:

[legend]
Collaboration diagram for vtkWin32PolyDataMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32PolyDataMapper2D, vtkPolyDataMapper2D)
virtual void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)

Static Public Methods

vtkWin32PolyDataMapper2D * | New ()

Protected Methods

vtkWin32PolyDataMapper2D ()
~vtkWin32PolyDataMapper2D ()

Detailed Description

2D PolyData support for windows.

Date:
2002/01/22 15:38:44
Revision:
1.10

vtkWin32PolyDataMapper2D provides 2D PolyData annotation support for vtk under windows. Normally the user should use vtkPolyDataMapper2D which in turn will use this class.

See also:
vtkPolyDataMapper2D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (66%)
  • Hoffman, Bill (29%)

Definition at line 43 of file vtkWin32PolyDataMapper2D.h.

Constructor & Destructor Documentation

vtkWin32PolyDataMapper2D::vtkWin32PolyDataMapper2D ( ) [inline, protected]

Definition at line 53 of file vtkWin32PolyDataMapper2D.h.

vtkWin32PolyDataMapper2D::~vtkWin32PolyDataMapper2D ( ) [inline, protected]

Definition at line 54 of file vtkWin32PolyDataMapper2D.h.

Member Function Documentation

vtkWin32PolyDataMapper2D::vtkTypeRevisionMacro | ( | vtkWin32PolyDataMapper2D | ,
 |  | vtkPolyDataMapper2D |
 | ) |

Reimplemented from vtkPolyDataMapper2D.

vtkWin32PolyDataMapper2D* vtkWin32PolyDataMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper2D.

virtual void vtkWin32PolyDataMapper2D::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actually draw the poly data.

Reimplemented from vtkMapper2D.

The documentation for this class was generated from the following files:
  • Rendering/vtkMesaPolyDataMapper2D.h
  • Rendering/vtkWin32PolyDataMapper2D.h
Generated on Mon Mar 25 01:35:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32RenderWindowInteractor Class Reference

implements Win32 specific functions. More...

#include <vtkWin32RenderWindowInteractor.h>

Inheritance diagram for vtkWin32RenderWindowInteractor:

[legend]
Collaboration diagram for vtkWin32RenderWindowInteractor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
virtual void | Start ()
void | TerminateApp (void)
virtual void | ExitCallback ()
virtual void | Enable ()
virtual void | Disable ()
virtual void | SetInstallMessageProc (int)
virtual int | GetInstallMessageProc ()
virtual void | InstallMessageProcOn ()
virtual void | InstallMessageProcOff ()
int | CreateTimer (int timertype)
int | DestroyTimer (void)
virtual void | OnMouseMove (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnNCMouseMove (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnRButtonDown (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnRButtonUp (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnMButtonDown (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnMButtonUp (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnLButtonDown (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnLButtonUp (HWND wnd, UINT nFlags, int X, int Y)
virtual void | OnSize (HWND wnd, UINT nType, int X, int Y)
virtual void | OnTimer (HWND wnd, UINT nIDEvent)
virtual void | OnKeyDown (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags)
virtual void | OnKeyUp (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags)
virtual void | OnChar (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags)

Static Public Methods

vtkWin32RenderWindowInteractor * | New ()
void | SetClassExitMethod (void(*f)(void *), void *arg)
void | SetClassExitMethodArgDelete (void(*f)(void *))

Protected Methods

vtkWin32RenderWindowInteractor ()
~vtkWin32RenderWindowInteractor ()

Protected Attributes

HWND | WindowId
UINT | TimerId
WNDPROC | OldProc
int | InstallMessageProc
int | MouseInWindow

Static Protected Attributes

void(* | ClassExitMethod )(void *)
void(* | ClassExitMethodArgDelete )(void *)
void * | ClassExitMethodArg

Friends

VTK_RENDERING_EXPORT LRESULT
CALLBACK 		vtkHandleMessage (HWND hwnd, UINT uMsg, WPARAM w, LPARAM l)
VTK_RENDERING_EXPORT LRESULT
CALLBACK 		vtkHandleMessage2 (HWND hwnd, UINT uMsg, WPARAM w, LPARAM l, vtkWin32RenderWindowInteractor *me)

Detailed Description

implements Win32 specific functions.

Date:
2002/01/22 15:39:49
Revision:
1.42
required by vtkRenderWindowInteractor.

By default the interactor installs a MessageProc callback which intercepts windows' messages to the window and controls interactions by routing them to the InteractoStyle classes. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessageProc to false. This provides a minimal "Mapped" mode of interaction

Events:
vtkCommand::LeftButtonReleaseEvent vtkCommand::ExitEvent vtkCommand::RightButtonPressEvent vtkCommand::MiddleButtonReleaseEvent vtkCommand::MouseMoveEvent vtkCommand::EnterEvent vtkCommand::StartEvent vtkCommand::TimerEvent vtkCommand::MiddleButtonPressEvent vtkCommand::RightButtonReleaseEvent vtkCommand::ConfigureEvent vtkCommand::KeyPressEvent vtkCommand::CharEvent vtkCommand::LeaveEvent vtkCommand::LeftButtonPressEvent vtkCommand::KeyReleaseEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (51%)
  • Pan, Tony (29%)
  • Gobbi, David (6%)
  • Miller, Jim (5%)
Examples:
vtkWin32RenderWindowInteractor (Examples)

Definition at line 55 of file vtkWin32RenderWindowInteractor.h.

Constructor & Destructor Documentation

vtkWin32RenderWindowInteractor::vtkWin32RenderWindowInteractor ( ) [protected]

vtkWin32RenderWindowInteractor::~vtkWin32RenderWindowInteractor ( ) [protected]

Member Function Documentation

vtkWin32RenderWindowInteractor* vtkWin32RenderWindowInteractor::New ( ) [static]

Construct object so that light follows camera motion.

Reimplemented from vtkRenderWindowInteractor.

vtkWin32RenderWindowInteractor::vtkTypeRevisionMacro | ( | vtkWin32RenderWindowInteractor | ,
 |  | vtkRenderWindowInteractor |
 | ) |

Reimplemented from vtkRenderWindowInteractor.

void vtkWin32RenderWindowInteractor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::Initialize ( void ) [virtual]

Initialize the event handler

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::Enable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::Disable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::Start ( void ) [virtual]

This will start up the event loop and never return. If you call this method it will loop processing events until the application is exited.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::SetInstallMessageProc ( int ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual int vtkWin32RenderWindowInteractor::GetInstallMessageProc ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual void vtkWin32RenderWindowInteractor::InstallMessageProcOn ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

virtual void vtkWin32RenderWindowInteractor::InstallMessageProcOff ( ) [virtual]

By default the interactor installs a MessageProc callback which intercepts windows messages to the window and controls interactions. MFC or BCB programs can prevent this and instead directly route any mouse/key messages into the event bindings by setting InstallMessgeProc to false.

void vtkWin32RenderWindowInteractor::TerminateApp ( void ) [virtual]

Win32 specific application terminate, calls ClassExitMethod then calls PostQuitMessage(0) to terminate the application. An application can Specify ExitMethod for alternative behavior (i.e. suppression of keyboard exit)

Reimplemented from vtkRenderWindowInteractor.

int vtkWin32RenderWindowInteractor::CreateTimer ( int timertype ) [virtual]

Win32 timer methods

Reimplemented from vtkRenderWindowInteractor.

int vtkWin32RenderWindowInteractor::DestroyTimer ( void ) [virtual]

Win32 timer methods

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkWin32RenderWindowInteractor::OnMouseMove | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnNCMouseMove | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnRButtonDown | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnRButtonUp | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnMButtonDown | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnMButtonUp | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnLButtonDown | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnLButtonUp | ( | HWND | wnd,
 |  | UINT | nFlags,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnSize | ( | HWND | wnd,
 |  | UINT | nType,
 |  | int | X,
 |  | int | Y
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnTimer | ( | HWND | wnd,
 |  | UINT | nIDEvent
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnKeyDown | ( | HWND | wnd,
 |  | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnKeyUp | ( | HWND | wnd,
 |  | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

virtual void vtkWin32RenderWindowInteractor::OnChar | ( | HWND | wnd,
 |  | UINT | nChar,
 |  | UINT | nRepCnt,
 |  | UINT | nFlags
 | ) | [virtual]

Various methods that a Win32 window can redirect to this class to be handled.

void vtkWin32RenderWindowInteractor::SetClassExitMethod | ( | void(* | f)(void *),
 |  | void * | arg
 | ) | [static]

Methods to set the default exit method for the class. This method is only used if no instance level ExitMethod has been defined. It is provided as a means to control how an interactor is exited given the various language bindings (tcl, Win32, etc.).

void vtkWin32RenderWindowInteractor::SetClassExitMethodArgDelete ( void(* f)(void *) ) [static]

Methods to set the default exit method for the class. This method is only used if no instance level ExitMethod has been defined. It is provided as a means to control how an interactor is exited given the various language bindings (tcl, Win32, etc.).

virtual void vtkWin32RenderWindowInteractor::ExitCallback ( ) [virtual]

These methods correspond to the the Exit, User and Pick callbacks. They allow for the Style to invoke them.

Reimplemented from vtkRenderWindowInteractor.

Friends And Related Function Documentation

VTK_RENDERING_EXPORT LRESULT CALLBACK vtkHandleMessage | ( | HWND | hwnd,
 |  | UINT | uMsg,
 |  | WPARAM | w,
 |  | LPARAM | l
 | ) | [friend]

VTK_RENDERING_EXPORT LRESULT CALLBACK vtkHandleMessage2 | ( | HWND | hwnd,
 |  | UINT | uMsg,
 |  | WPARAM | w,
 |  | LPARAM | l,
 |  | vtkWin32RenderWindowInteractor * | me
 | ) | [friend]

Member Data Documentation

HWND vtkWin32RenderWindowInteractor::WindowId [protected]

Definition at line 147 of file vtkWin32RenderWindowInteractor.h.

UINT vtkWin32RenderWindowInteractor::TimerId [protected]

Definition at line 148 of file vtkWin32RenderWindowInteractor.h.

WNDPROC vtkWin32RenderWindowInteractor::OldProc [protected]

Definition at line 149 of file vtkWin32RenderWindowInteractor.h.

int vtkWin32RenderWindowInteractor::InstallMessageProc [protected]

Definition at line 150 of file vtkWin32RenderWindowInteractor.h.

int vtkWin32RenderWindowInteractor::MouseInWindow [protected]

Definition at line 152 of file vtkWin32RenderWindowInteractor.h.

void(* vtkWin32RenderWindowInteractor::ClassExitMethod)(void *) [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Win32)

void(* vtkWin32RenderWindowInteractor::ClassExitMethodArgDelete)(void *) [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Win32)

void* vtkWin32RenderWindowInteractor::ClassExitMethodArg [static, protected]

Class variables so an exit method can be defined for this class (used to set different exit methods for various language bindings, i.e. tcl, java, Win32)

Definition at line 161 of file vtkWin32RenderWindowInteractor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32RenderWindowInteractor.h
Generated on Mon Mar 25 01:35:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32TextMapper Class Reference

2D Text annotation support for windows. More...

#include <vtkWin32TextMapper.h>

Inheritance diagram for vtkWin32TextMapper:

[legend]
Collaboration diagram for vtkWin32TextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32TextMapper, vtkTextMapper)
void | GetSize (vtkViewport *viewport, int size[2])

Static Public Methods

vtkWin32TextMapper * | New ()

Protected Methods

vtkWin32TextMapper ()
~vtkWin32TextMapper ()

Protected Attributes

vtkTimeStamp BuildTime
int | LastSize [2]
HFONT | Font

Detailed Description

2D Text annotation support for windows.

Date:
2002/01/22 15:39:50
Revision:
1.24

vtkWin32TextMapper provides 2D text annotation support for vtk under Xwindows. Normally the user should use vtktextMapper which in turn will use this class.

See also:
vtkTextMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (81%)
  • Schroeder, Will (7%)
  • Miller, Jim (6%)

Definition at line 43 of file vtkWin32TextMapper.h.

Constructor & Destructor Documentation

vtkWin32TextMapper::vtkWin32TextMapper ( ) [protected]

vtkWin32TextMapper::~vtkWin32TextMapper ( ) [protected]

Member Function Documentation

vtkWin32TextMapper::vtkTypeRevisionMacro | ( | vtkWin32TextMapper | ,
 |  | vtkTextMapper |
 | ) |

Reimplemented from vtkTextMapper.

Reimplemented in vtkWin32OpenGLTextMapper.

vtkWin32TextMapper* vtkWin32TextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkTextMapper.

Reimplemented in vtkWin32OpenGLTextMapper.

void vtkWin32TextMapper::GetSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [virtual]

What is the size of the rectangle required to draw this mapper ?

Reimplemented from vtkTextMapper.

Member Data Documentation

vtkTimeStamp vtkWin32TextMapper::BuildTime [protected]

Definition at line 56 of file vtkWin32TextMapper.h.

int vtkWin32TextMapper::LastSize[2] [protected]

Definition at line 57 of file vtkWin32TextMapper.h.

HFONT vtkWin32TextMapper::Font [protected]

Definition at line 58 of file vtkWin32TextMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWin32TextMapper.h
Generated on Mon Mar 25 01:35:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWin32VideoSource Class Reference

Video-for-Windows video digitizer. More...

#include <vtkWin32VideoSource.h>

Inheritance diagram for vtkWin32VideoSource:

[legend]
Collaboration diagram for vtkWin32VideoSource:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWin32VideoSource, vtkVideoSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Record ()
void | Play ()
void | Stop ()
void | Grab ()
void | SetFrameSize (int x, int y, int z)
void | SetFrameRate (float rate)
void | SetOutputFormat (int format)
void | VideoFormatDialog ()
void | VideoSourceDialog ()
void | Initialize ()
void | ReleaseSystemResources ()
void | SetPreview (int p)
virtual void | PreviewOn ()
virtual void | PreviewOff ()
virtual int | GetPreview ()
void | InternalGrab (LPVIDEOHDR VideoHdrPtr)
void | OnParentWndDestroy ()

Static Public Methods

vtkWin32VideoSource * | New ()

Protected Methods

vtkWin32VideoSource ()
~vtkWin32VideoSource ()
void | CheckBuffer ()
void | UnpackRasterLine (char *outptr, char *inptr, int start, int count)
void | DoVFWFormatSetup ()
void | DoVFWFormatCheck ()

Protected Attributes

char | WndClassName [16]
HWND | CapWnd
HWND | ParentWnd
CAPSTATUS | CapStatus
CAPDRIVERCAPS | CapDriverCaps
CAPTUREPARMS | CaptureParms
LPBITMAPINFO | BitMapPtr
int | BitMapSize
int | Preview

Detailed Description

Video-for-Windows video digitizer.

Date:
2002/01/22 15:30:45
Revision:
1.15

vtkWin32VideoSource grabs frames or streaming video from a Video for Windows compatible device on the Win32 platform.

See also:
vtkVideoSource vtkMILVideoSource
Created by:
  • Gobbi, David
Contributed by (if > 5%):
  • Gobbi, David (98%)
Tests:
vtkWin32VideoSource (Tests)

Definition at line 46 of file vtkWin32VideoSource.h.

Constructor & Destructor Documentation

vtkWin32VideoSource::vtkWin32VideoSource ( ) [protected]

vtkWin32VideoSource::~vtkWin32VideoSource ( ) [protected]

Member Function Documentation

vtkWin32VideoSource* vtkWin32VideoSource::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkVideoSource.

vtkWin32VideoSource::vtkTypeRevisionMacro | ( | vtkWin32VideoSource | ,
 |  | vtkVideoSource |
 | ) |

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::Record ( ) [virtual]

Standard VCR functionality: Record incoming video.

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::Play ( ) [virtual]

Standard VCR functionality: Play recorded video.

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::Stop ( ) [virtual]

Standard VCR functionality: Stop recording or playing.

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::Grab ( ) [virtual]

Grab a single video frame.

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::SetFrameSize | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) | [virtual]

Request a particular frame size (set the third value to 1).

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::SetFrameRate ( float rate ) [virtual]

Request a particular frame rate (default 30 frames per second).

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::SetOutputFormat ( int format ) [virtual]

Request a particular output format (default: VTK_RGB).

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::SetPreview ( int p )

Turn on/off the preview (overlay) window.

virtual void vtkWin32VideoSource::PreviewOn ( ) [virtual]

Turn on/off the preview (overlay) window.

virtual void vtkWin32VideoSource::PreviewOff ( ) [virtual]

Turn on/off the preview (overlay) window.

virtual int vtkWin32VideoSource::GetPreview ( ) [virtual]

Turn on/off the preview (overlay) window.

void vtkWin32VideoSource::VideoFormatDialog ( )

Bring up a modal dialog box for video format selection.

void vtkWin32VideoSource::VideoSourceDialog ( )

Bring up a modal dialog box for video input selection.

void vtkWin32VideoSource::Initialize ( ) [virtual]

Initialize the driver (this is called automatically when the first grab is done).

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::ReleaseSystemResources ( ) [virtual]

Free the driver (this is called automatically inside the destructor).

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::InternalGrab ( LPVIDEOHDR VideoHdrPtr )

For internal use only

void vtkWin32VideoSource::OnParentWndDestroy ( )

For internal use only

void vtkWin32VideoSource::CheckBuffer ( ) [protected]

void vtkWin32VideoSource::UnpackRasterLine | ( | char * | outptr,
 |  | char * | inptr,
 |  | int | start,
 |  | int | count
 | ) | [protected, virtual]

These methods can be overridden in subclasses

Reimplemented from vtkVideoSource.

void vtkWin32VideoSource::DoVFWFormatSetup ( ) [protected]

void vtkWin32VideoSource::DoVFWFormatCheck ( ) [protected]

Member Data Documentation

char vtkWin32VideoSource::WndClassName[16] [protected]

Definition at line 104 of file vtkWin32VideoSource.h.

HWND vtkWin32VideoSource::CapWnd [protected]

Definition at line 105 of file vtkWin32VideoSource.h.

HWND vtkWin32VideoSource::ParentWnd [protected]

Definition at line 106 of file vtkWin32VideoSource.h.

CAPSTATUS vtkWin32VideoSource::CapStatus [protected]

Definition at line 107 of file vtkWin32VideoSource.h.

CAPDRIVERCAPS vtkWin32VideoSource::CapDriverCaps [protected]

Definition at line 108 of file vtkWin32VideoSource.h.

CAPTUREPARMS vtkWin32VideoSource::CaptureParms [protected]

Definition at line 109 of file vtkWin32VideoSource.h.

LPBITMAPINFO vtkWin32VideoSource::BitMapPtr [protected]

Definition at line 110 of file vtkWin32VideoSource.h.

int vtkWin32VideoSource::BitMapSize [protected]

Definition at line 111 of file vtkWin32VideoSource.h.

int vtkWin32VideoSource::Preview [protected]

Definition at line 113 of file vtkWin32VideoSource.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkWin32VideoSource.h
Generated on Mon Mar 25 01:36:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWinCE Class Reference

support for C++ functionality missing in WinCE. More...

#include <vtkWinCE.h>

Detailed Description

support for C++ functionality missing in WinCE.

Date:
2002/01/22 15:26:45
Revision:
1.2

This is a half baked implementaiton of some of the key features missing from WindowsCE. Half of this is implemented and half is missing.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (100%)

The documentation for this class was generated from the following file:
  • Common/vtkWinCE.h
Generated on Mon Mar 25 01:36:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWinCEOpenGLRenderWindow Class Reference

OpenGL rendering window. More...

#include <vtkWinCEOpenGLRenderWindow.h>

Inheritance diagram for vtkWinCEOpenGLRenderWindow:

[legend]
Collaboration diagram for vtkWinCEOpenGLRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWinCEOpenGLRenderWindow, vtkOpenGLRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Start (void)
void | Frame (void)
virtual void | WindowInitialize (void)
virtual void | Initialize (void)
virtual void | SetFullScreen (int)
virtual void | WindowRemap (void)
virtual void | PrefFullScreen (void)
virtual void | SetSize (int, int)
virtual int * | GetSize ()
virtual void | SetPosition (int, int)
virtual int * | GetScreenSize ()
virtual int * | GetPosition ()
virtual void | SetWindowName (char *)
void | SetWindowInfo (char *)
void | SetParentInfo (char *)
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void | SetDisplayId (void *)
virtual void | SetWindowId (HWND)
virtual void | SetStereoCapableWindow (int capable)
void | MakeCurrent ()
virtual int | GetEventPending ()
void | Clean ()
virtual HWND | GetWindowId ()
void | SetWindowId (void *foo)
virtual void | SetParentId (HWND)
void | SetParentId (void *foo)
virtual void | SetNextWindowId (HWND)
void | HideCursor ()
void | ShowCursor ()

Static Public Methods

vtkWinCEOpenGLRenderWindow * | New ()

Protected Methods

vtkWinCEOpenGLRenderWindow ()
~vtkWinCEOpenGLRenderWindow ()
virtual LRESULT | MessageProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)
void | ResizeWhileOffscreen (int xsize, int ysize)
void | CreateAWindow (int x, int y, int width, int height)
void | InitializeApplication ()

Static Protected Methods

LRESULT APIENTRY | WndProc (HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)

Protected Attributes

HINSTANCE | ApplicationInstance
OSMesaContext | OffScreenContextId
void * | OffScreenWindow
HDC | DeviceContext
HWND | WindowId
HWND | ParentId
HWND | NextWindowId
int | OwnWindow
int | ScreenSize [2]
int | CursorHidden

Detailed Description

OpenGL rendering window.

Date:
2002/01/22 15:39:51
Revision:
1.3

vtkWinCEOpenGLRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkWinCEOpenGLRenderer interfaces to the standard OpenGL graphics library in the Windows/NT environment..

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (100%)

Definition at line 43 of file vtkWinCEOpenGLRenderWindow.h.

Constructor & Destructor Documentation

vtkWinCEOpenGLRenderWindow::vtkWinCEOpenGLRenderWindow ( ) [protected]

vtkWinCEOpenGLRenderWindow::~vtkWinCEOpenGLRenderWindow ( ) [protected]

Member Function Documentation

vtkWinCEOpenGLRenderWindow* vtkWinCEOpenGLRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkRenderWindow.

vtkWinCEOpenGLRenderWindow::vtkTypeRevisionMacro | ( | vtkWinCEOpenGLRenderWindow | ,
 |  | vtkOpenGLRenderWindow |
 | ) |

Reimplemented from vtkOpenGLRenderWindow.

void vtkWinCEOpenGLRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkOpenGLRenderWindow.

virtual void vtkWinCEOpenGLRenderWindow::Start ( void ) [virtual]

Begin the rendering process.

Reimplemented from vtkRenderWindow.

void vtkWinCEOpenGLRenderWindow::Frame ( void ) [virtual]

End the rendering process and display the image.

Reimplemented from vtkRenderWindow.

virtual void vtkWinCEOpenGLRenderWindow::WindowInitialize ( void ) [virtual]

Create the window

virtual void vtkWinCEOpenGLRenderWindow::Initialize ( void ) [virtual]

Initialize the rendering window.

virtual void vtkWinCEOpenGLRenderWindow::SetFullScreen ( int ) [virtual]

Change the window to fill the entire screen.

Reimplemented from vtkRenderWindow.

virtual void vtkWinCEOpenGLRenderWindow::WindowRemap ( void ) [virtual]

Remap the window.

Reimplemented from vtkRenderWindow.

virtual void vtkWinCEOpenGLRenderWindow::PrefFullScreen ( void ) [virtual]

Set the preferred window size to full screen.

virtual void vtkWinCEOpenGLRenderWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the size of the window.

Reimplemented from vtkWindow.

virtual int* vtkWinCEOpenGLRenderWindow::GetSize ( ) [virtual]

Get the current size of the window.

Reimplemented from vtkWindow.

virtual void vtkWinCEOpenGLRenderWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set the position of the window.

Reimplemented from vtkWindow.

virtual int* vtkWinCEOpenGLRenderWindow::GetScreenSize ( ) [virtual]

Return the screen size.

virtual int* vtkWinCEOpenGLRenderWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates of the window.

Reimplemented from vtkWindow.

virtual void vtkWinCEOpenGLRenderWindow::SetWindowName ( char * name ) [virtual]

Set the name of the window. This appears at the top of the window normally.

Reimplemented from vtkWindow.

void vtkWinCEOpenGLRenderWindow::SetWindowInfo ( char * info ) [virtual]

Set this RenderWindow's window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkWinCEOpenGLRenderWindow::SetParentInfo ( char * info ) [virtual]

Sets the HWND id of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

virtual void* vtkWinCEOpenGLRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 97 of file vtkWinCEOpenGLRenderWindow.h.

virtual void* vtkWinCEOpenGLRenderWindow::GetGenericWindowId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 98 of file vtkWinCEOpenGLRenderWindow.h.

virtual void* vtkWinCEOpenGLRenderWindow::GetGenericParentId ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 99 of file vtkWinCEOpenGLRenderWindow.h.

virtual void* vtkWinCEOpenGLRenderWindow::GetGenericContext ( ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 100 of file vtkWinCEOpenGLRenderWindow.h.

virtual void vtkWinCEOpenGLRenderWindow::SetDisplayId ( void * foo ) [inline, virtual]

Dummy stubs for vtkWindow API.

Reimplemented from vtkRenderWindow.

Definition at line 101 of file vtkWinCEOpenGLRenderWindow.h.

virtual HWND vtkWinCEOpenGLRenderWindow::GetWindowId ( ) [virtual]

Get the window id.

void vtkWinCEOpenGLRenderWindow::SetWindowId ( void * foo ) [inline, virtual]

Get the window id.

Reimplemented from vtkRenderWindow.

Definition at line 106 of file vtkWinCEOpenGLRenderWindow.h.

virtual void vtkWinCEOpenGLRenderWindow::SetWindowId ( HWND ) [virtual]

Set the window id to a pre-existing window.

virtual void vtkWinCEOpenGLRenderWindow::SetParentId ( HWND ) [virtual]

Set the window's parent id to a pre-existing window.

void vtkWinCEOpenGLRenderWindow::SetParentId ( void * foo ) [inline, virtual]

Set the window's parent id to a pre-existing window.

Reimplemented from vtkRenderWindow.

Definition at line 115 of file vtkWinCEOpenGLRenderWindow.h.

virtual void vtkWinCEOpenGLRenderWindow::SetNextWindowId ( HWND ) [virtual]

Set the window id of the new window once a WindowRemap is done.

virtual void vtkWinCEOpenGLRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. This method overrides the superclass method since this class can actually check whether the window has been realized yet.

Reimplemented from vtkRenderWindow.

void vtkWinCEOpenGLRenderWindow::MakeCurrent ( ) [virtual]

Make this windows OpenGL context the current context.

Reimplemented from vtkOpenGLRenderWindow.

virtual int vtkWinCEOpenGLRenderWindow::GetEventPending ( ) [virtual]

Check to see if an event is pending for this window. This is a useful check to abort a long render.

Reimplemented from vtkRenderWindow.

void vtkWinCEOpenGLRenderWindow::Clean ( )

Clean up device contexts, rendering contexts, etc.

void vtkWinCEOpenGLRenderWindow::HideCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkWinCEOpenGLRenderWindow::ShowCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

virtual LRESULT vtkWinCEOpenGLRenderWindow::MessageProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [protected, virtual]

LRESULT APIENTRY vtkWinCEOpenGLRenderWindow::WndProc | ( | HWND | hWnd,
 |  | UINT | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) | [static, protected]

void vtkWinCEOpenGLRenderWindow::ResizeWhileOffscreen | ( | int | xsize,
 |  | int | ysize
 | ) | [protected]

void vtkWinCEOpenGLRenderWindow::CreateAWindow | ( | int | x,
 |  | int | y,
 |  | int | width,
 |  | int | height
 | ) | [protected]

void vtkWinCEOpenGLRenderWindow::InitializeApplication ( ) [protected]

Member Data Documentation

HINSTANCE vtkWinCEOpenGLRenderWindow::ApplicationInstance [protected]

Definition at line 151 of file vtkWinCEOpenGLRenderWindow.h.

OSMesaContext vtkWinCEOpenGLRenderWindow::OffScreenContextId [protected]

Definition at line 153 of file vtkWinCEOpenGLRenderWindow.h.

void* vtkWinCEOpenGLRenderWindow::OffScreenWindow [protected]

Definition at line 154 of file vtkWinCEOpenGLRenderWindow.h.

HDC vtkWinCEOpenGLRenderWindow::DeviceContext [protected]

Definition at line 156 of file vtkWinCEOpenGLRenderWindow.h.

HWND vtkWinCEOpenGLRenderWindow::WindowId [protected]

Definition at line 157 of file vtkWinCEOpenGLRenderWindow.h.

HWND vtkWinCEOpenGLRenderWindow::ParentId [protected]

Definition at line 158 of file vtkWinCEOpenGLRenderWindow.h.

HWND vtkWinCEOpenGLRenderWindow::NextWindowId [protected]

Definition at line 159 of file vtkWinCEOpenGLRenderWindow.h.

int vtkWinCEOpenGLRenderWindow::OwnWindow [protected]

Definition at line 160 of file vtkWinCEOpenGLRenderWindow.h.

int vtkWinCEOpenGLRenderWindow::ScreenSize[2] [protected]

Definition at line 161 of file vtkWinCEOpenGLRenderWindow.h.

int vtkWinCEOpenGLRenderWindow::CursorHidden [protected]

Definition at line 171 of file vtkWinCEOpenGLRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWinCEOpenGLRenderWindow.h
Generated on Mon Mar 25 01:36:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindow Class Reference

window superclass for ImageWindow and RenderWindow. More...

#include <vtkWindow.h>

Inheritance diagram for vtkWindow:

[legend]
Collaboration diagram for vtkWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWindow, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Render ()=0
virtual void | MakeCurrent ()
virtual void | SetDisplayId (void *)=0
virtual void | SetWindowId (void *)=0
virtual void | SetParentId (void *)=0
virtual void * | GetGenericDisplayId ()=0
virtual void * | GetGenericWindowId ()=0
virtual void * | GetGenericParentId ()=0
virtual void * | GetGenericContext ()=0
virtual void * | GetGenericDrawable ()=0
virtual void | SetWindowInfo (char *)=0
virtual void | SetParentInfo (char *)=0
virtual int * | GetPosition ()
virtual void | SetPosition (int, int)
virtual void | SetPosition (int a[2])
virtual int * | GetSize ()
virtual void | SetSize (int, int)
virtual void | SetSize (int a[2])
virtual void | SetMapped (int)
virtual int | GetMapped ()
virtual void | MappedOn ()
virtual void | MappedOff ()
virtual void | SetErase (int)
virtual int | GetErase ()
virtual void | EraseOn ()
virtual void | EraseOff ()
virtual void | SetDoubleBuffer (int)
virtual int | GetDoubleBuffer ()
virtual void | DoubleBufferOn ()
virtual void | DoubleBufferOff ()
virtual char * | GetWindowName ()
virtual void | SetWindowName (char *)
virtual unsigned char * | GetPixelData (int, int, int, int, int)
virtual int | GetDPI ()
virtual void | SetDPI (int)
virtual void | SetOffScreenRendering (int)
virtual int | GetOffScreenRendering ()
virtual void | OffScreenRenderingOn ()
virtual void | OffScreenRenderingOff ()
virtual void | SetTileScale (int)
virtual int | GetTileScale ()
virtual void | SetTileViewport (float, float, float, float)
virtual void | SetTileViewport (float[4])
virtual float * | GetTileViewport ()
virtual void | GetTileViewport (float &, float &, float &, float &)
virtual void | GetTileViewport (float[4])

Protected Methods

vtkWindow ()
~vtkWindow ()

Protected Attributes

int | OffScreenRendering
char * | WindowName
int | Size [2]
int | Position [2]
int | Mapped
int | Erase
int | DoubleBuffer
int | DPI
float | TileViewport [4]
int | TileSize [2]
int | TileScale

Detailed Description

window superclass for ImageWindow and RenderWindow.

Date:
2002/01/22 15:26:46
Revision:
1.26

vtkWindow is an abstract object to specify the behavior of a rendering or imaging window. It contains vtkViewports.

See also:
vtkImageWindow vtkRenderWindow vtkViewport
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Avila, Lisa (5%)
Examples:
vtkWindow (Examples)

Definition at line 45 of file vtkWindow.h.

Constructor & Destructor Documentation

vtkWindow::vtkWindow ( ) [protected]

vtkWindow::~vtkWindow ( ) [protected]

Member Function Documentation

vtkWindow::vtkTypeRevisionMacro | ( | vtkWindow | ,
 |  | vtkObject |
 | ) |

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkMesaRenderWindow, vtkOpenGLImageWindow, vtkOpenGLRenderWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

void vtkWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkMesaRenderWindow, vtkOpenGLImageWindow, vtkOpenGLRenderWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetDisplayId ( void * foo ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetWindowId ( void * foo ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetParentId ( void * foo ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void* vtkWindow::GetGenericDisplayId ( ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void* vtkWindow::GetGenericWindowId ( ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void* vtkWindow::GetGenericParentId ( ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void* vtkWindow::GetGenericContext ( ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void* vtkWindow::GetGenericDrawable ( ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetWindowInfo ( char * info ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetParentInfo ( char * info ) [pure virtual]

These are window system independent methods that are used to help interface vtkWindow to native windowing systems.

Reimplemented in vtkImageWindow, vtkRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual int* vtkWindow::GetPosition ( ) [virtual]

Set/Get the position in screen coordinates of the rendering window.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the position in screen coordinates of the rendering window.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Referenced by vtkXOpenGLRenderWindow::SetPosition(), vtkXMesaRenderWindow::SetPosition(), vtkWin32OpenGLRenderWindow::SetPosition(), and vtkImageWindow::SetPosition().

virtual void vtkWindow::SetPosition ( int a[2] ) [virtual]

Set/Get the position in screen coordinates of the rendering window.

Reimplemented in vtkImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual int* vtkWindow::GetSize ( ) [virtual]

Set/Get the size of the window in screen coordinates.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, and vtkXImageWindow.

virtual void vtkWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the size of the window in screen coordinates.

Reimplemented in vtkImageWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Referenced by vtkXOpenGLRenderWindow::SetSize(), vtkXMesaRenderWindow::SetSize(), vtkWin32OpenGLRenderWindow::SetSize(), and vtkImageWindow::SetSize().

virtual void vtkWindow::SetSize ( int a[2] ) [virtual]

Set/Get the size of the window in screen coordinates.

Reimplemented in vtkImageWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::SetMapped ( int ) [virtual]

Keep track of whether the rendering window has been mapped to screen.

virtual int vtkWindow::GetMapped ( ) [virtual]

Keep track of whether the rendering window has been mapped to screen.

virtual void vtkWindow::MappedOn ( ) [virtual]

Keep track of whether the rendering window has been mapped to screen.

virtual void vtkWindow::MappedOff ( ) [virtual]

Keep track of whether the rendering window has been mapped to screen.

virtual void vtkWindow::SetErase ( int ) [virtual]

Turn on/off erasing the screen between images. This allows multiple exposure sequences if turned on. You will need to turn double buffering off or make use of the SwapBuffers methods to prevent you from swapping buffers between exposures.

virtual int vtkWindow::GetErase ( ) [virtual]

Turn on/off erasing the screen between images. This allows multiple exposure sequences if turned on. You will need to turn double buffering off or make use of the SwapBuffers methods to prevent you from swapping buffers between exposures.

virtual void vtkWindow::EraseOn ( ) [virtual]

Turn on/off erasing the screen between images. This allows multiple exposure sequences if turned on. You will need to turn double buffering off or make use of the SwapBuffers methods to prevent you from swapping buffers between exposures.

virtual void vtkWindow::EraseOff ( ) [virtual]

Turn on/off erasing the screen between images. This allows multiple exposure sequences if turned on. You will need to turn double buffering off or make use of the SwapBuffers methods to prevent you from swapping buffers between exposures.

virtual void vtkWindow::SetDoubleBuffer ( int ) [virtual]

Keep track of whether double buffering is on or off

virtual int vtkWindow::GetDoubleBuffer ( ) [virtual]

Keep track of whether double buffering is on or off

virtual void vtkWindow::DoubleBufferOn ( ) [virtual]

Keep track of whether double buffering is on or off

virtual void vtkWindow::DoubleBufferOff ( ) [virtual]

Keep track of whether double buffering is on or off

virtual char* vtkWindow::GetWindowName ( ) [virtual]

Get name of rendering window

virtual void vtkWindow::SetWindowName ( char * name ) [virtual]

Get name of rendering window

Reimplemented in vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual void vtkWindow::Render ( ) [pure virtual]

Ask each viewport owned by this Window to render its image and synchronize this process.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkOpenGLImageWindow, vtkQuartzImageWindow, vtkRenderWindow, vtkWin32OpenGLImageWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual unsigned char* vtkWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [inline, virtual]

Get the pixel data of an image, transmitted as RGBRGBRGB. The front argument indicates if the front buffer should be used or the back buffer. It is the caller's responsibility to delete the resulting array. It is very important to realize that the memory in this array is organized from the bottom of the window to the top. The origin of the screen is in the lower left corner. The y axis increases as you go up the screen. So the storage of pixels is from left to right and from bottom to top.

Reimplemented in vtkMesaImageWindow, vtkMesaRenderWindow, vtkOpenGLImageWindow, vtkOpenGLRenderWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkWin32ImageWindow, vtkWin32OpenGLImageWindow, and vtkXImageWindow.

Definition at line 123 of file vtkWindow.h.

virtual int vtkWindow::GetDPI ( ) [virtual]

Return a best estimate to the dots per inch of the display device being rendered (or printed).

virtual void vtkWindow::SetDPI ( int ) [virtual]

Return a best estimate to the dots per inch of the display device being rendered (or printed).

virtual void vtkWindow::SetOffScreenRendering ( int i ) [virtual]

Create a window in memory instead of on the screen. This may not be supported for every type of window and on some windows you may need to invoke this prior to the first render.

Reimplemented in vtkMesaImageWindow, vtkWin32OpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

virtual int vtkWindow::GetOffScreenRendering ( ) [virtual]

Create a window in memory instead of on the screen. This may not be supported for every type of window and on some windows you may need to invoke this prior to the first render.

virtual void vtkWindow::OffScreenRenderingOn ( ) [virtual]

Create a window in memory instead of on the screen. This may not be supported for every type of window and on some windows you may need to invoke this prior to the first render.

virtual void vtkWindow::OffScreenRenderingOff ( ) [virtual]

Create a window in memory instead of on the screen. This may not be supported for every type of window and on some windows you may need to invoke this prior to the first render.

virtual void vtkWindow::MakeCurrent ( ) [inline, virtual]

Make the window current. May be overridden in subclasses to do for example a glXMakeCurrent or a wglMakeCurrent.

Reimplemented in vtkImageWindow, vtkMesaImageWindow, vtkMesaRenderWindow, vtkOpenGLImageWindow, vtkOpenGLRenderWindow, vtkQuartzImageWindow, vtkQuartzRenderWindow, vtkRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32OpenGLRenderWindow, vtkWinCEOpenGLRenderWindow, vtkXMesaRenderWindow, and vtkXOpenGLRenderWindow.

Definition at line 145 of file vtkWindow.h.

virtual void vtkWindow::SetTileScale ( int ) [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual int vtkWindow::GetTileScale ( ) [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual void vtkWindow::SetTileViewport | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual void vtkWindow::SetTileViewport ( float [4] ) [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual float* vtkWindow::GetTileViewport ( ) [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual void vtkWindow::GetTileViewport | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

virtual void vtkWindow::GetTileViewport ( float [4] ) [virtual]

These methods are used by vtkWindowToImageFilter to tell a VTK window to simulate a larger window by tiling. For 3D geometry these methods have no impact. It is just in handling annotation that this information must be available to the mappers and the coordinate calculations.

Member Data Documentation

int vtkWindow::OffScreenRendering [protected]

Definition at line 161 of file vtkWindow.h.

char* vtkWindow::WindowName [protected]

Definition at line 165 of file vtkWindow.h.

int vtkWindow::Size[2] [protected]

Definition at line 166 of file vtkWindow.h.

int vtkWindow::Position[2] [protected]

Definition at line 167 of file vtkWindow.h.

int vtkWindow::Mapped [protected]

Definition at line 168 of file vtkWindow.h.

int vtkWindow::Erase [protected]

Definition at line 169 of file vtkWindow.h.

int vtkWindow::DoubleBuffer [protected]

Definition at line 170 of file vtkWindow.h.

int vtkWindow::DPI [protected]

Definition at line 171 of file vtkWindow.h.

float vtkWindow::TileViewport[4] [protected]

Definition at line 173 of file vtkWindow.h.

int vtkWindow::TileSize[2] [protected]

Definition at line 174 of file vtkWindow.h.

int vtkWindow::TileScale [protected]

Definition at line 175 of file vtkWindow.h.

The documentation for this class was generated from the following file:
  • Common/vtkWindow.h
Generated on Mon Mar 25 01:36:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowedSincPolyDataFilter Class Reference

adjust point positions using a windowed sinc function interpolation kernel. More...

#include <vtkWindowedSincPolyDataFilter.h>

Inheritance diagram for vtkWindowedSincPolyDataFilter:

[legend]
Collaboration diagram for vtkWindowedSincPolyDataFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWindowedSincPolyDataFilter, vtkPolyDataToPolyDataFilter)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | SetNumberOfIterations (int)
virtual int | GetNumberOfIterations ()
virtual void | SetPassBand (float)
virtual float | GetPassBand ()
virtual void | SetFeatureEdgeSmoothing (int)
virtual int | GetFeatureEdgeSmoothing ()
virtual void | FeatureEdgeSmoothingOn ()
virtual void | FeatureEdgeSmoothingOff ()
virtual void | SetFeatureAngle (float)
virtual float | GetFeatureAngle ()
virtual void | SetEdgeAngle (float)
virtual float | GetEdgeAngle ()
virtual void | SetBoundarySmoothing (int)
virtual int | GetBoundarySmoothing ()
virtual void | BoundarySmoothingOn ()
virtual void | BoundarySmoothingOff ()
virtual void | SetGenerateErrorScalars (int)
virtual int | GetGenerateErrorScalars ()
virtual void | GenerateErrorScalarsOn ()
virtual void | GenerateErrorScalarsOff ()
virtual void | SetGenerateErrorVectors (int)
virtual int | GetGenerateErrorVectors ()
virtual void | GenerateErrorVectorsOn ()
virtual void | GenerateErrorVectorsOff ()

Static Public Methods

vtkWindowedSincPolyDataFilter * | New ()

Protected Methods

vtkWindowedSincPolyDataFilter ()
~vtkWindowedSincPolyDataFilter ()
void | Execute ()

Protected Attributes

int | NumberOfIterations
float | PassBand
int | FeatureEdgeSmoothing
float | FeatureAngle
float | EdgeAngle
int | BoundarySmoothing
int | GenerateErrorScalars
int | GenerateErrorVectors

Detailed Description

adjust point positions using a windowed sinc function interpolation kernel.

Date:
2002/01/22 15:29:57
Revision:
1.21

vtkWindowedSincPolyDataFiler adjust point coordinate using a windowed sinc function interpolation kernel. The effect is to "relax" the mesh, making the cells better shaped and the vertices more evenly distributed. Note that this filter operates the lines, polygons, and triangle strips composing an instance of vtkPolyData. Vertex or poly-vertex cells are never modified.

The algorithm proceeds as follows. For each vertex v, a topological and geometric analysis is performed to determine which vertices are connected to v, and which cells are connected to v. Then, a connectivity array is constructed for each vertex. (The connectivity array is a list of lists of vertices that directly attach to each vertex.) Next, an iteration phase begins over all vertices. For each vertex v, the coordinates of v are modified using a windowed sinc function interpolation kernel. Taubin describes this methodology is the IBM tech report RC-20404 (#90237, dated 3/12/96) "Optimal Surface Smoothing as Filter Design" G. Taubin, T. Zhang and G. Golub. (Zhang and Golub are at Stanford University).

This report discusses using standard signal processing low-pass filters (in particular windowed sinc functions) to smooth polyhedra. The transfer functions of the low-pass filters are approximated by Chebyshev polynomials. This facilitates applying the filters in an iterative diffusion process (as opposed to a kernel convolution). The more smoothing iterations applied, the higher the degree of polynomial approximating the low-pass filter transfer function. Each smoothing iteration, therefore, applies the next higher term of the Chebyshev filter approximation to the polyhedron. This decoupling of the filter into an iteratively applied polynomial is possible since the Chebyshev polynomials are orthogonal, i.e. increasing the order of the approximation to the filter transfer function does not alter the previously calculated coefficients for the low order terms.

Note: Care must be taken to avoid smoothing with too few iterations. A Chebyshev approximation with too few terms is an poor approximation. The first few smoothing iterations represent a severe scaling and translation of the data. Subsequent iterations cause the smoothed polyhedron to converge to the true location and scale of the object. We have attempted to protect against this by automatically adjusting the filter, effectively widening the pass band. This adjustment is only possible if the number of iterations is greater than 1. Note that this sacrifices some degree of smoothing for model integrity. For those interested, the filter is adjusted by searching for a value sigma such that the actual pass band is k_pb + sigma and such that the filter transfer function evaluates to unity at k_pb, i.e. f(k_pb) = 1

This implementation is currently limited to using an interpolation kernel based on Hamming windows. Other windows (such as Hann, Blackman, Kaiser, Lanczos, Gaussian, and exponential windows) could be used instead.

There are some special instance variables used to control the execution of this filter. (These ivars basically control what vertices can be smoothed, and the creation of the connectivity array.) The BoundarySmoothing ivar enables/disables the smoothing operation on vertices that are on the "boundary" of the mesh. A boundary vertex is one that is surrounded by a semi-cycle of polygons (or used by a single line).

Another important ivar is FeatureEdgeSmoothing. If this ivar is enabled, then interior vertices are classified as either "simple", "interior edge", or "fixed", and smoothed differently. (Interior vertices are manifold vertices surrounded by a cycle of polygons; or used by two line cells.) The classification is based on the number of feature edges attached to v. A feature edge occurs when the angle between the two surface normals of a polygon sharing an edge is greater than the FeatureAngle ivar. Then, vertices used by no feature edges are classified "simple", vertices used by exactly two feature edges are classified "interior edge", and all others are "fixed" vertices.

Once the classification is known, the vertices are smoothed differently. Corner (i.e., fixed) vertices are not smoothed at all. Simple vertices are smoothed as before . Interior edge vertices are smoothed only along their two connected edges, and only if the angle between the edges is less than the EdgeAngle ivar.

The total smoothing can be controlled by using two ivars. The NumberOfIterations determines the maximum number of smoothing passes. The NumberOfIterations corresponds to the degree of the polynomial that is used to approximate the windowed sinc function. Ten or twenty iterations is all the is usually necessary. Contrast this with vtkSmoothPolyDataFilter which usually requires 100 to 200 smoothing iterations. vtkSmoothPolyDataFilter is also not an approximation to an ideal low-pass filter, which can cause the geometry to shrink as the amount of smoothing increases.

The second ivar is the specification of the PassBand for the windowed sinc filter. By design, the PassBand is specified as a floating point number between 0 and 2. Lower PassBand values produce more smoothing. A good default value for the PassBand is 0.1 (for those interested, the PassBand (and frequencies) for PolyData are based on the valence of the vertices, this limits all the frequency modes in a polyhedral mesh to between 0 and 2.)

There are two instance variables that control the generation of error data. If the ivar GenerateErrorScalars is on, then a scalar value indicating the distance of each vertex from its original position is computed. If the ivar GenerateErrorVectors is on, then a vector representing change in position is computed.

Warning:
The smoothing operation reduces high frequency information in the geometry of the mesh. With excessive smoothing important details may be lost. Enabling FeatureEdgeSmoothing helps reduce this effect, but cannot entirely eliminate it.
See also:
vtkSmoothPolyDataFilter vtkDecimate vtkDecimatePro
Created by:
  • Miller, Jim
Contributed by (if > 5%):
  • Miller, Jim (74%)
  • Lorensen, Bill (9%)
  • Henderson, Amy (9%)
Tests:
vtkWindowedSincPolyDataFilter (Tests)

Definition at line 149 of file vtkWindowedSincPolyDataFilter.h.

Constructor & Destructor Documentation

vtkWindowedSincPolyDataFilter::vtkWindowedSincPolyDataFilter ( ) [protected]

vtkWindowedSincPolyDataFilter::~vtkWindowedSincPolyDataFilter ( ) [inline, protected]

Definition at line 218 of file vtkWindowedSincPolyDataFilter.h.

Member Function Documentation

vtkWindowedSincPolyDataFilter::vtkTypeRevisionMacro | ( | vtkWindowedSincPolyDataFilter | ,
 |  | vtkPolyDataToPolyDataFilter |
 | ) |

Reimplemented from vtkPolyDataToPolyDataFilter.

void vtkWindowedSincPolyDataFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

vtkWindowedSincPolyDataFilter* vtkWindowedSincPolyDataFilter::New ( ) [static]

Construct object with number of iterations 20; passband .1; feature edge smoothing turned off; feature angle 45 degrees; edge angle 15 degrees; and boundary smoothing turned on. Error scalars and vectors are not generated (by default). The convergence criterion is 0.0 of the bounding box diagonal.

Reimplemented from vtkPolyDataSource.

virtual void vtkWindowedSincPolyDataFilter::SetNumberOfIterations ( int ) [virtual]

Specify the number of iterations (or degree of the polynomial approximating the windowed sinc function).

virtual int vtkWindowedSincPolyDataFilter::GetNumberOfIterations ( ) [virtual]

Specify the number of iterations (or degree of the polynomial approximating the windowed sinc function).

virtual void vtkWindowedSincPolyDataFilter::SetPassBand ( float ) [virtual]

Set the passband value for the windowed sinc filter

virtual float vtkWindowedSincPolyDataFilter::GetPassBand ( ) [virtual]

Set the passband value for the windowed sinc filter

virtual void vtkWindowedSincPolyDataFilter::SetFeatureEdgeSmoothing ( int ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual int vtkWindowedSincPolyDataFilter::GetFeatureEdgeSmoothing ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkWindowedSincPolyDataFilter::FeatureEdgeSmoothingOn ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkWindowedSincPolyDataFilter::FeatureEdgeSmoothingOff ( ) [virtual]

Turn on/off smoothing along sharp interior edges.

virtual void vtkWindowedSincPolyDataFilter::SetFeatureAngle ( float ) [virtual]

Specify the feature angle for sharp edge identification.

virtual float vtkWindowedSincPolyDataFilter::GetFeatureAngle ( ) [virtual]

Specify the feature angle for sharp edge identification.

virtual void vtkWindowedSincPolyDataFilter::SetEdgeAngle ( float ) [virtual]

Specify the edge angle to control smoothing along edges (either interior or boundary).

virtual float vtkWindowedSincPolyDataFilter::GetEdgeAngle ( ) [virtual]

Specify the edge angle to control smoothing along edges (either interior or boundary).

virtual void vtkWindowedSincPolyDataFilter::SetBoundarySmoothing ( int ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual int vtkWindowedSincPolyDataFilter::GetBoundarySmoothing ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkWindowedSincPolyDataFilter::BoundarySmoothingOn ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkWindowedSincPolyDataFilter::BoundarySmoothingOff ( ) [virtual]

Turn on/off the smoothing of vertices on the boundary of the mesh.

virtual void vtkWindowedSincPolyDataFilter::SetGenerateErrorScalars ( int ) [virtual]

Turn on/off the generation of scalar distance values.

virtual int vtkWindowedSincPolyDataFilter::GetGenerateErrorScalars ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkWindowedSincPolyDataFilter::GenerateErrorScalarsOn ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkWindowedSincPolyDataFilter::GenerateErrorScalarsOff ( ) [virtual]

Turn on/off the generation of scalar distance values.

virtual void vtkWindowedSincPolyDataFilter::SetGenerateErrorVectors ( int ) [virtual]

Turn on/off the generation of error vectors.

virtual int vtkWindowedSincPolyDataFilter::GetGenerateErrorVectors ( ) [virtual]

Turn on/off the generation of error vectors.

virtual void vtkWindowedSincPolyDataFilter::GenerateErrorVectorsOn ( ) [virtual]

Turn on/off the generation of error vectors.

virtual void vtkWindowedSincPolyDataFilter::GenerateErrorVectorsOff ( ) [virtual]

Turn on/off the generation of error vectors.

void vtkWindowedSincPolyDataFilter::Execute ( ) [protected, virtual]

This method is the old style execute method

Reimplemented from vtkSource.

Member Data Documentation

int vtkWindowedSincPolyDataFilter::NumberOfIterations [protected]

Definition at line 222 of file vtkWindowedSincPolyDataFilter.h.

float vtkWindowedSincPolyDataFilter::PassBand [protected]

Definition at line 223 of file vtkWindowedSincPolyDataFilter.h.

int vtkWindowedSincPolyDataFilter::FeatureEdgeSmoothing [protected]

Definition at line 224 of file vtkWindowedSincPolyDataFilter.h.

float vtkWindowedSincPolyDataFilter::FeatureAngle [protected]

Definition at line 225 of file vtkWindowedSincPolyDataFilter.h.

float vtkWindowedSincPolyDataFilter::EdgeAngle [protected]

Definition at line 226 of file vtkWindowedSincPolyDataFilter.h.

int vtkWindowedSincPolyDataFilter::BoundarySmoothing [protected]

Definition at line 227 of file vtkWindowedSincPolyDataFilter.h.

int vtkWindowedSincPolyDataFilter::GenerateErrorScalars [protected]

Definition at line 228 of file vtkWindowedSincPolyDataFilter.h.

int vtkWindowedSincPolyDataFilter::GenerateErrorVectors [protected]

Definition at line 229 of file vtkWindowedSincPolyDataFilter.h.

The documentation for this class was generated from the following file:
  • Graphics/vtkWindowedSincPolyDataFilter.h
Generated on Mon Mar 25 01:36:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowLevelLookupTable Class Reference

map scalar values into colors or colors to scalars; generate color table. More...

#include <vtkWindowLevelLookupTable.h>

Inheritance diagram for vtkWindowLevelLookupTable:

[legend]
Collaboration diagram for vtkWindowLevelLookupTable:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWindowLevelLookupTable, vtkLookupTable)
void | PrintSelf (ostream &os, vtkIndent indent)
void | Build ()
void | SetWindow (float window)
virtual float | GetWindow ()
void | SetLevel (float level)
virtual float | GetLevel ()
void | SetInverseVideo (int iv)
virtual int | GetInverseVideo ()
virtual void | InverseVideoOn ()
virtual void | InverseVideoOff ()
virtual void | SetMinimumTableValue (float, float, float, float)
virtual void | SetMinimumTableValue (float[4])
virtual float * | GetMinimumTableValue ()
virtual void | GetMinimumTableValue (float &, float &, float &, float &)
virtual void | GetMinimumTableValue (float[4])
virtual void | SetMaximumTableValue (float, float, float, float)
virtual void | SetMaximumTableValue (float[4])
virtual float * | GetMaximumTableValue ()
virtual void | GetMaximumTableValue (float &, float &, float &, float &)
virtual void | GetMaximumTableValue (float[4])
void | SetMinimumColor (int r, int g, int b, int a)
void | SetMinimumColor (const unsigned char rgba[4])
void | GetMinimumColor (unsigned char rgba[4])
unsigned char * | GetMinimumColor ()
void | SetMaximumColor (int r, int g, int b, int a)
void | SetMaximumColor (const unsigned char rgba[4])
void | GetMaximumColor (unsigned char rgba[4])
unsigned char * | GetMaximumColor ()

Static Public Methods

vtkWindowLevelLookupTable * | New ()

Protected Methods

vtkWindowLevelLookupTable (int sze=256, int ext=256)
~vtkWindowLevelLookupTable ()

Protected Attributes

float | Window
float | Level
int | InverseVideo
float | MaximumTableValue [4]
float | MinimumTableValue [4]
unsigned char | MinimumColor [4]
unsigned char | MaximumColor [4]

Detailed Description

map scalar values into colors or colors to scalars; generate color table.

Date:
2002/01/22 15:26:47
Revision:
1.30

vtkWindowLevelLookupTable is an object that is used by mapper objects to map scalar values into rgba (red-green-blue-alpha transparency) color specification, or rgba into scalar values. The color table can be created by direct insertion of color values, or by specifying a window and level. Window / Level is used in medical imaging to specify a linear greyscale ramp. The Level is the center of the ramp. The Window is the width of the ramp.

Warning:
vtkWindowLevelLookupTable is a reference counted object. Therefore, you should always use operator "new" to construct new objects. This procedure will avoid memory problems (see text).
See also:
vtkLogLookupTable
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (49%)
  • Gobbi, David (38%)

Definition at line 52 of file vtkWindowLevelLookupTable.h.

Constructor & Destructor Documentation

vtkWindowLevelLookupTable::vtkWindowLevelLookupTable | ( | int | sze = 256,
 |  | int | ext = 256
 | ) | [protected]

vtkWindowLevelLookupTable::~vtkWindowLevelLookupTable ( ) [inline, protected]

Definition at line 144 of file vtkWindowLevelLookupTable.h.

Member Function Documentation

vtkWindowLevelLookupTable* vtkWindowLevelLookupTable::New ( ) [static]

Construct with range=[0,1]; and hsv ranges set up for rainbow color table (from red to blue).

Reimplemented from vtkLookupTable.

vtkWindowLevelLookupTable::vtkTypeRevisionMacro | ( | vtkWindowLevelLookupTable | ,
 |  | vtkLookupTable |
 | ) |

Reimplemented from vtkLookupTable.

void vtkWindowLevelLookupTable::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkLookupTable.

void vtkWindowLevelLookupTable::Build ( ) [virtual]

Generate lookup table as a linear ramp between MinimumTableValue and MaximumTableValue.

Reimplemented from vtkLookupTable.

void vtkWindowLevelLookupTable::SetWindow ( float window ) [inline]

Set the window for the lookup table. The window is the difference between TableRange[0] and TableRange[1].

Definition at line 66 of file vtkWindowLevelLookupTable.h.

virtual float vtkWindowLevelLookupTable::GetWindow ( ) [virtual]

Set the window for the lookup table. The window is the difference between TableRange[0] and TableRange[1].

void vtkWindowLevelLookupTable::SetLevel ( float level ) [inline]

Set the Level for the lookup table. The level is the average of TableRange[0] and TableRange[1].

Definition at line 77 of file vtkWindowLevelLookupTable.h.

virtual float vtkWindowLevelLookupTable::GetLevel ( ) [virtual]

Set the Level for the lookup table. The level is the average of TableRange[0] and TableRange[1].

void vtkWindowLevelLookupTable::SetInverseVideo ( int iv )

Set inverse video on or off. You can achieve the same effect by switching the MinimumTableValue and the MaximumTableValue.

virtual int vtkWindowLevelLookupTable::GetInverseVideo ( ) [virtual]

Set inverse video on or off. You can achieve the same effect by switching the MinimumTableValue and the MaximumTableValue.

virtual void vtkWindowLevelLookupTable::InverseVideoOn ( ) [virtual]

Set inverse video on or off. You can achieve the same effect by switching the MinimumTableValue and the MaximumTableValue.

virtual void vtkWindowLevelLookupTable::InverseVideoOff ( ) [virtual]

Set inverse video on or off. You can achieve the same effect by switching the MinimumTableValue and the MaximumTableValue.

virtual void vtkWindowLevelLookupTable::SetMinimumTableValue | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the minimum table value. All lookup table entries below the start of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::SetMinimumTableValue ( float [4] ) [virtual]

Set the minimum table value. All lookup table entries below the start of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual float* vtkWindowLevelLookupTable::GetMinimumTableValue ( ) [virtual]

Set the minimum table value. All lookup table entries below the start of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::GetMinimumTableValue | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the minimum table value. All lookup table entries below the start of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::GetMinimumTableValue ( float [4] ) [virtual]

Set the minimum table value. All lookup table entries below the start of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::SetMaximumTableValue | ( | float | ,
 |  | float | ,
 |  | float | ,
 |  | float |
 | ) | [virtual]

Set the maximum table value. All lookup table entries above the end of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::SetMaximumTableValue ( float [4] ) [virtual]

Set the maximum table value. All lookup table entries above the end of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual float* vtkWindowLevelLookupTable::GetMaximumTableValue ( ) [virtual]

Set the maximum table value. All lookup table entries above the end of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::GetMaximumTableValue | ( | float & | ,
 |  | float & | ,
 |  | float & | ,
 |  | float & |
 | ) | [virtual]

Set the maximum table value. All lookup table entries above the end of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

virtual void vtkWindowLevelLookupTable::GetMaximumTableValue ( float [4] ) [virtual]

Set the maximum table value. All lookup table entries above the end of the ramp will be set to this color. After you change this value, you must re-build the lookup table.

void vtkWindowLevelLookupTable::SetMinimumColor | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | a
 | ) | [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMinimumTableValue() instead.

Definition at line 111 of file vtkWindowLevelLookupTable.h.

void vtkWindowLevelLookupTable::SetMinimumColor ( const unsigned char rgba[4] ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMinimumTableValue() instead.

Definition at line 113 of file vtkWindowLevelLookupTable.h.

void vtkWindowLevelLookupTable::GetMinimumColor ( unsigned char rgba[4] ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMinimumTableValue() instead.

Definition at line 115 of file vtkWindowLevelLookupTable.h.

unsigned char* vtkWindowLevelLookupTable::GetMinimumColor ( ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMinimumTableValue() instead.

Definition at line 120 of file vtkWindowLevelLookupTable.h.

void vtkWindowLevelLookupTable::SetMaximumColor | ( | int | r,
 |  | int | g,
 |  | int | b,
 |  | int | a
 | ) | [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMaximumTableValue() instead.

Definition at line 128 of file vtkWindowLevelLookupTable.h.

void vtkWindowLevelLookupTable::SetMaximumColor ( const unsigned char rgba[4] ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMaximumTableValue() instead.

Definition at line 130 of file vtkWindowLevelLookupTable.h.

void vtkWindowLevelLookupTable::GetMaximumColor ( unsigned char rgba[4] ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMaximumTableValue() instead.

Definition at line 132 of file vtkWindowLevelLookupTable.h.

unsigned char* vtkWindowLevelLookupTable::GetMaximumColor ( ) [inline]

For backwards compatibility: specify the color using integers in the range [0,255]. Deprecated: use SetMaximumTableValue() instead.

Definition at line 137 of file vtkWindowLevelLookupTable.h.

Member Data Documentation

float vtkWindowLevelLookupTable::Window [protected]

Definition at line 146 of file vtkWindowLevelLookupTable.h.

float vtkWindowLevelLookupTable::Level [protected]

Definition at line 147 of file vtkWindowLevelLookupTable.h.

int vtkWindowLevelLookupTable::InverseVideo [protected]

Definition at line 148 of file vtkWindowLevelLookupTable.h.

float vtkWindowLevelLookupTable::MaximumTableValue[4] [protected]

Definition at line 149 of file vtkWindowLevelLookupTable.h.

float vtkWindowLevelLookupTable::MinimumTableValue[4] [protected]

Definition at line 150 of file vtkWindowLevelLookupTable.h.

unsigned char vtkWindowLevelLookupTable::MinimumColor[4] [protected]

Definition at line 151 of file vtkWindowLevelLookupTable.h.

unsigned char vtkWindowLevelLookupTable::MaximumColor[4] [protected]

Definition at line 152 of file vtkWindowLevelLookupTable.h.

The documentation for this class was generated from the following file:
  • Common/vtkWindowLevelLookupTable.h
Generated on Mon Mar 25 01:36:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWindowToImageFilter Class Reference

Use a vtkWindow as input to image pipeline. More...

#include <vtkWindowToImageFilter.h>

Inheritance diagram for vtkWindowToImageFilter:

[legend]
Collaboration diagram for vtkWindowToImageFilter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWindowToImageFilter, vtkImageSource)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetInput (vtkWindow *input)
virtual vtkWindow * | GetInput ()
virtual void | SetMagnification (int)
virtual int | GetMagnification ()
virtual void | ReadFrontBufferOn ()
virtual void | ReadFrontBufferOff ()
virtual int | GetReadFrontBuffer ()
virtual void | SetReadFrontBuffer (int)

Static Public Methods

vtkWindowToImageFilter * | New ()

Protected Methods

vtkWindowToImageFilter ()
~vtkWindowToImageFilter ()
void | ExecuteInformation ()
void | ExecuteData (vtkDataObject *data)

Protected Attributes

vtkWindow * Input
int | Magnification
int | ReadFrontBuffer

Detailed Description

Use a vtkWindow as input to image pipeline.

Date:
2002/03/19 16:19:45
Revision:
1.7

vtkWindowToImageFilter provides methods needed to read the data in a vtkWindow and use it as input to the imaging pipeline. This is useful for saving an image to a file for example. Use this filter to convert RenderWindows or ImageWindows to an image format.

Warning:
A vtkWindow doesn't behave like other parts of the VTK pipeline: its modification time doesn't get updated when an image is rendered. As a result, naive use of vtkWindowToImageFilter will produce an image of the first image that the window rendered, but which is never updated on subsequent window updates. This behavior is unexpected and in general undesirable.
Warning:
To force an update of the output image, call vtkWindowToImageFilter's Modified method after rendering to the window.
Warning:
In VTK versions 4 and later, this filter is part of the canonical way to output an image of a window to a file (replacing the obsolete SaveImageAsPPM method for vtkRenderWindows that existed in 3.2 and earlier). Connect this filter to the output of the window, and filter's output to a writer such as vtkPNGWriter.
See also:
vtkWindow
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (84%)
Examples:
vtkWindowToImageFilter (Examples)
Tests:
vtkWindowToImageFilter (Tests)

Definition at line 69 of file vtkWindowToImageFilter.h.

Constructor & Destructor Documentation

vtkWindowToImageFilter::vtkWindowToImageFilter ( ) [protected]

vtkWindowToImageFilter::~vtkWindowToImageFilter ( ) [protected]

Member Function Documentation

vtkWindowToImageFilter* vtkWindowToImageFilter::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageSource.

vtkWindowToImageFilter::vtkTypeRevisionMacro | ( | vtkWindowToImageFilter | ,
 |  | vtkImageSource |
 | ) |

Reimplemented from vtkImageSource.

void vtkWindowToImageFilter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkSource.

void vtkWindowToImageFilter::SetInput ( vtkWindow * input )

Indicates what renderer to get the pixel data from.

virtual vtkWindow* vtkWindowToImageFilter::GetInput ( ) [virtual]

Returns which renderer is being used as the source for the pixel data.

virtual void vtkWindowToImageFilter::SetMagnification ( int ) [virtual]

The magnification of the current render window

virtual int vtkWindowToImageFilter::GetMagnification ( ) [virtual]

The magnification of the current render window

virtual void vtkWindowToImageFilter::ReadFrontBufferOn ( ) [virtual]

The magnification of the current render window

virtual void vtkWindowToImageFilter::ReadFrontBufferOff ( ) [virtual]

The magnification of the current render window

virtual int vtkWindowToImageFilter::GetReadFrontBuffer ( ) [virtual]

The magnification of the current render window

virtual void vtkWindowToImageFilter::SetReadFrontBuffer ( int ) [virtual]

The magnification of the current render window

void vtkWindowToImageFilter::ExecuteInformation ( ) [protected, virtual]

Reimplemented from vtkSource.

void vtkWindowToImageFilter::ExecuteData ( vtkDataObject * data ) [protected]

Member Data Documentation

vtkWindow* vtkWindowToImageFilter::Input [protected]

Definition at line 103 of file vtkWindowToImageFilter.h.

int vtkWindowToImageFilter::Magnification [protected]

Definition at line 104 of file vtkWindowToImageFilter.h.

int vtkWindowToImageFilter::ReadFrontBuffer [protected]

Definition at line 105 of file vtkWindowToImageFilter.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWindowToImageFilter.h
Generated on Mon Mar 25 01:36:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWorldPointPicker Class Reference

find world x,y,z corresponding to display x,y,z. More...

#include <vtkWorldPointPicker.h>

Inheritance diagram for vtkWorldPointPicker:

[legend]
Collaboration diagram for vtkWorldPointPicker:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWorldPointPicker, vtkAbstractPicker)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Pick (float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)
int | Pick (float selectionPt[3], vtkRenderer *renderer)

Static Public Methods

vtkWorldPointPicker * | New ()

Protected Methods

vtkWorldPointPicker ()
~vtkWorldPointPicker ()

Detailed Description

find world x,y,z corresponding to display x,y,z.

Date:
2002/01/22 15:39:52
Revision:
1.22

vtkWorldPointPicker is used to find the x,y,z world coordinate of a screen x,y,z. This picker cannot pick actors and/or mappers, it simply determines an x-y-z coordinate in world space. (It will always return a x-y-z, even if the selection point is not over a prop/actor.)

Warning:
The PickMethod() is not invoked, but StartPickMethod() and EndPickMethod() are.
See also:
vtkPropPicker vtkPicker vtkCellPicker vtkPointPicker
Events:
vtkCommand::EndPickEvent vtkCommand::StartPickEvent
Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (65%)
  • Schroeder, Will (27%)
  • Martin, Ken (6%)
Tests:
vtkWorldPointPicker (Tests)

Definition at line 54 of file vtkWorldPointPicker.h.

Constructor & Destructor Documentation

vtkWorldPointPicker::vtkWorldPointPicker ( ) [protected]

vtkWorldPointPicker::~vtkWorldPointPicker ( ) [inline, protected]

Definition at line 71 of file vtkWorldPointPicker.h.

Member Function Documentation

vtkWorldPointPicker* vtkWorldPointPicker::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

vtkWorldPointPicker::vtkTypeRevisionMacro | ( | vtkWorldPointPicker | ,
 |  | vtkAbstractPicker |
 | ) |

Reimplemented from vtkAbstractPicker.

void vtkWorldPointPicker::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkAbstractPicker.

int vtkWorldPointPicker::Pick | ( | float | selectionX,
 |  | float | selectionY,
 |  | float | selectionZ,
 |  | vtkRenderer * | renderer
 | ) | [virtual]

Perform the pick. (This method overload's the superclass.)

Reimplemented from vtkAbstractPicker.

int vtkWorldPointPicker::Pick | ( | float | selectionPt[3],
 |  | vtkRenderer * | renderer
 | ) | [inline]

Perform the pick. (This method overload's the superclass.)

Reimplemented from vtkAbstractPicker.

Definition at line 65 of file vtkWorldPointPicker.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkWorldPointPicker.h
Generated on Mon Mar 25 01:36:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkWriter Class Reference

abstract class to write data to file(s). More...

#include <vtkWriter.h>

Inheritance diagram for vtkWriter:

[legend]
Collaboration diagram for vtkWriter:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkWriter, vtkProcessObject)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Write ()
void | Update ()
void | EncodeArrayName (char *resname, const char *name)
vtkDataObject * GetInput ()

Protected Methods

vtkWriter ()
~vtkWriter ()
virtual void | WriteData ()=0

Protected Attributes

vtkTimeStamp WriteTime

Detailed Description

abstract class to write data to file(s).

Date:
2002/03/13 02:20:12
Revision:
1.45

vtkWriter is an abstract class for mapper objects that write their data to disk (or into a communications port). All writers respond to Write() method. This method insures that there is input and input is up to date.

Since vtkWriter is a subclass of vtkProcessObject, StartMethod(), EndMethod(), and ProgressMethod() are all available to writers. These methods are executed before and after execution of the Write() method. You can also specify arguments to these methods.

Warning:
Every subclass of vtkWriter must implement a WriteData() method. Most likely will have to create SetInput() method as well.
See also:
vtkBYUWriter vtkDataWriter vtkSTLWriter vtkVoxelWriter vtkMCubesWriter
Events:
vtkCommand::StartEvent vtkCommand::EndEvent
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (53%)
  • Martin, Ken (14%)
  • Cedilnik, Andy (12%)
  • Lorensen, Bill (7%)
  • Biddiscombe, John (5%)

Definition at line 61 of file vtkWriter.h.

Constructor & Destructor Documentation

vtkWriter::vtkWriter ( ) [protected]

vtkWriter::~vtkWriter ( ) [protected]

Member Function Documentation

vtkWriter::vtkTypeRevisionMacro | ( | vtkWriter | ,
 |  | vtkProcessObject |
 | ) |

Reimplemented from vtkProcessObject.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataObjectWriter, vtkDataSetWriter, vtkDataWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkSTLWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, vtkUnstructuredGridWriter, and vtkPDataSetWriter.

void vtkWriter::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkProcessObject.

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataObjectWriter, vtkDataSetWriter, vtkDataWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, vtkUnstructuredGridWriter, and vtkPDataSetWriter.

virtual void vtkWriter::Write ( ) [virtual]

Write data to output. Method executes subclasses WriteData() method, as well as StartMethod() and EndMethod() methods.

Reimplemented in vtkPDataSetWriter.

void vtkWriter::Update ( )

Convenient alias for Write() method.

void vtkWriter::EncodeArrayName | ( | char * | resname,
 |  | const char * | name
 | ) |

Encode the name so that the reader will not have problems. The resulting string is up to four time the size of the input string.

vtkDataObject* vtkWriter::GetInput ( )

Reimplemented in vtkDataObjectWriter, vtkDataSetWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, and vtkUnstructuredGridWriter.

virtual void vtkWriter::WriteData ( ) [protected, pure virtual]

Reimplemented in vtkBYUWriter, vtkCGMWriter, vtkDataObjectWriter, vtkDataSetWriter, vtkDataWriter, vtkIVWriter, vtkMCubesWriter, vtkPLYWriter, vtkPolyDataWriter, vtkRectilinearGridWriter, vtkSTLWriter, vtkStructuredGridWriter, vtkStructuredPointsWriter, and vtkUnstructuredGridWriter.

Member Data Documentation

vtkTimeStamp vtkWriter::WriteTime [protected]

Definition at line 86 of file vtkWriter.h.

The documentation for this class was generated from the following file:
  • IO/vtkWriter.h
Generated on Mon Mar 25 01:36:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXImageMapper Class Reference

2D image display support for X windows. More...

#include <vtkXImageMapper.h>

Inheritance diagram for vtkXImageMapper:

[legend]
Collaboration diagram for vtkXImageMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXImageMapper, vtkImageMapper)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RenderData (vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor)
int | GetXWindowDepth (vtkWindow *window)
void | GetXWindowVisualId (vtkWindow *window, Visual *visualID)
int | GetXWindowVisualClass (vtkWindow *window)
void | GetXColors (int colors[])
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)
void | GetXWindowColorMasks (vtkWindow *window, unsigned long *rmask, unsigned long *gmask, unsigned long *bmask)
virtual int | GetNumberOfColors ()

Static Public Methods

vtkXImageMapper * | New ()

Protected Methods

vtkXImageMapper ()
~vtkXImageMapper ()

Protected Attributes

XImage * | Image
unsigned char * | DataOut
int | DataOutSize
int | NumberOfColors

Detailed Description

2D image display support for X windows.

Date:
2002/01/22 15:39:53
Revision:
1.24

vtkXImageMapper is a concrete subclass of vtkImageMapper that renders images under X windows.

See also:
vtkImageMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (70%)
  • Law, Charles (10%)
  • Schroeder, Will (8%)
  • Miller, Jim (8%)

Definition at line 54 of file vtkXImageMapper.h.

Constructor & Destructor Documentation

vtkXImageMapper::vtkXImageMapper ( ) [protected]

vtkXImageMapper::~vtkXImageMapper ( ) [protected]

Member Function Documentation

vtkXImageMapper* vtkXImageMapper::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkImageMapper.

vtkXImageMapper::vtkTypeRevisionMacro | ( | vtkXImageMapper | ,
 |  | vtkImageMapper |
 | ) |

Reimplemented from vtkImageMapper.

void vtkXImageMapper::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageMapper.

void vtkXImageMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Handle the render method.

Reimplemented from vtkMapper2D.

Definition at line 64 of file vtkXImageMapper.h.

void vtkXImageMapper::RenderData | ( | vtkViewport * | viewport,
 |  | vtkImageData * | data,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Called by the Render function in vtkImageMapper. Actually draws the image to the screen.

Reimplemented from vtkImageMapper.

int vtkXImageMapper::GetXWindowDepth ( vtkWindow * window )

Returns the depth of the X window

void vtkXImageMapper::GetXWindowVisualId | ( | vtkWindow * | window,
 |  | Visual * | visualID
 | ) |

Returns the visual id of the window

int vtkXImageMapper::GetXWindowVisualClass ( vtkWindow * window )

Returns the visual class of the window

void vtkXImageMapper::GetXColors ( int colors[] )

Returns a pseudo color mapping from 0 255 to 50 199

void vtkXImageMapper::GetXWindowColorMasks | ( | vtkWindow * | window,
 |  | unsigned long * | rmask,
 |  | unsigned long * | gmask,
 |  | unsigned long * | bmask
 | ) |

Returns the color masks used by the window.

virtual int vtkXImageMapper::GetNumberOfColors ( ) [virtual]

Gets the number of colors in the pseudo color map.

Member Data Documentation

XImage* vtkXImageMapper::Image [protected]

Definition at line 99 of file vtkXImageMapper.h.

unsigned char* vtkXImageMapper::DataOut [protected]

Definition at line 100 of file vtkXImageMapper.h.

int vtkXImageMapper::DataOutSize [protected]

Definition at line 101 of file vtkXImageMapper.h.

int vtkXImageMapper::NumberOfColors [protected]

Definition at line 102 of file vtkXImageMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXImageMapper.h
Generated on Mon Mar 25 01:36:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXImageWindow Class Reference

2D display window for X. More...

#include <vtkXImageWindow.h>

Inheritance diagram for vtkXImageWindow:

[legend]
Collaboration diagram for vtkXImageWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXImageWindow, vtkImageWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
void | SetWindowName (char *name)
void | SwapBuffers ()
void | Frame ()
virtual int | GetDesiredDepth ()
virtual Colormap | GetDesiredColormap ()
virtual Visual * | GetDesiredVisual ()
Visual * | GetVisualId ()
void | SetBackgroundColor (float r, float g, float b)
void | EraseWindow ()
unsigned char * | GetPixelData (int x1, int y1, int x2, int y2, int)
void | SetWindowInfo (char *info)
void | SetParentInfo (char *info)
virtual int | GetNumberOfColors ()
virtual int | GetVisualDepth ()
virtual int | GetVisualClass ()
Window | GetParentId ()
void | SetParentId (Window)
void | SetParentId (void *)
void | SetDisplayId (Display *)
void | SetDisplayId (void *)
void | SetWindowId (Window)
void | SetWindowId (void *)
Window | GetWindowId ()
Display * | GetDisplayId ()
GC | GetGC ()
int * | GetPosition ()
void | GetPosition (int *x, int *y)
void | SetPosition (int, int)
void | SetPosition (int a[2])
int * | GetSize ()
void | GetSize (int *x, int *y)
void | SetSize (int x, int y)
void | SetSize (int a[2])
void * | GetGenericDisplayId ()
void * | GetGenericWindowId ()
void * | GetGenericParentId ()
void * | GetGenericContext ()
void * | GetGenericDrawable ()

Static Public Methods

vtkXImageWindow * | New ()

Protected Methods

vtkXImageWindow ()
~vtkXImageWindow ()
void | MakeDefaultWindow ()
void | GetDefaultVisualInfo (XVisualInfo *info)
Colormap | MakeColorMap (Visual *visual)
void | AllocateDirectColorMap ()
void | GetShiftsScalesAndMasks (int &rshift, int &gshift, int &bshift, int &rscale, int &gscale, int &bscale, unsigned long &rmask, unsigned long &gmask, unsigned long &bmask)

Protected Attributes

Window | ParentId
Window | WindowId
Display * | DisplayId
Visual * | VisualId
int | VisualDepth
int | VisualClass
Colormap | ColorMap
GC | Gc
int | Offset
XColor | Colors [256]
int | NumberOfColors
Pixmap | Drawable
int | OwnDisplay
int | PixmapWidth
int | PixmapHeight

Detailed Description

2D display window for X.

Date:
2002/01/22 15:39:54
Revision:
1.29

vtkXImageWindow is a concrete subclass of vtkImageWindow to support 2D rendering in vtk.

See also:
vtkImageWindow
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (61%)
  • Lorensen, Bill (12%)
  • Schroeder, Will (6%)

Definition at line 48 of file vtkXImageWindow.h.

Constructor & Destructor Documentation

vtkXImageWindow::vtkXImageWindow ( ) [protected]

vtkXImageWindow::~vtkXImageWindow ( ) [protected]

Member Function Documentation

vtkXImageWindow* vtkXImageWindow::New ( ) [static]

Creates a vtkImageWindow with background erasing disabled and gray scale hint off

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

vtkXImageWindow::vtkTypeRevisionMacro | ( | vtkXImageWindow | ,
 |  | vtkImageWindow |
 | ) |

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::SetWindowName ( char * name ) [virtual]

Implements SetWindowName for a X window

Reimplemented from vtkWindow.

virtual int vtkXImageWindow::GetNumberOfColors ( ) [virtual]

Gets the number of colors in the pseudo color map.

virtual int vtkXImageWindow::GetVisualDepth ( ) [virtual]

Gets the windows depth. For the templated function.

virtual int vtkXImageWindow::GetVisualClass ( ) [virtual]

Gets the windows visual class. For the templated function.

Window vtkXImageWindow::GetParentId ( )

These are here for using a tk window.

void vtkXImageWindow::SetParentId ( Window )

These are here for using a tk window.

void vtkXImageWindow::SetParentId ( void * foo ) [virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::SetDisplayId ( Display * )

These are here for using a tk window.

void vtkXImageWindow::SetDisplayId ( void * foo ) [virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::SetWindowId ( Window )

These are here for using a tk window.

void vtkXImageWindow::SetWindowId ( void * foo ) [virtual]

These are here for using a tk window.

Reimplemented from vtkImageWindow.

Window vtkXImageWindow::GetWindowId ( )

These are here for using a tk window.

Display* vtkXImageWindow::GetDisplayId ( )

These are here for using a tk window.

GC vtkXImageWindow::GetGC ( )

These are here for using a tk window.

int* vtkXImageWindow::GetPosition ( ) [virtual]

Set/Get the position of the window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::GetPosition | ( | int * | x,
 |  | int * | y
 | ) | [inline, virtual]

Set/Get the position of the window.

Reimplemented from vtkImageWindow.

Definition at line 90 of file vtkXImageWindow.h.

void vtkXImageWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the position of the window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::SetPosition ( int a[2] ) [inline, virtual]

Set/Get the position of the window.

Reimplemented from vtkImageWindow.

Definition at line 92 of file vtkXImageWindow.h.

int* vtkXImageWindow::GetSize ( ) [virtual]

Set/Get the size of the window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::GetSize | ( | int * | x,
 |  | int * | y
 | ) | [inline, virtual]

Set/Get the size of the window.

Reimplemented from vtkImageWindow.

Definition at line 98 of file vtkXImageWindow.h.

void vtkXImageWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Set/Get the size of the window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::SetSize ( int a[2] ) [inline, virtual]

Set/Get the size of the window.

Reimplemented from vtkImageWindow.

Definition at line 100 of file vtkXImageWindow.h.

void* vtkXImageWindow::GetGenericDisplayId ( ) [inline, virtual]

The GetGenericXXX functions are necessary to draw into a VTKWindow.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

Definition at line 105 of file vtkXImageWindow.h.

void* vtkXImageWindow::GetGenericWindowId ( ) [inline, virtual]

The GetGenericXXX functions are necessary to draw into a VTKWindow.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

Definition at line 106 of file vtkXImageWindow.h.

void* vtkXImageWindow::GetGenericParentId ( ) [inline, virtual]

The GetGenericXXX functions are necessary to draw into a VTKWindow.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

Definition at line 107 of file vtkXImageWindow.h.

void* vtkXImageWindow::GetGenericContext ( ) [inline, virtual]

The GetGenericXXX functions are necessary to draw into a VTKWindow.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

Definition at line 108 of file vtkXImageWindow.h.

void* vtkXImageWindow::GetGenericDrawable ( ) [virtual]

The GetGenericXXX functions are necessary to draw into a VTKWindow.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::SwapBuffers ( ) [virtual]

Swaps the 2D drawing buffers. The user should not need to use this call. To invoke double buffering, call DoubleBufferOn

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::Frame ( void ) [virtual]

Flush the buffer and swap buffers if necessary.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

virtual int vtkXImageWindow::GetDesiredDepth ( ) [virtual]

Determine the desired depth of the window.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

virtual Colormap vtkXImageWindow::GetDesiredColormap ( ) [virtual]

Determine the desired colormap of the window.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

virtual Visual* vtkXImageWindow::GetDesiredVisual ( ) [virtual]

Determine the desired visual for the window

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

Visual* vtkXImageWindow::GetVisualId ( ) [inline]

Return the id of the visual we are using

Definition at line 129 of file vtkXImageWindow.h.

void vtkXImageWindow::SetBackgroundColor | ( | float | r,
 |  | float | g,
 |  | float | b
 | ) |

Set the background color of the window.

void vtkXImageWindow::EraseWindow ( ) [virtual]

Erase the contents of the window.

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

unsigned char* vtkXImageWindow::GetPixelData | ( | int | x,
 |  | int | y,
 |  | int | x2,
 |  | int | y2,
 |  | int | front
 | ) | [virtual]

Get the pixel data of an image, transmitted as RGBRGBRGB. It is the caller's responsibility to delete the resulting array. It is very important to realize that the memory in this array is organized from the bottom of the window to the top. The origin of the screen is in the lower left corner. The y axis increases as you go up the screen. So the storage of pixels is from left to right and from bottom to top. To maintain the same prototype as in vtkRenderWindow, the last argument is provided, but currently not used.

Reimplemented from vtkWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::SetWindowInfo ( char * info ) [virtual]

Set this ImageWindow's X window id to a pre-existing window.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::SetParentInfo ( char * info ) [virtual]

Sets the X window id of the window that WILL BE created.

Reimplemented from vtkImageWindow.

void vtkXImageWindow::MakeDefaultWindow ( ) [protected, virtual]

Reimplemented from vtkImageWindow.

Reimplemented in vtkMesaImageWindow, and vtkOpenGLImageWindow.

void vtkXImageWindow::GetDefaultVisualInfo ( XVisualInfo * info ) [protected]

Colormap vtkXImageWindow::MakeColorMap ( Visual * visual ) [protected]

void vtkXImageWindow::AllocateDirectColorMap ( ) [protected]

void vtkXImageWindow::GetShiftsScalesAndMasks | ( | int & | rshift,
 |  | int & | gshift,
 |  | int & | bshift,
 |  | int & | rscale,
 |  | int & | gscale,
 |  | int & | bscale,
 |  | unsigned long & | rmask,
 |  | unsigned long & | gmask,
 |  | unsigned long & | bmask
 | ) | [protected]

Member Data Documentation

Window vtkXImageWindow::ParentId [protected]

Definition at line 158 of file vtkXImageWindow.h.

Window vtkXImageWindow::WindowId [protected]

Definition at line 159 of file vtkXImageWindow.h.

Display* vtkXImageWindow::DisplayId [protected]

Definition at line 160 of file vtkXImageWindow.h.

Visual* vtkXImageWindow::VisualId [protected]

Definition at line 161 of file vtkXImageWindow.h.

int vtkXImageWindow::VisualDepth [protected]

Definition at line 162 of file vtkXImageWindow.h.

int vtkXImageWindow::VisualClass [protected]

Definition at line 163 of file vtkXImageWindow.h.

Colormap vtkXImageWindow::ColorMap [protected]

Definition at line 164 of file vtkXImageWindow.h.

GC vtkXImageWindow::Gc [protected]

Definition at line 165 of file vtkXImageWindow.h.

int vtkXImageWindow::Offset [protected]

Definition at line 166 of file vtkXImageWindow.h.

XColor vtkXImageWindow::Colors[256] [protected]

Definition at line 167 of file vtkXImageWindow.h.

int vtkXImageWindow::NumberOfColors [protected]

Definition at line 168 of file vtkXImageWindow.h.

Pixmap vtkXImageWindow::Drawable [protected]

Definition at line 169 of file vtkXImageWindow.h.

int vtkXImageWindow::OwnDisplay [protected]

Definition at line 170 of file vtkXImageWindow.h.

int vtkXImageWindow::PixmapWidth [protected]

Definition at line 171 of file vtkXImageWindow.h.

int vtkXImageWindow::PixmapHeight [protected]

Definition at line 172 of file vtkXImageWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXImageWindow.h
Generated on Mon Mar 25 01:36:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMesaRenderWindow Class Reference

Mesa rendering window. More...

#include <vtkXMesaRenderWindow.h>

Inheritance diagram for vtkXMesaRenderWindow:

[legend]
Collaboration diagram for vtkXMesaRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXMesaRenderWindow, vtkMesaRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Start (void)
virtual void | Frame (void)
virtual void | WindowInitialize (void)
virtual void | Initialize (void)
virtual void | SetFullScreen (int)
virtual void | WindowRemap (void)
virtual void | PrefFullScreen (void)
virtual void | SetStereoCapableWindow (int capable)
void | MakeCurrent ()
virtual int * | GetScreenSize ()
virtual int * | GetPosition ()
Display * | GetDisplayId ()
Window | GetParentId ()
Window | GetWindowId ()
virtual int | GetEventPending ()
void | SetWindowInfo (char *info)
void | SetParentInfo (char *info)
void | Render ()
void | SetOffScreenRendering (int i)
virtual void | SetSize (int, int)
virtual void | SetSize (int a[2])
virtual Colormap | GetDesiredColormap ()
virtual Visual * | GetDesiredVisual ()
virtual XVisualInfo * | GetDesiredVisualInfo ()
virtual int | GetDesiredDepth ()
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void * | GetGenericDrawable ()
void | SetDisplayId (Display *)
void | SetDisplayId (void *)
void | SetParentId (Window)
void | SetParentId (void *)
void | SetWindowId (Window)
void | SetWindowId (void *)
void | SetNextWindowId (Window)
void | SetWindowName (char *)
void | SetPosition (int, int)
void | SetPosition (int a[2])
void | HideCursor ()
void | ShowCursor ()

Static Public Methods

vtkXMesaRenderWindow * | New ()

Protected Methods

vtkXMesaRenderWindow ()
~vtkXMesaRenderWindow ()

Protected Attributes

GLXContext | ContextId
Window | ParentId
Window | WindowId
Window | NextWindowId
Display * | DisplayId
Colormap | ColorMap
int | OwnWindow
int | OwnDisplay
int | ScreenSize [2]
int | CursorHidden
OSMesaContext | OffScreenContextId
void * | OffScreenWindow
int | ScreenMapped
int | ScreenDoubleBuffer

Detailed Description

Mesa rendering window.

Date:
2002/03/13 16:11:09
Revision:
1.8

vtkXMesaRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkOpenGLRenderer interfaces to the OpenGL graphics library. Application programmers should normally use vtkRenderWindow instead of the OpenGL specific version.

Created by:
  • Law, Charles
Contributed by (if > 5%):
  • Law, Charles (69%)
  • Hoffman, Bill (29%)
Tests:
vtkXMesaRenderWindow (Tests)

Definition at line 55 of file vtkXMesaRenderWindow.h.

Constructor & Destructor Documentation

vtkXMesaRenderWindow::vtkXMesaRenderWindow ( ) [protected]

vtkXMesaRenderWindow::~vtkXMesaRenderWindow ( ) [protected]

Member Function Documentation

vtkXMesaRenderWindow* vtkXMesaRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkRenderWindow.

vtkXMesaRenderWindow::vtkTypeRevisionMacro | ( | vtkXMesaRenderWindow | ,
 |  | vtkMesaRenderWindow |
 | ) |

Reimplemented from vtkMesaRenderWindow.

void vtkXMesaRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkMesaRenderWindow.

virtual void vtkXMesaRenderWindow::Start ( void ) [virtual]

Begin the rendering process.

Reimplemented from vtkRenderWindow.

virtual void vtkXMesaRenderWindow::Frame ( void ) [virtual]

End the rendering process and display the image.

Reimplemented from vtkRenderWindow.

virtual void vtkXMesaRenderWindow::WindowInitialize ( void ) [virtual]

Initialize the window for rendering.

virtual void vtkXMesaRenderWindow::Initialize ( void ) [virtual]

Initialize the rendering window.

virtual void vtkXMesaRenderWindow::SetFullScreen ( int ) [virtual]

Change the window to fill the entire screen.

Reimplemented from vtkRenderWindow.

virtual void vtkXMesaRenderWindow::WindowRemap ( void ) [virtual]

Resize the window.

Reimplemented from vtkRenderWindow.

virtual void vtkXMesaRenderWindow::PrefFullScreen ( void ) [virtual]

Set the preferred window size to full screen.

virtual void vtkXMesaRenderWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Specify the size of the rendering window.

Reimplemented from vtkWindow.

virtual void vtkXMesaRenderWindow::SetSize ( int a[2] ) [inline, virtual]

Specify the size of the rendering window.

Reimplemented from vtkWindow.

Definition at line 89 of file vtkXMesaRenderWindow.h.

virtual Colormap vtkXMesaRenderWindow::GetDesiredColormap ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual Visual* vtkXMesaRenderWindow::GetDesiredVisual ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual XVisualInfo* vtkXMesaRenderWindow::GetDesiredVisualInfo ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual int vtkXMesaRenderWindow::GetDesiredDepth ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual void vtkXMesaRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. This method overrides the superclass method since this class can actually check whether the window has been realized yet.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::MakeCurrent ( ) [virtual]

Make this window the current OpenGL context.

Reimplemented from vtkMesaRenderWindow.

virtual void* vtkXMesaRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 111 of file vtkXMesaRenderWindow.h.

virtual void* vtkXMesaRenderWindow::GetGenericWindowId ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

virtual void* vtkXMesaRenderWindow::GetGenericParentId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 113 of file vtkXMesaRenderWindow.h.

virtual void* vtkXMesaRenderWindow::GetGenericContext ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

virtual void* vtkXMesaRenderWindow::GetGenericDrawable ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 115 of file vtkXMesaRenderWindow.h.

virtual int* vtkXMesaRenderWindow::GetScreenSize ( ) [virtual]

Get the size of the screen in pixels

virtual int* vtkXMesaRenderWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates (pixels) of the window.

Reimplemented from vtkWindow.

Display* vtkXMesaRenderWindow::GetDisplayId ( )

Get this RenderWindow's X display id.

void vtkXMesaRenderWindow::SetDisplayId ( Display * )

Set the X display id for this RenderWindow to use to a pre-existing X display id.

void vtkXMesaRenderWindow::SetDisplayId ( void * foo ) [virtual]

Set the X display id for this RenderWindow to use to a pre-existing X display id.

Reimplemented from vtkRenderWindow.

Window vtkXMesaRenderWindow::GetParentId ( )

Get this RenderWindow's parent X window id.

void vtkXMesaRenderWindow::SetParentId ( Window )

Sets the parent of the window that WILL BE created.

void vtkXMesaRenderWindow::SetParentId ( void * foo ) [virtual]

Sets the parent of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

Window vtkXMesaRenderWindow::GetWindowId ( )

Get this RenderWindow's X window id.

void vtkXMesaRenderWindow::SetWindowId ( Window )

Set this RenderWindow's X window id to a pre-existing window.

void vtkXMesaRenderWindow::SetWindowId ( void * foo ) [virtual]

Set this RenderWindow's X window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::SetNextWindowId ( Window )

Specify the X window id to use if a WindowRemap is done.

void vtkXMesaRenderWindow::SetWindowName ( char * name ) [virtual]

Specify the X window id to use if a WindowRemap is done.

Reimplemented from vtkWindow.

void vtkXMesaRenderWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Move the window to a new position on the display.

Reimplemented from vtkWindow.

void vtkXMesaRenderWindow::SetPosition ( int a[2] ) [inline, virtual]

Move the window to a new position on the display.

Reimplemented from vtkWindow.

Definition at line 161 of file vtkXMesaRenderWindow.h.

void vtkXMesaRenderWindow::HideCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::ShowCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

virtual int vtkXMesaRenderWindow::GetEventPending ( ) [virtual]

Get the properties available at runtime that would result in the best Xwindow for 3D rendering.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::SetWindowInfo ( char * info ) [virtual]

Set this RenderWindow's X window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::SetParentInfo ( char * info ) [virtual]

Sets the X window id of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::Render ( void ) [virtual]

This computes the size of the render window before calling the supper classes render

Reimplemented from vtkRenderWindow.

void vtkXMesaRenderWindow::SetOffScreenRendering ( int i ) [virtual]

Render without displaying the window.

Reimplemented from vtkWindow.

Member Data Documentation

GLXContext vtkXMesaRenderWindow::ContextId [protected]

Definition at line 58 of file vtkXMesaRenderWindow.h.

Window vtkXMesaRenderWindow::ParentId [protected]

Definition at line 192 of file vtkXMesaRenderWindow.h.

Window vtkXMesaRenderWindow::WindowId [protected]

Definition at line 193 of file vtkXMesaRenderWindow.h.

Window vtkXMesaRenderWindow::NextWindowId [protected]

Definition at line 194 of file vtkXMesaRenderWindow.h.

Display* vtkXMesaRenderWindow::DisplayId [protected]

Definition at line 195 of file vtkXMesaRenderWindow.h.

Colormap vtkXMesaRenderWindow::ColorMap [protected]

Definition at line 196 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::OwnWindow [protected]

Definition at line 197 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::OwnDisplay [protected]

Definition at line 198 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::ScreenSize[2] [protected]

Definition at line 199 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::CursorHidden [protected]

Definition at line 200 of file vtkXMesaRenderWindow.h.

OSMesaContext vtkXMesaRenderWindow::OffScreenContextId [protected]

Definition at line 203 of file vtkXMesaRenderWindow.h.

void* vtkXMesaRenderWindow::OffScreenWindow [protected]

Definition at line 204 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::ScreenMapped [protected]

Definition at line 205 of file vtkXMesaRenderWindow.h.

int vtkXMesaRenderWindow::ScreenDoubleBuffer [protected]

Definition at line 207 of file vtkXMesaRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXMesaRenderWindow.h
Generated on Mon Mar 25 01:36:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMesaTextMapper Class Reference

#include <vtkXMesaTextMapper.h>

Inheritance diagram for vtkXMesaTextMapper:

[legend]
Collaboration diagram for vtkXMesaTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXMesaTextMapper, vtkXTextMapper)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)

Static Public Methods

vtkXMesaTextMapper * | New ()
int | GetListBaseForFont (vtkTextMapper *tm, vtkViewport *vp, Font)

Protected Methods

vtkXMesaTextMapper ()
~vtkXMesaTextMapper ()

Constructor & Destructor Documentation

vtkXMesaTextMapper::vtkXMesaTextMapper ( ) [protected]

vtkXMesaTextMapper::~vtkXMesaTextMapper ( ) [inline, protected]

Definition at line 66 of file vtkXMesaTextMapper.h.

Member Function Documentation

vtkXMesaTextMapper::vtkTypeRevisionMacro | ( | vtkXMesaTextMapper | ,
 |  | vtkXTextMapper |
 | ) |

Reimplemented from vtkXTextMapper.

vtkXMesaTextMapper* vtkXMesaTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkXTextMapper.

void vtkXMesaTextMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkXMesaTextMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

Definition at line 50 of file vtkXMesaTextMapper.h.

virtual void vtkXMesaTextMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

int vtkXMesaTextMapper::GetListBaseForFont | ( | vtkTextMapper * | tm,
 |  | vtkViewport * | vp,
 |  | Font |
 | ) | [static]

An internal function used for caching font display lists.

The documentation for this class was generated from the following file:
  • Rendering/vtkXMesaTextMapper.h
Generated on Mon Mar 25 01:36:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMLFileOutputWindow Class Reference

XML File Specific output window class. More...

#include <vtkXMLFileOutputWindow.h>

Inheritance diagram for vtkXMLFileOutputWindow:

[legend]
Collaboration diagram for vtkXMLFileOutputWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXMLFileOutputWindow, vtkFileOutputWindow)
virtual void | DisplayTag (const char *)
virtual void | DisplayText (const char *)
virtual void | DisplayErrorText (const char *)
virtual void | DisplayWarningText (const char *)
virtual void | DisplayGenericWarningText (const char *)
virtual void | DisplayDebugText (const char *)

Static Public Methods

vtkXMLFileOutputWindow * | New ()

Protected Methods

vtkXMLFileOutputWindow ()
virtual | ~vtkXMLFileOutputWindow ()
void | Initialize ()
virtual void | DisplayXML (const char *, const char *)

Detailed Description

XML File Specific output window class.

Date:
2002/01/22 15:26:48
Revision:
1.7

Writes debug/warning/error output to an XML file. Uses prefined XML tags for each text display method. The text is processed to replace XML markup characters.

DisplayText - <Text>

DisplayErrorText - <Error>

DisplayWarningText - <Warning>

DisplayGenericWarningText - <GenericWarning>

DisplayDebugText - <Debug.

The method DisplayTag outputs the text unprocessed. To use this class, instantiate it and then call SetInstance(this).

Created by:
  • Lorensen, Bill
Contributed by (if > 5%):
  • Lorensen, Bill (98%)
Tests:
vtkXMLFileOutputWindow (Tests)

Definition at line 55 of file vtkXMLFileOutputWindow.h.

Constructor & Destructor Documentation

vtkXMLFileOutputWindow::vtkXMLFileOutputWindow ( ) [inline, protected]

Definition at line 78 of file vtkXMLFileOutputWindow.h.

virtual vtkXMLFileOutputWindow::~vtkXMLFileOutputWindow ( ) [inline, protected, virtual]

Definition at line 79 of file vtkXMLFileOutputWindow.h.

Member Function Documentation

vtkXMLFileOutputWindow::vtkTypeRevisionMacro | ( | vtkXMLFileOutputWindow | ,
 |  | vtkFileOutputWindow |
 | ) |

Reimplemented from vtkFileOutputWindow.

vtkXMLFileOutputWindow* vtkXMLFileOutputWindow::New ( ) [static]

This is a singleton pattern New. There will only be ONE reference to a vtkOutputWindow object per process. Clients that call this must call Delete on the object so that the reference counting will work. The single instance will be unreferenced when the program exits.

Reimplemented from vtkFileOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayText ( const char * ) [virtual]

Put the text into the log file. The text is processed to replace &, <, > with &amp, &lt, and &gt. Each display method outputs a different XML tag.

Reimplemented from vtkFileOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayErrorText ( const char * ) [virtual]

Put the text into the log file. The text is processed to replace &, <, > with &amp, &lt, and &gt. Each display method outputs a different XML tag.

Reimplemented from vtkOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayWarningText ( const char * ) [virtual]

Put the text into the log file. The text is processed to replace &, <, > with &amp, &lt, and &gt. Each display method outputs a different XML tag.

Reimplemented from vtkOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayGenericWarningText ( const char * ) [virtual]

Put the text into the log file. The text is processed to replace &, <, > with &amp, &lt, and &gt. Each display method outputs a different XML tag.

Reimplemented from vtkOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayDebugText ( const char * ) [virtual]

Put the text into the log file. The text is processed to replace &, <, > with &amp, &lt, and &gt. Each display method outputs a different XML tag.

Reimplemented from vtkOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayTag ( const char * ) [virtual]

Put the text into the log file without processing it.

void vtkXMLFileOutputWindow::Initialize ( ) [protected]

Reimplemented from vtkFileOutputWindow.

virtual void vtkXMLFileOutputWindow::DisplayXML | ( | const char * | ,
 |  | const char * |
 | ) | [protected, virtual]

The documentation for this class was generated from the following file:
  • Common/vtkXMLFileOutputWindow.h
Generated on Mon Mar 25 01:36:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXMLParser Class Reference

Parse XML to handle element tags and attributes. More...

#include <vtkXMLParser.h>

Inheritance diagram for vtkXMLParser:

[legend]
Collaboration diagram for vtkXMLParser:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXMLParser, vtkObject)
void | PrintSelf (ostream &os, vtkIndent indent)
int | Parse ()
virtual void | SetStream (istream *)
virtual istream * | GetStream ()

Static Public Methods

vtkXMLParser * | New ()

Protected Methods

vtkXMLParser ()
~vtkXMLParser ()
virtual int | ParseStream ()
virtual int | ParsingComplete ()
virtual void | StartElement (const char *name, const char **atts)
virtual void | EndElement (const char *name)
virtual void | CharacterDataHandler (const char *data, int length)
virtual void | ReportStrayAttribute (const char *element, const char *attr, const char *value)
virtual void | ReportMissingAttribute (const char *element, const char *attr)
virtual void | ReportBadAttribute (const char *element, const char *attr, const char *value)
virtual void | ReportUnknownElement (const char *element)
virtual void | ReportXmlParseError ()
unsigned long | GetXMLByteIndex ()
int | ParseBuffer (const char *buffer, unsigned int count)
int | ParseBuffer (const char *buffer)

Static Protected Methods

int | IsSpace (char c)
void | StartElementFunction (void *parser, const char *name, const char **atts)
void | EndElementFunction (void *parser, const char *name)
void | CharacterDataHandlerFunction (void *parser, const char *data, int length)

Protected Attributes

istream * Stream
void * | Parser

Detailed Description

Parse XML to handle element tags and attributes.

Date:
2002/03/19 20:41:52
Revision:
1.1

vtkXMLParser reads a stream and parses XML element tags and corresponding attributes. Each element begin tag and its attributes are sent to the StartElement method. Each element end tag is sent to the EndElement method. Subclasses should replace these methods to actually use the tags.

Created by:
  • King, Brad
Contributed by (if > 5%):
  • King, Brad (98%)

Definition at line 40 of file vtkXMLParser.h.

Constructor & Destructor Documentation

vtkXMLParser::vtkXMLParser ( ) [protected]

vtkXMLParser::~vtkXMLParser ( ) [protected]

Member Function Documentation

vtkXMLParser::vtkTypeRevisionMacro | ( | vtkXMLParser | ,
 |  | vtkObject |
 | ) |

void vtkXMLParser::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkObject.

vtkXMLParser* vtkXMLParser::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkObject.

virtual void vtkXMLParser::SetStream ( istream * ) [virtual]

Get/Set the input stream.

virtual istream* vtkXMLParser::GetStream ( ) [virtual]

Get/Set the input stream.

int vtkXMLParser::Parse ( )

Parse the input stream.

virtual int vtkXMLParser::ParseStream ( ) [protected, virtual]

virtual int vtkXMLParser::ParsingComplete ( ) [protected, virtual]

virtual void vtkXMLParser::StartElement | ( | const char * | name,
 |  | const char ** | atts
 | ) | [protected, virtual]

virtual void vtkXMLParser::EndElement ( const char * name ) [protected, virtual]

virtual void vtkXMLParser::CharacterDataHandler | ( | const char * | data,
 |  | int | length
 | ) | [protected, virtual]

virtual void vtkXMLParser::ReportStrayAttribute | ( | const char * | element,
 |  | const char * | attr,
 |  | const char * | value
 | ) | [protected, virtual]

virtual void vtkXMLParser::ReportMissingAttribute | ( | const char * | element,
 |  | const char * | attr
 | ) | [protected, virtual]

virtual void vtkXMLParser::ReportBadAttribute | ( | const char * | element,
 |  | const char * | attr,
 |  | const char * | value
 | ) | [protected, virtual]

virtual void vtkXMLParser::ReportUnknownElement ( const char * element ) [protected, virtual]

virtual void vtkXMLParser::ReportXmlParseError ( ) [protected, virtual]

unsigned long vtkXMLParser::GetXMLByteIndex ( ) [protected]

int vtkXMLParser::ParseBuffer | ( | const char * | buffer,
 |  | unsigned int | count
 | ) | [protected]

int vtkXMLParser::ParseBuffer ( const char * buffer ) [protected]

int vtkXMLParser::IsSpace ( char c ) [static, protected]

void vtkXMLParser::StartElementFunction | ( | void * | parser,
 |  | const char * | name,
 |  | const char ** | atts
 | ) | [static, protected]

void vtkXMLParser::EndElementFunction | ( | void * | parser,
 |  | const char * | name
 | ) | [static, protected]

void vtkXMLParser::CharacterDataHandlerFunction | ( | void * | parser,
 |  | const char * | data,
 |  | int | length
 | ) | [static, protected]

Member Data Documentation

istream* vtkXMLParser::Stream [protected]

Definition at line 64 of file vtkXMLParser.h.

void* vtkXMLParser::Parser [protected]

Definition at line 67 of file vtkXMLParser.h.

The documentation for this class was generated from the following file:
  • IO/vtkXMLParser.h
Generated on Mon Mar 25 01:36:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXOpenGLRenderWindow Class Reference

OpenGL rendering window. More...

#include <vtkXOpenGLRenderWindow.h>

Inheritance diagram for vtkXOpenGLRenderWindow:

[legend]
Collaboration diagram for vtkXOpenGLRenderWindow:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXOpenGLRenderWindow, vtkOpenGLRenderWindow)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Start (void)
virtual void | Frame (void)
virtual void | WindowInitialize (void)
virtual void | Initialize (void)
virtual void | SetFullScreen (int)
virtual void | WindowRemap (void)
virtual void | PrefFullScreen (void)
virtual void | SetStereoCapableWindow (int capable)
void | MakeCurrent ()
virtual int * | GetScreenSize ()
virtual int * | GetPosition ()
Display * | GetDisplayId ()
Window | GetParentId ()
Window | GetWindowId ()
virtual int | GetEventPending ()
void | SetWindowInfo (char *info)
void | SetParentInfo (char *info)
void | Render ()
void | SetOffScreenRendering (int i)
virtual void | SetSize (int, int)
virtual void | SetSize (int a[2])
virtual Colormap | GetDesiredColormap ()
virtual Visual * | GetDesiredVisual ()
virtual XVisualInfo * | GetDesiredVisualInfo ()
virtual int | GetDesiredDepth ()
virtual void * | GetGenericDisplayId ()
virtual void * | GetGenericWindowId ()
virtual void * | GetGenericParentId ()
virtual void * | GetGenericContext ()
virtual void * | GetGenericDrawable ()
void | SetDisplayId (Display *)
void | SetDisplayId (void *)
void | SetParentId (Window)
void | SetParentId (void *)
void | SetWindowId (Window)
void | SetWindowId (void *)
void | SetNextWindowId (Window)
void | SetWindowName (char *)
void | SetPosition (int, int)
void | SetPosition (int a[2])
void | HideCursor ()
void | ShowCursor ()

Static Public Methods

vtkXOpenGLRenderWindow * | New ()

Protected Methods

vtkXOpenGLRenderWindow ()
~vtkXOpenGLRenderWindow ()

Protected Attributes

GLXContext | ContextId
Window | ParentId
Window | WindowId
Window | NextWindowId
Display * | DisplayId
Colormap | ColorMap
int | OwnWindow
int | OwnDisplay
int | ScreenSize [2]
int | CursorHidden

Detailed Description

OpenGL rendering window.

Date:
2002/01/22 15:39:56
Revision:
1.10

vtkXOpenGLRenderWindow is a concrete implementation of the abstract class vtkRenderWindow. vtkOpenGLRenderer interfaces to the OpenGL graphics library. Application programmers should normally use vtkRenderWindow instead of the OpenGL specific version.

Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (73%)
  • Hoffman, Bill (25%)
Examples:
vtkXOpenGLRenderWindow (Examples)
Tests:
vtkXOpenGLRenderWindow (Tests)

Definition at line 58 of file vtkXOpenGLRenderWindow.h.

Constructor & Destructor Documentation

vtkXOpenGLRenderWindow::vtkXOpenGLRenderWindow ( ) [protected]

vtkXOpenGLRenderWindow::~vtkXOpenGLRenderWindow ( ) [protected]

Member Function Documentation

vtkXOpenGLRenderWindow* vtkXOpenGLRenderWindow::New ( ) [static]

Construct an instance of vtkRenderWindow with its screen size set to 300x300, borders turned on, positioned at (0,0), double buffering turned on.

Reimplemented from vtkRenderWindow.

vtkXOpenGLRenderWindow::vtkTypeRevisionMacro | ( | vtkXOpenGLRenderWindow | ,
 |  | vtkOpenGLRenderWindow |
 | ) |

Reimplemented from vtkOpenGLRenderWindow.

void vtkXOpenGLRenderWindow::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkOpenGLRenderWindow.

virtual void vtkXOpenGLRenderWindow::Start ( void ) [virtual]

Begin the rendering process.

Reimplemented from vtkRenderWindow.

virtual void vtkXOpenGLRenderWindow::Frame ( void ) [virtual]

End the rendering process and display the image.

Reimplemented from vtkRenderWindow.

virtual void vtkXOpenGLRenderWindow::WindowInitialize ( void ) [virtual]

Initialize the window for rendering.

virtual void vtkXOpenGLRenderWindow::Initialize ( void ) [virtual]

Initialize the rendering window.

virtual void vtkXOpenGLRenderWindow::SetFullScreen ( int ) [virtual]

Change the window to fill the entire screen.

Reimplemented from vtkRenderWindow.

virtual void vtkXOpenGLRenderWindow::WindowRemap ( void ) [virtual]

Resize the window.

Reimplemented from vtkRenderWindow.

virtual void vtkXOpenGLRenderWindow::PrefFullScreen ( void ) [virtual]

Set the preferred window size to full screen.

virtual void vtkXOpenGLRenderWindow::SetSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

Specify the size of the rendering window.

Reimplemented from vtkWindow.

virtual void vtkXOpenGLRenderWindow::SetSize ( int a[2] ) [inline, virtual]

Specify the size of the rendering window.

Reimplemented from vtkWindow.

Definition at line 92 of file vtkXOpenGLRenderWindow.h.

virtual Colormap vtkXOpenGLRenderWindow::GetDesiredColormap ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual Visual* vtkXOpenGLRenderWindow::GetDesiredVisual ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual XVisualInfo* vtkXOpenGLRenderWindow::GetDesiredVisualInfo ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual int vtkXOpenGLRenderWindow::GetDesiredDepth ( ) [virtual]

Get the X properties of an ideal rendering window.

virtual void vtkXOpenGLRenderWindow::SetStereoCapableWindow ( int capable ) [virtual]

Prescribe that the window be created in a stereo-capable mode. This method must be called before the window is realized. This method overrides the superclass method since this class can actually check whether the window has been realized yet.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::MakeCurrent ( ) [virtual]

Make this window the current OpenGL context.

Reimplemented from vtkOpenGLRenderWindow.

virtual void* vtkXOpenGLRenderWindow::GetGenericDisplayId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 114 of file vtkXOpenGLRenderWindow.h.

virtual void* vtkXOpenGLRenderWindow::GetGenericWindowId ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

virtual void* vtkXOpenGLRenderWindow::GetGenericParentId ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 116 of file vtkXOpenGLRenderWindow.h.

virtual void* vtkXOpenGLRenderWindow::GetGenericContext ( ) [virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

virtual void* vtkXOpenGLRenderWindow::GetGenericDrawable ( ) [inline, virtual]

Xwindow get set functions

Reimplemented from vtkRenderWindow.

Definition at line 118 of file vtkXOpenGLRenderWindow.h.

virtual int* vtkXOpenGLRenderWindow::GetScreenSize ( ) [virtual]

Get the size of the screen in pixels

virtual int* vtkXOpenGLRenderWindow::GetPosition ( ) [virtual]

Get the position in screen coordinates (pixels) of the window.

Reimplemented from vtkWindow.

Display* vtkXOpenGLRenderWindow::GetDisplayId ( )

Get this RenderWindow's X display id.

void vtkXOpenGLRenderWindow::SetDisplayId ( Display * )

Set the X display id for this RenderWindow to use to a pre-existing X display id.

void vtkXOpenGLRenderWindow::SetDisplayId ( void * foo ) [virtual]

Set the X display id for this RenderWindow to use to a pre-existing X display id.

Reimplemented from vtkRenderWindow.

Window vtkXOpenGLRenderWindow::GetParentId ( )

Get this RenderWindow's parent X window id.

void vtkXOpenGLRenderWindow::SetParentId ( Window )

Sets the parent of the window that WILL BE created.

void vtkXOpenGLRenderWindow::SetParentId ( void * foo ) [virtual]

Sets the parent of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

Window vtkXOpenGLRenderWindow::GetWindowId ( )

Get this RenderWindow's X window id.

void vtkXOpenGLRenderWindow::SetWindowId ( Window )

Set this RenderWindow's X window id to a pre-existing window.

void vtkXOpenGLRenderWindow::SetWindowId ( void * foo ) [virtual]

Set this RenderWindow's X window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::SetNextWindowId ( Window )

Specify the X window id to use if a WindowRemap is done.

void vtkXOpenGLRenderWindow::SetWindowName ( char * name ) [virtual]

Specify the X window id to use if a WindowRemap is done.

Reimplemented from vtkWindow.

void vtkXOpenGLRenderWindow::SetPosition | ( | int | x,
 |  | int | y
 | ) | [virtual]

Move the window to a new position on the display.

Reimplemented from vtkWindow.

void vtkXOpenGLRenderWindow::SetPosition ( int a[2] ) [inline, virtual]

Move the window to a new position on the display.

Reimplemented from vtkWindow.

Definition at line 164 of file vtkXOpenGLRenderWindow.h.

void vtkXOpenGLRenderWindow::HideCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::ShowCursor ( ) [virtual]

Hide or Show the mouse cursor, it is nice to be able to hide the default cursor if you want VTK to display a 3D cursor instead.

Reimplemented from vtkRenderWindow.

virtual int vtkXOpenGLRenderWindow::GetEventPending ( ) [virtual]

Get the properties available at runtime that would result in the best Xwindow for 3D rendering.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::SetWindowInfo ( char * info ) [virtual]

Set this RenderWindow's X window id to a pre-existing window.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::SetParentInfo ( char * info ) [virtual]

Sets the X window id of the window that WILL BE created.

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::Render ( void ) [virtual]

This computes the size of the render window before calling the supper classes render

Reimplemented from vtkRenderWindow.

void vtkXOpenGLRenderWindow::SetOffScreenRendering ( int i ) [virtual]

Render without displaying the window.

Reimplemented from vtkWindow.

Member Data Documentation

GLXContext vtkXOpenGLRenderWindow::ContextId [protected]

Definition at line 61 of file vtkXOpenGLRenderWindow.h.

Window vtkXOpenGLRenderWindow::ParentId [protected]

Definition at line 195 of file vtkXOpenGLRenderWindow.h.

Window vtkXOpenGLRenderWindow::WindowId [protected]

Definition at line 196 of file vtkXOpenGLRenderWindow.h.

Window vtkXOpenGLRenderWindow::NextWindowId [protected]

Definition at line 197 of file vtkXOpenGLRenderWindow.h.

Display* vtkXOpenGLRenderWindow::DisplayId [protected]

Definition at line 198 of file vtkXOpenGLRenderWindow.h.

Colormap vtkXOpenGLRenderWindow::ColorMap [protected]

Definition at line 199 of file vtkXOpenGLRenderWindow.h.

int vtkXOpenGLRenderWindow::OwnWindow [protected]

Definition at line 200 of file vtkXOpenGLRenderWindow.h.

int vtkXOpenGLRenderWindow::OwnDisplay [protected]

Definition at line 201 of file vtkXOpenGLRenderWindow.h.

int vtkXOpenGLRenderWindow::ScreenSize[2] [protected]

Definition at line 202 of file vtkXOpenGLRenderWindow.h.

int vtkXOpenGLRenderWindow::CursorHidden [protected]

Definition at line 203 of file vtkXOpenGLRenderWindow.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXOpenGLRenderWindow.h
Generated on Mon Mar 25 01:36:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXOpenGLTextMapper Class Reference

2D Text annotation support for windows. More...

#include <vtkXMesaTextMapper.h>

Inheritance diagram for vtkXOpenGLTextMapper:

[legend]
Collaboration diagram for vtkXOpenGLTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXOpenGLTextMapper, vtkXTextMapper)
virtual void | ReleaseGraphicsResources (vtkWindow *)
void | RenderOpaqueGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderTranslucentGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderGeometry (vtkViewport *viewport, vtkActor2D *actor)
void | RenderOverlay (vtkViewport *, vtkActor2D *)

Static Public Methods

vtkXOpenGLTextMapper * | New ()
int | GetListBaseForFont (vtkTextMapper *tm, vtkViewport *vp, Font)

Protected Methods

vtkXOpenGLTextMapper ()
~vtkXOpenGLTextMapper ()

Detailed Description

2D Text annotation support for windows.

Date:
2002/01/22 15:39:55
Revision:
1.11

vtkXMesaTextMapper provides 2D text annotation support for vtk under Xwindows. Normally the user should use vtktextMapper which in turn will use this class.

See also:
vtkTextMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (91%)

Definition at line 43 of file vtkXOpenGLTextMapper.h.

Constructor & Destructor Documentation

vtkXOpenGLTextMapper::vtkXOpenGLTextMapper ( ) [protected]

vtkXOpenGLTextMapper::~vtkXOpenGLTextMapper ( ) [protected]

Member Function Documentation

vtkXOpenGLTextMapper::vtkTypeRevisionMacro | ( | vtkXOpenGLTextMapper | ,
 |  | vtkXTextMapper |
 | ) |

Reimplemented from vtkXTextMapper.

vtkXOpenGLTextMapper* vtkXOpenGLTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkXTextMapper.

void vtkXOpenGLTextMapper::RenderOpaqueGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkXOpenGLTextMapper::RenderTranslucentGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

void vtkXOpenGLTextMapper::RenderGeometry | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) |

Actally draw the text.

void vtkXOpenGLTextMapper::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [inline, virtual]

Actally draw the text.

Reimplemented from vtkMapper2D.

Definition at line 54 of file vtkXOpenGLTextMapper.h.

virtual void vtkXOpenGLTextMapper::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkAbstractMapper.

int vtkXOpenGLTextMapper::GetListBaseForFont | ( | vtkTextMapper * | tm,
 |  | vtkViewport * | vp,
 |  | Font |
 | ) | [static]

An internal function used for caching font display lists.

The documentation for this class was generated from the following files:
  • Rendering/vtkXMesaTextMapper.h
  • Rendering/vtkXOpenGLTextMapper.h
Generated on Mon Mar 25 01:36:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXPolyDataMapper2D Class Reference

2D PolyData support for windows. More...

#include <vtkXPolyDataMapper2D.h>

Inheritance diagram for vtkXPolyDataMapper2D:

[legend]
Collaboration diagram for vtkXPolyDataMapper2D:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXPolyDataMapper2D, vtkPolyDataMapper2D)
void | RenderOverlay (vtkViewport *viewport, vtkActor2D *actor)

Static Public Methods

vtkXPolyDataMapper2D * | New ()

Protected Methods

vtkXPolyDataMapper2D ()
~vtkXPolyDataMapper2D ()

Detailed Description

2D PolyData support for windows.

Date:
2002/01/22 15:39:58
Revision:
1.18

vtkXPolyDataMapper2D provides 2D PolyData annotation support for vtk under windows. Normally the user should use vtkPolyDataMapper2D which in turn will use this class.

See also:
vtkPolyDataMapper2D
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (76%)
  • Schroeder, Will (11%)
  • Law, Charles (8%)

Definition at line 44 of file vtkXPolyDataMapper2D.h.

Constructor & Destructor Documentation

vtkXPolyDataMapper2D::vtkXPolyDataMapper2D ( ) [inline, protected]

Definition at line 54 of file vtkXPolyDataMapper2D.h.

vtkXPolyDataMapper2D::~vtkXPolyDataMapper2D ( ) [inline, protected]

Definition at line 55 of file vtkXPolyDataMapper2D.h.

Member Function Documentation

vtkXPolyDataMapper2D::vtkTypeRevisionMacro | ( | vtkXPolyDataMapper2D | ,
 |  | vtkPolyDataMapper2D |
 | ) |

Reimplemented from vtkPolyDataMapper2D.

vtkXPolyDataMapper2D* vtkXPolyDataMapper2D::New ( ) [static]

Instantiate object with no start, end, or progress methods.

Reimplemented from vtkPolyDataMapper2D.

void vtkXPolyDataMapper2D::RenderOverlay | ( | vtkViewport * | viewport,
 |  | vtkActor2D * | actor
 | ) | [virtual]

Actually draw the poly data.

Reimplemented from vtkMapper2D.

The documentation for this class was generated from the following file:
  • Rendering/vtkXPolyDataMapper2D.h
Generated on Mon Mar 25 01:36:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXRenderWindowInteractor Class Reference

an X event driven interface for a RenderWindow. More...

#include <vtkXRenderWindowInteractor.h>

Inheritance diagram for vtkXRenderWindowInteractor:

[legend]
Collaboration diagram for vtkXRenderWindowInteractor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXRenderWindowInteractor, vtkRenderWindowInteractor)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
void | TerminateApp (void)
virtual void | Start ()
virtual void | GetMousePosition (int *x, int *y)
virtual void | SetBreakLoopFlag (int)
virtual int | GetBreakLoopFlag ()
virtual void | BreakLoopFlagOn ()
virtual void | BreakLoopFlagOff ()
int | CreateTimer (int timertype)
int | DestroyTimer (void)
virtual void | Initialize (XtAppContext app)
virtual XtAppContext | GetApp ()
virtual void | Enable ()
virtual void | Disable ()
virtual void | SetWidget (Widget)
Widget | GetWidget ()
virtual void | SetTopLevelShell (Widget)
Widget | GetTopLevelShell ()

Static Public Methods

vtkXRenderWindowInteractor * | New ()

Protected Methods

vtkXRenderWindowInteractor ()
~vtkXRenderWindowInteractor ()
XtIntervalId | AddTimeOut (XtAppContext app_context, unsigned long interval, XtTimerCallbackProc proc, XtPointer client_data)
void | Timer (XtPointer client_data, XtIntervalId *id)
void | Callback (Widget w, XtPointer client_data, XEvent *event, Boolean *ctd)

Protected Attributes

Display * | DisplayId
Window | WindowId
Widget | Top
int | OwnTop
XtAppContext | App
int | PositionBeforeStereo [2]
Widget | TopLevelShell
int | BreakLoopFlag

Friends

void | vtkXRenderWindowInteractorCallback (Widget, XtPointer, XEvent *, Boolean *)
void | vtkXRenderWindowInteractorTimer (XtPointer, XtIntervalId *)

Detailed Description

an X event driven interface for a RenderWindow.

Date:
2002/01/22 15:39:59
Revision:
1.64

vtkXRenderWindowInteractor is a convenience object that provides event bindings to common graphics functions. For example, camera and actor functions such as zoom-in/zoom-out, azimuth, roll, and pan. IT is one of the window system specific subclasses of vtkRenderWindowInteractor. Please see vtkRenderWindowInteractor documentation for event bindings.

See also:
vtkRenderWindowInteractor vtkXRenderWindow
I've been though this and deleted all I think should go, tried to create the basic structure and if you're lucky it might even work! but frankly I doubt it
Events:
vtkCommand::LeftButtonReleaseEvent vtkCommand::RightButtonPressEvent vtkCommand::MouseMoveEvent vtkCommand::MiddleButtonReleaseEvent vtkCommand::EnterEvent vtkCommand::StartEvent vtkCommand::TimerEvent vtkCommand::KeyPressEvent vtkCommand::RightButtonReleaseEvent vtkCommand::ConfigureEvent vtkCommand::MiddleButtonPressEvent vtkCommand::CharEvent vtkCommand::LeaveEvent vtkCommand::LeftButtonPressEvent vtkCommand::KeyReleaseEvent
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (44%)
  • Pan, Tony (28%)
  • Gobbi, David (6%)
  • Schroeder, Will (5%)
Examples:
vtkXRenderWindowInteractor (Examples)

Definition at line 61 of file vtkXRenderWindowInteractor.h.

Constructor & Destructor Documentation

vtkXRenderWindowInteractor::vtkXRenderWindowInteractor ( ) [protected]

vtkXRenderWindowInteractor::~vtkXRenderWindowInteractor ( ) [protected]

Member Function Documentation

vtkXRenderWindowInteractor* vtkXRenderWindowInteractor::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkRenderWindowInteractor.

vtkXRenderWindowInteractor::vtkTypeRevisionMacro | ( | vtkXRenderWindowInteractor | ,
 |  | vtkRenderWindowInteractor |
 | ) |

Reimplemented from vtkRenderWindowInteractor.

void vtkXRenderWindowInteractor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowInteractor::Initialize ( void ) [virtual]

Initializes the event handlers without an XtAppContext. This is good for when you don't have a user interface, but you still want to have mouse interaction.

Reimplemented from vtkRenderWindowInteractor.

void vtkXRenderWindowInteractor::TerminateApp ( void ) [inline, virtual]

Call exit on 'q','e' keypress. Want more ???

Reimplemented from vtkRenderWindowInteractor.

Definition at line 74 of file vtkXRenderWindowInteractor.h.

virtual void vtkXRenderWindowInteractor::SetBreakLoopFlag ( int ) [virtual]

The BreakLoopFlag is checked in the Start() method. Setting it to anything other than zero will cause the interactor loop to terminate and return to the calling function.

virtual int vtkXRenderWindowInteractor::GetBreakLoopFlag ( ) [virtual]

The BreakLoopFlag is checked in the Start() method. Setting it to anything other than zero will cause the interactor loop to terminate and return to the calling function.

virtual void vtkXRenderWindowInteractor::BreakLoopFlagOn ( ) [virtual]

The BreakLoopFlag is checked in the Start() method. Setting it to anything other than zero will cause the interactor loop to terminate and return to the calling function.

virtual void vtkXRenderWindowInteractor::BreakLoopFlagOff ( ) [virtual]

The BreakLoopFlag is checked in the Start() method. Setting it to anything other than zero will cause the interactor loop to terminate and return to the calling function.

int vtkXRenderWindowInteractor::CreateTimer ( int timertype ) [virtual]

X timer methods

Reimplemented from vtkRenderWindowInteractor.

int vtkXRenderWindowInteractor::DestroyTimer ( void ) [virtual]

X timer methods

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowInteractor::Initialize ( XtAppContext app ) [virtual]

Initializes the event handlers using an XtAppContext that you have provided. This assumes that you want to own the event loop.

virtual XtAppContext vtkXRenderWindowInteractor::GetApp ( ) [virtual]

Initializes the event handlers using an XtAppContext that you have provided. This assumes that you want to own the event loop.

virtual void vtkXRenderWindowInteractor::Enable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowInteractor::Disable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowInteractor::Start ( void ) [virtual]

This will start up the X event loop and never return. If you call this method it will loop processing X events until the application is exited.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowInteractor::SetWidget ( Widget ) [virtual]

Specify the Xt widget to use for interaction. This method is one of a couple steps that are required for setting up a vtkRenderWindowInteractor as a widget inside of another user interface. You do not need to use this method if the render window will be a stand-alone window. This is only used when you want the render window to be a subwindow within a larger user interface. In that case, you must tell the render window what X display id to use, and then ask the render window what depth, visual and colormap it wants. Then, you must create an Xt TopLevelShell with those settings. Then you can create the rest of your user interface as a child of the TopLevelShell you created. Eventually, you will create a drawing area or some other widget to serve as the rendering window. You must use the SetWidget method to tell this Interactor about that widget. It's X and it's not terribly easy, but it looks cool.

Widget vtkXRenderWindowInteractor::GetWidget ( ) [inline]

Specify the Xt widget to use for interaction. This method is one of a couple steps that are required for setting up a vtkRenderWindowInteractor as a widget inside of another user interface. You do not need to use this method if the render window will be a stand-alone window. This is only used when you want the render window to be a subwindow within a larger user interface. In that case, you must tell the render window what X display id to use, and then ask the render window what depth, visual and colormap it wants. Then, you must create an Xt TopLevelShell with those settings. Then you can create the rest of your user interface as a child of the TopLevelShell you created. Eventually, you will create a drawing area or some other widget to serve as the rendering window. You must use the SetWidget method to tell this Interactor about that widget. It's X and it's not terribly easy, but it looks cool.

Definition at line 131 of file vtkXRenderWindowInteractor.h.

virtual void vtkXRenderWindowInteractor::SetTopLevelShell ( Widget ) [virtual]

This method will store the top level shell widget for the interactor. This method and the method invocation sequence applies for: 1 vtkRenderWindow-Interactor pair in a nested widget hierarchy multiple vtkRenderWindow-Interactor pairs in the same top level shell It is not needed for 1 vtkRenderWindow-Interactor pair as the direct child of a top level shell multiple vtkRenderWindow-Interactor pairs, each in its own top level shell The method, along with EnterNotify event, changes the keyboard focus among the widgets/vtkRenderWindow(s) so the Interactor(s) can receive the proper keyboard events. The following calls need to be made: vtkRenderWindow's display ID need to be set to the top level shell's display ID. vtkXRenderWindowInteractor's Widget has to be set to the vtkRenderWindow's container widget vtkXRenderWindowInteractor's TopLevel has to be set to the top level shell widget note that the procedure for setting up render window in a widget needs to be followed. See vtkRenderWindowInteractor's SetWidget method. If multiple vtkRenderWindow-Interactor pairs in SEPARATE windows are desired, do not set the display ID (Interactor will create them as needed. Alternatively, create and set distinct DisplayID for each vtkRenderWindow. Using the same display ID without setting the parent widgets will cause the display to be reinitialized every time an interactor is initialized), do not set the widgets (so the render windows would be in their own windows), and do not set TopLevelShell (each has its own top level shell already)

Widget vtkXRenderWindowInteractor::GetTopLevelShell ( ) [inline]

This method will store the top level shell widget for the interactor. This method and the method invocation sequence applies for: 1 vtkRenderWindow-Interactor pair in a nested widget hierarchy multiple vtkRenderWindow-Interactor pairs in the same top level shell It is not needed for 1 vtkRenderWindow-Interactor pair as the direct child of a top level shell multiple vtkRenderWindow-Interactor pairs, each in its own top level shell The method, along with EnterNotify event, changes the keyboard focus among the widgets/vtkRenderWindow(s) so the Interactor(s) can receive the proper keyboard events. The following calls need to be made: vtkRenderWindow's display ID need to be set to the top level shell's display ID. vtkXRenderWindowInteractor's Widget has to be set to the vtkRenderWindow's container widget vtkXRenderWindowInteractor's TopLevel has to be set to the top level shell widget note that the procedure for setting up render window in a widget needs to be followed. See vtkRenderWindowInteractor's SetWidget method. If multiple vtkRenderWindow-Interactor pairs in SEPARATE windows are desired, do not set the display ID (Interactor will create them as needed. Alternatively, create and set distinct DisplayID for each vtkRenderWindow. Using the same display ID without setting the parent widgets will cause the display to be reinitialized every time an interactor is initialized), do not set the widgets (so the render windows would be in their own windows), and do not set TopLevelShell (each has its own top level shell already)

Definition at line 160 of file vtkXRenderWindowInteractor.h.

virtual void vtkXRenderWindowInteractor::GetMousePosition | ( | int * | x,
 |  | int * | y
 | ) | [virtual]

Re-defines virtual function to get mouse position by querying X-server.

Reimplemented from vtkRenderWindowInteractor.

XtIntervalId vtkXRenderWindowInteractor::AddTimeOut | ( | XtAppContext | app_context,
 |  | unsigned long | interval,
 |  | XtTimerCallbackProc | proc,
 |  | XtPointer | client_data
 | ) | [protected]

void vtkXRenderWindowInteractor::Timer | ( | XtPointer | client_data,
 |  | XtIntervalId * | id
 | ) | [protected]

void vtkXRenderWindowInteractor::Callback | ( | Widget | w,
 |  | XtPointer | client_data,
 |  | XEvent * | event,
 |  | Boolean * | ctd
 | ) | [protected]

Friends And Related Function Documentation

void vtkXRenderWindowInteractorCallback | ( | Widget | ,
 |  | XtPointer | ,
 |  | XEvent * | ,
 |  | Boolean * |
 | ) | [friend]

Functions that are used internally.

void vtkXRenderWindowInteractorTimer | ( | XtPointer | ,
 |  | XtIntervalId * |
 | ) | [friend]

Functions that are used internally.

Member Data Documentation

Display* vtkXRenderWindowInteractor::DisplayId [protected]

Definition at line 178 of file vtkXRenderWindowInteractor.h.

Window vtkXRenderWindowInteractor::WindowId [protected]

Definition at line 179 of file vtkXRenderWindowInteractor.h.

Widget vtkXRenderWindowInteractor::Top [protected]

Definition at line 180 of file vtkXRenderWindowInteractor.h.

int vtkXRenderWindowInteractor::OwnTop [protected]

Definition at line 181 of file vtkXRenderWindowInteractor.h.

XtAppContext vtkXRenderWindowInteractor::App [protected]

Definition at line 182 of file vtkXRenderWindowInteractor.h.

int vtkXRenderWindowInteractor::PositionBeforeStereo[2] [protected]

Definition at line 183 of file vtkXRenderWindowInteractor.h.

Widget vtkXRenderWindowInteractor::TopLevelShell [protected]

Definition at line 184 of file vtkXRenderWindowInteractor.h.

int vtkXRenderWindowInteractor::BreakLoopFlag [protected]

Definition at line 186 of file vtkXRenderWindowInteractor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXRenderWindowInteractor.h
Generated on Mon Mar 25 01:36:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXRenderWindowTclInteractor Class Reference

a TCL event driven interface for a RenderWindow. More...

#include <vtkXRenderWindowTclInteractor.h>

Inheritance diagram for vtkXRenderWindowTclInteractor:

[legend]
Collaboration diagram for vtkXRenderWindowTclInteractor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXRenderWindowTclInteractor, vtkRenderWindowInteractor)
void | PrintSelf (ostream &os, vtkIndent indent)
virtual void | Initialize ()
void | TerminateApp (void)
virtual void | Initialize (XtAppContext app)
virtual XtAppContext | GetApp ()
virtual void | Enable ()
virtual void | Disable ()
virtual void | Start ()
virtual void | UpdateSize (int, int)
virtual void | SetWidget (Widget)
Widget | GetWidget ()
virtual void | SetTopLevelShell (Widget)
Widget | GetTopLevelShell ()
int | CreateTimer (int timertype)
int | DestroyTimer (void)
virtual int | GetBreakLoopFlag ()
virtual void | SetBreakLoopFlag (int)

Static Public Methods

vtkXRenderWindowTclInteractor * | New ()

Protected Methods

vtkXRenderWindowTclInteractor ()
~vtkXRenderWindowTclInteractor ()

Protected Attributes

Widget | TopLevelShell
Display * | DisplayId
Window | WindowId
Widget | top
Widget | oldTop
XtAppContext | App
int | PositionBeforeStereo [2]
int | BreakLoopFlag

Friends

void | vtkXRenderWindowTclInteractorCallback (Widget, XtPointer, XEvent *, Boolean *)
void | vtkXRenderWindowTclInteractorTimer (XtPointer, XtIntervalId *)

Detailed Description

a TCL event driven interface for a RenderWindow.

Date:
2002/01/22 15:40:01
Revision:
1.21

vtkXRenderWindowTclInteractor is a convenience object that provides event bindings to common graphics functions. For example, camera and actor functions such as zoom-in/zoom-out, azimuth, roll, and pan. IT is one of the window system specific subclasses of vtkRenderWindowInteractor. Please see vtkRenderWindowInteractor documentation for event bindings.

See also:
vtkRenderWindowInteractor vtkXRenderWindow
Events:
vtkCommand::EnterEvent vtkCommand::LeftButtonReleaseEvent vtkCommand::TimerEvent vtkCommand::StartEvent vtkCommand::RightButtonReleaseEvent vtkCommand::RightButtonPressEvent vtkCommand::MiddleButtonPressEvent vtkCommand::CharEvent vtkCommand::MouseMoveEvent vtkCommand::MiddleButtonReleaseEvent vtkCommand::LeftButtonPressEvent
Created by:
  • Miller, Jim
Contributed by (if > 5%):
  • Miller, Jim (57%)
  • Martin, Ken (26%)

Definition at line 52 of file vtkXRenderWindowTclInteractor.h.

Constructor & Destructor Documentation

vtkXRenderWindowTclInteractor::vtkXRenderWindowTclInteractor ( ) [protected]

vtkXRenderWindowTclInteractor::~vtkXRenderWindowTclInteractor ( ) [protected]

Member Function Documentation

vtkXRenderWindowTclInteractor* vtkXRenderWindowTclInteractor::New ( ) [static]

Create an object with Debug turned off, modified time initialized to zero, and reference counting on.

Reimplemented from vtkRenderWindowInteractor.

vtkXRenderWindowTclInteractor::vtkTypeRevisionMacro | ( | vtkXRenderWindowTclInteractor | ,
 |  | vtkRenderWindowInteractor |
 | ) |

Reimplemented from vtkRenderWindowInteractor.

void vtkXRenderWindowTclInteractor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::Initialize ( void ) [virtual]

Initializes the event handlers without an XtAppContext. This is good for when you don't have a user interface, but you still want to have mouse interaction.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::Initialize ( XtAppContext app ) [virtual]

Initializes the event handlers using an XtAppContext that you have provided. This assumes that you want to own the event loop.

virtual XtAppContext vtkXRenderWindowTclInteractor::GetApp ( ) [virtual]

Initializes the event handlers using an XtAppContext that you have provided. This assumes that you want to own the event loop.

virtual void vtkXRenderWindowTclInteractor::Enable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::Disable ( ) [virtual]

Enable/Disable interactions. By default interactors are enabled when initialized. Initialize() must be called prior to enabling/disabling interaction. These methods are used when a window/widget is being shared by multiple renderers and interactors. This allows a "modal" display where one interactor is active when its data is to be displayed and all other interactors associated with the widget are disabled when their data is not displayed.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::Start ( void ) [virtual]

This will start up the X event loop and never return. If you call this method it will loop processing X events until the application is exited.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::UpdateSize | ( | int | x,
 |  | int | y
 | ) | [virtual]

This will start up the X event loop and never return. If you call this method it will loop processing X events until the application is exited.

Reimplemented from vtkRenderWindowInteractor.

virtual void vtkXRenderWindowTclInteractor::SetWidget ( Widget ) [virtual]

Specify the Xt widget to use for interaction. This method is one of a couple steps that are required for setting up a vtkRenderWindowInteractor as a widget inside of another user interface. You do not need to use this method if the render window will be a stand-alone window. This is only used when you want the render window to be a subwindow within a larger user interface. In that case, you must tell the render window what X display id to use, and then ask the render window what depth, visual and colormap it wants. Then, you must create an Xt TopLevelShell with those settings. Then you can create the rest of your user interface as a child of the TopLevelShell you created. Eventually, you will create a drawing area or some other widget to serve as the rendering window. You must use the SetWidget method to tell this Interactor about that widget. It's X and it's not terribly easy, but it looks cool.

Widget vtkXRenderWindowTclInteractor::GetWidget ( ) [inline]

Specify the Xt widget to use for interaction. This method is one of a couple steps that are required for setting up a vtkRenderWindowInteractor as a widget inside of another user interface. You do not need to use this method if the render window will be a stand-alone window. This is only used when you want the render window to be a subwindow within a larger user interface. In that case, you must tell the render window what X display id to use, and then ask the render window what depth, visual and colormap it wants. Then, you must create an Xt TopLevelShell with those settings. Then you can create the rest of your user interface as a child of the TopLevelShell you created. Eventually, you will create a drawing area or some other widget to serve as the rendering window. You must use the SetWidget method to tell this Interactor about that widget. It's X and it's not terribly easy, but it looks cool.

Definition at line 107 of file vtkXRenderWindowTclInteractor.h.

virtual void vtkXRenderWindowTclInteractor::SetTopLevelShell ( Widget ) [virtual]

This method will store the top level shell widget for the interactor. This method and the method invocation sequence applies for: * vtkRenderWindow-Interactor pair in a nested widget hierarchy * multiple vtkRenderWindow-Interactor pairs in the same top level shell It is not needed for: * vtkRenderWindow-Interactor pair as the direct child of a top level shell, * multiple vtkRenderWindow-Interactor pairs, each in its own top level shell. This method, along with EnterNotify event, changes the keyboard focus among the widgets/vtkRenderWindow(s) so the Interactor(s) can receive the proper keyboard events. The following calls need to be made: * vtkRenderWindow's display ID need to be set to the top level shell's display ID. * vtkXRenderWindowInteractor's Widget has to be set to the vtkRenderWindow's container widget. * vtkXRenderWindowInteractor's TopLevel has to be set to the top level shell widget. Note that the procedure for setting up render window in a widget needs to be followed. See vtkRenderWindowInteractor's SetWidget() method. If multiple vtkRenderWindow-Interactor pairs in SEPARATE windows are desired, do not set the display ID (Interactor will create them as needed. Alternatively, create and set distinct DisplayID for each vtkRenderWindow. Using the same display ID without setting the parent widgets will cause the display to be reinitialized every time an interactor is initialized), do not set the widgets (so the render windows would be in their own windows), and do not set TopLevelShell (each has its own top level shell already)

Widget vtkXRenderWindowTclInteractor::GetTopLevelShell ( ) [inline]

This method will store the top level shell widget for the interactor. This method and the method invocation sequence applies for: * vtkRenderWindow-Interactor pair in a nested widget hierarchy * multiple vtkRenderWindow-Interactor pairs in the same top level shell It is not needed for: * vtkRenderWindow-Interactor pair as the direct child of a top level shell, * multiple vtkRenderWindow-Interactor pairs, each in its own top level shell. This method, along with EnterNotify event, changes the keyboard focus among the widgets/vtkRenderWindow(s) so the Interactor(s) can receive the proper keyboard events. The following calls need to be made: * vtkRenderWindow's display ID need to be set to the top level shell's display ID. * vtkXRenderWindowInteractor's Widget has to be set to the vtkRenderWindow's container widget. * vtkXRenderWindowInteractor's TopLevel has to be set to the top level shell widget. Note that the procedure for setting up render window in a widget needs to be followed. See vtkRenderWindowInteractor's SetWidget() method. If multiple vtkRenderWindow-Interactor pairs in SEPARATE windows are desired, do not set the display ID (Interactor will create them as needed. Alternatively, create and set distinct DisplayID for each vtkRenderWindow. Using the same display ID without setting the parent widgets will cause the display to be reinitialized every time an interactor is initialized), do not set the widgets (so the render windows would be in their own windows), and do not set TopLevelShell (each has its own top level shell already)

Definition at line 137 of file vtkXRenderWindowTclInteractor.h.

int vtkXRenderWindowTclInteractor::CreateTimer ( int timertype ) [virtual]

X timer methods.

Reimplemented from vtkRenderWindowInteractor.

int vtkXRenderWindowTclInteractor::DestroyTimer ( void ) [virtual]

X timer methods.

Reimplemented from vtkRenderWindowInteractor.

void vtkXRenderWindowTclInteractor::TerminateApp ( void ) [virtual]

X Tcl specific application terminate.

Reimplemented from vtkRenderWindowInteractor.

virtual int vtkXRenderWindowTclInteractor::GetBreakLoopFlag ( ) [virtual]

Set this flag to break the event loop.

virtual void vtkXRenderWindowTclInteractor::SetBreakLoopFlag ( int ) [virtual]

Set this flag to break the event loop.

Friends And Related Function Documentation

void vtkXRenderWindowTclInteractorCallback | ( | Widget | ,
 |  | XtPointer | ,
 |  | XEvent * | ,
 |  | Boolean * |
 | ) | [friend]

Functions that are used internally.

void vtkXRenderWindowTclInteractorTimer | ( | XtPointer | ,
 |  | XtIntervalId * |
 | ) | [friend]

Functions that are used internally.

Member Data Documentation

Widget vtkXRenderWindowTclInteractor::TopLevelShell [protected]

Definition at line 167 of file vtkXRenderWindowTclInteractor.h.

Display* vtkXRenderWindowTclInteractor::DisplayId [protected]

Definition at line 169 of file vtkXRenderWindowTclInteractor.h.

Window vtkXRenderWindowTclInteractor::WindowId [protected]

Definition at line 170 of file vtkXRenderWindowTclInteractor.h.

Widget vtkXRenderWindowTclInteractor::top [protected]

Definition at line 171 of file vtkXRenderWindowTclInteractor.h.

Widget vtkXRenderWindowTclInteractor::oldTop [protected]

Definition at line 172 of file vtkXRenderWindowTclInteractor.h.

XtAppContext vtkXRenderWindowTclInteractor::App [protected]

Definition at line 173 of file vtkXRenderWindowTclInteractor.h.

int vtkXRenderWindowTclInteractor::PositionBeforeStereo[2] [protected]

Definition at line 174 of file vtkXRenderWindowTclInteractor.h.

int vtkXRenderWindowTclInteractor::BreakLoopFlag [protected]

Definition at line 176 of file vtkXRenderWindowTclInteractor.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXRenderWindowTclInteractor.h
Generated on Mon Mar 25 01:36:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXTextMapper Class Reference

2D Text annotation support for X. More...

#include <vtkXTextMapper.h>

Inheritance diagram for vtkXTextMapper:

[legend]
Collaboration diagram for vtkXTextMapper:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXTextMapper, vtkTextMapper)
void | SetFontSize (int size)
void | GetSize (vtkViewport *viewport, int size[2])

Static Public Methods

vtkXTextMapper * | New ()

Protected Methods

vtkXTextMapper ()
~vtkXTextMapper ()
void | DetermineSize (vtkViewport *viewport, int size[2])

Protected Attributes

Font | CurrentFont
vtkTimeStamp SizeMTime
int | Size [2]
int | ViewportSize [2]

Detailed Description

2D Text annotation support for X.

Date:
2002/01/22 15:40:03
Revision:
1.21

vtkXTextMapper provides 2D text annotation support for vtx under Xwindows. Normally the user should use vtktextMapper which in turn will use this class.

See also:
vtkTextMapper
Created by:
  • Martin, Ken
Contributed by (if > 5%):
  • Martin, Ken (77%)
  • Schroeder, Will (8%)
  • Miller, Jim (6%)
  • Law, Charles (5%)

Definition at line 51 of file vtkXTextMapper.h.

Constructor & Destructor Documentation

vtkXTextMapper::vtkXTextMapper ( ) [protected]

vtkXTextMapper::~vtkXTextMapper ( ) [inline, protected]

Definition at line 66 of file vtkXTextMapper.h.

Member Function Documentation

vtkXTextMapper::vtkTypeRevisionMacro | ( | vtkXTextMapper | ,
 |  | vtkTextMapper |
 | ) |

Reimplemented from vtkTextMapper.

Reimplemented in vtkXMesaTextMapper, and vtkXOpenGLTextMapper.

vtkXTextMapper* vtkXTextMapper::New ( ) [static]

Creates a new text mapper with Font size 12, bold off, italic off, and Arial font.

Reimplemented from vtkTextMapper.

Reimplemented in vtkXMesaTextMapper, and vtkXOpenGLTextMapper.

void vtkXTextMapper::SetFontSize ( int size ) [virtual]

Set the font size used by the mapper. If the font size is available, the code will use the nearest available size.

Reimplemented from vtkTextMapper.

void vtkXTextMapper::GetSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [virtual]

What is the size of the rectangle required to draw this mapper ?

Reimplemented from vtkTextMapper.

void vtkXTextMapper::DetermineSize | ( | vtkViewport * | viewport,
 |  | int | size[2]
 | ) | [protected]

Actually get the size of the rectangle.

Member Data Documentation

Font vtkXTextMapper::CurrentFont [protected]

Definition at line 71 of file vtkXTextMapper.h.

vtkTimeStamp vtkXTextMapper::SizeMTime [protected]

Definition at line 74 of file vtkXTextMapper.h.

int vtkXTextMapper::Size[2] [protected]

Definition at line 75 of file vtkXTextMapper.h.

int vtkXTextMapper::ViewportSize[2] [protected]

Definition at line 76 of file vtkXTextMapper.h.

The documentation for this class was generated from the following file:
  • Rendering/vtkXTextMapper.h
Generated on Mon Mar 25 01:36:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


vtkXYPlotActor Class Reference

generate an x-y plot from input dataset(s) or field data. More...

#include <vtkXYPlotActor.h>

Inheritance diagram for vtkXYPlotActor:

[legend]
Collaboration diagram for vtkXYPlotActor:

[legend]
List of all members.

Public Methods

vtkTypeRevisionMacro (vtkXYPlotActor, vtkActor2D)
void | PrintSelf (ostream &os, vtkIndent indent)
void | RemoveAllInputs ()
vtkDataSetCollection * GetInputList ()
void | AddDataObjectInput (vtkDataObject *in)
void | RemoveDataObjectInput (vtkDataObject *in)
void | SetPlotColor (int i, float r, float g, float b)
void | SetPlotColor (int i, const float color[3])
float * | GetPlotColor (int i)
void | SetPlotSymbol (int i, vtkPolyData *input)
vtkPolyData * | GetPlotSymbol (int i)
void | SetPlotLabel (int i, const char *label)
const char * | GetPlotLabel (int i)
virtual int | GetPlotCurvePoints ()
virtual void | SetPlotCurvePoints (int)
virtual void | PlotCurvePointsOn ()
virtual void | PlotCurvePointsOff ()
virtual int | GetPlotCurveLines ()
virtual void | SetPlotCurveLines (int)
virtual void | PlotCurveLinesOn ()
virtual void | PlotCurveLinesOff ()
void | SetPlotLines (int i, int)
int | GetPlotLines (int i)
void | SetPlotPoints (int i, int)
int | GetPlotPoints (int i)
void | ViewportToPlotCoordinate (vtkViewport *viewport, float &u, float &v)
void | PlotToViewportCoordinate (vtkViewport *viewport, float &u, float &v)
int | IsInPlot (vtkViewport *viewport, float u, float v)
unsigned long | GetMTime ()
void | ReleaseGraphicsResources (vtkWindow *)
void | AddInput (vtkDataSet *in, const char *arrayName, int component)
void | AddInput (vtkDataSet *in)
void | RemoveInput (vtkDataSet *in, const char *arrayName, int component)
void | RemoveInput (vtkDataSet *in)
void | SetPointComponent (int i, int comp)
int | GetPointComponent (int i)
virtual void | SetXValues (int)
virtual int | GetXValues ()
void | SetXValuesToIndex ()
void | SetXValuesToArcLength ()
void | SetXValuesToNormalizedArcLength ()
void | SetXValuesToValue ()
const char * | GetXValuesAsString ()
vtkDataObjectCollection * GetDataObjectInputList ()
virtual void | SetDataObjectPlotMode (int)
virtual int | GetDataObjectPlotMode ()
void | SetDataObjectPlotModeToRows ()
void | SetDataObjectPlotModeToColumns ()
const char * | GetDataObjectPlotModeAsString ()
void | SetDataObjectXComponent (int i, int comp)
int | GetDataObjectXComponent (int i)
void | SetDataObjectYComponent (int i, int comp)
int | GetDataObjectYComponent (int i)
virtual void | SetExchangeAxes (int)
virtual int | GetExchangeAxes ()
virtual void | ExchangeAxesOn ()
virtual void | ExchangeAxesOff ()
virtual void | SetReverseXAxis (int)
virtual int | GetReverseXAxis ()
virtual void | ReverseXAxisOn ()
virtual void | ReverseXAxisOff ()
virtual void | SetReverseYAxis (int)
virtual int | GetReverseYAxis ()
virtual void | ReverseYAxisOn ()
virtual void | ReverseYAxisOff ()
vtkLegendBoxActor * GetLegendBoxActor ()
vtkGlyphSource2D * GetGlyphSource ()
virtual void | SetTitle (const char *)
virtual char * | GetTitle ()
virtual void | SetXTitle (const char *)
virtual char * | GetXTitle ()
virtual void | SetYTitle (const char *)
virtual char * | GetYTitle ()
virtual void | SetXRange (float, float)
void | SetXRange (float[2])
virtual float * | GetXRange ()
virtual void | GetXRange (float data[2])
virtual void | SetYRange (float, float)
void | SetYRange (float[2])
virtual float * | GetYRange ()
virtual void | GetYRange (float data[2])
void | SetPlotRange (float xmin, float ymin, float xmax, float ymax)
virtual void | SetNumberOfXLabels (int)
virtual int | GetNumberOfXLabels ()
virtual void | SetNumberOfYLabels (int)
virtual int | GetNumberOfYLabels ()
void | SetNumberOfLabels (int num)
virtual void | SetLegend (int)
virtual int | GetLegend ()
virtual void | LegendOn ()
virtual void | LegendOff ()
virtual void | SetLegendPosition (float, float)
void | SetLegendPosition (float[2])
virtual float * | GetLegendPosition ()
virtual void | GetLegendPosition (float &, float &)
virtual void | GetLegendPosition (float[2])
virtual void | SetLegendPosition2 (float, float)
void | SetLegendPosition2 (float[2])
virtual float * | GetLegendPosition2 ()
virtual void | GetLegendPosition2 (float &, float &)
virtual void | GetLegendPosition2 (float[2])
virtual void | SetBold (int)
virtual int | GetBold ()
virtual void | BoldOn ()
virtual void | BoldOff ()
virtual void | SetItalic (int)
virtual int | GetItalic ()
virtual void | ItalicOn ()
virtual void | ItalicOff ()
virtual void | SetShadow (int)
virtual int | GetShadow ()
virtual void | ShadowOn ()
virtual void | ShadowOff ()
virtual void | SetLogx (int)
virtual int | GetLogx ()
virtual void | LogxOn ()
virtual void | LogxOff ()
virtual void | SetFontFamily (int)
virtual int | GetFontFamily ()
void | SetFontFamilyToArial ()
void | SetFontFamilyToCourier ()
void | SetFontFamilyToTimes ()
virtual void | SetLabelFormat (const char *)
virtual char * | GetLabelFormat ()
virtual void | SetBorder (int)
virtual int | GetBorder ()
virtual int | GetPlotPoints ()
virtual void | SetPlotPoints (int)
virtual void | PlotPointsOn ()
virtual void | PlotPointsOff ()
virtual int | GetPlotLines ()
virtual void | SetPlotLines (int)
virtual void | PlotLinesOn ()
virtual void | PlotLinesOff ()
virtual void | SetGlyphSize (float)
virtual float | GetGlyphSize ()
void | ViewportToPlotCoordinate (vtkViewport *viewport)
virtual void | SetPlotCoordinate (float, float)
void | SetPlotCoordinate (float[2])
virtual float * | GetPlotCoordinate ()
virtual void | GetPlotCoordinate (float &, float &)
virtual void | GetPlotCoordinate (float[2])
void | PlotToViewportCoordinate (vtkViewport *viewport)
virtual void | SetViewportCoordinate (float, float)
void | SetViewportCoordinate (float[2])
virtual float * | GetViewportCoordinate ()
virtual void | GetViewportCoordinate (float &, float &)
virtual void | GetViewportCoordinate (float[2])
int | RenderOpaqueGeometry (vtkViewport *)
int | RenderOverlay (vtkViewport *)
int | RenderTranslucentGeometry (vtkViewport *)

Static Public Methods

vtkXYPlotActor * | New ()

Protected Methods

vtkXYPlotActor ()
~vtkXYPlotActor ()
void | InitializeEntries ()
void | ComputeXRange (float range[2], float *lengths)
void | ComputeYRange (float range[2])
void | ComputeDORange (float xrange[2], float yrange[2], float *lengths)
virtual void | CreatePlotData (int *pos, int *pos2, float xRange[2], float yRange[2], float *norms, int numDS, int numDO)
void | PlaceAxes (vtkViewport *viewport, int *size, int pos[2], int pos2[2])
void | GenerateClipPlanes (int *pos, int *pos2)
float | ComputeGlyphScale (int i, int *pos, int *pos2)
void | ClipPlotData (int *pos, int *pos2, vtkPolyData *pd)
float * | TransformPoint (int pos[2], int pos2[2], float x[3], float xNew[3])

Protected Attributes

vtkDataSetCollection * InputList
char ** | SelectedInputScalars
vtkIntArray * SelectedInputScalarsComponent
vtkDataObjectCollection * DataObjectInputList
char * | Title
char * | XTitle
char * | YTitle
int | XValues
int | NumberOfXLabels
int | NumberOfYLabels
int | Bold
int | Italic
int | Shadow
int | FontFamily
int | Logx
char * | LabelFormat
float | XRange [2]
float | YRange [2]
float | XComputedRange [2]
float | YComputedRange [2]
int | Border
int | PlotLines
int | PlotPoints
int | PlotCurveLines
int | PlotCurvePoints
int | ExchangeAxes
int | ReverseXAxis
int | ReverseYAxis
vtkTextMapper * TitleMapper
vtkActor2D * TitleActor
vtkAxisActor2D * XAxis
vtkAxisActor2D * YAxis
float | ViewportCoordinate [2]
float | PlotCoordinate [2]
int | DataObjectPlotMode
vtkIntArray * XComponent
vtkIntArray * YComponent
vtkIntArray * LinesOn
vtkIntArray * PointsOn
int | NumberOfInputs
vtkPolyData ** PlotData
vtkGlyph2D ** PlotGlyph
vtkAppendPolyData ** PlotAppend
vtkPolyDataMapper2D ** PlotMapper
vtkActor2D ** PlotActor
int | Legend
float | LegendPosition [2]
float | LegendPosition2 [2]
vtkLegendBoxActor * LegendActor
vtkGlyphSource2D * GlyphSource
vtkPlanes * ClipPlanes
float | GlyphSize
int | CachedSize [2]
vtkTimeStamp BuildTime

Detailed Description

generate an x-y plot from input dataset(s) or field data.

Date:
2002/01/22 15:30:47
Revision:
1.19

vtkXYPlotActor creates an x-y plot of data from one or more input data sets or field data. The class plots dataset scalar values (y-axis) against the points (x-axis). The x-axis values are generated by taking the point ids, computing a cumulative arc length, or a normalized arc length. More than one input data set can be specified to generate multiple plots. Alternatively, if field data is supplied as input, the class plots one component against another. (The user must specify which component to use as the x-axis and which for the y-axis.)

To use this class to plot dataset(s), you must specify one or more input datasets containing scalar and point data. You'll probably also want to invoke a method to control how the point coordinates are converted into x values (by default point ids are used).

To use this class to plot field data, you must specify one or more input data objects with its associated field data. You'll also want to specify which component to use as the x-axis and which to use as the y-axis. Note that when plotting field data, the x and y values are used directly (i.e., there are no options to normalize the components).

Once you've set up the plot, you'll want to position it. The PositionCoordinate defines the lower-left location of the x-y plot (specified in normalized viewport coordinates) and the Position2Coordinate define the upper-right corner. (Note: the Position2Coordinate is relative to PositionCoordinate, so you can move the vtkXYPlotActor around the viewport by setting just the PositionCoordinate.) The combination of the two position coordinates specifies a rectangle in which the plot will lie.

Optional features include the ability to specify axes labels, label format, plot title, and control font properties and type. You can also manually specify the x and y plot ranges (by default they are computed automatically). The Border instance variable is used to create space between the boundary of the plot window (specified by PositionCoordinate and Position2Coordinate) and the plot itself.

There are several advanced features as well. You can assign per curve properties (such as color and a plot symbol). (Note that each input dataset and/or data object creates a single curve.) Another option is to add a plot legend that graphically indicates the correspondance between the curve, curve symbols, and the data source. You can also exchange the x and y axes if you prefer you plot orientation that way.

Warning:
If you are interested in plotting something other than scalar data, you can use the vtk data shuffling filters (e.g., vtkAttributeDataToFieldDataFilter snd vtkFieldDataToAttributeDataFilter) to convert the data into scalar data and/or points.
See also:
vtkActor2D vtkTextMapper vtkScalarBarActor vtkAxisActor2D vtkCubeAxesActor vtkAttributeDataToFieldDataFilter vtkFieldDataToAttributeDataFilter
Created by:
  • Schroeder, Will
Contributed by (if > 5%):
  • Schroeder, Will (64%)
  • Lee, Jeff (29%)
Examples:
vtkXYPlotActor (Examples)
Tests:
vtkXYPlotActor (Tests)

Definition at line 109 of file vtkXYPlotActor.h.

Constructor & Destructor Documentation

vtkXYPlotActor::vtkXYPlotActor ( ) [protected]

vtkXYPlotActor::~vtkXYPlotActor ( ) [protected]

Member Function Documentation

vtkXYPlotActor::vtkTypeRevisionMacro | ( | vtkXYPlotActor | ,
 |  | vtkActor2D |
 | ) |

Reimplemented from vtkActor2D.

void vtkXYPlotActor::PrintSelf | ( | ostream & | os,
 |  | vtkIndent | indent
 | ) | [virtual]

Methods invoked by print to print information about the object including superclasses. Typically not called by the user (use Print() instead) but used in the hierarchical print process to combine the output of several classes.

Reimplemented from vtkActor2D.

vtkXYPlotActor* vtkXYPlotActor::New ( ) [static]

Instantiate object with autorange computation; bold, italic, and shadows on; arial font family; the number of labels set to 5 for the x and y axes; a label format of "-#6.3g"; and x coordinates computed from point ids.

Reimplemented from vtkActor2D.

void vtkXYPlotActor::AddInput | ( | vtkDataSet * | in,
 |  | const char * | arrayName,
 |  | int | component
 | ) |

Add a dataset to the list of data to append. The array name specifies which point array to plot. If the array name is NULL, then the default scalars are used. The array can have multiple components, but only the first component is ploted.

void vtkXYPlotActor::AddInput ( vtkDataSet * in ) [inline]

Add a dataset to the list of data to append. The array name specifies which point array to plot. If the array name is NULL, then the default scalars are used. The array can have multiple components, but only the first component is ploted.

Definition at line 132 of file vtkXYPlotActor.h.

void vtkXYPlotActor::RemoveInput | ( | vtkDataSet * | in,
 |  | const char * | arrayName,
 |  | int | component
 | ) |

Remove a dataset from the list of data to append.

void vtkXYPlotActor::RemoveInput ( vtkDataSet * in ) [inline]

Remove a dataset from the list of data to append.

Definition at line 138 of file vtkXYPlotActor.h.

void vtkXYPlotActor::RemoveAllInputs ( )

This removes all of the data set inputs, but does not change the data object inputs.

vtkDataSetCollection* vtkXYPlotActor::GetInputList ( ) [inline]

Return the list of inputs to this filter.

Definition at line 146 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetPointComponent | ( | int | i,
 |  | int | comp
 | ) |

If plotting points by value, which component to use to determine the value. This sets a value per each input dataset (i.e., the ith dataset).

int vtkXYPlotActor::GetPointComponent ( int i )

If plotting points by value, which component to use to determine the value. This sets a value per each input dataset (i.e., the ith dataset).

virtual void vtkXYPlotActor::SetXValues ( int ) [virtual]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

virtual int vtkXYPlotActor::GetXValues ( ) [virtual]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

void vtkXYPlotActor::SetXValuesToIndex ( ) [inline]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

Definition at line 168 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetXValuesToArcLength ( ) [inline]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

Definition at line 169 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetXValuesToNormalizedArcLength ( ) [inline]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

Definition at line 170 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetXValuesToValue ( ) [inline]

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

Definition at line 172 of file vtkXYPlotActor.h.

const char* vtkXYPlotActor::GetXValuesAsString ( )

Specify how the independent (x) variable is computed from the points. The independent variable can be the scalar/point index (i.e., point id), the accumulated arc length along the points, the normalized arc length, or by component value. If plotting datasets (e.g., points), the value that is used is specified by the PointComponent ivar. (Note: these methods also control how field data is plotted. Field data is usually plotted by value or index, if plotting length 1-dimensional length measures are used.)

void vtkXYPlotActor::AddDataObjectInput ( vtkDataObject * in )

Add a dataset to the list of data to append.

void vtkXYPlotActor::RemoveDataObjectInput ( vtkDataObject * in )

Remove a dataset from the list of data to append.

vtkDataObjectCollection* vtkXYPlotActor::GetDataObjectInputList ( ) [inline]

Return the list of inputs to this filter.

Definition at line 189 of file vtkXYPlotActor.h.

virtual void vtkXYPlotActor::SetDataObjectPlotMode ( int ) [virtual]

Indicate whether to plot rows or columns. If plotting rows, then the dependent variables is taken from a specified row, versus rows (y).

virtual int vtkXYPlotActor::GetDataObjectPlotMode ( ) [virtual]

Indicate whether to plot rows or columns. If plotting rows, then the dependent variables is taken from a specified row, versus rows (y).

void vtkXYPlotActor::SetDataObjectPlotModeToRows ( ) [inline]

Indicate whether to plot rows or columns. If plotting rows, then the dependent variables is taken from a specified row, versus rows (y).

Definition at line 198 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetDataObjectPlotModeToColumns ( ) [inline]

Indicate whether to plot rows or columns. If plotting rows, then the dependent variables is taken from a specified row, versus rows (y).

Definition at line 200 of file vtkXYPlotActor.h.

const char* vtkXYPlotActor::GetDataObjectPlotModeAsString ( )

Indicate whether to plot rows or columns. If plotting rows, then the dependent variables is taken from a specified row, versus rows (y).

void vtkXYPlotActor::SetDataObjectXComponent | ( | int | i,
 |  | int | comp
 | ) |

Specify which component of the input data object to use as the independent variable for the ith input data object. (This ivar is ignored if plotting the index.) Note that the value is interpreted differently depending on DataObjectPlotMode. If the mode is Rows, then the value of DataObjectXComponent is the row number; otherwise it's the column number.

int vtkXYPlotActor::GetDataObjectXComponent ( int i )

Specify which component of the input data object to use as the independent variable for the ith input data object. (This ivar is ignored if plotting the index.) Note that the value is interpreted differently depending on DataObjectPlotMode. If the mode is Rows, then the value of DataObjectXComponent is the row number; otherwise it's the column number.

void vtkXYPlotActor::SetDataObjectYComponent | ( | int | i,
 |  | int | comp
 | ) |

Specify which component of the input data object to use as the dependent variable for the ith input data object. (This ivar is ignored if plotting the index.) Note that the value is interpreted differently depending on DataObjectPlotMode. If the mode is Rows, then the value of DataObjectYComponent is the row number; otherwise it's the column number.

int vtkXYPlotActor::GetDataObjectYComponent ( int i )

Specify which component of the input data object to use as the dependent variable for the ith input data object. (This ivar is ignored if plotting the index.) Note that the value is interpreted differently depending on DataObjectPlotMode. If the mode is Rows, then the value of DataObjectYComponent is the row number; otherwise it's the column number.

void vtkXYPlotActor::SetPlotColor | ( | int | i,
 |  | float | r,
 |  | float | g,
 |  | float | b
 | ) |

void vtkXYPlotActor::SetPlotColor | ( | int | i,
 |  | const float | color[3]
 | ) | [inline]

Definition at line 234 of file vtkXYPlotActor.h.

float* vtkXYPlotActor::GetPlotColor ( int i )

void vtkXYPlotActor::SetPlotSymbol | ( | int | i,
 |  | vtkPolyData * | input
 | ) |

vtkPolyData* vtkXYPlotActor::GetPlotSymbol ( int i )

void vtkXYPlotActor::SetPlotLabel | ( | int | i,
 |  | const char * | label
 | ) |

const char* vtkXYPlotActor::GetPlotLabel ( int i )

virtual int vtkXYPlotActor::GetPlotCurvePoints ( ) [virtual]

virtual void vtkXYPlotActor::SetPlotCurvePoints ( int ) [virtual]

virtual void vtkXYPlotActor::PlotCurvePointsOn ( ) [virtual]

virtual void vtkXYPlotActor::PlotCurvePointsOff ( ) [virtual]

virtual int vtkXYPlotActor::GetPlotCurveLines ( ) [virtual]

virtual void vtkXYPlotActor::SetPlotCurveLines ( int ) [virtual]

virtual void vtkXYPlotActor::PlotCurveLinesOn ( ) [virtual]

virtual void vtkXYPlotActor::PlotCurveLinesOff ( ) [virtual]

void vtkXYPlotActor::SetPlotLines | ( | int | i,
 |  | int |
 | ) |

int vtkXYPlotActor::GetPlotLines ( int i )

void vtkXYPlotActor::SetPlotPoints | ( | int | i,
 |  | int |
 | ) |

int vtkXYPlotActor::GetPlotPoints ( int i )

virtual void vtkXYPlotActor::SetExchangeAxes ( int ) [virtual]

Enable/Disable exchange of the x-y axes (i.e., what was x becomes y, and vice-versa). Exchanging axes affects the labeling as well.

virtual int vtkXYPlotActor::GetExchangeAxes ( ) [virtual]

Enable/Disable exchange of the x-y axes (i.e., what was x becomes y, and vice-versa). Exchanging axes affects the labeling as well.

virtual void vtkXYPlotActor::ExchangeAxesOn ( ) [virtual]

Enable/Disable exchange of the x-y axes (i.e., what was x becomes y, and vice-versa). Exchanging axes affects the labeling as well.

virtual void vtkXYPlotActor::ExchangeAxesOff ( ) [virtual]

Enable/Disable exchange of the x-y axes (i.e., what was x becomes y, and vice-versa). Exchanging axes affects the labeling as well.

virtual void vtkXYPlotActor::SetReverseXAxis ( int ) [virtual]

Normally the x-axis is plotted from minimum to maximum. Setting this instance variable causes the x-axis to be plotted from maximum to minimum. Note that boolean always applies to the x-axis even if ExchangeAxes is set.

virtual int vtkXYPlotActor::GetReverseXAxis ( ) [virtual]

Normally the x-axis is plotted from minimum to maximum. Setting this instance variable causes the x-axis to be plotted from maximum to minimum. Note that boolean always applies to the x-axis even if ExchangeAxes is set.

virtual void vtkXYPlotActor::ReverseXAxisOn ( ) [virtual]

Normally the x-axis is plotted from minimum to maximum. Setting this instance variable causes the x-axis to be plotted from maximum to minimum. Note that boolean always applies to the x-axis even if ExchangeAxes is set.

virtual void vtkXYPlotActor::ReverseXAxisOff ( ) [virtual]

Normally the x-axis is plotted from minimum to maximum. Setting this instance variable causes the x-axis to be plotted from maximum to minimum. Note that boolean always applies to the x-axis even if ExchangeAxes is set.

virtual void vtkXYPlotActor::SetReverseYAxis ( int ) [virtual]

Normally the y-axis is plotted from minimum to maximum. Setting this instance variable causes the y-axis to be plotted from maximum to minimum. Note that boolean always applies to the y-axis even if ExchangeAxes is set.

virtual int vtkXYPlotActor::GetReverseYAxis ( ) [virtual]

Normally the y-axis is plotted from minimum to maximum. Setting this instance variable causes the y-axis to be plotted from maximum to minimum. Note that boolean always applies to the y-axis even if ExchangeAxes is set.

virtual void vtkXYPlotActor::ReverseYAxisOn ( ) [virtual]

Normally the y-axis is plotted from minimum to maximum. Setting this instance variable causes the y-axis to be plotted from maximum to minimum. Note that boolean always applies to the y-axis even if ExchangeAxes is set.

virtual void vtkXYPlotActor::ReverseYAxisOff ( ) [virtual]

Normally the y-axis is plotted from minimum to maximum. Setting this instance variable causes the y-axis to be plotted from maximum to minimum. Note that boolean always applies to the y-axis even if ExchangeAxes is set.

vtkLegendBoxActor* vtkXYPlotActor::GetLegendBoxActor ( ) [inline]

Retrieve handles to the legend box and glyph source. This is useful if you would like to change the default behavior of the legend box or glyph source. For example, the default glyph can be changed from a line to a vertex plus line, etc.)

Definition at line 293 of file vtkXYPlotActor.h.

vtkGlyphSource2D* vtkXYPlotActor::GetGlyphSource ( ) [inline]

Retrieve handles to the legend box and glyph source. This is useful if you would like to change the default behavior of the legend box or glyph source. For example, the default glyph can be changed from a line to a vertex plus line, etc.)

Definition at line 295 of file vtkXYPlotActor.h.

virtual void vtkXYPlotActor::SetTitle ( const char * ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual char* vtkXYPlotActor::GetTitle ( ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual void vtkXYPlotActor::SetXTitle ( const char * ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual char* vtkXYPlotActor::GetXTitle ( ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual void vtkXYPlotActor::SetYTitle ( const char * ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual char* vtkXYPlotActor::GetYTitle ( ) [virtual]

Set/Get the title of the x-y plot, and the title along the x and y axes.

virtual void vtkXYPlotActor::SetXRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

void vtkXYPlotActor::SetXRange ( float [2] )

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

virtual float* vtkXYPlotActor::GetXRange ( ) [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

virtual void vtkXYPlotActor::GetXRange ( float data[2] ) [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

virtual void vtkXYPlotActor::SetYRange | ( | float | ,
 |  | float |
 | ) | [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

void vtkXYPlotActor::SetYRange ( float [2] )

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

virtual float* vtkXYPlotActor::GetYRange ( ) [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

virtual void vtkXYPlotActor::GetYRange ( float data[2] ) [virtual]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

void vtkXYPlotActor::SetPlotRange | ( | float | xmin,
 |  | float | ymin,
 |  | float | xmax,
 |  | float | ymax
 | ) | [inline]

Set the plot range (range of independent and dependent variables) to plot. Data outside of the range will be clipped. If the plot range of either the x or y variables is set to (v1,v2), where v1 == v2, then the range will be computed automatically. Note that the x-range values should be consistent with the way the independent variable is created (via INDEX, DISTANCE, or ARC_LENGTH).

Definition at line 321 of file vtkXYPlotActor.h.

virtual void vtkXYPlotActor::SetNumberOfXLabels ( int ) [virtual]

Set/Get the number of annotation labels to show along the x and y axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data. The convenience method SetNumberOfLables() sets the number of x and y labels to the same value.

virtual int vtkXYPlotActor::GetNumberOfXLabels ( ) [virtual]

Set/Get the number of annotation labels to show along the x and y axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data. The convenience method SetNumberOfLables() sets the number of x and y labels to the same value.

virtual void vtkXYPlotActor::SetNumberOfYLabels ( int ) [virtual]

Set/Get the number of annotation labels to show along the x and y axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data. The convenience method SetNumberOfLables() sets the number of x and y labels to the same value.

virtual int vtkXYPlotActor::GetNumberOfYLabels ( ) [virtual]

Set/Get the number of annotation labels to show along the x and y axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data. The convenience method SetNumberOfLables() sets the number of x and y labels to the same value.

void vtkXYPlotActor::SetNumberOfLabels ( int num ) [inline]

Set/Get the number of annotation labels to show along the x and y axes. This values is a suggestion: the number of labels may vary depending on the particulars of the data. The convenience method SetNumberOfLables() sets the number of x and y labels to the same value.

Definition at line 335 of file vtkXYPlotActor.h.

virtual void vtkXYPlotActor::SetLegend ( int ) [virtual]

Enable/Disable the creation of a legend. If on, the legend labels will be created automatically unless the per plot legend symbol has been set.

virtual int vtkXYPlotActor::GetLegend ( ) [virtual]

Enable/Disable the creation of a legend. If on, the legend labels will be created automatically unless the per plot legend symbol has been set.

virtual void vtkXYPlotActor::LegendOn ( ) [virtual]

Enable/Disable the creation of a legend. If on, the legend labels will be created automatically unless the per plot legend symbol has been set.

virtual void vtkXYPlotActor::LegendOff ( ) [virtual]

Enable/Disable the creation of a legend. If on, the legend labels will be created automatically unless the per plot legend symbol has been set.

virtual void vtkXYPlotActor::SetLegendPosition | ( | float | ,
 |  | float |
 | ) | [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

void vtkXYPlotActor::SetLegendPosition ( float [2] )

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual float* vtkXYPlotActor::GetLegendPosition ( ) [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::GetLegendPosition | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::GetLegendPosition ( float [2] ) [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::SetLegendPosition2 | ( | float | ,
 |  | float |
 | ) | [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

void vtkXYPlotActor::SetLegendPosition2 ( float [2] )

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual float* vtkXYPlotActor::GetLegendPosition2 ( ) [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::GetLegendPosition2 | ( | float & | ,
 |  | float & |
 | ) | [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::GetLegendPosition2 ( float [2] ) [virtual]

Use these methods to control the position of the legend. The variables LegendPosition and LegendPosition2 define the lower-left and upper-right position of the legend. The coordinates are expressed as normalized values with respect to the rectangle defined by PositionCoordinate and Position2Coordinate. Note that LegendPosition2 is relative to LegendPosition.

virtual void vtkXYPlotActor::SetBold ( int ) [virtual]

Enable/Disable bolding annotation text.

virtual int vtkXYPlotActor::GetBold ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkXYPlotActor::BoldOn ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkXYPlotActor::BoldOff ( ) [virtual]

Enable/Disable bolding annotation text.

virtual void vtkXYPlotActor::SetItalic ( int ) [virtual]

Enable/Disable italicizing annotation text.

virtual int vtkXYPlotActor::GetItalic ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkXYPlotActor::ItalicOn ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkXYPlotActor::ItalicOff ( ) [virtual]

Enable/Disable italicizing annotation text.

virtual void vtkXYPlotActor::SetShadow ( int ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual int vtkXYPlotActor::GetShadow ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkXYPlotActor::ShadowOn ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkXYPlotActor::ShadowOff ( ) [virtual]

Enable/Disable creating shadows on the annotation text. Shadows make the text easier to read.

virtual void vtkXYPlotActor::SetLogx ( int ) [virtual]

Enable/Disable plotting of Log of x-values.

virtual int vtkXYPlotActor::GetLogx ( ) [virtual]

Enable/Disable plotting of Log of x-values.

virtual void vtkXYPlotActor::LogxOn ( ) [virtual]

Enable/Disable plotting of Log of x-values.

virtual void vtkXYPlotActor::LogxOff ( ) [virtual]

Enable/Disable plotting of Log of x-values.

virtual void vtkXYPlotActor::SetFontFamily ( int ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

virtual int vtkXYPlotActor::GetFontFamily ( ) [virtual]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

void vtkXYPlotActor::SetFontFamilyToArial ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 396 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetFontFamilyToCourier ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 397 of file vtkXYPlotActor.h.

void vtkXYPlotActor::SetFontFamilyToTimes ( ) [inline]

Set/Get the font family for the annotation text. Three font types are available: Arial (VTK_ARIAL), Courier (VTK_COURIER), and Times (VTK_TIMES).

Definition at line 398 of file vtkXYPlotActor.h.

virtual void vtkXYPlotActor::SetLabelFormat ( const char * ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual char* vtkXYPlotActor::GetLabelFormat ( ) [virtual]

Set/Get the format with which to print the labels on the scalar bar.

virtual void vtkXYPlotActor::SetBorder ( int ) [virtual]

Set/Get the spacing between the plot window and the plot. The value is specified in pixels.

virtual int vtkXYPlotActor::GetBorder ( ) [virtual]

Set/Get the spacing between the plot window and the plot. The value is specified in pixels.

virtual int vtkXYPlotActor::GetPlotPoints ( ) [virtual]

Set/Get whether the points are rendered. The point size can be set in the property object. This is a global flag which affects the plot only if per curve symbols are not defined.

virtual void vtkXYPlotActor::SetPlotPoints ( int ) [virtual]

Set/Get whether the points are rendered. The point size can be set in the property object. This is a global flag which affects the plot only if per curve symbols are not defined.

virtual void vtkXYPlotActor::PlotPointsOn ( ) [virtual]

Set/Get whether the points are rendered. The point size can be set in the property object. This is a global flag which affects the plot only if per curve symbols are not defined.

virtual void vtkXYPlotActor::PlotPointsOff ( ) [virtual]

Set/Get whether the points are rendered. The point size can be set in the property object. This is a global flag which affects the plot only if per curve symbols are not defined.

virtual int vtkXYPlotActor::GetPlotLines ( ) [virtual]

Set/Get whether the lines are rendered. The line width can be set in the property object.

virtual void vtkXYPlotActor::SetPlotLines ( int ) [virtual]

Set/Get whether the lines are rendered. The line width can be set in the property object.

virtual void vtkXYPlotActor::PlotLinesOn ( ) [virtual]

Set/Get whether the lines are rendered. The line width can be set in the property object.

virtual void vtkXYPlotActor::PlotLinesOff ( ) [virtual]

Set/Get whether the lines are rendered. The line width can be set in the property object.

virtual void vtkXYPlotActor::SetGlyphSize ( float ) [virtual]

Set/Get the factor that controls how big glyphs are in the plot. The number is expressed as a fraction of the length of the diagonal of the plot bounding box.

virtual float vtkXYPlotActor::GetGlyphSize ( ) [virtual]

Set/Get the factor that controls how big glyphs are in the plot. The number is expressed as a fraction of the length of the diagonal of the plot bounding box.

void vtkXYPlotActor::ViewportToPlotCoordinate | ( | vtkViewport * | viewport,
 |  | float & | u,
 |  | float & | v
 | ) |

Given a position within the viewport used by the plot, return the the plot coordinates (XAxis value, YAxis value)

void vtkXYPlotActor::ViewportToPlotCoordinate ( vtkViewport * viewport )

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

virtual void vtkXYPlotActor::SetPlotCoordinate | ( | float | ,
 |  | float |
 | ) | [virtual]

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

void vtkXYPlotActor::SetPlotCoordinate ( float [2] )

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

virtual float* vtkXYPlotActor::GetPlotCoordinate ( ) [virtual]

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

virtual void vtkXYPlotActor::GetPlotCoordinate | ( | float & | ,
 |  | float & |
 | ) | [virtual]

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

virtual void vtkXYPlotActor::GetPlotCoordinate ( float [2] ) [virtual]

An alternate form of ViewportToPlotCoordinate() above. This method inputs the viewport coordinate pair (defined by the ivar ViewportCoordinate)and then stores them in the ivar PlotCoordinate.

void vtkXYPlotActor::PlotToViewportCoordinate | ( | vtkViewport * | viewport,
 |  | float & | u,
 |  | float & | v
 | ) |

Given a plot coordinate, return the viewpoint position

void vtkXYPlotActor::PlotToViewportCoordinate ( vtkViewport * viewport )

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

virtual void vtkXYPlotActor::SetViewportCoordinate | ( | float | ,
 |  | float |
 | ) | [virtual]

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

void vtkXYPlotActor::SetViewportCoordinate ( float [2] )

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

virtual float* vtkXYPlotActor::GetViewportCoordinate ( ) [virtual]

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

virtual void vtkXYPlotActor::GetViewportCoordinate | ( | float & | ,
 |  | float & |
 | ) | [virtual]

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

virtual void vtkXYPlotActor::GetViewportCoordinate ( float [2] ) [virtual]

An alternate form of PlotToViewportCoordinate() above. This method inputs the plot coordinate pair (defined in the ivar PlotCoordinate) and then stores them in the ivar ViewportCoordinate. (This method can be wrapped.)

int vtkXYPlotActor::IsInPlot | ( | vtkViewport * | viewport,
 |  | float | u,
 |  | float | v
 | ) |

Is the specified viewport position within the plot area (as opposed to the region used by the plot plus the labels)?

unsigned long vtkXYPlotActor::GetMTime ( ) [virtual]

Take into account the modified time of internal helper classes.

Reimplemented from vtkActor2D.

int vtkXYPlotActor::RenderOpaqueGeometry ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the x-y plot.

Reimplemented from vtkActor2D.

int vtkXYPlotActor::RenderOverlay ( vtkViewport * viewport ) [virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the x-y plot.

Reimplemented from vtkActor2D.

int vtkXYPlotActor::RenderTranslucentGeometry ( vtkViewport * viewport ) [inline, virtual]

WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the x-y plot.

Reimplemented from vtkActor2D.

Definition at line 478 of file vtkXYPlotActor.h.

void vtkXYPlotActor::ReleaseGraphicsResources ( vtkWindow * ) [virtual]

Release any graphics resources that are being consumed by this actor. The parameter window could be used to determine which graphic resources to release.

Reimplemented from vtkActor2D.

void vtkXYPlotActor::InitializeEntries ( ) [protected]

void vtkXYPlotActor::ComputeXRange | ( | float | range[2],
 |  | float * | lengths
 | ) | [protected]

void vtkXYPlotActor::ComputeYRange ( float range[2] ) [protected]

void vtkXYPlotActor::ComputeDORange | ( | float | xrange[2],
 |  | float | yrange[2],
 |  | float * | lengths
 | ) | [protected]

virtual void vtkXYPlotActor::CreatePlotData | ( | int * | pos,
 |  | int * | pos2,
 |  | float | xRange[2],
 |  | float | yRange[2],
 |  | float * | norms,
 |  | int | numDS,
 |  | int | numDO
 | ) | [protected, virtual]

void vtkXYPlotActor::PlaceAxes | ( | vtkViewport * | viewport,
 |  | int * | size,
 |  | int | pos[2],
 |  | int | pos2[2]
 | ) | [protected]

void vtkXYPlotActor::GenerateClipPlanes | ( | int * | pos,
 |  | int * | pos2
 | ) | [protected]

float vtkXYPlotActor::ComputeGlyphScale | ( | int | i,
 |  | int * | pos,
 |  | int * | pos2
 | ) | [protected]

void vtkXYPlotActor::ClipPlotData | ( | int * | pos,
 |  | int * | pos2,
 |  | vtkPolyData * | pd
 | ) | [protected]

float* vtkXYPlotActor::TransformPoint | ( | int | pos[2],
 |  | int | pos2[2],
 |  | float | x[3],
 |  | float | xNew[3]
 | ) | [protected]

Member Data Documentation

vtkDataSetCollection* vtkXYPlotActor::InputList [protected]

Definition at line 491 of file vtkXYPlotActor.h.

char** vtkXYPlotActor::SelectedInputScalars [protected]

Definition at line 492 of file vtkXYPlotActor.h.

vtkIntArray* vtkXYPlotActor::SelectedInputScalarsComponent [protected]

Definition at line 493 of file vtkXYPlotActor.h.

vtkDataObjectCollection* vtkXYPlotActor::DataObjectInputList [protected]

Definition at line 494 of file vtkXYPlotActor.h.

char* vtkXYPlotActor::Title [protected]

Definition at line 495 of file vtkXYPlotActor.h.

char* vtkXYPlotActor::XTitle [protected]

Definition at line 496 of file vtkXYPlotActor.h.

char* vtkXYPlotActor::YTitle [protected]

Definition at line 497 of file vtkXYPlotActor.h.

int vtkXYPlotActor::XValues [protected]

Definition at line 498 of file vtkXYPlotActor.h.

int vtkXYPlotActor::NumberOfXLabels [protected]

Definition at line 499 of file vtkXYPlotActor.h.

int vtkXYPlotActor::NumberOfYLabels [protected]

Definition at line 500 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Bold [protected]

Definition at line 501 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Italic [protected]

Definition at line 502 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Shadow [protected]

Definition at line 503 of file vtkXYPlotActor.h.

int vtkXYPlotActor::FontFamily [protected]

Definition at line 504 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Logx [protected]

Definition at line 505 of file vtkXYPlotActor.h.

char* vtkXYPlotActor::LabelFormat [protected]

Definition at line 506 of file vtkXYPlotActor.h.

float vtkXYPlotActor::XRange[2] [protected]

Definition at line 507 of file vtkXYPlotActor.h.

float vtkXYPlotActor::YRange[2] [protected]

Definition at line 508 of file vtkXYPlotActor.h.

float vtkXYPlotActor::XComputedRange[2] [protected]

Definition at line 509 of file vtkXYPlotActor.h.

float vtkXYPlotActor::YComputedRange[2] [protected]

Definition at line 510 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Border [protected]

Definition at line 511 of file vtkXYPlotActor.h.

int vtkXYPlotActor::PlotLines [protected]

Definition at line 512 of file vtkXYPlotActor.h.

int vtkXYPlotActor::PlotPoints [protected]

Definition at line 513 of file vtkXYPlotActor.h.

int vtkXYPlotActor::PlotCurveLines [protected]

Definition at line 514 of file vtkXYPlotActor.h.

int vtkXYPlotActor::PlotCurvePoints [protected]

Definition at line 515 of file vtkXYPlotActor.h.

int vtkXYPlotActor::ExchangeAxes [protected]

Definition at line 516 of file vtkXYPlotActor.h.

int vtkXYPlotActor::ReverseXAxis [protected]

Definition at line 517 of file vtkXYPlotActor.h.

int vtkXYPlotActor::ReverseYAxis [protected]

Definition at line 518 of file vtkXYPlotActor.h.

vtkTextMapper* vtkXYPlotActor::TitleMapper [protected]

Definition at line 520 of file vtkXYPlotActor.h.

vtkActor2D* vtkXYPlotActor::TitleActor [protected]

Definition at line 521 of file vtkXYPlotActor.h.

vtkAxisActor2D* vtkXYPlotActor::XAxis [protected]

Definition at line 523 of file vtkXYPlotActor.h.

vtkAxisActor2D* vtkXYPlotActor::YAxis [protected]

Definition at line 524 of file vtkXYPlotActor.h.

float vtkXYPlotActor::ViewportCoordinate[2] [protected]

Definition at line 526 of file vtkXYPlotActor.h.

float vtkXYPlotActor::PlotCoordinate[2] [protected]

Definition at line 527 of file vtkXYPlotActor.h.

int vtkXYPlotActor::DataObjectPlotMode [protected]

Definition at line 530 of file vtkXYPlotActor.h.

vtkIntArray* vtkXYPlotActor::XComponent [protected]

Definition at line 531 of file vtkXYPlotActor.h.

vtkIntArray* vtkXYPlotActor::YComponent [protected]

Definition at line 532 of file vtkXYPlotActor.h.

vtkIntArray* vtkXYPlotActor::LinesOn [protected]

Definition at line 533 of file vtkXYPlotActor.h.

vtkIntArray* vtkXYPlotActor::PointsOn [protected]

Definition at line 534 of file vtkXYPlotActor.h.

int vtkXYPlotActor::NumberOfInputs [protected]

Definition at line 539 of file vtkXYPlotActor.h.

vtkPolyData** vtkXYPlotActor::PlotData [protected]

Definition at line 540 of file vtkXYPlotActor.h.

vtkGlyph2D** vtkXYPlotActor::PlotGlyph [protected]

Definition at line 541 of file vtkXYPlotActor.h.

vtkAppendPolyData** vtkXYPlotActor::PlotAppend [protected]

Definition at line 542 of file vtkXYPlotActor.h.

vtkPolyDataMapper2D** vtkXYPlotActor::PlotMapper [protected]

Definition at line 543 of file vtkXYPlotActor.h.

vtkActor2D** vtkXYPlotActor::PlotActor [protected]

Definition at line 544 of file vtkXYPlotActor.h.

int vtkXYPlotActor::Legend [protected]

Definition at line 549 of file vtkXYPlotActor.h.

float vtkXYPlotActor::LegendPosition[2] [protected]

Definition at line 550 of file vtkXYPlotActor.h.

float vtkXYPlotActor::LegendPosition2[2] [protected]

Definition at line 551 of file vtkXYPlotActor.h.

vtkLegendBoxActor* vtkXYPlotActor::LegendActor [protected]

Definition at line 552 of file vtkXYPlotActor.h.

vtkGlyphSource2D* vtkXYPlotActor::GlyphSource [protected]

Definition at line 553 of file vtkXYPlotActor.h.

vtkPlanes* vtkXYPlotActor::ClipPlanes [protected]

Definition at line 554 of file vtkXYPlotActor.h.

float vtkXYPlotActor::GlyphSize [protected]

Definition at line 555 of file vtkXYPlotActor.h.

int vtkXYPlotActor::CachedSize[2] [protected]

Definition at line 558 of file vtkXYPlotActor.h.

vtkTimeStamp vtkXYPlotActor::BuildTime [protected]

Definition at line 559 of file vtkXYPlotActor.h.

The documentation for this class was generated from the following file:
  • Hybrid/vtkXYPlotActor.h
Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hierarchical Index

VTK Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • _vtkLink_s
  • _vtkLocalTri
  • _vtkLocalVertex
  • _vtkPriorityItem
  • _vtkProLocalTri
  • _vtkProLocalVertex
  • _vtkStreamPoint
  • _vtkTclVoidFuncArg
  • Camera
  • vtkCellType
  • Chunk
  • vtkCollectionElement
  • Colour
  • Colour_24
  • vtkCommand
    • vtkCallbackCommand
    • vtkJavaCommand
    • vtkOldStyleCallbackCommand
    • vtkPythonCommand
    • vtkTclCommand
  • vtkContainer
    • vtkAbstractList< DType >
  • vtkDataSetAttributes::FieldList
  • vtkErrorCode
  • Face
  • vtkFieldData::BasicIterator
    • vtkFieldData::Iterator
  • vtkFieldData::CopyFieldFlag
  • vtkHeapNode
  • vtkImageCanvasSource2DPixel
  • vtkImageConnectorSeed
  • vtkImageIterator< DType >
    • vtkImageProgressIterator< DType >
  • vtkIndent
  • vtkInstantiatorInitialize
  • istream
  • vtkJavaVoidFuncArg
  • vtkLargeInteger
  • List
  • vtkLODProp3DEntry
  • vtkMaskFields::CopyFieldFlag
  • Material
  • MatProp
  • vtkMergeFields::Component
  • Mesh
  • vtkMPICommunicator::Request
  • NSOpenGLView
    • vtkQuartzGLView
  • NSWindow
    • vtkQuartzWindow
  • vtkOBBNode
  • vtkObject
    • vtkAbstractPicker
      • vtkAbstractPropPicker
        • vtkPicker
          • vtkCellPicker
          • vtkPointPicker
        • vtkPropPicker
      • vtkWorldPointPicker
    • vtkAbstractTransform
      • vtkGeneralTransform
      • vtkHomogeneousTransform
        • vtkLinearTransform
          • vtkIdentityTransform
          • vtkIterativeClosestPointTransform
          • vtkLandmarkTransform
          • vtkMatrixToLinearTransform
          • vtkTransform
        • vtkMatrixToHomogeneousTransform
        • vtkPerspectiveTransform
      • vtkWarpTransform
        • vtkGridTransform
        • vtkThinPlateSplineTransform
    • vtkAssemblyNode
    • vtkByteSwap
    • vtkCamera
      • vtkMesaCamera
      • vtkOpenGLCamera
    • vtkCell
      • vtkCell3D
        • vtkHexahedron
        • vtkPyramid
        • vtkTetra
        • vtkVoxel
        • vtkWedge
      • vtkEmptyCell
      • vtkGenericCell
      • vtkLine
      • vtkNonLinearCell
        • vtkExplicitCell
        • vtkQuadraticEdge
      • vtkPixel
      • vtkPolygon
      • vtkPolyLine
      • vtkPolyVertex
      • vtkQuad
      • vtkTriangle
      • vtkTriangleStrip
      • vtkVertex
    • vtkCellArray
    • vtkCellLinks
    • vtkCellTypes
    • vtkCollection
      • vtkAssemblyPath
      • vtkAssemblyPaths
      • vtkCullerCollection
      • vtkDataObjectCollection
      • vtkDataSetCollection
      • vtkImagerCollection
      • vtkImageReader2Collection
      • vtkImplicitFunctionCollection
      • vtkLightCollection
      • vtkMapperCollection
      • vtkObjectFactoryCollection
      • vtkOverrideInformationCollection
      • vtkPlaneCollection
      • vtkPolyDataCollection
      • vtkPropCollection
        • vtkActor2DCollection
        • vtkActorCollection
        • vtkProp3DCollection
        • vtkVolumeCollection
      • vtkRendererCollection
      • vtkRenderWindowCollection
      • vtkStructuredPointsCollection
      • vtkTransformCollection
    • vtkCommunicator
      • vtkMPICommunicator
      • vtkSharedMemoryCommunicator
      • vtkSocketCommunicator
    • vtkCompositeManager
      • vtkTreeComposite
    • vtkContourValues
    • vtkCoordinate
    • vtkCriticalSection
    • vtkCuller
      • vtkFrustumCoverageCuller
    • vtkDataArray
      • vtkBitArray
      • vtkCharArray
      • vtkDoubleArray
      • vtkFloatArray
      • vtkIdTypeArray
      • vtkIntArray
      • vtkLongArray
      • vtkShortArray
      • vtkUnsignedCharArray
      • vtkUnsignedIntArray
      • vtkUnsignedLongArray
      • vtkUnsignedShortArray
      • vtkVoidArray
    • vtkDataObject
      • vtkDataSet
        • vtkImageData
          • vtkStructuredPoints
            • vtkImageCanvasSource2D
        • vtkPointSet
          • vtkPolyData
          • vtkStructuredGrid
          • vtkUnstructuredGrid
        • vtkRectilinearGrid
      • vtkImageStencilData
      • vtkPiecewiseFunction
    • vtkDebugLeaks
    • vtkDirectionEncoder
      • vtkRecursiveSphereDirectionEncoder
    • vtkDirectory
    • vtkDynamicLoader
    • vtkEdgeTable
    • vtkEncodedGradientEstimator
      • vtkFiniteDifferenceGradientEstimator
    • vtkEncodedGradientShader
    • vtkExporter
      • vtkIVExporter
      • vtkOBJExporter
      • vtkOOGLExporter
      • vtkRIBExporter
      • vtkVRMLExporter
    • vtkExtentTranslator
      • vtkBranchExtentTranslator
    • vtkFieldData
      • vtkDataSetAttributes
        • vtkCellData
        • vtkPointData
    • vtkFunctionParser
    • vtkFunctionSet
      • vtkInterpolatedVelocityField
    • vtkGraphicsFactory
    • vtkHeap
    • vtkIdList
    • vtkImageConnector
    • vtkImageReader2Factory
    • vtkImageViewer
    • vtkImageViewer2
    • vtkImagingFactory
    • vtkImplicitFunction
      • vtkCone
      • vtkCylinder
      • vtkImplicitBoolean
      • vtkImplicitDataSet
      • vtkImplicitSelectionLoop
      • vtkImplicitSum
      • vtkImplicitVolume
      • vtkImplicitWindowFunction
      • vtkPerlinNoise
      • vtkPlane
      • vtkPlanes
      • vtkQuadric
      • vtkSphere
      • vtkSuperquadric
    • vtkImporter
      • vtk3DSImporter
      • vtkVRMLImporter
    • vtkInitialValueProblemSolver
      • vtkRungeKutta2
      • vtkRungeKutta4
      • vtkRungeKutta45
    • vtkInstantiator
    • vtkInteractorStyle
      • vtkInteractorStyleFlight
      • vtkInteractorStyleImage
      • vtkInteractorStyleJoystickActor
      • vtkInteractorStyleJoystickCamera
      • vtkInteractorStyleSwitch
        • vtkInteractorStyleUser
      • vtkInteractorStyleTrackball
      • vtkInteractorStyleTrackballActor
      • vtkInteractorStyleTrackballCamera
      • vtkInteractorStyleUnicam
    • vtkLight
      • vtkMesaLight
      • vtkOpenGLLight
      • vtkRIBLight
    • vtkLightKit
    • vtkLocator
      • vtkCellLocator
        • vtkOBBTree
      • vtkPointLocator
        • vtkMergePoints
      • vtkPointLocator2D
        • vtkMergePoints2D
    • vtkMath
    • vtkMatrix4x4
    • vtkMPIEventLog
    • vtkMPIGroup
    • vtkMultiProcessController
      • vtkMPIController
      • vtkSocketController
      • vtkThreadedController
    • vtkMultiProcessLog
    • vtkMultiThreader
    • vtkMutexLock
    • vtkObjectFactory
      • vtkKitwareObjectFactory
      • vtkParallelFactory
    • vtkOrderedTriangulator
    • vtkOutputWindow
      • vtkFileOutputWindow
        • vtkXMLFileOutputWindow
      • vtkWin32OutputWindow
    • vtkOverrideInformation
    • vtkPipelineSize
    • vtkPoints
    • vtkPriorityQueue
    • vtkProcessObject
      • vtkAbstractMapper
        • vtkAbstractMapper3D
          • vtkMapper
            • vtkDataSetMapper
            • vtkPolyDataMapper
              • vtkMesaPolyDataMapper
              • vtkOpenGLPolyDataMapper
          • vtkVolumeMapper
            • vtkVolumeProMapper
              • vtkVolumeProVG500Mapper
                • vtkOpenGLVolumeProVG500Mapper
              • vtkVolumeProVP1000Mapper
                • vtkOpenGLVolumeProVP1000Mapper
            • vtkVolumeRayCastMapper
              • vtkMesaVolumeRayCastMapper
              • vtkOpenGLVolumeRayCastMapper
            • vtkVolumeTextureMapper
              • vtkVolumeTextureMapper2D
                • vtkMesaVolumeTextureMapper2D
                • vtkOpenGLVolumeTextureMapper2D
        • vtkMapper2D
          • vtkImageMapper
            • vtkMesaImageMapper
            • vtkOpenGLImageMapper
            • vtkQuartzImageMapper
            • vtkWin32ImageMapper
            • vtkXImageMapper
          • vtkLabeledDataMapper
          • vtkPolyDataMapper2D
            • vtkMesaPolyDataMapper2D
            • vtkOpenGLPolyDataMapper2D
            • vtkWin32PolyDataMapper2D
            • vtkXPolyDataMapper2D
          • vtkTextMapper
            • vtkQuartzTextMapper
            • vtkWin32TextMapper
              • vtkWin32OpenGLTextMapper
            • vtkXTextMapper
              • vtkXMesaTextMapper
              • vtkXOpenGLTextMapper
      • vtkImageBlockWriter
      • vtkImageExport
      • vtkImageWriter
        • vtkBMPWriter
        • vtkJPEGWriter
        • vtkPImageWriter
        • vtkPNGWriter
        • vtkPNMWriter
        • vtkPostScriptWriter
        • vtkTIFFWriter
      • vtkMassProperties
      • vtkOutputPort
      • vtkSource
        • vtkDataObjectSource
          • vtkDataSetToDataObjectFilter
        • vtkDataObjectToDataSetFilter
        • vtkDataReader
          • vtkDataObjectReader
          • vtkDataSetReader
          • vtkPolyDataReader
          • vtkRectilinearGridReader
          • vtkStructuredGridReader
          • vtkStructuredPointsReader
          • vtkUnstructuredGridReader
        • vtkDataSetSource
          • vtkDataSetToDataSetFilter
            • vtkArrayCalculator
            • vtkAssignAttribute
            • vtkAttributeDataToFieldDataFilter
            • vtkBrownianPoints
            • vtkCastToConcrete
            • vtkCellDataToPointData
              • vtkPCellDataToPointData
            • vtkCellDerivatives
            • vtkDicer
              • vtkOBBDicer
            • vtkElevationFilter
            • vtkExtractTensorComponents
            • vtkFieldDataToAttributeDataFilter
            • vtkIdFilter
            • vtkImplicitTextureCoords
            • vtkInterpolateDataSetAttributes
            • vtkMaskFields
            • vtkMergeDataObjectFilter
            • vtkMergeFields
            • vtkMergeFilter
            • vtkPieceScalars
            • vtkPointDataToCellData
            • vtkProbeFilter
            • vtkProgrammableAttributeDataFilter
            • vtkProgrammableFilter
            • vtkProjectedTexture
            • vtkRearrangeFields
            • vtkSimpleElevationFilter
            • vtkSplitField
            • vtkTextureMapToCylinder
            • vtkTextureMapToPlane
            • vtkTextureMapToSphere
            • vtkThresholdTextureCoords
            • vtkTransformTextureCoords
            • vtkVectorDot
            • vtkVectorNorm
          • vtkEnSightReader
            • vtkEnSight6BinaryReader
            • vtkEnSight6Reader
            • vtkEnSightGoldBinaryReader
            • vtkEnSightGoldReader
          • vtkGenericEnSightReader
        • vtkExtractVectorComponents
        • vtkImageSource
          • vtkDEMReader
          • vtkImageBlockReader
          • vtkImageEllipsoidSource
          • vtkImageGaussianSource
          • vtkImageGridSource
          • vtkImageImport
          • vtkImageMandelbrotSource
          • vtkImageMultipleInputFilter
            • vtkImageAppend
            • vtkImageAppendComponents
            • vtkImageBlend
            • vtkImageMultipleInputOutputFilter
            • vtkImageTwoInputFilter
              • vtkImageCheckerboard
              • vtkImageCorrelation
              • vtkImageDifference
              • vtkImageDotProduct
              • vtkImageLogic
              • vtkImageMask
              • vtkImageMathematics
              • vtkImageNonMaximumSuppression
          • vtkImageNoiseSource
          • vtkImageReader2
            • vtkImageReader
              • vtkBMPReader
              • vtkPNMReader
            • vtkJPEGReader
            • vtkMedicalImageReader2
              • vtkGESignaReader
            • vtkPNGReader
            • vtkSLCReader
            • vtkTIFFReader
          • vtkImageSinusoidSource
          • vtkImageToImageFilter
            • vtkImageAccumulate
            • vtkImageButterworthHighPass
            • vtkImageButterworthLowPass
            • vtkImageCacheFilter
            • vtkImageCast
            • vtkImageChangeInformation
            • vtkImageClip
            • vtkImageConvolve
            • vtkImageDataStreamer
              • vtkMemoryLimitImageDataStreamer
            • vtkImageDivergence
            • vtkImageEuclideanToPolar
            • vtkImageExtractComponents
            • vtkImageFlip
            • vtkImageGaussianSmooth
            • vtkImageGradient
            • vtkImageGradientMagnitude
            • vtkImageHSVToRGB
            • vtkImageIdealHighPass
            • vtkImageIdealLowPass
            • vtkImageInPlaceFilter
              • vtkImageCursor3D
            • vtkImageIslandRemoval2D
            • vtkImageIterateFilter
              • vtkImageDecomposeFilter
                • vtkImageCityBlockDistance
                • vtkImageEuclideanDistance
                • vtkImageFourierCenter
                • vtkImageFourierFilter
                  • vtkImageFFT
                  • vtkImageRFFT
                • vtkImageSeparableConvolution
              • vtkImageSkeleton2D
            • vtkImageLaplacian
            • vtkImageLogarithmicScale
            • vtkImageLuminance
            • vtkImageMagnify
            • vtkImageMagnitude
            • vtkImageMapToColors
              • vtkImageMapToRGBA
              • vtkImageMapToWindowLevelColors
            • vtkImageMaskBits
            • vtkImageNormalize
            • vtkImageOpenClose3D
            • vtkImagePadFilter
              • vtkImageConstantPad
              • vtkImageMirrorPad
              • vtkImageWrapPad
            • vtkImagePermute
            • vtkImageQuantizeRGBToIndex
            • vtkImageResample
            • vtkImageReslice
            • vtkImageRGBToHSV
            • vtkImageSeedConnectivity
            • vtkImageShiftScale
            • vtkImageShrink3D
            • vtkImageSpatialFilter
              • vtkImageAnisotropicDiffusion2D
              • vtkImageAnisotropicDiffusion3D
              • vtkImageContinuousDilate3D
              • vtkImageContinuousErode3D
              • vtkImageDilateErode3D
              • vtkImageHybridMedian2D
              • vtkImageMedian3D
              • vtkImageRange3D
              • vtkImageSobel2D
              • vtkImageSobel3D
              • vtkImageVariance3D
            • vtkImageStencil
            • vtkImageThreshold
            • vtkImageTranslateExtent
          • vtkRenderLargeImage
          • vtkRTAnalyticSource
          • vtkSimpleImageToImageFilter
            • vtkSimpleImageFilterExample
          • vtkTransformToGrid
          • vtkVideoSource
            • vtkMILVideoSource
            • vtkWin32VideoSource
          • vtkWindowToImageFilter
        • vtkImageStencilSource
          • vtkImageToImageStencil
          • vtkImplicitFunctionToImageStencil
          • vtkPolyDataToImageStencil
        • vtkImageToStructuredPoints
        • vtkInputPort
        • vtkPCAAnalysisFilter
        • vtkPDataSetReader
        • vtkPiecewiseFunctionSource
          • vtkPiecewiseFunctionToPiecewiseFunctionFilter
            • vtkPiecewiseFunctionShiftScale
        • vtkPointSetSource
          • vtkPointSetToPointSetFilter
            • vtkTransformFilter
            • vtkWarpLens
            • vtkWarpScalar
            • vtkWarpTo
            • vtkWarpVector
            • vtkWeightedTransformFilter
        • vtkPolyDataSource
          • vtkArrowSource
          • vtkAxes
          • vtkButtonSource
          • vtkBYUReader
          • vtkConeSource
          • vtkCubeSource
          • vtkCursor3D
          • vtkCylinderSource
          • vtkDataSetToPolyDataFilter
            • vtkCellCenters
            • vtkContourFilter
              • vtkKitwareContourFilter
            • vtkCutMaterial
            • vtkCutter
            • vtkDataSetSurfaceFilter
              • vtkPVGeometryFilter
            • vtkEdgePoints
            • vtkExtractEdges
            • vtkGeometryFilter
            • vtkGlyph3D
              • vtkGlyph2D
            • vtkHedgeHog
            • vtkHyperStreamline
            • vtkMarchingContourFilter
            • vtkMaskPoints
            • vtkOutlineCornerFilter
            • vtkOutlineFilter
            • vtkProgrammableGlyphFilter
            • vtkSelectVisiblePoints
            • vtkStreamer
              • vtkStreamLine
                • vtkDashedStreamLine
              • vtkStreamPoints
            • vtkTensorGlyph
            • vtkThresholdPoints
          • vtkDelaunay2D
          • vtkDiskSource
          • vtkEarthSource
          • vtkGlyphSource2D
          • vtkImageMarchingCubes
          • vtkLineSource
          • vtkMarchingSquares
          • vtkMCubesReader
          • vtkOBJReader
          • vtkOutlineSource
            • vtkOutlineCornerSource
          • vtkParticleReader
          • vtkPlaneSource
          • vtkPLYReader
          • vtkPointSource
          • vtkPolyDataToPolyDataFilter
            • vtkAppendPolyData
            • vtkApproximatingSubdivisionFilter
              • vtkLoopSubdivisionFilter
            • vtkArcPlotter
            • vtkBandedPolyDataContourFilter
            • vtkCleanPolyData
              • vtkQuantizePolyDataPoints
            • vtkClipPolyData
            • vtkDecimate
            • vtkDecimatePro
            • vtkDepthSortPolyData
            • vtkExtractPolyDataGeometry
            • vtkExtractPolyDataPiece
            • vtkFeatureEdges
            • vtkGLUTesselatorTriangleFilter
            • vtkGraphLayoutFilter
            • vtkHull
            • vtkInterpolatingSubdivisionFilter
              • vtkButterflySubdivisionFilter
              • vtkLinearSubdivisionFilter
            • vtkLinearExtrusionFilter
              • vtkPLinearExtrusionFilter
            • vtkMaskPolyData
            • vtkPolyDataConnectivityFilter
            • vtkPolyDataNormals
              • vtkPPolyDataNormals
            • vtkPolyDataStreamer
            • vtkQuadricClustering
            • vtkQuadricDecimation
            • vtkReflectionFilter
            • vtkReverseSense
            • vtkRibbonFilter
            • vtkRotationalExtrusionFilter
            • vtkRuledSurfaceFilter
            • vtkSelectPolyData
            • vtkShrinkPolyData
            • vtkSmoothPolyDataFilter
            • vtkStripper
            • vtkSubPixelPositionEdgels
            • vtkTransformPolyDataFilter
            • vtkTransmitPolyDataPiece
            • vtkTriangleFilter
            • vtkTriangularTCoords
            • vtkTubeFilter
            • vtkVoxelContoursToSurfaceFilter
            • vtkWindowedSincPolyDataFilter
          • vtkRectilinearGridToPolyDataFilter
            • vtkRectilinearGridGeometryFilter
            • vtkRectilinearGridOutlineFilter
          • vtkSpatialRepresentationFilter
          • vtkSpherePuzzle
          • vtkSpherePuzzleArrows
          • vtkSphereSource
            • vtkPSphereSource
          • vtkSTLReader
          • vtkStructuredGridToPolyDataFilter
            • vtkGridSynchronizedTemplates3D
            • vtkStructuredGridGeometryFilter
            • vtkStructuredGridOutlineFilter
          • vtkStructuredPointsToPolyDataFilter
            • vtkDividingCubes
            • vtkImageDataGeometryFilter
              • vtkStructuredPointsGeometryFilter
            • vtkImageToPolyDataFilter
            • vtkLinkEdgels
            • vtkMarchingCubes
            • vtkRecursiveDividingCubes
          • vtkSuperquadricSource
          • vtkSynchronizedTemplates2D
          • vtkSynchronizedTemplates3D
          • vtkTextSource
          • vtkTexturedSphereSource
          • vtkUGFacetReader
          • vtkUnstructuredGridToPolyDataFilter
            • vtkContourGrid
          • vtkVectorText
        • vtkProcrustesAlignmentFilter
        • vtkProgrammableDataObjectSource
        • vtkProgrammableSource
        • vtkRectilinearGridSource
        • vtkStructuredGridSource
          • vtkDataSetToStructuredGridFilter
          • vtkPLOT3DReader
          • vtkPOPReader
          • vtkStructuredGridToStructuredGridFilter
            • vtkBlankStructuredGrid
            • vtkBlankStructuredGridWithImage
            • vtkExtractGrid
        • vtkStructuredPointsSource
          • vtkBooleanTexture
          • vtkDataSetToStructuredPointsFilter
            • vtkGaussianSplatter
            • vtkImplicitModeller
            • vtkShepardMethod
            • vtkSurfaceReconstructionFilter
            • vtkVoxelModeller
          • vtkPointLoad
          • vtkRendererSource
          • vtkSampleFunction
          • vtkStructuredPointsToStructuredPointsFilter
            • vtkExtractVOI
            • vtkSweptSurface
          • vtkTriangularTexture
          • vtkVolumeReader
            • vtkVolume16Reader
        • vtkUnstructuredGridSource
          • vtkDataSetToUnstructuredGridFilter
            • vtkAppendFilter
            • vtkClipDataSet
            • vtkConnectivityFilter
            • vtkDataSetTriangleFilter
            • vtkExtractGeometry
            • vtkShrinkFilter
            • vtkThreshold
          • vtkDelaunay3D
          • vtkStructuredPointsToUnstructuredGridFilter
            • vtkClipVolume
          • vtkUnstructuredGridToUnstructuredGridFilter
            • vtkExtractUnstructuredGrid
            • vtkExtractUnstructuredGridPiece
            • vtkSubdivideTetra
            • vtkTransmitUnstructuredGridPiece
      • vtkTexture
        • vtkMesaTexture
        • vtkOpenGLTexture
      • vtkWriter
        • vtkDataObjectWriter
        • vtkDataWriter
          • vtkDataSetWriter
            • vtkPDataSetWriter
          • vtkPolyDataWriter
            • vtkBYUWriter
            • vtkCGMWriter
            • vtkIVWriter
            • vtkMCubesWriter
            • vtkPLYWriter
            • vtkSTLWriter
          • vtkRectilinearGridWriter
          • vtkStructuredGridWriter
          • vtkStructuredPointsWriter
          • vtkUnstructuredGridWriter
    • vtkProcessStatistics
    • vtkProp
      • vtkActor2D
        • vtkAxisActor2D
        • vtkCaptionActor2D
        • vtkCubeAxesActor2D
        • vtkLegendBoxActor
        • vtkParallelCoordinatesActor
        • vtkScalarBarActor
        • vtkScaledTextActor
        • vtkXYPlotActor
      • vtkImageActor
        • vtkMesaImageActor
        • vtkOpenGLImageActor
      • vtkProp3D
        • vtkActor
          • vtkFollower
          • vtkLODActor
          • vtkMesaActor
          • vtkOpenGLActor
        • vtkAssembly
        • vtkLODProp3D
        • vtkVolume
      • vtkPropAssembly
    • vtkProperty
      • vtkMesaProperty
      • vtkOpenGLProperty
      • vtkRIBProperty
    • vtkProperty2D
    • vtkRayCaster
    • vtkReferenceCount
    • vtkRenderWindowInteractor
      • vtkQuartzRenderWindowInteractor
      • vtkWin32RenderWindowInteractor
      • vtkXRenderWindowInteractor
      • vtkXRenderWindowTclInteractor
    • vtkScalarsToColors
      • vtkColorTransferFunction
      • vtkLookupTable
        • vtkLogLookupTable
        • vtkWindowLevelLookupTable
    • vtkScalarTree
      • vtkSimpleScalarTree
    • vtkSliceCubes
    • vtkSpline
      • vtkCardinalSpline
      • vtkKochanekSpline
    • vtkStructuredData
    • vtkTensor
    • vtkThreadSafeLog
    • vtkTimerLog
    • vtkVersion
    • vtkViewport
      • vtkImager
        • vtkMesaImager
        • vtkOpenGLImager
      • vtkRenderer
        • vtkMesaRenderer
        • vtkOpenGLRenderer
    • vtkVolumeProperty
    • vtkVolumeRayCastFunction
      • vtkVolumeRayCastCompositeFunction
      • vtkVolumeRayCastIsosurfaceFunction
      • vtkVolumeRayCastMIPFunction
    • vtkWindow
      • vtkImageWindow
        • vtkQuartzImageWindow
        • vtkWin32ImageWindow
        • vtkWin32OpenGLImageWindow
        • vtkXImageWindow
          • vtkMesaImageWindow
          • vtkOpenGLImageWindow
      • vtkRenderWindow
        • vtkMesaRenderWindow
          • vtkXMesaRenderWindow
        • vtkOpenGLRenderWindow
          • vtkWin32OpenGLRenderWindow
          • vtkWinCEOpenGLRenderWindow
          • vtkXOpenGLRenderWindow
        • vtkQuartzRenderWindow
    • vtkXMLParser
  • vtkObjectFactory::OverrideInformation
  • ofstream
  • OmniLight
  • vtkOpenGLStateCache
  • ostream
  • ostrhelp
  • ostrstream
  • OtherData
  • OtherElem
  • vtkOutputWindowSmartPointer
  • vtkPLY
  • PlyElement
  • PlyFile
  • PlyOtherElems
  • PlyOtherProp
  • PlyProperty
  • vtkProTriArray
  • vtkProVertexArray
  • PyVTKClass
  • PyVTKObject
  • PyVTKSpecialObject
  • vtkRayCastStructures
  • vtkRearrangeFields::Operation
  • SetGet
  • vtkSimpleCriticalSection
  • vtkSimpleMutexLock
  • vtkSplitField::Component
  • SpotLight
  • vtkStreamArray
  • Summary
  • vtkSystemIncludes
  • vtkTclCommandArgStruct
  • vtkTclCommandStruct
  • vtkTclInterpStruct
  • ThreadInfoStruct
  • vtkTimerLogEntry
  • vtkTimeStamp
  • vtkTkImageViewerWidget
  • vtkTkImageWindowWidget
  • vtkTkRenderWidget
  • vtkTransformConcatenation
  • vtkTransformConcatenationStack
  • vtkTransformPair
  • vtkTriArray
  • VectorType< T >
  • vtkVertexArray
  • vtkVolumeRayCastStructures
  • vtkVRMLAllocator
  • VTK_ERROR_QUADRIC
  • VTK_LINE_CASES
  • VTK_POINT_QUADRIC
  • VTK_TRIANGLE_CASES
  • VTKRayCastRayInfo
  • VTKRayCastVolumeInfo
  • VTKVRCDynamicInfo
  • VTKVRCStaticInfo
  • vtkWin32Header
  • vtkWinCE
Generated on Mon Mar 25 01:15:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Compound Member Index

VTK Compound Members

a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z | ~

Here is a list of all class members with links to the class documentation for each member:

- a -

  • A : vtkRungeKutta45
  • a : Face
  • AAFrames : vtkRenderWindow
  • AbortCheckEvent : vtkCommand
  • AbortCheckMethod : vtkRenderWindow
  • AbortCheckMethodArg : vtkRenderWindow
  • AbortCheckMethodArgDelete : vtkRenderWindow
  • AbortExecute : vtkProcessObject
  • AbortExecuteOff() : vtkProcessObject
  • AbortExecuteOn() : vtkProcessObject
  • AbortFlag : vtkCommand
  • AbortRender : vtkRenderWindow
  • Absolute : vtkWarpTo
  • AbsoluteError : vtkDecimatePro
  • AbsoluteOff() : vtkWarpTo
  • AbsoluteOn() : vtkWarpTo
  • AbsoluteTolerance : vtkCleanPolyData
  • aCamera : Camera
  • AccumulateError : vtkDecimatePro
  • AccumulateErrorOff() : vtkDecimatePro
  • AccumulateErrorOn() : vtkDecimatePro
  • AccumulationBuffer : vtkRenderWindow
  • AccumulationBufferSize : vtkRenderWindow
  • AccumulationMode : vtkGaussianSplatter
  • AccuracyCode : vtkDEMReader
  • aCellArray : Mesh
  • Active : vtkMPIEventLog, vtkSpherePuzzle
  • ActiveCamera : vtkRenderer
  • ActiveComponent : vtkImageMapToColors
  • ActiveFlag : ThreadInfoStruct
  • ActiveFlagLock : ThreadInfoStruct
  • Actor2D : vtkImageViewer
  • ActorMode : vtkRenderWindowInteractor, vtkInteractorStyleTrackball
  • Actors : vtkRenderer, vtkPicker
  • Actors2D : vtkViewport
  • Adaptive : vtkInitialValueProblemSolver
  • Add() : vtkHeap
  • add_comment() : vtkPLY
  • add_element() : vtkPLY
  • add_obj_info() : vtkPLY
  • add_property() : vtkPLY
  • AddActor() : vtkRenderer
  • AddActor2D() : vtkViewport
  • AddArray() : vtkPOPReader, vtkFieldData
  • AddArrayName() : vtkPOPReader
  • AddCellReference() : vtkPolyData, vtkCellLinks
  • AddClippingPlane() : vtkAbstractMapper
  • AddComplexVariableDescription() : vtkGenericEnSightReader
  • AddComplexVariableType() : vtkGenericEnSightReader
  • AddComponent() : vtkSplitField, vtkMergeFields, vtkTensor
  • AddConsumer() : vtkProp, vtkDataObject, vtkAbstractMapper
  • AddCubeEdgePlanes() : vtkHull
  • AddCubeFacePlanes() : vtkHull
  • AddCubeVertexPlanes() : vtkHull
  • AddCuller() : vtkRenderer
  • AddDataObjectInput() : vtkXYPlotActor
  • AddEdge() : vtkQuadricClustering
  • AddEdges() : vtkQuadricClustering
  • AddEntry() : vtkThreadSafeLog
  • AddEstimatedRenderTime() : vtkLODProp3D, vtkProp
  • AddField() : vtkMergeFilter
  • AddFunction() : vtkPLOT3DReader, vtkImplicitSum, vtkImplicitBoolean
  • AddGhostLevel() : vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • AddHSVPoint() : vtkColorTransferFunction
  • AddHSVSegment() : vtkColorTransferFunction
  • AddImager() : vtkImageWindow
  • AddInput() : vtkXYPlotActor, vtkProgrammableAttributeDataFilter, vtkInterpolateDataSetAttributes, vtkAppendPolyData, vtkAppendFilter, vtkImageMultipleInputFilter, vtkProcessObject
  • AddInputValues : vtkWeightedTransformFilter
  • AddInputValuesOff() : vtkWeightedTransformFilter
  • AddInputValuesOn() : vtkWeightedTransformFilter
  • AddInternalByte() : vtkFunctionParser
  • AddItem() : vtkVolumeCollection, vtkRenderWindowCollection, vtkRendererCollection, vtkProp3DCollection, vtkMapperCollection, vtkLightCollection, vtkImagerCollection, vtkCullerCollection, vtkActorCollection, vtkImageReader2Collection, vtkStructuredPointsCollection, vtkPolyDataCollection, vtkTransformCollection, vtkPropCollection, vtkPlaneCollection, vtkOverrideInformationCollection, vtkObjectFactoryCollection, vtkImplicitFunctionCollection, vtkDataSetCollection, vtkDataObjectCollection, vtkCollection, vtkAssemblyPaths, vtkActor2DCollection
  • AddLight() : vtkRenderer
  • AddLightsToRenderer() : vtkLightKit
  • AddLineToLineList() : vtkVoxelContoursToSurfaceFilter
  • AddLocatorPoint() : vtkImageMarchingCubes
  • AddLOD() : vtkLODProp3D
  • AddLODMapper() : vtkLODActor
  • AddMessage() : vtkSharedMemoryCommunicator
  • AddNode() : vtkAssemblyPath
  • AddObserver() : vtkObject
  • AddOperation() : vtkRearrangeFields
  • AddOrientation() : vtkProp3D
  • AddOutput() : vtkSource
  • AddParameter() : vtkRIBProperty
  • AddPart() : vtkAssembly, vtkPropAssembly
  • AddPickList() : vtkAbstractPicker
  • AddPlane() : vtkHull
  • AddPoint() : vtkSpline, vtkPiecewiseFunction
  • AddPolygons() : vtkQuadricClustering
  • AddPosition() : vtkProp3D, vtkTransformTextureCoords
  • AddProcessId() : vtkMPIGroup
  • AddProp() : vtkViewport
  • AddQuadric() : vtkQuadricDecimation, vtkQuadricClustering
  • AddRecursiveSpherePlanes() : vtkHull
  • AddReferenceToCell() : vtkUnstructuredGrid, vtkPolyData
  • AddRenderer() : vtkRenderWindow
  • AddRGBPoint() : vtkColorTransferFunction
  • AddRGBSegment() : vtkColorTransferFunction
  • AddRMI() : vtkMultiProcessController
  • AddScalarArrayName() : vtkArrayCalculator
  • AddScalarVariable() : vtkArrayCalculator
  • AddSeed() : vtkImageSeedConnectivity, vtkImageConnector, vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • AddSeedToEnd() : vtkImageConnector
  • AddSegment() : vtkPiecewiseFunction
  • AddSpecifiedRegion() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • AddTetras() : vtkOrderedTriangulator
  • AddText() : vtkWin32OutputWindow
  • AddTimeOut() : vtkXRenderWindowInteractor
  • AddTriangle() : vtkQuadricClustering
  • AddTriangles() : vtkQuadricClustering
  • AddVariable() : vtkRIBProperty
  • AddVariableDescription() : vtkGenericEnSightReader, vtkEnSightReader
  • AddVariableFileName() : vtkEnSightReader
  • AddVariableType() : vtkGenericEnSightReader, vtkEnSightReader
  • AddVectorArrayName() : vtkArrayCalculator
  • AddVectorVariable() : vtkArrayCalculator
  • AddVertex() : vtkQuadricClustering
  • AddVertices() : vtkQuadricClustering
  • AddVolume() : vtkRenderer
  • Adjoint() : vtkMatrix4x4
  • AdjustAxes() : vtkCubeAxesActor2D
  • AdjustBounds : vtkSweptSurface, vtkImplicitModeller
  • AdjustBoundsOff() : vtkSweptSurface, vtkImplicitModeller
  • AdjustBoundsOn() : vtkSweptSurface, vtkImplicitModeller
  • AdjustDistance : vtkSweptSurface, vtkImplicitModeller
  • AdjustLabels : vtkAxisActor2D
  • AdjustLabelsOff() : vtkAxisActor2D
  • AdjustLabelsOn() : vtkAxisActor2D
  • AdjustSpacingAndOrigin() : vtkVolume16Reader
  • AdjustViewport() : vtkPerspectiveTransform
  • AdjustZBuffer() : vtkPerspectiveTransform
  • AdvanceFrameBuffer() : vtkVideoSource
  • Algorithm : vtkImageEuclideanDistance
  • aLight : SpotLight, OmniLight
  • Allocate() : vtkVoidArray, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPriorityQueue, vtkPolyData, vtkPoints, vtkLookupTable, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkCellTypes, vtkCellLinks, vtkCellArray, vtkBitArray
  • AllocateArrays() : vtkFieldData
  • Allocated : VectorType< T >
  • AllocateDirectColorMap() : vtkXImageWindow
  • AllocatedRenderTime : vtkRenderer, vtkProp
  • AllocateExtents() : vtkImageStencilData
  • AllocateLinks() : vtkCellLinks
  • AllocateLog() : vtkTimerLog
  • AllocateMemory() : vtkVRMLAllocator, vtkHeap
  • AllocateMILBuffer() : vtkMILVideoSource
  • AllocateMILDigitizer() : vtkMILVideoSource
  • AllocateOutputData() : vtkImageStencilSource, vtkImageSource
  • AllocateOutputScalars() : vtkImageIterateFilter, vtkImageEuclideanDistance, vtkImageCityBlockDistance
  • AllocatePointVisibility() : vtkStructuredGrid
  • AllocateScalars() : vtkImageData
  • AllocateTime() : vtkRenderer
  • AllOff() : vtkCursor3D
  • AllOn() : vtkCursor3D
  • AllowShift : vtkImageDifference
  • AllowShiftOff() : vtkImageDifference
  • AllowShiftOn() : vtkImageDifference
  • AllScalars : vtkThreshold
  • AllScalarsOff() : vtkThreshold
  • AllScalarsOn() : vtkThreshold
  • Alpha : vtkPLOT3DReader, vtkDelaunay3D, vtkDelaunay2D, vtkScalarsToColors
  • AlphaFunc_bucket : vtkOpenGLStateCache
  • AlphaRange : vtkLookupTable
  • aMapper : Mesh
  • Ambient : vtkVolumeProperty, vtkRenderer, vtkProperty
  • ambient : MatProp
  • AmbientColor : vtkProperty
  • Amplitude : vtkImageSinusoidSource, vtkPerlinNoise
  • anActor : Mesh
  • Angle : vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkCone
  • AngleAccelerationFactor : vtkInteractorStyleFlight
  • AngleStepSize : vtkInteractorStyleFlight
  • AnimState : vtkInteractorStyle
  • aNormals : Mesh
  • ANY_SOURCE : vtkMultiProcessController
  • AnyEvent : vtkCommand
  • aPoints : Mesh
  • aPolyData : Mesh
  • App : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • Append : vtkImplicitModeller, vtkQuadricClustering, vtkFileOutputWindow
  • AppendArrow() : vtkSpherePuzzleArrows
  • AppendAxis : vtkImageAppend
  • AppendCells() : vtkAppendPolyData
  • AppendData() : vtkAppendPolyData
  • AppendDifferentPoints() : vtkAppendPolyData
  • AppendFeatureQuadrics() : vtkQuadricClustering
  • AppendItem() : vtkAbstractList< DType >
  • AppendOff() : vtkFileOutputWindow
  • AppendOn() : vtkFileOutputWindow
  • ApplicationId : vtkQuartzRenderWindowInteractor
  • ApplicationInitialized : vtkQuartzRenderWindow
  • ApplicationInstance : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • ApplyOperation() : vtkRearrangeFields
  • ApplyProperties() : vtkActorCollection, vtkActor
  • ApplyTransform() : vtkCamera
  • aProperty : MatProp
  • area : _vtkLocalTri, _vtkProLocalTri
  • AreaThreshold : vtkImageIslandRemoval2D
  • Array : vtkTriArray, vtkVertexArray, vtkStreamArray, vtkProTriArray, vtkProVertexArray, vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPriorityQueue, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkCellLinks, vtkBitArray
  • ArrayAccessMode : vtkPolyDataMapper2D, vtkMapper
  • ArrayComponent : vtkPolyDataMapper2D, vtkMapper
  • ArrayFileDimensionality : vtkPOPReader
  • ArrayFileNames : vtkPOPReader
  • ArrayId : vtkPolyDataMapper2D, vtkMapper, vtkBlankStructuredGrid
  • ArrayName : vtkPolyDataMapper2D, vtkMapper, vtkCutMaterial, vtkPLYWriter, vtkBlankStructuredGrid, vtkFieldData::CopyFieldFlag
  • ArrayNames : vtkPOPReader
  • ArrayOffsets : vtkPOPReader
  • ArraySize : vtkVolumeTextureMapper, vtkVolume, vtkPiecewiseFunction
  • ascii_get_element() : vtkPLY
  • Aspect : vtkViewport
  • AspectRatio : vtkDecimate, vtkProjectedTexture
  • Assign() : vtkAssignAttribute
  • AssignedNumberOfPieces : vtkBranchExtentTranslator
  • AssignedPiece : vtkBranchExtentTranslator
  • AssignJavaVM() : vtkJavaCommand
  • aStripper : Mesh
  • AttachmentPointCoordinate : vtkCaptionActor2D
  • AttenuationValues : vtkLight
  • ATTRIBUTE : vtkSplitField, vtkRearrangeFields, vtkMergeFields, vtkAssignAttribute
  • AttributeComponents : vtkQuadricDecimation
  • AttributeIndices : vtkDataSetAttributes
  • AttributeLimits : vtkDataSetAttributes
  • AttributeLimitTypes : vtkDataSetAttributes
  • AttributeLocation : vtkAssignAttribute
  • AttributeLocationNames : vtkAssignAttribute
  • AttributeMode : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • AttributeNames : vtkSplitField, vtkRearrangeFields, vtkMaskFields, vtkAssignAttribute, vtkDataSetAttributes
  • Attributes : vtkEdgeTable
  • AttributeType : vtkSplitField, vtkRearrangeFields::Operation, vtkAssignAttribute
  • AttributeTypes : vtkDataSetAttributes
  • AutoAdjustCameraClippingRange : vtkInteractorStyle
  • AutoAdjustCameraClippingRangeOff() : vtkInteractorStyle
  • AutoAdjustCameraClippingRangeOn() : vtkInteractorStyle
  • AutoAdjustSampleDistances : vtkVolumeRayCastMapper
  • AutoAdjustSampleDistancesOff() : vtkVolumeRayCastMapper
  • AutoAdjustSampleDistancesOn() : vtkVolumeRayCastMapper
  • AutoAdvance : vtkVideoSource
  • AutoAdvanceOff() : vtkVideoSource
  • AutoAdvanceOn() : vtkVideoSource
  • AutoCropOutput : vtkImageReslice
  • AutoCropOutputOff() : vtkImageReslice
  • AutoCropOutputOn() : vtkImageReslice
  • Automatic : vtkLocator
  • AutomaticBoundsComputation : vtkGraphLayoutFilter
  • AutomaticBoundsComputationOff() : vtkGraphLayoutFilter
  • AutomaticBoundsComputationOn() : vtkGraphLayoutFilter
  • AutomaticCylinderGeneration : vtkTextureMapToCylinder
  • AutomaticCylinderGenerationOff() : vtkTextureMapToCylinder
  • AutomaticCylinderGenerationOn() : vtkTextureMapToCylinder
  • AutomaticLODSelection : vtkLODProp3D
  • AutomaticLODSelectionOff() : vtkLODProp3D
  • AutomaticLODSelectionOn() : vtkLODProp3D
  • AutomaticNormalGeneration : vtkImplicitSelectionLoop
  • AutomaticNormalGenerationOff() : vtkImplicitSelectionLoop
  • AutomaticNormalGenerationOn() : vtkImplicitSelectionLoop
  • AutomaticOff() : vtkLocator
  • AutomaticOn() : vtkLocator
  • AutomaticPickLODSelection : vtkLODProp3D
  • AutomaticPickLODSelectionOff() : vtkLODProp3D
  • AutomaticPickLODSelectionOn() : vtkLODProp3D
  • AutomaticPlaneGeneration : vtkTextureMapToPlane
  • AutomaticPlaneGenerationOff() : vtkTextureMapToPlane
  • AutomaticPlaneGenerationOn() : vtkTextureMapToPlane
  • AutomaticScaleAdjustmentOff() : vtkRayCaster
  • AutomaticScaleAdjustmentOn() : vtkRayCaster
  • AutomaticSphereGeneration : vtkTextureMapToSphere
  • AutomaticSphereGenerationOff() : vtkTextureMapToSphere
  • AutomaticSphereGenerationOn() : vtkTextureMapToSphere
  • Averaging : vtkImageDifference
  • AveragingOff() : vtkImageShrink3D, vtkImageDifference
  • AveragingOn() : vtkImageShrink3D, vtkImageDifference
  • Axes : vtkOBBNode, vtkCursor3D
  • AxesOff() : vtkCursor3D
  • AxesOn() : vtkCursor3D
  • Axis : vtkAxisActor2D
  • AxisActor : vtkAxisActor2D
  • AxisMapper : vtkAxisActor2D
  • AxisTextureSize : vtkVolumeTextureMapper2D
  • AxisVisibility : vtkAxisActor2D
  • AxisVisibilityOff() : vtkAxisActor2D
  • AxisVisibilityOn() : vtkAxisActor2D
  • Azimuth() : vtkCamera
  • AzimuthScan() : vtkInteractorStyleFlight
  • AzimuthScanning : vtkInteractorStyleFlight
  • AzimuthStepSize : vtkInteractorStyleFlight

- b -
  • b : Face
  • B : vtkRungeKutta45
  • BackBuffer : vtkWin32ImageWindow
  • BackfaceCulling : vtkProperty
  • BackfaceCullingOff() : vtkProperty
  • BackfaceCullingOn() : vtkProperty
  • BackfaceProperty : vtkActor
  • BackfaceRender() : vtkProperty, vtkOpenGLProperty, vtkMesaProperty
  • Background : vtkRIBExporter, vtkViewport
  • BackgroundColor : vtkImageStencil, vtkImageReslice, vtkTextSource
  • BackgroundOff() : vtkRIBExporter
  • BackgroundOn() : vtkRIBExporter
  • Backing : vtkTextSource
  • BackingImage : vtkRenderer
  • BackingOff() : vtkTextSource
  • BackingOn() : vtkTextSource
  • BackingStore : vtkRenderer
  • BackingStoreOff() : vtkRenderer
  • BackingStoreOn() : vtkRenderer
  • bank : Camera
  • Barrier() : vtkThreadedController, vtkSocketController, vtkMultiProcessController, vtkMPIController
  • BarrierEnded() : vtkThreadedController
  • BarrierInProgress : vtkThreadedController
  • BarrierLock : vtkThreadedController
  • BarrierStarted() : vtkThreadedController
  • BarycentricCoords() : vtkTriangle, vtkTetra
  • BasicIterator() : vtkFieldData::BasicIterator
  • Basis : vtkThinPlateSplineTransform
  • BasisDerivative : vtkThinPlateSplineTransform
  • BasisFunction : vtkThinPlateSplineTransform
  • Begin() : vtkFieldData::Iterator
  • BeginId : vtkMPIEventLog
  • BeginIndex() : vtkFieldData::BasicIterator
  • BeginSpan() : vtkImageIterator< DType >
  • Between() : vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • BilinearImageZoomOff() : vtkRayCaster
  • BilinearImageZoomOn() : vtkRayCaster
  • binary_get_element() : vtkPLY
  • BitMapPtr : vtkWin32VideoSource
  • BitMapSize : vtkWin32VideoSource
  • Blanking : vtkStructuredGrid
  • BlankingOff() : vtkStructuredGrid
  • BlankingOn() : vtkStructuredGrid
  • BlankPoint() : vtkStructuredGrid
  • BlendFunc_bucket : vtkOpenGLStateCache
  • BlendMode : vtkVolumeProMapper, vtkImageBlend
  • BLOCK_MODE : vtkExtentTranslator
  • Blue : vtkColorTransferFunction
  • blue : Colour_24, Colour
  • BlueDiffuseShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • BlueSpecularShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • Bold : vtkTextMapper, vtkScalarBarActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • BoldOff() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • BoldOn() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • Border : vtkXYPlotActor, vtkLegendBoxActor, vtkCaptionActor2D
  • BorderActor : vtkLegendBoxActor
  • BorderMapper : vtkLegendBoxActor
  • BorderOff() : vtkLegendBoxActor, vtkCaptionActor2D
  • BorderOn() : vtkLegendBoxActor, vtkCaptionActor2D
  • BorderPolyData : vtkLegendBoxActor
  • Borders : vtkRenderWindow
  • BordersOff() : vtkRenderWindow
  • BordersOn() : vtkRenderWindow
  • Bottom : vtkCollection
  • BoundaryEdges : vtkFeatureEdges
  • BoundaryEdgesOff() : vtkFeatureEdges
  • BoundaryEdgesOn() : vtkFeatureEdges
  • BoundarySmoothing : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • BoundarySmoothingOff() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • BoundarySmoothingOn() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • BoundaryVertexDeletion : vtkDecimate, vtkDecimatePro
  • BoundaryVertexDeletionOff() : vtkDecimate, vtkDecimatePro
  • BoundaryVertexDeletionOn() : vtkDecimate, vtkDecimatePro
  • BoundingTriangulation : vtkDelaunay3D, vtkDelaunay2D
  • BoundingTriangulationOff() : vtkDelaunay3D, vtkDelaunay2D
  • BoundingTriangulationOn() : vtkDelaunay3D, vtkDelaunay2D
  • Bounds : vtkProp3D, vtkImageActor, vtkEncodedGradientEstimator, vtkAbstractMapper3D, vtkCubeAxesActor2D, vtkQuadricClustering, vtkOutlineSource, vtkCellLocator, vtkPropAssembly, vtkPoints, vtkPointLocator2D, vtkPointLocator, vtkDataSet, vtkCell
  • BOUNDS_TAG : vtkCompositeManager
  • BoundsClip : vtkEncodedGradientEstimator
  • BoundsClipOff() : vtkEncodedGradientEstimator
  • BoundsClipOn() : vtkEncodedGradientEstimator
  • BoundsComputed : vtkImplicitModeller
  • BoundsMTime : vtkActor
  • BranchingFactor : vtkSimpleScalarTree
  • BREAK_RMI_TAG : vtkMultiProcessController
  • BreakFlag : vtkMultiProcessController
  • BreakLoopFlag : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • BreakLoopFlagOff() : vtkXRenderWindowInteractor
  • BreakLoopFlagOn() : vtkXRenderWindowInteractor
  • BreakOnError() : vtkObject
  • BrightnessLevel : vtkMILVideoSource
  • Buckets : vtkCellLocator, vtkPointLocator2D
  • Buffer : vtkTransmitPolyDataPiece
  • BufferGhostLevel : vtkTransmitPolyDataPiece
  • BufferNumberOfPieces : vtkTransmitPolyDataPiece
  • BufferPiece : vtkTransmitPolyDataPiece
  • BufferPointerCallback : vtkImageExport, vtkImageImport
  • BufferPointerCallbackType : vtkImageImport, vtkImageExport
  • Build() : vtkWindowLevelLookupTable, vtkScalarsToColors, vtkLookupTable
  • BuildAxis() : vtkAxisActor2D
  • BuildCells() : vtkPolyData
  • BuildFunctionFromTable() : vtkPiecewiseFunction, vtkColorTransferFunction
  • BuildInternalFunctionStructure() : vtkFunctionParser
  • BuildInternalSubstringStructure() : vtkFunctionParser
  • BuildLinks() : vtkUnstructuredGrid, vtkPolyData, vtkCellLinks
  • BuildLocator() : vtkOBBTree, vtkCellLocator, vtkPointLocator2D, vtkPointLocator, vtkLocator
  • BuildLoop() : vtkDecimate
  • BuildPaths() : vtkAssembly, vtkPropAssembly, vtkProp
  • BuildShadingTable() : vtkEncodedGradientShader
  • BuildTime : vtkWin32TextMapper, vtkVolumeMapper, vtkScaledTextActor, vtkQuartzTextMapper, vtkPolyDataMapper2D, vtkMapper, vtkLODActor, vtkLabeledDataMapper, vtkEncodedGradientEstimator, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkScalarTree, vtkColorTransferFunction, vtkLookupTable, vtkLocator
  • BuildTree() : vtkOBBTree, vtkOBBDicer, vtkSimpleScalarTree, vtkScalarTree
  • BuildTreeExecuteTime : vtkImageQuantizeRGBToIndex
  • BuildTube() : vtkHyperStreamline
  • bump_map : MatProp
  • bump_strength : MatProp
  • Button : vtkInteractorStyleUser
  • ButtonDown : vtkInteractorStyleUnicam
  • Bypass : vtkImageToImageFilter, vtkImageMultipleInputFilter
  • BypassOff() : vtkImageToImageFilter, vtkImageMultipleInputFilter
  • BypassOn() : vtkImageToImageFilter, vtkImageMultipleInputFilter
  • BypassWasOn : vtkImageToImageFilter
  • ByteCode : vtkFunctionParser
  • ByteCodeSize : vtkFunctionParser

- c -
  • c : Face
  • C : vtkRungeKutta45
  • CacheCellBounds : vtkCellLocator
  • CacheCellBoundsOff() : vtkCellLocator
  • CacheCellBoundsOn() : vtkCellLocator
  • CachedProp3D : vtkProp3D
  • CachedSize : vtkXYPlotActor, vtkLegendBoxActor
  • CacheHit : vtkInterpolatedVelocityField
  • CacheMiss : vtkInterpolatedVelocityField
  • CacheSize : vtkImageCacheFilter
  • Caching : vtkInterpolatedVelocityField
  • CachingOff() : vtkInterpolatedVelocityField
  • CachingOn() : vtkInterpolatedVelocityField
  • CalculateTotalWeight() : vtkImplicitSum
  • Callback : vtkXRenderWindowInteractor, vtkOldStyleCallbackCommand, vtkCallbackCommand
  • CallbackUserData : vtkImageImport
  • Camera : vtkFollower, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkArcPlotter
  • CameraLightTransform : vtkCamera
  • CameraList : vtk3DSImporter
  • CameraOrActor : vtkInteractorStyleSwitch
  • CameraPosition : VTKRayCastRayInfo
  • CameraThickness : VTKVRCStaticInfo
  • Cancel() : vtkMPICommunicator::Request
  • CannotOpenFileError : vtkErrorCode
  • CanReadFile() : vtkTIFFReader, vtkSLCReader, vtkPNMReader, vtkPNGReader, vtkJPEGReader, vtkImageReader2, vtkGESignaReader, vtkBMPReader
  • CanSplitLoop() : vtkDecimate
  • Cap() : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller
  • CapDriverCaps : vtkWin32VideoSource
  • Capping : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller, vtkTubeFilter, vtkRotationalExtrusionFilter, vtkLinearExtrusionFilter, vtkCylinderSource, vtkConeSource
  • CappingOff() : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller, vtkTubeFilter, vtkRotationalExtrusionFilter, vtkLinearExtrusionFilter, vtkCylinderSource, vtkConeSource
  • CappingOn() : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller, vtkTubeFilter, vtkRotationalExtrusionFilter, vtkLinearExtrusionFilter, vtkCylinderSource, vtkConeSource
  • CapStatus : vtkWin32VideoSource
  • Caption : vtkCaptionActor2D
  • CaptureParms : vtkWin32VideoSource
  • CapValue : vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller
  • CapWnd : vtkWin32VideoSource
  • CaseFileName : vtkGenericEnSightReader, vtkEnSightReader
  • CastLines() : vtkVoxelContoursToSurfaceFilter
  • CastRay() : vtkVolumeRayCastMIPFunction, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction, vtkVolumeRayCastCompositeFunction
  • CastToChar() : vtkLargeInteger
  • CastToInt() : vtkLargeInteger
  • CastToLong() : vtkLargeInteger
  • CastToShort() : vtkLargeInteger
  • CastToUnsignedLong() : vtkLargeInteger
  • Cell : vtkInterpolatedVelocityField, vtkGenericCell
  • CELL_DATA : vtkSplitField, vtkRearrangeFields, vtkMergeFields, vtkMaskFields, vtkAssignAttribute
  • CELL_DATA_FIELD : vtkDataSet
  • CellBoundary() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • CellBounds : vtkCellLocator
  • CellClipping : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • CellClippingOff() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • CellClippingOn() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • CellConnectivityArray : vtkDataObjectToDataSetFilter
  • CellConnectivityArrayComponent : vtkDataObjectToDataSetFilter
  • CellConnectivityComponentRange : vtkDataObjectToDataSetFilter
  • CellData : vtkDataSetToDataObjectFilter, vtkDataSet
  • CellDataOff() : vtkDataSetToDataObjectFilter
  • CellDataOn() : vtkDataSetToDataObjectFilter
  • CellDataWeightArray : vtkWeightedTransformFilter
  • CellHasBeenVisited : vtkCellLocator
  • cellId : _vtkStreamPoint
  • CellId : vtkCellPicker, vtkExplicitCell
  • CellIds : vtkEnSightReader, vtkIdFilter
  • CellIdsOff() : vtkIdFilter
  • CellIdsOn() : vtkIdFilter
  • CellMaximum : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • CellMinimum : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • Cells : vtkOBBNode, vtkPolyData
  • cells : _vtkLink_s
  • CellScalarsFlag : vtkPieceScalars
  • CellTypeArray : vtkDataObjectToDataSetFilter
  • CellTypeArrayComponent : vtkDataObjectToDataSetFilter
  • CellTypeComponentRange : vtkDataObjectToDataSetFilter
  • Center : vtkProp3D, vtkInteractorStyleUnicam, vtkInteractorStyle, vtkAbstractMapper3D, vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkTextureMapToSphere, vtkSuperquadricSource, vtkSphereSource, vtkPointSource, vtkPlaneSource, vtkGlyphSource2D, vtkCylinderSource, vtkCubeSource, vtkSuperquadric, vtkSphere, vtkCylinder, vtkViewport, vtkDataSet
  • center : Summary
  • CenterDistance : VTKRayCastVolumeInfo
  • CenterImage : vtkImageChangeInformation
  • CenterImageOff() : vtkImageChangeInformation
  • CenterImageOn() : vtkImageChangeInformation
  • CenterPoint : vtkCutMaterial
  • Char : vtkInteractorStyleUser
  • CharacterDataHandler() : vtkXMLParser
  • CharacterDataHandlerFunction() : vtkXMLParser
  • CharacteristicsTime : vtkDataReader
  • CharacterizeFile() : vtkDataReader
  • CharEvent : vtkCommand
  • CharTag : vtkInteractorStyleUser
  • CheckAbortStatus() : vtkRenderWindow
  • CheckAttributes() : vtkDataSet
  • CheckBuffer() : vtkWin32VideoSource
  • CheckError() : vtkDecimate
  • CheckFor() : vtkDataReader
  • CheckForAbortComposite() : vtkCompositeManager
  • CheckForAbortRender() : vtkCompositeManager
  • CheckInRenderStatus() : vtkRenderWindow
  • CheckMeanDistance : vtkIterativeClosestPointTransform
  • CheckMeanDistanceOff() : vtkIterativeClosestPointTransform
  • CheckMeanDistanceOn() : vtkIterativeClosestPointTransform
  • CheckOutput() : vtkPDataSetReader
  • CheckSubSampling() : vtkVolumeProVP1000Mapper
  • CheckSyntax() : vtkFunctionParser
  • Choose() : vtkInteractorStyleUnicam
  • CircleLimits : vtkEncodedGradientEstimator
  • CircleLimitsSize : vtkEncodedGradientEstimator
  • CircuitCheck() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkAbstractTransform
  • Circumcircle() : vtkTriangle
  • CircumferentialResolution : vtkDiskSource, vtkButtonSource
  • Circumsphere() : vtkTetra
  • Clamping : vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction
  • ClampingOff() : vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction
  • ClampingOn() : vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction
  • ClampOverflow : vtkImageShiftScale, vtkImageCast
  • ClampOverflowOff() : vtkImageShiftScale, vtkImageCast
  • ClampOverflowOn() : vtkImageShiftScale, vtkImageCast
  • ClampScaling : vtkTensorGlyph
  • ClampScalingOff() : vtkTensorGlyph
  • ClampScalingOn() : vtkTensorGlyph
  • ClampValue : vtkSpline
  • ClampValueOff() : vtkSpline
  • ClampValueOn() : vtkSpline
  • ClassExitMethod : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • ClassExitMethodArg : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • ClassExitMethodArgDelete : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • ClassFinalize() : vtkInstantiator
  • ClassInitialize() : vtkInstantiator
  • Clean() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • CleanAll() : vtkHeap
  • CleanUp() : vtkVRMLAllocator
  • CleanUpOffScreenRendering() : vtkWin32OpenGLRenderWindow
  • Clear() : vtkRenderer, vtkOpenGLRenderer, vtkMesaRenderer
  • ClearCellHasBeenVisited() : vtkCellLocator
  • ClearColor_buckets : vtkOpenGLStateCache
  • ClearDepth_bucket : vtkOpenGLStateCache
  • ClearFieldFlags() : vtkMaskFields, vtkFieldData
  • ClearInRenderStatus() : vtkRenderWindow
  • ClearLastCellId() : vtkInterpolatedVelocityField
  • ClearLights() : vtkOpenGLRenderer, vtkMesaRenderer
  • ClientData : vtkOldStyleCallbackCommand, vtkCallbackCommand
  • ClientDataDeleteCallback : vtkOldStyleCallbackCommand, vtkCallbackCommand
  • Clip() : vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkGenericCell, vtkEmptyCell, vtkCell3D, vtkCell
  • ClipBounds() : vtkCubeAxesActor2D
  • ClipData : vtkImageClip
  • ClipDataOff() : vtkImageClip
  • ClipDataOn() : vtkImageClip
  • ClipEdge() : vtkBandedPolyDataContourFilter
  • ClipExtent : vtkPOPReader
  • ClipFunction : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • ClipIndex : vtkBandedPolyDataContourFilter
  • ClippedOutput : vtkClipVolume
  • Clipping : vtkBandedPolyDataContourFilter
  • ClippingOff() : vtkBandedPolyDataContourFilter
  • ClippingOn() : vtkBandedPolyDataContourFilter
  • ClippingPlane : VTKVRCStaticInfo
  • ClippingPlanes : vtkAbstractMapper
  • ClippingRange : vtkCamera
  • ClipPlane_bucket : vtkOpenGLStateCache
  • ClipPlanes : vtkXYPlotActor
  • ClipPlotData() : vtkXYPlotActor
  • ClipPolygonsFromPlanes() : vtkHull
  • ClipRayAgainstClippingPlanes() : vtkVolumeRayCastMapper
  • ClipRayAgainstVolume() : vtkVolumeRayCastMapper
  • ClipRegion : vtkVideoSource
  • ClipSegment() : vtkImageCanvasSource2D
  • ClipTolerance : vtkBandedPolyDataContourFilter
  • ClipValues : vtkBandedPolyDataContourFilter
  • ClipVoxel() : vtkClipVolume
  • CloseConnection() : vtkSocketController, vtkSocketCommunicator
  • Closed : vtkSpline
  • ClosedOff() : vtkSpline
  • ClosedOn() : vtkSpline
  • CloseLibrary() : vtkDynamicLoader
  • ClosePPMImageFile() : vtkImageWindow
  • ClosestPoint : vtkSelectPolyData, vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • CloseSurface : vtkRuledSurfaceFilter
  • CloseSurfaceOff() : vtkRuledSurfaceFilter
  • CloseSurfaceOn() : vtkRuledSurfaceFilter
  • CloseVTKFile() : vtkDataWriter, vtkDataReader
  • Coefficients : vtkSpline, vtkQuadric
  • col : SpotLight, OmniLight
  • CollapseEdge() : vtkDecimatePro
  • CollectRevisions() : vtkObject
  • Color : VTKRayCastVolumeInfo, vtkVolumeRayCastIsosurfaceFunction, VTKVRCStaticInfo, VTKVRCDynamicInfo, vtkProperty, vtkLight, vtkPLYWriter, vtkGlyphSource2D, VTKRayCastRayInfo, vtkProperty2D
  • ColorByArrayComponent() : vtkPolyDataMapper2D, vtkMapper
  • ColorByPiece : vtkPolyDataStreamer
  • ColorByPieceOff() : vtkPolyDataStreamer
  • ColorByPieceOn() : vtkPolyDataStreamer
  • ColorChannels : VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkVolumeProperty
  • ColorGlyphs : vtkTensorGlyph
  • ColorGlyphsOff() : vtkTensorGlyph
  • ColorGlyphsOn() : vtkTensorGlyph
  • Coloring : vtkFeatureEdges
  • ColoringOff() : vtkFeatureEdges
  • ColoringOn() : vtkFeatureEdges
  • ColorLevel : vtkImageMapper
  • ColorMap : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow
  • ColorMaterial_bucket : vtkOpenGLStateCache
  • ColorMode : vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkCGMWriter, vtkImageToPolyDataFilter, vtkProgrammableGlyphFilter, vtkGlyph3D
  • ColorRegions : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ColorRegionsOff() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ColorRegionsOn() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • Colors : vtkXImageWindow, vtkPolyDataMapper2D, vtkMapper, vtkBMPReader, vtkLegendBoxActor, vtkSpherePuzzle
  • ColorSpace : vtkColorTransferFunction
  • ColorWindow : vtkImageMapper
  • command : _vtkTclVoidFuncArg
  • CommandFunction : vtkTclCommandStruct
  • CommandLookup : vtkTclInterpStruct
  • comments : PlyFile
  • Communicator : vtkMultiProcessController
  • Communicators : vtkSharedMemoryCommunicator
  • CompareFunction : vtkAbstractList< DType >
  • CompareOperationsByName() : vtkRearrangeFields
  • CompareOperationsByType() : vtkRearrangeFields
  • CompatHdc : vtkWin32ImageWindow
  • Complement() : vtkLargeInteger
  • ComplexVariableDescriptions : vtkGenericEnSightReader, vtkEnSightReader
  • ComplexVariableFileNames : vtkEnSightReader
  • ComplexVariableFileSets : vtkEnSightReader
  • ComplexVariableTimeSets : vtkEnSightReader
  • ComplexVariableTypes : vtkGenericEnSightReader, vtkEnSightReader
  • Component : vtkSplitField::Component, vtkMergeFields::Component, vtkPLYWriter, vtkBlankStructuredGrid
  • ComponentBlendAdd : vtkVolumeMapper
  • ComponentBlendMaxOpacity : vtkVolumeMapper
  • ComponentBlendMode : vtkVolumeMapper
  • ComponentBlendModes : vtkVolumeMapper
  • ComponentExtent : vtkImageAccumulate
  • ComponentOrigin : vtkImageAccumulate
  • Components : vtkImageExtractComponents
  • ComponentSpacing : vtkImageAccumulate
  • Composite() : vtkCompositeManager
  • CompositeBuffer() : vtkTreeComposite, vtkCompositeManager
  • CompositeMethod : vtkVolumeRayCastCompositeFunction
  • CompositeTime : vtkCompositeManager
  • CompoundThreshold : vtkImageBlend
  • Compute() : vtkSpline, vtkKochanekSpline, vtkCardinalSpline
  • COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG : vtkCompositeManager
  • ComputeAspect() : vtkViewport
  • ComputeAStep() : vtkRungeKutta45
  • ComputeAxisTextureSize() : vtkVolumeTextureMapper2D
  • ComputeBlockExtents() : vtkImageBlockReader
  • ComputeBounds() : vtkSweptSurface, vtkRectilinearGrid, vtkPolyData, vtkPointSet, vtkPoints, vtkImageData, vtkDataSet
  • ComputeCameraLightTransform() : vtkCamera
  • ComputeCellId() : vtkStructuredData, vtkRectilinearGrid, vtkImageData
  • ComputeCellNormals : vtkPolyDataNormals
  • ComputeCellNormalsOff() : vtkPolyDataNormals
  • ComputeCellNormalsOn() : vtkPolyDataNormals
  • ComputeCellTags() : vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • ComputeCircleLimits() : vtkEncodedGradientEstimator
  • ComputeCompositePerspectiveTransform() : vtkCamera
  • ComputeCost() : vtkQuadricDecimation
  • ComputeDataIncrements() : vtkImageReader2, vtkBMPReader
  • ComputeDataPipelineSize() : vtkPipelineSize
  • ComputedDisplayValue : vtkCoordinate
  • ComputeDensity() : vtkPLOT3DReader
  • ComputedFloatDisplayValue : vtkCoordinate
  • ComputedFloatViewportValue : vtkCoordinate
  • ComputeDisplayToWorld() : vtkInteractorStyle
  • ComputeDistance() : vtkCamera
  • ComputeDivisionExtents() : vtkBYUReader, vtkAxes
  • ComputeDORange() : vtkXYPlotActor
  • ComputedUserDefinedValue : vtkCoordinate
  • ComputedViewportValue : vtkCoordinate
  • ComputedWorldValue : vtkCoordinate
  • ComputeEffectiveStress : vtkPointLoad
  • ComputeEffectiveStressOff() : vtkPointLoad
  • ComputeEffectiveStressOn() : vtkPointLoad
  • ComputeEnthalpy() : vtkPLOT3DReader
  • ComputeEntropy() : vtkPLOT3DReader
  • ComputeExtentOriginAndSpacing() : vtkDEMReader
  • ComputeFootprint() : vtkSweptSurface
  • ComputeGlyphScale() : vtkXYPlotActor
  • ComputeGradientMagnitudes : vtkEncodedGradientEstimator
  • ComputeGradientMagnitudesOff() : vtkEncodedGradientEstimator
  • ComputeGradientMagnitudesOn() : vtkEncodedGradientEstimator
  • ComputeGradients : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeGradientsOff() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeGradientsOn() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeIncrements() : vtkImageData
  • ComputeInputUpdateExtent() : vtkImageWrapPad, vtkImageTranslateExtent, vtkImageSpatialFilter, vtkImageSkeleton2D, vtkImageShrink3D, vtkImageSeparableConvolution, vtkImageRFFT, vtkImageReslice, vtkImageResample, vtkImageQuantizeRGBToIndex, vtkImagePermute, vtkImagePadFilter, vtkImageNonMaximumSuppression, vtkImageMirrorPad, vtkImageMagnify, vtkImageLaplacian, vtkImageIterateFilter, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSmooth, vtkImageFourierCenter, vtkImageFlip, vtkImageFFT, vtkImageEuclideanDistance, vtkImageDivergence, vtkImageDifference, vtkImageCorrelation, vtkImageCityBlockDistance, vtkImageChangeInformation, vtkImageBlend, vtkImageAppend, vtkImageAccumulate, vtkSimpleImageToImageFilter, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter
  • ComputeInputUpdateExtents() : vtkSynchronizedTemplates3D, vtkKitwareContourFilter, vtkGridSynchronizedTemplates3D, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkUnstructuredGridReader, vtkPolyDataReader, vtkImageSeedConnectivity, vtkImageReslice, vtkImageIterateFilter, vtkStructuredGridGeometryFilter, vtkProbeFilter, vtkPolyDataStreamer, vtkMergeFilter, vtkLoopSubdivisionFilter, vtkGlyph3D, vtkGeometryFilter, vtkFieldDataToAttributeDataFilter, vtkFeatureEdges, vtkExtractGrid, vtkDataSetToDataObjectFilter, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkCleanPolyData, vtkAppendPolyData, vtkUnstructuredGridToPolyDataFilter, vtkUnstructuredGridSource, vtkStructuredPointsToUnstructuredGridFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToPolyDataFilter, vtkPolyDataSource, vtkPointSetToPointSetFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToPolyDataFilter, vtkDataSetToDataSetFilter, vtkSource
  • ComputeInternalEnergy() : vtkPLOT3DReader
  • ComputeInternalFileName() : vtkImageReader2
  • ComputeInverseTransformedExtent() : vtkImageReader
  • ComputeInverseTransformedIncrements() : vtkImageReader
  • ComputeKernel() : vtkImageGaussianSmooth
  • ComputeKineticEnergy() : vtkPLOT3DReader
  • ComputeLRVector() : vtkInteractorStyleFlight
  • ComputeMatrices() : vtkVolumeRayCastMapper
  • ComputeMatrix() : vtkProp3D
  • ComputeMaximumPoint() : vtkCutMaterial
  • ComputeMedian() : vtkImageHybridMedian2D
  • ComputeModelBounds() : vtkVoxelModeller, vtkShepardMethod, vtkGaussianSplatter, vtkImplicitModeller
  • ComputeMomentum() : vtkPLOT3DReader
  • ComputeNextStep() : vtkRungeKutta45, vtkRungeKutta4, vtkRungeKutta2, vtkInitialValueProblemSolver
  • ComputeNormal() : vtkCutMaterial, vtkTextureMapToPlane, vtkProjectedTexture, vtkTriangle, vtkPolygon
  • ComputeNormalDirection() : vtkTriangle
  • ComputeNormals : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkSampleFunction, vtk3DSImporter, vtkContourGrid, vtkContourFilter, vtkAxes
  • ComputeNormalsOff() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkSampleFunction, vtk3DSImporter, vtkContourGrid, vtkContourFilter, vtkAxes
  • ComputeNormalsOn() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkSampleFunction, vtk3DSImporter, vtkContourGrid, vtkContourFilter, vtkAxes
  • ComputeNumberOfDivisions : vtkQuadricClustering
  • ComputeNumberOfSteps() : vtkSweptSurface
  • ComputeOBB() : vtkOBBTree
  • ComputeOutputMemorySize() : vtkPipelineSize
  • ComputeOutputWholeExtent() : vtkImageSpatialFilter
  • ComputePerspectiveTransform() : vtkCamera
  • ComputePlaneDistances() : vtkHull
  • ComputePointId() : vtkStructuredData, vtkRectilinearGrid, vtkImageData
  • ComputePointNormals : vtkPolyDataNormals
  • ComputePointNormalsOff() : vtkPolyDataNormals
  • ComputePointNormalsOn() : vtkPolyDataNormals
  • ComputePressure() : vtkPLOT3DReader
  • ComputePressureGradient() : vtkPLOT3DReader
  • ComputeProjectionVector() : vtkDepthSortPolyData
  • ComputeQuadric() : vtkQuadricDecimation, vtkTriangle
  • ComputeRange() : vtkAxisActor2D, vtkDataArray
  • ComputeRepresentativePoint() : vtkQuadricClustering
  • ComputeRequiredInputUpdateExtent() : vtkImageSource
  • ComputeRowBounds() : vtkVolumeRayCastMapper
  • ComputeScalarIndex() : vtkBandedPolyDataContourFilter
  • ComputeScalars : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeScalarsOff() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeScalarsOn() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • ComputeScreenCoverage() : vtkVolume
  • ComputeSourcePipelineSize() : vtkPipelineSize
  • ComputeStagnationEnergy() : vtkPLOT3DReader
  • ComputeStringOffset() : vtkAxisActor2D
  • ComputeStructuredCoordinates() : vtkRectilinearGrid, vtkImageData
  • ComputeSwirl() : vtkPLOT3DReader
  • ComputeTemperature() : vtkPLOT3DReader
  • ComputeTime : vtkSpline, vtkPoints, vtkDataSet
  • ComputeTransformedBounds() : vtkVolume16Reader
  • ComputeTransformedDimensions() : vtkVolume16Reader
  • ComputeTransformedExtent() : vtkImageReader
  • ComputeTransformedIncrements() : vtkImageReader
  • ComputeTransformedOrigin() : vtkVolume16Reader, vtkImageReader
  • ComputeTransformedSpacing() : vtkVolume16Reader, vtkImageReader
  • ComputeVelocity() : vtkPLOT3DReader
  • ComputeVelocityMagnitude() : vtkPLOT3DReader
  • ComputeViewPlaneNormal() : vtkCamera
  • ComputeViewTransform() : vtkCamera
  • ComputeVisiblePropBounds() : vtkRenderer, vtkCompositeManager
  • ComputeVisiblePropBoundsRMI() : vtkCompositeManager
  • ComputeVolume() : vtkTetra
  • ComputeVorticity() : vtkPLOT3DReader, vtkStreamer
  • ComputeWeights() : vtkPolygon
  • ComputeWorldToDisplay() : vtkInteractorStyle
  • ComputeXRange() : vtkXYPlotActor
  • ComputeYRange() : vtkXYPlotActor
  • Computing : vtkCoordinate
  • Concatenate() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenation
  • Concatenation : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • ConeAngle : vtkLight
  • ConfigureEvent : vtkCommand
  • ConfigureTag : vtkInteractorStyleUser
  • ConnectedValue : vtkImageConnector
  • Connectivity : vtkUnstructuredGrid
  • Connector : vtkImageSeedConnectivity
  • ConnectTo() : vtkSocketController, vtkSocketCommunicator
  • ConsiderAnisotropy : vtkImageEuclideanDistance
  • ConsiderAnisotropyOff() : vtkImageEuclideanDistance
  • ConsiderAnisotropyOn() : vtkImageEuclideanDistance
  • Consistency : vtkPolyDataNormals
  • ConsistencyOff() : vtkPolyDataNormals
  • ConsistencyOn() : vtkPolyDataNormals
  • Constant : vtkImageLogarithmicScale, vtkImageConstantPad
  • ConstantC : vtkImageMathematics
  • ConstantK : vtkImageMathematics
  • ConstantSize : vtkImageMandelbrotSource
  • ConstantSizeOff() : vtkImageMandelbrotSource
  • ConstantSizeOn() : vtkImageMandelbrotSource
  • ConstructArray() : vtkFieldDataToAttributeDataFilter
  • ConstructCellArray() : vtkDataObjectToDataSetFilter
  • ConstructCells() : vtkDataObjectToDataSetFilter
  • ConstructClass() : vtkDebugLeaks
  • ConstructDimensions() : vtkDataObjectToDataSetFilter
  • ConstructFieldData() : vtkFieldDataToAttributeDataFilter
  • ConstructGhostLevels() : vtkFieldDataToAttributeDataFilter
  • ConstructNormals() : vtkFieldDataToAttributeDataFilter
  • ConstructOrigin() : vtkDataObjectToDataSetFilter
  • ConstructPoints() : vtkDataObjectToDataSetFilter
  • ConstructScalars() : vtkFieldDataToAttributeDataFilter
  • ConstructSpacing() : vtkDataObjectToDataSetFilter
  • ConstructTCoords() : vtkFieldDataToAttributeDataFilter
  • ConstructTensors() : vtkFieldDataToAttributeDataFilter
  • ConstructVectors() : vtkFieldDataToAttributeDataFilter
  • Consts : vtkSocketController, vtkMultiProcessController
  • Consumers : vtkProp, vtkDataObject, vtkAbstractMapper
  • Context : vtkVolumeProMapper
  • ContextId : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow
  • ContinuousIncrements : vtkImageIterator< DType >
  • Contour() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • Contours : vtkContourValues
  • ContourValues : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkBandedPolyDataContourFilter
  • ContrastLevel : vtkMILVideoSource
  • ControlKey : vtkRenderWindowInteractor
  • Controller : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkOutputPort, vtkInputPort, vtkCompositeManager
  • Controllers : vtkThreadedController
  • ControlMode : vtkInteractorStyleTrackball
  • Convergence : vtkSmoothPolyDataFilter
  • ConvertColor() : vtkGlyphSource2D
  • ConvertCroppingRegionPlanesToVoxels() : vtkVolumeMapper
  • ConvertIDToIndex() : vtkLODProp3D
  • ConvertLinesToPoints : vtkCleanPolyData
  • ConvertLinesToPointsOff() : vtkCleanPolyData
  • ConvertLinesToPointsOn() : vtkCleanPolyData
  • ConvertPolysToLines : vtkCleanPolyData
  • ConvertPolysToLinesOff() : vtkCleanPolyData
  • ConvertPolysToLinesOn() : vtkCleanPolyData
  • ConvertStripsToPolys : vtkCleanPolyData
  • ConvertStripsToPolysOff() : vtkCleanPolyData
  • ConvertStripsToPolysOn() : vtkCleanPolyData
  • ConvertUnsignedCharToRGBA() : vtkScalarsToColors
  • CoolDownRate : vtkGraphLayoutFilter
  • CoordinateSystem : vtkCoordinate
  • Coords : vtkOpenGLImageActor, vtkMesaImageActor
  • COPY : vtkRearrangeFields
  • copy_property() : vtkPLY
  • CopyAllocate() : vtkDataSetAttributes
  • CopyAllOff() : vtkMaskFields, vtkFieldData, vtkDataSetAttributes
  • CopyAllOn() : vtkMaskFields, vtkFieldData, vtkDataSetAttributes
  • CopyAndCastFrom() : vtkImageData
  • CopyAttributeFlags : vtkDataSetAttributes
  • CopyAttributeOff() : vtkMaskFields
  • CopyAttributeOn() : vtkMaskFields
  • CopyAttributeOnOff() : vtkMaskFields
  • CopyAttributes : vtkMaskFields
  • CopyAttributesOff() : vtkMaskFields
  • CopyAttributesOn() : vtkMaskFields
  • CopyCellData : vtkQuadricClustering
  • CopyCellDataOff() : vtkQuadricClustering
  • CopyCellDataOn() : vtkQuadricClustering
  • CopyCells() : vtkPolyData
  • CopyComponent() : vtkDataArray
  • CopyData() : vtkImageClip, vtkImageInPlaceFilter, vtkDataSetAttributes
  • CopyFieldFlags : vtkMaskFields, vtkFieldData
  • CopyFieldOff() : vtkMaskFields, vtkFieldData
  • CopyFieldOn() : vtkMaskFields, vtkFieldData
  • CopyFieldOnOff() : vtkMaskFields, vtkFieldData
  • CopyFields : vtkMaskFields
  • CopyFieldsOff() : vtkMaskFields
  • CopyFieldsOn() : vtkMaskFields
  • CopyFlags() : vtkFieldData
  • CopyFrom() : vtkMPIGroup, vtkMPICommunicator
  • CopyImportVoidPointer() : vtkImageImport
  • CopyInformation() : vtkDataObject
  • CopyNormalsOff() : vtkDataSetAttributes
  • CopyNormalsOn() : vtkDataSetAttributes
  • CopyOriginAndSample() : vtkImageMandelbrotSource
  • CopyProcessIdsFrom() : vtkMPIGroup
  • CopyResultFrame() : vtkRenderWindow
  • CopyScalarsOff() : vtkDataSetAttributes
  • CopyScalarsOn() : vtkDataSetAttributes
  • CopyStructure() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkPointSet, vtkImageData, vtkDataSet
  • CopyTCoordsOff() : vtkDataSetAttributes
  • CopyTCoordsOn() : vtkDataSetAttributes
  • CopyTensorsOff() : vtkDataSetAttributes
  • CopyTensorsOn() : vtkDataSetAttributes
  • CopyTuple() : vtkDataSetAttributes
  • CopyTypeSpecificInformation() : vtkImageData, vtkDataObject
  • CopyVectorsOff() : vtkDataSetAttributes
  • CopyVectorsOn() : vtkDataSetAttributes
  • Corner : vtkOBBNode
  • CornerFactor : vtkOutlineCornerSource, vtkOutlineCornerFilter
  • CornerOffset : vtkCubeAxesActor2D
  • Corners : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • CornersOff() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • CornersOn() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • CorrectBasePlaneSize() : vtkVolumeProVG500Mapper
  • CorrectedScalarOpacityArray : vtkVolume
  • CorrectedScalarOpacityArrayMTime : vtkVolume
  • CorrectedStepSize : vtkVolume
  • Count : VectorType< T >, vtkDividingCubes, vtkRecursiveDividingCubes, vtkImageProgressIterator< DType >
  • Count2 : vtkImageProgressIterator< DType >
  • count_external : PlyProperty
  • count_internal : PlyProperty
  • count_offset : PlyProperty
  • Counter : vtkThreadedController
  • CounterLock : vtkThreadedController
  • CoverExtent() : vtkPDataSetReader
  • CpuTicks : vtkTimerLogEntry
  • CreateAllInstance() : vtkObjectFactory
  • CreateArrow() : vtkGlyphSource2D
  • CreateAWindow() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow
  • CreateBitmapObject() : vtkWin32ImageMapper
  • CreateCallback : vtkObjectFactory::OverrideInformation
  • CreateCircle() : vtkGlyphSource2D
  • CreateCross() : vtkGlyphSource2D
  • CreateDash() : vtkGlyphSource2D
  • CreateDataArray() : vtkDataArray
  • CreateDefaultLocator() : vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkUGFacetReader, vtkSTLReader, vtkMCubesReader, vtkIterativeClosestPointTransform, vtkGeometryFilter, vtkFeatureEdges, vtkExtractUnstructuredGrid, vtkExtractEdges, vtkDelaunay3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData
  • CreateDefaultLookupTable() : vtkPolyDataMapper2D, vtkMapper, vtkDataArray
  • CreateDefaultPicker() : vtkRenderWindowInteractor
  • CreateDiamond() : vtkGlyphSource2D
  • CreatedLight : vtkRenderer
  • CreateFunction : vtkObjectFactory, vtkInstantiator
  • CreateGhostCells : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • CreateGhostCellsOff() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • CreateGhostCellsOn() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • CreateHookedArrow() : vtkGlyphSource2D
  • CreateImageDataOutput() : vtkEnSightGoldReader, vtkEnSightGoldBinaryReader
  • CreateImageReader2() : vtkImageReader2Factory
  • CreateInitialPolygon() : vtkHull
  • CreateInstance() : vtkImagingFactory, vtkGraphicsFactory, vtkObjectFactory, vtkInstantiator
  • CreateLight() : vtkRenderer
  • CreateObject() : vtkKitwareObjectFactory, vtkObjectFactory
  • CreateOffScreenDC() : vtkWin32OpenGLRenderWindow
  • CreateOutput() : vtkDecimate
  • CreateOutputWindow() : vtkThreadedController, vtkSocketController, vtkMultiProcessController, vtkMPIController
  • CreateOwnLODs() : vtkLODActor
  • CreatePlotData() : vtkXYPlotActor
  • CreateProcessControllers() : vtkThreadedController
  • CreateRectilinearGridOutput() : vtkEnSightGoldReader, vtkEnSightGoldBinaryReader
  • CreateSquare() : vtkGlyphSource2D
  • CreateStructuredGridOutput() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • CreateThickArrow() : vtkGlyphSource2D
  • CreateThickCross() : vtkGlyphSource2D
  • CreateTimer() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • CreateTriangle() : vtkGlyphSource2D
  • CreateUnstructuredGridOutput() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • CreateVertex() : vtkGlyphSource2D
  • CreatorTable : vtkInstantiator
  • CritSec : vtkSimpleCriticalSection
  • Crop() : vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataObject
  • Cropping : vtkVolumeMapper
  • CroppingOff() : vtkVolumeMapper
  • CroppingOn() : vtkVolumeMapper
  • CroppingRegionFlags : vtkVolumeMapper
  • CroppingRegionPlanes : vtkVolumeMapper
  • Cross : vtkMath, vtkGlyphSource2D
  • CrossOff() : vtkGlyphSource2D
  • CrossOn() : vtkGlyphSource2D
  • CTime : vtkImageClip
  • CtrlKey : vtkInteractorStyle
  • Cull() : vtkFrustumCoverageCuller, vtkCuller
  • Cullers : vtkRenderer
  • CullFace_bucket : vtkOpenGLStateCache
  • Current : vtkHeap, vtkCollection
  • CurrentCamera : vtkInteractorStyle
  • CurrentCpuTicks : vtkTimerLog
  • CurrentFont : vtkXTextMapper
  • CurrentGLCache : vtkOpenGLStateCache
  • CurrentIndex : vtkLODProp3D
  • CurrentLight : vtkInteractorStyle
  • CurrentPickId : vtkViewport
  • CurrentPosition : vtkMPIGroup
  • CurrentProp : vtkInteractorStyle
  • CurrentRenderer : vtkInteractorStyle
  • CurrentStyle : vtkInteractorStyleSwitch
  • CurrentSubFrame : vtkRenderWindow
  • CurrentWallTime : vtkTimerLog
  • Cursor : vtkVolumeProMapper
  • CursorHidden : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkQuartzRenderWindow
  • CursorOff() : vtkVolumeProMapper
  • CursorOn() : vtkVolumeProMapper
  • CursorPosition : vtkVolumeProMapper, vtkImageCursor3D
  • CursorRadius : vtkImageCursor3D
  • CursorType : vtkVolumeProMapper
  • CursorValue : vtkImageCursor3D
  • CursorXAxisColor : vtkVolumeProMapper
  • CursorYAxisColor : vtkVolumeProMapper
  • CursorZAxisColor : vtkVolumeProMapper
  • CustomDisplayExtents : vtkImageMapper
  • Cut : vtkVolumeProMapper
  • CutFunction : vtkCutter
  • CutOff : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • CutPlane : vtkVolumeProMapper
  • CutPlaneEquation : vtkVolumeProMapper
  • CutPlaneFallOffDistance : vtkVolumeProMapper
  • CutPlaneOff() : vtkVolumeProMapper
  • CutPlaneOn() : vtkVolumeProMapper
  • CutPlaneThickness : vtkVolumeProMapper
  • CylinderClip : vtkEncodedGradientEstimator
  • CylinderClipOff() : vtkEncodedGradientEstimator
  • CylinderClipOn() : vtkEncodedGradientEstimator

- d -
  • d : _vtkStreamPoint
  • Dash : vtkGlyphSource2D
  • DashFactor : vtkDashedStreamLine
  • DashOff() : vtkGlyphSource2D
  • DashOn() : vtkGlyphSource2D
  • Data : vtkImageCacheFilter, VectorType< T >, vtkPoints, vtkFieldData
  • DATA_OBJECT : vtkSplitField, vtkRearrangeFields, vtkMergeFields
  • DATA_OBJECT_FIELD : vtkDataSet
  • DATA_TRANSFER_TAG : vtkInputPort
  • DataAppended : vtkImplicitModeller
  • DataByteOrder : vtkPLYWriter
  • DataDescription : vtkStructuredGrid, vtkRectilinearGrid, vtkImageData
  • DataDimensions : vtkVolume16Reader, vtkImageExport
  • DataExtent : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • DataExtentCallback : vtkImageExport, vtkImageImport
  • DataExtentCallbackType : vtkImageImport, vtkImageExport
  • DataHasBeenGenerated() : vtkDataObject
  • DataHeader : vtkWin32ImageWindow
  • DataIncrement : VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • DataIncrements : vtkImageReader2
  • DataMask : vtkVolume16Reader, vtkImageReader
  • DataNormal() : vtkWarpScalar
  • DataObjectInputList : vtkXYPlotActor
  • DataObjectPlotMode : vtkXYPlotActor
  • DataOrigin : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkVideoSource
  • DataOut : vtkXImageMapper, vtkWin32ImageMapper, vtkQuartzImageMapper
  • DataOutSize : vtkXImageMapper
  • DataReleased : vtkDataObject
  • DataScalarType : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • DataSet : vtkPicker, vtkScalarTree, vtkImplicitDataSet, vtkLocator, vtkInterpolatedVelocityField
  • DataSetContour() : vtkMarchingContourFilter, vtkKitwareContourFilter
  • DataSetExecute() : vtkDataSetSurfaceFilter
  • DataSetType : vtkDataObjectToDataSetFilter
  • DataSize : VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • DataSpacing : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkVideoSource
  • DataTime : vtkInputPort
  • DataType : vtkPDataSetReader
  • DataVOI : vtkImageReader
  • DataWasPassed : vtkImageMapToColors, vtkImageBlend
  • Date : vtkMedicalImageReader2
  • DC : vtkRungeKutta45
  • Debug : vtkObject
  • DebugOff() : vtkImageOpenClose3D, vtkObject
  • DebugOn : vtkImageOpenClose3D, vtkObject, vtkTclInterpStruct
  • DebugPrintTree() : vtkOBBNode
  • Decimation : vtkImageToPolyDataFilter
  • DecimationError : vtkImageToPolyDataFilter
  • DecimationOff() : vtkImageToPolyDataFilter
  • DecimationOn() : vtkImageToPolyDataFilter
  • Declarations : vtkRIBProperty
  • Decode8BitData() : vtkSLCReader
  • DecodeArrayName() : vtkDataReader
  • DecodedNormal : vtkRecursiveSphereDirectionEncoder
  • DecomposeStrip() : vtkTriangleStrip
  • DeepCopy() : vtkProperty, vtkLightKit, vtkLight, vtkImageStencilData, vtkPiecewiseFunction, vtkColorTransferFunction, vtkVoidArray, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTensor, vtkStructuredGrid, vtkShortArray, vtkRectilinearGrid, vtkProperty2D, vtkPolyData, vtkPointSet, vtkPoints, vtkMatrix4x4, vtkLongArray, vtkIntArray, vtkImageData, vtkIdTypeArray, vtkIdList, vtkGenericCell, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataSetAttributes, vtkDataSet, vtkDataObject, vtkDataArray, vtkCharArray, vtkCellTypes, vtkCellLinks, vtkCellArray, vtkCell, vtkBitArray, vtkTransformConcatenationStack, vtkTransformConcatenation, vtkAbstractTransform
  • DeepestLevel : vtkOBBTree
  • DefaultBias : vtkKochanekSpline
  • DefaultContinuity : vtkKochanekSpline
  • DefaultNormal : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • DefaultNormalize : vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter
  • DefaultNormalizeOff() : vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter
  • DefaultNormalizeOn() : vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter
  • DefaultTension : vtkKochanekSpline
  • DefaultZ : vtkImageCanvasSource2D
  • Degree : vtkDecimate, vtkDecimatePro
  • DegreesToRadians() : vtkMath
  • Delete() : vtkTimeStamp, vtkObject, vtkSimpleMutexLock, vtkIndent, vtkSimpleCriticalSection, vtkContainer, vtkCommand, vtkTransformConcatenationStack, vtkTransformConcatenation
  • DeleteAllComponents() : vtkSplitField, vtkMergeFields
  • DeleteAllOperations() : vtkRearrangeFields
  • DeleteAndNext() : vtkHeap
  • DeleteAndSetMarshalString() : vtkCommunicator
  • DeleteArrays() : vtkPOPReader
  • DeleteBlockExtents() : vtkImageBlockReader
  • DeleteCell() : vtkPolyData, vtkCellTypes
  • DeleteCells() : vtkPolyData
  • DeleteElement() : vtkCollection, vtkActor2DCollection
  • DeleteEvent : vtkCommand
  • DeleteId() : vtkPriorityQueue, vtkIdList
  • DeleteLastNode() : vtkAssemblyPath
  • DeleteLinks() : vtkPolyData
  • DeleteLocator() : vtkImageMarchingCubes
  • DeleteMessage() : vtkSharedMemoryCommunicator
  • DeleteOperation() : vtkRearrangeFields
  • DeleteOwnLODs() : vtkLODActor
  • DeletePickList() : vtkAbstractPicker
  • DeletePoint() : vtkPolyData, vtkCellLinks
  • DeleteQuadHash() : vtkDataSetSurfaceFilter
  • DeleteSeed() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • DeleteSpecifiedRegion() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • DeleteTable() : vtkDebugLeaks
  • DeleteTree() : vtkOBBTree, vtkOBBDicer
  • DeltaAzimuth : vtkInteractorStyle
  • DeltaElevation : vtkInteractorStyle
  • DeltaRadius : vtkRotationalExtrusionFilter
  • Demand() : VectorType< T >
  • DEMLevel : vtkDEMReader
  • Density : vtkPLOT3DReader
  • Depth : vtkBMPReader, vtkButtonSource, VTKRayCastRayInfo
  • DepthBuffer : vtkVolumeProVP1000Mapper
  • DepthFunc_bucket : vtkOpenGLStateCache
  • DepthMask_bucket : vtkOpenGLStateCache
  • DepthRange_FAR_bucket : vtkOpenGLStateCache
  • DepthRange_NEAR_bucket : vtkOpenGLStateCache
  • depthSize : vtkQuartzGLView
  • DepthSortMode : vtkDepthSortPolyData
  • DepthValues : vtkRendererSource, vtkPOPReader
  • DepthValuesOff() : vtkRendererSource
  • DepthValuesOn() : vtkRendererSource
  • deRefs : _vtkLocalVertex
  • Derivatives() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • Derivs : vtkInitialValueProblemSolver
  • Description : vtkObjectFactory::OverrideInformation
  • DesiredUpdateRate : vtkRenderWindowInteractor, vtkRenderWindow
  • DestroyTimer() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • DestructClass() : vtkDebugLeaks
  • Detached : vtkFieldData::Iterator
  • DetachFieldData() : vtkFieldData::Iterator
  • Determinant() : vtkMatrix4x4
  • Determinant2x2() : vtkMath
  • Determinant3x3() : vtkMath
  • DetermineEnSightVersion() : vtkGenericEnSightReader
  • DetermineSize() : vtkXTextMapper
  • Device : vtkLODActor, vtkFollower
  • DeviceContext : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • DevicePickRender() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • DeviceRender() : vtkRenderer, vtkOpenGLRenderer, vtkMesaRenderer
  • Diagonalize3x3() : vtkMath
  • DiagonalLength : vtkInteractorStyleFlight
  • DIBPtr : vtkWin32ImageWindow
  • DiceMode : vtkDicer
  • Diffuse : vtkVolumeProperty, vtkProperty
  • diffuse : MatProp
  • DiffuseColor : vtkProperty
  • DiffusionFactor : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • DiffusionThreshold : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • DilateValue : vtkImageDilateErode3D
  • Dimension : VTK_POINT_QUADRIC
  • Dimensionality : vtkImageSeedConnectivity, vtkImageResample, vtkImageNonMaximumSuppression, vtkImageLaplacian, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSmooth, vtkImageDecomposeFilter, vtkImageCorrelation
  • Dimensions : vtkPOPReader, vtkDataObjectToDataSetFilter, vtkStructuredGrid, vtkRectilinearGrid, vtkImageData
  • DimensionsArray : vtkDataObjectToDataSetFilter
  • DimensionsArrayComponent : vtkDataObjectToDataSetFilter
  • DimensionsComponentRange : vtkDataObjectToDataSetFilter
  • Direction : vtkImageSinusoidSource, vtkDepthSortPolyData, vtkStreamArray, VTKRayCastRayInfo
  • DirectionEncoder : vtkEncodedGradientEstimator
  • DirectionOfProjection : vtkCamera
  • Disable() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor, vtkObjectFactory
  • DisableLOD() : vtkLODProp3D
  • DisableMotion : vtkInteractorStyleFlight
  • DisableMotionOff() : vtkInteractorStyleFlight
  • DisableMotionOn() : vtkInteractorStyleFlight
  • DisambiguateOperators() : vtkFunctionParser
  • DisjointOBBNodes() : vtkOBBTree
  • DisplacementFileName : vtkBYUWriter, vtkBYUReader
  • DisplacementGrid : vtkGridTransform
  • DisplacementScale : vtkTransformToGrid, vtkGridTransform
  • DisplacementShader : vtkRIBProperty
  • DisplacementShift : vtkTransformToGrid, vtkGridTransform
  • DisplayDebugText() : vtkXMLFileOutputWindow, vtkOutputWindow
  • DisplayedMessage : vtkVolumeProMapper
  • DisplayErrorText() : vtkXMLFileOutputWindow, vtkOutputWindow
  • DisplayExtent : vtkImageMapper, vtkImageActor
  • DisplayGenericWarningText() : vtkXMLFileOutputWindow, vtkOutputWindow
  • DisplayId : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow
  • DisplayLocation : vtkProperty2D
  • DisplayPoint : vtkViewport
  • DisplayTag() : vtkXMLFileOutputWindow
  • DisplayText() : vtkXMLFileOutputWindow, vtkWin32OutputWindow, vtkOutputWindow, vtkFileOutputWindow
  • DisplayToLocalDisplay() : vtkViewport
  • DisplayToNormalizedDisplay() : vtkViewport
  • DisplayToView() : vtkViewport
  • DisplayToWorld() : vtkViewport
  • DisplayWarningText() : vtkXMLFileOutputWindow, vtkOutputWindow
  • DisplayXML() : vtkXMLFileOutputWindow
  • DispObjCenter : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • Dist : vtkInteractorStyleUnicam
  • Distance : vtkCamera, vtkDividingCubes, vtkRecursiveDividingCubes
  • Distance2BetweenPoints() : vtkMath
  • Distance2ToBounds() : vtkCellLocator, vtkPointLocator
  • Distance2ToBucket() : vtkCellLocator, vtkPointLocator
  • DistanceFactor : vtkRuledSurfaceFilter
  • DistanceToLine() : vtkLine
  • DistanceToPlane() : vtkPlane
  • DistributeError() : vtkDecimatePro
  • Distribution : vtkPointSource
  • DivideByZeroToC : vtkImageMathematics
  • DivideByZeroToCOff() : vtkImageMathematics
  • DivideByZeroToCOn() : vtkImageMathematics
  • DivisionOrigin : vtkQuadricClustering
  • Divisions : vtkImageBlockWriter, vtkImageBlockReader, vtkPointLocator2D, vtkPointLocator
  • DivisionSpacing : vtkQuadricClustering
  • DoAARender() : vtkRenderWindow
  • DoCopyAllOff : vtkFieldData
  • DoCopyAllOn : vtkFieldData
  • DoFDRender() : vtkRenderWindow
  • Dolly : vtkInteractorStyleUnicam, vtkCamera, vtkRenderWindowInteractor
  • DollyCamera() : vtkInteractorStyle
  • DollyXY() : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage
  • DonePick() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • DoStereoRender() : vtkRenderWindow
  • Dot() : vtkMath
  • Dot2D() : vtkMath
  • DoTimerStart() : vtkInteractorStyleFlight
  • DoTimerStop() : vtkInteractorStyleFlight
  • DoubleBuffer : vtkWindow
  • DoubleBufferOff() : vtkWindow
  • DoubleBufferOn() : vtkWindow
  • DoubleDegreesToRadians() : vtkMath
  • DoublePoint : vtkTransform, vtkMatrix4x4
  • DoUpdateInformation : vtkInputPort
  • DoVFWFormatCheck() : vtkWin32VideoSource
  • DoVFWFormatSetup() : vtkWin32VideoSource
  • DOWN_DATA_TIME_TAG : vtkInputPort
  • DownPt : vtkInteractorStyleUnicam
  • DPI : vtkWindow
  • Dragable : vtkProp
  • DragableOff() : vtkProp
  • DragableOn() : vtkProp
  • Draw() : vtkOpenGLPolyDataMapper, vtkMesaPolyDataMapper
  • Drawable : vtkXImageWindow
  • DrawBoundingBox : vtkVolumeProVP1000Mapper
  • DrawBuffer_bucket : vtkOpenGLStateCache
  • DrawCircle() : vtkImageCanvasSource2D
  • DrawColor : vtkImageCanvasSource2D
  • DrawPoint() : vtkImageCanvasSource2D
  • DrawSegment() : vtkImageCanvasSource2D
  • DrawSegment3D() : vtkImageCanvasSource2D
  • DTime : vtkInteractorStyleUnicam
  • Dummy : vtkPolyData
  • DumpEntry() : vtkTimerLog
  • DumpLog() : vtkThreadSafeLog, vtkMultiProcessLog, vtkTimerLog
  • Duplicate() : vtkMPICommunicator

- e -
  • EarCutTriangulation() : vtkPolygon
  • EccentricGaussian() : vtkGaussianSplatter
  • Eccentricity : vtkGaussianSplatter
  • EdgeAngle : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • EdgeColor : vtkProperty
  • EdgeCosts : vtkQuadricDecimation
  • EdgeLengths : vtkDecimatePro
  • Edges : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkQuadricDecimation
  • edges : VTK_LINE_CASES, VTK_TRIANGLE_CASES
  • EdgesOff() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • EdgesOn() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • EdgeTable : vtkContourGrid
  • EdgeVisibility : vtkProperty
  • EdgeVisibilityOff() : vtkProperty
  • EdgeVisibilityOn() : vtkProperty
  • elem_count : OtherElem
  • elem_name : OtherElem
  • Element : vtkMatrix4x4
  • ElementIdsListed : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • elems : PlyFile
  • Elevation() : vtkCamera
  • ElevationBounds : vtkDEMReader
  • ElevationPattern : vtkDEMReader
  • ElevationUnitOfMeasure : vtkDEMReader
  • Ellipse : vtkImageVariance3D, vtkImageRange3D, vtkImageDilateErode3D, vtkImageContinuousErode3D, vtkImageContinuousDilate3D
  • EmptyCell : vtkStructuredGrid, vtkPolyData
  • Enable() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • Enable_buckets : vtkOpenGLStateCache
  • Enable_GL_CLIP_PLANE_buckets : vtkOpenGLStateCache
  • Enable_GL_LIGHT_buckets : vtkOpenGLStateCache
  • Enabled : vtkRenderWindowInteractor
  • EnabledFlag : vtkObjectFactory::OverrideInformation
  • EnableLOD() : vtkLODProp3D
  • EncodeArrayName() : vtkWriter
  • EncodedNormals : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkEncodedGradientEstimator
  • EncodedNormalsSize : vtkEncodedGradientEstimator
  • End() : vtkFieldData::BasicIterator
  • end : Chunk
  • EndAppend() : vtkImplicitModeller, vtkQuadricClustering
  • EndAppendUsingPoints() : vtkQuadricClustering
  • EndAppendVertexGeometry() : vtkQuadricClustering
  • EndDolly() : vtkInteractorStyle
  • EndElement() : vtkXMLParser
  • EndElementFunction() : vtkXMLParser
  • EndEvent : vtkCommand
  • ENDIAN_TAG : vtkSocketController
  • EndId : vtkMPIEventLog
  • EndInteractorTag : vtkCompositeManager
  • EndOfDataEvent : vtkCommand
  • EndPan() : vtkInteractorStyle
  • EndPhi : vtkSphereSource
  • EndPickCallback() : vtkRenderWindowInteractor
  • EndPickEvent : vtkCommand
  • EndPickTag : vtkRenderWindowInteractor, vtkAbstractPicker
  • EndPiece : vtkPDataSetWriter
  • EndPoint1List : vtkQuadricDecimation
  • EndPoint2List : vtkQuadricDecimation
  • EndPointer : vtkImageIterator< DType >
  • EndPointInsertion() : vtkDelaunay3D
  • EndRender() : vtkCompositeManager
  • EndRotate() : vtkInteractorStyle
  • EndSpan() : vtkImageIterator< DType >
  • EndSpin() : vtkInteractorStyle
  • EndTag : vtkCompositeManager, vtkViewport, vtkProcessObject
  • EndTheta : vtkSphereSource
  • EndTime : vtkTimerLog
  • EndTimer() : vtkInteractorStyle
  • EndUniformScale() : vtkInteractorStyle
  • EndUserInteraction() : vtkInteractorStyleUser
  • EndWrite : vtkExporter
  • EndWriteArg : vtkExporter
  • EndWriteArgDelete : vtkExporter
  • EndZoom() : vtkInteractorStyle
  • Energy : vtkPLOT3DReader
  • EnlargeOutputUpdateExtents() : vtkSource
  • EnterEvent : vtkCommand
  • enterField() : vtkVRMLImporter
  • enterNode() : vtkVRMLImporter
  • EnterTag : vtkInteractorStyleUser
  • equal_strings() : vtkPLY
  • Erase : vtkOpenGLImager, vtkMesaImager, vtkImager, vtkWindow
  • EraseOff() : vtkWindow
  • EraseOn() : vtkWindow
  • EraseWindow() : vtkXImageWindow, vtkWin32ImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow
  • ErodeValue : vtkImageDilateErode3D
  • Error : vtkSLCReader, vtkImageToPolyDataFilter, vtkNonLinearCell
  • ErrorCodes : vtkInitialValueProblemSolver
  • ErrorEvent : vtkCommand
  • ErrorIds : vtkErrorCode
  • ErrorIncrement : vtkDecimate
  • ErrorIsAbsolute : vtkDecimatePro
  • ErrorPerThread : vtkImageDifference
  • ErrorQuadrics : vtkQuadricDecimation
  • ErrorString() : vtkMPIController
  • EstimatedRenderTime : vtkProp
  • EstimatedTime : vtkLODProp3DEntry
  • EstimateMatrixCondition() : vtkMath
  • EstimateSize() : vtkCellArray
  • Evaluate() : vtkKochanekSpline, vtkCardinalSpline, vtkPlane, vtkFunctionParser
  • EvaluateBounds() : vtkCubeAxesActor2D
  • EvaluateFunction() : vtkSuperquadric, vtkSphere, vtkPerlinNoise, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkCylinder, vtkCone, vtkQuadric, vtkPlanes, vtkPlane, vtkImplicitFunction
  • EvaluateGradient() : vtkSuperquadric, vtkSphere, vtkPerlinNoise, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkCylinder, vtkCone, vtkQuadric, vtkPlanes, vtkPlane, vtkImplicitFunction
  • EvaluateImageAt() : vtkTIFFReader
  • EvaluateLocation() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • EvaluateLoop() : vtkDecimate
  • EvaluateMTime : vtkFunctionParser
  • EvaluatePoint() : vtkCubeAxesActor2D
  • EvaluatePosition() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • EvaluateSet() : vtkImageMandelbrotSource
  • EvaluateVertex() : vtkDecimatePro
  • Event : vtkTimerLogEntry
  • EventCallbackCommand : vtkInteractorStyle
  • EventIds : vtkCommand
  • EventPosition : vtkRenderWindowInteractor
  • EXACT : vtkDataSetAttributes
  • ExchangeAxes : vtkXYPlotActor
  • ExchangeAxesOff() : vtkXYPlotActor
  • ExchangeAxesOn() : vtkXYPlotActor
  • Execute() : vtkSelectVisiblePoints, vtkRendererSource, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSweptSurface, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkKitwareContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkDecimate, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkRectilinearGridOutlineFilter, vtkPVGeometryFilter, vtkPSphereSource, vtkPPolyDataNormals, vtkPOPReader, vtkPLinearExtrusionFilter, vtkPieceScalars, vtkPDataSetReader, vtkPCellDataToPointData, vtkImageBlockReader, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkCutMaterial, vtkVolume16Reader, vtkUnstructuredGridReader, vtkUGFacetReader, vtkStructuredPointsReader, vtkStructuredGridReader, vtkSTLReader, vtkRectilinearGridReader, vtkPolyDataReader, vtkPLYReader, vtkPLOT3DReader, vtkParticleReader, vtkOBJReader, vtkMCubesReader, vtkGenericEnSightReader, vtkEnSightReader, vtkDataSetReader, vtkDataObjectReader, vtkBYUReader, vtkVoxelModeller, vtkTriangularTexture, vtkSurfaceReconstructionFilter, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkExtractVOI, vtkBooleanTexture, vtkWeightedTransformFilter, vtkVectorText, vtkProcrustesAlignmentFilter, vtkPCAAnalysisFilter, vtkImplicitModeller, vtkImageToPolyDataFilter, vtkGLUTesselatorTriangleFilter, vtkEarthSource, vtkDepthSortPolyData, vtkArcPlotter, vtkWindowedSincPolyDataFilter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkWarpLens, vtkVoxelContoursToSurfaceFilter, vtkVectorNorm, vtkVectorDot, vtkTubeFilter, vtkTriangularTCoords, vtkTriangleFilter, vtkTransformTextureCoords, vtkTransformPolyDataFilter, vtkTransformFilter, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold, vtkTextureMapToSphere, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkTexturedSphereSource, vtkTextSource, vtkTensorGlyph, vtkSuperquadricSource, vtkSubPixelPositionEdgels, vtkSubdivideTetra, vtkStructuredGridOutlineFilter, vtkStructuredGridGeometryFilter, vtkStripper, vtkStreamPoints, vtkStreamLine, vtkSplitField, vtkSphereSource, vtkSpherePuzzleArrows, vtkSpherePuzzle, vtkSpatialRepresentationFilter, vtkSmoothPolyDataFilter, vtkSimpleElevationFilter, vtkShrinkPolyData, vtkShrinkFilter, vtkSelectPolyData, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkReverseSense, vtkReflectionFilter, vtkRecursiveDividingCubes, vtkRectilinearGridGeometryFilter, vtkRearrangeFields, vtkQuadricDecimation, vtkQuadricClustering, vtkProjectedTexture, vtkProgrammableSource, vtkProgrammableGlyphFilter, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter, vtkProbeFilter, vtkPolyDataStreamer, vtkPolyDataNormals, vtkPolyDataConnectivityFilter, vtkPointSource, vtkPointDataToCellData, vtkPlaneSource, vtkOutlineSource, vtkOutlineFilter, vtkOutlineCornerSource, vtkOutlineCornerFilter, vtkOBBDicer, vtkMergeFilter, vtkMergeFields, vtkMergeDataObjectFilter, vtkMassProperties, vtkMaskPolyData, vtkMaskPoints, vtkMaskFields, vtkLinkEdgels, vtkLineSource, vtkLinearExtrusionFilter, vtkInterpolatingSubdivisionFilter, vtkInterpolateDataSetAttributes, vtkImplicitTextureCoords, vtkImageDataGeometryFilter, vtkIdFilter, vtkHyperStreamline, vtkHull, vtkHedgeHog, vtkGraphLayoutFilter, vtkGlyphSource2D, vtkGlyph3D, vtkGlyph2D, vtkGeometryFilter, vtkFieldDataToAttributeDataFilter, vtkFeatureEdges, vtkExtractVectorComponents, vtkExtractUnstructuredGrid, vtkExtractTensorComponents, vtkExtractPolyDataGeometry, vtkExtractGrid, vtkExtractGeometry, vtkExtractEdges, vtkElevationFilter, vtkEdgePoints, vtkDiskSource, vtkDelaunay3D, vtkDelaunay2D, vtkDecimatePro, vtkDataSetTriangleFilter, vtkDataSetToDataObjectFilter, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkDashedStreamLine, vtkCylinderSource, vtkCutter, vtkCursor3D, vtkCubeSource, vtkContourGrid, vtkContourFilter, vtkConnectivityFilter, vtkConeSource, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkCellDerivatives, vtkCellDataToPointData, vtkCellCenters, vtkButtonSource, vtkBrownianPoints, vtkBlankStructuredGridWithImage, vtkBlankStructuredGrid, vtkBandedPolyDataContourFilter, vtkAxes, vtkAttributeDataToFieldDataFilter, vtkAssignAttribute, vtkArrowSource, vtkArrayCalculator, vtkApproximatingSubdivisionFilter, vtkAppendPolyData, vtkAppendFilter, vtkPiecewiseFunctionShiftScale, vtkImageToStructuredPoints, vtkImageSource, vtkCastToConcrete, vtkTclCommand, vtkSource, vtkPythonCommand, vtkOldStyleCallbackCommand, vtkJavaCommand, vtkCommand, vtkCallbackCommand
  • ExecuteAxis() : vtkImageGaussianSmooth
  • ExecuteData() : vtkWindowToImageFilter, vtkRTAnalyticSource, vtkTIFFReader, vtkSLCReader, vtkPNGReader, vtkJPEGReader, vtkImageReader2, vtkImageReader, vtkGESignaReader, vtkDEMReader, vtkBMPReader, vtkImageTranslateExtent, vtkImageStencilSource, vtkImageSinusoidSource, vtkImageSeedConnectivity, vtkImageQuantizeRGBToIndex, vtkImageNoiseSource, vtkImageMapToWindowLevelColors, vtkImageMapToColors, vtkImageMandelbrotSource, vtkImageIterateFilter, vtkImageIslandRemoval2D, vtkImageImport, vtkImageGridSource, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkImageCursor3D, vtkImageClip, vtkImageChangeInformation, vtkImageBlend, vtkImageAccumulate, vtkVideoSource, vtkTransformToGrid, vtkRenderLargeImage, vtkPolyDataToImageStencil, vtkSimpleImageToImageFilter, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkImageInPlaceFilter, vtkSource
  • ExecuteExtent : vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D
  • ExecuteFaceQuads() : vtkDataSetSurfaceFilter
  • ExecuteFaceStrips() : vtkDataSetSurfaceFilter
  • ExecuteFft() : vtkImageFourierFilter
  • ExecuteFftForwardBackward() : vtkImageFourierFilter
  • ExecuteFftStep2() : vtkImageFourierFilter
  • ExecuteFftStepN() : vtkImageFourierFilter
  • ExecuteGhostLevel : vtkPolyDataReader, vtkPolyDataSource
  • ExecuteInformation() : vtkWindowToImageFilter, vtkSynchronizedTemplates3D, vtkSweptSurface, vtkKitwareContourFilter, vtkGridSynchronizedTemplates3D, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkRTAnalyticSource, vtkRectilinearGridOutlineFilter, vtkPOPReader, vtkPDataSetReader, vtkImageBlockReader, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkVolume16Reader, vtkTIFFReader, vtkStructuredPointsReader, vtkStructuredGridReader, vtkSLCReader, vtkRectilinearGridReader, vtkPNMReader, vtkPNGReader, vtkPLOT3DReader, vtkParticleReader, vtkJPEGReader, vtkImageReader2, vtkImageReader, vtkGESignaReader, vtkDEMReader, vtkBMPReader, vtkSampleFunction, vtkImageVariance3D, vtkImageTranslateExtent, vtkImageThreshold, vtkImageStencil, vtkImageSpatialFilter, vtkImageSobel3D, vtkImageSobel2D, vtkImageSinusoidSource, vtkImageShrink3D, vtkImageShiftScale, vtkImageSeparableConvolution, vtkImageRFFT, vtkImageReslice, vtkImageResample, vtkImageRange3D, vtkImageQuantizeRGBToIndex, vtkImagePermute, vtkImagePadFilter, vtkImageNormalize, vtkImageNonMaximumSuppression, vtkImageNoiseSource, vtkImageMathematics, vtkImageMask, vtkImageMapToWindowLevelColors, vtkImageMapToColors, vtkImageMandelbrotSource, vtkImageMagnitude, vtkImageMagnify, vtkImageLuminance, vtkImageIterateFilter, vtkImageImport, vtkImageGridSource, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSource, vtkImageFlip, vtkImageFFT, vtkImageExtractComponents, vtkImageEuclideanDistance, vtkImageEllipsoidSource, vtkImageDotProduct, vtkImageDivergence, vtkImageDifference, vtkImageCorrelation, vtkImageClip, vtkImageChangeInformation, vtkImageCast, vtkImageBlend, vtkImageAppendComponents, vtkImageAppend, vtkImageAccumulate, vtkExtractVOI, vtkVideoSource, vtkTransformToGrid, vtkRenderLargeImage, vtkImplicitModeller, vtkSphereSource, vtkProbeFilter, vtkPointSource, vtkOutlineFilter, vtkOutlineCornerFilter, vtkGlyph3D, vtkGeometryFilter, vtkExtractGrid, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkConeSource, vtkCleanPolyData, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsSource, vtkSimpleImageToImageFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkDataSetToDataSetFilter, vtkCastToConcrete, vtkSource
  • ExecuteMethod : vtkProgrammableSource, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter
  • ExecuteMethodArg : vtkProgrammableSource, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter
  • ExecuteMethodArgDelete : vtkProgrammableSource, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter
  • ExecuteNumberOfPieces : vtkPolyDataReader, vtkPolyDataSource
  • ExecutePiece : vtkPolyDataReader, vtkPolyDataSource
  • ExecuteRfft() : vtkImageFourierFilter
  • ExecuteTime : vtkProgrammableSource, vtkMassProperties
  • ExitCallback() : vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • ExitEvent : vtkCommand
  • exitField() : vtkVRMLImporter
  • ExitInteractor() : vtkCompositeManager
  • exitNode() : vtkVRMLImporter
  • ExitTag : vtkRenderWindowInteractor
  • Exponent : vtkLight
  • ExponentFactor : vtkGaussianSplatter
  • Export() : vtkImageExport
  • ExportArrays : vtkRIBExporter
  • ExportArraysOff() : vtkRIBExporter
  • ExportArraysOn() : vtkRIBExporter
  • ExportVoidPointer : vtkImageExport
  • Extend : vtkStreamArray, vtkPriorityQueue, vtkEdgeTable, vtkCellTypes, vtkCellLinks
  • Extent : vtkStructuredGridGeometryFilter, vtkRectilinearGridGeometryFilter, vtkImageDataGeometryFilter, vtkGeometryFilter, vtkExtractUnstructuredGrid, vtkExtentTranslator, vtkDataObject
  • ExtentClipping : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • ExtentClippingOff() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • ExtentClippingOn() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • ExtentListLengths : vtkImageStencilData
  • ExtentLists : vtkImageStencilData
  • ExtentTranslation : vtkImageChangeInformation
  • ExtentTranslator : vtkImageDataStreamer, vtkDataObject
  • external : Material
  • external_type : PlyProperty
  • ExtractBoundaryCells : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractBoundaryCellsOff() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractBoundaryCellsOn() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractEigenvalues : vtkTensorGlyph
  • ExtractEigenvaluesOff() : vtkTensorGlyph
  • ExtractEigenvaluesOn() : vtkTensorGlyph
  • ExtractInside : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractInsideOff() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractInsideOn() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • ExtractionMode : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ExtractNormals : vtkExtractTensorComponents
  • ExtractNormalsOff() : vtkExtractTensorComponents
  • ExtractNormalsOn() : vtkExtractTensorComponents
  • ExtractScalars : vtkExtractTensorComponents
  • ExtractScalarsOff() : vtkExtractTensorComponents
  • ExtractScalarsOn() : vtkExtractTensorComponents
  • ExtractTCoords : vtkExtractTensorComponents
  • ExtractTCoordsOff() : vtkExtractTensorComponents
  • ExtractTCoordsOn() : vtkExtractTensorComponents
  • ExtractToFieldData : vtkExtractVectorComponents
  • ExtractToFieldDataOff() : vtkExtractVectorComponents
  • ExtractToFieldDataOn() : vtkExtractVectorComponents
  • ExtractVectors : vtkExtractTensorComponents
  • ExtractVectorsOff() : vtkExtractTensorComponents
  • ExtractVectorsOn() : vtkExtractTensorComponents
  • ExtrudePoint : vtkLinearExtrusionFilter
  • ExtrusionPoint : vtkLinearExtrusionFilter
  • ExtrusionType : vtkLinearExtrusionFilter
  • EyeAngle : vtkCamera

- f -
  • face : Mesh
  • Faces : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • faces : Mesh
  • FacesOff() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • FacesOn() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • falloff : SpotLight
  • FAngle : _vtkLocalVertex, _vtkProLocalVertex
  • FarClip : VTKRayCastRayInfo
  • FastForward() : vtkVideoSource
  • FatalMILError : vtkMILVideoSource
  • FDFrames : vtkRenderWindow
  • FeatureAngle : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter, vtkPolyDataNormals, vtkFeatureEdges, vtkDecimatePro
  • FeatureAngleIncrement : vtkDecimate
  • FeatureEdges : vtkQuadricClustering, vtkFeatureEdges
  • FeatureEdgeSmoothing : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • FeatureEdgeSmoothingOff() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • FeatureEdgeSmoothingOn() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • FeatureEdgesOff() : vtkFeatureEdges
  • FeatureEdgesOn() : vtkFeatureEdges
  • FeaturePoints : vtkQuadricClustering
  • FeaturePointsAngle : vtkQuadricClustering
  • FieldData : vtkIdFilter, vtkDicer, vtkDataSetToDataObjectFilter, vtkDataObject
  • FieldDataArray : vtkLabeledDataMapper, vtkArcPlotter
  • FieldDataName : vtkDataWriter, vtkDataReader
  • FieldDataNameAllocSize : vtkDataReader
  • FieldDataNameInFile : vtkDataReader
  • FieldDataOff() : vtkIdFilter, vtkDicer, vtkDataSetToDataObjectFilter
  • FieldDataOn() : vtkIdFilter, vtkDicer, vtkDataSetToDataObjectFilter
  • FieldDataType : vtkDataSet
  • FieldList : vtkDataSetAttributes::FieldList, vtkMergeFilter
  • FieldLocation : vtkRearrangeFields, vtkMaskFields, vtkSplitField, vtkMergeFields
  • FieldLocationNames : vtkSplitField, vtkRearrangeFields, vtkMergeFields, vtkMaskFields
  • FieldLocations : vtkSplitField, vtkMergeFields
  • FieldName : vtkSplitField, vtkSplitField::Component, vtkRearrangeFields::Operation, vtkMergeFields, vtkMergeFields::Component, vtkAssignAttribute
  • Fields : vtkFieldData::Iterator
  • FieldType : vtkRearrangeFields, vtkMergeFields, vtkAssignAttribute, vtkSplitField, vtkRearrangeFields::Operation, vtkAssignAttribute
  • FieldTypes : vtkSplitField
  • File : vtkParticleReader, vtkImageReader2
  • file_type : PlyFile
  • FileDimensionality : vtkImageWriter, vtkImageReader2
  • FileFD : vtkVRMLImporter, vtk3DSImporter
  • FileFormat : vtkPLOT3DReader
  • FileFormatError : vtkErrorCode
  • FileLowerLeft : vtkImageWriter, vtkImageReader2
  • FileLowerLeftOff() : vtkImageReader2
  • FileLowerLeftOn() : vtkImageReader2
  • FileName : vtkVRMLExporter, vtkOOGLExporter, vtkIVExporter, vtkImageWindow, vtkSliceCubes, vtkPOPReader, vtkPDataSetReader, vtkUGFacetReader, vtkSTLReader, vtkPLYReader, vtkParticleReader, vtkOBJReader, vtkMCubesReader, vtkImageWriter, vtkImageReader2, vtkDEMReader, vtkDataWriter, vtkDataReader, vtkVRMLImporter, vtk3DSImporter, vtkFileOutputWindow
  • FileNameSliceOffset : vtkImageReader2
  • FileNameSliceSpacing : vtkImageReader2
  • FileNotFoundError : vtkErrorCode
  • FileNumber : vtkImageWriter
  • FilePath : vtkGenericEnSightReader, vtkEnSightReader
  • FilePattern : vtkPDataSetWriter, vtkImageBlockWriter, vtkImageBlockReader, vtkVolumeReader, vtkImageWriter, vtkImageReader2
  • FilePointer : vtkVRMLExporter
  • FilePrefix : vtkOBJExporter, vtkVolumeReader, vtkImageWriter, vtkImageReader2, vtkRIBExporter
  • FilePtr : vtkRIBExporter
  • FileSetFilenameNumbersCollection : vtkEnSightReader
  • FileSetNumberOfStepsCollection : vtkEnSightReader
  • FileSets : vtkEnSightReader
  • FileSetsWithFilenameNumbers : vtkEnSightReader
  • FileType : vtkDataWriter, vtkDataReader
  • FillBox() : vtkImageCanvasSource2D
  • FillComponent() : vtkDataArray
  • Filled : vtkGlyphSource2D
  • FilledOff() : vtkGlyphSource2D
  • FilledOn() : vtkGlyphSource2D
  • FillLight : vtkLightKit
  • FillLightAngle : vtkLightKit
  • FillLightColor : vtkLightKit
  • FillLightWarmth : vtkLightKit
  • FillPixel() : vtkImageCanvasSource2D
  • FillTriangle() : vtkImageCanvasSource2D
  • FillTube() : vtkImageCanvasSource2D
  • FillValue : vtkSweptSurface, vtkImageGridSource
  • Filter0 : vtkImageOpenClose3D
  • Filter1 : vtkImageOpenClose3D
  • FilteredAxes : vtkImagePermute
  • FilteredAxis : vtkImageFlip
  • FinalExtentTranslation : vtkImageChangeInformation
  • Finalize() : vtkThreadedController, vtkSocketController, vtkMultiProcessController, vtkMPIController
  • FinalizeLogging() : vtkMPIEventLog
  • find_element() : vtkPLY
  • find_property() : vtkPLY
  • FindAffectedEdges() : vtkQuadricDecimation
  • FindAndGetCell() : vtkRectilinearGrid, vtkImageData, vtkDataSet
  • FindCell() : vtkRectilinearGrid, vtkPointSet, vtkImageData, vtkDataSet
  • FindClosestInsertedPoint() : vtkPointLocator
  • FindClosestNPoints() : vtkPointLocator2D, vtkPointLocator
  • FindClosestPoint() : vtkCellLocator, vtkPointLocator2D, vtkPointLocator
  • FindClosestPointWithinRadius() : vtkCellLocator, vtkPointLocator
  • FindComponent() : vtkSplitField, vtkMergeFields
  • FindDistributedPoints() : vtkPointLocator2D, vtkPointLocator
  • FindEdge() : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • FindEnclosingFaces() : vtkDelaunay3D
  • FindEndOfMathFunction() : vtkFunctionParser
  • FindFeaturePoints() : vtkQuadricClustering
  • FindFlag() : vtkMaskFields, vtkFieldData
  • FindItem() : vtkAbstractList< DType >
  • FindMessage() : vtkSharedMemoryCommunicator
  • FindOperation() : vtkRearrangeFields
  • FindPickedActor() : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • FindPoint() : vtkRectilinearGrid, vtkPointSet, vtkImageData, vtkDataSet
  • FindPointsWithinRadius() : vtkPointLocator2D, vtkPointLocator
  • FindPokedCamera() : vtkInteractorStyle
  • FindPokedRenderer() : vtkInteractorStyle
  • FindProcessId() : vtkMPIGroup
  • FindSplit() : vtkDecimatePro
  • FindTetra() : vtkDelaunay3D
  • First : vtkHeap
  • FirstCpuTicks : vtkTimerLog
  • FirstRender : vtkImageViewer2
  • FirstWallTime : vtkTimerLog
  • Fit1D() : vtkKochanekSpline, vtkCardinalSpline
  • FitClosed1D() : vtkCardinalSpline
  • FixedUpVector : vtkInteractorStyleFlight
  • FixUpVector : vtkInteractorStyleFlight
  • FixUpVectorOff() : vtkInteractorStyleFlight
  • FixUpVectorOn() : vtkInteractorStyleFlight
  • FlipFrames : vtkVideoSource
  • FlipNormals : vtkMCubesReader, vtkPolyDataNormals
  • FlipNormalsOff() : vtkMCubesReader, vtkPolyDataNormals
  • FlipNormalsOn() : vtkMCubesReader, vtkPolyDataNormals
  • FlipR : vtkTransformTextureCoords
  • FlipROff() : vtkTransformTextureCoords
  • FlipROn() : vtkTransformTextureCoords
  • FlipS : vtkTransformTextureCoords
  • FlipSOff() : vtkTransformTextureCoords
  • FlipSOn() : vtkTransformTextureCoords
  • FlipT : vtkTransformTextureCoords
  • FlipTexture : vtkImplicitTextureCoords
  • FlipTextureOff() : vtkImplicitTextureCoords
  • FlipTextureOn() : vtkImplicitTextureCoords
  • FlipTOff() : vtkTransformTextureCoords
  • FlipTOn() : vtkTransformTextureCoords
  • FloatPoint : vtkMatrix4x4
  • flush() : ostream
  • Flush : vtkFileOutputWindow
  • FlushOff() : vtkFileOutputWindow
  • FlushOn() : vtkFileOutputWindow
  • FlyByKey() : vtkInteractorStyleFlight
  • FlyByMouse() : vtkInteractorStyleFlight
  • Flying : vtkInteractorStyleFlight
  • FlyMode : vtkCubeAxesActor2D
  • FlyTo() : vtkRenderWindowInteractor
  • FlyToImage() : vtkRenderWindowInteractor
  • FocalDepth : vtkInteractorStyle
  • FocalDisk : vtkCamera
  • FocalPoint : vtkLight, vtkCamera, vtkProjectedTexture, vtkCursor3D
  • Focus : vtkCursor3D
  • FocusSphere : vtkInteractorStyleUnicam
  • FocusSphereRenderer : vtkInteractorStyleUnicam
  • Font : vtkWin32TextMapper, vtkQuartzTextMapper
  • FontFactor : vtkAxisActor2D, vtkCubeAxesActor2D
  • FontFamily : vtkTextMapper, vtkScalarBarActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • FontMTime : vtkTextMapper
  • FontSize : vtkTextMapper, vtkLabeledDataMapper
  • ForceBuild() : vtkLookupTable
  • ForceDeepCopy : vtkSharedMemoryCommunicator, vtkMultiProcessController
  • ForceDeepCopyOff() : vtkMultiProcessController
  • ForceDeepCopyOn() : vtkMultiProcessController
  • ForceGrab : vtkMILVideoSource
  • ForegroundColor : vtkTextSource
  • FormatAndMarkEvent() : vtkTimerLog
  • FormatHeight : vtkWarpLens
  • FormatWidth : vtkWarpLens
  • ForwardTransform : vtkTransformPair
  • ForwardTransformDerivative() : vtkThinPlateSplineTransform, vtkGridTransform, vtkWarpTransform
  • ForwardTransformPoint() : vtkThinPlateSplineTransform, vtkGridTransform, vtkWarpTransform
  • fp : PlyFile
  • Frame() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow
  • FrameBuffer : vtkVideoSource
  • FrameBufferBitsPerPixel : vtkVideoSource
  • FrameBufferExtent : vtkVideoSource
  • FrameBufferIndex : vtkVideoSource
  • FrameBufferMutex : vtkVideoSource
  • FrameBufferRowAlignment : vtkVideoSource
  • FrameBufferSize : vtkVideoSource
  • FrameBufferTimeStamps : vtkVideoSource
  • FrameCount : vtkVideoSource
  • FrameCounter : vtkMILVideoSource
  • FrameIndex : vtkVideoSource
  • FrameMaxSize : vtkMILVideoSource
  • FrameOutputExtent : vtkVideoSource
  • FrameRate : vtkVideoSource
  • FrameSize : vtkVideoSource
  • FreeSearchStructure() : vtkOBBTree, vtkCellLocator, vtkPointLocator2D, vtkPointLocator, vtkLocator
  • freeze() : ostrhelp
  • Frequency : vtkPerlinNoise
  • FromFieldLoc : vtkRearrangeFields::Operation
  • FrontfaceCulling : vtkProperty
  • FrontfaceCullingOff() : vtkProperty
  • FrontfaceCullingOn() : vtkProperty
  • Frustum() : vtkPerspectiveTransform
  • Fsmach : vtkPLOT3DReader
  • FullScreen : vtkRenderWindow
  • FullScreenOff() : vtkRenderWindow
  • FullScreenOn() : vtkRenderWindow
  • Function : vtkArrayCalculator, vtkPiecewiseFunction, vtkColorTransferFunction, vtkFunctionParser
  • FunctionFileFunctionNumber : vtkPLOT3DReader
  • FunctionFileName : vtkPLOT3DReader
  • FunctionGradient() : vtkImplicitFunction
  • FunctionInitialize() : vtkVolumeRayCastFunction
  • FunctionLength : vtkFunctionParser
  • FunctionList : vtkPLOT3DReader, vtkImplicitSum, vtkImplicitBoolean
  • FunctionMTime : vtkFunctionParser
  • FunctionParser : vtkArrayCalculator
  • FunctionRange : vtkPiecewiseFunction
  • FunctionSet : vtkInitialValueProblemSolver
  • FunctionSize : vtkPiecewiseFunction, vtkColorTransferFunction
  • FunctionValue() : vtkImplicitFunction
  • FunctionValues() : vtkInterpolatedVelocityField, vtkFunctionSet

- g -
  • Gamma : vtkPLOT3DReader
  • Gate : vtkSharedMemoryCommunicator
  • Gaussian() : vtkGaussianSplatter
  • Gc : vtkXImageWindow
  • GenCell : vtkInterpolatedVelocityField
  • GeneralizedProjectPoint() : vtkPlane
  • GenerateBitmapData() : vtkWin32ImageMapper
  • GenerateClippedOutput : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateClippedOutputOff() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateClippedOutputOn() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateClipPlanes() : vtkXYPlotActor
  • GenerateClipScalars : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateClipScalarsOff() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateClipScalarsOn() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GenerateContourEdges : vtkBandedPolyDataContourFilter
  • GenerateContourEdgesOff() : vtkBandedPolyDataContourFilter
  • GenerateContourEdgesOn() : vtkBandedPolyDataContourFilter
  • GenerateCutScalars : vtkCutter
  • GenerateCutScalarsOff() : vtkCutter
  • GenerateCutScalarsOn() : vtkCutter
  • GenerateErrorScalars : vtkDecimate, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateErrorScalarsOff() : vtkDecimate, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateErrorScalarsOn() : vtkDecimate, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateErrorVectors : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateErrorVectorsOff() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateErrorVectorsOn() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GenerateEvenStencil() : vtkLoopSubdivisionFilter
  • GenerateFace() : vtkCellLocator, vtkPointLocator2D, vtkPointLocator
  • GenerateHull() : vtkHull
  • GenerateIndex() : vtkCellLocator
  • GenerateOddStencil() : vtkLoopSubdivisionFilter
  • GenerateOutput() : vtkSpatialRepresentationFilter
  • GeneratePointIds : vtkGlyph3D
  • GeneratePointIdsOff() : vtkGlyph3D
  • GeneratePointIdsOn() : vtkGlyph3D
  • GeneratePoints() : vtkPOPReader
  • GeneratePolyData() : vtk3DSImporter
  • GeneratePolygons() : vtkOBBTree
  • GenerateRepresentation() : vtkOBBTree, vtkCellLocator, vtkPointLocator2D, vtkPointLocator, vtkLocator
  • GenerateSelectionScalars : vtkSelectPolyData
  • GenerateSelectionScalarsOff() : vtkSelectPolyData
  • GenerateSelectionScalarsOn() : vtkSelectPolyData
  • GenerateSlidingNormals() : vtkPolyLine
  • GenerateSubdivisionCells() : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • GenerateSubdivisionPoints() : vtkLoopSubdivisionFilter, vtkLinearSubdivisionFilter, vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • GenerateTexturesAndRenderQuads() : vtkVolumeTextureMapper2D
  • GenerateUnselectedOutput : vtkSelectPolyData
  • GenerateUnselectedOutputOff() : vtkSelectPolyData
  • GenerateUnselectedOutputOn() : vtkSelectPolyData
  • GenerateValues() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkBandedPolyDataContourFilter, vtkContourValues
  • GenerateVertices : vtkMaskPoints
  • GenerateVerticesOff() : vtkMaskPoints
  • GenerateVerticesOn() : vtkMaskPoints
  • GenericComputeOutputMemorySize() : vtkPipelineSize
  • GenericComputeSourcePipelineSize() : vtkPipelineSize
  • Geometry : vtkDataSetToDataObjectFilter
  • GeometryExtractor : vtkDataSetMapper
  • GeometryFileName : vtkGenericEnSightReader, vtkEnSightReader, vtkBYUWriter, vtkBYUReader
  • GeometryFileSet : vtkEnSightReader
  • GeometryOff() : vtkDataSetToDataObjectFilter
  • GeometryOn() : vtkDataSetToDataObjectFilter
  • GeometryTimeSet : vtkEnSightReader
  • GeometryTimeValue : vtkEnSightReader
  • get() : istream
  • Get() : VectorType< T >
  • get_ascii_item() : vtkPLY
  • get_binary_item() : vtkPLY
  • get_item_value() : vtkPLY
  • get_prop_type() : vtkPLY
  • get_stored_item() : vtkPLY
  • get_words() : vtkPLY
  • GetAAFrames() : vtkRenderWindow
  • GetAbortExecute() : vtkProcessObject
  • GetAbortFlag() : vtkCommand
  • GetAbortRender() : vtkRenderWindow
  • GetAbsolute() : vtkWarpTo
  • GetAbsoluteError() : vtkDecimatePro
  • GetAbsoluteTolerance() : vtkCleanPolyData
  • GetAccumulateError() : vtkDecimatePro
  • GetAccumulationMode() : vtkGaussianSplatter
  • GetAccumulationModeAsString() : vtkGaussianSplatter
  • GetAccuracyCode() : vtkDEMReader
  • GetActiveCamera() : vtkRenderer
  • GetActiveComponent() : vtkImageMapToColors
  • GetActor() : vtkAbstractPropPicker
  • GetActor2D() : vtkImageViewer, vtkAbstractPropPicker
  • GetActorMatrixPointer() : vtkSweptSurface
  • GetActorMode() : vtkInteractorStyleTrackball
  • GetActors() : vtkRenderer, vtkPicker, vtkLODProp3D, vtkAssembly, vtkActor, vtkProp
  • GetActors2D() : vtkViewport, vtkProp, vtkActor2D
  • GetActualMemorySize() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkPointSet, vtkPoints, vtkImageData, vtkFieldData, vtkDataSet, vtkDataObject, vtkDataArray, vtkCellTypes, vtkCellLinks, vtkCellArray
  • GetAddInputValues() : vtkWeightedTransformFilter
  • GetAdjustBounds() : vtkSweptSurface, vtkImplicitModeller
  • GetAdjustDistance() : vtkSweptSurface, vtkImplicitModeller
  • GetAdjustLabels() : vtkAxisActor2D
  • GetAlgorithm() : vtkImageEuclideanDistance
  • GetAllocatedRenderTime() : vtkRenderer, vtkProp
  • GetAllowShift() : vtkImageDifference
  • GetAllScalars() : vtkThreshold
  • GetAlpha() : vtkPLOT3DReader, vtkDelaunay3D, vtkDelaunay2D, vtkScalarsToColors
  • GetAlphaRange() : vtkLookupTable
  • GetAmbient() : vtkVolumeProperty, vtkRenderer, vtkProperty
  • GetAmbientColor() : vtkProperty
  • GetAmplitude() : vtkImageSinusoidSource, vtkPerlinNoise
  • GetAngle() : vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkConeSource, vtkCone
  • GetAngleAccelerationFactor() : vtkInteractorStyleFlight
  • GetAngleStepSize() : vtkInteractorStyleFlight
  • GetApp() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • GetAppend() : vtkFileOutputWindow
  • GetAppendAxis() : vtkImageAppend
  • GetAreaThreshold() : vtkImageIslandRemoval2D
  • GetArray() : vtkFieldData
  • GetArrayAccessMode() : vtkPolyDataMapper2D, vtkMapper
  • GetArrayComponent() : vtkPolyDataMapper2D, vtkMapper
  • GetArrayContainingComponent() : vtkFieldData
  • GetArrayId() : vtkPolyDataMapper2D, vtkMapper, vtkBlankStructuredGrid
  • GetArrayIncrements() : vtkImageData
  • GetArrayName() : vtkPolyDataMapper2D, vtkMapper, vtkCutMaterial, vtkPLYWriter, vtkBlankStructuredGrid, vtkFieldData
  • GetArrayPointer() : vtkImageData
  • GetArrayPointerForExtent() : vtkImageData
  • GetArraySize() : vtkVolume
  • GetAspect() : vtkViewport
  • GetAspectRatio() : vtkDecimate, vtkProjectedTexture
  • GetAssembly() : vtkAbstractPropPicker
  • GetAssignedNumberOfPieces() : vtkBranchExtentTranslator
  • GetAssignedPiece() : vtkBranchExtentTranslator
  • GetAttachmentPoint() : vtkCaptionActor2D
  • GetAttachmentPointCoordinate() : vtkCaptionActor2D
  • GetAttenuationValues() : vtkLight
  • GetAttribute() : vtkDataSetAttributes
  • GetAttributeComponents() : vtkQuadricDecimation
  • GetAttributeIndices() : vtkDataSetAttributes
  • GetAttributeLocation() : vtkMaskFields
  • GetAttributeMode() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • GetAttributeModeAsString() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • GetAttributeType() : vtkMaskFields
  • GetAttributeTypeAsString() : vtkDataSetAttributes
  • GetAutoAdjustCameraClippingRange() : vtkInteractorStyle
  • GetAutoAdjustSampleDistances() : vtkVolumeRayCastMapper
  • GetAutoAdvance() : vtkVideoSource
  • GetAutoCropOutput() : vtkImageReslice
  • GetAutoCroppedOutputBounds() : vtkImageReslice
  • GetAutomatic() : vtkLocator
  • GetAutomaticBoundsComputation() : vtkGraphLayoutFilter
  • GetAutomaticCylinderGeneration() : vtkTextureMapToCylinder
  • GetAutomaticLODSelection() : vtkLODProp3D
  • GetAutomaticNormalGeneration() : vtkImplicitSelectionLoop
  • GetAutomaticPickLODSelection() : vtkLODProp3D
  • GetAutomaticPickPropIndex() : vtkLODProp3D
  • GetAutomaticPlaneGeneration() : vtkTextureMapToPlane
  • GetAutomaticScaleAdjustment() : vtkRayCaster
  • GetAutomaticScaleLowerLimit() : vtkRayCaster
  • GetAutomaticSphereGeneration() : vtkTextureMapToSphere
  • GetAvailableBoardMemory() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkVolumeProMapper
  • GetAveraging() : vtkImageShrink3D, vtkImageDifference
  • GetAxes() : vtkCursor3D
  • GetAxisMagnificationFactor() : vtkImageResample
  • GetAxisTextureSize() : vtkVolumeTextureMapper2D
  • GetAxisUpdateExtent() : vtkImageData
  • GetAxisVisibility() : vtkAxisActor2D
  • GetBackfaceCulling() : vtkProperty
  • GetBackfaceProperty() : vtkActor
  • GetBackground() : vtkRIBExporter, vtkViewport
  • GetBackgroundColor() : vtkImageStencil, vtkImageReslice, vtkTextSource
  • GetBackgroundInput() : vtkImageStencil
  • GetBackgroundLevel() : vtkImageReslice
  • GetBackgroundValue() : vtkImageStencil
  • GetBacking() : vtkTextSource
  • GetBackingStore() : vtkRenderer
  • GetBasis() : vtkThinPlateSplineTransform
  • GetBasisAsString() : vtkThinPlateSplineTransform
  • GetBilinearImageZoom() : vtkRayCaster
  • GetBinaryOutputString() : vtkDataWriter
  • GetBit() : vtkLargeInteger
  • GetBlanking() : vtkStructuredGrid
  • GetBlankingInput() : vtkBlankStructuredGridWithImage
  • GetBlendMode() : vtkVolumeProMapper, vtkImageBlend
  • GetBlendModeAsString() : vtkVolumeProMapper, vtkImageBlend
  • GetBlueDiffuseShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetBlueSpecularShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetBlueValue() : vtkColorTransferFunction
  • GetBold() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • GetBorder() : vtkXYPlotActor, vtkLegendBoxActor, vtkCaptionActor2D
  • GetBorders() : vtkRenderWindow
  • GetBoundaryEdges() : vtkFeatureEdges
  • GetBoundarySmoothing() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetBoundaryVertexDeletion() : vtkDecimate, vtkDecimatePro
  • GetBoundingTriangulation() : vtkDelaunay3D, vtkDelaunay2D
  • GetBounds() : vtkVolumeMapper, vtkVolume, vtkProp3D, vtkPolyDataMapper, vtkMapper, vtkLODProp3D, vtkImageActor, vtkEncodedGradientEstimator, vtkAssembly, vtkActor, vtkAbstractMapper3D, vtkCubeAxesActor2D, vtkOutlineSource, vtkPropAssembly, vtkProp, vtkPoints, vtkDataSet, vtkCell
  • GetBoundsClip() : vtkEncodedGradientEstimator
  • GetBranchingFactor() : vtkSimpleScalarTree
  • GetBreakFlag() : vtkMultiProcessController
  • GetBreakLoopFlag() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • GetBrightnessLevel() : vtkMILVideoSource
  • GetBucketNeighbors() : vtkCellLocator, vtkPointLocator2D, vtkPointLocator
  • GetBufferPointerCallback() : vtkImageImport, vtkImageExport
  • GetBuffersTime : vtkCompositeManager
  • GetBuildTime() : vtkLocator
  • GetBuildTreeExecuteTime() : vtkImageQuantizeRGBToIndex
  • GetButton() : vtkInteractorStyleUser
  • GetButtonDown() : vtkQuartzRenderWindowInteractor
  • GetBypass() : vtkImageToImageFilter, vtkImageMultipleInputFilter
  • GetCacheCellBounds() : vtkCellLocator
  • GetCacheHit() : vtkInterpolatedVelocityField
  • GetCacheMiss() : vtkInterpolatedVelocityField
  • GetCacheSize() : vtkImageCacheFilter
  • GetCaching() : vtkInterpolatedVelocityField
  • GetCallbackUserData() : vtkImageImport, vtkImageExport
  • GetCamera() : vtkFollower, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkArcPlotter
  • GetCameraLightTransformMatrix() : vtkCamera
  • GetCapping() : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller, vtkTubeFilter, vtkRotationalExtrusionFilter, vtkLinearExtrusionFilter, vtkCylinderSource, vtkConeSource
  • GetCaption() : vtkCaptionActor2D
  • GetCapValue() : vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller
  • GetCaseFileName() : vtkGenericEnSightReader, vtkEnSightReader
  • GetCases() : VTK_LINE_CASES, VTK_TRIANGLE_CASES
  • GetCell() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet, vtkCellArray
  • GetCellBounds() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet
  • GetCellClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetCellConnectivityComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetCellConnectivityComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetCellConnectivityComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetCellConnectivityComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetCellData() : vtkDataSetToDataObjectFilter, vtkDataSet
  • GetCellDataWeightArray() : vtkWeightedTransformFilter
  • GetCellDimension() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkGenericCell, vtkEmptyCell, vtkCell3D, vtkCell
  • GetCellEdgeNeighbors() : vtkPolyData
  • GetCellId() : vtkCellPicker
  • GetCellIds() : vtkIdFilter
  • GetCellLinks() : vtkUnstructuredGrid
  • GetCellLocation() : vtkCellTypes
  • GetCellMaximum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetCellMinimum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetCellNeigbors() : vtkStructuredData
  • GetCellNeighbors() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkDataSet
  • GetCellPoints() : vtkUnstructuredGrid, vtkStructuredGrid, vtkStructuredData, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet
  • GetCells() : vtkCellLocator, vtkUnstructuredGrid, vtkCellLinks
  • GetCellType() : vtkWedge, vtkVoxel, vtkVertex, vtkUnstructuredGrid, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkStructuredGrid, vtkRectilinearGrid, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPolyData, vtkPixel, vtkLine, vtkImageData, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkDataSet, vtkCellTypes, vtkCell
  • GetCellTypeComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetCellTypeComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetCellTypeComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetCellTypeComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetCellTypes() : vtkDataSet
  • GetCenter() : vtkProp3D, vtkAbstractMapper3D, vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkWarpLens, vtkTextureMapToSphere, vtkSuperquadricSource, vtkSphereSource, vtkPointSource, vtkPlaneSource, vtkGlyphSource2D, vtkCylinderSource, vtkCubeSource, vtkSuperquadric, vtkSphere, vtkCylinder, vtkViewport, vtkDataSet
  • GetCenterImage() : vtkImageChangeInformation
  • GetCenterPoint() : vtkCutMaterial
  • GetChar() : vtkInteractorStyleUser
  • GetCheckMeanDistance() : vtkIterativeClosestPointTransform
  • GetChildren() : vtkCellLocator
  • GetCircleLimits() : vtkEncodedGradientEstimator
  • GetCircumferentialResolution() : vtkDiskSource, vtkButtonSource
  • GetClamping() : vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction
  • GetClampOverflow() : vtkImageShiftScale, vtkImageCast
  • GetClampScaling() : vtkTensorGlyph
  • GetClampValue() : vtkSpline
  • GetClassName() : vtkThreadSafeLog, vtkMultiProcessLog, vtkTIFFReader, vtkTimeStamp, vtkObject, vtkSimpleMutexLock, vtkIndent, vtkSimpleCriticalSection
  • GetClassOverrideName() : vtkOverrideInformation, vtkObjectFactory
  • GetClassOverrideWithName() : vtkOverrideInformation, vtkObjectFactory
  • GetClientData() : vtkCallbackCommand
  • GetClipData() : vtkImageClip
  • GetClipExtent() : vtkPOPReader
  • GetClipFunction() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GetClippedOutput() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GetClipping() : vtkBandedPolyDataContourFilter
  • GetClippingPlanes() : vtkAbstractMapper
  • GetClippingRange() : vtkCamera
  • GetClipRegion() : vtkVideoSource
  • GetClosed() : vtkSpline
  • GetClosestPoint() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetCloseSurface() : vtkRuledSurfaceFilter
  • GetCloseValue() : vtkImageOpenClose3D
  • GetCoefficients() : vtkQuadric
  • GetColor() : vtkProperty, vtkLight, vtkTIFFReader, vtkPLYWriter, vtkGlyphSource2D, vtkColorTransferFunction, vtkScalarsToColors, vtkProperty2D, vtkLookupTable
  • GetColorByPiece() : vtkPolyDataStreamer
  • GetColorChannels() : vtkVolumeProperty
  • GetColorGlyphs() : vtkTensorGlyph
  • GetColoring() : vtkFeatureEdges
  • GetColorLevel() : vtkImageViewer2, vtkImageViewer, vtkImageMapper
  • GetColorMode() : vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkCGMWriter, vtkImageToPolyDataFilter, vtkProgrammableGlyphFilter, vtkGlyph3D
  • GetColorModeAsString() : vtkPolyDataMapper2D, vtkMapper, vtkProgrammableGlyphFilter, vtkGlyph3D
  • GetColorRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetColors() : vtkPLYWriter, vtkBMPReader
  • GetColorScale() : vtkImageMapper
  • GetColorShift() : vtkImageMapper
  • GetColorSpace() : vtkColorTransferFunction
  • GetColorWindow() : vtkImageViewer2, vtkImageViewer, vtkImageMapper
  • GetColumn() : vtkTensor
  • GetCommand() : vtkObject
  • GetCommunicator() : vtkMultiProcessController
  • GetComplexDescription() : vtkGenericEnSightReader, vtkEnSightReader
  • GetComplexVariableType() : vtkGenericEnSightReader, vtkEnSightReader
  • GetComponent() : vtkPLYWriter, vtkBlankStructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTensor, vtkShortArray, vtkLongArray, vtkIntArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray
  • GetComponentBlendMode() : vtkVolumeMapper
  • GetComponentExtent() : vtkImageAccumulate
  • GetComponentOrigin() : vtkImageAccumulate
  • GetComponents() : vtkImageExtractComponents
  • GetComponentSpacing() : vtkImageAccumulate
  • GetComponentsType() : vtkFieldDataToAttributeDataFilter
  • GetCompositeMethod() : vtkVolumeRayCastCompositeFunction
  • GetCompositeMethodAsString() : vtkVolumeRayCastCompositeFunction
  • GetCompositePerspectiveTransform() : vtkCamera
  • GetCompositePerspectiveTransformMatrix() : vtkCamera
  • GetCompositeTime() : vtkCompositeManager
  • GetCompoundThreshold() : vtkImageBlend
  • GetComputeCellNormals() : vtkPolyDataNormals
  • GetComputedDisplayValue() : vtkCoordinate
  • GetComputedFloatDisplayValue() : vtkCoordinate
  • GetComputedFloatViewportValue() : vtkCoordinate
  • GetComputedLocalDisplayValue() : vtkCoordinate
  • GetComputedUserDefinedValue() : vtkCoordinate
  • GetComputedValue() : vtkCoordinate
  • GetComputedViewportValue() : vtkCoordinate
  • GetComputedWorldValue() : vtkCoordinate
  • GetComputeEffectiveStress() : vtkPointLoad
  • GetComputeGradientMagnitudes() : vtkEncodedGradientEstimator
  • GetComputeGradients() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • GetComputeNormals() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkSampleFunction, vtk3DSImporter, vtkContourGrid, vtkContourFilter, vtkAxes
  • GetComputePointNormals() : vtkPolyDataNormals
  • GetComputeScalars() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • GetConcatenatedTransform() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • GetConeAngle() : vtkLight
  • GetConnectedValue() : vtkImageConnector
  • GetConnector() : vtkImageSeedConnectivity
  • GetConsiderAnisotropy() : vtkImageEuclideanDistance
  • GetConsistency() : vtkPolyDataNormals
  • GetConstant() : vtkImageLogarithmicScale, vtkImageConstantPad
  • GetConstantC() : vtkImageMathematics
  • GetConstantK() : vtkImageMathematics
  • GetConstantSize() : vtkImageMandelbrotSource
  • GetConsumer() : vtkProp, vtkDataObject, vtkAbstractMapper
  • GetContinuousIncrements() : vtkImageData
  • GetContourEdgesOutput() : vtkBandedPolyDataContourFilter
  • GetContrastLevel() : vtkMILVideoSource
  • GetControlKey() : vtkRenderWindowInteractor
  • GetController() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkOutputPort, vtkInputPort, vtkCompositeManager
  • GetConvergence() : vtkSmoothPolyDataFilter
  • GetConvertLinesToPoints() : vtkCleanPolyData
  • GetConvertPolysToLines() : vtkCleanPolyData
  • GetConvertStripsToPolys() : vtkCleanPolyData
  • GetCoolDownRate() : vtkGraphLayoutFilter
  • GetCoordinateSystem() : vtkCoordinate
  • GetCoordinateSystemAsString() : vtkCoordinate
  • GetCopyCellData() : vtkQuadricClustering
  • GetCopyNormals() : vtkDataSetAttributes
  • GetCopyScalars() : vtkDataSetAttributes
  • GetCopyTCoords() : vtkDataSetAttributes
  • GetCopyTensors() : vtkDataSetAttributes
  • GetCopyVectors() : vtkDataSetAttributes
  • GetCornerFactor() : vtkOutlineCornerSource, vtkOutlineCornerFilter
  • GetCornerOffset() : vtkCubeAxesActor2D
  • GetCorners() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetCorrectedScalarOpacityArray() : vtkVolume
  • GetCPUTime() : vtkTimerLog
  • GetCreateGhostCells() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • GetCropping() : vtkVolumeMapper
  • GetCroppingRegionFlags() : vtkVolumeMapper
  • GetCroppingRegionPlanes() : vtkVolumeMapper
  • GetCross() : vtkGlyphSource2D
  • GetCtrlKey() : vtkInteractorStyleUser
  • GetCullers() : vtkRenderer
  • GetCurrentIndex() : vtkFieldData::BasicIterator
  • GetCurrentStyle() : vtkInteractorStyleSwitch
  • GetCurrentTime() : vtkTimerLog
  • GetCursor() : vtkVolumeProMapper
  • GetCursorPosition() : vtkVolumeProMapper, vtkImageCursor3D
  • GetCursorRadius() : vtkImageCursor3D
  • GetCursorType() : vtkVolumeProMapper
  • GetCursorTypeAsString() : vtkVolumeProMapper
  • GetCursorValue() : vtkImageCursor3D
  • GetCursorXAxisColor() : vtkVolumeProMapper
  • GetCursorYAxisColor() : vtkVolumeProMapper
  • GetCursorZAxisColor() : vtkVolumeProMapper
  • GetCustomDisplayExtents() : vtkImageMapper
  • GetCutFunction() : vtkCutter
  • GetCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • GetCutPlane() : vtkVolumeProMapper
  • GetCutPlaneEquation() : vtkVolumeProMapper
  • GetCutPlaneFallOffDistance() : vtkVolumeProMapper
  • GetCutPlaneThickness() : vtkVolumeProMapper
  • GetCylinderClip() : vtkEncodedGradientEstimator
  • GetDash() : vtkGlyphSource2D
  • GetDashFactor() : vtkDashedStreamLine
  • GetData() : vtkPoints, vtkDataArray, vtkCellArray
  • GetDataByteOrder() : vtkVolume16Reader, vtkPLYWriter, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • GetDataByteOrderAsString() : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • GetDataDimension() : vtkStructuredGrid, vtkStructuredData, vtkRectilinearGrid, vtkImageData
  • GetDataDimensions() : vtkVolume16Reader, vtkImageExport
  • GetDataExtent() : vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkImageExport
  • GetDataExtentCallback() : vtkImageImport, vtkImageExport
  • GetDataIncrements() : vtkImageReader2
  • GetDataMask() : vtkVolume16Reader, vtkImageReader
  • GetDataMemorySize() : vtkImageExport
  • GetDataNumberOfScalarComponents() : vtkImageExport
  • GetDataObject() : vtkMergeDataObjectFilter
  • GetDataObjectInputList() : vtkXYPlotActor
  • GetDataObjectPlotMode() : vtkXYPlotActor
  • GetDataObjectPlotModeAsString() : vtkXYPlotActor
  • GetDataObjectType() : vtkImageStencilData, vtkPiecewiseFunction, vtkUnstructuredGrid, vtkStructuredPoints, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet, vtkDataObject
  • GetDataObjectXComponent() : vtkXYPlotActor
  • GetDataObjectYComponent() : vtkXYPlotActor
  • GetDataOrigin() : vtkVolumeTextureMapper, vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkImageExport, vtkVideoSource
  • GetDataPointer() : vtkPiecewiseFunction, vtkColorTransferFunction
  • GetDataReleased() : vtkDataObject
  • GetDataScalarType() : vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkImageExport
  • GetDataScalarTypeAsString() : vtkImageImport, vtkImageGridSource, vtkImageExport
  • GetDataSet() : vtkPicker, vtkScalarTree, vtkImplicitDataSet, vtkLocator, vtkInterpolatedVelocityField
  • GetDataSetType() : vtkDataObjectToDataSetFilter
  • GetDataSpacing() : vtkVolumeTextureMapper, vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkImageExport, vtkVideoSource
  • GetDataType() : vtkPDataSetReader, vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPoints, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • GetDataTypeMax() : vtkDataArray
  • GetDataTypeMin() : vtkDataArray
  • GetDataTypeRange() : vtkDataArray
  • GetDataTypeSize() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • GetDataVOI() : vtkImageReader
  • GetDate() : vtkMedicalImageReader2
  • GetDebug() : vtkObject
  • GetDecimation() : vtkImageToPolyDataFilter
  • GetDecimationError() : vtkImageToPolyDataFilter
  • GetDeclarations() : vtkRIBProperty
  • GetDecodedGradient() : vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder
  • GetDecodedGradientTable() : vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder
  • GetDefaultBias() : vtkKochanekSpline
  • GetDefaultContinuity() : vtkKochanekSpline
  • GetDefaultNormal() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • GetDefaultNormalize() : vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter
  • GetDefaultTension() : vtkKochanekSpline
  • GetDefaultVisualInfo() : vtkXImageWindow
  • GetDefaultZ() : vtkImageCanvasSource2D
  • GetDegree() : vtkDecimate, vtkDecimatePro
  • GetDeltaRadius() : vtkRotationalExtrusionFilter
  • GetDEMLevel() : vtkDEMReader
  • GetDepth() : vtkBMPReader, vtkButtonSource
  • GetDepthBufferSize() : vtkRenderWindow, vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • GetDepthBufferValues() : vtkVolumeProVP1000Mapper, vtkOpenGLVolumeProVP1000Mapper
  • GetDepthSortMode() : vtkDepthSortPolyData
  • GetDepthValues() : vtkRendererSource
  • GetDescription() : vtkParallelFactory, vtkGenericEnSightReader, vtkEnSightReader, vtkOverrideInformation, vtkObjectFactory
  • GetDescriptiveName() : vtkTIFFReader, vtkSLCReader, vtkPNMReader, vtkPNGReader, vtkJPEGReader, vtkImageReader2, vtkGESignaReader, vtkBMPReader
  • GetDesiredColormap() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow
  • GetDesiredDepth() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow
  • GetDesiredUpdateRate() : vtkRenderWindowInteractor, vtkRenderWindow
  • GetDesiredVisual() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow
  • GetDesiredVisualInfo() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkOpenGLImageWindow, vtkMesaImageWindow
  • GetDIBPtr() : vtkWin32ImageWindow
  • GetDiceMode() : vtkDicer
  • GetDiffuse() : vtkVolumeProperty, vtkProperty
  • GetDiffuseColor() : vtkProperty
  • GetDiffusionFactor() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetDiffusionThreshold() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetDilateValue() : vtkImageDilateErode3D
  • GetDimensionality() : vtkImageSeedConnectivity, vtkImageResample, vtkImageNonMaximumSuppression, vtkImageLaplacian, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSmooth, vtkImageDecomposeFilter, vtkImageCorrelation
  • GetDimensions() : vtkPOPReader, vtkDataObjectToDataSetFilter, vtkStructuredGrid, vtkRectilinearGrid, vtkImageData
  • GetDirection() : vtkImageSinusoidSource, vtkDepthSortPolyData
  • GetDirectionEncoder() : vtkEncodedGradientEstimator
  • GetDirectionOfProjection() : vtkCamera
  • GetDisableMotion() : vtkInteractorStyleFlight
  • GetDisplacementFileName() : vtkBYUWriter, vtkBYUReader
  • GetDisplacementGrid() : vtkGridTransform
  • GetDisplacementScale() : vtkTransformToGrid, vtkGridTransform
  • GetDisplacementShader() : vtkRIBProperty
  • GetDisplacementShift() : vtkTransformToGrid, vtkGridTransform
  • GetDisplayExtent() : vtkImageActor
  • GetDisplayId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow
  • GetDisplayLocation() : vtkProperty2D
  • GetDisplayPoint() : vtkViewport
  • GetDistance() : vtkCamera, vtkDividingCubes, vtkRecursiveDividingCubes
  • GetDistanceFactor() : vtkRuledSurfaceFilter
  • GetDistribution() : vtkPointSource
  • GetDivideByZeroToC() : vtkImageMathematics
  • GetDivisionOrigin() : vtkQuadricClustering
  • GetDivisions() : vtkImageBlockWriter, vtkImageBlockReader, vtkPointLocator2D, vtkPointLocator
  • GetDivisionSpacing() : vtkQuadricClustering
  • GetDolly() : vtkRenderWindowInteractor
  • GetDoubleBuffer() : vtkWindow
  • GetDoUpdateInformation() : vtkInputPort
  • GetDPI() : vtkWindow
  • GetDragable() : vtkProp
  • GetDrawColor() : vtkImageCanvasSource2D
  • GetEccentricity() : vtkGaussianSplatter
  • GetEdge() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • GetEdgeAngle() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetEdgeArray() : vtkWedge, vtkVoxel, vtkTetra, vtkPyramid, vtkHexahedron
  • GetEdgeCellId() : vtkQuadricDecimation
  • GetEdgeColor() : vtkProperty
  • GetEdgePoints() : vtkWedge, vtkVoxel, vtkTetra, vtkPyramid, vtkHexahedron, vtkCell3D
  • GetEdges() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetEdgeVisibility() : vtkProperty
  • GetElapsedTime() : vtkThreadSafeLog, vtkTimerLog
  • GetElement() : vtkMatrix4x4
  • GetElementaryOperatorNumber() : vtkFunctionParser
  • GetElementType() : vtkEnSightReader
  • GetElevationBounds() : vtkDEMReader
  • GetElevationPattern() : vtkDEMReader
  • GetElevationUnitOfMeasure() : vtkDEMReader
  • GetEnabled() : vtkRenderWindowInteractor
  • GetEnableFlag() : vtkObjectFactory
  • GetEncodedDirection() : vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder
  • GetEncodedNormalIndex() : vtkEncodedGradientEstimator
  • GetEncodedNormals() : vtkVolumeTextureMapper, vtkEncodedGradientEstimator
  • GetEndPhi() : vtkSphereSource
  • GetEndPiece() : vtkPDataSetWriter
  • GetEndTheta() : vtkSphereSource
  • GetEntryColor() : vtkLegendBoxActor
  • GetEntryString() : vtkLegendBoxActor
  • GetEntrySymbol() : vtkLegendBoxActor
  • GetErase() : vtkWindow
  • GetErodeValue() : vtkImageDilateErode3D
  • GetError() : vtkSLCReader, vtkImageDifference, vtkImageToPolyDataFilter, vtkNonLinearCell
  • GetErrorCode() : vtkSource
  • GetErrorCodeFromString() : vtkErrorCode
  • GetErrorIncrement() : vtkDecimate
  • GetErrorIsAbsolute() : vtkDecimatePro
  • GetEstimatedMemorySize() : vtkPSphereSource, vtkImageData, vtkDataObject
  • GetEstimatedRenderTime() : vtkProp
  • GetEstimatedSize() : vtkPipelineSize
  • GetEvals() : vtkPCAAnalysisFilter
  • GetEventIdFromString() : vtkCommand
  • GetEventPending() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindow, vtkQuartzRenderWindow
  • GetEventPosition() : vtkRenderWindowInteractor
  • GetExchangeAxes() : vtkXYPlotActor
  • GetExecuteExtent() : vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D
  • GetExponent() : vtkLight
  • GetExponentFactor() : vtkGaussianSplatter
  • GetExportArrays() : vtkRIBExporter
  • GetExportVoidPointer() : vtkImageExport
  • GetExtent() : vtkImageStencilData, vtkStructuredGridGeometryFilter, vtkRectilinearGridGeometryFilter, vtkImageDataGeometryFilter, vtkGeometryFilter, vtkExtractUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkImageData, vtkExtentTranslator
  • GetExtentClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetExtentTranslation() : vtkImageChangeInformation
  • GetExtentTranslator() : vtkImageDataStreamer, vtkDataObject
  • GetExtentType() : vtkImageStencilData, vtkStructuredGrid, vtkRectilinearGrid, vtkImageData, vtkDataObject
  • GetExtractBoundaryCells() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • GetExtractEigenvalues() : vtkTensorGlyph
  • GetExtractInside() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • GetExtractionMode() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetExtractionModeAsString() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetExtractNormals() : vtkExtractTensorComponents
  • GetExtractScalars() : vtkExtractTensorComponents
  • GetExtractTCoords() : vtkExtractTensorComponents
  • GetExtractToFieldData() : vtkExtractVectorComponents
  • GetExtractVectors() : vtkExtractTensorComponents
  • GetExtrusionPoint() : vtkLinearExtrusionFilter
  • GetExtrusionType() : vtkLinearExtrusionFilter
  • GetEyeAngle() : vtkCamera
  • GetFace() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • GetFaceArray() : vtkWedge, vtkVoxel, vtkTetra, vtkPyramid, vtkHexahedron
  • GetFacePoints() : vtkWedge, vtkVoxel, vtkTetra, vtkPyramid, vtkHexahedron, vtkCell3D
  • GetFaces() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetFDFrames() : vtkRenderWindow
  • GetFeatureAngle() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter, vtkPolyDataNormals, vtkFeatureEdges, vtkDecimatePro
  • GetFeatureAngleIncrement() : vtkDecimate
  • GetFeatureEdges() : vtkQuadricClustering, vtkFeatureEdges
  • GetFeatureEdgeSmoothing() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetFeaturePointsAngle() : vtkQuadricClustering
  • GetField() : vtkFieldData
  • GetFieldArray() : vtkFieldDataToAttributeDataFilter
  • GetFieldData() : vtkIdFilter, vtkDicer, vtkDataSetToDataObjectFilter, vtkDataObject
  • GetFieldDataArray() : vtkLabeledDataMapper, vtkArcPlotter
  • GetFieldDataFromLocation() : vtkRearrangeFields
  • GetFieldDataName() : vtkDataWriter, vtkDataReader, vtkDataObjectWriter
  • GetFieldDataNameInFile() : vtkDataReader
  • GetFile() : vtkImageReader2, vtkDirectory
  • GetFileDimensionality() : vtkImageWriter, vtkImageReader2
  • GetFileExensions() : vtkTIFFReader, vtkSLCReader, vtkPNMReader, vtkPNGReader, vtkJPEGReader, vtkImageReader2, vtkGESignaReader, vtkBMPReader
  • GetFileFD() : vtkVRMLImporter, vtk3DSImporter
  • GetFileFormat() : vtkPLOT3DReader
  • GetFileLowerLeft() : vtkImageReader2
  • GetFileName() : vtkVRMLExporter, vtkOOGLExporter, vtkIVExporter, vtkImageWindow, vtkSliceCubes, vtkPOPReader, vtkPDataSetReader, vtkUGFacetReader, vtkSTLReader, vtkSLCReader, vtkPLYReader, vtkParticleReader, vtkOBJReader, vtkMCubesReader, vtkImageWriter, vtkImageReader2, vtkDEMReader, vtkDataWriter, vtkDataReader, vtkDataObjectWriter, vtkVRMLImporter, vtk3DSImporter, vtkFileOutputWindow
  • GetFileNameSliceOffset() : vtkImageReader2
  • GetFileNameSliceSpacing() : vtkImageReader2
  • GetFilePath() : vtkGenericEnSightReader, vtkEnSightReader
  • GetFilePattern() : vtkPDataSetWriter, vtkImageBlockWriter, vtkImageBlockReader, vtkVolumeReader, vtkImageWriter, vtkImageReader2
  • GetFilePrefix() : vtkOBJExporter, vtkVolumeReader, vtkImageWriter, vtkImageReader2, vtkRIBExporter
  • GetFileType() : vtkPLOT3DReader, vtkDataWriter, vtkDataReader, vtkDataObjectWriter
  • GetFilled() : vtkGlyphSource2D
  • GetFillLightAngle() : vtkLightKit
  • GetFillLightAzimuth() : vtkLightKit
  • GetFillLightColor() : vtkLightKit
  • GetFillLightElevation() : vtkLightKit
  • GetFillLightWarmth() : vtkLightKit
  • GetFillValue() : vtkSweptSurface, vtkImageGridSource
  • GetFilter0() : vtkImageOpenClose3D
  • GetFilter1() : vtkImageOpenClose3D
  • GetFilteredAxes() : vtkImagePermute
  • GetFilteredAxis() : vtkImageFlip
  • GetFirst() : vtkSplitField, vtkRearrangeFields, vtkMergeFields
  • GetFirstNode() : vtkAssemblyPath
  • GetFirstNonZeroValue() : vtkPiecewiseFunction
  • GetFixedUpVector() : vtkInteractorStyleFlight
  • GetFixUpVector() : vtkInteractorStyleFlight
  • GetFlag() : vtkMaskFields, vtkFieldData
  • GetFlipNormals() : vtkMCubesReader, vtkPolyDataNormals
  • GetFlipR() : vtkTransformTextureCoords
  • GetFlipS() : vtkTransformTextureCoords
  • GetFlipT() : vtkTransformTextureCoords
  • GetFlipTexture() : vtkImplicitTextureCoords
  • GetFlush() : vtkFileOutputWindow
  • GetFlyMode() : vtkCubeAxesActor2D
  • GetFocalDisk() : vtkCamera
  • GetFocalPoint() : vtkLight, vtkCamera, vtkProjectedTexture, vtkCursor3D
  • GetFocus() : vtkCursor3D
  • GetFontFactor() : vtkAxisActor2D, vtkCubeAxesActor2D
  • GetFontFamily() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • GetFontSize() : vtkTextMapper, vtkLabeledDataMapper
  • GetForceDeepCopy() : vtkMultiProcessController
  • GetForegroundColor() : vtkTextSource
  • GetFormat() : vtkTIFFReader
  • GetFormatHeight() : vtkWarpLens
  • GetFormatWidth() : vtkWarpLens
  • GetFrameBufferSize() : vtkVideoSource
  • GetFrameCount() : vtkVideoSource
  • GetFrameIndex() : vtkVideoSource
  • GetFrameRate() : vtkVideoSource
  • GetFrameSize() : vtkVideoSource
  • GetFrameTimeStamp() : vtkVideoSource
  • GetFrequency() : vtkPerlinNoise
  • GetFrontfaceCulling() : vtkProperty
  • GetFrustumPlanes() : vtkCamera
  • GetFsmach() : vtkPLOT3DReader
  • GetFullScreen() : vtkRenderWindow
  • GetFunction() : vtkArrayCalculator, vtkImplicitBoolean, vtkFunctionParser
  • GetFunctionFileName() : vtkPLOT3DReader
  • GetFunctionSet() : vtkInitialValueProblemSolver
  • GetGamma() : vtkPLOT3DReader
  • GetGC() : vtkXImageWindow
  • GetGenerateClippedOutput() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GetGenerateClipScalars() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GetGenerateContourEdges() : vtkBandedPolyDataContourFilter
  • GetGenerateCutScalars() : vtkCutter
  • GetGenerateErrorScalars() : vtkDecimate, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetGenerateErrorVectors() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetGeneratePointIds() : vtkGlyph3D
  • GetGenerateSelectionScalars() : vtkSelectPolyData
  • GetGenerateUnselectedOutput() : vtkSelectPolyData
  • GetGenerateVertices() : vtkMaskPoints
  • GetGenericContext() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • GetGenericDisplayId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • GetGenericDrawable() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkRenderWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • GetGenericParentId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • GetGenericWindowId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • GetGeometry() : vtkMergeFilter, vtkDataSetToDataObjectFilter
  • GetGeometryFileName() : vtkGenericEnSightReader, vtkEnSightReader, vtkEnSightGoldReader, vtkBYUWriter, vtkBYUReader
  • GetGetBuffersTime() : vtkCompositeManager
  • GetGhostLevel() : vtkPolyDataMapper, vtkPDataSetWriter, vtkUnstructuredGrid, vtkPolyData, vtkExtentTranslator
  • GetGlobalController() : vtkMultiProcessController
  • GetGlobalDefaultNumberOfThreads() : vtkMultiThreader
  • GetGlobalImmediateModeRendering() : vtkMapper
  • GetGlobalMaximumNumberOfMultiSamples() : vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • GetGlobalMaximumNumberOfThreads() : vtkMultiThreader
  • GetGlobalReleaseDataFlag() : vtkDataObject
  • GetGlobalWarningDisplay() : vtkObject
  • GetGlyphSize() : vtkXYPlotActor
  • GetGlyphSource() : vtkXYPlotActor
  • GetGlyphType() : vtkGlyphSource2D
  • GetGradientDiffuseModulation() : vtkVolumeProMapper
  • GetGradientEstimator() : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • GetGradientMagnitudeBias() : vtkVolumeTextureMapper, vtkVolumeRayCastMapper, vtkVolumeMapper, vtkEncodedGradientEstimator
  • GetGradientMagnitudes() : vtkVolumeTextureMapper, vtkEncodedGradientEstimator
  • GetGradientMagnitudeScale() : vtkVolumeTextureMapper, vtkVolumeRayCastMapper, vtkVolumeMapper, vtkEncodedGradientEstimator
  • GetGradientMagnitudeThreshold() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GetGradientOpacity() : vtkVolumeProperty
  • GetGradientOpacityArray() : vtkVolumeTextureMapper, vtkVolume
  • GetGradientOpacityConstant() : vtkVolume
  • GetGradientOpacityModulation() : vtkVolumeProMapper
  • GetGradientOpacityMTime() : vtkVolumeProperty
  • GetGradientShader() : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • GetGradientSpecularModulation() : vtkVolumeProMapper
  • GetGradientThreshold() : vtkLinkEdgels
  • GetGradMaps() : vtkSubPixelPositionEdgels
  • GetGraphBounds() : vtkGraphLayoutFilter
  • GetGrayArray() : vtkVolume
  • GetGrayScaleHint() : vtkImageWindow, vtkImageViewer
  • GetGrayTransferFunction() : vtkVolumeProperty
  • GetGrayTransferFunctionMTime() : vtkVolumeProperty
  • GetGreenDiffuseShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetGreenSpecularShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetGreenValue() : vtkColorTransferFunction
  • GetGridExtent() : vtkTransformToGrid
  • GetGridFileName() : vtkPOPReader
  • GetGridNumber() : vtkPLOT3DReader
  • GetGridOrigin() : vtkImageGridSource, vtkTransformToGrid
  • GetGridScalarType() : vtkTransformToGrid
  • GetGridSpacing() : vtkImageGridSource, vtkTransformToGrid
  • GetGroundSystem() : vtkDEMReader
  • GetGroundZone() : vtkDEMReader
  • GetHandleBoundaries() : vtkImageNonMaximumSuppression, vtkImageGradientMagnitude, vtkImageGradient
  • GetHandleObservers() : vtkInteractorStyle
  • GetHeader() : vtkDataWriter, vtkDataReader, vtkDataObjectWriter
  • GetHeaderSize() : vtkVolume16Reader, vtkMCubesReader, vtkImageReader2
  • GetHeadlightColor() : vtkLightKit
  • GetHeadlightWarmth() : vtkLightKit
  • GetHeight() : vtkTextMapper, vtkArcPlotter, vtkCylinderSource, vtkConeSource, vtkButtonSource, vtkActor2D
  • GetHighPoint() : vtkElevationFilter
  • GetHomogeneousInverse() : vtkHomogeneousTransform
  • GetHueLevel() : vtkMILVideoSource
  • GetHueRange() : vtkLookupTable
  • GetId() : vtkIdList
  • GetIdsArrayName() : vtkIdFilter
  • GetIdsOfCellsOfType() : vtkUnstructuredGrid
  • GetImage() : vtkVolumeReader, vtkVolume16Reader, vtkImageDifference
  • GetImageActor() : vtkImageViewer2
  • GetImageData() : vtkImageCanvasSource2D
  • GetImageDataOutput() : vtkInputPort
  • GetImageHeight() : vtkWarpLens
  • GetImageLowerLeft() : vtkImageExport
  • GetImageMapper() : vtkImageViewer
  • GetImageNumber() : vtkMedicalImageReader2
  • GetImager() : vtkImageViewer
  • GetImageRange() : vtkMarchingSquares, vtkVolumeReader
  • GetImagers() : vtkImageWindow
  • GetImageSampleDistance() : vtkVolumeRayCastMapper
  • GetImageScale() : vtkRayCaster
  • GetImageScaleCount() : vtkRayCaster
  • GetImageWidth() : vtkWarpLens
  • GetImageWindow() : vtkImageViewer, vtkImager
  • GetImmediateModeRendering() : vtkMapper
  • GetImplicitFunction() : vtkSampleFunction, vtkExtractPolyDataGeometry, vtkExtractGeometry, vtkImplicitWindowFunction
  • GetImportVoidPointer() : vtkImageImport
  • GetInAbortCheck() : vtkRenderWindow
  • GetIncludeBoundary() : vtkExtractGrid
  • GetIncrement() : vtkDividingCubes, vtkRecursiveDividingCubes
  • GetIncrements() : vtkImageData
  • GetIndependentComponents() : vtkVolumeMapper
  • GetIndependentVariables() : vtkParallelCoordinatesActor
  • GetIndex() : vtkLookupTable
  • GetIndexMatrix() : vtkImageReslice
  • GetIndexMode() : vtkGlyph3D
  • GetIndexModeAsString() : vtkGlyph3D
  • GetInertia() : vtkCubeAxesActor2D
  • GetInflectionPointRatio() : vtkDecimatePro
  • GetInflectionPoints() : vtkDecimatePro
  • GetInformationInput() : vtkImageReslice, vtkImageChangeInformation
  • GetInIn() : vtkBooleanTexture
  • GetInitialError() : vtkDecimate
  • GetInitialFeatureAngle() : vtkDecimate
  • GetInitialize() : vtkImageEuclideanDistance
  • GetInitialized() : vtkRenderWindowInteractor, vtkVideoSource
  • GetInitializeExecuteTime() : vtkImageQuantizeRGBToIndex
  • GetInnerRadius() : vtkDiskSource
  • GetInOn() : vtkBooleanTexture
  • GetInOut() : vtkBooleanTexture
  • GetInput() : vtkWindowToImageFilter, vtkVolumeMapper, vtkTexture, vtkTextMapper, vtkRendererSource, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkParallelCoordinatesActor, vtkMapper, vtkLabeledDataMapper, vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor, vtkExporter, vtkEncodedGradientEstimator, vtkDataSetMapper, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkImageMarchingCubes, vtkOutputPort, vtkImageBlockWriter, vtkWriter, vtkUnstructuredGridWriter, vtkStructuredPointsWriter, vtkStructuredGridWriter, vtkRectilinearGridWriter, vtkPolyDataWriter, vtkImageWriter, vtkDataSetWriter, vtkDataObjectWriter, vtkImplicitFunctionToImageStencil, vtkImageToImageStencil, vtkImageExport, vtkTransformToGrid, vtkRenderLargeImage, vtkProcrustesAlignmentFilter, vtkPolyDataToImageStencil, vtkPCAAnalysisFilter, vtkCubeAxesActor2D, vtkSpatialRepresentationFilter, vtkMassProperties, vtkExtractVectorComponents, vtkDelaunay3D, vtkDelaunay2D, vtkDataSetToDataObjectFilter, vtkDataObjectToDataSetFilter, vtkAppendPolyData, vtkAppendFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkUnstructuredGridToPolyDataFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToPolyDataFilter, vtkStructuredGridToStructuredGridFilter, vtkStructuredGridToPolyDataFilter, vtkSimpleImageToImageFilter, vtkRectilinearGridToPolyDataFilter, vtkPolyDataToPolyDataFilter, vtkPointSetToPointSetFilter, vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkDataSetToUnstructuredGridFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToStructuredGridFilter, vtkDataSetToPolyDataFilter, vtkDataSetToDataSetFilter, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkGeneralTransform
  • GetInput1() : vtkImageTwoInputFilter
  • GetInput2() : vtkImageTwoInputFilter
  • GetInputArray() : vtkDataReader
  • GetInputAsDataSet() : vtkMapper
  • GetInputAspect() : vtkEncodedGradientEstimator
  • GetInputConnectValue() : vtkImageSeedConnectivity
  • GetInputField() : vtkFieldDataToAttributeDataFilter
  • GetInputList() : vtkXYPlotActor, vtkProgrammableAttributeDataFilter, vtkInterpolateDataSetAttributes, vtkAppendFilter
  • GetInputMemoryLimit() : vtkSynchronizedTemplates3D, vtkImageMarchingCubes, vtkImageToImageFilter
  • GetInputs() : vtkProcessObject
  • GetInputScalarsSelection() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkGridSynchronizedTemplates3D, vtkWarpScalar, vtkThreshold, vtkContourGrid, vtkContourFilter, vtkClipDataSet
  • GetInputSize() : vtkEncodedGradientEstimator
  • GetInputString() : vtkDataReader
  • GetInputStringLength() : vtkDataReader
  • GetInputType() : vtkImageQuantizeRGBToIndex
  • GetInputVectorsSelection() : vtkWarpVector
  • GetInsertLocation() : vtkCellArray
  • GetInsideOut() : vtkSelectPolyData, vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • GetInstallMessageProc() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • GetInstance() : vtkOutputWindow
  • GetIntegrationDirection() : vtkStreamer, vtkHyperStreamline
  • GetIntegrationDirectionAsString() : vtkStreamer
  • GetIntegrationStepLength() : vtkStreamer, vtkHyperStreamline
  • GetIntegrator() : vtkStreamer
  • GetIntensity() : vtkLight
  • GetInteractive() : vtkRenderer
  • GetInteractor() : vtkRenderWindow, vtkInteractorStyle
  • GetInteractorStyle() : vtkRenderWindowInteractor
  • GetIntermixIntersectingGeometry() : vtkVolumeRayCastMapper, vtkVolumeProMapper
  • GetInternalFileName() : vtkImageReader2
  • GetInternalImage() : vtkTIFFReader
  • GetInternalSkipFactor() : vtkVolumeTextureMapper2D
  • GetInterpolate() : vtkTexture, vtkImageActor, vtkImageReslice, vtkImageResample, vtkImageMagnify
  • GetInterpolation() : vtkProperty
  • GetInterpolationAsString() : vtkProperty
  • GetInterpolationMode() : vtkImageReslice, vtkGridTransform
  • GetInterpolationModeAsString() : vtkImageReslice, vtkGridTransform
  • GetInterpolationType() : vtkVolumeProperty
  • GetInterpolationTypeAsString() : vtkVolumeProperty
  • GetInTextureCoord() : vtkThresholdTextureCoords
  • GetInValue() : vtkImageThreshold, vtkImageEllipsoidSource
  • GetInverse() : vtkTransform, vtkAbstractTransform
  • GetInverseFlag() : vtkWarpTransform, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenation
  • GetInverseIterations() : vtkWarpTransform
  • GetInverseTolerance() : vtkWarpTransform
  • GetInverseVideo() : vtkWindowLevelLookupTable
  • GetIsConnected() : vtkSocketCommunicator
  • GetIsIdentity() : vtkProp3D
  • GetIslandValue() : vtkImageIslandRemoval2D
  • GetIsOpaque() : vtkActor
  • GetIsoValue() : vtkVolumeRayCastIsosurfaceFunction
  • GetIsPicking() : vtkViewport
  • GetIStream() : vtkDataReader
  • GetItalic() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • GetItem() : vtkDataSetCollection, vtkDataObjectCollection, vtkAbstractList< DType >
  • GetItemAsObject() : vtkCollection
  • GetIteration() : vtkImageIterateFilter
  • GetIterationInput() : vtkImageIterateFilter
  • GetIterationOutput() : vtkImageIterateFilter
  • GetJustification() : vtkTextMapper, vtkCaptionActor2D
  • GetK1() : vtkWarpLens
  • GetK2() : vtkWarpLens
  • GetKappa() : vtkWarpLens
  • GetKernel() : vtkImageConvolve
  • GetKernel3x3() : vtkImageConvolve
  • GetKernel3x3x3() : vtkImageConvolve
  • GetKernel5x5() : vtkImageConvolve
  • GetKernel5x5x5() : vtkImageConvolve
  • GetKernel7x7() : vtkImageConvolve
  • GetKernel7x7x7() : vtkImageConvolve
  • GetKernelMiddle() : vtkImageSpatialFilter
  • GetKernelSize() : vtkImageSpatialFilter, vtkImageConvolve
  • GetKeyCode() : vtkRenderWindowInteractor
  • GetKeyLightAngle() : vtkLightKit
  • GetKeyLightAzimuth() : vtkLightKit
  • GetKeyLightColor() : vtkLightKit
  • GetKeyLightElevation() : vtkLightKit
  • GetKeyLightIntensity() : vtkLightKit
  • GetKeyLightWarmth() : vtkLightKit
  • GetKeySym() : vtkRenderWindowInteractor, vtkInteractorStyleUser
  • GetKeyToFillRatio() : vtkLightKit
  • GetKeyToHeadRatio() : vtkLightKit
  • GetKx() : vtkMassProperties
  • GetKy() : vtkMassProperties
  • GetKz() : vtkMassProperties
  • GetLabeledComponent() : vtkLabeledDataMapper
  • GetLabelFactor() : vtkAxisActor2D
  • GetLabelFormat() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkCubeAxesActor2D
  • GetLabelMode() : vtkLabeledDataMapper
  • GetLabelVisibility() : vtkAxisActor2D
  • GetLandmarkTransform() : vtkProcrustesAlignmentFilter, vtkIterativeClosestPointTransform
  • GetLastActor() : vtkActorCollection
  • GetLastActor2D() : vtkActor2DCollection
  • GetLastCellId() : vtkInterpolatedVelocityField
  • GetLastItem() : vtkMapperCollection, vtkImagerCollection, vtkCullerCollection, vtkActorCollection, vtkActor2DCollection
  • GetLastLocalCoordinates() : vtkInterpolatedVelocityField
  • GetLastNode() : vtkAssemblyPath
  • GetLastPos() : vtkInteractorStyleUser
  • GetLastProp() : vtkPropCollection
  • GetLastProp3D() : vtkProp3DCollection
  • GetLastRenderedLODID() : vtkLODProp3D
  • GetLastRenderTimeInSeconds() : vtkRenderer
  • GetLastUpdateTimeInCPUSeconds() : vtkEncodedGradientEstimator
  • GetLastUpdateTimeInSeconds() : vtkEncodedGradientEstimator
  • GetLastWeights() : vtkInterpolatedVelocityField
  • GetLatLongTessellation() : vtkSphereSource
  • GetLayer() : vtkRenderer
  • GetLayerNumber() : vtkActor2D
  • GetLeader() : vtkCaptionActor2D
  • GetLeaderGlyph() : vtkCaptionActor2D
  • GetLeaderGlyphSize() : vtkCaptionActor2D
  • GetLeftConstraint() : vtkSpline
  • GetLeftValue() : vtkSpline
  • GetLegend() : vtkXYPlotActor
  • GetLegendBoxActor() : vtkXYPlotActor
  • GetLegendPosition() : vtkXYPlotActor
  • GetLegendPosition2() : vtkXYPlotActor
  • GetLength() : vtkProp3D, vtkAbstractMapper3D, vtkLargeInteger, vtkDataSet
  • GetLength2() : vtkCell
  • GetLevel() : vtkImageMapToWindowLevelColors, vtkSpatialRepresentationFilter, vtkSimpleScalarTree, vtkWindowLevelLookupTable, vtkLocator
  • GetLibraryPath() : vtkObjectFactory
  • GetLightFollowCamera() : vtkRenderWindowInteractor, vtkRenderer
  • GetLights() : vtkRenderer
  • GetLightType() : vtkLight
  • GetLimitsFileName() : vtkSliceCubes, vtkMCubesWriter, vtkMCubesReader
  • GetLinearInverse() : vtkLinearTransform
  • GetLineOffset() : vtkTextMapper
  • GetLines() : vtkPolyData
  • GetLinesComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetLinesComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetLinesComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetLinesComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetLineSmoothing() : vtkRenderWindow
  • GetLineSpacing() : vtkTextMapper
  • GetLineStipplePattern() : vtkProperty, vtkProperty2D
  • GetLineStippleRepeatFactor() : vtkProperty, vtkProperty2D
  • GetLineValue() : vtkImageGridSource
  • GetLineWidth() : vtkProperty, vtkProperty2D
  • GetLink() : vtkCellLinks
  • GetLinkThreshold() : vtkLinkEdgels
  • GetListBaseForFont() : vtkXOpenGLTextMapper, vtkXMesaTextMapper, vtkWin32OpenGLTextMapper
  • GetListOfUniqueCellTypes() : vtkUnstructuredGrid
  • GetListSize() : vtkFieldData::BasicIterator
  • GetLmcolorMode() : vtkOpenGLPolyDataMapper, vtkMesaPolyDataMapper
  • GetLoadValue() : vtkPointLoad
  • GetLocalController() : vtkThreadedController, vtkMultiProcessController
  • GetLocality() : vtkDataObject
  • GetLocalProcessId() : vtkThreadedController, vtkMultiProcessController
  • GetLocalRotation() : vtkDEMReader
  • GetLocator() : vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkUGFacetReader, vtkSTLReader, vtkMCubesReader, vtkIterativeClosestPointTransform, vtkGeometryFilter, vtkFeatureEdges, vtkExtractUnstructuredGrid, vtkExtractEdges, vtkDelaunay3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData
  • GetLocatorMaxLevel() : vtkImplicitModeller
  • GetLocatorPoint() : vtkImageMarchingCubes
  • GetLocatorPointer() : vtkImageMarchingCubes
  • GetLockBorder() : vtkLegendBoxActor
  • GetLockSizesForBoardMemory() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkVolumeProMapper
  • GetLODBackfaceProperty() : vtkLODProp3D
  • GetLODEstimatedRenderTime() : vtkLODProp3D
  • GetLODIndexEstimatedRenderTime() : vtkLODProp3D
  • GetLODIndexLevel() : vtkLODProp3D
  • GetLODLevel() : vtkLODProp3D
  • GetLODMapper() : vtkLODProp3D
  • GetLODMappers() : vtkLODActor
  • GetLODProperty() : vtkLODProp3D
  • GetLODTexture() : vtkLODProp3D
  • GetLogScaling() : vtkHyperStreamline
  • GetLogx() : vtkXYPlotActor
  • GetLookupIndexExecuteTime() : vtkImageQuantizeRGBToIndex
  • GetLookupTable() : vtkWin32ImageMapper, vtkTexture, vtkScalarBarActor, vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkImageQuantizeRGBToIndex, vtkImageMapToColors, vtkImageToPolyDataFilter, vtkDataArray
  • GetLookupTableName() : vtkDataWriter, vtkDataReader
  • GetLoop() : vtkSelectPolyData, vtkImplicitSelectionLoop
  • GetLowerThreshold() : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • GetLowPoint() : vtkElevationFilter
  • GetLuminance() : vtkScalarsToColors
  • GetMagnification() : vtkWindowToImageFilter, vtkRenderLargeImage
  • GetMagnificationFactors() : vtkImageMagnify
  • GetMaintainLuminance() : vtkLightKit
  • GetMajorBoardVersion() : vtkVolumeProMapper
  • GetManifoldEdges() : vtkFeatureEdges
  • GetManual() : vtkCompositeManager
  • GetMapColorScalarsThroughLookupTable() : vtkTexture
  • GetMapLabel() : vtkDEMReader
  • GetMapped() : vtkWindow
  • GetMappedScalars() : vtkTexture
  • GetMapper() : vtkVolume, vtkScaledTextActor, vtkPicker, vtkActor, vtkActor2D
  • GetMapperPosition() : vtkPicker
  • GetMaskAlpha() : vtkImageMask
  • GetMaskedOutputValue() : vtkImageMask
  • GetMaskedOutputValueLength() : vtkImageMask
  • GetMasks() : vtkImageMaskBits
  • GetMatchFileName() : vtkEnSightReader, vtkEnSightGoldReader
  • GetMaterial() : vtkCutMaterial
  • GetMaterialArrayName() : vtkCutMaterial
  • GetMathFunctionNumber() : vtkFunctionParser
  • GetMathFunctionStringLength() : vtkFunctionParser
  • GetMatrix() : vtkProp3D, vtkFollower, vtkProp, vtkHomogeneousTransform, vtkAssemblyNode
  • GetMax() : vtkImageAccumulate
  • GetMaxBlankingValue() : vtkBlankStructuredGrid
  • GetMaxCellSize() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet, vtkCellArray
  • GetMaxEntries() : vtkTimerLog
  • GetMaxId() : vtkDataArray
  • GetMaximizeMethod() : vtkVolumeRayCastMIPFunction
  • GetMaximizeMethodAsString() : vtkVolumeRayCastMIPFunction
  • GetMaximum() : vtkRTAnalyticSource, vtkImageShrink3D, vtkImageRGBToHSV, vtkImageNoiseSource, vtkImageHSVToRGB, vtkImageGaussianSource
  • GetMaximumCollapsedEdges() : vtkQuadricDecimation
  • GetMaximumColor() : vtkWindowLevelLookupTable
  • GetMaximumCost() : vtkQuadricDecimation
  • GetMaximumCoverage() : vtkFrustumCoverageCuller
  • GetMaximumDistance() : vtkVoxelModeller, vtkShepardMethod, vtkImageEuclideanDistance, vtkImplicitModeller
  • GetMaximumError() : vtkDecimate, vtkDecimatePro
  • GetMaximumFeatureAngle() : vtkDecimate
  • GetMaximumImageSampleDistance() : vtkVolumeRayCastMapper
  • GetMaximumIterations() : vtkDecimate
  • GetMaximumLeaderGlyphSize() : vtkCaptionActor2D
  • GetMaximumLength() : vtkStripper
  • GetMaximumLineHeight() : vtkScaledTextActor
  • GetMaximumMeanDistance() : vtkIterativeClosestPointTransform
  • GetMaximumNumberOfColors() : vtkScalarBarActor
  • GetMaximumNumberOfInterpolationSteps() : vtkSweptSurface
  • GetMaximumNumberOfIterations() : vtkImageMandelbrotSource, vtkIterativeClosestPointTransform
  • GetMaximumNumberOfLandmarks() : vtkIterativeClosestPointTransform
  • GetMaximumNumberOfPieces() : vtkDataObject
  • GetMaximumNumberOfPlanes() : vtkVolumeTextureMapper2D
  • GetMaximumNumberOfPoints() : vtkMaskPoints
  • GetMaximumNumberOfSquawks() : vtkDecimate
  • GetMaximumPoint() : vtkCutMaterial
  • GetMaximumPropagationDistance() : vtkHyperStreamline
  • GetMaximumPropagationTime() : vtkStreamer
  • GetMaximumSpeed() : vtkBrownianPoints
  • GetMaximumStorageSize() : vtkVolumeTextureMapper2D
  • GetMaximumSubIterations() : vtkDecimate
  • GetMaximumTableValue() : vtkWindowLevelLookupTable
  • GetMaximumTimeValue() : vtkGenericEnSightReader, vtkEnSightReader
  • GetMaxLevel() : vtkSimpleScalarTree, vtkLocator
  • GetMaxMTime() : vtkTransformConcatenation
  • GetMaxNorm() : vtkDataArray
  • GetMaxNumberOfIterations() : vtkGraphLayoutFilter
  • GetMaxRecursionDepth() : vtkPolyDataNormals
  • GetMaxRenderTime() : vtkCompositeManager
  • GetMaxScaleFactor() : vtkTensorGlyph
  • GetMaxXBound() : vtkVolume
  • GetMaxYBound() : vtkVolume
  • GetMaxZBound() : vtkVolume
  • GetMean() : vtkImageShrink3D, vtkImageAccumulate
  • GetMeanDistance() : vtkIterativeClosestPointTransform
  • GetMeanDistanceMode() : vtkIterativeClosestPointTransform
  • GetMeanDistanceModeAsString() : vtkIterativeClosestPointTransform
  • GetMeasuredFileName() : vtkEnSightReader, vtkEnSightGoldReader
  • GetMedian() : vtkImageShrink3D
  • GetMemoryData() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • GetMemoryDC() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • GetMemoryLimit() : vtkPImageWriter, vtkMemoryLimitImageDataStreamer, vtkDicer
  • GetMemoryLimitInBytes() : vtkVoxelContoursToSurfaceFilter
  • GetMergeTolerance() : vtkClipVolume
  • GetMerging() : vtkUGFacetReader, vtkSTLReader, vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetMILAppID() : vtkMILVideoSource
  • GetMILBufID() : vtkMILVideoSource
  • GetMILDigID() : vtkMILVideoSource
  • GetMILDigitizerDCF() : vtkMILVideoSource
  • GetMILDigitizerNumber() : vtkMILVideoSource
  • GetMILErrorMessages() : vtkMILVideoSource
  • GetMILSysID() : vtkMILVideoSource
  • GetMILSystemNumber() : vtkMILVideoSource
  • GetMILSystemType() : vtkMILVideoSource
  • GetMin() : vtkImageAccumulate
  • GetMinBlankingValue() : vtkBlankStructuredGrid
  • GetMinimum() : vtkImageShrink3D, vtkImageNoiseSource
  • GetMinimumColor() : vtkWindowLevelLookupTable
  • GetMinimumCoverage() : vtkFrustumCoverageCuller
  • GetMinimumImageSampleDistance() : vtkVolumeRayCastMapper
  • GetMinimumSize() : vtkScaledTextActor
  • GetMinimumSpeed() : vtkBrownianPoints
  • GetMinimumTableValue() : vtkWindowLevelLookupTable
  • GetMinimumTimeValue() : vtkGenericEnSightReader, vtkEnSightReader
  • GetMinorBoardVersion() : vtkVolumeProMapper
  • GetMinXBound() : vtkVolume
  • GetMinYBound() : vtkVolume
  • GetMinZBound() : vtkVolume
  • GetMirror() : vtkImageReslice
  • GetMode() : vtkLandmarkTransform
  • GetModeAsString() : vtkLandmarkTransform
  • GetModelBounds() : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller, vtkCursor3D
  • GetModesRequiredFor() : vtkPCAAnalysisFilter
  • GetMotionAccelerationFactor() : vtkInteractorStyleFlight
  • GetMotionStepSize() : vtkInteractorStyleFlight
  • GetMousePosition() : vtkXRenderWindowInteractor, vtkRenderWindowInteractor
  • GetMTime() : vtkWin32ImageMapper, vtkVolumeProperty, vtkVolume, vtkSelectVisiblePoints, vtkRendererSource, vtkRenderer, vtkPolyDataMapper2D, vtkMapper, vtkImageMapper, vtkExporter, vtkDataSetMapper, vtkAssembly, vtkActor, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSweptSurface, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkUGFacetReader, vtkSTLReader, vtkMCubesReader, vtkSampleFunction, vtkImageSeparableConvolution, vtkImageReslice, vtkImageOpenClose3D, vtkImageMapToColors, vtkXYPlotActor, vtkWeightedTransformFilter, vtkTransformToGrid, vtkThinPlateSplineTransform, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkGridTransform, vtkDepthSortPolyData, vtkArcPlotter, vtkTransformPolyDataFilter, vtkTransformFilter, vtkSelectPolyData, vtkGeometryFilter, vtkFeatureEdges, vtkExtractUnstructuredGrid, vtkExtractPolyDataGeometry, vtkExtractGeometry, vtkExtractEdges, vtkDelaunay3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkBandedPolyDataContourFilter, vtkSpline, vtkPiecewiseFunction, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkTransform, vtkTimeStamp, vtkPropAssembly, vtkPointSet, vtkPerspectiveTransform, vtkObject, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkImplicitFunction, vtkGeneralTransform, vtkFieldData, vtkDataSet, vtkDataObject, vtkAssemblyPaths, vtkAssemblyPath, vtkAssemblyNode, vtkActor2D, vtkAbstractTransform, vtkAbstractMapper
  • GetMultiLineSize() : vtkTextMapper
  • GetMultiSamples() : vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • GetName() : vtkDataArray
  • GetNcells() : vtkCellLinks
  • GetNeighborhoodSize() : vtkSurfaceReconstructionFilter
  • GetNetReferenceCount() : vtkPointSet, vtkDataObject
  • GetNeverRendered() : vtkRenderWindow
  • GetNextActor() : vtkActorCollection
  • GetNextActor2D() : vtkActor2DCollection
  • GetNextCell() : vtkSimpleScalarTree, vtkScalarTree, vtkCellArray
  • GetNextComponent() : vtkSplitField, vtkMergeFields
  • GetNextEdge() : vtkEdgeTable
  • GetNextEntryIndex() : vtkLODProp3D
  • GetNextExtent() : vtkImageStencilData
  • GetNextIndent() : vtkIndent
  • GetNextItem() : vtkVolumeCollection, vtkRenderWindowCollection, vtkRendererCollection, vtkMapperCollection, vtkLightCollection, vtkImagerCollection, vtkCullerCollection, vtkActorCollection, vtkImageReader2Collection, vtkStructuredPointsCollection, vtkPolyDataCollection, vtkTransformCollection, vtkPlaneCollection, vtkOverrideInformationCollection, vtkObjectFactoryCollection, vtkImplicitFunctionCollection, vtkDataSetCollection, vtkDataObjectCollection, vtkAssemblyPaths, vtkActor2DCollection
  • GetNextItemAsObject() : vtkCollection
  • GetNextNode() : vtkAssemblyPath
  • GetNextOperation() : vtkRearrangeFields
  • GetNextPart() : vtkActor
  • GetNextPath() : vtkAssembly, vtkPropAssembly, vtkProp
  • GetNextProp() : vtkPropCollection
  • GetNextProp3D() : vtkProp3DCollection
  • GetNextVisibleQuadFromHash() : vtkDataSetSurfaceFilter
  • GetNextVolume() : vtkVolumeCollection
  • GetNoHardware() : vtkVolumeProMapper
  • GetNonManifoldEdges() : vtkFeatureEdges
  • GetNonManifoldTraversal() : vtkPolyDataNormals
  • GetNormal() : vtkCutMaterial, vtkWarpScalar, vtkTextureMapToPlane, vtkPlaneSource, vtkImplicitSelectionLoop, vtkPlane
  • GetNormalComponentArrayComponent() : vtkFieldDataToAttributeDataFilter
  • GetNormalComponentArrayName() : vtkFieldDataToAttributeDataFilter
  • GetNormalComponentMaxRange() : vtkFieldDataToAttributeDataFilter
  • GetNormalComponentMinRange() : vtkFieldDataToAttributeDataFilter
  • GetNormalComponentNormalizeFlag() : vtkFieldDataToAttributeDataFilter
  • GetNormalComponents() : vtkExtractTensorComponents
  • GetNormalize() : vtkVectorNorm
  • GetNormalizeByWeight() : vtkImplicitSum
  • GetNormalizedShapeIndex() : vtkMassProperties
  • GetNormalizeNormals() : vtkExtractTensorComponents
  • GetNormals() : vtkMCubesReader, vtkMergeFilter, vtkPlanes, vtkDataSetAttributes
  • GetNormalsName() : vtkDataWriter, vtkDataReader
  • GetNormalsNameInFile() : vtkDataReader
  • GetNormalWarping() : vtkGaussianSplatter
  • GetNotMask() : vtkImageMask
  • GetNullValue() : vtkShepardMethod, vtkGaussianSplatter
  • GetNumberOfActualPieces() : vtkDicer
  • GetNumberOfAllocations() : vtkHeap
  • GetNumberOfArrays() : vtkFieldData
  • GetNumberOfBoards() : vtkVolumeProMapper
  • GetNumberOfBuckets() : vtkCellLocator
  • GetNumberOfCells() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet, vtkCellArray
  • GetNumberOfCellsPerBucket() : vtkCellLocator
  • GetNumberOfCloudPoints() : vtkLODActor
  • GetNumberOfColors() : vtkXImageWindow, vtkXImageMapper, vtkImageQuantizeRGBToIndex, vtkLookupTable
  • GetNumberOfComplexScalarsPerElement() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfComplexScalarsPerNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfComplexVariables() : vtkEnSightReader
  • GetNumberOfComplexVectorsPerElement() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfComplexVectorsPerNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfComponents() : vtkImageExtractComponents, vtkFieldData, vtkDataArray
  • GetNumberOfComponentsCallback() : vtkImageImport, vtkImageExport
  • GetNumberOfConcatenatedTransforms() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • GetNumberOfConnectivityEntries() : vtkCellArray
  • GetNumberOfConsumers() : vtkProp, vtkDataObject, vtkAbstractMapper
  • GetNumberOfContours() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkBandedPolyDataContourFilter, vtkContourValues
  • GetNumberOfDivisions() : vtkImageCheckerboard, vtkQuadricClustering
  • GetNumberOfEdges() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkEdgeTable, vtkCell
  • GetNumberOfElements() : vtkImageMedian3D
  • GetNumberOfEncodedDirections() : vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder
  • GetNumberOfEntries() : vtkLegendBoxActor
  • GetNumberOfExtractedRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetNumberOfFaces() : vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • GetNumberOfFieldDataInFile() : vtkDataReader
  • GetNumberOfFiles() : vtkDirectory
  • GetNumberOfFlyFrames() : vtkRenderWindowInteractor
  • GetNumberOfFunctions() : vtkFunctionSet
  • GetNumberOfGhostLevels() : vtkPOPReader
  • GetNumberOfGrids() : vtkPLOT3DReader
  • GetNumberOfIds() : vtkIdList
  • GetNumberOfIndependentVariables() : vtkFunctionSet
  • GetNumberOfInflectionPoints() : vtkDecimatePro
  • GetNumberOfInputs() : vtkProcessObject
  • GetNumberOfInterpolationSteps() : vtkSweptSurface
  • GetNumberOfItems() : vtkPriorityQueue, vtkContainer, vtkCollection
  • GetNumberOfIterations() : vtkImageIterateFilter, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkIterativeClosestPointTransform, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • GetNumberOfLabels() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkAxisActor2D, vtkCubeAxesActor2D
  • GetNumberOfLayers() : vtkRenderWindow
  • GetNumberOfLines() : vtkTextMapper, vtkPolyData
  • GetNumberOfNormalsInFile() : vtkDataReader
  • GetNumberOfOutputFrames() : vtkVideoSource
  • GetNumberOfOutputs() : vtkSource
  • GetNumberOfOverrides() : vtkObjectFactory
  • GetNumberOfParts() : vtkActor, vtkUGFacetReader
  • GetNumberOfPaths() : vtkAssembly, vtkPropCollection, vtkPropAssembly, vtkProp
  • GetNumberOfPieces() : vtkPolyDataMapper, vtkPDataSetWriter, vtkDicer, vtkUnstructuredGrid, vtkPolyData, vtkExtentTranslator
  • GetNumberOfPlanes() : vtkHull, vtkPlanes
  • GetNumberOfPoints() : vtkStreamArray, vtkPointSource, vtkStructuredGrid, vtkRectilinearGrid, vtkPointSet, vtkPoints, vtkImageData, vtkDataSet, vtkCell
  • GetNumberOfPointsPerBucket() : vtkPointLocator2D, vtkPointLocator
  • GetNumberOfPointsPerPiece() : vtkDicer
  • GetNumberOfPolys() : vtkPolyData
  • GetNumberOfPostTransforms() : vtkTransformConcatenation
  • GetNumberOfPreTransforms() : vtkTransformConcatenation
  • GetNumberOfProcesses() : vtkMultiProcessController
  • GetNumberOfProcessIds() : vtkMPIGroup
  • GetNumberOfPropsRenderedAsGeometry() : vtkRenderer
  • GetNumberOfSamplesTaken() : vtkRayCaster
  • GetNumberOfScalarArrays() : vtkArrayCalculator
  • GetNumberOfScalarComponents() : vtkImageBlockReader, vtkImageReader2, vtkImageImport, vtkImageData
  • GetNumberOfScalarsInFile() : vtkDataReader
  • GetNumberOfScalarsPerElement() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfScalarsPerMeasuredNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfScalarsPerNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfScalarVariables() : vtkFunctionParser
  • GetNumberOfSides() : vtkTubeFilter, vtkHyperStreamline
  • GetNumberOfSmoothingIterations() : vtkImageToPolyDataFilter
  • GetNumberOfSources() : vtkGlyph3D
  • GetNumberOfStreamDivisions() : vtkImageDataStreamer, vtkPolyDataStreamer
  • GetNumberOfStreamers() : vtkStreamer
  • GetNumberOfStrips() : vtkPolyData
  • GetNumberOfSubdivisions() : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • GetNumberOfSubPieces() : vtkPolyDataMapper, vtkPipelineSize
  • GetNumberOfTableValues() : vtkLookupTable
  • GetNumberOfTCoords() : vtkExtractTensorComponents
  • GetNumberOfTCoordsInFile() : vtkDataReader
  • GetNumberOfTensorsInFile() : vtkDataReader
  • GetNumberOfTensorsSymmPerElement() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfTensorsSymmPerNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfThreads() : vtkVolumeRayCastMapper, vtkRayCaster, vtkEncodedGradientEstimator, vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D, vtkImplicitModeller, vtkStreamer, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkMultiThreader
  • GetNumberOfTransforms() : vtkWeightedTransformFilter, vtkTransformConcatenation
  • GetNumberOfTriangles() : vtkTriArray, vtkProTriArray
  • GetNumberOfTuples() : vtkFieldData, vtkDataArray
  • GetNumberOfTypes() : vtkCellTypes
  • GetNumberOfVariables() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfVectorArrays() : vtkArrayCalculator
  • GetNumberOfVectorsInFile() : vtkDataReader
  • GetNumberOfVectorsPerElement() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfVectorsPerMeasuredNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfVectorsPerNode() : vtkGenericEnSightReader, vtkEnSightReader
  • GetNumberOfVectorVariables() : vtkFunctionParser
  • GetNumberOfVertices() : vtkVertexArray, vtkProVertexArray
  • GetNumberOfVerts() : vtkPolyData
  • GetNumberOfXDivisions() : vtkQuadricClustering
  • GetNumberOfXLabels() : vtkXYPlotActor
  • GetNumberOfYDivisions() : vtkQuadricClustering
  • GetNumberOfYLabels() : vtkXYPlotActor
  • GetNumberOfZDivisions() : vtkQuadricClustering
  • GetObjectFactory() : vtkOverrideInformation
  • GetOffScreenRendering() : vtkWindow
  • GetOffset() : vtkArcPlotter, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints, vtkDelaunay3D, vtkDelaunay2D
  • GetOldOrigin() : vtkImageStencilData
  • GetOldPos() : vtkInteractorStyleUser
  • GetOldSpacing() : vtkImageStencilData
  • GetOnIn() : vtkBooleanTexture
  • GetOnOn() : vtkBooleanTexture
  • GetOnOut() : vtkBooleanTexture
  • GetOnRatio() : vtkEarthSource, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints
  • GetOpacity() : vtkProperty, vtkImageBlend, vtkVideoSource, vtkScalarsToColors, vtkProperty2D, vtkLookupTable
  • GetOpenValue() : vtkImageOpenClose3D
  • GetOperandNumber() : vtkFunctionParser
  • GetOperation() : vtkImageMathematics, vtkImageMaskBits, vtkImageLogic
  • GetOperationType() : vtkImplicitBoolean
  • GetOperationTypeAsString() : vtkImplicitBoolean
  • GetOptimization() : vtkImageReslice
  • GetOptimizedTransform() : vtkImageReslice
  • GetOrder() : vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • GetOrient() : vtkGlyph3D
  • GetOrientation() : vtkScalarBarActor, vtkProp3D, vtkCamera, vtkProjectedTexture, vtkTransform
  • GetOrientationScalars() : vtkStreamer
  • GetOrientationWXYZ() : vtkProp3D, vtkCamera, vtkTransform
  • GetOrigin() : vtkProp3D, vtkImageStencilData, vtkDepthSortPolyData, vtkTransformTextureCoords, vtkTextureMapToPlane, vtkPlaneSource, vtkDataObjectToDataSetFilter, vtkButtonSource, vtkAxes, vtkViewport, vtkPlane, vtkImageData
  • GetOriginalSource() : vtkBranchExtentTranslator
  • GetOriginCallback() : vtkImageImport, vtkImageExport
  • GetOriginCX() : vtkImageMandelbrotSource
  • GetOriginScale() : vtkImageChangeInformation
  • GetOriginTranslation() : vtkImageChangeInformation
  • GetOuterRadius() : vtkDiskSource
  • GetOutGradient() : vtkImplicitVolume, vtkImplicitDataSet
  • GetOutIn() : vtkBooleanTexture
  • GetOutline() : vtkEarthSource, vtkCursor3D
  • GetOutlineFlag() : vtkPVGeometryFilter
  • GetOutOn() : vtkBooleanTexture
  • GetOutOut() : vtkBooleanTexture
  • GetOutput() : vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow, vtkPDataSetReader, vtkUnstructuredGridReader, vtkStructuredPointsReader, vtkStructuredGridReader, vtkRectilinearGridReader, vtkPolyDataReader, vtkDataSetReader, vtkDataObjectReader, vtkImageStencilSource, vtkImageOpenClose3D, vtkImageCanvasSource2D, vtkProcrustesAlignmentFilter, vtkPCAAnalysisFilter, vtkSpatialRepresentationFilter, vtkProgrammableDataObjectSource, vtkExtractVectorComponents, vtkDataObjectToDataSetFilter, vtkUnstructuredGridSource, vtkStructuredPointsSource, vtkStructuredGridSource, vtkRectilinearGridSource, vtkPolyDataSource, vtkPointSetToPointSetFilter, vtkPointSetSource, vtkPiecewiseFunctionSource, vtkImageToStructuredPoints, vtkImageSource, vtkImageMultipleInputOutputFilter, vtkDataSetToDataSetFilter, vtkDataSetSource, vtkDataObjectSource, vtkSource
  • GetOutputAttributeData() : vtkFieldDataToAttributeDataFilter
  • GetOutputConnectedValue() : vtkImageSeedConnectivity
  • GetOutputDimensionality() : vtkImageReslice
  • GetOutputExtent() : vtkImageReslice
  • GetOutputExtentStart() : vtkImageChangeInformation
  • GetOutputField() : vtkMergeDataObjectFilter
  • GetOutputFormat() : vtkImageMapToColors, vtkVideoSource
  • GetOutputIndex() : vtkSource
  • GetOutputNumberOfScalarComponents() : vtkImagePadFilter
  • GetOutputOrigin() : vtkImageReslice, vtkImageChangeInformation
  • GetOutputPointId() : vtkDataSetSurfaceFilter
  • GetOutputs() : vtkSource
  • GetOutputScalarType() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • GetOutputSpacing() : vtkImageReslice, vtkImageChangeInformation
  • GetOutputString() : vtkDataWriter
  • GetOutputStringLength() : vtkDataWriter
  • GetOutputStyle() : vtkImageToPolyDataFilter
  • GetOutputTrueValue() : vtkImageLogic
  • GetOutputUnconnectedValue() : vtkImageSeedConnectivity
  • GetOutputWholeExtent() : vtkImagePadFilter, vtkImageClip, vtkVideoSource
  • GetOutTextureCoord() : vtkThresholdTextureCoords
  • GetOutValue() : vtkImageThreshold, vtkImageEllipsoidSource, vtkImplicitVolume, vtkImplicitDataSet
  • GetOverlap() : vtkImageBlockWriter, vtkImageBlockReader
  • GetOverlappingBuckets() : vtkCellLocator, vtkPointLocator2D, vtkPointLocator
  • GetOverrideDescription() : vtkObjectFactory
  • GetOverrideInformation() : vtkObjectFactory
  • GetP1() : vtkWarpLens
  • GetP2() : vtkWarpLens
  • GetPadding() : vtkLegendBoxActor, vtkCaptionActor2D
  • GetParallelIncrements() : vtkRayCaster
  • GetParallelProjection() : vtkCamera
  • GetParallelScale() : vtkCamera
  • GetParallelStartPosition() : vtkRayCaster
  • GetParallelStreaming() : vtkAppendPolyData
  • GetParameterisedShape() : vtkPCAAnalysisFilter
  • GetParameters() : vtkRIBProperty
  • GetParametricCenter() : vtkWedge, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkGenericCell, vtkCell
  • GetParentId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow
  • GetPartColorIndex() : vtkUGFacetReader
  • GetPartNumber() : vtkUGFacetReader, vtkBYUReader
  • GetParts() : vtkAssembly, vtkPropAssembly
  • GetPassAlphaToOutput() : vtkImageMapToColors
  • GetPassAttributeData() : vtkAttributeDataToFieldDataFilter
  • GetPassBand() : vtkWindowedSincPolyDataFilter
  • GetPassCellData() : vtkCellDataToPointData
  • GetPassLines() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter, vtkRuledSurfaceFilter
  • GetPassPointData() : vtkPointDataToCellData
  • GetPassTensorsToOutput() : vtkExtractTensorComponents
  • GetPassVerts() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter
  • GetPath() : vtkAbstractPropPicker
  • GetPatientID() : vtkMedicalImageReader2
  • GetPatientName() : vtkMedicalImageReader2
  • GetPCoords() : vtkCellPicker
  • GetPeriod() : vtkImageSinusoidSource
  • GetPermutation() : vtkSpherePuzzleArrows
  • GetPerspectiveTransform() : vtkCamera
  • GetPerspectiveTransformMatrix() : vtkCamera
  • GetPerspectiveViewRays() : vtkRayCaster
  • GetPhase() : vtkImageSinusoidSource, vtkPerlinNoise
  • GetPhi() : vtkTexturedSphereSource
  • GetPhiResolution() : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • GetPhiRoundness() : vtkSuperquadricSource, vtkSuperquadric
  • GetPhiThreshold() : vtkLinkEdgels
  • GetPickable() : vtkProp
  • GetPickColor() : vtkInteractorStyle
  • GetPickedId() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • GetPickedPositions() : vtkPicker
  • GetPickedZ() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • GetPicker() : vtkRenderWindowInteractor
  • GetPickFromList() : vtkAbstractPicker
  • GetPickList() : vtkAbstractPicker
  • GetPickLODID() : vtkLODProp3D
  • GetPickPosition() : vtkAbstractPicker
  • GetPickX() : vtkViewport
  • GetPickY() : vtkViewport
  • GetPiece() : vtkPolyDataMapper, vtkUnstructuredGrid, vtkPolyData, vtkExtentTranslator
  • GetPieceInvariant() : vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkCleanPolyData
  • GetPipelineFlag() : vtkOutputPort
  • GetPipelineModifiedCallback() : vtkImageImport, vtkImageExport
  • GetPipelineMTime() : vtkDataObject
  • GetPixelAspect() : vtkViewport
  • GetPixelData() : vtkXImageWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkOpenGLImageWindow, vtkMesaRenderWindow, vtkMesaImageWindow, vtkWindow
  • GetPixelSamples() : vtkRIBExporter
  • GetPlane() : vtkReflectionFilter, vtkPlanes
  • GetPlaneUnitOfMeasure() : vtkDEMReader
  • GetPlaying() : vtkVideoSource
  • GetPlotColor() : vtkXYPlotActor
  • GetPlotComponent() : vtkArcPlotter
  • GetPlotCoordinate() : vtkXYPlotActor
  • GetPlotCurveLines() : vtkXYPlotActor
  • GetPlotCurvePoints() : vtkXYPlotActor
  • GetPlotLabel() : vtkXYPlotActor
  • GetPlotLines() : vtkXYPlotActor
  • GetPlotMode() : vtkArcPlotter
  • GetPlotPoints() : vtkXYPlotActor
  • GetPlotSymbol() : vtkXYPlotActor
  • GetPoint() : vtkProgrammableGlyphFilter, vtkStructuredGrid, vtkRectilinearGrid, vtkPointSet, vtkPoints, vtkImageData, vtkDataSet
  • GetPoint1() : vtkAxisActor2D, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • GetPoint1Coordinate() : vtkAxisActor2D
  • GetPoint2() : vtkAxisActor2D, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • GetPoint2Coordinate() : vtkAxisActor2D
  • GetPointCells() : vtkUnstructuredGrid, vtkStructuredGrid, vtkStructuredData, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataSet
  • GetPointClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetPointComponent() : vtkXYPlotActor
  • GetPointComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetPointComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetPointComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetPointComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetPointComponentNormailzeFlag() : vtkDataObjectToDataSetFilter
  • GetPointData() : vtkProgrammableGlyphFilter, vtkDataSetToDataObjectFilter, vtkDataSet
  • GetPointer() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLookupTable, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkCellArray, vtkBitArray
  • GetPointerToData() : vtkImageExport
  • GetPointGradient() : vtkImageData
  • GetPointId() : vtkPointPicker, vtkProgrammableGlyphFilter, vtkCell
  • GetPointIds() : vtkIdFilter, vtkCell
  • GetPointIdsName() : vtkGlyph3D
  • GetPointMaximum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetPointMerging() : vtkCleanPolyData
  • GetPointMinimum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • GetPoints() : vtkPointSet, vtkPoints, vtkPointLocator2D, vtkPlanes, vtkCell
  • GetPointsInBucket() : vtkPointLocator
  • GetPointSize() : vtkProperty, vtkProperty2D
  • GetPointSmoothing() : vtkRenderWindow
  • GetPointVisibility() : vtkStructuredGrid
  • GetPoissonsRatio() : vtkPointLoad
  • GetPolyDataInput() : vtkProgrammableFilter
  • GetPolyDataMapper() : vtkDataSetMapper
  • GetPolyDataOutput() : vtkInputPort, vtkDataSetReader, vtkProgrammableSource, vtkDataObjectToDataSetFilter, vtkPointSetToPointSetFilter, vtkDataSetToDataSetFilter
  • GetPolygonSize() : vtkDEMReader
  • GetPolygonSmoothing() : vtkRenderWindow
  • GetPolys() : vtkPolyData
  • GetPolysComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetPolysComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetPolysComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetPolysComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetPosition() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkProp3D, vtkLight, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkCamera, vtkWarpTo, vtkTransformTextureCoords, vtkProjectedTexture, vtkWindow, vtkTransform, vtkActor2D
  • GetPosition2() : vtkActor2D
  • GetPosition2Coordinate() : vtkActor2D
  • GetPositional() : vtkLight
  • GetPositionCoordinate() : vtkActor2D
  • GetPositionScale() : vtkPiecewiseFunctionShiftScale
  • GetPositionShift() : vtkPiecewiseFunctionShiftScale
  • GetPreMultiplyFlag() : vtkTransformConcatenation
  • GetPreserveEdges() : vtkDecimate
  • GetPreserveExtents() : vtkImageAppend
  • GetPreserveImageExtent() : vtkImageFlip
  • GetPreserveTopology() : vtkDecimate, vtkDecimatePro
  • GetPreSorted() : vtkOrderedTriangulator
  • GetPreSplitMesh() : vtkDecimatePro
  • GetPreventSeam() : vtkTextureMapToSphere, vtkTextureMapToCylinder
  • GetPreview() : vtkWin32VideoSource
  • GetPrincipalPoint() : vtkWarpLens
  • GetPriority() : vtkPriorityQueue
  • GetProcessCPUTimeInMilliseconds() : vtkProcessStatistics
  • GetProcessId() : vtkMPIGroup
  • GetProcessMode() : vtkImplicitModeller
  • GetProcessModeAsString() : vtkImplicitModeller
  • GetProcessorName() : vtkMPIController
  • GetProcessSizeInBytes() : vtkProcessStatistics
  • GetProfileDimension() : vtkDEMReader
  • GetProgress() : vtkProcessObject
  • GetProgressive() : vtkJPEGWriter
  • GetProgressText() : vtkProcessObject
  • GetProjectionAxes() : vtkImageMandelbrotSource
  • GetProjectionParameters() : vtkDEMReader
  • GetProp() : vtkAbstractPropPicker, vtkCubeAxesActor2D, vtkAssemblyNode
  • GetProp3D() : vtkAbstractPropPicker, vtkDepthSortPolyData
  • GetProp3Ds() : vtkPicker
  • GetPropagateUpdateExtentCallback() : vtkImageImport, vtkImageExport
  • GetPropAssembly() : vtkAbstractPropPicker
  • GetProperty() : vtkVolume, vtkActor, vtkActor2D
  • GetProps() : vtkViewport
  • GetPrune() : vtkImageSkeleton2D
  • GetQFactor() : vtkQuantizePolyDataPoints
  • GetQFileName() : vtkPLOT3DReader
  • GetQuality() : vtkTexture, vtkJPEGWriter
  • GetR() : vtkPLOT3DReader
  • GetRadialRatio() : vtkButtonSource
  • GetRadialResolution() : vtkDiskSource
  • GetRadius() : vtkPOPReader, vtkImageEllipsoidSource, vtkGaussianSplatter, vtkEarthSource, vtkArcPlotter, vtkTubeFilter, vtkTexturedSphereSource, vtkSphereSource, vtkPointSource, vtkHyperStreamline, vtkCylinderSource, vtkConeSource, vtkSphere, vtkCylinder
  • GetRadiusFactor() : vtkTubeFilter
  • GetRadiusFactors() : vtkImageGaussianSmooth
  • GetRamp() : vtkLookupTable
  • GetRandomMode() : vtkPieceScalars, vtkMaskPoints
  • GetRange() : vtkAxisActor2D, vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction, vtkScalarsToColors, vtkLookupTable, vtkDataArray
  • GetRanges() : vtkCubeAxesActor2D
  • GetRatio() : vtkImageCanvasSource2D
  • GetRayCaster() : vtkRenderer
  • GetRe() : vtkPLOT3DReader
  • GetReadDisplacement() : vtkBYUReader
  • GetReader() : vtkSliceCubes
  • GetReadFromInputString() : vtkDataReader
  • GetReadFrontBuffer() : vtkWindowToImageFilter
  • GetReadScalar() : vtkBYUReader
  • GetReadTexture() : vtkBYUReader
  • GetRecording() : vtkVideoSource
  • GetRectilinearGridInput() : vtkProgrammableFilter
  • GetRectilinearGridOutput() : vtkInputPort, vtkDataSetReader, vtkProgrammableSource, vtkDataObjectToDataSetFilter, vtkDataSetToDataSetFilter
  • GetRecursionDepth() : vtkRecursiveSphereDirectionEncoder
  • GetRedDiffuseShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetRedrawMTime() : vtkVolume, vtkActor, vtkProp
  • GetRedSpecularShadingTable() : vtkVolumeTextureMapper, vtkEncodedGradientShader
  • GetReductionFactor() : vtkCompositeManager
  • GetRedValue() : vtkColorTransferFunction
  • GetReferenceCoordinate() : vtkCoordinate
  • GetReferenceCount() : vtkObject
  • GetRegisteredFactories() : vtkObjectFactory
  • GetRegisteredReaders() : vtkImageReader2Factory
  • GetRelativePosition() : vtkSweptSurface
  • GetRelaxationFactor() : vtkSmoothPolyDataFilter
  • GetReleaseDataFlag() : vtkSource, vtkDataObject
  • GetRemoteProcessId() : vtkInputPort
  • GetRenderer() : vtkSelectVisiblePoints, vtkImporter, vtkImageViewer2, vtkImageViewer, vtkAbstractPicker
  • GetRenderers() : vtkRenderWindow
  • GetRenderFlag() : vtkRendererSource
  • GetRenderLibrary() : vtkRenderWindow, vtkGraphicsFactory
  • GetRenderTime() : vtkMapper
  • GetRenderTimeMultiplier() : vtkProp
  • GetRenderToRectangle() : vtkImageMapper
  • GetRenderWindow() : vtkVolumeTextureMapper, vtkRenderWindowInteractor, vtkRenderer, vtkImporter, vtkImageViewer2, vtkImageViewer, vtkExporter, vtkCompositeManager
  • GetRepeat() : vtkTexture
  • GetRepeatCount() : vtkRenderWindowInteractor
  • GetReplaceIn() : vtkImageThreshold
  • GetReplaceOut() : vtkImageThreshold
  • GetReplaceValue() : vtkImageIslandRemoval2D
  • GetRepresentation() : vtkProperty
  • GetRepresentationAsString() : vtkProperty
  • GetRequestExactExtent() : vtkDataObject
  • GetResliceAxes() : vtkImageReslice
  • GetResliceAxesDirectionCosines() : vtkImageReslice
  • GetResliceAxesOrigin() : vtkImageReslice
  • GetResliceTransform() : vtkImageReslice
  • GetResolution() : vtkCGMWriter, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkPlaneSource, vtkLineSource, vtkCylinderSource, vtkConeSource
  • GetResolveCoincidentTopology() : vtkMapper
  • GetResolveCoincidentTopologyPolygonOffsetParameters() : vtkMapper
  • GetResolveCoincidentTopologyZShift() : vtkMapper
  • GetResultArrayName() : vtkArrayCalculator
  • GetRetainCellLists() : vtkLocator
  • GetReverseCells() : vtkReverseSense
  • GetReverseNormals() : vtkReverseSense
  • GetReverseStencil() : vtkImageStencil, vtkImageAccumulate
  • GetReverseXAxis() : vtkXYPlotActor
  • GetReverseYAxis() : vtkXYPlotActor
  • GetRFunction() : vtkImplicitTextureCoords
  • GetRGBAArray() : vtkVolumeTextureMapper
  • GetRGBACharPixelData() : vtkRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • GetRGBAPixelData() : vtkWin32OpenGLImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkOpenGLImageWindow, vtkMesaRenderWindow, vtkMesaImageWindow
  • GetRGBArray() : vtkVolume
  • GetRGBTransferFunction() : vtkVolumeProperty
  • GetRGBTransferFunctionMTime() : vtkVolumeProperty
  • GetRightConstraint() : vtkSpline
  • GetRightValue() : vtkSpline
  • GetRightVandUpV() : vtkInteractorStyleUnicam
  • GetRoll() : vtkCamera
  • GetRotationAngle() : vtkGlyphSource2D
  • GetRuledMode() : vtkRuledSurfaceFilter
  • GetRuledModeAsString() : vtkRuledSurfaceFilter
  • GetSampleCX() : vtkImageMandelbrotSource
  • GetSampleDimensions() : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller
  • GetSampleDistance() : vtkVolumeRayCastMapper
  • GetSampleRate() : vtkExtractVOI, vtkExtractGrid
  • GetSampleSpacing() : vtkSurfaceReconstructionFilter
  • GetSampleSpacingInVoxels() : vtkFiniteDifferenceGradientEstimator
  • GetSaturationLevel() : vtkMILVideoSource
  • GetSaturationRange() : vtkLookupTable
  • GetSavePointInterval() : vtkStreamer
  • GetSaveTextures() : vtkVolumeTextureMapper2D
  • GetScalarArrayName() : vtkArrayCalculator
  • GetScalarArrayNames() : vtkArrayCalculator
  • GetScalarComponentArrayComponent() : vtkFieldDataToAttributeDataFilter
  • GetScalarComponentArrayName() : vtkFieldDataToAttributeDataFilter
  • GetScalarComponentAsFloat() : vtkImageData
  • GetScalarComponentMaxRange() : vtkFieldDataToAttributeDataFilter
  • GetScalarComponentMinRange() : vtkFieldDataToAttributeDataFilter
  • GetScalarComponentNormalizeFlag() : vtkFieldDataToAttributeDataFilter
  • GetScalarComponents() : vtkExtractTensorComponents
  • GetScalarConnectivity() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • GetScalarFileName() : vtkBYUWriter, vtkBYUReader
  • GetScalarFunctionNumber() : vtkPLOT3DReader
  • GetScalarLut() : vtkDataReader
  • GetScalarMode() : vtkPolyDataMapper2D, vtkMapper, vtkPieceScalars, vtkExtractTensorComponents, vtkBandedPolyDataContourFilter
  • GetScalarModeAsString() : vtkMapper
  • GetScalarOpacity() : vtkVolumeProperty
  • GetScalarOpacityArray() : vtkVolume
  • GetScalarOpacityMTime() : vtkVolumeProperty
  • GetScalarPointer() : vtkImageData
  • GetScalarPointerForExtent() : vtkImageData
  • GetScalarRange() : vtkPolyDataMapper2D, vtkMapper, vtkVectorDot, vtkPolyDataConnectivityFilter, vtkElevationFilter, vtkConnectivityFilter, vtkStructuredGrid, vtkDataSet
  • GetScalarResult() : vtkFunctionParser
  • GetScalars() : vtkMergeFilter, vtkDataSetAttributes, vtkAbstractMapper
  • GetScalarSize() : vtkImageData
  • GetScalarsName() : vtkDataWriter, vtkDataReader
  • GetScalarsNameInFile() : vtkDataReader
  • GetScalarTags() : vtkSTLReader
  • GetScalarTree() : vtkContourFilter
  • GetScalarType() : vtkImageBlockReader, vtkImageData
  • GetScalarTypeAsString() : vtkImageData
  • GetScalarTypeCallback() : vtkImageImport, vtkImageExport
  • GetScalarTypeMax() : vtkImageData
  • GetScalarTypeMin() : vtkImageData
  • GetScalarVariableName() : vtkArrayCalculator, vtkFunctionParser
  • GetScalarVariableNames() : vtkArrayCalculator
  • GetScalarVariableValue() : vtkFunctionParser
  • GetScalarVisibility() : vtkPolyDataMapper2D, vtkMapper, vtkLegendBoxActor
  • GetScalarWarping() : vtkGaussianSplatter
  • GetScale() : vtkProp3D, vtkImageShiftScale, vtkTransformTextureCoords, vtkSuperquadricSource, vtkGlyphSource2D, vtkSuperquadric, vtkTransform, vtkLookupTable
  • GetScale2() : vtkGlyphSource2D
  • GetScaleFactor() : vtkTriangularTexture, vtkGaussianSplatter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkTensorGlyph, vtkLinearExtrusionFilter, vtkHedgeHog, vtkGlyph3D, vtkAxes
  • GetScaleMode() : vtkGlyph3D
  • GetScaleModeAsString() : vtkGlyph3D
  • GetScaling() : vtkCubeAxesActor2D, vtkTensorGlyph, vtkGlyph3D
  • GetScreenSize() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkQuartzRenderWindow
  • GetSelectedImageScaleIndex() : vtkRayCaster
  • GetSelectedLODID() : vtkLODProp3D
  • GetSelectedPickLODID() : vtkLODProp3D
  • GetSelectedScalarComponent() : vtkArrayCalculator
  • GetSelectedScalarComponents() : vtkArrayCalculator
  • GetSelectedVectorComponents() : vtkArrayCalculator
  • GetSelectInvisible() : vtkSelectVisiblePoints
  • GetSelection() : vtkSelectVisiblePoints
  • GetSelectionEdges() : vtkSelectPolyData
  • GetSelectionMode() : vtkSelectPolyData
  • GetSelectionModeAsString() : vtkSelectPolyData
  • GetSelectionPoint() : vtkAbstractPicker
  • GetSelectionWindow() : vtkSelectVisiblePoints
  • GetSeries() : vtkMedicalImageReader2
  • GetSetBuffersTime() : vtkCompositeManager
  • GetSFunction() : vtkImplicitTextureCoords
  • GetShade() : vtkVolumeTextureMapper, vtkVolumeProperty
  • GetShadow() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • GetShadows() : vtkRIBLight
  • GetShaftRadius() : vtkArrowSource
  • GetShaftResolution() : vtkArrowSource
  • GetShapeParameters() : vtkPCAAnalysisFilter
  • GetShift() : vtkImageShrink3D, vtkImageShiftScale
  • GetShiftKey() : vtkRenderWindowInteractor, vtkInteractorStyleUser
  • GetShiftsScalesAndMasks() : vtkXImageWindow
  • GetShoulderResolution() : vtkButtonSource
  • GetShoulderTextureCoordinate() : vtkButtonSource
  • GetShrinkFactor() : vtkShrinkPolyData, vtkShrinkFilter
  • GetShrinkFactors() : vtkImageShrink3D
  • GetSidesShareVertices() : vtkTubeFilter
  • GetSigma() : vtkThinPlateSplineTransform
  • GetSign() : vtkLargeInteger
  • GetSize() : vtkXTextMapper, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32TextMapper, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkTextMapper, vtkRenderWindowInteractor, vtkQuartzTextMapper, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkRIBExporter, vtkSuperquadricSource, vtkSuperquadric, vtkPiecewiseFunction, vtkColorTransferFunction, vtkWindow, vtkViewport, vtkDataArray, vtkCellArray
  • GetSizeCX() : vtkImageMandelbrotSource
  • GetSliceNumber() : vtkImageActor
  • GetSmoothing() : vtkImageToPolyDataFilter
  • GetSort() : vtkCGMWriter
  • GetSortBy() : vtkCutter
  • GetSortByAsString() : vtkCutter
  • GetSortingStyle() : vtkFrustumCoverageCuller
  • GetSortingStyleAsString() : vtkFrustumCoverageCuller
  • GetSortScalars() : vtkDepthSortPolyData
  • GetSource() : vtkIterativeClosestPointTransform, vtkTensorGlyph, vtkStreamer, vtkSmoothPolyDataFilter, vtkProgrammableGlyphFilter, vtkProbeFilter, vtkGlyph3D, vtkDelaunay2D, vtkDataObject
  • GetSourceLandmarks() : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • GetSpacing() : vtkImageStencilData, vtkVoxelContoursToSurfaceFilter, vtkDataObjectToDataSetFilter, vtkImageData
  • GetSpacingCallback() : vtkImageImport, vtkImageExport
  • GetSpacingScale() : vtkImageChangeInformation
  • GetSpatialMatch() : vtkProbeFilter
  • GetSpatialRepresentation() : vtkSpatialRepresentationFilter
  • GetSpatialResolution() : vtkDEMReader
  • GetSpecifiedColor() : vtkCGMWriter
  • GetSpecular() : vtkVolumeProperty, vtkProperty
  • GetSpecularColor() : vtkProperty
  • GetSpecularPower() : vtkVolumeProperty, vtkProperty
  • GetSpeed() : vtkVRMLExporter
  • GetSpeedScalars() : vtkStreamer
  • GetSplitAngle() : vtkDecimatePro
  • GetSplitMode() : vtkExtentTranslator
  • GetSplitting() : vtkPolyDataNormals, vtkDecimatePro
  • GetSquareNeighborhood() : vtkImageIslandRemoval2D
  • GetSRange() : vtkTextureMapToPlane, vtkProjectedTexture
  • GetStandardDeviation() : vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageAccumulate
  • GetStandardDeviations() : vtkImageGaussianSmooth
  • GetStartByMatchingCentroids() : vtkIterativeClosestPointTransform
  • GetStartLocation() : vtkStreamer, vtkHyperStreamline
  • GetStartPhi() : vtkSphereSource
  • GetStartPiece() : vtkPDataSetWriter
  • GetStartPosition() : vtkStreamer, vtkHyperStreamline
  • GetStartTheta() : vtkSphereSource
  • GetStartTimeStamp() : vtkVideoSource
  • GetState() : vtkSpherePuzzle
  • GetStencil() : vtkImageStencil, vtkImageReslice, vtkImageBlend, vtkImageAccumulate
  • GetStepLength() : vtkStreamLine, vtkHyperStreamline
  • GetStereoCapableWindow() : vtkRenderWindow
  • GetStereoRender() : vtkRenderWindow
  • GetStereoType() : vtkRenderWindow
  • GetStereoTypeAsString() : vtkRenderWindow
  • GetStillUpdateRate() : vtkRenderWindowInteractor
  • GetSTLFileType() : vtkSTLReader
  • GetStream() : vtkXMLParser
  • GetStreamers() : vtkStreamer
  • GetStreamPoint() : vtkStreamArray
  • GetStringFromErrorCode() : vtkErrorCode
  • GetStringFromEventId() : vtkCommand
  • GetStrips() : vtkPolyData
  • GetStripsComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetStripsComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetStripsComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetStripsComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetStructuredGridInput() : vtkProgrammableFilter
  • GetStructuredGridOutput() : vtkInputPort, vtkDataSetReader, vtkProgrammableSource, vtkDataObjectToDataSetFilter, vtkPointSetToPointSetFilter, vtkDataSetToDataSetFilter
  • GetStructuredPointsInput() : vtkProgrammableFilter
  • GetStructuredPointsOutput() : vtkInputPort, vtkDataSetReader, vtkProgrammableSource, vtkDataObjectToDataSetFilter, vtkDataSetToDataSetFilter
  • GetStudy() : vtkMedicalImageReader2
  • GetSubFrames() : vtkRenderWindow
  • GetSubId() : vtkCellPicker
  • GetSubImageSize() : vtkImageToPolyDataFilter
  • GetSubVolume() : vtkVolumeProMapper
  • GetSuperSampling() : vtkVolumeProMapper
  • GetSuperSamplingFactor() : vtkVolumeProMapper
  • GetSurfaceArea() : vtkMassProperties
  • GetSurfaceShader() : vtkRIBProperty
  • GetSwapBuffers() : vtkRenderWindow
  • GetSwapBytes() : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • GetSwapBytesInReceivedData() : vtkSocketController, vtkSocketCommunicator
  • GetSwitch() : vtkLight
  • GetSymbolAddress() : vtkDynamicLoader
  • GetSymmetric() : vtkAxes
  • GetT() : vtkInterpolateDataSetAttributes
  • GetTable() : vtkPiecewiseFunction, vtkColorTransferFunction
  • GetTableRange() : vtkLookupTable
  • GetTableValue() : vtkLookupTable
  • GetTag() : vtkOutputPort, vtkInputPort
  • GetTarget() : vtkIterativeClosestPointTransform
  • GetTargetFlag() : vtkSubPixelPositionEdgels
  • GetTargetLandmarks() : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • GetTargetReduction() : vtkDecimate, vtkDecimatePro
  • GetTargetTextureSize() : vtkVolumeTextureMapper2D
  • GetTargetValue() : vtkSubPixelPositionEdgels
  • GetTCoordComponentArrayComponent() : vtkFieldDataToAttributeDataFilter
  • GetTCoordComponentArrayName() : vtkFieldDataToAttributeDataFilter
  • GetTCoordComponentMaxRange() : vtkFieldDataToAttributeDataFilter
  • GetTCoordComponentMinRange() : vtkFieldDataToAttributeDataFilter
  • GetTCoordComponentNormalizeFlag() : vtkFieldDataToAttributeDataFilter
  • GetTCoordComponents() : vtkExtractTensorComponents
  • GetTCoords() : vtkMergeFilter, vtkDataSetAttributes
  • GetTCoordsName() : vtkDataWriter, vtkDataReader
  • GetTCoordsNameInFile() : vtkDataReader
  • GetTensorComponentArrayComponent() : vtkFieldDataToAttributeDataFilter
  • GetTensorComponentArrayName() : vtkFieldDataToAttributeDataFilter
  • GetTensorComponentMaxRange() : vtkFieldDataToAttributeDataFilter
  • GetTensorComponentMinRange() : vtkFieldDataToAttributeDataFilter
  • GetTensorComponentNormalizeFlag() : vtkFieldDataToAttributeDataFilter
  • GetTensorMode() : vtkCellDerivatives
  • GetTensorModeAsString() : vtkCellDerivatives
  • GetTensors() : vtkMergeFilter, vtkDataSetAttributes
  • GetTensorsName() : vtkDataWriter, vtkDataReader
  • GetTensorsNameInFile() : vtkDataReader
  • GetTerminalEigenvalue() : vtkHyperStreamline
  • GetTerminalSpeed() : vtkStreamer
  • GetTestOutput() : vtkQuadricDecimation
  • GetTetras() : vtkOrderedTriangulator
  • GetText() : vtkVectorText, vtkTextSource
  • GetTexture() : vtkVolumeTextureMapper2D, vtkActor
  • GetTextureDimension() : vtkThresholdTextureCoords
  • GetTextureDimensions() : vtkButtonSource
  • GetTextureFileName() : vtkBYUWriter, vtkBYUReader
  • GetTextureName() : vtkRIBExporter
  • GetTexturePattern() : vtkTriangularTexture
  • GetTexturePrefix() : vtkRIBExporter
  • GetTextureResolution() : vtkButtonSource
  • GetTextureStyle() : vtkButtonSource
  • GetTFunction() : vtkImplicitTextureCoords
  • GetTheta() : vtkTexturedSphereSource
  • GetThetaMaximum() : vtkImageEuclideanToPolar
  • GetThetaResolution() : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • GetThetaRoundness() : vtkSuperquadricSource, vtkSuperquadric
  • GetThickness() : vtkCamera, vtkBooleanTexture, vtkSuperquadricSource, vtkSuperquadric
  • GetThreeDimensionalLayout() : vtkGraphLayoutFilter
  • GetThreeDimensionalLeader() : vtkCaptionActor2D
  • GetThreshold() : vtkImplicitFunctionToImageStencil, vtkImageDifference
  • GetThresholdedError() : vtkImageDifference
  • GetTickLength() : vtkAxisActor2D
  • GetTickOffset() : vtkAxisActor2D
  • GetTickVisibility() : vtkAxisActor2D
  • GetTIFFName() : vtkRIBExporter
  • GetTiledSize() : vtkViewport
  • GetTileScale() : vtkWindow
  • GetTileViewport() : vtkWindow
  • GetTime() : vtkPLOT3DReader
  • GetTimeFactor() : vtkRenderer
  • GetTimeIncrement() : vtkStreamPoints
  • GetTimerLog() : vtkMultiProcessLog
  • GetTimeToDraw() : vtkAbstractMapper
  • GetTimeValue() : vtkGenericEnSightReader, vtkEnSightReader
  • GetTipLength() : vtkArrowSource
  • GetTipRadius() : vtkArrowSource
  • GetTipResolution() : vtkArrowSource
  • GetTitle() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkAxisActor2D, vtkXYPlotActor
  • GetTitleVisibility() : vtkAxisActor2D
  • GetTolerance() : vtkSelectVisiblePoints, vtkPicker, vtkPolyDataToImageStencil, vtkDelaunay3D, vtkDelaunay2D, vtkCleanPolyData, vtkLocator
  • GetToleranceIsAbsolute() : vtkCleanPolyData
  • GetTopLevelShell() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • GetTopology() : vtkDataSetToDataObjectFilter
  • GetToroidal() : vtkSuperquadricSource, vtkSuperquadric
  • GetTotalRenderTime() : vtkRayCaster
  • GetTrackballMode() : vtkInteractorStyleTrackball
  • GetTRange() : vtkTextureMapToPlane, vtkProjectedTexture
  • GetTransform() : vtkVolume16Reader, vtkImageReader, vtkWeightedTransformFilter, vtkTransformPolyDataFilter, vtkTransformFilter, vtkDelaunay2D, vtkImplicitFunction, vtkTransformConcatenation
  • GetTransformCoordinate() : vtkPolyDataMapper2D
  • GetTransformedFocalPoint() : vtkLight
  • GetTransformedPosition() : vtkLight
  • GetTransformInputSampling() : vtkImageReslice
  • GetTransformMatrix() : vtkLight
  • GetTransforms() : vtkSweptSurface
  • GetTranslation() : vtkImageTranslateExtent, vtkRotationalExtrusionFilter
  • GetTranspose() : vtkTransform
  • GetTraversalLocation() : vtkCellArray
  • GetTriangle() : vtkTriArray, vtkProTriArray
  • GetTuple() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • GetTuple1() : vtkDataArray
  • GetTuple2() : vtkDataArray
  • GetTuple3() : vtkDataArray
  • GetTuple4() : vtkDataArray
  • GetTuple9() : vtkDataArray
  • GetTuples() : vtkDataArray
  • GetTwoSided() : vtkButtonSource
  • GetTwoSidedLighting() : vtkRenderer
  • GetType() : vtkPiecewiseFunction
  • GetUFlowFileName() : vtkPOPReader
  • GetUnconnectedValue() : vtkImageConnector
  • GetUnselectedOutput() : vtkSelectPolyData
  • GetUnstructuredGridInput() : vtkProgrammableFilter
  • GetUnstructuredGridOutput() : vtkInputPort, vtkDataSetReader, vtkProgrammableSource, vtkDataObjectToDataSetFilter, vtkPointSetToPointSetFilter, vtkDataSetToDataSetFilter
  • GetUp() : vtkProjectedTexture
  • GetUpdateDataCallback() : vtkImageImport, vtkImageExport
  • GetUpdateExtent() : vtkUnstructuredGrid, vtkPolyData, vtkDataObject
  • GetUpdateGhostLevel() : vtkDataObject
  • GetUpdateInformationCallback() : vtkImageImport, vtkImageExport
  • GetUpdateNumberOfPieces() : vtkDataObject
  • GetUpdatePiece() : vtkDataObject
  • GetUpdateTime() : vtkDataObject
  • GetUpperThreshold() : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • GetUpVector() : vtkCutMaterial
  • GetUseChar() : vtkCompositeManager
  • GetUseCompositing() : vtkCompositeManager
  • GetUseCustomExtents() : vtkImageMapper
  • GetUseCylinderClip() : vtkEncodedGradientEstimator
  • GetUseDefaultNormal() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • GetUseFeatureEdges() : vtkQuadricClustering
  • GetUseFeaturePoints() : vtkQuadricClustering
  • GetUseFileSets() : vtkEnSightReader
  • GetUseInputPoints() : vtkQuadricClustering
  • GetUseInternalTriangles() : vtkQuadricClustering
  • GetUseLookupTableScalarRange() : vtkPolyDataMapper2D, vtkMapper
  • GetUseNormal() : vtkWarpScalar
  • GetUseRanges() : vtkCubeAxesActor2D
  • GetUseRelativeFileNames() : vtkPDataSetWriter
  • GetUserManagedInputs() : vtkAppendPolyData
  • GetUserMatrix() : vtkProp3D
  • GetUserTransform() : vtkProp3D
  • GetUseScalarTree() : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • GetUseStrips() : vtkDataSetSurfaceFilter
  • GetUseTimeSets() : vtkEnSightReader
  • GetUseTwoSortIds() : vtkOrderedTriangulator
  • GetUvinf() : vtkPLOT3DReader
  • GetValidPoints() : vtkProbeFilter
  • GetValue() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkRecursiveDividingCubes, vtkEdgePoints, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkBandedPolyDataContourFilter, vtkPiecewiseFunction, vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCoordinate, vtkContourValues, vtkCharArray, vtkBitArray
  • GetValueRange() : vtkLookupTable
  • GetValues() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkBandedPolyDataContourFilter, vtkContourValues
  • GetValueScale() : vtkPiecewiseFunctionShiftScale
  • GetValueShift() : vtkPiecewiseFunctionShiftScale
  • GetVariableNameLength() : vtkFunctionParser
  • GetVariableType() : vtkGenericEnSightReader, vtkEnSightReader
  • GetVaryRadius() : vtkTubeFilter
  • GetVaryRadiusAsString() : vtkTubeFilter
  • GetVaryWidth() : vtkRibbonFilter
  • GetVector() : vtkDepthSortPolyData, vtkSimpleElevationFilter, vtkLinearExtrusionFilter
  • GetVectorArrayName() : vtkArrayCalculator
  • GetVectorArrayNames() : vtkArrayCalculator
  • GetVectorComponentArrayComponent() : vtkFieldDataToAttributeDataFilter
  • GetVectorComponentArrayName() : vtkFieldDataToAttributeDataFilter
  • GetVectorComponentMaxRange() : vtkFieldDataToAttributeDataFilter
  • GetVectorComponentMinRange() : vtkFieldDataToAttributeDataFilter
  • GetVectorComponentNormalizeFlag() : vtkFieldDataToAttributeDataFilter
  • GetVectorComponents() : vtkExtractTensorComponents
  • GetVectorFunctionFileName() : vtkPLOT3DReader
  • GetVectorFunctionNumber() : vtkPLOT3DReader
  • GetVectorInput() : vtkImageToStructuredPoints
  • GetVectorMode() : vtkHedgeHog, vtkGlyph3D, vtkCellDerivatives
  • GetVectorModeAsString() : vtkHedgeHog, vtkGlyph3D, vtkCellDerivatives
  • GetVectorResult() : vtkFunctionParser
  • GetVectors() : vtkMergeFilter, vtkDataSetAttributes
  • GetVectorsName() : vtkDataWriter, vtkDataReader
  • GetVectorsNameInFile() : vtkDataReader
  • GetVectorVariableName() : vtkArrayCalculator, vtkFunctionParser
  • GetVectorVariableNames() : vtkArrayCalculator
  • GetVectorVariableValue() : vtkFunctionParser
  • GetVertex() : vtkVertexArray, vtkProVertexArray
  • GetVertexCells() : vtkCellCenters
  • GetVerticalJustification() : vtkTextMapper, vtkCaptionActor2D
  • GetVerts() : vtkPolyData
  • GetVertsComponentArrayComponent() : vtkDataObjectToDataSetFilter
  • GetVertsComponentArrayName() : vtkDataObjectToDataSetFilter
  • GetVertsComponentMaxRange() : vtkDataObjectToDataSetFilter
  • GetVertsComponentMinRange() : vtkDataObjectToDataSetFilter
  • GetVFlowFileName() : vtkPOPReader
  • GetVideoChannel() : vtkMILVideoSource
  • GetVideoFormat() : vtkMILVideoSource
  • GetVideoInput() : vtkMILVideoSource
  • GetViewAngle() : vtkCamera
  • GetViewingRaysMTime() : vtkCamera
  • GetViewPlaneNormal() : vtkCamera
  • GetViewPoint() : vtkViewport
  • GetViewport() : vtkCGMWriter, vtkViewport, vtkCoordinate
  • GetViewportCoordinate() : vtkXYPlotActor
  • GetViewRaysSize() : vtkRayCaster
  • GetViewRaysStepSize() : vtkRayCaster
  • GetViewShear() : vtkCamera
  • GetViewTransform() : vtkCamera
  • GetViewTransformMatrix() : vtkCamera
  • GetViewTransformObject() : vtkCamera
  • GetViewUp() : vtkCamera
  • GetVisibility() : vtkProp
  • GetVisualClass() : vtkXImageWindow
  • GetVisualDepth() : vtkXImageWindow
  • GetVisualId() : vtkXImageWindow
  • GetVOI() : vtkExtractVOI, vtkExtractGrid
  • GetVoidPointer() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPoints, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • GetVolume() : vtkAbstractPropPicker, vtkMassProperties, vtkImplicitVolume
  • GetVolumeRayCastFunction() : vtkVolumeRayCastMapper
  • GetVolumes() : vtkVolume, vtkRenderer, vtkAssembly, vtkProp
  • GetVolumeX() : vtkMassProperties
  • GetVolumeY() : vtkMassProperties
  • GetVolumeZ() : vtkMassProperties
  • GetVorticity() : vtkStreamer
  • GetVoxelCount() : vtkImageAccumulate
  • GetVoxelCroppingRegionPlanes() : vtkVolumeMapper
  • GetVoxelGradient() : vtkImageData
  • GetVRMLDEFObject() : vtkVRMLImporter
  • GetVTKBuildVersion() : vtkVersion
  • GetVTKMajorVersion() : vtkVersion
  • GetVTKMinorVersion() : vtkVersion
  • GetVTKSourceVersion() : vtkKitwareObjectFactory, vtkParallelFactory, vtkVersion, vtkObjectFactory
  • GetVTKVersion() : vtkVersion
  • GetVTKWindow() : vtkRenderer, vtkImager, vtkViewport
  • GetVvinf() : vtkPLOT3DReader
  • GetVxComponent() : vtkExtractVectorComponents
  • GetVyComponent() : vtkExtractVectorComponents
  • GetVzComponent() : vtkExtractVectorComponents
  • GetWeightArray() : vtkWeightedTransformFilter
  • GetWholeExtent() : vtkRTAnalyticSource, vtkImageBlockReader, vtkImageMandelbrotSource, vtkImageImport, vtkImageEllipsoidSource, vtkExtentTranslator, vtkDataObject
  • GetWholeExtentCallback() : vtkImageImport, vtkImageExport
  • GetWholeWindow() : vtkRendererSource
  • GetWholeZMax() : vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor
  • GetWholeZMin() : vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor
  • GetWidget() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • GetWidth() : vtkTextMapper, vtkRibbonFilter, vtkButtonSource, vtkActor2D
  • GetWidthFactor() : vtkRibbonFilter
  • GetWindow() : vtkImageMapToWindowLevelColors, vtkWindowLevelLookupTable
  • GetWindowCenter() : vtkCamera
  • GetWindowId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • GetWindowLevel() : vtkImageViewer2
  • GetWindowLevelCurrentPosition() : vtkInteractorStyleImage
  • GetWindowLevelStartPosition() : vtkInteractorStyleImage
  • GetWindowName() : vtkImageViewer2, vtkImageViewer, vtkWindow
  • GetWindowRange() : vtkImplicitWindowFunction
  • GetWindowValues() : vtkImplicitWindowFunction
  • GetWorldCommunicator() : vtkMPICommunicator
  • GetWorldPoint() : vtkViewport
  • GetWorldUpVector() : vtkInteractorStyleUnicam
  • GetWrap() : vtkImageReslice, vtkCursor3D
  • GetWriteDisplacement() : vtkBYUWriter
  • GetWriteScalar() : vtkBYUWriter
  • GetWriteTexture() : vtkBYUWriter
  • GetWriteToOutputString() : vtkDataWriter
  • GetWrongVLIVersion() : vtkVolumeProMapper
  • GetWvinf() : vtkPLOT3DReader
  • GetXAxisVisibility() : vtkCubeAxesActor2D
  • GetXColors() : vtkXImageMapper
  • GetXCoordinates() : vtkRectilinearGrid
  • GetXCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • GetXFreq() : vtkRTAnalyticSource
  • GetXKernel() : vtkImageSeparableConvolution
  • GetXLabel() : vtkCubeAxesActor2D
  • GetXLength() : vtkCubeSource
  • GetXMag() : vtkRTAnalyticSource
  • GetXMLByteIndex() : vtkXMLParser
  • GetXRange() : vtkProp3D, vtkXYPlotActor
  • GetXResolution() : vtkPlaneSource
  • GetXShadows() : vtkCursor3D
  • GetXSize() : vtkTriangularTexture, vtkBooleanTexture
  • GetXTitle() : vtkXYPlotActor
  • GetXValues() : vtkXYPlotActor
  • GetXValuesAsString() : vtkXYPlotActor
  • GetXWindowColorMasks() : vtkXImageMapper
  • GetXWindowDepth() : vtkXImageMapper
  • GetXWindowVisualClass() : vtkXImageMapper
  • GetXWindowVisualId() : vtkXImageMapper
  • GetXYPlane() : vtkWarpScalar
  • GetXYZFileName() : vtkPLOT3DReader
  • GetYAxisVisibility() : vtkCubeAxesActor2D
  • GetYCoordinates() : vtkRectilinearGrid
  • GetYCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • GetYFreq() : vtkRTAnalyticSource
  • GetYKernel() : vtkImageSeparableConvolution
  • GetYLabel() : vtkCubeAxesActor2D
  • GetYLength() : vtkCubeSource
  • GetYMag() : vtkRTAnalyticSource
  • GetYRange() : vtkProp3D, vtkXYPlotActor
  • GetYResolution() : vtkPlaneSource
  • GetYShadows() : vtkCursor3D
  • GetYSize() : vtkTriangularTexture, vtkBooleanTexture
  • GetYTitle() : vtkXYPlotActor
  • GetZ() : vtkRenderer, vtkCompositeManager
  • GetZAxisVisibility() : vtkCubeAxesActor2D
  • GetZbufferData() : vtkRenderWindow, vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • GetZBufferValue() : vtkVolumeRayCastMapper
  • GetZCoordinates() : vtkRectilinearGrid
  • GetZCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • GetZeroNormalDiffuseIntensity() : vtkEncodedGradientShader
  • GetZeroNormalSpecularIntensity() : vtkEncodedGradientShader
  • GetZeroNormalThreshold() : vtkEncodedGradientEstimator
  • GetZeroOpacityThreshold() : vtkVolumeRayCastMIPFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction, vtkVolumeRayCastCompositeFunction
  • GetZeroPad() : vtkEncodedGradientEstimator
  • GetZFreq() : vtkRTAnalyticSource
  • GetZKernel() : vtkImageSeparableConvolution
  • GetZLabel() : vtkCubeAxesActor2D
  • GetZLength() : vtkCubeSource
  • GetZMag() : vtkRTAnalyticSource
  • GetZRange() : vtkProp3D
  • GetZShadows() : vtkCursor3D
  • GetZSlice() : vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor
  • GhostLevel : vtkPolyDataMapper, vtkPDataSetWriter, vtkExtentTranslator, vtkDataObject
  • GhostLevelArray : vtkFieldDataToAttributeDataFilter
  • GhostLevelArrayComponent : vtkFieldDataToAttributeDataFilter
  • GhostLevelComponentRange : vtkFieldDataToAttributeDataFilter
  • GhostLevelNormalize : vtkFieldDataToAttributeDataFilter
  • glAlphaFunc() : vtkOpenGLStateCache
  • glBlendFunc() : vtkOpenGLStateCache
  • glClear() : vtkOpenGLStateCache
  • glClearColor() : vtkOpenGLStateCache
  • glClearDepth() : vtkOpenGLStateCache
  • glClipPlane() : vtkOpenGLStateCache
  • glColorMaterial() : vtkOpenGLStateCache
  • glCullFace() : vtkOpenGLStateCache
  • glDepthFunc() : vtkOpenGLStateCache
  • glDepthMask() : vtkOpenGLStateCache
  • glDepthRange() : vtkOpenGLStateCache
  • glDisable() : vtkOpenGLStateCache
  • glDrawBuffer() : vtkOpenGLStateCache
  • glEnable() : vtkOpenGLStateCache
  • glLightf() : vtkOpenGLStateCache
  • glLightfv() : vtkOpenGLStateCache
  • glLighti() : vtkOpenGLStateCache
  • glLightModelfv() : vtkOpenGLStateCache
  • glLightModeli() : vtkOpenGLStateCache
  • glLineStipple() : vtkOpenGLStateCache
  • glLineWidth() : vtkOpenGLStateCache
  • glMaterialfv() : vtkOpenGLStateCache
  • glMatrixMode() : vtkOpenGLStateCache
  • GlobalImmediateModeRenderingOff() : vtkMapper
  • GlobalImmediateModeRenderingOn() : vtkMapper
  • GlobalIndex : vtkMesaTexture, vtkMesaImageActor
  • GlobalReleaseDataFlagOff() : vtkDataObject
  • GlobalReleaseDataFlagOn() : vtkDataObject
  • GlobalTMin : vtkPicker
  • GlobalWarningDisplayOff() : vtkObject
  • GlobalWarningDisplayOn() : vtkObject
  • glPointSize() : vtkOpenGLStateCache
  • glScissor() : vtkOpenGLStateCache
  • glShadeModel() : vtkOpenGLStateCache
  • glTexEnvf() : vtkOpenGLStateCache
  • GLUTesselator : vtkGLUTesselatorTriangleFilter
  • glViewport() : vtkOpenGLStateCache
  • GlyphMethod : vtkProgrammableGlyphFilter
  • GlyphMethodArg : vtkProgrammableGlyphFilter
  • GlyphMethodArgDelete : vtkProgrammableGlyphFilter
  • GlyphSize : vtkXYPlotActor
  • GlyphSource : vtkXYPlotActor
  • GlyphType : vtkGlyphSource2D
  • Grab() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • GradientDiffuseModulation : vtkVolumeProMapper
  • GradientDiffuseModulationOff() : vtkVolumeProMapper
  • GradientDiffuseModulationOn() : vtkVolumeProMapper
  • GradientEstimator : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • GradientMagnitudeBias : vtkEncodedGradientEstimator
  • GradientMagnitudes : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkEncodedGradientEstimator
  • GradientMagnitudeScale : vtkEncodedGradientEstimator
  • GradientMagnitudeThreshold : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GradientMagnitudeThresholdOff() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GradientMagnitudeThresholdOn() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • GradientOpacity : vtkVolumeProperty
  • GradientOpacityArray : vtkVolumeTextureMapper, vtkVolume
  • GradientOpacityArrayMTime : vtkVolume
  • GradientOpacityConstant : vtkVolume
  • GradientOpacityModulation : vtkVolumeProMapper
  • GradientOpacityModulationOff() : vtkVolumeProMapper
  • GradientOpacityModulationOn() : vtkVolumeProMapper
  • GradientOpacityMTime : vtkVolumeProperty
  • Gradients : vtkImageMarchingCubes
  • GradientShader : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • GradientSpecularModulation : vtkVolumeProMapper
  • GradientSpecularModulationOff() : vtkVolumeProMapper
  • GradientSpecularModulationOn() : vtkVolumeProMapper
  • GradientTableSize : vtkVolumeProMapper
  • GradientThreshold : vtkLinkEdgels
  • GraphBounds : vtkGraphLayoutFilter
  • GrayArray : vtkVolume
  • GrayArrayMTime : vtkVolume
  • GRAYSCALE : vtkTIFFReader
  • GrayScaleHint : vtkImageWindow
  • GrayScaleHintOff() : vtkImageWindow, vtkImageViewer
  • GrayScaleHintOn() : vtkImageWindow, vtkImageViewer
  • GrayTransferFunction : vtkVolumeProperty
  • GrayTransferFunctionMTime : vtkVolumeProperty
  • Green : vtkColorTransferFunction
  • green : Colour_24, Colour
  • GreenDiffuseShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • GreenSpecularShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • Grid : vtkPLOT3DReader
  • GridExtent : vtkTransformToGrid
  • GridFileName : vtkPOPReader
  • GridNumber : vtkPLOT3DReader
  • GridOrigin : vtkImageGridSource, vtkTransformToGrid
  • GridScalarType : vtkTransformToGrid
  • GridSize : vtkRecursiveSphereDirectionEncoder
  • GridSpacing : vtkImageGridSource, vtkTransformToGrid
  • GroundCoords : vtkDEMReader
  • GroundSystem : vtkDEMReader
  • GroundZone : vtkDEMReader
  • Group : vtkMPICommunicator

- h -
  • H : vtkCellLocator, vtkPointLocator2D, vtkPointLocator
  • Handle : vtkMPICommunicator
  • HandleBoundaries : vtkImageSpatialFilter, vtkImageNonMaximumSuppression, vtkImageGradientMagnitude, vtkImageGradient
  • HandleBoundariesOff() : vtkImageNonMaximumSuppression, vtkImageGradientMagnitude, vtkImageGradient
  • HandleBoundariesOn() : vtkImageNonMaximumSuppression, vtkImageGradientMagnitude, vtkImageGradient
  • HandleObservers : vtkInteractorStyle
  • HandleObserversOff() : vtkInteractorStyle
  • HandleObserversOn() : vtkInteractorStyle
  • HashPoint() : vtkQuadricClustering
  • HashTable : vtkPointLocator2D, vtkPointLocator
  • HasObserver() : vtkObject
  • HasOverride() : vtkObjectFactory
  • HasOverrideAny() : vtkObjectFactory
  • HBitmap : vtkWin32ImageMapper, vtkQuartzImageMapper
  • Head : vtkSplitField, vtkRearrangeFields, vtkMergeFields
  • Header : vtkDataWriter, vtkDataReader
  • HeaderSize : vtkVolume16Reader, vtkMCubesReader, vtkImageReader2
  • Headlight : vtkLightKit
  • HeadlightColor : vtkLightKit
  • HeadlightWarmth : vtkLightKit
  • Heap : vtkVRMLAllocator
  • Height : vtkTkRenderWidget, vtkTkImageWindowWidget, vtkTkImageViewerWidget, vtkArcPlotter, vtkCylinderSource, vtkConeSource, vtkButtonSource
  • Hexahedron : vtkUnstructuredGrid, vtkStructuredGrid
  • hidden : Mesh
  • HideCursor() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindowInteractor, vtkRenderWindow, vtkQuartzRenderWindow
  • HighlightActor2D() : vtkInteractorStyle
  • HighlightProp() : vtkInteractorStyle
  • HighlightProp3D() : vtkInteractorStyle
  • HighPoint : vtkElevationFilter
  • HitBBox() : vtkCell
  • hotspot : SpotLight
  • HSVToRGB() : vtkColorTransferFunction
  • HueLevel : vtkMILVideoSource
  • HueRange : vtkLookupTable

- i -
  • Ia : vtkCellArray
  • Id : vtkRearrangeFields::Operation
  • ID : vtkLODProp3DEntry, vtkImageProgressIterator< DType >
  • id : _vtkLocalTri, _vtkLocalVertex, _vtkProLocalTri, _vtkProLocalVertex, _vtkPriorityItem
  • Identity() : vtkTransform, vtkPerspectiveTransform, vtkMatrix4x4, vtkGeneralTransform, vtkTransformConcatenation, vtkAbstractTransform
  • Identity3x3() : vtkMath
  • Ids : vtkIdList
  • IdsArrayName : vtkIdFilter
  • IFile : vtkGenericEnSightReader, vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • Image : vtkXImageMapper, vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ImageActor : vtkImageViewer2
  • ImageBuffer : vtkVolumeProVP1000Mapper
  • ImageClipper : vtkVolumeMapper
  • ImageContour() : vtkMarchingContourFilter
  • ImageData : vtkImageCanvasSource2D
  • ImageDataExecute() : vtkPVGeometryFilter, vtkPDataSetReader
  • ImageHeight : vtkWarpLens
  • ImageInUseSize : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ImageLowerLeft : vtkImageExport
  • ImageLowerLeftOff() : vtkImageExport
  • ImageLowerLeftOn() : vtkImageExport
  • ImageMapper : vtkImageViewer
  • ImageMemorySize : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ImageNumber : vtkMedicalImageReader2
  • ImageOrigin : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ImageRange : vtkMarchingSquares, vtkVolumeReader
  • Imagers : vtkImageWindow
  • ImageSampleDistance : vtkVolumeRayCastMapper
  • ImageSize : VTKRayCastRayInfo
  • ImageViewer : vtkTkImageViewerWidget
  • ImageViewportSize : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ImageWidth : vtkWarpLens
  • ImageWindow : vtkTkImageWindowWidget
  • ImmediateModeRendering : vtkMapper
  • ImmediateModeRenderingOff() : vtkMapper
  • ImmediateModeRenderingOn() : vtkMapper
  • Immediates : vtkFunctionParser
  • ImmediatesSize : vtkFunctionParser
  • ImplicitFunction : vtkSampleFunction, vtkExtractPolyDataGeometry, vtkExtractGeometry, vtkImplicitWindowFunction
  • ImportActors() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportBegin() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportCameras() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportEnd() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportLights() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportProperties() : vtkImporter, vtkVRMLImporter, vtk3DSImporter
  • ImportVoidPointer : vtkImageImport
  • InAbortCheck : vtkRenderWindow
  • InCellCount : vtkQuadricClustering
  • IncludeBoundary : vtkExtractGrid
  • IncludeBoundaryOff() : vtkExtractGrid
  • IncludeBoundaryOn() : vtkExtractGrid
  • IncreaseArraySize() : vtkPiecewiseFunction
  • Increment : vtkDividingCubes, vtkRecursiveDividingCubes
  • IncrementLinkCount() : vtkCellLinks
  • IncrementLocatorZ() : vtkImageMarchingCubes
  • Increments : vtkImageIterator< DType >, vtkImageData
  • InDelete : vtkTclInterpStruct
  • Indent : vtkIndent
  • IndependentComponents : vtkVolumeMapper
  • IndependentComponentsOff() : vtkVolumeMapper
  • IndependentComponentsOn() : vtkVolumeMapper
  • Index : vtkOpenGLTexture, vtkOpenGLImageActor, vtkMesaTexture, vtkMesaImageActor, vtkImageConnectorSeed, vtkSplitField::Component, vtkMergeFields::Component
  • IndexMatrix : vtkImageReslice
  • IndexMode : vtkGlyph3D
  • IndexTable : vtkRecursiveSphereDirectionEncoder
  • IndexTableRecursionDepth : vtkRecursiveSphereDirectionEncoder
  • Inertia : vtkCubeAxesActor2D
  • InertiaAxes : vtkCubeAxesActor2D
  • InflectionPointRatio : vtkDecimatePro
  • InflectionPoints : vtkDecimatePro
  • INFORMATION_TRANSFER_TAG : vtkInputPort
  • InformationInput : vtkImageReslice, vtkImageChangeInformation
  • InformationTime : vtkSource
  • InIn : vtkBooleanTexture
  • Init() : VectorType< T >, vtkSimpleCriticalSection
  • InitEdgeInsertion() : vtkEdgeTable
  • InitialError : vtkDecimate
  • InitialFeatureAngle : vtkDecimate
  • Initialize : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32RenderWindowInteractor, vtkWin32OpenGLRenderWindow, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkPropPicker, vtkPointPicker, vtkPicker, vtkOpenGLStateCache, vtkCellPicker, vtkAbstractPropPicker, vtkAbstractPicker, vtkThreadedController, vtkSocketController, vtkSharedMemoryCommunicator, vtkMultiProcessController, vtkMPIGroup, vtkMPIController, vtkMPICommunicator, vtkImageStencilData, vtkWin32VideoSource, vtkVRMLAllocator, vtkVideoSource, vtkMILVideoSource, vtkSimpleScalarTree, vtkScalarTree, vtkPiecewiseFunction, vtkXMLFileOutputWindow, vtkWin32OutputWindow, vtkVoidArray, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTensor, vtkStructuredGrid, vtkShortArray, vtkRungeKutta45, vtkRungeKutta4, vtkRectilinearGrid, vtkPolyData, vtkPointSet, vtkPoints, vtkPointLocator2D, vtkPointLocator, vtkLongArray, vtkLocator, vtkIntArray, vtkInitialValueProblemSolver, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkFileOutputWindow, vtkFieldData, vtkEdgeTable, vtkDoubleArray, vtkDataSetAttributes, vtkDataSet, vtkDataObject, vtkDataArray, vtkCharArray, vtkCellArray, vtkCell, vtkBitArray, vtkImageEuclideanDistance
  • InitializeApplication() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow
  • InitializeBarrier() : vtkThreadedController
  • InitializeCharacteristics() : vtkDataReader
  • InitializeClippingPlanes() : vtkVolumeRayCastMapper
  • InitializeColors() : vtkTIFFReader
  • InitializeCommunicator() : vtkMPIController
  • InitializeCopy() : vtkMPICommunicator
  • Initialized : vtkRenderWindowInteractor, vtkSocketController, vtkSharedMemoryCommunicator, vtkMPIGroup, vtkMPIController, vtkMPICommunicator, vtkImageClip, vtkVideoSource, vtkInitialValueProblemSolver
  • InitializeEntries() : vtkXYPlotActor, vtkLegendBoxActor
  • InitializeExecuteTime : vtkImageQuantizeRGBToIndex
  • InitializeFieldList() : vtkDataSetAttributes::FieldList
  • InitializeFields() : vtkFieldData, vtkDataSetAttributes
  • InitializeIndexTable() : vtkRecursiveSphereDirectionEncoder
  • InitializeLocator() : vtkImageMarchingCubes
  • InitializeLogging() : vtkMPIEventLog
  • InitializeNumberOfProcesses() : vtkMPIController
  • InitializeOff() : vtkImageEuclideanDistance
  • InitializeOffScreen() : vtkCompositeManager
  • InitializeOn() : vtkImageEuclideanDistance
  • InitializePickList() : vtkAbstractPicker
  • InitializePieces() : vtkCompositeManager
  • InitializeQuadHash() : vtkDataSetSurfaceFilter
  • InitializeQuadric() : vtkQuadricClustering
  • InitializeReaders() : vtkImageReader2Factory
  • InitializeRender() : vtkVolumeTextureMapper2D, vtkVolumeTextureMapper
  • InitializeRMICommunicator() : vtkMPIController
  • InitializeRMIs() : vtkCompositeManager
  • InitializeSeedList() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • InitializeSpecifiedRegionList() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • InitializeThreadedIntegrate() : vtkStreamer
  • InitializeWarmthFunctions() : vtkLightKit
  • InitOutput() : vtkImageAppend
  • InitPartTraversal() : vtkActor
  • InitPathTraversal() : vtkProp3D, vtkAssembly, vtkPropAssembly, vtkProp
  • InitPointInsertion() : vtkDelaunay3D, vtkPointLocator, vtkEdgeTable
  • InitQuadHashTraversal() : vtkDataSetSurfaceFilter
  • InitTraversal() : vtkSimpleScalarTree, vtkScalarTree, vtkEdgeTable, vtkCollection, vtkCellArray
  • InitTriangulation() : vtkOrderedTriangulator
  • InnerRadius : vtkDiskSource
  • InnerSize : vtkRecursiveSphereDirectionEncoder
  • InOn : vtkBooleanTexture
  • InOut : vtkBooleanTexture
  • Input : vtkWindowToImageFilter, vtkTextMapper, vtkRendererSource, vtkPolyDataMapper2D, vtkLabeledDataMapper, vtkImageActor, vtkEncodedGradientEstimator, vtkImplicitFunctionToImageStencil, vtkTransformToGrid, vtkRenderLargeImage, vtkCubeAxesActor2D, vtkPiecewiseFunctionShiftScale, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkGeneralTransform
  • InputArray : vtkDataReader
  • InputAspect : vtkEncodedGradientEstimator
  • InputAttributeType : vtkAssignAttribute
  • InputConnectValue : vtkImageSeedConnectivity
  • InputField : vtkFieldDataToAttributeDataFilter
  • InputList : vtkXYPlotActor, vtkProgrammableAttributeDataFilter, vtkInterpolateDataSetAttributes, vtkAppendFilter
  • InputMemoryLimit : vtkImageMarchingCubes
  • Inputs : vtkProcessObject
  • InputScalarsSelection : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkGridSynchronizedTemplates3D, vtkWarpScalar, vtkThreshold, vtkContourGrid, vtkContourFilter, vtkClipDataSet
  • InputSize : vtkEncodedGradientEstimator
  • InputString : vtkDataReader
  • InputStringLength : vtkDataReader
  • InputStringPos : vtkDataReader
  • InputType : vtkImageQuantizeRGBToIndex
  • InputVectorsSelection : vtkWarpVector
  • InRegisterLoop() : vtkSelectPolyData, vtkSource
  • InRender : vtkRenderWindow
  • Insert() : vtkPriorityQueue
  • InsertCell() : vtkBandedPolyDataContourFilter, vtkCellTypes
  • InsertCellPoint() : vtkCellArray
  • InsertCellReference() : vtkCellLinks
  • InsertComponent() : vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • InsertEdge() : vtkEdgeTable
  • InsertedPoints : vtkOBBTree
  • InsertId() : vtkIdList
  • InsertionLevel : vtkPointLocator
  • InsertionPointId : vtkPointLocator
  • InsertionTol2 : vtkPointLocator2D, vtkPointLocator
  • InsertItem() : vtkAbstractList< DType >
  • InsertLocation : vtkCellArray
  • InsertNextCell() : vtkUnstructuredGrid, vtkPolyData, vtkCellTypes, vtkCellArray
  • InsertNextCellReference() : vtkCellLinks
  • InsertNextExtent() : vtkImageStencilData
  • InsertNextId() : vtkIdList
  • InsertNextLinkedCell() : vtkUnstructuredGrid, vtkPolyData
  • InsertNextLinkedPoint() : vtkPolyData
  • InsertNextPoint() : vtkPoints, vtkPointLocator, vtkCellLinks
  • InsertNextStreamPoint() : vtkStreamArray
  • InsertNextTriangle() : vtkTriArray, vtkProTriArray
  • InsertNextTuple() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • InsertNextTuple1() : vtkDataArray
  • InsertNextTuple2() : vtkDataArray
  • InsertNextTuple3() : vtkDataArray
  • InsertNextTuple4() : vtkDataArray
  • InsertNextTuple9() : vtkDataArray
  • InsertNextType() : vtkCellTypes
  • InsertNextValue() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkBitArray
  • InsertNextVertex() : vtkVertexArray, vtkProVertexArray
  • InsertPoint() : vtkDelaunay3D, vtkPiecewiseFunction, vtkPoints, vtkPointLocator, vtkOrderedTriangulator, vtkNonLinearCell
  • InsertQuadInHash() : vtkDataSetSurfaceFilter
  • InsertTetra() : vtkDelaunay3D
  • InsertTime : vtkLookupTable
  • InsertTriInHash() : vtkDataSetSurfaceFilter
  • InsertTuple() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • InsertTuple1() : vtkDataArray
  • InsertTuple2() : vtkDataArray
  • InsertTuple3() : vtkDataArray
  • InsertTuple4() : vtkDataArray
  • InsertTuple9() : vtkDataArray
  • InsertUniqueId() : vtkIdList
  • InsertUniquePoint() : vtkMergePoints, vtkPointLocator, vtkEdgeTable
  • InsertValue() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkBitArray
  • InsideOrOutside() : vtkOBBTree
  • InsideOut : vtkSelectPolyData, vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • InsideOutOff() : vtkSelectPolyData, vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • InsideOutOn() : vtkSelectPolyData, vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • InSphere() : vtkDelaunay3D
  • InstallMessageProc : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • InstallMessageProcOff() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • InstallMessageProcOn() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • InstanceLookup : vtkTclInterpStruct
  • InstanceNormal() : vtkWarpScalar
  • Integrate() : vtkStreamer
  • IntegrateMajorEigenvector() : vtkHyperStreamline
  • IntegrateMediumEigenvector() : vtkHyperStreamline
  • IntegrateMinorEigenvector() : vtkHyperStreamline
  • IntegrationDirection : vtkStreamer, vtkHyperStreamline
  • IntegrationEigenvector : vtkHyperStreamline
  • IntegrationStepLength : vtkStreamer, vtkHyperStreamline
  • Integrator : vtkStreamer
  • Intensity : vtkLight
  • InteractionPicker : vtkInteractorStyleUnicam, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • InteractionProp : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • Interactive : vtkRenderer
  • InteractiveOff() : vtkRenderer
  • InteractiveOn() : vtkRenderer
  • Interactor : vtkRenderWindow, vtkInteractorStyle, vtkImageViewer2
  • InteractorStyle : vtkRenderWindowInteractor, vtkImageViewer2
  • IntermixIntersectingGeometry : vtkVolumeRayCastMapper, vtkVolumeProMapper
  • IntermixIntersectingGeometryOff() : vtkVolumeRayCastMapper, vtkVolumeProMapper
  • IntermixIntersectingGeometryOn() : vtkVolumeRayCastMapper, vtkVolumeProMapper
  • internal_type : PlyProperty
  • InternalDataSet : vtkQuadraticEdge
  • InternalDeepCopy() : vtkThinPlateSplineTransform, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkGridTransform, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkIdentityTransform, vtkHomogeneousTransform, vtkGeneralTransform, vtkAbstractTransform
  • InternalDoublePoint : vtkAbstractTransform
  • InternalFileName : vtkImageWriter, vtkImageReader2
  • InternalFloatPoint : vtkAbstractTransform
  • InternalGrab() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • InternalImageStencilDataCopy() : vtkImageStencilData
  • InternalMaxDistance : vtkImplicitModeller
  • InternalSkipFactor : vtkVolumeTextureMapper2D
  • InternalTesselate() : vtkQuadraticEdge
  • InternalTransformDerivative() : vtkWarpTransform, vtkLinearTransform, vtkIdentityTransform, vtkHomogeneousTransform, vtkGeneralTransform, vtkAbstractTransform
  • InternalTransformNormal() : vtkLinearTransform, vtkIdentityTransform
  • InternalTransformPoint() : vtkWarpTransform, vtkLinearTransform, vtkIdentityTransform, vtkHomogeneousTransform, vtkGeneralTransform, vtkAbstractTransform
  • InternalTransformVector() : vtkLinearTransform, vtkIdentityTransform
  • InternalUpdate() : vtkThinPlateSplineTransform, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkGridTransform, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkGeneralTransform, vtkAbstractTransform
  • Interp : vtkTkRenderWidget, vtkTkImageWindowWidget, vtkTkImageViewerWidget, vtkTclCommandArgStruct, vtkTclCommand
  • interp : _vtkTclVoidFuncArg
  • Interpolate : vtkTexture, vtkImageActor, vtkImageResample, vtkImageMagnify
  • InterpolateAllocate() : vtkDataSetAttributes
  • InterpolateEdge() : vtkDataSetAttributes
  • InterpolateOff() : vtkTexture, vtkImageActor, vtkImageReslice, vtkImageResample, vtkImageMagnify
  • InterpolateOn() : vtkTexture, vtkImageActor, vtkImageReslice, vtkImageResample, vtkImageMagnify
  • InterpolatePoint() : vtkDataSetAttributes
  • InterpolatePosition() : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • InterpolateStates() : vtkSweptSurface
  • InterpolateTime() : vtkDataSetAttributes
  • InterpolateTuple() : vtkDataSetAttributes
  • Interpolation : vtkProperty
  • InterpolationDerivs() : vtkWedge, vtkVoxel, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPixel, vtkHexahedron
  • InterpolationFunction : vtkGridTransform
  • InterpolationFunctions() : vtkWedge, vtkVoxel, vtkVertex, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPixel, vtkLine, vtkHexahedron
  • InterpolationMode : vtkImageReslice, vtkGridTransform
  • InterpolationType : VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkVolumeProperty
  • IntersectFieldList() : vtkDataSetAttributes::FieldList
  • Intersection() : vtkLine
  • IntersectionList : vtkVoxelContoursToSurfaceFilter
  • IntersectionListLength : vtkVoxelContoursToSurfaceFilter
  • IntersectPolygonWithPolygon() : vtkPolygon
  • IntersectWith() : vtkIdList
  • IntersectWithLine() : vtkPointPicker, vtkPicker, vtkCellPicker, vtkOBBTree, vtkCellLocator, vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPlane, vtkPixel, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • IntersectWithOBBTree() : vtkOBBTree
  • Intervals : vtkSpline
  • InTextureCoord : vtkThresholdTextureCoords
  • INVALID_SOURCE : vtkMultiProcessController
  • InValue : vtkImageThreshold, vtkImageEllipsoidSource
  • Inverse() : vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkWarpTransform, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkIdentityTransform, vtkGeneralTransform, vtkTransformConcatenation, vtkAbstractTransform
  • InverseFlag : vtkWarpTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkTransformConcatenation
  • InverseIterations : vtkWarpTransform
  • InverseTolerance : vtkWarpTransform
  • InverseTransform : vtkTransformPair
  • InverseTransformDerivative() : vtkGridTransform, vtkWarpTransform
  • InverseTransformPoint() : vtkGridTransform, vtkWarpTransform
  • InverseVideo : vtkWindowLevelLookupTable
  • InverseVideoOff() : vtkWindowLevelLookupTable
  • InverseVideoOn() : vtkWindowLevelLookupTable
  • Invert() : vtkMatrix4x4
  • Invert3x3() : vtkMath
  • InvertMatrix() : vtkMath
  • InvokeEvent() : vtkObject
  • InvokeExecuteDataCallbacks() : vtkImageImport
  • InvokeExecuteInformationCallbacks() : vtkImageImport
  • InvokeUpdateInformationCallbacks() : vtkImageImport
  • IS : vtkGenericEnSightReader, vtkEnSightReader, vtkDataReader
  • is_list : PlyProperty
  • IsA() : vtkTIFFReader, vtkObject, vtkSimpleMutexLock, vtkSimpleCriticalSection
  • IsAdaptive() : vtkInitialValueProblemSolver
  • IsARayCastMapper() : vtkAbstractMapper3D
  • IsARenderIntoImageMapper() : vtkAbstractMapper3D
  • IsArrayAnAttribute() : vtkDataSetAttributes
  • IsAtEnd() : vtkImageIterator< DType >
  • IsAttributePresent() : vtkDataSetAttributes::FieldList
  • IsBarrierInProgress : vtkThreadedController
  • IsCellVisible() : vtkStructuredGrid
  • IsConnected : vtkSocketCommunicator
  • IsConsumer() : vtkProp, vtkDataObject, vtkAbstractMapper
  • IsContourValue() : vtkBandedPolyDataContourFilter
  • IsCopied : vtkMaskFields::CopyFieldFlag, vtkFieldData::CopyFieldFlag
  • IsDot : vtkInteractorStyleUnicam
  • IsEdge() : vtkPolyData, vtkEdgeTable
  • IsElementaryOperator() : vtkFunctionParser
  • IsEven() : vtkLargeInteger
  • IsExplicitCell() : vtkExplicitCell, vtkCell
  • IsFileName() : vtkPOPReader
  • IsFilePolyData() : vtkDataReader
  • IsFileRectilinearGrid() : vtkDataReader
  • IsFileStructuredGrid() : vtkDataReader
  • IsFileStructuredPoints() : vtkDataReader
  • IsFileUnstructuredGrid() : vtkDataReader
  • IsFileValid() : vtkDataReader
  • IsHomogeneous() : vtkUnstructuredGrid
  • IsId() : vtkIdList
  • IsIdentity : vtkProp3D
  • IsInPlot() : vtkXYPlotActor
  • IsInsertedPoint() : vtkMergePoints2D, vtkMergePoints, vtkPointLocator2D, vtkPointLocator
  • IsInViewport() : vtkViewport
  • IsItemPresent() : vtkCollection, vtkAssemblyPaths, vtkActor2DCollection
  • IslandValue : vtkImageIslandRemoval2D
  • IsLinear() : vtkNonLinearCell, vtkGenericCell, vtkCell
  • IsOdd() : vtkLargeInteger
  • IsoValue : vtkVolumeRayCastIsosurfaceFunction
  • IsPicking : vtkViewport
  • IsPointUsedByCell() : vtkPolyData
  • IsPointVisible() : vtkStructuredGrid
  • IsScalarResult() : vtkFunctionParser
  • IsSpace() : vtkXMLParser
  • IsSubstringCompletelyEnclosed() : vtkFunctionParser
  • IsTriangle() : vtkPolyData
  • IsType() : vtkCellTypes
  • IsTypeOf() : vtkTIFFReader, vtkObject
  • IsValidSplit() : vtkDecimatePro
  • IsVariableName() : vtkFunctionParser
  • IsVectorResult() : vtkFunctionParser
  • IsZero() : vtkLargeInteger
  • Italic : vtkTextMapper, vtkScalarBarActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • ItalicOff() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • ItalicOn() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • Item : vtkCollectionElement
  • ItemLocation : vtkPriorityQueue
  • Iterate() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • Iteration : vtkImageIterateFilter
  • IterationData : vtkImageIterateFilter
  • IterativeExecuteData() : vtkImageSkeleton2D, vtkImageSeparableConvolution, vtkImageRFFT, vtkImageIterateFilter, vtkImageFourierCenter, vtkImageFFT, vtkImageEuclideanDistance, vtkImageCityBlockDistance
  • Iterator() : vtkFieldData::Iterator
  • IV : vtkTkImageViewerWidget
  • IW : vtkTkImageWindowWidget

- j -
  • Jacobi() : vtkMath
  • JacobianInverse() : vtkWedge, vtkTetra, vtkPyramid, vtkHexahedron
  • JacobiN() : vtkMath
  • JoystickActor : vtkInteractorStyleSwitch
  • JoystickCamera : vtkInteractorStyleSwitch
  • JoystickDollyActor() : vtkInteractorStyleTrackball
  • JoystickOrTrackball : vtkInteractorStyleSwitch
  • JoystickPanActor() : vtkInteractorStyleTrackball
  • JoystickRotateActor() : vtkInteractorStyleTrackball
  • JoystickScaleActor() : vtkInteractorStyleTrackball
  • JoystickSpinActor() : vtkInteractorStyleTrackball
  • JumpTo() : vtkInteractorStyleFlight
  • Justification : vtkTextMapper, vtkCaptionActor2D

- k -
  • K1 : vtkWarpLens
  • K2 : vtkWarpLens
  • KeepHandle : vtkMPICommunicator
  • KeepHandleOff() : vtkMPICommunicator
  • KeepHandleOn() : vtkMPICommunicator
  • Kernel : vtkImageConvolve
  • KernelMiddle : vtkImageSpatialFilter
  • KernelSize : vtkImageSpatialFilter, vtkImageConvolve
  • KeyCode : vtkRenderWindowInteractor
  • KeyLight : vtkLightKit
  • KeyLightAngle : vtkLightKit
  • KeyLightColor : vtkLightKit
  • KeyLightIntensity : vtkLightKit
  • KeyLightWarmth : vtkLightKit
  • KeyPressEvent : vtkCommand
  • KeyPressTag : vtkInteractorStyleUser
  • KeyReleaseEvent : vtkCommand
  • KeyReleaseTag : vtkInteractorStyleUser
  • KeysDown : vtkInteractorStyleFlight
  • KeySym : vtkRenderWindowInteractor, vtkInteractorStyleUser
  • KeyToFillRatio : vtkLightKit
  • KeyToHeadRatio : vtkLightKit
  • Kids : vtkOBBNode
  • Kx : vtkMassProperties
  • Ky : vtkMassProperties
  • Kz : vtkMassProperties

- l -
  • LabelActors : vtkAxisActor2D
  • LabeledComponent : vtkLabeledDataMapper
  • LabelFactor : vtkAxisActor2D
  • LabelFormat : vtkScalarBarActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkCubeAxesActor2D
  • LabelMappers : vtkAxisActor2D
  • LabelMode : vtkLabeledDataMapper
  • Labels : vtkCubeAxesActor2D
  • LabelVisibility : vtkAxisActor2D
  • LabelVisibilityOff() : vtkAxisActor2D
  • LabelVisibilityOn() : vtkAxisActor2D
  • LandmarkTransform : vtkProcrustesAlignmentFilter, vtkIterativeClosestPointTransform
  • Last : vtkHeap
  • LastCellId : vtkInterpolatedVelocityField
  • LastError() : vtkDynamicLoader
  • LastEventId : vtkMPIEventLog
  • LastId : vtkRearrangeFields
  • LastLabelFontSize : vtkAxisActor2D
  • LastNumberOfProcesses : vtkThreadedController
  • LastNumberOfScalarComponents : vtkVideoSource
  • LastOrigin : vtkScaledTextActor
  • LastOutputExtent : vtkVideoSource
  • LastPCoords : vtkInterpolatedVelocityField
  • LastPipelineMTime : vtkImageExport
  • LastPix : vtkInteractorStyleUnicam
  • LastPoint1 : vtkAxisActor2D
  • LastPoint2 : vtkAxisActor2D
  • LastPos : vtkInteractorStyleUnicam, vtkInteractorStyle
  • LastRenderTimeInSeconds : vtkRenderer
  • LastSeed : vtkImageConnector
  • LastSize : vtkWin32TextMapper, vtkScaledTextActor, vtkQuartzTextMapper, vtkAxisActor2D
  • LastTitleFontSize : vtkAxisActor2D
  • LastUpdateExtentWasOutsideOfTheExtent : vtkDataObject
  • LastUpdateTimeInCPUSeconds : vtkEncodedGradientEstimator
  • LastUpdateTimeInSeconds : vtkEncodedGradientEstimator
  • LastWindow : vtkAbstractMapper
  • LatLongTessellation : vtkSphereSource
  • LatLongTessellationOff() : vtkSphereSource
  • LatLongTessellationOn() : vtkSphereSource
  • Layer : vtkRenderer
  • LayerNumber : vtkActor2D
  • Leader : vtkCaptionActor2D
  • LeaderGlyph : vtkCaptionActor2D
  • LeaderGlyphSize : vtkCaptionActor2D
  • LeaderOff() : vtkCaptionActor2D
  • LeaderOn() : vtkCaptionActor2D
  • LeaveEvent : vtkCommand
  • LeaveTag : vtkInteractorStyleUser
  • LeftButtonPressEvent : vtkCommand
  • LeftButtonPressTag : vtkInteractorStyle
  • LeftButtonReleaseEvent : vtkCommand
  • LeftButtonReleaseTag : vtkInteractorStyle
  • LeftConstraint : vtkSpline
  • LeftEye : vtkCamera
  • LeftValue : vtkSpline
  • LegacyCheckWholeExtent() : vtkImageImport
  • LegacyHack : vtkSource
  • Legend : vtkXYPlotActor
  • LegendActor : vtkXYPlotActor
  • LegendEntriesVisible : vtkLegendBoxActor
  • LegendOff() : vtkXYPlotActor
  • LegendOn() : vtkXYPlotActor
  • LegendPosition : vtkXYPlotActor
  • LegendPosition2 : vtkXYPlotActor
  • length : Chunk
  • lengths : Summary
  • lens : Camera
  • Letters : vtkVectorText
  • Level : vtkLODProp3DEntry, vtkImageMapToWindowLevelColors, vtkSpatialRepresentationFilter, vtkSimpleScalarTree, vtkWindowLevelLookupTable, vtkLocator
  • LibExtension() : vtkDynamicLoader
  • LibPrefix() : vtkDynamicLoader
  • Light : vtkRIBLight
  • Lightf_buckets : vtkOpenGLStateCache
  • LightFollowCamera : vtkRenderWindowInteractor, vtkRenderer
  • LightFollowCameraOff() : vtkRenderWindowInteractor, vtkRenderer
  • LightFollowCameraOn() : vtkRenderWindowInteractor, vtkRenderer
  • Lightfv_buckets : vtkOpenGLStateCache
  • Lighti_SPOT_CUTOFF_buckets : vtkOpenGLStateCache
  • LightModelfv_LIGHT_MODEL_AMBIENT_bucket : vtkOpenGLStateCache
  • LightModeli_LIGHT_MODEL_TWO_SIDE_bucket : vtkOpenGLStateCache
  • Lights : vtkVolumeProMapper, vtkRenderer
  • LightType : vtkLight
  • LightTypeIsCameraLight() : vtkLight
  • LightTypeIsHeadlight() : vtkLight
  • LightTypeIsSceneLight() : vtkLight
  • LimitsFileName : vtkSliceCubes, vtkMCubesWriter, vtkMCubesReader
  • Line : vtkWedge, vtkVoxel, vtkUnstructuredGrid, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkStructuredGrid, vtkRectilinearGrid, vtkQuad, vtkPyramid, vtkPolyLine, vtkPolygon, vtkPolyData, vtkPixel, vtkImageData, vtkHexahedron
  • LinearSolve3x3() : vtkMath
  • LineIntersectsNode() : vtkOBBTree
  • LineList : vtkVoxelContoursToSurfaceFilter
  • LineListLength : vtkVoxelContoursToSurfaceFilter
  • LineListSize : vtkVoxelContoursToSurfaceFilter
  • LineOffset : vtkTextMapper
  • Lines : vtkPolyData
  • LinesArray : vtkDataObjectToDataSetFilter
  • LinesArrayComponent : vtkDataObjectToDataSetFilter
  • LinesComponentRange : vtkDataObjectToDataSetFilter
  • LineSize : vtkTextMapper
  • LineSmoothing : vtkRenderWindow
  • LineSmoothingOff() : vtkRenderWindow
  • LineSmoothingOn() : vtkRenderWindow
  • LinesOn : vtkXYPlotActor
  • LineSpacing : vtkTextMapper
  • LineStipple_FACTOR_bucket : vtkOpenGLStateCache
  • LineStipple_PATTERN_bucket : vtkOpenGLStateCache
  • LineStipplePattern : vtkProperty, vtkProperty2D
  • LineStippleRepeatFactor : vtkProperty, vtkProperty2D
  • LineValue : vtkImageGridSource
  • LineWidth : vtkProperty, vtkProperty2D
  • LineWidth_bucket : vtkOpenGLStateCache
  • LinkEdgels() : vtkLinkEdgels
  • Links : vtkUnstructuredGrid, vtkPolyData
  • LinkThreshold : vtkLinkEdgels
  • List : vtkFieldData::BasicIterator
  • ListId : vtkOpenGLPolyDataMapper, vtkMesaPolyDataMapper
  • ListSize : vtkFieldData::BasicIterator
  • Load() : vtkTexture, vtkOpenGLTexture, vtkOpenGLImageActor, vtkMesaTexture, vtkMesaImageActor, vtkImageActor
  • LoadedDataSize : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • LoadTime : vtkOpenGLTexture, vtkOpenGLImageActor, vtkMesaTexture, vtkMesaImageActor
  • LoadValue : vtkPointLoad
  • LocalDisplayToDisplay() : vtkViewport
  • Locality : vtkDataObject
  • LocalProcessId : vtkMultiProcessController
  • LocalRotation : vtkDEMReader
  • LocalThreadId : vtkSharedMemoryCommunicator
  • Location : vtkMaskFields::CopyFieldFlag
  • LocationArray : vtkCellTypes
  • Locations : vtkUnstructuredGrid
  • Locator : vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkUGFacetReader, vtkSTLReader, vtkMCubesReader, vtkIterativeClosestPointTransform, vtkGeometryFilter, vtkFeatureEdges, vtkExtractUnstructuredGrid, vtkExtractEdges, vtkEdgePoints, vtkDelaunay3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkPointSet
  • LocatorDimX : vtkImageMarchingCubes
  • LocatorDimY : vtkImageMarchingCubes
  • LocatorMaxLevel : vtkImplicitModeller
  • LocatorMinX : vtkImageMarchingCubes
  • LocatorMinY : vtkImageMarchingCubes
  • LocatorPointIds : vtkImageMarchingCubes
  • Lock : vtkMutexLock, vtkSimpleMutexLock, vtkCriticalSection, vtkSimpleCriticalSection, vtkCompositeManager
  • LockBorder : vtkLegendBoxActor
  • LockBorderOff() : vtkLegendBoxActor
  • LockBorderOn() : vtkLegendBoxActor
  • LODMappers : vtkLODActor
  • LODs : vtkLODProp3D
  • LogScaling : vtkHyperStreamline
  • LogScalingOff() : vtkHyperStreamline
  • LogScalingOn() : vtkHyperStreamline
  • Logx : vtkXYPlotActor
  • LogxOff() : vtkXYPlotActor
  • LogxOn() : vtkXYPlotActor
  • LookupIndexExecuteTime : vtkImageQuantizeRGBToIndex
  • LookupTable : vtkWin32ImageMapper, vtkVolumeProMapper, vtkTexture, vtkScalarBarActor, vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkImageQuantizeRGBToIndex, vtkImageMapToColors, vtkImageToPolyDataFilter, vtkDataArray
  • LookupTableName : vtkDataWriter, vtkDataReader
  • Loop : vtkSelectPolyData, vtkImplicitSelectionLoop
  • Lower() : vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • LowerCase() : vtkDataReader
  • LowerThreshold : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • LowMapper : vtkLODActor
  • LowPoint : vtkElevationFilter
  • LUFactor3x3() : vtkMath
  • LUFactorLinearSystem() : vtkMath
  • LUSolve3x3() : vtkMath
  • LUSolveLinearSystem() : vtkMath

- m -
  • Magnification : vtkWindowToImageFilter, vtkRenderLargeImage
  • MagnificationFactors : vtkImageResample, vtkImageMagnify
  • MagnifyBuffer() : vtkCompositeManager
  • MaintainLuminance : vtkLightKit
  • MaintainLuminanceOff() : vtkLightKit
  • MaintainLuminanceOn() : vtkLightKit
  • MajorBoardVersion : vtkVolumeProMapper
  • MajorDirection : vtkVolumeTextureMapper2D
  • MakeCamera() : vtkRenderer, vtkMesaRenderer
  • MakeColorMap() : vtkXImageWindow
  • MakeCurrent() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkOpenGLImageWindow, vtkMesaRenderWindow, vtkMesaImageWindow, vtkImageWindow, vtkWindow
  • MakeDataSuitable() : vtkOpenGLImageActor, vtkMesaImageActor
  • MakeDefaultWindow() : vtkXImageWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow
  • MakeFileName() : vtkPOPReader
  • MakeLight() : vtkRenderer, vtkMesaRenderer
  • MakeObject() : vtkTIFFReader, vtkSLCReader, vtkPNMReader, vtkPNGReader, vtkJPEGReader, vtkImageReader2, vtkGESignaReader, vtkBMPReader, vtkImageStencilData, vtkPiecewiseFunction, vtkWedge, vtkVoxel, vtkVoidArray, vtkVertex, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkStructuredPoints, vtkStructuredGrid, vtkShortArray, vtkRungeKutta45, vtkRungeKutta4, vtkRungeKutta2, vtkRectilinearGrid, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPolyData, vtkPoints, vtkPixel, vtkLongArray, vtkLine, vtkIntArray, vtkInitialValueProblemSolver, vtkImageData, vtkIdTypeArray, vtkHexahedron, vtkGenericCell, vtkFloatArray, vtkFieldData, vtkEmptyCell, vtkDoubleArray, vtkDataObject, vtkDataArray, vtkCharArray, vtkCell, vtkBitArray
  • MakePieceScalars() : vtkPieceScalars
  • MakeProperty() : vtkMesaActor, vtkActor
  • MakeRandomScalars() : vtkPieceScalars
  • MakeRenderWindowInteractor() : vtkRenderWindow
  • MakeTransform() : vtkThinPlateSplineTransform, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkGridTransform, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkIdentityTransform, vtkGeneralTransform, vtkAbstractTransform
  • ManifoldEdges : vtkFeatureEdges
  • ManifoldEdgesOff() : vtkFeatureEdges
  • ManifoldEdgesOn() : vtkFeatureEdges
  • Manual : vtkCompositeManager
  • ManualHeaderSize : vtkImageReader2
  • ManualOff() : vtkCompositeManager
  • ManualOn() : vtkCompositeManager
  • MapColorScalarsThroughLookupTable : vtkTexture
  • MapColorScalarsThroughLookupTableOff() : vtkTexture
  • MapColorScalarsThroughLookupTableOn() : vtkTexture
  • MapFunction() : vtkPLOT3DReader
  • MapLabel : vtkDEMReader
  • Mapped : vtkWindow
  • MappedOff() : vtkWindow
  • MappedOn() : vtkWindow
  • MappedScalars : vtkTexture
  • Mapper : vtkVolume, vtkPicker, vtkActor, vtkActor2D
  • MapperBounds : vtkActor
  • MapperPosition : vtkPicker
  • MapScalars() : vtkPolyDataMapper2D, vtkMapper, vtkScalarsToColors
  • MapScalarsThroughTable() : vtkScalarsToColors
  • MapScalarsThroughTable2() : vtkColorTransferFunction, vtkScalarsToColors, vtkLookupTable
  • MapScalarsToColors() : vtkTexture
  • MapValue() : vtkColorTransferFunction, vtkScalarsToColors, vtkLookupTable
  • March() : vtkImageMarchingCubes
  • MarkData() : vtkImageConnector
  • MarkEvent() : vtkTimerLog
  • MarkHorizontal() : vtkSpherePuzzle
  • MarkParents() : vtkCellLocator
  • MarkPicked() : vtkPicker
  • MarkPoints() : vtkOBBDicer
  • MarkVertical() : vtkSpherePuzzle
  • MarshalDataLength : vtkCommunicator
  • MarshalString : vtkCommunicator
  • MarshalStringLength : vtkCommunicator
  • MaskAlpha : vtkImageMask
  • MaskedOutputValue : vtkImageMask
  • MaskedOutputValueLength : vtkImageMask
  • MaskPoints : vtkLODActor
  • Masks : vtkImageMaskBits
  • MatchFileName : vtkEnSightReader
  • Material : vtkCutMaterial
  • MaterialArrayName : vtkCutMaterial
  • Materialfv_buckets : vtkOpenGLStateCache
  • MaterialList : vtk3DSImporter
  • MatPropList : vtk3DSImporter
  • Matrix : vtkProp3D, vtkHomogeneousTransform
  • Matrix3x3ToQuaternion() : vtkMath
  • MatrixMode_bucket : vtkOpenGLStateCache
  • MatrixMTime : vtkProp3D
  • MatrixUpdateMTime : vtkTransform
  • MatrixW : vtkThinPlateSplineTransform
  • Max : vtkImageAccumulate
  • MAX : vtkDataSetAttributes
  • MAX_PROCESSES : vtkMultiProcessController
  • MaxBlankingValue : vtkBlankStructuredGrid
  • MaxEntries : vtkTimerLog
  • MaxId : vtkTriArray, vtkVertexArray, vtkStreamArray, vtkProTriArray, vtkProVertexArray, vtkPriorityQueue, vtkDataArray, vtkCellTypes, vtkCellLinks
  • MaximizeMethod : vtkVolumeRayCastMIPFunction
  • MaximizeOpacity : VTKVRCStaticInfo
  • Maximum : vtkRTAnalyticSource, vtkImageShrink3D, vtkImageRGBToHSV, vtkImageNoiseSource, vtkImageHSVToRGB, vtkImageGaussianSource
  • MaximumCollapsedEdges : vtkQuadricDecimation
  • MaximumColor : vtkWindowLevelLookupTable
  • MaximumCost : vtkQuadricDecimation
  • MaximumCoverage : vtkFrustumCoverageCuller
  • MaximumDistance : vtkVoxelModeller, vtkShepardMethod, vtkImageEuclideanDistance, vtkImplicitModeller
  • MaximumError : vtkDecimate, vtkDecimatePro
  • MaximumFeatureAngle : vtkDecimate
  • MaximumImageSampleDistance : vtkVolumeRayCastMapper
  • MaximumIterations : vtkDecimate
  • MaximumLeaderGlyphSize : vtkCaptionActor2D
  • MaximumLength : vtkStripper
  • MaximumLineHeight : vtkScaledTextActor
  • MaximumMeanDistance : vtkIterativeClosestPointTransform
  • MaximumNumberOfArrays : vtkPOPReader
  • MaximumNumberOfColors : vtkScalarBarActor
  • MaximumNumberOfInterpolationSteps : vtkSweptSurface
  • MaximumNumberOfIterations : vtkImageMandelbrotSource, vtkIterativeClosestPointTransform
  • MaximumNumberOfLandmarks : vtkIterativeClosestPointTransform
  • MaximumNumberOfPieces : vtkDataObject
  • MaximumNumberOfPlanes : vtkVolumeTextureMapper2D
  • MaximumNumberOfPoints : vtkMaskPoints
  • MaximumNumberOfProcesses : vtkMultiProcessController
  • MaximumNumberOfProcessIds : vtkMPIGroup
  • MaximumNumberOfSquawks : vtkDecimate
  • MaximumOff() : vtkImageShrink3D
  • MaximumOn() : vtkImageShrink3D
  • MaximumPoint : vtkCutMaterial
  • MaximumPropagationDistance : vtkHyperStreamline
  • MaximumPropagationTime : vtkStreamer
  • MaximumSpeed : vtkBrownianPoints
  • MaximumStorageSize : vtkVolumeTextureMapper2D
  • MaximumSubIterations : vtkDecimate
  • MaximumTableValue : vtkWindowLevelLookupTable
  • MaximumTimeValue : vtkGenericEnSightReader, vtkEnSightReader
  • MaxLevel : vtkSimpleScalarTree, vtkLocator
  • MaxNumberOfIterations : vtkGraphLayoutFilter
  • MaxNumberOfTransforms : vtkTransformConcatenation
  • MaxRenderTime : vtkCompositeManager
  • MaxScaleFactor : vtkTensorGlyph
  • Mean : vtkImageShrink3D, vtkImageAccumulate
  • MeanDistance : vtkIterativeClosestPointTransform
  • MeanDistanceMode : vtkIterativeClosestPointTransform
  • MeanOff() : vtkImageShrink3D
  • MeanOn() : vtkImageShrink3D
  • MeasuredFileName : vtkEnSightReader
  • MeasuredFileSet : vtkEnSightReader
  • MeasuredNodeIds : vtkEnSightReader
  • MeasuredTimeSet : vtkEnSightReader
  • MeasuredTimeValue : vtkEnSightReader
  • Median : vtkImageShrink3D
  • MedianOff() : vtkImageShrink3D
  • MedianOn() : vtkImageShrink3D
  • MediumMapper : vtkLODActor
  • MemoryBuffer : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • MemoryData : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • MemoryDataHeader : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • MemoryHdc : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • MemoryLimit : vtkPImageWriter, vtkMemoryLimitImageDataStreamer, vtkDicer
  • MemoryLimitInBytes : vtkVoxelContoursToSurfaceFilter
  • Merge() : vtkMergeFields
  • MergeArray() : vtkMergeFields
  • MergeTolerance : vtkClipVolume
  • Merging : vtkUGFacetReader, vtkSTLReader, vtkGeometryFilter, vtkExtractUnstructuredGrid
  • MergingOff() : vtkUGFacetReader, vtkSTLReader, vtkGeometryFilter, vtkExtractUnstructuredGrid
  • MergingOn() : vtkUGFacetReader, vtkSTLReader, vtkGeometryFilter, vtkExtractUnstructuredGrid
  • Mesh : vtkQuadricDecimation
  • MeshList : vtk3DSImporter
  • MessageListEnd : vtkSharedMemoryCommunicator
  • MessageListLock : vtkSharedMemoryCommunicator
  • MessageListStart : vtkSharedMemoryCommunicator
  • MessageProc() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow
  • MFChandledWindow : vtkWin32OpenGLRenderWindow
  • mid : vtkJavaCommand, vtkJavaVoidFuncArg
  • MiddleButtonPressEvent : vtkCommand
  • MiddleButtonPressTag : vtkInteractorStyle
  • MiddleButtonReleaseEvent : vtkCommand
  • MiddleButtonReleaseTag : vtkInteractorStyle
  • MILAppID : vtkMILVideoSource
  • MILAppInternallyAllocated : vtkMILVideoSource
  • MILBufID : vtkMILVideoSource
  • MILDigID : vtkMILVideoSource
  • MILDigitizerDCF : vtkMILVideoSource
  • MILDigitizerNumber : vtkMILVideoSource
  • MILErrorMessages : vtkMILVideoSource
  • MILErrorMessagesOff() : vtkMILVideoSource
  • MILErrorMessagesOn() : vtkMILVideoSource
  • MILInterpreterDLL : vtkMILVideoSource
  • MILInterpreterForSystem() : vtkMILVideoSource
  • MILSysID : vtkMILVideoSource
  • MILSysInternallyAllocated : vtkMILVideoSource
  • MILSystemNumber : vtkMILVideoSource
  • MILSystemType : vtkMILVideoSource
  • Min : vtkImageAccumulate
  • MinBlankingValue : vtkBlankStructuredGrid
  • Minimum : vtkImageShrink3D, vtkImageNoiseSource
  • MinimumColor : vtkWindowLevelLookupTable
  • MinimumCoverage : vtkFrustumCoverageCuller
  • MinimumImageSampleDistance : vtkVolumeRayCastMapper
  • MinimumOff() : vtkImageShrink3D
  • MinimumOn() : vtkImageShrink3D
  • MinimumPieceSize : vtkGridSynchronizedTemplates3D
  • MinimumSize : vtkScaledTextActor
  • MinimumSpeed : vtkBrownianPoints
  • MinimumTableValue : vtkWindowLevelLookupTable
  • MinimumTimeValue : vtkGenericEnSightReader, vtkEnSightReader
  • MinimumViewDistance : vtkVolumeRayCastMapper
  • MinorBoardVersion : vtkVolumeProMapper
  • MIPFunction : VTKVRCStaticInfo
  • Mirror : vtkImageReslice
  • MirrorOff() : vtkImageReslice
  • MirrorOn() : vtkImageReslice
  • Mode : vtkLandmarkTransform
  • ModelBounds : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller, vtkCursor3D
  • Modes : vtkExtentTranslator
  • Modified() : vtkLODActor, vtkLightKit, vtkImageOpenClose3D, vtkTimeStamp, vtkObject
  • ModifiedEvent : vtkCommand
  • ModifyArrayName() : vtkRIBExporter
  • ModifyOutputUpdateExtent() : vtkImageBlockReader
  • Momentum : vtkPLOT3DReader
  • MotionAccelerationFactor : vtkInteractorStyleFlight
  • MotionAlongVector() : vtkInteractorStyleFlight
  • MotionFactor : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage
  • MotionStepSize : vtkInteractorStyleFlight
  • MotionUserScale : vtkInteractorStyleFlight
  • MotionVector : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • MouseInWindow : vtkWin32RenderWindowInteractor
  • MouseMoveEvent : vtkCommand
  • MouseMoveTag : vtkInteractorStyleUser
  • MOVE : vtkRearrangeFields
  • Move() : vtkSubPixelPositionEdgels
  • MoveHorizontal() : vtkSpherePuzzle
  • MovePoint() : vtkSpherePuzzle
  • MovePoints() : vtkPiecewiseFunction
  • MoveVertical() : vtkSpherePuzzle
  • MTime : vtkObject
  • mtl : Mesh
  • MultipleData : vtkMultiProcessController, vtkMultiThreader
  • MultipleMethod : vtkMultiProcessController, vtkMultiThreader
  • MultipleMethodExecute() : vtkThreadedController, vtkSocketController, vtkMultiProcessController, vtkMPIController, vtkMultiThreader
  • MultipleMethodFlag : vtkThreadedController
  • Multiply3x3() : vtkMath
  • Multiply4x4() : vtkMatrix4x4
  • MultiplyDoublePoint() : vtkMatrix4x4
  • MultiplyFloatPoint() : vtkMatrix4x4
  • MultiplyPoint() : vtkTransform, vtkMatrix4x4
  • MultiSamples : vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • MultiThread() : vtkImageToImageFilter
  • MultiThreader : vtkThreadedController
  • MutexLock : vtkSimpleMutexLock
  • my_alloc() : vtkPLY
  • MyNSTimer : vtkQuartzWindow
  • MyRotateCamera() : vtkInteractorStyleUnicam
  • MyTranslateCamera() : vtkInteractorStyleUnicam
  • myvtkQuartzGLView : vtkQuartzWindow
  • myVTKRenderWindow : vtkQuartzWindow, vtkQuartzGLView
  • myVTKRenderWindowInteractor : vtkQuartzWindow, vtkQuartzGLView

- n -
  • n : _vtkLocalTri, _vtkProLocalTri
  • NAME : vtkSplitField, vtkRearrangeFields, vtkMergeFields, vtkAssignAttribute
  • name : PlyOtherProp, PlyElement, PlyProperty
  • Name : vtkMaskFields::CopyFieldFlag, vtkDataArray
  • ncells : _vtkLink_s
  • NearClip : VTKRayCastRayInfo
  • NeedGradients : vtkImageMarchingCubes
  • NeighborhoodSize : vtkSurfaceReconstructionFilter
  • Neighbors : vtkDecimate, vtkDecimatePro
  • nelems : PlyFile
  • NeverRendered : vtkRenderWindow
  • New() : vtkXTextMapper, vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXPolyDataMapper2D, vtkXOpenGLTextMapper, vtkXOpenGLRenderWindow, vtkXMesaTextMapper, vtkXMesaRenderWindow, vtkXImageWindow, vtkXImageMapper, vtkWorldPointPicker, vtkWindowToImageFilter, vtkWinCEOpenGLRenderWindow, vtkWin32TextMapper, vtkWin32RenderWindowInteractor, vtkWin32PolyDataMapper2D, vtkWin32OpenGLTextMapper, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkWin32ImageMapper, vtkVRMLExporter, vtkVolumeTextureMapper2D, vtkVolumeRayCastMIPFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastCompositeFunction, vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkVolumeProperty, vtkVolumeProMapper, vtkVolumeCollection, vtkVolume, vtkTexture, vtkTextMapper, vtkSelectVisiblePoints, vtkScaledTextActor, vtkScalarBarActor, vtkRenderWindowInteractor, vtkRenderWindowCollection, vtkRenderWindow, vtkRendererSource, vtkRendererCollection, vtkRenderer, vtkRecursiveSphereDirectionEncoder, vtkRayCaster, vtkQuartzTextMapper, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkQuartzImageMapper, vtkPropPicker, vtkProperty, vtkProp3DCollection, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkPointPicker, vtkPicker, vtkParallelCoordinatesActor, vtkOpenGLVolumeTextureMapper2D, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLTexture, vtkOpenGLRenderer, vtkOpenGLProperty, vtkOpenGLPolyDataMapper2D, vtkOpenGLPolyDataMapper, vtkOpenGLLight, vtkOpenGLImageWindow, vtkOpenGLImager, vtkOpenGLImageMapper, vtkOpenGLImageActor, vtkOpenGLCamera, vtkOpenGLActor, vtkOOGLExporter, vtkOBJExporter, vtkMesaVolumeTextureMapper2D, vtkMesaVolumeRayCastMapper, vtkMesaTexture, vtkMesaRenderer, vtkMesaProperty, vtkMesaPolyDataMapper2D, vtkMesaPolyDataMapper, vtkMesaLight, vtkMesaImageWindow, vtkMesaImager, vtkMesaImageMapper, vtkMesaImageActor, vtkMesaCamera, vtkMesaActor, vtkMapperCollection, vtkLODProp3D, vtkLODActor, vtkLightKit, vtkLightCollection, vtkLight, vtkLabeledDataMapper, vtkIVExporter, vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleSwitch, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle, vtkImagingFactory, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkImagerCollection, vtkImager, vtkImageMapper, vtkImageActor, vtkGraphicsFactory, vtkFrustumCoverageCuller, vtkFollower, vtkFiniteDifferenceGradientEstimator, vtkEncodedGradientShader, vtkDataSetMapper, vtkCullerCollection, vtkCellPicker, vtkCamera, vtkAxisActor2D, vtkAssembly, vtkActorCollection, vtkActor, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSweptSurface, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkKitwareObjectFactory, vtkKitwareContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkDecimate, vtkTreeComposite, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkThreadSafeLog, vtkThreadedController, vtkSocketController, vtkSocketCommunicator, vtkSharedMemoryCommunicator, vtkRTAnalyticSource, vtkRectilinearGridOutlineFilter, vtkPVGeometryFilter, vtkPSphereSource, vtkPPolyDataNormals, vtkPOPReader, vtkPLinearExtrusionFilter, vtkPipelineSize, vtkPImageWriter, vtkPieceScalars, vtkPDataSetWriter, vtkPDataSetReader, vtkPCellDataToPointData, vtkParallelFactory, vtkOutputPort, vtkMultiProcessLog, vtkMultiProcessController, vtkMPIGroup, vtkMPIEventLog, vtkMPIController, vtkMPICommunicator, vtkMemoryLimitImageDataStreamer, vtkInputPort, vtkImageBlockWriter, vtkImageBlockReader, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkCutMaterial, vtkBranchExtentTranslator, vtkXMLParser, vtkVolume16Reader, vtkUnstructuredGridWriter, vtkUnstructuredGridReader, vtkUGFacetReader, vtkTIFFWriter, vtkTIFFReader, vtkStructuredPointsWriter, vtkStructuredPointsReader, vtkStructuredGridWriter, vtkStructuredGridReader, vtkSTLWriter, vtkSTLReader, vtkSLCReader, vtkRectilinearGridWriter, vtkRectilinearGridReader, vtkPostScriptWriter, vtkPolyDataWriter, vtkPolyDataReader, vtkPNMWriter, vtkPNMReader, vtkPNGWriter, vtkPNGReader, vtkPLYWriter, vtkPLYReader, vtkPLOT3DReader, vtkParticleReader, vtkOBJReader, vtkMedicalImageReader2, vtkMCubesWriter, vtkMCubesReader, vtkJPEGWriter, vtkJPEGReader, vtkIVWriter, vtkImageWriter, vtkImageReader2Factory, vtkImageReader2Collection, vtkImageReader2, vtkImageReader, vtkGESignaReader, vtkGenericEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader, vtkDEMReader, vtkDataWriter, vtkDataSetWriter, vtkDataSetReader, vtkDataReader, vtkDataObjectWriter, vtkDataObjectReader, vtkCGMWriter, vtkBYUWriter, vtkBYUReader, vtkBMPWriter, vtkBMPReader, vtkVoxelModeller, vtkTriangularTexture, vtkSurfaceReconstructionFilter, vtkSimpleImageFilterExample, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkImplicitFunctionToImageStencil, vtkImageWrapPad, vtkImageVariance3D, vtkImageTranslateExtent, vtkImageToImageStencil, vtkImageThreshold, vtkImageStencilSource, vtkImageStencilData, vtkImageStencil, vtkImageSpatialFilter, vtkImageSobel3D, vtkImageSobel2D, vtkImageSkeleton2D, vtkImageSinusoidSource, vtkImageShrink3D, vtkImageShiftScale, vtkImageSeparableConvolution, vtkImageSeedConnectivity, vtkImageRGBToHSV, vtkImageRFFT, vtkImageReslice, vtkImageResample, vtkImageRange3D, vtkImageQuantizeRGBToIndex, vtkImagePermute, vtkImagePadFilter, vtkImageOpenClose3D, vtkImageNormalize, vtkImageNonMaximumSuppression, vtkImageNoiseSource, vtkImageMirrorPad, vtkImageMedian3D, vtkImageMathematics, vtkImageMaskBits, vtkImageMask, vtkImageMapToWindowLevelColors, vtkImageMapToRGBA, vtkImageMapToColors, vtkImageMandelbrotSource, vtkImageMagnitude, vtkImageMagnify, vtkImageLuminance, vtkImageLogic, vtkImageLogarithmicScale, vtkImageLaplacian, vtkImageIslandRemoval2D, vtkImageImport, vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageHybridMedian2D, vtkImageHSVToRGB, vtkImageGridSource, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSource, vtkImageGaussianSmooth, vtkImageFourierCenter, vtkImageFlip, vtkImageFFT, vtkImageExtractComponents, vtkImageExport, vtkImageEuclideanToPolar, vtkImageEuclideanDistance, vtkImageEllipsoidSource, vtkImageDotProduct, vtkImageDivergence, vtkImageDilateErode3D, vtkImageDifference, vtkImageDataStreamer, vtkImageCursor3D, vtkImageCorrelation, vtkImageConvolve, vtkImageContinuousErode3D, vtkImageContinuousDilate3D, vtkImageConstantPad, vtkImageConnector, vtkImageConnectorSeed, vtkImageClip, vtkImageCityBlockDistance, vtkImageCheckerboard, vtkImageChangeInformation, vtkImageCast, vtkImageCanvasSource2D, vtkImageCanvasSource2DPixel, vtkImageCacheFilter, vtkImageButterworthLowPass, vtkImageButterworthHighPass, vtkImageBlend, vtkImageAppendComponents, vtkImageAppend, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkImageAccumulate, vtkGaussianSplatter, vtkExtractVOI, vtkBooleanTexture, vtkXYPlotActor, vtkWin32VideoSource, vtkWeightedTransformFilter, vtkVRMLImporter, vtkVideoSource, vtkVectorText, vtkTransformToGrid, vtkThinPlateSplineTransform, vtkRIBProperty, vtkRIBLight, vtkRIBExporter, vtkRenderLargeImage, vtkProcrustesAlignmentFilter, vtkPolyDataToImageStencil, vtkPCAAnalysisFilter, vtkMILVideoSource, vtkLegendBoxActor, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkImplicitModeller, vtkImageToPolyDataFilter, vtkGridTransform, vtkGLUTesselatorTriangleFilter, vtkEarthSource, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkArcPlotter, vtk3DSImporter, vtkWindowedSincPolyDataFilter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkWarpLens, vtkVoxelContoursToSurfaceFilter, vtkVectorNorm, vtkVectorDot, vtkTubeFilter, vtkTriangularTCoords, vtkTriangleFilter, vtkTransformTextureCoords, vtkTransformPolyDataFilter, vtkTransformFilter, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold, vtkTextureMapToSphere, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkTexturedSphereSource, vtkTextSource, vtkTensorGlyph, vtkSuperquadricSource, vtkSubPixelPositionEdgels, vtkSubdivideTetra, vtkStructuredPointsGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredGridGeometryFilter, vtkStripper, vtkStreamPoints, vtkStreamLine, vtkStreamer, vtkSplitField, vtkSphereSource, vtkSpherePuzzleArrows, vtkSpherePuzzle, vtkSpatialRepresentationFilter, vtkSmoothPolyDataFilter, vtkSimpleElevationFilter, vtkShrinkPolyData, vtkShrinkFilter, vtkSelectPolyData, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkReverseSense, vtkReflectionFilter, vtkRecursiveDividingCubes, vtkRectilinearGridGeometryFilter, vtkRearrangeFields, vtkQuantizePolyDataPoints, vtkQuadricDecimation, vtkQuadricClustering, vtkProjectedTexture, vtkProgrammableSource, vtkProgrammableGlyphFilter, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter, vtkProbeFilter, vtkPolyDataStreamer, vtkPolyDataNormals, vtkPolyDataConnectivityFilter, vtkPointSource, vtkPointDataToCellData, vtkPlaneSource, vtkOutlineSource, vtkOutlineFilter, vtkOutlineCornerSource, vtkOutlineCornerFilter, vtkOBBTree, vtkOBBDicer, vtkMergeFilter, vtkMergeFields, vtkMergeDataObjectFilter, vtkMassProperties, vtkMaskPolyData, vtkMaskPoints, vtkMaskFields, vtkLoopSubdivisionFilter, vtkLinkEdgels, vtkLineSource, vtkLinearSubdivisionFilter, vtkLinearExtrusionFilter, vtkInterpolateDataSetAttributes, vtkImplicitTextureCoords, vtkImageDataGeometryFilter, vtkIdFilter, vtkHyperStreamline, vtkHull, vtkHedgeHog, vtkGraphLayoutFilter, vtkGlyphSource2D, vtkGlyph3D, vtkGlyph2D, vtkGeometryFilter, vtkFieldDataToAttributeDataFilter, vtkFeatureEdges, vtkExtractVectorComponents, vtkExtractUnstructuredGrid, vtkExtractTensorComponents, vtkExtractPolyDataGeometry, vtkExtractGrid, vtkExtractGeometry, vtkExtractEdges, vtkElevationFilter, vtkEdgePoints, vtkDiskSource, vtkDelaunay3D, vtkDelaunay2D, vtkDecimatePro, vtkDataSetTriangleFilter, vtkDataSetToDataObjectFilter, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkDashedStreamLine, vtkCylinderSource, vtkCutter, vtkCursor3D, vtkCubeSource, vtkContourGrid, vtkContourFilter, vtkConnectivityFilter, vtkConeSource, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkCellDerivatives, vtkCellDataToPointData, vtkCellCenters, vtkButtonSource, vtkButterflySubdivisionFilter, vtkBrownianPoints, vtkBlankStructuredGridWithImage, vtkBlankStructuredGrid, vtkBandedPolyDataContourFilter, vtkAxes, vtkAttributeDataToFieldDataFilter, vtkAssignAttribute, vtkArrowSource, vtkArrayCalculator, vtkAppendPolyData, vtkAppendFilter, vtkUnstructuredGridSource, vtkSuperquadric, vtkStructuredPointsSource, vtkStructuredPointsCollection, vtkStructuredGridSource, vtkSphere, vtkSimpleScalarTree, vtkRectilinearGridSource, vtkPolyDataSource, vtkPolyDataCollection, vtkPointSetSource, vtkPiecewiseFunctionSource, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunction, vtkPerlinNoise, vtkMergePoints2D, vtkMergePoints, vtkKochanekSpline, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkImageTwoInputFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageSource, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkImageInPlaceFilter, vtkDataSetSource, vtkDataObjectSource, vtkCylinder, vtkCone, vtkColorTransferFunction, vtkCellLocator, vtkCastToConcrete, vtkCardinalSpline, vtkXMLFileOutputWindow, vtkWindowLevelLookupTable, vtkWin32OutputWindow, vtkWedge, vtkVoxel, vtkVoidArray, vtkVertex, vtkVersion, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTriangleStrip, vtkTriangle, vtkTransformCollection, vtkTransform, vtkTimeStamp, vtkTimerLog, vtkTetra, vtkTensor, vtkTclCommand, vtkStructuredPoints, vtkStructuredGrid, vtkStructuredData, vtkShortArray, vtkRungeKutta45, vtkRungeKutta4, vtkRungeKutta2, vtkReferenceCount, vtkRectilinearGrid, vtkQuadric, vtkQuadraticEdge, vtkQuad, vtkPythonCommand, vtkPyramid, vtkProperty2D, vtkPropCollection, vtkPropAssembly, vtkProp, vtkProcessStatistics, vtkProcessObject, vtkPriorityQueue, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPolyData, vtkPoints, vtkPointLocator2D, vtkPointLocator, vtkPointData, vtkPlanes, vtkPlaneCollection, vtkPlane, vtkPixel, vtkPerspectiveTransform, vtkOverrideInformationCollection, vtkOverrideInformation, vtkOutputWindow, vtkOrderedTriangulator, vtkOldStyleCallbackCommand, vtkObjectFactoryCollection, vtkObject, vtkMutexLock, vtkSimpleMutexLock, vtkMultiThreader, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrix4x4, vtkMath, vtkMapper2D, vtkLookupTable, vtkLongArray, vtkLogLookupTable, vtkLine, vtkJavaCommand, vtkInterpolatedVelocityField, vtkIntArray, vtkInstantiator, vtkIndent, vtkImplicitFunctionCollection, vtkImageData, vtkIdTypeArray, vtkIdList, vtkIdentityTransform, vtkHexahedron, vtkHeap, vtkGenericCell, vtkGeneralTransform, vtkFunctionParser, vtkFloatArray, vtkFileOutputWindow, vtkFieldData, vtkExtentTranslator, vtkEmptyCell, vtkEdgeTable, vtkDynamicLoader, vtkDoubleArray, vtkDirectory, vtkDebugLeaks, vtkDataSetCollection, vtkDataSetAttributes, vtkDataObjectCollection, vtkDataObject, vtkCriticalSection, vtkSimpleCriticalSection, vtkCoordinate, vtkContourValues, vtkCollection, vtkCharArray, vtkCellTypes, vtkCellLinks, vtkCellData, vtkCellArray, vtkCallbackCommand, vtkByteSwap, vtkBitArray, vtkAssemblyPaths, vtkAssemblyPath, vtkAssemblyNode, vtkActor2DCollection, vtkActor2D, vtkTransformConcatenationStack, vtkTransformConcatenation
  • NEW_DATA_TIME_TAG : vtkInputPort
  • NewCommand : vtkTclCommandStruct
  • NewMessage() : vtkSharedMemoryCommunicator
  • NewPickPoint : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • newRefs : _vtkLocalVertex
  • NewSeed() : vtkImageConnector
  • Next : vtkFieldData::Iterator, vtkImageConnectorSeed, vtkImageCanvasSource2DPixel, vtkSplitField::Component, vtkRearrangeFields::Operation, vtkMergeFields::Component, vtkHeapNode, vtkCollectionElement
  • NextDataEvent : vtkCommand
  • NextDerivs : vtkRungeKutta45, vtkRungeKutta4
  • NextEntry : vtkTimerLog
  • NextIndex() : vtkFieldData::BasicIterator
  • NextLine() : vtkTextMapper
  • NextSpan() : vtkImageProgressIterator< DType >, vtkImageIterator< DType >
  • NextWindowId : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzImageWindow
  • NoBlockReceive() : vtkMPIController, vtkMPICommunicator
  • NoBlockSend() : vtkMPIController, vtkMPICommunicator
  • NodeIdsListed : vtkEnSightGoldBinaryReader
  • NoError : vtkErrorCode
  • NoEvent : vtkCommand
  • NoFileNameError : vtkErrorCode
  • NOFORMAT : vtkTIFFReader
  • NoHardware : vtkVolumeProMapper
  • NOLIMIT : vtkDataSetAttributes
  • NonManifoldEdges : vtkFeatureEdges
  • NonManifoldEdgesOff() : vtkFeatureEdges
  • NonManifoldEdgesOn() : vtkFeatureEdges
  • NonManifoldTraversal : vtkPolyDataNormals
  • NonManifoldTraversalOff() : vtkPolyDataNormals
  • NonManifoldTraversalOn() : vtkPolyDataNormals
  • Norm() : vtkMath
  • Norm2D() : vtkMath
  • Normal : vtkCutMaterial, vtkWarpScalar, vtkTextureMapToPlane, vtkPlaneSource, vtkImplicitSelectionLoop, vtkPolygon, vtkPlane
  • NormalArrayComponents : vtkFieldDataToAttributeDataFilter
  • NormalArrays : vtkFieldDataToAttributeDataFilter
  • NormalComponentRange : vtkFieldDataToAttributeDataFilter
  • NormalComponents : vtkExtractTensorComponents
  • Normalize : vtkMath, vtkVectorNorm
  • Normalize2D() : vtkMath
  • NormalizeByWeight : vtkImplicitSum
  • NormalizeByWeightOff() : vtkImplicitSum
  • NormalizeByWeightOn() : vtkImplicitSum
  • NormalizedDisplayToDisplay() : vtkViewport
  • NormalizedDisplayToViewport() : vtkViewport
  • NormalizedShapeIndex : vtkMassProperties
  • NormalizedViewportToView() : vtkViewport
  • NormalizedViewportToViewport() : vtkViewport
  • NormalizeMouseXY() : vtkInteractorStyleUnicam
  • NormalizeNormals : vtkExtractTensorComponents
  • NormalizeNormalsOff() : vtkExtractTensorComponents
  • NormalizeNormalsOn() : vtkExtractTensorComponents
  • NormalizeOff() : vtkVectorNorm
  • NormalizeOn() : vtkVectorNorm
  • NormalNormalize : vtkFieldDataToAttributeDataFilter
  • NORMALS : vtkDataSetAttributes
  • Normals : vtkImageMarchingCubes, vtkMCubesReader, vtkPlanes
  • NormalsName : vtkDataWriter, vtkDataReader
  • NormalsNameAllocSize : vtkDataReader
  • NormalsNameInFile : vtkDataReader
  • NormalsOff() : vtkMCubesReader
  • NormalsOn() : vtkMCubesReader
  • NormalWarping : vtkGaussianSplatter
  • NormalWarpingOff() : vtkGaussianSplatter
  • NormalWarpingOn() : vtkGaussianSplatter
  • NOT_INITIALIZED : vtkInitialValueProblemSolver
  • NotMask : vtkImageMask
  • NotMaskOff() : vtkImageMask
  • NotMaskOn() : vtkImageMask
  • nprops : PlyOtherProp, PlyElement
  • NullPoint() : vtkPointData
  • NullValue : vtkShepardMethod
  • num : PlyElement
  • NUM_ATTRIBUTES : vtkDataSetAttributes
  • num_comments : PlyFile
  • num_elems : PlyOtherElems
  • num_obj_info : PlyFile
  • Number : vtkTclInterpStruct
  • NumberOfActiveArrays : vtkFieldData
  • NumberOfActualPieces : vtkDicer
  • NumberOfAllocations : vtkHeap
  • NumberOfArrays : vtkPOPReader, vtkFieldData
  • NumberOfAttributeComponents : vtkDataSetAttributes
  • NumberOfBinsUsed : vtkQuadricClustering
  • NumberOfBoards : vtkVolumeProMapper
  • NumberOfBuckets : vtkPointLocator2D, vtkPointLocator
  • NumberOfCells : vtkCellArray
  • NumberOfCellsPerBucket : vtkCellLocator
  • NumberOfClippingPlanes : VTKVRCStaticInfo
  • NumberOfClipValues : vtkBandedPolyDataContourFilter
  • NumberOfCloudPoints : vtkLODActor
  • NumberOfCollapsedEdges : vtkQuadricDecimation
  • NumberOfColors : vtkXImageWindow, vtkXImageMapper, vtkImageQuantizeRGBToIndex, vtkLookupTable
  • NumberOfColumns : vtkDEMReader
  • NumberOfComplexScalarsPerElement : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfComplexScalarsPerNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfComplexVariables : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfComplexVectorsPerElement : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfComplexVectorsPerNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfComponents : vtkImageExtractComponents, vtkQuadricDecimation, vtkMergeFields, vtkDataArray
  • NumberOfComponentsCallback : vtkImageExport, vtkImageImport
  • NumberOfComponentsCallbackType : vtkImageImport, vtkImageExport
  • NumberOfConsumers : vtkProp, vtkDataObject, vtkAbstractMapper
  • NumberOfDegeneracies : vtkDelaunay3D
  • NumberOfDivisions : vtkImageCheckerboard, vtkCellLocator
  • NumberOfDuplicatePoints : vtkDelaunay3D
  • NumberOfEdges : vtkEdgeTable
  • NumberOfElements : vtkImageMedian3D
  • NumberOfEntries : vtkLODProp3D, vtkThreadSafeLog, vtkLegendBoxActor
  • NumberOfExtentEntries : vtkImageStencilData
  • NumberOfFieldDataInFile : vtkDataReader
  • NumberOfFieldFlags : vtkMaskFields, vtkFieldData
  • NumberOfFlyFrames : vtkRenderWindowInteractor
  • NumberOfGeometryParts : vtkEnSightReader
  • NumberOfGhostLevels : vtkPOPReader
  • NumberOfGrids : vtkPLOT3DReader
  • NumberOfIds : vtkIdList
  • NumberOfInputs : vtkXYPlotActor, vtkProcessObject
  • NumberOfInterpolationSteps : vtkSweptSurface
  • NumberOfItems : vtkCollection
  • NumberOfIterations : vtkImageIterateFilter, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkIterativeClosestPointTransform, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • NumberOfLabels : vtkScalarBarActor, vtkAxisActor2D, vtkCubeAxesActor2D
  • NumberOfLabelsBuilt : vtkScalarBarActor, vtkAxisActor2D
  • NumberOfLayers : vtkRenderWindow
  • NumberOfLights : vtkVolumeProMapper
  • NumberOfLightsBound : vtkOpenGLRenderer, vtkMesaRenderer
  • NumberOfLines : vtkTextMapper
  • NumberOfLinesAllocated : vtkTextMapper
  • NumberOfLODs : vtkLODProp3D
  • NumberOfMeasuredPoints : vtkEnSightReader
  • NumberOfNewCells : vtkDataSetSurfaceFilter
  • NumberOfNormalsInFile : vtkDataReader
  • NumberOfOctants : vtkCellLocator
  • NumberOfOutputFrames : vtkVideoSource
  • NumberOfOutputs : vtkSource
  • NumberOfParents : vtkCellLocator
  • NumberOfPieces : vtkPolyDataMapper, vtkPDataSetWriter, vtkPDataSetReader, vtkDicer, vtkExtentTranslator, vtkDataObject
  • NumberOfPlanes : vtkHull
  • NumberOfPoints : vtkPLOT3DReader, vtkParticleReader, vtkThinPlateSplineTransform, vtkPointSource, vtkColorTransferFunction
  • NumberOfPointsPerBucket : vtkPointLocator2D, vtkPointLocator
  • NumberOfPointsPerPiece : vtkDicer
  • NumberOfPreTransforms : vtkTransformConcatenation
  • NumberOfProcesses : vtkSocketCommunicator, vtkMultiProcessController
  • NumberOfPropsRenderedAsGeometry : vtkRenderer
  • NumberOfPropsToRayCast : vtkRenderer
  • NumberOfPropsToRenderIntoImage : vtkRenderer
  • NumberOfRequiredInputs : vtkProcessObject
  • NumberOfRows : vtkDEMReader
  • NumberOfScalarArrays : vtkArrayCalculator
  • NumberOfScalarComponents : vtkImageBlockReader, vtkImageReader2, vtkImageImport, vtkVideoSource, vtkFieldDataToAttributeDataFilter, vtkImageData
  • NumberOfScalarsInFile : vtkDataReader
  • NumberOfScalarsPerElement : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfScalarsPerMeasuredNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfScalarsPerNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfScalarVariables : vtkFunctionParser
  • NumberOfSides : vtkTubeFilter, vtkHyperStreamline
  • NumberOfSlicesPerChunk : vtkImageMarchingCubes
  • NumberOfSmoothingIterations : vtkImageToPolyDataFilter
  • NumberOfSources : vtkGlyph3D
  • NumberOfStepsTaken : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • NumberOfStepsToTake : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • NumberOfStreamDivisions : vtkImageDataStreamer, vtkPolyDataStreamer
  • NumberOfStreamers : vtkStreamer, vtkHyperStreamline
  • NumberOfSubdivisions : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • NumberOfSubPieces : vtkPolyDataMapper
  • NumberOfTCoordComponents : vtkFieldDataToAttributeDataFilter
  • NumberOfTCoords : vtkExtractTensorComponents
  • NumberOfTCoordsInFile : vtkDataReader
  • NumberOfTensorsInFile : vtkDataReader
  • NumberOfTensorsSymmPerElement : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfTensorsSymmPerNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfThreads : vtkVolumeRayCastMapper, vtkEncodedGradientEstimator, vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D, vtkSharedMemoryCommunicator, vtkImplicitModeller, vtkStreamer, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkMultiThreader, ThreadInfoStruct
  • NumberOfTransforms : vtkWeightedTransformFilter, vtkTransformConcatenation
  • NumberOfUnstructuredPoints : vtkEnSight6Reader, vtkEnSight6BinaryReader
  • NumberOfVariables : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfVectorArrays : vtkArrayCalculator
  • NumberOfVectorsInFile : vtkDataReader
  • NumberOfVectorsPerElement : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfVectorsPerMeasuredNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfVectorsPerNode : vtkGenericEnSightReader, vtkEnSightReader
  • NumberOfVectorVariables : vtkFunctionParser
  • NumberOfXDivisions : vtkQuadricClustering
  • NumberOfXLabels : vtkXYPlotActor
  • NumberOfYDivisions : vtkQuadricClustering
  • NumberOfYLabels : vtkXYPlotActor
  • NumberOfZDivisions : vtkQuadricClustering
  • NumFlips : vtkPolyDataNormals
  • NumFuncs : vtkFunctionSet
  • NumIndepVars : vtkFunctionSet

- o -
  • OBBCount : vtkOBBTree
  • OBBTree : vtkPolyDataToImageStencil
  • obj : vtkPythonCommand
  • obj_info : PlyFile
  • ObjCenter : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • OBJECT_DATA : vtkMaskFields
  • ObliqueAngles : vtkCamera
  • OffScreenContextId : vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkMesaImageWindow
  • OffScreenRendering : vtkWindow
  • OffScreenRenderingOff() : vtkWindow
  • OffScreenRenderingOn() : vtkWindow
  • OffScreenWindow : vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkMesaImageWindow
  • Offset : vtkXImageWindow, vtkArcPlotter, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints, vtkDelaunay3D, vtkDelaunay2D
  • offset : PlyProperty
  • OffsetPoint() : vtkArcPlotter
  • old_get_words() : vtkPLY
  • old_write_ascii_item() : vtkPLY
  • OldHdc : vtkWin32ImageWindow
  • OldHookFunction : vtkMILVideoSource
  • OldMonitorSetting : vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • OldOrigin : vtkImageStencilData
  • OldPalette : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzImageWindow
  • OldPickPoint : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • OldPos : vtkInteractorStyleUser
  • OldProc : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OldRowBounds : vtkVolumeRayCastMapper
  • OldScreen : vtkRenderWindow
  • OldSpacing : vtkImageStencilData
  • oldTop : vtkXRenderWindowTclInteractor
  • OldUserDataPtr : vtkMILVideoSource
  • OldX : vtkInteractorStyleTrackball, vtkInteractorStyleFlight
  • OldY : vtkInteractorStyleTrackball, vtkInteractorStyleFlight
  • omega : _vtkStreamPoint
  • OmniList : vtk3DSImporter
  • OnChar() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor, vtkInteractorStyleUser, vtkInteractorStyleTrackball, vtkInteractorStyleSwitch, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnConfigure() : vtkInteractorStyleUser, vtkInteractorStyle
  • OnEnter() : vtkInteractorStyleUser, vtkInteractorStyle
  • OnIn : vtkBooleanTexture
  • OnKeyDown() : vtkWin32RenderWindowInteractor, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnKeyPress() : vtkInteractorStyleUser, vtkInteractorStyle
  • OnKeyRelease() : vtkInteractorStyleUser, vtkInteractorStyle
  • OnKeyUp() : vtkWin32RenderWindowInteractor, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnLButtonDown() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnLButtonUp() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnLeave() : vtkInteractorStyleUser, vtkInteractorStyle
  • OnLeftButtonDown() : vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnLeftButtonMove() : vtkInteractorStyleUnicam
  • OnLeftButtonUp() : vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnMButtonDown() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnMButtonUp() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnMiddleButtonDown() : vtkInteractorStyleUser, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnMiddleButtonMove() : vtkInteractorStyleUnicam
  • OnMiddleButtonUp() : vtkInteractorStyleUser, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnMouseMove() : vtkWin32RenderWindowInteractor, vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnNCMouseMove() : vtkWin32RenderWindowInteractor
  • OnOn : vtkBooleanTexture
  • OnOut : vtkBooleanTexture
  • OnParentWndDestroy() : vtkWin32VideoSource
  • OnRatio : vtkEarthSource, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints
  • OnRButtonDown() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnRButtonUp() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnRightButtonDown() : vtkInteractorStyleUser, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnRightButtonMove() : vtkInteractorStyleUnicam
  • OnRightButtonUp() : vtkInteractorStyleUser, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle
  • OnSize() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • OnTimer() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor, vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleFlight, vtkInteractorStyle
  • Opacity : vtkProperty, vtkImageBlend, vtkVideoSource, vtkProperty2D
  • OpacityArrayLength : vtkImageBlend
  • Open() : vtkDirectory
  • OpenAndSeekFile() : vtkImageReader
  • OpenFile() : vtkPDataSetWriter, vtkPDataSetReader, vtkParticleReader, vtkImageReader2
  • OpenGLInit() : vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • OpenImportFile() : vtkVRMLImporter
  • OpenLibrary() : vtkDynamicLoader
  • OpenPPMImageFile() : vtkImageWindow
  • OpenVTKFile() : vtkDataWriter, vtkDataReader
  • OperateOnBounds() : vtkQuantizePolyDataPoints, vtkCleanPolyData
  • OperateOnPoint() : vtkQuantizePolyDataPoints, vtkCleanPolyData
  • Operation : vtkRearrangeFields::Operation, vtkImageMathematics, vtkImageMaskBits, vtkImageLogic
  • OperationType : vtkRearrangeFields, vtkRearrangeFields::Operation, vtkImplicitBoolean
  • OperationTypeNames : vtkRearrangeFields
  • operator &() : vtkLargeInteger
  • operator &=() : vtkLargeInteger
  • operator *() : vtkLargeInteger
  • operator *=() : vtkLargeInteger
  • operator delete() : VectorType< T >
  • operator float *() : vtkTensor
  • operator new() : VectorType< T >
  • operator T *() : VectorType< T >
  • operator unsigned long() : vtkTimeStamp
  • operator!=() : vtkLargeInteger
  • operator%() : vtkLargeInteger
  • operator%=() : vtkLargeInteger
  • operator+() : vtkLargeInteger
  • operator++() : vtkLargeInteger
  • operator+=() : VectorType< T >, vtkLargeInteger
  • operator-() : vtkLargeInteger
  • operator--() : vtkLargeInteger
  • operator-=() : vtkLargeInteger
  • operator/() : vtkLargeInteger
  • operator/=() : vtkLargeInteger
  • operator<() : vtkTimeStamp, vtkLargeInteger
  • operator<< : ostrstream, ofstream, ostream, vtkObject, vtkLargeInteger, vtkIndent
  • operator<<=() : vtkLargeInteger
  • operator<=() : vtkLargeInteger
  • operator=() : vtkVolumeProVP1000Mapper, vtkOpenGLVolumeProVP1000Mapper, vtkTreeComposite, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkPVGeometryFilter, vtkPOPReader, vtkPDataSetWriter, vtkPDataSetReader, vtkCompositeManager, vtkImplicitFunctionToImageStencil, vtkPolyDataToImageStencil, vtkStructuredPointsGeometryFilter, vtkSpherePuzzleArrows, vtkSpherePuzzle, vtkMatrix4x4, vtkLargeInteger, vtkFieldData::Iterator, vtkFieldData::BasicIterator, vtkDataSetAttributes::FieldList
  • operator==() : vtkLargeInteger
  • operator>() : vtkTimeStamp, vtkLargeInteger
  • operator>=() : vtkLargeInteger
  • operator>>() : istream, vtkLargeInteger
  • operator>>=() : vtkLargeInteger
  • operator[]() : VectorType< T >, vtkMatrix4x4
  • operator^() : vtkLargeInteger
  • operator^=() : vtkLargeInteger
  • operator|() : vtkLargeInteger
  • operator|=() : vtkLargeInteger
  • Optimization : vtkImageReslice
  • OptimizationOff() : vtkImageReslice
  • OptimizationOn() : vtkImageReslice
  • OptimizedComputeInputUpdateExtent() : vtkImageReslice
  • OptimizedThreadedExecute() : vtkImageReslice
  • OptimizedTransform : vtkImageReslice
  • Order : vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • Orient : vtkGlyph3D
  • Orientation : vtkScalarBarActor, vtkProp3D, vtkProjectedTexture
  • OrientationScalars : vtkStreamer
  • OrientationScalarsOff() : vtkStreamer
  • OrientationScalarsOn() : vtkStreamer
  • OrientOff() : vtkGlyph3D
  • OrientOn() : vtkGlyph3D
  • Origin : vtkProp3D, vtkInteractorStyleTrackball, vtkImageStencilData, vtkDepthSortPolyData, vtkTransformTextureCoords, vtkTextureMapToPlane, vtkPlaneSource, vtkDataObjectToDataSetFilter, vtkButtonSource, vtkAxes, vtkViewport, VTKRayCastRayInfo, vtkPlane, vtkImageData
  • OriginalSource : vtkBranchExtentTranslator
  • OriginArray : vtkDataObjectToDataSetFilter
  • OriginArrayComponent : vtkDataObjectToDataSetFilter
  • OriginCallback : vtkImageExport, vtkImageImport
  • OriginCallbackType : vtkImageImport, vtkImageExport
  • OriginComponentRange : vtkDataObjectToDataSetFilter
  • OriginCX : vtkImageMandelbrotSource
  • OriginScale : vtkImageChangeInformation
  • OriginTranslation : vtkImageChangeInformation
  • Ortho() : vtkPerspectiveTransform
  • Orthogonalize3x3() : vtkMath
  • OrthogonalizeViewUp() : vtkCamera
  • OStream : vtkFileOutputWindow
  • OTHER : vtkTIFFReader
  • other_data : OtherElem
  • other_elems : PlyFile
  • other_list : PlyOtherElems
  • other_offset : PlyElement
  • other_props : OtherElem, OtherData
  • other_size : PlyElement
  • OUT_OF_DOMAIN : vtkInitialValueProblemSolver
  • OutCellCount : vtkQuadricClustering
  • OuterRadius : vtkDiskSource
  • OuterSize : vtkRecursiveSphereDirectionEncoder
  • OutGradient : vtkImplicitVolume, vtkImplicitDataSet
  • OutIn : vtkBooleanTexture
  • Outline : vtkInteractorStyle, vtkEarthSource, vtkCursor3D
  • OutlineActor : vtkInteractorStyle
  • OutlineCornerSource : vtkOutlineCornerFilter
  • OutlineFilter : vtkLODActor
  • OutlineFlag : vtkPVGeometryFilter
  • OutlineMapper : vtkInteractorStyle
  • OutlineOff() : vtkEarthSource, vtkCursor3D
  • OutlineOn() : vtkEarthSource, vtkCursor3D
  • OutlineSource : vtkOutlineFilter
  • OutOn : vtkBooleanTexture
  • OutOut : vtkBooleanTexture
  • OutputAttributeData : vtkFieldDataToAttributeDataFilter
  • OutputConnectedValue : vtkImageSeedConnectivity
  • OutputDataType : vtkMergeFields
  • OutputDimensionality : vtkImageReslice
  • OutputExtent : vtkImageReslice
  • OutputExtentStart : vtkImageChangeInformation
  • OutputField : vtkMergeDataObjectFilter
  • OutputFormat : vtkImageMapToColors, vtkVideoSource
  • OutputLines : vtkQuadricClustering
  • OutputNeedsInitialization : vtkVideoSource
  • OutputNumberOfScalarComponents : vtkImagePadFilter
  • OutputOrigin : vtkImageReslice, vtkImageChangeInformation
  • Outputs : vtkSource
  • OutputScalarType : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • OutputSpacing : vtkImageReslice, vtkImageResample, vtkImageChangeInformation
  • OutputString : vtkDataWriter
  • OutputStringAllocatedLength : vtkDataWriter
  • OutputStringLength : vtkDataWriter
  • OutputStyle : vtkImageToPolyDataFilter
  • OutputTriangleArray : vtkQuadricClustering
  • OutputTrueValue : vtkImageLogic
  • OutputUnconnectedValue : vtkImageSeedConnectivity
  • OutputWholeExtent : vtkImagePadFilter, vtkImageClip, vtkVideoSource
  • OutputWindow : vtkMultiProcessController, vtkWin32OutputWindow
  • OutTextureCoord : vtkThresholdTextureCoords
  • OutValue : vtkImageThreshold, vtkImageEllipsoidSource, vtkImplicitVolume, vtkImplicitDataSet
  • Overlap : vtkImageBlockWriter, vtkImageBlockReader
  • OverrideArray : vtkObjectFactory
  • OverrideArrayLength : vtkObjectFactory
  • OverrideClassNames : vtkObjectFactory
  • OverrideWithName : vtkObjectFactory::OverrideInformation
  • OwnDisplay : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow
  • OwnTop : vtkXRenderWindowInteractor
  • OwnWindow : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow

- p -
  • p : _vtkStreamPoint
  • P1 : vtkWarpLens
  • P2 : vtkWarpLens
  • Padding : vtkLegendBoxActor, vtkCaptionActor2D
  • Palette : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • PALETTE_GRAYSCALE : vtkTIFFReader
  • PALETTE_RGB : vtkTIFFReader
  • Pan() : vtkInteractorStyleUnicam, vtkImageMandelbrotSource
  • PanCamera() : vtkInteractorStyle
  • PanXY() : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage
  • ParallelProjection : vtkCamera
  • ParallelProjectionOff() : vtkCamera
  • ParallelProjectionOn() : vtkCamera
  • ParallelScale : vtkCamera
  • ParallelStreaming : vtkAppendPolyData
  • ParallelStreamingOff() : vtkAppendPolyData
  • ParallelStreamingOn() : vtkAppendPolyData
  • ParameterizePolygon() : vtkPolygon
  • ParameterMethod : vtkOutputPort
  • ParameterMethodArg : vtkOutputPort
  • ParameterMethodArgDelete : vtkOutputPort
  • Parameters : vtkRIBProperty
  • Parent : vtkSharedMemoryCommunicator, vtkOBBNode
  • ParentId : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • ParentWnd : vtkWin32VideoSource
  • Parse() : vtkXMLParser, vtkFunctionParser
  • ParseBuffer() : vtkXMLParser
  • ParseMTime : vtkFunctionParser
  • Parser : vtkXMLParser
  • ParseStream() : vtkXMLParser
  • ParsingComplete() : vtkXMLParser
  • PartColors : vtkUGFacetReader
  • PartNumber : vtkUGFacetReader, vtkBYUReader
  • Parts : vtkAssembly, vtkPropAssembly
  • PassAlphaToOutput : vtkImageMapToColors
  • PassAlphaToOutputOff() : vtkImageMapToColors
  • PassAlphaToOutputOn() : vtkImageMapToColors
  • PassAttributeData : vtkAttributeDataToFieldDataFilter
  • PassAttributeDataOff() : vtkAttributeDataToFieldDataFilter
  • PassAttributeDataOn() : vtkAttributeDataToFieldDataFilter
  • PassBand : vtkWindowedSincPolyDataFilter
  • PassCellData : vtkCellDataToPointData
  • PassCellDataOff() : vtkCellDataToPointData
  • PassCellDataOn() : vtkCellDataToPointData
  • PassData() : vtkFieldData, vtkDataSetAttributes
  • PassLines : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter, vtkRuledSurfaceFilter
  • PassLinesOff() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter, vtkRuledSurfaceFilter
  • PassLinesOn() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter, vtkRuledSurfaceFilter
  • PassPointData : vtkPointDataToCellData
  • PassPointDataOff() : vtkPointDataToCellData
  • PassPointDataOn() : vtkPointDataToCellData
  • PassTensorsToOutput : vtkExtractTensorComponents
  • PassTensorsToOutputOff() : vtkExtractTensorComponents
  • PassTensorsToOutputOn() : vtkExtractTensorComponents
  • PassVerts : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter
  • PassVertsOff() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter
  • PassVertsOn() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter
  • Path : vtkAbstractPropPicker
  • PathArray : vtkRenderer
  • PathArrayCount : vtkRenderer
  • Paths : vtkProp
  • PathTime : vtkAssembly, vtkPropAssembly
  • PatientID : vtkMedicalImageReader2
  • PatientName : vtkMedicalImageReader2
  • PCoords : vtkCellPicker
  • PData : vtkCompositeManager
  • Peek() : vtkPriorityQueue
  • PerformAzimuthalScan() : vtkInteractorStyleFlight
  • Period : vtkImageSinusoidSource
  • Permutation : vtkSpherePuzzleArrows
  • PermuteExtent() : vtkImageDecomposeFilter
  • PermuteIncrements() : vtkImageDecomposeFilter
  • Perpendiculars() : vtkMath
  • Perspective() : vtkPerspectiveTransform
  • PerspectiveMatrix : vtkVolumeRayCastMapper
  • PerspectiveTransform : vtkCamera
  • Phase : vtkImageSinusoidSource, vtkPerlinNoise
  • Phi : vtkTexturedSphereSource
  • PhiResolution : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • PhiRoundness : vtkSuperquadricSource, vtkSuperquadric
  • PhiThreshold : vtkLinkEdgels
  • Pi() : vtkMath
  • Pick() : vtkWorldPointPicker, vtkPropPicker, vtkPicker, vtkAbstractPicker, vtkProp
  • Pickable : vtkProp
  • PickableOff() : vtkProp
  • PickableOn() : vtkProp
  • PickColor : vtkInteractorStyle
  • PickedActor2D : vtkInteractorStyle
  • PickedPositions : vtkPicker
  • PickedProp : vtkViewport
  • PickedRenderer : vtkInteractorStyle
  • PickedZ : vtkOpenGLRenderer, vtkMesaRenderer
  • Picker : vtkRenderWindowInteractor
  • PickEvent : vtkCommand
  • PickFromList : vtkAbstractPicker
  • PickFromListOff() : vtkAbstractPicker
  • PickFromListOn() : vtkAbstractPicker
  • PickFromProps : vtkPropPicker, vtkViewport
  • PickGeometry() : vtkRenderer
  • PickInfo : vtkOpenGLRenderer, vtkMesaRenderer
  • PickList : vtkAbstractPicker
  • PickPosition : vtkAbstractPicker
  • PickProp() : vtkRenderer, vtkPropPicker, vtkImager, vtkViewport
  • PickPropFrom() : vtkViewport
  • PickRender() : vtkRenderer
  • PickTag : vtkAbstractPicker, vtkProp
  • PickX : vtkViewport
  • PickY : vtkViewport
  • Piece : vtkPolyDataMapper, vtkExtentTranslator, vtkDataObject
  • PieceExtents : vtkPDataSetReader
  • PieceFileNames : vtkPDataSetReader
  • PieceInvariant : vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkCleanPolyData
  • PieceInvariantOff() : vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkCleanPolyData
  • PieceInvariantOn() : vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkCleanPolyData
  • PieceMask : vtkSpherePuzzle
  • PieceToExtent() : vtkBranchExtentTranslator, vtkExtentTranslator
  • PieceToExtentByPoints() : vtkExtentTranslator
  • PieceToExtentThreadSafe() : vtkExtentTranslator
  • PiecewiseFunction : vtkSpline
  • PipelineFlag : vtkOutputPort
  • PipelineFlagOff() : vtkOutputPort
  • PipelineFlagOn() : vtkOutputPort
  • PipelineModifiedCallback : vtkImageExport, vtkImageImport
  • PipelineModifiedCallbackType : vtkImageImport, vtkImageExport
  • PipelineMTime : vtkDataObject
  • Pitch() : vtkCamera
  • PitchAngle : vtkInteractorStyleFlight
  • Pixel : vtkVoxel, vtkUnstructuredGrid, vtkRectilinearGrid, VTKRayCastRayInfo, vtkImageData
  • PixelAspect : vtkViewport
  • PixelizeImage() : vtkImageToPolyDataFilter
  • PixelSamples : vtkRIBExporter
  • PixmapHeight : vtkXImageWindow
  • PixmapWidth : vtkXImageWindow
  • PlaceAxes() : vtkXYPlotActor
  • Plane : vtkReflectionFilter, vtkPlanes
  • PlaneFunction : vtkCutMaterial
  • Planes : vtkHull
  • PlanesStorageSize : vtkHull
  • PlaneUnitOfMeasure : vtkDEMReader
  • Play() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • PlayerThreader : vtkVideoSource
  • PlayerThreadId : vtkVideoSource
  • Playing : vtkVideoSource
  • PlotActor : vtkXYPlotActor
  • PlotAppend : vtkXYPlotActor
  • PlotComponent : vtkArcPlotter
  • PlotCoordinate : vtkXYPlotActor
  • PlotCurveLines : vtkXYPlotActor
  • PlotCurveLinesOff() : vtkXYPlotActor
  • PlotCurveLinesOn() : vtkXYPlotActor
  • PlotCurvePoints : vtkXYPlotActor
  • PlotCurvePointsOff() : vtkXYPlotActor
  • PlotCurvePointsOn() : vtkXYPlotActor
  • PlotData : vtkXYPlotActor
  • PlotGlyph : vtkXYPlotActor
  • PlotLines : vtkXYPlotActor
  • PlotLinesOff() : vtkXYPlotActor
  • PlotLinesOn() : vtkXYPlotActor
  • PlotMapper : vtkXYPlotActor
  • PlotMode : vtkArcPlotter
  • PlotPoints : vtkXYPlotActor
  • PlotPointsOff() : vtkXYPlotActor
  • PlotPointsOn() : vtkXYPlotActor
  • PlotToViewportCoordinate() : vtkXYPlotActor
  • ply_close() : vtkPLY
  • ply_describe_element() : vtkPLY
  • ply_describe_other_elements() : vtkPLY
  • ply_describe_other_properties() : vtkPLY
  • ply_describe_property() : vtkPLY
  • ply_element_count() : vtkPLY
  • ply_free_other_elements() : vtkPLY
  • ply_get_comments() : vtkPLY
  • ply_get_element() : vtkPLY
  • ply_get_element_description() : vtkPLY
  • ply_get_element_setup() : vtkPLY
  • ply_get_info() : vtkPLY
  • ply_get_obj_info() : vtkPLY
  • ply_get_other_element() : vtkPLY
  • ply_get_other_properties() : vtkPLY
  • ply_get_property() : vtkPLY
  • ply_header_complete() : vtkPLY
  • ply_open_for_reading() : vtkPLY
  • ply_open_for_writing() : vtkPLY
  • ply_put_comment() : vtkPLY
  • ply_put_element() : vtkPLY
  • ply_put_element_setup() : vtkPLY
  • ply_put_obj_info() : vtkPLY
  • ply_put_other_elements() : vtkPLY
  • ply_read() : vtkPLY
  • ply_write() : vtkPLY
  • Point : vtkProgrammableGlyphFilter, vtkTransform
  • Point1 : vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • Point1Coordinate : vtkAxisActor2D
  • Point2 : vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • Point2Coordinate : vtkAxisActor2D
  • POINT_DATA : vtkSplitField, vtkRearrangeFields, vtkMergeFields, vtkMaskFields, vtkAssignAttribute
  • POINT_DATA_FIELD : vtkDataSet
  • PointArrayComponents : vtkDataObjectToDataSetFilter
  • PointArrays : vtkDataObjectToDataSetFilter
  • PointClipping : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • PointClippingOff() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • PointClippingOn() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • PointComponentRange : vtkDataObjectToDataSetFilter
  • PointData : vtkProgrammableGlyphFilter, vtkDataSetToDataObjectFilter, vtkDataSet
  • PointDataOff() : vtkDataSetToDataObjectFilter
  • PointDataOn() : vtkDataSetToDataObjectFilter
  • Pointer : vtkImageConnectorSeed, vtkImageCanvasSource2DPixel, vtkTclCommandArgStruct, vtkImageIterator< DType >
  • PointerLookup : vtkTclInterpStruct
  • PointId : vtkPointPicker, vtkProgrammableGlyphFilter
  • PointIds : vtkIdFilter, vtkImplicitVolume, vtkCell
  • PointIdsName : vtkGlyph3D
  • PointIdsOff() : vtkIdFilter
  • PointIdsOn() : vtkIdFilter
  • PointInPolygon() : vtkPolygon
  • PointInTriangle() : vtkTriangle
  • PointMap : vtkDataSetSurfaceFilter
  • PointMaximum : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • PointMerging : vtkCleanPolyData
  • PointMergingOff() : vtkCleanPolyData
  • PointMergingOn() : vtkCleanPolyData
  • PointMinimum : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • PointMultiply() : vtkMatrix4x4
  • PointNormal : vtkWarpScalar
  • PointNormalize : vtkDataObjectToDataSetFilter
  • PointReturn : vtkRectilinearGrid
  • Points : vtkImageMarchingCubes, vtkPointSet, vtkPointLocator2D, vtkPointLocator, vtkPlanes, vtkEdgeTable, vtkCell
  • PointSize : vtkProperty, vtkProperty2D
  • PointSize_bucket : vtkOpenGLStateCache
  • PointsList : vtkOBBTree, vtkOBBDicer
  • PointSmoothing : vtkRenderWindow
  • PointSmoothingOff() : vtkRenderWindow
  • PointSmoothingOn() : vtkRenderWindow
  • PointsOn : vtkXYPlotActor
  • PointVisibility : vtkStructuredGrid
  • PoissonsRatio : vtkPointLoad
  • PokeMatrix() : vtkProp3D, vtkProp
  • PolyDataExecute() : vtkPDataSetReader, vtkGeometryFilter
  • PolyDataMapper : vtkDataSetMapper
  • Polygon : vtkUnstructuredGrid, vtkPolyData
  • PolygonalizeImage() : vtkImageToPolyDataFilter
  • PolygonSize : vtkDEMReader
  • PolygonSmoothing : vtkRenderWindow
  • PolygonSmoothingOff() : vtkRenderWindow
  • PolygonSmoothingOn() : vtkRenderWindow
  • PolyLine : vtkUnstructuredGrid, vtkPolyData
  • Polys : vtkPolyData
  • PolysArray : vtkDataObjectToDataSetFilter
  • PolysArrayComponent : vtkDataObjectToDataSetFilter
  • PolysComponentRange : vtkDataObjectToDataSetFilter
  • PolyVertex : vtkUnstructuredGrid, vtkPolyData
  • Pop() : VectorType< T >, vtkTransform, vtkPriorityQueue, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenationStack
  • PopSeed() : vtkImageConnector
  • pos : Camera, SpotLight, OmniLight
  • Position : vtkProp3D, vtkLight, vtkInteractorStyleTrackball, vtkCamera, vtkWarpTo, vtkTransformTextureCoords, vtkProjectedTexture, vtkWindow, vtkFieldData::BasicIterator, vtkEdgeTable
  • Position2Coordinate : vtkActor2D
  • PositionAdjustment : vtkImageMapper
  • Positional : vtkLight
  • PositionalOff() : vtkLight
  • PositionalOn() : vtkLight
  • PositionBeforeStereo : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • PositionCoordinate : vtkActor2D
  • PositionSampling() : vtkGaussianSplatter
  • PositionScale : vtkPiecewiseFunctionShiftScale
  • PositionShift : vtkPiecewiseFunctionShiftScale
  • PostMatrix : vtkTransformConcatenation
  • PostMatrixTransform : vtkTransformConcatenation
  • PostMultiply() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • PPMImageFilePtr : vtkImageWindow
  • PrefFullScreen() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkQuartzRenderWindow
  • PreMatrix : vtkTransformConcatenation
  • PreMatrixTransform : vtkTransformConcatenation
  • PrematureEndOfFileError : vtkErrorCode
  • PreMultiply() : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • PreMultiplyFlag : vtkTransformConcatenation
  • PrepareForNewData() : vtkImageData, vtkDataObject
  • PrependItem() : vtkAbstractList< DType >
  • Preprocess : vtkInteractorStyleTrackball
  • PreserveEdges : vtkDecimate
  • PreserveEdgesOff() : vtkDecimate
  • PreserveEdgesOn() : vtkDecimate
  • PreserveExtents : vtkImageAppend
  • PreserveExtentsOff() : vtkImageAppend
  • PreserveExtentsOn() : vtkImageAppend
  • PreserveImageExtent : vtkImageFlip
  • PreserveImageExtentOff() : vtkImageFlip
  • PreserveImageExtentOn() : vtkImageFlip
  • PreserveTopology : vtkDecimate, vtkDecimatePro
  • PreserveTopologyOff() : vtkDecimate, vtkDecimatePro
  • PreserveTopologyOn() : vtkDecimate, vtkDecimatePro
  • PreSortedOff() : vtkOrderedTriangulator
  • PreSortedOn() : vtkOrderedTriangulator
  • PreSplitMesh : vtkDecimatePro
  • PreSplitMeshOff() : vtkDecimatePro
  • PreSplitMeshOn() : vtkDecimatePro
  • PreventSeam : vtkTextureMapToSphere, vtkTextureMapToCylinder
  • PreventSeamOff() : vtkTextureMapToSphere, vtkTextureMapToCylinder
  • PreventSeamOn() : vtkTextureMapToSphere, vtkTextureMapToCylinder
  • Preview : vtkWin32VideoSource
  • PreviewOff() : vtkWin32VideoSource
  • PreviewOn() : vtkWin32VideoSource
  • PreviousPickMethod : vtkLODProp3D
  • PreviousPickMethodArg : vtkLODProp3D
  • PreviousPickProp : vtkLODProp3D
  • PrincipalPoint : vtkWarpLens
  • Print() : vtkObject
  • PrintAllComponents() : vtkSplitField, vtkMergeFields
  • PrintAllOperations() : vtkRearrangeFields
  • PrintComponent() : vtkSplitField, vtkMergeFields
  • PrintCurrentLeaks() : vtkDebugLeaks
  • PrintHeader() : vtkObject
  • PrintOperation() : vtkRearrangeFields
  • PrintSelf() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkXImageMapper, vtkWorldPointPicker, vtkWindowToImageFilter, vtkWinCEOpenGLRenderWindow, vtkWin32RenderWindowInteractor, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkWin32ImageMapper, vtkVRMLExporter, vtkVolumeTextureMapper2D, vtkVolumeTextureMapper, vtkVolumeRayCastMIPFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastCompositeFunction, vtkVolumeProperty, vtkVolumeProMapper, vtkVolumeMapper, vtkVolume, vtkTexture, vtkTextMapper, vtkSelectVisiblePoints, vtkScaledTextActor, vtkScalarBarActor, vtkRenderWindowInteractor, vtkRenderWindow, vtkRendererSource, vtkRenderer, vtkRecursiveSphereDirectionEncoder, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkPropPicker, vtkProperty, vtkProp3D, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkPointPicker, vtkPicker, vtkParallelCoordinatesActor, vtkOpenGLVolumeTextureMapper2D, vtkOpenGLRenderWindow, vtkOpenGLRenderer, vtkOpenGLImageWindow, vtkOOGLExporter, vtkOBJExporter, vtkMesaVolumeTextureMapper2D, vtkMesaRenderWindow, vtkMesaRenderer, vtkMesaImageWindow, vtkMapper, vtkLODProp3D, vtkLODActor, vtkLightKit, vtkLight, vtkLabeledDataMapper, vtkIVExporter, vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleSwitch, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle, vtkImporter, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor, vtkFrustumCoverageCuller, vtkFollower, vtkFiniteDifferenceGradientEstimator, vtkExporter, vtkEncodedGradientShader, vtkEncodedGradientEstimator, vtkDataSetMapper, vtkCellPicker, vtkCamera, vtkAxisActor2D, vtkAssembly, vtkActor, vtkAbstractPropPicker, vtkAbstractPicker, vtkAbstractMapper3D, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSweptSurface, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkKitwareObjectFactory, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkDecimate, vtkTreeComposite, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkThreadedController, vtkSocketController, vtkSocketCommunicator, vtkSharedMemoryCommunicator, vtkRTAnalyticSource, vtkPVGeometryFilter, vtkPPolyDataNormals, vtkPOPReader, vtkPLinearExtrusionFilter, vtkPImageWriter, vtkPieceScalars, vtkPDataSetWriter, vtkPDataSetReader, vtkPCellDataToPointData, vtkParallelFactory, vtkOutputPort, vtkMultiProcessController, vtkMPIGroup, vtkMPIEventLog, vtkMPIController, vtkMPICommunicator, vtkMemoryLimitImageDataStreamer, vtkInputPort, vtkImageBlockWriter, vtkImageBlockReader, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkCutMaterial, vtkCompositeManager, vtkCommunicator, vtkBranchExtentTranslator, vtkXMLParser, vtkWriter, vtkVolumeReader, vtkVolume16Reader, vtkUnstructuredGridWriter, vtkUnstructuredGridReader, vtkUGFacetReader, vtkStructuredPointsWriter, vtkStructuredPointsReader, vtkStructuredGridWriter, vtkStructuredGridReader, vtkSTLReader, vtkSLCReader, vtkRectilinearGridWriter, vtkRectilinearGridReader, vtkPolyDataWriter, vtkPolyDataReader, vtkPLYWriter, vtkPLYReader, vtkPLOT3DReader, vtkParticleReader, vtkOBJReader, vtkMedicalImageReader2, vtkMCubesWriter, vtkMCubesReader, vtkJPEGWriter, vtkImageWriter, vtkImageReader2Factory, vtkImageReader2, vtkImageReader, vtkGenericEnSightReader, vtkEnSightReader, vtkDEMReader, vtkDataWriter, vtkDataSetWriter, vtkDataSetReader, vtkDataReader, vtkDataObjectWriter, vtkDataObjectReader, vtkCGMWriter, vtkBYUWriter, vtkBYUReader, vtkBMPReader, vtkVoxelModeller, vtkTriangularTexture, vtkSurfaceReconstructionFilter, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkImplicitFunctionToImageStencil, vtkImageVariance3D, vtkImageTranslateExtent, vtkImageToImageStencil, vtkImageThreshold, vtkImageStencilSource, vtkImageStencilData, vtkImageStencil, vtkImageSpatialFilter, vtkImageSobel3D, vtkImageSobel2D, vtkImageSkeleton2D, vtkImageSinusoidSource, vtkImageShrink3D, vtkImageShiftScale, vtkImageSeparableConvolution, vtkImageSeedConnectivity, vtkImageRGBToHSV, vtkImageReslice, vtkImageResample, vtkImageRange3D, vtkImageQuantizeRGBToIndex, vtkImagePermute, vtkImagePadFilter, vtkImageOpenClose3D, vtkImageNonMaximumSuppression, vtkImageNoiseSource, vtkImageMedian3D, vtkImageMathematics, vtkImageMaskBits, vtkImageMask, vtkImageMapToWindowLevelColors, vtkImageMapToColors, vtkImageMandelbrotSource, vtkImageMagnify, vtkImageLogic, vtkImageLogarithmicScale, vtkImageLaplacian, vtkImageIterateFilter, vtkImageIslandRemoval2D, vtkImageImport, vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageHSVToRGB, vtkImageGridSource, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSource, vtkImageGaussianSmooth, vtkImageFlip, vtkImageExtractComponents, vtkImageExport, vtkImageEuclideanToPolar, vtkImageEuclideanDistance, vtkImageEllipsoidSource, vtkImageDilateErode3D, vtkImageDifference, vtkImageDecomposeFilter, vtkImageDataStreamer, vtkImageCursor3D, vtkImageCorrelation, vtkImageConvolve, vtkImageContinuousErode3D, vtkImageContinuousDilate3D, vtkImageConstantPad, vtkImageConnector, vtkImageClip, vtkImageCheckerboard, vtkImageChangeInformation, vtkImageCast, vtkImageCanvasSource2D, vtkImageCacheFilter, vtkImageButterworthLowPass, vtkImageButterworthHighPass, vtkImageBlend, vtkImageAppend, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkImageAccumulate, vtkGaussianSplatter, vtkExtractVOI, vtkBooleanTexture, vtkXYPlotActor, vtkWin32VideoSource, vtkWeightedTransformFilter, vtkVRMLImporter, vtkVideoSource, vtkVectorText, vtkTransformToGrid, vtkThinPlateSplineTransform, vtkRIBProperty, vtkRIBLight, vtkRIBExporter, vtkRenderLargeImage, vtkProcrustesAlignmentFilter, vtkPolyDataToImageStencil, vtkPCAAnalysisFilter, vtkMILVideoSource, vtkLegendBoxActor, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkImplicitModeller, vtkImageToPolyDataFilter, vtkGridTransform, vtkGLUTesselatorTriangleFilter, vtkEarthSource, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkArcPlotter, vtk3DSImporter, vtkWindowedSincPolyDataFilter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkWarpLens, vtkVoxelContoursToSurfaceFilter, vtkVectorNorm, vtkVectorDot, vtkTubeFilter, vtkTriangularTCoords, vtkTriangleFilter, vtkTransformTextureCoords, vtkTransformPolyDataFilter, vtkTransformFilter, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold, vtkTextureMapToSphere, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkTexturedSphereSource, vtkTextSource, vtkTensorGlyph, vtkSuperquadricSource, vtkSubPixelPositionEdgels, vtkSubdivideTetra, vtkStructuredGridGeometryFilter, vtkStripper, vtkStreamPoints, vtkStreamLine, vtkStreamer, vtkSplitField, vtkSphereSource, vtkSpherePuzzleArrows, vtkSpherePuzzle, vtkSpatialRepresentationFilter, vtkSmoothPolyDataFilter, vtkSimpleElevationFilter, vtkShrinkPolyData, vtkShrinkFilter, vtkSelectPolyData, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkReverseSense, vtkReflectionFilter, vtkRecursiveDividingCubes, vtkRectilinearGridGeometryFilter, vtkRearrangeFields, vtkQuantizePolyDataPoints, vtkQuadricDecimation, vtkQuadricClustering, vtkProjectedTexture, vtkProgrammableGlyphFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter, vtkProbeFilter, vtkPolyDataStreamer, vtkPolyDataNormals, vtkPolyDataConnectivityFilter, vtkPointSource, vtkPointDataToCellData, vtkPlaneSource, vtkOutlineSource, vtkOutlineCornerSource, vtkOutlineCornerFilter, vtkOBBDicer, vtkMergeFilter, vtkMergeFields, vtkMergeDataObjectFilter, vtkMassProperties, vtkMaskPolyData, vtkMaskPoints, vtkMaskFields, vtkLinkEdgels, vtkLineSource, vtkLinearExtrusionFilter, vtkInterpolatingSubdivisionFilter, vtkInterpolateDataSetAttributes, vtkImplicitTextureCoords, vtkImageDataGeometryFilter, vtkIdFilter, vtkHyperStreamline, vtkHull, vtkHedgeHog, vtkGraphLayoutFilter, vtkGlyphSource2D, vtkGlyph3D, vtkGlyph2D, vtkGeometryFilter, vtkFieldDataToAttributeDataFilter, vtkFeatureEdges, vtkExtractVectorComponents, vtkExtractUnstructuredGrid, vtkExtractTensorComponents, vtkExtractPolyDataGeometry, vtkExtractGrid, vtkExtractGeometry, vtkExtractEdges, vtkElevationFilter, vtkEdgePoints, vtkDiskSource, vtkDicer, vtkDelaunay3D, vtkDelaunay2D, vtkDecimatePro, vtkDataSetTriangleFilter, vtkDataSetToDataObjectFilter, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkDashedStreamLine, vtkCylinderSource, vtkCutter, vtkCursor3D, vtkCubeSource, vtkContourGrid, vtkContourFilter, vtkConnectivityFilter, vtkConeSource, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkCellDerivatives, vtkCellDataToPointData, vtkCellCenters, vtkButtonSource, vtkBrownianPoints, vtkBlankStructuredGridWithImage, vtkBlankStructuredGrid, vtkBandedPolyDataContourFilter, vtkAxes, vtkAttributeDataToFieldDataFilter, vtkAssignAttribute, vtkArrowSource, vtkArrayCalculator, vtkApproximatingSubdivisionFilter, vtkAppendPolyData, vtkAppendFilter, vtkSuperquadric, vtkSpline, vtkSphere, vtkSimpleScalarTree, vtkScalarTree, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunction, vtkPerlinNoise, vtkKochanekSpline, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkCylinder, vtkCone, vtkColorTransferFunction, vtkCellLocator, vtkCardinalSpline, vtkWindowLevelLookupTable, vtkWindow, vtkWarpTransform, vtkVoidArray, vtkViewport, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTransform, vtkTimerLog, vtkStructuredGrid, vtkSource, vtkShortArray, vtkScalarsToColors, vtkRungeKutta4, vtkReferenceCount, vtkRectilinearGrid, vtkQuadric, vtkProperty2D, vtkPropAssembly, vtkProp, vtkProcessObject, vtkPriorityQueue, vtkPolyData, vtkPointSet, vtkPoints, vtkPointLocator2D, vtkPointLocator, vtkPointData, vtkPlanes, vtkPlane, vtkPerspectiveTransform, vtkOverrideInformation, vtkOutputWindow, vtkOrderedTriangulator, vtkObjectFactory, vtkObject, vtkNonLinearCell, vtkMutexLock, vtkMultiThreader, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrix4x4, vtkMapper2D, vtkLookupTable, vtkLongArray, vtkLogLookupTable, vtkLocator, vtkLinearTransform, vtkInterpolatedVelocityField, vtkIntArray, vtkInstantiator, vtkInitialValueProblemSolver, vtkImplicitFunction, vtkImageData, vtkIdTypeArray, vtkIdList, vtkIdentityTransform, vtkHomogeneousTransform, vtkHeap, vtkGeneralTransform, vtkFunctionSet, vtkFunctionParser, vtkFloatArray, vtkFileOutputWindow, vtkFieldData, vtkExtentTranslator, vtkExplicitCell, vtkEdgeTable, vtkDoubleArray, vtkDirectory, vtkDataSetAttributes, vtkDataSet, vtkDataObject, vtkDataArray, vtkCriticalSection, vtkCoordinate, vtkContourValues, vtkCollection, vtkCharArray, vtkCellData, vtkCell3D, vtkCell, vtkBitArray, vtkAssemblyPath, vtkAssemblyNode, vtkActor2D, vtkTransformConcatenation, vtkAbstractTransform, vtkAbstractMapper
  • PrintTrailer() : vtkObject
  • priority : _vtkPriorityItem
  • ProcessComponents() : vtkArcPlotter
  • ProcessEvents() : vtkInteractorStyle
  • ProcessIds : vtkMPIGroup
  • ProcessMode : vtkImplicitModeller
  • ProcessObject : vtkImageProgressIterator< DType >
  • ProcessorName : vtkMPIController
  • ProcessRMI() : vtkMultiProcessController
  • ProcessRMIs() : vtkMultiProcessController
  • ProfileDimension : vtkDEMReader
  • ProfileSeekOffset : vtkDEMReader
  • Progress : vtkProcessObject
  • ProgressEvent : vtkCommand
  • ProgressiveOff() : vtkJPEGWriter
  • ProgressiveOn() : vtkJPEGWriter
  • ProgressTag : vtkProcessObject
  • ProgressText : vtkProcessObject
  • ProjectionAxes : vtkImageMandelbrotSource
  • ProjectionParameters : vtkDEMReader
  • ProjectPoint() : vtkPlane
  • ProjectTo2D() : vtkTriangle
  • PromptText() : vtkWin32OutputWindow
  • PromptUser : vtkOutputWindow, vtkDebugLeaks
  • PromptUserOff() : vtkOutputWindow, vtkDebugLeaks
  • PromptUserOn() : vtkOutputWindow, vtkDebugLeaks
  • Prop : vtkCubeAxesActor2D
  • Prop3D : vtkLODProp3DEntry, vtkDepthSortPolyData
  • Prop3Ds : vtkPicker
  • Prop3DTransform() : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • Prop3DType : vtkLODProp3DEntry
  • PropagateUpdateExtent() : vtkInputPort, vtkImageStencilData, vtkImageImport, vtkSource, vtkDataObject
  • PropagateUpdateExtentCallback : vtkImageExport, vtkImageImport
  • PropagateUpdateExtentCallbackType : vtkImageImport, vtkImageExport
  • PropArray : vtkRenderer
  • PropArrayCount : vtkRenderer
  • Property : vtkVolume, vtkActor, vtkRIBProperty, vtkActor2D
  • PropPicked : vtkInteractorStyleTrackball, vtkInteractorStyle
  • Props : vtkViewport
  • props : PlyOtherProp, PlyElement
  • Prune : vtkImageSkeleton2D
  • PruneOff() : vtkImageSkeleton2D
  • PruneOn() : vtkImageSkeleton2D
  • Ptr : vtkHeapNode
  • Push() : VectorType< T >, vtkPlaneSource, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenationStack
  • PushDataStartEvent : vtkCommand
  • PushDistances() : vtkVoxelContoursToSurfaceFilter
  • putback() : istream
  • Pyramid : vtkUnstructuredGrid

- q -
  • QFactor : vtkQuantizePolyDataPoints
  • QFileName : vtkPLOT3DReader
  • Quad : vtkWedge, vtkUnstructuredGrid, vtkStructuredGrid, vtkPyramid, vtkPolygon, vtkPolyData, vtkHexahedron
  • QuadHash : vtkDataSetSurfaceFilter
  • QuadHashLength : vtkDataSetSurfaceFilter
  • QuadHashTraversal : vtkDataSetSurfaceFilter
  • QuadHashTraversalIndex : vtkDataSetSurfaceFilter
  • QuadraticEdge : vtkUnstructuredGrid
  • Quadric : VTK_ERROR_QUADRIC, VTK_POINT_QUADRIC
  • QuadricArray : vtkQuadricClustering
  • Quality : vtkTexture
  • QuaternionToMatrix3x3() : vtkMath
  • QueryNumber : vtkCellLocator

- r -
  • R : vtkPLOT3DReader
  • RadialRatio : vtkButtonSource
  • RadialResolution : vtkDiskSource
  • RadianToDegree : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage
  • Radius : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor, vtkPOPReader, vtkImageEllipsoidSource, vtkGaussianSplatter, vtkEarthSource, vtkArcPlotter, vtkTubeFilter, vtkTexturedSphereSource, vtkSphereSource, vtkSpherePuzzleArrows, vtkPointSource, vtkHyperStreamline, vtkCylinderSource, vtkConeSource, vtkSphere, vtkCylinder
  • RadiusFactor : vtkTubeFilter
  • RadiusFactors : vtkImageGaussianSmooth
  • Ramp : vtkLookupTable
  • Random() : vtkMath
  • RandomMode : vtkPieceScalars, vtkMaskPoints
  • RandomModeOff() : vtkPieceScalars, vtkMaskPoints
  • RandomModeOn() : vtkPieceScalars, vtkMaskPoints
  • RandomSeed() : vtkMath
  • Range : vtkAxisActor2D, vtkGlyph3D, vtkColorTransferFunction
  • Ranges : vtkCubeAxesActor2D
  • Ratio : vtkImageCanvasSource2D
  • RayCaster : vtkRenderer
  • rdbuf() : ostrstream
  • Re : vtkPLOT3DReader
  • Read() : vtkImporter, vtkImageBlockReader, vtkDataReader
  • Read16BitImage() : vtkVolume16Reader
  • Read3DS() : vtk3DSImporter
  • ReadArray() : vtkDataReader
  • ReadASCIISTL() : vtkSTLReader
  • ReadBinaryFunctionFile() : vtkPLOT3DReader
  • ReadBinaryGrid() : vtkPLOT3DReader
  • ReadBinaryGridDimensions() : vtkPLOT3DReader
  • ReadBinaryLine() : vtkGenericEnSightReader
  • ReadBinarySolution() : vtkPLOT3DReader
  • ReadBinarySTL() : vtkSTLReader
  • ReadBinaryVectorFunctionFile() : vtkPLOT3DReader
  • ReadBlock() : vtkImageBlockReader
  • ReadCaseFile() : vtkEnSightReader
  • ReadCellData() : vtkDataReader
  • ReadCells() : vtkDataReader
  • ReadCoordinates() : vtkDataReader
  • ReadCoScalarData() : vtkDataReader
  • ReadData() : vtkImporter
  • ReadDataArray() : vtkCommunicator
  • ReadDataSet() : vtkCommunicator
  • ReadDataSetData() : vtkDataReader
  • ReadDisplacement : vtkBYUReader
  • ReadDisplacementFile() : vtkBYUReader
  • ReadDisplacementOff() : vtkBYUReader
  • ReadDisplacementOn() : vtkBYUReader
  • Reader : vtkSliceCubes, vtkGenericEnSightReader, vtkDataSetReader
  • ReadFieldData() : vtkDataReader
  • ReadFloatArray() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • ReadFlow() : vtkPOPReader
  • ReadFromInputString : vtkDataReader
  • ReadFromInputStringOff() : vtkDataReader
  • ReadFromInputStringOn() : vtkDataReader
  • ReadFrontBuffer : vtkWindowToImageFilter
  • ReadFrontBufferOff() : vtkWindowToImageFilter
  • ReadFrontBufferOn() : vtkWindowToImageFilter
  • ReadGenericImage() : vtkTIFFReader
  • ReadGeometryFile() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader, vtkBYUReader
  • ReadHeader() : vtkDataReader
  • ReadHeaderTime : vtkDEMReader
  • ReadImage() : vtkVolume16Reader
  • ReadImageData() : vtkCommunicator
  • ReadImageInternal() : vtkTIFFReader
  • ReadInformationFile() : vtkPOPReader
  • ReadInt() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • ReadIntArray() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • ReadLine() : vtkGenericEnSightReader, vtkEnSightReader, vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader, vtkDataReader
  • ReadLutData() : vtkDataReader
  • ReadMeasuredGeometryFile() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadNextDataLine() : vtkGenericEnSightReader, vtkEnSightReader
  • ReadNormalData() : vtkDataReader
  • ReadObject() : vtkCommunicator
  • ReadOutputType() : vtkPDataSetReader, vtkDataSetReader
  • ReadPointData() : vtkDataReader
  • ReadPoints() : vtkPOPReader, vtkDataReader
  • ReadProfiles() : vtkDEMReader
  • ReadPVTKFileInformation() : vtkPDataSetReader
  • ReadRemainder() : vtkImageBlockReader
  • ReadScalar : vtkBYUReader
  • ReadScalarData() : vtkDataReader
  • ReadScalarFile() : vtkBYUReader
  • ReadScalarOff() : vtkBYUReader
  • ReadScalarOn() : vtkBYUReader
  • ReadScalarsPerElement() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadScalarsPerNode() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadSelf() : vtkLight
  • ReadString() : vtkDataReader
  • ReadTCoordsData() : vtkDataReader
  • ReadTensorData() : vtkDataReader
  • ReadTensorsPerElement() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadTensorsPerNode() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadTexture : vtkBYUReader
  • ReadTextureFile() : vtkBYUReader
  • ReadTextureOff() : vtkBYUReader
  • ReadTextureOn() : vtkBYUReader
  • ReadTypeARecord() : vtkDEMReader
  • ReadVariableFiles() : vtkEnSightReader
  • ReadVectorData() : vtkDataReader
  • ReadVectorsPerElement() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadVectorsPerNode() : vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader
  • ReadVolume() : vtkVolume16Reader
  • ReadVTKFileInformation() : vtkPDataSetReader
  • ReadXML() : vtkPDataSetReader
  • Receive() : vtkSocketCommunicator, vtkSharedMemoryCommunicator, vtkMultiProcessController, vtkMPICommunicator, vtkCommunicator
  • ReceiveMessage() : vtkSocketCommunicator
  • Record() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • Recording : vtkVideoSource
  • RectilinearGridExecute() : vtkPVGeometryFilter
  • RecursionDepth : vtkRecursiveSphereDirectionEncoder
  • RecursiveWrite() : vtkPImageWriter, vtkImageWriter
  • Red : vtkColorTransferFunction
  • red : Colour_24, Colour
  • RedDiffuseShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • RedSpecularShadingTable : vtkVolumeTextureMapper, VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • ReductionFactor : vtkCompositeManager
  • ReferenceCoordinate : vtkCoordinate
  • ReferenceCount : vtkObject, vtkContainer, vtkCommand
  • References : vtkDelaunay3D
  • reflection : MatProp
  • RegionSizes : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • Register() : vtkObject, vtkContainer, vtkCommand
  • RegisterAndGetOutputString() : vtkDataWriter
  • RegisterFactory() : vtkObjectFactory
  • RegisterInstantiator() : vtkInstantiator
  • RegisterOverride() : vtkObjectFactory
  • RegisterReader() : vtkImageReader2Factory
  • RegisterTextureResource() : vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • ReHash() : vtkObjectFactory
  • ReInitialize() : vtkRenderWindowInteractor
  • RelaxationFactor : vtkSmoothPolyDataFilter
  • ReleaseData() : vtkDataObject
  • ReleaseDataFlag : vtkDataObject
  • ReleaseDataFlagOff() : vtkSource, vtkDataObject
  • ReleaseDataFlagOn() : vtkSource, vtkDataObject
  • ReleaseGraphicsResources() : vtkXOpenGLTextMapper, vtkXMesaTextMapper, vtkWin32OpenGLTextMapper, vtkVolumeRayCastMapper, vtkVolumeMapper, vtkVolume, vtkTexture, vtkScaledTextActor, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkOpenGLTexture, vtkOpenGLPolyDataMapper, vtkOpenGLImageActor, vtkMesaTexture, vtkMesaPolyDataMapper, vtkMesaImageActor, vtkMapper, vtkLODProp3D, vtkLODActor, vtkLabeledDataMapper, vtkDataSetMapper, vtkAxisActor2D, vtkAssembly, vtkActor, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkPropAssembly, vtkProp, vtkActor2D, vtkAbstractMapper
  • ReleaseLocator() : vtkIterativeClosestPointTransform, vtkCleanPolyData
  • ReleaseRGBAPixelData() : vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • ReleaseSource() : vtkIterativeClosestPointTransform
  • ReleaseSystemResources() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • ReleaseTarget() : vtkIterativeClosestPointTransform
  • RemoteProcessId : vtkInputPort
  • RemoveActor() : vtkRenderer
  • RemoveActor2D() : vtkViewport
  • RemoveAllClippingPlanes() : vtkAbstractMapper
  • RemoveAllFunctions() : vtkPLOT3DReader, vtkImplicitSum
  • RemoveAllInputs() : vtkXYPlotActor, vtkProcessObject
  • RemoveAllItems() : vtkContainer, vtkCollection
  • RemoveAllOperations() : vtkRearrangeFields
  • RemoveAllPlanes() : vtkHull
  • RemoveAllPoints() : vtkSpline, vtkPiecewiseFunction, vtkColorTransferFunction
  • RemoveAllProps() : vtkViewport
  • RemoveAllSeeds() : vtkImageSeedConnectivity, vtkImageConnector
  • RemoveAllVariables() : vtkArrayCalculator, vtkFunctionParser
  • RemoveArray() : vtkFieldData, vtkDataSetAttributes
  • RemoveCellReference() : vtkPolyData, vtkCellLinks
  • RemoveClippingPlane() : vtkAbstractMapper
  • RemoveConsumer() : vtkProp, vtkDataObject, vtkAbstractMapper
  • RemoveCuller() : vtkRenderer
  • RemoveDataObjectInput() : vtkXYPlotActor
  • RemoveFunction() : vtkPLOT3DReader, vtkImplicitBoolean
  • RemoveGhostCells() : vtkUnstructuredGrid, vtkPolyData
  • RemoveImager() : vtkImageWindow
  • RemoveInput() : vtkXYPlotActor, vtkProgrammableAttributeDataFilter, vtkAppendPolyData, vtkAppendFilter, vtkImageMultipleInputFilter, vtkProcessObject
  • RemoveItem() : vtkCollection, vtkAssemblyPaths, vtkAbstractList< DType >
  • RemoveLight() : vtkRenderer
  • RemoveLightsFromRenderer() : vtkLightKit
  • RemoveLOD() : vtkLODProp3D
  • RemoveObserver() : vtkObject
  • RemoveOperation() : vtkRearrangeFields
  • RemoveOutput() : vtkSource
  • RemovePart() : vtkAssembly, vtkPropAssembly
  • RemovePoint() : vtkSpline, vtkPiecewiseFunction, vtkColorTransferFunction
  • RemoveProcessId() : vtkMPIGroup
  • RemoveProp() : vtkViewport
  • RemoveReferenceToCell() : vtkUnstructuredGrid, vtkPolyData
  • RemoveRenderer() : vtkRenderWindow
  • RemoveRMI() : vtkMultiProcessController
  • RemoveSpaces() : vtkFunctionParser
  • RemoveVolume() : vtkRenderer
  • REN_INFO_TAG : vtkCompositeManager
  • Render() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWin32OpenGLImageWindow, vtkVolumeTextureMapper2D, vtkVolumeTextureMapper, vtkVolumeRayCastMapper, vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkVolumeProMapper, vtkVolumeMapper, vtkTexture, vtkRenderWindowInteractor, vtkRenderWindow, vtkRendererCollection, vtkRenderer, vtkQuartzImageWindow, vtkProperty, vtkPolyDataMapper, vtkOpenGLVolumeTextureMapper2D, vtkOpenGLProperty, vtkOpenGLLight, vtkOpenGLImageWindow, vtkOpenGLCamera, vtkOpenGLActor, vtkMesaVolumeTextureMapper2D, vtkMesaProperty, vtkMesaLight, vtkMesaImageWindow, vtkMesaCamera, vtkMesaActor, vtkMapper, vtkLODActor, vtkLight, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkFollower, vtkDataSetMapper, vtkCamera, vtkActor, vtkRIBProperty, vtkRIBLight, vtkWindow, vtkProperty2D
  • RENDER_RMI_TAG : vtkCompositeManager
  • RenderBoundingBox() : vtkVolumeProVP1000Mapper, vtkOpenGLVolumeProVP1000Mapper
  • RenderCount : vtkCubeAxesActor2D
  • RenderData() : vtkXImageMapper, vtkWin32ImageMapper, vtkQuartzImageMapper, vtkOpenGLImageMapper, vtkMesaImageMapper, vtkImageMapper
  • Renderer : VTKVRCStaticInfo, vtkSelectVisiblePoints, vtkImporter, vtkImageViewer2, vtkImageViewer, vtkAbstractPicker
  • Renderers : vtkRenderWindow
  • RendererSize : vtkCompositeManager
  • RenderFlag : vtkRendererSource
  • RenderFlagOff() : vtkRendererSource
  • RenderFlagOn() : vtkRendererSource
  • RenderGeometry() : vtkXOpenGLTextMapper, vtkWin32OpenGLTextMapper
  • RenderHexagon() : vtkVolumeProVG500Mapper, vtkOpenGLVolumeProVG500Mapper
  • RenderImageBuffer() : vtkVolumeProVP1000Mapper, vtkOpenGLVolumeProVP1000Mapper
  • RenderOpaqueGeometry() : vtkXOpenGLTextMapper, vtkXMesaTextMapper, vtkWin32OpenGLTextMapper, vtkScaledTextActor, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkOpenGLPolyDataMapper2D, vtkOpenGLImager, vtkOpenGLImageMapper, vtkMesaPolyDataMapper2D, vtkMesaImager, vtkMesaImageMapper, vtkLODProp3D, vtkLODActor, vtkLabeledDataMapper, vtkImager, vtkImageActor, vtkFollower, vtkAxisActor2D, vtkAssembly, vtkActor, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkPropAssembly, vtkProp, vtkMapper2D, vtkActor2D
  • RenderOpaqueGeometryMultipleLines() : vtkTextMapper
  • RenderOverlay() : vtkXPolyDataMapper2D, vtkXOpenGLTextMapper, vtkXMesaTextMapper, vtkXImageMapper, vtkWin32PolyDataMapper2D, vtkWin32OpenGLTextMapper, vtkWin32ImageMapper, vtkScaledTextActor, vtkScalarBarActor, vtkRendererCollection, vtkRenderer, vtkQuartzTextMapper, vtkQuartzImageMapper, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkImager, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkPropAssembly, vtkProp, vtkMapper2D, vtkActor2DCollection, vtkActor2D
  • RenderOverlayMultipleLines() : vtkTextMapper
  • RenderPiece() : vtkPolyDataMapper, vtkOpenGLPolyDataMapper, vtkMesaPolyDataMapper
  • RenderQuads() : vtkVolumeTextureMapper2D, vtkOpenGLVolumeTextureMapper2D, vtkMesaVolumeTextureMapper2D
  • RenderRendererTable : vtkVolumeRayCastMapper
  • RenderRMI() : vtkCompositeManager
  • RenderSavedTexture() : vtkVolumeTextureMapper2D
  • RenderSomething : vtkCubeAxesActor2D
  • RenderStart() : vtkImageMapper
  • RenderTableEntries : vtkVolumeRayCastMapper
  • RenderTableSize : vtkVolumeRayCastMapper
  • RenderTexture() : vtkVolumeRayCastMapper, vtkOpenGLVolumeRayCastMapper, vtkMesaVolumeRayCastMapper
  • RenderTime : vtkRenderer, vtkMapper
  • RenderTimeMultiplier : vtkProp
  • RenderTimeTable : vtkVolumeRayCastMapper
  • RenderToRectangle : vtkImageMapper
  • RenderToRectangleOff() : vtkImageMapper
  • RenderToRectangleOn() : vtkImageMapper
  • RenderTranslucentGeometry() : vtkXOpenGLTextMapper, vtkWin32OpenGLTextMapper, vtkVolume, vtkScaledTextActor, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLODProp3D, vtkImager, vtkFollower, vtkAxisActor2D, vtkAssembly, vtkActor, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkPropAssembly, vtkProp, vtkMapper2D, vtkActor2D
  • RenderVolumeTable : vtkVolumeRayCastMapper
  • RenderWindow : vtkVolumeTextureMapper, vtkTkRenderWidget, vtkRenderWindowInteractor, vtkRenderer, vtkOpenGLTexture, vtkOpenGLImageActor, vtkMesaTexture, vtkMesaPolyDataMapper, vtkMesaImageActor, vtkImporter, vtkImageViewer2, vtkImageViewer, vtkExporter, vtkCompositeManager
  • RenderWindowInteractor : vtkCompositeManager
  • Repeat : vtkTexture
  • RepeatCount : vtkRenderWindowInteractor
  • RepeatOff() : vtkTexture
  • RepeatOn() : vtkTexture
  • ReplaceCell() : vtkUnstructuredGrid, vtkPolyData, vtkCellArray
  • ReplaceCellPoint() : vtkPolyData
  • ReplaceIn : vtkImageThreshold
  • ReplaceInOff() : vtkImageThreshold
  • ReplaceInOn() : vtkImageThreshold
  • ReplaceItem() : vtkCollection
  • ReplaceLinkedCell() : vtkPolyData
  • ReplaceOut : vtkImageThreshold
  • ReplaceOutOff() : vtkImageThreshold
  • ReplaceOutOn() : vtkImageThreshold
  • ReplaceValue : vtkImageIslandRemoval2D
  • ReplaceWildcards() : vtkGenericEnSightReader, vtkEnSightReader
  • ReplaceWildcardsHelper() : vtkGenericEnSightReader
  • ReportBadAttribute() : vtkXMLParser
  • ReportMissingAttribute() : vtkXMLParser
  • ReportStrayAttribute() : vtkXMLParser
  • ReportUnknownElement() : vtkXMLParser
  • ReportXmlParseError() : vtkXMLParser
  • Representation : vtkProperty
  • Req : vtkMPICommunicator::Request
  • RequestExactExtent : vtkDataObject
  • RequestExactExtentOff() : vtkDataObject
  • RequestExactExtentOn() : vtkDataObject
  • RequiredArrays : vtkDataSetAttributes
  • ResampleToPowerOfTwo() : vtkOpenGLTexture, vtkMesaTexture
  • Reserve() : VectorType< T >
  • Reset() : vtkTriArray, vtkVertexArray, vtkStreamArray, vtkSpherePuzzle, vtkProTriArray, vtkProVertexArray, vtkUnstructuredGrid, vtkPriorityQueue, vtkPolyData, vtkPoints, vtkIdList, vtkFieldData, vtkEdgeTable, vtkDataArray, vtkCellTypes, vtkCellLinks, vtkCellArray
  • ResetCamera() : vtkRenderer, vtkCompositeManager
  • ResetCameraClippingRange() : vtkRenderer, vtkInteractorStyle, vtkCompositeManager
  • ResetCameraClippingRangeEvent : vtkCommand
  • ResetCameraClippingRangeTag : vtkCompositeManager
  • ResetCameraEvent : vtkCommand
  • ResetCameraTag : vtkCompositeManager
  • ResetControllers() : vtkThreadedController
  • ResetLog() : vtkTimerLog
  • ResetOutput() : vtkSpatialRepresentationFilter
  • ResetOutputWholeExtent() : vtkImageClip
  • Resize() : vtkStreamArray, vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPriorityQueue, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkEdgeTable, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkCellLinks, vtkBitArray
  • ResizeAndExtend() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkBitArray
  • ResizeCellList() : vtkUnstructuredGrid, vtkPolyData, vtkCellLinks
  • ResizeWhileOffscreen() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow
  • ResliceAxes : vtkImageReslice
  • ResliceAxesDirectionCosines : vtkImageReslice
  • ResliceAxesOrigin : vtkImageReslice
  • ResliceTransform : vtkImageReslice
  • Resolution : vtkCGMWriter, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkLineSource, vtkCylinderSource, vtkConeSource
  • RestoreEstimatedRenderTime() : vtkLODProp3D, vtkProp
  • ResultArrayName : vtkArrayCalculator
  • ResultFrame : vtkRenderWindow
  • ResumeScreenRendering() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • RetainCellLists : vtkLocator
  • RetainCellListsOff() : vtkLocator
  • RetainCellListsOn() : vtkLocator
  • RetrieveRenderTime() : vtkVolumeRayCastMapper
  • ReturnValue : vtkTransform, vtkImplicitFunction
  • ReverseCell() : vtkPolyData, vtkCellArray
  • ReverseCells : vtkReverseSense
  • ReverseCellsOff() : vtkReverseSense
  • ReverseCellsOn() : vtkReverseSense
  • ReverseNormals : vtkReverseSense
  • ReverseNormalsOff() : vtkReverseSense
  • ReverseNormalsOn() : vtkReverseSense
  • ReverseStencil : vtkImageStencil, vtkImageAccumulate
  • ReverseStencilOff() : vtkImageStencil, vtkImageAccumulate
  • ReverseStencilOn() : vtkImageStencil, vtkImageAccumulate
  • ReverseXAxis : vtkXYPlotActor
  • ReverseXAxisOff() : vtkXYPlotActor
  • ReverseXAxisOn() : vtkXYPlotActor
  • ReverseYAxis : vtkXYPlotActor
  • ReverseYAxisOff() : vtkXYPlotActor
  • ReverseYAxisOn() : vtkXYPlotActor
  • Reversing : vtkInteractorStyleFlight
  • Rewind() : vtkVideoSource
  • RFunction : vtkImplicitTextureCoords
  • RGB : vtkTIFFReader, vtkGlyphSource2D
  • RGBA : vtkLookupTable
  • RGBAArray : vtkVolumeTextureMapper
  • RGBArray : vtkVolume
  • RGBArrayMTime : vtkVolume
  • RGBDataIncrement : VTKRayCastVolumeInfo
  • RGBDataOrigin : VTKRayCastVolumeInfo
  • RGBDataPointer : VTKRayCastVolumeInfo
  • RGBDataSize : VTKRayCastVolumeInfo
  • RGBDataSpacing : VTKRayCastVolumeInfo
  • RGBTextureCoefficient : VTKRayCastVolumeInfo
  • RGBToHSV() : vtkColorTransferFunction
  • RGBTransferFunction : vtkVolumeProperty
  • RGBTransferFunctionMTime : vtkVolumeProperty
  • RightButtonPressEvent : vtkCommand
  • RightButtonPressTag : vtkInteractorStyle
  • RightButtonReleaseEvent : vtkCommand
  • RightButtonReleaseTag : vtkInteractorStyle
  • RightConstraint : vtkSpline
  • RightFlag : vtkSpherePuzzle
  • RightValue : vtkSpline
  • RMI_ARG_TAG : vtkMultiProcessController
  • RMI_TAG : vtkMultiProcessController
  • RMICommunicator : vtkMultiProcessController
  • RMIs : vtkMultiProcessController
  • Roll() : vtkCamera
  • RootExecute() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece
  • Rotate() : vtkInteractorStyleUnicam, vtkTransformConcatenation
  • RotateCamera() : vtkInteractorStyle
  • RotateWXYZ() : vtkProp3D, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • RotateX() : vtkProp3D, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • RotateXY() : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickActor
  • RotateY() : vtkProp3D, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • RotateZ() : vtkProp3D, vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform
  • RotationAngle : vtkGlyphSource2D
  • Round() : vtkMath
  • RowBounds : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • RuledMode : vtkRuledSurfaceFilter
  • RunLengthImage() : vtkImageToPolyDataFilter
  • RW : vtkTkRenderWidget

- s -
  • s : _vtkStreamPoint
  • SafeDownCast() : vtkTIFFReader, vtkObject, vtkSimpleMutexLock, vtkSimpleCriticalSection
  • SampleCX : vtkImageMandelbrotSource
  • SampleDimensions : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller
  • SampleDistance : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • SampleInput() : vtkSweptSurface
  • SampleRate : vtkExtractVOI, vtkExtractGrid
  • SampleSpacing : vtkSurfaceReconstructionFilter
  • SampleSpacingInVoxels : vtkFiniteDifferenceGradientEstimator
  • SatelliteExecute() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece
  • SaturationLevel : vtkMILVideoSource
  • SaturationRange : vtkLookupTable
  • SavedEstimatedRenderTime : vtkProp
  • SaveImageAsPPM() : vtkImageWindow
  • SavePointInterval : vtkStreamer
  • SaveTextures : vtkVolumeTextureMapper2D
  • SaveUserArray : vtkImageImport, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkBitArray
  • ScalarArrayComponents : vtkFieldDataToAttributeDataFilter
  • ScalarArrayNames : vtkArrayCalculator
  • ScalarArrays : vtkFieldDataToAttributeDataFilter
  • ScalarComponentRange : vtkFieldDataToAttributeDataFilter
  • ScalarComponents : vtkExtractTensorComponents
  • ScalarConnectivity : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ScalarConnectivityOff() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ScalarConnectivityOn() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • ScalarDataPointer : VTKRayCastVolumeInfo, vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ScalarDataType : VTKRayCastVolumeInfo, vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ScalarFileName : vtkBYUWriter, vtkBYUReader
  • ScalarFunctionNumber : vtkPLOT3DReader
  • ScalarIsComponent() : vtkExtractTensorComponents
  • ScalarIsDeterminant() : vtkExtractTensorComponents
  • ScalarIsEffectiveStress() : vtkExtractTensorComponents
  • ScalarLut : vtkDataReader
  • ScalarMode : vtkPolyDataMapper2D, vtkMapper, vtkExtractTensorComponents, vtkBandedPolyDataContourFilter
  • ScalarNormalize : vtkFieldDataToAttributeDataFilter
  • ScalarOpacity : vtkVolumeProperty
  • ScalarOpacityArray : vtkVolume
  • ScalarOpacityArrayMTime : vtkVolume
  • ScalarOpacityMTime : vtkVolumeProperty
  • ScalarRange : vtkPolyDataMapper2D, vtkMapper, vtkVectorDot, vtkPolyDataConnectivityFilter, vtkElevationFilter, vtkConnectivityFilter, vtkDataSet
  • Scalars : vtkImageMarchingCubes, vtkSampleFunction, vtkSimpleScalarTree, vtkScalarTree
  • SCALARS : vtkDataSetAttributes
  • ScalarSampling() : vtkGaussianSplatter
  • ScalarsName : vtkDataWriter, vtkDataReader
  • ScalarsNameAllocSize : vtkDataReader
  • ScalarsNameInFile : vtkDataReader
  • ScalarTags : vtkSTLReader
  • ScalarTagsOff() : vtkSTLReader
  • ScalarTagsOn() : vtkSTLReader
  • ScalarTree : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • ScalarType : vtkImageBlockReader, vtkImageData
  • ScalarTypeCallback : vtkImageExport, vtkImageImport
  • ScalarTypeCallbackType : vtkImageImport, vtkImageExport
  • ScalarValue : VTKVRCDynamicInfo, vtkScalarTree
  • ScalarVariableNames : vtkArrayCalculator, vtkFunctionParser
  • ScalarVariableValues : vtkFunctionParser
  • ScalarVisibility : vtkPolyDataMapper2D, vtkMapper, vtkLegendBoxActor
  • ScalarVisibilityOff() : vtkPolyDataMapper2D, vtkMapper, vtkLegendBoxActor
  • ScalarVisibilityOn() : vtkPolyDataMapper2D, vtkMapper, vtkLegendBoxActor
  • ScalarWarping : vtkGaussianSplatter
  • ScalarWarpingOff() : vtkGaussianSplatter
  • ScalarWarpingOn() : vtkGaussianSplatter
  • Scale : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenation, vtkProp3D, vtkImageShiftScale, vtkTransformTextureCoords, vtkSuperquadricSource, vtkGlyphSource2D, vtkSuperquadric, vtkLookupTable
  • Scale2 : vtkGlyphSource2D
  • ScaleFactor : vtkTriangularTexture, vtkGaussianSplatter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkTensorGlyph, vtkLinearExtrusionFilter, vtkHedgeHog, vtkGlyph3D, vtkAxes
  • ScaleMode : vtkGlyph3D
  • ScaleXY() : vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickActor
  • Scaling : vtkCubeAxesActor2D, vtkTensorGlyph, vtkGlyph3D
  • ScalingOff() : vtkCubeAxesActor2D, vtkTensorGlyph, vtkGlyph3D
  • ScalingOn() : vtkCubeAxesActor2D, vtkTensorGlyph, vtkGlyph3D
  • Scissor_bucket : vtkOpenGLStateCache
  • ScreenContextId : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • ScreenDeviceContext : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • ScreenDoubleBuffer : vtkXMesaRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkMesaImageWindow
  • ScreenMapped : vtkXMesaRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkMesaImageWindow
  • ScreenSize : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • ScreenWindowSize : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • Section : vtkSpherePuzzle
  • Seed : vtkMath
  • Seeds : vtkImageSeedConnectivity, vtkImageConnector, vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • Seek() : vtkVideoSource
  • SeekFile() : vtkImageReader2
  • SelectedInputScalars : vtkXYPlotActor
  • SelectedInputScalarsComponent : vtkXYPlotActor
  • SelectedLODID : vtkLODProp3D
  • SelectedLODIndex : vtkLODProp3D
  • SelectedPickLODID : vtkLODProp3D
  • SelectedScalarComponents : vtkArrayCalculator
  • SelectedVectorComponents : vtkArrayCalculator
  • SelectInputScalars() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkGridSynchronizedTemplates3D, vtkWarpScalar, vtkThreshold, vtkContourGrid, vtkContourFilter, vtkClipDataSet
  • SelectInputVectors() : vtkWarpVector
  • SelectInvisible : vtkSelectVisiblePoints
  • SelectInvisibleOff() : vtkSelectVisiblePoints
  • SelectInvisibleOn() : vtkSelectVisiblePoints
  • Selection : vtkSelectVisiblePoints
  • SelectionEdges : vtkSelectPolyData
  • SelectionMode : vtkSelectPolyData
  • SelectionPoint : vtkAbstractPicker
  • SelectionWindow : vtkSelectVisiblePoints
  • SelectionWindowOff() : vtkSelectVisiblePoints
  • SelectionWindowOn() : vtkSelectVisiblePoints
  • self_illum : MatProp
  • SelfAdjustingTableRange : vtkTexture
  • Send() : vtkSocketCommunicator, vtkSharedMemoryCommunicator, vtkMultiProcessController, vtkMPICommunicator, vtkCommunicator
  • Series : vtkMedicalImageReader2
  • SetAAFrames() : vtkRenderWindow
  • SetAbortCheckMethod() : vtkRenderWindow
  • SetAbortCheckMethodArgDelete() : vtkRenderWindow
  • SetAbortExecute() : vtkProcessObject
  • SetAbortFlag() : vtkCommand
  • SetAbortFlagPointer() : vtkCommand
  • SetAbortRender() : vtkRenderWindow
  • SetAbsolute() : vtkWarpTo
  • SetAbsoluteError() : vtkDecimatePro
  • SetAbsoluteTolerance() : vtkCleanPolyData
  • SetAccumulateError() : vtkDecimatePro
  • SetAccumulationMode() : vtkGaussianSplatter
  • SetAccumulationModeToMax() : vtkGaussianSplatter
  • SetAccumulationModeToMin() : vtkGaussianSplatter
  • SetAccumulationModeToSum() : vtkGaussianSplatter
  • SetActiveAttribute() : vtkDataSetAttributes
  • SetActiveCamera() : vtkRenderer
  • SetActiveComponent() : vtkImageMapToColors
  • SetActiveNormals() : vtkDataSetAttributes
  • SetActiveScalars() : vtkDataSetAttributes
  • SetActiveTCoords() : vtkDataSetAttributes
  • SetActiveTensors() : vtkDataSetAttributes
  • SetActiveVectors() : vtkDataSetAttributes
  • SetActorModeToActor() : vtkInteractorStyleTrackball
  • SetActorModeToCamera() : vtkInteractorStyleTrackball
  • SetAddInputValues() : vtkWeightedTransformFilter
  • SetAdjustBounds() : vtkSweptSurface, vtkImplicitModeller
  • SetAdjustDistance() : vtkSweptSurface, vtkImplicitModeller
  • SetAdjustLabels() : vtkAxisActor2D
  • SetAlgorithm() : vtkImageEuclideanDistance
  • SetAlgorithmToSaito() : vtkImageEuclideanDistance
  • SetAlgorithmToSaitoCached() : vtkImageEuclideanDistance
  • SetAllEnableFlags() : vtkObjectFactory
  • SetAllocatedRenderTime() : vtkRenderer, vtkLODProp3D, vtkProp
  • SetAllowShift() : vtkImageDifference
  • SetAllScalars() : vtkThreshold
  • SetAlpha() : vtkDelaunay3D, vtkDelaunay2D, vtkScalarsToColors
  • SetAlphaRange() : vtkLookupTable
  • SetAmbient() : vtkVolumeProperty, vtkRenderer, vtkProperty
  • SetAmbientColor() : vtkProperty
  • SetAmplitude() : vtkImageSinusoidSource, vtkPerlinNoise
  • SetAngle() : vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkConeSource, vtkCone
  • SetAngleAccelerationFactor() : vtkInteractorStyleFlight
  • SetAngleStepSize() : vtkInteractorStyleFlight
  • SetAppend() : vtkFileOutputWindow
  • SetAppendAxis() : vtkImageAppend
  • SetAreaThreshold() : vtkImageIslandRemoval2D
  • SetArray() : vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkCharArray, vtkBitArray
  • SetArrayId() : vtkBlankStructuredGrid
  • SetArrayName() : vtkCutMaterial, vtkPLYWriter, vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter, vtkBlankStructuredGrid
  • SetAspect() : vtkViewport
  • SetAspectRatio() : vtkDecimate, vtkProjectedTexture
  • SetAssignedNumberOfPieces() : vtkBranchExtentTranslator
  • SetAssignedPiece() : vtkBranchExtentTranslator
  • SetAttachmentPoint() : vtkCaptionActor2D
  • SetAttenuationValues() : vtkLight
  • SetAttributeMode() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • SetAttributeModeToDefault() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • SetAttributeModeToUseCellData() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • SetAttributeModeToUsePointData() : vtkVectorNorm, vtkThreshold, vtkArrayCalculator
  • SetAutoAdjustCameraClippingRange() : vtkInteractorStyleSwitch, vtkInteractorStyle
  • SetAutoAdjustSampleDistances() : vtkVolumeRayCastMapper
  • SetAutoAdvance() : vtkVideoSource
  • SetAutoCropOutput() : vtkImageReslice
  • SetAutomatic() : vtkLocator
  • SetAutomaticBoundsComputation() : vtkGraphLayoutFilter
  • SetAutomaticCylinderGeneration() : vtkTextureMapToCylinder
  • SetAutomaticLODSelection() : vtkLODProp3D
  • SetAutomaticNormalGeneration() : vtkImplicitSelectionLoop
  • SetAutomaticPickLODSelection() : vtkLODProp3D
  • SetAutomaticPlaneGeneration() : vtkTextureMapToPlane
  • SetAutomaticScaleLowerLimit() : vtkRayCaster
  • SetAutomaticSphereGeneration() : vtkTextureMapToSphere
  • SetAveraging() : vtkImageShrink3D, vtkImageDifference
  • SetAxes() : vtkCursor3D
  • SetAxisMagnificationFactor() : vtkImageResample
  • SetAxisOutputSpacing() : vtkImageResample
  • SetAxisUpdateExtent() : vtkImageData
  • SetAxisVisibility() : vtkAxisActor2D
  • SetBackfaceCulling() : vtkProperty
  • SetBackfaceProperty() : vtkActor
  • SetBackground() : vtkRIBExporter, vtkViewport
  • SetBackgroundColor() : vtkXImageWindow, vtkWin32ImageWindow, vtkImageStencil, vtkImageReslice, vtkTextSource
  • SetBackgroundInput() : vtkImageStencil
  • SetBackgroundLevel() : vtkImageReslice
  • SetBackgroundValue() : vtkImageStencil
  • SetBacking() : vtkTextSource
  • SetBackingStore() : vtkRenderer
  • SetBasis() : vtkThinPlateSplineTransform
  • SetBasisDerivative() : vtkThinPlateSplineTransform
  • SetBasisFunction() : vtkThinPlateSplineTransform
  • SetBasisToR() : vtkThinPlateSplineTransform
  • SetBasisToR2LogR() : vtkThinPlateSplineTransform
  • SetBilinearImageZoom() : vtkRayCaster
  • SetBinaryInputString() : vtkDataReader
  • SetBlanking() : vtkStructuredGrid
  • SetBlankingInput() : vtkBlankStructuredGridWithImage
  • SetBlendMode() : vtkVolumeProMapper, vtkImageBlend
  • SetBlendModeToComposite() : vtkVolumeProMapper
  • SetBlendModeToCompound() : vtkImageBlend
  • SetBlendModeToMaximumIntensity() : vtkVolumeProMapper
  • SetBlendModeToMinimumIntensity() : vtkVolumeProMapper
  • SetBlendModeToNormal() : vtkImageBlend
  • SetBold() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetBorder() : vtkXYPlotActor, vtkLegendBoxActor, vtkCaptionActor2D
  • SetBorders() : vtkRenderWindow
  • SetBoundaryEdges() : vtkFeatureEdges
  • SetBoundarySmoothing() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetBoundaryVertexDeletion() : vtkDecimate, vtkDecimatePro
  • SetBoundingTriangulation() : vtkDelaunay3D, vtkDelaunay2D
  • SetBounds() : vtkEncodedGradientEstimator, vtkCubeAxesActor2D, vtkOutlineSource, vtkCubeSource, vtkPlanes
  • SetBoundsClip() : vtkEncodedGradientEstimator
  • SetBranchingFactor() : vtkSimpleScalarTree
  • SetBreakFlag() : vtkMultiProcessController
  • SetBreakLoopFlag() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • SetBrightnessLevel() : vtkMILVideoSource
  • SetBufferPointerCallback() : vtkImageImport
  • SetBuffersTime : vtkCompositeManager
  • SetBuildTreeExecuteTime() : vtkImageQuantizeRGBToIndex
  • SetButtonDown() : vtkQuartzRenderWindowInteractor
  • SetButtonPressMethod() : vtkInteractorStyleUser
  • SetButtonPressMethodArgDelete() : vtkInteractorStyleUser
  • SetButtonReleaseMethod() : vtkInteractorStyleUser
  • SetButtonReleaseMethodArgDelete() : vtkInteractorStyleUser
  • SetBypass() : vtkImageToImageFilter, vtkImageMultipleInputFilter
  • SetCacheCellBounds() : vtkCellLocator
  • SetCacheSize() : vtkImageCacheFilter
  • SetCaching() : vtkInterpolatedVelocityField
  • SetCallback() : vtkOldStyleCallbackCommand, vtkCallbackCommand
  • SetCallbackUserData() : vtkImageImport
  • SetCamera() : vtkFollower, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkArcPlotter
  • SetCapping() : vtkSweptSurface, vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller, vtkTubeFilter, vtkRotationalExtrusionFilter, vtkLinearExtrusionFilter, vtkCylinderSource, vtkConeSource
  • SetCaption() : vtkCaptionActor2D
  • SetCapValue() : vtkSampleFunction, vtkGaussianSplatter, vtkImplicitModeller
  • SetCaseFileName() : vtkGenericEnSightReader, vtkEnSightReader
  • SetCellClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetCellConnectivityComponent() : vtkDataObjectToDataSetFilter
  • SetCellData() : vtkDataSetToDataObjectFilter
  • SetCellDataWeightArray() : vtkWeightedTransformFilter
  • SetCellIds() : vtkIdFilter
  • SetCellMaximum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetCellMinimum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetCells() : vtkUnstructuredGrid, vtkCellArray
  • SetCellScalarsFlag() : vtkPieceScalars
  • SetCellType() : vtkGenericCell
  • SetCellTypeComponent() : vtkDataObjectToDataSetFilter
  • SetCellTypes() : vtkCellTypes
  • SetCellTypeToEmptyCell() : vtkGenericCell
  • SetCellTypeToHexahedron() : vtkGenericCell
  • SetCellTypeToLine() : vtkGenericCell
  • SetCellTypeToPixel() : vtkGenericCell
  • SetCellTypeToPolygon() : vtkGenericCell
  • SetCellTypeToPolyLine() : vtkGenericCell
  • SetCellTypeToPolyVertex() : vtkGenericCell
  • SetCellTypeToPyramid() : vtkGenericCell
  • SetCellTypeToQuad() : vtkGenericCell
  • SetCellTypeToQuadraticEdge() : vtkGenericCell
  • SetCellTypeToQuadraticTetra() : vtkGenericCell
  • SetCellTypeToQuadraticTriangle() : vtkGenericCell
  • SetCellTypeToTetra() : vtkGenericCell
  • SetCellTypeToTriangle() : vtkGenericCell
  • SetCellTypeToTriangleStrip() : vtkGenericCell
  • SetCellTypeToVertex() : vtkGenericCell
  • SetCellTypeToVoxel() : vtkGenericCell
  • SetCellTypeToWedge() : vtkGenericCell
  • SetCenter() : vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkWarpLens, vtkTextureMapToSphere, vtkSuperquadricSource, vtkSphereSource, vtkPointSource, vtkPlaneSource, vtkGlyphSource2D, vtkCylinderSource, vtkCubeSource, vtkSuperquadric, vtkSphere, vtkCylinder
  • SetCenterImage() : vtkImageChangeInformation
  • SetCharMethod() : vtkInteractorStyleUser
  • SetCharMethodArgDelete() : vtkInteractorStyleUser
  • SetCheckMeanDistance() : vtkIterativeClosestPointTransform
  • SetCircumferentialResolution() : vtkDiskSource, vtkButtonSource
  • SetClamping() : vtkGlyph3D, vtkPiecewiseFunction, vtkColorTransferFunction
  • SetClampOverflow() : vtkImageShiftScale, vtkImageCast
  • SetClampScaling() : vtkTensorGlyph
  • SetClampValue() : vtkSpline
  • SetClassExitMethod() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • SetClassExitMethodArgDelete() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • SetClassOverrideName() : vtkOverrideInformation
  • SetClassOverrideWithName() : vtkOverrideInformation
  • SetClientData() : vtkOldStyleCallbackCommand, vtkCallbackCommand
  • SetClientDataDeleteCallback() : vtkOldStyleCallbackCommand, vtkCallbackCommand
  • SetClipData() : vtkImageClip
  • SetClipExtent() : vtkPOPReader
  • SetClipFunction() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • SetClipping() : vtkBandedPolyDataContourFilter
  • SetClippingPlanes() : vtkAbstractMapper
  • SetClippingRange() : vtkCamera
  • SetClipRegion() : vtkVideoSource
  • SetClosed() : vtkSpline
  • SetClosestPoint() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetCloseSurface() : vtkRuledSurfaceFilter
  • SetCloseValue() : vtkImageOpenClose3D
  • SetCoefficients() : vtkQuadric
  • SetColor() : vtkVolumeProperty, vtkProperty, vtkLight, vtkPLYWriter, vtkGlyphSource2D, vtkProperty2D
  • SetColorByPiece() : vtkPolyDataStreamer
  • SetColorGlyphs() : vtkTensorGlyph
  • SetColoring() : vtkFeatureEdges
  • SetColorLevel() : vtkImageViewer2, vtkImageViewer, vtkImageMapper
  • SetColorMode() : vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkCGMWriter, vtkImageToPolyDataFilter, vtkProgrammableGlyphFilter, vtkGlyph3D
  • SetColorModeToColorByInput() : vtkProgrammableGlyphFilter
  • SetColorModeToColorByScalar() : vtkGlyph3D
  • SetColorModeToColorByScale() : vtkGlyph3D
  • SetColorModeToColorBySource() : vtkProgrammableGlyphFilter
  • SetColorModeToColorByVector() : vtkGlyph3D
  • SetColorModeToDefault() : vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkCGMWriter
  • SetColorModeToLinear256() : vtkImageToPolyDataFilter
  • SetColorModeToLUT() : vtkImageToPolyDataFilter
  • SetColorModeToMapScalars() : vtkPolyDataMapper2D, vtkMapper
  • SetColorModeToOff() : vtkPLYWriter
  • SetColorModeToRandomColors() : vtkCGMWriter
  • SetColorModeToSpecifiedColor() : vtkCGMWriter
  • SetColorModeToUniformCellColor() : vtkPLYWriter
  • SetColorModeToUniformColor() : vtkPLYWriter
  • SetColorModeToUniformPointColor() : vtkPLYWriter
  • SetColorRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetColorSpace() : vtkColorTransferFunction
  • SetColorSpaceToHSV() : vtkColorTransferFunction
  • SetColorSpaceToRGB() : vtkColorTransferFunction
  • SetColorWindow() : vtkImageViewer2, vtkImageViewer, vtkImageMapper
  • SetCommunicator() : vtkSocketController, vtkMPIController
  • SetComponent() : vtkPLYWriter, vtkBlankStructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTensor, vtkShortArray, vtkLongArray, vtkIntArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • SetComponentBlendMode() : vtkVolumeMapper
  • SetComponentBlendModeToAdd() : vtkVolumeMapper
  • SetComponentBlendModeToMaxOpacity() : vtkVolumeMapper
  • SetComponentExtent() : vtkImageAccumulate
  • SetComponentOrigin() : vtkImageAccumulate
  • SetComponents() : vtkImageExtractComponents
  • SetComponentSpacing() : vtkImageAccumulate
  • SetCompositeMethod() : vtkVolumeRayCastCompositeFunction
  • SetCompositeMethodToClassifyFirst() : vtkVolumeRayCastCompositeFunction
  • SetCompositeMethodToInterpolateFirst() : vtkVolumeRayCastCompositeFunction
  • SetCompoundThreshold() : vtkImageBlend
  • SetComputeCellNormals() : vtkPolyDataNormals
  • SetComputeEffectiveStress() : vtkPointLoad
  • SetComputeGradientMagnitudes() : vtkEncodedGradientEstimator
  • SetComputeGradients() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • SetComputeNormals() : vtkSynchronizedTemplates3D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkSampleFunction, vtk3DSImporter, vtkContourGrid, vtkContourFilter, vtkAxes
  • SetComputePointNormals() : vtkPolyDataNormals
  • SetComputeScalars() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkContourGrid, vtkContourFilter
  • SetConeAngle() : vtkLight
  • SetConfigureMethod() : vtkInteractorStyleUser
  • SetConfigureMethodArgDelete() : vtkInteractorStyleUser
  • SetConnectedValue() : vtkImageConnector
  • SetConsiderAnisotropy() : vtkImageEuclideanDistance
  • SetConsistency() : vtkPolyDataNormals
  • SetConstant() : vtkImageLogarithmicScale, vtkImageConstantPad
  • SetConstantC() : vtkImageMathematics
  • SetConstantK() : vtkImageMathematics
  • SetConstantSize() : vtkImageMandelbrotSource
  • SetContextId() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • SetContrastLevel() : vtkMILVideoSource
  • SetControlKey() : vtkRenderWindowInteractor
  • SetController() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkOutputPort, vtkInputPort, vtkCompositeManager
  • SetConvergence() : vtkSmoothPolyDataFilter
  • SetConvertLinesToPoints() : vtkCleanPolyData
  • SetConvertPolysToLines() : vtkCleanPolyData
  • SetConvertStripsToPolys() : vtkCleanPolyData
  • SetCoolDownRate() : vtkGraphLayoutFilter
  • SetCoordinateSystem() : vtkCoordinate
  • SetCoordinateSystemToDisplay() : vtkCoordinate
  • SetCoordinateSystemToNormalizedDisplay() : vtkCoordinate
  • SetCoordinateSystemToNormalizedViewport() : vtkCoordinate
  • SetCoordinateSystemToView() : vtkCoordinate
  • SetCoordinateSystemToViewport() : vtkCoordinate
  • SetCoordinateSystemToWorld() : vtkCoordinate
  • SetCopyAttribute() : vtkDataSetAttributes
  • SetCopyCellData() : vtkQuadricClustering
  • SetCopyNormals() : vtkDataSetAttributes
  • SetCopyScalars() : vtkDataSetAttributes
  • SetCopyTCoords() : vtkDataSetAttributes
  • SetCopyTensors() : vtkDataSetAttributes
  • SetCopyVectors() : vtkDataSetAttributes
  • SetCornerFactor() : vtkOutlineCornerSource, vtkOutlineCornerFilter
  • SetCornerOffset() : vtkCubeAxesActor2D
  • SetCorners() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetCreateGhostCells() : vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece
  • SetCropping() : vtkVolumeMapper
  • SetCroppingRegionFlags() : vtkVolumeMapper
  • SetCroppingRegionFlagsToCross() : vtkVolumeMapper
  • SetCroppingRegionFlagsToFence() : vtkVolumeMapper
  • SetCroppingRegionFlagsToInvertedCross() : vtkVolumeMapper
  • SetCroppingRegionFlagsToInvertedFence() : vtkVolumeMapper
  • SetCroppingRegionFlagsToSubVolume() : vtkVolumeMapper
  • SetCroppingRegionPlanes() : vtkVolumeMapper
  • SetCross() : vtkGlyphSource2D
  • SetCurrentStyle() : vtkInteractorStyleSwitch
  • SetCursor() : vtkVolumeProMapper
  • SetCursorPosition() : vtkVolumeProMapper, vtkImageCursor3D
  • SetCursorRadius() : vtkImageCursor3D
  • SetCursorType() : vtkVolumeProMapper
  • SetCursorTypeToCrossHair() : vtkVolumeProMapper
  • SetCursorTypeToPlane() : vtkVolumeProMapper
  • SetCursorValue() : vtkImageCursor3D
  • SetCursorXAxisColor() : vtkVolumeProMapper
  • SetCursorYAxisColor() : vtkVolumeProMapper
  • SetCursorZAxisColor() : vtkVolumeProMapper
  • SetCustomDisplayExtents() : vtkImageMapper
  • SetCutFunction() : vtkCutter
  • SetCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • SetCutPlane() : vtkVolumeProMapper
  • SetCutPlaneEquation() : vtkVolumeProMapper
  • SetCutPlaneFallOffDistance() : vtkVolumeProMapper
  • SetCutPlaneThickness() : vtkVolumeProMapper
  • SetCylinderClip() : vtkEncodedGradientEstimator
  • SetDash() : vtkGlyphSource2D
  • SetDashFactor() : vtkDashedStreamLine
  • SetData() : vtkPoints
  • SetDataByteOrder() : vtkVolume16Reader, vtkPLYWriter, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SetDataByteOrderToBigEndian() : vtkVolume16Reader, vtkPLYWriter, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SetDataByteOrderToLittleEndian() : vtkVolume16Reader, vtkPLYWriter, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SetDataDimensions() : vtkVolume16Reader
  • SetDataExtent() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataExtentCallback() : vtkImageImport
  • SetDataExtentToWholeExtent() : vtkImageImport
  • SetDataMask() : vtkVolume16Reader, vtkImageReader
  • SetDataObject() : vtkMergeDataObjectFilter
  • SetDataObjectPlotMode() : vtkXYPlotActor
  • SetDataObjectPlotModeToColumns() : vtkXYPlotActor
  • SetDataObjectPlotModeToRows() : vtkXYPlotActor
  • SetDataObjectXComponent() : vtkXYPlotActor
  • SetDataObjectYComponent() : vtkXYPlotActor
  • SetDataOrigin() : vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkVideoSource
  • SetDataScalarType() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataScalarTypeToDouble() : vtkImageReader2, vtkImageImport
  • SetDataScalarTypeToFloat() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataScalarTypeToInt() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataScalarTypeToShort() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataScalarTypeToUnsignedChar() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataScalarTypeToUnsignedShort() : vtkImageReader2, vtkImageImport, vtkImageGridSource
  • SetDataSet() : vtkScalarTree, vtkImplicitDataSet, vtkLocator, vtkInterpolatedVelocityField
  • SetDataSetType() : vtkDataObjectToDataSetFilter
  • SetDataSetTypeToPolyData() : vtkDataObjectToDataSetFilter
  • SetDataSetTypeToRectilinearGrid() : vtkDataObjectToDataSetFilter
  • SetDataSetTypeToStructuredGrid() : vtkDataObjectToDataSetFilter
  • SetDataSetTypeToStructuredPoints() : vtkDataObjectToDataSetFilter
  • SetDataSetTypeToUnstructuredGrid() : vtkDataObjectToDataSetFilter
  • SetDataSpacing() : vtkVolumeReader, vtkImageReader2, vtkImageImport, vtkImageGridSource, vtkVideoSource
  • SetDataType() : vtkPoints
  • SetDataTypeToBit() : vtkPoints
  • SetDataTypeToChar() : vtkPoints
  • SetDataTypeToDouble() : vtkPoints
  • SetDataTypeToFloat() : vtkPoints
  • SetDataTypeToInt() : vtkPoints
  • SetDataTypeToLong() : vtkPoints
  • SetDataTypeToShort() : vtkPoints
  • SetDataTypeToUnsignedChar() : vtkPoints
  • SetDataTypeToUnsignedInt() : vtkPoints
  • SetDataTypeToUnsignedLong() : vtkPoints
  • SetDataTypeToUnsignedShort() : vtkPoints
  • SetDataVOI() : vtkImageReader
  • SetDate() : vtkMedicalImageReader2
  • SetDebug() : vtkObject
  • SetDecimation() : vtkImageToPolyDataFilter
  • SetDecimationError() : vtkImageToPolyDataFilter
  • SetDefaultBias() : vtkKochanekSpline
  • SetDefaultContinuity() : vtkKochanekSpline
  • SetDefaultNormal() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • SetDefaultNormalize() : vtkFieldDataToAttributeDataFilter, vtkDataObjectToDataSetFilter
  • SetDefaultTension() : vtkKochanekSpline
  • SetDefaultZ() : vtkImageCanvasSource2D
  • SetDegree() : vtkDecimate, vtkDecimatePro
  • SetDeltaRadius() : vtkRotationalExtrusionFilter
  • SetDepth() : vtkButtonSource
  • SetDepthSortMode() : vtkDepthSortPolyData
  • SetDepthSortModeToBoundsCenter() : vtkDepthSortPolyData
  • SetDepthSortModeToFirstPoint() : vtkDepthSortPolyData
  • SetDepthSortModeToParametricCenter() : vtkDepthSortPolyData
  • SetDepthValues() : vtkRendererSource
  • SetDescription() : vtkMPIEventLog, vtkOverrideInformation
  • SetDesiredUpdateRate() : vtkRenderWindowInteractor, vtkRenderWindow
  • SetDeviceContext() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • SetDiceMode() : vtkDicer
  • SetDiceModeToMemoryLimitPerPiece() : vtkDicer
  • SetDiceModeToNumberOfPointsPerPiece() : vtkDicer
  • SetDiceModeToSpecifiedNumberOfPieces() : vtkDicer
  • SetDiffuse() : vtkVolumeProperty, vtkProperty
  • SetDiffuseColor() : vtkProperty
  • SetDiffusionFactor() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetDiffusionThreshold() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetDilateValue() : vtkImageDilateErode3D
  • SetDimensionality() : vtkImageSeedConnectivity, vtkImageResample, vtkImageNonMaximumSuppression, vtkImageLaplacian, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSmooth, vtkImageDecomposeFilter, vtkImageCorrelation
  • SetDimensions() : vtkDataObjectToDataSetFilter, vtkStructuredGrid, vtkStructuredData, vtkRectilinearGrid, vtkImageData
  • SetDimensionsComponent() : vtkDataObjectToDataSetFilter
  • SetDirection() : vtkImageSinusoidSource, vtkDepthSortPolyData
  • SetDirectionAngle() : vtkLight
  • SetDirectionEncoder() : vtkEncodedGradientEstimator
  • SetDirectionToBackToFront() : vtkDepthSortPolyData
  • SetDirectionToFrontToBack() : vtkDepthSortPolyData
  • SetDirectionToSpecifiedVector() : vtkDepthSortPolyData
  • SetDisableMotion() : vtkInteractorStyleFlight
  • SetDisplacementFileName() : vtkBYUWriter, vtkBYUReader
  • SetDisplacementGrid() : vtkGridTransform
  • SetDisplacementScale() : vtkGridTransform
  • SetDisplacementShader() : vtkRIBProperty
  • SetDisplacementShift() : vtkGridTransform
  • SetDisplayExtent() : vtkImageActor
  • SetDisplayId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkWindow
  • SetDisplayLocation() : vtkProperty2D
  • SetDisplayLocationToBackground() : vtkProperty2D
  • SetDisplayLocationToForeground() : vtkProperty2D
  • SetDisplayPoint() : vtkViewport
  • SetDisplayPosition() : vtkActor2D
  • SetDistance() : vtkCamera, vtkDividingCubes, vtkRecursiveDividingCubes
  • SetDistanceFactor() : vtkRuledSurfaceFilter
  • SetDistribution() : vtkPointSource
  • SetDistributionToShell() : vtkPointSource
  • SetDistributionToUniform() : vtkPointSource
  • SetDivideByZeroToC() : vtkImageMathematics
  • SetDivisionOrigin() : vtkQuadricClustering
  • SetDivisions() : vtkImageBlockWriter, vtkImageBlockReader, vtkPointLocator2D, vtkPointLocator
  • SetDivisionSpacing() : vtkQuadricClustering
  • SetDolly() : vtkRenderWindowInteractor
  • SetDoubleBuffer() : vtkWindow
  • SetDoUpdateInformation() : vtkInputPort
  • SetDPI() : vtkWindow
  • SetDragable() : vtkProp
  • SetDrawColor() : vtkImageCanvasSource2D
  • SetEccentricity() : vtkGaussianSplatter
  • SetEdgeAngle() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetEdgeColor() : vtkProperty
  • SetEdges() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetEdgeVisibility() : vtkProperty
  • SetElement() : vtkMatrix4x4
  • SetEnableFlag() : vtkObjectFactory
  • SetEndMethod() : vtkProcessObject
  • SetEndMethodArgDelete() : vtkProcessObject
  • SetEndPhi() : vtkSphereSource
  • SetEndPickMethod() : vtkRenderWindowInteractor, vtkAbstractPicker
  • SetEndPickMethodArgDelete() : vtkRenderWindowInteractor, vtkAbstractPicker
  • SetEndPiece() : vtkPDataSetWriter
  • SetEndRenderMethod() : vtkViewport
  • SetEndRenderMethodArgDelete() : vtkViewport
  • SetEndTheta() : vtkSphereSource
  • SetEndWrite() : vtkExporter
  • SetEndWriteArgDelete() : vtkExporter
  • SetEnterMethod() : vtkInteractorStyleUser
  • SetEnterMethodArgDelete() : vtkInteractorStyleUser
  • SetEntry() : vtkLegendBoxActor
  • SetEntryColor() : vtkLegendBoxActor
  • SetEntryString() : vtkLegendBoxActor
  • SetEntrySymbol() : vtkLegendBoxActor
  • SetErase() : vtkWindow
  • SetErodeValue() : vtkImageDilateErode3D
  • SetError() : vtkImageToPolyDataFilter, vtkNonLinearCell
  • SetErrorCode() : vtkSource
  • SetErrorIncrement() : vtkDecimate
  • SetErrorIsAbsolute() : vtkDecimatePro
  • SetEstimatedRenderTime() : vtkProp
  • SetEventInformation() : vtkRenderWindowInteractor
  • SetEventPosition() : vtkRenderWindowInteractor
  • SetExchangeAxes() : vtkXYPlotActor
  • SetExecuteMethod() : vtkProgrammableSource, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter
  • SetExecuteMethodArgDelete() : vtkProgrammableSource, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter
  • SetExitMethod() : vtkRenderWindowInteractor
  • SetExitMethodArgDelete() : vtkRenderWindowInteractor
  • SetExponent() : vtkLight
  • SetExponentFactor() : vtkGaussianSplatter
  • SetExportArrays() : vtkRIBExporter
  • SetExportVoidPointer() : vtkImageExport
  • SetExtent() : vtkImageStencilData, vtkImageCanvasSource2D, vtkStructuredGridGeometryFilter, vtkRectilinearGridGeometryFilter, vtkImageDataGeometryFilter, vtkGeometryFilter, vtkExtractUnstructuredGrid, vtkStructuredGrid, vtkStructuredData, vtkRectilinearGrid, vtkImageData, vtkExtentTranslator
  • SetExtentClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetExtentTranslation() : vtkImageChangeInformation
  • SetExtentTranslator() : vtkImageDataStreamer, vtkDataObject
  • SetExtractBoundaryCells() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • SetExtractEigenvalues() : vtkTensorGlyph
  • SetExtractInside() : vtkExtractPolyDataGeometry, vtkExtractGeometry
  • SetExtractionMode() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToAllRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToCellSeededRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToClosestPointRegion() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToLargestRegion() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToPointSeededRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractionModeToSpecifiedRegions() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetExtractNormals() : vtkExtractTensorComponents
  • SetExtractScalars() : vtkExtractTensorComponents
  • SetExtractTCoords() : vtkExtractTensorComponents
  • SetExtractToFieldData() : vtkExtractVectorComponents
  • SetExtractVectors() : vtkExtractTensorComponents
  • SetExtrusionPoint() : vtkLinearExtrusionFilter
  • SetExtrusionType() : vtkLinearExtrusionFilter
  • SetExtrusionTypeToNormalExtrusion() : vtkLinearExtrusionFilter
  • SetExtrusionTypeToPointExtrusion() : vtkLinearExtrusionFilter
  • SetExtrusionTypeToVectorExtrusion() : vtkLinearExtrusionFilter
  • SetEyeAngle() : vtkCamera
  • SetFaces() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetFDFrames() : vtkRenderWindow
  • SetFeatureAngle() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter, vtkPolyDataNormals, vtkFeatureEdges, vtkDecimatePro
  • SetFeatureAngleIncrement() : vtkDecimate
  • SetFeatureEdges() : vtkFeatureEdges
  • SetFeatureEdgeSmoothing() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetFeaturePointsAngle() : vtkQuadricClustering
  • SetFieldData() : vtkIdFilter, vtkDicer, vtkDataSetToDataObjectFilter, vtkDataObject
  • SetFieldDataArray() : vtkLabeledDataMapper, vtkArcPlotter
  • SetFieldDataName() : vtkDataWriter, vtkDataReader, vtkDataObjectWriter
  • SetFileDimensionality() : vtkImageWriter, vtkImageReader2
  • SetFileFormat() : vtkPLOT3DReader
  • SetFileLowerLeft() : vtkImageReader2
  • SetFileName() : vtkVRMLExporter, vtkOOGLExporter, vtkIVExporter, vtkImageWindow, vtkSliceCubes, vtkPOPReader, vtkPDataSetReader, vtkUGFacetReader, vtkSTLReader, vtkSLCReader, vtkPLYReader, vtkParticleReader, vtkOBJReader, vtkMCubesReader, vtkImageWriter, vtkImageReader2, vtkDEMReader, vtkDataWriter, vtkDataReader, vtkDataObjectWriter, vtkVRMLImporter, vtk3DSImporter, vtkFileOutputWindow
  • SetFileNameSliceOffset() : vtkImageReader2
  • SetFileNameSliceSpacing() : vtkImageReader2
  • SetFilePath() : vtkGenericEnSightReader, vtkEnSightReader
  • SetFilePattern() : vtkPDataSetWriter, vtkImageBlockWriter, vtkImageBlockReader, vtkVolumeReader, vtkImageWriter, vtkImageReader2
  • SetFilePointer() : vtkVRMLExporter
  • SetFilePrefix() : vtkOBJExporter, vtkVolumeReader, vtkImageWriter, vtkImageReader2, vtkRIBExporter
  • SetFileType() : vtkDataWriter, vtkDataObjectWriter
  • SetFileTypeToASCII() : vtkDataWriter, vtkDataObjectWriter
  • SetFileTypeToBinary() : vtkDataWriter, vtkDataObjectWriter
  • SetFilled() : vtkGlyphSource2D
  • SetFillLightAngle() : vtkLightKit
  • SetFillLightAzimuth() : vtkLightKit
  • SetFillLightElevation() : vtkLightKit
  • SetFillLightWarmth() : vtkLightKit
  • SetFillValue() : vtkSweptSurface, vtkImageGridSource
  • SetFilteredAxes() : vtkImagePermute, vtkImageFlip, vtkImageDecomposeFilter
  • SetFilteredAxis() : vtkImageFlip
  • SetFixedUpVector() : vtkInteractorStyleFlight
  • SetFixUpVector() : vtkInteractorStyleFlight
  • SetFlipNormals() : vtkMCubesReader, vtkPolyDataNormals
  • SetFlipR() : vtkTransformTextureCoords
  • SetFlipS() : vtkTransformTextureCoords
  • SetFlipT() : vtkTransformTextureCoords
  • SetFlipTexture() : vtkImplicitTextureCoords
  • SetFlush() : vtkFileOutputWindow
  • SetFlyMode() : vtkCubeAxesActor2D
  • SetFlyModeToClosestTriad() : vtkCubeAxesActor2D
  • SetFlyModeToOuterEdges() : vtkCubeAxesActor2D
  • SetFocalDisk() : vtkCamera
  • SetFocalPoint() : vtkLight, vtkCamera, vtkProjectedTexture, vtkCursor3D
  • SetFontFactor() : vtkAxisActor2D, vtkCubeAxesActor2D
  • SetFontFamily() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetFontFamilyToArial() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetFontFamilyToCourier() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetFontFamilyToTimes() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetFontSize() : vtkXTextMapper, vtkTextMapper, vtkLabeledDataMapper, vtkAxisActor2D
  • SetForceDeepCopy() : vtkMultiProcessController
  • SetForegroundColor() : vtkTextSource
  • SetFormatHeight() : vtkWarpLens
  • SetFormatWidth() : vtkWarpLens
  • SetFrameBufferSize() : vtkVideoSource
  • SetFrameCount() : vtkVideoSource
  • SetFrameRate() : vtkWin32VideoSource, vtkVideoSource
  • SetFrameSize() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • SetFrequency() : vtkPerlinNoise
  • SetFrontfaceCulling() : vtkProperty
  • SetFrustumPlanes() : vtkPlanes
  • SetFullScreen() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindow, vtkQuartzRenderWindow
  • SetFunction() : vtkArrayCalculator, vtkFunctionParser
  • SetFunctionFileName() : vtkPLOT3DReader
  • SetFunctionSet() : vtkInitialValueProblemSolver
  • SetFunctionWeight() : vtkImplicitSum
  • SetGamma() : vtkPLOT3DReader
  • SetGenerateClippedOutput() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • SetGenerateClipScalars() : vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • SetGenerateContourEdges() : vtkBandedPolyDataContourFilter
  • SetGenerateCutScalars() : vtkCutter
  • SetGenerateErrorScalars() : vtkDecimate, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetGenerateErrorVectors() : vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetGeneratePointIds() : vtkGlyph3D
  • SetGenerateSelectionScalars() : vtkSelectPolyData
  • SetGenerateUnselectedOutput() : vtkSelectPolyData
  • SetGenerateVertices() : vtkMaskPoints
  • SetGeometry() : vtkMergeFilter, vtkDataSetToDataObjectFilter
  • SetGeometryFileName() : vtkGenericEnSightReader, vtkEnSightReader, vtkEnSightGoldReader, vtkBYUWriter, vtkBYUReader
  • SetGhostLevel() : vtkPolyDataMapper, vtkPDataSetWriter, vtkExtentTranslator
  • SetGlobalController() : vtkMultiProcessController
  • SetGlobalDefaultNumberOfThreads() : vtkMultiThreader
  • SetGlobalImmediateModeRendering() : vtkMapper
  • SetGlobalMaximumNumberOfMultiSamples() : vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • SetGlobalMaximumNumberOfThreads() : vtkMultiThreader
  • SetGlobalRef() : vtkJavaCommand
  • SetGlobalReleaseDataFlag() : vtkDataObject
  • SetGlobalWarningDisplay() : vtkObject
  • SetGlyphMethod() : vtkProgrammableGlyphFilter
  • SetGlyphMethodArgDelete() : vtkProgrammableGlyphFilter
  • SetGlyphSize() : vtkXYPlotActor
  • SetGlyphType() : vtkGlyphSource2D
  • SetGlyphTypeToArrow() : vtkGlyphSource2D
  • SetGlyphTypeToCircle() : vtkGlyphSource2D
  • SetGlyphTypeToCross() : vtkGlyphSource2D
  • SetGlyphTypeToDash() : vtkGlyphSource2D
  • SetGlyphTypeToDiamond() : vtkGlyphSource2D
  • SetGlyphTypeToHookedArrow() : vtkGlyphSource2D
  • SetGlyphTypeToNone() : vtkGlyphSource2D
  • SetGlyphTypeToSquare() : vtkGlyphSource2D
  • SetGlyphTypeToThickArrow() : vtkGlyphSource2D
  • SetGlyphTypeToThickCross() : vtkGlyphSource2D
  • SetGlyphTypeToTriangle() : vtkGlyphSource2D
  • SetGlyphTypeToVertex() : vtkGlyphSource2D
  • SetGradientDiffuseModulation() : vtkVolumeProMapper
  • SetGradientEstimator() : vtkVolumeTextureMapper, vtkVolumeRayCastMapper
  • SetGradientMagnitudeBias() : vtkEncodedGradientEstimator
  • SetGradientMagnitudeScale() : vtkEncodedGradientEstimator
  • SetGradientMagnitudeThreshold() : vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D
  • SetGradientOpacity() : vtkVolumeProperty
  • SetGradientOpacityModulation() : vtkVolumeProMapper
  • SetGradientSpecularModulation() : vtkVolumeProMapper
  • SetGradientThreshold() : vtkLinkEdgels
  • SetGradMaps() : vtkSubPixelPositionEdgels
  • SetGraphBounds() : vtkGraphLayoutFilter
  • SetGrayScaleHint() : vtkImageWindow, vtkImageViewer
  • SetGridExtent() : vtkTransformToGrid
  • SetGridFileName() : vtkPOPReader
  • SetGridName() : vtkPOPReader
  • SetGridNumber() : vtkPLOT3DReader
  • SetGridOrigin() : vtkImageGridSource, vtkTransformToGrid
  • SetGridScalarType() : vtkTransformToGrid
  • SetGridScalarTypeToChar() : vtkTransformToGrid
  • SetGridScalarTypeToFloat() : vtkTransformToGrid
  • SetGridScalarTypeToShort() : vtkTransformToGrid
  • SetGridScalarTypeToUnsignedChar() : vtkTransformToGrid
  • SetGridScalarTypeToUnsignedShort() : vtkTransformToGrid
  • SetGridSpacing() : vtkImageGridSource, vtkTransformToGrid
  • SetGroup() : vtkMPICommunicator
  • SetHandleBoundaries() : vtkImageNonMaximumSuppression, vtkImageGradientMagnitude, vtkImageGradient
  • SetHandleObservers() : vtkInteractorStyle
  • SetHeader() : vtkDataWriter, vtkDataObjectWriter
  • SetHeaderSize() : vtkVolume16Reader, vtkMCubesReader, vtkImageReader2
  • SetHeadlightWarmth() : vtkLightKit
  • SetHeight() : vtkArcPlotter, vtkCylinderSource, vtkConeSource, vtkButtonSource, vtkActor2D
  • SetHighPoint() : vtkElevationFilter
  • SetHueLevel() : vtkMILVideoSource
  • SetHueRange() : vtkLookupTable
  • SetId() : vtkIdList
  • SetIdsArrayName() : vtkIdFilter
  • SetImage() : vtkImageDifference
  • SetImageData() : vtkImageCanvasSource2D
  • SetImageHeight() : vtkWarpLens
  • SetImageInput() : vtkImageMask
  • SetImageLowerLeft() : vtkImageExport
  • SetImageNumber() : vtkMedicalImageReader2
  • SetImageRange() : vtkMarchingSquares, vtkVolumeReader
  • SetImageSampleDistance() : vtkVolumeRayCastMapper
  • SetImageScale() : vtkRayCaster
  • SetImageWidth() : vtkWarpLens
  • SetImageWindow() : vtkImager
  • SetImmediateModeRendering() : vtkMapper
  • SetImplicitFunction() : vtkSampleFunction, vtkExtractPolyDataGeometry, vtkExtractGeometry, vtkImplicitWindowFunction
  • SetImportVoidPointer() : vtkImageImport
  • SetInAbortCheck() : vtkRenderWindow
  • SetIncludeBoundary() : vtkExtractGrid
  • SetIncrement() : vtkDividingCubes, vtkRecursiveDividingCubes
  • SetIndependentComponents() : vtkVolumeMapper
  • SetIndependentVariables() : vtkParallelCoordinatesActor
  • SetIndependentVariablesToColumns() : vtkParallelCoordinatesActor
  • SetIndependentVariablesToRows() : vtkParallelCoordinatesActor
  • SetIndexMode() : vtkGlyph3D
  • SetIndexModeToOff() : vtkGlyph3D
  • SetIndexModeToScalar() : vtkGlyph3D
  • SetIndexModeToVector() : vtkGlyph3D
  • SetInertia() : vtkCubeAxesActor2D
  • SetInflectionPointRatio() : vtkDecimatePro
  • SetInformationInput() : vtkImageReslice, vtkImageChangeInformation
  • SetInIn() : vtkBooleanTexture
  • SetInitialError() : vtkDecimate
  • SetInitialFeatureAngle() : vtkDecimate
  • SetInitialize() : vtkImageEuclideanDistance
  • SetInitializeExecuteTime() : vtkImageQuantizeRGBToIndex
  • SetInnerRadius() : vtkDiskSource
  • SetInOn() : vtkBooleanTexture
  • SetInOut() : vtkBooleanTexture
  • SetInput() : vtkWindowToImageFilter, vtkVolumeMapper, vtkTexture, vtkTextMapper, vtkRendererSource, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor, vtkExporter, vtkEncodedGradientEstimator, vtkDataSetMapper, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkImageMarchingCubes, vtkOutputPort, vtkImageBlockWriter, vtkUnstructuredGridWriter, vtkStructuredPointsWriter, vtkStructuredGridWriter, vtkRectilinearGridWriter, vtkPolyDataWriter, vtkImageWriter, vtkDataSetWriter, vtkDataObjectWriter, vtkImplicitFunctionToImageStencil, vtkImageToImageStencil, vtkImageOpenClose3D, vtkImageExport, vtkImageDifference, vtkTransformToGrid, vtkRenderLargeImage, vtkProcrustesAlignmentFilter, vtkPolyDataToImageStencil, vtkPCAAnalysisFilter, vtkCubeAxesActor2D, vtkSpatialRepresentationFilter, vtkMassProperties, vtkExtractVectorComponents, vtkDelaunay3D, vtkDelaunay2D, vtkDataSetToDataObjectFilter, vtkDataObjectToDataSetFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkUnstructuredGridToPolyDataFilter, vtkStructuredPointsToUnstructuredGridFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToPolyDataFilter, vtkStructuredGridToStructuredGridFilter, vtkStructuredGridToPolyDataFilter, vtkSimpleImageToImageFilter, vtkRectilinearGridToPolyDataFilter, vtkPolyDataToPolyDataFilter, vtkPointSetToPointSetFilter, vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkDataSetToUnstructuredGridFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToStructuredGridFilter, vtkDataSetToPolyDataFilter, vtkDataSetToDataSetFilter, vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkGeneralTransform
  • SetInput1() : vtkImageAppendComponents, vtkImageTwoInputFilter
  • SetInput2() : vtkImageAppendComponents, vtkImageTwoInputFilter
  • SetInputArray() : vtkDataReader
  • SetInputByNumber() : vtkAppendPolyData
  • SetInputConnectValue() : vtkImageSeedConnectivity
  • SetInputField() : vtkSplitField, vtkFieldDataToAttributeDataFilter
  • SetInputFieldToCellDataField() : vtkFieldDataToAttributeDataFilter
  • SetInputFieldToDataObjectField() : vtkFieldDataToAttributeDataFilter
  • SetInputFieldToPointDataField() : vtkFieldDataToAttributeDataFilter
  • SetInputMemoryLimit() : vtkSynchronizedTemplates3D, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkImageToImageFilter
  • SetInputScalarsSelection() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkGridSynchronizedTemplates3D, vtkWarpScalar, vtkThreshold, vtkContourGrid, vtkContourFilter, vtkClipDataSet
  • SetInputString() : vtkDataReader
  • SetInputVectorsSelection() : vtkWarpVector
  • SetInsideOut() : vtkSelectPolyData, vtkClipVolume, vtkClipPolyData, vtkClipDataSet
  • SetInstallMessageProc() : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • SetInstance() : vtkOutputWindow
  • SetIntegrationDirection() : vtkStreamer, vtkHyperStreamline
  • SetIntegrationDirectionToBackward() : vtkStreamer, vtkHyperStreamline
  • SetIntegrationDirectionToForward() : vtkStreamer, vtkHyperStreamline
  • SetIntegrationDirectionToIntegrateBothDirections() : vtkStreamer, vtkHyperStreamline
  • SetIntegrationStepLength() : vtkStreamer, vtkHyperStreamline
  • SetIntegrator() : vtkStreamer
  • SetIntensity() : vtkLight
  • SetInteractive() : vtkRenderer
  • SetInteractor() : vtkRenderWindow, vtkInteractorStyleSwitch, vtkInteractorStyle
  • SetInteractorStyle() : vtkRenderWindowInteractor
  • SetIntermixIntersectingGeometry() : vtkVolumeRayCastMapper, vtkVolumeProMapper
  • SetInterp() : vtkTclCommand
  • SetInterpolate() : vtkTexture, vtkImageActor, vtkImageReslice, vtkImageResample, vtkImageMagnify
  • SetInterpolation() : vtkProperty
  • SetInterpolationMode() : vtkImageReslice, vtkGridTransform
  • SetInterpolationModeToCubic() : vtkImageReslice, vtkGridTransform
  • SetInterpolationModeToLinear() : vtkImageReslice, vtkGridTransform
  • SetInterpolationModeToNearestNeighbor() : vtkImageReslice, vtkGridTransform
  • SetInterpolationToFlat() : vtkProperty
  • SetInterpolationToGouraud() : vtkProperty
  • SetInterpolationToPhong() : vtkProperty
  • SetInterpolationType() : vtkVolumeProperty
  • SetInterpolationTypeToLinear() : vtkVolumeProperty
  • SetInterpolationTypeToNearest() : vtkVolumeProperty
  • SetInTextureCoord() : vtkThresholdTextureCoords
  • SetInValue() : vtkImageThreshold, vtkImageEllipsoidSource
  • SetInverse() : vtkAbstractTransform
  • SetInverseIterations() : vtkWarpTransform
  • SetInverseTolerance() : vtkWarpTransform
  • SetInverseVideo() : vtkWindowLevelLookupTable
  • SetIslandValue() : vtkImageIslandRemoval2D
  • SetIsoValue() : vtkVolumeRayCastIsosurfaceFunction
  • SetItalic() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetItem() : vtkAbstractList< DType >
  • SetItemNoCheck() : vtkAbstractList< DType >
  • SetJustification() : vtkTextMapper, vtkCaptionActor2D
  • SetJustificationToCentered() : vtkTextMapper, vtkCaptionActor2D
  • SetJustificationToLeft() : vtkTextMapper, vtkCaptionActor2D
  • SetJustificationToRight() : vtkTextMapper, vtkCaptionActor2D
  • SetK1() : vtkWarpLens
  • SetK2() : vtkWarpLens
  • SetKappa() : vtkWarpLens
  • SetKeepHandle() : vtkMPICommunicator
  • SetKernel() : vtkImageConvolve
  • SetKernel3x3() : vtkImageConvolve
  • SetKernel3x3x3() : vtkImageConvolve
  • SetKernel5x5() : vtkImageConvolve
  • SetKernel5x5x5() : vtkImageConvolve
  • SetKernel7x7() : vtkImageConvolve
  • SetKernel7x7x7() : vtkImageConvolve
  • SetKernelSize() : vtkImageVariance3D, vtkImageRange3D, vtkImageOpenClose3D, vtkImageMedian3D, vtkImageDilateErode3D, vtkImageContinuousErode3D, vtkImageContinuousDilate3D
  • SetKeyCode() : vtkRenderWindowInteractor
  • SetKeyLightAngle() : vtkLightKit
  • SetKeyLightAzimuth() : vtkLightKit
  • SetKeyLightElevation() : vtkLightKit
  • SetKeyLightIntensity() : vtkLightKit
  • SetKeyLightWarmth() : vtkLightKit
  • SetKeyPressMethod() : vtkInteractorStyleUser
  • SetKeyPressMethodArgDelete() : vtkInteractorStyleUser
  • SetKeyReleaseMethod() : vtkInteractorStyleUser
  • SetKeyReleaseMethodArgDelete() : vtkInteractorStyleUser
  • SetKeySym() : vtkRenderWindowInteractor
  • SetKeyToFillRatio() : vtkLightKit
  • SetKeyToHeadRatio() : vtkLightKit
  • SetLabeledComponent() : vtkLabeledDataMapper
  • SetLabelFactor() : vtkAxisActor2D
  • SetLabelFormat() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkCubeAxesActor2D
  • SetLabelMode() : vtkLabeledDataMapper
  • SetLabelModeToLabelFieldData() : vtkLabeledDataMapper
  • SetLabelModeToLabelIds() : vtkLabeledDataMapper
  • SetLabelModeToLabelNormals() : vtkLabeledDataMapper
  • SetLabelModeToLabelScalars() : vtkLabeledDataMapper
  • SetLabelModeToLabelTCoords() : vtkLabeledDataMapper
  • SetLabelModeToLabelTensors() : vtkLabeledDataMapper
  • SetLabelModeToLabelVectors() : vtkLabeledDataMapper
  • SetLabelVisibility() : vtkAxisActor2D
  • SetLastCellId() : vtkInterpolatedVelocityField
  • SetLatLongTessellation() : vtkSphereSource
  • SetLayer() : vtkRenderer
  • SetLayerNumber() : vtkActor2D
  • SetLeader() : vtkCaptionActor2D
  • SetLeaderGlyph() : vtkCaptionActor2D
  • SetLeaderGlyphSize() : vtkCaptionActor2D
  • SetLeaveMethod() : vtkInteractorStyleUser
  • SetLeaveMethodArgDelete() : vtkInteractorStyleUser
  • SetLeftButtonPressMethod() : vtkInteractorStyle
  • SetLeftButtonPressMethodArgDelete() : vtkInteractorStyle
  • SetLeftButtonReleaseMethod() : vtkInteractorStyle
  • SetLeftButtonReleaseMethodArgDelete() : vtkInteractorStyle
  • SetLeftConstraint() : vtkSpline
  • SetLeftValue() : vtkSpline
  • SetLegend() : vtkXYPlotActor
  • SetLegendPosition() : vtkXYPlotActor
  • SetLegendPosition2() : vtkXYPlotActor
  • SetLevel() : vtkImageMapToWindowLevelColors, vtkWindowLevelLookupTable
  • SetLightFollowCamera() : vtkRenderWindowInteractor, vtkRenderer
  • SetLightType() : vtkLight
  • SetLightTypeToCameraLight() : vtkLight
  • SetLightTypeToHeadlight() : vtkLight
  • SetLightTypeToSceneLight() : vtkLight
  • SetLimitsFileName() : vtkSliceCubes, vtkMCubesWriter, vtkMCubesReader
  • SetLineOffset() : vtkTextMapper
  • SetLines() : vtkPolyData
  • SetLinesComponent() : vtkDataObjectToDataSetFilter
  • SetLineSmoothing() : vtkRenderWindow
  • SetLineSpacing() : vtkTextMapper
  • SetLineStipplePattern() : vtkProperty, vtkProperty2D
  • SetLineStippleRepeatFactor() : vtkProperty, vtkProperty2D
  • SetLineValue() : vtkImageGridSource
  • SetLineWidth() : vtkProperty, vtkProperty2D
  • SetLinkThreshold() : vtkLinkEdgels
  • SetLoadValue() : vtkPointLoad
  • SetLocality() : vtkDataObject
  • SetLocator() : vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkUGFacetReader, vtkSTLReader, vtkMCubesReader, vtkIterativeClosestPointTransform, vtkGeometryFilter, vtkFeatureEdges, vtkExtractUnstructuredGrid, vtkExtractEdges, vtkDelaunay3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData
  • SetLocatorMaxLevel() : vtkImplicitModeller
  • SetLockBorder() : vtkLegendBoxActor
  • SetLODBackfaceProperty() : vtkLODProp3D
  • SetLODLevel() : vtkLODProp3D
  • SetLODMapper() : vtkLODProp3D
  • SetLODProperty() : vtkLODProp3D
  • SetLODTexture() : vtkLODProp3D
  • SetLogScaling() : vtkHyperStreamline
  • SetLogx() : vtkXYPlotActor
  • SetLookupIndexExecuteTime() : vtkImageQuantizeRGBToIndex
  • SetLookupTable() : vtkWin32ImageMapper, vtkTexture, vtkScalarBarActor, vtkPolyDataMapper2D, vtkMapper, vtkPLYWriter, vtkImageMapToColors, vtkImageToPolyDataFilter, vtkDataArray
  • SetLookupTableName() : vtkDataWriter, vtkDataReader
  • SetLoop() : vtkSelectPolyData, vtkImplicitSelectionLoop
  • SetLowerThreshold() : vtkImageToImageStencil
  • SetLowPoint() : vtkElevationFilter
  • SetMagnification() : vtkWindowToImageFilter, vtkRenderLargeImage
  • SetMagnificationFactors() : vtkImageMagnify
  • SetMagnitudeInput() : vtkImageNonMaximumSuppression
  • SetMaintainLuminance() : vtkLightKit
  • SetManifoldEdges() : vtkFeatureEdges
  • SetManual() : vtkCompositeManager
  • SetMapColorScalarsThroughLookupTable() : vtkTexture
  • SetMapped() : vtkWindow
  • SetMapper() : vtkVolume, vtkScaledTextActor, vtkActor, vtkActor2D
  • SetMask() : vtkImageMaskBits
  • SetMaskAlpha() : vtkImageMask
  • SetMaskedOutputValue() : vtkImageMask
  • SetMaskInput() : vtkImageMask
  • SetMasks() : vtkImageMaskBits
  • SetMatchFileName() : vtkEnSightReader, vtkEnSightGoldReader
  • SetMaterial() : vtkCutMaterial
  • SetMaterialArrayName() : vtkCutMaterial
  • SetMatrix() : vtkTransform, vtkPerspectiveTransform, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkAssemblyNode
  • SetMaxBlankingValue() : vtkBlankStructuredGrid
  • SetMaxEntries() : vtkTimerLog
  • SetMaximizeMethod() : vtkVolumeRayCastMIPFunction
  • SetMaximizeMethodToOpacity() : vtkVolumeRayCastMIPFunction
  • SetMaximizeMethodToScalarValue() : vtkVolumeRayCastMIPFunction
  • SetMaximum() : vtkRTAnalyticSource, vtkImageShrink3D, vtkImageRGBToHSV, vtkImageNoiseSource, vtkImageHSVToRGB, vtkImageGaussianSource
  • SetMaximumCollapsedEdges() : vtkQuadricDecimation
  • SetMaximumColor() : vtkWindowLevelLookupTable
  • SetMaximumCost() : vtkQuadricDecimation
  • SetMaximumCoverage() : vtkFrustumCoverageCuller
  • SetMaximumDistance() : vtkVoxelModeller, vtkShepardMethod, vtkImageEuclideanDistance, vtkImplicitModeller
  • SetMaximumError() : vtkDecimate, vtkDecimatePro
  • SetMaximumFeatureAngle() : vtkDecimate
  • SetMaximumImageSampleDistance() : vtkVolumeRayCastMapper
  • SetMaximumIterations() : vtkDecimate
  • SetMaximumLeaderGlyphSize() : vtkCaptionActor2D
  • SetMaximumLength() : vtkStripper
  • SetMaximumLineHeight() : vtkScaledTextActor
  • SetMaximumMeanDistance() : vtkIterativeClosestPointTransform
  • SetMaximumNumberOfColors() : vtkScalarBarActor
  • SetMaximumNumberOfInterpolationSteps() : vtkSweptSurface
  • SetMaximumNumberOfIterations() : vtkImageMandelbrotSource, vtkIterativeClosestPointTransform
  • SetMaximumNumberOfLandmarks() : vtkIterativeClosestPointTransform
  • SetMaximumNumberOfPieces() : vtkDataObject
  • SetMaximumNumberOfPlanes() : vtkVolumeTextureMapper2D
  • SetMaximumNumberOfPoints() : vtkMaskPoints
  • SetMaximumNumberOfSquawks() : vtkDecimate
  • SetMaximumPropagationDistance() : vtkHyperStreamline
  • SetMaximumPropagationTime() : vtkStreamer
  • SetMaximumSpeed() : vtkBrownianPoints
  • SetMaximumStorageSize() : vtkVolumeTextureMapper2D
  • SetMaximumSubIterations() : vtkDecimate
  • SetMaximumTableValue() : vtkWindowLevelLookupTable
  • SetMaxLevel() : vtkSimpleScalarTree, vtkLocator
  • SetMaxNumberOfIterations() : vtkGraphLayoutFilter
  • SetMaxRecursionDepth() : vtkPolyDataNormals
  • SetMaxScaleFactor() : vtkTensorGlyph
  • SetMean() : vtkImageShrink3D
  • SetMeanDistanceMode() : vtkIterativeClosestPointTransform
  • SetMeanDistanceModeToAbsoluteValue() : vtkIterativeClosestPointTransform
  • SetMeanDistanceModeToRMS() : vtkIterativeClosestPointTransform
  • SetMeasuredFileName() : vtkEnSightReader, vtkEnSightGoldReader
  • SetMedian() : vtkImageShrink3D
  • SetMemoryLimit() : vtkPImageWriter, vtkMemoryLimitImageDataStreamer, vtkDicer
  • SetMemoryLimitInBytes() : vtkVoxelContoursToSurfaceFilter
  • SetMergeTolerance() : vtkClipVolume
  • SetMerging() : vtkUGFacetReader, vtkSTLReader, vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetMethodID() : vtkJavaCommand
  • SetMiddleButtonPressMethod() : vtkInteractorStyle
  • SetMiddleButtonPressMethodArgDelete() : vtkInteractorStyle
  • SetMiddleButtonReleaseMethod() : vtkInteractorStyle
  • SetMiddleButtonReleaseMethodArgDelete() : vtkInteractorStyle
  • SetMILAppID() : vtkMILVideoSource
  • SetMILDigitizerDCF() : vtkMILVideoSource
  • SetMILDigitizerNumber() : vtkMILVideoSource
  • SetMILErrorMessages() : vtkMILVideoSource
  • SetMILSysID() : vtkMILVideoSource
  • SetMILSystemNumber() : vtkMILVideoSource
  • SetMILSystemType() : vtkMILVideoSource
  • SetMILSystemTypeToCorona() : vtkMILVideoSource
  • SetMILSystemTypeToGenesis() : vtkMILVideoSource
  • SetMILSystemTypeToMeteor() : vtkMILVideoSource
  • SetMILSystemTypeToMeteorII() : vtkMILVideoSource
  • SetMILSystemTypeToMeteorIIDig() : vtkMILVideoSource
  • SetMILSystemTypeToPulsar() : vtkMILVideoSource
  • SetMinBlankingValue() : vtkBlankStructuredGrid
  • SetMinimum() : vtkImageShrink3D, vtkImageNoiseSource
  • SetMinimumColor() : vtkWindowLevelLookupTable
  • SetMinimumCoverage() : vtkFrustumCoverageCuller
  • SetMinimumImageSampleDistance() : vtkVolumeRayCastMapper
  • SetMinimumSize() : vtkScaledTextActor
  • SetMinimumSpeed() : vtkBrownianPoints
  • SetMinimumTableValue() : vtkWindowLevelLookupTable
  • SetMirror() : vtkImageReslice
  • SetMode() : vtkLandmarkTransform
  • SetModelBounds() : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller, vtkCursor3D
  • SetModeToAffine() : vtkLandmarkTransform
  • SetModeToRigidBody() : vtkLandmarkTransform
  • SetModeToSimilarity() : vtkLandmarkTransform
  • SetMotionAccelerationFactor() : vtkInteractorStyleFlight
  • SetMotionStepSize() : vtkInteractorStyleFlight
  • SetMouseMoveMethod() : vtkInteractorStyleUser
  • SetMouseMoveMethodArgDelete() : vtkInteractorStyleUser
  • SetMultipleMethod() : vtkMultiProcessController, vtkMultiThreader
  • SetMultiSamples() : vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • SetName() : vtkSplitField::Component, vtkMergeFields::Component, vtkDataArray
  • SetNeighborhoodSize() : vtkSurfaceReconstructionFilter
  • SetNextWindowId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzImageWindow
  • SetNonManifoldEdges() : vtkFeatureEdges
  • SetNonManifoldTraversal() : vtkPolyDataNormals
  • SetNormal() : vtkWarpScalar, vtkTextureMapToPlane, vtkPlaneSource, vtkImplicitSelectionLoop, vtkPlane
  • SetNormalComponent() : vtkFieldDataToAttributeDataFilter
  • SetNormalComponents() : vtkExtractTensorComponents
  • SetNormalize() : vtkVectorNorm
  • SetNormalizeByWeight() : vtkImplicitSum
  • SetNormalizeNormals() : vtkExtractTensorComponents
  • SetNormals() : vtkMCubesReader, vtkMergeFilter, vtkPlanes, vtkDataSetAttributes
  • SetNormalsName() : vtkDataWriter, vtkDataReader
  • SetNormalWarping() : vtkGaussianSplatter
  • SetNotMask() : vtkImageMask
  • SetNthInput() : vtkProcessObject
  • SetNthOutput() : vtkSource
  • SetNullValue() : vtkShepardMethod, vtkGaussianSplatter
  • SetNumberOfArrays() : vtkFieldData
  • SetNumberOfCellsPerBucket() : vtkCellLocator
  • SetNumberOfCloudPoints() : vtkLODActor
  • SetNumberOfColors() : vtkImageQuantizeRGBToIndex, vtkLookupTable
  • SetNumberOfComponents() : vtkMergeFields, vtkDataArray
  • SetNumberOfComponentsCallback() : vtkImageImport
  • SetNumberOfContours() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkCutter, vtkContourGrid, vtkContourFilter, vtkBandedPolyDataContourFilter, vtkContourValues
  • SetNumberOfDivisions() : vtkImageCheckerboard, vtkQuadricClustering
  • SetNumberOfEntries() : vtkLegendBoxActor
  • SetNumberOfFlyFrames() : vtkRenderWindowInteractor
  • SetNumberOfGhostLevels() : vtkPOPReader
  • SetNumberOfIds() : vtkIdList
  • SetNumberOfInputs() : vtkProcrustesAlignmentFilter, vtkPCAAnalysisFilter, vtkAppendPolyData, vtkProcessObject
  • SetNumberOfInterpolationSteps() : vtkSweptSurface
  • SetNumberOfIterations() : vtkImageSkeleton2D, vtkImageIterateFilter, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkWindowedSincPolyDataFilter, vtkSmoothPolyDataFilter
  • SetNumberOfLabels() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkAxisActor2D, vtkXYPlotActor, vtkCubeAxesActor2D
  • SetNumberOfLayers() : vtkRenderWindow
  • SetNumberOfOutputFrames() : vtkVideoSource
  • SetNumberOfOutputs() : vtkSource
  • SetNumberOfPieces() : vtkPolyDataMapper, vtkPDataSetWriter, vtkPDataSetReader, vtkDicer, vtkExtentTranslator
  • SetNumberOfPoints() : vtkPointSource, vtkPoints
  • SetNumberOfPointsPerBucket() : vtkPointLocator2D, vtkPointLocator
  • SetNumberOfPointsPerPiece() : vtkDicer
  • SetNumberOfProcesses() : vtkSocketController, vtkMultiProcessController
  • SetNumberOfScalarComponents() : vtkImageBlockReader, vtkImageReader2, vtkImageImport, vtkImageData
  • SetNumberOfSides() : vtkTubeFilter, vtkHyperStreamline
  • SetNumberOfSmoothingIterations() : vtkImageToPolyDataFilter
  • SetNumberOfSources() : vtkGlyph3D
  • SetNumberOfStreamDivisions() : vtkImageDataStreamer, vtkPolyDataStreamer
  • SetNumberOfSubdivisions() : vtkInterpolatingSubdivisionFilter, vtkApproximatingSubdivisionFilter
  • SetNumberOfSubPieces() : vtkPolyDataMapper
  • SetNumberOfTableValues() : vtkLookupTable
  • SetNumberOfTCoords() : vtkExtractTensorComponents
  • SetNumberOfThreads() : vtkVolumeRayCastMapper, vtkRayCaster, vtkEncodedGradientEstimator, vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D, vtkImplicitModeller, vtkStreamer, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkMultiThreader
  • SetNumberOfTransforms() : vtkWeightedTransformFilter
  • SetNumberOfTuples() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • SetNumberOfValues() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkBitArray
  • SetNumberOfXDivisions() : vtkQuadricClustering
  • SetNumberOfXLabels() : vtkXYPlotActor
  • SetNumberOfYDivisions() : vtkQuadricClustering
  • SetNumberOfYLabels() : vtkXYPlotActor
  • SetNumberOfZDivisions() : vtkQuadricClustering
  • SetObject() : vtkPythonCommand
  • SetObjectFactory() : vtkOverrideInformation
  • SetObliqueAngles() : vtkCamera
  • SetOffScreenRendering() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWin32OpenGLRenderWindow, vtkMesaImageWindow, vtkWindow
  • SetOffset() : vtkArcPlotter, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints, vtkDelaunay3D, vtkDelaunay2D
  • SetOffsetPosition() : vtkAxisActor2D
  • SetOldOrigin() : vtkImageStencilData
  • SetOldSpacing() : vtkImageStencilData
  • SetOnIn() : vtkBooleanTexture
  • SetOnOn() : vtkBooleanTexture
  • SetOnOut() : vtkBooleanTexture
  • SetOnRatio() : vtkEarthSource, vtkTubeFilter, vtkRuledSurfaceFilter, vtkMaskPolyData, vtkMaskPoints
  • SetOpacity() : vtkProperty, vtkImageBlend, vtkVideoSource, vtkProperty2D
  • SetOpenValue() : vtkImageOpenClose3D
  • SetOperation() : vtkImageMathematics, vtkImageMaskBits, vtkImageLogic
  • SetOperationToAbsoluteValue() : vtkImageMathematics
  • SetOperationToAdd() : vtkImageMathematics
  • SetOperationToAddConstant() : vtkImageMathematics
  • SetOperationToAnd() : vtkImageMaskBits, vtkImageLogic
  • SetOperationToATAN() : vtkImageMathematics
  • SetOperationToATAN2() : vtkImageMathematics
  • SetOperationToComplexMultiply() : vtkImageMathematics
  • SetOperationToConjugate() : vtkImageMathematics
  • SetOperationToCos() : vtkImageMathematics
  • SetOperationToDivide() : vtkImageMathematics
  • SetOperationToExp() : vtkImageMathematics
  • SetOperationToInvert() : vtkImageMathematics
  • SetOperationToLog() : vtkImageMathematics
  • SetOperationToMax() : vtkImageMathematics
  • SetOperationToMin() : vtkImageMathematics
  • SetOperationToMultiply() : vtkImageMathematics
  • SetOperationToMultiplyByK() : vtkImageMathematics
  • SetOperationToNand() : vtkImageMaskBits, vtkImageLogic
  • SetOperationToNor() : vtkImageMaskBits, vtkImageLogic
  • SetOperationToNot() : vtkImageLogic
  • SetOperationToOr() : vtkImageMaskBits, vtkImageLogic
  • SetOperationToReplaceCByK() : vtkImageMathematics
  • SetOperationToSin() : vtkImageMathematics
  • SetOperationToSquare() : vtkImageMathematics
  • SetOperationToSquareRoot() : vtkImageMathematics
  • SetOperationToSubtract() : vtkImageMathematics
  • SetOperationToXor() : vtkImageMaskBits, vtkImageLogic
  • SetOperationType() : vtkImplicitBoolean
  • SetOperationTypeToDifference() : vtkImplicitBoolean
  • SetOperationTypeToIntersection() : vtkImplicitBoolean
  • SetOperationTypeToUnion() : vtkImplicitBoolean
  • SetOperationTypeToUnionOfMagnitudes() : vtkImplicitBoolean
  • SetOptimization() : vtkImageReslice
  • SetOrder() : vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • SetOrient() : vtkGlyph3D
  • SetOrientation() : vtkScalarBarActor, vtkProp3D
  • SetOrientationScalars() : vtkStreamer
  • SetOrientationToHorizontal() : vtkScalarBarActor
  • SetOrientationToVertical() : vtkScalarBarActor
  • SetOrigin() : vtkProp3D, vtkImageStencilData, vtkDepthSortPolyData, vtkTransformTextureCoords, vtkTextureMapToPlane, vtkPlaneSource, vtkDataObjectToDataSetFilter, vtkButtonSource, vtkAxes, vtkPlane, vtkImageData
  • SetOriginalSource() : vtkBranchExtentTranslator
  • SetOriginCallback() : vtkImageImport
  • SetOriginComponent() : vtkDataObjectToDataSetFilter
  • SetOriginCX() : vtkImageMandelbrotSource
  • SetOriginScale() : vtkImageChangeInformation
  • SetOriginTranslation() : vtkImageChangeInformation
  • SetOuterRadius() : vtkDiskSource
  • SetOutGradient() : vtkImplicitVolume, vtkImplicitDataSet
  • SetOutIn() : vtkBooleanTexture
  • SetOutline() : vtkEarthSource, vtkCursor3D
  • SetOutOn() : vtkBooleanTexture
  • SetOutOut() : vtkBooleanTexture
  • SetOutput() : vtkPDataSetReader, vtkUnstructuredGridReader, vtkStructuredPointsReader, vtkStructuredGridReader, vtkRectilinearGridReader, vtkPolyDataReader, vtkDataObjectReader, vtkImageStencilSource, vtkUnstructuredGridSource, vtkStructuredPointsSource, vtkStructuredGridSource, vtkRectilinearGridSource, vtkPolyDataSource, vtkPointSetSource, vtkPiecewiseFunctionSource, vtkImageSource, vtkDataSetSource, vtkDataObjectSource
  • SetOutputAttributeData() : vtkFieldDataToAttributeDataFilter
  • SetOutputAttributeDataToCellData() : vtkFieldDataToAttributeDataFilter
  • SetOutputAttributeDataToPointData() : vtkFieldDataToAttributeDataFilter
  • SetOutputConnectedValue() : vtkImageSeedConnectivity
  • SetOutputDimensionality() : vtkImageReslice
  • SetOutputEvent : vtkCommand
  • SetOutputExtent() : vtkImageReslice
  • SetOutputExtentStart() : vtkImageChangeInformation
  • SetOutputExtentToDefault() : vtkImageReslice
  • SetOutputField() : vtkMergeFields, vtkMergeDataObjectFilter
  • SetOutputFieldToCellDataField() : vtkMergeDataObjectFilter
  • SetOutputFieldToDataObjectField() : vtkMergeDataObjectFilter
  • SetOutputFieldToPointDataField() : vtkMergeDataObjectFilter
  • SetOutputFormat() : vtkImageMapToColors, vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • SetOutputFormatToLuminance() : vtkImageMapToColors, vtkVideoSource
  • SetOutputFormatToLuminanceAlpha() : vtkImageMapToColors
  • SetOutputFormatToRGB() : vtkImageMapToColors, vtkVideoSource
  • SetOutputFormatToRGBA() : vtkImageMapToColors, vtkVideoSource
  • SetOutputNumberOfScalarComponents() : vtkImagePadFilter
  • SetOutputOrigin() : vtkImageReslice, vtkImageChangeInformation
  • SetOutputOriginToDefault() : vtkImageReslice
  • SetOutputScalarType() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToChar() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToDouble() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToFloat() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToInt() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToLong() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToShort() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToUnsignedChar() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToUnsignedInt() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToUnsignedLong() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputScalarTypeToUnsignedShort() : vtkImageThreshold, vtkImageShiftScale, vtkImageEllipsoidSource, vtkImageCast
  • SetOutputSpacing() : vtkImageReslice, vtkImageChangeInformation
  • SetOutputSpacingToDefault() : vtkImageReslice
  • SetOutputStyle() : vtkImageToPolyDataFilter
  • SetOutputStyleToPixelize() : vtkImageToPolyDataFilter
  • SetOutputStyleToPolygonalize() : vtkImageToPolyDataFilter
  • SetOutputStyleToRunLength() : vtkImageToPolyDataFilter
  • SetOutputTrueValue() : vtkImageLogic
  • SetOutputUnconnectedValue() : vtkImageSeedConnectivity
  • SetOutputWholeExtent() : vtkImagePadFilter, vtkImageClip, vtkVideoSource
  • SetOutTextureCoord() : vtkThresholdTextureCoords
  • SetOutValue() : vtkImageThreshold, vtkImageEllipsoidSource, vtkImplicitVolume, vtkImplicitDataSet
  • SetOverlap() : vtkImageBlockWriter, vtkImageBlockReader
  • SetP1() : vtkWarpLens
  • SetP2() : vtkWarpLens
  • SetPadding() : vtkLegendBoxActor, vtkCaptionActor2D
  • SetParallelProjection() : vtkCamera
  • SetParallelScale() : vtkCamera
  • SetParallelStreaming() : vtkAppendPolyData
  • SetParameter() : vtkRIBProperty
  • SetParameterMethod() : vtkOutputPort
  • SetParameterMethodArgDelete() : vtkOutputPort
  • SetParentId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzImageWindow, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkWindow
  • SetParentInfo() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkImageWindow, vtkWindow
  • SetPartNumber() : vtkUGFacetReader, vtkBYUReader
  • SetPassAlphaToOutput() : vtkImageMapToColors
  • SetPassAttributeData() : vtkAttributeDataToFieldDataFilter
  • SetPassBand() : vtkWindowedSincPolyDataFilter
  • SetPassCellData() : vtkCellDataToPointData
  • SetPassLines() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter, vtkRuledSurfaceFilter
  • SetPassPointData() : vtkPointDataToCellData
  • SetPassTensorsToOutput() : vtkExtractTensorComponents
  • SetPassVerts() : vtkGLUTesselatorTriangleFilter, vtkTriangleFilter
  • SetPath() : vtkAbstractPropPicker
  • SetPatientID() : vtkMedicalImageReader2
  • SetPatientName() : vtkMedicalImageReader2
  • SetPeriod() : vtkImageSinusoidSource
  • SetPermutation() : vtkSpherePuzzleArrows
  • SetPermutationComponent() : vtkSpherePuzzleArrows
  • SetPhase() : vtkImageSinusoidSource, vtkPerlinNoise
  • SetPhi() : vtkTexturedSphereSource
  • SetPhiResolution() : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • SetPhiRoundness() : vtkSuperquadricSource, vtkSuperquadric
  • SetPhiThreshold() : vtkLinkEdgels
  • SetPickable() : vtkProp
  • SetPickColor() : vtkInteractorStyle
  • SetPicker() : vtkRenderWindowInteractor
  • SetPickFromList() : vtkAbstractPicker
  • SetPickMethod() : vtkLODProp3D, vtkAbstractPicker, vtkProp
  • SetPickMethodArgDelete() : vtkLODProp3D, vtkAbstractPicker, vtkProp
  • SetPiece() : vtkPolyDataMapper, vtkExtentTranslator
  • SetPieceInvariant() : vtkPPolyDataNormals, vtkPLinearExtrusionFilter, vtkPCellDataToPointData, vtkCleanPolyData
  • SetPipelineFlag() : vtkOutputPort
  • SetPipelineModifiedCallback() : vtkImageImport
  • SetPipelineMTime() : vtkDataObject
  • SetPixelAspect() : vtkViewport
  • SetPixelData() : vtkWin32OpenGLImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkOpenGLImageWindow, vtkMesaRenderWindow, vtkMesaImageWindow
  • SetPixelSamples() : vtkRIBExporter
  • SetPlane() : vtkReflectionFilter, vtkHull
  • SetPlanes() : vtkHull
  • SetPlaneToXMax() : vtkReflectionFilter
  • SetPlaneToXMin() : vtkReflectionFilter
  • SetPlaneToYMax() : vtkReflectionFilter
  • SetPlaneToYMin() : vtkReflectionFilter
  • SetPlaneToZMax() : vtkReflectionFilter
  • SetPlaneToZMin() : vtkReflectionFilter
  • SetPlotColor() : vtkXYPlotActor
  • SetPlotComponent() : vtkArcPlotter
  • SetPlotCoordinate() : vtkXYPlotActor
  • SetPlotCurveLines() : vtkXYPlotActor
  • SetPlotCurvePoints() : vtkXYPlotActor
  • SetPlotLabel() : vtkXYPlotActor
  • SetPlotLines() : vtkXYPlotActor
  • SetPlotMode() : vtkArcPlotter
  • SetPlotModeToPlotFieldData() : vtkArcPlotter
  • SetPlotModeToPlotNormals() : vtkArcPlotter
  • SetPlotModeToPlotScalars() : vtkArcPlotter
  • SetPlotModeToPlotTCoords() : vtkArcPlotter
  • SetPlotModeToPlotTensors() : vtkArcPlotter
  • SetPlotModeToPlotVectors() : vtkArcPlotter
  • SetPlotPoints() : vtkXYPlotActor
  • SetPlotRange() : vtkXYPlotActor
  • SetPlotSymbol() : vtkXYPlotActor
  • SetPoint() : vtkSpherePuzzle, vtkPoints
  • SetPoint1() : vtkAxisActor2D, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • SetPoint2() : vtkAxisActor2D, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkPlaneSource, vtkLineSource
  • SetPointClipping() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetPointComponent() : vtkXYPlotActor, vtkDataObjectToDataSetFilter
  • SetPointData() : vtkDataSetToDataObjectFilter
  • SetPointer() : vtkOutputWindowSmartPointer
  • SetPointIds() : vtkIdFilter
  • SetPointIdsName() : vtkGlyph3D
  • SetPointMaximum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetPointMerging() : vtkCleanPolyData
  • SetPointMinimum() : vtkGeometryFilter, vtkExtractUnstructuredGrid
  • SetPoints() : vtkPointSet, vtkPointLocator2D, vtkPlanes
  • SetPointSize() : vtkProperty, vtkProperty2D
  • SetPointSmoothing() : vtkRenderWindow
  • SetPointVisibility() : vtkStructuredGrid
  • SetPoissonsRatio() : vtkPointLoad
  • SetPolygonSmoothing() : vtkRenderWindow
  • SetPolys() : vtkPolyData
  • SetPolysComponent() : vtkDataObjectToDataSetFilter
  • SetPosition() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkProp3D, vtkLight, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkCamera, vtkWarpTo, vtkTransformTextureCoords, vtkProjectedTexture, vtkWindow, vtkActor2D
  • SetPosition2() : vtkActor2D
  • SetPositional() : vtkLight
  • SetPositionScale() : vtkPiecewiseFunctionShiftScale
  • SetPositionShift() : vtkPiecewiseFunctionShiftScale
  • SetPreMultiplyFlag() : vtkTransformConcatenation
  • SetPreserveEdges() : vtkDecimate
  • SetPreserveExtents() : vtkImageAppend
  • SetPreserveImageExtent() : vtkImageFlip
  • SetPreserveTopology() : vtkDecimate, vtkDecimatePro
  • SetPreSorted() : vtkOrderedTriangulator
  • SetPreSplitMesh() : vtkDecimatePro
  • SetPreventSeam() : vtkTextureMapToSphere, vtkTextureMapToCylinder
  • SetPreview() : vtkWin32VideoSource
  • SetPrincipalPoint() : vtkWarpLens
  • SetProcessMode() : vtkImplicitModeller
  • SetProcessModeToPerCell() : vtkImplicitModeller
  • SetProcessModeToPerVoxel() : vtkImplicitModeller
  • SetProgress() : vtkProcessObject
  • SetProgressive() : vtkJPEGWriter
  • SetProgressMethod() : vtkProcessObject
  • SetProgressMethodArgDelete() : vtkProcessObject
  • SetProgressText() : vtkProcessObject
  • SetProjectionAxes() : vtkImageMandelbrotSource
  • SetPromptUser() : vtkOutputWindow
  • SetProp() : vtkCubeAxesActor2D, vtkAssemblyNode
  • SetProp3D() : vtkDepthSortPolyData
  • SetPropagateUpdateExtentCallback() : vtkImageImport
  • SetProperty() : vtkVolume, vtkActor, vtkActor2D
  • SetPrune() : vtkImageSkeleton2D
  • SetQFactor() : vtkQuantizePolyDataPoints
  • SetQFileName() : vtkPLOT3DReader
  • SetQuality() : vtkTexture, vtkJPEGWriter
  • SetQualityTo16Bit() : vtkTexture
  • SetQualityTo32Bit() : vtkTexture
  • SetQualityToDefault() : vtkTexture
  • SetR() : vtkPLOT3DReader
  • SetRadialRatio() : vtkButtonSource
  • SetRadialResolution() : vtkDiskSource
  • SetRadius() : vtkPOPReader, vtkImageEllipsoidSource, vtkGaussianSplatter, vtkEarthSource, vtkArcPlotter, vtkTubeFilter, vtkTexturedSphereSource, vtkSphereSource, vtkPointSource, vtkHyperStreamline, vtkCylinderSource, vtkConeSource, vtkSphere, vtkCylinder
  • SetRadiusFactor() : vtkImageGaussianSmooth, vtkTubeFilter
  • SetRadiusFactors() : vtkImageGaussianSmooth
  • SetRamp() : vtkLookupTable
  • SetRampToLinear() : vtkLookupTable
  • SetRampToSCurve() : vtkLookupTable
  • SetRandomMode() : vtkPieceScalars, vtkMaskPoints
  • SetRange() : vtkAxisActor2D, vtkGlyph3D, vtkColorTransferFunction, vtkScalarsToColors, vtkLookupTable
  • SetRanges() : vtkCubeAxesActor2D
  • SetRatio() : vtkImageCanvasSource2D
  • SetReadDisplacement() : vtkBYUReader
  • SetReader() : vtkSliceCubes
  • SetReadFromInputString() : vtkDataReader
  • SetReadFrontBuffer() : vtkWindowToImageFilter
  • SetReadScalar() : vtkBYUReader
  • SetReadTexture() : vtkBYUReader
  • SetRecursionDepth() : vtkRecursiveSphereDirectionEncoder
  • SetReductionFactor() : vtkCompositeManager
  • SetReferenceCoordinate() : vtkCoordinate
  • SetReferenceCount() : vtkObject
  • SetRelaxationFactor() : vtkSmoothPolyDataFilter
  • SetReleaseDataFlag() : vtkSource, vtkDataObject
  • SetRemoteProcessId() : vtkInputPort
  • SetRenderer() : vtkSelectVisiblePoints
  • SetRendererSize() : vtkCompositeManager
  • SetRenderFlag() : vtkRendererSource
  • SetRenderTime() : vtkMapper
  • SetRenderTimeMultiplier() : vtkProp
  • SetRenderToRectangle() : vtkImageMapper
  • SetRenderWindow() : vtkRenderWindowInteractor, vtkRenderer, vtkImporter, vtkExporter, vtkCompositeManager
  • SetRenderWindowInteractor() : vtkCompositeManager
  • SetRepeat() : vtkTexture
  • SetRepeatCount() : vtkRenderWindowInteractor
  • SetReplaceIn() : vtkImageThreshold
  • SetReplaceOut() : vtkImageThreshold
  • SetReplaceValue() : vtkImageIslandRemoval2D
  • SetRepresentation() : vtkProperty
  • SetRepresentationToPoints() : vtkProperty
  • SetRepresentationToSurface() : vtkProperty
  • SetRepresentationToWireframe() : vtkProperty
  • SetRequestExactExtent() : vtkDataObject
  • SetResliceAxes() : vtkImageReslice
  • SetResliceAxesDirectionCosines() : vtkImageReslice
  • SetResliceAxesOrigin() : vtkImageReslice
  • SetResliceTransform() : vtkImageReslice
  • SetResolution() : vtkCGMWriter, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkPlaneSource, vtkLineSource, vtkCylinderSource, vtkConeSource
  • SetResolveCoincidentTopology() : vtkMapper
  • SetResolveCoincidentTopologyPolygonOffsetParameters() : vtkMapper
  • SetResolveCoincidentTopologyToDefault() : vtkMapper
  • SetResolveCoincidentTopologyToOff() : vtkMapper
  • SetResolveCoincidentTopologyToPolygonOffset() : vtkMapper
  • SetResolveCoincidentTopologyToShiftZBuffer() : vtkMapper
  • SetResolveCoincidentTopologyZShift() : vtkMapper
  • SetResultArrayName() : vtkArrayCalculator
  • SetRetainCellLists() : vtkLocator
  • SetReverseCells() : vtkReverseSense
  • SetReverseNormals() : vtkReverseSense
  • SetReverseStencil() : vtkImageStencil, vtkImageAccumulate
  • SetReverseXAxis() : vtkXYPlotActor
  • SetReverseYAxis() : vtkXYPlotActor
  • SetRFunction() : vtkImplicitTextureCoords
  • SetRGBACharPixelData() : vtkRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • SetRGBAPixelData() : vtkWin32OpenGLImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkOpenGLRenderWindow, vtkOpenGLImageWindow, vtkMesaRenderWindow, vtkMesaImageWindow
  • SetRightButtonPressMethod() : vtkInteractorStyle
  • SetRightButtonPressMethodArgDelete() : vtkInteractorStyle
  • SetRightButtonReleaseMethod() : vtkInteractorStyle
  • SetRightButtonReleaseMethodArgDelete() : vtkInteractorStyle
  • SetRightConstraint() : vtkSpline
  • SetRightValue() : vtkSpline
  • SetRoll() : vtkCamera
  • SetRotationAngle() : vtkGlyphSource2D
  • SetRuledMode() : vtkRuledSurfaceFilter
  • SetRuledModeToPointWalk() : vtkRuledSurfaceFilter
  • SetRuledModeToResample() : vtkRuledSurfaceFilter
  • SetSample() : vtkImageMandelbrotSource
  • SetSampleCX() : vtkImageMandelbrotSource
  • SetSampleDimensions() : vtkSweptSurface, vtkVoxelModeller, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkGaussianSplatter, vtkImplicitModeller
  • SetSampleDistance() : vtkVolumeRayCastMapper
  • SetSampleRate() : vtkExtractVOI, vtkExtractGrid
  • SetSampleSpacing() : vtkSurfaceReconstructionFilter
  • SetSampleSpacingInVoxels() : vtkFiniteDifferenceGradientEstimator
  • SetSaturationLevel() : vtkMILVideoSource
  • SetSaturationRange() : vtkLookupTable
  • SetSavePointInterval() : vtkStreamer
  • SetScalar() : vtkGaussianSplatter
  • SetScalarComponent() : vtkFieldDataToAttributeDataFilter
  • SetScalarComponents() : vtkExtractTensorComponents
  • SetScalarConnectivity() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • SetScalarFileName() : vtkBYUWriter, vtkBYUReader
  • SetScalarFunctionNumber() : vtkPLOT3DReader
  • SetScalarLut() : vtkDataReader
  • SetScalarMode() : vtkPolyDataMapper2D, vtkMapper, vtkExtractTensorComponents, vtkBandedPolyDataContourFilter
  • SetScalarModeToCellData() : vtkPieceScalars
  • SetScalarModeToDefault() : vtkPolyDataMapper2D, vtkMapper
  • SetScalarModeToIndex() : vtkBandedPolyDataContourFilter
  • SetScalarModeToPointData() : vtkPieceScalars
  • SetScalarModeToUseCellData() : vtkPolyDataMapper2D, vtkMapper
  • SetScalarModeToUseCellFieldData() : vtkPolyDataMapper2D, vtkMapper
  • SetScalarModeToUsePointData() : vtkPolyDataMapper2D, vtkMapper
  • SetScalarModeToUsePointFieldData() : vtkPolyDataMapper2D, vtkMapper
  • SetScalarModeToValue() : vtkBandedPolyDataContourFilter
  • SetScalarOpacity() : vtkVolumeProperty
  • SetScalarRange() : vtkPolyDataMapper2D, vtkMapper, vtkVectorDot, vtkPolyDataConnectivityFilter, vtkElevationFilter, vtkConnectivityFilter
  • SetScalars() : vtkSampleFunction, vtkMergeFilter, vtkDataSetAttributes
  • SetScalarsName() : vtkDataWriter, vtkDataReader
  • SetScalarTags() : vtkSTLReader
  • SetScalarTree() : vtkContourFilter
  • SetScalarType() : vtkImageBlockReader, vtkImageData
  • SetScalarTypeCallback() : vtkImageImport
  • SetScalarTypeToChar() : vtkImageData
  • SetScalarTypeToDouble() : vtkImageData
  • SetScalarTypeToFloat() : vtkImageData
  • SetScalarTypeToInt() : vtkImageData
  • SetScalarTypeToLong() : vtkImageData
  • SetScalarTypeToShort() : vtkImageData
  • SetScalarTypeToUnsignedChar() : vtkImageData
  • SetScalarTypeToUnsignedInt() : vtkImageData
  • SetScalarTypeToUnsignedLong() : vtkImageData
  • SetScalarTypeToUnsignedShort() : vtkImageData
  • SetScalarVariableValue() : vtkFunctionParser
  • SetScalarVisibility() : vtkPolyDataMapper2D, vtkMapper, vtkLegendBoxActor
  • SetScalarWarping() : vtkGaussianSplatter
  • SetScale() : vtkProp3D, vtkImageShiftScale, vtkTransformTextureCoords, vtkSuperquadricSource, vtkGlyphSource2D, vtkSuperquadric, vtkLookupTable
  • SetScale2() : vtkGlyphSource2D
  • SetScaleFactor() : vtkTriangularTexture, vtkGaussianSplatter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkTensorGlyph, vtkLinearExtrusionFilter, vtkHedgeHog, vtkGlyph3D, vtkAxes
  • SetScaleMode() : vtkGlyph3D
  • SetScaleModeToDataScalingOff() : vtkGlyph3D
  • SetScaleModeToScaleByScalar() : vtkGlyph3D
  • SetScaleModeToScaleByVector() : vtkGlyph3D
  • SetScaleModeToScaleByVectorComponents() : vtkGlyph3D
  • SetScaleToLinear() : vtkLookupTable
  • SetScaleToLog10() : vtkLookupTable
  • SetScaling() : vtkCubeAxesActor2D, vtkTensorGlyph, vtkGlyph3D
  • SetSelectedImageScaleIndex() : vtkRayCaster
  • SetSelectedLODID() : vtkLODProp3D
  • SetSelectedPickLODID() : vtkLODProp3D
  • SetSelectInvisible() : vtkSelectVisiblePoints
  • SetSelection() : vtkSelectVisiblePoints
  • SetSelectionMode() : vtkSelectPolyData
  • SetSelectionModeToClosestPointRegion() : vtkSelectPolyData
  • SetSelectionModeToLargestRegion() : vtkSelectPolyData
  • SetSelectionModeToSmallestRegion() : vtkSelectPolyData
  • SetSelectionWindow() : vtkSelectVisiblePoints
  • SetSeries() : vtkMedicalImageReader2
  • SetSFunction() : vtkImplicitTextureCoords
  • SetShade() : vtkVolumeProperty
  • SetShadow() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • SetShadows() : vtkRIBLight
  • SetShaftRadius() : vtkArrowSource
  • SetShaftResolution() : vtkArrowSource
  • SetShift() : vtkImageShrink3D, vtkImageShiftScale
  • SetShiftKey() : vtkRenderWindowInteractor
  • SetShoulderResolution() : vtkButtonSource
  • SetShoulderTextureCoordinate() : vtkButtonSource
  • SetShrinkFactor() : vtkShrinkPolyData, vtkShrinkFilter
  • SetShrinkFactors() : vtkImageShrink3D
  • SetSidesShareVertices() : vtkTubeFilter
  • SetSigma() : vtkThinPlateSplineTransform
  • SetSingleMethod() : vtkMultiProcessController, vtkMultiThreader
  • SetSize() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindowInteractor, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkRIBExporter, vtkSuperquadricSource, vtkSuperquadric, vtkWindow, vtkAbstractList< DType >
  • SetSizeCX() : vtkImageMandelbrotSource
  • SetSmoothing() : vtkImageToPolyDataFilter
  • SetSort() : vtkCGMWriter
  • SetSortBy() : vtkCutter
  • SetSortByToSortByCell() : vtkCutter
  • SetSortByToSortByValue() : vtkCutter
  • SetSortingStyle() : vtkFrustumCoverageCuller
  • SetSortingStyleToBackToFront() : vtkFrustumCoverageCuller
  • SetSortingStyleToFrontToBack() : vtkFrustumCoverageCuller
  • SetSortingStyleToNone() : vtkFrustumCoverageCuller
  • SetSortScalars() : vtkDepthSortPolyData
  • SetSource() : vtkIterativeClosestPointTransform, vtkTensorGlyph, vtkStreamer, vtkSmoothPolyDataFilter, vtkProgrammableGlyphFilter, vtkProbeFilter, vtkGlyph3D, vtkDelaunay2D, vtkDataObject
  • SetSourceLandmarks() : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • SetSpacing() : vtkImageStencilData, vtkVoxelContoursToSurfaceFilter, vtkDataObjectToDataSetFilter, vtkImageData
  • SetSpacingCallback() : vtkImageImport
  • SetSpacingComponent() : vtkDataObjectToDataSetFilter
  • SetSpacingScale() : vtkImageChangeInformation
  • SetSpatialMatch() : vtkProbeFilter
  • SetSpatialRepresentation() : vtkSpatialRepresentationFilter
  • SetSpecifiedColor() : vtkCGMWriter
  • SetSpecular() : vtkVolumeProperty, vtkProperty
  • SetSpecularColor() : vtkProperty
  • SetSpecularPower() : vtkVolumeProperty, vtkProperty
  • SetSpeed() : vtkVRMLExporter
  • SetSpeedScalars() : vtkStreamer
  • SetSplitAngle() : vtkDecimatePro
  • SetSplitModeToBlock() : vtkExtentTranslator
  • SetSplitModeToXSlab() : vtkExtentTranslator
  • SetSplitModeToYSlab() : vtkExtentTranslator
  • SetSplitModeToZSlab() : vtkExtentTranslator
  • SetSplitting() : vtkPolyDataNormals, vtkDecimatePro
  • SetSquareNeighborhood() : vtkImageIslandRemoval2D
  • SetSRange() : vtkTextureMapToPlane, vtkProjectedTexture
  • SetStandardDeviation() : vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageGaussianSmooth
  • SetStandardDeviations() : vtkImageGaussianSmooth
  • SetStartByMatchingCentroids() : vtkIterativeClosestPointTransform
  • SetStartLocation() : vtkStreamer, vtkHyperStreamline
  • SetStartMethod() : vtkProcessObject
  • SetStartMethodArgDelete() : vtkProcessObject
  • SetStartPhi() : vtkSphereSource
  • SetStartPickMethod() : vtkRenderWindowInteractor, vtkAbstractPicker
  • SetStartPickMethodArgDelete() : vtkRenderWindowInteractor, vtkAbstractPicker
  • SetStartPiece() : vtkPDataSetWriter
  • SetStartPosition() : vtkStreamer, vtkHyperStreamline
  • SetStartRenderMethod() : vtkViewport
  • SetStartRenderMethodArgDelete() : vtkViewport
  • SetStartTheta() : vtkSphereSource
  • SetStartTimeStamp() : vtkVideoSource
  • SetStartWrite() : vtkExporter
  • SetStartWriteArgDelete() : vtkExporter
  • SetStencil() : vtkImageStencil, vtkImageReslice, vtkImageBlend, vtkImageAccumulate
  • SetStepLength() : vtkStreamLine, vtkHyperStreamline
  • SetStereoCapableWindow() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindow, vtkQuartzRenderWindow
  • SetStereoRender() : vtkRenderWindow
  • SetStereoType() : vtkRenderWindow
  • SetStereoTypeToCrystalEyes() : vtkRenderWindow
  • SetStereoTypeToDresden() : vtkRenderWindow
  • SetStereoTypeToInterlaced() : vtkRenderWindow
  • SetStereoTypeToLeft() : vtkRenderWindow
  • SetStereoTypeToRedBlue() : vtkRenderWindow
  • SetStereoTypeToRight() : vtkRenderWindow
  • SetStillUpdateRate() : vtkRenderWindowInteractor
  • SetStream() : vtkXMLParser
  • SetStringCommand() : vtkTclCommand
  • SetStrips() : vtkPolyData
  • SetStripsComponent() : vtkDataObjectToDataSetFilter
  • SetStudy() : vtkMedicalImageReader2
  • SetSubFrames() : vtkRenderWindow
  • SetSubImageSize() : vtkImageToPolyDataFilter
  • SetSubVolume() : vtkVolumeProMapper
  • SetSuperSampling() : vtkVolumeProMapper
  • SetSuperSamplingFactor() : vtkVolumeProMapper
  • SetSurfaceShader() : vtkRIBProperty
  • SetSwapBuffers() : vtkRenderWindow
  • SetSwapBytes() : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SetSwitch() : vtkLight
  • SetSymmetric() : vtkAxes
  • SetT() : vtkInterpolateDataSetAttributes
  • SetTableRange() : vtkLookupTable
  • SetTableValue() : vtkLookupTable
  • SetTag() : vtkOutputPort, vtkInputPort
  • SetTarget() : vtkIterativeClosestPointTransform
  • SetTargetFlag() : vtkSubPixelPositionEdgels
  • SetTargetLandmarks() : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • SetTargetReduction() : vtkDecimate, vtkDecimatePro
  • SetTargetTextureSize() : vtkVolumeTextureMapper2D
  • SetTargetValue() : vtkSubPixelPositionEdgels
  • SetTCoordComponent() : vtkFieldDataToAttributeDataFilter
  • SetTCoordComponents() : vtkExtractTensorComponents
  • SetTCoords() : vtkMergeFilter, vtkDataSetAttributes
  • SetTCoordsName() : vtkDataWriter, vtkDataReader
  • SetTensorComponent() : vtkFieldDataToAttributeDataFilter
  • SetTensorMode() : vtkCellDerivatives
  • SetTensorModeToComputeGradient() : vtkCellDerivatives
  • SetTensorModeToComputeStrain() : vtkCellDerivatives
  • SetTensorModeToPassTensors() : vtkCellDerivatives
  • SetTensors() : vtkMergeFilter, vtkDataSetAttributes
  • SetTensorsName() : vtkDataWriter, vtkDataReader
  • SetTerminalEigenvalue() : vtkHyperStreamline
  • SetTerminalSpeed() : vtkStreamer
  • SetText() : vtkVectorText, vtkTextSource
  • SetTexture() : vtkActor
  • SetTextureDimension() : vtkThresholdTextureCoords
  • SetTextureDimensions() : vtkButtonSource
  • SetTextureFileName() : vtkBYUWriter, vtkBYUReader
  • SetTexturePattern() : vtkTriangularTexture
  • SetTexturePrefix() : vtkRIBExporter
  • SetTextureResolution() : vtkButtonSource
  • SetTextureStyle() : vtkButtonSource
  • SetTextureStyleToFitImage() : vtkButtonSource
  • SetTextureStyleToProportional() : vtkButtonSource
  • SetTFunction() : vtkImplicitTextureCoords
  • SetTheta() : vtkTexturedSphereSource
  • SetThetaMaximum() : vtkImageEuclideanToPolar
  • SetThetaResolution() : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • SetThetaRoundness() : vtkSuperquadricSource, vtkSuperquadric
  • SetThickness() : vtkCamera, vtkBooleanTexture, vtkSuperquadricSource, vtkSuperquadric
  • SetThreeDimensionalLayout() : vtkGraphLayoutFilter
  • SetThreeDimensionalLeader() : vtkCaptionActor2D
  • SetThreshold() : vtkImplicitFunctionToImageStencil, vtkImageDifference
  • SetTickLength() : vtkAxisActor2D
  • SetTickOffset() : vtkAxisActor2D
  • SetTickVisibility() : vtkAxisActor2D
  • SetTileScale() : vtkWindow
  • SetTileViewport() : vtkWindow
  • SetTimeIncrement() : vtkStreamPoints
  • SetTimerLog() : vtkMultiProcessLog
  • SetTimerMethod() : vtkInteractorStyleUser
  • SetTimerMethodArgDelete() : vtkInteractorStyleUser
  • SetTimeValue() : vtkGenericEnSightReader, vtkEnSightReader
  • SetTipLength() : vtkArrowSource
  • SetTipRadius() : vtkArrowSource
  • SetTipResolution() : vtkArrowSource
  • SetTitle() : vtkScalarBarActor, vtkParallelCoordinatesActor, vtkAxisActor2D, vtkXYPlotActor
  • SetTitleVisibility() : vtkAxisActor2D
  • SetTolerance() : vtkSelectVisiblePoints, vtkPicker, vtkPolyDataToImageStencil, vtkDelaunay3D, vtkDelaunay2D, vtkCleanPolyData, vtkLocator
  • SetToleranceIsAbsolute() : vtkCleanPolyData
  • SetTopLevelShell() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • SetTopology() : vtkDataSetToDataObjectFilter
  • SetToroidal() : vtkSuperquadricSource, vtkSuperquadric
  • SetTrackballModeToJoystick() : vtkInteractorStyleTrackball
  • SetTrackballModeToTrackball() : vtkInteractorStyleTrackball
  • SetTRange() : vtkTextureMapToPlane, vtkProjectedTexture
  • SetTransform() : vtkVolume16Reader, vtkImageReader, vtkWeightedTransformFilter, vtkTransformPolyDataFilter, vtkTransformFilter, vtkDelaunay2D, vtkImplicitFunction
  • SetTransformCoordinate() : vtkPolyDataMapper2D
  • SetTransformInputSampling() : vtkImageReslice
  • SetTransformMatrix() : vtkLight
  • SetTransforms() : vtkSweptSurface
  • SetTranslation() : vtkImageTranslateExtent, vtkRotationalExtrusionFilter
  • SetTraversalLocation() : vtkCellArray
  • SetTuple() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • SetTuple1() : vtkDataArray
  • SetTuple2() : vtkDataArray
  • SetTuple3() : vtkDataArray
  • SetTuple4() : vtkDataArray
  • SetTuple9() : vtkDataArray
  • SetTwoSided() : vtkButtonSource
  • SetTwoSidedLighting() : vtkRenderer
  • SetUFlowFileName() : vtkPOPReader
  • SetUnconnectedValue() : vtkImageConnector
  • SetUp() : vtkProjectedTexture
  • SetupCamera() : vtkPerspectiveTransform
  • SetUpdateDataCallback() : vtkImageImport
  • SetUpdateExtent() : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyData, vtkImageData, vtkDataObject
  • SetUpdateExtentToWholeExtent() : vtkDataObject
  • SetUpdateGhostLevel() : vtkDataObject
  • SetUpdateInformationCallback() : vtkImageImport
  • SetUpdateNumberOfPieces() : vtkDataObject
  • SetUpdatePiece() : vtkDataObject
  • SetupInteractor() : vtkImageViewer2
  • SetupMemoryRendering() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow
  • SetupMotionVars() : vtkInteractorStyleFlight
  • SetupPalette() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • SetUpperThreshold() : vtkImageToImageStencil
  • SetupPixelFormat() : vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • SetUpVector() : vtkCutMaterial
  • SetUseChar() : vtkCompositeManager
  • SetUseCompositing() : vtkCompositeManager
  • SetUseCustomExtents() : vtkImageMapper
  • SetUseDefaultNormal() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • SetUseFeatureEdges() : vtkQuadricClustering
  • SetUseFeaturePoints() : vtkQuadricClustering
  • SetUseFileSets() : vtkEnSightReader
  • SetUseInputPoints() : vtkQuadricClustering
  • SetUseInternalTriangles() : vtkQuadricClustering
  • SetUseLookupTableScalarRange() : vtkPolyDataMapper2D, vtkMapper
  • SetUseNormal() : vtkWarpScalar
  • SetUseRanges() : vtkCubeAxesActor2D
  • SetUseRelativeFileNames() : vtkPDataSetWriter
  • SetUserInteractionMethod() : vtkInteractorStyleUser
  • SetUserInteractionMethodArgDelete() : vtkInteractorStyleUser
  • SetUserManagedInputs() : vtkAppendPolyData
  • SetUserMatrix() : vtkProp3D
  • SetUserMethod() : vtkRenderWindowInteractor
  • SetUserMethodArgDelete() : vtkRenderWindowInteractor
  • SetUserTransform() : vtkProp3D
  • SetUseScalarTree() : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • SetUseStrips() : vtkDataSetSurfaceFilter
  • SetUseTimeSets() : vtkEnSightReader
  • SetUseTwoSortIds() : vtkOrderedTriangulator
  • SetUvinf() : vtkPLOT3DReader
  • SetValue() : vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkRecursiveDividingCubes, vtkEdgePoints, vtkCutter, vtkContourGrid, vtkContourFilter, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkBandedPolyDataContourFilter, vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkCoordinate, vtkContourValues, vtkCharArray, vtkBitArray
  • SetValueRange() : vtkLookupTable
  • SetValueScale() : vtkPiecewiseFunctionShiftScale
  • SetValueShift() : vtkPiecewiseFunctionShiftScale
  • SetVariable() : vtkRIBProperty
  • SetVaryRadius() : vtkTubeFilter
  • SetVaryRadiusToVaryRadiusByScalar() : vtkTubeFilter
  • SetVaryRadiusToVaryRadiusByVector() : vtkTubeFilter
  • SetVaryRadiusToVaryRadiusOff() : vtkTubeFilter
  • SetVaryWidth() : vtkRibbonFilter
  • SetVector() : vtkDepthSortPolyData, vtkSimpleElevationFilter, vtkLinearExtrusionFilter
  • SetVectorComponent() : vtkFieldDataToAttributeDataFilter
  • SetVectorComponents() : vtkExtractTensorComponents
  • SetVectorFunctionFileName() : vtkPLOT3DReader
  • SetVectorFunctionNumber() : vtkPLOT3DReader
  • SetVectorInput() : vtkImageNonMaximumSuppression, vtkImageToStructuredPoints
  • SetVectorMode() : vtkHedgeHog, vtkGlyph3D, vtkCellDerivatives
  • SetVectorModeToComputeGradient() : vtkCellDerivatives
  • SetVectorModeToComputeVorticity() : vtkCellDerivatives
  • SetVectorModeToPassVectors() : vtkCellDerivatives
  • SetVectorModeToUseNormal() : vtkHedgeHog, vtkGlyph3D
  • SetVectorModeToUseVector() : vtkHedgeHog, vtkGlyph3D
  • SetVectorModeToVectorRotationOff() : vtkGlyph3D
  • SetVectors() : vtkMergeFilter, vtkDataSetAttributes
  • SetVectorsName() : vtkDataWriter, vtkDataReader
  • SetVectorVariableValue() : vtkFunctionParser
  • SetVertexCells() : vtkCellCenters
  • SetVerticalJustification() : vtkTextMapper, vtkCaptionActor2D
  • SetVerticalJustificationToBottom() : vtkTextMapper, vtkCaptionActor2D
  • SetVerticalJustificationToCentered() : vtkTextMapper, vtkCaptionActor2D
  • SetVerticalJustificationToTop() : vtkTextMapper, vtkCaptionActor2D
  • SetVerts() : vtkPolyData
  • SetVertsComponent() : vtkDataObjectToDataSetFilter
  • SetVFlowFileName() : vtkPOPReader
  • SetVideoChannel() : vtkMILVideoSource
  • SetVideoFormat() : vtkMILVideoSource
  • SetVideoFormatToCCIR() : vtkMILVideoSource
  • SetVideoFormatToNonStandard() : vtkMILVideoSource
  • SetVideoFormatToNTSC() : vtkMILVideoSource
  • SetVideoFormatToPAL() : vtkMILVideoSource
  • SetVideoFormatToRS170() : vtkMILVideoSource
  • SetVideoFormatToSECAM() : vtkMILVideoSource
  • SetVideoInput() : vtkMILVideoSource
  • SetVideoInputToComposite() : vtkMILVideoSource
  • SetVideoInputToDigital() : vtkMILVideoSource
  • SetVideoInputToMono() : vtkMILVideoSource
  • SetVideoInputToRGB() : vtkMILVideoSource
  • SetVideoInputToYC() : vtkMILVideoSource
  • SetViewAngle() : vtkCamera
  • SetViewPlaneNormal() : vtkCamera
  • SetViewPoint() : vtkViewport
  • SetViewport() : vtkCGMWriter, vtkViewport, vtkCoordinate
  • SetViewportCoordinate() : vtkXYPlotActor
  • SetViewRaysStepSize() : vtkRayCaster
  • SetViewShear() : vtkCamera
  • SetViewUp() : vtkCamera
  • SetVisibility() : vtkProp
  • SetVOI() : vtkExtractVOI, vtkExtractGrid
  • SetVoidArray() : vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFloatArray, vtkDoubleArray, vtkDataArray, vtkCharArray, vtkBitArray
  • SetVolume() : vtkImplicitVolume
  • SetVolumeRayCastFunction() : vtkVolumeRayCastMapper
  • SetVorticity() : vtkStreamer
  • SetVTKWindow() : vtkImager
  • SetVvinf() : vtkPLOT3DReader
  • SetWeightArray() : vtkWeightedTransformFilter
  • SetWholeExtent() : vtkRTAnalyticSource, vtkImageBlockReader, vtkImageSinusoidSource, vtkImageNoiseSource, vtkImageMandelbrotSource, vtkImageImport, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkExtentTranslator, vtkDataObject
  • SetWholeExtentCallback() : vtkImageImport
  • SetWholeWindow() : vtkRendererSource
  • SetWidget() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • SetWidth() : vtkRibbonFilter, vtkButtonSource, vtkActor2D
  • SetWidthFactor() : vtkRibbonFilter
  • SetWindow() : vtkImageMapToWindowLevelColors, vtkWindowLevelLookupTable
  • SetWindowCenter() : vtkCamera
  • SetWindowId() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkWindow
  • SetWindowInfo() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkRenderWindow, vtkQuartzRenderWindow, vtkImageWindow, vtkWindow
  • SetWindowName() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkWindow
  • SetWindowRange() : vtkImplicitWindowFunction
  • SetWindowValues() : vtkImplicitWindowFunction
  • SetWorldPoint() : vtkViewport
  • SetWorldUpVector() : vtkInteractorStyleUnicam
  • SetWrap() : vtkImageReslice, vtkCursor3D
  • SetWriteDisplacement() : vtkBYUWriter
  • SetWriteScalar() : vtkBYUWriter
  • SetWriteTexture() : vtkBYUWriter
  • SetWriteToOutputString() : vtkDataWriter
  • SetWvinf() : vtkPLOT3DReader
  • SetXAxisVisibility() : vtkCubeAxesActor2D
  • SetXCoordinates() : vtkRectilinearGrid
  • SetXCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • SetXFreq() : vtkRTAnalyticSource
  • SetXKernel() : vtkImageSeparableConvolution
  • SetXLabel() : vtkCubeAxesActor2D
  • SetXLength() : vtkCubeSource
  • SetXMag() : vtkRTAnalyticSource
  • SetXRange() : vtkXYPlotActor
  • SetXResolution() : vtkPlaneSource
  • SetXShadows() : vtkCursor3D
  • SetXSize() : vtkTriangularTexture, vtkBooleanTexture
  • SetXTitle() : vtkXYPlotActor
  • SetXValues() : vtkXYPlotActor
  • SetXValuesToArcLength() : vtkXYPlotActor
  • SetXValuesToIndex() : vtkXYPlotActor
  • SetXValuesToNormalizedArcLength() : vtkXYPlotActor
  • SetXValuesToValue() : vtkXYPlotActor
  • SetXYPlane() : vtkWarpScalar
  • SetXYZFileName() : vtkPLOT3DReader
  • SetYAxisVisibility() : vtkCubeAxesActor2D
  • SetYCoordinates() : vtkRectilinearGrid
  • SetYCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • SetYFreq() : vtkRTAnalyticSource
  • SetYKernel() : vtkImageSeparableConvolution
  • SetYLabel() : vtkCubeAxesActor2D
  • SetYLength() : vtkCubeSource
  • SetYMag() : vtkRTAnalyticSource
  • SetYRange() : vtkXYPlotActor
  • SetYResolution() : vtkPlaneSource
  • SetYShadows() : vtkCursor3D
  • SetYSize() : vtkTriangularTexture, vtkBooleanTexture
  • SetYTitle() : vtkXYPlotActor
  • SetZAxisVisibility() : vtkCubeAxesActor2D
  • SetZbufferData() : vtkRenderWindow, vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • SetZCoordinates() : vtkRectilinearGrid
  • SetZCutOff() : vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageButterworthLowPass, vtkImageButterworthHighPass
  • SetZeroNormalDiffuseIntensity() : vtkEncodedGradientShader
  • SetZeroNormalSpecularIntensity() : vtkEncodedGradientShader
  • SetZeroNormalThreshold() : vtkEncodedGradientEstimator
  • SetZeroPad() : vtkEncodedGradientEstimator
  • SetZFreq() : vtkRTAnalyticSource
  • SetZKernel() : vtkImageSeparableConvolution
  • SetZLabel() : vtkCubeAxesActor2D
  • SetZLength() : vtkCubeSource
  • SetZMag() : vtkRTAnalyticSource
  • SetZShadows() : vtkCursor3D
  • SetZSlice() : vtkImageViewer2, vtkImageViewer, vtkImageMapper, vtkImageActor
  • SFunction : vtkImplicitTextureCoords
  • Shade : vtkVolumeTextureMapper, vtkVolumeProperty
  • ShadeModel_bucket : vtkOpenGLStateCache
  • ShadeOff() : vtkVolumeProperty
  • ShadeOn() : vtkVolumeProperty
  • Shading : VTKRayCastVolumeInfo, VTKVRCStaticInfo
  • ShadingTable : vtkEncodedGradientShader
  • ShadingTableSize : vtkEncodedGradientShader
  • ShadingTableVolume : vtkEncodedGradientShader
  • Shadow : vtkTextMapper, vtkScalarBarActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • shadow : Mesh
  • shadow_flag : SpotLight
  • ShadowOff() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • ShadowOn() : vtkTextMapper, vtkScalarBarActor, vtkParallelCoordinatesActor, vtkLabeledDataMapper, vtkAxisActor2D, vtkXYPlotActor, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D
  • Shadows : vtkRIBLight
  • ShadowsOff() : vtkRIBLight
  • ShadowsOn() : vtkRIBLight
  • ShaftRadius : vtkArrowSource
  • ShaftResolution : vtkArrowSource
  • ShallowCopy() : vtkVolume, vtkTextMapper, vtkScaledTextActor, vtkScalarBarActor, vtkProp3D, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkMapper, vtkLODProp3D, vtkLODActor, vtkFollower, vtkAxisActor2D, vtkAssembly, vtkActor, vtkImageStencilData, vtkLegendBoxActor, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkPiecewiseFunction, vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPropAssembly, vtkProp, vtkPolyData, vtkPointSet, vtkPoints, vtkImageData, vtkGenericCell, vtkFieldData, vtkDataSetAttributes, vtkDataSet, vtkDataObject, vtkCell, vtkAssemblyPath, vtkActor2D, vtkAbstractMapper
  • Shear() : vtkPerspectiveTransform
  • Shift : vtkImageShrink3D, vtkImageShiftScale
  • ShiftKey : vtkRenderWindowInteractor, vtkInteractorStyle
  • Shifts : vtkImageAppend
  • ShiftScaleTime : vtkTransformToGrid
  • shininess : MatProp
  • ShoulderResolution : vtkButtonSource
  • ShoulderTextureCoordinate : vtkButtonSource
  • ShouldIReleaseData() : vtkDataObject
  • ShowCursor() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindowInteractor, vtkRenderWindow, vtkQuartzRenderWindow
  • ShrinkFactor : vtkShrinkPolyData, vtkShrinkFilter
  • ShrinkFactors : vtkImageShrink3D
  • SidesShareVertices : vtkTubeFilter
  • SidesShareVerticesOff() : vtkTubeFilter
  • SidesShareVerticesOn() : vtkTubeFilter
  • Sigma : vtkThinPlateSplineTransform
  • SignalNewMessage() : vtkSharedMemoryCommunicator
  • SignalNextThread() : vtkThreadedController
  • SimpleCriticalSection : vtkCriticalSection
  • SimpleExecute() : vtkSimpleImageFilterExample, vtkSimpleImageToImageFilter
  • SimpleMutexLock : vtkMutexLock
  • SingleData : vtkMultiProcessController, vtkMultiThreader
  • SingleMethod : vtkMultiProcessController, vtkMultiThreader
  • SingleMethodExecute() : vtkThreadedController, vtkSocketController, vtkMultiProcessController, vtkMPIController, vtkMultiThreader
  • SingularValueDecomposition3x3() : vtkMath
  • size : PlyOtherProp, PlyElement
  • Size : vtkXTextMapper, vtkRenderWindowInteractor, vtkRIBExporter, vtkLegendBoxActor, vtkSuperquadricSource, vtkStreamArray, vtkSuperquadric, vtkImplicitDataSet, vtkWindow, vtkViewport, vtkPriorityQueue, vtkIdList, vtkDataArray, vtkCellTypes, vtkCellLinks
  • SizeCX : vtkImageMandelbrotSource
  • SizeEstimator : vtkPImageWriter
  • SizeMTime : vtkXTextMapper
  • SizeOverrideArray : vtkObjectFactory
  • SkipImageData() : vtkEnSightGoldBinaryReader
  • SkipRectilinearGrid() : vtkEnSightGoldBinaryReader
  • SkipStructuredGrid() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • SkipTimeStep() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • SkipUnstructuredGrid() : vtkEnSightGoldBinaryReader, vtkEnSight6BinaryReader
  • SliceEndPointer : vtkImageIterator< DType >
  • SmartPointer : vtkOutputWindow
  • Smoothing : vtkImageToPolyDataFilter
  • SmoothingOff() : vtkImageToPolyDataFilter
  • SmoothingOn() : vtkImageToPolyDataFilter
  • SmoothPoints : vtkSmoothPolyDataFilter
  • Socket : vtkSocketCommunicator
  • SolveCubic() : vtkMath
  • SolveLeastSquares() : vtkMath
  • SolveLinear() : vtkMath
  • SolveLinearSystem() : vtkMath
  • SolveQuadratic() : vtkMath
  • Sort : vtkActor2DCollection, vtkCGMWriter
  • SortBy : vtkCutter
  • SortedInputs : vtkProcessObject
  • SortedInputs2 : vtkProcessObject
  • SortedListSize : vtkVoxelContoursToSurfaceFilter
  • SortedXList : vtkVoxelContoursToSurfaceFilter
  • SortedYList : vtkVoxelContoursToSurfaceFilter
  • SortingStyle : vtkFrustumCoverageCuller
  • SortInputsByLocality() : vtkProcessObject
  • SortLineList() : vtkVoxelContoursToSurfaceFilter
  • SortMerge() : vtkProcessObject
  • SortScalars : vtkDepthSortPolyData
  • SortScalarsOff() : vtkDepthSortPolyData
  • SortScalarsOn() : vtkDepthSortPolyData
  • Source : vtkIterativeClosestPointTransform, vtkGlyph3D, vtkDataObject
  • SourceIndex : vtkMergeFields::Component
  • SourceLandmarks : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • Spacing : vtkImageStencilData, vtkVoxelContoursToSurfaceFilter, vtkDataObjectToDataSetFilter, vtkImageData
  • SpacingArray : vtkDataObjectToDataSetFilter
  • SpacingArrayComponent : vtkDataObjectToDataSetFilter
  • SpacingCallback : vtkImageExport, vtkImageImport
  • SpacingCallbackType : vtkImageImport, vtkImageExport
  • SpacingComponentRange : vtkDataObjectToDataSetFilter
  • SpacingOrOriginHasChanged() : vtkImageStencilData
  • SpacingScale : vtkImageChangeInformation
  • SpanEndPointer : vtkImageIterator< DType >
  • SpanIterator : vtkImageIterator< DType >
  • SpatialMatch : vtkProbeFilter
  • SpatialMatchOff() : vtkProbeFilter
  • SpatialMatchOn() : vtkProbeFilter
  • SpatialRepresentation : vtkSpatialRepresentationFilter
  • SpatialResolution : vtkDEMReader
  • SpawnedThreadActiveFlag : vtkMultiThreader
  • SpawnedThreadActiveFlagLock : vtkMultiThreader
  • SpawnedThreadInfoArray : vtkMultiThreader
  • SpawnedThreadProcessID : vtkMultiThreader
  • SpawnThread() : vtkMultiThreader
  • SpecificFunctionInitialize() : vtkVolumeRayCastMIPFunction, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction, vtkVolumeRayCastCompositeFunction
  • SpecifiedColor : vtkCGMWriter
  • SpecifiedRegionIds : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • Specular : vtkVolumeProperty, vtkProperty
  • specular : MatProp
  • SpecularColor : vtkProperty
  • SpecularPower : vtkVolumeProperty, vtkProperty
  • speed : _vtkStreamPoint
  • Speed : vtkVRMLExporter
  • SpeedScalars : vtkStreamer
  • SpeedScalarsOff() : vtkStreamer
  • SpeedScalarsOn() : vtkStreamer
  • SpinCamera() : vtkInteractorStyle
  • SpinXY() : vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage
  • Split() : vtkSplitField
  • SplitAngle : vtkDecimatePro
  • SplitArray() : vtkSplitField
  • SplitExtent() : vtkImageRFFT, vtkImageFFT, vtkImageEuclideanDistance, vtkImageToImageFilter, vtkImageMultipleInputFilter, vtkExtentTranslator
  • SplitExtentByPoints() : vtkExtentTranslator
  • SplitExtentTmp() : vtkImageClip
  • SplitLoop() : vtkDecimate, vtkDecimatePro
  • SplitMesh() : vtkDecimatePro
  • SplitMode : vtkExtentTranslator
  • Splitting : vtkPolyDataNormals, vtkDecimatePro
  • SplittingOff() : vtkPolyDataNormals, vtkDecimatePro
  • SplittingOn() : vtkPolyDataNormals, vtkDecimatePro
  • SplitVertex() : vtkDecimatePro
  • SpotLightList : vtk3DSImporter
  • SquareNeighborhood : vtkImageIslandRemoval2D
  • SquareNeighborhoodOff() : vtkImageIslandRemoval2D
  • SquareNeighborhoodOn() : vtkImageIslandRemoval2D
  • Squeeze() : vtkVoidArray, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkPolyData, vtkPointSet, vtkPoints, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkFieldData, vtkDoubleArray, vtkDataSet, vtkDataArray, vtkCharArray, vtkCellTypes, vtkCellLinks, vtkCellArray, vtkBitArray
  • SqueezeInputArray() : vtkProcessObject
  • SRange : vtkTextureMapToPlane, vtkProjectedTexture
  • Stack : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkFunctionParser, vtkTransformConcatenationStack
  • StackBottom : vtkTransformConcatenationStack
  • StackPointer : vtkFunctionParser
  • StackSize : vtkFunctionParser, vtkTransformConcatenationStack
  • StandardDeviation : vtkRTAnalyticSource, vtkImageGaussianSource, vtkImageAccumulate
  • StandardDeviations : vtkImageGaussianSmooth
  • Start() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32RenderWindowInteractor, vtkWin32OpenGLRenderWindow, vtkRenderWindowInteractor, vtkRenderWindow, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkThreadedController
  • start : Chunk
  • StartAnimate() : vtkInteractorStyle
  • StartAppend() : vtkImplicitModeller, vtkQuadricClustering
  • StartByMatchingCentroids : vtkIterativeClosestPointTransform
  • StartByMatchingCentroidsOff() : vtkIterativeClosestPointTransform
  • StartByMatchingCentroidsOn() : vtkIterativeClosestPointTransform
  • StartCell : vtkStreamer, vtkHyperStreamline
  • StartDolly() : vtkInteractorStyle
  • StartElement() : vtkXMLParser
  • StartElementFunction() : vtkXMLParser
  • StartEvent : vtkCommand
  • StartFrom : vtkStreamer, vtkHyperStreamline
  • StartInteractor() : vtkCompositeManager
  • StartInteractorTag : vtkCompositeManager
  • StartLogging() : vtkMPIEventLog
  • StartPan() : vtkInteractorStyle
  • StartPCoords : vtkStreamer, vtkHyperStreamline
  • StartPhi : vtkSphereSource
  • StartPick() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • StartPickCallback() : vtkRenderWindowInteractor
  • StartPickEvent : vtkCommand
  • StartPickTag : vtkRenderWindowInteractor, vtkAbstractPicker
  • StartPiece : vtkPDataSetWriter
  • StartPix : vtkInteractorStyleUnicam
  • StartPosition : vtkStreamer, vtkHyperStreamline
  • StartRender() : vtkCompositeManager
  • StartRotate() : vtkInteractorStyle
  • StartSpin() : vtkInteractorStyle
  • StartState() : vtkInteractorStyle
  • StartSubId : vtkStreamer, vtkHyperStreamline
  • StartTag : vtkCompositeManager, vtkViewport, vtkProcessObject
  • StartTheta : vtkSphereSource
  • StartTime : vtkTimerLog
  • StartTimer() : vtkInteractorStyle, vtkThreadSafeLog, vtkTimerLog
  • StartTimeStamp : vtkVideoSource
  • StartUniformScale() : vtkInteractorStyle
  • StartUserInteraction() : vtkInteractorStyleUser
  • StartWrite : vtkExporter
  • StartWriteArg : vtkExporter
  • StartWriteArgDelete : vtkExporter
  • StartZoom() : vtkInteractorStyle
  • state : vtkInteractorStyleUnicam
  • State : vtkLODProp3DEntry, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyle, vtkSpherePuzzle
  • Stats : vtkDecimate
  • StatusOK() : vtkVolumeProMapper
  • Stencil : vtkImageBlend
  • StepLength : vtkStreamLine, vtkHyperStreamline
  • Stereo : vtkPerspectiveTransform, vtkCamera
  • StereoBuffer : vtkRenderWindow
  • StereoCapableWindow : vtkRenderWindow
  • StereoCapableWindowOff() : vtkRenderWindow
  • StereoCapableWindowOn() : vtkRenderWindow
  • StereoMidpoint() : vtkRenderWindow
  • StereoRender : vtkRenderWindow
  • StereoRenderComplete() : vtkRenderWindow
  • StereoRenderOff() : vtkRenderWindow
  • StereoRenderOn() : vtkRenderWindow
  • StereoStatus : vtkRenderWindow
  • StereoType : vtkRenderWindow
  • StereoUpdate() : vtkRenderWindow, vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • StillUpdateRate : vtkRenderWindowInteractor
  • Stop() : vtkWin32VideoSource, vtkVideoSource, vtkMILVideoSource
  • StopAnimate() : vtkInteractorStyle
  • StopLogging() : vtkMPIEventLog
  • StopState() : vtkInteractorStyle
  • StopTimer() : vtkThreadSafeLog, vtkTimerLog
  • Storage : vtkTensor
  • store_item() : vtkPLY
  • store_prop : PlyElement
  • StoreAttributes : vtkEdgeTable
  • StoreRenderTime() : vtkVolumeRayCastMapper
  • str() : ostrstream
  • StrDup() : vtkVRMLAllocator
  • Stream : vtkXMLParser
  • Streamers : vtkStreamer, vtkHyperStreamline
  • Strides : vtkImageSpatialFilter
  • StringCommand : vtkTclCommand
  • Strips : vtkPolyData
  • StripsArray : vtkDataObjectToDataSetFilter
  • StripsArrayComponent : vtkDataObjectToDataSetFilter
  • StripsComponentRange : vtkDataObjectToDataSetFilter
  • StructuredExecute() : vtkDataSetTriangleFilter, vtkDataSetSurfaceFilter
  • StructuredFlag : vtkPDataSetReader
  • StructuredGridContour() : vtkKitwareContourFilter
  • StructuredGridExecute() : vtkPVGeometryFilter, vtkPDataSetReader, vtkGeometryFilter
  • StructuredPointsContour() : vtkMarchingContourFilter, vtkKitwareContourFilter
  • Study : vtkMedicalImageReader2
  • Style : vtkRenderWindowInteractor
  • SubDivide() : vtkDividingCubes, vtkRecursiveDividingCubes
  • SubFrames : vtkRenderWindow
  • subId : _vtkStreamPoint
  • SubId : vtkCellPicker
  • SubImageSize : vtkImageToPolyDataFilter
  • SubjectHelper : vtkObject
  • SubVolume : vtkVolumeProMapper
  • SubVoxel : vtkDividingCubes
  • SubVoxelNormals : vtkDividingCubes
  • SubVoxelPts : vtkDividingCubes
  • SubVoxelScalars : vtkDividingCubes
  • SuccessfulTriangulation : vtkPolygon
  • Superclass : vtkTIFFReader
  • SuperSampling : vtkVolumeProMapper
  • SuperSamplingFactor : vtkVolumeProMapper
  • SuperSamplingOff() : vtkVolumeProMapper
  • SuperSamplingOn() : vtkVolumeProMapper
  • SurfaceArea : vtkMassProperties
  • SurfaceShader : vtkRIBProperty
  • Swap2BE() : vtkByteSwap
  • Swap2BERange() : vtkByteSwap
  • Swap2LE() : vtkByteSwap
  • Swap2LERange() : vtkByteSwap
  • Swap4BE() : vtkByteSwap
  • Swap4BERange() : vtkByteSwap
  • Swap4LE() : vtkByteSwap
  • Swap4LERange() : vtkByteSwap
  • Swap8BE() : vtkByteSwap
  • Swap8BERange() : vtkByteSwap
  • Swap8LE() : vtkByteSwap
  • Swap8LERange() : vtkByteSwap
  • SwapBuffers : vtkXImageWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzImageWindow, vtkOpenGLImageWindow, vtkMesaImageWindow, vtkImageWindow, vtkRenderWindow
  • SwapBuffersOff() : vtkRenderWindow
  • SwapBuffersOn() : vtkRenderWindow
  • SwapBytes : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SwapBytesInReceivedData : vtkSocketCommunicator
  • SwapBytesOff() : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SwapBytesOn() : vtkVolume16Reader, vtkParticleReader, vtkMCubesReader, vtkImageReader2
  • SwapFlag : vtkWin32ImageWindow
  • SwapForwardInverse() : vtkTransformPair
  • SwapVoidRange() : vtkByteSwap
  • SwapWrite2BERange() : vtkByteSwap
  • SwapWrite4BERange() : vtkByteSwap
  • SwapWrite8BERange() : vtkByteSwap
  • Switch : vtkLight
  • SwitchOff() : vtkLight
  • SwitchOn() : vtkLight
  • Symbol : vtkLegendBoxActor
  • SymbolActor : vtkLegendBoxActor
  • SymbolMapper : vtkLegendBoxActor
  • SymbolTransform : vtkLegendBoxActor
  • Symmetric : vtkAxes
  • SymmetricOff() : vtkAxes
  • SymmetricOn() : vtkAxes

- t -
  • t : _vtkStreamPoint
  • T : vtkDecimate, vtkInterpolateDataSetAttributes, vtkTensor
  • Table : vtkColorTransferFunction, vtkLookupTable, vtkEdgeTable
  • TableMaxId : vtkEdgeTable
  • TableRange : vtkLookupTable
  • TableSize : vtkColorTransferFunction, vtkEdgeTable
  • tag : Chunk
  • Tag : vtkOutputPort, vtkInputPort, vtkTclCommandArgStruct
  • Tags : vtkInputPort, vtkCompositeManager, vtkThreadSafeLog
  • Tail : vtkSplitField, vtkRearrangeFields, vtkMergeFields
  • target : Camera, SpotLight
  • Target : vtkIterativeClosestPointTransform, vtkImageProgressIterator< DType >
  • TargetFlag : vtkSubPixelPositionEdgels
  • TargetFlagOff() : vtkSubPixelPositionEdgels
  • TargetFlagOn() : vtkSubPixelPositionEdgels
  • TargetIndices : vtkDataSetAttributes
  • TargetLandmarks : vtkThinPlateSplineTransform, vtkLandmarkTransform
  • TargetReduction : vtkDecimate, vtkDecimatePro
  • TargetTextureSize : vtkVolumeTextureMapper2D
  • TargetValue : vtkSubPixelPositionEdgels
  • TCoordArrayComponents : vtkFieldDataToAttributeDataFilter
  • TCoordArrays : vtkFieldDataToAttributeDataFilter
  • TCoordComponentRange : vtkFieldDataToAttributeDataFilter
  • TCoordComponents : vtkExtractTensorComponents
  • TCoordNormalize : vtkFieldDataToAttributeDataFilter
  • TCoords : vtkOpenGLImageActor, vtkMesaImageActor
  • TCOORDS : vtkDataSetAttributes
  • TCoordsName : vtkDataWriter, vtkDataReader
  • TCoordsNameAllocSize : vtkDataReader
  • TCoordsNameInFile : vtkDataReader
  • TemplateTransformInverse() : vtkWarpTransform
  • TemplateTransformPoint() : vtkWarpTransform
  • TempStorage : vtkPLOT3DReader
  • TensorArrayComponents : vtkFieldDataToAttributeDataFilter
  • TensorArrays : vtkFieldDataToAttributeDataFilter
  • TensorComponentRange : vtkFieldDataToAttributeDataFilter
  • TensorMode : vtkCellDerivatives
  • TensorNormalize : vtkFieldDataToAttributeDataFilter
  • TENSORS : vtkDataSetAttributes
  • TensorsName : vtkDataWriter, vtkDataReader
  • TensorsNameAllocSize : vtkDataReader
  • TensorsNameInFile : vtkDataReader
  • TerminalEigenvalue : vtkHyperStreamline
  • TerminalNodesRequested : vtkSpatialRepresentationFilter
  • TerminalSpeed : vtkStreamer
  • TerminateApp() : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • TerminateThread() : vtkMultiThreader
  • Tesselate() : vtkQuadraticEdge, vtkNonLinearCell
  • Tesselation : vtkQuadraticEdge
  • Test() : vtkMPICommunicator::Request
  • Tetra : vtkUnstructuredGrid
  • TetraArray : vtkDelaunay3D
  • TetraCenter() : vtkTetra
  • tex_map : MatProp
  • tex_strength : MatProp
  • TexEnvf_MODE_bucket : vtkOpenGLStateCache
  • Text : vtkVectorText, vtkTextSource
  • TextActor : vtkScaledTextActor, vtkLegendBoxActor
  • TextLines : vtkTextMapper
  • TextMapper : vtkLegendBoxActor
  • Texture : vtkVolumeTextureMapper2D, vtkActor
  • TextureDimension : vtkThresholdTextureCoords
  • TextureDimensions : vtkButtonSource
  • TextureFileName : vtkBYUWriter, vtkBYUReader
  • TextureMTime : vtkVolumeTextureMapper2D
  • TexturePattern : vtkTriangularTexture
  • TexturePrefix : vtkRIBExporter
  • TextureResolution : vtkButtonSource
  • TextureResourceIds : vtkQuartzRenderWindow, vtkOpenGLRenderWindow, vtkMesaRenderWindow
  • TextureSize : vtkVolumeTextureMapper2D
  • TextureStyle : vtkButtonSource
  • TFunction : vtkImplicitTextureCoords
  • Theta : vtkTexturedSphereSource
  • theta : _vtkStreamPoint
  • ThetaMaximum : vtkImageEuclideanToPolar
  • ThetaResolution : vtkTexturedSphereSource, vtkSuperquadricSource, vtkSphereSource
  • ThetaRoundness : vtkSuperquadricSource, vtkSuperquadric
  • Thickness : vtkCamera, vtkBooleanTexture, vtkSuperquadricSource, vtkSuperquadric
  • ThreadedExecute() : vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D, vtkImplicitFunctionToImageStencil, vtkImageWrapPad, vtkImageVariance3D, vtkImageToImageStencil, vtkImageThreshold, vtkImageStencilSource, vtkImageStencil, vtkImageSobel3D, vtkImageSobel2D, vtkImageSkeleton2D, vtkImageShrink3D, vtkImageShiftScale, vtkImageRGBToHSV, vtkImageRFFT, vtkImageReslice, vtkImageResample, vtkImageRange3D, vtkImagePermute, vtkImageNormalize, vtkImageNonMaximumSuppression, vtkImageMirrorPad, vtkImageMedian3D, vtkImageMathematics, vtkImageMaskBits, vtkImageMask, vtkImageMapToWindowLevelColors, vtkImageMapToColors, vtkImageMagnitude, vtkImageMagnify, vtkImageLuminance, vtkImageLogic, vtkImageLogarithmicScale, vtkImageLaplacian, vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageHybridMedian2D, vtkImageHSVToRGB, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSmooth, vtkImageFourierCenter, vtkImageFlip, vtkImageFFT, vtkImageExtractComponents, vtkImageEuclideanToPolar, vtkImageDotProduct, vtkImageDivergence, vtkImageDilateErode3D, vtkImageDifference, vtkImageCorrelation, vtkImageConvolve, vtkImageContinuousErode3D, vtkImageContinuousDilate3D, vtkImageConstantPad, vtkImageCheckerboard, vtkImageCast, vtkImageButterworthLowPass, vtkImageButterworthHighPass, vtkImageBlend, vtkImageAppendComponents, vtkImageAppend, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkPolyDataToImageStencil, vtkImageToImageFilter, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter
  • ThreadedIntegrate() : vtkStreamer
  • Threader : vtkVolumeRayCastMapper, vtkEncodedGradientEstimator, vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D, vtkImplicitModeller, vtkStreamer, vtkImageToImageFilter, vtkImageMultipleInputFilter
  • ThreadID : ThreadInfoStruct
  • ThreadId : vtkThreadedController
  • ThreadIdType : vtkThreadedController
  • ThreadInfoArray : vtkMultiThreader
  • Threads : vtkSynchronizedTemplates3D, vtkGridSynchronizedTemplates3D
  • ThreeDimensionalLayout : vtkGraphLayoutFilter
  • ThreeDimensionalLayoutOff() : vtkGraphLayoutFilter
  • ThreeDimensionalLayoutOn() : vtkGraphLayoutFilter
  • ThreeDimensionalLeader : vtkCaptionActor2D
  • ThreeDimensionalLeaderOff() : vtkCaptionActor2D
  • ThreeDimensionalLeaderOn() : vtkCaptionActor2D
  • Threshold : vtkImplicitFunctionToImageStencil, vtkImageToImageStencil, vtkImageDifference
  • ThresholdBetween() : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • ThresholdByLower() : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • ThresholdByUpper() : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • ThresholdedErrorPerThread : vtkImageDifference
  • ThresholdFunction : vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • TickLength : vtkAxisActor2D
  • TickOffset : vtkAxisActor2D
  • TicksPerSecond : vtkTimerLog
  • TickVisibility : vtkAxisActor2D
  • TickVisibilityOff() : vtkAxisActor2D
  • TickVisibilityOn() : vtkAxisActor2D
  • TileScale : vtkWindow
  • TileSize : vtkWindow
  • TileViewport : vtkWindow
  • Time : vtkPLOT3DReader
  • TimeFactor : vtkRenderer
  • TimeIncrement : vtkStreamPoints
  • Timer : vtkXRenderWindowInteractor, vtkThreadSafeLog, vtkCompositeManager, vtkAbstractMapper
  • TimerEvent : vtkCommand
  • TimerId : vtkWin32RenderWindowInteractor, vtkQuartzRenderWindowInteractor
  • TimerLog : vtkTimerLog
  • TimerRunning : vtkInteractorStyleFlight
  • TimerTag : vtkInteractorStyleUser
  • Times : vtkImageCacheFilter
  • TimeSetFilenameNumbersCollection : vtkEnSightReader
  • TimeSets : vtkEnSightReader
  • TimeSetsWithFilenameNumbers : vtkEnSightReader
  • TimeSetTimeValuesCollection : vtkEnSightReader
  • TimeToDraw : vtkAbstractMapper
  • TimeValue : vtkGenericEnSightReader, vtkEnSightReader
  • TipLength : vtkArrowSource
  • TipRadius : vtkArrowSource
  • TipResolution : vtkArrowSource
  • Title : vtkScalarBarActor, vtkAxisActor2D, vtkXYPlotActor
  • TitleActor : vtkAxisActor2D, vtkXYPlotActor
  • TitleMapper : vtkAxisActor2D, vtkXYPlotActor
  • TitleVisibility : vtkAxisActor2D
  • TitleVisibilityOff() : vtkAxisActor2D
  • TitleVisibilityOn() : vtkAxisActor2D
  • TkWin : vtkTkRenderWidget, vtkTkImageWindowWidget, vtkTkImageViewerWidget
  • ToFieldLoc : vtkRearrangeFields::Operation
  • Tolerance : vtkSelectVisiblePoints, vtkPicker, vtkPolyDataToImageStencil, vtkDelaunay3D, vtkDelaunay2D, vtkCleanPolyData, vtkPolygon, vtkLocator
  • ToleranceIsAbsolute : vtkCleanPolyData
  • ToleranceIsAbsoluteOff() : vtkCleanPolyData
  • ToleranceIsAbsoluteOn() : vtkCleanPolyData
  • top : vtkXRenderWindowTclInteractor
  • Top : VectorType< T >, vtkXRenderWindowInteractor, vtkCollection
  • TopLevelShell : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor
  • Topology : vtkDataSetToDataObjectFilter
  • TopologyOff() : vtkDataSetToDataObjectFilter
  • TopologyOn() : vtkDataSetToDataObjectFilter
  • Toroidal : vtkSuperquadricSource, vtkSuperquadric
  • ToroidalOff() : vtkSuperquadricSource, vtkSuperquadric
  • ToroidalOn() : vtkSuperquadricSource, vtkSuperquadric
  • TotalWeight : vtkImplicitSum
  • TrackballActor : vtkInteractorStyleSwitch
  • TrackballCamera : vtkInteractorStyleSwitch
  • TrackballDollyActor() : vtkInteractorStyleTrackball
  • TrackballDollyCamera() : vtkInteractorStyleTrackball
  • TrackballMode : vtkInteractorStyleTrackball
  • TrackballPanActor() : vtkInteractorStyleTrackball
  • TrackballPanCamera() : vtkInteractorStyleTrackball
  • TrackballRotateActor() : vtkInteractorStyleTrackball
  • TrackballRotateCamera() : vtkInteractorStyleTrackball
  • TrackballScaleActor() : vtkInteractorStyleTrackball
  • TrackballSpinActor() : vtkInteractorStyleTrackball
  • TrackballSpinCamera() : vtkInteractorStyleTrackball
  • TRange : vtkTextureMapToPlane, vtkProjectedTexture
  • TRANSFER_NEEDED_TAG : vtkInputPort
  • TransferNeeded : vtkInputPort
  • Transform : vtkProp3D, vtkPicker, vtkCamera, vtkVolume16Reader, vtkImageReader, vtkLegendBoxActor, vtkDepthSortPolyData, vtkTransformPolyDataFilter, vtkTransformFilter, vtkSpherePuzzle, vtkDelaunay2D, vtkImplicitFunction, vtkAssemblyPath
  • TransformBounds() : vtkCubeAxesActor2D
  • TransformCoordinate : vtkPolyDataMapper2D
  • TransformDoubleNormal() : vtkLinearTransform
  • TransformDoubleNormalAtPoint() : vtkAbstractTransform
  • TransformDoublePoint() : vtkAbstractTransform
  • TransformDoubleVector() : vtkLinearTransform
  • TransformDoubleVectorAtPoint() : vtkAbstractTransform
  • TransformedDirection : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • TransformedEnd : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • TransformedFocalPointReturn : vtkLight
  • TransformedIncrement : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • TransformedPositionReturn : vtkLight
  • TransformedProp : vtkAssemblyPath
  • TransformedStart : VTKVRCDynamicInfo, VTKRayCastRayInfo
  • TransformFloatNormal() : vtkLinearTransform
  • TransformFloatNormalAtPoint() : vtkAbstractTransform
  • TransformFloatPoint() : vtkAbstractTransform
  • TransformFloatVector() : vtkLinearTransform
  • TransformFloatVectorAtPoint() : vtkAbstractTransform
  • TransformGlyph() : vtkGlyphSource2D
  • TransformInputSampling : vtkImageReslice
  • TransformInputSamplingOff() : vtkImageReslice
  • TransformInputSamplingOn() : vtkImageReslice
  • TransformList : vtkTransformConcatenation
  • TransformMatrix : vtkLight
  • TransformNormal() : vtkLinearTransform
  • TransformNormalAtPoint() : vtkAbstractTransform
  • TransformNormals() : vtkLinearTransform, vtkIdentityTransform
  • TransformPoint() : vtkXYPlotActor, vtkAbstractTransform
  • TransformPoints() : vtkLinearTransform, vtkIdentityTransform, vtkHomogeneousTransform, vtkAbstractTransform
  • TransformPointsNormalsVectors() : vtkLinearTransform, vtkIdentityTransform, vtkHomogeneousTransform, vtkAbstractTransform
  • Transforms : vtkSweptSurface, vtkWeightedTransformFilter
  • TransformSlice() : vtkVolume16Reader
  • TransformVector() : vtkLinearTransform
  • TransformVectorAtPoint() : vtkAbstractTransform
  • TransformVectors() : vtkLinearTransform, vtkIdentityTransform
  • Translate : vtkTransform, vtkPerspectiveTransform, vtkGeneralTransform, vtkTransformConcatenation, vtkImageToStructuredPoints
  • Translation : vtkImageTranslateExtent, vtkRotationalExtrusionFilter
  • transparency : MatProp
  • Transparent() : vtkRenderer
  • Transpose() : vtkMatrix4x4
  • Transpose3x3() : vtkMath
  • TraversalLocation : vtkCellArray
  • TraverseAndMark() : vtkPolyDataConnectivityFilter, vtkConnectivityFilter
  • Tree : vtkOBBTree, vtkSimpleScalarTree, vtkCellLocator
  • TreeSize : vtkSimpleScalarTree
  • Triangle : vtkWedge, vtkUnstructuredGrid, vtkTriangleStrip, vtkTetra, vtkPyramid, vtkPolygon, vtkPolyData
  • TriangleArea() : vtkTriangle
  • TriangleCenter() : vtkTriangle
  • TriangleIntersectsNode() : vtkOBBTree
  • Triangles : vtkImageMarchingCubes
  • TriangleStrip : vtkUnstructuredGrid, vtkPolyData
  • Triangulate() : vtkDecimate, vtkWedge, vtkVoxel, vtkVertex, vtkTriangleStrip, vtkTriangle, vtkTetra, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPixel, vtkOrderedTriangulator, vtkLine, vtkHexahedron, vtkGenericCell, vtkEmptyCell, vtkCell
  • Triangulator : vtkDataSetTriangleFilter, vtkCell3D
  • TriggerAsynchronousUpdate() : vtkInputPort, vtkImageStencilData, vtkSource, vtkDataObject
  • TriggerBreakRMIs() : vtkMultiProcessController
  • TriggerRMI() : vtkMultiProcessController
  • TriggerUpdate() : vtkOutputPort
  • TriggerUpdateInformation() : vtkOutputPort
  • Tris : vtkPolygon
  • TriScalars : vtkPolygon
  • Truncate() : vtkLargeInteger
  • Tuple : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFieldData, vtkDoubleArray, vtkCharArray, vtkBitArray
  • TupleSize : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkFieldData, vtkDoubleArray, vtkCharArray, vtkBitArray
  • TwoSided : vtkButtonSource
  • TwoSidedLighting : vtkRenderer
  • TwoSidedLightingOff() : vtkRenderer
  • TwoSidedLightingOn() : vtkRenderer
  • TwoSidedOff() : vtkButtonSource
  • TwoSidedOn() : vtkButtonSource
  • Type : vtkMaskFields::CopyFieldFlag
  • TypeArray : vtkCellTypes
  • Types : vtkUnstructuredGrid

- u -
  • UFlowFileName : vtkPOPReader
  • UFlowFileOffset : vtkPOPReader
  • UnBlankPoint() : vtkStructuredGrid
  • UnconnectedValue : vtkImageConnector
  • UNEXPECTED_VALUE : vtkInitialValueProblemSolver
  • UnknownError : vtkErrorCode
  • Unlock() : vtkMutexLock, vtkSimpleMutexLock, vtkCriticalSection, vtkSimpleCriticalSection
  • UnpackRasterLine() : vtkWin32VideoSource, vtkVideoSource
  • UnrecognizedFileTypeError : vtkErrorCode
  • UnRegister() : vtkRenderWindowInteractor, vtkRenderWindow, vtkSelectPolyData, vtkSource, vtkPointSet, vtkObject, vtkDataObject, vtkContainer, vtkCommand, vtkAbstractTransform
  • UnRegisterAllFactories() : vtkObjectFactory
  • UnRegisterAllOutputs() : vtkSource
  • UnRegisterFactory() : vtkObjectFactory
  • UnRegisterInstantiator() : vtkInstantiator
  • UnselectedOutput : vtkSelectPolyData
  • UnsignedCharRGBAValue : vtkColorTransferFunction
  • UnstructuredExecute() : vtkDataSetTriangleFilter
  • UnstructuredGridExecute() : vtkPVGeometryFilter, vtkPDataSetReader, vtkGeometryFilter, vtkDataSetSurfaceFilter
  • UnstructuredNodeIds : vtkEnSight6Reader, vtkEnSight6BinaryReader
  • UnstructuredPartIds : vtkEnSightReader
  • UnstructuredPoints : vtkEnSight6Reader, vtkEnSight6BinaryReader
  • uobj : vtkJavaCommand, vtkJavaVoidFuncArg
  • Up : vtkProjectedTexture
  • Update() : vtkVolumeTextureMapper, vtkVolumeMapper, vtkVolume, vtkPolyDataMapper, vtkMapper, vtkLightKit, vtkImporter, vtkExporter, vtkEncodedGradientEstimator, vtkAbstractMapper3D, vtkSliceCubes, vtkImageMarchingCubes, vtkPDataSetReader, vtkWriter, vtkGenericEnSightReader, vtkEnSightReader, vtkDataSetReader, vtkMassProperties, vtkSource, vtkLocator, vtkDataSetAttributes, vtkDataObject, vtkAbstractTransform
  • UPDATE_EXTENT_TAG : vtkInputPort
  • UpdateCamera() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkRenderer
  • UpdateCellCount() : vtkCellArray
  • UpdateComponentRange() : vtkFieldDataToAttributeDataFilter
  • UpdateCropping() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • UpdateCursor() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • UpdateCutPlane() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • UpdateData() : vtkMemoryLimitImageDataStreamer, vtkInputPort, vtkImageStencilData, vtkImageDataStreamer, vtkImageCast, vtkImageCacheFilter, vtkImplicitModeller, vtkProgrammableSource, vtkSource, vtkImageData, vtkDataObject
  • UpdateDataCallback : vtkImageExport, vtkImageImport
  • UpdateDataCallbackType : vtkImageImport, vtkImageExport
  • UpdateExtent : vtkDataObject
  • UpdateExtentInitialized : vtkDataObject
  • UpdateExtentIsEmpty() : vtkDataObject
  • UpdateExtentIsOutsideOfTheExtent() : vtkDataObject
  • UpdateFrameBuffer() : vtkVideoSource
  • UpdateGeometry() : vtkRenderer
  • UpdateGhostLevel : vtkDataObject
  • UpdateInformation() : vtkRendererSource, vtkInputPort, vtkImageImport, vtkProgrammableSource, vtkSource, vtkDataObject
  • UpdateInformationCallback : vtkImageExport, vtkImageImport
  • UpdateInformationCallbackType : vtkImageImport, vtkImageExport
  • UpdateInternalState() : vtkInteractorStyle
  • UpdateLightGeometry() : vtkRenderer
  • UpdateLights() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkRenderer, vtkOpenGLRenderer, vtkMesaRenderer
  • UpdateMouseSteering() : vtkInteractorStyleFlight
  • UpdateMTimes() : vtkVolumeProperty
  • UpdateNormals() : vtkFiniteDifferenceGradientEstimator, vtkEncodedGradientEstimator
  • UpdateNumberOfPieces : vtkDataObject
  • UpdateOwnLODs() : vtkLODActor
  • UpdatePaths() : vtkAssembly, vtkPropAssembly
  • UpdatePickId() : vtkOpenGLRenderer, vtkMesaRenderer, vtkImager, vtkViewport
  • UpdatePiece : vtkDataObject
  • UpdatePieceMeasures() : vtkDicer
  • UpdatePlane() : vtkPlaneSource
  • UpdatePointType() : vtkOrderedTriangulator
  • UpdateProgress() : vtkProcessObject
  • UpdateProperties() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • UpdateScalarOpacityforSampleSize() : vtkVolume
  • UpdateShadingTable() : vtkEncodedGradientShader
  • UpdateShadingTables() : vtkVolumeRayCastMapper
  • UpdateShiftScale() : vtkTransformToGrid
  • UpdateSize() : vtkXRenderWindowTclInteractor, vtkRenderWindowInteractor
  • UpdateSizeAndPosition() : vtkQuartzRenderWindow
  • UpdateTime : vtkOutputPort, vtkDataObject
  • UpdateTransferFunctions() : vtkVolume
  • UpdateViewport() : vtkOpenGLCamera, vtkMesaCamera, vtkCamera
  • UpdateVolume() : vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper
  • UpdateWholeExtent() : vtkSource
  • Updating : vtkDataObjectToDataSetFilter, vtkSource
  • Upper() : vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • UpperThreshold : vtkImageToImageStencil, vtkImageThreshold, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold
  • UpStreamMTime : vtkInputPort
  • UpVector : vtkCutMaterial
  • UseChar : vtkCompositeManager
  • UseCharOff() : vtkCompositeManager
  • UseCharOn() : vtkCompositeManager
  • UseCompositing : vtkCompositeManager
  • UseCompositingOff() : vtkCompositeManager
  • UseCompositingOn() : vtkCompositeManager
  • UseCustomExtents : vtkImageMapper
  • UseCustomExtentsOff() : vtkImageMapper
  • UseCustomExtentsOn() : vtkImageMapper
  • UseCylinderClip : vtkEncodedGradientEstimator
  • Used : VectorType< T >
  • UseDefaultNormal : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • UseDefaultNormalOff() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • UseDefaultNormalOn() : vtkArcPlotter, vtkTubeFilter, vtkRibbonFilter
  • UseFeatureEdges : vtkQuadricClustering
  • UseFeatureEdgesOff() : vtkQuadricClustering
  • UseFeatureEdgesOn() : vtkQuadricClustering
  • UseFeaturePoints : vtkQuadricClustering
  • UseFeaturePointsOff() : vtkQuadricClustering
  • UseFeaturePointsOn() : vtkQuadricClustering
  • UseFileSets : vtkEnSightReader
  • UseFileSetsOff() : vtkEnSightReader
  • UseFileSetsOn() : vtkEnSightReader
  • UseInputPoints : vtkQuadricClustering
  • UseInputPointsOff() : vtkQuadricClustering
  • UseInputPointsOn() : vtkQuadricClustering
  • UseInternalTriangles : vtkQuadricClustering
  • UseInternalTrianglesOff() : vtkQuadricClustering
  • UseInternalTrianglesOn() : vtkQuadricClustering
  • UseLookupTableScalarRange : vtkPolyDataMapper2D, vtkMapper
  • UseLookupTableScalarRangeOff() : vtkPolyDataMapper2D, vtkMapper
  • UseLookupTableScalarRangeOn() : vtkPolyDataMapper2D, vtkMapper
  • UseNew : VectorType< T >
  • useNode() : vtkVRMLImporter
  • UseNormal : vtkWarpScalar
  • UseNormalOff() : vtkWarpScalar
  • UseNormalOn() : vtkWarpScalar
  • UseRanges : vtkCubeAxesActor2D
  • UseRangesOff() : vtkCubeAxesActor2D
  • UseRangesOn() : vtkCubeAxesActor2D
  • UserCallback() : vtkRenderWindowInteractor
  • UserData : ThreadInfoStruct
  • UseRelativeFileNames : vtkPDataSetWriter
  • UseRelativeFileNamesOff() : vtkPDataSetWriter
  • UseRelativeFileNamesOn() : vtkPDataSetWriter
  • UserError : vtkErrorCode
  • UserEvent : vtkCommand
  • UserManagedInputsOff() : vtkAppendPolyData
  • UserManagedInputsOn() : vtkAppendPolyData
  • UserMatrix : vtkProp3D
  • UserTag : vtkRenderWindowInteractor, vtkInteractorStyleUser
  • UserTransform : vtkProp3D
  • UseScalarTree : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • UseScalarTreeOff() : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • UseScalarTreeOn() : vtkMarchingContourFilter, vtkContourGrid, vtkContourFilter
  • UseStrips : vtkDataSetSurfaceFilter
  • UseStripsOff() : vtkDataSetSurfaceFilter
  • UseStripsOn() : vtkDataSetSurfaceFilter
  • UseTimeSets : vtkEnSightReader
  • UseTimeSetsOff() : vtkEnSightReader
  • UseTimeSetsOn() : vtkEnSightReader
  • UseTwoSortIdsOff() : vtkOrderedTriangulator
  • UseTwoSortIdsOn() : vtkOrderedTriangulator
  • Uvinf : vtkPLOT3DReader

- v -
  • v : _vtkStreamPoint
  • V : vtkDecimate
  • ValidPoints : vtkProbeFilter
  • Vals : vtkInitialValueProblemSolver
  • Value : vtkSliceCubes, vtkDividingCubes, vtkRecursiveDividingCubes, vtkEdgePoints, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCoordinate
  • ValueRange : vtkLookupTable
  • Values : vtkThreadSafeLog
  • ValueScale : vtkPiecewiseFunctionShiftScale
  • ValueShift : vtkPiecewiseFunctionShiftScale
  • VariableDescriptions : vtkGenericEnSightReader, vtkEnSightReader
  • VariableFileNames : vtkEnSightReader
  • VariableFileSets : vtkEnSightReader
  • VariableMode : vtkEnSightReader
  • VariableMTime : vtkFunctionParser
  • VariableTimeSets : vtkEnSightReader
  • VariableTypes : vtkGenericEnSightReader, vtkEnSightReader
  • VaryRadius : vtkTubeFilter
  • VaryWidth : vtkRibbonFilter
  • VaryWidthOff() : vtkRibbonFilter
  • VaryWidthOn() : vtkRibbonFilter
  • Vector : vtkDepthSortPolyData, vtkSimpleElevationFilter, vtkLinearExtrusionFilter
  • VectorArrayComponents : vtkFieldDataToAttributeDataFilter
  • VectorArrayNames : vtkArrayCalculator
  • VectorArrays : vtkFieldDataToAttributeDataFilter
  • VectorComponentRange : vtkFieldDataToAttributeDataFilter
  • VectorComponents : vtkExtractTensorComponents
  • VectorFunctionFileName : vtkPLOT3DReader
  • VectorFunctionNumber : vtkPLOT3DReader
  • VectorMode : vtkHedgeHog, vtkGlyph3D, vtkCellDerivatives
  • VectorNormalize : vtkFieldDataToAttributeDataFilter
  • VECTORS : vtkDataSetAttributes
  • VectorsName : vtkDataWriter, vtkDataReader
  • VectorsNameAllocSize : vtkDataReader
  • VectorsNameInFile : vtkDataReader
  • VectorType() : VectorType< T >
  • VectorVariableNames : vtkArrayCalculator, vtkFunctionParser
  • VectorVariableValues : vtkFunctionParser
  • VerifyUpdateExtent() : vtkDataObject
  • version : PlyFile
  • vertex : Mesh
  • Vertex : vtkUnstructuredGrid, vtkStructuredGrid, vtkRectilinearGrid, vtkPolyVertex, vtkPolyData, vtkImageData
  • VertexCells : vtkCellCenters
  • VertexCellsOff() : vtkCellCenters
  • VertexCellsOn() : vtkCellCenters
  • VertexId : VTK_POINT_QUADRIC
  • VerticalFlag : vtkSpherePuzzle
  • VerticalJustification : vtkTextMapper, vtkCaptionActor2D
  • vertices : Mesh
  • verts : _vtkLocalTri, _vtkProLocalTri
  • Verts : vtkPolyData
  • VertsArray : vtkDataObjectToDataSetFilter
  • VertsArrayComponent : vtkDataObjectToDataSetFilter
  • VertsComponentRange : vtkDataObjectToDataSetFilter
  • VFlowFileName : vtkPOPReader
  • VFlowFileOffset : vtkPOPReader
  • ViaNormal() : vtkLinearExtrusionFilter
  • ViaPoint() : vtkLinearExtrusionFilter
  • ViaVector() : vtkLinearExtrusionFilter
  • VideoChannel : vtkMILVideoSource
  • VideoFormat : vtkMILVideoSource
  • VideoFormatDialog() : vtkWin32VideoSource
  • VideoInput : vtkMILVideoSource
  • VideoInputForColor : vtkMILVideoSource
  • VideoSourceDialog() : vtkWin32VideoSource
  • ViewAngle : vtkCamera
  • ViewFocus : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • ViewingRaysModified() : vtkCamera
  • ViewingRaysMTime : vtkCamera
  • ViewLook : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • ViewPlaneNormal : vtkCamera
  • ViewPoint : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor, vtkViewport
  • Viewport : vtkCGMWriter, vtkViewport, vtkCoordinate
  • Viewport_bucket : vtkOpenGLStateCache
  • ViewportCoordinate : vtkXYPlotActor
  • ViewportSize : vtkXTextMapper
  • ViewportToNormalizedDisplay() : vtkViewport
  • ViewportToNormalizedViewport() : vtkViewport
  • ViewportToPlotCoordinate() : vtkXYPlotActor
  • ViewRight : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor
  • ViewShear : vtkCamera
  • ViewToDisplay() : vtkViewport
  • ViewToNormalizedViewport() : vtkViewport
  • ViewToVolumeMatrix : VTKRayCastVolumeInfo
  • ViewToVoxelsMatrix : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • ViewToWorld() : vtkRenderer, vtkViewport
  • ViewToWorldMatrix : vtkVolumeRayCastMapper
  • ViewTransform : vtkCamera
  • ViewUp : vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleJoystickActor, vtkCamera
  • Visibility : vtkProp
  • VisibilityOff() : vtkProp
  • VisibilityOn() : vtkProp
  • VisibleActorCount() : vtkRenderer
  • VisibleVolumeCount() : vtkRenderer
  • VisualClass : vtkXImageWindow
  • VisualDepth : vtkXImageWindow
  • VisualId : vtkXImageWindow
  • vm : vtkJavaCommand, vtkJavaVoidFuncArg
  • VOI : vtkExtractVOI, vtkExtractGrid
  • Volume : VTKRayCastVolumeInfo, VTKVRCStaticInfo, vtkVolumeProMapper, vtkMassProperties, vtkImplicitVolume
  • VolumeBuildTime : vtkVolumeProMapper
  • VolumeDataType : vtkVolumeProMapper
  • VolumeInput : vtkVolumeProMapper
  • VolumeRayCastFunction : vtkVolumeRayCastMapper
  • VolumeRayCastMapper_CastRays : vtkVolumeRayCastMapper
  • Volumes : vtkRenderer
  • VolumeToWorldMatrix : VTKRayCastVolumeInfo
  • VolumeX : vtkMassProperties
  • VolumeY : vtkMassProperties
  • VolumeZ : vtkMassProperties
  • Vorticity : vtkStreamer
  • VorticityOff() : vtkStreamer
  • VorticityOn() : vtkStreamer
  • Voxel : vtkRecursiveDividingCubes, vtkUnstructuredGrid, vtkRectilinearGrid, vtkImageData
  • VoxelCount : vtkImageAccumulate
  • VoxelCroppingRegionPlanes : vtkVolumeMapper
  • VoxelsToViewMatrix : vtkVolumeRayCastMapper
  • VoxelsToWorldMatrix : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • vtk3DSImporter() : vtk3DSImporter
  • vtk_bases : PyVTKClass
  • vtk_class : PyVTKObject
  • vtk_delattr : PyVTKClass
  • vtk_dict : PyVTKObject, PyVTKClass
  • vtk_doc : PyVTKSpecialObject, PyVTKClass
  • vtk_getattr : PyVTKClass
  • vtk_methods : PyVTKSpecialObject, PyVTKClass
  • vtk_module : PyVTKClass
  • vtk_name : PyVTKSpecialObject, PyVTKClass
  • vtk_new : PyVTKClass
  • vtk_ptr : PyVTKSpecialObject, PyVTKObject
  • vtk_setattr : PyVTKClass
  • vtkAbstractMapper() : vtkAbstractMapper
  • vtkAbstractMapper3D() : vtkAbstractMapper3D
  • vtkAbstractPicker() : vtkAbstractPicker
  • vtkAbstractPropPicker() : vtkAbstractPropPicker
  • vtkAbstractTransform() : vtkAbstractTransform
  • vtkActor() : vtkActor
  • vtkActor2D() : vtkActor2D
  • vtkActor2DCollection() : vtkActor2DCollection
  • vtkActorCollection() : vtkActorCollection
  • vtkAppendFilter() : vtkAppendFilter
  • vtkAppendPolyData() : vtkAppendPolyData
  • vtkApproximatingSubdivisionFilter() : vtkApproximatingSubdivisionFilter
  • vtkArcPlotter() : vtkArcPlotter
  • vtkArrayCalculator() : vtkArrayCalculator
  • vtkArrowSource() : vtkArrowSource
  • vtkAssembly() : vtkAssembly
  • vtkAssemblyNode() : vtkAssemblyNode
  • vtkAssemblyPath() : vtkAssemblyPath
  • vtkAssemblyPaths() : vtkAssemblyPaths
  • vtkAssignAttribute() : vtkAssignAttribute
  • vtkAttributeDataToFieldDataFilter() : vtkAttributeDataToFieldDataFilter
  • vtkAxes() : vtkAxes
  • vtkAxisActor2D() : vtkAxisActor2D
  • vtkBandedPolyDataContourFilter() : vtkBandedPolyDataContourFilter
  • vtkBitArray() : vtkBitArray
  • vtkBlankStructuredGrid() : vtkBlankStructuredGrid
  • vtkBlankStructuredGridWithImage() : vtkBlankStructuredGridWithImage
  • vtkBMPReader() : vtkBMPReader
  • vtkBMPWriter() : vtkBMPWriter
  • vtkBooleanTexture() : vtkBooleanTexture
  • vtkBranchExtentTranslator() : vtkBranchExtentTranslator
  • vtkBrownianPoints() : vtkBrownianPoints
  • vtkButterflySubdivisionFilter() : vtkButterflySubdivisionFilter
  • vtkButtonSource() : vtkButtonSource
  • vtkByteSwap() : vtkByteSwap
  • vtkBYUReader() : vtkBYUReader
  • vtkBYUWriter() : vtkBYUWriter
  • vtkCallbackCommand() : vtkCallbackCommand
  • vtkCamera() : vtkCamera
  • vtkCaptionActor2D() : vtkCaptionActor2D
  • vtkCardinalSpline() : vtkCardinalSpline
  • vtkCastToConcrete() : vtkCastToConcrete
  • vtkCell() : vtkCell
  • vtkCell3D() : vtkCell3D
  • vtkCellArray() : vtkCellArray
  • vtkCellCenters() : vtkCellCenters
  • vtkCellData() : vtkCellData
  • vtkCellDataToPointData() : vtkCellDataToPointData
  • vtkCellDerivatives() : vtkCellDerivatives
  • vtkCellLinks() : vtkCellLinks
  • vtkCellLocator() : vtkCellLocator
  • vtkCellPicker() : vtkCellPicker
  • vtkCellTypes() : vtkCellTypes
  • vtkCGMWriter() : vtkCGMWriter
  • vtkCharArray() : vtkCharArray
  • vtkCleanPolyData() : vtkCleanPolyData
  • vtkCleanUpImageReader2Factory : vtkImageReader2Factory
  • vtkClipDataSet() : vtkClipDataSet
  • vtkClipPolyData() : vtkClipPolyData
  • vtkClipVolume() : vtkClipVolume
  • vtkCollection() : vtkCollection
  • vtkCollectionElement() : vtkCollectionElement
  • vtkColorTransferFunction() : vtkColorTransferFunction
  • vtkCommand() : vtkCommand
  • vtkCommunicator() : vtkCommunicator
  • vtkCompositeManager() : vtkCompositeManager
  • vtkCone() : vtkCone
  • vtkConeSource() : vtkConeSource
  • vtkConnectivityFilter() : vtkConnectivityFilter
  • vtkContainer() : vtkContainer
  • vtkContourFilter() : vtkContourFilter
  • vtkContourGrid() : vtkContourGrid
  • vtkContourValues() : vtkContourValues
  • vtkCoordinate() : vtkCoordinate
  • vtkCriticalSection() : vtkCriticalSection
  • vtkCubeAxesActor2D() : vtkCubeAxesActor2D
  • vtkCubeSource() : vtkCubeSource
  • vtkCuller() : vtkCuller
  • vtkCullerCollection() : vtkCullerCollection
  • vtkCursor3D() : vtkCursor3D
  • vtkCutMaterial() : vtkCutMaterial
  • vtkCutter() : vtkCutter
  • vtkCylinder() : vtkCylinder
  • vtkCylinderSource() : vtkCylinderSource
  • vtkDashedStreamLine() : vtkDashedStreamLine
  • vtkDataArray() : vtkDataArray
  • vtkDataObject() : vtkDataObject
  • vtkDataObjectCollection() : vtkDataObjectCollection
  • vtkDataObjectReader() : vtkDataObjectReader
  • vtkDataObjectSource() : vtkDataObjectSource
  • vtkDataObjectToDataSetFilter() : vtkDataObjectToDataSetFilter
  • vtkDataObjectWriter() : vtkDataObjectWriter
  • vtkDataReader() : vtkDataReader
  • vtkDataSet() : vtkDataSet
  • vtkDataSetAttributes : vtkDataSetAttributes, vtkDataSetAttributes::FieldList
  • vtkDataSetAttributes::FieldList : vtkDataSetAttributes
  • vtkDataSetCollection() : vtkDataSetCollection
  • vtkDataSetMapper() : vtkDataSetMapper
  • vtkDataSetReader() : vtkDataSetReader
  • vtkDataSetSource() : vtkDataSetSource
  • vtkDataSetSurfaceFilter() : vtkDataSetSurfaceFilter
  • vtkDataSetToDataObjectFilter() : vtkDataSetToDataObjectFilter
  • vtkDataSetToDataSetFilter() : vtkDataSetToDataSetFilter
  • vtkDataSetToPolyDataFilter() : vtkDataSetToPolyDataFilter
  • vtkDataSetToStructuredGridFilter() : vtkDataSetToStructuredGridFilter
  • vtkDataSetToStructuredPointsFilter() : vtkDataSetToStructuredPointsFilter
  • vtkDataSetToUnstructuredGridFilter() : vtkDataSetToUnstructuredGridFilter
  • vtkDataSetTriangleFilter() : vtkDataSetTriangleFilter
  • vtkDataSetWriter() : vtkDataSetWriter
  • vtkDataWriter() : vtkDataWriter
  • vtkDebugLeaks() : vtkDebugLeaks
  • vtkDecimate() : vtkDecimate
  • vtkDecimatePro() : vtkDecimatePro
  • vtkDelaunay2D() : vtkDelaunay2D
  • vtkDelaunay3D() : vtkDelaunay3D
  • vtkDEMReader() : vtkDEMReader
  • vtkDepthSortPolyData() : vtkDepthSortPolyData
  • vtkDicer() : vtkDicer
  • vtkDirectionEncoder() : vtkDirectionEncoder
  • vtkDirectory() : vtkDirectory
  • vtkDiskSource() : vtkDiskSource
  • vtkDividingCubes() : vtkDividingCubes
  • vtkDoubleArray() : vtkDoubleArray
  • vtkDynamicLoader() : vtkDynamicLoader
  • vtkEarthSource() : vtkEarthSource
  • vtkEdgePoints() : vtkEdgePoints
  • vtkEdgeTable() : vtkEdgeTable
  • vtkElevationFilter() : vtkElevationFilter
  • vtkEmptyCell() : vtkEmptyCell
  • vtkEncodedGradientEstimator() : vtkEncodedGradientEstimator
  • vtkEncodedGradientShader() : vtkEncodedGradientShader
  • vtkEnSight6BinaryReader() : vtkEnSight6BinaryReader
  • vtkEnSight6Reader() : vtkEnSight6Reader
  • vtkEnSightGoldBinaryReader() : vtkEnSightGoldBinaryReader
  • vtkEnSightGoldReader() : vtkEnSightGoldReader
  • vtkEnSightReader() : vtkEnSightReader
  • vtkExplicitCell() : vtkExplicitCell
  • vtkExporter() : vtkExporter
  • vtkExtentTranslator() : vtkExtentTranslator
  • vtkExtractEdges() : vtkExtractEdges
  • vtkExtractGeometry() : vtkExtractGeometry
  • vtkExtractGrid() : vtkExtractGrid
  • vtkExtractPolyDataGeometry() : vtkExtractPolyDataGeometry
  • vtkExtractPolyDataPiece() : vtkExtractPolyDataPiece
  • vtkExtractTensorComponents() : vtkExtractTensorComponents
  • vtkExtractUnstructuredGrid() : vtkExtractUnstructuredGrid
  • vtkExtractUnstructuredGridPiece() : vtkExtractUnstructuredGridPiece
  • vtkExtractVectorComponents() : vtkExtractVectorComponents
  • vtkExtractVOI() : vtkExtractVOI
  • vtkFeatureEdges() : vtkFeatureEdges
  • vtkFieldData() : vtkFieldData
  • vtkFieldDataToAttributeDataFilter() : vtkFieldDataToAttributeDataFilter
  • VTKFileFlag : vtkPDataSetReader
  • vtkFileOutputWindow() : vtkFileOutputWindow
  • vtkFiniteDifferenceGradientEstimator() : vtkFiniteDifferenceGradientEstimator
  • vtkFloatArray() : vtkFloatArray
  • vtkFollower() : vtkFollower
  • vtkFrustumCoverageCuller() : vtkFrustumCoverageCuller
  • vtkFunctionParser() : vtkFunctionParser
  • vtkFunctionSet() : vtkFunctionSet
  • vtkGaussianSplatter() : vtkGaussianSplatter
  • vtkGeneralTransform() : vtkGeneralTransform
  • vtkGenericCell() : vtkGenericCell
  • vtkGenericEnSightReader() : vtkGenericEnSightReader
  • vtkGeometryFilter() : vtkGeometryFilter
  • vtkGESignaReader() : vtkGESignaReader
  • vtkGLUTesselatorTriangleFilter() : vtkGLUTesselatorTriangleFilter
  • vtkGlyph2D() : vtkGlyph2D
  • vtkGlyph3D() : vtkGlyph3D
  • vtkGlyphSource2D() : vtkGlyphSource2D
  • vtkGraphicsFactory() : vtkGraphicsFactory
  • vtkGraphLayoutFilter() : vtkGraphLayoutFilter
  • vtkGridSynchronizedTemplates3D() : vtkGridSynchronizedTemplates3D
  • vtkGridTransform() : vtkGridTransform
  • vtkHandleMessage : vtkWin32RenderWindowInteractor
  • vtkHandleMessage2 : vtkWin32RenderWindowInteractor
  • vtkHeap() : vtkHeap
  • vtkHeapNode() : vtkHeapNode
  • vtkHedgeHog() : vtkHedgeHog
  • vtkHexahedron() : vtkHexahedron
  • vtkHomogeneousTransform() : vtkHomogeneousTransform
  • vtkHull() : vtkHull
  • vtkHyperStreamline() : vtkHyperStreamline
  • vtkIdentityTransform() : vtkIdentityTransform
  • vtkIdFilter() : vtkIdFilter
  • vtkIdList() : vtkIdList
  • vtkIdTypeArray() : vtkIdTypeArray
  • vtkImageAccumulate() : vtkImageAccumulate
  • vtkImageActor() : vtkImageActor
  • vtkImageAnisotropicDiffusion2D() : vtkImageAnisotropicDiffusion2D
  • vtkImageAnisotropicDiffusion3D() : vtkImageAnisotropicDiffusion3D
  • vtkImageAppend() : vtkImageAppend
  • vtkImageAppendComponents() : vtkImageAppendComponents
  • vtkImageBlend() : vtkImageBlend
  • vtkImageBlockReader() : vtkImageBlockReader
  • vtkImageBlockWriter() : vtkImageBlockWriter
  • vtkImageButterworthHighPass() : vtkImageButterworthHighPass
  • vtkImageButterworthLowPass() : vtkImageButterworthLowPass
  • vtkImageCacheFilter() : vtkImageCacheFilter
  • vtkImageCanvasSource2D() : vtkImageCanvasSource2D
  • vtkImageCast() : vtkImageCast
  • vtkImageChangeInformation() : vtkImageChangeInformation
  • vtkImageCheckerboard() : vtkImageCheckerboard
  • vtkImageCityBlockDistance() : vtkImageCityBlockDistance
  • vtkImageClip() : vtkImageClip
  • vtkImageConnector() : vtkImageConnector
  • vtkImageConstantPad() : vtkImageConstantPad
  • vtkImageContinuousDilate3D() : vtkImageContinuousDilate3D
  • vtkImageContinuousErode3D() : vtkImageContinuousErode3D
  • vtkImageConvolve() : vtkImageConvolve
  • vtkImageCorrelation() : vtkImageCorrelation
  • vtkImageCursor3D() : vtkImageCursor3D
  • vtkImageData() : vtkImageData
  • vtkImageDataGeometryFilter() : vtkImageDataGeometryFilter
  • vtkImageDataStreamer() : vtkImageDataStreamer
  • vtkImageDecomposeFilter() : vtkImageDecomposeFilter
  • vtkImageDifference() : vtkImageDifference
  • vtkImageDilateErode3D() : vtkImageDilateErode3D
  • vtkImageDivergence() : vtkImageDivergence
  • vtkImageDotProduct() : vtkImageDotProduct
  • vtkImageEllipsoidSource() : vtkImageEllipsoidSource
  • vtkImageEuclideanDistance() : vtkImageEuclideanDistance
  • vtkImageEuclideanToPolar() : vtkImageEuclideanToPolar
  • vtkImageExport() : vtkImageExport
  • vtkImageExtractComponents() : vtkImageExtractComponents
  • vtkImageFFT() : vtkImageFFT
  • vtkImageFlip() : vtkImageFlip
  • vtkImageFourierCenter() : vtkImageFourierCenter
  • vtkImageFourierFilter() : vtkImageFourierFilter
  • vtkImageGaussianSmooth() : vtkImageGaussianSmooth
  • vtkImageGaussianSource() : vtkImageGaussianSource
  • vtkImageGradient() : vtkImageGradient
  • vtkImageGradientMagnitude() : vtkImageGradientMagnitude
  • vtkImageGridSource() : vtkImageGridSource
  • vtkImageHSVToRGB() : vtkImageHSVToRGB
  • vtkImageHybridMedian2D() : vtkImageHybridMedian2D
  • vtkImageIdealHighPass() : vtkImageIdealHighPass
  • vtkImageIdealLowPass() : vtkImageIdealLowPass
  • vtkImageImport() : vtkImageImport
  • vtkImageInPlaceFilter() : vtkImageInPlaceFilter
  • vtkImageIslandRemoval2D() : vtkImageIslandRemoval2D
  • vtkImageIterateFilter() : vtkImageIterateFilter
  • vtkImageIterator() : vtkImageIterator< DType >
  • vtkImageLaplacian() : vtkImageLaplacian
  • vtkImageLogarithmicScale() : vtkImageLogarithmicScale
  • vtkImageLogic() : vtkImageLogic
  • vtkImageLuminance() : vtkImageLuminance
  • vtkImageMagnify() : vtkImageMagnify
  • vtkImageMagnitude() : vtkImageMagnitude
  • vtkImageMandelbrotSource() : vtkImageMandelbrotSource
  • vtkImageMapper() : vtkImageMapper
  • vtkImageMapToColors() : vtkImageMapToColors
  • vtkImageMapToRGBA() : vtkImageMapToRGBA
  • vtkImageMapToWindowLevelColors() : vtkImageMapToWindowLevelColors
  • vtkImageMarchingCubes() : vtkImageMarchingCubes
  • vtkImageMask() : vtkImageMask
  • vtkImageMaskBits() : vtkImageMaskBits
  • vtkImageMathematics() : vtkImageMathematics
  • vtkImageMedian3D() : vtkImageMedian3D
  • vtkImageMirrorPad() : vtkImageMirrorPad
  • vtkImageMultipleInputFilter() : vtkImageMultipleInputFilter
  • vtkImageMultipleInputOutputFilter() : vtkImageMultipleInputOutputFilter
  • vtkImageNoiseSource() : vtkImageNoiseSource
  • vtkImageNonMaximumSuppression() : vtkImageNonMaximumSuppression
  • vtkImageNormalize() : vtkImageNormalize
  • vtkImageOpenClose3D() : vtkImageOpenClose3D
  • vtkImagePadFilter() : vtkImagePadFilter
  • vtkImagePermute() : vtkImagePermute
  • vtkImageProgressIterator() : vtkImageProgressIterator< DType >
  • vtkImageQuantizeRGBToIndex() : vtkImageQuantizeRGBToIndex
  • vtkImager() : vtkImager
  • vtkImageRange3D() : vtkImageRange3D
  • vtkImagerCollection() : vtkImagerCollection
  • vtkImageReader() : vtkImageReader
  • vtkImageReader2() : vtkImageReader2
  • vtkImageReader2Collection() : vtkImageReader2Collection
  • vtkImageReader2Factory() : vtkImageReader2Factory
  • vtkImageResample() : vtkImageResample
  • vtkImageReslice() : vtkImageReslice
  • vtkImageRFFT() : vtkImageRFFT
  • vtkImageRGBToHSV() : vtkImageRGBToHSV
  • vtkImageSeedConnectivity() : vtkImageSeedConnectivity
  • vtkImageSeparableConvolution() : vtkImageSeparableConvolution
  • vtkImageShiftScale() : vtkImageShiftScale
  • vtkImageShrink3D() : vtkImageShrink3D
  • vtkImageSinusoidSource() : vtkImageSinusoidSource
  • vtkImageSkeleton2D() : vtkImageSkeleton2D
  • vtkImageSobel2D() : vtkImageSobel2D
  • vtkImageSobel3D() : vtkImageSobel3D
  • vtkImageSource() : vtkImageSource
  • vtkImageSpatialFilter() : vtkImageSpatialFilter
  • vtkImageStencil() : vtkImageStencil
  • vtkImageStencilData() : vtkImageStencilData
  • vtkImageStencilSource() : vtkImageStencilSource
  • vtkImageThreshold() : vtkImageThreshold
  • vtkImageToImageFilter() : vtkImageToImageFilter
  • vtkImageToImageStencil() : vtkImageToImageStencil
  • vtkImageToPolyDataFilter() : vtkImageToPolyDataFilter
  • vtkImageToStructuredPoints() : vtkImageToStructuredPoints
  • vtkImageTranslateExtent() : vtkImageTranslateExtent
  • vtkImageTwoInputFilter() : vtkImageTwoInputFilter
  • vtkImageVariance3D() : vtkImageVariance3D
  • vtkImageViewer() : vtkImageViewer
  • vtkImageViewer2() : vtkImageViewer2
  • vtkImageWindow() : vtkImageWindow
  • vtkImageWrapPad() : vtkImageWrapPad
  • vtkImageWriter() : vtkImageWriter
  • vtkImagingFactory() : vtkImagingFactory
  • vtkImplicitBoolean() : vtkImplicitBoolean
  • vtkImplicitDataSet() : vtkImplicitDataSet
  • vtkImplicitFunction() : vtkImplicitFunction
  • vtkImplicitFunctionCollection() : vtkImplicitFunctionCollection
  • vtkImplicitFunctionToImageStencil() : vtkImplicitFunctionToImageStencil
  • vtkImplicitModeller() : vtkImplicitModeller
  • vtkImplicitSelectionLoop() : vtkImplicitSelectionLoop
  • vtkImplicitSum() : vtkImplicitSum
  • vtkImplicitTextureCoords() : vtkImplicitTextureCoords
  • vtkImplicitVolume() : vtkImplicitVolume
  • vtkImplicitWindowFunction() : vtkImplicitWindowFunction
  • vtkImporter() : vtkImporter
  • vtkIndent() : vtkIndent
  • vtkInitialValueProblemSolver() : vtkInitialValueProblemSolver
  • vtkInputPort() : vtkInputPort
  • vtkInstantiator() : vtkInstantiator
  • vtkInstantiatorInitialize : vtkInstantiatorInitialize, vtkInstantiator
  • vtkIntArray() : vtkIntArray
  • vtkInteractorStyle() : vtkInteractorStyle
  • vtkInteractorStyleFlight() : vtkInteractorStyleFlight
  • vtkInteractorStyleImage() : vtkInteractorStyleImage
  • vtkInteractorStyleJoystickActor() : vtkInteractorStyleJoystickActor
  • vtkInteractorStyleJoystickCamera() : vtkInteractorStyleJoystickCamera
  • vtkInteractorStyleSwitch() : vtkInteractorStyleSwitch
  • vtkInteractorStyleTrackball() : vtkInteractorStyleTrackball
  • vtkInteractorStyleTrackballActor() : vtkInteractorStyleTrackballActor
  • vtkInteractorStyleTrackballCamera() : vtkInteractorStyleTrackballCamera
  • vtkInteractorStyleUnicam() : vtkInteractorStyleUnicam
  • vtkInteractorStyleUser() : vtkInteractorStyleUser
  • vtkInterpolateDataSetAttributes() : vtkInterpolateDataSetAttributes
  • vtkInterpolatedVelocityField() : vtkInterpolatedVelocityField
  • vtkInterpolatingSubdivisionFilter() : vtkInterpolatingSubdivisionFilter
  • vtkIterativeClosestPointTransform() : vtkIterativeClosestPointTransform
  • vtkIVExporter() : vtkIVExporter
  • vtkIVWriter() : vtkIVWriter
  • vtkJavaCommand() : vtkJavaCommand
  • vtkJPEGReader() : vtkJPEGReader
  • vtkJPEGWriter() : vtkJPEGWriter
  • vtkKitwareContourFilter : vtkKitwareContourFilter, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkGridSynchronizedTemplates3D
  • vtkKitwareObjectFactory() : vtkKitwareObjectFactory
  • vtkKochanekSpline() : vtkKochanekSpline
  • vtkLabeledDataMapper() : vtkLabeledDataMapper
  • vtkLandmarkTransform() : vtkLandmarkTransform
  • vtkLargeInteger() : vtkLargeInteger
  • vtkLegendBoxActor() : vtkLegendBoxActor
  • vtkLight() : vtkLight
  • vtkLightCollection() : vtkLightCollection
  • vtkLightKit() : vtkLightKit
  • vtkLine() : vtkLine
  • vtkLinearExtrusionFilter() : vtkLinearExtrusionFilter
  • vtkLinearSubdivisionFilter() : vtkLinearSubdivisionFilter
  • vtkLinearTransform() : vtkLinearTransform
  • vtkLineSource() : vtkLineSource
  • vtkLinkEdgels() : vtkLinkEdgels
  • vtkLocator() : vtkLocator
  • vtkLODActor() : vtkLODActor
  • vtkLODProp3D() : vtkLODProp3D
  • vtkLogLookupTable() : vtkLogLookupTable
  • vtkLongArray() : vtkLongArray
  • vtkLookupTable() : vtkLookupTable
  • vtkLoopSubdivisionFilter() : vtkLoopSubdivisionFilter
  • vtkMapper() : vtkMapper
  • vtkMapper2D() : vtkMapper2D
  • vtkMapperCollection() : vtkMapperCollection
  • vtkMarchingContourFilter() : vtkMarchingContourFilter
  • vtkMarchingCubes() : vtkMarchingCubes
  • vtkMarchingSquares() : vtkMarchingSquares
  • vtkMaskFields() : vtkMaskFields
  • vtkMaskPoints() : vtkMaskPoints
  • vtkMaskPolyData() : vtkMaskPolyData
  • vtkMassProperties() : vtkMassProperties
  • vtkMath() : vtkMath
  • vtkMatrix4x4() : vtkMatrix4x4
  • vtkMatrixToHomogeneousTransform() : vtkMatrixToHomogeneousTransform
  • vtkMatrixToLinearTransform() : vtkMatrixToLinearTransform
  • vtkMCubesReader() : vtkMCubesReader
  • vtkMCubesWriter() : vtkMCubesWriter
  • vtkMedicalImageReader2() : vtkMedicalImageReader2
  • vtkMemoryLimitImageDataStreamer() : vtkMemoryLimitImageDataStreamer
  • vtkMergeDataObjectFilter() : vtkMergeDataObjectFilter
  • vtkMergeFields() : vtkMergeFields
  • vtkMergeFilter() : vtkMergeFilter
  • vtkMergePoints() : vtkMergePoints
  • vtkMergePoints2D() : vtkMergePoints2D
  • vtkMesaActor() : vtkMesaActor
  • vtkMesaCamera() : vtkMesaCamera
  • vtkMesaImageActor() : vtkMesaImageActor
  • vtkMesaImageMapper() : vtkMesaImageMapper
  • vtkMesaImager() : vtkMesaImager
  • vtkMesaImageWindow() : vtkMesaImageWindow
  • vtkMesaLight() : vtkMesaLight
  • vtkMesaPolyDataMapper() : vtkMesaPolyDataMapper
  • vtkMesaPolyDataMapper2D() : vtkMesaPolyDataMapper2D
  • vtkMesaProperty() : vtkMesaProperty
  • vtkMesaRenderer() : vtkMesaRenderer
  • vtkMesaRenderWindow() : vtkMesaRenderWindow
  • vtkMesaTexture() : vtkMesaTexture
  • vtkMesaVolumeRayCastMapper() : vtkMesaVolumeRayCastMapper
  • vtkMesaVolumeTextureMapper2D() : vtkMesaVolumeTextureMapper2D
  • vtkMILVideoSource() : vtkMILVideoSource
  • vtkMPICommunicator : vtkMPICommunicator, vtkMPIGroup
  • vtkMPIController : vtkMPIController, vtkMPICommunicator
  • vtkMPIEventLog() : vtkMPIEventLog
  • vtkMPIGroup() : vtkMPIGroup
  • vtkMultiProcessController() : vtkMultiProcessController
  • vtkMultiProcessLog() : vtkMultiProcessLog
  • vtkMultiThreader() : vtkMultiThreader
  • vtkMutexLock() : vtkMutexLock
  • vtkNonLinearCell() : vtkNonLinearCell
  • vtkOBBDicer() : vtkOBBDicer
  • vtkOBBNode() : vtkOBBNode
  • vtkOBBTree() : vtkOBBTree
  • vtkObject() : vtkObject
  • vtkObjectFactory : vtkObjectFactory, vtkOverrideInformation
  • vtkObjectFactoryCollection() : vtkObjectFactoryCollection
  • vtkOBJExporter() : vtkOBJExporter
  • vtkOBJReader() : vtkOBJReader
  • vtkOldStyleCallbackCommand() : vtkOldStyleCallbackCommand
  • vtkOOGLExporter() : vtkOOGLExporter
  • vtkOpenGLActor() : vtkOpenGLActor
  • vtkOpenGLCamera() : vtkOpenGLCamera
  • vtkOpenGLImageActor() : vtkOpenGLImageActor
  • vtkOpenGLImageMapper() : vtkOpenGLImageMapper
  • vtkOpenGLImager() : vtkOpenGLImager
  • vtkOpenGLImageWindow() : vtkOpenGLImageWindow
  • vtkOpenGLLight() : vtkOpenGLLight
  • vtkOpenGLPolyDataMapper() : vtkOpenGLPolyDataMapper
  • vtkOpenGLPolyDataMapper2D() : vtkOpenGLPolyDataMapper2D
  • vtkOpenGLProperty() : vtkOpenGLProperty
  • vtkOpenGLRenderer() : vtkOpenGLRenderer
  • vtkOpenGLRenderWindow() : vtkOpenGLRenderWindow
  • vtkOpenGLStateCache() : vtkOpenGLStateCache
  • vtkOpenGLTexture() : vtkOpenGLTexture
  • vtkOpenGLVolumeProVG500Mapper() : vtkOpenGLVolumeProVG500Mapper
  • vtkOpenGLVolumeProVP1000Mapper() : vtkOpenGLVolumeProVP1000Mapper
  • vtkOpenGLVolumeRayCastMapper() : vtkOpenGLVolumeRayCastMapper
  • vtkOpenGLVolumeTextureMapper2D() : vtkOpenGLVolumeTextureMapper2D
  • vtkOrderedTriangulator() : vtkOrderedTriangulator
  • vtkOutlineCornerFilter() : vtkOutlineCornerFilter
  • vtkOutlineCornerSource() : vtkOutlineCornerSource
  • vtkOutlineFilter() : vtkOutlineFilter
  • vtkOutlineSource() : vtkOutlineSource
  • vtkOutputPort() : vtkOutputPort
  • vtkOutputWindow() : vtkOutputWindow
  • vtkOutputWindowSmartPointer() : vtkOutputWindowSmartPointer
  • vtkOverrideInformationCollection() : vtkOverrideInformationCollection
  • vtkParallelCoordinatesActor() : vtkParallelCoordinatesActor
  • vtkParallelFactory() : vtkParallelFactory
  • vtkParticleReader() : vtkParticleReader
  • vtkPCAAnalysisFilter() : vtkPCAAnalysisFilter
  • vtkPCellDataToPointData() : vtkPCellDataToPointData
  • vtkPDataSetReader() : vtkPDataSetReader
  • vtkPDataSetWriter() : vtkPDataSetWriter
  • vtkPerlinNoise() : vtkPerlinNoise
  • vtkPerspectiveTransform() : vtkPerspectiveTransform
  • vtkPicker() : vtkPicker
  • vtkPieceScalars() : vtkPieceScalars
  • vtkPiecewiseFunction() : vtkPiecewiseFunction
  • vtkPiecewiseFunctionShiftScale() : vtkPiecewiseFunctionShiftScale
  • vtkPiecewiseFunctionSource() : vtkPiecewiseFunctionSource
  • vtkPiecewiseFunctionToPiecewiseFunctionFilter() : vtkPiecewiseFunctionToPiecewiseFunctionFilter
  • vtkPImageWriter() : vtkPImageWriter
  • vtkPipelineSize() : vtkPipelineSize
  • vtkPixel() : vtkPixel
  • vtkPlane() : vtkPlane
  • vtkPlaneCollection() : vtkPlaneCollection
  • vtkPlanes() : vtkPlanes
  • vtkPlaneSource() : vtkPlaneSource
  • vtkPLinearExtrusionFilter() : vtkPLinearExtrusionFilter
  • vtkPLOT3DReader() : vtkPLOT3DReader
  • vtkPLYReader() : vtkPLYReader
  • vtkPLYWriter() : vtkPLYWriter
  • vtkPNGReader() : vtkPNGReader
  • vtkPNGWriter() : vtkPNGWriter
  • vtkPNMReader() : vtkPNMReader
  • vtkPNMWriter() : vtkPNMWriter
  • vtkPointData() : vtkPointData
  • vtkPointDataToCellData() : vtkPointDataToCellData
  • vtkPointLoad() : vtkPointLoad
  • vtkPointLocator() : vtkPointLocator
  • vtkPointLocator2D() : vtkPointLocator2D
  • vtkPointPicker() : vtkPointPicker
  • vtkPoints() : vtkPoints
  • vtkPointSet() : vtkPointSet
  • vtkPointSetSource() : vtkPointSetSource
  • vtkPointSetToPointSetFilter() : vtkPointSetToPointSetFilter
  • vtkPointSource() : vtkPointSource
  • vtkPolyData() : vtkPolyData
  • vtkPolyDataCollection() : vtkPolyDataCollection
  • vtkPolyDataConnectivityFilter() : vtkPolyDataConnectivityFilter
  • vtkPolyDataMapper() : vtkPolyDataMapper
  • vtkPolyDataMapper2D() : vtkPolyDataMapper2D
  • vtkPolyDataNormals() : vtkPolyDataNormals
  • vtkPolyDataReader() : vtkPolyDataReader
  • vtkPolyDataSource() : vtkPolyDataSource
  • vtkPolyDataStreamer() : vtkPolyDataStreamer
  • vtkPolyDataToImageStencil() : vtkPolyDataToImageStencil
  • vtkPolyDataToPolyDataFilter() : vtkPolyDataToPolyDataFilter
  • vtkPolyDataWriter() : vtkPolyDataWriter
  • vtkPolygon() : vtkPolygon
  • vtkPolyLine() : vtkPolyLine
  • vtkPolyVertex() : vtkPolyVertex
  • vtkPOPReader() : vtkPOPReader
  • vtkPostScriptWriter() : vtkPostScriptWriter
  • vtkPPolyDataNormals() : vtkPPolyDataNormals
  • vtkPriorityQueue() : vtkPriorityQueue
  • vtkProbeFilter() : vtkProbeFilter
  • vtkProcessObject() : vtkProcessObject
  • vtkProcessStatistics() : vtkProcessStatistics
  • vtkProcrustesAlignmentFilter() : vtkProcrustesAlignmentFilter
  • vtkProgrammableAttributeDataFilter() : vtkProgrammableAttributeDataFilter
  • vtkProgrammableDataObjectSource() : vtkProgrammableDataObjectSource
  • vtkProgrammableFilter() : vtkProgrammableFilter
  • vtkProgrammableGlyphFilter() : vtkProgrammableGlyphFilter
  • vtkProgrammableSource() : vtkProgrammableSource
  • vtkProjectedTexture() : vtkProjectedTexture
  • vtkProp() : vtkProp
  • vtkProp3D() : vtkProp3D
  • vtkProp3DCollection() : vtkProp3DCollection
  • vtkPropAssembly() : vtkPropAssembly
  • vtkPropCollection() : vtkPropCollection
  • vtkProperty() : vtkProperty
  • vtkProperty2D() : vtkProperty2D
  • vtkPropPicker() : vtkPropPicker
  • vtkProTriArray() : vtkProTriArray
  • vtkProVertexArray() : vtkProVertexArray
  • vtkPSphereSource() : vtkPSphereSource
  • vtkPVGeometryFilter() : vtkPVGeometryFilter
  • vtkPyramid() : vtkPyramid
  • vtkPythonCommand() : vtkPythonCommand
  • vtkQuad() : vtkQuad
  • vtkQuadraticEdge() : vtkQuadraticEdge
  • vtkQuadric() : vtkQuadric
  • vtkQuadricClustering() : vtkQuadricClustering
  • vtkQuadricDecimation() : vtkQuadricDecimation
  • vtkQuantizePolyDataPoints() : vtkQuantizePolyDataPoints
  • vtkQuartzImageMapper() : vtkQuartzImageMapper
  • vtkQuartzImageWindow() : vtkQuartzImageWindow
  • vtkQuartzRenderWindow() : vtkQuartzRenderWindow
  • vtkQuartzRenderWindowInteractor() : vtkQuartzRenderWindowInteractor
  • vtkQuartzTextMapper() : vtkQuartzTextMapper
  • vtkRayCaster() : vtkRayCaster
  • vtkRearrangeFields() : vtkRearrangeFields
  • vtkRectilinearGrid() : vtkRectilinearGrid
  • vtkRectilinearGridGeometryFilter() : vtkRectilinearGridGeometryFilter
  • vtkRectilinearGridOutlineFilter() : vtkRectilinearGridOutlineFilter
  • vtkRectilinearGridReader() : vtkRectilinearGridReader
  • vtkRectilinearGridSource() : vtkRectilinearGridSource
  • vtkRectilinearGridToPolyDataFilter() : vtkRectilinearGridToPolyDataFilter
  • vtkRectilinearGridWriter() : vtkRectilinearGridWriter
  • vtkRecursiveDividingCubes() : vtkRecursiveDividingCubes
  • vtkRecursiveSphereDirectionEncoder() : vtkRecursiveSphereDirectionEncoder
  • vtkReferenceCount() : vtkReferenceCount
  • vtkReflectionFilter() : vtkReflectionFilter
  • vtkRenderer() : vtkRenderer
  • vtkRendererCollection() : vtkRendererCollection
  • vtkRendererSource() : vtkRendererSource
  • vtkRenderLargeImage() : vtkRenderLargeImage
  • vtkRenderWindow() : vtkRenderWindow
  • vtkRenderWindowCollection() : vtkRenderWindowCollection
  • vtkRenderWindowInteractor() : vtkRenderWindowInteractor
  • vtkReverseSense() : vtkReverseSense
  • vtkRibbonFilter() : vtkRibbonFilter
  • vtkRIBExporter() : vtkRIBExporter
  • vtkRIBLight() : vtkRIBLight
  • vtkRIBProperty() : vtkRIBProperty
  • vtkRotationalExtrusionFilter() : vtkRotationalExtrusionFilter
  • vtkRTAnalyticSource() : vtkRTAnalyticSource
  • vtkRuledSurfaceFilter() : vtkRuledSurfaceFilter
  • vtkRungeKutta2() : vtkRungeKutta2
  • vtkRungeKutta4() : vtkRungeKutta4
  • vtkRungeKutta45() : vtkRungeKutta45
  • vtkSampleFunction() : vtkSampleFunction
  • vtkScalarBarActor() : vtkScalarBarActor
  • vtkScalarsToColors() : vtkScalarsToColors
  • vtkScalarTree() : vtkScalarTree
  • vtkScaledTextActor() : vtkScaledTextActor
  • vtkSelectPolyData() : vtkSelectPolyData
  • vtkSelectVisiblePoints() : vtkSelectVisiblePoints
  • vtkSetOldCallback() : vtkInteractorStyleUser
  • vtkSetOldDelete() : vtkInteractorStyleUser
  • vtkSharedMemoryCommunicator() : vtkSharedMemoryCommunicator
  • vtkShepardMethod() : vtkShepardMethod
  • vtkShortArray() : vtkShortArray
  • vtkShrinkFilter() : vtkShrinkFilter
  • vtkShrinkPolyData() : vtkShrinkPolyData
  • vtkSimpleCriticalSection() : vtkSimpleCriticalSection
  • vtkSimpleElevationFilter() : vtkSimpleElevationFilter
  • vtkSimpleImageFilterExample() : vtkSimpleImageFilterExample
  • vtkSimpleImageToImageFilter() : vtkSimpleImageToImageFilter
  • vtkSimpleMutexLock() : vtkSimpleMutexLock
  • vtkSimpleScalarTree() : vtkSimpleScalarTree
  • vtkSLCReader() : vtkSLCReader
  • vtkSliceCubes() : vtkSliceCubes
  • vtkSmoothPolyDataFilter() : vtkSmoothPolyDataFilter
  • vtkSocketCommunicator() : vtkSocketCommunicator
  • vtkSocketController() : vtkSocketController
  • vtkSource() : vtkSource
  • vtkSpatialRepresentationFilter() : vtkSpatialRepresentationFilter
  • vtkSphere() : vtkSphere
  • vtkSpherePuzzle() : vtkSpherePuzzle
  • vtkSpherePuzzleArrows() : vtkSpherePuzzleArrows
  • vtkSphereSource() : vtkSphereSource
  • vtkSpline() : vtkSpline
  • vtkSplitField() : vtkSplitField
  • vtkSTLReader() : vtkSTLReader
  • vtkSTLWriter() : vtkSTLWriter
  • vtkStrDup() : vtkHeap
  • vtkStreamArray() : vtkStreamArray
  • vtkStreamer() : vtkStreamer
  • vtkStreamLine() : vtkStreamLine
  • vtkStreamPoints() : vtkStreamPoints
  • vtkStripper() : vtkStripper
  • vtkStructuredData() : vtkStructuredData
  • vtkStructuredGrid() : vtkStructuredGrid
  • vtkStructuredGridGeometryFilter() : vtkStructuredGridGeometryFilter
  • vtkStructuredGridOutlineFilter() : vtkStructuredGridOutlineFilter
  • vtkStructuredGridReader() : vtkStructuredGridReader
  • vtkStructuredGridSource() : vtkStructuredGridSource
  • vtkStructuredGridToPolyDataFilter() : vtkStructuredGridToPolyDataFilter
  • vtkStructuredGridToStructuredGridFilter() : vtkStructuredGridToStructuredGridFilter
  • vtkStructuredGridWriter() : vtkStructuredGridWriter
  • vtkStructuredPoints() : vtkStructuredPoints
  • vtkStructuredPointsCollection() : vtkStructuredPointsCollection
  • vtkStructuredPointsGeometryFilter() : vtkStructuredPointsGeometryFilter
  • vtkStructuredPointsReader() : vtkStructuredPointsReader
  • vtkStructuredPointsSource() : vtkStructuredPointsSource
  • vtkStructuredPointsToPolyDataFilter() : vtkStructuredPointsToPolyDataFilter
  • vtkStructuredPointsToStructuredPointsFilter() : vtkStructuredPointsToStructuredPointsFilter
  • vtkStructuredPointsToUnstructuredGridFilter() : vtkStructuredPointsToUnstructuredGridFilter
  • vtkStructuredPointsWriter() : vtkStructuredPointsWriter
  • vtkSubdivideTetra() : vtkSubdivideTetra
  • vtkSubPixelPositionEdgels() : vtkSubPixelPositionEdgels
  • vtkSuperquadric() : vtkSuperquadric
  • vtkSuperquadricSource() : vtkSuperquadricSource
  • vtkSurfaceReconstructionFilter() : vtkSurfaceReconstructionFilter
  • vtkSweptSurface() : vtkSweptSurface
  • vtkSynchronizedTemplates2D() : vtkSynchronizedTemplates2D
  • vtkSynchronizedTemplates3D() : vtkSynchronizedTemplates3D
  • vtkTclCommand() : vtkTclCommand
  • vtkTensor() : vtkTensor
  • vtkTensorGlyph() : vtkTensorGlyph
  • vtkTetra() : vtkTetra
  • vtkTextMapper() : vtkTextMapper
  • vtkTextSource() : vtkTextSource
  • vtkTexture() : vtkTexture
  • vtkTexturedSphereSource() : vtkTexturedSphereSource
  • vtkTextureMapToCylinder() : vtkTextureMapToCylinder
  • vtkTextureMapToPlane() : vtkTextureMapToPlane
  • vtkTextureMapToSphere() : vtkTextureMapToSphere
  • vtkThinPlateSplineTransform() : vtkThinPlateSplineTransform
  • vtkThreadedController : vtkThreadedController, vtkSharedMemoryCommunicator
  • vtkThreadedControllerStart() : vtkThreadedController
  • vtkThreadSafeLog() : vtkThreadSafeLog
  • vtkThreshold() : vtkThreshold
  • vtkThresholdPoints() : vtkThresholdPoints
  • vtkThresholdTextureCoords() : vtkThresholdTextureCoords
  • vtkTIFFReader() : vtkTIFFReader
  • vtkTIFFWriter() : vtkTIFFWriter
  • vtkTimerLog() : vtkTimerLog
  • vtkTimeStamp() : vtkTimeStamp
  • vtkTransform() : vtkTransform
  • vtkTransformCollection() : vtkTransformCollection
  • vtkTransformConcatenation() : vtkTransformConcatenation
  • vtkTransformConcatenationStack() : vtkTransformConcatenationStack
  • vtkTransformFilter() : vtkTransformFilter
  • vtkTransformPolyDataFilter() : vtkTransformPolyDataFilter
  • vtkTransformTextureCoords() : vtkTransformTextureCoords
  • vtkTransformToGrid() : vtkTransformToGrid
  • vtkTransmitPolyDataPiece() : vtkTransmitPolyDataPiece
  • vtkTransmitUnstructuredGridPiece() : vtkTransmitUnstructuredGridPiece
  • vtkTreeComposite() : vtkTreeComposite
  • vtkTriangle() : vtkTriangle
  • vtkTriangleFilter() : vtkTriangleFilter
  • vtkTriangleStrip() : vtkTriangleStrip
  • vtkTriangularTCoords() : vtkTriangularTCoords
  • vtkTriangularTexture() : vtkTriangularTexture
  • vtkTriArray() : vtkTriArray
  • vtkTubeFilter() : vtkTubeFilter
  • vtkTypeRevisionMacro() : vtkXTextMapper, vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXPolyDataMapper2D, vtkXOpenGLTextMapper, vtkXOpenGLRenderWindow, vtkXMesaTextMapper, vtkXMesaRenderWindow, vtkXImageWindow, vtkXImageMapper, vtkWorldPointPicker, vtkWindowToImageFilter, vtkWinCEOpenGLRenderWindow, vtkWin32TextMapper, vtkWin32RenderWindowInteractor, vtkWin32PolyDataMapper2D, vtkWin32OpenGLTextMapper, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkWin32ImageMapper, vtkVRMLExporter, vtkVolumeTextureMapper2D, vtkVolumeTextureMapper, vtkVolumeRayCastMIPFunction, vtkVolumeRayCastMapper, vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction, vtkVolumeRayCastCompositeFunction, vtkVolumeProVP1000Mapper, vtkVolumeProVG500Mapper, vtkVolumeProperty, vtkVolumeProMapper, vtkVolumeMapper, vtkVolumeCollection, vtkVolume, vtkTexture, vtkTextMapper, vtkSelectVisiblePoints, vtkScaledTextActor, vtkScalarBarActor, vtkRenderWindowInteractor, vtkRenderWindowCollection, vtkRenderWindow, vtkRendererSource, vtkRendererCollection, vtkRenderer, vtkRecursiveSphereDirectionEncoder, vtkRayCaster, vtkQuartzTextMapper, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkQuartzImageWindow, vtkQuartzImageMapper, vtkPropPicker, vtkProperty, vtkProp3DCollection, vtkProp3D, vtkPolyDataMapper2D, vtkPolyDataMapper, vtkPointPicker, vtkPicker, vtkParallelCoordinatesActor, vtkOpenGLVolumeTextureMapper2D, vtkOpenGLVolumeRayCastMapper, vtkOpenGLVolumeProVP1000Mapper, vtkOpenGLVolumeProVG500Mapper, vtkOpenGLTexture, vtkOpenGLRenderWindow, vtkOpenGLRenderer, vtkOpenGLProperty, vtkOpenGLPolyDataMapper2D, vtkOpenGLPolyDataMapper, vtkOpenGLLight, vtkOpenGLImageWindow, vtkOpenGLImager, vtkOpenGLImageMapper, vtkOpenGLImageActor, vtkOpenGLCamera, vtkOpenGLActor, vtkOOGLExporter, vtkOBJExporter, vtkMesaVolumeTextureMapper2D, vtkMesaVolumeRayCastMapper, vtkMesaTexture, vtkMesaRenderWindow, vtkMesaRenderer, vtkMesaProperty, vtkMesaPolyDataMapper2D, vtkMesaPolyDataMapper, vtkMesaLight, vtkMesaImageWindow, vtkMesaImager, vtkMesaImageMapper, vtkMesaImageActor, vtkMesaCamera, vtkMesaActor, vtkMapperCollection, vtkMapper, vtkLODProp3D, vtkLODActor, vtkLightKit, vtkLightCollection, vtkLight, vtkLabeledDataMapper, vtkIVExporter, vtkInteractorStyleUser, vtkInteractorStyleUnicam, vtkInteractorStyleTrackballCamera, vtkInteractorStyleTrackballActor, vtkInteractorStyleTrackball, vtkInteractorStyleSwitch, vtkInteractorStyleJoystickCamera, vtkInteractorStyleJoystickActor, vtkInteractorStyleImage, vtkInteractorStyleFlight, vtkInteractorStyle, vtkImporter, vtkImagingFactory, vtkImageWindow, vtkImageViewer2, vtkImageViewer, vtkImagerCollection, vtkImager, vtkImageMapper, vtkImageActor, vtkGraphicsFactory, vtkFrustumCoverageCuller, vtkFollower, vtkFiniteDifferenceGradientEstimator, vtkExporter, vtkEncodedGradientShader, vtkEncodedGradientEstimator, vtkDirectionEncoder, vtkDataSetMapper, vtkCullerCollection, vtkCuller, vtkCellPicker, vtkCamera, vtkAxisActor2D, vtkAssembly, vtkActorCollection, vtkActor, vtkAbstractPropPicker, vtkAbstractPicker, vtkAbstractMapper3D, vtkSynchronizedTemplates3D, vtkSynchronizedTemplates2D, vtkSweptSurface, vtkSliceCubes, vtkMarchingSquares, vtkMarchingCubes, vtkMarchingContourFilter, vtkKitwareObjectFactory, vtkKitwareContourFilter, vtkImageMarchingCubes, vtkGridSynchronizedTemplates3D, vtkDividingCubes, vtkDecimate, vtkTreeComposite, vtkTransmitUnstructuredGridPiece, vtkTransmitPolyDataPiece, vtkThreadedController, vtkSocketController, vtkSocketCommunicator, vtkSharedMemoryCommunicator, vtkRTAnalyticSource, vtkRectilinearGridOutlineFilter, vtkPVGeometryFilter, vtkPSphereSource, vtkPPolyDataNormals, vtkPOPReader, vtkPLinearExtrusionFilter, vtkPipelineSize, vtkPImageWriter, vtkPieceScalars, vtkPDataSetWriter, vtkPDataSetReader, vtkPCellDataToPointData, vtkParallelFactory, vtkOutputPort, vtkMultiProcessController, vtkMPIGroup, vtkMPIEventLog, vtkMPIController, vtkMPICommunicator, vtkMemoryLimitImageDataStreamer, vtkInputPort, vtkImageBlockWriter, vtkImageBlockReader, vtkExtractUnstructuredGridPiece, vtkExtractPolyDataPiece, vtkCutMaterial, vtkCompositeManager, vtkCommunicator, vtkBranchExtentTranslator, vtkXMLParser, vtkWriter, vtkVolumeReader, vtkVolume16Reader, vtkUnstructuredGridWriter, vtkUnstructuredGridReader, vtkUGFacetReader, vtkTIFFWriter, vtkStructuredPointsWriter, vtkStructuredPointsReader, vtkStructuredGridWriter, vtkStructuredGridReader, vtkSTLWriter, vtkSTLReader, vtkSLCReader, vtkRectilinearGridWriter, vtkRectilinearGridReader, vtkPostScriptWriter, vtkPolyDataWriter, vtkPolyDataReader, vtkPNMWriter, vtkPNMReader, vtkPNGWriter, vtkPNGReader, vtkPLYWriter, vtkPLYReader, vtkPLOT3DReader, vtkParticleReader, vtkOBJReader, vtkMedicalImageReader2, vtkMCubesWriter, vtkMCubesReader, vtkJPEGWriter, vtkJPEGReader, vtkIVWriter, vtkImageWriter, vtkImageReader2Factory, vtkImageReader2Collection, vtkImageReader2, vtkImageReader, vtkGESignaReader, vtkGenericEnSightReader, vtkEnSightReader, vtkEnSightGoldReader, vtkEnSightGoldBinaryReader, vtkEnSight6Reader, vtkEnSight6BinaryReader, vtkDEMReader, vtkDataWriter, vtkDataSetWriter, vtkDataSetReader, vtkDataReader, vtkDataObjectWriter, vtkDataObjectReader, vtkCGMWriter, vtkBYUWriter, vtkBYUReader, vtkBMPWriter, vtkBMPReader, vtkVoxelModeller, vtkTriangularTexture, vtkSurfaceReconstructionFilter, vtkSimpleImageFilterExample, vtkShepardMethod, vtkSampleFunction, vtkPointLoad, vtkImplicitFunctionToImageStencil, vtkImageWrapPad, vtkImageVariance3D, vtkImageTranslateExtent, vtkImageToImageStencil, vtkImageThreshold, vtkImageStencilSource, vtkImageStencilData, vtkImageStencil, vtkImageSpatialFilter, vtkImageSobel3D, vtkImageSobel2D, vtkImageSkeleton2D, vtkImageSinusoidSource, vtkImageShrink3D, vtkImageShiftScale, vtkImageSeparableConvolution, vtkImageSeedConnectivity, vtkImageRGBToHSV, vtkImageRFFT, vtkImageReslice, vtkImageResample, vtkImageRange3D, vtkImageQuantizeRGBToIndex, vtkImagePermute, vtkImagePadFilter, vtkImageOpenClose3D, vtkImageNormalize, vtkImageNonMaximumSuppression, vtkImageNoiseSource, vtkImageMirrorPad, vtkImageMedian3D, vtkImageMathematics, vtkImageMaskBits, vtkImageMask, vtkImageMapToWindowLevelColors, vtkImageMapToRGBA, vtkImageMapToColors, vtkImageMandelbrotSource, vtkImageMagnitude, vtkImageMagnify, vtkImageLuminance, vtkImageLogic, vtkImageLogarithmicScale, vtkImageLaplacian, vtkImageIterateFilter, vtkImageIslandRemoval2D, vtkImageImport, vtkImageIdealLowPass, vtkImageIdealHighPass, vtkImageHybridMedian2D, vtkImageHSVToRGB, vtkImageGridSource, vtkImageGradientMagnitude, vtkImageGradient, vtkImageGaussianSource, vtkImageGaussianSmooth, vtkImageFourierFilter, vtkImageFourierCenter, vtkImageFlip, vtkImageFFT, vtkImageExtractComponents, vtkImageExport, vtkImageEuclideanToPolar, vtkImageEuclideanDistance, vtkImageEllipsoidSource, vtkImageDotProduct, vtkImageDivergence, vtkImageDilateErode3D, vtkImageDifference, vtkImageDecomposeFilter, vtkImageDataStreamer, vtkImageCursor3D, vtkImageCorrelation, vtkImageConvolve, vtkImageContinuousErode3D, vtkImageContinuousDilate3D, vtkImageConstantPad, vtkImageConnector, vtkImageClip, vtkImageCityBlockDistance, vtkImageCheckerboard, vtkImageChangeInformation, vtkImageCast, vtkImageCanvasSource2D, vtkImageCacheFilter, vtkImageButterworthLowPass, vtkImageButterworthHighPass, vtkImageBlend, vtkImageAppendComponents, vtkImageAppend, vtkImageAnisotropicDiffusion3D, vtkImageAnisotropicDiffusion2D, vtkImageAccumulate, vtkGaussianSplatter, vtkExtractVOI, vtkBooleanTexture, vtkXYPlotActor, vtkWin32VideoSource, vtkWeightedTransformFilter, vtkVRMLImporter, vtkVideoSource, vtkVectorText, vtkTransformToGrid, vtkThinPlateSplineTransform, vtkRIBProperty, vtkRIBLight, vtkRIBExporter, vtkRenderLargeImage, vtkProcrustesAlignmentFilter, vtkPolyDataToImageStencil, vtkPCAAnalysisFilter, vtkMILVideoSource, vtkLegendBoxActor, vtkLandmarkTransform, vtkIterativeClosestPointTransform, vtkImplicitModeller, vtkImageToPolyDataFilter, vtkGridTransform, vtkGLUTesselatorTriangleFilter, vtkEarthSource, vtkDepthSortPolyData, vtkCubeAxesActor2D, vtkCaptionActor2D, vtkArcPlotter, vtk3DSImporter, vtkWindowedSincPolyDataFilter, vtkWarpVector, vtkWarpTo, vtkWarpScalar, vtkWarpLens, vtkVoxelContoursToSurfaceFilter, vtkVectorNorm, vtkVectorDot, vtkTubeFilter, vtkTriangularTCoords, vtkTriangleFilter, vtkTransformTextureCoords, vtkTransformPolyDataFilter, vtkTransformFilter, vtkThresholdTextureCoords, vtkThresholdPoints, vtkThreshold, vtkTextureMapToSphere, vtkTextureMapToPlane, vtkTextureMapToCylinder, vtkTexturedSphereSource, vtkTextSource, vtkTensorGlyph, vtkSuperquadricSource, vtkSubPixelPositionEdgels, vtkSubdivideTetra, vtkStructuredPointsGeometryFilter, vtkStructuredGridOutlineFilter, vtkStructuredGridGeometryFilter, vtkStripper, vtkStreamPoints, vtkStreamLine, vtkStreamer, vtkSplitField, vtkSphereSource, vtkSpherePuzzleArrows, vtkSpherePuzzle, vtkSpatialRepresentationFilter, vtkSmoothPolyDataFilter, vtkSimpleElevationFilter, vtkShrinkPolyData, vtkShrinkFilter, vtkSelectPolyData, vtkRuledSurfaceFilter, vtkRotationalExtrusionFilter, vtkRibbonFilter, vtkReverseSense, vtkReflectionFilter, vtkRecursiveDividingCubes, vtkRectilinearGridGeometryFilter, vtkRearrangeFields, vtkQuantizePolyDataPoints, vtkQuadricDecimation, vtkQuadricClustering, vtkProjectedTexture, vtkProgrammableSource, vtkProgrammableGlyphFilter, vtkProgrammableFilter, vtkProgrammableDataObjectSource, vtkProgrammableAttributeDataFilter, vtkProbeFilter, vtkPolyDataStreamer, vtkPolyDataNormals, vtkPolyDataConnectivityFilter, vtkPointSource, vtkPointDataToCellData, vtkPlaneSource, vtkOutlineSource, vtkOutlineFilter, vtkOutlineCornerSource, vtkOutlineCornerFilter, vtkOBBTree, vtkOBBDicer, vtkMergeFilter, vtkMergeFields, vtkMergeDataObjectFilter, vtkMassProperties, vtkMaskPolyData, vtkMaskPoints, vtkMaskFields, vtkLoopSubdivisionFilter, vtkLinkEdgels, vtkLineSource, vtkLinearSubdivisionFilter, vtkLinearExtrusionFilter, vtkInterpolatingSubdivisionFilter, vtkInterpolateDataSetAttributes, vtkImplicitTextureCoords, vtkImageDataGeometryFilter, vtkIdFilter, vtkHyperStreamline, vtkHull, vtkHedgeHog, vtkGraphLayoutFilter, vtkGlyphSource2D, vtkGlyph3D, vtkGlyph2D, vtkGeometryFilter, vtkFieldDataToAttributeDataFilter, vtkFeatureEdges, vtkExtractVectorComponents, vtkExtractUnstructuredGrid, vtkExtractTensorComponents, vtkExtractPolyDataGeometry, vtkExtractGrid, vtkExtractGeometry, vtkExtractEdges, vtkElevationFilter, vtkEdgePoints, vtkDiskSource, vtkDicer, vtkDelaunay3D, vtkDelaunay2D, vtkDecimatePro, vtkDataSetTriangleFilter, vtkDataSetToDataObjectFilter, vtkDataSetSurfaceFilter, vtkDataObjectToDataSetFilter, vtkDashedStreamLine, vtkCylinderSource, vtkCutter, vtkCursor3D, vtkCubeSource, vtkContourGrid, vtkContourFilter, vtkConnectivityFilter, vtkConeSource, vtkClipVolume, vtkClipPolyData, vtkClipDataSet, vtkCleanPolyData, vtkCellDerivatives, vtkCellDataToPointData, vtkCellCenters, vtkButtonSource, vtkButterflySubdivisionFilter, vtkBrownianPoints, vtkBlankStructuredGridWithImage, vtkBlankStructuredGrid, vtkBandedPolyDataContourFilter, vtkAxes, vtkAttributeDataToFieldDataFilter, vtkAssignAttribute, vtkArrowSource, vtkArrayCalculator, vtkApproximatingSubdivisionFilter, vtkAppendPolyData, vtkAppendFilter, vtkUnstructuredGridToUnstructuredGridFilter, vtkUnstructuredGridToPolyDataFilter, vtkUnstructuredGridSource, vtkSuperquadric, vtkStructuredPointsToUnstructuredGridFilter, vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsToPolyDataFilter, vtkStructuredPointsSource, vtkStructuredPointsCollection, vtkStructuredGridToStructuredGridFilter, vtkStructuredGridToPolyDataFilter, vtkStructuredGridSource, vtkSpline, vtkSphere, vtkSimpleScalarTree, vtkSimpleImageToImageFilter, vtkScalarTree, vtkRectilinearGridToPolyDataFilter, vtkRectilinearGridSource, vtkPolyDataToPolyDataFilter, vtkPolyDataSource, vtkPolyDataCollection, vtkPointSetToPointSetFilter, vtkPointSetSource, vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkPiecewiseFunctionSource, vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunction, vtkPerlinNoise, vtkMergePoints2D, vtkMergePoints, vtkKochanekSpline, vtkImplicitWindowFunction, vtkImplicitVolume, vtkImplicitSum, vtkImplicitSelectionLoop, vtkImplicitDataSet, vtkImplicitBoolean, vtkImageTwoInputFilter, vtkImageToStructuredPoints, vtkImageToImageFilter, vtkImageSource, vtkImageMultipleInputOutputFilter, vtkImageMultipleInputFilter, vtkImageInPlaceFilter, vtkDataSetToUnstructuredGridFilter, vtkDataSetToStructuredPointsFilter, vtkDataSetToStructuredGridFilter, vtkDataSetToPolyDataFilter, vtkDataSetToDataSetFilter, vtkDataSetSource, vtkDataObjectSource, vtkCylinder, vtkCone, vtkColorTransferFunction, vtkCellLocator, vtkCastToConcrete, vtkCardinalSpline, vtkXMLFileOutputWindow, vtkWindowLevelLookupTable, vtkWindow, vtkWin32OutputWindow, vtkWedge, vtkWarpTransform, vtkVoxel, vtkVoidArray, vtkViewport, vtkVertex, vtkVersion, vtkUnstructuredGrid, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkTriangleStrip, vtkTriangle, vtkTransformCollection, vtkTransform, vtkTimerLog, vtkTetra, vtkTensor, vtkStructuredPoints, vtkStructuredGrid, vtkStructuredData, vtkSource, vtkShortArray, vtkScalarsToColors, vtkRungeKutta45, vtkRungeKutta4, vtkRungeKutta2, vtkReferenceCount, vtkRectilinearGrid, vtkQuadric, vtkQuadraticEdge, vtkQuad, vtkPyramid, vtkProperty2D, vtkPropCollection, vtkPropAssembly, vtkProp, vtkProcessStatistics, vtkProcessObject, vtkPriorityQueue, vtkPolyVertex, vtkPolyLine, vtkPolygon, vtkPolyData, vtkPointSet, vtkPoints, vtkPointLocator2D, vtkPointLocator, vtkPointData, vtkPlanes, vtkPlaneCollection, vtkPlane, vtkPixel, vtkPerspectiveTransform, vtkOverrideInformationCollection, vtkOverrideInformation, vtkOutputWindow, vtkOrderedTriangulator, vtkObjectFactoryCollection, vtkObjectFactory, vtkNonLinearCell, vtkMutexLock, vtkMultiThreader, vtkMatrixToLinearTransform, vtkMatrixToHomogeneousTransform, vtkMatrix4x4, vtkMath, vtkMapper2D, vtkLookupTable, vtkLongArray, vtkLogLookupTable, vtkLocator, vtkLinearTransform, vtkLine, vtkInterpolatedVelocityField, vtkIntArray, vtkInstantiator, vtkInitialValueProblemSolver, vtkImplicitFunctionCollection, vtkImplicitFunction, vtkImageData, vtkIdTypeArray, vtkIdList, vtkIdentityTransform, vtkHomogeneousTransform, vtkHexahedron, vtkHeap, vtkGenericCell, vtkGeneralTransform, vtkFunctionSet, vtkFunctionParser, vtkFloatArray, vtkFileOutputWindow, vtkFieldData, vtkExtentTranslator, vtkExplicitCell, vtkEmptyCell, vtkEdgeTable, vtkDynamicLoader, vtkDoubleArray, vtkDirectory, vtkDebugLeaks, vtkDataSetCollection, vtkDataSetAttributes, vtkDataSet, vtkDataObjectCollection, vtkDataObject, vtkDataArray, vtkCriticalSection, vtkCoordinate, vtkContourValues, vtkCollection, vtkCharArray, vtkCellTypes, vtkCellLinks, vtkCellData, vtkCellArray, vtkCell3D, vtkCell, vtkByteSwap, vtkBitArray, vtkAssemblyPaths, vtkAssemblyPath, vtkAssemblyNode, vtkActor2DCollection, vtkActor2D, vtkAbstractTransform, vtkAbstractMapper
  • vtkUGFacetReader() : vtkUGFacetReader
  • vtkUnsignedCharArray() : vtkUnsignedCharArray
  • vtkUnsignedIntArray() : vtkUnsignedIntArray
  • vtkUnsignedLongArray() : vtkUnsignedLongArray
  • vtkUnsignedShortArray() : vtkUnsignedShortArray
  • vtkUnstructuredGrid() : vtkUnstructuredGrid
  • vtkUnstructuredGridReader() : vtkUnstructuredGridReader
  • vtkUnstructuredGridSource() : vtkUnstructuredGridSource
  • vtkUnstructuredGridToPolyDataFilter() : vtkUnstructuredGridToPolyDataFilter
  • vtkUnstructuredGridToUnstructuredGridFilter() : vtkUnstructuredGridToUnstructuredGridFilter
  • vtkUnstructuredGridWriter() : vtkUnstructuredGridWriter
  • vtkVectorDot() : vtkVectorDot
  • vtkVectorNorm() : vtkVectorNorm
  • vtkVectorText() : vtkVectorText
  • vtkVersion() : vtkVersion
  • vtkVertex() : vtkVertex
  • vtkVertexArray() : vtkVertexArray
  • vtkVideoSource() : vtkVideoSource
  • vtkViewport() : vtkViewport
  • vtkVoidArray() : vtkVoidArray
  • vtkVolume() : vtkVolume
  • vtkVolume16Reader() : vtkVolume16Reader
  • vtkVolumeCollection() : vtkVolumeCollection
  • vtkVolumeMapper() : vtkVolumeMapper
  • vtkVolumeProMapper() : vtkVolumeProMapper
  • vtkVolumeProperty() : vtkVolumeProperty
  • vtkVolumeProVG500Mapper() : vtkVolumeProVG500Mapper
  • vtkVolumeProVP1000Mapper() : vtkVolumeProVP1000Mapper
  • vtkVolumeRayCastCompositeFunction() : vtkVolumeRayCastCompositeFunction
  • vtkVolumeRayCastFunction() : vtkVolumeRayCastFunction
  • vtkVolumeRayCastIsosurfaceFunction() : vtkVolumeRayCastIsosurfaceFunction
  • vtkVolumeRayCastMapper() : vtkVolumeRayCastMapper
  • vtkVolumeRayCastMIPFunction() : vtkVolumeRayCastMIPFunction
  • vtkVolumeReader() : vtkVolumeReader
  • vtkVolumeTextureMapper() : vtkVolumeTextureMapper
  • vtkVolumeTextureMapper2D() : vtkVolumeTextureMapper2D
  • vtkVoxel() : vtkVoxel
  • vtkVoxelContoursToSurfaceFilter() : vtkVoxelContoursToSurfaceFilter
  • vtkVoxelModeller() : vtkVoxelModeller
  • vtkVRMLExporter() : vtkVRMLExporter
  • vtkVRMLImporter() : vtkVRMLImporter
  • vtkWarpLens() : vtkWarpLens
  • vtkWarpScalar() : vtkWarpScalar
  • vtkWarpTo() : vtkWarpTo
  • vtkWarpTransform() : vtkWarpTransform
  • vtkWarpVector() : vtkWarpVector
  • vtkWedge() : vtkWedge
  • vtkWeightedTransformFilter() : vtkWeightedTransformFilter
  • vtkWin32ImageMapper() : vtkWin32ImageMapper
  • vtkWin32ImageWindow() : vtkWin32ImageWindow
  • vtkWin32OpenGLImageWindow() : vtkWin32OpenGLImageWindow
  • vtkWin32OpenGLRenderWindow() : vtkWin32OpenGLRenderWindow
  • vtkWin32OpenGLTextMapper() : vtkWin32OpenGLTextMapper
  • vtkWin32OutputWindow() : vtkWin32OutputWindow
  • vtkWin32PolyDataMapper2D() : vtkWin32PolyDataMapper2D
  • vtkWin32RenderWindowInteractor() : vtkWin32RenderWindowInteractor
  • vtkWin32TextMapper() : vtkWin32TextMapper
  • vtkWin32VideoSource() : vtkWin32VideoSource
  • vtkWinCEOpenGLRenderWindow() : vtkWinCEOpenGLRenderWindow
  • VTKWindow : vtkViewport
  • vtkWindow() : vtkWindow
  • vtkWindowedSincPolyDataFilter() : vtkWindowedSincPolyDataFilter
  • vtkWindowLevelLookupTable() : vtkWindowLevelLookupTable
  • vtkWindowToImageFilter() : vtkWindowToImageFilter
  • vtkWorldPointPicker() : vtkWorldPointPicker
  • vtkWriter() : vtkWriter
  • vtkXImageMapper() : vtkXImageMapper
  • vtkXImageWindow() : vtkXImageWindow
  • vtkXMesaRenderWindow() : vtkXMesaRenderWindow
  • vtkXMesaTextMapper() : vtkXMesaTextMapper
  • vtkXMLFileOutputWindow() : vtkXMLFileOutputWindow
  • vtkXMLParser() : vtkXMLParser
  • vtkXOpenGLRenderWindow() : vtkXOpenGLRenderWindow
  • vtkXOpenGLTextMapper() : vtkXOpenGLTextMapper
  • vtkXPolyDataMapper2D() : vtkXPolyDataMapper2D
  • vtkXRenderWindowInteractor() : vtkXRenderWindowInteractor
  • vtkXRenderWindowInteractorCallback : vtkXRenderWindowInteractor
  • vtkXRenderWindowInteractorTimer : vtkXRenderWindowInteractor
  • vtkXRenderWindowTclInteractor() : vtkXRenderWindowTclInteractor
  • vtkXRenderWindowTclInteractorCallback : vtkXRenderWindowTclInteractor
  • vtkXRenderWindowTclInteractorTimer : vtkXRenderWindowTclInteractor
  • vtkXTextMapper() : vtkXTextMapper
  • vtkXYPlotActor() : vtkXYPlotActor
  • Vvinf : vtkPLOT3DReader

- w -
  • Wait() : vtkMPICommunicator::Request
  • WaitForConnection() : vtkSocketController, vtkSocketCommunicator
  • WaitForNewMessage() : vtkSharedMemoryCommunicator
  • WaitForNextThread() : vtkThreadedController
  • WaitForPreviousBarrierToEnd() : vtkThreadedController
  • WaitForUpdate() : vtkOutputPort
  • WaitingForId : vtkSharedMemoryCommunicator
  • WallTime : vtkTimerLogEntry
  • WarmthFunction : vtkLightKit
  • WarmthToIntensity() : vtkLightKit
  • WarmthToRGB() : vtkLightKit
  • WarmthToRGBI() : vtkLightKit
  • WarningEvent : vtkCommand
  • Wedge : vtkUnstructuredGrid
  • WeightArray : vtkWeightedTransformFilter
  • Weights : vtkImplicitSum, vtkImplicitDataSet, vtkInterpolatedVelocityField
  • which_elem : PlyFile
  • whichButtonDown : vtkQuartzRenderWindowInteractor
  • WholeExtent : vtkRTAnalyticSource, vtkImageBlockReader, vtkDEMReader, vtkImageSinusoidSource, vtkImageNoiseSource, vtkImageMandelbrotSource, vtkImageImport, vtkImageGaussianSource, vtkImageEllipsoidSource, vtkExtentTranslator, vtkDataObject
  • WholeExtentCallback : vtkImageExport, vtkImageImport
  • WholeExtentCallbackType : vtkImageImport, vtkImageExport
  • WholeWindow : vtkRendererSource
  • WholeWindowOff() : vtkRendererSource
  • WholeWindowOn() : vtkRendererSource
  • Width : vtkTkRenderWidget, vtkTkImageWindowWidget, vtkTkImageViewerWidget, vtkRibbonFilter, vtkButtonSource
  • WidthFactor : vtkRibbonFilter
  • WIN_INFO_TAG : vtkCompositeManager
  • Window : vtkImageMapToWindowLevelColors, vtkWindowLevelLookupTable
  • WindowAspect() : vtkInteractorStyleUnicam
  • WindowCenter : vtkCamera
  • WindowConfigure() : vtkQuartzRenderWindow
  • WindowController : vtkQuartzRenderWindow
  • WindowCreated : vtkImageWindow
  • WindowId : vtkXRenderWindowTclInteractor, vtkXRenderWindowInteractor, vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkXImageWindow, vtkWinCEOpenGLRenderWindow, vtkWin32RenderWindowInteractor, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32ImageWindow, vtkQuartzRenderWindowInteractor, vtkQuartzRenderWindow, vtkQuartzImageWindow
  • WindowInitialize() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkQuartzRenderWindow
  • WindowLevel : vtkImageViewer2
  • WindowLevelCurrentPosition : vtkInteractorStyleImage
  • WindowLevelEvent : vtkCommand
  • WindowLevelStartPosition : vtkInteractorStyleImage
  • WindowLevelXY() : vtkInteractorStyleImage
  • WindowName : vtkWindow
  • WindowRange : vtkImplicitWindowFunction
  • WindowRemap() : vtkXOpenGLRenderWindow, vtkXMesaRenderWindow, vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkRenderWindow, vtkQuartzRenderWindow
  • WindowValues : vtkImplicitWindowFunction
  • WndClassName : vtkWin32VideoSource
  • WndProc() : vtkWinCEOpenGLRenderWindow, vtkWin32OpenGLRenderWindow, vtkWin32OpenGLImageWindow, vtkWin32OutputWindow
  • WorkingList : vtkVoxelContoursToSurfaceFilter
  • WorkingListLength : vtkVoxelContoursToSurfaceFilter
  • WorldCommunicator : vtkMPICommunicator
  • WorldPoint : vtkViewport
  • WorldPointPicker : vtkPropPicker
  • WorldRMICommunicator : vtkMPIController
  • WorldSampleDistance : vtkVolumeRayCastMapper
  • WorldToDisplay() : vtkViewport
  • WorldToView() : vtkRenderer, vtkViewport
  • WorldToVolumeMatrix : VTKRayCastVolumeInfo
  • WorldToVoxelsMatrix : vtkVolumeRayCastMapper, VTKVRCStaticInfo
  • WorldUpVector : vtkInteractorStyleUnicam
  • Wrap : vtkImageReslice, vtkCursor3D
  • WrapFlag : vtkTimerLog
  • WrapOff() : vtkImageReslice, vtkCursor3D
  • WrapOn() : vtkImageReslice, vtkCursor3D
  • write() : ofstream, ostream
  • Write() : vtkExporter, vtkSliceCubes, vtkPDataSetWriter, vtkImageBlockWriter, vtkWriter, vtkPNGWriter, vtkJPEGWriter, vtkImageWriter, vtkVoxelModeller
  • write_ascii_item() : vtkPLY
  • write_binary_item() : vtkPLY
  • write_scalar_type() : vtkPLY
  • WriteActor() : vtkRIBExporter
  • WriteALight() : vtkVRMLExporter, vtkOOGLExporter, vtkIVExporter
  • WriteAmbientLight() : vtkRIBExporter
  • WriteAnActor() : vtkVRMLExporter, vtkOOGLExporter, vtkOBJExporter, vtkIVExporter
  • WriteArray() : vtkDataWriter
  • WriteAsciiSTL() : vtkSTLWriter
  • WriteBinarySTL() : vtkSTLWriter
  • WriteBlanking() : vtkStructuredGridWriter
  • WriteCamera() : vtkRIBExporter
  • WriteCellData() : vtkDataWriter
  • WriteCells() : vtkDataWriter
  • WriteCoordinates() : vtkDataWriter
  • WriteData() : vtkVRMLExporter, vtkOOGLExporter, vtkOBJExporter, vtkIVExporter, vtkExporter, vtkWriter, vtkUnstructuredGridWriter, vtkStructuredPointsWriter, vtkStructuredGridWriter, vtkSTLWriter, vtkRectilinearGridWriter, vtkPolyDataWriter, vtkPLYWriter, vtkMCubesWriter, vtkIVWriter, vtkDataWriter, vtkDataSetWriter, vtkDataObjectWriter, vtkCGMWriter, vtkBYUWriter, vtkRIBExporter
  • WriteDataArray() : vtkCommunicator
  • WriteDataSet() : vtkCommunicator
  • WriteDataSetData() : vtkDataWriter
  • WriteDisplacement : vtkBYUWriter
  • WriteDisplacementFile() : vtkBYUWriter
  • WriteDisplacementOff() : vtkBYUWriter
  • WriteDisplacementOn() : vtkBYUWriter
  • WriteFieldData() : vtkDataWriter
  • WriteFile() : vtkTIFFWriter, vtkPostScriptWriter, vtkPNMWriter, vtkImageWriter, vtkBMPWriter
  • WriteFileHeader() : vtkTIFFWriter, vtkPostScriptWriter, vtkPNMWriter, vtkImageWriter, vtkBMPWriter
  • WriteFileTrailer() : vtkPostScriptWriter, vtkImageWriter
  • WriteGeometryFile() : vtkBYUWriter
  • WriteHeader() : vtkDataWriter, vtkRIBExporter
  • WriteImageData() : vtkCommunicator
  • WriteImageMetaData() : vtkPDataSetWriter
  • WriteLight() : vtkRIBExporter
  • WriteNormalData() : vtkDataWriter
  • WriteObject() : vtkCommunicator
  • WritePointData() : vtkVRMLExporter, vtkIVExporter, vtkDataWriter
  • WritePointer() : vtkVoidArray, vtkUnsignedShortArray, vtkUnsignedLongArray, vtkUnsignedIntArray, vtkUnsignedCharArray, vtkShortArray, vtkLookupTable, vtkLongArray, vtkIntArray, vtkIdTypeArray, vtkIdList, vtkFloatArray, vtkDoubleArray, vtkCharArray, vtkCellArray, vtkBitArray
  • WritePoints() : vtkDataWriter
  • WritePolyData() : vtkIVWriter
  • WritePolygons() : vtkRIBExporter
  • WritePPMImageFile() : vtkImageWindow
  • WriteProperty() : vtkRIBExporter
  • Writer : vtkDataObjectWriter
  • WriteRectilinearGridMetaData() : vtkPDataSetWriter
  • WriteScalar : vtkBYUWriter
  • WriteScalarData() : vtkDataWriter
  • WriteScalarFile() : vtkBYUWriter
  • WriteScalarOff() : vtkBYUWriter
  • WriteScalarOn() : vtkBYUWriter
  • WriteSelf() : vtkLight
  • WriteSlice() : vtkPNGWriter, vtkJPEGWriter
  • WriteStrips() : vtkRIBExporter
  • WriteStructuredGridMetaData() : vtkPDataSetWriter
  • WriteTCoordData() : vtkDataWriter
  • WriteTensorData() : vtkDataWriter
  • WriteTexture : vtkRIBExporter, vtkBYUWriter
  • WriteTextureFile() : vtkBYUWriter
  • WriteTextureOff() : vtkBYUWriter
  • WriteTextureOn() : vtkBYUWriter
  • WriteTime : vtkWriter
  • WriteToOutputString : vtkDataWriter
  • WriteToOutputStringOff() : vtkDataWriter
  • WriteToOutputStringOn() : vtkDataWriter
  • WriteTrailer() : vtkRIBExporter
  • WriteUnstructuredMetaData() : vtkPDataSetWriter
  • WriteVectorData() : vtkDataWriter
  • WriteViewport() : vtkRIBExporter
  • WrongVLIVersion : vtkVolumeProMapper
  • Wvinf : vtkPLOT3DReader

- x -
  • x : _vtkLocalVertex, _vtkStreamPoint, _vtkProLocalVertex
  • X : vtkImageCanvasSource2DPixel
  • X2 : vtkInteractorStyleFlight
  • X_SLAB_MODE : vtkExtentTranslator
  • XAxis : vtkXYPlotActor, vtkCubeAxesActor2D
  • XAxisVisibility : vtkCubeAxesActor2D
  • XAxisVisibilityOff() : vtkCubeAxesActor2D
  • XAxisVisibilityOn() : vtkCubeAxesActor2D
  • XBinSize : vtkQuadricClustering
  • XComponent : vtkXYPlotActor
  • XComputedRange : vtkXYPlotActor
  • XCoordinates : vtkRectilinearGrid
  • XExtents : vtkImageBlockReader
  • XFreq : vtkRTAnalyticSource
  • XKernel : vtkImageSeparableConvolution
  • XLabel : vtkCubeAxesActor2D
  • XLength : vtkCubeSource
  • XMag : vtkRTAnalyticSource
  • XRange : vtkXYPlotActor
  • XResolution : vtkPlaneSource
  • XShadows : vtkCursor3D
  • XShadowsOff() : vtkCursor3D
  • XShadowsOn() : vtkCursor3D
  • XSize : vtkTriangularTexture, vtkBooleanTexture
  • XTitle : vtkXYPlotActor
  • XValues : vtkXYPlotActor
  • XYPlane : vtkWarpScalar
  • XYPlaneOff() : vtkWarpScalar
  • XYPlaneOn() : vtkWarpScalar
  • XYZFileName : vtkPLOT3DReader

- y -
  • Y : vtkImageCanvasSource2DPixel
  • Y2 : vtkInteractorStyleFlight
  • Y_SLAB_MODE : vtkExtentTranslator
  • Yaw() : vtkCamera
  • YawAngle : vtkInteractorStyleFlight
  • YAxis : vtkXYPlotActor, vtkCubeAxesActor2D
  • YAxisVisibility : vtkCubeAxesActor2D
  • YAxisVisibilityOff() : vtkCubeAxesActor2D
  • YAxisVisibilityOn() : vtkCubeAxesActor2D
  • YBinSize : vtkQuadricClustering
  • YComponent : vtkXYPlotActor
  • YComputedRange : vtkXYPlotActor
  • YCoordinates : vtkRectilinearGrid
  • YExtents : vtkImageBlockReader
  • YFreq : vtkRTAnalyticSource
  • YKernel : vtkImageSeparableConvolution
  • YLabel : vtkCubeAxesActor2D
  • YLength : vtkCubeSource
  • YMag : vtkRTAnalyticSource
  • YRange : vtkXYPlotActor
  • YResolution : vtkPlaneSource
  • YShadows : vtkCursor3D
  • YShadowsOff() : vtkCursor3D
  • YShadowsOn() : vtkCursor3D
  • YSize : vtkTriangularTexture, vtkBooleanTexture
  • YTitle : vtkXYPlotActor
  • yylex : vtkVRMLImporter

- z -
  • Z_SLAB_MODE : vtkExtentTranslator
  • ZAxis : vtkCubeAxesActor2D
  • ZAxisVisibility : vtkCubeAxesActor2D
  • ZAxisVisibilityOff() : vtkCubeAxesActor2D
  • ZAxisVisibilityOn() : vtkCubeAxesActor2D
  • ZBinSize : vtkQuadricClustering
  • ZBuffer : vtkVolumeRayCastMapper
  • ZBufferOrigin : vtkVolumeRayCastMapper
  • ZBufferSize : vtkVolumeRayCastMapper
  • ZCoordinates : vtkRectilinearGrid
  • ZData : vtkCompositeManager
  • Zero() : vtkMatrix4x4
  • ZeroNormalDiffuseIntensity : vtkEncodedGradientShader
  • ZeroNormalSpecularIntensity : vtkEncodedGradientShader
  • ZeroNormalThreshold : vtkEncodedGradientEstimator
  • ZeroPad : vtkEncodedGradientEstimator
  • ZeroPadOff() : vtkEncodedGradientEstimator
  • ZeroPadOn() : vtkEncodedGradientEstimator
  • ZExtents : vtkImageBlockReader
  • ZFreq : vtkRTAnalyticSource
  • ZKernel : vtkImageSeparableConvolution
  • ZLabel : vtkCubeAxesActor2D
  • ZLength : vtkCubeSource
  • ZMag : vtkRTAnalyticSource
  • ZNormal() : vtkWarpScalar
  • Zoom() : vtkCamera, vtkImageMandelbrotSource
  • ZShadows : vtkCursor3D
  • ZShadowsOff() : vtkCursor3D
  • ZShadowsOn() : vtkCursor3D
  • ZSlice : vtkImageMapper

- ~ -
  • ~BasicIterator() : vtkFieldData::BasicIterator
  • ~Component() : vtkSplitField::Component, vtkMergeFields::Component
  • ~FieldList() : vtkDataSetAttributes::FieldList
  • ~Iterator() : vtkFieldData::Iterator
  • ~Operation() : vtkRearrangeFields::Operation
  • ~VectorType() : VectorType< T >
  • ~vtk3DSImporter() : vtk3DSImporter
  • ~vtkAbstractMapper() : vtkAbstractMapper
  • ~vtkAbstractMapper3D() : vtkAbstractMapper3D
  • ~vtkAbstractPicker() : vtkAbstractPicker
  • ~vtkAbstractPropPicker() : vtkAbstractPropPicker
  • ~vtkAbstractTransform() : vtkAbstractTransform
  • ~vtkActor() : vtkActor
  • ~vtkActor2D() : vtkActor2D
  • ~vtkActor2DCollection() : vtkActor2DCollection
  • ~vtkActorCollection() : vtkActorCollection
  • ~vtkAppendFilter() : vtkAppendFilter
  • ~vtkAppendPolyData() : vtkAppendPolyData
  • ~vtkApproximatingSubdivisionFilter() : vtkApproximatingSubdivisionFilter
  • ~vtkArcPlotter() : vtkArcPlotter
  • ~vtkArrayCalculator() : vtkArrayCalculator
  • ~vtkArrowSource() : vtkArrowSource
  • ~vtkAssembly() : vtkAssembly
  • ~vtkAssemblyNode() : vtkAssemblyNode
  • ~vtkAssemblyPath() : vtkAssemblyPath
  • ~vtkAssemblyPaths() : vtkAssemblyPaths
  • ~vtkAssignAttribute() : vtkAssignAttribute
  • ~vtkAttributeDataToFieldDataFilter() : vtkAttributeDataToFieldDataFilter
  • ~vtkAxes() : vtkAxes
  • ~vtkAxisActor2D() : vtkAxisActor2D
  • ~vtkBandedPolyDataContourFilter() : vtkBandedPolyDataContourFilter
  • ~vtkBitArray() : vtkBitArray
  • ~vtkBlankStructuredGrid() : vtkBlankStructuredGrid
  • ~vtkBlankStructuredGridWithImage() : vtkBlankStructuredGridWithImage
  • ~vtkBMPReader() : vtkBMPReader
  • ~vtkBMPWriter() : vtkBMPWriter
  • ~vtkBooleanTexture() : vtkBooleanTexture
  • ~vtkBranchExtentTranslator() : vtkBranchExtentTranslator
  • ~vtkBrownianPoints() : vtkBrownianPoints
  • ~vtkButterflySubdivisionFilter() : vtkButterflySubdivisionFilter
  • ~vtkButtonSource() : vtkButtonSource
  • ~vtkByteSwap() : vtkByteSwap
  • ~vtkBYUReader() : vtkBYUReader
  • ~vtkBYUWriter() : vtkBYUWriter
  • ~vtkCallbackCommand() : vtkCallbackCommand
  • ~vtkCamera() : vtkCamera
  • ~vtkCaptionActor2D() : vtkCaptionActor2D
  • ~vtkCardinalSpline() : vtkCardinalSpline
  • ~vtkCastToConcrete() : vtkCastToConcrete
  • ~vtkCell() : vtkCell
  • ~vtkCell3D() : vtkCell3D
  • ~vtkCellArray() : vtkCellArray
  • ~vtkCellCenters() : vtkCellCenters
  • ~vtkCellData() : vtkCellData
  • ~vtkCellDataToPointData() : vtkCellDataToPointData
  • ~vtkCellDerivatives() : vtkCellDerivatives
  • ~vtkCellLinks() : vtkCellLinks
  • ~vtkCellLocator() : vtkCellLocator
  • ~vtkCellPicker() : vtkCellPicker
  • ~vtkCellTypes() : vtkCellTypes
  • ~vtkCGMWriter() : vtkCGMWriter
  • ~vtkCharArray() : vtkCharArray
  • ~vtkCleanPolyData() : vtkCleanPolyData
  • ~vtkClipDataSet() : vtkClipDataSet
  • ~vtkClipPolyData() : vtkClipPolyData
  • ~vtkClipVolume() : vtkClipVolume
  • ~vtkCollection() : vtkCollection
  • ~vtkColorTransferFunction() : vtkColorTransferFunction
  • ~vtkCommand() : vtkCommand
  • ~vtkCommunicator() : vtkCommunicator
  • ~vtkCompositeManager() : vtkCompositeManager
  • ~vtkCone() : vtkCone
  • ~vtkConeSource() : vtkConeSource
  • ~vtkConnectivityFilter() : vtkConnectivityFilter
  • ~vtkContainer() : vtkContainer
  • ~vtkContourFilter() : vtkContourFilter
  • ~vtkContourGrid() : vtkContourGrid
  • ~vtkContourValues() : vtkContourValues
  • ~vtkCoordinate() : vtkCoordinate
  • ~vtkCubeAxesActor2D() : vtkCubeAxesActor2D
  • ~vtkCubeSource() : vtkCubeSource
  • ~vtkCuller() : vtkCuller
  • ~vtkCullerCollection() : vtkCullerCollection
  • ~vtkCursor3D() : vtkCursor3D
  • ~vtkCutMaterial() : vtkCutMaterial
  • ~vtkCutter() : vtkCutter
  • ~vtkCylinder() : vtkCylinder
  • ~vtkCylinderSource() : vtkCylinderSource
  • ~vtkDashedStreamLine() : vtkDashedStreamLine
  • ~vtkDataArray() : vtkDataArray
  • ~vtkDataObject() : vtkDataObject
  • ~vtkDataObjectCollection() : vtkDataObjectCollection
  • ~vtkDataObjectReader() : vtkDataObjectReader
  • ~vtkDataObjectSource() : vtkDataObjectSource
  • ~vtkDataObjectToDataSetFilter() : vtkDataObjectToDataSetFilter
  • ~vtkDataObjectWriter() : vtkDataObjectWriter
  • ~vtkDataReader() : vtkDataReader
  • ~vtkDataSet() : vtkDataSet
  • ~vtkDataSetAttributes() : vtkDataSetAttributes
  • ~vtkDataSetCollection() : vtkDataSetCollection
  • ~vtkDataSetMapper() : vtkDataSetMapper
  • ~vtkDataSetReader() : vtkDataSetReader
  • ~vtkDataSetSource() : vtkDataSetSource
  • ~vtkDataSetSurfaceFilter() : vtkDataSetSurfaceFilter
  • ~vtkDataSetToDataObjectFilter() : vtkDataSetToDataObjectFilter
  • ~vtkDataSetToDataSetFilter() : vtkDataSetToDataSetFilter
  • ~vtkDataSetToPolyDataFilter() : vtkDataSetToPolyDataFilter
  • ~vtkDataSetToStructuredGridFilter() : vtkDataSetToStructuredGridFilter
  • ~vtkDataSetToStructuredPointsFilter() : vtkDataSetToStructuredPointsFilter
  • ~vtkDataSetToUnstructuredGridFilter() : vtkDataSetToUnstructuredGridFilter
  • ~vtkDataSetTriangleFilter() : vtkDataSetTriangleFilter
  • ~vtkDataSetWriter() : vtkDataSetWriter
  • ~vtkDataWriter() : vtkDataWriter
  • ~vtkDebugLeaks() : vtkDebugLeaks
  • ~vtkDecimate() : vtkDecimate
  • ~vtkDecimatePro() : vtkDecimatePro
  • ~vtkDelaunay2D() : vtkDelaunay2D
  • ~vtkDelaunay3D() : vtkDelaunay3D
  • ~vtkDEMReader() : vtkDEMReader
  • ~vtkDepthSortPolyData() : vtkDepthSortPolyData
  • ~vtkDicer() : vtkDicer
  • ~vtkDirectionEncoder() : vtkDirectionEncoder
  • ~vtkDirectory() : vtkDirectory
  • ~vtkDiskSource() : vtkDiskSource
  • ~vtkDividingCubes() : vtkDividingCubes
  • ~vtkDoubleArray() : vtkDoubleArray
  • ~vtkDynamicLoader() : vtkDynamicLoader
  • ~vtkEarthSource() : vtkEarthSource
  • ~vtkEdgePoints() : vtkEdgePoints
  • ~vtkEdgeTable() : vtkEdgeTable
  • ~vtkElevationFilter() : vtkElevationFilter
  • ~vtkEmptyCell() : vtkEmptyCell
  • ~vtkEncodedGradientEstimator() : vtkEncodedGradientEstimator
  • ~vtkEncodedGradientShader() : vtkEncodedGradientShader
  • ~vtkEnSight6BinaryReader() : vtkEnSight6BinaryReader
  • ~vtkEnSight6Reader() : vtkEnSight6Reader
  • ~vtkEnSightGoldBinaryReader() : vtkEnSightGoldBinaryReader
  • ~vtkEnSightGoldReader() : vtkEnSightGoldReader
  • ~vtkEnSightReader() : vtkEnSightReader
  • ~vtkExplicitCell() : vtkExplicitCell
  • ~vtkExporter() : vtkExporter
  • ~vtkExtentTranslator() : vtkExtentTranslator
  • ~vtkExtractEdges() : vtkExtractEdges
  • ~vtkExtractGeometry() : vtkExtractGeometry
  • ~vtkExtractGrid() : vtkExtractGrid
  • ~vtkExtractPolyDataGeometry() : vtkExtractPolyDataGeometry
  • ~vtkExtractPolyDataPiece() : vtkExtractPolyDataPiece
  • ~vtkExtractTensorComponents() : vtkExtractTensorComponents
  • ~vtkExtractUnstructuredGrid() : vtkExtractUnstructuredGrid
  • ~vtkExtractUnstructuredGridPiece() : vtkExtractUnstructuredGridPiece
  • ~vtkExtractVectorComponents() : vtkExtractVectorComponents
  • ~vtkExtractVOI() : vtkExtractVOI
  • ~vtkFeatureEdges() : vtkFeatureEdges
  • ~vtkFieldData() : vtkFieldData
  • ~vtkFieldDataToAttributeDataFilter() : vtkFieldDataToAttributeDataFilter
  • ~vtkFileOutputWindow() : vtkFileOutputWindow
  • ~vtkFiniteDifferenceGradientEstimator() : vtkFiniteDifferenceGradientEstimator
  • ~vtkFloatArray() : vtkFloatArray
  • ~vtkFollower() : vtkFollower
  • ~vtkFrustumCoverageCuller() : vtkFrustumCoverageCuller
  • ~vtkFunctionParser() : vtkFunctionParser
  • ~vtkFunctionSet() : vtkFunctionSet
  • ~vtkGaussianSplatter() : vtkGaussianSplatter
  • ~vtkGeneralTransform() : vtkGeneralTransform
  • ~vtkGenericCell() : vtkGenericCell
  • ~vtkGenericEnSightReader() : vtkGenericEnSightReader
  • ~vtkGeometryFilter() : vtkGeometryFilter
  • ~vtkGESignaReader() : vtkGESignaReader
  • ~vtkGLUTesselatorTriangleFilter() : vtkGLUTesselatorTriangleFilter
  • ~vtkGlyph2D() : vtkGlyph2D
  • ~vtkGlyph3D() : vtkGlyph3D
  • ~vtkGlyphSource2D() : vtkGlyphSource2D
  • ~vtkGraphLayoutFilter() : vtkGraphLayoutFilter
  • ~vtkGridSynchronizedTemplates3D() : vtkGridSynchronizedTemplates3D
  • ~vtkGridTransform() : vtkGridTransform
  • ~vtkHeap() : vtkHeap
  • ~vtkHedgeHog() : vtkHedgeHog
  • ~vtkHexahedron() : vtkHexahedron
  • ~vtkHomogeneousTransform() : vtkHomogeneousTransform
  • ~vtkHull() : vtkHull
  • ~vtkHyperStreamline() : vtkHyperStreamline
  • ~vtkIdentityTransform() : vtkIdentityTransform
  • ~vtkIdFilter() : vtkIdFilter
  • ~vtkIdList() : vtkIdList
  • ~vtkIdTypeArray() : vtkIdTypeArray
  • ~vtkImageAccumulate() : vtkImageAccumulate
  • ~vtkImageActor() : vtkImageActor
  • ~vtkImageAnisotropicDiffusion2D() : vtkImageAnisotropicDiffusion2D
  • ~vtkImageAnisotropicDiffusion3D() : vtkImageAnisotropicDiffusion3D
  • ~vtkImageAppend() : vtkImageAppend
  • ~vtkImageAppendComponents() : vtkImageAppendComponents
  • ~vtkImageBlend() : vtkImageBlend
  • ~vtkImageBlockReader() : vtkImageBlockReader
  • ~vtkImageBlockWriter() : vtkImageBlockWriter
  • ~vtkImageButterworthHighPass() : vtkImageButterworthHighPass
  • ~vtkImageButterworthLowPass() : vtkImageButterworthLowPass
  • ~vtkImageCacheFilter() : vtkImageCacheFilter
  • ~vtkImageCanvasSource2D() : vtkImageCanvasSource2D
  • ~vtkImageCast() : vtkImageCast
  • ~vtkImageChangeInformation() : vtkImageChangeInformation
  • ~vtkImageCheckerboard() : vtkImageCheckerboard
  • ~vtkImageCityBlockDistance() : vtkImageCityBlockDistance
  • ~vtkImageClip() : vtkImageClip
  • ~vtkImageConnector() : vtkImageConnector
  • ~vtkImageConstantPad() : vtkImageConstantPad
  • ~vtkImageContinuousDilate3D() : vtkImageContinuousDilate3D
  • ~vtkImageContinuousErode3D() : vtkImageContinuousErode3D
  • ~vtkImageConvolve() : vtkImageConvolve
  • ~vtkImageCorrelation() : vtkImageCorrelation
  • ~vtkImageCursor3D() : vtkImageCursor3D
  • ~vtkImageData() : vtkImageData
  • ~vtkImageDataGeometryFilter() : vtkImageDataGeometryFilter
  • ~vtkImageDataStreamer() : vtkImageDataStreamer
  • ~vtkImageDecomposeFilter() : vtkImageDecomposeFilter
  • ~vtkImageDifference() : vtkImageDifference
  • ~vtkImageDilateErode3D() : vtkImageDilateErode3D
  • ~vtkImageDivergence() : vtkImageDivergence
  • ~vtkImageDotProduct() : vtkImageDotProduct
  • ~vtkImageEllipsoidSource() : vtkImageEllipsoidSource
  • ~vtkImageEuclideanDistance() : vtkImageEuclideanDistance
  • ~vtkImageEuclideanToPolar() : vtkImageEuclideanToPolar
  • ~vtkImageExport() : vtkImageExport
  • ~vtkImageExtractComponents() : vtkImageExtractComponents
  • ~vtkImageFFT() : vtkImageFFT
  • ~vtkImageFlip() : vtkImageFlip
  • ~vtkImageFourierCenter() : vtkImageFourierCenter
  • ~vtkImageFourierFilter() : vtkImageFourierFilter
  • ~vtkImageGaussianSmooth() : vtkImageGaussianSmooth
  • ~vtkImageGaussianSource() : vtkImageGaussianSource
  • ~vtkImageGradient() : vtkImageGradient
  • ~vtkImageGradientMagnitude() : vtkImageGradientMagnitude
  • ~vtkImageGridSource() : vtkImageGridSource
  • ~vtkImageHSVToRGB() : vtkImageHSVToRGB
  • ~vtkImageHybridMedian2D() : vtkImageHybridMedian2D
  • ~vtkImageIdealHighPass() : vtkImageIdealHighPass
  • ~vtkImageIdealLowPass() : vtkImageIdealLowPass
  • ~vtkImageImport() : vtkImageImport
  • ~vtkImageInPlaceFilter() : vtkImageInPlaceFilter
  • ~vtkImageIslandRemoval2D() : vtkImageIslandRemoval2D
  • ~vtkImageIterateFilter() : vtkImageIterateFilter
  • ~vtkImageLaplacian() : vtkImageLaplacian
  • ~vtkImageLogarithmicScale() : vtkImageLogarithmicScale
  • ~vtkImageLogic() : vtkImageLogic
  • ~vtkImageLuminance() : vtkImageLuminance
  • ~vtkImageMagnify() : vtkImageMagnify
  • ~vtkImageMagnitude() : vtkImageMagnitude
  • ~vtkImageMandelbrotSource() : vtkImageMandelbrotSource
  • ~vtkImageMapper() : vtkImageMapper
  • ~vtkImageMapToColors() : vtkImageMapToColors
  • ~vtkImageMapToRGBA() : vtkImageMapToRGBA
  • ~vtkImageMapToWindowLevelColors() : vtkImageMapToWindowLevelColors
  • ~vtkImageMarchingCubes() : vtkImageMarchingCubes
  • ~vtkImageMask() : vtkImageMask
  • ~vtkImageMaskBits() : vtkImageMaskBits
  • ~vtkImageMathematics() : vtkImageMathematics
  • ~vtkImageMedian3D() : vtkImageMedian3D
  • ~vtkImageMirrorPad() : vtkImageMirrorPad
  • ~vtkImageMultipleInputFilter() : vtkImageMultipleInputFilter
  • ~vtkImageMultipleInputOutputFilter() : vtkImageMultipleInputOutputFilter
  • ~vtkImageNoiseSource() : vtkImageNoiseSource
  • ~vtkImageNonMaximumSuppression() : vtkImageNonMaximumSuppression
  • ~vtkImageNormalize() : vtkImageNormalize
  • ~vtkImageOpenClose3D() : vtkImageOpenClose3D
  • ~vtkImagePadFilter() : vtkImagePadFilter
  • ~vtkImagePermute() : vtkImagePermute
  • ~vtkImageQuantizeRGBToIndex() : vtkImageQuantizeRGBToIndex
  • ~vtkImager() : vtkImager
  • ~vtkImageRange3D() : vtkImageRange3D
  • ~vtkImagerCollection() : vtkImagerCollection
  • ~vtkImageReader() : vtkImageReader
  • ~vtkImageReader2() : vtkImageReader2
  • ~vtkImageReader2Collection() : vtkImageReader2Collection
  • ~vtkImageReader2Factory() : vtkImageReader2Factory
  • ~vtkImageResample() : vtkImageResample
  • ~vtkImageReslice() : vtkImageReslice
  • ~vtkImageRFFT() : vtkImageRFFT
  • ~vtkImageRGBToHSV() : vtkImageRGBToHSV
  • ~vtkImageSeedConnectivity() : vtkImageSeedConnectivity
  • ~vtkImageSeparableConvolution() : vtkImageSeparableConvolution
  • ~vtkImageShiftScale() : vtkImageShiftScale
  • ~vtkImageShrink3D() : vtkImageShrink3D
  • ~vtkImageSinusoidSource() : vtkImageSinusoidSource
  • ~vtkImageSkeleton2D() : vtkImageSkeleton2D
  • ~vtkImageSobel2D() : vtkImageSobel2D
  • ~vtkImageSobel3D() : vtkImageSobel3D
  • ~vtkImageSource() : vtkImageSource
  • ~vtkImageSpatialFilter() : vtkImageSpatialFilter
  • ~vtkImageStencil() : vtkImageStencil
  • ~vtkImageStencilData() : vtkImageStencilData
  • ~vtkImageStencilSource() : vtkImageStencilSource
  • ~vtkImageThreshold() : vtkImageThreshold
  • ~vtkImageToImageFilter() : vtkImageToImageFilter
  • ~vtkImageToImageStencil() : vtkImageToImageStencil
  • ~vtkImageToPolyDataFilter() : vtkImageToPolyDataFilter
  • ~vtkImageToStructuredPoints() : vtkImageToStructuredPoints
  • ~vtkImageTranslateExtent() : vtkImageTranslateExtent
  • ~vtkImageTwoInputFilter() : vtkImageTwoInputFilter
  • ~vtkImageVariance3D() : vtkImageVariance3D
  • ~vtkImageViewer() : vtkImageViewer
  • ~vtkImageViewer2() : vtkImageViewer2
  • ~vtkImageWindow() : vtkImageWindow
  • ~vtkImageWrapPad() : vtkImageWrapPad
  • ~vtkImageWriter() : vtkImageWriter
  • ~vtkImplicitBoolean() : vtkImplicitBoolean
  • ~vtkImplicitDataSet() : vtkImplicitDataSet
  • ~vtkImplicitFunction() : vtkImplicitFunction
  • ~vtkImplicitFunctionCollection() : vtkImplicitFunctionCollection
  • ~vtkImplicitFunctionToImageStencil() : vtkImplicitFunctionToImageStencil
  • ~vtkImplicitModeller() : vtkImplicitModeller
  • ~vtkImplicitSelectionLoop() : vtkImplicitSelectionLoop
  • ~vtkImplicitSum() : vtkImplicitSum
  • ~vtkImplicitTextureCoords() : vtkImplicitTextureCoords
  • ~vtkImplicitVolume() : vtkImplicitVolume
  • ~vtkImplicitWindowFunction() : vtkImplicitWindowFunction
  • ~vtkImporter() : vtkImporter
  • ~vtkInitialValueProblemSolver() : vtkInitialValueProblemSolver
  • ~vtkInputPort() : vtkInputPort
  • ~vtkInstantiator() : vtkInstantiator
  • ~vtkInstantiatorInitialize() : vtkInstantiatorInitialize
  • ~vtkIntArray() : vtkIntArray
  • ~vtkInteractorStyle() : vtkInteractorStyle
  • ~vtkInteractorStyleFlight() : vtkInteractorStyleFlight
  • ~vtkInteractorStyleImage() : vtkInteractorStyleImage
  • ~vtkInteractorStyleJoystickActor() : vtkInteractorStyleJoystickActor
  • ~vtkInteractorStyleJoystickCamera() : vtkInteractorStyleJoystickCamera
  • ~vtkInteractorStyleSwitch() : vtkInteractorStyleSwitch
  • ~vtkInteractorStyleTrackball() : vtkInteractorStyleTrackball
  • ~vtkInteractorStyleTrackballActor() : vtkInteractorStyleTrackballActor
  • ~vtkInteractorStyleTrackballCamera() : vtkInteractorStyleTrackballCamera
  • ~vtkInteractorStyleUnicam() : vtkInteractorStyleUnicam
  • ~vtkInteractorStyleUser() : vtkInteractorStyleUser
  • ~vtkInterpolateDataSetAttributes() : vtkInterpolateDataSetAttributes
  • ~vtkInterpolatedVelocityField() : vtkInterpolatedVelocityField
  • ~vtkInterpolatingSubdivisionFilter() : vtkInterpolatingSubdivisionFilter
  • ~vtkIterativeClosestPointTransform() : vtkIterativeClosestPointTransform
  • ~vtkIVExporter() : vtkIVExporter
  • ~vtkIVWriter() : vtkIVWriter
  • ~vtkJavaCommand() : vtkJavaCommand
  • ~vtkJPEGReader() : vtkJPEGReader
  • ~vtkJPEGWriter() : vtkJPEGWriter
  • ~vtkKitwareContourFilter() : vtkKitwareContourFilter
  • ~vtkKochanekSpline() : vtkKochanekSpline
  • ~vtkLabeledDataMapper() : vtkLabeledDataMapper
  • ~vtkLandmarkTransform() : vtkLandmarkTransform
  • ~vtkLargeInteger() : vtkLargeInteger
  • ~vtkLegendBoxActor() : vtkLegendBoxActor
  • ~vtkLight() : vtkLight
  • ~vtkLightCollection() : vtkLightCollection
  • ~vtkLightKit() : vtkLightKit
  • ~vtkLine() : vtkLine
  • ~vtkLinearExtrusionFilter() : vtkLinearExtrusionFilter
  • ~vtkLinearSubdivisionFilter() : vtkLinearSubdivisionFilter
  • ~vtkLinearTransform() : vtkLinearTransform
  • ~vtkLineSource() : vtkLineSource
  • ~vtkLinkEdgels() : vtkLinkEdgels
  • ~vtkLocator() : vtkLocator
  • ~vtkLODActor() : vtkLODActor
  • ~vtkLODProp3D() : vtkLODProp3D
  • ~vtkLogLookupTable() : vtkLogLookupTable
  • ~vtkLongArray() : vtkLongArray
  • ~vtkLookupTable() : vtkLookupTable
  • ~vtkLoopSubdivisionFilter() : vtkLoopSubdivisionFilter
  • ~vtkMapper() : vtkMapper
  • ~vtkMapper2D() : vtkMapper2D
  • ~vtkMapperCollection() : vtkMapperCollection
  • ~vtkMarchingContourFilter() : vtkMarchingContourFilter
  • ~vtkMarchingCubes() : vtkMarchingCubes
  • ~vtkMarchingSquares() : vtkMarchingSquares
  • ~vtkMaskFields() : vtkMaskFields
  • ~vtkMaskPoints() : vtkMaskPoints
  • ~vtkMaskPolyData() : vtkMaskPolyData
  • ~vtkMassProperties() : vtkMassProperties
  • ~vtkMath() : vtkMath
  • ~vtkMatrix4x4() : vtkMatrix4x4
  • ~vtkMatrixToHomogeneousTransform() : vtkMatrixToHomogeneousTransform
  • ~vtkMatrixToLinearTransform() : vtkMatrixToLinearTransform
  • ~vtkMCubesReader() : vtkMCubesReader
  • ~vtkMCubesWriter() : vtkMCubesWriter
  • ~vtkMedicalImageReader2() : vtkMedicalImageReader2
  • ~vtkMemoryLimitImageDataStreamer() : vtkMemoryLimitImageDataStreamer
  • ~vtkMergeDataObjectFilter() : vtkMergeDataObjectFilter
  • ~vtkMergeFields() : vtkMergeFields
  • ~vtkMergeFilter() : vtkMergeFilter
  • ~vtkMergePoints() : vtkMergePoints
  • ~vtkMergePoints2D() : vtkMergePoints2D
  • ~vtkMesaActor() : vtkMesaActor
  • ~vtkMesaCamera() : vtkMesaCamera
  • ~vtkMesaImageActor() : vtkMesaImageActor
  • ~vtkMesaImageMapper() : vtkMesaImageMapper
  • ~vtkMesaImager() : vtkMesaImager
  • ~vtkMesaImageWindow() : vtkMesaImageWindow
  • ~vtkMesaLight() : vtkMesaLight
  • ~vtkMesaPolyDataMapper() : vtkMesaPolyDataMapper
  • ~vtkMesaPolyDataMapper2D() : vtkMesaPolyDataMapper2D
  • ~vtkMesaProperty() : vtkMesaProperty
  • ~vtkMesaRenderer() : vtkMesaRenderer
  • ~vtkMesaRenderWindow() : vtkMesaRenderWindow
  • ~vtkMesaTexture() : vtkMesaTexture
  • ~vtkMesaVolumeRayCastMapper() : vtkMesaVolumeRayCastMapper
  • ~vtkMesaVolumeTextureMapper2D() : vtkMesaVolumeTextureMapper2D
  • ~vtkMILVideoSource() : vtkMILVideoSource
  • ~vtkMPICommunicator() : vtkMPICommunicator
  • ~vtkMPIController() : vtkMPIController
  • ~vtkMPIEventLog() : vtkMPIEventLog
  • ~vtkMPIGroup() : vtkMPIGroup
  • ~vtkMultiProcessController() : vtkMultiProcessController
  • ~vtkMultiProcessLog() : vtkMultiProcessLog
  • ~vtkMultiThreader() : vtkMultiThreader
  • ~vtkNonLinearCell() : vtkNonLinearCell
  • ~vtkOBBDicer() : vtkOBBDicer
  • ~vtkOBBNode() : vtkOBBNode
  • ~vtkOBBTree() : vtkOBBTree
  • ~vtkObject() : vtkObject
  • ~vtkObjectFactory() : vtkObjectFactory
  • ~vtkObjectFactoryCollection() : vtkObjectFactoryCollection
  • ~vtkOBJExporter() : vtkOBJExporter
  • ~vtkOBJReader() : vtkOBJReader
  • ~vtkOldStyleCallbackCommand() : vtkOldStyleCallbackCommand
  • ~vtkOOGLExporter() : vtkOOGLExporter
  • ~vtkOpenGLActor() : vtkOpenGLActor
  • ~vtkOpenGLCamera() : vtkOpenGLCamera
  • ~vtkOpenGLImageActor() : vtkOpenGLImageActor
  • ~vtkOpenGLImageMapper() : vtkOpenGLImageMapper
  • ~vtkOpenGLImager() : vtkOpenGLImager
  • ~vtkOpenGLImageWindow() : vtkOpenGLImageWindow
  • ~vtkOpenGLLight() : vtkOpenGLLight
  • ~vtkOpenGLPolyDataMapper() : vtkOpenGLPolyDataMapper
  • ~vtkOpenGLPolyDataMapper2D() : vtkOpenGLPolyDataMapper2D
  • ~vtkOpenGLProperty() : vtkOpenGLProperty
  • ~vtkOpenGLRenderer() : vtkOpenGLRenderer
  • ~vtkOpenGLRenderWindow() : vtkOpenGLRenderWindow
  • ~vtkOpenGLStateCache() : vtkOpenGLStateCache
  • ~vtkOpenGLTexture() : vtkOpenGLTexture
  • ~vtkOpenGLVolumeProVG500Mapper() : vtkOpenGLVolumeProVG500Mapper
  • ~vtkOpenGLVolumeProVP1000Mapper() : vtkOpenGLVolumeProVP1000Mapper
  • ~vtkOpenGLVolumeRayCastMapper() : vtkOpenGLVolumeRayCastMapper
  • ~vtkOpenGLVolumeTextureMapper2D() : vtkOpenGLVolumeTextureMapper2D
  • ~vtkOrderedTriangulator() : vtkOrderedTriangulator
  • ~vtkOutlineCornerFilter() : vtkOutlineCornerFilter
  • ~vtkOutlineCornerSource() : vtkOutlineCornerSource
  • ~vtkOutlineFilter() : vtkOutlineFilter
  • ~vtkOutlineSource() : vtkOutlineSource
  • ~vtkOutputPort() : vtkOutputPort
  • ~vtkOutputWindow() : vtkOutputWindow
  • ~vtkOutputWindowSmartPointer() : vtkOutputWindowSmartPointer
  • ~vtkOverrideInformationCollection() : vtkOverrideInformationCollection
  • ~vtkParallelCoordinatesActor() : vtkParallelCoordinatesActor
  • ~vtkParallelFactory() : vtkParallelFactory
  • ~vtkParticleReader() : vtkParticleReader
  • ~vtkPCAAnalysisFilter() : vtkPCAAnalysisFilter
  • ~vtkPCellDataToPointData() : vtkPCellDataToPointData
  • ~vtkPDataSetReader() : vtkPDataSetReader
  • ~vtkPDataSetWriter() : vtkPDataSetWriter
  • ~vtkPerlinNoise() : vtkPerlinNoise
  • ~vtkPerspectiveTransform() : vtkPerspectiveTransform
  • ~vtkPicker() : vtkPicker
  • ~vtkPieceScalars() : vtkPieceScalars
  • ~vtkPiecewiseFunction() : vtkPiecewiseFunction
  • ~vtkPiecewiseFunctionShiftScale() : vtkPiecewiseFunctionShiftScale
  • ~vtkPiecewiseFunctionSource() : vtkPiecewiseFunctionSource
  • ~vtkPiecewiseFunctionToPiecewiseFunctionFilter() : vtkPiecewiseFunctionToPiecewiseFunctionFilter
  • ~vtkPImageWriter() : vtkPImageWriter
  • ~vtkPixel() : vtkPixel
  • ~vtkPlane() : vtkPlane
  • ~vtkPlaneCollection() : vtkPlaneCollection
  • ~vtkPlanes() : vtkPlanes
  • ~vtkPlaneSource() : vtkPlaneSource
  • ~vtkPLinearExtrusionFilter() : vtkPLinearExtrusionFilter
  • ~vtkPLOT3DReader() : vtkPLOT3DReader
  • ~vtkPLYReader() : vtkPLYReader
  • ~vtkPLYWriter() : vtkPLYWriter
  • ~vtkPNGReader() : vtkPNGReader
  • ~vtkPNGWriter() : vtkPNGWriter
  • ~vtkPNMReader() : vtkPNMReader
  • ~vtkPNMWriter() : vtkPNMWriter
  • ~vtkPointData() : vtkPointData
  • ~vtkPointDataToCellData() : vtkPointDataToCellData
  • ~vtkPointLoad() : vtkPointLoad
  • ~vtkPointLocator() : vtkPointLocator
  • ~vtkPointLocator2D() : vtkPointLocator2D
  • ~vtkPointPicker() : vtkPointPicker
  • ~vtkPoints() : vtkPoints
  • ~vtkPointSet() : vtkPointSet
  • ~vtkPointSetSource() : vtkPointSetSource
  • ~vtkPointSetToPointSetFilter() : vtkPointSetToPointSetFilter
  • ~vtkPointSource() : vtkPointSource
  • ~vtkPolyData() : vtkPolyData
  • ~vtkPolyDataCollection() : vtkPolyDataCollection
  • ~vtkPolyDataConnectivityFilter() : vtkPolyDataConnectivityFilter
  • ~vtkPolyDataMapper() : vtkPolyDataMapper
  • ~vtkPolyDataMapper2D() : vtkPolyDataMapper2D
  • ~vtkPolyDataNormals() : vtkPolyDataNormals
  • ~vtkPolyDataReader() : vtkPolyDataReader
  • ~vtkPolyDataSource() : vtkPolyDataSource
  • ~vtkPolyDataStreamer() : vtkPolyDataStreamer
  • ~vtkPolyDataToImageStencil() : vtkPolyDataToImageStencil
  • ~vtkPolyDataToPolyDataFilter() : vtkPolyDataToPolyDataFilter
  • ~vtkPolyDataWriter() : vtkPolyDataWriter
  • ~vtkPolygon() : vtkPolygon
  • ~vtkPolyLine() : vtkPolyLine
  • ~vtkPolyVertex() : vtkPolyVertex
  • ~vtkPOPReader() : vtkPOPReader
  • ~vtkPostScriptWriter() : vtkPostScriptWriter
  • ~vtkPPolyDataNormals() : vtkPPolyDataNormals
  • ~vtkPriorityQueue() : vtkPriorityQueue
  • ~vtkProbeFilter() : vtkProbeFilter
  • ~vtkProcessObject() : vtkProcessObject
  • ~vtkProcessStatistics() : vtkProcessStatistics
  • ~vtkProcrustesAlignmentFilter() : vtkProcrustesAlignmentFilter
  • ~vtkProgrammableAttributeDataFilter() : vtkProgrammableAttributeDataFilter
  • ~vtkProgrammableDataObjectSource() : vtkProgrammableDataObjectSource
  • ~vtkProgrammableFilter() : vtkProgrammableFilter
  • ~vtkProgrammableGlyphFilter() : vtkProgrammableGlyphFilter
  • ~vtkProgrammableSource() : vtkProgrammableSource
  • ~vtkProjectedTexture() : vtkProjectedTexture
  • ~vtkProp() : vtkProp
  • ~vtkProp3D() : vtkProp3D
  • ~vtkProp3DCollection() : vtkProp3DCollection
  • ~vtkPropAssembly() : vtkPropAssembly
  • ~vtkPropCollection() : vtkPropCollection
  • ~vtkProperty() : vtkProperty
  • ~vtkProperty2D() : vtkProperty2D
  • ~vtkPropPicker() : vtkPropPicker
  • ~vtkProTriArray() : vtkProTriArray
  • ~vtkProVertexArray() : vtkProVertexArray
  • ~vtkPSphereSource() : vtkPSphereSource
  • ~vtkPVGeometryFilter() : vtkPVGeometryFilter
  • ~vtkPyramid() : vtkPyramid
  • ~vtkPythonCommand() : vtkPythonCommand
  • ~vtkQuad() : vtkQuad
  • ~vtkQuadraticEdge() : vtkQuadraticEdge
  • ~vtkQuadric() : vtkQuadric
  • ~vtkQuadricClustering() : vtkQuadricClustering
  • ~vtkQuadricDecimation() : vtkQuadricDecimation
  • ~vtkQuantizePolyDataPoints() : vtkQuantizePolyDataPoints
  • ~vtkQuartzImageMapper() : vtkQuartzImageMapper
  • ~vtkQuartzImageWindow() : vtkQuartzImageWindow
  • ~vtkQuartzRenderWindow() : vtkQuartzRenderWindow
  • ~vtkQuartzRenderWindowInteractor() : vtkQuartzRenderWindowInteractor
  • ~vtkQuartzTextMapper() : vtkQuartzTextMapper
  • ~vtkRayCaster() : vtkRayCaster
  • ~vtkRearrangeFields() : vtkRearrangeFields
  • ~vtkRectilinearGrid() : vtkRectilinearGrid
  • ~vtkRectilinearGridGeometryFilter() : vtkRectilinearGridGeometryFilter
  • ~vtkRectilinearGridOutlineFilter() : vtkRectilinearGridOutlineFilter
  • ~vtkRectilinearGridReader() : vtkRectilinearGridReader
  • ~vtkRectilinearGridSource() : vtkRectilinearGridSource
  • ~vtkRectilinearGridToPolyDataFilter() : vtkRectilinearGridToPolyDataFilter
  • ~vtkRectilinearGridWriter() : vtkRectilinearGridWriter
  • ~vtkRecursiveDividingCubes() : vtkRecursiveDividingCubes
  • ~vtkRecursiveSphereDirectionEncoder() : vtkRecursiveSphereDirectionEncoder
  • ~vtkReferenceCount() : vtkReferenceCount
  • ~vtkReflectionFilter() : vtkReflectionFilter
  • ~vtkRenderer() : vtkRenderer
  • ~vtkRendererCollection() : vtkRendererCollection
  • ~vtkRendererSource() : vtkRendererSource
  • ~vtkRenderLargeImage() : vtkRenderLargeImage
  • ~vtkRenderWindow() : vtkRenderWindow
  • ~vtkRenderWindowCollection() : vtkRenderWindowCollection
  • ~vtkRenderWindowInteractor() : vtkRenderWindowInteractor
  • ~vtkReverseSense() : vtkReverseSense
  • ~vtkRibbonFilter() : vtkRibbonFilter
  • ~vtkRIBExporter() : vtkRIBExporter
  • ~vtkRIBLight() : vtkRIBLight
  • ~vtkRIBProperty() : vtkRIBProperty
  • ~vtkRotationalExtrusionFilter() : vtkRotationalExtrusionFilter
  • ~vtkRTAnalyticSource() : vtkRTAnalyticSource
  • ~vtkRuledSurfaceFilter() : vtkRuledSurfaceFilter
  • ~vtkRungeKutta2() : vtkRungeKutta2
  • ~vtkRungeKutta4() : vtkRungeKutta4
  • ~vtkRungeKutta45() : vtkRungeKutta45
  • ~vtkSampleFunction() : vtkSampleFunction
  • ~vtkScalarBarActor() : vtkScalarBarActor
  • ~vtkScalarsToColors() : vtkScalarsToColors
  • ~vtkScalarTree() : vtkScalarTree
  • ~vtkScaledTextActor() : vtkScaledTextActor
  • ~vtkSelectPolyData() : vtkSelectPolyData
  • ~vtkSelectVisiblePoints() : vtkSelectVisiblePoints
  • ~vtkSharedMemoryCommunicator() : vtkSharedMemoryCommunicator
  • ~vtkShepardMethod() : vtkShepardMethod
  • ~vtkShortArray() : vtkShortArray
  • ~vtkShrinkFilter() : vtkShrinkFilter
  • ~vtkShrinkPolyData() : vtkShrinkPolyData
  • ~vtkSimpleCriticalSection() : vtkSimpleCriticalSection
  • ~vtkSimpleElevationFilter() : vtkSimpleElevationFilter
  • ~vtkSimpleImageFilterExample() : vtkSimpleImageFilterExample
  • ~vtkSimpleImageToImageFilter() : vtkSimpleImageToImageFilter
  • ~vtkSimpleMutexLock() : vtkSimpleMutexLock
  • ~vtkSimpleScalarTree() : vtkSimpleScalarTree
  • ~vtkSLCReader() : vtkSLCReader
  • ~vtkSliceCubes() : vtkSliceCubes
  • ~vtkSmoothPolyDataFilter() : vtkSmoothPolyDataFilter
  • ~vtkSocketCommunicator() : vtkSocketCommunicator
  • ~vtkSocketController() : vtkSocketController
  • ~vtkSource() : vtkSource
  • ~vtkSpatialRepresentationFilter() : vtkSpatialRepresentationFilter
  • ~vtkSphere() : vtkSphere
  • ~vtkSpherePuzzle() : vtkSpherePuzzle
  • ~vtkSpherePuzzleArrows() : vtkSpherePuzzleArrows
  • ~vtkSphereSource() : vtkSphereSource
  • ~vtkSpline() : vtkSpline
  • ~vtkSplitField() : vtkSplitField
  • ~vtkSTLReader() : vtkSTLReader
  • ~vtkSTLWriter() : vtkSTLWriter
  • ~vtkStreamArray() : vtkStreamArray
  • ~vtkStreamer() : vtkStreamer
  • ~vtkStreamLine() : vtkStreamLine
  • ~vtkStreamPoints() : vtkStreamPoints
  • ~vtkStripper() : vtkStripper
  • ~vtkStructuredData() : vtkStructuredData
  • ~vtkStructuredGrid() : vtkStructuredGrid
  • ~vtkStructuredGridGeometryFilter() : vtkStructuredGridGeometryFilter
  • ~vtkStructuredGridOutlineFilter() : vtkStructuredGridOutlineFilter
  • ~vtkStructuredGridReader() : vtkStructuredGridReader
  • ~vtkStructuredGridSource() : vtkStructuredGridSource
  • ~vtkStructuredGridToPolyDataFilter() : vtkStructuredGridToPolyDataFilter
  • ~vtkStructuredGridToStructuredGridFilter() : vtkStructuredGridToStructuredGridFilter
  • ~vtkStructuredGridWriter() : vtkStructuredGridWriter
  • ~vtkStructuredPoints() : vtkStructuredPoints
  • ~vtkStructuredPointsCollection() : vtkStructuredPointsCollection
  • ~vtkStructuredPointsGeometryFilter() : vtkStructuredPointsGeometryFilter
  • ~vtkStructuredPointsReader() : vtkStructuredPointsReader
  • ~vtkStructuredPointsSource() : vtkStructuredPointsSource
  • ~vtkStructuredPointsToPolyDataFilter() : vtkStructuredPointsToPolyDataFilter
  • ~vtkStructuredPointsToStructuredPointsFilter() : vtkStructuredPointsToStructuredPointsFilter
  • ~vtkStructuredPointsToUnstructuredGridFilter() : vtkStructuredPointsToUnstructuredGridFilter
  • ~vtkStructuredPointsWriter() : vtkStructuredPointsWriter
  • ~vtkSubdivideTetra() : vtkSubdivideTetra
  • ~vtkSubPixelPositionEdgels() : vtkSubPixelPositionEdgels
  • ~vtkSuperquadric() : vtkSuperquadric
  • ~vtkSuperquadricSource() : vtkSuperquadricSource
  • ~vtkSurfaceReconstructionFilter() : vtkSurfaceReconstructionFilter
  • ~vtkSweptSurface() : vtkSweptSurface
  • ~vtkSynchronizedTemplates2D() : vtkSynchronizedTemplates2D
  • ~vtkSynchronizedTemplates3D() : vtkSynchronizedTemplates3D
  • ~vtkTclCommand() : vtkTclCommand
  • ~vtkTensor() : vtkTensor
  • ~vtkTensorGlyph() : vtkTensorGlyph
  • ~vtkTetra() : vtkTetra
  • ~vtkTextMapper() : vtkTextMapper
  • ~vtkTextSource() : vtkTextSource
  • ~vtkTexture() : vtkTexture
  • ~vtkTexturedSphereSource() : vtkTexturedSphereSource
  • ~vtkTextureMapToCylinder() : vtkTextureMapToCylinder
  • ~vtkTextureMapToPlane() : vtkTextureMapToPlane
  • ~vtkTextureMapToSphere() : vtkTextureMapToSphere
  • ~vtkThinPlateSplineTransform() : vtkThinPlateSplineTransform
  • ~vtkThreadedController() : vtkThreadedController
  • ~vtkThreadSafeLog() : vtkThreadSafeLog
  • ~vtkThreshold() : vtkThreshold
  • ~vtkThresholdPoints() : vtkThresholdPoints
  • ~vtkThresholdTextureCoords() : vtkThresholdTextureCoords
  • ~vtkTIFFReader() : vtkTIFFReader
  • ~vtkTIFFWriter() : vtkTIFFWriter
  • ~vtkTimerLog() : vtkTimerLog
  • ~vtkTransform() : vtkTransform
  • ~vtkTransformCollection() : vtkTransformCollection
  • ~vtkTransformConcatenation() : vtkTransformConcatenation
  • ~vtkTransformConcatenationStack() : vtkTransformConcatenationStack
  • ~vtkTransformFilter() : vtkTransformFilter
  • ~vtkTransformPolyDataFilter() : vtkTransformPolyDataFilter
  • ~vtkTransformTextureCoords() : vtkTransformTextureCoords
  • ~vtkTransformToGrid() : vtkTransformToGrid
  • ~vtkTransmitPolyDataPiece() : vtkTransmitPolyDataPiece
  • ~vtkTransmitUnstructuredGridPiece() : vtkTransmitUnstructuredGridPiece
  • ~vtkTreeComposite() : vtkTreeComposite
  • ~vtkTriangle() : vtkTriangle
  • ~vtkTriangleFilter() : vtkTriangleFilter
  • ~vtkTriangleStrip() : vtkTriangleStrip
  • ~vtkTriangularTCoords() : vtkTriangularTCoords
  • ~vtkTriangularTexture() : vtkTriangularTexture
  • ~vtkTriArray() : vtkTriArray
  • ~vtkTubeFilter() : vtkTubeFilter
  • ~vtkUGFacetReader() : vtkUGFacetReader
  • ~vtkUnsignedCharArray() : vtkUnsignedCharArray
  • ~vtkUnsignedIntArray() : vtkUnsignedIntArray
  • ~vtkUnsignedLongArray() : vtkUnsignedLongArray
  • ~vtkUnsignedShortArray() : vtkUnsignedShortArray
  • ~vtkUnstructuredGrid() : vtkUnstructuredGrid
  • ~vtkUnstructuredGridReader() : vtkUnstructuredGridReader
  • ~vtkUnstructuredGridSource() : vtkUnstructuredGridSource
  • ~vtkUnstructuredGridToPolyDataFilter() : vtkUnstructuredGridToPolyDataFilter
  • ~vtkUnstructuredGridToUnstructuredGridFilter() : vtkUnstructuredGridToUnstructuredGridFilter
  • ~vtkUnstructuredGridWriter() : vtkUnstructuredGridWriter
  • ~vtkVectorDot() : vtkVectorDot
  • ~vtkVectorNorm() : vtkVectorNorm
  • ~vtkVectorText() : vtkVectorText
  • ~vtkVersion() : vtkVersion
  • ~vtkVertex() : vtkVertex
  • ~vtkVertexArray() : vtkVertexArray
  • ~vtkVideoSource() : vtkVideoSource
  • ~vtkViewport() : vtkViewport
  • ~vtkVoidArray() : vtkVoidArray
  • ~vtkVolume() : vtkVolume
  • ~vtkVolume16Reader() : vtkVolume16Reader
  • ~vtkVolumeCollection() : vtkVolumeCollection
  • ~vtkVolumeMapper() : vtkVolumeMapper
  • ~vtkVolumeProMapper() : vtkVolumeProMapper
  • ~vtkVolumeProperty() : vtkVolumeProperty
  • ~vtkVolumeProVG500Mapper() : vtkVolumeProVG500Mapper
  • ~vtkVolumeProVP1000Mapper() : vtkVolumeProVP1000Mapper
  • ~vtkVolumeRayCastCompositeFunction() : vtkVolumeRayCastCompositeFunction
  • ~vtkVolumeRayCastFunction() : vtkVolumeRayCastFunction
  • ~vtkVolumeRayCastIsosurfaceFunction() : vtkVolumeRayCastIsosurfaceFunction
  • ~vtkVolumeRayCastMapper() : vtkVolumeRayCastMapper
  • ~vtkVolumeRayCastMIPFunction() : vtkVolumeRayCastMIPFunction
  • ~vtkVolumeReader() : vtkVolumeReader
  • ~vtkVolumeTextureMapper() : vtkVolumeTextureMapper
  • ~vtkVolumeTextureMapper2D() : vtkVolumeTextureMapper2D
  • ~vtkVoxel() : vtkVoxel
  • ~vtkVoxelContoursToSurfaceFilter() : vtkVoxelContoursToSurfaceFilter
  • ~vtkVoxelModeller() : vtkVoxelModeller
  • ~vtkVRMLExporter() : vtkVRMLExporter
  • ~vtkVRMLImporter() : vtkVRMLImporter
  • ~vtkWarpLens() : vtkWarpLens
  • ~vtkWarpScalar() : vtkWarpScalar
  • ~vtkWarpTo() : vtkWarpTo
  • ~vtkWarpTransform() : vtkWarpTransform
  • ~vtkWarpVector() : vtkWarpVector
  • ~vtkWedge() : vtkWedge
  • ~vtkWeightedTransformFilter() : vtkWeightedTransformFilter
  • ~vtkWin32ImageMapper() : vtkWin32ImageMapper
  • ~vtkWin32ImageWindow() : vtkWin32ImageWindow
  • ~vtkWin32OpenGLImageWindow() : vtkWin32OpenGLImageWindow
  • ~vtkWin32OpenGLRenderWindow() : vtkWin32OpenGLRenderWindow
  • ~vtkWin32OpenGLTextMapper() : vtkWin32OpenGLTextMapper
  • ~vtkWin32OutputWindow() : vtkWin32OutputWindow
  • ~vtkWin32PolyDataMapper2D() : vtkWin32PolyDataMapper2D
  • ~vtkWin32RenderWindowInteractor() : vtkWin32RenderWindowInteractor
  • ~vtkWin32TextMapper() : vtkWin32TextMapper
  • ~vtkWin32VideoSource() : vtkWin32VideoSource
  • ~vtkWinCEOpenGLRenderWindow() : vtkWinCEOpenGLRenderWindow
  • ~vtkWindow() : vtkWindow
  • ~vtkWindowedSincPolyDataFilter() : vtkWindowedSincPolyDataFilter
  • ~vtkWindowLevelLookupTable() : vtkWindowLevelLookupTable
  • ~vtkWindowToImageFilter() : vtkWindowToImageFilter
  • ~vtkWorldPointPicker() : vtkWorldPointPicker
  • ~vtkWriter() : vtkWriter
  • ~vtkXImageMapper() : vtkXImageMapper
  • ~vtkXImageWindow() : vtkXImageWindow
  • ~vtkXMesaRenderWindow() : vtkXMesaRenderWindow
  • ~vtkXMesaTextMapper() : vtkXMesaTextMapper
  • ~vtkXMLFileOutputWindow() : vtkXMLFileOutputWindow
  • ~vtkXMLParser() : vtkXMLParser
  • ~vtkXOpenGLRenderWindow() : vtkXOpenGLRenderWindow
  • ~vtkXOpenGLTextMapper() : vtkXOpenGLTextMapper
  • ~vtkXPolyDataMapper2D() : vtkXPolyDataMapper2D
  • ~vtkXRenderWindowInteractor() : vtkXRenderWindowInteractor
  • ~vtkXRenderWindowTclInteractor() : vtkXRenderWindowTclInteractor
  • ~vtkXTextMapper() : vtkXTextMapper
  • ~vtkXYPlotActor() : vtkXYPlotActor
Generated on Mon Mar 25 01:15:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


File Member Index

VTK File Members

b | c | d | e | g | i | j | m | o | p | r | s | t | v | w

Here is a list of all file members with links to the files they belong to:

- b -

  • byte : vtk3DS.h

- c -
  • cerr : vtkWinCE.h
  • cin : vtkWinCE.h
  • close : vtkQuartzWindow.h
  • cout : vtkWinCE.h

- d -
  • DEFAULTINCREMENT : vtkVRML.h
  • drawRect : vtkQuartzGLView.h
  • dword : vtk3DS.h

- e -
  • EDGE_LIST : vtkMarchingSquaresCases.h, vtkMarchingCubesCases.h
  • endl : vtkWinCE.h

- g -
  • getvtkQuartzGLView : vtkQuartzWindow.h
  • getVTKRenderWindow : vtkQuartzWindow.h, vtkQuartzGLView.h
  • getVTKRenderWindowInteractor : vtkQuartzWindow.h, vtkQuartzGLView.h

- i -
  • id : vtkQuartzGLView.h
  • idx0 : vtkImageIslandRemoval2D.h
  • idx1 : vtkImageIslandRemoval2D.h
  • Imag : vtkImageFourierFilter.h
  • initWithFrame : vtkQuartzGLView.h
  • inPtr : vtkImageIslandRemoval2D.h

- j -
  • Java_vtkPanel_Lock() : vtkJavaAwt.h
  • Java_vtkPanel_RenderCreate() : vtkJavaAwt.h
  • Java_vtkPanel_UnLock() : vtkJavaAwt.h

- m -
  • M : vtkgluPickMatrix.h
  • makeCurrentContext : vtkQuartzWindow.h
  • myalloc : vtkPLY.h

- o -
  • OtherData : vtkPLY.h
  • OtherElem : vtkPLY.h
  • outPtr : vtkImageIslandRemoval2D.h

- p -
  • PLY_ASCII : vtkPLY.h
  • PLY_BINARY_BE : vtkPLY.h
  • PLY_BINARY_LE : vtkPLY.h
  • PLY_CHAR : vtkPLY.h
  • PLY_DOUBLE : vtkPLY.h
  • PLY_END_TYPE : vtkPLY.h
  • PLY_ERROR : vtkPLY.h
  • PLY_FLOAT : vtkPLY.h
  • PLY_INT : vtkPLY.h
  • PLY_LIST : vtkPLY.h
  • PLY_OKAY : vtkPLY.h
  • PLY_SCALAR : vtkPLY.h
  • PLY_SHORT : vtkPLY.h
  • PLY_START_TYPE : vtkPLY.h
  • PLY_UCHAR : vtkPLY.h
  • PLY_UINT : vtkPLY.h
  • PLY_USHORT : vtkPLY.h
  • PlyElement : vtkPLY.h
  • PlyFile : vtkPLY.h
  • PlyOtherElems : vtkPLY.h
  • PlyOtherProp : vtkPLY.h
  • PlyProperty : vtkPLY.h
  • PyArg_VTKParseTuple() : vtkPythonUtil.h
  • PyVTKClass_Check() : vtkPythonUtil.h
  • PyVTKClass_New() : vtkPythonUtil.h
  • PyVTKObject_Check() : vtkPythonUtil.h
  • PyVTKObject_New() : vtkPythonUtil.h
  • PyVTKSpecialObject_New() : vtkPythonUtil.h
  • PyVTKSpecialObjectCheck() : vtkPythonUtil.h

- r -
  • Real : vtkImageFourierFilter.h

- s -
  • SELECT_MASK : vtkTimerLog.h
  • setvtkQuartzGLView : vtkQuartzWindow.h
  • setVTKRenderWindow : vtkQuartzWindow.h, vtkQuartzGLView.h
  • setVTKRenderWindowInteractor : vtkQuartzWindow.h, vtkQuartzGLView.h
  • standardNodes : vtkVRML.h

- t -
  • TheTime() : vtkInteractorStyleUnicam.h

- v -
  • Vector : vtk3DS.h
  • VTK_3D_EXTENT : vtkDataObject.h
  • VTK_ABS : vtkImageMathematics.h
  • VTK_ACCUMULATION_MODE_MAX : vtkGaussianSplatter.h
  • VTK_ACCUMULATION_MODE_MIN : vtkGaussianSplatter.h
  • VTK_ACCUMULATION_MODE_SUM : vtkGaussianSplatter.h
  • VTK_ADD : vtkImageMathematics.h
  • VTK_ADDC : vtkImageMathematics.h
  • VTK_AND : vtkImageLogic.h
  • VTK_ARIAL : vtkTextMapper.h
  • VTK_ARROW_GLYPH : vtkGlyphSource2D.h
  • VTK_ASCII : vtkWriter.h, vtkDataReader.h
  • VTK_ATAN : vtkImageMathematics.h
  • VTK_ATAN2 : vtkImageMathematics.h
  • VTK_ATTRIBUTE_MODE_DEFAULT : vtkVectorNorm.h, vtkThreshold.h, vtkArrayCalculator.h
  • VTK_ATTRIBUTE_MODE_USE_CELL_DATA : vtkVectorNorm.h, vtkThreshold.h, vtkArrayCalculator.h
  • VTK_ATTRIBUTE_MODE_USE_POINT_DATA : vtkVectorNorm.h, vtkThreshold.h, vtkArrayCalculator.h
  • VTK_BACKGROUND_LOCATION : vtkProperty2D.h
  • VTK_BIG_ENDIAN : vtkPLYWriter.h
  • VTK_BINARY : vtkWriter.h, vtkDataReader.h
  • VTK_BIT : vtkSetGet.h
  • VTK_BIT_MAX : vtkSetGet.h
  • VTK_BIT_MIN : vtkSetGet.h
  • VTK_BLEND_MODE_COMPOSITE : vtkVolumeProMapper.h
  • VTK_BLEND_MODE_MAX_INTENSITY : vtkVolumeProMapper.h
  • VTK_BLEND_MODE_MIN_INTENSITY : vtkVolumeProMapper.h
  • VTK_BUILD_VERSION : vtkVersion.h
  • VTK_CELL_DATA : vtkFieldDataToAttributeDataFilter.h
  • VTK_CELL_DATA_FIELD : vtkFieldDataToAttributeDataFilter.h
  • VTK_CELL_MODE : vtkImplicitModeller.h
  • VTK_CELL_SIZE : vtkCell.h
  • VTK_CHAR : vtkSetGet.h
  • VTK_CHAR_MAX : vtkSetGet.h
  • VTK_CHAR_MIN : vtkSetGet.h
  • VTK_CIRCLE_GLYPH : vtkGlyphSource2D.h
  • VTK_COLOR_BY_INPUT : vtkProgrammableGlyphFilter.h
  • VTK_COLOR_BY_SCALAR : vtkGlyph3D.h
  • VTK_COLOR_BY_SCALE : vtkGlyph3D.h
  • VTK_COLOR_BY_SOURCE : vtkProgrammableGlyphFilter.h
  • VTK_COLOR_BY_VECTOR : vtkGlyph3D.h
  • VTK_COLOR_MODE_DEFAULT : vtkPLYWriter.h, vtkCGMWriter.h, vtkScalarsToColors.h
  • VTK_COLOR_MODE_LINEAR_256 : vtkImageToPolyDataFilter.h
  • VTK_COLOR_MODE_LUT : vtkImageToPolyDataFilter.h
  • VTK_COLOR_MODE_MAP_SCALARS : vtkScalarsToColors.h
  • VTK_COLOR_MODE_OFF : vtkPLYWriter.h
  • VTK_COLOR_MODE_RANDOM_COLORS : vtkCGMWriter.h
  • VTK_COLOR_MODE_SPECIFIED_COLOR : vtkCGMWriter.h
  • VTK_COLOR_MODE_UNIFORM_CELL_COLOR : vtkPLYWriter.h
  • VTK_COLOR_MODE_UNIFORM_COLOR : vtkPLYWriter.h
  • VTK_COLOR_MODE_UNIFORM_POINT_COLOR : vtkPLYWriter.h
  • VTK_COMMON_EXPORT : vtkWin32Header.h
  • VTK_COMPLEX_MULTIPLY : vtkImageMathematics.h
  • VTK_COMPLEX_SCALAR_PER_ELEMENT : vtkEnSightReader.h
  • VTK_COMPLEX_SCALAR_PER_NODE : vtkEnSightReader.h
  • VTK_COMPLEX_VECTOR_PER_ELEMENT : vtkEnSightReader.h
  • VTK_COMPLEX_VECTOR_PER_NODE : vtkEnSightReader.h
  • VTK_COMPOSITE_CLASSIFY_FIRST : vtkVolumeRayCastCompositeFunction.h
  • VTK_COMPOSITE_INTERPOLATE_FIRST : vtkVolumeRayCastCompositeFunction.h
  • VTK_CONJUGATE : vtkImageMathematics.h
  • VTK_COS : vtkImageMathematics.h
  • VTK_COURIER : vtkTextMapper.h
  • VTK_CREATE_CREATE_FUNCTION : vtkObjectFactory.h
  • VTK_CROP_CROSS : vtkVolumeMapper.h
  • VTK_CROP_FENCE : vtkVolumeMapper.h
  • VTK_CROP_INVERTED_CROSS : vtkVolumeMapper.h
  • VTK_CROP_INVERTED_FENCE : vtkVolumeMapper.h
  • VTK_CROP_SUBVOLUME : vtkVolumeMapper.h
  • VTK_CROSS_GLYPH : vtkGlyphSource2D.h
  • VTK_CTF_HSV : vtkColorTransferFunction.h
  • VTK_CTF_RGB : vtkColorTransferFunction.h
  • VTK_CULLER_SORT_BACK_TO_FRONT : vtkFrustumCoverageCuller.h
  • VTK_CULLER_SORT_FRONT_TO_BACK : vtkFrustumCoverageCuller.h
  • VTK_CULLER_SORT_NONE : vtkFrustumCoverageCuller.h
  • VTK_CURSOR_TYPE_CROSSHAIR : vtkVolumeProMapper.h
  • VTK_CURSOR_TYPE_PLANE : vtkVolumeProMapper.h
  • VTK_DASH_GLYPH : vtkGlyphSource2D.h
  • VTK_DATA_OBJECT : vtkSetGet.h
  • VTK_DATA_OBJECT_FIELD : vtkFieldDataToAttributeDataFilter.h
  • VTK_DATA_SCALING_OFF : vtkGlyph3D.h
  • VTK_DATA_SET : vtkSetGet.h
  • VTK_DIAMOND_GLYPH : vtkGlyphSource2D.h
  • VTK_DICE_MODE_MEMORY_LIMIT : vtkDicer.h
  • VTK_DICE_MODE_NUMBER_OF_POINTS : vtkDicer.h
  • VTK_DICE_MODE_SPECIFIED_NUMBER : vtkDicer.h
  • VTK_DIFFERENCE : vtkImplicitBoolean.h
  • VTK_DIRECTION_BACK_TO_FRONT : vtkDepthSortPolyData.h
  • VTK_DIRECTION_FRONT_TO_BACK : vtkDepthSortPolyData.h
  • VTK_DIRECTION_SPECIFIED_VECTOR : vtkDepthSortPolyData.h
  • VTK_DISPLAY : vtkCoordinate.h
  • VTK_DIVIDE : vtkImageMathematics.h
  • VTK_DOUBLE : vtkSetGet.h
  • VTK_DOUBLE_MAX : vtkSetGet.h
  • VTK_DOUBLE_MIN : vtkSetGet.h
  • VTK_EDT_SAITO : vtkImageEuclideanDistance.h
  • VTK_EDT_SAITO_CACHED : vtkImageEuclideanDistance.h
  • VTK_EMPTY : vtkStructuredData.h
  • VTK_EMPTY_CELL : vtkCellType.h
  • VTK_ENSIGHT_6 : vtkGenericEnSightReader.h
  • VTK_ENSIGHT_6_BINARY : vtkGenericEnSightReader.h
  • VTK_ENSIGHT_BAR2 : vtkEnSightReader.h
  • VTK_ENSIGHT_BAR3 : vtkEnSightReader.h
  • VTK_ENSIGHT_GOLD : vtkGenericEnSightReader.h
  • VTK_ENSIGHT_GOLD_BINARY : vtkGenericEnSightReader.h
  • VTK_ENSIGHT_HEXA20 : vtkEnSightReader.h
  • VTK_ENSIGHT_HEXA8 : vtkEnSightReader.h
  • VTK_ENSIGHT_NSIDED : vtkEnSightReader.h
  • VTK_ENSIGHT_PENTA15 : vtkEnSightReader.h
  • VTK_ENSIGHT_PENTA6 : vtkEnSightReader.h
  • VTK_ENSIGHT_POINT : vtkEnSightReader.h
  • VTK_ENSIGHT_PYRAMID13 : vtkEnSightReader.h
  • VTK_ENSIGHT_PYRAMID5 : vtkEnSightReader.h
  • VTK_ENSIGHT_QUAD4 : vtkEnSightReader.h
  • VTK_ENSIGHT_QUAD8 : vtkEnSightReader.h
  • VTK_ENSIGHT_TETRA10 : vtkEnSightReader.h
  • VTK_ENSIGHT_TETRA4 : vtkEnSightReader.h
  • VTK_ENSIGHT_TRIA3 : vtkEnSightReader.h
  • VTK_ENSIGHT_TRIA6 : vtkEnSightReader.h
  • VTK_ERROR : vtkSetGet.h
  • VTK_EXP : vtkImageMathematics.h
  • VTK_EXPORT : vtkWin32Header.h
  • VTK_EXTRACT_ALL_REGIONS : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_EXTRACT_CELL_SEEDED_REGIONS : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_EXTRACT_CLOSEST_POINT_REGION : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_EXTRACT_COMPONENT : vtkExtractTensorComponents.h
  • VTK_EXTRACT_DETERMINANT : vtkExtractTensorComponents.h
  • VTK_EXTRACT_EFFECTIVE_STRESS : vtkExtractTensorComponents.h
  • VTK_EXTRACT_LARGEST_REGION : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_EXTRACT_POINT_SEEDED_REGIONS : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_EXTRACT_SPECIFIED_REGIONS : vtkPolyDataConnectivityFilter.h, vtkConnectivityFilter.h
  • VTK_FACTORY_INTERFACE_EXPORT : vtkObjectFactory.h
  • VTK_FACTORY_INTERFACE_IMPLEMENT : vtkObjectFactory.h
  • VTK_FILE_BYTE_ORDER_BIG_ENDIAN : vtkVolume16Reader.h, vtkParticleReader.h, vtkMCubesReader.h, vtkImageReader2.h, vtkImageReader.h
  • VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN : vtkVolume16Reader.h, vtkParticleReader.h, vtkMCubesReader.h, vtkImageReader2.h, vtkImageReader.h
  • VTK_FILTERING_EXPORT : vtkWin32Header.h
  • VTK_FLAT : vtkRender.h
  • VTK_FLOAT : vtkSetGet.h
  • VTK_FLOAT_MAX : vtkSetGet.h
  • VTK_FLOAT_MIN : vtkSetGet.h
  • VTK_FLY_CLOSEST_TRIAD : vtkCubeAxesActor2D.h
  • VTK_FLY_OUTER_EDGES : vtkCubeAxesActor2D.h
  • VTK_FOREGROUND_LOCATION : vtkProperty2D.h
  • VTK_GET_ARRAY_BY_ID : vtkMapper.h, vtkAbstractMapper.h
  • VTK_GET_ARRAY_BY_NAME : vtkMapper.h, vtkAbstractMapper.h
  • VTK_GOURAUD : vtkRender.h
  • VTK_GRAPHICS_EXPORT : vtkWin32Header.h
  • VTK_GRID_CUBIC : vtkGridTransform.h
  • VTK_GRID_LINEAR : vtkGridTransform.h
  • VTK_GRID_NEAREST : vtkGridTransform.h
  • VTK_HAS_ID_TYPE : vtkSystemIncludes.h
  • VTK_HEXAHEDRON : vtkCellType.h
  • VTK_HOOKEDARROW_GLYPH : vtkGlyphSource2D.h
  • VTK_HYBRID_EXPORT : vtkWin32Header.h
  • VTK_ICP_MODE_AV : vtkIterativeClosestPointTransform.h
  • VTK_ICP_MODE_RMS : vtkIterativeClosestPointTransform.h
  • VTK_ID_TYPE : vtkSetGet.h
  • VTK_IMAGE_BLEND_MODE_COMPOUND : vtkImageBlend.h
  • VTK_IMAGE_BLEND_MODE_NORMAL : vtkImageBlend.h
  • VTK_IMAGE_DATA : vtkSetGet.h
  • VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_MAGNITUDE_INPUT : vtkImageNonMaximumSuppression.h
  • VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_VECTOR_INPUT : vtkImageNonMaximumSuppression.h
  • VTK_IMAGING_EXPORT : vtkWin32Header.h
  • VTK_INDEXING_BY_SCALAR : vtkGlyph3D.h
  • VTK_INDEXING_BY_VECTOR : vtkGlyph3D.h
  • VTK_INDEXING_OFF : vtkGlyph3D.h
  • VTK_INSIDE_CLOSEST_POINT_REGION : vtkSelectPolyData.h
  • VTK_INSIDE_LARGEST_REGION : vtkSelectPolyData.h
  • VTK_INSIDE_SMALLEST_REGION : vtkSelectPolyData.h
  • VTK_INT : vtkSetGet.h
  • VTK_INT_MAX : vtkSetGet.h
  • VTK_INT_MIN : vtkSetGet.h
  • VTK_INTEGRATE_BACKWARD : vtkStreamer.h, vtkHyperStreamline.h
  • VTK_INTEGRATE_BOTH_DIRECTIONS : vtkStreamer.h, vtkHyperStreamline.h
  • VTK_INTEGRATE_FORWARD : vtkStreamer.h, vtkHyperStreamline.h
  • VTK_INTERACTOR_STYLE_ACTOR_NONE : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_ACTOR_PAN : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_ACTOR_ROTATE : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_ACTOR_SCALE : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_ACTOR_SPIN : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_ACTOR_ZOOM : vtkInteractorStyleTrackballActor.h, vtkInteractorStyleJoystickActor.h
  • VTK_INTERACTOR_STYLE_CAMERA_NONE : vtkInteractorStyleTrackballCamera.h, vtkInteractorStyleJoystickCamera.h
  • VTK_INTERACTOR_STYLE_CAMERA_PAN : vtkInteractorStyleTrackballCamera.h, vtkInteractorStyleJoystickCamera.h
  • VTK_INTERACTOR_STYLE_CAMERA_ROTATE : vtkInteractorStyleTrackballCamera.h, vtkInteractorStyleJoystickCamera.h
  • VTK_INTERACTOR_STYLE_CAMERA_SPIN : vtkInteractorStyleTrackballCamera.h, vtkInteractorStyleJoystickCamera.h
  • VTK_INTERACTOR_STYLE_CAMERA_ZOOM : vtkInteractorStyleTrackballCamera.h, vtkInteractorStyleJoystickCamera.h
  • VTK_INTERACTOR_STYLE_IMAGE_NONE : vtkInteractorStyleImage.h
  • VTK_INTERACTOR_STYLE_IMAGE_PAN : vtkInteractorStyleImage.h
  • VTK_INTERACTOR_STYLE_IMAGE_SPIN : vtkInteractorStyleImage.h
  • VTK_INTERACTOR_STYLE_IMAGE_WINDOW_LEVEL : vtkInteractorStyleImage.h
  • VTK_INTERACTOR_STYLE_IMAGE_ZOOM : vtkInteractorStyleImage.h
  • VTK_INTERSECTION : vtkImplicitBoolean.h
  • VTK_INVERT : vtkImageMathematics.h
  • VTK_IO_EXPORT : vtkWin32Header.h
  • VTK_IV_COLUMN : vtkParallelCoordinatesActor.h
  • VTK_IV_ROW : vtkParallelCoordinatesActor.h
  • VTK_LABEL_FIELD_DATA : vtkLabeledDataMapper.h
  • VTK_LABEL_IDS : vtkLabeledDataMapper.h
  • VTK_LABEL_NORMALS : vtkLabeledDataMapper.h
  • VTK_LABEL_SCALARS : vtkLabeledDataMapper.h
  • VTK_LABEL_TCOORDS : vtkLabeledDataMapper.h
  • VTK_LABEL_TENSORS : vtkLabeledDataMapper.h
  • VTK_LABEL_VECTORS : vtkLabeledDataMapper.h
  • VTK_LANDMARK_AFFINE : vtkLandmarkTransform.h
  • VTK_LANDMARK_RIGIDBODY : vtkLandmarkTransform.h
  • VTK_LANDMARK_SIMILARITY : vtkLandmarkTransform.h
  • VTK_LARGE_FLOAT : vtkSetGet.h
  • VTK_LARGE_ID : vtkSetGet.h
  • VTK_LARGE_INTEGER : vtkSetGet.h
  • VTK_LEAN_AND_MEAN : vtkWinCE.h
  • VTK_LEGACY_METHOD : vtkSetGet.h
  • VTK_LIGHT_TYPE_CAMERA_LIGHT : vtkLight.h
  • VTK_LIGHT_TYPE_HEADLIGHT : vtkLight.h
  • VTK_LIGHT_TYPE_SCENE_LIGHT : vtkLight.h
  • VTK_LINE : vtkCellType.h
  • VTK_LINEAR_INTERPOLATION : vtkVolumeProperty.h
  • VTK_LIST_DELETE : vtk3DS.h
  • VTK_LIST_FIELDS : vtk3DS.h
  • VTK_LIST_FIND : vtk3DS.h
  • VTK_LIST_INSERT : vtk3DS.h
  • VTK_LIST_KILL : vtk3DS.h
  • VTK_LITTLE_ENDIAN : vtkPLYWriter.h
  • VTK_LOG : vtkImageMathematics.h
  • VTK_LOG_EVENT_LENGTH : vtkTimerLog.h
  • VTK_LONG : vtkSetGet.h
  • VTK_LONG_MAX : vtkSetGet.h
  • VTK_LONG_MIN : vtkSetGet.h
  • VTK_LUMINANCE : vtkScalarsToColors.h
  • VTK_LUMINANCE_ALPHA : vtkScalarsToColors.h
  • VTK_MAJOR_VERSION : vtkVersion.h
  • VTK_MAX : vtkImageMathematics.h
  • VTK_MAX_LABELS : vtkAxisActor2D.h
  • VTK_MAX_SHADING_TABLES : vtkEncodedGradientShader.h
  • VTK_MAX_SPATIAL_REP_LEVEL : vtkSpatialRepresentationFilter.h
  • VTK_MAX_SPHERE_RESOLUTION : vtkTexturedSphereSource.h, vtkSphereSource.h, vtkSpherePuzzle.h
  • VTK_MAX_SUPERQUADRIC_RESOLUTION : vtkSuperquadricSource.h
  • VTK_MAX_THREADS : vtkMultiThreader.h
  • VTK_MAXIMIZE_OPACITY : vtkVolumeRayCastMIPFunction.h
  • VTK_MAXIMIZE_SCALAR_VALUE : vtkVolumeRayCastMIPFunction.h
  • VTK_MIL_CCIR : vtkMILVideoSource.h
  • VTK_MIL_COMPOSITE : vtkMILVideoSource.h
  • VTK_MIL_CORONA : vtkMILVideoSource.h
  • VTK_MIL_DEFAULT : vtkMILVideoSource.h
  • VTK_MIL_DIGITAL : vtkMILVideoSource.h
  • VTK_MIL_GENESIS : vtkMILVideoSource.h
  • VTK_MIL_METEOR : vtkMILVideoSource.h
  • VTK_MIL_METEOR_II : vtkMILVideoSource.h
  • VTK_MIL_METEOR_II_DIG : vtkMILVideoSource.h
  • VTK_MIL_MONO : vtkMILVideoSource.h
  • VTK_MIL_NONSTANDARD : vtkMILVideoSource.h
  • VTK_MIL_NTSC : vtkMILVideoSource.h
  • VTK_MIL_PAL : vtkMILVideoSource.h
  • VTK_MIL_PULSAR : vtkMILVideoSource.h
  • VTK_MIL_RGB : vtkMILVideoSource.h
  • VTK_MIL_RS170 : vtkMILVideoSource.h
  • VTK_MIL_SECAM : vtkMILVideoSource.h
  • VTK_MIL_YC : vtkMILVideoSource.h
  • VTK_MIN : vtkImageMathematics.h
  • VTK_MIN_SUPERQUADRIC_ROUNDNESS : vtkSuperquadricSource.h
  • VTK_MIN_SUPERQUADRIC_THICKNESS : vtkSuperquadricSource.h, vtkSuperquadric.h
  • VTK_MINOR_VERSION : vtkVersion.h
  • VTK_MULTI_PROCESS_LOG_MAX : vtkMultiProcessLog.h
  • VTK_MULTIPLY : vtkImageMathematics.h
  • VTK_MULTIPLYBYK : vtkImageMathematics.h
  • VTK_NAND : vtkImageLogic.h
  • VTK_NEAREST_INTERPOLATION : vtkVolumeProperty.h
  • VTK_NO_GLYPH : vtkGlyphSource2D.h
  • VTK_NOP : vtkImageLogic.h
  • VTK_NOR : vtkImageLogic.h
  • VTK_NORMAL_EXTRUSION : vtkLinearExtrusionFilter.h
  • VTK_NORMALIZED_DISPLAY : vtkCoordinate.h
  • VTK_NORMALIZED_VIEWPORT : vtkCoordinate.h
  • VTK_NOT : vtkImageLogic.h
  • VTK_NUMBER_STATISTICS : vtkDecimate.h
  • VTK_OK : vtkSetGet.h
  • VTK_OPAQUE : vtkSetGet.h
  • VTK_OR : vtkImageLogic.h
  • VTK_ORIENT_HORIZONTAL : vtkScalarBarActor.h
  • VTK_ORIENT_VERTICAL : vtkScalarBarActor.h
  • VTK_PARALLEL_EXPORT : vtkWin32Header.h
  • VTK_PARAMETRIC_CURVE : vtkCellType.h
  • VTK_PARAMETRIC_SURFACE : vtkCellType.h
  • VTK_PARSER_ABSOLUTE_VALUE : vtkFunctionParser.h
  • VTK_PARSER_ADD : vtkFunctionParser.h
  • VTK_PARSER_ARCCOSINE : vtkFunctionParser.h
  • VTK_PARSER_ARCSINE : vtkFunctionParser.h
  • VTK_PARSER_ARCTANGENT : vtkFunctionParser.h
  • VTK_PARSER_BEGIN_VARIABLES : vtkFunctionParser.h
  • VTK_PARSER_CEILING : vtkFunctionParser.h
  • VTK_PARSER_COSINE : vtkFunctionParser.h
  • VTK_PARSER_DIVIDE : vtkFunctionParser.h
  • VTK_PARSER_DOT_PRODUCT : vtkFunctionParser.h
  • VTK_PARSER_ERROR_RESULT : vtkFunctionParser.h
  • VTK_PARSER_EXPONENT : vtkFunctionParser.h
  • VTK_PARSER_FLOOR : vtkFunctionParser.h
  • VTK_PARSER_HYPERBOLIC_COSINE : vtkFunctionParser.h
  • VTK_PARSER_HYPERBOLIC_SINE : vtkFunctionParser.h
  • VTK_PARSER_HYPERBOLIC_TANGENT : vtkFunctionParser.h
  • VTK_PARSER_IMMEDIATE : vtkFunctionParser.h
  • VTK_PARSER_LOGARITHM : vtkFunctionParser.h
  • VTK_PARSER_MAGNITUDE : vtkFunctionParser.h
  • VTK_PARSER_MULTIPLY : vtkFunctionParser.h
  • VTK_PARSER_NORMALIZE : vtkFunctionParser.h
  • VTK_PARSER_POWER : vtkFunctionParser.h
  • VTK_PARSER_SCALAR_MULTIPLE : vtkFunctionParser.h
  • VTK_PARSER_SINE : vtkFunctionParser.h
  • VTK_PARSER_SQUARE_ROOT : vtkFunctionParser.h
  • VTK_PARSER_SUBTRACT : vtkFunctionParser.h
  • VTK_PARSER_TANGENT : vtkFunctionParser.h
  • VTK_PARSER_UNARY_MINUS : vtkFunctionParser.h
  • VTK_PARSER_VECTOR_ADD : vtkFunctionParser.h
  • VTK_PARSER_VECTOR_SUBTRACT : vtkFunctionParser.h
  • VTK_PARSER_VECTOR_UNARY_MINUS : vtkFunctionParser.h
  • VTK_PATENTED_EXPORT : vtkWin32Header.h
  • VTK_PHONG : vtkRender.h
  • VTK_PIECES_EXTENT : vtkDataObject.h
  • VTK_PIECEWISE_FUNCTION : vtkSetGet.h
  • VTK_PIXEL : vtkCellType.h
  • VTK_PLOT_FIELD_DATA : vtkArcPlotter.h
  • VTK_PLOT_NORMALS : vtkArcPlotter.h
  • VTK_PLOT_SCALARS : vtkArcPlotter.h
  • VTK_PLOT_TCOORDS : vtkArcPlotter.h
  • VTK_PLOT_TENSORS : vtkArcPlotter.h
  • VTK_PLOT_VECTORS : vtkArcPlotter.h
  • VTK_POINT_DATA : vtkFieldDataToAttributeDataFilter.h
  • VTK_POINT_DATA_FIELD : vtkFieldDataToAttributeDataFilter.h
  • VTK_POINT_EXTRUSION : vtkLinearExtrusionFilter.h
  • VTK_POINT_SHELL : vtkPointSource.h
  • VTK_POINT_UNIFORM : vtkPointSource.h
  • VTK_POINTS : vtkRender.h
  • VTK_POLY_DATA : vtkSetGet.h
  • VTK_POLY_LINE : vtkCellType.h
  • VTK_POLY_VERTEX : vtkCellType.h
  • VTK_POLYGON : vtkCellType.h
  • VTK_PYRAMID : vtkCellType.h
  • VTK_PYTHON_EXPORT : vtkPythonUtil.h
  • VTK_QUAD : vtkCellType.h
  • VTK_QUADRATIC_EDGE : vtkCellType.h
  • VTK_QUADRATIC_TETRA : vtkCellType.h
  • VTK_QUADRATIC_TRIANGLE : vtkCellType.h
  • VTK_RAMP_LINEAR : vtkLookupTable.h
  • VTK_RAMP_SCURVE : vtkLookupTable.h
  • VTK_RBF_CUSTOM : vtkThinPlateSplineTransform.h
  • VTK_RBF_R : vtkThinPlateSplineTransform.h
  • VTK_RBF_R2LOGR : vtkThinPlateSplineTransform.h
  • VTK_RECTILINEAR_GRID : vtkSetGet.h
  • VTK_RENDERING_EXPORT : vtkWin32Header.h
  • VTK_REPLACECBYK : vtkImageMathematics.h
  • VTK_RESLICE_CUBIC : vtkImageReslice.h
  • VTK_RESLICE_LINEAR : vtkImageReslice.h
  • VTK_RESLICE_NEAREST : vtkImageReslice.h
  • VTK_RESOLVE_OFF : vtkMapper.h
  • VTK_RESOLVE_POLYGON_OFFSET : vtkMapper.h
  • VTK_RESOLVE_SHIFT_ZBUFFER : vtkMapper.h
  • VTK_RGB : vtkScalarsToColors.h
  • VTK_RGBA : vtkScalarsToColors.h
  • VTK_RULED_MODE_POINT_WALK : vtkRuledSurfaceFilter.h
  • VTK_RULED_MODE_RESAMPLE : vtkRuledSurfaceFilter.h
  • VTK_SCALAR_MODE_DEFAULT : vtkAbstractMapper.h
  • VTK_SCALAR_MODE_INDEX : vtkBandedPolyDataContourFilter.h
  • VTK_SCALAR_MODE_USE_CELL_DATA : vtkAbstractMapper.h
  • VTK_SCALAR_MODE_USE_CELL_FIELD_DATA : vtkAbstractMapper.h
  • VTK_SCALAR_MODE_USE_POINT_DATA : vtkAbstractMapper.h
  • VTK_SCALAR_MODE_USE_POINT_FIELD_DATA : vtkAbstractMapper.h
  • VTK_SCALAR_MODE_VALUE : vtkBandedPolyDataContourFilter.h
  • VTK_SCALAR_PER_ELEMENT : vtkEnSightReader.h
  • VTK_SCALAR_PER_MEASURED_NODE : vtkEnSightReader.h
  • VTK_SCALAR_PER_NODE : vtkEnSightReader.h
  • VTK_SCALE_BY_SCALAR : vtkGlyph3D.h
  • VTK_SCALE_BY_VECTOR : vtkGlyph3D.h
  • VTK_SCALE_BY_VECTORCOMPONENTS : vtkGlyph3D.h
  • VTK_SCALE_LINEAR : vtkLookupTable.h
  • VTK_SCALE_LOG10 : vtkLookupTable.h
  • VTK_SHORT : vtkSetGet.h
  • VTK_SHORT_MAX : vtkSetGet.h
  • VTK_SHORT_MIN : vtkSetGet.h
  • VTK_SIN : vtkImageMathematics.h
  • VTK_SINGLE_POINT : vtkStructuredData.h
  • VTK_SORT_BOUNDS_CENTER : vtkDepthSortPolyData.h
  • VTK_SORT_BY_CELL : vtkCutter.h
  • VTK_SORT_BY_VALUE : vtkCutter.h
  • VTK_SORT_FIRST_POINT : vtkDepthSortPolyData.h
  • VTK_SORT_PARAMETRIC_CENTER : vtkDepthSortPolyData.h
  • VTK_SOURCE_VERSION : vtkVersion.h
  • VTK_SQR : vtkImageMathematics.h
  • VTK_SQRT : vtkImageMathematics.h
  • VTK_SQUARE_GLYPH : vtkGlyphSource2D.h
  • VTK_STEREO_CRYSTAL_EYES : vtkRenderWindow.h
  • VTK_STEREO_DRESDEN : vtkRenderWindow.h
  • VTK_STEREO_INTERLACED : vtkRenderWindow.h
  • VTK_STEREO_LEFT : vtkRenderWindow.h
  • VTK_STEREO_RED_BLUE : vtkRenderWindow.h
  • VTK_STEREO_RIGHT : vtkRenderWindow.h
  • VTK_STRING : vtkSetGet.h
  • VTK_STRUCTURED_GRID : vtkSetGet.h
  • VTK_STRUCTURED_POINTS : vtkSetGet.h
  • VTK_STYLE_PIXELIZE : vtkImageToPolyDataFilter.h
  • VTK_STYLE_POLYGONALIZE : vtkImageToPolyDataFilter.h
  • VTK_STYLE_RUN_LENGTH : vtkImageToPolyDataFilter.h
  • VTK_SUBTRACT : vtkImageMathematics.h
  • VTK_SURFACE : vtkRender.h
  • VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_1 : vtkSynchronizedTemplates3D.h
  • VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_2 : vtkSynchronizedTemplates3D.h
  • VTK_TENSOR_MODE_COMPUTE_GRADIENT : vtkCellDerivatives.h
  • VTK_TENSOR_MODE_COMPUTE_STRAIN : vtkCellDerivatives.h
  • VTK_TENSOR_MODE_PASS_TENSORS : vtkCellDerivatives.h
  • VTK_TENSOR_SYMM_PER_ELEMENT : vtkEnSightReader.h
  • VTK_TENSOR_SYMM_PER_NODE : vtkEnSightReader.h
  • VTK_TETRA : vtkCellType.h
  • VTK_TEXT_BOTTOM : vtkTextMapper.h
  • VTK_TEXT_CENTERED : vtkTextMapper.h
  • VTK_TEXT_LEFT : vtkTextMapper.h
  • VTK_TEXT_RIGHT : vtkTextMapper.h
  • VTK_TEXT_TOP : vtkTextMapper.h
  • VTK_TEXTURE_QUALITY_16BIT : vtkTexture.h
  • VTK_TEXTURE_QUALITY_32BIT : vtkTexture.h
  • VTK_TEXTURE_QUALITY_DEFAULT : vtkTexture.h
  • VTK_TEXTURE_STYLE_FIT_IMAGE : vtkButtonSource.h
  • VTK_TEXTURE_STYLE_PROPORTIONAL : vtkButtonSource.h
  • VTK_THICKARROW_GLYPH : vtkGlyphSource2D.h
  • VTK_THICKCROSS_GLYPH : vtkGlyphSource2D.h
  • VTK_THREAD_RETURN_TYPE : vtkMultiThreader.h
  • VTK_THREAD_RETURN_VALUE : vtkMultiThreader.h
  • VTK_THREAD_SAFE_LOG_MAX : vtkThreadSafeLog.h
  • VTK_TIMES : vtkTextMapper.h
  • VTK_TK_EXPORT : vtkWin32Header.h
  • VTK_TOL : vtkCell.h
  • VTK_TRIANGLE : vtkCellType.h
  • VTK_TRIANGLE_GLYPH : vtkGlyphSource2D.h
  • VTK_TRIANGLE_STRIP : vtkCellType.h
  • VTK_UNCHANGED : vtkStructuredData.h
  • VTK_UNICAM_BUTTON_LEFT : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_BUTTON_MIDDLE : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_BUTTON_RIGHT : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_CAM_INT_CHOOSE : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_CAM_INT_DOLLY : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_CAM_INT_PAN : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_CAM_INT_ROT : vtkInteractorStyleUnicam.h
  • VTK_UNICAM_NONE : vtkInteractorStyleUnicam.h
  • VTK_UNION : vtkImplicitBoolean.h
  • VTK_UNION_OF_MAGNITUDES : vtkImplicitBoolean.h
  • VTK_UNSIGNED_CHAR : vtkSetGet.h
  • VTK_UNSIGNED_CHAR_MAX : vtkSetGet.h
  • VTK_UNSIGNED_CHAR_MIN : vtkSetGet.h
  • VTK_UNSIGNED_INT : vtkSetGet.h
  • VTK_UNSIGNED_INT_MAX : vtkSetGet.h
  • VTK_UNSIGNED_INT_MIN : vtkSetGet.h
  • VTK_UNSIGNED_LONG : vtkSetGet.h
  • VTK_UNSIGNED_LONG_MAX : vtkSetGet.h
  • VTK_UNSIGNED_LONG_MIN : vtkSetGet.h
  • VTK_UNSIGNED_SHORT : vtkSetGet.h
  • VTK_UNSIGNED_SHORT_MAX : vtkSetGet.h
  • VTK_UNSIGNED_SHORT_MIN : vtkSetGet.h
  • VTK_UNSTRUCTURED_GRID : vtkSetGet.h
  • VTK_USE_NORMAL : vtkHedgeHog.h, vtkGlyph3D.h
  • VTK_USE_VECTOR : vtkHedgeHog.h, vtkGlyph3D.h
  • VTK_USE_X_MAX : vtkReflectionFilter.h
  • VTK_USE_X_MIN : vtkReflectionFilter.h
  • VTK_USE_Y_MAX : vtkReflectionFilter.h
  • VTK_USE_Y_MIN : vtkReflectionFilter.h
  • VTK_USE_Z_MAX : vtkReflectionFilter.h
  • VTK_USE_Z_MIN : vtkReflectionFilter.h
  • VTK_USERDEFINED : vtkCoordinate.h
  • VTK_VARY_RADIUS_BY_SCALAR : vtkTubeFilter.h
  • VTK_VARY_RADIUS_BY_VECTOR : vtkTubeFilter.h
  • VTK_VARY_RADIUS_OFF : vtkTubeFilter.h
  • VTK_VECTOR_EXTRUSION : vtkLinearExtrusionFilter.h
  • VTK_VECTOR_MODE_COMPUTE_GRADIENT : vtkCellDerivatives.h
  • VTK_VECTOR_MODE_COMPUTE_VORTICITY : vtkCellDerivatives.h
  • VTK_VECTOR_MODE_PASS_VECTORS : vtkCellDerivatives.h
  • VTK_VECTOR_PER_ELEMENT : vtkEnSightReader.h
  • VTK_VECTOR_PER_MEASURED_NODE : vtkEnSightReader.h
  • VTK_VECTOR_PER_NODE : vtkEnSightReader.h
  • VTK_VECTOR_ROTATION_OFF : vtkGlyph3D.h
  • VTK_VERSION : vtkVersion.h
  • VTK_VERTEX : vtkCellType.h
  • VTK_VERTEX_GLYPH : vtkGlyphSource2D.h
  • VTK_VIEW : vtkCoordinate.h
  • VTK_VIEWPORT : vtkCoordinate.h
  • VTK_VOID : vtkSetGet.h
  • VTK_VOLUME_12BIT_LOWER : vtkVolumeProMapper.h
  • VTK_VOLUME_12BIT_UPPER : vtkVolumeProMapper.h
  • VTK_VOLUME_16BIT : vtkVolumeProVP1000Mapper.h
  • VTK_VOLUME_32BIT : vtkVolumeProVP1000Mapper.h
  • VTK_VOLUME_8BIT : vtkVolumeProMapper.h
  • VTK_VOLUMEPRO_EXPORT : vtkVolumeProVG500Mapper.h
  • VTK_VOXEL : vtkCellType.h
  • VTK_VOXEL_MODE : vtkImplicitModeller.h
  • VTK_WEDGE : vtkCellType.h
  • VTK_WHOLE_MULTI_GRID_NO_IBLANKING : vtkPLOT3DReader.h
  • VTK_WHOLE_SINGLE_GRID_NO_IBLANKING : vtkPLOT3DReader.h
  • VTK_WIREFRAME : vtkRender.h
  • VTK_WORLD : vtkCoordinate.h
  • VTK_X_LINE : vtkStructuredData.h
  • VTK_XOR : vtkImageLogic.h
  • VTK_XY_PLANE : vtkStructuredData.h
  • VTK_XYPLOT_ARC_LENGTH : vtkXYPlotActor.h
  • VTK_XYPLOT_COLUMN : vtkXYPlotActor.h
  • VTK_XYPLOT_INDEX : vtkXYPlotActor.h
  • VTK_XYPLOT_NORMALIZED_ARC_LENGTH : vtkXYPlotActor.h
  • VTK_XYPLOT_ROW : vtkXYPlotActor.h
  • VTK_XYPLOT_VALUE : vtkXYPlotActor.h
  • VTK_XYZ_GRID : vtkStructuredData.h
  • VTK_XZ_PLANE : vtkStructuredData.h
  • VTK_Y_LINE : vtkStructuredData.h
  • VTK_YZ_PLANE : vtkStructuredData.h
  • VTK_Z_LINE : vtkStructuredData.h
  • vtkBooleanMacro : vtkSetGet.h
  • vtkCritSecType : vtkCriticalSection.h
  • vtkCxxRevisionMacro : vtkSetGet.h
  • vtkCxxSetObjectMacro : vtkSetGet.h
  • vtkDebugMacro : vtkSetGet.h
  • vtkDeterminant3x3() : vtkMath.h
  • vtkErrorMacro : vtkSetGet.h
  • vtkErrorWithObjectMacro : vtkSetGet.h
  • vtkFloorFuncMacro : vtkVolumeRayCastMapper.h
  • vtkGenericWarningMacro : vtkSetGet.h
  • vtkGetMacro : vtkSetGet.h
  • vtkGetObjectMacro : vtkSetGet.h
  • vtkGetStringMacro : vtkSetGet.h
  • vtkGetVector2Macro : vtkSetGet.h
  • vtkGetVector3Macro : vtkSetGet.h
  • vtkGetVector4Macro : vtkSetGet.h
  • vtkGetVector6Macro : vtkSetGet.h
  • vtkGetVectorMacro : vtkSetGet.h
  • vtkgluPickMatrix() : vtkgluPickMatrix.h
  • VTKI_TIMER_FIRST : vtkRenderWindowInteractor.h
  • VTKI_TIMER_UPDATE : vtkRenderWindowInteractor.h
  • vtkIdType : vtkSystemIncludes.h
  • vtkImage2DIslandPixel : vtkImageIslandRemoval2D.h
  • vtkImageComplex : vtkImageFourierFilter.h
  • vtkImageComplexAdd : vtkImageFourierFilter.h
  • vtkImageComplexConjugate : vtkImageFourierFilter.h
  • vtkImageComplexEuclidSet : vtkImageFourierFilter.h
  • vtkImageComplexExponential : vtkImageFourierFilter.h
  • vtkImageComplexMultiply : vtkImageFourierFilter.h
  • vtkImageComplexPolarSet : vtkImageFourierFilter.h
  • vtkImageComplexPrint : vtkImageFourierFilter.h
  • vtkImageComplexScale : vtkImageFourierFilter.h
  • vtkImageComplexSubtract : vtkImageFourierFilter.h
  • vtkImageScalarTypeNameMacro : vtkSetGet.h
  • vtkInstantiatorInitializer : vtkInstantiator.h
  • VTKIS_ACTOR : vtkInteractorStyleTrackball.h, vtkInteractorStyleSwitch.h
  • VTKIS_ANIM_OFF : vtkInteractorStyle.h
  • VTKIS_ANIM_ON : vtkInteractorStyle.h
  • VTKIS_CAMERA : vtkInteractorStyleTrackball.h, vtkInteractorStyleSwitch.h
  • VTKIS_CONTROL_OFF : vtkInteractorStyleTrackball.h
  • VTKIS_CONTROL_ON : vtkInteractorStyleTrackball.h
  • VTKIS_DOLLY : vtkInteractorStyle.h
  • VTKIS_JOY : vtkInteractorStyleTrackball.h
  • VTKIS_JOYSTICK : vtkInteractorStyleSwitch.h
  • VTKIS_PAN : vtkInteractorStyle.h
  • VTKIS_ROTATE : vtkInteractorStyle.h
  • VTKIS_SPIN : vtkInteractorStyle.h
  • VTKIS_START : vtkInteractorStyle.h
  • VTKIS_TIMER : vtkInteractorStyle.h
  • VTKIS_TRACK : vtkInteractorStyleTrackball.h
  • VTKIS_TRACKBALL : vtkInteractorStyleSwitch.h
  • VTKIS_USCALE : vtkInteractorStyle.h
  • VTKIS_USERINTERACTION : vtkInteractorStyleUser.h
  • VTKIS_ZOOM : vtkInteractorStyle.h
  • vtkJavaCreateNewJavaStub() : vtkJavaUtil.h
  • vtkJavaCreateNewJavaStubForObject() : vtkJavaUtil.h
  • vtkJavaDeleteObject() : vtkJavaUtil.h
  • vtkJavaGetId() : vtkJavaUtil.h
  • vtkJavaGetObjectFromPointer() : vtkJavaUtil.h
  • vtkJavaGetPointerFromObject() : vtkJavaUtil.h
  • vtkJavaMakeJArrayOfByteFromUnsignedChar() : vtkJavaUtil.h
  • vtkJavaMakeJArrayOfDoubleFromDouble() : vtkJavaUtil.h
  • vtkJavaMakeJArrayOfDoubleFromFloat() : vtkJavaUtil.h
  • vtkJavaMakeJArrayOfIntFromInt() : vtkJavaUtil.h
  • vtkJavaMakeJavaString() : vtkJavaUtil.h
  • vtkJavaRegisterCastFunction() : vtkJavaUtil.h
  • vtkJavaRegisterNewObject() : vtkJavaUtil.h
  • vtkJavaUTFToChar() : vtkJavaUtil.h
  • vtkJavaVoidFunc() : vtkJavaUtil.h
  • vtkJavaVoidFuncArgDelete() : vtkJavaUtil.h
  • vtkLibHandle : vtkDynamicLoader.h
  • vtkLoad() : vtkKitwareObjectFactory.h, vtkParallelFactory.h
  • vtkLocalTri : vtkDecimate.h
  • vtkLocalTriPtr : vtkDecimate.h
  • vtkLocalVertex : vtkDecimate.h
  • vtkLocalVertexPtr : vtkDecimate.h
  • vtkMutexType : vtkMutexLock.h
  • vtknewfunc : vtkPythonUtil.h
  • vtkNotUsed : vtkSetGet.h
  • vtkOpenGLCall_glAlphaFunc : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glBegin : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glBindTexture : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glBlendFunc : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glCallList : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glClear : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glClearColor : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glClearDepth : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glClipPlane : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glColor3f : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glColor4fv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glColor4ubv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glColorMaterial : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glCullFace : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDeleteLists : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDeleteTextures : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDepthFunc : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDepthMask : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDepthRange : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDisable : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDrawBuffer : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glDrawPixels : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glEnable : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glEnd : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glEndList : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glGenLists : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glGenTextures : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glGetIntegerv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glInitNames : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glIsList : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glIsTexture : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLightf : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLightfv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLighti : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLightModelfv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLightModeli : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLineStipple : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLineWidth : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLoadIdentity : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLoadMatrixd : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glLoadName : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glMaterialfv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glMatrixMode : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glMultMatrixd : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glNewList : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glNormal3fv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPixelStorei : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPointSize : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPolygonOffset : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPopMatrix : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPushMatrix : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glPushName : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glRasterPos2f : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glRasterPos3f : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glReadBuffer : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glReadPixels : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glRenderMode : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glScissor : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glSelectBuffer : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glShadeModel : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glTexCoord2fv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glTexEnvf : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glTexImage2D : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glTexParameterf : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glVertex3fv : vtkOpenGLStateCache.h
  • vtkOpenGLCall_glViewport : vtkOpenGLStateCache.h
  • vtkOutputWindow : vtkOutputWindow.h
  • vtkOutputWindowDisplayDebugText() : vtkSetGet.h
  • vtkOutputWindowDisplayErrorText() : vtkSetGet.h
  • vtkOutputWindowDisplayGenericWarningText() : vtkSetGet.h
  • vtkOutputWindowDisplayText() : vtkSetGet.h
  • vtkOutputWindowDisplayWarningText() : vtkSetGet.h
  • vtkPriorityItem : vtkPriorityQueue.h
  • vtkProcessFunctionType : vtkMultiProcessController.h
  • vtkProLocalTri : vtkDecimatePro.h
  • vtkProLocalTriPtr : vtkDecimatePro.h
  • vtkProLocalVertex : vtkDecimatePro.h
  • vtkProLocalVertexPtr : vtkDecimatePro.h
  • vtkPythonAddClassToHash() : vtkPythonUtil.h
  • vtkPythonAddObjectToHash() : vtkPythonUtil.h
  • vtkPythonCheckArray() : vtkPythonUtil.h
  • vtkPythonDeleteObjectFromHash() : vtkPythonUtil.h
  • vtkPythonGetObjectFromObject() : vtkPythonUtil.h
  • vtkPythonGetObjectFromPointer() : vtkPythonUtil.h
  • vtkPythonGetPointerFromObject() : vtkPythonUtil.h
  • vtkPythonManglePointer() : vtkPythonUtil.h
  • vtkPythonUnmanglePointer() : vtkPythonUtil.h
  • vtkPythonVoidFunc() : vtkPythonUtil.h
  • vtkPythonVoidFuncArgDelete() : vtkPythonUtil.h
  • vtkRMIFunctionType : vtkMultiProcessController.h
  • vtkRoundFuncMacro : vtkVolumeRayCastMapper.h
  • vtkSetClampMacro : vtkSetGet.h
  • vtkSetMacro : vtkSetGet.h
  • vtkSetObjectBodyMacro : vtkSetGet.h
  • vtkSetObjectImplementationMacro : vtkSetGet.h
  • vtkSetObjectMacro : vtkSetGet.h
  • vtkSetStringMacro : vtkSetGet.h
  • vtkSetVector2Macro : vtkSetGet.h
  • vtkSetVector3Macro : vtkSetGet.h
  • vtkSetVector4Macro : vtkSetGet.h
  • vtkSetVector6Macro : vtkSetGet.h
  • vtkSetVectorMacro : vtkSetGet.h
  • vtkStandardNewMacro : vtkSetGet.h
  • vtkStreamPoint : vtkStreamer.h
  • vtkSwap4 : vtkSocketCommunicator.h
  • vtkSwap4Range : vtkSocketCommunicator.h
  • vtkSwap8 : vtkSocketCommunicator.h
  • vtkSwap8Range : vtkSocketCommunicator.h
  • VTKTCL_EXPORT : vtkTclUtil.h
  • vtkTclCreateNew() : vtkTclUtil.h
  • vtkTclDeleteCommandStruct() : vtkTclUtil.h
  • vtkTclDeleteObjectFromHash() : vtkTclUtil.h
  • vtkTclGenericDeleteObject() : vtkTclUtil.h
  • vtkTclGetObjectFromPointer() : vtkTclUtil.h
  • vtkTclGetPointerFromObject() : vtkTclUtil.h
  • vtkTclInDelete() : vtkTclUtil.h
  • vtkTclListInstances() : vtkTclUtil.h
  • vtkTclNewInstanceCommand() : vtkTclUtil.h
  • vtkTclVoidFunc() : vtkTclUtil.h
  • vtkTclVoidFuncArg : vtkTclUtil.h
  • vtkTclVoidFuncArgDelete() : vtkTclUtil.h
  • vtkTemplateMacro10 : vtkSetGet.h
  • vtkTemplateMacro3 : vtkSetGet.h
  • vtkTemplateMacro4 : vtkSetGet.h
  • vtkTemplateMacro5 : vtkSetGet.h
  • vtkTemplateMacro6 : vtkSetGet.h
  • vtkTemplateMacro7 : vtkSetGet.h
  • vtkTemplateMacro8 : vtkSetGet.h
  • vtkTemplateMacro9 : vtkSetGet.h
  • vtkThreadFunctionType : vtkMultiThreader.h
  • vtkThreadProcessIDType : vtkMultiThreader.h
  • vtkTimerLogMacro : vtkTimerLog.h
  • vtkTrilinFuncMacro : vtkVolumeRayCastMapper.h
  • vtkTypeMacro : vtkSetGet.h
  • vtkTypeRevisionMacro : vtkSetGet.h
  • vtkViewportCoordinateMacro : vtkSetGet.h
  • vtkWarningMacro : vtkSetGet.h
  • vtkWarningWithObjectMacro : vtkSetGet.h
  • vtkWorldCoordinateMacro : vtkSetGet.h

- w -
  • windowShouldZoom : vtkQuartzWindow.h
  • windowWillResize : vtkQuartzWindow.h
  • word : vtk3DS.h
Generated on Mon Mar 25 01:37:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Page Index

VTK Related Pages

Here is a list of all related documentation pages:
  • Contributors
  • Class To Examples (3..L)
  • Class To Examples (M..R)
  • Class To Examples (S..X)
  • Class To Tests (3..B)
  • Class To Tests (C)
  • Class To Tests (D..F)
  • Class To Tests (G..H)
  • Class To Tests (I)
  • Class To Tests (J..O)
  • Class To Tests (P)
  • Class To Tests (Q..R)
  • Class To Tests (S)
  • Class To Tests (T)
  • Class To Tests (U..X)
  • Class to Events (I..X)
  • Event to Classes (A..W)
  • Full-text Index (A..b)
  • Full-text Index (c..e)
  • Full-text Index (f..l)
  • Full-text Index (m..q)
  • Full-text Index (r..s)
  • Full-text Index (t..z)
Generated on Mon Mar 25 01:37:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Contributors
  • 38 authors(s) reported
  • Files matching (?:^hints|^README|\.(?:c|cmake|cpp|cxx|h|html|in|java|mm|pl|py|tcl|txt))$ and not matching (?:^vtkVersion\.\w+|^pkgIndex\.tcl|^vtkParse\.tab\.c|\.yy\.c)$ are taken into account
  • 44970 CVS revision(s) processed from 2152 matching file(s)
  • 26836 revision(s) kept (18134 revision(s) removed from 'massive commits' > 200 changes per date/author/message)
  • revision's contribution is 1.0 * (number of lines added) + 0.5 * (number of lines removed)
  • 787 class(es) found (matching ^(vtk[A-Z0-9][A-Za-z0-9]+)\.(?:c|cpp|cxx|h|mm)$)
Version:
0.7
Author:
doc_contributors.pl, by Sebastien Barre

Contributors (by alphabetical order)

  • Alyassin, Majeid
  • Avila, Lisa
  • Avila, Rick
  • Barre, Sebastien
  • Biddiscombe, John
  • Blezek, Dan
  • Blue, Rusty
  • Bruno, Jeannette
  • Cedilnik, Andy
  • Childs, Hank
  • Citrini, Tom
  • Davis, Jon
  • Geveci, Berk
  • Gobbi, David
  • Halle, Michael
  • Hammond, Rich
  • Henderson, Amy
  • Hoffman, Bill
  • Hutton, Tim
  • Kelly, Ann
  • King, Brad
  • Law, Charles
  • Lee, Jeff
  • Lorensen, Bill
  • Martin, Ken
  • Miller, Jim
  • Montanaro, Skip
  • Pan, Tony
  • Paulsen, Rasmus Reinhold
  • Ramachandran, Prabhu
  • Schroeder, Will
  • Slack, Christopher
  • Starreveld, Yves
  • Turek, Matt
  • Turner, Wes
  • Volpe, Christopher
  • Warfield, Simon
  • Yamrom, Boris

Contributors (by decreasing order of global contribution)

Note:
Contributions lower than 0.01% are not listed

  1. Schroeder, Will
  2. Martin, Ken
  3. Law, Charles
  4. Lorensen, Bill
  5. Gobbi, David
  6. Avila, Lisa
  7. Geveci, Berk
  8. Henderson, Amy
  9. Hoffman, Bill
  10. Miller, Jim
  11. Barre, Sebastien
  12. Kelly, Ann
  13. Biddiscombe, John
  14. Citrini, Tom
  15. Lee, Jeff
  16. Starreveld, Yves
  17. Pan, Tony
  18. Cedilnik, Andy
  19. Blue, Rusty
  20. Halle, Michael
  21. Blezek, Dan
  22. Turek, Matt
  23. King, Brad
  24. Hutton, Tim
  25. Volpe, Christopher
  26. Davis, Jon
  27. Warfield, Simon
  28. Yamrom, Boris
  29. Alyassin, Majeid
  30. Childs, Hank
  31. Paulsen, Rasmus Reinhold
  32. Ramachandran, Prabhu
  33. Turner, Wes
  34. Slack, Christopher

Detailed contributions (by decreasing order)

Note:
Contributions lower than 0.01% are not listed
Note:
Details are:
  • % of global contribution at 2002/03/25, % at date of last contribution, % at date of first contribution
  • first 10 contributed classes > 2% of author's total contribution
  • first 5 contributed (non-class) files > 1% of author's total contribution
  1. Schroeder, Will (will):
    • 24.38% (2002/03/25), 24.46% (2002/03/18), 0.91% (1994/01/06)
    • 525 class(es): ...
    • 107 file(s): ...
  2. Martin, Ken (martink):
    • 22.13% (2002/03/25), 22.19% (2002/03/19), 100% (1994/01/05)
    • 735 class(es): vtkVectorText (13%), vtkEarthSource (3%)...
    • 215 file(s): ...
  3. Law, Charles (lawcc):
    • 11.13% (2002/03/25), 11.17% (2002/03/19), 0.04% (1996/05/28)
    • 477 class(es): vtkImageData (4%), vtkSynchronizedTemplates3D (2%)...
    • 32 file(s): ...
  4. Lorensen, Bill (lorensen):
    • 7.18% (2002/03/25), 7.26% (2002/02/16), 7.57% (1994/02/22)
    • 571 class(es): vtkVRMLImporter (8%), vtk3DSImporter (2%)...
    • 138 file(s): /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl (5%), /Common/Testing/Cxx/otherArrays.cxx (1%), /Common/Testing/Tcl/PrintSelfCheck.tcl (1%)...
  5. Gobbi, David (dgobbi):
    • 6.53% (2002/03/25), 6.59% (2002/02/27), 0.1% (1999/03/30)
    • 135 class(es): vtkImageReslice (10%), vtkGeneralTransform (6%), vtkPythonUtil (5%), vtkThinPlateSplineTransform (4%), vtkVideoSource (3%), vtkTransform (3%), vtkCamera (2%), vtkWin32VideoSource (2%), vtkGridTransform (2%), vtkMILVideoSource (2%), vtkPerspectiveTransform (2%)...
    • 46 file(s): /Wrapping/Python/wxVTKRenderWindow.py (1%)...
  6. Avila, Lisa (avila):
    • 5.39% (2002/03/25), 5.39% (2002/03/22), 0.02% (1996/06/06)
    • 281 class(es): vtkVolumeRayCastMapper (13%), vtkVolumeTextureMapper2D (7%), vtkVolumeRayCastCompositeFunction (7%), vtkRayCaster (6%), vtkRenderer (3%), vtkColorTransferFunction (3%), vtkVolume (3%), vtkVolumeProMapper (3%), vtkVolumeProperty (2%), vtkLODProp3D (2%)...
    • 28 file(s): ...
  7. Geveci, Berk (berk):
    • 5.17% (2002/03/25), 5.22% (2002/02/28), 0% (2000/09/05)
    • 346 class(es): vtkWin32OpenGLRenderWindow (10%), vtkDataSetAttributes (6%), vtkSynchronizedTemplates3D (3%), vtkMPICommunicator (2%), vtkFieldData (2%), vtkSocketCommunicator (2%), vtkDataArray (2%)...
    • 146 file(s): ...
  8. Henderson, Amy (henderson):
    • 4.85% (2002/03/25), 4.9% (2002/02/27), 0.13% (2000/06/28)
    • 300 class(es): vtkEnSight6Reader (11%), vtkEnSightGoldReader (10%), vtkEnSightGoldBinaryReader (7%), vtkEnSight6BinaryReader (6%), vtkEnSightReader (6%), vtkFunctionParser (4%), vtkVolumeProVP1000Mapper (4%), vtkGenericEnSightReader (2%), vtkQuadricClustering (2%), vtkQuadricDecimation (2%), vtkArrayCalculator (2%)...
    • 24 file(s): ...
  9. Hoffman, Bill (hoffman):
    • 2.34% (2002/03/25), 2.34% (2002/03/22), 0.19% (1999/10/05)
    • 174 class(es): vtkMesaPolyDataMapper (5%), vtkCompositeManager (5%), vtkObjectFactory (5%), vtkPOPReader (4%), vtkVolumeProVG500Mapper (4%), vtkPDataSetReader (3%), vtkXMesaRenderWindow (2%), vtkTreeComposite (2%), vtkVolumeProMapper (2%), vtkXOpenGLRenderWindow (2%), vtkDebugLeaks (2%)...
    • 41 file(s): /README.html (1%)...
  10. Miller, Jim (millerjv):
    • 2.21% (2002/03/25), 2.24% (2002/02/13), 0.01% (1997/10/16)
    • 273 class(es): vtkCellLocator (6%), vtkXRenderWindowTclInteractor (5%), vtkWin32ImageMapper (4%), vtkWindowedSincPolyDataFilter (4%)...
    • 32 file(s): /Graphics/Testing/Tcl/contourCells.tcl (3%), /Hybrid/Testing/Tcl/camera.tcl (1%)...
  11. Barre, Sebastien (barre):
    • 1.88% (2002/03/25), 1.89% (2002/03/22), 0.01% (2000/07/31)
    • 49 class(es): vtkIterativeClosestPointTransform (4%), vtkImageBlend (3%)...
    • 136 file(s): /Utilities/Doxygen/doc_contributors.pl (9%), /Utilities/Doxygen/doc_class2example.pl (7%), /Utilities/Doxygen/doc_index.pl (5%), /Utilities/Doxygen/doc_header2doxygen.pl (5%), /Utilities/Doxygen/doc_readme.txt (3%), /Wrapping/Tcl/vtkinteraction/TkInteractor.tcl (3%)...
  12. Kelly, Ann (kellyae):
    • 0.85% (2002/03/25), 2.25% (1998/09/18), 0% (1998/03/23)
    • 318 class(es): vtkTransform (2%), vtkPolyData (2%)...
  13. Biddiscombe, John (biddi):
    • 0.7% (2002/03/25), 0.72% (2002/01/10), 0.1% (2000/02/23)
    • 89 class(es): vtkInteractorStyleFlight (10%), vtkWin32ImageMapper (10%), vtkCleanPolyData (9%), vtkAppendPolyData (6%), vtkPlanes (5%), vtkImageMapper (3%), vtkAbstractMapper (3%), vtkOpenGLImageMapper (3%), vtkFrustumCoverageCuller (3%), vtkQuantizePolyDataPoints (2%), vtkOpenGLPolyDataMapper2D (2%)...
    • 13 file(s): /Graphics/Testing/Cxx/FrustumClip.cxx (1%)...
  14. Citrini, Tom (citrit):
    • 0.69% (2002/03/25), 1.12% (2000/07/06), 1.12% (2000/06/28)
    • 2 class(es): vtkVRMLImporter (91%), vtkVRML (8%)...
  15. Lee, Jeff (jlee):
    • 0.59% (2002/03/25), 0.59% (2002/03/20), 0.22% (2001/03/15)
    • 29 class(es): vtkXYPlotActor (35%), vtkByteSwap (14%), vtkMaskFields (12%), vtkUnstructuredGrid (7%), vtkAxisActor2D (5%), vtkCellTypes (2%), vtkJavaAwt (2%), vtkSocketCommunicator (2%)...
    • 3 file(s): /Wrapping/Java/vtkPanel.java (5%), /Wrapping/Java/SimpleVTK.java (1%)...
  16. Starreveld, Yves (starreveld):
    • 0.54% (2002/03/25), 0.55% (2002/01/17), 0.01% (2001/03/30)
    • 30 class(es): vtkQuartzRenderWindow (27%), vtkQuartzImageWindow (16%), vtkQuartzRenderWindowInteractor (13%), vtkQuartzTextMapper (7%), vtkQuartzGLView (5%), vtkImageAccumulate (5%), vtkQuartzWindow (2%), vtkTkImageViewerWidget (2%), vtkTkRenderWidget (2%), vtkTkImageWindowWidget (2%)...
    • 15 file(s): /Rendering/CMakeLists.txt (1%)...
  17. Pan, Tony (tpan):
    • 0.5% (2002/03/25), 1.05% (1999/07/09), 0.58% (1998/10/24)
    • 6 class(es): vtkRenderWindowInteractor (39%), vtkWin32RenderWindowInteractor (28%), vtkXRenderWindowInteractor (24%), vtkMath (4%)...
  18. Cedilnik, Andy (andy):
    • 0.41% (2002/03/25), 0.41% (2002/03/25), 0% (2001/11/05)
    • 87 class(es): vtkTIFFReader (23%), vtkRIBExporter (12%), vtkSetGet (5%), vtkErrorCode (4%), vtkAbstractList (3%), vtkContainer (3%), vtkCubeAxesActor2D (2%)...
    • 30 file(s): /Common/Testing/Cxx/TestImageIterator.cxx (2%), /Common/CMakeLists.txt (1%), /Common/Testing/Cxx/TestContainers.cxx (1%)...
  19. Blue, Rusty (blue):
    • 0.4% (2002/03/25), 0.42% (2001/12/18), 0.02% (1997/04/25)
    • 31 class(es): vtkCellLocator (34%), vtkImplicitModeller (19%), vtkPointLocator (11%), vtkDecimatePro (5%), vtkByteSwap (3%), vtkOBBTree (3%), vtkTransform (3%), vtkDecimate (3%), vtkSweptSurface (2%), vtkMatrix4x4 (2%)...
  20. Halle, Michael (halazar):
    • 0.33% (2002/03/25), 0.33% (2002/03/11), 0% (2000/07/31)
    • 17 class(es): vtkWeightedTransformFilter (33%), vtkLightKit (20%), vtkLight (10%), vtkImplicitSum (10%), vtkPerlinNoise (8%), vtkCamera (4%), vtkRenderer (3%)...
    • 6 file(s): /Examples/Modelling/Tcl/PerlinTerrain.tcl (2%), /Filtering/Testing/Tcl/ImplicitSum.tcl (1%), /Filtering/Testing/Tcl/PerlinNoise.tcl (1%)...
  21. Blezek, Dan (blezek):
    • 0.29% (2002/03/25), 0.29% (2002/02/13), 0% (1999/11/10)
    • 27 class(es): vtkPolyLine (32%), vtkImageSeparableConvolution (24%), vtkTkImageViewerWidget (5%), vtkImageThreshold (3%), vtkTkImageWindowWidget (3%), vtkXImageWindow (3%), vtkImageMask (2%), vtkTkRenderWidget (2%)...
    • 21 file(s): /Graphics/Testing/Tcl/FitEllipse.tcl (3%), /Wrapping/Tcl/vtkbase/vtkbase.tcl (2%), /Imaging/Testing/Tcl/TestSeparableFilter.tcl (1%)...
  22. Turek, Matt (turek):
    • 0.26% (2002/03/25), 0.32% (2001/07/31), 0% (1997/05/29)
    • 32 class(es): vtkActor2DCollection (21%), vtkActor2D (19%), vtkProperty2D (13%), vtkFileOutputWindow (8%), vtkMapper2D (7%), vtkViewport (7%), vtkLODProp3D (6%), vtkRenderer (2%)...
  23. King, Brad (king):
    • 0.25% (2002/03/25), 0.25% (2002/03/19), 0% (2001/07/10)
    • 44 class(es): vtkInstantiator (21%), vtkImageImport (15%), vtkXMLParser (14%), vtkImageExport (12%), vtkObjectFactoryCollection (2%), vtkCuller (2%)...
    • 19 file(s): /CMakeLists.txt (2%), /Rendering/CMakeLists.txt (1%), /Wrapping/Tcl/tkAppInit.cxx.in (1%), /Common/CMakeLists.txt (1%)...
  24. Hutton, Tim (timh):
    • 0.16% (2002/03/25), 0.17% (2002/02/13), 0.1% (2000/03/07)
    • 4 class(es): vtkProcrustesAlignmentFilter (38%), vtkLandmarkTransform (34%), vtkPCAAnalysisFilter (3%), vtkOpenGLTexture (2%)...
    • 4 file(s): /Examples/Modelling/Tcl/procrustesAlignment.tcl (11%), /Hybrid/Testing/Tcl/TestProcrustes.tcl (8%)...
  25. Volpe, Christopher (volpe):
    • 0.11% (2002/03/25), 0.11% (2002/02/07), 0.12% (1999/08/27)
    • 13 class(es): vtkTransform (32%), vtkCriticalSection (26%), vtkMatrix4x4 (20%), vtkTubeFilter (10%), vtkStreamer (3%)...
  26. Davis, Jon (davisje):
    • 0.09% (2002/03/25), 0.14% (2000/11/30), 0.01% (2000/09/19)
    • 9 class(es): vtkPythonUtil (51%), vtkInteractorStyleFlight (26%), vtkPolyData (9%), vtkAppendFilter (4%), vtkSelectVisiblePoints (2%)...
  27. Warfield, Simon (warfield):
    • 0.08% (2002/03/25), 0.09% (2002/02/02), 0.18% (1999/06/18)
    • 2 class(es): vtkOBBTree (99%)...
  28. Yamrom, Boris (yamrom):
    • 0.07% (2002/03/25), 0.1% (2001/05/04), 0% (1997/01/14)
    • 37 class(es): vtkMath (32%), vtkImageMapper (16%), vtkVRMLExporter (12%), vtkWin32ImageMapper (7%), vtkSubPixelPositionEdgels (4%), vtkImagePermute (2%), vtkImageToStructuredPoints (2%)...
  29. Alyassin, Majeid (alyassin):
    • 0.07% (2002/03/25), 0.19% (1998/10/05), 0.15% (1997/01/27)
    • 3 class(es): vtkMassProperties (53%), vtkImageCast (40%), vtkImageMathematics (6%)...
  30. Childs, Hank (childs):
    • 0.06% (2002/03/25), 0.08% (2001/04/25), 0% (2000/07/12)
    • 18 class(es): vtkRenderWindow (31%), vtkRenderer (16%), vtkRendererCollection (14%), vtkInteractorStyle (6%), vtkOpenGLRenderer (5%), vtkXRenderWindowInteractor (5%), vtkScalarBarActor (4%), vtkRectilinearGrid (3%), vtkOpenGLPolyDataMapper (2%), vtkOpenGLCamera (2%)...
  31. Paulsen, Rasmus Reinhold (paulsen):
    • 0.06% (2002/03/25), 0.06% (2002/02/13), 0.06% (2002/02/12)
    • 1 class(es): vtkPCAAnalysisFilter (99%)...
    • 1 file(s): ...
  32. Ramachandran, Prabhu (prabhu):
    • 0.05% (2002/03/25), 0.05% (2002/03/14), 0% (2001/04/11)
    • 8 class(es): vtkDataReader (7%), vtkInteractorStyleTrackballActor (6%), vtkGlyphSource2D (6%), vtkInteractorStyleTrackballCamera (5%), vtkSetGet (3%), vtkInteractorStyleJoystickActor (2%)...
    • 18 file(s): /Wrapping/Python/vtk/README.txt (17%), /Wrapping/Python/vtk/__init__.py (7%), /Wrapping/Python/QVTKRenderWidget.py (5%), /Wrapping/Python/wxVTKRenderWindow.py (5%), /Wrapping/Python/vtkTkRenderWidget.py (4%), /Wrapping/Python/vtkLoadPythonTkWidgets.py (3%)...
  33. Turner, Wes (turner):
    • 0.05% (2002/03/25), 0.05% (2002/03/01), 0% (2001/02/21)
    • 28 class(es): vtkLODProp3D (35%), vtkSTLReader (18%), vtkVRMLImporter (5%), vtkPicker (4%)...
  34. Slack, Christopher (slack):
    • 0.01% (2002/03/25), 0.02% (1999/02/11), 0% (1998/07/29)
    • 2 class(es): vtkXImageWindow (84%), vtkCubeSource (15%)...
Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Examples (3..L)
  • 202 class(es) in 120 file(s) from directories matching ^Examples$ on Mon Mar 25 01:05:29 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

3
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtk3DSImporter
  • Tcl
    • /Examples/IO/Tcl/flamingo.tcl
    • /Examples/Rendering/Tcl/RenderLargeImage.tcl

A
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkActor
  • C++
    • /Examples/Build/vtkMy/Examples/Cxx/Ex2/vtkmyEx2.cxx
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
    • /Examples/GUI/Win32/SampleMFC/SampleDoc.cpp
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/Rendering/Cxx/Cylinder.cxx
    • /Examples/Tutorial/Step1/Cxx/Cone.cxx
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
  • Java
    • /Examples/Tutorial/Step1/Java/Cone.java
    • /Examples/Tutorial/Step2/Java/Cone2.java
  • Python
    • /Examples/Tutorial/Step1/Python/Cone.py
    • /Examples/Tutorial/Step2/Python/Cone2.py
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Build/vtkMy/Examples/Tcl/vtkmyEx2.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/SpherePuzzle.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
vtkActor2D
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleDoc.cpp
  • Tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
vtkAppendPolyData
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/VisualizationAlgorithms/Tcl/DepthSort.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkArrayCalculator
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkAssembly
  • Tcl
    • /Examples/Rendering/Tcl/assembly.tcl
vtkAssignAttribute
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkAxes
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl

B
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkBMPReader
  • Tcl
    • /Examples/Rendering/Tcl/TPlane.tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
vtkBYUReader
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkBandedPolyDataContourFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl

C
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkCamera
  • C++
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
    • /Examples/Modelling/Tcl/hello.tcl
    • /Examples/Rendering/Tcl/assembly.tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/DepthSort.tcl
    • /Examples/VisualizationAlgorithms/Tcl/deciFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/smoothFran.tcl
vtkCardinalSpline
  • Tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
vtkCastToConcrete
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkCellArray
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/Rendering/Tcl/keyBottle.tcl
vtkCellCenters
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
vtkCellPicker
  • Tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
vtkClipPolyData
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
vtkColorTransferFunction
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkCone
  • Tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
vtkConeSource
  • C++
    • /Examples/Build/vtkMy/Examples/Cxx/Ex2/vtkmyEx2.cxx
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Tutorial/Step1/Cxx/Cone.cxx
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
  • Java
    • /Examples/Tutorial/Step1/Java/Cone.java
    • /Examples/Tutorial/Step2/Java/Cone2.java
  • Python
    • /Examples/Tutorial/Step1/Python/Cone.py
    • /Examples/Tutorial/Step2/Python/Cone2.py
  • Tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Build/vtkMy/Examples/Tcl/vtkmyEx2.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
    • /Examples/Rendering/Tcl/assembly.tcl
    • /Examples/Tutorial/Step1/Tcl/Cone.tcl
    • /Examples/Tutorial/Step2/Tcl/Cone2.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
vtkConnectivityFilter
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
vtkContourFilter
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/hello.tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
    • /Examples/Modelling/Tcl/reconstructSurface.tcl
    • /Examples/ParallelProcessing/MPI/Tcl/PVTKDemo.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ColorIsosurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/VisQuad.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
vtkCoordinate
  • Tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
vtkCubeAxesActor2D
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
vtkCubeSource
  • Tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Rendering/Tcl/assembly.tcl
vtkCutter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/CutCombustor.tcl
vtkCylinderSource
  • C++
    • /Examples/Rendering/Cxx/Cylinder.cxx
  • Tcl
    • /Examples/Rendering/Tcl/Cylinder.tcl
    • /Examples/Rendering/Tcl/assembly.tcl

D
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkDEMReader
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
vtkDataObjectToDataSetFilter
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkDataSet
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
vtkDataSetAttributes
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
vtkDataSetMapper
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleDoc.cpp
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/SubsampleGrid.tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
vtkDataSetReader
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleDoc.cpp
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
vtkDecimatePro
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/deciFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/smoothFran.tcl
vtkDelaunay2D
  • Tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
vtkDelaunay3D
  • Tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
vtkDepthSortPolyData
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/DepthSort.tcl
vtkDoubleArray
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl

E
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkElevationFilter
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
  • Tcl
    • /Examples/ParallelProcessing/MPI/Tcl/PVTKDemo.tcl
vtkExtractEdges
  • Tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
vtkExtractGeometry
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
vtkExtractGrid
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/SubsampleGrid.tcl
vtkExtractUnstructuredGrid
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
vtkExtractVOI
  • Tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl

F
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkFeatureEdges
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkFloatArray
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Modelling/Tcl/expCos.tcl
vtkFollower
  • Tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl

G
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkGaussianSplatter
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkGeometryFilter
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
vtkGlyph3D
  • C++
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
  • Tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
vtkGlyphSource2D
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx

H
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkHedgeHog
  • C++
    • /Examples/DataManipulation/Cxx/SGrid.cxx
vtkHexahedron
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl

I
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkIdFilter
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
vtkIdList
  • Tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
vtkImageAccumulate
  • Tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
vtkImageActor
  • Tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
vtkImageCanvasSource2D
  • Tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
vtkImageClip
  • Tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
vtkImageData
  • C++
    • /Examples/Build/vtkMy/Imaging/vtkImageFoo.cxx
vtkImageDataGeometryFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
vtkImageGradient
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
vtkImageGradientMagnitude
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
vtkImageLuminance
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
vtkImageMandelbrotSource
  • Tcl
    • /Examples/ImageProcessing/Tcl/MandelbrotViewer.tcl
vtkImageMapToRGBA
  • Tcl
    • /Examples/ImageProcessing/Tcl/MandelbrotViewer.tcl
vtkImageReader
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
  • Tcl
    • /Examples/ImageProcessing/Tcl/Histogram.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
vtkImageReader2Factory
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkImageShiftScale
  • Tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
vtkImageShrink3D
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
vtkImageToImageFilter
  • C++
    • /Examples/Build/vtkMy/Imaging/vtkImageFoo.cxx
vtkImageViewer
  • Tcl
    • /Examples/ImageProcessing/Tcl/Histogram.tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
    • /Examples/ImageProcessing/Tcl/MandelbrotViewer.tcl
vtkImplicitBoolean
  • Tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
vtkImplicitModeller
  • Tcl
    • /Examples/Modelling/Tcl/hello.tcl
vtkImplicitSum
  • Tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
vtkIndent
  • C++
    • /Examples/Build/vtkMy/Imaging/vtkImageFoo.cxx
vtkInputPort
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
vtkIntArray
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkInteractorStyleImage
  • Tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl

K
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkKochanekSpline
  • Tcl
    • /Examples/Rendering/Tcl/KeyFrame.tcl

L
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkLODActor
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/Rendering/Tcl/CADPart.tcl
    • /Examples/Rendering/Tcl/FilterCADPart.tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ColorIsosurface.tcl
vtkLODProp3D
  • Tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkLabeledDataMapper
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
vtkLight
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
vtkLine
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkLineSource
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl
vtkLookupTable
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/ImageProcessing/Tcl/MandelbrotViewer.tcl
    • /Examples/Rendering/Tcl/rainbow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Examples (M..R)
  • 202 class(es) in 120 file(s) from directories matching ^Examples$ on Mon Mar 25 01:05:29 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

M
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkMPIController
  • Tcl
    • /Examples/ParallelProcessing/MPI/Tcl/PVTKDemo.tcl
vtkMaskPoints
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
vtkMath
  • C++
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
  • Tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
vtkMergeFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
vtkMesaActor
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkMesaPolyDataMapper
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkMesaRenderWindow
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkMesaRenderer
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkMultiProcessController
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/PipelineParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelismWithPorts.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx

O
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkObject
  • C++
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
vtkOutlineFilter
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
    • /Examples/VisualizationAlgorithms/Tcl/VisQuad.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkOutputPort
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx

P
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkPLOT3DReader
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Rendering/Tcl/rainbow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ColorIsosurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/CutCombustor.tcl
    • /Examples/VisualizationAlgorithms/Tcl/SubsampleGrid.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
vtkPNGWriter
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkPerlinNoise
  • Tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
vtkPiecewiseFunction
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkPixel
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkPlane
  • Tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/CutCombustor.tcl
vtkPlaneSource
  • Tcl
    • /Examples/Modelling/Tcl/expCos.tcl
    • /Examples/Rendering/Tcl/TPlane.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkPointDataToCellData
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
vtkPointSource
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
vtkPoints
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
    • /Examples/Modelling/Tcl/expCos.tcl
    • /Examples/Modelling/Tcl/reconstructSurface.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/Rendering/Tcl/keyBottle.tcl
vtkPolyData
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/Rendering/Tcl/keyBottle.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
vtkPolyDataMapper
  • C++
    • /Examples/Build/vtkMy/Examples/Cxx/Ex2/vtkmyEx2.cxx
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/Rendering/Cxx/Cylinder.cxx
    • /Examples/Tutorial/Step1/Cxx/Cone.cxx
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
  • Java
    • /Examples/Tutorial/Step1/Java/Cone.java
    • /Examples/Tutorial/Step2/Java/Cone2.java
  • Python
    • /Examples/Tutorial/Step1/Python/Cone.py
    • /Examples/Tutorial/Step2/Python/Cone2.py
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Build/vtkMy/Examples/Tcl/vtkmyEx2.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/SpherePuzzle.tcl
vtkPolyDataMapper2D
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
vtkPolyDataNormals
  • Tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ColorIsosurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/deciFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/smoothFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
vtkPolyDataReader
  • Tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
    • /Examples/Modelling/Tcl/hello.tcl
    • /Examples/VisualizationAlgorithms/Tcl/deciFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/smoothFran.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
vtkPolyLine
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkPolyVertex
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkPolygon
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkProbeFilter
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkProcrustesAlignmentFilter
  • Tcl
    • /Examples/Modelling/Tcl/procrustesAlignment.tcl
vtkProgrammableDataObjectSource
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkProgrammableFilter
  • Tcl
    • /Examples/Modelling/Tcl/expCos.tcl
vtkProgrammableSource
  • Tcl
    • /Examples/Modelling/Tcl/reconstructSurface.tcl
vtkProp
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleView.cpp
vtkPropCollection
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleView.cpp
    • /Examples/GUI/Win32/SampleMFC/vtkMFCDocument.cpp
vtkProperty
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkPyramid
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl

Q
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkQuad
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkQuadric
  • Tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
    • /Examples/VisualizationAlgorithms/Tcl/VisQuad.tcl

R
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkRTAnalyticSource
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/pipe1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task4.cxx
  • Tcl
    • /Examples/ParallelProcessing/MPI/Tcl/PVTKDemo.tcl
vtkRearrangeFields
  • Tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
vtkRectilinearGrid
  • C++
    • /Examples/DataManipulation/Cxx/RGrid.cxx
vtkRectilinearGridGeometryFilter
  • C++
    • /Examples/DataManipulation/Cxx/RGrid.cxx
vtkRenderLargeImage
  • Tcl
    • /Examples/Rendering/Tcl/RenderLargeImage.tcl
vtkRenderWindow
  • C++
    • /Examples/Build/vtkMy/Examples/Cxx/Ex2/vtkmyEx2.cxx
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/Rendering/Cxx/Cylinder.cxx
    • /Examples/Tutorial/Step1/Cxx/Cone.cxx
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
  • Java
    • /Examples/Tutorial/Step1/Java/Cone.java
    • /Examples/Tutorial/Step2/Java/Cone2.java
  • Python
    • /Examples/Tutorial/Step1/Python/Cone.py
    • /Examples/Tutorial/Step2/Python/Cone2.py
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Build/vtkMy/Examples/Tcl/vtkmyEx2.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkRenderWindowInteractor
  • C++
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/Rendering/Cxx/Cylinder.cxx
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/IO/Tcl/flamingo.tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
vtkRenderer
  • C++
    • /Examples/Build/vtkMy/Examples/Cxx/Ex2/vtkmyEx2.cxx
    • /Examples/DataManipulation/Cxx/Arrays.cxx
    • /Examples/DataManipulation/Cxx/Cube.cxx
    • /Examples/DataManipulation/Cxx/RGrid.cxx
    • /Examples/DataManipulation/Cxx/SGrid.cxx
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
    • /Examples/GUI/Win32/SampleMFC/vtkMFCRenderView.cpp
    • /Examples/GUI/Win32/SimpleCxx/Win32Cone.cxx
    • /Examples/Modelling/Cxx/finance.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/pipe2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task1.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task2.cxx
    • /Examples/ParallelProcessing/Generic/Cxx/task3.cxx
    • /Examples/Rendering/Cxx/Cylinder.cxx
    • /Examples/Tutorial/Step1/Cxx/Cone.cxx
    • /Examples/Tutorial/Step2/Cxx/Cone2.cxx
  • Java
    • /Examples/Tutorial/Step1/Java/Cone.java
    • /Examples/Tutorial/Step2/Java/Cone2.java
  • Python
    • /Examples/Tutorial/Step1/Python/Cone.py
    • /Examples/Tutorial/Step2/Python/Cone2.py
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/cubeAxes.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Build/vtkMy/Examples/Tcl/vtkmyEx2.tcl
    • /Examples/DataManipulation/Tcl/Arrays.tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/CreateStrip.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/ImageProcessing/Tcl/ImageInteractor.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
vtkReverseSense
  • Tcl
    • /Examples/Modelling/Tcl/reconstructSurface.tcl
vtkRotationalExtrusionFilter
  • Tcl
    • /Examples/Rendering/Tcl/keyBottle.tcl
vtkRuledSurfaceFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl
vtkRungeKutta4
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Examples (S..X)
  • 202 class(es) in 120 file(s) from directories matching ^Examples$ on Mon Mar 25 01:05:29 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

S
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkSLCReader
  • Tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkSTLReader
  • Tcl
    • /Examples/IO/Tcl/stl.tcl
    • /Examples/Rendering/Tcl/CADPart.tcl
    • /Examples/Rendering/Tcl/FilterCADPart.tcl
vtkSampleFunction
  • Tcl
    • /Examples/ImageProcessing/Tcl/Contours2D.tcl
    • /Examples/Modelling/Tcl/PerlinTerrain.tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
    • /Examples/VisualizationAlgorithms/Tcl/VisQuad.tcl
vtkScaledTextActor
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
vtkSelectVisiblePoints
  • Tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
vtkShrinkFilter
  • Tcl
    • /Examples/Modelling/Tcl/Delaunay3D.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
vtkShrinkPolyData
  • Tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Rendering/Tcl/FilterCADPart.tcl
vtkSmoothPolyDataFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/smoothFran.tcl
vtkSphere
  • Tcl
    • /Examples/Modelling/Tcl/iceCream.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
vtkSpherePuzzle
  • Tcl
    • /Examples/Modelling/Tcl/SpherePuzzle.tcl
vtkSpherePuzzleArrows
  • Tcl
    • /Examples/Modelling/Tcl/SpherePuzzle.tcl
vtkSphereSource
  • C++
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/labeledMesh.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/GUI/Tcl/Mace.tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/procrustesAlignment.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/Rendering/Tcl/assembly.tcl
    • /Examples/VisualizationAlgorithms/Tcl/DepthSort.tcl
vtkStreamLine
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl
vtkStripper
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkStructuredGrid
  • C++
    • /Examples/DataManipulation/Cxx/SGrid.cxx
vtkStructuredGridGeometryFilter
  • Tcl
    • /Examples/Rendering/Tcl/rainbow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/CutCombustor.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
vtkStructuredGridOutlineFilter
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/Rendering/Tcl/rainbow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ColorIsosurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/CutCombustor.tcl
    • /Examples/VisualizationAlgorithms/Tcl/SubsampleGrid.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VisualizationAlgorithms/Tcl/streamSurface.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
vtkStructuredGridReader
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl
vtkStructuredPointsReader
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
vtkSurfaceReconstructionFilter
  • Tcl
    • /Examples/Modelling/Tcl/reconstructSurface.tcl

T
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkTIFFWriter
  • Tcl
    • /Examples/Rendering/Tcl/RenderLargeImage.tcl
vtkTestUtilities
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
vtkTetra
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkTextMapper
  • C++
    • /Examples/GUI/Win32/SampleMFC/SampleDoc.cpp
  • Tcl
    • /Examples/Annotation/Tcl/TestText.tcl
    • /Examples/Annotation/Tcl/annotatePick.tcl
    • /Examples/Annotation/Tcl/multiLineText.tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
vtkTexture
  • Tcl
    • /Examples/Rendering/Tcl/TPlane.tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkTextureMapToCylinder
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkTextureMapToPlane
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkTextureMapToSphere
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkThreshold
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
vtkThresholdPoints
  • Tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
vtkTimerLog
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/ParallelIso.cxx
vtkTkImageViewerWidget
  • Tcl
    • /Examples/ImageProcessing/Tcl/Histogram.tcl
    • /Examples/ImageProcessing/Tcl/HistogramWidget.tcl
    • /Examples/ImageProcessing/Tcl/MandelbrotViewer.tcl
vtkTkRenderWidget
  • Tcl
    • /Examples/GUI/Tcl/MaceTk.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl
    • /Examples/Modelling/Tcl/SpherePuzzle.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkTransform
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Modelling/Tcl/expCos.tcl
    • /Examples/Modelling/Tcl/procrustesAlignment.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractGeometry.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkTransformPolyDataFilter
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Modelling/Tcl/expCos.tcl
    • /Examples/Modelling/Tcl/procrustesAlignment.tcl
    • /Examples/VisualizationAlgorithms/Tcl/probeComb.tcl
    • /Examples/VisualizationAlgorithms/Tcl/spikeF.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkTransformTextureCoords
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/GenerateTextureCoords.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
vtkTreeComposite
  • C++
    • /Examples/ParallelProcessing/Generic/Cxx/TaskParallelism.cxx
  • Tcl
    • /Examples/ParallelProcessing/MPI/Tcl/PVTKDemo.tcl
vtkTriangle
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkTriangleFilter
  • Tcl
    • /Examples/VisualizationAlgorithms/Tcl/ClipCow.tcl
    • /Examples/VisualizationAlgorithms/Tcl/TransformTextureCoords.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkTriangleStrip
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkTubeFilter
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
    • /Examples/Modelling/Tcl/DelMesh.tcl
    • /Examples/Modelling/Tcl/constrainedDelaunay.tcl
    • /Examples/Modelling/Tcl/faultLines.tcl
    • /Examples/Rendering/Tcl/CSpline.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTube.tcl
    • /Examples/VisualizationAlgorithms/Tcl/officeTubes.tcl

U
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkUnstructuredGrid
  • C++
    • /Examples/Modelling/Cxx/finance.cxx
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
vtkUnstructuredGridReader
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl

V
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkVectorText
  • Tcl
    • /Examples/Annotation/Tcl/textOrigin.tcl
    • /Examples/DataManipulation/Tcl/FinancialField.tcl
    • /Examples/DataManipulation/Tcl/marching.tcl
vtkVertex
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkVolume
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
vtkVolumeProperty
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkVolumeRayCastCompositeFunction
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkVolumeRayCastMapper
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleRayCast.tcl
    • /Examples/VolumeRendering/Tcl/volSimpleLOD.tcl
vtkVolumeTextureMapper2D
  • Tcl
    • /Examples/VolumeRendering/Tcl/SimpleTextureMap2D.tcl
vtkVoxel
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl

W
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkWarpScalar
  • Tcl
    • /Examples/Modelling/Tcl/expCos.tcl
    • /Examples/VisualizationAlgorithms/Tcl/BandContourTerrain.tcl
    • /Examples/VisualizationAlgorithms/Tcl/imageWarp.tcl
    • /Examples/VisualizationAlgorithms/Tcl/warpComb.tcl
vtkWarpVector
  • Tcl
    • /Examples/DataManipulation/Tcl/pointToCellData.tcl
    • /Examples/VisualizationAlgorithms/Tcl/ExtractUGrid.tcl
vtkWedge
  • Tcl
    • /Examples/DataManipulation/Tcl/BuildUGrid.tcl
vtkWin32OpenGLRenderWindow
  • C++
    • /Examples/GUI/Win32/SampleMFC/vtkMFCRenderView.cpp
vtkWin32RenderWindowInteractor
  • C++
    • /Examples/GUI/Win32/SampleMFC/vtkMFCRenderView.cpp
vtkWindow
  • C++
    • /Examples/GUI/Win32/SampleMFC/vtkMFCView.cpp
vtkWindowToImageFilter
  • Tcl
    • /Examples/MangledMesa/Tcl/OffScreenCone.tcl
    • /Examples/MangledMesa/Tcl/OffScreenPrinting.tcl

X
Navigation:
[3 | A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkXOpenGLRenderWindow
  • C++
    • /Examples/GUI/Motif/Example2.cxx
vtkXRenderWindowInteractor
  • C++
    • /Examples/GUI/Motif/Example1.cxx
    • /Examples/GUI/Motif/Example2.cxx
vtkXYPlotActor
  • Tcl
    • /Examples/Annotation/Tcl/xyPlot.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (3..B)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

3
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtk3DSImporter
  • Tcl
    • /Hybrid/Testing/Tcl/largeImageOffset.tcl
    • /Hybrid/Testing/Tcl/largeImageParallel.tcl

A
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkAbstractList
  • C++
    • /Common/Testing/Cxx/TestContainers.cxx
vtkActor
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
vtkActor2D
  • Tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
    • /IO/Testing/Tcl/Plot3DVectors.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationModes.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorPad.tcl
    • /Imaging/Testing/Tcl/ResliceOptimizationOff.tcl
    • /Imaging/Testing/Tcl/ReslicePermutations.tcl
    • /Imaging/Testing/Tcl/ResliceWrapOblique.tcl
    • /Imaging/Testing/Tcl/ResliceWrapPad.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestAllLogic.tcl
    • /Imaging/Testing/Tcl/TestAllMaskBits.tcl
    • /Imaging/Testing/Tcl/TestAllMathematics.tcl
    • /Imaging/Testing/Tcl/TestAllShrinks.tcl
    • /Rendering/Testing/Tcl/TestTiling.tcl
    • /Rendering/Testing/Tcl/labeledContours.tcl
vtkAppendFilter
  • Tcl
    • /Hybrid/Testing/Tcl/camera.tcl
vtkAppendPolyData
  • C++
    • /Parallel/Testing/Cxx/ParallelIso.cxx
  • Tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Hybrid/Testing/Tcl/depthSort.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
vtkArcPlotter
  • Tcl
    • /Hybrid/Testing/Tcl/bore.tcl
vtkArrayCalculator
  • Tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkArrowSource
  • Tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
vtkAssembly
  • Tcl
    • /Rendering/Testing/Tcl/assembly.tcl
    • /Rendering/Testing/Tcl/propAssembly.tcl
vtkAssignAttribute
  • Tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkAxes
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Patented/Testing/Tcl/financialField.tcl
    • /Rendering/Testing/Tcl/rotations.tcl

B
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkBMPReader
  • Tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Imaging/Testing/Tcl/ResliceColorWrap.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
    • /Imaging/Testing/Tcl/TestStencilWithImage.tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkBMPWriter
  • Tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
vtkBYUReader
  • C++
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/teapotHulls.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /Rendering/Testing/Tcl/rotations.tcl
vtkBYUWriter
  • Tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkBandedPolyDataContourFilter
  • Tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
vtkBlankStructuredGrid
  • Tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
vtkBlankStructuredGridWithImage
  • Tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
vtkBooleanTexture
  • Tcl
    • /Graphics/Testing/Tcl/quadricCut.tcl
vtkBranchExtentTranslator
  • Tcl
    • /Parallel/Testing/Tcl/TestBranchExtentTranslator.tcl
vtkBrownianPoints
  • Tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
vtkButterflySubdivisionFilter
  • Tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
vtkButtonSource
  • Tcl
    • /Graphics/Testing/Tcl/TestButtonSource.tcl
vtkByteSwap
  • C++
    • /Common/Testing/Cxx/otherByteSwap.cxx

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (C)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

C
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkCamera
  • C++
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Rendering/Testing/Cxx/otherCoordinate.cxx
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/deciFranFace.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
    • /Graphics/Testing/Tcl/polyConn.tcl
    • /Graphics/Testing/Tcl/recursiveDC.tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
    • /Graphics/Testing/Tcl/spatialRepAll.tcl
    • /Graphics/Testing/Tcl/stripF.tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl
    • /Hybrid/Testing/Tcl/3DMorph.tcl
    • /Hybrid/Testing/Tcl/bore.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /Hybrid/Testing/Tcl/depthSort.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
vtkCaptionActor2D
  • Tcl
    • /Hybrid/Testing/Tcl/TestCaptionActor.tcl
vtkCardinalSpline
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
vtkCastToConcrete
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkCell
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
vtkCellArray
  • C++
    • /Common/Testing/Cxx/otherCellArray.cxx
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/TestQuadricClustering.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TestTriangleFilter.tcl
    • /Graphics/Testing/Tcl/constrainedDelaunay.tcl
    • /Graphics/Testing/Tcl/contoursToSurface.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
    • /Graphics/Testing/Tcl/socbal.tcl
    • /Graphics/Testing/Tcl/triangularTexture.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Rendering/Testing/Tcl/TestOnePoint.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
    • /Rendering/Testing/Tcl/multiLineText.tcl
vtkCellCenters
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
vtkCellData
  • C++
    • /Common/Testing/Cxx/otherEmptyCell.cxx
vtkCellDataToPointData
  • Tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
vtkCellDerivatives
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
vtkCellLocator
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
  • Tcl
    • /Graphics/Testing/Tcl/spatialRepAll.tcl
vtkCellPicker
  • Tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkCellTypes
  • C++
    • /Common/Testing/Cxx/otherCellTypes.cxx
vtkCharArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
vtkCleanPolyData
  • Tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
    • /Parallel/Testing/Tcl/TestExtrudePiece.tcl
vtkClipDataSet
  • Tcl
    • /Graphics/Testing/Tcl/clipImage.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
vtkClipPolyData
  • C++
    • /Graphics/Testing/Cxx/FrustumClip.cxx
  • Tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/createBFont.tcl
    • /Graphics/Testing/Tcl/cutLoop.tcl
vtkClipVolume
  • Tcl
    • /Graphics/Testing/Tcl/clipVolume.tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
vtkColorTransferFunction
  • C++
    • /Filtering/Testing/Cxx/otherColorTransferFunction.cxx
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkCommunicator
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
vtkCone
  • Tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Patented/Testing/Tcl/iceCream.tcl
vtkConeSource
  • C++
    • /Graphics/Testing/Cxx/Mace.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/coneResolution.tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
    • /Graphics/Testing/Tcl/stereoDresdenMace.tcl
    • /Graphics/Testing/Tcl/testReflect.tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
    • /Hybrid/Testing/Tcl/TestCaptionActor.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Rendering/Testing/Tcl/CamBlur.tcl
    • /Rendering/Testing/Tcl/TestFlyTo.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickActor.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickCamera.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackball.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballActor.tcl
vtkConnectivityFilter
  • Tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/scalarConn.tcl
vtkContainer
  • C++
    • /Common/Testing/Cxx/TestContainers.cxx
vtkContourFilter
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
  • Tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/contour2DAll.tcl
    • /Graphics/Testing/Tcl/contour3DAll.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/extractVectors.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/multipleIso.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/reconstructSurface.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/scalarConn.tcl
    • /Graphics/Testing/Tcl/skinOrder.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
    • /Hybrid/Testing/Tcl/3DMorph.tcl
vtkCoordinate
  • C++
    • /Rendering/Testing/Cxx/otherCoordinate.cxx
  • Tcl
    • /Rendering/Testing/Tcl/multiLineText.tcl
vtkCubeAxesActor2D
  • Tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
vtkCubeSource
  • Tcl
    • /Graphics/Testing/Tcl/triangularTCoords.tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Rendering/Testing/Tcl/assembly.tcl
    • /Rendering/Testing/Tcl/propAssembly.tcl
vtkCursor3D
  • Tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
vtkCutMaterial
  • Tcl
    • /Parallel/Testing/Tcl/TestCutMaterial.tcl
vtkCutter
  • Tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
vtkCylinder
  • Tcl
    • /Graphics/Testing/Tcl/extractPolyData.tcl
vtkCylinderSource
  • Tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
    • /Graphics/Testing/Tcl/TransformConcatenation.tcl
    • /Rendering/Testing/Tcl/assembly.tcl
    • /Rendering/Testing/Tcl/propAssembly.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (D..F)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

D
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkDEMReader
  • Tcl
    • /IO/Testing/Tcl/dem.tcl
vtkDashedStreamLine
  • Tcl
    • /Graphics/Testing/Tcl/combStreamers2.tcl
vtkDataArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
vtkDataObjectReader
  • Tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Patented/Testing/Tcl/financialField.tcl
vtkDataObjectToDataSetFilter
  • Tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Patented/Testing/Tcl/financialField.tcl
vtkDataObjectWriter
  • Tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
vtkDataSetAttributes
  • Tcl
    • /Common/Testing/Tcl/otherDataSetAttributes.tcl
vtkDataSetMapper
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
  • Tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/TransformConcatenation.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/clipImage.tcl
    • /Graphics/Testing/Tcl/clipVolume.tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
    • /Graphics/Testing/Tcl/dicer.tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
    • /Graphics/Testing/Tcl/edgePoints.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
vtkDataSetReader
  • Tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter2.tcl
    • /Imaging/Testing/Tcl/voxelModel.tcl
    • /Parallel/Testing/Tcl/RectOutline.tcl
vtkDataSetSurfaceFilter
  • Tcl
    • /Graphics/Testing/Tcl/dataSetSurfaceFilter.tcl
    • /Parallel/Testing/Tcl/TestBranchExtentTranslator.tcl
    • /Parallel/Testing/Tcl/TestPDataSetReaderGrid.tcl
vtkDataSetToDataObjectFilter
  • Tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Rendering/Testing/Tcl/TestParallelCoordinates.tcl
vtkDataSetTriangleFilter
  • Tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter2.tcl
    • /Parallel/Testing/Tcl/TestUnstructuredPieces.tcl
vtkDataSetWriter
  • Tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
    • /Imaging/Testing/Tcl/voxelModel.tcl
vtkDebugLeaks
  • C++
    • /Common/Testing/Cxx/ObjectFactory.cxx
    • /Common/Testing/Cxx/TestImageIterator.cxx
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherByteSwap.cxx
    • /Common/Testing/Cxx/otherCellArray.cxx
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
    • /Common/Testing/Cxx/otherCellTypes.cxx
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Common/Testing/Cxx/otherFieldData.cxx
    • /Common/Testing/Cxx/otherLookupTable.cxx
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
    • /Common/Testing/Cxx/otherTimerLog.cxx
    • /Filtering/Testing/Cxx/otherColorTransferFunction.cxx
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
  • Tcl
    • /Common/Testing/Tcl/otherDataSetAttributes.tcl
    • /Common/Testing/Tcl/otherPrint.tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
vtkDecimate
  • Tcl
    • /Patented/Testing/Tcl/deciBrain.tcl
    • /Patented/Testing/Tcl/deciBrainErrors.tcl
vtkDecimatePro
  • Tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/deciFranFace.tcl
vtkDelaunay2D
  • Tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/constrainedDelaunay.tcl
vtkDelaunay3D
  • Tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
vtkDepthSortPolyData
  • Tcl
    • /Hybrid/Testing/Tcl/depthSort.tcl
vtkDiskSource
  • Tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Parallel/Testing/Tcl/TestExtrudePiece.tcl
vtkDividingCubes
  • Tcl
    • /Patented/Testing/Tcl/dcubes.tcl
vtkDoubleArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx

E
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkEarthSource
  • Tcl
    • /Hybrid/Testing/Tcl/earth.tcl
vtkEdgePoints
  • Tcl
    • /Graphics/Testing/Tcl/edgePoints.tcl
vtkElevationFilter
  • C++
    • /Parallel/Testing/Cxx/ParallelIso.cxx
  • Tcl
    • /Graphics/Testing/Tcl/progGlyphs.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Parallel/Testing/Tcl/RectOutline.tcl
vtkEmptyCell
  • C++
    • /Common/Testing/Cxx/otherEmptyCell.cxx
vtkEnSightGoldBinaryReader
  • Tcl
    • /Graphics/Testing/Tcl/nacaBinary.tcl
vtkExtractEdges
  • Tcl
    • /Graphics/Testing/Tcl/constrainedDelaunay.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkExtractGeometry
  • Tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Graphics/Testing/Tcl/dataSetSurfaceFilter.tcl
    • /Graphics/Testing/Tcl/geomFilter.tcl
vtkExtractGrid
  • Python
    • /Graphics/Testing/Python/glyphComb.py
  • Tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
vtkExtractPolyDataGeometry
  • Tcl
    • /Graphics/Testing/Tcl/extractPolyData.tcl
vtkExtractPolyDataPiece
  • Tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
    • /Parallel/Testing/Tcl/TestExtrudePiece.tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
vtkExtractTensorComponents
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
vtkExtractUnstructuredGrid
  • Tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
vtkExtractUnstructuredGridPiece
  • Tcl
    • /Parallel/Testing/Tcl/TestUnstructuredPieces.tcl
vtkExtractVOI
  • Tcl
    • /Imaging/Testing/Tcl/resampledTexture.tcl
vtkExtractVectorComponents
  • Tcl
    • /Graphics/Testing/Tcl/extractVectors.tcl

F
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkFeatureEdges
  • Tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Hybrid/Testing/Tcl/TestICPTransform.tcl
vtkFieldData
  • C++
    • /Common/Testing/Cxx/otherFieldData.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/banana.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkFieldDataToAttributeDataFilter
  • Tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Patented/Testing/Tcl/financialField.tcl
vtkFileOutputWindow
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkFiniteDifferenceGradientEstimator
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
vtkFloatArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Common/Testing/Cxx/otherFieldData.cxx
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
  • Tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
    • /Graphics/Testing/Tcl/hull.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/shepards.tcl
    • /Graphics/Testing/Tcl/socbal.tcl
    • /Graphics/Testing/Tcl/triangularTexture.tcl
    • /Hybrid/Testing/Tcl/banana.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
vtkFollower
  • Tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Patented/Testing/Tcl/financialField.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (G..H)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

G
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkGESignaReader
  • Tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude.tcl
vtkGaussianSplatter
  • Tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Patented/Testing/Tcl/financialField.tcl
vtkGeneralTransform
  • Tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl
vtkGenericCell
  • C++
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestStructuredGrid.tcl
vtkGenericEnSightReader
  • Tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
vtkGeometryFilter
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/eleState.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/geomFilter.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter.tcl
    • /Graphics/Testing/Tcl/warplens.tcl
vtkGlyph2D
  • Tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
vtkGlyph3D
  • C++
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
  • Python
    • /Graphics/Testing/Python/glyphComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
    • /Graphics/Testing/Tcl/scalarColors.tcl
    • /Graphics/Testing/Tcl/stereoDresdenMace.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Rendering/Testing/Tcl/CamBlur.tcl
    • /Rendering/Testing/Tcl/TestFlyTo.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickActor.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickCamera.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackball.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballActor.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballCamera.tcl
vtkGlyphSource2D
  • Python
    • /Graphics/Testing/Python/glyphComb.py
  • Tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
vtkGraphLayoutFilter
  • Tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
vtkGridTransform
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl

H
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkHedgeHog
  • Tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
    • /IO/Testing/Tcl/Plot3DVectors.tcl
vtkHexahedron
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkHull
  • Tcl
    • /Graphics/Testing/Tcl/hull.tcl
    • /Graphics/Testing/Tcl/teapotHulls.tcl
vtkHyperStreamline
  • Tcl
    • /Graphics/Testing/Tcl/Hyper.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (I)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

I
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkIVExporter
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkIVWriter
  • Tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkIdFilter
  • Tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
vtkIdList
  • C++
    • /Common/Testing/Cxx/otherCellArray.cxx
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Common/Testing/Cxx/otherFieldData.cxx
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestStructuredGrid.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
vtkIdTypeArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherCellArray.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
vtkIdentityTransform
  • Tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
vtkImageAccumulate
  • Tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
vtkImageActor
  • Tcl
    • /Rendering/Testing/Tcl/ImageActor.tcl
vtkImageAnisotropicDiffusion2D
  • Tcl
    • /Imaging/Testing/Tcl/TestAnisotropicDiffusion2D.tcl
vtkImageAnisotropicDiffusion3D
  • Tcl
    • /Imaging/Testing/Tcl/TestAnisotropicDiffusion3D.tcl
vtkImageAppend
  • Tcl
    • /Imaging/Testing/Tcl/TestAllFlips.tcl
    • /Imaging/Testing/Tcl/TestInPlaceFilter.tcl
vtkImageAppendComponents
  • Tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
vtkImageBlend
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
vtkImageButterworthHighPass
  • Tcl
    • /Imaging/Testing/Tcl/TestButterworthHighPass.tcl
vtkImageButterworthLowPass
  • Tcl
    • /Imaging/Testing/Tcl/TestButterworthLowPass.tcl
vtkImageCacheFilter
  • Tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp3D.tcl
    • /Imaging/Testing/Tcl/TestCache.tcl
vtkImageCanvasSource2D
  • Tcl
    • /Imaging/Testing/Tcl/TestCheckerboard.tcl
    • /Imaging/Testing/Tcl/TestConvolve.tcl
    • /Imaging/Testing/Tcl/TestCorrelation.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
    • /Imaging/Testing/Tcl/TestHSVToRGB.tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
    • /Imaging/Testing/Tcl/TestSkeleton2D.tcl
vtkImageCast
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/contour2DAll.tcl
    • /Graphics/Testing/Tcl/contour3DAll.tcl
    • /Imaging/Testing/Tcl/LaplacianEdgeEnhance.tcl
    • /Imaging/Testing/Tcl/TestAllFlips.tcl
    • /Imaging/Testing/Tcl/TestCityBlockDistance.tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistance.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistanceCached.tcl
    • /Imaging/Testing/Tcl/TestHSVToRGB.tcl
    • /Patented/Testing/Tcl/contour2DAll.tcl
    • /Patented/Testing/Tcl/imageMCAll.tcl
    • /Patented/Testing/Tcl/sync3dAll.tcl
vtkImageChangeInformation
  • Tcl
    • /Imaging/Testing/Tcl/TestChangeInformation.tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude2.tcl
vtkImageCheckerboard
  • Tcl
    • /Imaging/Testing/Tcl/TestCheckerboard.tcl
vtkImageCityBlockDistance
  • Tcl
    • /Imaging/Testing/Tcl/TestCityBlockDistance.tcl
vtkImageClip
  • Tcl
    • /Graphics/Testing/Tcl/contour2DAll.tcl
    • /Graphics/Testing/Tcl/contour3DAll.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter.tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude2.tcl
    • /Imaging/Testing/Tcl/TestSkeleton2D.tcl
    • /Parallel/Testing/Tcl/TestBranchExtentTranslator.tcl
    • /Patented/Testing/Tcl/contour2DAll.tcl
    • /Patented/Testing/Tcl/imageMCAll.tcl
    • /Patented/Testing/Tcl/sync3dAll.tcl
vtkImageConstantPad
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
vtkImageContinuousDilate3D
  • Tcl
    • /Imaging/Testing/Tcl/ContinuousClose2D.tcl
vtkImageContinuousErode3D
  • Tcl
    • /Imaging/Testing/Tcl/ContinuousClose2D.tcl
vtkImageConvolve
  • Tcl
    • /Imaging/Testing/Tcl/TestConvolve.tcl
vtkImageCorrelation
  • Tcl
    • /Imaging/Testing/Tcl/TestCorrelation.tcl
vtkImageCursor3D
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Imaging/Testing/Tcl/TestInPlaceFilter.tcl
vtkImageData
  • C++
    • /Common/Testing/Cxx/TestImageIterator.cxx
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
    • /Parallel/Testing/Tcl/TestCutMaterial.tcl
vtkImageDataGeometryFilter
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/createBFont.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModel.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /IO/Testing/Tcl/dem.tcl
vtkImageDataStreamer
  • Tcl
    • /Imaging/Testing/Tcl/TestMapToRGBABlockStreaming.tcl
vtkImageDifference
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
vtkImageDivergence
  • Tcl
    • /Imaging/Testing/Tcl/TestDivergence.tcl
vtkImageDotProduct
  • Tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
vtkImageEllipsoidSource
  • Tcl
    • /Imaging/Testing/Tcl/TestAllLogic.tcl
    • /Imaging/Testing/Tcl/TestAllMathematics.tcl
    • /Imaging/Testing/Tcl/TestMask2.tcl
    • /Parallel/Testing/Tcl/TestCutMaterial.tcl
vtkImageEuclideanDistance
  • Tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistance.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistanceCached.tcl
vtkImageEuclideanToPolar
  • Tcl
    • /Imaging/Testing/Tcl/TestEuclideanToPolar.tcl
vtkImageExport
  • C++
    • /Imaging/Testing/Cxx/ImportExport.cxx
vtkImageExtractComponents
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
vtkImageFFT
  • Tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
    • /Imaging/Testing/Tcl/TestButterworthHighPass.tcl
    • /Imaging/Testing/Tcl/TestButterworthLowPass.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
    • /Imaging/Testing/Tcl/TestIdealLowPass.tcl
vtkImageFlip
  • Tcl
    • /Imaging/Testing/Tcl/TestAllFlips.tcl
vtkImageFourierCenter
  • Tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
vtkImageGaussianSmooth
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/createBFont.tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
vtkImageGaussianSource
  • Tcl
    • /Imaging/Testing/Tcl/TestEuclideanToPolar.tcl
    • /Parallel/Testing/Tcl/TestBranchExtentTranslator.tcl
    • /Parallel/Testing/Tcl/TestCutMaterial.tcl
vtkImageGradient
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
    • /Imaging/Testing/Tcl/TestDivergence.tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
    • /Imaging/Testing/Tcl/TestEuclideanToPolar.tcl
    • /Imaging/Testing/Tcl/TestNormalize.tcl
vtkImageGradientMagnitude
  • Tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude.tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude2.tcl
vtkImageGridSource
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
vtkImageHSVToRGB
  • Tcl
    • /Imaging/Testing/Tcl/TestHSVToRGB.tcl
vtkImageHybridMedian2D
  • Tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
vtkImageIdealHighPass
  • Tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
vtkImageIdealLowPass
  • Tcl
    • /Imaging/Testing/Tcl/TestIdealLowPass.tcl
vtkImageImport
  • C++
    • /Imaging/Testing/Cxx/ImportExport.cxx
vtkImageIslandRemoval2D
  • Tcl
    • /Imaging/Testing/Tcl/TestIslandRemoval2D.tcl
vtkImageIterator
  • C++
    • /Common/Testing/Cxx/TestImageIterator.cxx
vtkImageLaplacian
  • Tcl
    • /Imaging/Testing/Tcl/LaplacianEdgeEnhance.tcl
vtkImageLogarithmicScale
  • Tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
vtkImageLogic
  • Tcl
    • /Imaging/Testing/Tcl/TestAllLogic.tcl
vtkImageLuminance
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
vtkImageMagnify
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Imaging/Testing/Tcl/TestAllShrinks.tcl
    • /Imaging/Testing/Tcl/TestInPlaceFilter.tcl
    • /Imaging/Testing/Tcl/TestShiftScale.tcl
    • /Imaging/Testing/Tcl/TestShiftScale2.tcl
    • /Imaging/Testing/Tcl/TestSkeleton2D.tcl
vtkImageMagnitude
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
vtkImageMandelbrotSource
  • Tcl
    • /Imaging/Testing/Tcl/TestMapToWindowLevelColors.tcl
    • /Parallel/Testing/Tcl/TestPDataSetReaderGrid.tcl
vtkImageMapToColors
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestMapToRGBABlockStreaming.tcl
    • /Parallel/Testing/Tcl/TestImageStreamer.tcl
vtkImageMapToRGBA
  • Tcl
    • /Imaging/Testing/Tcl/TestQuantizeTo16Colors.tcl
vtkImageMapToWindowLevelColors
  • Tcl
    • /Imaging/Testing/Tcl/TestMapToWindowLevelColors.tcl
vtkImageMapper
  • Tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationModes.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorPad.tcl
    • /Imaging/Testing/Tcl/ResliceOptimizationOff.tcl
    • /Imaging/Testing/Tcl/ReslicePermutations.tcl
    • /Imaging/Testing/Tcl/ResliceWrapOblique.tcl
    • /Imaging/Testing/Tcl/ResliceWrapPad.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestAllLogic.tcl
    • /Imaging/Testing/Tcl/TestAllMaskBits.tcl
    • /Imaging/Testing/Tcl/TestAllMathematics.tcl
    • /Imaging/Testing/Tcl/TestAllShrinks.tcl
    • /Rendering/Testing/Tcl/TestTiling.tcl
vtkImageMarchingCubes
  • Tcl
    • /Patented/Testing/Tcl/TestImageMarchingCubes.tcl
vtkImageMask
  • Tcl
    • /Imaging/Testing/Tcl/TestMask2.tcl
vtkImageMaskBits
  • Tcl
    • /Imaging/Testing/Tcl/TestAllMaskBits.tcl
vtkImageMathematics
  • Tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
    • /Imaging/Testing/Tcl/LaplacianEdgeEnhance.tcl
    • /Imaging/Testing/Tcl/TestAllMathematics.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
vtkImageMedian3D
  • Tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
    • /Imaging/Testing/Tcl/TestMedian3D.tcl
vtkImageMirrorPad
  • Tcl
    • /Imaging/Testing/Tcl/TestQuantizeTo16Colors.tcl
vtkImageNoiseSource
  • Tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
vtkImageNonMaximumSuppression
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
vtkImageNormalize
  • Tcl
    • /Imaging/Testing/Tcl/TestNormalize.tcl
vtkImageOpenClose3D
  • Tcl
    • /Imaging/Testing/Tcl/TestOpenClose3D.tcl
vtkImagePermute
  • Tcl
    • /Imaging/Testing/Tcl/TestPermute.tcl
vtkImageProgressIterator
  • C++
    • /Common/Testing/Cxx/TestImageIterator.cxx
vtkImageQuantizeRGBToIndex
  • Tcl
    • /Hybrid/Testing/Tcl/imageToPolyData.tcl
    • /Imaging/Testing/Tcl/TestQuantizeTo16Colors.tcl
vtkImageRFFT
  • Tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
    • /Imaging/Testing/Tcl/TestFFTCorrelation.tcl
vtkImageRGBToHSV
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Imaging/Testing/Tcl/TestHSVToRGB.tcl
vtkImageRange3D
  • Tcl
    • /Imaging/Testing/Tcl/TestRange3D.tcl
vtkImageReader
  • C++
    • /Imaging/Testing/Cxx/ImportExport.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
  • Tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter.tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp3D.tcl
    • /Imaging/Testing/Tcl/ContinuousClose2D.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationModes.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorPad.tcl
    • /Imaging/Testing/Tcl/ResliceOptimizationOff.tcl
    • /Imaging/Testing/Tcl/ReslicePermutations.tcl
    • /Imaging/Testing/Tcl/ReslicePermuteResample.tcl
    • /Imaging/Testing/Tcl/ResliceWrapOblique.tcl
    • /Imaging/Testing/Tcl/ResliceWrapPad.tcl
    • /Imaging/Testing/Tcl/TestAllFlips.tcl
    • /Imaging/Testing/Tcl/TestAllShrinks.tcl
    • /Imaging/Testing/Tcl/TestAnisotropicDiffusion3D.tcl
    • /Imaging/Testing/Tcl/TestCache.tcl
    • /Imaging/Testing/Tcl/TestMapToRGBABlockStreaming.tcl
    • /Imaging/Testing/Tcl/TestPermute.tcl
    • /Imaging/Testing/Tcl/TestRange3D.tcl
vtkImageReader2Factory
  • Tcl
    • /IO/Testing/Tcl/TestJPEGReader.tcl
    • /IO/Testing/Tcl/TestTIFFReader.tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
vtkImageResample
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
    • /Imaging/Testing/Tcl/TestResample.tcl
vtkImageReslice
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp3D.tcl
    • /Imaging/Testing/Tcl/ResliceColorWrap.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationModes.tcl
    • /Imaging/Testing/Tcl/ResliceInterpolationOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorOblique.tcl
    • /Imaging/Testing/Tcl/ResliceMirrorPad.tcl
    • /Imaging/Testing/Tcl/ResliceOptimizationOff.tcl
    • /Imaging/Testing/Tcl/ReslicePermutations.tcl
    • /Imaging/Testing/Tcl/ReslicePermuteResample.tcl
    • /Imaging/Testing/Tcl/ResliceWrapOblique.tcl
    • /Imaging/Testing/Tcl/ResliceWrapPad.tcl
    • /Imaging/Testing/Tcl/TestChangeInformation.tcl
vtkImageSeedConnectivity
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
vtkImageSeparableConvolution
  • Tcl
    • /Imaging/Testing/Tcl/TestSeparableFilter.tcl
vtkImageShiftScale
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
    • /Imaging/Testing/Tcl/TestShiftScale.tcl
    • /Imaging/Testing/Tcl/TestShiftScale2.tcl
    • /Imaging/Testing/Tcl/TestStencilWithFunction.tcl
vtkImageShrink3D
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestAllMaskBits.tcl
    • /Imaging/Testing/Tcl/TestAllShrinks.tcl
vtkImageSinusoidSource
  • Tcl
    • /Imaging/Testing/Tcl/TestNormalize.tcl
vtkImageSkeleton2D
  • Tcl
    • /Imaging/Testing/Tcl/TestSkeleton2D.tcl
vtkImageSobel2D
  • Tcl
    • /Imaging/Testing/Tcl/TestSobel2D.tcl
vtkImageSobel3D
  • Tcl
    • /Imaging/Testing/Tcl/TestSobel3D.tcl
vtkImageStencil
  • Tcl
    • /Hybrid/Testing/Tcl/TestImageStencilWithPolydata.tcl
    • /Imaging/Testing/Tcl/TestStencilWithFunction.tcl
    • /Imaging/Testing/Tcl/TestStencilWithImage.tcl
vtkImageThreshold
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestCityBlockDistance.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistance.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistanceCached.tcl
    • /Imaging/Testing/Tcl/TestHybridMedian2D.tcl
    • /Imaging/Testing/Tcl/TestIslandRemoval2D.tcl
    • /Imaging/Testing/Tcl/TestOpenClose3D.tcl
vtkImageToImageStencil
  • Tcl
    • /Imaging/Testing/Tcl/TestStencilWithImage.tcl
vtkImageToPolyDataFilter
  • Tcl
    • /Hybrid/Testing/Tcl/imageToPolyData.tcl
vtkImageToStructuredPoints
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
vtkImageTranslateExtent
  • Tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestStencilWithImage.tcl
vtkImageVariance3D
  • Tcl
    • /Imaging/Testing/Tcl/TestVariance3D.tcl
vtkImageViewer
  • C++
    • /Imaging/Testing/Cxx/ImportExport.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestImageStencilWithPolydata.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp3D.tcl
    • /Hybrid/Testing/Tcl/largeImageOffset.tcl
    • /Hybrid/Testing/Tcl/largeImageParallel.tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
    • /IO/Testing/Tcl/TestJPEGReader.tcl
    • /IO/Testing/Tcl/TestTIFFReader.tcl
    • /Imaging/Testing/Tcl/ContinuousClose2D.tcl
    • /Imaging/Testing/Tcl/IdealHighPass.tcl
    • /Imaging/Testing/Tcl/LaplacianEdgeEnhance.tcl
    • /Imaging/Testing/Tcl/ResliceColorWrap.tcl
    • /Imaging/Testing/Tcl/ReslicePermuteResample.tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
    • /Imaging/Testing/Tcl/TestAllFlips.tcl
    • /Imaging/Testing/Tcl/TestAnisotropicDiffusion2D.tcl
vtkImageViewer2
  • Tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
vtkImageWrapPad
  • Tcl
    • /Imaging/Testing/Tcl/TestCheckerboard.tcl
    • /Imaging/Testing/Tcl/TestWrapPad.tcl
vtkImplicitBoolean
  • Tcl
    • /Patented/Testing/Tcl/iceCream.tcl
    • /Patented/Testing/Tcl/nc.tcl
vtkImplicitDataSet
  • Tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
vtkImplicitFunctionToImageStencil
  • Tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestStencilWithFunction.tcl
vtkImplicitModeller
  • Tcl
    • /Hybrid/Testing/Tcl/3DMorph.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModel.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Patented/Testing/Tcl/nc.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
    • /Patented/Testing/Tcl/sweptVtk.tcl
vtkImplicitSelectionLoop
  • Tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
vtkImplicitSum
  • Tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
vtkImplicitTextureCoords
  • Tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/quadricCut.tcl
vtkImplicitVolume
  • Tcl
    • /Patented/Testing/Tcl/nc.tcl
vtkImplicitWindowFunction
  • Tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
vtkIndent
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkInputPort
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
vtkIntArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherCellTypes.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkInteractorStyleSwitch
  • Tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickActor.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickCamera.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballActor.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballCamera.tcl
vtkInteractorStyleTrackball
  • Tcl
    • /Rendering/Testing/Tcl/TestStyleTrackball.tcl
vtkInterpolateDataSetAttributes
  • Tcl
    • /Hybrid/Testing/Tcl/3DMorph.tcl
vtkIterativeClosestPointTransform
  • Tcl
    • /Hybrid/Testing/Tcl/TestICPTransform.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (J..O)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

J
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkJPEGReader
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Graphics/Testing/Tcl/TestButtonSource.tcl
vtkJPEGWriter
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl

K
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkKitwareContourFilter
  • Tcl
    • /Patented/Testing/Tcl/TestGridSynchronizedTemplates3D.tcl
    • /Patented/Testing/Tcl/TestSynchronizedTemplates2D.tcl
    • /Patented/Testing/Tcl/TestSynchronizedTemplates3D.tcl
vtkKochanekSpline
  • Tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl

L
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkLODActor
  • Tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/cutLoop.tcl
    • /Graphics/Testing/Tcl/stereoDresdenMace.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Rendering/Testing/Tcl/TestFlyTo.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickActor.tcl
    • /Rendering/Testing/Tcl/TestStyleJoystickCamera.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackball.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballActor.tcl
    • /Rendering/Testing/Tcl/TestStyleTrackballCamera.tcl
vtkLODProp3D
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkLabeledDataMapper
  • Tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Rendering/Testing/Tcl/labeledContours.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
vtkLight
  • Tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
    • /IO/Testing/Tcl/Plot3DVectors.tcl
    • /Patented/Testing/Tcl/dcubes.tcl
    • /Patented/Testing/Tcl/headBone.tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkLine
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkLineSource
  • Python
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModel.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
vtkLinearExtrusionFilter
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/eleState.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
vtkLinearSubdivisionFilter
  • Tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
vtkLinkEdgels
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
vtkLogLookupTable
  • C++
    • /Common/Testing/Cxx/otherLookupTable.cxx
  • Tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
vtkLongArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
vtkLookupTable
  • C++
    • /Common/Testing/Cxx/otherLookupTable.cxx
  • Tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/nacaBinary.tcl
    • /Graphics/Testing/Tcl/socbal.tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /IO/Testing/Tcl/TestPLYReadWrite.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestMapToRGBABlockStreaming.tcl
    • /Parallel/Testing/Tcl/TestImageStreamer.tcl
vtkLoopSubdivisionFilter
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl

M
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkMCubesReader
  • Tcl
    • /Patented/Testing/Tcl/genHead.tcl
vtkMCubesWriter
  • Tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkMPICommunicator
  • C++
    • /Parallel/Testing/Cxx/MPIGroups.cxx
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkMPIController
  • C++
    • /Parallel/Testing/Cxx/MPIGroups.cxx
vtkMPIGroup
  • C++
    • /Parallel/Testing/Cxx/MPIGroups.cxx
vtkMarchingContourFilter
  • Tcl
    • /Patented/Testing/Tcl/contour2DAll.tcl
    • /Patented/Testing/Tcl/financialField.tcl
    • /Patented/Testing/Tcl/iceCream.tcl
    • /Patented/Testing/Tcl/imageMCAll.tcl
    • /Patented/Testing/Tcl/mcubes.tcl
    • /Patented/Testing/Tcl/nc.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
    • /Patented/Testing/Tcl/sweptVtk.tcl
vtkMarchingCubes
  • Tcl
    • /Patented/Testing/Tcl/headBone.tcl
vtkMarchingSquares
  • Tcl
    • /Patented/Testing/Tcl/TestMarchingSquares.tcl
vtkMaskPoints
  • Tcl
    • /Rendering/Testing/Tcl/labeledContours.tcl
vtkMaskPolyData
  • Tcl
    • /Graphics/Testing/Tcl/stripF.tcl
vtkMassProperties
  • Tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
vtkMath
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/eleState.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
    • /Graphics/Testing/Tcl/hull.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/shepards.tcl
    • /Graphics/Testing/Tcl/skinOrder.tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
    • /Parallel/Testing/Tcl/TestUnstructuredPieces.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
    • /Rendering/Testing/Tcl/ScalarBar.tcl
vtkMatrix4x4
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/stereoDresdenMace.tcl
    • /Imaging/Testing/Tcl/ResliceOptimizationOff.tcl
vtkMatrixToHomogeneousTransform
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
vtkMatrixToLinearTransform
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
vtkMemoryLimitImageDataStreamer
  • Tcl
    • /Parallel/Testing/Tcl/TestImageStreamer.tcl
vtkMergeFields
  • Tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
vtkMergeFilter
  • Tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
vtkMergePoints
  • Tcl
    • /Patented/Testing/Tcl/TestMarchingSquares.tcl
    • /Patented/Testing/Tcl/headBone.tcl
vtkMesaActor
  • Tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
vtkMesaPolyDataMapper
  • Tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
vtkMesaRenderer
  • Tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
vtkMultiProcessController
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx

O
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkOBBDicer
  • Tcl
    • /Graphics/Testing/Tcl/dicer.tcl
vtkOBBTree
  • Tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
vtkOBJExporter
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkOBJReader
  • Tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
vtkOOGLExporter
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkObject
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Common/Testing/Tcl/otherPrint.tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
vtkObjectFactory
  • C++
    • /Common/Testing/Cxx/ObjectFactory.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
vtkOutlineCornerFilter
  • Tcl
    • /Graphics/Testing/Tcl/dicer.tcl
vtkOutlineFilter
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/clipImage.tcl
    • /Graphics/Testing/Tcl/clipVolume.tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
    • /Graphics/Testing/Tcl/contour2DAll.tcl
    • /Graphics/Testing/Tcl/contour3DAll.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/recursiveDC.tcl
    • /Graphics/Testing/Tcl/scalarConn.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModel.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Patented/Testing/Tcl/TestImageMarchingCubes.tcl
    • /Patented/Testing/Tcl/TestMarchingSquares.tcl
    • /Patented/Testing/Tcl/TestSynchronizedTemplates2D.tcl
vtkOutputPort
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
vtkOutputWindow
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkOverrideInformation
  • C++
    • /Common/Testing/Cxx/ObjectFactory.cxx
vtkOverrideInformationCollection
  • C++
    • /Common/Testing/Cxx/ObjectFactory.cxx

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (P)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

P
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkPDataSetReader
  • Tcl
    • /Parallel/Testing/Tcl/TestPDataSetReaderGrid.tcl
vtkPDataSetWriter
  • Tcl
    • /Parallel/Testing/Tcl/TestPDataSetReaderGrid.tcl
vtkPImageWriter
  • Tcl
    • /Parallel/Testing/Tcl/TestPImageWriter.tcl
vtkPLOT3DReader
  • C++
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Python
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl
    • /Graphics/Testing/Tcl/combStreamers2.tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
    • /Graphics/Testing/Tcl/dataSetSurfaceFilter.tcl
    • /Graphics/Testing/Tcl/extractVectors.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/geomFilter.tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /Graphics/Testing/Tcl/multipleIso.tcl
    • /Graphics/Testing/Tcl/polyConn.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
vtkPLYReader
  • Tcl
    • /IO/Testing/Tcl/TestPLYReadWrite.tcl
vtkPLYWriter
  • Tcl
    • /IO/Testing/Tcl/TestPLYReadWrite.tcl
vtkPLinearExtrusionFilter
  • Tcl
    • /Parallel/Testing/Tcl/TestExtrudePiece.tcl
vtkPNGReader
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
    • /Graphics/Testing/Tcl/deciFranFace.tcl
    • /Graphics/Testing/Tcl/warplens.tcl
    • /Hybrid/Testing/Tcl/TestImageStencilWithPolydata.tcl
    • /Hybrid/Testing/Tcl/imageToPolyData.tcl
    • /Imaging/Testing/Tcl/LaplacianEdgeEnhance.tcl
    • /Imaging/Testing/Tcl/Spectrum.tcl
    • /Imaging/Testing/Tcl/TestAccumulate.tcl
    • /Imaging/Testing/Tcl/TestAnisotropicDiffusion2D.tcl
    • /Imaging/Testing/Tcl/TestButterworthHighPass.tcl
    • /Imaging/Testing/Tcl/TestButterworthLowPass.tcl
    • /Imaging/Testing/Tcl/TestChangeInformation.tcl
    • /Imaging/Testing/Tcl/TestCityBlockDistance.tcl
    • /Imaging/Testing/Tcl/TestDivergence.tcl
    • /Imaging/Testing/Tcl/TestDotProduct.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistance.tcl
    • /Imaging/Testing/Tcl/TestEuclideanDistanceCached.tcl
    • /Imaging/Testing/Tcl/TestGradientMagnitude2.tcl
    • /Imaging/Testing/Tcl/TestIdealLowPass.tcl
    • /Imaging/Testing/Tcl/TestIslandRemoval2D.tcl
vtkPNGWriter
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
vtkPNMReader
  • C++
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/createBFont.tcl
    • /Graphics/Testing/Tcl/socbal.tcl
    • /Hybrid/Testing/Tcl/earth.tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestMask2.tcl
    • /Imaging/Testing/Tcl/TestQuantizeTo16Colors.tcl
    • /Imaging/Testing/Tcl/TestStencilWithImage.tcl
vtkPNMWriter
  • Tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
    • /Imaging/Testing/Tcl/TestShiftScale.tcl
vtkParallelCoordinatesActor
  • Tcl
    • /Rendering/Testing/Tcl/TestParallelCoordinates.tcl
vtkParallelFactory
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
    • /Parallel/Testing/Tcl/TestUnstructuredPieces.tcl
vtkParticleReader
  • Tcl
    • /IO/Testing/Tcl/ParticleReader.tcl
vtkPerlinNoise
  • Tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
vtkPerspectiveTransform
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
vtkPieceScalars
  • Tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
    • /Parallel/Testing/Tcl/TestUnstructuredPieces.tcl
vtkPiecewiseFunction
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkPipelineSize
  • Tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
vtkPixel
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkPlane
  • Tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Patented/Testing/Tcl/iceCream.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkPlaneSource
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl
    • /Graphics/Testing/Tcl/combStreamers2.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/progGlyphs.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModel.tcl
    • /Hybrid/Testing/Tcl/appendImplicitModelNoBounds.tcl
    • /Imaging/Testing/Tcl/resampledTexture.tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkPlanes
  • C++
    • /Graphics/Testing/Cxx/FrustumClip.cxx
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Graphics/Testing/Tcl/hull.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Patented/Testing/Tcl/nc.tcl
vtkPointData
  • C++
    • /Common/Testing/Cxx/otherEmptyCell.cxx
  • Tcl
    • /Graphics/Testing/Tcl/triangularTexture.tcl
vtkPointDataToCellData
  • Tcl
    • /IO/Testing/Tcl/TestPLYReadWrite.tcl
vtkPointLoad
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
vtkPointLocator
  • C++
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
  • Tcl
    • /Graphics/Testing/Tcl/spatialRepAll.tcl
vtkPointPicker
  • Tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkPointSource
  • Tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
vtkPoints
  • C++
    • /Common/Testing/Cxx/otherEmptyCell.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/TestQuadricClustering.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TestStructuredGrid.tcl
    • /Graphics/Testing/Tcl/TestTriangleFilter.tcl
vtkPolyData
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/TestBandedContourFilter.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/TestQuadricClustering.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TestTriangleFilter.tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/constrainedDelaunay.tcl
    • /Graphics/Testing/Tcl/contoursToSurface.tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
vtkPolyDataConnectivityFilter
  • Tcl
    • /Graphics/Testing/Tcl/polyConn.tcl
vtkPolyDataMapper
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
vtkPolyDataMapper2D
  • Tcl
    • /Graphics/Testing/Tcl/glyph2D.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
    • /Rendering/Testing/Tcl/multiLineText.tcl
vtkPolyDataNormals
  • C++
    • /Parallel/Testing/Cxx/MPIGroups.cxx
  • Tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/extractVectors.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
    • /Graphics/Testing/Tcl/stripF.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl
    • /Hybrid/Testing/Tcl/cubeAxes.tcl
    • /IO/Testing/Tcl/dem.tcl
    • /Parallel/Testing/Tcl/TestPolyDataPieces.tcl
vtkPolyDataReader
  • Tcl
    • /Graphics/Testing/Tcl/deciFranFace.tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
    • /Graphics/Testing/Tcl/eleState.tcl
    • /Graphics/Testing/Tcl/fieldToPolyData.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
    • /Graphics/Testing/Tcl/stripF.tcl
    • /Hybrid/Testing/Tcl/bore.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
    • /Patented/Testing/Tcl/deciBrain.tcl
    • /Patented/Testing/Tcl/deciBrainErrors.tcl
    • /Patented/Testing/Tcl/sweptVtk.tcl
vtkPolyDataStreamer
  • Tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
vtkPolyDataToImageStencil
  • Tcl
    • /Hybrid/Testing/Tcl/TestImageStencilWithPolydata.tcl
vtkPolyDataWriter
  • Tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkPolyLine
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkPolyVertex
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/scalarColors.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkPolygon
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkPostScriptWriter
  • Tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
vtkProbeFilter
  • Tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkProcrustesAlignmentFilter
  • Tcl
    • /Hybrid/Testing/Tcl/TestProcrustes.tcl
vtkProgrammableAttributeDataFilter
  • Tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Rendering/Testing/Tcl/ScalarBar.tcl
    • /Rendering/Testing/Tcl/TestTiling.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkProgrammableDataObjectSource
  • Tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkProgrammableGlyphFilter
  • Tcl
    • /Graphics/Testing/Tcl/progGlyphs.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
vtkProgrammableSource
  • Tcl
    • /Graphics/Testing/Tcl/reconstructSurface.tcl
    • /Imaging/Testing/Tcl/reconstructSurface.tcl
vtkPropAssembly
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Rendering/Testing/Tcl/propAssembly.tcl
vtkProperty
  • C++
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
  • Tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
    • /Parallel/Testing/Tcl/TestExtrudePiece.tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkPyramid
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (Q..R)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

Q
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkQuad
  • C++
    • /Common/Testing/Cxx/otherCellArray.cxx
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Common/Testing/Tcl/otherInterp.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkQuadric
  • Tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/clipVolume.tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
    • /Graphics/Testing/Tcl/quadricCut.tcl
    • /Graphics/Testing/Tcl/scalarConn.tcl
vtkQuadricClustering
  • Tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
    • /Graphics/Testing/Tcl/TestQuadricClustering.tcl
vtkQuadricDecimation
  • Tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl

R
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkRIBExporter
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkRIBLight
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkRIBProperty
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkRTAnalyticSource
  • C++
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
vtkRayCaster
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkRearrangeFields
  • Tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
vtkRectilinearGrid
  • C++
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
vtkRectilinearGridGeometryFilter
  • C++
    • /Graphics/Testing/Cxx/RGrid.cxx
  • Tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
vtkRectilinearGridOutlineFilter
  • Tcl
    • /Parallel/Testing/Tcl/RectOutline.tcl
vtkRectilinearGridReader
  • C++
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Tcl
    • /Graphics/Testing/Tcl/dataSetSurfaceFilter.tcl
    • /Graphics/Testing/Tcl/geomFilter.tcl
vtkRecursiveDividingCubes
  • Tcl
    • /Graphics/Testing/Tcl/recursiveDC.tcl
vtkReflectionFilter
  • Tcl
    • /Graphics/Testing/Tcl/testReflect.tcl
vtkRegressionTestImage
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Imaging/Testing/Cxx/ImportExport.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
vtkRenderLargeImage
  • Tcl
    • /Hybrid/Testing/Tcl/largeImageOffset.tcl
    • /Hybrid/Testing/Tcl/largeImageParallel.tcl
vtkRenderWindow
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Graphics/Testing/Cxx/volProt.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
    • /Rendering/Testing/Cxx/otherCoordinate.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
vtkRenderWindowInteractor
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Graphics/Testing/Cxx/volProt.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
  • Python
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
vtkRenderer
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Graphics/Testing/Cxx/RGrid.cxx
    • /Graphics/Testing/Cxx/expCos.cxx
    • /Graphics/Testing/Cxx/volProt.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
    • /Rendering/Testing/Cxx/otherCoordinate.cxx
  • Python
    • /Graphics/Testing/Python/Cone.py
    • /Graphics/Testing/Python/glyphComb.py
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/Disk.tcl
    • /Graphics/Testing/Tcl/EnSight6Elements.tcl
    • /Graphics/Testing/Tcl/EnSightGoldElements.tcl
    • /Graphics/Testing/Tcl/ExtractTensors.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/Hyper.tcl
    • /Graphics/Testing/Tcl/KlineBottle.tcl
vtkRendererSource
  • Tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkReverseSense
  • Tcl
    • /Graphics/Testing/Tcl/reconstructSurface.tcl
    • /Imaging/Testing/Tcl/reconstructSurface.tcl
vtkRibbonFilter
  • Tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
vtkRotationalExtrusionFilter
  • Tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
vtkRuledSurfaceFilter
  • Python
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
  • Tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
vtkRungeKutta4
  • Python
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (S)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

S
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkSLCReader
  • Tcl
    • /Graphics/Testing/Tcl/contour2DAll.tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Imaging/Testing/Tcl/TestInPlaceFilter.tcl
    • /Patented/Testing/Tcl/contour2DAll.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
vtkSTLReader
  • Tcl
    • /Graphics/Testing/Tcl/dicer.tcl
    • /Graphics/Testing/Tcl/spatialRepAll.tcl
vtkSTLWriter
  • Tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkSampleFunction
  • Tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Filtering/Testing/Tcl/PerlinNoise.tcl
    • /Graphics/Testing/Tcl/FitEllipse.tcl
    • /Graphics/Testing/Tcl/clipVolume.tcl
    • /Graphics/Testing/Tcl/clipVolume2.tcl
    • /Graphics/Testing/Tcl/scalarConn.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
    • /Patented/Testing/Tcl/iceCream.tcl
    • /Patented/Testing/Tcl/nc.tcl
vtkScalarBarActor
  • Tcl
    • /Rendering/Testing/Tcl/ScalarBar.tcl
    • /Rendering/Testing/Tcl/TestTiling.tcl
vtkSelectPolyData
  • Tcl
    • /Graphics/Testing/Tcl/cutLoop.tcl
vtkSelectVisiblePoints
  • Tcl
    • /Rendering/Testing/Tcl/labeledContours.tcl
    • /Rendering/Testing/Tcl/labeledMesh.tcl
vtkShepardMethod
  • Tcl
    • /Graphics/Testing/Tcl/shepards.tcl
vtkShortArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherRectilinearGrid.cxx
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
vtkShrinkFilter
  • Tcl
    • /Graphics/Testing/Tcl/Delaunay3D.tcl
    • /Graphics/Testing/Tcl/subDivideTetra.tcl
    • /Graphics/Testing/Tcl/testDataSetTriangleFilter2.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
vtkShrinkPolyData
  • Tcl
    • /Graphics/Testing/Tcl/Delaunay2D.tcl
    • /Graphics/Testing/Tcl/Delaunay2DAlpha.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
vtkSimpleElevationFilter
  • Tcl
    • /IO/Testing/Tcl/TestPLYReadWrite.tcl
vtkSimpleImageFilterExample
  • Tcl
    • /Imaging/Testing/Tcl/TestSimpleImageExample.tcl
vtkSliceCubes
  • Tcl
    • /Patented/Testing/Tcl/genHead.tcl
vtkSmoothPolyDataFilter
  • Tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
vtkSocketCommunicator
  • C++
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx
vtkSocketController
  • C++
    • /Parallel/Testing/Cxx/SocketClient.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx
vtkSpatialRepresentationFilter
  • Tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
    • /Graphics/Testing/Tcl/spatialRepAll.tcl
vtkSphere
  • Tcl
    • /Filtering/Testing/Tcl/ImplicitSum.tcl
    • /Graphics/Testing/Tcl/dataSetSurfaceFilter.tcl
    • /Graphics/Testing/Tcl/geomFilter.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
    • /Imaging/Testing/Tcl/TestBlendStencil.tcl
    • /Imaging/Testing/Tcl/TestStencilWithFunction.tcl
    • /Patented/Testing/Tcl/iceCream.tcl
vtkSpherePuzzle
  • Tcl
    • /Graphics/Testing/Tcl/TestSpherePuzzle.tcl
    • /Graphics/Testing/Tcl/TestSpherePuzzleArrows.tcl
vtkSpherePuzzleArrows
  • Tcl
    • /Graphics/Testing/Tcl/TestSpherePuzzle.tcl
    • /Graphics/Testing/Tcl/TestSpherePuzzleArrows.tcl
vtkSphereSource
  • C++
    • /Graphics/Testing/Cxx/CellLocator.cxx
    • /Graphics/Testing/Cxx/FrustumClip.cxx
    • /Graphics/Testing/Cxx/Mace.cxx
    • /Graphics/Testing/Cxx/PointLocator.cxx
    • /Parallel/Testing/Cxx/MPIGroups.cxx
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/SelectionLoop.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/StreamPolyData.tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/TestQuadricClustering.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/cutLoop.tcl
    • /Graphics/Testing/Tcl/extractPolyData.tcl
    • /Graphics/Testing/Tcl/hull.tcl
    • /Graphics/Testing/Tcl/quadricCut.tcl
    • /Graphics/Testing/Tcl/scalarColors.tcl
    • /Graphics/Testing/Tcl/stereoDresdenMace.tcl
    • /Graphics/Testing/Tcl/subdividePointData.tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl
    • /Graphics/Testing/Tcl/triangularTCoords.tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
vtkSplitField
  • Tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
vtkStreamLine
  • Python
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
vtkStreamPoints
  • Tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
vtkStripper
  • C++
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/stripF.tcl
    • /Graphics/Testing/Tcl/warplens.tcl
vtkStructuredGrid
  • C++
    • /Common/Testing/Cxx/otherStructuredGrid.cxx
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Graphics/Testing/Tcl/CellDataToPointData.tcl
    • /Graphics/Testing/Tcl/TestStructuredGrid.tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
vtkStructuredGridGeometryFilter
  • Tcl
    • /Graphics/Testing/Tcl/TestStructuredGrid.tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
    • /Graphics/Testing/Tcl/polyConn.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
    • /IO/Testing/Tcl/Plot3DVectors.tcl
vtkStructuredGridOutlineFilter
  • Python
    • /Graphics/Testing/Python/streamComb.py
    • /Graphics/Testing/Python/streamSurface.py
    • /Graphics/Testing/Python/streamSurface2.py
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Graphics/Testing/Tcl/MultidimensionalSolution.tcl
    • /Graphics/Testing/Tcl/blankGrid.tcl
    • /Graphics/Testing/Tcl/combStreamers.tcl
    • /Graphics/Testing/Tcl/combStreamers2.tcl
    • /Graphics/Testing/Tcl/cursor3D.tcl
    • /Graphics/Testing/Tcl/extractVectors.tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
    • /Graphics/Testing/Tcl/polyConn.tcl
    • /Graphics/Testing/Tcl/probe.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/splitVectors.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl
    • /Patented/Testing/Tcl/TestGridSynchronizedTemplates3D.tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkStructuredGridReader
  • Tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
    • /Graphics/Testing/Tcl/officeStreamPoints.tcl
vtkStructuredGridWriter
  • Tcl
    • /Graphics/Testing/Tcl/fieldToSGrid.tcl
vtkStructuredPoints
  • Tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
vtkStructuredPointsReader
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Tcl
    • /Graphics/Testing/Tcl/contour3DAll.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/recursiveDC.tcl
    • /Patented/Testing/Tcl/dcubes.tcl
    • /Patented/Testing/Tcl/imageMCAll.tcl
    • /Patented/Testing/Tcl/sync3dAll.tcl
vtkSubPixelPositionEdgels
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
vtkSubdivideTetra
  • Tcl
    • /Graphics/Testing/Tcl/subDivideTetra.tcl
vtkSuperquadricSource
  • Tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/progGlyphs.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Hybrid/Testing/Tcl/TestICPTransform.tcl
vtkSurfaceReconstructionFilter
  • Tcl
    • /Graphics/Testing/Tcl/reconstructSurface.tcl
    • /Imaging/Testing/Tcl/reconstructSurface.tcl
vtkSweptSurface
  • Tcl
    • /Patented/Testing/Tcl/nc.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
    • /Patented/Testing/Tcl/sweptVtk.tcl
vtkSynchronizedTemplates3D
  • Tcl
    • /Patented/Testing/Tcl/sync3dAll.tcl

Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (T)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

T
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkTIFFReader
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
    • /Imaging/Testing/Tcl/TestAllBlends.tcl
    • /Imaging/Testing/Tcl/TestAllBlendsFloat.tcl
    • /Imaging/Testing/Tcl/TestAllMaskBits.tcl
    • /Parallel/Testing/Tcl/TestPImageWriter.tcl
    • /Rendering/Testing/Tcl/ImageActor.tcl
vtkTIFFWriter
  • Tcl
    • /IO/Testing/Tcl/TestImageWriters.tcl
vtkTclUtil
  • Tcl
    • /Common/Testing/Tcl/otherInterp.tcl
vtkTensorGlyph
  • Tcl
    • /Graphics/Testing/Tcl/TenEllip.tcl
vtkTestUtilities
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
    • /Imaging/Testing/Cxx/ImportExport.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Parallel/Testing/Cxx/SocketServer.cxx
vtkTetra
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/subDivideTetra.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkTextMapper
  • Tcl
    • /IO/Testing/Tcl/Plot3DScalars.tcl
    • /IO/Testing/Tcl/Plot3DVectors.tcl
    • /Rendering/Testing/Tcl/multiLineText.tcl
vtkTextSource
  • Tcl
    • /Hybrid/Testing/Tcl/text.tcl
vtkTexture
  • Tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestButtonSource.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
    • /Graphics/Testing/Tcl/deciFranFace.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/quadricCut.tcl
    • /Graphics/Testing/Tcl/socbal.tcl
    • /Graphics/Testing/Tcl/triangularTCoords.tcl
    • /Graphics/Testing/Tcl/triangularTexture.tcl
    • /Hybrid/Testing/Tcl/earth.tcl
    • /Imaging/Testing/Tcl/resampledTexture.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/rendererSource.tcl
vtkTextureMapToCylinder
  • Tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
vtkTextureMapToPlane
  • Tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
vtkTextureMapToSphere
  • Tcl
    • /Graphics/Testing/Tcl/socbal.tcl
vtkTexturedSphereSource
  • Tcl
    • /Hybrid/Testing/Tcl/earth.tcl
vtkThinPlateSplineTransform
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp.tcl
    • /Hybrid/Testing/Tcl/TestThinPlateWarp3D.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl
vtkThreadedController
  • C++
    • /Parallel/Testing/Cxx/ThreadedCommunicator.cxx
vtkThreshold
  • Tcl
    • /Graphics/Testing/Tcl/Canny.tcl
    • /Graphics/Testing/Tcl/subPixelPositionMin.tcl
vtkThresholdPoints
  • Tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
vtkTimeStamp
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkTimerLog
  • C++
    • /Common/Testing/Cxx/otherTimerLog.cxx
    • /Parallel/Testing/Cxx/ParallelIso.cxx
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
vtkTkImageViewerWidget
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
vtkTkImageWindowWidget
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkTkRenderWidget
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
    • /Filtering/Testing/Tcl/squadViewer.tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
vtkTransform
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
  • Tcl
    • /Common/Testing/Tcl/otherInterp.tcl
    • /Graphics/Testing/Tcl/Delaunay2DTransform.tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
    • /Graphics/Testing/Tcl/SliceOrder.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TransformConcatenation.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
    • /Graphics/Testing/Tcl/extractPolyData.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestProcrustes.tcl
    • /Hybrid/Testing/Tcl/banana.tcl
vtkTransformCollection
  • Tcl
    • /Patented/Testing/Tcl/nc.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
    • /Patented/Testing/Tcl/sweptVtk.tcl
vtkTransformFilter
  • Tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/testQuadricDecimation.tcl
    • /Hybrid/Testing/Tcl/banana.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
vtkTransformPolyDataFilter
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
  • Tcl
    • /Graphics/Testing/Tcl/MatrixToTransform.tcl
    • /Graphics/Testing/Tcl/OBBCylinder.tcl
    • /Graphics/Testing/Tcl/TestRuledSurface.tcl
    • /Graphics/Testing/Tcl/TransformConcatenation.tcl
    • /Graphics/Testing/Tcl/TransformCoverage.tcl
    • /Graphics/Testing/Tcl/TransformPolyData.tcl
    • /Graphics/Testing/Tcl/cowHair.tcl
    • /Graphics/Testing/Tcl/cowHair2.tcl
    • /Graphics/Testing/Tcl/probeComb.tcl
    • /Graphics/Testing/Tcl/progGlyphsBySource.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Hybrid/Testing/Tcl/TestProcrustes.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl
    • /Hybrid/Testing/Tcl/camera.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
vtkTransformTextureCoords
  • Tcl
    • /Graphics/Testing/Tcl/cylMap.tcl
vtkTransformToGrid
  • Tcl
    • /Hybrid/Testing/Tcl/TestGridWarp3D.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpCubic.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpLinear.tcl
    • /Hybrid/Testing/Tcl/TestGridWarpNearest.tcl
    • /Hybrid/Testing/Tcl/WarpPolyData.tcl
vtkTreeComposite
  • C++
    • /Parallel/Testing/Cxx/MPIGroups.cxx
vtkTriangle
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Common/Testing/Tcl/otherInterp.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkTriangleFilter
  • C++
    • /Rendering/Testing/Cxx/TimeRenderer.cxx
    • /Rendering/Testing/Cxx/TimeRenderer2.cxx
  • Tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestTriangleFilter.tcl
    • /Graphics/Testing/Tcl/capCow.tcl
    • /Graphics/Testing/Tcl/capSphere.tcl
    • /Graphics/Testing/Tcl/clipArt.tcl
    • /Graphics/Testing/Tcl/eleState.tcl
    • /Graphics/Testing/Tcl/motor.tcl
    • /Graphics/Testing/Tcl/smoothMeshOnMesh.tcl
    • /Graphics/Testing/Tcl/warplens.tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
    • /Hybrid/Testing/Tcl/imageToPolyData.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
    • /Parallel/Testing/Tcl/TestBranchExtentTranslator.tcl
    • /Patented/Testing/Tcl/deciBrain.tcl
    • /Patented/Testing/Tcl/deciBrainErrors.tcl
vtkTriangleStrip
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkTriangularTCoords
  • Tcl
    • /Graphics/Testing/Tcl/triangularTCoords.tcl
vtkTriangularTexture
  • Tcl
    • /Graphics/Testing/Tcl/triangularTCoords.tcl
    • /Graphics/Testing/Tcl/triangularTexture.tcl
vtkTubeFilter
  • Python
    • /Graphics/Testing/Python/tubeComb.py
  • Tcl
    • /Filtering/Testing/Tcl/CSpline.tcl
    • /Filtering/Testing/Tcl/KSpline.tcl
    • /Filtering/Testing/Tcl/closedSplines.tcl
    • /Graphics/Testing/Tcl/TestGraphLayoutFilter.tcl
    • /Graphics/Testing/Tcl/constrainedDelaunay.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
    • /Hybrid/Testing/Tcl/bore.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl

Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class To Tests (U..X)
  • 482 class(es) in 338 file(s) from directories matching ^Testing$ on Mon Mar 25 01:05:30 2002
  • 4 parser(s) : [Java, Python, C++, Tcl]
  • at most 20 file(s) per parser
Version:
0.81
Author:
doc_class2example.pl, by Sebastien Barre
Legend:
  • : the corresponding file uses data files.
  • : the corresponding file has a baseline picture (click to display)

U
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkUGFacetReader
  • Tcl
    • /Patented/Testing/Tcl/nc.tcl
    • /Patented/Testing/Tcl/sweepAuto.tcl
vtkUnsignedCharArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Common/Testing/Cxx/otherCellTypes.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestTriangleFilter.tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Graphics/Testing/Tcl/scalarColors.tcl
    • /Graphics/Testing/Tcl/schwarz.tcl
vtkUnsignedIntArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
vtkUnsignedLongArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
    • /Parallel/Testing/Cxx/GenericCommunicator.cxx
vtkUnsignedShortArray
  • C++
    • /Common/Testing/Cxx/otherArrays.cxx
vtkUnstructuredGrid
  • C++
    • /Parallel/Testing/Cxx/SocketClient.cxx
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllPolygons.tcl
    • /Graphics/Testing/Tcl/PolyDataMapperAllWireframe.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Graphics/Testing/Tcl/scalarColors.tcl
    • /Graphics/Testing/Tcl/subDivideTetra.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkUnstructuredGridReader
  • C++
    • /Parallel/Testing/Cxx/SocketServer.cxx
  • Tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Rendering/Testing/Tcl/TestParallelCoordinates.tcl

V
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkVRMLExporter
  • Tcl
    • /Rendering/Testing/Tcl/cells.tcl
vtkVRMLImporter
  • Tcl
    • /Hybrid/Testing/Tcl/VRMLImporter.tcl
vtkVectorDot
  • Tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
vtkVectorNorm
  • Tcl
    • /Patented/Testing/Tcl/headBone.tcl
vtkVectorText
  • Tcl
    • /Graphics/Testing/Tcl/extrudeCopyCD.tcl
    • /Hybrid/Testing/Tcl/3DMorph.tcl
    • /Hybrid/Testing/Tcl/MassProperties.tcl
    • /Hybrid/Testing/Tcl/clipHex.tcl
    • /Hybrid/Testing/Tcl/clipPyramid.tcl
    • /Hybrid/Testing/Tcl/clipTet.tcl
    • /Hybrid/Testing/Tcl/clipWedge.tcl
    • /Hybrid/Testing/Tcl/financialField2.tcl
    • /Hybrid/Testing/Tcl/financialField3.tcl
    • /Hybrid/Testing/Tcl/text.tcl
    • /Patented/Testing/Tcl/financialField.tcl
vtkVertex
  • C++
    • /Common/Testing/Cxx/ObjectFactory.cxx
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkViewport
  • C++
    • /Rendering/Testing/Cxx/otherCoordinate.cxx
vtkVolume
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkVolume16Reader
  • Tcl
    • /Graphics/Testing/Tcl/clipImage.tcl
    • /Graphics/Testing/Tcl/edgePoints.tcl
    • /Graphics/Testing/Tcl/skinOrder.tcl
    • /Imaging/Testing/Tcl/resampledTexture.tcl
    • /Patented/Testing/Tcl/TestImageMarchingCubes.tcl
    • /Patented/Testing/Tcl/TestMarchingSquares.tcl
    • /Patented/Testing/Tcl/genHead.tcl
    • /Patented/Testing/Tcl/headBone.tcl
    • /Patented/Testing/Tcl/mcubes.tcl
    • /Rendering/Testing/Tcl/labeledContours.tcl
vtkVolumeProperty
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkVolumeRayCastCompositeFunction
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
vtkVolumeRayCastIsosurfaceFunction
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
vtkVolumeRayCastMIPFunction
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
vtkVolumeRayCastMapper
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Hybrid/Testing/Tcl/cursor3D.tcl
    • /Rendering/Testing/Tcl/volRCClipPlanes.tcl
    • /Rendering/Testing/Tcl/volRCCropRegions.tcl
    • /Rendering/Testing/Tcl/volRCRotateClip.tcl
vtkVolumeTextureMapper2D
  • C++
    • /Graphics/Testing/Cxx/volProt.cxx
  • Tcl
    • /Rendering/Testing/Tcl/volTM2DCropRegions.tcl
    • /Rendering/Testing/Tcl/volTM2DRotateClip.tcl
vtkVoxel
  • C++
    • /Common/Testing/Cxx/otherCellBoundaries.cxx
    • /Common/Testing/Cxx/otherCellDerivatives.cxx
    • /Common/Testing/Cxx/otherCellPosition.cxx
  • Tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkVoxelContoursToSurfaceFilter
  • Tcl
    • /Graphics/Testing/Tcl/contoursToSurface.tcl
vtkVoxelModeller
  • Tcl
    • /Imaging/Testing/Tcl/voxelModel.tcl

W
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkWarpLens
  • Tcl
    • /Graphics/Testing/Tcl/warplens.tcl
vtkWarpScalar
  • C++
    • /Graphics/Testing/Cxx/expCos.cxx
  • Tcl
    • /Graphics/Testing/Tcl/mergeFilter.tcl
    • /IO/Testing/Tcl/dem.tcl
vtkWarpTo
  • Tcl
    • /Hybrid/Testing/Tcl/camera.tcl
vtkWarpVector
  • Tcl
    • /Graphics/Testing/Tcl/dispPlot.tcl
    • /Graphics/Testing/Tcl/extractUGrid.tcl
    • /Graphics/Testing/Tcl/fieldToRGrid.tcl
    • /Graphics/Testing/Tcl/fieldToUGrid.tcl
    • /Graphics/Testing/Tcl/rectGrid.tcl
    • /Graphics/Testing/Tcl/smoothCyl.tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
vtkWedge
  • Tcl
    • /Common/Testing/Tcl/otherInterp.tcl
    • /Graphics/Testing/Tcl/TestCellDerivs.tcl
    • /Graphics/Testing/Tcl/contourCells.tcl
    • /Rendering/Testing/Tcl/cells.tcl
    • /Rendering/Testing/Tcl/pickCells.tcl
vtkWeightedTransformFilter
  • Tcl
    • /Hybrid/Testing/Tcl/banana.tcl
vtkWin32OutputWindow
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkWin32VideoSource
  • Tcl
    • /Common/Testing/Tcl/TestEmptyInput.tcl
vtkWindowToImageFilter
  • Tcl
    • /Common/Testing/Tcl/rtImageTest.tcl
    • /Imaging/Testing/Tcl/TestMapToWindowLevelColors.tcl
    • /Rendering/Testing/Tcl/TestTiling.tcl
vtkWindowedSincPolyDataFilter
  • Tcl
    • /Graphics/Testing/Tcl/smoothCyl2.tcl
    • /IO/Testing/Tcl/TestPolygonWriters.tcl
vtkWorldPointPicker
  • Tcl
    • /Rendering/Testing/Tcl/pickCells.tcl

X
Navigation:
[3 | A | B | C | D | E | F | G | H | I | J | K | L | M | O | P | Q | R | S | T | U | V | W | X]
vtkXMLFileOutputWindow
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkXMesaRenderWindow
  • Tcl
    • /Graphics/Testing/Tcl/MesaCone.tcl
vtkXOpenGLRenderWindow
  • Tcl
    • /Common/Testing/Tcl/TestSetGet.tcl
vtkXYPlotActor
  • Tcl
    • /Hybrid/Testing/Tcl/xyPlot.tcl
    • /Hybrid/Testing/Tcl/xyPlot2.tcl
    • /Hybrid/Testing/Tcl/xyPlot3.tcl
    • /Hybrid/Testing/Tcl/xyPlot4.tcl

Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Class to Events (I..X)
  • 747 implementation file(s) returning 29 word(s) for 25 classe(es) on Mon Mar 25 01:04:34 2002
  • 25 file(s) updated
Version:
0.2
Author:
doc_codematch.pl, by Sebastien Barre

I
Navigation:
[I | M | O | P | R | S | W | X]
vtkImageDataStreamer
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkImageMarchingCubes
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkImager
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkInputPort
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkInteractorStyle
  • vtkCommand::ConfigureEvent, vtkCommand::EnterEvent, vtkCommand::KeyPressEvent, vtkCommand::LeaveEvent, vtkCommand::LeftButtonPressEvent, vtkCommand::LeftButtonReleaseEvent, vtkCommand::MiddleButtonPressEvent, vtkCommand::MiddleButtonReleaseEvent, vtkCommand::MouseMoveEvent, vtkCommand::RightButtonPressEvent, vtkCommand::RightButtonReleaseEvent, vtkCommand::TimerEvent
vtkInteractorStyleImage
  • vtkCommand::WindowLevelEvent
vtkInteractorStyleUser
  • vtkCommand::CharEvent, vtkCommand::ConfigureEvent, vtkCommand::EnterEvent, vtkCommand::KeyPressEvent, vtkCommand::KeyReleaseEvent, vtkCommand::LeaveEvent, vtkCommand::LeftButtonPressEvent, vtkCommand::LeftButtonReleaseEvent, vtkCommand::MiddleButtonPressEvent, vtkCommand::MiddleButtonReleaseEvent, vtkCommand::MouseMoveEvent, vtkCommand::RightButtonPressEvent, vtkCommand::RightButtonReleaseEvent, vtkCommand::TimerEvent, vtkCommand::UserEvent

M
Navigation:
[I | M | O | P | R | S | W | X]
vtkMassProperties
  • vtkCommand::EndEvent, vtkCommand::StartEvent

O
Navigation:
[I | M | O | P | R | S | W | X]
vtkObject
  • vtkCommand::DeleteEvent, vtkCommand::ModifiedEvent
vtkOpenGLPolyDataMapper
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkOutputPort
  • vtkCommand::EndEvent, vtkCommand::StartEvent

P
Navigation:
[I | M | O | P | R | S | W | X]
vtkPicker
  • vtkCommand::EndPickEvent, vtkCommand::PickEvent, vtkCommand::StartPickEvent
vtkProcessObject
  • vtkCommand::ProgressEvent
vtkProgrammableSource
  • vtkCommand::EndEvent, vtkCommand::StartEvent
vtkProp
  • vtkCommand::PickEvent
vtkPropPicker
  • vtkCommand::EndPickEvent, vtkCommand::PickEvent, vtkCommand::StartPickEvent

R
Navigation:
[I | M | O | P | R | S | W | X]
vtkRenderWindow
  • vtkCommand::AbortCheckEvent, vtkCommand::EndEvent, vtkCommand::StartEvent
vtkRenderWindowInteractor
  • vtkCommand::EndPickEvent, vtkCommand::ExitEvent, vtkCommand::StartPickEvent, vtkCommand::UserEvent
vtkRenderer
  • vtkCommand::EndEvent, vtkCommand::ResetCameraClippingRangeEvent, vtkCommand::ResetCameraEvent, vtkCommand::StartEvent

S
Navigation:
[I | M | O | P | R | S | W | X]
vtkSource
  • vtkCommand::EndEvent, vtkCommand::SetOutputEvent, vtkCommand::StartEvent

W
Navigation:
[I | M | O | P | R | S | W | X]
vtkWin32RenderWindowInteractor
  • vtkCommand::CharEvent, vtkCommand::ConfigureEvent, vtkCommand::EnterEvent, vtkCommand::ExitEvent, vtkCommand::KeyPressEvent, vtkCommand::KeyReleaseEvent, vtkCommand::LeaveEvent, vtkCommand::LeftButtonPressEvent, vtkCommand::LeftButtonReleaseEvent, vtkCommand::MiddleButtonPressEvent, vtkCommand::MiddleButtonReleaseEvent, vtkCommand::MouseMoveEvent, vtkCommand::RightButtonPressEvent, vtkCommand::RightButtonReleaseEvent, vtkCommand::StartEvent, vtkCommand::TimerEvent
vtkWorldPointPicker
  • vtkCommand::EndPickEvent, vtkCommand::StartPickEvent
vtkWriter
  • vtkCommand::EndEvent, vtkCommand::StartEvent

X
Navigation:
[I | M | O | P | R | S | W | X]
vtkXRenderWindowInteractor
  • vtkCommand::CharEvent, vtkCommand::ConfigureEvent, vtkCommand::EnterEvent, vtkCommand::KeyPressEvent, vtkCommand::KeyReleaseEvent, vtkCommand::LeaveEvent, vtkCommand::LeftButtonPressEvent, vtkCommand::LeftButtonReleaseEvent, vtkCommand::MiddleButtonPressEvent, vtkCommand::MiddleButtonReleaseEvent, vtkCommand::MouseMoveEvent, vtkCommand::RightButtonPressEvent, vtkCommand::RightButtonReleaseEvent, vtkCommand::StartEvent, vtkCommand::TimerEvent
vtkXRenderWindowTclInteractor
  • vtkCommand::CharEvent, vtkCommand::EnterEvent, vtkCommand::LeftButtonPressEvent, vtkCommand::LeftButtonReleaseEvent, vtkCommand::MiddleButtonPressEvent, vtkCommand::MiddleButtonReleaseEvent, vtkCommand::MouseMoveEvent, vtkCommand::RightButtonPressEvent, vtkCommand::RightButtonReleaseEvent, vtkCommand::StartEvent, vtkCommand::TimerEvent
Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Event to Classes (A..W)
  • 747 implementation file(s) returning 29 word(s) for 25 classe(es) on Mon Mar 25 01:04:34 2002
  • 25 file(s) updated
Version:
0.2
Author:
doc_codematch.pl, by Sebastien Barre

A
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::AbortCheckEvent
  • vtkRenderWindow

C
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::CharEvent
  • vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::ConfigureEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor

D
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::DeleteEvent
  • vtkObject

E
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::EndEvent
  • vtkImageDataStreamer, vtkImageMarchingCubes, vtkImager, vtkInputPort, vtkMassProperties, vtkOpenGLPolyDataMapper, vtkOutputPort, vtkProgrammableSource, vtkRenderWindow, vtkRenderer, vtkSource, vtkWriter
vtkCommand::EndPickEvent
  • vtkPicker, vtkPropPicker, vtkRenderWindowInteractor, vtkWorldPointPicker
vtkCommand::EnterEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::ExitEvent
  • vtkRenderWindowInteractor, vtkWin32RenderWindowInteractor

K
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::KeyPressEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor
vtkCommand::KeyReleaseEvent
  • vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor

L
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::LeaveEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor
vtkCommand::LeftButtonPressEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::LeftButtonReleaseEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor

M
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::MiddleButtonPressEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::MiddleButtonReleaseEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::ModifiedEvent
  • vtkObject
vtkCommand::MouseMoveEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor

P
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::PickEvent
  • vtkPicker, vtkProp, vtkPropPicker
vtkCommand::ProgressEvent
  • vtkProcessObject

R
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::ResetCameraClippingRangeEvent
  • vtkRenderer
vtkCommand::ResetCameraEvent
  • vtkRenderer
vtkCommand::RightButtonPressEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::RightButtonReleaseEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor

S
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::SetOutputEvent
  • vtkSource
vtkCommand::StartEvent
  • vtkImageDataStreamer, vtkImageMarchingCubes, vtkImager, vtkInputPort, vtkMassProperties, vtkOpenGLPolyDataMapper, vtkOutputPort, vtkProgrammableSource, vtkRenderWindow, vtkRenderer, vtkSource, vtkWin32RenderWindowInteractor, vtkWriter, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor
vtkCommand::StartPickEvent
  • vtkPicker, vtkPropPicker, vtkRenderWindowInteractor, vtkWorldPointPicker

T
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::TimerEvent
  • vtkInteractorStyle, vtkInteractorStyleUser, vtkWin32RenderWindowInteractor, vtkXRenderWindowInteractor, vtkXRenderWindowTclInteractor

U
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::UserEvent
  • vtkInteractorStyleUser, vtkRenderWindowInteractor

W
Navigation:
[A | C | D | E | K | L | M | P | R | S | T | U | W]
vtkCommand::WindowLevelEvent
  • vtkInteractorStyleImage
Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (A..b)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

A
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
A-Z
  • vtkVectorText (1)
ACM
  • vtkButterflySubdivisionFilter (1), vtkLoopSubdivisionFilter (1), vtkRungeKutta45 (1)
ALOG
  • vtkMPIEventLog (1)
ANL
  • vtkMPIEventLog (1)
ANSI
  • vtkSystemIncludes (6)
API
  • vtkAbstractPicker (3), vtkCell3D (3), vtkAbstractPropPicker (2), vtkHexahedron (2), vtkImageIterateFilter (2), vtkPyramid (2), vtkQuadraticEdge (2), vtkTetra (2), vtkVoxel (2), vtkWedge (2), [...]
AWT
  • vtkJavaAwt (3)

B
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
BCB
  • vtkQuartzRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2)
BMP
  • vtkBMPReader (5), vtkBMPWriter (2)
BMRT
  • vtkRIBExporter (2)
BNF
  • vtkVRML (1), vtkVRMLImporter (1)
BSD
  • vtkSocketCommunicator (1)
BTX
  • vtkMatrix4x4 (10), vtkMultiProcessController (5), vtkImageConvolve (4), vtkAbstractTransform (3), vtkDataSetAttributes (3), vtkImageFourierFilter (3), vtkInstantiator (3), vtkMergeFields (3), vtkMultiThreader (3), vtkOBBTree (3), [...]
BYU
  • vtkBYUReader (2), vtkBYUWriter (2)

C
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
CGM
  • vtkCGMWriter (7), vtkImageToPolyDataFilter (1)
CLOG
  • vtkMPIEventLog (1)
CONTAINES
  • vtkMPIController (1)
CPU
  • vtkTimerLog (1)
CRV
  • vtkCriticalSection (1)

D
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
DCF
  • vtkMILVideoSource (1)
DEF
  • vtkVRMLImporter (3)
DEM
  • vtkDEMReader (10)

E
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
EDIT
  • vtkWin32OutputWindow (1)
EDS
  • vtkUGFacetReader (1)
ENG
  • vtkTreeComposite (1)
EOF
  • vtkEnSightGoldBinaryReader (4), vtkEnSightGoldReader (4), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkEnSightReader (2)
ETX
  • vtkMatrix4x4 (10), vtkMultiProcessController (5), vtkImageConvolve (4), vtkAbstractTransform (3), vtkDataSetAttributes (3), vtkImageFourierFilter (3), vtkInstantiator (3), vtkMergeFields (3), vtkMultiThreader (3), vtkOBBTree (3), [...]

F
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
FFT
  • vtkImageFFT (1), vtkImageRFFT (1), vtkImageFourierCenter (1)
FITNESS
  • vtkPLY (1)

G
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
GLU
  • vtkGLUTesselatorTriangleFilter (1)
GUI
  • vtkBMPReader (1), vtkImageReader2 (1), vtkJPEGReader (1), vtkOverrideInformation (1), vtkPNGReader (1), vtkProcessObject (1), vtkTIFFReader (1)

H
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
HREF
  • vtkDEMReader (1)
HSV
  • vtkImageHSVToRGB (1), vtkImageRGBToHSV (1), vtkColorTransferFunction (2)
HWND
  • vtkWin32ImageWindow (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1)

I
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
IBM
  • vtkWindowedSincPolyDataFilter (1)
ICP
  • vtkIterativeClosestPointTransform (4)
IEEE
  • vtkTriangularTCoords (1), vtkTriangularTexture (1)
III
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
IJG
  • vtkJPEGWriter (2)
ISBN
  • vtkRIBExporter (1)

J
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
JAWT
  • vtkJavaAwt (3)

L
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
LCD
  • vtkInteractorStyle (1)
LEAD
  • vtkMPIController (1)
LIMITATION
  • vtkPLY (1)
LOD
  • vtkLODProp3D (31), vtkLODActor (5), vtkHull (1), vtkProp (1), vtkRenderWindowInteractor (1)
LUT
  • vtkImageToPolyDataFilter (1)

M
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
MERCHANTABILITY
  • vtkPLY (1)
MFC
  • vtkQuartzRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkWin32ImageWindow (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1)
MIL
  • vtkMILVideoSource (2)
MIP
  • vtkVolumeRayCastFunction (1)
MIT
  • vtkMPIController (1)
MOVIE
  • vtkBYUReader (2), vtkBYUWriter (2)
MPE
  • vtkMPIEventLog (2)
MPI
  • vtkMPIController (11), vtkMPICommunicator (7), vtkMPIEventLog (2), vtkMPIGroup (2), vtkMultiProcessController (4), vtkCommunicator (1)
MUNC
  • vtkMassProperties (1)

N
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
NASA
  • vtkPLOT3DReader (1)
NSI
  • vtkMassProperties (1)
NURBS
  • vtkExplicitCell (1)

O
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
OBB
  • vtkOBBTree (28), vtkOBBDicer (1), vtkLocator (1)
OBJ
  • vtkOBJExporter (1)
OOGL
  • vtkOOGLExporter (2)

P
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
PAN
  • vtkInteractorStyleUnicam (2)
PLY
  • vtkPLY (15), vtkPLYWriter (6), vtkPLYReader (2), vtkHeap (1)
PNG
  • vtkPNGReader (3), vtkPNGWriter (2)
PNM
  • vtkPNMWriter (2), vtkPNMReader (1)
POP
  • vtkPOPReader (1)
POSIX
  • vtkMultiThreader (1)
PPM
  • vtkImageWindow (2)
PRE
  • vtkCoordinate (2)

R
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
R-G-B
  • vtkFieldDataToAttributeDataFilter (1)
RFFT
  • vtkImageRFFT (1)
RGB
  • vtkImageHSVToRGB (1), vtkImageQuantizeRGBToIndex (1), vtkImageRGBToHSV (1), vtkColorTransferFunction (5), vtkCGMWriter (2), vtkScalarsToColors (2), vtkVolumeProperty (2), vtkFieldDataToAttributeDataFilter (1), vtkImageBlend (1), vtkImageImport (1), [...]
RGBARGBA
  • vtkMesaImageWindow (1), vtkMesaRenderWindow (1), vtkOpenGLImageWindow (1), vtkOpenGLRenderWindow (1), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkWin32OpenGLImageWindow (1)
RGBARGBARGBA
  • vtkRenderWindow (1)
RGBRGB
  • vtkMesaImageWindow (1), vtkMesaRenderWindow (1), vtkOpenGLImageWindow (1), vtkOpenGLRenderWindow (1), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkWin32OpenGLImageWindow (1)
RGBRGBRGB
  • vtkRenderWindow (1), vtkWindow (1), vtkXImageWindow (1)
RGBV
  • vtkVolumeProperty (1)
RIB
  • vtkRIBExporter (4)
RIP
  • vtkRIBLight (1), vtkRIBProperty (1)
RMI
  • vtkMultiProcessController (7), vtkOutputPort (2), vtkCompositeManager (1), vtkMPIController (1), vtkThreadedController (1)
RMS
  • vtkIterativeClosestPointTransform (1)

S
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
SGI
  • vtkMultiThreader (2)
SIGGRAPH
  • vtkButterflySubdivisionFilter (1), vtkLoopSubdivisionFilter (1)
SLC
  • vtkSLCReader (5)
SLOG
  • vtkMPIEventLog (1)
STL
  • vtkSystemIncludes (1)
SVD
  • vtkMath (1)

T
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
TAG
  • vtkInputPort (1), vtkOutputPort (1)
TCL
  • vtkXRenderWindowTclInteractor (1)
TIFF
  • vtkTIFFReader (3), vtkTIFFWriter (2)

U
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
USERDEFINED
  • vtkCoordinate (1)

V
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
VAX
  • vtkImageReader2 (2), vtkMCubesReader (2), vtkParticleReader (2), vtkVolume16Reader (2), vtkSTLReader (1), vtkSTLWriter (1)
VCR
  • vtkMILVideoSource (3), vtkWin32VideoSource (3), vtkVideoSource (1)
VOI
  • vtkExtractVOI (3), vtkExtractGrid (3), vtkImageReader (1)
VRML
  • vtkVRMLImporter (8), vtkVRMLExporter (4), vtkVRML (1), vtkHeap (1)
VTK
  • vtkImageImport (8), vtkObject (6), vtkAbstractTransform (4), vtkIdentityTransform (4), vtkInstantiator (4), vtkLinearTransform (4), vtkObjectFactory (3), vtkPythonUtil (3), vtkSystemIncludes (3), vtkVRMLImporter (3), [...]

X
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
XML
  • vtkXMLParser (8), vtkXMLFileOutputWindow (5)
XXX
  • vtkInteractorStyleUnicam (1)
XYZ
  • vtkPLOT3DReader (1)

a
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
ability
  • vtkImplicitFunction (1), vtkMapper (1), vtkParallelCoordinatesActor (1), vtkPriorityQueue (1), vtkProgrammableDataObjectSource (1), vtkProgrammableSource (1), vtkScalarBarActor (1), vtkStructuredGrid (1), vtkXYPlotActor (1)
abort (aborted, aborts)
  • vtkCommand (1), vtkDataObjectToDataSetFilter (1), vtkLODProp3D (1), vtkMPIEventLog (1), vtkObject (1), vtkProp (1), vtkQuartzRenderWindow (1), vtkRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1)
absolute
  • vtkHyperStreamline (2), vtkIterativeClosestPointTransform (2), vtkWarpTo (2), vtkCleanPolyData (1), vtkCoordinate (1), vtkImplicitBoolean (1), vtkLocator (1), vtkPDataSetWriter (1), vtkPlanes (1), vtkStreamPoints (1)
abstact
  • vtkCommunicator (1)
abstract
  • vtkAbstractMapper (2), vtkAbstractMapper3D (2), vtkAbstractPropPicker (2), vtkAbstractList (1), vtkAbstractPicker (1), vtkDataSetToDataSetFilter (5), vtkPointSetToPointSetFilter (5), vtkExtractVectorComponents (3), vtkCastToConcrete (2), vtkCell (2), [...]
academic
  • vtkMatrix4x4 (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
accelerate (acceleration)
  • vtkContourFilter (3), vtkContourGrid (2), vtkInteractorStyleFlight (2), vtkMarchingContourFilter (2), vtkSimpleScalarTree (2), vtkAbstractPicker (1), vtkCellPicker (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleJoystickCamera (1), vtkKitwareContourFilter (1), [...]
accelerator
  • vtkInteractorStyleFlight (1)
accept (accepted)
  • vtkDataObjectSource (1), vtkMultiThreader (1), vtkOutputPort (1), vtkProcessObject (1), vtkRIBExporter (1)
acceptable
  • vtkMapper (1)
access (accesses, accessing)
  • vtkCellTypes (3), vtkGenericCell (3), vtkImageData (2), vtkImageImport (2), vtkLODProp3D (2), vtkNonLinearCell (2), vtkPolyData (2), vtkScalarTree (2), vtkTkImageViewerWidget (2), vtkTkImageWindowWidget (2), [...]
accessor
  • vtkQuartzWindow (1)
accommodate
  • vtkSweptSurface (1)
accompanying
  • vtkImageChangeInformation (1)
accomplish (accomplished)
  • vtkThreadedController (2), vtkCellArray (1), vtkExtractVectorComponents (1), vtkLODActor (1)
accord
  • vtkWarpLens (1)
accordingly
  • vtkTransform (2), vtkAbstractTransform (1), vtkGeneralTransform (1), vtkPerspectiveTransform (1)
account
  • vtkPipelineSize (2), vtkAbstractTransform (1), vtkBandedPolyDataContourFilter (1), vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1), vtkGeneralTransform (1), vtkMCubesReader (1), vtkPerspectiveTransform (1), vtkTransform (1), vtkXYPlotActor (1)
accumulate (accumulated, accumulating, accumulation)
  • vtkImageAccumulate (1), vtkDecimatePro (6), vtkImplicitSelectionLoop (2), vtkQuadricClustering (2), vtkGaussianSplatter (1), vtkXYPlotActor (1)
accurate (accuracy)
  • vtkDEMReader (2), vtkDividingCubes (1), vtkEncodedGradientShader (1), vtkImageData (1), vtkImplicitSum (1), vtkMath (1), vtkProp (1), vtkRecursiveDividingCubes (1), vtkVolumeRayCastMapper (1)
ache
  • vtkCompositeManager (1)
achieve
  • vtkTextureMapToPlane (1), vtkVolumeRayCastMapper (1), vtkWindowLevelLookupTable (1)
acquired
  • vtkAbstractTransform (1)
acquisition
  • vtkVideoSource (1)
actally
  • vtkQuartzTextMapper (1), vtkWin32OpenGLTextMapper (1), vtkXMesaTextMapper (1), vtkXOpenGLTextMapper (1)
actions
  • vtkInteractorStyle (1), vtkRenderWindow (1)
activated
  • vtkSpherePuzzle (1)
active (actively)
  • vtkAssignAttribute (3), vtkDataSetAttributes (3), vtkRenderer (2), vtkAbstractMapper (1), vtkClipDataSet (1), vtkContourFilter (1), vtkContourGrid (1), vtkGridSynchronizedTemplates3D (1), vtkMesaImageWindow (1), vtkPCAAnalysisFilter (1), [...]
activities
  • vtkPropCollection (1)
actor (actors)
  • vtkActor (24), vtkInteractorStyle (11), vtkLODActor (8), vtkActorCollection (6), vtkActor2D (5), vtkLegendBoxActor (5), vtkScaledTextActor (5), vtkAxisActor2D (4), vtkCaptionActor2D (4), vtkCubeAxesActor2D (4), [...]
acts
  • vtkGaussianSplatter (2), vtkGenericCell (1), vtkInterpolatedVelocityField (1)
actuall
  • vtkContainer (1)
adapted
  • vtkDecimate (1), vtkMatrix4x4 (1), vtkPointLoad (1)
adaptive
  • vtkInitialValueProblemSolver (3), vtkRungeKutta45 (2)
adding
  • vtkFieldData (2), vtkCellArray (1), vtkCleanPolyData (1), vtkMPIGroup (1), vtkSpline (1)
addition
  • vtkGlyphSource2D (2), vtkImplicitModeller (2), vtkCellType (1), vtkImageBlend (1), vtkLight (1), vtkPLOT3DReader (1), vtkProgrammableGlyphFilter (1), vtkProp3D (1), vtkQuadricClustering (1), vtkQuantizePolyDataPoints (1), [...]
additional (additionally)
  • vtkPLOT3DReader (3), vtkMapper (2), vtkScalarsToColors (2), vtkCell (1), vtkDataReader (1), vtkDecimate (1), vtkDecimatePro (1), vtkDelaunay2D (1), vtkEdgeTable (1), vtkExplicitCell (1), [...]
address (addressed, addresses)
  • vtkCharArray (3), vtkExtractTensorComponents (3), vtkDoubleArray (2), vtkFloatArray (2), vtkIdTypeArray (2), vtkIntArray (2), vtkLongArray (2), vtkShortArray (2), vtkUnsignedCharArray (2), vtkUnsignedIntArray (2), [...]
adequate
  • vtkSurfaceReconstructionFilter (1)
adjacent
  • vtkDecimatePro (1), vtkImplicitModeller (1)
adjoined
  • vtkImageAnisotropicDiffusion3D (1)
adjoint
  • vtkMatrix4x4 (1)
adjust (adjusted, adjusting, adjusts)
  • vtkWindowedSincPolyDataFilter (4), vtkRenderer (3), vtkSubPixelPositionEdgels (3), vtkAxisActor2D (2), vtkCommand (2), vtkErrorCode (2), vtkInteractorStyle (2), vtkSmoothPolyDataFilter (2), vtkVolumeRayCastMapper (2), vtkButtonSource (1), [...]
adjustable
  • vtkPerlinNoise (1)
adjustment (adjustments)
  • vtkPerspectiveTransform (2), vtkAxisActor2D (1), vtkFollower (1), vtkInteractorStyle (1), vtkSubPixelPositionEdgels (1), vtkWindowedSincPolyDataFilter (1)
advance (advanced, advances)
  • vtkRenderer (1), vtkTreeComposite (1), vtkVectorText (1), vtkVideoSource (1), vtkViewport (1), vtkXYPlotActor (1)
advantage (advantages)
  • vtkCellArray (1), vtkOutputPort (1), vtkPLY (1), vtkRecursiveDividingCubes (1)
aesthetics
  • vtkLightKit (1)
affect (affected, affecting, affects)
  • vtkInteractorStyle (2), vtkMapper (2), vtkProp (2), vtkXYPlotActor (2), vtkGaussianSplatter (1), vtkGraphLayoutFilter (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkImplicitModeller (1), vtkPlaneSource (1), [...]
affine
  • vtkLinearTransform (1), vtkProcrustesAlignmentFilter (1), vtkTransform (1)
aggregated
  • vtkOBBDicer (2)
aggressive
  • vtkMarchingCubes (1)
agree (agreed)
  • vtkAbstractTransform (1), vtkDelaunay3D (1)
ahead
  • vtkEnSight6BinaryReader (1), vtkEnSight6Reader (1), vtkEnSightGoldBinaryReader (1), vtkEnSightGoldReader (1), vtkOpenGLStateCache (1)
aims
  • vtkSimpleImageToImageFilter (1)
alamos
  • vtkTreeComposite (3)
algorithm (algorithms)
  • vtkDecimatePro (9), vtkImageEuclideanDistance (8), vtkDecimate (6), vtkQuadricClustering (5), vtkDelaunay3D (4), vtkIterativeClosestPointTransform (4), vtkConnectivityFilter (3), vtkDelaunay2D (2), vtkGraphLayoutFilter (2), vtkImageToPolyDataFilter (2), [...]
alias
  • vtkExporter (1), vtkWriter (1)
alignment (alignments)
  • vtkProcrustesAlignmentFilter (6), vtkVideoSource (1)
aligns (aligned, aligning)
  • vtkGaussianSplatter (2), vtkMath (2), vtkPCAAnalysisFilter (2), vtkProcrustesAlignmentFilter (2), vtkCylinderSource (1), vtkMassProperties (1), vtkPixel (1), vtkPlaneSource (1), vtkRenderWindow (1)
allocate (allocated, allocates, allocating, allocation, allocations)
  • vtkDataArray (12), vtkCharArray (11), vtkPolyData (11), vtkDoubleArray (8), vtkFloatArray (8), vtkIntArray (8), vtkLongArray (8), vtkShortArray (8), vtkUnsignedCharArray (8), vtkUnsignedIntArray (8), [...]
allow (allowed, allowing, allows)
  • vtkDecimatePro (3), vtkPlaneSource (3), vtkStreamer (3), vtkTransform (3), vtkGeneralTransform (2), vtkGenericCell (2), vtkImageDifference (2), vtkInteractorStyleUser (2), vtkLODProp3D (2), vtkMapper (2), [...]
allowable
  • vtkDecimatePro (2), vtkCellType (1), vtkDecimate (1), vtkImageDifference (1), vtkLocator (1), vtkPlanes (1), vtkQuadricDecimation (1), vtkSimpleScalarTree (1), vtkStripper (1), vtkSuperquadric (1), [...]
allowablew
  • vtkTubeFilter (1)
allready
  • vtkPCAAnalysisFilter (1)
alpha
  • vtkImageBlend (13), vtkDelaunay2D (11), vtkDelaunay3D (10), vtkLookupTable (6), vtkCamera (3), vtkImageMapToColors (3), vtkImageMask (3), vtkScalarsToColors (3), vtkLinkEdgels (2), vtkMapper (2), [...]
alphanumeric
  • vtkVectorText (1)
alter (altered)
  • vtkCleanPolyData (1), vtkDecimate (1), vtkQuantizePolyDataPoints (1), vtkWindowedSincPolyDataFilter (1)
alternate
  • vtkXYPlotActor (2), vtkOBBTree (1)
alyassin
  • vtkMassProperties (1)
ambient
  • vtkProperty (7), vtkEncodedGradientShader (4), vtkRenderer (2), vtkVolumeProperty (2), vtkViewport (1)
ambiguity
  • vtkCommunicator (2), vtkMPICommunicator (2), vtkMPIController (1), vtkMultiProcessController (1), vtkSharedMemoryCommunicator (1), vtkSocketCommunicator (1)
ames
  • vtkPLOT3DReader (1)
amount (amounts)
  • vtkProcessObject (2), vtkDataArray (1), vtkDecimate (1), vtkDirectionEncoder (1), vtkEncodedGradientShader (1), vtkImageToPolyDataFilter (1), vtkImplicitModeller (1), vtkInteractorStyle (1), vtkInteractorStyleTrackball (1), vtkLinearExtrusionFilter (1), [...]
amplitude
  • vtkPerlinNoise (3)
analogous
  • vtkWeightedTransformFilter (1)
analysis
  • vtkPCAAnalysisFilter (2), vtkMath (1), vtkProcrustesAlignmentFilter (1), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
analytic
  • vtkVolumeRayCastIsosurfaceFunction (1)
analytical
  • vtkPointLoad (1)
analyzed
  • vtkMPIEventLog (1), vtkTimerLog (1)
anatomical
  • vtkConnectivityFilter (2)
ancillary
  • vtkTreeComposite (1)
angle (angles)
  • vtkCamera (13), vtkDecimatePro (10), vtkDecimate (8), vtkPerspectiveTransform (6), vtkSmoothPolyDataFilter (6), vtkWindowedSincPolyDataFilter (6), vtkSphereSource (5), vtkCone (4), vtkLight (4), vtkTransform (4), [...]
angular
  • vtkInteractorStyleFlight (2), vtkTextureMapToSphere (2), vtkCamera (1), vtkLightKit (1)
animated
  • vtkRenderWindowInteractor (1)
anisotropic
  • vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1)
anisotropically
  • vtkViewport (1)
annealing
  • vtkGraphLayoutFilter (1)
annotation (annotations)
  • vtkScalarBarActor (10), vtkAxisActor2D (5), vtkCubeAxesActor2D (5), vtkParallelCoordinatesActor (5), vtkXYPlotActor (5), vtkProp (2), vtkQuartzTextMapper (2), vtkTextMapper (2), vtkWin32OpenGLTextMapper (2), vtkWin32TextMapper (2), [...]
annual
  • vtkButterflySubdivisionFilter (1), vtkLoopSubdivisionFilter (1)
answer
  • vtkMath (1), vtkSpherePuzzle (1)
antialiasing
  • vtkRenderWindow (2), vtkMesaRenderWindow (1), vtkOpenGLRenderWindow (1)
anymap
  • vtkPNMReader (2)
anyway
  • vtkCompositeManager (1), vtkDataSetReader (1), vtkMultiThreader (1)
apart
  • vtkRuledSurfaceFilter (1)
apparent
  • vtkLightKit (1)
appearance
  • vtkImageViewer (1), vtkImageWindow (1), vtkQuadricDecimation (1), vtkVRMLImporter (1)
appears (appearing)
  • vtkAssembly (1), vtkInteractorStyleUnicam (1), vtkLightKit (1), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkStreamLine (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1)
append (appended, appending)
  • vtkAppendPolyData (7), vtkAppendFilter (6), vtkImageAppend (3), vtkImplicitModeller (13), vtkQuadricClustering (6), vtkXYPlotActor (5), vtkIdentityTransform (3), vtkLinearTransform (3), vtkFileOutputWindow (2), vtkOBJExporter (2), [...]
applicable
  • vtkArcPlotter (1), vtkLabeledDataMapper (1)
application (applications)
  • vtkWin32RenderWindowInteractor (4), vtkInteractorStyle (3), vtkQuartzRenderWindowInteractor (3), vtkImageEuclideanDistance (2), vtkXRenderWindowTclInteractor (2), vtkAppendPolyData (1), vtkButtonSource (1), vtkCutter (1), vtkDataSet (1), vtkDicer (1), [...]
applies
  • vtkImageMaskBits (2), vtkXYPlotActor (2), vtkGlyphSource2D (1), vtkWindowedSincPolyDataFilter (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
applying
  • vtkImageReslice (3), vtkWarpLens (1), vtkWindowedSincPolyDataFilter (1)
approach (approaches)
  • vtkVolumeRayCastIsosurfaceFunction (2), vtkImplicitDataSet (1), vtkImplicitVolume (1), vtkInteractorStyleTrackball (1), vtkLine (1), vtkMapper (1), vtkQuadricClustering (1), vtkRecursiveDividingCubes (1), vtkRuledSurfaceFilter (1), vtkSweptSurface (1), [...]
approved
  • vtkTreeComposite (1)
approximate (approximated, approximately, approximates, approximating, approximation)
  • vtkWindowedSincPolyDataFilter (9), vtkApproximatingSubdivisionFilter (2), vtkLoopSubdivisionFilter (2), vtkDashedStreamLine (1), vtkDecimate (1), vtkDecimatePro (1), vtkDividingCubes (1), vtkEncodedGradientShader (1), vtkOBBTree (1), vtkPCAAnalysisFilter (1), [...]
arbitrarily
  • vtkElevationFilter (1), vtkLargeInteger (1)
arbitrarly
  • vtkImageSeparableConvolution (1)
arbitrary
  • vtkArcPlotter (2), vtkAssembly (2), vtkDashedStreamLine (2), vtkShrinkFilter (2), vtkStreamLine (2), vtkVoxelModeller (2), vtkButterflySubdivisionFilter (1), vtkByteSwap (1), vtkClipDataSet (1), vtkContourFilter (1), [...]
arc-seconds
  • vtkDEMReader (1)
architecture
  • vtkDynamicLoader (2), vtkVolumeTextureMapper2D (1)
area (areas)
  • vtkMassProperties (4), vtkDashedStreamLine (2), vtkImageIslandRemoval2D (2), vtkDecimatePro (1), vtkImageCanvasSource2D (1), vtkLightKit (1), vtkScaledTextActor (1), vtkStreamLine (1), vtkTriangle (1), vtkXRenderWindowInteractor (1), [...]
aren
  • vtkGlyph3D (1), vtkImageSpatialFilter (1), vtkPostScriptWriter (1), vtkVRMLExporter (1)
argc
  • vtkMPIController (1)
argonne
  • vtkMPIEventLog (1)
args
  • vtkSetGet (1), vtkTimerLog (1)
arguements
  • vtkExtentTranslator (1)
argv
  • vtkMPIController (1)
arial
  • vtkCubeAxesActor2D (2), vtkLabeledDataMapper (2), vtkParallelCoordinatesActor (2), vtkScalarBarActor (2), vtkTextMapper (2), vtkXYPlotActor (2), vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkLegendBoxActor (1)
arise
  • vtkDataSet (1)
arranged
  • vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageData (1), vtkMath (1), vtkPlaneSource (1), vtkPriorityQueue (1)
arrangement
  • vtkGraphLayoutFilter (1)
array (arrays)
  • vtkDataArray (50), vtkArrayCalculator (21), vtkCharArray (20), vtkDoubleArray (20), vtkFloatArray (20), vtkIdTypeArray (20), vtkIntArray (20), vtkLongArray (20), vtkShortArray (20), vtkUnsignedCharArray (20), [...]
arrival
  • vtkSharedMemoryCommunicator (1)
arrives
  • vtkDataObject (1), vtkImageStencilData (1)
arrow (arrows)
  • vtkArrowSource (2), vtkCaptionActor2D (3), vtkGlyphSource2D (1), vtkInteractorStyleFlight (1), vtkSpherePuzzle (1)
artifacts
  • vtkCompositeManager (1), vtkExtractUnstructuredGrid (1), vtkGeometryFilter (1)
as-is
  • vtkMatrixToHomogeneousTransform (1), vtkMatrixToLinearTransform (1)
ascii (ASCII)
  • vtkSTLReader (3), vtkVectorText (3), vtkDataWriter (2), vtkPLY (2), vtkDEMReader (1), vtkDataObjectReader (1), vtkDataObjectWriter (1), vtkDataReader (1), vtkOBJExporter (1), vtkPLYWriter (1), [...]
asked
  • vtkObjectFactory (3), vtkOutputWindow (1)
asking
  • vtkPlanes (1)
aspect
  • vtkCamera (3), vtkOBBTree (2), vtkProjectedTexture (2), vtkViewport (2), vtkVoxelContoursToSurfaceFilter (2), vtkDecimate (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkInteractorStyleUnicam (1), vtkPerspectiveTransform (1)
assembled
  • vtkStripper (1)
assemblies
  • vtkAssembly (11), vtkAbstractPropPicker (4), vtkPropAssembly (3), vtkActor (2), vtkAssemblyNode (2)
assembly
  • vtkAssembly (19), vtkAssemblyPath (13), vtkPropAssembly (12), vtkAssemblyNode (9), vtkAssemblyPaths (3), vtkAbstractPropPicker (20), vtkActor (3), vtkProp (3), vtkProp3D (2), vtkCubeAxesActor2D (1), [...]
assert
  • vtkInteractorStyleUnicam (1)
assign (assigning, assigns)
  • vtkAssignAttribute (7), vtkBrownianPoints (2), vtkPoints (2), vtkProjectedTexture (2), vtkWeightedTransformFilter (2), vtkAttributeDataToFieldDataFilter (1), vtkBooleanTexture (1), vtkDataObject (1), vtkDataObjectToDataSetFilter (1), vtkFieldDataToAttributeDataFilter (1), [...]
assignment
  • vtkBranchExtentTranslator (3), vtkTensor (2), vtkTriangularTexture (1)
associate (associating, association)
  • vtkAbstractPropPicker (2), vtkAssemblyNode (2), vtkCaptionActor2D (1), vtkDataObjectToDataSetFilter (1), vtkEdgeTable (1), vtkFieldDataToAttributeDataFilter (1), vtkLegendBoxActor (1), vtkPLOT3DReader (1), vtkScalarBarActor (1)
assume (assuming)
  • vtkAbstractPropPicker (2), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkAssignAttribute (1), vtkDataObject (1), vtkDataSetAttributes (1), vtkEdgeTable (1), vtkEncodedGradientEstimator (1), vtkOrderedTriangulator (1), vtkRearrangeFields (1), [...]
assumption
  • vtkMassProperties (1), vtkOrderedTriangulator (1)
assure
  • vtkRenderWindowInteractor (1)
asynchronous (asynchronously)
  • vtkDataObject (3), vtkImageStencilData (2), vtkMultiProcessController (1), vtkOutputPort (1)
asynchrony
  • vtkVideoSource (1)
atan
  • vtkCamera (1)
attach (attached, attaches)
  • vtkSmoothPolyDataFilter (2), vtkWindowedSincPolyDataFilter (2), vtkCamera (1), vtkImageToStructuredPoints (1), vtkImageViewer2 (1), vtkImager (1), vtkLight (1), vtkOBBTree (1), vtkRenderer (1), vtkStructuredGridGeometryFilter (1), [...]
attachment (attachments)
  • vtkCaptionActor2D (6), vtkDecimate (2), vtkDecimatePro (1)
attack
  • vtkPLOT3DReader (2)
attempt (attempted, attempting)
  • vtkLightKit (2), vtkBranchExtentTranslator (1), vtkCellLocator (1), vtkCubeAxesActor2D (1), vtkDecimate (1), vtkDynamicLoader (1), vtkImageImport (1), vtkMILVideoSource (1), vtkPImageWriter (1), vtkPythonUtil (1), [...]
attenuation (attenuated)
  • vtkLight (2), vtkImageButterworthHighPass (1), vtkImageButterworthLowPass (1)
attractive
  • vtkLightKit (1)
attribute (ATTRIBUTE, attributes)
  • vtkDataSetAttributes (42), vtkFieldDataToAttributeDataFilter (17), vtkAssignAttribute (8), vtkProgrammableAttributeDataFilter (8), vtkAttributeDataToFieldDataFilter (6), vtkInterpolateDataSetAttributes (4), vtkFieldData (13), vtkProgrammableGlyphFilter (8), vtkXMLParser (8), vtkDataReader (6), [...]
atts
  • vtkXMLParser (1)
augmented
  • vtkScalarsToColors (1)
august
  • vtkLoopSubdivisionFilter (1)
author (Authoring)
  • vtkVRMLImporter (2), vtkVRML (1)
authors (authored)
  • vtkInteractorStyleUnicam (1), vtkTreeComposite (1)
authorship
  • vtkTreeComposite (1)
autodetect
  • vtkMILVideoSource (1)
automatic
  • vtkLODProp3D (6), vtkLookupTable (4), vtkGraphLayoutFilter (3), vtkLocator (3), vtkSweptSurface (2), vtkTextureMapToPlane (2), vtkArcPlotter (1), vtkCellLocator (1), vtkGaussianSplatter (1), vtkImplicitSelectionLoop (1), [...]
automatically
  • vtkAbstractTransform (5), vtkTextureMapToCylinder (4), vtkTextureMapToSphere (4), vtkVideoSource (4), vtkImplicitModeller (3), vtkRenderer (3), vtkXYPlotActor (3), vtkActor (2), vtkArcPlotter (2), vtkCamera (2), [...]
autorange
  • vtkParallelCoordinatesActor (1), vtkXYPlotActor (1)
auxiliary
  • vtkProgrammableAttributeDataFilter (1)
availiable
  • vtkImageReader2Factory (4)
average (averaged, averages, averaging)
  • vtkCellLocator (2), vtkDecimate (2), vtkPointLocator (2), vtkPointLocator2D (2), vtkSmoothPolyDataFilter (2), vtkCellDataToPointData (1), vtkImageAnisotropicDiffusion2D (1), vtkImageDifference (1), vtkIterativeClosestPointTransform (1), vtkLocator (1), [...]
avoids (avoided)
  • vtkPriorityQueue (2), vtkAbstractPropPicker (1), vtkDelaunay2D (1), vtkInterpolatedVelocityField (1), vtkMarchingSquares (1), vtkProgrammableFilter (1)
axes
  • vtkCubeAxesActor2D (21), vtkAxes (5), vtkParallelCoordinatesActor (13), vtkXYPlotActor (8), vtkImageReslice (7), vtkImagePermute (6), vtkOBBTree (6), vtkPlaneSource (5), vtkImageDecomposeFilter (4), vtkCursor3D (3), [...]
axis
  • vtkAxisActor2D (21), vtkProp3D (15), vtkTextureMapToCylinder (9), vtkImageActor (5), vtkImageAppend (5), vtkImageMapper (5), vtkButtonSource (3), vtkCubeAxesActor2D (3), vtkExtentTranslator (3), vtkImageBlockReader (3), [...]
axisymmetric
  • vtkRotationalExtrusionFilter (1)
azimuth
  • vtkLightKit (6), vtkCamera (1), vtkLight (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)

b
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
back-to-front
  • vtkCutter (2), vtkDepthSortPolyData (2), vtkFrustumCoverageCuller (1)
backface
  • vtkProperty (6), vtkLODProp3D (2), vtkActor (1), vtkPolyDataNormals (1), vtkRenderer (1)
background (backgrounds)
  • vtkRIBExporter (8), vtkProperty2D (4), vtkImageReslice (3), vtkTextSource (3), vtkRenderer (2), vtkViewport (2), vtkImageWindow (1), vtkOrderedTriangulator (1), vtkWin32ImageWindow (1), vtkXImageWindow (1)
backward (backwards)
  • vtkRenderer (2), vtkVideoSource (2), vtkWindowLevelLookupTable (2), vtkExporter (1), vtkImageCityBlockDistance (1), vtkPicker (1), vtkSource (1), vtkStreamLine (1), vtkStreamer (1), vtkViewport (1)
baked
  • vtkWinCE (1)
balances (balanced)
  • vtkPriorityQueue (2)
band (bands)
  • vtkBandedPolyDataContourFilter (6), vtkWindowedSincPolyDataFilter (2), vtkImageIdealHighPass (1), vtkImageIdealLowPass (1)
banking
  • vtk3DS (1)
barr
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
barrier
  • vtkThreadedController (1)
bartels
  • vtkKochanekSpline (1)
barycentric
  • vtkTetra (3), vtkTriangle (3)
base
  • vtkLocator (3), vtkObjectFactory (3), vtkTransform (3), vtkGeneralTransform (2), vtkMesaProperty (2), vtkObject (2), vtkOpenGLProperty (2), vtkPerspectiveTransform (2), vtkAbstractTransform (1), vtkArrowSource (1), [...]
basis
  • vtkThinPlateSplineTransform (3), vtkCardinalSpline (2), vtkKochanekSpline (1), vtkWeightedTransformFilter (1)
beat
  • vtkPerlinNoise (1)
behalf
  • vtkJavaUtil (1)
behave (behaved, behaves)
  • vtkFieldData (13), vtkImageOpenClose3D (2), vtkArrowSource (1), vtkInteractorStyleUser (1), vtkMPICommunicator (1), vtkOpenGLStateCache (1), vtkQuadricClustering (1), vtkWindowToImageFilter (1)
behavior (behaviour)
  • vtkInteractorStyle (2), vtkPythonUtil (2), vtkRenderWindow (2), vtkXYPlotActor (2), vtkAppendPolyData (1), vtkAttributeDataToFieldDataFilter (1), vtkBMPReader (1), vtkCell (1), vtkCellType (1), vtkConnectivityFilter (1), [...]
believe
  • vtkImageIterateFilter (1)
bell
  • vtkVRML (1), vtkVRMLImporter (1)
belong (belongs)
  • vtkCell3D (2), vtkDicer (2), vtkRenderer (2), vtkExtractPolyDataPiece (1), vtkExtractUnstructuredGridPiece (1), vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkInteractorStyleTrackball (1)
bends (bending)
  • vtkKochanekSpline (1), vtkWeightedTransformFilter (1)
beside
  • vtkCellPicker (1), vtkPointPicker (1)
besides
  • vtkProgrammableAttributeDataFilter (1), vtkVectorText (1)
beta
  • vtkCamera (3)
beyond
  • vtkCell (2), vtkExplicitCell (2), vtkCamera (1), vtkPriorityQueue (1), vtkTexture (1)
bias
  • vtkEncodedGradientEstimator (3), vtkKochanekSpline (3)
bigger
  • vtkVolumeRayCastMapper (2), vtkImageEuclideanDistance (1), vtkRenderWindow (1)
bilinear
  • vtkImageMagnify (1)
binary (BINARY)
  • vtkEnSight6BinaryReader (2), vtkEnSightGoldBinaryReader (1), vtkMCubesReader (4), vtkMCubesWriter (4), vtkSTLReader (4), vtkPLY (3), vtkDataObjectReader (2), vtkDataObjectWriter (2), vtkDataReader (2), vtkImageEllipsoidSource (2), [...]
binding (bindings)
  • vtkQuartzRenderWindowInteractor (4), vtkRearrangeFields (4), vtkWin32RenderWindowInteractor (4), vtkInteractorStyleImage (3), vtkAssignAttribute (2), vtkInteractorStyle (2), vtkInteractorStyleFlight (2), vtkSplitField (2), vtkXRenderWindowInteractor (2), vtkXRenderWindowTclInteractor (2), [...]
bins (binning)
  • vtkQuadricClustering (8), vtkImageAccumulate (6), vtkMarchingCubes (1)
biological
  • vtkPCAAnalysisFilter (1)
bit-mask (bit-masks)
  • vtkImageMaskBits (4)
bitmap (bitmaps)
  • vtkBMPReader (1), vtkPNMReader (1), vtkWin32ImageMapper (1)
bits
  • vtkBitArray (4), vtkLargeInteger (2), vtkImageToPolyDataFilter (1), vtkRenderWindow (1), vtkVideoSource (1), vtkVolume16Reader (1), vtkVoxelModeller (1)
bitwise
  • vtkImageMaskBits (1)
black
  • vtkBooleanTexture (1), vtkMCubesReader (1), vtkRIBExporter (1), vtkRenderer (1), vtkTextSource (1), vtkViewport (1)
blackman
  • vtkWindowedSincPolyDataFilter (1)
blank (blanked, blanking)
  • vtkBlankStructuredGrid (14), vtkBlankStructuredGridWithImage (7), vtkStructuredGrid (9), vtkStructuredGridGeometryFilter (5), vtkEnSightReader (1), vtkGenericEnSightReader (1), vtkImageCanvasSource2D (1)
blend (blending, blends)
  • vtkImageBlend (8), vtkScalarsToColors (5), vtkVolumeProMapper (3), vtkImageMask (2), vtkRenderWindow (2), vtkMapper (1), vtkPolyDataMapper2D (1), vtkVolumeMapper (1), vtkWeightedTransformFilter (1)
blendfunc
  • vtkOpenGLStateCache (1)
block (blocks)
  • vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkImageCityBlockDistance (1), vtkSharedMemoryCommunicator (3), vtkCommunicator (2), vtkExtentTranslator (2), vtkColorTransferFunction (1), vtkDataObject (1), vtkImageStencilData (1), vtkMPICommunicator (1), [...]
blue (blues)
  • vtkLightKit (3), vtkPLYWriter (2), vtkRIBExporter (2), vtkEncodedGradientShader (1), vtkImageHSVToRGB (1), vtkImageRGBToHSV (1), vtkInteractorStyle (1), vtkLookupTable (1), vtkPLY (1), vtkPLYReader (1), [...]
blur
  • vtkRenderWindow (1)
blurry
  • vtkPolyDataNormals (1)
board
  • vtkVolumeProMapper (4), vtkOpenGLVolumeProVP1000Mapper (1), vtkPLY (1), vtkRenderWindowInteractor (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
body
  • vtkIterativeClosestPointTransform (2), vtkProcrustesAlignmentFilter (1), vtkSetGet (1)
bold (bolding)
  • vtkCubeAxesActor2D (3), vtkLabeledDataMapper (3), vtkTextMapper (3), vtkAxisActor2D (2), vtkParallelCoordinatesActor (2), vtkScalarBarActor (2), vtkXYPlotActor (2), vtkCaptionActor2D (1), vtkLegendBoxActor (1)
bone (bones)
  • vtkWeightedTransformFilter (5)
bookstein
  • vtkThinPlateSplineTransform (1)
boolean
  • vtkImplicitBoolean (8), vtkExtractTensorComponents (7), vtkTensorGlyph (6), vtkTransformTextureCoords (6), vtkGraphLayoutFilter (3), vtkImageMaskBits (3), vtkLocator (3), vtkStreamer (3), vtkWarpScalar (3), vtkConnectivityFilter (2), [...]
boor
  • vtkMath (1)
border (borders)
  • vtkLegendBoxActor (7), vtkCaptionActor2D (4), vtkRenderWindow (3), vtkInteractorStyleUnicam (1), vtkXYPlotActor (1)
borland
  • vtkVRML (1)
bottles
  • vtkRotationalExtrusionFilter (1)
bottom
  • vtkRenderWindow (2), vtkWindow (2), vtkXImageWindow (2), vtkAbstractPropPicker (1), vtkCaptionActor2D (1), vtkConeSource (1), vtkInteractorStyle (1), vtkSpherePuzzle (1), vtkTextMapper (1)
bottom-up
  • vtkOBBTree (1)
boudns
  • vtkImageActor (1)
bounced
  • vtkLightKit (1)
bound (bounded, bounding, bounds)
  • vtkCubeAxesActor2D (22), vtkImplicitModeller (13), vtkDataSet (12), vtkSweptSurface (8), vtkGaussianSplatter (7), vtkGraphLayoutFilter (6), vtkOBBTree (6), vtkRenderer (6), vtkCell (5), vtkCursor3D (5), [...]
boundaries
  • vtkImageSpatialFilter (2), vtkImageToPolyDataFilter (2), vtkSampleFunction (2), vtkDecimate (1), vtkGeometryFilter (1), vtkImageCityBlockDistance (1), vtkImageLaplacian (1), vtkImageMirrorPad (1), vtkImageSeparableConvolution (1), vtkQuadricClustering (1), [...]
boundary
  • vtkQuadricClustering (5), vtkSmoothPolyDataFilter (5), vtkWindowedSincPolyDataFilter (5), vtkImplicitModeller (4), vtkOrderedTriangulator (4), vtkCell (3), vtkDecimatePro (3), vtkFeatureEdges (3), vtkBooleanTexture (2), vtkExtractGrid (2), [...]
boxes
  • vtkLocator (1), vtkOBBTree (1), vtkSpatialRepresentationFilter (1)
branches (branching)
  • vtkSimpleScalarTree (3), vtkBranchExtentTranslator (2), vtkAbstractTransform (1)
breadth
  • vtkImageConnector (2)
breaks (breaking)
  • vtkExtentTranslator (2), vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkImageToImageFilter (1), vtkQuadricClustering (1), vtkRectilinearGridOutlineFilter (1)
breakup
  • vtkProbeFilter (1)
brick
  • vtkHexahedron (1)
brief
  • vtkInteractorStyleUnicam (1)
brigham
  • vtkLightKit (1)
brighness
  • vtkMILVideoSource (1)
bright (brightness)
  • vtkLightKit (7), vtkLight (2)
brighter
  • vtkLightKit (1)
brightest
  • vtkLightKit (1)
brightnesses
  • vtkLightKit (1)
bring
  • vtkSource (2), vtkWin32VideoSource (2), vtkDataObjectSource (1), vtkDataSetAttributes (1), vtkInteractorStyle (1)
broad
  • vtkKochanekSpline (1)
brown
  • vtkInteractorStyleUnicam (3)
browse
  • vtkMergeFields (1), vtkRearrangeFields (1), vtkSplitField (1)
brush (brushing)
  • vtkParallelCoordinatesActor (1), vtkSelectVisiblePoints (1)
bsize
  • vtkPCAAnalysisFilter (7)
bucket (buckets)
  • vtkLocator (8), vtkPointLocator (8), vtkPointLocator2D (7), vtkCellLocator (5), vtkOpenGLStateCache (1)
buffer (buffered, buffering, buffers)
  • vtkRenderWindow (10), vtkImageImport (7), vtkWindow (5), vtkImageWindow (4), vtkVideoSource (4), vtkWin32ImageWindow (4), vtkXImageWindow (4), vtkCompositeManager (3), vtkMesaImageWindow (3), vtkOpenGLImageWindow (3), [...]
builds
  • vtkSLCReader (1)
built-in
  • vtkSetGet (5), vtkImageReader2Factory (1), vtkTimerLog (1)
bulb (bulbs)
  • vtkLightKit (2)
bump (bumped)
  • vtkDecimate (1), vtkLookupTable (1)
butterfly
  • vtkButterflySubdivisionFilter (3), vtkImageFFT (1), vtkImageRFFT (1)
button (buttons)
  • vtkButtonSource (23), vtkInteractorStyleUnicam (14), vtkInteractorStyleUser (10), vtkInteractorStyleJoystickActor (9), vtkInteractorStyleJoystickCamera (9), vtkInteractorStyleTrackballActor (9), vtkInteractorStyleTrackballCamera (9), vtkInteractorStyle (7), vtkInteractorStyleFlight (3), vtkInteractorStyleImage (3)
by-product
  • vtkDataObject (1)
bypass (bypasses)
  • vtkImageMultipleInputFilter (1), vtkRenderWindow (1)
byte (bytes)
  • vtkByteSwap (37), vtkVolume16Reader (7), vtkEncodedGradientEstimator (5), vtkImageReader2 (5), vtkParticleReader (5), vtkMCubesReader (4), vtkPLY (3), vtkRecursiveSphereDirectionEncoder (3), vtkDirectionEncoder (2), vtkSTLReader (2), [...]
Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (c..e)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

c
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
c-style
  • vtkXMLParser (1)
cache (cached, caches, caching)
  • vtkImageCacheFilter (1), vtkInterpolatedVelocityField (7), vtkImageIterateFilter (5), vtkActor (2), vtkAssembly (1), vtkCellLocator (1), vtkDataReader (1), vtkImageEuclideanDistance (1), vtkImageOpenClose3D (1), vtkImageSource (1), [...]
calc
  • vtkGraphLayoutFilter (1)
calculate (calculated, calculates, calculating, calculation, calculations)
  • vtkWarpTransform (5), vtkIdentityTransform (4), vtkLinearTransform (4), vtkImageFourierFilter (3), vtkAbstractTransform (2), vtkGeneralTransform (2), vtkGridTransform (2), vtkHomogeneousTransform (2), vtkMarchingContourFilter (2), vtkMath (2), [...]
calibrated
  • vtkWarpLens (2)
california
  • vtkTreeComposite (2)
callback (callbacks)
  • vtkCallbackCommand (2), vtkOldStyleCallbackCommand (2), vtkImageImport (28), vtkImageExport (4), vtkQuartzRenderWindowInteractor (3), vtkWin32RenderWindowInteractor (3), vtkCommand (2), vtkJavaUtil (2), vtkObject (2), vtkRenderWindowInteractor (2), [...]
calldata
  • vtkCallbackCommand (1)
caller (callers)
  • vtkImageReader2Factory (2), vtkAssignAttribute (1), vtkMaskFields (1), vtkMergeFields (1), vtkMultiThreader (1), vtkRearrangeFields (1), vtkRenderWindow (1), vtkSpherePuzzle (1), vtkSplitField (1), vtkWindow (1), [...]
cambridge
  • vtkRungeKutta45 (1)
camera (cameras)
  • vtkCamera (34), vtkInteractorStyleJoystickCamera (5), vtkInteractorStyleTrackballCamera (4), vtkMesaCamera (1), vtkOpenGLCamera (1), vtkRenderer (17), vtkInteractorStyle (16), vtkLight (13), vtkInteractorStyleUnicam (10), vtkInteractorStyleImage (9), [...]
camera-view
  • vtkPerspectiveTransform (1)
campfire
  • vtkLightKit (1)
candidate (candidates)
  • vtkPicker (3), vtkCellLocator (2), vtkAbstractPicker (1)
canny
  • vtkLinkEdgels (1)
canonical
  • vtkRenderWindow (1), vtkWindowToImageFilter (1)
canvas
  • vtkImageCanvasSource2D (4)
capabilities
  • vtkImplicitTextureCoords (1), vtkScalarBarActor (1)
capability
  • vtkHyperStreamline (1), vtkImplicitFunction (1), vtkImplicitModeller (1), vtkRegressionTestImage (1), vtkSweptSurface (1), vtkTensorGlyph (1)
capable
  • vtkVideoSource (1)
capacity
  • vtkAbstractList (1)
capping (capped)
  • vtkRotationalExtrusionFilter (7), vtkLinearExtrusionFilter (6), vtkImplicitModeller (4), vtkSampleFunction (4), vtkGaussianSplatter (3), vtkSweptSurface (3), vtkConeSource (2), vtkCylinderSource (1)
caption
  • vtkCaptionActor2D (18)
capture (captured, captures)
  • vtkTimerLog (1), vtkVolumeRayCastMapper (1), vtkWin32Header (1)
cardinal
  • vtkCardinalSpline (4), vtkKochanekSpline (1)
care (carling)
  • vtkDataObject (1), vtkDelaunay2D (1), vtkInteractorStyleSwitch (1), vtkMatrix4x4 (1), vtkObject (1), vtkWindowedSincPolyDataFilter (1)
careful (carefully)
  • vtkCellArray (2), vtkCleanPolyData (1), vtkCollection (1), vtkEncodedGradientEstimator (1), vtkImplicitModeller (1), vtkInstantiator (1), vtkPLY (1), vtkPolyData (1), vtkSelectVisiblePoints (1), vtkTexture (1)
carpet
  • vtkWarpScalar (1)
carriage
  • vtkFileOutputWindow (1), vtkTextMapper (1), vtkWin32OutputWindow (1)
carries (carried)
  • vtkCellLocator (2), vtkDelaunay2D (1), vtkLocator (1)
cartesian
  • vtkParallelCoordinatesActor (1)
cascade (cascaded)
  • vtkCoordinate (3)
cash
  • vtkRungeKutta45 (1)
cast (casting, casts)
  • vtkVolumeRayCastMapper (5), vtkRayCastStructures (4), vtkImageCast (3), vtkVolumeRayCastFunction (3), vtkCastToConcrete (2), vtkVolumeRayCastStructures (2), vtkMesaVolumeRayCastMapper (1), vtkOpenGLVolumeRayCastMapper (1), vtkVolumeRayCastIsosurfaceFunction (1), vtkVolumeRayCastMIPFunction (1), [...]
caster (casters)
  • vtkRayCastStructures (4), vtkVolumeRayCastFunction (2), vtkAbstractMapper3D (1), vtkVolumeMapper (1), vtkVolumeRayCastIsosurfaceFunction (1), vtkVolumeRayCastMIPFunction (1), vtkVolumeRayCastMapper (1)
category
  • vtkRenderer (1)
catholique
  • vtkImageEuclideanDistance (1)
causing
  • vtkMPICommunicator (1)
caution
  • vtkImageExport (1), vtkPolyData (1), vtkWin32ImageMapper (1)
caveates
  • vtkContainer (1)
caveats
  • vtkDecimatePro (2), vtkAbstractPicker (1), vtkAbstractPropPicker (1), vtkAssembly (1), vtkAssemblyNode (1), vtkAssignAttribute (1), vtkAttributeDataToFieldDataFilter (1), vtkBranchExtentTranslator (1), vtkCGMWriter (1), vtkCastToConcrete (1), [...]
ceiling
  • vtkLightKit (1)
cell (cells)
  • vtkCell (80), vtkCellLocator (51), vtkCellArray (44), vtkNonLinearCell (20), vtkCell3D (19), vtkCellLinks (18), vtkCellTypes (11), vtkCellPicker (10), vtkExplicitCell (10), vtkCellCenters (9), [...]
cell-by-cell
  • vtkDataSetAttributes (1), vtkVolumeRayCastMapper (1)
cell-links
  • vtkCellLinks (1)
center (centered, centers)
  • vtkCellCenters (5), vtkImageFourierCenter (2), vtkPlaneSource (9), vtkCamera (8), vtkInteractorStyleUnicam (6), vtkInteractorStyle (5), vtkTextureMapToSphere (5), vtkCell (4), vtkCylinderSource (4), vtkDataSet (4), [...]
centerate
  • vtkPieceScalars (1)
centerline
  • vtkInteractorStyle (1)
central
  • vtkImageGradient (2), vtkFiniteDifferenceGradientEstimator (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkImageData (1), vtkImageGradientMagnitude (1), vtkImageNonMaximumSuppression (1), vtkSharedMemoryCommunicator (1)
centralize (centralizes)
  • vtkSystemIncludes (2), vtkSetGet (1)
centroid
  • vtkIterativeClosestPointTransform (2), vtkShrinkFilter (2), vtkShrinkPolyData (2), vtkTriangularTexture (2), vtkSmoothPolyDataFilter (1)
chaining
  • vtkIndent (1)
chance
  • vtkDataSetAttributes (1), vtkVolumeRayCastFunction (1)
channel (channels)
  • vtkVolumeProperty (4), vtkMILVideoSource (1)
char (chars)
  • vtkCharArray (1), vtkUnsignedCharArray (1), vtkPLYWriter (3), vtkScalarsToColors (3), vtkVolume (3), vtkCompositeManager (2), vtkDataArray (2), vtkImageActor (2), vtkImageSeedConnectivity (2), vtkImageToPolyDataFilter (2), [...]
character (characters)
  • vtkGlyph3D (4), vtkInteractorStyleUser (4), vtkVectorText (4), vtkWinCE (4), vtkCharArray (3), vtkDataReader (3), vtkGenericEnSightReader (3), vtkSetGet (3), vtkTextSource (3), vtkUnsignedCharArray (3), [...]
character-string
  • vtkDataArray (1), vtkFieldData (1)
characteristic (characteristics)
  • vtkDataReader (3), vtkOrderedTriangulator (1), vtkParallelCoordinatesActor (1)
characterizes
  • vtkMassProperties (1)
charge
  • vtkTreeComposite (1)
charts
  • vtkLinearExtrusionFilter (1)
chebyshev
  • vtkWindowedSincPolyDataFilter (4)
check (checked, checks)
  • vtkEdgeTable (3), vtkQuartzRenderWindow (3), vtkWin32OpenGLRenderWindow (3), vtkWinCEOpenGLRenderWindow (3), vtkAbstractTransform (2), vtkBitArray (2), vtkDataObject (2), vtkDataSet (2), vtkDataSetAttributes (2), vtkFunctionParser (2), [...]
checkboard
  • vtkImageCheckerboard (1)
checkerboard
  • vtkImageCheckerboard (3)
child
  • vtkXRenderWindowInteractor (2), vtkXRenderWindowTclInteractor (2), vtkAssembly (1), vtkPriorityQueue (1), vtkPropAssembly (1), vtkSimpleScalarTree (1)
children
  • vtkOBBTree (3), vtkSimpleScalarTree (3), vtkLocator (2), vtkAssembly (1), vtkObject (1), vtkPropAssembly (1)
chip
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
choice (choices)
  • vtkDelaunay2D (1), vtkDelaunay3D (1), vtkExtractUnstructuredGrid (1), vtkFieldDataToAttributeDataFilter (1), vtkImageToPolyDataFilter (1), vtkMergeDataObjectFilter (1)
choosen
  • vtkPDataSetReader (1), vtkPieceScalars (1)
chooses (choosing)
  • vtkHull (3), vtkExtentTranslator (1), vtkInteractorStyleUnicam (1)
chordal
  • vtkNonLinearCell (1)
chosen
  • vtkCleanPolyData (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkLightKit (1), vtkRuledSurfaceFilter (1), vtkSelectPolyData (1)
chunk (chunks)
  • vtkHull (1), vtkImageMarchingCubes (1), vtkSynchronizedTemplates3D (1)
circle
  • vtkEncodedGradientEstimator (3), vtkFrustumCoverageCuller (2), vtkRotationalExtrusionFilter (1)
circular
  • vtkAbstractTransform (2), vtkSuperquadric (2), vtkSuperquadricSource (2), vtkButtonSource (1), vtkGeneralTransform (1), vtkImageRange3D (1), vtkPerspectiveTransform (1), vtkTransform (1)
circumcenter
  • vtkTetra (1), vtkTriangle (1)
circumferential
  • vtkDiskSource (2), vtkButtonSource (1)
circumscribes (circumscribed)
  • vtkButtonSource (2), vtkEncodedGradientEstimator (1)
circumsphere (circumspheres)
  • vtkDelaunay3D (3), vtkOrderedTriangulator (3), vtkDelaunay2D (1)
citriniti
  • vtkVRML (1), vtkVRMLImporter (1)
citrit
  • vtkVRML (1), vtkVRMLImporter (1)
city
  • vtkImageCityBlockDistance (1)
clam-shell
  • vtkButtonSource (1)
clamp (clamped, clamping)
  • vtkGlyph3D (7), vtkPiecewiseFunction (3), vtkTensorGlyph (3), vtkColorTransferFunction (2), vtkImageDataGeometryFilter (2), vtkLookupTable (2), vtkRectilinearGridGeometryFilter (2), vtkStructuredGridGeometryFilter (2), vtkContourValues (1), vtkGlyph2D (1), [...]
classification
  • vtkSmoothPolyDataFilter (2), vtkWindowedSincPolyDataFilter (2)
classified
  • vtkOrderedTriangulator (7), vtkSmoothPolyDataFilter (3), vtkWindowedSincPolyDataFilter (3), vtkDecimatePro (1)
classify
  • vtkVolumeRayCastCompositeFunction (1)
classname
  • vtkObjectFactory (1)
clean (cleaned, cleaning, cleans)
  • vtkCleanPolyData (1), vtkBandedPolyDataContourFilter (2), vtkDelaunay3D (2), vtkMultiProcessController (2), vtkBitArray (1), vtkCharArray (1), vtkDataArray (1), vtkDebugLeaks (1), vtkDoubleArray (1), vtkFloatArray (1), [...]
clears (cleared, clearing)
  • vtkVideoSource (2), vtkAbstractTransform (1), vtkImageReslice (1), vtkRenderWindowInteractor (1), vtkVolumeRayCastMapper (1)
click
  • vtkInteractorStyleUnicam (2)
clientdata
  • vtkCallbackCommand (1)
clients
  • vtkMatrix4x4 (1), vtkOutputWindow (1)
cline
  • vtkDividingCubes (1)
clip (clipped, clipping, clips)
  • vtkClipDataSet (17), vtkClipVolume (17), vtkClipPolyData (16), vtkImageClip (1), vtkCamera (11), vtkBandedPolyDataContourFilter (7), vtkImageStencilSource (6), vtkAbstractMapper (5), vtkVideoSource (5), vtkInteractorStyle (4), [...]
clipper
  • vtkVolumeMapper (1)
clockwise
  • vtkDelaunay2D (1), vtkLightKit (1)
clone (cloned)
  • vtkBMPReader (1), vtkGESignaReader (1), vtkJPEGReader (1), vtkPNGReader (1), vtkPNMReader (1), vtkSLCReader (1), vtkStreamer (1), vtkTIFFReader (1)
close (closed, closely, closes, closing)
  • vtkImageOpenClose3D (9), vtkRuledSurfaceFilter (6), vtkSpline (6), vtkOBBTree (4), vtkGlyphSource2D (3), vtkGaussianSplatter (2), vtkImageSkeleton2D (2), vtkLightKit (2), vtkMath (2), vtkSampleFunction (2), [...]
closest
  • vtkIterativeClosestPointTransform (4), vtkCellLocator (19), vtkPointLocator (9), vtkPointLocator2D (7), vtkSelectPolyData (5), vtkCell (3), vtkPicker (3), vtkConnectivityFilter (2), vtkCubeAxesActor2D (2), vtkHyperStreamline (2), [...]
closure
  • vtkImplicitModeller (1)
cloud (clouds)
  • vtkLODActor (4), vtkDividingCubes (3), vtkPointSource (3), vtkRecursiveDividingCubes (2), vtkPolyLine (1), vtkPolyVertex (1), vtkTriangleStrip (1)
cluster (clusters)
  • vtkQuadricClustering (1), vtkImageIslandRemoval2D (1)
cmake
  • vtkVolumeProVG500Mapper (5), vtkVolumeProVP1000Mapper (5)
code (codes)
  • vtkErrorCode (2), vtkSource (4), vtkDEMReader (3), vtkMath (3), vtkSetGet (3), vtkImageBlend (2), vtkInstantiator (2), vtkJavaAwt (2), vtkExtentTranslator (1), vtkFunctionParser (1), [...]
coded
  • vtkExtentTranslator (1), vtkImageHSVToRGB (1), vtkImageRGBToHSV (1)
coefficient (coefficients)
  • vtkProperty (6), vtkVolumeProperty (3), vtkImplicitSum (2), vtkQuadric (2), vtkKochanekSpline (1), vtkSpline (1), vtkSuperquadric (1), vtkSuperquadricSource (1), vtkWeightedTransformFilter (1), vtkWindowedSincPolyDataFilter (1)
coherent
  • vtkImageToPolyDataFilter (1)
coincidence
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
coincident
  • vtkExtractUnstructuredGrid (3), vtkDelaunay2D (2), vtkDelaunay3D (2), vtkMapper (2), vtkMergePoints (2), vtkMergePoints2D (2), vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkCone (1), [...]
colapses
  • vtkImageMagnitude (1)
cold
  • vtkLightKit (2)
collapse (collapsed, collapses, collapsing)
  • vtkQuadricDecimation (5), vtkDecimatePro (2), vtkDecimate (1), vtkImageMandelbrotSource (1), vtkOBBTree (1)
collect (collection, collections, collects)
  • vtkCollection (5), vtkActor2DCollection (4), vtkImagerCollection (3), vtkStructuredPointsCollection (2), vtkActorCollection (1), vtkLightCollection (1), vtkEnSightReader (4), vtkPicker (4), vtkRenderer (3), vtkAssembly (2), [...]
collector
  • vtkSynchronizedTemplates3D (1)
collide (collided)
  • vtkAbstractTransform (1), vtkLocator (1)
collinear
  • vtkThinPlateSplineTransform (1)
collision
  • vtkLocator (1), vtkSpatialRepresentationFilter (1)
colon
  • vtkObjectFactory (1)
color (colored, coloring, colors, colour)
  • vtkScalarsToColors (11), vtkColorTransferFunction (8), vtkImageMapToWindowLevelColors (3), vtkCGMWriter (27), vtkImageToPolyDataFilter (22), vtkLookupTable (18), vtkProperty (17), vtkPLYWriter (16), vtkMapper (10), vtkScalarBarActor (10), [...]
colormap
  • vtkXImageWindow (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
column (columns)
  • vtkExtractTensorComponents (11), vtkParallelCoordinatesActor (7), vtkImageReslice (6), vtkFieldData (3), vtkMath (3), vtkXYPlotActor (3), vtkTensorGlyph (2), vtkDEMReader (1), vtkDataArray (1), vtkImageDifference (1), [...]
combinaing
  • vtkOrderedTriangulator (1)
combination (combinations)
  • vtkBooleanTexture (5), vtkImplicitBoolean (5), vtkHull (2), vtkObject (2), vtkOrderedTriangulator (2), vtkPerspectiveTransform (2), vtkUnstructuredGrid (2), vtkAbstractTransform (1), vtkCGMWriter (1), vtkCone (1), [...]
combine (combined, combines, combining)
  • vtkVolumeMapper (3), vtkDataSet (2), vtkGaussianSplatter (2), vtkImageMask (2), vtkImageStencil (2), vtkActor (1), vtkArcPlotter (1), vtkDataObjectToDataSetFilter (1), vtkImageReslice (1), vtkImplicitBoolean (1), [...]
comes
  • vtkImageExport (1), vtkImageReader2 (1), vtkImageReader2Factory (1), vtkMapper (1), vtkMesaVolumeRayCastMapper (1), vtkOpenGLVolumeRayCastMapper (1), vtkPolyDataMapper2D (1), vtkRIBExporter (1)
coming
  • vtkImageAppendComponents (1), vtkMapper (1), vtkPolyDataMapper2D (1)
comm
  • vtkMPIController (1)
command (commands)
  • vtkCommand (3), vtkCallbackCommand (1), vtkTestUtilities (4), vtk3DS (3), vtkObject (3), vtkInstantiator (2), vtkAssignAttribute (1), vtkErrorCode (1), vtkImageReslice (1), vtkInteractorStyle (1), [...]
comments
  • vtkAssemblyPath (2), vtkPLY (2), vtkMarchingCubesCases (1)
commonly
  • vtkCamera (1), vtkGaussianSplatter (1)
communicate (communicates, communication, communications)
  • vtkMultiProcessController (10), vtkSocketCommunicator (6), vtkInputPort (4), vtkMPIController (3), vtkSharedMemoryCommunicator (3), vtkSocketController (3), vtkThreadedController (2), vtkCellTypes (1), vtkCommunicator (1), vtkDataSetWriter (1), [...]
communicator (COMMUNICATOR, communicators)
  • vtkMPICommunicator (16), vtkSharedMemoryCommunicator (4), vtkCommunicator (2), vtkSocketCommunicator (2), vtkMPIController (16), vtkMultiProcessController (10), vtkSocketController (4), vtkThreadedController (2)
compact (compactness)
  • vtkCellArray (1), vtkTriangleStrip (1), vtkVoxelModeller (1)
companion
  • vtkRIBExporter (1)
compare (compares, comparing)
  • vtkImageDifference (5), vtkAbstractList (1), vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkImageCheckerboard (1), vtkImageReslice (1), vtkRegressionTestImage (1), vtkSliceCubes (1), vtkTriangle (1)
comparisons
  • vtkDataObjectSource (1), vtkSource (1), vtkTimeStamp (1)
compatibility (COMPATIBILITY)
  • vtkRenderer (2), vtkWindowLevelLookupTable (2), vtkActor (1), vtkActor2DCollection (1), vtkActorCollection (1), vtkCamera (1), vtkCastToConcrete (1), vtkClipDataSet (1), vtkDataObjectWriter (1), vtkExporter (1), [...]
compatible
  • vtkOrderedTriangulator (2), vtkDataSetTriangleFilter (1), vtkMesaActor (1), vtkTextureMapToPlane (1), vtkWin32VideoSource (1)
compensate
  • vtkLightKit (1)
compilation
  • vtkPoints (1)
compile (compiled)
  • vtkObjectFactory (2), vtkDebugLeaks (1), vtkPLYWriter (1), vtkRIBExporter (1)
compile-time
  • vtkProgrammableFilter (1), vtkSystemIncludes (1)
compiler (compilers)
  • vtkSetGet (2), vtkActor2DCollection (1), vtkActorCollection (1), vtkAppendFilter (1), vtkAppendPolyData (1), vtkAssemblyPath (1), vtkAssemblyPaths (1), vtkBitArray (1), vtkCubeAxesActor2D (1), vtkCullerCollection (1), [...]
complementary
  • vtkImageStencilData (1)
completeness
  • vtkProcrustesAlignmentFilter (1), vtkSetGet (1)
completes (completed)
  • vtkDelaunay3D (1), vtkImplicitModeller (1), vtkViewport (1)
complex (COMPLEX)
  • vtkImageFourierFilter (5), vtkDecimate (3), vtkImageMandelbrotSource (3), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkEnSightGoldBinaryReader (2), vtkEnSightGoldReader (2), vtkImageFFT (2), vtkImageRFFT (2), vtkMath (2), [...]
complexity
  • vtkDecimate (1), vtkDecimatePro (1), vtkImageEuclideanDistance (1), vtkImageToImageFilter (1), vtkLODActor (1), vtkSimpleImageToImageFilter (1)
compliance
  • vtkDataReader (1), vtkSystemIncludes (1)
compliant
  • vtkRIBExporter (1)
complicated
  • vtkActor2D (1), vtkImageReader (1), vtkMPICommunicator (1)
componenents
  • vtkXYPlotActor (1)
componenet
  • vtkEnSightGoldBinaryReader (1), vtkEnSightGoldReader (1), vtkImageAccumulate (1), vtkVolumeMapper (1)
component (components)
  • vtkExtractTensorComponents (14), vtkExtractVectorComponents (12), vtkImageAppendComponents (6), vtkImageExtractComponents (4), vtkFieldDataToAttributeDataFilter (49), vtkDataArray (32), vtkDataObjectToDataSetFilter (30), vtkFieldData (16), vtkVolumeProperty (15), vtkLabeledDataMapper (13), [...]
composing
  • vtkDataSet (2), vtkHyperStreamline (2), vtkShrinkFilter (2), vtkShrinkPolyData (2), vtkLineSource (1), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
composite (composited, compositing)
  • vtkCompositeManager (12), vtkVolumeRayCastCompositeFunction (2), vtkTreeComposite (1), vtkCell (2), vtkHyperStreamline (2), vtkProp3D (2), vtkRIBExporter (2), vtkStreamer (2), vtkCoordinate (1), vtkCubeAxesActor2D (1), [...]
compositer (compositers)
  • vtkCompositeManager (5), vtkTreeComposite (1)
compound (compounded)
  • vtkImageBlend (4)
compression (compressed)
  • vtkGESignaReader (2), vtkImageToPolyDataFilter (1), vtkJPEGWriter (1)
computation (computations)
  • vtkContourFilter (5), vtkContourGrid (5), vtkGridSynchronizedTemplates3D (5), vtkImageMarchingCubes (5), vtkMarchingContourFilter (5), vtkMarchingCubes (5), vtkSynchronizedTemplates3D (5), vtkSweptSurface (3), vtkEncodedGradientEstimator (2), vtkKitwareContourFilter (2), [...]
computational (computationally)
  • vtkPLOT3DReader (2), vtkCell (1), vtkInterpolatedVelocityField (1), vtkPixel (1), vtkVoxel (1), vtkWarpTransform (1)
computer
  • vtkButterflySubdivisionFilter (1), vtkCGMWriter (1), vtkCamera (1), vtkKochanekSpline (1), vtkPCAAnalysisFilter (1), vtkPLOT3DReader (1), vtkRenderer (1), vtkViewport (1)
comunicate
  • vtkCompositeManager (1), vtkTreeComposite (1)
concat
  • vtkAbstractTransform (4)
concatenate (concatenated, concatenates, concatenating, concatenation, concatenations)
  • vtkPerspectiveTransform (20), vtkTransform (17), vtkGeneralTransform (15), vtkAbstractTransform (7), vtkAssemblyPath (2), vtkProp3D (2), vtkAssembly (1), vtkAssemblyNode (1), vtkCamera (1), vtkFieldData (1), [...]
concatentation
  • vtkAssemblyPath (1)
concave
  • vtkEarthSource (1), vtkSelectPolyData (1)
concept
  • vtkImageWindow (1)
concerns (concerned)
  • vtkCamera (1), vtkSource (1)
concrete
  • vtkCastToConcrete (1), vtkProgrammableSource (7), vtkProgrammableFilter (5), vtkDataObjectToDataSetFilter (3), vtkInitialValueProblemSolver (3), vtkDataObject (2), vtkGenericCell (2), vtkInteractorStyleFlight (2), vtkMesaRenderer (2), vtkOpenGLRenderer (2), [...]
condition (conditions)
  • vtkDataObject (2), vtkMath (2), vtkCellArray (1), vtkDecimatePro (1), vtkGeometryFilter (1), vtkVolumeProMapper (1), vtkVolumeTextureMapper2D (1), vtkXMLParser (1)
cone
  • vtkCone (10), vtkConeSource (10), vtkArrowSource (6), vtkLight (2), vtkVRMLImporter (1)
conference
  • vtkButterflySubdivisionFilter (1)
configuration (configurations)
  • vtkMPIEventLog (1), vtkSystemIncludes (1), vtkThinPlateSplineTransform (1), vtkVolumeMapper (1)
configured
  • vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkSelectPolyData (1)
confine (confined)
  • vtkImageReslice (2), vtkOBBTree (1)
conflicts
  • vtkImageEuclideanDistance (1)
conforms
  • vtkImageExport (1)
confuse (confusing, confusion)
  • vtkAbstractPropPicker (2), vtkRIBExporter (1), vtkTreeComposite (1)
conglomeration
  • vtkImplicitModeller (1)
conjugate
  • vtkMath (2)
conjunction
  • vtkCellArray (4), vtkAxisActor2D (2), vtkCharArray (2), vtkInteractorStyleUser (2), vtkPlaneSource (2), vtkBitArray (1), vtkCaptionActor2D (1), vtkDataArray (1), vtkDataObjectToDataSetFilter (1), vtkDoubleArray (1), [...]
connect (connected, connecting, connection, connections, connects)
  • vtkConnectivityFilter (8), vtkPolyDataConnectivityFilter (7), vtkImageSeedConnectivity (5), vtkImageConnector (2), vtkSelectPolyData (5), vtkSmoothPolyDataFilter (5), vtkSocketCommunicator (4), vtkHull (3), vtkLinkEdgels (3), vtkRuledSurfaceFilter (3), [...]
connectivity
  • vtkConnectivityFilter (7), vtkPolyDataConnectivityFilter (4), vtkImageSeedConnectivity (1), vtkCellArray (6), vtkDataObjectToDataSetFilter (5), vtkSmoothPolyDataFilter (3), vtkWindowedSincPolyDataFilter (3), vtkCell (2), vtkExplicitCell (2), vtkImageConnector (2), [...]
connector
  • vtkImageCanvasSource2D (1)
conoturs
  • vtkBandedPolyDataContourFilter (1)
conquer
  • vtkPolygon (1)
consequence
  • vtkTimeStamp (1)
conservative
  • vtkDecimatePro (1)
conserve (conserving)
  • vtkBitArray (1), vtkCharArray (1), vtkDataArray (1), vtkDataObject (1), vtkDoubleArray (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkLongArray (1), vtkShortArray (1), [...]
considers
  • vtkImageOpenClose3D (1), vtkImplicitModeller (1), vtkPointSet (1)
consistency
  • vtkPolyDataNormals (2), vtkTriangle (2), vtkDataObject (1), vtkDataObjectSource (1), vtkImageMultipleInputFilter (1), vtkPoints (1), vtkSource (1)
consistent
  • vtkDataObjectToDataSetFilter (3), vtkPolyDataNormals (2), vtkBranchExtentTranslator (1), vtkFieldDataToAttributeDataFilter (1), vtkImageEuclideanDistance (1), vtkImageFFT (1), vtkImageRFFT (1), vtkInteractorStyleTrackball (1), vtkScalarsToColors (1), vtkXYPlotActor (1)
console
  • vtkFileOutputWindow (1), vtkOutputWindow (1)
const
  • vtkImplicitFunction (1)
constant (constantly, constants)
  • vtkImageConstantPad (2), vtkImageMandelbrotSource (7), vtkImageToPolyDataFilter (4), vtkMath (3), vtkFunctionSet (2), vtkInteractorStyleTrackball (2), vtkLight (2), vtkPLOT3DReader (2), vtkSetGet (2), vtkStreamPoints (2), [...]
constant-time
  • vtkDashedStreamLine (1)
constituents
  • vtkGeneralTransform (1), vtkPerspectiveTransform (1), vtkTransform (1)
constitutes
  • vtkDecimate (1), vtkMatrix4x4 (1)
constrain (constrained)
  • vtkDelaunay2D (7), vtkSmoothPolyDataFilter (3), vtkIterativeClosestPointTransform (2), vtkGlyph2D (1), vtkLandmarkTransform (1), vtkProcrustesAlignmentFilter (1), vtkSetGet (1), vtkStreamer (1)
constraint (constraints)
  • vtkDelaunay2D (3), vtkDecimate (2), vtkDecimatePro (2), vtkSpline (2)
constrast
  • vtkLightKit (1)
construct (constructing, construction, constructs)
  • vtkSurfaceReconstructionFilter (1), vtkFieldDataToAttributeDataFilter (15), vtkDelaunay2D (3), vtkDelaunay3D (3), vtkStripper (3), vtkCellDerivatives (2), vtkDataObjectToDataSetFilter (2), vtkPiecewiseFunction (2), vtkPolyDataConnectivityFilter (2), vtkArrowSource (1), [...]
constructur
  • vtkMultiProcessLog (1), vtkThreadSafeLog (1)
consumed
  • vtkCellArray (2), vtkAbstractMapper (1), vtkActor (1), vtkActor2D (1), vtkAssembly (1), vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkCellLinks (1), vtkCellTypes (1), vtkCubeAxesActor2D (1), [...]
consumer (consumers)
  • vtkDataObject (5), vtkAbstractMapper (3), vtkProp (3)
consumption
  • vtkDataReader (1)
contain (contained, containing, contains)
  • vtkCellLocator (4), vtkMath (4), vtkDelaunay2D (3), vtkDelaunay3D (3), vtkImporter (3), vtkMPICommunicator (3), vtkObjectFactory (3), vtkPLOT3DReader (3), vtkPOPReader (3), vtkRIBExporter (3), [...]
container (containers)
  • vtkContainer (9), vtkUnstructuredGrid (4), vtkAbstractList (1), vtkImageFourierFilter (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
conte
  • vtkMath (1)
contents
  • vtkVideoSource (3), vtkAssemblyPath (2), vtkImageFourierFilter (2), vtkImageWindow (2), vtkMesaImageWindow (2), vtkOpenGLImageWindow (2), vtkContourValues (1), vtkImageData (1), vtkImager (1), vtkMPIGroup (1), [...]
context (contexts)
  • vtkQuartzImageWindow (4), vtkQuartzRenderWindow (4), vtkWin32OpenGLImageWindow (4), vtkWin32OpenGLRenderWindow (4), vtkWinCEOpenGLRenderWindow (4), vtkMPICommunicator (2), vtkMPIController (2), vtkMesaImageWindow (2), vtkMultiProcessController (2), vtkOpenGLImageWindow (2), [...]
contiguous
  • vtkImageReader2 (1)
continents
  • vtkEarthSource (4)
continually
  • vtkFollower (1)
continue (continuing)
  • vtkAxes (1), vtkInteractorStyleJoystickActor (1), vtkProp (1), vtkSpline (1), vtkVoxelContoursToSurfaceFilter (1), vtkWeightedTransformFilter (1)
continuity
  • vtkKochanekSpline (4)
continuously
  • vtkInteractorStyle (1), vtkInteractorStyleUser (1)
contour (contoured, contouring, contours)
  • vtkBandedPolyDataContourFilter (34), vtkContourFilter (22), vtkMarchingContourFilter (22), vtkContourGrid (21), vtkContourValues (16), vtkVoxelContoursToSurfaceFilter (14), vtkKitwareContourFilter (8), vtkMarchingSquares (20), vtkImageMarchingCubes (19), vtkMarchingCubes (18), [...]
contract
  • vtkTreeComposite (1)
contracting
  • vtkQuadricDecimation (1)
contrast (contrasted)
  • vtkLightKit (3), vtkAssembly (1), vtkMCubesReader (1), vtkMILVideoSource (1), vtkPropAssembly (1), vtkWindowedSincPolyDataFilter (1)
contribution (contributed, contributing)
  • vtkGaussianSplatter (2), vtkShepardMethod (2), vtkEncodedGradientShader (1), vtkImplicitSum (1), vtkLightKit (1), vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1), vtkQuadricClustering (1), vtkWeightedTransformFilter (1)
controled (controlling)
  • vtkButtonSource (1), vtkCell (1), vtkDataObjectReader (1), vtkDataSetReader (1), vtkInteractorStyleImage (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1), vtkPolyDataReader (1), [...]
controller (controllers)
  • vtkMultiProcessController (9), vtkThreadedController (6), vtkMPIController (3), vtkOutputPort (6), vtkCompositeManager (2), vtkInputPort (2), vtkMPIGroup (2), vtkMPICommunicator (1), vtkTransmitPolyDataPiece (1), vtkTransmitUnstructuredGridPiece (1)
contruct
  • vtkPDataSetWriter (1)
conv
  • vtkInteractorStyleImage (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleTrackball (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1)
conveinence
  • vtkInteractorStyleUnicam (1)
conveniance
  • vtkMultiProcessController (1)
conveniece
  • vtkVolumeProMapper (1)
convenience
  • vtkDataArray (5), vtkPolyData (4), vtkDataSet (3), vtkMultiProcessController (3), vtkAbstractPropPicker (1), vtkAppendFilter (1), vtkAssemblyPath (1), vtkBranchExtentTranslator (1), vtkCamera (1), vtkCellDataToPointData (1), [...]
convenient
  • vtkImageReslice (2), vtkCGMWriter (1), vtkExporter (1), vtkImageActor (1), vtkRayCastStructures (1), vtkWriter (1)
convention (conventions)
  • vtkRIBExporter (2), vtkImageImport (1)
conventional
  • vtkHeap (1), vtkMath (1)
converge
  • vtkWarpTransform (1), vtkWindowedSincPolyDataFilter (1)
convergence
  • vtkSmoothPolyDataFilter (5), vtkIterativeClosestPointTransform (2), vtkProcrustesAlignmentFilter (1), vtkWindowedSincPolyDataFilter (1)
conversion
  • vtkDataSetToDataObjectFilter (5), vtkCleanPolyData (4), vtkFieldData (2), vtkBitArray (1), vtkCharArray (1), vtkColorTransferFunction (1), vtkDoubleArray (1), vtkGeometryFilter (1), vtkIdTypeArray (1), vtkIntArray (1), [...]
convert (converted, converting, converts)
  • vtkViewport (7), vtkPythonUtil (4), vtkRenderer (4), vtkBlankStructuredGrid (3), vtkCGMWriter (3), vtkScalarsToColors (3), vtkTransformToGrid (3), vtkCamera (2), vtkCoordinate (2), vtkGeometryFilter (2), [...]
convex
  • vtkPlanes (5), vtkHull (4), vtkDelaunay2D (3), vtkDelaunay3D (3), vtkDataSetTriangleFilter (1), vtkImageToPolyDataFilter (1), vtkImplicitSelectionLoop (1), vtkOBBTree (1), vtkPolygon (1)
convienence
  • vtkImageMandelbrotSource (3), vtkImageData (1)
convolution (convolutions)
  • vtkImageSeparableConvolution (10), vtkImageGaussianSmooth (3), vtkImageConvolve (1), vtkWindowedSincPolyDataFilter (1)
convolve (convolves)
  • vtkImageConvolve (1), vtkImageSeparableConvolution (1)
cookie-cutter
  • vtkImageStencil (1)
cool
  • vtkGraphLayoutFilter (1), vtkLightKit (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
cool-down
  • vtkGraphLayoutFilter (3)
cooler
  • vtkLightKit (3)
coord (coords)
  • vtkArcPlotter (1), vtkCell (1), vtkExtractTensorComponents (1), vtkFieldDataToAttributeDataFilter (1), vtkInteractorStyleTrackball (1), vtkLabeledDataMapper (1), vtkProgrammableAttributeDataFilter (1), vtkStreamer (1), vtkTexture (1)
coordaintes
  • vtkCaptionActor2D (1)
coordinate (coordinated, coordinates)
  • vtkCoordinate (26), vtkParallelCoordinatesActor (10), vtkViewport (29), vtkTriangle (14), vtkImplicitTextureCoords (13), vtkRectilinearGrid (13), vtkRenderer (13), vtkCamera (12), vtkCell (12), vtkAbstractPicker (11), [...]
cooresponding
  • vtkPDataSetWriter (1)
cootes
  • vtkPCAAnalysisFilter (2)
coplanar
  • vtkImplicitSelectionLoop (1)
copy (COPY)
  • vtkDataSetAttributes (49), vtkFieldData (15), vtkMaskFields (12), vtkByteSwap (6), vtkCell (6), vtkRearrangeFields (6), vtkImageImport (4), vtkPoints (4), vtkPolyData (4), vtkAbstractTransform (3), [...]
copyright
  • vtkPLY (2), vtkInteractorStyleUnicam (1), vtkVRML (1), vtkVRMLImporter (1)
core
  • vtkIterativeClosestPointTransform (1), vtkProgrammableAttributeDataFilter (1)
corkscrews
  • vtkRotationalExtrusionFilter (1)
corner (corners)
  • vtkOutlineCornerFilter (6), vtkOutlineCornerSource (5), vtkImageAnisotropicDiffusion2D (3), vtkImageAnisotropicDiffusion3D (3), vtkActor2D (2), vtkCaptionActor2D (2), vtkImageExport (2), vtkImageHybridMedian2D (2), vtkImageImport (2), vtkImageReader2 (2), [...]
corona
  • vtkMILVideoSource (1)
correcting (corrected)
  • vtkVolume (2), vtkOBBTree (1)
correlate (correlation)
  • vtkImageCorrelation (5), vtkInteractorStyleUnicam (1), vtkNonLinearCell (1)
correspond (corresponds)
  • vtkLightKit (4), vtkAssemblyPath (1), vtkAssignAttribute (1), vtkBandedPolyDataContourFilter (1), vtkDelaunay2D (1), vtkFieldData (1), vtkImageData (1), vtkInteractorStyleFlight (1), vtkLandmarkTransform (1), vtkProp (1), [...]
correspondance
  • vtkXYPlotActor (1)
correspondence
  • vtkProbeFilter (2), vtkCell (1), vtkPlanes (1), vtkScalarBarActor (1)
corrupted
  • vtkCellArray (1), vtkPolyDataNormals (1)
cosine (cosines)
  • vtkImageReslice (3), vtkDecimatePro (1), vtkImageSinusoidSource (1), vtkLight (1), vtkLinkEdgels (1)
cost (costs)
  • vtkQuadricDecimation (3), vtkContourFilter (1), vtkContourGrid (1), vtkCriticalSection (1), vtkFieldData (1), vtkKitwareContourFilter (1), vtkMarchingContourFilter (1)
count (counted, counting, counts)
  • vtkObject (10), vtkContainer (6), vtkSetGet (6), vtkPLY (4), vtkCellArray (3), vtkCommand (3), vtkAbstractPropPicker (2), vtkAssemblyNode (2), vtkDataObject (2), vtkMPICommunicator (2), [...]
counter-clockwise
  • vtkDelaunay2D (1), vtkLightKit (1), vtkTextureMapToSphere (1)
counterclockwise
  • vtkDEMReader (1)
counterpart
  • vtkContainer (1), vtkImager (1), vtkMesaImager (1), vtkOpenGLImager (1)
couple (coupled)
  • vtkDataObjectToDataSetFilter (1), vtkParticleReader (1), vtkStreamPoints (1), vtkVectorText (1), vtkVolumeRayCastFunction (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
courier
  • vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkCubeAxesActor2D (1), vtkLabeledDataMapper (1), vtkLegendBoxActor (1), vtkParallelCoordinatesActor (1), vtkScalarBarActor (1), vtkTextMapper (1), vtkXYPlotActor (1)
course
  • vtkAppendPolyData (1), vtkImageReader2Factory (1), vtkSynchronizedTemplates2D (1)
covariance
  • vtkOBBTree (2)
cover (covered, covers)
  • vtkFrustumCoverageCuller (1), vtkVolumeRayCastMapper (2), vtkWeightedTransformFilter (2), vtkImageAppend (1)
coverage
  • vtkFrustumCoverageCuller (9), vtkDEMReader (1), vtkLODProp3D (1), vtkVolume (1)
cputime
  • vtkTimerLog (2)
crash (CRASH)
  • vtkDataSet (1), vtkEncodedGradientEstimator (1), vtkMPIController (1)
createtimer
  • vtkRenderWindowInteractor (1)
creative
  • vtkImageSobel3D (1)
creator (creators)
  • vtkInstantiator (3), vtkProcessObject (1)
credits
  • vtkLightKit (1)
crisp
  • vtkPolyDataNormals (1)
criterion
  • vtkThreshold (10), vtkThresholdTextureCoords (9), vtkThresholdPoints (6), vtkDelaunay2D (4), vtkDelaunay3D (3), vtkConnectivityFilter (2), vtkDecimate (2), vtkOrderedTriangulator (2), vtkSmoothPolyDataFilter (2), vtkPolyDataConnectivityFilter (1), [...]
critical
  • vtkCriticalSection (2), vtkObjectFactory (1), vtkRegressionTestImage (1)
crop (cropped, cropping, crops)
  • vtkVolumeMapper (6), vtkDataObject (3), vtkImageConvolve (1), vtkImageReslice (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1), vtkVolumeRayCastFunction (1)
cross (crossed, crosses)
  • vtkMath (6), vtkGlyphSource2D (5), vtkHyperStreamline (5), vtkImplicitSelectionLoop (3), vtkCamera (2), vtkVolumeMapper (2), vtkArrowSource (1), vtkConeSource (1), vtkLine (1), vtkLookupTable (1), [...]
cross-section
  • vtkProjectedTexture (1)
crout
  • vtkMath (1)
crystal
  • vtkInteractorStyle (1)
ctrl (CTRL)
  • vtkInteractorStyleFlight (2), vtkInteractorStyleImage (2), vtkInteractorStyleJoystickActor (2), vtkInteractorStyleJoystickCamera (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2)
cube (cubes)
  • vtkCubeSource (9), vtkMCubesReader (6), vtkSliceCubes (6), vtkMCubesWriter (5), vtkCubeAxesActor2D (2), vtkMarchingCubesCases (1), vtkEdgePoints (3), vtkHull (3), vtkStructuredGrid (2), vtkExtentTranslator (1), [...]
cubic
  • vtkMath (2)
cubical
  • vtkDelaunay3D (1), vtkImageData (1)
cuisenai
  • vtkImageEuclideanDistance (1)
cuisenaire
  • vtkImageEuclideanDistance (2)
cull (culled, culling)
  • vtkFrustumCoverageCuller (4), vtkCuller (2), vtkProperty (6), vtkRenderer (2), vtkDicer (1), vtkOBBDicer (1), vtkPolyDataNormals (1), vtkProp (1), vtkViewport (1), vtkVolumeRayCastMapper (1)
culler (cullers)
  • vtkCullerCollection (5), vtkCuller (3), vtkRenderer (5), vtkLODProp3D (1)
cumulative (cumulatively)
  • vtkCleanPolyData (1), vtkXYPlotActor (1)
cursor (cursors)
  • vtkCursor3D (12), vtkImageCursor3D (6), vtkVolumeProMapper (6), vtkInteractorStyleUnicam (3), vtkQuartzRenderWindow (3), vtkRenderWindow (3), vtkRenderWindowInteractor (3), vtkWin32OpenGLRenderWindow (3), vtkWinCEOpenGLRenderWindow (3), vtkXMesaRenderWindow (3), [...]
curve (curved, curves)
  • vtkXYPlotActor (11), vtkKochanekSpline (5), vtkButtonSource (3), vtkStructuredGridGeometryFilter (3), vtkLinkEdgels (2), vtkImageButterworthHighPass (1), vtkImageButterworthLowPass (1), vtkRectilinearGridGeometryFilter (1), vtkSubPixelPositionEdgels (1)
custom
  • vtkImageMapper (2), vtkRIBExporter (2), vtkInteractorStyleUser (1), vtkProgrammableAttributeDataFilter (1), vtkThinPlateSplineTransform (1)
customizable
  • vtkInteractorStyleUser (1)
customize
  • vtkInteractorStyleUser (2), vtkCoordinate (1)
cutoff
  • vtkOpenGLStateCache (3), vtkImageButterworthHighPass (2), vtkImageButterworthLowPass (2), vtkImageIdealHighPass (2), vtkImageIdealLowPass (1), vtkImageIslandRemoval2D (1)
cuts (cutting)
  • vtkClipPolyData (3), vtkClipDataSet (2), vtkClipVolume (2), vtkCutter (2), vtkImplicitWindowFunction (1), vtkLine (1), vtkQuad (1), vtkQuadraticEdge (1), vtkTriangle (1)
cycle (cycles)
  • vtkAssembly (1), vtkCriticalSection (1), vtkImageButterworthHighPass (1), vtkImageButterworthLowPass (1), vtkImageIdealHighPass (1), vtkImageIdealLowPass (1), vtkImageMandelbrotSource (1), vtkImageSkeleton2D (1), vtkProp (1), vtkPropAssembly (1), [...]
cylinder (cylinders)
  • vtkTextureMapToCylinder (13), vtkCylinder (10), vtkCylinderSource (10), vtkWeightedTransformFilter (2), vtkArrowSource (1), vtkEncodedGradientEstimator (1), vtkRotationalExtrusionFilter (1), vtkVRMLImporter (1)
cylinder-like
  • vtkImplicitSelectionLoop (1)
cylindrical
  • vtkRotationalExtrusionFilter (1), vtkWeightedTransformFilter (1)

d
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
dangerous
  • vtkBitArray (1), vtkCharArray (1), vtkDoubleArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkLongArray (1), vtkObject (1), vtkShortArray (1), vtkUnsignedCharArray (1), vtkUnsignedIntArray (1), [...]
dangling
  • vtkAbstractPropPicker (1)
daniel
  • vtkVRML (1), vtkVRMLImporter (1)
dark
  • vtkRenderer (1)
dash (dashed, dashes)
  • vtkDashedStreamLine (11), vtkGlyphSource2D (2), vtkStreamer (1)
dashboard
  • vtkRegressionTestImage (1)
dataset (DATASET, datasets)
  • vtkDataSet (28), vtkDataObjectToDataSetFilter (20), vtkDataSetToDataObjectFilter (12), vtkImplicitDataSet (8), vtkDataSetCollection (5), vtkDataSetTriangleFilter (5), vtkClipDataSet (4), vtkInterpolateDataSetAttributes (4), vtkDataSetAttributes (3), vtkDataSetToDataSetFilter (3), [...]
date
  • vtkImageImport (2), vtkDataSetAttributes (1), vtkImageData (1), vtkSelectVisiblePoints (1), vtkSetGet (1), vtkWriter (1)
dated
  • vtkWindowedSincPolyDataFilter (1)
datset
  • vtkRectilinearGrid (1)
david
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
daylight
  • vtkLightKit (1)
deadlock
  • vtkTransmitPolyDataPiece (1), vtkTransmitUnstructuredGridPiece (1)
deal (deals)
  • vtkMarchingSquares (1), vtkSetGet (1), vtkVRMLImporter (1)
deallocation (deallocated, deallocating)
  • vtkCellLocator (5), vtkImageImport (1), vtkPriorityQueue (1)
dealloction
  • vtkCellLocator (1)
debug (debugging)
  • vtkObject (9), vtkSetGet (5), vtkXMLFileOutputWindow (2), vtkCompositeManager (1), vtkContainer (1), vtkDataObjectSource (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkFileOutputWindow (1), vtkGlyph3D (1), [...]
debugger
  • vtkObject (1)
decay
  • vtkGaussianSplatter (1)
decent
  • vtkWarpTransform (1)
decentering
  • vtkWarpLens (2)
decide (decides)
  • vtkGlyph3D (4), vtkAxisActor2D (2), vtkClipDataSet (2), vtkClipPolyData (2), vtkClipVolume (2), vtkDataObject (1), vtkLookupTable (1), vtkRuledSurfaceFilter (1)
decimate (decimated, decimation)
  • vtkDecimate (10), vtkDecimatePro (6), vtkImageToPolyDataFilter (3), vtkImageFourierFilter (2), vtkQuadricDecimation (1)
decimiated
  • vtkQuadricClustering (1)
declarations
  • vtkRIBProperty (2), vtkRIBExporter (1)
declared
  • vtkRIBProperty (1)
decode (Decodes)
  • vtkDataReader (1), vtkSLCReader (1)
decoded
  • vtkDirectionEncoder (1), vtkRecursiveSphereDirectionEncoder (1)
decompose (decomposed)
  • vtkGeneralTransform (1), vtkImageFFT (1), vtkImageRFFT (1), vtkImageSeparableConvolution (1), vtkPerspectiveTransform (1), vtkTransform (1), vtkTriangleStrip (1)
decomposition
  • vtkMath (3)
decoupling
  • vtkWindowedSincPolyDataFilter (1)
decrease (decreasing)
  • vtkCamera (2), vtkMath (2), vtkPiecewiseFunction (2), vtkCommand (1), vtkCompositeManager (1), vtkContainer (1), vtkImageExport (1), vtkInteractorStyle (1), vtkInteractorStyleFlight (1), vtkObject (1)
decremented
  • vtkRearrangeFields (1)
decription
  • vtkDataObjectToDataSetFilter (4), vtkFunctionParser (1), vtkMultiProcessLog (1), vtkThreadSafeLog (1)
decsription
  • vtkDecimate (1)
deep
  • vtkMultiProcessController (2), vtkBitArray (1), vtkCellArray (1), vtkCharArray (1), vtkDataArray (1), vtkDataObject (1), vtkDataSet (1), vtkDataSetAttributes (1), vtkDoubleArray (1), vtkFloatArray (1), [...]
deeper
  • vtkOBBTree (1), vtkSimpleScalarTree (1)
deepest
  • vtkRenderer (1)
defaulted
  • vtkEncodedGradientEstimator (1)
defect
  • vtkVolumeTextureMapper2D (1)
defer
  • vtkDecimatePro (1)
deferred
  • vtkDecimatePro (1), vtkOpenGLStateCache (1)
definitely
  • vtkVideoSource (1)
definitions
  • vtkImageQuantizeRGBToIndex (2), vtkDataObject (1), vtkRayCastStructures (1), vtkSTLReader (1)
deform
  • vtkImageReslice (1), vtkWarpLens (1), vtkWarpScalar (1), vtkWarpTo (1), vtkWarpVector (1), vtkWeightedTransformFilter (1)
deformation
  • vtkWarpVector (1), vtkWeightedTransformFilter (1)
defualt
  • vtkRuledSurfaceFilter (1), vtkTransmitPolyDataPiece (1), vtkTransmitUnstructuredGridPiece (1)
degenerate (degeneracy)
  • vtkCleanPolyData (7), vtkOrderedTriangulator (3), vtkDelaunay2D (2), vtkDelaunay3D (2), vtkTriangle (2), vtkCell (1), vtkClipVolume (1), vtkImageDilateErode3D (1), vtkImageOpenClose3D (1), vtkMCubesReader (1), [...]
degree (degrees)
  • vtkDecimatePro (6), vtkWindowedSincPolyDataFilter (6), vtkSphereSource (5), vtkCamera (4), vtkDecimate (4), vtkProp3D (4), vtk3DS (3), vtkCone (2), vtkFollower (2), vtkGeneralTransform (2), [...]
degree-of-freedom
  • vtkLinearTransform (1)
delaunay
  • vtkDelaunay3D (13), vtkDelaunay2D (11), vtkOrderedTriangulator (8)
delegate (delegated)
  • vtkMPIController (2), vtkBandedPolyDataContourFilter (1), vtkContourFilter (1), vtkContourGrid (1), vtkCutter (1), vtkDataObjectWriter (1), vtkDataWriter (1), vtkGridSynchronizedTemplates3D (1), vtkImageMarchingCubes (1), vtkMarchingContourFilter (1), [...]
delete (deleted, deletes, deleting, deletion)
  • vtkTestUtilities (8), vtkDecimate (6), vtkDecimatePro (6), vtkObject (6), vtkProcessObject (6), vtkDelaunay3D (5), vtkPolyData (5), vtkAbstractPicker (4), vtkOutputWindow (4), vtkPriorityQueue (4), [...]
delimited
  • vtkTextMapper (1)
delta
  • vtkImageTranslateExtent (1)
deltas
  • vtkTimerLog (1)
deltat
  • vtkInitialValueProblemSolver (1)
denominator
  • vtkImageData (1), vtkRectilinearGrid (1), vtkStructuredGrid (1)
dense
  • vtkDividingCubes (2), vtkRecursiveDividingCubes (2), vtkIterativeClosestPointTransform (1)
density
  • vtkPLOT3DReader (3), vtkDividingCubes (1), vtkEdgePoints (1)
department
  • vtkInteractorStyleUnicam (1), vtkTreeComposite (1)
depend
  • vtkImplicitSelectionLoop (1), vtkSelectPolyData (1), vtkStreamLine (1)
dependencies
  • vtkImplicitBoolean (1), vtkImplicitSum (1), vtkImplicitWindowFunction (1), vtkgluPickMatrix (1)
dependency
  • vtkArcPlotter (1), vtkImplicitDataSet (1)
deprecated
  • vtkInteractorStyleUser (2), vtkWindowLevelLookupTable (2), vtkAbstractTransform (1), vtkActor (1), vtkCamera (1), vtkMatrixToHomogeneousTransform (1), vtkMatrixToLinearTransform (1)
depricated
  • vtkColorTransferFunction (1)
depth
  • vtkButtonSource (3), vtkRenderWindow (3), vtkCamera (2), vtkLocator (2), vtkNonLinearCell (2), vtkPolyDataNormals (2), vtkRecursiveSphereDirectionEncoder (2), vtkRendererSource (2), vtkXImageWindow (2), vtkAbstractPicker (1), [...]
dereference (dereferences, dereferencing)
  • vtkGenericCell (2), vtkAssemblyNode (1)
deriv (derived, deriving, derivs)
  • vtkCell (3), vtkPLOT3DReader (3), vtkAbstractTransform (2), vtkDataSet (2), vtkDataSetMapper (2), vtkImplicitFunction (2), vtkCellLocator (1), vtkCollection (1), vtkDelaunay2D (1), vtkDelaunay3D (1), [...]
derivative (derivatives)
  • vtkCellDerivatives (5), vtkSpline (6), vtkCell (5), vtkWarpTransform (4), vtkTreeComposite (2), vtkAbstractTransform (1), vtkGeneralTransform (1), vtkHexahedron (1), vtkHomogeneousTransform (1), vtkIdentityTransform (1), [...]
descendants
  • vtkAssembly (2)
descending
  • vtkPCAAnalysisFilter (2)
describe (describes, describing)
  • vtkImageImport (5), vtkPerspectiveTransform (3), vtkLight (2), vtkMath (2), vtkTransform (2), vtkAbstractPropPicker (1), vtkCamera (1), vtkGridTransform (1), vtkImageStencilData (1), vtkKochanekSpline (1), [...]
desctructor
  • vtkActor2DCollection (1), vtkCellData (1)
design
  • vtkWindowedSincPolyDataFilter (2), vtkCommand (1), vtkObject (1)
designated
  • vtkRenderer (1)
destination
  • vtkCommunicator (2)
destroy (destroyed, destroying)
  • vtkVideoSource (2), vtkAbstractPropPicker (1), vtkAssemblyNode (1), vtkCellLinks (1), vtkMath (1), vtkWin32OutputWindow (1)
destruct (destruction)
  • vtkDebugLeaks (1), vtkMPICommunicator (1), vtkObject (1), vtkSocketController (1)
destructor
  • vtkImageCanvasSource2D (1), vtkMILVideoSource (1), vtkMultiProcessLog (1), vtkThreadSafeLog (1), vtkTimerLog (1), vtkVersion (1), vtkWin32VideoSource (1)
detach
  • vtkDynamicLoader (1)
detail (details)
  • vtkLODActor (11), vtkLODProp3D (4), vtkRearrangeFields (3), vtkEarthSource (2), vtkProp3D (2), vtkDataObjectReader (1), vtkDataSetReader (1), vtkDirectionEncoder (1), vtkMPIEventLog (1), vtkMassProperties (1), [...]
detect
  • vtkPointSet (1)
detector
  • vtkLinkEdgels (1)
detects (detected, detection)
  • vtkDataObject (1), vtkRenderWindow (1), vtkRenderWindowInteractor (1), vtkSTLReader (1), vtkSpatialRepresentationFilter (1), vtkVolumeRayCastMapper (1)
detemines
  • vtkInteractorStyleJoystickActor (1)
determinant (determinants)
  • vtkMath (11), vtkExtractTensorComponents (2), vtkMatrix4x4 (1)
develop (developed)
  • vtkCellLocator (1), vtkPCAAnalysisFilter (1), vtkParticleReader (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkProcrustesAlignmentFilter (1), vtkVideoSource (1)
developers
  • vtkCommand (1), vtkErrorCode (1)
development
  • vtkBranchExtentTranslator (1), vtkDataObject (1), vtkExtentTranslator (1)
deviation (deviations)
  • vtkImageGaussianSmooth (2), vtkPCAAnalysisFilter (2), vtkImageGaussianSource (1), vtkMassProperties (1), vtkNonLinearCell (1), vtkPointSource (1), vtkRTAnalyticSource (1)
device (devices)
  • vtkVideoSource (6), vtkImageToPolyDataFilter (2), vtkProperty (1), vtkProperty2D (1), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkRenderer (1), vtkViewport (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), [...]
device-specific
  • vtkPolyDataMapper (1)
diagonal
  • vtkMath (3), vtkInteractorStyleFlight (2), vtkSmoothPolyDataFilter (2), vtkAbstractMapper3D (1), vtkCaptionActor2D (1), vtkCell (1), vtkCleanPolyData (1), vtkDataSet (1), vtkDecimatePro (1), vtkDelaunay2D (1), [...]
diagonalize
  • vtkMath (1)
dialog
  • vtkWin32VideoSource (2)
diameter
  • vtkOBBTree (3), vtkProperty (1), vtkProperty2D (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
dicarded
  • vtkQuadricClustering (1)
didn
  • vtkWarpTransform (1)
difference (differences)
  • vtkImageDifference (4), vtkFiniteDifferenceGradientEstimator (3), vtkImageAnisotropicDiffusion3D (5), vtkImageAnisotropicDiffusion2D (4), vtkLinkEdgels (3), vtkImageData (2), vtkImageGradient (2), vtkWin32Header (2), vtkAssembly (1), vtkCamera (1), [...]
differential
  • vtkInitialValueProblemSolver (1)
differs
  • vtkImageIterateFilter (1), vtkOrderedTriangulator (1), vtkRecursiveDividingCubes (1)
difficult
  • vtkCleanPolyData (1), vtkWeightedTransformFilter (1)
diffuse (diffused, diffuses, diffusion)
  • vtkImageAnisotropicDiffusion2D (12), vtkImageAnisotropicDiffusion3D (9), vtkProperty (8), vtkEncodedGradientShader (7), vtkVolumeProperty (2), vtkLightKit (1), vtkVolumeProMapper (1), vtkWindowedSincPolyDataFilter (1)
digital
  • vtkDEMReader (4), vtkLinkEdgels (2), vtkSubPixelPositionEdgels (1)
digitised
  • vtkImageEuclideanDistance (1)
digitizer (digitizers)
  • vtkMILVideoSource (4), vtkWin32VideoSource (1)
dihedral
  • vtkDecimate (2), vtkDecimatePro (1), vtkFeatureEdges (1)
dilate (dilated, dilates)
  • vtkImageDilateErode3D (5), vtkImageContinuousDilate3D (2), vtkImageOpenClose3D (4)
dimension (dimensions)
  • vtkDataObjectToDataSetFilter (9), vtkStructuredData (9), vtkImageData (6), vtkCell (4), vtkExtractGrid (4), vtkGaussianSplatter (4), vtkMath (4), vtkRectilinearGrid (4), vtkShepardMethod (4), vtkButtonSource (3), [...]
dimensional
  • vtkImageGaussianSmooth (2), vtkAbstractList (1), vtkActor2D (1), vtkCell (1), vtkCutter (1), vtkGraphLayoutFilter (1), vtkImageDilateErode3D (1), vtkImageFFT (1), vtkImageGradient (1), vtkImageGradientMagnitude (1), [...]
dimensionality
  • vtkImageDecomposeFilter (4), vtkImageReslice (3), vtkImageLaplacian (2), vtkImageResample (2), vtkContourFilter (1), vtkContourGrid (1), vtkImageAccumulate (1), vtkImageConnector (1), vtkImageData (1), vtkImageGaussianSmooth (1), [...]
dimensioonality
  • vtkImageGaussianSmooth (1)
dimmer
  • vtkLightKit (3)
direction (directions)
  • vtkRecursiveSphereDirectionEncoder (10), vtkDirectionEncoder (8), vtkCamera (13), vtkDepthSortPolyData (13), vtkEncodedGradientEstimator (5), vtkInteractorStyle (5), vtkStreamer (5), vtkButtonSource (4), vtkImageReslice (4), vtkPlaneSource (4), [...]
directional
  • vtkLight (2), vtkLightKit (1)
directories
  • vtkDirectory (1)
directory
  • vtkDirectory (8), vtkPDataSetWriter (3), vtkEnSightReader (1), vtkTestUtilities (1)
disables (disabling)
  • vtkOpenGLStateCache (2), vtkInteractorStyleFlight (1), vtkQuartzRenderWindowInteractor (1), vtkRenderWindowInteractor (1), vtkSmoothPolyDataFilter (1), vtkWin32RenderWindowInteractor (1), vtkWindowedSincPolyDataFilter (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
disadvantage
  • vtkMapper (1)
disappear
  • vtkExporter (1)
disc
  • vtkDiskSource (2)
discards (discarded, discarding)
  • vtkRenderWindowInteractor (4), vtkDelaunay2D (2), vtkDelaunay3D (2), vtkCellArray (1), vtkOrderedTriangulator (1), vtkQuadricClustering (1)
disconnect (disconnected, disconnecting)
  • vtkDecimatePro (1), vtkShrinkFilter (1), vtkShrinkPolyData (1), vtkSource (1)
discovered
  • vtkCriticalSection (1)
discrete
  • vtkImageAccumulate (1), vtkMassProperties (1)
discretization
  • vtkSphereSource (1), vtkSuperquadricSource (1), vtkTexturedSphereSource (1)
discusses
  • vtkWindowedSincPolyDataFilter (1)
disjoint
  • vtkOBBTree (1)
disk
  • vtkDiskSource (4), vtkImageActor (2), vtkImageMapper (2), vtkCamera (1), vtkCellLocator (1), vtkDataSetWriter (1), vtkImageReader2 (1), vtkWriter (1)
dispaying
  • vtkImageFourierCenter (1)
dispersed
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
displacement (displacements)
  • vtkGridTransform (5), vtkBYUReader (3), vtkBYUWriter (3), vtkRIBProperty (2), vtkVectorDot (2), vtkWarpScalar (2), vtkInteractorStyleUser (1), vtkPerspectiveTransform (1), vtkSmoothPolyDataFilter (1), vtkWarpTo (1), [...]
display (DISPLAY, displayed, displaying, displays)
  • vtkViewport (11), vtkXRenderWindowInteractor (9), vtkXRenderWindowTclInteractor (9), vtkImageMapper (7), vtkXMesaRenderWindow (7), vtkXOpenGLRenderWindow (7), vtkCoordinate (6), vtkSelectVisiblePoints (5), vtkImageActor (4), vtkRenderWindowInteractor (4), [...]
displayable
  • vtkOverrideInformation (1)
distance (DISTANCE, distances)
  • vtkImageCityBlockDistance (10), vtkImageEuclideanDistance (8), vtkCamera (8), vtkImplicitModeller (8), vtkIterativeClosestPointTransform (8), vtkShepardMethod (7), vtkVolumeRayCastMapper (7), vtkVoxelModeller (5), vtkGaussianSplatter (4), vtkPerspectiveTransform (4), [...]
distinct
  • vtkMath (3), vtkDataWriter (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
distinguish
  • vtkMapper (2), vtkSetGet (1)
distortion (distorted)
  • vtkWarpLens (8), vtkGaussianSplatter (1), vtkWarpScalar (1)
distribute (distributed, distributes, distribution, distributions)
  • vtkGaussianSplatter (13), vtkPointSource (4), vtkPLY (3), vtkTreeComposite (2), vtkDataObjectToDataSetFilter (1), vtkDecimatePro (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkFieldDataToAttributeDataFilter (1), vtkInteractorStyleUnicam (1), [...]
divergence
  • vtkImageDivergence (3), vtkImageLaplacian (2), vtkMassProperties (1)
divide (divided, divides, dividing)
  • vtkEdgePoints (3), vtkDicer (2), vtkImageMathematics (2), vtkBandedPolyDataContourFilter (1), vtkImageAccumulate (1), vtkImageDataStreamer (1), vtkImageVariance3D (1), vtkImplicitSum (1), vtkLineSource (1), vtkLocator (1), [...]
divinding
  • vtkBandedPolyDataContourFilter (1)
divisible
  • vtkByteSwap (1)
divisions
  • vtkImageBlockReader (2), vtkImageCheckerboard (2), vtkPointLocator (2), vtkPointLocator2D (2), vtkQuadricClustering (2), vtkCellLocator (1), vtkImageBlockWriter (1), vtkOBBTree (1)
divs
  • vtkPointLocator (2)
documentation
  • vtkMPIEventLog (2), vtkGlyph2D (1), vtkImageAccumulate (1), vtkImageExport (1), vtkImageImport (1), vtkIterativeClosestPointTransform (1), vtkMapper (1), vtkMath (1), vtkOBBDicer (1), vtkPLY (1), [...]
dolly (DOLLY, dollying, dollys)
  • vtkInteractorStyleUnicam (8), vtkInteractorStyleImage (2), vtkRenderWindowInteractor (1)
dolly-in
  • vtkCamera (1)
dolly-out
  • vtkCamera (1)
domain
  • vtkImageIdealHighPass (5), vtkImageButterworthHighPass (3), vtkImageButterworthLowPass (3), vtkImageIdealLowPass (3), vtkPointLoad (2), vtkPLOT3DReader (1)
dots (dotting)
  • vtkSimpleElevationFilter (1), vtkWindow (1)
double (doubles)
  • vtkDoubleArray (4), vtkImageMandelbrotSource (8), vtkWinCE (4), vtkByteSwap (3), vtkButtonSource (2), vtkImageWindow (2), vtkMatrix4x4 (2), vtkRenderWindow (2), vtkWin32ImageWindow (2), vtkWindow (2), [...]
double-precision
  • vtkMath (8), vtkAbstractTransform (5), vtkLinearTransform (4), vtkTriangle (1)
doubt
  • vtkXRenderWindowInteractor (1)
down-stream
  • vtkDataObject (1)
downcast
  • vtkObject (1)
downloading
  • vtkVolumeTextureMapper2D (1)
downstream
  • vtkDataObjectSource (1), vtkDataSetToDataSetFilter (1), vtkPointSetToPointSetFilter (1), vtkProcessObject (1), vtkSource (1)
draft
  • vtkVRMLExporter (1)
drag (dragged, dragging)
  • vtkProp (3), vtkInteractorStyleUnicam (2)
dragable
  • vtkProp (3), vtkActor (1), vtkLODActor (1), vtkVolume (1)
dramatic
  • vtkTubeFilter (1)
dramatically
  • vtkRuledSurfaceFilter (1)
drastically
  • vtkQuadricClustering (1)
draw (drawing, draws)
  • vtkJavaAwt (14), vtkImageCanvasSource2D (6), vtkCubeAxesActor2D (5), vtkCaptionActor2D (3), vtkImageCursor3D (2), vtkImageMapper (2), vtkLabeledDataMapper (2), vtkLegendBoxActor (2), vtkMesaVolumeRayCastMapper (2), vtkOpenGLVolumeRayCastMapper (2), [...]
drawn
  • vtkAxisActor2D (5), vtkCaptionActor2D (3), vtkTextSource (3), vtkCubeAxesActor2D (2), vtkGlyphSource2D (2), vtkProperty (2), vtkProperty2D (2), vtkScaledTextActor (2), vtkActor2D (1), vtkAssembly (1), [...]
driven
  • vtkInteractorStyle (1), vtkQuadricClustering (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
driver
  • vtkMILVideoSource (2), vtkWin32VideoSource (2), vtkVideoSource (1)
dscription
  • vtkPieceScalars (1)
dshear
  • vtkCamera (2)
dummy
  • vtkDataWriter (1), vtkPolyData (1), vtkRenderWindow (1)
dumping
  • vtkTimerLog (1)
dumps
  • vtkMultiProcessLog (1)
duplicate (duplicated, duplicates, duplication)
  • vtkCleanPolyData (2), vtkCollection (2), vtkGeometryFilter (2), vtkMPICommunicator (2), vtkMPIController (2), vtkOrderedTriangulator (2), vtkPointLocator (2), vtkPolyDataNormals (2), vtkRibbonFilter (2), vtkTubeFilter (2), [...]
dxdz
  • vtkPerspectiveTransform (1)
dydz
  • vtkPerspectiveTransform (1)
dynamic (dynamics)
  • vtkDynamicLoader (4), vtkObjectFactory (3), vtkAbstractList (2), vtkBitArray (1), vtkCellLinks (1), vtkCharArray (1), vtkDoubleArray (1), vtkFloatArray (1), vtkGraphicsFactory (1), vtkIdTypeArray (1), [...]
dynamically
  • vtkFieldData (1), vtkLODActor (1), vtkObjectFactory (1)

e
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
earlier
  • vtkRecursiveDividingCubes (1), vtkRenderWindow (1), vtkWindowToImageFilter (1)
earliest
  • vtkVideoSource (1)
earth
  • vtkEarthSource (3), vtkPOPReader (1)
easily
  • vtkAssignAttribute (1), vtkDecimatePro (1), vtkInteractorStyleUnicam (1), vtkPlaneSource (1)
east
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
eccentricity
  • vtkGaussianSplatter (5)
edelsbrunner
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
edge (edges)
  • vtkEdgeTable (29), vtkFeatureEdges (18), vtkQuadraticEdge (4), vtkExtractEdges (3), vtkEdgePoints (2), vtkLinkEdgels (1), vtkSmoothPolyDataFilter (16), vtkWindowedSincPolyDataFilter (16), vtkQuadricClustering (11), vtkDecimate (9), [...]
edgel (edgels)
  • vtkLinkEdgels (10), vtkSubPixelPositionEdgels (7)
edition
  • vtkRungeKutta45 (1)
effect (effects)
  • vtkDepthSortPolyData (5), vtkCamera (4), vtkDicer (3), vtkImplicitModeller (3), vtkGaussianSplatter (2), vtkSmoothPolyDataFilter (2), vtkTubeFilter (2), vtkWindowedSincPolyDataFilter (2), vtkActor (1), vtkCommand (1), [...]
effectively
  • vtkImplicitWindowFunction (1), vtkWindowedSincPolyDataFilter (1)
effficeint
  • vtkProcessObject (1)
efficiency
  • vtkIdentityTransform (1), vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkImageReslice (1), vtkParallelCoordinatesActor (1), vtkPixel (1), vtkSetGet (1), vtkTensor (1)
efficient (efficiently)
  • vtkPolyData (6), vtkCellArray (2), vtkDataSet (2), vtkFieldData (2), vtkImageStencilData (2), vtkAppendPolyData (1), vtkCellLocator (1), vtkCutter (1), vtkDataArray (1), vtkExtractGeometry (1), [...]
effort
  • vtkLightKit (1)
eigenfunction
  • vtkTensorGlyph (1)
eigenvalue (eigenvalues)
  • vtkTensorGlyph (14), vtkHyperStreamline (9), vtkPCAAnalysisFilter (9), vtkMath (7)
eigenvector (eigenvectors)
  • vtkHyperStreamline (13), vtkTensorGlyph (9), vtkMath (8), vtkPCAAnalysisFilter (8), vtkOBBTree (1)
elaborate
  • vtkImplicitBoolean (1)
elapsed
  • vtkStreamer (3), vtkTimerLog (2), vtkInteractorStyleUnicam (1), vtkStreamLine (1)
elbow
  • vtkWeightedTransformFilter (1)
element
  • vtkPLY (13), vtkXMLParser (11), vtkEnSightReader (7), vtkEnSight6BinaryReader (3), vtkEnSight6Reader (3), vtkEnSightGoldBinaryReader (3), vtkEnSightGoldReader (3), vtkPLYReader (3), vtkAbstractList (2), vtkCollection (2), [...]
elementary
  • vtkMath (1)
elevation (elevations)
  • vtkElevationFilter (1), vtkDEMReader (10), vtkLightKit (5), vtkLight (1)
eliminate (eliminated, eliminates, elimination)
  • vtkCleanPolyData (2), vtkCommunicator (2), vtkDecimatePro (2), vtkMPICommunicator (2), vtkDecimate (1), vtkDelaunay3D (1), vtkHeap (1), vtkLinkEdgels (1), vtkMPIController (1), vtkMultiProcessController (1), [...]
ellipse
  • vtkImageOpenClose3D (1), vtkImplicitFunction (1)
ellipsoid
  • vtkImageEllipsoidSource (4), vtkButtonSource (6)
ellipsoidal
  • vtkButtonSource (1), vtkGaussianSplatter (1), vtkImageContinuousDilate3D (1), vtkImageContinuousErode3D (1), vtkImageRange3D (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
ellipsoidal-shaped
  • vtkButtonSource (1)
elliptic
  • vtkGaussianSplatter (1)
elliptical
  • vtkGaussianSplatter (6), vtkHyperStreamline (3), vtkButtonSource (2), vtkImageDilateErode3D (2), vtkImageVariance3D (2), vtkImageContinuousDilate3D (1), vtkImageContinuousErode3D (1), vtkImageRange3D (1)
embedding (embedded)
  • vtkRungeKutta45 (1), vtkTextMapper (1), vtkVolumeProMapper (1)
embers
  • vtkLightKit (1)
employee (employees)
  • vtkTreeComposite (2)
empty
  • vtkEmptyCell (1), vtkPolyData (4), vtkCellLocator (2), vtkDecimatePro (2), vtkExtractVectorComponents (2), vtkAssemblyPath (1), vtkBandedPolyDataContourFilter (1), vtkCellArray (1), vtkCollection (1), vtkCompositeManager (1), [...]
emulator
  • vtkRIBExporter (1)
encapsulate (encapsulates)
  • vtkColorTransferFunction (1), vtkDataObject (1), vtkOutputWindow (1)
enclosing (enclosed)
  • vtkDelaunay3D (2), vtkFrustumCoverageCuller (2), vtkRecursiveSphereDirectionEncoder (1)
encode (encoded, encodes, encoding)
  • vtkEncodedGradientEstimator (9), vtkDirectionEncoder (8), vtkRecursiveSphereDirectionEncoder (6), vtkEncodedGradientShader (3), vtkFiniteDifferenceGradientEstimator (1), vtkProgrammableDataObjectSource (1), vtkSLCReader (1), vtkSpherePuzzle (1), vtkWriter (1)
encoder
  • vtkRecursiveSphereDirectionEncoder (2), vtkEncodedGradientEstimator (2), vtkVolumeRayCastFunction (1)
encompass
  • vtkImageToPolyDataFilter (1)
encounter (encounters)
  • vtkImageEuclideanDistance (1), vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkUnstructuredGrid (1), vtkVolumeProMapper (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
encouraged
  • vtkTexture (1)
encoured
  • vtkMultiProcessController (1)
end-points
  • vtkEdgePoints (1)
endcode
  • vtkImageBlend (2)
endian (endianness)
  • vtkPLYWriter (4), vtkPLY (2), vtkMCubesReader (1), vtkMCubesWriter (1), vtkSocketCommunicator (1)
endif
  • vtkOpenGLStateCache (1)
endpoint (endpoints)
  • vtkQuadricDecimation (2), vtkCaptionActor2D (1), vtkLineSource (1)
endverbatim
  • vtkAssignAttribute (3), vtkRearrangeFields (3), vtkMaskFields (2), vtkMergeFields (2), vtkSplitField (2)
energy
  • vtkPLOT3DReader (4), vtkInteractorStyleUnicam (1), vtkTreeComposite (1)
enforce
  • vtkExtractGrid (1), vtkLightKit (1)
enforcement
  • vtkPolyDataNormals (1)
engineered
  • vtkImageFourierFilter (2)
ensure (ensures)
  • vtkCleanPolyData (1), vtkDataSet (1), vtkHomogeneousTransform (1), vtkImageData (1), vtkImageReslice (1), vtkImageStencilSource (1), vtkInstantiator (1), vtkLODProp3D (1), vtkLandmarkTransform (1), vtkLargeInteger (1), [...]
enter
  • vtkViewport (1)
enters
  • vtkInteractorStyleUser (1)
enthalpy
  • vtkPLOT3DReader (1)
entities
  • vtkLocator (6), vtkPropCollection (1)
entity
  • vtkMaskPolyData (3), vtkActor (1), vtkEarthSource (1), vtkProp3D (1), vtkVolume (1)
entrance
  • vtkOBBTree (1)
entries
  • vtkLegendBoxActor (7), vtkCollection (2), vtkPriorityQueue (2), vtkWindowLevelLookupTable (2), vtkActorCollection (1), vtkCellArray (1), vtkCellLinks (1), vtkCullerCollection (1), vtkDataSet (1), vtkDirectionEncoder (1), [...]
entropy
  • vtkPLOT3DReader (1)
entry
  • vtkEncodedGradientShader (3), vtkLegendBoxActor (2), vtkPriorityQueue (2), vtkArrayCalculator (1), vtkDataSet (1), vtkDataSetAttributes (1), vtkEnSightReader (1), vtkInteractorStyle (1), vtkMPIEventLog (1)
enum (enums)
  • vtkInteractorStyleUnicam (3), vtkAssignAttribute (2), vtkRearrangeFields (2), vtkSplitField (2), vtkMaskFields (1), vtkMergeFields (1)
enumerations
  • vtkInteractorStyleUnicam (1)
environment
  • vtkObjectFactory (2), vtkTestUtilities (2), vtkCommunicator (1), vtkMesaImageWindow (1), vtkMultiProcessController (1), vtkOpenGLImageWindow (1), vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), [...]
epfl
  • vtkImageEuclideanDistance (1)
epsilon
  • vtkOrderedTriangulator (1)
equation (equations)
  • vtkMath (11), vtkHull (3), vtkImageMandelbrotSource (3), vtkPlane (3), vtkQuadric (3), vtkCamera (2), vtkGaussianSplatter (2), vtkLookupTable (2), vtkCone (1), vtkCylinder (1), [...]
equivalent (equivalents)
  • vtkImageReslice (3), vtkWeightedTransformFilter (3), vtkCriticalSection (2), vtkAssembly (1), vtkFieldData (1), vtkImplicitTextureCoords (1), vtkMPICommunicator (1), vtkTransform (1)
erase
  • vtkImageWindow (1), vtkImager (1), vtkMesaImageWindow (1), vtkMesaImager (1), vtkOpenGLImageWindow (1), vtkOpenGLImager (1), vtkWin32ImageWindow (1), vtkXImageWindow (1)
erasing
  • vtkImageWindow (1), vtkMPIGroup (1), vtkWindow (1)
erode (eroded, erodes)
  • vtkImageDilateErode3D (4), vtkImageContinuousErode3D (1), vtkImageOpenClose3D (4), vtkImageSkeleton2D (1)
erosion
  • vtkImageSkeleton2D (2), vtkImageContinuousErode3D (1)
erratic
  • vtkScalarTree (1), vtkSimpleScalarTree (1)
error (ERROR, errors)
  • vtkErrorCode (4), vtkDecimatePro (21), vtkDecimate (14), vtkEnSightGoldBinaryReader (13), vtkEnSight6BinaryReader (12), vtkEnSightReader (12), vtkEnSightGoldReader (9), vtkEnSight6Reader (8), vtkDataReader (7), vtkNonLinearCell (6), [...]
esoteric
  • vtkInteractorStyle (1)
essentially
  • vtkCell (1), vtkProgrammableFilter (1), vtkProgrammableSource (1), vtkVertex (1)
estimate (estimated, estimates, estimating, estimation)
  • vtkFiniteDifferenceGradientEstimator (4), vtkRungeKutta45 (4), vtkInitialValueProblemSolver (3), vtkProp (3), vtkEncodedGradientEstimator (2), vtkImageData (2), vtkLODProp3D (2), vtkMassProperties (2), vtkPipelineSize (2), vtkCellArray (1), [...]
estimator
  • vtkVolumeRayCastFunction (1), vtkVolumeRayCastMapper (1), vtkVolumeRayCastStructures (1), vtkVolumeTextureMapper (1)
euclidean
  • vtkImageEuclideanDistance (5), vtkImageEuclideanToPolar (1), vtkVectorNorm (2)
evaluate (evaluated, evaluates, evaluating, evaluation)
  • vtkInterpolatedVelocityField (6), vtkFunctionParser (5), vtkImplicitFunction (5), vtkArrayCalculator (4), vtkPlane (4), vtkQuadric (4), vtkAssemblyPath (3), vtkImplicitDataSet (3), vtkImplicitSelectionLoop (3), vtkImplicitVolume (3), [...]
even (EVEN, evenly)
  • vtkAbstractPropPicker (2), vtkDelaunay2D (2), vtkExtractGrid (2), vtkMultiProcessController (2), vtkXYPlotActor (2), vtkBandedPolyDataContourFilter (1), vtkCastToConcrete (1), vtkClipDataSet (1), vtkContourFilter (1), vtkContourGrid (1), [...]
event (events)
  • vtkMPIEventLog (6), vtkRenderWindowInteractor (13), vtkXRenderWindowTclInteractor (11), vtkInteractorStyle (10), vtkXRenderWindowInteractor (10), vtkObject (5), vtkTimerLog (5), vtkWin32RenderWindowInteractor (5), vtkInteractorStyleFlight (4), vtkQuartzRenderWindowInteractor (4), [...]
event-driven
  • vtkInteractorStyle (1)
eventually
  • vtkDataObject (1), vtkHull (1), vtkImageStencilSource (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
ever-changing
  • vtkPCAAnalysisFilter (1)
everytime
  • vtkDataArray (1)
evokes
  • vtkCriticalSection (1)
examine (examined, examines, examining)
  • vtkBlankStructuredGrid (1), vtkCubeAxesActor2D (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkLinkEdgels (1), vtkPolyData (1), vtkSimpleScalarTree (1), vtkVoxelModeller (1)
examples
  • vtkAbstractPicker (2), vtkSetGet (2), vtkAbstractList (1), vtkImageData (1), vtkKitwareContourFilter (1), vtkMPIEventLog (1), vtkMarchingContourFilter (1), vtkPointLoad (1), vtkPolyData (1), vtkStructuredGrid (1)
exceed (exceeded, exceeding, exceeds)
  • vtkDecimate (2), vtkDecimatePro (1), vtkImageCast (1), vtkImageShiftScale (1), vtkOrderedTriangulator (1), vtkSpline (1), vtkSweptSurface (1)
exceedingly
  • vtkDataReader (1)
exception (exceptions)
  • vtkDelaunay2D (1), vtkObject (1), vtkRenderWindow (1)
excessive (excessively)
  • vtkDelaunay2D (1), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
exchange (exchanging)
  • vtkXYPlotActor (3), vtkDataArray (2), vtkFieldData (1)
exclude (excluded)
  • vtkCellLocator (2), vtkCollection (2), vtkDecimate (2), vtkDecimatePro (2), vtkImageCanvasSource2D (2), vtkImageConnector (2), vtkMesaPolyDataMapper (1), vtkMultiThreader (1), vtkOpenGLPolyDataMapper (1), vtkStreamer (1)
exclusion
  • vtkMutexLock (1)
exclusive (exclusively)
  • vtkVideoSource (2), vtkDataSet (1), vtkStructuredData (1), vtkUnstructuredGrid (1), vtkWin32Header (1)
executable
  • vtkInstantiator (1)
executing
  • vtkMultiProcessController (2), vtkImplicitFunction (1), vtkQuadricClustering (1), vtkRendererSource (1), vtkThreadedController (1)
exhausted
  • vtkAssembly (1), vtkCollection (1), vtkEdgeTable (1), vtkLightCollection (1), vtkPriorityQueue (1), vtkProp (1), vtkPropAssembly (1), vtkScalarTree (1), vtkSimpleScalarTree (1), vtkStructuredPointsCollection (1)
exist (existed, existing, exists)
  • vtkLight (5), vtkArrayCalculator (2), vtkDecimatePro (2), vtkFunctionParser (2), vtkImageReslice (2), vtkMPICommunicator (2), vtkActor2D (1), vtkDataSetAttributes (1), vtkEdgeTable (1), vtkEnSightReader (1), [...]
existence
  • vtkInteractorStyleTrackball (1)
exit (exited, exiting, exits)
  • vtkQuartzRenderWindowInteractor (7), vtkWin32RenderWindowInteractor (7), vtkCellLocator (3), vtkDebugLeaks (3), vtkRenderWindowInteractor (3), vtkOutputWindow (2), vtkXRenderWindowInteractor (2), vtkInteractorStyle (1), vtkLargeInteger (1), vtkOBBTree (1), [...]
exitmethod
  • vtkRenderWindowInteractor (1)
exorbitantly
  • vtkRenderWindow (1)
expands (expanded, expanding)
  • vtkGaussianSplatter (1), vtkImageAppend (1), vtkImageData (1), vtkImageMultipleInputFilter (1), vtkImplicitModeller (1), vtkSweptSurface (1), vtkVideoSource (1)
expansive
  • vtkInterpolatedVelocityField (1)
expat
  • vtkXMLParser (1)
expect (expected)
  • vtkAssemblyNode (1), vtkDataSetReader (1), vtkHull (1), vtkImageEuclideanToPolar (1), vtkImageHSVToRGB (1), vtkImageOpenClose3D (1), vtkImageRGBToHSV (1), vtkPDataSetReader (1), vtkQuantizePolyDataPoints (1)
expense
  • vtkImageCacheFilter (1)
expensive
  • vtkContourFilter (2), vtkContourGrid (2), vtkGridSynchronizedTemplates3D (2), vtkImageMarchingCubes (2), vtkMarchingContourFilter (2), vtkMarchingCubes (2), vtkSynchronizedTemplates3D (2), vtkDataSet (1), vtkGridTransform (1), vtkKitwareContourFilter (1), [...]
experience
  • vtkGraphLayoutFilter (1)
experiment (experimenting)
  • vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkImageData (1)
experimental
  • vtkAbstractTransform (1), vtkGeneralTransform (1), vtkPerspectiveTransform (1), vtkTransform (1)
explanation
  • vtkMapper (1)
explicit
  • vtkExplicitCell (4), vtkCell (1), vtkLocator (1)
explicitely
  • vtkQuadricClustering (1)
explicity
  • vtkQuadricClustering (1)
exponent
  • vtkGaussianSplatter (3), vtkEncodedGradientShader (1), vtkLight (1)
exponential
  • vtkWindowedSincPolyDataFilter (1)
export (exported, exporting, exports)
  • vtkImageExport (9), vtkRIBExporter (3), vtkExporter (1), vtkIVExporter (1), vtkOBJExporter (1), vtkOOGLExporter (1), vtkVRMLExporter (1), vtkIVWriter (1)
exporter (exporters)
  • vtkExporter (1), vtkActor (1), vtkActor2D (1), vtkAssembly (1), vtkLODProp3D (1), vtkProp (1), vtkVolume (1)
expose
  • vtkRenderer (1)
exposure (exposures)
  • vtkWindow (2)
express (EXPRESS, expresses, expression)
  • vtkFunctionParser (2), vtkGaussianSplatter (1), vtkIterativeClosestPointTransform (1), vtkPLY (1), vtkTetra (1), vtkTreeComposite (1), vtkTriangle (1)
extdent
  • vtkBranchExtentTranslator (1)
extend (extended, extending, extends)
  • vtkCellArray (2), vtkCellLinks (2), vtkArrowSource (1), vtkCell3D (1), vtkDecimate (1), vtkFieldData (1), vtkImageMandelbrotSource (1), vtkImageSobel3D (1), vtkInteractorStyleUnicam (1), vtkKitwareContourFilter (1), [...]
extened
  • vtkImageReader2Factory (1)
extension (extensions)
  • vtkBMPReader (3), vtkImageReader2 (3), vtkJPEGReader (3), vtkPNGReader (3), vtkTIFFReader (3), vtkDynamicLoader (1), vtkImageAppend (1), vtkPriorityQueue (1), vtkSubPixelPositionEdgels (1)
extent (extents)
  • vtkExtentTranslator (10), vtkBranchExtentTranslator (8), vtkImageTranslateExtent (2), vtkDataObject (36), vtkImageImport (18), vtkImageReslice (13), vtkImageStencilData (12), vtkImageData (11), vtkRectilinearGrid (9), vtkStructuredGrid (8), [...]
extentsions
  • vtkGESignaReader (1)
exterior
  • vtkCubeAxesActor2D (2)
external (externally)
  • vtkInteractorStyleTrackball (2), vtk3DS (1), vtkCellArray (1), vtkHeap (1), vtkRenderWindowInteractor (1), vtkVRMLImporter (1)
extra
  • vtkBandedPolyDataContourFilter (2), vtkCellArray (2), vtkCellLocator (2), vtkDataSet (2), vtkImageMirrorPad (2), vtkImagePadFilter (2), vtkPolyData (2), vtkAttributeDataToFieldDataFilter (1), vtkCellTypes (1), vtkCharArray (1), [...]
extract (extracted, extracting, extraction, extracts)
  • vtkExtractTensorComponents (25), vtkExtractGeometry (6), vtkExtractPolyDataGeometry (6), vtkExtractVOI (4), vtkExtractVectorComponents (4), vtkExtractEdges (3), vtkExtractGrid (3), vtkExtractUnstructuredGrid (3), vtkImageExtractComponents (2), vtkConnectivityFilter (20), [...]
extreme (extremes)
  • vtkImplicitModeller (1), vtkLightKit (1)
extrude
  • vtkLinearExtrusionFilter (1)
extrusion
  • vtkLinearExtrusionFilter (9)
eyes
  • vtkCamera (2), vtkInteractorStyle (1)
Generated on Mon Mar 25 01:37:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (f..l)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

f
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
face (faces)
  • vtkDataSetSurfaceFilter (1), vtkOrderedTriangulator (5), vtkHull (4), vtk3DS (3), vtkCell (3), vtkImageAnisotropicDiffusion3D (3), vtkPLYReader (3), vtkDelaunay3D (2), vtkGeometryFilter (2), vtkOpenGLStateCache (2), [...]
facet (facets)
  • vtkUGFacetReader (3), vtkConeSource (1), vtkCylinderSource (1), vtkDataSetTriangleFilter (1)
facilitates
  • vtkWindowedSincPolyDataFilter (1)
facility
  • vtkInteractorStyle (1)
facing
  • vtkProperty (2), vtkFollower (1), vtkRenderer (1)
facor
  • vtkCompositeManager (1)
factor (factored, factors)
  • vtkTensorGlyph (10), vtkGlyph3D (7), vtkSmoothPolyDataFilter (5), vtkAxisActor2D (4), vtkMath (4), vtkCamera (3), vtkGaussianSplatter (3), vtkImageAnisotropicDiffusion2D (3), vtkImageGaussianSmooth (3), vtkSimpleScalarTree (3), [...]
factories
  • vtkObjectFactory (12), vtkObjectFactoryCollection (1)
factorization
  • vtkMath (4)
factory
  • vtkObjectFactory (18), vtkKitwareObjectFactory (4), vtkOverrideInformation (6)
fail (failed, fails)
  • vtkRegressionTestImage (2), vtkCommunicator (1), vtkInstantiator (1)
failure
  • vtkAssembly (1), vtkInitialValueProblemSolver (1), vtkMPICommunicator (1), vtkMPIEventLog (1), vtkPropAssembly (1), vtkRectilinearGrid (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1)
fall
  • vtkQuadricClustering (1), vtkSweptSurface (1)
falloff
  • vtk3DS (1), vtkLightKit (1), vtkVolumeProMapper (1)
false (FALSE)
  • vtkQuartzRenderWindowInteractor (2), vtkTensorGlyph (2), vtkWin32RenderWindowInteractor (2), vtkAbstractList (1), vtkAppendPolyData (1), vtkCleanPolyData (1), vtkDataSetAttributes (1), vtkImporter (1), vtkInputPort (1), vtkOpenGLStateCache (1)
family
  • vtkCubeAxesActor2D (3), vtkAxisActor2D (2), vtkParallelCoordinatesActor (2), vtkXYPlotActor (2), vtkCaptionActor2D (1), vtkGlyphSource2D (1), vtkLabeledDataMapper (1), vtkLegendBoxActor (1), vtkScalarBarActor (1), vtkTextMapper (1)
farther
  • vtkCamera (1)
farthest
  • vtkPointLocator (1), vtkPointLocator2D (1)
farz
  • vtkCamera (4)
fashion
  • vtkDecimatePro (1), vtkSetGet (1), vtkStructuredData (1), vtkTriangleStrip (1), vtkVoxelContoursToSurfaceFilter (1)
fast
  • vtkBitArray (2), vtkCharArray (2), vtkImageFFT (2), vtkImageRFFT (2), vtkPoints (2), vtkProperty (2), vtkAbstractPicker (1), vtkCompositeManager (1), vtkDataArray (1), vtkDataSetSurfaceFilter (1), [...]
faster
  • vtkCellLocator (4), vtkFieldData (2), vtkImplicitModeller (2), vtkAbstractPicker (1), vtkCleanPolyData (1), vtkCutter (1), vtkDataSetSurfaceFilter (1), vtkDelaunay3D (1), vtkIdList (1), vtkLODProp3D (1), [...]
fastest
  • vtkAbstractPicker (1), vtkDepthSortPolyData (1), vtkImageFFT (1), vtkImageRFFT (1), vtkVolumeMapper (1)
favor
  • vtkProgrammableSource (1)
feature (features)
  • vtkFeatureEdges (5), vtkQuadricClustering (7), vtkSmoothPolyDataFilter (7), vtkWindowedSincPolyDataFilter (7), vtkDecimate (6), vtkDecimatePro (3), vtkMapper (3), vtkImageReslice (2), vtkImplicitModeller (2), vtkPolyDataNormals (2), [...]
february
  • vtkPLY (1)
feed (feeds)
  • vtkImageOpenClose3D (1), vtkVectorText (1)
feet
  • vtkDEMReader (2)
fence
  • vtkVolumeMapper (2)
fewer
  • vtkInteractorStyleJoystickActor (1), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1), vtkMCubesReader (1), vtkTubeFilter (1)
field (fields)
  • vtkFieldData (38), vtkFieldDataToAttributeDataFilter (28), vtkRearrangeFields (15), vtkSplitField (12), vtkMergeFields (11), vtkAttributeDataToFieldDataFilter (9), vtkMaskFields (9), vtkInterpolatedVelocityField (2), vtkDataSetAttributes (17), vtkMergeDataObjectFilter (13), [...]
file (files, filled, filling)
  • vtkFileOutputWindow (7), vtkXMLFileOutputWindow (4), vtkImageReader2 (28), vtkDataReader (26), vtkEnSightReader (24), vtkPLOT3DReader (23), vtkBYUWriter (16), vtkPDataSetWriter (15), vtkRIBExporter (15), vtkVolume16Reader (15), [...]
filed
  • vtkImageData (1)
filename (filenames)
  • vtkEnSightReader (5), vtkImageReader2 (4), vtkDataReader (2), vtkOBJExporter (2), vtkVolumeReader (2), vtkDataSetReader (1), vtkGESignaReader (1), vtkGenericEnSightReader (1), vtkImageWriter (1), vtkMILVideoSource (1), [...]
fill (fills)
  • vtkLightKit (17), vtkImageCanvasSource2D (2), vtkPiecewiseFunction (2), vtkUnstructuredGrid (2), vtkBandedPolyDataContourFilter (1), vtkColorTransferFunction (1), vtkContourFilter (1), vtkContourGrid (1), vtkContourValues (1), vtkCutter (1), [...]
fill-in
  • vtkFieldDataToAttributeDataFilter (2)
filter (filtered, filtering, filters)
  • vtkWeightedTransformFilter (17), vtkWindowedSincPolyDataFilter (16), vtkProgrammableAttributeDataFilter (14), vtkDataSetToDataSetFilter (12), vtkPointSetToPointSetFilter (12), vtkProgrammableGlyphFilter (12), vtkProgrammableFilter (11), vtkMarchingContourFilter (8), vtkContourFilter (7), vtkDataObjectToDataSetFilter (6), [...]
finalize
  • vtkMPIController (1)
find (finding, finds)
  • vtkInteractorStyleUser (4), vtkPointLocator (4), vtkPointLocator2D (4), vtkQuadricDecimation (3), vtkAbstractList (2), vtkHyperStreamline (2), vtkImplicitDataSet (2), vtkImplicitVolume (2), vtkOBBTree (2), vtkStreamer (2), [...]
fine
  • vtkCutter (1)
fine-grained
  • vtkMILVideoSource (1)
finer
  • vtkPerlinNoise (1)
finialize
  • vtkSocketController (1)
finish (finishes)
  • vtkCompositeManager (2), vtkDataObject (1), vtkDataObjectSource (1), vtkImageStencilData (1), vtkMultiProcessController (1), vtkProcessObject (1), vtkSource (1), vtkThreadedController (1)
finite
  • vtkFiniteDifferenceGradientEstimator (2), vtkCellLocator (3), vtkLine (2), vtkQuadraticEdge (1), vtkStructuredData (1), vtkStructuredGrid (1)
first (FIRST)
  • vtkDataSet (14), vtkPointLocator (7), vtkDataReader (6), vtkDataSetAttributes (6), vtkImageBlend (6), vtkImageReslice (5), vtkPolyData (5), vtkRuledSurfaceFilter (5), vtkSpline (5), vtkVolumeMapper (5), [...]
firstcomponent
  • vtkSplitField (3)
fitlers
  • vtkImageData (1), vtkImageFFT (1), vtkImageRFFT (1)
fits
  • vtkCubeAxesActor2D (1), vtkLODProp3D (1), vtkLegendBoxActor (1), vtkSubPixelPositionEdgels (1)
flag (flags)
  • vtkDataSetAttributes (23), vtkQuadricClustering (12), vtkFieldDataToAttributeDataFilter (9), vtkDataObject (8), vtkMapper (6), vtkFieldData (5), vtkObjectFactory (5), vtkDataObjectToDataSetFilter (4), vtkMaskFields (4), vtkMultiProcessController (4), [...]
flat
  • vtkButtonSource (1), vtkDirectionEncoder (1), vtkPerspectiveTransform (1), vtkProperty (1), vtkRecursiveSphereDirectionEncoder (1)
flexible
  • vtkCriticalSection (1), vtkImageThreshold (1), vtkLightKit (1)
flight
  • vtkInteractorStyleFlight (3)
flip (flipped, flipping, flips)
  • vtkImageFlip (3), vtkTransformTextureCoords (10), vtkMCubesReader (4), vtkPolyDataNormals (4), vtkImplicitTextureCoords (3), vtkProjectedTexture (2), vtkGeneralTransform (1), vtkImageExport (1), vtkImageReslice (1), vtkMath (1), [...]
float (floating, floats)
  • vtkFloatArray (4), vtkQuartzRenderWindowInteractor (8), vtkWinCE (7), vtkLookupTable (6), vtkSetGet (6), vtkScalarsToColors (4), vtkDataArray (3), vtkOpenGLStateCache (3), vtkTransform (3), vtkCompositeManager (2), [...]
float-type
  • vtkFieldData (1)
floating-point
  • vtkDataArray (1), vtkLightKit (1), vtkPLY (1)
floor
  • vtkLightKit (1), vtkVolumeRayCastMapper (1)
florida
  • vtkLoopSubdivisionFilter (1)
flow
  • vtkPLOT3DReader (3), vtkStreamLine (2), vtkPOPReader (1), vtkStreamer (1), vtkWarpVector (1)
fluid
  • vtkPLOT3DReader (1)
flush
  • vtkImageWindow (1), vtkMesaImageWindow (1), vtkOpenGLImageWindow (1), vtkQuartzImageWindow (1), vtkWin32ImageWindow (1), vtkWin32OpenGLImageWindow (1), vtkXImageWindow (1)
flushing
  • vtkFileOutputWindow (1)
flux
  • vtkTubeFilter (1)
fly-to
  • vtkInteractorStyleImage (1)
flying
  • vtkRenderWindowInteractor (1)
focal
  • vtkCamera (17), vtkLight (11), vtkRenderWindow (3), vtkRenderer (3), vtkCursor3D (2), vtkInteractorStyle (2), vtkPerspectiveTransform (2), vtkProjectedTexture (1), vtkRenderWindowInteractor (1)
focal-point
  • vtkCamera (1)
focalpoint
  • vtkCamera (1)
focus (focuses)
  • vtkCursor3D (5), vtkProjectedTexture (4), vtkInteractorStyleUnicam (3), vtkVRMLImporter (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
fold
  • vtkWarpTransform (1)
follow (followed, following, follows)
  • vtkFollower (4), vtkDataSetAttributes (19), vtkMaskFields (8), vtkFieldData (6), vtkMath (4), vtkPLOT3DReader (4), vtkRIBExporter (4), vtkXYPlotActor (4), vtkActor (3), vtkDecimatePro (3), [...]
follower
  • vtkFollower (6)
font (fonts)
  • vtkAxisActor2D (12), vtkTextMapper (10), vtkLabeledDataMapper (8), vtkCubeAxesActor2D (6), vtkParallelCoordinatesActor (5), vtkScalarBarActor (5), vtkXYPlotActor (4), vtkCaptionActor2D (3), vtkLegendBoxActor (3), vtkTextSource (2), [...]
fool (fooling)
  • vtkImageIterateFilter (1), vtkTransform (1)
foot
  • vtkImageDilateErode3D (2), vtkImageContinuousDilate3D (1), vtkImageContinuousErode3D (1), vtkImageRange3D (1), vtkImageVariance3D (1)
footprint
  • vtkStreamer (1)
fora
  • vtkImageIterator (1)
force (forced, forces)
  • vtkImageReslice (3), vtkMultiProcessController (2), vtkCamera (1), vtkCompositeManager (1), vtkDecimatePro (1), vtkImplicitModeller (1), vtkIterativeClosestPointTransform (1), vtkLookupTable (1), vtkMapper (1), vtkPolyDataMapper2D (1), [...]
force-directed
  • vtkGraphLayoutFilter (2)
foreach
  • vtkImageBlend (4)
foreground
  • vtkProperty2D (2), vtkTextSource (1)
form (formed, forms)
  • vtkDataSetAttributes (4), vtkDataArray (3), vtkSpatialRepresentationFilter (3), vtkAbstractPropPicker (2), vtkAssemblyPath (2), vtkBMPReader (2), vtkCellArray (2), vtkCleanPolyData (2), vtkDataObjectWriter (2), vtkDataSet (2), [...]
format (FORMAT, formats, formatted)
  • vtkLabeledDataMapper (8), vtkImageReader2 (5), vtkPLOT3DReader (5), vtkMILVideoSource (4), vtkAxisActor2D (3), vtkBMPReader (3), vtkJPEGReader (3), vtkMPIEventLog (3), vtkPNGReader (3), vtkScalarBarActor (3), [...]
former
  • vtkAbstractTransform (1), vtkFieldData (1)
formula
  • vtkCamera (1), vtkProgrammableAttributeDataFilter (1), vtkRungeKutta45 (1)
fortran
  • vtkRungeKutta45 (1)
forty
  • vtkIndent (1)
forwards (forwarded)
  • vtkSocketController (3), vtkInteractorStyle (1), vtkOutputPort (1), vtkVideoSource (1)
fouling
  • vtkProgrammableGlyphFilter (1)
four-sided
  • vtkCubeSource (1)
fourier
  • vtkImageFourierFilter (1), vtkImageFFT (2), vtkImageRFFT (2)
fourth
  • vtkImageReslice (3), vtkVolumeMapper (2), vtkTetra (1)
foward
  • vtkImageOpenClose3D (2)
fraction
  • vtkHyperStreamline (4), vtkDecimate (3), vtkCleanPolyData (2), vtkDashedStreamLine (2), vtkDecimatePro (2), vtkImplicitModeller (2), vtkShrinkFilter (2), vtkShrinkPolyData (2), vtkStreamer (2), vtkSweptSurface (2), [...]
fractional
  • vtkDEMReader (1)
frame (frames)
  • vtkVideoSource (34), vtkRenderWindow (12), vtkRenderWindowInteractor (5), vtkWin32VideoSource (5), vtkMILVideoSource (3), vtkInteractorStyleUnicam (2), vtkCamera (1), vtkCompositeManager (1), vtkLODActor (1), vtkMapper (1), [...]
framebuffer (FRAMEBUFFER)
  • vtkVideoSource (6), vtkVolume (1)
framework
  • vtkObject (1)
frankly
  • vtkXRenderWindowInteractor (1)
free (freeing, frees)
  • vtkDataArray (4), vtkRenderWindowInteractor (4), vtkHeap (3), vtkJavaAwt (3), vtkLinearExtrusionFilter (3), vtkProcessObject (3), vtkRotationalExtrusionFilter (3), vtkExporter (2), vtkLocator (2), vtkPointSet (2), [...]
free-stream
  • vtkPLOT3DReader (4)
freed
  • vtkMPICommunicator (2), vtkMPIController (1), vtkPolyData (1), vtkRenderWindow (1), vtkRenderWindowInteractor (1)
freedom
  • vtkIterativeClosestPointTransform (2), vtkLandmarkTransform (1), vtkProcrustesAlignmentFilter (1)
freq
  • vtkImageButterworthHighPass (1), vtkImageButterworthLowPass (1)
frequence
  • vtkImageIdealHighPass (1)
frequencies
  • vtkRTAnalyticSource (1), vtkWindowedSincPolyDataFilter (1)
frequency
  • vtkImageFourierCenter (5), vtkImageButterworthHighPass (4), vtkImageButterworthLowPass (4), vtkImageIdealHighPass (3), vtkImageIdealLowPass (3), vtkPerlinNoise (3), vtkWindowedSincPolyDataFilter (2), vtkSmoothPolyDataFilter (1)
frequent (frequently)
  • vtkImageShiftScale (1), vtkLocator (1), vtkPriorityQueue (1), vtkVersion (1)
friend
  • vtkEncodedGradientEstimator (1), vtkOutputPort (1)
front (FRONT)
  • vtkRenderWindow (2), vtkWindow (2), vtkAbstractList (1), vtkActor (1), vtkCGMWriter (1), vtkCamera (1), vtkDepthSortPolyData (1), vtkImageWindow (1), vtkLightKit (1), vtkMesaImageWindow (1), [...]
front-to-back
  • vtkDepthSortPolyData (2), vtkCutter (1), vtkFrustumCoverageCuller (1)
frontface
  • vtkProperty (2), vtkPolyDataNormals (1)
frowned
  • vtkMatrix4x4 (1)
fruchterman
  • vtkGraphLayoutFilter (1)
frustrum
  • vtkPlanes (2)
frustum
  • vtkFrustumCoverageCuller (4), vtkPerspectiveTransform (8), vtkProjectedTexture (4), vtkCamera (2)
fsmach
  • vtkPLOT3DReader (1)
fulfill
  • vtkLODActor (1)
full-frame
  • vtkVideoSource (1)
func
  • vtkCallbackCommand (1)
funciton
  • vtkOverrideInformation (1)
functionality (FUNCTIONALITY)
  • vtkDataObject (6), vtkImageStencilData (4), vtkMILVideoSource (3), vtkWin32VideoSource (3), vtkImageViewer (2), vtkImageViewer2 (2), vtkgluPickMatrix (2), vtkAbstractPicker (1), vtkAbstractPropPicker (1), vtkActor (1), [...]
fund
  • vtkOldStyleCallbackCommand (1)
furhter
  • vtkImageExport (1), vtkImageImport (1)
further
  • vtkMath (2), vtkCleanPolyData (1), vtkCommand (1), vtkGlyph3D (1), vtkImplicitModeller (1), vtkLightKit (1), vtkSmoothPolyDataFilter (1)
future
  • vtkActor (1), vtkDEMReader (1), vtkDataWriter (1), vtkImageAppend (1), vtkImageCacheFilter (1), vtkLODActor (1), vtkMarchingContourFilter (1), vtkMultiProcessLog (1), vtkOutputPort (1), vtkParallelCoordinatesActor (1), [...]
fvect
  • vtkOpenGLStateCache (1)

g
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
gamma
  • vtkPLOT3DReader (1), vtkRegressionTestImage (1)
gaps
  • vtkImageOpenClose3D (1)
garbage
  • vtkContourValues (1)
gather (gathered)
  • vtkCompositeManager (1), vtkDecimate (1), vtkOBBTree (1)
gaussian
  • vtkGaussianSplatter (8), vtkImageGaussianSmooth (7), vtkImageGaussianSource (5), vtkPointSource (1), vtkRTAnalyticSource (1), vtkWindowedSincPolyDataFilter (1)
gavin
  • vtkVRML (1), vtkVRMLImporter (1)
gems
  • vtkCell (1), vtkMatrix4x4 (1), vtkPerlinNoise (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
general-purpose
  • vtkExtractUnstructuredGrid (1), vtkGeometryFilter (1)
generalizing (generalized)
  • vtkConnectivityFilter (1), vtkImageAccumulate (1), vtkImageData (1), vtkImageQuantizeRGBToIndex (1), vtkProcrustesAlignmentFilter (1)
generation
  • vtkDecimate (4), vtkLookupTable (4), vtkSmoothPolyDataFilter (3), vtkTubeFilter (3), vtkWindowedSincPolyDataFilter (3), vtkCellCenters (2), vtkDecimatePro (2), vtkGlyph3D (2), vtkIdFilter (2), vtkProgrammableGlyphFilter (2), [...]
generator
  • vtkCollection (1), vtkPointLoad (1)
generically
  • vtkFieldData (1)
generous
  • vtkHull (1)
geographical
  • vtkEarthSource (1)
geological
  • vtkDEMReader (1)
geometric
  • vtkAbstractPicker (3), vtkProperty (3), vtkAbstractTransform (2), vtkDataSet (2), vtkImageData (2), vtkLocator (2), vtkPicker (2), vtkPolyData (2), vtkRectilinearGrid (2), vtkSpatialRepresentationFilter (2), [...]
geometrical (geometrically)
  • vtkImageData (2), vtkConnectivityFilter (1), vtkPolyDataConnectivityFilter (1)
geometry
  • vtkGeometryFilter (6), vtkImageDataGeometryFilter (2), vtkRectilinearGridGeometryFilter (2), vtkStructuredGridGeometryFilter (2), vtkPVGeometryFilter (1), vtkEnSightGoldBinaryReader (8), vtkEnSightGoldReader (7), vtkGlyph3D (7), vtkSweptSurface (7), vtkEnSight6BinaryReader (6), [...]
geomview
  • vtkOOGLExporter (3)
ghost
  • vtkDataObject (2), vtkExtractPolyDataPiece (2), vtkExtractUnstructuredGridPiece (2), vtkPCellDataToPointData (2), vtkPolyData (2), vtkTransmitPolyDataPiece (2), vtkTransmitUnstructuredGridPiece (2), vtkUnstructuredGrid (2), vtkFieldDataToAttributeDataFilter (1), vtkImageData (1), [...]
giving
  • vtkBlankStructuredGrid (1), vtkMath (1), vtkOBBTree (1), vtkPointLocator (1), vtkPointLocator2D (1)
glasses
  • vtkInteractorStyle (1), vtkRotationalExtrusionFilter (1)
globally
  • vtkPolyDataNormals (1)
glyph (glyphed, glyphing, glyphs)
  • vtkGlyph3D (28), vtkGlyphSource2D (22), vtkTensorGlyph (9), vtkProgrammableGlyphFilter (6), vtkGlyph2D (1), vtkCaptionActor2D (6), vtkXYPlotActor (5), vtkArrowSource (1), vtkCellCenters (1)
goal
  • vtkVideoSource (1)
goes
  • vtkImageExport (1), vtkImageMandelbrotSource (1), vtkStreamLine (1)
gold
  • vtkEnSightGoldBinaryReader (2), vtkEnSightGoldReader (2)
golub
  • vtkWindowedSincPolyDataFilter (2)
gotten
  • vtkImageBlockReader (3)
gottschalk
  • vtkOBBTree (1)
gouraud
  • vtkProperty (2), vtkImageToPolyDataFilter (1), vtkPolyDataNormals (1)
governed
  • vtkXYPlotActor (1)
government
  • vtkTreeComposite (2)
gower
  • vtkProcrustesAlignmentFilter (1)
grab (grabbed, grabbing, grabs)
  • vtkVideoSource (7), vtkWin32VideoSource (3), vtkInteractorStyleTrackball (2), vtkMILVideoSource (2), vtkRendererSource (2), vtkAbstractPropPicker (1), vtkFieldData (1), vtkInteractorStyle (1), vtkProgrammableAttributeDataFilter (1), vtkVolumeRayCastFunction (1)
grabbers
  • vtkMILVideoSource (1)
gradient (gradients)
  • vtkEncodedGradientEstimator (13), vtkImageGradient (5), vtkFiniteDifferenceGradientEstimator (4), vtkImageGradientMagnitude (3), vtkSubPixelPositionEdgels (14), vtkCellDerivatives (9), vtkVolumeProperty (8), vtkImageAnisotropicDiffusion2D (7), vtkImageAnisotropicDiffusion3D (7), vtkContourFilter (6), [...]
gradually
  • vtkLookupTable (1)
grain
  • vtkQuantizePolyDataPoints (2)
grammar
  • vtkVRMLImporter (1)
grant (granted)
  • vtkInteractorStyleUnicam (1), vtkPLY (1), vtkTreeComposite (1)
graph (graphs)
  • vtkGraphLayoutFilter (12), vtkProcessObject (1), vtkSource (1)
graphic (graphics)
  • vtkMapper (7), vtkDataSetMapper (6), vtkAbstractMapper (3), vtkMesaRenderer (3), vtkOpenGLRenderer (3), vtkPolyDataMapper (3), vtkScalarBarActor (3), vtkTexture (3), vtkActor (2), vtkActor2D (2), [...]
graphical (graphically)
  • vtkMPIEventLog (1), vtkRenderWindow (1), vtkXYPlotActor (1)
gray
  • vtkVolume (3), vtkImageWindow (2), vtkVolumeProperty (2), vtkImageViewer (1)
grayscale
  • vtkPNMReader (1)
great (greatly)
  • vtkGaussianSplatter (1), vtkProp (1), vtkRuledSurfaceFilter (1), vtkVRMLImporter (1)
greater
  • vtkCamera (2), vtkClipDataSet (2), vtkClipPolyData (2), vtkClipVolume (2), vtkPolyData (2), vtkRuledSurfaceFilter (2), vtkThreshold (2), vtkTubeFilter (2), vtkUnstructuredGrid (2), vtkWindowedSincPolyDataFilter (2), [...]
greedy
  • vtkSelectPolyData (1)
green
  • vtkPLYWriter (2), vtkEncodedGradientShader (1), vtkImageHSVToRGB (1), vtkImageRGBToHSV (1), vtkInteractorStyle (1), vtkPLY (1), vtkPLYReader (1), vtkScalarsToColors (1)
greg
  • vtkPLY (1), vtkPerlinNoise (1)
grey
  • vtkImageGridSource (2), vtkImageReslice (1)
greyscale
  • vtkImageBlend (2), vtkWin32ImageMapper (2), vtkGESignaReader (1), vtkLookupTable (1), vtkScalarsToColors (1), vtkWindowLevelLookupTable (1)
grid (grids)
  • vtkTransformToGrid (13), vtkExtractGrid (11), vtkRectilinearGrid (9), vtkGridTransform (8), vtkBlankStructuredGridWithImage (6), vtkImageGridSource (5), vtkStructuredGrid (5), vtkStructuredGridGeometryFilter (4), vtkRectilinearGridGeometryFilter (3), vtkStructuredGridToStructuredGridFilter (3), [...]
gropp
  • vtkMPIController (1)
ground
  • vtkDEMReader (3)
group (grouping, groups)
  • vtkMPIGroup (8), vtkMPICommunicator (7), vtkAssembly (4), vtkDataArray (3), vtkPropAssembly (3), vtkCellTypes (1), vtkCoordinate (1), vtkMultiProcessController (1), vtkPolyDataConnectivityFilter (1), vtkPolygon (1), [...]
grow (grows)
  • vtkCellLinks (1), vtkCellTypes (1), vtkImplicitModeller (1), vtkPiecewiseFunction (1), vtkStreamer (1), vtkSweptSurface (1)
guarantee (guarantees)
  • vtkDecimatePro (2), vtkOrderedTriangulator (2), vtkHomogeneousTransform (1), vtkImageReslice (1)
guess
  • vtkLODProp3D (2), vtkInterpolatedVelocityField (1), vtkSurfaceReconstructionFilter (1)
guide
  • vtkDataObjectToDataSetFilter (2)
guideline
  • vtkCell (1)

h
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
hack
  • vtkImageClip (1), vtkImageIterateFilter (1), vtkImageToStructuredPoints (1)
half
  • vtkWinCE (3), vtkDashedStreamLine (2), vtkInteractorStyle (2), vtkSpherePuzzle (2), vtkImageShrink3D (1), vtkImageSpatialFilter (1), vtkOBBTree (1), vtkRibbonFilter (1)
half-cycle
  • vtkPerlinNoise (1)
halfway
  • vtkHull (1)
halle
  • vtkLightKit (1)
halogen
  • vtkLightKit (1)
hamming
  • vtkWindowedSincPolyDataFilter (1)
hand (handed)
  • vtkProp3D (3), vtkTransform (3), vtkAssignAttribute (1), vtkCell (1), vtkDelaunay2D (1), vtkPoints (1)
handle (handled, handles, handling)
  • vtkDataObject (5), vtkMPICommunicator (5), vtkImageSpatialFilter (3), vtkInteractorStyle (3), vtkXMLParser (3), vtkCompositeManager (2), vtkImageSeparableConvolution (2), vtkMapper (2), vtkProcessObject (2), vtkQuadricClustering (2), [...]
handler (handlers)
  • vtkXMLParser (6), vtkXRenderWindowInteractor (2), vtkXRenderWindowTclInteractor (2), vtkMPIEventLog (1), vtkQuartzRenderWindowInteractor (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWin32RenderWindowInteractor (1), vtkWinCEOpenGLRenderWindow (1)
hang
  • vtkMultiProcessController (1), vtkRectilinearGrid (1)
hann
  • vtkWindowedSincPolyDataFilter (1)
happen (happens)
  • vtkDataReader (1), vtkMCubesReader (1), vtkPolyData (1), vtkRenderer (1), vtkTimeStamp (1)
hard (hardly)
  • vtkCell (1), vtkExtentTranslator (1), vtkLODActor (1), vtkOBBTree (1), vtkOrderedTriangulator (1), vtkWeightedTransformFilter (1)
hardware
  • vtkAbstractPicker (5), vtkOpenGLVolumeProVG500Mapper (2), vtkOpenGLVolumeProVP1000Mapper (2), vtkPropPicker (2), vtkVideoSource (2), vtkVolumeProMapper (2), vtkVolumeProVG500Mapper (2), vtkVolumeProVP1000Mapper (2), vtkAbstractMapper3D (1), vtkMILVideoSource (1), [...]
harvard
  • vtkLightKit (1)
hash (hashes)
  • vtkQuadricClustering (2), vtkPointLocator (1), vtkPointLocator2D (1), vtkPythonUtil (1), vtkSTLReader (1)
head (heads)
  • vtkCaptionActor2D (6), vtkCompositeManager (1)
header (headers)
  • vtkWin32Header (1), vtkDataWriter (4), vtkInstantiator (4), vtkSetGet (4), vtkDataReader (3), vtkImageReader2 (2), vtkMCubesReader (2), vtkMedicalImageReader2 (2), vtkVolumeProVG500Mapper (2), vtkVolumeProVP1000Mapper (2), [...]
headlight (headlights)
  • vtkLightKit (14), vtkRenderer (3), vtkLight (2), vtkRenderWindowInteractor (1)
heap
  • vtkMatrix4x4 (1), vtkVRML (1)
heats
  • vtkPLOT3DReader (1)
height
  • vtkButtonSource (5), vtkCamera (5), vtkWarpLens (4), vtkConeSource (3), vtkArcPlotter (2), vtkCylinderSource (2), vtkPlaneSource (2), vtkActor2D (1), vtkAxisActor2D (1), vtkCubeSource (1), [...]
help
  • vtkActor (1), vtkCellArray (1), vtkCompositeManager (1), vtkDelaunay3D (1), vtkMath (1), vtkWindow (1)
helper (helpers)
  • vtkDataReader (4), vtkAbstractTransform (2), vtkContourValues (2), vtkDataWriter (2), vtkDelaunay3D (2), vtkImageStencilSource (2), vtkAbstractMapper (1), vtkAssignAttribute (1), vtkCubeAxesActor2D (1), vtkDataObject (1), [...]
helpful
  • vtkTimerLog (1)
hence
  • vtkOrderedTriangulator (2), vtkInteractorStyleImage (1), vtkMCubesReader (1), vtkMapper (1), vtkStructuredGrid (1)
hereby
  • vtkPLY (1)
herein
  • vtkTreeComposite (1)
hexagon
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProVG500Mapper (1)
hexahedra
  • vtkDataSet (1)
hexahedron
  • vtkHexahedron (3), vtkCell (1), vtkStructuredGrid (1), vtkUnstructuredGrid (1)
hexehedra
  • vtkCell3D (1)
hidden
  • vtk3DS (1), vtkCaptionActor2D (1), vtkPLinearExtrusionFilter (1)
hide (hides)
  • vtkQuartzRenderWindow (2), vtkRenderWindow (2), vtkRenderWindowInteractor (2), vtkWin32OpenGLRenderWindow (2), vtkWinCEOpenGLRenderWindow (2), vtkXMesaRenderWindow (2), vtkXOpenGLRenderWindow (2), vtkActor2DCollection (1), vtkActorCollection (1), vtkAppendFilter (1), [...]
hiding
  • vtkPolyData (2), vtkUnstructuredGrid (2), vtkImageData (1), vtkRectilinearGrid (1), vtkStructuredGrid (1)
hierarchical
  • vtkAssembly (1), vtkAssemblyNode (1), vtkOBBTree (1), vtkObject (1), vtkProp (1), vtkPropAssembly (1)
hierarchies
  • vtkAssembly (3), vtkPropAssembly (3)
hierarchy
  • vtkAssembly (5), vtkAssemblyPath (2), vtkAssemblyPaths (2), vtkPropAssembly (2), vtkAbstractPropPicker (1), vtkAbstractTransform (1), vtkCriticalSection (1), vtkHull (1), vtkProp (1), vtkXRenderWindowInteractor (1), [...]
high
  • vtkImageButterworthHighPass (1), vtkDashedStreamLine (1), vtkDecimate (1), vtkImageButterworthLowPass (1), vtkImageReslice (1), vtkInteractorStyleTrackball (1), vtkJPEGWriter (1), vtkSmoothPolyDataFilter (1), vtkStreamLine (1), vtkVolume16Reader (1), [...]
higher
  • vtkGraphLayoutFilter (3), vtkSurfaceReconstructionFilter (3), vtkSuperquadric (2), vtkSuperquadricSource (2), vtkWindowedSincPolyDataFilter (2), vtkCellType (1), vtkGaussianSplatter (1), vtkMILVideoSource (1), vtkMultiProcessController (1), vtkObject (1), [...]
higher-order
  • vtkGridTransform (1)
higher-performance
  • vtkCriticalSection (2)
highest
  • vtkPiecewiseFunction (2), vtkColorTransferFunction (1), vtkRenderer (1), vtkViewport (1)
highlight (highlighting, highlights)
  • vtkInteractorStyle (3), vtkDataObjectSource (1), vtkImplicitTextureCoords (1), vtkParallelCoordinatesActor (1), vtkProcessObject (1)
hint
  • vtkImageWindow (1), vtkProbeFilter (1)
histogram (histograms)
  • vtkImageAccumulate (6), vtkImageQuantizeRGBToIndex (1)
holds (holding)
  • vtkInteractorStyleFlight (2), vtkCamera (1), vtkImageAppend (1), vtkInteractorStyle (1), vtkInteractorStyleUnicam (1), vtkSource (1), vtkVersion (1), vtkVideoSource (1), vtkWeightedTransformFilter (1)
hole (holes)
  • vtkDecimatePro (4), vtkDecimate (3), vtkDiskSource (3), vtkDelaunay2D (1), vtkPolygon (1), vtkRuledSurfaceFilter (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
homogeneous
  • vtkHomogeneousTransform (3), vtkTransform (4), vtkPerspectiveTransform (3), vtkGeneralTransform (2), vtkMatrix4x4 (2), vtkAbstractTransform (1), vtkViewport (1)
hook (hooks)
  • vtkInteractorStyleUser (2), vtkAbstractPicker (1), vtkWin32ImageMapper (1)
hopcroft
  • vtkPriorityQueue (1)
hopefully
  • vtkWeightedTransformFilter (1)
hoppe
  • vtkSurfaceReconstructionFilter (2), vtkDecimatePro (1), vtkLoopSubdivisionFilter (1), vtkQuadricDecimation (1)
horizontal (horizontally)
  • vtkAxisActor2D (2), vtkCamera (1), vtkCaptionActor2D (1), vtkInteractorStyle (1), vtkRenderWindow (1), vtkScalarBarActor (1), vtkTextMapper (1)
horn
  • vtkMath (1)
horribly
  • vtkLightKit (1)
hospital
  • vtkLightKit (1)
host
  • vtkSocketCommunicator (1)
hotspot
  • vtk3DS (1)
http
  • vtkDEMReader (1), vtkImageEuclideanDistance (1), vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkPCAAnalysisFilter (1), vtkPLY (1), vtkPLYReader (1), vtkPLYWriter (1), vtkSurfaceReconstructionFilter (1), vtkVolumeProMapper (1), [...]
huge
  • vtkSliceCubes (1)
hughues
  • vtkQuadricDecimation (1)
hugues
  • vtkDecimatePro (1), vtkSurfaceReconstructionFilter (1)
hull
  • vtkHull (5), vtkDelaunay2D (3), vtkDelaunay3D (3), vtkOBBTree (1)
human
  • vtkOverrideInformation (1)
hundreds
  • vtkOrderedTriangulator (1)
hutton
  • vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1)
hybrid
  • vtkCaptionActor2D (1)
hyperstreamline (hyperstreamlines)
  • vtkHyperStreamline (24)

i
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
idea
  • vtkImplicitModeller (2), vtkImageReslice (1), vtkOrderedTriangulator (1)
ideal (ideally)
  • vtkImageStencilData (2), vtkMesaImageWindow (1), vtkOpenGLImageWindow (1), vtkWindowedSincPolyDataFilter (1), vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
identical
  • vtkCriticalSection (2), vtkBlankStructuredGridWithImage (1), vtkDelaunay2D (1), vtkImageDifference (1), vtkMultiProcessController (1), vtkThreadedController (1), vtkVolume (1)
identification
  • vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
identifier (identifiers)
  • vtkQuadricClustering (1), vtkVersion (1)
identify
  • vtkAbstractPropPicker (1), vtkAssemblyPath (1), vtkDebugLeaks (1), vtkKitwareContourFilter (1), vtkLocator (1), vtkMarchingContourFilter (1), vtkRenderWindowInteractor (1)
identity
  • vtkIdentityTransform (1), vtkTransform (4), vtkMatrix4x4 (2), vtkPerspectiveTransform (2), vtkProp3D (2), vtkAbstractTransform (1), vtkGeneralTransform (1), vtkImageIslandRemoval2D (1), vtkMath (1), vtkWeightedTransformFilter (1)
ifdef
  • vtkOpenGLStateCache (1), vtkSetGet (1)
ifndef
  • vtkBandedPolyDataContourFilter (1), vtkQuartzRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1)
ignore (ignores, ignoring)
  • vtkDataSetAttributes (4), vtkMath (4), vtkActor2D (1), vtkCGMWriter (1), vtkImageExport (1), vtkPolyDataMapper2D (1), vtkRectilinearGridOutlineFilter (1)
illegal
  • vtkProp3D (1), vtkVideoSource (1)
illumination
  • vtkEncodedGradientShader (4), vtkLightKit (2)
image (imageing, images, imaging)
  • vtkImageImport (21), vtkImageActor (16), vtkImageReslice (12), vtkImageToPolyDataFilter (11), vtkImageDifference (10), vtkWindowToImageFilter (9), vtkImageExport (8), vtkImageMask (8), vtkImageMapper (7), vtkBlankStructuredGridWithImage (6), [...]
image-image
  • vtkSimpleImageFilterExample (2), vtkSimpleImageToImageFilter (1)
imagemapper
  • vtkImageMapper (1)
imageof
  • vtkImageCorrelation (1)
imager (imagers)
  • vtkImager (5), vtkMesaImager (4), vtkOpenGLImager (4), vtkImagerCollection (1), vtkImageWindow (5), vtkWarpLens (3), vtkImageViewer (1), vtkImageViewer2 (1), vtkTextMapper (1)
imaginary
  • vtkImageMandelbrotSource (5), vtkImageRFFT (3), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkEnSightGoldBinaryReader (2), vtkEnSightGoldReader (2), vtkMath (2), vtkImageFFT (1)
imbedded
  • vtkEarthSource (1), vtkVolume16Reader (1), vtkVolumeReader (1)
immediate
  • vtkMapper (9), vtkDataSet (1), vtkLinkEdgels (1), vtkRenderWindow (1)
impact
  • vtkCamera (2), vtkDecimatePro (1), vtkWindow (1)
implementaiton
  • vtkWinCE (1)
implementation (IMPLEMENTATION, implementations)
  • vtkDataSet (3), vtkInteractorStyleUnicam (3), vtkDelaunay3D (2), vtkInteractorStyleFlight (2), vtkInteractorStyleTrackball (2), vtkMesaImageWindow (2), vtkOBBTree (2), vtkPerlinNoise (2), vtkPriorityQueue (2), vtkRecursiveDividingCubes (2), [...]
implementing
  • vtkInteractorStyle (1), vtkSetGet (1)
implication (implications)
  • vtkImageNoiseSource (1), vtkOrderedTriangulator (1), vtkSimpleScalarTree (1)
implicit (implicitly)
  • vtkImplicitBoolean (13), vtkImplicitTextureCoords (13), vtkImplicitFunction (11), vtkImplicitDataSet (6), vtkImplicitSum (6), vtkImplicitWindowFunction (6), vtkImplicitSelectionLoop (5), vtkImplicitFunctionCollection (3), vtkImplicitVolume (3), vtkImplicitFunctionToImageStencil (2), [...]
implies (IMPLIED, implied)
  • vtkHyperStreamline (2), vtkImageAccumulate (1), vtkImageMask (1), vtkPLY (1), vtkTreeComposite (1)
import (imported, importing, imports)
  • vtkImporter (11), vtkImageImport (7), vtk3DSImporter (3), vtkVRMLImporter (2), vtkImageGridSource (1)
importer
  • vtkImporter (1), vtkVRMLImporter (1), vtkHeap (1), vtkVRML (1)
importer-specific
  • vtkImporter (1)
impressive
  • vtkRenderWindow (1)
improperly
  • vtkCastToConcrete (1), vtkStructuredData (1)
improve (improves)
  • vtkButterflySubdivisionFilter (1), vtkDecimatePro (1), vtkImageViewer (1), vtkImageWindow (1), vtkShepardMethod (1)
improvement
  • vtkImplicitModeller (3), vtkDecimate (1)
in-lined
  • vtkIdList (1)
inaccurate
  • vtkCellDerivatives (1)
inactive
  • vtkSpherePuzzle (1)
inadequate
  • vtkCellArray (1)
incandescent
  • vtkLightKit (2)
inch (inches)
  • vtkPostScriptWriter (1), vtkWindow (1)
incident
  • vtkDecimate (1)
inclusion
  • vtkSystemIncludes (2)
inclusive
  • vtkBandedPolyDataContourFilter (2), vtkBlankStructuredGrid (1), vtkDataArray (1), vtkImageAccumulate (1), vtkImageCanvasSource2D (1), vtkImageThreshold (1), vtkImageToImageStencil (1), vtkVectorText (1)
incoming
  • vtkAssemblyPath (1), vtkMILVideoSource (1), vtkRibbonFilter (1), vtkTubeFilter (1), vtkVideoSource (1), vtkWin32VideoSource (1)
incompatible
  • vtkObjectFactory (1)
inconsistent
  • vtkDataObjectToDataSetFilter (1), vtkMCubesReader (1)
increase (increased, increases, increasing)
  • vtkImplicitModeller (4), vtkDecimate (3), vtkPiecewiseFunction (3), vtkObject (2), vtkTimeStamp (2), vtkWindowedSincPolyDataFilter (2), vtkBandedPolyDataContourFilter (1), vtkCommand (1), vtkContainer (1), vtkContourFilter (1), [...]
increment (incremented, incrementing, increments)
  • vtkImageData (7), vtkStreamPoints (3), vtkDecimate (2), vtkVolumeRayCastStructures (2), vtkCellLinks (1), vtkDashedStreamLine (1), vtkDividingCubes (1), vtkRearrangeFields (1), vtkRecursiveDividingCubes (1), vtkStreamLine (1), [...]
incremental (incrementally)
  • vtkPointLocator (5), vtkDecimatePro (2), vtkEdgeTable (1), vtkTransformTextureCoords (1)
indeed
  • vtkAbstractPropPicker (1)
indefinitely
  • vtkVideoSource (1)
indendent
  • vtkInteractorStyleTrackballActor (1)
indent (indenting)
  • vtkIndent (2)
indentation
  • vtkIndent (4)
independent (independently)
  • vtkXYPlotActor (5), vtkVolumeMapper (4), vtkParallelCoordinatesActor (3), vtkFunctionSet (2), vtkInteractorStyleJoystickActor (2), vtkVolumeProperty (2), vtkCellTypes (1), vtkCubeSource (1), vtkDirectory (1), vtkImageAnisotropicDiffusion2D (1), [...]
indexing (indexed)
  • vtkGlyph3D (4), vtkBMPReader (1), vtkDirectory (1), vtkGlyph2D (1), vtkImageExport (1), vtkImageTwoInputFilter (1), vtkVolumeRayCastMapper (1)
indication
  • vtkCellLocator (1), vtkStreamPoints (1), vtkStreamer (1)
indicator (indicators)
  • vtkCaptionActor2D (1), vtkPythonUtil (1)
indices
  • vtkDataSetAttributes (3), vtkRectilinearGridGeometryFilter (3), vtkStructuredGridGeometryFilter (3), vtkImageDataGeometryFilter (2), vtkMath (2), vtkXMLParser (2), vtkBandedPolyDataContourFilter (1), vtkExtentTranslator (1), vtkExtractGrid (1), vtkExtractVOI (1), [...]
indirect (indirectly)
  • vtkPointLocator (6), vtkLightKit (1)
individual (individually)
  • vtkColorTransferFunction (1), vtkImageImport (1), vtkInteractorStyleUser (1), vtkObjectFactory (1), vtkProgrammableAttributeDataFilter (1), vtkRenderWindow (1), vtkSetGet (1), vtkStreamLine (1)
inefficient
  • vtkImageReslice (1), vtkMatrix4x4 (1), vtkSTLReader (1)
inertial
  • vtkCubeAxesActor2D (1)
infinite (infinitely)
  • vtkLight (2), vtkMath (2), vtkCone (1), vtkCylinder (1), vtkImplicitSelectionLoop (1), vtkLightKit (1), vtkLine (1)
infinity
  • vtkHyperStreamline (2), vtkMath (1)
inflection
  • vtkDecimatePro (11)
influence (influenced)
  • vtkShepardMethod (3), vtkQuadricClustering (2), vtkGaussianSplatter (1)
info
  • vtkStructuredData (3), vtkVolumeRayCastStructures (3), vtkJavaAwt (2), vtkSetGet (2), vtkVolumeRayCastFunction (2), vtkDataObjectSource (1), vtkMedicalImageReader2 (1), vtkMultiThreader (1), vtkOpenGLStateCache (1), vtkPLY (1), [...]
inform
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProMapper (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
information (informations)
  • vtkImageChangeInformation (3), vtkOverrideInformation (2), vtkOverrideInformationCollection (1), vtkVolumeRayCastFunction (7), vtkCellTypes (6), vtkDataObject (6), vtkMergeFilter (5), vtkRenderWindowInteractor (5), vtkProp (4), vtkCell (3), [...]
ingests (ingesting)
  • vtkSliceCubes (1), vtkTransformTextureCoords (1)
inherent
  • vtkHeap (1)
inheritance
  • vtkObject (1)
inherits (inherited)
  • vtkPolyData (2), vtkUnstructuredGrid (2), vtkActor (1), vtkCaptionActor2D (1), vtkMergeDataObjectFilter (1), vtkQuantizePolyDataPoints (1), vtkVolume (1)
init
  • vtkWin32Header (1)
initial-value
  • vtkImageMandelbrotSource (1)
initialiazing
  • vtkSocketController (1)
initialization
  • vtkVolumeRayCastFunction (2), vtkDelaunay3D (1), vtkImporter (1), vtkVolumeProMapper (1)
initialize (initialized, initializes)
  • vtkMPIController (7), vtkRenderWindowInteractor (6), vtkXRenderWindowInteractor (5), vtkXRenderWindowTclInteractor (5), vtkDataSetAttributes (3), vtkEdgeTable (3), vtkOrderedTriangulator (3), vtkQuartzRenderWindow (3), vtkQuartzRenderWindowInteractor (3), vtkVideoSource (3), [...]
initiate (initiated, initiates)
  • vtkDataObject (1), vtkGridSynchronizedTemplates3D (1), vtkImageDataStreamer (1), vtkImporter (1), vtkMapper (1), vtkMemoryLimitImageDataStreamer (1), vtkMultiProcessController (1), vtkPolyDataStreamer (1)
inject (injected, injecting, injects)
  • vtkDelaunay3D (4), vtkGaussianSplatter (2), vtkDelaunay2D (1)
inline
  • vtkNonLinearCell (1)
inmaging
  • vtkSource (1)
inner
  • vtkButtonSource (4), vtkDiskSource (2), vtkProcessObject (1)
inquiry
  • vtkDataSet (3), vtkUnstructuredGrid (1)
insensitive
  • vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1)
insert (inserted, inserting, insertion, inserts)
  • vtkPointLocator (14), vtkEdgeTable (13), vtkCharArray (9), vtkDoubleArray (8), vtkFloatArray (8), vtkIntArray (8), vtkLongArray (8), vtkShortArray (8), vtkUnsignedCharArray (8), vtkUnsignedIntArray (8), [...]
insets
  • vtkBitArray (1)
inside
  • vtkOrderedTriangulator (11), vtkExtractGeometry (8), vtkExtractPolyDataGeometry (8), vtkCell (7), vtkClipDataSet (6), vtkClipPolyData (6), vtkClipVolume (6), vtkSelectPolyData (6), vtkCellLocator (4), vtkImplicitSelectionLoop (4), [...]
installs
  • vtkQuartzRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2)
instance (instances)
  • vtkFieldData (13), vtkInstantiator (9), vtkProp (6), vtkAxisActor2D (5), vtkObjectFactory (4), vtkOutputWindow (4), vtkRenderWindowInteractor (4), vtkSetGet (4), vtkActor (3), vtkActor2D (3), [...]
instantiate (instantiated, instantiates)
  • vtkEdgeTable (2), vtkArcPlotter (1), vtkAssemblyPath (1), vtkAxisActor2D (1), vtkCGMWriter (1), vtkCellArray (1), vtkCubeAxesActor2D (1), vtkDataArray (1), vtkDataSetToDataObjectFilter (1), vtkDataWriter (1), [...]
institute
  • vtkVRML (1), vtkVRMLImporter (1)
instructions
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProMapper (1)
insure (insures)
  • vtkCastToConcrete (2), vtkDataArray (2), vtkCellLocator (1), vtkDataObject (1), vtkMultiProcessLog (1), vtkPolyDataNormals (1), vtkProgrammableAttributeDataFilter (1), vtkSampleFunction (1), vtkThreadSafeLog (1), vtkTimerLog (1), [...]
inteface
  • vtkFunctionSet (1)
intefering
  • vtkMPICommunicator (1)
integerize
  • vtkCGMWriter (1)
integers
  • vtkWinCE (14), vtkImageImport (3), vtkWindowLevelLookupTable (2), vtkByteSwap (1), vtkDEMReader (1), vtkImageBlockReader (1), vtkImageBlockWriter (1)
integrate (integrated, integrates, integrating, integration, integrations)
  • vtkStreamer (24), vtkHyperStreamline (16), vtkRungeKutta45 (4), vtkInitialValueProblemSolver (3), vtkStreamLine (3), vtkPLOT3DReader (2), vtkInterpolatedVelocityField (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1)
integrator
  • vtkStreamer (2), vtkInitialValueProblemSolver (1)
integrity
  • vtkWindowedSincPolyDataFilter (1)
intelligently
  • vtkPolyData (1)
intensities
  • vtkLightKit (1), vtkVolumeProMapper (1)
intensity
  • vtkBooleanTexture (12), vtkLightKit (5), vtkEncodedGradientShader (3), vtkEncodedGradientEstimator (1), vtkImplicitTextureCoords (1), vtkLight (1), vtkPLYReader (1), vtkRenderer (1), vtkThresholdTextureCoords (1), vtkVolumeProperty (1), [...]
intent
  • vtkBranchExtentTranslator (1)
inter-process
  • vtkCellTypes (1), vtkCommunicator (1)
interact (interaction, interactions, interacts)
  • vtkInteractorStyleUser (8), vtkQuartzRenderWindowInteractor (5), vtkWin32RenderWindowInteractor (5), vtkInteractorStyle (4), vtkRenderWindowInteractor (4), vtkXRenderWindowInteractor (4), vtkXRenderWindowTclInteractor (4), vtkInteractorStyleTrackball (3), vtkInteractorStyleFlight (1), vtkInteractorStyleJoystickActor (1), [...]
interactive (interactively)
  • vtkInteractorStyleImage (2), vtkInteractorStyleTrackballCamera (2), vtkRenderer (2), vtkCompositeManager (1), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleSwitch (1), vtkMassProperties (1), vtkProp (1)
interactor (interactors)
  • vtkXRenderWindowInteractor (10), vtkRenderWindowInteractor (9), vtkXRenderWindowTclInteractor (9), vtkQuartzRenderWindowInteractor (7), vtkWin32RenderWindowInteractor (7), vtkInteractorStyle (3), vtkInteractorStyleSwitch (3), vtkInteractorStyleTrackball (2), vtkInteractorStyleUnicam (1), vtkInteractorStyleUser (1), [...]
interactory
  • vtkInteractorStyleSwitch (1)
interations
  • vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1)
intercept (intercepts)
  • vtkDebugLeaks (2), vtkQuartzRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2)
interest (interested, interesting)
  • vtkExtractGrid (4), vtkExtractVOI (4), vtkWindowedSincPolyDataFilter (2), vtkDecimate (1), vtkImageMarchingCubes (1), vtkInteractorStyleUnicam (1), vtkLocator (1), vtkMarchingCubes (1), vtkMarchingSquares (1), vtkPLOT3DReader (1), [...]
interface (interfaces, interfacing)
  • vtkImageExport (5), vtkXRenderWindowInteractor (5), vtkXRenderWindowTclInteractor (5), vtkDataObjectSource (3), vtkMapper (3), vtkProcessObject (3), vtkProp (3), vtkVideoSource (3), vtkAbstractMapper (2), vtkAbstractMapper3D (2), [...]
interfere (interfering)
  • vtkMPIController (2), vtkMultiProcessController (2)
interior
  • vtkSmoothPolyDataFilter (7), vtkWindowedSincPolyDataFilter (7), vtkDelaunay2D (1), vtkEdgePoints (1), vtkProperty (1), vtkSpline (1), vtkVoxel (1)
interlaced
  • vtkRenderWindow (1)
intermediate
  • vtkImageIterateFilter (1), vtkInteractorStyleFlight (1), vtkRenderWindow (1), vtkRotationalExtrusionFilter (1), vtkVoxelContoursToSurfaceFilter (1)
interpenetrate
  • vtkDepthSortPolyData (1)
interpolate (interpolated, interpolates, interpolating, interpolation, interpolations)
  • vtkInterpolateDataSetAttributes (9), vtkInterpolatedVelocityField (3), vtkDataSetAttributes (8), vtkSweptSurface (8), vtkImplicitDataSet (5), vtkNonLinearCell (5), vtkCell (4), vtkImplicitVolume (4), vtkKochanekSpline (4), vtkVolumeRayCastMapper (4), [...]
interpret (interpreted, interprets)
  • vtkImageLaplacian (2), vtkXYPlotActor (2), vtkBlankStructuredGridWithImage (1), vtkImageCorrelation (1), vtkImageDotProduct (1), vtkImageGradient (1), vtkImageGradientMagnitude (1), vtkImageNonMaximumSuppression (1), vtkInteractorStyleUnicam (1), vtkPLY (1), [...]
interpretation
  • vtkNonLinearCell (1)
interpreter (interpreters)
  • vtkProgrammableDataObjectSource (1), vtkProgrammableFilter (1), vtkProgrammableSource (1), vtkTkImageViewerWidget (1), vtkTkImageWindowWidget (1), vtkTkRenderWidget (1)
interprocess
  • vtkSocketCommunicator (1)
interrogating
  • vtkUGFacetReader (1)
interrupt
  • vtkRenderWindow (1)
intersect (intersected, intersecting, intersection, intersections, intersects)
  • vtkOBBTree (8), vtkCellLocator (7), vtkCell (6), vtkLine (5), vtkPicker (5), vtkPolygon (5), vtkLocator (4), vtkVertex (3), vtkIdList (2), vtkPlane (2), [...]
interupt
  • vtkCompositeManager (1)
interval (intervals)
  • vtkInitialValueProblemSolver (1), vtkPiecewiseFunction (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1), vtkStreamer (1)
intialize
  • vtkEdgeTable (1)
introduces (introduced, introducing)
  • vtkCleanPolyData (1), vtkDashedStreamLine (1), vtkDataSetToDataSetFilter (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkPointSetToPointSetFilter (1), vtkQuantizePolyDataPoints (1), vtkSelectVisiblePoints (1)
ints
  • vtkLargeInteger (1), vtkMultiThreader (1), vtkSocketCommunicator (1)
invalid
  • vtkCellArray (1), vtkDataObject (1), vtkDelaunay3D (1), vtkEnSightReader (1)
invalidate
  • vtkOpenGLStateCache (3)
invariance
  • vtkPLinearExtrusionFilter (4), vtkPCellDataToPointData (2), vtkPPolyDataNormals (2), vtkCleanPolyData (1)
invariant
  • vtkCleanPolyData (1), vtkPCellDataToPointData (1)
inverse (inversion)
  • vtkAbstractTransform (12), vtkTransform (10), vtkWarpTransform (10), vtkGeneralTransform (7), vtkPerspectiveTransform (7), vtkMath (4), vtkTetra (3), vtkHexahedron (2), vtkCamera (1), vtkDataReader (1), [...]
invert (inverted, inverts)
  • vtkAbstractTransform (2), vtkMath (2), vtkVolumeMapper (2), vtkWarpTransform (2), vtkCellArray (1), vtkGeneralTransform (1), vtkIdentityTransform (1), vtkImageMathematics (1), vtkIterativeClosestPointTransform (1), vtkLandmarkTransform (1), [...]
invertible
  • vtkDelaunay2D (1)
invisible
  • vtkSelectVisiblePoints (3)
invocation (invocations)
  • vtkHeap (2), vtkMultiProcessController (2), vtkAbstractPicker (1), vtkDataArray (1), vtkImageImport (1), vtkLight (1), vtkRenderWindow (1), vtkTexture (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
invoke (INVOKING, invoked, invokes, invoking)
  • vtkDataObjectSource (4), vtkDataSetAttributes (4), vtkObject (4), vtkRenderWindowInteractor (4), vtkCell (3), vtkOrderedTriangulator (3), vtkProp (3), vtkAbstractPicker (2), vtkAbstractPropPicker (2), vtkDataReader (2), [...]
involve (involves, involving)
  • vtkActor (1), vtkAssemblyNode (1), vtkFunctionParser (1), vtkImageExtractComponents (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkProp (1), vtkVolume (1)
inward
  • vtkCamera (1)
irix
  • vtkCriticalSection (1)
irregular
  • vtkImplicitSelectionLoop (1), vtkLinearExtrusionFilter (1), vtkTriangularTCoords (1), vtkTriangularTexture (1)
isbe
  • vtkPCAAnalysisFilter (1)
island (islands)
  • vtkImageIslandRemoval2D (2)
iso-contouring
  • vtkShepardMethod (1)
iso-surfacing (iso-surfaced)
  • vtkGaussianSplatter (2)
isocontour (isocontouring)
  • vtkScalarTree (2)
isoline (isolines)
  • vtkContourFilter (3), vtkContourGrid (3), vtkKitwareContourFilter (3), vtkMarchingContourFilter (3), vtkMarchingSquares (3), vtkMarchingSquaresCases (1), vtkSynchronizedTemplates2D (1)
isoparametric
  • vtkQuadraticEdge (2), vtkCellType (1)
isopoints
  • vtkContourFilter (1), vtkContourGrid (1), vtkKitwareContourFilter (1), vtkMarchingContourFilter (1)
isosurface (isosurfaces, isosurfacing)
  • vtkVolumeRayCastIsosurfaceFunction (2), vtkContourGrid (4), vtkSliceCubes (4), vtkContourFilter (3), vtkDividingCubes (3), vtkImageMarchingCubes (3), vtkKitwareContourFilter (3), vtkMarchingContourFilter (3), vtkMarchingCubes (3), vtkRecursiveDividingCubes (3), [...]
isotropic
  • vtkLandmarkTransform (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
isotropically
  • vtkProp3D (1)
isovalue
  • vtkVolumeRayCastIsosurfaceFunction (1)
isspace
  • vtkXMLParser (1)
issue (issued)
  • vtkImageIterateFilter (1), vtkMPIEventLog (1), vtkProjectedTexture (1), vtkSpatialRepresentationFilter (1)
istream
  • vtkDataReader (1)
italic (italics)
  • vtkCubeAxesActor2D (2), vtkLabeledDataMapper (2), vtkTextMapper (2), vtkAxisActor2D (1), vtkParallelCoordinatesActor (1), vtkScalarBarActor (1), vtkXYPlotActor (1)
italicizing
  • vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkCubeAxesActor2D (1), vtkLabeledDataMapper (1), vtkLegendBoxActor (1), vtkParallelCoordinatesActor (1), vtkScalarBarActor (1), vtkXYPlotActor (1)
item (items)
  • vtkAbstractList (12), vtkCollection (4), vtkPriorityQueue (4), vtkContainer (3), vtkCharArray (2), vtkImplicitModeller (2), vtkPLY (2), vtkAbstractTransform (1), vtkBitArray (1), vtkDoubleArray (1), [...]
iter
  • vtkImageStencilData (3)
iterate (iterated, iterates, iteration, iterations)
  • vtkImageIterateFilter (6), vtkWindowedSincPolyDataFilter (11), vtkDecimate (10), vtkSmoothPolyDataFilter (10), vtkIterativeClosestPointTransform (6), vtkGraphLayoutFilter (3), vtkImageProgressIterator (3), vtkImageAnisotropicDiffusion2D (2), vtkImageAnisotropicDiffusion3D (2), vtkMath (2), [...]
iterative (iteratively)
  • vtkIterativeClosestPointTransform (1), vtkWindowedSincPolyDataFilter (2), vtkGridTransform (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkSmoothPolyDataFilter (1), vtkThinPlateSplineTransform (1), vtkWarpTransform (1)
iterator
  • vtkImageIterator (6), vtkImageProgressIterator (4)
iverse
  • vtkAbstractTransform (1)

j
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
jacobi
  • vtkMath (1)
jacobian
  • vtkHexahedron (2), vtkTetra (2), vtkAbstractTransform (1)
january
  • vtkTimerLog (1)
java
  • vtkJavaAwt (1), vtkJavaUtil (1), vtkLinearTransform (6), vtkAbstractTransform (3), vtkRearrangeFields (3), vtkAssignAttribute (2), vtkSplitField (2), vtkInstantiator (1), vtkMatrix4x4 (1), vtkProgrammableAttributeDataFilter (1), [...]
joined
  • vtkCubeAxesActor2D (1)
joint (joints)
  • vtkWeightedTransformFilter (2)
joystick
  • vtkInteractorStyle (7), vtkInteractorStyleSwitch (4), vtkInteractorStyleTrackball (2), vtkRenderWindowInteractor (1)
jpeg (JPEG)
  • vtkJPEGReader (4), vtkJPEGWriter (4)
judge
  • vtkMath (1)
julia
  • vtkImageMandelbrotSource (1)
july
  • vtkKochanekSpline (1), vtkLoopSubdivisionFilter (1), vtkTreeComposite (1)
jump
  • vtkCubeAxesActor2D (1)
junior
  • vtkPLY (1)
justification
  • vtkTextMapper (3), vtkCaptionActor2D (2)
justified
  • vtkTextMapper (1)
justs
  • vtkImageOpenClose3D (1)

k
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
k-plane
  • vtkRectilinearGridGeometryFilter (3), vtkImageDataGeometryFilter (2), vtkStructuredGridGeometryFilter (2)
kaiser
  • vtkWindowedSincPolyDataFilter (1)
karp
  • vtkRungeKutta45 (1)
kd-trees
  • vtkCellLocator (1), vtkPointLocator (1), vtkPointLocator2D (1)
keeping
  • vtkImageMandelbrotSource (2), vtkEdgeTable (1), vtkMPICommunicator (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkRenderWindow (1)
kernal
  • vtkImageConvolve (1)
kernel (kernels)
  • vtkImageSeparableConvolution (11), vtkImageConvolve (9), vtkWindowedSincPolyDataFilter (5), vtkImageSpatialFilter (3), vtkImageCorrelation (1), vtkImageDilateErode3D (1), vtkImageGaussianSmooth (1), vtkImageSobel3D (1)
kernelsize
  • vtkImageSeparableConvolution (1)
key-to-fill
  • vtkLightKit (4)
key-to-headlight
  • vtkLightKit (2)
keyboard
  • vtkInteractorStyleFlight (2), vtkXRenderWindowInteractor (2), vtkXRenderWindowTclInteractor (2), vtkInteractorStyle (1), vtkQuartzRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1)
keypress
  • vtkInteractorStyle (13), vtkRenderWindowInteractor (3), vtkInteractorStyleImage (1), vtkXRenderWindowInteractor (1)
keys
  • vtkInteractorStyle (1), vtkInteractorStyleFlight (1)
keystroke
  • vtkInteractorStyleUser (2)
kill
  • vtkMultiThreader (1)
kilobytes
  • vtkDataObject (2), vtkCellArray (1), vtkCellLinks (1), vtkCellTypes (1), vtkDataArray (1), vtkDataSet (1), vtkDicer (1), vtkFieldData (1), vtkImageData (1), vtkMemoryLimitImageDataStreamer (1), [...]
kinds
  • vtkImageStencilSource (1)
kinetic
  • vtkPLOT3DReader (1)
kirk
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
kitware
  • vtkKitwareObjectFactory (2), vtkOpenGLVolumeProVG500Mapper (3), vtkOpenGLVolumeProVP1000Mapper (3), vtkVolumeProMapper (3), vtkVolumeProVG500Mapper (3), vtkVolumeProVP1000Mapper (3)
kludge
  • vtkOpenGLStateCache (1)
knowing
  • vtkCompositeManager (1)
knowledge
  • vtkGenericEnSightReader (1)
kochanek
  • vtkKochanekSpline (5)
kochenek
  • vtkKochanekSpline (1)
kutta
  • vtkStreamer (1)

l
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
label (labeled, labeling, labels)
  • vtkLabeledDataMapper (23), vtkAxisActor2D (21), vtkXYPlotActor (11), vtkCubeAxesActor2D (9), vtkParallelCoordinatesActor (7), vtkScalarBarActor (7), vtkAssignAttribute (5), vtkIdFilter (2), vtkCaptionActor2D (1), vtkCellCenters (1), [...]
laboratory
  • vtkTreeComposite (4)
lace
  • vtkQuadricClustering (1)
lacks
  • vtkParallelCoordinatesActor (1)
lanczos
  • vtkWindowedSincPolyDataFilter (1)
landmark (landmarks)
  • vtkLandmarkTransform (4), vtkThinPlateSplineTransform (5), vtkIterativeClosestPointTransform (2), vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1)
language (languages)
  • vtkDataArray (4), vtkQuartzRenderWindowInteractor (2), vtkRearrangeFields (2), vtkVRMLImporter (2), vtkWin32RenderWindowInteractor (2), vtkAssignAttribute (1), vtkImageWindow (1), vtkInstantiator (1), vtkInteractorStyleUnicam (1), vtkInteractorStyleUser (1), [...]
laplacian
  • vtkImageLaplacian (1), vtkSmoothPolyDataFilter (5)
large
  • vtkLargeInteger (1), vtkRenderLargeImage (1), vtkImageToPolyDataFilter (3), vtkImplicitModeller (3), vtkCamera (2), vtkMapper (2), vtkSweptSurface (2), vtkCGMWriter (1), vtkDataArray (1), vtkDataReader (1), [...]
larger
  • vtkButtonSource (2), vtkLightKit (2), vtkMapper (2), vtkAxisActor2D (1), vtkCamera (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkGridSynchronizedTemplates3D (1), vtkImageClip (1), vtkImageConstantPad (1), [...]
largest
  • vtkDecimate (3), vtkConnectivityFilter (2), vtkExtentTranslator (2), vtkPolyDataConnectivityFilter (2), vtkCellArray (1), vtkDataSet (1), vtkDecimatePro (1), vtkImageData (1), vtkImageImport (1), vtkImageIterateFilter (1), [...]
latitude
  • vtkSphereSource (9), vtkSuperquadricSource (3), vtkTexturedSphereSource (3), vtkLightKit (2), vtkPOPReader (2)
latter
  • vtkAbstractTransform (1), vtkDelaunay2D (1)
lattice
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
layer (layered, layers)
  • vtkActor2DCollection (6), vtkRenderer (5), vtkRenderWindow (4), vtkActor2D (2), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkPCellDataToPointData (1), vtkProp (1), vtkScalarBarActor (1)
laying
  • vtkSelectPolyData (4), vtkBlankStructuredGrid (1), vtkCleanPolyData (1)
layout
  • vtkGraphLayoutFilter (5)
leader (leaders)
  • vtkCaptionActor2D (20)
leading
  • vtkLargeInteger (1), vtkPixel (1)
leaf (leafs, leaves)
  • vtkSimpleScalarTree (5), vtkCellLocator (3), vtkOBBTree (3), vtkAbstractPropPicker (2), vtkPropAssembly (2), vtkSpatialRepresentationFilter (2), vtkAssemblyPaths (1), vtkInteractorStyleUser (1)
leak (leaks)
  • vtkDebugLeaks (2), vtkHeap (2), vtkContainer (1), vtkVRML (1)
least
  • vtkLightKit (3), vtkOrderedTriangulator (3), vtkDecimatePro (2), vtkImplicitModeller (2), vtkMath (2), vtkPointLocator2D (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageImport (1), vtkImplicitSelectionLoop (1), [...]
least-squares
  • vtkProcrustesAlignmentFilter (1)
leaving
  • vtkImageRFFT (1), vtkImageSkeleton2D (1), vtkInteractorStyleUnicam (1)
left-right
  • vtkProjectedTexture (1)
legacy (LEGACY)
  • vtkSetGet (2), vtkCamera (1), vtkDataObjectWriter (1), vtkImageAppendComponents (1), vtkImageDecomposeFilter (1), vtkImageMandelbrotSource (1), vtkPolyData (1), vtkPolyDataNormals (1), vtkRectilinearGrid (1), vtkSource (1), [...]
legend (legends)
  • vtkLegendBoxActor (15), vtkXYPlotActor (10), vtkScalarBarActor (2), vtkCaptionActor2D (1)
leland
  • vtkPLY (1)
length (lengths)
  • vtkHyperStreamline (15), vtkXYPlotActor (7), vtkStreamer (5), vtkButtonSource (4), vtkCubeSource (4), vtkHull (4), vtkStreamLine (4), vtkImageSeparableConvolution (3), vtkArrowSource (2), vtkDataSet (2), [...]
lens
  • vtkWarpLens (7), vtk3DS (1), vtkCamera (1), vtkProjectedTexture (1)
less-than
  • vtkDataSetAttributes (1)
letters
  • vtkTextSource (1)
letting
  • vtkRenderWindowInteractor (2)
level (levels)
  • vtkImageMapToWindowLevelColors (5), vtkWindowLevelLookupTable (5), vtkSpatialRepresentationFilter (13), vtkLODActor (12), vtkLocator (9), vtkLODProp3D (7), vtkXRenderWindowInteractor (7), vtkXRenderWindowTclInteractor (7), vtkDecimatePro (5), vtkImageMapper (4), [...]
level-of-detail
  • vtkProp (1)
levels-of-detail
  • vtkHull (1)
liability
  • vtkTreeComposite (1)
libary
  • vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
liberty
  • vtkImageSobel3D (1)
libjpeg
  • vtkJPEGWriter (1)
libraries
  • vtkInstantiator (3), vtkObjectFactory (3), vtkDynamicLoader (2), vtkProgrammableDataObjectSource (1), vtkProgrammableSource (1), vtkProperty (1), vtkTransform (1), vtkVolumeProMapper (1)
library
  • vtkDynamicLoader (7), vtkPLY (7), vtkMapper (3), vtkInstantiator (2), vtkMILVideoSource (2), vtkMesaPolyDataMapper (2), vtkObjectFactory (2), vtkOpenGLPolyDataMapper (2), vtkOpenGLVolumeProVG500Mapper (2), vtkOpenGLVolumeProVP1000Mapper (2), [...]
liens
  • vtkFeatureEdges (1)
lies
  • vtkOBBTree (2), vtkTextureMapToSphere (2), vtkButtonSource (1), vtkDataObject (1), vtkDataSetAttributes (1), vtkExtractPolyDataGeometry (1), vtkGlyphSource2D (1), vtkImageChangeInformation (1), vtkImageReslice (1), vtkImageStencilData (1), [...]
light (lighting, lights)
  • vtkLightKit (73), vtkLight (47), vtkLightCollection (4), vtkRIBLight (3), vtkMesaLight (1), vtkOpenGLLight (1), vtkRenderer (25), vtkOpenGLStateCache (9), vtkEncodedGradientShader (6), vtkImporter (5), [...]
light-tracking
  • vtkRenderer (1)
limit (limited, limits)
  • vtkMemoryLimitImageDataStreamer (1), vtkDecimatePro (3), vtkCell (2), vtkDicer (2), vtkMultiThreader (2), vtkPImageWriter (2), vtkPolyDataMapper (2), vtkSetGet (2), vtkSliceCubes (2), vtkVoxelContoursToSurfaceFilter (2), [...]
limitations
  • vtkCastToConcrete (2), vtkCGMWriter (1)
lindstrom
  • vtkQuadricClustering (1), vtkTriangle (1)
line (lines)
  • vtkLine (13), vtkStreamLine (9), vtkLinearExtrusionFilter (5), vtkPolyLine (5), vtkDashedStreamLine (2), vtkLineSource (2), vtkHyperStreamline (1), vtkRuledSurfaceFilter (16), vtkPolyData (12), vtkRibbonFilter (10), [...]
line-edge
  • vtkQuadraticEdge (1)
line-line
  • vtkLine (1)
linear (linearly)
  • vtkNonLinearCell (4), vtkLinearTransform (2), vtkLinearSubdivisionFilter (1), vtkLookupTable (6), vtkMath (5), vtkImageToPolyDataFilter (4), vtkImplicitSum (3), vtkWeightedTransformFilter (3), vtkAbstractTransform (2), vtkImageReslice (2), [...]
linearity
  • vtkNonLinearCell (1)
linefeed
  • vtkTextMapper (1)
link (linked, linking, links)
  • vtkCellLinks (10), vtkLinkEdgels (6), vtkPolyData (16), vtkInstantiator (3), vtkMergeFields (3), vtkRearrangeFields (3), vtkSplitField (3), vtkAbstractList (1), vtkGLUTesselatorTriangleFilter (1), vtkGeneralTransform (1), [...]
list (listed, lists)
  • vtkAbstractList (15), vtkIdList (13), vtkCellLinks (16), vtkCollection (16), vtkCellArray (14), vtkPolyData (13), vtkAssembly (10), vtkPropAssembly (10), vtkXYPlotActor (10), vtkPLY (9), [...]
lithography
  • vtkSTLReader (3), vtkSTLWriter (3), vtkPLYReader (1)
little
  • vtkPLYWriter (3), vtkImageSobel3D (1), vtkLightKit (1), vtkMesaPolyDataMapper (1), vtkOpenGLPolyDataMapper (1), vtkPLY (1), vtkWeightedTransformFilter (1)
live
  • vtkInputPort (1)
lmcolor
  • vtkMesaPolyDataMapper (2), vtkOpenGLPolyDataMapper (2)
load (loaded, loading, loads)
  • vtkPointLoad (4), vtkDynamicLoader (2), vtkObjectFactory (8), vtkMath (4), vtkTexture (3), vtkInstantiator (2), vtkLight (2), vtkLookupTable (2), vtkDirectory (1), vtkGraphicsFactory (1), [...]
locality
  • vtkDataObject (1), vtkProcessObject (1)
locally
  • vtkDecimate (1)
locate (located, locating, location, locations)
  • vtkDataArray (8), vtkCharArray (7), vtkDoubleArray (7), vtkFloatArray (7), vtkIntArray (7), vtkLight (7), vtkLongArray (7), vtkShortArray (7), vtkUnsignedCharArray (7), vtkUnsignedIntArray (7), [...]
locator (locators)
  • vtkLocator (21), vtkCellLocator (4), vtkPointLocator (2), vtkPointLocator2D (1), vtkCleanPolyData (9), vtkClipDataSet (4), vtkClipPolyData (4), vtkClipVolume (4), vtkDelaunay3D (4), vtkIterativeClosestPointTransform (4), [...]
lock (locked, locking)
  • vtkMutexLock (5), vtkJavaAwt (7), vtkCriticalSection (4), vtkAbstractTransform (1), vtkCompositeManager (1), vtkLegendBoxActor (1), vtkSharedMemoryCommunicator (1)
lockup
  • vtkCompositeManager (1)
logarithmic
  • vtkImageLogarithmicScale (1), vtkHyperStreamline (3), vtkLookupTable (2), vtkTensorGlyph (1)
logfile
  • vtkMPIEventLog (1)
logic
  • vtkImageLogic (1), vtkImageSpatialFilter (1)
logical
  • vtkAssembly (1), vtkDataArray (1)
logs (logging)
  • vtkMPIEventLog (4), vtkMultiProcessLog (3), vtkTimerLog (3)
long
  • vtkLongArray (3), vtkUnsignedLongArray (3), vtkWinCE (5), vtkDecimatePro (3), vtkOBBTree (3), vtkObject (3), vtkTimeStamp (3), vtkAbstractPropPicker (2), vtkMILVideoSource (2), vtkDashedStreamLine (1), [...]
longer
  • vtkDataSetAttributes (2), vtkBitArray (1), vtkCharArray (1), vtkDataArray (1), vtkDoubleArray (1), vtkFieldData (1), vtkFloatArray (1), vtkGraphLayoutFilter (1), vtkIdTypeArray (1), vtkIntArray (1), [...]
longest
  • vtkDecimate (1), vtkGaussianSplatter (1)
longitude
  • vtkSphereSource (9), vtkSuperquadricSource (3), vtkTexturedSphereSource (3), vtkLightKit (2), vtkPOPReader (2), vtkSpherePuzzle (1)
look (looking, looks)
  • vtkButtonSource (3), vtkInteractorStyleFlight (2), vtkLight (2), vtkSubPixelPositionEdgels (2), vtkWeightedTransformFilter (2), vtkCamera (1), vtkDataSet (1), vtkDataSetAttributes (1), vtkDelaunay2D (1), vtkEnSightReader (1), [...]
lookat
  • vtkLightKit (2)
lookup
  • vtkLookupTable (15), vtkWindowLevelLookupTable (7), vtkMapper (9), vtkPolyDataMapper2D (7), vtkScalarsToColors (7), vtkScalarBarActor (6), vtkImageMapToColors (5), vtkImageToPolyDataFilter (5), vtkImageQuantizeRGBToIndex (4), vtkTexture (4), [...]
lookuptable
  • vtkWin32ImageMapper (6), vtkMapper (2), vtkImageMapper (1), vtkPolyDataMapper2D (1)
loop (looping, loops)
  • vtkImplicitSelectionLoop (22), vtkLoopSubdivisionFilter (3), vtkSelectPolyData (28), vtkCellLocator (6), vtkRenderWindowInteractor (6), vtkMultiProcessController (5), vtkDelaunay2D (4), vtkXRenderWindowInteractor (4), vtkXRenderWindowTclInteractor (4), vtkDataObject (2), [...]
loosely
  • vtkPointLocator (1), vtkPointLocator2D (1), vtkPostScriptWriter (1)
lorensen
  • vtkDividingCubes (1), vtkMCubesReader (1), vtkMCubesWriter (1)
lose
  • vtkFieldData (2)
lost
  • vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
lots
  • vtkHeap (1), vtkMatrix4x4 (1)
louvain
  • vtkImageEuclideanDistance (1)
low-pass
  • vtkWindowedSincPolyDataFilter (4)
low-res
  • vtkLODActor (1)
lower
  • vtkThreshold (3), vtkThresholdPoints (3), vtkThresholdTextureCoords (3), vtkImageThreshold (2), vtkMath (2), vtkActor2D (1), vtkActor2DCollection (1), vtkBlankStructuredGrid (1), vtkContainer (1), vtkDataReader (1), [...]
lower-left
  • vtkXYPlotActor (2), vtkCaptionActor2D (1), vtkImageImport (1), vtkImageReslice (1)
lowest
  • vtkPiecewiseFunction (2), vtkColorTransferFunction (1), vtkImageData (1), vtkLODActor (1), vtkQuadricClustering (1), vtkRectilinearGrid (1), vtkStructuredGrid (1), vtkVolumeMapper (1), vtkVoxelContoursToSurfaceFilter (1)
ltswww
  • vtkImageEuclideanDistance (1)
lucky
  • vtkXRenderWindowInteractor (1)
ludke
  • vtkDividingCubes (1)
luminance
  • vtkImageLuminance (2), vtkScalarsToColors (2)
luts
  • vtkDataSetAttributes (1)
lying
  • vtkDividingCubes (2), vtkRecursiveDividingCubes (2), vtkSelectPolyData (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1), vtkExtractUnstructuredGrid (1), vtkOrderedTriangulator (1)
Generated on Mon Mar 25 01:37:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (m..q)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

m
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
mach
  • vtkPLOT3DReader (2)
machine (machines)
  • vtkByteSwap (4), vtkImageReader2 (4), vtkMCubesReader (4), vtkParticleReader (4), vtkVolume16Reader (4), vtkCommunicator (1), vtkEncodedGradientEstimator (1), vtkImplicitModeller (1), vtkSocketCommunicator (1), vtkSocketController (1), [...]
macro (macros)
  • vtkSetGet (27), vtkObjectFactory (4), vtkVolumeRayCastMapper (3), vtkDataObject (1), vtkImageFourierFilter (1), vtkRegressionTestImage (1), vtkSimpleScalarTree (1), vtkTimerLog (1)
magic
  • vtkMatrixToHomogeneousTransform (1), vtkMatrixToLinearTransform (1)
magnification
  • vtkImageMagnify (2), vtkImageResample (1), vtkRenderLargeImage (1), vtkWindowToImageFilter (1)
magnify
  • vtkImageMagnify (1)
magnitude (magnitudes)
  • vtkImageGradientMagnitude (2), vtkImageMagnitude (2), vtkEncodedGradientEstimator (11), vtkGlyph3D (10), vtkImageNonMaximumSuppression (4), vtkSubPixelPositionEdgels (4), vtkImageAnisotropicDiffusion2D (3), vtkImageAnisotropicDiffusion3D (3), vtkPlane (3), vtkStreamer (3), [...]
maintaining (maintained)
  • vtkLightKit (1), vtkLocator (1)
major
  • vtkHyperStreamline (9), vtkTensorGlyph (3), vtkAbstractTransform (1), vtkButtonSource (1), vtkDecimatePro (1), vtkEarthSource (1), vtkGaussianSplatter (1), vtkImageNoiseSource (1), vtkImageSource (1), vtkMath (1), [...]
majority
  • vtkInteractorStyle (1)
malloc
  • vtkHeap (4)
manage (manages)
  • vtkContourValues (2), vtkAbstractPicker (1), vtkAbstractPropPicker (1), vtkCellArray (1), vtkMultiProcessLog (1), vtkPDataSetReader (1), vtkPDataSetWriter (1), vtkProgrammableAttributeDataFilter (1), vtkProgrammableFilter (1), vtkWin32Header (1)
management
  • vtkOutputWindow (1)
manager
  • vtkRenderWindow (2)
mandelbrot
  • vtkImageMandelbrotSource (2)
mangle (mangled)
  • vtkPythonUtil (2), vtkMesaRenderWindow (1)
manhatten
  • vtkImageCityBlockDistance (1)
manifold
  • vtkFeatureEdges (2), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
manipulate (manipulated, manipulates, manipulating, manipulation)
  • vtkFieldData (6), vtkMatrix4x4 (3), vtkCellData (2), vtkCollection (2), vtkDataArray (2), vtkDataSetAttributes (2), vtkInteractorStyleImage (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2), vtkPointData (2), [...]
manner
  • vtkActor (1), vtkImageStencilData (1), vtkMultiProcessLog (1), vtkPointLocator (1), vtkPointLocator2D (1)
manocha
  • vtkOBBTree (1)
manual (manually)
  • vtkCompositeManager (5), vtkHull (2), vtkEnSight6BinaryReader (1), vtkEnSight6Reader (1), vtkEnSightGoldBinaryReader (1), vtkEnSightGoldReader (1), vtkGraphLayoutFilter (1), vtkImplicitModeller (1), vtkLookupTable (1), vtkPLOT3DReader (1), [...]
mapper (mappers)
  • vtkMapper (15), vtkAbstractMapper3D (8), vtkPolyDataMapper2D (8), vtkTextMapper (6), vtkVolumeMapper (6), vtkMapperCollection (5), vtkDataSetMapper (4), vtkPolyDataMapper (4), vtkLabeledDataMapper (3), vtkAbstractMapper (2), [...]
maps (mapped, mapping)
  • vtkTexture (9), vtkMapper (7), vtkScalarsToColors (5), vtkPolyDataMapper2D (4), vtkDataSetMapper (3), vtkImplicitWindowFunction (3), vtkTextureMapToCylinder (3), vtkTextureMapToPlane (3), vtkColorTransferFunction (2), vtkImageMandelbrotSource (2), [...]
marching
  • vtkMarchingCubesCases (1), vtkMarchingSquaresCases (1), vtkMCubesReader (6), vtkSliceCubes (6), vtkMCubesWriter (5)
mark (marked, marks)
  • vtkAxisActor2D (13), vtkMaskFields (2), vtkCamera (1), vtkCommand (1), vtkImageSeedConnectivity (1), vtkImageToPolyDataFilter (1), vtkObject (1), vtkPolyData (1), vtkSetGet (1), vtkTreeComposite (1), [...]
markup
  • vtkXMLFileOutputWindow (1)
marshal (marshaling)
  • vtkCommunicator (2)
mask (masked, masking, masks)
  • vtkImageMask (15), vtkMaskPoints (2), vtkImageReader (3), vtkImageCityBlockDistance (2), vtkImageIslandRemoval2D (2), vtkVolume16Reader (2), vtkImageEllipsoidSource (1), vtkImageMedian3D (1), vtkImageReader2 (1), vtkImageStencilSource (1), [...]
mass
  • vtkTubeFilter (1)
massless
  • vtkStreamer (2)
masters
  • vtkLoopSubdivisionFilter (1)
match (matched, matches, matching)
  • vtkImageThreshold (3), vtkImageToImageStencil (3), vtkIterativeClosestPointTransform (3), vtkCommunicator (2), vtkDataReader (2), vtkInputPort (2), vtkArrayCalculator (1), vtkAxisActor2D (1), vtkCommand (1), vtkDataObject (1), [...]
material (materials)
  • vtkCutMaterial (3), vtkEncodedGradientShader (5), vtk3DS (4), vtkExporter (1), vtkOBJExporter (1), vtkPCAAnalysisFilter (1), vtkPLY (1), vtkVRMLImporter (1), vtkVolume (1), vtkVolumeProVG500Mapper (1), [...]
math
  • vtkMath (2), vtkFunctionParser (1)
mathematic
  • vtkImageMathematics (1)
mathematical
  • vtkFunctionParser (2), vtkArrayCalculator (1), vtkRungeKutta45 (1)
matrices
  • vtkMath (5), vtkMatrix4x4 (4), vtkAssemblyPath (2), vtkQuadricClustering (2), vtkSweptSurface (2), vtkAssembly (1), vtkAssemblyNode (1), vtkProp (1), vtkVolumeRayCastFunction (1), vtkVolumeRayCastStructures (1)
matrix
  • vtkMatrix4x4 (12), vtkMatrixToHomogeneousTransform (7), vtkMatrixToLinearTransform (7), vtkgluPickMatrix (1), vtkMath (50), vtkTransform (26), vtkPerspectiveTransform (23), vtkProp3D (15), vtkGeneralTransform (12), vtkAssemblyPath (10), [...]
matrox
  • vtkMILVideoSource (3)
matter
  • vtkDataSetToDataSetFilter (1), vtkImageClip (1), vtkImplicitTextureCoords (1), vtkPointSetToPointSetFilter (1), vtkProbeFilter (1), vtkRenderer (1)
maximize
  • vtkVolumeRayCastFunction (1)
maximum (maximums)
  • vtkDecimate (11), vtkDecimatePro (11), vtkDataObject (4), vtkHyperStreamline (4), vtkSubPixelPositionEdgels (4), vtkTensorGlyph (4), vtkVolumeRayCastMIPFunction (4), vtkVolumeTextureMapper2D (4), vtkXYPlotActor (4), vtkBrownianPoints (3), [...]
maxium
  • vtkTubeFilter (1)
maybe
  • vtkImageStencilData (1), vtkProgrammableAttributeDataFilter (1)
mean (meaning, means)
  • vtkIterativeClosestPointTransform (7), vtkImageToPolyDataFilter (3), vtkPCAAnalysisFilter (3), vtkClipPolyData (2), vtkFieldData (2), vtkPolyData (2), vtkProcrustesAlignmentFilter (2), vtkReverseSense (2), vtkSimpleScalarTree (2), vtkSweptSurface (2), [...]
meant
  • vtkIdentityTransform (4), vtkLinearTransform (4), vtkAbstractTransform (2), vtkGeneralTransform (2), vtkHomogeneousTransform (2), vtkProgrammableGlyphFilter (2), vtkWarpTransform (2), vtkButtonSource (1), vtkImageConnector (1), vtkOutputPort (1), [...]
measure (measured, measures)
  • vtkCamera (3), vtkEnSightReader (3), vtkImageAnisotropicDiffusion2D (3), vtkImageAnisotropicDiffusion3D (3), vtkNonLinearCell (3), vtkDEMReader (2), vtkEnSightGoldReader (2), vtkTextureMapToSphere (2), vtkButtonSource (1), vtkEnSight6BinaryReader (1), [...]
measurement (measurements)
  • vtkDelaunay3D (1), vtkImageVariance3D (1), vtkMassProperties (1), vtkTimerLog (1)
mechanical
  • vtkWarpVector (1)
mechanism (mechanisms)
  • vtkVRMLImporter (3), vtkTransform (2), vtkAbstractTransform (1), vtkAssembly (1), vtkDataObject (1), vtkDataObjectSource (1), vtkErrorCode (1), vtkImplicitFunction (1), vtkInstantiator (1), vtkMapper (1), [...]
median
  • vtkImageHybridMedian2D (6), vtkImageMedian3D (5), vtkArcPlotter (2), vtkImageShrink3D (1)
medical
  • vtkMedicalImageReader2 (2), vtkImageEuclideanDistance (1), vtkWindowLevelLookupTable (1)
medium
  • vtkTensorGlyph (3), vtkLODActor (1)
medium-res
  • vtkLODActor (1)
meet
  • vtkConnectivityFilter (2), vtkCursor3D (1), vtkRenderWindow (1)
member (members)
  • vtkSetGet (9), vtkIterativeClosestPointTransform (2), vtkObjectFactory (2), vtkBandedPolyDataContourFilter (1), vtkDelaunay3D (1), vtkMatrix4x4 (1), vtkOpenGLStateCache (1), vtkPolyData (1), vtkRenderWindowInteractor (1), vtkTensor (1), [...]
memory
  • vtkMemoryLimitImageDataStreamer (1), vtkSharedMemoryCommunicator (1), vtkDataArray (11), vtkPolyData (11), vtkBitArray (9), vtkCellArray (9), vtkCharArray (8), vtkDoubleArray (8), vtkFloatArray (8), vtkIntArray (8), [...]
memory-management
  • vtkDataObjectSource (1), vtkProcessObject (1), vtkSource (1)
menu
  • vtkLegendBoxActor (1)
merge (merged, merges, merging)
  • vtkMergeFields (6), vtkMergeDataObjectFilter (5), vtkMergePoints (2), vtkMergePoints2D (2), vtkMergeFilter (1), vtkCleanPolyData (12), vtkExtractUnstructuredGrid (10), vtkGeometryFilter (7), vtkSTLReader (7), vtkMCubesReader (5), [...]
mesa
  • vtkMesaImageWindow (3), vtkMesaPolyDataMapper (3), vtkMesaRenderWindow (3), vtkMesaActor (2), vtkMesaCamera (2), vtkMesaImageActor (2), vtkMesaImageMapper (2), vtkMesaLight (2), vtkMesaProperty (2), vtkMesaTexture (2), [...]
mesh (meshes)
  • vtkDecimatePro (34), vtkSelectPolyData (16), vtkDecimate (11), vtkDelaunay3D (9), vtkDelaunay2D (7), vtkSmoothPolyDataFilter (5), vtkWindowedSincPolyDataFilter (5), vtkQuadricClustering (4), vtkQuadricDecimation (4), vtkWeightedTransformFilter (4), [...]
message (messages)
  • vtkMPIController (7), vtkSetGet (5), vtkImageOpenClose3D (4), vtkMultiProcessController (4), vtkQuartzRenderWindowInteractor (4), vtkSharedMemoryCommunicator (4), vtkWin32RenderWindowInteractor (4), vtkMPICommunicator (3), vtkOutputWindow (3), vtkCommunicator (2), [...]
meta
  • vtkDataObject (2), vtkMedicalImageReader2 (1), vtkPDataSetWriter (1)
metadata
  • vtkPDataSetReader (1), vtkPDataSetWriter (1)
metafile
  • vtkCGMWriter (1)
meteor
  • vtkMILVideoSource (1)
meters
  • vtkDEMReader (5)
methodology
  • vtkSetGet (3), vtkWindowedSincPolyDataFilter (1)
metric
  • vtkQuadricDecimation (2)
mhalle
  • vtkLightKit (1)
mice
  • vtkInteractorStyle (1)
michael
  • vtkLightKit (1)
microsoft
  • vtkWin32ImageMapper (2), vtkKitwareObjectFactory (1), vtkSurfaceReconstructionFilter (1), vtkTimerLog (1)
mid-edge
  • vtkQuadraticEdge (1)
middle
  • vtkCaptionActor2D (1), vtkImageContinuousDilate3D (1), vtkImageContinuousErode3D (1), vtkImageDilateErode3D (1), vtkImageMedian3D (1), vtkImageRange3D (1), vtkImageSpatialFilter (1), vtkImageVariance3D (1), vtkInteractorStyleImage (1), vtkInteractorStyleJoystickActor (1), [...]
midedge
  • vtkQuadraticEdge (1)
midpoints
  • vtkHull (1), vtkRecursiveSphereDirectionEncoder (1)
millimeters
  • vtkGESignaReader (1)
milliseconds
  • vtkVideoSource (1)
mind
  • vtkParticleReader (1)
mine
  • vtkRIBExporter (3)
minimal
  • vtkAbstractPicker (2), vtkPolyLine (1), vtkQuartzRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1)
minimize (minimizes, minimizing)
  • vtkPLY (1), vtkQuadricClustering (1), vtkSmoothPolyDataFilter (1), vtkTensor (1)
minimum (minimums)
  • vtkTubeFilter (5), vtkXYPlotActor (4), vtkBrownianPoints (3), vtkLookupTable (3), vtkBandedPolyDataContourFilter (2), vtkExtractUnstructuredGrid (2), vtkGeometryFilter (2), vtkImageCityBlockDistance (2), vtkImageContinuousErode3D (2), vtkImageDifference (2), [...]
minor
  • vtkTensorGlyph (3), vtkButtonSource (1), vtkGaussianSplatter (1), vtkHyperStreamline (1), vtkPCAAnalysisFilter (1), vtkVersion (1)
minus
  • vtkDataObject (1), vtkImageDifference (1), vtkImageRange3D (1), vtkPointSet (1), vtkWeightedTransformFilter (1)
mirror
  • vtkImageMirrorPad (3)
mirror-pad
  • vtkImageReslice (1)
misc
  • vtkDataSetAttributes (1)
miscellaneous
  • vtkImageExport (1)
mismatch
  • vtkDataSet (1)
misses (missed, missing)
  • vtkWinCE (3), vtkLightKit (2), vtkImageReader2 (1), vtkVRML (1), vtkXMLParser (1)
missippi
  • vtkMPIEventLog (1)
mixed
  • vtkAppendPolyData (1), vtkContourFilter (1), vtkContourGrid (1), vtkKitwareContourFilter (1), vtkMarchingContourFilter (1)
mixed-length
  • vtkFieldData (1)
modal
  • vtkWin32VideoSource (2), vtkQuartzRenderWindowInteractor (1), vtkRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
model (modeled, modeling, models)
  • vtkImplicitModeller (12), vtkVoxelModeller (1), vtkSweptSurface (7), vtkPCAAnalysisFilter (3), vtkDEMReader (2), vtkImplicitFunction (2), vtkLinearExtrusionFilter (2), vtkQuadricClustering (2), vtkRender (2), vtkRotationalExtrusionFilter (2), [...]
modeler
  • vtkTextureMapToSphere (1)
modification (modifications)
  • vtkObject (5), vtkMatrixToHomogeneousTransform (2), vtkMatrixToLinearTransform (2), vtkAppendFilter (1), vtkCamera (1), vtkDecimate (1), vtkDecimatePro (1), vtkImageClip (1), vtkProp (1), vtkTimeStamp (1), [...]
modifiedtime
  • vtkAbstractMapper (1), vtkImageMapper (1)
modifiers
  • vtkInteractorStyleUser (1)
modifies (MODIFIED, modified)
  • vtkDataSet (14), vtkImageImport (4), vtkGraphLayoutFilter (3), vtkImageSeparableConvolution (3), vtkImplicitFunction (3), vtkLODActor (3), vtkMapper (3), vtkPLY (3), vtkPolyDataMapper2D (3), vtkProgrammableAttributeDataFilter (3), [...]
modify (modifying)
  • vtkAbstractTransform (2), vtkCellType (2), vtkContourFilter (2), vtkContourGrid (2), vtkGridSynchronizedTemplates3D (2), vtkImageChangeInformation (2), vtkImageMarchingCubes (2), vtkImageReslice (2), vtkInteractorStyle (2), vtkMarchingContourFilter (2), [...]
modulation (modulated)
  • vtkVolumeProMapper (4), vtkImageMapToWindowLevelColors (3)
modulo
  • vtkImageWrapPad (1)
moffett
  • vtkPLOT3DReader (1)
molds
  • vtkImageDecomposeFilter (1)
moment
  • vtkRenderWindow (1)
momentum
  • vtkPLOT3DReader (3)
monitor
  • vtkDecimate (1)
monochrome
  • vtkImageMapToColors (1)
monotonically
  • vtkTimeStamp (2), vtkObject (1)
moon
  • vtkRIBExporter (2)
motion
  • vtkInteractorStyleFlight (11), vtkInteractorStyle (7), vtkInteractorStyleTrackball (5), vtkInteractorStyleUser (3), vtkInteractorStyleJoystickActor (2), vtkSmoothPolyDataFilter (2), vtkCaptionActor2D (1), vtkQuartzRenderWindowInteractor (1), vtkRenderWindow (1), vtkSweptSurface (1), [...]
motivated
  • vtkMath (6)
mouse
  • vtkInteractorStyleUnicam (23), vtkInteractorStyle (16), vtkInteractorStyleUser (16), vtkInteractorStyleFlight (12), vtkInteractorStyleImage (9), vtkInteractorStyleJoystickActor (7), vtkInteractorStyleJoystickCamera (7), vtkInteractorStyleTrackballActor (6), vtkInteractorStyleTrackballCamera (6), vtkRenderWindowInteractor (4), [...]
move (MOVE, moves)
  • vtkSpherePuzzle (12), vtkRearrangeFields (6), vtkInteractorStyle (4), vtkInteractorStyleJoystickCamera (3), vtkLight (3), vtkPlaneSource (3), vtkRenderer (3), vtkWeightedTransformFilter (3), vtkCamera (2), vtkImageData (2), [...]
moved
  • vtkInteractorStyleImage (2), vtkButtonSource (1), vtkInteractorStyleUnicam (1), vtkInteractorStyleUser (1), vtkLight (1), vtkRayCaster (1), vtkRearrangeFields (1), vtkReferenceCount (1), vtkThinPlateSplineTransform (1)
movement (movements)
  • vtkInteractorStyleUnicam (3), vtkRenderWindowInteractor (2), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleUser (1)
moving
  • vtkCamera (3), vtkInteractorStyleJoystickActor (3), vtkInteractorStyleUnicam (3), vtkImageData (2), vtkInteractorStyleJoystickCamera (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2), vtkCaptionActor2D (1), vtkInteractorStyleFlight (1), vtkInteractorStyleImage (1), [...]
multi
  • vtkImageFFT (1), vtkImageRFFT (1)
multi-component
  • vtkLabeledDataMapper (2), vtkDataArray (1), vtkImageMapToColors (1), vtkImageReslice (1), vtkImageStencil (1), vtkMapper (1), vtkPolyDataMapper2D (1), vtkSplitField (1)
multi-grid
  • vtkPLOT3DReader (1)
multi-part
  • vtkProp (1)
multi-process
  • vtkMPIController (1)
multi-processor
  • vtkImplicitModeller (1)
multi-resolution
  • vtkProp (1)
multi-spectral
  • vtkImageCanvasSource2D (1)
multi-threaded
  • vtkSimpleImageToImageFilter (1)
multibucket
  • vtkOpenGLStateCache (1)
multiple (multiples)
  • vtkMultiProcessController (4), vtkOutputPort (4), vtkXRenderWindowInteractor (4), vtkXRenderWindowTclInteractor (4), vtkActor (3), vtkImageAppend (3), vtkImageIterateFilter (3), vtkImageWriter (3), vtkMPICommunicator (3), vtkMultiThreader (3), [...]
multiplication
  • vtkGeneralTransform (1)
multiplicative
  • vtkMath (2)
multiplicity
  • vtkMath (2)
multiplier
  • vtkDelaunay2D (2), vtkDelaunay3D (2), vtkProp (1)
multiplies
  • vtkMatrix4x4 (1)
multiply (multiplied, multiplying)
  • vtkGaussianSplatter (3), vtkGlyph3D (3), vtkMath (2), vtkCamera (1), vtkHomogeneousTransform (1), vtkImageBlend (1), vtkImageFlip (1), vtkImageMathematics (1), vtkMatrix4x4 (1), vtkReverseSense (1)
multiprocess (multiprocessing)
  • vtkMultiProcessController (1), vtkCommunicator (1)
multisamples
  • vtkMesaRenderWindow (2), vtkOpenGLRenderWindow (2)
multithreading (multithreaded)
  • vtkMultiThreader (5), vtkImageToImageFilter (2), vtkDataSet (1), vtkImplicitModeller (1)
mutex (mutexes)
  • vtkMutexLock (1), vtkSharedMemoryCommunicator (4), vtkAbstractTransform (1), vtkJavaAwt (1), vtkVideoSource (1)
mutliple
  • vtkMergeFields (1)
mutltiply
  • vtkMath (1)
mutual (mutually)
  • vtkVideoSource (2), vtkMutexLock (1), vtkProcrustesAlignmentFilter (1)

n
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
n-components
  • vtkDataArray (1)
n-dimensional
  • vtkParallelCoordinatesActor (2), vtkDataSetTriangleFilter (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageEuclideanDistance (1), vtkOrderedTriangulator (1)
n-sided
  • vtkHull (2), vtkPolygon (2), vtkImageToPolyDataFilter (1)
n-tuples
  • vtkBitArray (1), vtkDoubleArray (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkLongArray (1), vtkShortArray (1), vtkUnsignedCharArray (1), vtkUnsignedIntArray (1), vtkUnsignedLongArray (1), [...]
n-vector
  • vtkMath (1)
naive
  • vtkWindowToImageFilter (1)
namespace
  • vtkMesaRenderWindow (1)
naming
  • vtkRIBExporter (2), vtkDataArray (1)
nand
  • vtkImageLogic (1)
nasty
  • vtkPolyData (1)
national
  • vtkTreeComposite (3), vtkMPIEventLog (1)
native
  • vtkDataArray (4), vtkImageData (1), vtkVRMLImporter (1), vtkWindow (1)
natural
  • vtkRTAnalyticSource (1), vtkSphereSource (1), vtkTetra (1), vtkTriangle (1)
nature
  • vtkSpatialRepresentationFilter (2), vtkEnSight6BinaryReader (1), vtkEnSight6Reader (1), vtkEnSightGoldBinaryReader (1), vtkEnSightGoldReader (1), vtkInitialValueProblemSolver (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1)
navigation
  • vtkInteractorStyleUnicam (3), vtkCubeAxesActor2D (1), vtkVRMLExporter (1)
ncells
  • vtkCellArray (1), vtkDepthSortPolyData (1)
nearby
  • vtkGaussianSplatter (1)
nearest
  • vtkCursor3D (1), vtkImageReslice (1), vtkMath (1), vtkSuperquadricSource (1), vtkVolumeRayCastIsosurfaceFunction (1), vtkVolumeRayCastMapper (1), vtkXTextMapper (1)
nearest-neighbor
  • vtkImageReslice (1)
nearly
  • vtkDelaunay2D (1), vtkDelaunay3D (1), vtkOrderedTriangulator (1), vtkWarpTransform (1)
nearz
  • vtkCamera (4)
necesary
  • vtkDataObject (1)
needles
  • vtkGaussianSplatter (1)
negated
  • vtkImageFlip (1)
negative
  • vtkImageCityBlockDistance (3), vtkMath (3), vtkPlaneSource (3), vtkImplicitTextureCoords (2), vtkVideoSource (2), vtkAxes (1), vtkCell3D (1), vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1), vtkGaussianSplatter (1), [...]
neighbor (neighboring, neighbors, neighbour)
  • vtkImageAnisotropicDiffusion2D (9), vtkImageAnisotropicDiffusion3D (7), vtkLinkEdgels (5), vtkImageVariance3D (3), vtkImageConnector (2), vtkImageHybridMedian2D (2), vtkPolyData (2), vtkPolyDataNormals (2), vtkSubPixelPositionEdgels (2), vtkCellLinks (1), [...]
neighborhood (neighborhoods)
  • vtkImageMedian3D (5), vtkImageAnisotropicDiffusion3D (4), vtkImageRange3D (4), vtkImageVariance3D (4), vtkImageAnisotropicDiffusion2D (3), vtkImageContinuousDilate3D (3), vtkImageContinuousErode3D (3), vtkImageSpatialFilter (3), vtkImageDilateErode3D (2), vtkImageHybridMedian2D (1), [...]
neither
  • vtkCubeAxesActor2D (1), vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1), vtkInteractorStyleUnicam (1), vtkTreeComposite (1)
nesting (nested)
  • vtkCompositeManager (3), vtkAssembly (1), vtkImplicitBoolean (1), vtkIndent (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
network (networks)
  • vtkDataObject (3), vtkSource (3), vtkDataObjectSource (2), vtkAbstractMapper3D (1), vtkGraphLayoutFilter (1), vtkPolyDataConnectivityFilter (1), vtkProcessObject (1), vtkProgrammableAttributeDataFilter (1), vtkProgrammableFilter (1)
neutral
  • vtkLightKit (2), vtkInteractorStyle (1)
newer
  • vtkWarpLens (2), vtkVRMLExporter (1)
newly
  • vtkMergePoints (1), vtkPointLocator (1)
newton
  • vtkWarpTransform (2)
nicely
  • vtkKochanekSpline (1), vtkLegendBoxActor (1)
nifty
  • vtkRuledSurfaceFilter (2), vtkTubeFilter (1)
no-arguments
  • vtkProp (1)
nodal
  • vtkVectorDot (1)
node (nodes)
  • vtkAssemblyNode (10), vtkAssemblyPath (16), vtkAbstractPropPicker (10), vtkOBBTree (10), vtkSimpleScalarTree (9), vtkEnSight6BinaryReader (4), vtkEnSight6Reader (4), vtkVRMLImporter (4), vtkEnSightGoldBinaryReader (3), vtkEnSightGoldReader (3), [...]
noise
  • vtkPerlinNoise (11), vtkImageNoiseSource (4), vtkVideoSource (1)
nominal
  • vtkHyperStreamline (1), vtkStreamer (1)
non-attribute
  • vtkDataSetAttributes (1), vtkExtractVectorComponents (1)
non-blank
  • vtkEnSightReader (1), vtkGenericEnSightReader (1)
non-blocking
  • vtkMPICommunicator (2), vtkMPIController (2)
non-boundary
  • vtkImageSpatialFilter (1)
non-castable
  • vtkFieldData (1)
non-complex
  • vtkEnSightReader (5), vtkGenericEnSightReader (1)
non-compressed
  • vtkTIFFWriter (1)
non-constant
  • vtkEncodedGradientEstimator (1)
non-convex
  • vtkPolygon (1)
non-existent
  • vtkWeightedTransformFilter (1)
non-field
  • vtkAttributeDataToFieldDataFilter (2)
non-incrementing
  • vtkDecimate (1)
non-invertible
  • vtkDelaunay2D (1)
non-linear
  • vtkNonLinearCell (6), vtkCell (1), vtkLightKit (1)
non-manifold
  • vtkDecimate (3), vtkFeatureEdges (3), vtkDecimatePro (2), vtkPolyDataNormals (2), vtkCleanPolyData (1), vtkQuantizePolyDataPoints (1)
non-maximum
  • vtkImageNonMaximumSuppression (1)
non-member
  • vtkImageMultipleInputFilter (1), vtkImageMultipleInputOutputFilter (1)
non-negative
  • vtkBMPReader (1)
non-periodic
  • vtkPerlinNoise (1)
non-planar
  • vtkDecimatePro (1), vtkSelectPolyData (1)
non-polar
  • vtkSphereSource (1)
non-power
  • vtkTexture (1)
non-rigid
  • vtkDelaunay2D (2)
non-self-intersecting
  • vtkImplicitSelectionLoop (1)
non-standard
  • vtkMILVideoSource (1)
non-static
  • vtkMatrix4x4 (1)
non-subvolume
  • vtkVolumeRayCastFunction (1)
non-toroidal
  • vtkSuperquadricSource (1)
non-transformed
  • vtkDelaunay2D (1), vtkPicker (1)
non-triangular
  • vtkSelectPolyData (1), vtkStripper (1)
non-zero
  • vtkDelaunay2D (3), vtkDelaunay3D (3), vtkAbstractPicker (2), vtkCell (2), vtkPicker (2), vtkPolyData (2), vtkStructuredGrid (2), vtkBlankStructuredGridWithImage (1), vtkDecimatePro (1), vtkEdgeTable (1), [...]
non-zero-valued
  • vtkImageSkeleton2D (1)
nonlinear
  • vtkGridTransform (2), vtkImageReslice (2), vtkThinPlateSplineTransform (2), vtkWarpTransform (2)
nonnegative
  • vtkLabeledDataMapper (1)
norm
  • vtkVectorNorm (4), vtkMath (11), vtkDataArray (1), vtkRungeKutta45 (1), vtkStreamer (1), vtkTensorGlyph (1)
normal (NORMALS, normaled, normals)
  • vtkPolyDataNormals (11), vtkPPolyDataNormals (1), vtkEncodedGradientEstimator (16), vtkGaussianSplatter (11), vtkPlane (11), vtkRecursiveSphereDirectionEncoder (11), vtkWarpScalar (11), vtkGlyph3D (10), vtkPlaneSource (10), vtkArcPlotter (9), [...]
normalization
  • vtkFieldDataToAttributeDataFilter (6), vtkDataObjectToDataSetFilter (4), vtkGlyph3D (1)
normalize (NORMALIZED, normalized, normalizes)
  • vtkImageNormalize (2), vtkMath (7), vtkCoordinate (6), vtkDataObjectToDataSetFilter (5), vtkFieldDataToAttributeDataFilter (5), vtkXYPlotActor (5), vtkVectorNorm (4), vtkImplicitSum (2), vtkInteractorStyleUnicam (2), vtkMassProperties (2), [...]
normall
  • vtkStructuredPoints (1)
north
  • vtkSphereSource (1), vtkSuperquadric (1), vtkSuperquadricSource (1), vtkTextureMapToSphere (1), vtkTexturedSphereSource (1)
notation
  • vtkGeneralTransform (2), vtkPerspectiveTransform (2), vtkTransform (2), vtkExtractTensorComponents (1)
note (NOTE, notes)
  • vtkDataArray (11), vtkXYPlotActor (10), vtkAbstractPropPicker (7), vtkCell (5), vtkCharArray (5), vtkExtractVectorComponents (5), vtkFieldData (5), vtkFieldDataToAttributeDataFilter (5), vtkMath (5), vtkConnectivityFilter (4), [...]
noted
  • vtkDataReader (1), vtkDelaunay2D (1)
notice
  • vtkPLY (2), vtkTreeComposite (1)
notification
  • vtkRenderWindowInteractor (1)
notify (notifying)
  • vtkCommand (1), vtkDataObjectSource (1), vtkProcessObject (1)
notion
  • vtkBooleanTexture (1), vtkDelaunay2D (1), vtkDelaunay3D (1)
npts
  • vtkCellArray (4), vtkPolygon (1)
null (NULL)
  • vtkAbstractPropPicker (8), vtkFieldData (5), vtkImageSeparableConvolution (4), vtkLODProp3D (4), vtkExtractVectorComponents (3), vtkOBBTree (3), vtkAssemblyPath (2), vtkCell (2), vtkCollection (2), vtkDataSetAttributes (2), [...]
null-terminated
  • vtkXMLParser (1)
numerical (numerically)
  • vtkMath (7), vtkDelaunay2D (3), vtkDelaunay3D (3), vtkCell (2), vtkAxisActor2D (1), vtkBandedPolyDataContourFilter (1), vtkRungeKutta45 (1), vtkSelectVisiblePoints (1), vtkStreamer (1)
nxmx
  • vtkImageMagnify (1)
nxnx
  • vtkImageEuclideanDistance (1)

o
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
obey
  • vtkDataSetAttributes (7), vtkFieldData (1)
object-object
  • vtkLocator (1)
object-oriented
  • vtkSetGet (1)
objects
  • vtkDataObjectSource (4), vtkProgrammableDataObjectSource (1), vtkDataObject (9), vtkObject (8), vtkXYPlotActor (7), vtkCollection (5), vtkSource (5), vtkDataSetAttributes (4), vtkTimeStamp (4), vtkActor2DCollection (3), [...]
oblique
  • vtkCamera (3), vtkPerspectiveTransform (3)
observed
  • vtkImageToImageFilter (1)
observer (observers)
  • vtkObject (4), vtkCommand (3), vtkCompositeManager (3), vtkInteractorStyle (2)
obsolete (obsoleted)
  • vtkRayCaster (2), vtkWarpLens (2), vtkImageDecomposeFilter (1), vtkImageToImageFilter (1), vtkReferenceCount (1), vtkRenderWindow (1), vtkStructuredPointsGeometryFilter (1), vtkWin32ImageMapper (1), vtkWin32ImageWindow (1), vtkWin32PolyDataMapper2D (1), [...]
obtains (obtaining)
  • vtkEarthSource (1), vtkImageActor (1), vtkImageMapper (1), vtkInterpolatedVelocityField (1), vtkMapper (1), vtkTexture (1)
occasion (occasions)
  • vtkCell (1), vtkMCubesReader (1)
occluded
  • vtkAxisActor2D (1), vtkCaptionActor2D (1)
occlusion
  • vtkDicer (1), vtkOBBDicer (1)
occupancy
  • vtkVoxelModeller (1)
occupied
  • vtkImplicitTextureCoords (1)
occuring (occured)
  • vtkSource (2), vtkCompositeManager (1), vtkPicker (1)
occurrences
  • vtkCollection (1), vtkIdList (1)
occurring
  • vtkGeometryFilter (1)
octahedron
  • vtkHull (3), vtkRecursiveSphereDirectionEncoder (2), vtkDelaunay3D (1)
octant (octants)
  • vtkCellLocator (12), vtkLocator (1), vtkOBBTree (1), vtkPointLocator (1)
october
  • vtkImageEuclideanDistance (1)
octree (octrees)
  • vtkCellLocator (3), vtkLocator (1), vtkPointLocator (1), vtkPointLocator2D (1)
octree-based
  • vtkCellLocator (1)
offers
  • vtkRuledSurfaceFilter (1)
offscreen
  • vtkMesaImageWindow (1)
offset (offsets)
  • vtkArcPlotter (5), vtkRuledSurfaceFilter (5), vtkConnectivityFilter (4), vtkDelaunay2D (4), vtkDelaunay3D (4), vtkPolyDataConnectivityFilter (4), vtkCellTypes (3), vtkPLY (3), vtkTubeFilter (3), vtkAxisActor2D (2), [...]
often
  • vtkImageReslice (2), vtkByteSwap (1), vtkCellLocator (1), vtkCubeAxesActor2D (1), vtkDataArray (1), vtkDataObjectToDataSetFilter (1), vtkFieldDataToAttributeDataFilter (1), vtkHeap (1), vtkHyperStreamline (1), vtkImageChangeInformation (1), [...]
okay
  • vtkPLY (1)
older
  • vtkAbstractPropPicker (1), vtkRenderer (1)
omitted (omitting)
  • vtkFieldData (1), vtkVolumeProperty (1)
omni
  • vtk3DS (1)
one-dimensional
  • vtkQuadraticEdge (1)
one-quarter
  • vtkDashedStreamLine (1)
one-to-one
  • vtkCell (1), vtkPlanes (1), vtkSocketController (1)
ones
  • vtkDataSetAttributes (1), vtkOutputWindow (1)
online
  • vtkPCAAnalysisFilter (1)
opacities
  • vtkVolumeRayCastMapper (1)
opacity
  • vtkVolumeProperty (18), vtkImageBlend (10), vtkVolume (6), vtkVolumeRayCastMIPFunction (6), vtkScalarsToColors (4), vtkProperty (3), vtkVolumeMapper (3), vtkProperty2D (2), vtkVolumeRayCastFunction (2), vtkBooleanTexture (1), [...]
opacity-modulating
  • vtkTriangularTCoords (1), vtkTriangularTexture (1)
opaque
  • vtkTriangularTexture (4), vtkActor (1), vtkProp (1), vtkProperty (1), vtkRenderer (1), vtkThresholdTextureCoords (1)
open-ended
  • vtkCylinderSource (1), vtkSetGet (1)
operate (operated, operates, operating, operation, operations)
  • vtkRearrangeFields (23), vtkLocator (5), vtkProgrammableAttributeDataFilter (5), vtkTransform (5), vtkAbstractPicker (4), vtkGeneralTransform (4), vtkPointLocator (4), vtkPointLocator2D (4), vtkArrayCalculator (3), vtkDataSetAttributes (3), [...]
operator (operators)
  • vtkPolyData (12), vtkImplicitBoolean (6), vtkImageMaskBits (3), vtkLargeInteger (3), vtkImageMask (1), vtkImageOpenClose3D (1), vtkScalarBarActor (1), vtkSystemIncludes (1), vtkTimeStamp (1), vtkTreeComposite (1), [...]
opportunity
  • vtkDataObject (1)
opposed
  • vtkWindowedSincPolyDataFilter (1), vtkXYPlotActor (1)
opposite
  • vtkCamera (2), vtkDataObject (1), vtkLightKit (1), vtkMCubesReader (1), vtkPerspectiveTransform (1), vtkPlaneSource (1)
optimal
  • vtkQuadricClustering (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkWindowedSincPolyDataFilter (1)
optimality
  • vtkDelaunay3D (1)
optimizations
  • vtkImageReslice (1)
optimize (optimized)
  • vtkContourFilter (1), vtkContourGrid (1), vtkVolumeTextureMapper2D (1)
order (ordered, ordering, orders)
  • vtkOrderedTriangulator (1), vtkCutter (5), vtkReverseSense (5), vtkMCubesReader (4), vtkPolyDataNormals (4), vtkTriangle (4), vtkDelaunay2D (3), vtkImageButterworthHighPass (3), vtkImageButterworthLowPass (3), vtkImageData (3), [...]
ordinary
  • vtkInitialValueProblemSolver (1), vtkMath (1)
organize (organizes)
  • vtkScalarTree (2), vtkSimpleScalarTree (1)
orient (oriented, orienting)
  • vtkGlyph3D (9), vtkHedgeHog (4), vtkOBBTree (3), vtkGlyph2D (2), vtkImplicitFunction (2), vtkRibbonFilter (2), vtkTensorGlyph (2), vtkVectorText (2), vtkArcPlotter (1), vtkCamera (1), [...]
orientation
  • vtkProp3D (13), vtkPolyDataNormals (3), vtkActor (2), vtkCamera (2), vtkFollower (2), vtkLinkEdgels (2), vtkOBBTree (2), vtkProperty (2), vtkReverseSense (2), vtkScalarBarActor (2), [...]
origin (origins)
  • vtkImageReslice (15), vtkPlaneSource (8), vtkImageChangeInformation (7), vtkDataObjectToDataSetFilter (6), vtkProp3D (6), vtkTransformTextureCoords (6), vtkImageAccumulate (5), vtkImageStencilData (5), vtkStructuredPoints (5), vtkActor (3), [...]
original (originally)
  • vtkDecimate (6), vtkDecimatePro (4), vtkDelaunay2D (4), vtkBranchExtentTranslator (3), vtkAttributeDataToFieldDataFilter (2), vtkSplitField (2), vtkAbstractTransform (1), vtkCell (1), vtkCell3D (1), vtkCompositeManager (1), [...]
orlando
  • vtkLoopSubdivisionFilter (1)
ortho
  • vtkPerspectiveTransform (6)
orthogonal
  • vtkImageActor (2), vtkPixel (2), vtkVoxel (2), vtkImageMapper (1), vtkOBBTree (1), vtkParallelCoordinatesActor (1), vtkPerspectiveTransform (1), vtkPlaneSource (1), vtkPlanes (1), vtkRuledSurfaceFilter (1), [...]
orthogonalize
  • vtkMath (1)
orthographic
  • vtkInteractorStyleUnicam (1), vtkPerspectiveTransform (1)
ostream
  • vtkSystemIncludes (2), vtkObject (1)
othersize
  • vtkVolumeRayCastFunction (1)
outgoing
  • vtkRibbonFilter (1), vtkTubeFilter (1)
outline (outlined, outlines)
  • vtkOutlineCornerFilter (4), vtkOutlineCornerSource (3), vtkOutlineFilter (3), vtkStructuredGridOutlineFilter (3), vtkOutlineSource (2), vtkRectilinearGridOutlineFilter (1), vtkPVGeometryFilter (3), vtkEarthSource (1), vtkLODActor (1), vtkQuadricDecimation (1)
outside (OUTSIDE, outsides)
  • vtkOrderedTriangulator (11), vtkVolume (10), vtkProp (9), vtkExtractGeometry (6), vtkExtractPolyDataGeometry (6), vtkCell (4), vtkCellLocator (4), vtkPiecewiseFunction (4), vtkSelectPolyData (4), vtkBandedPolyDataContourFilter (3), [...]
over
  • vtkDecimate (5), vtkImageProgressIterator (3), vtkWeightedTransformFilter (3), vtkCaptionActor2D (2), vtkImageMandelbrotSource (2), vtkKochanekSpline (2), vtkMath (2), vtkMultiProcessController (2), vtkSampleFunction (2), vtkSmoothPolyDataFilter (2), [...]
over-constrain
  • vtkRecursiveDividingCubes (1)
overall
  • vtkProperty (2), vtkAxisActor2D (1), vtkCubeAxesActor2D (1)
overflowing
  • vtkImageData (1)
overhead
  • vtkPriorityQueue (2), vtkLightKit (1), vtkSimpleScalarTree (1)
overide
  • vtkLODActor (1), vtkMarchingCubes (1), vtkPropPicker (1)
overlap (overlapped, overlapping)
  • vtkCubeAxesActor2D (1), vtkDepthSortPolyData (1), vtkGaussianSplatter (1), vtkImageBlockReader (1), vtkImageBlockWriter (1), vtkImageEuclideanDistance (1), vtkImageFFT (1), vtkImageNoiseSource (1), vtkImageRFFT (1)
overlay (overlays)
  • vtkActor2D (1), vtkAxisActor2D (1), vtkProp (1), vtkRenderer (1), vtkWin32VideoSource (1)
overload (overloaded, overloads)
  • vtkActor (2), vtkAssembly (2), vtkActor2D (1), vtkAxisActor2D (1), vtkBandedPolyDataContourFilter (1), vtkCaptionActor2D (1), vtkExplicitCell (1), vtkFollower (1), vtkImageSeparableConvolution (1), vtkImplicitFunction (1), [...]
overriden
  • vtkOverrideInformation (2)
overrides (overriding)
  • vtkDataSetAttributes (14), vtkObjectFactory (5), vtkMaskFields (4), vtkFieldData (3), vtkMultiThreader (1), vtkQuartzGLView (1), vtkWeightedTransformFilter (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1), vtkXMesaRenderWindow (1), [...]
overrrides
  • vtkQuartzRenderWindow (1)
overshoots
  • vtkKochanekSpline (1)
overwrite (overwritten)
  • vtkArrayCalculator (2), vtkEncodedGradientShader (1), vtkFileOutputWindow (1), vtkSimpleImageToImageFilter (1)
owned
  • vtkDataWriter (2), vtkDataReader (1), vtkRenderWindow (1), vtkWindow (1)
ownership
  • vtkPythonUtil (1)
owning
  • vtkNonLinearCell (2), vtkDataObject (1)
owns
  • vtkViewport (1)

p
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
package (packages)
  • vtkImageBlend (1), vtkImageViewer (1), vtkImageViewer2 (1), vtkRIBExporter (1)
packed
  • vtkGESignaReader (2), vtkBitArray (1)
padding
  • vtkCaptionActor2D (1), vtkImageConstantPad (1), vtkImageReslice (1), vtkLegendBoxActor (1), vtkVideoSource (1)
page
  • vtkDecimate (2), vtkDecimatePro (2), vtkCollection (1), vtkImageCanvasSource2D (1), vtkImageConnector (1), vtkOBBTree (1), vtkPostScriptWriter (1), vtkStreamer (1)
paint (paints)
  • vtkImageCanvasSource2D (2), vtkImageCursor3D (1)
painter
  • vtkCGMWriter (1), vtkDepthSortPolyData (1)
pair (pairs)
  • vtkXRenderWindowInteractor (5), vtkXRenderWindowTclInteractor (5), vtkEdgeTable (2), vtkMath (2), vtkProjectedTexture (2), vtkRuledSurfaceFilter (2), vtkSpline (2), vtkTextureMapToPlane (2), vtkVolumeMapper (2), vtkXYPlotActor (2), [...]
palette
  • vtkCGMWriter (1)
pancakes
  • vtkGaussianSplatter (1)
pans (panning)
  • vtkInteractorStyleImage (2), vtkInteractorStyleJoystickActor (2), vtkInteractorStyleJoystickCamera (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2), vtkInteractorStyleUnicam (2)
paper (papers)
  • vtkInteractorStyleUnicam (2), vtkDecimate (1), vtkDecimatePro (1), vtkImageEuclideanDistance (1), vtkKochanekSpline (1), vtkQuadricClustering (1), vtkQuadricDecimation (1), vtkTriangle (1), vtkTriangularTCoords (1), vtkTriangularTexture (1)
parabolic
  • vtkQuadraticEdge (2)
parallel
  • vtkParallelCoordinatesActor (7), vtkCamera (5), vtkAppendPolyData (1), vtkCompositeManager (1), vtkDataObject (1), vtkHull (1), vtkImageStencilData (1), vtkInteractorStyleUnicam (1), vtkMPIController (1), vtkOrderedTriangulator (1), [...]
parallelepiped
  • vtkVoxel (2)
parallelism
  • vtkOutputPort (4), vtkAppendPolyData (1), vtkMultiProcessController (1)
parallelogram
  • vtkPlaneSource (1)
parametric
  • vtkCell (10), vtkStreamer (4), vtkHyperStreamline (3), vtkLine (3), vtkCellPicker (2), vtkDataSet (2), vtkInterpolateDataSetAttributes (2), vtkTetra (2), vtkVertex (2), vtkCellCenters (1), [...]
parametrically
  • vtkCell (1), vtkTetra (1)
params
  • vtkOpenGLStateCache (4)
parent
  • vtkAssembly (3), vtkPropAssembly (3), vtkXMesaRenderWindow (2), vtkXOpenGLRenderWindow (2), vtkButterflySubdivisionFilter (1), vtkCellLocator (1), vtkImageReader (1), vtkImageReader2 (1), vtkInteractorStyle (1), vtkLoopSubdivisionFilter (1), [...]
parralel
  • vtkDataObject (1)
parse (parsed, parses, parsing)
  • vtkXMLParser (9), vtkFunctionParser (2), vtkArrayCalculator (1), vtkInteractorStyleUnicam (1), vtkTextMapper (1)
parser
  • vtkXMLParser (3), vtkVRMLImporter (3), vtkVRML (2)
part (PART, parts)
  • vtkAssembly (16), vtkPropAssembly (11), vtkUGFacetReader (7), vtkEnSightGoldBinaryReader (6), vtkEnSightGoldReader (6), vtkDataObject (5), vtkEnSight6BinaryReader (5), vtkEnSight6Reader (5), vtkActor (4), vtkEnSightReader (4), [...]
partial (partially)
  • vtkSphereSource (2), vtkAbstractTransform (1), vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1), vtkPriorityQueue (1), vtkSelectPolyData (1), vtkSpherePuzzle (1), vtkTexturedSphereSource (1)
particle (particles)
  • vtkParticleReader (2), vtkStreamer (4), vtkStreamLine (1), vtkStreamPoints (1)
particularly
  • vtkConnectivityFilter (1), vtkInteractorStyleUser (1), vtkMPIEventLog (1), vtkPolyDataConnectivityFilter (1), vtkSystemIncludes (1)
particulars
  • vtkCubeAxesActor2D (1), vtkDicer (1), vtkParallelCoordinatesActor (1), vtkXYPlotActor (1)
partioning
  • vtkCompositeManager (1), vtkPieceScalars (1)
pass (passes)
  • vtkImageButterworthHighPass (1), vtkImageButterworthLowPass (1), vtkImageIdealHighPass (1), vtkImageIdealLowPass (1), vtkDataSetAttributes (8), vtkCellDerivatives (3), vtkWindowedSincPolyDataFilter (3), vtkDecimate (2), vtkExtractTensorComponents (2), vtkImageCityBlockDistance (2), [...]
passband
  • vtkWindowedSincPolyDataFilter (2)
past
  • vtkOpenGLStateCache (1), vtkVideoSource (1)
paste
  • vtkDataArray (1)
patch (patched, patches)
  • vtkDecimate (1), vtkDecimatePro (1), vtkRecursiveSphereDirectionEncoder (1)
patents (patented)
  • vtkKitwareObjectFactory (2), vtkContourFilter (1), vtkContourGrid (1), vtkSynchronizedTemplates2D (1), vtkSynchronizedTemplates3D (1)
path (paths)
  • vtkAssemblyPaths (7), vtkAssemblyPath (6), vtkAbstractPropPicker (15), vtkSweptSurface (10), vtkProp (7), vtkTestUtilities (5), vtkAssemblyNode (3), vtkObjectFactory (3), vtkAssembly (2), vtkImageReader2Factory (2), [...]
patient
  • vtkMedicalImageReader2 (2)
pattern (patterns)
  • vtkImageCheckerboard (3), vtkProperty (3), vtkProperty2D (3), vtkCommand (2), vtkImageMaskBits (2), vtkPerlinNoise (2), vtkTriangularTexture (2), vtkGESignaReader (1), vtkImageBlockReader (1), vtkImageBlockWriter (1), [...]
paulsen
  • vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1)
pcoords
  • vtkDataSet (1), vtkImageData (1), vtkRectilinearGrid (1)
peak
  • vtkImageNonMaximumSuppression (1)
peek
  • vtkPriorityQueue (2)
peices
  • vtkImageEuclideanDistance (1)
pending
  • vtkSpherePuzzle (3), vtkQuartzRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1)
penny
  • vtkTriangularTCoords (1), vtkTriangularTexture (1)
people
  • vtkObject (1), vtkSetGet (1), vtkThinPlateSplineTransform (1), vtkTransform (1)
per-cell
  • vtkWeightedTransformFilter (2)
per-curve
  • vtkXYPlotActor (1)
per-point
  • vtkWeightedTransformFilter (2)
percentage (percentages)
  • vtkDashedStreamLine (1), vtkGaussianSplatter (1), vtkScaledTextActor (1), vtkSpherePuzzle (1), vtkTimerLog (1)
perceptual
  • vtkLightKit (3)
perfect
  • vtkCamera (1)
performance
  • vtkImplicitModeller (7), vtkAssembly (1), vtkDecimatePro (1), vtkDelaunay3D (1), vtkGeometryFilter (1), vtkIdList (1), vtkImageEuclideanDistance (1), vtkKitwareContourFilter (1), vtkLocator (1), vtkMapper (1), [...]
performance-optimized
  • vtkWeightedTransformFilter (1)
period
  • vtkImageSinusoidSource (1), vtkStreamLine (1)
periodically
  • vtkDataObjectSource (1), vtkProcessObject (1)
perlin
  • vtkPerlinNoise (5)
permissible
  • vtkDecimate (1)
permission
  • vtkPLY (2), vtkInteractorStyleUnicam (1)
permits
  • vtkDEMReader (1), vtkViewport (1)
permutation
  • vtkVolume16Reader (2), vtkImageReader (1), vtkImageReslice (1), vtkSpherePuzzleArrows (1)
permute (permuted, permutes, permuting)
  • vtkImagePermute (1), vtkImageReslice (6), vtkImageDecomposeFilter (1)
perpendicular
  • vtkCamera (4), vtkMath (2), vtkPlaneSource (2), vtkProjectedTexture (2), vtkRibbonFilter (2), vtkAxisActor2D (1), vtkGaussianSplatter (1), vtkInteractorStyleImage (1), vtkLine (1), vtkVolumeMapper (1)
perspective
  • vtkPerspectiveTransform (11), vtkCamera (6), vtkEncodedGradientShader (1), vtkInteractorStyleUnicam (1)
pertinent
  • vtkSelectPolyData (1)
peter
  • vtkQuadricClustering (1), vtkTriangle (1)
phase
  • vtkPerlinNoise (3), vtkImageSinusoidSource (1), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
phong
  • vtkProperty (1)
phys
  • vtkMassProperties (1)
physical (physically)
  • vtkPerlinNoise (1), vtkProperty (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
pick (picked, picking)
  • vtkAbstractPicker (34), vtkAbstractPropPicker (34), vtkPicker (16), vtkCellPicker (12), vtkPropPicker (11), vtkPointPicker (4), vtkWorldPointPicker (2), vtkgluPickMatrix (1), vtkViewport (14), vtkProp (12), [...]
pick-up
  • vtkCollection (1)
pickable
  • vtkProp (2), vtkActor (1), vtkLODActor (1), vtkPropPicker (1), vtkVolume (1)
picker (pickers)
  • vtkAbstractPicker (6), vtkAbstractPropPicker (3), vtkPicker (1), vtkWorldPointPicker (1), vtkInteractorStyleTrackball (2), vtkRenderWindowInteractor (2)
picture
  • vtkImageEuclideanDistance (1)
piece (pieced, pieces)
  • vtkPieceScalars (4), vtkTransmitPolyDataPiece (3), vtkTransmitUnstructuredGridPiece (3), vtkExtractPolyDataPiece (2), vtkExtractUnstructuredGridPiece (2), vtkDicer (20), vtkPDataSetWriter (13), vtkDataObject (10), vtkPolyDataStreamer (8), vtkOBBDicer (5), [...]
piecewise
  • vtkPiecewiseFunction (5), vtkPiecewiseFunctionSource (2), vtkPiecewiseFunctionToPiecewiseFunctionFilter (2), vtkLoopSubdivisionFilter (1), vtkSpline (1)
pile
  • vtkDataObject (1)
pill
  • vtkButtonSource (1)
pinching
  • vtkWeightedTransformFilter (1)
pipeline (PIPELINE, pipelined, pipelines)
  • vtkPipelineSize (1), vtkImageImport (18), vtkDataObject (13), vtkImageExport (9), vtkImageStencilData (8), vtkOutputPort (7), vtkAbstractTransform (4), vtkInputPort (4), vtkPerspectiveTransform (4), vtkTransform (4), [...]
pipline
  • vtkPipelineSize (1)
pivot
  • vtkMath (2)
pixar
  • vtkRIBExporter (3)
pixel (pixels)
  • vtkPixel (1), vtkImageSeedConnectivity (13), vtkImageAnisotropicDiffusion2D (9), vtkImageAnisotropicDiffusion3D (7), vtkImageDifference (7), vtkImageMask (7), vtkAbstractPicker (5), vtkImageAccumulate (4), vtkImageBlend (4), vtkImageNonMaximumSuppression (4), [...]
pixelize
  • vtkImageToPolyDataFilter (2)
pixmap (pixmaps)
  • vtkImageData (1), vtkPNMReader (1), vtkStructuredData (1)
place (places, placing)
  • vtkImageInPlaceFilter (1), vtkMath (5), vtkPointLocator (3), vtkProp3D (3), vtkMergeDataObjectFilter (2), vtkAssembly (1), vtkBandedPolyDataContourFilter (1), vtkCaptionActor2D (1), vtkCellCenters (1), vtkContourFilter (1), [...]
place-holder
  • vtkEmptyCell (1)
placement
  • vtkGraphLayoutFilter (2), vtkCaptionActor2D (1), vtkLegendBoxActor (1), vtkProgrammableGlyphFilter (1), vtkProp3D (1), vtkTextMapper (1)
planar
  • vtkDataSetTriangleFilter (1), vtkDecimate (1), vtkOrderedTriangulator (1), vtkStructuredGridGeometryFilter (1)
planarity
  • vtkDecimate (1)
plane (planes, planning)
  • vtkPlaneSource (35), vtkPlanes (21), vtkPlane (17), vtkTextureMapToPlane (17), vtkPlaneCollection (3), vtkHull (52), vtkCamera (18), vtkPerspectiveTransform (11), vtkVolumeMapper (8), vtkAbstractMapper (6), [...]
planimetric
  • vtkDEMReader (4)
plastic
  • vtkRIBExporter (1)
plate (plates)
  • vtkThinPlateSplineTransform (2), vtkLinearExtrusionFilter (1), vtkTransformToGrid (1)
platform (platforms)
  • vtkCriticalSection (3), vtkRenderWindowInteractor (3), vtkInteractorStyle (1), vtkMultiThreader (1), vtkTimerLog (1), vtkWin32OutputWindow (1), vtkWin32VideoSource (1)
platform-dependent
  • vtkRenderWindowInteractor (1)
platform-independent
  • vtkRenderWindowInteractor (2)
play (playing)
  • vtkVideoSource (5), vtkMILVideoSource (2), vtkWin32VideoSource (2)
pleasing
  • vtkGraphLayoutFilter (1)
plot (ploted, plots, plotted, plotting)
  • vtkXYPlotActor (65), vtkArcPlotter (24), vtkParallelCoordinatesActor (10), vtkCGMWriter (2), vtkImageToPolyDataFilter (2), vtkLabeledDataMapper (2), vtkUGFacetReader (2), vtkVectorDot (2), vtkCubeAxesActor2D (1), vtkImageAccumulate (1), [...]
plotters
  • vtkCGMWriter (1)
plugin
  • vtkImageReader2Factory (1)
plus
  • vtkActor (2), vtkProgrammableAttributeDataFilter (2), vtkXYPlotActor (2), vtkBooleanTexture (1), vtkDataSet (1), vtkEncodedGradientShader (1), vtkHexahedron (1), vtkImageData (1), vtkImageHybridMedian2D (1), vtkImageToStructuredPoints (1), [...]
pname
  • vtkOpenGLStateCache (3)
pnmtops
  • vtkPostScriptWriter (1)
point (pointed, pointing, points)
  • vtkPointLocator (49), vtkPointLocator2D (26), vtkMaskPoints (16), vtkPoints (16), vtkMergePoints (11), vtkSelectVisiblePoints (10), vtkPointDataToCellData (8), vtkPointSet (7), vtkPointSource (7), vtkMergePoints2D (6), [...]
point-by-point
  • vtkDataSetAttributes (1)
point-valued
  • vtkGaussianSplatter (1)
pointdata
  • vtkImageToStructuredPoints (1), vtkPointSetSource (1)
pointer (pointers)
  • vtkImageExport (7), vtkDataArray (6), vtkFieldData (6), vtkImageImport (5), vtkSetGet (5), vtkVoidArray (5), vtkBitArray (4), vtkCharArray (4), vtkDataSet (4), vtkDoubleArray (4), [...]
pointerless
  • vtkSimpleScalarTree (2)
pointset (pointsets)
  • vtkPCAAnalysisFilter (5), vtkProcrustesAlignmentFilter (5)
poisson
  • vtkPointLoad (1)
poked
  • vtkInteractorStyle (1)
polar
  • vtkImageEuclideanToPolar (1)
pole (poles)
  • vtkSphereSource (2), vtkTextureMapToSphere (2), vtkTexturedSphereSource (1)
poly (polys)
  • vtkCleanPolyData (6), vtkPolyData (5), vtkDepthSortPolyData (2), vtkPolyDataCollection (2), vtkMesaPolyDataMapper2D (1), vtkOpenGLPolyDataMapper2D (1), vtkPolyDataMapper (1), vtkWin32PolyDataMapper2D (1), vtkXPolyDataMapper2D (1), vtkQuadricClustering (2), [...]
poly-line (poly-lines)
  • vtkStripper (6)
poly-vertex
  • vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
polydata
  • vtkPolyDataToImageStencil (3), vtkClipPolyData (1), vtkNonLinearCell (3), vtkCGMWriter (2), vtkLinearSubdivisionFilter (2), vtkMaskPoints (2), vtkClipDataSet (1), vtkCompositeManager (1), vtkCutter (1), vtkIVWriter (1), [...]
polygon (polygons)
  • vtkPolygon (17), vtkImageToPolyDataFilter (18), vtkDelaunay2D (12), vtkPolyData (12), vtkPolyDataNormals (8), vtkHull (5), vtkStripper (5), vtkMapper (4), vtkProperty (4), vtkSmoothPolyDataFilter (4), [...]
polygonal
  • vtkClipPolyData (6), vtkLinearExtrusionFilter (6), vtkSelectPolyData (6), vtkRotationalExtrusionFilter (5), vtkAppendPolyData (3), vtkCGMWriter (3), vtkPolyDataConnectivityFilter (3), vtkPolyDataNormals (3), vtkSpatialRepresentationFilter (3), vtkCleanPolyData (2), [...]
polygonalize
  • vtkImageToPolyDataFilter (7)
polygones
  • vtkDelaunay2D (1)
polyhedra
  • vtkWindowedSincPolyDataFilter (1)
polyhedral
  • vtkWindowedSincPolyDataFilter (1)
polyhedron
  • vtkHull (5), vtkWindowedSincPolyDataFilter (2)
polyline (polylines)
  • vtkRuledSurfaceFilter (8), vtkArcPlotter (7), vtkDelaunay2D (2), vtkGraphLayoutFilter (2), vtkLineSource (2), vtkCGMWriter (1), vtkExtractEdges (1), vtkLinearExtrusionFilter (1), vtkLinkEdgels (1), vtkParallelCoordinatesActor (1), [...]
polynomial (polynomials)
  • vtkWindowedSincPolyDataFilter (6)
polytechnic
  • vtkVRML (1), vtkVRMLImporter (1)
poor (poorly)
  • vtkDelaunay2D (1), vtkEdgePoints (1), vtkOBBTree (1), vtkWindowedSincPolyDataFilter (1)
port (ported, ports)
  • vtkInputPort (10), vtkOutputPort (9), vtkVRMLImporter (2), vtkDataObject (9), vtkImageStencilData (3), vtkSocketController (2), vtkVRML (2), vtkDataSetWriter (1), vtkMultiProcessController (1), vtkSocketCommunicator (1), [...]
portability
  • vtkMath (1)
portable
  • vtkPNMReader (2), vtkDirectory (1), vtkDynamicLoader (1), vtkMPIController (1), vtkPNMWriter (1)
portion (portions)
  • vtkSelectPolyData (5), vtkExtractGrid (2), vtkExtractVOI (2), vtkFieldDataToAttributeDataFilter (2), vtkAbstractPropPicker (1), vtkButtonSource (1), vtkClipVolume (1), vtkDataObjectToDataSetFilter (1), vtkDataSetToDataObjectFilter (1), vtkGlyphSource2D (1), [...]
position (positioned, positioning, positions)
  • vtkSubPixelPositionEdgels (2), vtkLight (13), vtkPointLocator (11), vtkCamera (10), vtkPointLocator2D (8), vtkActor2D (7), vtkCoordinate (7), vtkHyperStreamline (7), vtkProp3D (7), vtkXYPlotActor (7), [...]
positional
  • vtkLight (6), vtkInteractorStyleImage (1)
positive
  • vtkCamera (2), vtkImplicitTextureCoords (2), vtkMath (2), vtkQuantizePolyDataPoints (2), vtkVideoSource (2), vtkHyperStreamline (1), vtkImageCityBlockDistance (1), vtkImplicitModeller (1), vtkLightKit (1), vtkLocator (1), [...]
possibilities
  • vtkCutter (1), vtkFieldDataToAttributeDataFilter (1)
possible
  • vtkImplicitModeller (4), vtkDelaunay2D (3), vtkMath (3), vtkSource (3), vtkCell (2), vtkContourFilter (2), vtkContourGrid (2), vtkDataObjectSource (2), vtkDataObjectToDataSetFilter (2), vtkDecimatePro (2), [...]
post
  • vtkMath (1)
post-concatenated
  • vtkAbstractTransform (2)
postion
  • vtkRenderWindowInteractor (1)
potential
  • vtkLODProp3D (1), vtkProgrammableGlyphFilter (1), vtkSpherePuzzle (1), vtkSweptSurface (1)
power (powers)
  • vtkProperty (3), vtkTexture (2), vtkVolumeRayCastMapper (2), vtkImageFFT (1), vtkImageRFFT (1), vtkRecursiveDividingCubes (1), vtkVideoSource (1), vtkVolumeProVG500Mapper (1), vtkVolumeProperty (1), vtkVolumeTextureMapper2D (1)
powerful
  • vtkImplicitFunction (1)
practical
  • vtkOpenGLStateCache (1)
practice
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
pre-allocated
  • vtkImageExport (1), vtkMath (1)
pre-concatenated
  • vtkAbstractTransform (2)
pre-existing
  • vtkWin32OpenGLImageWindow (3), vtkWin32OpenGLRenderWindow (3), vtkWinCEOpenGLRenderWindow (3), vtkXMesaRenderWindow (3), vtkXOpenGLRenderWindow (3), vtkQuartzImageWindow (2), vtkQuartzRenderWindow (2), vtkWin32ImageWindow (1), vtkXImageWindow (1)
pre-multiply (pre-multiplied)
  • vtkImageCanvasSource2D (1), vtkMath (1)
pre-sorted
  • vtkOrderedTriangulator (2)
precedence
  • vtkBlankStructuredGrid (2), vtkPLOT3DReader (1), vtkStreamer (1)
precedes (preceded, preceding)
  • vtkAssemblyPath (1), vtkMPIController (1), vtkMultiProcessController (1), vtkPiecewiseFunction (1), vtkThreadedController (1)
precendence
  • vtkDataReader (1)
precisely
  • vtkCleanPolyData (1), vtkMergePoints (1), vtkMergePoints2D (1)
precision
  • vtkDoubleArray (3), vtkDelaunay2D (1), vtkInteractorStyleTrackball (1), vtkMCubesWriter (1), vtkMath (1), vtkOrderedTriangulator (1), vtkRenderWindow (1), vtkTransformToGrid (1), vtkTriangle (1)
precomputed
  • vtkVolumeRayCastStructures (2), vtkVolumeRayCastFunction (1)
predecessor
  • vtkAbstractList (1)
prefer
  • vtkLabeledDataMapper (1), vtkXYPlotActor (1)
preference (preferences)
  • vtkImageMapper (1), vtkRenderWindowInteractor (1), vtkXYPlotActor (1)
preferred
  • vtkInteractorStyleUnicam (1), vtkQuartzRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1), vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
prefined
  • vtkXMLFileOutputWindow (1)
prefix
  • vtkRIBExporter (2), vtkDynamicLoader (1), vtkGESignaReader (1), vtkImageReader2 (1), vtkImageWriter (1), vtkOBJExporter (1), vtkSliceCubes (1), vtkVolume16Reader (1), vtkVolumeReader (1)
premature (prematurely)
  • vtkProcessObject (2)
prepare
  • vtkEdgeTable (1), vtkRenderWindowInteractor (1), vtkThinPlateSplineTransform (1), vtkTreeComposite (1)
prepend
  • vtkRegressionTestImage (1)
prependicular
  • vtkGaussianSplatter (1)
prepending
  • vtkTestUtilities (2)
preprocessing
  • vtkInteractorStyleTrackball (1)
prescribe
  • vtkQuartzRenderWindow (1), vtkRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1), vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
preservation
  • vtkDecimate (2), vtkDecimatePro (1)
preserve (preserved, preserves, preserving)
  • vtkDecimate (4), vtkDecimatePro (3), vtkImageHybridMedian2D (2), vtkClipDataSet (1), vtkDelaunay2D (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkImageCityBlockDistance (1), vtkImageFlip (1), vtkQuadricClustering (1), [...]
preset
  • vtkVideoSource (1)
presorted
  • vtkOrderedTriangulator (1)
press (pressed, pressing)
  • vtkInteractorStyleUser (9), vtkInteractorStyleUnicam (7), vtkInteractorStyle (2), vtkInteractorStyleFlight (2), vtkRungeKutta45 (2), vtkInteractorStyleImage (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1), [...]
pressure
  • vtkPLOT3DReader (2)
presumed
  • vtkPolygon (1)
presumption
  • vtkTextureMapToPlane (1)
pretty
  • vtkMesaPolyDataMapper (1), vtkOpenGLPolyDataMapper (1), vtkVRMLExporter (1)
prevents (preventing)
  • vtkCell (1), vtkCollection (1), vtkInteractorStyleFlight (1), vtkMPICommunicator (1), vtkMPIController (1), vtkVertex (1)
preview
  • vtkQuartzImageWindow (1), vtkQuartzRenderWindow (1), vtkWin32ImageWindow (1), vtkWin32OpenGLImageWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWin32VideoSource (1)
previous (previously)
  • vtkImageStencilData (3), vtkLODProp3D (3), vtkAbstractTransform (2), vtkDataArray (2), vtkEdgeTable (2), vtkHull (2), vtkInteractorStyleUser (2), vtkMPICommunicator (2), vtkMath (2), vtkPointLocator (2), [...]
primarily
  • vtkAssemblyPath (1), vtkGridTransform (1), vtkViewport (1)
primary
  • vtkDEMReader (2), vtkInteractorStyleUnicam (1), vtkMergePoints (1), vtkMergePoints2D (1), vtkProperty (1)
prime
  • vtkImageFFT (2), vtkImageRFFT (2)
primitive (primitives)
  • vtkNonLinearCell (5), vtkCell (4), vtkMapper (3), vtkStreamLine (3), vtkDataSetMapper (2), vtkDepthSortPolyData (2), vtkImplicitModeller (2), vtkLinearExtrusionFilter (2), vtkPolyDataMapper (2), vtkProperty (2), [...]
principal
  • vtkPCAAnalysisFilter (2), vtkWarpLens (2)
principle
  • vtkLocator (1)
print (printed, printing, prints)
  • vtkLabeledDataMapper (9), vtkObject (7), vtkSetGet (5), vtkIndent (3), vtkDebugLeaks (2), vtkImageDilateErode3D (2), vtkQuartzImageWindow (2), vtkQuartzRenderWindow (2), vtkScalarBarActor (2), vtkThreadSafeLog (2), [...]
printout
  • vtkDecimate (1), vtkSetGet (1)
printself
  • vtkWin32ImageMapper (1)
priori
  • vtkGenericEnSightReader (1)
priority
  • vtkPriorityQueue (10), vtkDecimatePro (6), vtkObject (2)
private
  • vtkAbstractTransform (1), vtkImageDecomposeFilter (1), vtkPiecewiseFunction (1)
probe
  • vtkProbeFilter (2), vtkCutMaterial (1)
problem (problems)
  • vtkInitialValueProblemSolver (1), vtkDelaunay2D (4), vtkDelaunay3D (3), vtkMapper (3), vtkDataSetToDataSetFilter (2), vtkPointSetToPointSetFilter (2), vtkBandedPolyDataContourFilter (1), vtkCell (1), vtkCleanPolyData (1), vtkCutter (1), [...]
proc
  • vtkDecimate (1), vtkDecimatePro (1)
procedural
  • vtkRecursiveDividingCubes (1), vtkSource (1), vtkTriangularTCoords (1)
procedure (procedures)
  • vtkProgrammableAttributeDataFilter (3), vtkRecursiveDividingCubes (2), vtkSelectPolyData (2), vtkCutter (1), vtkDataSetMapper (1), vtkImplicitSelectionLoop (1), vtkRenderWindowInteractor (1), vtkSurfaceReconstructionFilter (1), vtkWindowLevelLookupTable (1), vtkXRenderWindowInteractor (1), [...]
proceed
  • vtkDecimate (1)
proceedings
  • vtkLoopSubdivisionFilter (2), vtkButterflySubdivisionFilter (1), vtkOBBTree (1)
process (PROCESS, PROCESSES, processed, processes, processing)
  • vtkMultiProcessController (29), vtkProcessObject (10), vtkMultiProcessLog (4), vtkMPIController (14), vtkVolume (11), vtkMPICommunicator (10), vtkMPIGroup (10), vtkProp (10), vtkOutputPort (9), vtkInputPort (8), [...]
processors
  • vtkEncodedGradientEstimator (1), vtkMPIEventLog (1), vtkMultiProcessController (1), vtkMultiThreader (1), vtkVolumeRayCastMapper (1)
procrustes
  • vtkProcrustesAlignmentFilter (1)
produce (produced, produces, producing)
  • vtkBandedPolyDataContourFilter (2), vtkHull (2), vtkImageQuantizeRGBToIndex (2), vtkInteractorStyleFlight (2), vtkQuadraticEdge (2), vtkVoxelContoursToSurfaceFilter (2), vtkWeightedTransformFilter (2), vtkAbstractMapper3D (1), vtkArrowSource (1), vtkButtonSource (1), [...]
product (products)
  • vtkImageDotProduct (2), vtkMath (9), vtkCamera (2), vtkImplicitSelectionLoop (2), vtkVectorDot (2), vtkDataObjectToDataSetFilter (1), vtkLine (1), vtkNonLinearCell (1), vtkPlaneSource (1), vtkStreamLine (1), [...]
profiles
  • vtkWarpVector (1)
program (programmed, programming, programs)
  • vtkProgrammableFilter (1), vtkLinearTransform (6), vtkMPIController (4), vtkAbstractTransform (3), vtkDebugLeaks (3), vtkOutputWindow (2), vtkPLY (2), vtkQuartzRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2), vtkAssembly (1), [...]
programmable
  • vtkProgrammableDataObjectSource (1), vtkProgrammableGlyphFilter (1), vtkProgrammableSource (1)
programmatically
  • vtkSource (1)
programmer (programmers)
  • vtkInteractorStyle (1), vtkMapper (1), vtkOpenGLRenderWindow (1), vtkProgrammableGlyphFilter (1), vtkRenderWindowInteractor (1), vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
progress
  • vtkImageProgressIterator (3), vtkProcessObject (7), vtkRenderWindow (2), vtkImageOpenClose3D (1)
progressive
  • vtkDecimatePro (2), vtkJPEGWriter (1)
project (projected, projecting, projection, projections)
  • vtkProjectedTexture (4), vtkCamera (17), vtkPerspectiveTransform (9), vtkPlane (5), vtkInteractorStyleUnicam (4), vtkRibbonFilter (3), vtkImageMandelbrotSource (2), vtkImplicitSelectionLoop (2), vtkCell (1), vtkCubeAxesActor2D (1), [...]
projector
  • vtkProjectedTexture (11), vtkRenderWindow (2)
prompt
  • vtkDebugLeaks (1)
prop (props)
  • vtkProp (14), vtkPropAssembly (14), vtkAbstractPropPicker (12), vtkPropCollection (5), vtkPropPicker (5), vtkLODProp3D (4), vtkProp3DCollection (2), vtkProperty2D (2), vtkViewport (16), vtkRenderer (13), [...]
propagate (propagated, propagates, propagating, propagation)
  • vtkDataObject (9), vtkImageStencilData (7), vtkImageImport (4), vtkInputPort (3), vtkStreamer (3), vtkGaussianSplatter (2), vtkHyperStreamline (2), vtkAssembly (1), vtkOpenGLStateCache (1), vtkPolyDataNormals (1)
properties
  • vtkActor (11), vtkProperty (7), vtkPLY (6), vtkVolumeProperty (5), vtkXYPlotActor (5), vtkAssembly (3), vtkImporter (3), vtkPLYReader (2), vtkPLYWriter (2), vtkParallelCoordinatesActor (2), [...]
property
  • vtkProperty (6), vtkProperty2D (4), vtkVolumeProperty (2), vtkMesaProperty (1), vtkOpenGLProperty (1), vtkRIBProperty (1), vtkLODProp3D (10), vtkActor (8), vtkPLY (5), vtkVolume (3), [...]
proportion
  • vtkPCAAnalysisFilter (2), vtkInteractorStyleTrackball (1)
proportional
  • vtkDecimatePro (2), vtkButtonSource (1), vtkCaptionActor2D (1), vtkDecimate (1), vtkMath (1)
protect (protected)
  • vtkSource (2), vtkCellData (1), vtkDataObjectSource (1), vtkEncodedGradientEstimator (1), vtkImageMarchingCubes (1), vtkImageMultipleInputFilter (1), vtkImageMultipleInputOutputFilter (1), vtkMultiProcessLog (1), vtkObject (1), vtkProcessObject (1), [...]
protocol
  • vtkApproximatingSubdivisionFilter (1), vtkImporter (1), vtkInputPort (1), vtkInterpolatingSubdivisionFilter (1), vtkOutputPort (1), vtkProgrammableAttributeDataFilter (1)
prototype
  • vtkSetGet (2), vtkStreamer (2), vtkAbstractList (1), vtkXImageWindow (1)
providing
  • vtkCell (1), vtkCellArray (1), vtkInterpolatedVelocityField (1), vtkMath (1), vtkSampleFunction (1)
proxy
  • vtkMatrixToHomogeneousTransform (1), vtkMatrixToLinearTransform (1)
prune (pruning)
  • vtkImageSkeleton2D (6)
pseudo
  • vtkXImageMapper (2), vtkXImageWindow (1)
pseudoinverse
  • vtkMath (1)
psychometrika
  • vtkProcrustesAlignmentFilter (1)
public (publicly)
  • vtkOBBTree (2), vtkTreeComposite (2), vtkCell (1), vtkDataObjectSource (1), vtkDataSetAttributes (1), vtkEncodedGradientEstimator (1), vtkFieldDataToAttributeDataFilter (1), vtkImageDecomposeFilter (1), vtkImageFourierFilter (1), vtkImageMapper (1), [...]
published
  • vtkPCAAnalysisFilter (1)
pull (pulls)
  • vtkCubeAxesActor2D (2), vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkConnectivityFilter (1)
punched
  • vtkLinearExtrusionFilter (1)
punctuation
  • vtkVectorText (1)
pure
  • vtkContainer (1), vtkMath (1), vtkTransform (1)
purpose (PURPOSE, purposely, purposes)
  • vtkDelaunay3D (3), vtkImageReslice (2), vtkLightKit (2), vtkOBBTree (2), vtkPLY (2), vtkPerlinNoise (2), vtkAppendPolyData (1), vtkCellArray (1), vtkDataObjectSource (1), vtkGenericCell (1), [...]
push (pushed, pushes)
  • vtkPlaneSource (3), vtkAbstractTransform (1), vtkActor (1), vtkGeneralTransform (1), vtkLODProp3D (1), vtkPerspectiveTransform (1), vtkQuadricClustering (1), vtkRecursiveSphereDirectionEncoder (1), vtkTransform (1)
putting
  • vtkImageMultipleInputFilter (1), vtkImageToImageFilter (1), vtkWeightedTransformFilter (1)
puzzle
  • vtkSpherePuzzle (1), vtkSpherePuzzleArrows (1)
pvtk
  • vtkPDataSetWriter (3)
pyramid
  • vtkPyramid (5), vtkCell3D (1)
python
  • vtkPythonUtil (7), vtkLinearTransform (6), vtkAbstractTransform (3), vtkImageExport (3), vtkRearrangeFields (2), vtkAssignAttribute (1), vtkImageImport (1), vtkInstantiator (1), vtkInteractorStyleUser (1), vtkMatrix4x4 (1), [...]

q
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
quad (quads)
  • vtkQuad (3), vtkImageToPolyDataFilter (6), vtkVolumeTextureMapper2D (1)
quadrant
  • vtkPointLocator2D (1)
quadratic
  • vtkQuadraticEdge (2), vtkMath (3), vtkLight (2), vtkSubPixelPositionEdgels (2)
quadric (quadrics)
  • vtkQuadricClustering (22), vtkQuadric (6), vtkQuadricDecimation (4), vtkTriangle (2)
quadrilateral (quadrilaterals)
  • vtkPixel (2), vtkPlaneSource (2), vtkQuad (2), vtkSphereSource (2), vtkLinearExtrusionFilter (1), vtkTextSource (1), vtkWedge (1)
qualify
  • vtkAbstractPropPicker (1), vtkImageReader (1), vtkVolume16Reader (1)
quality
  • vtkJPEGWriter (3), vtkDecimatePro (1), vtkLightKit (1), vtkTextSource (1), vtkTexture (1)
quantity
  • vtkLODProp3D (1)
quantization
  • vtkQuantizePolyDataPoints (4)
quantize (quantized, quantizes)
  • vtkQuantizePolyDataPoints (3), vtkImageToPolyDataFilter (6)
quartz
  • vtkQuartzRenderWindowInteractor (6), vtkQuartzImageMapper (2)
quaternion
  • vtkMath (3), vtkLandmarkTransform (1)
queries
  • vtkLocator (1), vtkPolyData (1)
query (queried, querying)
  • vtkInteractorStyleUser (3), vtkAbstractPropPicker (1), vtkImageReader2Factory (1), vtkLight (1), vtkXRenderWindowInteractor (1)
question
  • vtkSpherePuzzle (1)
queue
  • vtkPriorityQueue (17), vtkDecimatePro (5)
quick (quickly)
  • vtkCellLocator (2), vtkPointLocator (2), vtkPointLocator2D (2), vtkCell (1), vtkContourFilter (1), vtkContourGrid (1), vtkImageReader2 (1), vtkKitwareContourFilter (1), vtkLightKit (1), vtkLocator (1), [...]
quicksort
  • vtkProcessObject (1)
quiet
  • vtkSetGet (1)
Generated on Mon Mar 25 01:37:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (r..s)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

r
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
r-axis
  • vtkTransformTextureCoords (1)
r-g-b-a-r-g-b-a
  • vtkLookupTable (1)
radial
  • vtkButtonSource (4), vtkWarpLens (4), vtkThinPlateSplineTransform (3), vtkDiskSource (1)
radians
  • vtkDEMReader (2), vtkMath (1)
radiating
  • vtkDecimate (1)
radii
  • vtkHyperStreamline (1)
radius
  • vtkTubeFilter (16), vtkCellLocator (9), vtkHyperStreamline (7), vtkConeSource (4), vtkDiskSource (4), vtkArcPlotter (3), vtkArrowSource (3), vtkEarthSource (3), vtkGaussianSplatter (3), vtkImageGaussianSmooth (3), [...]
rainbow
  • vtkLookupTable (1)
ramp
  • vtkLookupTable (6), vtkWindowLevelLookupTable (6), vtkFrustumCoverageCuller (1), vtkImageToPolyDataFilter (1)
random (randomly)
  • vtkMath (6), vtkBrownianPoints (2), vtkCGMWriter (2), vtkCellTypes (2), vtkLODActor (2), vtkMaskPoints (2), vtkPieceScalars (2), vtkPointSource (2), vtkPolyData (2), vtkCellArray (1), [...]
randomization
  • vtkMaskPoints (2)
range (ranges, ranging)
  • vtkLookupTable (16), vtkFieldDataToAttributeDataFilter (15), vtkBandedPolyDataContourFilter (13), vtkDataObjectToDataSetFilter (11), vtkDataArray (10), vtkAxisActor2D (9), vtkSimpleScalarTree (9), vtkXYPlotActor (8), vtkCubeAxesActor2D (7), vtkImplicitWindowFunction (7), [...]
rank
  • vtkMPIController (1)
rapid (rapidly)
  • vtkInteractorStyleUser (1), vtkMapper (1), vtkOrderedTriangulator (1), vtkPropPicker (1), vtkScalarTree (1)
rare
  • vtkCell (1)
rasmus
  • vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1)
raster
  • vtkCGMWriter (1), vtkImageToPolyDataFilter (1), vtkTextSource (1)
rate (rates)
  • vtkRenderWindowInteractor (5), vtkExtractGrid (4), vtkGraphLayoutFilter (4), vtkExtractVOI (3), vtkLODProp3D (3), vtkRenderWindow (3), vtkLODActor (2), vtkVideoSource (2), vtkCompositeManager (1), vtkImageDivergence (1), [...]
ratio (ratios)
  • vtkLightKit (10), vtkDecimatePro (3), vtkOBBTree (3), vtkButtonSource (2), vtkDecimate (2), vtkProjectedTexture (2), vtkViewport (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkEarthSource (1), [...]
ray-casting
  • vtkPolygon (1)
rays
  • vtkCamera (4), vtkVolumeRayCastMapper (2), vtkProjectedTexture (1)
re-build
  • vtkWindowLevelLookupTable (2)
re-calulated
  • vtkCamera (1)
re-check
  • vtkObjectFactory (1)
re-defines
  • vtkXRenderWindowInteractor (1)
re-executes
  • vtkSource (1)
re-loading
  • vtkObjectFactory (1)
re-order
  • vtkCuller (1)
re-record
  • vtkVideoSource (1)
re-renders (re-rendering)
  • vtkInteractorStyleUser (1), vtkRenderer (1)
re-sampled
  • vtkSweptSurface (1)
re-triangulation
  • vtkDecimate (1)
re-used
  • vtkInteractorStyleUnicam (1)
read-only
  • vtkCell (1)
readable
  • vtkDataObjectReader (1), vtkDataObjectWriter (1), vtkDataSetReader (1), vtkOverrideInformation (1), vtkPolyDataReader (1), vtkPolyDataWriter (1), vtkRectilinearGridReader (1), vtkRectilinearGridWriter (1), vtkSTLReader (1), vtkSTLWriter (1), [...]
reader (readers)
  • vtkImageReader2Factory (12), vtkPLOT3DReader (4), vtkEnSight6BinaryReader (3), vtkEnSight6Reader (3), vtkEnSightGoldBinaryReader (3), vtkEnSightGoldReader (3), vtkImageReader2 (3), vtkDataObjectReader (2), vtkEnSightReader (2), vtkImageReader (2), [...]
reads (reading)
  • vtkDataReader (8), vtkVolume16Reader (5), vtkBYUReader (4), vtkImageReader2 (4), vtkMCubesReader (4), vtkPNMReader (4), vtkBMPReader (3), vtkByteSwap (3), vtkDEMReader (3), vtkGESignaReader (3), [...]
ready
  • vtkDataObject (1), vtkImageData (1), vtkMergeDataObjectFilter (1)
real (REAL)
  • vtkMath (19), vtkImageMandelbrotSource (3), vtkImageRFFT (3), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkEnSightGoldBinaryReader (2), vtkEnSightGoldReader (2), vtkImageFFT (2), vtkDataObject (1), vtkImplicitFunction (1), [...]
real-world
  • vtkPerlinNoise (1)
realizable
  • vtkDecimate (1)
realize (realized)
  • vtkQuartzRenderWindow (2), vtkRenderWindow (2), vtkViewport (2), vtkWin32OpenGLRenderWindow (2), vtkWinCEOpenGLRenderWindow (2), vtkXMesaRenderWindow (2), vtkXOpenGLRenderWindow (2), vtkDecimatePro (1), vtkWindow (1), vtkXImageWindow (1)
realloc
  • vtkPolyData (1)
reallocate (reallocated, reallocates)
  • vtkFloatArray (2), vtkBitArray (1), vtkCharArray (1), vtkDataArray (1), vtkDoubleArray (1), vtkHull (1), vtkIdTypeArray (1), vtkImageData (1), vtkIntArray (1), vtkLongArray (1), [...]
rearrange (rearranges)
  • vtkDepthSortPolyData (1), vtkProcessObject (1)
reason
  • vtkAbstractPropPicker (1), vtkAssemblyNode (1), vtkCriticalSection (1), vtkImageCityBlockDistance (1), vtkInteractorStyleTrackball (1), vtkInterpolatedVelocityField (1), vtkRectilinearGridOutlineFilter (1), vtkSimpleImageToImageFilter (1), vtkTkImageViewerWidget (1), vtkTkImageWindowWidget (1), [...]
reasonable
  • vtkSurfaceReconstructionFilter (2), vtkAxisActor2D (1), vtkPostScriptWriter (1), vtkRenderWindow (1)
reasonably
  • vtkImageReslice (1)
rebuild (rebuilding)
  • vtkVolume (3), vtkDebugLeaks (1), vtkLocator (1), vtkLookupTable (1), vtkProp (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1), vtkVolumeProperty (1)
recall
  • vtkPropCollection (1)
receiving (received)
  • vtkInteractorStyleUser (2), vtkSharedMemoryCommunicator (2), vtkCommunicator (1), vtkEncodedGradientShader (1), vtkGaussianSplatter (1), vtkMultiProcessController (1), vtkShepardMethod (1), vtkSocketCommunicator (1)
recent
  • vtkVideoSource (2), vtkInteractorStyleUser (1), vtkTexture (1)
recipes
  • vtkMath (6), vtkRungeKutta45 (1)
reclaim (reclaimed, reclaims)
  • vtkCellArray (2), vtkCellLinks (1), vtkCellTypes (1), vtkCharArray (1), vtkDataSet (1), vtkDoubleArray (1), vtkFieldData (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), [...]
recoding
  • vtkVideoSource (1)
recognition
  • vtkImageEuclideanDistance (1)
recognizes
  • vtkTextMapper (1)
recommend
  • vtkEarthSource (1)
recommended
  • vtkKochanekSpline (1), vtkLightKit (1)
recompile
  • vtkProgrammableDataObjectSource (1), vtkProgrammableSource (1)
recompute (recomputed, recomputing)
  • vtkCamera (3), vtkActor (1), vtkEncodedGradientEstimator (1), vtkFiniteDifferenceGradientEstimator (1), vtkLegendBoxActor (1), vtkObject (1), vtkProcrustesAlignmentFilter (1), vtkVolumeProperty (1)
reconstructs (reconstruction)
  • vtkLoopSubdivisionFilter (1), vtkScalarTree (1), vtkSimpleScalarTree (1), vtkSurfaceReconstructionFilter (1)
record (recorded, recording, records)
  • vtkVideoSource (12), vtkMILVideoSource (3), vtkTimeStamp (3), vtkTimerLog (3), vtkWin32VideoSource (3), vtkMCubesWriter (2), vtkVoxelModeller (2), vtkAbstractTransform (1), vtkDEMReader (1), vtkEnSightReader (1), [...]
recover
  • vtkCellLinks (1), vtkDelaunay2D (1), vtkPolyData (1)
rectangle
  • vtkLegendBoxActor (2), vtkScaledTextActor (2), vtkXTextMapper (2), vtkXYPlotActor (2), vtkArrowSource (1), vtkGlyphSource2D (1), vtkImageMapper (1), vtkParallelCoordinatesActor (1), vtkQuartzTextMapper (1), vtkTextMapper (1), [...]
rectangular
  • vtkSelectVisiblePoints (3), vtkHexahedron (2), vtkImplicitModeller (2), vtkScalarBarActor (2), vtkStructuredData (2), vtkSuperquadric (2), vtkSuperquadricSource (2), vtkButtonSource (1), vtkCaptionActor2D (1), vtkExtractGrid (1), [...]
rectilinear
  • vtkRectilinearGrid (3), vtkRectilinearGridGeometryFilter (3), vtkRectilinearGridReader (2), vtkRectilinearGridSource (2), vtkRectilinearGridWriter (2), vtkRectilinearGridOutlineFilter (1), vtkRectilinearGridToPolyDataFilter (1), vtkDataReader (1), vtkDataWriter (1)
recursion
  • vtkRecursiveSphereDirectionEncoder (4), vtkOBBTree (2), vtkPolyDataNormals (1), vtkRecursiveDividingCubes (1)
recursive (recursively)
  • vtkRecursiveDividingCubes (4), vtkRecursiveSphereDirectionEncoder (4), vtkAssembly (3), vtkPropAssembly (3), vtkHull (2), vtkPolygon (2), vtkActor (1), vtkDecimatePro (1), vtkExtentTranslator (1), vtkOBBTree (1), [...]
red-blue
  • vtkInteractorStyle (1)
red-green-blue
  • vtkImageToPolyDataFilter (1)
red-green-blue-alpha
  • vtkLookupTable (1), vtkWindowLevelLookupTable (1)
redirect (redirection)
  • vtkOutputWindow (2), vtkQuartzRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1)
reds
  • vtkLightKit (1)
reduce (reduced, reduces, reducing)
  • vtkDecimatePro (3), vtkLightKit (3), vtkCutter (2), vtkDecimate (2), vtkMarchingSquares (2), vtkQuadricClustering (2), vtkQuadricDecimation (2), vtkSmoothPolyDataFilter (2), vtkStreamer (2), vtkWindowedSincPolyDataFilter (2), [...]
reduction
  • vtkDecimatePro (15), vtkDecimate (4), vtkCompositeManager (2)
redundancies
  • vtkOpenGLStateCache (1)
reexecute
  • vtkProgrammableAttributeDataFilter (1), vtkProgrammableFilter (1)
reference (references, referencing)
  • vtkObject (11), vtkPolyData (8), vtkContainer (6), vtkCellLinks (5), vtkAbstractPropPicker (4), vtkAssemblyNode (4), vtkDEMReader (4), vtkCommand (3), vtkOutputWindow (3), vtkSetGet (3), [...]
referring
  • vtkCellArray (1)
refers
  • vtkAssemblyNode (2), vtkCell (2), vtkBandedPolyDataContourFilter (1), vtkCell3D (1), vtkDataObjectToDataSetFilter (1), vtkSelectVisiblePoints (1)
refine
  • vtkCleanPolyData (1)
reflect (reflected, reflections, reflects)
  • vtkReflectionFilter (2), vtkMatrixToHomogeneousTransform (2), vtkMatrixToLinearTransform (2), vtkAppendFilter (1), vtkCellType (1), vtkExplicitCell (1), vtkGeneralTransform (1), vtkImageFlip (1), vtkInitialValueProblemSolver (1), vtkLightKit (1), [...]
reformatting
  • vtkImageActor (1), vtkImageMapper (1), vtkOutputWindow (1)
refuse
  • vtkVideoSource (1)
regardless
  • vtkLODProp3D (2), vtkBMPWriter (1), vtkImplicitModeller (1), vtkMapper (1), vtkPNMWriter (1), vtkPolyDataMapper2D (1)
regards (regarding)
  • vtkAssemblyPath (2), vtkDecimate (1), vtkLightKit (1)
regenerate
  • vtkLookupTable (1), vtkWeightedTransformFilter (1)
region (regions)
  • vtkConnectivityFilter (21), vtkPolyDataConnectivityFilter (21), vtkBooleanTexture (19), vtkButtonSource (14), vtkVolumeMapper (7), vtkImageToPolyDataFilter (6), vtkSelectPolyData (6), vtkImageInPlaceFilter (4), vtkImplicitModeller (3), vtkPlanes (3), [...]
register (registered)
  • vtkObjectFactory (14), vtkInstantiator (9), vtkImageReader2Factory (3), vtkXMLParser (3), vtkMultiProcessController (2), vtkMesaRenderWindow (1), vtkOpenGLRenderWindow (1), vtkQuartzRenderWindow (1), vtkVolumeProperty (1)
registration
  • vtkInstantiator (2), vtkDataObject (1), vtkPointSet (1)
regression
  • vtkRegressionTestImage (1), vtkCellType (1), vtkImageDifference (1), vtkRTAnalyticSource (1)
regular (regularly)
  • vtkStructuredData (5), vtkStructuredGrid (3), vtkImageData (2), vtkPiecewiseFunction (2), vtkRectilinearGrid (2), vtkColorTransferFunction (1), vtkDEMReader (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageReader2 (1), [...]
reingold
  • vtkGraphLayoutFilter (1)
reinitialize (reinitialized)
  • vtkDataArray (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
reinsertion (reinserted, reinserting)
  • vtkDecimatePro (1), vtkEdgeTable (1), vtkPriorityQueue (1)
relabeled
  • vtkImagePermute (1)
relation (related)
  • vtkActor (2), vtkAbstractPicker (1), vtkButtonSource (1), vtkImageActor (1), vtkImageMapper (1), vtkOrderedTriangulator (1), vtkProp3D (1), vtkSimpleScalarTree (1), vtkVolume (1)
relationship
  • vtkLightKit (1)
relative (relatively)
  • vtkCoordinate (4), vtkCaptionActor2D (3), vtkOBBTree (3), vtkActor2D (2), vtkImplicitModeller (2), vtkInteractorStyleUnicam (2), vtkVideoSource (2), vtkXYPlotActor (2), vtkAbstractPicker (1), vtkArcPlotter (1), [...]
relavent
  • vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1)
relax
  • vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
relaxation
  • vtkSmoothPolyDataFilter (5)
release (released, releases, releasing)
  • vtkDataObject (8), vtkInteractorStyleUser (7), vtkFieldData (3), vtkPolyData (3), vtkAbstractMapper (2), vtkActor (2), vtkActor2D (2), vtkAssembly (2), vtkAxisActor2D (2), vtkCaptionActor2D (2), [...]
relies
  • vtkJPEGWriter (1)
reload (reloading)
  • vtkMesaRenderer (1), vtkOpenGLRenderer (1), vtkRendererSource (1)
rely
  • vtkObject (1)
remain (remaining, remains)
  • vtkCubeAxesActor2D (2), vtkDecimatePro (2), vtkImageMandelbrotSource (2), vtkImageMagnify (1), vtkLinkEdgels (1), vtkMPICommunicator (1), vtkMesaVolumeRayCastMapper (1), vtkOpenGLVolumeRayCastMapper (1), vtkRuledSurfaceFilter (1)
remap
  • vtkQuartzRenderWindow (1), vtkRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1)
remaps
  • vtkMapper (1)
remember
  • vtkImplicitSelectionLoop (1), vtkProgrammableAttributeDataFilter (1)
remote (remotely)
  • vtkMultiProcessController (2), vtkOutputPort (1), vtkSocketController (1)
removal
  • vtkImageIslandRemoval2D (1)
removes (removed, removing)
  • vtkImageIslandRemoval2D (3), vtkPriorityQueue (3), vtkCollection (2), vtkMPIGroup (2), vtkPiecewiseFunction (2), vtkActor2DCollection (1), vtkCellLinks (1), vtkColorTransferFunction (1), vtkContainer (1), vtkDataObject (1), [...]
renamed
  • vtkStructuredPointsGeometryFilter (1)
render (RENDERING, rendered, rendering, renders)
  • vtkRenderWindow (32), vtkRenderer (20), vtkQuartzRenderWindow (11), vtkXMesaRenderWindow (11), vtkXOpenGLRenderWindow (11), vtkWin32OpenGLRenderWindow (9), vtkRenderWindowInteractor (7), vtkXRenderWindowInteractor (7), vtkXRenderWindowTclInteractor (7), vtkWinCEOpenGLRenderWindow (6), [...]
renderer (renderered, renderering, renderers)
  • vtkRenderer (27), vtkRendererSource (9), vtkRendererCollection (5), vtkMesaRenderer (1), vtkOpenGLRenderer (1), vtkRenderWindow (11), vtkImporter (7), vtkAbstractPicker (5), vtkInteractorStyle (4), vtkSelectVisiblePoints (4), [...]
renderings
  • vtkImageDifference (1), vtkTextSource (1)
renderman
  • vtkRIBExporter (7)
rensselaer
  • vtkVRML (1), vtkVRMLImporter (1)
reorder (reorders)
  • vtkImagePermute (1), vtkPolyDataNormals (1), vtkPriorityQueue (1)
repeat (repeated, repeating, repeats)
  • vtkProperty (2), vtkProperty2D (2), vtkRuledSurfaceFilter (2), vtkSmoothPolyDataFilter (2), vtkAssembly (1), vtkCamera (1), vtkCellArray (1), vtkImageMandelbrotSource (1), vtkMCubesReader (1), vtkPerlinNoise (1), [...]
repeatability
  • vtkMath (1)
repeatedly
  • vtkCellLocator (1)
repetition
  • vtkTexture (1)
replace (replaced, replaces, replacing)
  • vtkImageThreshold (4), vtkPolyData (4), vtkXMLParser (4), vtkDecimate (3), vtkImageMask (3), vtkRenderWindow (2), vtkXMLFileOutputWindow (2), vtkAttributeDataToFieldDataFilter (1), vtkCellArray (1), vtkCollection (1), [...]
replacement
  • vtkHeap (4), vtkVolumeReader (1)
replication (replicated)
  • vtkImageMagnify (2), vtkCompositeManager (1), vtkImageResample (1), vtkImageSeparableConvolution (1)
report (reported)
  • vtkXMLParser (5), vtkWindowedSincPolyDataFilter (2), vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkDebugLeaks (1), vtkPCAAnalysisFilter (1)
reposition (repositioning)
  • vtkRenderer (3), vtkCone (1), vtkCylinder (1), vtkGraphLayoutFilter (1), vtkRenderWindowInteractor (1), vtkSuperquadric (1)
repositories
  • vtkDataObject (1)
represent (represented, representing, represents)
  • vtkTransform (6), vtkCellArray (5), vtkHull (5), vtkPoints (5), vtkPolyData (5), vtkCellLinks (4), vtkDataArray (4), vtkDataObject (4), vtkFieldData (4), vtkAssemblyPaths (3), [...]
representation (representations)
  • vtkSpatialRepresentationFilter (4), vtkLocator (4), vtkProperty (4), vtkSweptSurface (4), vtkCursor3D (3), vtkByteSwap (2), vtkDataObject (2), vtkExplicitCell (2), vtkInteractorStyle (2), vtkOBBTree (2), [...]
representational
  • vtkCell (1), vtkExplicitCell (1)
representative
  • vtkQuadricClustering (3), vtkAxisActor2D (1), vtkDataSet (1)
reproduce (reproduced)
  • vtkTreeComposite (2), vtkInteractorStyleUnicam (1)
reqquested
  • vtkPolyData (1)
request (requesting, requests)
  • vtkDataObject (3), vtkWin32VideoSource (3), vtkBranchExtentTranslator (2), vtkImageDataStreamer (2), vtkMILVideoSource (2), vtkMPICommunicator (2), vtkMPIController (2), vtkPCellDataToPointData (2), vtkPiecewiseFunction (2), vtkVideoSource (2), [...]
requester
  • vtkDataObject (2)
requirement (requirements)
  • vtkCharArray (1), vtkDecimate (1), vtkDoubleArray (1), vtkExplicitCell (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkJavaAwt (1), vtkLongArray (1), vtkNonLinearCell (1), [...]
requiring
  • vtkCastToConcrete (1), vtkDataObjectToDataSetFilter (1), vtkExplicitCell (1), vtkOBBTree (1)
rerun
  • vtkVolumeProVG500Mapper (2), vtkVolumeProVP1000Mapper (2)
resample (RESAMPLE, resampled, resamples, resampling)
  • vtkImageResample (2), vtkImageReslice (5), vtkRuledSurfaceFilter (5), vtkShepardMethod (2), vtkGaussianSplatter (1), vtkImageChangeInformation (1), vtkTexture (1)
rescription
  • vtkDataObject (1)
research
  • vtkInteractorStyleUnicam (1), vtkPLOT3DReader (1), vtkSurfaceReconstructionFilter (1)
reserved
  • vtkImageResample (2), vtkDEMReader (1), vtkImageStencilData (1), vtkPLY (1)
reset (resets, resetting)
  • vtkCellArray (3), vtkInteractorStyle (3), vtkRenderer (3), vtkFieldData (2), vtkBitArray (1), vtkCellLinks (1), vtkCharArray (1), vtkDataArray (1), vtkDoubleArray (1), vtkEdgeTable (1), [...]
resize
  • vtkCharArray (4), vtkDoubleArray (4), vtkIdTypeArray (4), vtkIntArray (4), vtkLongArray (4), vtkShortArray (4), vtkUnsignedCharArray (4), vtkUnsignedIntArray (4), vtkUnsignedLongArray (4), vtkUnsignedShortArray (4), [...]
reslices
  • vtkImageReslice (1)
resolution
  • vtkConeSource (7), vtkRuledSurfaceFilter (6), vtkButtonSource (4), vtkPlaneSource (4), vtkArrowSource (3), vtkRotationalExtrusionFilter (3), vtkSphereSource (3), vtkSuperquadricSource (3), vtkCGMWriter (2), vtkDEMReader (2), [...]
resolution-sided
  • vtkConeSource (1)
resolve (resolved, resolves)
  • vtkOrderedTriangulator (2), vtkMapper (1)
resort
  • vtkHeap (1)
resoultion
  • vtkArrowSource (1)
resource (resources)
  • vtkTexture (3), vtkAbstractMapper (2), vtkActor (2), vtkActor2D (2), vtkAssembly (2), vtkAxisActor2D (2), vtkCaptionActor2D (2), vtkCubeAxesActor2D (2), vtkDataSetMapper (2), vtkLODActor (2), [...]
respectively
  • vtkGridTransform (1), vtkImplicitTextureCoords (1), vtkLightKit (1), vtkMath (1), vtkPicker (1), vtkVectorNorm (1)
respond
  • vtkWriter (2), vtkObject (1), vtkProp (1)
respondibility
  • vtkLODProp3D (1)
response
  • vtkLight (1), vtkLocator (1), vtkTexture (1)
responsibility
  • vtkEdgeTable (2), vtkProgrammableFilter (2), vtkImageReader2Factory (1), vtkPlanes (1), vtkProgrammableSource (1), vtkRenderWindow (1), vtkTreeComposite (1), vtkWindow (1), vtkXImageWindow (1)
responsible
  • vtkMultiProcessController (2), vtkDataArray (1), vtkDataWriter (1), vtkDelaunay3D (1), vtkExtentTranslator (1), vtkLODActor (1), vtkLight (1), vtkMesaVolumeRayCastMapper (1), vtkOpenGLVolumeRayCastMapper (1), vtkPDataSetWriter (1), [...]
rest
  • vtkEnSight6BinaryReader (1), vtkEnSight6Reader (1), vtkEnSightGoldBinaryReader (1), vtkEnSightGoldReader (1), vtkPythonUtil (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
restore (restored)
  • vtkLODProp3D (2), vtkDataObject (1), vtkDataSet (1), vtkPolyData (1), vtkProp (1), vtkProp3D (1), vtkRectilinearGrid (1)
restrained
  • vtkCursor3D (1)
restricted (restrictions)
  • vtkImageDilateErode3D (1), vtkTexture (1), vtkVoxelContoursToSurfaceFilter (1)
restrip
  • vtkPolyDataNormals (1)
resultant
  • vtkMath (1)
retain (retained, retaining)
  • vtkDataObjectSource (1), vtkDataSetToDataObjectFilter (1), vtkDividingCubes (1), vtkImageCacheFilter (1), vtkProcessObject (1), vtkRecursiveDividingCubes (1), vtkSource (1), vtkSweptSurface (1)
retaliation
  • vtkCompositeManager (1)
retriangulate
  • vtkDecimatePro (1)
retrieval
  • vtkBitArray (1), vtkCharArray (1), vtkContourValues (1), vtkDoubleArray (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkImplicitBoolean (1), vtkImplicitSum (1), vtkImplicitWindowFunction (1), vtkIntArray (1), [...]
retrieve (retrieved, retrieves, retrieving)
  • vtkPCAAnalysisFilter (4), vtkProcrustesAlignmentFilter (3), vtkInteractorStyleUser (2), vtkAbstractMapper (1), vtkCellArray (1), vtkDataObject (1), vtkDataObjectToDataSetFilter (1), vtkDataWriter (1), vtkEdgeTable (1), vtkExtractVectorComponents (1), [...]
retuned
  • vtkFunctionParser (1)
reuse
  • vtkCellArray (1)
reused
  • vtkDataObject (1), vtkImageData (1)
reversal
  • vtkReverseSense (2)
reverse (reversed, reverses, reversing)
  • vtkReverseSense (7), vtkInteractorStyleFlight (3), vtkImageRFFT (2), vtkCell (1), vtkCell3D (1), vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkImageAccumulate (1), vtkImageMask (1), [...]
reverves
  • vtkPolyDataNormals (1)
rewind
  • vtkVideoSource (2)
reynold (Reynolds)
  • vtkPLOT3DReader (2)
rgba (RGBA)
  • vtkLookupTable (5), vtkScalarsToColors (5), vtkImageMapToColors (2), vtkVolumeMapper (2), vtkWindowLevelLookupTable (2), vtkCGMWriter (1), vtkColorTransferFunction (1), vtkImageBlend (1), vtkMapper (1), vtkPLYWriter (1), [...]
rheingans
  • vtkTriangularTCoords (1), vtkTriangularTexture (1)
ribbon (ribbons)
  • vtkRibbonFilter (9), vtkRuledSurfaceFilter (1), vtkTubeFilter (1)
richard
  • vtkMatrix4x4 (1)
ride
  • vtkMultiProcessController (2)
ridiculous
  • vtkTexture (1)
right-edge
  • vtkInteractorStyleUnicam (1)
right-hand-rule
  • vtkDelaunay2D (1)
rights
  • vtkPLY (1), vtkTreeComposite (1)
rigid
  • vtkDelaunay2D (2), vtkIterativeClosestPointTransform (2), vtkProcrustesAlignmentFilter (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
rigid-body
  • vtkProcrustesAlignmentFilter (1)
rigidbody
  • vtkLandmarkTransform (1)
ring (ringing, rings)
  • vtkCriticalSection (1), vtkImageIdealHighPass (1), vtkImageIdealLowPass (1), vtkSuperquadric (1), vtkSuperquadricSource (1), vtkTriangularTexture (1)
rmis
  • vtkCompositeManager (1)
robust
  • vtkOrderedTriangulator (1), vtkWarpTransform (1)
roll
  • vtkCamera (1), vtkInteractorStyleFlight (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
room
  • vtkLookupTable (1)
root (roots)
  • vtkMath (24), vtkAssembly (3), vtkOBBTree (2), vtkCellLocator (1), vtkIterativeClosestPointTransform (1), vtkLocator (1), vtkPriorityQueue (1), vtkRegressionTestImage (1), vtkSpatialRepresentationFilter (1), vtkTestUtilities (1)
rotate (ROTATE, rotated, rotates, rotating, rotation, rotations)
  • vtkProp3D (19), vtkInteractorStyleUnicam (12), vtkTransform (8), vtkCamera (5), vtkInteractorStyle (5), vtkPerspectiveTransform (5), vtkTransformTextureCoords (5), vtkStreamer (4), vtkGeneralTransform (3), vtkImageReslice (3), [...]
rotational
  • vtkRotationalExtrusionFilter (1)
round (rounded, rounding, roundness, rounds)
  • vtkSuperquadric (5), vtkSuperquadricSource (4), vtkButtonSource (1), vtkInteractorStyleFlight (1), vtkMath (1), vtkVolumeRayCastMapper (1)
round-off
  • vtkSelectVisiblePoints (1)
route (routes, routing)
  • vtkQuartzRenderWindowInteractor (3), vtkWin32RenderWindowInteractor (3), vtkRenderWindowInteractor (2), vtkVRMLImporter (2), vtkInteractorStyle (1)
routine (routines)
  • vtkInteractorStyleFlight (3), vtkPLY (3), vtkInteractorStyle (2), vtkWin32ImageMapper (2), vtkAbstractList (1), vtkActor2DCollection (1), vtkActorCollection (1), vtkCellArray (1), vtkCellLocator (1), vtkImageCanvasSource2D (1), [...]
rows
  • vtkXYPlotActor (5), vtkParallelCoordinatesActor (3), vtkDEMReader (1), vtkImageReader (1), vtkMath (1), vtkVolume16Reader (1)
ruin
  • vtkMath (1)
rule (rules)
  • vtkDataSetAttributes (23), vtkMaskFields (8), vtkFieldData (6), vtkProp3D (3), vtkDelaunay2D (1), vtkImageSkeleton2D (1), vtkRIBExporter (1)
ruled
  • vtkRuledSurfaceFilter (5)
ruler
  • vtkCamera (1)
run-length
  • vtkSLCReader (1)
run-time
  • vtkPointSetToPointSetFilter (3), vtkCastToConcrete (1)
runge
  • vtkStreamer (1)
runs (running)
  • vtkDataSetAttributes (1), vtkGlyphSource2D (1), vtkImageCityBlockDistance (1), vtkInputPort (1), vtkMCubesReader (1), vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkOutputPort (1), vtkPoints (1), vtkPolyDataConnectivityFilter (1), [...]
runtime
  • vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)

s
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
s-axis
  • vtkTransformTextureCoords (3), vtkPolygon (1)
s-coordinate
  • vtkTextureMapToCylinder (5), vtkTextureMapToSphere (4), vtkProjectedTexture (1), vtkTextureMapToPlane (1)
s-curve
  • vtkLookupTable (4)
s-texture
  • vtkTextureMapToCylinder (1), vtkTextureMapToSphere (1)
saada
  • vtkPointLoad (1)
sacrifices
  • vtkWindowedSincPolyDataFilter (1)
safe (SAFE, safely)
  • vtkDataSet (32), vtkPointLocator (14), vtkExtentTranslator (2), vtkMath (2), vtkMultiProcessLog (2), vtkObject (2), vtkUnstructuredGrid (2), vtkBitArray (1), vtkCell (1), vtkCharArray (1), [...]
safer
  • vtkCell (1)
safest
  • vtkAbstractPropPicker (1)
safety
  • vtkThreadedController (1)
saito
  • vtkImageEuclideanDistance (4)
saito-cached
  • vtkImageEuclideanDistance (1)
sample (sampled, samples, sampling)
  • vtkSampleFunction (7), vtkShepardMethod (8), vtkVolumeRayCastMapper (8), vtkGaussianSplatter (7), vtkImplicitModeller (7), vtkFiniteDifferenceGradientEstimator (4), vtkVoxelModeller (4), vtkExtractGrid (3), vtkImageShrink3D (3), vtkSurfaceReconstructionFilter (3), [...]
satisfactory
  • vtkGeometryFilter (1)
satisfies (satisfied)
  • vtkThreshold (3), vtkCell3D (2), vtkThresholdTextureCoords (2), vtkCastToConcrete (1), vtkCell (1), vtkDataObject (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkThresholdPoints (1), vtkVolumeTextureMapper2D (1)
satisfy (satisfying)
  • vtkThreshold (3), vtkThresholdTextureCoords (2), vtkBitArray (1), vtkCell3D (1), vtkCellLocator (1), vtkDelaunay2D (1), vtkImageCacheFilter (1), vtkImageDataStreamer (1), vtkLinkEdgels (1), vtkMemoryLimitImageDataStreamer (1), [...]
saturation (saturated)
  • vtkLookupTable (5), vtkImageHSVToRGB (2), vtkImageRGBToHSV (2), vtkLightKit (1), vtkMILVideoSource (1)
save (saves)
  • vtkImageBlockReader (2), vtkImageBlockWriter (2), vtkImageStencilData (2), vtkThreadSafeLog (2), vtkBitArray (1), vtkCellLocator (1), vtkCharArray (1), vtkDataArray (1), vtkDoubleArray (1), vtkFloatArray (1), [...]
saved
  • vtkVolumeTextureMapper2D (2), vtkCellLocator (1), vtkProp (1), vtkThreadSafeLog (1)
saving
  • vtkImageWindow (1), vtkRegressionTestImage (1), vtkVolumeRayCastFunction (1), vtkWindowToImageFilter (1)
scalar (SCALARS, scalars)
  • vtkScalarBarActor (20), vtkScalarTree (17), vtkSimpleScalarTree (14), vtkPieceScalars (7), vtkScalarsToColors (7), vtkWarpScalar (7), vtkMapper (23), vtkGlyph3D (19), vtkClipDataSet (15), vtkPolyDataMapper2D (15), [...]
scalar-based
  • vtkSimpleScalarTree (1)
scale (scaled, scales, scaling)
  • vtkImageShiftScale (5), vtkScaledTextActor (5), vtkImageLogarithmicScale (1), vtkGlyph3D (33), vtkTensorGlyph (26), vtkProp3D (8), vtkHyperStreamline (7), vtkTransformTextureCoords (7), vtkCubeAxesActor2D (5), vtkGlyph2D (5), [...]
scalings
  • vtkPostScriptWriter (1)
scan (scanned, scanning)
  • vtkImageToPolyDataFilter (2), vtkImageSeedConnectivity (1), vtkSimpleScalarTree (1), vtkTextSource (1)
scanline
  • vtkImageData (1)
scatter
  • vtkImageAccumulate (1)
scene (scenes)
  • vtkLightKit (7), vtkExporter (3), vtkActor (2), vtkImageActor (2), vtkInteractorStyle (2), vtkInteractorStyleJoystickActor (2), vtkInteractorStyleJoystickCamera (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2), vtkLight (2), [...]
scheme
  • vtkButterflySubdivisionFilter (5), vtkLoopSubdivisionFilter (4), vtkContainer (2), vtkApproximatingSubdivisionFilter (1), vtkCompositeManager (1), vtkExtentTranslator (1), vtkInterpolatingSubdivisionFilter (1), vtkLinearSubdivisionFilter (1)
schroder
  • vtkButterflySubdivisionFilter (1)
scissor
  • vtkOpenGLStateCache (1)
screen (screens)
  • vtkWindow (7), vtkCamera (6), vtkViewport (6), vtkWin32OpenGLRenderWindow (5), vtkRenderWindow (4), vtkWinCEOpenGLRenderWindow (4), vtkXMesaRenderWindow (4), vtkXOpenGLRenderWindow (4), vtkQuartzRenderWindow (3), vtkImageMapper (2), [...]
script (scripting, scripts)
  • vtkVRMLImporter (2), vtkCellType (1), vtkImageFlip (1), vtkImageGaussianSmooth (1), vtkImageWindow (1), vtkInteractorStyleUser (1), vtkLODProp3D (1), vtkMPIEventLog (1), vtkMultiThreader (1)
scrren
  • vtkQuartzRenderWindow (1)
seames
  • vtkPolyDataStreamer (1)
seams
  • vtkAppendPolyData (1)
search (searched, searches, searching)
  • vtkSpatialRepresentationFilter (9), vtkPointLocator (4), vtkCellLocator (2), vtkDelaunay3D (2), vtkHyperStreamline (2), vtkImageConnector (2), vtkInterpolatedVelocityField (2), vtkLocator (2), vtkPointLocator2D (2), vtkStreamer (2), [...]
searchers
  • vtkSpatialRepresentationFilter (1)
seed (seeds)
  • vtkImageSeedConnectivity (8), vtkConnectivityFilter (5), vtkPolyDataConnectivityFilter (4), vtkMath (3), vtkImageConnector (2)
seeing
  • vtkRenderWindow (1)
seek
  • vtkVideoSource (2), vtkVolume16Reader (1)
seen
  • vtkCompositeManager (1), vtkLODActor (1), vtkLightKit (1), vtkPCAAnalysisFilter (1), vtkRenderer (1)
segment (segmented, segments)
  • vtkGlyphSource2D (3), vtkOBBTree (3), vtkRibbonFilter (3), vtkHyperStreamline (2), vtkPiecewiseFunction (2), vtkStreamLine (2), vtkDashedStreamLine (1), vtkImageOpenClose3D (1), vtkLineSource (1), vtkQuadraticEdge (1), [...]
segmentation
  • vtkConnectivityFilter (1), vtkVolume16Reader (1), vtkVolumeReader (1)
select (selected, selecting, selection)
  • vtkSelectPolyData (7), vtkSelectVisiblePoints (7), vtkImplicitSelectionLoop (6), vtkLODProp3D (14), vtkAbstractPicker (8), vtkPicker (8), vtkExtractUnstructuredGrid (7), vtkGeometryFilter (7), vtkExtractGrid (3), vtkExtractVOI (3), [...]
selectively
  • vtkMaskPoints (1)
self
  • vtkSetGet (4), vtkAbstractTransform (1), vtkDataObject (1), vtkPointSet (1), vtkShrinkFilter (1), vtkShrinkPolyData (1), vtkSocketController (1)
self-adjusting
  • vtkBitArray (1), vtkCharArray (1), vtkDoubleArray (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkLongArray (1), vtkShortArray (1), vtkUnsignedCharArray (1), vtkUnsignedIntArray (1), [...]
self-intersect (self-intersecting)
  • vtkSelectPolyData (2), vtkPolygon (1)
self-reference (self-referencing)
  • vtkAbstractPropPicker (1), vtkAbstractTransform (1), vtkAssemblyNode (1), vtkGeneralTransform (1), vtkPerspectiveTransform (1), vtkTransform (1)
sell
  • vtkPLY (1)
semantics
  • vtkGeneralTransform (6), vtkPerspectiveTransform (6), vtkTransform (6), vtkAbstractTransform (2)
semi-colon
  • vtkObjectFactory (1)
semi-cycle
  • vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
semi-infinite
  • vtkPointLoad (2)
semi-planar
  • vtkDecimatePro (1)
sense
  • vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1), vtkImplicitTextureCoords (1), vtkInteractorStyleUnicam (1), vtkIterativeClosestPointTransform (1), vtkLandmarkTransform (1), vtkLightKit (1), vtkMCubesReader (1), vtkProcrustesAlignmentFilter (1), [...]
sensitive
  • vtkInteractorStyle (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkInteractorStyleUnicam (1), vtkSmoothPolyDataFilter (1)
sent
  • vtkSharedMemoryCommunicator (2), vtkXMLParser (2), vtkBandedPolyDataContourFilter (1), vtkExtractUnstructuredGrid (1), vtkMapper (1), vtkPythonUtil (1), vtkRIBExporter (1)
separable
  • vtkImageSeparableConvolution (1)
separate (SEPARATE, separated, separately, separates, separation)
  • vtkStreamPoints (4), vtkDicer (3), vtkExtractVectorComponents (3), vtkParallelCoordinatesActor (3), vtkDecimatePro (2), vtkMergeFilter (2), vtkPLYWriter (2), vtkPiecewiseFunction (2), vtkPolyDataNormals (2), vtkProperty (2), [...]
separator
  • vtkTextMapper (1)
sequence (sequences)
  • vtkAbstractList (1), vtkAssembly (1), vtkCell (1), vtkCoordinate (1), vtkGlyphSource2D (1), vtkImageStencilData (1), vtkImplicitModeller (1), vtkPythonUtil (1), vtkSpline (1), vtkTriangularTexture (1), [...]
sequentially
  • vtkMultiProcessLog (1), vtkVideoSource (1)
series
  • vtkIdentityTransform (3), vtkLinearTransform (3), vtkAbstractTransform (2), vtkBandedPolyDataContourFilter (1), vtkButterflySubdivisionFilter (1), vtkCell (1), vtkContourFilter (1), vtkContourGrid (1), vtkDashedStreamLine (1), vtkDataSetToDataSetFilter (1), [...]
serries
  • vtkParticleReader (1)
serve (serves)
  • vtkRenderWindowInteractor (2), vtkAssembly (1), vtkCollection (1), vtkContourValues (1), vtkDataObject (1), vtkPointLoad (1), vtkPolyDataMapper (1), vtkStreamer (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
session
  • vtkVideoSource (1)
sets (setting)
  • vtkXYPlotActor (7), vtkGeneralTransform (5), vtkLandmarkTransform (5), vtkMapper (5), vtkPerspectiveTransform (5), vtkSetGet (5), vtkTransform (5), vtkDataObject (4), vtkDataObjectToDataSetFilter (4), vtkInterpolateDataSetAttributes (4), [...]
settings
  • vtkAxisActor2D (1), vtkMultiThreader (1), vtkRIBExporter (1), vtkRenderWindow (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1), vtkXYPlotActor (1)
setup
  • vtkCompositeManager (1), vtkDataObjectToDataSetFilter (1), vtkSimpleImageToImageFilter (1), vtkSpherePuzzle (1)
severe
  • vtkWindowedSincPolyDataFilter (1)
shader (shaders)
  • vtkRIBExporter (12), vtkRIBProperty (6), vtkEncodedGradientEstimator (2), vtkRIBLight (1), vtkVolumeRayCastMapper (1), vtkVolumeTextureMapper (1)
shading (shaded)
  • vtkEncodedGradientShader (13), vtkVolumeProperty (10), vtkProperty (5), vtkVolumeRayCastFunction (2), vtkVolumeRayCastStructures (2), vtkEncodedGradientEstimator (1), vtkImageToPolyDataFilter (1), vtkPolyDataNormals (1), vtkRIBExporter (1), vtkRender (1), [...]
shadow (shadows)
  • vtkCubeAxesActor2D (4), vtkLabeledDataMapper (4), vtkAxisActor2D (3), vtkParallelCoordinatesActor (3), vtkScalarBarActor (3), vtkTextMapper (3), vtkXYPlotActor (3), vtk3DS (2), vtkCaptionActor2D (2), vtkLegendBoxActor (2), [...]
shaft
  • vtkArrowSource (5)
shallow
  • vtkAbstractMapper (1), vtkActor (1), vtkActor2D (1), vtkAssembly (1), vtkAssemblyPath (1), vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkCubeAxesActor2D (1), vtkDataObject (1), vtkDataSet (1), [...]
shallower
  • vtkSimpleScalarTree (1)
shape (shaped, shapes)
  • vtkPCAAnalysisFilter (7), vtkMassProperties (4), vtkButtonSource (2), vtkDecimate (2), vtkGaussianSplatter (2), vtkKochanekSpline (2), vtkWeightedTransformFilter (2), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkEarthSource (1), [...]
share (shared, shares, sharing)
  • vtkSharedMemoryCommunicator (1), vtkConnectivityFilter (6), vtkPolyDataConnectivityFilter (5), vtkActor (3), vtkObjectFactory (3), vtkMultiProcessController (2), vtkPolyDataNormals (2), vtkCommunicator (1), vtkCriticalSection (1), vtkDataSet (1), [...]
sharp (sharply, sharpness)
  • vtkPolyDataNormals (5), vtkSmoothPolyDataFilter (2), vtkWindowedSincPolyDataFilter (2), vtkButtonSource (1), vtkDecimatePro (1), vtkFeatureEdges (1), vtkGaussianSplatter (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkImageButterworthHighPass (1), [...]
shear (sheared)
  • vtkCamera (5), vtkPerspectiveTransform (4)
shell
  • vtkXRenderWindowInteractor (7), vtkXRenderWindowTclInteractor (7), vtkLogLookupTable (1), vtkPointSource (1), vtkRenderWindowInteractor (1), vtkRotationalExtrusionFilter (1)
shepard
  • vtkShepardMethod (2)
shift (SHIFT, shifted, shifting, shifts)
  • vtkImageShiftScale (5), vtkInteractorStyleFlight (4), vtkTransformToGrid (4), vtkGridTransform (3), vtkImageFlip (3), vtkMapper (3), vtkImageDifference (2), vtkImageFourierCenter (2), vtkImageShrink3D (2), vtkInteractorStyleImage (2), [...]
shine (shines, shining)
  • vtkLightKit (4), vtkLight (3)
shooting
  • vtkCellPicker (2), vtkPointPicker (2), vtkPicker (1)
short
  • vtkShortArray (3), vtkUnsignedShortArray (3), vtkVolume (6), vtkGlyphSource2D (2), vtkDataSet (1), vtkGESignaReader (1), vtkImageImport (1), vtkOBBTree (1), vtkPNGWriter (1), vtkTexture (1), [...]
shortened
  • vtkCollection (1), vtkInterpolatedVelocityField (1)
shot
  • vtkRenderWindowInteractor (1)
shoudld
  • vtkOpenGLStateCache (1)
shoulder (shoulders)
  • vtkButtonSource (5)
show (showing, shows)
  • vtkScalarBarActor (2), vtkVectorDot (2), vtkAxisActor2D (1), vtkCubeAxesActor2D (1), vtkImageCheckerboard (1), vtkInstantiator (1), vtkLightKit (1), vtkPDataSetReader (1), vtkParallelCoordinatesActor (1), vtkProcessObject (1), [...]
shown
  • vtkImplicitModeller (2), vtkScalarBarActor (1)
shrink (shrinking, shrinks)
  • vtkShrinkPolyData (6), vtkShrinkFilter (5), vtkImageShrink3D (2), vtkImageSpatialFilter (2), vtkSmoothPolyDataFilter (1), vtkWindowedSincPolyDataFilter (1)
shrinkage
  • vtkSmoothPolyDataFilter (1)
shtml
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProMapper (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
shuffling
  • vtkMergeDataObjectFilter (1), vtkXYPlotActor (1)
shut
  • vtkAttributeDataToFieldDataFilter (1), vtkSetGet (1)
side (sides)
  • vtkTubeFilter (14), vtkHyperStreamline (5), vtkLightKit (5), vtkAxisActor2D (4), vtkRenderer (3), vtkButtonSource (2), vtkConeSource (2), vtkDataObject (2), vtkGaussianSplatter (2), vtkImageStencilData (2), [...]
sided
  • vtkButtonSource (2), vtkEncodedGradientShader (1), vtkRecursiveSphereDirectionEncoder (1)
sidestep
  • vtkInteractorStyleFlight (1)
siggraph
  • vtkDecimate (2), vtkDecimatePro (2), vtkLoopSubdivisionFilter (1), vtkOBBTree (1), vtkQuadricClustering (1), vtkTriangle (1)
sigma
  • vtkWindowedSincPolyDataFilter (2)
sign (signed)
  • vtkLargeInteger (2), vtkImageCityBlockDistance (1), vtkImplicitSelectionLoop (1), vtkSurfaceReconstructionFilter (1), vtkVoxelContoursToSurfaceFilter (1)
signa
  • vtkGESignaReader (2)
signal (signaled, signaling)
  • vtkInteractorStyleUnicam (1), vtkSharedMemoryCommunicator (1), vtkWindowedSincPolyDataFilter (1)
signature (signatures)
  • vtkRearrangeFields (4), vtkExtentTranslator (2)
significant (significantly)
  • vtkLightKit (2), vtkCamera (1), vtkImageEuclideanDistance (1), vtkImplicitModeller (1), vtkShepardMethod (1)
silently
  • vtkDataObject (1)
silicon
  • vtkVRML (1), vtkVRMLImporter (1)
similar (similarly)
  • vtkPolyData (3), vtkDataObject (2), vtkDataObjectToDataSetFilter (2), vtkActor2D (1), vtkDataObjectSource (1), vtkDecimatePro (1), vtkExporter (1), vtkImageReslice (1), vtkImageShiftScale (1), vtkImageWindow (1), [...]
similarity
  • vtkProcrustesAlignmentFilter (4), vtkIterativeClosestPointTransform (2), vtkLandmarkTransform (2), vtkPCAAnalysisFilter (1)
simple
  • vtkSimpleImageFilterExample (2), vtkSimpleImageToImageFilter (1), vtkLightKit (3), vtkSmoothPolyDataFilter (3), vtkWindowedSincPolyDataFilter (3), vtkImageIterator (2), vtkImageProgressIterator (2), vtkImageReslice (2), vtkLODActor (2), vtkTimerLog (2), [...]
simpler
  • vtkFieldData (1), vtkImageReader2 (1)
simplest
  • vtkSimpleImageToImageFilter (1)
simplex (simplexes)
  • vtkDelaunay2D (4), vtkDelaunay3D (4), vtkCell (1), vtkTetra (1), vtkTriangle (1)
simplices
  • vtkCell (1), vtkClipPolyData (1), vtkDataSetTriangleFilter (1), vtkTetra (1), vtkTriangle (1)
simplicity
  • vtkCellArray (1), vtkLightKit (1)
simplification
  • vtkLocator (1), vtkQuadricClustering (1), vtkSpatialRepresentationFilter (1), vtkTriangle (1)
simplifies
  • vtkInteractorStyleUnicam (1)
simplify (simplified, simplifying)
  • vtkPolyData (5), vtkPriorityQueue (1), vtkQuadricDecimation (1), vtkStructuredPoints (1)
simulate (simulated)
  • vtkGeneralTransform (1), vtkGraphLayoutFilter (1), vtkLightKit (1), vtkWindow (1)
simultaneously
  • vtkVolumeProperty (1)
sinc
  • vtkWindowedSincPolyDataFilter (8)
sine
  • vtkImageSinusoidSource (1)
single-component
  • vtkImageReslice (1)
single-precision
  • vtkAbstractTransform (2), vtkMatrix4x4 (1)
single-sided
  • vtkButtonSource (1)
singleton
  • vtkOutputWindow (3), vtkMPICommunicator (1)
singular
  • vtkMath (1)
singularities
  • vtkTensorGlyph (2), vtkHyperStreamline (1)
sinusoid
  • vtkImageSinusoidSource (3)
sinusoidal
  • vtkImageSinusoidSource (2)
site
  • vtkDEMReader (1)
situation (situations)
  • vtkAssignAttribute (1), vtkObject (1), vtkOrderedTriangulator (1), vtkRearrangeFields (1), vtkSplitField (1)
six-vector
  • vtkPlanes (1)
sixteen
  • vtkEarthSource (1)
sixth
  • vtkPNMReader (1)
size (sizes)
  • vtkAxisActor2D (10), vtkCellArray (7), vtkMath (7), vtkTextMapper (7), vtkCaptionActor2D (6), vtkImageMandelbrotSource (6), vtkSuperquadric (6), vtkSuperquadricSource (6), vtkVideoSource (6), vtkXTextMapper (6), [...]
size-and-shape
  • vtkProcrustesAlignmentFilter (1)
size-factor
  • vtkAxisActor2D (1)
sizeb
  • vtkPCAAnalysisFilter (1)
sized
  • vtkImageSpatialFilter (1), vtkSuperquadric (1), vtkSuperquadricSource (1)
sizeof
  • vtkHull (1)
skeleton
  • vtkImageSkeleton2D (1)
skewed
  • vtkLightKit (1)
skin (skinning)
  • vtkWeightedTransformFilter (10)
skinny
  • vtkOBBTree (1)
skip (skipped, skips)
  • vtkVolumeTextureMapper2D (2), vtkDecimatePro (1), vtkEnSightReader (1), vtkGenericEnSightReader (1), vtkImageReader2 (1), vtkImageSeparableConvolution (1), vtkMCubesReader (1), vtkVolume16Reader (1), vtkVolumeReader (1)
skirt
  • vtkLinearExtrusionFilter (4), vtkRotationalExtrusionFilter (4)
slab
  • vtkImplicitModeller (2), vtkExtentTranslator (1)
slack
  • vtkKochanekSpline (1)
slash
  • vtkTestUtilities (4)
sleep
  • vtkTimerLog (1)
slice (slices)
  • vtkImageReslice (6), vtkSliceCubes (4), vtkVolume16Reader (5), vtkEncodedGradientEstimator (4), vtkImageActor (4), vtkFrustumCoverageCuller (3), vtkImageMapper (3), vtkVolumeReader (3), vtkGESignaReader (2), vtkImageMarchingCubes (2), [...]
slice-size
  • vtkImageEuclideanDistance (1)
slice-through
  • vtkCutter (1)
slide
  • vtkProjectedTexture (1)
slightly
  • vtkImageDifference (1), vtkImageStencilSource (1), vtkLightKit (1), vtkOrderedTriangulator (1), vtkPolyDataStreamer (1), vtkRenderer (1)
slope (slopes)
  • vtkPiecewiseFunction (4)
slot
  • vtkPoints (2), vtkWeightedTransformFilter (2), vtkCellTypes (1), vtkEncodedGradientShader (1)
slow
  • vtkImageEuclideanDistance (1), vtkVolumeRayCastMapper (1)
slower
  • vtkMapper (2), vtkAbstractPicker (1), vtkAssembly (1), vtkCell (1), vtkCleanPolyData (1), vtkGaussianSplatter (1), vtkGraphLayoutFilter (1), vtkImageFFT (1), vtkImageRFFT (1), vtkImageReader (1), [...]
slowest
  • vtkVolumeMapper (1)
small
  • vtkDashedStreamLine (1), vtkDecimatePro (1), vtkElevationFilter (1), vtkFieldData (1), vtkHyperStreamline (1), vtkImageEuclideanDistance (1), vtkImageIslandRemoval2D (1), vtkImplicitModeller (1), vtkLODActor (1), vtkLocator (1), [...]
smaller
  • vtkStreamLine (3), vtkButtonSource (2), vtkImageDataStreamer (2), vtkImplicitModeller (2), vtkMemoryLimitImageDataStreamer (2), vtkSmoothPolyDataFilter (2), vtkVolumeRayCastMapper (2), vtkActor2DCollection (1), vtkAxisActor2D (1), vtkCamera (1), [...]
smallest
  • vtkSelectPolyData (2), vtkMPIGroup (1), vtkPlanes (1), vtkPriorityQueue (1), vtkQuadricClustering (1)
smax
  • vtkMapper (1), vtkPolyDataMapper2D (1)
smin
  • vtkMapper (1), vtkPolyDataMapper2D (1)
smooth (smoothed, smoothing, smoothly)
  • vtkSmoothPolyDataFilter (24), vtkWindowedSincPolyDataFilter (27), vtkImageToPolyDataFilter (7), vtkRenderWindow (3), vtkLoopSubdivisionFilter (2), vtkButtonSource (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), [...]
smoother
  • vtkStreamLine (2)
so-called
  • vtkOrderedTriangulator (1)
sobel
  • vtkImageSobel3D (3), vtkImageSobel2D (2)
sockets
  • vtkSocketController (8), vtkSocketCommunicator (2)
software (SOFTWARE)
  • vtkTreeComposite (9), vtkPLY (4), vtkAbstractMapper3D (2), vtkHeap (2), vtkAbstractMapper (1), vtkPolyDataMapper (1), vtkRungeKutta45 (1), vtkVolumeRayCastMapper (1)
solid (solids)
  • vtkLinearExtrusionFilter (1), vtkSTLReader (1), vtkSurfaceReconstructionFilter (1), vtkUGFacetReader (1), vtkVolumeRayCastStructures (1)
solution (solutions)
  • vtkMath (15), vtkPLOT3DReader (8), vtkIterativeClosestPointTransform (2), vtkImageIterateFilter (1), vtkLandmarkTransform (1)
solve (solves)
  • vtkMath (11), vtkSubPixelPositionEdgels (1)
solver (solvers)
  • vtkInitialValueProblemSolver (5), vtkRungeKutta45 (2)
sometimes
  • vtkCellTypes (1)
somewhat
  • vtkRuledSurfaceFilter (1), vtkWeightedTransformFilter (1)
soon
  • vtkExporter (1)
sort (sorted, sorting, sorts)
  • vtkDepthSortPolyData (15), vtkCutter (5), vtkCGMWriter (4), vtkActor2DCollection (3), vtkOrderedTriangulator (3), vtkMath (2), vtkOBBTree (2), vtkPCAAnalysisFilter (2), vtkPicker (2), vtkPointLocator (2), [...]
sounds
  • vtkRIBExporter (1)
source (sources)
  • vtkSource (9), vtkDataObjectSource (5), vtkProgrammableSource (5), vtkImageCanvasSource2D (4), vtkImageSource (4), vtkProgrammableDataObjectSource (3), vtkRendererSource (3), vtkImageEllipsoidSource (2), vtkStructuredPointsSource (2), vtkTextSource (2), [...]
south
  • vtkSuperquadric (1), vtkSuperquadricSource (1), vtkTextureMapToSphere (1)
space (spaced, spaces, spacing, spacings)
  • vtkImageReslice (11), vtkLight (9), vtkImageStencilData (7), vtkDataObjectToDataSetFilter (6), vtkImageMandelbrotSource (6), vtkImageResample (6), vtkFiniteDifferenceGradientEstimator (5), vtkImageAccumulate (5), vtkImageChangeInformation (5), vtkVolume16Reader (5), [...]
span (spanning)
  • vtkImageAccumulate (3), vtkImageIterator (3), vtkImageProgressIterator (1), vtkScalarTree (1), vtkSimpleScalarTree (1)
sparingly
  • vtkLightKit (1)
sparser
  • vtkGridTransform (1)
spatial (spatially)
  • vtkSpatialRepresentationFilter (10), vtkQuadricClustering (6), vtkCellLocator (3), vtkLocator (3), vtkImageIdealHighPass (2), vtkOBBDicer (2), vtkPointLocator (2), vtkPointLocator2D (2), vtkProbeFilter (2), vtkCleanPolyData (1), [...]
spawn (spawned)
  • vtkMultiThreader (2), vtkThreadedController (2), vtkImageToImageFilter (1), vtkMultiProcessController (1)
spec
  • vtkVRMLImporter (4), vtkLocator (1), vtkPLOT3DReader (1)
special (specially)
  • vtkDataSetAttributes (5), vtkDecimate (3), vtkKitwareContourFilter (3), vtkMarchingContourFilter (3), vtkPythonUtil (3), vtkDecimatePro (2), vtkLightKit (2), vtkMaskPoints (2), vtkNonLinearCell (2), vtkPolyData (2), [...]
specialization (specializations)
  • vtkGlyph2D (2), vtkProp3D (1)
specialized
  • vtkMapper (2), vtkAbstractTransform (1), vtkContourGrid (1), vtkDataArray (1), vtkExtractPolyDataGeometry (1), vtkGLUTesselatorTriangleFilter (1), vtkGridSynchronizedTemplates3D (1), vtkImageMarchingCubes (1), vtkImageReslice (1), vtkInteractorStyleImage (1), [...]
specifically
  • vtkCellPicker (1), vtkFollower (1), vtkMatrix4x4 (1), vtkPointPicker (1), vtkPolyData (1), vtkSubPixelPositionEdgels (1)
specification
  • vtkViewport (4), vtkLookupTable (3), vtkRenderer (3), vtkCGMWriter (1), vtkDataObjectToDataSetFilter (1), vtkDataReader (1), vtkImageDataGeometryFilter (1), vtkRectilinearGridGeometryFilter (1), vtkStructuredGridGeometryFilter (1), vtkWindowLevelLookupTable (1), [...]
specifics
  • vtkPipelineSize (1)
specifing
  • vtkQuadricClustering (1)
spectrum
  • vtkLightKit (1)
specular
  • vtkProperty (9), vtkEncodedGradientShader (8), vtkVolumeProperty (3), vtkVolumeProMapper (1)
speed (speeding, speeds)
  • vtkStreamer (8), vtkBrownianPoints (5), vtkInteractorStyleJoystickCamera (2), vtkCleanPolyData (1), vtkHyperStreamline (1), vtkImageStencilData (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1), vtkIterativeClosestPointTransform (1), [...]
spend
  • vtkRenderer (1)
sphere (spheres)
  • vtkSphereSource (11), vtkTextureMapToSphere (9), vtkSphere (7), vtkRecursiveSphereDirectionEncoder (5), vtkTexturedSphereSource (5), vtkPSphereSource (2), vtkSpherePuzzle (2), vtkSpherePuzzleArrows (1), vtkEarthSource (2), vtkFrustumCoverageCuller (2), [...]
spherical
  • vtkGaussianSplatter (2), vtkEarthSource (1), vtkSuperquadricSource (1)
spins (spinning)
  • vtkInteractorStyleImage (1), vtkInteractorStyleJoystickActor (1), vtkInteractorStyleJoystickCamera (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1)
splat (splats, splatted, splatting)
  • vtkGaussianSplatter (22)
spline (splines)
  • vtkSpline (16), vtkKochanekSpline (8), vtkCardinalSpline (3), vtkThinPlateSplineTransform (3), vtkCellType (1), vtkTransformToGrid (1)
split (splits, splitting)
  • vtkSplitField (6), vtkDecimatePro (24), vtkPolyDataNormals (5), vtkImageEuclideanDistance (3), vtkImageFFT (3), vtkImageRFFT (3), vtkOBBTree (3), vtkExtentTranslator (2), vtkAbstractTransform (1), vtkBranchExtentTranslator (1), [...]
spontaneously
  • vtkObject (1)
spot (spots)
  • vtkLight (1), vtkLightKit (1), vtkOpenGLStateCache (1)
spotlight
  • vtk3DS (4)
spread
  • vtkSurfaceReconstructionFilter (1)
springs
  • vtkRotationalExtrusionFilter (2)
sproc (SPROC)
  • vtkMultiThreader (3)
sqrt
  • vtkPCAAnalysisFilter (6), vtkTriangularTCoords (1), vtkTriangularTexture (1)
square (squared, squares)
  • vtkMarchingSquaresCases (1), vtkMath (11), vtkCell (3), vtkIterativeClosestPointTransform (3), vtkDecimatePro (2), vtkFrustumCoverageCuller (2), vtkDataSet (1), vtkEncodedGradientEstimator (1), vtkImageEuclideanDistance (1), vtkImageVariance3D (1), [...]
squeeze (Squeezes)
  • vtkFieldData (2), vtkCellArray (1)
squeezing (squeezed)
  • vtkHull (3)
stability
  • vtkSmoothPolyDataFilter (1)
stable
  • vtkSmoothPolyDataFilter (1), vtkVRMLExporter (1)
stack
  • vtkAbstractTransform (3), vtkGeneralTransform (3), vtkPerspectiveTransform (3), vtkTransform (3), vtkMatrix4x4 (2), vtkAssemblyPath (1), vtkImageConnector (1), vtkObject (1), vtkPolyDataNormals (1), vtkVoxelContoursToSurfaceFilter (1)
stagnation
  • vtkPLOT3DReader (1)
stale
  • vtkHomogeneousTransform (1)
stamp
  • vtkTimeStamp (1), vtkVolume (3), vtkVideoSource (1)
stand-alone
  • vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
standalone
  • vtkWin32ImageMapper (1)
standard
  • vtkSetGet (4), vtkMILVideoSource (3), vtkWin32VideoSource (3), vtkActor2DCollection (2), vtkAssemblyPath (2), vtkAssemblyPaths (2), vtkImageGaussianSmooth (2), vtkImagerCollection (2), vtkLODProp3D (2), vtkMath (2), [...]
standpoint
  • vtkOpenGLStateCache (1), vtkProperty (1)
stanford
  • vtkPLY (3), vtkPLYReader (3), vtkPLYWriter (3), vtkWindowedSincPolyDataFilter (1)
start-up
  • vtkProp (1)
started
  • vtkInteractorStyleUnicam (1)
startup
  • vtkMPIController (1)
state-change
  • vtkOpenGLStateCache (1)
statement (statements)
  • vtkSetGet (2), vtkImageData (1), vtkTreeComposite (1)
static
  • vtkDecimate (3), vtkDecimatePro (2), vtkEnSight6BinaryReader (2), vtkEnSight6Reader (2), vtkEnSightGoldBinaryReader (2), vtkEnSightGoldReader (2), vtkInstantiator (2), vtkObjectFactory (2), vtkThreadedController (2), vtkDataSetAttributes (1), [...]
stationary
  • vtkInteractorStyleFlight (2)
statistically
  • vtkMaskPoints (1)
statistics
  • vtkProcessStatistics (1), vtkImageAccumulate (3), vtkDecimate (1), vtkInterpolatedVelocityField (1), vtkTimerLog (1)
status
  • vtkRenderWindow (1), vtkRenderer (1)
stay
  • vtkCubeAxesActor2D (1), vtkPolyLine (1)
stderr
  • vtkOutputWindow (1)
stdout
  • vtkOutputWindow (1)
steaming
  • vtkImageMultipleInputFilter (1), vtkImageMultipleInputOutputFilter (1)
steers (steering)
  • vtkInteractorStyleFlight (6)
stencil
  • vtkImageStencilData (9), vtkImageStencil (6), vtkImageToImageStencil (3), vtkImplicitFunctionToImageStencil (3), vtkPolyDataToImageStencil (2), vtkImageAccumulate (2), vtkImageReslice (2), vtkImageBlend (1)
step (stepping, steps)
  • vtkHyperStreamline (5), vtkInteractorStyleFlight (5), vtkRayCastStructures (4), vtkVolumeRayCastFunction (4), vtkStreamer (3), vtkSweptSurface (3), vtkVolume (3), vtkPiecewiseFunction (2), vtkRungeKutta45 (2), vtkStreamLine (2), [...]
stepsize
  • vtkRungeKutta45 (6), vtkInitialValueProblemSolver (4)
stereo
  • vtkRenderWindow (11), vtkInteractorStyle (3), vtkPerspectiveTransform (3), vtkSTLReader (3), vtkSTLWriter (3), vtkCamera (1), vtkMesaRenderWindow (1), vtkOpenGLRenderWindow (1), vtkPLYReader (1), vtkQuartzRenderWindow (1), [...]
stereo-capable
  • vtkQuartzRenderWindow (1), vtkRenderWindow (1), vtkWin32OpenGLRenderWindow (1), vtkWinCEOpenGLRenderWindow (1), vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
stiffness
  • vtkThinPlateSplineTransform (1)
stippling
  • vtkProperty (2), vtkProperty2D (2)
stop (stopped, stops)
  • vtkVideoSource (2), vtkCompositeManager (1), vtkDecimate (1), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1), vtkInteractorStyleTrackballActor (1), vtkInteractorStyleTrackballCamera (1), vtkInteractorStyleUser (1), vtkIterativeClosestPointTransform (1), vtkMILVideoSource (1), [...]
storage
  • vtkBitArray (2), vtkCellTypes (2), vtkCharArray (2), vtkContourFilter (2), vtkContourGrid (2), vtkDoubleArray (2), vtkFloatArray (2), vtkGridSynchronizedTemplates3D (2), vtkIdTypeArray (2), vtkImageMarchingCubes (2), [...]
store (stored, stores, storing)
  • vtkFieldData (13), vtkAbstractTransform (5), vtkMath (5), vtkLinearTransform (4), vtkArrayCalculator (3), vtkImageReader2 (3), vtkMPICommunicator (3), vtkMedicalImageReader2 (3), vtkDataReader (2), vtkEdgeTable (2), [...]
straight
  • vtkParallelCoordinatesActor (1), vtkRuledSurfaceFilter (1)
strain
  • vtkCellDerivatives (2)
strange
  • vtkImplicitModeller (1), vtkWeightedTransformFilter (1)
stray
  • vtkXMLParser (1)
stream (streamed, streaming, streams)
  • vtkImageDataStreamer (4), vtkMemoryLimitImageDataStreamer (4), vtkStreamer (4), vtkPolyDataStreamer (3), vtkXMLParser (9), vtkByteSwap (3), vtkWinCE (3), vtkCleanPolyData (2), vtkImageMarchingCubes (2), vtkPImageWriter (2), [...]
streamer (streamers)
  • vtkStreamer (12), vtkStreamPoints (3), vtkDashedStreamLine (1), vtkExtentTranslator (1), vtkStreamLine (1)
streamline (streamlines)
  • vtkStreamLine (10), vtkDashedStreamLine (3), vtkHyperStreamline (1), vtkStreamer (6), vtkDividingCubes (1), vtkInterpolatedVelocityField (1), vtkRecursiveDividingCubes (1)
streamtubes
  • vtkTubeFilter (1)
stress
  • vtkPointLoad (6), vtkExtractTensorComponents (4)
stretched
  • vtkViewport (1)
strict (strictly)
  • vtkAbstractList (1), vtkAssembly (1), vtkCleanPolyData (1), vtkImplicitModeller (1), vtkNonLinearCell (1), vtkTetra (1), vtkTriangle (1), vtkWin32Header (1)
stride (strides)
  • vtkPiecewiseFunction (2), vtkImageShrink3D (1)
string (strings)
  • vtkTestUtilities (8), vtkDataReader (5), vtkLegendBoxActor (5), vtkAssignAttribute (4), vtkDataWriter (4), vtkGlyph3D (4), vtkRearrangeFields (4), vtkTextMapper (4), vtkWinCE (4), vtkCommunicator (3), [...]
stringle
  • vtkCGMWriter (1)
strip (striped, striping, stripped, strips)
  • vtkStripper (10), vtkTriangleStrip (6), vtkPolyData (12), vtkRuledSurfaceFilter (9), vtkTubeFilter (5), vtkLinearExtrusionFilter (3), vtkRotationalExtrusionFilter (3), vtkBYUWriter (2), vtkCGMWriter (2), vtkCleanPolyData (2), [...]
stripe
  • vtkRuledSurfaceFilter (2)
strp
  • vtkCleanPolyData (3)
struct
  • vtkPLY (1)
structure (structured, structures)
  • vtkBlankStructuredGridWithImage (6), vtkStructuredGrid (5), vtkStructuredData (4), vtkStructuredGridGeometryFilter (4), vtkRayCastStructures (3), vtkStructuredGridOutlineFilter (3), vtkStructuredPointsReader (3), vtkStructuredPointsSource (3), vtkStructuredGridReader (2), vtkStructuredGridSource (2), [...]
strung
  • vtkViewport (1)
stubs
  • vtkRenderWindow (1)
studio
  • vtk3DSImporter (2)
stuff
  • vtkImageFourierFilter (2), vtkDataObject (1), vtkDynamicLoader (1), vtkInteractorStyleTrackball (1), vtkLODActor (1), vtkLegendBoxActor (1), vtkOutputPort (1), vtkProp (1), vtkSpherePuzzle (1), vtkSystemIncludes (1), [...]
style (styles)
  • vtkInteractorStyle (8), vtkInteractorStyleSwitch (6), vtkInteractorStyleTrackball (4), vtkInteractorStyleUnicam (2), vtkOldStyleCallbackCommand (1), vtkImageToPolyDataFilter (4), vtkAxisActor2D (2), vtkButtonSource (2), vtkLabeledDataMapper (2), vtkCompositeManager (1), [...]
sub-cell
  • vtkCell (2)
sub-class (sub-classes)
  • vtkObjectFactory (5), vtkInitialValueProblemSolver (2), vtkImageReader2 (1), vtkInterpolatedVelocityField (1), vtkMesaRenderer (1), vtkOpenGLRenderer (1), vtkOutputWindow (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1), [...]
sub-divisions
  • vtkCellLocator (1), vtkPointLocator (1), vtkPointLocator2D (1)
sub-extent (sub-extents)
  • vtkImageStencilData (5)
sub-iteration (sub-iterations)
  • vtkDecimate (3)
sub-samples (sub-sampling)
  • vtkMaskPolyData (1), vtkSimpleImageToImageFilter (1)
sub-tubes
  • vtkHyperStreamline (2)
sub-voxel
  • vtkDividingCubes (1), vtkRecursiveDividingCubes (1)
subcell
  • vtkDataSet (1)
subclass (subclassed, subclasses, subclassing)
  • vtkFieldData (13), vtkDataObject (5), vtkInteractorStyle (5), vtkObject (5), vtkProp (5), vtkRenderWindowInteractor (5), vtkXMLParser (5), vtkAbstractPicker (4), vtkMultiProcessController (4), vtkSource (4), [...]
subclass-specific
  • vtkAbstractTransform (2)
subdivide (subdivided, subdivides, subdividing)
  • vtkSubdivideTetra (2), vtkHull (3), vtkLinearSubdivisionFilter (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkRecursiveSphereDirectionEncoder (1), vtkStructuredGrid (1)
subdivision (subdivisions)
  • vtkButterflySubdivisionFilter (5), vtkLoopSubdivisionFilter (5), vtkApproximatingSubdivisionFilter (3), vtkInterpolatingSubdivisionFilter (3), vtkLinearSubdivisionFilter (2), vtkRecursiveSphereDirectionEncoder (3), vtkPlaneSource (2), vtkCellLocator (1), vtkHull (1), vtkLocator (1), [...]
subextent
  • vtkBranchExtentTranslator (1)
subject
  • vtkCommand (2), vtkObject (1)
subpieces
  • vtkPipelineSize (1)
subregion
  • vtkVolumeRayCastMapper (1)
subsample (subsampled, subsamples, subsampling)
  • vtkExtractGrid (7), vtkExtractVOI (5), vtkImageShrink3D (1)
subsegments
  • vtkVolumeRayCastFunction (1)
subsequently
  • vtkRIBExporter (1), vtkVideoSource (1)
subset
  • vtkExtractUnstructuredGrid (1), vtkImageClip (1), vtkImageReader (1), vtkMaskPolyData (1)
substitution
  • vtkMath (1)
subtly
  • vtkLightKit (1)
subtract (subtracts)
  • vtkImageMathematics (1), vtkImplicitBoolean (1), vtkLandmarkTransform (1), vtkThinPlateSplineTransform (1)
subvolume
  • vtkVolumeProMapper (2), vtkVolumeMapper (1)
subwindow
  • vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
succeeds
  • vtkLinkEdgels (1)
succesful
  • vtkDataSetAttributes (1)
success
  • vtkMPICommunicator (2), vtkMPIController (2), vtkCommunicator (1), vtkMPIGroup (1)
successful (successfully)
  • vtkAbstractPicker (2), vtkLinkEdgels (2), vtkPicker (2), vtkDynamicLoader (1), vtkImageEuclideanDistance (1), vtkImageFFT (1), vtkImageRFFT (1), vtkInteractorStyle (1)
successfull
  • vtkAbstractList (9)
successive
  • vtkImplicitModeller (2)
successor
  • vtkAbstractList (1)
suffer
  • vtkWeightedTransformFilter (1)
sufficient
  • vtkEncodedGradientEstimator (1)
suffix
  • vtkOBJExporter (1)
suggestion (suggested)
  • vtkLabeledDataMapper (2), vtkAxisActor2D (1), vtkCubeAxesActor2D (1), vtkParallelCoordinatesActor (1), vtkXYPlotActor (1)
suitable
  • vtkButtonSource (1), vtkCGMWriter (1), vtkPLOT3DReader (1)
suited
  • vtkImageReslice (1)
summarized
  • vtkSweptSurface (1)
summary
  • vtk3DS (1), vtkInteractorStyleImage (1), vtkLoopSubdivisionFilter (1)
sums (summed)
  • vtkImageReader (1), vtkImageVariance3D (1), vtkImplicitSum (1), vtkVolume16Reader (1)
sunlight
  • vtkLightKit (1)
sunset
  • vtkLightKit (2)
super
  • vtkMesaRenderer (2), vtkImageInPlaceFilter (1), vtkImageMultipleInputFilter (1), vtkImageMultipleInputOutputFilter (1), vtkImagePadFilter (1), vtkImageReader2 (1), vtkImageSpatialFilter (1), vtkMesaActor (1), vtkPCellDataToPointData (1)
super-communicator
  • vtkMPICommunicator (1)
superclass (superclasses)
  • vtkImageIterateFilter (4), vtkCubeAxesActor2D (3), vtkImageToImageFilter (3), vtkVolumeProVG500Mapper (3), vtkVolumeProVP1000Mapper (3), vtkAbstractTransform (2), vtkCommand (2), vtkDataArray (2), vtkDataReader (2), vtkDirectionEncoder (2), [...]
superimpose
  • vtkImageEuclideanDistance (1)
superior
  • vtkDecimatePro (1), vtkImageToPolyDataFilter (1)
superquadric (superquadrics)
  • vtkSuperquadricSource (19), vtkSuperquadric (18)
supersampling
  • vtkVolumeProMapper (3)
supersedes
  • vtkDataReader (1)
supper
  • vtkXMesaRenderWindow (1), vtkXOpenGLRenderWindow (1)
supplemental
  • vtkCellLinks (1), vtkCellTypes (1)
supplying
  • vtkJPEGWriter (1), vtkMapper (1), vtkTensor (1)
support (supported, supporting, supports)
  • vtkTexture (4), vtkWin32ImageWindow (4), vtkInteractorStyle (3), vtkSocketCommunicator (3), vtkVectorText (3), vtkAssembly (2), vtkCellArray (2), vtkDataArray (2), vtkGESignaReader (2), vtkGenericCell (2), [...]
supposed (supposedly)
  • vtkDelaunay2D (1), vtkDelaunay3D (1), vtkQuadricClustering (1)
suppresion
  • vtkQuartzRenderWindowInteractor (1)
suppression
  • vtkImageNonMaximumSuppression (1), vtkWin32RenderWindowInteractor (1)
surface (surfaces)
  • vtkRuledSurfaceFilter (22), vtkSurfaceReconstructionFilter (6), vtkSweptSurface (6), vtkVoxelContoursToSurfaceFilter (3), vtkVolumeRayCastIsosurfaceFunction (2), vtkDataSetSurfaceFilter (1), vtkJavaAwt (12), vtkProperty (8), vtkCutter (5), vtkImplicitModeller (5), [...]
surgical
  • vtkLightKit (1)
surrounding (surrounded)
  • vtkSmoothPolyDataFilter (2), vtkWindowedSincPolyDataFilter (2), vtkDecimatePro (1)
survey
  • vtkDEMReader (1)
sutible
  • vtkRenderer (2), vtkActor (1)
swap (swapped, swapping, swaps)
  • vtkByteSwap (43), vtkVolume16Reader (7), vtkImageReader2 (6), vtkParticleReader (6), vtkMCubesReader (5), vtkRenderWindow (4), vtkImageWindow (2), vtkMesaImageWindow (2), vtkOpenGLImageWindow (2), vtkQuartzImageWindow (2), [...]
sweep (sweeping, sweeps)
  • vtkRotationalExtrusionFilter (7), vtkLinearExtrusionFilter (4)
sweet
  • vtkSetGet (1)
sweldens
  • vtkButterflySubdivisionFilter (1)
swept
  • vtkSweptSurface (6), vtkLinearExtrusionFilter (3), vtkRotationalExtrusionFilter (3)
swirl
  • vtkPLOT3DReader (1)
swiss-army-knife
  • vtkImageReslice (1)
switches (switched)
  • vtkAbstractTransform (1), vtkQuantizePolyDataPoints (1)
symbol (symbols)
  • vtkLegendBoxActor (11), vtkXYPlotActor (7), vtkDynamicLoader (2), vtkGlyphSource2D (1), vtkPLY (1)
symetric
  • vtkAxes (1)
symmetric
  • vtkMath (3), vtkWarpLens (3), vtkRotationalExtrusionFilter (1), vtkTriangularTCoords (1)
symmetry
  • vtkTriangularTCoords (1)
synchronize (synchronized)
  • vtkGridSynchronizedTemplates3D (1), vtkSynchronizedTemplates2D (1), vtkSynchronizedTemplates3D (1), vtkRenderWindow (2), vtkMPIController (1), vtkMultiProcessController (1), vtkRenderer (1), vtkSelectVisiblePoints (1), vtkThreadedController (1), vtkWindow (1)
synonymous
  • vtkLinearTransform (2)
synonyms
  • vtkRenderer (1), vtkViewport (1)
syntax
  • vtkInteractorStyleUnicam (1), vtkOldStyleCallbackCommand (1), vtkXMLParser (1)
system (systems)
  • vtkSystemIncludes (2), vtkCoordinate (12), vtkMILVideoSource (6), vtkHyperStreamline (5), vtkStreamer (5), vtkDEMReader (3), vtkMapper (3), vtkPolygon (3), vtkSTLReader (3), vtkSTLWriter (3), [...]
Generated on Mon Mar 25 01:37:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Full-text Index (t..z)
  • 768 file(s) indexed by 3129 word(s) on Mon Mar 25 01:04:39 2002
  • max limit is 10 xref(s) per word
Version:
0.22
Author:
doc_index.pl, by Sebastien Barre

t
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
t-axis
  • vtkTransformTextureCoords (2), vtkPolygon (1)
t-coordinate (t-coordinates)
  • vtkTextureMapToCylinder (2), vtkTransformTextureCoords (2), vtkProjectedTexture (1), vtkTextureMapToPlane (1), vtkTextureMapToSphere (1)
table (tables)
  • vtkLookupTable (26), vtkWindowLevelLookupTable (11), vtkEdgeTable (5), vtkGlyph3D (15), vtkEncodedGradientShader (13), vtkMapper (9), vtkImageToPolyDataFilter (8), vtkRecursiveSphereDirectionEncoder (8), vtkPolyDataMapper2D (7), vtkScalarBarActor (7), [...]
tabular
  • vtkProgrammableDataObjectSource (1)
tags (tagging)
  • vtkXMLParser (3), vtkMultiProcessController (2), vtkThreadSafeLog (2), vtkImageOpenClose3D (1), vtkInputPort (1), vtkMPICommunicator (1), vtkMPIController (1), vtkSTLReader (1), vtkXMLFileOutputWindow (1)
tail (tails)
  • vtkLookupTable (2), vtkAbstractPropPicker (1), vtkImageReader2 (1)
tangent
  • vtkStreamLine (1)
tape
  • vtkVideoSource (4)
target
  • vtkDecimate (4), vtkIterativeClosestPointTransform (4), vtkThinPlateSplineTransform (3), vtk3DS (2), vtkDicer (2), vtkLandmarkTransform (2), vtkSubPixelPositionEdgels (2), vtkLocator (1), vtkPipelineSize (1), vtkRearrangeFields (1), [...]
task (tasks)
  • vtkImageReslice (1), vtkImageToImageFilter (1), vtkInteractorStyleUnicam (1), vtkOutputPort (1), vtkPDataSetWriter (1)
taubin
  • vtkWindowedSincPolyDataFilter (2)
tcoords (TCOORDS)
  • vtkAssignAttribute (1), vtkDataSetAttributes (1), vtkFieldDataToAttributeDataFilter (1), vtkPolyData (1), vtkRearrangeFields (1), vtkSplitField (1), vtkUnstructuredGrid (1)
tearing
  • vtkRuledSurfaceFilter (1)
tech
  • vtkWindowedSincPolyDataFilter (1)
technique (techniques)
  • vtkAbstractMapper (1), vtkAbstractMapper3D (1), vtkFiniteDifferenceGradientEstimator (1), vtkInteractorStyleUnicam (1), vtkLocator (1), vtkLoopSubdivisionFilter (1), vtkMCubesReader (1), vtkMCubesWriter (1), vtkRecursiveDividingCubes (1), vtkRenderWindow (1), [...]
tells
  • vtkAssignAttribute (2), vtkCompositeManager (1), vtkMultiProcessController (1), vtkOrderedTriangulator (1), vtkParallelCoordinatesActor (1), vtkSplitField (1)
temperature
  • vtkPLOT3DReader (1)
template (templated, templates)
  • vtkSynchronizedTemplates3D (3), vtkGridSynchronizedTemplates3D (2), vtkSynchronizedTemplates2D (1), vtkContainer (2), vtkEncodedGradientEstimator (2), vtkSetGet (2), vtkXImageWindow (2), vtkAbstractList (1), vtkImageDecomposeFilter (1), vtkImageFourierFilter (1), [...]
temporarily
  • vtkImageIterateFilter (1), vtkInteractorStyleFlight (1), vtkMesaRenderer (1), vtkOpenGLRenderer (1)
temporary
  • vtkRenderer (2), vtkImageMandelbrotSource (1), vtkMatrix4x4 (1), vtkPLOT3DReader (1), vtkProcessObject (1), vtkSTLReader (1), vtkSynchronizedTemplates3D (1)
tend (tends)
  • vtkMapper (2), vtkImageReader2 (1), vtkLightKit (1), vtkMCubesReader (1), vtkObject (1), vtkOpenGLStateCache (1), vtkParticleReader (1), vtkPerlinNoise (1), vtkVolume16Reader (1)
tension
  • vtkKochanekSpline (3)
tensor (TENSORS, tensors)
  • vtkExtractTensorComponents (24), vtkTensor (10), vtkTensorGlyph (6), vtkCellDerivatives (10), vtkDataSetAttributes (6), vtkPointLoad (6), vtkDataWriter (3), vtkLabeledDataMapper (3), vtkArcPlotter (2), vtkDataReader (2), [...]
terarecon
  • vtkOpenGLVolumeProVG500Mapper (1), vtkOpenGLVolumeProVP1000Mapper (1), vtkVolumeProMapper (1), vtkVolumeProVG500Mapper (1), vtkVolumeProVP1000Mapper (1)
term (termed, terms)
  • vtkWindowedSincPolyDataFilter (3), vtkCleanPolyData (2), vtkStreamLine (2), vtkAbstractTransform (1), vtkCellArray (1), vtkCellTypes (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkImageStencilData (1), vtkMapper (1), [...]
terminal
  • vtkStreamer (5), vtkHyperStreamline (3), vtkSpatialRepresentationFilter (1)
terminate (terminated, terminates, terminating, termination)
  • vtkDataObject (3), vtkImageStencilData (3), vtkQuartzRenderWindowInteractor (2), vtkStreamer (2), vtkWin32RenderWindowInteractor (2), vtkCaptionActor2D (1), vtkCell3D (1), vtkDebugLeaks (1), vtkHyperStreamline (1), vtkImporter (1), [...]
terribly
  • vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
tesselate
  • vtkQuadraticEdge (1)
tesselation
  • vtkNonLinearCell (1), vtkQuadraticEdge (1)
tessellate (tessellated, tessellates, tessellating, tessellation)
  • vtkNonLinearCell (10), vtkSphereSource (3), vtkGLUTesselatorTriangleFilter (1), vtkQuadraticEdge (1)
test (tested, testing, tests)
  • vtkRegressionTestImage (4), vtkMPICommunicator (4), vtkMPIController (4), vtkImplicitModeller (2), vtkLocator (2), vtkTriangle (2), vtkAbstractPicker (1), vtkCellType (1), vtkImageDifference (1), vtkImageEllipsoidSource (1), [...]
tetra (tetras)
  • vtkSubdivideTetra (1), vtkTetra (1), vtkOrderedTriangulator (4), vtkDelaunay3D (2)
tetrahdera
  • vtkOrderedTriangulator (2)
tetrahedra
  • vtkDelaunay3D (7), vtkClipVolume (2), vtkSubdivideTetra (2), vtkCell (1), vtkCell3D (1), vtkClipDataSet (1), vtkOrderedTriangulator (1)
tetrahedrahedron
  • vtkOrderedTriangulator (2)
tetrahedral
  • vtkDataSetTriangleFilter (1), vtkDelaunay3D (1)
tetrahedron
  • vtkOrderedTriangulator (9), vtkTetra (9), vtkDelaunay3D (3), vtkCell (1), vtkCutter (1), vtkSubdivideTetra (1), vtkUnstructuredGrid (1)
tetrahedronalization (tetrahedronalizations)
  • vtkDelaunay3D (3)
tets
  • vtkImageIterator (1)
text
  • vtkTextMapper (10), vtkScaledTextActor (9), vtkTextSource (6), vtkVectorText (5), vtkQuartzTextMapper (3), vtkWin32OpenGLTextMapper (3), vtkXMesaTextMapper (3), vtkXOpenGLTextMapper (3), vtkXTextMapper (3), vtkWin32TextMapper (2), [...]
textbook
  • vtkDataObjectToDataSetFilter (2)
texture (textures)
  • vtkTransformTextureCoords (26), vtkTexture (20), vtkImplicitTextureCoords (15), vtkTriangularTexture (12), vtkBooleanTexture (11), vtkThresholdTextureCoords (9), vtkProjectedTexture (8), vtkVolumeTextureMapper2D (8), vtkTextureMapToCylinder (7), vtkTextureMapToPlane (7), [...]
thanks
  • vtkJPEGWriter (1), vtkPCAAnalysisFilter (1), vtkProcrustesAlignmentFilter (1)
theorem
  • vtkMassProperties (1)
theory
  • vtkTestUtilities (2)
thesis
  • vtkImageEuclideanDistance (1), vtkLoopSubdivisionFilter (1)
theta
  • vtkSphereSource (4), vtkTexturedSphereSource (3), vtkImageEuclideanToPolar (2), vtkPSphereSource (2), vtkSuperquadricSource (2), vtkMath (1), vtkStreamer (1), vtkSuperquadric (1), vtkTextureMapToSphere (1)
thick (thickness)
  • vtkBooleanTexture (5), vtkSuperquadric (5), vtkSuperquadricSource (5), vtkCamera (1), vtkImplicitWindowFunction (1), vtkTubeFilter (1), vtkVolume (1), vtkVolumeProMapper (1), vtkVolumeRayCastFunction (1)
thie
  • vtkVectorText (1)
thin
  • vtkThinPlateSplineTransform (2), vtkDepthSortPolyData (1), vtkImageHybridMedian2D (1), vtkTransformToGrid (1)
thinking
  • vtkImageMandelbrotSource (1)
thinnest
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
third-party
  • vtkImageImport (16), vtkImageExport (3)
thirty
  • vtkRenderWindow (1)
thomas
  • vtkVRML (1), vtkVRMLImporter (1)
thousand
  • vtkImplicitModeller (2)
thread (THREAD, threaded, threads)
  • vtkMultiThreader (26), vtkThreadedController (8), vtkDataSet (46), vtkPointLocator (20), vtkSharedMemoryCommunicator (5), vtkImageToImageFilter (4), vtkImplicitModeller (4), vtkMultiProcessController (4), vtkExtentTranslator (3), vtkMultiProcessLog (3), [...]
thread-safe
  • vtkGenericCell (2), vtkDataArray (1), vtkDataSet (1), vtkImageStencilSource (1), vtkInitialValueProblemSolver (1)
three-dimensional
  • vtkDataSetTriangleFilter (1)
three-group
  • vtkPolygon (1)
three-quarters
  • vtkDashedStreamLine (1)
threshold (thresholded, thresholding, thresholds)
  • vtkThresholdTextureCoords (10), vtkThreshold (9), vtkThresholdPoints (6), vtkImageThreshold (3), vtkLinkEdgels (10), vtkImageAnisotropicDiffusion2D (5), vtkImageAnisotropicDiffusion3D (5), vtkImageBlend (5), vtkImageDifference (5), vtkImageCast (1), [...]
thrown
  • vtkRenderWindow (1)
tick (ticks)
  • vtkAxisActor2D (20), vtkParallelCoordinatesActor (1), vtkTimerLog (1)
tiffcomp
  • vtkRIBExporter (2)
tightens
  • vtkKochanekSpline (1)
tightest-fitting
  • vtkOBBTree (1)
tiled
  • vtkVolumeTextureMapper2D (1)
tiling
  • vtkPlaneSource (1), vtkRenderLargeImage (1), vtkWindow (1)
time (timeing, times)
  • vtkTimeStamp (10), vtkTimerLog (8), vtkLODProp3D (13), vtkStreamer (8), vtkEnSightReader (7), vtkObject (7), vtkProp (6), vtkRenderer (6), vtkStreamLine (6), vtkFrustumCoverageCuller (5), [...]
time-efficient
  • vtkImageStencilSource (1)
timed
  • vtkProp (1)
timer (timers)
  • vtkTimerLog (4), vtkRenderWindowInteractor (6), vtkInteractorStyle (1), vtkInteractorStyleFlight (1), vtkQuartzRenderWindowInteractor (1), vtkWin32RenderWindowInteractor (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
timestamp (timestamps)
  • vtkVersion (2), vtkVideoSource (2)
timing
  • vtkTimerLog (7), vtkThreadSafeLog (2), vtkMPIEventLog (1), vtkProp (1)
title (titles)
  • vtkAxisActor2D (7), vtkParallelCoordinatesActor (3), vtkXYPlotActor (3), vtkCubeAxesActor2D (2), vtkScalarBarActor (2)
toggle (toggled)
  • vtkInteractorStyle (3), vtkImageAnisotropicDiffusion2D (1), vtkImageAnisotropicDiffusion3D (1)
tolerance
  • vtkCleanPolyData (7), vtkDelaunay2D (4), vtkDelaunay3D (4), vtkSelectVisiblePoints (4), vtkClipVolume (3), vtkPicker (3), vtkTriangle (3), vtkCell (2), vtkDataSet (2), vtkPolygon (2), [...]
toolkit
  • vtkDataSetReader (1), vtkDelaunay2D (1), vtkObject (1), vtkRIBExporter (1)
top-bottom
  • vtkProjectedTexture (1)
top-down
  • vtkOBBTree (2)
top-edge
  • vtkInteractorStyleUnicam (1)
topological (topologically)
  • vtkCell (5), vtkDataSet (4), vtkExtractGrid (3), vtkExtractVOI (3), vtkImageData (3), vtkPolyData (3), vtkRectilinearGrid (3), vtkStructuredData (3), vtkStructuredGrid (3), vtkCell3D (2), [...]
topology
  • vtkDecimate (6), vtkDecimatePro (6), vtkDelaunay2D (5), vtkDataSetToDataObjectFilter (4), vtkContourFilter (2), vtkContourGrid (2), vtkDataObjectToDataSetFilter (2), vtkDataSet (2), vtkFieldDataToAttributeDataFilter (2), vtkGridSynchronizedTemplates3D (2), [...]
toriwaki
  • vtkImageEuclideanDistance (1)
toroid (toroids)
  • vtkSuperquadric (4), vtkSuperquadricSource (4)
toroidal
  • vtkSuperquadric (4), vtkSuperquadricSource (3)
torus
  • vtkRotationalExtrusionFilter (1)
total (totally)
  • vtkDecimatePro (4), vtkCellArray (3), vtkDataSetAttributes (2), vtkImageDifference (2), vtkImageStencilData (2), vtkPLOT3DReader (2), vtkDecimate (1), vtkGeneralTransform (1), vtkImageEuclideanDistance (1), vtkImageFFT (1), [...]
touch (touched)
  • vtkHull (1), vtkImageOpenClose3D (1), vtkSimpleImageToImageFilter (1)
towards
  • vtkHull (3), vtkWarpTo (3), vtkInteractorStyle (2), vtkInteractorStyleUnicam (2), vtkLinearExtrusionFilter (2), vtkCamera (1), vtkDelaunay3D (1), vtkLight (1), vtkLightKit (1), vtkProperty (1), [...]
tracer
  • vtkRIBExporter (1)
traces (tracing)
  • vtkImageSkeleton2D (3), vtkPCAAnalysisFilter (1), vtkProcessObject (1), vtkProcrustesAlignmentFilter (1), vtkRIBExporter (1), vtkSource (1)
track (tracked, tracking)
  • vtkInteractorStyleTrackball (1), vtkDelaunay3D (3), vtkCellArray (2), vtkDataSetAttributes (2), vtkEdgeTable (2), vtkImageToPolyDataFilter (2), vtkObject (2), vtkWindow (2), vtkXYPlotActor (2), vtkCamera (1), [...]
trackball
  • vtkInteractorStyleTrackball (5), vtkInteractorStyle (5), vtkInteractorStyleSwitch (3), vtkRenderWindowInteractor (1)
traditional
  • vtkWeightedTransformFilter (1)
training
  • vtkPCAAnalysisFilter (1)
tranfser
  • vtkVolumeMapper (1)
trans
  • vtkActor (2), vtkProp3D (2)
transactions
  • vtkRungeKutta45 (1)
transfer (transfered)
  • vtkColorTransferFunction (6), vtkVolumeProperty (13), vtkVolume (10), vtkWindowedSincPolyDataFilter (4), vtkVolumeMapper (2), vtkCompositeManager (1), vtkEncodedGradientEstimator (1), vtkPiecewiseFunction (1), vtkScalarsToColors (1), vtkSocketCommunicator (1), [...]
transferred
  • vtkInputPort (1)
transform (transformed, transforming, transforms)
  • vtkAbstractTransform (27), vtkWeightedTransformFilter (27), vtkTransform (12), vtkGeneralTransform (11), vtkPerspectiveTransform (10), vtkWarpTransform (7), vtkGridTransform (6), vtkIterativeClosestPointTransform (6), vtkTransformToGrid (6), vtkTransformFilter (5), [...]
transformable
  • vtkAssembly (1), vtkImageReader (1)
transformation (transformations)
  • vtkTransform (50), vtkPerspectiveTransform (48), vtkGeneralTransform (35), vtkAbstractTransform (33), vtkLinearTransform (18), vtkWarpTransform (12), vtkIdentityTransform (11), vtkProp3D (11), vtkHomogeneousTransform (9), vtkLight (7), [...]
transformation-related
  • vtkProp3D (1)
transition
  • vtkCriticalSection (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkSystemIncludes (1), vtkThresholdTextureCoords (1)
translate (translated, translates, translating, translation, translations)
  • vtkRotationalExtrusionFilter (5), vtkTransform (5), vtkTransformTextureCoords (5), vtkPlaneSource (4), vtkImageChangeInformation (3), vtkInteractorStyle (3), vtkPerspectiveTransform (3), vtkBlankStructuredGrid (2), vtkDataObject (2), vtkLandmarkTransform (2), [...]
translational
  • vtkRotationalExtrusionFilter (1)
translator
  • vtkBranchExtentTranslator (3), vtkImageDataStreamer (1)
translucent
  • vtkCutter (1), vtkProp (1), vtkRenderer (1)
transmitted
  • vtkMesaImageWindow (2), vtkMesaRenderWindow (2), vtkOpenGLImageWindow (2), vtkOpenGLRenderWindow (2), vtkQuartzImageWindow (2), vtkQuartzRenderWindow (2), vtkRenderWindow (2), vtkWin32OpenGLImageWindow (2), vtkDecimatePro (1), vtkWindow (1), [...]
transparency
  • vtkBooleanTexture (11), vtkAbstractPicker (1), vtkCompositeManager (1), vtkDepthSortPolyData (1), vtkImplicitTextureCoords (1), vtkLookupTable (1), vtkTreeComposite (1), vtkWindowLevelLookupTable (1)
transparent (transparently)
  • vtkRenderer (3), vtkAbstractPicker (1), vtkAssemblyPath (1), vtkBooleanTexture (1), vtkDividingCubes (1), vtkInputPort (1), vtkOutputPort (1), vtkProperty (1), vtkRecursiveDividingCubes (1), vtkThresholdTextureCoords (1)
transpose (transposed)
  • vtkMath (3), vtkMatrix4x4 (1), vtkTransform (1)
travels (travelled)
  • vtkStreamer (3), vtkStreamLine (1)
traversal
  • vtkCellArray (9), vtkPolyData (6), vtkSimpleScalarTree (3), vtkCollection (2), vtkPolyDataNormals (2), vtkScalarTree (2), vtkAssembly (1), vtkEdgeTable (1), vtkProgrammableAttributeDataFilter (1), vtkProp (1), [...]
traverse (traversed, traverses, traversing)
  • vtkUnstructuredGrid (3), vtkAssembly (2), vtkEdgeTable (2), vtkPolyData (2), vtkPropAssembly (2), vtkDelaunay3D (1), vtkImageToPolyDataFilter (1), vtkMapper (1), vtkScalarTree (1), vtkSimpleScalarTree (1)
treat (treating)
  • vtkImageData (2), vtkImplicitDataSet (1), vtkImplicitVolume (1), vtkOpenGLStateCache (1), vtkSetGet (1)
treatment
  • vtkNonLinearCell (2), vtkButterflySubdivisionFilter (1), vtkCell (1)
tree (trees)
  • vtkSimpleScalarTree (18), vtkOBBTree (10), vtkScalarTree (7), vtkTreeComposite (1), vtkLocator (8), vtkContourFilter (4), vtkPriorityQueue (4), vtkContourGrid (3), vtkMarchingContourFilter (3), vtkSpatialRepresentationFilter (3), [...]
tree-like
  • vtkAssembly (1), vtkPropAssembly (1)
tri-linear
  • vtkVolumeRayCastIsosurfaceFunction (1), vtkVolumeRayCastMapper (1)
triad
  • vtkCubeAxesActor2D (1)
triangle (triangles)
  • vtkTriangle (25), vtkTriangleStrip (11), vtkGLUTesselatorTriangleFilter (4), vtkTriangleFilter (4), vtkDataSetTriangleFilter (1), vtkQuadricClustering (20), vtkDecimate (13), vtkDecimatePro (13), vtkDelaunay2D (12), vtkPolyData (12), [...]
triangular
  • vtkTriangularTexture (3), vtkTriangularTCoords (1), vtkMath (5), vtkPyramid (1), vtkWedge (1)
triangulate (triangulated, triangulates, triangulation, triangulations)
  • vtkDelaunay2D (35), vtkOrderedTriangulator (27), vtkDelaunay3D (22), vtkDecimate (4), vtkDecimatePro (4), vtkPolygon (4), vtkClipDataSet (2), vtkDataSetTriangleFilter (2), vtkButterflySubdivisionFilter (1), vtkCell (1), [...]
triangulator
  • vtkOrderedTriangulator (1)
trick
  • vtkImplicitSelectionLoop (1), vtkPolyData (1)
trickiest
  • vtkCaptionActor2D (1), vtkProgrammableFilter (1)
tried
  • vtkLinkEdgels (1), vtkXRenderWindowInteractor (1)
tries
  • vtkExtentTranslator (1), vtkInitialValueProblemSolver (1), vtkRungeKutta45 (1)
trigger (triggered, triggering, triggers)
  • vtkMultiProcessController (4), vtkDataObject (1), vtkImageStencilData (1), vtkImageWriter (1), vtkInputPort (1), vtkJPEGWriter (1), vtkOutputPort (1), vtkPNGWriter (1), vtkQuadricClustering (1)
triplet (triplets)
  • vtkPLYReader (1), vtkPLYWriter (1), vtkPoints (1), vtkVectorNorm (1)
trouble
  • vtkEarthSource (1)
truncate
  • vtkCone (1), vtkCylinder (1)
trustees
  • vtkPLY (1)
tube (tubes)
  • vtkTubeFilter (21), vtkHyperStreamline (11), vtkStreamer (2), vtkRuledSurfaceFilter (1)
tube-like
  • vtkHyperStreamline (1)
tungsten
  • vtkLightKit (1)
tunnels
  • vtkDecimate (1)
tuple (tuples)
  • vtkDataArray (23), vtkFieldData (18), vtkCharArray (10), vtkDoubleArray (8), vtkFloatArray (8), vtkIntArray (8), vtkLongArray (8), vtkShortArray (8), vtkUnsignedCharArray (8), vtkUnsignedIntArray (8), [...]
tupples
  • vtkDataSet (1)
ture (turned, turning)
  • vtkExtractUnstructuredGrid (1), vtkImplicitTextureCoords (1), vtkTextureMapToPlane (1), vtkTransformTextureCoords (1), vtkVolumeProperty (4), vtkClipDataSet (3), vtkClipPolyData (3), vtkClipVolume (3), vtkPolyDataNormals (3), vtkRenderer (3), [...]
turk
  • vtkPLY (1)
turn (turns)
  • vtkRenderWindow (8), vtkCursor3D (7), vtkDataSetAttributes (7), vtkDecimate (6), vtkPolyDataNormals (6), vtkRenderer (6), vtkDataSetToDataObjectFilter (5), vtkDecimatePro (5), vtkFeatureEdges (5), vtkGeometryFilter (5), [...]
turn-off
  • vtkStructuredGrid (1)
twelve
  • vtkSubdivideTetra (2), vtkHull (1), vtkOutlineFilter (1)
twenty
  • vtkWindowedSincPolyDataFilter (1)
twice
  • vtkLightKit (1)
two-dimensional
  • vtkDataSetTriangleFilter (1), vtkImageCanvasSource2D (1)
two-sided
  • vtkRenderer (5), vtkViewport (2)
txtplastic
  • vtkRIBExporter (1)
type-checking
  • vtkCastToConcrete (2)
typecast (typecasting)
  • vtkHomogeneousTransform (1), vtkLinearTransform (1), vtkTimeStamp (1)
typedef
  • vtkMarchingCubesCases (1)
typical
  • vtkCellLocator (1), vtkCoordinate (1), vtkElevationFilter (1), vtkExtractGrid (1), vtkExtractVOI (1), vtkLightKit (1), vtkPLY (1), vtkPointLocator (1), vtkPointLocator2D (1), vtkTimeStamp (1), [...]

u
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
ugly
  • vtkDynamicLoader (1), vtkLightKit (1)
ullman
  • vtkPriorityQueue (1)
un-asked-for
  • vtkPLY (1)
un-setting
  • vtkSharedMemoryCommunicator (1)
unaffected
  • vtkCollection (1)
unavailable
  • vtkTextMapper (1)
unbound
  • vtkPythonUtil (1)
unchanged
  • vtkIdentityTransform (1), vtkImageBlend (1), vtkImageSkeleton2D (1), vtkInteractorStyleUser (1), vtkMapper (1), vtkPolyDataMapper2D (1), vtkStructuredData (1), vtkTransformPolyDataFilter (1)
unclear
  • vtkCriticalSection (1)
unclipped
  • vtkImageStencilData (1)
unconnected
  • vtkImageSeedConnectivity (1)
uncontrolled
  • vtkTensorGlyph (1)
uncut
  • vtkClipDataSet (1), vtkClipPolyData (1), vtkClipVolume (1)
undecided
  • vtkOBBTree (1)
undef
  • vtkOpenGLStateCache (1)
undefine (undefined)
  • vtkCellLocator (3), vtkPropAssembly (1), vtkTimerLog (1)
undershoots
  • vtkKochanekSpline (1)
understanding
  • vtkPCAAnalysisFilter (1)
undesirable
  • vtkMCubesReader (1), vtkRenderWindow (1), vtkWindowToImageFilter (1)
undirected
  • vtkGraphLayoutFilter (2)
uneven
  • vtkSurfaceReconstructionFilter (1)
unexpected
  • vtkFieldData (13), vtkRenderer (1), vtkWindowToImageFilter (1)
unfinished
  • vtkQuadricClustering (1)
unicam
  • vtkInteractorStyleUnicam (3)
unified
  • vtkLightKit (1)
uniform (uniformly)
  • vtkPLYWriter (5), vtkDataObjectToDataSetFilter (1), vtkFieldDataToAttributeDataFilter (1), vtkGlyph3D (1), vtkGridTransform (1), vtkImageNoiseSource (1), vtkImageShrink3D (1), vtkPointSource (1), vtkQuadricClustering (1), vtkScalarsToColors (1)
uniform-level
  • vtkCellLocator (1)
unigraphics
  • vtkUGFacetReader (4)
uninitialized
  • vtkDataObject (1)
union
  • vtkSweptSurface (2), vtkGaussianSplatter (1), vtkImageAppend (1), vtkImplicitBoolean (1)
unique (uniqueness)
  • vtkOrderedTriangulator (7), vtkEdgeTable (3), vtkMultiProcessController (2), vtkPythonUtil (2), vtkRecursiveSphereDirectionEncoder (2), vtkUnstructuredGrid (2), vtkAbstractList (1), vtkDelaunay2D (1), vtkDelaunay3D (1), vtkObject (1), [...]
unit (united, units)
  • vtkDEMReader (4), vtkImageGaussianSmooth (3), vtkFiniteDifferenceGradientEstimator (2), vtkHull (2), vtkImageButterworthHighPass (2), vtkImageButterworthLowPass (2), vtkImageIdealHighPass (2), vtkImageIdealLowPass (2), vtkImageMarchingCubes (2), vtkInteractorStyleFlight (2), [...]
unity
  • vtkWindowedSincPolyDataFilter (1)
universal
  • vtkTimerLog (1)
universite
  • vtkImageEuclideanDistance (1)
university
  • vtkInteractorStyleUnicam (2), vtkPLY (2), vtkPLYReader (2), vtkTreeComposite (2), vtkLoopSubdivisionFilter (1), vtkMPIEventLog (1), vtkPLYWriter (1), vtkRungeKutta45 (1), vtkWindowedSincPolyDataFilter (1)
unix (UNIX)
  • vtkDirectory (1), vtkImageReader2 (1), vtkMCubesReader (1), vtkParticleReader (1), vtkRenderWindow (1), vtkVolume16Reader (1), vtkWin32Header (1)
unknown
  • vtkDEMReader (1), vtkEnSightReader (1), vtkGenericEnSightReader (1), vtkPolyData (1), vtkXMLParser (1)
unlike
  • vtkPixel (1), vtkVoxel (1), vtkWeightedTransformFilter (1)
unlock
  • vtkCriticalSection (2), vtkJavaAwt (2), vtkMutexLock (2)
unmodified
  • vtkSource (1)
unnecessarily
  • vtkMPICommunicator (1)
unnecessary
  • vtkDataArray (1), vtkInputPort (1), vtkRotationalExtrusionFilter (1)
unneeded
  • vtkBitArray (1)
unnormalized
  • vtkTriangle (2)
unordered
  • vtkDataObjectCollection (1), vtkDataSetCollection (1)
unorganized
  • vtkDelaunay2D (1), vtkDelaunay3D (1), vtkSurfaceReconstructionFilter (1)
unpickable
  • vtkAbstractPicker (1)
unpredictable
  • vtkRectilinearGrid (1), vtkSelectPolyData (1)
unprocessed
  • vtkXMLFileOutputWindow (1)
unreferenced
  • vtkOutputWindow (1)
unregister (unregistered)
  • vtkInstantiator (3), vtkObjectFactory (1)
unsatisfactory
  • vtkOBBTree (1)
unselected
  • vtkSelectPolyData (2)
unsorted
  • vtkCollection (2), vtkActorCollection (1), vtkCullerCollection (1), vtkLightCollection (1), vtkMapperCollection (1), vtkProp3DCollection (1), vtkPropCollection (1), vtkRenderWindowCollection (1), vtkRendererCollection (1), vtkVolumeCollection (1)
unstable
  • vtkThinPlateSplineTransform (1)
unstructured
  • vtkExtractUnstructuredGrid (2), vtkUnstructuredGridReader (2), vtkUnstructuredGridSource (2), vtkUnstructuredGridWriter (2), vtkDataSetToUnstructuredGridFilter (1), vtkStructuredPointsToUnstructuredGridFilter (1), vtkDataObject (4), vtkDelaunay3D (4), vtkShepardMethod (4), vtkNonLinearCell (3), [...]
untouched
  • vtkInstantiator (1)
untransformed
  • vtkPicker (2), vtkDelaunay2D (1)
unusual
  • vtkExtractVectorComponents (1), vtkImageCanvasSource2D (1), vtkImageReader2 (1), vtkImplicitModeller (1), vtkProgrammableFilter (1), vtkStructuredGrid (1)
unvisited
  • vtkShepardMethod (1)
up-to-date
  • vtkSource (2), vtkDataObjectSource (1), vtkHomogeneousTransform (1)
updata
  • vtkInputPort (1)
update (UPDATE, updated, updates, updating)
  • vtkDataObject (37), vtkAbstractTransform (13), vtkImageStencilData (11), vtkSource (10), vtkVolumeProVG500Mapper (6), vtkVolumeProVP1000Mapper (6), vtkPolyData (5), vtkHomogeneousTransform (4), vtkIdentityTransform (4), vtkLinearTransform (4), [...]
upper
  • vtkThreshold (3), vtkThresholdPoints (3), vtkThresholdTextureCoords (3), vtkImageThreshold (2), vtkMath (2), vtkActor2D (1), vtkBlankStructuredGrid (1), vtkExtractTensorComponents (1), vtkImageExport (1), vtkImageReader2 (1), [...]
upper-left
  • vtkImageImport (1)
upper-right
  • vtkXYPlotActor (2), vtkCaptionActor2D (1)
upstream
  • vtkDataObject (4), vtkBranchExtentTranslator (1), vtkInputPort (1)
upward
  • vtkPolyData (2), vtkCellLinks (1)
usage
  • vtkCaptionActor2D (1), vtkCoordinate (1), vtkPolyDataMapper (1), vtkProcessStatistics (1), vtkQuadricClustering (1), vtkSimpleScalarTree (1)
usefull
  • vtkPieceScalars (1)
useless
  • vtkPolyData (1), vtkUnstructuredGrid (1)
user-controllable
  • vtkTextureMapToCylinder (1)
user-defined
  • vtkGaussianSplatter (1), vtkInteractorStyle (1), vtkMPIController (1), vtkProgrammableGlyphFilter (1)
user-managed
  • vtkVRML (1)
user-programmable
  • vtkProgrammableFilter (1)
user-provided
  • vtkBitArray (1), vtkCharArray (1), vtkDataArray (1), vtkDoubleArray (1), vtkFloatArray (1), vtkIdTypeArray (1), vtkIntArray (1), vtkLongArray (1), vtkPropPicker (1), vtkShortArray (1), [...]
user-specified
  • vtkClipDataSet (2), vtkClipPolyData (2), vtkClipVolume (2), vtkCutter (2), vtkProgrammableAttributeDataFilter (2), vtkProgrammableSource (2), vtkDecimate (1), vtkGaussianSplatter (1), vtkImplicitWindowFunction (1), vtkOutlineCornerSource (1), [...]
user-supplied
  • vtkProp3D (1)
usermatrix
  • vtkActor (1)
usgs (USGS)
  • vtkDEMReader (2)
usinge
  • vtkPythonUtil (1)
usuall
  • vtkProcrustesAlignmentFilter (1)
utah
  • vtkLoopSubdivisionFilter (1)
utility
  • vtkCellArray (1), vtkInstantiator (1), vtkInteractorStyle (1), vtkPythonUtil (1), vtkWeightedTransformFilter (1), vtkWin32ImageMapper (1), vtkXMLParser (1)
utilized
  • vtkAttributeDataToFieldDataFilter (1)

v
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
v-tabe
  • vtkContainer (1)
valence
  • vtkButterflySubdivisionFilter (1), vtkWindowedSincPolyDataFilter (1)
valid
  • vtkLODProp3D (4), vtkProgrammableGlyphFilter (3), vtkDataArray (2), vtkDataReader (2), vtkImageData (2), vtkPolyData (2), vtkProcessObject (2), vtkProgrammableAttributeDataFilter (2), vtkRectilinearGrid (2), vtkStructuredGrid (2), [...]
validity
  • vtkPLOT3DReader (1)
valued
  • vtkImplicitFunction (1)
variable (variables)
  • vtkFunctionParser (17), vtkEnSightReader (15), vtkXYPlotActor (12), vtkGenericEnSightReader (9), vtkSetGet (6), vtkActor2D (5), vtkParallelCoordinatesActor (5), vtkArrayCalculator (4), vtkEnSight6BinaryReader (4), vtkEnSight6Reader (4), [...]
variance
  • vtkImageVariance3D (3)
variant (variants)
  • vtkActor2DCollection (1), vtkActorCollection (1), vtkVolumeCollection (1)
variation (variations)
  • vtkTubeFilter (4), vtkPCAAnalysisFilter (2), vtkHull (1), vtkPriorityQueue (1), vtkRibbonFilter (1), vtkTextureMapToCylinder (1), vtkTextureMapToSphere (1)
variety
  • vtkCoordinate (2), vtkAxisActor2D (1), vtkImageMaskBits (1), vtkVersion (1)
varying (varied)
  • vtkLightKit (1), vtkPiecewiseFunction (1), vtkTubeFilter (1), vtkVolumeRayCastMapper (1)
vector (VECTORS, vectors)
  • vtkExtractVectorComponents (7), vtkVectorNorm (5), vtkWarpVector (4), vtkVectorDot (2), vtkMath (39), vtkGlyph3D (26), vtkCellDerivatives (15), vtkCamera (12), vtkPLOT3DReader (10), vtkFunctionParser (9), [...]
velocity
  • vtkInterpolatedVelocityField (3), vtkStreamer (6), vtkPLOT3DReader (5), vtkExtractVectorComponents (3), vtkStreamLine (3), vtkDashedStreamLine (2), vtkCell (1), vtkInteractorStyleJoystickActor (1)
verbatim
  • vtkAssignAttribute (3), vtkRearrangeFields (3), vtkMaskFields (2), vtkMergeFields (2), vtkSplitField (2)
version (versioning, versions)
  • vtkVersion (3), vtkMath (12), vtkCellLocator (6), vtkPLY (3), vtkObjectFactory (2), vtkRenderer (2), vtkTriangle (2), vtkAbstractPropPicker (1), vtkActor2DCollection (1), vtkActorCollection (1), [...]
versus
  • vtkPLYWriter (2), vtkDashedStreamLine (1), vtkDataObjectSource (1), vtkProcessObject (1), vtkSource (1), vtkXYPlotActor (1)
vert
  • vtkCleanPolyData (3)
vertex
  • vtkVertex (5), vtkDecimate (12), vtkDecimatePro (10), vtkSmoothPolyDataFilter (9), vtkWindowedSincPolyDataFilter (7), vtkAbstractTransform (6), vtkPolyData (6), vtkQuadricClustering (5), vtkCellCenters (4), vtkTriangle (4), [...]
vertical (vertically)
  • vtkTextMapper (3), vtkAxisActor2D (2), vtkScalarBarActor (2), vtkCaptionActor2D (1), vtkImageExport (1), vtkLightKit (1), vtkScaledTextActor (1), vtkSpherePuzzle (1), vtkVideoSource (1)
vertices
  • vtkSmoothPolyDataFilter (19), vtkWindowedSincPolyDataFilter (18), vtkQuadricClustering (9), vtkDecimatePro (7), vtkPolyData (7), vtkCell3D (6), vtkCellLocator (5), vtkDecimate (5), vtkMaskPoints (4), vtkRecursiveSphereDirectionEncoder (4), [...]
verticies
  • vtkQuadricClustering (1)
verts
  • vtkPolyData (2), vtkDataSetToDataObjectFilter (1), vtkMaskPoints (1)
vibration
  • vtkVectorDot (1)
vice-versa
  • vtkXYPlotActor (1)
video
  • vtkMILVideoSource (11), vtkVideoSource (11), vtkWin32VideoSource (8), vtkWindowLevelLookupTable (1)
view (VIEW, viewed, viewing, views)
  • vtkViewport (7), vtkTkImageViewerWidget (1), vtkCamera (27), vtkRenderer (12), vtkPerspectiveTransform (8), vtkDepthSortPolyData (4), vtkFrustumCoverageCuller (4), vtkButtonSource (2), vtkCoordinate (2), vtkCutMaterial (2), [...]
view-up
  • vtkCamera (1)
viewer (viewers)
  • vtkImageViewer (2), vtkImageViewer2 (1), vtkImageMandelbrotSource (2), vtkLightKit (2), vtkCubeAxesActor2D (1), vtkImageWindow (1), vtkMPIEventLog (1), vtkQuartzImageWindow (1), vtkScalarBarActor (1), vtkWin32ImageWindow (1), [...]
viewpoint
  • vtkInteractorStyleTrackballCamera (1), vtkXYPlotActor (1)
viewport (VIEWPORT, viewports)
  • vtkViewport (15), vtkCamera (12), vtkCoordinate (8), vtkXYPlotActor (5), vtkScalarBarActor (4), vtkActor2D (3), vtkCGMWriter (3), vtkCubeAxesActor2D (3), vtkInteractorStyle (3), vtkParallelCoordinatesActor (3), [...]
violated
  • vtkVolumeTextureMapper2D (1)
virtual
  • vtkLight (3), vtkCamera (2), vtkScaledTextActor (2), vtkAbstractTransform (1), vtkActor (1), vtkActor2D (1), vtkAssembly (1), vtkAxisActor2D (1), vtkCaptionActor2D (1), vtkCharArray (1), [...]
visibility
  • vtkAxisActor2D (4), vtkProp (3), vtkStructuredGrid (3), vtkPropAssembly (2), vtkProperty (2), vtkSelectVisiblePoints (2), vtkActor (1), vtkCubeAxesActor2D (1), vtkLODActor (1), vtkVolume (1)
visible
  • vtkSelectVisiblePoints (6), vtkRenderer (5), vtkAxisActor2D (3), vtkStructuredGrid (2), vtkTubeFilter (2), vtkBlankStructuredGrid (1), vtkBlankStructuredGridWithImage (1), vtkCubeAxesActor2D (1), vtkCursor3D (1), vtkDashedStreamLine (1), [...]
vision
  • vtkPCAAnalysisFilter (1)
visit (visited)
  • vtkImplicitModeller (4), vtkQuadricClustering (2)
visual
  • vtkXImageWindow (3), vtkXImageMapper (2), vtkAssignAttribute (1), vtkDashedStreamLine (1), vtkRearrangeFields (1), vtkSplitField (1), vtkStreamPoints (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
visualise
  • vtkPCAAnalysisFilter (1)
visualization
  • vtkDataObject (4), vtkProcessObject (4), vtkCell (2), vtkSource (2), vtkActor (1), vtkCellType (1), vtkConnectivityFilter (1), vtkDataSetReader (1), vtkDelaunay2D (1), vtkDicer (1), [...]
visualize (visualized, visualizing)
  • vtkPLOT3DReader (2), vtkShepardMethod (2), vtkCutter (1), vtkHyperStreamline (1), vtkPieceScalars (1), vtkProgrammableDataObjectSource (1), vtkSpherePuzzleArrows (1), vtkWeightedTransformFilter (1)
volue
  • vtkImageAppend (1)
volume (volumes)
  • vtkVolume (18), vtkVolumeProperty (16), vtkVolumeMapper (8), vtkImplicitVolume (7), vtkVolumeProMapper (7), vtkVolumeTextureMapper2D (7), vtkVolumeRayCastMapper (6), vtkVolumeRayCastStructures (6), vtkVolumeProVP1000Mapper (5), vtkVolumeTextureMapper (5), [...]
volumetric
  • vtkVolume (2), vtkAbstractMapper (1), vtkAbstractMapper3D (1), vtkCutter (1)
vorticity
  • vtkStreamer (11), vtkCellDerivatives (2), vtkStreamLine (2), vtkPLOT3DReader (1)
voxel (voxels)
  • vtkVoxelModeller (2), vtkVoxel (1), vtkImplicitModeller (10), vtkImageData (6), vtkGaussianSplatter (5), vtkImageAnisotropicDiffusion3D (5), vtkImageReslice (5), vtkImageAnisotropicDiffusion2D (4), vtkConnectivityFilter (3), vtkFiniteDifferenceGradientEstimator (3), [...]
voxelization
  • vtkVoxelModeller (1)
vx-vy-vz
  • vtkPoints (1)

w
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
wait (waiting)
  • vtkOutputPort (3), vtkDataObject (1), vtkImageStencilData (1), vtkSocketCommunicator (1), vtkSocketController (1)
walk
  • vtkDelaunay3D (1)
wall
  • vtkTimerLog (2), vtkCursor3D (1), vtkLightKit (1)
walltime
  • vtkTimerLog (2)
ward
  • vtkPerlinNoise (1)
warm
  • vtkLightKit (2)
warmer
  • vtkLightKit (2)
warmth
  • vtkLightKit (7)
warning (WARNING, warnings)
  • vtkVolume (11), vtkProp (10), vtkSetGet (6), vtkVolumeProperty (5), vtkDataObject (4), vtkVolumeRayCastMapper (4), vtkDecimate (3), vtkImageStencilData (3), vtkVolumeMapper (3), vtkCaptionActor2D (2), [...]
warp (warping)
  • vtkWarpScalar (5), vtkWarpTo (2), vtkWarpTransform (2), vtkWarpVector (1), vtkGaussianSplatter (4), vtkThinPlateSplineTransform (4), vtkGridTransform (2), vtkAbstractTransform (1), vtkImplicitFunction (1)
warranty (WARRANTY)
  • vtkPLY (2), vtkTreeComposite (1)
wasted
  • vtkVolumeRayCastMapper (1), vtkVolumeTextureMapper2D (1)
wave
  • vtkPolyDataNormals (2)
wavefront
  • vtkOBJReader (3), vtkOBJExporter (2), vtkExporter (1)
weaker
  • vtkLightKit (1)
website
  • vtkPCAAnalysisFilter (1)
wedge
  • vtkWedge (5), vtkCell3D (1), vtkLinearExtrusionFilter (1)
weight (weighted, weighting, weights)
  • vtkWeightedTransformFilter (15), vtkImplicitSum (9), vtkCell (4), vtkDataSet (4), vtkDataSetAttributes (3), vtkImplicitDataSet (2), vtkInterpolatedVelocityField (2), vtkCellData (1), vtkMassProperties (1), vtkPolygon (1), [...]
weird
  • vtkGaussianSplatter (1), vtkImplicitModeller (1)
west
  • vtkSuperquadric (1), vtkSuperquadricSource (1)
whatever
  • vtkCamera (1), vtkProperty (1), vtkRenderer (1), vtkVRMLImporter (1)
whenever
  • vtkAbstractTransform (2), vtkInteractorStyleUser (2), vtkCamera (1), vtkLandmarkTransform (1), vtkMultiProcessController (1), vtkPolyData (1), vtkRearrangeFields (1), vtkThinPlateSplineTransform (1)
whereas
  • vtkLabeledDataMapper (1), vtkLookupTable (1), vtkRenderWindowInteractor (1), vtkRungeKutta45 (1), vtkStructuredPoints (1), vtkTransformFilter (1), vtkTransformPolyDataFilter (1)
whethter
  • vtkExtractGeometry (1), vtkExtractPolyDataGeometry (1)
white (whites)
  • vtkLightKit (5), vtkGlyphSource2D (2), vtkLight (1), vtkProperty (1), vtkRenderer (1), vtkTextSource (1), vtkViewport (1)
widely
  • vtkDelaunay2D (1), vtkDelaunay3D (1)
widening
  • vtkWindowedSincPolyDataFilter (1)
widget (widgets)
  • vtkTkImageViewerWidget (6), vtkTkImageWindowWidget (6), vtkTkRenderWidget (6), vtkXRenderWindowInteractor (15), vtkXRenderWindowTclInteractor (15), vtkQuartzRenderWindowInteractor (2), vtkRenderWindowInteractor (2), vtkWin32RenderWindowInteractor (2)
width
  • vtkRibbonFilter (10), vtkButtonSource (4), vtkWarpLens (4), vtkCamera (2), vtkPlaneSource (2), vtkProjectedTexture (2), vtkProperty (2), vtkProperty2D (2), vtkActor2D (1), vtkArcPlotter (1), [...]
wildcards
  • vtkGenericEnSightReader (1)
window (windowed, windowing, windows)
  • vtkWin32OpenGLRenderWindow (29), vtkWinCEOpenGLRenderWindow (28), vtkQuartzRenderWindow (26), vtkXMesaRenderWindow (26), vtkXOpenGLRenderWindow (26), vtkRenderWindow (24), vtkWin32OpenGLImageWindow (22), vtkQuartzImageWindow (19), vtkXImageWindow (17), vtkWindow (16), [...]
wine
  • vtkRotationalExtrusionFilter (1)
wireframe
  • vtkCursor3D (6), vtkOutlineCornerFilter (2), vtkOutlineCornerSource (2), vtkOutlineFilter (2), vtkOutlineSource (2), vtkStructuredGridOutlineFilter (2), vtkEarthSource (1), vtkInteractorStyle (1), vtkProperty (1), vtkRectilinearGridOutlineFilter (1), [...]
wise
  • vtkContourFilter (2), vtkContourGrid (2), vtkGridSynchronizedTemplates3D (2), vtkImageMarchingCubes (2), vtkMarchingContourFilter (2), vtkMarchingCubes (2), vtkSynchronizedTemplates3D (2), vtkRenderWindow (1)
wishes
  • vtkInstantiator (1)
within
  • vtkCellLocator (9), vtkIdentityTransform (4), vtkLinearTransform (4), vtkSelectPolyData (4), vtkEncodedGradientEstimator (3), vtkImageStencilData (3), vtkImplicitWindowFunction (3), vtkXYPlotActor (3), vtkAbstractTransform (2), vtkCellArray (2), [...]
without (WITHOUT)
  • vtkIdentityTransform (4), vtkLinearTransform (4), vtkPLY (3), vtkPriorityQueue (3), vtkGeneralTransform (2), vtkHomogeneousTransform (2), vtkInteractorStyleUnicam (2), vtkWarpTransform (2), vtkXRenderWindowInteractor (2), vtkXRenderWindowTclInteractor (2), [...]
women
  • vtkLightKit (1)
woods
  • vtkVRML (1), vtkVRMLImporter (1)
work-around
  • vtkWarpTransform (1)
world (WORLD)
  • vtkWorldPointPicker (3), vtkProp3D (9), vtkViewport (6), vtkCoordinate (5), vtkRenderer (5), vtkCamera (4), vtkLight (4), vtkCaptionActor2D (2), vtkInteractorStyleUnicam (2), vtkPerspectiveTransform (2), [...]
world-coordinate
  • vtkCamera (1)
worry
  • vtkDecimate (1)
worse
  • vtkSimpleScalarTree (1)
wrap (wrapped, wrapping, wraps)
  • vtkImageWrapPad (1), vtkCursor3D (5), vtkDataArray (4), vtkMultiThreader (1), vtkPLY (1), vtkPriorityQueue (1), vtkProgrammableAttributeDataFilter (1), vtkTimeStamp (1), vtkVRMLImporter (1), vtkVideoSource (1), [...]
wrap-pad
  • vtkImageReslice (2)
wrapper (wrappers)
  • vtkDataArray (4), vtkInteractorStyle (2), vtkPythonUtil (2), vtkImageViewer (1), vtkImageViewer2 (1), vtkInstantiator (1), vtkMPIEventLog (1), vtkMapper (1), vtkMultiThreader (1), vtkProgrammableFilter (1)
writable
  • vtkStructuredPointsWriter (1)
write (writes, writing, written)
  • vtkDataWriter (14), vtkBYUWriter (11), vtkPDataSetWriter (8), vtkPLYWriter (7), vtkImageWriter (6), vtkWriter (6), vtkPImageWriter (4), vtkSTLWriter (4), vtkDataObjectWriter (3), vtkMCubesWriter (3), [...]
writer (writers)
  • vtkWriter (2), vtkBYUWriter (1), vtkCGMWriter (1), vtkImageBlockWriter (1), vtkImageWriter (1), vtkJPEGWriter (1), vtkMCubesWriter (1), vtkPDataSetWriter (1), vtkPImageWriter (1), vtkPNGWriter (1), [...]
wrong
  • vtkLODProp3D (2), vtkDataSetReader (1), vtkThreadedController (1)
wxyz (WXYZ)
  • vtkProp3D (1), vtkTransform (1)

x
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
x-axis
  • vtkXYPlotActor (7), vtkCone (1), vtkConeSource (1), vtkImageReslice (1), vtkTensorGlyph (1), vtkTextureMapToSphere (1)
x-component
  • vtkExtractVectorComponents (1), vtkPLOT3DReader (1)
x-direction
  • vtkCubeSource (1), vtkExtractTensorComponents (1), vtkRectilinearGrid (1), vtkTensorGlyph (1)
x-dx
  • vtkFiniteDifferenceGradientEstimator (1)
x-ellipsoid
  • vtkButtonSource (1)
x-origin
  • vtkPlane (1)
x-range
  • vtkXYPlotActor (1)
x-row
  • vtkImageStencilSource (2), vtkImageStencilData (1)
x-server
  • vtkXRenderWindowInteractor (1)
x-shadows
  • vtkCursor3D (1)
x-values
  • vtkParallelCoordinatesActor (1), vtkXYPlotActor (1)
ximg
  • vtkGESignaReader (2)
xnext
  • vtkInitialValueProblemSolver (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1)
xprev
  • vtkInitialValueProblemSolver (1), vtkRungeKutta2 (1), vtkRungeKutta4 (1), vtkRungeKutta45 (1)
xproj
  • vtkPlane (2)
xwindow (Xwindows)
  • vtkXMesaRenderWindow (2), vtkXOpenGLRenderWindow (2), vtkMesaImageWindow (1), vtkOpenGLImageWindow (1), vtkQuartzTextMapper (1), vtkWin32OpenGLTextMapper (1), vtkWin32TextMapper (1), vtkXMesaTextMapper (1), vtkXOpenGLTextMapper (1), vtkXTextMapper (1)

y
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
y-axis
  • vtkXYPlotActor (6), vtkCamera (1), vtkCylinder (1), vtkCylinderSource (1), vtkImageReslice (1), vtkSuperquadric (1), vtkTensorGlyph (1)
y-component
  • vtkExtractVectorComponents (1), vtkPLOT3DReader (1)
y-direction
  • vtkCubeSource (1), vtkRectilinearGrid (1), vtkTensorGlyph (1)
y-dy
  • vtkFiniteDifferenceGradientEstimator (1)
y-ellipsoid
  • vtkButtonSource (1)
y-max-value
  • vtkParallelCoordinatesActor (1)
y-min-value
  • vtkParallelCoordinatesActor (1)
y-shadows
  • vtkCursor3D (1)
yacc
  • vtkVRMLImporter (3), vtkVRML (1)
yield (yields)
  • vtkAxisActor2D (2), vtkRecursiveSphereDirectionEncoder (1), vtkRenderWindow (1), vtkSurfaceReconstructionFilter (1)
yourself
  • vtkAbstractTransform (1)

z
Navigation:
[A | B | C | D | E | F | G | H | I | J | L | M | N | O | P | R | S | T | U | V | X | a | b | c | d | e | f | g | h | i | j | k | l | m | n | o | p | q | r | s | t | u | v | w | x | y | z]
z-axis
  • vtkRotationalExtrusionFilter (4), vtkPlaneSource (2), vtkWarpScalar (2), vtkDelaunay2D (1), vtkGlyph2D (1), vtkGlyphSource2D (1), vtkImageReslice (1), vtkPlane (1), vtkTensorGlyph (1), vtkTextureMapToCylinder (1), [...]
z-buffer (z-buffered, z-buffering)
  • vtkCamera (4), vtkMapper (3), vtkRendererSource (3), vtkAbstractPicker (2), vtkSelectVisiblePoints (2), vtkCaptionActor2D (1)
z-component
  • vtkMath (4), vtkExtractVectorComponents (1), vtkPLOT3DReader (1), vtkTriangle (1)
z-coordinate
  • vtkDataObjectToDataSetFilter (1), vtkGlyphSource2D (1), vtkPointLocator2D (1), vtkPolyDataMapper2D (1)
z-direction
  • vtkCubeSource (1), vtkRectilinearGrid (1), vtkTensorGlyph (1)
z-dz
  • vtkFiniteDifferenceGradientEstimator (1)
z-eliipsoid
  • vtkButtonSource (1)
z-shadows
  • vtkCursor3D (1)
z-shift
  • vtkMapper (1)
z-value
  • vtkSelectVisiblePoints (1), vtkWarpScalar (1)
z-y-z
  • vtkDataObjectToDataSetFilter (1)
zbuffer
  • vtkRenderWindow (2), vtkVolumeRayCastMapper (2), vtkMesaRenderWindow (1), vtkOpenGLRenderWindow (1), vtkQuartzRenderWindow (1)
zero
  • vtkPiecewiseFunction (7), vtkDataObject (4), vtkDataReader (4), vtkEnSight6BinaryReader (4), vtkEnSightGoldBinaryReader (4), vtkImageMask (4), vtkRenderWindow (4), vtkEncodedGradientEstimator (3), vtkEncodedGradientShader (3), vtkAbstractList (2), [...]
zero-offset
  • vtkCellArray (1), vtkImageDataGeometryFilter (1), vtkRectilinearGridGeometryFilter (1), vtkStructuredGridGeometryFilter (1)
zfar
  • vtkPerspectiveTransform (2)
zhang
  • vtkWindowedSincPolyDataFilter (2)
znear
  • vtkPerspectiveTransform (2)
zone
  • vtkDEMReader (1)
zoom (zoomed, zooming)
  • vtkInteractorStyle (5), vtkInteractorStyleJoystickActor (3), vtkInteractorStyleJoystickCamera (2), vtkInteractorStyleTrackballActor (2), vtkInteractorStyleTrackballCamera (2), vtkCaptionActor2D (1), vtkImageMandelbrotSource (1), vtkInteractorStyleImage (1), vtkRenderWindowInteractor (1)
zoom-in
  • vtkCamera (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
zoom-out
  • vtkCamera (1), vtkXRenderWindowInteractor (1), vtkXRenderWindowTclInteractor (1)
zoomm
  • vtkInteractorStyleImage (1)
zorin
  • vtkButterflySubdivisionFilter (1)
zplane
  • vtkPerspectiveTransform (1)
zslice
  • vtkImageMapper (2)
Generated on Mon Mar 25 01:37:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Alphabetical index

VTK Compound Index

3
vtkImageMultipleInputFilter vtkProcessObject
vtk3DSImporter vtkImageMultipleInputOutputFilter vtkProcessStatistics
_
vtkImageNoiseSource vtkProcrustesAlignmentFilter
_vtkLink_s vtkImageNonMaximumSuppression vtkProgrammableAttributeDataFilter
_vtkLocalTri vtkImageNormalize vtkProgrammableDataObjectSource
_vtkLocalVertex vtkImageOpenClose3D vtkProgrammableFilter
_vtkPriorityItem vtkImagePadFilter vtkProgrammableGlyphFilter
_vtkProLocalTri vtkImagePermute vtkProgrammableSource
_vtkProLocalVertex vtkImageProgressIterator vtkProjectedTexture
_vtkStreamPoint vtkImageQuantizeRGBToIndex vtkProp
_vtkTclVoidFuncArg vtkImager vtkProp3D
A
vtkImageRange3D vtkProp3DCollection
vtkAbstractList vtkImagerCollection vtkPropAssembly
vtkAbstractMapper vtkImageReader vtkPropCollection
vtkAbstractMapper3D vtkImageReader2 vtkProperty
vtkAbstractPicker vtkImageReader2Collection vtkProperty2D
vtkAbstractPropPicker vtkImageReader2Factory vtkPropPicker
vtkAbstractTransform vtkImageResample vtkProTriArray
vtkActor vtkImageReslice vtkProVertexArray
vtkActor2D vtkImageRFFT vtkPSphereSource
vtkActor2DCollection vtkImageRGBToHSV vtkPVGeometryFilter
vtkActorCollection vtkImageSeedConnectivity vtkPyramid
vtkAppendFilter vtkImageSeparableConvolution vtkPythonCommand
vtkAppendPolyData vtkImageShiftScale PyVTKClass
vtkApproximatingSubdivisionFilter vtkImageShrink3D PyVTKObject
vtkArcPlotter vtkImageSinusoidSource PyVTKSpecialObject
vtkArrayCalculator vtkImageSkeleton2D
Q
vtkArrowSource vtkImageSobel2D vtkQuad
vtkAssembly vtkImageSobel3D vtkQuadraticEdge
vtkAssemblyNode vtkImageSource vtkQuadric
vtkAssemblyPath vtkImageSpatialFilter vtkQuadricClustering
vtkAssemblyPaths vtkImageStencil vtkQuadricDecimation
vtkAssignAttribute vtkImageStencilData vtkQuantizePolyDataPoints
vtkAttributeDataToFieldDataFilter vtkImageStencilSource vtkQuartzGLView
vtkAxes vtkImageThreshold vtkQuartzImageMapper
vtkAxisActor2D vtkImageToImageFilter vtkQuartzImageWindow
B
vtkImageToImageStencil vtkQuartzRenderWindow
vtkBandedPolyDataContourFilter vtkImageToPolyDataFilter vtkQuartzRenderWindowInteractor
vtkBitArray vtkImageToStructuredPoints vtkQuartzTextMapper
vtkBlankStructuredGrid vtkImageTranslateExtent vtkQuartzWindow
vtkBlankStructuredGridWithImage vtkImageTwoInputFilter
R
vtkBMPReader vtkImageVariance3D vtkRayCaster
vtkBMPWriter vtkImageViewer vtkRayCastStructures
vtkBooleanTexture vtkImageViewer2 vtkRearrangeFields
vtkBranchExtentTranslator vtkImageWindow vtkRearrangeFields::Operation
vtkBrownianPoints vtkImageWrapPad vtkRectilinearGrid
vtkButterflySubdivisionFilter vtkImageWriter vtkRectilinearGridGeometryFilter
vtkButtonSource vtkImagingFactory vtkRectilinearGridOutlineFilter
vtkByteSwap vtkImplicitBoolean vtkRectilinearGridReader
vtkBYUReader vtkImplicitDataSet vtkRectilinearGridSource
vtkBYUWriter vtkImplicitFunction vtkRectilinearGridToPolyDataFilter
C
vtkImplicitFunctionCollection vtkRectilinearGridWriter
vtkCallbackCommand vtkImplicitFunctionToImageStencil vtkRecursiveDividingCubes
Camera vtkImplicitModeller vtkRecursiveSphereDirectionEncoder
vtkCamera vtkImplicitSelectionLoop vtkReferenceCount
vtkCaptionActor2D vtkImplicitSum vtkReflectionFilter
vtkCardinalSpline vtkImplicitTextureCoords vtkRenderer
vtkCastToConcrete vtkImplicitVolume vtkRendererCollection
vtkCell vtkImplicitWindowFunction vtkRendererSource
vtkCell3D vtkImporter vtkRenderLargeImage
vtkCellArray vtkIndent vtkRenderWindow
vtkCellCenters vtkInitialValueProblemSolver vtkRenderWindowCollection
vtkCellData vtkInputPort vtkRenderWindowInteractor
vtkCellDataToPointData vtkInstantiator vtkReverseSense
vtkCellDerivatives vtkInstantiatorInitialize vtkRibbonFilter
vtkCellLinks vtkIntArray vtkRIBExporter
vtkCellLocator vtkInteractorStyle vtkRIBLight
vtkCellPicker vtkInteractorStyleFlight vtkRIBProperty
vtkCellType vtkInteractorStyleImage vtkRotationalExtrusionFilter
vtkCellTypes vtkInteractorStyleJoystickActor vtkRTAnalyticSource
vtkCGMWriter vtkInteractorStyleJoystickCamera vtkRuledSurfaceFilter
vtkCharArray vtkInteractorStyleSwitch vtkRungeKutta2
Chunk vtkInteractorStyleTrackball vtkRungeKutta4
vtkCleanPolyData vtkInteractorStyleTrackballActor vtkRungeKutta45
vtkClipDataSet vtkInteractorStyleTrackballCamera
S
vtkClipPolyData vtkInteractorStyleUnicam vtkSampleFunction
vtkClipVolume vtkInteractorStyleUser vtkScalarBarActor
vtkCollection vtkInterpolateDataSetAttributes vtkScalarsToColors
vtkCollectionElement vtkInterpolatedVelocityField vtkScalarTree
vtkColorTransferFunction vtkInterpolatingSubdivisionFilter vtkScaledTextActor
Colour istream vtkSelectPolyData
Colour_24 vtkIterativeClosestPointTransform vtkSelectVisiblePoints
vtkCommand vtkIVExporter SetGet
vtkCommunicator vtkIVWriter vtkSharedMemoryCommunicator
vtkCompositeManager
J
vtkShepardMethod
vtkCone vtkJavaCommand vtkShortArray
vtkConeSource vtkJavaVoidFuncArg vtkShrinkFilter
vtkConnectivityFilter vtkJPEGReader vtkShrinkPolyData
vtkContainer vtkJPEGWriter vtkSimpleCriticalSection
vtkContourFilter
K
vtkSimpleElevationFilter
vtkContourGrid vtkKitwareContourFilter vtkSimpleImageFilterExample
vtkContourValues vtkKitwareObjectFactory vtkSimpleImageToImageFilter
vtkCoordinate vtkKochanekSpline vtkSimpleMutexLock
vtkCriticalSection
L
vtkSimpleScalarTree
vtkCubeAxesActor2D vtkLabeledDataMapper vtkSLCReader
vtkCubeSource vtkLandmarkTransform vtkSliceCubes
vtkCuller vtkLargeInteger vtkSmoothPolyDataFilter
vtkCullerCollection vtkLegendBoxActor vtkSocketCommunicator
vtkCursor3D vtkLight vtkSocketController
vtkCutMaterial vtkLightCollection vtkSource
vtkCutter vtkLightKit vtkSpatialRepresentationFilter
vtkCylinder vtkLine vtkSphere
vtkCylinderSource vtkLinearExtrusionFilter vtkSpherePuzzle
D
vtkLinearSubdivisionFilter vtkSpherePuzzleArrows
vtkDashedStreamLine vtkLinearTransform vtkSphereSource
vtkDataArray vtkLineSource vtkSpline
vtkDataObject vtkLinkEdgels vtkSplitField
vtkDataObjectCollection List vtkSplitField::Component
vtkDataObjectReader vtkLocator SpotLight
vtkDataObjectSource vtkLODActor vtkSTLReader
vtkDataObjectToDataSetFilter vtkLODProp3D vtkSTLWriter
vtkDataObjectWriter vtkLODProp3DEntry vtkStreamArray
vtkDataReader vtkLogLookupTable vtkStreamer
vtkDataSet vtkLongArray vtkStreamLine
vtkDataSetAttributes vtkLookupTable vtkStreamPoints
vtkDataSetAttributes::FieldList vtkLoopSubdivisionFilter vtkStripper
vtkDataSetCollection
M
vtkStructuredData
vtkDataSetMapper vtkMapper vtkStructuredGrid
vtkDataSetReader vtkMapper2D vtkStructuredGridGeometryFilter
vtkDataSetSource vtkMapperCollection vtkStructuredGridOutlineFilter
vtkDataSetSurfaceFilter vtkMarchingContourFilter vtkStructuredGridReader
vtkDataSetToDataObjectFilter vtkMarchingCubes vtkStructuredGridSource
vtkDataSetToDataSetFilter vtkMarchingSquares vtkStructuredGridToPolyDataFilter
vtkDataSetToPolyDataFilter vtkMaskFields vtkStructuredGridToStructuredGridFilter
vtkDataSetToStructuredGridFilter vtkMaskFields::CopyFieldFlag vtkStructuredGridWriter
vtkDataSetToStructuredPointsFilter vtkMaskPoints vtkStructuredPoints
vtkDataSetToUnstructuredGridFilter vtkMaskPolyData vtkStructuredPointsCollection
vtkDataSetTriangleFilter vtkMassProperties vtkStructuredPointsGeometryFilter
vtkDataSetWriter Material vtkStructuredPointsReader
vtkDataWriter vtkMath vtkStructuredPointsSource
vtkDebugLeaks MatProp vtkStructuredPointsToPolyDataFilter
vtkDecimate vtkMatrix4x4 vtkStructuredPointsToStructuredPointsFilter
vtkDecimatePro vtkMatrixToHomogeneousTransform vtkStructuredPointsToUnstructuredGridFilter
vtkDelaunay2D vtkMatrixToLinearTransform vtkStructuredPointsWriter
vtkDelaunay3D vtkMCubesReader vtkSubdivideTetra
vtkDEMReader vtkMCubesWriter vtkSubPixelPositionEdgels
vtkDepthSortPolyData vtkMedicalImageReader2 Summary
vtkDicer vtkMemoryLimitImageDataStreamer vtkSuperquadric
vtkDirectionEncoder vtkMergeDataObjectFilter vtkSuperquadricSource
vtkDirectory vtkMergeFields vtkSurfaceReconstructionFilter
vtkDiskSource vtkMergeFields::Component vtkSweptSurface
vtkDividingCubes vtkMergeFilter vtkSynchronizedTemplates2D
vtkDoubleArray vtkMergePoints vtkSynchronizedTemplates3D
vtkDynamicLoader vtkMergePoints2D vtkSystemIncludes
E
vtkMesaActor
T
vtkEarthSource vtkMesaCamera vtkTclCommand
vtkEdgePoints vtkMesaImageActor vtkTclCommandArgStruct
vtkEdgeTable vtkMesaImageMapper vtkTclCommandStruct
vtkElevationFilter vtkMesaImager vtkTclInterpStruct
vtkEmptyCell vtkMesaImageWindow vtkTensor
vtkEncodedGradientEstimator vtkMesaLight vtkTensorGlyph
vtkEncodedGradientShader vtkMesaPolyDataMapper vtkTetra
vtkEnSight6BinaryReader vtkMesaPolyDataMapper2D vtkTextMapper
vtkEnSight6Reader vtkMesaProperty vtkTextSource
vtkEnSightGoldBinaryReader vtkMesaRenderer vtkTexture
vtkEnSightGoldReader vtkMesaRenderWindow vtkTexturedSphereSource
vtkEnSightReader vtkMesaTexture vtkTextureMapToCylinder
vtkErrorCode vtkMesaVolumeRayCastMapper vtkTextureMapToPlane
vtkExplicitCell vtkMesaVolumeTextureMapper2D vtkTextureMapToSphere
vtkExporter Mesh vtkThinPlateSplineTransform
vtkExtentTranslator vtkMILVideoSource vtkThreadedController
vtkExtractEdges vtkMPICommunicator ThreadInfoStruct
vtkExtractGeometry vtkMPICommunicator::Request vtkThreadSafeLog
vtkExtractGrid vtkMPIController vtkThreshold
vtkExtractPolyDataGeometry vtkMPIEventLog vtkThresholdPoints
vtkExtractPolyDataPiece vtkMPIGroup vtkThresholdTextureCoords
vtkExtractTensorComponents vtkMultiProcessController vtkTIFFReader
vtkExtractUnstructuredGrid vtkMultiProcessLog vtkTIFFWriter
vtkExtractUnstructuredGridPiece vtkMultiThreader vtkTimerLog
vtkExtractVectorComponents vtkMutexLock vtkTimerLogEntry
vtkExtractVOI
N
vtkTimeStamp
F
vtkNonLinearCell vtkTkImageViewerWidget
Face NSOpenGLView vtkTkImageWindowWidget
vtkFeatureEdges NSWindow vtkTkRenderWidget
vtkFieldData
O
vtkTransform
vtkFieldData::BasicIterator vtkOBBDicer vtkTransformCollection
vtkFieldData::CopyFieldFlag vtkOBBNode vtkTransformConcatenation
vtkFieldData::Iterator vtkOBBTree vtkTransformConcatenationStack
vtkFieldDataToAttributeDataFilter vtkObject vtkTransformFilter
vtkFileOutputWindow vtkObjectFactory vtkTransformPair
vtkFiniteDifferenceGradientEstimator vtkObjectFactory::OverrideInformation vtkTransformPolyDataFilter
vtkFloatArray vtkObjectFactoryCollection vtkTransformTextureCoords
vtkFollower vtkOBJExporter vtkTransformToGrid
vtkFrustumCoverageCuller vtkOBJReader vtkTransmitPolyDataPiece
vtkFunctionParser ofstream vtkTransmitUnstructuredGridPiece
vtkFunctionSet vtkOldStyleCallbackCommand vtkTreeComposite
G
OmniLight vtkTriangle
vtkGaussianSplatter vtkOOGLExporter vtkTriangleFilter
vtkGeneralTransform vtkOpenGLActor vtkTriangleStrip
vtkGenericCell vtkOpenGLCamera vtkTriangularTCoords
vtkGenericEnSightReader vtkOpenGLImageActor vtkTriangularTexture
vtkGeometryFilter vtkOpenGLImageMapper vtkTriArray
vtkGESignaReader vtkOpenGLImager vtkTubeFilter
vtkGLUTesselatorTriangleFilter vtkOpenGLImageWindow
U
vtkGlyph2D vtkOpenGLLight vtkUGFacetReader
vtkGlyph3D vtkOpenGLPolyDataMapper vtkUnsignedCharArray
vtkGlyphSource2D vtkOpenGLPolyDataMapper2D vtkUnsignedIntArray
vtkGraphicsFactory vtkOpenGLProperty vtkUnsignedLongArray
vtkGraphLayoutFilter vtkOpenGLRenderer vtkUnsignedShortArray
vtkGridSynchronizedTemplates3D vtkOpenGLRenderWindow vtkUnstructuredGrid
vtkGridTransform vtkOpenGLStateCache vtkUnstructuredGridReader
H
vtkOpenGLTexture vtkUnstructuredGridSource
vtkHeap vtkOpenGLVolumeProVG500Mapper vtkUnstructuredGridToPolyDataFilter
vtkHeapNode vtkOpenGLVolumeProVP1000Mapper vtkUnstructuredGridToUnstructuredGridFilter
vtkHedgeHog vtkOpenGLVolumeRayCastMapper vtkUnstructuredGridWriter
vtkHexahedron vtkOpenGLVolumeTextureMapper2D
V
vtkHomogeneousTransform vtkOrderedTriangulator vtkVectorDot
vtkHull ostream vtkVectorNorm
vtkHyperStreamline ostrhelp vtkVectorText
I
ostrstream VectorType
vtkIdentityTransform OtherData vtkVersion
vtkIdFilter OtherElem vtkVertex
vtkIdList vtkOutlineCornerFilter vtkVertexArray
vtkIdTypeArray vtkOutlineCornerSource vtkVideoSource
vtkImageAccumulate vtkOutlineFilter vtkViewport
vtkImageActor vtkOutlineSource vtkVoidArray
vtkImageAnisotropicDiffusion2D vtkOutputPort vtkVolume
vtkImageAnisotropicDiffusion3D vtkOutputWindow vtkVolume16Reader
vtkImageAppend vtkOutputWindowSmartPointer vtkVolumeCollection
vtkImageAppendComponents vtkOverrideInformation vtkVolumeMapper
vtkImageBlend vtkOverrideInformationCollection vtkVolumeProMapper
vtkImageBlockReader
P
vtkVolumeProperty
vtkImageBlockWriter vtkParallelCoordinatesActor vtkVolumeProVG500Mapper
vtkImageButterworthHighPass vtkParallelFactory vtkVolumeProVP1000Mapper
vtkImageButterworthLowPass vtkParticleReader vtkVolumeRayCastCompositeFunction
vtkImageCacheFilter vtkPCAAnalysisFilter vtkVolumeRayCastFunction
vtkImageCanvasSource2D vtkPCellDataToPointData vtkVolumeRayCastIsosurfaceFunction
vtkImageCanvasSource2DPixel vtkPDataSetReader vtkVolumeRayCastMapper
vtkImageCast vtkPDataSetWriter vtkVolumeRayCastMIPFunction
vtkImageChangeInformation vtkPerlinNoise vtkVolumeRayCastStructures
vtkImageCheckerboard vtkPerspectiveTransform vtkVolumeReader
vtkImageCityBlockDistance vtkPicker vtkVolumeTextureMapper
vtkImageClip vtkPieceScalars vtkVolumeTextureMapper2D
vtkImageConnector vtkPiecewiseFunction vtkVoxel
vtkImageConnectorSeed vtkPiecewiseFunctionShiftScale vtkVoxelContoursToSurfaceFilter
vtkImageConstantPad vtkPiecewiseFunctionSource vtkVoxelModeller
vtkImageContinuousDilate3D vtkPiecewiseFunctionToPiecewiseFunctionFilter vtkVRMLAllocator
vtkImageContinuousErode3D vtkPImageWriter vtkVRMLExporter
vtkImageConvolve vtkPipelineSize vtkVRMLImporter
vtkImageCorrelation vtkPixel VTK_ERROR_QUADRIC
vtkImageCursor3D vtkPlane VTK_LINE_CASES
vtkImageData vtkPlaneCollection VTK_POINT_QUADRIC
vtkImageDataGeometryFilter vtkPlanes VTK_TRIANGLE_CASES
vtkImageDataStreamer vtkPlaneSource VTKRayCastRayInfo
vtkImageDecomposeFilter vtkPLinearExtrusionFilter VTKRayCastVolumeInfo
vtkImageDifference vtkPLOT3DReader VTKVRCDynamicInfo
vtkImageDilateErode3D vtkPLY VTKVRCStaticInfo
vtkImageDivergence PlyElement
W
vtkImageDotProduct PlyFile vtkWarpLens
vtkImageEllipsoidSource PlyOtherElems vtkWarpScalar
vtkImageEuclideanDistance PlyOtherProp vtkWarpTo
vtkImageEuclideanToPolar PlyProperty vtkWarpTransform
vtkImageExport vtkPLYReader vtkWarpVector
vtkImageExtractComponents vtkPLYWriter vtkWedge
vtkImageFFT vtkPNGReader vtkWeightedTransformFilter
vtkImageFlip vtkPNGWriter vtkWin32Header
vtkImageFourierCenter vtkPNMReader vtkWin32ImageMapper
vtkImageFourierFilter vtkPNMWriter vtkWin32ImageWindow
vtkImageGaussianSmooth vtkPointData vtkWin32OpenGLImageWindow
vtkImageGaussianSource vtkPointDataToCellData vtkWin32OpenGLRenderWindow
vtkImageGradient vtkPointLoad vtkWin32OpenGLTextMapper
vtkImageGradientMagnitude vtkPointLocator vtkWin32OutputWindow
vtkImageGridSource vtkPointLocator2D vtkWin32PolyDataMapper2D
vtkImageHSVToRGB vtkPointPicker vtkWin32RenderWindowInteractor
vtkImageHybridMedian2D vtkPoints vtkWin32TextMapper
vtkImageIdealHighPass vtkPointSet vtkWin32VideoSource
vtkImageIdealLowPass vtkPointSetSource vtkWinCE
vtkImageImport vtkPointSetToPointSetFilter vtkWinCEOpenGLRenderWindow
vtkImageInPlaceFilter vtkPointSource vtkWindow
vtkImageIslandRemoval2D vtkPolyData vtkWindowedSincPolyDataFilter
vtkImageIterateFilter vtkPolyDataCollection vtkWindowLevelLookupTable
vtkImageIterator vtkPolyDataConnectivityFilter vtkWindowToImageFilter
vtkImageLaplacian vtkPolyDataMapper vtkWorldPointPicker
vtkImageLogarithmicScale vtkPolyDataMapper2D vtkWriter
vtkImageLogic vtkPolyDataNormals
X
vtkImageLuminance vtkPolyDataReader vtkXImageMapper
vtkImageMagnify vtkPolyDataSource vtkXImageWindow
vtkImageMagnitude vtkPolyDataStreamer vtkXMesaRenderWindow
vtkImageMandelbrotSource vtkPolyDataToImageStencil vtkXMesaTextMapper
vtkImageMapper vtkPolyDataToPolyDataFilter vtkXMLFileOutputWindow
vtkImageMapToColors vtkPolyDataWriter vtkXMLParser
vtkImageMapToRGBA vtkPolygon vtkXOpenGLRenderWindow
vtkImageMapToWindowLevelColors vtkPolyLine vtkXOpenGLTextMapper
vtkImageMarchingCubes vtkPolyVertex vtkXPolyDataMapper2D
vtkImageMask vtkPOPReader vtkXRenderWindowInteractor
vtkImageMaskBits vtkPostScriptWriter vtkXRenderWindowTclInteractor
vtkImageMathematics vtkPPolyDataNormals vtkXTextMapper
vtkImageMedian3D vtkPriorityQueue vtkXYPlotActor
vtkImageMirrorPad vtkProbeFilter
Generated on Mon Mar 25 01:15:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VectorType Member List

This is the complete list of members for VectorType, including all inherited members.
  • Allocated [protected]
  • Count(void) const [inline]
  • Data [protected]
  • Demand(int newSize) [inline]
  • Get(int index) const [inline]
  • Init() [inline]
  • operator delete(void *) [inline]
  • operator new(size_t n) [inline]
  • operator T *() const [inline]
  • operator+=(T datum) [inline]
  • operator[](int index) [inline]
  • Pop() [inline]
  • Push(T datum) [inline]
  • Reserve(int newSize) [inline]
  • Top() [inline]
  • Used [protected]
  • UseNew
  • VectorType() [inline]
  • VectorType(int usenew) [inline]
  • ~VectorType(void) [inline]
Generated on Mon Mar 25 01:33:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtk3DSImporter Member List

This is the complete list of members for vtk3DSImporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CameraList
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FileFD [protected]
  • FileName [protected]
  • GeneratePolyData(Mesh *meshPtr) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeNormals() [virtual]
  • GetDebug()
  • GetFileFD() [inline]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImportActors(vtkRenderer *renderer) [protected, virtual]
  • vtkImporter::ImportActors(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportBegin() [protected, virtual]
  • ImportCameras(vtkRenderer *renderer) [protected, virtual]
  • vtkImporter::ImportCameras(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportEnd() [protected, virtual]
  • ImportLights(vtkRenderer *renderer) [protected, virtual]
  • vtkImporter::ImportLights(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportProperties(vtkRenderer *renderer) [protected, virtual]
  • vtkImporter::ImportProperties(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaterialList
  • MatPropList
  • MeshList
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OmniList
  • operator=(const vtk3DSImporter &) (defined in vtk3DSImporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Read()
  • Read3DS() [protected]
  • ReadData() [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetComputeNormals(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SpotLightList
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline]
  • vtk3DSImporter() [protected]
  • vtk3DSImporter(const vtk3DSImporter &) (defined in vtk3DSImporter) [private]
  • vtkImporter() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtk3DSImporter, vtkImporter)
  • ~vtk3DSImporter() [protected]
  • ~vtkImporter() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractList Member List

This is the complete list of members for vtkAbstractList, including all inherited members.
  • AppendItem(DType a)=0 [pure virtual]
  • CompareFunction typedef
  • Delete() [inline]
  • FindItem(DType a, unsigned long &res)=0 [pure virtual]
  • FindItem(DType a, CompareFunction compare, unsigned long &res)=0 [pure virtual]
  • GetItem(unsigned long id, DType &ret)=0 [pure virtual]
  • GetNumberOfItems()=0 [pure virtual]
  • InsertItem(unsigned long loc, DType a)=0 [pure virtual]
  • PrependItem(DType a)=0 [pure virtual]
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • RemoveAllItems()=0 [pure virtual]
  • RemoveItem(unsigned long id)=0 [pure virtual]
  • SetItem(unsigned long loc, DType a)=0 [pure virtual]
  • SetItemNoCheck(unsigned long loc, DType a)=0 [pure virtual]
  • SetSize(unsigned long size)=0 [pure virtual]
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • vtkContainer() [inline, protected]
  • ~vtkContainer() [inline, protected, virtual]
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractMapper3D Member List

This is the complete list of members for vtkAbstractMapper3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetBounds()=0 [pure virtual]
  • GetBounds(float bounds[6]) [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLength()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAbstractMapper3D &) (defined in vtkAbstractMapper3D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()=0 [pure virtual]
  • UpdateProgress(float amount)
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkAbstractMapper3D(const vtkAbstractMapper3D &) (defined in vtkAbstractMapper3D) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkAbstractMapper3D, vtkAbstractMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:15:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractMapper Member List

This is the complete list of members for vtkAbstractMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAbstractMapper &) (defined in vtkAbstractMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper(const vtkAbstractMapper &) (defined in vtkAbstractMapper) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkAbstractMapper, vtkProcessObject)
  • ~vtkAbstractMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:15:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractPicker Member List

This is the complete list of members for vtkAbstractPicker, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkAbstractPicker &) (defined in vtkAbstractPicker) [private]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)=0 [pure virtual]
  • Pick(float selectionPt[3], vtkRenderer *ren) [inline]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPicker(const vtkAbstractPicker &) (defined in vtkAbstractPicker) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAbstractPicker, vtkObject)
  • ~vtkAbstractPicker() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractPropPicker Member List

This is the complete list of members for vtkAbstractPropPicker, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetActor() [virtual]
  • GetActor2D() [virtual]
  • GetAssembly() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPath() [virtual]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetProp() [virtual]
  • GetProp3D() [virtual]
  • GetPropAssembly() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GetVolume() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkAbstractPropPicker &) (defined in vtkAbstractPropPicker) [private]
  • Path [protected]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer)=0 [pure virtual]
  • Pick(float selectionPt[3], vtkRenderer *ren) [inline]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPath(vtkAssemblyPath *) [virtual]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPropPicker() [protected]
  • vtkAbstractPropPicker(const vtkAbstractPropPicker &) (defined in vtkAbstractPropPicker) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAbstractPropPicker, vtkAbstractPicker)
  • ~vtkAbstractPicker() [protected]
  • ~vtkAbstractPropPicker() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAbstractTransform Member List

This is the complete list of members for vtkAbstractTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • DependsOnInverse (defined in vtkAbstractTransform) [private]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInverse()
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *) [inline, protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3])=0 [pure virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3])=0 [pure virtual]
  • InternalTransformPoint(const float in[3], float out[3])=0 [pure virtual]
  • InternalTransformPoint(const double in[3], double out[3])=0 [pure virtual]
  • InternalUpdate() [inline, protected, virtual]
  • InUnRegister (defined in vtkAbstractTransform) [private]
  • Inverse()=0 [pure virtual]
  • InverseMutex (defined in vtkAbstractTransform) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MyInverse (defined in vtkAbstractTransform) [private]
  • New() [inline, static]
  • operator=(const vtkAbstractTransform &) (defined in vtkAbstractTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • UpdateMutex (defined in vtkAbstractTransform) [private]
  • UpdateTime (defined in vtkAbstractTransform) [private]
  • vtkAbstractTransform() [protected]
  • vtkAbstractTransform(const vtkAbstractTransform &) (defined in vtkAbstractTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAbstractTransform, vtkObject)
  • ~vtkAbstractTransform() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkActor2D Member List

This is the complete list of members for vtkActor2D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetLayerNumber() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LayerNumber [protected]
  • Mapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkActor2D &) (defined in vtkActor2D) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetLayerNumber(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkActor2D(const vtkActor2D &) (defined in vtkActor2D) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkActor2D, vtkProp)
  • ~vtkActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:15:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkActor2DCollection Member List

This is the complete list of members for vtkActor2DCollection, including all inherited members.
  • AddItem(vtkActor2D *a)
  • AddItem(vtkObject *o) (defined in vtkActor2DCollection) [inline, private]
  • AddItem(vtkProp *o) (defined in vtkActor2DCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastActor2D() [inline]
  • GetLastItem() [inline]
  • GetLastProp() [inline]
  • GetMTime() [virtual]
  • GetNextActor2D() [inline]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNextProp() [inline]
  • GetNumberOfItems()
  • GetNumberOfPaths()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkActor2D *a) [inline]
  • IsItemPresent(vtkObject *o) (defined in vtkActor2DCollection) [inline, private]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkActor2DCollection &) (defined in vtkActor2DCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOverlay(vtkViewport *viewport)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Sort()
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkActor2DCollection() [inline, protected]
  • vtkActor2DCollection(const vtkActor2DCollection &) (defined in vtkActor2DCollection) [private]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPropCollection() [inline, protected]
  • vtkTypeRevisionMacro(vtkActor2DCollection, vtkPropCollection)
  • ~vtkActor2DCollection() [protected]
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPropCollection() [inline, protected]
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkActor Member List

This is the complete list of members for vtkActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ApplyProperties() [inline, virtual]
  • BackfaceProperty [protected]
  • Bounds [protected]
  • BoundsMTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBackfaceProperty()
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetIsOpaque() [protected]
  • GetLength()
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPart() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfParts() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetTexture() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPartTraversal() [virtual]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • MakeProperty() [virtual]
  • Mapper [protected]
  • MapperBounds [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkActor &) (defined in vtkActor) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkMapper *) [inline, virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBackfaceProperty(vtkProperty *lut)
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkMapper *) [virtual]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkProperty *lut)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetTexture(vtkTexture *) [virtual]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Texture [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor() [protected]
  • vtkActor(const vtkActor &) (defined in vtkActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkActor, vtkProp3D)
  • ~vtkActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:15:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkActorCollection Member List

This is the complete list of members for vtkActorCollection, including all inherited members.
  • AddItem(vtkActor *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkActorCollection) [inline, private]
  • AddItem(vtkProp *o) (defined in vtkActorCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplyProperties(vtkProperty *p)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastActor() [inline]
  • GetLastItem() [inline]
  • GetLastProp() [inline]
  • GetMTime() [virtual]
  • GetNextActor() [inline]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNextProp() [inline]
  • GetNumberOfItems()
  • GetNumberOfPaths()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkActorCollection &) (defined in vtkActorCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkActorCollection() [inline, protected]
  • vtkActorCollection(const vtkActorCollection &) (defined in vtkActorCollection) [private]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPropCollection() [inline, protected]
  • vtkTypeRevisionMacro(vtkActorCollection, vtkPropCollection)
  • ~vtkActorCollection() [inline, protected]
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPropCollection() [inline, protected]
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAppendFilter Member List

This is the complete list of members for vtkAppendFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataSet *in)
  • AddInput(vtkDataObject *) (defined in vtkAppendFilter) [inline, private, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int idx)
  • GetInput() [inline]
  • GetInputList()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputList [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAppendFilter &) (defined in vtkAppendFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataSet *in)
  • RemoveInput(vtkDataObject *input) (defined in vtkAppendFilter) [inline, private, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkAppendFilter() [protected]
  • vtkAppendFilter(const vtkAppendFilter &) (defined in vtkAppendFilter) [private]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkAppendFilter, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkAppendFilter() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:15:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAppendPolyData Member List

This is the complete list of members for vtkAppendPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkPolyData *)
  • AddInput(vtkDataObject *) (defined in vtkAppendPolyData) [inline, private, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AppendCells(vtkIdType *pDest, vtkCellArray *src, vtkIdType offset) [protected]
  • AppendData(vtkDataArray *dest, vtkDataArray *src, vtkIdType offset) [protected]
  • AppendDifferentPoints(vtkDataArray *dest, vtkDataArray *src, vtkIdType offset) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int idx)
  • GetInput() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetParallelStreaming() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUserManagedInputs() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAppendPolyData &) (defined in vtkAppendPolyData) [private]
  • Outputs [protected]
  • ParallelStreaming [protected]
  • ParallelStreamingOff() [virtual]
  • ParallelStreamingOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkPolyData *)
  • RemoveInput(vtkDataObject *input) (defined in vtkAppendPolyData) [inline, private, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetInputByNumber(int num, vtkPolyData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num)
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetParallelStreaming(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUserManagedInputs(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UserManagedInputs (defined in vtkAppendPolyData) [private]
  • UserManagedInputsOff() [virtual]
  • UserManagedInputsOn() [virtual]
  • vtkAppendPolyData() [protected]
  • vtkAppendPolyData(const vtkAppendPolyData &) (defined in vtkAppendPolyData) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkAppendPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkAppendPolyData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkApproximatingSubdivisionFilter Member List

This is the complete list of members for vtkApproximatingSubdivisionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindEdge(vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds) [protected]
  • GenerateSubdivisionCells(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD) [protected]
  • GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)=0 [protected, pure virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSubdivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolatePosition(vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubdivisions [protected]
  • operator=(const vtkApproximatingSubdivisionFilter &) (defined in vtkApproximatingSubdivisionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSubdivisions(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkApproximatingSubdivisionFilter() [protected]
  • vtkApproximatingSubdivisionFilter(const vtkApproximatingSubdivisionFilter &) (defined in vtkApproximatingSubdivisionFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkApproximatingSubdivisionFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkApproximatingSubdivisionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkArcPlotter Member List

This is the complete list of members for vtkArcPlotter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • ActiveComponent (defined in vtkArcPlotter) [private]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Camera [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Data (defined in vtkArcPlotter) [private]
  • DataRange (defined in vtkArcPlotter) [private]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultNormal [protected]
  • Delete() [virtual]
  • EndComp (defined in vtkArcPlotter) [private]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FieldDataArray [protected]
  • GetAbortExecute() [virtual]
  • GetCamera() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultNormal() [virtual]
  • GetDefaultNormal(float data[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetFieldDataArray() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPlotComponent() [virtual]
  • GetPlotMode() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseDefaultNormal() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Height [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComponents (defined in vtkArcPlotter) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • OffsetPoint(vtkIdType ptId, vtkPoints *inPts, float n[3], vtkPoints *newPts, float offset, float *range, float val) [protected]
  • operator=(const vtkArcPlotter &) (defined in vtkArcPlotter) [private]
  • Outputs [protected]
  • PlotComponent [protected]
  • PlotMode [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessComponents(vtkIdType numPts, vtkPointData *pd) [protected]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCamera(vtkCamera *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultNormal(float, float, float) [virtual]
  • SetDefaultNormal(float[3]) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataArray(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float) [virtual]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(float) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPlotComponent(int) [virtual]
  • SetPlotMode(int) [virtual]
  • SetPlotModeToPlotFieldData() [inline]
  • SetPlotModeToPlotNormals() [inline]
  • SetPlotModeToPlotScalars() [inline]
  • SetPlotModeToPlotTCoords() [inline]
  • SetPlotModeToPlotTensors() [inline]
  • SetPlotModeToPlotVectors() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseDefaultNormal(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartComp (defined in vtkArcPlotter) [private]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • Tuple (defined in vtkArcPlotter) [private]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseDefaultNormal [protected]
  • UseDefaultNormalOff() [virtual]
  • UseDefaultNormalOn() [virtual]
  • vtkArcPlotter() [protected]
  • vtkArcPlotter(const vtkArcPlotter &) (defined in vtkArcPlotter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkArcPlotter, vtkPolyDataToPolyDataFilter)
  • ~vtkArcPlotter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkArrayCalculator Member List

This is the complete list of members for vtkArrayCalculator, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddScalarArrayName(const char *arrayName, int component=0)
  • AddScalarVariable(const char *variableName, const char *arrayName, int component=0)
  • AddVectorArrayName(const char *arrayName, int component0=0, int component1=1, int component2=2)
  • AddVectorVariable(const char *variableName, const char *arrayName, int component0=0, int component1=1, int component2=2)
  • AttributeMode [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • Function [protected]
  • FunctionParser [protected]
  • GetAbortExecute() [virtual]
  • GetAttributeMode() [virtual]
  • GetAttributeModeAsString()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFunction() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarArrays() [virtual]
  • GetNumberOfVectorArrays() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResultArrayName() [virtual]
  • GetScalarArrayName(int i)
  • GetScalarArrayNames() [inline]
  • GetScalarVariableName(int i)
  • GetScalarVariableNames() [inline]
  • GetSelectedScalarComponent(int i)
  • GetSelectedScalarComponents() [inline]
  • GetSelectedVectorComponents() [inline]
  • GetSelectedVectorComponents(int i)
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GetVectorArrayName(int i)
  • GetVectorArrayNames() [inline]
  • GetVectorVariableName(int i)
  • GetVectorVariableNames() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarArrays [protected]
  • NumberOfVectorArrays [protected]
  • operator=(const vtkArrayCalculator &) (defined in vtkArrayCalculator) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveAllVariables()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ResultArrayName [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarArrayNames [protected]
  • ScalarVariableNames [protected]
  • SelectedScalarComponents [protected]
  • SelectedVectorComponents [protected]
  • SetAbortExecute(int) [virtual]
  • SetAttributeMode(int) [virtual]
  • SetAttributeModeToDefault() [inline]
  • SetAttributeModeToUseCellData() [inline]
  • SetAttributeModeToUsePointData() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFunction(const char *function)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResultArrayName(const char *name)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorArrayNames [protected]
  • VectorVariableNames [protected]
  • vtkArrayCalculator() [protected]
  • vtkArrayCalculator(const vtkArrayCalculator &) (defined in vtkArrayCalculator) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkArrayCalculator, vtkDataSetToDataSetFilter)
  • ~vtkArrayCalculator() [protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkArrowSource Member List

This is the complete list of members for vtkArrowSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShaftRadius() [virtual]
  • GetShaftResolution() [virtual]
  • GetTipLength() [virtual]
  • GetTipRadius() [virtual]
  • GetTipResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkArrowSource &) (defined in vtkArrowSource) [inline, private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetShaftRadius(float) [virtual]
  • SetShaftResolution(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTipLength(float) [virtual]
  • SetTipRadius(float) [virtual]
  • SetTipResolution(int) [virtual]
  • ShaftRadius [protected]
  • ShaftResolution [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TipLength [protected]
  • TipRadius [protected]
  • TipResolution [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkArrowSource() [protected]
  • vtkArrowSource(const vtkArrowSource &) (defined in vtkArrowSource) [inline, private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkArrowSource, vtkPolyDataSource)
  • ~vtkArrowSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAssembly Member List

This is the complete list of members for vtkAssembly, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPart(vtkProp3D *)
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetLength()
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetParts() [inline]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkAssembly &) (defined in vtkAssembly) [private]
  • Orientation [protected]
  • Origin [protected]
  • Parts [protected]
  • Paths [protected]
  • PathTime [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePart(vtkProp3D *)
  • RenderOpaqueGeometry(vtkViewport *ren) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *ren) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePaths() [protected, virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkAssembly() [protected]
  • vtkAssembly(const vtkAssembly &) (defined in vtkAssembly) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkAssembly, vtkProp3D)
  • ~vtkAssembly() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAssemblyNode Member List

This is the complete list of members for vtkAssemblyNode, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMatrix() [virtual]
  • GetMTime() [virtual]
  • GetProp() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Matrix (defined in vtkAssemblyNode) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkAssemblyNode &) (defined in vtkAssemblyNode) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Prop (defined in vtkAssemblyNode) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatrix(vtkMatrix4x4 *matrix)
  • SetProp(vtkProp *prop)
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAssemblyNode() [protected]
  • vtkAssemblyNode(const vtkAssemblyNode &) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAssemblyNode, vtkObject)
  • ~vtkAssemblyNode() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAssemblyPath Member List

This is the complete list of members for vtkAssemblyPath, including all inherited members.
  • AddItem(vtkObject *o) (defined in vtkAssemblyPath) [inline, private]
  • AddNode(vtkProp *p, vtkMatrix4x4 *m)
  • AddNode(vtkAssemblyNode *n) [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • DeleteLastNode()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFirstNode()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastNode()
  • GetMTime() [virtual]
  • GetNextItemAsObject() [inline]
  • GetNextNode()
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkAssemblyPath &) (defined in vtkAssemblyPath) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkAssemblyPath *path)
  • SubjectHelper [protected]
  • Top [protected]
  • Transform [protected]
  • TransformedProp [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAssemblyPath() [protected]
  • vtkAssemblyPath(const vtkAssemblyPath &) (defined in vtkAssemblyPath) [private]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAssemblyPath, vtkCollection)
  • ~vtkAssemblyPath() [protected]
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAssemblyPaths Member List

This is the complete list of members for vtkAssemblyPaths, including all inherited members.
  • AddItem(vtkAssemblyPath *p) [inline]
  • AddItem(vtkObject *o) (defined in vtkAssemblyPaths) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkAssemblyPath *p) [inline]
  • IsItemPresent(vtkObject *o) (defined in vtkAssemblyPaths) [inline, private]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkAssemblyPaths &) (defined in vtkAssemblyPaths) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(vtkAssemblyPath *p) [inline]
  • RemoveItem(vtkObject *o) (defined in vtkAssemblyPaths) [inline, private]
  • RemoveItem(int i) (defined in vtkAssemblyPaths) [inline, private]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAssemblyPaths() [inline, protected]
  • vtkAssemblyPaths(const vtkAssemblyPaths &) (defined in vtkAssemblyPaths) [private]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkAssemblyPaths, vtkCollection)
  • ~vtkAssemblyPaths() [inline, protected]
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAssignAttribute Member List

This is the complete list of members for vtkAssignAttribute, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Assign(int inputAttributeType, int attributeType, int attributeLoc)
  • Assign(const char *fieldName, int attributeType, int attributeLoc)
  • Assign(const char *name, const char *attributeType, const char *attributeLoc)
  • ATTRIBUTE enum value [protected]
  • AttributeLocation [protected]
  • AttributeLocation enum name
  • AttributeLocationNames [protected, static]
  • AttributeNames [protected, static]
  • AttributeType [protected]
  • BreakOnError() [static]
  • CELL_DATA enum value
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldName [protected]
  • FieldType [protected]
  • FieldType enum name [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputAttributeType [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • NAME enum value [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAssignAttribute &) (defined in vtkAssignAttribute) [private]
  • Outputs [protected]
  • POINT_DATA enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkAssignAttribute() [protected]
  • vtkAssignAttribute(const vtkAssignAttribute &) (defined in vtkAssignAttribute) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkAssignAttribute, vtkDataSetToDataSetFilter)
  • ~vtkAssignAttribute() [protected, virtual]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAttributeDataToFieldDataFilter Member List

This is the complete list of members for vtkAttributeDataToFieldDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassAttributeData() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAttributeDataToFieldDataFilter &) (defined in vtkAttributeDataToFieldDataFilter) [private]
  • Outputs [protected]
  • PassAttributeData [protected]
  • PassAttributeDataOff() [virtual]
  • PassAttributeDataOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPassAttributeData(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkAttributeDataToFieldDataFilter() [protected]
  • vtkAttributeDataToFieldDataFilter(const vtkAttributeDataToFieldDataFilter &) (defined in vtkAttributeDataToFieldDataFilter) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkAttributeDataToFieldDataFilter, vtkDataSetToDataSetFilter)
  • ~vtkAttributeDataToFieldDataFilter() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAxes Member List

This is the complete list of members for vtkAxes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDivisionExtents(vtkDataObject *output, int idx, int numDivisions) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeNormals() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetSymmetric() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkAxes &) (defined in vtkAxes) [private]
  • Origin [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSymmetric(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Symmetric [protected]
  • SymmetricOff() [virtual]
  • SymmetricOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkAxes() [protected]
  • vtkAxes(const vtkAxes &) (defined in vtkAxes) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkAxes, vtkPolyDataSource)
  • ~vtkAxes() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkAxisActor2D Member List

This is the complete list of members for vtkAxisActor2D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AdjustLabels [protected]
  • AdjustLabelsOff() [virtual]
  • AdjustLabelsOn() [virtual]
  • AllocatedRenderTime [protected]
  • Axis [protected]
  • AxisActor [protected]
  • AxisMapper [protected]
  • AxisVisibility [protected]
  • AxisVisibilityOff() [virtual]
  • AxisVisibilityOn() [virtual]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildAxis(vtkViewport *viewport) [protected, virtual]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(float inRange[2], float outRange[2], int inNumTicks, int &outNumTicks, float &interval) [static]
  • ComputeStringOffset(float width, float height, float theta) [protected, static]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • FontFactor [protected]
  • FontFamily [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAdjustLabels() [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetAxisVisibility() [virtual]
  • GetBold() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFontFactor() [virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetItalic() [virtual]
  • GetLabelFactor() [virtual]
  • GetLabelFormat() [virtual]
  • GetLabelVisibility() [virtual]
  • GetLayerNumber() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfLabels() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetPoint1() [virtual]
  • GetPoint1Coordinate() [virtual]
  • GetPoint2() [virtual]
  • GetPoint2Coordinate() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRange() [virtual]
  • GetRange(float data[2]) [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetShadow() [virtual]
  • GetTickLength() [virtual]
  • GetTickOffset() [virtual]
  • GetTickVisibility() [virtual]
  • GetTitle() [virtual]
  • GetTitleVisibility() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabelActors [protected]
  • LabelFactor [protected]
  • LabelFormat [protected]
  • LabelMappers [protected]
  • LabelVisibility [protected]
  • LabelVisibilityOff() [virtual]
  • LabelVisibilityOn() [virtual]
  • LastLabelFontSize [protected]
  • LastPoint1 [protected]
  • LastPoint2 [protected]
  • LastSize [protected]
  • LastTitleFontSize [protected]
  • LayerNumber [protected]
  • Mapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfLabels [protected]
  • NumberOfLabelsBuilt [protected]
  • operator=(const vtkAxisActor2D &) (defined in vtkAxisActor2D) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • Point1Coordinate [protected]
  • Point2Coordinate [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • Range [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAdjustLabels(int) [virtual]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetAxisVisibility(int) [virtual]
  • SetBold(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFontFactor(float) [virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(vtkViewport *viewport, vtkTextMapper *textMapper, int *size, float factor, int &stringWidth, int &stringHeight) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetItalic(int) [virtual]
  • SetLabelFactor(float) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLabelVisibility(int) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetNumberOfLabels(int) [virtual]
  • SetOffsetPosition(float xTick[3], float theta, int stringHeight, int stringWidth, int offset, vtkActor2D *actor) [protected, static]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPoint1(float x[2]) [virtual]
  • SetPoint1(float x, float y) [virtual]
  • SetPoint2(float x[2]) [virtual]
  • SetPoint2(float x, float y) [virtual]
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetRange(float, float) [virtual]
  • SetRange(float[2])
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetShadow(int) [virtual]
  • SetTickLength(int) [virtual]
  • SetTickOffset(int) [virtual]
  • SetTickVisibility(int) [virtual]
  • SetTitle(const char *) [virtual]
  • SetTitleVisibility(int) [virtual]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • TickLength [protected]
  • TickOffset [protected]
  • TickVisibility [protected]
  • TickVisibilityOff() [virtual]
  • TickVisibilityOn() [virtual]
  • Title [protected]
  • TitleActor [protected]
  • TitleMapper [protected]
  • TitleVisibility [protected]
  • TitleVisibilityOff() [virtual]
  • TitleVisibilityOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkAxisActor2D() [protected]
  • vtkAxisActor2D(const vtkAxisActor2D &) (defined in vtkAxisActor2D) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkAxisActor2D, vtkActor2D)
  • ~vtkActor2D() [protected]
  • ~vtkAxisActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:15:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBandedPolyDataContourFilter Member List

This is the complete list of members for vtkBandedPolyDataContourFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClipEdge(int v1, int v2, vtkPoints *pts, vtkDataArray *scalars, vtkPointData *inPD, vtkPointData *outPD) [protected]
  • ClipIndex [protected]
  • Clipping [protected]
  • ClippingOff() [virtual]
  • ClippingOn() [virtual]
  • ClipTolerance [protected]
  • ClipValues [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeScalarIndex(float) [protected]
  • ContourValues [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateContourEdges [protected]
  • GenerateContourEdgesOff() [virtual]
  • GenerateContourEdgesOn() [virtual]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipping() [virtual]
  • GetCommand(unsigned long tag)
  • GetContourEdgesOutput() [inline]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateContourEdges() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarMode() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsertCell(vtkCellArray *cells, int npts, vtkIdType *pts, int cellId, float s, vtkFloatArray *newS) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsContourValue(float val) [protected]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfClipValues [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBandedPolyDataContourFilter &) (defined in vtkBandedPolyDataContourFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • SetAbortExecute(int) [virtual]
  • SetClipping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateContourEdges(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToIndex() [inline]
  • SetScalarModeToValue() [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBandedPolyDataContourFilter() [protected]
  • vtkBandedPolyDataContourFilter(const vtkBandedPolyDataContourFilter &) (defined in vtkBandedPolyDataContourFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkBandedPolyDataContourFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkBandedPolyDataContourFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBitArray Member List

This is the complete list of members for vtkBitArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • DeepCopy(vtkDataArray &da) (defined in vtkBitArray) [inline, private]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id)
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const int i) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const int i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkBitArray &) (defined in vtkBitArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(unsigned char *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const int value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkBitArray(vtkIdType numComp=1) [protected]
  • vtkBitArray(const vtkBitArray &) (defined in vtkBitArray) [private]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkBitArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkBitArray() [protected]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBlankStructuredGrid Member List

This is the complete list of members for vtkBlankStructuredGrid, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Component [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetArrayId() [virtual]
  • GetArrayName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaxBlankingValue() [virtual]
  • GetMinBlankingValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaxBlankingValue [protected]
  • MinBlankingValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBlankStructuredGrid &) (defined in vtkBlankStructuredGrid) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetArrayId(int) [virtual]
  • SetArrayName(const char *) [virtual]
  • SetComponent(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetMaxBlankingValue(float) [virtual]
  • SetMinBlankingValue(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBlankStructuredGrid() [protected]
  • vtkBlankStructuredGrid(const vtkBlankStructuredGrid &) (defined in vtkBlankStructuredGrid) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkStructuredGridToStructuredGridFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkBlankStructuredGrid, vtkStructuredGridToStructuredGridFilter)
  • ~vtkBlankStructuredGrid() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
  • ~vtkStructuredGridToStructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:15:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBlankStructuredGridWithImage Member List

This is the complete list of members for vtkBlankStructuredGridWithImage, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBlankingInput()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBlankStructuredGridWithImage &) (defined in vtkBlankStructuredGridWithImage) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlankingInput(vtkImageData *input)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBlankStructuredGridWithImage() [inline, protected]
  • vtkBlankStructuredGridWithImage(const vtkBlankStructuredGridWithImage &) (defined in vtkBlankStructuredGridWithImage) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkStructuredGridToStructuredGridFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkBlankStructuredGridWithImage, vtkStructuredGridToStructuredGridFilter)
  • ~vtkBlankStructuredGridWithImage() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
  • ~vtkStructuredGridToStructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:15:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBMPReader Member List

This is the complete list of members for vtkBMPReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname) [virtual]
  • vtkImageReader::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Colors [protected]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeInverseTransformedExtent(int inExtent[6], int outExtent[6])
  • ComputeInverseTransformedIncrements(int inIncr[3], int outIncr[3])
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ComputeTransformedExtent(int inExtent[6], int outExtent[6]) [protected]
  • ComputeTransformedIncrements(int inIncr[3], int outIncr[3]) [protected]
  • ComputeTransformedOrigin(float origin[3]) [protected]
  • ComputeTransformedSpacing(float Spacing[3]) [protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataMask [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • DataVOI [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Depth [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetColors() [virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataMask() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDataVOI() [virtual]
  • GetDataVOI(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataVOI(int[6]) [virtual]
  • GetDebug()
  • GetDepth() [virtual]
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenAndSeekFile(int extent[6], int slice)
  • OpenFile()
  • operator=(const vtkBMPReader &) (defined in vtkBMPReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataMask(int val) [inline]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDataVOI(int, int, int, int, int, int) [virtual]
  • SetDataVOI(int[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SetTransform(vtkTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBMPReader() [protected]
  • vtkBMPReader(const vtkBMPReader &) (defined in vtkBMPReader) [private]
  • vtkImageReader() [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkBMPReader, vtkImageReader)
  • ~vtkBMPReader() [protected]
  • ~vtkImageReader() [protected]
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBMPWriter Member List

This is the complete list of members for vtkBMPWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBMPWriter &) (defined in vtkBMPWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkBMPWriter() [protected]
  • vtkBMPWriter(const vtkBMPWriter &) (defined in vtkBMPWriter) [private]
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkBMPWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int ext[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • ~vtkBMPWriter() [inline, protected]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:15:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBooleanTexture Member List

This is the complete list of members for vtkBooleanTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInIn() [virtual]
  • GetInIn(unsigned char data[2]) [virtual]
  • GetInOn() [virtual]
  • GetInOn(unsigned char data[2]) [virtual]
  • GetInOut() [virtual]
  • GetInOut(unsigned char data[2]) [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOnIn() [virtual]
  • GetOnIn(unsigned char data[2]) [virtual]
  • GetOnOn() [virtual]
  • GetOnOn(unsigned char data[2]) [virtual]
  • GetOnOut() [virtual]
  • GetOnOut(unsigned char data[2]) [virtual]
  • GetOutIn() [virtual]
  • GetOutIn(unsigned char data[2]) [virtual]
  • GetOutOn() [virtual]
  • GetOutOn(unsigned char data[2]) [virtual]
  • GetOutOut() [virtual]
  • GetOutOut(unsigned char data[2]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetThickness() [virtual]
  • GetXSize() [virtual]
  • GetYSize() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InIn [protected]
  • InOn [protected]
  • InOut [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OnIn [protected]
  • OnOn [protected]
  • OnOut [protected]
  • operator=(const vtkBooleanTexture &) (defined in vtkBooleanTexture) [private]
  • OutIn [protected]
  • OutOn [protected]
  • OutOut [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInIn(unsigned char, unsigned char) [virtual]
  • SetInIn(unsigned char[2])
  • SetInOn(unsigned char, unsigned char) [virtual]
  • SetInOn(unsigned char[2])
  • SetInOut(unsigned char, unsigned char) [virtual]
  • SetInOut(unsigned char[2])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOnIn(unsigned char, unsigned char) [virtual]
  • SetOnIn(unsigned char[2])
  • SetOnOn(unsigned char, unsigned char) [virtual]
  • SetOnOn(unsigned char[2])
  • SetOnOut(unsigned char, unsigned char) [virtual]
  • SetOnOut(unsigned char[2])
  • SetOutIn(unsigned char, unsigned char) [virtual]
  • SetOutIn(unsigned char[2])
  • SetOutOn(unsigned char, unsigned char) [virtual]
  • SetOutOn(unsigned char[2])
  • SetOutOut(unsigned char, unsigned char) [virtual]
  • SetOutOut(unsigned char[2])
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThickness(int) [virtual]
  • SetXSize(int) [virtual]
  • SetYSize(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Thickness [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBooleanTexture() [protected]
  • vtkBooleanTexture(const vtkBooleanTexture &) (defined in vtkBooleanTexture) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkBooleanTexture, vtkStructuredPointsSource)
  • XSize [protected]
  • YSize [protected]
  • ~vtkBooleanTexture() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:15:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBranchExtentTranslator Member List

This is the complete list of members for vtkBranchExtentTranslator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AssignedNumberOfPieces [protected]
  • AssignedPiece [protected]
  • BLOCK_MODE enum value [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • GetAssignedNumberOfPieces() [virtual]
  • GetAssignedPiece() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetGhostLevel() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetOriginalSource() [virtual]
  • GetPiece() [virtual]
  • GetReferenceCount() [inline]
  • GetSplitMode() [virtual]
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modes enum name [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfPieces [protected]
  • operator=(const vtkBranchExtentTranslator &) (defined in vtkBranchExtentTranslator) [private]
  • OriginalSource [protected]
  • Piece [protected]
  • PieceToExtent() [virtual]
  • PieceToExtentByPoints() [virtual]
  • PieceToExtentThreadSafe(int piece, int numPieces, int ghostLevel, int *wholeExtent, int *resultExtent, int splitMode, int byPoints) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAssignedNumberOfPieces(int) [virtual]
  • SetAssignedPiece(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetExtent(int, int, int, int, int, int) [virtual]
  • SetExtent(int[6]) [virtual]
  • SetGhostLevel(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNumberOfPieces(int) [virtual]
  • SetOriginalSource(vtkImageData *) [virtual]
  • SetPiece(int) [virtual]
  • SetReferenceCount(int)
  • SetSplitModeToBlock() [inline]
  • SetSplitModeToXSlab() [inline]
  • SetSplitModeToYSlab() [inline]
  • SetSplitModeToZSlab() [inline]
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • SplitExtent(int piece, int numPieces, int *extent, int splitMode) [protected]
  • SplitExtentByPoints(int piece, int numPieces, int *extent, int splitMode) [protected]
  • SplitMode [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkBranchExtentTranslator() [protected]
  • vtkBranchExtentTranslator(const vtkBranchExtentTranslator &) (defined in vtkBranchExtentTranslator) [private]
  • vtkExtentTranslator() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkBranchExtentTranslator, vtkExtentTranslator)
  • WholeExtent [protected]
  • X_SLAB_MODE enum value [protected]
  • Y_SLAB_MODE enum value [protected]
  • Z_SLAB_MODE enum value [protected]
  • ~vtkBranchExtentTranslator() [protected]
  • ~vtkExtentTranslator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBrownianPoints Member List

This is the complete list of members for vtkBrownianPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumSpeed() [virtual]
  • GetMinimumSpeed() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumSpeed [protected]
  • MinimumSpeed [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBrownianPoints &) (defined in vtkBrownianPoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetMaximumSpeed(float) [virtual]
  • SetMinimumSpeed(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBrownianPoints() [protected]
  • vtkBrownianPoints(const vtkBrownianPoints &) (defined in vtkBrownianPoints) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkBrownianPoints, vtkDataSetToDataSetFilter)
  • ~vtkBrownianPoints() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkButterflySubdivisionFilter Member List

This is the complete list of members for vtkButterflySubdivisionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindEdge(vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds) [protected]
  • GenerateBoundaryStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys, vtkIdList *stencilIds, float *weights) (defined in vtkButterflySubdivisionFilter) [private]
  • GenerateButterflyStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys, vtkIdList *stencilIds, float *weights) (defined in vtkButterflySubdivisionFilter) [private]
  • GenerateLoopStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys, vtkIdList *stencilIds, float *weights) (defined in vtkButterflySubdivisionFilter) [private]
  • GenerateSubdivisionCells(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD) [protected]
  • GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD) (defined in vtkButterflySubdivisionFilter) [private, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSubdivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolatePosition(vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubdivisions [protected]
  • operator=(const vtkButterflySubdivisionFilter &) (defined in vtkButterflySubdivisionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSubdivisions(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkButterflySubdivisionFilter() [inline, protected]
  • vtkButterflySubdivisionFilter(const vtkButterflySubdivisionFilter &) (defined in vtkButterflySubdivisionFilter) [private]
  • vtkInterpolatingSubdivisionFilter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkButterflySubdivisionFilter, vtkInterpolatingSubdivisionFilter)
  • ~vtkButterflySubdivisionFilter() [inline, protected]
  • ~vtkInterpolatingSubdivisionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkButtonSource Member List

This is the complete list of members for vtkButtonSource, including all inherited members.
  • A (defined in vtkButtonSource) [private]
  • A2 (defined in vtkButtonSource) [private]
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • B (defined in vtkButtonSource) [private]
  • B2 (defined in vtkButtonSource) [private]
  • BreakOnError() [static]
  • C (defined in vtkButtonSource) [private]
  • C2 (defined in vtkButtonSource) [private]
  • CircumferentialResolution [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDepth(int inTextureRegion, float x, float y, float n[3]) (defined in vtkButtonSource) [private]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreatePolygons(vtkCellArray *newPolys, int num, int res, int startIdx) (defined in vtkButtonSource) [private]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Depth [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCircumferentialResolution() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepth() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadialRatio() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShoulderResolution() [virtual]
  • GetShoulderTextureCoordinate() [virtual]
  • GetShoulderTextureCoordinate(float &, float &) [virtual]
  • GetShoulderTextureCoordinate(float[2]) [virtual]
  • GetTextureDimensions() [virtual]
  • GetTextureDimensions(int &, int &) [virtual]
  • GetTextureDimensions(int[2]) [virtual]
  • GetTextureResolution() [virtual]
  • GetTextureStyle() [virtual]
  • GetTwoSided() [virtual]
  • GetWidth() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Height [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolateCurve(int inTextureRegion, vtkPoints *newPts, int numPts, vtkFloatArray *normals, vtkFloatArray *tcoords, int res, int c1StartPoint, int c1Incr, int c2StartPoint, int s2Incr, int startPoint, int incr) (defined in vtkButtonSource) [private]
  • IntersectEllipseWithLine(float a2, float b2, float dX, float dY, float &xe, float &ye) (defined in vtkButtonSource) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkButtonSource &) (defined in vtkButtonSource) [private]
  • Origin [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RadialRatio [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCircumferentialResolution(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDepth(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadialRatio(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetShoulderResolution(int) [virtual]
  • SetShoulderTextureCoordinate(float, float) [virtual]
  • SetShoulderTextureCoordinate(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTextureDimensions(int, int) [virtual]
  • SetTextureDimensions(int[2])
  • SetTextureResolution(int) [virtual]
  • SetTextureStyle(int) [virtual]
  • SetTextureStyleToFitImage() [inline]
  • SetTextureStyleToProportional() [inline]
  • SetTwoSided(int) [virtual]
  • SetWidth(float) [virtual]
  • ShoulderResolution [protected]
  • ShoulderTextureCoordinate [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextureDimensions [protected]
  • TextureResolution [protected]
  • TextureStyle [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • TwoSided [protected]
  • TwoSidedOff() [virtual]
  • TwoSidedOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkButtonSource() [protected]
  • vtkButtonSource(const vtkButtonSource &) (defined in vtkButtonSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkButtonSource, vtkPolyDataSource)
  • Width [protected]
  • ~vtkButtonSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkByteSwap Member List

This is the complete list of members for vtkByteSwap, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkByteSwap &) (defined in vtkByteSwap) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Swap2BE(short *s) [static]
  • Swap2BE(unsigned short *s) [static]
  • Swap2BERange(char *c, int num) [static]
  • Swap2BERange(short *i, int num) [inline, static]
  • Swap2Bytes(char *&data) (defined in vtkByteSwap) [inline, private, static]
  • Swap2LE(short *s) [static]
  • Swap2LE(unsigned short *s) [static]
  • Swap2LERange(char *c, int num) [static]
  • Swap2LERange(short *i, int num) [inline, static]
  • Swap4BE(char *c) [static]
  • Swap4BE(float *p) [inline, static]
  • Swap4BE(int *i) [inline, static]
  • Swap4BE(unsigned long *i) [inline, static]
  • Swap4BERange(char *c, int num) [static]
  • Swap4BERange(float *p, int num) [inline, static]
  • Swap4BERange(int *i, int num) [inline, static]
  • Swap4BERange(unsigned long *i, int num) [inline, static]
  • Swap4Bytes(char *&data) (defined in vtkByteSwap) [inline, private, static]
  • Swap4LE(char *c) [static]
  • Swap4LE(float *p) [inline, static]
  • Swap4LE(int *i) [inline, static]
  • Swap4LE(unsigned long *i) [inline, static]
  • Swap4LE(long *i) [inline, static]
  • Swap4LERange(char *c, int num) [static]
  • Swap4LERange(unsigned char *c, int num) [inline, static]
  • Swap4LERange(float *p, int num) [inline, static]
  • Swap4LERange(int *i, int num) [inline, static]
  • Swap4LERange(unsigned long *i, int num) [inline, static]
  • Swap8BE(char *c) [static]
  • Swap8BE(double *d) [inline, static]
  • Swap8BERange(char *c, int num) [static]
  • Swap8BERange(double *d, int num) [inline, static]
  • Swap8Bytes(char *&data) (defined in vtkByteSwap) [inline, private, static]
  • Swap8LE(char *c) [static]
  • Swap8LE(double *d) [inline, static]
  • Swap8LERange(char *c, int num) [static]
  • Swap8LERange(double *d, int num) [inline, static]
  • SwapVoidRange(void *buffer, int numWords, int wordSize) [static]
  • SwapWrite2BERange(char *c, int num, FILE *fp) [static]
  • SwapWrite2BERange(short *i, int num, FILE *fp) [inline, static]
  • SwapWrite2BERange(char *c, int num, ostream *fp) [static]
  • SwapWrite2BERange(short *i, int num, ostream *fp) [inline, static]
  • SwapWrite4BERange(char *c, int num, FILE *fp) [static]
  • SwapWrite4BERange(float *p, int num, FILE *fp) [inline, static]
  • SwapWrite4BERange(int *i, int num, FILE *fp) [inline, static]
  • SwapWrite4BERange(unsigned long *i, int num, FILE *fp) [inline, static]
  • SwapWrite4BERange(char *c, int num, ostream *fp) [static]
  • SwapWrite4BERange(float *p, int num, ostream *fp) [inline, static]
  • SwapWrite4BERange(int *i, int num, ostream *fp) [inline, static]
  • SwapWrite4BERange(unsigned long *i, int num, ostream *fp) [inline, static]
  • SwapWrite8BERange(char *c, int num, FILE *fp) [static]
  • SwapWrite8BERange(double *d, int num, FILE *fp) [inline, static]
  • SwapWrite8BERange(char *c, int num, ostream *fp) [static]
  • SwapWrite8BERange(double *d, int num, ostream *fp) [inline, static]
  • UnRegister(vtkObject *o) [virtual]
  • vtkByteSwap() [inline, protected]
  • vtkByteSwap(const vtkByteSwap &) (defined in vtkByteSwap) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkByteSwap, vtkObject)
  • ~vtkByteSwap() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBYUReader Member List

This is the complete list of members for vtkBYUReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDivisionExtents(vtkDataObject *output, int idx, int numDivisions) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplacementFileName [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GeometryFileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplacementFileName() [virtual]
  • GetErrorCode() [virtual]
  • GetGeometryFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPartNumber() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadDisplacement() [virtual]
  • GetReadScalar() [virtual]
  • GetReadTexture() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarFileName() [virtual]
  • GetTextureFileName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkBYUReader &) (defined in vtkBYUReader) [private]
  • Outputs [protected]
  • PartNumber [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadDisplacement [protected]
  • ReadDisplacementFile(int numPts) [protected]
  • ReadDisplacementOff() [virtual]
  • ReadDisplacementOn() [virtual]
  • ReadGeometryFile(FILE *fp, int &numPts) [protected]
  • ReadScalar [protected]
  • ReadScalarFile(int numPts) [protected]
  • ReadScalarOff() [virtual]
  • ReadScalarOn() [virtual]
  • ReadTexture [protected]
  • ReadTextureFile(int numPts) [protected]
  • ReadTextureOff() [virtual]
  • ReadTextureOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarFileName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplacementFileName(const char *) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGeometryFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPartNumber(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadDisplacement(int) [virtual]
  • SetReadScalar(int) [virtual]
  • SetReadTexture(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarFileName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTextureFileName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextureFileName [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkBYUReader() [protected]
  • vtkBYUReader(const vtkBYUReader &) (defined in vtkBYUReader) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkBYUReader, vtkPolyDataSource)
  • ~vtkBYUReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkBYUWriter Member List

This is the complete list of members for vtkBYUWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplacementFileName [protected]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GeometryFileName [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplacementFileName() [virtual]
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGeometryFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarFileName() [virtual]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetTextureFileName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteDisplacement() [virtual]
  • GetWriteScalar() [virtual]
  • GetWriteTexture() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkBYUWriter &) (defined in vtkBYUWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarFileName [protected]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplacementFileName(const char *) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGeometryFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarFileName(const char *) [virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetTextureFileName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteDisplacement(int) [virtual]
  • SetWriteScalar(int) [virtual]
  • SetWriteTexture(int) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • TextureFileName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkBYUWriter() [protected]
  • vtkBYUWriter(const vtkBYUWriter &) (defined in vtkBYUWriter) [private]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkBYUWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteDisplacement [protected]
  • WriteDisplacementFile(int numPts) [protected]
  • WriteDisplacementOff() [virtual]
  • WriteDisplacementOn() [virtual]
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteGeometryFile(FILE *fp, int numPts) [protected]
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalar [protected]
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteScalarFile(int numPts) [protected]
  • WriteScalarOff() [virtual]
  • WriteScalarOn() [virtual]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTexture [protected]
  • WriteTextureFile(int numPts) [protected]
  • WriteTextureOff() [virtual]
  • WriteTextureOn() [virtual]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkBYUWriter() [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCallbackCommand Member List

This is the complete list of members for vtkCallbackCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • Callback
  • CharEvent enum value
  • ClientData
  • ClientDataDeleteCallback
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *caller, unsigned long event, void *callData) [virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetClientData() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • New() [inline, static]
  • NextDataEvent enum value
  • NoEvent enum value
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetCallback(void(*f)(vtkObject *, unsigned long, void *, void *)) [inline]
  • SetClientData(void *cd) [inline]
  • SetClientDataDeleteCallback(void(*f)(void *)) [inline]
  • SetOutputEvent enum value
  • StartEvent enum value
  • StartPickEvent enum value
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • UserEvent enum value
  • vtkCallbackCommand() [protected]
  • vtkCommand() [inline, protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCallbackCommand() [protected]
  • ~vtkCommand() [inline, protected, virtual]
Generated on Mon Mar 25 01:15:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCamera Member List

This is the complete list of members for vtkCamera, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplyTransform(vtkTransform *t)
  • Azimuth(double angle)
  • BreakOnError() [static]
  • CameraLightTransform [protected]
  • ClippingRange [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCameraLightTransform() [protected]
  • ComputeCompositePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeDistance() [protected]
  • ComputePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeViewPlaneNormal()
  • ComputeViewTransform() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DirectionOfProjection [protected]
  • Distance [protected]
  • Dolly(double distance)
  • Elevation(double angle)
  • EyeAngle [protected]
  • FocalDisk [protected]
  • FocalPoint [protected]
  • GetCameraLightTransformMatrix()
  • GetClassName() [inline, virtual]
  • GetClippingRange() [virtual]
  • GetClippingRange(double &, double &) [virtual]
  • GetClippingRange(double[2]) [virtual]
  • GetClippingRange(float a[2]) [inline]
  • GetCommand(unsigned long tag)
  • GetCompositePerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetCompositePerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetDebug()
  • GetDirectionOfProjection() [virtual]
  • GetDirectionOfProjection(double &, double &, double &) [virtual]
  • GetDirectionOfProjection(double[3]) [virtual]
  • GetDirectionOfProjection(float a[3]) [inline]
  • GetDistance() [virtual]
  • GetEyeAngle() [virtual]
  • GetFocalDisk() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(double &, double &, double &) [virtual]
  • GetFocalPoint(double[3]) [virtual]
  • GetFocalPoint(float a[3]) [inline]
  • GetFrustumPlanes(float aspect, float planes[24])
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOrientation() [inline]
  • GetOrientationWXYZ() [inline]
  • GetParallelProjection() [virtual]
  • GetParallelScale() [virtual]
  • GetPerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetPerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetPosition() [virtual]
  • GetPosition(double &, double &, double &) [virtual]
  • GetPosition(double[3]) [virtual]
  • GetPosition(float a[3]) [inline]
  • GetReferenceCount() [inline]
  • GetRoll()
  • GetThickness() [virtual]
  • GetViewAngle() [virtual]
  • GetViewingRaysMTime()
  • GetViewPlaneNormal() [virtual]
  • GetViewPlaneNormal(double &, double &, double &) [virtual]
  • GetViewPlaneNormal(double[3]) [virtual]
  • GetViewPlaneNormal(float a[3]) [inline]
  • GetViewShear() [virtual]
  • GetViewShear(double &, double &, double &) [virtual]
  • GetViewShear(double[3]) [virtual]
  • GetViewTransform() [inline]
  • GetViewTransformMatrix() [inline]
  • GetViewTransformObject() [inline]
  • GetViewUp() [virtual]
  • GetViewUp(double &, double &, double &) [virtual]
  • GetViewUp(double[3]) [virtual]
  • GetViewUp(float a[3]) [inline]
  • GetWindowCenter() [virtual]
  • GetWindowCenter(double &, double &) [virtual]
  • GetWindowCenter(double[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftEye [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • ObliqueAngles [protected]
  • operator=(const vtkCamera &) (defined in vtkCamera) [private]
  • OrthogonalizeViewUp()
  • ParallelProjection [protected]
  • ParallelProjectionOff() [virtual]
  • ParallelProjectionOn() [virtual]
  • ParallelScale [protected]
  • PerspectiveTransform [protected]
  • Pitch(double angle)
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *) [inline, virtual]
  • Roll(double angle)
  • SafeDownCast(vtkObject *o) [static]
  • SetClippingRange(double near, double far)
  • SetClippingRange(const double a[2]) [inline]
  • SetClippingRange(const float a[2]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDistance(double)
  • SetEyeAngle(double) [virtual]
  • SetFocalDisk(double) [virtual]
  • SetFocalPoint(double x, double y, double z)
  • SetFocalPoint(const double a[3]) [inline]
  • SetFocalPoint(const float a[3]) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetObliqueAngles(double alpha, double beta)
  • SetParallelProjection(int flag)
  • SetParallelScale(double scale)
  • SetPosition(double x, double y, double z)
  • SetPosition(const double a[3]) [inline]
  • SetPosition(const float a[3]) [inline]
  • SetReferenceCount(int)
  • SetRoll(double angle)
  • SetThickness(double)
  • SetViewAngle(double angle)
  • SetViewPlaneNormal(double x, double y, double z)
  • SetViewPlaneNormal(const double a[3]) [inline]
  • SetViewPlaneNormal(const float a[3]) [inline]
  • SetViewShear(double dxdz, double dydz, double center)
  • SetViewShear(double d[3])
  • SetViewUp(double vx, double vy, double vz)
  • SetViewUp(const double a[3]) [inline]
  • SetViewUp(const float a[3]) [inline]
  • SetWindowCenter(double x, double y)
  • Stereo [protected]
  • SubjectHelper [protected]
  • Thickness [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateViewport(vtkRenderer *vtkNotUsed(ren)) [inline, virtual]
  • ViewAngle [protected]
  • ViewingRaysModified()
  • ViewingRaysMTime [protected]
  • ViewPlaneNormal [protected]
  • ViewShear [protected]
  • ViewTransform [protected]
  • ViewUp [protected]
  • vtkCamera() [protected]
  • vtkCamera(const vtkCamera &) (defined in vtkCamera) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCamera, vtkObject)
  • WindowCenter [protected]
  • Yaw(double angle)
  • Zoom(double factor)
  • ~vtkCamera() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:15:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCaptionActor2D Member List

This is the complete list of members for vtkCaptionActor2D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • AppendLeader (defined in vtkCaptionActor2D) [private]
  • AttachmentPointCoordinate [protected]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • Border [protected]
  • BorderActor (defined in vtkCaptionActor2D) [private]
  • BorderMapper (defined in vtkCaptionActor2D) [private]
  • BorderOff() [virtual]
  • BorderOn() [virtual]
  • BorderPolyData (defined in vtkCaptionActor2D) [private]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • Caption [protected]
  • CaptionActor (defined in vtkCaptionActor2D) [private]
  • CaptionMapper (defined in vtkCaptionActor2D) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • FontFamily [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetAttachmentPoint() [virtual]
  • GetAttachmentPointCoordinate() [virtual]
  • GetBold() [virtual]
  • GetBorder() [virtual]
  • GetBounds() [inline, virtual]
  • GetCaption() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLayerNumber() [virtual]
  • GetLeader() [virtual]
  • GetLeaderGlyph() [virtual]
  • GetLeaderGlyphSize() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMaximumLeaderGlyphSize() [virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPadding() [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetShadow() [virtual]
  • GetThreeDimensionalLeader() [virtual]
  • GetVerticalJustification() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeadGlyph (defined in vtkCaptionActor2D) [private]
  • HeadPolyData (defined in vtkCaptionActor2D) [private]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LayerNumber [protected]
  • Leader [protected]
  • LeaderActor2D (defined in vtkCaptionActor2D) [private]
  • LeaderActor3D (defined in vtkCaptionActor2D) [private]
  • LeaderGlyph [protected]
  • LeaderGlyphSize [protected]
  • LeaderMapper2D (defined in vtkCaptionActor2D) [private]
  • LeaderMapper3D (defined in vtkCaptionActor2D) [private]
  • LeaderOff() [virtual]
  • LeaderOn() [virtual]
  • LeaderPolyData (defined in vtkCaptionActor2D) [private]
  • Mapper [protected]
  • MapperCoordinate2D (defined in vtkCaptionActor2D) [private]
  • MaximumLeaderGlyphSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkCaptionActor2D &) (defined in vtkCaptionActor2D) [private]
  • Padding [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetAttachmentPoint(float x[3]) [virtual]
  • SetAttachmentPoint(float x, float y, float z) [virtual]
  • SetBold(int) [virtual]
  • SetBorder(int) [virtual]
  • SetCaption(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetItalic(int) [virtual]
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLayerNumber(int) [virtual]
  • SetLeader(int) [virtual]
  • SetLeaderGlyph(vtkPolyData *) [virtual]
  • SetLeaderGlyphSize(float) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetMaximumLeaderGlyphSize(int) [virtual]
  • SetPadding(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetShadow(int) [virtual]
  • SetThreeDimensionalLeader(int) [virtual]
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • ThreeDimensionalLeader [protected]
  • ThreeDimensionalLeaderOff() [virtual]
  • ThreeDimensionalLeaderOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • VerticalJustification [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkCaptionActor2D() [protected]
  • vtkCaptionActor2D(const vtkCaptionActor2D &) (defined in vtkCaptionActor2D) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkCaptionActor2D, vtkActor2D)
  • ~vtkActor2D() [protected]
  • ~vtkCaptionActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:16:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCardinalSpline Member List

This is the complete list of members for vtkCardinalSpline, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPoint(float t, float x)
  • BreakOnError() [static]
  • ClampValue [protected]
  • ClampValueOff() [virtual]
  • ClampValueOn() [virtual]
  • Closed [protected]
  • ClosedOff() [virtual]
  • ClosedOn() [virtual]
  • Coefficients [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Compute() [virtual]
  • ComputeTime [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Evaluate(float t)
  • Fit1D(int n, float *x, float *y, float *w, float coefficients[][4], int leftConstraint, float leftValue, int rightConstraint, float rightValue) [protected]
  • FitClosed1D(int n, float *x, float *y, float *w, float coefficients[][4]) [protected]
  • GetClampValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetClosed() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLeftConstraint() [virtual]
  • GetLeftValue() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRightConstraint() [virtual]
  • GetRightValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intervals [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftConstraint [protected]
  • LeftValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCardinalSpline &) (defined in vtkCardinalSpline) [private]
  • PiecewiseFunction [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllPoints()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePoint(float t)
  • RightConstraint [protected]
  • RightValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetClampValue(int) [virtual]
  • SetClosed(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLeftConstraint(int) [virtual]
  • SetLeftValue(float) [virtual]
  • SetReferenceCount(int)
  • SetRightConstraint(int) [virtual]
  • SetRightValue(float) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCardinalSpline() [protected]
  • vtkCardinalSpline(const vtkCardinalSpline &) (defined in vtkCardinalSpline) [private]
  • vtkObject() [protected]
  • vtkSpline() [protected]
  • vtkTypeRevisionMacro(vtkCardinalSpline, vtkSpline)
  • ~vtkCardinalSpline() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSpline() [protected]
Generated on Mon Mar 25 01:16:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCastToConcrete Member List

This is the complete list of members for vtkCastToConcrete, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCastToConcrete &) (defined in vtkCastToConcrete) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCastToConcrete() [inline, protected]
  • vtkCastToConcrete(const vtkCastToConcrete &) (defined in vtkCastToConcrete) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCastToConcrete, vtkDataSetToDataSetFilter)
  • ~vtkCastToConcrete() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCell3D Member List

This is the complete list of members for vtkCell3D, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts)=0 [pure virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs)=0 [pure virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights)=0 [pure virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)=0 [pure virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType()=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId)=0 [pure virtual]
  • GetEdgePoints(int edgeId, int *&pts)=0 [pure virtual]
  • GetFace(int faceId)=0 [pure virtual]
  • GetFacePoints(int faceId, int *&pts)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges()=0 [pure virtual]
  • GetNumberOfFaces()=0 [pure virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkCell3D &) (defined in vtkCell3D) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts)=0 [pure virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkCell3D(const vtkCell3D &) (defined in vtkCell3D) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCell3D, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCell Member List

This is the complete list of members for vtkCell, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts)=0 [pure virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)=0 [pure virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs)=0 [pure virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights)=0 [pure virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)=0 [pure virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension()=0 [pure virtual]
  • GetCellType()=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId)=0 [pure virtual]
  • GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges()=0 [pure virtual]
  • GetNumberOfFaces()=0 [pure virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkCell &) (defined in vtkCell) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts)=0 [pure virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell(const vtkCell &) (defined in vtkCell) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCell, vtkObject)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellArray Member List

This is the complete list of members for vtkCellArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const int ext=1000) [inline]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCellArray *ca)
  • Delete() [virtual]
  • EstimateSize(vtkIdType numCells, int maxPtsPerCell) [inline]
  • GetActualMemorySize()
  • GetCell(vtkIdType loc, vtkIdType &npts, vtkIdType *&pts) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetData() [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInsertLocation(int npts) [inline]
  • GetMaxCellSize()
  • GetMTime() [virtual]
  • GetNextCell(vtkIdType &npts, vtkIdType *&pts) [inline]
  • GetNumberOfCells() [inline]
  • GetNumberOfConnectivityEntries() [inline]
  • GetPointer() [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTraversalLocation() [inline]
  • GetTraversalLocation(vtkIdType npts) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Ia [protected]
  • Initialize() [inline]
  • InitTraversal() [inline]
  • InsertCellPoint(vtkIdType id) [inline]
  • InsertLocation [protected]
  • InsertNextCell(vtkCell *cell) [inline]
  • InsertNextCell(vtkIdType npts, vtkIdType *pts) [inline]
  • InsertNextCell(vtkIdList *pts) [inline]
  • InsertNextCell(int npts) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfCells [protected]
  • operator=(const vtkCellArray &) (defined in vtkCellArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceCell(vtkIdType loc, int npts, vtkIdType *pts) [inline]
  • Reset() [inline]
  • ReverseCell(vtkIdType loc) [inline]
  • SafeDownCast(vtkObject *o) [static]
  • SetCells(vtkIdType ncells, vtkIdTypeArray *cells)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetTraversalLocation(vtkIdType loc) [inline]
  • Squeeze() [inline]
  • SubjectHelper [protected]
  • TraversalLocation [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateCellCount(int npts) [inline]
  • vtkCellArray() [protected]
  • vtkCellArray(const vtkCellArray &) (defined in vtkCellArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCellArray, vtkObject)
  • WritePointer(const vtkIdType ncells, const vtkIdType size) [inline]
  • ~vtkCellArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellCenters Member List

This is the complete list of members for vtkCellCenters, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetVertexCells() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCellCenters &) (defined in vtkCellCenters) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVertexCells(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VertexCells [protected]
  • VertexCellsOff() [virtual]
  • VertexCellsOn() [virtual]
  • vtkCellCenters() [protected]
  • vtkCellCenters(const vtkCellCenters &) (defined in vtkCellCenters) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCellCenters, vtkDataSetToPolyDataFilter)
  • ~vtkCellCenters() [inline, protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellData Member List

This is the complete list of members for vtkCellData, including all inherited members.
  • AddArray(vtkDataArray *array)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)
  • AllocateArrays(int num)
  • AttributeIndices [protected]
  • AttributeLimits [protected, static]
  • AttributeLimitTypes enum name
  • AttributeNames [protected, static]
  • AttributeTypes enum name
  • BreakOnError() [static]
  • ClearFieldFlags() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllocate(vtkDataSetAttributes::FieldList &list, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllOff() [virtual]
  • CopyAllOn() [virtual]
  • CopyAttributeFlags [protected]
  • CopyData(vtkDataSetAttributes *fromPd, vtkIdType fromId, vtkIdType toId)
  • CopyData(vtkDataSetAttributes::FieldList &list, vtkDataSetAttributes *dsa, int idx, vtkIdType fromId, vtkIdType toId)
  • CopyFieldFlags [protected]
  • CopyFieldOff(const char *name) [inline]
  • CopyFieldOn(const char *name) [inline]
  • CopyFieldOnOff(const char *name, int onOff) [protected]
  • CopyFlags(const vtkFieldData *source) [protected]
  • CopyNormalsOff() [virtual]
  • CopyNormalsOn() [virtual]
  • CopyScalarsOff() [virtual]
  • CopyScalarsOn() [virtual]
  • CopyTCoordsOff() [virtual]
  • CopyTCoordsOn() [virtual]
  • CopyTensorsOff() [virtual]
  • CopyTensorsOn() [virtual]
  • CopyTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType fromId, vtkIdType toId)
  • CopyVectorsOff() [virtual]
  • CopyVectorsOn() [virtual]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkFieldData *pd) [virtual]
  • Delete() [virtual]
  • DoCopyAllOff [protected]
  • DoCopyAllOn [protected]
  • EXACT enum value
  • FindFlag(const char *field) [protected]
  • GetActualMemorySize() [virtual]
  • GetArray(int i)
  • GetArray(const char *arrayName, int &index)
  • GetArray(const char *arrayName)
  • GetArrayContainingComponent(int i, int &arrayComp)
  • GetArrayName(int i) [inline]
  • GetAttribute(int attributeType)
  • GetAttributeIndices(int *indexArray)
  • GetAttributeTypeAsString(int attributeType) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j)
  • GetCopyNormals()
  • GetCopyScalars()
  • GetCopyTCoords()
  • GetCopyTensors()
  • GetCopyVectors()
  • GetDebug()
  • GetField(vtkIdList *ptId, vtkFieldData *f)
  • GetFlag(const char *field) [protected]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormals()
  • GetNormals(const char *name)
  • GetNumberOfArrays()
  • GetNumberOfComponents()
  • GetNumberOfTuples()
  • GetReferenceCount() [inline]
  • GetScalars()
  • GetScalars(const char *name)
  • GetTCoords()
  • GetTCoords(const char *name)
  • GetTensors()
  • GetTensors(const char *name)
  • GetTuple(const vtkIdType i)
  • GetTuple(const vtkIdType i, float *tuple)
  • GetVectors()
  • GetVectors(const char *name)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitializeFields() [protected, virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c)
  • InsertNextTuple(const float *tuple)
  • InsertTuple(const vtkIdType i, const float *tuple)
  • InterpolateAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • InterpolateEdge(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdType p1, vtkIdType p2, float t)
  • InterpolatePoint(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdList *ids, float *weights)
  • InterpolateTime(vtkDataSetAttributes *from1, vtkDataSetAttributes *from2, vtkIdType id, float t)
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdList *ptIds, float *weights) [protected]
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdType id1, vtkIdType id2, float t) [protected]
  • InterpolateTuple(vtkDataArray *fromData1, vtkDataArray *fromData2, vtkDataArray *toData, vtkIdType id, float t) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsArrayAnAttribute(int idx)
  • IsTypeOf(const char *name) [static]
  • MakeObject()
  • MAX enum value
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NOLIMIT enum value
  • NORMALS enum value
  • NUM_ATTRIBUTES enum value
  • NumberOfActiveArrays [protected]
  • NumberOfArrays [protected]
  • NumberOfAttributeComponents [protected, static]
  • NumberOfFieldFlags [protected]
  • operator=(const vtkCellData &) (defined in vtkCellData) [private]
  • PassData(vtkFieldData *fd) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveArray(const char *name) [virtual]
  • RemoveArray(int index) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequiredArrays [protected]
  • Reset()
  • SafeDownCast(vtkObject *o) [static]
  • SCALARS enum value
  • SetActiveAttribute(const char *name, int attributeType)
  • SetActiveAttribute(int index, int attributeType)
  • SetActiveNormals(const char *name)
  • SetActiveScalars(const char *name)
  • SetActiveTCoords(const char *name)
  • SetActiveTensors(const char *name)
  • SetActiveVectors(const char *name)
  • SetArray(int i, vtkDataArray *array) [protected]
  • SetComponent(const vtkIdType i, const int j, const float c)
  • SetCopyAttribute(int index, int value)
  • SetCopyNormals(int i)
  • SetCopyScalars(int i)
  • SetCopyTCoords(int i)
  • SetCopyTensors(int i)
  • SetCopyVectors(int i)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormals(vtkDataArray *da)
  • SetNumberOfArrays(int num) [inline]
  • SetNumberOfTuples(const vtkIdType number)
  • SetReferenceCount(int)
  • SetScalars(vtkDataArray *da)
  • SetTCoords(vtkDataArray *da)
  • SetTensors(vtkDataArray *da)
  • SetTuple(const vtkIdType i, const float *tuple)
  • SetVectors(vtkDataArray *da)
  • ShallowCopy(vtkFieldData *pd) [virtual]
  • Squeeze()
  • SubjectHelper [protected]
  • TargetIndices [protected]
  • TCOORDS enum value
  • TENSORS enum value
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline, virtual]
  • VECTORS enum value
  • vtkCellData() [inline, protected]
  • vtkCellData(const vtkCellData &) (defined in vtkCellData) [private]
  • vtkDataSetAttributes() [protected]
  • vtkDataSetAttributes::FieldList class [friend]
  • vtkFieldData() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCellData, vtkDataSetAttributes)
  • ~vtkCellData() [inline, protected]
  • ~vtkDataSetAttributes() [protected]
  • ~vtkFieldData() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellDataToPointData Member List

This is the complete list of members for vtkCellDataToPointData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassCellData() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCellDataToPointData &) (defined in vtkCellDataToPointData) [private]
  • Outputs [protected]
  • PassCellData [protected]
  • PassCellDataOff() [virtual]
  • PassCellDataOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPassCellData(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCellDataToPointData() [protected]
  • vtkCellDataToPointData(const vtkCellDataToPointData &) (defined in vtkCellDataToPointData) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCellDataToPointData, vtkDataSetToDataSetFilter)
  • ~vtkCellDataToPointData() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellDerivatives Member List

This is the complete list of members for vtkCellDerivatives, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTensorMode() [virtual]
  • GetTensorModeAsString()
  • GetUnstructuredGridOutput()
  • GetVectorMode() [virtual]
  • GetVectorModeAsString()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCellDerivatives &) (defined in vtkCellDerivatives) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTensorMode(int) [virtual]
  • SetTensorModeToComputeGradient() [inline]
  • SetTensorModeToComputeStrain() [inline]
  • SetTensorModeToPassTensors() [inline]
  • SetVectorMode(int) [virtual]
  • SetVectorModeToComputeGradient() [inline]
  • SetVectorModeToComputeVorticity() [inline]
  • SetVectorModeToPassVectors() [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TensorMode [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorMode [protected]
  • vtkCellDerivatives() [protected]
  • vtkCellDerivatives(const vtkCellDerivatives &) (defined in vtkCellDerivatives) [private]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCellDerivatives, vtkDataSetToDataSetFilter)
  • ~vtkCellDerivatives() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellLinks Member List

This is the complete list of members for vtkCellLinks, including all inherited members.
  • AddCellReference(vtkIdType cellId, vtkIdType ptId) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(vtkIdType numLinks, vtkIdType ext=1000)
  • AllocateLinks(vtkIdType n) [protected]
  • Array [protected]
  • BreakOnError() [static]
  • BuildLinks(vtkDataSet *data)
  • BuildLinks(vtkDataSet *data, vtkCellArray *Connectivity)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCellLinks *src)
  • Delete() [virtual]
  • DeletePoint(vtkIdType ptId) [inline]
  • Extend [protected]
  • GetActualMemorySize()
  • GetCells(vtkIdType ptId) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLink(vtkIdType ptId) [inline]
  • GetMTime() [virtual]
  • GetNcells(vtkIdType ptId) [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IncrementLinkCount(vtkIdType ptId) [inline, protected]
  • InsertCellReference(vtkIdType ptId, unsigned short pos, vtkIdType cellId) [inline, protected]
  • InsertNextCellReference(vtkIdType ptId, vtkIdType cellId) [inline]
  • InsertNextPoint(int numLinks)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCellLinks &) (defined in vtkCellLinks) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveCellReference(vtkIdType cellId, vtkIdType ptId) [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset()
  • Resize(vtkIdType sz) [protected]
  • ResizeCellList(vtkIdType ptId, int size) [inline]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Size [protected]
  • Squeeze()
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCellLinks() [inline, protected]
  • vtkCellLinks(const vtkCellLinks &) (defined in vtkCellLinks) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCellLinks, vtkObject)
  • ~vtkCellLinks() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellLocator Member List

This is the complete list of members for vtkCellLocator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • Buckets [protected]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • CacheCellBounds [protected]
  • CacheCellBoundsOff() [virtual]
  • CacheCellBoundsOn() [virtual]
  • CellBounds [protected]
  • CellHasBeenVisited [protected]
  • ClearCellHasBeenVisited() [protected]
  • ClearCellHasBeenVisited(int id) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distance2ToBounds(float x[3], float bounds[6]) [protected]
  • Distance2ToBucket(float x[3], int nei[3]) [protected]
  • FindClosestPoint(float x[3], float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPoint(float x[3], float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2, int &inside)
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int numDivs, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateIndex(int offset, int numDivs, int i, int j, int k, vtkIdType &idx) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(int ijk[3], int ndivs, int level) [protected]
  • GetBuildTime() [virtual]
  • GetCacheCellBounds() [virtual]
  • GetCells(int bucket) [virtual]
  • GetChildren(int idx, int level, int children[8]) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfBuckets(void) [virtual]
  • GetNumberOfCellsPerBucket() [virtual]
  • GetOverlappingBuckets(float x[3], int ijk[3], float dist, int prevMinLevel[3], int prevMaxLevel[3]) [protected]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId) [virtual]
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId, vtkGenericCell *cell) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MarkParents(void *, int, int, int, int, int) [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfCellsPerBucket [protected]
  • NumberOfDivisions [protected]
  • NumberOfOctants [protected]
  • NumberOfParents [protected]
  • operator=(const vtkCellLocator &) (defined in vtkCellLocator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • QueryNumber [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetCacheCellBounds(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfCellsPerBucket(int) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Tree [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkCellLocator() [protected]
  • vtkCellLocator(const vtkCellLocator &) (defined in vtkCellLocator) [private]
  • vtkLocator() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCellLocator, vtkLocator)
  • ~vtkCellLocator() [protected]
  • ~vtkLocator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellPicker Member List

This is the complete list of members for vtkCellPicker, including all inherited members.
  • Actors [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • Cell (defined in vtkCellPicker) [private]
  • CellId [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetActor() [virtual]
  • GetActor2D() [virtual]
  • GetActors() [inline]
  • GetAssembly() [virtual]
  • GetCellId() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMapper() [virtual]
  • GetMapperPosition() [virtual]
  • GetMapperPosition(float data[3]) [virtual]
  • GetMTime() [virtual]
  • GetPath() [virtual]
  • GetPCoords() [virtual]
  • GetPCoords(float data[3]) [virtual]
  • GetPickedPositions() [inline]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetProp() [virtual]
  • GetProp3D() [virtual]
  • GetProp3Ds() [inline]
  • GetPropAssembly() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GetSubId() [virtual]
  • GetTolerance() [virtual]
  • GetVolume() [virtual]
  • GlobalTMin [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • IntersectWithLine(float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Mapper [protected]
  • MapperPosition [protected]
  • MarkPicked(vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m, float tMin, float mapperPos[3]) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCellPicker &) (defined in vtkCellPicker) [private]
  • Path [protected]
  • PCoords [protected]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer) [virtual]
  • Pick(float selectionPt[3], vtkRenderer *ren) [inline]
  • PickedPositions [protected]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Prop3Ds [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPath(vtkAssemblyPath *) [virtual]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • StartPickTag [protected]
  • SubId [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPropPicker() [protected]
  • vtkCellPicker() [protected]
  • vtkCellPicker(const vtkCellPicker &) (defined in vtkCellPicker) [private]
  • vtkObject() [protected]
  • vtkPicker() [protected]
  • vtkTypeRevisionMacro(vtkCellPicker, vtkPicker)
  • ~vtkAbstractPicker() [protected]
  • ~vtkAbstractPropPicker() [protected]
  • ~vtkCellPicker() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPicker() [protected]
Generated on Mon Mar 25 01:16:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCellTypes Member List

This is the complete list of members for vtkCellTypes, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(int sz=512, int ext=1000)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCellTypes *src)
  • Delete() [virtual]
  • DeleteCell(int cellId) [inline]
  • Extend [protected]
  • GetActualMemorySize()
  • GetCellLocation(int cellId) [inline]
  • GetCellType(int cellId) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfTypes() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InsertCell(int id, unsigned char type, int loc)
  • InsertNextCell(unsigned char type, int loc)
  • InsertNextType(unsigned char type) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsType(unsigned char type) [inline]
  • IsTypeOf(const char *name) [static]
  • LocationArray [protected]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCellTypes &) (defined in vtkCellTypes) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset()
  • SafeDownCast(vtkObject *o) [static]
  • SetCellTypes(int ncells, vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Size [protected]
  • Squeeze()
  • SubjectHelper [protected]
  • TypeArray [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCellTypes() [protected]
  • vtkCellTypes(const vtkCellTypes &) (defined in vtkCellTypes) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCellTypes, vtkObject)
  • ~vtkCellTypes() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCGMWriter Member List

This is the complete list of members for vtkCGMWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMode [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetColorMode() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetResolution() [virtual]
  • GetScalarsName() [virtual]
  • GetSort() [virtual]
  • GetSpecifiedColor() [virtual]
  • GetSpecifiedColor(float data[3]) [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetViewport() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkCGMWriter &) (defined in vtkCGMWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Resolution [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToRandomColors() [inline]
  • SetColorModeToSpecifiedColor() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetResolution(int) [virtual]
  • SetScalarsName(const char *) [virtual]
  • SetSort(int) [virtual]
  • SetSpecifiedColor(float, float, float) [virtual]
  • SetSpecifiedColor(float[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetViewport(vtkViewport *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • Sort [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpecifiedColor [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • Viewport [protected]
  • vtkCGMWriter() [protected]
  • vtkCGMWriter(const vtkCGMWriter &) (defined in vtkCGMWriter) [private]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkCGMWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkCGMWriter() [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCharArray Member List

This is the complete list of members for vtkCharArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *ia) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const char c) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const char c) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkCharArray &) (defined in vtkCharArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(char *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const char value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCharArray(vtkIdType numComp=1) [protected]
  • vtkCharArray(const vtkCharArray &) (defined in vtkCharArray) [private]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCharArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkCharArray() [protected]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCleanPolyData Member List

This is the complete list of members for vtkCleanPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AbsoluteTolerance [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ConvertLinesToPoints [protected]
  • ConvertLinesToPointsOff() [virtual]
  • ConvertLinesToPointsOn() [virtual]
  • ConvertPolysToLines [protected]
  • ConvertPolysToLinesOff() [virtual]
  • ConvertPolysToLinesOn() [virtual]
  • ConvertStripsToPolys [protected]
  • ConvertStripsToPolysOff() [virtual]
  • ConvertStripsToPolysOn() [virtual]
  • CreateDefaultLocator(void)
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAbsoluteTolerance() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConvertLinesToPoints() [virtual]
  • GetConvertPolysToLines() [virtual]
  • GetConvertStripsToPolys() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPieceInvariant() [virtual]
  • GetPointMerging() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTolerance() [virtual]
  • GetToleranceIsAbsolute() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OperateOnBounds(float in[6], float out[6]) [virtual]
  • OperateOnPoint(float in[3], float out[3]) [virtual]
  • operator=(const vtkCleanPolyData &) (defined in vtkCleanPolyData) [private]
  • Outputs [protected]
  • PieceInvariant [protected]
  • PieceInvariantOff() [virtual]
  • PieceInvariantOn() [virtual]
  • PointMerging [protected]
  • PointMergingOff() [virtual]
  • PointMergingOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • ReleaseLocator(void)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAbsoluteTolerance(float) [virtual]
  • SetConvertLinesToPoints(int) [virtual]
  • SetConvertPolysToLines(int) [virtual]
  • SetConvertStripsToPolys(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPieceInvariant(int) [virtual]
  • SetPointMerging(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • SetToleranceIsAbsolute(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • ToleranceIsAbsolute [protected]
  • ToleranceIsAbsoluteOff() [virtual]
  • ToleranceIsAbsoluteOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCleanPolyData() [protected]
  • vtkCleanPolyData(const vtkCleanPolyData &) (defined in vtkCleanPolyData) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCleanPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkCleanPolyData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkClipDataSet Member List

This is the complete list of members for vtkClipDataSet, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClipFunction [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GenerateClippedOutput [protected]
  • GenerateClippedOutputOff() [virtual]
  • GenerateClippedOutputOn() [virtual]
  • GenerateClipScalars [protected]
  • GenerateClipScalarsOff() [virtual]
  • GenerateClipScalarsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipFunction() [virtual]
  • GetClippedOutput()
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateClippedOutput() [virtual]
  • GetGenerateClipScalars() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetInsideOut() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsideOut [protected]
  • InsideOutOff() [virtual]
  • InsideOutOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkClipDataSet &) (defined in vtkClipDataSet) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetClipFunction(vtkImplicitFunction *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateClippedOutput(int) [virtual]
  • SetGenerateClipScalars(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetInsideOut(int) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • vtkClipDataSet(vtkImplicitFunction *cf=NULL) [protected]
  • vtkClipDataSet(const vtkClipDataSet &) (defined in vtkClipDataSet) [private]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkClipDataSet, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkClipDataSet() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:16:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkClipPolyData Member List

This is the complete list of members for vtkClipPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClipFunction [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateClippedOutput [protected]
  • GenerateClippedOutputOff() [virtual]
  • GenerateClippedOutputOn() [virtual]
  • GenerateClipScalars [protected]
  • GenerateClipScalarsOff() [virtual]
  • GenerateClipScalarsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipFunction() [virtual]
  • GetClippedOutput()
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateClippedOutput() [virtual]
  • GetGenerateClipScalars() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInsideOut() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsideOut [protected]
  • InsideOutOff() [virtual]
  • InsideOutOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkClipPolyData &) (defined in vtkClipPolyData) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClipFunction(vtkImplicitFunction *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateClippedOutput(int) [virtual]
  • SetGenerateClipScalars(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetInsideOut(int) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • vtkClipPolyData(vtkImplicitFunction *cf=NULL) [protected]
  • vtkClipPolyData(const vtkClipPolyData &) (defined in vtkClipPolyData) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkClipPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkClipPolyData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkClipVolume Member List

This is the complete list of members for vtkClipVolume, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClipFunction [protected]
  • ClippedOutput [protected]
  • ClipVoxel(float value, vtkDataArray *cellScalars, int flip, float origin[3], float spacing[3], vtkIdList *cellIds, vtkPoints *cellPts, vtkPointData *inPD, vtkPointData *outPD, vtkCellData *inCD, vtkIdType cellId, vtkCellData *outCD, vtkCellData *clippedCD) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GenerateClippedOutput [protected]
  • GenerateClippedOutputOff() [virtual]
  • GenerateClippedOutputOn() [virtual]
  • GenerateClipScalars [protected]
  • GenerateClipScalarsOff() [virtual]
  • GenerateClipScalarsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipFunction() [virtual]
  • GetClippedOutput()
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateClippedOutput() [virtual]
  • GetGenerateClipScalars() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInsideOut() [virtual]
  • GetLocator() [virtual]
  • GetMergeTolerance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsideOut [protected]
  • InsideOutOff() [virtual]
  • InsideOutOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • MergeTolerance [protected]
  • Mesh (defined in vtkClipVolume) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkClipVolume &) (defined in vtkClipVolume) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClipFunction(vtkImplicitFunction *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateClippedOutput(int) [virtual]
  • SetGenerateClipScalars(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInsideOut(int) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetMergeTolerance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Triangulator (defined in vtkClipVolume) [private]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • vtkClipVolume(vtkImplicitFunction *cf=NULL) [protected]
  • vtkClipVolume(const vtkClipVolume &) (defined in vtkClipVolume) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToUnstructuredGridFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkClipVolume, vtkStructuredPointsToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkClipVolume() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToUnstructuredGridFilter() [inline, protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:16:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCollection Member List

This is the complete list of members for vtkCollection, including all inherited members.
  • AddItem(vtkObject *)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkCollection &) (defined in vtkCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkCollection(const vtkCollection &) (defined in vtkCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCollection, vtkObject)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCollectionElement Member List

This is the complete list of members for vtkCollectionElement, including all inherited members.
  • Item
  • Next
  • vtkCollectionElement() [inline]
Generated on Mon Mar 25 01:16:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkColorTransferFunction Member List

This is the complete list of members for vtkColorTransferFunction, including all inherited members.
  • AddHSVPoint(float x, float h, float s, float v)
  • AddHSVSegment(float x1, float h1, float s1, float v1, float x2, float h2, float s2, float v2)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRGBPoint(float x, float r, float g, float b)
  • AddRGBSegment(float x1, float r1, float g1, float b1, float x2, float r2, float g2, float b2)
  • Alpha [protected]
  • Blue [protected]
  • BreakOnError() [static]
  • Build() [inline, virtual]
  • BuildFunctionFromTable(float x1, float x2, int size, float *table)
  • BuildTime [protected]
  • Clamping [protected]
  • ClampingOff() [virtual]
  • ClampingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorSpace [protected]
  • ConvertUnsignedCharToRGBA(vtkUnsignedCharArray *colors, int numComp, int numTuples) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkColorTransferFunction *f)
  • Delete() [virtual]
  • Function [protected]
  • FunctionSize [protected]
  • GetAlpha() [virtual]
  • GetBlueValue(float x)
  • GetClamping() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(float x) [inline]
  • GetColor(float x, float rgb[3]) [virtual]
  • GetColorSpace() [virtual]
  • GetCommand(unsigned long tag)
  • GetDataPointer() [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGreenValue(float x)
  • GetLuminance(float x) [inline]
  • GetMTime() [virtual]
  • GetOpacity(float vtkNotUsed(v)) [inline, virtual]
  • GetRange() [virtual]
  • GetRange(float &, float &) [virtual]
  • GetRange(float[2]) [virtual]
  • GetRedValue(float x)
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTable(float x1, float x2, int n, float *table)
  • GetTable(float x1, float x2, int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Green [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HSVToRGB(float h, float s, float v, float &r, float &g, float &b) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MapScalars(vtkDataArray *scalars, int colorMode, int component)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output, int outputFormat)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output) [inline]
  • MapScalarsThroughTable2(void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement) [virtual]
  • MapValue(float v) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfPoints [protected]
  • operator=(const vtkColorTransferFunction &) (defined in vtkColorTransferFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Range [protected]
  • Red [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllPoints()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePoint(float x)
  • RGBToHSV(float r, float g, float b, float &h, float &s, float &v) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAlpha(float alpha)
  • SetClamping(int) [virtual]
  • SetColorSpace(int) [virtual]
  • SetColorSpaceToHSV() [inline]
  • SetColorSpaceToRGB() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetRange(float, float) [inline, protected, virtual]
  • SetRange(float rng[2]) [inline, protected]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Table [protected]
  • TableSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnsignedCharRGBAValue [protected]
  • vtkColorTransferFunction() [protected]
  • vtkColorTransferFunction(const vtkColorTransferFunction &) (defined in vtkColorTransferFunction) [private]
  • vtkObject() [protected]
  • vtkScalarsToColors() [inline, protected]
  • vtkTypeRevisionMacro(vtkColorTransferFunction, vtkScalarsToColors)
  • ~vtkColorTransferFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarsToColors() [inline, protected]
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCommand Member List

This is the complete list of members for vtkCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • CharEvent enum value
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *caller, unsigned long, void *callData)=0 [pure virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • NextDataEvent enum value
  • NoEvent enum value
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetOutputEvent enum value
  • StartEvent enum value
  • StartPickEvent enum value
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • UserEvent enum value
  • vtkCommand() [inline, protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCommand() [inline, protected, virtual]
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCommunicator Member List

This is the complete list of members for vtkCommunicator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAndSetMarshalString(char *str, int strLength) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MarshalDataLength [protected]
  • MarshalString [protected]
  • MarshalStringLength [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkCommunicator &) (defined in vtkCommunicator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadDataArray(vtkDataArray *object) [protected]
  • ReadDataSet(vtkDataSet *object) [protected]
  • ReadImageData(vtkImageData *object) [protected]
  • ReadObject(vtkDataObject *object) [protected]
  • Receive(vtkDataObject *data, int remoteHandle, int tag) [virtual]
  • Receive(vtkDataArray *data, int remoteHandle, int tag) [virtual]
  • Receive(int *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Receive(unsigned long *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Receive(unsigned char *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Receive(char *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Receive(float *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Receive(double *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Send(vtkDataObject *data, int remoteHandle, int tag) [virtual]
  • Send(vtkDataArray *data, int remoteHandle, int tag) [virtual]
  • Send(int *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Send(unsigned long *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Send(unsigned char *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Send(char *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Send(float *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • Send(double *data, int length, int remoteHandle, int tag)=0 [pure virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCommunicator() [protected]
  • vtkCommunicator(const vtkCommunicator &) (defined in vtkCommunicator) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCommunicator, vtkObject)
  • WriteDataArray(vtkDataArray *object) [protected]
  • WriteDataSet(vtkDataSet *object) [protected]
  • WriteImageData(vtkImageData *object) [protected]
  • WriteObject(vtkDataObject *object) [protected]
  • ~vtkCommunicator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCompositeManager Member List

This is the complete list of members for vtkCompositeManager, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BOUNDS_TAG enum value
  • BreakOnError() [static]
  • CheckForAbortComposite() [inline, virtual]
  • CheckForAbortRender() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Composite()
  • CompositeBuffer(int width, int height, int useCharFlag, void *pBuf, float *zBuf, void *pTmp, float *zTmp)=0 [protected, pure virtual]
  • CompositeTime [protected]
  • COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG enum value
  • ComputeVisiblePropBounds(vtkRenderer *ren, float bounds[6]) [virtual]
  • ComputeVisiblePropBoundsRMI()
  • Controller [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndInteractorTag [protected]
  • EndRender()
  • EndTag [protected]
  • ExitInteractor()
  • GetBuffersTime [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCompositeTime() [virtual]
  • GetController() [virtual]
  • GetDebug()
  • GetGetBuffersTime() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetManual() [virtual]
  • GetMaxRenderTime() [virtual]
  • GetMTime() [virtual]
  • GetReductionFactor() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetSetBuffersTime() [virtual]
  • GetUseChar() [virtual]
  • GetUseCompositing() [virtual]
  • GetZ(int x, int y)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeOffScreen()
  • InitializePieces()
  • InitializeRMIs()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Lock [protected]
  • MagnifyBuffer(float *localPdata, int windowSize[2]) [protected]
  • Manual [protected]
  • ManualOff() [virtual]
  • ManualOn() [virtual]
  • MaxRenderTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkCompositeManager &) [protected]
  • PData [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReductionFactor [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • REN_INFO_TAG enum value
  • RENDER_RMI_TAG enum value
  • RendererSize [protected]
  • RenderRMI()
  • RenderWindow [protected]
  • RenderWindowInteractor [protected]
  • ResetCamera(vtkRenderer *ren)
  • ResetCameraClippingRange(vtkRenderer *ren)
  • ResetCameraClippingRangeTag [protected]
  • ResetCameraTag [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBuffersTime [protected]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetManual(int) [virtual]
  • SetReductionFactor(int factor)
  • SetReferenceCount(int)
  • SetRendererSize(int x, int y) [protected]
  • SetRenderWindow(vtkRenderWindow *renWin)
  • SetRenderWindowInteractor(vtkRenderWindowInteractor *iren) [protected]
  • SetUseChar(int) [virtual]
  • SetUseCompositing(int) [virtual]
  • StartInteractor()
  • StartInteractorTag [protected]
  • StartRender()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tags enum name
  • Timer [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UseChar [protected]
  • UseCharOff() [virtual]
  • UseCharOn() [virtual]
  • UseCompositing [protected]
  • UseCompositingOff() [virtual]
  • UseCompositingOn() [virtual]
  • vtkCompositeManager() [protected]
  • vtkCompositeManager(const vtkCompositeManager &) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCompositeManager, vtkObject)
  • WIN_INFO_TAG enum value
  • ZData [protected]
  • ~vtkCompositeManager() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCone Member List

This is the complete list of members for vtkCone, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Angle [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetAngle() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCone &) (defined in vtkCone) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCone() [protected]
  • vtkCone(const vtkCone &) (defined in vtkCone) [private]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCone, vtkImplicitFunction)
  • ~vtkCone() [inline, protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkConeSource Member List

This is the complete list of members for vtkConeSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAngle()
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Height [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkConeSource &) (defined in vtkConeSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Resolution [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAngle(float angle)
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkConeSource(int res=6) [protected]
  • vtkConeSource(const vtkConeSource &) (defined in vtkConeSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkConeSource, vtkPolyDataSource)
  • ~vtkConeSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkConnectivityFilter Member List

This is the complete list of members for vtkConnectivityFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddSeed(vtkIdType id)
  • AddSpecifiedRegion(int id)
  • BreakOnError() [static]
  • CellIds (defined in vtkConnectivityFilter) [private]
  • CellScalars (defined in vtkConnectivityFilter) [private]
  • ClosestPoint [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorRegions [protected]
  • ColorRegionsOff() [virtual]
  • ColorRegionsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteSeed(vtkIdType id)
  • DeleteSpecifiedRegion(int id)
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExtractionMode [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClosestPoint() [virtual]
  • GetClosestPoint(float data[3]) [virtual]
  • GetColorRegions() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractionMode() [virtual]
  • GetExtractionModeAsString() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfExtractedRegions()
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarConnectivity() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float &, float &) [virtual]
  • GetScalarRange(float[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeSeedList()
  • InitializeSpecifiedRegionList()
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InScalars (defined in vtkConnectivityFilter) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • NeighborCellPointIds (defined in vtkConnectivityFilter) [private]
  • New() [static]
  • NewScalars (defined in vtkConnectivityFilter) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumCellsInRegion (defined in vtkConnectivityFilter) [private]
  • operator=(const vtkConnectivityFilter &) (defined in vtkConnectivityFilter) [private]
  • Outputs [protected]
  • PointIds (defined in vtkConnectivityFilter) [private]
  • PointMap (defined in vtkConnectivityFilter) [private]
  • PointNumber (defined in vtkConnectivityFilter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • RegionNumber (defined in vtkConnectivityFilter) [private]
  • RegionSizes [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarConnectivity [protected]
  • ScalarConnectivityOff() [virtual]
  • ScalarConnectivityOn() [virtual]
  • ScalarRange [protected]
  • Seeds [protected]
  • SetAbortExecute(int) [virtual]
  • SetClosestPoint(float, float, float) [virtual]
  • SetClosestPoint(float[3]) [virtual]
  • SetColorRegions(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractionMode(int) [virtual]
  • SetExtractionModeToAllRegions() [inline]
  • SetExtractionModeToCellSeededRegions() [inline]
  • SetExtractionModeToClosestPointRegion() [inline]
  • SetExtractionModeToLargestRegion() [inline]
  • SetExtractionModeToPointSeededRegions() [inline]
  • SetExtractionModeToSpecifiedRegions() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarConnectivity(int) [virtual]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpecifiedRegionIds [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TraverseAndMark() [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Visited (defined in vtkConnectivityFilter) [private]
  • vtkConnectivityFilter() [protected]
  • vtkConnectivityFilter(const vtkConnectivityFilter &) (defined in vtkConnectivityFilter) [private]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkConnectivityFilter, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • Wave (defined in vtkConnectivityFilter) [private]
  • Wave2 (defined in vtkConnectivityFilter) [private]
  • ~vtkConnectivityFilter() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:16:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkContainer Member List

This is the complete list of members for vtkContainer, including all inherited members.
  • Delete() [inline]
  • GetNumberOfItems()=0 [pure virtual]
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • RemoveAllItems()=0 [pure virtual]
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • vtkContainer() [inline, protected]
  • ~vtkContainer() [inline, protected, virtual]
Generated on Mon Mar 25 01:16:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkContourFilter Member List

This is the complete list of members for vtkContourFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarTree() [virtual]
  • GetUseScalarTree() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkContourFilter &) (defined in vtkContourFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTree [protected]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarTree(vtkScalarTree *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseScalarTree(int) [virtual]
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseScalarTree [protected]
  • UseScalarTreeOff() [virtual]
  • UseScalarTreeOn() [virtual]
  • vtkContourFilter() [protected]
  • vtkContourFilter(const vtkContourFilter &) (defined in vtkContourFilter) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkContourFilter, vtkDataSetToPolyDataFilter)
  • ~vtkContourFilter() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkContourGrid Member List

This is the complete list of members for vtkContourGrid, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EdgeTable [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseScalarTree() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkContourGrid &) (defined in vtkContourGrid) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTree [protected]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input) [virtual]
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseScalarTree(int) [virtual]
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseScalarTree [protected]
  • UseScalarTreeOff() [virtual]
  • UseScalarTreeOn() [virtual]
  • vtkContourGrid() [protected]
  • vtkContourGrid(const vtkContourGrid &) (defined in vtkContourGrid) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkContourGrid, vtkUnstructuredGridToPolyDataFilter)
  • vtkUnstructuredGridToPolyDataFilter() [inline, protected]
  • ~vtkContourGrid() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:16:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkContourValues Member List

This is the complete list of members for vtkContourValues, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contours [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GenerateValues(int numContours, float range[2])
  • GenerateValues(int numContours, float rangeStart, float rangeEnd)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfContours()
  • GetReferenceCount() [inline]
  • GetValue(int i)
  • GetValues()
  • GetValues(float *contourValues)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkContourValues &) (defined in vtkContourValues) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNumberOfContours(const int number)
  • SetReferenceCount(int)
  • SetValue(int i, float value)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkContourValues() [protected]
  • vtkContourValues(const vtkContourValues &) (defined in vtkContourValues) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkContourValues, vtkObject)
  • ~vtkContourValues() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCoordinate Member List

This is the complete list of members for vtkCoordinate, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputedDisplayValue [protected]
  • ComputedFloatDisplayValue [protected]
  • ComputedFloatViewportValue [protected]
  • ComputedUserDefinedValue [protected]
  • ComputedViewportValue [protected]
  • ComputedWorldValue [protected]
  • Computing [protected]
  • CoordinateSystem [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputedDisplayValue(vtkViewport *)
  • GetComputedFloatDisplayValue(vtkViewport *)
  • GetComputedFloatViewportValue(vtkViewport *)
  • GetComputedLocalDisplayValue(vtkViewport *)
  • GetComputedUserDefinedValue(vtkViewport *) [inline, virtual]
  • GetComputedValue(vtkViewport *)
  • GetComputedViewportValue(vtkViewport *)
  • GetComputedWorldValue(vtkViewport *)
  • GetCoordinateSystem() [virtual]
  • GetCoordinateSystemAsString()
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCoordinate() [virtual]
  • GetReferenceCount() [inline]
  • GetValue() [virtual]
  • GetValue(float &, float &, float &) [virtual]
  • GetValue(float[3]) [virtual]
  • GetViewport() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCoordinate &) (defined in vtkCoordinate) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCoordinate [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetCoordinateSystem(int) [virtual]
  • SetCoordinateSystemToDisplay() [inline]
  • SetCoordinateSystemToNormalizedDisplay() [inline]
  • SetCoordinateSystemToNormalizedViewport() [inline]
  • SetCoordinateSystemToView() [inline]
  • SetCoordinateSystemToViewport() [inline]
  • SetCoordinateSystemToWorld() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCoordinate(vtkCoordinate *) [virtual]
  • SetReferenceCount(int)
  • SetValue(float, float, float) [virtual]
  • SetValue(float[3]) [virtual]
  • SetValue(float a, float b) [inline]
  • SetViewport(vtkViewport *viewport)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Value [protected]
  • Viewport [protected]
  • vtkCoordinate() [protected]
  • vtkCoordinate(const vtkCoordinate &) (defined in vtkCoordinate) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCoordinate, vtkObject)
  • ~vtkCoordinate() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCriticalSection Member List

This is the complete list of members for vtkCriticalSection, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Lock(void) [inline]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCriticalSection &) (defined in vtkCriticalSection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SimpleCriticalSection [protected]
  • SubjectHelper [protected]
  • Unlock(void) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCriticalSection() [inline, protected]
  • vtkCriticalSection(const vtkCriticalSection &) (defined in vtkCriticalSection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCriticalSection, vtkObject)
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCubeAxesActor2D Member List

This is the complete list of members for vtkCubeAxesActor2D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AdjustAxes(float pts[8][3], float bounds[6], int idx, int xIdx, int yIdx, int zIdx, int zIdx2, int xAxes, int yAxes, int zAxes, float xCoords[4], float yCoords[4], float zCoords[4], float xRange[2], float yRange[2], float zRange[2]) [protected]
  • AllocatedRenderTime [protected]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • Camera [protected]
  • ClipBounds(vtkViewport *viewport, float pts[8][3], float bounds[6]) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CornerOffset [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • EvaluateBounds(float planes[24], float bounds[6]) [protected]
  • EvaluatePoint(float planes[24], float x[3]) [protected]
  • FlyMode [protected]
  • FontFactor [protected]
  • FontFamily [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBold() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float &xmin, float &xmax, float &ymin, float &ymax, float &zmin, float &zmax)
  • GetBounds(float bounds[6])
  • GetCamera() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCornerOffset() [virtual]
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFlyMode() [virtual]
  • GetFontFactor() [virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetInertia() [virtual]
  • GetInput() [virtual]
  • GetItalic() [virtual]
  • GetLabelFormat() [virtual]
  • GetLayerNumber() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfLabels() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProp() [virtual]
  • GetProperty()
  • GetRanges()
  • GetRanges(float &xmin, float &xmax, float &ymin, float &ymax, float &zmin, float &zmax)
  • GetRanges(float ranges[6])
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScaling() [virtual]
  • GetShadow() [virtual]
  • GetUseRanges() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GetXAxisVisibility() [virtual]
  • GetXLabel() [virtual]
  • GetYAxisVisibility() [virtual]
  • GetYLabel() [virtual]
  • GetZAxisVisibility() [virtual]
  • GetZLabel() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inertia [protected]
  • InertiaAxes [protected]
  • InitPathTraversal() [virtual]
  • Input [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabelFormat [protected]
  • Labels [protected]
  • LayerNumber [protected]
  • Mapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfLabels [protected]
  • operator=(const vtkCubeAxesActor2D &) (defined in vtkCubeAxesActor2D) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Prop [protected]
  • Property [protected]
  • Ranges [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderCount [protected]
  • RenderOpaqueGeometry(vtkViewport *) [virtual]
  • RenderOverlay(vtkViewport *) [virtual]
  • RenderSomething [protected]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scaling [protected]
  • ScalingOff() [virtual]
  • ScalingOn() [virtual]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBold(int) [virtual]
  • SetBounds(float, float, float, float, float, float) [virtual]
  • SetBounds(float[6]) [virtual]
  • SetCamera(vtkCamera *) [virtual]
  • SetCornerOffset(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFlyMode(int) [virtual]
  • SetFlyModeToClosestTriad() [inline]
  • SetFlyModeToOuterEdges() [inline]
  • SetFontFactor(float) [virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetInertia(int) [virtual]
  • SetInput(vtkDataSet *) [virtual]
  • SetItalic(int) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetNumberOfLabels(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProp(vtkProp *) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetRanges(float, float, float, float, float, float) [virtual]
  • SetRanges(float[6]) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScaling(int) [virtual]
  • SetShadow(int) [virtual]
  • SetUseRanges(int) [virtual]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • SetXAxisVisibility(int) [virtual]
  • SetXLabel(const char *) [virtual]
  • SetYAxisVisibility(int) [virtual]
  • SetYLabel(const char *) [virtual]
  • SetZAxisVisibility(int) [virtual]
  • SetZLabel(const char *) [virtual]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkCubeAxesActor2D *actor)
  • ShallowCopy(vtkProp *prop) (defined in vtkCubeAxesActor2D) [inline, private, virtual]
  • SubjectHelper [protected]
  • TransformBounds(vtkViewport *viewport, float bounds[6], float pts[8][3]) [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UseRanges [protected]
  • UseRangesOff() [virtual]
  • UseRangesOn() [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkCubeAxesActor2D() [protected]
  • vtkCubeAxesActor2D(const vtkCubeAxesActor2D &) (defined in vtkCubeAxesActor2D) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkCubeAxesActor2D, vtkActor2D)
  • XAxis [protected]
  • XAxisVisibility [protected]
  • XAxisVisibilityOff() [virtual]
  • XAxisVisibilityOn() [virtual]
  • XLabel [protected]
  • YAxis [protected]
  • YAxisVisibility [protected]
  • YAxisVisibilityOff() [virtual]
  • YAxisVisibilityOn() [virtual]
  • YLabel [protected]
  • ZAxis [protected]
  • ZAxisVisibility [protected]
  • ZAxisVisibilityOff() [virtual]
  • ZAxisVisibilityOn() [virtual]
  • ZLabel [protected]
  • ~vtkActor2D() [protected]
  • ~vtkCubeAxesActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:16:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCubeSource Member List

This is the complete list of members for vtkCubeSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXLength() [virtual]
  • GetYLength() [virtual]
  • GetZLength() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCubeSource &) (defined in vtkCubeSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBounds(float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
  • SetBounds(float bounds[6])
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXLength(float) [virtual]
  • SetYLength(float) [virtual]
  • SetZLength(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCubeSource(float xL=1.0, float yL=1.0, float zL=1.0) [protected]
  • vtkCubeSource(const vtkCubeSource &) (defined in vtkCubeSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCubeSource, vtkPolyDataSource)
  • XLength [protected]
  • YLength [protected]
  • ZLength [protected]
  • ~vtkCubeSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCuller Member List

This is the complete list of members for vtkCuller, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Cull(vtkRenderer *ren, vtkProp **propList, int &listLength, int &initialized)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkCuller &) (defined in vtkCuller) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCuller() [protected]
  • vtkCuller(const vtkCuller &) (defined in vtkCuller) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCuller, vtkObject)
  • ~vtkCuller() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCullerCollection Member List

This is the complete list of members for vtkCullerCollection, including all inherited members.
  • AddItem(vtkCuller *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkCullerCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastItem() [inline]
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkCullerCollection &) (defined in vtkCullerCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkCullerCollection() [inline, protected]
  • vtkCullerCollection(const vtkCullerCollection &) (defined in vtkCullerCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCullerCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkCullerCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCursor3D Member List

This is the complete list of members for vtkCursor3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllOff()
  • AllOn()
  • Axes [protected]
  • AxesOff() [virtual]
  • AxesOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FocalPoint [protected]
  • Focus [protected]
  • GetAbortExecute() [virtual]
  • GetAxes() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetFocus() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutline() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetWrap() [virtual]
  • GetXShadows() [virtual]
  • GetYShadows() [virtual]
  • GetZShadows() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCursor3D &) (defined in vtkCursor3D) [private]
  • Outline [protected]
  • OutlineOff() [virtual]
  • OutlineOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAxes(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFocalPoint(float, float, float) [virtual]
  • SetFocalPoint(float[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetModelBounds(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SetModelBounds(float bounds[6])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutline(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWrap(int) [virtual]
  • SetXShadows(int) [virtual]
  • SetYShadows(int) [virtual]
  • SetZShadows(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCursor3D() [protected]
  • vtkCursor3D(const vtkCursor3D &) (defined in vtkCursor3D) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCursor3D, vtkPolyDataSource)
  • Wrap [protected]
  • WrapOff() [virtual]
  • WrapOn() [virtual]
  • XShadows [protected]
  • XShadowsOff() [virtual]
  • XShadowsOn() [virtual]
  • YShadows [protected]
  • YShadowsOff() [virtual]
  • YShadowsOn() [virtual]
  • ZShadows [protected]
  • ZShadowsOff() [virtual]
  • ZShadowsOn() [virtual]
  • ~vtkCursor3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCutMaterial Member List

This is the complete list of members for vtkCutMaterial, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ArrayName [protected]
  • BreakOnError() [static]
  • CenterPoint [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeMaximumPoint(vtkDataSet *input) [protected]
  • ComputeNormal() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetArrayName() [virtual]
  • GetCenterPoint() [virtual]
  • GetCenterPoint(float &, float &, float &) [virtual]
  • GetCenterPoint(float[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaterial() [virtual]
  • GetMaterialArrayName() [virtual]
  • GetMaximumPoint() [virtual]
  • GetMaximumPoint(float &, float &, float &) [virtual]
  • GetMaximumPoint(float[3]) [virtual]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float &, float &, float &) [virtual]
  • GetNormal(float[3]) [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUpVector() [virtual]
  • GetUpVector(float &, float &, float &) [virtual]
  • GetUpVector(float[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Material [protected]
  • MaterialArrayName [protected]
  • MaximumPoint [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCutMaterial &) (defined in vtkCutMaterial) [private]
  • Outputs [protected]
  • PlaneFunction [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetArrayName(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetMaterial(int) [virtual]
  • SetMaterialArrayName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUpVector(float, float, float) [virtual]
  • SetUpVector(float[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UpVector [protected]
  • vtkCutMaterial() [protected]
  • vtkCutMaterial(const vtkCutMaterial &) (defined in vtkCutMaterial) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCutMaterial, vtkDataSetToPolyDataFilter)
  • ~vtkCutMaterial() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCutter Member List

This is the complete list of members for vtkCutter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • CutFunction [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateCutScalars [protected]
  • GenerateCutScalarsOff() [virtual]
  • GenerateCutScalarsOn() [virtual]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCutFunction() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateCutScalars() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSortBy() [virtual]
  • GetSortByAsString() [inline]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCutter &) (defined in vtkCutter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCutFunction(vtkImplicitFunction *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateCutScalars(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSortBy(int) [virtual]
  • SetSortByToSortByCell() [inline]
  • SetSortByToSortByValue() [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortBy [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCutter(vtkImplicitFunction *cf=NULL) [protected]
  • vtkCutter(const vtkCutter &) (defined in vtkCutter) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCutter, vtkDataSetToPolyDataFilter)
  • ~vtkCutter() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCylinder Member List

This is the complete list of members for vtkCylinder, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkCylinder &) (defined in vtkCylinder) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCylinder() [protected]
  • vtkCylinder(const vtkCylinder &) (defined in vtkCylinder) [private]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkCylinder, vtkImplicitFunction)
  • ~vtkCylinder() [inline, protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkCylinderSource Member List

This is the complete list of members for vtkCylinderSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCapping() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Height [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkCylinderSource &) (defined in vtkCylinderSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Resolution [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCapping(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCylinderSource(int res=6) [protected]
  • vtkCylinderSource(const vtkCylinderSource &) (defined in vtkCylinderSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkCylinderSource, vtkPolyDataSource)
  • ~vtkCylinderSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDashedStreamLine Member List

This is the complete list of members for vtkDashedStreamLine, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeVorticity() [protected]
  • DashFactor [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDashFactor() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetIntegrationDirection() [virtual]
  • GetIntegrationDirectionAsString() [inline]
  • GetIntegrationStepLength() [virtual]
  • GetIntegrator() [virtual]
  • GetMaximumPropagationTime() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamers() [protected, virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrientationScalars() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSavePointInterval() [virtual]
  • GetSource()
  • GetSpeedScalars() [virtual]
  • GetStartLocation(int &subId, float pcoords[3])
  • GetStartPosition()
  • GetStepLength() [virtual]
  • GetStreamers() [inline, protected]
  • GetTerminalSpeed() [virtual]
  • GetVorticity() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeThreadedIntegrate() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Integrate() [protected]
  • IntegrationDirection [protected]
  • IntegrationStepLength [protected]
  • Integrator [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumPropagationTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamers [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkDashedStreamLine &) (defined in vtkDashedStreamLine) [private]
  • OrientationScalars [protected]
  • OrientationScalarsOff() [virtual]
  • OrientationScalarsOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavePointInterval [protected]
  • SetAbortExecute(int) [virtual]
  • SetDashFactor(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetIntegrationDirection(int) [virtual]
  • SetIntegrationDirectionToBackward() [inline]
  • SetIntegrationDirectionToForward() [inline]
  • SetIntegrationDirectionToIntegrateBothDirections() [inline]
  • SetIntegrationStepLength(float) [virtual]
  • SetIntegrator(vtkInitialValueProblemSolver *) [virtual]
  • SetMaximumPropagationTime(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrientationScalars(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSavePointInterval(float) [virtual]
  • SetSource(vtkDataSet *source)
  • SetSpeedScalars(int) [virtual]
  • SetStartLocation(vtkIdType cellId, int subId, float pcoords[3])
  • SetStartLocation(vtkIdType cellId, int subId, float r, float s, float t)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPosition(float x[3])
  • SetStartPosition(float x, float y, float z)
  • SetStepLength(float) [virtual]
  • SetTerminalSpeed(float) [virtual]
  • SetVorticity(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpeedScalars [protected]
  • SpeedScalarsOff() [virtual]
  • SpeedScalarsOn() [virtual]
  • SqueezeInputArray()
  • StartCell [protected]
  • StartFrom [protected]
  • StartPCoords [protected]
  • StartPosition [protected]
  • StartSubId [protected]
  • StartTag [protected]
  • StepLength [protected]
  • Streamers [protected]
  • SubjectHelper [protected]
  • TerminalSpeed [protected]
  • ThreadedIntegrate(void *arg) [protected, static]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vorticity [protected]
  • VorticityOff() [virtual]
  • VorticityOn() [virtual]
  • vtkDashedStreamLine() [protected]
  • vtkDashedStreamLine(const vtkDashedStreamLine &) (defined in vtkDashedStreamLine) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStreamer() [protected]
  • vtkStreamLine() [protected]
  • vtkTypeRevisionMacro(vtkDashedStreamLine, vtkStreamLine)
  • ~vtkDashedStreamLine() [inline, protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStreamer() [protected]
  • ~vtkStreamLine() [inline, protected]
Generated on Mon Mar 25 01:16:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataArray Member List

This is the complete list of members for vtkDataArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)=0 [pure virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentForLastRange (defined in vtkDataArray) [private]
  • ComputeRange(int comp) [virtual]
  • ComputeTimeForLastRange (defined in vtkDataArray) [private]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType()=0 [pure virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize()=0 [pure virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i)=0 [pure virtual]
  • GetTuple(const vtkIdType i, float *tuple)=0 [pure virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTupleN(const vtkIdType i, int n) (defined in vtkDataArray) [private]
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetVoidPointer(const vtkIdType id)=0 [pure virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize()=0 [pure virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple)=0 [pure virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertTuple(const vtkIdType i, const float *tuple)=0 [pure virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject()=0 [pure virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [inline, static]
  • NumberOfComponents [protected]
  • operator=(const vtkDataArray &) (defined in vtkDataArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Range (defined in vtkDataArray) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples)=0 [pure virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number)=0 [pure virtual]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple)=0 [pure virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze()=0 [pure virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkDataArray(const vtkDataArray &) (defined in vtkDataArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataArray, vtkObject)
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObject Member List

This is the complete list of members for vtkDataObject, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • GetActualMemorySize() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocality() [virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfConsumers() [virtual]
  • GetPipelineMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetSource() [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InternalDataObjectCopy(vtkDataObject *src) (defined in vtkDataObject) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkDataObject &) (defined in vtkDataObject) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [virtual]
  • SetUpdateExtent(int ext[6]) [virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • vtkDataObject() [protected]
  • vtkDataObject(const vtkDataObject &) (defined in vtkDataObject) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataObject, vtkObject)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObjectCollection Member List

This is the complete list of members for vtkDataObjectCollection, including all inherited members.
  • AddItem(vtkDataObject *ds) [inline]
  • AddItem(vtkObject *o) (defined in vtkDataObjectCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItem(int i) [inline]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkDataObjectCollection &) (defined in vtkDataObjectCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkDataObjectCollection() [inline, protected]
  • vtkDataObjectCollection(const vtkDataObjectCollection &) (defined in vtkDataObjectCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataObjectCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkDataObjectCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObjectReader Member List

This is the complete list of members for vtkDataObjectReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkDataObjectReader &) (defined in vtkDataObjectReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataObject *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataObjectReader() [protected]
  • vtkDataObjectReader(const vtkDataObjectReader &) (defined in vtkDataObjectReader) [private]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataObjectReader, vtkDataReader)
  • ~vtkDataObjectReader() [protected]
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObjectSource Member List

This is the complete list of members for vtkDataObjectSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataObjectSource &) (defined in vtkDataObjectSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataObject *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataObjectSource() [protected]
  • vtkDataObjectSource(const vtkDataObjectSource &) (defined in vtkDataObjectSource) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataObjectSource, vtkSource)
  • ~vtkDataObjectSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObjectToDataSetFilter Member List

This is the complete list of members for vtkDataObjectToDataSetFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellConnectivityArray [protected]
  • CellConnectivityArrayComponent [protected]
  • CellConnectivityComponentRange [protected]
  • CellTypeArray [protected]
  • CellTypeArrayComponent [protected]
  • CellTypeComponentRange [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ConstructCellArray(vtkDataArray *da, int comp, vtkIdType compRange[2]) [protected]
  • ConstructCells(vtkPolyData *pd) [protected]
  • ConstructCells(vtkUnstructuredGrid *ug) [protected]
  • ConstructDimensions() [protected]
  • ConstructOrigin() [protected]
  • ConstructPoints(vtkPointSet *ps) [protected]
  • ConstructPoints(vtkRectilinearGrid *rg) [protected]
  • ConstructSpacing() [protected]
  • DataSetType [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultNormalize [protected]
  • DefaultNormalizeOff() [virtual]
  • DefaultNormalizeOn() [virtual]
  • Delete() [virtual]
  • Dimensions [protected]
  • DimensionsArray [protected]
  • DimensionsArrayComponent [protected]
  • DimensionsComponentRange [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetCellConnectivityComponentArrayComponent()
  • GetCellConnectivityComponentArrayName()
  • GetCellConnectivityComponentMaxRange()
  • GetCellConnectivityComponentMinRange()
  • GetCellTypeComponentArrayComponent()
  • GetCellTypeComponentArrayName()
  • GetCellTypeComponentMaxRange()
  • GetCellTypeComponentMinRange()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSetType() [virtual]
  • GetDebug()
  • GetDefaultNormalize() [virtual]
  • GetDimensions() [virtual]
  • GetDimensions(int data[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLinesComponentArrayComponent()
  • GetLinesComponentArrayName()
  • GetLinesComponentMaxRange()
  • GetLinesComponentMinRange()
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointComponentArrayComponent(int comp)
  • GetPointComponentArrayName(int comp)
  • GetPointComponentMaxRange(int comp)
  • GetPointComponentMinRange(int comp)
  • GetPointComponentNormailzeFlag(int comp)
  • GetPolyDataOutput()
  • GetPolysComponentArrayComponent()
  • GetPolysComponentArrayName()
  • GetPolysComponentMaxRange()
  • GetPolysComponentMinRange()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float data[3]) [virtual]
  • GetStripsComponentArrayComponent()
  • GetStripsComponentArrayName()
  • GetStripsComponentMaxRange()
  • GetStripsComponentMinRange()
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GetVertsComponentArrayComponent()
  • GetVertsComponentArrayName()
  • GetVertsComponentMaxRange()
  • GetVertsComponentMinRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LinesArray [protected]
  • LinesArrayComponent [protected]
  • LinesComponentRange [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataObjectToDataSetFilter &) (defined in vtkDataObjectToDataSetFilter) [private]
  • Origin [protected]
  • OriginArray [protected]
  • OriginArrayComponent [protected]
  • OriginComponentRange [protected]
  • Outputs [protected]
  • PointArrayComponents [protected]
  • PointArrays [protected]
  • PointComponentRange [protected]
  • PointNormalize [protected]
  • PolysArray [protected]
  • PolysArrayComponent [protected]
  • PolysComponentRange [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetArrayName(char *&name, char *newName) [protected]
  • SetCellConnectivityComponent(char *arrayName, int arrayComp, int min, int max)
  • SetCellConnectivityComponent(char *arrayName, int arrayComp) [inline]
  • SetCellTypeComponent(char *arrayName, int arrayComp, int min, int max)
  • SetCellTypeComponent(char *arrayName, int arrayComp) [inline]
  • SetDataSetType(int)
  • SetDataSetTypeToPolyData() [inline]
  • SetDataSetTypeToRectilinearGrid() [inline]
  • SetDataSetTypeToStructuredGrid() [inline]
  • SetDataSetTypeToStructuredPoints() [inline]
  • SetDataSetTypeToUnstructuredGrid() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultNormalize(int) [virtual]
  • SetDimensions(int, int, int) [virtual]
  • SetDimensions(int[3]) [virtual]
  • SetDimensionsComponent(char *arrayName, int arrayComp, int min, int max)
  • SetDimensionsComponent(char *arrayName, int arrayComp) [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataObject *input)
  • SetLinesComponent(char *arrayName, int arrayComp, int min, int max)
  • SetLinesComponent(char *arrayName, int arrayComp) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOriginComponent(char *arrayName, int arrayComp, int min, int max)
  • SetOriginComponent(char *arrayName, int arrayComp) [inline]
  • SetPointComponent(int comp, char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetPointComponent(int comp, char *arrayName, int arrayComp) [inline]
  • SetPolysComponent(char *arrayName, int arrayComp, int min, int max)
  • SetPolysComponent(char *arrayName, int arrayComp) [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetSpacingComponent(char *arrayName, int arrayComp, int min, int max)
  • SetSpacingComponent(char *arrayName, int arrayComp) [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStripsComponent(char *arrayName, int arrayComp, int min, int max)
  • SetStripsComponent(char *arrayName, int arrayComp) [inline]
  • SetVertsComponent(char *arrayName, int arrayComp, int min, int max)
  • SetVertsComponent(char *arrayName, int arrayComp) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Spacing [protected]
  • SpacingArray [protected]
  • SpacingArrayComponent [protected]
  • SpacingComponentRange [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StripsArray [protected]
  • StripsArrayComponent [protected]
  • StripsComponentRange [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VertsArray [protected]
  • VertsArrayComponent [protected]
  • VertsComponentRange [protected]
  • vtkDataObjectToDataSetFilter() [protected]
  • vtkDataObjectToDataSetFilter(const vtkDataObjectToDataSetFilter &) (defined in vtkDataObjectToDataSetFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataObjectToDataSetFilter, vtkSource)
  • ~vtkDataObjectToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataObjectWriter Member List

This is the complete list of members for vtkDataObjectWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [inline]
  • GetFileName() [inline]
  • GetFileType() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [inline]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataObjectWriter &) (defined in vtkDataObjectWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(char *fieldname) [inline]
  • SetFileName(const char *filename) [inline]
  • SetFileType(int type) [inline]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(char *header) [inline]
  • SetInput(vtkDataObject *input)
  • SetInput(vtkDataObject &input) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • vtkDataObjectWriter() [protected]
  • vtkDataObjectWriter(const vtkDataObjectWriter &) (defined in vtkDataObjectWriter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkDataObjectWriter, vtkWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteData() [protected, virtual]
  • Writer [protected]
  • WriteTime [protected]
  • ~vtkDataObjectWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:16:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataReader Member List

This is the complete list of members for vtkDataReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput(int idx) [protected]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkDataReader &) (defined in vtkDataReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkDataReader(const vtkDataReader &) (defined in vtkDataReader) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataReader, vtkObject)
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:16:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSet Member List

This is the complete list of members for vtkDataSet, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds)=0 [pure virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)=0 [pure virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights)=0 [pure virtual]
  • FindPoint(float x, float y, float z) [inline]
  • FindPoint(float x[3])=0 [pure virtual]
  • GetActualMemorySize() [virtual]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId)=0 [pure virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell)=0 [pure virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds)=0 [pure virtual]
  • GetCellType(vtkIdType cellId)=0 [pure virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize()=0 [pure virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfCells()=0 [pure virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints()=0 [pure virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId)=0 [pure virtual]
  • GetPoint(vtkIdType id, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds)=0 [pure virtual]
  • GetPointData() [inline]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetSource() [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InternalDataSetCopy(vtkDataSet *src) (defined in vtkDataSet) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkDataSet &) (defined in vtkDataSet) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [virtual]
  • SetUpdateExtent(int ext[6]) [virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkDataSet(const vtkDataSet &) (defined in vtkDataSet) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataSet, vtkDataObject)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:16:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetAttributes Member List

This is the complete list of members for vtkDataSetAttributes, including all inherited members.
  • AddArray(vtkDataArray *array)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)
  • AllocateArrays(int num)
  • AttributeIndices [protected]
  • AttributeLimits [protected, static]
  • AttributeLimitTypes enum name
  • AttributeNames [protected, static]
  • AttributeTypes enum name
  • BreakOnError() [static]
  • CheckNumberOfComponents(vtkDataArray *da, int attributeType) (defined in vtkDataSetAttributes) [private, static]
  • ClearFieldFlags() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRequiredArrays(vtkDataSetAttributes *pd) (defined in vtkDataSetAttributes) [private]
  • CopyAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllocate(vtkDataSetAttributes::FieldList &list, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllOff() [virtual]
  • CopyAllOn() [virtual]
  • CopyAttributeFlags [protected]
  • CopyData(vtkDataSetAttributes *fromPd, vtkIdType fromId, vtkIdType toId)
  • CopyData(vtkDataSetAttributes::FieldList &list, vtkDataSetAttributes *dsa, int idx, vtkIdType fromId, vtkIdType toId)
  • CopyFieldFlags [protected]
  • CopyFieldOff(const char *name) [inline]
  • CopyFieldOn(const char *name) [inline]
  • CopyFieldOnOff(const char *name, int onOff) [protected]
  • CopyFlags(const vtkFieldData *source) [protected]
  • CopyNormalsOff() [virtual]
  • CopyNormalsOn() [virtual]
  • CopyScalarsOff() [virtual]
  • CopyScalarsOn() [virtual]
  • CopyTCoordsOff() [virtual]
  • CopyTCoordsOn() [virtual]
  • CopyTensorsOff() [virtual]
  • CopyTensorsOn() [virtual]
  • CopyTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType fromId, vtkIdType toId)
  • CopyVectorsOff() [virtual]
  • CopyVectorsOn() [virtual]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkFieldData *pd) [virtual]
  • Delete() [virtual]
  • DoCopyAllOff [protected]
  • DoCopyAllOn [protected]
  • EXACT enum value
  • FindFlag(const char *field) [protected]
  • GetActualMemorySize() [virtual]
  • GetArray(int i)
  • GetArray(const char *arrayName, int &index)
  • GetArray(const char *arrayName)
  • GetArrayContainingComponent(int i, int &arrayComp)
  • GetArrayName(int i) [inline]
  • GetAttribute(int attributeType)
  • GetAttributeIndices(int *indexArray)
  • GetAttributeTypeAsString(int attributeType) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j)
  • GetCopyNormals()
  • GetCopyScalars()
  • GetCopyTCoords()
  • GetCopyTensors()
  • GetCopyVectors()
  • GetDebug()
  • GetField(vtkIdList *ptId, vtkFieldData *f)
  • GetFlag(const char *field) [protected]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormals()
  • GetNormals(const char *name)
  • GetNumberOfArrays()
  • GetNumberOfComponents()
  • GetNumberOfTuples()
  • GetReferenceCount() [inline]
  • GetScalars()
  • GetScalars(const char *name)
  • GetTCoords()
  • GetTCoords(const char *name)
  • GetTensors()
  • GetTensors(const char *name)
  • GetTuple(const vtkIdType i)
  • GetTuple(const vtkIdType i, float *tuple)
  • GetVectors()
  • GetVectors(const char *name)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitializeFields() [protected, virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c)
  • InsertNextTuple(const float *tuple)
  • InsertTuple(const vtkIdType i, const float *tuple)
  • InterpolateAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • InterpolateEdge(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdType p1, vtkIdType p2, float t)
  • InterpolatePoint(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdList *ids, float *weights)
  • InterpolateTime(vtkDataSetAttributes *from1, vtkDataSetAttributes *from2, vtkIdType id, float t)
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdList *ptIds, float *weights) [protected]
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdType id1, vtkIdType id2, float t) [protected]
  • InterpolateTuple(vtkDataArray *fromData1, vtkDataArray *fromData2, vtkDataArray *toData, vtkIdType id, float t) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsArrayAnAttribute(int idx)
  • IsTypeOf(const char *name) [static]
  • MakeObject()
  • MAX enum value
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NOLIMIT enum value
  • NORMALS enum value
  • NUM_ATTRIBUTES enum value
  • NumberOfActiveArrays [protected]
  • NumberOfArrays [protected]
  • NumberOfAttributeComponents [protected, static]
  • NumberOfFieldFlags [protected]
  • operator=(const vtkDataSetAttributes &) (defined in vtkDataSetAttributes) [private]
  • PassData(vtkFieldData *fd) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveArray(const char *name) [virtual]
  • RemoveArray(int index) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequiredArrays [protected]
  • Reset()
  • SafeDownCast(vtkObject *o) [static]
  • SCALARS enum value
  • SetActiveAttribute(const char *name, int attributeType)
  • SetActiveAttribute(int index, int attributeType)
  • SetActiveNormals(const char *name)
  • SetActiveScalars(const char *name)
  • SetActiveTCoords(const char *name)
  • SetActiveTensors(const char *name)
  • SetActiveVectors(const char *name)
  • SetArray(int i, vtkDataArray *array) [protected]
  • SetAttribute(vtkDataArray *da, int attributeType) (defined in vtkDataSetAttributes) [private]
  • SetComponent(const vtkIdType i, const int j, const float c)
  • SetCopyAttribute(int index, int value)
  • SetCopyNormals(int i)
  • SetCopyScalars(int i)
  • SetCopyTCoords(int i)
  • SetCopyTensors(int i)
  • SetCopyVectors(int i)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormals(vtkDataArray *da)
  • SetNumberOfArrays(int num) [inline]
  • SetNumberOfTuples(const vtkIdType number)
  • SetReferenceCount(int)
  • SetScalars(vtkDataArray *da)
  • SetTCoords(vtkDataArray *da)
  • SetTensors(vtkDataArray *da)
  • SetTuple(const vtkIdType i, const float *tuple)
  • SetVectors(vtkDataArray *da)
  • ShallowCopy(vtkFieldData *pd) [virtual]
  • Squeeze()
  • SubjectHelper [protected]
  • TargetIndices [protected]
  • TCOORDS enum value
  • TENSORS enum value
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline, virtual]
  • VECTORS enum value
  • vtkDataSetAttributes() [protected]
  • vtkDataSetAttributes(const vtkDataSetAttributes &) (defined in vtkDataSetAttributes) [private]
  • vtkDataSetAttributes::FieldList class [friend]
  • vtkFieldData() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataSetAttributes, vtkFieldData)
  • ~vtkDataSetAttributes() [protected]
  • ~vtkFieldData() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetAttributes::FieldList Member List

This is the complete list of members for vtkDataSetAttributes::FieldList, including all inherited members.
  • ClearFields() (defined in vtkDataSetAttributes::FieldList) [private]
  • CurrentInput (defined in vtkDataSetAttributes::FieldList) [private]
  • DSAIndices (defined in vtkDataSetAttributes::FieldList) [private]
  • FieldComponents (defined in vtkDataSetAttributes::FieldList) [private]
  • FieldIndices (defined in vtkDataSetAttributes::FieldList) [private]
  • FieldList(int numInputs)
  • FieldList(const FieldList &) [inline, protected]
  • Fields (defined in vtkDataSetAttributes::FieldList) [private]
  • FieldTypes (defined in vtkDataSetAttributes::FieldList) [private]
  • InitializeFieldList(vtkDataSetAttributes *dsa)
  • IntersectFieldList(vtkDataSetAttributes *dsa)
  • IsAttributePresent(int attrType)
  • LUT (defined in vtkDataSetAttributes::FieldList) [private]
  • NumberOfDSAIndices (defined in vtkDataSetAttributes::FieldList) [private]
  • NumberOfFields (defined in vtkDataSetAttributes::FieldList) [private]
  • NumberOfTuples (defined in vtkDataSetAttributes::FieldList) [private]
  • operator=(const FieldList &) [inline, protected]
  • RemoveField(const char *name) (defined in vtkDataSetAttributes::FieldList) [private]
  • SetField(int index, vtkDataArray *da) (defined in vtkDataSetAttributes::FieldList) [private]
  • vtkDataSetAttributes class [friend]
  • ~FieldList()
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetCollection Member List

This is the complete list of members for vtkDataSetCollection, including all inherited members.
  • AddItem(vtkDataSet *ds) [inline]
  • AddItem(vtkObject *o) (defined in vtkDataSetCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItem(int i) [inline]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkDataSetCollection &) (defined in vtkDataSetCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkDataSetCollection() [inline, protected]
  • vtkDataSetCollection(const vtkDataSetCollection &) (defined in vtkDataSetCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDataSetCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkDataSetCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetMapper Member List

This is the complete list of members for vtkDataSetMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(const char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GeometryExtractor [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalImmediateModeRendering() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImmediateModeRendering() [virtual]
  • GetInput()
  • GetInputAsDataSet() [inline]
  • GetInputs() [inline]
  • GetLength()
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetPolyDataMapper() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTime() [virtual]
  • GetResolveCoincidentTopology() [static]
  • GetResolveCoincidentTopologyPolygonOffsetParameters(float &factor, float &units) [static]
  • GetResolveCoincidentTopologyZShift() [static]
  • GetScalarMode() [virtual]
  • GetScalarModeAsString()
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalImmediateModeRenderingOff() [inline, static]
  • GlobalImmediateModeRenderingOn() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImmediateModeRendering [protected]
  • ImmediateModeRenderingOff() [virtual]
  • ImmediateModeRenderingOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetMapper &) (defined in vtkDataSetMapper) [private]
  • PolyDataMapper [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkActor *act) [virtual]
  • RenderTime [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalImmediateModeRendering(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImmediateModeRendering(int) [virtual]
  • SetInput(vtkDataSet *input)
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTime(float time) [inline]
  • SetResolveCoincidentTopology(int val) [static]
  • SetResolveCoincidentTopologyPolygonOffsetParameters(float factor, float units) [static]
  • SetResolveCoincidentTopologyToDefault() [static]
  • SetResolveCoincidentTopologyToOff() [inline, static]
  • SetResolveCoincidentTopologyToPolygonOffset() [inline, static]
  • SetResolveCoincidentTopologyToShiftZBuffer() [inline, static]
  • SetResolveCoincidentTopologyZShift(double val) [static]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkDataSetMapper() [protected]
  • vtkDataSetMapper(const vtkDataSetMapper &) (defined in vtkDataSetMapper) [private]
  • vtkMapper() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkDataSetMapper, vtkMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkDataSetMapper() [protected]
  • ~vtkMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:17:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetReader Member List

This is the complete list of members for vtkDataSetReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetUnstructuredGridOutput()
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkDataSetReader &) (defined in vtkDataSetReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • Reader [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadOutputType() [virtual]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkDataSetReader() [protected]
  • vtkDataSetReader(const vtkDataSetReader &) (defined in vtkDataSetReader) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetReader, vtkDataReader)
  • ~vtkDataReader() [protected]
  • ~vtkDataSetReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetSource Member List

This is the complete list of members for vtkDataSetSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetSource &) (defined in vtkDataSetSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetSource(const vtkDataSetSource &) (defined in vtkDataSetSource) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetSource, vtkSource)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetSurfaceFilter Member List

This is the complete list of members for vtkDataSetSurfaceFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • DataSetExecute() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteQuadHash() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteFaceQuads(vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis) [protected]
  • ExecuteFaceStrips(vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis) [protected]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNextVisibleQuadFromHash() [protected]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputPointId(vtkIdType inPtId, vtkDataSet *input, vtkPoints *outPts, vtkPointData *outPD) [protected]
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseStrips() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeQuadHash(vtkIdType numPoints) [protected]
  • InitQuadHashTraversal() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsertQuadInHash(vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType d, vtkIdType sourceId) [protected]
  • InsertTriInHash(vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType sourceId) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfNewCells [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetSurfaceFilter &) (defined in vtkDataSetSurfaceFilter) [private]
  • Outputs [protected]
  • PointMap [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QuadHash [protected]
  • QuadHashLength [protected]
  • QuadHashTraversal [protected]
  • QuadHashTraversalIndex [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseStrips(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredExecute(vtkDataSet *input, int *ext) [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredGridExecute() [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseStrips [protected]
  • UseStripsOff() [virtual]
  • UseStripsOn() [virtual]
  • vtkDataSetSurfaceFilter() [protected]
  • vtkDataSetSurfaceFilter(const vtkDataSetSurfaceFilter &) (defined in vtkDataSetSurfaceFilter) [private]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetSurfaceFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetSurfaceFilter() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToDataObjectFilter Member List

This is the complete list of members for vtkDataSetToDataObjectFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellData [protected]
  • CellDataOff() [virtual]
  • CellDataOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldData [protected]
  • FieldDataOff() [virtual]
  • FieldDataOn() [virtual]
  • Geometry [protected]
  • GeometryOff() [virtual]
  • GeometryOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetCellData() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldData() [virtual]
  • GetGeometry() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointData() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTopology() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToDataObjectFilter &) (defined in vtkDataSetToDataObjectFilter) [private]
  • Outputs [protected]
  • PointData [protected]
  • PointDataOff() [virtual]
  • PointDataOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCellData(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldData(int) [virtual]
  • SetGeometry(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataObject *)
  • SetPointData(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTopology(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Topology [protected]
  • TopologyOff() [virtual]
  • TopologyOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataObjectSource() [protected]
  • vtkDataSetToDataObjectFilter() [protected]
  • vtkDataSetToDataObjectFilter(const vtkDataSetToDataObjectFilter &) (defined in vtkDataSetToDataObjectFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToDataObjectFilter, vtkDataObjectSource)
  • ~vtkDataObjectSource() [inline, protected]
  • ~vtkDataSetToDataObjectFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToDataSetFilter Member List

This is the complete list of members for vtkDataSetToDataSetFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToDataSetFilter &) (defined in vtkDataSetToDataSetFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkDataSetToDataSetFilter(const vtkDataSetToDataSetFilter &) (defined in vtkDataSetToDataSetFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToDataSetFilter, vtkDataSetSource)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToPolyDataFilter Member List

This is the complete list of members for vtkDataSetToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToPolyDataFilter &) (defined in vtkDataSetToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkDataSetToPolyDataFilter(const vtkDataSetToPolyDataFilter &) (defined in vtkDataSetToPolyDataFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToPolyDataFilter, vtkPolyDataSource)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToStructuredGridFilter Member List

This is the complete list of members for vtkDataSetToStructuredGridFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToStructuredGridFilter &) (defined in vtkDataSetToStructuredGridFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredGridFilter() [inline, protected]
  • vtkDataSetToStructuredGridFilter(const vtkDataSetToStructuredGridFilter &) (defined in vtkDataSetToStructuredGridFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToStructuredGridFilter, vtkStructuredGridSource)
  • ~vtkDataSetToStructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:17:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToStructuredPointsFilter Member List

This is the complete list of members for vtkDataSetToStructuredPointsFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToStructuredPointsFilter &) (defined in vtkDataSetToStructuredPointsFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkDataSetToStructuredPointsFilter(const vtkDataSetToStructuredPointsFilter &) (defined in vtkDataSetToStructuredPointsFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToStructuredPointsFilter, vtkStructuredPointsSource)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:17:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetToUnstructuredGridFilter Member List

This is the complete list of members for vtkDataSetToUnstructuredGridFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetToUnstructuredGridFilter &) (defined in vtkDataSetToUnstructuredGridFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkDataSetToUnstructuredGridFilter(const vtkDataSetToUnstructuredGridFilter &) (defined in vtkDataSetToUnstructuredGridFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetToUnstructuredGridFilter, vtkUnstructuredGridSource)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:17:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetTriangleFilter Member List

This is the complete list of members for vtkDataSetTriangleFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDataSetTriangleFilter &) (defined in vtkDataSetTriangleFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredExecute() [protected]
  • SubjectHelper [protected]
  • Triangulator [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredExecute() [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkDataSetTriangleFilter() [inline, protected]
  • vtkDataSetTriangleFilter(const vtkDataSetTriangleFilter &) (defined in vtkDataSetTriangleFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDataSetTriangleFilter, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkDataSetTriangleFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:17:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataSetWriter Member List

This is the complete list of members for vtkDataSetWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkDataSetWriter &) (defined in vtkDataSetWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkDataSet *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataSetWriter() [inline, protected]
  • vtkDataSetWriter(const vtkDataSetWriter &) (defined in vtkDataSetWriter) [private]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkDataSetWriter, vtkDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataSetWriter() [inline, protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:17:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDataWriter Member List

This is the complete list of members for vtkDataWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkDataWriter &) (defined in vtkDataWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkDataWriter(const vtkDataWriter &) (defined in vtkDataWriter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkDataWriter, vtkWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:17:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDebugLeaks Member List

This is the complete list of members for vtkDebugLeaks, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConstructClass(const char *classname) [static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteTable() [static]
  • DestructClass(const char *classname) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MemoryTable (defined in vtkDebugLeaks) [private, static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkDebugLeaks &) (defined in vtkDebugLeaks) [private]
  • Print(ostream &os)
  • PrintCurrentLeaks() [static]
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PromptUser [protected, static]
  • PromptUserOff() [static]
  • PromptUserOn() [static]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDebugLeaks() [inline, protected]
  • vtkDebugLeaks(const vtkDebugLeaks &) (defined in vtkDebugLeaks) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDebugLeaks, vtkObject)
  • ~vtkDebugLeaks() [inline, protected, virtual]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDecimate Member List

This is the complete list of members for vtkDecimate, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AspectRatio [protected]
  • BoundaryVertexDeletion [protected]
  • BoundaryVertexDeletionOff() [virtual]
  • BoundaryVertexDeletionOn() [virtual]
  • BreakOnError() [static]
  • BuildLoop(vtkIdType ptId, unsigned short int nTris, vtkIdType *tris) [protected]
  • CanSplitLoop(vtkLocalVertexPtr fedges[2], vtkIdType numVerts, vtkLocalVertexPtr verts[], vtkIdType &n1, vtkLocalVertexPtr l1[], vtkIdType &n2, vtkLocalVertexPtr l2[], float &ar) [protected]
  • CheckError() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateOutput(vtkIdType numPts, vtkIdType numTris, vtkIdType numEliminated, vtkPointData *pd, vtkPoints *inPts) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Degree [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • ErrorIncrement [protected]
  • EvaluateLoop(int &vtype, vtkIdType &numFEdges, vtkLocalVertexPtr fedges[]) [protected]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngleIncrement [protected]
  • GenerateErrorScalars [protected]
  • GenerateErrorScalarsOff() [virtual]
  • GenerateErrorScalarsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetAspectRatio() [virtual]
  • GetBoundaryVertexDeletion() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDegree() [virtual]
  • GetErrorCode() [virtual]
  • GetErrorIncrement() [virtual]
  • GetFeatureAngleIncrement() [virtual]
  • GetGenerateErrorScalars() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialError() [virtual]
  • GetInitialFeatureAngle() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumError() [virtual]
  • GetMaximumFeatureAngle() [virtual]
  • GetMaximumIterations() [virtual]
  • GetMaximumNumberOfSquawks() [virtual]
  • GetMaximumSubIterations() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPreserveEdges() [virtual]
  • GetPreserveTopology() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTargetReduction() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitialError [protected]
  • InitialFeatureAngle [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumError [protected]
  • MaximumFeatureAngle [protected]
  • MaximumIterations [protected]
  • MaximumNumberOfSquawks [protected]
  • MaximumSubIterations [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Neighbors [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDecimate &) (defined in vtkDecimate) [private]
  • Outputs [protected]
  • PreserveEdges [protected]
  • PreserveEdgesOff() [virtual]
  • PreserveEdgesOn() [virtual]
  • PreserveTopology [protected]
  • PreserveTopologyOff() [virtual]
  • PreserveTopologyOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAspectRatio(float) [virtual]
  • SetBoundaryVertexDeletion(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDegree(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetErrorIncrement(float) [virtual]
  • SetFeatureAngleIncrement(float) [virtual]
  • SetGenerateErrorScalars(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInitialError(float) [virtual]
  • SetInitialFeatureAngle(float) [virtual]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaximumError(float) [virtual]
  • SetMaximumFeatureAngle(float) [virtual]
  • SetMaximumIterations(int) [virtual]
  • SetMaximumNumberOfSquawks(int) [virtual]
  • SetMaximumSubIterations(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPreserveEdges(int) [virtual]
  • SetPreserveTopology(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetReduction(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitLoop(vtkLocalVertexPtr fedges[2], vtkIdType numVerts, vtkLocalVertexPtr *verts, vtkIdType &n1, vtkLocalVertexPtr *l1, vtkIdType &n2, vtkLocalVertexPtr *l2) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • Stats [protected]
  • SubjectHelper [protected]
  • T [protected]
  • TargetReduction [protected]
  • Triangulate(vtkIdType numVerts, vtkLocalVertexPtr verts[]) [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • V [protected]
  • vtkDecimate() [protected]
  • vtkDecimate(const vtkDecimate &) (defined in vtkDecimate) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDecimate, vtkPolyDataToPolyDataFilter)
  • ~vtkDecimate() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDecimatePro Member List

This is the complete list of members for vtkDecimatePro, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AbsoluteError [protected]
  • AccumulateError [protected]
  • AccumulateErrorOff() [virtual]
  • AccumulateErrorOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BoundaryVertexDeletion [protected]
  • BoundaryVertexDeletionOff() [virtual]
  • BoundaryVertexDeletionOn() [virtual]
  • BreakOnError() [static]
  • CollapseEdge(int type, vtkIdType ptId, vtkIdType collapseId, vtkIdType pt1, vtkIdType pt2, vtkIdList *CollapseTris) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CosAngle (defined in vtkDecimatePro) [private]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Degree [protected]
  • Delete() [virtual]
  • DeleteId(vtkIdType id) (defined in vtkDecimatePro) [inline, private]
  • DeleteQueue() (defined in vtkDecimatePro) [inline, private]
  • DistributeError(float error) [protected]
  • EdgeLengths [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Error (defined in vtkDecimatePro) [private]
  • ErrorIsAbsolute [protected]
  • EvaluateVertex(vtkIdType ptId, unsigned short int numTris, vtkIdType *tris, vtkIdType fedges[2]) [protected]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FindSplit(int type, vtkIdType fedges[2], vtkIdType &pt1, vtkIdType &pt2, vtkIdList *CollapseTris) [protected]
  • GetAbortExecute() [virtual]
  • GetAbsoluteError() [virtual]
  • GetAccumulateError() [virtual]
  • GetBoundaryVertexDeletion() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDegree() [virtual]
  • GetErrorCode() [virtual]
  • GetErrorIsAbsolute() [virtual]
  • GetFeatureAngle() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInflectionPointRatio() [virtual]
  • GetInflectionPoints(float *inflectionPoints)
  • GetInflectionPoints()
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumError() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInflectionPoints()
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPreserveTopology() [virtual]
  • GetPreSplitMesh() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSplitAngle() [virtual]
  • GetSplitting() [virtual]
  • GetTargetReduction() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InflectionPointRatio [protected]
  • InflectionPoints [protected]
  • InformationTime [protected]
  • InitializeQueue(vtkIdType numPts) (defined in vtkDecimatePro) [private]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Insert(vtkIdType id, float error=-1.0) (defined in vtkDecimatePro) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • IsValidSplit(int index) [protected]
  • LegacyHack
  • LoopArea (defined in vtkDecimatePro) [private]
  • MaximumError [protected]
  • Mesh (defined in vtkDecimatePro) [private]
  • Modified() [virtual]
  • MTime [protected]
  • Neighbors [protected]
  • New() [static]
  • Normal (defined in vtkDecimatePro) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRemainingTris (defined in vtkDecimatePro) [private]
  • NumberOfRequiredInputs [protected]
  • NumCollapses (defined in vtkDecimatePro) [private]
  • NumMerges (defined in vtkDecimatePro) [private]
  • operator=(const vtkDecimatePro &) (defined in vtkDecimatePro) [private]
  • Outputs [protected]
  • Pop(float &error) (defined in vtkDecimatePro) [private]
  • PreserveTopology [protected]
  • PreserveTopologyOff() [virtual]
  • PreserveTopologyOn() [virtual]
  • PreSplitMesh [protected]
  • PreSplitMeshOff() [virtual]
  • PreSplitMeshOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Pt (defined in vtkDecimatePro) [private]
  • Queue (defined in vtkDecimatePro) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Reset() (defined in vtkDecimatePro) [inline, private]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAbsoluteError(float) [virtual]
  • SetAccumulateError(int) [virtual]
  • SetBoundaryVertexDeletion(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDegree(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetErrorIsAbsolute(int) [virtual]
  • SetFeatureAngle(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInflectionPointRatio(float) [virtual]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaximumError(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPreserveTopology(int) [virtual]
  • SetPreSplitMesh(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSplitAngle(float) [virtual]
  • SetSplitting(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetReduction(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Split (defined in vtkDecimatePro) [private]
  • SplitAngle [protected]
  • SplitLoop(vtkIdType fedges[2], vtkIdType &n1, vtkIdType *l1, vtkIdType &n2, vtkIdType *l2) [protected]
  • SplitMesh() [protected]
  • SplitState (defined in vtkDecimatePro) [private]
  • Splitting [protected]
  • SplittingOff() [virtual]
  • SplittingOn() [virtual]
  • SplitVertex(vtkIdType ptId, int type, unsigned short int numTris, vtkIdType *tris, int insert) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • T (defined in vtkDecimatePro) [private]
  • TargetReduction [protected]
  • TheSplitAngle (defined in vtkDecimatePro) [private]
  • Tolerance (defined in vtkDecimatePro) [private]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • V (defined in vtkDecimatePro) [private]
  • VertexDegree (defined in vtkDecimatePro) [private]
  • VertexError (defined in vtkDecimatePro) [private]
  • vtkDecimatePro() [protected]
  • vtkDecimatePro(const vtkDecimatePro &) (defined in vtkDecimatePro) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDecimatePro, vtkPolyDataToPolyDataFilter)
  • X (defined in vtkDecimatePro) [private]
  • ~vtkDecimatePro() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDelaunay2D Member List

This is the complete list of members for vtkDelaunay2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Alpha [protected]
  • BoundingTriangulation [protected]
  • BoundingTriangulationOff() [virtual]
  • BoundingTriangulationOn() [virtual]
  • BreakOnError() [static]
  • CheckEdge(vtkIdType ptId, double x[3], vtkIdType p1, vtkIdType p2, vtkIdType tri) (defined in vtkDelaunay2D) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FillPolygons(vtkCellArray *polys, int *triUse) (defined in vtkDelaunay2D) [private]
  • FindTriangle(double x[3], vtkIdType ptIds[3], vtkIdType tri, double tol, vtkIdType nei[3], vtkIdList *neighbors) (defined in vtkDelaunay2D) [private]
  • GetAbortExecute() [virtual]
  • GetAlpha() [virtual]
  • GetBoundingTriangulation() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint(vtkIdType id, double x[3]) (defined in vtkDelaunay2D) [inline, private]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSource()
  • GetTolerance() [virtual]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InCircle(double x[3], double x1[3], double x2[3], double x3[3]) (defined in vtkDelaunay2D) [private]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Mesh (defined in vtkDelaunay2D) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfDegeneracies (defined in vtkDelaunay2D) [private]
  • NumberOfDuplicatePoints (defined in vtkDelaunay2D) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • operator=(const vtkDelaunay2D &) (defined in vtkDelaunay2D) [private]
  • Outputs [protected]
  • Points (defined in vtkDelaunay2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RecoverBoundary() (defined in vtkDelaunay2D) [private]
  • RecoverEdge(vtkIdType p1, vtkIdType p2) (defined in vtkDelaunay2D) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAlpha(double) [virtual]
  • SetBoundingTriangulation(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(double) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPoint(vtkIdType id, double *x) (defined in vtkDelaunay2D) [inline, private]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSource(vtkPolyData *)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(double) [virtual]
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDelaunay2D() [protected]
  • vtkDelaunay2D(const vtkDelaunay2D &) (defined in vtkDelaunay2D) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDelaunay2D, vtkPolyDataSource)
  • ~vtkDelaunay2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDelaunay3D Member List

This is the complete list of members for vtkDelaunay3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Alpha [protected]
  • BoundaryPts (defined in vtkDelaunay3D) [private]
  • BoundingTriangulation [protected]
  • BoundingTriangulationOff() [virtual]
  • BoundingTriangulationOn() [virtual]
  • BreakOnError() [static]
  • CheckedTetras (defined in vtkDelaunay3D) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndPointInsertion()
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • Faces (defined in vtkDelaunay3D) [private]
  • FindEnclosingFaces(float x[3], vtkUnstructuredGrid *Mesh, vtkIdList *tetras, vtkIdList *faces, vtkPointLocator *Locator) [protected]
  • FindTetra(vtkUnstructuredGrid *Mesh, double x[3], vtkIdType tetId, int depth) [protected]
  • GetAbortExecute() [virtual]
  • GetAlpha() [virtual]
  • GetBoundingTriangulation() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitPointInsertion(float center[3], float length, vtkIdType numPts, vtkPoints *&pts)
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsertPoint(vtkUnstructuredGrid *Mesh, vtkPoints *points, vtkIdType id, float x[3], vtkIdList *holeTetras)
  • InsertTetra(vtkUnstructuredGrid *Mesh, vtkPoints *pts, vtkIdType tetraId) [protected]
  • InSphere(double x[3], vtkIdType tetraId) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • NeiTetras (defined in vtkDelaunay3D) [private]
  • New() [static]
  • NumberOfDegeneracies [protected]
  • NumberOfDuplicatePoints [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • operator=(const vtkDelaunay3D &) (defined in vtkDelaunay3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • References [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAlpha(float) [virtual]
  • SetBoundingTriangulation(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(float) [virtual]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TetraArray [protected]
  • Tetras (defined in vtkDelaunay3D) [private]
  • Tolerance [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDelaunay3D() [protected]
  • vtkDelaunay3D(const vtkDelaunay3D &) (defined in vtkDelaunay3D) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDelaunay3D, vtkUnstructuredGridSource)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDelaunay3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:17:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDEMReader Member List

This is the complete list of members for vtkDEMReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AccuracyCode [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeExtentOriginAndSpacing(int extent[6], float origin[6], float spacing[6]) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DEMLevel [protected]
  • ElevationBounds [protected]
  • ElevationPattern [protected]
  • ElevationUnitOfMeasure [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [virtual]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetAccuracyCode() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDEMLevel() [virtual]
  • GetElevationBounds() [virtual]
  • GetElevationBounds(float data[2]) [virtual]
  • GetElevationPattern() [virtual]
  • GetElevationUnitOfMeasure() [virtual]
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGroundSystem() [virtual]
  • GetGroundZone() [virtual]
  • GetInputs() [inline]
  • GetLocalRotation() [virtual]
  • GetMapLabel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPlaneUnitOfMeasure() [virtual]
  • GetPolygonSize() [virtual]
  • GetProfileDimension() [virtual]
  • GetProfileDimension(int data[2]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetProjectionParameters() [virtual]
  • GetProjectionParameters(float data[15]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSpatialResolution() [virtual]
  • GetSpatialResolution(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GroundCoords [protected]
  • GroundSystem [protected]
  • GroundZone [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LocalRotation [protected]
  • MapLabel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColumns [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfRows [protected]
  • operator=(const vtkDEMReader &) (defined in vtkDEMReader) [private]
  • Outputs [protected]
  • PlaneUnitOfMeasure [protected]
  • PolygonSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProfileDimension [protected]
  • ProfileSeekOffset [protected]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ProjectionParameters [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadHeaderTime [protected]
  • ReadProfiles(vtkImageData *data) [protected]
  • ReadTypeARecord() [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpatialResolution [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDEMReader() [protected]
  • vtkDEMReader(const vtkDEMReader &) (defined in vtkDEMReader) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDEMReader, vtkImageSource)
  • WholeExtent [protected]
  • ~vtkDEMReader() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDepthSortPolyData Member List

This is the complete list of members for vtkDepthSortPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Camera [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeProjectionVector(double vector[3], double origin[3]) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DepthSortMode [protected]
  • Direction [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCamera() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthSortMode() [virtual]
  • GetDirection() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(double data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetProp3D()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSortScalars() [virtual]
  • GetVector() [virtual]
  • GetVector(double data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDepthSortPolyData &) (defined in vtkDepthSortPolyData) [private]
  • Origin [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • Prop3D [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCamera(vtkCamera *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDepthSortMode(int) [virtual]
  • SetDepthSortModeToBoundsCenter() [inline]
  • SetDepthSortModeToFirstPoint() [inline]
  • SetDepthSortModeToParametricCenter() [inline]
  • SetDirection(int) [virtual]
  • SetDirectionToBackToFront() [inline]
  • SetDirectionToFrontToBack() [inline]
  • SetDirectionToSpecifiedVector() [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(double, double, double) [virtual]
  • SetOrigin(double[3]) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetProp3D(vtkProp3D *)
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSortScalars(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVector(double, double, double) [virtual]
  • SetVector(double[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SortScalars [protected]
  • SortScalarsOff() [virtual]
  • SortScalarsOn() [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vector [protected]
  • vtkDepthSortPolyData() [protected]
  • vtkDepthSortPolyData(const vtkDepthSortPolyData &) (defined in vtkDepthSortPolyData) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDepthSortPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkDepthSortPolyData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDicer Member List

This is the complete list of members for vtkDicer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DiceMode [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldData [protected]
  • FieldDataOff() [virtual]
  • FieldDataOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiceMode() [virtual]
  • GetErrorCode() [virtual]
  • GetFieldData() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMemoryLimit() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfActualPieces() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfPointsPerPiece() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MemoryLimit [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfActualPieces [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPieces [protected]
  • NumberOfPointsPerPiece [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDicer &) (defined in vtkDicer) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDiceMode(int) [virtual]
  • SetDiceModeToMemoryLimitPerPiece() [inline]
  • SetDiceModeToNumberOfPointsPerPiece() [inline]
  • SetDiceModeToSpecifiedNumberOfPieces() [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldData(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetMemoryLimit(unsigned long) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfPieces(int) [virtual]
  • SetNumberOfPointsPerPiece(int) [virtual]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdatePieceMeasures() [protected, virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkDicer() [protected]
  • vtkDicer(const vtkDicer &) (defined in vtkDicer) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDicer, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkDicer() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDirectionEncoder Member List

This is the complete list of members for vtkDirectionEncoder, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDecodedGradient(int value)=0 [pure virtual]
  • GetDecodedGradientTable(void)=0 [pure virtual]
  • GetEncodedDirection(float n[3])=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfEncodedDirections(void)=0 [pure virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkDirectionEncoder &) (defined in vtkDirectionEncoder) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDirectionEncoder() [inline, protected]
  • vtkDirectionEncoder(const vtkDirectionEncoder &) (defined in vtkDirectionEncoder) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDirectionEncoder, vtkObject)
  • ~vtkDirectionEncoder() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDirectory Member List

This is the complete list of members for vtkDirectory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Files (defined in vtkDirectory) [private]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFile(int index)
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfFiles() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NumberOfFiles (defined in vtkDirectory) [private]
  • Open(const char *dir)
  • operator=(const vtkDirectory &) (defined in vtkDirectory) [private]
  • Path (defined in vtkDirectory) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDirectory() [protected]
  • vtkDirectory(const vtkDirectory &) (defined in vtkDirectory) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDirectory, vtkObject)
  • ~vtkDirectory() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDiskSource Member List

This is the complete list of members for vtkDiskSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CircumferentialResolution [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCircumferentialResolution() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInnerRadius() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOuterRadius() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadialResolution() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InnerRadius [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDiskSource &) (defined in vtkDiskSource) [private]
  • OuterRadius [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RadialResolution [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCircumferentialResolution(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInnerRadius(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOuterRadius(float) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadialResolution(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDiskSource() [protected]
  • vtkDiskSource(const vtkDiskSource &) (defined in vtkDiskSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkDiskSource, vtkPolyDataSource)
  • ~vtkDiskSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDividingCubes Member List

This is the complete list of members for vtkDividingCubes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Count [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distance [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDistance() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIncrement() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Increment [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkDividingCubes &) (defined in vtkDividingCubes) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDistance(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIncrement(int) [virtual]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubDivide(float origin[3], int dim[3], float h[3], float values[8]) [protected]
  • SubjectHelper [protected]
  • SubVoxel [protected]
  • SubVoxelNormals [protected]
  • SubVoxelPts [protected]
  • SubVoxelScalars [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • vtkDividingCubes() [protected]
  • vtkDividingCubes(const vtkDividingCubes &) (defined in vtkDividingCubes) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkDividingCubes, vtkStructuredPointsToPolyDataFilter)
  • ~vtkDividingCubes() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:17:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDoubleArray Member List

This is the complete list of members for vtkDoubleArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const double f) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const double f) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkDoubleArray &) (defined in vtkDoubleArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(double *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const double value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkDoubleArray(vtkIdType numComp=1) [protected]
  • vtkDoubleArray(const vtkDoubleArray &) (defined in vtkDoubleArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDoubleArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkDoubleArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkDynamicLoader Member List

This is the complete list of members for vtkDynamicLoader, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseLibrary(vtkLibHandle) [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetSymbolAddress(vtkLibHandle, const char *) [static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastError() [static]
  • LibExtension() [static]
  • LibPrefix() [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • OpenLibrary(const char *) [static]
  • operator=(const vtkDynamicLoader &) (defined in vtkDynamicLoader) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDynamicLoader() [inline, protected]
  • vtkDynamicLoader(const vtkDynamicLoader &) (defined in vtkDynamicLoader) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkDynamicLoader, vtkObject)
  • ~vtkDynamicLoader() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEarthSource Member List

This is the complete list of members for vtkEarthSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOnRatio() [virtual]
  • GetOutline() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OnRatio [protected]
  • operator=(const vtkEarthSource &) (defined in vtkEarthSource) [private]
  • Outline [protected]
  • OutlineOff() [virtual]
  • OutlineOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOnRatio(int) [virtual]
  • SetOutline(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkEarthSource() [protected]
  • vtkEarthSource(const vtkEarthSource &) (defined in vtkEarthSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEarthSource, vtkPolyDataSource)
  • ~vtkEarthSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEdgePoints Member List

This is the complete list of members for vtkEdgePoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkEdgePoints &) (defined in vtkEdgePoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkEdgePoints() [protected]
  • vtkEdgePoints(const vtkEdgePoints &) (defined in vtkEdgePoints) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEdgePoints, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkEdgePoints() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEdgeTable Member List

This is the complete list of members for vtkEdgeTable, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Attributes [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Extend [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNextEdge(vtkIdType &p1, vtkIdType &p2)
  • GetNumberOfEdges() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitEdgeInsertion(vtkIdType numPoints, int storeAttributes=0)
  • Initialize()
  • InitPointInsertion(vtkPoints *newPts, vtkIdType estSize)
  • InitTraversal()
  • InsertEdge(vtkIdType p1, vtkIdType p2)
  • InsertEdge(vtkIdType p1, vtkIdType p2, int attributeId)
  • InsertUniquePoint(vtkIdType p1, vtkIdType p2, float x[3], vtkIdType &ptId)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsEdge(vtkIdType p1, vtkIdType p2)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfEdges [protected]
  • operator=(const vtkEdgeTable &) (defined in vtkEdgeTable) [private]
  • Points [protected]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset()
  • Resize(vtkIdType size) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • StoreAttributes [protected]
  • SubjectHelper [protected]
  • Table [protected]
  • TableMaxId [protected]
  • TableSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkEdgeTable() [protected]
  • vtkEdgeTable(const vtkEdgeTable &) (defined in vtkEdgeTable) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkEdgeTable, vtkObject)
  • ~vtkEdgeTable() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkElevationFilter Member List

This is the complete list of members for vtkElevationFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHighPoint() [virtual]
  • GetHighPoint(float data[3]) [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLowPoint() [virtual]
  • GetLowPoint(float data[3]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighPoint [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LowPoint [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkElevationFilter &) (defined in vtkElevationFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHighPoint(float, float, float) [virtual]
  • SetHighPoint(float[3]) [virtual]
  • SetInput(vtkDataSet *input)
  • SetLowPoint(float, float, float) [virtual]
  • SetLowPoint(float[3]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkElevationFilter() [protected]
  • vtkElevationFilter(const vtkElevationFilter &) (defined in vtkElevationFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkElevationFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkElevationFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEmptyCell Member List

This is the complete list of members for vtkEmptyCell, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *pts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts1, vtkCellArray *lines, vtkCellArray *verts2, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int) [inline, virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [inline, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkEmptyCell &) (defined in vtkEmptyCell) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkEmptyCell() [inline, protected]
  • vtkEmptyCell(const vtkEmptyCell &) (defined in vtkEmptyCell) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkEmptyCell, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkEmptyCell() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEncodedGradientEstimator Member List

This is the complete list of members for vtkEncodedGradientEstimator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BoundsClip [protected]
  • BoundsClipOff() [virtual]
  • BoundsClipOn() [virtual]
  • BreakOnError() [static]
  • BuildTime
  • CircleLimits [protected]
  • CircleLimitsSize [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCircleLimits(int size) [protected]
  • ComputeGradientMagnitudes [protected]
  • ComputeGradientMagnitudesOff() [virtual]
  • ComputeGradientMagnitudesOn() [virtual]
  • CylinderClip [protected]
  • CylinderClipOff() [virtual]
  • CylinderClipOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DirectionEncoder [protected]
  • EncodedNormals
  • EncodedNormalsSize
  • GetBounds() [virtual]
  • GetBounds(int data[6]) [virtual]
  • GetBoundsClip() [virtual]
  • GetCircleLimits() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradientMagnitudes() [virtual]
  • GetCylinderClip() [virtual]
  • GetDebug()
  • GetDirectionEncoder() [virtual]
  • GetEncodedNormalIndex(int xyz_index)
  • GetEncodedNormalIndex(int x_index, int y_index, int z_index)
  • GetEncodedNormals(void)
  • GetGlobalWarningDisplay() [static]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes(void)
  • GetGradientMagnitudeScale() [virtual]
  • GetInput() [virtual]
  • GetInputAspect() [virtual]
  • GetInputAspect(float data[3]) [virtual]
  • GetInputSize() [virtual]
  • GetInputSize(int data[3]) [virtual]
  • GetLastUpdateTimeInCPUSeconds() [virtual]
  • GetLastUpdateTimeInSeconds() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetReferenceCount() [inline]
  • GetUseCylinderClip() [virtual]
  • GetZeroNormalThreshold() [virtual]
  • GetZeroPad() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientMagnitudeBias [protected]
  • GradientMagnitudes
  • GradientMagnitudeScale [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input
  • InputAspect [protected]
  • InputSize [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastUpdateTimeInCPUSeconds [protected]
  • LastUpdateTimeInSeconds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NumberOfThreads [protected]
  • operator=(const vtkEncodedGradientEstimator &) (defined in vtkEncodedGradientEstimator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetBounds(int, int, int, int, int, int) [virtual]
  • SetBounds(int[6]) [virtual]
  • SetBoundsClip(int) [virtual]
  • SetComputeGradientMagnitudes(int) [virtual]
  • SetCylinderClip(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionEncoder(vtkDirectionEncoder *direnc)
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientMagnitudeBias(float) [virtual]
  • SetGradientMagnitudeScale(float) [virtual]
  • SetInput(vtkImageData *) [virtual]
  • SetNumberOfThreads(int) [virtual]
  • SetReferenceCount(int)
  • SetZeroNormalThreshold(float v)
  • SetZeroPad(int) [virtual]
  • SubjectHelper [protected]
  • Threader [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update(void)
  • UpdateNormals(void)=0 [protected, pure virtual]
  • UseCylinderClip [protected]
  • vtkEncodedGradientEstimator() [protected]
  • vtkEncodedGradientEstimator(const vtkEncodedGradientEstimator &) (defined in vtkEncodedGradientEstimator) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkEncodedGradientEstimator, vtkObject)
  • ZeroNormalThreshold [protected]
  • ZeroPad [protected]
  • ZeroPadOff() [virtual]
  • ZeroPadOn() [virtual]
  • ~vtkEncodedGradientEstimator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEncodedGradientShader Member List

This is the complete list of members for vtkEncodedGradientShader, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • BuildShadingTable(int index, float lightDirection[3], float lightColor[3], float lightIntensity, float viewDirection[3], float material[4], int twoSided, vtkEncodedGradientEstimator *gradest, int updateFlag) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetBlueDiffuseShadingTable(vtkVolume *vol)
  • GetBlueSpecularShadingTable(vtkVolume *vol)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGreenDiffuseShadingTable(vtkVolume *vol)
  • GetGreenSpecularShadingTable(vtkVolume *vol)
  • GetMTime() [virtual]
  • GetRedDiffuseShadingTable(vtkVolume *vol)
  • GetRedSpecularShadingTable(vtkVolume *vol)
  • GetReferenceCount() [inline]
  • GetZeroNormalDiffuseIntensity() [virtual]
  • GetZeroNormalSpecularIntensity() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkEncodedGradientShader &) (defined in vtkEncodedGradientShader) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetZeroNormalDiffuseIntensity(float) [virtual]
  • SetZeroNormalSpecularIntensity(float) [virtual]
  • ShadingTable [protected]
  • ShadingTableSize [protected]
  • ShadingTableVolume [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateShadingTable(vtkRenderer *ren, vtkVolume *vol, vtkEncodedGradientEstimator *gradest)
  • vtkEncodedGradientShader() [protected]
  • vtkEncodedGradientShader(const vtkEncodedGradientShader &) (defined in vtkEncodedGradientShader) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkEncodedGradientShader, vtkObject)
  • ZeroNormalDiffuseIntensity [protected]
  • ZeroNormalSpecularIntensity [protected]
  • ~vtkEncodedGradientShader() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEnSight6BinaryReader Member List

This is the complete list of members for vtkEnSight6BinaryReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableFileName(char *fileName1, char *fileName2=NULL) [protected]
  • AddVariableType() [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CellIds [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableFileNames [protected]
  • ComplexVariableFileSets [protected]
  • ComplexVariableTimeSets [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateStructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • CreateUnstructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ElementIdsListed [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • FileSetFilenameNumbersCollection [protected]
  • FileSetNumberOfStepsCollection [protected]
  • FileSets [protected]
  • FileSetsWithFilenameNumbers [protected]
  • GeometryFileName [protected]
  • GeometryFileSet [protected]
  • GeometryTimeSet [protected]
  • GeometryTimeValue [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetElementType(char *line) [protected]
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMatchFileName() [protected, virtual]
  • GetMaximumTimeValue() [virtual]
  • GetMeasuredFileName() [protected, virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVariables() [inline]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables() [inline]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetUseFileSets() [protected, virtual]
  • GetUseTimeSets() [protected, virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IFile [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MatchFileName [protected]
  • MaximumTimeValue [protected]
  • MeasuredFileName [protected]
  • MeasuredFileSet [protected]
  • MeasuredNodeIds [protected]
  • MeasuredTimeSet [protected]
  • MeasuredTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfGeometryParts [protected]
  • NumberOfInputs [protected]
  • NumberOfMeasuredPoints [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfUnstructuredPoints [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkEnSight6BinaryReader &) (defined in vtkEnSight6BinaryReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadCaseFile() [protected]
  • ReadFloatArray(float *result, int numFloats) [protected]
  • ReadGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadInt(int *result) [protected]
  • ReadIntArray(int *result, int numInts) [protected]
  • ReadLine(char result[80]) [protected]
  • vtkEnSightReader::ReadLine(char result[256])
  • ReadMeasuredGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadNextDataLine(char result[256]) [protected]
  • ReadScalarsPerElement(char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadScalarsPerNode(char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadTensorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadTensorsPerNode(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVariableFiles() [protected]
  • ReadVectorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVectorsPerNode(char *fileName, char *description, int timeStep, int measured=0) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *filename, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatchFileName(const char *) [protected, virtual]
  • SetMeasuredFileName(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SetUseFileSets(int) [protected, virtual]
  • SetUseTimeSets(int) [protected, virtual]
  • SkipStructuredGrid(char line[256]) [protected]
  • SkipTimeStep() [protected]
  • SkipUnstructuredGrid(char line[256]) [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeSetFilenameNumbersCollection [protected]
  • TimeSets [protected]
  • TimeSetsWithFilenameNumbers [protected]
  • TimeSetTimeValuesCollection [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredNodeIds [protected]
  • UnstructuredPartIds [protected]
  • UnstructuredPoints [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFileSets [protected]
  • UseFileSetsOff() [protected, virtual]
  • UseFileSetsOn() [protected, virtual]
  • UseTimeSets [protected]
  • UseTimeSetsOff() [protected, virtual]
  • UseTimeSetsOn() [protected, virtual]
  • VariableDescriptions [protected]
  • VariableFileNames [protected]
  • VariableFileSets [protected]
  • VariableMode [protected]
  • VariableTimeSets [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkEnSight6BinaryReader() [protected]
  • vtkEnSight6BinaryReader(const vtkEnSight6BinaryReader &) (defined in vtkEnSight6BinaryReader) [private]
  • vtkEnSightReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEnSight6BinaryReader, vtkEnSightReader)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkEnSight6BinaryReader() [protected]
  • ~vtkEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEnSight6Reader Member List

This is the complete list of members for vtkEnSight6Reader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableFileName(char *fileName1, char *fileName2=NULL) [protected]
  • AddVariableType() [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CellIds [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableFileNames [protected]
  • ComplexVariableFileSets [protected]
  • ComplexVariableTimeSets [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateStructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • CreateUnstructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • FileSetFilenameNumbersCollection [protected]
  • FileSetNumberOfStepsCollection [protected]
  • FileSets [protected]
  • FileSetsWithFilenameNumbers [protected]
  • GeometryFileName [protected]
  • GeometryFileSet [protected]
  • GeometryTimeSet [protected]
  • GeometryTimeValue [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetElementType(char *line) [protected]
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMatchFileName() [protected, virtual]
  • GetMaximumTimeValue() [virtual]
  • GetMeasuredFileName() [protected, virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVariables() [inline]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables() [inline]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetUseFileSets() [protected, virtual]
  • GetUseTimeSets() [protected, virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MatchFileName [protected]
  • MaximumTimeValue [protected]
  • MeasuredFileName [protected]
  • MeasuredFileSet [protected]
  • MeasuredNodeIds [protected]
  • MeasuredTimeSet [protected]
  • MeasuredTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfGeometryParts [protected]
  • NumberOfInputs [protected]
  • NumberOfMeasuredPoints [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfUnstructuredPoints [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkEnSight6Reader &) (defined in vtkEnSight6Reader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadCaseFile() [protected]
  • ReadGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadLine(char result[256]) [protected]
  • ReadMeasuredGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadNextDataLine(char result[256]) [protected]
  • ReadScalarsPerElement(char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadScalarsPerNode(char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadTensorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadTensorsPerNode(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVariableFiles() [protected]
  • ReadVectorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVectorsPerNode(char *fileName, char *description, int timeStep, int measured=0) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *filename, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatchFileName(const char *) [protected, virtual]
  • SetMeasuredFileName(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SetUseFileSets(int) [protected, virtual]
  • SetUseTimeSets(int) [protected, virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeSetFilenameNumbersCollection [protected]
  • TimeSets [protected]
  • TimeSetsWithFilenameNumbers [protected]
  • TimeSetTimeValuesCollection [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredNodeIds [protected]
  • UnstructuredPartIds [protected]
  • UnstructuredPoints [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFileSets [protected]
  • UseFileSetsOff() [protected, virtual]
  • UseFileSetsOn() [protected, virtual]
  • UseTimeSets [protected]
  • UseTimeSetsOff() [protected, virtual]
  • UseTimeSetsOn() [protected, virtual]
  • VariableDescriptions [protected]
  • VariableFileNames [protected]
  • VariableFileSets [protected]
  • VariableMode [protected]
  • VariableTimeSets [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkEnSight6Reader() [protected]
  • vtkEnSight6Reader(const vtkEnSight6Reader &) (defined in vtkEnSight6Reader) [private]
  • vtkEnSightReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEnSight6Reader, vtkEnSightReader)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkEnSight6Reader() [protected]
  • ~vtkEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEnSightGoldBinaryReader Member List

This is the complete list of members for vtkEnSightGoldBinaryReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableFileName(char *fileName1, char *fileName2=NULL) [protected]
  • AddVariableType() [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CellIds [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableFileNames [protected]
  • ComplexVariableFileSets [protected]
  • ComplexVariableTimeSets [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateImageDataOutput(int partId, char line[80]) [protected]
  • CreateRectilinearGridOutput(int partId, char line[256]) [protected]
  • CreateStructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • CreateUnstructuredGridOutput(int partId, char line[80]) [protected, virtual]
  • vtkEnSightReader::CreateUnstructuredGridOutput(int partId, char line[256])=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ElementIdsListed [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • FileSetFilenameNumbersCollection [protected]
  • FileSetNumberOfStepsCollection [protected]
  • FileSets [protected]
  • FileSetsWithFilenameNumbers [protected]
  • GeometryFileName [protected]
  • GeometryFileSet [protected]
  • GeometryTimeSet [protected]
  • GeometryTimeValue [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetElementType(char *line) [protected]
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMatchFileName() [protected, virtual]
  • GetMaximumTimeValue() [virtual]
  • GetMeasuredFileName() [protected, virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVariables() [inline]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables() [inline]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetUseFileSets() [protected, virtual]
  • GetUseTimeSets() [protected, virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IFile [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MatchFileName [protected]
  • MaximumTimeValue [protected]
  • MeasuredFileName [protected]
  • MeasuredFileSet [protected]
  • MeasuredNodeIds [protected]
  • MeasuredTimeSet [protected]
  • MeasuredTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NodeIdsListed [protected]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfGeometryParts [protected]
  • NumberOfInputs [protected]
  • NumberOfMeasuredPoints [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkEnSightGoldBinaryReader &) (defined in vtkEnSightGoldBinaryReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadCaseFile() [protected]
  • ReadFloatArray(float *result, int numFloats) [protected]
  • ReadGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadInt(int *result) [protected]
  • ReadIntArray(int *result, int numInts) [protected]
  • ReadLine(char result[80]) [protected]
  • vtkEnSightReader::ReadLine(char result[256])
  • ReadMeasuredGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadNextDataLine(char result[256]) [protected]
  • ReadScalarsPerElement(char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadScalarsPerNode(char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadTensorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadTensorsPerNode(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVariableFiles() [protected]
  • ReadVectorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVectorsPerNode(char *fileName, char *description, int timeStep, int measured=0) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *filename, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatchFileName(const char *) [protected, virtual]
  • SetMeasuredFileName(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SetUseFileSets(int) [protected, virtual]
  • SetUseTimeSets(int) [protected, virtual]
  • SkipImageData(char line[256]) [protected]
  • SkipRectilinearGrid(char line[256]) [protected]
  • SkipStructuredGrid(char line[256]) [protected]
  • SkipTimeStep() [protected]
  • SkipUnstructuredGrid(char line[256]) [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeSetFilenameNumbersCollection [protected]
  • TimeSets [protected]
  • TimeSetsWithFilenameNumbers [protected]
  • TimeSetTimeValuesCollection [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredPartIds [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFileSets [protected]
  • UseFileSetsOff() [protected, virtual]
  • UseFileSetsOn() [protected, virtual]
  • UseTimeSets [protected]
  • UseTimeSetsOff() [protected, virtual]
  • UseTimeSetsOn() [protected, virtual]
  • VariableDescriptions [protected]
  • VariableFileNames [protected]
  • VariableFileSets [protected]
  • VariableMode [protected]
  • VariableTimeSets [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkEnSightGoldBinaryReader() [protected]
  • vtkEnSightGoldBinaryReader(const vtkEnSightGoldBinaryReader &) (defined in vtkEnSightGoldBinaryReader) [private]
  • vtkEnSightReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEnSightGoldBinaryReader, vtkEnSightReader)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkEnSightGoldBinaryReader() [protected]
  • ~vtkEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEnSightGoldReader Member List

This is the complete list of members for vtkEnSightGoldReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableFileName(char *fileName1, char *fileName2=NULL) [protected]
  • AddVariableType() [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CellIds [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableFileNames [protected]
  • ComplexVariableFileSets [protected]
  • ComplexVariableTimeSets [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateImageDataOutput(int partId, char line[256]) [protected]
  • CreateRectilinearGridOutput(int partId, char line[256]) [protected]
  • CreateStructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • CreateUnstructuredGridOutput(int partId, char line[256]) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • FileSetFilenameNumbersCollection [protected]
  • FileSetNumberOfStepsCollection [protected]
  • FileSets [protected]
  • FileSetsWithFilenameNumbers [protected]
  • GeometryFileName [protected]
  • GeometryFileSet [protected]
  • GeometryTimeSet [protected]
  • GeometryTimeValue [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetElementType(char *line) [protected]
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMatchFileName() [protected, virtual]
  • GetMaximumTimeValue() [virtual]
  • GetMeasuredFileName() [protected, virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVariables() [inline]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables() [inline]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetUseFileSets() [protected, virtual]
  • GetUseTimeSets() [protected, virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MatchFileName [protected]
  • MaximumTimeValue [protected]
  • MeasuredFileName [protected]
  • MeasuredFileSet [protected]
  • MeasuredNodeIds [protected]
  • MeasuredTimeSet [protected]
  • MeasuredTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfGeometryParts [protected]
  • NumberOfInputs [protected]
  • NumberOfMeasuredPoints [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkEnSightGoldReader &) (defined in vtkEnSightGoldReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadCaseFile() [protected]
  • ReadGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadLine(char result[256]) [protected]
  • ReadMeasuredGeometryFile(char *fileName, int timeStep) [protected, virtual]
  • ReadNextDataLine(char result[256]) [protected]
  • ReadScalarsPerElement(char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadScalarsPerNode(char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0) [protected, virtual]
  • ReadTensorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadTensorsPerNode(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVariableFiles() [protected]
  • ReadVectorsPerElement(char *fileName, char *description, int timeStep) [protected, virtual]
  • ReadVectorsPerNode(char *fileName, char *description, int timeStep, int measured=0) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *filename, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatchFileName(const char *) [protected, virtual]
  • SetMeasuredFileName(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SetUseFileSets(int) [protected, virtual]
  • SetUseTimeSets(int) [protected, virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeSetFilenameNumbersCollection [protected]
  • TimeSets [protected]
  • TimeSetsWithFilenameNumbers [protected]
  • TimeSetTimeValuesCollection [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredPartIds [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFileSets [protected]
  • UseFileSetsOff() [protected, virtual]
  • UseFileSetsOn() [protected, virtual]
  • UseTimeSets [protected]
  • UseTimeSetsOff() [protected, virtual]
  • UseTimeSetsOn() [protected, virtual]
  • VariableDescriptions [protected]
  • VariableFileNames [protected]
  • VariableFileSets [protected]
  • VariableMode [protected]
  • VariableTimeSets [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkEnSightGoldReader() [inline, protected]
  • vtkEnSightGoldReader(const vtkEnSightGoldReader &) (defined in vtkEnSightGoldReader) [private]
  • vtkEnSightReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEnSightGoldReader, vtkEnSightReader)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkEnSightGoldReader() [inline, protected]
  • ~vtkEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkEnSightReader Member List

This is the complete list of members for vtkEnSightReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableFileName(char *fileName1, char *fileName2=NULL) [protected]
  • AddVariableType() [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CellIds [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableFileNames [protected]
  • ComplexVariableFileSets [protected]
  • ComplexVariableTimeSets [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateStructuredGridOutput(int partId, char line[256])=0 [protected, pure virtual]
  • CreateUnstructuredGridOutput(int partId, char line[256])=0 [protected, pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • FileSetFilenameNumbersCollection [protected]
  • FileSetNumberOfStepsCollection [protected]
  • FileSets [protected]
  • FileSetsWithFilenameNumbers [protected]
  • GeometryFileName [protected]
  • GeometryFileSet [protected]
  • GeometryTimeSet [protected]
  • GeometryTimeValue [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetElementType(char *line) [protected]
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMatchFileName() [protected, virtual]
  • GetMaximumTimeValue() [virtual]
  • GetMeasuredFileName() [protected, virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVariables() [inline]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables() [inline]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetUseFileSets() [protected, virtual]
  • GetUseTimeSets() [protected, virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MatchFileName [protected]
  • MaximumTimeValue [protected]
  • MeasuredFileName [protected]
  • MeasuredFileSet [protected]
  • MeasuredNodeIds [protected]
  • MeasuredTimeSet [protected]
  • MeasuredTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfGeometryParts [protected]
  • NumberOfInputs [protected]
  • NumberOfMeasuredPoints [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkEnSightReader &) (defined in vtkEnSightReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadCaseFile() [protected]
  • ReadGeometryFile(char *fileName, int timeStep)=0 [protected, pure virtual]
  • ReadLine(char result[256]) [protected]
  • ReadMeasuredGeometryFile(char *fileName, int timeStep)=0 [protected, pure virtual]
  • ReadNextDataLine(char result[256]) [protected]
  • ReadScalarsPerElement(char *fileName, char *description, int timeStep, int numberOfComponents=1, int component=0)=0 [protected, pure virtual]
  • ReadScalarsPerNode(char *fileName, char *description, int timeStep, int measured=0, int numberOfComponents=1, int component=0)=0 [protected, pure virtual]
  • ReadTensorsPerElement(char *fileName, char *description, int timeStep)=0 [protected, pure virtual]
  • ReadTensorsPerNode(char *fileName, char *description, int timeStep)=0 [protected, pure virtual]
  • ReadVariableFiles() [protected]
  • ReadVectorsPerElement(char *fileName, char *description, int timeStep)=0 [protected, pure virtual]
  • ReadVectorsPerNode(char *fileName, char *description, int timeStep, int measured=0)=0 [protected, pure virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *filename, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMatchFileName(const char *) [protected, virtual]
  • SetMeasuredFileName(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SetUseFileSets(int) [protected, virtual]
  • SetUseTimeSets(int) [protected, virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeSetFilenameNumbersCollection [protected]
  • TimeSets [protected]
  • TimeSetsWithFilenameNumbers [protected]
  • TimeSetTimeValuesCollection [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredPartIds [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFileSets [protected]
  • UseFileSetsOff() [protected, virtual]
  • UseFileSetsOn() [protected, virtual]
  • UseTimeSets [protected]
  • UseTimeSetsOff() [protected, virtual]
  • UseTimeSetsOn() [protected, virtual]
  • VariableDescriptions [protected]
  • VariableFileNames [protected]
  • VariableFileSets [protected]
  • VariableMode [protected]
  • VariableTimeSets [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkEnSightReader() [protected]
  • vtkEnSightReader(const vtkEnSightReader &) (defined in vtkEnSightReader) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkEnSightReader, vtkDataSetSource)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkErrorCode Member List

This is the complete list of members for vtkErrorCode, including all inherited members.
  • CannotOpenFileError enum value
  • ErrorIds enum name
  • FileFormatError enum value
  • FileNotFoundError enum value
  • GetErrorCodeFromString(const char *event) [static]
  • GetStringFromErrorCode(unsigned long event) [static]
  • NoError enum value
  • NoFileNameError enum value
  • PrematureEndOfFileError enum value
  • UnknownError enum value
  • UnrecognizedFileTypeError enum value
  • UserError enum value
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExplicitCell Member List

This is the complete list of members for vtkExplicitCell, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts)=0 [pure virtual]
  • CellId [protected]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)=0 [pure virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs)=0 [pure virtual]
  • Error [protected]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights)=0 [pure virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)=0 [pure virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension()=0 [pure virtual]
  • GetCellType()=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId)=0 [pure virtual]
  • GetError() [virtual]
  • GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges()=0 [pure virtual]
  • GetNumberOfFaces()=0 [pure virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InsertPoint(vtkPointLocator *locator, vtkPoints *pts, float *x) [inline, protected]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkExplicitCell &) (defined in vtkExplicitCell) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetError(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Tesselate(vtkIdType cellId, vtkDataSet *input, vtkPolyData *output, vtkPointLocator *locator=NULL) [virtual]
  • Tesselate(vtkIdType cellId, vtkDataSet *input, vtkUnstructuredGrid *output, vtkPointLocator *locator=NULL) [virtual]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts)=0 [pure virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkExplicitCell() [protected]
  • vtkExplicitCell(const vtkExplicitCell &) (defined in vtkExplicitCell) [private]
  • vtkNonLinearCell() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkExplicitCell, vtkNonLinearCell)
  • ~vtkCell() [protected]
  • ~vtkExplicitCell() [inline, protected]
  • ~vtkNonLinearCell() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExporter Member List

This is the complete list of members for vtkExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkExporter &) (defined in vtkExporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkExporter(const vtkExporter &) (defined in vtkExporter) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkExporter, vtkObject)
  • Write() [virtual]
  • WriteData()=0 [protected, pure virtual]
  • ~vtkExporter() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtentTranslator Member List

This is the complete list of members for vtkExtentTranslator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BLOCK_MODE enum value [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetGhostLevel() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetPiece() [virtual]
  • GetReferenceCount() [inline]
  • GetSplitMode() [virtual]
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modes enum name [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfPieces [protected]
  • operator=(const vtkExtentTranslator &) (defined in vtkExtentTranslator) [private]
  • Piece [protected]
  • PieceToExtent() [virtual]
  • PieceToExtentByPoints() [virtual]
  • PieceToExtentThreadSafe(int piece, int numPieces, int ghostLevel, int *wholeExtent, int *resultExtent, int splitMode, int byPoints) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetExtent(int, int, int, int, int, int) [virtual]
  • SetExtent(int[6]) [virtual]
  • SetGhostLevel(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNumberOfPieces(int) [virtual]
  • SetPiece(int) [virtual]
  • SetReferenceCount(int)
  • SetSplitModeToBlock() [inline]
  • SetSplitModeToXSlab() [inline]
  • SetSplitModeToYSlab() [inline]
  • SetSplitModeToZSlab() [inline]
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • SplitExtent(int piece, int numPieces, int *extent, int splitMode) [protected]
  • SplitExtentByPoints(int piece, int numPieces, int *extent, int splitMode) [protected]
  • SplitMode [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkExtentTranslator() [protected]
  • vtkExtentTranslator(const vtkExtentTranslator &) (defined in vtkExtentTranslator) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkExtentTranslator, vtkObject)
  • WholeExtent [protected]
  • X_SLAB_MODE enum value [protected]
  • Y_SLAB_MODE enum value [protected]
  • Z_SLAB_MODE enum value [protected]
  • ~vtkExtentTranslator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractEdges Member List

This is the complete list of members for vtkExtractEdges, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractEdges &) (defined in vtkExtractEdges) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkExtractEdges() [protected]
  • vtkExtractEdges(const vtkExtractEdges &) (defined in vtkExtractEdges) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractEdges, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkExtractEdges() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractGeometry Member List

This is the complete list of members for vtkExtractGeometry, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExtractBoundaryCells [protected]
  • ExtractBoundaryCellsOff() [virtual]
  • ExtractBoundaryCellsOn() [virtual]
  • ExtractInside [protected]
  • ExtractInsideOff() [virtual]
  • ExtractInsideOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractBoundaryCells() [virtual]
  • GetExtractInside() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImplicitFunction() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImplicitFunction [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractGeometry &) (defined in vtkExtractGeometry) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractBoundaryCells(int) [virtual]
  • SetExtractInside(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImplicitFunction(vtkImplicitFunction *) [virtual]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkExtractGeometry(vtkImplicitFunction *f=NULL) [protected]
  • vtkExtractGeometry(const vtkExtractGeometry &) (defined in vtkExtractGeometry) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractGeometry, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkExtractGeometry() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:17:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractGrid Member List

This is the complete list of members for vtkExtractGrid, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIncludeBoundary() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleRate() [virtual]
  • GetSampleRate(int data[3]) [virtual]
  • GetVOI() [virtual]
  • GetVOI(int data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IncludeBoundary [protected]
  • IncludeBoundaryOff() [virtual]
  • IncludeBoundaryOn() [virtual]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractGrid &) (defined in vtkExtractGrid) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleRate [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIncludeBoundary(int) [virtual]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleRate(int, int, int) [virtual]
  • SetSampleRate(int[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVOI(int, int, int, int, int, int) [virtual]
  • SetVOI(int[6]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VOI [protected]
  • vtkExtractGrid() [protected]
  • vtkExtractGrid(const vtkExtractGrid &) (defined in vtkExtractGrid) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkStructuredGridToStructuredGridFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkExtractGrid, vtkStructuredGridToStructuredGridFilter)
  • ~vtkExtractGrid() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
  • ~vtkStructuredGridToStructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:17:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractPolyDataGeometry Member List

This is the complete list of members for vtkExtractPolyDataGeometry, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ExtractBoundaryCells [protected]
  • ExtractBoundaryCellsOff() [virtual]
  • ExtractBoundaryCellsOn() [virtual]
  • ExtractInside [protected]
  • ExtractInsideOff() [virtual]
  • ExtractInsideOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractBoundaryCells() [virtual]
  • GetExtractInside() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImplicitFunction() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImplicitFunction [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractPolyDataGeometry &) (defined in vtkExtractPolyDataGeometry) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractBoundaryCells(int) [virtual]
  • SetExtractInside(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImplicitFunction(vtkImplicitFunction *) [virtual]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkExtractPolyDataGeometry(vtkImplicitFunction *f=NULL) [protected]
  • vtkExtractPolyDataGeometry(const vtkExtractPolyDataGeometry &) (defined in vtkExtractPolyDataGeometry) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractPolyDataGeometry, vtkPolyDataToPolyDataFilter)
  • ~vtkExtractPolyDataGeometry() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractPolyDataPiece Member List

This is the complete list of members for vtkExtractPolyDataPiece, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddGhostLevel(vtkPolyData *input, vtkIntArray *cellTags, int ghostLevel) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCellTags(vtkIntArray *cellTags, vtkIdList *pointOwnership, int piece, int numPieces) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • CreateGhostCells [protected]
  • CreateGhostCellsOff() [virtual]
  • CreateGhostCellsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCreateGhostCells() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractPolyDataPiece &) (defined in vtkExtractPolyDataPiece) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCreateGhostCells(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkExtractPolyDataPiece() [protected]
  • vtkExtractPolyDataPiece(const vtkExtractPolyDataPiece &) (defined in vtkExtractPolyDataPiece) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractPolyDataPiece, vtkPolyDataToPolyDataFilter)
  • ~vtkExtractPolyDataPiece() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractTensorComponents Member List

This is the complete list of members for vtkExtractTensorComponents, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExtractNormals [protected]
  • ExtractNormalsOff() [virtual]
  • ExtractNormalsOn() [virtual]
  • ExtractScalars [protected]
  • ExtractScalarsOff() [virtual]
  • ExtractScalarsOn() [virtual]
  • ExtractTCoords [protected]
  • ExtractTCoordsOff() [virtual]
  • ExtractTCoordsOn() [virtual]
  • ExtractVectors [protected]
  • ExtractVectorsOff() [virtual]
  • ExtractVectorsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractNormals() [virtual]
  • GetExtractScalars() [virtual]
  • GetExtractTCoords() [virtual]
  • GetExtractVectors() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormalComponents() [virtual]
  • GetNormalComponents(int data[6]) [virtual]
  • GetNormalizeNormals() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfTCoords() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassTensorsToOutput() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarComponents() [virtual]
  • GetScalarComponents(int data[2]) [virtual]
  • GetScalarMode() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTCoordComponents() [virtual]
  • GetTCoordComponents(int data[6]) [virtual]
  • GetUnstructuredGridOutput()
  • GetVectorComponents() [virtual]
  • GetVectorComponents(int data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalComponents [protected]
  • NormalizeNormals [protected]
  • NormalizeNormalsOff() [virtual]
  • NormalizeNormalsOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfTCoords [protected]
  • operator=(const vtkExtractTensorComponents &) (defined in vtkExtractTensorComponents) [private]
  • Outputs [protected]
  • PassTensorsToOutput [protected]
  • PassTensorsToOutputOff() [virtual]
  • PassTensorsToOutputOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarComponents [protected]
  • ScalarIsComponent() [inline]
  • ScalarIsDeterminant() [inline]
  • ScalarIsEffectiveStress() [inline]
  • ScalarMode [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractNormals(int) [virtual]
  • SetExtractScalars(int) [virtual]
  • SetExtractTCoords(int) [virtual]
  • SetExtractVectors(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNormalComponents(int, int, int, int, int, int) [virtual]
  • SetNormalComponents(int[6]) [virtual]
  • SetNormalizeNormals(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfTCoords(int) [virtual]
  • SetOutput(vtkDataSet *)
  • SetPassTensorsToOutput(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarComponents(int, int) [virtual]
  • SetScalarComponents(int[2])
  • SetScalarMode(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordComponents(int, int, int, int, int, int) [virtual]
  • SetTCoordComponents(int[6]) [virtual]
  • SetVectorComponents(int, int, int, int, int, int) [virtual]
  • SetVectorComponents(int[6]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordComponents [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorComponents [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkExtractTensorComponents() [protected]
  • vtkExtractTensorComponents(const vtkExtractTensorComponents &) (defined in vtkExtractTensorComponents) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractTensorComponents, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkExtractTensorComponents() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractUnstructuredGrid Member List

This is the complete list of members for vtkExtractUnstructuredGrid, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellClipping [protected]
  • CellClippingOff() [virtual]
  • CellClippingOn() [virtual]
  • CellMaximum [protected]
  • CellMinimum [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • Extent [protected]
  • ExtentClipping [protected]
  • ExtentClippingOff() [virtual]
  • ExtentClippingOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetCellClipping() [virtual]
  • GetCellMaximum() [virtual]
  • GetCellMinimum() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [inline]
  • GetExtentClipping() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMerging() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointClipping() [virtual]
  • GetPointMaximum() [virtual]
  • GetPointMinimum() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Merging [protected]
  • MergingOff() [virtual]
  • MergingOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractUnstructuredGrid &) (defined in vtkExtractUnstructuredGrid) [private]
  • Outputs [protected]
  • PointClipping [protected]
  • PointClippingOff() [virtual]
  • PointClippingOn() [virtual]
  • PointMaximum [protected]
  • PointMinimum [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCellClipping(int) [virtual]
  • SetCellMaximum(vtkIdType) [virtual]
  • SetCellMinimum(vtkIdType) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
  • SetExtent(float extent[6])
  • SetExtentClipping(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input)
  • SetLocator(vtkPointLocator *locator)
  • SetMerging(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetPointClipping(int) [virtual]
  • SetPointMaximum(vtkIdType) [virtual]
  • SetPointMinimum(vtkIdType) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkExtractUnstructuredGrid() [protected]
  • vtkExtractUnstructuredGrid(const vtkExtractUnstructuredGrid &) (defined in vtkExtractUnstructuredGrid) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractUnstructuredGrid, vtkUnstructuredGridToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
  • ~vtkExtractUnstructuredGrid() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
  • ~vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:17:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractUnstructuredGridPiece Member List

This is the complete list of members for vtkExtractUnstructuredGridPiece, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddGhostLevel(vtkUnstructuredGrid *input, vtkIntArray *cellTags, int ghostLevel) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCellTags(vtkIntArray *cellTags, vtkIdList *pointOwnership, int piece, int numPieces) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • CreateGhostCells [protected]
  • CreateGhostCellsOff() [virtual]
  • CreateGhostCellsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCreateGhostCells() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractUnstructuredGridPiece &) (defined in vtkExtractUnstructuredGridPiece) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCreateGhostCells(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkExtractUnstructuredGridPiece() [protected]
  • vtkExtractUnstructuredGridPiece(const vtkExtractUnstructuredGridPiece &) (defined in vtkExtractUnstructuredGridPiece) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
  • ~vtkExtractUnstructuredGridPiece() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
  • ~vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:17:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractVectorComponents Member List

This is the complete list of members for vtkExtractVectorComponents, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExtractToFieldData [protected]
  • ExtractToFieldDataOff() [virtual]
  • ExtractToFieldDataOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractToFieldData() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int i=0)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetVxComponent()
  • GetVyComponent()
  • GetVzComponent()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractVectorComponents &) (defined in vtkExtractVectorComponents) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractToFieldData(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkExtractVectorComponents() [protected]
  • vtkExtractVectorComponents(const vtkExtractVectorComponents &) (defined in vtkExtractVectorComponents) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkExtractVectorComponents, vtkSource)
  • ~vtkExtractVectorComponents() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkExtractVOI Member List

This is the complete list of members for vtkExtractVOI, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleRate() [virtual]
  • GetSampleRate(int data[3]) [virtual]
  • GetVOI() [virtual]
  • GetVOI(int data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkExtractVOI &) (defined in vtkExtractVOI) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleRate [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleRate(int, int, int) [virtual]
  • SetSampleRate(int[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVOI(int, int, int, int, int, int) [virtual]
  • SetVOI(int[6]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VOI [protected]
  • vtkExtractVOI() [protected]
  • vtkExtractVOI(const vtkExtractVOI &) (defined in vtkExtractVOI) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkExtractVOI, vtkStructuredPointsToStructuredPointsFilter)
  • ~vtkExtractVOI() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
Generated on Mon Mar 25 01:17:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFeatureEdges Member List

This is the complete list of members for vtkFeatureEdges, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BoundaryEdges [protected]
  • BoundaryEdgesOff() [virtual]
  • BoundaryEdgesOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Coloring [protected]
  • ColoringOff() [virtual]
  • ColoringOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FeatureEdges [protected]
  • FeatureEdgesOff() [virtual]
  • FeatureEdgesOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetBoundaryEdges() [virtual]
  • GetClassName() [inline, virtual]
  • GetColoring() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFeatureAngle() [virtual]
  • GetFeatureEdges() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetManifoldEdges() [virtual]
  • GetMTime() [virtual]
  • GetNonManifoldEdges() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • ManifoldEdges [protected]
  • ManifoldEdgesOff() [virtual]
  • ManifoldEdgesOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NonManifoldEdges [protected]
  • NonManifoldEdgesOff() [virtual]
  • NonManifoldEdgesOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkFeatureEdges &) (defined in vtkFeatureEdges) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBoundaryEdges(int) [virtual]
  • SetColoring(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeatureAngle(float) [virtual]
  • SetFeatureEdges(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetManifoldEdges(int) [virtual]
  • SetNonManifoldEdges(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkFeatureEdges() [protected]
  • vtkFeatureEdges(const vtkFeatureEdges &) (defined in vtkFeatureEdges) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkFeatureEdges, vtkPolyDataToPolyDataFilter)
  • ~vtkFeatureEdges() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFieldData Member List

This is the complete list of members for vtkFieldData, including all inherited members.
  • AddArray(vtkDataArray *array)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)
  • AllocateArrays(int num)
  • BreakOnError() [static]
  • ClearFieldFlags() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyAllOff() [virtual]
  • CopyAllOn() [virtual]
  • CopyFieldFlags [protected]
  • CopyFieldOff(const char *name) [inline]
  • CopyFieldOn(const char *name) [inline]
  • CopyFieldOnOff(const char *name, int onOff) [protected]
  • CopyFlags(const vtkFieldData *source) [protected]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkFieldData *da) [virtual]
  • Delete() [virtual]
  • DoCopyAllOff [protected]
  • DoCopyAllOn [protected]
  • FindFlag(const char *field) [protected]
  • GetActualMemorySize() [virtual]
  • GetArray(int i)
  • GetArray(const char *arrayName, int &index)
  • GetArray(const char *arrayName)
  • GetArrayContainingComponent(int i, int &arrayComp)
  • GetArrayName(int i) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j)
  • GetDebug()
  • GetField(vtkIdList *ptId, vtkFieldData *f)
  • GetFlag(const char *field) [protected]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfArrays()
  • GetNumberOfComponents()
  • GetNumberOfTuples()
  • GetReferenceCount() [inline]
  • GetTuple(const vtkIdType i)
  • GetTuple(const vtkIdType i, float *tuple)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitializeFields() [protected, virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c)
  • InsertNextTuple(const float *tuple)
  • InsertTuple(const vtkIdType i, const float *tuple)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfActiveArrays [protected]
  • NumberOfArrays [protected]
  • NumberOfFieldFlags [protected]
  • operator=(const vtkFieldData &) (defined in vtkFieldData) [private]
  • PassData(vtkFieldData *fd) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveArray(const char *name) [inline, virtual]
  • RemoveArray(int index) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset()
  • SafeDownCast(vtkObject *o) [static]
  • SetArray(int i, vtkDataArray *array) [protected]
  • SetComponent(const vtkIdType i, const int j, const float c)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNumberOfArrays(int num) [inline]
  • SetNumberOfTuples(const vtkIdType number)
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple)
  • ShallowCopy(vtkFieldData *da) [virtual]
  • Squeeze()
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkFieldData() [protected]
  • vtkFieldData(const vtkFieldData &) (defined in vtkFieldData) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFieldData, vtkObject)
  • ~vtkFieldData() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFieldData::BasicIterator Member List

This is the complete list of members for vtkFieldData::BasicIterator, including all inherited members.
  • BasicIterator()
  • BasicIterator(const BasicIterator &source)
  • BasicIterator(const int *list, unsigned int listSize)
  • BeginIndex() [inline]
  • End() const [inline]
  • GetCurrentIndex() [inline]
  • GetListSize() const [inline]
  • List [protected]
  • ListSize [protected]
  • NextIndex() [inline]
  • operator=(const BasicIterator &source)
  • Position [protected]
  • ~BasicIterator() [virtual]
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFieldData::Iterator Member List

This is the complete list of members for vtkFieldData::Iterator, including all inherited members.
  • BasicIterator()
  • BasicIterator(const BasicIterator &source)
  • BasicIterator(const int *list, unsigned int listSize)
  • Begin() [inline]
  • BeginIndex() [inline]
  • Detached [protected]
  • DetachFieldData()
  • End() const [inline]
  • Fields [protected]
  • GetCurrentIndex() [inline]
  • GetListSize() const [inline]
  • Iterator(const Iterator &source)
  • Iterator(vtkFieldData *dsa, const int *list=0, unsigned int listSize=0)
  • List [protected]
  • ListSize [protected]
  • Next() [inline]
  • NextIndex() [inline]
  • operator=(const Iterator &source)
  • vtkFieldData::BasicIterator::operator=(const BasicIterator &source)
  • Position [protected]
  • ~BasicIterator() [virtual]
  • ~Iterator() [virtual]
Generated on Mon Mar 25 01:17:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFieldDataToAttributeDataFilter Member List

This is the complete list of members for vtkFieldDataToAttributeDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ConstructArray(vtkDataArray *da, int comp, vtkDataArray *frray, int fieldComp, vtkIdType min, vtkIdType max, int normalize) [static]
  • ConstructFieldData(int num, vtkDataSetAttributes *attr) [protected]
  • ConstructGhostLevels(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[2], char *array, int arrayComponent, int normalize) [protected]
  • ConstructNormals(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3]) [protected]
  • ConstructScalars(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[4][2], char *arrays[4], int arrayComponents[4], int normalize[4], int numComp) [protected]
  • ConstructTCoords(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3], int numComp) [protected]
  • ConstructTensors(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[9][2], char *arrays[9], int arrayComponents[9], int normalize[9]) [protected]
  • ConstructVectors(int num, vtkFieldData *fd, vtkDataSetAttributes *attr, vtkIdType componentRange[3][2], char *arrays[3], int arrayComponents[3], int normalize[3]) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultNormalize [protected]
  • DefaultNormalizeOff() [virtual]
  • DefaultNormalizeOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponentsType(int numComp, vtkDataArray **arrays) [static]
  • GetDebug()
  • GetDefaultNormalize() [virtual]
  • GetErrorCode() [virtual]
  • GetFieldArray(vtkFieldData *fd, char *name, int comp) [static]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputField() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormalComponentArrayComponent(int comp)
  • GetNormalComponentArrayName(int comp)
  • GetNormalComponentMaxRange(int comp)
  • GetNormalComponentMinRange(int comp)
  • GetNormalComponentNormalizeFlag(int comp)
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputAttributeData() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarComponentArrayComponent(int comp)
  • GetScalarComponentArrayName(int comp)
  • GetScalarComponentMaxRange(int comp)
  • GetScalarComponentMinRange(int comp)
  • GetScalarComponentNormalizeFlag(int comp)
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTCoordComponentArrayComponent(int comp)
  • GetTCoordComponentArrayName(int comp)
  • GetTCoordComponentMaxRange(int comp)
  • GetTCoordComponentMinRange(int comp)
  • GetTCoordComponentNormalizeFlag(int comp)
  • GetTensorComponentArrayComponent(int comp)
  • GetTensorComponentArrayName(int comp)
  • GetTensorComponentMaxRange(int comp)
  • GetTensorComponentMinRange(int comp)
  • GetTensorComponentNormalizeFlag(int comp)
  • GetUnstructuredGridOutput()
  • GetVectorComponentArrayComponent(int comp)
  • GetVectorComponentArrayName(int comp)
  • GetVectorComponentMaxRange(int comp)
  • GetVectorComponentMinRange(int comp)
  • GetVectorComponentNormalizeFlag(int comp)
  • GhostLevelArray [protected]
  • GhostLevelArrayComponent [protected]
  • GhostLevelComponentRange [protected]
  • GhostLevelNormalize [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputField [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalArrayComponents [protected]
  • NormalArrays [protected]
  • NormalComponentRange [protected]
  • NormalNormalize [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • NumberOfTCoordComponents [protected]
  • operator=(const vtkFieldDataToAttributeDataFilter &) (defined in vtkFieldDataToAttributeDataFilter) [private]
  • OutputAttributeData [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarArrayComponents [protected]
  • ScalarArrays [protected]
  • ScalarComponentRange [protected]
  • ScalarNormalize [protected]
  • SetAbortExecute(int) [virtual]
  • SetArrayName(vtkObject *self, char *&name, const char *newName) [static]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultNormalize(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetInputField(int) [virtual]
  • SetInputFieldToCellDataField() [inline]
  • SetInputFieldToDataObjectField() [inline]
  • SetInputFieldToPointDataField() [inline]
  • SetNormalComponent(int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetNormalComponent(int comp, const char *arrayName, int arrayComp) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetOutputAttributeData(int) [virtual]
  • SetOutputAttributeDataToCellData() [inline]
  • SetOutputAttributeDataToPointData() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarComponent(int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetScalarComponent(int comp, const char *arrayName, int arrayComp) [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordComponent(int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetTCoordComponent(int comp, const char *arrayName, int arrayComp) [inline]
  • SetTensorComponent(int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetTensorComponent(int comp, const char *arrayName, int arrayComp) [inline]
  • SetVectorComponent(int comp, const char *arrayName, int arrayComp, int min, int max, int normalize)
  • SetVectorComponent(int comp, const char *arrayName, int arrayComp) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordArrayComponents [protected]
  • TCoordArrays [protected]
  • TCoordComponentRange [protected]
  • TCoordNormalize [protected]
  • TensorArrayComponents [protected]
  • TensorArrays [protected]
  • TensorComponentRange [protected]
  • TensorNormalize [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateComponentRange(vtkDataArray *da, vtkIdType compRange[2]) [static]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorArrayComponents [protected]
  • VectorArrays [protected]
  • VectorComponentRange [protected]
  • VectorNormalize [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkFieldDataToAttributeDataFilter() [protected]
  • vtkFieldDataToAttributeDataFilter(const vtkFieldDataToAttributeDataFilter &) (defined in vtkFieldDataToAttributeDataFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkFieldDataToAttributeDataFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkFieldDataToAttributeDataFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFileOutputWindow Member List

This is the complete list of members for vtkFileOutputWindow, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Append [protected]
  • AppendOff() [virtual]
  • AppendOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayDebugText(const char *) [virtual]
  • DisplayErrorText(const char *) [virtual]
  • DisplayGenericWarningText(const char *) [virtual]
  • DisplayText(const char *) [virtual]
  • DisplayWarningText(const char *) [virtual]
  • FileName [protected]
  • Flush [protected]
  • FlushOff() [virtual]
  • FlushOn() [virtual]
  • GetAppend() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetFlush() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInstance() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkFileOutputWindow &) (defined in vtkFileOutputWindow) [private]
  • OStream [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PromptUser [protected]
  • PromptUserOff() [virtual]
  • PromptUserOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAppend(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetFileName(const char *) [virtual]
  • SetFlush(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstance(vtkOutputWindow *instance) [static]
  • SetPromptUser(int) [virtual]
  • SetReferenceCount(int)
  • SmartPointer [static]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkFileOutputWindow() [protected]
  • vtkFileOutputWindow(const vtkFileOutputWindow &) (defined in vtkFileOutputWindow) [private]
  • vtkObject() [protected]
  • vtkOutputWindow() [protected]
  • vtkTypeRevisionMacro(vtkFileOutputWindow, vtkOutputWindow)
  • ~vtkFileOutputWindow() [protected, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutputWindow() [protected, virtual]
Generated on Mon Mar 25 01:17:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFiniteDifferenceGradientEstimator Member List

This is the complete list of members for vtkFiniteDifferenceGradientEstimator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BoundsClip [protected]
  • BoundsClipOff() [virtual]
  • BoundsClipOn() [virtual]
  • BreakOnError() [static]
  • BuildTime
  • CircleLimits [protected]
  • CircleLimitsSize [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCircleLimits(int size) [protected]
  • ComputeGradientMagnitudes [protected]
  • ComputeGradientMagnitudesOff() [virtual]
  • ComputeGradientMagnitudesOn() [virtual]
  • CylinderClip [protected]
  • CylinderClipOff() [virtual]
  • CylinderClipOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DirectionEncoder [protected]
  • EncodedNormals
  • EncodedNormalsSize
  • GetBounds() [virtual]
  • GetBounds(int data[6]) [virtual]
  • GetBoundsClip() [virtual]
  • GetCircleLimits() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradientMagnitudes() [virtual]
  • GetCylinderClip() [virtual]
  • GetDebug()
  • GetDirectionEncoder() [virtual]
  • GetEncodedNormalIndex(int xyz_index)
  • GetEncodedNormalIndex(int x_index, int y_index, int z_index)
  • GetEncodedNormals(void)
  • GetGlobalWarningDisplay() [static]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes(void)
  • GetGradientMagnitudeScale() [virtual]
  • GetInput() [virtual]
  • GetInputAspect() [virtual]
  • GetInputAspect(float data[3]) [virtual]
  • GetInputSize() [virtual]
  • GetInputSize(int data[3]) [virtual]
  • GetLastUpdateTimeInCPUSeconds() [virtual]
  • GetLastUpdateTimeInSeconds() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetReferenceCount() [inline]
  • GetSampleSpacingInVoxels() [virtual]
  • GetUseCylinderClip() [virtual]
  • GetZeroNormalThreshold() [virtual]
  • GetZeroPad() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientMagnitudeBias [protected]
  • GradientMagnitudes
  • GradientMagnitudeScale [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input
  • InputAspect [protected]
  • InputSize [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastUpdateTimeInCPUSeconds [protected]
  • LastUpdateTimeInSeconds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfThreads [protected]
  • operator=(const vtkFiniteDifferenceGradientEstimator &) (defined in vtkFiniteDifferenceGradientEstimator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SampleSpacingInVoxels
  • SetBounds(int, int, int, int, int, int) [virtual]
  • SetBounds(int[6]) [virtual]
  • SetBoundsClip(int) [virtual]
  • SetComputeGradientMagnitudes(int) [virtual]
  • SetCylinderClip(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionEncoder(vtkDirectionEncoder *direnc)
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientMagnitudeBias(float) [virtual]
  • SetGradientMagnitudeScale(float) [virtual]
  • SetInput(vtkImageData *) [virtual]
  • SetNumberOfThreads(int) [virtual]
  • SetReferenceCount(int)
  • SetSampleSpacingInVoxels(int) [virtual]
  • SetZeroNormalThreshold(float v)
  • SetZeroPad(int) [virtual]
  • SubjectHelper [protected]
  • Threader [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update(void)
  • UpdateNormals(void) [protected, virtual]
  • UseCylinderClip [protected]
  • vtkEncodedGradientEstimator() [protected]
  • vtkFiniteDifferenceGradientEstimator() [protected]
  • vtkFiniteDifferenceGradientEstimator(const vtkFiniteDifferenceGradientEstimator &) (defined in vtkFiniteDifferenceGradientEstimator) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFiniteDifferenceGradientEstimator, vtkEncodedGradientEstimator)
  • ZeroNormalThreshold [protected]
  • ZeroPad [protected]
  • ZeroPadOff() [virtual]
  • ZeroPadOn() [virtual]
  • ~vtkEncodedGradientEstimator() [protected]
  • ~vtkFiniteDifferenceGradientEstimator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFloatArray Member List

This is the complete list of members for vtkFloatArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *fa) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const float f) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const float f) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkFloatArray &) (defined in vtkFloatArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(float *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const float value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkFloatArray(vtkIdType numComp=1) [protected]
  • vtkFloatArray(const vtkFloatArray &) (defined in vtkFloatArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFloatArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkFloatArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFollower Member List

This is the complete list of members for vtkFollower, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ApplyProperties() [inline, virtual]
  • BackfaceProperty [protected]
  • Bounds [protected]
  • BoundsMTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Camera [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Device [protected]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBackfaceProperty()
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCamera() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetIsOpaque() [protected]
  • GetLength()
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [inline, virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPart() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfParts() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetTexture() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPartTraversal() [virtual]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • MakeProperty() [virtual]
  • Mapper [protected]
  • MapperBounds [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkFollower &) (defined in vtkFollower) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • Render(vtkRenderer *, vtkMapper *) (defined in vtkFollower) [inline, private, virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBackfaceProperty(vtkProperty *lut)
  • SetCamera(vtkCamera *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkMapper *) [virtual]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkProperty *lut)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetTexture(vtkTexture *) [virtual]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Texture [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor() [protected]
  • vtkFollower() [protected]
  • vtkFollower(const vtkFollower &) (defined in vtkFollower) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkFollower, vtkActor)
  • ~vtkActor() [protected]
  • ~vtkFollower() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:17:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFrustumCoverageCuller Member List

This is the complete list of members for vtkFrustumCoverageCuller, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Cull(vtkRenderer *ren, vtkProp **propList, int &listLength, int &initialized) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMaximumCoverage() [virtual]
  • GetMinimumCoverage() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetSortingStyle() [virtual]
  • GetSortingStyleAsString(void)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaximumCoverage [protected]
  • MinimumCoverage [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkFrustumCoverageCuller &) (defined in vtkFrustumCoverageCuller) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximumCoverage(float) [virtual]
  • SetMinimumCoverage(float) [virtual]
  • SetReferenceCount(int)
  • SetSortingStyle(int) [virtual]
  • SetSortingStyleToBackToFront() [inline]
  • SetSortingStyleToFrontToBack() [inline]
  • SetSortingStyleToNone() [inline]
  • SortingStyle [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCuller() [protected]
  • vtkFrustumCoverageCuller() [protected]
  • vtkFrustumCoverageCuller(const vtkFrustumCoverageCuller &) (defined in vtkFrustumCoverageCuller) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFrustumCoverageCuller, vtkCuller)
  • ~vtkCuller() [protected]
  • ~vtkFrustumCoverageCuller() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFunctionParser Member List

This is the complete list of members for vtkFunctionParser, including all inherited members.
  • AddInternalByte(unsigned char newByte) [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • BuildInternalFunctionStructure() [protected]
  • BuildInternalSubstringStructure(int beginIndex, int endIndex) [protected]
  • ByteCode [protected]
  • ByteCodeSize [protected]
  • CheckSyntax() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisambiguateOperators() [protected]
  • Evaluate() [protected]
  • EvaluateMTime [protected]
  • FindEndOfMathFunction(int beginIndex) [protected]
  • Function [protected]
  • FunctionLength [protected]
  • FunctionMTime [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetElementaryOperatorNumber(char op) [protected]
  • GetFunction() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMathFunctionNumber(int currentIndex) [protected]
  • GetMathFunctionStringLength(int mathFunctionNumber) [protected]
  • GetMTime() [virtual]
  • GetNumberOfScalarVariables() [virtual]
  • GetNumberOfVectorVariables() [virtual]
  • GetOperandNumber(int currentIndex) [protected]
  • GetReferenceCount() [inline]
  • GetScalarResult()
  • GetScalarVariableName(int i)
  • GetScalarVariableValue(const char *variableName)
  • GetScalarVariableValue(int i)
  • GetVariableNameLength(int variableNumber) [protected]
  • GetVectorResult()
  • GetVectorResult(double result[3]) [inline]
  • GetVectorVariableName(int i)
  • GetVectorVariableValue(const char *variableName)
  • GetVectorVariableValue(const char *variableName, double value[3]) [inline]
  • GetVectorVariableValue(int i)
  • GetVectorVariableValue(int i, double value[3]) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Immediates [protected]
  • ImmediatesSize [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsElementaryOperator(int op) [protected]
  • IsScalarResult()
  • IsSubstringCompletelyEnclosed(int beginIndex, int endIndex) [protected]
  • IsTypeOf(const char *name) [static]
  • IsVariableName(int currentIndex) [protected]
  • IsVectorResult()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfScalarVariables [protected]
  • NumberOfVectorVariables [protected]
  • operator=(const vtkFunctionParser &) (defined in vtkFunctionParser) [private]
  • Parse() [protected]
  • ParseMTime [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllVariables()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveSpaces() [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarVariableNames [protected]
  • ScalarVariableValues [protected]
  • SetDebug(unsigned char debugFlag)
  • SetFunction(const char *function)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetScalarVariableValue(const char *variableName, double value)
  • SetScalarVariableValue(int i, double value)
  • SetVectorVariableValue(const char *variableName, double xValue, double yValue, double zValue)
  • SetVectorVariableValue(const char *variableName, const double values[3]) [inline]
  • SetVectorVariableValue(int i, double xValue, double yValue, double zValue)
  • SetVectorVariableValue(int i, const double values[3]) [inline]
  • Stack [protected]
  • StackPointer [protected]
  • StackSize [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • VariableMTime [protected]
  • VectorVariableNames [protected]
  • VectorVariableValues [protected]
  • vtkFunctionParser() [protected]
  • vtkFunctionParser(const vtkFunctionParser &) (defined in vtkFunctionParser) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFunctionParser, vtkObject)
  • ~vtkFunctionParser() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFunctionSet Member List

This is the complete list of members for vtkFunctionSet, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionValues(float *x, float *f)=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfFunctions() [inline, virtual]
  • GetNumberOfIndependentVariables() [inline, virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NumFuncs [protected]
  • NumIndepVars [protected]
  • operator=(const vtkFunctionSet &) (defined in vtkFunctionSet) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkFunctionSet() [protected]
  • vtkFunctionSet(const vtkFunctionSet &) (defined in vtkFunctionSet) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkFunctionSet, vtkObject)
  • ~vtkFunctionSet() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGaussianSplatter Member List

This is the complete list of members for vtkGaussianSplatter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AccumulationMode [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Cap(vtkFloatArray *s) [protected]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CapValue [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeModelBounds()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EccentricGaussian(float x[3]) [protected]
  • Eccentricity [protected]
  • Eccentricity2 (defined in vtkGaussianSplatter) [private]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExponentFactor [protected]
  • Gaussian(float x[3]) [protected]
  • GetAbortExecute() [virtual]
  • GetAccumulationMode() [virtual]
  • GetAccumulationModeAsString()
  • GetCapping() [virtual]
  • GetCapValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEccentricity() [virtual]
  • GetErrorCode() [virtual]
  • GetExponentFactor() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNormalWarping() [virtual]
  • GetNullValue() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GetScalarWarping() [virtual]
  • GetScaleFactor() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • N (defined in vtkGaussianSplatter) [private]
  • New() [static]
  • NewScalars (defined in vtkGaussianSplatter) [private]
  • NormalWarping [protected]
  • NormalWarpingOff() [virtual]
  • NormalWarpingOn() [virtual]
  • NullValue (defined in vtkGaussianSplatter) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkGaussianSplatter &) (defined in vtkGaussianSplatter) [private]
  • Origin (defined in vtkGaussianSplatter) [private]
  • Outputs [protected]
  • P (defined in vtkGaussianSplatter) [private]
  • PositionSampling(float) [inline, protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • Radius2 (defined in vtkGaussianSplatter) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • S (defined in vtkGaussianSplatter) [private]
  • SafeDownCast(vtkObject *o) [static]
  • Sample (defined in vtkGaussianSplatter) [private]
  • SampleDimensions [protected]
  • SampleFactor (defined in vtkGaussianSplatter) [private]
  • ScalarSampling(float s) [inline, protected]
  • ScalarWarping [protected]
  • ScalarWarpingOff() [virtual]
  • ScalarWarpingOn() [virtual]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetAccumulationMode(int) [virtual]
  • SetAccumulationModeToMax() [inline]
  • SetAccumulationModeToMin() [inline]
  • SetAccumulationModeToSum() [inline]
  • SetCapping(int) [virtual]
  • SetCapValue(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEccentricity(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExponentFactor(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetModelBounds(float, float, float, float, float, float) [virtual]
  • SetModelBounds(float[6]) [virtual]
  • SetNormalWarping(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNullValue(float) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetScalar(int idx, float dist2) [protected]
  • SetScalarWarping(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Spacing (defined in vtkGaussianSplatter) [private]
  • SplatDistance (defined in vtkGaussianSplatter) [private]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Visited (defined in vtkGaussianSplatter) [private]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkGaussianSplatter() [protected]
  • vtkGaussianSplatter(const vtkGaussianSplatter &) (defined in vtkGaussianSplatter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkGaussianSplatter, vtkDataSetToStructuredPointsFilter)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkGaussianSplatter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:17:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGeneralTransform Member List

This is the complete list of members for vtkGeneralTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Concatenate(vtkMatrix4x4 *matrix) [inline]
  • Concatenate(const double elements[16]) [inline]
  • Concatenate(vtkAbstractTransform *transform)
  • Concatenation [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConcatenatedTransform(int i) [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetInverse()
  • GetInverseFlag() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConcatenatedTransforms() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • Input [protected]
  • InternalDeepCopy(vtkAbstractTransform *t) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [inline, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkGeneralTransform &) (defined in vtkGeneralTransform) [private]
  • Pop() [inline]
  • PostMultiply() [inline]
  • PreMultiply() [inline]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Push() [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RotateWXYZ(double angle, double x, double y, double z) [inline]
  • RotateWXYZ(double angle, const double axis[3]) [inline]
  • RotateWXYZ(double angle, const float axis[3]) [inline]
  • RotateX(double angle) [inline]
  • RotateY(double angle) [inline]
  • RotateZ(double angle) [inline]
  • SafeDownCast(vtkObject *o) [static]
  • Scale(double x, double y, double z) [inline]
  • Scale(const double s[3]) [inline]
  • Scale(const float s[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkAbstractTransform *input)
  • SetInverse(vtkAbstractTransform *transform)
  • SetReferenceCount(int)
  • Stack [protected]
  • SubjectHelper [protected]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • Translate(double x, double y, double z) [inline]
  • Translate(const double x[3]) [inline]
  • Translate(const float x[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkGeneralTransform() [protected]
  • vtkGeneralTransform(const vtkGeneralTransform &) (defined in vtkGeneralTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkGeneralTransform, vtkAbstractTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkGeneralTransform() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGenericCell Member List

This is the complete list of members for vtkGenericCell, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • Cell [protected]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [virtual]
  • GetCellType() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int faceId) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [virtual]
  • GetNumberOfFaces() [virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkGenericCell &) (defined in vtkGenericCell) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetCellType(int cellType)
  • SetCellTypeToEmptyCell() [inline]
  • SetCellTypeToHexahedron() [inline]
  • SetCellTypeToLine() [inline]
  • SetCellTypeToPixel() [inline]
  • SetCellTypeToPolygon() [inline]
  • SetCellTypeToPolyLine() [inline]
  • SetCellTypeToPolyVertex() [inline]
  • SetCellTypeToPyramid() [inline]
  • SetCellTypeToQuad() [inline]
  • SetCellTypeToQuadraticEdge() [inline]
  • SetCellTypeToQuadraticTetra() [inline]
  • SetCellTypeToQuadraticTriangle() [inline]
  • SetCellTypeToTetra() [inline]
  • SetCellTypeToTriangle() [inline]
  • SetCellTypeToTriangleStrip() [inline]
  • SetCellTypeToVertex() [inline]
  • SetCellTypeToVoxel() [inline]
  • SetCellTypeToWedge() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkGenericCell() [protected]
  • vtkGenericCell(const vtkGenericCell &) (defined in vtkGenericCell) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkGenericCell, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkGenericCell() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:17:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGenericEnSightReader Member List

This is the complete list of members for vtkGenericEnSightReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddComplexVariableDescription(char *description) [protected]
  • AddComplexVariableType(int variableType) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddVariableDescription(char *description) [protected]
  • AddVariableType(int variableType) [protected]
  • BreakOnError() [static]
  • CaseFileName [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComplexVariableDescriptions [protected]
  • ComplexVariableTypes [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DetermineEnSightVersion() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePath [protected]
  • GeometryFileName [protected]
  • GetAbortExecute() [virtual]
  • GetCaseFileName() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComplexDescription(int n)
  • GetComplexVariableType(int n)
  • GetDebug()
  • GetDescription(int n)
  • GetDescription(int n, int type)
  • GetErrorCode() [virtual]
  • GetFilePath() [virtual]
  • GetGeometryFileName() [protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMaximumTimeValue() [virtual]
  • GetMinimumTimeValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfComplexScalarsPerElement() [virtual]
  • GetNumberOfComplexScalarsPerNode() [virtual]
  • GetNumberOfComplexVectorsPerElement() [virtual]
  • GetNumberOfComplexVectorsPerNode() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsPerElement() [virtual]
  • GetNumberOfScalarsPerMeasuredNode() [virtual]
  • GetNumberOfScalarsPerNode() [virtual]
  • GetNumberOfTensorsSymmPerElement() [virtual]
  • GetNumberOfTensorsSymmPerNode() [virtual]
  • GetNumberOfVariables(int type)
  • GetNumberOfVectorsPerElement() [virtual]
  • GetNumberOfVectorsPerMeasuredNode() [virtual]
  • GetNumberOfVectorsPerNode() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTimeValue() [virtual]
  • GetVariableType(int n)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IFile [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumTimeValue [protected]
  • MinimumTimeValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComplexScalarsPerElement [protected]
  • NumberOfComplexScalarsPerNode [protected]
  • NumberOfComplexVariables [protected]
  • NumberOfComplexVectorsPerElement [protected]
  • NumberOfComplexVectorsPerNode [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsPerElement [protected]
  • NumberOfScalarsPerMeasuredNode [protected]
  • NumberOfScalarsPerNode [protected]
  • NumberOfTensorsSymmPerElement [protected]
  • NumberOfTensorsSymmPerNode [protected]
  • NumberOfVariables [protected]
  • NumberOfVectorsPerElement [protected]
  • NumberOfVectorsPerMeasuredNode [protected]
  • NumberOfVectorsPerNode [protected]
  • operator=(const vtkGenericEnSightReader &) (defined in vtkGenericEnSightReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadBinaryLine(char result[80]) [protected]
  • Reader [protected]
  • ReadLine(char result[256]) [protected]
  • ReadNextDataLine(char result[256]) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceWildcards(char *fileName, int timeSet, int fileSet) [protected]
  • ReplaceWildcardsHelper(char *fileName, int num) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCaseFileName(char *fileName)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePath(const char *) [virtual]
  • SetGeometryFileName(const char *) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTimeValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VariableDescriptions [protected]
  • VariableTypes [protected]
  • vtkDataSetSource() [protected]
  • vtkGenericEnSightReader() [protected]
  • vtkGenericEnSightReader(const vtkGenericEnSightReader &) (defined in vtkGenericEnSightReader) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGenericEnSightReader, vtkDataSetSource)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkGenericEnSightReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:17:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGeometryFilter Member List

This is the complete list of members for vtkGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellClipping [protected]
  • CellClippingOff() [virtual]
  • CellClippingOn() [virtual]
  • CellMaximum [protected]
  • CellMinimum [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Extent [protected]
  • ExtentClipping [protected]
  • ExtentClippingOff() [virtual]
  • ExtentClippingOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetCellClipping() [virtual]
  • GetCellMaximum() [virtual]
  • GetCellMinimum() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [inline]
  • GetExtentClipping() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMerging() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointClipping() [virtual]
  • GetPointMaximum() [virtual]
  • GetPointMinimum() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Merging [protected]
  • MergingOff() [virtual]
  • MergingOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkGeometryFilter &) (defined in vtkGeometryFilter) [private]
  • Outputs [protected]
  • PointClipping [protected]
  • PointClippingOff() [virtual]
  • PointClippingOn() [virtual]
  • PointMaximum [protected]
  • PointMinimum [protected]
  • PolyDataExecute() [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCellClipping(int) [virtual]
  • SetCellMaximum(vtkIdType) [virtual]
  • SetCellMinimum(vtkIdType) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(float xMin, float xMax, float yMin, float yMax, float zMin, float zMax)
  • SetExtent(float extent[6])
  • SetExtentClipping(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetMerging(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPointClipping(int) [virtual]
  • SetPointMaximum(vtkIdType) [virtual]
  • SetPointMinimum(vtkIdType) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredGridExecute() [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredGridExecute() [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkGeometryFilter() [protected]
  • vtkGeometryFilter(const vtkGeometryFilter &) (defined in vtkGeometryFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGeometryFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkGeometryFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGESignaReader Member List

This is the complete list of members for vtkGESignaReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname) [virtual]
  • vtkMedicalImageReader2::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Date [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDate() [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetImageNumber() [virtual]
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPatientID() [virtual]
  • GetPatientName() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSeries() [virtual]
  • GetStudy() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • ImageNumber [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkGESignaReader &) (defined in vtkGESignaReader) [private]
  • Outputs [protected]
  • PatientID [protected]
  • PatientName [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • Series [protected]
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDate(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetImageNumber(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetPatientID(const char *) [virtual]
  • SetPatientName(const char *) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSeries(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStudy(const char *) [virtual]
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • Study [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkGESignaReader() [inline, protected]
  • vtkGESignaReader(const vtkGESignaReader &) (defined in vtkGESignaReader) [private]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkMedicalImageReader2() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGESignaReader, vtkImageReader2)
  • ~vtkGESignaReader() [inline, protected]
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkMedicalImageReader2() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGLUTesselatorTriangleFilter Member List

This is the complete list of members for vtkGLUTesselatorTriangleFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassLines() [virtual]
  • GetPassVerts() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GLUTesselator [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkGLUTesselatorTriangleFilter &) (defined in vtkGLUTesselatorTriangleFilter) [private]
  • Outputs [protected]
  • PassLines [protected]
  • PassLinesOff() [virtual]
  • PassLinesOn() [virtual]
  • PassVerts [protected]
  • PassVertsOff() [virtual]
  • PassVertsOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPassLines(int) [virtual]
  • SetPassVerts(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkGLUTesselatorTriangleFilter() [protected]
  • vtkGLUTesselatorTriangleFilter(const vtkGLUTesselatorTriangleFilter &) (defined in vtkGLUTesselatorTriangleFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGLUTesselatorTriangleFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkGLUTesselatorTriangleFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGlyph2D Member List

This is the complete list of members for vtkGlyph2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Clamping [protected]
  • ClampingOff() [virtual]
  • ClampingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMode [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GeneratePointIds [protected]
  • GeneratePointIdsOff() [virtual]
  • GeneratePointIdsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClamping() [virtual]
  • GetClassName() [inline, virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGeneratePointIds() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIndexMode() [virtual]
  • GetIndexModeAsString() [inline]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSources()
  • GetOrient() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointIdsName() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRange() [virtual]
  • GetRange(float data[2]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetScaleMode() [virtual]
  • GetScaleModeAsString() [inline]
  • GetScaling() [virtual]
  • GetSource(int id=0)
  • GetVectorMode() [virtual]
  • GetVectorModeAsString() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IndexMode [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSources [protected]
  • operator=(const vtkGlyph2D &) (defined in vtkGlyph2D) [private]
  • Orient [protected]
  • OrientOff() [virtual]
  • OrientOn() [virtual]
  • Outputs [protected]
  • PointIdsName [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Range [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • ScaleMode [protected]
  • Scaling [protected]
  • ScalingOff() [virtual]
  • ScalingOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClamping(int) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToColorByScalar() [inline]
  • SetColorModeToColorByScale() [inline]
  • SetColorModeToColorByVector() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGeneratePointIds(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIndexMode(int) [virtual]
  • SetIndexModeToOff() [inline]
  • SetIndexModeToScalar() [inline]
  • SetIndexModeToVector() [inline]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSources(int num)
  • SetOrient(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPointIdsName(const char *) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRange(float, float) [virtual]
  • SetRange(float[2])
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetScaleMode(int) [virtual]
  • SetScaleModeToDataScalingOff() [inline]
  • SetScaleModeToScaleByScalar() [inline]
  • SetScaleModeToScaleByVector() [inline]
  • SetScaleModeToScaleByVectorComponents() [inline]
  • SetScaling(int) [virtual]
  • SetSource(vtkPolyData *pd) [inline]
  • SetSource(int id, vtkPolyData *pd)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVectorMode(int) [virtual]
  • SetVectorModeToUseNormal() [inline]
  • SetVectorModeToUseVector() [inline]
  • SetVectorModeToVectorRotationOff() [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Source [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorMode [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkGlyph2D() [inline, protected]
  • vtkGlyph2D(const vtkGlyph2D &) (defined in vtkGlyph2D) [private]
  • vtkGlyph3D() [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGlyph2D, vtkGlyph3D)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkGlyph2D() [inline, protected]
  • ~vtkGlyph3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGlyph3D Member List

This is the complete list of members for vtkGlyph3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Clamping [protected]
  • ClampingOff() [virtual]
  • ClampingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMode [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GeneratePointIds [protected]
  • GeneratePointIdsOff() [virtual]
  • GeneratePointIdsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClamping() [virtual]
  • GetClassName() [inline, virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGeneratePointIds() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIndexMode() [virtual]
  • GetIndexModeAsString() [inline]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSources()
  • GetOrient() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointIdsName() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRange() [virtual]
  • GetRange(float data[2]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetScaleMode() [virtual]
  • GetScaleModeAsString() [inline]
  • GetScaling() [virtual]
  • GetSource(int id=0)
  • GetVectorMode() [virtual]
  • GetVectorModeAsString() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IndexMode [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSources [protected]
  • operator=(const vtkGlyph3D &) (defined in vtkGlyph3D) [private]
  • Orient [protected]
  • OrientOff() [virtual]
  • OrientOn() [virtual]
  • Outputs [protected]
  • PointIdsName [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Range [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • ScaleMode [protected]
  • Scaling [protected]
  • ScalingOff() [virtual]
  • ScalingOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClamping(int) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToColorByScalar() [inline]
  • SetColorModeToColorByScale() [inline]
  • SetColorModeToColorByVector() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGeneratePointIds(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIndexMode(int) [virtual]
  • SetIndexModeToOff() [inline]
  • SetIndexModeToScalar() [inline]
  • SetIndexModeToVector() [inline]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSources(int num)
  • SetOrient(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPointIdsName(const char *) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRange(float, float) [virtual]
  • SetRange(float[2])
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetScaleMode(int) [virtual]
  • SetScaleModeToDataScalingOff() [inline]
  • SetScaleModeToScaleByScalar() [inline]
  • SetScaleModeToScaleByVector() [inline]
  • SetScaleModeToScaleByVectorComponents() [inline]
  • SetScaling(int) [virtual]
  • SetSource(vtkPolyData *pd) [inline]
  • SetSource(int id, vtkPolyData *pd)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVectorMode(int) [virtual]
  • SetVectorModeToUseNormal() [inline]
  • SetVectorModeToUseVector() [inline]
  • SetVectorModeToVectorRotationOff() [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Source [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorMode [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkGlyph3D() [protected]
  • vtkGlyph3D(const vtkGlyph3D &) (defined in vtkGlyph3D) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGlyph3D, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkGlyph3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGlyphSource2D Member List

This is the complete list of members for vtkGlyphSource2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ConvertColor() [protected]
  • CreateArrow(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateCircle(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateCross(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale) [protected]
  • CreateDash(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale) [protected]
  • CreateDiamond(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateHookedArrow(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateSquare(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateThickArrow(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateThickCross(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateTriangle(vtkPoints *pts, vtkCellArray *lines, vtkCellArray *polys, vtkUnsignedCharArray *colors) [protected]
  • CreateVertex(vtkPoints *pts, vtkCellArray *verts, vtkUnsignedCharArray *colors) [protected]
  • Cross [protected]
  • CrossOff() [virtual]
  • CrossOn() [virtual]
  • Dash [protected]
  • DashOff() [virtual]
  • DashOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Filled [protected]
  • FilledOff() [virtual]
  • FilledOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetCross() [virtual]
  • GetDash() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilled() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGlyphType() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRotationAngle() [virtual]
  • GetScale() [virtual]
  • GetScale2() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GlyphType [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkGlyphSource2D &) (defined in vtkGlyphSource2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RGB [protected]
  • RotationAngle [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Scale [protected]
  • Scale2 [protected]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetCross(int) [virtual]
  • SetDash(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilled(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGlyphType(int) [virtual]
  • SetGlyphTypeToArrow() [inline]
  • SetGlyphTypeToCircle() [inline]
  • SetGlyphTypeToCross() [inline]
  • SetGlyphTypeToDash() [inline]
  • SetGlyphTypeToDiamond() [inline]
  • SetGlyphTypeToHookedArrow() [inline]
  • SetGlyphTypeToNone() [inline]
  • SetGlyphTypeToSquare() [inline]
  • SetGlyphTypeToThickArrow() [inline]
  • SetGlyphTypeToThickCross() [inline]
  • SetGlyphTypeToTriangle() [inline]
  • SetGlyphTypeToVertex() [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRotationAngle(float) [virtual]
  • SetScale(float) [virtual]
  • SetScale2(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TransformGlyph(vtkPoints *pts) [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkGlyphSource2D() [protected]
  • vtkGlyphSource2D(const vtkGlyphSource2D &) (defined in vtkGlyphSource2D) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGlyphSource2D, vtkPolyDataSource)
  • ~vtkGlyphSource2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGraphicsFactory Member List

This is the complete list of members for vtkGraphicsFactory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateInstance(const char *vtkclassname) [static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderLibrary() [static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkGraphicsFactory &) (defined in vtkGraphicsFactory) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkGraphicsFactory() [inline, protected]
  • vtkGraphicsFactory(const vtkGraphicsFactory &) (defined in vtkGraphicsFactory) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkGraphicsFactory, vtkObject)
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGraphLayoutFilter Member List

This is the complete list of members for vtkGraphLayoutFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AutomaticBoundsComputation [protected]
  • AutomaticBoundsComputationOff() [virtual]
  • AutomaticBoundsComputationOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CoolDownRate [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAutomaticBoundsComputation() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCoolDownRate() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGraphBounds() [virtual]
  • GetGraphBounds(float data[6]) [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMaxNumberOfIterations() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetThreeDimensionalLayout() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GraphBounds [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaxNumberOfIterations [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkGraphLayoutFilter &) (defined in vtkGraphLayoutFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAutomaticBoundsComputation(int) [virtual]
  • SetCoolDownRate(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGraphBounds(float, float, float, float, float, float) [virtual]
  • SetGraphBounds(float[6]) [virtual]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaxNumberOfIterations(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThreeDimensionalLayout(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreeDimensionalLayout [protected]
  • ThreeDimensionalLayoutOff() [virtual]
  • ThreeDimensionalLayoutOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkGraphLayoutFilter() [protected]
  • vtkGraphLayoutFilter(const vtkGraphLayoutFilter &) (defined in vtkGraphLayoutFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkGraphLayoutFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkGraphLayoutFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGridSynchronizedTemplates3D Member List

This is the complete list of members for vtkGridSynchronizedTemplates3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteExtent [protected]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExecuteExtent() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MinimumPieceSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkGridSynchronizedTemplates3D &) (defined in vtkGridSynchronizedTemplates3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetInputMemoryLimit(long limit)
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(int *exExt, int threadId)
  • Threader [protected]
  • Threads [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkGridSynchronizedTemplates3D() [protected]
  • vtkGridSynchronizedTemplates3D(const vtkGridSynchronizedTemplates3D &) (defined in vtkGridSynchronizedTemplates3D) [private]
  • vtkKitwareContourFilter [friend]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkGridSynchronizedTemplates3D, vtkStructuredGridToPolyDataFilter)
  • ~vtkGridSynchronizedTemplates3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:18:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkGridTransform Member List

This is the complete list of members for vtkGridTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • DisplacementGrid [protected]
  • DisplacementScale [protected]
  • DisplacementShift [protected]
  • ForwardTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [protected, virtual]
  • ForwardTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [protected, virtual]
  • ForwardTransformPoint(const float in[3], float out[3]) [protected, virtual]
  • ForwardTransformPoint(const double in[3], double out[3]) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplacementGrid() [virtual]
  • GetDisplacementScale() [virtual]
  • GetDisplacementShift() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInterpolationMode() [virtual]
  • GetInterpolationModeAsString() [inline]
  • GetInverse()
  • GetInverseFlag() [virtual]
  • GetInverseIterations() [virtual]
  • GetInverseTolerance() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • InterpolationFunction [protected]
  • InterpolationMode [protected]
  • Inverse() [virtual]
  • InverseFlag [protected]
  • InverseIterations [protected]
  • InverseTolerance [protected]
  • InverseTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [protected, virtual]
  • InverseTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [protected, virtual]
  • InverseTransformPoint(const float in[3], float out[3]) [protected, virtual]
  • InverseTransformPoint(const double in[3], double out[3]) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkGridTransform &) (defined in vtkGridTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetDisplacementGrid(vtkImageData *) [virtual]
  • SetDisplacementScale(float) [virtual]
  • SetDisplacementShift(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInterpolationMode(int mode)
  • SetInterpolationModeToCubic() [inline]
  • SetInterpolationModeToLinear() [inline]
  • SetInterpolationModeToNearestNeighbor() [inline]
  • SetInverse(vtkAbstractTransform *transform)
  • SetInverseIterations(int) [virtual]
  • SetInverseTolerance(double) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TemplateTransformInverse(const float in[3], float out[3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3]) [inline]
  • TemplateTransformInverse(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkGridTransform() [protected]
  • vtkGridTransform(const vtkGridTransform &) (defined in vtkGridTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkGridTransform, vtkWarpTransform)
  • vtkWarpTransform() [protected]
  • ~vtkAbstractTransform() [protected]
  • ~vtkGridTransform() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWarpTransform() [protected]
Generated on Mon Mar 25 01:18:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHeap Member List

This is the complete list of members for vtkHeap, including all inherited members.
  • Add(vtkHeapNode *node) [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateMemory(size_t n)
  • BreakOnError() [static]
  • CleanAll() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAndNext() [protected]
  • First [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfAllocations() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Last [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfAllocations [protected]
  • operator=(const vtkHeap &) (defined in vtkHeap) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkHeap() [protected]
  • vtkHeap(const vtkHeap &) (defined in vtkHeap) [private]
  • vtkObject() [protected]
  • vtkStrDup(const char *str)
  • vtkTypeRevisionMacro(vtkHeap, vtkObject)
  • ~vtkHeap() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHeapNode Member List

This is the complete list of members for vtkHeapNode, including all inherited members.
  • Next
  • Ptr
  • vtkHeapNode() [inline]
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHedgeHog Member List

This is the complete list of members for vtkHedgeHog, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetVectorMode() [virtual]
  • GetVectorModeAsString() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkHedgeHog &) (defined in vtkHedgeHog) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVectorMode(int) [virtual]
  • SetVectorModeToUseNormal() [inline]
  • SetVectorModeToUseVector() [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorMode [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkHedgeHog() [protected]
  • vtkHedgeHog(const vtkHedgeHog &) (defined in vtkHedgeHog) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkHedgeHog, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkHedgeHog() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHexahedron Member List

This is the complete list of members for vtkHexahedron, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetEdgeArray(int edgeId) [static]
  • GetEdgePoints(int edgeId, int *&pts) [virtual]
  • GetFace(int faceId) [virtual]
  • GetFaceArray(int faceId) [static]
  • GetFacePoints(int faceId, int *&pts) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[24]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[8]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • JacobianInverse(float pcoords[3], double **inverse, float derivs[24])
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkHexahedron &) (defined in vtkHexahedron) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkHexahedron() [protected]
  • vtkHexahedron(const vtkHexahedron &) (defined in vtkHexahedron) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkHexahedron, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkHexahedron() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHomogeneousTransform Member List

This is the complete list of members for vtkHomogeneousTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInverse()
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [inline, protected, virtual]
  • Inverse()=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform()=0 [pure virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkHomogeneousTransform &) (defined in vtkHomogeneousTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkHomogeneousTransform(const vtkHomogeneousTransform &) (defined in vtkHomogeneousTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkHomogeneousTransform, vtkAbstractTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHull Member List

This is the complete list of members for vtkHull, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddCubeEdgePlanes()
  • AddCubeFacePlanes()
  • AddCubeVertexPlanes()
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddPlane(float A, float B, float C)
  • AddPlane(float plane[3])
  • AddPlane(float A, float B, float C, float D)
  • AddPlane(float plane[3], float D)
  • AddRecursiveSpherePlanes(int level)
  • BreakOnError() [static]
  • ClipPolygonsFromPlanes(vtkPoints *points, vtkCellArray *polys, float *bounds) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputePlaneDistances() [protected]
  • CreateInitialPolygon(double *, int, float *) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateHull(vtkPolyData *pd, float *bounds)
  • GenerateHull(vtkPolyData *pd, float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfPlanes() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPlanes [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkHull &) (defined in vtkHull) [private]
  • Outputs [protected]
  • Planes [protected]
  • PlanesStorageSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveAllPlanes(void)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPlane(int i, float A, float B, float C)
  • SetPlane(int i, float plane[3])
  • SetPlane(int i, float A, float B, float C, float D)
  • SetPlane(int i, float plane[3], float D)
  • SetPlanes(vtkPlanes *planes)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkHull() [protected]
  • vtkHull(const vtkHull &) (defined in vtkHull) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkHull, vtkPolyDataToPolyDataFilter)
  • ~vtkHull() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkHyperStreamline Member List

This is the complete list of members for vtkHyperStreamline, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • BuildTube() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetIntegrationDirection() [virtual]
  • GetIntegrationStepLength() [virtual]
  • GetLogScaling() [virtual]
  • GetMaximumPropagationDistance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSides() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStartLocation(int &subId, float pcoords[3])
  • GetStartPosition()
  • GetStepLength() [virtual]
  • GetTerminalEigenvalue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • IntegrateMajorEigenvector()
  • IntegrateMediumEigenvector()
  • IntegrateMinorEigenvector()
  • IntegrationDirection [protected]
  • IntegrationEigenvector [protected]
  • IntegrationStepLength [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LogScaling [protected]
  • LogScalingOff() [virtual]
  • LogScalingOn() [virtual]
  • MaximumPropagationDistance [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSides [protected]
  • NumberOfStreamers [protected]
  • operator=(const vtkHyperStreamline &) (defined in vtkHyperStreamline) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetIntegrationDirection(int) [virtual]
  • SetIntegrationDirectionToBackward() [inline]
  • SetIntegrationDirectionToForward() [inline]
  • SetIntegrationDirectionToIntegrateBothDirections() [inline]
  • SetIntegrationStepLength(float) [virtual]
  • SetLogScaling(int) [virtual]
  • SetMaximumPropagationDistance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSides(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartLocation(vtkIdType cellId, int subId, float pcoords[3])
  • SetStartLocation(vtkIdType cellId, int subId, float r, float s, float t)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPosition(float x[3])
  • SetStartPosition(float x, float y, float z)
  • SetStepLength(float) [virtual]
  • SetTerminalEigenvalue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartCell [protected]
  • StartFrom [protected]
  • StartPCoords [protected]
  • StartPosition [protected]
  • StartSubId [protected]
  • StartTag [protected]
  • StepLength [protected]
  • Streamers [protected]
  • SubjectHelper [protected]
  • TerminalEigenvalue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkHyperStreamline() [protected]
  • vtkHyperStreamline(const vtkHyperStreamline &) (defined in vtkHyperStreamline) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkHyperStreamline, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkHyperStreamline() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIdentityTransform Member List

This is the complete list of members for vtkIdentityTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInverse()
  • GetLinearInverse() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *t) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [inline, protected, virtual]
  • Inverse() [inline, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkIdentityTransform &) (defined in vtkIdentityTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkIdentityTransform() [protected]
  • vtkIdentityTransform(const vtkIdentityTransform &) (defined in vtkIdentityTransform) [private]
  • vtkLinearTransform() [inline, protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIdentityTransform, vtkLinearTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkIdentityTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIdFilter Member List

This is the complete list of members for vtkIdFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellIds [protected]
  • CellIdsOff() [virtual]
  • CellIdsOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldData [protected]
  • FieldDataOff() [virtual]
  • FieldDataOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetCellIds() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldData() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIdsArrayName() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointIds() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IdsArrayName [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkIdFilter &) (defined in vtkIdFilter) [private]
  • Outputs [protected]
  • PointIds [protected]
  • PointIdsOff() [virtual]
  • PointIdsOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCellIds(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldData(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIdsArrayName(const char *) [virtual]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPointIds(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkIdFilter() [protected]
  • vtkIdFilter(const vtkIdFilter &) (defined in vtkIdFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkIdFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkIdFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIdList Member List

This is the complete list of members for vtkIdList, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const int sz, const int strategy=0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkIdList *ids)
  • Delete() [virtual]
  • DeleteId(vtkIdType id)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetId(const int i) [inline]
  • GetMTime() [virtual]
  • GetNumberOfIds() [inline]
  • GetPointer(const vtkIdType i) [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Ids [protected]
  • Initialize()
  • InsertId(const vtkIdType i, const vtkIdType id)
  • InsertNextId(const vtkIdType id) [inline]
  • InsertUniqueId(const vtkIdType id)
  • IntersectWith(vtkIdList &otherIds)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsId(vtkIdType id) [inline]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfIds [protected]
  • operator=(const vtkIdList &) (defined in vtkIdList) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetId(const vtkIdType i, const vtkIdType id) [inline]
  • SetNumberOfIds(const vtkIdType number)
  • SetReferenceCount(int)
  • Size [protected]
  • Squeeze() [inline]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkIdList() [protected]
  • vtkIdList(const vtkIdList &) (defined in vtkIdList) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIdList, vtkObject)
  • WritePointer(const vtkIdType i, const vtkIdType number)
  • ~vtkIdList() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIdTypeArray Member List

This is the complete list of members for vtkIdTypeArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *ia) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const vtkIdType i) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const vtkIdType i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkIdTypeArray &) (defined in vtkIdTypeArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(vtkIdType *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const vtkIdType value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkIdTypeArray(vtkIdType numComp=1) [protected]
  • vtkIdTypeArray(const vtkIdTypeArray &) (defined in vtkIdTypeArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIdTypeArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkIdTypeArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageAccumulate Member List

This is the complete list of members for vtkImageAccumulate, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentExtent [protected]
  • ComponentOrigin [protected]
  • ComponentSpacing [protected]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *input, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponentExtent(int extent[6])
  • GetComponentExtent() [inline]
  • GetComponentOrigin() [virtual]
  • GetComponentOrigin(float &, float &, float &) [virtual]
  • GetComponentOrigin(float[3]) [virtual]
  • GetComponentSpacing() [virtual]
  • GetComponentSpacing(float &, float &, float &) [virtual]
  • GetComponentSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMax() [virtual]
  • GetMax(double &, double &, double &) [virtual]
  • GetMax(double[3]) [virtual]
  • GetMean() [virtual]
  • GetMean(double &, double &, double &) [virtual]
  • GetMean(double[3]) [virtual]
  • GetMin() [virtual]
  • GetMin(double &, double &, double &) [virtual]
  • GetMin(double[3]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetReverseStencil() [virtual]
  • GetStandardDeviation() [virtual]
  • GetStandardDeviation(double &, double &, double &) [virtual]
  • GetStandardDeviation(double[3]) [virtual]
  • GetStencil()
  • GetVoxelCount() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Max [protected]
  • Mean [protected]
  • Min [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageAccumulate &) (defined in vtkImageAccumulate) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReverseStencil [protected]
  • ReverseStencilOff() [virtual]
  • ReverseStencilOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetComponentExtent(int extent[6])
  • SetComponentExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetComponentOrigin(float, float, float) [virtual]
  • SetComponentOrigin(float[3]) [virtual]
  • SetComponentSpacing(float, float, float) [virtual]
  • SetComponentSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetReverseStencil(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStencil(vtkImageStencilData *stencil)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StandardDeviation [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VoxelCount [protected]
  • vtkImageAccumulate() [protected]
  • vtkImageAccumulate(const vtkImageAccumulate &) (defined in vtkImageAccumulate) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageAccumulate, vtkImageToImageFilter)
  • ~vtkImageAccumulate() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageActor Member List

This is the complete list of members for vtkImageActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent [protected]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDisplayExtent(int extent[6])
  • GetDisplayExtent() [inline]
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInterpolate() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetSliceNumber()
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • Input [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *) [inline, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkImageActor &) (defined in vtkImageActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayExtent(int extent[6])
  • SetDisplayExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *) [virtual]
  • SetInterpolate(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • SetZSlice(int z) [inline]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkImageActor() [protected]
  • vtkImageActor(const vtkImageActor &) (defined in vtkImageActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkImageActor, vtkProp)
  • ~vtkImageActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:18:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageAnisotropicDiffusion2D Member List

This is the complete list of members for vtkImageAnisotropicDiffusion2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Corners [protected]
  • CornersOff() [virtual]
  • CornersOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DiffusionFactor [protected]
  • DiffusionThreshold [protected]
  • Edges [protected]
  • EdgesOff() [virtual]
  • EdgesOn() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • Faces [protected]
  • FacesOff() [virtual]
  • FacesOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCorners() [virtual]
  • GetDebug()
  • GetDiffusionFactor() [virtual]
  • GetDiffusionThreshold() [virtual]
  • GetEdges() [virtual]
  • GetErrorCode() [virtual]
  • GetFaces() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientMagnitudeThreshold() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientMagnitudeThreshold [protected]
  • GradientMagnitudeThresholdOff() [virtual]
  • GradientMagnitudeThresholdOn() [virtual]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iterate(vtkImageData *in, vtkImageData *out, float ar0, float ar1, int *coreExtent, int count) [protected]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageAnisotropicDiffusion2D &) (defined in vtkImageAnisotropicDiffusion2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCorners(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDiffusionFactor(float) [virtual]
  • SetDiffusionThreshold(float) [virtual]
  • SetEdges(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFaces(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientMagnitudeThreshold(int) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num)
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageAnisotropicDiffusion2D() [protected]
  • vtkImageAnisotropicDiffusion2D(const vtkImageAnisotropicDiffusion2D &) (defined in vtkImageAnisotropicDiffusion2D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageAnisotropicDiffusion2D, vtkImageSpatialFilter)
  • ~vtkImageAnisotropicDiffusion2D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageAnisotropicDiffusion3D Member List

This is the complete list of members for vtkImageAnisotropicDiffusion3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Corners [protected]
  • CornersOff() [virtual]
  • CornersOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DiffusionFactor [protected]
  • DiffusionThreshold [protected]
  • Edges [protected]
  • EdgesOff() [virtual]
  • EdgesOn() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • Faces [protected]
  • FacesOff() [virtual]
  • FacesOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCorners() [virtual]
  • GetDebug()
  • GetDiffusionFactor() [virtual]
  • GetDiffusionThreshold() [virtual]
  • GetEdges() [virtual]
  • GetErrorCode() [virtual]
  • GetFaces() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientMagnitudeThreshold() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientMagnitudeThreshold [protected]
  • GradientMagnitudeThresholdOff() [virtual]
  • GradientMagnitudeThresholdOn() [virtual]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iterate(vtkImageData *in, vtkImageData *out, float ar0, float ar1, float ar3, int *coreExtent, int count) [protected]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageAnisotropicDiffusion3D &) (defined in vtkImageAnisotropicDiffusion3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCorners(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDiffusionFactor(float) [virtual]
  • SetDiffusionThreshold(float) [virtual]
  • SetEdges(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFaces(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientMagnitudeThreshold(int) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num)
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageAnisotropicDiffusion3D() [protected]
  • vtkImageAnisotropicDiffusion3D(const vtkImageAnisotropicDiffusion3D &) (defined in vtkImageAnisotropicDiffusion3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageAnisotropicDiffusion3D, vtkImageSpatialFilter)
  • ~vtkImageAnisotropicDiffusion3D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageAppend Member List

This is the complete list of members for vtkImageAppend, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AppendAxis [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inputs, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAppendAxis() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPreserveExtents() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitOutput(int outExt[6], vtkImageData *outData) [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageAppend &) (defined in vtkImageAppend) [private]
  • Outputs [protected]
  • PreserveExtents [protected]
  • PreserveExtentsOff() [virtual]
  • PreserveExtentsOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAppendAxis(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetPreserveExtents(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • Shifts [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageAppend() [protected]
  • vtkImageAppend(const vtkImageAppend &) (defined in vtkImageAppend) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageAppend, vtkImageMultipleInputFilter)
  • ~vtkImageAppend() [protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageAppendComponents Member List

This is the complete list of members for vtkImageAppendComponents, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inputs, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageAppendComponents &) (defined in vtkImageAppendComponents) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [inline, virtual]
  • SetInput2(vtkImageData *input) [inline, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageAppendComponents() [inline, protected]
  • vtkImageAppendComponents(const vtkImageAppendComponents &) (defined in vtkImageAppendComponents) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageAppendComponents, vtkImageMultipleInputFilter)
  • ~vtkImageAppendComponents() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageBlend Member List

This is the complete list of members for vtkImageBlend, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BlendMode [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CompoundThreshold [protected]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataWasPassed [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCompoundThreshold() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOpacity(int idx)
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStencil() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • Opacity [protected]
  • OpacityArrayLength [protected]
  • operator=(const vtkImageBlend &) (defined in vtkImageBlend) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToCompound() [inline]
  • SetBlendModeToNormal() [inline]
  • SetBypass(int) [virtual]
  • SetCompoundThreshold(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOpacity(int idx, double opacity)
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStencil(vtkImageStencilData *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Stencil [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageBlend() [protected]
  • vtkImageBlend(const vtkImageBlend &) (defined in vtkImageBlend) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageBlend, vtkImageMultipleInputFilter)
  • ~vtkImageBlend() [protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageBlockReader Member List

This is the complete list of members for vtkImageBlockReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBlockExtents() [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteBlockExtents() [protected]
  • Divisions [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • vtkImageSource::Execute() [virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePattern [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int &, int &, int &) [virtual]
  • GetDivisions(int[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetFilePattern() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOverlap() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarType() [virtual]
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • ModifyOutputUpdateExtent() [protected]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • operator=(const vtkImageBlockReader &) (defined in vtkImageBlockReader) [private]
  • Outputs [protected]
  • Overlap [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(vtkImageData *data, int *ext) [protected]
  • ReadBlock(int xIdx, int yIdx, int zIdx, vtkImageData *data, int *ext) [protected]
  • ReadRemainder(vtkImageData *data, int *ext, int *doneExt) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarType [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int, int) [virtual]
  • SetDivisions(int[3]) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePattern(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOverlap(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarType(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageBlockReader() [protected]
  • vtkImageBlockReader(const vtkImageBlockReader &) (defined in vtkImageBlockReader) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageBlockReader, vtkImageSource)
  • WholeExtent [protected]
  • XExtents [protected]
  • YExtents [protected]
  • ZExtents [protected]
  • ~vtkImageBlockReader() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageBlockWriter Member List

This is the complete list of members for vtkImageBlockWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Divisions [protected]
  • EndTag [protected]
  • FilePattern [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int &, int &, int &) [virtual]
  • GetDivisions(int[3]) [virtual]
  • GetFilePattern() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOverlap() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageBlockWriter &) (defined in vtkImageBlockWriter) [private]
  • Overlap [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int, int) [virtual]
  • SetDivisions(int[3]) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFilePattern(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetOverlap(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageBlockWriter() [protected]
  • vtkImageBlockWriter(const vtkImageBlockWriter &) (defined in vtkImageBlockWriter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkImageBlockWriter, vtkProcessObject)
  • Write()
  • ~vtkImageBlockWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:18:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageButterworthHighPass Member List

This is the complete list of members for vtkImageButterworthHighPass, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CutOff [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCutOff() [virtual]
  • GetCutOff(float &, float &, float &) [virtual]
  • GetCutOff(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrder() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXCutOff() [inline]
  • GetYCutOff() [inline]
  • GetZCutOff() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageButterworthHighPass &) (defined in vtkImageButterworthHighPass) [private]
  • Order [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCutOff(float, float, float) [virtual]
  • SetCutOff(float[3]) [virtual]
  • SetCutOff(float v) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrder(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXCutOff(float v)
  • SetYCutOff(float v)
  • SetZCutOff(float v)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageButterworthHighPass() [protected]
  • vtkImageButterworthHighPass(const vtkImageButterworthHighPass &) (defined in vtkImageButterworthHighPass) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageButterworthHighPass, vtkImageToImageFilter)
  • ~vtkImageButterworthHighPass() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageButterworthLowPass Member List

This is the complete list of members for vtkImageButterworthLowPass, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CutOff [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCutOff() [virtual]
  • GetCutOff(float &, float &, float &) [virtual]
  • GetCutOff(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrder() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXCutOff() [inline]
  • GetYCutOff() [inline]
  • GetZCutOff() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageButterworthLowPass &) (defined in vtkImageButterworthLowPass) [private]
  • Order [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCutOff(float, float, float) [virtual]
  • SetCutOff(float[3]) [virtual]
  • SetCutOff(float v) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrder(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXCutOff(float v)
  • SetYCutOff(float v)
  • SetZCutOff(float v)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageButterworthLowPass() [protected]
  • vtkImageButterworthLowPass(const vtkImageButterworthLowPass &) (defined in vtkImageButterworthLowPass) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageButterworthLowPass, vtkImageToImageFilter)
  • ~vtkImageButterworthLowPass() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCacheFilter Member List

This is the complete list of members for vtkImageCacheFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CacheSize [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetCacheSize() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCacheFilter &) (defined in vtkImageCacheFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCacheSize(int size)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • Times [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *outData) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCacheFilter() [protected]
  • vtkImageCacheFilter(const vtkImageCacheFilter &) (defined in vtkImageCacheFilter) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCacheFilter, vtkImageToImageFilter)
  • ~vtkImageCacheFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCanvasSource2D Member List

This is the complete list of members for vtkImageCanvasSource2D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateScalars()
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • ClipSegment(int &a0, int &a1, int &b0, int &b1) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeCellId(int ijk[3]) [inline]
  • ComputeIncrements() [protected]
  • ComputePointId(int ijk[3]) [inline]
  • ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3])
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyAndCastFrom(vtkImageData *inData, int extent[6])
  • CopyAndCastFrom(vtkImageData *inData, int x0, int x1, int y0, int y1, int z0, int z1) [inline]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *image) [virtual]
  • Crop() [virtual]
  • DATA_OBJECT_FIELD enum value
  • DataDescription [protected]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • DefaultZ [protected]
  • Delete() [virtual]
  • Dimensions [protected]
  • DrawCircle(int c0, int c1, float radius)
  • DrawColor [protected]
  • DrawPoint(int p0, int p1)
  • DrawSegment(int x0, int y0, int x1, int y1)
  • DrawSegment3D(float *p0, float *p1)
  • DrawSegment3D(float x1, float y1, float z1, float x2, float y2, float z2) [inline]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FillBox(int min0, int max0, int min1, int max1)
  • FillPixel(int x, int y)
  • FillTriangle(int x0, int y0, int x1, int y1, int x2, int y2)
  • FillTube(int x0, int y0, int x1, int y1, float radius)
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • FindPoint(float x[3]) [virtual]
  • GetActualMemorySize() [virtual]
  • GetArrayIncrements(vtkDataArray *array, int increments[3])
  • GetArrayPointer(vtkDataArray *array, int coordinates[3])
  • GetArrayPointerForExtent(vtkDataArray *array, int extent[6])
  • GetAxisUpdateExtent(int axis, int &min, int &max)
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [inline, virtual]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetContinuousIncrements(int extent[6], int &incX, int &incY, int &incZ)
  • GetDataDimension() [inline]
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetDefaultZ() [virtual]
  • GetDimensions()
  • GetDimensions(int dims[3])
  • GetDrawColor() [virtual]
  • GetDrawColor(float &, float &, float &, float &) [virtual]
  • GetDrawColor(float[4]) [virtual]
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImageData() [virtual]
  • GetIncrements()
  • GetIncrements(int &incX, int &incY, int &incZ)
  • GetIncrements(int inc[3])
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize() [inline, virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfCells() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float &, float &, float &) [virtual]
  • GetOrigin(float[3]) [virtual]
  • GetOutput() [inline]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [virtual]
  • GetPoint(vtkIdType id, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [inline, virtual]
  • GetPointData() [inline]
  • GetPointGradient(int i, int j, int k, vtkDataArray *s, float g[3])
  • GetRatio() [virtual]
  • GetRatio(float &, float &, float &) [virtual]
  • GetRatio(float[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarComponentAsFloat(int x, int y, int z, int component)
  • GetScalarPointer(int coordinates[3])
  • GetScalarPointer(int x, int y, int z)
  • GetScalarPointer()
  • GetScalarPointerForExtent(int extent[6])
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetScalarSize()
  • GetScalarType()
  • GetScalarTypeAsString() [inline]
  • GetScalarTypeMax()
  • GetScalarTypeMin()
  • GetSource() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float &, float &, float &) [virtual]
  • GetSpacing(float[3]) [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetVoxelGradient(int i, int j, int k, vtkDataArray *s, vtkDataArray *g)
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageData [protected]
  • Increments [protected]
  • Initialize() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • NumberOfScalarComponents [protected]
  • operator=(const vtkImageCanvasSource2D &) (defined in vtkImageCanvasSource2D) [private]
  • Origin [protected]
  • Piece [protected]
  • PipelineMTime [protected]
  • Pixel [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • PrepareForNewData() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • Ratio [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • ScalarType [protected]
  • SetAxisUpdateExtent(int axis, int min, int max)
  • SetDebug(unsigned char debugFlag)
  • SetDefaultZ(int) [virtual]
  • SetDimensions(int i, int j, int k)
  • SetDimensions(int dims[3])
  • SetDrawColor(float, float, float, float) [virtual]
  • SetDrawColor(float[4]) [virtual]
  • SetDrawColor(float a) [inline]
  • SetDrawColor(float a, float b) [inline]
  • SetDrawColor(float a, float b, float c) [inline]
  • SetExtent(int *extent)
  • SetExtent(int x1, int x2, int y1, int y2, int z1, int z2)
  • vtkStructuredPoints::SetExtent(int extent[6])
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageData(vtkImageData *image)
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetNumberOfScalarComponents(int n)
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetRatio(float, float, float) [virtual]
  • SetRatio(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetScalarType(int) [virtual]
  • SetScalarTypeToChar() [inline]
  • SetScalarTypeToDouble() [inline]
  • SetScalarTypeToFloat() [inline]
  • SetScalarTypeToInt() [inline]
  • SetScalarTypeToLong() [inline]
  • SetScalarTypeToShort() [inline]
  • SetScalarTypeToUnsignedChar() [inline]
  • SetScalarTypeToUnsignedInt() [inline]
  • SetScalarTypeToUnsignedLong() [inline]
  • SetScalarTypeToUnsignedShort() [inline]
  • SetSource(vtkSource *s)
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkDataSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Spacing [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Voxel [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkImageCanvasSource2D() [protected]
  • vtkImageCanvasSource2D(const vtkImageCanvasSource2D &) (defined in vtkImageCanvasSource2D) [private]
  • vtkImageData() [protected]
  • vtkObject() [protected]
  • vtkStructuredPoints() [protected]
  • vtkTypeRevisionMacro(vtkImageCanvasSource2D, vtkStructuredPoints)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkImageCanvasSource2D() [protected]
  • ~vtkImageData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkStructuredPoints() [inline, protected]
Generated on Mon Mar 25 01:18:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCanvasSource2DPixel Member List

This is the complete list of members for vtkImageCanvasSource2DPixel, including all inherited members.
  • New() [inline, static]
  • Next
  • Pointer
  • X
  • Y
Generated on Mon Mar 25 01:18:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCast Member List

This is the complete list of members for vtkImageCast, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • ClampOverflow [protected]
  • ClampOverflowOff() [virtual]
  • ClampOverflowOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClampOverflow() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputScalarType() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCast &) (defined in vtkImageCast) [private]
  • Outputs [protected]
  • OutputScalarType [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetClampOverflow(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputScalarType(int) [virtual]
  • SetOutputScalarTypeToChar() [inline]
  • SetOutputScalarTypeToDouble() [inline]
  • SetOutputScalarTypeToFloat() [inline]
  • SetOutputScalarTypeToInt() [inline]
  • SetOutputScalarTypeToLong() [inline]
  • SetOutputScalarTypeToShort() [inline]
  • SetOutputScalarTypeToUnsignedChar() [inline]
  • SetOutputScalarTypeToUnsignedInt() [inline]
  • SetOutputScalarTypeToUnsignedLong() [inline]
  • SetOutputScalarTypeToUnsignedShort() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *data) [protected, virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCast() [protected]
  • vtkImageCast(const vtkImageCast &) (defined in vtkImageCast) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCast, vtkImageToImageFilter)
  • ~vtkImageCast() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageChangeInformation Member List

This is the complete list of members for vtkImageChangeInformation, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CenterImage [protected]
  • CenterImageOff() [virtual]
  • CenterImageOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • ExtentTranslation [protected]
  • FinalExtentTranslation [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetCenterImage() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtentTranslation() [virtual]
  • GetExtentTranslation(int &, int &, int &) [virtual]
  • GetExtentTranslation(int[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInformationInput() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOriginScale() [virtual]
  • GetOriginScale(float &, float &, float &) [virtual]
  • GetOriginScale(float[3]) [virtual]
  • GetOriginTranslation() [virtual]
  • GetOriginTranslation(float &, float &, float &) [virtual]
  • GetOriginTranslation(float[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputExtentStart() [virtual]
  • GetOutputExtentStart(int &, int &, int &) [virtual]
  • GetOutputExtentStart(int[3]) [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputOrigin() [virtual]
  • GetOutputOrigin(float &, float &, float &) [virtual]
  • GetOutputOrigin(float[3]) [virtual]
  • GetOutputs()
  • GetOutputSpacing() [virtual]
  • GetOutputSpacing(float &, float &, float &) [virtual]
  • GetOutputSpacing(float[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSpacingScale() [virtual]
  • GetSpacingScale(float &, float &, float &) [virtual]
  • GetSpacingScale(float[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationInput [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageChangeInformation &) (defined in vtkImageChangeInformation) [inline, private]
  • OriginScale [protected]
  • OriginTranslation [protected]
  • OutputExtentStart [protected]
  • OutputOrigin [protected]
  • Outputs [protected]
  • OutputSpacing [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCenterImage(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtentTranslation(int, int, int) [virtual]
  • SetExtentTranslation(int[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInformationInput(vtkImageData *) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOriginScale(float, float, float) [virtual]
  • SetOriginScale(float[3]) [virtual]
  • SetOriginTranslation(float, float, float) [virtual]
  • SetOriginTranslation(float[3]) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputExtentStart(int, int, int) [virtual]
  • SetOutputExtentStart(int[3]) [virtual]
  • SetOutputOrigin(float, float, float) [virtual]
  • SetOutputOrigin(float[3]) [virtual]
  • SetOutputSpacing(float, float, float) [virtual]
  • SetOutputSpacing(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSpacingScale(float, float, float) [virtual]
  • SetSpacingScale(float[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpacingScale [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageChangeInformation() [protected]
  • vtkImageChangeInformation(const vtkImageChangeInformation &) (defined in vtkImageChangeInformation) [inline, private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageChangeInformation, vtkImageToImageFilter)
  • ~vtkImageChangeInformation() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCheckerboard Member List

This is the complete list of members for vtkImageCheckerboard, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfDivisions() [virtual]
  • GetNumberOfDivisions(int data[3]) [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfDivisions [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCheckerboard &) (defined in vtkImageCheckerboard) [inline, private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfDivisions(int, int, int) [virtual]
  • SetNumberOfDivisions(int[3]) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCheckerboard() [protected]
  • vtkImageCheckerboard(const vtkImageCheckerboard &) (defined in vtkImageCheckerboard) [inline, private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCheckerboard, vtkImageTwoInputFilter)
  • ~vtkImageCheckerboard() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCityBlockDistance Member List

This is the complete list of members for vtkImageCityBlockDistance, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCityBlockDistance &) (defined in vtkImageCityBlockDistance) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCityBlockDistance() [protected]
  • vtkImageCityBlockDistance(const vtkImageCityBlockDistance &) (defined in vtkImageCityBlockDistance) [private]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCityBlockDistance, vtkImageDecomposeFilter)
  • ~vtkImageCityBlockDistance() [inline, protected]
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageClip Member List

This is the complete list of members for vtkImageClip, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • ClipData [protected]
  • ClipDataOff() [virtual]
  • ClipDataOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CopyData(vtkImageData *inData, vtkImageData *outData, int *ext) [protected]
  • CTime [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipData() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputWholeExtent(int extent[6])
  • GetOutputWholeExtent() [inline]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Initialized [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageClip &) (defined in vtkImageClip) [private]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ResetOutputWholeExtent()
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetClipData(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputWholeExtent(int extent[6])
  • SetOutputWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetOutputWholeExtent(int piece, int numPieces)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SplitExtentTmp(int piece, int numPieces, int *ext) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageClip() [protected]
  • vtkImageClip(const vtkImageClip &) (defined in vtkImageClip) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageClip, vtkImageToImageFilter)
  • ~vtkImageClip() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageConnector Member List

This is the complete list of members for vtkImageConnector, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddSeed(vtkImageConnectorSeed *seed)
  • AddSeedToEnd(vtkImageConnectorSeed *seed)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConnectedValue [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConnectedValue() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetUnconnectedValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastSeed [protected]
  • MarkData(vtkImageData *data, int dimensionality, int ext[6])
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NewSeed(int index[3], void *ptr)
  • operator=(const vtkImageConnector &) (defined in vtkImageConnector) [private]
  • PopSeed() [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllSeeds()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Seeds [protected]
  • SetConnectedValue(unsigned char) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetUnconnectedValue(unsigned char) [virtual]
  • SubjectHelper [protected]
  • UnconnectedValue [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageConnector() [protected]
  • vtkImageConnector(const vtkImageConnector &) (defined in vtkImageConnector) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageConnector, vtkObject)
  • ~vtkImageConnector() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageConnectorSeed Member List

This is the complete list of members for vtkImageConnectorSeed, including all inherited members.
  • Index
  • New() [inline, static]
  • Next
  • Pointer
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageConstantPad Member List

This is the complete list of members for vtkImageConstantPad, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Constant [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConstant() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputNumberOfScalarComponents() [virtual]
  • GetOutputs()
  • GetOutputWholeExtent(int extent[6])
  • GetOutputWholeExtent() [inline]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageConstantPad &) (defined in vtkImageConstantPad) [private]
  • OutputNumberOfScalarComponents [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetConstant(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputNumberOfScalarComponents(int) [virtual]
  • SetOutputWholeExtent(int extent[6])
  • SetOutputWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageConstantPad() [protected]
  • vtkImageConstantPad(const vtkImageConstantPad &) (defined in vtkImageConstantPad) [private]
  • vtkImagePadFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageConstantPad, vtkImagePadFilter)
  • ~vtkImageConstantPad() [inline, protected]
  • ~vtkImagePadFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageContinuousDilate3D Member List

This is the complete list of members for vtkImageContinuousDilate3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Ellipse [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageContinuousDilate3D &) (defined in vtkImageContinuousDilate3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageContinuousDilate3D() [protected]
  • vtkImageContinuousDilate3D(const vtkImageContinuousDilate3D &) (defined in vtkImageContinuousDilate3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageContinuousDilate3D, vtkImageSpatialFilter)
  • ~vtkImageContinuousDilate3D() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageContinuousErode3D Member List

This is the complete list of members for vtkImageContinuousErode3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Ellipse [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageContinuousErode3D &) (defined in vtkImageContinuousErode3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageContinuousErode3D() [protected]
  • vtkImageContinuousErode3D(const vtkImageContinuousErode3D &) (defined in vtkImageContinuousErode3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageContinuousErode3D, vtkImageSpatialFilter)
  • ~vtkImageContinuousErode3D() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageConvolve Member List

This is the complete list of members for vtkImageConvolve, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernel(float *kernel) [protected]
  • GetKernel() [protected]
  • GetKernel3x3()
  • GetKernel3x3(float kernel[9])
  • GetKernel3x3x3()
  • GetKernel3x3x3(float kernel[27])
  • GetKernel5x5()
  • GetKernel5x5(float kernel[25])
  • GetKernel5x5x5()
  • GetKernel5x5x5(float kernel[125])
  • GetKernel7x7()
  • GetKernel7x7(float kernel[49])
  • GetKernel7x7x7()
  • GetKernel7x7x7(float kernel[343])
  • GetKernelSize() [virtual]
  • GetKernelSize(int &, int &, int &) [virtual]
  • GetKernelSize(int[3]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Kernel [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageConvolve &) (defined in vtkImageConvolve) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernel(const float *kernel, int sizeX, int sizeY, int sizeZ) [protected]
  • SetKernel3x3(const float kernel[9])
  • SetKernel3x3x3(const float kernel[27])
  • SetKernel5x5(const float kernel[25])
  • SetKernel5x5x5(float kernel[125])
  • SetKernel7x7(float kernel[49])
  • SetKernel7x7x7(float kernel[343])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageConvolve() [protected]
  • vtkImageConvolve(const vtkImageConvolve &) (defined in vtkImageConvolve) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageConvolve, vtkImageToImageFilter)
  • ~vtkImageConvolve() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCorrelation Member List

This is the complete list of members for vtkImageCorrelation, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCorrelation &) (defined in vtkImageCorrelation) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCorrelation() [protected]
  • vtkImageCorrelation(const vtkImageCorrelation &) (defined in vtkImageCorrelation) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCorrelation, vtkImageTwoInputFilter)
  • ~vtkImageCorrelation() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageCursor3D Member List

This is the complete list of members for vtkImageCursor3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CopyData(vtkImageData *in, vtkImageData *out) [protected]
  • CursorPosition [protected]
  • CursorRadius [protected]
  • CursorValue [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *outData) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCursorPosition() [virtual]
  • GetCursorPosition(float &, float &, float &) [virtual]
  • GetCursorPosition(float[3]) [virtual]
  • GetCursorRadius() [virtual]
  • GetCursorValue() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageCursor3D &) (defined in vtkImageCursor3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCursorPosition(float, float, float) [virtual]
  • SetCursorPosition(float[3]) [virtual]
  • SetCursorRadius(int) [virtual]
  • SetCursorValue(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageCursor3D() [protected]
  • vtkImageCursor3D(const vtkImageCursor3D &) (defined in vtkImageCursor3D) [private]
  • vtkImageInPlaceFilter() [inline, protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageCursor3D, vtkImageInPlaceFilter)
  • ~vtkImageCursor3D() [inline, protected]
  • ~vtkImageInPlaceFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageData Member List

This is the complete list of members for vtkImageData, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateScalars()
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeCellId(int ijk[3]) [inline]
  • ComputeIncrements() [protected]
  • ComputePointId(int ijk[3]) [inline]
  • ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3])
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyAndCastFrom(vtkImageData *inData, int extent[6])
  • CopyAndCastFrom(vtkImageData *inData, int x0, int x1, int y0, int y1, int z0, int z1) [inline]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *image) [virtual]
  • Crop() [virtual]
  • DATA_OBJECT_FIELD enum value
  • DataDescription [protected]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Dimensions [protected]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • FindPoint(float x[3]) [virtual]
  • GetActualMemorySize() [virtual]
  • GetArrayIncrements(vtkDataArray *array, int increments[3])
  • GetArrayPointer(vtkDataArray *array, int coordinates[3])
  • GetArrayPointerForExtent(vtkDataArray *array, int extent[6])
  • GetAxisUpdateExtent(int axis, int &min, int &max)
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [inline, virtual]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetContinuousIncrements(int extent[6], int &incX, int &incY, int &incZ)
  • GetDataDimension() [inline]
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetDimensions()
  • GetDimensions(int dims[3])
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetIncrements()
  • GetIncrements(int &incX, int &incY, int &incZ)
  • GetIncrements(int inc[3])
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize() [inline, virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfCells() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float &, float &, float &) [virtual]
  • GetOrigin(float[3]) [virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [virtual]
  • GetPoint(vtkIdType id, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [inline, virtual]
  • GetPointData() [inline]
  • GetPointGradient(int i, int j, int k, vtkDataArray *s, float g[3])
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarComponentAsFloat(int x, int y, int z, int component)
  • GetScalarPointer(int coordinates[3])
  • GetScalarPointer(int x, int y, int z)
  • GetScalarPointer()
  • GetScalarPointerForExtent(int extent[6])
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetScalarSize()
  • GetScalarType()
  • GetScalarTypeAsString() [inline]
  • GetScalarTypeMax()
  • GetScalarTypeMin()
  • GetSource() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float &, float &, float &) [virtual]
  • GetSpacing(float[3]) [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetVoxelGradient(int i, int j, int k, vtkDataArray *s, vtkDataArray *g)
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Increments [protected]
  • Initialize() [virtual]
  • InternalImageDataCopy(vtkImageData *src) (defined in vtkImageData) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • NumberOfScalarComponents [protected]
  • operator=(const vtkImageData &) (defined in vtkImageData) [private]
  • Origin [protected]
  • Piece [protected]
  • PipelineMTime [protected]
  • Pixel [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • PrepareForNewData() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • ScalarType [protected]
  • SetAxisUpdateExtent(int axis, int min, int max)
  • SetDebug(unsigned char debugFlag)
  • SetDimensions(int i, int j, int k)
  • SetDimensions(int dims[3])
  • SetExtent(int extent[6])
  • SetExtent(int x1, int x2, int y1, int y2, int z1, int z2)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetNumberOfScalarComponents(int n)
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetScalarType(int) [virtual]
  • SetScalarTypeToChar() [inline]
  • SetScalarTypeToDouble() [inline]
  • SetScalarTypeToFloat() [inline]
  • SetScalarTypeToInt() [inline]
  • SetScalarTypeToLong() [inline]
  • SetScalarTypeToShort() [inline]
  • SetScalarTypeToUnsignedChar() [inline]
  • SetScalarTypeToUnsignedInt() [inline]
  • SetScalarTypeToUnsignedLong() [inline]
  • SetScalarTypeToUnsignedShort() [inline]
  • SetSource(vtkSource *s)
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkDataSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Spacing [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Voxel [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkImageData() [protected]
  • vtkImageData(const vtkImageData &) (defined in vtkImageData) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageData, vtkDataSet)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkImageData() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:18:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDataGeometryFilter Member List

This is the complete list of members for vtkImageDataGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Extent [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageDataGeometryFilter &) (defined in vtkImageDataGeometryFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(int extent[6])
  • SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDataGeometryFilter() [protected]
  • vtkImageDataGeometryFilter(const vtkImageDataGeometryFilter &) (defined in vtkImageDataGeometryFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkImageDataGeometryFilter, vtkStructuredPointsToPolyDataFilter)
  • ~vtkImageDataGeometryFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:18:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDataStreamer Member List

This is the complete list of members for vtkImageDataStreamer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExtentTranslator [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtentTranslator() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamDivisions() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamDivisions [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDataStreamer &) (defined in vtkImageDataStreamer) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtentTranslator(vtkExtentTranslator *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfStreamDivisions(int) [virtual]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *out) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDataStreamer() [protected]
  • vtkImageDataStreamer(const vtkImageDataStreamer &) (defined in vtkImageDataStreamer) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDataStreamer, vtkImageToImageFilter)
  • ~vtkImageDataStreamer() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDecomposeFilter Member List

This is the complete list of members for vtkImageDecomposeFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int[6], int[6]) [inline, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out)=0 [protected, pure virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDecomposeFilter &) (defined in vtkImageDecomposeFilter) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageDecomposeFilter(const vtkImageDecomposeFilter &) (defined in vtkImageDecomposeFilter) [private]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDecomposeFilter, vtkImageIterateFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDifference Member List

This is the complete list of members for vtkImageDifference, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllowShift [protected]
  • AllowShiftOff() [virtual]
  • AllowShiftOn() [virtual]
  • Averaging [protected]
  • AveragingOff() [virtual]
  • AveragingOn() [virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • ErrorPerThread [protected]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inputs, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAllowShift() [virtual]
  • GetAveraging() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetError(void)
  • GetError(float *e) [inline]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImage() [inline]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetThreshold() [virtual]
  • GetThresholdedError(void)
  • GetThresholdedError(float *e) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDifference &) (defined in vtkImageDifference) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAllowShift(int) [virtual]
  • SetAveraging(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImage(vtkImageData *image) [inline]
  • SetInput(vtkImageData *input) [inline]
  • SetInput(int num, vtkImageData *input) [inline, virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThreshold(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • Threshold [protected]
  • ThresholdedErrorPerThread [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDifference() [protected]
  • vtkImageDifference(const vtkImageDifference &) (defined in vtkImageDifference) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDifference, vtkImageTwoInputFilter)
  • ~vtkImageDifference() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDilateErode3D Member List

This is the complete list of members for vtkImageDilateErode3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DilateValue [protected]
  • Ellipse [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • ErodeValue [protected]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDilateValue() [virtual]
  • GetErodeValue() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDilateErode3D &) (defined in vtkImageDilateErode3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDilateValue(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErodeValue(float) [virtual]
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDilateErode3D() [protected]
  • vtkImageDilateErode3D(const vtkImageDilateErode3D &) (defined in vtkImageDilateErode3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDilateErode3D, vtkImageSpatialFilter)
  • ~vtkImageDilateErode3D() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDivergence Member List

This is the complete list of members for vtkImageDivergence, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDivergence &) (defined in vtkImageDivergence) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDivergence() [inline, protected]
  • vtkImageDivergence(const vtkImageDivergence &) (defined in vtkImageDivergence) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDivergence, vtkImageToImageFilter)
  • ~vtkImageDivergence() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageDotProduct Member List

This is the complete list of members for vtkImageDotProduct, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageDotProduct &) (defined in vtkImageDotProduct) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDotProduct() [inline, protected]
  • vtkImageDotProduct(const vtkImageDotProduct &) (defined in vtkImageDotProduct) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageDotProduct, vtkImageTwoInputFilter)
  • ~vtkImageDotProduct() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageEllipsoidSource Member List

This is the complete list of members for vtkImageEllipsoidSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *outData) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float &, float &, float &) [virtual]
  • GetCenter(float[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetInValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputScalarType() [virtual]
  • GetOutValue() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetRadius(float &, float &, float &) [virtual]
  • GetRadius(float[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetWholeExtent(int extent[6])
  • GetWholeExtent() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InValue [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageEllipsoidSource &) (defined in vtkImageEllipsoidSource) [private]
  • Outputs [protected]
  • OutputScalarType [protected]
  • OutValue [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInValue(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetOutputScalarType(int) [virtual]
  • SetOutputScalarTypeToChar() [inline]
  • SetOutputScalarTypeToDouble() [inline]
  • SetOutputScalarTypeToFloat() [inline]
  • SetOutputScalarTypeToInt() [inline]
  • SetOutputScalarTypeToLong() [inline]
  • SetOutputScalarTypeToShort() [inline]
  • SetOutputScalarTypeToUnsignedChar() [inline]
  • SetOutputScalarTypeToUnsignedInt() [inline]
  • SetOutputScalarTypeToUnsignedLong() [inline]
  • SetOutputScalarTypeToUnsignedShort() [inline]
  • SetOutValue(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float, float, float) [virtual]
  • SetRadius(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int extent[6])
  • SetWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageEllipsoidSource() [protected]
  • vtkImageEllipsoidSource(const vtkImageEllipsoidSource &) (defined in vtkImageEllipsoidSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageEllipsoidSource, vtkImageSource)
  • WholeExtent [protected]
  • ~vtkImageEllipsoidSource() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageEuclideanDistance Member List

This is the complete list of members for vtkImageEuclideanDistance, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Algorithm [protected]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ConsiderAnisotropy [protected]
  • ConsiderAnisotropyOff() [virtual]
  • ConsiderAnisotropyOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *input, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAlgorithm() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsiderAnisotropy() [virtual]
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialize() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMaximumDistance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Initialize [protected]
  • InitializeOff() [virtual]
  • InitializeOn() [virtual]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out) [virtual]
  • LegacyHack
  • MaximumDistance [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageEuclideanDistance &) (defined in vtkImageEuclideanDistance) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAlgorithm(int) [virtual]
  • SetAlgorithmToSaito() [inline]
  • SetAlgorithmToSaitoCached() [inline]
  • SetBypass(int) [inline]
  • SetConsiderAnisotropy(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInitialize(int) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMaximumDistance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageEuclideanDistance() [protected]
  • vtkImageEuclideanDistance(const vtkImageEuclideanDistance &) (defined in vtkImageEuclideanDistance) [private]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageEuclideanDistance, vtkImageDecomposeFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageEuclideanDistance() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageEuclideanToPolar Member List

This is the complete list of members for vtkImageEuclideanToPolar, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetThetaMaximum() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageEuclideanToPolar &) (defined in vtkImageEuclideanToPolar) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThetaMaximum(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThetaMaximum [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageEuclideanToPolar() [protected]
  • vtkImageEuclideanToPolar(const vtkImageEuclideanToPolar &) (defined in vtkImageEuclideanToPolar) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageEuclideanToPolar, vtkImageToImageFilter)
  • ~vtkImageEuclideanToPolar() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageExport Member List

This is the complete list of members for vtkImageExport, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • BufferPointerCallback() [protected, virtual]
  • BufferPointerCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • BufferPointerCallbackType typedef
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataDimensions [protected]
  • DataExtentCallback() [protected, virtual]
  • DataExtentCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • DataExtentCallbackType typedef
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • Export() [inline]
  • Export(void *) [virtual]
  • ExportVoidPointer [protected]
  • GetAbortExecute() [virtual]
  • GetBufferPointerCallback() const
  • GetCallbackUserData()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataDimensions(int *ptr)
  • GetDataDimensions() [inline]
  • GetDataExtent() [inline]
  • GetDataExtent(int *ptr) [inline]
  • GetDataExtentCallback() const
  • GetDataMemorySize()
  • GetDataNumberOfScalarComponents() [inline]
  • GetDataOrigin() [inline]
  • GetDataOrigin(float *ptr) [inline]
  • GetDataScalarType() [inline]
  • GetDataScalarTypeAsString() [inline]
  • GetDataSpacing() [inline]
  • GetDataSpacing(float *ptr) [inline]
  • GetDebug()
  • GetExportVoidPointer() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetImageLowerLeft() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfComponentsCallback() const
  • GetNumberOfInputs() [virtual]
  • GetOriginCallback() const
  • GetPipelineModifiedCallback() const
  • GetPointerToData()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetPropagateUpdateExtentCallback() const
  • GetReferenceCount() [inline]
  • GetScalarTypeCallback() const
  • GetSpacingCallback() const
  • GetUpdateDataCallback() const
  • GetUpdateInformationCallback() const
  • GetWholeExtentCallback() const
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageLowerLeft [protected]
  • ImageLowerLeftOff() [virtual]
  • ImageLowerLeftOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPipelineMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComponentsCallback() [protected, virtual]
  • NumberOfComponentsCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • NumberOfComponentsCallbackType typedef
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageExport &) (defined in vtkImageExport) [private]
  • OriginCallback() [protected, virtual]
  • OriginCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • OriginCallbackType typedef
  • PipelineModifiedCallback() [protected, virtual]
  • PipelineModifiedCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • PipelineModifiedCallbackType typedef
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtentCallback(int *) [protected, virtual]
  • PropagateUpdateExtentCallbackFunction(void *, int *) (defined in vtkImageExport) [private, static]
  • PropagateUpdateExtentCallbackType typedef
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTypeCallback() [protected, virtual]
  • ScalarTypeCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • ScalarTypeCallbackType typedef
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetExportVoidPointer(void *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageLowerLeft(int) [virtual]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpacingCallback() [protected, virtual]
  • SpacingCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • SpacingCallbackType typedef
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateDataCallback() [protected, virtual]
  • UpdateDataCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • UpdateDataCallbackType typedef
  • UpdateInformationCallback() [protected, virtual]
  • UpdateInformationCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • UpdateInformationCallbackType typedef
  • UpdateProgress(float amount)
  • vtkImageExport() [protected]
  • vtkImageExport(const vtkImageExport &) (defined in vtkImageExport) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkImageExport, vtkProcessObject)
  • WholeExtentCallback() [protected, virtual]
  • WholeExtentCallbackFunction(void *) (defined in vtkImageExport) [private, static]
  • WholeExtentCallbackType typedef
  • ~vtkImageExport() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:18:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageExtractComponents Member List

This is the complete list of members for vtkImageExtractComponents, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Components [protected]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponents() [virtual]
  • GetComponents(int &, int &, int &) [virtual]
  • GetComponents(int[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfComponents() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageExtractComponents &) (defined in vtkImageExtractComponents) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetComponents(int c1)
  • SetComponents(int c1, int c2)
  • SetComponents(int c1, int c2, int c3)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageExtractComponents() [protected]
  • vtkImageExtractComponents(const vtkImageExtractComponents &) (defined in vtkImageExtractComponents) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageExtractComponents, vtkImageToImageFilter)
  • ~vtkImageExtractComponents() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageFFT Member List

This is the complete list of members for vtkImageFFT, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteFft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • ExecuteFftForwardBackward(vtkImageComplex *in, vtkImageComplex *out, int N, int fb) [protected]
  • ExecuteFftStep2(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int fb) [protected]
  • ExecuteFftStepN(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int n, int fb) [protected]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • ExecuteRfft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out) [inline, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageFFT &) (defined in vtkImageFFT) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageFFT() [inline, protected]
  • vtkImageFFT(const vtkImageFFT &) (defined in vtkImageFFT) [private]
  • vtkImageFourierFilter() [inline, protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageFFT, vtkImageFourierFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageFFT() [inline, protected]
  • ~vtkImageFourierFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageFlip Member List

This is the complete list of members for vtkImageFlip, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • FilteredAxis [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilteredAxis() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPreserveImageExtent() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageFlip &) (defined in vtkImageFlip) [private]
  • Outputs [protected]
  • PreserveImageExtent [protected]
  • PreserveImageExtentOff() [virtual]
  • PreserveImageExtentOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis) [inline]
  • SetFilteredAxis(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetPreserveImageExtent(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageFlip() [protected]
  • vtkImageFlip(const vtkImageFlip &) (defined in vtkImageFlip) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageFlip, vtkImageToImageFilter)
  • ~vtkImageFlip() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageFourierCenter Member List

This is the complete list of members for vtkImageFourierCenter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out) [inline, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageFourierCenter &) (defined in vtkImageFourierCenter) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageFourierCenter() [protected]
  • vtkImageFourierCenter(const vtkImageFourierCenter &) (defined in vtkImageFourierCenter) [private]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageFourierCenter, vtkImageDecomposeFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageFourierCenter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageFourierFilter Member List

This is the complete list of members for vtkImageFourierFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int[6], int[6]) [inline, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteFft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • ExecuteFftForwardBackward(vtkImageComplex *in, vtkImageComplex *out, int N, int fb) [protected]
  • ExecuteFftStep2(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int fb) [protected]
  • ExecuteFftStepN(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int n, int fb) [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteRfft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out)=0 [protected, pure virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageFourierFilter &) (defined in vtkImageFourierFilter) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageFourierFilter() [inline, protected]
  • vtkImageFourierFilter(const vtkImageFourierFilter &) (defined in vtkImageFourierFilter) [private]
  • vtkImageIterateFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageFourierFilter, vtkImageDecomposeFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageFourierFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageGaussianSmooth Member List

This is the complete list of members for vtkImageGaussianSmooth, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeKernel(double *kernel, int min, int max, double std) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteAxis(int axis, vtkImageData *inData, int inExt[6], vtkImageData *outData, int outExt[6], int *pcycle, int target, int *pcount, int total) [protected]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadiusFactors() [virtual]
  • GetRadiusFactors(float &, float &, float &) [virtual]
  • GetRadiusFactors(float[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStandardDeviations() [virtual]
  • GetStandardDeviations(float &, float &, float &) [virtual]
  • GetStandardDeviations(float[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageGaussianSmooth &) (defined in vtkImageGaussianSmooth) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RadiusFactors [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadiusFactor(float f) [inline]
  • SetRadiusFactors(float, float, float) [virtual]
  • SetRadiusFactors(float[3]) [virtual]
  • SetRadiusFactors(float f, float f2) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStandardDeviation(float std) [inline]
  • SetStandardDeviation(float a, float b) [inline]
  • SetStandardDeviation(float a, float b, float c) [inline]
  • SetStandardDeviations(float, float, float) [virtual]
  • SetStandardDeviations(float[3]) [virtual]
  • SetStandardDeviations(float a, float b) [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StandardDeviations [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageGaussianSmooth() [protected]
  • vtkImageGaussianSmooth(const vtkImageGaussianSmooth &) (defined in vtkImageGaussianSmooth) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageGaussianSmooth, vtkImageToImageFilter)
  • ~vtkImageGaussianSmooth() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageGaussianSource Member List

This is the complete list of members for vtkImageGaussianSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float &, float &, float &) [virtual]
  • GetCenter(float[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStandardDeviation() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageGaussianSource &) (defined in vtkImageGaussianSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximum(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStandardDeviation(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StandardDeviation [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageGaussianSource() [protected]
  • vtkImageGaussianSource(const vtkImageGaussianSource &) (defined in vtkImageGaussianSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageGaussianSource, vtkImageSource)
  • WholeExtent [protected]
  • ~vtkImageGaussianSource() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageGradient Member List

This is the complete list of members for vtkImageGradient, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHandleBoundaries() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HandleBoundariesOff() [virtual]
  • HandleBoundariesOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageGradient &) (defined in vtkImageGradient) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleBoundaries(int) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageGradient() [protected]
  • vtkImageGradient(const vtkImageGradient &) (defined in vtkImageGradient) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageGradient, vtkImageToImageFilter)
  • ~vtkImageGradient() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageGradientMagnitude Member List

This is the complete list of members for vtkImageGradientMagnitude, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHandleBoundaries() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HandleBoundariesOff() [virtual]
  • HandleBoundariesOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageGradientMagnitude &) (defined in vtkImageGradientMagnitude) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleBoundaries(int) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageGradientMagnitude() [protected]
  • vtkImageGradientMagnitude(const vtkImageGradientMagnitude &) (defined in vtkImageGradientMagnitude) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageGradientMagnitude, vtkImageToImageFilter)
  • ~vtkImageGradientMagnitude() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageGridSource Member List

This is the complete list of members for vtkImageGridSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • FillValue [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataScalarTypeAsString() [inline]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFillValue() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGridOrigin() [virtual]
  • GetGridOrigin(int &, int &, int &) [virtual]
  • GetGridOrigin(int[3]) [virtual]
  • GetGridSpacing() [virtual]
  • GetGridSpacing(int &, int &, int &) [virtual]
  • GetGridSpacing(int[3]) [virtual]
  • GetInputs() [inline]
  • GetLineValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GridOrigin [protected]
  • GridSpacing [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LineValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageGridSource &) (defined in vtkImageGridSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int) [virtual]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFillValue(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGridOrigin(int, int, int) [virtual]
  • SetGridOrigin(int[3]) [virtual]
  • SetGridSpacing(int, int, int) [virtual]
  • SetGridSpacing(int[3]) [virtual]
  • SetLineValue(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageGridSource() [protected]
  • vtkImageGridSource(const vtkImageGridSource &) (defined in vtkImageGridSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageGridSource, vtkImageSource)
  • ~vtkImageGridSource() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageHSVToRGB Member List

This is the complete list of members for vtkImageHSVToRGB, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageHSVToRGB &) (defined in vtkImageHSVToRGB) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMaximum(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageHSVToRGB() [protected]
  • vtkImageHSVToRGB(const vtkImageHSVToRGB &) (defined in vtkImageHSVToRGB) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageHSVToRGB, vtkImageToImageFilter)
  • ~vtkImageHSVToRGB() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageHybridMedian2D Member List

This is the complete list of members for vtkImageHybridMedian2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeMedian(float *array, int size) [protected]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageHybridMedian2D &) (defined in vtkImageHybridMedian2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageHybridMedian2D() [protected]
  • vtkImageHybridMedian2D(const vtkImageHybridMedian2D &) (defined in vtkImageHybridMedian2D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageHybridMedian2D, vtkImageSpatialFilter)
  • ~vtkImageHybridMedian2D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageIdealHighPass Member List

This is the complete list of members for vtkImageIdealHighPass, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CutOff [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCutOff() [virtual]
  • GetCutOff(float &, float &, float &) [virtual]
  • GetCutOff(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXCutOff() [inline]
  • GetYCutOff() [inline]
  • GetZCutOff() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageIdealHighPass &) (defined in vtkImageIdealHighPass) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCutOff(float, float, float) [virtual]
  • SetCutOff(float[3]) [virtual]
  • SetCutOff(float v) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXCutOff(float v)
  • SetYCutOff(float v)
  • SetZCutOff(float v)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageIdealHighPass() [protected]
  • vtkImageIdealHighPass(const vtkImageIdealHighPass &) (defined in vtkImageIdealHighPass) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageIdealHighPass, vtkImageToImageFilter)
  • ~vtkImageIdealHighPass() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageIdealLowPass Member List

This is the complete list of members for vtkImageIdealLowPass, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CutOff [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCutOff() [virtual]
  • GetCutOff(float &, float &, float &) [virtual]
  • GetCutOff(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXCutOff() [inline]
  • GetYCutOff() [inline]
  • GetZCutOff() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageIdealLowPass &) (defined in vtkImageIdealLowPass) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCutOff(float, float, float) [virtual]
  • SetCutOff(float[3]) [virtual]
  • SetCutOff(float v) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXCutOff(float v)
  • SetYCutOff(float v)
  • SetZCutOff(float v)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageIdealLowPass() [protected]
  • vtkImageIdealLowPass(const vtkImageIdealLowPass &) (defined in vtkImageIdealLowPass) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageIdealLowPass, vtkImageToImageFilter)
  • ~vtkImageIdealLowPass() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageImport Member List

This is the complete list of members for vtkImageImport, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • BufferPointerCallback [protected]
  • BufferPointerCallbackType typedef
  • CallbackUserData [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CopyImportVoidPointer(void *ptr, int size)
  • DataExtent [protected]
  • DataExtentCallback [protected]
  • DataExtentCallbackType typedef
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *d) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBufferPointerCallback() [virtual]
  • GetCallbackUserData() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataExtentCallback() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataScalarTypeAsString() [inline]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImportVoidPointer() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfComponentsCallback() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOriginCallback() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPipelineModifiedCallback() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetPropagateUpdateExtentCallback() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarTypeCallback() [virtual]
  • GetSpacingCallback() [virtual]
  • GetUpdateDataCallback() [virtual]
  • GetUpdateInformationCallback() [virtual]
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GetWholeExtentCallback() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImportVoidPointer [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • InvokeExecuteDataCallbacks() [protected]
  • InvokeExecuteInformationCallbacks() [protected]
  • InvokeUpdateInformationCallbacks() [protected]
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyCheckWholeExtent() [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfComponentsCallback [protected]
  • NumberOfComponentsCallbackType typedef
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • operator=(const vtkImageImport &) (defined in vtkImageImport) [private]
  • OriginCallback [protected]
  • OriginCallbackType typedef
  • Outputs [protected]
  • PipelineModifiedCallback [protected]
  • PipelineModifiedCallbackType typedef
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • PropagateUpdateExtentCallback [protected]
  • PropagateUpdateExtentCallbackType typedef
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • ScalarTypeCallback [protected]
  • ScalarTypeCallbackType typedef
  • SetAbortExecute(int) [virtual]
  • SetBufferPointerCallback(BufferPointerCallbackType) [virtual]
  • SetCallbackUserData(void *) [virtual]
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataExtentCallback(DataExtentCallbackType) [virtual]
  • SetDataExtentToWholeExtent() [inline]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int) [virtual]
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImportVoidPointer(void *ptr)
  • SetImportVoidPointer(void *ptr, int save)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfComponentsCallback(NumberOfComponentsCallbackType) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOriginCallback(OriginCallbackType) [virtual]
  • SetOutput(vtkImageData *output)
  • SetPipelineModifiedCallback(PipelineModifiedCallbackType) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetPropagateUpdateExtentCallback(PropagateUpdateExtentCallbackType) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarTypeCallback(ScalarTypeCallbackType) [virtual]
  • SetSpacingCallback(SpacingCallbackType) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUpdateDataCallback(UpdateDataCallbackType) [virtual]
  • SetUpdateInformationCallback(UpdateInformationCallbackType) [virtual]
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • SetWholeExtentCallback(WholeExtentCallbackType) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpacingCallback [protected]
  • SpacingCallbackType typedef
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateDataCallback [protected]
  • UpdateDataCallbackType typedef
  • UpdateInformation() [protected, virtual]
  • UpdateInformationCallback [protected]
  • UpdateInformationCallbackType typedef
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageImport() [protected]
  • vtkImageImport(const vtkImageImport &) (defined in vtkImageImport) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageImport, vtkImageSource)
  • WholeExtent [protected]
  • WholeExtentCallback [protected]
  • WholeExtentCallbackType typedef
  • ~vtkImageImport() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:18:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageInPlaceFilter Member List

This is the complete list of members for vtkImageInPlaceFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • CopyData(vtkImageData *in, vtkImageData *out) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageInPlaceFilter &) (defined in vtkImageInPlaceFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageInPlaceFilter() [inline, protected]
  • vtkImageInPlaceFilter(const vtkImageInPlaceFilter &) (defined in vtkImageInPlaceFilter) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageInPlaceFilter, vtkImageToImageFilter)
  • ~vtkImageInPlaceFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageIslandRemoval2D Member List

This is the complete list of members for vtkImageIslandRemoval2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AreaThreshold [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAreaThreshold() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIslandValue() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetReplaceValue() [virtual]
  • GetSquareNeighborhood() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IslandValue [protected]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageIslandRemoval2D &) (defined in vtkImageIslandRemoval2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAreaThreshold(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetIslandValue(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetReplaceValue(float) [virtual]
  • SetSquareNeighborhood(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SquareNeighborhood [protected]
  • SquareNeighborhoodOff() [virtual]
  • SquareNeighborhoodOn() [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageIslandRemoval2D() [protected]
  • vtkImageIslandRemoval2D(const vtkImageIslandRemoval2D &) (defined in vtkImageIslandRemoval2D) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageIslandRemoval2D, vtkImageToImageFilter)
  • ~vtkImageIslandRemoval2D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageIterateFilter Member List

This is the complete list of members for vtkImageIterateFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int[6], int[6]) [inline, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out)=0 [protected, pure virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageIterateFilter &) (defined in vtkImageIterateFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageIterateFilter(const vtkImageIterateFilter &) (defined in vtkImageIterateFilter) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageIterateFilter, vtkImageToImageFilter)
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageIterator Member List

This is the complete list of members for vtkImageIterator, including all inherited members.
  • BeginSpan() [inline]
  • ContinuousIncrements [protected]
  • EndPointer [protected]
  • EndSpan() [inline]
  • Increments [protected]
  • IsAtEnd() [inline]
  • NextSpan()
  • Pointer [protected]
  • SliceEndPointer [protected]
  • SpanEndPointer [protected]
  • SpanIterator typedef
  • vtkImageIterator(vtkImageData *id, int *ext)
Generated on Mon Mar 25 01:19:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageLaplacian Member List

This is the complete list of members for vtkImageLaplacian, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageLaplacian &) (defined in vtkImageLaplacian) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageLaplacian() [protected]
  • vtkImageLaplacian(const vtkImageLaplacian &) (defined in vtkImageLaplacian) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageLaplacian, vtkImageToImageFilter)
  • ~vtkImageLaplacian() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageLogarithmicScale Member List

This is the complete list of members for vtkImageLogarithmicScale, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Constant [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConstant() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageLogarithmicScale &) (defined in vtkImageLogarithmicScale) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetConstant(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageLogarithmicScale() [protected]
  • vtkImageLogarithmicScale(const vtkImageLogarithmicScale &) (defined in vtkImageLogarithmicScale) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageLogarithmicScale, vtkImageToImageFilter)
  • ~vtkImageLogarithmicScale() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageLogic Member List

This is the complete list of members for vtkImageLogic, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOperation() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputTrueValue() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • Operation [protected]
  • operator=(const vtkImageLogic &) (defined in vtkImageLogic) [private]
  • Outputs [protected]
  • OutputTrueValue [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOperation(int) [virtual]
  • SetOperationToAnd() [inline]
  • SetOperationToNand() [inline]
  • SetOperationToNor() [inline]
  • SetOperationToNot() [inline]
  • SetOperationToOr() [inline]
  • SetOperationToXor() [inline]
  • SetOutput(vtkImageData *output)
  • SetOutputTrueValue(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageLogic() [protected]
  • vtkImageLogic(const vtkImageLogic &) (defined in vtkImageLogic) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageLogic, vtkImageTwoInputFilter)
  • ~vtkImageLogic() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageLuminance Member List

This is the complete list of members for vtkImageLuminance, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageLuminance &) (defined in vtkImageLuminance) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageLuminance() [inline, protected]
  • vtkImageLuminance(const vtkImageLuminance &) (defined in vtkImageLuminance) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageLuminance, vtkImageToImageFilter)
  • ~vtkImageLuminance() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMagnify Member List

This is the complete list of members for vtkImageMagnify, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetInterpolate() [virtual]
  • GetMagnificationFactors() [virtual]
  • GetMagnificationFactors(int &, int &, int &) [virtual]
  • GetMagnificationFactors(int[3]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MagnificationFactors [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMagnify &) (defined in vtkImageMagnify) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetInterpolate(int) [virtual]
  • SetMagnificationFactors(int, int, int) [virtual]
  • SetMagnificationFactors(int[3]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMagnify() [protected]
  • vtkImageMagnify(const vtkImageMagnify &) (defined in vtkImageMagnify) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMagnify, vtkImageToImageFilter)
  • ~vtkImageMagnify() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMagnitude Member List

This is the complete list of members for vtkImageMagnitude, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMagnitude &) (defined in vtkImageMagnitude) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMagnitude() [inline, protected]
  • vtkImageMagnitude(const vtkImageMagnitude &) (defined in vtkImageMagnitude) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMagnitude, vtkImageToImageFilter)
  • ~vtkImageMagnitude() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMandelbrotSource Member List

This is the complete list of members for vtkImageMandelbrotSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ConstantSize [protected]
  • ConstantSizeOff() [virtual]
  • ConstantSizeOn() [virtual]
  • CopyOriginAndSample(vtkImageMandelbrotSource *source)
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • EvaluateSet(double p[4]) [protected]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *outData) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConstantSize() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMaximumNumberOfIterations() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOriginCX() [virtual]
  • GetOriginCX(double &, double &, double &, double &) [virtual]
  • GetOriginCX(double[4]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetProjectionAxes() [virtual]
  • GetProjectionAxes(int &, int &, int &) [virtual]
  • GetProjectionAxes(int[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleCX() [virtual]
  • GetSampleCX(double &, double &, double &, double &) [virtual]
  • GetSampleCX(double[4]) [virtual]
  • GetSizeCX()
  • GetSizeCX(double s[4])
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumNumberOfIterations [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageMandelbrotSource &) (defined in vtkImageMandelbrotSource) [private]
  • OriginCX [protected]
  • Outputs [protected]
  • Pan(double x, double y, double z)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ProjectionAxes [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleCX [protected]
  • SetAbortExecute(int) [virtual]
  • SetConstantSize(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximumNumberOfIterations(unsigned short) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOriginCX(double, double, double, double) [virtual]
  • SetOriginCX(double[4]) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetProjectionAxes(int x, int y, int z)
  • SetProjectionAxes(int *a) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSample(double v) [inline]
  • SetSampleCX(double, double, double, double) [virtual]
  • SetSampleCX(double[4]) [virtual]
  • SetSizeCX(double cReal, double cImag, double xReal, double xImag)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int extent[6])
  • SetWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SizeCX [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMandelbrotSource() [protected]
  • vtkImageMandelbrotSource(const vtkImageMandelbrotSource &) (defined in vtkImageMandelbrotSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMandelbrotSource, vtkImageSource)
  • WholeExtent [protected]
  • Zoom(double factor)
  • ~vtkImageMandelbrotSource() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMapper Member List

This is the complete list of members for vtkImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CustomDisplayExtents [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageMapper &) (defined in vtkImageMapper) [private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *, vtkImageData *, vtkActor2D *)=0 [pure virtual]
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkImageMapper(const vtkImageMapper &) (defined in vtkImageMapper) [private]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkImageMapper, vtkMapper2D)
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:19:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMapToColors Member List

This is the complete list of members for vtkImageMapToColors, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • ActiveComponent [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataWasPassed [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetActiveComponent() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassAlphaToOutput() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMapToColors &) (defined in vtkImageMapToColors) [private]
  • OutputFormat [protected]
  • Outputs [protected]
  • PassAlphaToOutput [protected]
  • PassAlphaToOutputOff() [virtual]
  • PassAlphaToOutputOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetActiveComponent(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToLuminanceAlpha() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetPassAlphaToOutput(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMapToColors() [protected]
  • vtkImageMapToColors(const vtkImageMapToColors &) (defined in vtkImageMapToColors) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMapToColors, vtkImageToImageFilter)
  • ~vtkImageMapToColors() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMapToRGBA Member List

This is the complete list of members for vtkImageMapToRGBA, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • ActiveComponent [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataWasPassed [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetActiveComponent() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassAlphaToOutput() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMapToRGBA &) (defined in vtkImageMapToRGBA) [private]
  • OutputFormat [protected]
  • Outputs [protected]
  • PassAlphaToOutput [protected]
  • PassAlphaToOutputOff() [virtual]
  • PassAlphaToOutputOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetActiveComponent(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToLuminanceAlpha() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetPassAlphaToOutput(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMapToColors() [protected]
  • vtkImageMapToRGBA() [inline, protected]
  • vtkImageMapToRGBA(const vtkImageMapToRGBA &) (defined in vtkImageMapToRGBA) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMapToRGBA, vtkImageMapToColors)
  • ~vtkImageMapToColors() [protected]
  • ~vtkImageMapToRGBA() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMapToWindowLevelColors Member List

This is the complete list of members for vtkImageMapToWindowLevelColors, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • ActiveComponent [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataWasPassed [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetActiveComponent() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetLevel() [virtual]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassAlphaToOutput() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Level [protected]
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMapToWindowLevelColors &) (defined in vtkImageMapToWindowLevelColors) [private]
  • OutputFormat [protected]
  • Outputs [protected]
  • PassAlphaToOutput [protected]
  • PassAlphaToOutputOff() [virtual]
  • PassAlphaToOutputOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetActiveComponent(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetLevel(float) [virtual]
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToLuminanceAlpha() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetPassAlphaToOutput(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWindow(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMapToColors() [protected]
  • vtkImageMapToWindowLevelColors() [protected]
  • vtkImageMapToWindowLevelColors(const vtkImageMapToWindowLevelColors &) (defined in vtkImageMapToWindowLevelColors) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMapToWindowLevelColors, vtkImageToImageFilter)
  • Window [protected]
  • ~vtkImageMapToColors() [protected]
  • ~vtkImageMapToWindowLevelColors() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMarchingCubes Member List

This is the complete list of members for vtkImageMarchingCubes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddLocatorPoint(int cellX, int cellY, int edge, int ptId)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNormals
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteLocator() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [virtual]
  • GetInputs() [inline]
  • GetLocatorPoint(int cellX, int cellY, int edge)
  • GetLocatorPointer(int cellX, int cellY, int edge) [protected]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Gradients
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IncrementLocatorZ()
  • InformationTime [protected]
  • InitializeLocator(int min0, int max0, int min1, int max1) [protected]
  • InputMemoryLimit [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LocatorDimX [protected]
  • LocatorDimY [protected]
  • LocatorMinX [protected]
  • LocatorMinY [protected]
  • LocatorPointIds [protected]
  • March(vtkImageData *inData, int chunkMin, int chunkMax, int numContours, float *values) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • NeedGradients
  • New() [static]
  • Normals
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSlicesPerChunk [protected]
  • operator=(const vtkImageMarchingCubes &) (defined in vtkImageMarchingCubes) [private]
  • Outputs [protected]
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Scalars
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInputMemoryLimit(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Triangles
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMarchingCubes() [protected]
  • vtkImageMarchingCubes(const vtkImageMarchingCubes &) (defined in vtkImageMarchingCubes) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMarchingCubes, vtkPolyDataSource)
  • ~vtkImageMarchingCubes() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMask Member List

This is the complete list of members for vtkImageMask, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMaskAlpha() [virtual]
  • GetMaskedOutputValue() [inline]
  • GetMaskedOutputValueLength() [inline]
  • GetMTime() [virtual]
  • GetNotMask() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaskAlpha [protected]
  • MaskedOutputValue [protected]
  • MaskedOutputValueLength [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NotMask [protected]
  • NotMaskOff() [virtual]
  • NotMaskOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMask &) (defined in vtkImageMask) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageInput(vtkImageData *in) [inline]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetMaskAlpha(float) [virtual]
  • SetMaskedOutputValue(int num, float *v)
  • SetMaskedOutputValue(float v) [inline]
  • SetMaskedOutputValue(float v1, float v2) [inline]
  • SetMaskedOutputValue(float v1, float v2, float v3) [inline]
  • SetMaskInput(vtkImageData *in) [inline]
  • SetNotMask(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMask() [protected]
  • vtkImageMask(const vtkImageMask &) (defined in vtkImageMask) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMask, vtkImageTwoInputFilter)
  • ~vtkImageMask() [protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMaskBits Member List

This is the complete list of members for vtkImageMaskBits, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMasks() [virtual]
  • GetMasks(unsigned int &, unsigned int &, unsigned int &, unsigned int &) [virtual]
  • GetMasks(unsigned int[4]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOperation() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Masks [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • Operation [protected]
  • operator=(const vtkImageMaskBits &) (defined in vtkImageMaskBits) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &, vtkIndent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMask(unsigned int mask) [inline]
  • SetMasks(unsigned int, unsigned int, unsigned int, unsigned int) [virtual]
  • SetMasks(unsigned int[4]) [virtual]
  • SetMasks(unsigned int mask1, unsigned int mask2) [inline]
  • SetMasks(unsigned int mask1, unsigned int mask2, unsigned int mask3) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOperation(int) [virtual]
  • SetOperationToAnd() [inline]
  • SetOperationToNand() [inline]
  • SetOperationToNor() [inline]
  • SetOperationToOr() [inline]
  • SetOperationToXor() [inline]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMaskBits() [protected]
  • vtkImageMaskBits(const vtkImageMaskBits &) (defined in vtkImageMaskBits) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMaskBits, vtkImageToImageFilter)
  • ~vtkImageMaskBits() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMathematics Member List

This is the complete list of members for vtkImageMathematics, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ConstantC [protected]
  • ConstantK [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DivideByZeroToC [protected]
  • DivideByZeroToCOff() [virtual]
  • DivideByZeroToCOn() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConstantC() [virtual]
  • GetConstantK() [virtual]
  • GetDebug()
  • GetDivideByZeroToC() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOperation() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • Operation [protected]
  • operator=(const vtkImageMathematics &) (defined in vtkImageMathematics) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetConstantC(double) [virtual]
  • SetConstantK(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivideByZeroToC(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOperation(int) [virtual]
  • SetOperationToAbsoluteValue() [inline]
  • SetOperationToAdd() [inline]
  • SetOperationToAddConstant() [inline]
  • SetOperationToATAN() [inline]
  • SetOperationToATAN2() [inline]
  • SetOperationToComplexMultiply() [inline]
  • SetOperationToConjugate() [inline]
  • SetOperationToCos() [inline]
  • SetOperationToDivide() [inline]
  • SetOperationToExp() [inline]
  • SetOperationToInvert() [inline]
  • SetOperationToLog() [inline]
  • SetOperationToMax() [inline]
  • SetOperationToMin() [inline]
  • SetOperationToMultiply() [inline]
  • SetOperationToMultiplyByK() [inline]
  • SetOperationToReplaceCByK() [inline]
  • SetOperationToSin() [inline]
  • SetOperationToSquare() [inline]
  • SetOperationToSquareRoot() [inline]
  • SetOperationToSubtract() [inline]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMathematics() [protected]
  • vtkImageMathematics(const vtkImageMathematics &) (defined in vtkImageMathematics) [private]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMathematics, vtkImageTwoInputFilter)
  • ~vtkImageMathematics() [inline, protected]
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMedian3D Member List

This is the complete list of members for vtkImageMedian3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfElements() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfElements [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMedian3D &) (defined in vtkImageMedian3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMedian3D() [protected]
  • vtkImageMedian3D(const vtkImageMedian3D &) (defined in vtkImageMedian3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMedian3D, vtkImageSpatialFilter)
  • ~vtkImageMedian3D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMirrorPad Member List

This is the complete list of members for vtkImageMirrorPad, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputNumberOfScalarComponents() [virtual]
  • GetOutputs()
  • GetOutputWholeExtent(int extent[6])
  • GetOutputWholeExtent() [inline]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMirrorPad &) (defined in vtkImageMirrorPad) [private]
  • OutputNumberOfScalarComponents [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputNumberOfScalarComponents(int) [virtual]
  • SetOutputWholeExtent(int extent[6])
  • SetOutputWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outRegion, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMirrorPad() [inline, protected]
  • vtkImageMirrorPad(const vtkImageMirrorPad &) (defined in vtkImageMirrorPad) [private]
  • vtkImagePadFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMirrorPad, vtkImagePadFilter)
  • ~vtkImageMirrorPad() [inline, protected]
  • ~vtkImagePadFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMultipleInputFilter Member List

This is the complete list of members for vtkImageMultipleInputFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddInput(vtkDataObject *) (defined in vtkImageMultipleInputFilter) [inline, private, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMultipleInputFilter &) (defined in vtkImageMultipleInputFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveInput(vtkDataObject *) (defined in vtkImageMultipleInputFilter) [inline, private, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageMultipleInputFilter(const vtkImageMultipleInputFilter &) (defined in vtkImageMultipleInputFilter) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMultipleInputFilter, vtkImageSource)
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageMultipleInputOutputFilter Member List

This is the complete list of members for vtkImageMultipleInputOutputFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData **) [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput(int num)
  • GetOutput()
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageMultipleInputOutputFilter &) (defined in vtkImageMultipleInputOutputFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData **outDatas, int extent[6], int threadId) [virtual]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int threadId) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageMultipleInputOutputFilter() [protected]
  • vtkImageMultipleInputOutputFilter(const vtkImageMultipleInputOutputFilter &) (defined in vtkImageMultipleInputOutputFilter) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageMultipleInputOutputFilter, vtkImageSource)
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageMultipleInputOutputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageNoiseSource Member List

This is the complete list of members for vtkImageNoiseSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMinimum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • Minimum [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageNoiseSource &) (defined in vtkImageNoiseSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximum(float) [virtual]
  • SetMinimum(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageNoiseSource() [protected]
  • vtkImageNoiseSource(const vtkImageNoiseSource &) (defined in vtkImageNoiseSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageNoiseSource, vtkImageSource)
  • WholeExtent [protected]
  • ~vtkImageNoiseSource() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageNonMaximumSuppression Member List

This is the complete list of members for vtkImageNonMaximumSuppression, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHandleBoundaries() [virtual]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HandleBoundariesOff() [virtual]
  • HandleBoundariesOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageNonMaximumSuppression &) (defined in vtkImageNonMaximumSuppression) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleBoundaries(int) [virtual]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetMagnitudeInput(vtkImageData *input) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVectorInput(vtkImageData *input) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageNonMaximumSuppression() [protected]
  • vtkImageNonMaximumSuppression(const vtkImageNonMaximumSuppression &) (defined in vtkImageNonMaximumSuppression) [private]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageNonMaximumSuppression, vtkImageTwoInputFilter)
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageNonMaximumSuppression() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageNormalize Member List

This is the complete list of members for vtkImageNormalize, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageNormalize &) (defined in vtkImageNormalize) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageNormalize() [inline, protected]
  • vtkImageNormalize(const vtkImageNormalize &) (defined in vtkImageNormalize) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageNormalize, vtkImageToImageFilter)
  • ~vtkImageNormalize() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageOpenClose3D Member List

This is the complete list of members for vtkImageOpenClose3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • Filter0 [protected]
  • Filter1 [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCloseValue()
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilter0() [virtual]
  • GetFilter1() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOpenValue()
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageOpenClose3D &) (defined in vtkImageOpenClose3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetCloseValue(float value)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *Input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOpenValue(float value)
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageOpenClose3D() [protected]
  • vtkImageOpenClose3D(const vtkImageOpenClose3D &) (defined in vtkImageOpenClose3D) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageOpenClose3D, vtkImageToImageFilter)
  • ~vtkImageOpenClose3D() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImagePadFilter Member List

This is the complete list of members for vtkImagePadFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputNumberOfScalarComponents() [virtual]
  • GetOutputs()
  • GetOutputWholeExtent(int extent[6])
  • GetOutputWholeExtent() [inline]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImagePadFilter &) (defined in vtkImagePadFilter) [private]
  • OutputNumberOfScalarComponents [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputNumberOfScalarComponents(int) [virtual]
  • SetOutputWholeExtent(int extent[6])
  • SetOutputWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImagePadFilter() [protected]
  • vtkImagePadFilter(const vtkImagePadFilter &) (defined in vtkImagePadFilter) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImagePadFilter, vtkImageToImageFilter)
  • ~vtkImagePadFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImagePermute Member List

This is the complete list of members for vtkImagePermute, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • FilteredAxes [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilteredAxes() [virtual]
  • GetFilteredAxes(int &, int &, int &) [virtual]
  • GetFilteredAxes(int[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImagePermute &) (defined in vtkImagePermute) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int, int, int) [virtual]
  • SetFilteredAxes(int[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImagePermute() [protected]
  • vtkImagePermute(const vtkImagePermute &) (defined in vtkImagePermute) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImagePermute, vtkImageToImageFilter)
  • ~vtkImagePermute() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageProgressIterator Member List

This is the complete list of members for vtkImageProgressIterator, including all inherited members.
  • BeginSpan() [inline]
  • ContinuousIncrements [protected]
  • Count [protected]
  • Count2 [protected]
  • EndPointer [protected]
  • EndSpan() [inline]
  • ID [protected]
  • Increments [protected]
  • IsAtEnd() [inline]
  • NextSpan()
  • Pointer [protected]
  • ProcessObject [protected]
  • SliceEndPointer [protected]
  • SpanEndPointer [protected]
  • SpanIterator typedef
  • Target [protected]
  • vtkImageIterator(vtkImageData *id, int *ext)
  • vtkImageProgressIterator(vtkImageData *imgd, int *ext, vtkProcessObject *po, int id)
Generated on Mon Mar 25 01:19:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageQuantizeRGBToIndex Member List

This is the complete list of members for vtkImageQuantizeRGBToIndex, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • BuildTreeExecuteTime [protected]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBuildTreeExecuteTime() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitializeExecuteTime() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetInputType() [virtual]
  • GetLookupIndexExecuteTime() [virtual]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeExecuteTime [protected]
  • Inputs [protected]
  • InputType [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupIndexExecuteTime [protected]
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfColors [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageQuantizeRGBToIndex &) (defined in vtkImageQuantizeRGBToIndex) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBuildTreeExecuteTime(float) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInitializeExecuteTime(float) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetLookupIndexExecuteTime(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfColors(int) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageQuantizeRGBToIndex() [protected]
  • vtkImageQuantizeRGBToIndex(const vtkImageQuantizeRGBToIndex &) (defined in vtkImageQuantizeRGBToIndex) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageQuantizeRGBToIndex, vtkImageToImageFilter)
  • ~vtkImageQuantizeRGBToIndex() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImager Member List

This is the complete list of members for vtkImager, including all inherited members.
  • Actors2D [protected]
  • AddActor2D(vtkProp *p) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • Aspect [protected]
  • Background [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender() [protected, virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick() [protected, virtual]
  • EndTag [protected]
  • Erase() [inline, virtual]
  • GetActors2D()
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetImageWindow()
  • GetIsPicking() [virtual]
  • GetMTime() [virtual]
  • GetOrigin()
  • GetPickedId() [protected, virtual]
  • GetPickedZ() [virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetReferenceCount() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVTKWindow() [inline, virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • operator=(const vtkImager &) (defined in vtkImager) [private]
  • Origin [protected]
  • PickedProp [protected]
  • PickFromProps [protected]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Props [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RenderOpaqueGeometry() [virtual]
  • RenderOverlay() [virtual]
  • RenderTranslucentGeometry() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageWindow(vtkImageWindow *win)
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetVTKWindow(vtkWindow *win)
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize) [protected, virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePickId() [protected, virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &, float &, float &) [inline, virtual]
  • vtkImager() [protected]
  • vtkImager(const vtkImager &) (defined in vtkImager) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImager, vtkViewport)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &, float &, float &) [inline, virtual]
  • ~vtkImager() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:19:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageRange3D Member List

This is the complete list of members for vtkImageRange3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Ellipse [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageRange3D &) (defined in vtkImageRange3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageRange3D() [protected]
  • vtkImageRange3D(const vtkImageRange3D &) (defined in vtkImageRange3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageRange3D, vtkImageSpatialFilter)
  • ~vtkImageRange3D() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImagerCollection Member List

This is the complete list of members for vtkImagerCollection, including all inherited members.
  • AddItem(vtkImager *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkImagerCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastItem() [inline]
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkImagerCollection &) (defined in vtkImagerCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkImagerCollection() [inline, protected]
  • vtkImagerCollection(const vtkImagerCollection &) (defined in vtkImagerCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImagerCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkImagerCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:19:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageReader2 Member List

This is the complete list of members for vtkImageReader2, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkImageReader2 &) (defined in vtkImageReader2) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageReader2(const vtkImageReader2 &) (defined in vtkImageReader2) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageReader2, vtkImageSource)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageReader2Collection Member List

This is the complete list of members for vtkImageReader2Collection, including all inherited members.
  • AddItem(vtkImageReader2 *) [inline]
  • AddItem(vtkObject *o) (defined in vtkImageReader2Collection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkImageReader2Collection &) (defined in vtkImageReader2Collection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkImageReader2Collection() [inline, protected]
  • vtkImageReader2Collection(const vtkImageReader2Collection &) (defined in vtkImageReader2Collection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageReader2Collection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkImageReader2Collection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:19:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageReader2Factory Member List

This is the complete list of members for vtkImageReader2Factory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AvailiableReaders (defined in vtkImageReader2Factory) [private, static]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateImageReader2(const char *path) [static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRegisteredReaders(vtkImageReader2Collection *) [static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeReaders() [protected, static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImageReader2Factory &) (defined in vtkImageReader2Factory) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterReader(vtkImageReader2 *r) [static]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCleanUpImageReader2Factory class [friend]
  • vtkImageReader2Factory() [protected]
  • vtkImageReader2Factory(const vtkImageReader2Factory &) (defined in vtkImageReader2Factory) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageReader2Factory, vtkObject)
  • ~vtkImageReader2Factory() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:19:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageReader Member List

This is the complete list of members for vtkImageReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeInverseTransformedExtent(int inExtent[6], int outExtent[6])
  • ComputeInverseTransformedIncrements(int inIncr[3], int outIncr[3])
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ComputeTransformedExtent(int inExtent[6], int outExtent[6]) [protected]
  • ComputeTransformedIncrements(int inIncr[3], int outIncr[3]) [protected]
  • ComputeTransformedOrigin(float origin[3]) [protected]
  • ComputeTransformedSpacing(float Spacing[3]) [protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataMask [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • DataVOI [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataMask() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDataVOI() [virtual]
  • GetDataVOI(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataVOI(int[6]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenAndSeekFile(int extent[6], int slice)
  • OpenFile()
  • operator=(const vtkImageReader &) (defined in vtkImageReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataMask(int val) [inline]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDataVOI(int, int, int, int, int, int) [virtual]
  • SetDataVOI(int[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SetTransform(vtkTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader() [protected]
  • vtkImageReader(const vtkImageReader &) (defined in vtkImageReader) [private]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageReader, vtkImageSource)
  • ~vtkImageReader() [protected]
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageResample Member List

This is the complete list of members for vtkImageResample, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAxisMagnificationFactor(int axis)
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetInterpolate() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MagnificationFactors [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageResample &) (defined in vtkImageResample) [private]
  • Outputs [protected]
  • OutputSpacing [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAxisMagnificationFactor(int axis, float factor)
  • SetAxisOutputSpacing(int axis, float spacing)
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetInterpolate(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageResample() [protected]
  • vtkImageResample(const vtkImageResample &) (defined in vtkImageResample) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageResample, vtkImageToImageFilter)
  • ~vtkImageResample() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageReslice Member List

This is the complete list of members for vtkImageReslice, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AutoCropOutput [protected]
  • AutoCropOutputOff() [virtual]
  • AutoCropOutputOn() [virtual]
  • BackgroundColor [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *input, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAutoCropOutput() [virtual]
  • GetAutoCroppedOutputBounds(vtkImageData *input, float bounds[6]) [protected]
  • GetBackgroundColor() [virtual]
  • GetBackgroundColor(float &, float &, float &, float &) [virtual]
  • GetBackgroundColor(float[4]) [virtual]
  • GetBackgroundLevel() [inline]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIndexMatrix() [protected]
  • GetInformationInput() [virtual]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetInterpolate() [inline]
  • GetInterpolationMode() [virtual]
  • GetInterpolationModeAsString() [inline]
  • GetMirror() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOptimization() [virtual]
  • GetOptimizedTransform() [inline, protected]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputDimensionality() [virtual]
  • GetOutputExtent() [virtual]
  • GetOutputExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetOutputExtent(int[6]) [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputOrigin() [virtual]
  • GetOutputOrigin(float &, float &, float &) [virtual]
  • GetOutputOrigin(float[3]) [virtual]
  • GetOutputs()
  • GetOutputSpacing() [virtual]
  • GetOutputSpacing(float &, float &, float &) [virtual]
  • GetOutputSpacing(float[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResliceAxes() [virtual]
  • GetResliceAxesDirectionCosines(double x[3], double y[3], double z[3])
  • GetResliceAxesDirectionCosines(double xyz[9]) [inline]
  • GetResliceAxesDirectionCosines() [inline]
  • GetResliceAxesOrigin(double xyz[3])
  • GetResliceAxesOrigin() [inline]
  • GetResliceTransform() [virtual]
  • GetStencil()
  • GetTransformInputSampling() [virtual]
  • GetWrap() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IndexMatrix [protected]
  • InformationInput [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolateOff() [inline]
  • InterpolateOn() [inline]
  • InterpolationMode [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Mirror [protected]
  • MirrorOff() [virtual]
  • MirrorOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageReslice &) (defined in vtkImageReslice) [private]
  • Optimization [protected]
  • OptimizationOff() [virtual]
  • OptimizationOn() [virtual]
  • OptimizedComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected]
  • OptimizedThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected]
  • OptimizedTransform [protected]
  • OutputDimensionality [protected]
  • OutputExtent [protected]
  • OutputOrigin [protected]
  • Outputs [protected]
  • OutputSpacing [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ResliceAxes [protected]
  • ResliceAxesDirectionCosines [protected]
  • ResliceAxesOrigin [protected]
  • ResliceTransform [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAutoCropOutput(int) [virtual]
  • SetBackgroundColor(float, float, float, float) [virtual]
  • SetBackgroundColor(float[4]) [virtual]
  • SetBackgroundLevel(float v) [inline]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInformationInput(vtkImageData *) [virtual]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetInterpolate(int t) [inline]
  • SetInterpolationMode(int) [virtual]
  • SetInterpolationModeToCubic() [inline]
  • SetInterpolationModeToLinear() [inline]
  • SetInterpolationModeToNearestNeighbor() [inline]
  • SetMirror(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOptimization(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputDimensionality(int) [virtual]
  • SetOutputExtent(int, int, int, int, int, int) [virtual]
  • SetOutputExtent(int[6]) [virtual]
  • SetOutputExtentToDefault() [inline]
  • SetOutputOrigin(float, float, float) [virtual]
  • SetOutputOrigin(float[3]) [virtual]
  • SetOutputOriginToDefault() [inline]
  • SetOutputSpacing(float, float, float) [virtual]
  • SetOutputSpacing(float[3]) [virtual]
  • SetOutputSpacingToDefault() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResliceAxes(vtkMatrix4x4 *) [virtual]
  • SetResliceAxesDirectionCosines(double x0, double x1, double x2, double y0, double y1, double y2, double z0, double z1, double z2)
  • SetResliceAxesDirectionCosines(const double x[3], const double y[3], const double z[3]) [inline]
  • SetResliceAxesDirectionCosines(const double xyz[9]) [inline]
  • SetResliceAxesOrigin(double x, double y, double z)
  • SetResliceAxesOrigin(const double xyz[3]) [inline]
  • SetResliceTransform(vtkAbstractTransform *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStencil(vtkImageStencilData *stencil)
  • SetTransformInputSampling(int) [virtual]
  • SetWrap(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TransformInputSampling [protected]
  • TransformInputSamplingOff() [virtual]
  • TransformInputSamplingOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReslice() [protected]
  • vtkImageReslice(const vtkImageReslice &) (defined in vtkImageReslice) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageReslice, vtkImageToImageFilter)
  • Wrap [protected]
  • WrapOff() [virtual]
  • WrapOn() [virtual]
  • ~vtkImageReslice() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageRFFT Member List

This is the complete list of members for vtkImageRFFT, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteFft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • ExecuteFftForwardBackward(vtkImageComplex *in, vtkImageComplex *out, int N, int fb) [protected]
  • ExecuteFftStep2(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int fb) [protected]
  • ExecuteFftStepN(vtkImageComplex *p_in, vtkImageComplex *p_out, int N, int bsize, int n, int fb) [protected]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • ExecuteRfft(vtkImageComplex *in, vtkImageComplex *out, int N)
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out) [inline, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageRFFT &) (defined in vtkImageRFFT) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int threadId) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageFourierFilter() [inline, protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageRFFT() [inline, protected]
  • vtkImageRFFT(const vtkImageRFFT &) (defined in vtkImageRFFT) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageRFFT, vtkImageFourierFilter)
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageFourierFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageRFFT() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageRGBToHSV Member List

This is the complete list of members for vtkImageRGBToHSV, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageRGBToHSV &) (defined in vtkImageRGBToHSV) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMaximum(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageRGBToHSV() [protected]
  • vtkImageRGBToHSV(const vtkImageRGBToHSV &) (defined in vtkImageRGBToHSV) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageRGBToHSV, vtkImageToImageFilter)
  • ~vtkImageRGBToHSV() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSeedConnectivity Member List

This is the complete list of members for vtkImageSeedConnectivity, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddSeed(int num, int *index)
  • AddSeed(int i0, int i1, int i2)
  • AddSeed(int i0, int i1)
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Connector [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConnector() [virtual]
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputConnectValue() [virtual]
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputConnectedValue() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputUnconnectedValue() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputConnectValue [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSeedConnectivity &) (defined in vtkImageSeedConnectivity) [private]
  • OutputConnectedValue [protected]
  • Outputs [protected]
  • OutputUnconnectedValue [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveAllSeeds()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Seeds [protected]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputConnectValue(int) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputConnectedValue(int) [virtual]
  • SetOutputUnconnectedValue(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSeedConnectivity() [protected]
  • vtkImageSeedConnectivity(const vtkImageSeedConnectivity &) (defined in vtkImageSeedConnectivity) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSeedConnectivity, vtkImageToImageFilter)
  • ~vtkImageSeedConnectivity() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSeparableConvolution Member List

This is the complete list of members for vtkImageSeparableConvolution, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dimensionality [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *input, vtkImageData *output) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensionality() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetXKernel() [virtual]
  • GetYKernel() [virtual]
  • GetZKernel() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSeparableConvolution &) (defined in vtkImageSeparableConvolution) [private]
  • Outputs [protected]
  • PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1, int &min2, int &max2)
  • PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDimensionality(int dim)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilteredAxes(int axis0)
  • SetFilteredAxes(int axis0, int axis2)
  • SetFilteredAxes(int axis0, int axis2, int axis3)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [protected, virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXKernel(vtkFloatArray *) [virtual]
  • SetYKernel(vtkFloatArray *) [virtual]
  • SetZKernel(vtkFloatArray *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDecomposeFilter() [protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageSeparableConvolution() [protected]
  • vtkImageSeparableConvolution(const vtkImageSeparableConvolution &) (defined in vtkImageSeparableConvolution) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSeparableConvolution, vtkImageDecomposeFilter)
  • XKernel [protected]
  • YKernel [protected]
  • ZKernel [protected]
  • ~vtkImageDecomposeFilter() [inline, protected]
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSeparableConvolution() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageShiftScale Member List

This is the complete list of members for vtkImageShiftScale, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • ClampOverflow [protected]
  • ClampOverflowOff() [virtual]
  • ClampOverflowOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClampOverflow() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputScalarType() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScale() [virtual]
  • GetShift() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageShiftScale &) (defined in vtkImageShiftScale) [private]
  • Outputs [protected]
  • OutputScalarType [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Scale [protected]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetClampOverflow(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputScalarType(int) [virtual]
  • SetOutputScalarTypeToChar() [inline]
  • SetOutputScalarTypeToDouble() [inline]
  • SetOutputScalarTypeToFloat() [inline]
  • SetOutputScalarTypeToInt() [inline]
  • SetOutputScalarTypeToLong() [inline]
  • SetOutputScalarTypeToShort() [inline]
  • SetOutputScalarTypeToUnsignedChar() [inline]
  • SetOutputScalarTypeToUnsignedInt() [inline]
  • SetOutputScalarTypeToUnsignedLong() [inline]
  • SetOutputScalarTypeToUnsignedShort() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScale(float) [virtual]
  • SetShift(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • Shift [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageShiftScale() [protected]
  • vtkImageShiftScale(const vtkImageShiftScale &) (defined in vtkImageShiftScale) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageShiftScale, vtkImageToImageFilter)
  • ~vtkImageShiftScale() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageShrink3D Member List

This is the complete list of members for vtkImageShrink3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AveragingOff() [virtual]
  • AveragingOn() [virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAveraging() [inline]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMean() [virtual]
  • GetMedian() [virtual]
  • GetMinimum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShift() [virtual]
  • GetShift(int &, int &, int &) [virtual]
  • GetShift(int[3]) [virtual]
  • GetShrinkFactors() [virtual]
  • GetShrinkFactors(int &, int &, int &) [virtual]
  • GetShrinkFactors(int[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • MaximumOff() [virtual]
  • MaximumOn() [virtual]
  • Mean [protected]
  • MeanOff() [virtual]
  • MeanOn() [virtual]
  • Median [protected]
  • MedianOff() [virtual]
  • MedianOn() [virtual]
  • Minimum [protected]
  • MinimumOff() [virtual]
  • MinimumOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageShrink3D &) (defined in vtkImageShrink3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAveraging(int)
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMaximum(int)
  • SetMean(int)
  • SetMedian(int)
  • SetMinimum(int)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetShift(int, int, int) [virtual]
  • SetShift(int[3]) [virtual]
  • SetShrinkFactors(int, int, int) [virtual]
  • SetShrinkFactors(int[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • Shift [protected]
  • ShrinkFactors [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageShrink3D() [protected]
  • vtkImageShrink3D(const vtkImageShrink3D &) (defined in vtkImageShrink3D) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageShrink3D, vtkImageToImageFilter)
  • ~vtkImageShrink3D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSinusoidSource Member List

This is the complete list of members for vtkImageSinusoidSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • Amplitude [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Direction [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAmplitude() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDirection() [virtual]
  • GetDirection(float &, float &, float &) [virtual]
  • GetDirection(float[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPeriod() [virtual]
  • GetPhase() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageSinusoidSource &) (defined in vtkImageSinusoidSource) [private]
  • Outputs [protected]
  • Period [protected]
  • Phase [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAmplitude(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirection(float, float, float)
  • SetDirection(float dir[3])
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetPeriod(float) [virtual]
  • SetPhase(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSinusoidSource() [protected]
  • vtkImageSinusoidSource(const vtkImageSinusoidSource &) (defined in vtkImageSinusoidSource) [private]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSinusoidSource, vtkImageSource)
  • WholeExtent [protected]
  • ~vtkImageSinusoidSource() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSkeleton2D Member List

This is the complete list of members for vtkImageSkeleton2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AllocateOutputScalars(vtkImageData *outData) [protected, virtual]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetIteration() [virtual]
  • GetIterationInput() [protected]
  • GetIterationOutput() [protected]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetPrune() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Iteration [protected]
  • IterationData [protected]
  • IterativeExecuteData(vtkImageData *in, vtkImageData *out) [inline, virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSkeleton2D &) (defined in vtkImageSkeleton2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Prune [protected]
  • PruneOff() [virtual]
  • PruneOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int num) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetPrune(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageIterateFilter() [protected]
  • vtkImageSkeleton2D() [protected]
  • vtkImageSkeleton2D(const vtkImageSkeleton2D &) (defined in vtkImageSkeleton2D) [private]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSkeleton2D, vtkImageIterateFilter)
  • ~vtkImageIterateFilter() [protected]
  • ~vtkImageSkeleton2D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSobel2D Member List

This is the complete list of members for vtkImageSobel2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSobel2D &) (defined in vtkImageSobel2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSobel2D() [protected]
  • vtkImageSobel2D(const vtkImageSobel2D &) (defined in vtkImageSobel2D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSobel2D, vtkImageSpatialFilter)
  • ~vtkImageSobel2D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSobel3D Member List

This is the complete list of members for vtkImageSobel3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSobel3D &) (defined in vtkImageSobel3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int outExt[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSobel3D() [protected]
  • vtkImageSobel3D(const vtkImageSobel3D &) (defined in vtkImageSobel3D) [private]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSobel3D, vtkImageSpatialFilter)
  • ~vtkImageSobel3D() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSource Member List

This is the complete list of members for vtkImageSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageSource &) (defined in vtkImageSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageSource(const vtkImageSource &) (defined in vtkImageSource) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSource, vtkSource)
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageSpatialFilter Member List

This is the complete list of members for vtkImageSpatialFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageSpatialFilter &) (defined in vtkImageSpatialFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageSpatialFilter(const vtkImageSpatialFilter &) (defined in vtkImageSpatialFilter) [private]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageSpatialFilter, vtkImageToImageFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageStencil Member List

This is the complete list of members for vtkImageStencil, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BackgroundColor [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBackgroundColor() [virtual]
  • GetBackgroundColor(float &, float &, float &, float &) [virtual]
  • GetBackgroundColor(float[4]) [virtual]
  • GetBackgroundInput()
  • GetBackgroundValue() [inline]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetReverseStencil() [virtual]
  • GetStencil()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageStencil &) (defined in vtkImageStencil) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReverseStencil [protected]
  • ReverseStencilOff() [virtual]
  • ReverseStencilOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBackgroundColor(float, float, float, float) [virtual]
  • SetBackgroundColor(float[4]) [virtual]
  • SetBackgroundInput(vtkImageData *input) [virtual]
  • SetBackgroundValue(float val) [inline]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetReverseStencil(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStencil(vtkImageStencilData *stencil) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageStencil() [protected]
  • vtkImageStencil(const vtkImageStencil &) (defined in vtkImageStencil) [private]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageStencil, vtkImageToImageFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageStencil() [protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageStencilData Member List

This is the complete list of members for vtkImageStencilData, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateExtents()
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *o) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentListLengths [protected]
  • ExtentLists [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • GetActualMemorySize() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocality() [virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNextExtent(int &r1, int &r2, int xMin, int xMax, int yIdx, int zIdx, int &iter)
  • GetNumberOfConsumers() [virtual]
  • GetOldOrigin() [virtual]
  • GetOldOrigin(float &, float &, float &) [virtual]
  • GetOldOrigin(float[3]) [virtual]
  • GetOldSpacing() [virtual]
  • GetOldSpacing(float &, float &, float &) [virtual]
  • GetOldSpacing(float[3]) [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float &, float &, float &) [virtual]
  • GetOrigin(float[3]) [virtual]
  • GetPipelineMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetSource() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float &, float &, float &) [virtual]
  • GetSpacing(float[3]) [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertNextExtent(int r1, int r2, int yIdx, int zIdx)
  • InternalImageStencilDataCopy(vtkImageStencilData *s)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Locality [protected]
  • MakeObject() [virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfExtentEntries [protected]
  • NumberOfPieces [protected]
  • OldOrigin [protected]
  • OldSpacing [protected]
  • operator=(const vtkImageStencilData &) (defined in vtkImageStencilData) [private]
  • Origin [protected]
  • Piece [protected]
  • PipelineMTime [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetExtent(int, int, int, int, int, int) [virtual]
  • SetExtent(int[6]) [virtual]
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetOldOrigin(float, float, float) [virtual]
  • SetOldOrigin(float[3]) [virtual]
  • SetOldSpacing(float, float, float) [virtual]
  • SetOldSpacing(float[3]) [virtual]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [virtual]
  • SetUpdateExtent(int ext[6]) [virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *f) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Spacing [protected]
  • SpacingOrOriginHasChanged() [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • vtkDataObject() [protected]
  • vtkImageStencilData() [protected]
  • vtkImageStencilData(const vtkImageStencilData &) (defined in vtkImageStencilData) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageStencilData, vtkDataObject)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkImageStencilData() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:19:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageStencilSource Member List

This is the complete list of members for vtkImageStencilSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • vtkSource::GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageStencilSource &) (defined in vtkImageStencilSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageStencilData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageStencilData *output, int extent[6], int threadId) [protected, virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageStencilSource() [protected]
  • vtkImageStencilSource(const vtkImageStencilSource &) (defined in vtkImageStencilSource) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageStencilSource, vtkSource)
  • ~vtkImageStencilSource() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageThreshold Member List

This is the complete list of members for vtkImageThreshold, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetInValue() [virtual]
  • GetLowerThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputScalarType() [virtual]
  • GetOutValue() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetReplaceIn() [virtual]
  • GetReplaceOut() [virtual]
  • GetUpperThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InValue [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LowerThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageThreshold &) (defined in vtkImageThreshold) [private]
  • Outputs [protected]
  • OutputScalarType [protected]
  • OutValue [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReplaceIn [protected]
  • ReplaceInOff() [virtual]
  • ReplaceInOn() [virtual]
  • ReplaceOut [protected]
  • ReplaceOutOff() [virtual]
  • ReplaceOutOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetInValue(float val)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputScalarType(int) [virtual]
  • SetOutputScalarTypeToChar() [inline]
  • SetOutputScalarTypeToDouble() [inline]
  • SetOutputScalarTypeToFloat() [inline]
  • SetOutputScalarTypeToInt() [inline]
  • SetOutputScalarTypeToLong() [inline]
  • SetOutputScalarTypeToShort() [inline]
  • SetOutputScalarTypeToUnsignedChar() [inline]
  • SetOutputScalarTypeToUnsignedInt() [inline]
  • SetOutputScalarTypeToUnsignedLong() [inline]
  • SetOutputScalarTypeToUnsignedShort() [inline]
  • SetOutValue(float val)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetReplaceIn(int) [virtual]
  • SetReplaceOut(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • ThresholdBetween(float lower, float upper)
  • ThresholdByLower(float thresh)
  • ThresholdByUpper(float thresh)
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UpperThreshold [protected]
  • vtkImageSource() [protected]
  • vtkImageThreshold() [protected]
  • vtkImageThreshold(const vtkImageThreshold &) (defined in vtkImageThreshold) [private]
  • vtkImageToImageFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageThreshold, vtkImageToImageFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageThreshold() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageToImageFilter Member List

This is the complete list of members for vtkImageToImageFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageToImageFilter &) (defined in vtkImageToImageFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkImageToImageFilter(const vtkImageToImageFilter &) (defined in vtkImageToImageFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageToImageFilter, vtkImageSource)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageToImageStencil Member List

This is the complete list of members for vtkImageToImageStencil, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLowerThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • vtkSource::GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUpperThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LowerThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageToImageStencil &) (defined in vtkImageToImageStencil) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetLowerThreshold(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageStencilData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUpperThreshold(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageStencilData *output, int extent[6], int threadId) [protected, virtual]
  • Threshold [protected]
  • ThresholdBetween(float lower, float upper)
  • ThresholdByLower(float thresh)
  • ThresholdByUpper(float thresh)
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UpperThreshold [protected]
  • vtkImageStencilSource() [protected]
  • vtkImageToImageStencil() [protected]
  • vtkImageToImageStencil(const vtkImageToImageStencil &) (defined in vtkImageToImageStencil) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageToImageStencil, vtkImageStencilSource)
  • ~vtkImageStencilSource() [protected]
  • ~vtkImageToImageStencil() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageToPolyDataFilter Member List

This is the complete list of members for vtkImageToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Append (defined in vtkImageToPolyDataFilter) [private]
  • BreakOnError() [static]
  • BuildEdges(vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkUnsignedCharArray *pointDescr, vtkPolyData *edges) (defined in vtkImageToPolyDataFilter) [private]
  • BuildPolygons(vtkUnsignedCharArray *pointDescr, vtkPolyData *edges, int numPolys, vtkUnsignedCharArray *polyColors) (defined in vtkImageToPolyDataFilter) [private]
  • BuildTable(unsigned char *inPixels) (defined in vtkImageToPolyDataFilter) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMode [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecimateEdges(vtkPolyData *edges, vtkUnsignedCharArray *pointDescr, float tol2) (defined in vtkImageToPolyDataFilter) [private]
  • Decimation [protected]
  • DecimationError [protected]
  • DecimationOff() [virtual]
  • DecimationOn() [virtual]
  • Delete() [virtual]
  • EdgeTable (defined in vtkImageToPolyDataFilter) [private]
  • EdgeUses (defined in vtkImageToPolyDataFilter) [private]
  • EdgeUseTable (defined in vtkImageToPolyDataFilter) [private]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Error [protected]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GeneratePolygons(vtkPolyData *edges, int numPolys, vtkPolyData *output, vtkUnsignedCharArray *polyColors, vtkUnsignedCharArray *pointDescr) (defined in vtkImageToPolyDataFilter) [private]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(unsigned char *rgb) (defined in vtkImageToPolyDataFilter) [private]
  • GetColorMode() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDecimation() [virtual]
  • GetDecimationError() [virtual]
  • GetError() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIJ(int id, int &i, int &j, int dims[3]) (defined in vtkImageToPolyDataFilter) [private]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNeighbors(unsigned char *ptr, int &i, int &j, int dims[3], unsigned char *neighbors[4], int mode) (defined in vtkImageToPolyDataFilter) [private]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSmoothingIterations() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputStyle() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSmoothing() [virtual]
  • GetSubImageSize() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsSameColor(unsigned char *p1, unsigned char *p2) (defined in vtkImageToPolyDataFilter) [private]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSmoothingIterations [protected]
  • operator=(const vtkImageToPolyDataFilter &) (defined in vtkImageToPolyDataFilter) [private]
  • Outputs [protected]
  • OutputStyle [protected]
  • PixelizeImage(vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output) [protected, virtual]
  • PolyColors (defined in vtkImageToPolyDataFilter) [private]
  • PolygonalizeImage(vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output) [protected, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessImage(vtkUnsignedCharArray *pixels, int dims[2]) (defined in vtkImageToPolyDataFilter) [private]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QuantizeImage(vtkDataArray *inScalars, int numComp, int type, int dims[3], int ext[4]) (defined in vtkImageToPolyDataFilter) [private]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RunLengthImage(vtkUnsignedCharArray *pixels, int dims[3], float origin[3], float spacing[3], vtkPolyData *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToLinear256() [inline]
  • SetColorModeToLUT() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDecimation(int) [virtual]
  • SetDecimationError(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetError(int) [virtual]
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSmoothingIterations(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetOutputStyle(int) [virtual]
  • SetOutputStyleToPixelize() [inline]
  • SetOutputStyleToPolygonalize() [inline]
  • SetOutputStyleToRunLength() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSmoothing(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubImageSize(int) [virtual]
  • SmoothEdges(vtkUnsignedCharArray *pointDescr, vtkPolyData *edges) (defined in vtkImageToPolyDataFilter) [private]
  • Smoothing [protected]
  • SmoothingOff() [virtual]
  • SmoothingOn() [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubImageSize [protected]
  • SubjectHelper [protected]
  • Table (defined in vtkImageToPolyDataFilter) [private]
  • TableMTime (defined in vtkImageToPolyDataFilter) [private]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Visited (defined in vtkImageToPolyDataFilter) [private]
  • vtkImageToPolyDataFilter() [protected]
  • vtkImageToPolyDataFilter(const vtkImageToPolyDataFilter &) (defined in vtkImageToPolyDataFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkImageToPolyDataFilter, vtkStructuredPointsToPolyDataFilter)
  • ~vtkImageToPolyDataFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:19:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageToStructuredPoints Member List

This is the complete list of members for vtkImageToStructuredPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *data) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetVectorInput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageToStructuredPoints &) (defined in vtkImageToStructuredPoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVectorInput(vtkImageData *input)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Translate [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageToStructuredPoints() [protected]
  • vtkImageToStructuredPoints(const vtkImageToStructuredPoints &) (defined in vtkImageToStructuredPoints) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageToStructuredPoints, vtkSource)
  • ~vtkImageToStructuredPoints() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageTranslateExtent Member List

This is the complete list of members for vtkImageTranslateExtent, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTranslation() [virtual]
  • GetTranslation(int &, int &, int &) [virtual]
  • GetTranslation(int[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageTranslateExtent &) (defined in vtkImageTranslateExtent) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTranslation(int, int, int) [virtual]
  • SetTranslation(int[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • Translation [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkImageTranslateExtent() [protected]
  • vtkImageTranslateExtent(const vtkImageTranslateExtent &) (defined in vtkImageTranslateExtent) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageTranslateExtent, vtkImageToImageFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkImageTranslateExtent() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageTwoInputFilter Member List

This is the complete list of members for vtkImageTwoInputFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkImageData *input) [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [virtual]
  • BypassOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData **, vtkImageData *) [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int num)
  • GetInput()
  • GetInput1() [inline]
  • GetInput2() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageTwoInputFilter &) (defined in vtkImageTwoInputFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkImageData *input) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int num, vtkImageData *input) [virtual]
  • SetInput1(vtkImageData *input) [virtual]
  • SetInput2(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageMultipleInputFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageTwoInputFilter() [protected]
  • vtkImageTwoInputFilter(const vtkImageTwoInputFilter &) (defined in vtkImageTwoInputFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageTwoInputFilter, vtkImageMultipleInputFilter)
  • ~vtkImageMultipleInputFilter() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageTwoInputFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageVariance3D Member List

This is the complete list of members for vtkImageVariance3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeOutputWholeExtent(int extent[6], int handleBoundaries) [protected]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Ellipse [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetKernelMiddle() [inline]
  • GetKernelSize() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleBoundaries [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KernelMiddle [protected]
  • KernelSize [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageVariance3D &) (defined in vtkImageVariance3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetKernelSize(int size0, int size1, int size2)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • Strides [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkImageSpatialFilter() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkImageVariance3D() [protected]
  • vtkImageVariance3D(const vtkImageVariance3D &) (defined in vtkImageVariance3D) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageVariance3D, vtkImageSpatialFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageSpatialFilter() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkImageVariance3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:19:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageViewer2 Member List

This is the complete list of members for vtkImageViewer2, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FirstRender [protected]
  • GetClassName() [inline, virtual]
  • GetColorLevel() [inline]
  • GetColorWindow() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetImageActor() [virtual]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetPosition() [inline]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetRenderWindow() [virtual]
  • GetSize() [inline]
  • GetWholeZMax() [inline]
  • GetWholeZMin() [inline]
  • GetWindowLevel() [virtual]
  • GetWindowName() [inline]
  • GetZSlice() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageActor [protected]
  • Interactor [protected]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImageViewer2 &) (defined in vtkImageViewer2) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(void) [virtual]
  • Renderer [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetColorLevel(float s) [inline]
  • SetColorWindow(float s) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(void *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *in) [inline]
  • SetParentId(void *a) [inline]
  • SetPosition(int a, int b) [inline]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetSize(int a, int b) [inline]
  • SetSize(int a[2]) [virtual]
  • SetupInteractor(vtkRenderWindowInteractor *)
  • SetWindowId(void *a) [inline]
  • SetZSlice(int s) [inline]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageViewer2() [protected]
  • vtkImageViewer2(const vtkImageViewer2 &) (defined in vtkImageViewer2) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageViewer2, vtkObject)
  • WindowLevel [protected]
  • ~vtkImageViewer2() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageViewer Member List

This is the complete list of members for vtkImageViewer, including all inherited members.
  • Actor2D [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetActor2D() [inline]
  • GetClassName() [inline, virtual]
  • GetColorLevel() [inline]
  • GetColorWindow() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [inline]
  • GetImageMapper() [inline]
  • GetImager() [inline]
  • GetImageWindow() [inline]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetPosition() [inline]
  • GetReferenceCount() [inline]
  • GetRenderer() [inline]
  • GetRenderWindow() [inline]
  • GetSize() [inline]
  • GetWholeZMax() [inline]
  • GetWholeZMin() [inline]
  • GetWindowName() [inline]
  • GetZSlice() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHintOff() [inline]
  • GrayScaleHintOn() [inline]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageMapper [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImageViewer &) (defined in vtkImageViewer) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(void) [virtual]
  • Renderer [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetColorLevel(float s) [inline]
  • SetColorWindow(float s) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(void *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int vtkNotUsed(a)) [inline]
  • SetInput(vtkImageData *in) [inline]
  • SetParentId(void *a) [inline]
  • SetPosition(int a, int b) [inline]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetSize(int a, int b) [inline]
  • SetSize(int a[2]) [virtual]
  • SetWindowId(void *a) [inline]
  • SetZSlice(int s) [inline]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageViewer() [protected]
  • vtkImageViewer(const vtkImageViewer &) (defined in vtkImageViewer) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageViewer, vtkObject)
  • ~vtkImageViewer() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageWindow Member List

This is the complete list of members for vtkImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [virtual]
  • FileName [protected]
  • Frame()=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGenericContext()=0 [pure virtual]
  • GetGenericDisplayId()=0 [pure virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId()=0 [pure virtual]
  • GetGenericWindowId()=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int, int, int, int, int) [inline, virtual]
  • GetPosition()=0 [pure virtual]
  • GetPosition(int *x, int *y) [virtual]
  • GetReferenceCount() [inline]
  • GetSize()=0 [pure virtual]
  • GetSize(int *x, int *y) [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeCurrent() [inline, virtual]
  • MakeDefaultWindow()=0 [protected, pure virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkImageWindow &) (defined in vtkImageWindow) [private]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(void *)=0 [pure virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *)=0 [pure virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPosition(int x, int y)=0 [pure virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetSize(int, int)=0 [pure virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *)=0 [pure virtual]
  • SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers()=0 [pure virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageWindow() [protected]
  • vtkImageWindow(const vtkImageWindow &) (defined in vtkImageWindow) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImageWindow, vtkWindow)
  • vtkWindow() [protected]
  • WindowCreated [protected]
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:20:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageWrapPad Member List

This is the complete list of members for vtkImageWrapPad, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExecuteInformation() [inline, protected, virtual]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputNumberOfScalarComponents() [virtual]
  • GetOutputs()
  • GetOutputWholeExtent(int extent[6])
  • GetOutputWholeExtent() [inline]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImageWrapPad &) (defined in vtkImageWrapPad) [private]
  • OutputNumberOfScalarComponents [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputNumberOfScalarComponents(int) [virtual]
  • SetOutputWholeExtent(int extent[6])
  • SetOutputWholeExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outRegion, int ext[6], int id) [protected, virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImagePadFilter() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkImageWrapPad() [inline, protected]
  • vtkImageWrapPad(const vtkImageWrapPad &) (defined in vtkImageWrapPad) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImageWrapPad, vtkImagePadFilter)
  • ~vtkImagePadFilter() [inline, protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkImageWrapPad() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:20:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImageWriter Member List

This is the complete list of members for vtkImageWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImageWriter &) (defined in vtkImageWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkImageWriter(const vtkImageWriter &) (defined in vtkImageWriter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkImageWriter, vtkProcessObject)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:20:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImagingFactory Member List

This is the complete list of members for vtkImagingFactory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateInstance(const char *vtkclassname) [static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkImagingFactory &) (defined in vtkImagingFactory) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImagingFactory() [inline, protected]
  • vtkImagingFactory(const vtkImagingFactory &) (defined in vtkImagingFactory) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImagingFactory, vtkObject)
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitBoolean Member List

This is the complete list of members for vtkImplicitBoolean, including all inherited members.
  • AddFunction(vtkImplicitFunction *in)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionList [protected]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFunction() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOperationType() [virtual]
  • GetOperationTypeAsString() [inline]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OperationType [protected]
  • operator=(const vtkImplicitBoolean &) (defined in vtkImplicitBoolean) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveFunction(vtkImplicitFunction *in)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetOperationType(int) [virtual]
  • SetOperationTypeToDifference() [inline]
  • SetOperationTypeToIntersection() [inline]
  • SetOperationTypeToUnion() [inline]
  • SetOperationTypeToUnionOfMagnitudes() [inline]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitBoolean() [protected]
  • vtkImplicitBoolean(const vtkImplicitBoolean &) (defined in vtkImplicitBoolean) [private]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitBoolean, vtkImplicitFunction)
  • ~vtkImplicitBoolean() [protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitDataSet Member List

This is the complete list of members for vtkImplicitDataSet, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOutGradient() [virtual]
  • GetOutGradient(float &, float &, float &) [virtual]
  • GetOutGradient(float[3]) [virtual]
  • GetOutValue() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImplicitDataSet &) (defined in vtkImplicitDataSet) [private]
  • OutGradient [protected]
  • OutValue [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetOutGradient(float, float, float) [virtual]
  • SetOutGradient(float[3]) [virtual]
  • SetOutValue(float) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitDataSet() [protected]
  • vtkImplicitDataSet(const vtkImplicitDataSet &) (defined in vtkImplicitDataSet) [private]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitDataSet, vtkImplicitFunction)
  • Weights [protected]
  • ~vtkImplicitDataSet() [protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitFunction Member List

This is the complete list of members for vtkImplicitFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3])=0 [pure virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3])=0 [pure virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkImplicitFunction &) (defined in vtkImplicitFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkImplicitFunction(const vtkImplicitFunction &) (defined in vtkImplicitFunction) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitFunction, vtkObject)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitFunctionCollection Member List

This is the complete list of members for vtkImplicitFunctionCollection, including all inherited members.
  • AddItem(vtkImplicitFunction *) [inline]
  • AddItem(vtkObject *o) (defined in vtkImplicitFunctionCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkImplicitFunctionCollection &) (defined in vtkImplicitFunctionCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkImplicitFunctionCollection() [inline, protected]
  • vtkImplicitFunctionCollection(const vtkImplicitFunctionCollection &) (defined in vtkImplicitFunctionCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitFunctionCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkImplicitFunctionCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitFunctionToImageStencil Member List

This is the complete list of members for vtkImplicitFunctionToImageStencil, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • vtkSource::GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImplicitFunctionToImageStencil &) [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImplicitFunction *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageStencilData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThreshold(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageStencilData *output, int extent[6], int threadId) [protected, virtual]
  • Threshold [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageStencilSource() [protected]
  • vtkImplicitFunctionToImageStencil() [protected]
  • vtkImplicitFunctionToImageStencil(const vtkImplicitFunctionToImageStencil &) (defined in vtkImplicitFunctionToImageStencil) [inline, private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImplicitFunctionToImageStencil, vtkImageStencilSource)
  • ~vtkImageStencilSource() [protected]
  • ~vtkImplicitFunctionToImageStencil() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:20:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitModeller Member List

This is the complete list of members for vtkImplicitModeller, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdjustBounds [protected]
  • AdjustBoundsOff() [virtual]
  • AdjustBoundsOn() [virtual]
  • AdjustDistance [protected]
  • Append(vtkDataSet *input)
  • BoundsComputed [protected]
  • BreakOnError() [static]
  • Cap(vtkDataArray *s) [protected]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CapValue [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeModelBounds(vtkDataSet *input=NULL)
  • DataAppended [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndAppend()
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAdjustBounds() [virtual]
  • GetAdjustDistance() [virtual]
  • GetCapping() [virtual]
  • GetCapValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocatorMaxLevel() [virtual]
  • GetMaximumDistance() [virtual]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProcessMode() [virtual]
  • GetProcessModeAsString(void)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalMaxDistance [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LocatorMaxLevel [protected]
  • MaximumDistance [protected]
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkImplicitModeller &) (defined in vtkImplicitModeller) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessMode [protected]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • SetAbortExecute(int) [virtual]
  • SetAdjustBounds(int) [virtual]
  • SetAdjustDistance(float) [virtual]
  • SetCapping(int) [virtual]
  • SetCapValue(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetLocatorMaxLevel(int) [virtual]
  • SetMaximumDistance(float) [virtual]
  • SetModelBounds(float, float, float, float, float, float) [virtual]
  • SetModelBounds(float[6]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkStructuredPoints *output)
  • SetProcessMode(int) [virtual]
  • SetProcessModeToPerCell() [inline]
  • SetProcessModeToPerVoxel() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartAppend()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkImplicitModeller() [protected]
  • vtkImplicitModeller(const vtkImplicitModeller &) (defined in vtkImplicitModeller) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkImplicitModeller, vtkDataSetToStructuredPointsFilter)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkImplicitModeller() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:20:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitSelectionLoop Member List

This is the complete list of members for vtkImplicitSelectionLoop, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AutomaticNormalGeneration [protected]
  • AutomaticNormalGenerationOff() [virtual]
  • AutomaticNormalGenerationOn() [virtual]
  • Bounds (defined in vtkImplicitSelectionLoop) [private]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaX (defined in vtkImplicitSelectionLoop) [private]
  • DeltaY (defined in vtkImplicitSelectionLoop) [private]
  • DeltaZ (defined in vtkImplicitSelectionLoop) [private]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetAutomaticNormalGeneration() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLoop() [virtual]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializationTime (defined in vtkImplicitSelectionLoop) [private]
  • Initialize() (defined in vtkImplicitSelectionLoop) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Loop [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • operator=(const vtkImplicitSelectionLoop &) (defined in vtkImplicitSelectionLoop) [private]
  • Origin (defined in vtkImplicitSelectionLoop) [private]
  • Polygon (defined in vtkImplicitSelectionLoop) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomaticNormalGeneration(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLoop(vtkPoints *) [virtual]
  • SetNormal(float, float, float) [virtual]
  • SetNormal(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkImplicitSelectionLoop() [protected]
  • vtkImplicitSelectionLoop(const vtkImplicitSelectionLoop &) (defined in vtkImplicitSelectionLoop) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitSelectionLoop, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkImplicitSelectionLoop() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitSum Member List

This is the complete list of members for vtkImplicitSum, including all inherited members.
  • AddFunction(vtkImplicitFunction *in, float weight)
  • AddFunction(vtkImplicitFunction *in) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CalculateTotalWeight(void) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionList [protected]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormalizeByWeight() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizeByWeight [protected]
  • NormalizeByWeightOff() [virtual]
  • NormalizeByWeightOn() [virtual]
  • operator=(const vtkImplicitSum &) (defined in vtkImplicitSum) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllFunctions()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFunctionWeight(vtkImplicitFunction *f, float weight)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormalizeByWeight(int) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • TotalWeight [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkImplicitSum() [protected]
  • vtkImplicitSum(const vtkImplicitSum &) (defined in vtkImplicitSum) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitSum, vtkImplicitFunction)
  • Weights [protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkImplicitSum() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitTextureCoords Member List

This is the complete list of members for vtkImplicitTextureCoords, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FlipTexture [protected]
  • FlipTextureOff() [virtual]
  • FlipTextureOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFlipTexture() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRFunction() [virtual]
  • GetSFunction() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTFunction() [virtual]
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkImplicitTextureCoords &) (defined in vtkImplicitTextureCoords) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RFunction [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFlipTexture(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRFunction(vtkImplicitFunction *) [virtual]
  • SetSFunction(vtkImplicitFunction *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTFunction(vtkImplicitFunction *) [virtual]
  • SFunction [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TFunction [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkImplicitTextureCoords() [protected]
  • vtkImplicitTextureCoords(const vtkImplicitTextureCoords &) (defined in vtkImplicitTextureCoords) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkImplicitTextureCoords, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkImplicitTextureCoords() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:20:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitVolume Member List

This is the complete list of members for vtkImplicitVolume, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOutGradient() [virtual]
  • GetOutGradient(float &, float &, float &) [virtual]
  • GetOutGradient(float[3]) [virtual]
  • GetOutValue() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GetVolume() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImplicitVolume &) (defined in vtkImplicitVolume) [private]
  • OutGradient [protected]
  • OutValue [protected]
  • PointIds [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetOutGradient(float, float, float) [virtual]
  • SetOutGradient(float[3]) [virtual]
  • SetOutValue(float) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SetVolume(vtkImageData *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Volume [protected]
  • vtkImplicitFunction() [protected]
  • vtkImplicitVolume() [protected]
  • vtkImplicitVolume(const vtkImplicitVolume &) (defined in vtkImplicitVolume) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitVolume, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkImplicitVolume() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImplicitWindowFunction Member List

This is the complete list of members for vtkImplicitWindowFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetImplicitFunction() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GetWindowRange() [virtual]
  • GetWindowRange(float data[2]) [virtual]
  • GetWindowValues() [virtual]
  • GetWindowValues(float data[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImplicitFunction [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkImplicitWindowFunction &) (defined in vtkImplicitWindowFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetImplicitFunction(vtkImplicitFunction *) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SetWindowRange(float, float) [virtual]
  • SetWindowRange(float[2])
  • SetWindowValues(float, float) [virtual]
  • SetWindowValues(float[2])
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkImplicitWindowFunction() [protected]
  • vtkImplicitWindowFunction(const vtkImplicitWindowFunction &) (defined in vtkImplicitWindowFunction) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImplicitWindowFunction, vtkImplicitFunction)
  • WindowRange [protected]
  • WindowValues [protected]
  • ~vtkImplicitFunction() [protected]
  • ~vtkImplicitWindowFunction() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkImporter Member List

This is the complete list of members for vtkImporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImportActors(vtkRenderer *vtkNotUsed(renderer)) [inline, protected, virtual]
  • ImportBegin() [inline, protected, virtual]
  • ImportCameras(vtkRenderer *vtkNotUsed(renderer)) [inline, protected, virtual]
  • ImportEnd() [inline, protected, virtual]
  • ImportLights(vtkRenderer *vtkNotUsed(renderer)) [inline, protected, virtual]
  • ImportProperties(vtkRenderer *vtkNotUsed(renderer)) [inline, protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkImporter &) (defined in vtkImporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Read()
  • ReadData() [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline]
  • vtkImporter() [protected]
  • vtkImporter(const vtkImporter &) (defined in vtkImporter) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkImporter, vtkObject)
  • ~vtkImporter() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIndent Member List

This is the complete list of members for vtkIndent, including all inherited members.
  • Delete() [inline]
  • GetClassName() [inline, virtual]
  • GetNextIndent()
  • Indent [protected]
  • New() [static]
  • operator<<(ostream &os, vtkIndent &o) [friend]
  • vtkIndent(int ind=0) [inline]
Generated on Mon Mar 25 01:20:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInitialValueProblemSolver Member List

This is the complete list of members for vtkInitialValueProblemSolver, including all inherited members.
  • Adaptive [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Derivs [protected]
  • ErrorCodes enum name
  • FunctionSet [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFunctionSet() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsAdaptive() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NOT_INITIALIZED enum value
  • operator=(const vtkInitialValueProblemSolver &) (defined in vtkInitialValueProblemSolver) [private]
  • OUT_OF_DOMAIN enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFunctionSet(vtkFunctionSet *functionset) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UNEXPECTED_VALUE enum value
  • UnRegister(vtkObject *o) [virtual]
  • Vals [protected]
  • vtkInitialValueProblemSolver() [protected]
  • vtkInitialValueProblemSolver(const vtkInitialValueProblemSolver &) (defined in vtkInitialValueProblemSolver) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInitialValueProblemSolver, vtkObject)
  • ~vtkInitialValueProblemSolver() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInputPort Member List

This is the complete list of members for vtkInputPort, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Controller [protected]
  • DATA_TRANSFER_TAG enum value
  • DataTime [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DoUpdateInformation [protected]
  • DOWN_DATA_TIME_TAG enum value
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetController() [inline]
  • GetDebug()
  • GetDoUpdateInformation() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImageDataOutput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int idx) [protected]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRemoteProcessId() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTag() [virtual]
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • INFORMATION_TRANSFER_TAG enum value
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NEW_DATA_TIME_TAG enum value
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkInputPort &) (defined in vtkInputPort) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *vtkNotUsed(output)) [inline]
  • vtkSource::PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoteProcessId [protected]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDoUpdateInformation(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRemoteProcessId(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTag(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tag [protected]
  • Tags enum name
  • TRANSFER_NEEDED_TAG enum value
  • TransferNeeded [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UPDATE_EXTENT_TAG enum value
  • UpdateData(vtkDataObject *out) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UpStreamMTime [protected]
  • vtkInputPort() [protected]
  • vtkInputPort(const vtkInputPort &) (defined in vtkInputPort) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkInputPort, vtkSource)
  • ~vtkInputPort() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInstantiator Member List

This is the complete list of members for vtkInstantiator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClassFinalize() [protected, static]
  • ClassInitialize() [protected, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateFunction typedef
  • CreateInstance(const char *className) [static]
  • CreatorTable [protected, static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkInstantiator &) (defined in vtkInstantiator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterInstantiator(const char *className, CreateFunction createFunction) [static]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterInstantiator(const char *className, CreateFunction createFunction) [static]
  • vtkInstantiator() [protected]
  • vtkInstantiator(const vtkInstantiator &) (defined in vtkInstantiator) [private]
  • vtkInstantiatorInitialize class [friend]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInstantiator, vtkObject)
  • ~vtkInstantiator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInstantiatorInitialize Member List

This is the complete list of members for vtkInstantiatorInitialize, including all inherited members.
  • Count (defined in vtkInstantiatorInitialize) [private, static]
  • vtkInstantiatorInitialize()
  • ~vtkInstantiatorInitialize()
Generated on Mon Mar 25 01:20:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIntArray Member List

This is the complete list of members for vtkIntArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *ia) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const int i) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const int i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkIntArray &) (defined in vtkIntArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(int *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const int value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkIntArray(vtkIdType numComp=1) [protected]
  • vtkIntArray(const vtkIntArray &) (defined in vtkIntArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIntArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkIntArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyle Member List

This is the complete list of members for vtkInteractorStyle, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnTimer() [virtual]
  • operator=(const vtkInteractorStyle &) (defined in vtkInteractorStyle) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyle(const vtkInteractorStyle &) (defined in vtkInteractorStyle) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyle, vtkObject)
  • ~vtkInteractorStyle() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleFlight Member List

This is the complete list of members for vtkInteractorStyleFlight, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AngleAccelerationFactor [protected]
  • AngleStepSize [protected]
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • AzimuthScan(void) [protected]
  • AzimuthScanning [protected]
  • AzimuthStepSize [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeLRVector(double vector[3]) [protected]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DiagonalLength [protected]
  • DisableMotion [protected]
  • DisableMotionOff() [virtual]
  • DisableMotionOn() [virtual]
  • DollyCamera(int x, int y) [protected, virtual]
  • DoTimerStart(void) [protected]
  • DoTimerStop(void) [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FixedUpVector [protected]
  • FixUpVector [protected]
  • FixUpVectorOff() [virtual]
  • FixUpVectorOn() [virtual]
  • FlyByKey(void) [protected]
  • FlyByMouse(void) [protected]
  • Flying [protected]
  • FocalDepth [protected]
  • GetAngleAccelerationFactor() [virtual]
  • GetAngleStepSize() [virtual]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisableMotion() [virtual]
  • GetFixedUpVector() [virtual]
  • GetFixedUpVector(double data[3]) [virtual]
  • GetFixUpVector() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMotionAccelerationFactor() [virtual]
  • GetMotionStepSize() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • JumpTo(double campos[3], double focpos[3])
  • KeysDown [protected]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionAccelerationFactor [protected]
  • MotionAlongVector(double vector[3], double amount) [protected]
  • MotionStepSize [protected]
  • MotionUserScale [protected]
  • MTime [protected]
  • New() [static]
  • OldX [protected]
  • OldY [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnTimer(void) [virtual]
  • operator=(const vtkInteractorStyleFlight &) (defined in vtkInteractorStyleFlight) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PerformAzimuthalScan(int numsteps)
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • PitchAngle [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • Reversing [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAngleAccelerationFactor(double) [virtual]
  • SetAngleStepSize(double) [virtual]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisableMotion(int) [virtual]
  • SetFixedUpVector(double data[]) [virtual]
  • SetFixUpVector(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMotionAccelerationFactor(double) [virtual]
  • SetMotionStepSize(double) [virtual]
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetupMotionVars(void) [protected]
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • TimerRunning [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • UpdateMouseSteering(int x, int y) [protected]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleFlight() [protected]
  • vtkInteractorStyleFlight(const vtkInteractorStyleFlight &) (defined in vtkInteractorStyleFlight) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleFlight, vtkInteractorStyle)
  • X2 [protected]
  • Y2 [protected]
  • YawAngle [protected]
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleFlight() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:20:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleImage Member List

This is the complete list of members for vtkInteractorStyleImage, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • DollyXY(int dx, int dy) [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetWindowLevelCurrentPosition() [virtual]
  • GetWindowLevelCurrentPosition(int &, int &) [virtual]
  • GetWindowLevelCurrentPosition(int[2]) [virtual]
  • GetWindowLevelStartPosition() [virtual]
  • GetWindowLevelStartPosition(int &, int &) [virtual]
  • GetWindowLevelStartPosition(int[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MTime [protected]
  • New() [static]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMouseMove(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnTimer() [virtual]
  • operator=(const vtkInteractorStyleImage &) (defined in vtkInteractorStyleImage) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PanXY(int x, int y, int oldX, int oldY) [protected]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • RadianToDegree [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • SpinXY(int dx, int dy, int oldX, int oldY) [protected]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleImage() [protected]
  • vtkInteractorStyleImage(const vtkInteractorStyleImage &) (defined in vtkInteractorStyleImage) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleImage, vtkInteractorStyle)
  • WindowLevelCurrentPosition [protected]
  • WindowLevelStartPosition [protected]
  • WindowLevelXY(int dx, int dy) [protected]
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleImage() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:21:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleJoystickActor Member List

This is the complete list of members for vtkInteractorStyleJoystickActor, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DispObjCenter [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • DollyXY(int x, int y) [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPickedActor(int x, int y) [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • InteractionPicker [protected]
  • InteractionProp [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MotionVector [protected]
  • MTime [protected]
  • New() [static]
  • NewPickPoint [protected]
  • ObjCenter [protected]
  • OldPickPoint [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMouseMove(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnTimer(void) [virtual]
  • operator=(const vtkInteractorStyleJoystickActor &) (defined in vtkInteractorStyleJoystickActor) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PanXY(int x, int y) [protected]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • Prop3DTransform(vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale) [protected]
  • Prop3DTransform(vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale) [protected]
  • PropPicked [protected]
  • RadianToDegree [protected]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • RotateXY(int x, int y) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleXY(int x, int y) [protected]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • SpinXY(int x, int y) [protected]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • ViewFocus [protected]
  • ViewLook [protected]
  • ViewPoint [protected]
  • ViewRight [protected]
  • ViewUp [protected]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleJoystickActor() [protected]
  • vtkInteractorStyleJoystickActor(const vtkInteractorStyleJoystickActor &) (defined in vtkInteractorStyleJoystickActor) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleJoystickActor, vtkObject)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleJoystickActor() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:21:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleJoystickCamera Member List

This is the complete list of members for vtkInteractorStyleJoystickCamera, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MTime [protected]
  • New() [static]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMouseMove(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnTimer(void) [virtual]
  • operator=(const vtkInteractorStyleJoystickCamera &) (defined in vtkInteractorStyleJoystickCamera) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleJoystickCamera() [protected]
  • vtkInteractorStyleJoystickCamera(const vtkInteractorStyleJoystickCamera &) (defined in vtkInteractorStyleJoystickCamera) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleJoystickCamera, vtkObject)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleJoystickCamera() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:21:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleSwitch Member List

This is the complete list of members for vtkInteractorStyleSwitch, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • CameraOrActor [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • CurrentStyle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCurrentStyle() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • JoystickActor [protected]
  • JoystickCamera [protected]
  • JoystickOrTrackball [protected]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnTimer() [virtual]
  • operator=(const vtkInteractorStyleSwitch &) (defined in vtkInteractorStyleSwitch) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int value) [virtual]
  • SetCurrentStyle() [protected]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *iren) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • TrackballActor [protected]
  • TrackballCamera [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleSwitch() [protected]
  • vtkInteractorStyleSwitch(const vtkInteractorStyleSwitch &) (defined in vtkInteractorStyleSwitch) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleSwitch, vtkInteractorStyle)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleSwitch() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:21:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleTrackball Member List

This is the complete list of members for vtkInteractorStyleTrackball, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • ControlMode [protected]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DispObjCenter [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPickedActor(int X, int Y) [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetActorMode() [virtual]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetTrackballMode() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • InteractionPicker [protected]
  • InteractionProp [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • JoystickDollyActor(int x, int y) [protected, virtual]
  • JoystickPanActor(int x, int y) [protected, virtual]
  • JoystickRotateActor(int x, int y) [protected, virtual]
  • JoystickScaleActor(int x, int y) [protected, virtual]
  • JoystickSpinActor(int x, int y) [protected, virtual]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MotionVector [protected]
  • MTime [protected]
  • New() [static]
  • NewPickPoint [protected]
  • ObjCenter [protected]
  • OldPickPoint [protected]
  • OldX [protected]
  • OldY [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnTimer(void) [virtual]
  • operator=(const vtkInteractorStyleTrackball &) (defined in vtkInteractorStyleTrackball) [private]
  • Origin [protected]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Position [protected]
  • Preprocess [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • Prop3DTransform(vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale) [protected]
  • Prop3DTransform(vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale) [protected]
  • PropPicked [protected]
  • RadianToDegree [protected]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetActorModeToActor() [virtual]
  • SetActorModeToCamera() [virtual]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetTrackballModeToJoystick() [virtual]
  • SetTrackballModeToTrackball() [virtual]
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • TrackballDollyActor(int x, int y) [protected, virtual]
  • TrackballDollyCamera(int x, int y) [protected, virtual]
  • TrackballMode [protected]
  • TrackballPanActor(int x, int y) [protected, virtual]
  • TrackballPanCamera(int x, int y) [protected, virtual]
  • TrackballRotateActor(int x, int y) [protected, virtual]
  • TrackballRotateCamera(int x, int y) [protected, virtual]
  • TrackballScaleActor(int x, int y) [protected, virtual]
  • TrackballSpinActor(int x, int y) [protected, virtual]
  • TrackballSpinCamera(int x, int y) [protected, virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • ViewFocus [protected]
  • ViewLook [protected]
  • ViewPoint [protected]
  • ViewRight [protected]
  • ViewUp [protected]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleTrackball() [protected]
  • vtkInteractorStyleTrackball(const vtkInteractorStyleTrackball &) (defined in vtkInteractorStyleTrackball) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleTrackball, vtkInteractorStyle)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleTrackball() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:21:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleTrackballActor Member List

This is the complete list of members for vtkInteractorStyleTrackballActor, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DispObjCenter [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • DollyXY(int dx, int dy) [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPickedActor(int x, int y) [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • InteractionPicker [protected]
  • InteractionProp [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MotionVector [protected]
  • MTime [protected]
  • New() [static]
  • NewPickPoint [protected]
  • ObjCenter [protected]
  • OldPickPoint [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMouseMove(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnTimer() [virtual]
  • operator=(const vtkInteractorStyleTrackballActor &) (defined in vtkInteractorStyleTrackballActor) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PanXY(int x, int y, int oldX, int oldY) [protected]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • Prop3DTransform(vtkProp3D *prop3D, double *boxCenter, int numRotation, double **rotate, double *scale) [protected]
  • Prop3DTransform(vtkProp3D *prop3D, float *boxCenter, int NumRotation, double **rotate, double *scale) [protected]
  • PropPicked [protected]
  • RadianToDegree [protected]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • RotateXY(int x, int y, int oldX, int oldY) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleXY(int x, int y, int oldX, int oldY) [protected]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • SpinXY(int dx, int dy, int oldX, int oldY) [protected]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • ViewFocus [protected]
  • ViewLook [protected]
  • ViewPoint [protected]
  • ViewRight [protected]
  • ViewUp [protected]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleTrackballActor() [protected]
  • vtkInteractorStyleTrackballActor(const vtkInteractorStyleTrackballActor &) (defined in vtkInteractorStyleTrackballActor) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleTrackballActor, vtkObject)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleTrackballActor() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleTrackballCamera Member List

This is the complete list of members for vtkInteractorStyleTrackballCamera, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • DollyXY(int dx, int dy) [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MotionFactor [protected]
  • MTime [protected]
  • New() [static]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnMouseMove(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int x, int y) [virtual]
  • OnRightButtonUp(int ctrl, int shift, int x, int y) [virtual]
  • OnTimer() [virtual]
  • operator=(const vtkInteractorStyleTrackballCamera &) (defined in vtkInteractorStyleTrackballCamera) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PanXY(int x, int y, int oldX, int oldY) [protected]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • RadianToDegree [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • RotateXY(int dx, int dy) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • SpinXY(int dx, int dy, int oldX, int oldY) [protected]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleTrackballCamera() [protected]
  • vtkInteractorStyleTrackballCamera(const vtkInteractorStyleTrackballCamera &) (defined in vtkInteractorStyleTrackballCamera) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleTrackballCamera, vtkObject)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleTrackballCamera() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleUnicam Member List

This is the complete list of members for vtkInteractorStyleUnicam, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • ButtonDown [protected]
  • Center [protected]
  • Choose(int X, int Y) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • Dist [protected]
  • Dolly(int X, int Y) [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • DownPt [protected]
  • DTime [protected]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndZoom() [protected, virtual]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • FocusSphere [protected]
  • FocusSphereRenderer [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetMTime() [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetRightVandUpV(float *p, vtkCamera *cam, float *rightV, float *upV) [protected]
  • GetWorldUpVector() [virtual]
  • GetWorldUpVector(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • InteractionPicker [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsDot [protected]
  • IsTypeOf(const char *name) [static]
  • LastPix [protected]
  • LastPos [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MyRotateCamera(float cx, float cy, float cz, float ax, float ay, float az, float angle) [protected]
  • MyTranslateCamera(float v[3]) [protected]
  • New() [static]
  • NormalizeMouseXY(int X, int Y, float *NX, float *NY) [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnConfigure(int width, int height) [virtual]
  • OnEnter(int ctrl, int shift, int x, int y) [virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int x, int y) [virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnMiddleButtonMove(int, int, int, int) [inline, virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [virtual]
  • OnRightButtonMove(int, int, int, int) [inline, virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [virtual]
  • OnTimer(void) [virtual]
  • operator=(const vtkInteractorStyleUnicam &) (defined in vtkInteractorStyleUnicam) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • Pan(int X, int Y) [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • Rotate(int X, int Y) [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *interactor) [virtual]
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetWorldUpVector(double a[3]) [inline]
  • SetWorldUpVector(float a[3]) [inline]
  • SetWorldUpVector(float x, float y, float z)
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartPix [protected]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartZoom() [protected, virtual]
  • state [protected]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleUnicam() [protected]
  • vtkInteractorStyleUnicam(const vtkInteractorStyleUnicam &) (defined in vtkInteractorStyleUnicam) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleUnicam, vtkInteractorStyle)
  • WindowAspect() [protected]
  • WorldUpVector [protected]
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleUnicam() [protected, virtual]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInteractorStyleUser Member List

This is the complete list of members for vtkInteractorStyleUser, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AnimState [protected]
  • AutoAdjustCameraClippingRange [protected]
  • AutoAdjustCameraClippingRangeOff() [virtual]
  • AutoAdjustCameraClippingRangeOn() [virtual]
  • BreakOnError() [static]
  • Button [protected]
  • CameraOrActor [protected]
  • Center [protected]
  • Char [protected]
  • CharTag [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, double *worldPt) [protected, virtual]
  • ComputeDisplayToWorld(double x, double y, double z, float *worldPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, double *displayPt) [protected, virtual]
  • ComputeWorldToDisplay(double x, double y, double z, float *displayPt) [protected, virtual]
  • ConfigureTag [protected]
  • CtrlKey [protected]
  • CurrentCamera [protected]
  • CurrentLight [protected]
  • CurrentProp [protected]
  • CurrentRenderer [protected]
  • CurrentStyle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaAzimuth [protected]
  • DeltaElevation [protected]
  • DollyCamera(int x, int y) [protected, virtual]
  • EndDolly() [protected, virtual]
  • EndPan() [protected, virtual]
  • EndRotate() [protected, virtual]
  • EndSpin() [protected, virtual]
  • EndTimer() [protected, virtual]
  • EndUniformScale() [protected, virtual]
  • EndUserInteraction()
  • EndZoom() [protected, virtual]
  • EnterTag [protected]
  • EventCallbackCommand [protected]
  • FindPokedCamera(int, int)
  • FindPokedRenderer(int, int)
  • FocalDepth [protected]
  • GetAutoAdjustCameraClippingRange() [virtual]
  • GetButton() [virtual]
  • GetChar() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCtrlKey() [virtual]
  • GetCurrentStyle() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHandleObservers() [protected, virtual]
  • GetInteractor() [virtual]
  • GetKeySym() [virtual]
  • GetLastPos() [virtual]
  • GetLastPos(int &, int &) [virtual]
  • GetLastPos(int[2]) [virtual]
  • GetMTime() [virtual]
  • GetOldPos() [virtual]
  • GetOldPos(int &, int &) [virtual]
  • GetOldPos(int[2]) [virtual]
  • GetPickColor() [virtual]
  • GetPickColor(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetShiftKey() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HandleObservers [protected]
  • HandleObserversOff() [protected, virtual]
  • HandleObserversOn() [protected, virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HighlightActor2D(vtkActor2D *actor2D) [virtual]
  • HighlightProp(vtkProp *prop) [virtual]
  • HighlightProp3D(vtkProp3D *prop3D) [virtual]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • JoystickActor [protected]
  • JoystickCamera [protected]
  • JoystickOrTrackball [protected]
  • KeyPressTag [protected]
  • KeyReleaseTag [protected]
  • KeySym [protected]
  • LastPos [protected]
  • LeaveTag [protected]
  • LeftButtonPressTag [protected]
  • LeftButtonReleaseTag [protected]
  • MiddleButtonPressTag [protected]
  • MiddleButtonReleaseTag [protected]
  • Modified() [virtual]
  • MouseMoveTag [protected]
  • MTime [protected]
  • New() [static]
  • OldPos [protected]
  • OnChar(int ctrl, int shift, char keycode, int repeatcount) [protected, virtual]
  • OnConfigure(int width, int height) [protected, virtual]
  • OnEnter(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnKeyDown(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnKeyPress(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [protected, virtual]
  • OnKeyRelease(int ctrl, int shift, char keycode, char *keysym, int repeatcount) [protected, virtual]
  • OnKeyUp(int ctrl, int shift, char keycode, int repeatcount) [virtual]
  • OnLeave(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnLeftButtonDown(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnLeftButtonUp(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnMiddleButtonDown(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnMiddleButtonUp(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnMouseMove(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnRightButtonDown(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnRightButtonUp(int ctrl, int shift, int X, int Y) [protected, virtual]
  • OnTimer(void) [protected, virtual]
  • operator=(const vtkInteractorStyleUser &) (defined in vtkInteractorStyleUser) [private]
  • Outline [protected]
  • OutlineActor [protected]
  • OutlineMapper [protected]
  • PanCamera(int x, int y) [protected, virtual]
  • PickColor [protected]
  • PickedActor2D [protected]
  • PickedRenderer [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessEvents(vtkObject *object, unsigned long event, void *clientdata, void *calldata) [protected, static]
  • PropPicked [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetCameraClippingRange() [protected]
  • RightButtonPressTag [protected]
  • RightButtonReleaseTag [protected]
  • RotateCamera(int x, int y) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutoAdjustCameraClippingRange(int value) [virtual]
  • SetButtonPressMethod(void(*f)(void *), void *arg)
  • SetButtonPressMethodArgDelete(void(*f)(void *))
  • SetButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetCharMethod(void(*f)(void *), void *arg)
  • SetCharMethodArgDelete(void(*f)(void *))
  • SetConfigureMethod(void(*f)(void *), void *arg)
  • SetConfigureMethodArgDelete(void(*f)(void *))
  • SetCurrentStyle() [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEnterMethod(void(*f)(void *), void *arg)
  • SetEnterMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetHandleObservers(int) [protected, virtual]
  • SetInteractor(vtkRenderWindowInteractor *iren) [virtual]
  • SetKeyPressMethod(void(*f)(void *), void *arg)
  • SetKeyPressMethodArgDelete(void(*f)(void *))
  • SetKeyReleaseMethod(void(*f)(void *), void *arg)
  • SetKeyReleaseMethodArgDelete(void(*f)(void *))
  • SetLeaveMethod(void(*f)(void *), void *arg)
  • SetLeaveMethodArgDelete(void(*f)(void *))
  • SetLeftButtonPressMethod(void(*f)(void *), void *arg)
  • SetLeftButtonPressMethodArgDelete(void(*f)(void *))
  • SetLeftButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetLeftButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonPressMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonPressMethodArgDelete(void(*f)(void *))
  • SetMiddleButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetMiddleButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetMouseMoveMethod(void(*f)(void *), void *arg)
  • SetMouseMoveMethodArgDelete(void(*f)(void *))
  • SetPickColor(float, float, float) [virtual]
  • SetPickColor(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetRightButtonPressMethod(void(*f)(void *), void *arg)
  • SetRightButtonPressMethodArgDelete(void(*f)(void *))
  • SetRightButtonReleaseMethod(void(*f)(void *), void *arg)
  • SetRightButtonReleaseMethodArgDelete(void(*f)(void *))
  • SetTimerMethod(void(*f)(void *), void *arg)
  • SetTimerMethodArgDelete(void(*f)(void *))
  • SetUserInteractionMethod(void(*f)(void *), void *arg)
  • SetUserInteractionMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • SpinCamera(int x, int y) [protected, virtual]
  • StartAnimate() [protected, virtual]
  • StartDolly() [protected, virtual]
  • StartPan() [protected, virtual]
  • StartRotate() [protected, virtual]
  • StartSpin() [protected, virtual]
  • StartState(int newstate) [protected, virtual]
  • StartTimer() [protected, virtual]
  • StartUniformScale() [protected, virtual]
  • StartUserInteraction()
  • StartZoom() [protected, virtual]
  • State [protected]
  • StopAnimate() [protected, virtual]
  • StopState() [protected, virtual]
  • SubjectHelper [protected]
  • TimerTag [protected]
  • TrackballActor [protected]
  • TrackballCamera [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateInternalState(int ctrl, int shift, int X, int Y) [protected, virtual]
  • UserTag [protected]
  • vtkInteractorStyle() [protected]
  • vtkInteractorStyleSwitch() [protected]
  • vtkInteractorStyleUser() [protected]
  • vtkInteractorStyleUser(const vtkInteractorStyleUser &) (defined in vtkInteractorStyleUser) [private]
  • vtkObject() [protected]
  • vtkSetOldCallback(unsigned long &tag, unsigned long event, void(*f)(void *), void *arg) [protected]
  • vtkSetOldDelete(unsigned long tag, void(*f)(void *)) [protected]
  • vtkTypeRevisionMacro(vtkInteractorStyleUser, vtkInteractorStyleSwitch)
  • ~vtkInteractorStyle() [protected]
  • ~vtkInteractorStyleSwitch() [protected]
  • ~vtkInteractorStyleUser() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInterpolateDataSetAttributes Member List

This is the complete list of members for vtkInterpolateDataSetAttributes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataSet *in)
  • AddInput(vtkDataObject *) (defined in vtkInterpolateDataSetAttributes) [inline, private, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputList()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetT() [virtual]
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputList [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkInterpolateDataSetAttributes &) (defined in vtkInterpolateDataSetAttributes) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) (defined in vtkInterpolateDataSetAttributes) [inline, private, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetT(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • T [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkInterpolateDataSetAttributes() [protected]
  • vtkInterpolateDataSetAttributes(const vtkInterpolateDataSetAttributes &) (defined in vtkInterpolateDataSetAttributes) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkInterpolateDataSetAttributes, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkInterpolateDataSetAttributes() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:22:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInterpolatedVelocityField Member List

This is the complete list of members for vtkInterpolatedVelocityField, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CacheHit [protected]
  • CacheMiss [protected]
  • Caching [protected]
  • CachingOff() [virtual]
  • CachingOn() [virtual]
  • Cell [protected]
  • ClearLastCellId() [inline]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionValues(float *x, float *f) [virtual]
  • GenCell [protected]
  • GetCacheHit() [virtual]
  • GetCacheMiss() [virtual]
  • GetCaching() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLastCellId() [virtual]
  • GetLastLocalCoordinates(float pcoords[3])
  • GetLastWeights(float *w)
  • GetMTime() [virtual]
  • GetNumberOfFunctions() [inline, virtual]
  • GetNumberOfIndependentVariables() [inline, virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastCellId [protected]
  • LastPCoords [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumFuncs [protected]
  • NumIndepVars [protected]
  • operator=(const vtkInterpolatedVelocityField &) (defined in vtkInterpolatedVelocityField) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetCaching(int) [virtual]
  • SetDataSet(vtkDataSet *dataset) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLastCellId(vtkIdType) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkFunctionSet() [protected]
  • vtkInterpolatedVelocityField() [protected]
  • vtkInterpolatedVelocityField(const vtkInterpolatedVelocityField &) (defined in vtkInterpolatedVelocityField) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkInterpolatedVelocityField, vtkFunctionSet)
  • Weights [protected]
  • ~vtkFunctionSet() [inline, protected]
  • ~vtkInterpolatedVelocityField() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkInterpolatingSubdivisionFilter Member List

This is the complete list of members for vtkInterpolatingSubdivisionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindEdge(vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds) [protected]
  • GenerateSubdivisionCells(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD) [protected]
  • GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD)=0 [protected, pure virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSubdivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolatePosition(vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubdivisions [protected]
  • operator=(const vtkInterpolatingSubdivisionFilter &) (defined in vtkInterpolatingSubdivisionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSubdivisions(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkInterpolatingSubdivisionFilter() [protected]
  • vtkInterpolatingSubdivisionFilter(const vtkInterpolatingSubdivisionFilter &) (defined in vtkInterpolatingSubdivisionFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkInterpolatingSubdivisionFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkInterpolatingSubdivisionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:22:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIterativeClosestPointTransform Member List

This is the complete list of members for vtkIterativeClosestPointTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CheckMeanDistance [protected]
  • CheckMeanDistanceOff() [virtual]
  • CheckMeanDistanceOn() [virtual]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateDefaultLocator(void) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetCheckMeanDistance() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInverse()
  • GetLandmarkTransform() [virtual]
  • GetLinearInverse() [inline]
  • GetLocator() [virtual]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMaximumMeanDistance() [virtual]
  • GetMaximumNumberOfIterations() [virtual]
  • GetMaximumNumberOfLandmarks() [virtual]
  • GetMeanDistance() [virtual]
  • GetMeanDistanceMode() [virtual]
  • GetMeanDistanceModeAsString()
  • GetMTime() [protected, virtual]
  • GetNumberOfIterations() [virtual]
  • GetReferenceCount() [inline]
  • GetSource() [virtual]
  • GetStartByMatchingCentroids() [virtual]
  • GetTarget() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LandmarkTransform [protected]
  • Locator [protected]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • MaximumMeanDistance [protected]
  • MaximumNumberOfIterations [protected]
  • MaximumNumberOfLandmarks [protected]
  • MeanDistance [protected]
  • MeanDistanceMode [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfIterations [protected]
  • operator=(const vtkIterativeClosestPointTransform &) (defined in vtkIterativeClosestPointTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseLocator(void) [protected]
  • ReleaseSource(void) [protected]
  • ReleaseTarget(void) [protected]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetCheckMeanDistance(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetLocator(vtkCellLocator *locator)
  • SetMaximumMeanDistance(float) [virtual]
  • SetMaximumNumberOfIterations(int) [virtual]
  • SetMaximumNumberOfLandmarks(int) [virtual]
  • SetMeanDistanceMode(int) [virtual]
  • SetMeanDistanceModeToAbsoluteValue() [inline]
  • SetMeanDistanceModeToRMS() [inline]
  • SetReferenceCount(int)
  • SetSource(vtkDataSet *source)
  • SetStartByMatchingCentroids(int) [virtual]
  • SetTarget(vtkDataSet *target)
  • Source [protected]
  • StartByMatchingCentroids [protected]
  • StartByMatchingCentroidsOff() [virtual]
  • StartByMatchingCentroidsOn() [virtual]
  • SubjectHelper [protected]
  • Target [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkIterativeClosestPointTransform() [protected]
  • vtkIterativeClosestPointTransform(const vtkIterativeClosestPointTransform &) (defined in vtkIterativeClosestPointTransform) [private]
  • vtkLinearTransform() [inline, protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIterativeClosestPointTransform, vtkLinearTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkIterativeClosestPointTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIVExporter Member List

This is the complete list of members for vtkIVExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • FileName [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkIVExporter &) (defined in vtkIVExporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkIVExporter() [protected]
  • vtkIVExporter(const vtkIVExporter &) (defined in vtkIVExporter) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkIVExporter, vtkExporter)
  • Write() [virtual]
  • WriteALight(vtkLight *aLight, FILE *fp) [protected]
  • WriteAnActor(vtkActor *anActor, FILE *fp) [protected]
  • WriteData() [protected, virtual]
  • WritePointData(vtkPoints *points, vtkDataArray *normals, vtkDataArray *tcoords, vtkUnsignedCharArray *colors, FILE *fp) [protected]
  • ~vtkExporter() [protected]
  • ~vtkIVExporter() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkIVWriter Member List

This is the complete list of members for vtkIVWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkIVWriter &) (defined in vtkIVWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkIVWriter() [inline, protected]
  • vtkIVWriter(const vtkIVWriter &) (defined in vtkIVWriter) [private]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkIVWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WritePolyData(vtkPolyData *polyData, FILE *fp) [protected]
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkIVWriter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkJavaCommand Member List

This is the complete list of members for vtkJavaCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • AssignJavaVM(JNIEnv *env) [inline]
  • CharEvent enum value
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *, unsigned long, void *) [virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • mid
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • New() [inline, static]
  • NextDataEvent enum value
  • NoEvent enum value
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetGlobalRef(jobject obj) [inline]
  • SetMethodID(jmethodID id) [inline]
  • SetOutputEvent enum value
  • StartEvent enum value
  • StartPickEvent enum value
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • uobj
  • UserEvent enum value
  • vm
  • vtkCommand() [inline, protected]
  • vtkJavaCommand() [protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCommand() [inline, protected, virtual]
  • ~vtkJavaCommand() [protected]
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkJPEGReader Member List

This is the complete list of members for vtkJPEGReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname)
  • vtkImageReader2::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkJPEGReader &) (defined in vtkJPEGReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkJPEGReader() [inline, protected]
  • vtkJPEGReader(const vtkJPEGReader &) (defined in vtkJPEGReader) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkJPEGReader, vtkImageReader2)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkJPEGReader() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:22:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkJPEGWriter Member List

This is the complete list of members for vtkJPEGWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressive() [virtual]
  • GetProgressText() [virtual]
  • GetQuality() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkJPEGWriter &) (defined in vtkJPEGWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • Progressive (defined in vtkJPEGWriter) [private]
  • ProgressiveOff() [virtual]
  • ProgressiveOn() [virtual]
  • ProgressTag [protected]
  • ProgressText [protected]
  • Quality (defined in vtkJPEGWriter) [private]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressive(unsigned int) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQuality(int) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkJPEGWriter() [protected]
  • vtkJPEGWriter(const vtkJPEGWriter &) (defined in vtkJPEGWriter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkJPEGWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteSlice(vtkImageData *data) [protected]
  • ~vtkImageWriter() [protected]
  • ~vtkJPEGWriter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:22:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkKitwareContourFilter Member List

This is the complete list of members for vtkKitwareContourFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *data) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • DataSetContour() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarTree() [virtual]
  • GetUseScalarTree() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkKitwareContourFilter &) (defined in vtkKitwareContourFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTree [protected]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarTree(vtkScalarTree *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseScalarTree(int) [virtual]
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredGridContour(int dim) [protected]
  • StructuredPointsContour(int dim) [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseScalarTree [protected]
  • UseScalarTreeOff() [virtual]
  • UseScalarTreeOn() [virtual]
  • vtkContourFilter() [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkKitwareContourFilter() [protected]
  • vtkKitwareContourFilter(const vtkKitwareContourFilter &) (defined in vtkKitwareContourFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkKitwareContourFilter, vtkContourFilter)
  • ~vtkContourFilter() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkKitwareContourFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:22:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkKitwareObjectFactory Member List

This is the complete list of members for vtkKitwareObjectFactory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateAllInstance(const char *vtkclassname, vtkCollection *retList) [static]
  • CreateFunction typedef
  • CreateInstance(const char *vtkclassname) [static]
  • CreateObject(const char *vtkclassname) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Disable(const char *className) [virtual]
  • GetClassName() [inline, virtual]
  • GetClassOverrideName(int index) [virtual]
  • GetClassOverrideWithName(int index) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDescription()=0 [pure virtual]
  • GetEnableFlag(int index) [virtual]
  • GetEnableFlag(const char *className, const char *subclassName) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLibraryPath() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfOverrides() [virtual]
  • GetOverrideDescription(int index) [virtual]
  • GetOverrideInformation(const char *name, vtkOverrideInformationCollection *) [static]
  • GetReferenceCount() [inline]
  • GetRegisteredFactories() [static]
  • GetVTKSourceVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HasOverride(const char *className) [virtual]
  • HasOverride(const char *className, const char *subclassName) [virtual]
  • HasOverrideAny(const char *className) [static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkKitwareObjectFactory &) (defined in vtkKitwareObjectFactory) [private]
  • OverrideArray [protected]
  • OverrideArrayLength [protected]
  • OverrideClassNames [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterFactory(vtkObjectFactory *) [static]
  • RegisterOverride(const char *classOverride, const char *overrideClassName, const char *description, int enableFlag, CreateFunction createFunction) [protected]
  • ReHash() [static]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAllEnableFlags(int flag, const char *className) [static]
  • SetAllEnableFlags(int flag, const char *className, const char *subclassName) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEnableFlag(int flag, const char *className, const char *subclassName) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SizeOverrideArray [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllFactories() [static]
  • UnRegisterFactory(vtkObjectFactory *) [static]
  • vtkKitwareObjectFactory() [inline, protected]
  • vtkKitwareObjectFactory(const vtkKitwareObjectFactory &) (defined in vtkKitwareObjectFactory) [private]
  • vtkObject() [protected]
  • vtkObjectFactory() [protected]
  • vtkTypeRevisionMacro(vtkKitwareObjectFactory, vtkObjectFactory)
  • ~vtkObject() [protected, virtual]
  • ~vtkObjectFactory() [protected]
Generated on Mon Mar 25 01:22:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkKochanekSpline Member List

This is the complete list of members for vtkKochanekSpline, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPoint(float t, float x)
  • BreakOnError() [static]
  • ClampValue [protected]
  • ClampValueOff() [virtual]
  • ClampValueOn() [virtual]
  • Closed [protected]
  • ClosedOff() [virtual]
  • ClosedOn() [virtual]
  • Coefficients [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Compute() [virtual]
  • ComputeTime [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultBias [protected]
  • DefaultContinuity [protected]
  • DefaultTension [protected]
  • Delete() [virtual]
  • Evaluate(float t)
  • Fit1D(int n, float *x, float *y, float tension, float bias, float continuity, float coefficients[][4], int leftConstraint, float leftValue, int rightConstraint, float rightValue) [protected]
  • GetClampValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetClosed() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultBias() [virtual]
  • GetDefaultContinuity() [virtual]
  • GetDefaultTension() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLeftConstraint() [virtual]
  • GetLeftValue() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRightConstraint() [virtual]
  • GetRightValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intervals [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftConstraint [protected]
  • LeftValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkKochanekSpline &) (defined in vtkKochanekSpline) [private]
  • PiecewiseFunction [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllPoints()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePoint(float t)
  • RightConstraint [protected]
  • RightValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetClampValue(int) [virtual]
  • SetClosed(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultBias(float) [virtual]
  • SetDefaultContinuity(float) [virtual]
  • SetDefaultTension(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLeftConstraint(int) [virtual]
  • SetLeftValue(float) [virtual]
  • SetReferenceCount(int)
  • SetRightConstraint(int) [virtual]
  • SetRightValue(float) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkKochanekSpline() [protected]
  • vtkKochanekSpline(const vtkKochanekSpline &) (defined in vtkKochanekSpline) [private]
  • vtkObject() [protected]
  • vtkSpline() [protected]
  • vtkTypeRevisionMacro(vtkKochanekSpline, vtkSpline)
  • ~vtkKochanekSpline() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSpline() [protected]
Generated on Mon Mar 25 01:22:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLabeledDataMapper Member List

This is the complete list of members for vtkLabeledDataMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FieldDataArray [protected]
  • FontFamily [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFieldDataArray() [virtual]
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetLabeledComponent() [virtual]
  • GetLabelFormat() [virtual]
  • GetLabelMode() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetTimeToDraw() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabeledComponent [protected]
  • LabelFormat [protected]
  • LabelMode [protected]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLabels (defined in vtkLabeledDataMapper) [private]
  • NumberOfLabelsAllocated (defined in vtkLabeledDataMapper) [private]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkLabeledDataMapper &) (defined in vtkLabeledDataMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataArray(int) [virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *) [virtual]
  • SetItalic(int) [virtual]
  • SetLabeledComponent(int) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLabelMode(int) [virtual]
  • SetLabelModeToLabelFieldData() [inline]
  • SetLabelModeToLabelIds() [inline]
  • SetLabelModeToLabelNormals() [inline]
  • SetLabelModeToLabelScalars() [inline]
  • SetLabelModeToLabelTCoords() [inline]
  • SetLabelModeToLabelTensors() [inline]
  • SetLabelModeToLabelVectors() [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextMappers (defined in vtkLabeledDataMapper) [private]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkAbstractMapper() [protected]
  • vtkLabeledDataMapper() [protected]
  • vtkLabeledDataMapper(const vtkLabeledDataMapper &) (defined in vtkLabeledDataMapper) [private]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkLabeledDataMapper, vtkMapper2D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkLabeledDataMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:22:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLandmarkTransform Member List

This is the complete list of members for vtkLandmarkTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInverse()
  • GetLinearInverse() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMode() [virtual]
  • GetModeAsString() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetSourceLandmarks() [virtual]
  • GetTargetLandmarks() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • Mode [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkLandmarkTransform &) (defined in vtkLandmarkTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetMode(int) [virtual]
  • SetModeToAffine() [inline]
  • SetModeToRigidBody() [inline]
  • SetModeToSimilarity() [inline]
  • SetReferenceCount(int)
  • SetSourceLandmarks(vtkPoints *points)
  • SetTargetLandmarks(vtkPoints *points)
  • SourceLandmarks [protected]
  • SubjectHelper [protected]
  • TargetLandmarks [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkLandmarkTransform() [protected]
  • vtkLandmarkTransform(const vtkLandmarkTransform &) (defined in vtkLandmarkTransform) [private]
  • vtkLinearTransform() [inline, protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLandmarkTransform, vtkLinearTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkLandmarkTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:22:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLargeInteger Member List

This is the complete list of members for vtkLargeInteger, including all inherited members.
  • CastToChar(void) const
  • CastToInt(void) const
  • CastToLong(void) const
  • CastToShort(void) const
  • CastToUnsignedLong(void) const
  • Complement(void)
  • Contract() (defined in vtkLargeInteger) [private]
  • Expand(unsigned int n) (defined in vtkLargeInteger) [private]
  • GetBit(unsigned int p) const
  • GetLength(void) const
  • GetSign(void) const
  • IsEven(void) const
  • IsGreater(const vtkLargeInteger &n) const (defined in vtkLargeInteger) [private]
  • IsOdd(void) const
  • IsSmaller(const vtkLargeInteger &n) const (defined in vtkLargeInteger) [private]
  • IsZero() const
  • Max (defined in vtkLargeInteger) [private]
  • Minus(const vtkLargeInteger &n) (defined in vtkLargeInteger) [private]
  • Negative (defined in vtkLargeInteger) [private]
  • Number (defined in vtkLargeInteger) [private]
  • operator &(const vtkLargeInteger &n) const
  • operator &=(const vtkLargeInteger &n)
  • operator *(const vtkLargeInteger &n) const
  • operator *=(const vtkLargeInteger &n)
  • operator!=(const vtkLargeInteger &n) const
  • operator%(const vtkLargeInteger &n) const
  • operator%=(const vtkLargeInteger &n)
  • operator+(const vtkLargeInteger &n) const
  • operator++(void)
  • operator++(int)
  • operator+=(const vtkLargeInteger &n)
  • operator-(const vtkLargeInteger &n) const
  • operator--(void)
  • operator--(int)
  • operator-=(const vtkLargeInteger &n)
  • operator/(const vtkLargeInteger &n) const
  • operator/=(const vtkLargeInteger &n)
  • operator<(const vtkLargeInteger &n) const
  • operator<<(int n) const
  • operator<<(ostream &s, const vtkLargeInteger &n) [friend]
  • operator<<=(int n)
  • operator<=(const vtkLargeInteger &n) const
  • operator=(const vtkLargeInteger &n)
  • operator==(const vtkLargeInteger &n) const
  • operator>(const vtkLargeInteger &n) const
  • operator>=(const vtkLargeInteger &n) const
  • operator>>(int n) const
  • operator>>(istream &s, vtkLargeInteger &n) [friend]
  • operator>>=(int n)
  • operator^(const vtkLargeInteger &n) const
  • operator^=(const vtkLargeInteger &n)
  • operator|(const vtkLargeInteger &n) const
  • operator|=(const vtkLargeInteger &n)
  • Plus(const vtkLargeInteger &n) (defined in vtkLargeInteger) [private]
  • Sig (defined in vtkLargeInteger) [private]
  • Truncate(unsigned int n)
  • vtkLargeInteger(void)
  • vtkLargeInteger(long n)
  • vtkLargeInteger(unsigned long n)
  • vtkLargeInteger(int n)
  • vtkLargeInteger(unsigned int n)
  • vtkLargeInteger(const vtkLargeInteger &n)
  • ~vtkLargeInteger(void)
Generated on Mon Mar 25 01:23:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLegendBoxActor Member List

This is the complete list of members for vtkLegendBoxActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • Border [protected]
  • BorderActor [protected]
  • BorderMapper [protected]
  • BorderOff() [virtual]
  • BorderOn() [virtual]
  • BorderPolyData [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime [protected]
  • CachedSize [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Colors [protected]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • FontFamily [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBold() [virtual]
  • GetBorder() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEntryColor(int i)
  • GetEntryString(int i)
  • GetEntrySymbol(int i)
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetItalic() [virtual]
  • GetLayerNumber() [virtual]
  • GetLockBorder() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfEntries() [inline]
  • GetNumberOfPaths() [inline, virtual]
  • GetPadding() [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScalarVisibility() [virtual]
  • GetShadow() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeEntries() [protected]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LayerNumber [protected]
  • LegendEntriesVisible [protected]
  • LockBorder [protected]
  • LockBorderOff() [virtual]
  • LockBorderOn() [virtual]
  • Mapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfEntries [protected]
  • operator=(const vtkLegendBoxActor &) (defined in vtkLegendBoxActor) [private]
  • Padding [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBold(int) [virtual]
  • SetBorder(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEntry(int i, vtkPolyData *symbol, const char *string, float color[3])
  • SetEntryColor(int i, float color[3])
  • SetEntryColor(int i, float r, float g, float b)
  • SetEntryString(int i, const char *string)
  • SetEntrySymbol(int i, vtkPolyData *symbol)
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetItalic(int) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetLockBorder(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetNumberOfEntries(int num)
  • SetPadding(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScalarVisibility(int) [virtual]
  • SetShadow(int) [virtual]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • Symbol [protected]
  • SymbolActor [protected]
  • SymbolMapper [protected]
  • SymbolTransform [protected]
  • TextActor [protected]
  • TextMapper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkLegendBoxActor() [protected]
  • vtkLegendBoxActor(const vtkLegendBoxActor &) (defined in vtkLegendBoxActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkLegendBoxActor, vtkActor2D)
  • ~vtkActor2D() [protected]
  • ~vtkLegendBoxActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:23:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLight Member List

This is the complete list of members for vtkLight, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AttenuationValues [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ConeAngle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkLight *light)
  • Delete() [virtual]
  • Exponent [protected]
  • FocalPoint [protected]
  • GetAttenuationValues() [virtual]
  • GetAttenuationValues(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetConeAngle() [virtual]
  • GetDebug()
  • GetExponent() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIntensity() [virtual]
  • GetLightType() [virtual]
  • GetMTime() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetPositional() [virtual]
  • GetReferenceCount() [inline]
  • GetSwitch() [virtual]
  • GetTransformedFocalPoint(float &a0, float &a1, float &a2)
  • GetTransformedFocalPoint(float a[3])
  • GetTransformedFocalPoint()
  • GetTransformedPosition(float &a0, float &a1, float &a2)
  • GetTransformedPosition(float a[3])
  • GetTransformedPosition()
  • GetTransformMatrix() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intensity [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LightType [protected]
  • LightTypeIsCameraLight()
  • LightTypeIsHeadlight()
  • LightTypeIsSceneLight()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkLight &) (defined in vtkLight) [private]
  • Position [protected]
  • Positional [protected]
  • PositionalOff() [virtual]
  • PositionalOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadSelf(istream &is)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, int) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAttenuationValues(float, float, float) [virtual]
  • SetAttenuationValues(float[3]) [virtual]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetConeAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionAngle(float elevation, float azimuth)
  • SetDirectionAngle(float ang[2]) [inline]
  • SetExponent(float) [virtual]
  • SetFocalPoint(float, float, float) [virtual]
  • SetFocalPoint(float[3]) [virtual]
  • SetFocalPoint(double *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIntensity(float) [virtual]
  • SetLightType(int) [virtual]
  • SetLightTypeToCameraLight()
  • SetLightTypeToHeadlight()
  • SetLightTypeToSceneLight()
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetPosition(double *a) [inline]
  • SetPositional(int) [virtual]
  • SetReferenceCount(int)
  • SetSwitch(int) [virtual]
  • SetTransformMatrix(vtkMatrix4x4 *) [virtual]
  • SubjectHelper [protected]
  • Switch [protected]
  • SwitchOff() [virtual]
  • SwitchOn() [virtual]
  • TransformedFocalPointReturn [protected]
  • TransformedPositionReturn [protected]
  • TransformMatrix [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkLight() [protected]
  • vtkLight(const vtkLight &) (defined in vtkLight) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLight, vtkObject)
  • WriteSelf(ostream &os)
  • ~vtkLight() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLightCollection Member List

This is the complete list of members for vtkLightCollection, including all inherited members.
  • AddItem(vtkLight *a)
  • AddItem(vtkObject *o) (defined in vtkLightCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem()
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkLightCollection &) (defined in vtkLightCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkLightCollection() [inline, protected]
  • vtkLightCollection(const vtkLightCollection &) (defined in vtkLightCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLightCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkLightCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLightKit Member List

This is the complete list of members for vtkLightKit, including all inherited members.
  • AddLightsToRenderer(vtkRenderer *renderer)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkLightKit *kit)
  • Delete() [virtual]
  • FillLight [protected]
  • FillLightAngle [protected]
  • FillLightColor [protected]
  • FillLightWarmth [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFillLightAngle() [virtual]
  • GetFillLightAngle(float data[2]) [virtual]
  • GetFillLightAzimuth() [inline]
  • GetFillLightColor() [virtual]
  • GetFillLightColor(float data[3]) [virtual]
  • GetFillLightElevation() [inline]
  • GetFillLightWarmth() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeadlightColor() [virtual]
  • GetHeadlightColor(float data[3]) [virtual]
  • GetHeadlightWarmth() [virtual]
  • GetKeyLightAngle() [virtual]
  • GetKeyLightAngle(float data[2]) [virtual]
  • GetKeyLightAzimuth() [inline]
  • GetKeyLightColor() [virtual]
  • GetKeyLightColor(float data[3]) [virtual]
  • GetKeyLightElevation() [inline]
  • GetKeyLightIntensity() [virtual]
  • GetKeyLightWarmth() [virtual]
  • GetKeyToFillRatio() [virtual]
  • GetKeyToHeadRatio() [virtual]
  • GetMaintainLuminance() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Headlight [protected]
  • HeadlightColor [protected]
  • HeadlightWarmth [protected]
  • InitializeWarmthFunctions() [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyLight [protected]
  • KeyLightAngle [protected]
  • KeyLightColor [protected]
  • KeyLightIntensity [protected]
  • KeyLightWarmth [protected]
  • KeyToFillRatio [protected]
  • KeyToHeadRatio [protected]
  • MaintainLuminance [protected]
  • MaintainLuminanceOff() [virtual]
  • MaintainLuminanceOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkLightKit &) (defined in vtkLightKit) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveLightsFromRenderer(vtkRenderer *renderer)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFillLightAngle(float elevation, float azimuth)
  • SetFillLightAngle(float angle[2]) [inline]
  • SetFillLightAzimuth(float x) [inline]
  • SetFillLightElevation(float x) [inline]
  • SetFillLightWarmth(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeadlightWarmth(float) [virtual]
  • SetKeyLightAngle(float elevation, float azimuth)
  • SetKeyLightAngle(float angle[2]) [inline]
  • SetKeyLightAzimuth(float x) [inline]
  • SetKeyLightElevation(float x) [inline]
  • SetKeyLightIntensity(float) [virtual]
  • SetKeyLightWarmth(float) [virtual]
  • SetKeyToFillRatio(float) [virtual]
  • SetKeyToHeadRatio(float) [virtual]
  • SetMaintainLuminance(int) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkLightKit() [protected]
  • vtkLightKit(const vtkLightKit &) (defined in vtkLightKit) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLightKit, vtkObject)
  • WarmthFunction [protected]
  • WarmthToIntensity(float w) [protected]
  • WarmthToRGB(float w, float rgb[3]) [protected]
  • WarmthToRGBI(float w, float rgb[3], float &i) [protected]
  • ~vtkLightKit() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLine Member List

This is the complete list of members for vtkLine, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • DistanceToLine(float x[3], float p1[3], float p2[3], float &t, float closestPoint[3]) [static]
  • DistanceToLine(float x[3], float p1[3], float p2[3]) [static]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int) [inline, virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationFunctions(float pcoords[3], float weights[2]) [static]
  • Intersection(float p1[3], float p2[3], float x1[3], float x2[3], float &u, float &v) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkLine &) (defined in vtkLine) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkLine() [protected]
  • vtkLine(const vtkLine &) (defined in vtkLine) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLine, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkLine() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLinearExtrusionFilter Member List

This is the complete list of members for vtkLinearExtrusionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ExtrudePoint [protected]
  • ExtrusionPoint [protected]
  • ExtrusionType [protected]
  • GetAbortExecute() [virtual]
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtrusionPoint() [virtual]
  • GetExtrusionPoint(float data[3]) [virtual]
  • GetExtrusionType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetVector() [virtual]
  • GetVector(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkLinearExtrusionFilter &) (defined in vtkLinearExtrusionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtrusionPoint(float, float, float) [virtual]
  • SetExtrusionPoint(float[3]) [virtual]
  • SetExtrusionType(int) [virtual]
  • SetExtrusionTypeToNormalExtrusion() [inline]
  • SetExtrusionTypeToPointExtrusion() [inline]
  • SetExtrusionTypeToVectorExtrusion() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVector(float, float, float) [virtual]
  • SetVector(float[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vector [protected]
  • ViaNormal(float x[3], vtkIdType id, vtkDataArray *normals) [protected]
  • ViaPoint(float x[3], vtkIdType id, vtkDataArray *normals=0) [protected]
  • ViaVector(float x[3], vtkIdType id, vtkDataArray *normals=0) [protected]
  • vtkLinearExtrusionFilter() [protected]
  • vtkLinearExtrusionFilter(const vtkLinearExtrusionFilter &) (defined in vtkLinearExtrusionFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkLinearExtrusionFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkLinearExtrusionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLinearSubdivisionFilter Member List

This is the complete list of members for vtkLinearSubdivisionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindEdge(vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds) [protected]
  • GenerateSubdivisionCells(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD) [protected]
  • GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSubdivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolatePosition(vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubdivisions [protected]
  • operator=(const vtkLinearSubdivisionFilter &) (defined in vtkLinearSubdivisionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSubdivisions(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkInterpolatingSubdivisionFilter() [protected]
  • vtkLinearSubdivisionFilter() [inline, protected]
  • vtkLinearSubdivisionFilter(const vtkLinearSubdivisionFilter &) (defined in vtkLinearSubdivisionFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkLinearSubdivisionFilter, vtkInterpolatingSubdivisionFilter)
  • ~vtkInterpolatingSubdivisionFilter() [inline, protected]
  • ~vtkLinearSubdivisionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLinearTransform Member List

This is the complete list of members for vtkLinearTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInverse()
  • GetLinearInverse() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [inline, protected, virtual]
  • Inverse()=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform()=0 [pure virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkLinearTransform &) (defined in vtkLinearTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkLinearTransform() [inline, protected]
  • vtkLinearTransform(const vtkLinearTransform &) (defined in vtkLinearTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLinearTransform, vtkHomogeneousTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLineSource Member List

This is the complete list of members for vtkLineSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint1() [virtual]
  • GetPoint1(float data[3]) [virtual]
  • GetPoint2() [virtual]
  • GetPoint2(float data[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkLineSource &) (defined in vtkLineSource) [private]
  • Outputs [protected]
  • Point1 [protected]
  • Point2 [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Resolution [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPoint1(float, float, float) [virtual]
  • SetPoint1(float[3]) [virtual]
  • SetPoint2(float, float, float) [virtual]
  • SetPoint2(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkLineSource(int res=1) [protected]
  • vtkLineSource(const vtkLineSource &) (defined in vtkLineSource) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkLineSource, vtkPolyDataSource)
  • ~vtkLineSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLinkEdgels Member List

This is the complete list of members for vtkLinkEdgels, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientThreshold() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLinkThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPhiThreshold() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientThreshold [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LinkEdgels(int xdim, int ydim, float *image, vtkDataArray *inVectors, vtkCellArray *newLines, vtkPoints *newPts, vtkFloatArray *outScalars, vtkFloatArray *outVectors, int z) [protected]
  • LinkThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkLinkEdgels &) (defined in vtkLinkEdgels) [private]
  • Outputs [protected]
  • PhiThreshold [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientThreshold(float) [virtual]
  • SetInput(vtkImageData *input)
  • SetLinkThreshold(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPhiThreshold(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkLinkEdgels() [protected]
  • vtkLinkEdgels(const vtkLinkEdgels &) (defined in vtkLinkEdgels) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkLinkEdgels, vtkStructuredPointsToPolyDataFilter)
  • ~vtkLinkEdgels() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:23:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLocator Member List

This is the complete list of members for vtkLocator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • BreakOnError() [static]
  • BuildLocator()=0 [pure virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FreeSearchStructure()=0 [pure virtual]
  • GenerateRepresentation(int level, vtkPolyData *pd)=0 [pure virtual]
  • GetAutomatic() [virtual]
  • GetBuildTime() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkLocator &) (defined in vtkLocator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkLocator() [protected]
  • vtkLocator(const vtkLocator &) (defined in vtkLocator) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLocator, vtkObject)
  • ~vtkLocator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLODActor Member List

This is the complete list of members for vtkLODActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddLODMapper(vtkMapper *mapper)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ApplyProperties() [inline, virtual]
  • BackfaceProperty [protected]
  • Bounds [protected]
  • BoundsMTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime [protected]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • CreateOwnLODs() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteOwnLODs() [protected]
  • Device [protected]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBackfaceProperty()
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetIsOpaque() [protected]
  • GetLength()
  • GetLODMappers() [virtual]
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPart() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfCloudPoints() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfParts() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetTexture() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPartTraversal() [virtual]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • LODMappers [protected]
  • LowMapper [protected]
  • MakeProperty() [virtual]
  • Mapper [protected]
  • MapperBounds [protected]
  • MaskPoints [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • MediumMapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfCloudPoints [protected]
  • NumberOfConsumers [protected]
  • operator=(const vtkLODActor &) (defined in vtkLODActor) [private]
  • Orientation [protected]
  • Origin [protected]
  • OutlineFilter [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkMapper *) [virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBackfaceProperty(vtkProperty *lut)
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkMapper *) [virtual]
  • SetNumberOfCloudPoints(int) [virtual]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkProperty *lut)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetTexture(vtkTexture *) [virtual]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Texture [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateOwnLODs() [protected]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor() [protected]
  • vtkLODActor() [protected]
  • vtkLODActor(const vtkLODActor &) (defined in vtkLODActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkLODActor, vtkActor)
  • ~vtkActor() [protected]
  • ~vtkLODActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:23:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLODProp3D Member List

This is the complete list of members for vtkLODProp3D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vp) [virtual]
  • vtkProp3D::AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddLOD(vtkMapper *m, vtkProperty *p, vtkProperty *back, vtkTexture *t, float time)
  • AddLOD(vtkMapper *m, vtkProperty *p, vtkTexture *t, float time)
  • AddLOD(vtkMapper *m, vtkProperty *p, vtkProperty *back, float time)
  • AddLOD(vtkMapper *m, vtkProperty *p, float time)
  • AddLOD(vtkMapper *m, vtkTexture *t, float time)
  • AddLOD(vtkMapper *m, float time)
  • AddLOD(vtkVolumeMapper *m, vtkVolumeProperty *p, float time)
  • AddLOD(vtkVolumeMapper *m, float time)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • AutomaticLODSelection [protected]
  • AutomaticLODSelectionOff() [virtual]
  • AutomaticLODSelectionOn() [virtual]
  • AutomaticPickLODSelection [protected]
  • AutomaticPickLODSelectionOff() [virtual]
  • AutomaticPickLODSelectionOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • ConvertIDToIndex(int id) [protected]
  • CurrentIndex [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisableLOD(int id)
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EnableLOD(int id)
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetAutomaticLODSelection() [virtual]
  • GetAutomaticPickLODSelection() [virtual]
  • GetAutomaticPickPropIndex(void) [protected]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetLastRenderedLODID()
  • GetLength()
  • GetLODBackfaceProperty(int id, vtkProperty **t)
  • GetLODEstimatedRenderTime(int id)
  • GetLODIndexEstimatedRenderTime(int index)
  • GetLODIndexLevel(int index)
  • GetLODLevel(int id)
  • GetLODMapper(int id, vtkMapper **m)
  • GetLODMapper(int id, vtkVolumeMapper **m)
  • GetLODMapper(int id)
  • GetLODProperty(int id, vtkProperty **p)
  • GetLODProperty(int id, vtkVolumeProperty **p)
  • GetLODTexture(int id, vtkTexture **t)
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextEntryIndex() [protected]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPickLODID(void)
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetSelectedLODID() [virtual]
  • GetSelectedPickLODID() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • LODs [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfEntries [protected]
  • NumberOfLODs [protected]
  • operator=(const vtkLODProp3D &) (defined in vtkLODProp3D) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • PreviousPickMethod [protected]
  • PreviousPickMethodArg [protected]
  • PreviousPickProp [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveLOD(int id)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SelectedLODID [protected]
  • SelectedLODIndex [protected]
  • SelectedPickLODID [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vp)
  • vtkProp3D::SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetAutomaticLODSelection(int) [virtual]
  • SetAutomaticPickLODSelection(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLODBackfaceProperty(int id, vtkProperty *t)
  • SetLODLevel(int id, float level)
  • SetLODMapper(int id, vtkMapper *m)
  • SetLODMapper(int id, vtkVolumeMapper *m)
  • SetLODProperty(int id, vtkProperty *p)
  • SetLODProperty(int id, vtkVolumeProperty *p)
  • SetLODTexture(int id, vtkTexture *t)
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetSelectedLODID(int) [virtual]
  • SetSelectedPickLODID(int id)
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkLODProp3D() [protected]
  • vtkLODProp3D(const vtkLODProp3D &) (defined in vtkLODProp3D) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkLODProp3D, vtkProp3D)
  • ~vtkLODProp3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:23:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLogLookupTable Member List

This is the complete list of members for vtkLogLookupTable, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(int sz=256, int ext=256)
  • Alpha [protected]
  • AlphaRange [protected]
  • BreakOnError() [static]
  • Build() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConvertUnsignedCharToRGBA(vtkUnsignedCharArray *colors, int numComp, int numTuples) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ForceBuild() [virtual]
  • GetAlpha() [virtual]
  • GetAlphaRange() [virtual]
  • GetAlphaRange(float &, float &) [virtual]
  • GetAlphaRange(float[2]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(float x) [inline]
  • GetColor(float x, float rgb[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHueRange() [virtual]
  • GetHueRange(float &, float &) [virtual]
  • GetHueRange(float[2]) [virtual]
  • GetIndex(float v) [virtual]
  • GetLuminance(float x) [inline]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetNumberOfTableValues() [inline]
  • GetOpacity(float v)
  • vtkScalarsToColors::GetOpacity(float vtkNotUsed(v)) [inline, virtual]
  • GetPointer(const vtkIdType id) [inline]
  • GetRamp() [virtual]
  • GetRange() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetSaturationRange() [virtual]
  • GetSaturationRange(float &, float &) [virtual]
  • GetSaturationRange(float[2]) [virtual]
  • GetScale() [virtual]
  • GetTableRange() [virtual]
  • GetTableRange(float data[2]) [virtual]
  • GetTableValue(vtkIdType id)
  • GetTableValue(vtkIdType id, float rgba[4])
  • GetValueRange() [virtual]
  • GetValueRange(float &, float &) [virtual]
  • GetValueRange(float[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HueRange [protected]
  • InsertTime [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MapScalars(vtkDataArray *scalars, int colorMode, int component)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output, int outputFormat)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output) [inline]
  • MapScalarsThroughTable2(void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement) [virtual]
  • MapValue(float v) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • operator=(const vtkLogLookupTable &) (defined in vtkLogLookupTable) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Ramp [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RGBA [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaturationRange [protected]
  • Scale [protected]
  • SetAlpha(float alpha)
  • SetAlphaRange(float, float) [virtual]
  • SetAlphaRange(float[2])
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHueRange(float, float) [virtual]
  • SetHueRange(float[2])
  • SetNumberOfColors(vtkIdType) [virtual]
  • SetNumberOfTableValues(vtkIdType number)
  • SetRamp(int) [virtual]
  • SetRampToLinear() [inline]
  • SetRampToSCurve() [inline]
  • SetRange(float min, float max) [inline, virtual]
  • SetRange(float rng[2]) [inline]
  • SetReferenceCount(int)
  • SetSaturationRange(float, float) [virtual]
  • SetSaturationRange(float[2])
  • SetScale(int scale)
  • SetScaleToLinear() [inline]
  • SetScaleToLog10() [inline]
  • SetTableRange(float r[2])
  • SetTableRange(float min, float max) [virtual]
  • SetTableValue(vtkIdType indx, float rgba[4])
  • SetTableValue(vtkIdType indx, float r, float g, float b, float a=1.0)
  • SetValueRange(float, float) [virtual]
  • SetValueRange(float[2])
  • SubjectHelper [protected]
  • Table [protected]
  • TableRange [protected]
  • UnRegister(vtkObject *o) [virtual]
  • ValueRange [protected]
  • vtkLogLookupTable(int sze=256, int ext=256) [protected]
  • vtkLogLookupTable(const vtkLogLookupTable &) (defined in vtkLogLookupTable) [private]
  • vtkLookupTable(int sze=256, int ext=256) [protected]
  • vtkObject() [protected]
  • vtkScalarsToColors() [inline, protected]
  • vtkTypeRevisionMacro(vtkLogLookupTable, vtkLookupTable)
  • WritePointer(const vtkIdType id, const int number)
  • ~vtkLogLookupTable() [inline, protected]
  • ~vtkLookupTable() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarsToColors() [inline, protected]
Generated on Mon Mar 25 01:23:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLongArray Member List

This is the complete list of members for vtkLongArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const long) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const long i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkLongArray &) (defined in vtkLongArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(long *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const long value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkLongArray(vtkIdType numComp=1) [protected]
  • vtkLongArray(const vtkLongArray &) (defined in vtkLongArray) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkLongArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkLongArray() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLookupTable Member List

This is the complete list of members for vtkLookupTable, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(int sz=256, int ext=256)
  • Alpha [protected]
  • AlphaRange [protected]
  • BreakOnError() [static]
  • Build() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConvertUnsignedCharToRGBA(vtkUnsignedCharArray *colors, int numComp, int numTuples) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ForceBuild() [virtual]
  • GetAlpha() [virtual]
  • GetAlphaRange() [virtual]
  • GetAlphaRange(float &, float &) [virtual]
  • GetAlphaRange(float[2]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(float x) [inline]
  • GetColor(float x, float rgb[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHueRange() [virtual]
  • GetHueRange(float &, float &) [virtual]
  • GetHueRange(float[2]) [virtual]
  • GetIndex(float v) [virtual]
  • GetLuminance(float x) [inline]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetNumberOfTableValues() [inline]
  • GetOpacity(float v)
  • vtkScalarsToColors::GetOpacity(float vtkNotUsed(v)) [inline, virtual]
  • GetPointer(const vtkIdType id) [inline]
  • GetRamp() [virtual]
  • GetRange() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetSaturationRange() [virtual]
  • GetSaturationRange(float &, float &) [virtual]
  • GetSaturationRange(float[2]) [virtual]
  • GetScale() [virtual]
  • GetTableRange() [virtual]
  • GetTableRange(float data[2]) [virtual]
  • GetTableValue(vtkIdType id)
  • GetTableValue(vtkIdType id, float rgba[4])
  • GetValueRange() [virtual]
  • GetValueRange(float &, float &) [virtual]
  • GetValueRange(float[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HueRange [protected]
  • InsertTime [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MapScalars(vtkDataArray *scalars, int colorMode, int component)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output, int outputFormat)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output) [inline]
  • MapScalarsThroughTable2(void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement) [virtual]
  • MapValue(float v) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • operator=(const vtkLookupTable &) (defined in vtkLookupTable) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Ramp [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RGBA [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaturationRange [protected]
  • Scale [protected]
  • SetAlpha(float alpha)
  • SetAlphaRange(float, float) [virtual]
  • SetAlphaRange(float[2])
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHueRange(float, float) [virtual]
  • SetHueRange(float[2])
  • SetNumberOfColors(vtkIdType) [virtual]
  • SetNumberOfTableValues(vtkIdType number)
  • SetRamp(int) [virtual]
  • SetRampToLinear() [inline]
  • SetRampToSCurve() [inline]
  • SetRange(float min, float max) [inline, virtual]
  • SetRange(float rng[2]) [inline]
  • SetReferenceCount(int)
  • SetSaturationRange(float, float) [virtual]
  • SetSaturationRange(float[2])
  • SetScale(int scale)
  • SetScaleToLinear() [inline]
  • SetScaleToLog10() [inline]
  • SetTableRange(float r[2])
  • SetTableRange(float min, float max) [virtual]
  • SetTableValue(vtkIdType indx, float rgba[4])
  • SetTableValue(vtkIdType indx, float r, float g, float b, float a=1.0)
  • SetValueRange(float, float) [virtual]
  • SetValueRange(float[2])
  • SubjectHelper [protected]
  • Table [protected]
  • TableRange [protected]
  • UnRegister(vtkObject *o) [virtual]
  • ValueRange [protected]
  • vtkLookupTable(int sze=256, int ext=256) [protected]
  • vtkLookupTable(const vtkLookupTable &) (defined in vtkLookupTable) [private]
  • vtkObject() [protected]
  • vtkScalarsToColors() [inline, protected]
  • vtkTypeRevisionMacro(vtkLookupTable, vtkScalarsToColors)
  • WritePointer(const vtkIdType id, const int number)
  • ~vtkLookupTable() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarsToColors() [inline, protected]
Generated on Mon Mar 25 01:23:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLoopSubdivisionFilter Member List

This is the complete list of members for vtkLoopSubdivisionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindEdge(vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds) [protected]
  • GenerateEvenStencil(vtkIdType p1, vtkPolyData *polys, vtkIdList *stencilIds, float *weights) [protected]
  • GenerateOddStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys, vtkIdList *stencilIds, float *weights) [protected]
  • GenerateSubdivisionCells(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD) [protected]
  • GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD) [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSubdivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolatePosition(vtkPoints *inputPts, vtkPoints *outputPts, vtkIdList *stencil, float *weights) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubdivisions [protected]
  • operator=(const vtkLoopSubdivisionFilter &) (defined in vtkLoopSubdivisionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSubdivisions(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkApproximatingSubdivisionFilter() [protected]
  • vtkLoopSubdivisionFilter() [inline, protected]
  • vtkLoopSubdivisionFilter(const vtkLoopSubdivisionFilter &) (defined in vtkLoopSubdivisionFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkLoopSubdivisionFilter, vtkApproximatingSubdivisionFilter)
  • ~vtkApproximatingSubdivisionFilter() [inline, protected]
  • ~vtkLoopSubdivisionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMapper2D Member List

This is the complete list of members for vtkMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMapper2D &) (defined in vtkMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkMapper2D(const vtkMapper2D &) (defined in vtkMapper2D) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMapper2D, vtkAbstractMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:23:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMapper Member List

This is the complete list of members for vtkMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(const char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalImmediateModeRendering() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImmediateModeRendering() [virtual]
  • GetInput()
  • GetInputAsDataSet() [inline]
  • GetInputs() [inline]
  • GetLength()
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTime() [virtual]
  • GetResolveCoincidentTopology() [static]
  • GetResolveCoincidentTopologyPolygonOffsetParameters(float &factor, float &units) [static]
  • GetResolveCoincidentTopologyZShift() [static]
  • GetScalarMode() [virtual]
  • GetScalarModeAsString()
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalImmediateModeRenderingOff() [inline, static]
  • GlobalImmediateModeRenderingOn() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImmediateModeRendering [protected]
  • ImmediateModeRenderingOff() [virtual]
  • ImmediateModeRenderingOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMapper &) (defined in vtkMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkActor *a)=0 [pure virtual]
  • RenderTime [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalImmediateModeRendering(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImmediateModeRendering(int) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTime(float time) [inline]
  • SetResolveCoincidentTopology(int val) [static]
  • SetResolveCoincidentTopologyPolygonOffsetParameters(float factor, float units) [static]
  • SetResolveCoincidentTopologyToDefault() [static]
  • SetResolveCoincidentTopologyToOff() [inline, static]
  • SetResolveCoincidentTopologyToPolygonOffset() [inline, static]
  • SetResolveCoincidentTopologyToShiftZBuffer() [inline, static]
  • SetResolveCoincidentTopologyZShift(double val) [static]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMapper() [protected]
  • vtkMapper(const vtkMapper &) (defined in vtkMapper) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMapper, vtkAbstractMapper3D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:23:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMapperCollection Member List

This is the complete list of members for vtkMapperCollection, including all inherited members.
  • AddItem(vtkMapper *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkMapperCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastItem() [inline]
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkMapperCollection &) (defined in vtkMapperCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkMapperCollection() [inline, protected]
  • vtkMapperCollection(const vtkMapperCollection &) (defined in vtkMapperCollection) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMapperCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkMapperCollection() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMarchingContourFilter Member List

This is the complete list of members for vtkMarchingContourFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • DataSetContour() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseScalarTree() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageContour(int dim) [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMarchingContourFilter &) (defined in vtkMarchingContourFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTree [protected]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseScalarTree(int) [virtual]
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredPointsContour(int dim) [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseScalarTree [protected]
  • UseScalarTreeOff() [virtual]
  • UseScalarTreeOn() [virtual]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkMarchingContourFilter() [protected]
  • vtkMarchingContourFilter(const vtkMarchingContourFilter &) (defined in vtkMarchingContourFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMarchingContourFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkMarchingContourFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMarchingCubes Member List

This is the complete list of members for vtkMarchingCubes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMarchingCubes &) (defined in vtkMarchingCubes) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkMarchingCubes() [protected]
  • vtkMarchingCubes(const vtkMarchingCubes &) (defined in vtkMarchingCubes) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkMarchingCubes, vtkStructuredPointsToPolyDataFilter)
  • ~vtkMarchingCubes() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:23:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMarchingSquares Member List

This is the complete list of members for vtkMarchingSquares, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ContourValues [protected]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImageRange() [virtual]
  • GetImageRange(int data[6]) [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageRange [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMarchingSquares &) (defined in vtkMarchingSquares) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageRange(int data[]) [virtual]
  • SetImageRange(int imin, int imax, int jmin, int jmax, int kmin, int kmax)
  • SetInput(vtkImageData *input)
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkMarchingSquares() [protected]
  • vtkMarchingSquares(const vtkMarchingSquares &) (defined in vtkMarchingSquares) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMarchingSquares, vtkPolyDataSource)
  • ~vtkMarchingSquares() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMaskFields Member List

This is the complete list of members for vtkMaskFields, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AttributeNames [protected, static]
  • BreakOnError() [static]
  • CELL_DATA enum value
  • ClearFieldFlags() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CopyAllOff() [virtual]
  • CopyAllOn() [virtual]
  • CopyAttributeOff(int attributeLocation, int attributeType) [inline]
  • CopyAttributeOff(const char *attributeLoc, const char *attributeType)
  • CopyAttributeOn(int attributeLocation, int attributeType) [inline]
  • CopyAttributeOn(const char *attributeLoc, const char *attributeType)
  • CopyAttributeOnOff(int attributeLocation, int attributeType, int onOff) [protected]
  • CopyAttributes [protected]
  • CopyAttributesOff() [inline]
  • CopyAttributesOn() [inline]
  • CopyFieldFlags [protected]
  • CopyFieldOff(int fieldLocation, const char *name) [inline]
  • CopyFieldOff(const char *fieldLoc, const char *name)
  • CopyFieldOn(int fieldLocation, const char *name) [inline]
  • CopyFieldOn(const char *fieldLoc, const char *name)
  • CopyFieldOnOff(int fieldLocation, const char *name, int onOff) [protected]
  • CopyFields [protected]
  • CopyFieldsOff() [inline]
  • CopyFieldsOn() [inline]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldLocation enum name
  • FieldLocationNames [protected, static]
  • FindFlag(const char *field, int location) [protected]
  • FindFlag(int arrayType, int location) [protected]
  • GetAbortExecute() [virtual]
  • GetAttributeLocation(const char *loc) [protected]
  • GetAttributeType(const char *type) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFlag(const char *field, int location) [protected]
  • GetFlag(int arrayType, int location) [protected]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfFieldFlags [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OBJECT_DATA enum value
  • operator=(const vtkMaskFields &) (defined in vtkMaskFields) [private]
  • Outputs [protected]
  • POINT_DATA enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkMaskFields()
  • vtkMaskFields(const vtkMaskFields &) (defined in vtkMaskFields) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMaskFields, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkMaskFields() [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMaskPoints Member List

This is the complete list of members for vtkMaskPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateVertices [protected]
  • GenerateVerticesOff() [virtual]
  • GenerateVerticesOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateVertices() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumNumberOfPoints() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOnRatio() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRandomMode() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumNumberOfPoints [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • OnRatio [protected]
  • operator=(const vtkMaskPoints &) (defined in vtkMaskPoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RandomMode [protected]
  • RandomModeOff() [virtual]
  • RandomModeOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateVertices(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetMaximumNumberOfPoints(vtkIdType) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(vtkIdType) [virtual]
  • SetOnRatio(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRandomMode(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkMaskPoints() [protected]
  • vtkMaskPoints(const vtkMaskPoints &) (defined in vtkMaskPoints) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMaskPoints, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkMaskPoints() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMaskPolyData Member List

This is the complete list of members for vtkMaskPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOnRatio() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • OnRatio [protected]
  • operator=(const vtkMaskPolyData &) (defined in vtkMaskPolyData) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(vtkIdType) [virtual]
  • SetOnRatio(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkMaskPolyData() [protected]
  • vtkMaskPolyData(const vtkMaskPolyData &) (defined in vtkMaskPolyData) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMaskPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkMaskPolyData() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMassProperties Member List

This is the complete list of members for vtkMassProperties, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • Execute() [protected]
  • ExecuteTime [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetKx() [inline]
  • GetKy() [inline]
  • GetKz() [inline]
  • GetMTime() [virtual]
  • GetNormalizedShapeIndex() [inline]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetSurfaceArea() [inline]
  • GetVolume() [inline]
  • GetVolumeX() [inline]
  • GetVolumeY() [inline]
  • GetVolumeZ() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Kx [protected]
  • Ky [protected]
  • Kz [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedShapeIndex [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMassProperties &) (defined in vtkMassProperties) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SurfaceArea [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • Volume [protected]
  • VolumeX [protected]
  • VolumeY [protected]
  • VolumeZ [protected]
  • vtkMassProperties() [protected]
  • vtkMassProperties(const vtkMassProperties &) (defined in vtkMassProperties) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMassProperties, vtkProcessObject)
  • ~vtkMassProperties() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:23:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMath Member List

This is the complete list of members for vtkMath, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Cross(const float x[3], const float y[3], float z[3]) [inline, static]
  • Cross(const double x[3], const double y[3], double z[3]) [inline, static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DegreesToRadians() [inline, static]
  • Delete() [virtual]
  • Determinant2x2(const float c1[2], const float c2[2]) [inline, static]
  • Determinant2x2(double a, double b, double c, double d) [inline, static]
  • Determinant3x3(float A[3][3]) [inline, static]
  • Determinant3x3(double A[3][3]) [inline, static]
  • Determinant3x3(const float c1[3], const float c2[3], const float c3[3]) [inline, static]
  • Determinant3x3(double a1, double a2, double a3, double b1, double b2, double b3, double c1, double c2, double c3) [inline, static]
  • Diagonalize3x3(const float A[3][3], float w[3], float V[3][3]) [static]
  • Diagonalize3x3(const double A[3][3], double w[3], double V[3][3]) [static]
  • Distance2BetweenPoints(const float x[3], const float y[3]) [inline, static]
  • Distance2BetweenPoints(const double x[3], const double y[3]) [inline, static]
  • Dot(const float x[3], const float y[3]) [inline, static]
  • Dot(const double x[3], const double y[3]) [inline, static]
  • Dot2D(const float x[3], const float y[3]) [inline, static]
  • Dot2D(const double x[3], const double y[3]) [inline, static]
  • DoubleDegreesToRadians() [inline, static]
  • EstimateMatrixCondition(double **A, int size) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity3x3(float A[3][3]) [static]
  • Identity3x3(double A[3][3]) [static]
  • Invert3x3(const float A[3][3], float AI[3][3]) [static]
  • Invert3x3(const double A[3][3], double AI[3][3]) [static]
  • InvertMatrix(double **A, double **AI, int size) [static]
  • InvertMatrix(double **A, double **AI, int size, int *tmp1Size, double *tmp2Size) [static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Jacobi(float **a, float *w, float **v) [static]
  • Jacobi(double **a, double *w, double **v) [static]
  • JacobiN(float **a, int n, float *w, float **v) [static]
  • JacobiN(double **a, int n, double *w, double **v) [static]
  • LinearSolve3x3(const float A[3][3], const float x[3], float y[3]) [static]
  • LinearSolve3x3(const double A[3][3], const double x[3], double y[3]) [static]
  • LUFactor3x3(float A[3][3], int index[3]) [static]
  • LUFactor3x3(double A[3][3], int index[3]) [static]
  • LUFactorLinearSystem(double **A, int *index, int size) [static]
  • LUFactorLinearSystem(double **A, int *index, int size, double *tmpSize) [static]
  • LUSolve3x3(const float A[3][3], const int index[3], float x[3]) [static]
  • LUSolve3x3(const double A[3][3], const int index[3], double x[3]) [static]
  • LUSolveLinearSystem(double **A, int *index, double *x, int size) [static]
  • Matrix3x3ToQuaternion(const float A[3][3], float quat[4]) [static]
  • Matrix3x3ToQuaternion(const double A[3][3], double quat[4]) [static]
  • Modified() [virtual]
  • MTime [protected]
  • Multiply3x3(const float A[3][3], const float in[3], float out[3]) [static]
  • Multiply3x3(const double A[3][3], const double in[3], double out[3]) [static]
  • Multiply3x3(const float A[3][3], const float B[3][3], float C[3][3]) [static]
  • Multiply3x3(const double A[3][3], const double B[3][3], double C[3][3]) [static]
  • New() [static]
  • Norm(const float *x, int n) [static]
  • Norm(const float x[3]) [inline, static]
  • Norm(const double x[3]) [inline, static]
  • Norm2D(const float x[3]) [inline, static]
  • Norm2D(const double x[3]) [inline, static]
  • Normalize(float x[3]) [inline, static]
  • Normalize(double x[3]) [inline, static]
  • Normalize2D(float x[3]) [inline, static]
  • Normalize2D(double x[3]) [inline, static]
  • operator=(const vtkMath &) (defined in vtkMath) [private]
  • Orthogonalize3x3(const float A[3][3], float B[3][3]) [static]
  • Orthogonalize3x3(const double A[3][3], double B[3][3]) [static]
  • Perpendiculars(const double x[3], double y[3], double z[3], double theta) [static]
  • Perpendiculars(const float x[3], float y[3], float z[3], double theta) [static]
  • Pi() [inline, static]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • QuaternionToMatrix3x3(const float quat[4], float A[3][3]) [static]
  • QuaternionToMatrix3x3(const double quat[4], double A[3][3]) [static]
  • Random() [static]
  • Random(float min, float max) [inline, static]
  • RandomSeed(long s) [static]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Round(float f) [inline, static]
  • Round(double f) [inline, static]
  • SafeDownCast(vtkObject *o) [static]
  • Seed [protected, static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SingularValueDecomposition3x3(const float A[3][3], float U[3][3], float w[3], float VT[3][3]) [static]
  • SingularValueDecomposition3x3(const double A[3][3], double U[3][3], double w[3], double VT[3][3]) [static]
  • SolveCubic(double c0, double c1, double c2, double c3) [static]
  • SolveCubic(double c0, double c1, double c2, double c3, double *r1, double *r2, double *r3, int *num_roots) [static]
  • SolveLeastSquares(int numberOfSamples, double **xt, int xOrder, double **yt, int yOrder, double **mt) [static]
  • SolveLinear(double c0, double c1) [static]
  • SolveLinear(double c0, double c1, double *r1, int *num_roots) [static]
  • SolveLinearSystem(double **A, double *x, int size) [static]
  • SolveQuadratic(double c0, double c1, double c2) [static]
  • SolveQuadratic(double c0, double c1, double c2, double *r1, double *r2, int *num_roots) [static]
  • SubjectHelper [protected]
  • Transpose3x3(const float A[3][3], float AT[3][3]) [static]
  • Transpose3x3(const double A[3][3], double AT[3][3]) [static]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMath() [inline, protected]
  • vtkMath(const vtkMath &) (defined in vtkMath) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMath, vtkObject)
  • ~vtkMath() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMatrix4x4 Member List

This is the complete list of members for vtkMatrix4x4, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Adjoint(vtkMatrix4x4 *in, vtkMatrix4x4 *out) [inline]
  • Adjoint(const double inElements[16], double outElements[16]) [static]
  • Adjoint(vtkMatrix4x4 &in, vtkMatrix4x4 &out) [inline]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkMatrix4x4 *source) [inline]
  • DeepCopy(double Elements[16], vtkMatrix4x4 *source) [inline, static]
  • DeepCopy(double Elements[16], const double newElements[16]) [static]
  • DeepCopy(const double Elements[16]) [inline]
  • Delete() [virtual]
  • Determinant() [inline]
  • Determinant(const double Elements[16]) [static]
  • Determinant(vtkMatrix4x4 &in) [inline]
  • Determinant(vtkMatrix4x4 *in) [inline]
  • DoublePoint [protected]
  • Element
  • FloatPoint [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetElement(int i, int j) const [inline]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • Identity(double Elements[16]) [static]
  • Invert(vtkMatrix4x4 *in, vtkMatrix4x4 *out) [inline, static]
  • Invert() [inline]
  • Invert(const double inElements[16], double outElements[16]) [static]
  • Invert(vtkMatrix4x4 &in, vtkMatrix4x4 &out) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • Multiply4x4(vtkMatrix4x4 *a, vtkMatrix4x4 *b, vtkMatrix4x4 *c) [inline, static]
  • Multiply4x4(const double a[16], const double b[16], double c[16]) [static]
  • MultiplyDoublePoint(const double in[4]) [inline]
  • MultiplyFloatPoint(const float in[4]) [inline]
  • MultiplyPoint(const float in[4], float out[4]) [inline]
  • MultiplyPoint(const double in[4], double out[4]) [inline]
  • MultiplyPoint(const double Elements[16], const float in[4], float out[4]) [static]
  • MultiplyPoint(const double Elements[16], const double in[4], double out[4]) [static]
  • MultiplyPoint(const float in[4]) [inline]
  • New() [static]
  • operator=(double element)
  • operator=(const vtkMatrix4x4 &source) (defined in vtkMatrix4x4) [private]
  • operator[](const unsigned int i) [inline]
  • operator[](unsigned int i) const [inline]
  • PointMultiply(const double Elements[16], const float in[4], float out[4]) [static]
  • PointMultiply(const double Elements[16], const double in[4], double out[4]) [static]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetElement(int i, int j, double value) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Transpose(vtkMatrix4x4 *in, vtkMatrix4x4 *out) [inline, static]
  • Transpose() [inline]
  • Transpose(const double inElements[16], double outElements[16]) [static]
  • Transpose(vtkMatrix4x4 &in, vtkMatrix4x4 &out) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMatrix4x4() [inline, protected]
  • vtkMatrix4x4(const vtkMatrix4x4 &) (defined in vtkMatrix4x4) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMatrix4x4, vtkObject)
  • Zero() [inline]
  • Zero(double Elements[16]) [static]
  • ~vtkMatrix4x4() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMatrixToHomogeneousTransform Member List

This is the complete list of members for vtkMatrixToHomogeneousTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInput() [virtual]
  • GetInverse()
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • Input [protected]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InverseFlag [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMatrixToHomogeneousTransform &) (defined in vtkMatrixToHomogeneousTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkMatrix4x4 *) [virtual]
  • SetInverse(vtkAbstractTransform *transform)
  • SetMatrix(vtkMatrix4x4 *matrix) [inline]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkMatrixToHomogeneousTransform() [protected]
  • vtkMatrixToHomogeneousTransform(const vtkMatrixToHomogeneousTransform &) (defined in vtkMatrixToHomogeneousTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMatrixToHomogeneousTransform, vtkHomogeneousTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkMatrixToHomogeneousTransform() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMatrixToLinearTransform Member List

This is the complete list of members for vtkMatrixToLinearTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInput() [virtual]
  • GetInverse()
  • GetLinearInverse() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • Input [protected]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InverseFlag [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMatrixToLinearTransform &) (defined in vtkMatrixToLinearTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkMatrix4x4 *) [virtual]
  • SetInverse(vtkAbstractTransform *transform)
  • SetMatrix(vtkMatrix4x4 *matrix) [inline]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkLinearTransform() [inline, protected]
  • vtkMatrixToLinearTransform() [protected]
  • vtkMatrixToLinearTransform(const vtkMatrixToLinearTransform &) (defined in vtkMatrixToLinearTransform) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMatrixToLinearTransform, vtkLinearTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkMatrixToLinearTransform() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMCubesReader Member List

This is the complete list of members for vtkMCubesReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FileName [protected]
  • FlipNormals [protected]
  • FlipNormalsOff() [virtual]
  • FlipNormalsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetFlipNormals() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize() [virtual]
  • GetInputs() [inline]
  • GetLimitsFileName() [virtual]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNormals() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LimitsFileName [protected]
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normals [protected]
  • NormalsOff() [virtual]
  • NormalsOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMCubesReader &) (defined in vtkMCubesReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetFlipNormals(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(int) [virtual]
  • SetLimitsFileName(const char *) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNormals(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkMCubesReader() [protected]
  • vtkMCubesReader(const vtkMCubesReader &) (defined in vtkMCubesReader) [private]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMCubesReader, vtkPolyDataSource)
  • ~vtkMCubesReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMCubesWriter Member List

This is the complete list of members for vtkMCubesWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLimitsFileName() [virtual]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LimitsFileName [protected]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkMCubesWriter &) (defined in vtkMCubesWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLimitsFileName(const char *) [virtual]
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkMCubesWriter() [protected]
  • vtkMCubesWriter(const vtkMCubesWriter &) (defined in vtkMCubesWriter) [private]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMCubesWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkMCubesWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:23:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMedicalImageReader2 Member List

This is the complete list of members for vtkMedicalImageReader2, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Date [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDate() [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetImageNumber() [virtual]
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPatientID() [virtual]
  • GetPatientName() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSeries() [virtual]
  • GetStudy() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • ImageNumber [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkMedicalImageReader2 &) (defined in vtkMedicalImageReader2) [private]
  • Outputs [protected]
  • PatientID [protected]
  • PatientName [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • Series [protected]
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDate(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetImageNumber(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetPatientID(const char *) [virtual]
  • SetPatientName(const char *) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSeries(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStudy(const char *) [virtual]
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • Study [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkMedicalImageReader2() [protected]
  • vtkMedicalImageReader2(const vtkMedicalImageReader2 &) (defined in vtkMedicalImageReader2) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMedicalImageReader2, vtkImageReader2)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkMedicalImageReader2() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMemoryLimitImageDataStreamer Member List

This is the complete list of members for vtkMemoryLimitImageDataStreamer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Bypass [protected]
  • BypassOff() [inline]
  • BypassOn() [inline]
  • BypassWasOn [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteInformation(vtkImageData *inData, vtkImageData *outData) [protected, virtual]
  • ExtentTranslator [protected]
  • GetAbortExecute() [virtual]
  • GetBypass() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtentTranslator() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit() [inline]
  • GetInputs() [inline]
  • GetMemoryLimit() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamDivisions() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MemoryLimit [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiThread(vtkImageData *input, vtkImageData *output) [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamDivisions [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkMemoryLimitImageDataStreamer &) (defined in vtkMemoryLimitImageDataStreamer) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBypass(int) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtentTranslator(vtkExtentTranslator *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetInputMemoryLimit(int) [inline]
  • SetMemoryLimit(unsigned long) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfStreamDivisions(int) [virtual]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SplitExtent(int splitExt[6], int startExt[6], int num, int total) [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *inData, vtkImageData *outData, int extent[6], int threadId) [virtual]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *out) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDataStreamer() [protected]
  • vtkImageSource() [protected]
  • vtkImageToImageFilter() [protected]
  • vtkMemoryLimitImageDataStreamer() [protected]
  • vtkMemoryLimitImageDataStreamer(const vtkMemoryLimitImageDataStreamer &) (defined in vtkMemoryLimitImageDataStreamer) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMemoryLimitImageDataStreamer, vtkImageDataStreamer)
  • ~vtkImageDataStreamer() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkImageToImageFilter() [protected]
  • ~vtkMemoryLimitImageDataStreamer() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergeDataObjectFilter Member List

This is the complete list of members for vtkMergeDataObjectFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataObject()
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputField() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMergeDataObjectFilter &) (defined in vtkMergeDataObjectFilter) [private]
  • OutputField [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataObject(vtkDataObject *object)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetOutputField(int) [virtual]
  • SetOutputFieldToCellDataField() [inline]
  • SetOutputFieldToDataObjectField() [inline]
  • SetOutputFieldToPointDataField() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkMergeDataObjectFilter() [protected]
  • vtkMergeDataObjectFilter(const vtkMergeDataObjectFilter &) (defined in vtkMergeDataObjectFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMergeDataObjectFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkMergeDataObjectFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergeFields Member List

This is the complete list of members for vtkMergeFields, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddComponent(Component *op) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ATTRIBUTE enum value [protected]
  • BreakOnError() [static]
  • CELL_DATA enum value
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • DATA_OBJECT enum value
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAllComponents() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldLocation [protected]
  • FieldLocationNames [protected, static]
  • FieldLocations enum name
  • FieldName [protected]
  • FieldType enum name [protected]
  • FindComponent(int index) [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFirst() [inline, protected]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNextComponent(Component *op) [inline, protected]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Head [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Merge(int component, const char *arrayName, int sourceComp)
  • MergeArray(vtkDataArray *in, vtkDataArray *out, int inComp, int outComp) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • NAME enum value [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMergeFields &) (defined in vtkMergeFields) [private]
  • OutputDataType [protected]
  • Outputs [protected]
  • POINT_DATA enum value
  • Print(ostream &os)
  • PrintAllComponents(ostream &os, vtkIndent indent) [inline, protected]
  • PrintComponent(Component *op, ostream &os, vtkIndent indent) [inline, protected]
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetOutputField(const char *name, int fieldLoc)
  • SetOutputField(const char *name, const char *fieldLoc)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tail [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkMergeFields() [protected]
  • vtkMergeFields(const vtkMergeFields &) (defined in vtkMergeFields) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMergeFields, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkMergeFields() [protected, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergeFilter Member List

This is the complete list of members for vtkMergeFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddField(const char *name, vtkDataSet *input)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *data) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldList [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGeometry() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormals()
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalars()
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTCoords()
  • GetTensors()
  • GetUnstructuredGridOutput()
  • GetVectors()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMergeFilter &) (defined in vtkMergeFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGeometry(vtkDataSet *input) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNormals(vtkDataSet *)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalars(vtkDataSet *)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoords(vtkDataSet *)
  • SetTensors(vtkDataSet *)
  • SetVectors(vtkDataSet *)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkMergeFilter() [protected]
  • vtkMergeFilter(const vtkMergeFilter &) (defined in vtkMergeFilter) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMergeFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkMergeFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:23:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergePoints2D Member List

This is the complete list of members for vtkMergePoints2D, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • Buckets [protected]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Divisions [protected]
  • FindClosestNPoints(int N, float x[2], vtkIdList *result) [virtual]
  • FindClosestNPoints(int N, float x, float y, vtkIdList *result) [virtual]
  • FindClosestPoint(float x[2]) [virtual]
  • FindDistributedPoints(int N, float x[2], vtkIdList *result, int M) [virtual]
  • FindDistributedPoints(int N, float x, float y, vtkIdList *result, int M) [virtual]
  • FindPointsWithinRadius(float R, float x[2], vtkIdList *result) [virtual]
  • FindPointsWithinRadius(float R, float x, float y, vtkIdList *result) [virtual]
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(int ijk[2], int ndivs[2], int level) [protected]
  • GetBuildTime() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfPointsPerBucket() [virtual]
  • GetOverlappingBuckets(float x[2], int ijk[2], float dist, int level) [protected]
  • GetPoints() [virtual]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HashTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertionTol2 [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInsertedPoint(float x[2]) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfBuckets [protected]
  • NumberOfPointsPerBucket [protected]
  • operator=(const vtkMergePoints2D &) (defined in vtkMergePoints2D) [private]
  • Points [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int) [virtual]
  • SetDivisions(int[2])
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfPointsPerBucket(int) [virtual]
  • SetPoints(vtkPoints *) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkLocator() [protected]
  • vtkMergePoints2D() [inline, protected]
  • vtkMergePoints2D(const vtkMergePoints2D &) (defined in vtkMergePoints2D) [private]
  • vtkObject() [protected]
  • vtkPointLocator2D() [protected]
  • vtkTypeRevisionMacro(vtkMergePoints2D, vtkPointLocator2D)
  • ~vtkLocator() [protected]
  • ~vtkMergePoints2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointLocator2D() [protected]
Generated on Mon Mar 25 01:23:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergePoints Member List

This is the complete list of members for vtkMergePoints, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distance2ToBounds(const float x[3], const float bounds[6]) [protected]
  • Distance2ToBucket(const float x[3], const int nei[3]) [protected]
  • Divisions [protected]
  • FindClosestInsertedPoint(const float x[3]) [virtual]
  • FindClosestNPoints(int N, const float x[3], vtkIdList *result) [virtual]
  • FindClosestNPoints(int N, float x, float y, float z, vtkIdList *result) [virtual]
  • FindClosestPoint(const float x[3]) [virtual]
  • FindClosestPoint(float x, float y, float z)
  • FindClosestPointWithinRadius(float radius, const float x[3], float &dist2)
  • FindClosestPointWithinRadius(float radius, const float x[3], float inputDataLength, float &dist2)
  • FindDistributedPoints(int N, const float x[3], vtkIdList *result, int M) [virtual]
  • FindDistributedPoints(int N, float x, float y, float z, vtkIdList *result, int M) [virtual]
  • FindPointsWithinRadius(float R, const float x[3], vtkIdList *result) [virtual]
  • FindPointsWithinRadius(float R, float x, float y, float z, vtkIdList *result) [virtual]
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(vtkNeighborPoints *buckets, const int ijk[3], const int ndivs[3], int level) [protected]
  • GetBuildTime() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfPointsPerBucket() [virtual]
  • GetOverlappingBuckets(vtkNeighborPoints *buckets, const float x[3], const int ijk[3], float dist, int level) [protected]
  • GetOverlappingBuckets(vtkNeighborPoints *buckets, const float x[3], float dist, int prevMinLevel[3], int prevMaxLevel[3]) [protected]
  • GetPointsInBucket(const float x[3], int ijk[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HashTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitPointInsertion(vtkPoints *newPts, const float bounds[6]) [virtual]
  • InitPointInsertion(vtkPoints *newPts, const float bounds[6], vtkIdType estSize) [virtual]
  • InsertionLevel [protected]
  • InsertionPointId [protected]
  • InsertionTol2 [protected]
  • InsertNextPoint(const float x[3]) [virtual]
  • InsertPoint(vtkIdType ptId, const float x[3]) [virtual]
  • InsertUniquePoint(const float x[3], vtkIdType &ptId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInsertedPoint(const float x[3]) [virtual]
  • IsInsertedPoint(float x, float y, float z) [inline]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfBuckets [protected]
  • NumberOfPointsPerBucket [protected]
  • operator=(const vtkMergePoints &) (defined in vtkMergePoints) [private]
  • Points [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int, int) [virtual]
  • SetDivisions(int[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfPointsPerBucket(int) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkLocator() [protected]
  • vtkMergePoints() [inline, protected]
  • vtkMergePoints(const vtkMergePoints &) (defined in vtkMergePoints) [private]
  • vtkObject() [protected]
  • vtkPointLocator() [protected]
  • vtkTypeRevisionMacro(vtkMergePoints, vtkPointLocator)
  • ~vtkLocator() [protected]
  • ~vtkMergePoints() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointLocator() [protected]
Generated on Mon Mar 25 01:23:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaActor Member List

This is the complete list of members for vtkMesaActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ApplyProperties() [inline, virtual]
  • BackfaceProperty [protected]
  • Bounds [protected]
  • BoundsMTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBackfaceProperty()
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetIsOpaque() [protected]
  • GetLength()
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPart() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfParts() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetTexture() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPartTraversal() [virtual]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • MakeProperty() [virtual]
  • Mapper [protected]
  • MapperBounds [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkMesaActor &) (defined in vtkMesaActor) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkMapper *mapper) [virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBackfaceProperty(vtkProperty *lut)
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkMapper *) [virtual]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkProperty *lut)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetTexture(vtkTexture *) [virtual]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Texture [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor() [protected]
  • vtkMesaActor() [inline, protected]
  • vtkMesaActor(const vtkMesaActor &) (defined in vtkMesaActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkMesaActor, vtkActor)
  • ~vtkActor() [protected]
  • ~vtkMesaActor() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:23:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaCamera Member List

This is the complete list of members for vtkMesaCamera, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplyTransform(vtkTransform *t)
  • Azimuth(double angle)
  • BreakOnError() [static]
  • CameraLightTransform [protected]
  • ClippingRange [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCameraLightTransform() [protected]
  • ComputeCompositePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeDistance() [protected]
  • ComputePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeViewPlaneNormal()
  • ComputeViewTransform() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DirectionOfProjection [protected]
  • Distance [protected]
  • Dolly(double distance)
  • Elevation(double angle)
  • EyeAngle [protected]
  • FocalDisk [protected]
  • FocalPoint [protected]
  • GetCameraLightTransformMatrix()
  • GetClassName() [inline, virtual]
  • GetClippingRange() [virtual]
  • GetClippingRange(double &, double &) [virtual]
  • GetClippingRange(double[2]) [virtual]
  • GetClippingRange(float a[2]) [inline]
  • GetCommand(unsigned long tag)
  • GetCompositePerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetCompositePerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetDebug()
  • GetDirectionOfProjection() [virtual]
  • GetDirectionOfProjection(double &, double &, double &) [virtual]
  • GetDirectionOfProjection(double[3]) [virtual]
  • GetDirectionOfProjection(float a[3]) [inline]
  • GetDistance() [virtual]
  • GetEyeAngle() [virtual]
  • GetFocalDisk() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(double &, double &, double &) [virtual]
  • GetFocalPoint(double[3]) [virtual]
  • GetFocalPoint(float a[3]) [inline]
  • GetFrustumPlanes(float aspect, float planes[24])
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOrientation() [inline]
  • GetOrientationWXYZ() [inline]
  • GetParallelProjection() [virtual]
  • GetParallelScale() [virtual]
  • GetPerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetPerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetPosition() [virtual]
  • GetPosition(double &, double &, double &) [virtual]
  • GetPosition(double[3]) [virtual]
  • GetPosition(float a[3]) [inline]
  • GetReferenceCount() [inline]
  • GetRoll()
  • GetThickness() [virtual]
  • GetViewAngle() [virtual]
  • GetViewingRaysMTime()
  • GetViewPlaneNormal() [virtual]
  • GetViewPlaneNormal(double &, double &, double &) [virtual]
  • GetViewPlaneNormal(double[3]) [virtual]
  • GetViewPlaneNormal(float a[3]) [inline]
  • GetViewShear() [virtual]
  • GetViewShear(double &, double &, double &) [virtual]
  • GetViewShear(double[3]) [virtual]
  • GetViewTransform() [inline]
  • GetViewTransformMatrix() [inline]
  • GetViewTransformObject() [inline]
  • GetViewUp() [virtual]
  • GetViewUp(double &, double &, double &) [virtual]
  • GetViewUp(double[3]) [virtual]
  • GetViewUp(float a[3]) [inline]
  • GetWindowCenter() [virtual]
  • GetWindowCenter(double &, double &) [virtual]
  • GetWindowCenter(double[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftEye [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • ObliqueAngles [protected]
  • operator=(const vtkMesaCamera &) (defined in vtkMesaCamera) [private]
  • OrthogonalizeViewUp()
  • ParallelProjection [protected]
  • ParallelProjectionOff() [virtual]
  • ParallelProjectionOn() [virtual]
  • ParallelScale [protected]
  • PerspectiveTransform [protected]
  • Pitch(double angle)
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • Roll(double angle)
  • SafeDownCast(vtkObject *o) [static]
  • SetClippingRange(double near, double far)
  • SetClippingRange(const double a[2]) [inline]
  • SetClippingRange(const float a[2]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDistance(double)
  • SetEyeAngle(double) [virtual]
  • SetFocalDisk(double) [virtual]
  • SetFocalPoint(double x, double y, double z)
  • SetFocalPoint(const double a[3]) [inline]
  • SetFocalPoint(const float a[3]) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetObliqueAngles(double alpha, double beta)
  • SetParallelProjection(int flag)
  • SetParallelScale(double scale)
  • SetPosition(double x, double y, double z)
  • SetPosition(const double a[3]) [inline]
  • SetPosition(const float a[3]) [inline]
  • SetReferenceCount(int)
  • SetRoll(double angle)
  • SetThickness(double)
  • SetViewAngle(double angle)
  • SetViewPlaneNormal(double x, double y, double z)
  • SetViewPlaneNormal(const double a[3]) [inline]
  • SetViewPlaneNormal(const float a[3]) [inline]
  • SetViewShear(double dxdz, double dydz, double center)
  • SetViewShear(double d[3])
  • SetViewUp(double vx, double vy, double vz)
  • SetViewUp(const double a[3]) [inline]
  • SetViewUp(const float a[3]) [inline]
  • SetWindowCenter(double x, double y)
  • Stereo [protected]
  • SubjectHelper [protected]
  • Thickness [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateViewport(vtkRenderer *ren)
  • vtkCamera::UpdateViewport(vtkRenderer *vtkNotUsed(ren)) [inline, virtual]
  • ViewAngle [protected]
  • ViewingRaysModified()
  • ViewingRaysMTime [protected]
  • ViewPlaneNormal [protected]
  • ViewShear [protected]
  • ViewTransform [protected]
  • ViewUp [protected]
  • vtkCamera() [protected]
  • vtkMesaCamera() [inline, protected]
  • vtkMesaCamera(const vtkMesaCamera &) (defined in vtkMesaCamera) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaCamera, vtkCamera)
  • WindowCenter [protected]
  • Yaw(double angle)
  • Zoom(double factor)
  • ~vtkCamera() [protected]
  • ~vtkMesaCamera() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:23:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaImageActor Member List

This is the complete list of members for vtkMesaImageActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Coords [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent [protected]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDisplayExtent(int extent[6])
  • GetDisplayExtent() [inline]
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInterpolate() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetSliceNumber()
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [inline]
  • GlobalIndex [protected, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Index [protected]
  • InitPathTraversal() [virtual]
  • Input [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *ren) [virtual]
  • LoadTime [protected]
  • MakeDataSuitable(int &xsize, int &ysize, int &release) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkMesaImageActor &) (defined in vtkMesaImageActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RenderWindow [protected]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayExtent(int extent[6])
  • SetDisplayExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *) [virtual]
  • SetInterpolate(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • SetZSlice(int z) [inline]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • TCoords [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkImageActor() [protected]
  • vtkMesaImageActor() [protected]
  • vtkMesaImageActor(const vtkMesaImageActor &) (defined in vtkMesaImageActor) [private]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkMesaImageActor, vtkImageActor)
  • ~vtkImageActor() [protected]
  • ~vtkMesaImageActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:24:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaImageMapper Member List

This is the complete list of members for vtkMesaImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CustomDisplayExtents [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMesaImageMapper &) (defined in vtkMesaImageMapper) [private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkMesaImageMapper() [protected]
  • vtkMesaImageMapper(const vtkMesaImageMapper &) (defined in vtkMesaImageMapper) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaImageMapper, vtkImageMapper)
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkMesaImageMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:24:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaImager Member List

This is the complete list of members for vtkMesaImager, including all inherited members.
  • Actors2D [protected]
  • AddActor2D(vtkProp *p) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • Aspect [protected]
  • Background [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender() [protected, virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick() [protected, virtual]
  • EndTag [protected]
  • Erase() [virtual]
  • GetActors2D()
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetImageWindow()
  • GetIsPicking() [virtual]
  • GetMTime() [virtual]
  • GetOrigin()
  • GetPickedId() [protected, virtual]
  • GetPickedZ() [virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetReferenceCount() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVTKWindow() [inline, virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • operator=(const vtkMesaImager &) (defined in vtkMesaImager) [private]
  • Origin [protected]
  • PickedProp [protected]
  • PickFromProps [protected]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Props [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RenderOpaqueGeometry() [virtual]
  • RenderOverlay() [virtual]
  • RenderTranslucentGeometry() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageWindow(vtkImageWindow *win)
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetVTKWindow(vtkWindow *win)
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize) [protected, virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePickId() [protected, virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &, float &, float &) [inline, virtual]
  • vtkImager() [protected]
  • vtkMesaImager() [inline, protected]
  • vtkMesaImager(const vtkMesaImager &) (defined in vtkMesaImager) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaImager, vtkImager)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &, float &, float &) [inline, virtual]
  • ~vtkImager() [protected]
  • ~vtkMesaImager() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:24:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaImageWindow Member List

This is the complete list of members for vtkMesaImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateDirectColorMap() [protected]
  • BreakOnError() [static]
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMap [protected]
  • Colors [protected]
  • ContextId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayId [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Drawable [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [inline, virtual]
  • FileName [protected]
  • Frame() [virtual]
  • Gc [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultVisualInfo(XVisualInfo *info) [protected]
  • GetDesiredColormap() [virtual]
  • GetDesiredDepth() [virtual]
  • GetDesiredVisual() [virtual]
  • GetDesiredVisualInfo()
  • GetDisplayId()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGC()
  • GetGenericContext() [virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetParentId()
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPosition() [virtual]
  • GetPosition(int *x, int *y) [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetShiftsScalesAndMasks(int &rshift, int &gshift, int &bshift, int &rscale, int &gscale, int &bscale, unsigned long &rmask, unsigned long &gmask, unsigned long &bmask) [protected]
  • GetSize() [virtual]
  • GetSize(int *x, int *y) [inline, virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetVisualClass() [virtual]
  • GetVisualDepth() [virtual]
  • GetVisualId() [inline]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeColorMap(Visual *visual) [protected]
  • MakeCurrent() [virtual]
  • MakeDefaultWindow() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • OffScreenContextId [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OffScreenWindow [protected]
  • Offset [protected]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkMesaImageWindow &) (defined in vtkMesaImageWindow) [private]
  • OwnDisplay [protected]
  • ParentId [protected]
  • PixmapHeight [protected]
  • PixmapWidth [protected]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • SetBackgroundColor(float r, float g, float b)
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(Display *)
  • SetDisplayId(void *) [virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int i) [virtual]
  • SetParentId(Window)
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *info) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int x, int y) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(Window)
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *info) [virtual]
  • SetWindowName(char *name) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • VisualClass [protected]
  • VisualDepth [protected]
  • VisualId [protected]
  • vtkImageWindow() [protected]
  • vtkMesaImageWindow() [protected]
  • vtkMesaImageWindow(const vtkMesaImageWindow &) (defined in vtkMesaImageWindow) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaImageWindow, vtkXImageWindow)
  • vtkWindow() [protected]
  • vtkXImageWindow() [protected]
  • WindowCreated [protected]
  • WindowId [protected]
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkMesaImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWindow() [protected]
  • ~vtkXImageWindow() [protected]
Generated on Mon Mar 25 01:24:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaLight Member List

This is the complete list of members for vtkMesaLight, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AttenuationValues [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ConeAngle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkLight *light)
  • Delete() [virtual]
  • Exponent [protected]
  • FocalPoint [protected]
  • GetAttenuationValues() [virtual]
  • GetAttenuationValues(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetConeAngle() [virtual]
  • GetDebug()
  • GetExponent() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIntensity() [virtual]
  • GetLightType() [virtual]
  • GetMTime() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetPositional() [virtual]
  • GetReferenceCount() [inline]
  • GetSwitch() [virtual]
  • GetTransformedFocalPoint(float &a0, float &a1, float &a2)
  • GetTransformedFocalPoint(float a[3])
  • GetTransformedFocalPoint()
  • GetTransformedPosition(float &a0, float &a1, float &a2)
  • GetTransformedPosition(float a[3])
  • GetTransformedPosition()
  • GetTransformMatrix() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intensity [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LightType [protected]
  • LightTypeIsCameraLight()
  • LightTypeIsHeadlight()
  • LightTypeIsSceneLight()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMesaLight &) (defined in vtkMesaLight) [private]
  • Position [protected]
  • Positional [protected]
  • PositionalOff() [virtual]
  • PositionalOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadSelf(istream &is)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, int light_index) [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAttenuationValues(float, float, float) [virtual]
  • SetAttenuationValues(float[3]) [virtual]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetConeAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionAngle(float elevation, float azimuth)
  • SetDirectionAngle(float ang[2]) [inline]
  • SetExponent(float) [virtual]
  • SetFocalPoint(float, float, float) [virtual]
  • SetFocalPoint(float[3]) [virtual]
  • SetFocalPoint(double *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIntensity(float) [virtual]
  • SetLightType(int) [virtual]
  • SetLightTypeToCameraLight()
  • SetLightTypeToHeadlight()
  • SetLightTypeToSceneLight()
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetPosition(double *a) [inline]
  • SetPositional(int) [virtual]
  • SetReferenceCount(int)
  • SetSwitch(int) [virtual]
  • SetTransformMatrix(vtkMatrix4x4 *) [virtual]
  • SubjectHelper [protected]
  • Switch [protected]
  • SwitchOff() [virtual]
  • SwitchOn() [virtual]
  • TransformedFocalPointReturn [protected]
  • TransformedPositionReturn [protected]
  • TransformMatrix [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkLight() [protected]
  • vtkMesaLight() [inline, protected]
  • vtkMesaLight(const vtkMesaLight &) (defined in vtkMesaLight) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaLight, vtkLight)
  • WriteSelf(ostream &os)
  • ~vtkLight() [protected]
  • ~vtkMesaLight() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:24:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaPolyDataMapper2D Member List

This is the complete list of members for vtkMesaPolyDataMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarMode() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetTransformCoordinate() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMesaPolyDataMapper2D &) (defined in vtkMesaPolyDataMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransformCoordinate(vtkCoordinate *) [virtual]
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • TransformCoordinate [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkMesaPolyDataMapper2D() [inline, protected]
  • vtkMesaPolyDataMapper2D(const vtkMesaPolyDataMapper2D &) (defined in vtkMesaPolyDataMapper2D) [private]
  • vtkObject() [protected]
  • vtkPolyDataMapper2D() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaPolyDataMapper2D, vtkPolyDataMapper2D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkMesaPolyDataMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper2D() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:24:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaPolyDataMapper Member List

This is the complete list of members for vtkMesaPolyDataMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(const char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Draw(vtkRenderer *ren, vtkActor *a) [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGhostLevel() [virtual]
  • GetGlobalImmediateModeRendering() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImmediateModeRendering() [virtual]
  • GetInput()
  • GetInputAsDataSet() [inline]
  • GetInputs() [inline]
  • GetLength()
  • GetLmcolorMode(vtkProperty *prop)
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfSubPieces() [virtual]
  • GetPiece() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTime() [virtual]
  • GetResolveCoincidentTopology() [static]
  • GetResolveCoincidentTopologyPolygonOffsetParameters(float &factor, float &units) [static]
  • GetResolveCoincidentTopologyZShift() [static]
  • GetScalarMode() [virtual]
  • GetScalarModeAsString()
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GhostLevel [protected]
  • GlobalImmediateModeRenderingOff() [inline, static]
  • GlobalImmediateModeRenderingOn() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImmediateModeRendering [protected]
  • ImmediateModeRenderingOff() [virtual]
  • ImmediateModeRenderingOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • ListId [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfPieces [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubPieces [protected]
  • operator=(const vtkMesaPolyDataMapper &) (defined in vtkMesaPolyDataMapper) [private]
  • Piece [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkActor *act) [virtual]
  • RenderPiece(vtkRenderer *ren, vtkActor *a) [virtual]
  • RenderTime [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGhostLevel(int) [virtual]
  • SetGlobalImmediateModeRendering(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImmediateModeRendering(int) [virtual]
  • SetInput(vtkPolyData *in)
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfPieces(int) [virtual]
  • SetNumberOfSubPieces(int) [virtual]
  • SetPiece(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTime(float time) [inline]
  • SetResolveCoincidentTopology(int val) [static]
  • SetResolveCoincidentTopologyPolygonOffsetParameters(float factor, float units) [static]
  • SetResolveCoincidentTopologyToDefault() [static]
  • SetResolveCoincidentTopologyToOff() [inline, static]
  • SetResolveCoincidentTopologyToPolygonOffset() [inline, static]
  • SetResolveCoincidentTopologyToShiftZBuffer() [inline, static]
  • SetResolveCoincidentTopologyZShift(double val) [static]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMapper() [protected]
  • vtkMesaPolyDataMapper() [protected]
  • vtkMesaPolyDataMapper(const vtkMesaPolyDataMapper &) (defined in vtkMesaPolyDataMapper) [private]
  • vtkObject() [protected]
  • vtkPolyDataMapper() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaPolyDataMapper, vtkPolyDataMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMapper() [protected]
  • ~vtkMesaPolyDataMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:24:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaProperty Member List

This is the complete list of members for vtkMesaProperty, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Ambient [protected]
  • AmbientColor [protected]
  • BackfaceCulling [protected]
  • BackfaceCullingOff() [virtual]
  • BackfaceCullingOn() [virtual]
  • BackfaceRender(vtkActor *a, vtkRenderer *ren) [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkProperty *p)
  • Delete() [virtual]
  • Diffuse [protected]
  • DiffuseColor [protected]
  • EdgeColor [protected]
  • EdgeVisibility [protected]
  • EdgeVisibilityOff() [virtual]
  • EdgeVisibilityOn() [virtual]
  • FrontfaceCulling [protected]
  • FrontfaceCullingOff() [virtual]
  • FrontfaceCullingOn() [virtual]
  • GetAmbient() [virtual]
  • GetAmbientColor() [virtual]
  • GetAmbientColor(float data[3]) [virtual]
  • GetBackfaceCulling() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor()
  • GetColor(float rgb[3])
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiffuse() [virtual]
  • GetDiffuseColor() [virtual]
  • GetDiffuseColor(float data[3]) [virtual]
  • GetEdgeColor() [virtual]
  • GetEdgeColor(float data[3]) [virtual]
  • GetEdgeVisibility() [virtual]
  • GetFrontfaceCulling() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInterpolation() [virtual]
  • GetInterpolationAsString() [inline]
  • GetLineStipplePattern() [virtual]
  • GetLineStippleRepeatFactor() [virtual]
  • GetLineWidth() [virtual]
  • GetMTime() [virtual]
  • GetOpacity() [virtual]
  • GetPointSize() [virtual]
  • GetReferenceCount() [inline]
  • GetRepresentation() [virtual]
  • GetRepresentationAsString() [inline]
  • GetSpecular() [virtual]
  • GetSpecularColor() [virtual]
  • GetSpecularColor(float data[3]) [virtual]
  • GetSpecularPower() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interpolation [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineStipplePattern [protected]
  • LineStippleRepeatFactor [protected]
  • LineWidth [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Opacity [protected]
  • operator=(const vtkMesaProperty &) (defined in vtkMesaProperty) [private]
  • PointSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkActor *a, vtkRenderer *ren) [virtual]
  • Representation [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAmbient(float) [virtual]
  • SetAmbientColor(float, float, float) [virtual]
  • SetAmbientColor(float[3]) [virtual]
  • SetBackfaceCulling(int) [virtual]
  • SetColor(float r, float g, float b)
  • SetColor(float a[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDiffuse(float) [virtual]
  • SetDiffuseColor(float, float, float) [virtual]
  • SetDiffuseColor(float[3]) [virtual]
  • SetEdgeColor(float, float, float) [virtual]
  • SetEdgeColor(float[3]) [virtual]
  • SetEdgeVisibility(int) [virtual]
  • SetFrontfaceCulling(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInterpolation(int) [virtual]
  • SetInterpolationToFlat() [inline]
  • SetInterpolationToGouraud() [inline]
  • SetInterpolationToPhong() [inline]
  • SetLineStipplePattern(int) [virtual]
  • SetLineStippleRepeatFactor(int) [virtual]
  • SetLineWidth(float) [virtual]
  • SetOpacity(float) [virtual]
  • SetPointSize(float) [virtual]
  • SetReferenceCount(int)
  • SetRepresentation(int) [virtual]
  • SetRepresentationToPoints() [inline]
  • SetRepresentationToSurface() [inline]
  • SetRepresentationToWireframe() [inline]
  • SetSpecular(float) [virtual]
  • SetSpecularColor(float, float, float) [virtual]
  • SetSpecularColor(float[3]) [virtual]
  • SetSpecularPower(float) [virtual]
  • Specular [protected]
  • SpecularColor [protected]
  • SpecularPower [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMesaProperty() [inline, protected]
  • vtkMesaProperty(const vtkMesaProperty &) (defined in vtkMesaProperty) [private]
  • vtkObject() [protected]
  • vtkProperty() [protected]
  • vtkTypeRevisionMacro(vtkMesaProperty, vtkProperty)
  • ~vtkMesaProperty() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProperty() [inline, protected]
Generated on Mon Mar 25 01:24:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaRenderer Member List

This is the complete list of members for vtkMesaRenderer, including all inherited members.
  • ActiveCamera [protected]
  • Actors [protected]
  • Actors2D [protected]
  • AddActor(vtkProp *p) [inline]
  • AddActor2D(vtkProp *p) [inline]
  • AddCuller(vtkCuller *)
  • AddLight(vtkLight *)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • AddVolume(vtkProp *p) [inline]
  • AllocatedRenderTime [protected]
  • AllocateTime() [protected]
  • Ambient [protected]
  • Aspect [protected]
  • Background [protected]
  • BackingImage [protected]
  • BackingStore [protected]
  • BackingStoreOff() [virtual]
  • BackingStoreOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • Clear(void) [virtual]
  • ClearLights(void)
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • ComputeVisiblePropBounds(float bounds[6])
  • CreatedLight [protected]
  • CreateLight(void)
  • Cullers [protected]
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender() [protected, virtual]
  • DeviceRender(void) [virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick() [protected, virtual]
  • EndTag [protected]
  • GetActiveCamera()
  • GetActors()
  • GetActors2D()
  • GetAllocatedRenderTime() [virtual]
  • GetAmbient() [virtual]
  • GetAmbient(float data[3]) [virtual]
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetBackingStore() [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCullers() [inline]
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInteractive() [virtual]
  • GetIsPicking() [virtual]
  • GetLastRenderTimeInSeconds() [virtual]
  • GetLayer() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetLights() [inline]
  • GetMTime() [virtual]
  • GetNumberOfPropsRenderedAsGeometry() [virtual]
  • GetOrigin()
  • GetPickedId() [protected, virtual]
  • GetPickedZ() [protected, virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetRayCaster() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetTimeFactor() [virtual]
  • GetTwoSidedLighting() [virtual]
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVolumes()
  • GetVTKWindow() [virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GetZ(int x, int y)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interactive [protected]
  • InteractiveOff() [virtual]
  • InteractiveOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LastRenderTimeInSeconds [protected]
  • Layer [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Lights [protected]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • MakeCamera() [virtual]
  • MakeLight() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • NumberOfLightsBound [protected]
  • NumberOfPropsRenderedAsGeometry [protected]
  • NumberOfPropsToRayCast [protected]
  • NumberOfPropsToRenderIntoImage [protected]
  • operator=(const vtkMesaRenderer &) (defined in vtkMesaRenderer) [private]
  • Origin [protected]
  • PathArray [protected]
  • PathArrayCount [protected]
  • PickedProp [protected]
  • PickedZ [protected]
  • PickFromProps [protected]
  • PickGeometry() [protected, virtual]
  • PickInfo [protected]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickRender(vtkPropCollection *props) [protected, virtual]
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropArray [protected]
  • PropArrayCount [protected]
  • Props [protected]
  • RayCaster [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor(vtkProp *p) [inline]
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveCuller(vtkCuller *)
  • RemoveLight(vtkLight *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RemoveVolume(vtkProp *p) [inline]
  • Render() [virtual]
  • RenderOverlay()
  • RenderTime [protected]
  • RenderWindow [protected]
  • ResetCamera()
  • ResetCamera(float bounds[6])
  • ResetCamera(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • ResetCameraClippingRange()
  • ResetCameraClippingRange(float bounds[6])
  • ResetCameraClippingRange(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SafeDownCast(vtkObject *o) [static]
  • SetActiveCamera(vtkCamera *)
  • SetAllocatedRenderTime(float) [virtual]
  • SetAmbient(float, float, float) [virtual]
  • SetAmbient(float[3]) [virtual]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetBackingStore(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractive(int) [virtual]
  • SetLayer(int) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetTwoSidedLighting(int) [virtual]
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize) [protected, virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeFactor [protected]
  • Transparent()
  • TwoSidedLighting [protected]
  • TwoSidedLightingOff() [virtual]
  • TwoSidedLightingOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateCamera(void) [protected, virtual]
  • UpdateGeometry(void) [protected, virtual]
  • UpdateLightGeometry(void) [protected, virtual]
  • UpdateLights(void) [virtual]
  • UpdatePickId() [protected, virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &wx, float &wy, float &wz) [virtual]
  • VisibleActorCount()
  • VisibleVolumeCount()
  • Volumes [protected]
  • vtkMesaRenderer() [protected]
  • vtkMesaRenderer(const vtkMesaRenderer &) (defined in vtkMesaRenderer) [private]
  • vtkObject() [protected]
  • vtkRenderer() [protected]
  • vtkTypeRevisionMacro(vtkMesaRenderer, vtkRenderer)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &wx, float &wy, float &wz) [virtual]
  • ~vtkMesaRenderer() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderer() [protected]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:24:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaRenderWindow Member List

This is the complete list of members for vtkMesaRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame() [inline, virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [inline, virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline, virtual]
  • InAbortCheck [protected]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent()=0 [pure virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldMonitorSetting [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkMesaRenderWindow &) (defined in vtkMesaRenderWindow) [private]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [inline, virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *) [inline, virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *) [inline, virtual]
  • SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [inline, virtual]
  • Size [protected]
  • Start() [inline, virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMesaRenderWindow() [protected]
  • vtkMesaRenderWindow(const vtkMesaRenderWindow &) (defined in vtkMesaRenderWindow) [private]
  • vtkObject() [protected]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkMesaRenderWindow, vtkRenderWindow)
  • vtkWindow() [protected]
  • WindowName [protected]
  • WindowRemap() [inline, virtual]
  • ~vtkMesaRenderWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:24:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaTexture Member List

This is the complete list of members for vtkMesaTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInterpolate() [virtual]
  • GetLookupTable() [virtual]
  • GetMapColorScalarsThroughLookupTable() [virtual]
  • GetMappedScalars() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetQuality() [virtual]
  • GetReferenceCount() [inline]
  • GetRepeat() [virtual]
  • GlobalIndex [protected, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Index [protected]
  • Inputs [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *ren) [virtual]
  • LoadTime [protected]
  • LookupTable [protected]
  • MapColorScalarsThroughLookupTable [protected]
  • MapColorScalarsThroughLookupTableOff() [virtual]
  • MapColorScalarsThroughLookupTableOn() [virtual]
  • MappedScalars [protected]
  • MapScalarsToColors(vtkDataArray *scalars)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMesaTexture &) (defined in vtkMesaTexture) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • Quality [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • RenderWindow [protected]
  • Repeat [protected]
  • RepeatOff() [virtual]
  • RepeatOn() [virtual]
  • ResampleToPowerOfTwo(int &xsize, int &ysize, unsigned char *dptr, int bpp) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelfAdjustingTableRange [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInterpolate(int) [virtual]
  • SetLookupTable(vtkLookupTable *)
  • SetMapColorScalarsThroughLookupTable(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQuality(int) [virtual]
  • SetQualityTo16Bit() [inline]
  • SetQualityTo32Bit() [inline]
  • SetQualityToDefault() [inline]
  • SetReferenceCount(int)
  • SetRepeat(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkMesaTexture() [protected]
  • vtkMesaTexture(const vtkMesaTexture &) (defined in vtkMesaTexture) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTexture() [protected]
  • vtkTypeRevisionMacro(vtkMesaTexture, vtkTexture)
  • ~vtkMesaTexture() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTexture() [protected]
Generated on Mon Mar 25 01:24:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaVolumeRayCastMapper Member List

This is the complete list of members for vtkMesaVolumeRayCastMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AutoAdjustSampleDistances [protected]
  • AutoAdjustSampleDistancesOff() [virtual]
  • AutoAdjustSampleDistancesOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • ClipRayAgainstClippingPlanes(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [protected]
  • ClipRayAgainstVolume(VTKVRCDynamicInfo *dynamicInfo, float bounds[6]) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeMatrices(vtkImageData *data, vtkVolume *vol) [protected]
  • ComputeRowBounds(vtkVolume *vol, vtkRenderer *ren) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdjustSampleDistances() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientShader() [virtual]
  • GetImageSampleDistance() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetMaximumImageSampleDistance() [virtual]
  • GetMinimumImageSampleDistance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetSampleDistance() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetVolumeRayCastFunction() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetZBufferValue(int x, int y) [protected]
  • GetZeroOpacityThreshold(vtkVolume *vol)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientShader [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Image [protected]
  • ImageClipper [protected]
  • ImageInUseSize [protected]
  • ImageMemorySize [protected]
  • ImageOrigin [protected]
  • ImageSampleDistance [protected]
  • ImageViewportSize [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeClippingPlanes(VTKVRCStaticInfo *staticInfo, vtkPlaneCollection *planes) [protected]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MaximumImageSampleDistance [protected]
  • MinimumImageSampleDistance [protected]
  • MinimumViewDistance [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • OldRowBounds [protected]
  • operator=(const vtkMesaVolumeRayCastMapper &) (defined in vtkMesaVolumeRayCastMapper) [private]
  • PerspectiveMatrix [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderRendererTable [protected]
  • RenderTableEntries [protected]
  • RenderTableSize [protected]
  • RenderTexture(vtkVolume *vol, vtkRenderer *ren) [protected, virtual]
  • RenderTimeTable [protected]
  • RenderVolumeTable [protected]
  • RetrieveRenderTime(vtkRenderer *ren, vtkVolume *vol) [protected]
  • RowBounds [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • ScalarDataPointer [protected]
  • ScalarDataType [protected]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdjustSampleDistances(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetImageSampleDistance(float) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetMaximumImageSampleDistance(float) [virtual]
  • SetMinimumImageSampleDistance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfThreads(int num)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetSampleDistance(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVolumeRayCastFunction(vtkVolumeRayCastFunction *) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StoreRenderTime(vtkRenderer *ren, vtkVolume *vol, float t) [protected]
  • SubjectHelper [protected]
  • Threader [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UpdateShadingTables(vtkRenderer *ren, vtkVolume *vol) [protected]
  • ViewToVoxelsMatrix [protected]
  • ViewToWorldMatrix [protected]
  • VolumeRayCastFunction [protected]
  • VolumeRayCastMapper_CastRays(void *arg) [friend]
  • VoxelCroppingRegionPlanes [protected]
  • VoxelsToViewMatrix [protected]
  • VoxelsToWorldMatrix [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMesaVolumeRayCastMapper() [protected]
  • vtkMesaVolumeRayCastMapper(const vtkMesaVolumeRayCastMapper &) (defined in vtkMesaVolumeRayCastMapper) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaVolumeRayCastMapper, vtkVolumeRayCastMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeRayCastMapper() [protected]
  • WorldSampleDistance [protected]
  • WorldToVoxelsMatrix [protected]
  • ZBuffer [protected]
  • ZBufferOrigin [protected]
  • ZBufferSize [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMesaVolumeRayCastMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeRayCastMapper() [protected]
Generated on Mon Mar 25 01:24:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMesaVolumeTextureMapper2D Member List

This is the complete list of members for vtkMesaVolumeTextureMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArraySize [protected]
  • AxisTextureSize [protected]
  • BlueDiffuseShadingTable [protected]
  • BlueSpecularShadingTable [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeAxisTextureSize(int axis, int *size) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodedNormals [protected]
  • EndTag [protected]
  • GenerateTexturesAndRenderQuads(vtkRenderer *ren, vtkVolume *vol) [protected]
  • GetAbortExecute() [virtual]
  • GetAxisTextureSize() [inline]
  • GetBlueDiffuseShadingTable() [inline]
  • GetBlueSpecularShadingTable() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetEncodedNormals() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes() [inline]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientOpacityArray() [inline]
  • GetGradientShader() [virtual]
  • GetGreenDiffuseShadingTable() [inline]
  • GetGreenSpecularShadingTable() [inline]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetInternalSkipFactor() [inline]
  • GetLength()
  • GetMaximumNumberOfPlanes() [virtual]
  • GetMaximumStorageSize() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRedDiffuseShadingTable() [inline]
  • GetRedSpecularShadingTable() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRGBAArray() [inline]
  • GetSaveTextures() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShade() [virtual]
  • GetTargetTextureSize() [virtual]
  • GetTargetTextureSize(int &, int &) [virtual]
  • GetTargetTextureSize(int[2]) [virtual]
  • GetTexture() [inline]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientMagnitudes [protected]
  • GradientOpacityArray [protected]
  • GradientShader [protected]
  • GreenDiffuseShadingTable [protected]
  • GreenSpecularShadingTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol) [inline, protected]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol, int majorDirection) [protected]
  • Inputs [protected]
  • InternalSkipFactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MajorDirection [protected]
  • MaximumNumberOfPlanes [protected]
  • MaximumStorageSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkMesaVolumeTextureMapper2D &) (defined in vtkMesaVolumeTextureMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RedDiffuseShadingTable [protected]
  • RedSpecularShadingTable [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkVolume *vol) [virtual]
  • RenderQuads(int count, float *v, float *t, unsigned char *texture, int size[2], int reverseFlag)
  • vtkVolumeTextureMapper2D::RenderQuads(int vtkNotUsed(count), float *vtkNotUsed(v), float *vtkNotUsed(t), unsigned char *vtkNotUsed(texture), int vtkNotUsed(size)[2], int vtkNotUsed(reverseFlag)) [inline, virtual]
  • RenderSavedTexture() [protected]
  • RenderWindow [protected]
  • RGBAArray [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • SaveTextures [protected]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetMaximumNumberOfPlanes(int) [virtual]
  • SetMaximumStorageSize(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetTextureSize(int, int) [virtual]
  • SetTargetTextureSize(int[2])
  • Shade [protected]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TargetTextureSize [protected]
  • Texture [protected]
  • TextureMTime [protected]
  • TextureSize [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMesaVolumeTextureMapper2D() [protected]
  • vtkMesaVolumeTextureMapper2D(const vtkMesaVolumeTextureMapper2D &) (defined in vtkMesaVolumeTextureMapper2D) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkMesaVolumeTextureMapper2D, vtkVolumeTextureMapper2D)
  • vtkVolumeMapper() [protected]
  • vtkVolumeTextureMapper() [protected]
  • vtkVolumeTextureMapper2D() [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMesaVolumeTextureMapper2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeTextureMapper() [protected]
  • ~vtkVolumeTextureMapper2D() [protected]
Generated on Mon Mar 25 01:25:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMILVideoSource Member List

This is the complete list of members for vtkMILVideoSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdvanceFrameBuffer(int n) [protected, virtual]
  • AllocateMILBuffer() [protected, virtual]
  • AllocateMILDigitizer() [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AutoAdvance [protected]
  • AutoAdvanceOff() [virtual]
  • AutoAdvanceOn() [virtual]
  • BreakOnError() [static]
  • BrightnessLevel [protected]
  • ClipRegion [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ContrastLevel [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • FastForward() [virtual]
  • FatalMILError [protected]
  • FlipFrames [protected]
  • ForceGrab
  • FrameBuffer [protected]
  • FrameBufferBitsPerPixel [protected]
  • FrameBufferExtent [protected]
  • FrameBufferIndex [protected]
  • FrameBufferMutex [protected]
  • FrameBufferRowAlignment [protected]
  • FrameBufferSize [protected]
  • FrameBufferTimeStamps [protected]
  • FrameCount [protected]
  • FrameCounter
  • FrameIndex [protected]
  • FrameMaxSize [protected]
  • FrameOutputExtent [protected]
  • FrameRate [protected]
  • FrameSize [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdvance() [virtual]
  • GetBrightnessLevel() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipRegion() [virtual]
  • GetClipRegion(int &, int &, int &, int &, int &, int &) [virtual]
  • GetClipRegion(int[6]) [virtual]
  • GetCommand(unsigned long tag)
  • GetContrastLevel() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFrameBufferSize() [virtual]
  • GetFrameCount() [virtual]
  • GetFrameIndex() [virtual]
  • GetFrameRate() [virtual]
  • GetFrameSize() [virtual]
  • GetFrameSize(int &, int &, int &) [virtual]
  • GetFrameSize(int[3]) [virtual]
  • GetFrameTimeStamp(int frame) [virtual]
  • GetFrameTimeStamp() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHueLevel() [virtual]
  • GetInitialized() [inline, virtual]
  • GetInputs() [inline]
  • GetMILAppID() [virtual]
  • GetMILBufID() [virtual]
  • GetMILDigID() [virtual]
  • GetMILDigitizerDCF() [virtual]
  • GetMILDigitizerNumber() [virtual]
  • GetMILErrorMessages() [virtual]
  • GetMILSysID() [virtual]
  • GetMILSystemNumber() [virtual]
  • GetMILSystemType() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputFrames() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOpacity() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputWholeExtent() [virtual]
  • GetOutputWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetOutputWholeExtent(int[6]) [virtual]
  • GetPlaying() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRecording() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSaturationLevel() [virtual]
  • GetStartTimeStamp() [inline]
  • GetVideoChannel() [virtual]
  • GetVideoFormat() [virtual]
  • GetVideoInput() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Grab() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HueLevel [protected]
  • InformationTime [protected]
  • Initialize() [virtual]
  • Initialized [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalGrab() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastNumberOfScalarComponents [protected]
  • LastOutputExtent [protected]
  • LegacyHack
  • MILAppID [protected]
  • MILAppInternallyAllocated [protected]
  • MILBufID [protected]
  • MILDigID [protected]
  • MILDigitizerDCF [protected]
  • MILDigitizerNumber [protected]
  • MILErrorMessages [protected]
  • MILErrorMessagesOff() [virtual]
  • MILErrorMessagesOn() [virtual]
  • MILInterpreterDLL [protected]
  • MILInterpreterForSystem(int system) [protected, virtual]
  • MILSysID [protected]
  • MILSysInternallyAllocated [protected]
  • MILSystemNumber [protected]
  • MILSystemType [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputFrames [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OldHookFunction
  • OldUserDataPtr
  • Opacity [protected]
  • operator=(const vtkMILVideoSource &) (defined in vtkMILVideoSource) [private]
  • OutputFormat [protected]
  • OutputNeedsInitialization [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Play() [virtual]
  • PlayerThreader [protected]
  • PlayerThreadId [protected]
  • Playing [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Record() [virtual]
  • Recording [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • ReleaseSystemResources() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Rewind() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaturationLevel [protected]
  • Seek(int n) [virtual]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdvance(int) [virtual]
  • SetBrightnessLevel(float brightness) [virtual]
  • SetClipRegion(int r[6]) [inline, virtual]
  • SetClipRegion(int x0, int x1, int y0, int y1, int z0, int z1) [virtual]
  • SetContrastLevel(float contrast) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFrameBufferSize(int FrameBufferSize) [virtual]
  • SetFrameCount(int) [virtual]
  • SetFrameRate(float rate) [virtual]
  • SetFrameSize(int x, int y, int z) [virtual]
  • vtkVideoSource::SetFrameSize(int dim[3]) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHueLevel(float hue) [virtual]
  • SetMILAppID(long) [virtual]
  • SetMILDigitizerDCF(const char *) [virtual]
  • SetMILDigitizerNumber(int) [virtual]
  • SetMILErrorMessages(int yesno) [virtual]
  • SetMILSysID(long) [virtual]
  • SetMILSystemNumber(int) [virtual]
  • SetMILSystemType(int) [virtual]
  • SetMILSystemTypeToCorona() [inline]
  • SetMILSystemTypeToGenesis() [inline]
  • SetMILSystemTypeToMeteor() [inline]
  • SetMILSystemTypeToMeteorII() [inline]
  • SetMILSystemTypeToMeteorIIDig() [inline]
  • SetMILSystemTypeToPulsar() [inline]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputFrames(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOpacity(float) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int format) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetOutputWholeExtent(int, int, int, int, int, int) [virtual]
  • SetOutputWholeExtent(int[6]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSaturationLevel(float saturation) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartTimeStamp(double t) [inline]
  • SetVideoChannel(int channel) [virtual]
  • SetVideoFormat(int format) [virtual]
  • SetVideoFormatToCCIR() [inline]
  • SetVideoFormatToNonStandard() [inline]
  • SetVideoFormatToNTSC() [inline]
  • SetVideoFormatToPAL() [inline]
  • SetVideoFormatToRS170() [inline]
  • SetVideoFormatToSECAM() [inline]
  • SetVideoInput(int input) [virtual]
  • SetVideoInputToComposite() [inline]
  • SetVideoInputToDigital() [inline]
  • SetVideoInputToMono() [inline]
  • SetVideoInputToRGB() [inline]
  • SetVideoInputToYC() [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StartTimeStamp [protected]
  • Stop() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnpackRasterLine(char *outPtr, char *rowPtr, int start, int count) [protected, virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateFrameBuffer() [protected, virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VideoChannel [protected]
  • VideoFormat [protected]
  • VideoInput [protected]
  • VideoInputForColor [protected]
  • vtkImageSource() [protected]
  • vtkMILVideoSource() [protected]
  • vtkMILVideoSource(const vtkMILVideoSource &) (defined in vtkMILVideoSource) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkMILVideoSource, vtkVideoSource)
  • vtkVideoSource() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkMILVideoSource() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVideoSource() [protected]
Generated on Mon Mar 25 01:25:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMPICommunicator Member List

This is the complete list of members for vtkMPICommunicator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CheckForMPIError(int err) (defined in vtkMPICommunicator) [private, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyFrom(vtkMPICommunicator *source) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAndSetMarshalString(char *str, int strLength) [protected]
  • Duplicate(vtkMPICommunicator *source) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetWorldCommunicator() [static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Group [protected]
  • Handle [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(vtkMPICommunicator *mpiComm, vtkMPIGroup *group)
  • InitializeCopy(vtkMPICommunicator *source) [protected]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeepHandle [protected]
  • KeepHandleOff() [protected, virtual]
  • KeepHandleOn() [protected, virtual]
  • MarshalDataLength [protected]
  • MarshalString [protected]
  • MarshalStringLength [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoBlockReceive(int *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockReceive(unsigned long *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockReceive(char *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockReceive(float *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockSend(int *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockSend(unsigned long *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockSend(char *data, int length, int remoteProcessId, int tag, Request &req)
  • NoBlockSend(float *data, int length, int remoteProcessId, int tag, Request &req)
  • operator=(const vtkMPICommunicator &) (defined in vtkMPICommunicator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadDataArray(vtkDataArray *object) [protected]
  • ReadDataSet(vtkDataSet *object) [protected]
  • ReadImageData(vtkImageData *object) [protected]
  • ReadObject(vtkDataObject *object) [protected]
  • Receive(int *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(char *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(float *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(double *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(vtkDataObject *data, int remoteProcessId, int tag) [inline, virtual]
  • Receive(vtkDataArray *data, int remoteProcessId, int tag) [inline, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(char *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(float *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(double *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(vtkDataObject *data, int remoteProcessId, int tag) [inline, virtual]
  • Send(vtkDataArray *data, int remoteProcessId, int tag) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetGroup(vtkMPIGroup *) [protected, virtual]
  • SetKeepHandle(int) [protected, virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCommunicator() [protected]
  • vtkMPICommunicator() [protected]
  • vtkMPICommunicator(const vtkMPICommunicator &) (defined in vtkMPICommunicator) [private]
  • vtkMPIController class [friend]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMPICommunicator, vtkObject)
  • WorldCommunicator [protected, static]
  • WriteDataArray(vtkDataArray *object) [protected]
  • WriteDataSet(vtkDataSet *object) [protected]
  • WriteImageData(vtkImageData *object) [protected]
  • WriteObject(vtkDataObject *object) [protected]
  • ~vtkCommunicator() [protected]
  • ~vtkMPICommunicator() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMPICommunicator::Request Member List

This is the complete list of members for vtkMPICommunicator::Request, including all inherited members.
  • Cancel()
  • Req
  • Test()
  • Wait()
Generated on Mon Mar 25 01:25:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMPIController Member List

This is the complete list of members for vtkMPIController, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRMI(vtkRMIFunctionType, void *localArg, int tag)
  • ANY_SOURCE enum value
  • Barrier() [virtual]
  • BREAK_RMI_TAG enum value
  • BreakFlag [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Communicator [protected]
  • Consts enum name
  • CreateOutputWindow() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ErrorString(int err) [static]
  • Finalize() [virtual]
  • ForceDeepCopy [protected]
  • ForceDeepCopyOff() [virtual]
  • ForceDeepCopyOn() [virtual]
  • GetBreakFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCommunicator() [virtual]
  • GetDebug()
  • GetForceDeepCopy() [virtual]
  • GetGlobalController() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocalController() [protected, virtual]
  • GetLocalProcessId() [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfProcesses() [virtual]
  • GetProcessorName() [static]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(int *argc, char ***arcv) [virtual]
  • vtkMultiProcessController::Initialize(int *vtkNotUsed(argc), char ***vtkNotUsed(arcv))=0 [pure virtual]
  • InitializeCommunicator(vtkMPICommunicator *comm) [protected]
  • Initialized [protected, static]
  • InitializeNumberOfProcesses() [protected]
  • InitializeRMICommunicator() [protected]
  • INVALID_SOURCE enum value
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LocalProcessId [protected]
  • MAX_PROCESSES enum value
  • MaximumNumberOfProcesses [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultipleData [protected]
  • MultipleMethod [protected]
  • MultipleMethodExecute() [virtual]
  • New() [static]
  • NoBlockReceive(int *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockReceive(unsigned long *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockReceive(char *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockReceive(float *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockSend(int *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockSend(unsigned long *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockSend(char *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NoBlockSend(float *data, int length, int remoteProcessId, int tag, vtkMPICommunicator::Request &req) [inline]
  • NumberOfProcesses [protected]
  • operator=(const vtkMPIController &) (defined in vtkMPIController) [private]
  • OutputWindow [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessorName [protected, static]
  • ProcessRMI(int remoteProcessId, void *arg, int argLength, int rmiTag) [protected]
  • ProcessRMIs()
  • Receive(int *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(float *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(double *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(vtkDataObject *data, int remoteId, int tag) [inline]
  • Receive(vtkDataArray *data, int remoteId, int tag) [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRMI(vtkRMIFunctionType f, void *arg, int tag) [inline]
  • RMI_ARG_TAG enum value
  • RMI_TAG enum value
  • RMICommunicator [protected]
  • RMIs [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Send(char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(float *data, int length, int remoteProcessId, int tag) [inline]
  • Send(double *data, int length, int remoteProcessId, int tag) [inline]
  • Send(vtkDataObject *data, int remoteId, int tag) [inline]
  • Send(vtkDataArray *data, int remoteId, int tag) [inline]
  • SetBreakFlag(int) [virtual]
  • SetCommunicator(vtkMPICommunicator *comm)
  • SetDebug(unsigned char debugFlag)
  • SetForceDeepCopy(int) [virtual]
  • SetGlobalController(vtkMultiProcessController *controller) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMultipleMethod(int index, vtkProcessFunctionType, void *data)
  • SetNumberOfProcesses(int num) [virtual]
  • SetReferenceCount(int)
  • SetSingleMethod(vtkProcessFunctionType, void *data)
  • SingleData [protected]
  • SingleMethod [protected]
  • SingleMethodExecute() [virtual]
  • SubjectHelper [protected]
  • TriggerBreakRMIs()
  • TriggerRMI(int remoteProcessId, void *arg, int argLength, int tag)
  • TriggerRMI(int remoteProcessId, char *arg, int tag) [inline]
  • TriggerRMI(int remoteProcessId, int tag) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMPIController() [protected]
  • vtkMPIController(const vtkMPIController &) (defined in vtkMPIController) [private]
  • vtkMultiProcessController() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMPIController, vtkMultiProcessController)
  • WorldRMICommunicator [protected, static]
  • ~vtkMPIController() [protected]
  • ~vtkMultiProcessController() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMPIEventLog Member List

This is the complete list of members for vtkMPIEventLog, including all inherited members.
  • Active [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BeginId [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndId [protected]
  • FinalizeLogging(const char *fileName) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeLogging() [static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastEventId [protected, static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMPIEventLog &) (defined in vtkMPIEventLog) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetDescription(const char *name, const char *desc)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • StartLogging()
  • StopLogging()
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMPIEventLog() [protected]
  • vtkMPIEventLog(const vtkMPIEventLog &) (defined in vtkMPIEventLog) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMPIEventLog, vtkObject)
  • ~vtkMPIEventLog() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMPIGroup Member List

This is the complete list of members for vtkMPIGroup, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProcessId(int processId)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyFrom(vtkMPIGroup *group) [protected]
  • CopyProcessIdsFrom(vtkMPIGroup *group)
  • CurrentPosition [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FindProcessId(int processId)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfProcessIds() [inline]
  • GetProcessId(int pos)
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(vtkMPIController *controller)
  • Initialize(int numProcIds) [protected]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaximumNumberOfProcessIds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMPIGroup &) (defined in vtkMPIGroup) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessIds [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProcessId(int processId)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMPICommunicator class [friend]
  • vtkMPIGroup() [protected]
  • vtkMPIGroup(const vtkMPIGroup &) (defined in vtkMPIGroup) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMPIGroup, vtkObject)
  • ~vtkMPIGroup() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMultiProcessController Member List

This is the complete list of members for vtkMultiProcessController, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRMI(vtkRMIFunctionType, void *localArg, int tag)
  • ANY_SOURCE enum value
  • Barrier()=0 [pure virtual]
  • BREAK_RMI_TAG enum value
  • BreakFlag [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Communicator [protected]
  • Consts enum name
  • CreateOutputWindow()=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Finalize()=0 [pure virtual]
  • ForceDeepCopy [protected]
  • ForceDeepCopyOff() [virtual]
  • ForceDeepCopyOn() [virtual]
  • GetBreakFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCommunicator() [virtual]
  • GetDebug()
  • GetForceDeepCopy() [virtual]
  • GetGlobalController() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocalController() [protected, virtual]
  • GetLocalProcessId() [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfProcesses() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(int *vtkNotUsed(argc), char ***vtkNotUsed(arcv))=0 [pure virtual]
  • INVALID_SOURCE enum value
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LocalProcessId [protected]
  • MAX_PROCESSES enum value
  • MaximumNumberOfProcesses [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultipleData [protected]
  • MultipleMethod [protected]
  • MultipleMethodExecute()=0 [pure virtual]
  • New() [static]
  • NumberOfProcesses [protected]
  • operator=(const vtkMultiProcessController &) (defined in vtkMultiProcessController) [private]
  • OutputWindow [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessRMI(int remoteProcessId, void *arg, int argLength, int rmiTag) [protected]
  • ProcessRMIs()
  • Receive(int *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(float *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(double *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(vtkDataObject *data, int remoteId, int tag) [inline]
  • Receive(vtkDataArray *data, int remoteId, int tag) [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRMI(vtkRMIFunctionType f, void *arg, int tag) [inline]
  • RMI_ARG_TAG enum value
  • RMI_TAG enum value
  • RMICommunicator [protected]
  • RMIs [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Send(char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(float *data, int length, int remoteProcessId, int tag) [inline]
  • Send(double *data, int length, int remoteProcessId, int tag) [inline]
  • Send(vtkDataObject *data, int remoteId, int tag) [inline]
  • Send(vtkDataArray *data, int remoteId, int tag) [inline]
  • SetBreakFlag(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetForceDeepCopy(int) [virtual]
  • SetGlobalController(vtkMultiProcessController *controller) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMultipleMethod(int index, vtkProcessFunctionType, void *data)
  • SetNumberOfProcesses(int num) [virtual]
  • SetReferenceCount(int)
  • SetSingleMethod(vtkProcessFunctionType, void *data)
  • SingleData [protected]
  • SingleMethod [protected]
  • SingleMethodExecute()=0 [pure virtual]
  • SubjectHelper [protected]
  • TriggerBreakRMIs()
  • TriggerRMI(int remoteProcessId, void *arg, int argLength, int tag)
  • TriggerRMI(int remoteProcessId, char *arg, int tag) [inline]
  • TriggerRMI(int remoteProcessId, int tag) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMultiProcessController() [protected]
  • vtkMultiProcessController(const vtkMultiProcessController &) (defined in vtkMultiProcessController) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMultiProcessController, vtkObject)
  • ~vtkMultiProcessController() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMultiProcessLog Member List

This is the complete list of members for vtkMultiProcessLog, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DumpLog(char *filename) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetTimerLog() [static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMultiProcessLog &) (defined in vtkMultiProcessLog) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetTimerLog(vtkThreadSafeLog *log) [static]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMultiProcessLog() [inline, protected]
  • vtkMultiProcessLog(const vtkMultiProcessLog &) (defined in vtkMultiProcessLog) [private]
  • vtkObject() [protected]
  • ~vtkMultiProcessLog() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMultiThreader Member List

This is the complete list of members for vtkMultiThreader, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalDefaultNumberOfThreads() [static]
  • GetGlobalMaximumNumberOfThreads() [static]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • MultipleData [protected]
  • MultipleMethod [protected]
  • MultipleMethodExecute()
  • New() [static]
  • NumberOfThreads [protected]
  • operator=(const vtkMultiThreader &) (defined in vtkMultiThreader) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalDefaultNumberOfThreads(int val) [static]
  • SetGlobalMaximumNumberOfThreads(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMultipleMethod(int index, vtkThreadFunctionType, void *data)
  • SetNumberOfThreads(int) [virtual]
  • SetReferenceCount(int)
  • SetSingleMethod(vtkThreadFunctionType, void *data)
  • SingleData [protected]
  • SingleMethod [protected]
  • SingleMethodExecute()
  • SpawnedThreadActiveFlag [protected]
  • SpawnedThreadActiveFlagLock [protected]
  • SpawnedThreadInfoArray [protected]
  • SpawnedThreadProcessID [protected]
  • SpawnThread(vtkThreadFunctionType, void *data)
  • SubjectHelper [protected]
  • TerminateThread(int thread_id)
  • ThreadInfoArray [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMultiThreader() [protected]
  • vtkMultiThreader(const vtkMultiThreader &) (defined in vtkMultiThreader) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMultiThreader, vtkObject)
  • ~vtkMultiThreader() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMutexLock Member List

This is the complete list of members for vtkMutexLock, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Lock(void) [inline]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkMutexLock &) (defined in vtkMutexLock) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SimpleMutexLock [protected]
  • SubjectHelper [protected]
  • Unlock(void) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMutexLock() [inline, protected]
  • vtkMutexLock(const vtkMutexLock &) (defined in vtkMutexLock) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkMutexLock, vtkObject)
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkNonLinearCell Member List

This is the complete list of members for vtkNonLinearCell, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts)=0 [pure virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut)=0 [pure virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd)=0 [pure virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs)=0 [pure virtual]
  • Error [protected]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights)=0 [pure virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights)=0 [pure virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension()=0 [pure virtual]
  • GetCellType()=0 [pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId)=0 [pure virtual]
  • GetError() [virtual]
  • GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges()=0 [pure virtual]
  • GetNumberOfFaces()=0 [pure virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InsertPoint(vtkPointLocator *locator, vtkPoints *pts, float *x) [inline, protected]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId)=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkNonLinearCell &) (defined in vtkNonLinearCell) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetError(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Tesselate(vtkIdType cellId, vtkDataSet *input, vtkPolyData *output, vtkPointLocator *locator=NULL) [virtual]
  • Tesselate(vtkIdType cellId, vtkDataSet *input, vtkUnstructuredGrid *output, vtkPointLocator *locator=NULL) [virtual]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts)=0 [pure virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkNonLinearCell() [protected]
  • vtkNonLinearCell(const vtkNonLinearCell &) (defined in vtkNonLinearCell) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkNonLinearCell, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkNonLinearCell() [inline, protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOBBDicer Member List

This is the complete list of members for vtkOBBDicer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • BuildTree(vtkIdList *ptIds, vtkOBBNode *OBBptr) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteTree(vtkOBBNode *OBBptr) [protected]
  • DiceMode [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldData [protected]
  • FieldDataOff() [virtual]
  • FieldDataOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiceMode() [virtual]
  • GetErrorCode() [virtual]
  • GetFieldData() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMemoryLimit() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfActualPieces() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfPointsPerPiece() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MarkPoints(vtkOBBNode *OBBptr, vtkShortArray *groupIds) [protected]
  • MemoryLimit [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfActualPieces [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPieces [protected]
  • NumberOfPointsPerPiece [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOBBDicer &) (defined in vtkOBBDicer) [private]
  • Outputs [protected]
  • PointsList [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDiceMode(int) [virtual]
  • SetDiceModeToMemoryLimitPerPiece() [inline]
  • SetDiceModeToNumberOfPointsPerPiece() [inline]
  • SetDiceModeToSpecifiedNumberOfPieces() [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldData(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetMemoryLimit(unsigned long) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfPieces(int) [virtual]
  • SetNumberOfPointsPerPiece(int) [virtual]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdatePieceMeasures() [protected, virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkDicer() [protected]
  • vtkOBBDicer() [inline, protected]
  • vtkOBBDicer(const vtkOBBDicer &) (defined in vtkOBBDicer) [private]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOBBDicer, vtkDicer)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkDicer() [inline, protected]
  • ~vtkOBBDicer() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:25:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOBBNode Member List

This is the complete list of members for vtkOBBNode, including all inherited members.
  • Axes
  • Cells
  • Corner
  • DebugPrintTree(int level, double *leaf_vol, int *minCells, int *maxCells)
  • Kids
  • Parent
  • vtkOBBNode()
  • ~vtkOBBNode()
Generated on Mon Mar 25 01:25:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOBBTree Member List

This is the complete list of members for vtkOBBTree, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • Buckets [protected]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • BuildTree(vtkIdList *cells, vtkOBBNode *parent, int level) [protected]
  • CacheCellBounds [protected]
  • CacheCellBoundsOff() [virtual]
  • CacheCellBoundsOn() [virtual]
  • CellBounds [protected]
  • CellHasBeenVisited [protected]
  • ClearCellHasBeenVisited() [protected]
  • ClearCellHasBeenVisited(int id) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeOBB(vtkPoints *pts, float corner[3], float max[3], float mid[3], float min[3], float size[3])
  • ComputeOBB(vtkDataSet *input, float corner[3], float max[3], float mid[3], float min[3], float size[3])
  • ComputeOBB(vtkIdList *cells, float corner[3], float max[3], float mid[3], float min[3], float size[3]) [protected]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepestLevel [protected]
  • Delete() [virtual]
  • DeleteTree(vtkOBBNode *OBBptr) [protected]
  • DisjointOBBNodes(vtkOBBNode *nodeA, vtkOBBNode *nodeB, vtkMatrix4x4 *XformBtoA)
  • Distance2ToBounds(float x[3], float bounds[6]) [protected]
  • Distance2ToBucket(float x[3], int nei[3]) [protected]
  • FindClosestPoint(float x[3], float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPoint(float x[3], float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2)
  • FindClosestPointWithinRadius(float x[3], float radius, float closestPoint[3], vtkGenericCell *cell, vtkIdType &cellId, int &subId, float &dist2, int &inside)
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int numDivs, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateIndex(int offset, int numDivs, int i, int j, int k, vtkIdType &idx) [protected]
  • GeneratePolygons(vtkOBBNode *OBBptr, int level, int repLevel, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(int ijk[3], int ndivs, int level) [protected]
  • GetBuildTime() [virtual]
  • GetCacheCellBounds() [virtual]
  • GetCells(int bucket) [virtual]
  • GetChildren(int idx, int level, int children[8]) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfBuckets(void) [virtual]
  • GetNumberOfCellsPerBucket() [virtual]
  • GetOverlappingBuckets(float x[3], int ijk[3], float dist, int prevMinLevel[3], int prevMaxLevel[3]) [protected]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertedPoints [protected]
  • InsideOrOutside(const float point[3])
  • IntersectWithLine(const float a0[3], const float a1[3], vtkPoints *points, vtkIdList *cellIds)
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId) [virtual]
  • IntersectWithLine(float a0[3], float a1[3], float tol, float &t, float x[3], float pcoords[3], int &subId, vtkIdType &cellId, vtkGenericCell *cell) [virtual]
  • IntersectWithOBBTree(vtkOBBTree *OBBTreeB, vtkMatrix4x4 *XformBtoA, int(*function)(vtkOBBNode *nodeA, vtkOBBNode *nodeB, vtkMatrix4x4 *Xform, void *arg), void *data_arg)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • LineIntersectsNode(vtkOBBNode *pA, float B0[3], float B1[3])
  • MarkParents(void *, int, int, int, int, int) [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfCellsPerBucket [protected]
  • NumberOfDivisions [protected]
  • NumberOfOctants [protected]
  • NumberOfParents [protected]
  • OBBCount [protected]
  • operator=(const vtkOBBTree &) (defined in vtkOBBTree) [private]
  • PointsList [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • QueryNumber [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetCacheCellBounds(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfCellsPerBucket(int) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Tree [protected]
  • TriangleIntersectsNode(vtkOBBNode *pA, float p0[3], float p1[3], float p2[3], vtkMatrix4x4 *XformBtoA)
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkCellLocator() [protected]
  • vtkLocator() [protected]
  • vtkOBBTree() [protected]
  • vtkOBBTree(const vtkOBBTree &) (defined in vtkOBBTree) [private]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkOBBTree, vtkCellLocator)
  • ~vtkCellLocator() [protected]
  • ~vtkLocator() [protected]
  • ~vtkOBBTree() [protected]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkObject Member List

This is the complete list of members for vtkObject, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator<<(ostream &os, vtkObject &o) [friend]
  • operator=(const vtkObject &) (defined in vtkObject) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkObject(const vtkObject &) (defined in vtkObject) [private]
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:25:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkObjectFactory Member List

This is the complete list of members for vtkObjectFactory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateAllInstance(const char *vtkclassname, vtkCollection *retList) [static]
  • CreateFunction typedef
  • CreateInstance(const char *vtkclassname) [static]
  • CreateObject(const char *vtkclassname) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Disable(const char *className) [virtual]
  • GetClassName() [inline, virtual]
  • GetClassOverrideName(int index) [virtual]
  • GetClassOverrideWithName(int index) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDescription()=0 [pure virtual]
  • GetEnableFlag(int index) [virtual]
  • GetEnableFlag(const char *className, const char *subclassName) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLibraryPath() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfOverrides() [virtual]
  • GetOverrideDescription(int index) [virtual]
  • GetOverrideInformation(const char *name, vtkOverrideInformationCollection *) [static]
  • GetReferenceCount() [inline]
  • GetRegisteredFactories() [static]
  • GetVTKSourceVersion()=0 [pure virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrowOverrideArray() (defined in vtkObjectFactory) [private]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HasOverride(const char *className) [virtual]
  • HasOverride(const char *className, const char *subclassName) [virtual]
  • HasOverrideAny(const char *className) [static]
  • Init() (defined in vtkObjectFactory) [private, static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LibraryCompilerUsed (defined in vtkObjectFactory) [private]
  • LibraryHandle (defined in vtkObjectFactory) [private]
  • LibraryPath (defined in vtkObjectFactory) [private]
  • LibraryVTKVersion (defined in vtkObjectFactory) [private]
  • LoadDynamicFactories() (defined in vtkObjectFactory) [private, static]
  • LoadLibrariesInPath(const char *) (defined in vtkObjectFactory) [private, static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkObjectFactory &) (defined in vtkObjectFactory) [private]
  • OverrideArray [protected]
  • OverrideArrayLength [protected]
  • OverrideClassNames [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterDefaults() (defined in vtkObjectFactory) [private, static]
  • RegisteredFactories (defined in vtkObjectFactory) [private, static]
  • RegisterFactory(vtkObjectFactory *) [static]
  • RegisterOverride(const char *classOverride, const char *overrideClassName, const char *description, int enableFlag, CreateFunction createFunction) [protected]
  • ReHash() [static]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAllEnableFlags(int flag, const char *className) [static]
  • SetAllEnableFlags(int flag, const char *className, const char *subclassName) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEnableFlag(int flag, const char *className, const char *subclassName) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SizeOverrideArray [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllFactories() [static]
  • UnRegisterFactory(vtkObjectFactory *) [static]
  • vtkObject() [protected]
  • vtkObjectFactory() [protected]
  • vtkObjectFactory(const vtkObjectFactory &) (defined in vtkObjectFactory) [private]
  • vtkTypeRevisionMacro(vtkObjectFactory, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkObjectFactory() [protected]
Generated on Mon Mar 25 01:25:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkObjectFactoryCollection Member List

This is the complete list of members for vtkObjectFactoryCollection, including all inherited members.
  • AddItem(vtkObjectFactory *t) [inline]
  • AddItem(vtkObject *o) (defined in vtkObjectFactoryCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkObjectFactoryCollection &) (defined in vtkObjectFactoryCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkObjectFactoryCollection() [inline, protected]
  • vtkObjectFactoryCollection(const vtkObjectFactoryCollection &) (defined in vtkObjectFactoryCollection) [private]
  • vtkTypeRevisionMacro(vtkObjectFactoryCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkObjectFactoryCollection() [inline, protected]
Generated on Mon Mar 25 01:25:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOBJExporter Member List

This is the complete list of members for vtkOBJExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • FilePrefix [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkOBJExporter &) (defined in vtkOBJExporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetFilePrefix(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkObject() [protected]
  • vtkOBJExporter() [protected]
  • vtkOBJExporter(const vtkOBJExporter &) (defined in vtkOBJExporter) [private]
  • vtkTypeRevisionMacro(vtkOBJExporter, vtkExporter)
  • Write() [virtual]
  • WriteAnActor(vtkActor *anActor, FILE *fpObj, FILE *fpMat, int &id) [protected]
  • WriteData() [protected, virtual]
  • ~vtkExporter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOBJExporter() [protected]
Generated on Mon Mar 25 01:25:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOBJReader Member List

This is the complete list of members for vtkOBJReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOBJReader &) (defined in vtkOBJReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkOBJReader() [protected]
  • vtkOBJReader(const vtkOBJReader &) (defined in vtkOBJReader) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOBJReader, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkOBJReader() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:25:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOldStyleCallbackCommand Member List

This is the complete list of members for vtkOldStyleCallbackCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • Callback
  • CharEvent enum value
  • ClientData
  • ClientDataDeleteCallback
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *, unsigned long, void *) [virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • New() [inline, static]
  • NextDataEvent enum value
  • NoEvent enum value
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetCallback(void(*f)(void *)) [inline]
  • SetClientData(void *cd) [inline]
  • SetClientDataDeleteCallback(void(*f)(void *)) [inline]
  • SetOutputEvent enum value
  • StartEvent enum value
  • StartPickEvent enum value
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • UserEvent enum value
  • vtkCommand() [inline, protected]
  • vtkOldStyleCallbackCommand() [protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCommand() [inline, protected, virtual]
  • ~vtkOldStyleCallbackCommand() [protected]
Generated on Mon Mar 25 01:25:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOOGLExporter Member List

This is the complete list of members for vtkOOGLExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • FileName [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkOOGLExporter &) (defined in vtkOOGLExporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkObject() [protected]
  • vtkOOGLExporter() [protected]
  • vtkOOGLExporter(const vtkOOGLExporter &) (defined in vtkOOGLExporter) [private]
  • vtkTypeRevisionMacro(vtkOOGLExporter, vtkExporter)
  • Write() [virtual]
  • WriteALight(vtkLight *aLight, FILE *fp) [protected]
  • WriteAnActor(vtkActor *anActor, FILE *fp, int count) [protected]
  • WriteData() [protected, virtual]
  • ~vtkExporter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOOGLExporter() [protected]
Generated on Mon Mar 25 01:25:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLActor Member List

This is the complete list of members for vtkOpenGLActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ApplyProperties() [inline, virtual]
  • BackfaceProperty [protected]
  • Bounds [protected]
  • BoundsMTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBackfaceProperty()
  • GetBounds(float bounds[6]) [inline]
  • GetBounds() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetIsOpaque() [protected]
  • GetLength()
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPart() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfParts() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetTexture() [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPartTraversal() [virtual]
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • MakeProperty() [virtual]
  • Mapper [protected]
  • MapperBounds [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkOpenGLActor &) (defined in vtkOpenGLActor) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkMapper *mapper) [virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBackfaceProperty(vtkProperty *lut)
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkMapper *) [virtual]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkProperty *lut)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetTexture(vtkTexture *) [virtual]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Texture [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor() [protected]
  • vtkObject() [protected]
  • vtkOpenGLActor() [inline, protected]
  • vtkOpenGLActor(const vtkOpenGLActor &) (defined in vtkOpenGLActor) [private]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLActor, vtkActor)
  • ~vtkActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLActor() [inline, protected]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:25:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLCamera Member List

This is the complete list of members for vtkOpenGLCamera, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplyTransform(vtkTransform *t)
  • Azimuth(double angle)
  • BreakOnError() [static]
  • CameraLightTransform [protected]
  • ClippingRange [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCameraLightTransform() [protected]
  • ComputeCompositePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeDistance() [protected]
  • ComputePerspectiveTransform(double aspect, double nearz, double farz) [protected]
  • ComputeViewPlaneNormal()
  • ComputeViewTransform() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DirectionOfProjection [protected]
  • Distance [protected]
  • Dolly(double distance)
  • Elevation(double angle)
  • EyeAngle [protected]
  • FocalDisk [protected]
  • FocalPoint [protected]
  • GetCameraLightTransformMatrix()
  • GetClassName() [inline, virtual]
  • GetClippingRange() [virtual]
  • GetClippingRange(double &, double &) [virtual]
  • GetClippingRange(double[2]) [virtual]
  • GetClippingRange(float a[2]) [inline]
  • GetCommand(unsigned long tag)
  • GetCompositePerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetCompositePerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetDebug()
  • GetDirectionOfProjection() [virtual]
  • GetDirectionOfProjection(double &, double &, double &) [virtual]
  • GetDirectionOfProjection(double[3]) [virtual]
  • GetDirectionOfProjection(float a[3]) [inline]
  • GetDistance() [virtual]
  • GetEyeAngle() [virtual]
  • GetFocalDisk() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(double &, double &, double &) [virtual]
  • GetFocalPoint(double[3]) [virtual]
  • GetFocalPoint(float a[3]) [inline]
  • GetFrustumPlanes(float aspect, float planes[24])
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetOrientation() [inline]
  • GetOrientationWXYZ() [inline]
  • GetParallelProjection() [virtual]
  • GetParallelScale() [virtual]
  • GetPerspectiveTransform(double aspect, double nearz, double farz) [inline]
  • GetPerspectiveTransformMatrix(double aspect, double nearz, double farz)
  • GetPosition() [virtual]
  • GetPosition(double &, double &, double &) [virtual]
  • GetPosition(double[3]) [virtual]
  • GetPosition(float a[3]) [inline]
  • GetReferenceCount() [inline]
  • GetRoll()
  • GetThickness() [virtual]
  • GetViewAngle() [virtual]
  • GetViewingRaysMTime()
  • GetViewPlaneNormal() [virtual]
  • GetViewPlaneNormal(double &, double &, double &) [virtual]
  • GetViewPlaneNormal(double[3]) [virtual]
  • GetViewPlaneNormal(float a[3]) [inline]
  • GetViewShear() [virtual]
  • GetViewShear(double &, double &, double &) [virtual]
  • GetViewShear(double[3]) [virtual]
  • GetViewTransform() [inline]
  • GetViewTransformMatrix() [inline]
  • GetViewTransformObject() [inline]
  • GetViewUp() [virtual]
  • GetViewUp(double &, double &, double &) [virtual]
  • GetViewUp(double[3]) [virtual]
  • GetViewUp(float a[3]) [inline]
  • GetWindowCenter() [virtual]
  • GetWindowCenter(double &, double &) [virtual]
  • GetWindowCenter(double[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftEye [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • ObliqueAngles [protected]
  • operator=(const vtkOpenGLCamera &) (defined in vtkOpenGLCamera) [private]
  • OrthogonalizeViewUp()
  • ParallelProjection [protected]
  • ParallelProjectionOff() [virtual]
  • ParallelProjectionOn() [virtual]
  • ParallelScale [protected]
  • PerspectiveTransform [protected]
  • Pitch(double angle)
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • Roll(double angle)
  • SafeDownCast(vtkObject *o) [static]
  • SetClippingRange(double near, double far)
  • SetClippingRange(const double a[2]) [inline]
  • SetClippingRange(const float a[2]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDistance(double)
  • SetEyeAngle(double) [virtual]
  • SetFocalDisk(double) [virtual]
  • SetFocalPoint(double x, double y, double z)
  • SetFocalPoint(const double a[3]) [inline]
  • SetFocalPoint(const float a[3]) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetObliqueAngles(double alpha, double beta)
  • SetParallelProjection(int flag)
  • SetParallelScale(double scale)
  • SetPosition(double x, double y, double z)
  • SetPosition(const double a[3]) [inline]
  • SetPosition(const float a[3]) [inline]
  • SetReferenceCount(int)
  • SetRoll(double angle)
  • SetThickness(double)
  • SetViewAngle(double angle)
  • SetViewPlaneNormal(double x, double y, double z)
  • SetViewPlaneNormal(const double a[3]) [inline]
  • SetViewPlaneNormal(const float a[3]) [inline]
  • SetViewShear(double dxdz, double dydz, double center)
  • SetViewShear(double d[3])
  • SetViewUp(double vx, double vy, double vz)
  • SetViewUp(const double a[3]) [inline]
  • SetViewUp(const float a[3]) [inline]
  • SetWindowCenter(double x, double y)
  • Stereo [protected]
  • SubjectHelper [protected]
  • Thickness [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateViewport(vtkRenderer *ren)
  • vtkCamera::UpdateViewport(vtkRenderer *vtkNotUsed(ren)) [inline, virtual]
  • ViewAngle [protected]
  • ViewingRaysModified()
  • ViewingRaysMTime [protected]
  • ViewPlaneNormal [protected]
  • ViewShear [protected]
  • ViewTransform [protected]
  • ViewUp [protected]
  • vtkCamera() [protected]
  • vtkObject() [protected]
  • vtkOpenGLCamera() [inline, protected]
  • vtkOpenGLCamera(const vtkOpenGLCamera &) (defined in vtkOpenGLCamera) [private]
  • vtkTypeRevisionMacro(vtkOpenGLCamera, vtkCamera)
  • WindowCenter [protected]
  • Yaw(double angle)
  • Zoom(double factor)
  • ~vtkCamera() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLCamera() [inline, protected]
Generated on Mon Mar 25 01:25:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLImageActor Member List

This is the complete list of members for vtkOpenGLImageActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Coords [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent [protected]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDisplayExtent(int extent[6])
  • GetDisplayExtent() [inline]
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInterpolate() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetSliceNumber()
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Index [protected]
  • InitPathTraversal() [virtual]
  • Input [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *ren) [virtual]
  • LoadTime [protected]
  • MakeDataSuitable(int &xsize, int &ysize, int &release) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkOpenGLImageActor &) (defined in vtkOpenGLImageActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RenderWindow [protected]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayExtent(int extent[6])
  • SetDisplayExtent(int minX, int maxX, int minY, int maxY, int minZ, int maxZ)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *) [virtual]
  • SetInterpolate(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • SetZSlice(int z) [inline]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • TCoords [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkImageActor() [protected]
  • vtkObject() [protected]
  • vtkOpenGLImageActor() [protected]
  • vtkOpenGLImageActor(const vtkOpenGLImageActor &) (defined in vtkOpenGLImageActor) [private]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLImageActor, vtkImageActor)
  • ~vtkImageActor() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLImageActor() [protected]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:25:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLImageMapper Member List

This is the complete list of members for vtkOpenGLImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CustomDisplayExtents [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLImageMapper &) (defined in vtkOpenGLImageMapper) [private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkOpenGLImageMapper() [protected]
  • vtkOpenGLImageMapper(const vtkOpenGLImageMapper &) (defined in vtkOpenGLImageMapper) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLImageMapper, vtkImageMapper)
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLImageMapper() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:25:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLImager Member List

This is the complete list of members for vtkOpenGLImager, including all inherited members.
  • Actors2D [protected]
  • AddActor2D(vtkProp *p) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • Aspect [protected]
  • Background [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender() [protected, virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick() [protected, virtual]
  • EndTag [protected]
  • Erase() [virtual]
  • GetActors2D()
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetImageWindow()
  • GetIsPicking() [virtual]
  • GetMTime() [virtual]
  • GetOrigin()
  • GetPickedId() [protected, virtual]
  • GetPickedZ() [virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetReferenceCount() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVTKWindow() [inline, virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • operator=(const vtkOpenGLImager &) (defined in vtkOpenGLImager) [private]
  • Origin [protected]
  • PickedProp [protected]
  • PickFromProps [protected]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Props [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RenderOpaqueGeometry() [virtual]
  • RenderOverlay() [virtual]
  • RenderTranslucentGeometry() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageWindow(vtkImageWindow *win)
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetVTKWindow(vtkWindow *win)
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize) [protected, virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePickId() [protected, virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &, float &, float &) [inline, virtual]
  • vtkImager() [protected]
  • vtkObject() [protected]
  • vtkOpenGLImager() [inline, protected]
  • vtkOpenGLImager(const vtkOpenGLImager &) (defined in vtkOpenGLImager) [private]
  • vtkTypeRevisionMacro(vtkOpenGLImager, vtkImager)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &, float &, float &) [inline, virtual]
  • ~vtkImager() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLImager() [inline, protected]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:25:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLImageWindow Member List

This is the complete list of members for vtkOpenGLImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateDirectColorMap() [protected]
  • BreakOnError() [static]
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMap [protected]
  • Colors [protected]
  • ContextId
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayId [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Drawable [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [inline, virtual]
  • FileName [protected]
  • Frame() [virtual]
  • Gc [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultVisualInfo(XVisualInfo *info) [protected]
  • GetDesiredColormap() [virtual]
  • GetDesiredDepth() [virtual]
  • GetDesiredVisual() [virtual]
  • GetDesiredVisualInfo()
  • GetDisplayId()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGC()
  • GetGenericContext() [virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetParentId()
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPosition() [virtual]
  • GetPosition(int *x, int *y) [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetShiftsScalesAndMasks(int &rshift, int &gshift, int &bshift, int &rscale, int &gscale, int &bscale, unsigned long &rmask, unsigned long &gmask, unsigned long &bmask) [protected]
  • GetSize() [virtual]
  • GetSize(int *x, int *y) [inline, virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetVisualClass() [virtual]
  • GetVisualDepth() [virtual]
  • GetVisualId() [inline]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeColorMap(Visual *visual) [protected]
  • MakeCurrent() [virtual]
  • MakeDefaultWindow() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • Offset [protected]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkOpenGLImageWindow &) (defined in vtkOpenGLImageWindow) [private]
  • OwnDisplay [protected]
  • ParentId [protected]
  • PixmapHeight [protected]
  • PixmapWidth [protected]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • SetBackgroundColor(float r, float g, float b)
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(Display *)
  • SetDisplayId(void *) [virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(Window)
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *info) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int x, int y) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(Window)
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *info) [virtual]
  • SetWindowName(char *name) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • VisualClass [protected]
  • VisualDepth [protected]
  • VisualId [protected]
  • vtkImageWindow() [protected]
  • vtkObject() [protected]
  • vtkOpenGLImageWindow() [protected]
  • vtkOpenGLImageWindow(const vtkOpenGLImageWindow &) (defined in vtkOpenGLImageWindow) [private]
  • vtkTypeRevisionMacro(vtkOpenGLImageWindow, vtkXImageWindow)
  • vtkWindow() [protected]
  • vtkXImageWindow() [protected]
  • WindowCreated [protected]
  • WindowId [protected]
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLImageWindow() [protected]
  • ~vtkWindow() [protected]
  • ~vtkXImageWindow() [protected]
Generated on Mon Mar 25 01:25:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLLight Member List

This is the complete list of members for vtkOpenGLLight, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AttenuationValues [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ConeAngle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkLight *light)
  • Delete() [virtual]
  • Exponent [protected]
  • FocalPoint [protected]
  • GetAttenuationValues() [virtual]
  • GetAttenuationValues(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetConeAngle() [virtual]
  • GetDebug()
  • GetExponent() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIntensity() [virtual]
  • GetLightType() [virtual]
  • GetMTime() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetPositional() [virtual]
  • GetReferenceCount() [inline]
  • GetSwitch() [virtual]
  • GetTransformedFocalPoint(float &a0, float &a1, float &a2)
  • GetTransformedFocalPoint(float a[3])
  • GetTransformedFocalPoint()
  • GetTransformedPosition(float &a0, float &a1, float &a2)
  • GetTransformedPosition(float a[3])
  • GetTransformedPosition()
  • GetTransformMatrix() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intensity [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LightType [protected]
  • LightTypeIsCameraLight()
  • LightTypeIsHeadlight()
  • LightTypeIsSceneLight()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkOpenGLLight &) (defined in vtkOpenGLLight) [private]
  • Position [protected]
  • Positional [protected]
  • PositionalOff() [virtual]
  • PositionalOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadSelf(istream &is)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, int light_index) [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAttenuationValues(float, float, float) [virtual]
  • SetAttenuationValues(float[3]) [virtual]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetConeAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionAngle(float elevation, float azimuth)
  • SetDirectionAngle(float ang[2]) [inline]
  • SetExponent(float) [virtual]
  • SetFocalPoint(float, float, float) [virtual]
  • SetFocalPoint(float[3]) [virtual]
  • SetFocalPoint(double *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIntensity(float) [virtual]
  • SetLightType(int) [virtual]
  • SetLightTypeToCameraLight()
  • SetLightTypeToHeadlight()
  • SetLightTypeToSceneLight()
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetPosition(double *a) [inline]
  • SetPositional(int) [virtual]
  • SetReferenceCount(int)
  • SetSwitch(int) [virtual]
  • SetTransformMatrix(vtkMatrix4x4 *) [virtual]
  • SubjectHelper [protected]
  • Switch [protected]
  • SwitchOff() [virtual]
  • SwitchOn() [virtual]
  • TransformedFocalPointReturn [protected]
  • TransformedPositionReturn [protected]
  • TransformMatrix [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkLight() [protected]
  • vtkObject() [protected]
  • vtkOpenGLLight() [inline, protected]
  • vtkOpenGLLight(const vtkOpenGLLight &) (defined in vtkOpenGLLight) [private]
  • vtkTypeRevisionMacro(vtkOpenGLLight, vtkLight)
  • WriteSelf(ostream &os)
  • ~vtkLight() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLLight() [inline, protected]
Generated on Mon Mar 25 01:25:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLPolyDataMapper2D Member List

This is the complete list of members for vtkOpenGLPolyDataMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarMode() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetTransformCoordinate() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLPolyDataMapper2D &) (defined in vtkOpenGLPolyDataMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransformCoordinate(vtkCoordinate *) [virtual]
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • TransformCoordinate [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkOpenGLPolyDataMapper2D() [inline, protected]
  • vtkOpenGLPolyDataMapper2D(const vtkOpenGLPolyDataMapper2D &) (defined in vtkOpenGLPolyDataMapper2D) [private]
  • vtkPolyDataMapper2D() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLPolyDataMapper2D, vtkPolyDataMapper2D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLPolyDataMapper2D() [inline, protected]
  • ~vtkPolyDataMapper2D() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:26:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLPolyDataMapper Member List

This is the complete list of members for vtkOpenGLPolyDataMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(const char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Draw(vtkRenderer *ren, vtkActor *a) [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGhostLevel() [virtual]
  • GetGlobalImmediateModeRendering() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImmediateModeRendering() [virtual]
  • GetInput()
  • GetInputAsDataSet() [inline]
  • GetInputs() [inline]
  • GetLength()
  • GetLmcolorMode(vtkProperty *prop)
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfSubPieces() [virtual]
  • GetPiece() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTime() [virtual]
  • GetResolveCoincidentTopology() [static]
  • GetResolveCoincidentTopologyPolygonOffsetParameters(float &factor, float &units) [static]
  • GetResolveCoincidentTopologyZShift() [static]
  • GetScalarMode() [virtual]
  • GetScalarModeAsString()
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GhostLevel [protected]
  • GlobalImmediateModeRenderingOff() [inline, static]
  • GlobalImmediateModeRenderingOn() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImmediateModeRendering [protected]
  • ImmediateModeRenderingOff() [virtual]
  • ImmediateModeRenderingOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • ListId [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfPieces [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubPieces [protected]
  • operator=(const vtkOpenGLPolyDataMapper &) (defined in vtkOpenGLPolyDataMapper) [private]
  • Piece [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkActor *act) [virtual]
  • RenderPiece(vtkRenderer *ren, vtkActor *a) [virtual]
  • RenderTime [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGhostLevel(int) [virtual]
  • SetGlobalImmediateModeRendering(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImmediateModeRendering(int) [virtual]
  • SetInput(vtkPolyData *in)
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfPieces(int) [virtual]
  • SetNumberOfSubPieces(int) [virtual]
  • SetPiece(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTime(float time) [inline]
  • SetResolveCoincidentTopology(int val) [static]
  • SetResolveCoincidentTopologyPolygonOffsetParameters(float factor, float units) [static]
  • SetResolveCoincidentTopologyToDefault() [static]
  • SetResolveCoincidentTopologyToOff() [inline, static]
  • SetResolveCoincidentTopologyToPolygonOffset() [inline, static]
  • SetResolveCoincidentTopologyToShiftZBuffer() [inline, static]
  • SetResolveCoincidentTopologyZShift(double val) [static]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMapper() [protected]
  • vtkObject() [protected]
  • vtkOpenGLPolyDataMapper() [protected]
  • vtkOpenGLPolyDataMapper(const vtkOpenGLPolyDataMapper &) (defined in vtkOpenGLPolyDataMapper) [private]
  • vtkPolyDataMapper() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLPolyDataMapper, vtkPolyDataMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLPolyDataMapper() [protected]
  • ~vtkPolyDataMapper() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:25:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLProperty Member List

This is the complete list of members for vtkOpenGLProperty, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Ambient [protected]
  • AmbientColor [protected]
  • BackfaceCulling [protected]
  • BackfaceCullingOff() [virtual]
  • BackfaceCullingOn() [virtual]
  • BackfaceRender(vtkActor *a, vtkRenderer *ren) [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkProperty *p)
  • Delete() [virtual]
  • Diffuse [protected]
  • DiffuseColor [protected]
  • EdgeColor [protected]
  • EdgeVisibility [protected]
  • EdgeVisibilityOff() [virtual]
  • EdgeVisibilityOn() [virtual]
  • FrontfaceCulling [protected]
  • FrontfaceCullingOff() [virtual]
  • FrontfaceCullingOn() [virtual]
  • GetAmbient() [virtual]
  • GetAmbientColor() [virtual]
  • GetAmbientColor(float data[3]) [virtual]
  • GetBackfaceCulling() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor()
  • GetColor(float rgb[3])
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiffuse() [virtual]
  • GetDiffuseColor() [virtual]
  • GetDiffuseColor(float data[3]) [virtual]
  • GetEdgeColor() [virtual]
  • GetEdgeColor(float data[3]) [virtual]
  • GetEdgeVisibility() [virtual]
  • GetFrontfaceCulling() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInterpolation() [virtual]
  • GetInterpolationAsString() [inline]
  • GetLineStipplePattern() [virtual]
  • GetLineStippleRepeatFactor() [virtual]
  • GetLineWidth() [virtual]
  • GetMTime() [virtual]
  • GetOpacity() [virtual]
  • GetPointSize() [virtual]
  • GetReferenceCount() [inline]
  • GetRepresentation() [virtual]
  • GetRepresentationAsString() [inline]
  • GetSpecular() [virtual]
  • GetSpecularColor() [virtual]
  • GetSpecularColor(float data[3]) [virtual]
  • GetSpecularPower() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interpolation [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineStipplePattern [protected]
  • LineStippleRepeatFactor [protected]
  • LineWidth [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Opacity [protected]
  • operator=(const vtkOpenGLProperty &) (defined in vtkOpenGLProperty) [private]
  • PointSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkActor *a, vtkRenderer *ren) [virtual]
  • Representation [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAmbient(float) [virtual]
  • SetAmbientColor(float, float, float) [virtual]
  • SetAmbientColor(float[3]) [virtual]
  • SetBackfaceCulling(int) [virtual]
  • SetColor(float r, float g, float b)
  • SetColor(float a[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDiffuse(float) [virtual]
  • SetDiffuseColor(float, float, float) [virtual]
  • SetDiffuseColor(float[3]) [virtual]
  • SetEdgeColor(float, float, float) [virtual]
  • SetEdgeColor(float[3]) [virtual]
  • SetEdgeVisibility(int) [virtual]
  • SetFrontfaceCulling(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInterpolation(int) [virtual]
  • SetInterpolationToFlat() [inline]
  • SetInterpolationToGouraud() [inline]
  • SetInterpolationToPhong() [inline]
  • SetLineStipplePattern(int) [virtual]
  • SetLineStippleRepeatFactor(int) [virtual]
  • SetLineWidth(float) [virtual]
  • SetOpacity(float) [virtual]
  • SetPointSize(float) [virtual]
  • SetReferenceCount(int)
  • SetRepresentation(int) [virtual]
  • SetRepresentationToPoints() [inline]
  • SetRepresentationToSurface() [inline]
  • SetRepresentationToWireframe() [inline]
  • SetSpecular(float) [virtual]
  • SetSpecularColor(float, float, float) [virtual]
  • SetSpecularColor(float[3]) [virtual]
  • SetSpecularPower(float) [virtual]
  • Specular [protected]
  • SpecularColor [protected]
  • SpecularPower [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOpenGLProperty() [inline, protected]
  • vtkOpenGLProperty(const vtkOpenGLProperty &) (defined in vtkOpenGLProperty) [private]
  • vtkProperty() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLProperty, vtkProperty)
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLProperty() [inline, protected]
  • ~vtkProperty() [inline, protected]
Generated on Mon Mar 25 01:26:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLRenderer Member List

This is the complete list of members for vtkOpenGLRenderer, including all inherited members.
  • ActiveCamera [protected]
  • Actors [protected]
  • Actors2D [protected]
  • AddActor(vtkProp *p) [inline]
  • AddActor2D(vtkProp *p) [inline]
  • AddCuller(vtkCuller *)
  • AddLight(vtkLight *)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • AddVolume(vtkProp *p) [inline]
  • AllocatedRenderTime [protected]
  • AllocateTime() [protected]
  • Ambient [protected]
  • Aspect [protected]
  • Background [protected]
  • BackingImage [protected]
  • BackingStore [protected]
  • BackingStoreOff() [virtual]
  • BackingStoreOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • Clear(void) [virtual]
  • ClearLights(void)
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • ComputeVisiblePropBounds(float bounds[6])
  • CreatedLight [protected]
  • CreateLight(void)
  • Cullers [protected]
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender() [protected, virtual]
  • DeviceRender(void) [virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick() [protected, virtual]
  • EndTag [protected]
  • GetActiveCamera()
  • GetActors()
  • GetActors2D()
  • GetAllocatedRenderTime() [virtual]
  • GetAmbient() [virtual]
  • GetAmbient(float data[3]) [virtual]
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetBackingStore() [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCullers() [inline]
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInteractive() [virtual]
  • GetIsPicking() [virtual]
  • GetLastRenderTimeInSeconds() [virtual]
  • GetLayer() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetLights() [inline]
  • GetMTime() [virtual]
  • GetNumberOfPropsRenderedAsGeometry() [virtual]
  • GetOrigin()
  • GetPickedId() [protected, virtual]
  • GetPickedZ() [protected, virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetRayCaster() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetTimeFactor() [virtual]
  • GetTwoSidedLighting() [virtual]
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVolumes()
  • GetVTKWindow() [virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GetZ(int x, int y)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interactive [protected]
  • InteractiveOff() [virtual]
  • InteractiveOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LastRenderTimeInSeconds [protected]
  • Layer [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Lights [protected]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • MakeCamera() [virtual]
  • MakeLight() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • NumberOfLightsBound [protected]
  • NumberOfPropsRenderedAsGeometry [protected]
  • NumberOfPropsToRayCast [protected]
  • NumberOfPropsToRenderIntoImage [protected]
  • operator=(const vtkOpenGLRenderer &) (defined in vtkOpenGLRenderer) [private]
  • Origin [protected]
  • PathArray [protected]
  • PathArrayCount [protected]
  • PickedProp [protected]
  • PickedZ [protected]
  • PickFromProps [protected]
  • PickGeometry() [protected, virtual]
  • PickInfo [protected]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickRender(vtkPropCollection *props) [protected, virtual]
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropArray [protected]
  • PropArrayCount [protected]
  • Props [protected]
  • RayCaster [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor(vtkProp *p) [inline]
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveCuller(vtkCuller *)
  • RemoveLight(vtkLight *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RemoveVolume(vtkProp *p) [inline]
  • Render() [virtual]
  • RenderOverlay()
  • RenderTime [protected]
  • RenderWindow [protected]
  • ResetCamera()
  • ResetCamera(float bounds[6])
  • ResetCamera(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • ResetCameraClippingRange()
  • ResetCameraClippingRange(float bounds[6])
  • ResetCameraClippingRange(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SafeDownCast(vtkObject *o) [static]
  • SetActiveCamera(vtkCamera *)
  • SetAllocatedRenderTime(float) [virtual]
  • SetAmbient(float, float, float) [virtual]
  • SetAmbient(float[3]) [virtual]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetBackingStore(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractive(int) [virtual]
  • SetLayer(int) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetTwoSidedLighting(int) [virtual]
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize) [protected, virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeFactor [protected]
  • Transparent()
  • TwoSidedLighting [protected]
  • TwoSidedLightingOff() [virtual]
  • TwoSidedLightingOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateCamera(void) [protected, virtual]
  • UpdateGeometry(void) [protected, virtual]
  • UpdateLightGeometry(void) [protected, virtual]
  • UpdateLights(void) [virtual]
  • UpdatePickId() [protected, virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &wx, float &wy, float &wz) [virtual]
  • VisibleActorCount()
  • VisibleVolumeCount()
  • Volumes [protected]
  • vtkObject() [protected]
  • vtkOpenGLRenderer() [protected]
  • vtkOpenGLRenderer(const vtkOpenGLRenderer &) (defined in vtkOpenGLRenderer) [private]
  • vtkRenderer() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLRenderer, vtkRenderer)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &wx, float &wy, float &wz) [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLRenderer() [protected]
  • ~vtkRenderer() [protected]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:26:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLRenderWindow Member List

This is the complete list of members for vtkOpenGLRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame() [inline, virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [inline, virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline, virtual]
  • InAbortCheck [protected]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent()=0 [pure virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldMonitorSetting [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkOpenGLRenderWindow &) (defined in vtkOpenGLRenderWindow) [private]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [inline, virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *) [inline, virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *) [inline, virtual]
  • SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [inline, virtual]
  • Size [protected]
  • Start() [inline, virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOpenGLRenderWindow() [protected]
  • vtkOpenGLRenderWindow(const vtkOpenGLRenderWindow &) (defined in vtkOpenGLRenderWindow) [private]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLRenderWindow, vtkRenderWindow)
  • vtkWindow() [protected]
  • WindowName [protected]
  • WindowRemap() [inline, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLRenderWindow() [protected]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:26:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLStateCache Member List

This is the complete list of members for vtkOpenGLStateCache, including all inherited members.
  • AlphaFunc_bucket
  • BlendFunc_bucket
  • ClearColor_buckets
  • ClearDepth_bucket
  • ClipPlane_bucket
  • ColorMaterial_bucket
  • CullFace_bucket
  • CurrentGLCache [static]
  • DepthFunc_bucket
  • DepthMask_bucket
  • DepthRange_FAR_bucket
  • DepthRange_NEAR_bucket
  • DrawBuffer_bucket
  • Enable_buckets
  • Enable_GL_CLIP_PLANE_buckets
  • Enable_GL_LIGHT_buckets
  • glAlphaFunc(GLenum e, GLclampf cf) [inline]
  • glBlendFunc(GLenum e, GLenum e1) [inline]
  • glClear(GLbitfield b) [inline]
  • glClearColor(GLclampf r, GLclampf g, GLclampf b, GLclampf a) [inline]
  • glClearDepth(GLclampd d) [inline]
  • glClipPlane(GLenum e, const GLdouble *eqn) [inline]
  • glColorMaterial(GLenum face, GLenum mode) [inline]
  • glCullFace(GLenum e) [inline]
  • glDepthFunc(GLenum e) [inline]
  • glDepthMask(GLenum e) [inline]
  • glDepthRange(GLclampd nearval, GLclampd farval) [inline]
  • glDisable(GLenum e) [inline]
  • glDrawBuffer(GLenum e) [inline]
  • glEnable(GLenum e) [inline]
  • glLightf(GLenum light, GLenum pname, GLfloat f) [inline]
  • glLightfv(GLenum light, GLenum pname, const GLfloat *params) [inline]
  • glLighti(GLenum light, GLenum pname, GLint f) [inline]
  • glLightModelfv(GLenum e, GLfloat *fv) [inline]
  • glLightModeli(GLenum e, GLint i) [inline]
  • glLineStipple(GLint factor, GLushort pattern) [inline]
  • glLineWidth(GLfloat f) [inline]
  • glMaterialfv(GLenum face, GLenum pname, const GLfloat *params) [inline]
  • glMatrixMode(GLenum e) [inline]
  • glPointSize(GLfloat f) [inline]
  • glScissor(GLint llx, GLint lly, GLint u, GLint v) [inline]
  • glShadeModel(GLenum e) [inline]
  • glTexEnvf(GLenum e, GLenum e1, GLfloat f) [inline]
  • glViewport(GLint llx, GLint lly, GLint u, GLint v) [inline]
  • Initialize()
  • Lightf_buckets
  • Lightfv_buckets
  • Lighti_SPOT_CUTOFF_buckets
  • LightModelfv_LIGHT_MODEL_AMBIENT_bucket
  • LightModeli_LIGHT_MODEL_TWO_SIDE_bucket
  • LineStipple_FACTOR_bucket
  • LineStipple_PATTERN_bucket
  • LineWidth_bucket
  • Materialfv_buckets
  • MatrixMode_bucket
  • PointSize_bucket
  • Scissor_bucket
  • ShadeModel_bucket
  • TexEnvf_MODE_bucket
  • Viewport_bucket
  • vtkOpenGLStateCache()
  • ~vtkOpenGLStateCache()
Generated on Mon Mar 25 01:26:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLTexture Member List

This is the complete list of members for vtkOpenGLTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInterpolate() [virtual]
  • GetLookupTable() [virtual]
  • GetMapColorScalarsThroughLookupTable() [virtual]
  • GetMappedScalars() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetQuality() [virtual]
  • GetReferenceCount() [inline]
  • GetRepeat() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Index [protected]
  • Inputs [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *ren) [virtual]
  • LoadTime [protected]
  • LookupTable [protected]
  • MapColorScalarsThroughLookupTable [protected]
  • MapColorScalarsThroughLookupTableOff() [virtual]
  • MapColorScalarsThroughLookupTableOn() [virtual]
  • MappedScalars [protected]
  • MapScalarsToColors(vtkDataArray *scalars)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLTexture &) (defined in vtkOpenGLTexture) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • Quality [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • RenderWindow [protected]
  • Repeat [protected]
  • RepeatOff() [virtual]
  • RepeatOn() [virtual]
  • ResampleToPowerOfTwo(int &xsize, int &ysize, unsigned char *dptr, int bpp) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelfAdjustingTableRange [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInterpolate(int) [virtual]
  • SetLookupTable(vtkLookupTable *)
  • SetMapColorScalarsThroughLookupTable(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQuality(int) [virtual]
  • SetQualityTo16Bit() [inline]
  • SetQualityTo32Bit() [inline]
  • SetQualityToDefault() [inline]
  • SetReferenceCount(int)
  • SetRepeat(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkObject() [protected]
  • vtkOpenGLTexture() [protected]
  • vtkOpenGLTexture(const vtkOpenGLTexture &) (defined in vtkOpenGLTexture) [private]
  • vtkProcessObject() [protected]
  • vtkTexture() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLTexture, vtkTexture)
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLTexture() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkTexture() [protected]
Generated on Mon Mar 25 01:26:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLVolumeProVG500Mapper Member List

This is the complete list of members for vtkOpenGLVolumeProVG500Mapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BlendMode [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • Context [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • CorrectBasePlaneSize(VLIPixel *inBase, int inSize[2], VLIPixel **outBase, int outSize[2], VLIVector2D textureCoords[6]) [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Cursor [protected]
  • CursorOff() [virtual]
  • CursorOn() [virtual]
  • CursorPosition [protected]
  • CursorType [protected]
  • CursorXAxisColor [protected]
  • CursorYAxisColor [protected]
  • CursorZAxisColor [protected]
  • Cut [protected]
  • CutPlane [protected]
  • CutPlaneEquation [protected]
  • CutPlaneFallOffDistance [protected]
  • CutPlaneOff() [virtual]
  • CutPlaneOn() [virtual]
  • CutPlaneThickness [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayedMessage [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAvailableBoardMemory() [virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetCursor() [virtual]
  • GetCursorPosition() [virtual]
  • GetCursorPosition(double data[3]) [virtual]
  • GetCursorType() [virtual]
  • GetCursorTypeAsString(void) [inline]
  • GetCursorXAxisColor() [virtual]
  • GetCursorXAxisColor(double data[3]) [virtual]
  • GetCursorYAxisColor() [virtual]
  • GetCursorYAxisColor(double data[3]) [virtual]
  • GetCursorZAxisColor() [virtual]
  • GetCursorZAxisColor(double data[3]) [virtual]
  • GetCutPlane() [virtual]
  • GetCutPlaneEquation() [virtual]
  • GetCutPlaneEquation(double data[4]) [virtual]
  • GetCutPlaneFallOffDistance() [virtual]
  • GetCutPlaneThickness() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientDiffuseModulation() [virtual]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetGradientOpacityModulation() [virtual]
  • GetGradientSpecularModulation() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetLockSizesForBoardMemory(unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize) [virtual]
  • vtkVolumeProMapper::GetLockSizesForBoardMemory(unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize)) [inline, virtual]
  • GetMajorBoardVersion() [virtual]
  • GetMinorBoardVersion() [virtual]
  • GetMTime() [virtual]
  • GetNoHardware() [virtual]
  • GetNumberOfBoards() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetSubVolume() [virtual]
  • GetSubVolume(int data[6]) [virtual]
  • GetSuperSampling() [virtual]
  • GetSuperSamplingFactor() [virtual]
  • GetSuperSamplingFactor(double data[3]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetWrongVLIVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientDiffuseModulation [protected]
  • GradientDiffuseModulationOff() [virtual]
  • GradientDiffuseModulationOn() [virtual]
  • GradientOpacityModulation [protected]
  • GradientOpacityModulationOff() [virtual]
  • GradientOpacityModulationOn() [virtual]
  • GradientSpecularModulation [protected]
  • GradientSpecularModulationOff() [virtual]
  • GradientSpecularModulationOn() [virtual]
  • GradientTableSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Lights [protected]
  • LoadedDataSize [protected]
  • LookupTable [protected]
  • MajorBoardVersion [protected]
  • MinorBoardVersion [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoHardware [protected]
  • NumberOfBoards [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLights [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLVolumeProVG500Mapper &) (defined in vtkOpenGLVolumeProVG500Mapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderHexagon(vtkRenderer *ren, vtkVolume *vol, VLIPixel *basePlane, int size[2], VLIVector3D hexagon[6], VLIVector2D textureCoords[6]) [protected]
  • vtkVolumeProVG500Mapper::RenderHexagon(vtkRenderer *vtkNotUsed(ren), vtkVolume *vtkNotUsed(vol), VLIPixel *vtkNotUsed(basePlane), int size[2], VLIVector3D hexagon[6], VLIVector2D textureCoords[6]) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToComposite() [inline]
  • SetBlendModeToMaximumIntensity() [inline]
  • SetBlendModeToMinimumIntensity() [inline]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetCursor(int) [virtual]
  • SetCursorPosition(double, double, double) [virtual]
  • SetCursorPosition(double[3]) [virtual]
  • SetCursorType(int) [virtual]
  • SetCursorTypeToCrossHair() [inline]
  • SetCursorTypeToPlane() [inline]
  • SetCursorXAxisColor(double, double, double) [virtual]
  • SetCursorXAxisColor(double[3]) [virtual]
  • SetCursorYAxisColor(double, double, double) [virtual]
  • SetCursorYAxisColor(double[3]) [virtual]
  • SetCursorZAxisColor(double, double, double) [virtual]
  • SetCursorZAxisColor(double[3]) [virtual]
  • SetCutPlane(int) [virtual]
  • SetCutPlaneEquation(double, double, double, double) [virtual]
  • SetCutPlaneEquation(double[4]) [virtual]
  • SetCutPlaneFallOffDistance(int) [virtual]
  • SetCutPlaneThickness(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientDiffuseModulation(int) [virtual]
  • SetGradientOpacityModulation(int) [virtual]
  • SetGradientSpecularModulation(int) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubVolume(int, int, int, int, int, int) [virtual]
  • SetSubVolume(int[6]) [virtual]
  • SetSuperSampling(int) [virtual]
  • SetSuperSamplingFactor(double x, double y, double z)
  • SetSuperSamplingFactor(double f[3]) [inline]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StatusOK() [protected]
  • SubjectHelper [protected]
  • SubVolume [protected]
  • SuperSampling [protected]
  • SuperSamplingFactor [protected]
  • SuperSamplingOff() [virtual]
  • SuperSamplingOn() [virtual]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateCamera(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCropping(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCursor(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCutPlane(vtkRenderer *, vtkVolume *) [protected]
  • UpdateLights(vtkRenderer *, vtkVolume *) [protected]
  • UpdateProgress(float amount)
  • UpdateProperties(vtkRenderer *, vtkVolume *) [protected]
  • UpdateVolume(vtkRenderer *, vtkVolume *) [protected]
  • Volume [protected]
  • VolumeBuildTime [protected]
  • VolumeDataType [protected]
  • VolumeInput [protected]
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkOpenGLVolumeProVG500Mapper() [inline, protected]
  • vtkOpenGLVolumeProVG500Mapper(const vtkOpenGLVolumeProVG500Mapper &) (defined in vtkOpenGLVolumeProVG500Mapper) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLVolumeProVG500Mapper, vtkVolumeProVG500Mapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeProMapper() [protected]
  • vtkVolumeProVG500Mapper() [protected]
  • WrongVLIVersion [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLVolumeProVG500Mapper() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeProMapper() [protected]
  • ~vtkVolumeProVG500Mapper() [protected]
Generated on Mon Mar 25 01:26:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLVolumeProVP1000Mapper Member List

This is the complete list of members for vtkOpenGLVolumeProVP1000Mapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BlendMode [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • CheckSubSampling(const VLIVolume *inVolume, const VLIContext *inContext, int &outImageWidth, int &outImageHeight) [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • Context [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Cursor [protected]
  • CursorOff() [virtual]
  • CursorOn() [virtual]
  • CursorPosition [protected]
  • CursorType [protected]
  • CursorXAxisColor [protected]
  • CursorYAxisColor [protected]
  • CursorZAxisColor [protected]
  • Cut [protected]
  • CutPlane [protected]
  • CutPlaneEquation [protected]
  • CutPlaneFallOffDistance [protected]
  • CutPlaneOff() [virtual]
  • CutPlaneOn() [virtual]
  • CutPlaneThickness [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DepthBuffer [protected]
  • DisplayedMessage [protected]
  • DrawBoundingBox [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAvailableBoardMemory() [virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetCursor() [virtual]
  • GetCursorPosition() [virtual]
  • GetCursorPosition(double data[3]) [virtual]
  • GetCursorType() [virtual]
  • GetCursorTypeAsString(void) [inline]
  • GetCursorXAxisColor() [virtual]
  • GetCursorXAxisColor(double data[3]) [virtual]
  • GetCursorYAxisColor() [virtual]
  • GetCursorYAxisColor(double data[3]) [virtual]
  • GetCursorZAxisColor() [virtual]
  • GetCursorZAxisColor(double data[3]) [virtual]
  • GetCutPlane() [virtual]
  • GetCutPlaneEquation() [virtual]
  • GetCutPlaneEquation(double data[4]) [virtual]
  • GetCutPlaneFallOffDistance() [virtual]
  • GetCutPlaneThickness() [virtual]
  • GetDebug()
  • GetDepthBufferValues(vtkRenderer *ren, int size[2], unsigned int *outData) [protected, virtual]
  • vtkVolumeProVP1000Mapper::GetDepthBufferValues(vtkRenderer *vtkNotUsed(ren), int size[2], unsigned int *outData) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientDiffuseModulation() [virtual]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetGradientOpacityModulation() [virtual]
  • GetGradientSpecularModulation() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetLockSizesForBoardMemory(unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize) [virtual]
  • vtkVolumeProMapper::GetLockSizesForBoardMemory(unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize)) [inline, virtual]
  • GetMajorBoardVersion() [virtual]
  • GetMinorBoardVersion() [virtual]
  • GetMTime() [virtual]
  • GetNoHardware() [virtual]
  • GetNumberOfBoards() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetSubVolume() [virtual]
  • GetSubVolume(int data[6]) [virtual]
  • GetSuperSampling() [virtual]
  • GetSuperSamplingFactor() [virtual]
  • GetSuperSamplingFactor(double data[3]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetWrongVLIVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientDiffuseModulation [protected]
  • GradientDiffuseModulationOff() [virtual]
  • GradientDiffuseModulationOn() [virtual]
  • GradientOpacityModulation [protected]
  • GradientOpacityModulationOff() [virtual]
  • GradientOpacityModulationOn() [virtual]
  • GradientSpecularModulation [protected]
  • GradientSpecularModulationOff() [virtual]
  • GradientSpecularModulationOn() [virtual]
  • GradientTableSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageBuffer [protected]
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Lights [protected]
  • LoadedDataSize [protected]
  • LookupTable [protected]
  • MajorBoardVersion [protected]
  • MinorBoardVersion [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoHardware [protected]
  • NumberOfBoards [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLights [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLVolumeProVP1000Mapper &) [protected]
  • vtkVolumeProVP1000Mapper::operator=(const vtkVolumeProVP1000Mapper &)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderBoundingBox(vtkRenderer *ren, vtkVolume *vol) [protected, virtual]
  • vtkVolumeProVP1000Mapper::RenderBoundingBox(vtkRenderer *vtkNotUsed(ren), vtkVolume *vol) [inline, virtual]
  • RenderImageBuffer(vtkRenderer *ren, vtkVolume *vol, int size[2], unsigned int *outData) [protected]
  • vtkVolumeProVP1000Mapper::RenderImageBuffer(vtkRenderer *vtkNotUsed(ren), vtkVolume *vol, int size[2], unsigned int *outData) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToComposite() [inline]
  • SetBlendModeToMaximumIntensity() [inline]
  • SetBlendModeToMinimumIntensity() [inline]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetCursor(int) [virtual]
  • SetCursorPosition(double, double, double) [virtual]
  • SetCursorPosition(double[3]) [virtual]
  • SetCursorType(int) [virtual]
  • SetCursorTypeToCrossHair() [inline]
  • SetCursorTypeToPlane() [inline]
  • SetCursorXAxisColor(double, double, double) [virtual]
  • SetCursorXAxisColor(double[3]) [virtual]
  • SetCursorYAxisColor(double, double, double) [virtual]
  • SetCursorYAxisColor(double[3]) [virtual]
  • SetCursorZAxisColor(double, double, double) [virtual]
  • SetCursorZAxisColor(double[3]) [virtual]
  • SetCutPlane(int) [virtual]
  • SetCutPlaneEquation(double, double, double, double) [virtual]
  • SetCutPlaneEquation(double[4]) [virtual]
  • SetCutPlaneFallOffDistance(int) [virtual]
  • SetCutPlaneThickness(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientDiffuseModulation(int) [virtual]
  • SetGradientOpacityModulation(int) [virtual]
  • SetGradientSpecularModulation(int) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubVolume(int, int, int, int, int, int) [virtual]
  • SetSubVolume(int[6]) [virtual]
  • SetSuperSampling(int) [virtual]
  • SetSuperSamplingFactor(double x, double y, double z)
  • SetSuperSamplingFactor(double f[3]) [inline]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StatusOK() [protected]
  • SubjectHelper [protected]
  • SubVolume [protected]
  • SuperSampling [protected]
  • SuperSamplingFactor [protected]
  • SuperSamplingOff() [virtual]
  • SuperSamplingOn() [virtual]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateCamera(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCropping(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCursor(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCutPlane(vtkRenderer *, vtkVolume *) [protected]
  • UpdateLights(vtkRenderer *, vtkVolume *) [protected]
  • UpdateProgress(float amount)
  • UpdateProperties(vtkRenderer *, vtkVolume *) [protected]
  • UpdateVolume(vtkRenderer *, vtkVolume *) [protected]
  • Volume [protected]
  • VolumeBuildTime [protected]
  • VolumeDataType [protected]
  • VolumeInput [protected]
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkOpenGLVolumeProVP1000Mapper() [inline, protected]
  • vtkOpenGLVolumeProVP1000Mapper(const vtkOpenGLVolumeProVP1000Mapper &) [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLVolumeProVP1000Mapper, vtkVolumeProVP1000Mapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeProMapper() [protected]
  • vtkVolumeProVP1000Mapper() [protected]
  • vtkVolumeProVP1000Mapper(const vtkVolumeProVP1000Mapper &) [protected]
  • WrongVLIVersion [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLVolumeProVP1000Mapper() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeProMapper() [protected]
  • ~vtkVolumeProVP1000Mapper() [protected]
Generated on Mon Mar 25 01:26:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLVolumeRayCastMapper Member List

This is the complete list of members for vtkOpenGLVolumeRayCastMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AutoAdjustSampleDistances [protected]
  • AutoAdjustSampleDistancesOff() [virtual]
  • AutoAdjustSampleDistancesOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • ClipRayAgainstClippingPlanes(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [protected]
  • ClipRayAgainstVolume(VTKVRCDynamicInfo *dynamicInfo, float bounds[6]) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeMatrices(vtkImageData *data, vtkVolume *vol) [protected]
  • ComputeRowBounds(vtkVolume *vol, vtkRenderer *ren) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdjustSampleDistances() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientShader() [virtual]
  • GetImageSampleDistance() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetMaximumImageSampleDistance() [virtual]
  • GetMinimumImageSampleDistance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetSampleDistance() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetVolumeRayCastFunction() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetZBufferValue(int x, int y) [protected]
  • GetZeroOpacityThreshold(vtkVolume *vol)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientShader [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Image [protected]
  • ImageClipper [protected]
  • ImageInUseSize [protected]
  • ImageMemorySize [protected]
  • ImageOrigin [protected]
  • ImageSampleDistance [protected]
  • ImageViewportSize [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeClippingPlanes(VTKVRCStaticInfo *staticInfo, vtkPlaneCollection *planes) [protected]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MaximumImageSampleDistance [protected]
  • MinimumImageSampleDistance [protected]
  • MinimumViewDistance [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • OldRowBounds [protected]
  • operator=(const vtkOpenGLVolumeRayCastMapper &) (defined in vtkOpenGLVolumeRayCastMapper) [private]
  • PerspectiveMatrix [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderRendererTable [protected]
  • RenderTableEntries [protected]
  • RenderTableSize [protected]
  • RenderTexture(vtkVolume *vol, vtkRenderer *ren) [protected, virtual]
  • RenderTimeTable [protected]
  • RenderVolumeTable [protected]
  • RetrieveRenderTime(vtkRenderer *ren, vtkVolume *vol) [protected]
  • RowBounds [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • ScalarDataPointer [protected]
  • ScalarDataType [protected]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdjustSampleDistances(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetImageSampleDistance(float) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetMaximumImageSampleDistance(float) [virtual]
  • SetMinimumImageSampleDistance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfThreads(int num)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetSampleDistance(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVolumeRayCastFunction(vtkVolumeRayCastFunction *) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StoreRenderTime(vtkRenderer *ren, vtkVolume *vol, float t) [protected]
  • SubjectHelper [protected]
  • Threader [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UpdateShadingTables(vtkRenderer *ren, vtkVolume *vol) [protected]
  • ViewToVoxelsMatrix [protected]
  • ViewToWorldMatrix [protected]
  • VolumeRayCastFunction [protected]
  • VolumeRayCastMapper_CastRays(void *arg) [friend]
  • VoxelCroppingRegionPlanes [protected]
  • VoxelsToViewMatrix [protected]
  • VoxelsToWorldMatrix [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkOpenGLVolumeRayCastMapper() [protected]
  • vtkOpenGLVolumeRayCastMapper(const vtkOpenGLVolumeRayCastMapper &) (defined in vtkOpenGLVolumeRayCastMapper) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLVolumeRayCastMapper, vtkVolumeRayCastMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeRayCastMapper() [protected]
  • WorldSampleDistance [protected]
  • WorldToVoxelsMatrix [protected]
  • ZBuffer [protected]
  • ZBufferOrigin [protected]
  • ZBufferSize [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLVolumeRayCastMapper() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeRayCastMapper() [protected]
Generated on Mon Mar 25 01:26:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOpenGLVolumeTextureMapper2D Member List

This is the complete list of members for vtkOpenGLVolumeTextureMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArraySize [protected]
  • AxisTextureSize [protected]
  • BlueDiffuseShadingTable [protected]
  • BlueSpecularShadingTable [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeAxisTextureSize(int axis, int *size) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodedNormals [protected]
  • EndTag [protected]
  • GenerateTexturesAndRenderQuads(vtkRenderer *ren, vtkVolume *vol) [protected]
  • GetAbortExecute() [virtual]
  • GetAxisTextureSize() [inline]
  • GetBlueDiffuseShadingTable() [inline]
  • GetBlueSpecularShadingTable() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetEncodedNormals() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes() [inline]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientOpacityArray() [inline]
  • GetGradientShader() [virtual]
  • GetGreenDiffuseShadingTable() [inline]
  • GetGreenSpecularShadingTable() [inline]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetInternalSkipFactor() [inline]
  • GetLength()
  • GetMaximumNumberOfPlanes() [virtual]
  • GetMaximumStorageSize() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRedDiffuseShadingTable() [inline]
  • GetRedSpecularShadingTable() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRGBAArray() [inline]
  • GetSaveTextures() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShade() [virtual]
  • GetTargetTextureSize() [virtual]
  • GetTargetTextureSize(int &, int &) [virtual]
  • GetTargetTextureSize(int[2]) [virtual]
  • GetTexture() [inline]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientMagnitudes [protected]
  • GradientOpacityArray [protected]
  • GradientShader [protected]
  • GreenDiffuseShadingTable [protected]
  • GreenSpecularShadingTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol) [inline, protected]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol, int majorDirection) [protected]
  • Inputs [protected]
  • InternalSkipFactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MajorDirection [protected]
  • MaximumNumberOfPlanes [protected]
  • MaximumStorageSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOpenGLVolumeTextureMapper2D &) (defined in vtkOpenGLVolumeTextureMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RedDiffuseShadingTable [protected]
  • RedSpecularShadingTable [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkVolume *vol) [virtual]
  • RenderQuads(int count, float *v, float *t, unsigned char *texture, int size[2], int reverseFlag)
  • vtkVolumeTextureMapper2D::RenderQuads(int vtkNotUsed(count), float *vtkNotUsed(v), float *vtkNotUsed(t), unsigned char *vtkNotUsed(texture), int vtkNotUsed(size)[2], int vtkNotUsed(reverseFlag)) [inline, virtual]
  • RenderSavedTexture() [protected]
  • RenderWindow [protected]
  • RGBAArray [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • SaveTextures [protected]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetMaximumNumberOfPlanes(int) [virtual]
  • SetMaximumStorageSize(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetTextureSize(int, int) [virtual]
  • SetTargetTextureSize(int[2])
  • Shade [protected]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TargetTextureSize [protected]
  • Texture [protected]
  • TextureMTime [protected]
  • TextureSize [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkOpenGLVolumeTextureMapper2D() [protected]
  • vtkOpenGLVolumeTextureMapper2D(const vtkOpenGLVolumeTextureMapper2D &) (defined in vtkOpenGLVolumeTextureMapper2D) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOpenGLVolumeTextureMapper2D, vtkVolumeTextureMapper2D)
  • vtkVolumeMapper() [protected]
  • vtkVolumeTextureMapper() [protected]
  • vtkVolumeTextureMapper2D() [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLVolumeTextureMapper2D() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeTextureMapper() [protected]
  • ~vtkVolumeTextureMapper2D() [protected]
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOrderedTriangulator Member List

This is the complete list of members for vtkOrderedTriangulator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddTetras(int classification, vtkUnstructuredGrid *ugrid)
  • AddTetras(int classification, vtkCellArray *connectivity)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPreSorted() [virtual]
  • GetReferenceCount() [inline]
  • GetTetras(int classification, vtkUnstructuredGrid *ugrid)
  • GetUseTwoSortIds() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTriangulation(float bounds[6], int numPts)
  • InsertPoint(vtkIdType id, float x[3], int type)
  • InsertPoint(vtkIdType id, vtkIdType sortid, float x[3], int type)
  • InsertPoint(vtkIdType id, vtkIdType sortid, vtkIdType sortid2, float x[3], int type)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaximumNumberOfPoints (defined in vtkOrderedTriangulator) [private]
  • Mesh (defined in vtkOrderedTriangulator) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfPoints (defined in vtkOrderedTriangulator) [private]
  • operator=(const vtkOrderedTriangulator &) (defined in vtkOrderedTriangulator) [private]
  • Pool (defined in vtkOrderedTriangulator) [private]
  • PreSorted (defined in vtkOrderedTriangulator) [private]
  • PreSortedOff() [virtual]
  • PreSortedOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetPreSorted(int) [virtual]
  • SetReferenceCount(int)
  • SetUseTwoSortIds(int) [virtual]
  • SubjectHelper [protected]
  • Triangulate()
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePointType(vtkIdType internalId, int type)
  • UseTwoSortIds (defined in vtkOrderedTriangulator) [private]
  • UseTwoSortIdsOff() [virtual]
  • UseTwoSortIdsOn() [virtual]
  • vtkObject() [protected]
  • vtkOrderedTriangulator() [protected]
  • vtkOrderedTriangulator(const vtkOrderedTriangulator &) (defined in vtkOrderedTriangulator) [private]
  • vtkTypeRevisionMacro(vtkOrderedTriangulator, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkOrderedTriangulator() [protected]
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutlineCornerFilter Member List

This is the complete list of members for vtkOutlineCornerFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CornerFactor [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCornerFactor() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOutlineCornerFilter &) (defined in vtkOutlineCornerFilter) [private]
  • OutlineCornerSource [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCornerFactor(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkOutlineCornerFilter() [protected]
  • vtkOutlineCornerFilter(const vtkOutlineCornerFilter &) (defined in vtkOutlineCornerFilter) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOutlineCornerFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutlineCornerFilter() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutlineCornerSource Member List

This is the complete list of members for vtkOutlineCornerSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CornerFactor [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float data[6]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCornerFactor() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOutlineCornerSource &) (defined in vtkOutlineCornerSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBounds(float, float, float, float, float, float) [virtual]
  • SetBounds(float[6]) [virtual]
  • SetCornerFactor(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkOutlineCornerSource() [protected]
  • vtkOutlineCornerSource(const vtkOutlineCornerSource &) (defined in vtkOutlineCornerSource) [private]
  • vtkOutlineSource() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOutlineCornerSource, vtkOutlineSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkOutlineCornerSource() [inline, protected]
  • ~vtkOutlineSource() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:26:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutlineFilter Member List

This is the complete list of members for vtkOutlineFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOutlineFilter &) (defined in vtkOutlineFilter) [private]
  • OutlineSource [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkOutlineFilter() [protected]
  • vtkOutlineFilter(const vtkOutlineFilter &) (defined in vtkOutlineFilter) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOutlineFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutlineFilter() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:26:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutlineSource Member List

This is the complete list of members for vtkOutlineSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float data[6]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOutlineSource &) (defined in vtkOutlineSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBounds(float, float, float, float, float, float) [virtual]
  • SetBounds(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkOutlineSource() [protected]
  • vtkOutlineSource(const vtkOutlineSource &) (defined in vtkOutlineSource) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkOutlineSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkOutlineSource() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:26:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutputPort Member List

This is the complete list of members for vtkOutputPort, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Controller [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetController() [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetPipelineFlag() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetTag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkOutputPort &) (defined in vtkOutputPort) [private]
  • ParameterMethod [protected]
  • ParameterMethodArg [protected]
  • ParameterMethodArgDelete [protected]
  • PipelineFlag [protected]
  • PipelineFlagOff() [virtual]
  • PipelineFlagOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataObject *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetParameterMethod(void(*f)(void *), void *arg)
  • SetParameterMethodArgDelete(void(*f)(void *))
  • SetPipelineFlag(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTag(int tag)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tag [protected]
  • TriggerUpdate(int remoteProcessId)
  • TriggerUpdateInformation(int remoteProcessId)
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UpdateTime [protected]
  • vtkObject() [protected]
  • vtkOutputPort() [protected]
  • vtkOutputPort(const vtkOutputPort &) (defined in vtkOutputPort) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkOutputPort, vtkProcessObject)
  • WaitForUpdate() [inline]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutputPort() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:27:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutputWindow Member List

This is the complete list of members for vtkOutputWindow, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayDebugText(const char *) [virtual]
  • DisplayErrorText(const char *) [virtual]
  • DisplayGenericWarningText(const char *) [virtual]
  • DisplayText(const char *) [virtual]
  • DisplayWarningText(const char *) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInstance() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Instance (defined in vtkOutputWindow) [private, static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkOutputWindow &) (defined in vtkOutputWindow) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PromptUser [protected]
  • PromptUserOff() [virtual]
  • PromptUserOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstance(vtkOutputWindow *instance) [static]
  • SetPromptUser(int) [virtual]
  • SetReferenceCount(int)
  • SmartPointer [static]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOutputWindow() [protected]
  • vtkOutputWindow(const vtkOutputWindow &) (defined in vtkOutputWindow) [private]
  • vtkTypeRevisionMacro(vtkOutputWindow, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkOutputWindow() [protected, virtual]
Generated on Mon Mar 25 01:27:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOutputWindowSmartPointer Member List

This is the complete list of members for vtkOutputWindowSmartPointer, including all inherited members.
  • Pointer (defined in vtkOutputWindowSmartPointer) [private]
  • SetPointer(vtkOutputWindow *obj) [inline]
  • vtkOutputWindowSmartPointer(vtkOutputWindow *p) [inline]
  • ~vtkOutputWindowSmartPointer()
Generated on Mon Mar 25 01:27:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOverrideInformation Member List

This is the complete list of members for vtkOverrideInformation, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClassOverrideName (defined in vtkOverrideInformation) [private]
  • ClassOverrideWithName (defined in vtkOverrideInformation) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Description (defined in vtkOverrideInformation) [private]
  • GetClassName() [inline, virtual]
  • GetClassOverrideName() [inline]
  • GetClassOverrideWithName() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDescription() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetObjectFactory() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • ObjectFactory (defined in vtkOverrideInformation) [private]
  • operator=(const vtkOverrideInformation &) (defined in vtkOverrideInformation) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetClassOverrideName(const char *) [virtual]
  • SetClassOverrideWithName(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDescription(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetObjectFactory(vtkObjectFactory *) [protected, virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkObjectFactory class [friend]
  • vtkOverrideInformation() (defined in vtkOverrideInformation) [private]
  • vtkOverrideInformation(const vtkOverrideInformation &) (defined in vtkOverrideInformation) [private]
  • vtkTypeRevisionMacro(vtkOverrideInformation, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkOverrideInformation() (defined in vtkOverrideInformation) [private]
Generated on Mon Mar 25 01:27:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkOverrideInformationCollection Member List

This is the complete list of members for vtkOverrideInformationCollection, including all inherited members.
  • AddItem(vtkOverrideInformation *) [inline]
  • AddItem(vtkObject *o) (defined in vtkOverrideInformationCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkOverrideInformationCollection &) (defined in vtkOverrideInformationCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkOverrideInformationCollection() [inline, protected]
  • vtkOverrideInformationCollection(const vtkOverrideInformationCollection &) (defined in vtkOverrideInformationCollection) [private]
  • vtkTypeRevisionMacro(vtkOverrideInformationCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkOverrideInformationCollection() [inline, protected]
Generated on Mon Mar 25 01:27:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkParallelCoordinatesActor Member List

This is the complete list of members for vtkParallelCoordinatesActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Axes (defined in vtkParallelCoordinatesActor) [private]
  • Bold (defined in vtkParallelCoordinatesActor) [private]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime (defined in vtkParallelCoordinatesActor) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • FontFamily (defined in vtkParallelCoordinatesActor) [private]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBold() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetIndependentVariables() [virtual]
  • GetInput() [virtual]
  • GetItalic() [virtual]
  • GetLabelFormat() [virtual]
  • GetLayerNumber() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfLabels() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetShadow() [virtual]
  • GetTitle() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IndependentVariables (defined in vtkParallelCoordinatesActor) [private]
  • Initialize() (defined in vtkParallelCoordinatesActor) [private]
  • InitPathTraversal() [virtual]
  • Input (defined in vtkParallelCoordinatesActor) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic (defined in vtkParallelCoordinatesActor) [private]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabelFormat (defined in vtkParallelCoordinatesActor) [private]
  • LayerNumber [protected]
  • Mapper [protected]
  • Maxs (defined in vtkParallelCoordinatesActor) [private]
  • Mins (defined in vtkParallelCoordinatesActor) [private]
  • Modified() [virtual]
  • MTime [protected]
  • N (defined in vtkParallelCoordinatesActor) [private]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfLabels (defined in vtkParallelCoordinatesActor) [private]
  • operator=(const vtkParallelCoordinatesActor &) (defined in vtkParallelCoordinatesActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PlaceAxes(vtkViewport *viewport, int *size) (defined in vtkParallelCoordinatesActor) [private]
  • PlotActor (defined in vtkParallelCoordinatesActor) [private]
  • PlotData (defined in vtkParallelCoordinatesActor) [private]
  • PlotMapper (defined in vtkParallelCoordinatesActor) [private]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *) [virtual]
  • RenderOverlay(vtkViewport *) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBold(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetIndependentVariables(int) [virtual]
  • SetIndependentVariablesToColumns() [inline]
  • SetIndependentVariablesToRows() [inline]
  • SetInput(vtkDataObject *) [virtual]
  • SetItalic(int) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetNumberOfLabels(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetShadow(int) [virtual]
  • SetTitle(const char *) [virtual]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • Shadow (defined in vtkParallelCoordinatesActor) [private]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Title (defined in vtkParallelCoordinatesActor) [private]
  • TitleActor (defined in vtkParallelCoordinatesActor) [private]
  • TitleMapper (defined in vtkParallelCoordinatesActor) [private]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkObject() [protected]
  • vtkParallelCoordinatesActor() [protected]
  • vtkParallelCoordinatesActor(const vtkParallelCoordinatesActor &) (defined in vtkParallelCoordinatesActor) [private]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkParallelCoordinatesActor, vtkActor2D)
  • Xs (defined in vtkParallelCoordinatesActor) [private]
  • YMax (defined in vtkParallelCoordinatesActor) [private]
  • YMin (defined in vtkParallelCoordinatesActor) [private]
  • ~vtkActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkParallelCoordinatesActor() [protected]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:27:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkParallelFactory Member List

This is the complete list of members for vtkParallelFactory, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CreateAllInstance(const char *vtkclassname, vtkCollection *retList) [static]
  • CreateFunction typedef
  • CreateInstance(const char *vtkclassname) [static]
  • CreateObject(const char *vtkclassname) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Disable(const char *className) [virtual]
  • GetClassName() [inline, virtual]
  • GetClassOverrideName(int index) [virtual]
  • GetClassOverrideWithName(int index) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDescription() [virtual]
  • GetEnableFlag(int index) [virtual]
  • GetEnableFlag(const char *className, const char *subclassName) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLibraryPath() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfOverrides() [virtual]
  • GetOverrideDescription(int index) [virtual]
  • GetOverrideInformation(const char *name, vtkOverrideInformationCollection *) [static]
  • GetReferenceCount() [inline]
  • GetRegisteredFactories() [static]
  • GetVTKSourceVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HasOverride(const char *className) [virtual]
  • HasOverride(const char *className, const char *subclassName) [virtual]
  • HasOverrideAny(const char *className) [static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkParallelFactory &) (defined in vtkParallelFactory) [private]
  • OverrideArray [protected]
  • OverrideArrayLength [protected]
  • OverrideClassNames [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterFactory(vtkObjectFactory *) [static]
  • RegisterOverride(const char *classOverride, const char *overrideClassName, const char *description, int enableFlag, CreateFunction createFunction) [protected]
  • ReHash() [static]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAllEnableFlags(int flag, const char *className) [static]
  • SetAllEnableFlags(int flag, const char *className, const char *subclassName) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEnableFlag(int flag, const char *className, const char *subclassName) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SizeOverrideArray [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllFactories() [static]
  • UnRegisterFactory(vtkObjectFactory *) [static]
  • vtkObject() [protected]
  • vtkObjectFactory() [protected]
  • vtkParallelFactory() [protected]
  • vtkParallelFactory(const vtkParallelFactory &) (defined in vtkParallelFactory) [private]
  • vtkTypeRevisionMacro(vtkParallelFactory, vtkObjectFactory)
  • ~vtkObject() [protected, virtual]
  • ~vtkObjectFactory() [protected]
  • ~vtkParallelFactory() [inline, protected]
Generated on Mon Mar 25 01:27:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkParticleReader Member List

This is the complete list of members for vtkParticleReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • File [protected]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPoints [protected]
  • NumberOfRequiredInputs [protected]
  • OpenFile() [protected]
  • operator=(const vtkParticleReader &) (defined in vtkParticleReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkParticleReader() [protected]
  • vtkParticleReader(const vtkParticleReader &) (defined in vtkParticleReader) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkParticleReader, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkParticleReader() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPCAAnalysisFilter Member List

This is the complete list of members for vtkPCAAnalysisFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Evals (defined in vtkPCAAnalysisFilter) [private]
  • evecMat2 (defined in vtkPCAAnalysisFilter) [private]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetEvals() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int idx)
  • GetInputs() [inline]
  • GetModesRequiredFor(float proportion)
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetParameterisedShape(vtkFloatArray *b, vtkPointSet *shape)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShapeParameters(vtkPointSet *shape, vtkFloatArray *b, int bsize)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • meanshape (defined in vtkPCAAnalysisFilter) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPCAAnalysisFilter &) (defined in vtkPCAAnalysisFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int idx, vtkPointSet *p)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int n)
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPCAAnalysisFilter() [protected]
  • vtkPCAAnalysisFilter(const vtkPCAAnalysisFilter &) (defined in vtkPCAAnalysisFilter) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPCAAnalysisFilter, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPCAAnalysisFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPCellDataToPointData Member List

This is the complete list of members for vtkPCellDataToPointData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassCellData() [virtual]
  • GetPieceInvariant() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPCellDataToPointData &) (defined in vtkPCellDataToPointData) [private]
  • Outputs [protected]
  • PassCellData [protected]
  • PassCellDataOff() [virtual]
  • PassCellDataOn() [virtual]
  • PieceInvariant [protected]
  • PieceInvariantOff() [virtual]
  • PieceInvariantOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPassCellData(int) [virtual]
  • SetPieceInvariant(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCellDataToPointData() [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkPCellDataToPointData() [protected]
  • vtkPCellDataToPointData(const vtkPCellDataToPointData &) (defined in vtkPCellDataToPointData) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPCellDataToPointData, vtkCellDataToPointData)
  • ~vtkCellDataToPointData() [inline, protected]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPCellDataToPointData() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPDataSetReader Member List

This is the complete list of members for vtkPDataSetReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CheckOutput() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • CoverExtent(int ext[6], int *pieceMask) [protected]
  • DataType [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataType() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput() [virtual]
  • vtkSource::GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageDataExecute() [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPieces [protected]
  • NumberOfRequiredInputs [protected]
  • OpenFile() [protected]
  • operator=(const vtkPDataSetReader &) [protected]
  • Outputs [protected]
  • PieceExtents [protected]
  • PieceFileNames [protected]
  • PolyDataExecute() [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadOutputType() [virtual]
  • ReadPVTKFileInformation(ifstream *fp) [protected]
  • ReadVTKFileInformation(ifstream *fp) [protected]
  • ReadXML(ifstream *file, char **block, char **param, char **value) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfPieces(int num) [protected]
  • SetOutput(vtkDataSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredFlag [protected]
  • StructuredGridExecute() [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredGridExecute() [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VTKFileFlag [protected]
  • vtkObject() [protected]
  • vtkPDataSetReader() [protected]
  • vtkPDataSetReader(const vtkPDataSetReader &) [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPDataSetReader, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPDataSetReader() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPDataSetWriter Member List

This is the complete list of members for vtkPDataSetWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndPiece [protected]
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FilePattern [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEndPiece() [virtual]
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFileType() [virtual]
  • GetGhostLevel() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetStartPiece() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetUseRelativeFileNames() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GhostLevel [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfPieces [protected]
  • NumberOfRequiredInputs [protected]
  • OpenFile() [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkPDataSetWriter &) [protected]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetEndPiece(int) [virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFilePattern(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGhostLevel(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkDataSet *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfPieces(int num)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPiece(int) [virtual]
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetUseRelativeFileNames(int) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartPiece [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • UseRelativeFileNames [protected]
  • UseRelativeFileNamesOff() [virtual]
  • UseRelativeFileNamesOn() [virtual]
  • VectorsName [protected]
  • vtkDataSetWriter() [inline, protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPDataSetWriter() [protected]
  • vtkPDataSetWriter(const vtkPDataSetWriter &) [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPDataSetWriter, vtkDataSetWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteImageMetaData(vtkImageData *input, char *root, char *str, ostream *fptr) [protected]
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteRectilinearGridMetaData(vtkRectilinearGrid *input, char *root, char *str, ostream *fptr) [protected]
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteStructuredGridMetaData(vtkStructuredGrid *input, char *root, char *str, ostream *fptr) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteUnstructuredMetaData(vtkDataSet *input, char *root, char *str, ostream *fptr) [protected]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataSetWriter() [inline, protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPDataSetWriter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:27:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPerlinNoise Member List

This is the complete list of members for vtkPerlinNoise, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Amplitude [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • Frequency [protected]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetAmplitude() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFrequency() [virtual]
  • GetFrequency(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPhase() [virtual]
  • GetPhase(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPerlinNoise &) (defined in vtkPerlinNoise) [private]
  • Phase [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAmplitude(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetFrequency(float, float, float) [virtual]
  • SetFrequency(float[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetPhase(float, float, float) [virtual]
  • SetPhase(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkPerlinNoise() [protected]
  • vtkPerlinNoise(const vtkPerlinNoise &) (defined in vtkPerlinNoise) [private]
  • vtkTypeRevisionMacro(vtkPerlinNoise, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPerlinNoise() [inline, protected]
Generated on Mon Mar 25 01:27:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPerspectiveTransform Member List

This is the complete list of members for vtkPerspectiveTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AdjustViewport(double oldXMin, double oldXMax, double oldYMin, double oldYMax, double newXMin, double newXMax, double newYMin, double newYMax)
  • AdjustZBuffer(double oldNearZ, double oldFarZ, double newNearZ, double newFarZ)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Concatenate(vtkMatrix4x4 *matrix) [inline]
  • Concatenate(const double elements[16]) [inline]
  • Concatenate(vtkHomogeneousTransform *transform)
  • Concatenation [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • Frustum(double xmin, double xmax, double ymin, double ymax, double znear, double zfar)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConcatenatedTransform(int i) [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInput() [inline]
  • GetInverse()
  • GetInverseFlag() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConcatenatedTransforms() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • Input [protected]
  • InternalDeepCopy(vtkAbstractTransform *t) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [inline, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPerspectiveTransform &) (defined in vtkPerspectiveTransform) [private]
  • Ortho(double xmin, double xmax, double ymin, double ymax, double znear, double zfar)
  • Perspective(double angle, double aspect, double znear, double zfar)
  • Pop() [inline]
  • PostMultiply() [inline]
  • PreMultiply() [inline]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Push() [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RotateWXYZ(double angle, double x, double y, double z) [inline]
  • RotateWXYZ(double angle, const double axis[3]) [inline]
  • RotateWXYZ(double angle, const float axis[3]) [inline]
  • RotateX(double angle) [inline]
  • RotateY(double angle) [inline]
  • RotateZ(double angle) [inline]
  • SafeDownCast(vtkObject *o) [static]
  • Scale(double x, double y, double z) [inline]
  • Scale(const double s[3]) [inline]
  • Scale(const float s[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkHomogeneousTransform *input)
  • SetInverse(vtkAbstractTransform *transform)
  • SetMatrix(vtkMatrix4x4 *matrix) [inline]
  • SetMatrix(const double elements[16]) [inline]
  • SetReferenceCount(int)
  • SetupCamera(const double position[3], const double focalpoint[3], const double viewup[3])
  • Shear(double dxdz, double dydz, double zplane)
  • Stack [protected]
  • Stereo(double angle, double focaldistance)
  • SubjectHelper [protected]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • Translate(double x, double y, double z) [inline]
  • Translate(const double x[3]) [inline]
  • Translate(const float x[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkObject() [protected]
  • vtkPerspectiveTransform() [protected]
  • vtkPerspectiveTransform(const vtkPerspectiveTransform &t) (defined in vtkPerspectiveTransform) [private]
  • vtkTypeRevisionMacro(vtkPerspectiveTransform, vtkHomogeneousTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPerspectiveTransform() [protected]
Generated on Mon Mar 25 01:27:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPicker Member List

This is the complete list of members for vtkPicker, including all inherited members.
  • Actors [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetActor() [virtual]
  • GetActor2D() [virtual]
  • GetActors() [inline]
  • GetAssembly() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMapper() [virtual]
  • GetMapperPosition() [virtual]
  • GetMapperPosition(float data[3]) [virtual]
  • GetMTime() [virtual]
  • GetPath() [virtual]
  • GetPickedPositions() [inline]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetProp() [virtual]
  • GetProp3D() [virtual]
  • GetProp3Ds() [inline]
  • GetPropAssembly() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GetTolerance() [virtual]
  • GetVolume() [virtual]
  • GlobalTMin [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • IntersectWithLine(float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Mapper [protected]
  • MapperPosition [protected]
  • MarkPicked(vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m, float tMin, float mapperPos[3]) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPicker &) (defined in vtkPicker) [private]
  • Path [protected]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer) [virtual]
  • Pick(float selectionPt[3], vtkRenderer *ren) [inline]
  • PickedPositions [protected]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Prop3Ds [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPath(vtkAssemblyPath *) [virtual]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPropPicker() [protected]
  • vtkObject() [protected]
  • vtkPicker() [protected]
  • vtkPicker(const vtkPicker &) (defined in vtkPicker) [private]
  • vtkTypeRevisionMacro(vtkPicker, vtkAbstractPropPicker)
  • ~vtkAbstractPicker() [protected]
  • ~vtkAbstractPropPicker() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPicker() [protected]
Generated on Mon Mar 25 01:27:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPieceScalars Member List

This is the complete list of members for vtkPieceScalars, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellScalarsFlag [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRandomMode() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarMode() [inline]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakePieceScalars(int piece, vtkIdType numScalars) [protected]
  • MakeRandomScalars(int piece, vtkIdType numScalars) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPieceScalars &) (defined in vtkPieceScalars) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • RandomMode [protected]
  • RandomModeOff() [virtual]
  • RandomModeOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCellScalarsFlag(int) [protected, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRandomMode(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarModeToCellData() [inline]
  • SetScalarModeToPointData() [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkPieceScalars() [protected]
  • vtkPieceScalars(const vtkPieceScalars &) (defined in vtkPieceScalars) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPieceScalars, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPieceScalars() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPiecewiseFunction Member List

This is the complete list of members for vtkPiecewiseFunction, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPoint(float x, float val)
  • AddSegment(float x1, float val1, float x2, float val2)
  • ArraySize [protected]
  • BreakOnError() [static]
  • BuildFunctionFromTable(float x1, float x2, int size, float *table, int stride=1)
  • Clamping [protected]
  • ClampingOff() [virtual]
  • ClampingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *f) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • Function [protected]
  • FunctionRange [protected]
  • FunctionSize [protected]
  • GetActualMemorySize() [virtual]
  • GetClamping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataPointer() [inline]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetFirstNonZeroValue()
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocality() [virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfConsumers() [virtual]
  • GetPipelineMTime() [virtual]
  • GetRange()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetSize()
  • GetSource() [virtual]
  • GetTable(float x1, float x2, int size, float *table, int stride=1)
  • GetType()
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetValue(float x)
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IncreaseArraySize() [protected]
  • Initialize() [virtual]
  • InsertPoint(float x, float val) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Locality [protected]
  • MakeObject() [virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MovePoints(int index, int down) [protected]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkPiecewiseFunction &) (defined in vtkPiecewiseFunction) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllPoints()
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePoint(float x)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetClamping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [virtual]
  • SetUpdateExtent(int ext[6]) [virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *f) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • vtkDataObject() [protected]
  • vtkObject() [protected]
  • vtkPiecewiseFunction() [protected]
  • vtkPiecewiseFunction(const vtkPiecewiseFunction &) (defined in vtkPiecewiseFunction) [private]
  • vtkTypeRevisionMacro(vtkPiecewiseFunction, vtkDataObject)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPiecewiseFunction() [protected]
Generated on Mon Mar 25 01:27:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPiecewiseFunctionShiftScale Member List

This is the complete list of members for vtkPiecewiseFunctionShiftScale, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPositionScale() [virtual]
  • GetPositionShift() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValueScale() [virtual]
  • GetValueShift() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPiecewiseFunctionShiftScale &) (defined in vtkPiecewiseFunctionShiftScale) [private]
  • Outputs [protected]
  • PositionScale [protected]
  • PositionShift [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPiecewiseFunction *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPiecewiseFunction *output)
  • SetPositionScale(float) [virtual]
  • SetPositionShift(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValueScale(float) [virtual]
  • SetValueShift(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • ValueScale [protected]
  • ValueShift [protected]
  • vtkObject() [protected]
  • vtkPiecewiseFunctionShiftScale() [protected]
  • vtkPiecewiseFunctionShiftScale(const vtkPiecewiseFunctionShiftScale &) (defined in vtkPiecewiseFunctionShiftScale) [private]
  • vtkPiecewiseFunctionSource() [protected]
  • vtkPiecewiseFunctionToPiecewiseFunctionFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionToPiecewiseFunctionFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPiecewiseFunctionShiftScale() [protected]
  • ~vtkPiecewiseFunctionSource() [inline, protected]
  • ~vtkPiecewiseFunctionToPiecewiseFunctionFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPiecewiseFunctionSource Member List

This is the complete list of members for vtkPiecewiseFunctionSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPiecewiseFunctionSource &) (defined in vtkPiecewiseFunctionSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPiecewiseFunction *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPiecewiseFunctionSource() [protected]
  • vtkPiecewiseFunctionSource(const vtkPiecewiseFunctionSource &) (defined in vtkPiecewiseFunctionSource) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPiecewiseFunctionSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPiecewiseFunctionSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPiecewiseFunctionToPiecewiseFunctionFilter Member List

This is the complete list of members for vtkPiecewiseFunctionToPiecewiseFunctionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPiecewiseFunctionToPiecewiseFunctionFilter &) (defined in vtkPiecewiseFunctionToPiecewiseFunctionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPiecewiseFunction *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPiecewiseFunction *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPiecewiseFunctionSource() [protected]
  • vtkPiecewiseFunctionToPiecewiseFunctionFilter() [protected]
  • vtkPiecewiseFunctionToPiecewiseFunctionFilter(const vtkPiecewiseFunctionToPiecewiseFunctionFilter &) (defined in vtkPiecewiseFunctionToPiecewiseFunctionFilter) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPiecewiseFunctionToPiecewiseFunctionFilter, vtkPiecewiseFunctionSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPiecewiseFunctionSource() [inline, protected]
  • ~vtkPiecewiseFunctionToPiecewiseFunctionFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPImageWriter Member List

This is the complete list of members for vtkPImageWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMemoryLimit() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MemoryLimit [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPImageWriter &) (defined in vtkPImageWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [inline, protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetMemoryLimit(unsigned long) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SizeEstimator [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkPImageWriter() [protected]
  • vtkPImageWriter(const vtkPImageWriter &) (defined in vtkPImageWriter) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPImageWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPImageWriter() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:27:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPipelineSize Member List

This is the complete list of members for vtkPipelineSize, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataPipelineSize(vtkDataObject *input, unsigned long sizes[3]) [protected]
  • ComputeOutputMemorySize(vtkSource *src, vtkDataObject *output, unsigned long *inputSize, unsigned long size[2]) [protected]
  • ComputeSourcePipelineSize(vtkSource *src, vtkDataObject *output, unsigned long size[3]) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GenericComputeOutputMemorySize(vtkSource *src, vtkDataObject *output, unsigned long *inputSize, unsigned long size[2]) [protected]
  • GenericComputeSourcePipelineSize(vtkSource *src, vtkDataObject *output, unsigned long size[3]) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEstimatedSize(vtkDataObject *input)
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfSubPieces(unsigned long memoryLimit, vtkPolyDataMapper *mapper)
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPipelineSize &) (defined in vtkPipelineSize) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkPipelineSize() [inline, protected]
  • vtkPipelineSize(const vtkPipelineSize &) (defined in vtkPipelineSize) [private]
  • vtkTypeRevisionMacro(vtkPipelineSize, vtkObject)
  • ~vtkObject() [protected, virtual]
Generated on Mon Mar 25 01:27:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPixel Member List

This is the complete list of members for vtkPixel, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[8]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[4]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPixel &) (defined in vtkPixel) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkPixel() [protected]
  • vtkPixel(const vtkPixel &) (defined in vtkPixel) [private]
  • vtkTypeRevisionMacro(vtkPixel, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPixel() [protected]
Generated on Mon Mar 25 01:27:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPlane Member List

This is the complete list of members for vtkPlane, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DistanceToPlane(float x[3], float n[3], float p0[3]) [inline, static]
  • Evaluate(float normal[3], float origin[3], float x[3]) [inline, static]
  • Evaluate(double normal[3], double origin[3], double x[3]) [inline, static]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GeneralizedProjectPoint(float x[3], float origin[3], float normal[3], float xproj[3]) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float data[3]) [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IntersectWithLine(float p1[3], float p2[3], float n[3], float p0[3], float &t, float x[3]) [static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • operator=(const vtkPlane &) (defined in vtkPlane) [private]
  • Origin [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProjectPoint(float x[3], float origin[3], float normal[3], float xproj[3]) [static]
  • ProjectPoint(double x[3], double origin[3], double normal[3], double xproj[3]) [static]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormal(float, float, float) [virtual]
  • SetNormal(float[3]) [virtual]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkPlane() [protected]
  • vtkPlane(const vtkPlane &) (defined in vtkPlane) [private]
  • vtkTypeRevisionMacro(vtkPlane, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPlane() [inline, protected]
Generated on Mon Mar 25 01:27:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPlaneCollection Member List

This is the complete list of members for vtkPlaneCollection, including all inherited members.
  • AddItem(vtkPlane *) [inline]
  • AddItem(vtkObject *o) (defined in vtkPlaneCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkPlaneCollection &) (defined in vtkPlaneCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPlaneCollection() [inline, protected]
  • vtkPlaneCollection(const vtkPlaneCollection &) (defined in vtkPlaneCollection) [private]
  • vtkTypeRevisionMacro(vtkPlaneCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPlaneCollection() [inline, protected]
Generated on Mon Mar 25 01:27:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPlanes Member List

This is the complete list of members for vtkPlanes, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds (defined in vtkPlanes) [private]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormals() [virtual]
  • GetNumberOfPlanes()
  • GetPlane(int i)
  • GetPoints() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normals [protected]
  • operator=(const vtkPlanes &) (defined in vtkPlanes) [private]
  • Plane [protected]
  • Planes (defined in vtkPlanes) [private]
  • Points [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBounds(float bounds[6])
  • SetBounds(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SetDebug(unsigned char debugFlag)
  • SetFrustumPlanes(float planes[24])
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormals(vtkDataArray *normals)
  • SetPoints(vtkPoints *) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkPlanes() [protected]
  • vtkPlanes(const vtkPlanes &) (defined in vtkPlanes) [private]
  • vtkTypeRevisionMacro(vtkPlanes, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPlanes() [protected]
Generated on Mon Mar 25 01:27:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPlaneSource Member List

This is the complete list of members for vtkPlaneSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float data[3]) [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint1() [virtual]
  • GetPoint1(float data[3]) [virtual]
  • GetPoint2() [virtual]
  • GetPoint2(float data[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution(int &xR, int &yR) [inline]
  • GetXResolution() [virtual]
  • GetYResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPlaneSource &) (defined in vtkPlaneSource) [private]
  • Origin [protected]
  • Outputs [protected]
  • Point1 [protected]
  • Point2 [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Push(float distance)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float x, float y, float z)
  • SetCenter(float center[3])
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormal(float nx, float ny, float nz)
  • SetNormal(float n[3])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPoint1(float x, float y, float z)
  • SetPoint1(float pnt[3])
  • SetPoint2(float x, float y, float z)
  • SetPoint2(float pnt[3])
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(const int xR, const int yR)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetXResolution(int) [virtual]
  • SetYResolution(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdatePlane(float v1[3], float v2[3]) [protected]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPlaneSource() [protected]
  • vtkPlaneSource(const vtkPlaneSource &) (defined in vtkPlaneSource) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPlaneSource, vtkPolyDataSource)
  • XResolution [protected]
  • YResolution [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPlaneSource() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPLinearExtrusionFilter Member List

This is the complete list of members for vtkPLinearExtrusionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ExtrudePoint [protected]
  • ExtrusionPoint [protected]
  • ExtrusionType [protected]
  • GetAbortExecute() [virtual]
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtrusionPoint() [virtual]
  • GetExtrusionPoint(float data[3]) [virtual]
  • GetExtrusionType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPieceInvariant() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetVector() [virtual]
  • GetVector(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPLinearExtrusionFilter &) (defined in vtkPLinearExtrusionFilter) [private]
  • Outputs [protected]
  • PieceInvariant [protected]
  • PieceInvariantOff() [virtual]
  • PieceInvariantOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtrusionPoint(float, float, float) [virtual]
  • SetExtrusionPoint(float[3]) [virtual]
  • SetExtrusionType(int) [virtual]
  • SetExtrusionTypeToNormalExtrusion() [inline]
  • SetExtrusionTypeToPointExtrusion() [inline]
  • SetExtrusionTypeToVectorExtrusion() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPieceInvariant(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVector(float, float, float) [virtual]
  • SetVector(float[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vector [protected]
  • ViaNormal(float x[3], vtkIdType id, vtkDataArray *normals) [protected]
  • ViaPoint(float x[3], vtkIdType id, vtkDataArray *normals=0) [protected]
  • ViaVector(float x[3], vtkIdType id, vtkDataArray *normals=0) [protected]
  • vtkLinearExtrusionFilter() [protected]
  • vtkObject() [protected]
  • vtkPLinearExtrusionFilter() [protected]
  • vtkPLinearExtrusionFilter(const vtkPLinearExtrusionFilter &) (defined in vtkPLinearExtrusionFilter) [private]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPLinearExtrusionFilter, vtkLinearExtrusionFilter)
  • ~vtkLinearExtrusionFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPLinearExtrusionFilter() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPLOT3DReader Member List

This is the complete list of members for vtkPLOT3DReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddFunction(int functionNumber) [inline]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Alpha [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDensity(vtkPointData *outputPD) [protected]
  • ComputeEnthalpy(vtkPointData *outputPD) [protected]
  • ComputeEntropy(vtkPointData *outputPD) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalEnergy(vtkPointData *outputPD) [protected]
  • ComputeKineticEnergy(vtkPointData *outputPD) [protected]
  • ComputeMomentum(vtkPointData *outputPD) [protected]
  • ComputePressure(vtkPointData *outputPD) [protected]
  • ComputePressureGradient(vtkPointData *outputPD) [protected]
  • ComputeStagnationEnergy(vtkPointData *outputPD) [protected]
  • ComputeSwirl(vtkPointData *outputPD) [protected]
  • ComputeTemperature(vtkPointData *outputPD) [protected]
  • ComputeVelocity(vtkPointData *outputPD) [protected]
  • ComputeVelocityMagnitude(vtkPointData *outputPD) [protected]
  • ComputeVorticity(vtkPointData *outputPD) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Density [protected]
  • EndTag [protected]
  • Energy [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FileFormat [protected]
  • Fsmach [protected]
  • FunctionFileFunctionNumber [protected]
  • FunctionFileName [protected]
  • FunctionList [protected]
  • Gamma [protected]
  • GetAbortExecute() [virtual]
  • GetAlpha() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileFormat() [virtual]
  • GetFileType(FILE *fp) [protected]
  • GetFsmach() [virtual]
  • GetFunctionFileName() [virtual]
  • GetGamma() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGridNumber() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfGrids() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetQFileName() [virtual]
  • GetR() [virtual]
  • GetRe() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarFunctionNumber() [virtual]
  • GetTime() [virtual]
  • GetUvinf() [virtual]
  • GetVectorFunctionFileName() [virtual]
  • GetVectorFunctionNumber() [virtual]
  • GetVvinf() [virtual]
  • GetWvinf() [virtual]
  • GetXYZFileName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Grid [protected]
  • GridNumber [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MapFunction(int fNumber, vtkPointData *outputPD) [protected]
  • Modified() [virtual]
  • Momentum [protected]
  • MTime [protected]
  • New() [static]
  • NumberOfGrids [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPoints [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPLOT3DReader &) (defined in vtkPLOT3DReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QFileName [protected]
  • R [protected]
  • Re [protected]
  • ReadBinaryFunctionFile(FILE *fp, vtkStructuredGrid *output) [protected]
  • ReadBinaryGrid(FILE *fp, vtkStructuredGrid *output) [protected]
  • ReadBinaryGridDimensions(FILE *fp, vtkStructuredGrid *output) [protected]
  • ReadBinarySolution(FILE *fp, vtkStructuredGrid *output) [protected]
  • ReadBinaryVectorFunctionFile(FILE *fp, vtkStructuredGrid *output) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllFunctions() [inline]
  • RemoveAllInputs()
  • RemoveFunction(int)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarFunctionNumber [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileFormat(int) [virtual]
  • SetFunctionFileName(const char *) [virtual]
  • SetGamma(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGridNumber(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQFileName(const char *) [virtual]
  • SetR(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarFunctionNumber(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUvinf(float) [virtual]
  • SetVectorFunctionFileName(const char *) [virtual]
  • SetVectorFunctionNumber(int) [virtual]
  • SetVvinf(float) [virtual]
  • SetWvinf(float) [virtual]
  • SetXYZFileName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TempStorage [protected]
  • Time [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Uvinf [protected]
  • VectorFunctionFileName [protected]
  • VectorFunctionNumber [protected]
  • vtkObject() [protected]
  • vtkPLOT3DReader() [protected]
  • vtkPLOT3DReader(const vtkPLOT3DReader &) (defined in vtkPLOT3DReader) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkTypeRevisionMacro(vtkPLOT3DReader, vtkStructuredGridSource)
  • Vvinf [protected]
  • Wvinf [protected]
  • XYZFileName [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPLOT3DReader() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:27:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPLY Member List

This is the complete list of members for vtkPLY, including all inherited members.
  • add_comment(PlyFile *, char *) [static]
  • add_element(PlyFile *, char **, int) [static]
  • add_obj_info(PlyFile *, char *) [static]
  • add_property(PlyFile *, char **, int) [static]
  • ascii_get_element(PlyFile *, char *) [static]
  • binary_get_element(PlyFile *, char *) [static]
  • copy_property(PlyProperty *, PlyProperty *) [static]
  • equal_strings(const char *, const char *) [static]
  • find_element(PlyFile *, char *) [static]
  • find_property(PlyElement *, const char *, int *) [static]
  • get_ascii_item(char *, int, int *, unsigned int *, double *) [static]
  • get_binary_item(FILE *, int, int *, unsigned int *, double *) [static]
  • get_item_value(char *, int) [static]
  • get_prop_type(char *) [static]
  • get_stored_item(void *, int, int *, unsigned int *, double *) [static]
  • get_words(FILE *, int *, char **) [static]
  • my_alloc(int, int, char *) [static]
  • old_get_words(FILE *, int *) [static]
  • old_write_ascii_item(FILE *, char *, int) [static]
  • ply_close(PlyFile *) [static]
  • ply_describe_element(PlyFile *, char *, int, int, PlyProperty *) [static]
  • ply_describe_other_elements(PlyFile *, PlyOtherElems *) [static]
  • ply_describe_other_properties(PlyFile *, PlyOtherProp *, int) [static]
  • ply_describe_property(PlyFile *, char *, PlyProperty *) [static]
  • ply_element_count(PlyFile *, char *, int) [static]
  • ply_free_other_elements(PlyOtherElems *) [static]
  • ply_get_comments(PlyFile *, int *) [static]
  • ply_get_element(PlyFile *, void *) [static]
  • ply_get_element_description(PlyFile *, char *, int *, int *) [static]
  • ply_get_element_setup(PlyFile *, char *, int, PlyProperty *) [static]
  • ply_get_info(PlyFile *, float *, int *) [static]
  • ply_get_obj_info(PlyFile *, int *) [static]
  • ply_get_other_element(PlyFile *, char *, int) [static]
  • ply_get_other_properties(PlyFile *, char *, int) [static]
  • ply_get_property(PlyFile *, char *, PlyProperty *) [static]
  • ply_header_complete(PlyFile *) [static]
  • ply_open_for_reading(char *, int *, char ***, int *, float *) [static]
  • ply_open_for_writing(char *, int, const char **, int, float *) [static]
  • ply_put_comment(PlyFile *, char *) [static]
  • ply_put_element(PlyFile *, void *) [static]
  • ply_put_element_setup(PlyFile *, char *) [static]
  • ply_put_obj_info(PlyFile *, char *) [static]
  • ply_put_other_elements(PlyFile *) [static]
  • ply_read(FILE *, int *, char ***) [static]
  • ply_write(FILE *, int, const char **, int) [static]
  • store_item(char *, int, int, unsigned int, double) [static]
  • write_ascii_item(FILE *, int, unsigned int, double, int) [static]
  • write_binary_item(FILE *, int, unsigned int, double, int) [static]
  • write_scalar_type(FILE *, int) [static]
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPLYReader Member List

This is the complete list of members for vtkPLYReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPLYReader &) (defined in vtkPLYReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPLYReader() [protected]
  • vtkPLYReader(const vtkPLYReader &) (defined in vtkPLYReader) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPLYReader, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPLYReader() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPLYWriter Member List

This is the complete list of members for vtkPLYWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayName [protected]
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ColorMode [protected]
  • Component [protected]
  • DataByteOrder [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetArrayName() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(unsigned char &, unsigned char &, unsigned char &) [virtual]
  • GetColor(unsigned char[3]) [virtual]
  • GetColorMode() [virtual]
  • GetColors(vtkIdType num, vtkDataSetAttributes *dsa) [protected]
  • GetCommand(unsigned long tag)
  • GetComponent() [virtual]
  • GetDataByteOrder() [virtual]
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTable() [virtual]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkPLYWriter &) (defined in vtkPLYWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetArrayName(const char *) [virtual]
  • SetColor(unsigned char, unsigned char, unsigned char) [virtual]
  • SetColor(unsigned char[3]) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToOff() [inline]
  • SetColorModeToUniformCellColor() [inline]
  • SetColorModeToUniformColor() [inline]
  • SetColorModeToUniformPointColor() [inline]
  • SetComponent(int) [virtual]
  • SetDataByteOrder(int) [virtual]
  • SetDataByteOrderToBigEndian() [inline]
  • SetDataByteOrderToLittleEndian() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPLYWriter() [protected]
  • vtkPLYWriter(const vtkPLYWriter &) (defined in vtkPLYWriter) [private]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPLYWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPLYWriter() [protected]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:27:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPNGReader Member List

This is the complete list of members for vtkPNGReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname) [protected, virtual]
  • vtkImageReader2::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, protected, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, protected, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, protected, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkPNGReader &) (defined in vtkPNGReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkPNGReader() [inline, protected]
  • vtkPNGReader(const vtkPNGReader &) (defined in vtkPNGReader) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPNGReader, vtkImageReader2)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPNGReader() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPNGWriter Member List

This is the complete list of members for vtkPNGWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPNGWriter &) (defined in vtkPNGWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkPNGWriter() [protected]
  • vtkPNGWriter(const vtkPNGWriter &) (defined in vtkPNGWriter) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPNGWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • WriteSlice(vtkImageData *data) [protected]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPNGWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:27:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPNMReader Member List

This is the complete list of members for vtkPNMReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname)
  • vtkImageReader::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeInverseTransformedExtent(int inExtent[6], int outExtent[6])
  • ComputeInverseTransformedIncrements(int inIncr[3], int outIncr[3])
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • ComputeTransformedExtent(int inExtent[6], int outExtent[6]) [protected]
  • ComputeTransformedIncrements(int inIncr[3], int outIncr[3]) [protected]
  • ComputeTransformedOrigin(float origin[3]) [protected]
  • ComputeTransformedSpacing(float Spacing[3]) [protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataMask [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • DataVOI [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataMask() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDataVOI() [virtual]
  • GetDataVOI(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataVOI(int[6]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenAndSeekFile(int extent[6], int slice)
  • OpenFile()
  • operator=(const vtkPNMReader &) (defined in vtkPNMReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataMask(int val) [inline]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDataVOI(int, int, int, int, int, int) [virtual]
  • SetDataVOI(int[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SetTransform(vtkTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader() [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkPNMReader() [inline, protected]
  • vtkPNMReader(const vtkPNMReader &) (defined in vtkPNMReader) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPNMReader, vtkImageReader)
  • ~vtkImageReader() [protected]
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPNMReader() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPNMWriter Member List

This is the complete list of members for vtkPNMWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPNMWriter &) (defined in vtkPNMWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkPNMWriter() [inline, protected]
  • vtkPNMWriter(const vtkPNMWriter &) (defined in vtkPNMWriter) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPNMWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPNMWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:27:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointData Member List

This is the complete list of members for vtkPointData, including all inherited members.
  • AddArray(vtkDataArray *array)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)
  • AllocateArrays(int num)
  • AttributeIndices [protected]
  • AttributeLimits [protected, static]
  • AttributeLimitTypes enum name
  • AttributeNames [protected, static]
  • AttributeTypes enum name
  • BreakOnError() [static]
  • ClearFieldFlags() [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllocate(vtkDataSetAttributes::FieldList &list, vtkIdType sze=0, vtkIdType ext=1000)
  • CopyAllOff() [virtual]
  • CopyAllOn() [virtual]
  • CopyAttributeFlags [protected]
  • CopyData(vtkDataSetAttributes *fromPd, vtkIdType fromId, vtkIdType toId)
  • CopyData(vtkDataSetAttributes::FieldList &list, vtkDataSetAttributes *dsa, int idx, vtkIdType fromId, vtkIdType toId)
  • CopyFieldFlags [protected]
  • CopyFieldOff(const char *name) [inline]
  • CopyFieldOn(const char *name) [inline]
  • CopyFieldOnOff(const char *name, int onOff) [protected]
  • CopyFlags(const vtkFieldData *source) [protected]
  • CopyNormalsOff() [virtual]
  • CopyNormalsOn() [virtual]
  • CopyScalarsOff() [virtual]
  • CopyScalarsOn() [virtual]
  • CopyTCoordsOff() [virtual]
  • CopyTCoordsOn() [virtual]
  • CopyTensorsOff() [virtual]
  • CopyTensorsOn() [virtual]
  • CopyTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType fromId, vtkIdType toId)
  • CopyVectorsOff() [virtual]
  • CopyVectorsOn() [virtual]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkFieldData *pd) [virtual]
  • Delete() [virtual]
  • DoCopyAllOff [protected]
  • DoCopyAllOn [protected]
  • EXACT enum value
  • FindFlag(const char *field) [protected]
  • GetActualMemorySize() [virtual]
  • GetArray(int i)
  • GetArray(const char *arrayName, int &index)
  • GetArray(const char *arrayName)
  • GetArrayContainingComponent(int i, int &arrayComp)
  • GetArrayName(int i) [inline]
  • GetAttribute(int attributeType)
  • GetAttributeIndices(int *indexArray)
  • GetAttributeTypeAsString(int attributeType) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j)
  • GetCopyNormals()
  • GetCopyScalars()
  • GetCopyTCoords()
  • GetCopyTensors()
  • GetCopyVectors()
  • GetDebug()
  • GetField(vtkIdList *ptId, vtkFieldData *f)
  • GetFlag(const char *field) [protected]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNormals()
  • GetNormals(const char *name)
  • GetNumberOfArrays()
  • GetNumberOfComponents()
  • GetNumberOfTuples()
  • GetReferenceCount() [inline]
  • GetScalars()
  • GetScalars(const char *name)
  • GetTCoords()
  • GetTCoords(const char *name)
  • GetTensors()
  • GetTensors(const char *name)
  • GetTuple(const vtkIdType i)
  • GetTuple(const vtkIdType i, float *tuple)
  • GetVectors()
  • GetVectors(const char *name)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitializeFields() [protected, virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c)
  • InsertNextTuple(const float *tuple)
  • InsertTuple(const vtkIdType i, const float *tuple)
  • InterpolateAllocate(vtkDataSetAttributes *pd, vtkIdType sze=0, vtkIdType ext=1000)
  • InterpolateEdge(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdType p1, vtkIdType p2, float t)
  • InterpolatePoint(vtkDataSetAttributes *fromPd, vtkIdType toId, vtkIdList *ids, float *weights)
  • InterpolateTime(vtkDataSetAttributes *from1, vtkDataSetAttributes *from2, vtkIdType id, float t)
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdList *ptIds, float *weights) [protected]
  • InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData, vtkIdType toId, vtkIdType id1, vtkIdType id2, float t) [protected]
  • InterpolateTuple(vtkDataArray *fromData1, vtkDataArray *fromData2, vtkDataArray *toData, vtkIdType id, float t) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsArrayAnAttribute(int idx)
  • IsTypeOf(const char *name) [static]
  • MakeObject()
  • MAX enum value
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NOLIMIT enum value
  • NORMALS enum value
  • NullPoint(vtkIdType ptId)
  • NUM_ATTRIBUTES enum value
  • NumberOfActiveArrays [protected]
  • NumberOfArrays [protected]
  • NumberOfAttributeComponents [protected, static]
  • NumberOfFieldFlags [protected]
  • operator=(const vtkPointData &) (defined in vtkPointData) [private]
  • PassData(vtkFieldData *fd) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveArray(const char *name) [virtual]
  • RemoveArray(int index) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequiredArrays [protected]
  • Reset()
  • SafeDownCast(vtkObject *o) [static]
  • SCALARS enum value
  • SetActiveAttribute(const char *name, int attributeType)
  • SetActiveAttribute(int index, int attributeType)
  • SetActiveNormals(const char *name)
  • SetActiveScalars(const char *name)
  • SetActiveTCoords(const char *name)
  • SetActiveTensors(const char *name)
  • SetActiveVectors(const char *name)
  • SetArray(int i, vtkDataArray *array) [protected]
  • SetComponent(const vtkIdType i, const int j, const float c)
  • SetCopyAttribute(int index, int value)
  • SetCopyNormals(int i)
  • SetCopyScalars(int i)
  • SetCopyTCoords(int i)
  • SetCopyTensors(int i)
  • SetCopyVectors(int i)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNormals(vtkDataArray *da)
  • SetNumberOfArrays(int num) [inline]
  • SetNumberOfTuples(const vtkIdType number)
  • SetReferenceCount(int)
  • SetScalars(vtkDataArray *da)
  • SetTCoords(vtkDataArray *da)
  • SetTensors(vtkDataArray *da)
  • SetTuple(const vtkIdType i, const float *tuple)
  • SetVectors(vtkDataArray *da)
  • ShallowCopy(vtkFieldData *pd) [virtual]
  • Squeeze()
  • SubjectHelper [protected]
  • TargetIndices [protected]
  • TCOORDS enum value
  • TENSORS enum value
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline, virtual]
  • VECTORS enum value
  • vtkDataSetAttributes() [protected]
  • vtkDataSetAttributes::FieldList class [friend]
  • vtkFieldData() [protected]
  • vtkObject() [protected]
  • vtkPointData() [inline, protected]
  • vtkPointData(const vtkPointData &) (defined in vtkPointData) [private]
  • vtkTypeRevisionMacro(vtkPointData, vtkDataSetAttributes)
  • ~vtkDataSetAttributes() [protected]
  • ~vtkFieldData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointData() [inline, protected]
Generated on Mon Mar 25 01:27:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointDataToCellData Member List

This is the complete list of members for vtkPointDataToCellData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassPointData() [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPointDataToCellData &) (defined in vtkPointDataToCellData) [private]
  • Outputs [protected]
  • PassPointData [protected]
  • PassPointDataOff() [virtual]
  • PassPointDataOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPassPointData(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkPointDataToCellData() [protected]
  • vtkPointDataToCellData(const vtkPointDataToCellData &) (defined in vtkPointDataToCellData) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPointDataToCellData, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointDataToCellData() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointLoad Member List

This is the complete list of members for vtkPointLoad, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeEffectiveStress [protected]
  • ComputeEffectiveStressOff() [virtual]
  • ComputeEffectiveStressOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeEffectiveStress() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLoadValue() [virtual]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoissonsRatio() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LoadValue [protected]
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPointLoad &) (defined in vtkPointLoad) [private]
  • Outputs [protected]
  • PoissonsRatio [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • SetAbortExecute(int) [virtual]
  • SetComputeEffectiveStress(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLoadValue(float) [virtual]
  • SetModelBounds(float, float, float, float, float, float) [virtual]
  • SetModelBounds(float[6]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetPoissonsRatio(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointLoad() [protected]
  • vtkPointLoad(const vtkPointLoad &) (defined in vtkPointLoad) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkPointLoad, vtkStructuredPointsSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPointLoad() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:27:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointLocator2D Member List

This is the complete list of members for vtkPointLocator2D, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • Buckets [protected]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Divisions [protected]
  • FindClosestNPoints(int N, float x[2], vtkIdList *result) [virtual]
  • FindClosestNPoints(int N, float x, float y, vtkIdList *result) [virtual]
  • FindClosestPoint(float x[2]) [virtual]
  • FindDistributedPoints(int N, float x[2], vtkIdList *result, int M) [virtual]
  • FindDistributedPoints(int N, float x, float y, vtkIdList *result, int M) [virtual]
  • FindPointsWithinRadius(float R, float x[2], vtkIdList *result) [virtual]
  • FindPointsWithinRadius(float R, float x, float y, vtkIdList *result) [virtual]
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(int ijk[2], int ndivs[2], int level) [protected]
  • GetBuildTime() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfPointsPerBucket() [virtual]
  • GetOverlappingBuckets(float x[2], int ijk[2], float dist, int level) [protected]
  • GetPoints() [virtual]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HashTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertionTol2 [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInsertedPoint(float x[2]) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfBuckets [protected]
  • NumberOfPointsPerBucket [protected]
  • operator=(const vtkPointLocator2D &) (defined in vtkPointLocator2D) [private]
  • Points [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int) [virtual]
  • SetDivisions(int[2])
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfPointsPerBucket(int) [virtual]
  • SetPoints(vtkPoints *) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkLocator() [protected]
  • vtkObject() [protected]
  • vtkPointLocator2D() [protected]
  • vtkPointLocator2D(const vtkPointLocator2D &) (defined in vtkPointLocator2D) [private]
  • vtkTypeRevisionMacro(vtkPointLocator2D, vtkLocator)
  • ~vtkLocator() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointLocator2D() [protected]
Generated on Mon Mar 25 01:27:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointLocator Member List

This is the complete list of members for vtkPointLocator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Automatic [protected]
  • AutomaticOff() [virtual]
  • AutomaticOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildLocator() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distance2ToBounds(const float x[3], const float bounds[6]) [protected]
  • Distance2ToBucket(const float x[3], const int nei[3]) [protected]
  • Divisions [protected]
  • FindClosestInsertedPoint(const float x[3]) [virtual]
  • FindClosestNPoints(int N, const float x[3], vtkIdList *result) [virtual]
  • FindClosestNPoints(int N, float x, float y, float z, vtkIdList *result) [virtual]
  • FindClosestPoint(const float x[3]) [virtual]
  • FindClosestPoint(float x, float y, float z)
  • FindClosestPointWithinRadius(float radius, const float x[3], float &dist2)
  • FindClosestPointWithinRadius(float radius, const float x[3], float inputDataLength, float &dist2)
  • FindDistributedPoints(int N, const float x[3], vtkIdList *result, int M) [virtual]
  • FindDistributedPoints(int N, float x, float y, float z, vtkIdList *result, int M) [virtual]
  • FindPointsWithinRadius(float R, const float x[3], vtkIdList *result) [virtual]
  • FindPointsWithinRadius(float R, float x, float y, float z, vtkIdList *result) [virtual]
  • FreeSearchStructure() [virtual]
  • GenerateFace(int face, int i, int j, int k, vtkPoints *pts, vtkCellArray *polys) [protected]
  • GenerateRepresentation(int level, vtkPolyData *pd) [virtual]
  • GetAutomatic() [virtual]
  • GetBucketNeighbors(vtkNeighborPoints *buckets, const int ijk[3], const int ndivs[3], int level) [protected]
  • GetBuildTime() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetDivisions() [virtual]
  • GetDivisions(int data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfPointsPerBucket() [virtual]
  • GetOverlappingBuckets(vtkNeighborPoints *buckets, const float x[3], const int ijk[3], float dist, int level) [protected]
  • GetOverlappingBuckets(vtkNeighborPoints *buckets, const float x[3], float dist, int prevMinLevel[3], int prevMaxLevel[3]) [protected]
  • GetPointsInBucket(const float x[3], int ijk[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetRetainCellLists() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • H [protected]
  • HashTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitPointInsertion(vtkPoints *newPts, const float bounds[6]) [virtual]
  • InitPointInsertion(vtkPoints *newPts, const float bounds[6], vtkIdType estSize) [virtual]
  • InsertionLevel [protected]
  • InsertionPointId [protected]
  • InsertionTol2 [protected]
  • InsertNextPoint(const float x[3]) [virtual]
  • InsertPoint(vtkIdType ptId, const float x[3]) [virtual]
  • InsertUniquePoint(const float x[3], vtkIdType &ptId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInsertedPoint(float x, float y, float z) [inline]
  • IsInsertedPoint(const float x[3]) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfBuckets [protected]
  • NumberOfPointsPerBucket [protected]
  • operator=(const vtkPointLocator &) (defined in vtkPointLocator) [private]
  • Points [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RetainCellLists [protected]
  • RetainCellListsOff() [virtual]
  • RetainCellListsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomatic(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisions(int, int, int) [virtual]
  • SetDivisions(int[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetNumberOfPointsPerBucket(int) [virtual]
  • SetReferenceCount(int)
  • SetRetainCellLists(int) [virtual]
  • SetTolerance(float) [virtual]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • vtkLocator() [protected]
  • vtkObject() [protected]
  • vtkPointLocator() [protected]
  • vtkPointLocator(const vtkPointLocator &) (defined in vtkPointLocator) [private]
  • vtkTypeRevisionMacro(vtkPointLocator, vtkLocator)
  • ~vtkLocator() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointLocator() [protected]
Generated on Mon Mar 25 01:27:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointPicker Member List

This is the complete list of members for vtkPointPicker, including all inherited members.
  • Actors [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetActor() [virtual]
  • GetActor2D() [virtual]
  • GetActors() [inline]
  • GetAssembly() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMapper() [virtual]
  • GetMapperPosition() [virtual]
  • GetMapperPosition(float data[3]) [virtual]
  • GetMTime() [virtual]
  • GetPath() [virtual]
  • GetPickedPositions() [inline]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetPointId() [virtual]
  • GetProp() [virtual]
  • GetProp3D() [virtual]
  • GetProp3Ds() [inline]
  • GetPropAssembly() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GetTolerance() [virtual]
  • GetVolume() [virtual]
  • GlobalTMin [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • IntersectWithLine(float p1[3], float p2[3], float tol, vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Mapper [protected]
  • MapperPosition [protected]
  • MarkPicked(vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m, float tMin, float mapperPos[3]) [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPointPicker &) (defined in vtkPointPicker) [private]
  • Path [protected]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer) [virtual]
  • Pick(float selectionPt[3], vtkRenderer *ren) [inline]
  • PickedPositions [protected]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • PointId [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Prop3Ds [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPath(vtkAssemblyPath *) [virtual]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPropPicker() [protected]
  • vtkObject() [protected]
  • vtkPicker() [protected]
  • vtkPointPicker() [protected]
  • vtkPointPicker(const vtkPointPicker &) (defined in vtkPointPicker) [private]
  • vtkTypeRevisionMacro(vtkPointPicker, vtkPicker)
  • ~vtkAbstractPicker() [protected]
  • ~vtkAbstractPropPicker() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPicker() [protected]
  • ~vtkPointPicker() [inline, protected]
Generated on Mon Mar 25 01:27:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPoints Member List

This is the complete list of members for vtkPoints, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Data [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkPoints *ad) [virtual]
  • Delete() [virtual]
  • GetActualMemorySize()
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetData() [inline]
  • GetDataType() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfPoints() [inline]
  • GetPoint(vtkIdType id) [inline]
  • GetPoint(vtkIdType id, float x[3]) [inline]
  • GetPoint(vtkIdType id, double x[3]) [inline]
  • GetPoints(vtkIdList *ptId, vtkPoints *fp)
  • GetReferenceCount() [inline]
  • GetVoidPointer(const int id) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertNextPoint(const float x[3]) [inline]
  • InsertNextPoint(const double x[3]) [inline]
  • InsertNextPoint(double x, double y, double z) [inline]
  • InsertPoint(vtkIdType id, const float x[3]) [inline]
  • InsertPoint(vtkIdType id, const double x[3]) [inline]
  • InsertPoint(vtkIdType id, double x, double y, double z) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject()
  • Modified() [virtual]
  • MTime [protected]
  • New(int dataType) [static]
  • New() [static]
  • operator=(const vtkPoints &) (defined in vtkPoints) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetData(vtkDataArray *) [virtual]
  • SetDataType(int dataType) [virtual]
  • SetDataTypeToBit() [inline]
  • SetDataTypeToChar() [inline]
  • SetDataTypeToDouble() [inline]
  • SetDataTypeToFloat() [inline]
  • SetDataTypeToInt() [inline]
  • SetDataTypeToLong() [inline]
  • SetDataTypeToShort() [inline]
  • SetDataTypeToUnsignedChar() [inline]
  • SetDataTypeToUnsignedInt() [inline]
  • SetDataTypeToUnsignedLong() [inline]
  • SetDataTypeToUnsignedShort() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetNumberOfPoints(vtkIdType number) [inline]
  • SetPoint(vtkIdType id, const float x[3]) [inline]
  • SetPoint(vtkIdType id, const double x[3]) [inline]
  • SetPoint(vtkIdType id, double x, double y, double z) [inline]
  • SetReferenceCount(int)
  • ShallowCopy(vtkPoints *ad) [virtual]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkPoints(int dataType=VTK_FLOAT) [protected]
  • vtkPoints(const vtkPoints &) (defined in vtkPoints) [private]
  • vtkTypeRevisionMacro(vtkPoints, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkPoints() [protected]
Generated on Mon Mar 25 01:27:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointSet Member List

This is the complete list of members for vtkPointSet, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *pd) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x[3]) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • GetActualMemorySize() [virtual]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId)=0 [pure virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell)=0 [pure virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds)=0 [pure virtual]
  • GetCellType(vtkIdType cellId)=0 [pure virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize()=0 [pure virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [virtual]
  • GetNumberOfCells()=0 [pure virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [inline, virtual]
  • GetPoint(vtkIdType ptId, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds)=0 [pure virtual]
  • GetPointData() [inline]
  • GetPoints() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetSource() [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Locality [protected]
  • Locator [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkPointSet &) (defined in vtkPointSet) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • Points [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetPoints(vtkPoints *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [virtual]
  • SetUpdateExtent(int ext[6]) [virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkObject() [protected]
  • vtkPointSet() [protected]
  • vtkPointSet(const vtkPointSet &) (defined in vtkPointSet) [private]
  • vtkTypeRevisionMacro(vtkPointSet, vtkDataSet)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSet() [protected]
Generated on Mon Mar 25 01:27:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointSetSource Member List

This is the complete list of members for vtkPointSetSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPointSetSource &) (defined in vtkPointSetSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetSource(const vtkPointSetSource &) (defined in vtkPointSetSource) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPointSetSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointSetToPointSetFilter Member List

This is the complete list of members for vtkPointSetToPointSetFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPointSetToPointSetFilter &) (defined in vtkPointSetToPointSetFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkPointSetToPointSetFilter(const vtkPointSetToPointSetFilter &) (defined in vtkPointSetToPointSetFilter) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPointSetToPointSetFilter, vtkPointSetSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPointSource Member List

This is the complete list of members for vtkPointSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distribution [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDistribution() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfPoints() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfPoints [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPointSource &) (defined in vtkPointSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDistribution(int) [virtual]
  • SetDistributionToShell() [inline]
  • SetDistributionToUniform() [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfPoints(vtkIdType) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSource(vtkIdType numPts=10) [protected]
  • vtkPointSource(const vtkPointSource &) (defined in vtkPointSource) [private]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPointSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSource() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:27:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyData Member List

This is the complete list of members for vtkPolyData, including all inherited members.
  • AddCellReference(vtkIdType cellId) [inline]
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddReferenceToCell(vtkIdType ptId, vtkIdType cellId)
  • Allocate(vtkIdType numCells=1000, int extSize=1000)
  • Allocate(vtkPolyData *inPolyData, vtkIdType numCells=1000, int extSize=1000)
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildCells()
  • BuildLinks()
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Cells [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyCells(vtkPolyData *pd, vtkIdList *idList, vtkPointLocator *locator=NULL)
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • DeleteCell(vtkIdType cellId) [inline]
  • DeleteCells()
  • DeleteLinks()
  • DeletePoint(vtkIdType ptId) [inline]
  • Dummy [protected, static]
  • EmptyCell [protected]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x[3]) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • GetActualMemorySize() [virtual]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellEdgeNeighbors(vtkIdType cellId, vtkIdType p1, vtkIdType p2, vtkIdList *cellIds)
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList &ptIds, vtkIdList &cellIds) (defined in vtkPolyData) [inline, private]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdType &npts, vtkIdType *&pts)
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGhostLevel() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLength()
  • GetLines()
  • GetLocality() [virtual]
  • GetMaxCellSize() [virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [virtual]
  • GetNumberOfCells() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfLines()
  • GetNumberOfPieces() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetNumberOfPolys()
  • GetNumberOfStrips()
  • GetNumberOfVerts()
  • GetPiece() [virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [inline, virtual]
  • GetPoint(vtkIdType ptId, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [virtual]
  • GetPointCells(vtkIdType ptId, unsigned short &ncells, vtkIdType *&cells) [inline]
  • GetPointData() [inline]
  • GetPoints() [virtual]
  • GetPolys()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetSource() [virtual]
  • GetStrips()
  • GetUpdateExtent(int &piece, int &numPieces, int &ghostLevel)
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetVerts()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertNextCell(int type, int npts, vtkIdType *pts)
  • InsertNextCell(int type, vtkIdList *pts)
  • InsertNextLinkedCell(int type, int npts, vtkIdType *pts)
  • InsertNextLinkedPoint(float x[3], int numLinks)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsEdge(int v1, int v2) [inline]
  • IsPointUsedByCell(vtkIdType ptId, vtkIdType cellId) [inline]
  • IsTriangle(int v1, int v2, int v3) [inline]
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Lines [protected]
  • Links [protected]
  • Locality [protected]
  • Locator [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkPolyData &) (defined in vtkPolyData) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • Points [protected]
  • Polygon [protected]
  • PolyLine [protected]
  • Polys [protected]
  • PolyVertex [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveCellReference(vtkIdType cellId) [inline]
  • RemoveConsumer(vtkObject *c)
  • RemoveGhostCells(int level)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveReferenceToCell(vtkIdType ptId, vtkIdType cellId)
  • ReplaceCell(vtkIdType cellId, int npts, vtkIdType *pts)
  • ReplaceCellPoint(vtkIdType cellId, vtkIdType oldPtId, vtkIdType newPtId) [inline]
  • ReplaceLinkedCell(vtkIdType cellId, int npts, vtkIdType *pts)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • Reset()
  • ResizeCellList(vtkIdType ptId, int size) [inline]
  • ReverseCell(vtkIdType cellId)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLines(vtkCellArray *l)
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetPoints(vtkPoints *) [virtual]
  • SetPolys(vtkCellArray *p)
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetStrips(vtkCellArray *s)
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkPointSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetVerts(vtkCellArray *v)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • Strips [protected]
  • SubjectHelper [protected]
  • Triangle [protected]
  • TriangleStrip [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Verts [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkObject() [protected]
  • vtkPointSet() [protected]
  • vtkPolyData() [protected]
  • vtkPolyData(const vtkPolyData &) (defined in vtkPolyData) [private]
  • vtkTypeRevisionMacro(vtkPolyData, vtkPointSet)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSet() [protected]
  • ~vtkPolyData() [protected]
Generated on Mon Mar 25 01:28:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataCollection Member List

This is the complete list of members for vtkPolyDataCollection, including all inherited members.
  • AddItem(vtkPolyData *pd) [inline]
  • AddItem(vtkObject *o) (defined in vtkPolyDataCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkPolyDataCollection &) (defined in vtkPolyDataCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPolyDataCollection() [inline, protected]
  • vtkPolyDataCollection(const vtkPolyDataCollection &) (defined in vtkPolyDataCollection) [private]
  • vtkTypeRevisionMacro(vtkPolyDataCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataCollection() [inline, protected]
Generated on Mon Mar 25 01:28:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataConnectivityFilter Member List

This is the complete list of members for vtkPolyDataConnectivityFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddSeed(int id)
  • AddSpecifiedRegion(int id)
  • BreakOnError() [static]
  • CellIds (defined in vtkPolyDataConnectivityFilter) [private]
  • CellScalars (defined in vtkPolyDataConnectivityFilter) [private]
  • ClosestPoint [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorRegions [protected]
  • ColorRegionsOff() [virtual]
  • ColorRegionsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteSeed(int id)
  • DeleteSpecifiedRegion(int id)
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ExtractionMode [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClosestPoint() [virtual]
  • GetClosestPoint(float data[3]) [virtual]
  • GetColorRegions() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractionMode() [virtual]
  • GetExtractionModeAsString() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfExtractedRegions()
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarConnectivity() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeSeedList()
  • InitializeSpecifiedRegionList()
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InScalars (defined in vtkPolyDataConnectivityFilter) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Mesh (defined in vtkPolyDataConnectivityFilter) [private]
  • Modified() [virtual]
  • MTime [protected]
  • NeighborCellPointIds (defined in vtkPolyDataConnectivityFilter) [private]
  • New() [static]
  • NewScalars (defined in vtkPolyDataConnectivityFilter) [private]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumCellsInRegion (defined in vtkPolyDataConnectivityFilter) [private]
  • operator=(const vtkPolyDataConnectivityFilter &) (defined in vtkPolyDataConnectivityFilter) [private]
  • Outputs [protected]
  • PointIds (defined in vtkPolyDataConnectivityFilter) [private]
  • PointMap (defined in vtkPolyDataConnectivityFilter) [private]
  • PointNumber (defined in vtkPolyDataConnectivityFilter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • RegionNumber (defined in vtkPolyDataConnectivityFilter) [private]
  • RegionSizes [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarConnectivity [protected]
  • ScalarConnectivityOff() [virtual]
  • ScalarConnectivityOn() [virtual]
  • ScalarRange [protected]
  • Seeds [protected]
  • SetAbortExecute(int) [virtual]
  • SetClosestPoint(float, float, float) [virtual]
  • SetClosestPoint(float[3]) [virtual]
  • SetColorRegions(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractionMode(int) [virtual]
  • SetExtractionModeToAllRegions() [inline]
  • SetExtractionModeToCellSeededRegions() [inline]
  • SetExtractionModeToClosestPointRegion() [inline]
  • SetExtractionModeToLargestRegion() [inline]
  • SetExtractionModeToPointSeededRegions() [inline]
  • SetExtractionModeToSpecifiedRegions() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarConnectivity(int) [virtual]
  • SetScalarRange(float data[]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpecifiedRegionIds [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TraverseAndMark() [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Visited (defined in vtkPolyDataConnectivityFilter) [private]
  • vtkObject() [protected]
  • vtkPolyDataConnectivityFilter() [protected]
  • vtkPolyDataConnectivityFilter(const vtkPolyDataConnectivityFilter &) (defined in vtkPolyDataConnectivityFilter) [private]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataConnectivityFilter, vtkPolyDataToPolyDataFilter)
  • Wave (defined in vtkPolyDataConnectivityFilter) [private]
  • Wave2 (defined in vtkPolyDataConnectivityFilter) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataConnectivityFilter() [protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataMapper2D Member List

This is the complete list of members for vtkPolyDataMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarMode() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetTransformCoordinate() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPolyDataMapper2D &) (defined in vtkPolyDataMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransformCoordinate(vtkCoordinate *) [virtual]
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • TransformCoordinate [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataMapper2D() [protected]
  • vtkPolyDataMapper2D(const vtkPolyDataMapper2D &) (defined in vtkPolyDataMapper2D) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataMapper2D, vtkMapper2D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper2D() [protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:28:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataMapper Member List

This is the complete list of members for vtkPolyDataMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(const char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGhostLevel() [virtual]
  • GetGlobalImmediateModeRendering() [static]
  • GetGlobalWarningDisplay() [static]
  • GetImmediateModeRendering() [virtual]
  • GetInput()
  • GetInputAsDataSet() [inline]
  • GetInputs() [inline]
  • GetLength()
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfSubPieces() [virtual]
  • GetPiece() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTime() [virtual]
  • GetResolveCoincidentTopology() [static]
  • GetResolveCoincidentTopologyPolygonOffsetParameters(float &factor, float &units) [static]
  • GetResolveCoincidentTopologyZShift() [static]
  • GetScalarMode() [virtual]
  • GetScalarModeAsString()
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GhostLevel [protected]
  • GlobalImmediateModeRenderingOff() [inline, static]
  • GlobalImmediateModeRenderingOn() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImmediateModeRendering [protected]
  • ImmediateModeRenderingOff() [virtual]
  • ImmediateModeRenderingOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfPieces [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSubPieces [protected]
  • operator=(const vtkPolyDataMapper &) (defined in vtkPolyDataMapper) [private]
  • Piece [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkActor *act) [virtual]
  • RenderPiece(vtkRenderer *ren, vtkActor *act)=0 [pure virtual]
  • RenderTime [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGhostLevel(int) [virtual]
  • SetGlobalImmediateModeRendering(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImmediateModeRendering(int) [virtual]
  • SetInput(vtkPolyData *in)
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfPieces(int) [virtual]
  • SetNumberOfSubPieces(int) [virtual]
  • SetPiece(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTime(float time) [inline]
  • SetResolveCoincidentTopology(int val) [static]
  • SetResolveCoincidentTopologyPolygonOffsetParameters(float factor, float units) [static]
  • SetResolveCoincidentTopologyToDefault() [static]
  • SetResolveCoincidentTopologyToOff() [inline, static]
  • SetResolveCoincidentTopologyToPolygonOffset() [inline, static]
  • SetResolveCoincidentTopologyToShiftZBuffer() [inline, static]
  • SetResolveCoincidentTopologyZShift(double val) [static]
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkMapper() [protected]
  • vtkObject() [protected]
  • vtkPolyDataMapper() [protected]
  • vtkPolyDataMapper(const vtkPolyDataMapper &) (defined in vtkPolyDataMapper) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataMapper, vtkMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkMapper() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:28:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataNormals Member List

This is the complete list of members for vtkPolyDataNormals, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellIds (defined in vtkPolyDataNormals) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCellNormals [protected]
  • ComputeCellNormalsOff() [virtual]
  • ComputeCellNormalsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputePointNormals [protected]
  • ComputePointNormalsOff() [virtual]
  • ComputePointNormalsOn() [virtual]
  • Consistency [protected]
  • ConsistencyOff() [virtual]
  • ConsistencyOn() [virtual]
  • CosAngle (defined in vtkPolyDataNormals) [private]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FlipNormals [protected]
  • FlipNormalsOff() [virtual]
  • FlipNormalsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeCellNormals() [virtual]
  • GetComputePointNormals() [virtual]
  • GetConsistency() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFeatureAngle() [virtual]
  • GetFlipNormals() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaxRecursionDepth() [inline]
  • GetMTime() [virtual]
  • GetNonManifoldTraversal() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSplitting() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Map (defined in vtkPolyDataNormals) [private]
  • MarkAndSplit(vtkIdType ptId) (defined in vtkPolyDataNormals) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NewMesh (defined in vtkPolyDataNormals) [private]
  • NonManifoldTraversal [protected]
  • NonManifoldTraversalOff() [virtual]
  • NonManifoldTraversalOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumFlips [protected]
  • OldMesh (defined in vtkPolyDataNormals) [private]
  • operator=(const vtkPolyDataNormals &) (defined in vtkPolyDataNormals) [private]
  • Outputs [protected]
  • PolyNormals (defined in vtkPolyDataNormals) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetComputeCellNormals(int) [virtual]
  • SetComputePointNormals(int) [virtual]
  • SetConsistency(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeatureAngle(float) [virtual]
  • SetFlipNormals(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaxRecursionDepth(int) [inline]
  • SetNonManifoldTraversal(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSplitting(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Splitting [protected]
  • SplittingOff() [virtual]
  • SplittingOn() [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TraverseAndOrder(void) (defined in vtkPolyDataNormals) [private]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Visited (defined in vtkPolyDataNormals) [private]
  • vtkObject() [protected]
  • vtkPolyDataNormals() [protected]
  • vtkPolyDataNormals(const vtkPolyDataNormals &) (defined in vtkPolyDataNormals) [private]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataNormals, vtkPolyDataToPolyDataFilter)
  • Wave (defined in vtkPolyDataNormals) [private]
  • Wave2 (defined in vtkPolyDataNormals) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataNormals() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataReader Member List

This is the complete list of members for vtkPolyDataReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkPolyDataReader &) (defined in vtkPolyDataReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkPolyDataReader() [protected]
  • vtkPolyDataReader(const vtkPolyDataReader &) (defined in vtkPolyDataReader) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataReader, vtkDataReader)
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataReader() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataSource Member List

This is the complete list of members for vtkPolyDataSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPolyDataSource &) (defined in vtkPolyDataSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataSource(const vtkPolyDataSource &) (defined in vtkPolyDataSource) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataStreamer Member List

This is the complete list of members for vtkPolyDataStreamer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByPiece [protected]
  • ColorByPieceOff() [virtual]
  • ColorByPieceOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetColorByPiece() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamDivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamDivisions [protected]
  • operator=(const vtkPolyDataStreamer &) (defined in vtkPolyDataStreamer) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetColorByPiece(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfStreamDivisions(int num)
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataStreamer() [protected]
  • vtkPolyDataStreamer(const vtkPolyDataStreamer &) (defined in vtkPolyDataStreamer) [private]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataStreamer, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataStreamer() [protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataToImageStencil Member List

This is the complete list of members for vtkPolyDataToImageStencil, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected]
  • vtkSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • vtkSource::GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OBBTree [protected]
  • operator=(const vtkPolyDataToImageStencil &) [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageStencilData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageStencilData *output, int extent[6], int threadId) [protected, virtual]
  • Tolerance [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageStencilSource() [protected]
  • vtkObject() [protected]
  • vtkPolyDataToImageStencil() [protected]
  • vtkPolyDataToImageStencil(const vtkPolyDataToImageStencil &) (defined in vtkPolyDataToImageStencil) [inline, private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataToImageStencil, vtkImageStencilSource)
  • ~vtkImageStencilSource() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataToImageStencil() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataToPolyDataFilter Member List

This is the complete list of members for vtkPolyDataToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPolyDataToPolyDataFilter &) (defined in vtkPolyDataToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkPolyDataToPolyDataFilter(const vtkPolyDataToPolyDataFilter &) (defined in vtkPolyDataToPolyDataFilter) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataToPolyDataFilter, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyDataWriter Member List

This is the complete list of members for vtkPolyDataWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkPolyDataWriter &) (defined in vtkPolyDataWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkPolyDataWriter(const vtkPolyDataWriter &) (defined in vtkPolyDataWriter) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPolyDataWriter, vtkDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:28:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolygon Member List

This is the complete list of members for vtkPolygon, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *tris, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNormal(vtkPoints *p, int numPts, vtkIdType *pts, float n[3]) [static]
  • ComputeNormal(vtkPoints *p, float n[3]) [static]
  • ComputeNormal(int numPts, float *pts, float n[3]) [static]
  • ComputeWeights(float x[3], float *weights)
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EarCutTriangulation() [protected]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectPolygonWithPolygon(int npts, float *pts, float bounds[6], int npts2, float *pts2, float bounds2[3], float tol, float x[3]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • operator=(const vtkPolygon &) (defined in vtkPolygon) [private]
  • ParameterizePolygon(float p0[3], float p10[3], float &l10, float p20[3], float &l20, float n[3])
  • PointIds
  • PointInPolygon(float x[3], int numPts, float *pts, float bounds[6], float n[3]) [static]
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • SuccessfulTriangulation [protected]
  • Tolerance [protected]
  • Triangle [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulate(vtkIdList *outTris)
  • Tris [protected]
  • TriScalars [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkPolygon() [protected]
  • vtkPolygon(const vtkPolygon &) (defined in vtkPolygon) [private]
  • vtkTypeRevisionMacro(vtkPolygon, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolygon() [protected]
Generated on Mon Mar 25 01:28:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyLine Member List

This is the complete list of members for vtkPolyLine, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GenerateSlidingNormals(vtkPoints *, vtkCellArray *, vtkDataArray *)
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int vtkNotUsed(edgeId)) [inline]
  • vtkCell::GetEdge(int edgeId)=0 [pure virtual]
  • GetFace(int vtkNotUsed(faceId)) [inline]
  • vtkCell::GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPolyLine &) (defined in vtkPolyLine) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkPolyLine() [protected]
  • vtkPolyLine(const vtkPolyLine &) (defined in vtkPolyLine) [private]
  • vtkTypeRevisionMacro(vtkPolyLine, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyLine() [protected]
Generated on Mon Mar 25 01:28:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPolyVertex Member List

This is the complete list of members for vtkPolyVertex, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int vtkNotUsed(edgeId)) [inline]
  • vtkCell::GetEdge(int edgeId)=0 [pure virtual]
  • GetFace(int vtkNotUsed(faceId)) [inline]
  • vtkCell::GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPolyVertex &) (defined in vtkPolyVertex) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Vertex [protected]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkPolyVertex() [protected]
  • vtkPolyVertex(const vtkPolyVertex &) (defined in vtkPolyVertex) [private]
  • vtkTypeRevisionMacro(vtkPolyVertex, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyVertex() [protected]
Generated on Mon Mar 25 01:28:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPOPReader Member List

This is the complete list of members for vtkPOPReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddArray(char *arrayName, char *fileName, unsigned long offset) [protected]
  • AddArrayName(char *arrayName, char *fileName, unsigned long offset) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ArrayFileDimensionality [protected]
  • ArrayFileNames [protected]
  • ArrayNames [protected]
  • ArrayOffsets [protected]
  • BreakOnError() [static]
  • ClipExtent [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteArrays() [protected]
  • DepthValues [protected]
  • Dimensions [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FileName [protected]
  • GeneratePoints() [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipExtent() [virtual]
  • GetClipExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetClipExtent(int[6]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDimensions() [virtual]
  • GetDimensions(int &, int &) [virtual]
  • GetDimensions(int[2]) [virtual]
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGridFileName() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfGhostLevels() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUFlowFileName() [virtual]
  • GetVFlowFileName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GridFileName [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsFileName(char *name) [protected]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeFileName(char *name) [protected]
  • MaximumNumberOfArrays [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfArrays [protected]
  • NumberOfGhostLevels [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPOPReader &) [inline, protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReadFlow() [protected]
  • ReadInformationFile() [protected]
  • ReadPoints(vtkImageData *image) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClipExtent(int, int, int, int, int, int) [virtual]
  • SetClipExtent(int[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGridFileName(const char *) [protected, virtual]
  • SetGridName(char *name) [protected]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfGhostLevels(int) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUFlowFileName(const char *) [protected, virtual]
  • SetVFlowFileName(const char *) [protected, virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UFlowFileName [protected]
  • UFlowFileOffset [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VFlowFileName [protected]
  • VFlowFileOffset [protected]
  • vtkObject() [protected]
  • vtkPOPReader() [protected]
  • vtkPOPReader(const vtkPOPReader &) [inline, protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkTypeRevisionMacro(vtkPOPReader, vtkStructuredGridSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPOPReader() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:28:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPostScriptWriter Member List

This is the complete list of members for vtkPostScriptWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPostScriptWriter &) (defined in vtkPostScriptWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkPostScriptWriter() [inline, protected]
  • vtkPostScriptWriter(const vtkPostScriptWriter &) (defined in vtkPostScriptWriter) [private]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkPostScriptWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int extent[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [protected, virtual]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPostScriptWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:28:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPPolyDataNormals Member List

This is the complete list of members for vtkPPolyDataNormals, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCellNormals [protected]
  • ComputeCellNormalsOff() [virtual]
  • ComputeCellNormalsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputePointNormals [protected]
  • ComputePointNormalsOff() [virtual]
  • ComputePointNormalsOn() [virtual]
  • Consistency [protected]
  • ConsistencyOff() [virtual]
  • ConsistencyOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FlipNormals [protected]
  • FlipNormalsOff() [virtual]
  • FlipNormalsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeCellNormals() [virtual]
  • GetComputePointNormals() [virtual]
  • GetConsistency() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFeatureAngle() [virtual]
  • GetFlipNormals() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaxRecursionDepth() [inline]
  • GetMTime() [virtual]
  • GetNonManifoldTraversal() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPieceInvariant() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSplitting() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NonManifoldTraversal [protected]
  • NonManifoldTraversalOff() [virtual]
  • NonManifoldTraversalOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumFlips [protected]
  • operator=(const vtkPPolyDataNormals &) (defined in vtkPPolyDataNormals) [private]
  • Outputs [protected]
  • PieceInvariant [protected]
  • PieceInvariantOff() [virtual]
  • PieceInvariantOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetComputeCellNormals(int) [virtual]
  • SetComputePointNormals(int) [virtual]
  • SetConsistency(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeatureAngle(float) [virtual]
  • SetFlipNormals(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaxRecursionDepth(int) [inline]
  • SetNonManifoldTraversal(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPieceInvariant(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSplitting(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Splitting [protected]
  • SplittingOff() [virtual]
  • SplittingOn() [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataNormals() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkPPolyDataNormals() [protected]
  • vtkPPolyDataNormals(const vtkPPolyDataNormals &) (defined in vtkPPolyDataNormals) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPPolyDataNormals, vtkPolyDataNormals)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataNormals() [inline, protected]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkPPolyDataNormals() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPriorityQueue Member List

This is the complete list of members for vtkPriorityQueue, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000)
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteId(vtkIdType id) [inline]
  • Extend [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfItems() [inline]
  • GetPriority(vtkIdType id) [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Insert(float priority, vtkIdType id)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • ItemLocation [protected]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPriorityQueue &) (defined in vtkPriorityQueue) [private]
  • Peek(vtkIdType location, float &priority) [inline]
  • Peek(vtkIdType location=0) [inline]
  • Pop(vtkIdType location, float &priority)
  • Pop(vtkIdType location=0)
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset()
  • Resize(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Size [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkPriorityQueue() [protected]
  • vtkPriorityQueue(const vtkPriorityQueue &) (defined in vtkPriorityQueue) [private]
  • vtkTypeRevisionMacro(vtkPriorityQueue, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkPriorityQueue() [protected]
Generated on Mon Mar 25 01:28:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProbeFilter Member List

This is the complete list of members for vtkProbeFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSource()
  • GetSpatialMatch() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GetValidPoints() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProbeFilter &) (defined in vtkProbeFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSource(vtkDataSet *source)
  • SetSpatialMatch(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpatialMatch [protected]
  • SpatialMatchOff() [virtual]
  • SpatialMatchOn() [virtual]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • ValidPoints [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProbeFilter() [protected]
  • vtkProbeFilter(const vtkProbeFilter &) (defined in vtkProbeFilter) [private]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProbeFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProbeFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProcessObject Member List

This is the complete list of members for vtkProcessObject, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProcessObject &) (defined in vtkProcessObject) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProcessObject(const vtkProcessObject &) (defined in vtkProcessObject) [private]
  • vtkTypeRevisionMacro(vtkProcessObject, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
Generated on Mon Mar 25 01:28:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProcessStatistics Member List

This is the complete list of members for vtkProcessStatistics, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetProcessCPUTimeInMilliseconds()
  • GetProcessSizeInBytes()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkProcessStatistics &) (defined in vtkProcessStatistics) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkProcessStatistics() [protected]
  • vtkProcessStatistics(const vtkProcessStatistics &) (defined in vtkProcessStatistics) [private]
  • vtkTypeRevisionMacro(vtkProcessStatistics, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessStatistics() [inline, protected]
Generated on Mon Mar 25 01:28:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProcrustesAlignmentFilter Member List

This is the complete list of members for vtkProcrustesAlignmentFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput(int idx)
  • GetInputs() [inline]
  • GetLandmarkTransform() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int idx)
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LandmarkTransform [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProcrustesAlignmentFilter &) (defined in vtkProcrustesAlignmentFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(int idx, vtkPointSet *p)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int n)
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProcrustesAlignmentFilter() [protected]
  • vtkProcrustesAlignmentFilter(const vtkProcrustesAlignmentFilter &) (defined in vtkProcrustesAlignmentFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProcrustesAlignmentFilter, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProcrustesAlignmentFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProgrammableAttributeDataFilter Member List

This is the complete list of members for vtkProgrammableAttributeDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataSet *in)
  • AddInput(vtkDataObject *) (defined in vtkProgrammableAttributeDataFilter) [inline, private, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteMethod [protected]
  • ExecuteMethodArg [protected]
  • ExecuteMethodArgDelete [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputList() [inline]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InputList [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProgrammableAttributeDataFilter &) (defined in vtkProgrammableAttributeDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataSet *in)
  • RemoveInput(vtkDataObject *input) (defined in vtkProgrammableAttributeDataFilter) [inline, private, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExecuteMethod(void(*f)(void *), void *arg)
  • SetExecuteMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProgrammableAttributeDataFilter() [protected]
  • vtkProgrammableAttributeDataFilter(const vtkProgrammableAttributeDataFilter &) (defined in vtkProgrammableAttributeDataFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProgrammableAttributeDataFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProgrammableAttributeDataFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProgrammableDataObjectSource Member List

This is the complete list of members for vtkProgrammableDataObjectSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteMethod [protected]
  • ExecuteMethodArg [protected]
  • ExecuteMethodArgDelete [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProgrammableDataObjectSource &) (defined in vtkProgrammableDataObjectSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExecuteMethod(void(*f)(void *), void *arg)
  • SetExecuteMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProgrammableDataObjectSource() [protected]
  • vtkProgrammableDataObjectSource(const vtkProgrammableDataObjectSource &) (defined in vtkProgrammableDataObjectSource) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProgrammableDataObjectSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProgrammableDataObjectSource() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProgrammableFilter Member List

This is the complete list of members for vtkProgrammableFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteMethod [protected]
  • ExecuteMethodArg [protected]
  • ExecuteMethodArgDelete [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataInput()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridInput()
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridInput()
  • GetStructuredGridOutput()
  • GetStructuredPointsInput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridInput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProgrammableFilter &) (defined in vtkProgrammableFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExecuteMethod(void(*f)(void *), void *arg)
  • SetExecuteMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProgrammableFilter() [protected]
  • vtkProgrammableFilter(const vtkProgrammableFilter &) (defined in vtkProgrammableFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProgrammableFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProgrammableFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProgrammableGlyphFilter Member List

This is the complete list of members for vtkProgrammableGlyphFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMode [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint() [virtual]
  • GetPoint(float &, float &, float &) [virtual]
  • GetPoint(float[3]) [virtual]
  • GetPointData() [virtual]
  • GetPointId() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSource()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GlyphMethod [protected]
  • GlyphMethodArg [protected]
  • GlyphMethodArgDelete [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProgrammableGlyphFilter &) (defined in vtkProgrammableGlyphFilter) [private]
  • Outputs [protected]
  • Point [protected]
  • PointData [protected]
  • PointId [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetColorMode(int) [virtual]
  • SetColorModeToColorByInput() [inline]
  • SetColorModeToColorBySource() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGlyphMethod(void(*f)(void *), void *arg)
  • SetGlyphMethodArgDelete(void(*f)(void *))
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSource(vtkPolyData *source)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkProgrammableGlyphFilter() [protected]
  • vtkProgrammableGlyphFilter(const vtkProgrammableGlyphFilter &) (defined in vtkProgrammableGlyphFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProgrammableGlyphFilter, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkProgrammableGlyphFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProgrammableSource Member List

This is the complete list of members for vtkProgrammableSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • ExecuteMethod [protected]
  • ExecuteMethodArg [protected]
  • ExecuteMethodArgDelete [protected]
  • ExecuteTime [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int idx) [protected]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProgrammableSource &) (defined in vtkProgrammableSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExecuteMethod(void(*f)(void *), void *arg)
  • SetExecuteMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProgrammableSource() [protected]
  • vtkProgrammableSource(const vtkProgrammableSource &) (defined in vtkProgrammableSource) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProgrammableSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProgrammableSource() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProjectedTexture Member List

This is the complete list of members for vtkProjectedTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AspectRatio [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormal() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FocalPoint [protected]
  • GetAbortExecute() [virtual]
  • GetAspectRatio() [virtual]
  • GetAspectRatio(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrientation() [virtual]
  • GetOrientation(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSRange() [virtual]
  • GetSRange(float data[2]) [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTRange() [virtual]
  • GetTRange(float data[2]) [virtual]
  • GetUnstructuredGridOutput()
  • GetUp() [virtual]
  • GetUp(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkProjectedTexture &) (defined in vtkProjectedTexture) [private]
  • Orientation [protected]
  • Outputs [protected]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAspectRatio(float, float, float) [virtual]
  • SetAspectRatio(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFocalPoint(float focalPoint[3])
  • SetFocalPoint(float x, float y, float z)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSRange(float, float) [virtual]
  • SetSRange(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTRange(float, float) [virtual]
  • SetTRange(float[2])
  • SetUp(float, float, float) [virtual]
  • SetUp(float[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • SRange [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TRange [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Up [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkProjectedTexture() [protected]
  • vtkProjectedTexture(const vtkProjectedTexture &) (defined in vtkProjectedTexture) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkProjectedTexture, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkProjectedTexture() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProp3D Member List

This is the complete list of members for vtkProp3D, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()=0 [pure virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIsIdentity() [virtual]
  • GetLength()
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkProp3D &) (defined in vtkProp3D) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *) [inline, virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkProp3D(const vtkProp3D &) (defined in vtkProp3D) [private]
  • vtkTypeRevisionMacro(vtkProp3D, vtkProp)
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
Generated on Mon Mar 25 01:28:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProp3DCollection Member List

This is the complete list of members for vtkProp3DCollection, including all inherited members.
  • AddItem(vtkProp3D *p) [inline]
  • AddItem(vtkObject *o) (defined in vtkProp3DCollection) [inline, private]
  • AddItem(vtkProp *o) (defined in vtkProp3DCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastProp() [inline]
  • GetLastProp3D() [inline]
  • GetMTime() [virtual]
  • GetNextItemAsObject() [inline]
  • GetNextProp() [inline]
  • GetNextProp3D() [inline]
  • GetNumberOfItems()
  • GetNumberOfPaths()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkProp3DCollection &) (defined in vtkProp3DCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkProp3DCollection() [inline, protected]
  • vtkProp3DCollection(const vtkProp3DCollection &) (defined in vtkProp3DCollection) [private]
  • vtkPropCollection() [inline, protected]
  • vtkTypeRevisionMacro(vtkProp3DCollection, vtkPropCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp3DCollection() [inline, protected]
  • ~vtkPropCollection() [inline, protected]
Generated on Mon Mar 25 01:28:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProp Member List

This is the complete list of members for vtkProp, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkProp &) (defined in vtkProp) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *) [inline, virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp(const vtkProp &) (defined in vtkProp) [private]
  • vtkTypeRevisionMacro(vtkProp, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
Generated on Mon Mar 25 01:28:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPropAssembly Member List

This is the complete list of members for vtkPropAssembly, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPart(vtkProp *)
  • AllocatedRenderTime [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [virtual]
  • GetParts()
  • GetPickable() [virtual]
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkPropAssembly &) (defined in vtkPropAssembly) [private]
  • Parts [protected]
  • Paths [protected]
  • PathTime [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePart(vtkProp *)
  • RenderOpaqueGeometry(vtkViewport *ren) [virtual]
  • RenderOverlay(vtkViewport *) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *ren) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *Prop) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePaths() [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkPropAssembly() [protected]
  • vtkPropAssembly(const vtkPropAssembly &) (defined in vtkPropAssembly) [private]
  • vtkTypeRevisionMacro(vtkPropAssembly, vtkProp)
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkPropAssembly() [protected]
Generated on Mon Mar 25 01:28:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPropCollection Member List

This is the complete list of members for vtkPropCollection, including all inherited members.
  • AddItem(vtkProp *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkPropCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastProp() [inline]
  • GetMTime() [virtual]
  • GetNextItemAsObject() [inline]
  • GetNextProp() [inline]
  • GetNumberOfItems()
  • GetNumberOfPaths()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkPropCollection &) (defined in vtkPropCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPropCollection() [inline, protected]
  • vtkPropCollection(const vtkPropCollection &) (defined in vtkPropCollection) [private]
  • vtkTypeRevisionMacro(vtkPropCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPropCollection() [inline, protected]
Generated on Mon Mar 25 01:28:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProperty2D Member List

This is the complete list of members for vtkProperty2D, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkProperty2D *p)
  • Delete() [virtual]
  • DisplayLocation [protected]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplayLocation() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLineStipplePattern() [virtual]
  • GetLineStippleRepeatFactor() [virtual]
  • GetLineWidth() [virtual]
  • GetMTime() [virtual]
  • GetOpacity() [virtual]
  • GetPointSize() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineStipplePattern [protected]
  • LineStippleRepeatFactor [protected]
  • LineWidth [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Opacity [protected]
  • operator=(const vtkProperty2D &) (defined in vtkProperty2D) [private]
  • PointSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkViewport *vtkNotUsed(viewport)) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayLocation(int) [virtual]
  • SetDisplayLocationToBackground() [inline]
  • SetDisplayLocationToForeground() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLineStipplePattern(int) [virtual]
  • SetLineStippleRepeatFactor(int) [virtual]
  • SetLineWidth(float) [virtual]
  • SetOpacity(float) [virtual]
  • SetPointSize(float) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkProperty2D() [protected]
  • vtkProperty2D(const vtkProperty2D &) (defined in vtkProperty2D) [private]
  • vtkTypeRevisionMacro(vtkProperty2D, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProperty2D() [protected]
Generated on Mon Mar 25 01:28:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProperty Member List

This is the complete list of members for vtkProperty, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Ambient [protected]
  • AmbientColor [protected]
  • BackfaceCulling [protected]
  • BackfaceCullingOff() [virtual]
  • BackfaceCullingOn() [virtual]
  • BackfaceRender(vtkActor *, vtkRenderer *) [inline, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkProperty *p)
  • Delete() [virtual]
  • Diffuse [protected]
  • DiffuseColor [protected]
  • EdgeColor [protected]
  • EdgeVisibility [protected]
  • EdgeVisibilityOff() [virtual]
  • EdgeVisibilityOn() [virtual]
  • FrontfaceCulling [protected]
  • FrontfaceCullingOff() [virtual]
  • FrontfaceCullingOn() [virtual]
  • GetAmbient() [virtual]
  • GetAmbientColor() [virtual]
  • GetAmbientColor(float data[3]) [virtual]
  • GetBackfaceCulling() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor()
  • GetColor(float rgb[3])
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiffuse() [virtual]
  • GetDiffuseColor() [virtual]
  • GetDiffuseColor(float data[3]) [virtual]
  • GetEdgeColor() [virtual]
  • GetEdgeColor(float data[3]) [virtual]
  • GetEdgeVisibility() [virtual]
  • GetFrontfaceCulling() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInterpolation() [virtual]
  • GetInterpolationAsString() [inline]
  • GetLineStipplePattern() [virtual]
  • GetLineStippleRepeatFactor() [virtual]
  • GetLineWidth() [virtual]
  • GetMTime() [virtual]
  • GetOpacity() [virtual]
  • GetPointSize() [virtual]
  • GetReferenceCount() [inline]
  • GetRepresentation() [virtual]
  • GetRepresentationAsString() [inline]
  • GetSpecular() [virtual]
  • GetSpecularColor() [virtual]
  • GetSpecularColor(float data[3]) [virtual]
  • GetSpecularPower() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interpolation [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineStipplePattern [protected]
  • LineStippleRepeatFactor [protected]
  • LineWidth [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Opacity [protected]
  • operator=(const vtkProperty &) (defined in vtkProperty) [private]
  • PointSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkActor *, vtkRenderer *) [inline, virtual]
  • Representation [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAmbient(float) [virtual]
  • SetAmbientColor(float, float, float) [virtual]
  • SetAmbientColor(float[3]) [virtual]
  • SetBackfaceCulling(int) [virtual]
  • SetColor(float r, float g, float b)
  • SetColor(float a[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDiffuse(float) [virtual]
  • SetDiffuseColor(float, float, float) [virtual]
  • SetDiffuseColor(float[3]) [virtual]
  • SetEdgeColor(float, float, float) [virtual]
  • SetEdgeColor(float[3]) [virtual]
  • SetEdgeVisibility(int) [virtual]
  • SetFrontfaceCulling(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInterpolation(int) [virtual]
  • SetInterpolationToFlat() [inline]
  • SetInterpolationToGouraud() [inline]
  • SetInterpolationToPhong() [inline]
  • SetLineStipplePattern(int) [virtual]
  • SetLineStippleRepeatFactor(int) [virtual]
  • SetLineWidth(float) [virtual]
  • SetOpacity(float) [virtual]
  • SetPointSize(float) [virtual]
  • SetReferenceCount(int)
  • SetRepresentation(int) [virtual]
  • SetRepresentationToPoints() [inline]
  • SetRepresentationToSurface() [inline]
  • SetRepresentationToWireframe() [inline]
  • SetSpecular(float) [virtual]
  • SetSpecularColor(float, float, float) [virtual]
  • SetSpecularColor(float[3]) [virtual]
  • SetSpecularPower(float) [virtual]
  • Specular [protected]
  • SpecularColor [protected]
  • SpecularPower [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkProperty() [protected]
  • vtkProperty(const vtkProperty &) (defined in vtkProperty) [private]
  • vtkTypeRevisionMacro(vtkProperty, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProperty() [inline, protected]
Generated on Mon Mar 25 01:28:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPropPicker Member List

This is the complete list of members for vtkPropPicker, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetActor() [virtual]
  • GetActor2D() [virtual]
  • GetAssembly() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPath() [virtual]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetProp() [virtual]
  • GetProp3D() [virtual]
  • GetPropAssembly() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GetVolume() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPropPicker &) (defined in vtkPropPicker) [private]
  • Path [protected]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer) [virtual]
  • Pick(float selectionPt[3], vtkRenderer *renderer) [inline]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickFromProps [protected]
  • PickList [protected]
  • PickPosition [protected]
  • PickProp(float selectionX, float selectionY, vtkRenderer *renderer)
  • PickProp(float selectionX, float selectionY, vtkRenderer *renderer, vtkPropCollection *pickfrom)
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPath(vtkAssemblyPath *) [virtual]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkAbstractPropPicker() [protected]
  • vtkObject() [protected]
  • vtkPropPicker() [protected]
  • vtkPropPicker(const vtkPropPicker &) (defined in vtkPropPicker) [private]
  • vtkTypeRevisionMacro(vtkPropPicker, vtkAbstractPropPicker)
  • WorldPointPicker [protected]
  • ~vtkAbstractPicker() [protected]
  • ~vtkAbstractPropPicker() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPropPicker() [protected]
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProTriArray Member List

This is the complete list of members for vtkProTriArray, including all inherited members.
  • Array
  • GetNumberOfTriangles() [inline]
  • GetTriangle(vtkIdType i) [inline]
  • InsertNextTriangle(vtkProLocalTri &t) [inline]
  • MaxId
  • Reset() [inline]
  • vtkProTriArray(const vtkIdType sz) [inline]
  • ~vtkProTriArray() [inline]
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkProVertexArray Member List

This is the complete list of members for vtkProVertexArray, including all inherited members.
  • Array
  • GetNumberOfVertices() [inline]
  • GetVertex(vtkIdType i) [inline]
  • InsertNextVertex(vtkProLocalVertex &v) [inline]
  • MaxId
  • Reset() [inline]
  • vtkProVertexArray(const vtkIdType sz) [inline]
  • ~vtkProVertexArray() [inline]
Generated on Mon Mar 25 01:28:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPSphereSource Member List

This is the complete list of members for vtkPSphereSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndPhi [protected]
  • EndTag [protected]
  • EndTheta [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEndPhi() [virtual]
  • GetEndTheta() [virtual]
  • GetErrorCode() [virtual]
  • GetEstimatedMemorySize()
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLatLongTessellation() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPhiResolution() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStartPhi() [virtual]
  • GetStartTheta() [virtual]
  • GetThetaResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LatLongTessellation [protected]
  • LatLongTessellationOff() [virtual]
  • LatLongTessellationOn() [virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPSphereSource &) (defined in vtkPSphereSource) [private]
  • Outputs [protected]
  • PhiResolution [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetEndPhi(float) [virtual]
  • SetEndTheta(float) [virtual]
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLatLongTessellation(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPhiResolution(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPhi(float) [virtual]
  • SetStartTheta(float) [virtual]
  • SetThetaResolution(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartPhi [protected]
  • StartTag [protected]
  • StartTheta [protected]
  • SubjectHelper [protected]
  • ThetaResolution [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkPSphereSource() [inline, protected]
  • vtkPSphereSource(const vtkPSphereSource &) (defined in vtkPSphereSource) [private]
  • vtkSource() [protected]
  • vtkSphereSource(int res=8) [protected]
  • vtkTypeRevisionMacro(vtkPSphereSource, vtkSphereSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkPSphereSource() [inline, protected]
  • ~vtkSource() [protected]
  • ~vtkSphereSource() [inline, protected]
Generated on Mon Mar 25 01:28:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPVGeometryFilter Member List

This is the complete list of members for vtkPVGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • DataSetExecute() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteQuadHash() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteFaceQuads(vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis) [protected]
  • ExecuteFaceStrips(vtkDataSet *input, int maxFlag, int *ext, int aAxis, int bAxis, int cAxis) [protected]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNextVisibleQuadFromHash() [protected]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutlineFlag() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputPointId(vtkIdType inPtId, vtkDataSet *input, vtkPoints *outPts, vtkPointData *outPD) [protected]
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseStrips() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageDataExecute(vtkImageData *input) [protected]
  • InformationTime [protected]
  • InitializeQuadHash(vtkIdType numPoints) [protected]
  • InitQuadHashTraversal() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsertQuadInHash(vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType d, vtkIdType sourceId) [protected]
  • InsertTriInHash(vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType sourceId) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfNewCells [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkPVGeometryFilter &) [inline, protected]
  • OutlineFlag [protected]
  • Outputs [protected]
  • PointMap [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QuadHash [protected]
  • QuadHashLength [protected]
  • QuadHashTraversal [protected]
  • QuadHashTraversalIndex [protected]
  • RectilinearGridExecute(vtkRectilinearGrid *input) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseStrips(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StructuredExecute(vtkDataSet *input, int *ext) [protected]
  • StructuredGridExecute(vtkStructuredGrid *input) [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnstructuredGridExecute(vtkUnstructuredGrid *input) [protected]
  • vtkDataSetSurfaceFilter::UnstructuredGridExecute()
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseStrips [protected]
  • UseStripsOff() [virtual]
  • UseStripsOn() [virtual]
  • vtkDataSetSurfaceFilter() [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkPVGeometryFilter() [protected]
  • vtkPVGeometryFilter(const vtkPVGeometryFilter &) [inline, protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkPVGeometryFilter, vtkDataSetSurfaceFilter)
  • ~vtkDataSetSurfaceFilter() [protected]
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkPVGeometryFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:28:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPyramid Member List

This is the complete list of members for vtkPyramid, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetEdgeArray(int edgeId) [static]
  • GetEdgePoints(int edgeId, int *&pts) [virtual]
  • GetFace(int faceId) [virtual]
  • GetFaceArray(int faceId) [static]
  • GetFacePoints(int faceId, int *&pts) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [inline, virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[15]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[5]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • JacobianInverse(float pcoords[3], double **inverse, float derivs[15])
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkPyramid &) (defined in vtkPyramid) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangle [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkObject() [protected]
  • vtkPyramid() [protected]
  • vtkPyramid(const vtkPyramid &) (defined in vtkPyramid) [private]
  • vtkTypeRevisionMacro(vtkPyramid, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPyramid() [protected]
Generated on Mon Mar 25 01:28:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkPythonCommand Member List

This is the complete list of members for vtkPythonCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • CharEvent enum value
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *ptr, unsigned long eventtype, void *) [virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • New() [inline, static]
  • NextDataEvent enum value
  • NoEvent enum value
  • obj
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetObject(PyObject *o)
  • SetOutputEvent enum value
  • StartEvent enum value
  • StartPickEvent enum value
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • UserEvent enum value
  • vtkCommand() [inline, protected]
  • vtkPythonCommand() [protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCommand() [inline, protected, virtual]
  • ~vtkPythonCommand() [protected]
Generated on Mon Mar 25 01:28:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuad Member List

This is the complete list of members for vtkQuad, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[8]) [static]
  • InterpolationFunctions(float pcoords[3], float sf[4]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkQuad &) (defined in vtkQuad) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkQuad() [protected]
  • vtkQuad(const vtkQuad &) (defined in vtkQuad) [private]
  • vtkTypeRevisionMacro(vtkQuad, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuad() [protected]
Generated on Mon Mar 25 01:28:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuadraticEdge Member List

This is the complete list of members for vtkQuadraticEdge, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *lines, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • Error [protected]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int) [inline, virtual]
  • GetError() [virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InsertPoint(vtkPointLocator *locator, vtkPoints *pts, float *x) [inline, protected]
  • InternalDataSet [protected]
  • InternalTesselate() [protected]
  • InterpolationDerivs(float pcoords[3], float derivs[3]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[3]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkQuadraticEdge &) (defined in vtkQuadraticEdge) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetError(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Tesselate(vtkIdType cellId, vtkDataSet *input, vtkPolyData *output, vtkPointLocator *locator=NULL) [virtual]
  • Tesselate(vtkIdType vtkNotUsed(cellId), vtkDataSet *vtkNotUsed(input), vtkUnstructuredGrid *vtkNotUsed(output), vtkPointLocator *locator=NULL) [virtual]
  • vtkNonLinearCell::Tesselate(vtkIdType cellId, vtkDataSet *input, vtkUnstructuredGrid *output, vtkPointLocator *locator=NULL) [virtual]
  • Tesselation [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkNonLinearCell() [protected]
  • vtkObject() [protected]
  • vtkQuadraticEdge() [protected]
  • vtkQuadraticEdge(const vtkQuadraticEdge &) (defined in vtkQuadraticEdge) [private]
  • vtkTypeRevisionMacro(vtkQuadraticEdge, vtkNonLinearCell)
  • ~vtkCell() [protected]
  • ~vtkNonLinearCell() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuadraticEdge() [protected]
Generated on Mon Mar 25 01:28:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuadric Member List

This is the complete list of members for vtkQuadric, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • Coefficients [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetClassName() [inline, virtual]
  • GetCoefficients() [virtual]
  • GetCoefficients(float data[10]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkQuadric &) (defined in vtkQuadric) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetCoefficients(float a[10])
  • SetCoefficients(float a0, float a1, float a2, float a3, float a4, float a5, float a6, float a7, float a8, float a9)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkQuadric() [protected]
  • vtkQuadric(const vtkQuadric &) (defined in vtkQuadric) [private]
  • vtkTypeRevisionMacro(vtkQuadric, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuadric() [inline, protected]
Generated on Mon Mar 25 01:28:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuadricClustering Member List

This is the complete list of members for vtkQuadricClustering, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddEdge(vtkIdType *binIds, float *pt0, float *pt1, int geometeryFlag) [protected]
  • AddEdges(vtkCellArray *edges, vtkPoints *points, int geometryFlag) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddPolygons(vtkCellArray *polys, vtkPoints *points, int geometryFlag) [protected]
  • AddQuadric(vtkIdType binId, float quadric[9]) [protected]
  • AddTriangle(vtkIdType *binIds, float *pt0, float *pt1, float *pt2, int geometeryFlag) [protected]
  • AddTriangles(vtkCellArray *tris, vtkPoints *points, int geometryFlag) [protected]
  • AddVertex(vtkIdType binId, float *pt, int geometryFlag) [protected]
  • AddVertices(vtkCellArray *verts, vtkPoints *points, int geometryFlag) [protected]
  • Append(vtkPolyData *piece)
  • AppendFeatureQuadrics(vtkPolyData *pd) [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNumberOfDivisions [protected]
  • ComputeRepresentativePoint(float quadric[9], vtkIdType binId, float point[3]) [protected]
  • CopyCellData [protected]
  • CopyCellDataOff() [virtual]
  • CopyCellDataOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DivisionOrigin [protected]
  • DivisionSpacing [protected]
  • EndAppend()
  • EndAppendUsingPoints(vtkPolyData *input) [protected]
  • EndAppendVertexGeometry(vtkPolyData *input) [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureEdges [protected]
  • FeaturePoints [protected]
  • FeaturePointsAngle [protected]
  • FindFeaturePoints(vtkCellArray *edges, vtkPoints *edgePts, float angle) [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCopyCellData() [virtual]
  • GetDebug()
  • GetDivisionOrigin() [virtual]
  • GetDivisionOrigin(float &, float &, float &) [virtual]
  • GetDivisionOrigin(float[3]) [virtual]
  • GetDivisionSpacing() [virtual]
  • GetDivisionSpacing(float &, float &, float &) [virtual]
  • GetDivisionSpacing(float[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetFeatureEdges() [inline]
  • GetFeaturePointsAngle() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfDivisions()
  • GetNumberOfDivisions(int div[3])
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfXDivisions() [virtual]
  • GetNumberOfYDivisions() [virtual]
  • GetNumberOfZDivisions() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseFeatureEdges() [virtual]
  • GetUseFeaturePoints() [virtual]
  • GetUseInputPoints() [virtual]
  • GetUseInternalTriangles() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HashPoint(float point[3]) [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InCellCount [protected]
  • InformationTime [protected]
  • InitializeQuadric(float quadric[9]) [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfBinsUsed [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfXDivisions [protected]
  • NumberOfYDivisions [protected]
  • NumberOfZDivisions [protected]
  • operator=(const vtkQuadricClustering &) (defined in vtkQuadricClustering) [private]
  • OutCellCount [protected]
  • OutputLines [protected]
  • Outputs [protected]
  • OutputTriangleArray [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QuadricArray [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCopyCellData(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDivisionOrigin(float x, float y, float z)
  • SetDivisionOrigin(float o[3]) [inline]
  • SetDivisionSpacing(float x, float y, float z)
  • SetDivisionSpacing(float s[3]) [inline]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeaturePointsAngle(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfDivisions(int div[3])
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfXDivisions(int num)
  • SetNumberOfYDivisions(int num)
  • SetNumberOfZDivisions(int num)
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseFeatureEdges(int) [virtual]
  • SetUseFeaturePoints(int) [virtual]
  • SetUseInputPoints(int) [virtual]
  • SetUseInternalTriangles(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartAppend(float *bounds)
  • StartAppend(float x0, float x1, float y0, float y1, float z0, float z1) [inline]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseFeatureEdges [protected]
  • UseFeatureEdgesOff() [virtual]
  • UseFeatureEdgesOn() [virtual]
  • UseFeaturePoints [protected]
  • UseFeaturePointsOff() [virtual]
  • UseFeaturePointsOn() [virtual]
  • UseInputPoints [protected]
  • UseInputPointsOff() [virtual]
  • UseInputPointsOn() [virtual]
  • UseInternalTriangles [protected]
  • UseInternalTrianglesOff() [virtual]
  • UseInternalTrianglesOn() [virtual]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkQuadricClustering() [protected]
  • vtkQuadricClustering(const vtkQuadricClustering &) (defined in vtkQuadricClustering) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkQuadricClustering, vtkPolyDataToPolyDataFilter)
  • XBinSize [protected]
  • YBinSize [protected]
  • ZBinSize [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkQuadricClustering() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuadricDecimation Member List

This is the complete list of members for vtkQuadricDecimation, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddQuadric(vtkIdType oldPtId, vtkIdType newPtId) [protected]
  • AttributeComponents [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCost(vtkIdType edgeId, float x[3], vtkPointData *pd) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeQuadric(vtkIdType pointId) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EdgeCosts [protected]
  • Edges [protected]
  • EndPoint1List [protected]
  • EndPoint2List [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • ErrorQuadrics [protected]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FindAffectedEdges(vtkIdType p1Id, vtkIdType p2Id, vtkIdList *edges) [protected]
  • GetAbortExecute() [virtual]
  • GetAttributeComponents() [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdgeCellId(vtkIdType p1Id, vtkIdType p2Id) [protected]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumCollapsedEdges() [virtual]
  • GetMaximumCost() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTestOutput() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumCollapsedEdges [protected]
  • MaximumCost [protected]
  • Mesh [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfCollapsedEdges [protected]
  • NumberOfComponents [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkQuadricDecimation &) (defined in vtkQuadricDecimation) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaximumCollapsedEdges(int) [virtual]
  • SetMaximumCost(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkQuadricDecimation() [protected]
  • vtkQuadricDecimation(const vtkQuadricDecimation &) (defined in vtkQuadricDecimation) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkQuadricDecimation, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkQuadricDecimation() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuantizePolyDataPoints Member List

This is the complete list of members for vtkQuantizePolyDataPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AbsoluteTolerance [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ConvertLinesToPoints [protected]
  • ConvertLinesToPointsOff() [virtual]
  • ConvertLinesToPointsOn() [virtual]
  • ConvertPolysToLines [protected]
  • ConvertPolysToLinesOff() [virtual]
  • ConvertPolysToLinesOn() [virtual]
  • ConvertStripsToPolys [protected]
  • ConvertStripsToPolysOff() [virtual]
  • ConvertStripsToPolysOn() [virtual]
  • CreateDefaultLocator(void)
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAbsoluteTolerance() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConvertLinesToPoints() [virtual]
  • GetConvertPolysToLines() [virtual]
  • GetConvertStripsToPolys() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPieceInvariant() [virtual]
  • GetPointMerging() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetQFactor() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTolerance() [virtual]
  • GetToleranceIsAbsolute() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OperateOnBounds(float in[6], float out[6]) [virtual]
  • OperateOnPoint(float in[3], float out[3]) [virtual]
  • operator=(const vtkQuantizePolyDataPoints &) (defined in vtkQuantizePolyDataPoints) [private]
  • Outputs [protected]
  • PieceInvariant [protected]
  • PieceInvariantOff() [virtual]
  • PieceInvariantOn() [virtual]
  • PointMerging [protected]
  • PointMergingOff() [virtual]
  • PointMergingOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • QFactor [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • ReleaseLocator(void)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAbsoluteTolerance(float) [virtual]
  • SetConvertLinesToPoints(int) [virtual]
  • SetConvertPolysToLines(int) [virtual]
  • SetConvertStripsToPolys(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetLocator(vtkPointLocator *locator)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPieceInvariant(int) [virtual]
  • SetPointMerging(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQFactor(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • SetToleranceIsAbsolute(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • ToleranceIsAbsolute [protected]
  • ToleranceIsAbsoluteOff() [virtual]
  • ToleranceIsAbsoluteOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkCleanPolyData() [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkQuantizePolyDataPoints() [protected]
  • vtkQuantizePolyDataPoints(const vtkQuantizePolyDataPoints &) (defined in vtkQuantizePolyDataPoints) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkQuantizePolyDataPoints, vtkCleanPolyData)
  • ~vtkCleanPolyData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkQuantizePolyDataPoints() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzImageMapper Member List

This is the complete list of members for vtkQuartzImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CustomDisplayExtents [protected]
  • DataOut
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HBitmap
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkQuartzImageMapper &) (defined in vtkQuartzImageMapper) [inline, private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkQuartzImageMapper() [protected]
  • vtkQuartzImageMapper(const vtkQuartzImageMapper &) (defined in vtkQuartzImageMapper) [inline, private]
  • vtkTypeRevisionMacro(vtkQuartzImageMapper, vtkImageMapper)
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkQuartzImageMapper() [protected]
Generated on Mon Mar 25 01:29:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzImageWindow Member List

This is the complete list of members for vtkQuartzImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplicationInstance [protected]
  • BreakOnError() [static]
  • Clean()
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ContextId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeviceContext [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [virtual]
  • FileName [protected]
  • Frame() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMemoryData() [inline]
  • GetMemoryDC()
  • GetMTime() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetOutput() [inline]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPosition() [virtual]
  • vtkImageWindow::GetPosition(int *x, int *y) [virtual]
  • GetReferenceCount() [inline]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetSize() [virtual]
  • vtkImageWindow::GetSize(int *x, int *y) [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId() [virtual]
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeCurrent() [virtual]
  • MakeDefaultWindow() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • MemoryBuffer [protected]
  • MemoryData [protected]
  • MemoryDataHeader [protected]
  • MemoryHdc [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextWindowId [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldPalette [protected]
  • OpenGLInit() [virtual]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkQuartzImageWindow &) (defined in vtkQuartzImageWindow) [inline, private]
  • OwnWindow [protected]
  • Palette [protected]
  • ParentId [protected]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • ResumeScreenRendering()
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • ScreenContextId [protected]
  • ScreenDeviceContext [protected]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • ScreenSize [protected]
  • ScreenWindowSize [protected]
  • SetContextId(void *)
  • SetDebug(unsigned char debugFlag)
  • SetDeviceContext(void *)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetNextWindowId(void *) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPosition(int, int) [virtual]
  • vtkImageWindow::SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • vtkImageWindow::SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetupMemoryRendering(int x, int y, void *prn)
  • SetupPalette(void *hDC) [virtual]
  • SetupPixelFormat(void *hDC, int dwFlags, int debug, int bpp=16, int zbpp=16) [virtual]
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageWindow() [protected]
  • vtkObject() [protected]
  • vtkQuartzImageWindow() [protected]
  • vtkQuartzImageWindow(const vtkQuartzImageWindow &) (defined in vtkQuartzImageWindow) [inline, private]
  • vtkTypeRevisionMacro(vtkQuartzImageWindow, vtkImageWindow)
  • vtkWindow() [protected]
  • WindowCreated [protected]
  • WindowId [protected]
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuartzImageWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:29:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzRenderWindow Member List

This is the complete list of members for vtkQuartzRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • ApplicationInitialized [protected]
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • Clean()
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ContextId [protected]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • CursorHidden [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DeviceContext [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame(void) [virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int,int,int,int,int) [inline, virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetScreenSize() [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId() [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [virtual]
  • InAbortCheck [protected]
  • Initialize(void) [virtual]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkQuartzRenderWindow &) (defined in vtkQuartzRenderWindow) [private]
  • OwnWindow [protected]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • PrefFullScreen(void) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScreenContextId [protected]
  • ScreenDeviceContext [protected]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • ScreenSize [protected]
  • ScreenWindowSize [protected]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetContextId(void *)
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDeviceContext(void *)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *) [inline, virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • vtkRenderWindow::SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int,int,int,int,unsigned char *, int, int blend=0) [inline, virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • vtkRenderWindow::SetSize(int a[2]) [virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetupPalette(void *hDC) [virtual]
  • SetupPixelFormat(void *hDC, void *dwFlags, int debug, int bpp=16, int zbpp=16) [virtual]
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(void *)
  • vtkRenderWindow::SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [virtual]
  • Size [protected]
  • Start(void) [virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSizeAndPosition(int xPos, int yPos, int xSize, int ySize)
  • vtkObject() [protected]
  • vtkQuartzRenderWindow() [protected]
  • vtkQuartzRenderWindow(const vtkQuartzRenderWindow &) (defined in vtkQuartzRenderWindow) [private]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkQuartzRenderWindow, vtkRenderWindow)
  • vtkWindow() [protected]
  • WindowConfigure(void) [virtual]
  • WindowController [protected]
  • WindowId [protected]
  • WindowInitialize(void) [virtual]
  • WindowName [protected]
  • WindowRemap(void) [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuartzRenderWindow() [protected]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:29:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzRenderWindowInteractor Member List

This is the complete list of members for vtkQuartzRenderWindowInteractor, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplicationId [protected]
  • BreakOnError() [static]
  • ClassExitMethod [protected, static]
  • ClassExitMethodArg [protected, static]
  • ClassExitMethodArgDelete [protected, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ControlKey [protected]
  • CreateDefaultPicker() [virtual]
  • CreateTimer(int timertype) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DestroyTimer(void) [virtual]
  • Disable() [virtual]
  • Dolly [protected]
  • Enable() [virtual]
  • Enabled [protected]
  • EndPickCallback() [virtual]
  • EndPickTag [protected]
  • EventPosition [protected]
  • ExitCallback() [virtual]
  • ExitTag [protected]
  • FlyTo(vtkRenderer *ren, float x, float y, float z)
  • FlyTo(vtkRenderer *ren, float *x) [inline]
  • FlyToImage(vtkRenderer *ren, float x, float y)
  • FlyToImage(vtkRenderer *ren, float *x) [inline]
  • GetButtonDown()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetControlKey() [virtual]
  • GetDebug()
  • GetDesiredUpdateRate() [virtual]
  • GetDolly() [virtual]
  • GetEnabled() [virtual]
  • GetEventPosition() [virtual]
  • GetEventPosition(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [virtual]
  • GetInstallMessageProc() [virtual]
  • GetInteractorStyle() [virtual]
  • GetKeyCode() [virtual]
  • GetKeySym() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetMousePosition(int *x, int *y) [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfFlyFrames() [virtual]
  • GetPicker() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRepeatCount() [virtual]
  • GetShiftKey() [virtual]
  • GetSize() [virtual]
  • GetSize(int &, int &) [virtual]
  • GetSize(int[2]) [virtual]
  • GetStillUpdateRate() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline]
  • Initialize() [virtual]
  • Initialized [protected]
  • InstallMessageProc [protected]
  • InstallMessageProcOff() [virtual]
  • InstallMessageProcOn() [virtual]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyCode [protected]
  • KeySym [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfFlyFrames [protected]
  • OldProc [protected]
  • OnChar(void *wnd, int nChar, int nRepCnt, int nFlags) [virtual]
  • OnLButtonDown(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnLButtonUp(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnMButtonDown(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnMButtonUp(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnRButtonDown(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnRButtonUp(void *wnd, int nFlags, int X, int Y) [virtual]
  • OnSize(void *wnd, int nType, int X, int Y) [virtual]
  • OnTimer(void *wnd, int nIDEvent) [virtual]
  • operator=(const vtkQuartzRenderWindowInteractor &) (defined in vtkQuartzRenderWindowInteractor) [private]
  • Picker [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReInitialize() [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderWindow [protected]
  • RepeatCount [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetButtonDown(int button)
  • SetClassExitMethod(void(*f)(void *), void *arg) [static]
  • SetClassExitMethodArgDelete(void(*f)(void *)) [static]
  • SetControlKey(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float) [virtual]
  • SetDolly(float) [virtual]
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0) [inline]
  • SetEventPosition(int, int) [virtual]
  • SetEventPosition(int[2])
  • SetExitMethod(void(*f)(void *), void *arg)
  • SetExitMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstallMessageProc(int) [virtual]
  • SetInteractorStyle(vtkInteractorStyle *) [virtual]
  • SetKeyCode(int) [virtual]
  • SetKeySym(const char *) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetNumberOfFlyFrames(int) [virtual]
  • SetPicker(vtkAbstractPicker *) [virtual]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *aren)
  • SetRepeatCount(int) [virtual]
  • SetShiftKey(int) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetStillUpdateRate(float) [virtual]
  • SetUserMethod(void(*f)(void *), void *arg)
  • SetUserMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • ShowCursor() [inline]
  • Size [protected]
  • Start() [virtual]
  • StartPickCallback() [virtual]
  • StartPickTag [protected]
  • StillUpdateRate [protected]
  • Style [protected]
  • SubjectHelper [protected]
  • TerminateApp(void) [virtual]
  • TimerId [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSize(int x, int y) [virtual]
  • UserCallback() [virtual]
  • UserTag [protected]
  • vtkObject() [protected]
  • vtkQuartzRenderWindowInteractor() [protected]
  • vtkQuartzRenderWindowInteractor(const vtkQuartzRenderWindowInteractor &) (defined in vtkQuartzRenderWindowInteractor) [private]
  • vtkRenderWindowInteractor() [protected]
  • vtkTypeRevisionMacro(vtkQuartzRenderWindowInteractor, vtkRenderWindowInteractor)
  • whichButtonDown [protected]
  • WindowId [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkQuartzRenderWindowInteractor() [protected]
  • ~vtkRenderWindowInteractor() [protected]
Generated on Mon Mar 25 01:29:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzTextMapper Member List

This is the complete list of members for vtkQuartzTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • Font [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastSize [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkQuartzTextMapper &) (defined in vtkQuartzTextMapper) [inline, private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkQuartzTextMapper() [protected]
  • vtkQuartzTextMapper(const vtkQuartzTextMapper &) (defined in vtkQuartzTextMapper) [inline, private]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkQuartzTextMapper, vtkTextMapper)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkQuartzTextMapper() [protected]
  • ~vtkTextMapper() [protected]
Generated on Mon Mar 25 01:29:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRayCaster Member List

This is the complete list of members for vtkRayCaster, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AutomaticScaleAdjustmentOff(void) [inline]
  • AutomaticScaleAdjustmentOn(void) [inline]
  • BilinearImageZoomOff() [inline]
  • BilinearImageZoomOn() [inline]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetAutomaticScaleAdjustment() [inline]
  • GetAutomaticScaleLowerLimit() [inline]
  • GetBilinearImageZoom() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetImageScale(int vtkNotUsed(level)) [inline]
  • GetImageScaleCount(void) [inline]
  • GetMTime() [virtual]
  • GetNumberOfSamplesTaken() [inline]
  • GetNumberOfThreads() [inline]
  • GetParallelIncrements(void) [inline]
  • GetParallelStartPosition(void) [inline]
  • GetPerspectiveViewRays() [inline]
  • GetReferenceCount() [inline]
  • GetSelectedImageScaleIndex(int vtkNotUsed(level)) [inline]
  • GetTotalRenderTime() [inline]
  • GetViewRaysSize(int *vtkNotUsed(size)) [inline]
  • GetViewRaysStepSize(int vtkNotUsed(level)) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkRayCaster &) (defined in vtkRayCaster) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAutomaticScaleLowerLimit(float vtkNotUsed(scale)) [inline]
  • SetBilinearImageZoom(int vtkNotUsed(val)) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageScale(int vtkNotUsed(level), float vtkNotUsed(scale)) [inline]
  • SetNumberOfThreads(int vtkNotUsed(val)) [inline]
  • SetReferenceCount(int)
  • SetSelectedImageScaleIndex(int vtkNotUsed(level), float vtkNotUsed(scale)) [inline]
  • SetViewRaysStepSize(int vtkNotUsed(level), float vtkNotUsed(scale)) [inline]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkRayCaster() [inline, protected]
  • vtkRayCaster(const vtkRayCaster &) (defined in vtkRayCaster) [private]
  • vtkTypeRevisionMacro(vtkRayCaster, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkRayCaster() [inline, protected]
Generated on Mon Mar 25 01:29:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRearrangeFields Member List

This is the complete list of members for vtkRearrangeFields, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOperation(int operationType, int attributeType, int fromFieldLoc, int toFieldLoc)
  • AddOperation(int operationType, const char *name, int fromFieldLoc, int toFieldLoc)
  • AddOperation(const char *operationType, const char *attributeType, const char *fromFieldLoc, const char *toFieldLoc)
  • AddOperation(Operation *op) [protected]
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ApplyOperation(Operation *op, vtkDataSet *input, vtkDataSet *output) [protected]
  • ATTRIBUTE enum value
  • AttributeNames [protected, static]
  • BreakOnError() [static]
  • CELL_DATA enum value
  • CollectRevisions(ostream &os) [protected, virtual]
  • CompareOperationsByName(const Operation *op1, const Operation *op2) [protected]
  • CompareOperationsByType(const Operation *op1, const Operation *op2) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • COPY enum value
  • DATA_OBJECT enum value
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAllOperations() [protected]
  • DeleteOperation(Operation *op, Operation *before) [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldLocation enum name
  • FieldLocationNames [protected, static]
  • FieldType enum name
  • FindOperation(int id, Operation *&before) [protected]
  • FindOperation(const char *name, Operation *&before) [protected]
  • FindOperation(int operationType, const char *name, int fromFieldLoc, int toFieldLoc, Operation *&before) [protected]
  • FindOperation(int operationType, int attributeType, int fromFieldLoc, int toFieldLoc, Operation *&before) [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataFromLocation(vtkDataSet *ds, int fieldLoc) [protected]
  • GetFirst() [inline, protected]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNextOperation(Operation *op) [inline, protected]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Head [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastId [protected]
  • LegacyHack
  • Modified() [virtual]
  • MOVE enum value
  • MTime [protected]
  • NAME enum value
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • OperationType enum name
  • OperationTypeNames [protected, static]
  • operator=(const vtkRearrangeFields &) (defined in vtkRearrangeFields) [private]
  • Outputs [protected]
  • POINT_DATA enum value
  • Print(ostream &os)
  • PrintAllOperations(ostream &os, vtkIndent indent) [inline, protected]
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintOperation(Operation *op, ostream &os, vtkIndent indent) [inline, protected]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveAllOperations() [inline]
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOperation(int operationId)
  • RemoveOperation(int operationType, int attributeType, int fromFieldLoc, int toFieldLoc)
  • RemoveOperation(int operationType, const char *name, int fromFieldLoc, int toFieldLoc)
  • RemoveOperation(const char *operationType, const char *attributeType, const char *fromFieldLoc, const char *toFieldLoc)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tail [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRearrangeFields() [protected]
  • vtkRearrangeFields(const vtkRearrangeFields &) (defined in vtkRearrangeFields) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRearrangeFields, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRearrangeFields() [protected, virtual]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGrid Member List

This is the complete list of members for vtkRectilinearGrid, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeCellId(int ijk[3]) [inline]
  • ComputePointId(int ijk[3]) [inline]
  • ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3])
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataDescription [protected]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Dimensions [protected]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • FindPoint(float x[3]) [virtual]
  • GetActualMemorySize() [virtual]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList &ptIds, vtkIdList &cellIds) (defined in vtkRectilinearGrid) [inline, private]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [inline, virtual]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataDimension() [inline]
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetDimensions() [virtual]
  • GetDimensions(int data[3]) [virtual]
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize() [inline, virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfCells() [inline, virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [virtual]
  • GetPoint(vtkIdType id, float x[3]) [virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [inline, virtual]
  • GetPointData() [inline]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetSource() [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GetXCoordinates() [virtual]
  • GetYCoordinates() [virtual]
  • GetZCoordinates() [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkRectilinearGrid &) (defined in vtkRectilinearGrid) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • Pixel [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • PointReturn [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetDebug(unsigned char debugFlag)
  • SetDimensions(int i, int j, int k)
  • SetDimensions(int dim[3])
  • SetExtent(int extent[6])
  • SetExtent(int x1, int x2, int y1, int y2, int z1, int z2)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkDataSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • SetXCoordinates(vtkDataArray *) [virtual]
  • SetYCoordinates(vtkDataArray *) [virtual]
  • SetZCoordinates(vtkDataArray *) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Voxel [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkObject() [protected]
  • vtkRectilinearGrid() [protected]
  • vtkRectilinearGrid(const vtkRectilinearGrid &) (defined in vtkRectilinearGrid) [private]
  • vtkTypeRevisionMacro(vtkRectilinearGrid, vtkDataSet)
  • WholeExtent [protected]
  • XCoordinates [protected]
  • YCoordinates [protected]
  • ZCoordinates [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRectilinearGrid() [protected]
Generated on Mon Mar 25 01:29:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridGeometryFilter Member List

This is the complete list of members for vtkRectilinearGridGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Extent [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int data[6]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRectilinearGridGeometryFilter &) (defined in vtkRectilinearGridGeometryFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
  • SetExtent(int extent[6])
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRectilinearGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridGeometryFilter() [protected]
  • vtkRectilinearGridGeometryFilter(const vtkRectilinearGridGeometryFilter &) (defined in vtkRectilinearGridGeometryFilter) [private]
  • vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRectilinearGridGeometryFilter, vtkRectilinearGridToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridGeometryFilter() [inline, protected]
  • ~vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridOutlineFilter Member List

This is the complete list of members for vtkRectilinearGridOutlineFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRectilinearGridOutlineFilter &) (defined in vtkRectilinearGridOutlineFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRectilinearGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridOutlineFilter() [inline, protected]
  • vtkRectilinearGridOutlineFilter(const vtkRectilinearGridOutlineFilter &) (defined in vtkRectilinearGridOutlineFilter) [private]
  • vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRectilinearGridOutlineFilter, vtkRectilinearGridToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridOutlineFilter() [inline, protected]
  • ~vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridReader Member List

This is the complete list of members for vtkRectilinearGridReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkRectilinearGridReader &) (defined in vtkRectilinearGridReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkRectilinearGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridReader() [protected]
  • vtkRectilinearGridReader(const vtkRectilinearGridReader &) (defined in vtkRectilinearGridReader) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRectilinearGridReader, vtkDataReader)
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridReader() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridSource Member List

This is the complete list of members for vtkRectilinearGridSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRectilinearGridSource &) (defined in vtkRectilinearGridSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkRectilinearGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridSource() [protected]
  • vtkRectilinearGridSource(const vtkRectilinearGridSource &) (defined in vtkRectilinearGridSource) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRectilinearGridSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridSource() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridToPolyDataFilter Member List

This is the complete list of members for vtkRectilinearGridToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRectilinearGridToPolyDataFilter &) (defined in vtkRectilinearGridToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRectilinearGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • vtkRectilinearGridToPolyDataFilter(const vtkRectilinearGridToPolyDataFilter &) (defined in vtkRectilinearGridToPolyDataFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRectilinearGridToPolyDataFilter, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridToPolyDataFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRectilinearGridWriter Member List

This is the complete list of members for vtkRectilinearGridWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkRectilinearGridWriter &) (defined in vtkRectilinearGridWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkRectilinearGrid *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRectilinearGridWriter() [inline, protected]
  • vtkRectilinearGridWriter(const vtkRectilinearGridWriter &) (defined in vtkRectilinearGridWriter) [private]
  • vtkTypeRevisionMacro(vtkRectilinearGridWriter, vtkDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRectilinearGridWriter() [inline, protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:29:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRecursiveDividingCubes Member List

This is the complete list of members for vtkRecursiveDividingCubes, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Count [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Distance [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDistance() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIncrement() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Increment [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRecursiveDividingCubes &) (defined in vtkRecursiveDividingCubes) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDistance(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIncrement(int) [virtual]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubDivide(float origin[3], float h[3], float values[8]) [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Value [protected]
  • Voxel [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkRecursiveDividingCubes() [protected]
  • vtkRecursiveDividingCubes(const vtkRecursiveDividingCubes &) (defined in vtkRecursiveDividingCubes) [private]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkRecursiveDividingCubes, vtkStructuredPointsToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRecursiveDividingCubes() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:29:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRecursiveSphereDirectionEncoder Member List

This is the complete list of members for vtkRecursiveSphereDirectionEncoder, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodedNormal [protected]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDecodedGradient(int value) [virtual]
  • GetDecodedGradientTable(void) [virtual]
  • GetEncodedDirection(float n[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNumberOfEncodedDirections(void) [virtual]
  • GetRecursionDepth() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GridSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • IndexTable [protected]
  • IndexTableRecursionDepth [protected]
  • InitializeIndexTable(void) [protected]
  • InnerSize [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkRecursiveSphereDirectionEncoder &) (defined in vtkRecursiveSphereDirectionEncoder) [private]
  • OuterSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • RecursionDepth [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetRecursionDepth(int) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDirectionEncoder() [inline, protected]
  • vtkObject() [protected]
  • vtkRecursiveSphereDirectionEncoder() [protected]
  • vtkRecursiveSphereDirectionEncoder(const vtkRecursiveSphereDirectionEncoder &) (defined in vtkRecursiveSphereDirectionEncoder) [private]
  • vtkTypeRevisionMacro(vtkRecursiveSphereDirectionEncoder, vtkDirectionEncoder)
  • ~vtkDirectionEncoder() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRecursiveSphereDirectionEncoder() [protected]
Generated on Mon Mar 25 01:29:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkReferenceCount Member List

This is the complete list of members for vtkReferenceCount, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkReferenceCount &) (defined in vtkReferenceCount) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkReferenceCount() [protected]
  • vtkReferenceCount(const vtkReferenceCount &) (defined in vtkReferenceCount) [private]
  • vtkTypeRevisionMacro(vtkReferenceCount, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkReferenceCount() [protected]
Generated on Mon Mar 25 01:29:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkReflectionFilter Member List

This is the complete list of members for vtkReflectionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPlane() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkReflectionFilter &) (defined in vtkReflectionFilter) [private]
  • Outputs [protected]
  • Plane [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPlane(int) [virtual]
  • SetPlaneToXMax() [inline]
  • SetPlaneToXMin() [inline]
  • SetPlaneToYMax() [inline]
  • SetPlaneToYMin() [inline]
  • SetPlaneToZMax() [inline]
  • SetPlaneToZMin() [inline]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkReflectionFilter() [protected]
  • vtkReflectionFilter(const vtkReflectionFilter &) (defined in vtkReflectionFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkReflectionFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkReflectionFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:29:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRenderer Member List

This is the complete list of members for vtkRenderer, including all inherited members.
  • ActiveCamera [protected]
  • Actors [protected]
  • Actors2D [protected]
  • AddActor(vtkProp *p) [inline]
  • AddActor2D(vtkProp *p) [inline]
  • AddCuller(vtkCuller *)
  • AddLight(vtkLight *)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • AddVolume(vtkProp *p) [inline]
  • AllocatedRenderTime [protected]
  • AllocateTime() [protected]
  • Ambient [protected]
  • Aspect [protected]
  • Background [protected]
  • BackingImage [protected]
  • BackingStore [protected]
  • BackingStoreOff() [virtual]
  • BackingStoreOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • Clear() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • ComputeVisiblePropBounds(float bounds[6])
  • CreatedLight [protected]
  • CreateLight(void)
  • Cullers [protected]
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender()=0 [protected, pure virtual]
  • DeviceRender()=0 [pure virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick()=0 [protected, pure virtual]
  • EndTag [protected]
  • GetActiveCamera()
  • GetActors()
  • GetActors2D()
  • GetAllocatedRenderTime() [virtual]
  • GetAmbient() [virtual]
  • GetAmbient(float data[3]) [virtual]
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetBackingStore() [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCullers() [inline]
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInteractive() [virtual]
  • GetIsPicking() [virtual]
  • GetLastRenderTimeInSeconds() [virtual]
  • GetLayer() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetLights() [inline]
  • GetMTime() [virtual]
  • GetNumberOfPropsRenderedAsGeometry() [virtual]
  • GetOrigin()
  • GetPickedId()=0 [protected, pure virtual]
  • GetPickedZ()=0 [pure virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetRayCaster() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetTimeFactor() [virtual]
  • GetTwoSidedLighting() [virtual]
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVolumes()
  • GetVTKWindow() [virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GetZ(int x, int y)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interactive [protected]
  • InteractiveOff() [virtual]
  • InteractiveOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LastRenderTimeInSeconds [protected]
  • Layer [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Lights [protected]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • MakeCamera() [virtual]
  • MakeLight() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • NumberOfPropsRenderedAsGeometry [protected]
  • NumberOfPropsToRayCast [protected]
  • NumberOfPropsToRenderIntoImage [protected]
  • operator=(const vtkRenderer &) (defined in vtkRenderer) [private]
  • Origin [protected]
  • PathArray [protected]
  • PathArrayCount [protected]
  • PickedProp [protected]
  • PickFromProps [protected]
  • PickGeometry() [protected, virtual]
  • PickProp(float selectionX, float selectionY) [virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickRender(vtkPropCollection *props) [protected, virtual]
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropArray [protected]
  • PropArrayCount [protected]
  • Props [protected]
  • RayCaster [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor(vtkProp *p) [inline]
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveCuller(vtkCuller *)
  • RemoveLight(vtkLight *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • RemoveVolume(vtkProp *p) [inline]
  • Render() [virtual]
  • RenderOverlay()
  • RenderTime [protected]
  • RenderWindow [protected]
  • ResetCamera()
  • ResetCamera(float bounds[6])
  • ResetCamera(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • ResetCameraClippingRange()
  • ResetCameraClippingRange(float bounds[6])
  • ResetCameraClippingRange(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SafeDownCast(vtkObject *o) [static]
  • SetActiveCamera(vtkCamera *)
  • SetAllocatedRenderTime(float) [virtual]
  • SetAmbient(float, float, float) [virtual]
  • SetAmbient(float[3]) [virtual]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetBackingStore(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractive(int) [virtual]
  • SetLayer(int) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetTwoSidedLighting(int) [virtual]
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize)=0 [protected, pure virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TimeFactor [protected]
  • Transparent()
  • TwoSidedLighting [protected]
  • TwoSidedLightingOff() [virtual]
  • TwoSidedLightingOn() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateCamera(void) [protected, virtual]
  • UpdateGeometry(void) [protected, virtual]
  • UpdateLightGeometry(void) [protected, virtual]
  • UpdateLights(void) [inline, protected, virtual]
  • UpdatePickId()=0 [protected, pure virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &wx, float &wy, float &wz) [virtual]
  • VisibleActorCount()
  • VisibleVolumeCount()
  • Volumes [protected]
  • vtkObject() [protected]
  • vtkRenderer() [protected]
  • vtkRenderer(const vtkRenderer &) (defined in vtkRenderer) [private]
  • vtkTypeRevisionMacro(vtkRenderer, vtkViewport)
  • vtkViewport() [protected]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &wx, float &wy, float &wz) [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderer() [protected]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:29:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRendererCollection Member List

This is the complete list of members for vtkRendererCollection, including all inherited members.
  • AddItem(vtkRenderer *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkRendererCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkRendererCollection &) (defined in vtkRendererCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderOverlay()
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkRendererCollection() [inline, protected]
  • vtkRendererCollection(const vtkRendererCollection &) (defined in vtkRendererCollection) [private]
  • vtkTypeRevisionMacro(vtkRendererCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRendererCollection() [inline, protected]
Generated on Mon Mar 25 01:29:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRendererSource Member List

This is the complete list of members for vtkRendererSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DepthValues [protected]
  • DepthValuesOff() [virtual]
  • DepthValuesOn() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthValues() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRenderFlag() [virtual]
  • GetWholeWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRendererSource &) (defined in vtkRendererSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RenderFlag [protected]
  • RenderFlagOff() [virtual]
  • RenderFlagOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDepthValues(int) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderer *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRenderFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeWindow(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [protected, virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRendererSource() [protected]
  • vtkRendererSource(const vtkRendererSource &) (defined in vtkRendererSource) [private]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkRendererSource, vtkStructuredPointsSource)
  • WholeWindow [protected]
  • WholeWindowOff() [virtual]
  • WholeWindowOn() [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRendererSource() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:29:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRenderLargeImage Member List

This is the complete list of members for vtkRenderLargeImage, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetMagnification() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Magnification [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRenderLargeImage &) (defined in vtkRenderLargeImage) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderer *) [virtual]
  • SetMagnification(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRenderLargeImage() [protected]
  • vtkRenderLargeImage(const vtkRenderLargeImage &) (defined in vtkRenderLargeImage) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRenderLargeImage, vtkImageSource)
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRenderLargeImage() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRenderWindow Member List

This is the complete list of members for vtkRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame() [inline, virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [inline, virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [inline, virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int, int, int, int, int) [inline, virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int,int,int,int,int) [inline, virtual]
  • GetRGBAPixelData(int,int,int,int,int) [inline, virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int, int, int, int) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline, virtual]
  • InAbortCheck [protected]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [inline, virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • NeverRendered [protected]
  • New() [static]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldScreen [protected]
  • operator=(const vtkRenderWindow &) (defined in vtkRenderWindow) [private]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *) [inline, virtual]
  • SetParentInfo(char *) [inline, virtual]
  • SetPixelData(int, int, int, int, unsigned char *, int) [inline, virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int,int,int,int,unsigned char *, int, int blend=0) [inline, virtual]
  • SetRGBAPixelData(int,int,int,int,float *, int, int blend=0) [inline, virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *) [inline, virtual]
  • SetWindowInfo(char *) [inline, virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int, int, int, int, float *) [inline, virtual]
  • ShowCursor() [inline, virtual]
  • Size [protected]
  • Start() [inline, virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkRenderWindow() [protected]
  • vtkRenderWindow(const vtkRenderWindow &) (defined in vtkRenderWindow) [private]
  • vtkTypeRevisionMacro(vtkRenderWindow, vtkWindow)
  • vtkWindow() [protected]
  • WindowName [protected]
  • WindowRemap() [inline, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:30:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRenderWindowCollection Member List

This is the complete list of members for vtkRenderWindowCollection, including all inherited members.
  • AddItem(vtkRenderWindow *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkRenderWindowCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkRenderWindowCollection &) (defined in vtkRenderWindowCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkRenderWindowCollection() [inline, protected]
  • vtkRenderWindowCollection(const vtkRenderWindowCollection &) (defined in vtkRenderWindowCollection) [private]
  • vtkTypeRevisionMacro(vtkRenderWindowCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindowCollection() [inline, protected]
Generated on Mon Mar 25 01:30:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRenderWindowInteractor Member List

This is the complete list of members for vtkRenderWindowInteractor, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ControlKey [protected]
  • CreateDefaultPicker() [virtual]
  • CreateTimer(int) [inline, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DestroyTimer() [inline, virtual]
  • Disable() [inline, virtual]
  • Dolly [protected]
  • Enable() [inline, virtual]
  • Enabled [protected]
  • EndPickCallback() [virtual]
  • EndPickTag [protected]
  • EventPosition [protected]
  • ExitCallback() [virtual]
  • ExitTag [protected]
  • FlyTo(vtkRenderer *ren, float x, float y, float z)
  • FlyTo(vtkRenderer *ren, float *x) [inline]
  • FlyToImage(vtkRenderer *ren, float x, float y)
  • FlyToImage(vtkRenderer *ren, float *x) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetControlKey() [virtual]
  • GetDebug()
  • GetDesiredUpdateRate() [virtual]
  • GetDolly() [virtual]
  • GetEnabled() [virtual]
  • GetEventPosition() [virtual]
  • GetEventPosition(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [virtual]
  • GetInteractorStyle() [virtual]
  • GetKeyCode() [virtual]
  • GetKeySym() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetMousePosition(int *x, int *y) [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfFlyFrames() [virtual]
  • GetPicker() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRepeatCount() [virtual]
  • GetShiftKey() [virtual]
  • GetSize() [virtual]
  • GetSize(int &, int &) [virtual]
  • GetSize(int[2]) [virtual]
  • GetStillUpdateRate() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline]
  • Initialize() [inline, virtual]
  • Initialized [protected]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyCode [protected]
  • KeySym [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfFlyFrames [protected]
  • operator=(const vtkRenderWindowInteractor &) (defined in vtkRenderWindowInteractor) [private]
  • Picker [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReInitialize() [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderWindow [protected]
  • RepeatCount [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetControlKey(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float) [virtual]
  • SetDolly(float) [virtual]
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0) [inline]
  • SetEventPosition(int, int) [virtual]
  • SetEventPosition(int[2])
  • SetExitMethod(void(*f)(void *), void *arg)
  • SetExitMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractorStyle(vtkInteractorStyle *) [virtual]
  • SetKeyCode(int) [virtual]
  • SetKeySym(const char *) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetNumberOfFlyFrames(int) [virtual]
  • SetPicker(vtkAbstractPicker *) [virtual]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *aren)
  • SetRepeatCount(int) [virtual]
  • SetShiftKey(int) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetStillUpdateRate(float) [virtual]
  • SetUserMethod(void(*f)(void *), void *arg)
  • SetUserMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • ShowCursor() [inline]
  • Size [protected]
  • Start() [inline, virtual]
  • StartPickCallback() [virtual]
  • StartPickTag [protected]
  • StillUpdateRate [protected]
  • Style [protected]
  • SubjectHelper [protected]
  • TerminateApp(void) [inline, virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSize(int x, int y) [virtual]
  • UserCallback() [virtual]
  • UserTag [protected]
  • vtkObject() [protected]
  • vtkRenderWindowInteractor() [protected]
  • vtkRenderWindowInteractor(const vtkRenderWindowInteractor &) (defined in vtkRenderWindowInteractor) [private]
  • vtkTypeRevisionMacro(vtkRenderWindowInteractor, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindowInteractor() [protected]
Generated on Mon Mar 25 01:30:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkReverseSense Member List

This is the complete list of members for vtkReverseSense, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetReverseCells() [virtual]
  • GetReverseNormals() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkReverseSense &) (defined in vtkReverseSense) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ReverseCells [protected]
  • ReverseCellsOff() [virtual]
  • ReverseCellsOn() [virtual]
  • ReverseNormals [protected]
  • ReverseNormalsOff() [virtual]
  • ReverseNormalsOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetReverseCells(int) [virtual]
  • SetReverseNormals(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkReverseSense() [protected]
  • vtkReverseSense(const vtkReverseSense &) (defined in vtkReverseSense) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkReverseSense, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkReverseSense() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRibbonFilter Member List

This is the complete list of members for vtkRibbonFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Angle [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultNormal [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAngle() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultNormal() [virtual]
  • GetDefaultNormal(float data[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUseDefaultNormal() [virtual]
  • GetVaryWidth() [virtual]
  • GetWidth() [virtual]
  • GetWidthFactor() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRibbonFilter &) (defined in vtkRibbonFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultNormal(float, float, float) [virtual]
  • SetDefaultNormal(float[3]) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseDefaultNormal(int) [virtual]
  • SetVaryWidth(int) [virtual]
  • SetWidth(float) [virtual]
  • SetWidthFactor(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseDefaultNormal [protected]
  • UseDefaultNormalOff() [virtual]
  • UseDefaultNormalOn() [virtual]
  • VaryWidth [protected]
  • VaryWidthOff() [virtual]
  • VaryWidthOn() [virtual]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkRibbonFilter() [protected]
  • vtkRibbonFilter(const vtkRibbonFilter &) (defined in vtkRibbonFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRibbonFilter, vtkPolyDataToPolyDataFilter)
  • Width [protected]
  • WidthFactor [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRibbonFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRIBExporter Member List

This is the complete list of members for vtkRIBExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Background [protected]
  • BackgroundOff() [virtual]
  • BackgroundOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • ExportArrays [protected]
  • ExportArraysOff() [virtual]
  • ExportArraysOn() [virtual]
  • FilePrefix [protected]
  • FilePtr [protected]
  • GetBackground() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetExportArrays() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetPixelSamples() [virtual]
  • GetPixelSamples(int data[2]) [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetSize() [virtual]
  • GetSize(int data[2]) [virtual]
  • GetTextureName(vtkTexture *aTexture) [protected]
  • GetTexturePrefix() [virtual]
  • GetTIFFName(vtkTexture *aTexture) [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • ModifyArrayName(char *newname, const char *name) [protected]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkRIBExporter &) (defined in vtkRIBExporter) [private]
  • PixelSamples [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBackground(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetExportArrays(int) [virtual]
  • SetFilePrefix(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetPixelSamples(int, int) [virtual]
  • SetPixelSamples(int[2])
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • SetTexturePrefix(const char *) [virtual]
  • Size [protected]
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • TexturePrefix [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkObject() [protected]
  • vtkRIBExporter() [protected]
  • vtkRIBExporter(const vtkRIBExporter &) (defined in vtkRIBExporter) [private]
  • vtkTypeRevisionMacro(vtkRIBExporter, vtkExporter)
  • Write() [virtual]
  • WriteActor(vtkActor *anActor) [protected]
  • WriteAmbientLight(int count) [protected]
  • WriteCamera(vtkCamera *aCamera) [protected]
  • WriteData() [protected, virtual]
  • WriteHeader(vtkRenderer *aRen) [protected]
  • WriteLight(vtkLight *aLight, int count) [protected]
  • WritePolygons(vtkPolyData *pd, vtkUnsignedCharArray *colors, vtkProperty *aProperty) [protected]
  • WriteProperty(vtkProperty *aProperty, vtkTexture *aTexture) [protected]
  • WriteStrips(vtkPolyData *pd, vtkUnsignedCharArray *colors, vtkProperty *aProperty) [protected]
  • WriteTexture(vtkTexture *aTexture) [protected]
  • WriteTrailer() [protected]
  • WriteViewport(vtkRenderer *aRenderer, int size[2]) [protected]
  • ~vtkExporter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRIBExporter() [protected]
Generated on Mon Mar 25 01:30:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRIBLight Member List

This is the complete list of members for vtkRIBLight, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AttenuationValues [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • ConeAngle [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkLight *light)
  • Delete() [virtual]
  • Exponent [protected]
  • FocalPoint [protected]
  • GetAttenuationValues() [virtual]
  • GetAttenuationValues(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor() [virtual]
  • GetColor(float data[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetConeAngle() [virtual]
  • GetDebug()
  • GetExponent() [virtual]
  • GetFocalPoint() [virtual]
  • GetFocalPoint(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetIntensity() [virtual]
  • GetLightType() [virtual]
  • GetMTime() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetPositional() [virtual]
  • GetReferenceCount() [inline]
  • GetShadows() [virtual]
  • GetSwitch() [virtual]
  • GetTransformedFocalPoint(float &a0, float &a1, float &a2)
  • GetTransformedFocalPoint(float a[3])
  • GetTransformedFocalPoint()
  • GetTransformedPosition(float &a0, float &a1, float &a2)
  • GetTransformedPosition(float a[3])
  • GetTransformedPosition()
  • GetTransformMatrix() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intensity [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Light [protected]
  • LightType [protected]
  • LightTypeIsCameraLight()
  • LightTypeIsHeadlight()
  • LightTypeIsSceneLight()
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkRIBLight &) (defined in vtkRIBLight) [private]
  • Position [protected]
  • Positional [protected]
  • PositionalOff() [virtual]
  • PositionalOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadSelf(istream &is)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, int index) [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAttenuationValues(float, float, float) [virtual]
  • SetAttenuationValues(float[3]) [virtual]
  • SetColor(float, float, float) [virtual]
  • SetColor(float[3]) [virtual]
  • SetConeAngle(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDirectionAngle(float elevation, float azimuth)
  • SetDirectionAngle(float ang[2]) [inline]
  • SetExponent(float) [virtual]
  • SetFocalPoint(float, float, float) [virtual]
  • SetFocalPoint(float[3]) [virtual]
  • SetFocalPoint(double *a) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetIntensity(float) [virtual]
  • SetLightType(int) [virtual]
  • SetLightTypeToCameraLight()
  • SetLightTypeToHeadlight()
  • SetLightTypeToSceneLight()
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetPosition(double *a) [inline]
  • SetPositional(int) [virtual]
  • SetReferenceCount(int)
  • SetShadows(int) [virtual]
  • SetSwitch(int) [virtual]
  • SetTransformMatrix(vtkMatrix4x4 *) [virtual]
  • Shadows [protected]
  • ShadowsOff() [virtual]
  • ShadowsOn() [virtual]
  • SubjectHelper [protected]
  • Switch [protected]
  • SwitchOff() [virtual]
  • SwitchOn() [virtual]
  • TransformedFocalPointReturn [protected]
  • TransformedPositionReturn [protected]
  • TransformMatrix [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkLight() [protected]
  • vtkObject() [protected]
  • vtkRIBLight() [protected]
  • vtkRIBLight(const vtkRIBLight &) (defined in vtkRIBLight) [private]
  • vtkTypeRevisionMacro(vtkRIBLight, vtkLight)
  • WriteSelf(ostream &os)
  • ~vtkLight() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRIBLight() [protected]
Generated on Mon Mar 25 01:30:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRIBProperty Member List

This is the complete list of members for vtkRIBProperty, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddParameter(char *parameter, char *value)
  • AddVariable(char *variable, char *declaration)
  • Ambient [protected]
  • AmbientColor [protected]
  • BackfaceCulling [protected]
  • BackfaceCullingOff() [virtual]
  • BackfaceCullingOn() [virtual]
  • BackfaceRender(vtkActor *, vtkRenderer *) [inline, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Declarations [protected]
  • DeepCopy(vtkProperty *p)
  • Delete() [virtual]
  • Diffuse [protected]
  • DiffuseColor [protected]
  • DisplacementShader [protected]
  • EdgeColor [protected]
  • EdgeVisibility [protected]
  • EdgeVisibilityOff() [virtual]
  • EdgeVisibilityOn() [virtual]
  • FrontfaceCulling [protected]
  • FrontfaceCullingOff() [virtual]
  • FrontfaceCullingOn() [virtual]
  • GetAmbient() [virtual]
  • GetAmbientColor() [virtual]
  • GetAmbientColor(float data[3]) [virtual]
  • GetBackfaceCulling() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor()
  • GetColor(float rgb[3])
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDeclarations()
  • GetDiffuse() [virtual]
  • GetDiffuseColor() [virtual]
  • GetDiffuseColor(float data[3]) [virtual]
  • GetDisplacementShader() [virtual]
  • GetEdgeColor() [virtual]
  • GetEdgeColor(float data[3]) [virtual]
  • GetEdgeVisibility() [virtual]
  • GetFrontfaceCulling() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInterpolation() [virtual]
  • GetInterpolationAsString() [inline]
  • GetLineStipplePattern() [virtual]
  • GetLineStippleRepeatFactor() [virtual]
  • GetLineWidth() [virtual]
  • GetMTime() [virtual]
  • GetOpacity() [virtual]
  • GetParameters()
  • GetPointSize() [virtual]
  • GetReferenceCount() [inline]
  • GetRepresentation() [virtual]
  • GetRepresentationAsString() [inline]
  • GetSpecular() [virtual]
  • GetSpecularColor() [virtual]
  • GetSpecularColor(float data[3]) [virtual]
  • GetSpecularPower() [virtual]
  • GetSurfaceShader() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Interpolation [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineStipplePattern [protected]
  • LineStippleRepeatFactor [protected]
  • LineWidth [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Opacity [protected]
  • operator=(const vtkRIBProperty &) (defined in vtkRIBProperty) [private]
  • Parameters [protected]
  • PointSize [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkActor *a, vtkRenderer *ren) [protected, virtual]
  • Representation [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAmbient(float) [virtual]
  • SetAmbientColor(float, float, float) [virtual]
  • SetAmbientColor(float[3]) [virtual]
  • SetBackfaceCulling(int) [virtual]
  • SetColor(float r, float g, float b)
  • SetColor(float a[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDiffuse(float) [virtual]
  • SetDiffuseColor(float, float, float) [virtual]
  • SetDiffuseColor(float[3]) [virtual]
  • SetDisplacementShader(const char *) [virtual]
  • SetEdgeColor(float, float, float) [virtual]
  • SetEdgeColor(float[3]) [virtual]
  • SetEdgeVisibility(int) [virtual]
  • SetFrontfaceCulling(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInterpolation(int) [virtual]
  • SetInterpolationToFlat() [inline]
  • SetInterpolationToGouraud() [inline]
  • SetInterpolationToPhong() [inline]
  • SetLineStipplePattern(int) [virtual]
  • SetLineStippleRepeatFactor(int) [virtual]
  • SetLineWidth(float) [virtual]
  • SetOpacity(float) [virtual]
  • SetParameter(char *parameter, char *value)
  • SetPointSize(float) [virtual]
  • SetReferenceCount(int)
  • SetRepresentation(int) [virtual]
  • SetRepresentationToPoints() [inline]
  • SetRepresentationToSurface() [inline]
  • SetRepresentationToWireframe() [inline]
  • SetSpecular(float) [virtual]
  • SetSpecularColor(float, float, float) [virtual]
  • SetSpecularColor(float[3]) [virtual]
  • SetSpecularPower(float) [virtual]
  • SetSurfaceShader(const char *) [virtual]
  • SetVariable(char *variable, char *declaration)
  • Specular [protected]
  • SpecularColor [protected]
  • SpecularPower [protected]
  • SubjectHelper [protected]
  • SurfaceShader [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkProperty() [protected]
  • vtkRIBProperty() [protected]
  • vtkRIBProperty(const vtkRIBProperty &) (defined in vtkRIBProperty) [private]
  • vtkTypeRevisionMacro(vtkRIBProperty, vtkProperty)
  • ~vtkObject() [protected, virtual]
  • ~vtkProperty() [inline, protected]
  • ~vtkRIBProperty() [protected]
Generated on Mon Mar 25 01:30:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRotationalExtrusionFilter Member List

This is the complete list of members for vtkRotationalExtrusionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Angle [protected]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeltaRadius [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetAngle() [virtual]
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDeltaRadius() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution() [virtual]
  • GetTranslation() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRotationalExtrusionFilter &) (defined in vtkRotationalExtrusionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Resolution [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAngle(float) [virtual]
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDeltaRadius(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTranslation(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Translation [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkRotationalExtrusionFilter() [protected]
  • vtkRotationalExtrusionFilter(const vtkRotationalExtrusionFilter &) (defined in vtkRotationalExtrusionFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRotationalExtrusionFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRotationalExtrusionFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRTAnalyticSource Member List

This is the complete list of members for vtkRTAnalyticSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float &, float &, float &) [virtual]
  • GetCenter(float[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMaximum() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStandardDeviation() [virtual]
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GetXFreq() [virtual]
  • GetXMag() [virtual]
  • GetYFreq() [virtual]
  • GetYMag() [virtual]
  • GetZFreq() [virtual]
  • GetZMag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Maximum [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkRTAnalyticSource &) (defined in vtkRTAnalyticSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximum(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStandardDeviation(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetWholeExtent(int xMinx, int xMax, int yMin, int yMax, int zMin, int zMax)
  • SetXFreq(float) [virtual]
  • SetXMag(float) [virtual]
  • SetYFreq(float) [virtual]
  • SetYMag(float) [virtual]
  • SetZFreq(float) [virtual]
  • SetZMag(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StandardDeviation [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkRTAnalyticSource() [protected]
  • vtkRTAnalyticSource(const vtkRTAnalyticSource &) (defined in vtkRTAnalyticSource) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRTAnalyticSource, vtkImageSource)
  • WholeExtent [protected]
  • XFreq [protected]
  • XMag [protected]
  • YFreq [protected]
  • YMag [protected]
  • ZFreq [protected]
  • ZMag [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkRTAnalyticSource() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRuledSurfaceFilter Member List

This is the complete list of members for vtkRuledSurfaceFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CloseSurface [protected]
  • CloseSurfaceOff() [virtual]
  • CloseSurfaceOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DistanceFactor [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCloseSurface() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDistanceFactor() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOffset() [virtual]
  • GetOnRatio() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassLines() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetResolution() [virtual]
  • GetResolution(int data[2]) [virtual]
  • GetRuledMode() [virtual]
  • GetRuledModeAsString()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Ids (defined in vtkRuledSurfaceFilter) [private]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • Offset [protected]
  • OnRatio [protected]
  • operator=(const vtkRuledSurfaceFilter &) (defined in vtkRuledSurfaceFilter) [private]
  • Outputs [protected]
  • PassLines [protected]
  • PassLinesOff() [virtual]
  • PassLinesOn() [virtual]
  • PointWalk(vtkPolyData *output, vtkPoints *inPts, int npts, vtkIdType *pts, int npts2, vtkIdType *pts2) (defined in vtkRuledSurfaceFilter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Resample(vtkPolyData *output, vtkPoints *inPts, vtkPoints *newPts, int npts, vtkIdType *pts, int npts2, vtkIdType *pts2) (defined in vtkRuledSurfaceFilter) [private]
  • Resolution [protected]
  • RuledMode [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCloseSurface(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDistanceFactor(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOffset(int) [virtual]
  • SetOnRatio(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetPassLines(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetResolution(int, int) [virtual]
  • SetResolution(int[2])
  • SetRuledMode(int) [virtual]
  • SetRuledModeToPointWalk() [inline]
  • SetRuledModeToResample() [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkRuledSurfaceFilter() [protected]
  • vtkRuledSurfaceFilter(const vtkRuledSurfaceFilter &) (defined in vtkRuledSurfaceFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkRuledSurfaceFilter, vtkPolyDataToPolyDataFilter)
  • Weights (defined in vtkRuledSurfaceFilter) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkRuledSurfaceFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRungeKutta2 Member List

This is the complete list of members for vtkRungeKutta2, including all inherited members.
  • Adaptive [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Derivs [protected]
  • ErrorCodes enum name
  • FunctionSet [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFunctionSet() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsAdaptive() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [inline, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NOT_INITIALIZED enum value
  • operator=(const vtkRungeKutta2 &) (defined in vtkRungeKutta2) [private]
  • OUT_OF_DOMAIN enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFunctionSet(vtkFunctionSet *functionset) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UNEXPECTED_VALUE enum value
  • UnRegister(vtkObject *o) [virtual]
  • Vals [protected]
  • vtkInitialValueProblemSolver() [protected]
  • vtkObject() [protected]
  • vtkRungeKutta2() [protected]
  • vtkRungeKutta2(const vtkRungeKutta2 &) (defined in vtkRungeKutta2) [private]
  • vtkTypeRevisionMacro(vtkRungeKutta2, vtkInitialValueProblemSolver)
  • ~vtkInitialValueProblemSolver() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRungeKutta2() [protected]
Generated on Mon Mar 25 01:30:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRungeKutta4 Member List

This is the complete list of members for vtkRungeKutta4, including all inherited members.
  • Adaptive [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Derivs [protected]
  • ErrorCodes enum name
  • FunctionSet [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFunctionSet() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsAdaptive() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [inline, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextDerivs [protected]
  • NOT_INITIALIZED enum value
  • operator=(const vtkRungeKutta4 &) (defined in vtkRungeKutta4) [private]
  • OUT_OF_DOMAIN enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFunctionSet(vtkFunctionSet *functionset) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UNEXPECTED_VALUE enum value
  • UnRegister(vtkObject *o) [virtual]
  • Vals [protected]
  • vtkInitialValueProblemSolver() [protected]
  • vtkObject() [protected]
  • vtkRungeKutta4() [protected]
  • vtkRungeKutta4(const vtkRungeKutta4 &) (defined in vtkRungeKutta4) [private]
  • vtkTypeRevisionMacro(vtkRungeKutta4, vtkInitialValueProblemSolver)
  • ~vtkInitialValueProblemSolver() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRungeKutta4() [protected]
Generated on Mon Mar 25 01:30:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRungeKutta45 Member List

This is the complete list of members for vtkRungeKutta45, including all inherited members.
  • A [protected, static]
  • Adaptive [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • B [protected, static]
  • BreakOnError() [static]
  • C [protected, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float &error) [protected]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [inline, virtual]
  • ComputeNextStep(float *xprev, float *dxprev, float *xnext, float t, float &delT, float &delTActual, float minStep, float maxStep, float maxError, float &error) [virtual]
  • DC [protected, static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Derivs [protected]
  • ErrorCodes enum name
  • FunctionSet [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFunctionSet() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsAdaptive() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [inline, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextDerivs [protected]
  • NOT_INITIALIZED enum value
  • operator=(const vtkRungeKutta45 &) (defined in vtkRungeKutta45) [private]
  • OUT_OF_DOMAIN enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFunctionSet(vtkFunctionSet *functionset) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UNEXPECTED_VALUE enum value
  • UnRegister(vtkObject *o) [virtual]
  • Vals [protected]
  • vtkInitialValueProblemSolver() [protected]
  • vtkObject() [protected]
  • vtkRungeKutta45() [protected]
  • vtkRungeKutta45(const vtkRungeKutta45 &) (defined in vtkRungeKutta45) [private]
  • vtkTypeRevisionMacro(vtkRungeKutta45, vtkInitialValueProblemSolver)
  • ~vtkInitialValueProblemSolver() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRungeKutta45() [protected]
Generated on Mon Mar 25 01:30:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSampleFunction Member List

This is the complete list of members for vtkSampleFunction, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Cap(vtkDataArray *s) [protected]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CapValue [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetCapping() [virtual]
  • GetCapValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeNormals() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImplicitFunction() [virtual]
  • GetInputs() [inline]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImplicitFunction [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSampleFunction &) (defined in vtkSampleFunction) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • Scalars [protected]
  • SetAbortExecute(int) [virtual]
  • SetCapping(int) [virtual]
  • SetCapValue(float) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImplicitFunction(vtkImplicitFunction *) [virtual]
  • SetModelBounds(float, float, float, float, float, float) [virtual]
  • SetModelBounds(float[6]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetScalars(vtkDataArray *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSampleFunction() [protected]
  • vtkSampleFunction(const vtkSampleFunction &) (defined in vtkSampleFunction) [private]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkSampleFunction, vtkStructuredPointsSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSampleFunction() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:30:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkScalarBarActor Member List

This is the complete list of members for vtkScalarBarActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateAndSizeLabels(int *labelSize, int *size, vtkViewport *viewport, float *range) (defined in vtkScalarBarActor) [private]
  • AllocatedRenderTime [protected]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime (defined in vtkScalarBarActor) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • FontFamily [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBold() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetItalic() [virtual]
  • GetLabelFormat() [virtual]
  • GetLayerNumber() [virtual]
  • GetLookupTable() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMaximumNumberOfColors() [virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfLabels() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation() [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetShadow() [virtual]
  • GetTitle() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabelFormat [protected]
  • LastOrigin (defined in vtkScalarBarActor) [private]
  • LastSize (defined in vtkScalarBarActor) [private]
  • LayerNumber [protected]
  • LookupTable [protected]
  • Mapper [protected]
  • MaximumNumberOfColors [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfLabels [protected]
  • NumberOfLabelsBuilt [protected]
  • operator=(const vtkScalarBarActor &) (defined in vtkScalarBarActor) [private]
  • Orientation [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • ScalarBar (defined in vtkScalarBarActor) [private]
  • ScalarBarActor (defined in vtkScalarBarActor) [private]
  • ScalarBarMapper (defined in vtkScalarBarActor) [private]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBold(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetItalic(int) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetLookupTable(vtkScalarsToColors *) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetMaximumNumberOfColors(int) [virtual]
  • SetNumberOfLabels(int) [virtual]
  • SetOrientation(int) [virtual]
  • SetOrientationToHorizontal() [inline]
  • SetOrientationToVertical() [inline]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetShadow(int) [virtual]
  • SetTitle(const char *) [virtual]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SizeTitle(int *titleSize, int *size, vtkViewport *viewport) (defined in vtkScalarBarActor) [private]
  • SubjectHelper [protected]
  • TextActors (defined in vtkScalarBarActor) [private]
  • TextMappers (defined in vtkScalarBarActor) [private]
  • Title [protected]
  • TitleActor (defined in vtkScalarBarActor) [private]
  • TitleMapper (defined in vtkScalarBarActor) [private]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkScalarBarActor() [protected]
  • vtkScalarBarActor(const vtkScalarBarActor &) (defined in vtkScalarBarActor) [private]
  • vtkTypeRevisionMacro(vtkScalarBarActor, vtkActor2D)
  • ~vtkActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkScalarBarActor() [protected]
Generated on Mon Mar 25 01:30:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkScalarsToColors Member List

This is the complete list of members for vtkScalarsToColors, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Alpha [protected]
  • BreakOnError() [static]
  • Build() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConvertUnsignedCharToRGBA(vtkUnsignedCharArray *colors, int numComp, int numTuples) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetAlpha() [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(float v, float rgb[3])=0 [pure virtual]
  • GetColor(float v) [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLuminance(float x) [inline]
  • GetMTime() [virtual]
  • GetOpacity(float vtkNotUsed(v)) [inline, virtual]
  • GetRange()=0 [pure virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MapScalars(vtkDataArray *scalars, int colorMode, int component)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output, int outputFormat)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output) [inline]
  • MapScalarsThroughTable2(void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputFormat)=0 [pure virtual]
  • MapValue(float v)=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkScalarsToColors &) (defined in vtkScalarsToColors) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RGB (defined in vtkScalarsToColors) [private]
  • SafeDownCast(vtkObject *o) [static]
  • SetAlpha(float alpha)
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetRange(float min, float max)=0 [pure virtual]
  • SetRange(float rng[2]) [inline]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkScalarsToColors() [inline, protected]
  • vtkScalarsToColors(const vtkScalarsToColors &) (defined in vtkScalarsToColors) [private]
  • vtkTypeRevisionMacro(vtkScalarsToColors, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarsToColors() [inline, protected]
Generated on Mon Mar 25 01:30:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkScalarTree Member List

This is the complete list of members for vtkScalarTree, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • BuildTime [protected]
  • BuildTree()=0 [pure virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetNextCell(vtkIdType &cellId, vtkIdList *&ptIds, vtkDataArray *cellScalars)=0 [pure virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize()=0 [pure virtual]
  • InitTraversal(float scalarValue)=0 [pure virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkScalarTree &) (defined in vtkScalarTree) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Scalars [protected]
  • ScalarValue [protected]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkScalarTree() [protected]
  • vtkScalarTree(const vtkScalarTree &) (defined in vtkScalarTree) [private]
  • vtkTypeRevisionMacro(vtkScalarTree, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarTree() [protected]
Generated on Mon Mar 25 01:30:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkScaledTextActor Member List

This is the complete list of members for vtkScaledTextActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight()
  • GetLayerNumber() [virtual]
  • GetMapper(void) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMaximumLineHeight() [virtual]
  • GetMinimumSize() [virtual]
  • GetMinimumSize(int &, int &) [virtual]
  • GetMinimumSize(int[2]) [virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastOrigin [protected]
  • LastSize [protected]
  • LayerNumber [protected]
  • Mapper [protected]
  • MaximumLineHeight [protected]
  • MinimumSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkScaledTextActor &) (defined in vtkScaledTextActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport) [virtual]
  • RenderOverlay(vtkViewport *viewport) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeight(float h)
  • SetLayerNumber(int) [virtual]
  • SetMapper(vtkTextMapper *mapper)
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetMaximumLineHeight(float) [virtual]
  • SetMinimumSize(int, int) [virtual]
  • SetMinimumSize(int[2])
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • TextActor [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkScaledTextActor() [protected]
  • vtkScaledTextActor(const vtkScaledTextActor &) (defined in vtkScaledTextActor) [private]
  • vtkTypeRevisionMacro(vtkScaledTextActor, vtkActor2D)
  • ~vtkActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkScaledTextActor() [protected]
Generated on Mon Mar 25 01:30:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSelectPolyData Member List

This is the complete list of members for vtkSelectPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClosestPoint [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateSelectionScalars [protected]
  • GenerateSelectionScalarsOff() [virtual]
  • GenerateSelectionScalarsOn() [virtual]
  • GenerateUnselectedOutput [protected]
  • GenerateUnselectedOutputOff() [virtual]
  • GenerateUnselectedOutputOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGenerateSelectionScalars() [virtual]
  • GetGenerateUnselectedOutput() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInsideOut() [virtual]
  • GetLoop() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPointNeighbors(vtkIdType ptId, vtkIdList *nei) (defined in vtkSelectPolyData) [private]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSelectionEdges() [inline]
  • GetSelectionMode() [virtual]
  • GetSelectionModeAsString() [inline]
  • GetUnselectedOutput() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InsideOut [protected]
  • InsideOutOff() [virtual]
  • InsideOutOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Loop [protected]
  • Mesh (defined in vtkSelectPolyData) [private]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSelectPolyData &) (defined in vtkSelectPolyData) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionEdges [protected]
  • SelectionMode [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGenerateSelectionScalars(int) [virtual]
  • SetGenerateUnselectedOutput(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetInsideOut(int) [virtual]
  • SetLoop(vtkPoints *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSelectionMode(int) [virtual]
  • SetSelectionModeToClosestPointRegion() [inline]
  • SetSelectionModeToLargestRegion() [inline]
  • SetSelectionModeToSmallestRegion() [inline]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • UnselectedOutput [protected]
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSelectPolyData() [protected]
  • vtkSelectPolyData(const vtkSelectPolyData &) (defined in vtkSelectPolyData) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSelectPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSelectPolyData() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSelectVisiblePoints Member List

This is the complete list of members for vtkSelectVisiblePoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRenderer() [inline]
  • GetSelectInvisible() [virtual]
  • GetSelection() [virtual]
  • GetSelection(int data[4]) [virtual]
  • GetSelectionWindow() [virtual]
  • GetTolerance() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSelectVisiblePoints &) (defined in vtkSelectVisiblePoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInvisible [protected]
  • SelectInvisibleOff() [virtual]
  • SelectInvisibleOn() [virtual]
  • Selection [protected]
  • SelectionWindow [protected]
  • SelectionWindowOff() [virtual]
  • SelectionWindowOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRenderer(vtkRenderer *ren) [inline]
  • SetSelectInvisible(int) [virtual]
  • SetSelection(int, int, int, int) [virtual]
  • SetSelection(int[4]) [virtual]
  • SetSelectionWindow(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTolerance(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tolerance [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSelectVisiblePoints() [protected]
  • vtkSelectVisiblePoints(const vtkSelectVisiblePoints &) (defined in vtkSelectVisiblePoints) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSelectVisiblePoints, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSelectVisiblePoints() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:30:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSharedMemoryCommunicator Member List

This is the complete list of members for vtkSharedMemoryCommunicator, including all inherited members.
  • AddMessage(vtkSharedMemoryCommunicatorMessage *message) [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Communicators [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAndSetMarshalString(char *str, int strLength) [protected]
  • DeleteMessage(vtkSharedMemoryCommunicatorMessage *message) [protected]
  • FindMessage(int sendId, int tag) [protected]
  • ForceDeepCopy [protected]
  • Gate [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(int nThreads, int forceDeepCopy) [protected]
  • Initialized [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LocalThreadId [protected]
  • MarshalDataLength [protected]
  • MarshalString [protected]
  • MarshalStringLength [protected]
  • MessageListEnd [protected]
  • MessageListLock [protected]
  • MessageListStart [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NewMessage(vtkDataObject *object, void *data, int dataLength) [protected]
  • NewMessage(vtkDataArray *object, void *data, int dataLength) [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkSharedMemoryCommunicator &) (defined in vtkSharedMemoryCommunicator) [private]
  • Parent [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadDataArray(vtkDataArray *object) [protected]
  • ReadDataSet(vtkDataSet *object) [protected]
  • ReadImageData(vtkImageData *object) [protected]
  • ReadObject(vtkDataObject *object) [protected]
  • Receive(int *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(unsigned long *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(char *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(unsigned char *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(float *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(double *data, int length, int remoteThreadId, int tag) [virtual]
  • Receive(vtkDataObject *data, int remoteThreadId, int tag) [virtual]
  • Receive(vtkDataArray *data, int remoteThreadId, int tag) [virtual]
  • Receive(vtkDataObject *object, void *data, int dataLength, int remoteThreadId, int tag) [protected]
  • Receive(vtkDataArray *object, int dataLength, int remoteThreadId, int tag) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(unsigned long *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(char *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(unsigned char *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(float *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(double *data, int length, int remoteThreadId, int tag) [virtual]
  • Send(vtkDataObject *data, int remoteThreadId, int tag) [virtual]
  • Send(vtkDataArray *data, int remoteThreadId, int tag) [virtual]
  • Send(vtkDataObject *object, void *data, int dataLength, int remoteThreadId, int tag) [protected]
  • Send(vtkDataArray *object, int dataLength, int remoteThreadId, int tag) [protected]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SignalNewMessage(vtkSharedMemoryCommunicator *receiveCommunicator) [inline, protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCommunicator() [protected]
  • vtkObject() [protected]
  • vtkSharedMemoryCommunicator() [protected]
  • vtkSharedMemoryCommunicator(const vtkSharedMemoryCommunicator &) (defined in vtkSharedMemoryCommunicator) [private]
  • vtkThreadedController class [friend]
  • vtkTypeRevisionMacro(vtkSharedMemoryCommunicator, vtkObject)
  • WaitForNewMessage() [inline, protected]
  • WaitingForId [protected]
  • WriteDataArray(vtkDataArray *object) [protected]
  • WriteDataSet(vtkDataSet *object) [protected]
  • WriteImageData(vtkImageData *object) [protected]
  • WriteObject(vtkDataObject *object) [protected]
  • ~vtkCommunicator() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSharedMemoryCommunicator() [protected]
Generated on Mon Mar 25 01:30:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkShepardMethod Member List

This is the complete list of members for vtkShepardMethod, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeModelBounds(float origin[3], float ar[3])
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumDistance() [virtual]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNullValue() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumDistance [protected]
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NullValue [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkShepardMethod &) (defined in vtkShepardMethod) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetMaximumDistance(float) [virtual]
  • SetModelBounds(float, float, float, float, float, float) [virtual]
  • SetModelBounds(float[6]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNullValue(float) [virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkShepardMethod() [protected]
  • vtkShepardMethod(const vtkShepardMethod &) (defined in vtkShepardMethod) [private]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkShepardMethod, vtkDataSetToStructuredPointsFilter)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkShepardMethod() [inline, protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:30:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkShortArray Member List

This is the complete list of members for vtkShortArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const short) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const short i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkShortArray &) (defined in vtkShortArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(short *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const short value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkShortArray(vtkIdType numComp=1) [protected]
  • vtkShortArray(const vtkShortArray &) (defined in vtkShortArray) [private]
  • vtkTypeRevisionMacro(vtkShortArray, vtkDataArray)
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkShortArray() [protected]
Generated on Mon Mar 25 01:30:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkShrinkFilter Member List

This is the complete list of members for vtkShrinkFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShrinkFactor() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkShrinkFilter &) (defined in vtkShrinkFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetShrinkFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShrinkFactor [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkShrinkFilter(float sf=0.5) [protected]
  • vtkShrinkFilter(const vtkShrinkFilter &) (defined in vtkShrinkFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkShrinkFilter, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkShrinkFilter() [inline, protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:31:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkShrinkPolyData Member List

This is the complete list of members for vtkShrinkPolyData, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetShrinkFactor() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkShrinkPolyData &) (defined in vtkShrinkPolyData) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetShrinkFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShrinkFactor [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkShrinkPolyData(float sf=0.5) [protected]
  • vtkShrinkPolyData(const vtkShrinkPolyData &) (defined in vtkShrinkPolyData) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkShrinkPolyData, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkShrinkPolyData() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleCriticalSection Member List

This is the complete list of members for vtkSimpleCriticalSection, including all inherited members.
  • CritSec [protected]
  • Delete() [inline]
  • GetClassName() [inline, virtual]
  • Init()
  • IsA(const char *name) [virtual]
  • Lock(void)
  • New() [static]
  • SafeDownCast(vtkSimpleCriticalSection *o) [static]
  • Unlock(void)
  • vtkSimpleCriticalSection() [inline]
  • vtkSimpleCriticalSection(int isLocked) [inline]
  • ~vtkSimpleCriticalSection() [virtual]
Generated on Mon Mar 25 01:31:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleElevationFilter Member List

This is the complete list of members for vtkSimpleElevationFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GetVector() [virtual]
  • GetVector(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSimpleElevationFilter &) (defined in vtkSimpleElevationFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVector(float, float, float) [virtual]
  • SetVector(float[3]) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vector [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSimpleElevationFilter() [protected]
  • vtkSimpleElevationFilter(const vtkSimpleElevationFilter &) (defined in vtkSimpleElevationFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSimpleElevationFilter, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSimpleElevationFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleImageFilterExample Member List

This is the complete list of members for vtkSimpleImageFilterExample, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSimpleImageFilterExample &) (defined in vtkSimpleImageFilterExample) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SimpleExecute(vtkImageData *input, vtkImageData *output) [protected, virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSimpleImageFilterExample() [inline, protected]
  • vtkSimpleImageFilterExample(const vtkSimpleImageFilterExample &) (defined in vtkSimpleImageFilterExample) [private]
  • vtkSimpleImageToImageFilter() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSimpleImageFilterExample, vtkSimpleImageToImageFilter)
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSimpleImageFilterExample() [inline, protected]
  • ~vtkSimpleImageToImageFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleImageToImageFilter Member List

This is the complete list of members for vtkSimpleImageToImageFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtent(int inExt[6], int outExt[6]) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *output) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSimpleImageToImageFilter &) (defined in vtkSimpleImageToImageFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SimpleExecute(vtkImageData *input, vtkImageData *output)=0 [protected, pure virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSimpleImageToImageFilter() [protected]
  • vtkSimpleImageToImageFilter(const vtkSimpleImageToImageFilter &) (defined in vtkSimpleImageToImageFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSimpleImageToImageFilter, vtkImageSource)
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSimpleImageToImageFilter() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleMutexLock Member List

This is the complete list of members for vtkSimpleMutexLock, including all inherited members.
  • Delete() [inline]
  • GetClassName() [inline, virtual]
  • IsA(const char *name) [virtual]
  • Lock(void)
  • MutexLock [protected]
  • New() [static]
  • SafeDownCast(vtkSimpleMutexLock *o) [static]
  • Unlock(void)
  • vtkSimpleMutexLock()
  • ~vtkSimpleMutexLock() [virtual]
Generated on Mon Mar 25 01:31:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSimpleScalarTree Member List

This is the complete list of members for vtkSimpleScalarTree, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BranchingFactor [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • BuildTree() [virtual]
  • CellId (defined in vtkSimpleScalarTree) [private]
  • ChildNumber (defined in vtkSimpleScalarTree) [private]
  • CollectRevisions(ostream &os) [protected, virtual]
  • DataSet [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FindNextLeaf(vtkIdType index, int level) (defined in vtkSimpleScalarTree) [private]
  • FindStartLeaf(vtkIdType index, int level) (defined in vtkSimpleScalarTree) [private]
  • GetBranchingFactor() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataSet() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLevel() [virtual]
  • GetMaxLevel() [virtual]
  • GetMTime() [virtual]
  • GetNextCell(vtkIdType &cellId, vtkIdList *&ptIds, vtkDataArray *cellScalars) [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InitTraversal(float scalarValue) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeafOffset (defined in vtkSimpleScalarTree) [private]
  • Level [protected]
  • MaxLevel [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkSimpleScalarTree &) (defined in vtkSimpleScalarTree) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Scalars [protected]
  • ScalarValue [protected]
  • SetBranchingFactor(int) [virtual]
  • SetDataSet(vtkDataSet *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxLevel(int) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Tree [protected]
  • TreeIndex (defined in vtkSimpleScalarTree) [private]
  • TreeSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkScalarTree() [protected]
  • vtkSimpleScalarTree() [protected]
  • vtkSimpleScalarTree(const vtkSimpleScalarTree &) (defined in vtkSimpleScalarTree) [private]
  • vtkTypeRevisionMacro(vtkSimpleScalarTree, vtkScalarTree)
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarTree() [protected]
  • ~vtkSimpleScalarTree() [protected]
Generated on Mon Mar 25 01:31:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSLCReader Member List

This is the complete list of members for vtkSLCReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname)
  • vtkImageReader2::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Decode8BitData(unsigned char *in_ptr, int size) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Error [protected]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetError() [virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkSLCReader &) (defined in vtkSLCReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSLCReader() [protected]
  • vtkSLCReader(const vtkSLCReader &) (defined in vtkSLCReader) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSLCReader, vtkImageReader2)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSLCReader() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSliceCubes Member List

This is the complete list of members for vtkSliceCubes, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Execute() [protected]
  • FileName [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLimitsFileName() [virtual]
  • GetMTime() [virtual]
  • GetReader() [virtual]
  • GetReferenceCount() [inline]
  • GetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LimitsFileName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkSliceCubes &) (defined in vtkSliceCubes) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Reader [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLimitsFileName(const char *) [virtual]
  • SetReader(vtkVolumeReader *) [virtual]
  • SetReferenceCount(int)
  • SetValue(float) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • Value [protected]
  • vtkObject() [protected]
  • vtkSliceCubes() [protected]
  • vtkSliceCubes(const vtkSliceCubes &) (defined in vtkSliceCubes) [private]
  • vtkTypeRevisionMacro(vtkSliceCubes, vtkObject)
  • Write() [inline]
  • ~vtkObject() [protected, virtual]
  • ~vtkSliceCubes() [protected]
Generated on Mon Mar 25 01:31:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSmoothPolyDataFilter Member List

This is the complete list of members for vtkSmoothPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BoundarySmoothing [protected]
  • BoundarySmoothingOff() [virtual]
  • BoundarySmoothingOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Convergence [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EdgeAngle [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FeatureEdgeSmoothing [protected]
  • FeatureEdgeSmoothingOff() [virtual]
  • FeatureEdgeSmoothingOn() [virtual]
  • GenerateErrorScalars [protected]
  • GenerateErrorScalarsOff() [virtual]
  • GenerateErrorScalarsOn() [virtual]
  • GenerateErrorVectors [protected]
  • GenerateErrorVectorsOff() [virtual]
  • GenerateErrorVectorsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetBoundarySmoothing() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConvergence() [virtual]
  • GetDebug()
  • GetEdgeAngle() [virtual]
  • GetErrorCode() [virtual]
  • GetFeatureAngle() [virtual]
  • GetFeatureEdgeSmoothing() [virtual]
  • GetGenerateErrorScalars() [virtual]
  • GetGenerateErrorVectors() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRelaxationFactor() [virtual]
  • GetReleaseDataFlag() [virtual]
  • GetSource()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSmoothPolyDataFilter &) (defined in vtkSmoothPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RelaxationFactor [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBoundarySmoothing(int) [virtual]
  • SetConvergence(float) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEdgeAngle(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeatureAngle(float) [virtual]
  • SetFeatureEdgeSmoothing(int) [virtual]
  • SetGenerateErrorScalars(int) [virtual]
  • SetGenerateErrorVectors(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRelaxationFactor(float) [virtual]
  • SetReleaseDataFlag(int) [virtual]
  • SetSource(vtkPolyData *source)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SmoothPoints [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSmoothPolyDataFilter() [protected]
  • vtkSmoothPolyDataFilter(const vtkSmoothPolyDataFilter &) (defined in vtkSmoothPolyDataFilter) [private]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkSmoothPolyDataFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSmoothPolyDataFilter() [inline, protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSocketCommunicator Member List

This is the complete list of members for vtkSocketCommunicator, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseConnection() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConnectTo(char *hostName, int port) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAndSetMarshalString(char *str, int strLength) [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetIsConnected() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetSwapBytesInReceivedData() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConnected [protected]
  • IsTypeOf(const char *name) [static]
  • MarshalDataLength [protected]
  • MarshalString [protected]
  • MarshalStringLength [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfProcesses [protected]
  • operator=(const vtkSocketCommunicator &) (defined in vtkSocketCommunicator) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReadDataArray(vtkDataArray *object) [protected]
  • ReadDataSet(vtkDataSet *object) [protected]
  • ReadImageData(vtkImageData *object) [protected]
  • ReadObject(vtkDataObject *object) [protected]
  • Receive(int *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(char *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(float *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(double *data, int length, int remoteProcessId, int tag) [virtual]
  • Receive(vtkDataObject *data, int remoteId, int tag) [inline, virtual]
  • Receive(vtkDataArray *data, int remoteId, int tag) [inline, virtual]
  • ReceiveMessage(char *data, int size, int length, int tag) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(char *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(float *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(double *data, int length, int remoteProcessId, int tag) [virtual]
  • Send(vtkDataObject *data, int remoteId, int tag) [inline, virtual]
  • Send(vtkDataArray *data, int remoteId, int tag) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Socket [protected]
  • SubjectHelper [protected]
  • SwapBytesInReceivedData [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCommunicator() [protected]
  • vtkObject() [protected]
  • vtkSocketCommunicator() [protected]
  • vtkSocketCommunicator(const vtkSocketCommunicator &) (defined in vtkSocketCommunicator) [private]
  • vtkTypeRevisionMacro(vtkSocketCommunicator, vtkCommunicator)
  • WaitForConnection(int port) [virtual]
  • WriteDataArray(vtkDataArray *object) [protected]
  • WriteDataSet(vtkDataSet *object) [protected]
  • WriteImageData(vtkImageData *object) [protected]
  • WriteObject(vtkDataObject *object) [protected]
  • ~vtkCommunicator() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSocketCommunicator() [protected]
Generated on Mon Mar 25 01:31:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSocketController Member List

This is the complete list of members for vtkSocketController, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRMI(vtkRMIFunctionType, void *localArg, int tag)
  • ANY_SOURCE enum value
  • Barrier() [inline, virtual]
  • BREAK_RMI_TAG enum value
  • BreakFlag [protected]
  • BreakOnError() [static]
  • CloseConnection() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Communicator [protected]
  • ConnectTo(char *hostName, int port) [inline, virtual]
  • Consts enum name
  • CreateOutputWindow() [inline, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ENDIAN_TAG enum value
  • Finalize() [inline, virtual]
  • ForceDeepCopy [protected]
  • ForceDeepCopyOff() [virtual]
  • ForceDeepCopyOn() [virtual]
  • GetBreakFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCommunicator() [virtual]
  • GetDebug()
  • GetForceDeepCopy() [virtual]
  • GetGlobalController() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocalController() [protected, virtual]
  • GetLocalProcessId() [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfProcesses() [virtual]
  • GetReferenceCount() [inline]
  • GetSwapBytesInReceivedData() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(int *, char ***) [virtual]
  • Initialize() [inline, virtual]
  • vtkMultiProcessController::Initialize(int *vtkNotUsed(argc), char ***vtkNotUsed(arcv))=0 [pure virtual]
  • Initialized [protected, static]
  • INVALID_SOURCE enum value
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LocalProcessId [protected]
  • MAX_PROCESSES enum value
  • MaximumNumberOfProcesses [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultipleData [protected]
  • MultipleMethod [protected]
  • MultipleMethodExecute() [inline, virtual]
  • New() [static]
  • NumberOfProcesses [protected]
  • operator=(const vtkSocketController &) (defined in vtkSocketController) [private]
  • OutputWindow [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessRMI(int remoteProcessId, void *arg, int argLength, int rmiTag) [protected]
  • ProcessRMIs()
  • Receive(int *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(float *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(double *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(vtkDataObject *data, int remoteId, int tag) [inline]
  • Receive(vtkDataArray *data, int remoteId, int tag) [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRMI(vtkRMIFunctionType f, void *arg, int tag) [inline]
  • RMI_ARG_TAG enum value
  • RMI_TAG enum value
  • RMICommunicator [protected]
  • RMIs [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Send(char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(float *data, int length, int remoteProcessId, int tag) [inline]
  • Send(double *data, int length, int remoteProcessId, int tag) [inline]
  • Send(vtkDataObject *data, int remoteId, int tag) [inline]
  • Send(vtkDataArray *data, int remoteId, int tag) [inline]
  • SetBreakFlag(int) [virtual]
  • SetCommunicator(vtkSocketCommunicator *comm)
  • SetDebug(unsigned char debugFlag)
  • SetForceDeepCopy(int) [virtual]
  • SetGlobalController(vtkMultiProcessController *controller) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMultipleMethod(int index, vtkProcessFunctionType, void *data)
  • SetNumberOfProcesses(int num) [virtual]
  • SetReferenceCount(int)
  • SetSingleMethod(vtkProcessFunctionType, void *data)
  • SingleData [protected]
  • SingleMethod [protected]
  • SingleMethodExecute() [inline, virtual]
  • SubjectHelper [protected]
  • TriggerBreakRMIs()
  • TriggerRMI(int remoteProcessId, void *arg, int argLength, int tag)
  • TriggerRMI(int remoteProcessId, char *arg, int tag) [inline]
  • TriggerRMI(int remoteProcessId, int tag) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMultiProcessController() [protected]
  • vtkObject() [protected]
  • vtkSocketController() [protected]
  • vtkSocketController(const vtkSocketController &) (defined in vtkSocketController) [private]
  • vtkTypeRevisionMacro(vtkSocketController, vtkMultiProcessController)
  • WaitForConnection(int port) [inline, virtual]
  • ~vtkMultiProcessController() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSocketController() [protected]
Generated on Mon Mar 25 01:31:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSource Member List

This is the complete list of members for vtkSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • ErrorCode (defined in vtkSource) [private]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int idx) [protected]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSource &) (defined in vtkSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSource(const vtkSource &) (defined in vtkSource) [private]
  • vtkTypeRevisionMacro(vtkSource, vtkProcessObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
Generated on Mon Mar 25 01:31:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSpatialRepresentationFilter Member List

This is the complete list of members for vtkSpatialRepresentationFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateOutput() [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLevel() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput(int level)
  • GetOutput()
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSpatialRepresentation() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Level [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSpatialRepresentationFilter &) (defined in vtkSpatialRepresentationFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • ResetOutput()
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSpatialRepresentation(vtkLocator *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpatialRepresentation [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TerminalNodesRequested [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSpatialRepresentationFilter() [protected]
  • vtkSpatialRepresentationFilter(const vtkSpatialRepresentationFilter &) (defined in vtkSpatialRepresentationFilter) [private]
  • vtkTypeRevisionMacro(vtkSpatialRepresentationFilter, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSpatialRepresentationFilter() [protected]
Generated on Mon Mar 25 01:31:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSphere Member List

This is the complete list of members for vtkSphere, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float n[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkSphere &) (defined in vtkSphere) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkSphere() [protected]
  • vtkSphere(const vtkSphere &) (defined in vtkSphere) [private]
  • vtkTypeRevisionMacro(vtkSphere, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSphere() [inline, protected]
Generated on Mon Mar 25 01:31:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSpherePuzzle Member List

This is the complete list of members for vtkSpherePuzzle, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • Active [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Colors [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetState() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MarkHorizontal(int section) [protected]
  • MarkVertical(int section) [protected]
  • Modified() [virtual]
  • MoveHorizontal(int section, int percentage, int rightFlag)
  • MovePoint(int percentage)
  • MoveVertical(int section, int percentage, int rightFlag)
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSpherePuzzle &) [protected]
  • Outputs [protected]
  • PieceMask [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Reset()
  • RightFlag [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Section [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPoint(float x, float y, float z)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • State [protected]
  • SubjectHelper [protected]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VerticalFlag [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSpherePuzzle() [protected]
  • vtkSpherePuzzle(const vtkSpherePuzzle &) [protected]
  • vtkTypeRevisionMacro(vtkSpherePuzzle, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSpherePuzzle() [protected]
Generated on Mon Mar 25 01:31:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSpherePuzzleArrows Member List

This is the complete list of members for vtkSpherePuzzleArrows, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AppendArrow(int id0, int id1, vtkPoints *pts, vtkCellArray *polys) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPermutation() [virtual]
  • GetPermutation(int data[32]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSpherePuzzleArrows &) [protected]
  • Outputs [protected]
  • Permutation [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPermutation(int data[]) [virtual]
  • SetPermutation(vtkSpherePuzzle *puz) [inline]
  • SetPermutationComponent(int comp, int val)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSpherePuzzleArrows() [protected]
  • vtkSpherePuzzleArrows(const vtkSpherePuzzleArrows &) [protected]
  • vtkTypeRevisionMacro(vtkSpherePuzzleArrows, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSpherePuzzleArrows() [protected]
Generated on Mon Mar 25 01:31:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSphereSource Member List

This is the complete list of members for vtkSphereSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndPhi [protected]
  • EndTag [protected]
  • EndTheta [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEndPhi() [virtual]
  • GetEndTheta() [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLatLongTessellation() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPhiResolution() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStartPhi() [virtual]
  • GetStartTheta() [virtual]
  • GetThetaResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LatLongTessellation [protected]
  • LatLongTessellationOff() [virtual]
  • LatLongTessellationOn() [virtual]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSphereSource &) (defined in vtkSphereSource) [private]
  • Outputs [protected]
  • PhiResolution [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetEndPhi(float) [virtual]
  • SetEndTheta(float) [virtual]
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLatLongTessellation(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPhiResolution(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPhi(float) [virtual]
  • SetStartTheta(float) [virtual]
  • SetThetaResolution(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartPhi [protected]
  • StartTag [protected]
  • StartTheta [protected]
  • SubjectHelper [protected]
  • ThetaResolution [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSphereSource(int res=8) [protected]
  • vtkSphereSource(const vtkSphereSource &) (defined in vtkSphereSource) [private]
  • vtkTypeRevisionMacro(vtkSphereSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSphereSource() [inline, protected]
Generated on Mon Mar 25 01:31:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSpline Member List

This is the complete list of members for vtkSpline, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPoint(float t, float x)
  • BreakOnError() [static]
  • ClampValue [protected]
  • ClampValueOff() [virtual]
  • ClampValueOn() [virtual]
  • Closed [protected]
  • ClosedOff() [virtual]
  • ClosedOn() [virtual]
  • Coefficients [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Compute()=0 [pure virtual]
  • ComputeTime [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClampValue() [virtual]
  • GetClassName() [inline, virtual]
  • GetClosed() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLeftConstraint() [virtual]
  • GetLeftValue() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRightConstraint() [virtual]
  • GetRightValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Intervals [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LeftConstraint [protected]
  • LeftValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkSpline &) (defined in vtkSpline) [private]
  • PiecewiseFunction [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllPoints()
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemovePoint(float t)
  • RightConstraint [protected]
  • RightValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetClampValue(int) [virtual]
  • SetClosed(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLeftConstraint(int) [virtual]
  • SetLeftValue(float) [virtual]
  • SetReferenceCount(int)
  • SetRightConstraint(int) [virtual]
  • SetRightValue(float) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkSpline() [protected]
  • vtkSpline(const vtkSpline &) (defined in vtkSpline) [private]
  • vtkTypeRevisionMacro(vtkSpline, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkSpline() [protected]
Generated on Mon Mar 25 01:31:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSplitField Member List

This is the complete list of members for vtkSplitField, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddComponent(Component *op) [protected]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • ATTRIBUTE enum value [protected]
  • AttributeNames [protected, static]
  • AttributeType [protected]
  • BreakOnError() [static]
  • CELL_DATA enum value
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • DATA_OBJECT enum value
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteAllComponents() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldLocation [protected]
  • FieldLocationNames [protected, static]
  • FieldLocations enum name
  • FieldName [protected]
  • FieldType [protected]
  • FieldTypes enum name [protected]
  • FindComponent(int index) [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFirst() [inline, protected]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNextComponent(Component *op) [inline, protected]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Head [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • NAME enum value [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSplitField &) (defined in vtkSplitField) [private]
  • Outputs [protected]
  • POINT_DATA enum value
  • Print(ostream &os)
  • PrintAllComponents(ostream &os, vtkIndent indent) [inline, protected]
  • PrintComponent(Component *op, ostream &os, vtkIndent indent) [inline, protected]
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetInputField(int attributeType, int fieldLoc)
  • SetInputField(const char *name, int fieldLoc)
  • SetInputField(const char *name, const char *fieldLoc)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Split(int component, const char *arrayName)
  • SplitArray(vtkDataArray *da, int component) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tail [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSplitField() [protected]
  • vtkSplitField(const vtkSplitField &) (defined in vtkSplitField) [private]
  • vtkTypeRevisionMacro(vtkSplitField, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSplitField() [protected, virtual]
Generated on Mon Mar 25 01:31:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSTLReader Member List

This is the complete list of members for vtkSTLReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMerging() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarTags() [virtual]
  • GetSTLFileType(FILE *fp) [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Merging [protected]
  • MergingOff() [virtual]
  • MergingOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSTLReader &) (defined in vtkSTLReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadASCIISTL(FILE *fp, vtkPoints *, vtkCellArray *, vtkFloatArray *scalars=0) [protected]
  • ReadBinarySTL(FILE *fp, vtkPoints *, vtkCellArray *) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarTags [protected]
  • ScalarTagsOff() [virtual]
  • ScalarTagsOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocator(vtkPointLocator *locator)
  • SetMerging(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarTags(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSTLReader() [protected]
  • vtkSTLReader(const vtkSTLReader &) (defined in vtkSTLReader) [private]
  • vtkTypeRevisionMacro(vtkSTLReader, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSTLReader() [protected]
Generated on Mon Mar 25 01:31:23 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSTLWriter Member List

This is the complete list of members for vtkSTLWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkSTLWriter &) (defined in vtkSTLWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkPolyData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataWriter() [inline, protected]
  • vtkProcessObject() [protected]
  • vtkSTLWriter() [protected]
  • vtkSTLWriter(const vtkSTLWriter &) (defined in vtkSTLWriter) [private]
  • vtkTypeRevisionMacro(vtkSTLWriter, vtkPolyDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteAsciiSTL(vtkPoints *pts, vtkCellArray *polys) [protected]
  • WriteBinarySTL(vtkPoints *pts, vtkCellArray *polys) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataWriter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSTLWriter() [inline, protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:31:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStreamArray Member List

This is the complete list of members for vtkStreamArray, including all inherited members.
  • Array
  • Direction
  • Extend
  • GetNumberOfPoints() [inline]
  • GetStreamPoint(vtkIdType i) [inline]
  • InsertNextStreamPoint() [inline]
  • MaxId
  • Reset() [inline]
  • Resize(vtkIdType sz)
  • Size
  • vtkStreamArray()
  • ~vtkStreamArray() [inline]
Generated on Mon Mar 25 01:31:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStreamer Member List

This is the complete list of members for vtkStreamer, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeVorticity() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetIntegrationDirection() [virtual]
  • GetIntegrationDirectionAsString() [inline]
  • GetIntegrationStepLength() [virtual]
  • GetIntegrator() [virtual]
  • GetMaximumPropagationTime() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamers() [protected, virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrientationScalars() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSavePointInterval() [virtual]
  • GetSource()
  • GetSpeedScalars() [virtual]
  • GetStartLocation(int &subId, float pcoords[3])
  • GetStartPosition()
  • GetStreamers() [inline, protected]
  • GetTerminalSpeed() [virtual]
  • GetVorticity() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeThreadedIntegrate() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Integrate() [protected]
  • IntegrationDirection [protected]
  • IntegrationStepLength [protected]
  • Integrator [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumPropagationTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamers [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkStreamer &) (defined in vtkStreamer) [private]
  • OrientationScalars [protected]
  • OrientationScalarsOff() [virtual]
  • OrientationScalarsOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavePointInterval [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetIntegrationDirection(int) [virtual]
  • SetIntegrationDirectionToBackward() [inline]
  • SetIntegrationDirectionToForward() [inline]
  • SetIntegrationDirectionToIntegrateBothDirections() [inline]
  • SetIntegrationStepLength(float) [virtual]
  • SetIntegrator(vtkInitialValueProblemSolver *) [virtual]
  • SetMaximumPropagationTime(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrientationScalars(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSavePointInterval(float) [virtual]
  • SetSource(vtkDataSet *source)
  • SetSpeedScalars(int) [virtual]
  • SetStartLocation(vtkIdType cellId, int subId, float pcoords[3])
  • SetStartLocation(vtkIdType cellId, int subId, float r, float s, float t)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPosition(float x[3])
  • SetStartPosition(float x, float y, float z)
  • SetTerminalSpeed(float) [virtual]
  • SetVorticity(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpeedScalars [protected]
  • SpeedScalarsOff() [virtual]
  • SpeedScalarsOn() [virtual]
  • SqueezeInputArray()
  • StartCell [protected]
  • StartFrom [protected]
  • StartPCoords [protected]
  • StartPosition [protected]
  • StartSubId [protected]
  • StartTag [protected]
  • Streamers [protected]
  • SubjectHelper [protected]
  • TerminalSpeed [protected]
  • ThreadedIntegrate(void *arg) [protected, static]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vorticity [protected]
  • VorticityOff() [virtual]
  • VorticityOn() [virtual]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStreamer() [protected]
  • vtkStreamer(const vtkStreamer &) (defined in vtkStreamer) [private]
  • vtkTypeRevisionMacro(vtkStreamer, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStreamer() [protected]
Generated on Mon Mar 25 01:31:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStreamLine Member List

This is the complete list of members for vtkStreamLine, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeVorticity() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetIntegrationDirection() [virtual]
  • GetIntegrationDirectionAsString() [inline]
  • GetIntegrationStepLength() [virtual]
  • GetIntegrator() [virtual]
  • GetMaximumPropagationTime() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamers() [protected, virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrientationScalars() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSavePointInterval() [virtual]
  • GetSource()
  • GetSpeedScalars() [virtual]
  • GetStartLocation(int &subId, float pcoords[3])
  • GetStartPosition()
  • GetStepLength() [virtual]
  • GetStreamers() [inline, protected]
  • GetTerminalSpeed() [virtual]
  • GetVorticity() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeThreadedIntegrate() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Integrate() [protected]
  • IntegrationDirection [protected]
  • IntegrationStepLength [protected]
  • Integrator [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumPropagationTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamers [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkStreamLine &) (defined in vtkStreamLine) [private]
  • OrientationScalars [protected]
  • OrientationScalarsOff() [virtual]
  • OrientationScalarsOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavePointInterval [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetIntegrationDirection(int) [virtual]
  • SetIntegrationDirectionToBackward() [inline]
  • SetIntegrationDirectionToForward() [inline]
  • SetIntegrationDirectionToIntegrateBothDirections() [inline]
  • SetIntegrationStepLength(float) [virtual]
  • SetIntegrator(vtkInitialValueProblemSolver *) [virtual]
  • SetMaximumPropagationTime(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrientationScalars(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSavePointInterval(float) [virtual]
  • SetSource(vtkDataSet *source)
  • SetSpeedScalars(int) [virtual]
  • SetStartLocation(vtkIdType cellId, int subId, float pcoords[3])
  • SetStartLocation(vtkIdType cellId, int subId, float r, float s, float t)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPosition(float x[3])
  • SetStartPosition(float x, float y, float z)
  • SetStepLength(float) [virtual]
  • SetTerminalSpeed(float) [virtual]
  • SetVorticity(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpeedScalars [protected]
  • SpeedScalarsOff() [virtual]
  • SpeedScalarsOn() [virtual]
  • SqueezeInputArray()
  • StartCell [protected]
  • StartFrom [protected]
  • StartPCoords [protected]
  • StartPosition [protected]
  • StartSubId [protected]
  • StartTag [protected]
  • StepLength [protected]
  • Streamers [protected]
  • SubjectHelper [protected]
  • TerminalSpeed [protected]
  • ThreadedIntegrate(void *arg) [protected, static]
  • Threader [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vorticity [protected]
  • VorticityOff() [virtual]
  • VorticityOn() [virtual]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStreamer() [protected]
  • vtkStreamLine() [protected]
  • vtkStreamLine(const vtkStreamLine &) (defined in vtkStreamLine) [private]
  • vtkTypeRevisionMacro(vtkStreamLine, vtkStreamer)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStreamer() [protected]
  • ~vtkStreamLine() [inline, protected]
Generated on Mon Mar 25 01:31:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStreamPoints Member List

This is the complete list of members for vtkStreamPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeVorticity() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetIntegrationDirection() [virtual]
  • GetIntegrationDirectionAsString() [inline]
  • GetIntegrationStepLength() [virtual]
  • GetIntegrator() [virtual]
  • GetMaximumPropagationTime() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfStreamers() [protected, virtual]
  • GetNumberOfThreads() [virtual]
  • GetOrientationScalars() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSavePointInterval() [virtual]
  • GetSource()
  • GetSpeedScalars() [virtual]
  • GetStartLocation(int &subId, float pcoords[3])
  • GetStartPosition()
  • GetStreamers() [inline, protected]
  • GetTerminalSpeed() [virtual]
  • GetTimeIncrement() [virtual]
  • GetVorticity() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • InitializeThreadedIntegrate() [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • Integrate() [protected]
  • IntegrationDirection [protected]
  • IntegrationStepLength [protected]
  • Integrator [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumPropagationTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfStreamers [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkStreamPoints &) (defined in vtkStreamPoints) [private]
  • OrientationScalars [protected]
  • OrientationScalarsOff() [virtual]
  • OrientationScalarsOn() [virtual]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavePointInterval [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetIntegrationDirection(int) [virtual]
  • SetIntegrationDirectionToBackward() [inline]
  • SetIntegrationDirectionToForward() [inline]
  • SetIntegrationDirectionToIntegrateBothDirections() [inline]
  • SetIntegrationStepLength(float) [virtual]
  • SetIntegrator(vtkInitialValueProblemSolver *) [virtual]
  • SetMaximumPropagationTime(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOrientationScalars(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSavePointInterval(float) [virtual]
  • SetSource(vtkDataSet *source)
  • SetSpeedScalars(int) [virtual]
  • SetStartLocation(vtkIdType cellId, int subId, float pcoords[3])
  • SetStartLocation(vtkIdType cellId, int subId, float r, float s, float t)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartPosition(float x[3])
  • SetStartPosition(float x, float y, float z)
  • SetTerminalSpeed(float) [virtual]
  • SetTimeIncrement(float) [virtual]
  • SetVorticity(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SpeedScalars [protected]
  • SpeedScalarsOff() [virtual]
  • SpeedScalarsOn() [virtual]
  • SqueezeInputArray()
  • StartCell [protected]
  • StartFrom [protected]
  • StartPCoords [protected]
  • StartPosition [protected]
  • StartSubId [protected]
  • StartTag [protected]
  • Streamers [protected]
  • SubjectHelper [protected]
  • TerminalSpeed [protected]
  • ThreadedIntegrate(void *arg) [protected, static]
  • Threader [protected]
  • TimeIncrement [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Vorticity [protected]
  • VorticityOff() [virtual]
  • VorticityOn() [virtual]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStreamer() [protected]
  • vtkStreamPoints() [protected]
  • vtkStreamPoints(const vtkStreamPoints &) (defined in vtkStreamPoints) [private]
  • vtkTypeRevisionMacro(vtkStreamPoints, vtkStreamer)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStreamer() [protected]
  • ~vtkStreamPoints() [inline, protected]
Generated on Mon Mar 25 01:31:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStripper Member List

This is the complete list of members for vtkStripper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumLength() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumLength [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStripper &) (defined in vtkStripper) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMaximumLength(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStripper() [protected]
  • vtkStripper(const vtkStripper &) (defined in vtkStripper) [private]
  • vtkTypeRevisionMacro(vtkStripper, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStripper() [inline, protected]
Generated on Mon Mar 25 01:31:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredData Member List

This is the complete list of members for vtkStructuredData, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeCellId(int dim[3], int ijk[3]) [inline, static]
  • ComputePointId(int dim[3], int ijk[3]) [inline, static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetCellNeigbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds, int dim[3]) [static]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds, int dataDescription, int dim[3]) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataDimension(int dataDescription) [static]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds, int dim[3]) [static]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkStructuredData &) (defined in vtkStructuredData) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetDimensions(int inDim[3], int dim[3]) [static]
  • SetExtent(int inExt[6], int ext[6]) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkStructuredData() [inline, protected]
  • vtkStructuredData(const vtkStructuredData &) (defined in vtkStructuredData) [private]
  • vtkTypeRevisionMacro(vtkStructuredData, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkStructuredData() [inline, protected]
Generated on Mon Mar 25 01:31:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGrid Member List

This is the complete list of members for vtkStructuredGrid, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatePointVisibility() [protected]
  • Blanking [protected]
  • BlankingOff()
  • BlankingOn()
  • BlankPoint(vtkIdType ptId)
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataDescription [protected]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Dimensions [protected]
  • EmptyCell [protected]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x[3]) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • GetActualMemorySize() [virtual]
  • GetBlanking() [inline]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList &ptIds, vtkIdList &cellIds) (defined in vtkStructuredGrid) [inline, private]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [virtual]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataDimension() [inline]
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetDimensions() [virtual]
  • GetDimensions(int dim[3]) [virtual]
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize() [inline, virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [virtual]
  • GetNumberOfCells() [inline, virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [inline, virtual]
  • GetPoint(vtkIdType ptId, float p[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [inline, virtual]
  • GetPointData() [inline]
  • GetPoints() [virtual]
  • GetPointVisibility() [inline]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange() [inline]
  • GetSource() [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Hexahedron [protected]
  • Initialize() [virtual]
  • InternalStructuredGridCopy(vtkStructuredGrid *src) (defined in vtkStructuredGrid) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsCellVisible(vtkIdType cellId)
  • IsConsumer(vtkObject *c)
  • IsPointVisible(vtkIdType ptId) [inline]
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Locality [protected]
  • Locator [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkStructuredGrid &) (defined in vtkStructuredGrid) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • Points [protected]
  • PointVisibility [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetBlanking(int blanking)
  • SetDebug(unsigned char debugFlag)
  • SetDimensions(int i, int j, int k)
  • SetDimensions(int dim[3])
  • SetExtent(int extent[6])
  • SetExtent(int x1, int x2, int y1, int y2, int z1, int z2)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetPoints(vtkPoints *) [virtual]
  • SetPointVisibility(vtkUnsignedCharArray *pointVisibility)
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkPointSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnBlankPoint(vtkIdType ptId)
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkObject() [protected]
  • vtkPointSet() [protected]
  • vtkStructuredGrid() [protected]
  • vtkStructuredGrid(const vtkStructuredGrid &) (defined in vtkStructuredGrid) [private]
  • vtkTypeRevisionMacro(vtkStructuredGrid, vtkPointSet)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSet() [protected]
  • ~vtkStructuredGrid() [protected]
Generated on Mon Mar 25 01:31:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridGeometryFilter Member List

This is the complete list of members for vtkStructuredGridGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Extent [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int data[6]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredGridGeometryFilter &) (defined in vtkStructuredGridGeometryFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
  • SetExtent(int extent[6])
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridGeometryFilter() [protected]
  • vtkStructuredGridGeometryFilter(const vtkStructuredGridGeometryFilter &) (defined in vtkStructuredGridGeometryFilter) [private]
  • vtkStructuredGridToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkStructuredGridGeometryFilter, vtkStructuredGridToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridGeometryFilter() [inline, protected]
  • ~vtkStructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:31:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridOutlineFilter Member List

This is the complete list of members for vtkStructuredGridOutlineFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredGridOutlineFilter &) (defined in vtkStructuredGridOutlineFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridOutlineFilter() [inline, protected]
  • vtkStructuredGridOutlineFilter(const vtkStructuredGridOutlineFilter &) (defined in vtkStructuredGridOutlineFilter) [private]
  • vtkStructuredGridToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkStructuredGridOutlineFilter, vtkStructuredGridToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridOutlineFilter() [inline, protected]
  • ~vtkStructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:31:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridReader Member List

This is the complete list of members for vtkStructuredGridReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkStructuredGridReader &) (defined in vtkStructuredGridReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridReader() [protected]
  • vtkStructuredGridReader(const vtkStructuredGridReader &) (defined in vtkStructuredGridReader) [private]
  • vtkTypeRevisionMacro(vtkStructuredGridReader, vtkDataReader)
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridReader() [protected]
Generated on Mon Mar 25 01:31:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridSource Member List

This is the complete list of members for vtkStructuredGridSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredGridSource &) (defined in vtkStructuredGridSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkStructuredGridSource(const vtkStructuredGridSource &) (defined in vtkStructuredGridSource) [private]
  • vtkTypeRevisionMacro(vtkStructuredGridSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:31:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridToPolyDataFilter Member List

This is the complete list of members for vtkStructuredGridToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredGridToPolyDataFilter &) (defined in vtkStructuredGridToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridToPolyDataFilter() [inline, protected]
  • vtkStructuredGridToPolyDataFilter(const vtkStructuredGridToPolyDataFilter &) (defined in vtkStructuredGridToPolyDataFilter) [private]
  • vtkTypeRevisionMacro(vtkStructuredGridToPolyDataFilter, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:31:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridToStructuredGridFilter Member List

This is the complete list of members for vtkStructuredGridToStructuredGridFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredGridToStructuredGridFilter &) (defined in vtkStructuredGridToStructuredGridFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkStructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredGridSource() [protected]
  • vtkStructuredGridToStructuredGridFilter() [inline, protected]
  • vtkStructuredGridToStructuredGridFilter(const vtkStructuredGridToStructuredGridFilter &) (defined in vtkStructuredGridToStructuredGridFilter) [private]
  • vtkTypeRevisionMacro(vtkStructuredGridToStructuredGridFilter, vtkStructuredGridSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredGridSource() [inline, protected]
  • ~vtkStructuredGridToStructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:31:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredGridWriter Member List

This is the complete list of members for vtkStructuredGridWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkStructuredGridWriter &) (defined in vtkStructuredGridWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkStructuredGrid *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkStructuredGridWriter() [inline, protected]
  • vtkStructuredGridWriter(const vtkStructuredGridWriter &) (defined in vtkStructuredGridWriter) [private]
  • vtkTypeRevisionMacro(vtkStructuredGridWriter, vtkDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteBlanking(ostream *fp, vtkStructuredGrid *ds) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkStructuredGridWriter() [inline, protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:31:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPoints Member List

This is the complete list of members for vtkStructuredPoints, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateScalars()
  • Bounds [protected]
  • BreakOnError() [static]
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeCellId(int ijk[3]) [inline]
  • ComputeIncrements() [protected]
  • ComputePointId(int ijk[3]) [inline]
  • ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3])
  • ComputeTime [protected]
  • Consumers [protected]
  • CopyAndCastFrom(vtkImageData *inData, int extent[6])
  • CopyAndCastFrom(vtkImageData *inData, int x0, int x1, int y0, int y1, int z0, int z1) [inline]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *image) [virtual]
  • Crop() [virtual]
  • DATA_OBJECT_FIELD enum value
  • DataDescription [protected]
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Dimensions [protected]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • FindPoint(float x[3]) [virtual]
  • GetActualMemorySize() [virtual]
  • GetArrayIncrements(vtkDataArray *array, int increments[3])
  • GetArrayPointer(vtkDataArray *array, int coordinates[3])
  • GetArrayPointerForExtent(vtkDataArray *array, int extent[6])
  • GetAxisUpdateExtent(int axis, int &min, int &max)
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [inline, virtual]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetContinuousIncrements(int extent[6], int &incX, int &incY, int &incZ)
  • GetDataDimension() [inline]
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetDimensions()
  • GetDimensions(int dims[3])
  • GetEstimatedMemorySize() [virtual]
  • GetExtent() [virtual]
  • GetExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetExtent(int[6]) [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetIncrements()
  • GetIncrements(int &incX, int &incY, int &incZ)
  • GetIncrements(int inc[3])
  • GetLength()
  • GetLocality() [virtual]
  • GetMaxCellSize() [inline, virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [inline, virtual]
  • GetNumberOfCells() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float &, float &, float &) [virtual]
  • GetOrigin(float[3]) [virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [virtual]
  • GetPoint(vtkIdType id, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [inline, virtual]
  • GetPointData() [inline]
  • GetPointGradient(int i, int j, int k, vtkDataArray *s, float g[3])
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarComponentAsFloat(int x, int y, int z, int component)
  • GetScalarPointer(int coordinates[3])
  • GetScalarPointer(int x, int y, int z)
  • GetScalarPointer()
  • GetScalarPointerForExtent(int extent[6])
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetScalarSize()
  • GetScalarType()
  • GetScalarTypeAsString() [inline]
  • GetScalarTypeMax()
  • GetScalarTypeMin()
  • GetSource() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float &, float &, float &) [virtual]
  • GetSpacing(float[3]) [virtual]
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetVoxelGradient(int i, int j, int k, vtkDataArray *s, vtkDataArray *g)
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Increments [protected]
  • Initialize() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Locality [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • NumberOfScalarComponents [protected]
  • operator=(const vtkStructuredPoints &) (defined in vtkStructuredPoints) [private]
  • Origin [protected]
  • Piece [protected]
  • PipelineMTime [protected]
  • Pixel [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • PrepareForNewData() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • ScalarType [protected]
  • SetAxisUpdateExtent(int axis, int min, int max)
  • SetDebug(unsigned char debugFlag)
  • SetDimensions(int i, int j, int k)
  • SetDimensions(int dims[3])
  • SetExtent(int extent[6])
  • SetExtent(int x1, int x2, int y1, int y2, int z1, int z2)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetNumberOfScalarComponents(int n)
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetScalarType(int) [virtual]
  • SetScalarTypeToChar() [inline]
  • SetScalarTypeToDouble() [inline]
  • SetScalarTypeToFloat() [inline]
  • SetScalarTypeToInt() [inline]
  • SetScalarTypeToLong() [inline]
  • SetScalarTypeToShort() [inline]
  • SetScalarTypeToUnsignedChar() [inline]
  • SetScalarTypeToUnsignedInt() [inline]
  • SetScalarTypeToUnsignedLong() [inline]
  • SetScalarTypeToUnsignedShort() [inline]
  • SetSource(vtkSource *s)
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkDataSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Spacing [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Voxel [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkImageData() [protected]
  • vtkObject() [protected]
  • vtkStructuredPoints() [protected]
  • vtkStructuredPoints(const vtkStructuredPoints &) (defined in vtkStructuredPoints) [private]
  • vtkTypeRevisionMacro(vtkStructuredPoints, vtkImageData)
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkImageData() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkStructuredPoints() [inline, protected]
Generated on Mon Mar 25 01:31:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsCollection Member List

This is the complete list of members for vtkStructuredPointsCollection, including all inherited members.
  • AddItem(vtkStructuredPoints *ds) [inline]
  • AddItem(vtkObject *o) (defined in vtkStructuredPointsCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkStructuredPointsCollection &) (defined in vtkStructuredPointsCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkStructuredPointsCollection() [inline, protected]
  • vtkStructuredPointsCollection(const vtkStructuredPointsCollection &) (defined in vtkStructuredPointsCollection) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkStructuredPointsCollection() [inline, protected]
Generated on Mon Mar 25 01:31:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsGeometryFilter Member List

This is the complete list of members for vtkStructuredPointsGeometryFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • Extent [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtent() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredPointsGeometryFilter &) [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtent(int extent[6])
  • SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageDataGeometryFilter() [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsGeometryFilter() [protected]
  • vtkStructuredPointsGeometryFilter(const vtkStructuredPointsGeometryFilter &) [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkTypeRevisionMacro(vtkStructuredPointsGeometryFilter, vtkImageDataGeometryFilter)
  • ~vtkImageDataGeometryFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsGeometryFilter() [inline, protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:31:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsReader Member List

This is the complete list of members for vtkStructuredPointsReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput(int idx) [inline]
  • GetOutput()
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkStructuredPointsReader &) (defined in vtkStructuredPointsReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsReader() [protected]
  • vtkStructuredPointsReader(const vtkStructuredPointsReader &) (defined in vtkStructuredPointsReader) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsReader, vtkDataReader)
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsReader() [protected]
Generated on Mon Mar 25 01:31:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsSource Member List

This is the complete list of members for vtkStructuredPointsSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredPointsSource &) (defined in vtkStructuredPointsSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkStructuredPointsSource(const vtkStructuredPointsSource &) (defined in vtkStructuredPointsSource) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsSource, vtkSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
Generated on Mon Mar 25 01:31:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsToPolyDataFilter Member List

This is the complete list of members for vtkStructuredPointsToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredPointsToPolyDataFilter &) (defined in vtkStructuredPointsToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToPolyDataFilter() [inline, protected]
  • vtkStructuredPointsToPolyDataFilter(const vtkStructuredPointsToPolyDataFilter &) (defined in vtkStructuredPointsToPolyDataFilter) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsToPolyDataFilter, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:31:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsToStructuredPointsFilter Member List

This is the complete list of members for vtkStructuredPointsToStructuredPointsFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredPointsToStructuredPointsFilter &) (defined in vtkStructuredPointsToStructuredPointsFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
  • vtkStructuredPointsToStructuredPointsFilter(const vtkStructuredPointsToStructuredPointsFilter &) (defined in vtkStructuredPointsToStructuredPointsFilter) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsToStructuredPointsFilter, vtkStructuredPointsSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
Generated on Mon Mar 25 01:31:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsToUnstructuredGridFilter Member List

This is the complete list of members for vtkStructuredPointsToUnstructuredGridFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkStructuredPointsToUnstructuredGridFilter &) (defined in vtkStructuredPointsToUnstructuredGridFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsToUnstructuredGridFilter() [inline, protected]
  • vtkStructuredPointsToUnstructuredGridFilter(const vtkStructuredPointsToUnstructuredGridFilter &) (defined in vtkStructuredPointsToUnstructuredGridFilter) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsToUnstructuredGridFilter, vtkUnstructuredGridSource)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsToUnstructuredGridFilter() [inline, protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:31:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkStructuredPointsWriter Member List

This is the complete list of members for vtkStructuredPointsWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkStructuredPointsWriter &) (defined in vtkStructuredPointsWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkImageData *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkStructuredPointsWriter() [inline, protected]
  • vtkStructuredPointsWriter(const vtkStructuredPointsWriter &) (defined in vtkStructuredPointsWriter) [private]
  • vtkTypeRevisionMacro(vtkStructuredPointsWriter, vtkDataWriter)
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkStructuredPointsWriter() [inline, protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:31:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSubdivideTetra Member List

This is the complete list of members for vtkSubdivideTetra, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSubdivideTetra &) (defined in vtkSubdivideTetra) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSubdivideTetra() [protected]
  • vtkSubdivideTetra(const vtkSubdivideTetra &) (defined in vtkSubdivideTetra) [private]
  • vtkTypeRevisionMacro(vtkSubdivideTetra, vtkUnstructuredGridToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSubdivideTetra() [inline, protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
  • ~vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:31:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSubPixelPositionEdgels Member List

This is the complete list of members for vtkSubPixelPositionEdgels, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradMaps()
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTargetFlag() [virtual]
  • GetTargetValue() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • Move(int xdim, int ydim, int zdim, int x, int y, float *img, vtkDataArray *inVecs, float *result, int z, float *aspect, float *resultNormal) [protected]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSubPixelPositionEdgels &) (defined in vtkSubPixelPositionEdgels) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradMaps(vtkStructuredPoints *gm)
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetFlag(int) [virtual]
  • SetTargetValue(float) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TargetFlag [protected]
  • TargetFlagOff() [virtual]
  • TargetFlagOn() [virtual]
  • TargetValue [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSubPixelPositionEdgels() [protected]
  • vtkSubPixelPositionEdgels(const vtkSubPixelPositionEdgels &) (defined in vtkSubPixelPositionEdgels) [private]
  • vtkTypeRevisionMacro(vtkSubPixelPositionEdgels, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSubPixelPositionEdgels() [protected]
Generated on Mon Mar 25 01:31:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSuperquadric Member List

This is the complete list of members for vtkSuperquadric, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EvaluateFunction(float x[3]) [virtual]
  • EvaluateFunction(float x, float y, float z) [inline]
  • EvaluateGradient(float x[3], float g[3]) [virtual]
  • FunctionGradient(const float x[3], float g[3])
  • FunctionGradient(const float x[3]) [inline]
  • FunctionGradient(float x, float y, float z) [inline]
  • FunctionValue(const float x[3])
  • FunctionValue(float x, float y, float z) [inline]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPhiRoundness() [virtual]
  • GetReferenceCount() [inline]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetSize() [virtual]
  • GetThetaRoundness() [virtual]
  • GetThickness() [virtual]
  • GetToroidal() [virtual]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkSuperquadric &) (defined in vtkSuperquadric) [private]
  • PhiRoundness [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Scale [protected]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetPhiRoundness(float e)
  • SetReferenceCount(int)
  • SetScale(float, float, float) [virtual]
  • SetScale(float[3]) [virtual]
  • SetSize(float) [virtual]
  • SetThetaRoundness(float e)
  • SetThickness(float) [virtual]
  • SetToroidal(int) [virtual]
  • SetTransform(vtkAbstractTransform *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • ThetaRoundness [protected]
  • Thickness [protected]
  • Toroidal [protected]
  • ToroidalOff() [virtual]
  • ToroidalOn() [virtual]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImplicitFunction() [protected]
  • vtkObject() [protected]
  • vtkSuperquadric() [protected]
  • vtkSuperquadric(const vtkSuperquadric &) (defined in vtkSuperquadric) [private]
  • vtkTypeRevisionMacro(vtkSuperquadric, vtkImplicitFunction)
  • ~vtkImplicitFunction() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkSuperquadric() [inline, protected]
Generated on Mon Mar 25 01:31:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSuperquadricSource Member List

This is the complete list of members for vtkSuperquadricSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPhiResolution() [virtual]
  • GetPhiRoundness() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetSize() [virtual]
  • GetThetaResolution() [virtual]
  • GetThetaRoundness() [virtual]
  • GetThickness() [virtual]
  • GetToroidal() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSuperquadricSource &) (defined in vtkSuperquadricSource) [private]
  • Outputs [protected]
  • PhiResolution [protected]
  • PhiRoundness [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Scale [protected]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPhiResolution(int i)
  • SetPhiRoundness(float e)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScale(float, float, float) [virtual]
  • SetScale(float[3]) [virtual]
  • SetSize(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetThetaResolution(int i)
  • SetThetaRoundness(float e)
  • SetThickness(float) [virtual]
  • SetToroidal(int) [virtual]
  • Size [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThetaResolution [protected]
  • ThetaRoundness [protected]
  • Thickness [protected]
  • Toroidal [protected]
  • ToroidalOff() [virtual]
  • ToroidalOn() [virtual]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSuperquadricSource(int res=16) [protected]
  • vtkSuperquadricSource(const vtkSuperquadricSource &) (defined in vtkSuperquadricSource) [private]
  • vtkTypeRevisionMacro(vtkSuperquadricSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSuperquadricSource() [inline, protected]
Generated on Mon Mar 25 01:31:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSurfaceReconstructionFilter Member List

This is the complete list of members for vtkSurfaceReconstructionFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNeighborhoodSize() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleSpacing() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • NeighborhoodSize [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSurfaceReconstructionFilter &) (defined in vtkSurfaceReconstructionFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleSpacing [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNeighborhoodSize(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleSpacing(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkSurfaceReconstructionFilter() [protected]
  • vtkSurfaceReconstructionFilter(const vtkSurfaceReconstructionFilter &) (defined in vtkSurfaceReconstructionFilter) [private]
  • vtkTypeRevisionMacro(vtkSurfaceReconstructionFilter, vtkDataSetToStructuredPointsFilter)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkSurfaceReconstructionFilter() [inline, protected]
Generated on Mon Mar 25 01:31:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSweptSurface Member List

This is the complete list of members for vtkSweptSurface, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdjustBounds [protected]
  • AdjustBoundsOff() [virtual]
  • AdjustBoundsOn() [virtual]
  • AdjustDistance [protected]
  • BreakOnError() [static]
  • Cap(vtkDataArray *s) [protected]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds(float origin[3], float ar[3], float bbox[24]) [protected]
  • ComputeFootprint(vtkMatrix4x4 *m, int inDim[3], float inOrigin[3], float inSpacing[3], int Indicies[6]) [protected]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNumberOfSteps(vtkTransform *t1, vtkTransform *t2, float bbox[24]) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FillValue [protected]
  • GetAbortExecute() [virtual]
  • GetActorMatrixPointer(vtkTransform &t, float origin[3], float position[3], float orientation[3]) [protected]
  • GetAdjustBounds() [virtual]
  • GetAdjustDistance() [virtual]
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFillValue() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumNumberOfInterpolationSteps() [virtual]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfInterpolationSteps() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRelativePosition(vtkTransform &t, float *origin, float *position) [protected]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GetTransforms() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InterpolateStates(float *pos1, float *pos2, float *euler1, float *euler2, float t, float *posOut, float *eulerOut) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumNumberOfInterpolationSteps [protected]
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfInterpolationSteps [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSweptSurface &) (defined in vtkSweptSurface) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • SampleInput(vtkMatrix4x4 *m, int inDim[3], float inOrigin[3], float inAr[3], vtkDataArray *in, vtkDataArray *out) [protected]
  • SetAbortExecute(int) [virtual]
  • SetAdjustBounds(int) [virtual]
  • SetAdjustDistance(float) [virtual]
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFillValue(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetMaximumNumberOfInterpolationSteps(int) [virtual]
  • SetModelBounds(float data[]) [virtual]
  • SetModelBounds(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfInterpolationSteps(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int, int, int) [virtual]
  • SetSampleDimensions(int[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransforms(vtkTransformCollection *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • T (defined in vtkSweptSurface) [private]
  • Transforms [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
  • vtkSweptSurface() [protected]
  • vtkSweptSurface(const vtkSweptSurface &) (defined in vtkSweptSurface) [private]
  • vtkTypeRevisionMacro(vtkSweptSurface, vtkStructuredPointsToStructuredPointsFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkStructuredPointsToStructuredPointsFilter() [inline, protected]
  • ~vtkSweptSurface() [protected]
Generated on Mon Mar 25 01:31:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSynchronizedTemplates2D Member List

This is the complete list of members for vtkSynchronizedTemplates2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkSynchronizedTemplates2D &) (defined in vtkSynchronizedTemplates2D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkKitwareContourFilter [friend]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSynchronizedTemplates2D() [protected]
  • vtkSynchronizedTemplates2D(const vtkSynchronizedTemplates2D &) (defined in vtkSynchronizedTemplates2D) [private]
  • vtkTypeRevisionMacro(vtkSynchronizedTemplates2D, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSynchronizedTemplates2D() [protected]
Generated on Mon Mar 25 01:31:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSynchronizedTemplates3D Member List

This is the complete list of members for vtkSynchronizedTemplates3D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeGradients [protected]
  • ComputeGradientsOff() [virtual]
  • ComputeGradientsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeNormals [protected]
  • ComputeNormalsOff() [virtual]
  • ComputeNormalsOn() [virtual]
  • ComputeScalars [protected]
  • ComputeScalarsOff() [virtual]
  • ComputeScalarsOn() [virtual]
  • ContourValues [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteExtent [protected]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GenerateValues(int numContours, float range[2]) [inline]
  • GenerateValues(int numContours, float rangeStart, float rangeEnd) [inline]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComputeGradients() [virtual]
  • GetComputeNormals() [virtual]
  • GetComputeScalars() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExecuteExtent() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputMemoryLimit()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfContours() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetValue(int i) [inline]
  • GetValues() [inline]
  • GetValues(float *contourValues) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • operator=(const vtkSynchronizedTemplates3D &) (defined in vtkSynchronizedTemplates3D) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetComputeGradients(int) [virtual]
  • SetComputeNormals(int) [virtual]
  • SetComputeScalars(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInputMemoryLimit(unsigned long limit)
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfContours(int number) [inline]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfThreads(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetValue(int i, float value) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThreadedExecute(vtkImageData *data, int *exExt, int threadId)
  • Threader [protected]
  • Threads [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkKitwareContourFilter [friend]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkSynchronizedTemplates3D() [protected]
  • vtkSynchronizedTemplates3D(const vtkSynchronizedTemplates3D &) (defined in vtkSynchronizedTemplates3D) [private]
  • vtkTypeRevisionMacro(vtkSynchronizedTemplates3D, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkSynchronizedTemplates3D() [protected]
Generated on Mon Mar 25 01:31:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTclCommand Member List

This is the complete list of members for vtkTclCommand, including all inherited members.
  • AbortCheckEvent enum value
  • AbortFlag [protected]
  • AnyEvent enum value
  • CharEvent enum value
  • ConfigureEvent enum value
  • Delete() [inline]
  • DeleteEvent enum value
  • EndEvent enum value
  • EndOfDataEvent enum value
  • EndPickEvent enum value
  • EnterEvent enum value
  • ErrorEvent enum value
  • EventIds enum name
  • Execute(vtkObject *, unsigned long, void *) [virtual]
  • ExitEvent enum value
  • GetAbortFlag() [inline]
  • GetEventIdFromString(const char *event) [static]
  • GetStringFromEventId(unsigned long event) [static]
  • Interp
  • KeyPressEvent enum value
  • KeyReleaseEvent enum value
  • LeaveEvent enum value
  • LeftButtonPressEvent enum value
  • LeftButtonReleaseEvent enum value
  • MiddleButtonPressEvent enum value
  • MiddleButtonReleaseEvent enum value
  • ModifiedEvent enum value
  • MouseMoveEvent enum value
  • New() [inline, static]
  • NextDataEvent enum value
  • NoEvent enum value
  • PickEvent enum value
  • ProgressEvent enum value
  • PushDataStartEvent enum value
  • ReferenceCount [protected]
  • Register()
  • Register(vtkObject *) [inline]
  • ResetCameraClippingRangeEvent enum value
  • ResetCameraEvent enum value
  • RightButtonPressEvent enum value
  • RightButtonReleaseEvent enum value
  • SetAbortFlag(int f) [inline]
  • SetAbortFlagPointer(int *f) [inline]
  • SetInterp(Tcl_Interp *interp) [inline]
  • SetOutputEvent enum value
  • SetStringCommand(const char *arg)
  • StartEvent enum value
  • StartPickEvent enum value
  • StringCommand
  • TimerEvent enum value
  • UnRegister()
  • UnRegister(vtkObject *) [inline]
  • UserEvent enum value
  • vtkCommand() [inline, protected]
  • vtkTclCommand() [protected]
  • WarningEvent enum value
  • WindowLevelEvent enum value
  • ~vtkCommand() [inline, protected, virtual]
  • ~vtkTclCommand() [protected]
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTensor Member List

This is the complete list of members for vtkTensor, including all inherited members.
  • AddComponent(int i, int j, float v) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkTensor *t) [inline]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetColumn(int j) [inline]
  • GetCommand(unsigned long tag)
  • GetComponent(int i, int j) [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator float *() [inline]
  • operator=(const vtkTensor &) (defined in vtkTensor) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetComponent(int i, int j, float v) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • Storage [protected]
  • SubjectHelper [protected]
  • T
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTensor() [protected]
  • vtkTensor(const vtkTensor &) (defined in vtkTensor) [private]
  • vtkTypeRevisionMacro(vtkTensor, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkTensor() [inline, protected]
Generated on Mon Mar 25 01:31:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTensorGlyph Member List

This is the complete list of members for vtkTensorGlyph, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • ClampScaling [protected]
  • ClampScalingOff() [virtual]
  • ClampScalingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorGlyphs [protected]
  • ColorGlyphsOff() [virtual]
  • ColorGlyphsOn() [virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ExtractEigenvalues [protected]
  • ExtractEigenvaluesOff() [virtual]
  • ExtractEigenvaluesOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClampScaling() [virtual]
  • GetClassName() [inline, virtual]
  • GetColorGlyphs() [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetExtractEigenvalues() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaxScaleFactor() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetScaling() [virtual]
  • GetSource()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaxScaleFactor [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTensorGlyph &) (defined in vtkTensorGlyph) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • Scaling [protected]
  • ScalingOff() [virtual]
  • ScalingOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClampScaling(int) [virtual]
  • SetColorGlyphs(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetExtractEigenvalues(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetMaxScaleFactor(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetScaling(int) [virtual]
  • SetSource(vtkPolyData *source)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTensorGlyph() [protected]
  • vtkTensorGlyph(const vtkTensorGlyph &) (defined in vtkTensorGlyph) [private]
  • vtkTypeRevisionMacro(vtkTensorGlyph, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTensorGlyph() [protected]
Generated on Mon Mar 25 01:31:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTetra Member List

This is the complete list of members for vtkTetra, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BarycentricCoords(double x[3], double x1[3], double x2[3], double x3[3], double x4[3], double bcoords[4]) [static]
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Circumsphere(double p1[3], double p2[3], double p3[3], double p4[3], double center[3]) [static]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeVolume(double p1[3], double p2[3], double p3[3], double p4[3]) [static]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetEdgeArray(int edgeId) [static]
  • GetEdgePoints(int edgeId, int *&pts) [virtual]
  • GetFace(int faceId) [virtual]
  • GetFaceArray(int faceId) [static]
  • GetFacePoints(int faceId, int *&pts) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [inline, virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float derivs[12]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[4]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • JacobianInverse(double **inverse, float derivs[12])
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkTetra &) (defined in vtkTetra) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • TetraCenter(float p1[3], float p2[3], float p3[3], float p4[3], float center[3]) [static]
  • Triangle [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkObject() [protected]
  • vtkTetra() [protected]
  • vtkTetra(const vtkTetra &) (defined in vtkTetra) [private]
  • vtkTypeRevisionMacro(vtkTetra, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTetra() [protected]
Generated on Mon Mar 25 01:32:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTextMapper Member List

This is the complete list of members for vtkTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *, int size[2]) [inline, virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTextMapper &) (defined in vtkTextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTextMapper(const vtkTextMapper &) (defined in vtkTextMapper) [private]
  • vtkTypeRevisionMacro(vtkTextMapper, vtkMapper2D)
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
Generated on Mon Mar 25 01:32:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTextSource Member List

This is the complete list of members for vtkTextSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BackgroundColor [protected]
  • Backing [protected]
  • BackingOff() [virtual]
  • BackingOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • ForegroundColor [protected]
  • GetAbortExecute() [virtual]
  • GetBackgroundColor() [virtual]
  • GetBackgroundColor(float data[3]) [virtual]
  • GetBacking() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetForegroundColor() [virtual]
  • GetForegroundColor(float data[3]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetText() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTextSource &) (defined in vtkTextSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBackgroundColor(float, float, float) [virtual]
  • SetBackgroundColor(float[3]) [virtual]
  • SetBacking(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetForegroundColor(float, float, float) [virtual]
  • SetForegroundColor(float[3]) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetText(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Text [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTextSource() [protected]
  • vtkTextSource(const vtkTextSource &) (defined in vtkTextSource) [private]
  • vtkTypeRevisionMacro(vtkTextSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTextSource() [protected]
Generated on Mon Mar 25 01:32:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTexture Member List

This is the complete list of members for vtkTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInterpolate() [virtual]
  • GetLookupTable() [virtual]
  • GetMapColorScalarsThroughLookupTable() [virtual]
  • GetMappedScalars() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetQuality() [virtual]
  • GetReferenceCount() [inline]
  • GetRepeat() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • Interpolate [protected]
  • InterpolateOff() [virtual]
  • InterpolateOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Load(vtkRenderer *) [inline, virtual]
  • LookupTable [protected]
  • MapColorScalarsThroughLookupTable [protected]
  • MapColorScalarsThroughLookupTableOff() [virtual]
  • MapColorScalarsThroughLookupTableOn() [virtual]
  • MappedScalars [protected]
  • MapScalarsToColors(vtkDataArray *scalars)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTexture &) (defined in vtkTexture) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • Quality [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren) [virtual]
  • Repeat [protected]
  • RepeatOff() [virtual]
  • RepeatOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelfAdjustingTableRange [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input)
  • SetInterpolate(int) [virtual]
  • SetLookupTable(vtkLookupTable *)
  • SetMapColorScalarsThroughLookupTable(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetQuality(int) [virtual]
  • SetQualityTo16Bit() [inline]
  • SetQualityTo32Bit() [inline]
  • SetQualityToDefault() [inline]
  • SetReferenceCount(int)
  • SetRepeat(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTexture() [protected]
  • vtkTexture(const vtkTexture &) (defined in vtkTexture) [private]
  • vtkTypeRevisionMacro(vtkTexture, vtkObject)
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTexture() [protected]
Generated on Mon Mar 25 01:32:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTexturedSphereSource Member List

This is the complete list of members for vtkTexturedSphereSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPhi() [virtual]
  • GetPhiResolution() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTheta() [virtual]
  • GetThetaResolution() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTexturedSphereSource &) (defined in vtkTexturedSphereSource) [private]
  • Outputs [protected]
  • Phi [protected]
  • PhiResolution [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPhi(float) [virtual]
  • SetPhiResolution(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTheta(float) [virtual]
  • SetThetaResolution(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Theta [protected]
  • ThetaResolution [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTexturedSphereSource(int res=8) [protected]
  • vtkTexturedSphereSource(const vtkTexturedSphereSource &) (defined in vtkTexturedSphereSource) [private]
  • vtkTypeRevisionMacro(vtkTexturedSphereSource, vtkPolyDataSource)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTexturedSphereSource() [inline, protected]
Generated on Mon Mar 25 01:32:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTextureMapToCylinder Member List

This is the complete list of members for vtkTextureMapToCylinder, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AutomaticCylinderGeneration [protected]
  • AutomaticCylinderGenerationOff() [virtual]
  • AutomaticCylinderGenerationOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAutomaticCylinderGeneration() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint1() [virtual]
  • GetPoint1(float data[3]) [virtual]
  • GetPoint2() [virtual]
  • GetPoint2(float data[3]) [virtual]
  • GetPolyDataOutput()
  • GetPreventSeam() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTextureMapToCylinder &) (defined in vtkTextureMapToCylinder) [private]
  • Outputs [protected]
  • Point1 [protected]
  • Point2 [protected]
  • PreventSeam [protected]
  • PreventSeamOff() [virtual]
  • PreventSeamOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAutomaticCylinderGeneration(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPoint1(float, float, float) [virtual]
  • SetPoint1(float[3]) [virtual]
  • SetPoint2(float, float, float) [virtual]
  • SetPoint2(float[3]) [virtual]
  • SetPreventSeam(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTextureMapToCylinder() [protected]
  • vtkTextureMapToCylinder(const vtkTextureMapToCylinder &) (defined in vtkTextureMapToCylinder) [private]
  • vtkTypeRevisionMacro(vtkTextureMapToCylinder, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTextureMapToCylinder() [inline, protected]
Generated on Mon Mar 25 01:32:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTextureMapToPlane Member List

This is the complete list of members for vtkTextureMapToPlane, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AutomaticPlaneGeneration [protected]
  • AutomaticPlaneGenerationOff() [virtual]
  • AutomaticPlaneGenerationOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeNormal() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAutomaticPlaneGeneration() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float data[3]) [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPoint1() [virtual]
  • GetPoint1(float data[3]) [virtual]
  • GetPoint2() [virtual]
  • GetPoint2(float data[3]) [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSRange() [virtual]
  • GetSRange(float data[2]) [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTRange() [virtual]
  • GetTRange(float data[2]) [virtual]
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTextureMapToPlane &) (defined in vtkTextureMapToPlane) [private]
  • Origin [protected]
  • Outputs [protected]
  • Point1 [protected]
  • Point2 [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAutomaticPlaneGeneration(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNormal(float, float, float) [virtual]
  • SetNormal(float[3]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOutput(vtkDataSet *)
  • SetPoint1(float, float, float) [virtual]
  • SetPoint1(float[3]) [virtual]
  • SetPoint2(float, float, float) [virtual]
  • SetPoint2(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSRange(float, float) [virtual]
  • SetSRange(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTRange(float, float) [virtual]
  • SetTRange(float[2])
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • SRange [protected]
  • StartTag [protected]
  • SubjectHelper [protected]
  • TRange [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTextureMapToPlane() [protected]
  • vtkTextureMapToPlane(const vtkTextureMapToPlane &) (defined in vtkTextureMapToPlane) [private]
  • vtkTypeRevisionMacro(vtkTextureMapToPlane, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTextureMapToPlane() [inline, protected]
Generated on Mon Mar 25 01:32:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTextureMapToSphere Member List

This is the complete list of members for vtkTextureMapToSphere, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AutomaticSphereGeneration [protected]
  • AutomaticSphereGenerationOff() [virtual]
  • AutomaticSphereGenerationOn() [virtual]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAutomaticSphereGeneration() [virtual]
  • GetCenter() [virtual]
  • GetCenter(float data[3]) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetPreventSeam() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTextureMapToSphere &) (defined in vtkTextureMapToSphere) [private]
  • Outputs [protected]
  • PreventSeam [protected]
  • PreventSeamOff() [virtual]
  • PreventSeamOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAutomaticSphereGeneration(int) [virtual]
  • SetCenter(float, float, float) [virtual]
  • SetCenter(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetPreventSeam(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTextureMapToSphere() [protected]
  • vtkTextureMapToSphere(const vtkTextureMapToSphere &) (defined in vtkTextureMapToSphere) [private]
  • vtkTypeRevisionMacro(vtkTextureMapToSphere, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTextureMapToSphere() [inline, protected]
Generated on Mon Mar 25 01:32:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThinPlateSplineTransform Member List

This is the complete list of members for vtkThinPlateSplineTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Basis [protected]
  • BasisDerivative [protected]
  • BasisFunction [protected]
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • ForwardTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [protected, virtual]
  • ForwardTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [protected, virtual]
  • ForwardTransformPoint(const float in[3], float out[3]) [protected, virtual]
  • ForwardTransformPoint(const double in[3], double out[3]) [protected, virtual]
  • GetBasis() [virtual]
  • GetBasisAsString()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInverse()
  • GetInverseFlag() [virtual]
  • GetInverseIterations() [virtual]
  • GetInverseTolerance() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetSigma() [virtual]
  • GetSourceLandmarks() [virtual]
  • GetTargetLandmarks() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *transform) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InverseFlag [protected]
  • InverseIterations [protected]
  • InverseTolerance [protected]
  • InverseTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [protected, virtual]
  • InverseTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [protected, virtual]
  • InverseTransformPoint(const float in[3], float out[3]) [protected, virtual]
  • InverseTransformPoint(const double in[3], double out[3]) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • MatrixW [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfPoints [protected]
  • operator=(const vtkThinPlateSplineTransform &) (defined in vtkThinPlateSplineTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetBasis(int basis)
  • SetBasisDerivative(double(*dUdr)(double r, double &dU)) [inline]
  • SetBasisFunction(double(*U)(double r)) [inline]
  • SetBasisToR() [inline]
  • SetBasisToR2LogR() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetInverseIterations(int) [virtual]
  • SetInverseTolerance(double) [virtual]
  • SetReferenceCount(int)
  • SetSigma(double) [virtual]
  • SetSourceLandmarks(vtkPoints *source)
  • SetTargetLandmarks(vtkPoints *target)
  • Sigma [protected]
  • SourceLandmarks [protected]
  • SubjectHelper [protected]
  • TargetLandmarks [protected]
  • TemplateTransformInverse(const float in[3], float out[3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3]) [inline]
  • TemplateTransformInverse(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkObject() [protected]
  • vtkThinPlateSplineTransform() [protected]
  • vtkThinPlateSplineTransform(const vtkThinPlateSplineTransform &) (defined in vtkThinPlateSplineTransform) [private]
  • vtkTypeRevisionMacro(vtkThinPlateSplineTransform, vtkWarpTransform)
  • vtkWarpTransform() [protected]
  • ~vtkAbstractTransform() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkThinPlateSplineTransform() [protected]
  • ~vtkWarpTransform() [protected]
Generated on Mon Mar 25 01:32:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThreadedController Member List

This is the complete list of members for vtkThreadedController, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRMI(vtkRMIFunctionType, void *localArg, int tag)
  • ANY_SOURCE enum value
  • Barrier() [virtual]
  • BarrierEnded() [protected, static]
  • BarrierInProgress [protected, static]
  • BarrierLock [protected, static]
  • BarrierStarted() [protected, static]
  • BREAK_RMI_TAG enum value
  • BreakFlag [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Communicator [protected]
  • Consts enum name
  • Controllers [protected]
  • Counter [protected, static]
  • CounterLock [protected, static]
  • CreateOutputWindow() [virtual]
  • CreateProcessControllers() [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Finalize() [inline, virtual]
  • ForceDeepCopy [protected]
  • ForceDeepCopyOff() [virtual]
  • ForceDeepCopyOn() [virtual]
  • GetBreakFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCommunicator() [virtual]
  • GetDebug()
  • GetForceDeepCopy() [virtual]
  • GetGlobalController() [static]
  • GetGlobalWarningDisplay() [static]
  • GetLocalController() [protected, virtual]
  • GetLocalProcessId() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfProcesses() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize(int *argc, char ***arcv) [virtual]
  • vtkMultiProcessController::Initialize(int *vtkNotUsed(argc), char ***vtkNotUsed(arcv))=0 [pure virtual]
  • InitializeBarrier() [protected, static]
  • INVALID_SOURCE enum value
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsBarrierInProgress [protected, static]
  • IsTypeOf(const char *name) [static]
  • LastNumberOfProcesses [protected]
  • LocalProcessId [protected]
  • MAX_PROCESSES enum value
  • MaximumNumberOfProcesses [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultipleData [protected]
  • MultipleMethod [protected]
  • MultipleMethodExecute() [virtual]
  • MultipleMethodFlag [protected]
  • MultiThreader [protected]
  • New() [static]
  • NumberOfProcesses [protected]
  • operator=(const vtkThreadedController &) (defined in vtkThreadedController) [private]
  • OutputWindow [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProcessRMI(int remoteProcessId, void *arg, int argLength, int rmiTag) [protected]
  • ProcessRMIs()
  • Receive(int *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(float *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(double *data, int length, int remoteProcessId, int tag) [inline]
  • Receive(vtkDataObject *data, int remoteId, int tag) [inline]
  • Receive(vtkDataArray *data, int remoteId, int tag) [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRMI(vtkRMIFunctionType f, void *arg, int tag) [inline]
  • ResetControllers() [protected]
  • RMI_ARG_TAG enum value
  • RMI_TAG enum value
  • RMICommunicator [protected]
  • RMIs [protected]
  • SafeDownCast(vtkObject *o) [static]
  • Send(int *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned long *data, int length, int remoteProcessId, int tag) [inline]
  • Send(char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(unsigned char *data, int length, int remoteProcessId, int tag) [inline]
  • Send(float *data, int length, int remoteProcessId, int tag) [inline]
  • Send(double *data, int length, int remoteProcessId, int tag) [inline]
  • Send(vtkDataObject *data, int remoteId, int tag) [inline]
  • Send(vtkDataArray *data, int remoteId, int tag) [inline]
  • SetBreakFlag(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetForceDeepCopy(int) [virtual]
  • SetGlobalController(vtkMultiProcessController *controller) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMultipleMethod(int index, vtkProcessFunctionType, void *data)
  • SetNumberOfProcesses(int num) [virtual]
  • SetReferenceCount(int)
  • SetSingleMethod(vtkProcessFunctionType, void *data)
  • SignalNextThread() [protected, static]
  • SingleData [protected]
  • SingleMethod [protected]
  • SingleMethodExecute() [virtual]
  • Start(int threadIdx) [protected]
  • SubjectHelper [protected]
  • ThreadId [protected]
  • ThreadIdType typedef [protected]
  • TriggerBreakRMIs()
  • TriggerRMI(int remoteProcessId, void *arg, int argLength, int tag)
  • TriggerRMI(int remoteProcessId, char *arg, int tag) [inline]
  • TriggerRMI(int remoteProcessId, int tag) [inline]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMultiProcessController() [protected]
  • vtkObject() [protected]
  • vtkThreadedController() [protected]
  • vtkThreadedController(const vtkThreadedController &) (defined in vtkThreadedController) [private]
  • vtkThreadedControllerStart(void *arg) [protected, static]
  • vtkTypeRevisionMacro(vtkThreadedController, vtkMultiProcessController)
  • WaitForNextThread() [protected, static]
  • WaitForPreviousBarrierToEnd() [protected, static]
  • ~vtkMultiProcessController() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkThreadedController() [protected]
Generated on Mon Mar 25 01:32:12 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThreadSafeLog Member List

This is the complete list of members for vtkThreadSafeLog, including all inherited members.
  • AddEntry(char *tag, float value)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DumpLog(char *filename, int mode=ios::out)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetElapsedTime() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfEntries [protected]
  • operator=(const vtkThreadSafeLog &) (defined in vtkThreadSafeLog) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • StartTimer() [inline]
  • StopTimer() [inline]
  • SubjectHelper [protected]
  • Tags [protected]
  • Timer [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Values [protected]
  • vtkObject() [protected]
  • vtkThreadSafeLog() [protected]
  • vtkThreadSafeLog(const vtkThreadSafeLog &) (defined in vtkThreadSafeLog) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkThreadSafeLog() [protected]
Generated on Mon Mar 25 01:32:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThreshold Member List

This is the complete list of members for vtkThreshold, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllScalars [protected]
  • AllScalarsOff() [virtual]
  • AllScalarsOn() [virtual]
  • AttributeMode [protected]
  • Between(float s) [inline, protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAllScalars() [virtual]
  • GetAttributeMode() [virtual]
  • GetAttributeModeAsString()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetLowerThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUpperThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Lower(float s) [inline, protected]
  • LowerThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkThreshold &) (defined in vtkThreshold) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetAllScalars(int) [virtual]
  • SetAttributeMode(int) [virtual]
  • SetAttributeModeToDefault() [inline]
  • SetAttributeModeToUseCellData() [inline]
  • SetAttributeModeToUsePointData() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThresholdBetween(float lower, float upper)
  • ThresholdByLower(float lower)
  • ThresholdByUpper(float upper)
  • ThresholdFunction [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Upper(float s) [inline, protected]
  • UpperThreshold [protected]
  • vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkThreshold() [protected]
  • vtkThreshold(const vtkThreshold &) (defined in vtkThreshold) [private]
  • vtkTypeRevisionMacro(vtkThreshold, vtkDataSetToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • ~vtkDataSetToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkThreshold() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:32:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThresholdPoints Member List

This is the complete list of members for vtkThresholdPoints, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Between(float s) [inline, protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLowerThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetUpperThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Lower(float s) [inline, protected]
  • LowerThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkThresholdPoints &) (defined in vtkThresholdPoints) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • ThresholdBetween(float lower, float upper)
  • ThresholdByLower(float lower)
  • ThresholdByUpper(float upper)
  • ThresholdFunction [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Upper(float s) [inline, protected]
  • UpperThreshold [protected]
  • vtkDataSetToPolyDataFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkThresholdPoints() [protected]
  • vtkThresholdPoints(const vtkThresholdPoints &) (defined in vtkThresholdPoints) [private]
  • vtkTypeRevisionMacro(vtkThresholdPoints, vtkDataSetToPolyDataFilter)
  • ~vtkDataSetToPolyDataFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkThresholdPoints() [inline, protected]
Generated on Mon Mar 25 01:32:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkThresholdTextureCoords Member List

This is the complete list of members for vtkThresholdTextureCoords, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • Between(float s) [inline, protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInTextureCoord() [virtual]
  • GetInTextureCoord(float data[3]) [virtual]
  • GetLowerThreshold() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutTextureCoord() [virtual]
  • GetOutTextureCoord(float data[3]) [virtual]
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetTextureDimension() [virtual]
  • GetUnstructuredGridOutput()
  • GetUpperThreshold() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InTextureCoord [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Lower(float s) [inline, protected]
  • LowerThreshold [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkThresholdTextureCoords &) (defined in vtkThresholdTextureCoords) [private]
  • Outputs [protected]
  • OutTextureCoord [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetInTextureCoord(float, float, float) [virtual]
  • SetInTextureCoord(float[3]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetOutTextureCoord(float, float, float) [virtual]
  • SetOutTextureCoord(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTextureDimension(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextureDimension [protected]
  • ThresholdBetween(float lower, float upper)
  • ThresholdByLower(float lower)
  • ThresholdByUpper(float upper)
  • ThresholdFunction [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • Upper(float s) [inline, protected]
  • UpperThreshold [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkThresholdTextureCoords() [protected]
  • vtkThresholdTextureCoords(const vtkThresholdTextureCoords &) (defined in vtkThresholdTextureCoords) [private]
  • vtkTypeRevisionMacro(vtkThresholdTextureCoords, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkThresholdTextureCoords() [inline, protected]
Generated on Mon Mar 25 01:32:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTIFFReader Member List

This is the complete list of members for vtkTIFFReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CanReadFile(const char *fname) [virtual]
  • vtkImageReader2::CanReadFile(const char *vtkNotUsed(fname)) [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorBlue (defined in vtkTIFFReader) [private]
  • ColorGreen (defined in vtkTIFFReader) [private]
  • ColorRed (defined in vtkTIFFReader) [private]
  • ComputeDataIncrements() [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeInternalFileName(int slice)
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataExtent [protected]
  • DataIncrements [protected]
  • DataOrigin [protected]
  • DataScalarType [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • EvaluateImageAt(void *, void *) [protected]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *out) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • File [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileLowerLeftOff() [virtual]
  • FileLowerLeftOn() [virtual]
  • FileName [protected]
  • FileNameSliceOffset [protected]
  • FileNameSliceSpacing [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [virtual]
  • GetColor(int index, unsigned short *r, unsigned short *g, unsigned short *b)
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataExtent() [virtual]
  • GetDataExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetDataExtent(int[6]) [virtual]
  • GetDataIncrements() [virtual]
  • GetDataIncrements(unsigned long data[4]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataScalarType() [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetDescriptiveName() [inline, virtual]
  • GetErrorCode() [virtual]
  • GetFile() [inline]
  • GetFileDimensionality() [inline]
  • GetFileExensions() [inline, virtual]
  • GetFileLowerLeft() [virtual]
  • GetFileName() [virtual]
  • GetFileNameSliceOffset() [virtual]
  • GetFileNameSliceSpacing() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetFormat()
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize()
  • GetHeaderSize(unsigned long slice)
  • GetInputs() [inline]
  • GetInternalFileName() [virtual]
  • GetInternalImage() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarComponents() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GRAYSCALE enum value
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • ImageFormat (defined in vtkTIFFReader) [private]
  • InformationTime [protected]
  • InitializeColors()
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalExtents (defined in vtkTIFFReader) [private]
  • InternalFileName [protected]
  • InternalImage (defined in vtkTIFFReader) [private]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *type) [virtual]
  • IsTypeOf(const char *type) [static]
  • LegacyHack
  • MakeObject() [inline, virtual]
  • ManualHeaderSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NOFORMAT enum value
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OpenFile()
  • operator=(const vtkTIFFReader &) (defined in vtkTIFFReader) [private]
  • OTHER enum value
  • Outputs [protected]
  • PALETTE_GRAYSCALE enum value
  • PALETTE_RGB enum value
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadGenericImage(void *out, unsigned int width, unsigned int height, unsigned int size) [protected]
  • ReadImageInternal(void *, void *outPtr, int *outExt, unsigned int size)
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RGB enum value
  • SafeDownCast(vtkObject *o) [static]
  • SeekFile(int i, int j, int k)
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataExtent(int, int, int, int, int, int) [virtual]
  • SetDataExtent(int[6]) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataScalarType(int type)
  • SetDataScalarTypeToDouble() [inline]
  • SetDataScalarTypeToFloat() [inline]
  • SetDataScalarTypeToInt() [inline]
  • SetDataScalarTypeToShort() [inline]
  • SetDataScalarTypeToUnsignedChar() [inline]
  • SetDataScalarTypeToUnsignedShort() [inline]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileDimensionality(int) [virtual]
  • SetFileLowerLeft(int) [virtual]
  • SetFileName(const char *)
  • SetFileNameSliceOffset(int) [virtual]
  • SetFileNameSliceSpacing(int) [virtual]
  • SetFilePattern(const char *)
  • SetFilePrefix(const char *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(unsigned long size)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfScalarComponents(int) [virtual]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Superclass typedef
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • TotalColors (defined in vtkTIFFReader) [private]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageReader2() [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTIFFReader() [protected]
  • vtkTIFFReader(const vtkTIFFReader &) (defined in vtkTIFFReader) [private]
  • vtkTypeRevisionMacro(vtkImageReader2, vtkImageSource)
  • ~vtkImageReader2() [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTIFFReader() [protected]
Generated on Mon Mar 25 01:32:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTIFFWriter Member List

This is the complete list of members for vtkTIFFWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • FileDimensionality [protected]
  • FileLowerLeft [protected]
  • FileName [protected]
  • FileNumber [protected]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileDimensionality() [virtual]
  • GetFileName() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InternalFileName [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTIFFWriter &) (defined in vtkTIFFWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RecursiveWrite(int dim, vtkImageData *region, ofstream *file) [protected, virtual]
  • RecursiveWrite(int dim, vtkImageData *cache, vtkImageData *data, ofstream *file) [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFileDimensionality(int) [virtual]
  • SetFileName(const char *)
  • SetFilePattern(const char *filePattern)
  • SetFilePrefix(char *filePrefix)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • vtkImageWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTIFFWriter() [inline, protected]
  • vtkTIFFWriter(const vtkTIFFWriter &) (defined in vtkTIFFWriter) [private]
  • vtkTypeRevisionMacro(vtkTIFFWriter, vtkImageWriter)
  • Write() [virtual]
  • WriteFile(ofstream *file, vtkImageData *data, int ext[6]) [protected, virtual]
  • WriteFileHeader(ofstream *, vtkImageData *) [protected, virtual]
  • WriteFileTrailer(ofstream *, vtkImageData *) [inline, protected, virtual]
  • ~vtkImageWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTIFFWriter() [inline, protected]
Generated on Mon Mar 25 01:32:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTimerLog Member List

This is the complete list of members for vtkTimerLog, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateLog() [static]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CurrentCpuTicks [protected, static]
  • CurrentWallTime [protected, static]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DumpEntry(ostream &os, int index, float time, float deltatime, int tick, int deltatick, char *event) [protected, static]
  • DumpLog(char *filename) [static]
  • EndTime [protected]
  • FirstCpuTicks [protected, static]
  • FirstWallTime [protected, static]
  • FormatAndMarkEvent(char *EventString,...) [static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCPUTime() [static]
  • GetCurrentTime() [static]
  • GetDebug()
  • GetElapsedTime()
  • GetGlobalWarningDisplay() [static]
  • GetMaxEntries() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MarkEvent(char *EventString) [static]
  • MaxEntries [protected, static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextEntry [protected, static]
  • operator=(const vtkTimerLog &) (defined in vtkTimerLog) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ResetLog() [static]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaxEntries(int a) [static]
  • SetReferenceCount(int)
  • StartTime [protected]
  • StartTimer()
  • StopTimer()
  • SubjectHelper [protected]
  • TicksPerSecond [protected, static]
  • TimerLog [protected, static]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTimerLog() [inline, protected]
  • vtkTimerLog(const vtkTimerLog &) (defined in vtkTimerLog) [private]
  • vtkTypeRevisionMacro(vtkTimerLog, vtkObject)
  • WrapFlag [protected, static]
  • ~vtkObject() [protected, virtual]
  • ~vtkTimerLog() [inline, protected]
Generated on Mon Mar 25 01:32:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTimeStamp Member List

This is the complete list of members for vtkTimeStamp, including all inherited members.
  • Delete() [inline]
  • GetClassName() [inline, virtual]
  • GetMTime() [inline]
  • Modified()
  • ModifiedTime (defined in vtkTimeStamp) [private]
  • New() [static]
  • operator unsigned long() [inline]
  • operator<(vtkTimeStamp &ts) [inline]
  • operator>(vtkTimeStamp &ts) [inline]
  • vtkTimeStamp() [inline]
Generated on Mon Mar 25 01:32:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTkImageViewerWidget Member List

This is the complete list of members for vtkTkImageViewerWidget, including all inherited members.
  • Height
  • ImageViewer
  • Interp
  • IV
  • TkWin
  • Width
Generated on Mon Mar 25 01:32:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTkImageWindowWidget Member List

This is the complete list of members for vtkTkImageWindowWidget, including all inherited members.
  • Height
  • ImageWindow
  • Interp
  • IW
  • TkWin
  • Width
Generated on Mon Mar 25 01:32:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTkRenderWidget Member List

This is the complete list of members for vtkTkRenderWidget, including all inherited members.
  • Height
  • Interp
  • RenderWindow
  • RW
  • TkWin
  • Width
Generated on Mon Mar 25 01:32:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransform Member List

This is the complete list of members for vtkTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Concatenate(vtkMatrix4x4 *matrix) [inline]
  • Concatenate(const double elements[16]) [inline]
  • Concatenate(vtkLinearTransform *transform)
  • Concatenation [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • DoublePoint [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConcatenatedTransform(int i) [inline]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHomogeneousInverse() [inline]
  • GetInput() [inline]
  • GetInverse(vtkMatrix4x4 *inverse)
  • GetInverse() [inline]
  • GetInverseFlag() [inline]
  • GetLinearInverse() [inline]
  • GetMatrix(vtkMatrix4x4 *m)
  • GetMatrix() [inline]
  • GetMTime() [virtual]
  • GetNumberOfConcatenatedTransforms() [inline]
  • GetOrientation(double orient[3])
  • GetOrientation(float orient[3]) [inline]
  • GetOrientation() [inline]
  • GetOrientationWXYZ(double wxyz[4])
  • GetOrientationWXYZ(float wxyz[3]) [inline]
  • GetOrientationWXYZ() [inline]
  • GetPosition(double pos[3])
  • GetPosition(float pos[3]) [inline]
  • GetPosition() [inline]
  • GetReferenceCount() [inline]
  • GetScale(double scale[3])
  • GetScale(float scale[3]) [inline]
  • GetScale() [inline]
  • GetTranspose(vtkMatrix4x4 *transpose)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity()
  • Input [protected]
  • InternalDeepCopy(vtkAbstractTransform *t) [protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformNormal(const float in[3], float out[3]) [virtual]
  • InternalTransformNormal(const double in[3], double out[3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalTransformVector(const float in[3], float out[3]) [virtual]
  • InternalTransformVector(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [protected, virtual]
  • Inverse() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform() [virtual]
  • Matrix [protected]
  • MatrixUpdateMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiplyPoint(const float in[4], float out[4]) [inline]
  • MultiplyPoint(const double in[4], double out[4]) [inline]
  • New() [static]
  • operator=(const vtkTransform &) (defined in vtkTransform) [private]
  • Point [protected]
  • Pop() [inline]
  • PostMultiply() [inline]
  • PreMultiply() [inline]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Push() [inline]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReturnValue [protected]
  • RotateWXYZ(double angle, double x, double y, double z) [inline]
  • RotateWXYZ(double angle, const double axis[3]) [inline]
  • RotateWXYZ(double angle, const float axis[3]) [inline]
  • RotateX(double angle) [inline]
  • RotateY(double angle) [inline]
  • RotateZ(double angle) [inline]
  • SafeDownCast(vtkObject *o) [static]
  • Scale(double x, double y, double z) [inline]
  • Scale(const double s[3]) [inline]
  • Scale(const float s[3]) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkLinearTransform *input)
  • SetInverse(vtkAbstractTransform *transform)
  • SetMatrix(vtkMatrix4x4 *matrix) [inline]
  • SetMatrix(const double elements[16]) [inline]
  • SetReferenceCount(int)
  • Stack [protected]
  • SubjectHelper [protected]
  • TransformDoubleNormal(double x, double y, double z) [inline]
  • TransformDoubleNormal(const double normal[3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVector(double x, double y, double z) [inline]
  • TransformDoubleVector(const double vec[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormal(float x, float y, float z) [inline]
  • TransformFloatNormal(const float normal[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVector(float x, float y, float z) [inline]
  • TransformFloatVector(const float vec[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormal(const float in[3], float out[3]) [inline]
  • TransformNormal(const double in[3], double out[3]) [inline]
  • TransformNormal(double x, double y, double z) [inline]
  • TransformNormal(const double normal[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms) [virtual]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVector(double x, double y, double z) [inline]
  • TransformVector(const double normal[3]) [inline]
  • TransformVector(const float in[3], float out[3]) [inline]
  • TransformVector(const double in[3], double out[3]) [inline]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • Translate(double x, double y, double z) [inline]
  • Translate(const double x[3]) [inline]
  • Translate(const float x[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkHomogeneousTransform() [protected]
  • vtkLinearTransform() [inline, protected]
  • vtkObject() [protected]
  • vtkTransform() [protected]
  • vtkTransform(const vtkTransform &t) (defined in vtkTransform) [private]
  • vtkTypeRevisionMacro(vtkTransform, vtkLinearTransform)
  • ~vtkAbstractTransform() [protected]
  • ~vtkHomogeneousTransform() [protected]
  • ~vtkLinearTransform() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTransform() [protected]
Generated on Mon Mar 25 01:32:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformCollection Member List

This is the complete list of members for vtkTransformCollection, including all inherited members.
  • AddItem(vtkTransform *) [inline]
  • AddItem(vtkObject *o) (defined in vtkTransformCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNumberOfItems()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkTransformCollection &) (defined in vtkTransformCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkTransformCollection() [inline, protected]
  • vtkTransformCollection(const vtkTransformCollection &) (defined in vtkTransformCollection) [private]
  • vtkTypeRevisionMacro(vtkTransformCollection, vtkCollection)
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTransformCollection() [inline, protected]
Generated on Mon Mar 25 01:32:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformConcatenation Member List

This is the complete list of members for vtkTransformConcatenation, including all inherited members.
  • Concatenate(vtkAbstractTransform *transform)
  • Concatenate(const double elements[16])
  • DeepCopy(vtkTransformConcatenation *transform)
  • Delete() [inline]
  • GetInverseFlag() [inline]
  • GetMaxMTime()
  • GetNumberOfPostTransforms() [inline]
  • GetNumberOfPreTransforms() [inline]
  • GetNumberOfTransforms() [inline]
  • GetPreMultiplyFlag() [inline]
  • GetTransform(int i)
  • Identity()
  • Inverse()
  • InverseFlag [protected]
  • MaxNumberOfTransforms [protected]
  • New() [inline, static]
  • NumberOfPreTransforms [protected]
  • NumberOfTransforms [protected]
  • PostMatrix [protected]
  • PostMatrixTransform [protected]
  • PreMatrix [protected]
  • PreMatrixTransform [protected]
  • PreMultiplyFlag [protected]
  • PrintSelf(ostream &os, vtkIndent indent)
  • Rotate(double angle, double x, double y, double z)
  • Scale(double x, double y, double z)
  • SetPreMultiplyFlag(int flag) [inline]
  • TransformList [protected]
  • Translate(double x, double y, double z)
  • vtkTransformConcatenation() [protected]
  • ~vtkTransformConcatenation() [protected]
Generated on Mon Mar 25 01:32:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformConcatenationStack Member List

This is the complete list of members for vtkTransformConcatenationStack, including all inherited members.
  • DeepCopy(vtkTransformConcatenationStack *stack)
  • Delete() [inline]
  • New() [inline, static]
  • Pop(vtkTransformConcatenation **concat)
  • Push(vtkTransformConcatenation **concat)
  • Stack [protected]
  • StackBottom [protected]
  • StackSize [protected]
  • vtkTransformConcatenationStack() [protected]
  • ~vtkTransformConcatenationStack() [protected]
Generated on Mon Mar 25 01:32:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformFilter Member List

This is the complete list of members for vtkTransformFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetTransform() [virtual]
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransformFilter &) (defined in vtkTransformFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransformFilter() [protected]
  • vtkTransformFilter(const vtkTransformFilter &) (defined in vtkTransformFilter) [private]
  • vtkTypeRevisionMacro(vtkTransformFilter, vtkPointSetToPointSetFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransformFilter() [protected]
Generated on Mon Mar 25 01:32:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformPair Member List

This is the complete list of members for vtkTransformPair, including all inherited members.
  • ForwardTransform
  • InverseTransform
  • SwapForwardInverse() [inline]
Generated on Mon Mar 25 01:32:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformPolyDataFilter Member List

This is the complete list of members for vtkTransformPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransformPolyDataFilter &) (defined in vtkTransformPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransform(vtkAbstractTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Transform [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransformPolyDataFilter() [protected]
  • vtkTransformPolyDataFilter(const vtkTransformPolyDataFilter &) (defined in vtkTransformPolyDataFilter) [private]
  • vtkTypeRevisionMacro(vtkTransformPolyDataFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransformPolyDataFilter() [protected]
Generated on Mon Mar 25 01:32:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformTextureCoords Member List

This is the complete list of members for vtkTransformTextureCoords, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AddPosition(float deltaR, float deltaS, float deltaT)
  • AddPosition(float deltaPosition[3])
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FlipR [protected]
  • FlipROff() [virtual]
  • FlipROn() [virtual]
  • FlipS [protected]
  • FlipSOff() [virtual]
  • FlipSOn() [virtual]
  • FlipT [protected]
  • FlipTOff() [virtual]
  • FlipTOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFlipR() [virtual]
  • GetFlipS() [virtual]
  • GetFlipT() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransformTextureCoords &) (defined in vtkTransformTextureCoords) [private]
  • Origin [protected]
  • Outputs [protected]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Scale [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFlipR(int) [virtual]
  • SetFlipS(int) [virtual]
  • SetFlipT(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOrigin(float, float, float) [virtual]
  • SetOrigin(float[3]) [virtual]
  • SetOutput(vtkDataSet *)
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScale(float, float, float) [virtual]
  • SetScale(float[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransformTextureCoords() [protected]
  • vtkTransformTextureCoords(const vtkTransformTextureCoords &) (defined in vtkTransformTextureCoords) [private]
  • vtkTypeRevisionMacro(vtkTransformTextureCoords, vtkDataSetToDataSetFilter)
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransformTextureCoords() [inline, protected]
Generated on Mon Mar 25 01:32:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransformToGrid Member List

This is the complete list of members for vtkTransformToGrid, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplacementScale [protected]
  • DisplacementShift [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplacementScale() [inline]
  • GetDisplacementShift() [inline]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGridExtent() [virtual]
  • GetGridExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetGridExtent(int[6]) [virtual]
  • GetGridOrigin() [virtual]
  • GetGridOrigin(float &, float &, float &) [virtual]
  • GetGridOrigin(float[3]) [virtual]
  • GetGridScalarType() [virtual]
  • GetGridSpacing() [virtual]
  • GetGridSpacing(float &, float &, float &) [virtual]
  • GetGridSpacing(float[3]) [virtual]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetMTime() [protected, virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GridExtent [protected]
  • GridOrigin [protected]
  • GridScalarType [protected]
  • GridSpacing [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransformToGrid &) (defined in vtkTransformToGrid) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGridExtent(int, int, int, int, int, int) [virtual]
  • SetGridExtent(int[6]) [virtual]
  • SetGridOrigin(float, float, float) [virtual]
  • SetGridOrigin(float[3]) [virtual]
  • SetGridScalarType(int) [virtual]
  • SetGridScalarTypeToChar() [inline]
  • SetGridScalarTypeToFloat() [inline]
  • SetGridScalarTypeToShort() [inline]
  • SetGridScalarTypeToUnsignedChar() [inline]
  • SetGridScalarTypeToUnsignedShort() [inline]
  • SetGridSpacing(float, float, float) [virtual]
  • SetGridSpacing(float[3]) [virtual]
  • SetInput(vtkAbstractTransform *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShiftScaleTime [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateShiftScale() [protected]
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransformToGrid() [protected]
  • vtkTransformToGrid(const vtkTransformToGrid &) (defined in vtkTransformToGrid) [private]
  • vtkTypeRevisionMacro(vtkTransformToGrid, vtkImageSource)
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransformToGrid() [protected]
Generated on Mon Mar 25 01:32:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransmitPolyDataPiece Member List

This is the complete list of members for vtkTransmitPolyDataPiece, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Buffer [protected]
  • BufferGhostLevel [protected]
  • BufferNumberOfPieces [protected]
  • BufferPiece [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • Controller [protected]
  • CreateGhostCells [protected]
  • CreateGhostCellsOff() [virtual]
  • CreateGhostCellsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetController() [virtual]
  • GetCreateGhostCells() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransmitPolyDataPiece &) [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RootExecute() [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SatelliteExecute(int procId) [protected]
  • SetAbortExecute(int) [virtual]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetCreateGhostCells(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransmitPolyDataPiece() [protected]
  • vtkTransmitPolyDataPiece(const vtkTransmitPolyDataPiece &) [protected]
  • vtkTypeRevisionMacro(vtkTransmitPolyDataPiece, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransmitPolyDataPiece() [protected]
Generated on Mon Mar 25 01:32:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTransmitUnstructuredGridPiece Member List

This is the complete list of members for vtkTransmitUnstructuredGridPiece, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *out) [protected, virtual]
  • Controller [protected]
  • CreateGhostCells [protected]
  • CreateGhostCellsOff() [virtual]
  • CreateGhostCellsOn() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetController() [virtual]
  • GetCreateGhostCells() [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTransmitUnstructuredGridPiece &) [protected]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • RootExecute() [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SatelliteExecute(int procId) [protected]
  • SetAbortExecute(int) [virtual]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetCreateGhostCells(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTransmitUnstructuredGridPiece() [protected]
  • vtkTransmitUnstructuredGridPiece(const vtkTransmitUnstructuredGridPiece &) [protected]
  • vtkTypeRevisionMacro(vtkTransmitUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTransmitUnstructuredGridPiece() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
  • ~vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:32:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTreeComposite Member List

This is the complete list of members for vtkTreeComposite, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BOUNDS_TAG enum value
  • BreakOnError() [static]
  • CheckForAbortComposite() [inline, virtual]
  • CheckForAbortRender() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Composite()
  • CompositeBuffer(int width, int height, int useCharFlag, void *pBuf, float *zBuf, void *pTmp, float *zTmp) [protected, virtual]
  • CompositeTime [protected]
  • COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG enum value
  • ComputeVisiblePropBounds(vtkRenderer *ren, float bounds[6]) [virtual]
  • ComputeVisiblePropBoundsRMI()
  • Controller [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndInteractorTag [protected]
  • EndRender()
  • EndTag [protected]
  • ExitInteractor()
  • GetBuffersTime [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCompositeTime() [virtual]
  • GetController() [virtual]
  • GetDebug()
  • GetGetBuffersTime() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetManual() [virtual]
  • GetMaxRenderTime() [virtual]
  • GetMTime() [virtual]
  • GetReductionFactor() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetSetBuffersTime() [virtual]
  • GetUseChar() [virtual]
  • GetUseCompositing() [virtual]
  • GetZ(int x, int y)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeOffScreen()
  • InitializePieces()
  • InitializeRMIs()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Lock [protected]
  • MagnifyBuffer(float *localPdata, int windowSize[2]) [protected]
  • Manual [protected]
  • ManualOff() [virtual]
  • ManualOn() [virtual]
  • MaxRenderTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkTreeComposite &) [protected]
  • vtkCompositeManager::operator=(const vtkCompositeManager &)
  • PData [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReductionFactor [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • REN_INFO_TAG enum value
  • RENDER_RMI_TAG enum value
  • RendererSize [protected]
  • RenderRMI()
  • RenderWindow [protected]
  • RenderWindowInteractor [protected]
  • ResetCamera(vtkRenderer *ren)
  • ResetCameraClippingRange(vtkRenderer *ren)
  • ResetCameraClippingRangeTag [protected]
  • ResetCameraTag [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBuffersTime [protected]
  • SetController(vtkMultiProcessController *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetManual(int) [virtual]
  • SetReductionFactor(int factor)
  • SetReferenceCount(int)
  • SetRendererSize(int x, int y) [protected]
  • SetRenderWindow(vtkRenderWindow *renWin)
  • SetRenderWindowInteractor(vtkRenderWindowInteractor *iren) [protected]
  • SetUseChar(int) [virtual]
  • SetUseCompositing(int) [virtual]
  • StartInteractor()
  • StartInteractorTag [protected]
  • StartRender()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Tags enum name
  • Timer [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UseChar [protected]
  • UseCharOff() [virtual]
  • UseCharOn() [virtual]
  • UseCompositing [protected]
  • UseCompositingOff() [virtual]
  • UseCompositingOn() [virtual]
  • vtkCompositeManager() [protected]
  • vtkCompositeManager(const vtkCompositeManager &) [protected]
  • vtkObject() [protected]
  • vtkTreeComposite() [protected]
  • vtkTreeComposite(const vtkTreeComposite &) [protected]
  • vtkTypeRevisionMacro(vtkTreeComposite, vtkCompositeManager)
  • WIN_INFO_TAG enum value
  • ZData [protected]
  • ~vtkCompositeManager() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTreeComposite() [protected]
Generated on Mon Mar 25 01:32:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriangle Member List

This is the complete list of members for vtkTriangle, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BarycentricCoords(double x[2], double x1[2], double x2[2], double x3[2], double bcoords[3]) [static]
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Circumcircle(double p1[2], double p2[2], double p3[2], double center[2]) [static]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeNormal(vtkPoints *p, int numPts, vtkIdType *pts, float n[3]) [static]
  • ComputeNormal(float v1[3], float v2[3], float v3[3], float n[3]) [inline, static]
  • ComputeNormal(double v1[3], double v2[3], double v3[3], double n[3]) [inline, static]
  • ComputeNormalDirection(float v1[3], float v2[3], float v3[3], float n[3]) [inline, static]
  • ComputeNormalDirection(double v1[3], double v2[3], double v3[3], double n[3]) [inline, static]
  • ComputeQuadric(float x1[3], float x2[3], float x3[3], float quadric[4][4]) [static]
  • ComputeQuadric(float x1[3], float x2[3], float x3[3], vtkQuadric *quadric) [static]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [inline, virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkTriangle &) (defined in vtkTriangle) [private]
  • PointIds
  • PointInTriangle(float x[3], float x1[3], float x2[3], float x3[3], float tol2) [static]
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ProjectTo2D(double x1[3], double x2[3], double x3[3], double v1[2], double v2[2], double v3[2]) [static]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • TriangleArea(float p1[3], float p2[3], float p3[3]) [inline, static]
  • TriangleCenter(float p1[3], float p2[3], float p3[3], float center[3]) [inline, static]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkTriangle() [protected]
  • vtkTriangle(const vtkTriangle &) (defined in vtkTriangle) [private]
  • vtkTypeRevisionMacro(vtkTriangle, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTriangle() [protected]
Generated on Mon Mar 25 01:32:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriangleFilter Member List

This is the complete list of members for vtkTriangleFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassLines() [virtual]
  • GetPassVerts() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTriangleFilter &) (defined in vtkTriangleFilter) [private]
  • Outputs [protected]
  • PassLines [protected]
  • PassLinesOff() [virtual]
  • PassLinesOn() [virtual]
  • PassVerts [protected]
  • PassVertsOff() [virtual]
  • PassVertsOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPassLines(int) [virtual]
  • SetPassVerts(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTriangleFilter() [inline, protected]
  • vtkTriangleFilter(const vtkTriangleFilter &) (defined in vtkTriangleFilter) [private]
  • vtkTypeRevisionMacro(vtkTriangleFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTriangleFilter() [inline, protected]
Generated on Mon Mar 25 01:32:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriangleStrip Member List

This is the complete list of members for vtkTriangleStrip, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecomposeStrip(int npts, vtkIdType *pts, vtkCellArray *tris) [static]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetFace(int vtkNotUsed(faceId)) [inline]
  • vtkCell::GetFace(int faceId)=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkTriangleStrip &) (defined in vtkTriangleStrip) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangle [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkTriangleStrip() [protected]
  • vtkTriangleStrip(const vtkTriangleStrip &) (defined in vtkTriangleStrip) [private]
  • vtkTypeRevisionMacro(vtkTriangleStrip, vtkCell)
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkTriangleStrip() [protected]
Generated on Mon Mar 25 01:32:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriangularTCoords Member List

This is the complete list of members for vtkTriangularTCoords, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTriangularTCoords &) (defined in vtkTriangularTCoords) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTriangularTCoords() [inline, protected]
  • vtkTriangularTCoords(const vtkTriangularTCoords &) (defined in vtkTriangularTCoords) [private]
  • vtkTypeRevisionMacro(vtkTriangularTCoords, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTriangularTCoords() [inline, protected]
Generated on Mon Mar 25 01:32:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriangularTexture Member List

This is the complete list of members for vtkTriangularTexture, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetTexturePattern() [virtual]
  • GetXSize() [virtual]
  • GetYSize() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkTriangularTexture &) (defined in vtkTriangularTexture) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTexturePattern(int) [virtual]
  • SetXSize(int) [virtual]
  • SetYSize(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TexturePattern [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTriangularTexture() [protected]
  • vtkTriangularTexture(const vtkTriangularTexture &) (defined in vtkTriangularTexture) [private]
  • vtkTypeRevisionMacro(vtkTriangularTexture, vtkStructuredPointsSource)
  • XSize [protected]
  • YSize [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkTriangularTexture() [inline, protected]
Generated on Mon Mar 25 01:33:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTriArray Member List

This is the complete list of members for vtkTriArray, including all inherited members.
  • Array
  • GetNumberOfTriangles() [inline]
  • GetTriangle(vtkIdType i) [inline]
  • InsertNextTriangle(vtkLocalTri &t) [inline]
  • MaxId
  • Reset() [inline]
  • vtkTriArray(const vtkIdType sz) [inline]
  • ~vtkTriArray() [inline]
Generated on Mon Mar 25 01:33:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTubeFilter Member List

This is the complete list of members for vtkTubeFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • Capping [protected]
  • CappingOff() [virtual]
  • CappingOn() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DefaultNormal [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetCapping() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultNormal() [virtual]
  • GetDefaultNormal(float data[3]) [virtual]
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfSides() [virtual]
  • GetOffset() [virtual]
  • GetOnRatio() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRadius() [virtual]
  • GetRadiusFactor() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSidesShareVertices() [virtual]
  • GetUseDefaultNormal() [virtual]
  • GetVaryRadius() [virtual]
  • GetVaryRadiusAsString() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfSides [protected]
  • Offset [protected]
  • OnRatio [protected]
  • operator=(const vtkTubeFilter &) (defined in vtkTubeFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Radius [protected]
  • RadiusFactor [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCapping(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDefaultNormal(float, float, float) [virtual]
  • SetDefaultNormal(float[3]) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfSides(int) [virtual]
  • SetOffset(int) [virtual]
  • SetOnRatio(int) [virtual]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetRadius(float) [virtual]
  • SetRadiusFactor(float) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSidesShareVertices(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseDefaultNormal(int) [virtual]
  • SetVaryRadius(int) [virtual]
  • SetVaryRadiusToVaryRadiusByScalar() [inline]
  • SetVaryRadiusToVaryRadiusByVector() [inline]
  • SetVaryRadiusToVaryRadiusOff() [inline]
  • SidesShareVertices [protected]
  • SidesShareVerticesOff() [virtual]
  • SidesShareVerticesOn() [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseDefaultNormal [protected]
  • UseDefaultNormalOff() [virtual]
  • UseDefaultNormalOn() [virtual]
  • VaryRadius [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTubeFilter() [protected]
  • vtkTubeFilter(const vtkTubeFilter &) (defined in vtkTubeFilter) [private]
  • vtkTypeRevisionMacro(vtkTubeFilter, vtkPolyDataToPolyDataFilter)
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkTubeFilter() [inline, protected]
Generated on Mon Mar 25 01:33:02 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUGFacetReader Member List

This is the complete list of members for vtkUGFacetReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • CreateDefaultLocator()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FileName [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetLocator() [virtual]
  • GetMerging() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfParts()
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPartColorIndex(int partId)
  • GetPartNumber() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Locator [protected]
  • Merging [protected]
  • MergingOff() [virtual]
  • MergingOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkUGFacetReader &) (defined in vtkUGFacetReader) [private]
  • Outputs [protected]
  • PartColors [protected]
  • PartNumber [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocator(vtkPointLocator *locator)
  • SetMerging(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPartNumber(int) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkUGFacetReader, vtkPolyDataSource)
  • vtkUGFacetReader() [protected]
  • vtkUGFacetReader(const vtkUGFacetReader &) (defined in vtkUGFacetReader) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUGFacetReader() [protected]
Generated on Mon Mar 25 01:33:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnsignedCharArray Member List

This is the complete list of members for vtkUnsignedCharArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const unsigned char c) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const unsigned char c) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkUnsignedCharArray &) (defined in vtkUnsignedCharArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(unsigned char *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const unsigned char value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkUnsignedCharArray, vtkDataArray)
  • vtkUnsignedCharArray(vtkIdType numComp=1) [protected]
  • vtkUnsignedCharArray(const vtkUnsignedCharArray &) (defined in vtkUnsignedCharArray) [private]
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkUnsignedCharArray() [protected]
Generated on Mon Mar 25 01:33:05 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnsignedIntArray Member List

This is the complete list of members for vtkUnsignedIntArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • DeepCopy(vtkDataArray &da) [inline]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const unsigned int) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const unsigned int i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkUnsignedIntArray &) (defined in vtkUnsignedIntArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(unsigned int *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const unsigned int value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkUnsignedIntArray, vtkDataArray)
  • vtkUnsignedIntArray(vtkIdType numComp=1) [protected]
  • vtkUnsignedIntArray(const vtkUnsignedIntArray &) (defined in vtkUnsignedIntArray) [private]
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkUnsignedIntArray() [protected]
Generated on Mon Mar 25 01:33:06 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnsignedLongArray Member List

This is the complete list of members for vtkUnsignedLongArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • DeepCopy(vtkDataArray &da) [inline]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const unsigned long) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const unsigned long i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkUnsignedLongArray &) (defined in vtkUnsignedLongArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(unsigned long *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const unsigned long value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkUnsignedLongArray, vtkDataArray)
  • vtkUnsignedLongArray(vtkIdType numComp=1) [protected]
  • vtkUnsignedLongArray(const vtkUnsignedLongArray &) (defined in vtkUnsignedLongArray) [private]
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkUnsignedLongArray() [protected]
Generated on Mon Mar 25 01:33:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnsignedShortArray Member List

This is the complete list of members for vtkUnsignedShortArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *ia) [virtual]
  • DeepCopy(vtkDataArray &ia) [inline]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(const unsigned short) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, const unsigned short i) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkUnsignedShortArray &) (defined in vtkUnsignedShortArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaveUserArray [protected]
  • SetArray(unsigned short *array, vtkIdType size, int save)
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, const unsigned short value) [inline]
  • SetVoidArray(void *array, vtkIdType size, int save) [inline]
  • vtkDataArray::SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkUnsignedShortArray, vtkDataArray)
  • vtkUnsignedShortArray(vtkIdType numComp=1) [protected]
  • vtkUnsignedShortArray(const vtkUnsignedShortArray &) (defined in vtkUnsignedShortArray) [private]
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkUnsignedShortArray() [protected]
Generated on Mon Mar 25 01:33:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGrid Member List

This is the complete list of members for vtkUnstructuredGrid, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddReferenceToCell(vtkIdType ptId, vtkIdType cellId)
  • Allocate(vtkIdType numCells=1000, int extSize=1000) [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildLinks()
  • CELL_DATA_FIELD enum value
  • CellData [protected]
  • Center [protected]
  • CheckAttributes()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeBounds() [virtual]
  • ComputeTime [protected]
  • Connectivity [protected]
  • Consumers [protected]
  • CopyInformation(vtkDataObject *data)
  • CopyStructure(vtkDataSet *ds) [virtual]
  • CopyTypeSpecificInformation(vtkDataObject *data) [inline, virtual]
  • Crop() [protected, virtual]
  • DATA_OBJECT_FIELD enum value
  • DataHasBeenGenerated()
  • DataReleased [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataObject *src) [virtual]
  • Delete() [virtual]
  • Extent [protected]
  • ExtentTranslator [protected]
  • FieldData [protected]
  • FieldDataType enum name
  • FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell, vtkIdType cellId, float tol2, int &subId, float pcoords[3], float *weights) [virtual]
  • FindPoint(float x[3]) [virtual]
  • FindPoint(float x, float y, float z) [inline]
  • GetActualMemorySize() [virtual]
  • GetBounds()
  • GetBounds(float bounds[6])
  • GetCell(vtkIdType cellId) [virtual]
  • GetCell(vtkIdType cellId, vtkGenericCell *cell) [virtual]
  • GetCellBounds(vtkIdType cellId, float bounds[6]) [virtual]
  • GetCellData() [inline]
  • GetCellLinks() [inline]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds, vtkIdList *cellIds) [virtual]
  • GetCellNeighbors(vtkIdType cellId, vtkIdList &ptIds, vtkIdList &cellIds) (defined in vtkUnstructuredGrid) [inline, private]
  • GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) [virtual]
  • GetCellPoints(vtkIdType cellId, vtkIdType &npts, vtkIdType *&pts) [virtual]
  • GetCells() [inline]
  • GetCellType(vtkIdType cellId) [virtual]
  • GetCellTypes(vtkCellTypes *types) [virtual]
  • GetCenter()
  • GetCenter(float center[3])
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectType() [inline, virtual]
  • GetDataReleased() [virtual]
  • GetDebug()
  • GetEstimatedMemorySize() [virtual]
  • GetExtentTranslator()
  • GetExtentType() [inline, protected, virtual]
  • GetFieldData() [virtual]
  • GetGhostLevel() [virtual]
  • GetGlobalReleaseDataFlag() [static]
  • GetGlobalWarningDisplay() [static]
  • GetIdsOfCellsOfType(int type, vtkIntArray *array)
  • GetLength()
  • GetListOfUniqueCellTypes(vtkUnsignedCharArray *uniqueTypes)
  • GetLocality() [virtual]
  • GetMaxCellSize() [virtual]
  • GetMaximumNumberOfPieces() [virtual]
  • GetMTime() [virtual]
  • GetNetReferenceCount() [virtual]
  • GetNumberOfCells() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPieces() [virtual]
  • GetNumberOfPoints() [inline, virtual]
  • GetPiece() [virtual]
  • GetPipelineMTime() [virtual]
  • GetPoint(vtkIdType ptId) [inline, virtual]
  • GetPoint(vtkIdType ptId, float x[3]) [inline, virtual]
  • GetPointCells(vtkIdType ptId, vtkIdList *cellIds) [virtual]
  • GetPointData() [inline]
  • GetPoints() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetRequestExactExtent() [virtual]
  • GetScalarRange(float range[2]) [virtual]
  • GetScalarRange()
  • GetSource() [virtual]
  • GetUpdateExtent(int &piece, int &numPieces, int &ghostLevel)
  • GetUpdateExtent() [virtual]
  • GetUpdateExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetUpdateExtent(int[6]) [virtual]
  • GetUpdateGhostLevel() [virtual]
  • GetUpdateNumberOfPieces() [virtual]
  • GetUpdatePiece() [virtual]
  • GetUpdateTime()
  • GetWholeExtent() [virtual]
  • GetWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetWholeExtent(int[6]) [virtual]
  • GhostLevel [protected]
  • GlobalReleaseDataFlagOff() [inline]
  • GlobalReleaseDataFlagOn() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Hexahedron [protected]
  • Initialize() [virtual]
  • InsertNextCell(int type, int npts, vtkIdType *pts)
  • InsertNextCell(int type, vtkIdList *ptIds)
  • InsertNextLinkedCell(int type, int npts, vtkIdType *pts)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsHomogeneous()
  • IsTypeOf(const char *name) [static]
  • LastUpdateExtentWasOutsideOfTheExtent [protected]
  • Line [protected]
  • Links [protected]
  • Locality [protected]
  • Locations [protected]
  • Locator [protected]
  • MakeObject() [inline, virtual]
  • MaximumNumberOfPieces [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfPieces [protected]
  • operator=(const vtkUnstructuredGrid &) (defined in vtkUnstructuredGrid) [private]
  • Piece [protected]
  • PipelineMTime [protected]
  • Pixel [protected]
  • POINT_DATA_FIELD enum value
  • PointData [protected]
  • Points [protected]
  • Polygon [protected]
  • PolyLine [protected]
  • PolyVertex [protected]
  • PrepareForNewData() [inline, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PropagateUpdateExtent() [virtual]
  • Pyramid [protected]
  • Quad [protected]
  • QuadraticEdge [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseData()
  • ReleaseDataFlag [protected]
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveGhostCells(int level)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveReferenceToCell(vtkIdType ptId, vtkIdType cellId)
  • ReplaceCell(vtkIdType cellId, int npts, vtkIdType *pts)
  • RequestExactExtent [protected]
  • RequestExactExtentOff() [virtual]
  • RequestExactExtentOn() [virtual]
  • Reset()
  • ResizeCellList(vtkIdType ptId, int size)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetCells(int *types, vtkCellArray *cells)
  • SetCells(vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations, vtkCellArray *cells)
  • SetDebug(unsigned char debugFlag)
  • SetExtentTranslator(vtkExtentTranslator *translator)
  • SetFieldData(vtkFieldData *) [virtual]
  • SetGlobalReleaseDataFlag(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetLocality(float) [virtual]
  • SetMaximumNumberOfPieces(int) [virtual]
  • SetPipelineMTime(unsigned long time) [inline]
  • SetPoints(vtkPoints *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetRequestExactExtent(int v)
  • SetSource(vtkSource *s)
  • SetUpdateExtent(int piece, int numPieces, int ghostLevel)
  • SetUpdateExtent(int piece, int numPieces) [inline]
  • SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2) [inline, virtual]
  • SetUpdateExtent(int ext[6]) [inline, virtual]
  • vtkPointSet::SetUpdateExtent(int vtkNotUsed(piece), int vtkNotUsed(numPieces), int vtkNotUsed(ghostLevel)) [inline, virtual]
  • SetUpdateExtentToWholeExtent()
  • SetUpdateGhostLevel(int level)
  • SetUpdateNumberOfPieces(int num)
  • SetUpdatePiece(int piece)
  • SetWholeExtent(int, int, int, int, int, int) [virtual]
  • SetWholeExtent(int[6]) [virtual]
  • ShallowCopy(vtkDataObject *src) [virtual]
  • ShouldIReleaseData()
  • Source [protected]
  • Squeeze() [virtual]
  • SubjectHelper [protected]
  • Tetra [protected]
  • Triangle [protected]
  • TriangleStrip [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • Types [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateData() [virtual]
  • UpdateExtent [protected]
  • UpdateExtentInitialized [protected]
  • UpdateExtentIsEmpty() [protected]
  • UpdateExtentIsOutsideOfTheExtent() [protected]
  • UpdateGhostLevel [protected]
  • UpdateInformation() [virtual]
  • UpdateNumberOfPieces [protected]
  • UpdatePiece [protected]
  • UpdateTime [protected]
  • VerifyUpdateExtent() [protected, virtual]
  • Vertex [protected]
  • Voxel [protected]
  • vtkDataObject() [protected]
  • vtkDataSet() [protected]
  • vtkObject() [protected]
  • vtkPointSet() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGrid, vtkPointSet)
  • vtkUnstructuredGrid(const vtkUnstructuredGrid &) (defined in vtkUnstructuredGrid) [private]
  • vtkUnstructuredGrid() [protected]
  • Wedge [protected]
  • WholeExtent [protected]
  • ~vtkDataObject() [protected]
  • ~vtkDataSet() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSet() [protected]
  • ~vtkUnstructuredGrid() [protected]
Generated on Mon Mar 25 01:33:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGridReader Member List

This is the complete list of members for vtkUnstructuredGridReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CharacteristicsTime [protected]
  • CharacterizeFile() [protected]
  • CheckFor(const char *name, char *line, int &num, char **&array, int &allocSize) [protected]
  • CloseVTKFile()
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DecodeArrayName(char *resname, const char *name) [protected]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FieldDataName [protected]
  • FieldDataNameAllocSize [protected]
  • FieldDataNameInFile [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFieldDataName() [virtual]
  • GetFieldDataNameInFile(int i)
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInputArray() [virtual]
  • GetInputs() [inline]
  • GetInputString() [virtual]
  • GetInputStringLength() [virtual]
  • GetIStream() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNormalsNameInFile(int i)
  • GetNumberOfFieldDataInFile() [inline]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfNormalsInFile() [inline]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfScalarsInFile() [inline]
  • GetNumberOfTCoordsInFile() [inline]
  • GetNumberOfTensorsInFile() [inline]
  • GetNumberOfVectorsInFile() [inline]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFromInputString() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarLut() [protected, virtual]
  • GetScalarsName() [virtual]
  • GetScalarsNameInFile(int i)
  • GetTCoordsName() [virtual]
  • GetTCoordsNameInFile(int i)
  • GetTensorsName() [virtual]
  • GetTensorsNameInFile(int i)
  • GetVectorsName() [virtual]
  • GetVectorsNameInFile(int i)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • InformationTime [protected]
  • InitializeCharacteristics() [protected]
  • InputArray [protected]
  • Inputs [protected]
  • InputString [protected]
  • InputStringLength [protected]
  • InputStringPos [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IS [protected]
  • IsA(const char *name) [virtual]
  • IsFilePolyData() [inline]
  • IsFileRectilinearGrid() [inline]
  • IsFileStructuredGrid() [inline]
  • IsFileStructuredPoints() [inline]
  • IsFileUnstructuredGrid() [inline]
  • IsFileValid(const char *dstype)
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LookupTableName [protected]
  • LowerCase(char *str, const size_t len=256)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NormalsNameAllocSize [protected]
  • NormalsNameInFile [protected]
  • NumberOfFieldDataInFile [protected]
  • NumberOfInputs [protected]
  • NumberOfNormalsInFile [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarsInFile [protected]
  • NumberOfTCoordsInFile [protected]
  • NumberOfTensorsInFile [protected]
  • NumberOfVectorsInFile [protected]
  • OpenVTKFile()
  • operator=(const vtkUnstructuredGridReader &) (defined in vtkUnstructuredGridReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read(char *)
  • Read(unsigned char *)
  • Read(short *)
  • Read(unsigned short *)
  • Read(int *)
  • Read(unsigned int *)
  • Read(long *)
  • Read(unsigned long *)
  • Read(float *)
  • Read(double *)
  • ReadArray(const char *dataType, int numTuples, int numComp)
  • ReadCellData(vtkDataSet *ds, int numCells)
  • ReadCells(int size, int *data)
  • ReadCells(int size, int *data, int skip1, int read2, int skip3)
  • ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords)
  • ReadCoScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadDataSetData(vtkDataSet *ds) [protected]
  • ReadFieldData()
  • ReadFromInputString [protected]
  • ReadFromInputStringOff() [virtual]
  • ReadFromInputStringOn() [virtual]
  • ReadHeader()
  • ReadLine(char result[256])
  • ReadLutData(vtkDataSetAttributes *a) [protected]
  • ReadNormalData(vtkDataSetAttributes *a, int num) [protected]
  • ReadPointData(vtkDataSet *ds, int numPts)
  • ReadPoints(vtkPointSet *ps, int numPts)
  • ReadScalarData(vtkDataSetAttributes *a, int num) [protected]
  • ReadString(char result[256])
  • ReadTCoordsData(vtkDataSetAttributes *a, int num) [protected]
  • ReadTensorData(vtkDataSetAttributes *a, int num) [protected]
  • ReadVectorData(vtkDataSetAttributes *a, int num) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarLut [protected]
  • ScalarsName [protected]
  • ScalarsNameAllocSize [protected]
  • ScalarsNameInFile [protected]
  • SetAbortExecute(int) [virtual]
  • SetBinaryInputString(const char *, int len)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInputArray(vtkCharArray *) [virtual]
  • SetInputString(const char *in)
  • SetInputString(const char *in, int len)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFromInputString(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarLut(const char *) [protected, virtual]
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TCoordsNameAllocSize [protected]
  • TCoordsNameInFile [protected]
  • TensorsName [protected]
  • TensorsNameAllocSize [protected]
  • TensorsNameInFile [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VectorsName [protected]
  • VectorsNameAllocSize [protected]
  • VectorsNameInFile [protected]
  • vtkDataReader() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGridReader, vtkDataReader)
  • vtkUnstructuredGridReader() [protected]
  • vtkUnstructuredGridReader(const vtkUnstructuredGridReader &) (defined in vtkUnstructuredGridReader) [private]
  • ~vtkDataReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridReader() [protected]
Generated on Mon Mar 25 01:33:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGridSource Member List

This is the complete list of members for vtkUnstructuredGridSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkUnstructuredGridSource &) (defined in vtkUnstructuredGridSource) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGridSource, vtkSource)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridSource(const vtkUnstructuredGridSource &) (defined in vtkUnstructuredGridSource) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
Generated on Mon Mar 25 01:33:15 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGridToPolyDataFilter Member List

This is the complete list of members for vtkUnstructuredGridToPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkUnstructuredGridToPolyDataFilter &) (defined in vtkUnstructuredGridToPolyDataFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGridToPolyDataFilter, vtkPolyDataSource)
  • vtkUnstructuredGridToPolyDataFilter() [inline, protected]
  • vtkUnstructuredGridToPolyDataFilter(const vtkUnstructuredGridToPolyDataFilter &) (defined in vtkUnstructuredGridToPolyDataFilter) [inline, private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridToPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:33:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGridToUnstructuredGridFilter Member List

This is the complete list of members for vtkUnstructuredGridToUnstructuredGridFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkUnstructuredGridToUnstructuredGridFilter &) (defined in vtkUnstructuredGridToUnstructuredGridFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkUnstructuredGrid *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkUnstructuredGrid *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGridToUnstructuredGridFilter, vtkUnstructuredGridSource)
  • vtkUnstructuredGridSource() [protected]
  • vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
  • vtkUnstructuredGridToUnstructuredGridFilter(const vtkUnstructuredGridToUnstructuredGridFilter &) (defined in vtkUnstructuredGridToUnstructuredGridFilter) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkUnstructuredGridSource() [inline, protected]
  • ~vtkUnstructuredGridToUnstructuredGridFilter() [inline, protected]
Generated on Mon Mar 25 01:33:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkUnstructuredGridWriter Member List

This is the complete list of members for vtkUnstructuredGridWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CloseVTKFile(ostream *fp)
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • FieldDataName [protected]
  • FileName [protected]
  • FileType [protected]
  • GetAbortExecute() [virtual]
  • GetBinaryOutputString() [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFieldDataName() [virtual]
  • GetFileName() [virtual]
  • GetFileType() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeader() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTableName() [virtual]
  • GetMTime() [virtual]
  • GetNormalsName() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetOutputString() [virtual]
  • GetOutputStringLength() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarsName() [virtual]
  • GetTCoordsName() [virtual]
  • GetTensorsName() [virtual]
  • GetVectorsName() [virtual]
  • GetWriteToOutputString() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Header [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTableName [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NormalsName [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • OpenVTKFile() [virtual]
  • operator=(const vtkUnstructuredGridWriter &) (defined in vtkUnstructuredGridWriter) [private]
  • OutputString [protected]
  • OutputStringAllocatedLength [protected]
  • OutputStringLength [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterAndGetOutputString()
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • ScalarsName [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFieldDataName(const char *) [virtual]
  • SetFileName(const char *) [virtual]
  • SetFileType(int) [virtual]
  • SetFileTypeToASCII() [inline]
  • SetFileTypeToBinary() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeader(const char *) [virtual]
  • SetInput(vtkUnstructuredGrid *input)
  • SetLookupTableName(const char *) [virtual]
  • SetNormalsName(const char *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarsName(const char *) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTCoordsName(const char *) [virtual]
  • SetTensorsName(const char *) [virtual]
  • SetVectorsName(const char *) [virtual]
  • SetWriteToOutputString(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TCoordsName [protected]
  • TensorsName [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • VectorsName [protected]
  • vtkDataWriter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkUnstructuredGridWriter, vtkDataWriter)
  • vtkUnstructuredGridWriter() [inline, protected]
  • vtkUnstructuredGridWriter(const vtkUnstructuredGridWriter &) (defined in vtkUnstructuredGridWriter) [private]
  • vtkWriter() [protected]
  • Write() [virtual]
  • WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format, int num, int numComp) [protected]
  • WriteCellData(ostream *fp, vtkDataSet *ds)
  • WriteCells(ostream *fp, vtkCellArray *cells, const char *label)
  • WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes)
  • WriteData() [protected, virtual]
  • WriteDataSetData(ostream *fp, vtkDataSet *ds)
  • WriteFieldData(ostream *fp, vtkFieldData *f)
  • WriteHeader(ostream *fp)
  • WriteNormalData(ostream *fp, vtkDataArray *n, int num) [protected]
  • WritePointData(ostream *fp, vtkDataSet *ds)
  • WritePoints(ostream *fp, vtkPoints *p)
  • WriteScalarData(ostream *fp, vtkDataArray *s, int num) [protected]
  • WriteTCoordData(ostream *fp, vtkDataArray *tc, int num) [protected]
  • WriteTensorData(ostream *fp, vtkDataArray *t, int num) [protected]
  • WriteTime [protected]
  • WriteToOutputString [protected]
  • WriteToOutputStringOff() [virtual]
  • WriteToOutputStringOn() [virtual]
  • WriteVectorData(ostream *fp, vtkDataArray *v, int num) [protected]
  • ~vtkDataWriter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkUnstructuredGridWriter() [inline, protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:33:17 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVectorDot Member List

This is the complete list of members for vtkVectorDot, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVectorDot &) (defined in vtkVectorDot) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarRange [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkVectorDot, vtkDataSetToDataSetFilter)
  • vtkVectorDot() [protected]
  • vtkVectorDot(const vtkVectorDot &) (defined in vtkVectorDot) [private]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVectorDot() [inline, protected]
Generated on Mon Mar 25 01:33:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVectorNorm Member List

This is the complete list of members for vtkVectorNorm, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AttributeMode [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAttributeMode() [virtual]
  • GetAttributeModeAsString()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNormalize() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRectilinearGridOutput()
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetStructuredPointsOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normalize [protected]
  • NormalizeOff() [virtual]
  • NormalizeOn() [virtual]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVectorNorm &) (defined in vtkVectorNorm) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAttributeMode(int) [virtual]
  • SetAttributeModeToDefault() [inline]
  • SetAttributeModeToUseCellData() [inline]
  • SetAttributeModeToUsePointData() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input)
  • SetNormalize(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkDataSet *)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetSource() [protected]
  • vtkDataSetToDataSetFilter() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkVectorNorm, vtkDataSetToDataSetFilter)
  • vtkVectorNorm() [protected]
  • vtkVectorNorm(const vtkVectorNorm &) (defined in vtkVectorNorm) [private]
  • ~vtkDataSetSource() [inline, protected]
  • ~vtkDataSetToDataSetFilter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVectorNorm() [inline, protected]
Generated on Mon Mar 25 01:33:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVectorText Member List

This is the complete list of members for vtkVectorText, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetText() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Letters [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVectorText &) (defined in vtkVectorText) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetText(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Text [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkVectorText, vtkPolyDataSource)
  • vtkVectorText() [protected]
  • vtkVectorText(const vtkVectorText &) (defined in vtkVectorText) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVectorText() [protected]
Generated on Mon Mar 25 01:33:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVersion Member List

This is the complete list of members for vtkVersion, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetVTKBuildVersion() [inline, static]
  • GetVTKMajorVersion() [inline, static]
  • GetVTKMinorVersion() [inline, static]
  • GetVTKSourceVersion() [inline, static]
  • GetVTKVersion() [inline, static]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVersion &) (defined in vtkVersion) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVersion, vtkObject)
  • vtkVersion() [inline, protected]
  • vtkVersion(const vtkVersion &) (defined in vtkVersion) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkVersion() [inline, protected]
Generated on Mon Mar 25 01:33:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVertex Member List

This is the complete list of members for vtkVertex, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *pts, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts1, vtkCellArray *lines, vtkCellArray *verts2, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int) [inline, virtual]
  • GetFace(int) [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationFunctions(float pcoords[3], float weights[1]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVertex &) (defined in vtkVertex) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVertex, vtkCell)
  • vtkVertex() [protected]
  • vtkVertex(const vtkVertex &) (defined in vtkVertex) [private]
  • ~vtkCell() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVertex() [inline, protected]
Generated on Mon Mar 25 01:33:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVertexArray Member List

This is the complete list of members for vtkVertexArray, including all inherited members.
  • Array
  • GetNumberOfVertices() [inline]
  • GetVertex(vtkIdType i) [inline]
  • InsertNextVertex(vtkLocalVertex &v) [inline]
  • MaxId
  • Reset() [inline]
  • vtkVertexArray(const vtkIdType sz) [inline]
  • ~vtkVertexArray() [inline]
Generated on Mon Mar 25 01:33:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVideoSource Member List

This is the complete list of members for vtkVideoSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdvanceFrameBuffer(int n) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AutoAdvance [protected]
  • AutoAdvanceOff() [virtual]
  • AutoAdvanceOn() [virtual]
  • BreakOnError() [static]
  • ClipRegion [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • FastForward() [virtual]
  • FlipFrames [protected]
  • FrameBuffer [protected]
  • FrameBufferBitsPerPixel [protected]
  • FrameBufferExtent [protected]
  • FrameBufferIndex [protected]
  • FrameBufferMutex [protected]
  • FrameBufferRowAlignment [protected]
  • FrameBufferSize [protected]
  • FrameBufferTimeStamps [protected]
  • FrameCount [protected]
  • FrameIndex [protected]
  • FrameOutputExtent [protected]
  • FrameRate [protected]
  • FrameSize [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdvance() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipRegion() [virtual]
  • GetClipRegion(int &, int &, int &, int &, int &, int &) [virtual]
  • GetClipRegion(int[6]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFrameBufferSize() [virtual]
  • GetFrameCount() [virtual]
  • GetFrameIndex() [virtual]
  • GetFrameRate() [virtual]
  • GetFrameSize() [virtual]
  • GetFrameSize(int &, int &, int &) [virtual]
  • GetFrameSize(int[3]) [virtual]
  • GetFrameTimeStamp(int frame) [virtual]
  • GetFrameTimeStamp() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [inline, virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputFrames() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOpacity() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputWholeExtent() [virtual]
  • GetOutputWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetOutputWholeExtent(int[6]) [virtual]
  • GetPlaying() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRecording() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStartTimeStamp() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Grab() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Initialize() [virtual]
  • Initialized [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalGrab() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastNumberOfScalarComponents [protected]
  • LastOutputExtent [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputFrames [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • Opacity [protected]
  • operator=(const vtkVideoSource &) (defined in vtkVideoSource) [private]
  • OutputFormat [protected]
  • OutputNeedsInitialization [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • Play() [virtual]
  • PlayerThreader [protected]
  • PlayerThreadId [protected]
  • Playing [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Record() [virtual]
  • Recording [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • ReleaseSystemResources() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Rewind() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Seek(int n) [virtual]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdvance(int) [virtual]
  • SetClipRegion(int r[6]) [inline, virtual]
  • SetClipRegion(int x0, int x1, int y0, int y1, int z0, int z1) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFrameBufferSize(int FrameBufferSize) [virtual]
  • SetFrameCount(int) [virtual]
  • SetFrameRate(float rate) [virtual]
  • SetFrameSize(int x, int y, int z) [virtual]
  • SetFrameSize(int dim[3]) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputFrames(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOpacity(float) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int format) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetOutputWholeExtent(int, int, int, int, int, int) [virtual]
  • SetOutputWholeExtent(int[6]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartTimeStamp(double t) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StartTimeStamp [protected]
  • Stop() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnpackRasterLine(char *outPtr, char *rowPtr, int start, int count) [protected, virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateFrameBuffer() [protected, virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkVideoSource, vtkImageSource)
  • vtkVideoSource() [protected]
  • vtkVideoSource(const vtkVideoSource &) (defined in vtkVideoSource) [private]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVideoSource() [protected]
Generated on Mon Mar 25 01:33:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkViewport Member List

This is the complete list of members for vtkViewport, including all inherited members.
  • Actors2D [protected]
  • AddActor2D(vtkProp *p) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddProp(vtkProp *)
  • Aspect [protected]
  • Background [protected]
  • BreakOnError() [static]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeAspect()
  • CurrentPickId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DevicePickRender()=0 [protected, pure virtual]
  • DisplayPoint [protected]
  • DisplayToLocalDisplay(float &x, float &y) [virtual]
  • DisplayToNormalizedDisplay(float &u, float &v) [virtual]
  • DisplayToView() [virtual]
  • DisplayToWorld() [inline]
  • DonePick()=0 [protected, pure virtual]
  • EndTag [protected]
  • GetActors2D()
  • GetAspect() [virtual]
  • GetAspect(float data[2]) [virtual]
  • GetBackground() [virtual]
  • GetBackground(float data[3]) [virtual]
  • GetCenter() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDisplayPoint() [virtual]
  • GetDisplayPoint(float data[3]) [virtual]
  • GetDisplayPoint(double *a) [inline]
  • GetGlobalWarningDisplay() [static]
  • GetIsPicking() [virtual]
  • GetMTime() [virtual]
  • GetOrigin()
  • GetPickedId()=0 [protected, pure virtual]
  • GetPickedZ()=0 [pure virtual]
  • GetPickX() [virtual]
  • GetPickY() [virtual]
  • GetPixelAspect() [virtual]
  • GetPixelAspect(float data[2]) [virtual]
  • GetProps() [inline]
  • GetReferenceCount() [inline]
  • GetSize()
  • GetTiledSize(int *width, int *height)
  • GetViewPoint() [virtual]
  • GetViewPoint(float data[3]) [virtual]
  • GetViewport() [virtual]
  • GetViewport(float data[4]) [virtual]
  • GetVTKWindow()=0 [pure virtual]
  • GetWorldPoint() [virtual]
  • GetWorldPoint(float data[4]) [virtual]
  • GetWorldPoint(double *a) [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsInViewport(int x, int y) [virtual]
  • IsPicking [protected]
  • IsTypeOf(const char *name) [static]
  • LocalDisplayToDisplay(float &x, float &y) [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • NormalizedDisplayToDisplay(float &u, float &v) [virtual]
  • NormalizedDisplayToViewport(float &x, float &y) [virtual]
  • NormalizedViewportToView(float &x, float &y, float &z) [virtual]
  • NormalizedViewportToViewport(float &u, float &v) [virtual]
  • operator=(const vtkViewport &) (defined in vtkViewport) [private]
  • Origin [protected]
  • PickedProp [protected]
  • PickFromProps [protected]
  • PickProp(float selectionX, float selectionY)=0 [pure virtual]
  • PickPropFrom(float selectionX, float selectionY, vtkPropCollection *)
  • PickX [protected]
  • PickY [protected]
  • PixelAspect [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Props [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveActor2D(vtkProp *p)
  • RemoveAllProps(void)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveProp(vtkProp *)
  • SafeDownCast(vtkObject *o) [static]
  • SetAspect(float, float) [virtual]
  • SetAspect(float[2])
  • SetBackground(float, float, float) [virtual]
  • SetBackground(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPoint(float, float, float) [virtual]
  • SetDisplayPoint(float[3]) [virtual]
  • SetEndRenderMethod(void(*f)(void *), void *arg)
  • SetEndRenderMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPixelAspect(float, float) [virtual]
  • SetPixelAspect(float[2])
  • SetReferenceCount(int)
  • SetStartRenderMethod(void(*f)(void *), void *arg)
  • SetStartRenderMethodArgDelete(void(*f)(void *))
  • SetViewPoint(float, float, float) [virtual]
  • SetViewPoint(float[3]) [virtual]
  • SetViewport(float, float, float, float) [virtual]
  • SetViewport(float[4]) [virtual]
  • SetWorldPoint(float, float, float, float) [virtual]
  • SetWorldPoint(float[4]) [virtual]
  • Size [protected]
  • StartPick(unsigned int pickFromSize)=0 [protected, pure virtual]
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdatePickId()=0 [protected, pure virtual]
  • ViewPoint [protected]
  • Viewport [protected]
  • ViewportToNormalizedDisplay(float &x, float &y) [virtual]
  • ViewportToNormalizedViewport(float &u, float &v) [virtual]
  • ViewToDisplay() [virtual]
  • ViewToNormalizedViewport(float &x, float &y, float &z) [virtual]
  • ViewToWorld() [virtual]
  • ViewToWorld(float &, float &, float &) [inline, virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkViewport, vtkObject)
  • vtkViewport() [protected]
  • vtkViewport(const vtkViewport &) (defined in vtkViewport) [private]
  • VTKWindow [protected]
  • WorldPoint [protected]
  • WorldToDisplay() [inline]
  • WorldToView() [virtual]
  • WorldToView(float &, float &, float &) [inline, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkViewport() [protected]
Generated on Mon Mar 25 01:33:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVoidArray Member List

This is the complete list of members for vtkVoidArray, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(const vtkIdType sz, const vtkIdType ext=1000) [virtual]
  • Array [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeRange(int comp) [virtual]
  • CopyComponent(const int j, vtkDataArray *from, const int fromComponent) [virtual]
  • CreateDataArray(int dataType) [static]
  • CreateDefaultLookupTable()
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkDataArray *da) [virtual]
  • Delete() [virtual]
  • FillComponent(const int j, const float c) [virtual]
  • GetActualMemorySize()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetComponent(const vtkIdType i, const int j) [virtual]
  • GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin, int compMax, vtkFloatArray *data) [virtual]
  • GetDataType() [inline, virtual]
  • GetDataTypeMax()
  • GetDataTypeMin()
  • GetDataTypeRange(double range[2])
  • GetDataTypeSize() [inline, virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetLookupTable() [virtual]
  • GetMaxId() [inline]
  • GetMaxNorm() [virtual]
  • GetMTime() [virtual]
  • GetName()
  • GetNumberOfComponents() [inline]
  • GetNumberOfTuples() [inline]
  • GetPointer(const vtkIdType id) [inline]
  • GetRange(float range[2], int comp) [inline]
  • GetRange(int comp) [inline]
  • GetRange() [inline]
  • GetRange(float range[2]) [inline]
  • GetReferenceCount() [inline]
  • GetSize() [inline]
  • GetTuple(const vtkIdType i) [virtual]
  • GetTuple(const vtkIdType i, float *tuple) [virtual]
  • GetTuple(const vtkIdType i, double *tuple) [virtual]
  • GetTuple1(const vtkIdType i)
  • GetTuple2(const vtkIdType i)
  • GetTuple3(const vtkIdType i)
  • GetTuple4(const vtkIdType i)
  • GetTuple9(const vtkIdType i)
  • GetTuples(vtkIdList *ptIds, vtkDataArray *output)
  • GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output)
  • GetValue(const vtkIdType id) [inline]
  • GetVoidPointer(const vtkIdType id) [inline, virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [virtual]
  • InsertComponent(const vtkIdType i, const int j, const float c) [virtual]
  • InsertNextTuple(const float *tuple) [virtual]
  • InsertNextTuple(const double *tuple) [virtual]
  • InsertNextTuple1(float value)
  • InsertNextTuple2(float val0, float val1)
  • InsertNextTuple3(float val0, float val1, float val2)
  • InsertNextTuple4(float val0, float val1, float val2, float val3)
  • InsertNextTuple9(float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertNextValue(void *v) [inline]
  • InsertTuple(const vtkIdType i, const float *tuple) [virtual]
  • InsertTuple(const vtkIdType i, const double *tuple) [virtual]
  • InsertTuple1(const vtkIdType i, float value)
  • InsertTuple2(const vtkIdType i, float val0, float val1)
  • InsertTuple3(const vtkIdType i, float val0, float val1, float val2)
  • InsertTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • InsertTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • InsertValue(const vtkIdType id, void *p) [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LookupTable [protected]
  • MakeObject() [inline, virtual]
  • MaxId [protected]
  • Modified() [virtual]
  • MTime [protected]
  • Name [protected]
  • New() [static]
  • NumberOfComponents [protected]
  • operator=(const vtkVoidArray &) (defined in vtkVoidArray) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Reset() [inline]
  • Resize(vtkIdType numTuples) [virtual]
  • ResizeAndExtend(const vtkIdType sz) [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetComponent(const vtkIdType i, const int j, const float c) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetLookupTable(vtkLookupTable *lut)
  • SetName(const char *name)
  • SetNumberOfComponents(int) [virtual]
  • SetNumberOfTuples(const vtkIdType number) [virtual]
  • SetNumberOfValues(const vtkIdType number) [inline]
  • SetReferenceCount(int)
  • SetTuple(const vtkIdType i, const float *tuple) [virtual]
  • SetTuple(const vtkIdType i, const double *tuple) [virtual]
  • SetTuple1(const vtkIdType i, float value)
  • SetTuple2(const vtkIdType i, float val0, float val1)
  • SetTuple3(const vtkIdType i, float val0, float val1, float val2)
  • SetTuple4(const vtkIdType i, float val0, float val1, float val2, float val3)
  • SetTuple9(const vtkIdType i, float val0, float val1, float val2, float val3, float val4, float val5, float val6, float val7, float val8)
  • SetValue(const vtkIdType id, void *value) [inline]
  • SetVoidArray(void *vtkNotUsed(array), vtkIdType vtkNotUsed(size), int vtkNotUsed(save)) [inline, virtual]
  • Size [protected]
  • Squeeze() [inline, virtual]
  • SubjectHelper [protected]
  • Tuple [protected]
  • TupleSize [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkDataArray(vtkIdType numComp=1) [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVoidArray, vtkDataArray)
  • vtkVoidArray() [protected]
  • vtkVoidArray(const vtkVoidArray &) (defined in vtkVoidArray) [private]
  • WritePointer(const vtkIdType id, const vtkIdType number) [inline]
  • ~vtkDataArray() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVoidArray() [protected]
Generated on Mon Mar 25 01:33:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolume16Reader Member List

This is the complete list of members for vtkVolume16Reader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdjustSpacingAndOrigin(int dimensions[3], float Spacing[3], float origin[3]) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeTransformedBounds(int bounds[6]) [protected]
  • ComputeTransformedDimensions(int dimensions[3]) [protected]
  • ComputeTransformedOrigin(float origin[3]) [protected]
  • ComputeTransformedSpacing(float Spacing[3]) [protected]
  • DataDimensions [protected]
  • DataMask [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataByteOrder()
  • GetDataByteOrderAsString()
  • GetDataDimensions() [virtual]
  • GetDataDimensions(int data[2]) [virtual]
  • GetDataMask() [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeaderSize() [virtual]
  • GetImage(int ImageNumber) [virtual]
  • GetImageRange() [virtual]
  • GetImageRange(int data[2]) [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSwapBytes() [virtual]
  • GetTransform() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HeaderSize [protected]
  • ImageRange [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolume16Reader &) (defined in vtkVolume16Reader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Read16BitImage(FILE *fp, unsigned short *pixels, int xsize, int ysize, int skip, int swapBytes) [protected]
  • ReadImage(int ImageNumber) [protected]
  • ReadVolume(int FirstImage, int LastImage) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataByteOrder(int)
  • SetDataByteOrderToBigEndian()
  • SetDataByteOrderToLittleEndian()
  • SetDataDimensions(int, int) [virtual]
  • SetDataDimensions(int[2])
  • SetDataMask(unsigned short) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePattern(const char *) [virtual]
  • SetFilePrefix(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetHeaderSize(int) [virtual]
  • SetImageRange(int, int) [virtual]
  • SetImageRange(int[2])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSwapBytes(int) [virtual]
  • SetTransform(vtkTransform *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • SwapBytes [protected]
  • SwapBytesOff() [virtual]
  • SwapBytesOn() [virtual]
  • Transform [protected]
  • TransformSlice(unsigned short *slice, unsigned short *pixels, int k, int dimensions[3], int bounds[3]) [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkVolume16Reader, vtkVolumeReader)
  • vtkVolume16Reader() [protected]
  • vtkVolume16Reader(const vtkVolume16Reader &) (defined in vtkVolume16Reader) [private]
  • vtkVolumeReader() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkVolume16Reader() [protected]
  • ~vtkVolumeReader() [protected]
Generated on Mon Mar 25 01:33:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolume Member List

This is the complete list of members for vtkVolume, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOrientation(float, float, float)
  • AddOrientation(float a[3])
  • AddPosition(float deltaPosition[3])
  • AddPosition(float deltaX, float deltaY, float deltaZ)
  • AllocatedRenderTime [protected]
  • ArraySize [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • CachedProp3D [protected]
  • Center [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeMatrix() [virtual]
  • ComputeScreenCoverage(vtkViewport *vp) [protected]
  • Consumers [protected]
  • CorrectedScalarOpacityArray [protected]
  • CorrectedScalarOpacityArrayMTime [protected]
  • CorrectedStepSize [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *) [inline, virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetArraySize() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCorrectedScalarOpacityArray() [inline]
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientOpacityArray() [inline]
  • GetGradientOpacityConstant() [inline]
  • GetGrayArray() [inline]
  • GetIsIdentity() [virtual]
  • GetLength()
  • GetMapper() [virtual]
  • GetMatrix(vtkMatrix4x4 *m) [virtual]
  • GetMatrix(double m[16]) [virtual]
  • GetMatrix() [inline, virtual]
  • GetMaxXBound()
  • GetMaxYBound()
  • GetMaxZBound()
  • GetMinXBound()
  • GetMinYBound()
  • GetMinZBound()
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetOrientation()
  • GetOrientation(float o[3])
  • GetOrientationWXYZ()
  • GetOrigin() [virtual]
  • GetOrigin(float data[3]) [virtual]
  • GetPickable() [virtual]
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProperty()
  • GetRedrawMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetRGBArray() [inline]
  • GetScalarOpacityArray() [inline]
  • GetScale() [virtual]
  • GetScale(float data[3]) [virtual]
  • GetUserMatrix() [inline]
  • GetUserTransform() [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *vc) [virtual]
  • GetXRange()
  • GetYRange()
  • GetZRange()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientOpacityArray [protected]
  • GradientOpacityArrayMTime [protected]
  • GradientOpacityConstant [protected]
  • GrayArray [protected]
  • GrayArrayMTime [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitPathTraversal() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsIdentity [protected]
  • IsTypeOf(const char *name) [static]
  • Mapper [protected]
  • Matrix [protected]
  • MatrixMTime [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • operator=(const vtkVolume &) (defined in vtkVolume) [private]
  • Orientation [protected]
  • Origin [protected]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PokeMatrix(vtkMatrix4x4 *matrix)
  • vtkProp::PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveConsumer(vtkObject *c)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *) [inline, virtual]
  • RenderOverlay(vtkViewport *) [inline, virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport) [virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • RGBArray [protected]
  • RGBArrayMTime [protected]
  • RotateWXYZ(float, float, float, float)
  • RotateX(float)
  • RotateY(float)
  • RotateZ(float)
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • ScalarOpacityArray [protected]
  • ScalarOpacityArrayMTime [protected]
  • Scale [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapper(vtkVolumeMapper *mapper)
  • SetOrientation(float, float, float)
  • SetOrientation(float a[3])
  • SetOrigin(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetOrigin(float _arg[3]) [inline, virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPosition(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetPosition(float _arg[3]) [inline, virtual]
  • SetProperty(vtkVolumeProperty *property)
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetScale(float _arg1, float _arg2, float _arg3) [inline, virtual]
  • SetScale(float _arg[3]) [inline, virtual]
  • SetScale(float s) [inline]
  • SetUserMatrix(vtkMatrix4x4 *matrix)
  • SetUserTransform(vtkLinearTransform *transform)
  • SetVisibility(int) [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Transform [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateScalarOpacityforSampleSize(vtkRenderer *ren, float sample_distance)
  • UpdateTransferFunctions(vtkRenderer *ren)
  • UserMatrix [protected]
  • UserTransform [protected]
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkProp3D() [protected]
  • vtkTypeRevisionMacro(vtkVolume, vtkProp3D)
  • vtkVolume() [protected]
  • vtkVolume(const vtkVolume &) (defined in vtkVolume) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkProp3D() [protected]
  • ~vtkVolume() [protected]
Generated on Mon Mar 25 01:33:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeCollection Member List

This is the complete list of members for vtkVolumeCollection, including all inherited members.
  • AddItem(vtkVolume *a) [inline]
  • AddItem(vtkObject *o) (defined in vtkVolumeCollection) [inline, private]
  • AddItem(vtkProp *o) (defined in vtkVolumeCollection) [inline, private]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bottom [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Current [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteElement(vtkCollectionElement *) [protected, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetItemAsObject(int i)
  • GetLastProp() [inline]
  • GetMTime() [virtual]
  • GetNextItem() [inline]
  • GetNextItemAsObject() [inline]
  • GetNextProp() [inline]
  • GetNextVolume() [inline]
  • GetNumberOfItems()
  • GetNumberOfPaths()
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitTraversal() [inline]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsItemPresent(vtkObject *)
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfItems [protected]
  • operator=(const vtkVolumeCollection &) (defined in vtkVolumeCollection) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllItems()
  • RemoveItem(int i)
  • RemoveItem(vtkObject *)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReplaceItem(int i, vtkObject *)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • Top [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCollection() [protected]
  • vtkObject() [protected]
  • vtkPropCollection() [inline, protected]
  • vtkTypeRevisionMacro(vtkVolumeCollection, vtkPropCollection)
  • vtkVolumeCollection() [inline, protected]
  • vtkVolumeCollection(const vtkVolumeCollection &) (defined in vtkVolumeCollection) [private]
  • ~vtkCollection() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPropCollection() [inline, protected]
  • ~vtkVolumeCollection() [inline, protected]
Generated on Mon Mar 25 01:33:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeMapper Member List

This is the complete list of members for vtkVolumeMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLength()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeMapper &) (defined in vtkVolumeMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkVolume *vol)=0 [pure virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeMapper, vtkAbstractMapper3D)
  • vtkVolumeMapper() [protected]
  • vtkVolumeMapper(const vtkVolumeMapper &) (defined in vtkVolumeMapper) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
Generated on Mon Mar 25 01:33:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeProMapper Member List

This is the complete list of members for vtkVolumeProMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BlendMode [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • Context [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Cursor [protected]
  • CursorOff() [virtual]
  • CursorOn() [virtual]
  • CursorPosition [protected]
  • CursorType [protected]
  • CursorXAxisColor [protected]
  • CursorYAxisColor [protected]
  • CursorZAxisColor [protected]
  • Cut [protected]
  • CutPlane [protected]
  • CutPlaneEquation [protected]
  • CutPlaneFallOffDistance [protected]
  • CutPlaneOff() [virtual]
  • CutPlaneOn() [virtual]
  • CutPlaneThickness [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayedMessage [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAvailableBoardMemory() [inline, virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetCursor() [virtual]
  • GetCursorPosition() [virtual]
  • GetCursorPosition(double data[3]) [virtual]
  • GetCursorType() [virtual]
  • GetCursorTypeAsString(void) [inline]
  • GetCursorXAxisColor() [virtual]
  • GetCursorXAxisColor(double data[3]) [virtual]
  • GetCursorYAxisColor() [virtual]
  • GetCursorYAxisColor(double data[3]) [virtual]
  • GetCursorZAxisColor() [virtual]
  • GetCursorZAxisColor(double data[3]) [virtual]
  • GetCutPlane() [virtual]
  • GetCutPlaneEquation() [virtual]
  • GetCutPlaneEquation(double data[4]) [virtual]
  • GetCutPlaneFallOffDistance() [virtual]
  • GetCutPlaneThickness() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientDiffuseModulation() [virtual]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetGradientOpacityModulation() [virtual]
  • GetGradientSpecularModulation() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetLockSizesForBoardMemory(unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize)) [inline, virtual]
  • GetMajorBoardVersion() [virtual]
  • GetMinorBoardVersion() [virtual]
  • GetMTime() [virtual]
  • GetNoHardware() [virtual]
  • GetNumberOfBoards() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetSubVolume() [virtual]
  • GetSubVolume(int data[6]) [virtual]
  • GetSuperSampling() [virtual]
  • GetSuperSamplingFactor() [virtual]
  • GetSuperSamplingFactor(double data[3]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetWrongVLIVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientDiffuseModulation [protected]
  • GradientDiffuseModulationOff() [virtual]
  • GradientDiffuseModulationOn() [virtual]
  • GradientOpacityModulation [protected]
  • GradientOpacityModulationOff() [virtual]
  • GradientOpacityModulationOn() [virtual]
  • GradientSpecularModulation [protected]
  • GradientSpecularModulationOff() [virtual]
  • GradientSpecularModulationOn() [virtual]
  • GradientTableSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Lights [protected]
  • LookupTable [protected]
  • MajorBoardVersion [protected]
  • MinorBoardVersion [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoHardware [protected]
  • NumberOfBoards [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLights [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeProMapper &) (defined in vtkVolumeProMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToComposite() [inline]
  • SetBlendModeToMaximumIntensity() [inline]
  • SetBlendModeToMinimumIntensity() [inline]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetCursor(int) [virtual]
  • SetCursorPosition(double, double, double) [virtual]
  • SetCursorPosition(double[3]) [virtual]
  • SetCursorType(int) [virtual]
  • SetCursorTypeToCrossHair() [inline]
  • SetCursorTypeToPlane() [inline]
  • SetCursorXAxisColor(double, double, double) [virtual]
  • SetCursorXAxisColor(double[3]) [virtual]
  • SetCursorYAxisColor(double, double, double) [virtual]
  • SetCursorYAxisColor(double[3]) [virtual]
  • SetCursorZAxisColor(double, double, double) [virtual]
  • SetCursorZAxisColor(double[3]) [virtual]
  • SetCutPlane(int) [virtual]
  • SetCutPlaneEquation(double, double, double, double) [virtual]
  • SetCutPlaneEquation(double[4]) [virtual]
  • SetCutPlaneFallOffDistance(int) [virtual]
  • SetCutPlaneThickness(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientDiffuseModulation(int) [virtual]
  • SetGradientOpacityModulation(int) [virtual]
  • SetGradientSpecularModulation(int) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubVolume(int, int, int, int, int, int) [virtual]
  • SetSubVolume(int[6]) [virtual]
  • SetSuperSampling(int) [virtual]
  • SetSuperSamplingFactor(double x, double y, double z)
  • SetSuperSamplingFactor(double f[3]) [inline]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StatusOK() [protected]
  • SubjectHelper [protected]
  • SubVolume [protected]
  • SuperSampling [protected]
  • SuperSamplingFactor [protected]
  • SuperSamplingOff() [virtual]
  • SuperSamplingOn() [virtual]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • Volume [protected]
  • VolumeBuildTime [protected]
  • VolumeDataType [protected]
  • VolumeInput [protected]
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeProMapper, vtkVolumeMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeProMapper() [protected]
  • vtkVolumeProMapper(const vtkVolumeProMapper &) (defined in vtkVolumeProMapper) [private]
  • WrongVLIVersion [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeProMapper() [protected]
Generated on Mon Mar 25 01:33:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeProperty Member List

This is the complete list of members for vtkVolumeProperty, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Ambient [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorChannels [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Diffuse [protected]
  • GetAmbient(int index)
  • GetAmbient() [inline]
  • GetClassName() [inline, virtual]
  • GetColorChannels(int index)
  • GetColorChannels() [inline]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDiffuse(int index)
  • GetDiffuse() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetGradientOpacity(int index)
  • GetGradientOpacity() [inline]
  • GetGradientOpacityMTime(int index)
  • GetGradientOpacityMTime() [inline]
  • GetGrayTransferFunction(int index)
  • GetGrayTransferFunction() [inline]
  • GetGrayTransferFunctionMTime(int index)
  • GetGrayTransferFunctionMTime() [inline]
  • GetInterpolationType() [virtual]
  • GetInterpolationTypeAsString(void) [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRGBTransferFunction(int index)
  • GetRGBTransferFunction() [inline]
  • GetRGBTransferFunctionMTime(int index)
  • GetRGBTransferFunctionMTime() [inline]
  • GetScalarOpacity(int index)
  • GetScalarOpacity() [inline]
  • GetScalarOpacityMTime(int index)
  • GetScalarOpacityMTime() [inline]
  • GetShade(int index)
  • GetShade() [inline]
  • GetSpecular(int index)
  • GetSpecular() [inline]
  • GetSpecularPower(int index)
  • GetSpecularPower() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientOpacity [protected]
  • GradientOpacityMTime [protected]
  • GrayTransferFunction [protected]
  • GrayTransferFunctionMTime [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InterpolationType [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVolumeProperty &) (defined in vtkVolumeProperty) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RGBTransferFunction [protected]
  • RGBTransferFunctionMTime [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarOpacity [protected]
  • ScalarOpacityMTime [protected]
  • SetAmbient(int index, float value)
  • SetAmbient(float value) [inline]
  • SetColor(int index, vtkPiecewiseFunction *function)
  • SetColor(vtkPiecewiseFunction *f) [inline]
  • SetColor(int index, vtkColorTransferFunction *function)
  • SetColor(vtkColorTransferFunction *f) [inline]
  • SetDebug(unsigned char debugFlag)
  • SetDiffuse(int index, float value)
  • SetDiffuse(float value) [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientOpacity(int index, vtkPiecewiseFunction *function)
  • SetGradientOpacity(vtkPiecewiseFunction *function) [inline]
  • SetInterpolationType(int) [virtual]
  • SetInterpolationTypeToLinear() [inline]
  • SetInterpolationTypeToNearest() [inline]
  • SetReferenceCount(int)
  • SetScalarOpacity(int index, vtkPiecewiseFunction *function)
  • SetScalarOpacity(vtkPiecewiseFunction *f) [inline]
  • SetShade(int index, int value)
  • SetShade(int value) [inline]
  • SetSpecular(int index, float value)
  • SetSpecular(float value) [inline]
  • SetSpecularPower(int index, float value)
  • SetSpecularPower(float value) [inline]
  • Shade [protected]
  • ShadeOff(int index)
  • ShadeOff() [inline]
  • ShadeOn(int index)
  • ShadeOn() [inline]
  • Specular [protected]
  • SpecularPower [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateMTimes()
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeProperty, vtkObject)
  • vtkVolumeProperty() [protected]
  • vtkVolumeProperty(const vtkVolumeProperty &) (defined in vtkVolumeProperty) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkVolumeProperty() [protected]
Generated on Mon Mar 25 01:33:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeProVG500Mapper Member List

This is the complete list of members for vtkVolumeProVG500Mapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BlendMode [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • Context [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • CorrectBasePlaneSize(VLIPixel *inBase, int inSize[2], VLIPixel **outBase, int outSize[2], VLIVector2D textureCoords[6]) [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Cursor [protected]
  • CursorOff() [virtual]
  • CursorOn() [virtual]
  • CursorPosition [protected]
  • CursorType [protected]
  • CursorXAxisColor [protected]
  • CursorYAxisColor [protected]
  • CursorZAxisColor [protected]
  • Cut [protected]
  • CutPlane [protected]
  • CutPlaneEquation [protected]
  • CutPlaneFallOffDistance [protected]
  • CutPlaneOff() [virtual]
  • CutPlaneOn() [virtual]
  • CutPlaneThickness [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayedMessage [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAvailableBoardMemory() [virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetCursor() [virtual]
  • GetCursorPosition() [virtual]
  • GetCursorPosition(double data[3]) [virtual]
  • GetCursorType() [virtual]
  • GetCursorTypeAsString(void) [inline]
  • GetCursorXAxisColor() [virtual]
  • GetCursorXAxisColor(double data[3]) [virtual]
  • GetCursorYAxisColor() [virtual]
  • GetCursorYAxisColor(double data[3]) [virtual]
  • GetCursorZAxisColor() [virtual]
  • GetCursorZAxisColor(double data[3]) [virtual]
  • GetCutPlane() [virtual]
  • GetCutPlaneEquation() [virtual]
  • GetCutPlaneEquation(double data[4]) [virtual]
  • GetCutPlaneFallOffDistance() [virtual]
  • GetCutPlaneThickness() [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientDiffuseModulation() [virtual]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetGradientOpacityModulation() [virtual]
  • GetGradientSpecularModulation() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetLockSizesForBoardMemory(unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize) [virtual]
  • vtkVolumeProMapper::GetLockSizesForBoardMemory(unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize)) [inline, virtual]
  • GetMajorBoardVersion() [virtual]
  • GetMinorBoardVersion() [virtual]
  • GetMTime() [virtual]
  • GetNoHardware() [virtual]
  • GetNumberOfBoards() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetSubVolume() [virtual]
  • GetSubVolume(int data[6]) [virtual]
  • GetSuperSampling() [virtual]
  • GetSuperSamplingFactor() [virtual]
  • GetSuperSamplingFactor(double data[3]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetWrongVLIVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientDiffuseModulation [protected]
  • GradientDiffuseModulationOff() [virtual]
  • GradientDiffuseModulationOn() [virtual]
  • GradientOpacityModulation [protected]
  • GradientOpacityModulationOff() [virtual]
  • GradientOpacityModulationOn() [virtual]
  • GradientSpecularModulation [protected]
  • GradientSpecularModulationOff() [virtual]
  • GradientSpecularModulationOn() [virtual]
  • GradientTableSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Lights [protected]
  • LoadedDataSize [protected]
  • LookupTable [protected]
  • MajorBoardVersion [protected]
  • MinorBoardVersion [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoHardware [protected]
  • NumberOfBoards [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLights [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeProVG500Mapper &) (defined in vtkVolumeProVG500Mapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderHexagon(vtkRenderer *vtkNotUsed(ren), vtkVolume *vtkNotUsed(vol), VLIPixel *vtkNotUsed(basePlane), int size[2], VLIVector3D hexagon[6], VLIVector2D textureCoords[6]) [inline, protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToComposite() [inline]
  • SetBlendModeToMaximumIntensity() [inline]
  • SetBlendModeToMinimumIntensity() [inline]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetCursor(int) [virtual]
  • SetCursorPosition(double, double, double) [virtual]
  • SetCursorPosition(double[3]) [virtual]
  • SetCursorType(int) [virtual]
  • SetCursorTypeToCrossHair() [inline]
  • SetCursorTypeToPlane() [inline]
  • SetCursorXAxisColor(double, double, double) [virtual]
  • SetCursorXAxisColor(double[3]) [virtual]
  • SetCursorYAxisColor(double, double, double) [virtual]
  • SetCursorYAxisColor(double[3]) [virtual]
  • SetCursorZAxisColor(double, double, double) [virtual]
  • SetCursorZAxisColor(double[3]) [virtual]
  • SetCutPlane(int) [virtual]
  • SetCutPlaneEquation(double, double, double, double) [virtual]
  • SetCutPlaneEquation(double[4]) [virtual]
  • SetCutPlaneFallOffDistance(int) [virtual]
  • SetCutPlaneThickness(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientDiffuseModulation(int) [virtual]
  • SetGradientOpacityModulation(int) [virtual]
  • SetGradientSpecularModulation(int) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubVolume(int, int, int, int, int, int) [virtual]
  • SetSubVolume(int[6]) [virtual]
  • SetSuperSampling(int) [virtual]
  • SetSuperSamplingFactor(double x, double y, double z)
  • SetSuperSamplingFactor(double f[3]) [inline]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StatusOK() [protected]
  • SubjectHelper [protected]
  • SubVolume [protected]
  • SuperSampling [protected]
  • SuperSamplingFactor [protected]
  • SuperSamplingOff() [virtual]
  • SuperSamplingOn() [virtual]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateCamera(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCropping(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCursor(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCutPlane(vtkRenderer *, vtkVolume *) [protected]
  • UpdateLights(vtkRenderer *, vtkVolume *) [protected]
  • UpdateProgress(float amount)
  • UpdateProperties(vtkRenderer *, vtkVolume *) [protected]
  • UpdateVolume(vtkRenderer *, vtkVolume *) [protected]
  • Volume [protected]
  • VolumeBuildTime [protected]
  • VolumeDataType [protected]
  • VolumeInput [protected]
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeProVG500Mapper, vtkVolumeProMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeProMapper() [protected]
  • vtkVolumeProVG500Mapper() [protected]
  • vtkVolumeProVG500Mapper(const vtkVolumeProVG500Mapper &) (defined in vtkVolumeProVG500Mapper) [private]
  • WrongVLIVersion [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeProMapper() [protected]
  • ~vtkVolumeProVG500Mapper() [protected]
Generated on Mon Mar 25 01:33:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeProVP1000Mapper Member List

This is the complete list of members for vtkVolumeProVP1000Mapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BlendMode [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • CheckSubSampling(const VLIVolume *inVolume, const VLIContext *inContext, int &outImageWidth, int &outImageHeight) [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • Context [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Cursor [protected]
  • CursorOff() [virtual]
  • CursorOn() [virtual]
  • CursorPosition [protected]
  • CursorType [protected]
  • CursorXAxisColor [protected]
  • CursorYAxisColor [protected]
  • CursorZAxisColor [protected]
  • Cut [protected]
  • CutPlane [protected]
  • CutPlaneEquation [protected]
  • CutPlaneFallOffDistance [protected]
  • CutPlaneOff() [virtual]
  • CutPlaneOn() [virtual]
  • CutPlaneThickness [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DepthBuffer [protected]
  • DisplayedMessage [protected]
  • DrawBoundingBox [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAvailableBoardMemory() [virtual]
  • GetBlendMode() [virtual]
  • GetBlendModeAsString(void) [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetCursor() [virtual]
  • GetCursorPosition() [virtual]
  • GetCursorPosition(double data[3]) [virtual]
  • GetCursorType() [virtual]
  • GetCursorTypeAsString(void) [inline]
  • GetCursorXAxisColor() [virtual]
  • GetCursorXAxisColor(double data[3]) [virtual]
  • GetCursorYAxisColor() [virtual]
  • GetCursorYAxisColor(double data[3]) [virtual]
  • GetCursorZAxisColor() [virtual]
  • GetCursorZAxisColor(double data[3]) [virtual]
  • GetCutPlane() [virtual]
  • GetCutPlaneEquation() [virtual]
  • GetCutPlaneEquation(double data[4]) [virtual]
  • GetCutPlaneFallOffDistance() [virtual]
  • GetCutPlaneThickness() [virtual]
  • GetDebug()
  • GetDepthBufferValues(vtkRenderer *vtkNotUsed(ren), int size[2], unsigned int *outData) [inline, protected, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGradientDiffuseModulation() [virtual]
  • GetGradientMagnitudeBias() [inline, virtual]
  • GetGradientMagnitudeScale() [inline, virtual]
  • GetGradientOpacityModulation() [virtual]
  • GetGradientSpecularModulation() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetLockSizesForBoardMemory(unsigned int type, unsigned int *xSize, unsigned int *ySize, unsigned int *zSize) [virtual]
  • vtkVolumeProMapper::GetLockSizesForBoardMemory(unsigned int vtkNotUsed(type), unsigned int *vtkNotUsed(xSize), unsigned int *vtkNotUsed(ySize), unsigned int *vtkNotUsed(zSize)) [inline, virtual]
  • GetMajorBoardVersion() [virtual]
  • GetMinorBoardVersion() [virtual]
  • GetMTime() [virtual]
  • GetNoHardware() [virtual]
  • GetNumberOfBoards() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetSubVolume() [virtual]
  • GetSubVolume(int data[6]) [virtual]
  • GetSuperSampling() [virtual]
  • GetSuperSamplingFactor() [virtual]
  • GetSuperSamplingFactor(double data[3]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetWrongVLIVersion() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientDiffuseModulation [protected]
  • GradientDiffuseModulationOff() [virtual]
  • GradientDiffuseModulationOn() [virtual]
  • GradientOpacityModulation [protected]
  • GradientOpacityModulationOff() [virtual]
  • GradientOpacityModulationOn() [virtual]
  • GradientSpecularModulation [protected]
  • GradientSpecularModulationOff() [virtual]
  • GradientSpecularModulationOn() [virtual]
  • GradientTableSize [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageBuffer [protected]
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Lights [protected]
  • LoadedDataSize [protected]
  • LookupTable [protected]
  • MajorBoardVersion [protected]
  • MinorBoardVersion [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NoHardware [protected]
  • NumberOfBoards [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLights [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeProVP1000Mapper &) [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderBoundingBox(vtkRenderer *vtkNotUsed(ren), vtkVolume *vol) [inline, protected, virtual]
  • RenderImageBuffer(vtkRenderer *vtkNotUsed(ren), vtkVolume *vol, int size[2], unsigned int *outData) [inline, protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBlendMode(int) [virtual]
  • SetBlendModeToComposite() [inline]
  • SetBlendModeToMaximumIntensity() [inline]
  • SetBlendModeToMinimumIntensity() [inline]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetCursor(int) [virtual]
  • SetCursorPosition(double, double, double) [virtual]
  • SetCursorPosition(double[3]) [virtual]
  • SetCursorType(int) [virtual]
  • SetCursorTypeToCrossHair() [inline]
  • SetCursorTypeToPlane() [inline]
  • SetCursorXAxisColor(double, double, double) [virtual]
  • SetCursorXAxisColor(double[3]) [virtual]
  • SetCursorYAxisColor(double, double, double) [virtual]
  • SetCursorYAxisColor(double[3]) [virtual]
  • SetCursorZAxisColor(double, double, double) [virtual]
  • SetCursorZAxisColor(double[3]) [virtual]
  • SetCutPlane(int) [virtual]
  • SetCutPlaneEquation(double, double, double, double) [virtual]
  • SetCutPlaneEquation(double[4]) [virtual]
  • SetCutPlaneFallOffDistance(int) [virtual]
  • SetCutPlaneThickness(double) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientDiffuseModulation(int) [virtual]
  • SetGradientOpacityModulation(int) [virtual]
  • SetGradientSpecularModulation(int) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetSubVolume(int, int, int, int, int, int) [virtual]
  • SetSubVolume(int[6]) [virtual]
  • SetSuperSampling(int) [virtual]
  • SetSuperSamplingFactor(double x, double y, double z)
  • SetSuperSamplingFactor(double f[3]) [inline]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StatusOK() [protected]
  • SubjectHelper [protected]
  • SubVolume [protected]
  • SuperSampling [protected]
  • SuperSamplingFactor [protected]
  • SuperSamplingOff() [virtual]
  • SuperSamplingOn() [virtual]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateCamera(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCropping(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCursor(vtkRenderer *, vtkVolume *) [protected]
  • UpdateCutPlane(vtkRenderer *, vtkVolume *) [protected]
  • UpdateLights(vtkRenderer *, vtkVolume *) [protected]
  • UpdateProgress(float amount)
  • UpdateProperties(vtkRenderer *, vtkVolume *) [protected]
  • UpdateVolume(vtkRenderer *, vtkVolume *) [protected]
  • Volume [protected]
  • VolumeBuildTime [protected]
  • VolumeDataType [protected]
  • VolumeInput [protected]
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeProVP1000Mapper, vtkVolumeProMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeProMapper() [protected]
  • vtkVolumeProVP1000Mapper() [protected]
  • vtkVolumeProVP1000Mapper(const vtkVolumeProVP1000Mapper &) [protected]
  • WrongVLIVersion [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeProMapper() [protected]
  • ~vtkVolumeProVP1000Mapper() [protected]
Generated on Mon Mar 25 01:33:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeRayCastCompositeFunction Member List

This is the complete list of members for vtkVolumeRayCastCompositeFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CastRay(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CompositeMethod [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetCompositeMethod() [virtual]
  • GetCompositeMethodAsString(void)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetZeroOpacityThreshold(vtkVolume *vol) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVolumeRayCastCompositeFunction &) (defined in vtkVolumeRayCastCompositeFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetCompositeMethod(int) [virtual]
  • SetCompositeMethodToClassifyFirst() [inline]
  • SetCompositeMethodToInterpolateFirst() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SpecificFunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper) [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeRayCastCompositeFunction, vtkVolumeRayCastFunction)
  • vtkVolumeRayCastCompositeFunction() [protected]
  • vtkVolumeRayCastCompositeFunction(const vtkVolumeRayCastCompositeFunction &) (defined in vtkVolumeRayCastCompositeFunction) [private]
  • vtkVolumeRayCastFunction() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVolumeRayCastCompositeFunction() [protected]
  • ~vtkVolumeRayCastFunction() [inline, protected]
Generated on Mon Mar 25 01:33:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeRayCastFunction Member List

This is the complete list of members for vtkVolumeRayCastFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CastRay(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo)=0 [pure virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetZeroOpacityThreshold(vtkVolume *vol)=0 [pure virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkVolumeRayCastFunction &) (defined in vtkVolumeRayCastFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SpecificFunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper)=0 [protected, pure virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeRayCastFunction, vtkObject)
  • vtkVolumeRayCastFunction() [inline, protected]
  • vtkVolumeRayCastFunction(const vtkVolumeRayCastFunction &) (defined in vtkVolumeRayCastFunction) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkVolumeRayCastFunction() [inline, protected]
Generated on Mon Mar 25 01:33:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeRayCastIsosurfaceFunction Member List

This is the complete list of members for vtkVolumeRayCastIsosurfaceFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CastRay(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Color
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetIsoValue() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetZeroOpacityThreshold(vtkVolume *vol) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsoValue
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVolumeRayCastIsosurfaceFunction &) (defined in vtkVolumeRayCastIsosurfaceFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetIsoValue(float) [virtual]
  • SetReferenceCount(int)
  • SpecificFunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper) [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeRayCastIsosurfaceFunction, vtkVolumeRayCastFunction)
  • vtkVolumeRayCastFunction() [inline, protected]
  • vtkVolumeRayCastIsosurfaceFunction() [protected]
  • vtkVolumeRayCastIsosurfaceFunction(const vtkVolumeRayCastIsosurfaceFunction &) (defined in vtkVolumeRayCastIsosurfaceFunction) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkVolumeRayCastFunction() [inline, protected]
  • ~vtkVolumeRayCastIsosurfaceFunction() [protected]
Generated on Mon Mar 25 01:33:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeRayCastMapper Member List

This is the complete list of members for vtkVolumeRayCastMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AutoAdjustSampleDistances [protected]
  • AutoAdjustSampleDistancesOff() [virtual]
  • AutoAdjustSampleDistancesOn() [virtual]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • ClipRayAgainstClippingPlanes(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [protected]
  • ClipRayAgainstVolume(VTKVRCDynamicInfo *dynamicInfo, float bounds[6]) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeMatrices(vtkImageData *data, vtkVolume *vol) [protected]
  • ComputeRowBounds(vtkVolume *vol, vtkRenderer *ren) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdjustSampleDistances() [virtual]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientShader() [virtual]
  • GetImageSampleDistance() [virtual]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetIntermixIntersectingGeometry() [virtual]
  • GetLength()
  • GetMaximumImageSampleDistance() [virtual]
  • GetMinimumImageSampleDistance() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfThreads() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetSampleDistance() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetVolumeRayCastFunction() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GetZBufferValue(int x, int y) [protected]
  • GetZeroOpacityThreshold(vtkVolume *vol)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientShader [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Image [protected]
  • ImageClipper [protected]
  • ImageInUseSize [protected]
  • ImageMemorySize [protected]
  • ImageOrigin [protected]
  • ImageSampleDistance [protected]
  • ImageViewportSize [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeClippingPlanes(VTKVRCStaticInfo *staticInfo, vtkPlaneCollection *planes) [protected]
  • Inputs [protected]
  • IntermixIntersectingGeometry [protected]
  • IntermixIntersectingGeometryOff() [virtual]
  • IntermixIntersectingGeometryOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MaximumImageSampleDistance [protected]
  • MinimumImageSampleDistance [protected]
  • MinimumViewDistance [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfThreads [protected]
  • OldRowBounds [protected]
  • operator=(const vtkVolumeRayCastMapper &) (defined in vtkVolumeRayCastMapper) [private]
  • PerspectiveMatrix [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [virtual]
  • RenderRendererTable [protected]
  • RenderTableEntries [protected]
  • RenderTableSize [protected]
  • RenderTexture(vtkVolume *vol, vtkRenderer *ren)=0 [protected, pure virtual]
  • RenderTimeTable [protected]
  • RenderVolumeTable [protected]
  • RetrieveRenderTime(vtkRenderer *ren, vtkVolume *vol) [protected]
  • RowBounds [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • ScalarDataPointer [protected]
  • ScalarDataType [protected]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdjustSampleDistances(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetImageSampleDistance(float) [virtual]
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetIntermixIntersectingGeometry(int) [virtual]
  • SetMaximumImageSampleDistance(float) [virtual]
  • SetMinimumImageSampleDistance(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfThreads(int num)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetSampleDistance(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVolumeRayCastFunction(vtkVolumeRayCastFunction *) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StoreRenderTime(vtkRenderer *ren, vtkVolume *vol, float t) [protected]
  • SubjectHelper [protected]
  • Threader [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • UpdateShadingTables(vtkRenderer *ren, vtkVolume *vol) [protected]
  • ViewToVoxelsMatrix [protected]
  • ViewToWorldMatrix [protected]
  • VolumeRayCastFunction [protected]
  • VolumeRayCastMapper_CastRays(void *arg) [friend]
  • VoxelCroppingRegionPlanes [protected]
  • VoxelsToViewMatrix [protected]
  • VoxelsToWorldMatrix [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeRayCastMapper, vtkVolumeMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeRayCastMapper() [protected]
  • vtkVolumeRayCastMapper(const vtkVolumeRayCastMapper &) (defined in vtkVolumeRayCastMapper) [private]
  • WorldSampleDistance [protected]
  • WorldToVoxelsMatrix [protected]
  • ZBuffer [protected]
  • ZBufferOrigin [protected]
  • ZBufferSize [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeRayCastMapper() [protected]
Generated on Mon Mar 25 01:34:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeRayCastMIPFunction Member List

This is the complete list of members for vtkVolumeRayCastMIPFunction, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CastRay(VTKVRCDynamicInfo *dynamicInfo, VTKVRCStaticInfo *staticInfo) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • FunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo)
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMaximizeMethod() [virtual]
  • GetMaximizeMethodAsString(void)
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetZeroOpacityThreshold(vtkVolume *vol) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MaximizeMethod [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVolumeRayCastMIPFunction &) (defined in vtkVolumeRayCastMIPFunction) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetMaximizeMethod(int) [virtual]
  • SetMaximizeMethodToOpacity() [inline]
  • SetMaximizeMethodToScalarValue() [inline]
  • SetReferenceCount(int)
  • SpecificFunctionInitialize(vtkRenderer *ren, vtkVolume *vol, VTKVRCStaticInfo *staticInfo, vtkVolumeRayCastMapper *mapper) [protected, virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeRayCastMIPFunction, vtkVolumeRayCastFunction)
  • vtkVolumeRayCastFunction() [inline, protected]
  • vtkVolumeRayCastMIPFunction() [protected]
  • vtkVolumeRayCastMIPFunction(const vtkVolumeRayCastMIPFunction &) (defined in vtkVolumeRayCastMIPFunction) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkVolumeRayCastFunction() [inline, protected]
  • ~vtkVolumeRayCastMIPFunction() [protected]
Generated on Mon Mar 25 01:34:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeReader Member List

This is the complete list of members for vtkVolumeReader, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FilePattern [protected]
  • FilePrefix [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFilePattern() [virtual]
  • GetFilePrefix() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImage(int ImageNumber)=0 [pure virtual]
  • GetImageRange() [virtual]
  • GetImageRange(int data[2]) [virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageRange [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeReader &) (defined in vtkVolumeReader) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFilePattern(const char *) [virtual]
  • SetFilePrefix(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageRange(int, int) [virtual]
  • SetImageRange(int[2])
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkVolumeReader, vtkStructuredPointsSource)
  • vtkVolumeReader() [protected]
  • vtkVolumeReader(const vtkVolumeReader &) (defined in vtkVolumeReader) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkVolumeReader() [protected]
Generated on Mon Mar 25 01:34:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeTextureMapper2D Member List

This is the complete list of members for vtkVolumeTextureMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArraySize [protected]
  • AxisTextureSize [protected]
  • BlueDiffuseShadingTable [protected]
  • BlueSpecularShadingTable [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • ComputeAxisTextureSize(int axis, int *size) [protected]
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodedNormals [protected]
  • EndTag [protected]
  • GenerateTexturesAndRenderQuads(vtkRenderer *ren, vtkVolume *vol) [protected]
  • GetAbortExecute() [virtual]
  • GetAxisTextureSize() [inline]
  • GetBlueDiffuseShadingTable() [inline]
  • GetBlueSpecularShadingTable() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetEncodedNormals() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes() [inline]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientOpacityArray() [inline]
  • GetGradientShader() [virtual]
  • GetGreenDiffuseShadingTable() [inline]
  • GetGreenSpecularShadingTable() [inline]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetInternalSkipFactor() [inline]
  • GetLength()
  • GetMaximumNumberOfPlanes() [virtual]
  • GetMaximumStorageSize() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRedDiffuseShadingTable() [inline]
  • GetRedSpecularShadingTable() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRGBAArray() [inline]
  • GetSaveTextures() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShade() [virtual]
  • GetTargetTextureSize() [virtual]
  • GetTargetTextureSize(int &, int &) [virtual]
  • GetTargetTextureSize(int[2]) [virtual]
  • GetTexture() [inline]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientMagnitudes [protected]
  • GradientOpacityArray [protected]
  • GradientShader [protected]
  • GreenDiffuseShadingTable [protected]
  • GreenSpecularShadingTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol) [inline, protected]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol, int majorDirection) [protected]
  • Inputs [protected]
  • InternalSkipFactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • MajorDirection [protected]
  • MaximumNumberOfPlanes [protected]
  • MaximumStorageSize [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeTextureMapper2D &) (defined in vtkVolumeTextureMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RedDiffuseShadingTable [protected]
  • RedSpecularShadingTable [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *, vtkVolume *) [inline, virtual]
  • RenderQuads(int vtkNotUsed(count), float *vtkNotUsed(v), float *vtkNotUsed(t), unsigned char *vtkNotUsed(texture), int vtkNotUsed(size)[2], int vtkNotUsed(reverseFlag)) [inline, virtual]
  • RenderSavedTexture() [protected]
  • RenderWindow [protected]
  • RGBAArray [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • SaveTextures [protected]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetMaximumNumberOfPlanes(int) [virtual]
  • SetMaximumStorageSize(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTargetTextureSize(int, int) [virtual]
  • SetTargetTextureSize(int[2])
  • Shade [protected]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TargetTextureSize [protected]
  • Texture [protected]
  • TextureMTime [protected]
  • TextureSize [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeTextureMapper2D, vtkVolumeTextureMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeTextureMapper() [protected]
  • vtkVolumeTextureMapper2D() [protected]
  • vtkVolumeTextureMapper2D(const vtkVolumeTextureMapper2D &) (defined in vtkVolumeTextureMapper2D) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeTextureMapper() [protected]
  • ~vtkVolumeTextureMapper2D() [protected]
Generated on Mon Mar 25 01:34:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVolumeTextureMapper Member List

This is the complete list of members for vtkVolumeTextureMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArraySize [protected]
  • BlueDiffuseShadingTable [protected]
  • BlueSpecularShadingTable [protected]
  • Bounds [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • Center [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComponentBlendAdd enum value
  • ComponentBlendMaxOpacity enum value
  • ComponentBlendMode [protected]
  • ComponentBlendModes enum name
  • Consumers [protected]
  • ConvertCroppingRegionPlanesToVoxels() [protected]
  • Cropping [protected]
  • CroppingOff() [virtual]
  • CroppingOn() [virtual]
  • CroppingRegionFlags [protected]
  • CroppingRegionPlanes [protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodedNormals [protected]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetBlueDiffuseShadingTable() [inline]
  • GetBlueSpecularShadingTable() [inline]
  • GetBounds() [virtual]
  • GetBounds(float bounds[6]) [inline, virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetComponentBlendMode() [virtual]
  • GetConsumer(int i)
  • GetCropping() [virtual]
  • GetCroppingRegionFlags() [virtual]
  • GetCroppingRegionPlanes() [virtual]
  • GetCroppingRegionPlanes(float data[6]) [virtual]
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float data[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float data[3]) [virtual]
  • GetDebug()
  • GetEncodedNormals() [inline]
  • GetGlobalWarningDisplay() [static]
  • GetGradientEstimator() [virtual]
  • GetGradientMagnitudeBias() [virtual]
  • GetGradientMagnitudes() [inline]
  • GetGradientMagnitudeScale() [virtual]
  • GetGradientOpacityArray() [inline]
  • GetGradientShader() [virtual]
  • GetGreenDiffuseShadingTable() [inline]
  • GetGreenSpecularShadingTable() [inline]
  • GetIndependentComponents() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetLength()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRedDiffuseShadingTable() [inline]
  • GetRedSpecularShadingTable() [inline]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRGBAArray() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShade() [virtual]
  • GetTimeToDraw() [virtual]
  • GetVoxelCroppingRegionPlanes() [virtual]
  • GetVoxelCroppingRegionPlanes(float data[6]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GradientEstimator [protected]
  • GradientMagnitudes [protected]
  • GradientOpacityArray [protected]
  • GradientShader [protected]
  • GreenDiffuseShadingTable [protected]
  • GreenSpecularShadingTable [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageClipper [protected]
  • IndependentComponents [protected]
  • IndependentComponentsOff() [virtual]
  • IndependentComponentsOn() [virtual]
  • InitializeRender(vtkRenderer *ren, vtkVolume *vol) [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsARayCastMapper() [inline, virtual]
  • IsARenderIntoImageMapper() [inline, virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVolumeTextureMapper &) (defined in vtkVolumeTextureMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent index) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • RedDiffuseShadingTable [protected]
  • RedSpecularShadingTable [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render(vtkRenderer *ren, vtkVolume *vol)=0 [pure virtual]
  • RenderWindow [protected]
  • RGBAArray [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDistance [protected]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetComponentBlendMode(int) [virtual]
  • SetComponentBlendModeToAdd() [inline]
  • SetComponentBlendModeToMaxOpacity() [inline]
  • SetCropping(int) [virtual]
  • SetCroppingRegionFlags(int) [virtual]
  • SetCroppingRegionFlagsToCross() [inline]
  • SetCroppingRegionFlagsToFence() [inline]
  • SetCroppingRegionFlagsToInvertedCross() [inline]
  • SetCroppingRegionFlagsToInvertedFence() [inline]
  • SetCroppingRegionFlagsToSubVolume() [inline]
  • SetCroppingRegionPlanes(float, float, float, float, float, float) [virtual]
  • SetCroppingRegionPlanes(float[6]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetGradientEstimator(vtkEncodedGradientEstimator *gradest)
  • SetIndependentComponents(int) [virtual]
  • SetInput(vtkImageData *)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • Shade [protected]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [virtual]
  • UpdateProgress(float amount)
  • VoxelCroppingRegionPlanes [protected]
  • vtkAbstractMapper() [protected]
  • vtkAbstractMapper3D() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkVolumeTextureMapper, vtkVolumeMapper)
  • vtkVolumeMapper() [protected]
  • vtkVolumeTextureMapper() [protected]
  • vtkVolumeTextureMapper(const vtkVolumeTextureMapper &) (defined in vtkVolumeTextureMapper) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkAbstractMapper3D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkVolumeMapper() [protected]
  • ~vtkVolumeTextureMapper() [protected]
Generated on Mon Mar 25 01:34:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVoxel Member List

This is the complete list of members for vtkVoxel, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetEdgeArray(int edgeId) [static]
  • GetEdgePoints(int edgeId, int *&pts) [virtual]
  • GetFace(int faceId) [virtual]
  • GetFaceArray(int faceId) [static]
  • GetFacePoints(int faceId, int *&pts) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[24]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[8]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVoxel &) (defined in vtkVoxel) [private]
  • Pixel [protected]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVoxel, vtkCell)
  • vtkVoxel() [protected]
  • vtkVoxel(const vtkVoxel &) (defined in vtkVoxel) [private]
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVoxel() [protected]
Generated on Mon Mar 25 01:34:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVoxelContoursToSurfaceFilter Member List

This is the complete list of members for vtkVoxelContoursToSurfaceFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddLineToLineList(float x1, float y1, float x2, float y2) [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CastLines(float *slice, float gridOrigin[3], int gridSize[3], int type) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMemoryLimitInBytes() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSpacing() [virtual]
  • GetSpacing(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • IntersectionList [protected]
  • IntersectionListLength [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • LineList [protected]
  • LineListLength [protected]
  • LineListSize [protected]
  • MemoryLimitInBytes [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVoxelContoursToSurfaceFilter &) (defined in vtkVoxelContoursToSurfaceFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • PushDistances(float *ptr, int gridSize[3], int chunkSize) [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetMemoryLimitInBytes(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSpacing(float, float, float) [virtual]
  • SetSpacing(float[3]) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortedListSize [protected]
  • SortedXList [protected]
  • SortedYList [protected]
  • SortInputsByLocality() [protected]
  • SortLineList() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • Spacing [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkVoxelContoursToSurfaceFilter, vtkPolyDataToPolyDataFilter)
  • vtkVoxelContoursToSurfaceFilter() [protected]
  • vtkVoxelContoursToSurfaceFilter(const vtkVoxelContoursToSurfaceFilter &) (defined in vtkVoxelContoursToSurfaceFilter) [private]
  • WorkingList [protected]
  • WorkingListLength [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVoxelContoursToSurfaceFilter() [protected]
Generated on Mon Mar 25 01:34:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVoxelModeller Member List

This is the complete list of members for vtkVoxelModeller, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • ComputeModelBounds(float origin[3], float ar[3])
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMaximumDistance() [virtual]
  • GetModelBounds() [virtual]
  • GetModelBounds(float data[6]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetSampleDimensions() [virtual]
  • GetSampleDimensions(int data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • MaximumDistance [protected]
  • ModelBounds [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkVoxelModeller &) (defined in vtkVoxelModeller) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SampleDimensions [protected]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkDataSet *input) [virtual]
  • SetMaximumDistance(float) [virtual]
  • SetModelBounds(float bounds[6])
  • SetModelBounds(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkStructuredPoints *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetSampleDimensions(int i, int j, int k)
  • SetSampleDimensions(int dim[3])
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkDataSetToStructuredPointsFilter() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkStructuredPointsSource() [protected]
  • vtkTypeRevisionMacro(vtkVoxelModeller, vtkDataSetToStructuredPointsFilter)
  • vtkVoxelModeller() [protected]
  • vtkVoxelModeller(const vtkVoxelModeller &) (defined in vtkVoxelModeller) [private]
  • Write(char *)
  • ~vtkDataSetToStructuredPointsFilter() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkStructuredPointsSource() [inline, protected]
  • ~vtkVoxelModeller() [inline, protected]
Generated on Mon Mar 25 01:34:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVRMLExporter Member List

This is the complete list of members for vtkVRMLExporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndWrite [protected]
  • EndWriteArg [protected]
  • EndWriteArgDelete [protected]
  • FileName [protected]
  • FilePointer [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [inline]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetSpeed() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkVRMLExporter &) (defined in vtkVRMLExporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetEndWrite(void(*f)(void *), void *arg)
  • SetEndWriteArgDelete(void(*f)(void *))
  • SetFileName(const char *) [virtual]
  • SetFilePointer(FILE *)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkRenderWindow *renWin) [inline]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SetSpeed(float) [virtual]
  • SetStartWrite(void(*f)(void *), void *arg)
  • SetStartWriteArgDelete(void(*f)(void *))
  • Speed [protected]
  • StartWrite [protected]
  • StartWriteArg [protected]
  • StartWriteArgDelete [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • vtkExporter() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVRMLExporter, vtkExporter)
  • vtkVRMLExporter() [protected]
  • vtkVRMLExporter(const vtkVRMLExporter &) (defined in vtkVRMLExporter) [private]
  • Write() [virtual]
  • WriteALight(vtkLight *aLight, FILE *fp) [protected]
  • WriteAnActor(vtkActor *anActor, FILE *fp) [protected]
  • WriteData() [protected, virtual]
  • WritePointData(vtkPoints *points, vtkDataArray *normals, vtkDataArray *tcoords, vtkUnsignedCharArray *colors, FILE *fp) [protected]
  • ~vtkExporter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVRMLExporter() [protected]
Generated on Mon Mar 25 01:34:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVRMLImporter Member List

This is the complete list of members for vtkVRMLImporter, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CurrentActor (defined in vtkVRMLImporter) [private]
  • CurrentCamera (defined in vtkVRMLImporter) [private]
  • CurrentLight (defined in vtkVRMLImporter) [private]
  • CurrentLut (defined in vtkVRMLImporter) [private]
  • CurrentMapper (defined in vtkVRMLImporter) [private]
  • CurrentNormals (defined in vtkVRMLImporter) [private]
  • CurrentPoints (defined in vtkVRMLImporter) [private]
  • CurrentProperty (defined in vtkVRMLImporter) [private]
  • CurrentScalars (defined in vtkVRMLImporter) [private]
  • CurrentSource (defined in vtkVRMLImporter) [private]
  • CurrentTransform (defined in vtkVRMLImporter) [private]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeleteObject(vtkObject *) (defined in vtkVRMLImporter) [private]
  • enterField(const char *)
  • enterNode(const char *)
  • exitField()
  • exitNode()
  • FileFD [protected]
  • FileName [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileFD() [inline]
  • GetFileName() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetRenderWindow() [virtual]
  • GetVRMLDEFObject(const char *name)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Heap (defined in vtkVRMLImporter) [private]
  • IdTypeArrayNew() (defined in vtkVRMLImporter) [private]
  • ImportActors(vtkRenderer *) [inline, protected, virtual]
  • vtkImporter::ImportActors(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportBegin() [protected, virtual]
  • ImportCameras(vtkRenderer *) [inline, protected, virtual]
  • vtkImporter::ImportCameras(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportEnd() [protected, virtual]
  • ImportLights(vtkRenderer *) [inline, protected, virtual]
  • vtkImporter::ImportLights(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • ImportProperties(vtkRenderer *) [inline, protected, virtual]
  • vtkImporter::ImportProperties(vtkRenderer *vtkNotUsed(renderer)) [inline, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OpenImportFile() [protected]
  • operator=(const vtkVRMLImporter &) (defined in vtkVRMLImporter) [private]
  • PointsNew() (defined in vtkVRMLImporter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Read()
  • ReadData() [protected, virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • RenderWindow [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *) [virtual]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update() [inline]
  • useNode(const char *)
  • vtkImporter() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkVRMLImporter, vtkImporter)
  • vtkVRMLImporter() [protected]
  • vtkVRMLImporter(const vtkVRMLImporter &) (defined in vtkVRMLImporter) [private]
  • yylex(vtkVRMLImporter *) [friend]
  • ~vtkImporter() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkVRMLImporter() [protected]
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWarpLens Member List

This is the complete list of members for vtkWarpLens, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • FormatHeight [protected]
  • FormatWidth [protected]
  • GetAbortExecute() [virtual]
  • GetCenter()
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFormatHeight() [virtual]
  • GetFormatWidth() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetImageHeight() [virtual]
  • GetImageWidth() [virtual]
  • GetInput()
  • GetInputs() [inline]
  • GetK1() [virtual]
  • GetK2() [virtual]
  • GetKappa()
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetP1() [virtual]
  • GetP2() [virtual]
  • GetPolyDataOutput()
  • GetPrincipalPoint() [virtual]
  • GetPrincipalPoint(float data[2]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • ImageHeight [protected]
  • ImageWidth [protected]
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • K1 [protected]
  • K2 [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWarpLens &) (defined in vtkWarpLens) [private]
  • Outputs [protected]
  • P1 [protected]
  • P2 [protected]
  • PrincipalPoint [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetCenter(float centerX, float centerY)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFormatHeight(float) [virtual]
  • SetFormatWidth(float) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetImageHeight(int) [virtual]
  • SetImageWidth(int) [virtual]
  • SetInput(vtkPointSet *input)
  • SetK1(float) [virtual]
  • SetK2(float) [virtual]
  • SetKappa(float kappa)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetP1(float) [virtual]
  • SetP2(float) [virtual]
  • SetPrincipalPoint(float, float) [virtual]
  • SetPrincipalPoint(float[2])
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWarpLens, vtkPointSetToPointSetFilter)
  • vtkWarpLens() [protected]
  • vtkWarpLens(const vtkWarpLens &) (defined in vtkWarpLens) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWarpLens() [inline, protected]
Generated on Mon Mar 25 01:35:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWarpScalar Member List

This is the complete list of members for vtkWarpScalar, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • DataNormal(vtkIdType id, vtkDataArray *normals=NULL) [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputScalarsSelection() [virtual]
  • GetMTime() [virtual]
  • GetNormal() [virtual]
  • GetNormal(float data[3]) [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetStructuredGridOutput()
  • GetUnstructuredGridOutput()
  • GetUseNormal() [virtual]
  • GetXYPlane() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputScalarsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InstanceNormal(vtkIdType id, vtkDataArray *normals=NULL) [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • Normal [protected]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWarpScalar &) (defined in vtkWarpScalar) [private]
  • Outputs [protected]
  • PointNormal [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SelectInputScalars(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetInputScalarsSelection(const char *) [protected, virtual]
  • SetNormal(float, float, float) [virtual]
  • SetNormal(float[3]) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseNormal(int) [virtual]
  • SetXYPlane(int) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • UseNormal [protected]
  • UseNormalOff() [virtual]
  • UseNormalOn() [virtual]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWarpScalar, vtkPointSetToPointSetFilter)
  • vtkWarpScalar() [protected]
  • vtkWarpScalar(const vtkWarpScalar &) (defined in vtkWarpScalar) [private]
  • XYPlane [protected]
  • XYPlaneOff() [virtual]
  • XYPlaneOn() [virtual]
  • ZNormal(vtkIdType id, vtkDataArray *normals=NULL) [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWarpScalar() [protected]
Generated on Mon Mar 25 01:35:27 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWarpTo Member List

This is the complete list of members for vtkWarpTo, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • Absolute [protected]
  • AbsoluteOff() [virtual]
  • AbsoluteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAbsolute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetPosition() [virtual]
  • GetPosition(float data[3]) [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetStructuredGridOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWarpTo &) (defined in vtkWarpTo) [private]
  • Outputs [protected]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SetAbortExecute(int) [virtual]
  • SetAbsolute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetPosition(float, float, float) [virtual]
  • SetPosition(float[3]) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWarpTo, vtkPointSetToPointSetFilter)
  • vtkWarpTo() [protected]
  • vtkWarpTo(const vtkWarpTo &) (defined in vtkWarpTo) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWarpTo() [inline, protected]
Generated on Mon Mar 25 01:35:28 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWarpTransform Member List

This is the complete list of members for vtkWarpTransform, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CircuitCheck(vtkAbstractTransform *transform) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkAbstractTransform *)
  • Delete() [virtual]
  • ForwardTransformDerivative(const float in[3], float out[3], float derivative[3][3])=0 [protected, pure virtual]
  • ForwardTransformDerivative(const double in[3], double out[3], double derivative[3][3])=0 [protected, pure virtual]
  • ForwardTransformPoint(const float in[3], float out[3])=0 [protected, pure virtual]
  • ForwardTransformPoint(const double in[3], double out[3])=0 [protected, pure virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInverse()
  • GetInverseFlag() [virtual]
  • GetInverseIterations() [virtual]
  • GetInverseTolerance() [virtual]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Identity() [inline]
  • InternalDeepCopy(vtkAbstractTransform *) [inline, protected, virtual]
  • InternalDoublePoint [protected]
  • InternalFloatPoint [protected]
  • InternalTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [virtual]
  • InternalTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [virtual]
  • InternalTransformPoint(const float in[3], float out[3]) [virtual]
  • InternalTransformPoint(const double in[3], double out[3]) [virtual]
  • InternalUpdate() [inline, protected, virtual]
  • Inverse() [virtual]
  • InverseFlag [protected]
  • InverseIterations [protected]
  • InverseTolerance [protected]
  • InverseTransformDerivative(const float in[3], float out[3], float derivative[3][3]) [protected, virtual]
  • InverseTransformDerivative(const double in[3], double out[3], double derivative[3][3]) [protected, virtual]
  • InverseTransformPoint(const float in[3], float out[3]) [protected, virtual]
  • InverseTransformPoint(const double in[3], double out[3]) [protected, virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeTransform()=0 [pure virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • operator=(const vtkWarpTransform &) (defined in vtkWarpTransform) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInverse(vtkAbstractTransform *transform)
  • SetInverseIterations(int) [virtual]
  • SetInverseTolerance(double) [virtual]
  • SetReferenceCount(int)
  • SubjectHelper [protected]
  • TemplateTransformInverse(const float in[3], float out[3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3]) [inline]
  • TemplateTransformInverse(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformInverse(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3]) [inline]
  • TemplateTransformPoint(const float in[3], float out[3], float derivative[3][3]) [inline]
  • TemplateTransformPoint(const double in[3], double out[3], double derivative[3][3]) [inline]
  • TransformDoubleNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformDoublePoint(double x, double y, double z) [inline]
  • TransformDoublePoint(const double point[3]) [inline]
  • TransformDoubleVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • TransformFloatNormalAtPoint(const float point[3], const float normal[3]) [inline]
  • TransformFloatPoint(float x, float y, float z) [inline]
  • TransformFloatPoint(const float point[3]) [inline]
  • TransformFloatVectorAtPoint(const float point[3], const float vector[3]) [inline]
  • TransformNormalAtPoint(const float point[3], const float in[3], float out[3])
  • TransformNormalAtPoint(const double point[3], const double in[3], double out[3])
  • TransformNormalAtPoint(const double point[3], const double normal[3]) [inline]
  • TransformPoint(const float in[3], float out[3]) [inline]
  • TransformPoint(const double in[3], double out[3]) [inline]
  • TransformPoint(double x, double y, double z) [inline]
  • TransformPoint(const double point[3]) [inline]
  • TransformPoints(vtkPoints *inPts, vtkPoints *outPts) [virtual]
  • TransformPointsNormalsVectors(vtkPoints *inPts, vtkPoints *outPts, vtkDataArray *inNms, vtkDataArray *outNms, vtkDataArray *inVrs, vtkDataArray *outVrs) [virtual]
  • TransformVectorAtPoint(const float point[3], const float in[3], float out[3])
  • TransformVectorAtPoint(const double point[3], const double in[3], double out[3])
  • TransformVectorAtPoint(const double point[3], const double vector[3]) [inline]
  • UnRegister(vtkObject *O) [virtual]
  • Update()
  • vtkAbstractTransform() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWarpTransform, vtkAbstractTransform)
  • vtkWarpTransform() [protected]
  • vtkWarpTransform(const vtkWarpTransform &) (defined in vtkWarpTransform) [private]
  • ~vtkAbstractTransform() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWarpTransform() [protected]
Generated on Mon Mar 25 01:35:29 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWarpVector Member List

This is the complete list of members for vtkWarpVector, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetInputVectorsSelection() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetScaleFactor() [virtual]
  • GetStructuredGridOutput()
  • GetUnstructuredGridOutput()
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InputVectorsSelection [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWarpVector &) (defined in vtkWarpVector) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScaleFactor [protected]
  • SelectInputVectors(const char *fieldName) [inline]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetInputVectorsSelection(const char *) [protected, virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetScaleFactor(float) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWarpVector, vtkPointSetToPointSetFilter)
  • vtkWarpVector() [protected]
  • vtkWarpVector(const vtkWarpVector &) (defined in vtkWarpVector) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWarpVector() [protected]
Generated on Mon Mar 25 01:35:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWedge Member List

This is the complete list of members for vtkWedge, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bounds [protected]
  • BreakOnError() [static]
  • CellBoundary(int subId, float pcoords[3], vtkIdList *pts) [virtual]
  • Clip(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *connectivity, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd, int insideOut) [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Contour(float value, vtkDataArray *cellScalars, vtkPointLocator *locator, vtkCellArray *verts, vtkCellArray *lines, vtkCellArray *polys, vtkPointData *inPd, vtkPointData *outPd, vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • DeepCopy(vtkCell *c) [virtual]
  • Delete() [virtual]
  • Derivatives(int subId, float pcoords[3], float *values, int dim, float *derivs) [virtual]
  • EvaluateLocation(int &subId, float pcoords[3], float x[3], float *weights) [virtual]
  • EvaluatePosition(float x[3], float *closestPoint, int &subId, float pcoords[3], float &dist2, float *weights) [virtual]
  • GetBounds(float bounds[6])
  • GetBounds()
  • GetCellDimension() [inline, virtual]
  • GetCellType() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdge(int edgeId) [virtual]
  • GetEdgeArray(int edgeId) [static]
  • GetEdgePoints(int edgeId, int *&pts) [virtual]
  • GetFace(int faceId) [virtual]
  • GetFaceArray(int faceId) [static]
  • GetFacePoints(int faceId, int *&pts) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetLength2()
  • GetMTime() [virtual]
  • GetNumberOfEdges() [inline, virtual]
  • GetNumberOfFaces() [inline, virtual]
  • GetNumberOfPoints() [inline]
  • GetParametricCenter(float pcoords[3]) [inline, virtual]
  • GetPointId(int ptId) [inline]
  • GetPointIds() [inline]
  • GetPoints() [inline]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HitBBox(float bounds[6], float origin[3], float dir[3], float coord[3], float &t) [static]
  • Initialize(int npts, vtkIdType *pts, vtkPoints *p)
  • InterpolationDerivs(float pcoords[3], float derivs[18]) [static]
  • InterpolationFunctions(float pcoords[3], float weights[6]) [static]
  • IntersectWithLine(float p1[3], float p2[3], float tol, float &t, float x[3], float pcoords[3], int &subId) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsExplicitCell() [inline, virtual]
  • IsLinear() [inline, virtual]
  • IsTypeOf(const char *name) [static]
  • JacobianInverse(float pcoords[3], double **inverse, float derivs[18])
  • Line [protected]
  • MakeObject() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkWedge &) (defined in vtkWedge) [private]
  • PointIds
  • Points
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Quad [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • ShallowCopy(vtkCell *c) [virtual]
  • SubjectHelper [protected]
  • Triangle [protected]
  • Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) [virtual]
  • Triangulator [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkCell() [protected]
  • vtkCell3D() [inline, protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWedge, vtkCell)
  • vtkWedge() [protected]
  • vtkWedge(const vtkWedge &) (defined in vtkWedge) [private]
  • ~vtkCell() [protected]
  • ~vtkCell3D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWedge() [protected]
Generated on Mon Mar 25 01:35:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWeightedTransformFilter Member List

This is the complete list of members for vtkWeightedTransformFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddInputValues [protected]
  • AddInputValuesOff() [virtual]
  • AddInputValuesOn() [virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BreakOnError() [static]
  • CellDataWeightArray [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetAddInputValues() [virtual]
  • GetCellDataWeightArray() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetNumberOfTransforms() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPolyDataOutput()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStructuredGridOutput()
  • GetTransform(int num) [virtual]
  • GetUnstructuredGridOutput()
  • GetWeightArray() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfTransforms [protected]
  • operator=(const vtkWeightedTransformFilter &) (defined in vtkWeightedTransformFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetAddInputValues(int) [virtual]
  • SetCellDataWeightArray(const char *) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPointSet *input)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetNumberOfTransforms(int num) [virtual]
  • SetOutput(vtkPointSet *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransform(vtkAbstractTransform *transform, int num) [virtual]
  • SetWeightArray(const char *) [virtual]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Transforms [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPointSetSource() [protected]
  • vtkPointSetToPointSetFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWeightedTransformFilter, vtkPointSetToPointSetFilter)
  • vtkWeightedTransformFilter() [protected]
  • vtkWeightedTransformFilter(const vtkWeightedTransformFilter &) (defined in vtkWeightedTransformFilter) [private]
  • WeightArray [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPointSetSource() [inline, protected]
  • ~vtkPointSetToPointSetFilter() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWeightedTransformFilter() [protected]
Generated on Mon Mar 25 01:35:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32ImageMapper Member List

This is the complete list of members for vtkWin32ImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CreateBitmapObject(HBITMAP oldBitmap, BITMAPINFO &dataHeader, HDC windowDC, unsigned char *&DataOut, vtkImageData *data, int width, int height) [static]
  • CustomDisplayExtents [protected]
  • DataOut
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GenerateBitmapData(vtkImageData *data, void *inptr, unsigned char *DataOut, int dim, int DisplayExtent[6], float cwindow, float clevel, float cshift, float cscale, vtkLookupTable *lut) [static]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetLookupTable() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HBitmap
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWin32ImageMapper &) (defined in vtkWin32ImageMapper) [private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetLookupTable(vtkLookupTable *) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkWin32ImageMapper, vtkImageMapper)
  • vtkWin32ImageMapper() [protected]
  • vtkWin32ImageMapper(const vtkWin32ImageMapper &) (defined in vtkWin32ImageMapper) [private]
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkWin32ImageMapper() [protected]
Generated on Mon Mar 25 01:35:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32ImageWindow Member List

This is the complete list of members for vtkWin32ImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplicationInstance
  • BackBuffer [protected]
  • BreakOnError() [static]
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CompatHdc [protected]
  • DataHeader [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeviceContext
  • DIBPtr [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [virtual]
  • FileName [protected]
  • Frame() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDIBPtr()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMemoryData() [inline]
  • GetMemoryDC()
  • GetMTime() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetOutput() [inline]
  • GetPixelData(int x1, int y1, int x2, int y2, int) [virtual]
  • GetPosition() [virtual]
  • vtkImageWindow::GetPosition(int *x, int *y) [virtual]
  • GetReferenceCount() [inline]
  • GetSize() [virtual]
  • vtkImageWindow::GetSize(int *x, int *y) [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeCurrent() [inline, virtual]
  • MakeDefaultWindow() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • MemoryBuffer [protected]
  • MemoryData [protected]
  • MemoryDataHeader [protected]
  • MemoryHdc [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldHdc [protected]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkWin32ImageWindow &) (defined in vtkWin32ImageWindow) [private]
  • OwnWindow [protected]
  • Palette
  • ParentId
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • ResumeScreenRendering()
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • ScreenDeviceContext [protected]
  • ScreenMapped [protected]
  • ScreenWindowSize [protected]
  • SetBackgroundColor(float r, float g, float b)
  • SetDebug(unsigned char debugFlag)
  • SetDeviceContext(void *dc) [inline]
  • SetDeviceContext(HDC)
  • SetDisplayId(void *foo) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *id) [inline, virtual]
  • SetParentId(HWND)
  • SetParentInfo(char *) [virtual]
  • SetPosition(int, int) [virtual]
  • vtkImageWindow::SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetSize(int, int) [virtual]
  • vtkImageWindow::SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetupMemoryRendering(int x, int y, HDC prn)
  • SetWindowId(void *id) [inline, virtual]
  • SetWindowId(HWND)
  • SetWindowInfo(char *) [virtual]
  • SetWindowName(char *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • SwapFlag [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageWindow() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWin32ImageWindow, vtkImageWindow)
  • vtkWin32ImageWindow() [protected]
  • vtkWin32ImageWindow(const vtkWin32ImageWindow &) (defined in vtkWin32ImageWindow) [private]
  • vtkWindow() [protected]
  • WindowCreated [protected]
  • WindowId
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWin32ImageWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:35:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32OpenGLImageWindow Member List

This is the complete list of members for vtkWin32OpenGLImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ApplicationInstance [protected]
  • BreakOnError() [static]
  • Clean()
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ContextId [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeviceContext [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [virtual]
  • FileName [protected]
  • Frame() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMemoryData() [inline]
  • GetMemoryDC()
  • GetMTime() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetOutput() [inline]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPosition() [virtual]
  • GetPosition(int *x, int *y) [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetSize() [virtual]
  • GetSize(int *x, int *y) [inline, virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId() [virtual]
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeCurrent() [virtual]
  • MakeDefaultWindow() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • MemoryBuffer [protected]
  • MemoryData [protected]
  • MemoryDataHeader [protected]
  • MemoryHdc [protected]
  • MessageProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextWindowId [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldPalette [protected]
  • OpenGLInit() [virtual]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkWin32OpenGLImageWindow &) (defined in vtkWin32OpenGLImageWindow) [private]
  • OwnWindow [protected]
  • Palette [protected]
  • ParentId [protected]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • ResumeScreenRendering()
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • ScreenContextId [protected]
  • ScreenDeviceContext [protected]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • ScreenSize [protected]
  • ScreenWindowSize [protected]
  • SetContextId(HGLRC)
  • SetDebug(unsigned char debugFlag)
  • SetDeviceContext(HDC)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetNextWindowId(HWND) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(HWND) [virtual]
  • SetParentId(void *foo) [inline, virtual]
  • SetParentInfo(char *) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetupMemoryRendering(int x, int y, HDC prn)
  • SetupPalette(HDC hDC) [virtual]
  • SetupPixelFormat(HDC hDC, DWORD dwFlags, int debug, int bpp=16, int zbpp=16) [virtual]
  • SetWindowId(void *foo) [inline, virtual]
  • SetWindowId(HWND) [virtual]
  • SetWindowInfo(char *) [virtual]
  • SetWindowName(char *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkImageWindow() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWin32OpenGLImageWindow, vtkImageWindow)
  • vtkWin32OpenGLImageWindow() [protected]
  • vtkWin32OpenGLImageWindow(const vtkWin32OpenGLImageWindow &) (defined in vtkWin32OpenGLImageWindow) [private]
  • vtkWindow() [protected]
  • WindowCreated [protected]
  • WindowId [protected]
  • WindowName [protected]
  • WndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, static]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWin32OpenGLImageWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:35:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32OpenGLRenderWindow Member List

This is the complete list of members for vtkWin32OpenGLRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • ApplicationInstance [protected]
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • Clean()
  • CleanUpOffScreenRendering(void) [protected]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ContextId [protected]
  • CopyResultFrame() [virtual]
  • CreateAWindow(int x, int y, int width, int height) [protected]
  • CreateOffScreenDC(int xsize, int ysize, HDC aHdc) [protected]
  • CreateOffScreenDC(HBITMAP hbmp, HDC aHdc) [protected]
  • CurrentSubFrame [protected]
  • CursorHidden [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DeviceContext [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame(void) [virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMemoryData() [inline]
  • GetMemoryDC()
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetScreenSize() [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId() [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [virtual]
  • InAbortCheck [protected]
  • Initialize(void) [virtual]
  • InitializeApplication() [protected]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • MemoryBuffer [protected]
  • MemoryData [protected]
  • MemoryDataHeader [protected]
  • MemoryHdc [protected]
  • MessageProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, virtual]
  • MFChandledWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NextWindowId [protected]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldMonitorSetting [protected]
  • OldPalette [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkWin32OpenGLRenderWindow &) (defined in vtkWin32OpenGLRenderWindow) [private]
  • OwnWindow [protected]
  • Palette [protected]
  • ParentId [protected]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • PrefFullScreen(void) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResizeWhileOffscreen(int xsize, int ysize) [protected]
  • ResultFrame [protected]
  • ResumeScreenRendering(void)
  • SafeDownCast(vtkObject *o) [static]
  • ScreenContextId [protected]
  • ScreenDeviceContext [protected]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • ScreenSize [protected]
  • ScreenWindowSize [protected]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetContextId(HGLRC)
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDeviceContext(HDC)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNextWindowId(HWND) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int offscreen) [virtual]
  • SetParentId(HWND) [virtual]
  • SetParentId(void *foo) [inline, virtual]
  • SetParentInfo(char *) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetupMemoryRendering(int x, int y, HDC prn)
  • SetupMemoryRendering(HBITMAP hbmp)
  • SetupPalette(HDC hDC) [virtual]
  • SetupPixelFormat(HDC hDC, DWORD dwFlags, int debug, int bpp=16, int zbpp=16) [virtual]
  • SetWindowId(void *foo) [inline, virtual]
  • SetWindowId(HWND) [virtual]
  • SetWindowInfo(char *) [virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [virtual]
  • Size [protected]
  • Start(void) [virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOpenGLRenderWindow() [protected]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkWin32OpenGLRenderWindow, vtkOpenGLRenderWindow)
  • vtkWin32OpenGLRenderWindow() [protected]
  • vtkWin32OpenGLRenderWindow(const vtkWin32OpenGLRenderWindow &) (defined in vtkWin32OpenGLRenderWindow) [private]
  • vtkWindow() [protected]
  • WindowId [protected]
  • WindowInitialize(void) [virtual]
  • WindowName [protected]
  • WindowRemap(void) [virtual]
  • WndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, static]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLRenderWindow() [protected]
  • ~vtkRenderWindow() [protected]
  • ~vtkWin32OpenGLRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:35:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32OpenGLTextMapper Member List

This is the complete list of members for vtkWin32OpenGLTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • Font [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp) [static]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastSize [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWin32OpenGLTextMapper &) (defined in vtkWin32OpenGLTextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderGeometry(vtkViewport *viewport, vtkActor2D *actor)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *vtkNotUsed(viewport), vtkActor2D *vtkNotUsed(actor)) [inline]
  • vtkWin32TextMapper::RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkWin32OpenGLTextMapper, vtkWin32TextMapper)
  • vtkWin32OpenGLTextMapper() [protected]
  • vtkWin32OpenGLTextMapper(const vtkWin32OpenGLTextMapper &) (defined in vtkWin32OpenGLTextMapper) [private]
  • vtkWin32TextMapper() [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
  • ~vtkWin32OpenGLTextMapper() [protected]
  • ~vtkWin32TextMapper() [protected]
Generated on Mon Mar 25 01:35:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32OutputWindow Member List

This is the complete list of members for vtkWin32OutputWindow, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddText(const char *) [protected, static]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayDebugText(const char *) [virtual]
  • DisplayErrorText(const char *) [virtual]
  • DisplayGenericWarningText(const char *) [virtual]
  • DisplayText(const char *) [virtual]
  • DisplayWarningText(const char *) [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInstance() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, static]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkWin32OutputWindow &) (defined in vtkWin32OutputWindow) [private]
  • OutputWindow [protected, static]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PromptText(const char *text) [protected]
  • PromptUser [protected]
  • PromptUserOff() [virtual]
  • PromptUserOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstance(vtkOutputWindow *instance) [static]
  • SetPromptUser(int) [virtual]
  • SetReferenceCount(int)
  • SmartPointer [static]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOutputWindow() [protected]
  • vtkTypeRevisionMacro(vtkWin32OutputWindow, vtkOutputWindow)
  • vtkWin32OutputWindow() [inline, protected]
  • vtkWin32OutputWindow(const vtkWin32OutputWindow &) (defined in vtkWin32OutputWindow) [private]
  • WndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [static]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutputWindow() [protected, virtual]
  • ~vtkWin32OutputWindow() [inline, protected, virtual]
Generated on Mon Mar 25 01:35:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32PolyDataMapper2D Member List

This is the complete list of members for vtkWin32PolyDataMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarMode() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetTransformCoordinate() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWin32PolyDataMapper2D &) (defined in vtkWin32PolyDataMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransformCoordinate(vtkCoordinate *) [virtual]
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • TransformCoordinate [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataMapper2D() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkWin32PolyDataMapper2D, vtkPolyDataMapper2D)
  • vtkWin32PolyDataMapper2D() [inline, protected]
  • vtkWin32PolyDataMapper2D(const vtkWin32PolyDataMapper2D &) (defined in vtkWin32PolyDataMapper2D) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper2D() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkWin32PolyDataMapper2D() [inline, protected]
Generated on Mon Mar 25 01:35:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32RenderWindowInteractor Member List

This is the complete list of members for vtkWin32RenderWindowInteractor, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClassExitMethod [protected, static]
  • ClassExitMethodArg [protected, static]
  • ClassExitMethodArgDelete [protected, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ControlKey [protected]
  • CreateDefaultPicker() [virtual]
  • CreateTimer(int timertype) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DestroyTimer(void) [virtual]
  • Disable() [virtual]
  • Dolly [protected]
  • Enable() [virtual]
  • Enabled [protected]
  • EndPickCallback() [virtual]
  • EndPickTag [protected]
  • EventPosition [protected]
  • ExitCallback() [virtual]
  • ExitTag [protected]
  • FlyTo(vtkRenderer *ren, float x, float y, float z)
  • FlyTo(vtkRenderer *ren, float *x) [inline]
  • FlyToImage(vtkRenderer *ren, float x, float y)
  • FlyToImage(vtkRenderer *ren, float *x) [inline]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetControlKey() [virtual]
  • GetDebug()
  • GetDesiredUpdateRate() [virtual]
  • GetDolly() [virtual]
  • GetEnabled() [virtual]
  • GetEventPosition() [virtual]
  • GetEventPosition(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [virtual]
  • GetInstallMessageProc() [virtual]
  • GetInteractorStyle() [virtual]
  • GetKeyCode() [virtual]
  • GetKeySym() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetMousePosition(int *x, int *y) [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfFlyFrames() [virtual]
  • GetPicker() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRepeatCount() [virtual]
  • GetShiftKey() [virtual]
  • GetSize() [virtual]
  • GetSize(int &, int &) [virtual]
  • GetSize(int[2]) [virtual]
  • GetStillUpdateRate() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline]
  • Initialize() [virtual]
  • Initialized [protected]
  • InstallMessageProc [protected]
  • InstallMessageProcOff() [virtual]
  • InstallMessageProcOn() [virtual]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyCode [protected]
  • KeySym [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Modified() [virtual]
  • MouseInWindow [protected]
  • MTime [protected]
  • New() [static]
  • NumberOfFlyFrames [protected]
  • OldProc [protected]
  • OnChar(HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags) [virtual]
  • OnKeyDown(HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags) [virtual]
  • OnKeyUp(HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags) [virtual]
  • OnLButtonDown(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnLButtonUp(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnMButtonDown(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnMButtonUp(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnMouseMove(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnNCMouseMove(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnRButtonDown(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnRButtonUp(HWND wnd, UINT nFlags, int X, int Y) [virtual]
  • OnSize(HWND wnd, UINT nType, int X, int Y) [virtual]
  • OnTimer(HWND wnd, UINT nIDEvent) [virtual]
  • operator=(const vtkWin32RenderWindowInteractor &) (defined in vtkWin32RenderWindowInteractor) [private]
  • Picker [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReInitialize() [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderWindow [protected]
  • RepeatCount [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetClassExitMethod(void(*f)(void *), void *arg) [static]
  • SetClassExitMethodArgDelete(void(*f)(void *)) [static]
  • SetControlKey(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float) [virtual]
  • SetDolly(float) [virtual]
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0) [inline]
  • SetEventPosition(int, int) [virtual]
  • SetEventPosition(int[2])
  • SetExitMethod(void(*f)(void *), void *arg)
  • SetExitMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstallMessageProc(int) [virtual]
  • SetInteractorStyle(vtkInteractorStyle *) [virtual]
  • SetKeyCode(int) [virtual]
  • SetKeySym(const char *) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetNumberOfFlyFrames(int) [virtual]
  • SetPicker(vtkAbstractPicker *) [virtual]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *aren)
  • SetRepeatCount(int) [virtual]
  • SetShiftKey(int) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetStillUpdateRate(float) [virtual]
  • SetUserMethod(void(*f)(void *), void *arg)
  • SetUserMethodArgDelete(void(*f)(void *))
  • ShiftKey [protected]
  • ShowCursor() [inline]
  • Size [protected]
  • Start() [virtual]
  • StartPickCallback() [virtual]
  • StartPickTag [protected]
  • StillUpdateRate [protected]
  • Style [protected]
  • SubjectHelper [protected]
  • TerminateApp(void) [virtual]
  • TimerId [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSize(int x, int y) [virtual]
  • UserCallback() [virtual]
  • UserTag [protected]
  • vtkHandleMessage(HWND hwnd, UINT uMsg, WPARAM w, LPARAM l) [friend]
  • vtkHandleMessage2(HWND hwnd, UINT uMsg, WPARAM w, LPARAM l, vtkWin32RenderWindowInteractor *me) [friend]
  • vtkObject() [protected]
  • vtkRenderWindowInteractor() [protected]
  • vtkTypeRevisionMacro(vtkWin32RenderWindowInteractor, vtkRenderWindowInteractor)
  • vtkWin32RenderWindowInteractor() [protected]
  • vtkWin32RenderWindowInteractor(const vtkWin32RenderWindowInteractor &) (defined in vtkWin32RenderWindowInteractor) [private]
  • WindowId [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindowInteractor() [protected]
  • ~vtkWin32RenderWindowInteractor() [protected]
Generated on Mon Mar 25 01:35:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32TextMapper Member List

This is the complete list of members for vtkWin32TextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • Font [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastSize [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWin32TextMapper &) (defined in vtkWin32TextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkWin32TextMapper, vtkTextMapper)
  • vtkWin32TextMapper() [protected]
  • vtkWin32TextMapper(const vtkWin32TextMapper &) (defined in vtkWin32TextMapper) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
  • ~vtkWin32TextMapper() [protected]
Generated on Mon Mar 25 01:35:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWin32VideoSource Member List

This is the complete list of members for vtkWin32VideoSource, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AdvanceFrameBuffer(int n) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • AutoAdvance [protected]
  • AutoAdvanceOff() [virtual]
  • AutoAdvanceOn() [virtual]
  • BitMapPtr [protected]
  • BitMapSize [protected]
  • BreakOnError() [static]
  • CapDriverCaps [protected]
  • CapStatus [protected]
  • CaptureParms [protected]
  • CapWnd [protected]
  • CheckBuffer() [protected]
  • ClipRegion [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • DataOrigin [protected]
  • DataSpacing [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DoVFWFormatCheck() [protected]
  • DoVFWFormatSetup() [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected, virtual]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • FastForward() [virtual]
  • FlipFrames [protected]
  • FrameBuffer [protected]
  • FrameBufferBitsPerPixel [protected]
  • FrameBufferExtent [protected]
  • FrameBufferIndex [protected]
  • FrameBufferMutex [protected]
  • FrameBufferRowAlignment [protected]
  • FrameBufferSize [protected]
  • FrameBufferTimeStamps [protected]
  • FrameCount [protected]
  • FrameIndex [protected]
  • FrameOutputExtent [protected]
  • FrameRate [protected]
  • FrameSize [protected]
  • GetAbortExecute() [virtual]
  • GetAutoAdvance() [virtual]
  • GetClassName() [inline, virtual]
  • GetClipRegion() [virtual]
  • GetClipRegion(int &, int &, int &, int &, int &, int &) [virtual]
  • GetClipRegion(int[6]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDataOrigin() [virtual]
  • GetDataOrigin(float &, float &, float &) [virtual]
  • GetDataOrigin(float[3]) [virtual]
  • GetDataSpacing() [virtual]
  • GetDataSpacing(float &, float &, float &) [virtual]
  • GetDataSpacing(float[3]) [virtual]
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetFrameBufferSize() [virtual]
  • GetFrameCount() [virtual]
  • GetFrameIndex() [virtual]
  • GetFrameRate() [virtual]
  • GetFrameSize() [virtual]
  • GetFrameSize(int &, int &, int &) [virtual]
  • GetFrameSize(int[3]) [virtual]
  • GetFrameTimeStamp(int frame) [virtual]
  • GetFrameTimeStamp() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [inline, virtual]
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputFrames() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOpacity() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputFormat() [virtual]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetOutputWholeExtent() [virtual]
  • GetOutputWholeExtent(int &, int &, int &, int &, int &, int &) [virtual]
  • GetOutputWholeExtent(int[6]) [virtual]
  • GetPlaying() [virtual]
  • GetPreview() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetRecording() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GetStartTimeStamp() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • Grab() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Initialize() [virtual]
  • Initialized [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InternalGrab(LPVIDEOHDR VideoHdrPtr)
  • vtkVideoSource::InternalGrab() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LastNumberOfScalarComponents [protected]
  • LastOutputExtent [protected]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputFrames [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • NumberOfScalarComponents [protected]
  • OnParentWndDestroy()
  • Opacity [protected]
  • operator=(const vtkWin32VideoSource &) (defined in vtkWin32VideoSource) [private]
  • OutputFormat [protected]
  • OutputNeedsInitialization [protected]
  • Outputs [protected]
  • OutputWholeExtent [protected]
  • ParentWnd [protected]
  • Play() [virtual]
  • PlayerThreader [protected]
  • PlayerThreadId [protected]
  • Playing [protected]
  • Preview [protected]
  • PreviewOff() [virtual]
  • PreviewOn() [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • Record() [virtual]
  • Recording [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • ReleaseSystemResources() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • Rewind() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • Seek(int n) [virtual]
  • SetAbortExecute(int) [virtual]
  • SetAutoAdvance(int) [virtual]
  • SetClipRegion(int r[6]) [inline, virtual]
  • SetClipRegion(int x0, int x1, int y0, int y1, int z0, int z1) [virtual]
  • SetDataOrigin(float, float, float) [virtual]
  • SetDataOrigin(float[3]) [virtual]
  • SetDataSpacing(float, float, float) [virtual]
  • SetDataSpacing(float[3]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFrameBufferSize(int FrameBufferSize) [virtual]
  • SetFrameCount(int) [virtual]
  • SetFrameRate(float rate) [virtual]
  • SetFrameSize(int x, int y, int z) [virtual]
  • vtkVideoSource::SetFrameSize(int dim[3]) [inline, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputFrames(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOpacity(float) [virtual]
  • SetOutput(vtkImageData *output)
  • SetOutputFormat(int format) [virtual]
  • SetOutputFormatToLuminance() [inline]
  • SetOutputFormatToRGB() [inline]
  • SetOutputFormatToRGBA() [inline]
  • SetOutputWholeExtent(int, int, int, int, int, int) [virtual]
  • SetOutputWholeExtent(int[6]) [virtual]
  • SetPreview(int p)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetStartTimeStamp(double t) [inline]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • StartTimeStamp [protected]
  • Stop() [virtual]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnpackRasterLine(char *outptr, char *inptr, int start, int count) [protected, virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateFrameBuffer() [protected, virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • VideoFormatDialog()
  • VideoSourceDialog()
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWin32VideoSource, vtkVideoSource)
  • vtkVideoSource() [protected]
  • vtkWin32VideoSource() [protected]
  • vtkWin32VideoSource(const vtkWin32VideoSource &) (defined in vtkWin32VideoSource) [private]
  • WndClassName [protected]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkVideoSource() [protected]
  • ~vtkWin32VideoSource() [protected]
Generated on Mon Mar 25 01:36:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWinCEOpenGLRenderWindow Member List

This is the complete list of members for vtkWinCEOpenGLRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • ApplicationInstance [protected]
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • Clean()
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • CopyResultFrame() [virtual]
  • CreateAWindow(int x, int y, int width, int height) [protected]
  • CurrentSubFrame [protected]
  • CursorHidden [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DeviceContext [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame(void) [virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetScreenSize() [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId() [virtual]
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [virtual]
  • InAbortCheck [protected]
  • Initialize(void) [virtual]
  • InitializeApplication() [protected]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • MessageProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NextWindowId [protected]
  • NumberOfLayers [protected]
  • OffScreenContextId [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OffScreenWindow [protected]
  • OldMonitorSetting [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkWinCEOpenGLRenderWindow &) (defined in vtkWinCEOpenGLRenderWindow) [private]
  • OwnWindow [protected]
  • ParentId [protected]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • PrefFullScreen(void) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResizeWhileOffscreen(int xsize, int ysize) [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScreenSize [protected]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(void *) [inline, virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNextWindowId(HWND) [virtual]
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(HWND) [virtual]
  • SetParentId(void *foo) [inline, virtual]
  • SetParentInfo(char *) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • vtkOpenGLRenderWindow::SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • vtkOpenGLRenderWindow::SetSize(int a[2]) [virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *foo) [inline, virtual]
  • SetWindowId(HWND) [virtual]
  • SetWindowInfo(char *) [virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [virtual]
  • Size [protected]
  • Start(void) [virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOpenGLRenderWindow() [protected]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkWinCEOpenGLRenderWindow, vtkOpenGLRenderWindow)
  • vtkWinCEOpenGLRenderWindow() [protected]
  • vtkWinCEOpenGLRenderWindow(const vtkWinCEOpenGLRenderWindow &) (defined in vtkWinCEOpenGLRenderWindow) [private]
  • vtkWindow() [protected]
  • WindowId [protected]
  • WindowInitialize(void) [virtual]
  • WindowName [protected]
  • WindowRemap(void) [virtual]
  • WndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam) [protected, static]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLRenderWindow() [protected]
  • ~vtkRenderWindow() [protected]
  • ~vtkWinCEOpenGLRenderWindow() [protected]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:36:07 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWindow Member List

This is the complete list of members for vtkWindow, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetGenericContext()=0 [pure virtual]
  • GetGenericDisplayId()=0 [pure virtual]
  • GetGenericDrawable()=0 [pure virtual]
  • GetGenericParentId()=0 [pure virtual]
  • GetGenericWindowId()=0 [pure virtual]
  • GetGlobalWarningDisplay() [static]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetPixelData(int, int, int, int, int) [inline, virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetSize() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeCurrent() [inline, virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [inline, static]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • operator=(const vtkWindow &) (defined in vtkWindow) [private]
  • Position [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()=0 [pure virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(void *)=0 [pure virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(void *)=0 [pure virtual]
  • SetParentInfo(char *)=0 [pure virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [virtual]
  • SetReferenceCount(int)
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(void *)=0 [pure virtual]
  • SetWindowInfo(char *)=0 [pure virtual]
  • SetWindowName(char *) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWindow, vtkObject)
  • vtkWindow() [protected]
  • vtkWindow(const vtkWindow &) (defined in vtkWindow) [private]
  • WindowName [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWindow() [protected]
Generated on Mon Mar 25 01:36:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWindowedSincPolyDataFilter Member List

This is the complete list of members for vtkWindowedSincPolyDataFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • BoundarySmoothing [protected]
  • BoundarySmoothingOff() [virtual]
  • BoundarySmoothingOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EdgeAngle [protected]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, protected, virtual]
  • ExecuteGhostLevel [protected]
  • ExecuteInformation() [protected, virtual]
  • ExecuteNumberOfPieces [protected]
  • ExecutePiece [protected]
  • FeatureAngle [protected]
  • FeatureEdgeSmoothing [protected]
  • FeatureEdgeSmoothingOff() [virtual]
  • FeatureEdgeSmoothingOn() [virtual]
  • GenerateErrorScalars [protected]
  • GenerateErrorScalarsOff() [virtual]
  • GenerateErrorScalarsOn() [virtual]
  • GenerateErrorVectors [protected]
  • GenerateErrorVectorsOff() [virtual]
  • GenerateErrorVectorsOn() [virtual]
  • GetAbortExecute() [virtual]
  • GetBoundarySmoothing() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetEdgeAngle() [virtual]
  • GetErrorCode() [virtual]
  • GetFeatureAngle() [virtual]
  • GetFeatureEdgeSmoothing() [virtual]
  • GetGenerateErrorScalars() [virtual]
  • GetGenerateErrorVectors() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfIterations() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetPassBand() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfIterations [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWindowedSincPolyDataFilter &) (defined in vtkWindowedSincPolyDataFilter) [private]
  • Outputs [protected]
  • PassBand [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBoundarySmoothing(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEdgeAngle(float) [virtual]
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetFeatureAngle(float) [virtual]
  • SetFeatureEdgeSmoothing(int) [virtual]
  • SetGenerateErrorScalars(int) [virtual]
  • SetGenerateErrorVectors(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfIterations(int) [virtual]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkPolyData *output)
  • SetPassBand(float) [virtual]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkObject() [protected]
  • vtkPolyDataSource() [protected]
  • vtkPolyDataToPolyDataFilter() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWindowedSincPolyDataFilter, vtkPolyDataToPolyDataFilter)
  • vtkWindowedSincPolyDataFilter() [protected]
  • vtkWindowedSincPolyDataFilter(const vtkWindowedSincPolyDataFilter &) (defined in vtkWindowedSincPolyDataFilter) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataSource() [inline, protected]
  • ~vtkPolyDataToPolyDataFilter() [inline, protected]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWindowedSincPolyDataFilter() [inline, protected]
Generated on Mon Mar 25 01:36:11 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWindowLevelLookupTable Member List

This is the complete list of members for vtkWindowLevelLookupTable, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Allocate(int sz=256, int ext=256)
  • Alpha [protected]
  • AlphaRange [protected]
  • BreakOnError() [static]
  • Build() [virtual]
  • BuildTime [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ConvertUnsignedCharToRGBA(vtkUnsignedCharArray *colors, int numComp, int numTuples) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • ForceBuild() [virtual]
  • GetAlpha() [virtual]
  • GetAlphaRange() [virtual]
  • GetAlphaRange(float &, float &) [virtual]
  • GetAlphaRange(float[2]) [virtual]
  • GetClassName() [inline, virtual]
  • GetColor(float x) [inline]
  • GetColor(float x, float rgb[3]) [virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetHueRange() [virtual]
  • GetHueRange(float &, float &) [virtual]
  • GetHueRange(float[2]) [virtual]
  • GetIndex(float v) [virtual]
  • GetInverseVideo() [virtual]
  • GetLevel() [virtual]
  • GetLuminance(float x) [inline]
  • GetMaximumColor(unsigned char rgba[4]) [inline]
  • GetMaximumColor() [inline]
  • GetMaximumTableValue() [virtual]
  • GetMaximumTableValue(float &, float &, float &, float &) [virtual]
  • GetMaximumTableValue(float[4]) [virtual]
  • GetMinimumColor(unsigned char rgba[4]) [inline]
  • GetMinimumColor() [inline]
  • GetMinimumTableValue() [virtual]
  • GetMinimumTableValue(float &, float &, float &, float &) [virtual]
  • GetMinimumTableValue(float[4]) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetNumberOfTableValues() [inline]
  • GetOpacity(float v)
  • vtkScalarsToColors::GetOpacity(float vtkNotUsed(v)) [inline, virtual]
  • GetPointer(const vtkIdType id) [inline]
  • GetRamp() [virtual]
  • GetRange() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetSaturationRange() [virtual]
  • GetSaturationRange(float &, float &) [virtual]
  • GetSaturationRange(float[2]) [virtual]
  • GetScale() [virtual]
  • GetTableRange() [virtual]
  • GetTableRange(float data[2]) [virtual]
  • GetTableValue(vtkIdType id)
  • GetTableValue(vtkIdType id, float rgba[4])
  • GetValueRange() [virtual]
  • GetValueRange(float &, float &) [virtual]
  • GetValueRange(float[2]) [virtual]
  • GetWindow() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HueRange [protected]
  • InsertTime [protected]
  • InverseVideo [protected]
  • InverseVideoOff() [virtual]
  • InverseVideoOn() [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Level [protected]
  • MapScalars(vtkDataArray *scalars, int colorMode, int component)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output, int outputFormat)
  • MapScalarsThroughTable(vtkDataArray *scalars, unsigned char *output) [inline]
  • MapScalarsThroughTable2(void *input, unsigned char *output, int inputDataType, int numberOfValues, int inputIncrement, int outputIncrement) [virtual]
  • MapValue(float v) [virtual]
  • MaximumColor [protected]
  • MaximumTableValue [protected]
  • MinimumColor [protected]
  • MinimumTableValue [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • operator=(const vtkWindowLevelLookupTable &) (defined in vtkWindowLevelLookupTable) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Ramp [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RGBA [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SaturationRange [protected]
  • Scale [protected]
  • SetAlpha(float alpha)
  • SetAlphaRange(float, float) [virtual]
  • SetAlphaRange(float[2])
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetHueRange(float, float) [virtual]
  • SetHueRange(float[2])
  • SetInverseVideo(int iv)
  • SetLevel(float level) [inline]
  • SetMaximumColor(int r, int g, int b, int a) [inline]
  • SetMaximumColor(const unsigned char rgba[4]) [inline]
  • SetMaximumTableValue(float, float, float, float) [virtual]
  • SetMaximumTableValue(float[4]) [virtual]
  • SetMinimumColor(int r, int g, int b, int a) [inline]
  • SetMinimumColor(const unsigned char rgba[4]) [inline]
  • SetMinimumTableValue(float, float, float, float) [virtual]
  • SetMinimumTableValue(float[4]) [virtual]
  • SetNumberOfColors(vtkIdType) [virtual]
  • SetNumberOfTableValues(vtkIdType number)
  • SetRamp(int) [virtual]
  • SetRampToLinear() [inline]
  • SetRampToSCurve() [inline]
  • SetRange(float min, float max) [inline, virtual]
  • SetRange(float rng[2]) [inline]
  • SetReferenceCount(int)
  • SetSaturationRange(float, float) [virtual]
  • SetSaturationRange(float[2])
  • SetScale(int scale)
  • SetScaleToLinear() [inline]
  • SetScaleToLog10() [inline]
  • SetTableRange(float r[2])
  • SetTableRange(float min, float max) [virtual]
  • SetTableValue(vtkIdType indx, float rgba[4])
  • SetTableValue(vtkIdType indx, float r, float g, float b, float a=1.0)
  • SetValueRange(float, float) [virtual]
  • SetValueRange(float[2])
  • SetWindow(float window) [inline]
  • SubjectHelper [protected]
  • Table [protected]
  • TableRange [protected]
  • UnRegister(vtkObject *o) [virtual]
  • ValueRange [protected]
  • vtkLookupTable(int sze=256, int ext=256) [protected]
  • vtkObject() [protected]
  • vtkScalarsToColors() [inline, protected]
  • vtkTypeRevisionMacro(vtkWindowLevelLookupTable, vtkLookupTable)
  • vtkWindowLevelLookupTable(int sze=256, int ext=256) [protected]
  • vtkWindowLevelLookupTable(const vtkWindowLevelLookupTable &) (defined in vtkWindowLevelLookupTable) [private]
  • Window [protected]
  • WritePointer(const vtkIdType id, const int number)
  • ~vtkLookupTable() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkScalarsToColors() [inline, protected]
  • ~vtkWindowLevelLookupTable() [inline, protected]
Generated on Mon Mar 25 01:36:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWindowToImageFilter Member List

This is the complete list of members for vtkWindowToImageFilter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddOutput(vtkDataObject *output) [protected, virtual]
  • AllocateOutputData(vtkDataObject *out) [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeInputUpdateExtents(vtkDataObject *output) [virtual]
  • ComputeRequiredInputUpdateExtent(int *vtkNotUsed(in), int *vtkNotUsed(out)) [inline, protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • EnlargeOutputUpdateExtents(vtkDataObject *output) [virtual]
  • Execute() [protected, virtual]
  • Execute(vtkImageData *data) [protected, virtual]
  • ExecuteData(vtkDataObject *data) [protected]
  • vtkImageSource::ExecuteData(vtkDataObject *vtkNotUsed(output)) [inline, virtual]
  • ExecuteInformation() [protected, virtual]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetErrorCode() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetMagnification() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfOutputs() [virtual]
  • GetOutput()
  • GetOutput(int idx) [inline]
  • GetOutputIndex(vtkDataObject *out)
  • GetOutputs()
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReadFrontBuffer() [virtual]
  • GetReferenceCount() [inline]
  • GetReleaseDataFlag() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InformationTime [protected]
  • Input [protected]
  • Inputs [protected]
  • InRegisterLoop(vtkObject *) [virtual]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LegacyHack
  • Magnification [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfOutputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWindowToImageFilter &) (defined in vtkWindowToImageFilter) [private]
  • Outputs [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • PropagateUpdateExtent(vtkDataObject *output) [virtual]
  • ReadFrontBuffer [protected]
  • ReadFrontBufferOff() [virtual]
  • ReadFrontBufferOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseDataFlagOff() [virtual]
  • ReleaseDataFlagOn() [virtual]
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveOutput(vtkDataObject *output) [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetErrorCode(unsigned long) [protected, virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkWindow *input)
  • SetMagnification(int) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNthOutput(int num, vtkDataObject *output) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetNumberOfOutputs(int num) [protected]
  • SetOutput(vtkImageData *output)
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReadFrontBuffer(int) [virtual]
  • SetReferenceCount(int)
  • SetReleaseDataFlag(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TriggerAsynchronousUpdate() [virtual]
  • UnRegister(vtkObject *o) [virtual]
  • UnRegisterAllOutputs(void)
  • Update() [virtual]
  • UpdateData(vtkDataObject *output) [virtual]
  • UpdateInformation() [virtual]
  • UpdateProgress(float amount)
  • UpdateWholeExtent() [virtual]
  • Updating [protected]
  • vtkImageSource() [protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkSource() [protected]
  • vtkTypeRevisionMacro(vtkWindowToImageFilter, vtkImageSource)
  • vtkWindowToImageFilter() [protected]
  • vtkWindowToImageFilter(const vtkWindowToImageFilter &) (defined in vtkWindowToImageFilter) [private]
  • ~vtkImageSource() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkSource() [protected]
  • ~vtkWindowToImageFilter() [protected]
Generated on Mon Mar 25 01:36:14 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWorldPointPicker Member List

This is the complete list of members for vtkWorldPointPicker, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddPickList(vtkProp *)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DeletePickList(vtkProp *)
  • EndPickTag [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetPickFromList() [virtual]
  • GetPickList() [inline]
  • GetPickPosition() [virtual]
  • GetPickPosition(float data[3]) [virtual]
  • GetReferenceCount() [inline]
  • GetRenderer() [virtual]
  • GetSelectionPoint() [virtual]
  • GetSelectionPoint(float data[3]) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected, virtual]
  • InitializePickList()
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkWorldPointPicker &) (defined in vtkWorldPointPicker) [private]
  • Pick(float selectionX, float selectionY, float selectionZ, vtkRenderer *renderer) [virtual]
  • Pick(float selectionPt[3], vtkRenderer *renderer) [inline]
  • PickFromList [protected]
  • PickFromListOff() [virtual]
  • PickFromListOn() [virtual]
  • PickList [protected]
  • PickPosition [protected]
  • PickTag [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Renderer [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SelectionPoint [protected]
  • SetDebug(unsigned char debugFlag)
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetPickFromList(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetReferenceCount(int)
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • StartPickTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkAbstractPicker() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkWorldPointPicker, vtkAbstractPicker)
  • vtkWorldPointPicker() [protected]
  • vtkWorldPointPicker(const vtkWorldPointPicker &) (defined in vtkWorldPointPicker) [private]
  • ~vtkAbstractPicker() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWorldPointPicker() [inline, protected]
Generated on Mon Mar 25 01:36:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkWriter Member List

This is the complete list of members for vtkWriter, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EncodeArrayName(char *resname, const char *name)
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkWriter &) (defined in vtkWriter) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveAllInputs()
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • Update()
  • UpdateProgress(float amount)
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkWriter, vtkProcessObject)
  • vtkWriter() [protected]
  • vtkWriter(const vtkWriter &) (defined in vtkWriter) [private]
  • Write() [virtual]
  • WriteData()=0 [protected, pure virtual]
  • WriteTime [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkWriter() [protected]
Generated on Mon Mar 25 01:36:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXImageMapper Member List

This is the complete list of members for vtkXImageMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorLevel [protected]
  • ColorWindow [protected]
  • Consumers [protected]
  • CustomDisplayExtents [protected]
  • DataOut [protected]
  • DataOutSize [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayExtent
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorLevel() [virtual]
  • GetColorScale()
  • GetColorShift()
  • GetColorWindow() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetCustomDisplayExtents() [virtual]
  • GetCustomDisplayExtents(int data[4]) [virtual]
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput()
  • GetInputs() [inline]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderToRectangle() [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetTimeToDraw() [virtual]
  • GetUseCustomExtents() [virtual]
  • GetWholeZMax()
  • GetWholeZMin()
  • GetXColors(int colors[])
  • GetXWindowColorMasks(vtkWindow *window, unsigned long *rmask, unsigned long *gmask, unsigned long *bmask)
  • GetXWindowDepth(vtkWindow *window)
  • GetXWindowVisualClass(vtkWindow *window)
  • GetXWindowVisualId(vtkWindow *window, Visual *visualID)
  • GetZSlice() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Image [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkXImageMapper &) (defined in vtkXImageMapper) [private]
  • PositionAdjustment [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderData(vtkViewport *viewport, vtkImageData *data, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderStart(vtkViewport *viewport, vtkActor2D *actor)
  • RenderToRectangle [protected]
  • RenderToRectangleOff() [virtual]
  • RenderToRectangleOn() [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorLevel(float) [virtual]
  • SetColorWindow(float) [virtual]
  • SetCustomDisplayExtents(int data[]) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkImageData *input) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetRenderToRectangle(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetUseCustomExtents(int) [virtual]
  • SetZSlice(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseCustomExtents [protected]
  • UseCustomExtentsOff() [virtual]
  • UseCustomExtentsOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkImageMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkXImageMapper, vtkImageMapper)
  • vtkXImageMapper() [protected]
  • vtkXImageMapper(const vtkXImageMapper &) (defined in vtkXImageMapper) [private]
  • ZSlice [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkImageMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkXImageMapper() [protected]
Generated on Mon Mar 25 01:36:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXImageWindow Member List

This is the complete list of members for vtkXImageWindow, including all inherited members.
  • AddImager(vtkImager *im)
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocateDirectColorMap() [protected]
  • BreakOnError() [static]
  • ClosePPMImageFile() [virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMap [protected]
  • Colors [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayId [protected]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Drawable [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • EraseWindow() [virtual]
  • FileName [protected]
  • Frame() [virtual]
  • Gc [protected]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDefaultVisualInfo(XVisualInfo *info) [protected]
  • GetDesiredColormap() [virtual]
  • GetDesiredDepth() [virtual]
  • GetDesiredVisual() [virtual]
  • GetDisplayId()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetFileName() [virtual]
  • GetGC()
  • GetGenericContext() [inline, virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [inline, virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGrayScaleHint() [virtual]
  • GetImagers() [inline]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetNumberOfColors() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetParentId()
  • GetPixelData(int x1, int y1, int x2, int y2, int) [virtual]
  • GetPosition() [virtual]
  • GetPosition(int *x, int *y) [inline, virtual]
  • GetReferenceCount() [inline]
  • GetShiftsScalesAndMasks(int &rshift, int &gshift, int &bshift, int &rscale, int &gscale, int &bscale, unsigned long &rmask, unsigned long &gmask, unsigned long &bmask) [protected]
  • GetSize() [virtual]
  • GetSize(int *x, int *y) [inline, virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetVisualClass() [virtual]
  • GetVisualDepth() [virtual]
  • GetVisualId() [inline]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GrayScaleHint [protected]
  • GrayScaleHintOff() [virtual]
  • GrayScaleHintOn() [virtual]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Imagers [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • MakeColorMap(Visual *visual) [protected]
  • MakeCurrent() [inline, virtual]
  • MakeDefaultWindow() [protected, virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfColors [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • Offset [protected]
  • OpenPPMImageFile() [virtual]
  • operator=(const vtkXImageWindow &) (defined in vtkXImageWindow) [private]
  • OwnDisplay [protected]
  • ParentId [protected]
  • PixmapHeight [protected]
  • PixmapWidth [protected]
  • Position [protected]
  • PPMImageFilePtr [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveImager(vtkImager *im)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SaveImageAsPPM() [virtual]
  • SetBackgroundColor(float r, float g, float b)
  • SetDebug(unsigned char debugFlag)
  • SetDisplayId(Display *)
  • SetDisplayId(void *) [virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFileName(const char *) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGrayScaleHint(int) [virtual]
  • SetMapped(int) [virtual]
  • SetOffScreenRendering(int) [virtual]
  • SetParentId(Window)
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *info) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetSize(int x, int y) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(Window)
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *info) [virtual]
  • SetWindowName(char *name) [virtual]
  • Size [protected]
  • SubjectHelper [protected]
  • SwapBuffers() [virtual]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • VisualClass [protected]
  • VisualDepth [protected]
  • VisualId [protected]
  • vtkImageWindow() [protected]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkXImageWindow, vtkImageWindow)
  • vtkWindow() [protected]
  • vtkXImageWindow() [protected]
  • vtkXImageWindow(const vtkXImageWindow &) (defined in vtkXImageWindow) [private]
  • WindowCreated [protected]
  • WindowId [protected]
  • WindowName [protected]
  • WritePPMImageFile() [virtual]
  • ~vtkImageWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkWindow() [protected]
  • ~vtkXImageWindow() [protected]
Generated on Mon Mar 25 01:36:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXMesaRenderWindow Member List

This is the complete list of members for vtkXMesaRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMap [protected]
  • ContextId [protected]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • CursorHidden [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DisplayId [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame(void) [virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredColormap() [virtual]
  • GetDesiredDepth() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDesiredVisual() [virtual]
  • GetDesiredVisualInfo() [virtual]
  • GetDisplayId()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetParentId()
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetScreenSize() [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [virtual]
  • InAbortCheck [protected]
  • Initialize(void) [virtual]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NextWindowId [protected]
  • NumberOfLayers [protected]
  • OffScreenContextId [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OffScreenWindow [protected]
  • OldMonitorSetting [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkXMesaRenderWindow &) (defined in vtkXMesaRenderWindow) [private]
  • OwnDisplay [protected]
  • OwnWindow [protected]
  • ParentId [protected]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • PrefFullScreen(void) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScreenDoubleBuffer [protected]
  • ScreenMapped [protected]
  • ScreenSize [protected]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(Display *)
  • SetDisplayId(void *) [virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNextWindowId(Window)
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int i) [virtual]
  • SetParentId(Window)
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *info) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(Window)
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *info) [virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [virtual]
  • Size [protected]
  • Start(void) [virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkMesaRenderWindow() [protected]
  • vtkObject() [protected]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkXMesaRenderWindow, vtkMesaRenderWindow)
  • vtkWindow() [protected]
  • vtkXMesaRenderWindow() [protected]
  • vtkXMesaRenderWindow(const vtkXMesaRenderWindow &) (defined in vtkXMesaRenderWindow) [private]
  • WindowId [protected]
  • WindowInitialize(void) [virtual]
  • WindowName [protected]
  • WindowRemap(void) [virtual]
  • ~vtkMesaRenderWindow() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
  • ~vtkXMesaRenderWindow() [protected]
Generated on Mon Mar 25 01:36:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXMesaTextMapper Member List

This is the complete list of members for vtkXMesaTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CurrentFont [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DetermineSize(vtkViewport *viewport, int size[2]) [protected]
  • EndTag [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp, Font) [static]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkXMesaTextMapper &) (defined in vtkXMesaTextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • Size [protected]
  • SizeMTime [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • ViewportSize [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkXMesaTextMapper, vtkXTextMapper)
  • vtkXMesaTextMapper() [protected]
  • vtkXMesaTextMapper(const vtkXMesaTextMapper &) (defined in vtkXMesaTextMapper) [private]
  • vtkXTextMapper() [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
  • ~vtkXMesaTextMapper() [inline, protected]
  • ~vtkXTextMapper() [inline, protected]
Generated on Mon Mar 25 01:36:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXMLFileOutputWindow Member List

This is the complete list of members for vtkXMLFileOutputWindow, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Append [protected]
  • AppendOff() [virtual]
  • AppendOn() [virtual]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DisplayDebugText(const char *) [virtual]
  • DisplayErrorText(const char *) [virtual]
  • DisplayGenericWarningText(const char *) [virtual]
  • DisplayTag(const char *) [virtual]
  • DisplayText(const char *) [virtual]
  • DisplayWarningText(const char *) [virtual]
  • DisplayXML(const char *, const char *) [protected, virtual]
  • FileName [protected]
  • Flush [protected]
  • FlushOff() [virtual]
  • FlushOn() [virtual]
  • GetAppend() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetFileName() [virtual]
  • GetFlush() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInstance() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Initialize() [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkXMLFileOutputWindow &) (defined in vtkXMLFileOutputWindow) [private]
  • OStream [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • PromptUser [protected]
  • PromptUserOff() [virtual]
  • PromptUserOn() [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • SafeDownCast(vtkObject *o) [static]
  • SetAppend(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetFileName(const char *) [virtual]
  • SetFlush(int) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInstance(vtkOutputWindow *instance) [static]
  • SetPromptUser(int) [virtual]
  • SetReferenceCount(int)
  • SmartPointer [static]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkFileOutputWindow() [protected]
  • vtkObject() [protected]
  • vtkOutputWindow() [protected]
  • vtkTypeRevisionMacro(vtkXMLFileOutputWindow, vtkFileOutputWindow)
  • vtkXMLFileOutputWindow() [inline, protected]
  • vtkXMLFileOutputWindow(const vtkXMLFileOutputWindow &) (defined in vtkXMLFileOutputWindow) [private]
  • ~vtkFileOutputWindow() [protected, virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkOutputWindow() [protected, virtual]
  • ~vtkXMLFileOutputWindow() [inline, protected, virtual]
Generated on Mon Mar 25 01:36:32 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXMLParser Member List

This is the complete list of members for vtkXMLParser, including all inherited members.
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • BreakOnError() [static]
  • CharacterDataHandler(const char *data, int length) [protected, virtual]
  • CharacterDataHandlerFunction(void *parser, const char *data, int length) [protected, static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndElement(const char *name) [protected, virtual]
  • EndElementFunction(void *parser, const char *name) [protected, static]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetMTime() [virtual]
  • GetReferenceCount() [inline]
  • GetStream() [virtual]
  • GetXMLByteIndex() [protected]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsSpace(char c) [protected, static]
  • IsTypeOf(const char *name) [static]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • operator=(const vtkXMLParser &) (defined in vtkXMLParser) [private]
  • Parse()
  • ParseBuffer(const char *buffer, unsigned int count) [protected]
  • ParseBuffer(const char *buffer) [protected]
  • Parser [protected]
  • ParseStream() [protected, virtual]
  • ParsingComplete() [protected, virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • ReportBadAttribute(const char *element, const char *attr, const char *value) [protected, virtual]
  • ReportMissingAttribute(const char *element, const char *attr) [protected, virtual]
  • ReportStrayAttribute(const char *element, const char *attr, const char *value) [protected, virtual]
  • ReportUnknownElement(const char *element) [protected, virtual]
  • ReportXmlParseError() [protected, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetDebug(unsigned char debugFlag)
  • SetGlobalWarningDisplay(int val) [static]
  • SetReferenceCount(int)
  • SetStream(istream *) [virtual]
  • StartElement(const char *name, const char **atts) [protected, virtual]
  • StartElementFunction(void *parser, const char *name, const char **atts) [protected, static]
  • Stream [protected]
  • SubjectHelper [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkTypeRevisionMacro(vtkXMLParser, vtkObject)
  • vtkXMLParser() [protected]
  • vtkXMLParser(const vtkXMLParser &) (defined in vtkXMLParser) [private]
  • ~vtkObject() [protected, virtual]
  • ~vtkXMLParser() [protected]
Generated on Mon Mar 25 01:36:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXOpenGLRenderWindow Member List

This is the complete list of members for vtkXOpenGLRenderWindow, including all inherited members.
  • AAFrames [protected]
  • AbortCheckMethod [protected]
  • AbortCheckMethodArg [protected]
  • AbortCheckMethodArgDelete [protected]
  • AbortRender [protected]
  • AccumulationBuffer [protected]
  • AccumulationBufferSize [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddRenderer(vtkRenderer *)
  • Borders [protected]
  • BordersOff() [virtual]
  • BordersOn() [virtual]
  • BreakOnError() [static]
  • CheckAbortStatus() [virtual]
  • CheckInRenderStatus() [inline, virtual]
  • ClearInRenderStatus() [inline, virtual]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorMap [protected]
  • ContextId [protected]
  • CopyResultFrame() [virtual]
  • CurrentSubFrame [protected]
  • CursorHidden [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DisplayId [protected]
  • DoAARender() [protected, virtual]
  • DoFDRender() [protected, virtual]
  • DoStereoRender() [protected, virtual]
  • DoubleBuffer [protected]
  • DoubleBufferOff() [virtual]
  • DoubleBufferOn() [virtual]
  • DPI [protected]
  • Erase [protected]
  • EraseOff() [virtual]
  • EraseOn() [virtual]
  • FDFrames [protected]
  • Frame(void) [virtual]
  • FullScreen [protected]
  • FullScreenOff() [virtual]
  • FullScreenOn() [virtual]
  • GetAAFrames() [virtual]
  • GetAbortRender() [virtual]
  • GetBorders() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetDebug()
  • GetDepthBufferSize() [virtual]
  • GetDesiredColormap() [virtual]
  • GetDesiredDepth() [virtual]
  • GetDesiredUpdateRate() [virtual]
  • GetDesiredVisual() [virtual]
  • GetDesiredVisualInfo() [virtual]
  • GetDisplayId()
  • GetDoubleBuffer() [virtual]
  • GetDPI() [virtual]
  • GetErase() [virtual]
  • GetEventPending() [virtual]
  • GetFDFrames() [virtual]
  • GetFullScreen() [virtual]
  • GetGenericContext() [virtual]
  • GetGenericDisplayId() [inline, virtual]
  • GetGenericDrawable() [inline, virtual]
  • GetGenericParentId() [inline, virtual]
  • GetGenericWindowId() [virtual]
  • GetGlobalMaximumNumberOfMultiSamples() [static]
  • GetGlobalWarningDisplay() [static]
  • GetInAbortCheck() [virtual]
  • GetInteractor() [virtual]
  • GetLineSmoothing() [virtual]
  • GetMapped() [virtual]
  • GetMTime() [virtual]
  • GetMultiSamples() [virtual]
  • GetNeverRendered() [virtual]
  • GetNumberOfLayers() [virtual]
  • GetOffScreenRendering() [virtual]
  • GetParentId()
  • GetPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetPointSmoothing() [virtual]
  • GetPolygonSmoothing() [virtual]
  • GetPosition() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderers() [inline]
  • GetRenderLibrary() [inline, static]
  • GetRGBACharPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetRGBAPixelData(int x, int y, int x2, int y2, int front) [virtual]
  • GetScreenSize() [virtual]
  • GetSize() [virtual]
  • GetStereoCapableWindow() [virtual]
  • GetStereoRender() [virtual]
  • GetStereoType() [virtual]
  • GetStereoTypeAsString() [inline]
  • GetSubFrames() [virtual]
  • GetSwapBuffers() [virtual]
  • GetTileScale() [virtual]
  • GetTileViewport() [virtual]
  • GetTileViewport(float &, float &, float &, float &) [virtual]
  • GetTileViewport(float[4]) [virtual]
  • GetWindowId()
  • GetWindowName() [virtual]
  • GetZbufferData(int x1, int y1, int x2, int y2) [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [virtual]
  • InAbortCheck [protected]
  • Initialize(void) [virtual]
  • InRender [protected]
  • Interactor [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • LineSmoothing [protected]
  • LineSmoothingOff() [virtual]
  • LineSmoothingOn() [virtual]
  • MakeCurrent() [virtual]
  • MakeRenderWindowInteractor() [virtual]
  • Mapped [protected]
  • MappedOff() [virtual]
  • MappedOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • MultiSamples [protected]
  • NeverRendered [protected]
  • New() [static]
  • NextWindowId [protected]
  • NumberOfLayers [protected]
  • OffScreenRendering [protected]
  • OffScreenRenderingOff() [virtual]
  • OffScreenRenderingOn() [virtual]
  • OldMonitorSetting [protected]
  • OldScreen [protected]
  • OpenGLInit() [virtual]
  • operator=(const vtkXOpenGLRenderWindow &) (defined in vtkXOpenGLRenderWindow) [private]
  • OwnDisplay [protected]
  • OwnWindow [protected]
  • ParentId [protected]
  • PointSmoothing [protected]
  • PointSmoothingOff() [virtual]
  • PointSmoothingOn() [virtual]
  • PolygonSmoothing [protected]
  • PolygonSmoothingOff() [virtual]
  • PolygonSmoothingOn() [virtual]
  • Position [protected]
  • PrefFullScreen(void) [virtual]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • RegisterTextureResource(GLuint id)
  • ReleaseRGBAPixelData(float *data) [virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RemoveRenderer(vtkRenderer *)
  • Render() [virtual]
  • Renderers [protected]
  • ResultFrame [protected]
  • SafeDownCast(vtkObject *o) [static]
  • ScreenSize [protected]
  • SetAAFrames(int) [virtual]
  • SetAbortCheckMethod(void(*f)(void *), void *arg)
  • SetAbortCheckMethodArgDelete(void(*f)(void *))
  • SetAbortRender(int) [virtual]
  • SetBorders(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float)
  • SetDisplayId(Display *)
  • SetDisplayId(void *) [virtual]
  • SetDoubleBuffer(int) [virtual]
  • SetDPI(int) [virtual]
  • SetErase(int) [virtual]
  • SetFDFrames(int) [virtual]
  • SetFullScreen(int) [virtual]
  • SetGlobalMaximumNumberOfMultiSamples(int val) [static]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInAbortCheck(int) [virtual]
  • SetInteractor(vtkRenderWindowInteractor *)
  • SetLineSmoothing(int) [virtual]
  • SetMapped(int) [virtual]
  • SetMultiSamples(int) [virtual]
  • SetNextWindowId(Window)
  • SetNumberOfLayers(int) [virtual]
  • SetOffScreenRendering(int i) [virtual]
  • SetParentId(Window)
  • SetParentId(void *) [virtual]
  • SetParentInfo(char *info) [virtual]
  • SetPixelData(int x, int y, int x2, int y2, unsigned char *, int front) [virtual]
  • SetPointSmoothing(int) [virtual]
  • SetPolygonSmoothing(int) [virtual]
  • SetPosition(int, int) [virtual]
  • SetPosition(int a[2]) [inline, virtual]
  • SetReferenceCount(int)
  • SetRGBACharPixelData(int x, int y, int x2, int y2, unsigned char *, int front, int blend=0) [virtual]
  • SetRGBAPixelData(int x, int y, int x2, int y2, float *, int front, int blend=0) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int a[2]) [inline, virtual]
  • SetStereoCapableWindow(int capable) [virtual]
  • SetStereoRender(int stereo)
  • SetStereoType(int) [virtual]
  • SetStereoTypeToCrystalEyes() [inline]
  • SetStereoTypeToDresden() [inline]
  • SetStereoTypeToInterlaced() [inline]
  • SetStereoTypeToLeft() [inline]
  • SetStereoTypeToRedBlue() [inline]
  • SetStereoTypeToRight() [inline]
  • SetSubFrames(int) [virtual]
  • SetSwapBuffers(int) [virtual]
  • SetTileScale(int) [virtual]
  • SetTileViewport(float, float, float, float) [virtual]
  • SetTileViewport(float[4]) [virtual]
  • SetWindowId(Window)
  • SetWindowId(void *) [virtual]
  • SetWindowInfo(char *info) [virtual]
  • SetWindowName(char *) [virtual]
  • SetZbufferData(int x1, int y1, int x2, int y2, float *buffer) [virtual]
  • ShowCursor() [virtual]
  • Size [protected]
  • Start(void) [virtual]
  • StereoBuffer [protected]
  • StereoCapableWindow [protected]
  • StereoCapableWindowOff() [virtual]
  • StereoCapableWindowOn() [virtual]
  • StereoMidpoint() [virtual]
  • StereoRender [protected]
  • StereoRenderComplete() [virtual]
  • StereoRenderOff() [virtual]
  • StereoRenderOn() [virtual]
  • StereoStatus [protected]
  • StereoType [protected]
  • StereoUpdate() [virtual]
  • SubFrames [protected]
  • SubjectHelper [protected]
  • SwapBuffers [protected]
  • SwapBuffersOff() [virtual]
  • SwapBuffersOn() [virtual]
  • TextureResourceIds [protected]
  • TileScale [protected]
  • TileSize [protected]
  • TileViewport [protected]
  • UnRegister(vtkObject *o) [virtual]
  • vtkObject() [protected]
  • vtkOpenGLRenderWindow() [protected]
  • vtkRenderWindow() [protected]
  • vtkTypeRevisionMacro(vtkXOpenGLRenderWindow, vtkOpenGLRenderWindow)
  • vtkWindow() [protected]
  • vtkXOpenGLRenderWindow() [protected]
  • vtkXOpenGLRenderWindow(const vtkXOpenGLRenderWindow &) (defined in vtkXOpenGLRenderWindow) [private]
  • WindowId [protected]
  • WindowInitialize(void) [virtual]
  • WindowName [protected]
  • WindowRemap(void) [virtual]
  • ~vtkObject() [protected, virtual]
  • ~vtkOpenGLRenderWindow() [protected]
  • ~vtkRenderWindow() [protected]
  • ~vtkWindow() [protected]
  • ~vtkXOpenGLRenderWindow() [protected]
Generated on Mon Mar 25 01:36:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXOpenGLTextMapper Member List

This is the complete list of members for vtkXOpenGLTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CurrentFont [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DetermineSize(vtkViewport *viewport, int size[2]) [protected]
  • EndTag [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp, Font) [static]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkXOpenGLTextMapper &) (defined in vtkXOpenGLTextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderGeometry(vtkViewport *viewport, vtkActor2D *actor)
  • RenderOpaqueGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • Size [protected]
  • SizeMTime [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • ViewportSize [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkXOpenGLTextMapper, vtkXTextMapper)
  • vtkXOpenGLTextMapper() [protected]
  • vtkXOpenGLTextMapper(const vtkXOpenGLTextMapper &) (defined in vtkXOpenGLTextMapper) [private]
  • vtkXTextMapper() [protected]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
  • ~vtkXOpenGLTextMapper() [protected]
  • ~vtkXTextMapper() [inline, protected]
Generated on Mon Mar 25 01:36:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXPolyDataMapper2D Member List

This is the complete list of members for vtkXPolyDataMapper2D, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • ArrayAccessMode [protected]
  • ArrayComponent [protected]
  • ArrayId [protected]
  • ArrayName [protected]
  • BreakOnError() [static]
  • BuildTime [protected]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ColorByArrayComponent(int arrayNum, int component)
  • ColorByArrayComponent(char *arrayName, int component)
  • ColorMode [protected]
  • Colors [protected]
  • Consumers [protected]
  • CreateDefaultLookupTable() [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • EndTag [protected]
  • GetAbortExecute() [virtual]
  • GetArrayAccessMode() [inline]
  • GetArrayComponent() [inline]
  • GetArrayId() [inline]
  • GetArrayName() [inline]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetColorMode() [virtual]
  • GetColorModeAsString()
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetGlobalWarningDisplay() [static]
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetLookupTable()
  • GetMTime() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalarMode() [virtual]
  • GetScalarRange() [virtual]
  • GetScalarRange(float data[2]) [virtual]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetScalarVisibility() [virtual]
  • GetTimeToDraw() [virtual]
  • GetTransformCoordinate() [virtual]
  • GetUseLookupTableScalarRange() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • LastWindow [protected]
  • LookupTable [protected]
  • MapScalars(float alpha)
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkXPolyDataMapper2D &) (defined in vtkXPolyDataMapper2D) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlay(vtkViewport *viewport, vtkActor2D *actor) [virtual]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • ScalarMode [protected]
  • ScalarRange [protected]
  • ScalarVisibility [protected]
  • ScalarVisibilityOff() [virtual]
  • ScalarVisibilityOn() [virtual]
  • SetAbortExecute(int) [virtual]
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetColorMode(int) [virtual]
  • SetColorModeToDefault() [inline]
  • SetColorModeToMapScalars() [inline]
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(vtkPolyData *) [virtual]
  • SetLookupTable(vtkScalarsToColors *lut)
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetScalarMode(int) [virtual]
  • SetScalarModeToDefault() [inline]
  • SetScalarModeToUseCellData() [inline]
  • SetScalarModeToUseCellFieldData() [inline]
  • SetScalarModeToUsePointData() [inline]
  • SetScalarModeToUsePointFieldData() [inline]
  • SetScalarRange(float, float) [virtual]
  • SetScalarRange(float[2])
  • SetScalarVisibility(int) [virtual]
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetTransformCoordinate(vtkCoordinate *) [virtual]
  • SetUseLookupTableScalarRange(int) [virtual]
  • ShallowCopy(vtkAbstractMapper *m)
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • TransformCoordinate [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • UseLookupTableScalarRange [protected]
  • UseLookupTableScalarRangeOff() [virtual]
  • UseLookupTableScalarRangeOn() [virtual]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkPolyDataMapper2D() [protected]
  • vtkProcessObject() [protected]
  • vtkTypeRevisionMacro(vtkXPolyDataMapper2D, vtkPolyDataMapper2D)
  • vtkXPolyDataMapper2D() [inline, protected]
  • vtkXPolyDataMapper2D(const vtkXPolyDataMapper2D &) (defined in vtkXPolyDataMapper2D) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkPolyDataMapper2D() [protected]
  • ~vtkProcessObject() [protected]
  • ~vtkXPolyDataMapper2D() [inline, protected]
Generated on Mon Mar 25 01:36:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXRenderWindowInteractor Member List

This is the complete list of members for vtkXRenderWindowInteractor, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AddTimeOut(XtAppContext app_context, unsigned long interval, XtTimerCallbackProc proc, XtPointer client_data) [protected]
  • App [protected]
  • BreakLoopFlag [protected]
  • BreakLoopFlagOff() [virtual]
  • BreakLoopFlagOn() [virtual]
  • BreakOnError() [static]
  • Callback(Widget w, XtPointer client_data, XEvent *event, Boolean *ctd) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ControlKey [protected]
  • CreateDefaultPicker() [virtual]
  • CreateTimer(int timertype) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DestroyTimer(void) [virtual]
  • Disable() [virtual]
  • DisplayId [protected]
  • Dolly [protected]
  • Enable() [virtual]
  • Enabled [protected]
  • EndPickCallback() [virtual]
  • EndPickTag [protected]
  • EventPosition [protected]
  • ExitCallback() [virtual]
  • ExitTag [protected]
  • FlyTo(vtkRenderer *ren, float x, float y, float z)
  • FlyTo(vtkRenderer *ren, float *x) [inline]
  • FlyToImage(vtkRenderer *ren, float x, float y)
  • FlyToImage(vtkRenderer *ren, float *x) [inline]
  • GetApp() [virtual]
  • GetBreakLoopFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetControlKey() [virtual]
  • GetDebug()
  • GetDesiredUpdateRate() [virtual]
  • GetDolly() [virtual]
  • GetEnabled() [virtual]
  • GetEventPosition() [virtual]
  • GetEventPosition(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [virtual]
  • GetInteractorStyle() [virtual]
  • GetKeyCode() [virtual]
  • GetKeySym() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetMousePosition(int *x, int *y) [virtual]
  • GetMTime() [virtual]
  • GetNumberOfFlyFrames() [virtual]
  • GetPicker() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRepeatCount() [virtual]
  • GetShiftKey() [virtual]
  • GetSize() [virtual]
  • GetSize(int &, int &) [virtual]
  • GetSize(int[2]) [virtual]
  • GetStillUpdateRate() [virtual]
  • GetTopLevelShell() [inline]
  • GetWidget() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline]
  • Initialize() [virtual]
  • Initialize(XtAppContext app) [virtual]
  • Initialized [protected]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyCode [protected]
  • KeySym [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfFlyFrames [protected]
  • operator=(const vtkXRenderWindowInteractor &) (defined in vtkXRenderWindowInteractor) [private]
  • OwnTop [protected]
  • Picker [protected]
  • PositionBeforeStereo [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReInitialize() [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderWindow [protected]
  • RepeatCount [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBreakLoopFlag(int) [virtual]
  • SetControlKey(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float) [virtual]
  • SetDolly(float) [virtual]
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0) [inline]
  • SetEventPosition(int, int) [virtual]
  • SetEventPosition(int[2])
  • SetExitMethod(void(*f)(void *), void *arg)
  • SetExitMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractorStyle(vtkInteractorStyle *) [virtual]
  • SetKeyCode(int) [virtual]
  • SetKeySym(const char *) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetNumberOfFlyFrames(int) [virtual]
  • SetPicker(vtkAbstractPicker *) [virtual]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *aren)
  • SetRepeatCount(int) [virtual]
  • SetShiftKey(int) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetStillUpdateRate(float) [virtual]
  • SetTopLevelShell(Widget) [virtual]
  • SetUserMethod(void(*f)(void *), void *arg)
  • SetUserMethodArgDelete(void(*f)(void *))
  • SetWidget(Widget) [virtual]
  • ShiftKey [protected]
  • ShowCursor() [inline]
  • Size [protected]
  • Start() [virtual]
  • StartPickCallback() [virtual]
  • StartPickTag [protected]
  • StillUpdateRate [protected]
  • Style [protected]
  • SubjectHelper [protected]
  • TerminateApp(void) [inline, virtual]
  • Timer(XtPointer client_data, XtIntervalId *id) [protected]
  • Top [protected]
  • TopLevelShell [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSize(int x, int y) [virtual]
  • UserCallback() [virtual]
  • UserTag [protected]
  • vtkObject() [protected]
  • vtkRenderWindowInteractor() [protected]
  • vtkTypeRevisionMacro(vtkXRenderWindowInteractor, vtkRenderWindowInteractor)
  • vtkXRenderWindowInteractor() [protected]
  • vtkXRenderWindowInteractor(const vtkXRenderWindowInteractor &) (defined in vtkXRenderWindowInteractor) [private]
  • vtkXRenderWindowInteractorCallback(Widget, XtPointer, XEvent *, Boolean *) [friend]
  • vtkXRenderWindowInteractorTimer(XtPointer, XtIntervalId *) [friend]
  • WindowId [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindowInteractor() [protected]
  • ~vtkXRenderWindowInteractor() [protected]
Generated on Mon Mar 25 01:36:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXRenderWindowTclInteractor Member List

This is the complete list of members for vtkXRenderWindowTclInteractor, including all inherited members.
  • ActorMode [protected]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • App [protected]
  • BreakLoopFlag [protected]
  • BreakOnError() [static]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ControlKey [protected]
  • CreateDefaultPicker() [virtual]
  • CreateTimer(int timertype) [virtual]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DesiredUpdateRate [protected]
  • DestroyTimer(void) [virtual]
  • Disable() [virtual]
  • DisplayId [protected]
  • Dolly [protected]
  • Enable() [virtual]
  • Enabled [protected]
  • EndPickCallback() [virtual]
  • EndPickTag [protected]
  • EventPosition [protected]
  • ExitCallback() [virtual]
  • ExitTag [protected]
  • FlyTo(vtkRenderer *ren, float x, float y, float z)
  • FlyTo(vtkRenderer *ren, float *x) [inline]
  • FlyToImage(vtkRenderer *ren, float x, float y)
  • FlyToImage(vtkRenderer *ren, float *x) [inline]
  • GetApp() [virtual]
  • GetBreakLoopFlag() [virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetControlKey() [virtual]
  • GetDebug()
  • GetDesiredUpdateRate() [virtual]
  • GetDolly() [virtual]
  • GetEnabled() [virtual]
  • GetEventPosition() [virtual]
  • GetEventPosition(int data[2]) [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetInitialized() [virtual]
  • GetInteractorStyle() [virtual]
  • GetKeyCode() [virtual]
  • GetKeySym() [virtual]
  • GetLightFollowCamera() [virtual]
  • GetMousePosition(int *x, int *y) [inline, virtual]
  • GetMTime() [virtual]
  • GetNumberOfFlyFrames() [virtual]
  • GetPicker() [virtual]
  • GetReferenceCount() [inline]
  • GetRenderWindow() [virtual]
  • GetRepeatCount() [virtual]
  • GetShiftKey() [virtual]
  • GetSize() [virtual]
  • GetSize(int &, int &) [virtual]
  • GetSize(int[2]) [virtual]
  • GetStillUpdateRate() [virtual]
  • GetTopLevelShell() [inline]
  • GetWidget() [inline]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • HideCursor() [inline]
  • Initialize() [virtual]
  • Initialize(XtAppContext app) [virtual]
  • Initialized [protected]
  • InteractorStyle [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsTypeOf(const char *name) [static]
  • KeyCode [protected]
  • KeySym [protected]
  • LightFollowCamera [protected]
  • LightFollowCameraOff() [virtual]
  • LightFollowCameraOn() [virtual]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfFlyFrames [protected]
  • oldTop [protected]
  • operator=(const vtkXRenderWindowTclInteractor &) (defined in vtkXRenderWindowTclInteractor) [private]
  • Picker [protected]
  • PositionBeforeStereo [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReInitialize() [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • Render()
  • RenderWindow [protected]
  • RepeatCount [protected]
  • SafeDownCast(vtkObject *o) [static]
  • SetBreakLoopFlag(int) [virtual]
  • SetControlKey(int) [virtual]
  • SetDebug(unsigned char debugFlag)
  • SetDesiredUpdateRate(float) [virtual]
  • SetDolly(float) [virtual]
  • SetEndPickMethod(void(*f)(void *), void *arg)
  • SetEndPickMethodArgDelete(void(*f)(void *))
  • SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0, const char *keysym=0) [inline]
  • SetEventPosition(int, int) [virtual]
  • SetEventPosition(int[2])
  • SetExitMethod(void(*f)(void *), void *arg)
  • SetExitMethodArgDelete(void(*f)(void *))
  • SetGlobalWarningDisplay(int val) [static]
  • SetInteractorStyle(vtkInteractorStyle *) [virtual]
  • SetKeyCode(int) [virtual]
  • SetKeySym(const char *) [virtual]
  • SetLightFollowCamera(int) [virtual]
  • SetNumberOfFlyFrames(int) [virtual]
  • SetPicker(vtkAbstractPicker *) [virtual]
  • SetReferenceCount(int)
  • SetRenderWindow(vtkRenderWindow *aren)
  • SetRepeatCount(int) [virtual]
  • SetShiftKey(int) [virtual]
  • SetSize(int, int) [virtual]
  • SetSize(int[2])
  • SetStartPickMethod(void(*f)(void *), void *arg)
  • SetStartPickMethodArgDelete(void(*f)(void *))
  • SetStillUpdateRate(float) [virtual]
  • SetTopLevelShell(Widget) [virtual]
  • SetUserMethod(void(*f)(void *), void *arg)
  • SetUserMethodArgDelete(void(*f)(void *))
  • SetWidget(Widget) [virtual]
  • ShiftKey [protected]
  • ShowCursor() [inline]
  • Size [protected]
  • Start() [virtual]
  • StartPickCallback() [virtual]
  • StartPickTag [protected]
  • StillUpdateRate [protected]
  • Style [protected]
  • SubjectHelper [protected]
  • TerminateApp(void) [virtual]
  • top [protected]
  • TopLevelShell [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateSize(int, int) [virtual]
  • UserCallback() [virtual]
  • UserTag [protected]
  • vtkObject() [protected]
  • vtkRenderWindowInteractor() [protected]
  • vtkTypeRevisionMacro(vtkXRenderWindowTclInteractor, vtkRenderWindowInteractor)
  • vtkXRenderWindowTclInteractor() [protected]
  • vtkXRenderWindowTclInteractor(const vtkXRenderWindowTclInteractor &) (defined in vtkXRenderWindowTclInteractor) [private]
  • vtkXRenderWindowTclInteractorCallback(Widget, XtPointer, XEvent *, Boolean *) [friend]
  • vtkXRenderWindowTclInteractorTimer(XtPointer, XtIntervalId *) [friend]
  • WindowId [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkRenderWindowInteractor() [protected]
  • ~vtkXRenderWindowTclInteractor() [protected]
Generated on Mon Mar 25 01:36:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXTextMapper Member List

This is the complete list of members for vtkXTextMapper, including all inherited members.
  • AbortExecute
  • AbortExecuteOff() [virtual]
  • AbortExecuteOn() [virtual]
  • AddClippingPlane(vtkPlane *plane)
  • AddConsumer(vtkObject *c)
  • AddInput(vtkDataObject *input) [protected, virtual]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • BreakOnError() [static]
  • ClippingPlanes [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • Consumers [protected]
  • CurrentFont [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • DetermineSize(vtkViewport *viewport, int size[2]) [protected]
  • EndTag [protected]
  • FontFamily [protected]
  • FontMTime [protected]
  • FontSize [protected]
  • GetAbortExecute() [virtual]
  • GetBold() [virtual]
  • GetClassName() [inline, virtual]
  • GetClippingPlanes() [virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDebug()
  • GetFontFamily() [virtual]
  • GetFontSize() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetHeight(vtkViewport *)
  • GetInput() [virtual]
  • GetInputs() [inline]
  • GetItalic() [virtual]
  • GetJustification() [virtual]
  • GetLineOffset() [virtual]
  • GetLineSpacing() [virtual]
  • GetMTime() [virtual]
  • GetMultiLineSize(vtkViewport *viewport, int size[2]) [protected]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfInputs() [virtual]
  • GetNumberOfLines() [virtual]
  • GetNumberOfLines(const char *input)
  • GetProgress() [virtual]
  • GetProgressText() [virtual]
  • GetReferenceCount() [inline]
  • GetScalars(vtkDataSet *input, int scalarMode, int arrayAccessMode, int arrayId, const char *arrayName, int &component) [static]
  • GetShadow() [virtual]
  • GetSize(vtkViewport *viewport, int size[2]) [virtual]
  • GetTimeToDraw() [virtual]
  • GetVerticalJustification() [virtual]
  • GetWidth(vtkViewport *)
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • Input [protected]
  • Inputs [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • Justification [protected]
  • LastWindow [protected]
  • LineOffset [protected]
  • LineSize [protected]
  • LineSpacing [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NextLine(const char *input, int lineNum) [protected]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfLines [protected]
  • NumberOfLinesAllocated [protected]
  • NumberOfRequiredInputs [protected]
  • operator=(const vtkXTextMapper &) (defined in vtkXTextMapper) [private]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Progress [protected]
  • ProgressTag [protected]
  • ProgressText [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [inline, virtual]
  • RemoveAllClippingPlanes()
  • RemoveAllInputs()
  • RemoveClippingPlane(vtkPlane *plane)
  • RemoveConsumer(vtkObject *c)
  • RemoveInput(vtkDataObject *input) [protected, virtual]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderOverlay(vtkViewport *, vtkActor2D *) [inline, virtual]
  • RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor) [protected]
  • RenderTranslucentGeometry(vtkViewport *, vtkActor2D *) [inline, virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SetAbortExecute(int) [virtual]
  • SetBold(int val)
  • SetClippingPlanes(vtkPlaneCollection *) [virtual]
  • SetClippingPlanes(vtkPlanes *planes)
  • SetDebug(unsigned char debugFlag)
  • SetEndMethod(void(*f)(void *), void *arg)
  • SetEndMethodArgDelete(void(*f)(void *))
  • SetFontFamily(int val)
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetFontSize(int size) [virtual]
  • SetGlobalWarningDisplay(int val) [static]
  • SetInput(const char *inputString)
  • SetItalic(int val)
  • SetJustification(int) [virtual]
  • SetJustificationToCentered() [inline]
  • SetJustificationToLeft() [inline]
  • SetJustificationToRight() [inline]
  • SetLineOffset(float) [virtual]
  • SetLineSpacing(float) [virtual]
  • SetNthInput(int num, vtkDataObject *input) [protected, virtual]
  • SetNumberOfInputs(int num) [protected]
  • SetProgress(float) [virtual]
  • SetProgressMethod(void(*f)(void *), void *arg)
  • SetProgressMethodArgDelete(void(*f)(void *))
  • SetProgressText(const char *) [virtual]
  • SetReferenceCount(int)
  • SetShadow(int val)
  • SetStartMethod(void(*f)(void *), void *arg)
  • SetStartMethodArgDelete(void(*f)(void *))
  • SetVerticalJustification(int) [virtual]
  • SetVerticalJustificationToBottom() [inline]
  • SetVerticalJustificationToCentered() [inline]
  • SetVerticalJustificationToTop() [inline]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkTextMapper *tm)
  • vtkMapper2D::ShallowCopy(vtkAbstractMapper *m)
  • Size [protected]
  • SizeMTime [protected]
  • SortedInputs [protected]
  • SortedInputs2 [protected]
  • SortInputsByLocality() [protected]
  • SortMerge(vtkDataObject **a1, int l1, vtkDataObject **a2, int l2, vtkDataObject **results) [protected]
  • SqueezeInputArray()
  • StartTag [protected]
  • SubjectHelper [protected]
  • TextLines [protected]
  • Timer [protected]
  • TimeToDraw [protected]
  • UnRegister(vtkObject *o) [virtual]
  • UpdateProgress(float amount)
  • VerticalJustification [protected]
  • ViewportSize [protected]
  • vtkAbstractMapper() [protected]
  • vtkMapper2D() [inline, protected]
  • vtkObject() [protected]
  • vtkProcessObject() [protected]
  • vtkTextMapper() [protected]
  • vtkTypeRevisionMacro(vtkXTextMapper, vtkTextMapper)
  • vtkXTextMapper() [protected]
  • vtkXTextMapper(const vtkXTextMapper &) (defined in vtkXTextMapper) [private]
  • ~vtkAbstractMapper() [protected]
  • ~vtkMapper2D() [inline, protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProcessObject() [protected]
  • ~vtkTextMapper() [protected]
  • ~vtkXTextMapper() [inline, protected]
Generated on Mon Mar 25 01:36:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkXYPlotActor Member List

This is the complete list of members for vtkXYPlotActor, including all inherited members.
  • AddConsumer(vtkObject *c)
  • AddDataObjectInput(vtkDataObject *in)
  • AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp)) [inline, virtual]
  • AddInput(vtkDataSet *in, const char *arrayName, int component)
  • AddInput(vtkDataSet *in) [inline]
  • AddObserver(unsigned long event, vtkCommand *, float priority=0.0)
  • AddObserver(const char *event, vtkCommand *, float priority=0.0)
  • AllocatedRenderTime [protected]
  • Bold [protected]
  • BoldOff() [virtual]
  • BoldOn() [virtual]
  • Border [protected]
  • BreakOnError() [static]
  • BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path) [virtual]
  • BuildTime [protected]
  • CachedSize [protected]
  • ClipPlanes [protected]
  • ClipPlotData(int *pos, int *pos2, vtkPolyData *pd) [protected]
  • CollectRevisions(ostream &os) [protected, virtual]
  • ComputeDORange(float xrange[2], float yrange[2], float *lengths) [protected]
  • ComputeGlyphScale(int i, int *pos, int *pos2) [protected]
  • ComputeXRange(float range[2], float *lengths) [protected]
  • ComputeYRange(float range[2]) [protected]
  • Consumers [protected]
  • CreatePlotData(int *pos, int *pos2, float xRange[2], float yRange[2], float *norms, int numDS, int numDO) [protected, virtual]
  • DataObjectInputList [protected]
  • DataObjectPlotMode [protected]
  • Debug [protected]
  • DebugOff() [virtual]
  • DebugOn() [virtual]
  • Delete() [virtual]
  • Dragable [protected]
  • DragableOff() [virtual]
  • DragableOn() [virtual]
  • EstimatedRenderTime [protected]
  • ExchangeAxes [protected]
  • ExchangeAxesOff() [virtual]
  • ExchangeAxesOn() [virtual]
  • FontFamily [protected]
  • GenerateClipPlanes(int *pos, int *pos2) [protected]
  • GetActors(vtkPropCollection *) [inline, virtual]
  • GetActors2D(vtkPropCollection *pc) [virtual]
  • GetAllocatedRenderTime() [virtual]
  • GetBold() [virtual]
  • GetBorder() [virtual]
  • GetBounds() [inline, virtual]
  • GetClassName() [inline, virtual]
  • GetCommand(unsigned long tag)
  • GetConsumer(int i)
  • GetDataObjectInputList() [inline]
  • GetDataObjectPlotMode() [virtual]
  • GetDataObjectPlotModeAsString()
  • GetDataObjectXComponent(int i)
  • GetDataObjectYComponent(int i)
  • GetDebug()
  • GetDragable() [virtual]
  • GetEstimatedRenderTime(vtkViewport *) [inline, virtual]
  • GetEstimatedRenderTime() [inline, virtual]
  • GetExchangeAxes() [virtual]
  • GetFontFamily() [virtual]
  • GetGlobalWarningDisplay() [static]
  • GetGlyphSize() [virtual]
  • GetGlyphSource() [inline]
  • GetHeight()
  • GetInputList() [inline]
  • GetItalic() [virtual]
  • GetLabelFormat() [virtual]
  • GetLayerNumber() [virtual]
  • GetLegend() [virtual]
  • GetLegendBoxActor() [inline]
  • GetLegendPosition() [virtual]
  • GetLegendPosition(float &, float &) [virtual]
  • GetLegendPosition(float[2]) [virtual]
  • GetLegendPosition2() [virtual]
  • GetLegendPosition2(float &, float &) [virtual]
  • GetLegendPosition2(float[2]) [virtual]
  • GetLogx() [virtual]
  • GetMapper() [virtual]
  • GetMatrix() [inline, virtual]
  • GetMTime() [virtual]
  • GetNextPath() [virtual]
  • GetNumberOfConsumers() [virtual]
  • GetNumberOfPaths() [inline, virtual]
  • GetNumberOfXLabels() [virtual]
  • GetNumberOfYLabels() [virtual]
  • GetPickable() [virtual]
  • GetPlotColor(int i)
  • GetPlotCoordinate() [virtual]
  • GetPlotCoordinate(float &, float &) [virtual]
  • GetPlotCoordinate(float[2]) [virtual]
  • GetPlotCurveLines() [virtual]
  • GetPlotCurvePoints() [virtual]
  • GetPlotLabel(int i)
  • GetPlotLines(int i)
  • GetPlotLines() [virtual]
  • GetPlotPoints(int i)
  • GetPlotPoints() [virtual]
  • GetPlotSymbol(int i)
  • GetPointComponent(int i)
  • GetPosition() [virtual]
  • GetPosition2() [virtual]
  • GetPosition2Coordinate() [virtual]
  • GetPositionCoordinate() [virtual]
  • GetProperty()
  • GetRedrawMTime() [inline, virtual]
  • GetReferenceCount() [inline]
  • GetRenderTimeMultiplier() [virtual]
  • GetReverseXAxis() [virtual]
  • GetReverseYAxis() [virtual]
  • GetShadow() [virtual]
  • GetTitle() [virtual]
  • GetViewportCoordinate() [virtual]
  • GetViewportCoordinate(float &, float &) [virtual]
  • GetViewportCoordinate(float[2]) [virtual]
  • GetVisibility() [virtual]
  • GetVolumes(vtkPropCollection *) [inline, virtual]
  • GetWidth()
  • GetXRange() [virtual]
  • GetXRange(float data[2]) [virtual]
  • GetXTitle() [virtual]
  • GetXValues() [virtual]
  • GetXValuesAsString()
  • GetYRange() [virtual]
  • GetYRange(float data[2]) [virtual]
  • GetYTitle() [virtual]
  • GlobalWarningDisplayOff() [inline, static]
  • GlobalWarningDisplayOn() [inline, static]
  • GlyphSize [protected]
  • GlyphSource [protected]
  • HasObserver(unsigned long event)
  • HasObserver(const char *event)
  • InitializeEntries() [protected]
  • InitPathTraversal() [virtual]
  • InputList [protected]
  • InvokeEvent(unsigned long event, void *callData)
  • InvokeEvent(const char *event, void *callData)
  • IsA(const char *name) [virtual]
  • IsConsumer(vtkObject *c)
  • IsInPlot(vtkViewport *viewport, float u, float v)
  • IsTypeOf(const char *name) [static]
  • Italic [protected]
  • ItalicOff() [virtual]
  • ItalicOn() [virtual]
  • LabelFormat [protected]
  • LayerNumber [protected]
  • Legend [protected]
  • LegendActor [protected]
  • LegendOff() [virtual]
  • LegendOn() [virtual]
  • LegendPosition [protected]
  • LegendPosition2 [protected]
  • LinesOn [protected]
  • Logx [protected]
  • LogxOff() [virtual]
  • LogxOn() [virtual]
  • Mapper [protected]
  • Modified() [virtual]
  • MTime [protected]
  • New() [static]
  • NumberOfConsumers [protected]
  • NumberOfInputs [protected]
  • NumberOfXLabels [protected]
  • NumberOfYLabels [protected]
  • operator=(const vtkXYPlotActor &) (defined in vtkXYPlotActor) [private]
  • Paths [protected]
  • Pick() [virtual]
  • Pickable [protected]
  • PickableOff() [virtual]
  • PickableOn() [virtual]
  • PickTag [protected]
  • PlaceAxes(vtkViewport *viewport, int *size, int pos[2], int pos2[2]) [protected]
  • PlotActor [protected]
  • PlotAppend [protected]
  • PlotCoordinate [protected]
  • PlotCurveLines [protected]
  • PlotCurveLinesOff() [virtual]
  • PlotCurveLinesOn() [virtual]
  • PlotCurvePoints [protected]
  • PlotCurvePointsOff() [virtual]
  • PlotCurvePointsOn() [virtual]
  • PlotData [protected]
  • PlotGlyph [protected]
  • PlotLines [protected]
  • PlotLinesOff() [virtual]
  • PlotLinesOn() [virtual]
  • PlotMapper [protected]
  • PlotPoints [protected]
  • PlotPointsOff() [virtual]
  • PlotPointsOn() [virtual]
  • PlotToViewportCoordinate(vtkViewport *viewport, float &u, float &v)
  • PlotToViewportCoordinate(vtkViewport *viewport)
  • PointsOn [protected]
  • PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) [inline, virtual]
  • Position2Coordinate [protected]
  • PositionCoordinate [protected]
  • Print(ostream &os)
  • PrintHeader(ostream &os, vtkIndent indent) [virtual]
  • PrintSelf(ostream &os, vtkIndent indent) [virtual]
  • PrintTrailer(ostream &os, vtkIndent indent) [virtual]
  • Property [protected]
  • ReferenceCount [protected]
  • Register(vtkObject *o)
  • ReleaseGraphicsResources(vtkWindow *) [virtual]
  • RemoveAllInputs()
  • RemoveConsumer(vtkObject *c)
  • RemoveDataObjectInput(vtkDataObject *in)
  • RemoveInput(vtkDataSet *in, const char *arrayName, int component)
  • RemoveInput(vtkDataSet *in) [inline]
  • RemoveObserver(vtkCommand *)
  • RemoveObserver(unsigned long tag)
  • RenderOpaqueGeometry(vtkViewport *) [virtual]
  • RenderOverlay(vtkViewport *) [virtual]
  • RenderTimeMultiplier [protected]
  • RenderTranslucentGeometry(vtkViewport *) [inline, virtual]
  • RestoreEstimatedRenderTime() [inline, virtual]
  • ReverseXAxis [protected]
  • ReverseXAxisOff() [virtual]
  • ReverseXAxisOn() [virtual]
  • ReverseYAxis [protected]
  • ReverseYAxisOff() [virtual]
  • ReverseYAxisOn() [virtual]
  • SafeDownCast(vtkObject *o) [static]
  • SavedEstimatedRenderTime [protected]
  • SelectedInputScalars [protected]
  • SelectedInputScalarsComponent [protected]
  • SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v)) [inline, virtual]
  • SetBold(int) [virtual]
  • SetBorder(int) [virtual]
  • SetDataObjectPlotMode(int) [virtual]
  • SetDataObjectPlotModeToColumns() [inline]
  • SetDataObjectPlotModeToRows() [inline]
  • SetDataObjectXComponent(int i, int comp)
  • SetDataObjectYComponent(int i, int comp)
  • SetDebug(unsigned char debugFlag)
  • SetDisplayPosition(int, int)
  • SetDragable(int) [virtual]
  • SetEstimatedRenderTime(float t) [inline, virtual]
  • SetExchangeAxes(int) [virtual]
  • SetFontFamily(int) [virtual]
  • SetFontFamilyToArial() [inline]
  • SetFontFamilyToCourier() [inline]
  • SetFontFamilyToTimes() [inline]
  • SetGlobalWarningDisplay(int val) [static]
  • SetGlyphSize(float) [virtual]
  • SetHeight(float h)
  • SetItalic(int) [virtual]
  • SetLabelFormat(const char *) [virtual]
  • SetLayerNumber(int) [virtual]
  • SetLegend(int) [virtual]
  • SetLegendPosition(float, float) [virtual]
  • SetLegendPosition(float[2])
  • SetLegendPosition2(float, float) [virtual]
  • SetLegendPosition2(float[2])
  • SetLogx(int) [virtual]
  • SetMapper(vtkMapper2D *mapper) [virtual]
  • SetNumberOfLabels(int num) [inline]
  • SetNumberOfXLabels(int) [virtual]
  • SetNumberOfYLabels(int) [virtual]
  • SetPickable(int) [virtual]
  • SetPickMethod(void(*f)(void *), void *arg)
  • SetPickMethodArgDelete(void(*f)(void *))
  • SetPlotColor(int i, float r, float g, float b)
  • SetPlotColor(int i, const float color[3]) [inline]
  • SetPlotCoordinate(float, float) [virtual]
  • SetPlotCoordinate(float[2])
  • SetPlotCurveLines(int) [virtual]
  • SetPlotCurvePoints(int) [virtual]
  • SetPlotLabel(int i, const char *label)
  • SetPlotLines(int i, int)
  • SetPlotLines(int) [virtual]
  • SetPlotPoints(int i, int)
  • SetPlotPoints(int) [virtual]
  • SetPlotRange(float xmin, float ymin, float xmax, float ymax) [inline]
  • SetPlotSymbol(int i, vtkPolyData *input)
  • SetPointComponent(int i, int comp)
  • SetPosition(float x[2]) [virtual]
  • SetPosition(float x, float y) [virtual]
  • SetPosition2(float x[2]) [virtual]
  • SetPosition2(float x, float y) [virtual]
  • SetProperty(vtkProperty2D *) [virtual]
  • SetReferenceCount(int)
  • SetRenderTimeMultiplier(float t) [inline]
  • SetReverseXAxis(int) [virtual]
  • SetReverseYAxis(int) [virtual]
  • SetShadow(int) [virtual]
  • SetTitle(const char *) [virtual]
  • SetViewportCoordinate(float, float) [virtual]
  • SetViewportCoordinate(float[2])
  • SetVisibility(int) [virtual]
  • SetWidth(float w)
  • SetXRange(float, float) [virtual]
  • SetXRange(float[2])
  • SetXTitle(const char *) [virtual]
  • SetXValues(int) [virtual]
  • SetXValuesToArcLength() [inline]
  • SetXValuesToIndex() [inline]
  • SetXValuesToNormalizedArcLength() [inline]
  • SetXValuesToValue() [inline]
  • SetYRange(float, float) [virtual]
  • SetYRange(float[2])
  • SetYTitle(const char *) [virtual]
  • Shadow [protected]
  • ShadowOff() [virtual]
  • ShadowOn() [virtual]
  • ShallowCopy(vtkProp *prop) [virtual]
  • SubjectHelper [protected]
  • Title [protected]
  • TitleActor [protected]
  • TitleMapper [protected]
  • TransformPoint(int pos[2], int pos2[2], float x[3], float xNew[3]) [protected]
  • UnRegister(vtkObject *o) [virtual]
  • ViewportCoordinate [protected]
  • ViewportToPlotCoordinate(vtkViewport *viewport, float &u, float &v)
  • ViewportToPlotCoordinate(vtkViewport *viewport)
  • Visibility [protected]
  • VisibilityOff() [virtual]
  • VisibilityOn() [virtual]
  • vtkActor2D() [protected]
  • vtkObject() [protected]
  • vtkProp() [protected]
  • vtkTypeRevisionMacro(vtkXYPlotActor, vtkActor2D)
  • vtkXYPlotActor() [protected]
  • vtkXYPlotActor(const vtkXYPlotActor &) (defined in vtkXYPlotActor) [private]
  • XAxis [protected]
  • XComponent [protected]
  • XComputedRange [protected]
  • XRange [protected]
  • XTitle [protected]
  • XValues [protected]
  • YAxis [protected]
  • YComponent [protected]
  • YComputedRange [protected]
  • YRange [protected]
  • YTitle [protected]
  • ~vtkActor2D() [protected]
  • ~vtkObject() [protected, virtual]
  • ~vtkProp() [protected]
  • ~vtkXYPlotActor() [protected]
Generated on Mon Mar 25 01:37:16 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 200 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class for which not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
Generated on Mon Mar 25 01:37:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzGLView Member List

This is the complete list of members for vtkQuartzGLView, including all inherited members.
  • depthSize
  • myVTKRenderWindow
  • myVTKRenderWindowInteractor
Generated on Mon Mar 25 01:29:09 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkQuartzWindow Member List

This is the complete list of members for vtkQuartzWindow, including all inherited members.
  • MyNSTimer
  • myvtkQuartzGLView
  • myVTKRenderWindow
  • myVTKRenderWindowInteractor
Generated on Mon Mar 25 01:29:30 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkLink_s Member List

This is the complete list of members for _vtkLink_s, including all inherited members.
  • cells
  • ncells
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkLocalTri Member List

This is the complete list of members for _vtkLocalTri, including all inherited members.
  • area
  • id
  • n
  • verts
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkLocalVertex Member List

This is the complete list of members for _vtkLocalVertex, including all inherited members.
  • deRefs
  • FAngle
  • id
  • newRefs
  • x
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkPriorityItem Member List

This is the complete list of members for _vtkPriorityItem, including all inherited members.
  • id
  • priority
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkProLocalTri Member List

This is the complete list of members for _vtkProLocalTri, including all inherited members.
  • area
  • id
  • n
  • verts
Generated on Mon Mar 25 01:15:20 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkProLocalVertex Member List

This is the complete list of members for _vtkProLocalVertex, including all inherited members.
  • FAngle
  • id
  • x
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkStreamPoint Member List

This is the complete list of members for _vtkStreamPoint, including all inherited members.
  • cellId
  • d
  • omega
  • p
  • s
  • speed
  • subId
  • t
  • theta
  • v
  • x
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

_vtkTclVoidFuncArg Member List

This is the complete list of members for _vtkTclVoidFuncArg, including all inherited members.
  • command
  • interp
Generated on Mon Mar 25 01:15:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Camera Member List

This is the complete list of members for Camera, including all inherited members.
  • aCamera
  • bank
  • lens
  • pos
  • target
Generated on Mon Mar 25 01:15:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Chunk Member List

This is the complete list of members for Chunk, including all inherited members.
  • end
  • length
  • start
  • tag
Generated on Mon Mar 25 01:16:18 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Colour Member List

This is the complete list of members for Colour, including all inherited members.
  • blue
  • green
  • red
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Colour_24 Member List

This is the complete list of members for Colour_24, including all inherited members.
  • blue
  • green
  • red
Generated on Mon Mar 25 01:16:25 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Face Member List

This is the complete list of members for Face, including all inherited members.
  • a
  • b
  • c
Generated on Mon Mar 25 01:17:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

istream Member List

This is the complete list of members for istream, including all inherited members.
  • get(char &c) [inline]
  • operator>>(char *str)
  • operator>>(int &x)
  • operator>>(char &ch)
  • operator>>(float &fl)
  • operator>>(double &dbl)
  • putback(char &c) [inline]
Generated on Mon Mar 25 01:22:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Material Member List

This is the complete list of members for Material, including all inherited members.
  • external
Generated on Mon Mar 25 01:23:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

MatProp Member List

This is the complete list of members for MatProp, including all inherited members.
  • ambient
  • aProperty
  • bump_map
  • bump_strength
  • diffuse
  • reflection
  • self_illum
  • shininess
  • specular
  • tex_map
  • tex_strength
  • transparency
Generated on Mon Mar 25 01:23:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Mesh Member List

This is the complete list of members for Mesh, including all inherited members.
  • aCellArray
  • aMapper
  • anActor
  • aNormals
  • aPoints
  • aPolyData
  • aStripper
  • face
  • faces
  • hidden
  • mtl
  • shadow
  • vertex
  • vertices
Generated on Mon Mar 25 01:25:10 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ofstream Member List

This is the complete list of members for ofstream, including all inherited members.
  • operator<<(const char *str)
  • operator<<(void *str)
  • operator<<(short x)
  • operator<<(unsigned short x)
  • operator<<(int x)
  • operator<<(long l)
  • operator<<(unsigned long l)
  • operator<<(char ch)
  • operator<<(float fl)
  • operator<<(double dbl)
  • write(void *data, size_t size)
Generated on Mon Mar 25 01:25:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

OmniLight Member List

This is the complete list of members for OmniLight, including all inherited members.
  • aLight
  • col
  • pos
Generated on Mon Mar 25 01:25:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ostream Member List

This is the complete list of members for ostream, including all inherited members.
  • flush() [inline]
  • operator<<(const char *str)
  • operator<<(void *str)
  • operator<<(short x)
  • operator<<(unsigned short x)
  • operator<<(int x)
  • operator<<(unsigned int x)
  • operator<<(long l)
  • operator<<(unsigned long l)
  • operator<<(char ch)
  • operator<<(float fl)
  • operator<<(double dbl)
  • write(void *data, size_t size)
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ostrhelp Member List

This is the complete list of members for ostrhelp, including all inherited members.
  • freeze(int i)
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ostrstream Member List

This is the complete list of members for ostrstream, including all inherited members.
  • operator<<(char *str)
  • operator<<(void *str)
  • operator<<(int x)
  • operator<<(long l)
  • operator<<(char ch)
  • operator<<(float fl)
  • operator<<(double dbl)
  • rdbuf()
  • str()
Generated on Mon Mar 25 01:26:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

OtherData Member List

This is the complete list of members for OtherData, including all inherited members.
  • other_props
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

OtherElem Member List

This is the complete list of members for OtherElem, including all inherited members.
  • elem_count
  • elem_name
  • other_data
  • other_props
Generated on Mon Mar 25 01:26:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PlyElement Member List

This is the complete list of members for PlyElement, including all inherited members.
  • name
  • nprops
  • num
  • other_offset
  • other_size
  • props
  • size
  • store_prop
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PlyFile Member List

This is the complete list of members for PlyFile, including all inherited members.
  • comments
  • elems
  • file_type
  • fp
  • nelems
  • num_comments
  • num_obj_info
  • obj_info
  • other_elems
  • version
  • which_elem
Generated on Mon Mar 25 01:27:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PlyOtherElems Member List

This is the complete list of members for PlyOtherElems, including all inherited members.
  • num_elems
  • other_list
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PlyOtherProp Member List

This is the complete list of members for PlyOtherProp, including all inherited members.
  • name
  • nprops
  • props
  • size
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PlyProperty Member List

This is the complete list of members for PlyProperty, including all inherited members.
  • count_external
  • count_internal
  • count_offset
  • external_type
  • internal_type
  • is_list
  • name
  • offset
Generated on Mon Mar 25 01:27:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PyVTKClass Member List

This is the complete list of members for PyVTKClass, including all inherited members.
  • vtk_bases
  • vtk_delattr
  • vtk_dict
  • vtk_doc
  • vtk_getattr
  • vtk_methods
  • vtk_module
  • vtk_name
  • vtk_new
  • vtk_setattr
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PyVTKObject Member List

This is the complete list of members for PyVTKObject, including all inherited members.
  • vtk_class
  • vtk_dict
  • vtk_ptr
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

PyVTKSpecialObject Member List

This is the complete list of members for PyVTKSpecialObject, including all inherited members.
  • vtk_doc
  • vtk_methods
  • vtk_name
  • vtk_ptr
Generated on Mon Mar 25 01:28:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

SpotLight Member List

This is the complete list of members for SpotLight, including all inherited members.
  • aLight
  • col
  • falloff
  • hotspot
  • pos
  • shadow_flag
  • target
Generated on Mon Mar 25 01:31:22 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

Summary Member List

This is the complete list of members for Summary, including all inherited members.
  • center
  • lengths
Generated on Mon Mar 25 01:31:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

ThreadInfoStruct Member List

This is the complete list of members for ThreadInfoStruct, including all inherited members.
  • ActiveFlag
  • ActiveFlagLock
  • NumberOfThreads
  • ThreadID
  • UserData
Generated on Mon Mar 25 01:32:13 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTK_ERROR_QUADRIC Member List

This is the complete list of members for VTK_ERROR_QUADRIC, including all inherited members.
  • Quadric
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTK_LINE_CASES Member List

This is the complete list of members for VTK_LINE_CASES, including all inherited members.
  • edges
  • GetCases() [static]
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTK_POINT_QUADRIC Member List

This is the complete list of members for VTK_POINT_QUADRIC, including all inherited members.
  • Dimension
  • Quadric
  • VertexId
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTK_TRIANGLE_CASES Member List

This is the complete list of members for VTK_TRIANGLE_CASES, including all inherited members.
  • edges
  • GetCases() [static]
Generated on Mon Mar 25 01:35:03 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkFieldData::CopyFieldFlag Member List

This is the complete list of members for vtkFieldData::CopyFieldFlag, including all inherited members.
  • ArrayName
  • IsCopied
Generated on Mon Mar 25 01:17:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkJavaVoidFuncArg Member List

This is the complete list of members for vtkJavaVoidFuncArg, including all inherited members.
  • mid
  • uobj
  • vm
Generated on Mon Mar 25 01:22:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkLODProp3DEntry Member List

This is the complete list of members for vtkLODProp3DEntry, including all inherited members.
  • EstimatedTime
  • ID
  • Level
  • Prop3D
  • Prop3DType
  • State
Generated on Mon Mar 25 01:23:19 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMaskFields::CopyFieldFlag Member List

This is the complete list of members for vtkMaskFields::CopyFieldFlag, including all inherited members.
  • IsCopied
  • Location
  • Name
  • Type
Generated on Mon Mar 25 01:23:31 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkMergeFields::Component Member List

This is the complete list of members for vtkMergeFields::Component, including all inherited members.
  • Component() [inline]
  • FieldName
  • Index
  • Next
  • SetName(const char *name) [inline]
  • SourceIndex
  • ~Component() [inline]
Generated on Mon Mar 25 01:23:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkObjectFactory::OverrideInformation Member List

This is the complete list of members for vtkObjectFactory::OverrideInformation, including all inherited members.
  • CreateCallback
  • Description
  • EnabledFlag
  • OverrideWithName
Generated on Mon Mar 25 01:25:26 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTKRayCastRayInfo Member List

This is the complete list of members for VTKRayCastRayInfo, including all inherited members.
  • CameraPosition
  • Color
  • Depth
  • Direction
  • FarClip
  • ImageSize
  • NearClip
  • NumberOfStepsTaken
  • NumberOfStepsToTake
  • Origin
  • Pixel
  • TransformedDirection
  • TransformedEnd
  • TransformedIncrement
  • TransformedStart
Generated on Mon Mar 25 01:35:04 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTKRayCastVolumeInfo Member List

This is the complete list of members for VTKRayCastVolumeInfo, including all inherited members.
  • BlueDiffuseShadingTable
  • BlueSpecularShadingTable
  • CenterDistance
  • Color
  • ColorChannels
  • DataIncrement
  • DataOrigin
  • DataSize
  • DataSpacing
  • EncodedNormals
  • GradientMagnitudes
  • GreenDiffuseShadingTable
  • GreenSpecularShadingTable
  • InterpolationType
  • RedDiffuseShadingTable
  • RedSpecularShadingTable
  • RGBDataIncrement
  • RGBDataOrigin
  • RGBDataPointer
  • RGBDataSize
  • RGBDataSpacing
  • RGBTextureCoefficient
  • ScalarDataPointer
  • ScalarDataType
  • Shading
  • ViewToVolumeMatrix
  • Volume
  • VolumeToWorldMatrix
  • WorldToVolumeMatrix
Generated on Mon Mar 25 01:35:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkRearrangeFields::Operation Member List

This is the complete list of members for vtkRearrangeFields::Operation, including all inherited members.
  • AttributeType
  • FieldName
  • FieldType
  • FromFieldLoc
  • Id
  • Next
  • Operation() [inline]
  • OperationType
  • ToFieldLoc
  • ~Operation() [inline]
Generated on Mon Mar 25 01:29:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkSplitField::Component Member List

This is the complete list of members for vtkSplitField::Component, including all inherited members.
  • Component() [inline]
  • FieldName
  • Index
  • Next
  • SetName(const char *name) [inline]
  • ~Component() [inline]
Generated on Mon Mar 25 01:31:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTclCommandArgStruct Member List

This is the complete list of members for vtkTclCommandArgStruct, including all inherited members.
  • Interp
  • Pointer
  • Tag
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTclCommandStruct Member List

This is the complete list of members for vtkTclCommandStruct, including all inherited members.
  • CommandFunction
  • NewCommand
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTclInterpStruct Member List

This is the complete list of members for vtkTclInterpStruct, including all inherited members.
  • CommandLookup
  • DebugOn
  • InDelete
  • InstanceLookup
  • Number
  • PointerLookup
Generated on Mon Mar 25 01:31:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkTimerLogEntry Member List

This is the complete list of members for vtkTimerLogEntry, including all inherited members.
  • CpuTicks
  • Event
  • WallTime
Generated on Mon Mar 25 01:32:21 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTKVRCDynamicInfo Member List

This is the complete list of members for VTKVRCDynamicInfo, including all inherited members.
  • Color
  • NumberOfStepsTaken
  • NumberOfStepsToTake
  • ScalarValue
  • TransformedDirection
  • TransformedEnd
  • TransformedIncrement
  • TransformedStart
Generated on Mon Mar 25 01:35:08 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

VTKVRCStaticInfo Member List

This is the complete list of members for VTKVRCStaticInfo, including all inherited members.
  • BlueDiffuseShadingTable
  • BlueSpecularShadingTable
  • CameraThickness
  • ClippingPlane
  • Color
  • ColorChannels
  • DataIncrement
  • DataOrigin
  • DataSize
  • DataSpacing
  • EncodedNormals
  • GradientMagnitudes
  • GreenDiffuseShadingTable
  • GreenSpecularShadingTable
  • Image
  • ImageInUseSize
  • ImageMemorySize
  • ImageOrigin
  • ImageViewportSize
  • InterpolationType
  • MaximizeOpacity
  • MIPFunction
  • NumberOfClippingPlanes
  • RedDiffuseShadingTable
  • RedSpecularShadingTable
  • Renderer
  • RowBounds
  • ScalarDataPointer
  • ScalarDataType
  • Shading
  • ViewToVoxelsMatrix
  • Volume
  • VoxelsToWorldMatrix
  • WorldToVoxelsMatrix
Generated on Mon Mar 25 01:35:24 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Member List

vtkVRMLAllocator Member List

This is the complete list of members for vtkVRMLAllocator, including all inherited members.
  • AllocateMemory(size_t n) [static]
  • CleanUp() [static]
  • Heap [static]
  • Initialize() [static]
  • StrDup(const char *str) [static]
Generated on Mon Mar 25 01:34:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtk3DS.h Source File

IO/vtk3DS.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtk3DS.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00017 #include <ctype.h>
00018
00019 typedef float Vector[3];
00020
00021 /* A generic list type */
00022 #define VTK_LIST_INSERT(root, node) list_insert ((List **)&root, reinterpret_cast<List *>(node))
00023 #define VTK_LIST_FIND(root, name)   list_find   ((List **)&root, name)
00024 #define VTK_LIST_DELETE(root, node) list_delete ((List **)&root, (List *)node)
00025 #define VTK_LIST_KILL(root)         list_kill   ((List **)&root)
00026
00027 #define VTK_LIST_FIELDS  \
00028     char name[80];   \
00029     void *next;
00030
00031
00032 typedef unsigned char  byte;
00033 typedef unsigned short word;
00034 typedef unsigned int  dword;
00035
00036 typedef struct {
00037    VTK_LIST_FIELDS
00038 } List;
00039
00040
00041 typedef struct {
00042     int a, b, c;
00043 } Face;
00044
00045
00046 typedef struct {
00047     float red, green, blue;
00048 } Colour;
00049
00050
00051 /* Omni light command */
00052 typedef struct {
00053     VTK_LIST_FIELDS
00054
00055     Vector pos;            /* Light position */
00056     Colour col;            /* Light colour */
00057     vtkLight *aLight;
00058 } OmniLight;
00059
00060
00061 /* Spotlight command */
00062 typedef struct {
00063     VTK_LIST_FIELDS
00064
00065     Vector pos;            /* Spotlight position */
00066     Vector target;         /* Spotlight target location */
00067     Colour col;            /* Spotlight colour */
00068     float  hotspot;        /* Hotspot angle (degrees) */
00069     float  falloff;        /* Falloff angle (degrees) */
00070     int    shadow_flag;    /* Shadow flag (not used) */
00071     vtkLight *aLight;
00072 } SpotLight;
00073
00074
00075 /* Camera command */
00076 typedef struct {
00077     VTK_LIST_FIELDS
00078
00079     Vector pos;            /* Camera location */
00080     Vector target;         /* Camera target */
00081     float  bank;           /* Banking angle (degrees) */
00082     float  lens;           /* Camera lens size (mm) */
00083     vtkCamera *aCamera;
00084 } Camera;
00085
00086
00087 /* Material list */
00088 typedef struct {
00089     VTK_LIST_FIELDS
00090
00091     int  external;         /* Externally defined material? */
00092 } Material;
00093
00094
00095 /* Object summary */
00096 typedef struct {
00097     VTK_LIST_FIELDS
00098
00099     Vector center;         /* Min value of object extents */
00100     Vector lengths;        /* Max value of object extents */
00101 } Summary;
00102
00103
00104 /* Material property */
00105 typedef struct {
00106     VTK_LIST_FIELDS
00107
00108     Colour ambient;
00109     Colour diffuse;
00110     Colour specular;
00111     float  shininess;
00112     float  transparency;
00113     float  reflection;
00114     int    self_illum;
00115     char   tex_map[40];
00116     float  tex_strength;
00117     char   bump_map[40];
00118     float  bump_strength;
00119     vtkProperty *aProperty;
00120 } MatProp;
00121
00122
00123
00124 class vtkActor;
00125 class vtkPolyDataMapper;
00126 class vtkPolyDataNormals;
00127 class vtkStripper;
00128 class vtkPoints;
00129 class vtkCellArray;
00130 class vtkPolyData;
00131
00132 /* A mesh object */
00133 typedef struct {
00134     VTK_LIST_FIELDS
00135
00136     int  vertices;         /* Number of vertices */
00137     Vector *vertex;        /* List of object vertices */
00138
00139     int  faces;            /* Number of faces */
00140     Face *face;            /* List of object faces */
00141     Material **mtl;        /* Materials for each face */
00142
00143     int hidden;            /* Hidden flag */
00144     int shadow;            /* Shadow flag */
00145     vtkActor *anActor;
00146     vtkPolyDataMapper *aMapper;
00147     vtkPolyDataNormals *aNormals;
00148     vtkStripper *aStripper;
00149     vtkPoints *aPoints;
00150     vtkCellArray *aCellArray;
00151     vtkPolyData *aPolyData;
00152
00153 } Mesh;
00154
00155
00156 typedef struct {
00157     dword start;
00158     dword end;
00159     dword length;
00160     word  tag;
00161 } Chunk;
00162
00163
00164 typedef struct {
00165     byte red;
00166     byte green;
00167     byte blue;
00168 } Colour_24;
00169
00170
00171
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtk3DSImporter.h Source File

Hybrid/vtk3DSImporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtk3DSImporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtk3DSImporter_h
00042 #define __vtk3DSImporter_h
00043
00044 #include <stdio.h>
00045 #include "vtkImporter.h"
00046 #include "vtk3DS.h"
00047 #include "vtkPolyData.h"
00048
00049 class VTK_HYBRID_EXPORT vtk3DSImporter : public vtkImporter
00050 {
00051 public:
00052   static vtk3DSImporter *New();
00053
00054   vtkTypeRevisionMacro(vtk3DSImporter,vtkImporter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkSetStringMacro(FileName);
00060   vtkGetStringMacro(FileName);
00062
00064
00066   vtkSetMacro(ComputeNormals,int);
00067   vtkGetMacro(ComputeNormals,int);
00068   vtkBooleanMacro(ComputeNormals,int);
00070
00072   FILE *GetFileFD() {return this->FileFD;};
00073
00074   OmniLight *OmniList;
00075   SpotLight *SpotLightList;
00076   Camera    *CameraList;
00077   Mesh      *MeshList;
00078   Material  *MaterialList;
00079   MatProp   *MatPropList;
00080
00081 protected:
00082   vtk3DSImporter();
00083   ~vtk3DSImporter();
00084
00085   virtual int ImportBegin ();
00086   virtual void ImportEnd ();
00087   virtual void ImportActors (vtkRenderer *renderer);
00088   virtual void ImportCameras (vtkRenderer *renderer);
00089   virtual void ImportLights (vtkRenderer *renderer);
00090   virtual void ImportProperties (vtkRenderer *renderer);
00091   vtkPolyData *GeneratePolyData (Mesh *meshPtr);
00092   int Read3DS ();
00093
00094   char *FileName;
00095   FILE *FileFD;
00096   int ComputeNormals;
00097 private:
00098   vtk3DSImporter(const vtk3DSImporter&);  // Not implemented.
00099   void operator=(const vtk3DSImporter&);  // Not implemented.
00100 };
00101
00102 #endif
00103
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAbstractList.h Source File

Common/vtkAbstractList.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractList.h,v $
00005   Language:  C++
00006
00007
00008 Copyright (c) 1993-2001 Ken Martin, Will Schroeder, Bill Lorensen
00009 All rights reserved.
00010
00011 Redistribution and use in source and binary forms, with or without
00012 modification, are permitted provided that the following conditions are met:
00013
00014  * Redistributions of source code must retain the above copyright notice,
00015    this list of conditions and the following disclaimer.
00016
00017  * Redistributions in binary form must reproduce the above copyright notice,
00018    this list of conditions and the following disclaimer in the documentation
00019    and/or other materials provided with the distribution.
00020
00021  * Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names
00022    of any contributors may be used to endorse or promote products derived
00023    from this software without specific prior written permission.
00024
00025  * Modified source versions must be plainly marked as such, and must not be
00026    misrepresented as being the original software.
00027
00028 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS''
00029 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00030 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
00031 ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
00032 ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
00033 DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
00034 SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
00035 CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
00036 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00037 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00038
00039 =========================================================================*/
00068 #include "vtkContainer.h"
00069
00070 template<class DType>
00071 class vtkAbstractList : public vtkContainer
00072 {
00073 public:
00076   typedef int (*CompareFunction)(DType item1, DType item2);
00077
00080   virtual int AppendItem(DType a) = 0;
00081
00084   virtual int PrependItem(DType a) = 0;
00085
00088   virtual int InsertItem(unsigned long loc, DType a) = 0;
00089
00092   virtual int SetItem(unsigned long loc, DType a) = 0;
00093
00096   virtual void SetItemNoCheck(unsigned long loc, DType a) = 0;
00097
00099   virtual int RemoveItem(unsigned long id) = 0;
00100
00103   virtual int GetItem(unsigned long id, DType& ret) = 0;
00104
00108   virtual int FindItem(DType a, unsigned long &res) = 0;
00109
00111
00114   virtual int FindItem(DType a, CompareFunction compare,
00115                        unsigned long &res) = 0;
00117
00119   virtual int SetSize(unsigned long size) = 0;
00120 };
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkAbstractMapper3D.h Source File

Rendering/vtkAbstractMapper3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractMapper3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkAbstractMapper3D_h
00045 #define __vtkAbstractMapper3D_h
00046
00047 #include "vtkAbstractMapper.h"
00048
00049 class vtkWindow;
00050 class vtkDataSet;
00051
00052 class VTK_RENDERING_EXPORT vtkAbstractMapper3D : public vtkAbstractMapper
00053 {
00054 public:
00055   vtkTypeRevisionMacro(vtkAbstractMapper3D,vtkAbstractMapper);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00060   virtual float *GetBounds()=0;
00061
00063   virtual void GetBounds(float bounds[6]);
00064
00066   float *GetCenter();
00067
00069   float GetLength();
00070
00073   virtual int IsARayCastMapper() {return 0;};
00074
00078   virtual int IsARenderIntoImageMapper() {return 0;};
00079
00081   virtual void Update()=0;
00082
00083 protected:
00084    vtkAbstractMapper3D();
00085   ~vtkAbstractMapper3D() {};
00086
00087   float Bounds[6];
00088   float Center[3];
00089
00090 private:
00091   vtkAbstractMapper3D(const vtkAbstractMapper3D&);  // Not implemented.
00092   void operator=(const vtkAbstractMapper3D&);  // Not implemented.
00093 };
00094
00095 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAbstractMapper.h Source File

Common/vtkAbstractMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkAbstractMapper_h
00041 #define __vtkAbstractMapper_h
00042
00043 #include "vtkProcessObject.h"
00044 #include "vtkPlaneCollection.h"
00045 #include "vtkPlane.h"
00046 #include "vtkPlanes.h"
00047 #include "vtkTimerLog.h"
00048
00049 #define VTK_SCALAR_MODE_DEFAULT 0
00050 #define VTK_SCALAR_MODE_USE_POINT_DATA 1
00051 #define VTK_SCALAR_MODE_USE_CELL_DATA 2
00052 #define VTK_SCALAR_MODE_USE_POINT_FIELD_DATA 3
00053 #define VTK_SCALAR_MODE_USE_CELL_FIELD_DATA 4
00054
00055 #define VTK_GET_ARRAY_BY_ID 0
00056 #define VTK_GET_ARRAY_BY_NAME 1
00057
00058 class vtkWindow;
00059 class vtkDataSet;
00060
00061 class VTK_COMMON_EXPORT vtkAbstractMapper : public vtkProcessObject
00062 {
00063 public:
00064   vtkTypeRevisionMacro(vtkAbstractMapper,vtkProcessObject);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068   virtual unsigned long GetMTime();
00069
00073   virtual void ReleaseGraphicsResources(vtkWindow *) {};
00074
00076
00077   vtkGetMacro( TimeToDraw, float );
00079
00081
00083   void AddClippingPlane(vtkPlane *plane);
00084   void RemoveClippingPlane(vtkPlane *plane);
00085   void RemoveAllClippingPlanes();
00087
00089
00090   vtkSetObjectMacro(ClippingPlanes,vtkPlaneCollection);
00091   vtkGetObjectMacro(ClippingPlanes,vtkPlaneCollection);
00093
00096   void SetClippingPlanes(vtkPlanes *planes);
00097
00099   void ShallowCopy(vtkAbstractMapper *m);
00100
00102
00107   static vtkDataArray *GetScalars(vtkDataSet *input, int scalarMode,
00108                                   int arrayAccessMode, int arrayId,
00109                                   const char *arrayName, int& component);
00110   // Description:
00111   // Get the number of consumers
00112   vtkGetMacro(NumberOfConsumers,int);
00114
00116
00117   void AddConsumer(vtkObject *c);
00118   void RemoveConsumer(vtkObject *c);
00119   vtkObject *GetConsumer(int i);
00120   int IsConsumer(vtkObject *c);
00122
00123 protected:
00124   vtkAbstractMapper();
00125   ~vtkAbstractMapper();
00126
00127   vtkTimerLog *Timer;
00128   float TimeToDraw;
00129   vtkWindow *LastWindow;   // Window used for the previous render
00130   vtkPlaneCollection *ClippingPlanes;
00131
00132   // how many consumers does this object have
00133   int NumberOfConsumers;
00134   vtkObject **Consumers;
00135
00136 private:
00137   vtkAbstractMapper(const vtkAbstractMapper&);  // Not implemented.
00138   void operator=(const vtkAbstractMapper&);  // Not implemented.
00139 };
00140
00141 #endif
00142
00143
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkAbstractPicker.h Source File

Rendering/vtkAbstractPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00068 #ifndef __vtkAbstractPicker_h
00069 #define __vtkAbstractPicker_h
00070
00071 #include "vtkObject.h"
00072 #include "vtkRenderer.h"
00073
00074 class VTK_RENDERING_EXPORT vtkAbstractPicker : public vtkObject
00075 {
00076 public:
00077   vtkTypeRevisionMacro(vtkAbstractPicker,vtkObject);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00081
00082   vtkGetObjectMacro(Renderer,vtkRenderer);
00084
00086
00088   vtkGetVectorMacro(SelectionPoint,float,3);
00090
00092
00093   vtkGetVectorMacro(PickPosition,float,3);
00095
00097
00101   virtual int Pick(float selectionX, float selectionY, float selectionZ,
00102                    vtkRenderer *renderer) = 0;
00104
00106
00109   int Pick(float selectionPt[3], vtkRenderer *ren)
00110     {return this->Pick(selectionPt[0],selectionPt[1],selectionPt[2],ren);};
00112
00114   void SetStartPickMethod(void (*f)(void *), void *arg);
00115
00117   void SetPickMethod(void (*f)(void *), void *arg);
00118
00121   void SetEndPickMethod(void (*f)(void *), void *arg);
00122
00124   void SetStartPickMethodArgDelete(void (*f)(void *));
00125
00127   void SetPickMethodArgDelete(void (*f)(void *));
00128
00130   void SetEndPickMethodArgDelete(void (*f)(void *));
00131
00133
00136   vtkSetMacro(PickFromList,int);
00137   vtkGetMacro(PickFromList,int);
00138   vtkBooleanMacro(PickFromList,int);
00140
00142   void InitializePickList();
00143
00145   void AddPickList(vtkProp *);
00146
00148   void DeletePickList(vtkProp *);
00149
00151   vtkPropCollection *GetPickList() {return this->PickList;}
00152
00153 protected:
00154   vtkAbstractPicker();
00155   ~vtkAbstractPicker();
00156
00157   virtual void Initialize();
00158
00159   vtkRenderer *Renderer; //pick occurred in this renderer's viewport
00160   float SelectionPoint[3]; //selection point in window (pixel) coordinates
00161   float PickPosition[3]; //selection point in world coordinates
00162
00163   // the following are used to manage invocation of pick methods
00164   unsigned long StartPickTag;
00165   unsigned long PickTag;
00166   unsigned long EndPickTag;
00167
00168   // use the following to control picking from a list
00169   int PickFromList;
00170   vtkPropCollection *PickList;
00171 private:
00172   vtkAbstractPicker(const vtkAbstractPicker&);  // Not implemented.
00173   void operator=(const vtkAbstractPicker&);  // Not implemented.
00174 };
00175
00176 #endif
00177
00178
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkAbstractPropPicker.h Source File

Rendering/vtkAbstractPropPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractPropPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00074 #ifndef __vtkAbstractPropPicker_h
00075 #define __vtkAbstractPropPicker_h
00076
00077 #include "vtkAbstractPicker.h"
00078
00079 class vtkProp;
00080 class vtkPropAssembly;
00081 class vtkAssembly;
00082 class vtkActor;
00083 class vtkVolume;
00084 class vtkProp3D;
00085
00086 class VTK_RENDERING_EXPORT vtkAbstractPropPicker : public vtkAbstractPicker
00087 {
00088 public:
00089   vtkTypeRevisionMacro(vtkAbstractPropPicker,vtkAbstractPicker);
00090   void PrintSelf(ostream& os, vtkIndent indent);
00091
00093
00100   vtkSetObjectMacro(Path,vtkAssemblyPath);
00101   vtkGetObjectMacro(Path,vtkAssemblyPath);
00103
00104   // The following are convenience methods to maintain API with older
00105   // versions of VTK, and to allow query for the return type of a pick. Note:
00106   // the functionality of these methods can also be obtained by using the
00107   // returned vtkAssemblyPath and using the IsA() to determine type.
00108
00111   virtual vtkProp *GetProp();
00112
00115   virtual vtkProp3D *GetProp3D();
00116
00119   virtual vtkActor *GetActor();
00120
00123   virtual vtkActor2D *GetActor2D();
00124
00127   virtual vtkVolume *GetVolume();
00128
00134   virtual vtkAssembly *GetAssembly();
00135
00141   virtual vtkPropAssembly *GetPropAssembly();
00142
00143 protected:
00144   vtkAbstractPropPicker();
00145   ~vtkAbstractPropPicker();
00146
00147   void Initialize();
00148
00149   vtkAssemblyPath *Path; //this is what is picked, and includes the prop
00150 private:
00151   vtkAbstractPropPicker(const vtkAbstractPropPicker&);  // Not implemented.
00152   void operator=(const vtkAbstractPropPicker&);  // Not implemented.
00153 };
00154
00155 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAbstractTransform.h Source File

Common/vtkAbstractTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAbstractTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkAbstractTransform_h
00049 #define __vtkAbstractTransform_h
00050
00051 #include "vtkObject.h"
00052 #include "vtkMatrix4x4.h"
00053 #include "vtkPoints.h"
00054
00055 class vtkSimpleCriticalSection;
00056
00057
00058 class VTK_COMMON_EXPORT vtkAbstractTransform : public vtkObject
00059 {
00060 public:
00061
00062   vtkTypeRevisionMacro(vtkAbstractTransform,vtkObject);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00068   void TransformPoint(const float in[3], float out[3]) {
00069     this->Update(); this->InternalTransformPoint(in,out); };
00071
00073
00075   void TransformPoint(const double in[3], double out[3]) {
00076     this->Update(); this->InternalTransformPoint(in,out); };
00078
00080
00082   double *TransformPoint(double x, double y, double z) {
00083     return this->TransformDoublePoint(x,y,z); }
00084   double *TransformPoint(const double point[3]) {
00085     return this->TransformPoint(point[0],point[1],point[2]); };
00087
00089
00091   float *TransformFloatPoint(float x, float y, float z) {
00092       this->InternalFloatPoint[0] = x;
00093       this->InternalFloatPoint[1] = y;
00094       this->InternalFloatPoint[2] = z;
00095       this->TransformPoint(this->InternalFloatPoint,this->InternalFloatPoint);
00096       return this->InternalFloatPoint; };
00097   float *TransformFloatPoint(const float point[3]) {
00098     return this->TransformFloatPoint(point[0],point[1],point[2]); };
00100
00102
00104   double *TransformDoublePoint(double x, double y, double z) {
00105     this->InternalDoublePoint[0] = x;
00106     this->InternalDoublePoint[1] = y;
00107     this->InternalDoublePoint[2] = z;
00108     this->TransformPoint(this->InternalDoublePoint,this->InternalDoublePoint);
00109     return this->InternalDoublePoint; };
00110   double *TransformDoublePoint(const double point[3]) {
00111     return this->TransformDoublePoint(point[0],point[1],point[2]); };
00113
00115
00118   void TransformNormalAtPoint(const float point[3], const float in[3],
00119                               float out[3]);
00120   void TransformNormalAtPoint(const double point[3], const double in[3],
00121                               double out[3]);
00123
00124   double *TransformNormalAtPoint(const double point[3],
00125                                  const double normal[3]) {
00126     this->TransformNormalAtPoint(point,normal,this->InternalDoublePoint);
00127     return this->InternalDoublePoint; };
00128
00130
00133   double *TransformDoubleNormalAtPoint(const double point[3],
00134                                        const double normal[3]) {
00135     this->TransformNormalAtPoint(point,normal,this->InternalDoublePoint);
00136     return this->InternalDoublePoint; };
00138
00140
00143   float *TransformFloatNormalAtPoint(const float point[3],
00144                                      const float normal[3]) {
00145     this->TransformNormalAtPoint(point,normal,this->InternalFloatPoint);
00146     return this->InternalFloatPoint; };
00148
00150
00153   void TransformVectorAtPoint(const float point[3], const float in[3],
00154                               float out[3]);
00155   void TransformVectorAtPoint(const double point[3], const double in[3],
00156                               double out[3]);
00158
00159   double *TransformVectorAtPoint(const double point[3],
00160                                  const double vector[3]) {
00161     this->TransformVectorAtPoint(point,vector,this->InternalDoublePoint);
00162     return this->InternalDoublePoint; };
00163
00165
00168   double *TransformDoubleVectorAtPoint(const double point[3],
00169                                        const double vector[3]) {
00170     this->TransformVectorAtPoint(point,vector,this->InternalDoublePoint);
00171     return this->InternalDoublePoint; };
00173
00175
00178   float *TransformFloatVectorAtPoint(const float point[3],
00179                                      const float vector[3]) {
00180     this->TransformVectorAtPoint(point,vector,this->InternalFloatPoint);
00181     return this->InternalFloatPoint; };
00183
00186   virtual void TransformPoints(vtkPoints *inPts, vtkPoints *outPts);
00187
00189
00191   virtual void TransformPointsNormalsVectors(vtkPoints *inPts,
00192                                              vtkPoints *outPts,
00193                                              vtkDataArray *inNms,
00194                                              vtkDataArray *outNms,
00195                                              vtkDataArray *inVrs,
00196                                              vtkDataArray *outVrs);
00198
00204   vtkAbstractTransform *GetInverse();
00205
00209   void SetInverse(vtkAbstractTransform *transform);
00210
00212   virtual void Inverse() = 0;
00213
00215   void DeepCopy(vtkAbstractTransform *);
00216
00220   void Update();
00221
00223
00225   virtual void InternalTransformPoint(const float in[3], float out[3]) = 0;
00226   virtual void InternalTransformPoint(const double in[3], double out[3]) = 0;
00228
00230
00234   virtual void InternalTransformDerivative(const float in[3], float out[3],
00235                                            float derivative[3][3]) = 0;
00236   virtual void InternalTransformDerivative(const double in[3], double out[3],
00237                                            double derivative[3][3]) = 0;
00239
00241   virtual vtkAbstractTransform *MakeTransform() = 0;
00242
00249   virtual int CircuitCheck(vtkAbstractTransform *transform);
00250
00252   unsigned long GetMTime();
00253
00256   void UnRegister(vtkObject *O);
00257
00259
00261   void Identity() {
00262     vtkWarningMacro("vtkAbstractTransform::Identity() is deprecated"); };
00264
00265 protected:
00266   vtkAbstractTransform();
00267   ~vtkAbstractTransform();
00268
00270   virtual void InternalUpdate() {};
00271
00273   virtual void InternalDeepCopy(vtkAbstractTransform *) {};
00274
00275   float InternalFloatPoint[3];
00276   double InternalDoublePoint[3];
00277
00278 private:
00279
00280 //BTX
00281   // We need to record the time of the last update, and we also need
00282   // to do mutex locking so updates don't collide.  These are private
00283   // because Update() is not virtual.
00284   // If DependsOnInverse is set, then this transform object will
00285   // check its inverse on every update, and update itself accordingly
00286   // if necessary.
00287 //ETX
00288   vtkTimeStamp UpdateTime;
00289   vtkSimpleCriticalSection *UpdateMutex;
00290   vtkSimpleCriticalSection *InverseMutex;
00291   int DependsOnInverse;
00292
00293 //BTX
00294   // MyInverse is a transform which is the inverse of this one.
00295 //ETX
00296   vtkAbstractTransform *MyInverse;
00297
00298   int InUnRegister;
00299
00300 private:
00301   vtkAbstractTransform(const vtkAbstractTransform&);  // Not implemented.
00302   void operator=(const vtkAbstractTransform&);  // Not implemented.
00303 };
00304
00305 //BTX
00306 //-------------------------------------------------------------------------
00307 // A simple data structure to hold both a transform and its inverse.
00308 // One of ForwardTransform or InverseTransform might be NULL,
00309 // and must be acquired by calling GetInverse() on the other.
00310 class vtkTransformPair
00311 {
00312 public:
00313   vtkAbstractTransform *ForwardTransform;
00314   vtkAbstractTransform *InverseTransform;
00315
00316   void SwapForwardInverse() {
00317     vtkAbstractTransform *tmp = this->ForwardTransform;
00318     this->ForwardTransform = this->InverseTransform;
00319     this->InverseTransform = tmp; };
00320 };
00321
00322 // A helper class (not derived from vtkObject) to store a series of
00323 // transformations in a pipelined concatenation.
00324 class VTK_COMMON_EXPORT vtkTransformConcatenation
00325 {
00326 public:
00327   static vtkTransformConcatenation *New() {
00328     return new vtkTransformConcatenation(); };
00329   void Delete() { delete this; };
00330
00331   // add a transform to the list according to Pre/PostMultiply semantics
00332   void Concatenate(vtkAbstractTransform *transform);
00333
00334   // concatenate with a matrix according to Pre/PostMultiply semantics
00335   void Concatenate(const double elements[16]);
00336
00337   // set the PreMultiply flag
00338   void SetPreMultiplyFlag(int flag) { this->PreMultiplyFlag = flag; };
00339   int GetPreMultiplyFlag() { return this->PreMultiplyFlag; };
00340
00341   // the three basic linear transformations
00342   void Translate(double x, double y, double z);
00343   void Rotate(double angle, double x, double y, double z);
00344   void Scale(double x, double y, double z);
00345
00346   // invert the concatenation
00347   void Inverse();
00348
00349   // get the inverse flag
00350   int GetInverseFlag() { return this->InverseFlag; };
00351
00352   // identity simply clears the transform list
00353   void Identity();
00354
00355   // copy the list
00356   void DeepCopy(vtkTransformConcatenation *transform);
00357
00358   // the number of stored transforms
00359   int GetNumberOfTransforms() { return this->NumberOfTransforms; };
00360
00361   // the number of transforms that were pre-concatenated (note that
00362   // whenever Iverse() is called, the pre-concatenated and
00363   // post-concatenated transforms are switched)
00364   int GetNumberOfPreTransforms() { return this->NumberOfPreTransforms; };
00365
00366   // the number of transforms that were post-concatenated.
00367   int GetNumberOfPostTransforms() {
00368     return this->NumberOfTransforms-this->NumberOfPreTransforms; };
00369
00370   // get one of the transforms
00371   vtkAbstractTransform *GetTransform(int i);
00372
00373   // get maximum MTime of all transforms
00374   unsigned long GetMaxMTime();
00375
00376   void PrintSelf(ostream& os, vtkIndent indent);
00377
00378 protected:
00379   vtkTransformConcatenation();
00380   ~vtkTransformConcatenation();
00381
00382   int InverseFlag;
00383   int PreMultiplyFlag;
00384
00385   vtkMatrix4x4 *PreMatrix;
00386   vtkMatrix4x4 *PostMatrix;
00387   vtkAbstractTransform *PreMatrixTransform;
00388   vtkAbstractTransform *PostMatrixTransform;
00389
00390   int NumberOfTransforms;
00391   int NumberOfPreTransforms;
00392   int MaxNumberOfTransforms;
00393   vtkTransformPair *TransformList;
00394 };
00395
00396 // A helper class (not derived from vtkObject) to store a stack of
00397 // concatenations.
00398 class VTK_COMMON_EXPORT vtkTransformConcatenationStack
00399 {
00400 public:
00401   static vtkTransformConcatenationStack *New() {
00402     return new vtkTransformConcatenationStack(); };
00403   void Delete() { delete this; };
00404
00405   // pop will pop delete 'concat', then pop the
00406   // top item on the stack onto 'concat'.
00407   void Pop(vtkTransformConcatenation **concat);
00408
00409   // push will move 'concat' onto the stack, and
00410   // make 'concat' a copy of its previous self
00411   void Push(vtkTransformConcatenation **concat);
00412
00413   void DeepCopy(vtkTransformConcatenationStack *stack);
00414
00415 protected:
00416   vtkTransformConcatenationStack();
00417   ~vtkTransformConcatenationStack();
00418
00419   int StackSize;
00420   vtkTransformConcatenation **Stack;
00421   vtkTransformConcatenation **StackBottom;
00422 };
00423
00424 //ETX
00425
00426 #endif
00427
00428
00429
00430
00431
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkActor2D.h Source File

Common/vtkActor2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkActor2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkActor2D_h
00048 #define __vtkActor2D_h
00049
00050 #include "vtkProp.h"
00051 #include "vtkCoordinate.h"
00052 #include "vtkProperty2D.h"
00053 class vtkMapper2D;
00054
00055 class VTK_COMMON_EXPORT vtkActor2D : public vtkProp
00056 {
00057 public:
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059   vtkTypeRevisionMacro(vtkActor2D,vtkProp);
00060
00063   static vtkActor2D* New();
00064
00066
00067   int RenderOverlay(vtkViewport *viewport);
00068   int RenderOpaqueGeometry(vtkViewport *viewport);
00069   int RenderTranslucentGeometry(vtkViewport *viewport);
00071
00073
00074   virtual void SetMapper(vtkMapper2D *mapper);
00075   vtkGetObjectMacro(Mapper, vtkMapper2D);
00077
00079
00080   vtkSetMacro(LayerNumber, int);
00081   vtkGetMacro(LayerNumber, int);
00083
00086   vtkProperty2D* GetProperty();
00087
00089
00090   vtkSetObjectMacro(Property, vtkProperty2D);
00092
00094
00097   vtkViewportCoordinateMacro(Position);
00099
00101   void SetDisplayPosition(int,int);
00102
00104
00108   vtkViewportCoordinateMacro(Position2);
00110
00112
00115   void SetWidth(float w);
00116   float GetWidth();
00117   void SetHeight(float h);
00118   float GetHeight();
00120
00122   unsigned long GetMTime();
00123
00127   virtual void GetActors2D(vtkPropCollection *pc);
00128
00131   void ShallowCopy(vtkProp *prop);
00132
00136   virtual void ReleaseGraphicsResources(vtkWindow *);
00137
00138 protected:
00139   vtkActor2D();
00140   ~vtkActor2D();
00141
00142   vtkMapper2D *Mapper;
00143   int LayerNumber;
00144   vtkProperty2D *Property;
00145   vtkCoordinate *PositionCoordinate;
00146   vtkCoordinate *Position2Coordinate;
00147 private:
00148   vtkActor2D(const vtkActor2D&);  // Not implemented.
00149   void operator=(const vtkActor2D&);  // Not implemented.
00150 };
00151
00152 #endif
00153
00154
00155
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkActor2DCollection.h Source File

Common/vtkActor2DCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkActor2DCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkActor2DCollection_h
00039 #define __vtkActor2DCollection_h
00040
00041 #include "vtkPropCollection.h"
00042 #include "vtkActor2D.h"
00043 class vtkViewport;
00044
00045 class VTK_COMMON_EXPORT vtkActor2DCollection : public vtkPropCollection
00046 {
00047  public:
00050   static vtkActor2DCollection *New();
00051
00052   vtkTypeRevisionMacro(vtkActor2DCollection,vtkPropCollection);
00053
00056   void Sort();
00057
00060   void AddItem(vtkActor2D *a);
00061
00063
00064   int IsItemPresent(vtkActor2D *a);
00065   vtkActor2D *GetNextActor2D();
00066   vtkActor2D *GetLastActor2D();
00068
00070
00073  vtkActor2D *GetNextItem();
00074  vtkActor2D *GetLastItem();
00076
00077
00079   void RenderOverlay(vtkViewport* viewport);
00080
00081
00082 protected:
00083   vtkActor2DCollection() {};
00084   ~vtkActor2DCollection();
00085
00086   virtual void DeleteElement(vtkCollectionElement *);
00087
00088 private:
00089   // hide the standard AddItem from the user and the compiler.
00090   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00091   void AddItem(vtkProp *o) { this->vtkPropCollection::AddItem(o); };
00092   int IsItemPresent(vtkObject *o) { return this->vtkCollection::IsItemPresent(o); };
00093
00094 private:
00095   vtkActor2DCollection(const vtkActor2DCollection&);  // Not implemented.
00096   void operator=(const vtkActor2DCollection&);  // Not implemented.
00097 };
00098
00099 inline int vtkActor2DCollection::IsItemPresent(vtkActor2D *a)
00100 {
00101   return this->vtkCollection::IsItemPresent((vtkObject *)a);
00102 }
00103
00104 inline vtkActor2D *vtkActor2DCollection::GetNextActor2D()
00105 {
00106   return static_cast<vtkActor2D *>(this->GetNextItemAsObject());
00107 }
00108
00109 inline vtkActor2D *vtkActor2DCollection::GetLastActor2D()
00110 {
00111   if ( this->Bottom == NULL )
00112     {
00113     return NULL;
00114     }
00115   else
00116     {
00117     return static_cast<vtkActor2D *>(this->Bottom->Item);
00118     }
00119 }
00120
00121 inline vtkActor2D *vtkActor2DCollection::GetNextItem()
00122 {
00123   return this->GetNextActor2D();
00124 }
00125
00126 inline vtkActor2D *vtkActor2DCollection::GetLastItem()
00127 {
00128   return this->GetLastActor2D();
00129 }
00130
00131 #endif
00132
00133
00134
00135
00136
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkActor.h Source File

Rendering/vtkActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkActor_h
00051 #define __vtkActor_h
00052
00053 #include "vtkProp3D.h"
00054 #include "vtkProperty.h"
00055 #include "vtkTexture.h"
00056 #include "vtkMapper.h"
00057
00058 class vtkRenderer;
00059 class vtkPropCollection;
00060 class vtkActorCollection;
00061
00062 class VTK_RENDERING_EXPORT vtkActor : public vtkProp3D
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkActor,vtkProp3D);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00071   static vtkActor *New();
00072
00076   virtual void GetActors(vtkPropCollection *);
00077
00079
00080   virtual int RenderOpaqueGeometry(vtkViewport *viewport);
00081   virtual int RenderTranslucentGeometry(vtkViewport *viewport);
00083
00089   virtual void Render(vtkRenderer *, vtkMapper *) {};
00090
00092   void ShallowCopy(vtkProp *prop);
00093
00097   void ReleaseGraphicsResources(vtkWindow *);
00098
00100
00105   void SetProperty(vtkProperty *lut);
00106   vtkProperty *GetProperty();
00108
00112   virtual vtkProperty* MakeProperty();
00113
00115
00119   void SetBackfaceProperty(vtkProperty *lut);
00120   vtkProperty *GetBackfaceProperty();
00122
00124
00127   vtkSetObjectMacro(Texture,vtkTexture);
00128   vtkGetObjectMacro(Texture,vtkTexture);
00130
00135   virtual void SetMapper(vtkMapper *);
00136
00138
00139   vtkGetObjectMacro(Mapper,vtkMapper);
00141
00143
00146   void GetBounds(float bounds[6]) {this->vtkProp3D::GetBounds( bounds );};
00147   float *GetBounds();
00149
00156   virtual void ApplyProperties() {return;};
00157
00160   unsigned long int GetMTime();
00161
00166   virtual unsigned long GetRedrawMTime();
00167
00169
00173   virtual void InitPartTraversal();
00174   virtual vtkActor *GetNextPart();
00175   virtual int GetNumberOfParts();
00177
00178 protected:
00179   vtkActor();
00180   ~vtkActor();
00181
00182   vtkProperty *Property;
00183   vtkProperty *BackfaceProperty;
00184   vtkTexture *Texture;
00185   vtkMapper *Mapper;
00186
00187   // is this actor opaque
00188   int GetIsOpaque();
00189
00190   // Bounds are cached in an actor - the MapperBounds are also cache to
00191   // help know when the Bounds need to be recomputed.
00192   float        MapperBounds[6];
00193   vtkTimeStamp BoundsMTime;
00194
00195 private:
00196   vtkActor(const vtkActor&);  // Not implemented.
00197   void operator=(const vtkActor&);  // Not implemented.
00198 };
00199
00200 #endif
00201
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkActorCollection.h Source File

Rendering/vtkActorCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkActorCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkActorC_h
00041 #define __vtkActorC_h
00042
00043 #include "vtkPropCollection.h"
00044 #include "vtkActor.h"
00045 class vtkProperty;
00046
00047 class VTK_RENDERING_EXPORT vtkActorCollection : public vtkPropCollection
00048 {
00049 public:
00050   static vtkActorCollection *New();
00051   vtkTypeRevisionMacro(vtkActorCollection,vtkPropCollection);
00052
00054   void AddItem(vtkActor *a);
00055
00057   vtkActor *GetNextActor();
00058
00060   vtkActor *GetLastActor();
00061
00063
00066   vtkActor *GetNextItem();
00067   vtkActor *GetLastItem();
00069
00071   void ApplyProperties(vtkProperty *p);
00072
00073 protected:
00074   vtkActorCollection() {};
00075   ~vtkActorCollection() {};
00076
00077
00078 private:
00079   // hide the standard AddItem from the user and the compiler.
00080   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00081   void AddItem(vtkProp *o) { this->vtkPropCollection::AddItem(o); };
00082
00083 private:
00084   vtkActorCollection(const vtkActorCollection&);  // Not implemented.
00085   void operator=(const vtkActorCollection&);  // Not implemented.
00086 };
00087
00088 inline void vtkActorCollection::AddItem(vtkActor *a)
00089 {
00090   this->vtkCollection::AddItem((vtkObject *)a);
00091 }
00092
00093 inline vtkActor *vtkActorCollection::GetNextActor()
00094 {
00095   return static_cast<vtkActor *>(this->GetNextItemAsObject());
00096 }
00097
00098 inline vtkActor *vtkActorCollection::GetLastActor()
00099 {
00100   if ( this->Bottom == NULL )
00101     {
00102     return NULL;
00103     }
00104   else
00105     {
00106     return static_cast<vtkActor *>(this->Bottom->Item);
00107     }
00108 }
00109
00110 inline vtkActor *vtkActorCollection::GetNextItem()
00111 {
00112   return this->GetNextActor();
00113 }
00114
00115 inline vtkActor *vtkActorCollection::GetLastItem()
00116 {
00117   return this->GetLastActor();
00118 }
00119
00120 #endif
00121
00122
00123
00124
00125
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkAppendFilter.h Source File

Graphics/vtkAppendFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAppendFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkAppendFilter_h
00047 #define __vtkAppendFilter_h
00048
00049 #include "vtkDataSetToUnstructuredGridFilter.h"
00050 #include "vtkDataSetCollection.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkAppendFilter : public vtkDataSetToUnstructuredGridFilter
00053 {
00054 public:
00055   static vtkAppendFilter *New();
00056
00057   vtkTypeRevisionMacro(vtkAppendFilter,vtkDataSetToUnstructuredGridFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   void AddInput(vtkDataSet *in);
00062
00064
00065   vtkDataSet *GetInput(int idx);
00066   vtkDataSet *GetInput()
00067     {return this->GetInput( 0 );}
00069
00071   void RemoveInput(vtkDataSet *in);
00072
00075   vtkDataSetCollection *GetInputList();
00076
00077 protected:
00078   vtkAppendFilter();
00079   ~vtkAppendFilter();
00080
00081   // Usual data generation method
00082   void Execute();
00083
00084   // list of data sets to append together.
00085   // Here as a convenience.  It is a copy of the input array.
00086   vtkDataSetCollection *InputList;
00087
00088 private:
00089   // hide the superclass' AddInput() from the user and the compiler
00090   void AddInput(vtkDataObject *)
00091     { vtkErrorMacro( << "AddInput() must be called with a vtkDataSet not a vtkDataObject."); };
00092   void RemoveInput(vtkDataObject *input)
00093     { this->vtkProcessObject::RemoveInput(input); };
00094 private:
00095   vtkAppendFilter(const vtkAppendFilter&);  // Not implemented.
00096   void operator=(const vtkAppendFilter&);  // Not implemented.
00097 };
00098
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkAppendPolyData.h Source File

Graphics/vtkAppendPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAppendPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkAppendPolyData_h
00051 #define __vtkAppendPolyData_h
00052
00053 #include "vtkPolyDataToPolyDataFilter.h"
00054
00055 class VTK_GRAPHICS_EXPORT vtkAppendPolyData : public vtkPolyDataToPolyDataFilter
00056 {
00057 public:
00058   static vtkAppendPolyData *New();
00059
00060   vtkTypeRevisionMacro(vtkAppendPolyData,vtkPolyDataToPolyDataFilter);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00068   vtkSetMacro(UserManagedInputs,int);
00069   vtkGetMacro(UserManagedInputs,int);
00070   vtkBooleanMacro(UserManagedInputs,int);
00072
00075   void AddInput(vtkPolyData *);
00076
00079   void RemoveInput(vtkPolyData *);
00080
00082
00083   vtkPolyData *GetInput(int idx);
00084   vtkPolyData *GetInput() { return this->GetInput( 0 ); };
00086
00089   void SetNumberOfInputs(int num);
00090
00091   // Set Nth input, should only be used when UserManagedInputs is true.
00092   void SetInputByNumber(int num, vtkPolyData *input);
00093
00095
00102   vtkSetMacro(ParallelStreaming, int);
00103   vtkGetMacro(ParallelStreaming, int);
00104   vtkBooleanMacro(ParallelStreaming, int);
00106
00107 protected:
00108   vtkAppendPolyData();
00109   ~vtkAppendPolyData();
00110
00111   // Flag for selecting parallel streaming behavior
00112   int ParallelStreaming;
00113
00114   // Usual data generation method
00115   void Execute();
00116
00117   void ComputeInputUpdateExtents(vtkDataObject *output);
00118
00119   // An efficient way to append data/cells.
00120   void AppendData(vtkDataArray *dest, vtkDataArray *src, vtkIdType offset);
00121   void AppendDifferentPoints(vtkDataArray *dest, vtkDataArray *src,
00122                              vtkIdType offset);
00123   vtkIdType *AppendCells(vtkIdType *pDest, vtkCellArray *src,
00124                          vtkIdType offset);
00125
00126  private:
00127   // hide the superclass' AddInput() from the user and the compiler
00128   void AddInput(vtkDataObject *)
00129     { vtkErrorMacro( << "AddInput() must be called with a vtkPolyData not a vtkDataObject."); };
00130   void RemoveInput(vtkDataObject *input)
00131     { this->vtkProcessObject::RemoveInput(input);
00132     this->vtkProcessObject::SqueezeInputArray();};
00133   int UserManagedInputs;
00134 private:
00135   vtkAppendPolyData(const vtkAppendPolyData&);  // Not implemented.
00136   void operator=(const vtkAppendPolyData&);  // Not implemented.
00137 };
00138
00139 #endif
00140
00141
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkApproximatingSubdivisionFilter.h Source File

Graphics/vtkApproximatingSubdivisionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkApproximatingSubdivisionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkApproximatingSubdivisionFilter_h
00036 #define __vtkApproximatingSubdivisionFilter_h
00037
00038 #include "vtkPolyDataToPolyDataFilter.h"
00039 #include "vtkIntArray.h"
00040 #include "vtkIdList.h"
00041 #include "vtkCellArray.h"
00042
00043 class VTK_GRAPHICS_EXPORT vtkApproximatingSubdivisionFilter : public vtkPolyDataToPolyDataFilter
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkApproximatingSubdivisionFilter,vtkPolyDataToPolyDataFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   vtkSetMacro(NumberOfSubdivisions,int);
00052   vtkGetMacro(NumberOfSubdivisions,int);
00054
00055 protected:
00056   vtkApproximatingSubdivisionFilter();
00057   ~vtkApproximatingSubdivisionFilter() {};
00058
00059   void Execute();
00060   virtual void GenerateSubdivisionPoints (vtkPolyData *inputDS,
00061                                           vtkIntArray *edgeData,
00062                                           vtkPoints *outputPts,
00063                                           vtkPointData *outputPD) = 0;
00064   void GenerateSubdivisionCells (vtkPolyData *inputDS, vtkIntArray *edgeData,
00065                                  vtkCellArray *outputPolys,
00066                                  vtkCellData *outputCD);
00067   int FindEdge (vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1,
00068                 vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds);
00069   vtkIdType InterpolatePosition (vtkPoints *inputPts, vtkPoints *outputPts,
00070                                  vtkIdList *stencil, float *weights);
00071   int NumberOfSubdivisions;
00072 private:
00073   vtkApproximatingSubdivisionFilter(const vtkApproximatingSubdivisionFilter&);  // Not implemented.
00074   void operator=(const vtkApproximatingSubdivisionFilter&);  // Not implemented.
00075 };
00076
00077 #endif
00078
00079
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkArcPlotter.h Source File

Hybrid/vtkArcPlotter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkArcPlotter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkArcPlotter_h
00055 #define __vtkArcPlotter_h
00056
00057 #include "vtkPolyDataToPolyDataFilter.h"
00058 #include "vtkCamera.h"
00059
00060 #define VTK_PLOT_SCALARS    1
00061 #define VTK_PLOT_VECTORS    2
00062 #define VTK_PLOT_NORMALS    3
00063 #define VTK_PLOT_TCOORDS    4
00064 #define VTK_PLOT_TENSORS    5
00065 #define VTK_PLOT_FIELD_DATA 6
00066
00067 class VTK_HYBRID_EXPORT vtkArcPlotter : public vtkPolyDataToPolyDataFilter
00068 {
00069 public:
00071   static vtkArcPlotter *New();
00072
00073   vtkTypeRevisionMacro(vtkArcPlotter,vtkPolyDataToPolyDataFilter);
00074   void PrintSelf(ostream& os, vtkIndent indent);
00075
00077
00079   vtkSetObjectMacro(Camera,vtkCamera);
00080   vtkGetObjectMacro(Camera,vtkCamera);
00082
00084
00088   vtkSetMacro(PlotMode, int);
00089   vtkGetMacro(PlotMode, int);
00090   void SetPlotModeToPlotScalars() {this->SetPlotMode(VTK_PLOT_SCALARS);};
00091   void SetPlotModeToPlotVectors() {this->SetPlotMode(VTK_PLOT_VECTORS);};
00092   void SetPlotModeToPlotNormals() {this->SetPlotMode(VTK_PLOT_NORMALS);};
00093   void SetPlotModeToPlotTCoords() {this->SetPlotMode(VTK_PLOT_TCOORDS);};
00094   void SetPlotModeToPlotTensors() {this->SetPlotMode(VTK_PLOT_TENSORS);};
00095   void SetPlotModeToPlotFieldData()
00096             {this->SetPlotMode(VTK_PLOT_FIELD_DATA);};
00098
00100
00103   vtkSetMacro(PlotComponent,int);
00104   vtkGetMacro(PlotComponent,int);
00106
00108
00109   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00110   vtkGetMacro(Radius,float);
00112
00114
00116   vtkSetClampMacro(Height,float,0.0,VTK_LARGE_FLOAT);
00117   vtkGetMacro(Height,float);
00119
00121
00124   vtkSetClampMacro(Offset, float, 0.0, VTK_LARGE_FLOAT);
00125   vtkGetMacro(Offset, float);
00127
00129
00132   vtkSetMacro(UseDefaultNormal,int);
00133   vtkGetMacro(UseDefaultNormal,int);
00134   vtkBooleanMacro(UseDefaultNormal,int);
00136
00138
00140   vtkSetVector3Macro(DefaultNormal,float);
00141   vtkGetVectorMacro(DefaultNormal,float,3);
00143
00145
00147   vtkSetClampMacro(FieldDataArray,int,0,VTK_LARGE_INTEGER);
00148   vtkGetMacro(FieldDataArray,int);
00150
00152   unsigned long GetMTime();
00153
00154 protected:
00155   vtkArcPlotter();
00156   ~vtkArcPlotter();
00157
00158   void Execute();
00159   int  OffsetPoint(vtkIdType ptId, vtkPoints *inPts, float n[3],
00160                    vtkPoints *newPts, float offset, float *range, float val);
00161   int  ProcessComponents(vtkIdType numPts, vtkPointData *pd);
00162
00163   vtkCamera *Camera;
00164   int       PlotMode;
00165   int       PlotComponent;
00166   float     Radius;
00167   float     Height;
00168   float     Offset;
00169   float     DefaultNormal[3];
00170   int       UseDefaultNormal;
00171   int       FieldDataArray;
00172
00173 private:
00174   vtkDataArray *Data;
00175   float    *DataRange;
00176   float    *Tuple;
00177   int       NumberOfComponents;
00178   int       ActiveComponent;
00179   int       StartComp;
00180   int       EndComp;
00181
00182 private:
00183   vtkArcPlotter(const vtkArcPlotter&);  // Not implemented.
00184   void operator=(const vtkArcPlotter&);  // Not implemented.
00185 };
00186
00187 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkArrayCalculator.h Source File

Graphics/vtkArrayCalculator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkArrayCalculator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkArrayCalculator_h
00046 #define __vtkArrayCalculator_h
00047
00048 #include "vtkDataSetToDataSetFilter.h"
00049
00050 class vtkFunctionParser;
00051
00052 #define VTK_ATTRIBUTE_MODE_DEFAULT 0
00053 #define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
00054 #define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2
00055
00056 class VTK_GRAPHICS_EXPORT vtkArrayCalculator : public vtkDataSetToDataSetFilter
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkArrayCalculator,vtkDataSetToDataSetFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00062   static vtkArrayCalculator *New();
00063
00065
00066   void SetFunction(const char* function);
00067   vtkGetStringMacro(Function);
00069
00071
00076   void AddScalarArrayName(const char* arrayName, int component = 0);
00077   void AddVectorArrayName(const char* arrayName, int component0 = 0,
00078                           int component1 = 1, int component2 = 2);
00080
00082
00084   void AddScalarVariable(const char* variableName, const char* arrayName,
00085                          int component = 0);
00086   void AddVectorVariable(const char* variableName, const char* arrayName,
00087                          int component0 = 0, int component1 = 1,
00088                          int component2 = 2);
00090
00092
00096   void SetResultArrayName(const char* name);
00097   vtkGetStringMacro(ResultArrayName);
00099
00101
00106   vtkSetMacro(AttributeMode,int);
00107   vtkGetMacro(AttributeMode,int);
00108   void SetAttributeModeToDefault()
00109     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_DEFAULT);};
00110   void SetAttributeModeToUsePointData()
00111     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_POINT_DATA);};
00112   void SetAttributeModeToUseCellData()
00113     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_CELL_DATA);};
00114   const char *GetAttributeModeAsString();
00116
00118   void RemoveAllVariables();
00119
00121
00122   char** GetScalarArrayNames() { return this->ScalarArrayNames; }
00123   char* GetScalarArrayName(int i);
00124   char** GetVectorArrayNames() { return this->VectorArrayNames; }
00125   char* GetVectorArrayName(int i);
00126   char** GetScalarVariableNames() { return this->ScalarVariableNames; }
00127   char* GetScalarVariableName(int i);
00128   char** GetVectorVariableNames() { return this->VectorVariableNames; }
00129   char* GetVectorVariableName(int i);
00130   int* GetSelectedScalarComponents() { return this->SelectedScalarComponents; }
00131   int GetSelectedScalarComponent(int i);
00132   int** GetSelectedVectorComponents() { return this->SelectedVectorComponents;}
00133   int* GetSelectedVectorComponents(int i);
00134   vtkGetMacro(NumberOfScalarArrays, int);
00135   vtkGetMacro(NumberOfVectorArrays, int);
00137
00138 protected:
00139   vtkArrayCalculator();
00140   ~vtkArrayCalculator();
00141
00142   void Execute();
00143
00144   char* Function;
00145   char* ResultArrayName;
00146   char** ScalarArrayNames;
00147   char** VectorArrayNames;
00148   char** ScalarVariableNames;
00149   char** VectorVariableNames;
00150   int NumberOfScalarArrays;
00151   int NumberOfVectorArrays;
00152   int AttributeMode;
00153   int* SelectedScalarComponents;
00154   int** SelectedVectorComponents;
00155   vtkFunctionParser* FunctionParser;
00156 private:
00157   vtkArrayCalculator(const vtkArrayCalculator&);  // Not implemented.
00158   void operator=(const vtkArrayCalculator&);  // Not implemented.
00159 };
00160
00161 #endif
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkArrowSource.h Source File

Graphics/vtkArrowSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkArrowSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkArrowSource_h
00039 #define __vtkArrowSource_h
00040
00041 #include "vtkPolyDataSource.h"
00042
00043 class VTK_GRAPHICS_EXPORT vtkArrowSource : public vtkPolyDataSource
00044 {
00045 public:
00047   static vtkArrowSource *New();
00048
00049   vtkTypeRevisionMacro(vtkArrowSource,vtkPolyDataSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetClampMacro(TipLength,float,0.0,1.0);
00055   vtkGetMacro(TipLength,float);
00056   vtkSetClampMacro(TipRadius,float,0.0,10.0);
00057   vtkGetMacro(TipRadius,float);
00059
00061
00063   vtkSetClampMacro(TipResolution,int,1,128);
00064   vtkGetMacro(TipResolution,int);
00066
00068
00069   vtkSetClampMacro(ShaftRadius,float,0.0,5.0);
00070   vtkGetMacro(ShaftRadius,float);
00072
00074
00076   vtkSetClampMacro(ShaftResolution,int,0,128);
00077   vtkGetMacro(ShaftResolution,int);
00079
00080 protected:
00081   vtkArrowSource();
00082   ~vtkArrowSource() {};
00083
00084   void Execute();
00085
00086   int TipResolution;
00087   float TipLength;
00088   float TipRadius;
00089
00090   int ShaftResolution;
00091   float ShaftRadius;
00092
00093 private:
00094   vtkArrowSource(const vtkArrowSource&) {};  // Not implemented.
00095   void operator=(const vtkArrowSource&) {};  // Not implemented.
00096 };
00097
00098 #endif
00099
00100
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkAssembly.h Source File

Rendering/vtkAssembly.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAssembly.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00073 #ifndef __vtkAssembly_h
00074 #define __vtkAssembly_h
00075
00076 #include "vtkProp3D.h"
00077 #include "vtkAbstractMapper3D.h"
00078
00079 class vtkAssemblyPaths;
00080 class vtkProp3DCollection;
00081 class vtkMapper;
00082 class vtkProperty;
00083 class vtkActor;
00084
00085 class VTK_RENDERING_EXPORT vtkAssembly : public vtkProp3D
00086 {
00087 public:
00088   static vtkAssembly *New();
00089
00090   vtkTypeRevisionMacro(vtkAssembly,vtkProp3D);
00091   void PrintSelf(ostream& os, vtkIndent indent);
00092
00094   void AddPart(vtkProp3D *);
00095
00097   void RemovePart(vtkProp3D *);
00098
00100   vtkProp3DCollection *GetParts();
00101
00103
00106   void GetActors(vtkPropCollection *);
00107   void GetVolumes(vtkPropCollection *);
00109
00111
00116   int RenderOpaqueGeometry(vtkViewport *ren);
00117   int RenderTranslucentGeometry(vtkViewport *ren);
00119
00123   void ReleaseGraphicsResources(vtkWindow *);
00124
00126
00136   void InitPathTraversal();
00137   vtkAssemblyPath *GetNextPath();
00138   int GetNumberOfPaths();
00140
00142
00143   void GetBounds(float bounds[6]) {this->vtkProp3D::GetBounds( bounds );};
00144   float *GetBounds();
00146
00149   unsigned long int GetMTime();
00150
00152   void ShallowCopy(vtkProp *prop);
00153
00154 //BTX
00159   void BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path);
00160 //ETX
00161
00162 protected:
00163   vtkAssembly();
00164   ~vtkAssembly();
00165
00166   // Keep a list of direct descendants of the assembly hierarchy
00167   vtkProp3DCollection *Parts;
00168
00169   // Support the BuildPaths() method. Caches last paths built for
00170   // performance.
00171   vtkTimeStamp PathTime;
00172   virtual void UpdatePaths(); //apply transformations and properties recursively
00173
00174 private:
00175   vtkAssembly(const vtkAssembly&);  // Not implemented.
00176   void operator=(const vtkAssembly&);  // Not implemented.
00177 };
00178
00180 inline vtkProp3DCollection *vtkAssembly::GetParts() {return this->Parts;}
00181
00182 #endif
00183
00184
00185
00186
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAssemblyNode.h Source File

Common/vtkAssemblyNode.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAssemblyNode.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkAssemblyNode_h
00057 #define __vtkAssemblyNode_h
00058
00059 #include "vtkObject.h"
00060 #include "vtkProp.h"
00061 #include "vtkMatrix4x4.h"
00062
00063 class VTK_COMMON_EXPORT vtkAssemblyNode : public vtkObject
00064 {
00065 public:
00067   static vtkAssemblyNode *New();
00068
00069   vtkTypeRevisionMacro(vtkAssemblyNode,vtkObject);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00074   void SetProp(vtkProp *prop);
00075   vtkGetObjectMacro(Prop, vtkProp);
00077
00079
00084   void SetMatrix(vtkMatrix4x4 *matrix);
00085   vtkGetObjectMacro(Matrix, vtkMatrix4x4);
00087
00090   virtual unsigned long GetMTime();
00091
00092 protected:
00093   vtkAssemblyNode();
00094   ~vtkAssemblyNode();
00095   vtkAssemblyNode(const vtkAssemblyNode&);
00096 private:
00097   vtkProp *Prop; //reference to vtkProp
00098   vtkMatrix4x4 *Matrix; //associated matrix
00099
00100 private:
00101   void operator=(const vtkAssemblyNode&);  // Not implemented.
00102   // Not implemented.
00103 };
00104
00105 #endif
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAssemblyPath.h Source File

Common/vtkAssemblyPath.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAssemblyPath.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkAssemblyPath_h
00040 #define __vtkAssemblyPath_h
00041
00042 #include "vtkCollection.h"
00043
00044 class vtkAssemblyNode;
00045 class vtkMatrix4x4;
00046 class vtkTransform;
00047 class vtkProp;
00048
00049 class VTK_COMMON_EXPORT vtkAssemblyPath : public vtkCollection
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkAssemblyPath,vtkCollection);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056   static vtkAssemblyPath *New();
00057
00061   void AddNode(vtkProp *p, vtkMatrix4x4 *m);
00062
00068   vtkAssemblyNode *GetNextNode();
00069
00073   vtkAssemblyNode *GetFirstNode();
00074
00077   vtkAssemblyNode *GetLastNode();
00078
00080   void DeleteLastNode();
00081
00083   void ShallowCopy(vtkAssemblyPath *path);
00084
00087   virtual unsigned long GetMTime();
00088
00089 protected:
00090   vtkAssemblyPath();
00091   ~vtkAssemblyPath();
00092
00093   void AddNode(vtkAssemblyNode *n); //Internal method adds assembly node
00094   vtkTransform *Transform; //Used to perform matrix concatentation
00095   vtkProp *TransformedProp; //A transformed prop used to do the rendering
00096
00097 private:
00098   // hide the standard AddItem from the user and the compiler.
00099   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00100
00101 private:
00102   vtkAssemblyPath(const vtkAssemblyPath&);  // Not implemented.
00103   void operator=(const vtkAssemblyPath&);  // Not implemented.
00104 };
00105
00106 #endif
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkAssemblyPaths.h Source File

Common/vtkAssemblyPaths.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAssemblyPaths.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkAssemblyPaths_h
00038 #define __vtkAssemblyPaths_h
00039
00040 #include "vtkCollection.h"
00041 #include "vtkAssemblyPath.h"
00042
00043 class vtkProp;
00044
00045 class VTK_COMMON_EXPORT vtkAssemblyPaths : public vtkCollection
00046 {
00047 public:
00048   static vtkAssemblyPaths *New();
00049   vtkTypeRevisionMacro(vtkAssemblyPaths,vtkCollection);
00050
00052   void AddItem(vtkAssemblyPath *p);
00053
00055   void RemoveItem(vtkAssemblyPath *p);
00056
00059   int IsItemPresent(vtkAssemblyPath *p);
00060
00062   vtkAssemblyPath *GetNextItem();
00063
00066   virtual unsigned long GetMTime();
00067
00068 protected:
00069   vtkAssemblyPaths() {};
00070   ~vtkAssemblyPaths() {};
00071
00072 private:
00073   // hide the standard AddItem from the user and the compiler.
00074   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00075   void RemoveItem(vtkObject *o) { this->vtkCollection::RemoveItem(o); };
00076   void RemoveItem(int i) { this->vtkCollection::RemoveItem(i); };
00077   int  IsItemPresent(vtkObject *o)
00078     { return this->vtkCollection::IsItemPresent(o);};
00079 private:
00080   vtkAssemblyPaths(const vtkAssemblyPaths&);  // Not implemented.
00081   void operator=(const vtkAssemblyPaths&);  // Not implemented.
00082 };
00083
00084 inline void vtkAssemblyPaths::AddItem(vtkAssemblyPath *p)
00085 {
00086   this->vtkCollection::AddItem((vtkObject *)p);
00087 }
00088
00089 inline void vtkAssemblyPaths::RemoveItem(vtkAssemblyPath *p)
00090 {
00091   this->vtkCollection::RemoveItem((vtkObject *)p);
00092 }
00093
00094 inline int vtkAssemblyPaths::IsItemPresent(vtkAssemblyPath *p)
00095 {
00096   return this->vtkCollection::IsItemPresent((vtkObject *)p);
00097 }
00098
00099 inline vtkAssemblyPath *vtkAssemblyPaths::GetNextItem()
00100 {
00101   return (vtkAssemblyPath *)(this->GetNextItemAsObject());
00102 }
00103
00104 #endif
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkAssignAttribute.h Source File

Graphics/vtkAssignAttribute.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAssignAttribute.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00072 #ifndef __vtkAssignAttribute_h
00073 #define __vtkAssignAttribute_h
00074
00075 #include "vtkDataSetToDataSetFilter.h"
00076
00077 class vtkFieldData;
00078
00079 class VTK_GRAPHICS_EXPORT vtkAssignAttribute : public vtkDataSetToDataSetFilter
00080 {
00081 public:
00082   vtkTypeRevisionMacro(vtkAssignAttribute,vtkDataSetToDataSetFilter);
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084
00086   static vtkAssignAttribute *New();
00087
00089   void Assign(int inputAttributeType, int attributeType, int attributeLoc);
00090
00092   void Assign(const char* fieldName, int attributeType, int attributeLoc);
00093
00095
00097   void Assign(const char* name, const char* attributeType,
00098               const char* attributeLoc);
00100
00101
00102 //BTX
00103   enum AttributeLocation
00104   {
00105     POINT_DATA=0,
00106     CELL_DATA=1
00107   };
00108 //ETX
00109
00110 protected:
00111
00112 //BTX
00113   enum FieldType
00114   {
00115     NAME,
00116     ATTRIBUTE
00117   };
00118 //ETX
00119
00120   vtkAssignAttribute();
00121   virtual ~vtkAssignAttribute();
00122
00123   void Execute();
00124
00125   char* FieldName;
00126   int FieldType;
00127   int AttributeType;
00128   int InputAttributeType;
00129   int AttributeLocation;
00130
00131   static char AttributeLocationNames[2][12];
00132   static char AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10];
00133 private:
00134   vtkAssignAttribute(const vtkAssignAttribute&);  // Not implemented.
00135   void operator=(const vtkAssignAttribute&);  // Not implemented.
00136 };
00137
00138 #endif
00139
00140
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkAttributeDataToFieldDataFilter.h Source File

Graphics/vtkAttributeDataToFieldDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAttributeDataToFieldDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkAttributeDataToFieldDataFilter_h
00054 #define __vtkAttributeDataToFieldDataFilter_h
00055
00056 #include "vtkDataSetToDataSetFilter.h"
00057
00058 class VTK_GRAPHICS_EXPORT vtkAttributeDataToFieldDataFilter : public vtkDataSetToDataSetFilter
00059 {
00060 public:
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062   vtkTypeRevisionMacro(vtkAttributeDataToFieldDataFilter,vtkDataSetToDataSetFilter);
00063
00065   static vtkAttributeDataToFieldDataFilter *New();
00066
00068
00070   vtkSetMacro(PassAttributeData,int);
00071   vtkGetMacro(PassAttributeData,int);
00072   vtkBooleanMacro(PassAttributeData,int);
00074
00075 protected:
00076   vtkAttributeDataToFieldDataFilter();
00077   ~vtkAttributeDataToFieldDataFilter() {};
00078
00079   void Execute(); //generate output data
00080
00081   int PassAttributeData;
00082 private:
00083   vtkAttributeDataToFieldDataFilter(const vtkAttributeDataToFieldDataFilter&);  // Not implemented.
00084   void operator=(const vtkAttributeDataToFieldDataFilter&);  // Not implemented.
00085 };
00086
00087 #endif
00088
00089
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkAxes.h Source File

Graphics/vtkAxes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAxes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkAxes_h
00044 #define __vtkAxes_h
00045
00046 #include "vtkPolyDataSource.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkAxes : public vtkPolyDataSource
00049 {
00050 public:
00051   static vtkAxes *New();
00052
00053   vtkTypeRevisionMacro(vtkAxes,vtkPolyDataSource);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetVector3Macro(Origin,float);
00059   vtkGetVectorMacro(Origin,float,3);
00061
00063
00064   vtkSetMacro(ScaleFactor,float);
00065   vtkGetMacro(ScaleFactor,float);
00067
00069
00070   vtkSetMacro(Symmetric,int);
00071   vtkGetMacro(Symmetric,int);
00072   vtkBooleanMacro(Symmetric,int);
00074
00076
00077   vtkSetMacro(ComputeNormals, int);
00078   vtkGetMacro(ComputeNormals, int);
00079   vtkBooleanMacro(ComputeNormals, int);
00081
00082 protected:
00083   vtkAxes();
00084   ~vtkAxes() {};
00085
00086   void Execute();
00087   // This source does not know how to generate pieces yet.
00088   int ComputeDivisionExtents(vtkDataObject *output,
00089                              int idx, int numDivisions);
00090
00091   float Origin[3];
00092   float ScaleFactor;
00093
00094   int Symmetric;
00095   int ComputeNormals;
00096 private:
00097   vtkAxes(const vtkAxes&);  // Not implemented.
00098   void operator=(const vtkAxes&);  // Not implemented.
00099 };
00100
00101 #endif
00102
00103
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkAxisActor2D.h Source File

Rendering/vtkAxisActor2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkAxisActor2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00063 #ifndef __vtkAxisActor2D_h
00064 #define __vtkAxisActor2D_h
00065
00066 #include "vtkActor2D.h"
00067 #include "vtkPolyDataMapper2D.h"
00068 #include "vtkTextMapper.h"
00069
00070 #define VTK_MAX_LABELS 25
00071
00072 class VTK_RENDERING_EXPORT vtkAxisActor2D : public vtkActor2D
00073 {
00074 public:
00075   vtkTypeRevisionMacro(vtkAxisActor2D,vtkActor2D);
00076   void PrintSelf(ostream& os, vtkIndent indent);
00077
00079   static vtkAxisActor2D *New();
00080
00082
00083   vtkViewportCoordinateMacro(Point1);
00085
00087
00090   vtkViewportCoordinateMacro(Point2);
00092
00094
00096   vtkSetVector2Macro(Range,float);
00097   vtkGetVectorMacro(Range,float,2);
00099
00101
00102   vtkSetClampMacro(NumberOfLabels, int, 2, VTK_MAX_LABELS);
00103   vtkGetMacro(NumberOfLabels, int);
00105
00107
00108   vtkSetStringMacro(LabelFormat);
00109   vtkGetStringMacro(LabelFormat);
00111
00113
00116   vtkSetMacro(AdjustLabels, int);
00117   vtkGetMacro(AdjustLabels, int);
00118   vtkBooleanMacro(AdjustLabels, int);
00120
00122
00123   vtkSetStringMacro(Title);
00124   vtkGetStringMacro(Title);
00126
00128
00129   vtkSetMacro(Bold, int);
00130   vtkGetMacro(Bold, int);
00131   vtkBooleanMacro(Bold, int);
00133
00135
00136   vtkSetMacro(Italic, int);
00137   vtkGetMacro(Italic, int);
00138   vtkBooleanMacro(Italic, int);
00140
00142
00144   vtkSetMacro(Shadow, int);
00145   vtkGetMacro(Shadow, int);
00146   vtkBooleanMacro(Shadow, int);
00148
00150
00153   vtkSetMacro(FontFamily, int);
00154   vtkGetMacro(FontFamily, int);
00155   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00156   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00157   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00159
00161
00163   vtkSetClampMacro(TickLength, int, 0, 100);
00164   vtkGetMacro(TickLength, int);
00166
00168
00171   vtkSetClampMacro(TickOffset, int, 0, 100);
00172   vtkGetMacro(TickOffset, int);
00174
00176
00177   vtkSetMacro(AxisVisibility, int);
00178   vtkGetMacro(AxisVisibility, int);
00179   vtkBooleanMacro(AxisVisibility, int);
00181
00183
00184   vtkSetMacro(TickVisibility, int);
00185   vtkGetMacro(TickVisibility, int);
00186   vtkBooleanMacro(TickVisibility, int);
00188
00190
00191   vtkSetMacro(LabelVisibility, int);
00192   vtkGetMacro(LabelVisibility, int);
00193   vtkBooleanMacro(LabelVisibility, int);
00195
00197
00198   vtkSetMacro(TitleVisibility, int);
00199   vtkGetMacro(TitleVisibility, int);
00200   vtkBooleanMacro(TitleVisibility, int);
00202
00204
00207   vtkSetClampMacro(FontFactor, float, 0.1, 2.0);
00208   vtkGetMacro(FontFactor, float);
00210
00212
00214   vtkSetClampMacro(LabelFactor, float, 0.1, 2.0);
00215   vtkGetMacro(LabelFactor, float);
00217
00219
00220   int RenderOverlay(vtkViewport* viewport);
00221   int RenderOpaqueGeometry(vtkViewport* viewport);
00222   int RenderTranslucentGeometry(vtkViewport *) {return 0;}
00224
00228   void ReleaseGraphicsResources(vtkWindow *);
00229
00231
00239   static void ComputeRange(float inRange[2], float outRange[2],
00240                            int inNumTicks, int &outNumTicks, float &interval);
00242
00244
00251   static int SetFontSize(vtkViewport *viewport, vtkTextMapper *textMapper,
00252                          int *size, float factor,
00253                          int &stringWidth, int &stringHeight);
00255
00257   void ShallowCopy(vtkProp *prop);
00258
00259 protected:
00260   vtkAxisActor2D();
00261   ~vtkAxisActor2D();
00262
00263   vtkCoordinate *Point1Coordinate;
00264   vtkCoordinate *Point2Coordinate;
00265   char  *Title;
00266   float Range[2];
00267   int   NumberOfLabels;
00268   char  *LabelFormat;
00269   int   NumberOfLabelsBuilt;
00270   int   AdjustLabels;
00271   float FontFactor;
00272   float LabelFactor;
00273   int   TickLength;
00274   int   TickOffset;
00275
00276   int   Bold;
00277   int   Italic;
00278   int   Shadow;
00279   int   FontFamily;
00280
00281   int   AxisVisibility;
00282   int   TickVisibility;
00283   int   LabelVisibility;
00284   int   TitleVisibility;
00285
00286   int   LastPoint1[2];
00287   int   LastPoint2[2];
00288
00289   int   LastSize[2];
00290   int   LastTitleFontSize;
00291   int   LastLabelFontSize;
00292
00293   virtual void BuildAxis(vtkViewport *viewport);
00294   static float ComputeStringOffset(float width, float height, float theta);
00295   static void SetOffsetPosition(float xTick[3], float theta, int stringHeight,
00296                                 int stringWidth, int offset, vtkActor2D *actor);
00297
00298   vtkTextMapper *TitleMapper;
00299   vtkActor2D    *TitleActor;
00300
00301   vtkTextMapper **LabelMappers;
00302   vtkActor2D    **LabelActors;
00303
00304   vtkPolyData         *Axis;
00305   vtkPolyDataMapper2D *AxisMapper;
00306   vtkActor2D          *AxisActor;
00307
00308   vtkTimeStamp  BuildTime;
00309 private:
00310   vtkAxisActor2D(const vtkAxisActor2D&);  // Not implemented.
00311   void operator=(const vtkAxisActor2D&);  // Not implemented.
00312 };
00313
00314
00315 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkBandedPolyDataContourFilter.h Source File

Graphics/vtkBandedPolyDataContourFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBandedPolyDataContourFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkBandedPolyDataContourFilter_h
00057 #define __vtkBandedPolyDataContourFilter_h
00058
00059 #include "vtkPolyDataToPolyDataFilter.h"
00060 #include "vtkContourValues.h"
00061
00062 #define VTK_SCALAR_MODE_INDEX 0
00063 #define VTK_SCALAR_MODE_VALUE 1
00064
00065 class VTK_GRAPHICS_EXPORT vtkBandedPolyDataContourFilter : public vtkPolyDataToPolyDataFilter
00066 {
00067 public:
00068   vtkTypeRevisionMacro(vtkBandedPolyDataContourFilter,vtkPolyDataToPolyDataFilter);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00072   static vtkBandedPolyDataContourFilter *New();
00073
00075
00079   void SetValue(int i, float value);
00080   float GetValue(int i);
00081   float *GetValues();
00082   void GetValues(float *contourValues);
00083   void SetNumberOfContours(int number);
00084   int GetNumberOfContours();
00085   void GenerateValues(int numContours, float range[2]);
00086   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00088
00090
00094   vtkSetMacro(Clipping,int);
00095   vtkGetMacro(Clipping,int);
00096   vtkBooleanMacro(Clipping,int);
00098
00100
00104   vtkSetClampMacro(ScalarMode,int,VTK_SCALAR_MODE_INDEX,VTK_SCALAR_MODE_VALUE);
00105   vtkGetMacro(ScalarMode,int);
00106   void SetScalarModeToIndex()
00107     {this->SetScalarMode(VTK_SCALAR_MODE_INDEX);}
00108   void SetScalarModeToValue()
00109     {this->SetScalarMode(VTK_SCALAR_MODE_VALUE);}
00111
00113
00117   vtkSetMacro(GenerateContourEdges,int);
00118   vtkGetMacro(GenerateContourEdges,int);
00119   vtkBooleanMacro(GenerateContourEdges,int);
00121
00123
00125   vtkPolyData *GetContourEdgesOutput()
00126     {return static_cast<vtkPolyData *>(this->Outputs[1]);}
00128
00131   unsigned long GetMTime();
00132
00133 protected:
00134   vtkBandedPolyDataContourFilter();
00135   ~vtkBandedPolyDataContourFilter();
00136
00137   void Execute();
00138
00139   int ComputeScalarIndex(float);
00140   int IsContourValue(float val);
00141   int ClipEdge(int v1, int v2, vtkPoints *pts, vtkDataArray *scalars,
00142                vtkPointData *inPD, vtkPointData *outPD);
00143   int InsertCell(vtkCellArray *cells, int npts, vtkIdType *pts,
00144                  int cellId, float s, vtkFloatArray *newS);
00145
00146   // data members
00147   vtkContourValues *ContourValues;
00148
00149   int Clipping;
00150   int ScalarMode;
00151
00152   // sorted and cleaned contour values
00153   float *ClipValues;
00154   int   NumberOfClipValues;
00155   int ClipIndex[2]; //indices outside of this range (inclusive) are clipped
00156   float ClipTolerance; //used to clean up numerical problems
00157
00158   //the second output
00159   int GenerateContourEdges;
00160
00161 private:
00162   vtkBandedPolyDataContourFilter(const vtkBandedPolyDataContourFilter&);  // Not implemented.
00163   void operator=(const vtkBandedPolyDataContourFilter&);  // Not implemented.
00164 };
00165
00167
00169 inline void vtkBandedPolyDataContourFilter::SetValue(int i, float value)
00170   {this->ContourValues->SetValue(i,value);}
00172
00174
00175 inline float vtkBandedPolyDataContourFilter::GetValue(int i)
00176   {return this->ContourValues->GetValue(i);}
00178
00180
00182 inline float *vtkBandedPolyDataContourFilter::GetValues()
00183   {return this->ContourValues->GetValues();}
00185
00187
00190 inline void vtkBandedPolyDataContourFilter::GetValues(float *contourValues)
00191   {this->ContourValues->GetValues(contourValues);}
00193
00195
00198 inline void vtkBandedPolyDataContourFilter::SetNumberOfContours(int number)
00199   {this->ContourValues->SetNumberOfContours(number);}
00201
00203
00204 inline int vtkBandedPolyDataContourFilter::GetNumberOfContours()
00205   {return this->ContourValues->GetNumberOfContours();}
00207
00209
00211 inline void vtkBandedPolyDataContourFilter::GenerateValues(int numContours,
00212                                                            float range[2])
00213   {this->ContourValues->GenerateValues(numContours, range);}
00215
00217
00219 inline void vtkBandedPolyDataContourFilter::GenerateValues(int numContours,
00220                                                            float rangeStart,
00221                                                            float rangeEnd)
00222   {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00224
00225
00226 #endif
00227
00228
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkBitArray.h Source File

Common/vtkBitArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBitArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkBitArray_h
00040 #define __vtkBitArray_h
00041
00042 #include "vtkDataArray.h"
00043
00044 class VTK_COMMON_EXPORT vtkBitArray : public vtkDataArray
00045 {
00046 public:
00047   static vtkBitArray *New();
00048   vtkTypeRevisionMacro(vtkBitArray,vtkDataArray);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00053   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00054
00056   void Initialize();
00057
00058   // satisfy vtkDataArray API
00059   vtkDataArray *MakeObject();
00060   int GetDataType() {return VTK_BIT;};
00061   int GetDataTypeSize() { return 0; }
00062
00064   void SetNumberOfTuples(const vtkIdType number);
00065
00068   float *GetTuple(const vtkIdType i);
00069
00071
00072   void GetTuple(const vtkIdType i, float * tuple);
00073   void GetTuple(const vtkIdType i, double * tuple);
00075
00077
00078   void SetTuple(const vtkIdType i, const float * tuple);
00079   void SetTuple(const vtkIdType i, const double * tuple);
00081
00083
00085   void InsertTuple(const vtkIdType i, const float * tuple);
00086   void InsertTuple(const vtkIdType i, const double * tuple);
00088
00090
00092   vtkIdType InsertNextTuple(const float * tuple);
00093   vtkIdType InsertNextTuple(const double * tuple);
00095
00100   void SetComponent(const vtkIdType i, const int j, const float c);
00101
00103   void Squeeze();
00104
00106   virtual void Resize(vtkIdType numTuples);
00107
00109   int GetValue(const vtkIdType id);
00110
00116   void SetNumberOfValues(const vtkIdType number);
00117
00120   void SetValue(const vtkIdType id, const int value);
00121
00123
00124   void InsertValue(const vtkIdType id, const int i);
00125   vtkIdType InsertNextValue(const int i);
00127
00131   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00132
00134   unsigned char *GetPointer(const vtkIdType id) {return this->Array + id/8;}
00135
00137
00140   unsigned char *WritePointer(const vtkIdType id, const vtkIdType number);
00141   void *GetVoidPointer(const vtkIdType id)
00142     {return (void *)this->GetPointer(id);};
00144
00146   void DeepCopy(vtkDataArray *da);
00147
00149
00155   void SetArray(unsigned char* array, vtkIdType size, int save);
00156   void SetVoidArray(void *array, vtkIdType size, int save)
00157     {this->SetArray((unsigned char *)array, size, save);};
00159
00160
00161 protected:
00162   vtkBitArray(vtkIdType numComp=1);
00163   ~vtkBitArray();
00164
00165   unsigned char *Array;   // pointer to data
00166   unsigned char *ResizeAndExtend(const vtkIdType sz);
00167     // function to resize data
00168
00169   int TupleSize; //used for data conversion
00170   float *Tuple;
00171
00172   int SaveUserArray;
00173
00174 private:
00175   // hide superclass' DeepCopy() from the user and the compiler
00176   void DeepCopy(vtkDataArray &da) {this->vtkDataArray::DeepCopy(&da);}
00177
00178 private:
00179   vtkBitArray(const vtkBitArray&);  // Not implemented.
00180   void operator=(const vtkBitArray&);  // Not implemented.
00181 };
00182
00183 inline unsigned char *vtkBitArray::WritePointer(const vtkIdType id,
00184                                                 const vtkIdType number)
00185 {
00186   vtkIdType newSize=id+number;
00187   if ( newSize > this->Size )
00188     {
00189     this->ResizeAndExtend(newSize);
00190     }
00191   if ( (--newSize) > this->MaxId )
00192     {
00193     this->MaxId = newSize;
00194     }
00195   return this->Array + id/8;
00196 }
00197
00198 inline void vtkBitArray::SetNumberOfValues(const vtkIdType number)
00199 {
00200   this->Allocate(number);
00201   this->MaxId = number - 1;
00202 }
00203
00204 inline void vtkBitArray::SetValue(const vtkIdType id, const int value)
00205 {
00206   if (value)
00207     {
00208     this->Array[id/8] |= (0x80 >> id%8);
00209     }
00210   else
00211     {
00212     this->Array[id/8] &= (~(0x80 >> id%8));
00213     }
00214 }
00215
00216 inline void vtkBitArray::InsertValue(const vtkIdType id, const int i)
00217 {
00218   if ( id >= this->Size )
00219     {
00220     this->ResizeAndExtend(id+1);
00221     }
00222   if (i)
00223     {
00224     this->Array[id/8] |= (0x80 >> id%8);
00225     }
00226   else
00227     {
00228     this->Array[id/8] &= (~(0x80 >> id%8));
00229     }
00230   if ( id > this->MaxId )
00231     {
00232     this->MaxId = id;
00233     }
00234 }
00235
00236 inline vtkIdType vtkBitArray::InsertNextValue(const int i)
00237 {
00238   this->InsertValue (++this->MaxId,i); return this->MaxId;
00239 }
00240
00241 inline void vtkBitArray::Squeeze() {this->ResizeAndExtend (this->MaxId+1);}
00242
00243 #endif
00244
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkBlankStructuredGrid.h Source File

Graphics/vtkBlankStructuredGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBlankStructuredGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkBlankStructuredGrid_h
00046 #define __vtkBlankStructuredGrid_h
00047
00048 #include "vtkStructuredGridToStructuredGridFilter.h"
00049
00050 class VTK_GRAPHICS_EXPORT vtkBlankStructuredGrid : public vtkStructuredGridToStructuredGridFilter
00051 {
00052 public:
00053   static vtkBlankStructuredGrid *New();
00054   vtkTypeRevisionMacro(vtkBlankStructuredGrid,vtkStructuredGridToStructuredGridFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00060   vtkSetMacro(MinBlankingValue,float);
00061   vtkGetMacro(MinBlankingValue,float);
00063
00065
00067   vtkSetMacro(MaxBlankingValue,float);
00068   vtkGetMacro(MaxBlankingValue,float);
00070
00072
00075   vtkSetStringMacro(ArrayName);
00076   vtkGetStringMacro(ArrayName);
00078
00080
00083   vtkSetMacro(ArrayId,int);
00084   vtkGetMacro(ArrayId,int);
00086
00088
00090   vtkSetClampMacro(Component,int,0,VTK_LARGE_INTEGER);
00091   vtkGetMacro(Component,int);
00093
00094 protected:
00095   vtkBlankStructuredGrid();
00096   ~vtkBlankStructuredGrid();
00097
00098   void Execute();
00099
00100   float MinBlankingValue;
00101   float MaxBlankingValue;
00102   char  *ArrayName;
00103   int   ArrayId;
00104   int   Component;
00105
00106 private:
00107   vtkBlankStructuredGrid(const vtkBlankStructuredGrid&);  // Not implemented.
00108   void operator=(const vtkBlankStructuredGrid&);  // Not implemented.
00109 };
00110
00111 #endif
00112
00113
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkBlankStructuredGridWithImage.h Source File

Graphics/vtkBlankStructuredGridWithImage.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBlankStructuredGridWithImage.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkBlankStructuredGridWithImage_h
00045 #define __vtkBlankStructuredGridWithImage_h
00046
00047 #include "vtkStructuredGridToStructuredGridFilter.h"
00048
00049 class vtkImageData;
00050
00051 class VTK_GRAPHICS_EXPORT vtkBlankStructuredGridWithImage : public vtkStructuredGridToStructuredGridFilter
00052 {
00053 public:
00054   static vtkBlankStructuredGridWithImage *New();
00055   vtkTypeRevisionMacro(vtkBlankStructuredGridWithImage,vtkStructuredGridToStructuredGridFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   void SetBlankingInput(vtkImageData *input);
00061   vtkImageData *GetBlankingInput();
00063
00064 protected:
00065   vtkBlankStructuredGridWithImage() {this->NumberOfRequiredInputs = 2;}
00066   ~vtkBlankStructuredGridWithImage() {}
00067
00068   void Execute();
00069 private:
00070   vtkBlankStructuredGridWithImage(const vtkBlankStructuredGridWithImage&);  // Not implemented.
00071   void operator=(const vtkBlankStructuredGridWithImage&);  // Not implemented.
00072 };
00073
00074 #endif
00075
00076
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkBMPReader.h Source File

IO/vtkBMPReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBMPReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkBMPReader_h
00058 #define __vtkBMPReader_h
00059
00060 #include <stdio.h>
00061 #include "vtkImageReader.h"
00062
00063 class VTK_IO_EXPORT vtkBMPReader : public vtkImageReader
00064 {
00065 public:
00066   static vtkBMPReader *New();
00067   vtkTypeRevisionMacro(vtkBMPReader,vtkImageReader);
00068
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00072
00073   vtkGetMacro(Depth,int);
00074   //Description: create a clone of this object.
00075   virtual vtkImageReader2* MakeObject() { return vtkBMPReader::New(); }
00077
00079   virtual int CanReadFile(const char* fname);
00080   // Description:
00081   // Get the file extensions for this format.
00082   // Returns a string with a space separated list of extensions in
00083   // the format .extension
00084   virtual const char* GetFileExensions()
00085     {
00086       return ".bmp";
00087     }
00089
00091
00093   virtual const char* GetDescriptiveName()
00094     {
00095       return "Windows BMP";
00096     }
00098
00099 //BTX
00101   /*! Returns the color lut. */
00102   vtkGetMacro(Colors,unsigned char *);
00104 //ETX
00105
00106 protected:
00107   vtkBMPReader();
00108   ~vtkBMPReader();
00109
00110   unsigned char *Colors;
00111   short Depth;
00112
00113   virtual void ComputeDataIncrements();
00114   virtual void ExecuteInformation();
00115   virtual void ExecuteData(vtkDataObject *out);
00116 private:
00117   vtkBMPReader(const vtkBMPReader&);  // Not implemented.
00118   void operator=(const vtkBMPReader&);  // Not implemented.
00119 };
00120 #endif
00121
00122
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkBMPWriter.h Source File

IO/vtkBMPWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBMPWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkBMPWriter_h
00039 #define __vtkBMPWriter_h
00040
00041 #include "vtkImageWriter.h"
00042
00043 class VTK_IO_EXPORT vtkBMPWriter : public vtkImageWriter
00044 {
00045 public:
00046   static vtkBMPWriter *New();
00047   vtkTypeRevisionMacro(vtkBMPWriter,vtkImageWriter);
00048
00049 protected:
00050   vtkBMPWriter();
00051   ~vtkBMPWriter() {};
00052
00053   virtual void WriteFile(ofstream *file, vtkImageData *data, int ext[6]);
00054   virtual void WriteFileHeader(ofstream *, vtkImageData *);
00055 private:
00056   vtkBMPWriter(const vtkBMPWriter&);  // Not implemented.
00057   void operator=(const vtkBMPWriter&);  // Not implemented.
00058 };
00059
00060 #endif
00061
00062
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkBooleanTexture.h Source File

Imaging/vtkBooleanTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBooleanTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00059 #ifndef __vtkBooleanTexture_h
00060 #define __vtkBooleanTexture_h
00061
00062 #include "vtkStructuredPointsSource.h"
00063
00064 class VTK_IMAGING_EXPORT vtkBooleanTexture : public vtkStructuredPointsSource
00065 {
00066 public:
00067   static vtkBooleanTexture *New();
00068
00069   vtkTypeRevisionMacro(vtkBooleanTexture,vtkStructuredPointsSource);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00074   vtkSetMacro(XSize,int);
00075   vtkGetMacro(XSize,int);
00077
00079
00080   vtkSetMacro(YSize,int);
00081   vtkGetMacro(YSize,int);
00083
00085
00086   vtkSetMacro(Thickness,int);
00087   vtkGetMacro(Thickness,int);
00089
00091
00092   vtkSetVector2Macro(InIn,unsigned char);
00093   vtkGetVectorMacro(InIn,unsigned char,2);
00095
00097
00098   vtkSetVector2Macro(InOut,unsigned char);
00099   vtkGetVectorMacro(InOut,unsigned char,2);
00101
00103
00104   vtkSetVector2Macro(OutIn,unsigned char);
00105   vtkGetVectorMacro(OutIn,unsigned char,2);
00107
00109
00110   vtkSetVector2Macro(OutOut,unsigned char);
00111   vtkGetVectorMacro(OutOut,unsigned char,2);
00113
00115
00116   vtkSetVector2Macro(OnOn,unsigned char);
00117   vtkGetVectorMacro(OnOn,unsigned char,2);
00119
00121
00122   vtkSetVector2Macro(OnIn,unsigned char);
00123   vtkGetVectorMacro(OnIn,unsigned char,2);
00125
00127
00128   vtkSetVector2Macro(OnOut,unsigned char);
00129   vtkGetVectorMacro(OnOut,unsigned char,2);
00131
00133
00134   vtkSetVector2Macro(InOn,unsigned char);
00135   vtkGetVectorMacro(InOn,unsigned char,2);
00137
00139
00140   vtkSetVector2Macro(OutOn,unsigned char);
00141   vtkGetVectorMacro(OutOn,unsigned char,2);
00143
00144 protected:
00145   vtkBooleanTexture();
00146   ~vtkBooleanTexture() {};
00147
00148   void Execute();
00149
00150   int XSize;
00151   int YSize;
00152
00153   int Thickness;
00154   unsigned char InIn[2];
00155   unsigned char InOut[2];
00156   unsigned char OutIn[2];
00157   unsigned char OutOut[2];
00158   unsigned char OnOn[2];
00159   unsigned char OnIn[2];
00160   unsigned char OnOut[2];
00161   unsigned char InOn[2];
00162   unsigned char OutOn[2];
00163
00164 private:
00165   vtkBooleanTexture(const vtkBooleanTexture&);  // Not implemented.
00166   void operator=(const vtkBooleanTexture&);  // Not implemented.
00167 };
00168
00169 #endif
00170
00171
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkBranchExtentTranslator.h Source File

Parallel/vtkBranchExtentTranslator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBranchExtentTranslator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkBranchExtentTranslator_h
00043 #define __vtkBranchExtentTranslator_h
00044
00045 #include "vtkExtentTranslator.h"
00046 #include "vtkImageData.h"
00047
00048
00049 class VTK_PARALLEL_EXPORT vtkBranchExtentTranslator : public vtkExtentTranslator
00050 {
00051 public:
00052   static vtkBranchExtentTranslator *New();
00053
00054   vtkTypeRevisionMacro(vtkBranchExtentTranslator,vtkExtentTranslator);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkSetObjectMacro(OriginalSource,vtkImageData);
00060   vtkGetObjectMacro(OriginalSource,vtkImageData);
00062
00064   int PieceToExtent();
00065
00067
00073   vtkSetMacro(AssignedPiece, int);
00074   vtkGetMacro(AssignedPiece, int);
00075   vtkSetMacro(AssignedNumberOfPieces, int);
00076   vtkGetMacro(AssignedNumberOfPieces, int);
00078
00079 protected:
00080   vtkBranchExtentTranslator();
00081   ~vtkBranchExtentTranslator();
00082
00083   vtkImageData *OriginalSource;
00084   int AssignedPiece;
00085   int AssignedNumberOfPieces;
00086 private:
00087   vtkBranchExtentTranslator(const vtkBranchExtentTranslator&);  // Not implemented.
00088   void operator=(const vtkBranchExtentTranslator&);  // Not implemented.
00089 };
00090
00091 #endif
00092
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkBrownianPoints.h Source File

Graphics/vtkBrownianPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBrownianPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkBrownianPoints_h
00039 #define __vtkBrownianPoints_h
00040
00041 #include "vtkDataSetToDataSetFilter.h"
00042
00043 class VTK_GRAPHICS_EXPORT vtkBrownianPoints : public vtkDataSetToDataSetFilter
00044 {
00045 public:
00047   static vtkBrownianPoints *New();
00048
00049   vtkTypeRevisionMacro(vtkBrownianPoints,vtkDataSetToDataSetFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetClampMacro(MinimumSpeed,float,0.0,VTK_LARGE_FLOAT);
00055   vtkGetMacro(MinimumSpeed,float);
00057
00059
00060   vtkSetClampMacro(MaximumSpeed,float,0.0,VTK_LARGE_FLOAT);
00061   vtkGetMacro(MaximumSpeed,float);
00063
00064 protected:
00065   vtkBrownianPoints();
00066   ~vtkBrownianPoints() {};
00067
00068   void Execute();
00069   float MinimumSpeed;
00070   float MaximumSpeed;
00071 private:
00072   vtkBrownianPoints(const vtkBrownianPoints&);  // Not implemented.
00073   void operator=(const vtkBrownianPoints&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkButterflySubdivisionFilter.h Source File

Graphics/vtkButterflySubdivisionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkButterflySubdivisionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkButterflySubdivisionFilter_h
00055 #define __vtkButterflySubdivisionFilter_h
00056
00057 #include "vtkInterpolatingSubdivisionFilter.h"
00058 #include "vtkIntArray.h"
00059 #include "vtkIdList.h"
00060 #include "vtkCellArray.h"
00061
00062 class VTK_GRAPHICS_EXPORT vtkButterflySubdivisionFilter : public vtkInterpolatingSubdivisionFilter
00063 {
00064 public:
00066
00067   static vtkButterflySubdivisionFilter *New();
00068   vtkTypeRevisionMacro(vtkButterflySubdivisionFilter,vtkInterpolatingSubdivisionFilter);
00070
00071  protected:
00072   vtkButterflySubdivisionFilter () {};
00073   ~vtkButterflySubdivisionFilter () {};
00074
00075  private:
00076   void GenerateSubdivisionPoints(vtkPolyData *inputDS, vtkIntArray *edgeData,
00077                                  vtkPoints *outputPts, vtkPointData *outputPD);
00078   void GenerateButterflyStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys,
00079                                 vtkIdList *stencilIds, float *weights);
00080   void GenerateLoopStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys,
00081                            vtkIdList *stencilIds, float *weights);
00082   void GenerateBoundaryStencil(vtkIdType p1, vtkIdType p2, vtkPolyData *polys,
00083                                vtkIdList *stencilIds, float *weights);
00084 private:
00085   vtkButterflySubdivisionFilter(const vtkButterflySubdivisionFilter&);  // Not implemented.
00086   void operator=(const vtkButterflySubdivisionFilter&);  // Not implemented.
00087 };
00088
00089 #endif
00090
00091
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkButtonSource.h Source File

Graphics/vtkButtonSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkButtonSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkButtonSource_h
00050 #define __vtkButtonSource_h
00051
00052 #include "vtkPolyDataSource.h"
00053
00054 #define VTK_TEXTURE_STYLE_FIT_IMAGE    0
00055 #define VTK_TEXTURE_STYLE_PROPORTIONAL 1
00056
00057 class VTK_GRAPHICS_EXPORT vtkButtonSource : public vtkPolyDataSource
00058 {
00059 public:
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061   vtkTypeRevisionMacro(vtkButtonSource,vtkPolyDataSource);
00062
00064   static vtkButtonSource *New();
00065
00067
00068   vtkSetClampMacro(Width,float,0.0,VTK_LARGE_FLOAT);
00069   vtkGetMacro(Width,float);
00071
00073
00074   vtkSetClampMacro(Height,float,0.0,VTK_LARGE_FLOAT);
00075   vtkGetMacro(Height,float);
00077
00079
00080   vtkSetClampMacro(Depth,float,0.0,VTK_LARGE_FLOAT);
00081   vtkGetMacro(Depth,float);
00083
00085
00092   vtkSetClampMacro(RadialRatio,float,1.0,VTK_LARGE_FLOAT);
00093   vtkGetMacro(RadialRatio,float);
00095
00097
00099   vtkSetClampMacro(CircumferentialResolution,int,4,VTK_LARGE_INTEGER);
00100   vtkGetMacro(CircumferentialResolution,int);
00102
00104
00106   vtkSetClampMacro(TextureResolution,int,1,VTK_LARGE_INTEGER);
00107   vtkGetMacro(TextureResolution,int);
00109
00111
00113   vtkSetClampMacro(ShoulderResolution,int,1,VTK_LARGE_INTEGER);
00114   vtkGetMacro(ShoulderResolution,int);
00116
00118
00119   vtkSetVector3Macro(Origin,float);
00120   vtkGetVectorMacro(Origin,float,3);
00122
00124
00130   vtkSetClampMacro(TextureStyle,int,VTK_TEXTURE_STYLE_FIT_IMAGE,
00131                                     VTK_TEXTURE_STYLE_PROPORTIONAL);
00132   vtkGetMacro(TextureStyle,int);
00133   void SetTextureStyleToFitImage()
00134     {this->SetTextureStyle(VTK_TEXTURE_STYLE_FIT_IMAGE);}
00135   void SetTextureStyleToProportional()
00136     {this->SetTextureStyle(VTK_TEXTURE_STYLE_PROPORTIONAL);}
00138
00140
00142   vtkSetVector2Macro(TextureDimensions,int);
00143   vtkGetVector2Macro(TextureDimensions,int);
00145
00147
00148   vtkSetVector2Macro(ShoulderTextureCoordinate,float);
00149   vtkGetVector2Macro(ShoulderTextureCoordinate,float);
00151
00153
00157   vtkSetMacro(TwoSided,int);
00158   vtkGetMacro(TwoSided,int);
00159   vtkBooleanMacro(TwoSided,int);
00161
00162 protected:
00163   vtkButtonSource();
00164   ~vtkButtonSource() {}
00165
00166   void Execute();
00167
00168   float Width;
00169   float Height;
00170   float Depth;
00171
00172   int   CircumferentialResolution;
00173   int   TextureResolution;
00174   int   ShoulderResolution;
00175
00176   float Origin[3];
00177   float ShoulderTextureCoordinate[2];
00178
00179   float RadialRatio;
00180   int TextureStyle;
00181   int TextureDimensions[2];
00182   int TwoSided;
00183
00184 private:
00185   vtkButtonSource(const vtkButtonSource&);  // Not implemented.
00186   void operator=(const vtkButtonSource&);  // Not implemented.
00187
00188   //internal variable related to axes of ellipsoid
00189   float A;
00190   float A2;
00191   float B;
00192   float B2;
00193   float C;
00194   float C2;
00195
00196   float ComputeDepth(int inTextureRegion, float x, float y, float n[3]);
00197   void InterpolateCurve(int inTextureRegion, vtkPoints *newPts, int numPts,
00198                         vtkFloatArray *normals, vtkFloatArray *tcoords,
00199                         int res, int c1StartPoint,int c1Incr,
00200                         int c2StartPoint,int s2Incr, int startPoint,int incr);
00201   void CreatePolygons(vtkCellArray *newPolys, int num, int res, int startIdx);
00202   void IntersectEllipseWithLine(float a2, float b2, float dX, float dY,
00203                                 float& xe, float& ye);
00204
00205
00206 };
00207
00208 #endif
00209
00210
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkByteSwap.h Source File

Common/vtkByteSwap.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkByteSwap.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkByteSwap_h
00041 #define __vtkByteSwap_h
00042
00043 #include "vtkObject.h"
00044
00045 class VTK_COMMON_EXPORT vtkByteSwap : public vtkObject
00046 {
00047 public:
00048   static vtkByteSwap *New();
00049   vtkTypeRevisionMacro(vtkByteSwap,vtkObject);
00050
00052
00053   static void Swap2LE(short *s);
00054   static void Swap2LE(unsigned short *s);
00056
00058
00059   static void Swap4LE(char *c);
00060   static void Swap4LE(float *p) { vtkByteSwap::Swap4LE((char *)p);};
00061   static void Swap4LE(int *i)   { vtkByteSwap::Swap4LE((char *)i);};
00062   static void Swap4LE(unsigned long *i) { vtkByteSwap::Swap4LE((char *)i);};
00063   static void Swap4LE(long *i) { vtkByteSwap::Swap4LE((char *)i);};
00065
00067
00069   static void Swap8LE(char *c);
00070   static void Swap8LE(double *d) { vtkByteSwap::Swap8LE((char *)d);};
00072
00074
00076   static void Swap2LERange(char *c,int num);
00077   static void Swap2LERange(short *i,int num)
00078   { vtkByteSwap::Swap2LERange((char *)i,num);};
00080
00082
00084   static void Swap4LERange(char *c,int num);
00085   static void Swap4LERange(unsigned char *c,int num)
00086   { vtkByteSwap::Swap4LERange((char *)c,num);};
00087   static void Swap4LERange(float *p,int num)
00088   { vtkByteSwap::Swap4LERange((char *)p,num);};
00089   static void Swap4LERange(int *i,int num)
00090   { vtkByteSwap::Swap4LERange((char *)i,num);};
00091   static void Swap4LERange(unsigned long *i,int num)
00092   { vtkByteSwap::Swap4LERange((char *)i,num);};
00094
00096
00098   static void Swap8LERange(char *c, int num);
00099   static void Swap8LERange(double *d, int num)
00100   { vtkByteSwap::Swap8LERange((char *)d, num);};
00102
00104
00105   static void Swap2BE(short *s);
00106   static void Swap2BE(unsigned short *s);
00108
00110
00112   static void Swap4BE(char *c);
00113   static void Swap4BE(float *p) { vtkByteSwap::Swap4BE((char *)p);};
00114   static void Swap4BE(int *i)   { vtkByteSwap::Swap4BE((char *)i);};
00115   static void Swap4BE(unsigned long *i) { vtkByteSwap::Swap4BE((char *)i);};
00117
00119
00121   static void Swap8BE(char *c);
00122   static void Swap8BE(double *d) { vtkByteSwap::Swap8BE((char *)d);};
00124
00126
00128   static void Swap2BERange(char *c,int num);
00129   static void Swap2BERange(short *i,int num)
00130   { vtkByteSwap::Swap2BERange((char *)i,num);};
00132
00134
00136   static void Swap4BERange(char *c,int num);
00137   static void Swap4BERange(float *p,int num)
00138   { vtkByteSwap::Swap4BERange((char *)p,num); };
00139   static void Swap4BERange(int *i,int num)
00140   { vtkByteSwap::Swap4BERange((char *)i,num); };
00141   static void Swap4BERange(unsigned long *i,int num)
00142   { vtkByteSwap::Swap4BERange((char *)i,num); };
00144
00145 #ifdef VTK_USE_64BIT_IDS
00146   static void Swap4BERange(vtkIdType *i,int num)
00147   { vtkByteSwap::Swap4BERange((char *)i,num); };
00148 #endif
00149
00151
00153   static void Swap8BERange(char *c,int num);
00154   static void Swap8BERange(double *d,int num)
00155   { vtkByteSwap::Swap8BERange((char *)d,num); };
00157
00159
00162   static void SwapWrite2BERange(char *c,int num,FILE *fp);
00163   static void SwapWrite2BERange(short *i,int num, FILE *fp)
00164   {vtkByteSwap::SwapWrite2BERange((char *)i,num,fp);};
00166
00168
00171   static void SwapWrite4BERange(char *c,int num,FILE *fp);
00172   static void SwapWrite4BERange(float *p,int num, FILE *fp)
00173   { vtkByteSwap::SwapWrite4BERange((char *)p,num,fp);};
00174   static void SwapWrite4BERange(int *i,int num,FILE *fp)
00175   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00176   static void SwapWrite4BERange(unsigned long *i,int num, FILE *fp)
00177   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00178 #ifdef VTK_USE_64BIT_IDS
00179   static void SwapWrite4BERange(vtkIdType *i,int num, FILE *fp)
00180   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00182 #endif
00183
00184
00187   static void SwapWrite8BERange(char *c,int num,FILE *fp);
00188   static void SwapWrite8BERange(double *d,int num, FILE *fp)
00189   { vtkByteSwap::SwapWrite8BERange((char *)d,num,fp);};
00191
00193
00196   static void SwapWrite2BERange(char *c,int num, ostream *fp);
00197   static void SwapWrite2BERange(short *i,int num, ostream *fp)
00198   {vtkByteSwap::SwapWrite2BERange((char *)i,num,fp);};
00200
00202
00205   static void SwapWrite4BERange(char *c,int num, ostream *fp);
00206   static void SwapWrite4BERange(float *p,int num, ostream *fp)
00207   { vtkByteSwap::SwapWrite4BERange((char *)p,num,fp);};
00208   static void SwapWrite4BERange(int *i,int num, ostream *fp)
00209   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00210   static void SwapWrite4BERange(unsigned long *i,int num, ostream *fp)
00211   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00212 #ifdef VTK_USE_64BIT_IDS
00213   static void SwapWrite4BERange(vtkIdType *i,int num, ostream *fp)
00214   { vtkByteSwap::SwapWrite4BERange((char *)i,num,fp);};
00216 #endif
00217
00218
00221   static void SwapWrite8BERange(char *c,int num, ostream *fp);
00222   static void SwapWrite8BERange(double *d,int num, ostream *fp)
00223   { vtkByteSwap::SwapWrite8BERange((char *)d,num,fp);};
00225
00228   static void SwapVoidRange(void *buffer, int numWords, int wordSize);
00229
00230
00231 protected:
00232   vtkByteSwap() {};
00233   ~vtkByteSwap() {};
00234
00235 private:
00237   static void Swap2Bytes(char* &data);
00238
00239   static void Swap4Bytes(char* &data);
00240
00241   static void Swap8Bytes(char* &data);
00242
00243 private:
00244   vtkByteSwap(const vtkByteSwap&);  // Not implemented.
00245   void operator=(const vtkByteSwap&);  // Not implemented.
00246 };
00247
00248
00249 inline void
00250 vtkByteSwap::Swap2Bytes(char* &data)
00251 {
00252   char one_byte;
00253   one_byte = data[0]; data[0] = data[1]; data[1] = one_byte;
00254 }
00255
00256 inline void
00257 vtkByteSwap::Swap4Bytes(char* &data)
00258 {
00259   char one_byte;
00260   one_byte = data[0]; data[0] = data[3]; data[3] = one_byte;
00261   one_byte = data[1]; data[1] = data[2]; data[2] = one_byte;
00262 }
00263
00264 inline void
00265 vtkByteSwap::Swap8Bytes(char* &data)
00266 {
00267   char one_byte;
00268   one_byte = data[0]; data[0] = data[7]; data[7] = one_byte;
00269   one_byte = data[1]; data[1] = data[6]; data[6] = one_byte;
00270   one_byte = data[2]; data[2] = data[5]; data[5] = one_byte;
00271   one_byte = data[3]; data[3] = data[4]; data[4] = one_byte;
00272 }
00273
00274 #endif
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkBYUReader.h Source File

IO/vtkBYUReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBYUReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkBYUReader_h
00043 #define __vtkBYUReader_h
00044
00045 #include <stdio.h>
00046 #include "vtkPolyDataSource.h"
00047
00048 class VTK_IO_EXPORT vtkBYUReader : public vtkPolyDataSource
00049 {
00050 public:
00051   static vtkBYUReader *New();
00052
00053   vtkTypeRevisionMacro(vtkBYUReader,vtkPolyDataSource);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetStringMacro(GeometryFileName);
00059   vtkGetStringMacro(GeometryFileName);
00061
00063
00064   vtkSetStringMacro(DisplacementFileName);
00065   vtkGetStringMacro(DisplacementFileName);
00067
00069
00070   vtkSetStringMacro(ScalarFileName);
00071   vtkGetStringMacro(ScalarFileName);
00073
00075
00076   vtkSetStringMacro(TextureFileName);
00077   vtkGetStringMacro(TextureFileName);
00079
00081
00082   vtkSetMacro(ReadDisplacement,int);
00083   vtkGetMacro(ReadDisplacement,int);
00084   vtkBooleanMacro(ReadDisplacement,int);
00086
00088
00089   vtkSetMacro(ReadScalar,int);
00090   vtkGetMacro(ReadScalar,int);
00091   vtkBooleanMacro(ReadScalar,int);
00093
00095
00097   vtkSetMacro(ReadTexture,int);
00098   vtkGetMacro(ReadTexture,int);
00099   vtkBooleanMacro(ReadTexture,int);
00101
00103
00104   vtkSetClampMacro(PartNumber,int,1,VTK_LARGE_INTEGER);
00105   vtkGetMacro(PartNumber,int);
00107
00108 protected:
00109   vtkBYUReader();
00110   ~vtkBYUReader();
00111
00112   void Execute();
00113   // This source does not know how to generate pieces yet.
00114   int ComputeDivisionExtents(vtkDataObject *output,
00115                              int idx, int numDivisions);
00116
00117   char *GeometryFileName;
00118   char *DisplacementFileName;
00119   char *ScalarFileName;
00120   char *TextureFileName;
00121   int ReadDisplacement;
00122   int ReadScalar;
00123   int ReadTexture;
00124   int PartNumber;
00125
00126   void ReadGeometryFile(FILE *fp, int &numPts);
00127   void ReadDisplacementFile(int numPts);
00128   void ReadScalarFile(int numPts);
00129   void ReadTextureFile(int numPts);
00130 private:
00131   vtkBYUReader(const vtkBYUReader&);  // Not implemented.
00132   void operator=(const vtkBYUReader&);  // Not implemented.
00133 };
00134
00135 #endif
00136
00137
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkBYUWriter.h Source File

IO/vtkBYUWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkBYUWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkBYUWriter_h
00045 #define __vtkBYUWriter_h
00046
00047 #include <stdio.h>
00048 #include "vtkPolyDataWriter.h"
00049 #include "vtkPolyData.h"
00050
00051 class VTK_IO_EXPORT vtkBYUWriter : public vtkPolyDataWriter
00052 {
00053 public:
00054   static vtkBYUWriter *New();
00055
00056   vtkTypeRevisionMacro(vtkBYUWriter,vtkPolyDataWriter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00061   vtkSetStringMacro(GeometryFileName);
00062   vtkGetStringMacro(GeometryFileName);
00064
00066
00067   vtkSetStringMacro(DisplacementFileName);
00068   vtkGetStringMacro(DisplacementFileName);
00070
00072
00073   vtkSetStringMacro(ScalarFileName);
00074   vtkGetStringMacro(ScalarFileName);
00076
00078
00079   vtkSetStringMacro(TextureFileName);
00080   vtkGetStringMacro(TextureFileName);
00082
00084
00085   vtkSetMacro(WriteDisplacement,int);
00086   vtkGetMacro(WriteDisplacement,int);
00087   vtkBooleanMacro(WriteDisplacement,int);
00089
00091
00092   vtkSetMacro(WriteScalar,int);
00093   vtkGetMacro(WriteScalar,int);
00094   vtkBooleanMacro(WriteScalar,int);
00096
00098
00099   vtkSetMacro(WriteTexture,int);
00100   vtkGetMacro(WriteTexture,int);
00101   vtkBooleanMacro(WriteTexture,int);
00103
00104 protected:
00105   vtkBYUWriter();
00106   ~vtkBYUWriter();
00107
00108   void WriteData();
00109
00110   char *GeometryFileName;
00111   char *DisplacementFileName;
00112   char *ScalarFileName;
00113   char *TextureFileName;
00114   int WriteDisplacement;
00115   int WriteScalar;
00116   int WriteTexture;
00117
00118   void WriteGeometryFile(FILE *fp, int numPts);
00119   void WriteDisplacementFile(int numPts);
00120   void WriteScalarFile(int numPts);
00121   void WriteTextureFile(int numPts);
00122 private:
00123   vtkBYUWriter(const vtkBYUWriter&);  // Not implemented.
00124   void operator=(const vtkBYUWriter&);  // Not implemented.
00125 };
00126
00127 #endif
00128
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCallbackCommand.h Source File

Common/vtkCallbackCommand.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCallbackCommand.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00029 #ifndef __vtkCallbackCommand_h
00030 #define __vtkCallbackCommand_h
00031
00032 #include "vtkCommand.h"
00033
00034 // a good command to use for generic function callbacks
00035 // the function should have the format
00036 // void func(vtkObject *,void *clientdata, void *calldata)
00037 class VTK_COMMON_EXPORT vtkCallbackCommand : public vtkCommand
00038 {
00039 public:
00040   static vtkCallbackCommand *New()
00041     {return new vtkCallbackCommand;};
00042
00043   void SetClientData(void *cd)
00044     {this->ClientData = cd;};
00045   void* GetClientData()
00046     {return this->ClientData; }
00047   void SetCallback(void (*f)(vtkObject *, unsigned long, void *, void *))
00048     {this->Callback = f;};
00049   void SetClientDataDeleteCallback(void (*f)(void *))
00050     {this->ClientDataDeleteCallback = f;};
00051
00052   void Execute(vtkObject *caller, unsigned long event, void *callData);
00053
00054   void *ClientData;
00055   void (*Callback)(vtkObject *, unsigned long, void *, void *);
00056   void (*ClientDataDeleteCallback)(void *);
00057 protected:
00058   vtkCallbackCommand();
00059   ~vtkCallbackCommand();
00060 };
00061
00062
00063
00064 #endif /* __vtkCallbackCommand_h */
00065
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkCamera.h Source File

Rendering/vtkCamera.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCamera.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkCamera_h
00047 #define __vtkCamera_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkTransform.h"
00051 #include "vtkPerspectiveTransform.h"
00052
00053 class vtkRenderer;
00054
00055 class VTK_RENDERING_EXPORT vtkCamera : public vtkObject
00056 {
00057  public:
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059   vtkTypeRevisionMacro(vtkCamera,vtkObject);
00060
00064   static vtkCamera *New();
00065
00067
00069   void SetPosition(double x, double y, double z);
00070   void SetPosition(const double a[3]) {
00071     this->SetPosition(a[0], a[1], a[2]); };
00072   void SetPosition(const float a[3]) {
00073     this->SetPosition(a[0], a[1], a[2]); };
00074   vtkGetVector3Macro(Position,double);
00075   void GetPosition(float a[3]) {
00076     double tmp[3]; this->GetPosition(tmp);
00077     a[0] = tmp[0]; a[1] = tmp[1]; a[2] = tmp[2]; };
00079
00081
00083   void SetFocalPoint(double x, double y, double z);
00084   void SetFocalPoint(const double a[3]) {
00085     this->SetFocalPoint(a[0], a[1], a[2]);};
00086   void SetFocalPoint(const float a[3]) {
00087     this->SetFocalPoint(a[0], a[1], a[2]);};
00088   vtkGetVector3Macro(FocalPoint,double);
00089   void GetFocalPoint(float a[3]) {
00090     double tmp[3]; this->GetFocalPoint(tmp);
00091     a[0] = tmp[0]; a[1] = tmp[1]; a[2] = tmp[2]; };
00093
00095
00097   void SetViewUp(double vx, double vy, double vz);
00098   void SetViewUp(const double a[3]) {
00099     this->SetViewUp(a[0], a[1], a[2]); }
00100   void SetViewUp(const float a[3]) {
00101     this->SetViewUp(a[0], a[1], a[2]); }
00102   vtkGetVector3Macro(ViewUp,double);
00103   void GetViewUp(float a[3]) {
00104     double tmp[3]; this->GetViewUp(tmp);
00105     a[0] = tmp[0]; a[1] = tmp[1]; a[2] = tmp[2]; };
00107
00111   void OrthogonalizeViewUp();
00112
00114
00116   void SetDistance(double);
00117   vtkGetMacro(Distance,double);
00119
00121
00124   vtkGetVector3Macro(DirectionOfProjection,double);
00125   void GetDirectionOfProjection(float a[3]) {
00126     double tmp[3]; this->GetDirectionOfProjection(tmp);
00127     a[0] = tmp[0]; a[1] = tmp[1]; a[2] = tmp[2]; };
00129
00133   void Dolly(double distance);
00134
00136
00137   void SetRoll(double angle);
00138   double GetRoll();
00140
00142   void Roll(double angle);
00143
00147   void Azimuth(double angle);
00148
00152   void Yaw(double angle);
00153
00156   void Elevation(double angle);
00157
00160   void Pitch(double angle);
00161
00163
00166   void SetParallelProjection(int flag);
00167   vtkGetMacro(ParallelProjection,int);
00168   vtkBooleanMacro(ParallelProjection,int);
00170
00172
00179   void SetViewAngle(double angle);
00180   vtkGetMacro(ViewAngle,double);
00182
00184
00189   void SetParallelScale(double scale);
00190   vtkGetMacro(ParallelScale,double);
00192
00197   void Zoom(double factor);
00198
00200
00207   void SetClippingRange(double near, double far);
00208   void SetClippingRange(const double a[2]) {
00209     this->SetClippingRange(a[0], a[1]); };
00210   void SetClippingRange(const float a[2]) {
00211     this->SetClippingRange(a[0], a[1]); };
00212   vtkGetVector2Macro(ClippingRange,double);
00213   void GetClippingRange(float a[2]) {
00214     double tmp[2]; this->GetClippingRange(tmp);
00215     a[0] = tmp[0]; a[1] = tmp[1]; };
00217
00219
00222   void SetThickness(double);
00223   vtkGetMacro(Thickness,double);
00225
00227
00232   void SetWindowCenter(double x, double y);
00233   vtkGetVector2Macro(WindowCenter,double);
00235
00244   void SetObliqueAngles(double alpha, double beta);
00245
00249   void ApplyTransform(vtkTransform *t);
00250
00252
00255   vtkGetVector3Macro(ViewPlaneNormal,double);
00256   void GetViewPlaneNormal(float a[3]) {
00257     double tmp[3]; this->GetViewPlaneNormal(tmp);
00258     a[0] = tmp[0]; a[1] = tmp[1]; a[2] = tmp[2]; };
00260
00261
00263
00267   void SetViewShear(double dxdz, double dydz, double center);
00268   void SetViewShear(double d[3]);
00269   vtkGetVector3Macro(ViewShear, double);
00271
00273
00275   vtkSetMacro(EyeAngle,double);
00276   vtkGetMacro(EyeAngle,double);
00278
00280
00284   vtkSetMacro(FocalDisk,double);
00285   vtkGetMacro(FocalDisk,double);
00287
00289
00290   vtkMatrix4x4 *GetViewTransformMatrix() {
00291     return this->ViewTransform->GetMatrix(); };
00293
00295
00300   vtkMatrix4x4 *GetPerspectiveTransformMatrix(double aspect,
00301                                               double nearz,
00302                                               double farz);
00304
00306
00312   vtkMatrix4x4 *GetCompositePerspectiveTransformMatrix(double aspect,
00313                                                        double nearz,
00314                                                        double farz);
00316
00320   virtual void Render(vtkRenderer *) {};
00321
00324   unsigned long GetViewingRaysMTime();
00325
00328   void ViewingRaysModified();
00329
00335   void GetFrustumPlanes(float aspect, float planes[24]);
00336
00338
00339   float *GetOrientation() {
00340     return this->ViewTransform->GetOrientation(); };
00341   float *GetOrientationWXYZ() {
00342     return this->ViewTransform->GetOrientationWXYZ(); };
00344
00346
00349   void SetViewPlaneNormal(double x, double y, double z);
00350   void SetViewPlaneNormal(const double a[3]) {
00351     this->SetViewPlaneNormal(a[0], a[1], a[2]); };
00352   void SetViewPlaneNormal(const float a[3]) {
00353     this->SetViewPlaneNormal(a[0], a[1], a[2]); };
00355
00358   void ComputeViewPlaneNormal();
00359
00363   vtkMatrix4x4 *GetCameraLightTransformMatrix();
00364
00366   virtual void UpdateViewport(vtkRenderer *vtkNotUsed(ren)) {}
00367
00368 #ifndef VTK_REMOVE_LEGACY_CODE
00369
00370
00371   vtkMatrix4x4 &GetViewTransform()
00372     {VTK_LEGACY_METHOD(GetViewTransformMatrix,"3.2"); return *this->GetViewTransformMatrix();}
00373   vtkMatrix4x4 &GetPerspectiveTransform(double aspect,double nearz,double farz)
00374     {VTK_LEGACY_METHOD(GetPerspectiveTransformMatrix,"3.2"); return *this->GetPerspectiveTransformMatrix(aspect, nearz, farz);}
00375   vtkMatrix4x4 &GetCompositePerspectiveTransform(double aspect, double nearz, double farz)
00376     {VTK_LEGACY_METHOD(GetCompositePerspectiveTransformMatrix,"3.2"); return *this->GetCompositePerspectiveTransformMatrix(aspect,nearz,farz);}
00378 #endif
00379
00380   vtkTransform *GetViewTransformObject() {return this->ViewTransform;};
00381
00382 protected:
00383   vtkCamera();
00384   ~vtkCamera();
00385
00387
00388   void ComputeDistance();
00389   void ComputeViewTransform();
00390   void ComputePerspectiveTransform(double aspect, double nearz, double farz);
00391   void ComputeCompositePerspectiveTransform(double aspect,
00392                                             double nearz, double farz);
00393   void ComputeCameraLightTransform();
00395
00396   double WindowCenter[2];
00397   double ObliqueAngles[2];
00398   double FocalPoint[3];
00399   double Position[3];
00400   double ViewUp[3];
00401   double ViewAngle;
00402   double ClippingRange[2];
00403   double EyeAngle;
00404   int    ParallelProjection;
00405   double ParallelScale;
00406   int    Stereo;
00407   int    LeftEye;
00408   double Thickness;
00409   double Distance;
00410   double DirectionOfProjection[3];
00411   double ViewPlaneNormal[3];
00412   double ViewShear[3];
00413
00414   vtkTransform *ViewTransform;
00415   vtkPerspectiveTransform *PerspectiveTransform;
00416   vtkPerspectiveTransform *Transform;
00417   vtkTransform *CameraLightTransform;
00418
00419   double FocalDisk;
00420
00421   // ViewingRaysMtime keeps track of camera modifications which will
00422   // change the calculation of viewing rays for the camera before it is
00423   // transformed to the camera's location and orientation.
00424   vtkTimeStamp ViewingRaysMTime;
00425 private:
00426   vtkCamera(const vtkCamera&);  // Not implemented.
00427   void operator=(const vtkCamera&);  // Not implemented.
00428 };
00429
00430 #endif
00431
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkCaptionActor2D.h Source File

Hybrid/vtkCaptionActor2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCaptionActor2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00066 #ifndef __vtkCaptionActor2D_h
00067 #define __vtkCaptionActor2D_h
00068
00069 #include "vtkActor2D.h"
00070 #include "vtkTextMapper.h"
00071 #include "vtkPolyData.h"
00072
00073 class vtkPolyDataMapper2D;
00074 class vtkPolyDataMapper;
00075 class vtkScaledTextActor;
00076 class vtkGlyph2D;
00077 class vtkGlyph3D;
00078 class vtkAppendPolyData;
00079 class vtkActor;
00080
00081 class VTK_HYBRID_EXPORT vtkCaptionActor2D : public vtkActor2D
00082 {
00083 public:
00084   vtkTypeRevisionMacro(vtkCaptionActor2D,vtkActor2D);
00085   void PrintSelf(ostream& os, vtkIndent indent);
00086
00087   static vtkCaptionActor2D *New();
00088
00090
00092   vtkSetStringMacro(Caption);
00093   vtkGetStringMacro(Caption);
00095
00097
00100   vtkWorldCoordinateMacro(AttachmentPoint);
00102
00104
00105   vtkSetMacro(Border,int);
00106   vtkGetMacro(Border,int);
00107   vtkBooleanMacro(Border,int);
00109
00111
00113   vtkSetMacro(Leader,int);
00114   vtkGetMacro(Leader,int);
00115   vtkBooleanMacro(Leader,int);
00117
00119
00121   vtkSetMacro(ThreeDimensionalLeader,int);
00122   vtkGetMacro(ThreeDimensionalLeader,int);
00123   vtkBooleanMacro(ThreeDimensionalLeader,int);
00125
00127
00130   vtkSetObjectMacro(LeaderGlyph,vtkPolyData);
00131   vtkGetObjectMacro(LeaderGlyph,vtkPolyData);
00133
00135
00140   vtkSetClampMacro(LeaderGlyphSize,float,0.0,0.1);
00141   vtkGetMacro(LeaderGlyphSize,float);
00143
00145
00148   vtkSetClampMacro(MaximumLeaderGlyphSize,int,1,1000);
00149   vtkGetMacro(MaximumLeaderGlyphSize,int);
00151
00153
00155   vtkSetClampMacro(Padding, int, 0, 50);
00156   vtkGetMacro(Padding, int);
00158
00160
00161   vtkSetMacro(Bold, int);
00162   vtkGetMacro(Bold, int);
00163   vtkBooleanMacro(Bold, int);
00165
00167
00168   vtkSetMacro(Italic, int);
00169   vtkGetMacro(Italic, int);
00170   vtkBooleanMacro(Italic, int);
00172
00174
00176   vtkSetMacro(Shadow, int);
00177   vtkGetMacro(Shadow, int);
00178   vtkBooleanMacro(Shadow, int);
00180
00182
00185   vtkSetMacro(FontFamily, int);
00186   vtkGetMacro(FontFamily, int);
00187   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00188   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00189   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00191
00193
00195   vtkSetClampMacro(Justification,int,VTK_TEXT_LEFT,VTK_TEXT_RIGHT);
00196   vtkGetMacro(Justification,int);
00197   void SetJustificationToLeft()
00198     {this->SetJustification(VTK_TEXT_LEFT);}
00199   void SetJustificationToCentered()
00200     {this->SetJustification(VTK_TEXT_CENTERED);}
00201   void SetJustificationToRight()
00202     {this->SetJustification(VTK_TEXT_RIGHT);}
00204
00206
00208   vtkSetClampMacro(VerticalJustification,int,VTK_TEXT_BOTTOM,VTK_TEXT_TOP);
00209   vtkGetMacro(VerticalJustification,int);
00210   void SetVerticalJustificationToBottom()
00211     {this->SetVerticalJustification(VTK_TEXT_BOTTOM);}
00212   void SetVerticalJustificationToCentered()
00213     {this->SetVerticalJustification(VTK_TEXT_CENTERED);}
00214   void SetVerticalJustificationToTop()
00215     {this->SetVerticalJustification(VTK_TEXT_TOP);}
00217
00220   void ShallowCopy(vtkProp *prop);
00221
00222 //BTX
00227   virtual void ReleaseGraphicsResources(vtkWindow *);
00228
00230
00233   int RenderOpaqueGeometry(vtkViewport* viewport);
00234   int RenderTranslucentGeometry(vtkViewport* ) {return 0;}
00235   int RenderOverlay(vtkViewport* viewport);
00237 //ETX
00238
00239 protected:
00240   vtkCaptionActor2D();
00241   ~vtkCaptionActor2D();
00242
00243   vtkCoordinate *AttachmentPointCoordinate;
00244
00245   char  *Caption;
00246   int   Border;
00247   int   Leader;
00248   int   ThreeDimensionalLeader;
00249   float LeaderGlyphSize;
00250   int   MaximumLeaderGlyphSize;
00251   vtkPolyData *LeaderGlyph; //what to put on the end of the leader
00252
00253   int   Padding;
00254   int   Bold;
00255   int   Italic;
00256   int   Shadow;
00257   int   FontFamily;
00258   int   Justification;
00259   int   VerticalJustification;
00260
00261 private:
00262   vtkTextMapper      *CaptionMapper;
00263   vtkScaledTextActor *CaptionActor;
00264
00265   vtkPolyData         *BorderPolyData;
00266   vtkPolyDataMapper2D *BorderMapper;
00267   vtkActor2D          *BorderActor;
00268
00269   vtkPolyData   *HeadPolyData; //single attachment point for glyphing
00270   vtkGlyph3D    *HeadGlyph;  //for 3D leader
00271   vtkPolyData   *LeaderPolyData; //line represents the leader
00272   vtkAppendPolyData *AppendLeader; //append head and leader
00273
00274   //for 2D leader
00275   vtkCoordinate       *MapperCoordinate2D;
00276   vtkPolyDataMapper2D *LeaderMapper2D;
00277   vtkActor2D          *LeaderActor2D;
00278
00279   //for 3D leader
00280   vtkPolyDataMapper *LeaderMapper3D;
00281   vtkActor          *LeaderActor3D;
00282
00283 private:
00284   vtkCaptionActor2D(const vtkCaptionActor2D&);  // Not implemented.
00285   void operator=(const vtkCaptionActor2D&);  // Not implemented.
00286 };
00287
00288
00289 #endif
00290
00291
00292
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkCardinalSpline.h Source File

Filtering/vtkCardinalSpline.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCardinalSpline.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkCardinalSpline_h
00044 #define __vtkCardinalSpline_h
00045
00046 #include "vtkSpline.h"
00047
00048 class VTK_FILTERING_EXPORT vtkCardinalSpline : public vtkSpline
00049 {
00050 public:
00051   static vtkCardinalSpline *New();
00052
00053   vtkTypeRevisionMacro(vtkCardinalSpline,vtkSpline);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   void Compute ();
00058
00060   float Evaluate (float t);
00061
00062 protected:
00063   vtkCardinalSpline();
00064   ~vtkCardinalSpline() {};
00065
00066   void Fit1D (int n, float *x, float *y, float *w, float coefficients[][4],
00067               int leftConstraint, float leftValue, int rightConstraint, float rightValue);
00068   void FitClosed1D (int n, float *x, float *y, float *w,
00069                     float coefficients[][4]);
00070 private:
00071   vtkCardinalSpline(const vtkCardinalSpline&);  // Not implemented.
00072   void operator=(const vtkCardinalSpline&);  // Not implemented.
00073 };
00074
00075 #endif
00076
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkCastToConcrete.h Source File

Filtering/vtkCastToConcrete.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCastToConcrete.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00059 #ifndef __vtkCastToConcrete_h
00060 #define __vtkCastToConcrete_h
00061
00062 #include "vtkDataSetToDataSetFilter.h"
00063
00064 class VTK_FILTERING_EXPORT vtkCastToConcrete : public vtkDataSetToDataSetFilter
00065 {
00066
00067 public:
00068   static vtkCastToConcrete *New();
00069   vtkTypeRevisionMacro(vtkCastToConcrete,vtkDataSetToDataSetFilter);
00070
00071 protected:
00072   vtkCastToConcrete() {};
00073   ~vtkCastToConcrete() {};
00074
00075   void Execute(); //insures compatibility; satisfies abstract api in vtkFilter
00076   void ExecuteInformation();
00077 private:
00078   vtkCastToConcrete(const vtkCastToConcrete&);  // Not implemented.
00079   void operator=(const vtkCastToConcrete&);  // Not implemented.
00080 };
00081
00082 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCell3D.h Source File

Common/vtkCell3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCell3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkCell3D_h
00038 #define __vtkCell3D_h
00039
00040 #include "vtkCell.h"
00041
00042 class vtkOrderedTriangulator;
00043
00044 class VTK_COMMON_EXPORT vtkCell3D : public vtkCell
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkCell3D,vtkCell);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00055   virtual void GetEdgePoints(int edgeId, int* &pts) = 0;
00056
00062   virtual void GetFacePoints(int faceId, int* &pts) = 0;
00063
00065
00076   virtual void Clip(float value, vtkDataArray *cellScalars,
00077                     vtkPointLocator *locator, vtkCellArray *connectivity,
00078                     vtkPointData *inPd, vtkPointData *outPd,
00079                     vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00080                     int insideOut);
00082
00084   virtual int GetCellDimension() {return 3;}
00085
00086 protected:
00087   vtkCell3D():Triangulator(NULL) {}
00088   ~vtkCell3D();
00089
00090   vtkOrderedTriangulator *Triangulator;
00091
00092 private:
00093   vtkCell3D(const vtkCell3D&);  // Not implemented.
00094   void operator=(const vtkCell3D&);  // Not implemented.
00095 };
00096
00097 #endif
00098
00099
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCell.h Source File

Common/vtkCell.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCell.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkCell_h
00052 #define __vtkCell_h
00053
00054 #define VTK_CELL_SIZE 512
00055 #define VTK_TOL 1.e-05 // Tolerance for geometric calculation
00056
00057 #include "vtkObject.h"
00058 #include "vtkPoints.h"
00059 #include "vtkIdList.h"
00060
00061 // Include vtkCellType to include the defined cell types
00062 #include "vtkCellType.h"
00063
00064 class vtkCellArray;
00065 class vtkPointLocator;
00066 class vtkPointData;
00067 class vtkCellData;
00068
00069 class VTK_COMMON_EXPORT vtkCell : public vtkObject
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkCell,vtkObject);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00077   void Initialize(int npts, vtkIdType *pts, vtkPoints *p);
00078
00081   virtual vtkCell *MakeObject() = 0;
00082
00086   virtual void ShallowCopy(vtkCell *c);
00087
00090   virtual void DeepCopy(vtkCell *c);
00091
00093   virtual int GetCellType() = 0;
00094
00096   virtual int GetCellDimension() = 0;
00097
00101   virtual int IsLinear() {return 1;}
00102
00106   virtual int IsExplicitCell() {return 0;}
00107
00109   vtkPoints *GetPoints() {return this->Points;}
00110
00112   int GetNumberOfPoints() {return this->PointIds->GetNumberOfIds();}
00113
00115   virtual int GetNumberOfEdges() = 0;
00116
00118   virtual int GetNumberOfFaces() = 0;
00119
00121   vtkIdList *GetPointIds() {return this->PointIds;}
00122
00124   vtkIdType GetPointId(int ptId) {return this->PointIds->GetId(ptId);}
00125
00127   virtual vtkCell *GetEdge(int edgeId) = 0;
00128
00130   virtual vtkCell *GetFace(int faceId) = 0;
00131
00137   virtual int CellBoundary(int subId, float pcoords[3], vtkIdList *pts) = 0;
00138
00140
00154   virtual int EvaluatePosition(float x[3], float* closestPoint,
00155                                int& subId, float pcoords[3],
00156                                float& dist2, float *weights) = 0;
00158
00160
00163   virtual void EvaluateLocation(int& subId, float pcoords[3],
00164                                 float x[3], float *weights) = 0;
00166
00168
00179   virtual void Contour(float value, vtkDataArray *cellScalars,
00180                        vtkPointLocator *locator, vtkCellArray *verts,
00181                        vtkCellArray *lines, vtkCellArray *polys,
00182                        vtkPointData *inPd, vtkPointData *outPd,
00183                        vtkCellData *inCd, vtkIdType cellId,
00184                        vtkCellData *outCd) = 0;
00186
00188
00199   virtual void Clip(float value, vtkDataArray *cellScalars,
00200                     vtkPointLocator *locator, vtkCellArray *connectivity,
00201                     vtkPointData *inPd, vtkPointData *outPd,
00202                     vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00203                     int insideOut) = 0;
00205
00207
00210   virtual int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00211                                 float x[3], float pcoords[3], int& subId) = 0;
00213
00221   virtual int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts) = 0;
00222
00224
00236   virtual void Derivatives(int subId, float pcoords[3], float *values,
00237                            int dim, float *derivs) = 0;
00239
00240
00243   void GetBounds(float bounds[6]);
00244
00245
00248   float *GetBounds();
00249
00250
00252   float GetLength2();
00253
00254
00260   virtual int GetParametricCenter(float pcoords[3]);
00261
00262
00264
00271   static char HitBBox(float bounds[6], float origin[3], float dir[3],
00272                       float coord[3], float& t);
00274
00275
00276   // left public for quick computational access
00277   vtkPoints *Points;
00278   vtkIdList *PointIds;
00279
00280 protected:
00281   vtkCell();
00282   ~vtkCell();
00283
00284   float Bounds[6];
00285 private:
00286   vtkCell(const vtkCell&);  // Not implemented.
00287   void operator=(const vtkCell&);  // Not implemented.
00288 };
00289
00290 #endif
00291
00292
Generated on Mon Mar 25 01:07:33 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCellArray.h Source File

Common/vtkCellArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkCellArray_h
00055 #define __vtkCellArray_h
00056
00057 #include "vtkIdTypeArray.h"
00058 #include "vtkCell.h"
00059
00060 class VTK_COMMON_EXPORT vtkCellArray : public vtkObject
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkCellArray,vtkObject);
00064
00066   static vtkCellArray *New();
00067
00069
00070   int Allocate(const vtkIdType sz, const int ext=1000)
00071     {return this->Ia->Allocate(sz,ext);}
00073
00075
00076   void Initialize()
00077     {this->Ia->Initialize();}
00079
00081
00082   vtkIdType GetNumberOfCells()
00083     {return this->NumberOfCells;}
00085
00087
00093   vtkIdType EstimateSize(vtkIdType numCells, int maxPtsPerCell)
00094     {return numCells*(1+maxPtsPerCell);}
00096
00100   void InitTraversal() {this->TraversalLocation=0;};
00101
00105   int GetNextCell(vtkIdType& npts, vtkIdType* &pts);
00106
00108
00109   vtkIdType GetSize()
00110     {return this->Ia->GetSize();}
00112
00114
00117   vtkIdType GetNumberOfConnectivityEntries()
00118     {return this->Ia->GetMaxId()+1;}
00120
00123   void GetCell(vtkIdType loc, vtkIdType &npts, vtkIdType* &pts);
00124
00126   vtkIdType InsertNextCell(vtkCell *cell);
00127
00130   vtkIdType InsertNextCell(vtkIdType npts, vtkIdType* pts);
00131
00134   vtkIdType InsertNextCell(vtkIdList *pts);
00135
00140   vtkIdType InsertNextCell(int npts);
00141
00144   void InsertCellPoint(vtkIdType id);
00145
00148   void UpdateCellCount(int npts);
00149
00151
00153   vtkIdType GetInsertLocation(int npts)
00154     {return (this->InsertLocation - npts - 1);};
00156
00158
00159   vtkIdType GetTraversalLocation()
00160     {return this->TraversalLocation;}
00161   void SetTraversalLocation(vtkIdType loc)
00162     {this->TraversalLocation = loc;}
00164
00166
00168   vtkIdType GetTraversalLocation(vtkIdType npts)
00169     {return(this->TraversalLocation-npts-1);}
00171
00174   void ReverseCell(vtkIdType loc);
00175
00177   void ReplaceCell(vtkIdType loc, int npts, vtkIdType *pts);
00178
00181   int GetMaxCellSize();
00182
00184
00185   vtkIdType *GetPointer()
00186     {return this->Ia->GetPointer(0);}
00188
00192   vtkIdType *WritePointer(const vtkIdType ncells, const vtkIdType size);
00193
00201   void SetCells(vtkIdType ncells, vtkIdTypeArray *cells);
00202
00204   void DeepCopy(vtkCellArray *ca);
00205
00207
00208   vtkDataArray *GetData()
00209     {return this->Ia;}
00211
00213   void Reset();
00214
00216
00217   void Squeeze()
00218     {this->Ia->Squeeze();}
00220
00227   unsigned long GetActualMemorySize();
00228
00229 protected:
00230   vtkCellArray();
00231   ~vtkCellArray();
00232
00233   vtkIdType NumberOfCells;
00234   vtkIdType InsertLocation;     //keep track of current insertion point
00235   vtkIdType TraversalLocation;   //keep track of traversal position
00236   vtkIdTypeArray *Ia;
00237 private:
00238   vtkCellArray(const vtkCellArray&);  // Not implemented.
00239   void operator=(const vtkCellArray&);  // Not implemented.
00240 };
00241
00242
00243 inline vtkIdType vtkCellArray::InsertNextCell(vtkIdType npts, vtkIdType* pts)
00244 {
00245   vtkIdType i = this->Ia->GetMaxId() + 1;
00246   vtkIdType *ptr = this->Ia->WritePointer(i, npts+1);
00247
00248   for ( *ptr++ = npts, i = 0; i < npts; i++)
00249     {
00250     *ptr++ = *pts++;
00251     }
00252
00253   this->NumberOfCells++;
00254   this->InsertLocation += npts + 1;
00255
00256   return this->NumberOfCells - 1;
00257 }
00258
00259 inline vtkIdType vtkCellArray::InsertNextCell(vtkIdList *pts)
00260 {
00261   vtkIdType npts = pts->GetNumberOfIds();
00262   vtkIdType i = this->Ia->GetMaxId() + 1;
00263   vtkIdType *ptr = this->Ia->WritePointer(i,npts+1);
00264
00265   for ( *ptr++ = npts, i = 0; i < npts; i++)
00266     {
00267     *ptr++ = pts->GetId(i);
00268     }
00269
00270   this->NumberOfCells++;
00271   this->InsertLocation += npts + 1;
00272
00273   return this->NumberOfCells - 1;
00274 }
00275
00276 inline vtkIdType vtkCellArray::InsertNextCell(int npts)
00277 {
00278   this->InsertLocation = this->Ia->InsertNextValue(npts) + 1;
00279   this->NumberOfCells++;
00280
00281   return this->NumberOfCells - 1;
00282 }
00283
00284 inline void vtkCellArray::InsertCellPoint(vtkIdType id)
00285 {
00286   this->Ia->InsertValue(this->InsertLocation++, id);
00287 }
00288
00289 inline void vtkCellArray::UpdateCellCount(int npts)
00290 {
00291   this->Ia->SetValue(this->InsertLocation-npts-1, npts);
00292 }
00293
00294 inline vtkIdType vtkCellArray::InsertNextCell(vtkCell *cell)
00295 {
00296   int npts = cell->GetNumberOfPoints();
00297   vtkIdType i = this->Ia->GetMaxId() + 1;
00298   vtkIdType *ptr = this->Ia->WritePointer(i,npts+1);
00299
00300   for ( *ptr++ = npts, i = 0; i < npts; i++)
00301     {
00302     *ptr++ = cell->PointIds->GetId(i);
00303     }
00304
00305   this->NumberOfCells++;
00306   this->InsertLocation += npts + 1;
00307
00308   return this->NumberOfCells - 1;
00309 }
00310
00311
00312 inline void vtkCellArray::Reset()
00313 {
00314   this->NumberOfCells = 0;
00315   this->InsertLocation = 0;
00316   this->TraversalLocation = 0;
00317   this->Ia->Reset();
00318 }
00319
00320
00321 inline int vtkCellArray::GetNextCell(vtkIdType& npts, vtkIdType* &pts)
00322 {
00323   if ( this->Ia->GetMaxId() >= 0 &&
00324   this->TraversalLocation <= this->Ia->GetMaxId() )
00325     {
00326     npts = this->Ia->GetValue(this->TraversalLocation++);
00327     pts = this->Ia->GetPointer(this->TraversalLocation);
00328     this->TraversalLocation += npts;
00329     return 1;
00330     }
00331   else
00332     {
00333     return 0;
00334     }
00335 }
00336
00337 inline void vtkCellArray::GetCell(vtkIdType loc, vtkIdType &npts,
00338                                   vtkIdType* &pts)
00339 {
00340   npts=this->Ia->GetValue(loc++);
00341   pts=this->Ia->GetPointer(loc);
00342 }
00343
00344
00345 inline void vtkCellArray::ReverseCell(vtkIdType loc)
00346 {
00347   int i;
00348   vtkIdType tmp;
00349   vtkIdType npts=this->Ia->GetValue(loc);
00350   vtkIdType *pts=this->Ia->GetPointer(loc+1);
00351   for (i=0; i < (npts/2); i++)
00352     {
00353     tmp = pts[i];
00354     pts[i] = pts[npts-i-1];
00355     pts[npts-i-1] = tmp;
00356     }
00357 }
00358
00359 inline void vtkCellArray::ReplaceCell(vtkIdType loc, int npts, vtkIdType *pts)
00360 {
00361   vtkIdType *oldPts=this->Ia->GetPointer(loc+1);
00362   for (int i=0; i < npts; i++)
00363     {
00364     oldPts[i] = pts[i];
00365     }
00366 }
00367
00368 inline vtkIdType *vtkCellArray::WritePointer(const vtkIdType ncells,
00369                                              const vtkIdType size)
00370 {
00371   this->NumberOfCells = ncells;
00372   this->InsertLocation = 0;
00373   this->TraversalLocation = 0;
00374   return this->Ia->WritePointer(0,size);
00375 }
00376
00377 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCellCenters.h Source File

Graphics/vtkCellCenters.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellCenters.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkCellCenters_h
00052 #define __vtkCellCenters_h
00053
00054 #include "vtkDataSetToPolyDataFilter.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkCellCenters : public vtkDataSetToPolyDataFilter
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkCellCenters,vtkDataSetToPolyDataFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063   static vtkCellCenters *New();
00064
00066
00067   vtkSetMacro(VertexCells,int);
00068   vtkGetMacro(VertexCells,int);
00069   vtkBooleanMacro(VertexCells,int);
00071
00072 protected:
00073   vtkCellCenters();
00074   ~vtkCellCenters() {};
00075
00076   void Execute();
00077
00078   int VertexCells;
00079 private:
00080   vtkCellCenters(const vtkCellCenters&);  // Not implemented.
00081   void operator=(const vtkCellCenters&);  // Not implemented.
00082 };
00083
00084 #endif
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCellData.h Source File

Common/vtkCellData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkCellData_h
00040 #define __vtkCellData_h
00041
00042 #include "vtkDataSetAttributes.h"
00043
00044 class VTK_COMMON_EXPORT vtkCellData : public vtkDataSetAttributes
00045 {
00046 public:
00047   static vtkCellData *New();
00048
00049   vtkTypeRevisionMacro(vtkCellData,vtkDataSetAttributes);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00052 protected:
00053   vtkCellData() {}; //make sure constructor and desctructor are protected
00054   ~vtkCellData() {};
00055
00056 private:
00057   vtkCellData(const vtkCellData&);  // Not implemented.
00058   void operator=(const vtkCellData&);  // Not implemented.
00059 };
00060
00061 #endif
00062
00063
00064
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCellDataToPointData.h Source File

Graphics/vtkCellDataToPointData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellDataToPointData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkCellDataToPointData_h
00049 #define __vtkCellDataToPointData_h
00050
00051 #include "vtkDataSetToDataSetFilter.h"
00052
00053 class VTK_GRAPHICS_EXPORT vtkCellDataToPointData : public vtkDataSetToDataSetFilter
00054 {
00055 public:
00056   static vtkCellDataToPointData *New();
00057   vtkTypeRevisionMacro(vtkCellDataToPointData,vtkDataSetToDataSetFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00064   vtkSetMacro(PassCellData,int);
00065   vtkGetMacro(PassCellData,int);
00066   vtkBooleanMacro(PassCellData,int);
00068
00069 protected:
00070   vtkCellDataToPointData();
00071   ~vtkCellDataToPointData() {};
00072
00073   void Execute();
00074
00075   int PassCellData;
00076 private:
00077   vtkCellDataToPointData(const vtkCellDataToPointData&);  // Not implemented.
00078   void operator=(const vtkCellDataToPointData&);  // Not implemented.
00079 };
00080
00081 #endif
00082
00083
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCellDerivatives.h Source File

Graphics/vtkCellDerivatives.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellDerivatives.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkCellDerivatives_h
00059 #define __vtkCellDerivatives_h
00060
00061 #include "vtkDataSetToDataSetFilter.h"
00062
00063 #define VTK_VECTOR_MODE_PASS_VECTORS      0
00064 #define VTK_VECTOR_MODE_COMPUTE_GRADIENT  1
00065 #define VTK_VECTOR_MODE_COMPUTE_VORTICITY 2
00066
00067 #define VTK_TENSOR_MODE_PASS_TENSORS     0
00068 #define VTK_TENSOR_MODE_COMPUTE_GRADIENT 1
00069 #define VTK_TENSOR_MODE_COMPUTE_STRAIN   2
00070
00071 class VTK_GRAPHICS_EXPORT vtkCellDerivatives : public vtkDataSetToDataSetFilter
00072 {
00073 public:
00074   vtkTypeRevisionMacro(vtkCellDerivatives,vtkDataSetToDataSetFilter);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078   static vtkCellDerivatives *New();
00079
00081
00086   vtkSetMacro(VectorMode,int);
00087   vtkGetMacro(VectorMode,int);
00088   void SetVectorModeToPassVectors()
00089     {this->SetVectorMode(VTK_VECTOR_MODE_PASS_VECTORS);};
00090   void SetVectorModeToComputeGradient()
00091     {this->SetVectorMode(VTK_VECTOR_MODE_COMPUTE_GRADIENT);};
00092   void SetVectorModeToComputeVorticity()
00093     {this->SetVectorMode(VTK_VECTOR_MODE_COMPUTE_VORTICITY);};
00094   const char *GetVectorModeAsString();
00096
00098
00103   vtkSetMacro(TensorMode,int);
00104   vtkGetMacro(TensorMode,int);
00105   void SetTensorModeToPassTensors()
00106     {this->SetTensorMode(VTK_TENSOR_MODE_PASS_TENSORS);};
00107   void SetTensorModeToComputeGradient()
00108     {this->SetTensorMode(VTK_TENSOR_MODE_COMPUTE_GRADIENT);};
00109   void SetTensorModeToComputeStrain()
00110     {this->SetTensorMode(VTK_TENSOR_MODE_COMPUTE_STRAIN);};
00111   const char *GetTensorModeAsString();
00113
00114 protected:
00115   vtkCellDerivatives();
00116   ~vtkCellDerivatives() {};
00117   void Execute();
00118
00119   int VectorMode;
00120   int TensorMode;
00121 private:
00122   vtkCellDerivatives(const vtkCellDerivatives&);  // Not implemented.
00123   void operator=(const vtkCellDerivatives&);  // Not implemented.
00124 };
00125
00126 #endif
00127
00128
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCellLinks.h Source File

Common/vtkCellLinks.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellLinks.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkCellLinks_h
00041 #define __vtkCellLinks_h
00042
00043 #include "vtkObject.h"
00044 class vtkDataSet;
00045 class vtkCellArray;
00046
00047 struct _vtkLink_s {
00048     unsigned short ncells;
00049     vtkIdType *cells;
00050 };
00051
00052 class VTK_COMMON_EXPORT vtkCellLinks : public vtkObject
00053 {
00054 public:
00055   static vtkCellLinks *New();
00056   vtkTypeRevisionMacro(vtkCellLinks,vtkObject);
00057
00060   void Allocate(vtkIdType numLinks, vtkIdType ext=1000);
00061
00063   _vtkLink_s &GetLink(vtkIdType ptId) {return this->Array[ptId];};
00064
00066   unsigned short GetNcells(vtkIdType ptId) { return this->Array[ptId].ncells;};
00067
00069   void BuildLinks(vtkDataSet *data);
00070
00072   void BuildLinks(vtkDataSet *data, vtkCellArray *Connectivity);
00073
00075   vtkIdType *GetCells(vtkIdType ptId) {return this->Array[ptId].cells;};
00076
00079   vtkIdType InsertNextPoint(int numLinks);
00080
00084   void InsertNextCellReference(vtkIdType ptId, vtkIdType cellId);
00085
00087   void DeletePoint(vtkIdType ptId);
00088
00092   void RemoveCellReference(vtkIdType cellId, vtkIdType ptId);
00093
00097   void AddCellReference(vtkIdType cellId, vtkIdType ptId);
00098
00101   void ResizeCellList(vtkIdType ptId, int size);
00102
00104   void Squeeze();
00105
00107   void Reset();
00108
00115   unsigned long GetActualMemorySize();
00116
00119   void DeepCopy(vtkCellLinks *src);
00120
00121 protected:
00122   vtkCellLinks():Array(NULL),Size(0),MaxId(-1),Extend(1000) {};
00123   ~vtkCellLinks();
00124
00126   void IncrementLinkCount(vtkIdType ptId) { this->Array[ptId].ncells++;};
00127
00128   void AllocateLinks(vtkIdType n);
00129
00131
00132   void InsertCellReference(vtkIdType ptId, unsigned short pos,
00133                            vtkIdType cellId);
00135
00136   _vtkLink_s *Array;   // pointer to data
00137   vtkIdType Size;       // allocated size of data
00138   vtkIdType MaxId;     // maximum index inserted thus far
00139   vtkIdType Extend;     // grow array by this point
00140   _vtkLink_s *Resize(vtkIdType sz);  // function to resize data
00141 private:
00142   vtkCellLinks(const vtkCellLinks&);  // Not implemented.
00143   void operator=(const vtkCellLinks&);  // Not implemented.
00144 };
00145
00146
00147 inline void vtkCellLinks::InsertCellReference(vtkIdType ptId,
00148                                               unsigned short pos,
00149                                               vtkIdType cellId)
00150 {
00151   this->Array[ptId].cells[pos] = cellId;
00152 }
00153
00154 inline void vtkCellLinks::DeletePoint(vtkIdType ptId)
00155 {
00156   this->Array[ptId].ncells = 0;
00157   delete [] this->Array[ptId].cells;
00158   this->Array[ptId].cells = NULL;
00159 }
00160
00161 inline void vtkCellLinks::InsertNextCellReference(vtkIdType ptId,
00162                                                   vtkIdType cellId)
00163 {
00164   this->Array[ptId].cells[this->Array[ptId].ncells++] = cellId;
00165 }
00166
00167 inline void vtkCellLinks::RemoveCellReference(vtkIdType cellId, vtkIdType ptId)
00168 {
00169   vtkIdType *cells=this->Array[ptId].cells;
00170   int ncells=this->Array[ptId].ncells;
00171
00172   for (int i=0; i < ncells; i++)
00173     {
00174     if (cells[i] == cellId)
00175       {
00176       for (int j=i; j < (ncells-1); j++)
00177         {
00178         cells[j] = cells[j+1];
00179         }
00180       this->Array[ptId].ncells--;
00181       break;
00182       }
00183     }
00184 }
00185
00186 inline void vtkCellLinks::AddCellReference(vtkIdType cellId, vtkIdType ptId)
00187 {
00188   this->Array[ptId].cells[this->Array[ptId].ncells++] = cellId;
00189 }
00190
00191 inline void vtkCellLinks::ResizeCellList(vtkIdType ptId, int size)
00192 {
00193   int newSize;
00194   vtkIdType *cells;
00195
00196   newSize = this->Array[ptId].ncells + size;
00197   cells = new vtkIdType[newSize];
00198   memcpy(cells, this->Array[ptId].cells,
00199          this->Array[ptId].ncells*sizeof(vtkIdType));
00200   delete [] this->Array[ptId].cells;
00201   this->Array[ptId].cells = cells;
00202 }
00203
00204 #endif
00205
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkCellLocator.h Source File

Filtering/vtkCellLocator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellLocator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkCellLocator_h
00054 #define __vtkCellLocator_h
00055
00056 #include "vtkLocator.h"
00057
00058 class vtkNeighborCells;
00059
00060 class VTK_FILTERING_EXPORT vtkCellLocator : public vtkLocator
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkCellLocator,vtkLocator);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00068   static vtkCellLocator *New();
00069
00071
00072   vtkSetClampMacro(NumberOfCellsPerBucket,int,1,VTK_LARGE_INTEGER);
00073   vtkGetMacro(NumberOfCellsPerBucket,int);
00075
00077
00082   vtkSetMacro(CacheCellBounds,int);
00083   vtkGetMacro(CacheCellBounds,int);
00084   vtkBooleanMacro(CacheCellBounds,int);
00086
00088
00090   virtual int IntersectWithLine(float a0[3], float a1[3], float tol,
00091                                 float& t, float x[3], float pcoords[3],
00092                                 int &subId);
00094
00096
00098   virtual int IntersectWithLine(float a0[3], float a1[3], float tol,
00099                                 float& t, float x[3], float pcoords[3],
00100                                 int &subId, vtkIdType &cellId);
00102
00104
00107   virtual int IntersectWithLine(float a0[3], float a1[3], float tol,
00108                                 float& t, float x[3], float pcoords[3],
00109                                 int &subId, vtkIdType &cellId,
00110                                 vtkGenericCell *cell);
00112
00114
00117   void FindClosestPoint(float x[3], float closestPoint[3], vtkIdType &cellId,
00118                         int &subId, float& dist2);
00120
00122
00131   void FindClosestPoint(float x[3], float closestPoint[3],
00132                         vtkGenericCell *cell, vtkIdType &cellId, int &subId,
00133                         float& dist2);
00135
00137
00143   int FindClosestPointWithinRadius(float x[3], float radius,
00144                                    float closestPoint[3], vtkIdType &cellId,
00145                                    int &subId, float& dist2);
00147
00149
00162   int FindClosestPointWithinRadius(float x[3], float radius,
00163                                    float closestPoint[3],
00164                                    vtkGenericCell *cell, vtkIdType &cellId,
00165                                    int &subId, float& dist2);
00167
00169
00184   int FindClosestPointWithinRadius(float x[3], float radius,
00185                                    float closestPoint[3],
00186                                    vtkGenericCell *cell, vtkIdType &cellId,
00187                                    int &subId, float& dist2, int &inside);
00189
00191   virtual vtkIdList *GetCells(int bucket);
00192
00195   virtual int GetNumberOfBuckets(void);
00196
00198
00199   void FreeSearchStructure();
00200   void BuildLocator();
00201   void GenerateRepresentation(int level, vtkPolyData *pd);
00203
00204 protected:
00205   vtkCellLocator();
00206   ~vtkCellLocator();
00207
00208   void GetBucketNeighbors(int ijk[3], int ndivs, int level);
00209   void GetOverlappingBuckets(float x[3], int ijk[3], float dist,
00210                              int prevMinLevel[3], int prevMaxLevel[3]);
00211
00212   void ClearCellHasBeenVisited();
00213   void ClearCellHasBeenVisited(int id);
00214
00215   float Distance2ToBucket(float x[3], int nei[3]);
00216   float Distance2ToBounds(float x[3], float bounds[6]);
00217
00218   int NumberOfCellsPerBucket; // cells per octant
00219   int NumberOfOctants; // number of octants in tree
00220   float Bounds[6]; // bounding box root octant
00221   int NumberOfParents; // number of parent octants
00222   float H[3]; // width of leaf octant in x-y-z directions
00223   int NumberOfDivisions; // number of "leaf" octant sub-divisions
00224   vtkIdList **Tree; // octree
00225
00226   void MarkParents(void*, int, int, int, int, int);
00227   void GetChildren(int idx, int level, int children[8]);
00228   int GenerateIndex(int offset, int numDivs, int i, int j, int k,
00229                     vtkIdType &idx);
00230   void GenerateFace(int face, int numDivs, int i, int j, int k,
00231                     vtkPoints *pts, vtkCellArray *polys);
00232
00233   vtkNeighborCells *Buckets;
00234   unsigned char *CellHasBeenVisited;
00235   unsigned char QueryNumber;
00236   int CacheCellBounds;
00237 //BTX - begin tcl exclude
00238   float (*CellBounds)[6];
00239 //ETX - end tcl exclude
00240 private:
00241   vtkCellLocator(const vtkCellLocator&);  // Not implemented.
00242   void operator=(const vtkCellLocator&);  // Not implemented.
00243 };
00244
00245 #endif
00246
00247
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkCellPicker.h Source File

Rendering/vtkCellPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkCellPicker_h
00046 #define __vtkCellPicker_h
00047
00048 #include "vtkPicker.h"
00049
00050 class vtkGenericCell;
00051
00052 class VTK_RENDERING_EXPORT vtkCellPicker : public vtkPicker
00053 {
00054 public:
00055   static vtkCellPicker *New();
00056   vtkTypeRevisionMacro(vtkCellPicker,vtkPicker);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00061   vtkGetMacro(CellId, vtkIdType);
00063
00065
00066   vtkGetMacro(SubId, int);
00068
00070
00072   vtkGetVectorMacro(PCoords, float,3);
00074
00075 protected:
00076   vtkCellPicker();
00077   ~vtkCellPicker();
00078
00079   vtkIdType CellId; // picked cell
00080   int SubId; // picked cell subId
00081   float PCoords[3]; // picked cell parametric coordinates
00082
00083   virtual float IntersectWithLine(float p1[3], float p2[3], float tol,
00084                                   vtkAssemblyPath *path, vtkProp3D *p,
00085                                   vtkAbstractMapper3D *m);
00086   void Initialize();
00087
00088 private:
00089   vtkGenericCell *Cell; //used to accelerate picking
00090
00091 private:
00092   vtkCellPicker(const vtkCellPicker&);  // Not implemented.
00093   void operator=(const vtkCellPicker&);  // Not implemented.
00094 };
00095
00096 #endif
00097
00098
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCellType.h Source File

Common/vtkCellType.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellType.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkCellType_h
00036 #define __vtkCellType_h
00037
00038 // To add a new cell type, define a new integer type flag here, then
00039 // create a subclass of vtkCell to implement the proper behavior. You
00040 // may have to modify the following methods: vtkDataSet (and subclasses)
00041 // GetCell() and vtkGenericCell::SetCellType(). Also, to do the job right,
00042 // you'll also have to modify the readers/writers and regression tests
00043 // (example scripts) to reflect the new cell addition.
00044
00045 // Linear cells
00046 #define VTK_EMPTY_CELL 0
00047 #define VTK_VERTEX 1
00048 #define VTK_POLY_VERTEX 2
00049 #define VTK_LINE 3
00050 #define VTK_POLY_LINE 4
00051 #define VTK_TRIANGLE 5
00052 #define VTK_TRIANGLE_STRIP 6
00053 #define VTK_POLYGON 7
00054 #define VTK_PIXEL 8
00055 #define VTK_QUAD 9
00056 #define VTK_TETRA 10
00057 #define VTK_VOXEL 11
00058 #define VTK_HEXAHEDRON 12
00059 #define VTK_WEDGE 13
00060 #define VTK_PYRAMID 14
00061
00062 // Higher order, isoparametric cells
00063 #define VTK_QUADRATIC_EDGE     21
00064 #define VTK_QUADRATIC_TRIANGLE 22
00065 #define VTK_QUADRATIC_TETRA    23
00066
00067 // Parametric splines and such
00068 #define VTK_PARAMETRIC_CURVE 51
00069 #define VTK_PARAMETRIC_SURFACE 52
00070
00071 #endif
00072
00073
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCellTypes.h Source File

Common/vtkCellTypes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCellTypes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkCellTypes_h
00052 #define __vtkCellTypes_h
00053
00054 #include "vtkObject.h"
00055 #include "vtkCellType.h"
00056 #include "vtkIntArray.h"
00057 #include "vtkUnsignedCharArray.h"
00058
00059
00060 class VTK_COMMON_EXPORT vtkCellTypes : public vtkObject
00061 {
00062 public:
00063   static vtkCellTypes *New();
00064   vtkTypeRevisionMacro(vtkCellTypes,vtkObject);
00065
00067   int Allocate(int sz=512, int ext=1000);
00068
00070   void InsertCell(int id, unsigned char type, int loc);
00071
00073   int InsertNextCell(unsigned char type, int loc);
00074
00076   void SetCellTypes(int ncells, vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations);
00077
00079   int GetCellLocation(int cellId) { return this->LocationArray->GetValue(cellId);};
00080
00082   void DeleteCell(int cellId) { this->TypeArray->SetValue(cellId, VTK_EMPTY_CELL);};
00083
00085   int GetNumberOfTypes() { return (this->MaxId + 1);};
00086
00088   int IsType(unsigned char type);
00089
00092   int InsertNextType(unsigned char type){return this->InsertNextCell(type,-1);};
00093
00095   unsigned char GetCellType(int cellId) { return this->TypeArray->GetValue(cellId);};
00096
00098   void Squeeze();
00099
00101   void Reset();
00102
00109   unsigned long GetActualMemorySize();
00110
00113   void DeepCopy(vtkCellTypes *src);
00114
00115 protected:
00116   vtkCellTypes();
00117   ~vtkCellTypes();
00118
00119   vtkUnsignedCharArray *TypeArray; // pointer to types array
00120   vtkIntArray *LocationArray;   // pointer to array of offsets
00121   int Size;            // allocated size of data
00122   int MaxId;           // maximum index inserted thus far
00123   int Extend;          // grow array by this point
00124 private:
00125   vtkCellTypes(const vtkCellTypes&);  // Not implemented.
00126   void operator=(const vtkCellTypes&);    // Not implemented.
00127 };
00128
00129
00130
00131 inline int vtkCellTypes::IsType(unsigned char type)
00132 {
00133   int numTypes=this->GetNumberOfTypes();
00134
00135   for (int i=0; i<numTypes; i++)
00136     {
00137     if ( type == this->GetCellType(i))
00138       {
00139       return 1;
00140       }
00141     }
00142   return 0;
00143 }
00144
00145
00146 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkCGMWriter.h Source File

IO/vtkCGMWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCGMWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkCGMWriter_h
00048 #define __vtkCGMWriter_h
00049
00050 #include "vtkPolyDataWriter.h"
00051 #include "vtkViewport.h"
00052
00053 #define VTK_COLOR_MODE_DEFAULT 0
00054 #define VTK_COLOR_MODE_SPECIFIED_COLOR 1
00055 #define VTK_COLOR_MODE_RANDOM_COLORS 2
00056
00057 class VTK_IO_EXPORT vtkCGMWriter : public vtkPolyDataWriter
00058 {
00059 public:
00062   static vtkCGMWriter *New() {return new vtkCGMWriter;};
00063
00064   vtkTypeRevisionMacro(vtkCGMWriter,vtkPolyDataWriter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068
00073   vtkSetObjectMacro(Viewport, vtkViewport);
00074   vtkGetObjectMacro(Viewport, vtkViewport);
00076
00078
00081   vtkSetMacro(Sort,int);
00082   vtkGetMacro(Sort,int);
00084
00086
00088   vtkSetClampMacro(Resolution, int, 100, VTK_LARGE_INTEGER);
00089   vtkGetMacro(Resolution, int);
00091
00093
00102   vtkSetMacro(ColorMode,int);
00103   vtkGetMacro(ColorMode,int);
00104   void SetColorModeToDefault() {
00105     this->SetColorMode(VTK_COLOR_MODE_DEFAULT);};
00106   void SetColorModeToSpecifiedColor() {
00107     this->SetColorMode(VTK_COLOR_MODE_SPECIFIED_COLOR);};
00108   void SetColorModeToRandomColors() {
00109     this->SetColorMode(VTK_COLOR_MODE_RANDOM_COLORS);};
00111
00113
00118   vtkSetVector3Macro(SpecifiedColor,float);
00119   vtkGetVectorMacro(SpecifiedColor,float,3);
00121
00122 protected:
00123   vtkCGMWriter();
00124   ~vtkCGMWriter();
00125   void WriteData();
00126
00127   vtkViewport *Viewport;
00128   int         ColorMode;
00129   float       SpecifiedColor[3];
00130   int         Resolution;
00131   int         Sort;
00132
00133 private:
00134   vtkCGMWriter(const vtkCGMWriter&);  // Not implemented.
00135   void operator=(const vtkCGMWriter&);  // Not implemented.
00136 };
00137
00138 #endif
00139
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCharArray.h Source File

Common/vtkCharArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCharArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkCharArray_h
00042 #define __vtkCharArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkCharArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkCharArray *New();
00050
00051   vtkTypeRevisionMacro(vtkCharArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   vtkDataArray *MakeObject();
00063
00065   int GetDataType() {return VTK_CHAR;};
00066
00068   int GetDataTypeSize() { return sizeof(char); }
00069
00072   void SetNumberOfTuples(const vtkIdType number);
00073
00076   float *GetTuple(const vtkIdType i);
00077
00079
00080   void GetTuple(const vtkIdType i, float * tuple);
00081   void GetTuple(const vtkIdType i, double * tuple);
00083
00085
00086   void SetTuple(const vtkIdType i, const float * tuple);
00087   void SetTuple(const vtkIdType i, const double * tuple);
00089
00091
00093   void InsertTuple(const vtkIdType i, const float * tuple);
00094   void InsertTuple(const vtkIdType i, const double * tuple);
00096
00098
00100   vtkIdType InsertNextTuple(const float * tuple);
00101   vtkIdType InsertNextTuple(const double * tuple);
00103
00105   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);}
00106
00108   virtual void Resize(vtkIdType numTuples);
00109
00113   float GetComponent(const vtkIdType i, const int j);
00114
00119   void SetComponent(const vtkIdType i, const int j, const float c);
00120
00124   void InsertComponent(const vtkIdType i, const int j, const float c);
00125
00127   char GetValue(const vtkIdType id) {return this->Array[id];};
00128
00130
00132   void SetValue(const vtkIdType id, const char value)
00133     { this->Array[id] = value;}
00135
00139   void SetNumberOfValues(const vtkIdType number);
00140
00144   char *WritePointer(const vtkIdType id, const vtkIdType number);
00145
00147   void InsertValue(const vtkIdType id, const char c);
00148
00151   vtkIdType InsertNextValue(const char c);
00152
00154
00156   void *GetVoidPointer(const vtkIdType id)
00157     {return (void *)this->GetPointer(id);};
00158   char *GetPointer(const vtkIdType id) {return this->Array + id;}
00160
00162   void DeepCopy(vtkDataArray *ia);
00163
00165
00171   void SetArray(char* array, vtkIdType size, int save);
00172   void SetVoidArray(void *array, vtkIdType size, int save)
00173     {this->SetArray((char*)array, size, save);};
00175
00176 protected:
00177   vtkCharArray(vtkIdType numComp=1);
00178   ~vtkCharArray();
00179
00180   char *Array;    // pointer to data
00181   char *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00182
00183   int TupleSize; //used for data conversion
00184   float *Tuple;
00185
00186   int SaveUserArray;
00187 private:
00188   vtkCharArray(const vtkCharArray&);  // Not implemented.
00189   void operator=(const vtkCharArray&);  // Not implemented.
00190 };
00191
00192
00193 // Specify the number of values for this object to hold. Does an
00194 // allocation as well as setting the MaxId ivar. Used in conjunction with
00195 // SetValue() method for fast insertion.
00196 inline void vtkCharArray::SetNumberOfValues(const vtkIdType number)
00197 {
00198   this->Allocate(number);
00199   this->MaxId = number - 1;
00200 }
00201
00202
00203 // Get the address of a particular data index. Make sure data is allocated
00204 // for the number of items requested. Set MaxId according to the number of
00205 // data values requested.
00206 inline char *vtkCharArray::WritePointer(const vtkIdType id,
00207                                         const vtkIdType number)
00208 {
00209   vtkIdType newSize=id+number;
00210   if ( newSize > this->Size )
00211     {
00212     this->ResizeAndExtend(newSize);
00213     }
00214   if ( (--newSize) > this->MaxId )
00215     {
00216     this->MaxId = newSize;
00217     }
00218   return this->Array + id;
00219 }
00220
00221 inline void vtkCharArray::InsertValue(const vtkIdType id, const char c)
00222 {
00223   if ( id >= this->Size )
00224     {
00225     this->ResizeAndExtend(id+1);
00226     }
00227   this->Array[id] = c;
00228   if ( id > this->MaxId )
00229     {
00230     this->MaxId = id;
00231     }
00232 }
00233
00234 inline vtkIdType vtkCharArray::InsertNextValue(const char c)
00235 {
00236   this->InsertValue (++this->MaxId,c);
00237   return this->MaxId;
00238 }
00239
00240
00241 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCleanPolyData.h Source File

Graphics/vtkCleanPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCleanPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00074 #ifndef __vtkCleanPolyData_h
00075 #define __vtkCleanPolyData_h
00076
00077 #include "vtkPolyDataToPolyDataFilter.h"
00078
00079 class VTK_GRAPHICS_EXPORT vtkCleanPolyData : public vtkPolyDataToPolyDataFilter
00080 {
00081 public:
00082   static vtkCleanPolyData *New();
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084   vtkTypeRevisionMacro(vtkCleanPolyData,vtkPolyDataToPolyDataFilter);
00085
00087
00090   vtkSetMacro(ToleranceIsAbsolute,int);
00091   vtkBooleanMacro(ToleranceIsAbsolute,int);
00092   vtkGetMacro(ToleranceIsAbsolute,int);
00094
00096
00097   vtkSetClampMacro(Tolerance,float,0.0,1.0);
00098   vtkGetMacro(Tolerance,float);
00100
00102
00103   vtkSetClampMacro(AbsoluteTolerance,float,0.0,VTK_LARGE_FLOAT);
00104   vtkGetMacro(AbsoluteTolerance,float);
00106
00108
00109   vtkSetMacro(ConvertLinesToPoints,int);
00110   vtkBooleanMacro(ConvertLinesToPoints,int);
00111   vtkGetMacro(ConvertLinesToPoints,int);
00113
00115
00116   vtkSetMacro(ConvertPolysToLines,int);
00117   vtkBooleanMacro(ConvertPolysToLines,int);
00118   vtkGetMacro(ConvertPolysToLines,int);
00120
00122
00123   vtkSetMacro(ConvertStripsToPolys,int);
00124   vtkBooleanMacro(ConvertStripsToPolys,int);
00125   vtkGetMacro(ConvertStripsToPolys,int);
00127
00129
00133   vtkSetMacro(PointMerging,int);
00134   vtkGetMacro(PointMerging,int);
00135   vtkBooleanMacro(PointMerging,int);
00137
00139
00141   void SetLocator(vtkPointLocator *locator);
00142   vtkGetObjectMacro(Locator,vtkPointLocator);
00144
00146   void CreateDefaultLocator(void);
00147
00149   void ReleaseLocator(void);
00150
00152   unsigned long int GetMTime();
00153
00155   virtual void OperateOnPoint(float in[3], float out[3]);
00156
00158   virtual void OperateOnBounds(float in[6], float out[6]);
00159
00160   // This filter is difficult to stream.
00161   // To get invariant results, the whole input must be processed at once.
00162   // This flag allows the user to select whether strict piece invariance
00163   // is required.  By default it is on.  When off, the filter can stream,
00164   // but results may change.
00165   vtkSetMacro(PieceInvariant, int);
00166   vtkGetMacro(PieceInvariant, int);
00167   vtkBooleanMacro(PieceInvariant, int);
00168
00169 protected:
00170   vtkCleanPolyData();
00171  ~vtkCleanPolyData();
00172
00173   // Usual data generation method
00174   void Execute();
00175   void ExecuteInformation();
00176   virtual void ComputeInputUpdateExtents(vtkDataObject *output);
00177
00178   int   PointMerging;
00179   float Tolerance;
00180   float AbsoluteTolerance;
00181   int ConvertLinesToPoints;
00182   int ConvertPolysToLines;
00183   int ConvertStripsToPolys;
00184   int ToleranceIsAbsolute;
00185   vtkPointLocator *Locator;
00186
00187   int PieceInvariant;
00188 private:
00189   vtkCleanPolyData(const vtkCleanPolyData&);  // Not implemented.
00190   void operator=(const vtkCleanPolyData&);  // Not implemented.
00191 };
00192
00193 #endif
00194
00195
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkClipDataSet.h Source File

Graphics/vtkClipDataSet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkClipDataSet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00073 #ifndef __vtkClipDataSet_h
00074 #define __vtkClipDataSet_h
00075
00076 #include "vtkDataSetToUnstructuredGridFilter.h"
00077 #include "vtkImplicitFunction.h"
00078
00079 class VTK_GRAPHICS_EXPORT vtkClipDataSet : public vtkDataSetToUnstructuredGridFilter
00080 {
00081 public:
00082   vtkTypeRevisionMacro(vtkClipDataSet,vtkDataSetToUnstructuredGridFilter);
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084
00087   static vtkClipDataSet *New();
00088
00090
00093   vtkSetMacro(Value,float);
00094   vtkGetMacro(Value,float);
00096
00098
00103   vtkSetMacro(InsideOut,int);
00104   vtkGetMacro(InsideOut,int);
00105   vtkBooleanMacro(InsideOut,int);
00107
00109
00112   vtkSetObjectMacro(ClipFunction,vtkImplicitFunction);
00113   vtkGetObjectMacro(ClipFunction,vtkImplicitFunction);
00115
00117
00121   vtkSetMacro(GenerateClipScalars,int);
00122   vtkGetMacro(GenerateClipScalars,int);
00123   vtkBooleanMacro(GenerateClipScalars,int);
00125
00127
00129   vtkSetMacro(GenerateClippedOutput,int);
00130   vtkGetMacro(GenerateClippedOutput,int);
00131   vtkBooleanMacro(GenerateClippedOutput,int);
00133
00135   vtkUnstructuredGrid *GetClippedOutput();
00136
00138
00140   void SetLocator(vtkPointLocator *locator);
00141   vtkGetObjectMacro(Locator,vtkPointLocator);
00143
00146   void CreateDefaultLocator();
00147
00149   unsigned long GetMTime();
00150
00152
00154   vtkGetStringMacro(InputScalarsSelection);
00155   void SelectInputScalars(const char *fieldName)
00156     {this->SetInputScalarsSelection(fieldName);}
00158
00159 protected:
00160   vtkClipDataSet(vtkImplicitFunction *cf=NULL);
00161   ~vtkClipDataSet();
00162
00163   void Execute();
00164   vtkImplicitFunction *ClipFunction;
00165
00166   vtkPointLocator *Locator;
00167   int InsideOut;
00168   float Value;
00169   int GenerateClipScalars;
00170
00171   int GenerateClippedOutput;
00172
00173   char *InputScalarsSelection;
00174   vtkSetStringMacro(InputScalarsSelection);
00175
00176 private:
00177   vtkClipDataSet(const vtkClipDataSet&);  // Not implemented.
00178   void operator=(const vtkClipDataSet&);  // Not implemented.
00179 };
00180
00181 #endif
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkClipPolyData.h Source File

Graphics/vtkClipPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkClipPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00077 #ifndef __vtkClipPolyData_h
00078 #define __vtkClipPolyData_h
00079
00080 #include "vtkPolyDataToPolyDataFilter.h"
00081 #include "vtkImplicitFunction.h"
00082
00083 class VTK_GRAPHICS_EXPORT vtkClipPolyData : public vtkPolyDataToPolyDataFilter
00084 {
00085 public:
00086   vtkTypeRevisionMacro(vtkClipPolyData,vtkPolyDataToPolyDataFilter);
00087   void PrintSelf(ostream& os, vtkIndent indent);
00088
00091   static vtkClipPolyData *New();
00092
00094
00097   vtkSetMacro(Value,float);
00098   vtkGetMacro(Value,float);
00100
00102
00107   vtkSetMacro(InsideOut,int);
00108   vtkGetMacro(InsideOut,int);
00109   vtkBooleanMacro(InsideOut,int);
00111
00113
00116   vtkSetObjectMacro(ClipFunction,vtkImplicitFunction);
00117   vtkGetObjectMacro(ClipFunction,vtkImplicitFunction);
00119
00121
00125   vtkSetMacro(GenerateClipScalars,int);
00126   vtkGetMacro(GenerateClipScalars,int);
00127   vtkBooleanMacro(GenerateClipScalars,int);
00129
00131
00133   vtkSetMacro(GenerateClippedOutput,int);
00134   vtkGetMacro(GenerateClippedOutput,int);
00135   vtkBooleanMacro(GenerateClippedOutput,int);
00137
00139   vtkPolyData *GetClippedOutput();
00140
00142
00144   void SetLocator(vtkPointLocator *locator);
00145   vtkGetObjectMacro(Locator,vtkPointLocator);
00147
00150   void CreateDefaultLocator();
00151
00153   unsigned long GetMTime();
00154
00155 protected:
00156   vtkClipPolyData(vtkImplicitFunction *cf=NULL);
00157   ~vtkClipPolyData();
00158
00159   void Execute();
00160   vtkImplicitFunction *ClipFunction;
00161
00162   vtkPointLocator *Locator;
00163   int InsideOut;
00164   float Value;
00165   int GenerateClipScalars;
00166
00167   int GenerateClippedOutput;
00168 private:
00169   vtkClipPolyData(const vtkClipPolyData&);  // Not implemented.
00170   void operator=(const vtkClipPolyData&);  // Not implemented.
00171 };
00172
00173 #endif
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkClipVolume.h Source File

Graphics/vtkClipVolume.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkClipVolume.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00069 #ifndef __vtkClipVolume_h
00070 #define __vtkClipVolume_h
00071
00072 #include "vtkStructuredPointsToUnstructuredGridFilter.h"
00073 #include "vtkImplicitFunction.h"
00074
00075 class vtkMergePoints;
00076 class vtkOrderedTriangulator;
00077
00078 class VTK_GRAPHICS_EXPORT vtkClipVolume : public vtkStructuredPointsToUnstructuredGridFilter
00079 {
00080 public:
00081   vtkTypeRevisionMacro(vtkClipVolume,vtkStructuredPointsToUnstructuredGridFilter);
00082   void PrintSelf(ostream& os, vtkIndent indent);
00083
00087   static vtkClipVolume *New();
00088
00090
00093   vtkSetMacro(Value,float);
00094   vtkGetMacro(Value,float);
00096
00098
00103   vtkSetMacro(InsideOut,int);
00104   vtkGetMacro(InsideOut,int);
00105   vtkBooleanMacro(InsideOut,int);
00107
00109
00112   vtkSetObjectMacro(ClipFunction,vtkImplicitFunction);
00113   vtkGetObjectMacro(ClipFunction,vtkImplicitFunction);
00115
00117
00121   vtkSetMacro(GenerateClipScalars,int);
00122   vtkGetMacro(GenerateClipScalars,int);
00123   vtkBooleanMacro(GenerateClipScalars,int);
00125
00127
00129   vtkSetMacro(GenerateClippedOutput,int);
00130   vtkGetMacro(GenerateClippedOutput,int);
00131   vtkBooleanMacro(GenerateClippedOutput,int);
00133
00135   vtkUnstructuredGrid *GetClippedOutput();
00136
00138
00141   vtkSetClampMacro(MergeTolerance,float,0.0001,0.25);
00142   vtkGetMacro(MergeTolerance,float);
00144
00146
00148   void SetLocator(vtkPointLocator *locator);
00149   vtkGetObjectMacro(Locator,vtkPointLocator);
00151
00154   void CreateDefaultLocator();
00155
00157   unsigned long int GetMTime();
00158
00159 protected:
00160   vtkClipVolume(vtkImplicitFunction *cf=NULL);
00161   ~vtkClipVolume();
00162
00163   void Execute();
00164   void ClipVoxel(float value, vtkDataArray *cellScalars, int flip,
00165                  float origin[3], float spacing[3], vtkIdList *cellIds,
00166                  vtkPoints *cellPts, vtkPointData *inPD, vtkPointData *outPD,
00167                  vtkCellData *inCD, vtkIdType cellId, vtkCellData *outCD,
00168                  vtkCellData *clippedCD);
00169   vtkImplicitFunction *ClipFunction;
00170   vtkPointLocator *Locator;
00171   int InsideOut;
00172   float Value;
00173   int GenerateClipScalars;
00174   float MergeTolerance;
00175
00176   int GenerateClippedOutput;
00177   vtkUnstructuredGrid *ClippedOutput;
00178
00179 private:
00180   vtkUnstructuredGrid    *Mesh;
00181   vtkOrderedTriangulator *Triangulator;
00182
00183 private:
00184   vtkClipVolume(const vtkClipVolume&);  // Not implemented.
00185   void operator=(const vtkClipVolume&);  // Not implemented.
00186 };
00187
00188 #endif
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCollection.h Source File

Common/vtkCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkCollection_h
00044 #define __vtkCollection_h
00045
00046 #include "vtkObject.h"
00047
00048 //BTX - begin tcl exclude
00049 class vtkCollectionElement //;prevents pick-up by man page generator
00050 {
00051  public:
00052   vtkCollectionElement():Item(NULL),Next(NULL) {};
00053   vtkObject *Item;
00054   vtkCollectionElement *Next;
00055 };
00056 //ETX end tcl exclude
00057
00058 class VTK_COMMON_EXPORT vtkCollection : public vtkObject
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkCollection,vtkObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065   static vtkCollection *New();
00066
00068   void AddItem(vtkObject *);
00069
00071   void ReplaceItem(int i, vtkObject *);
00072
00078   void RemoveItem(int i);
00079
00083   void RemoveItem(vtkObject *);
00084
00086   void RemoveAllItems();
00087
00090   int  IsItemPresent(vtkObject *);
00091
00093   int  GetNumberOfItems();
00094
00097   void InitTraversal() { this->Current = this->Top;};
00098
00101   vtkObject *GetNextItemAsObject();
00102
00105   vtkObject *GetItemAsObject(int i);
00106
00107 protected:
00108   vtkCollection();
00109   ~vtkCollection();
00110
00111   virtual void DeleteElement(vtkCollectionElement *);
00112   int NumberOfItems;
00113   vtkCollectionElement *Top;
00114   vtkCollectionElement *Bottom;
00115   vtkCollectionElement *Current;
00116
00117 private:
00118   vtkCollection(const vtkCollection&);
00119   void operator=(const vtkCollection&);
00120 };
00121
00122
00123 inline vtkObject *vtkCollection::GetNextItemAsObject()
00124 {
00125   vtkCollectionElement *elem=this->Current;
00126
00127   if ( elem != NULL )
00128     {
00129     this->Current = elem->Next;
00130     return elem->Item;
00131     }
00132   else
00133     {
00134     return NULL;
00135     }
00136 }
00137
00138 #endif
00139
00140
00141
00142
00143
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkColorTransferFunction.h Source File

Filtering/vtkColorTransferFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkColorTransferFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkColorTransferFunction_h
00045 #define __vtkColorTransferFunction_h
00046
00047 #include "vtkScalarsToColors.h"
00048 #include "vtkPiecewiseFunction.h"
00049
00050 #define VTK_CTF_RGB   0
00051 #define VTK_CTF_HSV   1
00052
00053 class VTK_FILTERING_EXPORT vtkColorTransferFunction : public vtkScalarsToColors
00054 {
00055 public:
00056   static vtkColorTransferFunction *New();
00057   vtkTypeRevisionMacro(vtkColorTransferFunction,vtkScalarsToColors);
00058   void DeepCopy( vtkColorTransferFunction *f );
00059
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064   int GetSize() {return this->NumberOfPoints;};
00065
00067
00068   void AddRGBPoint( float x, float r, float g, float b );
00069   void AddHSVPoint( float x, float h, float s, float v );
00071
00073
00074   void AddRGBSegment( float x1, float r1, float g1, float b1,
00075                       float x2, float r2, float g2, float b2 );
00076   void AddHSVSegment( float x1, float h1, float s1, float v1,
00077                       float x2, float h2, float s2, float v2 );
00079
00081
00082   void RemovePoint( float x );
00083   void RemoveAllPoints();
00085
00087
00089   float *GetColor(float x) {
00090     return vtkScalarsToColors::GetColor(x); }
00091   void GetColor(float x, float rgb[3]);
00093
00095
00096   float GetRedValue( float x );
00097   float GetGreenValue( float x );
00098   float GetBlueValue( float x );
00100
00102   virtual unsigned char *MapValue(float v);
00103
00105
00106   vtkGetVector2Macro( Range, float );
00108
00110
00111   void GetTable( float x1, float x2, int n, float* table );
00112   const unsigned char *GetTable( float x1, float x2, int n);
00114
00119   void BuildFunctionFromTable( float x1, float x2, int size, float *table);
00120
00122
00123   vtkSetClampMacro( Clamping, int, 0, 1 );
00124   vtkGetMacro( Clamping, int );
00125   vtkBooleanMacro( Clamping, int );
00127
00129
00130   vtkSetClampMacro( ColorSpace, int, VTK_CTF_RGB, VTK_CTF_HSV );
00131   void SetColorSpaceToRGB(){this->SetColorSpace(VTK_CTF_RGB);};
00132   void SetColorSpaceToHSV(){this->SetColorSpace(VTK_CTF_HSV);};
00133   vtkGetMacro( ColorSpace, int );
00135
00137   float *GetDataPointer() {return this->Function;};
00138
00140
00141   virtual void MapScalarsThroughTable2(void *input, unsigned char *output,
00142                                      int inputDataType, int numberOfValues,
00143                                      int inputIncrement, int outputIncrement);
00145
00146 protected:
00147   vtkColorTransferFunction();
00148   ~vtkColorTransferFunction();
00149
00150   // Determines the function value outside of defined points
00151   // Zero = always return 0.0 outside of defined points
00152   // One  = clamp to the lowest value below defined points and
00153   //        highest value above defined points
00154   int Clamping;
00155
00156   // The color space in which interpolation is performed
00157   int ColorSpace;
00158
00159   // The color function
00160   float       *Function;
00161   int         FunctionSize;
00162   int         NumberOfPoints;
00163
00164   // conversion methods
00165   void RGBToHSV( float r, float g, float b, float &h, float &s, float &v );
00166   void HSVToRGB( float h, float s, float v, float &r, float &g, float &b );
00167
00168   // An evaluated color (0 to 255 RGBA A=255)
00169   unsigned char UnsignedCharRGBAValue[4];
00170
00171   // The min and max point locations for all three transfer functions
00172   float Range[2];
00173
00174   // Transfer functions for each color component
00175   // Remove after corresponding depricated methods are removed
00176   vtkPiecewiseFunction  *Red;
00177   vtkPiecewiseFunction  *Green;
00178   vtkPiecewiseFunction  *Blue;
00179   vtkTimeStamp BuildTime;
00180   unsigned char *Table;
00181   int TableSize;
00182
00184
00186   virtual void SetRange(float, float) {};
00187   void SetRange(float rng[2]) {this->SetRange(rng[0],rng[1]);};
00189
00190
00191 private:
00192   vtkColorTransferFunction(const vtkColorTransferFunction&);  // Not implemented.
00193   void operator=(const vtkColorTransferFunction&);  // Not implemented.
00194 };
00195
00196 #endif
00197
00198
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCommand.h Source File

Common/vtkCommand.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCommand.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkCommand_h
00039 #define __vtkCommand_h
00040
00041 #include "vtkWin32Header.h"
00042
00043 class vtkObject;
00044
00045 // The superclass that all commands should be subclasses of
00046 class VTK_COMMON_EXPORT vtkCommand
00047 {
00048 public:
00049   void Delete() {
00050     this->UnRegister(); }
00051
00053
00054   void Register();
00055   void Register(vtkObject *) {
00056     this->Register(); }
00058
00060
00063   void UnRegister();
00064   void UnRegister(vtkObject *) {
00065     this->UnRegister(); }
00067
00068   virtual void Execute(vtkObject *caller, unsigned long, void *callData) = 0;
00069   static const char *GetStringFromEventId(unsigned long event);
00070   static unsigned long GetEventIdFromString(const char *event);
00071
00073
00075   void SetAbortFlagPointer(int* f)  { this->AbortFlag = f;}
00076   void SetAbortFlag(int f)  { if(this->AbortFlag) *this->AbortFlag = f;}
00077   int GetAbortFlag() { return (this->AbortFlag) ? *this->AbortFlag: 0;}
00079
00080 //BTX
00081   // all the currently defined events
00082   // developers can use -- vtkCommand::UserEvent + int to
00083   // specify their own events.
00084   // if this list is adjusted, be sure to adjust vtkCommandEventStrings
00085   // in vtkCommand.cxx to match.
00086   enum EventIds {
00087     NoEvent = 0,
00088     AnyEvent,
00089     DeleteEvent,
00090     StartEvent,
00091     EndEvent,
00092     ProgressEvent,
00093     PickEvent,
00094     StartPickEvent,
00095     EndPickEvent,
00096     AbortCheckEvent,
00097     ExitEvent,
00098     LeftButtonPressEvent,
00099     LeftButtonReleaseEvent,
00100     MiddleButtonPressEvent,
00101     MiddleButtonReleaseEvent,
00102     RightButtonPressEvent,
00103     RightButtonReleaseEvent,
00104     EnterEvent,
00105     LeaveEvent,
00106     KeyPressEvent,
00107     KeyReleaseEvent,
00108     CharEvent,
00109     ConfigureEvent,
00110     TimerEvent,
00111     MouseMoveEvent,
00112     ResetCameraEvent,
00113     ResetCameraClippingRangeEvent,
00114     ModifiedEvent,
00115     WindowLevelEvent,
00116     NextDataEvent,
00117     PushDataStartEvent,
00118     SetOutputEvent,
00119     EndOfDataEvent,
00120     ErrorEvent,
00121     WarningEvent,
00122     UserEvent = 1000
00123   };
00124 //ETX
00125 protected:
00126   int* AbortFlag;
00127   int ReferenceCount;      // Number of uses of this object by other objects
00128   vtkCommand() { this->AbortFlag = 0; this->ReferenceCount = 1;};
00129   virtual ~vtkCommand() {};
00130 };
00131
00132 #endif /* __vtkCommand_h */
00133
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkCommunicator.h Source File

Parallel/vtkCommunicator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCommunicator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkCommunicator_h
00047 #define __vtkCommunicator_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkDataObject.h"
00051 #include "vtkDataArray.h"
00052
00053 class vtkDataSet;
00054 class vtkImageData;
00055
00056 class VTK_PARALLEL_EXPORT vtkCommunicator : public vtkObject
00057 {
00058
00059 public:
00060
00061   vtkTypeRevisionMacro(vtkCommunicator, vtkObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00066   virtual int Send(vtkDataObject* data, int remoteHandle, int tag);
00067
00070   virtual int Send(vtkDataArray* data, int remoteHandle, int tag);
00071
00073
00074   virtual int Send(int* data, int length, int remoteHandle, int tag) = 0;
00075   virtual int Send(unsigned long* data, int length, int remoteHandle,
00076                    int tag) = 0;
00077   virtual int Send(unsigned char* data, int length, int remoteHandle,
00078                    int tag) = 0;
00079   virtual int Send(char* data, int length, int remoteHandle,
00080                    int tag) = 0;
00081   virtual int Send(float* data, int length, int remoteHandle,
00082                    int tag) = 0;
00083   virtual int Send(double* data, int length, int remoteHandle,
00084                    int tag) = 0;
00085 #ifdef VTK_USE_64BIT_IDS
00086   virtual int Send(vtkIdType* data, int length, int remoteHandle,
00087                    int tag) = 0;
00089 #endif
00090
00091
00094   virtual int Receive(vtkDataObject* data, int remoteHandle, int tag);
00095
00098   virtual int Receive(vtkDataArray* data, int remoteHandle, int tag);
00099
00101
00103   virtual int Receive(int* data, int length, int remoteHandle,
00104                       int tag) = 0;
00105   virtual int Receive(unsigned long* data, int length, int remoteHandle,
00106                       int tag) = 0;
00107   virtual int Receive(unsigned char* data, int length, int remoteHandle,
00108                       int tag) = 0;
00109   virtual int Receive(char* data, int length, int remoteHandle,
00110                       int tag) = 0;
00111   virtual int Receive(float* data, int length, int remoteHandle,
00112                       int tag) = 0;
00113   virtual int Receive(double* data, int length, int remoteHandle,
00114                       int tag) = 0;
00115 #ifdef VTK_USE_64BIT_IDS
00116   virtual int Receive(vtkIdType* data, int length, int remoteHandle,
00117                       int tag) = 0;
00119 #endif
00120
00121 protected:
00122
00123   void DeleteAndSetMarshalString(char *str, int strLength);
00124
00125   // Write and read from marshal string
00126   // return 1 success, 0 fail
00127   int WriteObject(vtkDataObject *object);
00128   int ReadObject(vtkDataObject *object);
00129
00130   int WriteDataSet(vtkDataSet *object);
00131   int ReadDataSet(vtkDataSet *object);
00132
00133   int WriteImageData(vtkImageData *object);
00134   int ReadImageData(vtkImageData *object);
00135
00136   int WriteDataArray(vtkDataArray *object);
00137   int ReadDataArray(vtkDataArray *object);
00138
00139   vtkCommunicator();
00140   ~vtkCommunicator();
00141
00142   char *MarshalString;
00143   int MarshalStringLength;
00144   // The data may not take up all of the string.
00145   int MarshalDataLength;
00146
00147 private:
00148   vtkCommunicator(const vtkCommunicator&);  // Not implemented.
00149   void operator=(const vtkCommunicator&);  // Not implemented.
00150 };
00151
00152 #endif // __vtkCommunicator_h
00153
00154
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkCompositeManager.h Source File

Parallel/vtkCompositeManager.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCompositeManager.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkCompositeManager_h
00044 #define __vtkCompositeManager_h
00045
00046 #include "vtkObject.h"
00047 #include "vtkRenderWindow.h"
00048 #include "vtkRenderWindowInteractor.h"
00049 #include "vtkRenderer.h"
00050 #include "vtkMultiProcessController.h"
00051
00052 class vtkTimerLog;
00053
00054
00055 class VTK_PARALLEL_EXPORT vtkCompositeManager : public vtkObject
00056 {
00057 public:
00058   vtkTypeRevisionMacro(vtkCompositeManager,vtkObject);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00064   vtkGetObjectMacro(RenderWindow, vtkRenderWindow);
00065   void SetRenderWindow(vtkRenderWindow *renWin);
00067
00071   void InitializePieces();
00072
00074   void InitializeOffScreen();
00075
00077
00078   void StartInteractor();
00079   void ExitInteractor();
00080   void StartRender();
00081   void EndRender();
00082   void RenderRMI();
00083   void ResetCamera(vtkRenderer *ren);
00084   void ResetCameraClippingRange(vtkRenderer *ren);
00085   void ComputeVisiblePropBoundsRMI();
00087
00090   void InitializeRMIs();
00091
00093
00098   void SetReductionFactor(int factor);
00099   vtkGetMacro(ReductionFactor, int);
00101
00103
00106   vtkSetMacro(UseChar, int);
00107   vtkGetMacro(UseChar, int);
00108   vtkBooleanMacro(UseChar, int);
00110
00112
00113   vtkSetMacro(UseCompositing, int);
00114   vtkGetMacro(UseCompositing, int);
00115   vtkBooleanMacro(UseCompositing, int);
00117
00119
00121   vtkGetMacro(GetBuffersTime, double);
00122   vtkGetMacro(SetBuffersTime, double);
00123   vtkGetMacro(CompositeTime, double);
00124   vtkGetMacro(MaxRenderTime, double);
00126
00128   float GetZ(int x, int y);
00129
00131
00134   vtkSetObjectMacro(Controller, vtkMultiProcessController);
00135   vtkGetObjectMacro(Controller, vtkMultiProcessController);
00137
00138 //BTX
00139
00140   enum Tags {
00141     RENDER_RMI_TAG=12721,
00142     COMPUTE_VISIBLE_PROP_BOUNDS_RMI_TAG=56563,
00143     WIN_INFO_TAG=22134,
00144     REN_INFO_TAG=22135,
00145     BOUNDS_TAG=94135
00146   };
00147
00149
00152   virtual void CheckForAbortRender() {}
00153   virtual int CheckForAbortComposite() {return 0;}
00155 //ETX
00156
00158   virtual void ComputeVisiblePropBounds(vtkRenderer *ren, float bounds[6]);
00159
00161
00165   vtkSetMacro(Manual, int);
00166   vtkGetMacro(Manual, int);
00167   vtkBooleanMacro(Manual, int);
00168   void Composite();
00170
00171
00172 protected:
00173   vtkCompositeManager();
00174   ~vtkCompositeManager();
00175   vtkCompositeManager(const vtkCompositeManager&);
00176   void operator=(const vtkCompositeManager&);
00177
00178   // A compositing algorithm to be implemented by the subclass.
00179   virtual void CompositeBuffer(int width, int height, int useCharFlag,
00180                                void *pBuf, float *zBuf,
00181                                void *pTmp, float *zTmp) = 0;
00182
00183   void SetRendererSize(int x, int y);
00184   float* MagnifyBuffer(float *localPdata, int windowSize[2]);
00185
00186   vtkRenderWindow* RenderWindow;
00187   vtkRenderWindowInteractor* RenderWindowInteractor;
00188   vtkMultiProcessController* Controller;
00189
00190   unsigned long StartInteractorTag;
00191   unsigned long EndInteractorTag;
00192   unsigned long StartTag;
00193   unsigned long EndTag;
00194   unsigned long ResetCameraTag;
00195   unsigned long ResetCameraClippingRangeTag;
00196   int UseChar;
00197   int UseCompositing;
00198
00199   // Convenience method used internally. It set up the start observer
00200   // and allows the render window's interactor to be set before or after
00201   // the compositer's render window (not exactly true).
00202   void SetRenderWindowInteractor(vtkRenderWindowInteractor *iren);
00203
00204   // Arrays for compositing.
00205   float *PData;
00206   float *ZData;
00207   int RendererSize[2];
00208
00209   // Reduction factor (For fast interactive compositing).
00210   int ReductionFactor;
00211
00212   // This cause me a head ache while trying to debug a lockup.
00213   // I am taking it out in retaliation.  I do not think nested
00214   // RMI's can occur anyway.
00215   // This flag stops nested RMIs from occuring.  Some rmis send and receive information.
00216   // Nesting them can lock up the processes.
00217   int Lock;
00218
00219   double GetBuffersTime;
00220   double SetBuffersTime;
00221   double CompositeTime;
00222   double MaxRenderTime;
00223
00224   // Needed to compute the MaxRenderTime.
00225   vtkTimerLog *Timer;
00226
00227   // For manual compositing.
00228   int Manual;
00229 };
00230
00231 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkCone.h Source File

Filtering/vtkCone.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCone.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkCone_h
00049 #define __vtkCone_h
00050
00051 #include "vtkImplicitFunction.h"
00052
00053 class VTK_FILTERING_EXPORT vtkCone : public vtkImplicitFunction
00054 {
00055 public:
00057   static vtkCone *New();
00058
00059   vtkTypeRevisionMacro(vtkCone,vtkImplicitFunction);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   float EvaluateFunction(float x[3]);
00065   float EvaluateFunction(float x, float y, float z)
00066     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00068
00070   void EvaluateGradient(float x[3], float g[3]);
00071
00073
00074   vtkSetClampMacro(Angle,float,0,89.0);
00075   vtkGetMacro(Angle,float);
00077
00078 protected:
00079   vtkCone();
00080   ~vtkCone() {};
00081
00082   float Angle;
00083
00084 private:
00085   vtkCone(const vtkCone&);  // Not implemented.
00086   void operator=(const vtkCone&);  // Not implemented.
00087 };
00088
00089 #endif
00090
00091
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkConeSource.h Source File

Graphics/vtkConeSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkConeSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkConeSource_h
00047 #define __vtkConeSource_h
00048
00049 #include "vtkPolyDataSource.h"
00050
00051 class VTK_GRAPHICS_EXPORT vtkConeSource : public vtkPolyDataSource
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkConeSource,vtkPolyDataSource);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00059   static vtkConeSource *New();
00060
00062
00063   vtkSetClampMacro(Height,float,0.0,VTK_LARGE_FLOAT)
00064   vtkGetMacro(Height,float);
00066
00068
00069   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT)
00070   vtkGetMacro(Radius,float);
00072
00074
00075   vtkSetClampMacro(Resolution,int,0,VTK_CELL_SIZE)
00076   vtkGetMacro(Resolution,int);
00078
00080
00081   void SetAngle (float angle);
00082   float GetAngle ();
00084
00086
00087   vtkSetMacro(Capping,int);
00088   vtkGetMacro(Capping,int);
00089   vtkBooleanMacro(Capping,int);
00091
00092 protected:
00093   vtkConeSource(int res=6);
00094   ~vtkConeSource() {};
00095
00096   void Execute();
00097   void ExecuteInformation();
00098   float Height;
00099   float Radius;
00100   int Resolution;
00101   int Capping;
00102 private:
00103   vtkConeSource(const vtkConeSource&);  // Not implemented.
00104   void operator=(const vtkConeSource&);  // Not implemented.
00105 };
00106
00107 #endif
00108
00109
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkConnectivityFilter.h Source File

Graphics/vtkConnectivityFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkConnectivityFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00066 #ifndef __vtkConnectivityFilter_h
00067 #define __vtkConnectivityFilter_h
00068
00069 #include "vtkDataSetToUnstructuredGridFilter.h"
00070
00071 #define VTK_EXTRACT_POINT_SEEDED_REGIONS 1
00072 #define VTK_EXTRACT_CELL_SEEDED_REGIONS 2
00073 #define VTK_EXTRACT_SPECIFIED_REGIONS 3
00074 #define VTK_EXTRACT_LARGEST_REGION 4
00075 #define VTK_EXTRACT_ALL_REGIONS 5
00076 #define VTK_EXTRACT_CLOSEST_POINT_REGION 6
00077
00078 class vtkFloatArray;
00079
00080 class VTK_GRAPHICS_EXPORT vtkConnectivityFilter : public vtkDataSetToUnstructuredGridFilter
00081 {
00082 public:
00083   vtkTypeRevisionMacro(vtkConnectivityFilter,vtkDataSetToUnstructuredGridFilter);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00087   static vtkConnectivityFilter *New();
00088
00090
00093   vtkSetMacro(ScalarConnectivity,int);
00094   vtkGetMacro(ScalarConnectivity,int);
00095   vtkBooleanMacro(ScalarConnectivity,int);
00097
00099
00101   vtkSetVector2Macro(ScalarRange,float);
00102   vtkGetVector2Macro(ScalarRange,float);
00104
00106
00107   vtkSetClampMacro(ExtractionMode,int,
00108             VTK_EXTRACT_POINT_SEEDED_REGIONS,VTK_EXTRACT_CLOSEST_POINT_REGION);
00109   vtkGetMacro(ExtractionMode,int);
00110   void SetExtractionModeToPointSeededRegions()
00111     {this->SetExtractionMode(VTK_EXTRACT_POINT_SEEDED_REGIONS);};
00112   void SetExtractionModeToCellSeededRegions()
00113     {this->SetExtractionMode(VTK_EXTRACT_CELL_SEEDED_REGIONS);};
00114   void SetExtractionModeToLargestRegion()
00115     {this->SetExtractionMode(VTK_EXTRACT_LARGEST_REGION);};
00116   void SetExtractionModeToSpecifiedRegions()
00117     {this->SetExtractionMode(VTK_EXTRACT_SPECIFIED_REGIONS);};
00118   void SetExtractionModeToClosestPointRegion()
00119     {this->SetExtractionMode(VTK_EXTRACT_CLOSEST_POINT_REGION);};
00120   void SetExtractionModeToAllRegions()
00121     {this->SetExtractionMode(VTK_EXTRACT_ALL_REGIONS);};
00122   const char *GetExtractionModeAsString();
00124
00126   void InitializeSeedList();
00127
00129   void AddSeed(vtkIdType id);
00130
00132   void DeleteSeed(vtkIdType id);
00133
00135   void InitializeSpecifiedRegionList();
00136
00138   void AddSpecifiedRegion(int id);
00139
00141   void DeleteSpecifiedRegion(int id);
00142
00144
00146   vtkSetVector3Macro(ClosestPoint,float);
00147   vtkGetVectorMacro(ClosestPoint,float,3);
00149
00151   int GetNumberOfExtractedRegions();
00152
00154
00155   vtkSetMacro(ColorRegions,int);
00156   vtkGetMacro(ColorRegions,int);
00157   vtkBooleanMacro(ColorRegions,int);
00159
00160 protected:
00161   vtkConnectivityFilter();
00162   ~vtkConnectivityFilter();
00163
00164   // Usual data generation method
00165   void Execute();
00166
00167   int ColorRegions; //boolean turns on/off scalar gen for separate regions
00168   int ExtractionMode; //how to extract regions
00169   vtkIdList *Seeds; //id's of points or cells used to seed regions
00170   vtkIdList *SpecifiedRegionIds; //regions specified for extraction
00171   vtkIntArray *RegionSizes; //size (in cells) of each region extracted
00172
00173   float ClosestPoint[3];
00174
00175   int ScalarConnectivity;
00176   float ScalarRange[2];
00177
00178   void TraverseAndMark();
00179
00180 private:
00181   // used to support algorithm execution
00182   vtkFloatArray *CellScalars;
00183   vtkIdList *NeighborCellPointIds;
00184   vtkIdType *Visited;
00185   vtkIdType *PointMap;
00186   vtkFloatArray *NewScalars;
00187   int RegionNumber;
00188   vtkIdType PointNumber;
00189   int NumCellsInRegion;
00190   vtkDataArray *InScalars;
00191   vtkIdList *Wave;
00192   vtkIdList *Wave2;
00193   vtkIdList *PointIds;
00194   vtkIdList *CellIds;
00195 private:
00196   vtkConnectivityFilter(const vtkConnectivityFilter&);  // Not implemented.
00197   void operator=(const vtkConnectivityFilter&);  // Not implemented.
00198 };
00199
00201 inline const char *vtkConnectivityFilter::GetExtractionModeAsString(void)
00202 {
00203   if ( this->ExtractionMode == VTK_EXTRACT_POINT_SEEDED_REGIONS )
00204     {
00205     return "ExtractPointSeededRegions";
00206     }
00207   else if ( this->ExtractionMode == VTK_EXTRACT_CELL_SEEDED_REGIONS )
00208     {
00209     return "ExtractCellSeededRegions";
00210     }
00211   else if ( this->ExtractionMode == VTK_EXTRACT_SPECIFIED_REGIONS )
00212     {
00213     return "ExtractSpecifiedRegions";
00214     }
00215   else if ( this->ExtractionMode == VTK_EXTRACT_ALL_REGIONS )
00216     {
00217     return "ExtractAllRegions";
00218     }
00219   else if ( this->ExtractionMode == VTK_EXTRACT_CLOSEST_POINT_REGION )
00220     {
00221     return "ExtractClosestPointRegion";
00222     }
00223   else
00224     {
00225     return "ExtractLargestRegion";
00226     }
00227 }
00228
00229 #endif
00230
00231
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkContainer.h Source File

Common/vtkContainer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkContainer.h,v $
00005   Language:  C++
00006
00007
00008   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00009   All rights reserved.
00010   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00011
00012      This software is distributed WITHOUT ANY WARRANTY; without even
00013      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00014      PURPOSE.  See the above copyright notice for more information.
00015
00016 =========================================================================*/
00048 #include "vtkObject.h"
00049
00050 class VTK_COMMON_EXPORT vtkContainer
00051 {
00052 public:
00056   virtual unsigned long GetNumberOfItems() = 0;
00057
00059   virtual void RemoveAllItems() = 0;
00060
00063   void Delete() { this->UnRegister(); }
00064
00066
00067   void Register();
00068   void Register(vtkObject *) { this->Register(); }
00070
00072
00075   void UnRegister();
00076   void UnRegister(vtkObject *) { this->UnRegister(); }
00078
00079 protected:
00080   unsigned long ReferenceCount;
00081   vtkContainer() { this->ReferenceCount = 1;};
00082   virtual ~vtkContainer() {};
00083 };
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkContourFilter.h Source File

Graphics/vtkContourFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkContourFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00071 #ifndef __vtkContourFilter_h
00072 #define __vtkContourFilter_h
00073
00074 #include "vtkDataSetToPolyDataFilter.h"
00075 #include "vtkContourValues.h"
00076 #include "vtkScalarTree.h"
00077
00078 class VTK_GRAPHICS_EXPORT vtkContourFilter : public vtkDataSetToPolyDataFilter
00079 {
00080 public:
00081   vtkTypeRevisionMacro(vtkContourFilter,vtkDataSetToPolyDataFilter);
00082   void PrintSelf(ostream& os, vtkIndent indent);
00083
00086   static vtkContourFilter *New();
00087
00089
00090   void SetValue(int i, float value);
00091   float GetValue(int i);
00092   float *GetValues();
00093   void GetValues(float *contourValues);
00094   void SetNumberOfContours(int number);
00095   int GetNumberOfContours();
00096   void GenerateValues(int numContours, float range[2]);
00097   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00099
00101   unsigned long GetMTime();
00102
00104
00108   vtkSetMacro(ComputeNormals,int);
00109   vtkGetMacro(ComputeNormals,int);
00110   vtkBooleanMacro(ComputeNormals,int);
00112
00114
00120   vtkSetMacro(ComputeGradients,int);
00121   vtkGetMacro(ComputeGradients,int);
00122   vtkBooleanMacro(ComputeGradients,int);
00124
00126
00127   vtkSetMacro(ComputeScalars,int);
00128   vtkGetMacro(ComputeScalars,int);
00129   vtkBooleanMacro(ComputeScalars,int);
00131
00133
00134   vtkSetMacro(UseScalarTree,int);
00135   vtkGetMacro(UseScalarTree,int);
00136   vtkBooleanMacro(UseScalarTree,int);
00138
00140
00141   vtkSetObjectMacro(ScalarTree,vtkScalarTree);
00142   vtkGetObjectMacro(ScalarTree,vtkScalarTree);
00144
00146
00148   void SetLocator(vtkPointLocator *locator);
00149   vtkGetObjectMacro(Locator,vtkPointLocator);
00151
00154   void CreateDefaultLocator();
00155
00157
00160   vtkGetStringMacro(InputScalarsSelection);
00161   void SelectInputScalars(const char *fieldName)
00162     {this->SetInputScalarsSelection(fieldName);}
00164
00165 protected:
00166   vtkContourFilter();
00167   ~vtkContourFilter();
00168
00169   void Execute();
00170
00171   vtkContourValues *ContourValues;
00172   int ComputeNormals;
00173   int ComputeGradients;
00174   int ComputeScalars;
00175   vtkPointLocator *Locator;
00176   int UseScalarTree;
00177   vtkScalarTree *ScalarTree;
00178
00179   char *InputScalarsSelection;
00180   vtkSetStringMacro(InputScalarsSelection);
00181
00182 private:
00183   vtkContourFilter(const vtkContourFilter&);  // Not implemented.
00184   void operator=(const vtkContourFilter&);  // Not implemented.
00185 };
00186
00189 inline void vtkContourFilter::SetValue(int i, float value)
00190 {this->ContourValues->SetValue(i,value);}
00191
00193
00194 inline float vtkContourFilter::GetValue(int i)
00195 {return this->ContourValues->GetValue(i);}
00197
00199
00201 inline float *vtkContourFilter::GetValues()
00202 {return this->ContourValues->GetValues();}
00204
00208 inline void vtkContourFilter::GetValues(float *contourValues)
00209 {this->ContourValues->GetValues(contourValues);}
00210
00214 inline void vtkContourFilter::SetNumberOfContours(int number)
00215 {this->ContourValues->SetNumberOfContours(number);}
00216
00218
00219 inline int vtkContourFilter::GetNumberOfContours()
00220 {return this->ContourValues->GetNumberOfContours();}
00222
00224
00226 inline void vtkContourFilter::GenerateValues(int numContours, float range[2])
00227 {this->ContourValues->GenerateValues(numContours, range);}
00229
00231
00233 inline void vtkContourFilter::GenerateValues(int numContours, float
00234                                              rangeStart, float rangeEnd)
00235 {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00237
00238
00239 #endif
00240
00241
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkContourGrid.h Source File

Graphics/vtkContourGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkContourGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00063 #ifndef __vtkContourGrid_h
00064 #define __vtkContourGrid_h
00065
00066 #include "vtkUnstructuredGridToPolyDataFilter.h"
00067 #include "vtkContourValues.h"
00068
00069 class vtkScalarTree;
00070 class vtkEdgeTable;
00071
00072 class VTK_GRAPHICS_EXPORT vtkContourGrid : public vtkUnstructuredGridToPolyDataFilter
00073 {
00074 public:
00075   vtkTypeRevisionMacro(vtkContourGrid,vtkUnstructuredGridToPolyDataFilter);
00076   void PrintSelf(ostream& os, vtkIndent indent);
00077
00080   static vtkContourGrid *New();
00081
00083
00084   void SetValue(int i, float value);
00085   float GetValue(int i);
00086   float *GetValues();
00087   void GetValues(float *contourValues);
00088   void SetNumberOfContours(int number);
00089   int GetNumberOfContours();
00090   void GenerateValues(int numContours, float range[2]);
00091   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00093
00095   unsigned long GetMTime();
00096
00098
00102   vtkSetMacro(ComputeNormals,int);
00103   vtkGetMacro(ComputeNormals,int);
00104   vtkBooleanMacro(ComputeNormals,int);
00106
00108
00114   vtkSetMacro(ComputeGradients,int);
00115   vtkGetMacro(ComputeGradients,int);
00116   vtkBooleanMacro(ComputeGradients,int);
00118
00120
00121   vtkSetMacro(ComputeScalars,int);
00122   vtkGetMacro(ComputeScalars,int);
00123   vtkBooleanMacro(ComputeScalars,int);
00125
00127
00128   vtkSetMacro(UseScalarTree,int);
00129   vtkGetMacro(UseScalarTree,int);
00130   vtkBooleanMacro(UseScalarTree,int);
00132
00134
00136   void SetLocator(vtkPointLocator *locator);
00137   vtkGetObjectMacro(Locator,vtkPointLocator);
00139
00142   void CreateDefaultLocator();
00143
00145
00148   vtkGetStringMacro(InputScalarsSelection);
00149   void SelectInputScalars(const char *fieldName)
00150     {this->SetInputScalarsSelection(fieldName);}
00152
00153 protected:
00154   vtkContourGrid();
00155   ~vtkContourGrid();
00156
00157   void Execute();
00158
00159   vtkContourValues *ContourValues;
00160   int ComputeNormals;
00161   int ComputeGradients;
00162   int ComputeScalars;
00163   vtkPointLocator *Locator;
00164   int UseScalarTree;
00165   vtkScalarTree *ScalarTree;
00166   vtkEdgeTable *EdgeTable;
00167
00168   char *InputScalarsSelection;
00169   vtkSetStringMacro(InputScalarsSelection);
00170
00171 private:
00172   vtkContourGrid(const vtkContourGrid&);  // Not implemented.
00173   void operator=(const vtkContourGrid&);  // Not implemented.
00174 };
00175
00178 inline void vtkContourGrid::SetValue(int i, float value)
00179 {this->ContourValues->SetValue(i,value);}
00180
00182
00183 inline float vtkContourGrid::GetValue(int i)
00184 {return this->ContourValues->GetValue(i);}
00186
00188
00190 inline float *vtkContourGrid::GetValues()
00191 {return this->ContourValues->GetValues();}
00193
00197 inline void vtkContourGrid::GetValues(float *contourValues)
00198 {this->ContourValues->GetValues(contourValues);}
00199
00203 inline void vtkContourGrid::SetNumberOfContours(int number)
00204 {this->ContourValues->SetNumberOfContours(number);}
00205
00207
00208 inline int vtkContourGrid::GetNumberOfContours()
00209 {return this->ContourValues->GetNumberOfContours();}
00211
00213
00215 inline void vtkContourGrid::GenerateValues(int numContours, float range[2])
00216 {this->ContourValues->GenerateValues(numContours, range);}
00218
00220
00222 inline void vtkContourGrid::GenerateValues(int numContours, float
00223                                              rangeStart, float rangeEnd)
00224 {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00226
00227
00228 #endif
00229
00230
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkContourValues.h Source File

Common/vtkContourValues.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkContourValues.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkContourValues_h
00041 #define __vtkContourValues_h
00042
00043 #include "vtkObject.h"
00044 #include "vtkIntArray.h"
00045
00046 class vtkFloatArray;
00047
00048 class VTK_COMMON_EXPORT vtkContourValues : public vtkObject
00049 {
00050 public:
00052   static vtkContourValues *New();
00053
00054   vtkTypeRevisionMacro(vtkContourValues,vtkObject);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058   void SetValue(int i, float value);
00059
00062   float GetValue(int i);
00063
00066   float *GetValues();
00067
00070   void GetValues(float *contourValues);
00071
00075   void SetNumberOfContours(const int number);
00076
00078   int GetNumberOfContours();
00079
00082   void GenerateValues(int numContours, float range[2]);
00083
00086   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00087
00088
00089 protected:
00090   vtkContourValues();
00091   ~vtkContourValues();
00092
00093   vtkFloatArray *Contours;
00094
00095 private:
00096   vtkContourValues(const vtkContourValues&);  // Not implemented.
00097   void operator=(const vtkContourValues&);  // Not implemented.
00098 };
00099
00100 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCoordinate.h Source File

Common/vtkCoordinate.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCoordinate.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00066 #ifndef __vtkCoordinate_h
00067 #define __vtkCoordinate_h
00068
00069 #include "vtkObject.h"
00070 class vtkViewport;
00071
00072 #define VTK_DISPLAY             0
00073 #define VTK_NORMALIZED_DISPLAY  1
00074 #define VTK_VIEWPORT            2
00075 #define VTK_NORMALIZED_VIEWPORT 3
00076 #define VTK_VIEW                4
00077 #define VTK_WORLD               5
00078 #define VTK_USERDEFINED         6
00079
00080 class VTK_COMMON_EXPORT vtkCoordinate : public vtkObject
00081 {
00082 public:
00083   vtkTypeRevisionMacro(vtkCoordinate,vtkObject);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00088   static vtkCoordinate* New();
00089
00091
00094   vtkSetMacro(CoordinateSystem, int);
00095   vtkGetMacro(CoordinateSystem, int);
00096   void SetCoordinateSystemToDisplay() {this->SetCoordinateSystem(VTK_DISPLAY);}
00097   void SetCoordinateSystemToNormalizedDisplay()
00098         {this->SetCoordinateSystem(VTK_NORMALIZED_DISPLAY);}
00099   void SetCoordinateSystemToViewport()
00100         {this->SetCoordinateSystem(VTK_VIEWPORT);}
00101   void SetCoordinateSystemToNormalizedViewport()
00102         {this->SetCoordinateSystem(VTK_NORMALIZED_VIEWPORT);}
00103   void SetCoordinateSystemToView() {this->SetCoordinateSystem(VTK_VIEW);}
00104   void SetCoordinateSystemToWorld() {this->SetCoordinateSystem(VTK_WORLD);}
00106
00107   const char *GetCoordinateSystemAsString ();
00108
00110
00112   vtkSetVector3Macro(Value,float);
00113   vtkGetVector3Macro(Value,float);
00114   void SetValue(float a, float b) { this->SetValue(a,b,0.0);}
00116
00118
00121   vtkSetObjectMacro(ReferenceCoordinate,vtkCoordinate);
00122   vtkGetObjectMacro(ReferenceCoordinate,vtkCoordinate);
00124
00126
00128   void SetViewport(vtkViewport *viewport);
00129   vtkGetObjectMacro(Viewport,vtkViewport);
00131
00133
00134   float *GetComputedWorldValue(vtkViewport *);
00135   int *GetComputedViewportValue(vtkViewport *);
00136   int *GetComputedDisplayValue(vtkViewport *);
00137   int *GetComputedLocalDisplayValue(vtkViewport *);
00139
00140   float *GetComputedFloatViewportValue(vtkViewport *);
00141   float *GetComputedFloatDisplayValue(vtkViewport *);
00142
00147   float *GetComputedValue(vtkViewport *);
00148
00150
00154   virtual float *GetComputedUserDefinedValue(vtkViewport *)
00155     { return this->Value; }
00157
00158 protected:
00159   vtkCoordinate();
00160   ~vtkCoordinate();
00161
00162   float Value[3];
00163   int   CoordinateSystem;
00164   vtkCoordinate *ReferenceCoordinate;
00165   vtkViewport *Viewport;
00166   float ComputedWorldValue[3];
00167   int   ComputedDisplayValue[2];
00168   int   ComputedViewportValue[2];
00169   int   Computing;
00170
00171   float ComputedFloatDisplayValue[2];
00172   float ComputedFloatViewportValue[2];
00173   float ComputedUserDefinedValue[3];
00174
00175 private:
00176   vtkCoordinate(const vtkCoordinate&);  // Not implemented.
00177   void operator=(const vtkCoordinate&);  // Not implemented.
00178 };
00179
00180 #endif
00181
00182
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkCriticalSection.h Source File

Common/vtkCriticalSection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCriticalSection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkCriticalSection_h
00047 #define __vtkCriticalSection_h
00048
00049 #include "vtkObject.h"
00050
00051 //BTX
00052
00053 #ifdef VTK_USE_SPROC
00054 #include <abi_mutex.h>
00055 typedef abilock_t vtkCritSecType;
00056 #endif
00057
00058 #ifdef VTK_USE_PTHREADS
00059 #include <pthread.h>
00060 typedef pthread_mutex_t vtkCritSecType;
00061 #endif
00062
00063 #ifdef VTK_USE_WIN32_THREADS
00064 #include <winbase.h>
00065 typedef CRITICAL_SECTION vtkCritSecType;
00066 #endif
00067
00068 #ifndef VTK_USE_SPROC
00069 #ifndef VTK_USE_PTHREADS
00070 #ifndef VTK_USE_WIN32_THREADS
00071 typedef int vtkCritSecType;
00072 #endif
00073 #endif
00074 #endif
00075
00076 // Critical Section object that is not a vtkObject.
00077 class VTK_COMMON_EXPORT vtkSimpleCriticalSection
00078 {
00079 public:
00080   vtkSimpleCriticalSection()
00081     {
00082       this->Init();
00083     }
00084
00085   vtkSimpleCriticalSection(int isLocked)
00086     {
00087       this->Init();
00088       if(isLocked)
00089         {
00090         this->Lock();
00091         }
00092     }
00093
00094   void Init();
00095
00096   virtual ~vtkSimpleCriticalSection();
00097
00098   static vtkSimpleCriticalSection *New();
00099
00100   // What's the point of these (here and in MutexLock)? This class
00101   // is not part of the hierarchy!! -CRV
00102   virtual const char *GetClassName() {return "vtkSimpleCriticalSection";};
00103   virtual int IsA(const char *name);
00104   static vtkSimpleCriticalSection *SafeDownCast(vtkSimpleCriticalSection *o);
00105
00106   void Delete() {delete this;}
00107
00109   void Lock( void );
00110
00112   void Unlock( void );
00113
00114 protected:
00115   vtkCritSecType   CritSec;
00116 };
00117
00118 //ETX
00119
00120 class VTK_COMMON_EXPORT vtkCriticalSection : public vtkObject
00121 {
00122 public:
00123   static vtkCriticalSection *New();
00124
00125   vtkTypeRevisionMacro(vtkCriticalSection,vtkObject);
00126   void PrintSelf(ostream& os, vtkIndent indent);
00127
00129   void Lock( void );
00130
00132   void Unlock( void );
00133
00134 protected:
00135   vtkSimpleCriticalSection   SimpleCriticalSection;
00136   vtkCriticalSection() {};
00137 private:
00138   vtkCriticalSection(const vtkCriticalSection&);  // Not implemented.
00139   void operator=(const vtkCriticalSection&);  // Not implemented.
00140 };
00141
00142
00143 inline void vtkCriticalSection::Lock( void )
00144 {
00145   this->SimpleCriticalSection.Lock();
00146 }
00147
00148 inline void vtkCriticalSection::Unlock( void )
00149 {
00150   this->SimpleCriticalSection.Unlock();
00151 }
00152
00153 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkCubeAxesActor2D.h Source File

Hybrid/vtkCubeAxesActor2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCubeAxesActor2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00060 #ifndef __vtkCubeAxesActor2D_h
00061 #define __vtkCubeAxesActor2D_h
00062
00063 #include "vtkAxisActor2D.h"
00064 #include "vtkCamera.h"
00065
00066 #define VTK_FLY_OUTER_EDGES 0
00067 #define VTK_FLY_CLOSEST_TRIAD 1
00068
00069 class VTK_HYBRID_EXPORT vtkCubeAxesActor2D : public vtkActor2D
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkCubeAxesActor2D,vtkActor2D);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00078   static vtkCubeAxesActor2D *New();
00079
00081
00082   int RenderOverlay(vtkViewport*);
00083   int RenderOpaqueGeometry(vtkViewport*);
00084   int RenderTranslucentGeometry(vtkViewport *) {return 0;}
00086
00088
00091   vtkSetObjectMacro(Input, vtkDataSet);
00092   vtkGetObjectMacro(Input, vtkDataSet);
00094
00096
00098   vtkSetObjectMacro(Prop, vtkProp);
00099   vtkGetObjectMacro(Prop, vtkProp);
00101
00103
00107   vtkSetVector6Macro(Bounds,float);
00108   float *GetBounds();
00109   void GetBounds(float& xmin, float& xmax, float& ymin, float& ymax,
00110                  float& zmin, float& zmax);
00111   void GetBounds(float bounds[6]);
00113
00115
00118   vtkSetVector6Macro(Ranges,float);
00119   float *GetRanges();
00120   void GetRanges(float& xmin, float& xmax, float& ymin, float& ymax,
00121                  float& zmin, float& zmax);
00122   void GetRanges(float ranges[6]);
00124
00126
00128   vtkSetMacro(UseRanges,int);
00129   vtkGetMacro(UseRanges,int);
00130   vtkBooleanMacro(UseRanges,int);
00132
00134
00136   vtkSetObjectMacro(Camera,vtkCamera);
00137   vtkGetObjectMacro(Camera,vtkCamera);
00139
00141
00143   vtkSetClampMacro(FlyMode, int, VTK_FLY_OUTER_EDGES, VTK_FLY_CLOSEST_TRIAD);
00144   vtkGetMacro(FlyMode, int);
00145   void SetFlyModeToOuterEdges()
00146     {this->SetFlyMode(VTK_FLY_OUTER_EDGES);};
00147   void SetFlyModeToClosestTriad()
00148     {this->SetFlyMode(VTK_FLY_CLOSEST_TRIAD);};
00150
00152
00156   vtkSetMacro(Scaling,int);
00157   vtkGetMacro(Scaling,int);
00158   vtkBooleanMacro(Scaling,int);
00160
00162
00165   vtkSetClampMacro(NumberOfLabels, int, 0, 50);
00166   vtkGetMacro(NumberOfLabels, int);
00168
00170
00172   vtkSetStringMacro(XLabel);
00173   vtkGetStringMacro(XLabel);
00174   vtkSetStringMacro(YLabel);
00175   vtkGetStringMacro(YLabel);
00176   vtkSetStringMacro(ZLabel);
00177   vtkGetStringMacro(ZLabel);
00179
00181
00182   vtkSetMacro(Bold, int);
00183   vtkGetMacro(Bold, int);
00184   vtkBooleanMacro(Bold, int);
00186
00188
00189   vtkSetMacro(Italic, int);
00190   vtkGetMacro(Italic, int);
00191   vtkBooleanMacro(Italic, int);
00193
00195
00197   vtkSetMacro(Shadow, int);
00198   vtkGetMacro(Shadow, int);
00199   vtkBooleanMacro(Shadow, int);
00201
00203
00206   vtkSetMacro(FontFamily, int);
00207   vtkGetMacro(FontFamily, int);
00208   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00209   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00210   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00212
00214
00216   vtkSetStringMacro(LabelFormat);
00217   vtkGetStringMacro(LabelFormat);
00219
00221
00223   vtkSetClampMacro(FontFactor, float, 0.1, 2.0);
00224   vtkGetMacro(FontFactor, float);
00226
00228
00231   vtkSetClampMacro(Inertia, int, 1, VTK_LARGE_INTEGER);
00232   vtkGetMacro(Inertia, float);
00234
00236
00239   vtkSetMacro(CornerOffset, float);
00240   vtkGetMacro(CornerOffset, float);
00242
00246   void ReleaseGraphicsResources(vtkWindow *);
00247
00249
00250   vtkSetMacro(XAxisVisibility,int);
00251   vtkGetMacro(XAxisVisibility,int);
00252   vtkBooleanMacro(XAxisVisibility,int);
00253   vtkSetMacro(YAxisVisibility,int);
00254   vtkGetMacro(YAxisVisibility,int);
00255   vtkBooleanMacro(YAxisVisibility,int);
00256   vtkSetMacro(ZAxisVisibility,int);
00257   vtkGetMacro(ZAxisVisibility,int);
00258   vtkBooleanMacro(ZAxisVisibility,int);
00260
00262   void ShallowCopy(vtkCubeAxesActor2D *actor);
00263
00264 protected:
00265   vtkCubeAxesActor2D();
00266   ~vtkCubeAxesActor2D();
00267
00268   vtkDataSet *Input;    //Define bounds from input data, or
00269   vtkProp    *Prop;     //Define bounds from actor/assembly, or
00270   float      Bounds[6]; //Define bounds explicitly
00271   float      Ranges[6]; //Define ranges explicitly
00272   int        UseRanges; //Flag to use ranges or not
00273
00274   vtkCamera *Camera;
00275   int FlyMode;
00276   int Scaling;
00277
00278   vtkAxisActor2D *XAxis;
00279   vtkAxisActor2D *YAxis;
00280   vtkAxisActor2D *ZAxis;
00281
00282   int   NumberOfLabels;
00283   char *XLabel;
00284   char *YLabel;
00285   char *ZLabel;
00286   char *Labels[3];
00287
00288   int XAxisVisibility;
00289   int YAxisVisibility;
00290   int ZAxisVisibility;
00291
00292   int   Bold;
00293   int   Italic;
00294   int   Shadow;
00295   int   FontFamily;
00296   char  *LabelFormat;
00297   float FontFactor;
00298   float CornerOffset;
00299   int   Inertia;
00300   int   RenderCount;
00301   int   InertiaAxes[8];
00302
00303   int RenderSomething;
00304
00305   // various helper methods
00306   void TransformBounds(vtkViewport *viewport, float bounds[6],
00307                        float pts[8][3]);
00308   int ClipBounds(vtkViewport *viewport, float pts[8][3], float bounds[6]);
00309   float EvaluatePoint(float planes[24], float x[3]);
00310   float EvaluateBounds(float planes[24], float bounds[6]);
00311   void AdjustAxes(float pts[8][3], float bounds[6],
00312                   int idx, int xIdx, int yIdx, int zIdx, int zIdx2,
00313                   int xAxes, int yAxes, int zAxes,
00314                   float xCoords[4], float yCoords[4], float zCoords[4],
00315                   float xRange[2], float yRange[2], float zRange[2]);
00316
00317 private:
00318   // hide the superclass' ShallowCopy() from the user and the compiler.
00319   void ShallowCopy(vtkProp *prop) { this->vtkProp::ShallowCopy( prop ); };
00320 private:
00321   vtkCubeAxesActor2D(const vtkCubeAxesActor2D&);  // Not implemented.
00322   void operator=(const vtkCubeAxesActor2D&);  // Not implemented.
00323 };
00324
00325
00326 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCubeSource.h Source File

Graphics/vtkCubeSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCubeSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkCubeSource_h
00042 #define __vtkCubeSource_h
00043
00044 #include "vtkPolyDataSource.h"
00045
00046 class VTK_GRAPHICS_EXPORT vtkCubeSource : public vtkPolyDataSource
00047 {
00048 public:
00049   static vtkCubeSource *New();
00050   vtkTypeRevisionMacro(vtkCubeSource,vtkPolyDataSource);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   vtkSetClampMacro(XLength,float,0.0,VTK_LARGE_FLOAT);
00056   vtkGetMacro(XLength,float);
00058
00060
00061   vtkSetClampMacro(YLength,float,0.0,VTK_LARGE_FLOAT);
00062   vtkGetMacro(YLength,float);
00064
00066
00067   vtkSetClampMacro(ZLength,float,0.0,VTK_LARGE_FLOAT);
00068   vtkGetMacro(ZLength,float);
00070
00072
00073   vtkSetVector3Macro(Center,float);
00074   vtkGetVectorMacro(Center,float,3);
00076
00078
00080   void SetBounds(float xMin, float xMax,
00081                  float yMin, float yMax,
00082                  float zMin, float zMax);
00083   void SetBounds(float bounds[6]);
00085
00086
00087 protected:
00088   vtkCubeSource(float xL=1.0, float yL=1.0, float zL=1.0);
00089   ~vtkCubeSource() {};
00090
00091   void Execute();
00092   float XLength;
00093   float YLength;
00094   float ZLength;
00095   float Center[3];
00096 private:
00097   vtkCubeSource(const vtkCubeSource&);  // Not implemented.
00098   void operator=(const vtkCubeSource&);  // Not implemented.
00099 };
00100
00101 #endif
00102
00103
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkCuller.h Source File

Rendering/vtkCuller.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCuller.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkCuller_h
00041 #define __vtkCuller_h
00042
00043 #include "vtkObject.h"
00044
00045 class vtkProp;
00046 class vtkRenderer;
00047
00048 class VTK_RENDERING_EXPORT vtkCuller : public vtkObject
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkCuller,vtkObject);
00052
00054
00055   virtual float Cull( vtkRenderer *ren, vtkProp **propList,
00056                       int& listLength, int& initialized )=0;
00058
00059 protected:
00060   vtkCuller();
00061   ~vtkCuller();
00062 private:
00063   vtkCuller(const vtkCuller&);  // Not implemented.
00064   void operator=(const vtkCuller&);    // Not implemented.
00065 };
00066
00067 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkCullerCollection.h Source File

Rendering/vtkCullerCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCullerCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkCullerC_h
00040 #define __vtkCullerC_h
00041
00042 #include "vtkCollection.h"
00043 #include "vtkCuller.h"
00044
00045 class VTK_RENDERING_EXPORT vtkCullerCollection : public vtkCollection
00046 {
00047  public:
00048   static vtkCullerCollection *New();
00049   vtkTypeRevisionMacro(vtkCullerCollection,vtkCollection);
00050
00052
00053   void AddItem(vtkCuller *a) {
00054     this->vtkCollection::AddItem((vtkObject *)a);};
00056
00058
00059   vtkCuller *GetNextItem() {
00060     return static_cast<vtkCuller *>(this->GetNextItemAsObject());};
00062
00064   vtkCuller *GetLastItem();
00065
00066 protected:
00067   vtkCullerCollection() {};
00068   ~vtkCullerCollection() {};
00069
00070
00071 private:
00072   // hide the standard AddItem from the user and the compiler.
00073   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00074
00075 private:
00076   vtkCullerCollection(const vtkCullerCollection&);  // Not implemented.
00077   void operator=(const vtkCullerCollection&);  // Not implemented.
00078 };
00079
00080
00081 inline vtkCuller *vtkCullerCollection::GetLastItem()
00082 {
00083   if ( this->Bottom == NULL )
00084     {
00085     return NULL;
00086     }
00087   else
00088     {
00089     return static_cast<vtkCuller *>(this->Bottom->Item);
00090     }
00091 }
00092
00093 #endif
00094
00095
00096
00097
00098
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCursor3D.h Source File

Graphics/vtkCursor3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCursor3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkCursor3D_h
00045 #define __vtkCursor3D_h
00046
00047 #include "vtkPolyDataSource.h"
00048
00049 class VTK_GRAPHICS_EXPORT vtkCursor3D : public vtkPolyDataSource
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkCursor3D,vtkPolyDataSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   static vtkCursor3D *New();
00058
00060
00061   void SetModelBounds(float xmin, float xmax, float ymin, float ymax,
00062                       float zmin, float zmax);
00063   void SetModelBounds(float bounds[6]);
00064   vtkGetVectorMacro(ModelBounds,float,6);
00066
00068
00069   vtkSetVector3Macro(FocalPoint,float);
00070   vtkGetVectorMacro(FocalPoint,float,3);
00072
00074
00075   vtkSetMacro(Outline,int);
00076   vtkGetMacro(Outline,int);
00077   vtkBooleanMacro(Outline,int);
00079
00081
00082   vtkSetMacro(Axes,int);
00083   vtkGetMacro(Axes,int);
00084   vtkBooleanMacro(Axes,int);
00086
00088
00089   vtkSetMacro(XShadows,int);
00090   vtkGetMacro(XShadows,int);
00091   vtkBooleanMacro(XShadows,int);
00093
00095
00096   vtkSetMacro(YShadows,int);
00097   vtkGetMacro(YShadows,int);
00098   vtkBooleanMacro(YShadows,int);
00100
00102
00103   vtkSetMacro(ZShadows,int);
00104   vtkGetMacro(ZShadows,int);
00105   vtkBooleanMacro(ZShadows,int);
00107
00109
00112   vtkSetMacro(Wrap,int);
00113   vtkGetMacro(Wrap,int);
00114   vtkBooleanMacro(Wrap,int);
00116
00118   vtkPolyData *GetFocus() {return (vtkPolyData *)this->Focus;};
00119
00121
00122   void AllOn();
00123   void AllOff();
00125
00126 protected:
00127   vtkCursor3D();
00128   ~vtkCursor3D();
00129
00130   void Execute();
00131
00132   vtkPolyData *Focus;
00133   float ModelBounds[6];
00134   float FocalPoint[3];
00135   int Outline;
00136   int Axes;
00137   int XShadows;
00138   int YShadows;
00139   int ZShadows;
00140   int Wrap;
00141 private:
00142   vtkCursor3D(const vtkCursor3D&);  // Not implemented.
00143   void operator=(const vtkCursor3D&);  // Not implemented.
00144 };
00145
00146 #endif
00147
00148
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkCutMaterial.h Source File

Parallel/vtkCutMaterial.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCutMaterial.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkCutMaterial_h
00039 #define __vtkCutMaterial_h
00040
00041 #include "vtkDataSetToPolyDataFilter.h"
00042 #include "vtkPlane.h"
00043
00044
00045 class VTK_PARALLEL_EXPORT vtkCutMaterial : public vtkDataSetToPolyDataFilter
00046 {
00047 public:
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049   vtkTypeRevisionMacro(vtkCutMaterial,vtkDataSetToPolyDataFilter);
00050   static vtkCutMaterial *New();
00051
00053
00054   vtkSetStringMacro(MaterialArrayName);
00055   vtkGetStringMacro(MaterialArrayName);
00057
00059
00060   vtkSetMacro(Material, int);
00061   vtkGetMacro(Material, int);
00063
00065
00066   vtkSetStringMacro(ArrayName);
00067   vtkGetStringMacro(ArrayName);
00069
00071
00072   vtkSetVector3Macro(UpVector, float);
00073   vtkGetVector3Macro(UpVector, float);
00075
00077
00079   vtkGetVector3Macro(MaximumPoint, float);
00080   vtkGetVector3Macro(CenterPoint, float);
00081   vtkGetVector3Macro(Normal, float);
00083
00084 protected:
00085   vtkCutMaterial();
00086   ~vtkCutMaterial();
00087
00088   void Execute(); //generate output data
00089   void ComputeMaximumPoint(vtkDataSet *input);
00090   void ComputeNormal();
00091
00092   char *MaterialArrayName;
00093   int Material;
00094   char *ArrayName;
00095   float UpVector[3];
00096   float MaximumPoint[3];
00097   float CenterPoint[3];
00098   float Normal[3];
00099
00100   vtkPlane *PlaneFunction;
00101
00102 private:
00103   vtkCutMaterial(const vtkCutMaterial&);  // Not implemented.
00104   void operator=(const vtkCutMaterial&);  // Not implemented.
00105 };
00106
00107 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCutter.h Source File

Graphics/vtkCutter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCutter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkCutter_h
00059 #define __vtkCutter_h
00060
00061 #include "vtkDataSetToPolyDataFilter.h"
00062 #include "vtkContourValues.h"
00063 #include "vtkImplicitFunction.h"
00064
00065 #define VTK_SORT_BY_VALUE 0
00066 #define VTK_SORT_BY_CELL 1
00067
00068 class VTK_GRAPHICS_EXPORT vtkCutter : public vtkDataSetToPolyDataFilter
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkCutter,vtkDataSetToPolyDataFilter);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00076   static vtkCutter *New();
00077
00079
00081   void SetValue(int i, float value)
00082     {this->ContourValues->SetValue(i,value);}
00084
00086
00087   float GetValue(int i)
00088     {return this->ContourValues->GetValue(i);}
00090
00092
00094   float *GetValues()
00095     {return this->ContourValues->GetValues();}
00097
00099
00102   void GetValues(float *contourValues)
00103     {this->ContourValues->GetValues(contourValues);}
00105
00107
00110   void SetNumberOfContours(int number)
00111     {this->ContourValues->SetNumberOfContours(number);}
00113
00115
00116   int GetNumberOfContours()
00117     {return this->ContourValues->GetNumberOfContours();}
00119
00121
00123   void GenerateValues(int numContours, float range[2])
00124     {this->ContourValues->GenerateValues(numContours, range);}
00126
00128
00130   void GenerateValues(int numContours, float rangeStart, float rangeEnd)
00131     {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00133
00136   unsigned long GetMTime();
00137
00139
00140   vtkSetObjectMacro(CutFunction,vtkImplicitFunction);
00141   vtkGetObjectMacro(CutFunction,vtkImplicitFunction);
00143
00145
00148   vtkSetMacro(GenerateCutScalars,int);
00149   vtkGetMacro(GenerateCutScalars,int);
00150   vtkBooleanMacro(GenerateCutScalars,int);
00152
00154
00156   void SetLocator(vtkPointLocator *locator);
00157   vtkGetObjectMacro(Locator,vtkPointLocator);
00159
00161
00169   vtkSetClampMacro(SortBy,int,VTK_SORT_BY_VALUE,VTK_SORT_BY_CELL);
00170   vtkGetMacro(SortBy,int);
00171   void SetSortByToSortByValue()
00172     {this->SetSortBy(VTK_SORT_BY_VALUE);}
00173   void SetSortByToSortByCell()
00174     {this->SetSortBy(VTK_SORT_BY_CELL);}
00175   const char *GetSortByAsString();
00177
00180   void CreateDefaultLocator();
00181
00182 protected:
00183   vtkCutter(vtkImplicitFunction *cf=NULL);
00184   ~vtkCutter();
00185
00186   void Execute();
00187   vtkImplicitFunction *CutFunction;
00188
00189   vtkPointLocator *Locator;
00190   int SortBy;
00191   vtkContourValues *ContourValues;
00192   int GenerateCutScalars;
00193 private:
00194   vtkCutter(const vtkCutter&);  // Not implemented.
00195   void operator=(const vtkCutter&);  // Not implemented.
00196 };
00197
00199 inline const char *vtkCutter::GetSortByAsString(void)
00200 {
00201   if ( this->SortBy == VTK_SORT_BY_VALUE )
00202     {
00203     return "SortByValue";
00204     }
00205   else
00206     {
00207     return "SortByCell";
00208     }
00209 }
00210
00211
00212 #endif
00213
00214
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkCylinder.h Source File

Filtering/vtkCylinder.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCylinder.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkCylinder_h
00046 #define __vtkCylinder_h
00047
00048 #include "vtkImplicitFunction.h"
00049
00050 class VTK_FILTERING_EXPORT vtkCylinder : public vtkImplicitFunction
00051 {
00052 public:
00053   vtkTypeRevisionMacro(vtkCylinder,vtkImplicitFunction);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   static vtkCylinder *New();
00058
00060
00061   float EvaluateFunction(float x[3]);
00062   float EvaluateFunction(float x, float y, float z)
00063     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00065
00067   void EvaluateGradient(float x[3], float g[3]);
00068
00070
00071   vtkSetMacro(Radius,float);
00072   vtkGetMacro(Radius,float);
00074
00076
00077   vtkSetVector3Macro(Center,float);
00078   vtkGetVectorMacro(Center,float,3);
00080 protected:
00081   vtkCylinder();
00082   ~vtkCylinder() {};
00083
00084   float Radius;
00085   float Center[3];
00086
00087 private:
00088   vtkCylinder(const vtkCylinder&);  // Not implemented.
00089   void operator=(const vtkCylinder&);  // Not implemented.
00090 };
00091
00092 #endif
00093
00094
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkCylinderSource.h Source File

Graphics/vtkCylinderSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkCylinderSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkCylinderSource_h
00044 #define __vtkCylinderSource_h
00045
00046 #include "vtkPolyDataSource.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkCylinderSource : public vtkPolyDataSource
00049 {
00050 public:
00051   static vtkCylinderSource *New();
00052   vtkTypeRevisionMacro(vtkCylinderSource,vtkPolyDataSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetClampMacro(Height,float,0.0,VTK_LARGE_FLOAT)
00058   vtkGetMacro(Height,float);
00060
00062
00063   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT)
00064   vtkGetMacro(Radius,float);
00066
00068
00069   vtkSetVector3Macro(Center,float);
00070   vtkGetVectorMacro(Center,float,3);
00072
00074
00075   vtkSetClampMacro(Resolution,int,0,VTK_CELL_SIZE)
00076   vtkGetMacro(Resolution,int);
00078
00080
00081   vtkSetMacro(Capping,int);
00082   vtkGetMacro(Capping,int);
00083   vtkBooleanMacro(Capping,int);
00085
00086 protected:
00087   vtkCylinderSource(int res=6);
00088   ~vtkCylinderSource() {};
00089
00090   void Execute();
00091   float Height;
00092   float Radius;
00093   float Center[3];
00094   int Resolution;
00095   int Capping;
00096
00097 private:
00098   vtkCylinderSource(const vtkCylinderSource&);  // Not implemented.
00099   void operator=(const vtkCylinderSource&);  // Not implemented.
00100 };
00101
00102 #endif
00103
00104
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDashedStreamLine.h Source File

Graphics/vtkDashedStreamLine.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDashedStreamLine.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkDashedStreamLine_h
00050 #define __vtkDashedStreamLine_h
00051
00052 #include "vtkStreamLine.h"
00053
00054 class VTK_GRAPHICS_EXPORT vtkDashedStreamLine : public vtkStreamLine
00055 {
00056 public:
00057   static vtkDashedStreamLine *New();
00058   vtkTypeRevisionMacro(vtkDashedStreamLine,vtkStreamLine);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00065   vtkSetClampMacro(DashFactor,float,0.01,1.0);
00066   vtkGetMacro(DashFactor,float);
00068
00069 protected:
00070   vtkDashedStreamLine();
00071   ~vtkDashedStreamLine() {};
00072
00073   // Convert streamer array into vtkPolyData
00074   void Execute();
00075
00076   // the fraction of on versus off in dash
00077   float DashFactor;
00078
00079 private:
00080   vtkDashedStreamLine(const vtkDashedStreamLine&);  // Not implemented.
00081   void operator=(const vtkDashedStreamLine&);  // Not implemented.
00082 };
00083
00084 #endif
00085
00086
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataArray.h Source File

Common/vtkDataArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkDataArray_h
00059 #define __vtkDataArray_h
00060
00061 #include "vtkObject.h"
00062 #include "vtkLargeInteger.h"
00063
00064 class vtkFloatArray;
00065 class vtkLookupTable;
00066 class vtkIdList;
00067
00068 class VTK_COMMON_EXPORT vtkDataArray : public vtkObject
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkDataArray,vtkObject);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075
00077   virtual int Allocate(const vtkIdType sz, const vtkIdType ext=1000) = 0;
00078   virtual void Initialize() = 0;
00080
00084   virtual vtkDataArray *MakeObject() = 0;
00085
00088   virtual int GetDataType() = 0;
00089
00092   virtual int GetDataTypeSize() = 0;
00093
00095
00097   vtkSetClampMacro(NumberOfComponents,int,1,VTK_LARGE_INTEGER);
00098   int GetNumberOfComponents() {return this->NumberOfComponents;};
00100
00103   virtual void SetNumberOfTuples(const vtkIdType number) = 0;
00104
00106
00107   vtkIdType GetNumberOfTuples()
00108     {return (this->MaxId + 1)/this->NumberOfComponents;}
00110
00115   virtual float *GetTuple(const vtkIdType i) = 0;
00116
00118
00121   virtual void GetTuple(const vtkIdType i, float * tuple) = 0;
00122   virtual void GetTuple(const vtkIdType i, double * tuple);
00124
00126
00129   float GetTuple1(const vtkIdType i);
00130   float* GetTuple2(const vtkIdType i);
00131   float* GetTuple3(const vtkIdType i);
00132   float* GetTuple4(const vtkIdType i);
00133   float* GetTuple9(const vtkIdType i);
00135
00139   void GetTuples(vtkIdList *ptIds, vtkDataArray *output);
00140
00144   void GetTuples(vtkIdType p1, vtkIdType p2, vtkDataArray *output);
00145
00147
00150   virtual void SetTuple(const vtkIdType i, const float * tuple) = 0;
00151   virtual void SetTuple(const vtkIdType i, const double * tuple);
00153
00155
00158   void SetTuple1(const vtkIdType i, float value);
00159   void SetTuple2(const vtkIdType i, float val0, float val1);
00160   void SetTuple3(const vtkIdType i, float val0, float val1, float val2);
00161   void SetTuple4(const vtkIdType i, float val0, float val1, float val2,
00162                  float val3);
00163   void SetTuple9(const vtkIdType i, float val0, float val1, float val2,
00164                  float val3, float val4, float val5, float val6,
00165                  float val7, float val8);
00167
00169
00171   virtual void InsertTuple(const vtkIdType i, const float * tuple) = 0;
00172   virtual void InsertTuple(const vtkIdType i, const double * tuple);
00174
00176
00179   void InsertTuple1(const vtkIdType i, float value);
00180   void InsertTuple2(const vtkIdType i, float val0, float val1);
00181   void InsertTuple3(const vtkIdType i, float val0, float val1, float val2);
00182   void InsertTuple4(const vtkIdType i, float val0, float val1, float val2,
00183                     float val3);
00184   void InsertTuple9(const vtkIdType i, float val0, float val1, float val2,
00185                     float val3, float val4, float val5, float val6,
00186                     float val7, float val8);
00188
00190
00193   virtual vtkIdType InsertNextTuple(const float * tuple) = 0;
00194   virtual vtkIdType InsertNextTuple(const double * tuple);
00196
00198
00201   void InsertNextTuple1(float value);
00202   void InsertNextTuple2(float val0, float val1);
00203   void InsertNextTuple3(float val0, float val1, float val2);
00204   void InsertNextTuple4(float val0, float val1, float val2,
00205                         float val3);
00206   void InsertNextTuple9(float val0, float val1, float val2,
00207                         float val3, float val4, float val5, float val6,
00208                         float val7, float val8);
00210
00214   virtual float GetComponent(const vtkIdType i, const int j);
00215
00220   virtual void SetComponent(const vtkIdType i, const int j, const float c);
00221
00225   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00226
00228
00234   virtual void GetData(vtkIdType tupleMin, vtkIdType tupleMax, int compMin,
00235                        int compMax, vtkFloatArray* data);
00237
00240   virtual void DeepCopy(vtkDataArray *da);
00241
00246   virtual void FillComponent(const int j, const float c);
00247
00249
00255   virtual void CopyComponent(const int j, vtkDataArray *from,
00256                              const int fromComponent);
00258
00261   virtual void *GetVoidPointer(const vtkIdType id) = 0;
00262
00264   virtual void Squeeze() = 0;
00265
00267   virtual void Resize(vtkIdType numTuples) = 0;
00268
00270
00271   void Reset()
00272     {this->MaxId = -1;}
00274
00276
00277   vtkIdType GetSize()
00278     {return this->Size;}
00280
00282
00283   vtkIdType GetMaxId()
00284     {return this->MaxId;}
00286
00288
00294   virtual void SetVoidArray(void *vtkNotUsed(array),
00295                             vtkIdType vtkNotUsed(size),
00296                             int vtkNotUsed(save)) {};
00298
00305   unsigned long GetActualMemorySize();
00306
00309   void CreateDefaultLookupTable();
00310
00312
00313   void SetLookupTable(vtkLookupTable *lut);
00314   vtkGetObjectMacro(LookupTable,vtkLookupTable);
00316
00318
00319   void SetName(const char* name);
00320   const char* GetName();
00322
00324
00326   void GetRange(float range[2], int comp)
00327     {
00328       this->ComputeRange(comp);
00329       memcpy(range, this->Range, 2*sizeof(float));
00330     }
00331   float* GetRange(int comp)
00332     {
00333       this->ComputeRange(comp);
00334       return this->Range;
00335     }
00337
00338   virtual void ComputeRange(int comp);
00340
00342   float* GetRange()
00343     {
00344       this->ComputeRange(0);
00345       return this->Range;
00346     }
00347   void GetRange(float range[2])
00348     {
00349       this->GetRange(range,0);
00350     }
00352
00354
00357   void GetDataTypeRange(double range[2]);
00358   double GetDataTypeMin();
00359   double GetDataTypeMax();
00361
00364   virtual float GetMaxNorm();
00365
00371   static vtkDataArray* CreateDataArray(int dataType);
00372
00373 protected:
00374   // Construct object with default tuple dimension (number of components) of 1.
00375   vtkDataArray(vtkIdType numComp=1);
00376   ~vtkDataArray();
00377
00378   vtkLookupTable *LookupTable;
00379
00380   vtkIdType Size;      // allocated size of data
00381   vtkIdType MaxId;     // maximum index inserted thus far
00382   int NumberOfComponents; // the number of components per tuple
00383
00384   char* Name;
00385
00386 private:
00387   float Range[2];
00388   int ComponentForLastRange;
00389   vtkTimeStamp ComputeTimeForLastRange;
00390
00391   float* GetTupleN(const vtkIdType i, int n);
00392
00393 private:
00394   vtkDataArray(const vtkDataArray&);  // Not implemented.
00395   void operator=(const vtkDataArray&);  // Not implemented.
00396 };
00397
00398 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataObject.h Source File

Common/vtkDataObject.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObject.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkDataObject_h
00047 #define __vtkDataObject_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkFieldData.h"
00051
00052 class vtkProcessObject;
00053 class vtkSource;
00054 class vtkExtentTranslator;
00055
00056 #define VTK_PIECES_EXTENT   0
00057 #define VTK_3D_EXTENT       1
00058
00059 class VTK_COMMON_EXPORT vtkDataObject : public vtkObject
00060 {
00061 public:
00062   static vtkDataObject *New();
00063
00064   vtkTypeRevisionMacro(vtkDataObject,vtkObject);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068   virtual vtkDataObject *MakeObject() {return vtkDataObject::New();}
00069
00071
00072   vtkGetObjectMacro(Source,vtkSource);
00073   void SetSource(vtkSource *s);
00075
00078   unsigned long int GetMTime();
00079
00080   // Rescription:
00081   // Restore data object to initial state,
00082   virtual void Initialize();
00083
00088   void ReleaseData();
00089
00092   int ShouldIReleaseData();
00093
00095
00096   vtkGetMacro(DataReleased,int);
00098
00100
00102   vtkSetMacro(ReleaseDataFlag,int);
00103   vtkGetMacro(ReleaseDataFlag,int);
00104   vtkBooleanMacro(ReleaseDataFlag,int);
00106
00108
00110   static void SetGlobalReleaseDataFlag(int val);
00111   void GlobalReleaseDataFlagOn() {this->SetGlobalReleaseDataFlag(1);};
00112   void GlobalReleaseDataFlagOff() {this->SetGlobalReleaseDataFlag(0);};
00113   static int GetGlobalReleaseDataFlag();
00115
00117
00118   vtkSetObjectMacro(FieldData,vtkFieldData);
00119   vtkGetObjectMacro(FieldData,vtkFieldData);
00121
00122   // Handle the source/data loop.
00123   void UnRegister(vtkObject *o);
00124
00128   virtual int GetNetReferenceCount() {return this->ReferenceCount;};
00129
00135   virtual void Update();
00136
00142   virtual void UpdateInformation();
00143
00148   virtual void PropagateUpdateExtent();
00149
00155   virtual void TriggerAsynchronousUpdate();
00156
00163   virtual void UpdateData();
00164
00170   virtual unsigned long GetEstimatedMemorySize();
00171
00173
00176   virtual void SetUpdateExtent(int vtkNotUsed(piece),int vtkNotUsed(numPieces),
00177                                int vtkNotUsed(ghostLevel))
00178     {vtkErrorMacro("Subclass did not implement 'SetUpdateExtent'");}
00179   void SetUpdateExtent(int piece, int numPieces)
00180     {this->SetUpdateExtent(piece, numPieces, 0);}
00182
00184
00191   virtual void SetUpdateExtent(int x1, int x2, int y1, int y2, int z1, int z2);
00192   virtual void SetUpdateExtent( int ext[6] );
00193   vtkGetVector6Macro( UpdateExtent, int );
00195
00200   virtual int GetDataObjectType() {return VTK_DATA_OBJECT;}
00201
00204   unsigned long GetUpdateTime();
00205
00210   void SetUpdateExtentToWholeExtent();
00211
00212   void SetPipelineMTime(unsigned long time) {this->PipelineMTime = time; }
00213   vtkGetMacro(PipelineMTime, unsigned long);
00214
00220   virtual unsigned long GetActualMemorySize();
00221
00223   void CopyInformation( vtkDataObject *data );
00224
00226
00227   virtual void CopyTypeSpecificInformation( vtkDataObject *data )
00228     {this->CopyInformation( data );};
00230
00232
00234   void SetUpdatePiece(int piece);
00235   void SetUpdateNumberOfPieces(int num);
00236   vtkGetMacro( UpdatePiece, int );
00237   vtkGetMacro( UpdateNumberOfPieces, int );
00239
00241
00243   void SetUpdateGhostLevel(int level);
00244   vtkGetMacro(UpdateGhostLevel, int);
00246
00248
00253   void SetRequestExactExtent(int v);
00254   vtkGetMacro(RequestExactExtent, int);
00255   vtkBooleanMacro(RequestExactExtent, int);
00257
00259
00262   vtkSetVector6Macro( WholeExtent, int );
00263   vtkGetVector6Macro( WholeExtent, int );
00265
00267
00271   vtkSetMacro( MaximumNumberOfPieces, int );
00272   vtkGetMacro( MaximumNumberOfPieces, int );
00274
00278   void DataHasBeenGenerated();
00279
00283   virtual void PrepareForNewData() {this->Initialize();};
00284
00286
00288   virtual void ShallowCopy(vtkDataObject *src);
00289   virtual void DeepCopy(vtkDataObject *src);
00291
00293
00296   vtkSetMacro(Locality, float);
00297   vtkGetMacro(Locality, float);
00299
00301
00302   void SetExtentTranslator(vtkExtentTranslator *translator);
00303   vtkExtentTranslator *GetExtentTranslator();
00305
00307
00308   vtkGetMacro(NumberOfConsumers,int);
00310
00312
00313   void AddConsumer(vtkObject *c);
00314   void RemoveConsumer(vtkObject *c);
00315   vtkObject *GetConsumer(int i);
00316   int IsConsumer(vtkObject *c);
00318
00319
00320 protected:
00321
00322   vtkDataObject();
00323   ~vtkDataObject();
00324
00325   // General field data associated with data object
00326   vtkFieldData  *FieldData;
00327
00328   // Who generated this data as output?
00329   vtkSource     *Source;
00330
00331   // Keep track of data release during network execution
00332   int DataReleased;
00333
00334   // how many consumers does this object have
00335   int NumberOfConsumers;
00336   vtkObject **Consumers;
00337
00339   int UpdateExtentIsOutsideOfTheExtent();
00340
00345   int UpdateExtentIsEmpty();
00346
00354   virtual int VerifyUpdateExtent();
00355
00356   // The ExtentType will be left as VTK_PIECES_EXTENT for data objects
00357   // such as vtkPolyData and vtkUnstructuredGrid. The ExtentType will be
00358   // changed to VTK_3D_EXTENT for data objects with 3D structure such as
00359   // vtkImageData (and its subclass vtkStructuredPoints), vtkRectilinearGrid,
00360   // and vtkStructuredGrid. The default is the have an extent in pieces,
00361   // with only one piece (no streaming possible).
00362   virtual int GetExtentType() { return VTK_PIECES_EXTENT; };
00363
00364   // If the ExtentType is VTK_3D_EXTENT, then these three extent variables
00365   // represent the whole extent, the extent currently in memory, and the
00366   // requested update extent. The extent is given as 3 min/max pairs.
00367   int WholeExtent[6];
00368   int Extent[6];
00369   int UpdateExtent[6];
00370   // First update, the update extent will be set to the whole extent.
00371   unsigned char UpdateExtentInitialized;
00372   // An object to translate from unstructured pieces to structured extents.
00373   vtkExtentTranslator *ExtentTranslator;
00374
00375   // Unstructured request stuff
00376   int NumberOfPieces;
00377   int Piece;
00378   int MaximumNumberOfPieces;
00379   int UpdateNumberOfPieces;
00380   int UpdatePiece;
00381
00382   // This request flag indicates whether the requester can handle
00383   // more data than requested.  Right now it is used in vtkImageData.
00384   // Image filters can return more data than requested.  The the
00385   // consumer cannot handle this (i.e. DataSetToDataSetFitler)
00386   // this image will crop itself.  This functionality used to be in
00387   // ImageToStructuredPoints.
00388   int RequestExactExtent;
00389
00390   // This method crops the data object (if necesary) so that the extent
00391   // matches the update extent.
00392   virtual void Crop();
00393
00394   int GhostLevel;
00395   int UpdateGhostLevel;
00396
00397   // Data will release after use by a filter if this flag is set
00398   int ReleaseDataFlag;
00399
00400   // When was this data last generated?
00401   vtkTimeStamp UpdateTime;
00402
00403   // The Maximum MTime of all upstream filters and data objects.
00404   // This does not include the MTime of this data object.
00405   unsigned long PipelineMTime;
00406
00407   // Was the update extent propagated down the pipeline
00408   int LastUpdateExtentWasOutsideOfTheExtent;
00409
00410   // A value indicating whether we have a port upstream and how
00411   // many filters removed it is.
00412   // 0.0 : no ports.
00413   // 1.0 : my source is a port.
00414   // 0.5 : the next upstream filter is a port ...
00415   float Locality;
00416
00417 private:
00418   // Helper method for the ShallowCopy and DeepCopy methods.
00419   void InternalDataObjectCopy(vtkDataObject *src);
00420 private:
00421   vtkDataObject(const vtkDataObject&);  // Not implemented.
00422   void operator=(const vtkDataObject&);  // Not implemented.
00423 };
00424
00425 #endif
00426
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataObjectCollection.h Source File

Common/vtkDataObjectCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObjectCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkDataObjectCollection_h
00034 #define __vtkDataObjectCollection_h
00035
00036 #include "vtkCollection.h"
00037 #include "vtkDataObject.h"
00038
00039 class VTK_COMMON_EXPORT vtkDataObjectCollection : public vtkCollection
00040 {
00041 public:
00042   static vtkDataObjectCollection *New();
00043   vtkTypeRevisionMacro(vtkDataObjectCollection,vtkCollection);
00044
00046
00047   void AddItem(vtkDataObject *ds) {
00048     this->vtkCollection::AddItem((vtkObject *)ds);};
00050
00052
00053   vtkDataObject *GetNextItem() {
00054     return static_cast<vtkDataObject *>(this->GetNextItemAsObject());};
00056
00058
00059   vtkDataObject *GetItem(int i) {
00060     return static_cast<vtkDataObject *>(this->GetItemAsObject(i));};
00062
00063 protected:
00064   vtkDataObjectCollection() {};
00065   ~vtkDataObjectCollection() {};
00066
00067
00068 private:
00069   // hide the standard AddItem from the user and the compiler.
00070   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00071
00072 private:
00073   vtkDataObjectCollection(const vtkDataObjectCollection&);  // Not implemented.
00074   void operator=(const vtkDataObjectCollection&);  // Not implemented.
00075 };
00076
00077
00078 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataObjectReader.h Source File

IO/vtkDataObjectReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObjectReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkDataObjectReader_h
00045 #define __vtkDataObjectReader_h
00046
00047 #include "vtkDataReader.h"
00048 #include "vtkDataObject.h"
00049
00050 class VTK_IO_EXPORT vtkDataObjectReader : public vtkDataReader
00051 {
00052 public:
00053   static vtkDataObjectReader *New();
00054   vtkTypeRevisionMacro(vtkDataObjectReader,vtkDataReader);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkDataObject *GetOutput();
00060   vtkDataObject *GetOutput(int idx)
00061     {return this->vtkSource::GetOutput(idx); };
00062   void SetOutput(vtkDataObject *);
00064
00065 protected:
00066   vtkDataObjectReader();
00067   ~vtkDataObjectReader();
00068
00069   void Execute();
00070 private:
00071   vtkDataObjectReader(const vtkDataObjectReader&);  // Not implemented.
00072   void operator=(const vtkDataObjectReader&);  // Not implemented.
00073 };
00074
00075 #endif
00076
00077
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataObjectSource.h Source File

Filtering/vtkDataObjectSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObjectSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkDataObjectSource_h
00065 #define __vtkDataObjectSource_h
00066
00067 #include "vtkSource.h"
00068
00069 class vtkDataObject;
00070
00071 class VTK_FILTERING_EXPORT vtkDataObjectSource : public vtkSource
00072 {
00073 public:
00074   static vtkDataObjectSource *New();
00075   vtkTypeRevisionMacro(vtkDataObjectSource,vtkSource);
00076
00078
00079   vtkDataObject *GetOutput();
00080   vtkDataObject *GetOutput(int idx)
00081     {return (vtkDataObject *) this->vtkSource::GetOutput(idx); };
00082   void SetOutput(vtkDataObject *);
00084
00085 protected:
00086   vtkDataObjectSource();
00087   ~vtkDataObjectSource() {};
00088
00089 private:
00090   vtkDataObjectSource(const vtkDataObjectSource&);  // Not implemented.
00091   void operator=(const vtkDataObjectSource&);  // Not implemented.
00092 };
00093
00094 #endif
00095
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDataObjectToDataSetFilter.h Source File

Graphics/vtkDataObjectToDataSetFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObjectToDataSetFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00082 #ifndef __vtkDataObjectToDataSetFilter_h
00083 #define __vtkDataObjectToDataSetFilter_h
00084
00085 #include "vtkSource.h"
00086 #include "vtkFieldData.h"
00087 #include "vtkDataSet.h"
00088
00089 class vtkPointSet;
00090 class vtkPolyData;
00091 class vtkStructuredPoints;
00092 class vtkStructuredGrid;
00093 class vtkRectilinearGrid;
00094 class vtkUnstructuredGrid;
00095 class vtkCellArray;
00096
00097 class VTK_GRAPHICS_EXPORT vtkDataObjectToDataSetFilter : public vtkSource
00098 {
00099 public:
00100   static vtkDataObjectToDataSetFilter *New();
00101   vtkTypeRevisionMacro(vtkDataObjectToDataSetFilter,vtkSource);
00102   void PrintSelf(ostream& os, vtkIndent indent);
00103
00105
00106   void SetInput(vtkDataObject *input);
00107   vtkDataObject *GetInput();
00109
00111
00112   void SetDataSetType(int);
00113   vtkGetMacro(DataSetType,int);
00114   void SetDataSetTypeToPolyData() {
00115     this->SetDataSetType(VTK_POLY_DATA);};
00116   void SetDataSetTypeToStructuredPoints() {
00117     this->SetDataSetType(VTK_STRUCTURED_POINTS);};
00118   void SetDataSetTypeToStructuredGrid() {
00119     this->SetDataSetType(VTK_STRUCTURED_GRID);};
00120   void SetDataSetTypeToRectilinearGrid() {
00121     this->SetDataSetType(VTK_RECTILINEAR_GRID);};
00122   void SetDataSetTypeToUnstructuredGrid() {
00123     this->SetDataSetType(VTK_UNSTRUCTURED_GRID);};
00125
00127
00132   vtkDataSet *GetOutput();
00133   vtkDataSet *GetOutput(int idx)
00134     {return static_cast<vtkDataSet *>(this->vtkSource::GetOutput(idx)); };
00135   vtkPolyData *GetPolyDataOutput();
00136   vtkStructuredPoints *GetStructuredPointsOutput();
00137   vtkStructuredGrid *GetStructuredGridOutput();
00138   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00139   vtkRectilinearGrid *GetRectilinearGridOutput();
00141
00143
00154   void SetPointComponent(int comp, char *arrayName, int arrayComp,
00155                          int min, int max, int normalize);
00156   void SetPointComponent(int comp, char *arrayName, int arrayComp)
00157     {this->SetPointComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00158   const char *GetPointComponentArrayName(int comp);
00159   int GetPointComponentArrayComponent(int comp);
00160   int GetPointComponentMinRange(int comp);
00161   int GetPointComponentMaxRange(int comp);
00162   int GetPointComponentNormailzeFlag(int comp);
00164
00166
00173   void SetVertsComponent(char *arrayName, int arrayComp, int min, int max);
00174   void SetVertsComponent(char *arrayName, int arrayComp)
00175     {this->SetVertsComponent(arrayName, arrayComp, -1, -1);};
00176   const char *GetVertsComponentArrayName();
00177   int GetVertsComponentArrayComponent();
00178   int GetVertsComponentMinRange();
00179   int GetVertsComponentMaxRange();
00180   void SetLinesComponent(char *arrayName, int arrayComp, int min, int max);
00181   void SetLinesComponent(char *arrayName, int arrayComp)
00182     {this->SetLinesComponent(arrayName, arrayComp, -1, -1);};
00183   const char *GetLinesComponentArrayName();
00184   int GetLinesComponentArrayComponent();
00185   int GetLinesComponentMinRange();
00186   int GetLinesComponentMaxRange();
00187   void SetPolysComponent(char *arrayName, int arrayComp, int min, int max);
00188   void SetPolysComponent(char *arrayName, int arrayComp)
00189     {this->SetPolysComponent(arrayName, arrayComp, -1, -1);};
00190   const char *GetPolysComponentArrayName();
00191   int GetPolysComponentArrayComponent();
00192   int GetPolysComponentMinRange();
00193   int GetPolysComponentMaxRange();
00194   void SetStripsComponent(char *arrayName, int arrayComp, int min, int max);
00195   void SetStripsComponent(char *arrayName, int arrayComp)
00196     {this->SetStripsComponent(arrayName, arrayComp, -1, -1);};
00197   const char *GetStripsComponentArrayName();
00198   int GetStripsComponentArrayComponent();
00199   int GetStripsComponentMinRange();
00200   int GetStripsComponentMaxRange();
00202
00204
00211   void SetCellTypeComponent(char *arrayName, int arrayComp,
00212                             int min, int max);
00213   void SetCellTypeComponent(char *arrayName, int arrayComp)
00214     {this->SetCellTypeComponent(arrayName, arrayComp, -1, -1);};
00215   const char *GetCellTypeComponentArrayName();
00216   int GetCellTypeComponentArrayComponent();
00217   int GetCellTypeComponentMinRange();
00218   int GetCellTypeComponentMaxRange();
00219   void SetCellConnectivityComponent(char *arrayName, int arrayComp,
00220                                     int min, int max);
00221   void SetCellConnectivityComponent(char *arrayName, int arrayComp)
00222     {this->SetCellConnectivityComponent(arrayName, arrayComp, -1, -1);};
00223   const char *GetCellConnectivityComponentArrayName();
00224   int GetCellConnectivityComponentArrayComponent();
00225   int GetCellConnectivityComponentMinRange();
00226   int GetCellConnectivityComponentMaxRange();
00228
00230
00232   vtkSetMacro(DefaultNormalize,int);
00233   vtkGetMacro(DefaultNormalize,int);
00234   vtkBooleanMacro(DefaultNormalize,int);
00236
00238
00241   vtkSetVector3Macro(Dimensions,int);
00242   vtkGetVectorMacro(Dimensions,int,3);
00244
00246
00248   vtkSetVector3Macro(Origin,float);
00249   vtkGetVectorMacro(Origin,float,3);
00251
00253
00255   vtkSetVector3Macro(Spacing,float);
00256   vtkGetVectorMacro(Spacing,float,3);
00258
00260
00265   void SetDimensionsComponent(char *arrayName, int arrayComp, int min, int max);
00266   void SetDimensionsComponent(char *arrayName, int arrayComp)
00267     {this->SetDimensionsComponent(arrayName, arrayComp, -1, -1);};
00268   void SetSpacingComponent(char *arrayName, int arrayComp, int min, int max);
00269   void SetSpacingComponent(char *arrayName, int arrayComp)
00270     {this->SetSpacingComponent(arrayName, arrayComp, -1, -1);};
00271   void SetOriginComponent(char *arrayName, int arrayComp, int min, int max);
00272   void SetOriginComponent(char *arrayName, int arrayComp)
00273     {this->SetOriginComponent(arrayName, arrayComp, -1, -1);};
00275
00276 protected:
00277   vtkDataObjectToDataSetFilter();
00278   ~vtkDataObjectToDataSetFilter();
00279
00280   void Execute(); //generate output data
00281   void ExecuteInformation();
00282   void ComputeInputUpdateExtents(vtkDataObject *output);
00283
00284   char Updating;
00285
00286   // control flags used to generate the output dataset
00287   int DataSetType; //the type of dataset to generate
00288
00289   // Support definition of points
00290   char *PointArrays[3]; //the name of the arrays
00291   int PointArrayComponents[3]; //the array components used for x-y-z
00292   vtkIdType PointComponentRange[3][2]; //the range of the components to use
00293   int PointNormalize[3]; //flags control normalization
00294
00295   // These define cells for vtkPolyData
00296   char *VertsArray; //the name of the array
00297   int VertsArrayComponent; //the array component
00298   vtkIdType VertsComponentRange[2]; //the range of the components to use
00299
00300   char *LinesArray; //the name of the array
00301   int LinesArrayComponent; //the array component used for cell types
00302   vtkIdType LinesComponentRange[2]; //the range of the components to use
00303
00304   char *PolysArray; //the name of the array
00305   int PolysArrayComponent; //the array component
00306   vtkIdType PolysComponentRange[2]; //the range of the components to use
00307
00308   char *StripsArray; //the name of the array
00309   int StripsArrayComponent; //the array component
00310   vtkIdType StripsComponentRange[2]; //the range of the components to use
00311
00312   // Used to define vtkUnstructuredGrid datasets
00313   char *CellTypeArray; //the name of the array
00314   int CellTypeArrayComponent; //the array component used for cell types
00315   vtkIdType CellTypeComponentRange[2]; //the range of the components to use
00316
00317   char *CellConnectivityArray; //the name of the array
00318   int CellConnectivityArrayComponent; //the array components used for cell connectivity
00319   vtkIdType CellConnectivityComponentRange[2]; //the range of the components to use
00320
00321   // helper methods (and attributes) to construct datasets
00322   void SetArrayName(char* &name, char *newName);
00323   vtkIdType ConstructPoints(vtkPointSet *ps);
00324   vtkIdType ConstructPoints(vtkRectilinearGrid *rg);
00325   int ConstructCells(vtkPolyData *pd);
00326   int ConstructCells(vtkUnstructuredGrid *ug);
00327   vtkCellArray *ConstructCellArray(vtkDataArray *da, int comp,
00328                                    vtkIdType compRange[2]);
00329
00330   // Default value for normalization
00331   int DefaultNormalize;
00332
00333   // Couple of different ways to specify dimensions, spacing, and origin.
00334   int Dimensions[3];
00335   float Origin[3];
00336   float Spacing[3];
00337
00338   char *DimensionsArray; //the name of the array
00339   int DimensionsArrayComponent; //the component of the array used for dimensions
00340   vtkIdType DimensionsComponentRange[2]; //the ComponentRange of the array for the dimensions
00341
00342   char *OriginArray; //the name of the array
00343   int OriginArrayComponent; //the component of the array used for Origins
00344   vtkIdType OriginComponentRange[2]; //the ComponentRange of the array for the Origins
00345
00346   char *SpacingArray; //the name of the array
00347   int SpacingArrayComponent; //the component of the array used for Spacings
00348   vtkIdType SpacingComponentRange[2]; //the ComponentRange of the array for the Spacings
00349
00350   void ConstructDimensions();
00351   void ConstructSpacing();
00352   void ConstructOrigin();
00353
00354 private:
00355   vtkDataObjectToDataSetFilter(const vtkDataObjectToDataSetFilter&);  // Not implemented.
00356   void operator=(const vtkDataObjectToDataSetFilter&);  // Not implemented.
00357 };
00358
00359 #endif
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataObjectWriter.h Source File

IO/vtkDataObjectWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataObjectWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkDataObjectWriter_h
00044 #define __vtkDataObjectWriter_h
00045
00046 #include "vtkDataWriter.h"
00047 #include "vtkFieldData.h"
00048
00049 class VTK_IO_EXPORT vtkDataObjectWriter : public vtkWriter
00050 {
00051 public:
00052   static vtkDataObjectWriter *New();
00053   vtkTypeRevisionMacro(vtkDataObjectWriter,vtkWriter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   void SetInput(vtkDataObject *input);
00059   vtkDataObject *GetInput();
00061
00063
00064   void SetFileName(const char *filename) {this->Writer->SetFileName(filename);};
00065   char *GetFileName() {return this->Writer->GetFileName();};
00066   void SetHeader(char *header) {this->Writer->SetHeader(header);};
00067   char *GetHeader() {return this->Writer->GetHeader();};
00068   void SetFileType(int type) {this->Writer->SetFileType(type);};
00069   int GetFileType() {return this->Writer->GetFileType();};
00070   void SetFileTypeToASCII() {this->Writer->SetFileType(VTK_ASCII);};
00071   void SetFileTypeToBinary() {this->Writer->SetFileType(VTK_BINARY);};
00072   void SetFieldDataName(char *fieldname) {this->Writer->SetFieldDataName(fieldname);};
00073   char *GetFieldDataName() {return this->Writer->GetFieldDataName();};
00075
00077
00078   void SetInput(vtkDataObject &input)
00079     {this->SetInput(&input);}
00081
00082 protected:
00083   vtkDataObjectWriter();
00084   ~vtkDataObjectWriter();
00085
00086   void WriteData();
00087   vtkDataWriter *Writer;
00088
00089 private:
00090   vtkDataObjectWriter(const vtkDataObjectWriter&);  // Not implemented.
00091   void operator=(const vtkDataObjectWriter&);  // Not implemented.
00092 };
00093
00094 #endif
00095
00096
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataReader.h Source File

IO/vtkDataReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkDataReader_h
00041 #define __vtkDataReader_h
00042
00043 #include "vtkSource.h"
00044 #include "vtkDataSetAttributes.h"
00045 #include "vtkCharArray.h"
00046
00047 #define VTK_ASCII 1
00048 #define VTK_BINARY 2
00049
00050 class vtkDataSet;
00051 class vtkPointSet;
00052 class vtkRectilinearGrid;
00053
00054 class VTK_IO_EXPORT vtkDataReader : public vtkSource
00055 {
00056 public:
00057   static vtkDataReader *New();
00058   vtkTypeRevisionMacro(vtkDataReader,vtkObject);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   vtkSetStringMacro(FileName);
00064   vtkGetStringMacro(FileName);
00066
00068
00070   int IsFileValid(const char *dstype);
00071   int IsFileStructuredPoints() {
00072     return this->IsFileValid("structured_points");};
00073   int IsFilePolyData() {
00074     return this->IsFileValid("polydata");};
00075   int IsFileStructuredGrid() {
00076     return this->IsFileValid("structured_grid");};
00077   int IsFileUnstructuredGrid() {
00078     return this->IsFileValid("unstructured_grid");};
00079   int IsFileRectilinearGrid() {
00080     return this->IsFileValid("rectilinear_grid");};
00082
00084
00088   void SetInputString(const char *in);
00089   vtkGetStringMacro(InputString);
00090   void SetInputString(const char *in, int len);
00091   vtkGetMacro(InputStringLength, int);
00092   void SetBinaryInputString(const char *, int len);
00094
00096
00102   vtkSetObjectMacro(InputArray, vtkCharArray);
00103   vtkGetObjectMacro(InputArray, vtkCharArray);
00105
00107
00108   vtkGetStringMacro(Header);
00110
00112
00114   vtkSetMacro(ReadFromInputString,int);
00115   vtkGetMacro(ReadFromInputString,int);
00116   vtkBooleanMacro(ReadFromInputString,int);
00118
00120
00122   vtkGetMacro(FileType,int);
00124
00126
00130   int GetNumberOfScalarsInFile()
00131     {this->CharacterizeFile(); return this->NumberOfScalarsInFile;}
00132   int GetNumberOfVectorsInFile()
00133     {this->CharacterizeFile(); return this->NumberOfVectorsInFile;}
00134   int GetNumberOfTensorsInFile()
00135     {this->CharacterizeFile(); return this->NumberOfTensorsInFile;}
00136   int GetNumberOfNormalsInFile()
00137     {this->CharacterizeFile(); return this->NumberOfNormalsInFile;}
00138   int GetNumberOfTCoordsInFile()
00139     {this->CharacterizeFile(); return this->NumberOfTCoordsInFile;}
00140   int GetNumberOfFieldDataInFile()
00141     {this->CharacterizeFile(); return this->NumberOfFieldDataInFile;}
00143
00145
00148   const char *GetScalarsNameInFile(int i);
00149   const char *GetVectorsNameInFile(int i);
00150   const char *GetTensorsNameInFile(int i);
00151   const char *GetNormalsNameInFile(int i);
00152   const char *GetTCoordsNameInFile(int i);
00153   const char *GetFieldDataNameInFile(int i);
00155
00157
00159   vtkSetStringMacro(ScalarsName);
00160   vtkGetStringMacro(ScalarsName);
00162
00164
00166   vtkSetStringMacro(VectorsName);
00167   vtkGetStringMacro(VectorsName);
00169
00171
00173   vtkSetStringMacro(TensorsName);
00174   vtkGetStringMacro(TensorsName);
00176
00178
00180   vtkSetStringMacro(NormalsName);
00181   vtkGetStringMacro(NormalsName);
00183
00185
00187   vtkSetStringMacro(TCoordsName);
00188   vtkGetStringMacro(TCoordsName);
00190
00192
00195   vtkSetStringMacro(LookupTableName);
00196   vtkGetStringMacro(LookupTableName);
00198
00200
00202   vtkSetStringMacro(FieldDataName);
00203   vtkGetStringMacro(FieldDataName);
00205
00207   int OpenVTKFile();
00208
00210   int ReadHeader();
00211
00215   int ReadCellData(vtkDataSet *ds, int numCells);
00216
00220   int ReadPointData(vtkDataSet *ds, int numPts);
00221
00223   int ReadPoints(vtkPointSet *ps, int numPts);
00224
00226   int ReadCells(int size, int *data);
00227
00229   int ReadCells(int size, int *data, int skip1, int read2, int skip3);
00230
00233   int ReadCoordinates(vtkRectilinearGrid *rg, int axes, int numCoords);
00234
00236
00237   vtkDataArray *ReadArray(const char *dataType, int numTuples, int numComp);
00238   vtkFieldData *ReadFieldData();
00240
00242
00244   int Read(char *);
00245   int Read(unsigned char *);
00246   int Read(short *);
00247   int Read(unsigned short *);
00248   int Read(int *);
00249   int Read(unsigned int *);
00250   int Read(long *);
00251   int Read(unsigned long *);
00252   int Read(float *);
00253   int Read(double *);
00255
00257   void CloseVTKFile();
00258
00259 //BTX
00262   int ReadLine(char result[256]);
00263
00266   int ReadString(char result[256]);
00267
00269   char *LowerCase(char *str, const size_t len=256);
00270
00272   istream *GetIStream() {return this->IS;};
00273 //ETX
00274
00275 protected:
00276   vtkDataReader();
00277   ~vtkDataReader();
00278
00279   char *FileName;
00280   int FileType;
00281   istream *IS;
00282
00283   char *ScalarsName;
00284   char *VectorsName;
00285   char *TensorsName;
00286   char *TCoordsName;
00287   char *NormalsName;
00288   char *LookupTableName;
00289   char *FieldDataName;
00290   char *ScalarLut;
00291
00292   int ReadFromInputString;
00293   char *InputString;
00294   int InputStringLength;
00295   int InputStringPos;
00296
00297   vtkSetStringMacro(ScalarLut);
00298   vtkGetStringMacro(ScalarLut);
00299
00300   char *Header;
00301
00302   int ReadScalarData(vtkDataSetAttributes *a, int num);
00303   int ReadVectorData(vtkDataSetAttributes *a, int num);
00304   int ReadNormalData(vtkDataSetAttributes *a, int num);
00305   int ReadTensorData(vtkDataSetAttributes *a, int num);
00306   int ReadCoScalarData(vtkDataSetAttributes *a, int num);
00307   int ReadLutData(vtkDataSetAttributes *a);
00308   int ReadTCoordsData(vtkDataSetAttributes *a, int num);
00309
00310   int ReadDataSetData(vtkDataSet *ds);
00311
00312   // This supports getting additional information from vtk files
00313   int  NumberOfScalarsInFile;
00314   char **ScalarsNameInFile;
00315   int ScalarsNameAllocSize;
00316   int  NumberOfVectorsInFile;
00317   char **VectorsNameInFile;
00318   int VectorsNameAllocSize;
00319   int  NumberOfTensorsInFile;
00320   char **TensorsNameInFile;
00321   int TensorsNameAllocSize;
00322   int  NumberOfTCoordsInFile;
00323   char **TCoordsNameInFile;
00324   int TCoordsNameAllocSize;
00325   int  NumberOfNormalsInFile;
00326   char **NormalsNameInFile;
00327   int NormalsNameAllocSize;
00328   int  NumberOfFieldDataInFile;
00329   char **FieldDataNameInFile;
00330   int FieldDataNameAllocSize;
00331   vtkTimeStamp CharacteristicsTime;
00332
00333   void InitializeCharacteristics();
00334   int CharacterizeFile(); //read entire file, storing important characteristics
00335   void CheckFor(const char* name, char *line, int &num, char** &array,
00336                 int& allocSize);
00337
00338   vtkCharArray* InputArray;
00339
00342   void DecodeArrayName(char *resname, const char* name);
00343
00344 private:
00345   vtkDataReader(const vtkDataReader&);  // Not implemented.
00346   void operator=(const vtkDataReader&);  // Not implemented.
00347 };
00348
00349 #endif
00350
00351
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataSet.h Source File

Common/vtkDataSet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkDataSet_h
00055 #define __vtkDataSet_h
00056
00057 #include "vtkDataObject.h"
00058 #include "vtkCellData.h"
00059 #include "vtkPointData.h"
00060 #include "vtkGenericCell.h"
00061 #include "vtkCellTypes.h"
00062
00063 class VTK_COMMON_EXPORT vtkDataSet : public vtkDataObject
00064 {
00065 public:
00066   vtkTypeRevisionMacro(vtkDataSet,vtkDataObject);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00072   virtual void CopyStructure(vtkDataSet *ds) = 0;
00073
00076   virtual vtkIdType GetNumberOfPoints() = 0;
00077
00080   virtual vtkIdType GetNumberOfCells() = 0;
00081
00084   virtual float *GetPoint(vtkIdType ptId) = 0;
00085
00089   virtual void GetPoint(vtkIdType id, float x[3]);
00090
00093   virtual vtkCell *GetCell(vtkIdType cellId) = 0;
00094
00099   virtual void GetCell(vtkIdType cellId, vtkGenericCell *cell) = 0;
00100
00109   virtual void GetCellBounds(vtkIdType cellId, float bounds[6]);
00110
00114   virtual int GetCellType(vtkIdType cellId) = 0;
00115
00123   virtual void GetCellTypes(vtkCellTypes *types);
00124
00128   virtual void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds) = 0;
00129
00133   virtual void GetPointCells(vtkIdType ptId, vtkIdList *cellIds) = 0;
00134
00136
00140   virtual void GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds,
00141                                 vtkIdList *cellIds);
00143
00145
00149   vtkIdType FindPoint(float x, float y, float z)
00150     {
00151     float xyz[3];
00152     xyz[0] = x; xyz[1] = y; xyz[2] = z;
00153     return this->FindPoint (xyz);
00154     }
00155   virtual vtkIdType FindPoint(float x[3]) = 0;
00157
00159
00167   virtual vtkIdType FindCell(float x[3], vtkCell *cell, vtkIdType cellId,
00168                              float tol2, int& subId, float pcoords[3],
00169                              float *weights) = 0;
00171
00173
00178   virtual vtkIdType FindCell(float x[3], vtkCell *cell,
00179                              vtkGenericCell *gencell, vtkIdType cellId,
00180                              float tol2, int& subId, float pcoords[3],
00181                              float *weights) = 0;
00183
00185
00191   virtual vtkCell *FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId,
00192                                   float tol2, int& subId, float pcoords[3],
00193                                   float *weights);
00195
00198   unsigned long int GetMTime();
00199
00202   vtkCellData *GetCellData() {return this->CellData;};
00203
00206   vtkPointData *GetPointData() {return this->PointData;};
00207
00210   virtual void Squeeze();
00211
00214   virtual void ComputeBounds();
00215
00218   float *GetBounds();
00219
00223   void GetBounds(float bounds[6]);
00224
00226   float *GetCenter();
00227
00230   void GetCenter(float center[3]);
00231
00235   float GetLength();
00236
00238   void Initialize();
00239
00246   virtual void GetScalarRange(float range[2]);
00247
00250   float *GetScalarRange();
00251
00255   virtual int GetMaxCellSize() = 0;
00256
00262   unsigned long GetActualMemorySize();
00263
00265
00266   int GetDataObjectType()
00267     {return VTK_DATA_SET;}
00269
00271
00272   void ShallowCopy(vtkDataObject *src);
00273   void DeepCopy(vtkDataObject *src);
00275
00276 //BTX
00277   enum FieldDataType
00278   {
00279     DATA_OBJECT_FIELD=0,
00280     POINT_DATA_FIELD=1,
00281     CELL_DATA_FIELD=2
00282   };
00283 //ETX
00284
00291   int CheckAttributes();
00292
00293 protected:
00294   // Constructor with default bounds (0,1, 0,1, 0,1).
00295   vtkDataSet();
00296   ~vtkDataSet();
00297
00298   vtkCellData *CellData;   // Scalars, vectors, etc. associated w/ each cell
00299   vtkPointData *PointData;   // Scalars, vectors, etc. associated w/ each point
00300   vtkTimeStamp ComputeTime; // Time at which bounds, center, etc. computed
00301   float Bounds[6];  // (xmin,xmax, ymin,ymax, zmin,zmax) geometric bounds
00302   float ScalarRange[2];
00303   float Center[3];
00304
00305 private:
00306   void InternalDataSetCopy(vtkDataSet *src);
00307 private:
00308   vtkDataSet(const vtkDataSet&);  // Not implemented.
00309   void operator=(const vtkDataSet&);    // Not implemented.
00310 };
00311
00312 inline void vtkDataSet::GetPoint(vtkIdType id, float x[3])
00313 {
00314   float *pt = this->GetPoint(id);
00315   x[0] = pt[0]; x[1] = pt[1]; x[2] = pt[2];
00316 }
00317
00318 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataSetAttributes.h Source File

Common/vtkDataSetAttributes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetAttributes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkDataSetAttributes_h
00045 #define __vtkDataSetAttributes_h
00046
00047 #include "vtkObject.h"
00048 #include "vtkFieldData.h"
00049
00050 class VTK_COMMON_EXPORT vtkDataSetAttributes : public vtkFieldData
00051 {
00052 public:
00054   static vtkDataSetAttributes *New();
00055
00056   vtkTypeRevisionMacro(vtkDataSetAttributes,vtkFieldData);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00061   virtual void Initialize();
00062
00065   virtual void Update() {}
00066
00073   virtual void PassData(vtkFieldData* fd);
00074
00076
00083   void CopyAllocate(vtkDataSetAttributes* pd, vtkIdType sze=0,
00084                     vtkIdType ext=1000);
00086
00094   void CopyData(vtkDataSetAttributes *fromPd, vtkIdType fromId, vtkIdType toId);
00095
00097
00100   void InterpolateAllocate(vtkDataSetAttributes* pd, vtkIdType sze=0,
00101                            vtkIdType ext=1000);
00103
00105
00107   void InterpolatePoint(vtkDataSetAttributes *fromPd, vtkIdType toId,
00108                         vtkIdList *ids, float *weights);
00110
00112
00116   void InterpolateEdge(vtkDataSetAttributes *fromPd, vtkIdType toId,
00117                        vtkIdType p1, vtkIdType p2, float t);
00119
00121
00128   void InterpolateTime(vtkDataSetAttributes *from1,
00129                        vtkDataSetAttributes *from2,
00130                        vtkIdType id, float t);
00132
00135   virtual void DeepCopy(vtkFieldData *pd);
00136
00138   virtual void ShallowCopy(vtkFieldData *pd);
00139
00141
00142   int SetScalars(vtkDataArray* da);
00143   int SetActiveScalars(const char* name);
00144   vtkDataArray* GetScalars();
00146
00148
00149   int SetVectors(vtkDataArray* da);
00150   int SetActiveVectors(const char* name);
00151   vtkDataArray* GetVectors();
00153
00155
00156   int SetNormals(vtkDataArray* da);
00157   int SetActiveNormals(const char* name);
00158   vtkDataArray* GetNormals();
00160
00162
00163   int SetTCoords(vtkDataArray* da);
00164   int SetActiveTCoords(const char* name);
00165   vtkDataArray* GetTCoords();
00167
00169
00170   int SetTensors(vtkDataArray* da);
00171   int SetActiveTensors(const char* name);
00172   vtkDataArray* GetTensors();
00174
00176
00179   vtkDataArray* GetScalars(const char* name);
00180   vtkDataArray* GetVectors(const char* name);
00181   vtkDataArray* GetNormals(const char* name);
00182   vtkDataArray* GetTCoords(const char* name);
00183   vtkDataArray* GetTensors(const char* name);
00185
00192   int SetActiveAttribute(const char* name, int attributeType);
00193
00195   int SetActiveAttribute(int index, int attributeType);
00196
00198   void SetCopyAttribute (int index, int value);
00199
00201
00207   void SetCopyScalars(int i);
00208   int GetCopyScalars();
00209   vtkBooleanMacro(CopyScalars, int);
00211
00213
00219   void SetCopyVectors(int i);
00220   int GetCopyVectors();
00221   vtkBooleanMacro(CopyVectors, int);
00223
00225
00231   void SetCopyNormals(int i);
00232   int GetCopyNormals();
00233   vtkBooleanMacro(CopyNormals, int);
00235
00237
00243   void SetCopyTCoords(int i);
00244   int GetCopyTCoords();
00245   vtkBooleanMacro(CopyTCoords, int);
00247
00249
00255   void SetCopyTensors(int i);
00256   int GetCopyTensors();
00257   vtkBooleanMacro(CopyTensors, int);
00259
00266   virtual void CopyAllOn();
00267
00274   virtual void CopyAllOff();
00275
00277
00281   void CopyTuple(vtkDataArray *fromData, vtkDataArray *toData,
00282                  vtkIdType fromId, vtkIdType toId);
00284
00287   void GetAttributeIndices(int* indexArray);
00288
00293   int IsArrayAnAttribute(int idx);
00294
00297   vtkDataArray* GetAttribute(int attributeType);
00298
00300   virtual void RemoveArray(const char *name);
00301
00304   static const char* GetAttributeTypeAsString(int attributeType);
00305
00306 //BTX
00307   // Always keep NUM_ATTRIBUTES as the last entry
00308   enum AttributeTypes
00309   {
00310     SCALARS=0,
00311     VECTORS=1,
00312     NORMALS=2,
00313     TCOORDS=3,
00314     TENSORS=4,
00315     NUM_ATTRIBUTES
00316   };
00317
00318   enum AttributeLimitTypes
00319   {
00320     MAX,
00321     EXACT,
00322     NOLIMIT
00323   };
00324
00325   class FieldList;
00326
00328
00330   void CopyAllocate(vtkDataSetAttributes::FieldList& list, vtkIdType sze=0,
00331                     vtkIdType ext=1000);
00333
00335
00339   void CopyData(vtkDataSetAttributes::FieldList& list,
00340                 vtkDataSetAttributes* dsa, int idx, vtkIdType fromId,
00341                 vtkIdType toId);
00343
00344   friend class vtkDataSetAttributes::FieldList;
00345 //ETX
00346
00347 protected:
00348   vtkDataSetAttributes();
00349   ~vtkDataSetAttributes();
00350
00351   // special methods to support managing data
00352   void InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData,
00353                         vtkIdType toId, vtkIdList *ptIds, float *weights);
00354   void InterpolateTuple(vtkDataArray *fromData, vtkDataArray *toData,
00355                         vtkIdType toId, vtkIdType id1, vtkIdType id2, float t);
00356   void InterpolateTuple(vtkDataArray *fromData1, vtkDataArray *fromData2,
00357                         vtkDataArray *toData, vtkIdType id, float t);
00358
00360   virtual void InitializeFields();
00361
00362   int AttributeIndices[NUM_ATTRIBUTES]; //index to attribute array in field data
00363   int CopyAttributeFlags[NUM_ATTRIBUTES]; //copy flag for attribute data
00364
00365 //BTX
00366   vtkFieldData::BasicIterator RequiredArrays;
00367 //ETX
00368
00369   int* TargetIndices;
00370
00371   virtual void RemoveArray(int index);
00372
00373   static const int NumberOfAttributeComponents[NUM_ATTRIBUTES];
00374   static const int AttributeLimits[NUM_ATTRIBUTES];
00375   static const char AttributeNames[NUM_ATTRIBUTES][10];
00376
00377 private:
00378   int SetAttribute(vtkDataArray* da, int attributeType);
00379   static int CheckNumberOfComponents(vtkDataArray* da, int attributeType);
00380
00381 //BTX
00382   vtkFieldData::BasicIterator  ComputeRequiredArrays(vtkDataSetAttributes* pd);
00383
00384 private:
00385   vtkDataSetAttributes(const vtkDataSetAttributes&);  // Not implemented.
00386   void operator=(const vtkDataSetAttributes&);  // Not implemented.
00387
00388 public:
00389   // This public class is used to perform set operations, other misc.
00390   // operations on fields. For example, vtkAppendFilter uses it to
00391   // determine which attributes the input datasets share in common.
00392   class VTK_COMMON_EXPORT FieldList
00393   {
00394   public:
00395     FieldList(int numInputs);
00396     ~FieldList();
00397
00398     void InitializeFieldList(vtkDataSetAttributes* dsa);
00399     void IntersectFieldList(vtkDataSetAttributes* dsa);
00400
00401     //Determine whether data is available
00402     int IsAttributePresent(int attrType); //true/false attributes specified
00403
00404     friend class vtkDataSetAttributes;
00405
00406   protected:
00407     FieldList(const FieldList&) {} //prevent these methods from being used
00408     void operator=(const FieldList&) {}
00409
00410   private:
00411     void SetField(int index, vtkDataArray *da);
00412     void RemoveField(const char *name);
00413     void ClearFields();
00414
00415     //These keep track of what is common across datasets
00416     char** Fields; //the names of the fields (first five are named attributes)
00417     int *FieldTypes; //the types of the fields (first five are named
00418                      //attributes)
00419     int *FieldComponents; //the number of components in each  fields
00420                           // (first five are named attributes)
00421     int *FieldIndices; //output data array index
00422                        // (first five are named attributes)
00423     vtkLookupTable **LUT; //luts associated with each array
00424     vtkIdType NumberOfTuples; //a running total of values
00425     int NumberOfFields; //the number of fields
00426
00427     //For every vtkDataSetAttributes that are processed, keep track of the
00428     //indices into various things. The indices are organized so that the
00429     //first NUM_ATTRIBUTES refer to attributes, the next refer to the
00430     //non-attribute fields, for a total of NUM_ATTRIBUTES + NumberOfFields.
00431     //CurrentInput is the current input being processed.
00432     int **DSAIndices;
00433     int NumberOfDSAIndices;
00434     int CurrentInput;
00435   };
00436
00437 //ETX
00438 };
00439
00440 #endif
00441
00442
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDataSetCollection.h Source File

Common/vtkDataSetCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkDataSetCollection_h
00036 #define __vtkDataSetCollection_h
00037
00038 #include "vtkCollection.h"
00039 #include "vtkDataSet.h"
00040
00041 class VTK_COMMON_EXPORT vtkDataSetCollection : public vtkCollection
00042 {
00043 public:
00044   static vtkDataSetCollection *New();
00045   vtkTypeRevisionMacro(vtkDataSetCollection,vtkCollection);
00046
00048
00049   void AddItem(vtkDataSet *ds) {
00050     this->vtkCollection::AddItem((vtkObject *)ds);};
00052
00054
00055   vtkDataSet *GetNextItem() {
00056     return static_cast<vtkDataSet *>(this->GetNextItemAsObject());};
00058
00060
00061   vtkDataSet *GetItem(int i) {
00062     return static_cast<vtkDataSet *>(this->GetItemAsObject(i));};
00064
00065 protected:
00066   vtkDataSetCollection() {};
00067   ~vtkDataSetCollection() {};
00068
00069
00070 private:
00071   // hide the standard AddItem from the user and the compiler.
00072   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00073
00074 private:
00075   vtkDataSetCollection(const vtkDataSetCollection&);  // Not implemented.
00076   void operator=(const vtkDataSetCollection&);  // Not implemented.
00077 };
00078
00079
00080 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkDataSetMapper.h Source File

Rendering/vtkDataSetMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkDataSetMapper_h
00046 #define __vtkDataSetMapper_h
00047
00048 #include "vtkDataSetSurfaceFilter.h"
00049 #include "vtkPolyDataMapper.h"
00050 #include "vtkRenderer.h"
00051 #include "vtkImageData.h"
00052
00053
00054 class VTK_RENDERING_EXPORT vtkDataSetMapper : public vtkMapper
00055 {
00056 public:
00057   static vtkDataSetMapper *New();
00058   vtkTypeRevisionMacro(vtkDataSetMapper,vtkMapper);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060   void Render(vtkRenderer *ren, vtkActor *act);
00061
00063
00065   vtkGetObjectMacro(PolyDataMapper, vtkPolyDataMapper);
00067
00071   void ReleaseGraphicsResources(vtkWindow *);
00072
00074   unsigned long GetMTime();
00075
00077
00078   void SetInput(vtkDataSet *input);
00079   vtkDataSet *GetInput();
00081
00082 protected:
00083   vtkDataSetMapper();
00084   ~vtkDataSetMapper();
00085
00086   vtkDataSetSurfaceFilter *GeometryExtractor;
00087   vtkPolyDataMapper *PolyDataMapper;
00088 private:
00089   vtkDataSetMapper(const vtkDataSetMapper&);  // Not implemented.
00090   void operator=(const vtkDataSetMapper&);  // Not implemented.
00091 };
00092
00093 #endif
00094
00095
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataSetReader.h Source File

IO/vtkDataSetReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkDataSetReader_h
00053 #define __vtkDataSetReader_h
00054
00055 #include "vtkDataReader.h"
00056 #include "vtkDataSet.h"
00057
00058 class vtkPolyData;
00059 class vtkStructuredPoints;
00060 class vtkStructuredGrid;
00061 class vtkUnstructuredGrid;
00062 class vtkRectilinearGrid;
00063
00064 class VTK_IO_EXPORT vtkDataSetReader : public vtkDataReader
00065 {
00066 public:
00067   static vtkDataSetReader *New();
00068   vtkTypeRevisionMacro(vtkDataSetReader,vtkDataReader);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00072
00075   vtkDataSet *GetOutput();
00076   vtkDataSet *GetOutput(int idx)
00077     {return static_cast<vtkDataSet *>(this->vtkSource::GetOutput(idx)); };
00079
00081
00086   vtkPolyData *GetPolyDataOutput();
00087   vtkStructuredPoints *GetStructuredPointsOutput();
00088   vtkStructuredGrid *GetStructuredGridOutput();
00089   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00090   vtkRectilinearGrid *GetRectilinearGridOutput();
00092
00094   void Update();
00095
00098   virtual int ReadOutputType();
00099
00100 protected:
00101   vtkDataSetReader();
00102   ~vtkDataSetReader();
00103
00104   void Execute();
00105   vtkDataReader *Reader;
00106
00107 private:
00108   vtkDataSetReader(const vtkDataSetReader&);  // Not implemented.
00109   void operator=(const vtkDataSetReader&);  // Not implemented.
00110 };
00111
00112 #endif
00113
00114
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetSource.h Source File

Filtering/vtkDataSetSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkDataSetSource_h
00032 #define __vtkDataSetSource_h
00033
00034 #include "vtkSource.h"
00035 #include "vtkDataSet.h"
00036
00037 class VTK_FILTERING_EXPORT vtkDataSetSource : public vtkSource
00038 {
00039 public:
00040   static vtkDataSetSource *New();
00041   vtkTypeRevisionMacro(vtkDataSetSource,vtkSource);
00042
00044
00045   vtkDataSet *GetOutput();
00046   vtkDataSet *GetOutput(int idx)
00047     {return (vtkDataSet *) this->vtkSource::GetOutput(idx); };
00048   void SetOutput(vtkDataSet *);
00050
00051 protected:
00052   vtkDataSetSource();
00053   ~vtkDataSetSource() {};
00054
00055 private:
00056   vtkDataSetSource(const vtkDataSetSource&);  // Not implemented.
00057   void operator=(const vtkDataSetSource&);  // Not implemented.
00058 };
00059
00060 #endif
00061
00062
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDataSetSurfaceFilter.h Source File

Graphics/vtkDataSetSurfaceFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetSurfaceFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkDataSetSurfaceFilter_h
00043 #define __vtkDataSetSurfaceFilter_h
00044
00045 #include "vtkDataSetToPolyDataFilter.h"
00046 #include "vtkStructuredGrid.h"
00047 #include "vtkImageData.h"
00048 #include "vtkUnstructuredGrid.h"
00049
00050 class vtkFastGeomQuad;
00051
00052
00053 class VTK_GRAPHICS_EXPORT vtkDataSetSurfaceFilter : public vtkDataSetToPolyDataFilter
00054 {
00055 public:
00056   static vtkDataSetSurfaceFilter *New();
00057   vtkTypeRevisionMacro(vtkDataSetSurfaceFilter,vtkDataSetToPolyDataFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00064   vtkSetMacro(UseStrips, int);
00065   vtkGetMacro(UseStrips, int);
00066   vtkBooleanMacro(UseStrips, int);
00068
00069 protected:
00070   vtkDataSetSurfaceFilter();
00071   ~vtkDataSetSurfaceFilter();
00072
00073   int UseStrips;
00074
00075   void ComputeInputUpdateExtents(vtkDataObject *output);
00076
00077   void Execute();
00078   void StructuredExecute(vtkDataSet *input, int *ext);
00079   void UnstructuredGridExecute();
00080   void DataSetExecute();
00081   void ExecuteInformation();
00082
00083   // Helper methods.
00084   void ExecuteFaceStrips(vtkDataSet *input, int maxFlag, int *ext,
00085                          int aAxis, int bAxis, int cAxis);
00086   void ExecuteFaceQuads(vtkDataSet *input, int maxFlag, int *ext,
00087                         int aAxis, int bAxis, int cAxis);
00088
00089   void InitializeQuadHash(vtkIdType numPoints);
00090   void DeleteQuadHash();
00091   void InsertQuadInHash(vtkIdType a, vtkIdType b, vtkIdType c, vtkIdType d,
00092                         vtkIdType sourceId);
00093   void InsertTriInHash(vtkIdType a, vtkIdType b, vtkIdType c,
00094                        vtkIdType sourceId);
00095   void InitQuadHashTraversal();
00096   vtkFastGeomQuad *GetNextVisibleQuadFromHash();
00097
00098   vtkFastGeomQuad **QuadHash;
00099   vtkIdType QuadHashLength;
00100   vtkFastGeomQuad *QuadHashTraversal;
00101   vtkIdType QuadHashTraversalIndex;
00102
00103   vtkIdType *PointMap;
00104   vtkIdType GetOutputPointId(vtkIdType inPtId, vtkDataSet *input,
00105                              vtkPoints *outPts, vtkPointData *outPD);
00106
00107   vtkIdType NumberOfNewCells;
00108
00109 private:
00110   vtkDataSetSurfaceFilter(const vtkDataSetSurfaceFilter&);  // Not implemented.
00111   void operator=(const vtkDataSetSurfaceFilter&);  // Not implemented.
00112 };
00113
00114 #endif
00115
00116
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDataSetToDataObjectFilter.h Source File

Graphics/vtkDataSetToDataObjectFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToDataObjectFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkDataSetToDataObjectFilter_h
00062 #define __vtkDataSetToDataObjectFilter_h
00063
00064 #include "vtkDataObjectSource.h"
00065 #include "vtkDataSet.h"
00066 #include "vtkCollection.h"
00067
00068 class VTK_GRAPHICS_EXPORT vtkDataSetToDataObjectFilter : public vtkDataObjectSource
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkDataSetToDataObjectFilter,vtkDataObjectSource);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075   static vtkDataSetToDataObjectFilter *New();
00076
00078
00079   vtkSetMacro(Geometry,int);
00080   vtkGetMacro(Geometry,int);
00081   vtkBooleanMacro(Geometry,int);
00083
00085
00086   vtkSetMacro(Topology,int);
00087   vtkGetMacro(Topology,int);
00088   vtkBooleanMacro(Topology,int);
00090
00092
00093   vtkSetMacro(FieldData,int);
00094   vtkGetMacro(FieldData,int);
00095   vtkBooleanMacro(FieldData,int);
00097
00099
00100   vtkSetMacro(PointData,int);
00101   vtkGetMacro(PointData,int);
00102   vtkBooleanMacro(PointData,int);
00104
00106
00107   vtkSetMacro(CellData,int);
00108   vtkGetMacro(CellData,int);
00109   vtkBooleanMacro(CellData,int);
00111
00113
00114   virtual void SetInput(vtkDataSet *input);
00115   vtkDataSet *GetInput();
00117
00118 protected:
00119   vtkDataSetToDataObjectFilter();
00120   ~vtkDataSetToDataObjectFilter();
00121
00122   void Execute(); //generate output data
00123   void ComputeInputUpdateExtents(vtkDataObject *output);
00124
00125   int Geometry;
00126   int Topology;
00127   int PointData;
00128   int CellData;
00129   int FieldData;
00130
00131 private:
00132   vtkDataSetToDataObjectFilter(const vtkDataSetToDataObjectFilter&);  // Not implemented.
00133   void operator=(const vtkDataSetToDataObjectFilter&);  // Not implemented.
00134 };
00135
00136 #endif
00137
00138
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetToDataSetFilter.h Source File

Filtering/vtkDataSetToDataSetFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToDataSetFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkDataSetToDataSetFilter_h
00053 #define __vtkDataSetToDataSetFilter_h
00054
00055 #include "vtkDataSetSource.h"
00056 #include "vtkDataSet.h"
00057
00058 class vtkPolyData;
00059 class vtkStructuredPoints;
00060 class vtkStructuredGrid;
00061 class vtkUnstructuredGrid;
00062 class vtkRectilinearGrid;
00063
00064 class VTK_FILTERING_EXPORT vtkDataSetToDataSetFilter : public vtkDataSetSource
00065 {
00066
00067 public:
00068   vtkTypeRevisionMacro(vtkDataSetToDataSetFilter,vtkDataSetSource);
00069
00071   void SetInput(vtkDataSet *input);
00072
00074
00076   vtkDataSet *GetOutput();
00077   vtkDataSet *GetOutput(int idx)
00078     {return (vtkDataSet *) this->vtkDataSetSource::GetOutput(idx); };
00080
00082   vtkPolyData *GetPolyDataOutput();
00083
00085   vtkStructuredPoints *GetStructuredPointsOutput();
00086
00088   vtkStructuredGrid *GetStructuredGridOutput();
00089
00091   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00092
00094   vtkRectilinearGrid *GetRectilinearGridOutput();
00095
00097   vtkDataSet *GetInput();
00098
00100   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00101
00102 protected:
00103   vtkDataSetToDataSetFilter();
00104   ~vtkDataSetToDataSetFilter();
00105
00106   void ExecuteInformation();
00107
00108 private:
00109   vtkDataSetToDataSetFilter(const vtkDataSetToDataSetFilter&);  // Not implemented.
00110   void operator=(const vtkDataSetToDataSetFilter&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
00116
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetToPolyDataFilter.h Source File

Filtering/vtkDataSetToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkDataSetToPolyDataFilter_h
00042 #define __vtkDataSetToPolyDataFilter_h
00043
00044 #include "vtkPolyDataSource.h"
00045 #include "vtkPolyData.h"
00046
00047 class VTK_FILTERING_EXPORT vtkDataSetToPolyDataFilter : public vtkPolyDataSource
00048 {
00049 public:
00050   vtkTypeRevisionMacro(vtkDataSetToPolyDataFilter,vtkPolyDataSource);
00051
00053
00054   virtual void SetInput(vtkDataSet *input);
00055   vtkDataSet *GetInput();
00057
00059   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00060
00061 protected:
00062   vtkDataSetToPolyDataFilter() {this->NumberOfRequiredInputs = 1;};
00063   ~vtkDataSetToPolyDataFilter() {};
00064
00065 private:
00066   vtkDataSetToPolyDataFilter(const vtkDataSetToPolyDataFilter&);  // Not implemented.
00067   void operator=(const vtkDataSetToPolyDataFilter&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetToStructuredGridFilter.h Source File

Filtering/vtkDataSetToStructuredGridFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToStructuredGridFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkDataSetToStructuredGridFilter_h
00035 #define __vtkDataSetToStructuredGridFilter_h
00036
00037 #include "vtkStructuredGridSource.h"
00038
00039 class VTK_FILTERING_EXPORT vtkDataSetToStructuredGridFilter : public vtkStructuredGridSource
00040 {
00041 public:
00042   vtkTypeRevisionMacro(vtkDataSetToStructuredGridFilter,vtkStructuredGridSource);
00043
00045
00046   virtual void SetInput(vtkDataSet *input);
00047   vtkDataSet *GetInput();
00049
00050 protected:
00051   vtkDataSetToStructuredGridFilter() {};
00052   ~vtkDataSetToStructuredGridFilter() {};
00053
00054 private:
00055   vtkDataSetToStructuredGridFilter(const vtkDataSetToStructuredGridFilter&);  // Not implemented.
00056   void operator=(const vtkDataSetToStructuredGridFilter&);  // Not implemented.
00057 };
00058
00059 #endif
00060
00061
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetToStructuredPointsFilter.h Source File

Filtering/vtkDataSetToStructuredPointsFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToStructuredPointsFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkDataSetToStructuredPointsFilter_h
00039 #define __vtkDataSetToStructuredPointsFilter_h
00040
00041 #include "vtkStructuredPointsSource.h"
00042
00043 class VTK_FILTERING_EXPORT vtkDataSetToStructuredPointsFilter : public vtkStructuredPointsSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkDataSetToStructuredPointsFilter,vtkStructuredPointsSource);
00047
00049
00050   virtual void SetInput(vtkDataSet *input);
00051   vtkDataSet *GetInput();
00053
00054 protected:
00055   vtkDataSetToStructuredPointsFilter() {this->NumberOfRequiredInputs = 1;};
00056   ~vtkDataSetToStructuredPointsFilter() {};
00057
00058   // All the DataSetToStructuredPointsFilters require all their input.
00059   void ComputeInputUpdateExtents(vtkDataObject *output);
00060 private:
00061   vtkDataSetToStructuredPointsFilter(const vtkDataSetToStructuredPointsFilter&);  // Not implemented.
00062   void operator=(const vtkDataSetToStructuredPointsFilter&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
00068
00069
00070
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkDataSetToUnstructuredGridFilter.h Source File

Filtering/vtkDataSetToUnstructuredGridFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetToUnstructuredGridFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkDataSetToUnstructuredGridFilter_h
00041 #define __vtkDataSetToUnstructuredGridFilter_h
00042
00043 #include "vtkUnstructuredGridSource.h"
00044
00045 class VTK_FILTERING_EXPORT vtkDataSetToUnstructuredGridFilter : public vtkUnstructuredGridSource
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkDataSetToUnstructuredGridFilter,vtkUnstructuredGridSource);
00049
00051
00052   virtual void SetInput(vtkDataSet *input);
00053   vtkDataSet *GetInput();
00055
00056 protected:
00057   vtkDataSetToUnstructuredGridFilter() {this->NumberOfRequiredInputs = 1;};
00058   ~vtkDataSetToUnstructuredGridFilter() {};
00059
00060
00061 private:
00062   vtkDataSetToUnstructuredGridFilter(const vtkDataSetToUnstructuredGridFilter&);  // Not implemented.
00063   void operator=(const vtkDataSetToUnstructuredGridFilter&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDataSetTriangleFilter.h Source File

Graphics/vtkDataSetTriangleFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetTriangleFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkDataSetTriangleFilter_h
00044 #define __vtkDataSetTriangleFilter_h
00045
00046 #include "vtkDataSetToUnstructuredGridFilter.h"
00047
00048 class vtkOrderedTriangulator;
00049
00050 class VTK_GRAPHICS_EXPORT vtkDataSetTriangleFilter : public vtkDataSetToUnstructuredGridFilter
00051 {
00052 public:
00053   static vtkDataSetTriangleFilter *New();
00054   vtkTypeRevisionMacro(vtkDataSetTriangleFilter,vtkDataSetToUnstructuredGridFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00057 protected:
00058   vtkDataSetTriangleFilter():Triangulator(NULL) {}
00059   ~vtkDataSetTriangleFilter();
00060
00061   // Usual data generation method
00062   void Execute();
00063
00064   // different execute methods depending on whether input is structured
00065   void StructuredExecute();
00066   void UnstructuredExecute();
00067
00068   vtkOrderedTriangulator *Triangulator;
00069 private:
00070   vtkDataSetTriangleFilter(const vtkDataSetTriangleFilter&);  // Not implemented.
00071   void operator=(const vtkDataSetTriangleFilter&);  // Not implemented.
00072 };
00073
00074 #endif
00075
00076
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataSetWriter.h Source File

IO/vtkDataSetWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataSetWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkDataSetWriter_h
00039 #define __vtkDataSetWriter_h
00040
00041 #include "vtkDataWriter.h"
00042
00043 class VTK_IO_EXPORT vtkDataSetWriter : public vtkDataWriter
00044 {
00045 public:
00046   static vtkDataSetWriter *New();
00047   vtkTypeRevisionMacro(vtkDataSetWriter,vtkDataWriter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   void SetInput(vtkDataSet *input);
00053   vtkDataSet *GetInput();
00055
00056 protected:
00057   vtkDataSetWriter() {};
00058   ~vtkDataSetWriter() {};
00059
00060   void WriteData();
00061
00062 private:
00063   vtkDataSetWriter(const vtkDataSetWriter&);  // Not implemented.
00064   void operator=(const vtkDataSetWriter&);  // Not implemented.
00065 };
00066
00067 #endif
00068
00069
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDataWriter.h Source File

IO/vtkDataWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDataWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkDataWriter_h
00043 #define __vtkDataWriter_h
00044
00045 #include <stdio.h>
00046 #include "vtkWriter.h"
00047
00048 class vtkDataSet;
00049 class vtkPoints;
00050 class vtkCellArray;
00051 class vtkDataArray;
00052
00053 class VTK_IO_EXPORT vtkDataWriter : public vtkWriter
00054 {
00055 public:
00056   vtkTypeRevisionMacro(vtkDataWriter,vtkWriter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00061   static vtkDataWriter *New();
00062
00064
00065   vtkSetStringMacro(FileName);
00066   vtkGetStringMacro(FileName);
00068
00070
00071   vtkSetMacro(WriteToOutputString,int);
00072   vtkGetMacro(WriteToOutputString,int);
00073   vtkBooleanMacro(WriteToOutputString,int);
00075
00077
00080   vtkGetMacro(OutputStringLength, int);
00081   vtkGetStringMacro(OutputString);
00082   unsigned char *GetBinaryOutputString() {
00083       return (unsigned char *)this->OutputString;};
00085
00089   char *RegisterAndGetOutputString();
00090
00092
00093   vtkSetStringMacro(Header);
00094   vtkGetStringMacro(Header);
00096
00098
00099   vtkSetClampMacro(FileType,int,VTK_ASCII,VTK_BINARY);
00100   vtkGetMacro(FileType,int);
00101   void SetFileTypeToASCII() {this->SetFileType(VTK_ASCII);};
00102   void SetFileTypeToBinary() {this->SetFileType(VTK_BINARY);};
00104
00106
00108   vtkSetStringMacro(ScalarsName);
00109   vtkGetStringMacro(ScalarsName);
00111
00113
00115   vtkSetStringMacro(VectorsName);
00116   vtkGetStringMacro(VectorsName);
00118
00120
00122   vtkSetStringMacro(TensorsName);
00123   vtkGetStringMacro(TensorsName);
00125
00127
00129   vtkSetStringMacro(NormalsName);
00130   vtkGetStringMacro(NormalsName);
00132
00134
00136   vtkSetStringMacro(TCoordsName);
00137   vtkGetStringMacro(TCoordsName);
00139
00141
00143   vtkSetStringMacro(LookupTableName);
00144   vtkGetStringMacro(LookupTableName);
00146
00148
00150   vtkSetStringMacro(FieldDataName);
00151   vtkGetStringMacro(FieldDataName);
00153
00155   virtual ostream *OpenVTKFile();
00156
00158   int WriteHeader(ostream *fp);
00159
00161   int WritePoints(ostream *fp, vtkPoints *p);
00162
00164   int WriteCoordinates(ostream *fp, vtkDataArray *coords, int axes);
00165
00167   int WriteCells(ostream *fp, vtkCellArray *cells, const char *label);
00168
00171   int WriteCellData(ostream *fp, vtkDataSet *ds);
00172
00175   int WritePointData(ostream *fp, vtkDataSet *ds);
00176
00178   int WriteFieldData(ostream *fp, vtkFieldData *f);
00179
00183   int WriteDataSetData(ostream *fp, vtkDataSet *ds);
00184
00186   void CloseVTKFile(ostream *fp);
00187
00188
00189 protected:
00190   vtkDataWriter();
00191   ~vtkDataWriter();
00192
00193   int WriteToOutputString;
00194   char *OutputString;
00195   int OutputStringLength;
00196   int OutputStringAllocatedLength;
00197
00198   void WriteData(); //dummy method to allow this class to be instantiated and delegated to
00199
00200   char *FileName;
00201   char *Header;
00202   int FileType;
00203
00204   char *ScalarsName;
00205   char *VectorsName;
00206   char *TensorsName;
00207   char *TCoordsName;
00208   char *NormalsName;
00209   char *LookupTableName;
00210   char *FieldDataName;
00211
00212   int WriteArray(ostream *fp, int dataType, vtkDataArray *data, const char *format,
00213                  int num, int numComp);
00214   int WriteScalarData(ostream *fp, vtkDataArray *s, int num);
00215   int WriteVectorData(ostream *fp, vtkDataArray *v, int num);
00216   int WriteNormalData(ostream *fp, vtkDataArray *n, int num);
00217   int WriteTCoordData(ostream *fp, vtkDataArray *tc, int num);
00218   int WriteTensorData(ostream *fp, vtkDataArray *t, int num);
00219
00220 private:
00221   vtkDataWriter(const vtkDataWriter&);  // Not implemented.
00222   void operator=(const vtkDataWriter&);  // Not implemented.
00223 };
00224
00225 #endif
00226
00227
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDebugLeaks.h Source File

Common/vtkDebugLeaks.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDebugLeaks.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkDebugLeaks_h
00045 #define __vtkDebugLeaks_h
00046
00047 #include "vtkObject.h"
00048 #include "vtkToolkits.h"
00049
00050 class vtkDebugLeaksHashTable;
00051
00052 class VTK_COMMON_EXPORT vtkDebugLeaks : public vtkObject
00053 {
00054 public:
00055   static vtkDebugLeaks *New();
00056   vtkTypeRevisionMacro(vtkDebugLeaks,vtkObject);
00057
00059   static void ConstructClass(const char* classname);
00060
00062   static void DestructClass(const char* classname);
00063
00065   static void PrintCurrentLeaks();
00066
00068   static void DeleteTable();
00069
00071
00072   static void PromptUserOn();
00073   static void PromptUserOff();
00075
00076 protected:
00077   vtkDebugLeaks(){};
00078   virtual ~vtkDebugLeaks(){};
00079
00080   static int PromptUser;
00081
00082 private:
00083   static vtkDebugLeaksHashTable* MemoryTable;
00084 private:
00085   vtkDebugLeaks(const vtkDebugLeaks&);  // Not implemented.
00086   void operator=(const vtkDebugLeaks&);  // Not implemented.
00087 };
00088
00089 #endif // __vtkDebugLeaks_h
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkDecimate.h Source File

Patented/vtkDecimate.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDecimate.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 5,559,388
00016      "Method for Reducting the Complexity of a Polygonal Mesh".
00017      Application of this software for commercial purposes requires
00018      a license grant from GE. Contact:
00019
00020          Carl B. Horton
00021          Sr. Counsel, Intellectual Property
00022          3000 N. Grandview Blvd., W-710
00023          Waukesha, WI  53188
00024          Phone:  (262) 513-4022
00025          E-Mail: Carl.Horton@med.ge.com
00026
00027      for more information.
00028
00029      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00030      "System and Method for the Display of Surface Structures Contained
00031      Within the Interior Region of a Solid Body".
00032      Application of this software for commercial purposes requires
00033      a license grant from GE. Contact:
00034
00035          Carl B. Horton
00036          Sr. Counsel, Intellectual Property
00037          3000 N. Grandview Blvd., W-710
00038          Waukesha, WI  53188
00039          Phone:  (262) 513-4022
00040          E-Mail: Carl.Horton@med.ge.com
00041
00042      for more information.
00043
00044 =========================================================================*/
00114 #ifndef __vtkDecimate_h
00115 #define __vtkDecimate_h
00116
00117 #include "vtkPolyDataToPolyDataFilter.h"
00118 #include "vtkMath.h"
00119 #include "vtkTriangle.h"
00120 #include "vtkPlane.h"
00121 #include "vtkPolygon.h"
00122 #include "vtkLine.h"
00123
00124 #define VTK_NUMBER_STATISTICS 12
00125
00126 //BTX - begin tcl exclude
00127 // Special structures for building loops
00128 typedef struct _vtkLocalVertex
00129   {
00130   vtkIdType     id;
00131   float   x[3];
00132   float   FAngle;
00133   int     deRefs; //monitor memory requirements; new only when necessary
00134   int     newRefs;
00135   } vtkLocalVertex, *vtkLocalVertexPtr;
00136
00137 typedef struct _vtkLocalTri
00138   {
00139   vtkIdType     id;
00140   float   area;
00141   float   n[3];
00142   vtkIdType     verts[3];
00143 } vtkLocalTri, *vtkLocalTriPtr;
00144
00145 //
00146 // Special classes for manipulating data
00147 //
00148 class vtkVertexArray { //;prevent man page generation
00149 public:
00150   vtkVertexArray(const vtkIdType sz)
00151     {this->MaxId = -1; this->Array = new vtkLocalVertex[sz];};
00152   ~vtkVertexArray() {if (this->Array) {delete [] this->Array;}};
00153   vtkIdType GetNumberOfVertices() {return this->MaxId + 1;};
00154   void InsertNextVertex(vtkLocalVertex& v)
00155     {this->MaxId++; this->Array[this->MaxId] = v;};
00156   vtkLocalVertex& GetVertex(vtkIdType i) {return this->Array[i];};
00157   void Reset() {this->MaxId = -1;};
00158
00159   vtkLocalVertex *Array;  // pointer to data
00160   vtkIdType MaxId;             // maximum index inserted thus far
00161 };
00162
00163 class vtkTriArray { //;prevent man page generation
00164 public:
00165   vtkTriArray(const vtkIdType sz)
00166     {this->MaxId = -1; this->Array = new vtkLocalTri[sz];};
00167   ~vtkTriArray() {if (this->Array) {delete [] this->Array;}};
00168   vtkIdType GetNumberOfTriangles() {return this->MaxId + 1;};
00169   void InsertNextTriangle(vtkLocalTri& t)
00170     {this->MaxId++; this->Array[this->MaxId] = t;};
00171   vtkLocalTri& GetTriangle(vtkIdType i) {return this->Array[i];};
00172   void Reset() {this->MaxId = -1;};
00173
00174   vtkLocalTri *Array;  // pointer to data
00175   vtkIdType MaxId;            // maximum index inserted thus far
00176 };
00177 //ETX - end tcl exclude
00178 //
00179
00180
00181 class VTK_PATENTED_EXPORT vtkDecimate : public vtkPolyDataToPolyDataFilter
00182 {
00183 public:
00184   static vtkDecimate *New();
00185   vtkTypeRevisionMacro(vtkDecimate,vtkPolyDataToPolyDataFilter);
00186   void PrintSelf(ostream& os, vtkIndent indent);
00187
00189
00191   vtkSetClampMacro(InitialError,float,0.0,1.0);
00192   vtkGetMacro(InitialError,float);
00194
00196
00198   vtkSetClampMacro(ErrorIncrement,float,0.0,1.0);
00199   vtkGetMacro(ErrorIncrement,float);
00201
00203
00205   vtkSetClampMacro(MaximumError,float,0.0,1.0);
00206   vtkGetMacro(MaximumError,float);
00208
00210
00213   vtkSetClampMacro(TargetReduction,float,0.0,1.0);
00214   vtkGetMacro(TargetReduction,float);
00216
00218
00220   vtkSetClampMacro(MaximumIterations,int,0,VTK_LARGE_INTEGER);
00221   vtkGetMacro(MaximumIterations,int);
00223
00225
00227   vtkSetClampMacro(MaximumSubIterations,int,1,VTK_LARGE_INTEGER);
00228   vtkGetMacro(MaximumSubIterations,int);
00230
00232
00233   vtkSetClampMacro(InitialFeatureAngle,float,0.0,180.0);
00234   vtkGetMacro(InitialFeatureAngle,float);
00236
00238
00240   vtkSetClampMacro(FeatureAngleIncrement,float,0.0,180.0);
00241   vtkGetMacro(FeatureAngleIncrement,float);
00243
00245
00246   vtkSetClampMacro(MaximumFeatureAngle,float,0.0,180.0);
00247   vtkGetMacro(MaximumFeatureAngle,float);
00249
00251
00252   vtkSetMacro(GenerateErrorScalars,int);
00253   vtkGetMacro(GenerateErrorScalars,int);
00254   vtkBooleanMacro(GenerateErrorScalars,int);
00256
00258
00259   vtkSetMacro(PreserveEdges,int);
00260   vtkGetMacro(PreserveEdges,int);
00261   vtkBooleanMacro(PreserveEdges,int);
00263
00265
00266   vtkSetMacro(BoundaryVertexDeletion,int);
00267   vtkGetMacro(BoundaryVertexDeletion,int);
00268   vtkBooleanMacro(BoundaryVertexDeletion,int);
00270
00272
00273   vtkSetClampMacro(AspectRatio,float,1.0,1000.0);
00274   vtkGetMacro(AspectRatio,float);
00276
00278
00280   vtkSetMacro(PreserveTopology,int);
00281   vtkGetMacro(PreserveTopology,int);
00282   vtkBooleanMacro(PreserveTopology,int);
00284
00286
00290   vtkSetClampMacro(Degree,int,25,VTK_CELL_SIZE);
00291   vtkGetMacro(Degree,int);
00293
00295
00298   vtkSetClampMacro(MaximumNumberOfSquawks,int,0,VTK_LARGE_INTEGER);
00299   vtkGetMacro(MaximumNumberOfSquawks,int);
00301
00302 protected:
00303   vtkDecimate();
00304   ~vtkDecimate();
00305
00306   void Execute();
00307
00308   float InitialFeatureAngle; // dihedral angle constraint
00309   float FeatureAngleIncrement;
00310   float MaximumFeatureAngle;
00311   int PreserveEdges; // do/don't worry about feature edges
00312   int BoundaryVertexDeletion;
00313   float InitialError; // decimation error in fraction of bounding box
00314   float ErrorIncrement; // each iteration will bump error this amount
00315   float MaximumError; // maximum error
00316   float TargetReduction; //target reduction of mesh (fraction)
00317   int MaximumIterations; // maximum number of passes over data
00318   int MaximumSubIterations; // maximum non-incrementing passes
00319   float AspectRatio; // control triangle shape during triangulation
00320   int Degree; // maximum number of triangles incident on vertex
00321   int Stats[VTK_NUMBER_STATISTICS]; // keep track of interesting statistics
00322   int GenerateErrorScalars; // turn on/off vertex error scalar generation
00323   int MaximumNumberOfSquawks; //control number of error messages
00324   int PreserveTopology; //control whether mesh topology is preserved
00325   vtkIdList *Neighbors; // to replace static
00326   vtkVertexArray *V; //to replace static
00327   vtkTriArray *T; //to replace static
00328
00329   void CreateOutput(vtkIdType numPts, vtkIdType numTris,
00330                     vtkIdType numEliminated, vtkPointData *pd,
00331                     vtkPoints *inPts);
00332   int BuildLoop(vtkIdType ptId, unsigned short int nTris, vtkIdType* tris);
00333   void EvaluateLoop(int& vtype, vtkIdType& numFEdges,
00334                     vtkLocalVertexPtr fedges[]);
00335   int CanSplitLoop(vtkLocalVertexPtr fedges[2], vtkIdType numVerts,
00336                    vtkLocalVertexPtr verts[], vtkIdType& n1,
00337                    vtkLocalVertexPtr l1[], vtkIdType& n2,
00338                    vtkLocalVertexPtr l2[], float& ar);
00339   void SplitLoop(vtkLocalVertexPtr fedges[2], vtkIdType numVerts,
00340                  vtkLocalVertexPtr *verts, vtkIdType& n1,
00341                  vtkLocalVertexPtr *l1, vtkIdType& n2, vtkLocalVertexPtr *l2);
00342   void Triangulate(vtkIdType numVerts, vtkLocalVertexPtr verts[]);
00343   int CheckError();
00344 private:
00345   vtkDecimate(const vtkDecimate&);  // Not implemented.
00346   void operator=(const vtkDecimate&);  // Not implemented.
00347 };
00348
00349 #endif
00350
00351
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDecimatePro.h Source File

Graphics/vtkDecimatePro.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDecimatePro.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00097 #ifndef __vtkDecimatePro_h
00098 #define __vtkDecimatePro_h
00099
00100 #include "vtkPolyDataToPolyDataFilter.h"
00101 #include "vtkPriorityQueue.h"
00102
00103 // Special structures for building loops
00104 typedef struct _vtkProLocalVertex
00105   {
00106   vtkIdType     id;
00107   float   x[3];
00108   float   FAngle;
00109   } vtkProLocalVertex, *vtkProLocalVertexPtr;
00110
00111 typedef struct _vtkProLocalTri
00112   {
00113   vtkIdType     id;
00114   float   area;
00115   float   n[3];
00116   vtkIdType     verts[3];
00117   } vtkProLocalTri, *vtkProLocalTriPtr;
00118
00119 //
00120 // Special classes for manipulating data
00121 //
00122 //BTX - begin tcl exclude
00123 //
00124 class vtkProVertexArray { //;prevent man page generation
00125 public:
00126   vtkProVertexArray(const vtkIdType sz)
00127     {this->MaxId = -1; this->Array = new vtkProLocalVertex[sz];};
00128   ~vtkProVertexArray()
00129     {
00130     if (this->Array)
00131       {
00132       delete [] this->Array;
00133       }
00134     };
00135   vtkIdType GetNumberOfVertices() {return this->MaxId + 1;};
00136   void InsertNextVertex(vtkProLocalVertex& v)
00137     {this->MaxId++; this->Array[this->MaxId] = v;};
00138   vtkProLocalVertex& GetVertex(vtkIdType i) {return this->Array[i];};
00139   void Reset() {this->MaxId = -1;};
00140
00141   vtkProLocalVertex *Array; // pointer to data
00142   vtkIdType MaxId;             // maximum index inserted thus far
00143 };
00144
00145 class vtkProTriArray { //;prevent man page generation
00146 public:
00147   vtkProTriArray(const vtkIdType sz)
00148     {this->MaxId = -1; this->Array = new vtkProLocalTri[sz];};
00149   ~vtkProTriArray()
00150     {
00151       if (this->Array)
00152         {
00153         delete [] this->Array;
00154         }
00155     };
00156   vtkIdType GetNumberOfTriangles() {return this->MaxId + 1;};
00157   void InsertNextTriangle(vtkProLocalTri& t)
00158     {this->MaxId++; this->Array[this->MaxId] = t;};
00159   vtkProLocalTri& GetTriangle(vtkIdType i) {return this->Array[i];};
00160   void Reset() {this->MaxId = -1;};
00161
00162   vtkProLocalTri *Array;  // pointer to data
00163   vtkIdType MaxId;           // maximum index inserted thus far
00164 };
00165 //ETX - end tcl exclude
00166 //
00167
00168
00169 class VTK_GRAPHICS_EXPORT vtkDecimatePro : public vtkPolyDataToPolyDataFilter
00170 {
00171 public:
00172   vtkTypeRevisionMacro(vtkDecimatePro,vtkPolyDataToPolyDataFilter);
00173   void PrintSelf(ostream& os, vtkIndent indent);
00174
00181   static vtkDecimatePro *New();
00182
00184
00190   vtkSetClampMacro(TargetReduction,float,0.0,1.0);
00191   vtkGetMacro(TargetReduction,float);
00193
00195
00198   vtkSetMacro(PreserveTopology,int);
00199   vtkGetMacro(PreserveTopology,int);
00200   vtkBooleanMacro(PreserveTopology,int);
00202
00204
00207   vtkSetClampMacro(FeatureAngle,float,0.0,180.0);
00208   vtkGetMacro(FeatureAngle,float);
00210
00212
00216   vtkSetMacro(Splitting,int);
00217   vtkGetMacro(Splitting,int);
00218   vtkBooleanMacro(Splitting,int);
00220
00222
00225   vtkSetClampMacro(SplitAngle,float,0.0,180.0);
00226   vtkGetMacro(SplitAngle,float);
00228
00230
00236   vtkSetMacro(PreSplitMesh,int);
00237   vtkGetMacro(PreSplitMesh,int);
00238   vtkBooleanMacro(PreSplitMesh,int);
00240
00242
00246   vtkSetClampMacro(MaximumError,float,0.0,VTK_LARGE_FLOAT);
00247   vtkGetMacro(MaximumError,float);
00249
00251
00258   vtkSetMacro(AccumulateError,int);
00259   vtkGetMacro(AccumulateError,int);
00260   vtkBooleanMacro(AccumulateError,int);
00262
00264
00268   vtkSetMacro(ErrorIsAbsolute,int);
00269   vtkGetMacro(ErrorIsAbsolute,int);
00271
00273
00274   vtkSetClampMacro(AbsoluteError,float,0.0,VTK_LARGE_FLOAT);
00275   vtkGetMacro(AbsoluteError,float);
00277
00279
00281   vtkSetMacro(BoundaryVertexDeletion,int);
00282   vtkGetMacro(BoundaryVertexDeletion,int);
00283   vtkBooleanMacro(BoundaryVertexDeletion,int);
00285
00287
00291   vtkSetClampMacro(Degree,int,25,VTK_CELL_SIZE);
00292   vtkGetMacro(Degree,int);
00294
00296
00299   vtkSetClampMacro(InflectionPointRatio,float,1.001,VTK_LARGE_FLOAT);
00300   vtkGetMacro(InflectionPointRatio,float);
00302
00303
00309   vtkIdType GetNumberOfInflectionPoints();
00310
00315   void GetInflectionPoints(float *inflectionPoints);
00316
00322   float *GetInflectionPoints();
00323
00324 protected:
00325   vtkDecimatePro();
00326   ~vtkDecimatePro();
00327
00328   void Execute();
00329
00330   float TargetReduction;
00331   float FeatureAngle;
00332   float MaximumError;
00333   float AbsoluteError;
00334   int ErrorIsAbsolute;
00335   int AccumulateError;
00336   float SplitAngle;
00337   int Splitting;
00338   int PreSplitMesh;
00339   int BoundaryVertexDeletion;
00340   int PreserveTopology;
00341   int Degree;
00342   float InflectionPointRatio;
00343   vtkFloatArray *InflectionPoints;
00344
00345   // to replace a static object
00346   vtkIdList *Neighbors;
00347   vtkPriorityQueue *EdgeLengths;
00348
00349   void SplitMesh();
00350   int EvaluateVertex(vtkIdType ptId, unsigned short int numTris,
00351                      vtkIdType *tris, vtkIdType fedges[2]);
00352   vtkIdType FindSplit(int type, vtkIdType fedges[2], vtkIdType& pt1,
00353                       vtkIdType& pt2, vtkIdList *CollapseTris);
00354   int IsValidSplit(int index);
00355   void SplitLoop(vtkIdType fedges[2], vtkIdType& n1, vtkIdType *l1,
00356                  vtkIdType& n2, vtkIdType *l2);
00357   void SplitVertex(vtkIdType ptId,int type, unsigned short int numTris,
00358                    vtkIdType *tris, int insert);
00359   int CollapseEdge(int type, vtkIdType ptId, vtkIdType collapseId,
00360                    vtkIdType pt1, vtkIdType pt2, vtkIdList *CollapseTris);
00361   void DistributeError(float error);
00362
00363 private:
00364   void InitializeQueue(vtkIdType numPts);
00365   void DeleteQueue()
00366     {
00367       if (this->Queue)
00368       {
00369        this->Queue->Delete();
00370       }
00371       this->Queue=NULL;};
00372   void Insert(vtkIdType id, float error= -1.0);
00373   int Pop(float &error);
00374   float DeleteId(vtkIdType id) {return this->Queue->DeleteId(id);};
00375   void Reset() {this->Queue->Reset();};
00376
00377   vtkPriorityQueue *Queue;
00378   vtkFloatArray *VertexError;
00379
00380   vtkProVertexArray *V;
00381   vtkProTriArray *T;
00382
00383   // Use to be static variables used by object
00384   vtkPolyData *Mesh; //operate on this data structure
00385   float Pt[3];      //least squares plane point
00386   float Normal[3];  //least squares plane normal
00387   float LoopArea;   //the total area of all triangles in a loop
00388   float CosAngle;   //Cosine of dihedral angle
00389   float Tolerance;  //Intersection tolerance
00390   float X[3];       //coordinates of current point
00391   int NumCollapses; //Number of times edge collapses occur
00392   int NumMerges;    //Number of times vertex merges occur
00393   int Split;        //Controls whether and when vertex splitting occurs
00394   int VertexDegree; //Maximum number of triangles that can use a vertex
00395   vtkIdType NumberOfRemainingTris; //Number of triangles left in the mesh
00396   float TheSplitAngle; //Split angle
00397   int SplitState;   //State of the splitting process
00398   float Error;      //Maximum allowable surface error
00399
00400 private:
00401   vtkDecimatePro(const vtkDecimatePro&);  // Not implemented.
00402   void operator=(const vtkDecimatePro&);  // Not implemented.
00403 };
00404
00405 #endif
00406
00407
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDelaunay2D.h Source File

Graphics/vtkDelaunay2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDelaunay2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00144 #ifndef __vtkDelaunay2D_h
00145 #define __vtkDelaunay2D_h
00146
00147 #include "vtkPointSet.h"
00148 #include "vtkPolyDataSource.h"
00149 #include "vtkAbstractTransform.h"
00150
00151 class VTK_GRAPHICS_EXPORT vtkDelaunay2D : public vtkPolyDataSource
00152 {
00153 public:
00154   vtkTypeRevisionMacro(vtkDelaunay2D,vtkPolyDataSource);
00155   void PrintSelf(ostream& os, vtkIndent indent);
00156
00159   static vtkDelaunay2D *New();
00160
00162
00167   void SetSource(vtkPolyData *);
00168   vtkPolyData *GetSource();
00170
00172
00176   vtkSetClampMacro(Alpha,double,0.0,VTK_LARGE_FLOAT);
00177   vtkGetMacro(Alpha,double);
00179
00181
00184   vtkSetClampMacro(Tolerance,double,0.0,1.0);
00185   vtkGetMacro(Tolerance,double);
00187
00189
00191   vtkSetClampMacro(Offset,double,0.75,VTK_LARGE_FLOAT);
00192   vtkGetMacro(Offset,double);
00194
00196
00200   vtkSetMacro(BoundingTriangulation,int);
00201   vtkGetMacro(BoundingTriangulation,int);
00202   vtkBooleanMacro(BoundingTriangulation,int);
00204
00206
00207   virtual void SetInput(vtkPointSet *input);
00208   vtkPointSet *GetInput();
00210
00212
00220   vtkSetObjectMacro(Transform, vtkAbstractTransform);
00221   vtkGetObjectMacro(Transform, vtkAbstractTransform);
00223
00224 protected:
00225   vtkDelaunay2D();
00226   ~vtkDelaunay2D();
00227
00228   void Execute();
00229
00230   double Alpha;
00231   double Tolerance;
00232   int BoundingTriangulation;
00233   double Offset;
00234
00235   vtkAbstractTransform *Transform;
00236
00237 private:
00238   vtkPolyData *Mesh; //the created mesh
00239   double *Points;    //the raw points in double precision
00240   void SetPoint(vtkIdType id, double *x)
00241     {vtkIdType idx=3*id;
00242     this->Points[idx] = x[0];
00243     this->Points[idx+1] = x[1];
00244     this->Points[idx+2] = x[2];
00245     }
00246
00247   void GetPoint(vtkIdType id, double x[3])
00248     {double *ptr = this->Points + 3*id;
00249     x[0] = *ptr++;
00250     x[1] = *ptr++;
00251     x[2] = *ptr;
00252     }
00253
00254   int NumberOfDuplicatePoints;
00255   int NumberOfDegeneracies;
00256
00257   int *RecoverBoundary();
00258   int RecoverEdge(vtkIdType p1, vtkIdType p2);
00259   void FillPolygons(vtkCellArray *polys, int *triUse);
00260
00261   int InCircle (double x[3], double x1[3], double x2[3], double x3[3]);
00262   vtkIdType FindTriangle(double x[3], vtkIdType ptIds[3], vtkIdType tri,
00263                          double tol, vtkIdType nei[3], vtkIdList *neighbors);
00264   void CheckEdge(vtkIdType ptId, double x[3], vtkIdType p1, vtkIdType p2,
00265                  vtkIdType tri);
00266
00267 private:
00268   vtkDelaunay2D(const vtkDelaunay2D&);  // Not implemented.
00269   void operator=(const vtkDelaunay2D&);  // Not implemented.
00270 };
00271
00272 #endif
00273
00274
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDelaunay3D.h Source File

Graphics/vtkDelaunay3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDelaunay3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00105 #ifndef __vtkDelaunay3D_h
00106 #define __vtkDelaunay3D_h
00107
00108 #include "vtkUnstructuredGridSource.h"
00109
00110 class vtkTetraArray;
00111
00112 class VTK_GRAPHICS_EXPORT vtkDelaunay3D : public vtkUnstructuredGridSource
00113 {
00114 public:
00115   vtkTypeRevisionMacro(vtkDelaunay3D,vtkUnstructuredGridSource);
00116   void PrintSelf(ostream& os, vtkIndent indent);
00117
00120   static vtkDelaunay3D *New();
00121
00123
00127   vtkSetClampMacro(Alpha,float,0.0,VTK_LARGE_FLOAT);
00128   vtkGetMacro(Alpha,float);
00130
00132
00135   vtkSetClampMacro(Tolerance,float,0.0,1.0);
00136   vtkGetMacro(Tolerance,float);
00138
00140
00142   vtkSetClampMacro(Offset,float,2.5,VTK_LARGE_FLOAT);
00143   vtkGetMacro(Offset,float);
00145
00147
00151   vtkSetMacro(BoundingTriangulation,int);
00152   vtkGetMacro(BoundingTriangulation,int);
00153   vtkBooleanMacro(BoundingTriangulation,int);
00155
00157
00159   void SetLocator(vtkPointLocator *locator);
00160   vtkGetObjectMacro(Locator,vtkPointLocator);
00162
00165   void CreateDefaultLocator();
00166
00168
00178   vtkUnstructuredGrid *InitPointInsertion(float center[3], float length,
00179                                           vtkIdType numPts, vtkPoints* &pts);
00181
00183
00192   void InsertPoint(vtkUnstructuredGrid *Mesh, vtkPoints *points,
00193                    vtkIdType id, float x[3], vtkIdList *holeTetras);
00195
00200   void EndPointInsertion();
00201
00203   unsigned long GetMTime();
00204
00206
00207   virtual void SetInput(vtkPointSet *input);
00208   vtkPointSet *GetInput();
00210
00211 protected:
00212   vtkDelaunay3D();
00213   ~vtkDelaunay3D();
00214
00215   void Execute();
00216
00217   float Alpha;
00218   float Tolerance;
00219   int BoundingTriangulation;
00220   float Offset;
00221
00222   vtkPointLocator *Locator;  //help locate points faster
00223
00224   vtkTetraArray *TetraArray; //used to keep track of circumspheres/neighbors
00225   int FindTetra(vtkUnstructuredGrid *Mesh, double x[3], vtkIdType tetId,
00226                 int depth);
00227   int InSphere(double x[3], vtkIdType tetraId);
00228   void InsertTetra(vtkUnstructuredGrid *Mesh, vtkPoints *pts,
00229                    vtkIdType tetraId);
00230
00231   int NumberOfDuplicatePoints; //keep track of bad data
00232   int NumberOfDegeneracies;
00233
00234   // Keep track of number of references to points to avoid new/delete calls
00235   int *References;
00236
00237   vtkIdType FindEnclosingFaces(float x[3], vtkUnstructuredGrid *Mesh,
00238                                vtkIdList *tetras, vtkIdList *faces,
00239                                vtkPointLocator *Locator);
00240
00241 private: //members added for performance
00242   vtkIdList *Tetras; //used in InsertPoint
00243   vtkIdList *Faces;  //used in InsertPoint
00244   vtkIdList *BoundaryPts; //used by InsertPoint
00245   vtkIdList *CheckedTetras; //used by InsertPoint
00246   vtkIdList *NeiTetras; //used by InsertPoint
00247
00248 private:
00249   vtkDelaunay3D(const vtkDelaunay3D&);  // Not implemented.
00250   void operator=(const vtkDelaunay3D&);  // Not implemented.
00251 };
00252
00253 #endif
00254
00255
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkDEMReader.h Source File

IO/vtkDEMReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDEMReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkDEMReader_h
00045 #define __vtkDEMReader_h
00046
00047 #include <stdio.h>
00048 #include "vtkImageSource.h"
00049 class VTK_IO_EXPORT vtkDEMReader : public vtkImageSource
00050 {
00051 public:
00052   static vtkDEMReader *New();
00053   vtkTypeRevisionMacro(vtkDEMReader,vtkImageSource);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetStringMacro(FileName);
00059   vtkGetStringMacro(FileName);
00061
00063
00064   vtkGetStringMacro(MapLabel);
00066
00068
00069   vtkGetMacro(DEMLevel,int);
00071
00073
00074   vtkGetMacro(ElevationPattern,  int);
00076
00078
00079   vtkGetMacro(GroundSystem,  int);
00081
00083
00084   vtkGetMacro(GroundZone,  int);
00086
00088
00089   vtkGetVectorMacro(ProjectionParameters,float,15);
00091
00093
00096   vtkGetMacro(PlaneUnitOfMeasure,  int);
00098
00100
00102   vtkGetMacro(ElevationUnitOfMeasure,  int);
00104
00106
00108   vtkGetMacro(PolygonSize,  int);
00110
00112
00114   vtkGetVectorMacro(ElevationBounds,float,2);
00116
00118
00121   vtkGetMacro(LocalRotation,  float);
00123
00125
00126   vtkGetMacro(AccuracyCode,  int);
00128
00130
00133   vtkGetVectorMacro(SpatialResolution,float,3);
00135
00137
00138   vtkGetVectorMacro(ProfileDimension,int,2);
00140
00144   void ExecuteInformation();
00145
00146 protected:
00147   vtkDEMReader();
00148   ~vtkDEMReader();
00149
00150   vtkTimeStamp ReadHeaderTime;
00151   int NumberOfColumns;
00152   int NumberOfRows;
00153   int WholeExtent[6];
00154   char *FileName;
00155   char MapLabel[145];
00156   int DEMLevel;
00157   int ElevationPattern;
00158   int GroundSystem;
00159   int GroundZone;
00160   float ProjectionParameters[15];
00161   int PlaneUnitOfMeasure;
00162   int ElevationUnitOfMeasure;
00163   int PolygonSize;
00164   float GroundCoords[4][2];
00165   float ElevationBounds[2];
00166   float LocalRotation;
00167   int AccuracyCode;
00168   float SpatialResolution[3];
00169   int ProfileDimension[2];
00170   int ProfileSeekOffset;
00171   void ComputeExtentOriginAndSpacing (int extent[6], float origin[6], float spacing[6]);
00172   int ReadTypeARecord ();
00173   int ReadProfiles (vtkImageData *data);
00174   void ExecuteData(vtkDataObject *out);
00175 private:
00176   vtkDEMReader(const vtkDEMReader&);  // Not implemented.
00177   void operator=(const vtkDEMReader&);  // Not implemented.
00178 };
00179
00180 #endif
00181
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkDepthSortPolyData.h Source File

Hybrid/vtkDepthSortPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDepthSortPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkDepthSortPolyData_h
00048 #define __vtkDepthSortPolyData_h
00049
00050 #include "vtkPolyDataToPolyDataFilter.h"
00051 #include "vtkCamera.h"
00052 #include "vtkProp3D.h"
00053 #include "vtkTransform.h"
00054
00055 #define VTK_DIRECTION_BACK_TO_FRONT 0
00056 #define VTK_DIRECTION_FRONT_TO_BACK 1
00057 #define VTK_DIRECTION_SPECIFIED_VECTOR 2
00058
00059 #define VTK_SORT_FIRST_POINT 0
00060 #define VTK_SORT_BOUNDS_CENTER 1
00061 #define VTK_SORT_PARAMETRIC_CENTER 2
00062
00063 class VTK_HYBRID_EXPORT vtkDepthSortPolyData : public vtkPolyDataToPolyDataFilter
00064 {
00065 public:
00067   static vtkDepthSortPolyData *New();
00068
00069   vtkTypeRevisionMacro(vtkDepthSortPolyData,vtkPolyDataToPolyDataFilter);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00075   vtkSetMacro(Direction,int);
00076   vtkGetMacro(Direction,int);
00077   void SetDirectionToFrontToBack()
00078     {this->SetDirection(VTK_DIRECTION_FRONT_TO_BACK);}
00079   void SetDirectionToBackToFront()
00080     {this->SetDirection(VTK_DIRECTION_BACK_TO_FRONT);}
00081   void SetDirectionToSpecifiedVector()
00082     {this->SetDirection(VTK_DIRECTION_SPECIFIED_VECTOR);}
00084
00086
00090   vtkSetMacro(DepthSortMode,int);
00091   vtkGetMacro(DepthSortMode,int);
00092   void SetDepthSortModeToFirstPoint()
00093     {this->SetDepthSortMode(VTK_SORT_FIRST_POINT);}
00094   void SetDepthSortModeToBoundsCenter()
00095     {this->SetDepthSortMode(VTK_SORT_BOUNDS_CENTER);}
00096   void SetDepthSortModeToParametricCenter()
00097     {this->SetDepthSortMode(VTK_SORT_PARAMETRIC_CENTER);}
00099
00101
00104   vtkSetObjectMacro(Camera,vtkCamera);
00105   vtkGetObjectMacro(Camera,vtkCamera);
00107
00109
00114   void SetProp3D(vtkProp3D *);
00115   vtkProp3D *GetProp3D();
00117
00119
00122   vtkSetVector3Macro(Vector,double);
00123   vtkGetVectorMacro(Vector,double,3);
00125
00127
00131   vtkSetVector3Macro(Origin,double);
00132   vtkGetVectorMacro(Origin,double,3);
00134
00136
00140   vtkSetMacro(SortScalars, int);
00141   vtkGetMacro(SortScalars, int);
00142   vtkBooleanMacro(SortScalars, int);
00144
00147   unsigned long GetMTime();
00148
00149 protected:
00150   vtkDepthSortPolyData();
00151   ~vtkDepthSortPolyData();
00152
00153   void Execute();
00154   void ComputeProjectionVector(double vector[3], double origin[3]);
00155
00156   int Direction;
00157   int DepthSortMode;
00158   vtkCamera *Camera;
00159   vtkProp3D *Prop3D;
00160   vtkTransform *Transform;
00161   double Vector[3];
00162   double Origin[3];
00163   int SortScalars;
00164
00165 private:
00166   vtkDepthSortPolyData(const vtkDepthSortPolyData&);  // Not implemented.
00167   void operator=(const vtkDepthSortPolyData&);  // Not implemented.
00168 };
00169
00170 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDicer.h Source File

Graphics/vtkDicer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDicer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkDicer_h
00054 #define __vtkDicer_h
00055
00056 #include "vtkDataSetToDataSetFilter.h"
00057
00058 #define VTK_DICE_MODE_NUMBER_OF_POINTS 0
00059 #define VTK_DICE_MODE_SPECIFIED_NUMBER 1
00060 #define VTK_DICE_MODE_MEMORY_LIMIT 2
00061
00062 class VTK_GRAPHICS_EXPORT vtkDicer : public vtkDataSetToDataSetFilter
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkDicer,vtkDataSetToDataSetFilter);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069
00074   vtkSetMacro(FieldData,int);
00075   vtkGetMacro(FieldData,int);
00076   vtkBooleanMacro(FieldData,int);
00078
00080
00082   vtkSetClampMacro(DiceMode,int,VTK_DICE_MODE_NUMBER_OF_POINTS,VTK_DICE_MODE_MEMORY_LIMIT);
00083   vtkGetMacro(DiceMode,int);
00084   void SetDiceModeToNumberOfPointsPerPiece()
00085     {this->SetDiceMode(VTK_DICE_MODE_NUMBER_OF_POINTS);};
00086   void SetDiceModeToSpecifiedNumberOfPieces()
00087     {this->SetDiceMode(VTK_DICE_MODE_SPECIFIED_NUMBER);};
00088   void SetDiceModeToMemoryLimitPerPiece()
00089     {this->SetDiceMode(VTK_DICE_MODE_MEMORY_LIMIT);};
00091
00093
00095   vtkGetMacro(NumberOfActualPieces,int);
00097
00099
00102   vtkSetClampMacro(NumberOfPointsPerPiece,int,1000,VTK_LARGE_INTEGER);
00103   vtkGetMacro(NumberOfPointsPerPiece,int);
00105
00107
00112   vtkSetClampMacro(NumberOfPieces,int,1,VTK_LARGE_INTEGER);
00113   vtkGetMacro(NumberOfPieces,int);
00115
00117
00120   vtkSetClampMacro(MemoryLimit,unsigned long,100,VTK_LARGE_INTEGER);
00121   vtkGetMacro(MemoryLimit,unsigned long);
00123
00124 protected:
00125   vtkDicer();
00126   ~vtkDicer() {};
00127
00128   virtual void UpdatePieceMeasures();
00129
00130   int           NumberOfPointsPerPiece;
00131   int           NumberOfPieces;
00132   unsigned long MemoryLimit;
00133   int           NumberOfActualPieces;
00134   int           FieldData;
00135   int           DiceMode;
00136
00137 private:
00138   vtkDicer(const vtkDicer&);  // Not implemented.
00139   void operator=(const vtkDicer&);  // Not implemented.
00140 };
00141
00142 #endif
00143
00144
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkDirectionEncoder.h Source File

Rendering/vtkDirectionEncoder.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDirectionEncoder.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00044 #ifndef __vtkDirectionEncoder_h
00045 #define __vtkDirectionEncoder_h
00046
00047 #include "vtkObject.h"
00048
00049 class VTK_RENDERING_EXPORT vtkDirectionEncoder : public vtkObject
00050 {
00051 public:
00053
00054   vtkTypeRevisionMacro(vtkDirectionEncoder,vtkObject);
00056
00058   virtual int GetEncodedDirection( float n[3] )=0;
00059
00061   virtual float *GetDecodedGradient( int value )=0;
00062
00064   virtual  int GetNumberOfEncodedDirections( void )=0;
00065
00070   virtual float *GetDecodedGradientTable( void )=0;
00071
00072 protected:
00073   vtkDirectionEncoder() {};
00074   ~vtkDirectionEncoder() {};
00075 private:
00076   vtkDirectionEncoder(const vtkDirectionEncoder&);  // Not implemented.
00077   void operator=(const vtkDirectionEncoder&);  // Not implemented.
00078 };
00079
00080
00081 #endif
00082
00083
00084
00085
00086
00087
00088
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDirectory.h Source File

Common/vtkDirectory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDirectory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkDirectory_h
00037 #define __vtkDirectory_h
00038
00039 #include "vtkObject.h"
00040 #include "vtkDebugLeaks.h"
00041
00042 class VTK_COMMON_EXPORT vtkDirectory : public vtkObject
00043 {
00044 public:
00046
00047   vtkTypeRevisionMacro(vtkDirectory,vtkObject);
00049
00051
00052   static vtkDirectory *New() {
00053 #ifdef VTK_DEBUG_LEAKS
00054     vtkDebugLeaks::ConstructClass("vtkDirectory");
00056 #endif
00057     return new vtkDirectory;};
00058
00060   virtual void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00066   int Open(const char* dir);
00067   // Description:
00068   // Return the number of files in the current directory.
00069   int GetNumberOfFiles() { return this->NumberOfFiles; }
00070   // Description:
00071   // Return the file at the given index, the indexing is 0 based
00072   const char* GetFile(int index);
00074 protected:
00075   vtkDirectory();
00076   ~vtkDirectory() ;
00077 private:
00078   char* Path;           // Path to Open'ed directory
00079   char** Files;                 // Array of Files
00080   int NumberOfFiles;            // Number if files in open directory
00081
00082 private:
00083   vtkDirectory(const vtkDirectory&);  // Not implemented.
00084   void operator=(const vtkDirectory&);  // Not implemented.
00085 };
00086
00087 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkDiskSource.h Source File

Graphics/vtkDiskSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDiskSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkDiskSource_h
00041 #define __vtkDiskSource_h
00042
00043 #include "vtkPolyDataSource.h"
00044 #include "vtkPolyData.h"
00045
00046 class VTK_GRAPHICS_EXPORT vtkDiskSource : public vtkPolyDataSource
00047 {
00048 public:
00049   static vtkDiskSource *New();
00050   vtkTypeRevisionMacro(vtkDiskSource,vtkPolyDataSource);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   vtkSetClampMacro(InnerRadius,float,0.0,VTK_LARGE_FLOAT)
00056   vtkGetMacro(InnerRadius,float);
00058
00060
00061   vtkSetClampMacro(OuterRadius,float,0.0,VTK_LARGE_FLOAT)
00062   vtkGetMacro(OuterRadius,float);
00064
00066
00067   vtkSetClampMacro(RadialResolution,int,1,VTK_LARGE_INTEGER)
00068   vtkGetMacro(RadialResolution,int);
00070
00072
00073   vtkSetClampMacro(CircumferentialResolution,int,3,VTK_LARGE_INTEGER)
00074   vtkGetMacro(CircumferentialResolution,int);
00076
00077 protected:
00078   vtkDiskSource();
00079   ~vtkDiskSource() {};
00080
00081   void Execute();
00082   float InnerRadius;
00083   float OuterRadius;
00084   int RadialResolution;
00085   int CircumferentialResolution;
00086
00087 private:
00088   vtkDiskSource(const vtkDiskSource&);  // Not implemented.
00089   void operator=(const vtkDiskSource&);  // Not implemented.
00090 };
00091
00092 #endif
00093
00094
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkDividingCubes.h Source File

Patented/vtkDividingCubes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDividingCubes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,719,585
00016      "Dividing Cubes System and Method for the Display of Surface Structures
00017      Contained Within the Interior Region of a Solid Body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00061 #ifndef __vtkDividingCubes_h
00062 #define __vtkDividingCubes_h
00063
00064 #include "vtkStructuredPointsToPolyDataFilter.h"
00065
00066 class VTK_PATENTED_EXPORT vtkDividingCubes : public vtkStructuredPointsToPolyDataFilter
00067 {
00068 public:
00069   static vtkDividingCubes *New();
00070   vtkTypeRevisionMacro(vtkDividingCubes,vtkStructuredPointsToPolyDataFilter);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00074
00075   vtkSetMacro(Value,float);
00076   vtkGetMacro(Value,float);
00078
00080
00081   vtkSetClampMacro(Distance,float,1.0e-06,VTK_LARGE_FLOAT);
00082   vtkGetMacro(Distance,float);
00084
00086
00089   vtkSetClampMacro(Increment,int,1,VTK_LARGE_INTEGER);
00090   vtkGetMacro(Increment,int);
00092
00093 protected:
00094   vtkDividingCubes();
00095   ~vtkDividingCubes();
00096
00097   void Execute();
00098   void SubDivide(float origin[3], int dim[3], float h[3], float values[8]);
00099
00100   float Value;
00101   float Distance;
00102   int Increment;
00103
00104   // working variable
00105   int Count;
00106
00107   vtkIdList *SubVoxelPts;
00108   vtkVoxel *SubVoxel;
00109   vtkFloatArray *SubVoxelScalars;
00110   vtkFloatArray *SubVoxelNormals;
00111 private:
00112   vtkDividingCubes(const vtkDividingCubes&);  // Not implemented.
00113   void operator=(const vtkDividingCubes&);  // Not implemented.
00114 };
00115
00116 #endif
00117
00118
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDoubleArray.h Source File

Common/vtkDoubleArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDoubleArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkDoubleArray_h
00045 #define __vtkDoubleArray_h
00046
00047 #include "vtkDataArray.h"
00048
00049 class VTK_COMMON_EXPORT vtkDoubleArray : public vtkDataArray
00050 {
00051 public:
00052   static vtkDoubleArray *New();
00053
00054   vtkTypeRevisionMacro(vtkDoubleArray,vtkDataArray);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00059   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00060
00062   void Initialize();
00063
00065   vtkDataArray *MakeObject();
00066
00068   int GetDataType() {return VTK_DOUBLE;};
00069
00071   int GetDataTypeSize() { return sizeof(double); }
00072
00074   void SetNumberOfTuples(const vtkIdType number);
00075
00078   float *GetTuple(const vtkIdType i);
00079
00081
00082   void GetTuple(const vtkIdType i, float * tuple);
00083   void GetTuple(const vtkIdType i, double * tuple);
00085
00087
00088   void SetTuple(const vtkIdType i, const float * tuple);
00089   void SetTuple(const vtkIdType i, const double * tuple);
00091
00093
00095   void InsertTuple(const vtkIdType i, const float * tuple);
00096   void InsertTuple(const vtkIdType i, const double * tuple);
00098
00100
00102   vtkIdType InsertNextTuple(const float * tuple);
00103   vtkIdType InsertNextTuple(const double * tuple);
00105
00107   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00108
00110   virtual void Resize(vtkIdType numTuples);
00111
00113   double GetValue(const vtkIdType id) {return this->Array[id];}
00114
00116
00118   void SetValue(const vtkIdType id, const double value)
00119     { this->Array[id] = value;};
00121
00125   void SetNumberOfValues(const vtkIdType number);
00126
00128   void InsertValue(const vtkIdType id, const double f);
00129
00132   vtkIdType InsertNextValue(const double f);
00133
00137   float GetComponent(const vtkIdType i, const int j);
00138
00143   void SetComponent(const vtkIdType i, const int j, const float c);
00144
00148   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00149
00153   double *WritePointer(const vtkIdType id, const vtkIdType number);
00154
00156
00158   double *GetPointer(const vtkIdType id) {return this->Array + id;}
00159   void *GetVoidPointer(const vtkIdType id)
00160     {return (void *)this->GetPointer(id);};
00162
00164   void DeepCopy(vtkDataArray *da);
00165
00167
00173   void SetArray(double* array, vtkIdType size, int save);
00174   void SetVoidArray(void *array, vtkIdType size, int save)
00175     {this->SetArray((double*)array, size, save);};
00177
00178 protected:
00179   vtkDoubleArray(vtkIdType numComp=1);
00180   ~vtkDoubleArray();
00181
00182   double *Array;   // pointer to data
00183   double *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00184
00185   int TupleSize; //used for data conversion
00186   float *Tuple;
00187
00188   int SaveUserArray;
00189 private:
00190   vtkDoubleArray(const vtkDoubleArray&);  // Not implemented.
00191   void operator=(const vtkDoubleArray&);  // Not implemented.
00192 };
00193
00194 inline void vtkDoubleArray::SetNumberOfValues(const vtkIdType number)
00195 {
00196   this->Allocate(number);
00197   this->MaxId = number - 1;
00198 }
00199
00200 inline double *vtkDoubleArray::WritePointer(const vtkIdType id,
00201                                             const vtkIdType number)
00202 {
00203   vtkIdType newSize=id+number;
00204   if ( newSize > this->Size )
00205     {
00206     this->ResizeAndExtend(newSize);
00207     }
00208   if ( (--newSize) > this->MaxId )
00209     {
00210     this->MaxId = newSize;
00211     }
00212   return this->Array + id;
00213 }
00214
00215 inline void vtkDoubleArray::InsertValue(const vtkIdType id, const double f)
00216 {
00217   if ( id >= this->Size )
00218     {
00219     this->ResizeAndExtend(id+1);
00220     }
00221   this->Array[id] = f;
00222   if ( id > this->MaxId )
00223     {
00224     this->MaxId = id;
00225     }
00226 }
00227
00228 inline vtkIdType vtkDoubleArray::InsertNextValue(const double f)
00229 {
00230   this->InsertValue (++this->MaxId,f);
00231   return this->MaxId;
00232 }
00233
00234
00235 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkDynamicLoader.h Source File

Common/vtkDynamicLoader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkDynamicLoader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkDynamicLoader_h
00036 #define __vtkDynamicLoader_h
00037 #include "vtkConfigure.h"
00038
00039 //BTX
00040 // Ugly stuff for library handles
00041 // They are different on several different OS's
00042 #if defined(__hpux)
00043 # include <dl.h>
00044   typedef shl_t vtkLibHandle;
00045 #elif defined(_WIN32)
00046 # include "vtkWin32Header.h"
00047   typedef HMODULE vtkLibHandle;
00048 #else
00049   typedef void* vtkLibHandle;
00050 #endif
00051 //ETX
00052
00053 #include "vtkObject.h"
00054
00055
00056 class VTK_COMMON_EXPORT vtkDynamicLoader : public vtkObject
00057 {
00058 public:
00059   static vtkDynamicLoader *New() {return new vtkDynamicLoader;};
00060   vtkTypeRevisionMacro(vtkDynamicLoader,vtkObject);
00061
00062   //BTX
00065   static vtkLibHandle OpenLibrary(const char*);
00066
00068
00070   static int CloseLibrary(vtkLibHandle);
00071   //ETX
00073
00075   static void* GetSymbolAddress(vtkLibHandle, const char*);
00076
00078   static const char* LibPrefix();
00079
00081   static const char* LibExtension();
00082
00084   static const char* LastError();
00085
00086 protected:
00087   vtkDynamicLoader() {};
00088   ~vtkDynamicLoader() {};
00089
00090
00091 private:
00092   vtkDynamicLoader(const vtkDynamicLoader&);  // Not implemented.
00093   void operator=(const vtkDynamicLoader&);  // Not implemented.
00094 };
00095
00096 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkEarthSource.h Source File

Hybrid/vtkEarthSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEarthSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkEarthSource_h
00039 #define __vtkEarthSource_h
00040
00041 #include "vtkPolyDataSource.h"
00042
00043 class VTK_HYBRID_EXPORT vtkEarthSource : public vtkPolyDataSource
00044 {
00045 public:
00046   static vtkEarthSource *New();
00047   vtkTypeRevisionMacro(vtkEarthSource,vtkPolyDataSource);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00053   vtkGetMacro(Radius,float);
00055
00057
00060   vtkSetClampMacro(OnRatio,int,1,16);
00061   vtkGetMacro(OnRatio,int);
00063
00065
00069   vtkSetMacro(Outline,int);
00070   vtkGetMacro(Outline,int);
00071   vtkBooleanMacro(Outline,int);
00073
00074 protected:
00075   vtkEarthSource();
00076   ~vtkEarthSource() {};
00077
00078   void Execute();
00079
00080   float Radius;
00081   int OnRatio;
00082   int Outline;
00083 private:
00084   vtkEarthSource(const vtkEarthSource&);  // Not implemented.
00085   void operator=(const vtkEarthSource&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
00091
00092
00093
00094
00095
00096
00097
00098
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkEdgePoints.h Source File

Graphics/vtkEdgePoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEdgePoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkEdgePoints_h
00046 #define __vtkEdgePoints_h
00047
00048 #include "vtkDataSetToPolyDataFilter.h"
00049 #include "vtkMergePoints.h"
00050
00051 class VTK_GRAPHICS_EXPORT vtkEdgePoints : public vtkDataSetToPolyDataFilter
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkEdgePoints,vtkDataSetToPolyDataFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058   static vtkEdgePoints *New();
00059
00061
00062   vtkSetMacro(Value,float);
00063   vtkGetMacro(Value,float);
00065
00066 protected:
00067   vtkEdgePoints();
00068   ~vtkEdgePoints();
00069
00070   void Execute();
00071
00072   float Value;
00073   vtkMergePoints *Locator;
00074 private:
00075   vtkEdgePoints(const vtkEdgePoints&);  // Not implemented.
00076   void operator=(const vtkEdgePoints&);  // Not implemented.
00077 };
00078
00079 #endif
00080
00081
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkEdgeTable.h Source File

Common/vtkEdgeTable.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEdgeTable.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkEdgeTable_h
00037 #define __vtkEdgeTable_h
00038
00039 #include "vtkObject.h"
00040
00041 class vtkIdList;
00042 class vtkPoints;
00043
00044 class VTK_COMMON_EXPORT vtkEdgeTable : public vtkObject
00045 {
00046 public:
00048   static vtkEdgeTable *New();
00049
00050   vtkTypeRevisionMacro(vtkEdgeTable,vtkObject);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054   void Initialize();
00055
00063   int InitEdgeInsertion(vtkIdType numPoints, int storeAttributes=0);
00064
00072   vtkIdType InsertEdge(vtkIdType p1, vtkIdType p2);
00073
00080   void InsertEdge(vtkIdType p1, vtkIdType p2, int attributeId);
00081
00087   int IsEdge(vtkIdType p1, vtkIdType p2);
00088
00092   int InitPointInsertion(vtkPoints *newPts, vtkIdType estSize);
00093
00095
00098   int InsertUniquePoint(vtkIdType p1, vtkIdType p2, float x[3],
00099                         vtkIdType &ptId);
00101
00103
00104   vtkGetMacro(NumberOfEdges, vtkIdType);
00106
00108   void InitTraversal();
00109
00114   int GetNextEdge(vtkIdType &p1, vtkIdType &p2);
00115
00118   void Reset();
00119
00120 protected:
00121   vtkEdgeTable();
00122   ~vtkEdgeTable();
00123
00124   vtkIdList **Table;
00125   vtkIdList **Attributes;
00126   int StoreAttributes;
00127   vtkIdType TableMaxId; //maximum point id inserted
00128   vtkIdType TableSize;  //allocated size of table
00129   int Position[2];
00130   int Extend;
00131   vtkIdType NumberOfEdges;
00132   vtkPoints *Points; //support point insertion
00133
00134   vtkIdList **Resize(vtkIdType size);
00135 private:
00136   vtkEdgeTable(const vtkEdgeTable&);  // Not implemented.
00137   void operator=(const vtkEdgeTable&);  // Not implemented.
00138 };
00139
00140 #endif
00141
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkElevationFilter.h Source File

Graphics/vtkElevationFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkElevationFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkElevationFilter_h
00044 #define __vtkElevationFilter_h
00045
00046 #include "vtkDataSetToDataSetFilter.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkElevationFilter : public vtkDataSetToDataSetFilter
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkElevationFilter,vtkDataSetToDataSetFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   static vtkElevationFilter *New();
00057
00059
00060   vtkSetVector3Macro(LowPoint,float);
00061   vtkGetVectorMacro(LowPoint,float,3);
00063
00065
00066   vtkSetVector3Macro(HighPoint,float);
00067   vtkGetVectorMacro(HighPoint,float,3);
00069
00071
00072   vtkSetVector2Macro(ScalarRange,float);
00073   vtkGetVectorMacro(ScalarRange,float,2);
00075
00076 protected:
00077   vtkElevationFilter();
00078   ~vtkElevationFilter() {};
00079
00080   void Execute();
00081   float LowPoint[3];
00082   float HighPoint[3];
00083   float ScalarRange[2];
00084 private:
00085   vtkElevationFilter(const vtkElevationFilter&);  // Not implemented.
00086   void operator=(const vtkElevationFilter&);  // Not implemented.
00087 };
00088
00089 #endif
00090
00091
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkEmptyCell.h Source File

Common/vtkEmptyCell.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEmptyCell.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkEmptyCell_h
00038 #define __vtkEmptyCell_h
00039
00040 #include "vtkCell.h"
00041
00042 class VTK_COMMON_EXPORT vtkEmptyCell : public vtkCell
00043 {
00044 public:
00045   static vtkEmptyCell *New();
00046   vtkTypeRevisionMacro(vtkEmptyCell,vtkCell);
00047
00049
00050   vtkCell *MakeObject() {return vtkEmptyCell::New();};
00051   int GetCellType() {return VTK_EMPTY_CELL;};
00052   int GetCellDimension() {return 0;};
00053   int GetNumberOfEdges() {return 0;};
00054   int GetNumberOfFaces() {return 0;};
00055   vtkCell *GetEdge(int) {return 0;};
00056   vtkCell *GetFace(int) {return 0;};
00057   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00058   void Contour(float value, vtkDataArray *cellScalars,
00059                vtkPointLocator *locator, vtkCellArray *verts1,
00060                vtkCellArray *lines, vtkCellArray *verts2,
00061                vtkPointData *inPd, vtkPointData *outPd,
00062                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00063   void Clip(float value, vtkDataArray *cellScalars,
00064             vtkPointLocator *locator, vtkCellArray *pts,
00065             vtkPointData *inPd, vtkPointData *outPd,
00066             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00067             int insideOut);
00069
00070   int EvaluatePosition(float x[3], float* closestPoint,
00071                        int& subId, float pcoords[3],
00072                        float& dist2, float *weights);
00073   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00074                         float *weights);
00075   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00076                         float x[3], float pcoords[3], int& subId);
00077   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00078   void Derivatives(int subId, float pcoords[3], float *values,
00079                    int dim, float *derivs);
00080
00081 protected:
00082   vtkEmptyCell() {};
00083   ~vtkEmptyCell() {};
00084
00085
00086 private:
00087   vtkEmptyCell(const vtkEmptyCell&);  // Not implemented.
00088   void operator=(const vtkEmptyCell&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkEncodedGradientEstimator.h Source File

Rendering/vtkEncodedGradientEstimator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEncodedGradientEstimator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00043 #ifndef __vtkEncodedGradientEstimator_h
00044 #define __vtkEncodedGradientEstimator_h
00045
00046 #include "vtkObject.h"
00047 #include "vtkMultiThreader.h"
00048 #include "vtkImageData.h"
00049 #include "vtkDirectionEncoder.h"
00050
00051 class VTK_RENDERING_EXPORT vtkEncodedGradientEstimator : public vtkObject
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkEncodedGradientEstimator,vtkObject);
00055   void PrintSelf( ostream& os, vtkIndent index );
00056
00058
00059   vtkSetObjectMacro( Input, vtkImageData );
00060   vtkGetObjectMacro( Input, vtkImageData );
00062
00064
00065   vtkSetMacro( GradientMagnitudeScale, float );
00066   vtkGetMacro( GradientMagnitudeScale, float );
00067   vtkSetMacro( GradientMagnitudeBias, float );
00068   vtkGetMacro( GradientMagnitudeBias, float );
00070
00072
00074   vtkSetClampMacro( BoundsClip, int, 0, 1 );
00075   vtkGetMacro( BoundsClip, int );
00076   vtkBooleanMacro( BoundsClip, int );
00078
00080
00083   vtkSetVector6Macro( Bounds, int );
00084   vtkGetVectorMacro(  Bounds, int, 6 );
00086
00088   void  Update( void );
00089
00091   unsigned short  *GetEncodedNormals( void );
00092
00094
00095   int   GetEncodedNormalIndex( int xyz_index );
00096   int   GetEncodedNormalIndex( int x_index, int y_index, int z_index );
00098
00100   unsigned char *GetGradientMagnitudes(void);
00101
00103
00105   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00106   vtkGetMacro( NumberOfThreads, int );
00108
00110
00112   void SetDirectionEncoder( vtkDirectionEncoder *direnc );
00113   vtkGetObjectMacro( DirectionEncoder, vtkDirectionEncoder );
00115
00117
00121   vtkSetMacro( ComputeGradientMagnitudes, int );
00122   vtkGetMacro( ComputeGradientMagnitudes, int );
00123   vtkBooleanMacro( ComputeGradientMagnitudes, int );
00125
00127
00131   vtkSetMacro( CylinderClip, int );
00132   vtkGetMacro( CylinderClip, int );
00133   vtkBooleanMacro( CylinderClip, int );
00135
00137
00138   vtkGetMacro( LastUpdateTimeInSeconds, float );
00139   vtkGetMacro( LastUpdateTimeInCPUSeconds, float );
00141
00142   vtkGetMacro( UseCylinderClip, int );
00143   int *GetCircleLimits() { return this->CircleLimits; };
00144
00146
00152   void SetZeroNormalThreshold( float v );
00153   vtkGetMacro( ZeroNormalThreshold, float );
00155
00157
00159   vtkSetClampMacro( ZeroPad, int, 0, 1 );
00160   vtkGetMacro( ZeroPad, int );
00161   vtkBooleanMacro( ZeroPad, int );
00163
00164
00165   // These variables should be protected but are being
00166   // made public to be accessible to the templated function.
00167   // We used to have the templated function as a friend, but
00168   // this does not work with all compilers
00169
00170   // The input scalar data on which the normals are computed
00171   vtkImageData         *Input;
00172
00173   // The encoded normals (2 bytes) and the size of the encoded normals
00174   unsigned short        *EncodedNormals;
00175   int                   EncodedNormalsSize[3];
00176
00177   // The magnitude of the gradient array and the size of this array
00178   unsigned char         *GradientMagnitudes;
00179
00180   // The time at which the normals were last built
00181   vtkTimeStamp          BuildTime;
00182
00183 //BTX
00184   vtkGetVectorMacro( InputSize, int, 3 );
00185   vtkGetVectorMacro( InputAspect, float, 3 );
00186 //ETX
00187
00188 protected:
00189   vtkEncodedGradientEstimator();
00190   ~vtkEncodedGradientEstimator();
00191
00192   // The number of threads to use when encoding normals
00193   int                        NumberOfThreads;
00194
00195   vtkMultiThreader           *Threader;
00196
00197   vtkDirectionEncoder        *DirectionEncoder;
00198
00199   virtual void               UpdateNormals( void ) = 0;
00200
00201   float                      GradientMagnitudeScale;
00202   float                      GradientMagnitudeBias;
00203
00204   float                      LastUpdateTimeInSeconds;
00205   float                      LastUpdateTimeInCPUSeconds;
00206
00207   float                      ZeroNormalThreshold;
00208
00209   int                        CylinderClip;
00210   int                        *CircleLimits;
00211   int                        CircleLimitsSize;
00212   int                        UseCylinderClip;
00213   void                       ComputeCircleLimits( int size );
00214
00215   int                        BoundsClip;
00216   int                        Bounds[6];
00217
00218   int                        InputSize[3];
00219   float                      InputAspect[3];
00220
00221   int                        ComputeGradientMagnitudes;
00222
00223   int                        ZeroPad;
00224
00225 private:
00226   vtkEncodedGradientEstimator(const vtkEncodedGradientEstimator&);  // Not implemented.
00227   void operator=(const vtkEncodedGradientEstimator&);  // Not implemented.
00228 };
00229
00230
00231 #endif
00232
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkEncodedGradientShader.h Source File

Rendering/vtkEncodedGradientShader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEncodedGradientShader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00043 #ifndef __vtkEncodedGradientShader_h
00044 #define __vtkEncodedGradientShader_h
00045
00046 #include "vtkObject.h"
00047
00048 class vtkVolume;
00049 class vtkRenderer;
00050 class vtkEncodedGradientEstimator;
00051
00052 #define VTK_MAX_SHADING_TABLES   100
00053
00054 class VTK_RENDERING_EXPORT vtkEncodedGradientShader : public vtkObject
00055 {
00056 public:
00057   static vtkEncodedGradientShader *New();
00058   vtkTypeRevisionMacro(vtkEncodedGradientShader,vtkObject);
00059
00061   void PrintSelf( ostream& os, vtkIndent index );
00062
00064
00066   vtkSetClampMacro( ZeroNormalDiffuseIntensity,  float, 0.0, 1.0);
00067   vtkGetMacro( ZeroNormalDiffuseIntensity, float );
00068   vtkSetClampMacro( ZeroNormalSpecularIntensity, float, 0.0, 1.0);
00069   vtkGetMacro( ZeroNormalSpecularIntensity, float );
00071
00073
00074   void UpdateShadingTable( vtkRenderer *ren, vtkVolume *vol,
00075                            vtkEncodedGradientEstimator *gradest);
00077
00079
00080   float *GetRedDiffuseShadingTable(    vtkVolume *vol );
00081   float *GetGreenDiffuseShadingTable(  vtkVolume *vol );
00082   float *GetBlueDiffuseShadingTable(   vtkVolume *vol );
00083   float *GetRedSpecularShadingTable(   vtkVolume *vol );
00084   float *GetGreenSpecularShadingTable( vtkVolume *vol );
00085   float *GetBlueSpecularShadingTable(  vtkVolume *vol );
00087
00088 protected:
00089   vtkEncodedGradientShader();
00090   ~vtkEncodedGradientShader();
00091
00093
00105   void  BuildShadingTable( int index,
00106                            float lightDirection[3],
00107                            float lightColor[3],
00108                            float lightIntensity,
00109                            float viewDirection[3],
00110                            float material[4],
00111                            int twoSided,
00112                            vtkEncodedGradientEstimator *gradest,
00113                            int updateFlag );
00115
00116   // The six shading tables (r diffuse ,g diffuse ,b diffuse,
00117   // r specular, g specular, b specular ) - with an entry for each
00118   // encoded normal plus one entry at the end for the zero normal
00119   // There is one shading table per volume listed in the ShadingTableVolume
00120   // array. A null entry indicates an available slot.
00121   float                        *ShadingTable[VTK_MAX_SHADING_TABLES][6];
00122   vtkVolume                    *ShadingTableVolume[VTK_MAX_SHADING_TABLES];
00123   int                          ShadingTableSize[VTK_MAX_SHADING_TABLES];
00124
00125   // The intensity of light used for the zero normals, since it
00126   // can not be computed from the normal angles. Defaults to 0.0.
00127   float    ZeroNormalDiffuseIntensity;
00128   float    ZeroNormalSpecularIntensity;
00129 private:
00130   vtkEncodedGradientShader(const vtkEncodedGradientShader&);  // Not implemented.
00131   void operator=(const vtkEncodedGradientShader&);  // Not implemented.
00132 };
00133
00134
00135 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkEnSight6BinaryReader.h Source File

IO/vtkEnSight6BinaryReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEnSight6BinaryReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkEnSight6BinaryReader_h
00048 #define __vtkEnSight6BinaryReader_h
00049
00050 #include "vtkEnSightReader.h"
00051
00052 class VTK_IO_EXPORT vtkEnSight6BinaryReader : public vtkEnSightReader
00053 {
00054 public:
00055   static vtkEnSight6BinaryReader *New();
00056   vtkTypeRevisionMacro(vtkEnSight6BinaryReader, vtkEnSightReader);
00057
00058 protected:
00059   vtkEnSight6BinaryReader();
00060   ~vtkEnSight6BinaryReader();
00061
00064   virtual int ReadGeometryFile(char* fileName, int timeStep);
00065
00068   virtual int ReadMeasuredGeometryFile(char* fileName, int timeStep);
00069
00071
00075   virtual int ReadScalarsPerNode(char* fileName, char* description,
00076                                  int timeStep, int measured = 0,
00077                                  int numberOfComponents = 1,
00078                                  int component = 0);
00080
00082
00084   virtual int ReadVectorsPerNode(char* fileName, char* description,
00085                                  int timeStep, int measured = 0);
00087
00089
00091   virtual int ReadTensorsPerNode(char* fileName, char* description,
00092                                  int timeStep);
00094
00096
00100   virtual int ReadScalarsPerElement(char* fileName, char* description,
00101                                     int timeStep, int numberOfComponents = 1,
00102                                     int component = 0);
00104
00106
00108   virtual int ReadVectorsPerElement(char* fileName, char* description,
00109                                     int timeStep);
00111
00113
00115   virtual int ReadTensorsPerElement(char* fileName, char* description,
00116                                     int timeStep);
00118
00121   virtual int CreateUnstructuredGridOutput(int partId, char line[256]);
00122
00125   virtual int CreateStructuredGridOutput(int partId, char line[256]);
00126
00129   int ReadLine(char result[80]);
00130
00133   int ReadInt(int *result);
00134
00137   int ReadIntArray(int *result, int numInts);
00138
00141   int ReadFloatArray(float *result, int numFloats);
00142
00144
00145   void SkipTimeStep();
00146   int SkipStructuredGrid(char line[256]);
00147   int SkipUnstructuredGrid(char line[256]);
00149
00150   // global list of points for the unstructured parts of the model
00151   int NumberOfUnstructuredPoints;
00152   vtkPoints* UnstructuredPoints;
00153   vtkIdList* UnstructuredNodeIds; // matching of node ids to point ids
00154
00155   int ElementIdsListed;
00156
00157   FILE *IFile;
00158 private:
00159   vtkEnSight6BinaryReader(const vtkEnSight6BinaryReader&);  // Not implemented.
00160   void operator=(const vtkEnSight6BinaryReader&);  // Not implemented.
00161 };
00162
00163 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkEnSight6Reader.h Source File

IO/vtkEnSight6Reader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEnSight6Reader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkEnSight6Reader_h
00048 #define __vtkEnSight6Reader_h
00049
00050 #include "vtkEnSightReader.h"
00051
00052 class VTK_IO_EXPORT vtkEnSight6Reader : public vtkEnSightReader
00053 {
00054 public:
00055   static vtkEnSight6Reader *New();
00056   vtkTypeRevisionMacro(vtkEnSight6Reader, vtkEnSightReader);
00057
00058 protected:
00059   vtkEnSight6Reader();
00060   ~vtkEnSight6Reader();
00061
00064   virtual int ReadGeometryFile(char* fileName, int timeStep);
00065
00068   virtual int ReadMeasuredGeometryFile(char* fileName, int timeStep);
00069
00071
00075   virtual int ReadScalarsPerNode(char* fileName, char* description,
00076                                  int timeStep, int measured = 0,
00077                                  int numberOfComponents = 1,
00078                                  int component = 0);
00080
00082
00084   virtual int ReadVectorsPerNode(char* fileName, char* description,
00085                                  int timeStep, int measured = 0);
00087
00089
00091   virtual int ReadTensorsPerNode(char* fileName, char* description,
00092                                  int timeStep);
00094
00096
00100   virtual int ReadScalarsPerElement(char* fileName, char* description,
00101                                     int timeStep, int numberOfComponents = 1,
00102                                     int component = 0);
00104
00106
00108   virtual int ReadVectorsPerElement(char* fileName, char* description,
00109                                     int timeStep);
00111
00113
00115   virtual int ReadTensorsPerElement(char* fileName, char* description,
00116                                     int timeStep);
00118
00121   virtual int CreateUnstructuredGridOutput(int partId, char line[256]);
00122
00125   virtual int CreateStructuredGridOutput(int partId, char line[256]);
00126
00127   // global list of points for the unstructured parts of the model
00128   int NumberOfUnstructuredPoints;
00129   vtkPoints* UnstructuredPoints;
00130   vtkIdList* UnstructuredNodeIds; // matching of node ids to point ids
00131 private:
00132   vtkEnSight6Reader(const vtkEnSight6Reader&);  // Not implemented.
00133   void operator=(const vtkEnSight6Reader&);  // Not implemented.
00134 };
00135
00136 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkEnSightGoldBinaryReader.h Source File

IO/vtkEnSightGoldBinaryReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEnSightGoldBinaryReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkEnSightGoldBinaryReader_h
00051 #define __vtkEnSightGoldBinaryReader_h
00052
00053 #include "vtkEnSightReader.h"
00054
00055 class VTK_IO_EXPORT vtkEnSightGoldBinaryReader : public vtkEnSightReader
00056 {
00057 public:
00058   static vtkEnSightGoldBinaryReader *New();
00059   vtkTypeRevisionMacro(vtkEnSightGoldBinaryReader, vtkEnSightReader);
00060
00061 protected:
00062   vtkEnSightGoldBinaryReader();
00063   ~vtkEnSightGoldBinaryReader();
00064
00067   virtual int ReadGeometryFile(char* fileName, int timeStep);
00068
00071   virtual int ReadMeasuredGeometryFile(char* fileName, int timeStep);
00072
00074
00077   virtual int ReadScalarsPerNode(char* fileName, char* description,
00078                                  int timeStep, int measured = 0,
00079                                  int numberOfComponents = 1,
00080                                  int component = 0);
00082
00084
00086   virtual int ReadVectorsPerNode(char* fileName, char* description,
00087                                  int timeStep, int measured = 0);
00089
00091
00093   virtual int ReadTensorsPerNode(char* fileName, char* description,
00094                                  int timeStep);
00096
00098
00101   virtual int ReadScalarsPerElement(char* fileName, char* description,
00102                                     int timeStep, int numberOfComponents = 1,
00103                                     int component = 0);
00105
00107
00109   virtual int ReadVectorsPerElement(char* fileName, char* description,
00110                                     int timeStep);
00112
00114
00116   virtual int ReadTensorsPerElement(char* fileName, char* description,
00117                                     int timeStep);
00119
00123   virtual int CreateUnstructuredGridOutput(int partId, char line[80]);
00124
00127   virtual int CreateStructuredGridOutput(int partId, char line[256]);
00128
00131   int CreateRectilinearGridOutput(int partId, char line[256]);
00132
00135   int CreateImageDataOutput(int partId, char line[80]);
00136
00139   int ReadLine(char result[80]);
00140
00143   int ReadInt(int *result);
00144
00147   int ReadIntArray(int *result, int numInts);
00148
00151   int ReadFloatArray(float *result, int numFloats);
00152
00154
00155   void SkipTimeStep();
00156   int SkipStructuredGrid(char line[256]);
00157   int SkipUnstructuredGrid(char line[256]);
00158   int SkipRectilinearGrid(char line[256]);
00159   int SkipImageData(char line[256]);
00161
00162   int NodeIdsListed;
00163   int ElementIdsListed;
00164
00165   FILE *IFile;
00166 private:
00167   vtkEnSightGoldBinaryReader(const vtkEnSightGoldBinaryReader&);  // Not implemented.
00168   void operator=(const vtkEnSightGoldBinaryReader&);  // Not implemented.
00169 };
00170
00171 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkEnSightGoldReader.h Source File

IO/vtkEnSightGoldReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEnSightGoldReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkEnSightGoldReader_h
00048 #define __vtkEnSightGoldReader_h
00049
00050 #include "vtkEnSightReader.h"
00051
00052 class VTK_IO_EXPORT vtkEnSightGoldReader : public vtkEnSightReader
00053 {
00054 public:
00055   static vtkEnSightGoldReader *New();
00056   vtkTypeRevisionMacro(vtkEnSightGoldReader, vtkEnSightReader);
00057
00058 protected:
00059   vtkEnSightGoldReader() {};
00060   ~vtkEnSightGoldReader() {};
00061
00064   virtual int ReadGeometryFile(char* fileName, int timeStep);
00065
00068   virtual int ReadMeasuredGeometryFile(char* fileName, int timeStep);
00069
00071
00074   virtual int ReadScalarsPerNode(char* fileName, char* description,
00075                                  int timeStep, int measured = 0,
00076                                  int numberOfComponents = 1,
00077                                  int component = 0);
00079
00081
00083   virtual int ReadVectorsPerNode(char* fileName, char* description,
00084                                  int timeStep, int measured = 0);
00086
00088
00090   virtual int ReadTensorsPerNode(char* fileName, char* description,
00091                                  int timeStep);
00093
00095
00098   virtual int ReadScalarsPerElement(char* fileName, char* description,
00099                                     int timeStep, int numberOfComponents = 1,
00100                                     int component = 0);
00102
00104
00106   virtual int ReadVectorsPerElement(char* fileName, char* description,
00107                                     int timeStep);
00109
00111
00113   virtual int ReadTensorsPerElement(char* fileName, char* description,
00114                                     int timeStep);
00116
00120   virtual int CreateUnstructuredGridOutput(int partId, char line[256]);
00121
00124   virtual int CreateStructuredGridOutput(int partId, char line[256]);
00125
00128   int CreateRectilinearGridOutput(int partId, char line[256]);
00129
00132   int CreateImageDataOutput(int partId, char line[256]);
00133
00135
00136   vtkSetStringMacro(GeometryFileName);
00137   vtkGetStringMacro(GeometryFileName);
00139
00141
00142   vtkSetStringMacro(MeasuredFileName);
00143   vtkGetStringMacro(MeasuredFileName);
00145
00147
00148   vtkSetStringMacro(MatchFileName);
00149   vtkGetStringMacro(MatchFileName);
00151 private:
00152   vtkEnSightGoldReader(const vtkEnSightGoldReader&);  // Not implemented.
00153   void operator=(const vtkEnSightGoldReader&);  // Not implemented.
00154 };
00155
00156 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkEnSightReader.h Source File

IO/vtkEnSightReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkEnSightReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00029 #ifndef __vtkEnSightReader_h
00030 #define __vtkEnSightReader_h
00031
00032 #include "vtkDataSetSource.h"
00033 #include "vtkCollection.h"
00034
00035 // element types
00036 #define VTK_ENSIGHT_POINT               0
00037 #define VTK_ENSIGHT_BAR2                1
00038 #define VTK_ENSIGHT_BAR3                2
00039 #define VTK_ENSIGHT_NSIDED              3
00040 #define VTK_ENSIGHT_TRIA3               4
00041 #define VTK_ENSIGHT_TRIA6               5
00042 #define VTK_ENSIGHT_QUAD4               6
00043 #define VTK_ENSIGHT_QUAD8               7
00044 #define VTK_ENSIGHT_TETRA4              8
00045 #define VTK_ENSIGHT_TETRA10             9
00046 #define VTK_ENSIGHT_PYRAMID5           10
00047 #define VTK_ENSIGHT_PYRAMID13          11
00048 #define VTK_ENSIGHT_HEXA8              12
00049 #define VTK_ENSIGHT_HEXA20             13
00050 #define VTK_ENSIGHT_PENTA6             14
00051 #define VTK_ENSIGHT_PENTA15            15
00052
00053 // variable types
00054 #define VTK_SCALAR_PER_NODE             0
00055 #define VTK_VECTOR_PER_NODE             1
00056 #define VTK_TENSOR_SYMM_PER_NODE        2
00057 #define VTK_SCALAR_PER_ELEMENT          3
00058 #define VTK_VECTOR_PER_ELEMENT          4
00059 #define VTK_TENSOR_SYMM_PER_ELEMENT     5
00060 #define VTK_SCALAR_PER_MEASURED_NODE    6
00061 #define VTK_VECTOR_PER_MEASURED_NODE    7
00062 #define VTK_COMPLEX_SCALAR_PER_NODE     8
00063 #define VTK_COMPLEX_VECTOR_PER_NODE     9
00064 #define VTK_COMPLEX_SCALAR_PER_ELEMENT 10
00065 #define VTK_COMPLEX_VECTOR_PER_ELEMENT 11
00066
00067 class VTK_IO_EXPORT vtkEnSightReader : public vtkDataSetSource
00068 {
00069 public:
00070   vtkTypeRevisionMacro(vtkEnSightReader, vtkDataSetSource);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00074
00075   void SetCaseFileName(char* fileName);
00076   vtkGetStringMacro(CaseFileName);
00078
00080
00082   vtkSetStringMacro(FilePath);
00083   vtkGetStringMacro(FilePath);
00085
00087
00088   int GetNumberOfVariables() { return this->NumberOfVariables; }
00089   int GetNumberOfComplexVariables() { return this->NumberOfComplexVariables; }
00091
00093
00094   int GetNumberOfVariables(int type); // returns -1 if unknown type specified
00095   vtkGetMacro(NumberOfScalarsPerNode, int);
00096   vtkGetMacro(NumberOfVectorsPerNode, int);
00097   vtkGetMacro(NumberOfTensorsSymmPerNode, int);
00098   vtkGetMacro(NumberOfScalarsPerElement, int);
00099   vtkGetMacro(NumberOfVectorsPerElement, int);
00100   vtkGetMacro(NumberOfTensorsSymmPerElement, int);
00101   vtkGetMacro(NumberOfScalarsPerMeasuredNode, int);
00102   vtkGetMacro(NumberOfVectorsPerMeasuredNode, int);
00103   vtkGetMacro(NumberOfComplexScalarsPerNode, int);
00104   vtkGetMacro(NumberOfComplexVectorsPerNode, int);
00105   vtkGetMacro(NumberOfComplexScalarsPerElement, int);
00106   vtkGetMacro(NumberOfComplexVectorsPerElement, int);
00108
00110   char* GetDescription(int n);
00111
00113   char* GetComplexDescription(int n);
00114
00124   char* GetDescription(int n, int type);
00125
00127
00128   int GetVariableType(int n);
00129   int GetComplexVariableType(int n);
00131
00132   void Update();
00133
00135
00136   vtkSetMacro(TimeValue, float);
00137   vtkGetMacro(TimeValue, float);
00139
00141
00142   vtkGetMacro(MinimumTimeValue, float);
00143   vtkGetMacro(MaximumTimeValue, float);
00145
00146 protected:
00147   vtkEnSightReader();
00148   ~vtkEnSightReader();
00149
00150   void Execute();
00151
00154   int ReadCaseFile();
00155
00158   virtual int ReadGeometryFile(char* fileName, int timeStep) = 0;
00159
00162   virtual int ReadMeasuredGeometryFile(char* fileName, int timeStep) = 0;
00163
00166   int ReadVariableFiles();
00167
00169
00171   virtual int ReadScalarsPerNode(char* fileName, char* description,
00172                                  int timeStep, int measured = 0,
00173                                  int numberOfComponents = 1,
00174                                  int component = 0) = 0;
00176
00178
00180   virtual int ReadVectorsPerNode(char* fileName, char* description,
00181                                  int timeStep, int measured = 0) = 0;
00183
00185
00187   virtual int ReadTensorsPerNode(char* fileName, char* description,
00188                                  int timeStep) = 0;
00190
00192
00194   virtual int ReadScalarsPerElement(char* fileName, char* description,
00195                                     int timeStep, int numberOfComponents = 1,
00196                                     int component = 0) = 0;
00198
00200
00202   virtual int ReadVectorsPerElement(char* fileName, char* description,
00203                                     int timeStep) = 0;
00205
00207
00209   virtual int ReadTensorsPerElement(char* fileName, char* description,
00210                                     int timeStep) = 0;
00212
00215   virtual int CreateUnstructuredGridOutput(int partId, char line[256]) = 0;
00216
00219   virtual int CreateStructuredGridOutput(int partId, char line[256]) = 0;
00220
00222
00223   vtkSetStringMacro(GeometryFileName);
00224   vtkGetStringMacro(GeometryFileName);
00226
00228
00229   vtkSetStringMacro(MeasuredFileName);
00230   vtkGetStringMacro(MeasuredFileName);
00232
00234
00235   vtkSetStringMacro(MatchFileName);
00236   vtkGetStringMacro(MatchFileName);
00238
00241   int ReadLine(char result[256]);
00242
00243   // Internal function that skips blank lines and reads the 1st
00244   // non-blank line it finds (up to 256 characters).
00245   // Returns 0 is there was an error.
00246   int ReadNextDataLine(char result[256]);
00247
00249   void AddVariableFileName(char* fileName1, char* fileName2 = NULL);
00250
00252   void AddVariableDescription(char* description);
00253
00255   void AddVariableType();
00256
00259   int GetElementType(char* line);
00260
00262   void ReplaceWildcards(char* filename, int num);
00263
00264   char* FilePath;
00265
00266   char* CaseFileName;
00267   char* GeometryFileName;
00268   char* MeasuredFileName;
00269   char* MatchFileName; // may not actually be necessary to read this file
00270
00271   // pointer to lists of vtkIdLists (cell ids per element type per part)
00272   vtkIdList*** CellIds;
00273
00274   // part ids of unstructured outputs
00275   vtkIdList* UnstructuredPartIds;
00276
00277   int VariableMode;
00278   int NumberOfVariables; // non-complex
00279   int NumberOfComplexVariables;
00280
00281   // array of types (one entry per instance of variable type in case file)
00282   int* VariableTypes; // non-complex
00283   int* ComplexVariableTypes;
00284
00285   // pointers to lists of filenames
00286   char** VariableFileNames; // non-complex
00287   char** ComplexVariableFileNames;
00288
00289   // pointers to lists of descriptions
00290   char** VariableDescriptions; // non-complex
00291   char** ComplexVariableDescriptions;
00292
00293   // array of time sets
00294   vtkIdList *VariableTimeSets;
00295   vtkIdList *ComplexVariableTimeSets;
00296
00297   // array of file sets
00298   vtkIdList *VariableFileSets;
00299   vtkIdList *ComplexVariableFileSets;
00300
00301   // collection of filename numbers per time set
00302   vtkCollection *TimeSetFilenameNumbersCollection;
00303   vtkIdList *TimeSetsWithFilenameNumbers;
00304
00305   // collection of time values per time set
00306   vtkCollection *TimeSetTimeValuesCollection;
00307
00308   // collection of filename numbers per file set
00309   vtkCollection *FileSetFilenameNumbersCollection;
00310   vtkIdList *FileSetsWithFilenameNumbers;
00311
00312   // collection of number of steps per file per file set
00313   vtkCollection *FileSetNumberOfStepsCollection;
00314
00315   // ids of the time and file sets
00316   vtkIdList *TimeSets;
00317   vtkIdList *FileSets;
00318
00319   int GeometryTimeSet;
00320   int GeometryFileSet;
00321   int MeasuredTimeSet;
00322   int MeasuredFileSet;
00323
00324   float TimeValue;
00325   float GeometryTimeValue;
00326   float MeasuredTimeValue;
00327
00328   float MinimumTimeValue;
00329   float MaximumTimeValue;
00330
00331   // number of file names / descriptions per type
00332   int NumberOfScalarsPerNode;
00333   int NumberOfVectorsPerNode;
00334   int NumberOfTensorsSymmPerNode;
00335   int NumberOfScalarsPerElement;
00336   int NumberOfVectorsPerElement;
00337   int NumberOfTensorsSymmPerElement;
00338   int NumberOfScalarsPerMeasuredNode;
00339   int NumberOfVectorsPerMeasuredNode;
00340   int NumberOfComplexScalarsPerNode;
00341   int NumberOfComplexVectorsPerNode;
00342   int NumberOfComplexScalarsPerElement;
00343   int NumberOfComplexVectorsPerElement;
00344
00345   istream* IS;
00346
00347   int UseTimeSets;
00348   vtkSetMacro(UseTimeSets, int);
00349   vtkGetMacro(UseTimeSets, int);
00350   vtkBooleanMacro(UseTimeSets, int);
00351
00352   int UseFileSets;
00353   vtkSetMacro(UseFileSets, int);
00354   vtkGetMacro(UseFileSets, int);
00355   vtkBooleanMacro(UseFileSets, int);
00356
00357   int NumberOfGeometryParts;
00358
00359   // global list of points for measured geometry
00360   int NumberOfMeasuredPoints;
00361   vtkIdList *MeasuredNodeIds;
00362 private:
00363   vtkEnSightReader(const vtkEnSightReader&);  // Not implemented.
00364   void operator=(const vtkEnSightReader&);  // Not implemented.
00365 };
00366
00367 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkErrorCode.h Source File

Common/vtkErrorCode.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkErrorCode.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkErrorCode_h
00033 #define __vtkErrorCode_h
00034
00035 // The superclass that all commands should be subclasses of
00036 class vtkErrorCode
00037 {
00038 public:
00039   static const char *GetStringFromErrorCode(unsigned long event);
00040   static unsigned long GetErrorCodeFromString(const char *event);
00041
00042 //BTX
00043   // all the currently defined error codes
00044   // developers can use -- vtkErrorCode::UserError + int to
00045   // specify their own errors.
00046   // if this list is adjusted, be sure to adjust vtkErrorCodeErrorStrings
00047   // in vtkErrorCode.cxx to match.
00048   enum ErrorIds {
00049     NoError = 0,
00050     FileNotFoundError,
00051     CannotOpenFileError,
00052     UnrecognizedFileTypeError,
00053     PrematureEndOfFileError,
00054     FileFormatError,
00055     NoFileNameError,
00056     UnknownError,
00057     UserError = 1000
00058   };
00059 //ETX
00060 };
00061
00062 #endif /* __vtkErrorCode_h */
00063
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkExplicitCell.h Source File

Common/vtkExplicitCell.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExplicitCell.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkExplicitCell_h
00037 #define __vtkExplicitCell_h
00038
00039 #include "vtkNonLinearCell.h"
00040
00041 class VTK_COMMON_EXPORT vtkExplicitCell : public vtkNonLinearCell
00042 {
00043 public:
00044   vtkTypeRevisionMacro(vtkExplicitCell,vtkNonLinearCell);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00051   virtual int IsExplicitCell() {return 1;}
00052
00053 protected:
00054   vtkExplicitCell();
00055   ~vtkExplicitCell() {}
00056
00057   vtkIdType CellId; //used to index into other arrays
00058
00059 private:
00060   vtkExplicitCell(const vtkExplicitCell&);  // Not implemented.
00061   void operator=(const vtkExplicitCell&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkExporter.h Source File

Rendering/vtkExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkExporter_h
00052 #define __vtkExporter_h
00053
00054 #include "vtkObject.h"
00055 #include "vtkRenderWindow.h"
00056
00057 class VTK_RENDERING_EXPORT vtkExporter : public vtkObject
00058 {
00059 public:
00060   vtkTypeRevisionMacro(vtkExporter,vtkObject);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00065   virtual void Write();
00066
00068   void Update();
00069
00071
00072   vtkSetObjectMacro(RenderWindow,vtkRenderWindow);
00073   vtkGetObjectMacro(RenderWindow,vtkRenderWindow);
00075
00077
00079   void SetInput(vtkRenderWindow *renWin) {this->SetRenderWindow(renWin);};
00080   vtkRenderWindow *GetInput() {return this->GetRenderWindow();};
00082
00085   void SetStartWrite(void (*f)(void *), void *arg);
00086
00089   void SetEndWrite(void (*f)(void *), void *arg);
00090
00092   void SetStartWriteArgDelete(void (*f)(void *));
00093
00095   void SetEndWriteArgDelete(void (*f)(void *));
00096
00098   unsigned long GetMTime();
00099
00100 protected:
00101   vtkExporter();
00102   ~vtkExporter();
00103
00104   vtkRenderWindow *RenderWindow;
00105   virtual void WriteData() = 0;
00106
00107   void (*StartWrite)(void *);
00108   void (*StartWriteArgDelete)(void *);
00109   void *StartWriteArg;
00110   void (*EndWrite)(void *);
00111   void (*EndWriteArgDelete)(void *);
00112   void *EndWriteArg;
00113 private:
00114   vtkExporter(const vtkExporter&);  // Not implemented.
00115   void operator=(const vtkExporter&);  // Not implemented.
00116 };
00117
00118 #endif
00119
00120
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkExtentTranslator.h Source File

Common/vtkExtentTranslator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtentTranslator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkExtentTranslator_h
00039 #define __vtkExtentTranslator_h
00040
00041 #include "vtkObject.h"
00042
00043
00044 class VTK_COMMON_EXPORT vtkExtentTranslator : public vtkObject
00045 {
00046 public:
00047   static vtkExtentTranslator *New();
00048
00049   vtkTypeRevisionMacro(vtkExtentTranslator,vtkObject);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00055   vtkSetVector6Macro(WholeExtent, int);
00056   vtkGetVector6Macro(WholeExtent, int);
00057   vtkSetVector6Macro(Extent, int);
00058   vtkGetVector6Macro(Extent, int);
00059   vtkSetMacro(Piece,int);
00060   vtkGetMacro(Piece,int);
00061   vtkSetMacro(NumberOfPieces,int);
00062   vtkGetMacro(NumberOfPieces,int);
00063   vtkSetMacro(GhostLevel, int);
00064   vtkGetMacro(GhostLevel, int);
00066
00068
00073   virtual int PieceToExtent();
00074   virtual int PieceToExtentByPoints();
00075   virtual int PieceToExtentThreadSafe(int piece, int numPieces,
00076                                       int ghostLevel, int *wholeExtent,
00077                                       int *resultExtent, int splitMode,
00078                                       int byPoints);
00080
00081
00082
00084
00088   void SetSplitModeToBlock()
00089     {this->SplitMode = vtkExtentTranslator::BLOCK_MODE;}
00090   void SetSplitModeToXSlab()
00091     {this->SplitMode = vtkExtentTranslator::X_SLAB_MODE;}
00092  void SetSplitModeToYSlab()
00093     {this->SplitMode = vtkExtentTranslator::Y_SLAB_MODE;}
00094  void SetSplitModeToZSlab()
00095     {this->SplitMode = vtkExtentTranslator::Z_SLAB_MODE;}
00096   vtkGetMacro(SplitMode,int);
00098
00099 protected:
00100   vtkExtentTranslator();
00101   ~vtkExtentTranslator();
00102
00104
00106   int SplitExtent(int piece, int numPieces, int *extent, int splitMode);
00107   int SplitExtentByPoints(int piece, int numPieces, int *extent,
00108                           int splitMode);
00110
00111   int Piece;
00112   int NumberOfPieces;
00113   int GhostLevel;
00114   int Extent[6];
00115   int WholeExtent[6];
00116   int SplitMode;
00117
00118 //BTX
00119   // Don't change the numbers here - they are used in the code
00120   // to indicate array indices.
00121   enum Modes {
00122     X_SLAB_MODE=0,
00123     Y_SLAB_MODE=1,
00124     Z_SLAB_MODE=2,
00125     BLOCK_MODE= 3
00126   };
00127 //ETX
00128
00129 private:
00130   vtkExtentTranslator(const vtkExtentTranslator&);  // Not implemented.
00131   void operator=(const vtkExtentTranslator&);  // Not implemented.
00132 };
00133
00134 #endif
00135
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractEdges.h Source File

Graphics/vtkExtractEdges.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractEdges.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkExtractEdges_h
00045 #define __vtkExtractEdges_h
00046
00047 #include "vtkDataSetToPolyDataFilter.h"
00048
00049 class VTK_GRAPHICS_EXPORT vtkExtractEdges : public vtkDataSetToPolyDataFilter
00050 {
00051 public:
00052   static vtkExtractEdges *New();
00053   vtkTypeRevisionMacro(vtkExtractEdges,vtkDataSetToPolyDataFilter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00059   void SetLocator(vtkPointLocator *locator);
00060   vtkGetObjectMacro(Locator,vtkPointLocator);
00062
00064   void CreateDefaultLocator();
00065
00067   unsigned long GetMTime();
00068
00069 protected:
00070   vtkExtractEdges();
00071   ~vtkExtractEdges();
00072
00073   // Usual data generation method
00074   void Execute();
00075
00076   vtkPointLocator *Locator;
00077 private:
00078   vtkExtractEdges(const vtkExtractEdges&);  // Not implemented.
00079   void operator=(const vtkExtractEdges&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
Generated on Mon Mar 25 01:07:41 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractGeometry.h Source File

Graphics/vtkExtractGeometry.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractGeometry.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkExtractGeometry_h
00055 #define __vtkExtractGeometry_h
00056
00057 #include "vtkDataSetToUnstructuredGridFilter.h"
00058 #include "vtkImplicitFunction.h"
00059
00060 class VTK_GRAPHICS_EXPORT vtkExtractGeometry : public vtkDataSetToUnstructuredGridFilter
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkExtractGeometry,vtkDataSetToUnstructuredGridFilter);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067   static vtkExtractGeometry *New();
00068
00070   unsigned long GetMTime();
00071
00073
00074   vtkSetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00075   vtkGetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00077
00079
00082   vtkSetMacro(ExtractInside,int);
00083   vtkGetMacro(ExtractInside,int);
00084   vtkBooleanMacro(ExtractInside,int);
00086
00088
00090   vtkSetMacro(ExtractBoundaryCells,int);
00091   vtkGetMacro(ExtractBoundaryCells,int);
00092   vtkBooleanMacro(ExtractBoundaryCells,int);
00094
00095 protected:
00096   vtkExtractGeometry(vtkImplicitFunction *f=NULL);
00097   ~vtkExtractGeometry();
00098
00099   // Usual data generation method
00100   void Execute();
00101
00102   vtkImplicitFunction *ImplicitFunction;
00103   int ExtractInside;
00104   int ExtractBoundaryCells;
00105
00106 private:
00107   vtkExtractGeometry(const vtkExtractGeometry&);  // Not implemented.
00108   void operator=(const vtkExtractGeometry&);  // Not implemented.
00109 };
00110
00111 #endif
00112
00113
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractGrid.h Source File

Graphics/vtkExtractGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkExtractGrid_h
00059 #define __vtkExtractGrid_h
00060
00061 #include "vtkStructuredGridToStructuredGridFilter.h"
00062
00063 class VTK_GRAPHICS_EXPORT vtkExtractGrid : public vtkStructuredGridToStructuredGridFilter
00064 {
00065 public:
00066   static vtkExtractGrid *New();
00067   vtkTypeRevisionMacro(vtkExtractGrid,vtkStructuredGridToStructuredGridFilter);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00071
00074   vtkSetVector6Macro(VOI,int);
00075   vtkGetVectorMacro(VOI,int,6);
00077
00079
00083   vtkSetVector3Macro(SampleRate, int);
00084   vtkGetVectorMacro(SampleRate, int, 3);
00086
00088
00094   vtkSetMacro(IncludeBoundary,int);
00095   vtkGetMacro(IncludeBoundary,int);
00096   vtkBooleanMacro(IncludeBoundary,int);
00098
00099 protected:
00100   vtkExtractGrid();
00101   ~vtkExtractGrid() {};
00102
00103   void Execute();
00104   void ExecuteInformation();
00105   void ComputeInputUpdateExtents(vtkDataObject *out);
00106
00107   int VOI[6];
00108   int SampleRate[3];
00109   int IncludeBoundary;
00110
00111 private:
00112   vtkExtractGrid(const vtkExtractGrid&);  // Not implemented.
00113   void operator=(const vtkExtractGrid&);  // Not implemented.
00114 };
00115
00116 #endif
00117
00118
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractPolyDataGeometry.h Source File

Graphics/vtkExtractPolyDataGeometry.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractPolyDataGeometry.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkExtractPolyDataGeometry_h
00051 #define __vtkExtractPolyDataGeometry_h
00052
00053 #include "vtkPolyDataToPolyDataFilter.h"
00054 #include "vtkImplicitFunction.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkExtractPolyDataGeometry : public vtkPolyDataToPolyDataFilter
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkExtractPolyDataGeometry,vtkPolyDataToPolyDataFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063   static vtkExtractPolyDataGeometry *New();
00064
00066   unsigned long GetMTime();
00067
00069
00070   vtkSetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00071   vtkGetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00073
00075
00078   vtkSetMacro(ExtractInside,int);
00079   vtkGetMacro(ExtractInside,int);
00080   vtkBooleanMacro(ExtractInside,int);
00082
00084
00086   vtkSetMacro(ExtractBoundaryCells,int);
00087   vtkGetMacro(ExtractBoundaryCells,int);
00088   vtkBooleanMacro(ExtractBoundaryCells,int);
00090
00091 protected:
00092   vtkExtractPolyDataGeometry(vtkImplicitFunction *f=NULL);
00093   ~vtkExtractPolyDataGeometry();
00094
00095   // Usual data generation method
00096   void Execute();
00097
00098   vtkImplicitFunction *ImplicitFunction;
00099   int ExtractInside;
00100   int ExtractBoundaryCells;
00101 private:
00102   vtkExtractPolyDataGeometry(const vtkExtractPolyDataGeometry&);  // Not implemented.
00103   void operator=(const vtkExtractPolyDataGeometry&);  // Not implemented.
00104 };
00105
00106 #endif
00107
00108
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkExtractPolyDataPiece.h Source File

Parallel/vtkExtractPolyDataPiece.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractPolyDataPiece.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkExtractPolyDataPiece_h
00034 #define __vtkExtractPolyDataPiece_h
00035
00036 #include "vtkPolyDataToPolyDataFilter.h"
00037
00038 class VTK_PARALLEL_EXPORT vtkExtractPolyDataPiece : public vtkPolyDataToPolyDataFilter
00039 {
00040 public:
00041   static vtkExtractPolyDataPiece *New();
00042   vtkTypeRevisionMacro(vtkExtractPolyDataPiece, vtkPolyDataToPolyDataFilter);
00043   void PrintSelf(ostream& os, vtkIndent indent);
00044
00046
00047   vtkSetMacro(CreateGhostCells, int);
00048   vtkGetMacro(CreateGhostCells, int);
00049   vtkBooleanMacro(CreateGhostCells, int);
00051
00052 protected:
00053   vtkExtractPolyDataPiece();
00054   ~vtkExtractPolyDataPiece() {};
00055
00056   // Usual data generation method
00057   void Execute();
00058   void ExecuteInformation();
00059   void ComputeInputUpdateExtents(vtkDataObject *out);
00060
00061   // A method for labeling which piece the cells belong to.
00062   void ComputeCellTags(vtkIntArray *cellTags, vtkIdList *pointOwnership,
00063                        int piece, int numPieces);
00064
00065   void AddGhostLevel(vtkPolyData *input, vtkIntArray *cellTags, int ghostLevel);
00066
00067   int CreateGhostCells;
00068 private:
00069   vtkExtractPolyDataPiece(const vtkExtractPolyDataPiece&);  // Not implemented.
00070   void operator=(const vtkExtractPolyDataPiece&);  // Not implemented.
00071 };
00072
00073 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractTensorComponents.h Source File

Graphics/vtkExtractTensorComponents.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractTensorComponents.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkExtractTensorComponents_h
00058 #define __vtkExtractTensorComponents_h
00059
00060 #include "vtkDataSetToDataSetFilter.h"
00061
00062 #define VTK_EXTRACT_COMPONENT 0
00063 #define VTK_EXTRACT_EFFECTIVE_STRESS 1
00064 #define VTK_EXTRACT_DETERMINANT 2
00065
00066 class VTK_GRAPHICS_EXPORT vtkExtractTensorComponents : public vtkDataSetToDataSetFilter
00067 {
00068 public:
00069   vtkTypeRevisionMacro(vtkExtractTensorComponents,vtkDataSetToDataSetFilter);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00074   static vtkExtractTensorComponents *New();
00075
00077
00078   vtkSetMacro(PassTensorsToOutput,int);
00079   vtkGetMacro(PassTensorsToOutput,int);
00080   vtkBooleanMacro(PassTensorsToOutput,int);
00082
00084
00085   vtkSetMacro(ExtractScalars,int);
00086   vtkGetMacro(ExtractScalars,int);
00087   vtkBooleanMacro(ExtractScalars,int);
00089
00091
00092   vtkSetVector2Macro(ScalarComponents,int);
00093   vtkGetVectorMacro(ScalarComponents,int,2);
00095
00097
00101   vtkSetMacro(ScalarMode,int);
00102   vtkGetMacro(ScalarMode,int);
00103   void ScalarIsComponent() {this->SetScalarMode(VTK_EXTRACT_COMPONENT);};
00104   void ScalarIsEffectiveStress() {
00105     this->SetScalarMode(VTK_EXTRACT_EFFECTIVE_STRESS);};
00106   void ScalarIsDeterminant() {this->SetScalarMode(VTK_EXTRACT_DETERMINANT);};
00108
00110
00111   vtkSetMacro(ExtractVectors,int);
00112   vtkGetMacro(ExtractVectors,int);
00113   vtkBooleanMacro(ExtractVectors,int);
00115
00117
00119   vtkSetVector6Macro(VectorComponents,int);
00120   vtkGetVectorMacro(VectorComponents,int,6);
00122
00123
00125
00126   vtkSetMacro(ExtractNormals,int);
00127   vtkGetMacro(ExtractNormals,int);
00128   vtkBooleanMacro(ExtractNormals,int);
00130
00132
00134   vtkSetMacro(NormalizeNormals,int);
00135   vtkGetMacro(NormalizeNormals,int);
00136   vtkBooleanMacro(NormalizeNormals,int);
00138
00140
00142   vtkSetVector6Macro(NormalComponents,int);
00143   vtkGetVectorMacro(NormalComponents,int,6);
00145
00147
00149   vtkSetMacro(ExtractTCoords,int);
00150   vtkGetMacro(ExtractTCoords,int);
00151   vtkBooleanMacro(ExtractTCoords,int);
00153
00155
00156   vtkSetClampMacro(NumberOfTCoords,int,1,3);
00157   vtkGetMacro(NumberOfTCoords,int);
00159
00161
00164   vtkSetVector6Macro(TCoordComponents,int);
00165   vtkGetVectorMacro(TCoordComponents,int,6);
00167
00168 protected:
00169   vtkExtractTensorComponents();
00170   ~vtkExtractTensorComponents() {};
00171
00172   void Execute();
00173
00174   int PassTensorsToOutput;
00175
00176   int ExtractScalars;
00177   int ExtractVectors;
00178   int ExtractNormals;
00179   int ExtractTCoords;
00180
00181   int ScalarMode;
00182   int ScalarComponents[2];
00183
00184   int VectorComponents[6];
00185
00186   int NormalizeNormals;
00187   int NormalComponents[6];
00188
00189   int NumberOfTCoords;
00190   int TCoordComponents[6];
00191
00192 private:
00193   vtkExtractTensorComponents(const vtkExtractTensorComponents&);  // Not implemented.
00194   void operator=(const vtkExtractTensorComponents&);  // Not implemented.
00195 };
00196
00197 #endif
00198
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractUnstructuredGrid.h Source File

Graphics/vtkExtractUnstructuredGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractUnstructuredGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkExtractUnstructuredGrid_h
00056 #define __vtkExtractUnstructuredGrid_h
00057
00058 #include "vtkUnstructuredGridToUnstructuredGridFilter.h"
00059
00060 class VTK_GRAPHICS_EXPORT vtkExtractUnstructuredGrid : public vtkUnstructuredGridToUnstructuredGridFilter
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkExtractUnstructuredGrid,vtkUnstructuredGridToUnstructuredGridFilter);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067   static vtkExtractUnstructuredGrid *New();
00068
00070
00071   vtkSetMacro(PointClipping,int);
00072   vtkGetMacro(PointClipping,int);
00073   vtkBooleanMacro(PointClipping,int);
00075
00077
00078   vtkSetMacro(CellClipping,int);
00079   vtkGetMacro(CellClipping,int);
00080   vtkBooleanMacro(CellClipping,int);
00082
00084
00085   vtkSetMacro(ExtentClipping,int);
00086   vtkGetMacro(ExtentClipping,int);
00087   vtkBooleanMacro(ExtentClipping,int);
00089
00091
00092   vtkSetClampMacro(PointMinimum,vtkIdType,0,VTK_LARGE_ID);
00093   vtkGetMacro(PointMinimum,vtkIdType);
00095
00097
00098   vtkSetClampMacro(PointMaximum,vtkIdType,0,VTK_LARGE_ID);
00099   vtkGetMacro(PointMaximum,vtkIdType);
00101
00103
00104   vtkSetClampMacro(CellMinimum,vtkIdType,0,VTK_LARGE_ID);
00105   vtkGetMacro(CellMinimum,vtkIdType);
00107
00109
00110   vtkSetClampMacro(CellMaximum,vtkIdType,0,VTK_LARGE_ID);
00111   vtkGetMacro(CellMaximum,vtkIdType);
00113
00115
00117   void SetExtent(float xMin, float xMax, float yMin, float yMax,
00118                  float zMin, float zMax);
00120
00122
00124   void SetExtent(float extent[6]);
00125   float *GetExtent() { return this->Extent;};
00127
00129
00132   vtkSetMacro(Merging,int);
00133   vtkGetMacro(Merging,int);
00134   vtkBooleanMacro(Merging,int);
00136
00138
00140   void SetLocator(vtkPointLocator *locator);
00141   vtkGetObjectMacro(Locator,vtkPointLocator);
00143
00145   void CreateDefaultLocator();
00146
00148   unsigned long GetMTime();
00149
00150 protected:
00151   vtkExtractUnstructuredGrid();
00152   ~vtkExtractUnstructuredGrid() {};
00153
00154   void Execute();
00155
00156   vtkIdType PointMinimum;
00157   vtkIdType PointMaximum;
00158   vtkIdType CellMinimum;
00159   vtkIdType CellMaximum;
00160   float Extent[6];
00161   int PointClipping;
00162   int CellClipping;
00163   int ExtentClipping;
00164
00165   int Merging;
00166   vtkPointLocator *Locator;
00167 private:
00168   vtkExtractUnstructuredGrid(const vtkExtractUnstructuredGrid&);  // Not implemented.
00169   void operator=(const vtkExtractUnstructuredGrid&);  // Not implemented.
00170 };
00171
00172 #endif
00173
00174
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkExtractUnstructuredGridPiece.h Source File

Parallel/vtkExtractUnstructuredGridPiece.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractUnstructuredGridPiece.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkExtractUnstructuredGridPiece_h
00035 #define __vtkExtractUnstructuredGridPiece_h
00036
00037 #include "vtkUnstructuredGridToUnstructuredGridFilter.h"
00038
00039 class VTK_PARALLEL_EXPORT vtkExtractUnstructuredGridPiece : public vtkUnstructuredGridToUnstructuredGridFilter
00040 {
00041 public:
00042   static vtkExtractUnstructuredGridPiece *New();
00043   vtkTypeRevisionMacro(vtkExtractUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00047
00048   vtkSetMacro(CreateGhostCells, int);
00049   vtkGetMacro(CreateGhostCells, int);
00050   vtkBooleanMacro(CreateGhostCells, int);
00052
00053 protected:
00054   vtkExtractUnstructuredGridPiece();
00055   ~vtkExtractUnstructuredGridPiece() {};
00056
00057   // Usual data generation method
00058   void Execute();
00059   void ExecuteInformation();
00060   void ComputeInputUpdateExtents(vtkDataObject *out);
00061
00062   // A method for labeling which piece the cells belong to.
00063   void ComputeCellTags(vtkIntArray *cellTags, vtkIdList *pointOwnership,
00064                        int piece, int numPieces);
00065
00066   void AddGhostLevel(vtkUnstructuredGrid *input, vtkIntArray *cellTags, int ghostLevel);
00067
00068   int CreateGhostCells;
00069 private:
00070   vtkExtractUnstructuredGridPiece(const vtkExtractUnstructuredGridPiece&);  // Not implemented.
00071   void operator=(const vtkExtractUnstructuredGridPiece&);  // Not implemented.
00072 };
00073
00074 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkExtractVectorComponents.h Source File

Graphics/vtkExtractVectorComponents.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractVectorComponents.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkExtractVectorComponents_h
00050 #define __vtkExtractVectorComponents_h
00051
00052 #include "vtkSource.h"
00053 #include "vtkDataSet.h"
00054
00055 class VTK_GRAPHICS_EXPORT vtkExtractVectorComponents : public vtkSource
00056 {
00057 public:
00058   static vtkExtractVectorComponents *New();
00059   vtkTypeRevisionMacro(vtkExtractVectorComponents,vtkSource);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063   virtual void SetInput(vtkDataSet *input);
00064
00066   vtkDataSet *GetInput();
00067
00072   vtkDataSet *GetVxComponent();
00073
00079   vtkDataSet *GetVyComponent();
00080
00086   vtkDataSet *GetVzComponent();
00087
00092   vtkDataSet *GetOutput(int i=0); //default extracts vector component.
00093
00095
00097   vtkSetMacro(ExtractToFieldData, int);
00098   vtkGetMacro(ExtractToFieldData, int);
00099   vtkBooleanMacro(ExtractToFieldData, int);
00101
00102 protected:
00103   vtkExtractVectorComponents();
00104   ~vtkExtractVectorComponents();
00105
00106   void Execute();
00107   int ExtractToFieldData;
00108 private:
00109   vtkExtractVectorComponents(const vtkExtractVectorComponents&);  // Not implemented.
00110   void operator=(const vtkExtractVectorComponents&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkExtractVOI.h Source File

Imaging/vtkExtractVOI.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkExtractVOI.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkExtractVOI_h
00058 #define __vtkExtractVOI_h
00059
00060 #include "vtkStructuredPointsToStructuredPointsFilter.h"
00061
00062 class VTK_IMAGING_EXPORT vtkExtractVOI : public vtkStructuredPointsToStructuredPointsFilter
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkExtractVOI,vtkStructuredPointsToStructuredPointsFilter);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   static vtkExtractVOI *New();
00070
00072
00075   vtkSetVector6Macro(VOI,int);
00076   vtkGetVectorMacro(VOI,int,6);
00078
00080
00084   vtkSetVector3Macro(SampleRate, int);
00085   vtkGetVectorMacro(SampleRate, int, 3);
00087
00088 protected:
00089   vtkExtractVOI();
00090   ~vtkExtractVOI() {};
00091
00092   void Execute();
00093   void ExecuteInformation();
00094
00095   int VOI[6];
00096   int SampleRate[3];
00097 private:
00098   vtkExtractVOI(const vtkExtractVOI&);  // Not implemented.
00099   void operator=(const vtkExtractVOI&);  // Not implemented.
00100 };
00101
00102 #endif
00103
00104
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkFeatureEdges.h Source File

Graphics/vtkFeatureEdges.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFeatureEdges.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkFeatureEdges_h
00056 #define __vtkFeatureEdges_h
00057
00058 #include "vtkPolyDataToPolyDataFilter.h"
00059
00060 class VTK_GRAPHICS_EXPORT vtkFeatureEdges : public vtkPolyDataToPolyDataFilter
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkFeatureEdges,vtkPolyDataToPolyDataFilter);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00068   static vtkFeatureEdges *New();
00069
00071
00072   vtkSetMacro(BoundaryEdges,int);
00073   vtkGetMacro(BoundaryEdges,int);
00074   vtkBooleanMacro(BoundaryEdges,int);
00076
00078
00079   vtkSetMacro(FeatureEdges,int);
00080   vtkGetMacro(FeatureEdges,int);
00081   vtkBooleanMacro(FeatureEdges,int);
00083
00085
00086   vtkSetClampMacro(FeatureAngle,float,0.0,180.0);
00087   vtkGetMacro(FeatureAngle,float);
00089
00091
00092   vtkSetMacro(NonManifoldEdges,int);
00093   vtkGetMacro(NonManifoldEdges,int);
00094   vtkBooleanMacro(NonManifoldEdges,int);
00096
00098
00099   vtkSetMacro(ManifoldEdges,int);
00100   vtkGetMacro(ManifoldEdges,int);
00101   vtkBooleanMacro(ManifoldEdges,int);
00103
00105
00106   vtkSetMacro(Coloring,int);
00107   vtkGetMacro(Coloring,int);
00108   vtkBooleanMacro(Coloring,int);
00110
00112
00114   void SetLocator(vtkPointLocator *locator);
00115   vtkGetObjectMacro(Locator,vtkPointLocator);
00117
00119   void CreateDefaultLocator();
00120
00122   unsigned long GetMTime();
00123
00124 protected:
00125   vtkFeatureEdges();
00126   ~vtkFeatureEdges();
00127
00128   // Usual data generation method
00129   void Execute();
00130   void ComputeInputUpdateExtents(vtkDataObject *output);
00131
00132   float FeatureAngle;
00133   int BoundaryEdges;
00134   int FeatureEdges;
00135   int NonManifoldEdges;
00136   int ManifoldEdges;
00137   int Coloring;
00138   vtkPointLocator *Locator;
00139 private:
00140   vtkFeatureEdges(const vtkFeatureEdges&);  // Not implemented.
00141   void operator=(const vtkFeatureEdges&);  // Not implemented.
00142 };
00143
00144 #endif
00145
00146
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkFieldData.h Source File

Common/vtkFieldData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFieldData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkFieldData_h
00058 #define __vtkFieldData_h
00059
00060 #include "vtkDataArray.h"
00061 #include "vtkIdList.h"
00062
00063 class VTK_COMMON_EXPORT vtkFieldData : public vtkObject
00064 {
00065 public:
00066   static vtkFieldData *New();
00067
00068   vtkTypeRevisionMacro(vtkFieldData,vtkObject);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00073   virtual void Initialize();
00074
00076   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00077
00080   vtkFieldData *MakeObject();
00081
00088   void AllocateArrays(int num);
00089
00090 #ifndef VTK_REMOVE_LEGACY_CODE
00091   void SetNumberOfArrays(int num)
00092     {
00093       vtkWarningMacro("This method will be deprecated. Please use "
00094                       "AllocateArrays() instead.");
00095       this->AllocateArrays(num);
00096     }
00097 #endif
00098
00102   int GetNumberOfArrays();
00103
00106   int AddArray(vtkDataArray *array);
00107
00109
00110   virtual void RemoveArray(const char *name)
00111     {
00112       int i;
00113       this->GetArray(name, i);
00114       this->RemoveArray(i);
00115     }
00117
00120   vtkDataArray *GetArray(int i);
00121
00124   vtkDataArray *GetArray(const char *arrayName, int &index);
00125
00126   // Return the array with the name given. Returns NULL is array not found.
00127   vtkDataArray *GetArray(const char *arrayName);
00128
00130
00132   const char* GetArrayName(int i)
00133     {
00134       vtkDataArray* da;
00135       if ((da=this->GetArray(i)))
00136         {
00137         return da->GetName();
00138         }
00139       else
00140         {
00141         return 0;
00142         }
00143     }
00145
00148   virtual void PassData(vtkFieldData* fd);
00149
00151
00156   void CopyFieldOn(const char* name) { this->CopyFieldOnOff(name, 1); }
00157   void CopyFieldOff(const char* name) { this->CopyFieldOnOff(name, 0); }
00159
00165   virtual void CopyAllOn();
00166
00172   virtual void CopyAllOff();
00173
00175   virtual void DeepCopy(vtkFieldData *da);
00176
00178   virtual void ShallowCopy(vtkFieldData *da);
00179
00182   void Squeeze();
00183
00186   void Reset();
00187
00192   virtual unsigned long GetActualMemorySize();
00193
00195   unsigned long int GetMTime();
00196
00203   void GetField(vtkIdList *ptId, vtkFieldData *f);
00204
00213   int GetArrayContainingComponent(int i, int& arrayComp);
00214
00221   int GetNumberOfComponents();
00222
00230   vtkIdType GetNumberOfTuples();
00231
00237   void SetNumberOfTuples(const vtkIdType number);
00238
00245   float *GetTuple(const vtkIdType i);
00246
00253   void GetTuple(const vtkIdType i, float * tuple);
00254
00261   void SetTuple(const vtkIdType i, const float * tuple);
00262
00269   void InsertTuple(const vtkIdType i, const float * tuple);
00270
00277   vtkIdType InsertNextTuple(const float * tuple);
00278
00284   float GetComponent(const vtkIdType i, const int j);
00285
00293   void SetComponent(const vtkIdType i, const int j, const float c);
00294
00302   void InsertComponent(const vtkIdType i, const int j, const float c);
00303
00304 protected:
00305
00306   vtkFieldData();
00307   ~vtkFieldData();
00308
00309   int NumberOfArrays;
00310   int NumberOfActiveArrays;
00311   vtkDataArray **Data;
00312
00313   int TupleSize; //used for type conversion
00314   float *Tuple;
00315
00317   void SetArray(int i, vtkDataArray *array);
00318
00319   virtual void RemoveArray(int index);
00320
00322   virtual void InitializeFields();
00323
00324 //BTX
00325
00326   struct CopyFieldFlag
00327   {
00328     char* ArrayName;
00329     int IsCopied;
00330   };
00331
00332   CopyFieldFlag* CopyFieldFlags; //the names of fields not to be copied
00333   int NumberOfFieldFlags; //the number of fields not to be copied
00334   void CopyFieldOnOff(const char* name, int onOff);
00335   void ClearFieldFlags();
00336   int FindFlag(const char* field);
00337   int GetFlag(const char* field);
00338   void CopyFlags(const vtkFieldData* source);
00339   int DoCopyAllOn;
00340   int DoCopyAllOff;
00341
00342
00343 private:
00344   vtkFieldData(const vtkFieldData&);  // Not implemented.
00345   void operator=(const vtkFieldData&);  // Not implemented.
00346
00347 public:
00348
00349   class VTK_COMMON_EXPORT BasicIterator
00350   {
00351   public:
00352     BasicIterator();
00353     BasicIterator(const BasicIterator& source);
00354     BasicIterator(const int* list, unsigned int listSize);
00355     BasicIterator& operator=(const BasicIterator& source);
00356     virtual ~BasicIterator();
00357
00358     int GetListSize() const
00359       {
00360         return this->ListSize;
00361       }
00362     int GetCurrentIndex()
00363       {
00364         return this->List[this->Position];
00365       }
00366     int BeginIndex()
00367       {
00368         this->Position = -1;
00369         return this->NextIndex();
00370       }
00371     int End() const
00372       {
00373         return (this->Position >= this->ListSize);
00374       }
00375     int NextIndex()
00376       {
00377         this->Position++;
00378         return (this->End() ? -1 : this->List[this->Position]);
00379       }
00380
00381   protected:
00382
00383     int* List;
00384     int ListSize;
00385     int Position;
00386   };
00387
00388   class VTK_COMMON_EXPORT Iterator : public BasicIterator
00389   {
00390   public:
00391
00392     Iterator(const Iterator& source);
00393     Iterator& operator=(const Iterator& source);
00394     virtual ~Iterator();
00395     Iterator(vtkFieldData* dsa, const int* list=0,
00396              unsigned int listSize=0);
00397
00398     vtkDataArray* Begin()
00399       {
00400         this->Position = -1;
00401         return this->Next();
00402       }
00403
00404     vtkDataArray* Next()
00405       {
00406         this->Position++;
00407         return (this->End() ? 0 :
00408                 Fields->GetArray(this->List[this->Position]));
00409       }
00410
00411     void DetachFieldData();
00412
00413   protected:
00414     vtkFieldData* Fields;
00415     int Detached;
00416   };
00417
00418
00419 //ETX
00420
00421 };
00422
00423
00424 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkFieldDataToAttributeDataFilter.h Source File

Graphics/vtkFieldDataToAttributeDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFieldDataToAttributeDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00070 #ifndef __vtkFieldDataToAttributeDataFilter_h
00071 #define __vtkFieldDataToAttributeDataFilter_h
00072
00073 #include "vtkDataSetToDataSetFilter.h"
00074
00075 #define VTK_DATA_OBJECT_FIELD 0
00076 #define VTK_POINT_DATA_FIELD 1
00077 #define VTK_CELL_DATA_FIELD 2
00078
00079 #define VTK_CELL_DATA 0
00080 #define VTK_POINT_DATA 1
00081
00082 class VTK_GRAPHICS_EXPORT vtkFieldDataToAttributeDataFilter : public vtkDataSetToDataSetFilter
00083 {
00084 public:
00085   void PrintSelf(ostream& os, vtkIndent indent);
00086   vtkTypeRevisionMacro(vtkFieldDataToAttributeDataFilter,vtkDataSetToDataSetFilter);
00087
00090   static vtkFieldDataToAttributeDataFilter *New();
00091
00093
00097   vtkSetMacro(InputField,int);
00098   vtkGetMacro(InputField,int);
00099   void SetInputFieldToDataObjectField()
00100     {this->SetInputField(VTK_DATA_OBJECT_FIELD);};
00101   void SetInputFieldToPointDataField()
00102     {this->SetInputField(VTK_POINT_DATA_FIELD);};
00103   void SetInputFieldToCellDataField()
00104     {this->SetInputField(VTK_CELL_DATA_FIELD);};
00106
00108
00110   vtkSetMacro(OutputAttributeData,int);
00111   vtkGetMacro(OutputAttributeData,int);
00112   void SetOutputAttributeDataToCellData()
00113     {this->SetOutputAttributeData(VTK_CELL_DATA);};
00114   void SetOutputAttributeDataToPointData()
00115     {this->SetOutputAttributeData(VTK_POINT_DATA);};
00117
00119
00124   void SetScalarComponent(int comp, const char *arrayName, int arrayComp,
00125                           int min, int max, int normalize);
00126   void SetScalarComponent(int comp, const char *arrayName, int arrayComp)
00127     {this->SetScalarComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00128   const char *GetScalarComponentArrayName(int comp);
00129   int GetScalarComponentArrayComponent(int comp);
00130   int GetScalarComponentMinRange(int comp);
00131   int GetScalarComponentMaxRange(int comp);
00132   int GetScalarComponentNormalizeFlag(int comp);
00134
00136
00141   void SetVectorComponent(int comp, const char *arrayName, int arrayComp,
00142                           int min, int max, int normalize);
00143   void SetVectorComponent(int comp, const char *arrayName, int arrayComp)
00144     {this->SetVectorComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00145   const char *GetVectorComponentArrayName(int comp);
00146   int GetVectorComponentArrayComponent(int comp);
00147   int GetVectorComponentMinRange(int comp);
00148   int GetVectorComponentMaxRange(int comp);
00149   int GetVectorComponentNormalizeFlag(int comp);
00151
00153
00158   void SetNormalComponent(int comp, const char *arrayName, int arrayComp,
00159                           int min, int max, int normalize);
00160   void SetNormalComponent(int comp, const char *arrayName, int arrayComp)
00161     {this->SetNormalComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00162   const char *GetNormalComponentArrayName(int comp);
00163   int GetNormalComponentArrayComponent(int comp);
00164   int GetNormalComponentMinRange(int comp);
00165   int GetNormalComponentMaxRange(int comp);
00166   int GetNormalComponentNormalizeFlag(int comp);
00168
00170
00175   void SetTensorComponent(int comp, const char *arrayName, int arrayComp,
00176                           int min, int max, int normalize);
00177   void SetTensorComponent(int comp, const char *arrayName, int arrayComp)
00178     {this->SetTensorComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00179   const char *GetTensorComponentArrayName(int comp);
00180   int GetTensorComponentArrayComponent(int comp);
00181   int GetTensorComponentMinRange(int comp);
00182   int GetTensorComponentMaxRange(int comp);
00183   int GetTensorComponentNormalizeFlag(int comp);
00185
00187
00192   void SetTCoordComponent(int comp, const char *arrayName, int arrayComp,
00193                           int min, int max, int normalize);
00194   void SetTCoordComponent(int comp, const char *arrayName, int arrayComp)
00195     {this->SetTCoordComponent(comp, arrayName, arrayComp, -1, -1, this->DefaultNormalize);};
00196   const char *GetTCoordComponentArrayName(int comp);
00197   int GetTCoordComponentArrayComponent(int comp);
00198   int GetTCoordComponentMinRange(int comp);
00199   int GetTCoordComponentMaxRange(int comp);
00200   int GetTCoordComponentNormalizeFlag(int comp);
00202
00204
00206   vtkSetMacro(DefaultNormalize,int);
00207   vtkGetMacro(DefaultNormalize,int);
00208   vtkBooleanMacro(DefaultNormalize,int);
00210
00211   // Helper functions, made public to support other classes
00212
00216   static int GetComponentsType(int numComp, vtkDataArray **arrays);
00217
00219
00223   static int ConstructArray(vtkDataArray *da, int comp, vtkDataArray *frray,
00224                             int fieldComp, vtkIdType min, vtkIdType max,
00225                             int normalize);
00227
00230   static vtkDataArray *GetFieldArray(vtkFieldData *fd, char *name, int comp);
00231
00233   static void SetArrayName(vtkObject *self, char* &name, const char *newName);
00234
00235 //BTX
00238   static int UpdateComponentRange(vtkDataArray *da, vtkIdType compRange[2]);
00239 //ETX
00240
00242   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00243
00244 protected:
00245   vtkFieldDataToAttributeDataFilter();
00246   ~vtkFieldDataToAttributeDataFilter();
00247
00248   void Execute(); //generate output data
00249
00250   int InputField;
00251   int OutputAttributeData;
00252
00253   int NumberOfScalarComponents; //the number of components to fill-in
00254   char *ScalarArrays[4]; //the name of the arrays used to construct the scalar
00255   int ScalarArrayComponents[4]; //the components of the arrays used to construct
00256   vtkIdType ScalarComponentRange[4][2]; //the range of the components to use
00257   int ScalarNormalize[4]; //flags control normalization
00258
00259   char *VectorArrays[3]; //the name of the arrays used to construct the vectors
00260   int VectorArrayComponents[3]; //the components of the arrays used to construct
00261   vtkIdType VectorComponentRange[3][2]; //the range of the components to use
00262   int VectorNormalize[3]; //flags control normalization
00263
00264   char *GhostLevelArray; //the name of the array used to construct the ghost levels
00265   int GhostLevelArrayComponent; //the component of the array used to construct
00266   vtkIdType GhostLevelComponentRange[2]; //the range of the components to use
00267   int GhostLevelNormalize; //flags control normalization
00268
00269   char *NormalArrays[3]; //the name of the arrays used to construct the normals
00270   int NormalArrayComponents[3]; //the components of the arrays used to construct
00271   vtkIdType NormalComponentRange[3][2]; //the range of the components to use
00272   int NormalNormalize[3]; //flags control normalization
00273
00274   char *TensorArrays[9]; //the name of the arrays used to construct the tensors
00275   int TensorArrayComponents[9]; //the components of the arrays used to construct
00276   vtkIdType TensorComponentRange[9][2]; //the range of the components to use
00277   int TensorNormalize[9]; //flags control normalization
00278
00279   int NumberOfTCoordComponents; //the number of components to fill-in
00280   char *TCoordArrays[3]; //the name of the arrays used to construct the tcoords
00281   int TCoordArrayComponents[3]; //the components of the arrays used to construct
00282   vtkIdType TCoordComponentRange[3][2]; //the range of the components to use
00283   int TCoordNormalize[3]; //flags control normalization
00284
00285   int DefaultNormalize;
00286
00287   void ConstructScalars(int num, vtkFieldData *fd, vtkDataSetAttributes *attr,
00288                         vtkIdType componentRange[4][2], char *arrays[4],
00289                         int arrayComponents[4], int normalize[4], int numComp);
00290   void ConstructVectors(int num, vtkFieldData *fd, vtkDataSetAttributes *attr,
00291                         vtkIdType componentRange[3][2], char *arrays[3],
00292                         int arrayComponents[3], int normalize[3]);
00293   void ConstructGhostLevels(int num, vtkFieldData *fd,
00294                             vtkDataSetAttributes *attr,
00295                             vtkIdType componentRange[2],
00296                             char *array, int arrayComponent, int normalize);
00297   void ConstructNormals(int num, vtkFieldData *fd, vtkDataSetAttributes *attr,
00298                         vtkIdType componentRange[3][2], char *arrays[3],
00299                         int arrayComponents[3], int normalize[3]);
00300   void ConstructTCoords(int num, vtkFieldData *fd, vtkDataSetAttributes *attr,
00301                         vtkIdType componentRange[3][2], char *arrays[3],
00302                         int arrayComponents[3], int normalize[3], int numComp);
00303   void ConstructTensors(int num, vtkFieldData *fd, vtkDataSetAttributes *attr,
00304                         vtkIdType componentRange[9][2], char *arrays[9],
00305                         int arrayComponents[9], int normalize[9]);
00306   void ConstructFieldData(int num, vtkDataSetAttributes *attr);
00307
00308 private:
00309   vtkFieldDataToAttributeDataFilter(const vtkFieldDataToAttributeDataFilter&);  // Not implemented.
00310   void operator=(const vtkFieldDataToAttributeDataFilter&);  // Not implemented.
00311 };
00312
00313 #endif
00314
00315
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkFileOutputWindow.h Source File

Common/vtkFileOutputWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFileOutputWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkFileOutputWindow_h
00038 #define __vtkFileOutputWindow_h
00039
00040 #include "vtkOutputWindow.h"
00041
00042
00043 class VTK_COMMON_EXPORT vtkFileOutputWindow : public vtkOutputWindow
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkFileOutputWindow, vtkOutputWindow);
00047
00048   static vtkFileOutputWindow* New();
00049
00050   virtual void PrintSelf(ostream& os, vtkIndent indent);
00051
00053   virtual void DisplayText(const char*);
00054
00056   vtkSetStringMacro(FileName);
00057   vtkGetStringMacro(FileName);
00059
00061
00062   vtkSetMacro(Flush, int);
00063   vtkGetMacro(Flush, int);
00064   vtkBooleanMacro(Flush, int);
00066
00068
00070   vtkSetMacro(Append, int);
00071   vtkGetMacro(Append, int);
00072   vtkBooleanMacro(Append, int);
00074
00075  protected:
00076   vtkFileOutputWindow();
00077   virtual ~vtkFileOutputWindow();
00078   void Initialize();
00079   char* FileName;
00080   ofstream* OStream;
00081   int Flush;
00082   int Append;
00083 private:
00084   vtkFileOutputWindow(const vtkFileOutputWindow&);  // Not implemented.
00085   void operator=(const vtkFileOutputWindow&);  // Not implemented.
00086 };
00087
00088
00089
00090 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkFiniteDifferenceGradientEstimator.h Source File

Rendering/vtkFiniteDifferenceGradientEstimator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFiniteDifferenceGradientEstimator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00053 #ifndef __vtkFiniteDifferenceGradientEstimator_h
00054 #define __vtkFiniteDifferenceGradientEstimator_h
00055
00056 #include "vtkEncodedGradientEstimator.h"
00057
00058 class VTK_RENDERING_EXPORT vtkFiniteDifferenceGradientEstimator : public vtkEncodedGradientEstimator
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkFiniteDifferenceGradientEstimator,vtkEncodedGradientEstimator);
00062   void PrintSelf( ostream& os, vtkIndent index );
00063
00066   static vtkFiniteDifferenceGradientEstimator *New();
00067
00069
00071   vtkSetMacro( SampleSpacingInVoxels, int );
00072   vtkGetMacro( SampleSpacingInVoxels, int );
00074
00075   // The sample spacing between samples taken for the normal estimation
00076   int SampleSpacingInVoxels;
00077
00078 protected:
00079   vtkFiniteDifferenceGradientEstimator();
00080   ~vtkFiniteDifferenceGradientEstimator();
00081
00082
00084   void UpdateNormals( void );
00085 private:
00086   vtkFiniteDifferenceGradientEstimator(const vtkFiniteDifferenceGradientEstimator&);  // Not implemented.
00087   void operator=(const vtkFiniteDifferenceGradientEstimator&);  // Not implemented.
00088 };
00089
00090
00091 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkFloatArray.h Source File

Common/vtkFloatArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFloatArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkFloatArray_h
00044 #define __vtkFloatArray_h
00045
00046 #include "vtkDataArray.h"
00047
00048 class VTK_COMMON_EXPORT vtkFloatArray : public vtkDataArray
00049 {
00050 public:
00051   static vtkFloatArray *New();
00052   vtkTypeRevisionMacro(vtkFloatArray,vtkDataArray);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00058
00060   void Initialize();
00061
00063   vtkDataArray *MakeObject();
00064
00066
00067   int GetDataType()
00068     {return VTK_FLOAT;}
00070
00072   int GetDataTypeSize() { return sizeof(float); }
00073
00075   void SetNumberOfTuples(const vtkIdType number);
00076
00078   float *GetTuple(const vtkIdType i);
00079
00081
00082   void GetTuple(const vtkIdType i, float * tuple);
00083   void GetTuple(const vtkIdType i, double * tuple);
00085
00087
00088   void SetTuple(const vtkIdType i, const float * tuple);
00089   void SetTuple(const vtkIdType i, const double * tuple);
00091
00093
00095   void InsertTuple(const vtkIdType i, const float * tuple);
00096   void InsertTuple(const vtkIdType i, const double * tuple);
00098
00100
00102   vtkIdType InsertNextTuple(const float * tuple);
00103   vtkIdType InsertNextTuple(const double * tuple);
00105
00107   void Squeeze() {this->ResizeAndExtend(this->MaxId+1);};
00108
00110   virtual void Resize(vtkIdType numTuples);
00111
00115   float GetComponent(const vtkIdType i, const int j);
00116
00121   void SetComponent(const vtkIdType i, const int j, const float c);
00122
00126   void InsertComponent(const vtkIdType i, const int j, const float c);
00127
00129
00130   float GetValue(const vtkIdType id)
00131     {return this->Array[id];}
00133
00135
00137   void SetValue(const vtkIdType id, const float value)
00138     {this->Array[id] = value;}
00140
00144   void SetNumberOfValues(const vtkIdType number);
00145
00147   void InsertValue(const vtkIdType id, const float f);
00148
00151   vtkIdType InsertNextValue(const float f);
00152
00156   float *WritePointer(const vtkIdType id, const vtkIdType number);
00157
00159
00161   void *GetVoidPointer(const vtkIdType id)
00162     {return (void *)this->GetPointer(id);}
00163   float *GetPointer(const vtkIdType id)
00164     {return this->Array + id;}
00166
00168   void DeepCopy(vtkDataArray *fa);
00169
00171
00177   void SetArray(float* array, vtkIdType size, int save);
00178   void SetVoidArray(void *array, vtkIdType size, int save)
00179     {this->SetArray((float*)array, size, save);}
00181
00182
00183 protected:
00184   vtkFloatArray(vtkIdType numComp=1);
00185   ~vtkFloatArray();
00186
00187   float *Array;  // pointer to data
00188   float *ResizeAndExtend(const vtkIdType sz);  // function to reallocate data
00189
00190   int SaveUserArray;
00191 private:
00192   vtkFloatArray(const vtkFloatArray&);  // Not implemented.
00193   void operator=(const vtkFloatArray&);  // Not implemented.
00194 };
00195
00196 inline void vtkFloatArray::SetNumberOfValues(const vtkIdType number)
00197 {
00198   this->Allocate(number);
00199   this->MaxId = number - 1;
00200 }
00201
00202
00203 inline float *vtkFloatArray::WritePointer(const vtkIdType id,
00204                                           const vtkIdType number)
00205 {
00206   vtkIdType newSize=id+number;
00207   if ( newSize > this->Size )
00208     {
00209     this->ResizeAndExtend(newSize);
00210     }
00211   if ( (--newSize) > this->MaxId )
00212     {
00213     this->MaxId = newSize;
00214     }
00215   return this->Array + id;
00216 }
00217
00218 inline void vtkFloatArray::InsertValue(const vtkIdType id, const float f)
00219 {
00220   if ( id >= this->Size )
00221     {
00222     this->ResizeAndExtend(id+1);
00223     }
00224   this->Array[id] = f;
00225   if ( id > this->MaxId )
00226     {
00227     this->MaxId = id;
00228     }
00229 }
00230
00231 inline vtkIdType vtkFloatArray::InsertNextValue(const float f)
00232 {
00233   this->InsertValue (++this->MaxId,f);
00234   return this->MaxId;
00235 }
00236
00237 #endif
Generated on Mon Mar 25 01:07:34 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkFollower.h Source File

Rendering/vtkFollower.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFollower.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkFollower_h
00049 #define __vtkFollower_h
00050
00051 #include "vtkActor.h"
00052 #include "vtkCamera.h"
00053
00054 class VTK_RENDERING_EXPORT vtkFollower : public vtkActor
00055 {
00056  public:
00057   vtkTypeRevisionMacro(vtkFollower,vtkActor);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   static vtkFollower *New();
00062
00064
00066   vtkSetObjectMacro(Camera,vtkCamera);
00067   vtkGetObjectMacro(Camera,vtkCamera);
00069
00071
00074   virtual int RenderOpaqueGeometry(vtkViewport *viewport);
00075   virtual int RenderTranslucentGeometry(vtkViewport *viewport);
00076   virtual void Render(vtkRenderer *ren);
00078
00080
00081   virtual void GetMatrix(vtkMatrix4x4 *m);
00082   virtual void GetMatrix(double m[16])
00083     {this->GetMatrix(this->Matrix); vtkMatrix4x4::DeepCopy(m,this->Matrix);};
00084   virtual vtkMatrix4x4* GetMatrix()
00085     {return this->vtkActor::GetMatrix();}
00087
00089   void ShallowCopy(vtkProp *prop);
00090
00091 protected:
00092   vtkFollower();
00093   ~vtkFollower();
00094
00095   vtkCamera *Camera;
00096   vtkActor  *Device;
00097 private:
00098   // hide the two parameter Render() method from the user and the compiler.
00099   virtual void Render(vtkRenderer *, vtkMapper *) {};
00100 private:
00101   vtkFollower(const vtkFollower&);  // Not implemented.
00102   void operator=(const vtkFollower&);  // Not implemented.
00103 };
00104
00105 #endif
00106
00107
00108
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkFrustumCoverageCuller.h Source File

Rendering/vtkFrustumCoverageCuller.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFrustumCoverageCuller.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkFrustumCoverageCuller_h
00047 #define __vtkFrustumCoverageCuller_h
00048
00049 #include "vtkCuller.h"
00050
00051 #define VTK_CULLER_SORT_NONE          0
00052 #define VTK_CULLER_SORT_FRONT_TO_BACK 1
00053 #define VTK_CULLER_SORT_BACK_TO_FRONT 2
00054
00055 class vtkProp;
00056 class vtkRenderer;
00057
00058 class VTK_RENDERING_EXPORT vtkFrustumCoverageCuller : public vtkCuller
00059 {
00060 public:
00061   static vtkFrustumCoverageCuller *New();
00062   vtkTypeRevisionMacro(vtkFrustumCoverageCuller,vtkCuller);
00063   void PrintSelf(ostream& os,vtkIndent indent);
00064
00066
00068   vtkSetMacro( MinimumCoverage, float );
00069   vtkGetMacro( MinimumCoverage, float );
00071
00073
00075   vtkSetMacro( MaximumCoverage, float );
00076   vtkGetMacro( MaximumCoverage, float );
00078
00080
00082   vtkSetClampMacro( SortingStyle, int,
00083         VTK_CULLER_SORT_NONE, VTK_CULLER_SORT_BACK_TO_FRONT );
00084   vtkGetMacro(SortingStyle,int);
00085   void SetSortingStyleToNone()
00086         {this->SetSortingStyle(VTK_CULLER_SORT_NONE);};
00087   void SetSortingStyleToBackToFront()
00088     {this->SetSortingStyle(VTK_CULLER_SORT_BACK_TO_FRONT);};
00089   void SetSortingStyleToFrontToBack()
00090     {this->SetSortingStyle(VTK_CULLER_SORT_FRONT_TO_BACK);};
00091   const char *GetSortingStyleAsString(void);
00093
00094 //BTX
00096   /*! WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE
00097       THESE METHODS OUTSIDE OF THE RENDERING PROCESS Perform the cull
00098       operation This method should only be called by vtkRenderer as part of
00099       the render process */
00100   float Cull( vtkRenderer *ren, vtkProp **propList,
00101               int& listLength, int& initialized );
00103 //ETX
00104
00105 protected:
00106   vtkFrustumCoverageCuller();
00107   ~vtkFrustumCoverageCuller() {};
00108
00109   float        MinimumCoverage;
00110   float        MaximumCoverage;
00111   int          SortingStyle;
00112 private:
00113   vtkFrustumCoverageCuller(const vtkFrustumCoverageCuller&);  // Not implemented.
00114   void operator=(const vtkFrustumCoverageCuller&);  // Not implemented.
00115 };
00116
00117
00118 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkFunctionParser.h Source File

Common/vtkFunctionParser.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFunctionParser.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkFunctionParser_h
00035 #define __vtkFunctionParser_h
00036
00037 #include "vtkObject.h"
00038
00039 #define VTK_PARSER_IMMEDIATE 1
00040 #define VTK_PARSER_UNARY_MINUS 2
00041
00042 // supported math functions
00043 #define VTK_PARSER_ADD 3
00044 #define VTK_PARSER_SUBTRACT 4
00045 #define VTK_PARSER_MULTIPLY 5
00046 #define VTK_PARSER_DIVIDE 6
00047 #define VTK_PARSER_POWER 7
00048 #define VTK_PARSER_ABSOLUTE_VALUE 8
00049 #define VTK_PARSER_EXPONENT 9
00050 #define VTK_PARSER_CEILING 10
00051 #define VTK_PARSER_FLOOR 11
00052 #define VTK_PARSER_LOGARITHM 12
00053 #define VTK_PARSER_SQUARE_ROOT 13
00054 #define VTK_PARSER_SINE 14
00055 #define VTK_PARSER_COSINE 15
00056 #define VTK_PARSER_TANGENT 16
00057 #define VTK_PARSER_ARCSINE 17
00058 #define VTK_PARSER_ARCCOSINE 18
00059 #define VTK_PARSER_ARCTANGENT 19
00060 #define VTK_PARSER_HYPERBOLIC_SINE 20
00061 #define VTK_PARSER_HYPERBOLIC_COSINE 21
00062 #define VTK_PARSER_HYPERBOLIC_TANGENT 22
00063
00064 // functions involving vectors
00065 #define VTK_PARSER_VECTOR_UNARY_MINUS 23
00066 #define VTK_PARSER_DOT_PRODUCT 24
00067 #define VTK_PARSER_VECTOR_ADD 25
00068 #define VTK_PARSER_VECTOR_SUBTRACT 26
00069 #define VTK_PARSER_SCALAR_MULTIPLE 27
00070 #define VTK_PARSER_MAGNITUDE 28
00071 #define VTK_PARSER_NORMALIZE 29
00072
00073 // codes for scalar variables come before those for vectors
00074 #define VTK_PARSER_BEGIN_VARIABLES 30
00075
00076 // the value that is retuned as a result if there is an error
00077 #define VTK_PARSER_ERROR_RESULT VTK_LARGE_FLOAT
00078
00079 class VTK_COMMON_EXPORT vtkFunctionParser : public vtkObject
00080 {
00081 public:
00082   static vtkFunctionParser *New();
00083   vtkTypeRevisionMacro(vtkFunctionParser, vtkObject);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00087
00088   void SetFunction(const char *function);
00089   vtkGetStringMacro(Function);
00091
00094   int IsScalarResult();
00095
00098   int IsVectorResult();
00099
00101   double GetScalarResult();
00102
00104
00105   double* GetVectorResult();
00106   void GetVectorResult(double result[3]) {
00107     double *r = this->GetVectorResult();
00108     result[0] = r[0]; result[1] = r[1]; result[2] = r[2]; };
00110
00112
00116   void SetScalarVariableValue(const char* variableName, double value);
00117   void SetScalarVariableValue(int i, double value);
00119
00121
00122   double GetScalarVariableValue(const char* variableName);
00123   double GetScalarVariableValue(int i);
00125
00127
00131   void SetVectorVariableValue(const char* variableName, double xValue,
00132                               double yValue, double zValue);
00133   void SetVectorVariableValue(const char* variableName,
00134                               const double values[3]) {
00135     this->SetVectorVariableValue(variableName,values[0],values[1],values[2]);};
00136   void SetVectorVariableValue(int i, double xValue, double yValue,
00137                               double zValue);
00138   void SetVectorVariableValue(int i, const double values[3]) {
00139     this->SetVectorVariableValue(i,values[0],values[1],values[2]);};
00141
00143
00144   double* GetVectorVariableValue(const char* variableName);
00145   void GetVectorVariableValue(const char* variableName, double value[3]) {
00146     double *r = this->GetVectorVariableValue(variableName);
00147     value[0] = r[0]; value[1] = r[1]; value[2] = r[2]; };
00148   double* GetVectorVariableValue(int i);
00149   void GetVectorVariableValue(int i, double value[3]) {
00150     double *r = this->GetVectorVariableValue(i);
00151     value[0] = r[0]; value[1] = r[1]; value[2] = r[2]; };
00153
00155
00156   vtkGetMacro(NumberOfScalarVariables,int);
00158
00160
00161   vtkGetMacro(NumberOfVectorVariables,int);
00163
00165   char* GetScalarVariableName(int i);
00166
00168   char* GetVectorVariableName(int i);
00169
00171   void RemoveAllVariables();
00172
00173 protected:
00174   vtkFunctionParser();
00175   ~vtkFunctionParser();
00176
00177   int Parse();
00178   void Evaluate();
00179
00180   int CheckSyntax();
00181   void RemoveSpaces();
00182
00183   int BuildInternalFunctionStructure();
00184   void BuildInternalSubstringStructure(int beginIndex, int endIndex);
00185   void AddInternalByte(unsigned char newByte);
00186
00187   int IsSubstringCompletelyEnclosed(int beginIndex, int endIndex);
00188   int FindEndOfMathFunction(int beginIndex);
00189
00190   int IsVariableName(int currentIndex);
00191   int IsElementaryOperator(int op);
00192
00193   int GetMathFunctionNumber(int currentIndex);
00194   int GetMathFunctionStringLength(int mathFunctionNumber);
00195   int GetElementaryOperatorNumber(char op);
00196   int GetOperandNumber(int currentIndex);
00197   int GetVariableNameLength(int variableNumber);
00198
00199   int DisambiguateOperators();
00200
00201   char* Function;
00202   int FunctionLength;
00203   int NumberOfScalarVariables;
00204   int NumberOfVectorVariables;
00205   char** ScalarVariableNames;
00206   char** VectorVariableNames;
00207   double* ScalarVariableValues;
00208   double** VectorVariableValues;
00209   unsigned char *ByteCode;
00210   int ByteCodeSize;
00211   double *Immediates;
00212   int ImmediatesSize;
00213   double *Stack;
00214   int StackSize;
00215   int StackPointer;
00216
00217   vtkTimeStamp FunctionMTime;
00218   vtkTimeStamp ParseMTime;
00219   vtkTimeStamp VariableMTime;
00220   vtkTimeStamp EvaluateMTime;
00221 private:
00222   vtkFunctionParser(const vtkFunctionParser&);  // Not implemented.
00223   void operator=(const vtkFunctionParser&);  // Not implemented.
00224 };
00225
00226 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkFunctionSet.h Source File

Common/vtkFunctionSet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkFunctionSet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkFunctionSet_h
00039 #define __vtkFunctionSet_h
00040
00041 #include "vtkObject.h"
00042
00043 class VTK_COMMON_EXPORT vtkFunctionSet : public vtkObject
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkFunctionSet,vtkObject);
00047   virtual void PrintSelf(ostream& os, vtkIndent indent);
00048
00052   virtual int FunctionValues(float* x, float* f) = 0;
00053
00055
00057   virtual int GetNumberOfFunctions() {
00058     return this->NumFuncs; }
00060
00062
00065   virtual int GetNumberOfIndependentVariables() {
00066     return this->NumIndepVars; }
00068
00069 protected:
00070   vtkFunctionSet();
00071   ~vtkFunctionSet() {};
00072
00073   int NumFuncs;
00074   int NumIndepVars;
00075
00076 private:
00077   vtkFunctionSet(const vtkFunctionSet&);  // Not implemented.
00078   void operator=(const vtkFunctionSet&);  // Not implemented.
00079 };
00080
00081 #endif
00082
00083
00084
00085
00086
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkGaussianSplatter.h Source File

Imaging/vtkGaussianSplatter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGaussianSplatter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00085 #ifndef __vtkGaussianSplatter_h
00086 #define __vtkGaussianSplatter_h
00087
00088 #include "vtkDataSetToStructuredPointsFilter.h"
00089
00090 #define VTK_ACCUMULATION_MODE_MIN 0
00091 #define VTK_ACCUMULATION_MODE_MAX 1
00092 #define VTK_ACCUMULATION_MODE_SUM 2
00093
00094 class vtkFloatAray;
00095
00096 class VTK_IMAGING_EXPORT vtkGaussianSplatter : public vtkDataSetToStructuredPointsFilter
00097 {
00098 public:
00099   vtkTypeRevisionMacro(vtkGaussianSplatter,vtkDataSetToStructuredPointsFilter);
00100   void PrintSelf(ostream& os, vtkIndent indent);
00101
00105   static vtkGaussianSplatter *New();
00106
00108
00110   void SetSampleDimensions(int i, int j, int k);
00111   void SetSampleDimensions(int dim[3]);
00112   vtkGetVectorMacro(SampleDimensions,int,3);
00114
00116
00120   vtkSetVector6Macro(ModelBounds,float);
00121   vtkGetVectorMacro(ModelBounds,float,6);
00123
00125
00128   vtkSetClampMacro(Radius,float,0.0,1.0);
00129   vtkGetMacro(Radius,float);
00131
00133
00136   vtkSetClampMacro(ScaleFactor,float,0.0,VTK_LARGE_FLOAT);
00137   vtkGetMacro(ScaleFactor,float);
00139
00141
00143   vtkSetMacro(ExponentFactor,float);
00144   vtkGetMacro(ExponentFactor,float);
00146
00148
00151   vtkSetMacro(NormalWarping,int);
00152   vtkGetMacro(NormalWarping,int);
00153   vtkBooleanMacro(NormalWarping,int);
00155
00157
00162   vtkSetClampMacro(Eccentricity,float,0.001,VTK_LARGE_FLOAT);
00163   vtkGetMacro(Eccentricity,float);
00165
00167
00168   vtkSetMacro(ScalarWarping,int);
00169   vtkGetMacro(ScalarWarping,int);
00170   vtkBooleanMacro(ScalarWarping,int);
00172
00174
00177   vtkSetMacro(Capping,int);
00178   vtkGetMacro(Capping,int);
00179   vtkBooleanMacro(Capping,int);
00181
00183
00185   vtkSetMacro(CapValue,float);
00186   vtkGetMacro(CapValue,float);
00188
00190
00194   vtkSetClampMacro(AccumulationMode,int,
00195                    VTK_ACCUMULATION_MODE_MIN,VTK_ACCUMULATION_MODE_SUM);
00196   vtkGetMacro(AccumulationMode,int);
00197   void SetAccumulationModeToMin()
00198     {this->SetAccumulationMode(VTK_ACCUMULATION_MODE_MIN);}
00199   void SetAccumulationModeToMax()
00200     {this->SetAccumulationMode(VTK_ACCUMULATION_MODE_MAX);}
00201   void SetAccumulationModeToSum()
00202     {this->SetAccumulationMode(VTK_ACCUMULATION_MODE_SUM);}
00203   const char *GetAccumulationModeAsString();
00205
00207
00210   vtkSetMacro(NullValue,float);
00211   vtkGetMacro(NullValue,float);
00213
00216   void ComputeModelBounds();
00217
00218 protected:
00219   vtkGaussianSplatter();
00220   ~vtkGaussianSplatter() {};
00221
00222   void Execute();
00223   void Cap(vtkFloatArray *s);
00224
00225   int SampleDimensions[3]; // dimensions of volume to splat into
00226   float Radius; // maximum distance splat propagates (as fraction 0->1)
00227   float ExponentFactor; // scale exponent of gaussian function
00228   float ModelBounds[6]; // bounding box of splatting dimensions
00229   int NormalWarping; // on/off warping of splat via normal
00230   float Eccentricity;// elliptic distortion due to normals
00231   int ScalarWarping; // on/off warping of splat via scalar
00232   float ScaleFactor; // splat size influenced by scale factor
00233   int Capping; // Cap side of volume to close surfaces
00234   float CapValue; // value to use for capping
00235   int AccumulationMode; // how to combine scalar values
00236
00237   float Gaussian(float x[3]);
00238   float EccentricGaussian(float x[3]);
00239   float ScalarSampling(float s)
00240     {return this->ScaleFactor * s;}
00241   float PositionSampling(float)
00242     {return this->ScaleFactor;}
00243   void SetScalar(int idx, float dist2);
00244
00245 //BTX
00246 private:
00247   vtkFloatArray *NewScalars;
00248   float Radius2;
00249   float (vtkGaussianSplatter::*Sample)(float x[3]);
00250   float (vtkGaussianSplatter::*SampleFactor)(float s);
00251   char *Visited;
00252   float Eccentricity2;
00253   float *P;
00254   float *N;
00255   float S;
00256   float Origin[3];
00257   float Spacing[3];
00258   float SplatDistance[3];
00259   float NullValue;
00260 //ETX
00261
00262 private:
00263   vtkGaussianSplatter(const vtkGaussianSplatter&);  // Not implemented.
00264   void operator=(const vtkGaussianSplatter&);  // Not implemented.
00265 };
00266
00267 #endif
00268
00269
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkGeneralTransform.h Source File

Common/vtkGeneralTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGeneralTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #include "vtkAbstractTransform.h"
00042
00043 #ifndef __vtkGeneralTransform_h
00044 #define __vtkGeneralTransform_h
00045
00046 class VTK_COMMON_EXPORT vtkGeneralTransform : public vtkAbstractTransform
00047 {
00048 public:
00049   static vtkGeneralTransform *New();
00050
00051   vtkTypeRevisionMacro(vtkGeneralTransform,vtkAbstractTransform);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00057   void Identity() { this->Concatenation->Identity(); this->Modified(); };
00058
00062   void Inverse() { this->Concatenation->Inverse(); this->Modified(); };
00063
00065
00067   void Translate(double x, double y, double z) {
00068     this->Concatenation->Translate(x,y,z); };
00069   void Translate(const double x[3]) { this->Translate(x[0], x[1], x[2]); };
00070   void Translate(const float x[3]) { this->Translate(x[0], x[1], x[2]); };
00072
00074
00078   void RotateWXYZ(double angle, double x, double y, double z) {
00079     this->Concatenation->Rotate(angle,x,y,z); };
00080   void RotateWXYZ(double angle, const double axis[3]) {
00081     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00082   void RotateWXYZ(double angle, const float axis[3]) {
00083     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00085
00087
00090   void RotateX(double angle) { this->RotateWXYZ(angle, 1, 0, 0); };
00091   void RotateY(double angle) { this->RotateWXYZ(angle, 0, 1, 0); };
00092   void RotateZ(double angle) { this->RotateWXYZ(angle, 0, 0, 1); };
00094
00096
00099   void Scale(double x, double y, double z) {
00100     this->Concatenation->Scale(x,y,z); };
00101   void Scale(const double s[3]) { this->Scale(s[0], s[1], s[2]); };
00102   void Scale(const float s[3]) { this->Scale(s[0], s[1], s[2]); };
00104
00106
00108   void Concatenate(vtkMatrix4x4 *matrix) {
00109     this->Concatenate(*matrix->Element); };
00110   void Concatenate(const double elements[16]) {
00111     this->Concatenation->Concatenate(elements); };
00113
00119   void Concatenate(vtkAbstractTransform *transform);
00120
00122
00127   void PreMultiply() {
00128     if (this->Concatenation->GetPreMultiplyFlag()) { return; }
00129     this->Concatenation->SetPreMultiplyFlag(1); this->Modified(); };
00131
00133
00138   void PostMultiply()  {
00139     if (!this->Concatenation->GetPreMultiplyFlag()) { return; }
00140     this->Concatenation->SetPreMultiplyFlag(0); this->Modified(); };
00142
00144
00146   int GetNumberOfConcatenatedTransforms() {
00147     return this->Concatenation->GetNumberOfTransforms() +
00148       (this->Input == NULL ? 0 : 1); };
00150
00152
00157   vtkAbstractTransform *GetConcatenatedTransform(int i) {
00158     if (this->Input == NULL) {
00159       return this->Concatenation->GetTransform(i); }
00160     else if (i < this->Concatenation->GetNumberOfPreTransforms()) {
00161       return this->Concatenation->GetTransform(i); }
00162     else if (i > this->Concatenation->GetNumberOfPreTransforms()) {
00163       return this->Concatenation->GetTransform(i-1); }
00164     else if (this->GetInverseFlag()) {
00165       return this->Input->GetInverse(); }
00166     else {
00167       return this->Input; } };
00169
00171
00177   void SetInput(vtkAbstractTransform *input);
00178   vtkAbstractTransform *GetInput() { return this->Input; };
00180
00182
00186   int GetInverseFlag() {
00187     return this->Concatenation->GetInverseFlag(); };
00189
00191
00192   void Push() { if (this->Stack == NULL) {
00193                     this->Stack = vtkTransformConcatenationStack::New(); }
00194                 this->Stack->Push(&this->Concatenation);
00195                 this->Modified(); };
00197
00199
00201   void Pop() { if (this->Stack == NULL) { return; }
00202                this->Stack->Pop(&this->Concatenation);
00203                this->Modified(); };
00205
00207
00209   void InternalTransformPoint(const float in[3], float out[3]);
00210   void InternalTransformPoint(const double in[3], double out[3]);
00212
00214
00216   void InternalTransformDerivative(const float in[3], float out[3],
00217                                    float derivative[3][3]);
00218   void InternalTransformDerivative(const double in[3], double out[3],
00219                                    double derivative[3][3]);
00221
00228   int CircuitCheck(vtkAbstractTransform *transform);
00229
00231   vtkAbstractTransform *MakeTransform();
00232
00234   unsigned long GetMTime();
00235
00236 protected:
00237   vtkGeneralTransform();
00238   ~vtkGeneralTransform();
00239
00240   void InternalDeepCopy(vtkAbstractTransform *t);
00241   void InternalUpdate();
00242
00243   vtkAbstractTransform *Input;
00244   vtkTransformConcatenation *Concatenation;
00245   vtkTransformConcatenationStack *Stack;
00246 private:
00247   vtkGeneralTransform(const vtkGeneralTransform&);  // Not implemented.
00248   void operator=(const vtkGeneralTransform&);  // Not implemented.
00249 };
00250
00251
00252 #endif
00253
00254
00255
00256
00257
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkGenericCell.h Source File

Common/vtkGenericCell.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGenericCell.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkGenericCell_h
00042 #define __vtkGenericCell_h
00043
00044 #include "vtkCell.h"
00045
00046 class VTK_COMMON_EXPORT vtkGenericCell : public vtkCell
00047 {
00048 public:
00050   static vtkGenericCell *New();
00051
00052   vtkTypeRevisionMacro(vtkGenericCell,vtkCell);
00053
00055
00056   vtkCell *MakeObject();
00057   void ShallowCopy(vtkCell *c);
00058   void DeepCopy(vtkCell *c);
00059   int GetCellType();
00060   int GetCellDimension();
00061   int IsLinear();
00062   int GetNumberOfEdges();
00063   int GetNumberOfFaces();
00064   vtkCell *GetEdge(int edgeId);
00065   vtkCell *GetFace(int faceId);
00066   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00067   int EvaluatePosition(float x[3], float* closestPoint,
00068                        int& subId, float pcoords[3],
00069                        float& dist2, float *weights);
00070   void EvaluateLocation(int& subId, float pcoords[3],
00071                         float x[3], float *weights);
00072   void Contour(float value, vtkDataArray *cellScalars,
00073                vtkPointLocator *locator, vtkCellArray *verts,
00074                vtkCellArray *lines, vtkCellArray *polys,
00075                vtkPointData *inPd, vtkPointData *outPd,
00076                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00077   void Clip(float value, vtkDataArray *cellScalars,
00078             vtkPointLocator *locator, vtkCellArray *connectivity,
00079             vtkPointData *inPd, vtkPointData *outPd,
00080             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00081             int insideOut);
00082   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00083                         float x[3], float pcoords[3], int& subId);
00084   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00085   void Derivatives(int subId, float pcoords[3], float *values,
00086                    int dim, float *derivs);
00087   int GetParametricCenter(float pcoords[3]);
00089
00091
00096   void SetCellType(int cellType);
00097   void SetCellTypeToEmptyCell() {this->SetCellType(VTK_EMPTY_CELL);}
00098   void SetCellTypeToVertex() {this->SetCellType(VTK_VERTEX);}
00099   void SetCellTypeToPolyVertex() {this->SetCellType(VTK_POLY_VERTEX);}
00100   void SetCellTypeToLine() {this->SetCellType(VTK_LINE);}
00101   void SetCellTypeToPolyLine() {this->SetCellType(VTK_POLY_LINE);}
00102   void SetCellTypeToTriangle() {this->SetCellType(VTK_TRIANGLE);}
00103   void SetCellTypeToTriangleStrip() {this->SetCellType(VTK_TRIANGLE_STRIP);}
00104   void SetCellTypeToPolygon() {this->SetCellType(VTK_POLYGON);}
00105   void SetCellTypeToPixel() {this->SetCellType(VTK_PIXEL);}
00106   void SetCellTypeToQuad() {this->SetCellType(VTK_QUAD);}
00107   void SetCellTypeToTetra() {this->SetCellType(VTK_TETRA);}
00108   void SetCellTypeToVoxel() {this->SetCellType(VTK_VOXEL);}
00109   void SetCellTypeToHexahedron() {this->SetCellType(VTK_HEXAHEDRON);}
00110   void SetCellTypeToWedge() {this->SetCellType(VTK_WEDGE);}
00111   void SetCellTypeToPyramid() {this->SetCellType(VTK_PYRAMID);}
00112   void SetCellTypeToQuadraticEdge() {this->SetCellType(VTK_QUADRATIC_EDGE);}
00113   void SetCellTypeToQuadraticTriangle() {this->SetCellType(VTK_QUADRATIC_TRIANGLE);}
00114   void SetCellTypeToQuadraticTetra() {this->SetCellType(VTK_QUADRATIC_TETRA);}
00116
00117 protected:
00118   vtkGenericCell();
00119   ~vtkGenericCell();
00120
00121   vtkCell *Cell;
00122
00123 private:
00124   vtkGenericCell(const vtkGenericCell&);  // Not implemented.
00125   void operator=(const vtkGenericCell&);  // Not implemented.
00126 };
00127
00128 #endif
00129
00130
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkGenericEnSightReader.h Source File

IO/vtkGenericEnSightReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGenericEnSightReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkGenericEnSightReader_h
00036 #define __vtkGenericEnSightReader_h
00037
00038 #include "vtkEnSightReader.h"
00039
00040 #define VTK_ENSIGHT_6    0
00041 #define VTK_ENSIGHT_6_BINARY 1
00042 #define VTK_ENSIGHT_GOLD 2
00043 #define VTK_ENSIGHT_GOLD_BINARY 3
00044
00045 class VTK_IO_EXPORT vtkGenericEnSightReader : public vtkDataSetSource
00046 {
00047 public:
00048   static vtkGenericEnSightReader *New();
00049   vtkTypeRevisionMacro(vtkGenericEnSightReader, vtkDataSetSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   void SetCaseFileName(char* fileName);
00055   vtkGetStringMacro(CaseFileName);
00057
00059
00060   vtkSetStringMacro(FilePath);
00061   vtkGetStringMacro(FilePath);
00063
00064   void Update();
00065
00067
00068   int GetNumberOfVariables(int type); // returns -1 if unknown type specified
00069   vtkGetMacro(NumberOfScalarsPerNode, int);
00070   vtkGetMacro(NumberOfVectorsPerNode, int);
00071   vtkGetMacro(NumberOfTensorsSymmPerNode, int);
00072   vtkGetMacro(NumberOfScalarsPerElement, int);
00073   vtkGetMacro(NumberOfVectorsPerElement, int);
00074   vtkGetMacro(NumberOfTensorsSymmPerElement, int);
00075   vtkGetMacro(NumberOfScalarsPerMeasuredNode, int);
00076   vtkGetMacro(NumberOfVectorsPerMeasuredNode, int);
00077   vtkGetMacro(NumberOfComplexScalarsPerNode, int);
00078   vtkGetMacro(NumberOfComplexVectorsPerNode, int);
00079   vtkGetMacro(NumberOfComplexScalarsPerElement, int);
00080   vtkGetMacro(NumberOfComplexVectorsPerElement, int);
00082
00084   char* GetDescription(int n);
00085
00087   char* GetComplexDescription(int n);
00088
00098   char* GetDescription(int n, int type);
00099
00101
00102   int GetVariableType(int n);
00103   int GetComplexVariableType(int n);
00105
00107
00108   vtkSetMacro(TimeValue, float);
00109   vtkGetMacro(TimeValue, float);
00111
00113
00114   vtkGetMacro(MinimumTimeValue, float);
00115   vtkGetMacro(MaximumTimeValue, float);
00117
00118 protected:
00119   vtkGenericEnSightReader();
00120   ~vtkGenericEnSightReader();
00121
00122   void Execute();
00123
00128   int DetermineEnSightVersion();
00129
00132   int ReadLine(char result[256]);
00133
00136   int ReadBinaryLine(char result[80]);
00137
00138   // Internal function that skips blank lines and reads the 1st
00139   // non-blank line it finds (up to 256 characters).
00140   // Returns 0 is there was an error.
00141   int ReadNextDataLine(char result[256]);
00142
00144
00145   vtkSetStringMacro(GeometryFileName);
00146   vtkGetStringMacro(GeometryFileName);
00148
00150
00151   void AddVariableDescription(char* description);
00152   void AddComplexVariableDescription(char* description);
00154
00156
00157   void AddVariableType(int variableType);
00158   void AddComplexVariableType(int variableType);
00160
00162
00164   void ReplaceWildcards(char* fileName, int timeSet, int fileSet);
00165   void ReplaceWildcardsHelper(char* fileName, int num);
00167
00168   istream* IS;
00169   FILE *IFile;
00170   vtkEnSightReader *Reader;
00171
00172   char* CaseFileName;
00173   char* GeometryFileName;
00174   char* FilePath;
00175
00176   int* VariableTypes;
00177   int* ComplexVariableTypes;
00178
00179   char** VariableDescriptions;
00180   char** ComplexVariableDescriptions;
00181
00182   int NumberOfVariables;
00183   int NumberOfComplexVariables;
00184
00185   // number of file names / descriptions per type
00186   int NumberOfScalarsPerNode;
00187   int NumberOfVectorsPerNode;
00188   int NumberOfTensorsSymmPerNode;
00189   int NumberOfScalarsPerElement;
00190   int NumberOfVectorsPerElement;
00191   int NumberOfTensorsSymmPerElement;
00192   int NumberOfScalarsPerMeasuredNode;
00193   int NumberOfVectorsPerMeasuredNode;
00194   int NumberOfComplexScalarsPerNode;
00195   int NumberOfComplexVectorsPerNode;
00196   int NumberOfComplexScalarsPerElement;
00197   int NumberOfComplexVectorsPerElement;
00198
00199   float TimeValue;
00200   float MinimumTimeValue;
00201   float MaximumTimeValue;
00202 private:
00203   vtkGenericEnSightReader(const vtkGenericEnSightReader&);  // Not implemented.
00204   void operator=(const vtkGenericEnSightReader&);  // Not implemented.
00205 };
00206
00207 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkGeometryFilter.h Source File

Graphics/vtkGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00065 #ifndef __vtkGeometryFilter_h
00066 #define __vtkGeometryFilter_h
00067
00068 #include "vtkDataSetToPolyDataFilter.h"
00069
00070 class VTK_GRAPHICS_EXPORT vtkGeometryFilter : public vtkDataSetToPolyDataFilter
00071 {
00072 public:
00073   static vtkGeometryFilter *New();
00074   vtkTypeRevisionMacro(vtkGeometryFilter,vtkDataSetToPolyDataFilter);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078
00079   vtkSetMacro(PointClipping,int);
00080   vtkGetMacro(PointClipping,int);
00081   vtkBooleanMacro(PointClipping,int);
00083
00085
00086   vtkSetMacro(CellClipping,int);
00087   vtkGetMacro(CellClipping,int);
00088   vtkBooleanMacro(CellClipping,int);
00090
00092
00093   vtkSetMacro(ExtentClipping,int);
00094   vtkGetMacro(ExtentClipping,int);
00095   vtkBooleanMacro(ExtentClipping,int);
00097
00099
00100   vtkSetClampMacro(PointMinimum,vtkIdType,0,VTK_LARGE_ID);
00101   vtkGetMacro(PointMinimum,vtkIdType);
00103
00105
00106   vtkSetClampMacro(PointMaximum,vtkIdType,0,VTK_LARGE_ID);
00107   vtkGetMacro(PointMaximum,vtkIdType);
00109
00111
00112   vtkSetClampMacro(CellMinimum,vtkIdType,0,VTK_LARGE_ID);
00113   vtkGetMacro(CellMinimum,vtkIdType);
00115
00117
00118   vtkSetClampMacro(CellMaximum,vtkIdType,0,VTK_LARGE_ID);
00119   vtkGetMacro(CellMaximum,vtkIdType);
00121
00123
00125   void SetExtent(float xMin, float xMax, float yMin, float yMax,
00126                  float zMin, float zMax);
00128
00130
00132   void SetExtent(float extent[6]);
00133   float *GetExtent() { return this->Extent;};
00135
00137
00140   vtkSetMacro(Merging,int);
00141   vtkGetMacro(Merging,int);
00142   vtkBooleanMacro(Merging,int);
00144
00146
00148   void SetLocator(vtkPointLocator *locator);
00149   vtkGetObjectMacro(Locator,vtkPointLocator);
00151
00153   void CreateDefaultLocator();
00154
00156   unsigned long GetMTime();
00157
00158 protected:
00159   vtkGeometryFilter();
00160   ~vtkGeometryFilter();
00161
00162   void Execute();
00163   void PolyDataExecute(); //special cases for performance
00164   void UnstructuredGridExecute();
00165   void StructuredGridExecute();
00166   void ComputeInputUpdateExtents(vtkDataObject *output);
00167   void ExecuteInformation();
00168
00169   vtkIdType PointMaximum;
00170   vtkIdType PointMinimum;
00171   vtkIdType CellMinimum;
00172   vtkIdType CellMaximum;
00173   float Extent[6];
00174   int PointClipping;
00175   int CellClipping;
00176   int ExtentClipping;
00177
00178   int Merging;
00179   vtkPointLocator *Locator;
00180 private:
00181   vtkGeometryFilter(const vtkGeometryFilter&);  // Not implemented.
00182   void operator=(const vtkGeometryFilter&);  // Not implemented.
00183 };
00184
00185 #endif
00186
00187
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkGESignaReader.h Source File

IO/vtkGESignaReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGESignaReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkGESignaReader_h
00046 #define __vtkGESignaReader_h
00047
00048 #include <stdio.h>
00049 #include "vtkMedicalImageReader2.h"
00050
00051 class VTK_IO_EXPORT vtkGESignaReader : public vtkMedicalImageReader2
00052 {
00053 public:
00054   static vtkGESignaReader *New();
00055   vtkTypeRevisionMacro(vtkGESignaReader,vtkImageReader2);
00057   virtual vtkImageReader2* MakeObject() { return vtkGESignaReader::New();}
00058   // Description: is the given file name a GESigna file?
00059   virtual int CanReadFile(const char* fname);
00061
00063
00064   virtual const char* GetFileExensions()
00065     {
00066       return ".MR .CT";
00067     }
00069
00071
00072   virtual const char* GetDescriptiveName()
00073     {
00074       return "GESigna";
00075     }
00077
00078 protected:
00079   vtkGESignaReader() {};
00080   ~vtkGESignaReader() {};
00081
00082   virtual void ExecuteInformation();
00083   virtual void ExecuteData(vtkDataObject *out);
00084
00085 private:
00086   vtkGESignaReader(const vtkGESignaReader&);  // Not implemented.
00087   void operator=(const vtkGESignaReader&);  // Not implemented.
00088 };
00089 #endif
00090
00091
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkgluPickMatrix.h Source File

Rendering/vtkgluPickMatrix.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkgluPickMatrix.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00026 #ifndef vtkgluPickMatrix_h
00027 #define vtkgluPickMatrix_h
00028
00029 // This function was copied from Mesa and sets up the pick matrix
00030 inline void vtkgluPickMatrix( GLdouble x, GLdouble y,
00031                               GLdouble width, GLdouble height,
00032                               int *origin, int *size )
00033 {
00034   GLfloat m[16];
00035   GLfloat sx, sy;
00036   GLfloat tx, ty;
00037
00038   sx = size[0] / width;
00039   sy = size[1] / height;
00040   tx = (size[0] + 2.0 * (origin[0] - x)) / width;
00041   ty = (size[1] + 2.0 * (origin[1] - y)) / height;
00042
00043 #define M(row,col)  m[col*4+row]
00044    M(0,0) = sx;   M(0,1) = 0.0;  M(0,2) = 0.0;  M(0,3) = tx;
00045    M(1,0) = 0.0;  M(1,1) = sy;   M(1,2) = 0.0;  M(1,3) = ty;
00046    M(2,0) = 0.0;  M(2,1) = 0.0;  M(2,2) = 1.0;  M(2,3) = 0.0;
00047    M(3,0) = 0.0;  M(3,1) = 0.0;  M(3,2) = 0.0;  M(3,3) = 1.0;
00048 #undef M
00049
00050    glMultMatrixf( m );
00051 }
00052
00053 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkGLUTesselatorTriangleFilter.h Source File

Hybrid/vtkGLUTesselatorTriangleFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGLUTesselatorTriangleFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkGLUTesselatorTriangleFilter_h
00041 #define __vtkGLUTesselatorTriangleFilter_h
00042
00043 #include "vtkPolyDataToPolyDataFilter.h"
00044 #include <GL/GLU.h>
00045
00046 class VTK_HYBRID_EXPORT vtkGLUTesselatorTriangleFilter : public vtkPolyDataToPolyDataFilter
00047 {
00048 public:
00049   static vtkGLUTesselatorTriangleFilter *New();
00050   vtkTypeRevisionMacro(vtkGLUTesselatorTriangleFilter,vtkPolyDataToPolyDataFilter);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   vtkBooleanMacro(PassVerts,int);
00056   vtkSetMacro(PassVerts,int);
00057   vtkGetMacro(PassVerts,int);
00059
00061
00062   vtkBooleanMacro(PassLines,int);
00063   vtkSetMacro(PassLines,int);
00064   vtkGetMacro(PassLines,int);
00066
00067 protected:
00068   vtkGLUTesselatorTriangleFilter();
00069   ~vtkGLUTesselatorTriangleFilter();
00070
00071   // Usual data generation method
00072   void Execute();
00073
00074         // Data
00075   int PassVerts;
00076   int PassLines;
00077   GLUtesselator *GLUTesselator;
00078
00079 private:
00080   vtkGLUTesselatorTriangleFilter(const vtkGLUTesselatorTriangleFilter&);  // Not implemented.
00081   void operator=(const vtkGLUTesselatorTriangleFilter&);  // Not implemented.
00082 };
00083
00084 #endif
00085
00086
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkGlyph2D.h Source File

Graphics/vtkGlyph2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGlyph2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkGlyph2D_h
00044 #define __vtkGlyph2D_h
00045
00046 #include "vtkGlyph3D.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkGlyph2D : public vtkGlyph3D
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkGlyph2D,vtkGlyph3D);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00058   static vtkGlyph2D *New();
00059
00060 protected:
00061   vtkGlyph2D() {};
00062   ~vtkGlyph2D() {};
00063
00064   void Execute();
00065 private:
00066   vtkGlyph2D(const vtkGlyph2D&);  // Not implemented.
00067   void operator=(const vtkGlyph2D&);  // Not implemented.
00068 };
00069
00070 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkGlyph3D.h Source File

Graphics/vtkGlyph3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGlyph3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00092 #ifndef __vtkGlyph3D_h
00093 #define __vtkGlyph3D_h
00094
00095 #include "vtkDataSetToPolyDataFilter.h"
00096
00097 #define VTK_SCALE_BY_SCALAR 0
00098 #define VTK_SCALE_BY_VECTOR 1
00099 #define VTK_SCALE_BY_VECTORCOMPONENTS 2
00100 #define VTK_DATA_SCALING_OFF 3
00101
00102 #define VTK_COLOR_BY_SCALE  0
00103 #define VTK_COLOR_BY_SCALAR 1
00104 #define VTK_COLOR_BY_VECTOR 2
00105
00106 #define VTK_USE_VECTOR 0
00107 #define VTK_USE_NORMAL 1
00108 #define VTK_VECTOR_ROTATION_OFF 2
00109
00110 #define VTK_INDEXING_OFF 0
00111 #define VTK_INDEXING_BY_SCALAR 1
00112 #define VTK_INDEXING_BY_VECTOR 2
00113
00114 class VTK_GRAPHICS_EXPORT vtkGlyph3D : public vtkDataSetToPolyDataFilter
00115 {
00116 public:
00117   vtkTypeRevisionMacro(vtkGlyph3D,vtkDataSetToPolyDataFilter);
00118   void PrintSelf(ostream& os, vtkIndent indent);
00119
00124   static vtkGlyph3D *New();
00125
00127
00129   void SetNumberOfSources(int num);
00130   int GetNumberOfSources();
00132
00134   void SetSource(vtkPolyData *pd) {this->SetSource(0,pd);};
00135
00137   void SetSource(int id, vtkPolyData *pd);
00138
00140   vtkPolyData *GetSource(int id=0);
00141
00143
00144   vtkSetMacro(Scaling,int);
00145   vtkBooleanMacro(Scaling,int);
00146   vtkGetMacro(Scaling,int);
00148
00150
00151   vtkSetMacro(ScaleMode,int);
00152   vtkGetMacro(ScaleMode,int);
00153   void SetScaleModeToScaleByScalar()
00154     {this->SetScaleMode(VTK_SCALE_BY_SCALAR);};
00155   void SetScaleModeToScaleByVector()
00156     {this->SetScaleMode(VTK_SCALE_BY_VECTOR);};
00157   void SetScaleModeToScaleByVectorComponents()
00158     {this->SetScaleMode(VTK_SCALE_BY_VECTORCOMPONENTS);};
00159   void SetScaleModeToDataScalingOff()
00160     {this->SetScaleMode(VTK_DATA_SCALING_OFF);};
00161   const char *GetScaleModeAsString();
00163
00165
00166   vtkSetMacro(ColorMode,int);
00167   vtkGetMacro(ColorMode,int);
00168   void SetColorModeToColorByScale()
00169     {this->SetColorMode(VTK_COLOR_BY_SCALE);};
00170   void SetColorModeToColorByScalar()
00171     {this->SetColorMode(VTK_COLOR_BY_SCALAR);};
00172   void SetColorModeToColorByVector()
00173     {this->SetColorMode(VTK_COLOR_BY_VECTOR);};
00174   const char *GetColorModeAsString();
00176
00178
00179   vtkSetMacro(ScaleFactor,float);
00180   vtkGetMacro(ScaleFactor,float);
00182
00184
00185   vtkSetVector2Macro(Range,float);
00186   vtkGetVectorMacro(Range,float,2);
00188
00190
00191   vtkSetMacro(Orient,int);
00192   vtkBooleanMacro(Orient,int);
00193   vtkGetMacro(Orient,int);
00195
00197
00199   vtkSetMacro(Clamping,int);
00200   vtkBooleanMacro(Clamping,int);
00201   vtkGetMacro(Clamping,int);
00203
00205
00206   vtkSetMacro(VectorMode,int);
00207   vtkGetMacro(VectorMode,int);
00208   void SetVectorModeToUseVector() {this->SetVectorMode(VTK_USE_VECTOR);};
00209   void SetVectorModeToUseNormal() {this->SetVectorMode(VTK_USE_NORMAL);};
00210   void SetVectorModeToVectorRotationOff()
00211     {this->SetVectorMode(VTK_VECTOR_ROTATION_OFF);};
00212   const char *GetVectorModeAsString();
00214
00216
00219   vtkSetMacro(IndexMode,int);
00220   vtkGetMacro(IndexMode,int);
00221   void SetIndexModeToScalar() {this->SetIndexMode(VTK_INDEXING_BY_SCALAR);};
00222   void SetIndexModeToVector() {this->SetIndexMode(VTK_INDEXING_BY_VECTOR);};
00223   void SetIndexModeToOff() {this->SetIndexMode(VTK_INDEXING_OFF);};
00224   const char *GetIndexModeAsString();
00226
00228
00232   vtkSetMacro(GeneratePointIds,int);
00233   vtkGetMacro(GeneratePointIds,int);
00234   vtkBooleanMacro(GeneratePointIds,int);
00236
00238
00241   vtkSetStringMacro(PointIdsName);
00242   vtkGetStringMacro(PointIdsName);
00244 protected:
00245   vtkGlyph3D();
00246   ~vtkGlyph3D();
00247
00248   void Execute();
00249   void ExecuteInformation();
00250   void ComputeInputUpdateExtents(vtkDataObject *output);
00251
00252   int NumberOfSources; // Number of source objects
00253   vtkPolyData **Source; // Geometry to copy to each point
00254   int Scaling; // Determine whether scaling of geometry is performed
00255   int ScaleMode; // Scale by scalar value or vector magnitude
00256   int ColorMode; // new scalars based on scale, scalar or vector
00257   float ScaleFactor; // Scale factor to use to scale geometry
00258   float Range[2]; // Range to use to perform scalar scaling
00259   int Orient; // boolean controls whether to "orient" data
00260   int VectorMode; // Orient/scale via normal or via vector data
00261   int Clamping; // whether to clamp scale factor
00262   int IndexMode; // what to use to index into glyph table
00263   int GeneratePointIds; // produce input points ids for each output point
00264   char *PointIdsName;
00265
00266 private:
00267   vtkGlyph3D(const vtkGlyph3D&);  // Not implemented.
00268   void operator=(const vtkGlyph3D&);  // Not implemented.
00269 };
00270
00272 inline const char *vtkGlyph3D::GetScaleModeAsString(void)
00273 {
00274   if ( this->ScaleMode == VTK_SCALE_BY_SCALAR )
00275     {
00276     return "ScaleByScalar";
00277     }
00278   else if ( this->ScaleMode == VTK_SCALE_BY_VECTOR )
00279     {
00280     return "ScaleByVector";
00281     }
00282   else
00283     {
00284     return "DataScalingOff";
00285     }
00286 }
00287
00289 inline const char *vtkGlyph3D::GetColorModeAsString(void)
00290 {
00291   if ( this->ColorMode == VTK_COLOR_BY_SCALAR )
00292     {
00293     return "ColorByScalar";
00294     }
00295   else if ( this->ColorMode == VTK_COLOR_BY_VECTOR )
00296     {
00297     return "ColorByVector";
00298     }
00299   else
00300     {
00301     return "ColorByScale";
00302     }
00303 }
00304
00306 inline const char *vtkGlyph3D::GetVectorModeAsString(void)
00307 {
00308   if ( this->VectorMode == VTK_USE_VECTOR)
00309     {
00310     return "UseVector";
00311     }
00312   else if ( this->VectorMode == VTK_USE_NORMAL)
00313     {
00314     return "UseNormal";
00315     }
00316   else
00317     {
00318     return "VectorRotationOff";
00319     }
00320 }
00321
00323 inline const char *vtkGlyph3D::GetIndexModeAsString(void)
00324 {
00325   if ( this->IndexMode == VTK_INDEXING_OFF)
00326     {
00327     return "IndexingOff";
00328     }
00329   else if ( this->IndexMode == VTK_INDEXING_BY_SCALAR)
00330     {
00331     return "IndexingByScalar";
00332     }
00333   else
00334     {
00335     return "IndexingByVector";
00336     }
00337 }
00338
00339 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkGlyphSource2D.h Source File

Graphics/vtkGlyphSource2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGlyphSource2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkGlyphSource2D_h
00046 #define __vtkGlyphSource2D_h
00047
00048 #include "vtkPolyDataSource.h"
00049
00050 #define VTK_NO_GLYPH 0
00051 #define VTK_VERTEX_GLYPH 1
00052 #define VTK_DASH_GLYPH 2
00053 #define VTK_CROSS_GLYPH 3
00054 #define VTK_THICKCROSS_GLYPH 4
00055 #define VTK_TRIANGLE_GLYPH 5
00056 #define VTK_SQUARE_GLYPH 6
00057 #define VTK_CIRCLE_GLYPH 7
00058 #define VTK_DIAMOND_GLYPH 8
00059 #define VTK_ARROW_GLYPH 9
00060 #define VTK_THICKARROW_GLYPH 10
00061 #define VTK_HOOKEDARROW_GLYPH 11
00062
00063 class VTK_GRAPHICS_EXPORT vtkGlyphSource2D : public vtkPolyDataSource
00064 {
00065 public:
00066   vtkTypeRevisionMacro(vtkGlyphSource2D,vtkPolyDataSource);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00071   static vtkGlyphSource2D *New();
00072
00074
00075   vtkSetVector3Macro(Center,float);
00076   vtkGetVectorMacro(Center,float,3);
00078
00080
00082   vtkSetClampMacro(Scale,float,0.0,VTK_LARGE_FLOAT);
00083   vtkGetMacro(Scale,float);
00085
00087
00089   vtkSetClampMacro(Scale2,float,0.0,VTK_LARGE_FLOAT);
00090   vtkGetMacro(Scale2,float);
00092
00094
00095   vtkSetVector3Macro(Color,float);
00096   vtkGetVectorMacro(Color,float,3);
00098
00100
00103   vtkSetMacro(Filled,int);
00104   vtkGetMacro(Filled,int);
00105   vtkBooleanMacro(Filled,int);
00107
00109
00112   vtkSetMacro(Dash,int);
00113   vtkGetMacro(Dash,int);
00114   vtkBooleanMacro(Dash,int);
00116
00118
00121   vtkSetMacro(Cross,int);
00122   vtkGetMacro(Cross,int);
00123   vtkBooleanMacro(Cross,int);
00125
00127
00130   vtkSetMacro(RotationAngle,float);
00131   vtkGetMacro(RotationAngle,float);
00133
00135
00136   vtkSetClampMacro(GlyphType,int,VTK_NO_GLYPH,VTK_HOOKEDARROW_GLYPH);
00137   vtkGetMacro(GlyphType,int);
00138   void SetGlyphTypeToNone() {this->SetGlyphType(VTK_NO_GLYPH);}
00139   void SetGlyphTypeToVertex() {this->SetGlyphType(VTK_VERTEX_GLYPH);}
00140   void SetGlyphTypeToDash() {this->SetGlyphType(VTK_DASH_GLYPH);}
00141   void SetGlyphTypeToCross() {this->SetGlyphType(VTK_CROSS_GLYPH);}
00142   void SetGlyphTypeToThickCross() {this->SetGlyphType(VTK_THICKCROSS_GLYPH);}
00143   void SetGlyphTypeToTriangle() {this->SetGlyphType(VTK_TRIANGLE_GLYPH);}
00144   void SetGlyphTypeToSquare() {this->SetGlyphType(VTK_SQUARE_GLYPH);}
00145   void SetGlyphTypeToCircle() {this->SetGlyphType(VTK_CIRCLE_GLYPH);}
00146   void SetGlyphTypeToDiamond() {this->SetGlyphType(VTK_DIAMOND_GLYPH);}
00147   void SetGlyphTypeToArrow() {this->SetGlyphType(VTK_ARROW_GLYPH);}
00148   void SetGlyphTypeToThickArrow() {this->SetGlyphType(VTK_THICKARROW_GLYPH);}
00149   void SetGlyphTypeToHookedArrow() {this->SetGlyphType(VTK_HOOKEDARROW_GLYPH);}
00151
00152 protected:
00153   vtkGlyphSource2D();
00154   ~vtkGlyphSource2D() {};
00155
00156   void Execute();
00157
00158   float Center[3];
00159   float Scale;
00160   float Scale2;
00161   float Color[3];
00162   int   Filled;
00163   int   Dash;
00164   int   Cross;
00165   int   GlyphType;
00166   float RotationAngle;
00167
00168   void TransformGlyph(vtkPoints *pts);
00169   void ConvertColor();
00170   unsigned char RGB[3];
00171
00172   void CreateVertex(vtkPoints *pts, vtkCellArray *verts,
00173                     vtkUnsignedCharArray *colors);
00174   void CreateDash(vtkPoints *pts, vtkCellArray *lines,
00175                   vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale);
00176   void CreateCross(vtkPoints *pts, vtkCellArray *lines,
00177                    vtkCellArray *polys, vtkUnsignedCharArray *colors, float scale);
00178   void CreateThickCross(vtkPoints *pts, vtkCellArray *lines,
00179                         vtkCellArray *polys, vtkUnsignedCharArray *colors);
00180   void CreateTriangle(vtkPoints *pts, vtkCellArray *lines,
00181                       vtkCellArray *polys, vtkUnsignedCharArray *colors);
00182   void CreateSquare(vtkPoints *pts, vtkCellArray *lines,
00183                     vtkCellArray *polys, vtkUnsignedCharArray *colors);
00184   void CreateCircle(vtkPoints *pts, vtkCellArray *lines,
00185                     vtkCellArray *polys, vtkUnsignedCharArray *colors);
00186   void CreateDiamond(vtkPoints *pts, vtkCellArray *lines,
00187                      vtkCellArray *polys, vtkUnsignedCharArray *colors);
00188   void CreateArrow(vtkPoints *pts, vtkCellArray *lines,
00189                    vtkCellArray *polys, vtkUnsignedCharArray *colors);
00190   void CreateThickArrow(vtkPoints *pts, vtkCellArray *lines,
00191                         vtkCellArray *polys, vtkUnsignedCharArray *colors);
00192   void CreateHookedArrow(vtkPoints *pts, vtkCellArray *lines,
00193                          vtkCellArray *polys, vtkUnsignedCharArray *colors);
00194
00195 private:
00196   vtkGlyphSource2D(const vtkGlyphSource2D&);  // Not implemented.
00197   void operator=(const vtkGlyphSource2D&);  // Not implemented.
00198 };
00199
00200 #endif
00201
00202
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkGraphicsFactory.h Source File

Rendering/vtkGraphicsFactory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGraphicsFactory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkGraphicsFactory_h
00032 #define __vtkGraphicsFactory_h
00033
00034 #include "vtkObject.h"
00035
00036 class VTK_RENDERING_EXPORT vtkGraphicsFactory : public vtkObject
00037 {
00038 public:
00039   static vtkGraphicsFactory *New() {return new vtkGraphicsFactory;};
00040   vtkTypeRevisionMacro(vtkGraphicsFactory,vtkObject);
00041
00044   static vtkObject* CreateInstance(const char* vtkclassname);
00045
00047   static const char *GetRenderLibrary();
00048
00049 protected:
00050   vtkGraphicsFactory() {};
00051 private:
00052   vtkGraphicsFactory(const vtkGraphicsFactory&);  // Not implemented.
00053   void operator=(const vtkGraphicsFactory&);  // Not implemented.
00054 };
00055
00056 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkGraphLayoutFilter.h Source File

Graphics/vtkGraphLayoutFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGraphLayoutFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkGraphLayoutFilter_h
00047 #define __vtkGraphLayoutFilter_h
00048
00049 #include "vtkPolyDataToPolyDataFilter.h"
00050
00051 class VTK_GRAPHICS_EXPORT vtkGraphLayoutFilter : public vtkPolyDataToPolyDataFilter
00052 {
00053 public:
00054   static vtkGraphLayoutFilter *New();
00055
00056   vtkTypeRevisionMacro(vtkGraphLayoutFilter,vtkPolyDataToPolyDataFilter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00063   vtkSetVector6Macro(GraphBounds,float);
00064   vtkGetVectorMacro(GraphBounds,float,6);
00066
00068
00071   vtkSetMacro(AutomaticBoundsComputation, int);
00072   vtkGetMacro(AutomaticBoundsComputation, int);
00073   vtkBooleanMacro(AutomaticBoundsComputation, int);
00075
00077
00080   vtkSetClampMacro(MaxNumberOfIterations, int, 0, VTK_LARGE_INTEGER);
00081   vtkGetMacro(MaxNumberOfIterations, int);
00083
00085
00088   vtkSetClampMacro(CoolDownRate, float, 0.01, VTK_LARGE_FLOAT);
00089   vtkGetMacro(CoolDownRate, float);
00091
00092   // Turn on/off layout of graph in three dimensions. If off, graph
00093   // layout occurs in two dimensions. By default, three dimensional
00094   // layout is on.
00095   vtkSetMacro(ThreeDimensionalLayout, int);
00096   vtkGetMacro(ThreeDimensionalLayout, int);
00097   vtkBooleanMacro(ThreeDimensionalLayout, int);
00098
00099 protected:
00100   vtkGraphLayoutFilter();
00101   ~vtkGraphLayoutFilter() {}
00102
00103   void Execute();
00104
00105   float GraphBounds[6];
00106   int   AutomaticBoundsComputation;  //Boolean controls automatic bounds calc.
00107   int   MaxNumberOfIterations;  //Maximum number of iterations.
00108   float CoolDownRate;  //Cool-down rate.  Note:  Higher # = Slower rate.
00109   int   ThreeDimensionalLayout;  //Boolean for a third dimension.
00110 private:
00111   vtkGraphLayoutFilter(const vtkGraphLayoutFilter&);  // Not implemented.
00112   void operator=(const vtkGraphLayoutFilter&);  // Not implemented.
00113 };
00114
00115 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkGridSynchronizedTemplates3D.h Source File

Patented/vtkGridSynchronizedTemplates3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGridSynchronizedTemplates3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENT PENDING.
00016
00017      Application of this software for commercial purposes requires
00018      a license grant from Kitware. Contact:
00019          Ken Martin
00020          Kitware
00021          469 Clifton Corporate Parkway,
00022          Clifton Park, NY 12065
00023          Phone:1-518-371-3971
00024      for more information.
00025
00026 =========================================================================*/
00052 #ifndef __vtkGridSynchronizedTemplates3D_h
00053 #define __vtkGridSynchronizedTemplates3D_h
00054
00055 #include "vtkStructuredGridToPolyDataFilter.h"
00056 #include "vtkContourValues.h"
00057 #include "vtkMultiThreader.h"
00058 #include "vtkKitwareContourFilter.h"
00059 #include "vtkFloatArray.h"
00060
00061
00062 class VTK_PATENTED_EXPORT vtkGridSynchronizedTemplates3D : public vtkStructuredGridToPolyDataFilter
00063 {
00064 public:
00065   static vtkGridSynchronizedTemplates3D *New();
00066   vtkTypeRevisionMacro(vtkGridSynchronizedTemplates3D,vtkStructuredGridToPolyDataFilter);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00070   unsigned long int GetMTime();
00071
00073
00077   vtkSetMacro(ComputeNormals,int);
00078   vtkGetMacro(ComputeNormals,int);
00079   vtkBooleanMacro(ComputeNormals,int);
00081
00083
00089   vtkSetMacro(ComputeGradients,int);
00090   vtkGetMacro(ComputeGradients,int);
00091   vtkBooleanMacro(ComputeGradients,int);
00093
00095
00096   vtkSetMacro(ComputeScalars,int);
00097   vtkGetMacro(ComputeScalars,int);
00098   vtkBooleanMacro(ComputeScalars,int);
00100
00103   void SetValue(int i, float value) {this->ContourValues->SetValue(i,value);}
00104
00106   float GetValue(int i) {return this->ContourValues->GetValue(i);}
00107
00110   float *GetValues() {return this->ContourValues->GetValues();}
00111
00113
00116   void GetValues(float *contourValues) {
00117     this->ContourValues->GetValues(contourValues);}
00119
00121
00124   void SetNumberOfContours(int number) {
00125     this->ContourValues->SetNumberOfContours(number);}
00127
00129
00130   int GetNumberOfContours() {
00131     return this->ContourValues->GetNumberOfContours();}
00133
00135
00137   void GenerateValues(int numContours, float range[2]) {
00138     this->ContourValues->GenerateValues(numContours, range);}
00140
00142
00144   void GenerateValues(int numContours, float rangeStart, float rangeEnd)
00145     {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00147
00149
00150   int *GetExecuteExtent() {return this->ExecuteExtent;}
00151   void ThreadedExecute(int *exExt, int threadId);
00153
00155
00156   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00157   vtkGetMacro( NumberOfThreads, int );
00159
00162   void SetInputMemoryLimit(long limit);
00163
00165
00168   vtkGetStringMacro(InputScalarsSelection);
00169   void SelectInputScalars(const char *fieldName)
00170     {this->SetInputScalarsSelection(fieldName);}
00172
00173 protected:
00174   vtkGridSynchronizedTemplates3D();
00175   ~vtkGridSynchronizedTemplates3D();
00176
00177   void Execute();
00178   void ExecuteInformation();
00179
00180   void ComputeInputUpdateExtents( vtkDataObject *output );
00181
00182   int ComputeNormals;
00183   int ComputeGradients;
00184   int ComputeScalars;
00185   vtkContourValues *ContourValues;
00186
00187   int NumberOfThreads;
00188   vtkMultiThreader *Threader;
00189   int MinimumPieceSize[3];
00190   int ExecuteExtent[6];
00191
00192   vtkPolyData *Threads[VTK_MAX_THREADS];
00193
00194   char *InputScalarsSelection;
00195   vtkSetStringMacro(InputScalarsSelection);
00196
00197 private:
00198   //BTX
00199   friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter;
00200   //ETX
00201 private:
00202   vtkGridSynchronizedTemplates3D(const vtkGridSynchronizedTemplates3D&);  // Not implemented.
00203   void operator=(const vtkGridSynchronizedTemplates3D&);  // Not implemented.
00204 };
00205
00206
00207 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkGridTransform.h Source File

Hybrid/vtkGridTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkGridTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkGridTransform_h
00041 #define __vtkGridTransform_h
00042
00043 #include "vtkWarpTransform.h"
00044 #include "vtkImageData.h"
00045
00046 #define VTK_GRID_NEAREST 0
00047 #define VTK_GRID_LINEAR 1
00048 #define VTK_GRID_CUBIC 3
00049
00050 class VTK_HYBRID_EXPORT vtkGridTransform : public vtkWarpTransform
00051 {
00052 public:
00053   static vtkGridTransform *New();
00054   vtkTypeRevisionMacro(vtkGridTransform,vtkWarpTransform);
00055   virtual void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00061   vtkSetObjectMacro(DisplacementGrid,vtkImageData);
00062   vtkGetObjectMacro(DisplacementGrid,vtkImageData);
00064
00066
00068   vtkSetMacro(DisplacementScale,float);
00069   vtkGetMacro(DisplacementScale,float);
00071
00073
00075   vtkSetMacro(DisplacementShift,float);
00076   vtkGetMacro(DisplacementShift,float);
00078
00080
00082   void SetInterpolationMode(int mode);
00083   vtkGetMacro(InterpolationMode,int);
00084   void SetInterpolationModeToNearestNeighbor()
00085     { this->SetInterpolationMode(VTK_GRID_NEAREST); };
00086   void SetInterpolationModeToLinear()
00087     { this->SetInterpolationMode(VTK_GRID_LINEAR); };
00088   void SetInterpolationModeToCubic()
00089     { this->SetInterpolationMode(VTK_GRID_CUBIC); };
00090   const char *GetInterpolationModeAsString();
00092
00094   vtkAbstractTransform *MakeTransform();
00095
00097   unsigned long GetMTime();
00098
00099 protected:
00100   vtkGridTransform();
00101   ~vtkGridTransform();
00102
00104   void InternalUpdate();
00105
00107   void InternalDeepCopy(vtkAbstractTransform *transform);
00108
00110
00111   void ForwardTransformPoint(const float in[3], float out[3]);
00112   void ForwardTransformPoint(const double in[3], double out[3]);
00114
00115   void ForwardTransformDerivative(const float in[3], float out[3],
00116                                   float derivative[3][3]);
00117   void ForwardTransformDerivative(const double in[3], double out[3],
00118                                   double derivative[3][3]);
00119
00120   void InverseTransformPoint(const float in[3], float out[3]);
00121   void InverseTransformPoint(const double in[3], double out[3]);
00122
00123   void InverseTransformDerivative(const float in[3], float out[3],
00124                                   float derivative[3][3]);
00125   void InverseTransformDerivative(const double in[3], double out[3],
00126                                   double derivative[3][3]);
00127
00128 //BTX
00129   void (*InterpolationFunction)(float point[3], float displacement[3],
00130                                 float derivatives[3][3],
00131                                 void *gridPtr, int gridType,
00132                                 int inExt[6], int inInc[3]);
00133 //ETX
00134   int InterpolationMode;
00135   vtkImageData *DisplacementGrid;
00136   float DisplacementScale;
00137   float DisplacementShift;
00138 private:
00139   vtkGridTransform(const vtkGridTransform&);  // Not implemented.
00140   void operator=(const vtkGridTransform&);  // Not implemented.
00141 };
00142
00143 //BTX
00144
00145 //----------------------------------------------------------------------------
00146 inline const char *vtkGridTransform::GetInterpolationModeAsString()
00147 {
00148   switch (this->InterpolationMode)
00149     {
00150     case VTK_GRID_NEAREST:
00151       return "NearestNeighbor";
00152     case VTK_GRID_LINEAR:
00153       return "Linear";
00154     case VTK_GRID_CUBIC:
00155       return "Cubic";
00156     default:
00157       return "";
00158     }
00159 }
00160 //ETX
00161
00162 #endif
00163
00164
00165
00166
00167
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkHeap.h Source File

Common/vtkHeap.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHeap.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkHeap_h
00046 #define __vtkHeap_h
00047
00048 #include "vtkObject.h"
00049
00050 //BTX
00051 class VTK_COMMON_EXPORT vtkHeapNode
00052 {
00053 public:
00054   void* Ptr;
00055   vtkHeapNode* Next;
00056   vtkHeapNode():Ptr(0),Next(0) {};
00057 };
00058 //ETX
00059
00060 class VTK_COMMON_EXPORT vtkHeap : public vtkObject
00061 {
00062 public:
00063   static vtkHeap *New();
00064   vtkTypeRevisionMacro(vtkHeap,vtkObject);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068   void* AllocateMemory(size_t n);
00069
00071   char* vtkStrDup(const char* str);
00072
00074
00075   vtkGetMacro(NumberOfAllocations,int);
00077
00078 protected:
00079   vtkHeap();
00080   ~vtkHeap();
00081
00082   void Add(vtkHeapNode* node);
00083   void CleanAll();
00084   vtkHeapNode* DeleteAndNext();
00085
00086   vtkHeapNode* First;
00087   vtkHeapNode* Last;
00088   vtkHeapNode* Current;
00089
00090   int NumberOfAllocations;
00091 private:
00092   vtkHeap(const vtkHeap&); // Not implemented.
00093   void operator=(const vtkHeap&);  // Not implemented.
00094 };
00095
00096 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkHedgeHog.h Source File

Graphics/vtkHedgeHog.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHedgeHog.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkHedgeHog_h
00044 #define __vtkHedgeHog_h
00045
00046 #include "vtkDataSetToPolyDataFilter.h"
00047
00048 #define VTK_USE_VECTOR 0
00049 #define VTK_USE_NORMAL 1
00050
00051 class VTK_GRAPHICS_EXPORT vtkHedgeHog : public vtkDataSetToPolyDataFilter
00052 {
00053 public:
00054   static vtkHedgeHog *New();
00055   vtkTypeRevisionMacro(vtkHedgeHog,vtkDataSetToPolyDataFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   vtkSetMacro(ScaleFactor,float);
00061   vtkGetMacro(ScaleFactor,float);
00063
00065
00066   vtkSetMacro(VectorMode,int);
00067   vtkGetMacro(VectorMode,int);
00068   void SetVectorModeToUseVector() {this->SetVectorMode(VTK_USE_VECTOR);};
00069   void SetVectorModeToUseNormal() {this->SetVectorMode(VTK_USE_NORMAL);};
00070   const char *GetVectorModeAsString();
00072
00073 protected:
00074   vtkHedgeHog();
00075   ~vtkHedgeHog() {};
00076
00077   void Execute();
00078   float ScaleFactor;
00079   int VectorMode; // Orient/scale via normal or via vector data
00080
00081 private:
00082   vtkHedgeHog(const vtkHedgeHog&);  // Not implemented.
00083   void operator=(const vtkHedgeHog&);  // Not implemented.
00084 };
00085
00087 inline const char *vtkHedgeHog::GetVectorModeAsString(void)
00088 {
00089   if ( this->VectorMode == VTK_USE_VECTOR)
00090     {
00091     return "UseVector";
00092     }
00093   else if ( this->VectorMode == VTK_USE_NORMAL)
00094     {
00095     return "UseNormal";
00096     }
00097   else
00098     {
00099     return "Unknown";
00100     }
00101 }
00102 #endif
00103
00104
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkHexahedron.h Source File

Common/vtkHexahedron.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHexahedron.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkHexahedron_h
00042 #define __vtkHexahedron_h
00043
00044 #include "vtkCell3D.h"
00045 #include "vtkLine.h"
00046 #include "vtkQuad.h"
00047
00048 class VTK_COMMON_EXPORT vtkHexahedron : public vtkCell3D
00049 {
00050 public:
00051   static vtkHexahedron *New();
00052   vtkTypeRevisionMacro(vtkHexahedron,vtkCell);
00053
00055
00056   virtual void GetEdgePoints(int edgeId, int* &pts);
00057   virtual void GetFacePoints(int faceId, int* &pts);
00059
00061
00062   vtkCell *MakeObject();
00063   int GetCellType() {return VTK_HEXAHEDRON;}
00064   int GetNumberOfEdges() {return 12;}
00065   int GetNumberOfFaces() {return 6;}
00066   vtkCell *GetEdge(int edgeId);
00067   vtkCell *GetFace(int faceId);
00068   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00069   void Contour(float value, vtkDataArray *cellScalars,
00070                vtkPointLocator *locator, vtkCellArray *verts,
00071                vtkCellArray *lines, vtkCellArray *polys,
00072                vtkPointData *inPd, vtkPointData *outPd,
00073                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00075
00076   int EvaluatePosition(float x[3], float* closestPoint,
00077                        int& subId, float pcoords[3],
00078                        float& dist2, float *weights);
00079   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00080                         float *weights);
00081   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00082                         float x[3], float pcoords[3], int& subId);
00083   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00084   void Derivatives(int subId, float pcoords[3], float *values,
00085                    int dim, float *derivs);
00086
00088
00089   static void InterpolationFunctions(float pcoords[3], float weights[8]);
00090   static void InterpolationDerivs(float pcoords[3], float derivs[24]);
00091   static int *GetEdgeArray(int edgeId);
00092   static int *GetFaceArray(int faceId);
00094
00098   void JacobianInverse(float pcoords[3], double **inverse, float derivs[24]);
00099
00100 protected:
00101   vtkHexahedron();
00102   ~vtkHexahedron();
00103
00104   vtkLine *Line;
00105   vtkQuad *Quad;
00106
00107 private:
00108   vtkHexahedron(const vtkHexahedron&);  // Not implemented.
00109   void operator=(const vtkHexahedron&);  // Not implemented.
00110 };
00111
00112 #endif
00113
00114
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkHomogeneousTransform.h Source File

Common/vtkHomogeneousTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHomogeneousTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkHomogeneousTransform_h
00037 #define __vtkHomogeneousTransform_h
00038
00039 #include "vtkAbstractTransform.h"
00040 #include "vtkMatrix4x4.h"
00041
00042 class VTK_COMMON_EXPORT vtkHomogeneousTransform : public vtkAbstractTransform
00043 {
00044 public:
00045
00046   vtkTypeRevisionMacro(vtkHomogeneousTransform,vtkAbstractTransform);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00051   void TransformPoints(vtkPoints *inPts, vtkPoints *outPts);
00052
00054
00056   virtual void TransformPointsNormalsVectors(vtkPoints *inPts,
00057                                              vtkPoints *outPts,
00058                                              vtkDataArray *inNms,
00059                                              vtkDataArray *outNms,
00060                                              vtkDataArray *inVrs,
00061                                              vtkDataArray *outVrs);
00063
00066   void GetMatrix(vtkMatrix4x4 *m);
00067
00072   vtkMatrix4x4 *GetMatrix() { this->Update(); return this->Matrix; };
00073
00075
00077   vtkHomogeneousTransform *GetHomogeneousInverse() {
00078     return (vtkHomogeneousTransform *)this->GetInverse(); };
00080
00082
00084   void InternalTransformPoint(const float in[3], float out[3]);
00085   void InternalTransformPoint(const double in[3], double out[3]);
00087
00089
00091   void InternalTransformDerivative(const float in[3], float out[3],
00092                                    float derivative[3][3]);
00093   void InternalTransformDerivative(const double in[3], double out[3],
00094                                    double derivative[3][3]);
00096
00097 protected:
00098   vtkHomogeneousTransform();
00099   ~vtkHomogeneousTransform();
00100
00101   void InternalDeepCopy(vtkAbstractTransform *transform);
00102
00103   vtkMatrix4x4 *Matrix;
00104 private:
00105   vtkHomogeneousTransform(const vtkHomogeneousTransform&);  // Not implemented.
00106   void operator=(const vtkHomogeneousTransform&);  // Not implemented.
00107 };
00108
00109 #endif
00110
00111
00112
00113
00114
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkHull.h Source File

Graphics/vtkHull.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHull.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkHull_h
00055 #define __vtkHull_h
00056
00057 #include "vtkPolyDataToPolyDataFilter.h"
00058
00059 class vtkPlanes;
00060
00061 class VTK_GRAPHICS_EXPORT vtkHull : public vtkPolyDataToPolyDataFilter
00062 {
00063 public:
00064   static vtkHull *New();
00065   vtkTypeRevisionMacro(vtkHull,vtkPolyDataToPolyDataFilter);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   void RemoveAllPlanes( void );
00070
00072
00081   int  AddPlane( float A, float B, float C );
00082   int  AddPlane( float plane[3] );
00084
00086
00092   void SetPlane( int i, float A, float B, float C );
00093   void SetPlane( int i, float plane[3] );
00095
00097
00099   int AddPlane( float A, float B, float C, float D );
00100   int AddPlane( float plane[3], float D );
00101   void SetPlane( int i, float A, float B, float C, float D );
00102   void SetPlane( int i, float plane[3], float D );
00104
00107   void SetPlanes( vtkPlanes *planes );
00108
00110
00111   vtkGetMacro( NumberOfPlanes, int );
00113
00118   void AddCubeVertexPlanes();
00119
00124   void AddCubeEdgePlanes();
00125
00128   void AddCubeFacePlanes();
00129
00137   void AddRecursiveSpherePlanes( int level );
00138
00140
00148   void GenerateHull(vtkPolyData *pd, float *bounds);
00149   void GenerateHull(vtkPolyData *pd, float xmin, float xmax,
00150                     float ymin, float ymax, float zmin, float zmax);
00152
00153 protected:
00154   vtkHull();
00155   ~vtkHull();
00156
00157   // The planes - 4 doubles per plane for A, B, C, D
00158   double     *Planes;
00159
00160   // This indicates the current size (in planes - 4*sizeof(float)) of
00161   // the this->Planes array. Planes are allocated in chunks so that the
00162   // array does not need to be reallocated every time a new plane is added
00163   int       PlanesStorageSize;
00164
00165   // The number of planes that have been added
00166   int       NumberOfPlanes;
00167
00168   // Internal method used to find the position of each plane
00169   void      ComputePlaneDistances();
00170
00171   // Internal method used to create the actual polygons from the set
00172   // of planes
00173   void      ClipPolygonsFromPlanes( vtkPoints *points, vtkCellArray *polys,
00174                                     float *bounds );
00175
00176   // Internal method used to create the initial "big" polygon from the
00177   // plane equation. This polygon is clipped by all other planes to form
00178   // the final polygon (or it may be clipped entirely)
00179   void      CreateInitialPolygon( double *, int, float * );
00180
00181   // The method that does it all...
00182   void      Execute();
00183 private:
00184   vtkHull(const vtkHull&);  // Not implemented.
00185   void operator=(const vtkHull&);  // Not implemented.
00186 };
00187
00188 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkHyperStreamline.h Source File

Graphics/vtkHyperStreamline.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkHyperStreamline.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkHyperStreamline_h
00063 #define __vtkHyperStreamline_h
00064
00065 #include "vtkDataSetToPolyDataFilter.h"
00066
00067 #define VTK_INTEGRATE_FORWARD 0
00068 #define VTK_INTEGRATE_BACKWARD 1
00069 #define VTK_INTEGRATE_BOTH_DIRECTIONS 2
00070
00071 class vtkHyperArray;
00072
00073 class VTK_GRAPHICS_EXPORT vtkHyperStreamline : public vtkDataSetToPolyDataFilter
00074 {
00075 public:
00076   vtkTypeRevisionMacro(vtkHyperStreamline,vtkDataSetToPolyDataFilter);
00077   void PrintSelf(ostream& os, vtkIndent indent);
00078
00083   static vtkHyperStreamline *New();
00084
00088   void SetStartLocation(vtkIdType cellId, int subId, float pcoords[3]);
00089
00091
00094   void SetStartLocation(vtkIdType cellId, int subId, float r, float s,
00095                         float t);
00097
00100   vtkIdType GetStartLocation(int& subId, float pcoords[3]);
00101
00105   void SetStartPosition(float x[3]);
00106
00110   void SetStartPosition(float x, float y, float z);
00111
00114   float *GetStartPosition();
00115
00117
00119   vtkSetClampMacro(MaximumPropagationDistance,float,0.0,VTK_LARGE_FLOAT);
00120   vtkGetMacro(MaximumPropagationDistance,float);
00122
00126   void IntegrateMajorEigenvector();
00127
00131   void IntegrateMediumEigenvector();
00132
00136   void IntegrateMinorEigenvector();
00137
00139
00141   vtkSetClampMacro(IntegrationStepLength,float,0.001,0.5);
00142   vtkGetMacro(IntegrationStepLength,float);
00144
00146
00149   vtkSetClampMacro(StepLength,float,0.000001,1.0);
00150   vtkGetMacro(StepLength,float);
00152
00154
00155   vtkSetClampMacro(IntegrationDirection,int,
00156                   VTK_INTEGRATE_FORWARD,VTK_INTEGRATE_BOTH_DIRECTIONS);
00157   vtkGetMacro(IntegrationDirection,int);
00158   void SetIntegrationDirectionToForward()
00159     {this->SetIntegrationDirection(VTK_INTEGRATE_FORWARD);};
00160   void SetIntegrationDirectionToBackward()
00161     {this->SetIntegrationDirection(VTK_INTEGRATE_BACKWARD);};
00162   void SetIntegrationDirectionToIntegrateBothDirections()
00163     {this->SetIntegrationDirection(VTK_INTEGRATE_BOTH_DIRECTIONS);};
00165
00167
00169   vtkSetClampMacro(TerminalEigenvalue,float,0.0,VTK_LARGE_FLOAT);
00170   vtkGetMacro(TerminalEigenvalue,float);
00172
00174
00176   vtkSetClampMacro(NumberOfSides,int,3,VTK_LARGE_INTEGER);
00177   vtkGetMacro(NumberOfSides,int);
00179
00181
00185   vtkSetClampMacro(Radius,float,0.0001,VTK_LARGE_FLOAT);
00186   vtkGetMacro(Radius,float);
00188
00190
00192   vtkSetMacro(LogScaling,int);
00193   vtkGetMacro(LogScaling,int);
00194   vtkBooleanMacro(LogScaling,int);
00196
00197 protected:
00198   vtkHyperStreamline();
00199   ~vtkHyperStreamline();
00200
00201   // Integrate data
00202   void Execute();
00203   void BuildTube();
00204
00205   // Flag indicates where streamlines start from (either position or location)
00206   int StartFrom;
00207
00208   // Starting from cell location
00209   vtkIdType StartCell;
00210   int StartSubId;
00211   float StartPCoords[3];
00212
00213   // starting from global x-y-z position
00214   float StartPosition[3];
00215
00216   //array of hyperstreamlines
00217   vtkHyperArray *Streamers;
00218   int NumberOfStreamers;
00219
00220   // length of hyperstreamline in absolute distance
00221   float MaximumPropagationDistance;
00222
00223   // integration direction
00224   int IntegrationDirection;
00225
00226   // the length (fraction of cell size) of integration steps
00227   float IntegrationStepLength;
00228
00229   // the length of the tube segments composing the hyperstreamline
00230   float StepLength;
00231
00232   // terminal propagation speed
00233   float TerminalEigenvalue;
00234
00235   // number of sides of tube
00236   int NumberOfSides;
00237
00238   // maximum radius of tube
00239   float Radius;
00240
00241   // boolean controls whether scaling is clamped
00242   int LogScaling;
00243
00244   // which eigenvector to use as integration vector field
00245   int IntegrationEigenvector;
00246 private:
00247   vtkHyperStreamline(const vtkHyperStreamline&);  // Not implemented.
00248   void operator=(const vtkHyperStreamline&);  // Not implemented.
00249 };
00250
00251 #endif
00252
00253
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkIdentityTransform.h Source File

Common/vtkIdentityTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIdentityTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkIdentityTransform_h
00040 #define __vtkIdentityTransform_h
00041
00042 #include "vtkLinearTransform.h"
00043
00044 class VTK_COMMON_EXPORT vtkIdentityTransform : public vtkLinearTransform
00045 {
00046 public:
00047   static vtkIdentityTransform *New();
00048
00049   vtkTypeRevisionMacro(vtkIdentityTransform,vtkLinearTransform);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00054   void TransformPoints(vtkPoints *inPts, vtkPoints *outPts);
00055
00058   void TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms);
00059
00062   void TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs);
00063
00065
00067   void TransformPointsNormalsVectors(vtkPoints *inPts,
00068                                      vtkPoints *outPts,
00069                                      vtkDataArray *inNms,
00070                                      vtkDataArray *outNms,
00071                                      vtkDataArray *inVrs,
00072                                      vtkDataArray *outVrs);
00074
00075   // Invert the transformation.  This doesn't do anything to the
00076   // identity transformation.
00077   void Inverse() {};
00078
00080
00082   void InternalTransformPoint(const float in[3], float out[3]);
00083   void InternalTransformPoint(const double in[3], double out[3]);
00085
00087
00089   void InternalTransformNormal(const float in[3], float out[3]);
00090   void InternalTransformNormal(const double in[3], double out[3]);
00092
00094
00096   void InternalTransformVector(const float in[3], float out[3]);
00097   void InternalTransformVector(const double in[3], double out[3]);
00099
00101
00103   void InternalTransformDerivative(const float in[3], float out[3],
00104                                    float derivative[3][3]);
00105   void InternalTransformDerivative(const double in[3], double out[3],
00106                                    double derivative[3][3]);
00108
00111   vtkAbstractTransform *MakeTransform();
00112
00113 protected:
00114   vtkIdentityTransform();
00115   ~vtkIdentityTransform();
00116
00117   void InternalDeepCopy(vtkAbstractTransform *t);
00118
00119 private:
00120   vtkIdentityTransform(const vtkIdentityTransform&);  // Not implemented.
00121   void operator=(const vtkIdentityTransform&);  // Not implemented.
00122 };
00123
00124 #endif
00125
00126
00127
00128
00129
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkIdFilter.h Source File

Graphics/vtkIdFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIdFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkIdFilter_h
00048 #define __vtkIdFilter_h
00049
00050 #include "vtkDataSetToDataSetFilter.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkIdFilter : public vtkDataSetToDataSetFilter
00053 {
00054 public:
00055   vtkTypeRevisionMacro(vtkIdFilter,vtkDataSetToDataSetFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00060   static vtkIdFilter *New();
00061
00063
00064   vtkSetMacro(PointIds,int);
00065   vtkGetMacro(PointIds,int);
00066   vtkBooleanMacro(PointIds,int);
00068
00070
00071   vtkSetMacro(CellIds,int);
00072   vtkGetMacro(CellIds,int);
00073   vtkBooleanMacro(CellIds,int);
00075
00077
00080   vtkSetMacro(FieldData,int);
00081   vtkGetMacro(FieldData,int);
00082   vtkBooleanMacro(FieldData,int);
00084
00086
00089   vtkSetStringMacro(IdsArrayName);
00090   vtkGetStringMacro(IdsArrayName);
00092
00093 protected:
00094   vtkIdFilter();
00095   ~vtkIdFilter();
00096
00097   void Execute();
00098
00099   int PointIds;
00100   int CellIds;
00101   int FieldData;
00102   char *IdsArrayName;
00103
00104 private:
00105   vtkIdFilter(const vtkIdFilter&);  // Not implemented.
00106   void operator=(const vtkIdFilter&);  // Not implemented.
00107 };
00108
00109 #endif
00110
00111
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkIdList.h Source File

Common/vtkIdList.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIdList.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkIdList_h
00044 #define __vtkIdList_h
00045
00046 #include "vtkObject.h"
00047
00048 class VTK_COMMON_EXPORT vtkIdList : public vtkObject
00049 {
00050 public:
00051   static vtkIdList *New();
00052
00053   void Initialize();
00054   int Allocate(const int sz, const int strategy=0);
00055   vtkTypeRevisionMacro(vtkIdList,vtkObject);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059   vtkIdType GetNumberOfIds() {return this->NumberOfIds;};
00060
00062   vtkIdType GetId(const int i) {return this->Ids[i];};
00063
00066   void SetNumberOfIds(const vtkIdType number);
00067
00071   void SetId(const vtkIdType i, const vtkIdType id) {this->Ids[i] = id;};
00072
00075   void InsertId(const vtkIdType i, const vtkIdType id);
00076
00079   vtkIdType InsertNextId(const vtkIdType id);
00080
00083   vtkIdType InsertUniqueId(const vtkIdType id);
00084
00086   vtkIdType *GetPointer(const vtkIdType i) {return this->Ids + i;};
00087
00091   vtkIdType *WritePointer(const vtkIdType i, const vtkIdType number);
00092
00094   void Reset() {this->NumberOfIds = 0;};
00095
00097   void Squeeze() {this->Resize(this->NumberOfIds);};
00098
00100   void DeepCopy(vtkIdList *ids);
00101
00104   void DeleteId(vtkIdType id);
00105
00108   vtkIdType IsId(vtkIdType id);
00109
00112   void IntersectWith(vtkIdList& otherIds);
00113
00114 protected:
00115   vtkIdList();
00116   ~vtkIdList();
00117
00118   vtkIdType NumberOfIds;
00119   vtkIdType Size;
00120   vtkIdType *Ids;
00121
00122   vtkIdType *Resize(const vtkIdType sz);
00123 private:
00124   vtkIdList(const vtkIdList&);  // Not implemented.
00125   void operator=(const vtkIdList&);  // Not implemented.
00126 };
00127
00128 // In-lined for performance
00129 inline vtkIdType vtkIdList::InsertNextId(const vtkIdType id)
00130 {
00131   if ( this->NumberOfIds >= this->Size )
00132     {
00133     this->Resize(this->NumberOfIds+1);
00134     }
00135   this->Ids[this->NumberOfIds++] = id;
00136   return this->NumberOfIds-1;
00137 }
00138
00139 inline vtkIdType vtkIdList::IsId(vtkIdType id)
00140 {
00141   vtkIdType *ptr, i;
00142   for (ptr=this->Ids, i=0; i<this->NumberOfIds; i++, ptr++)
00143     {
00144     if ( id == *ptr )
00145       {
00146       return i;
00147       }
00148     }
00149   return (-1);
00150 }
00151
00152 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkIdTypeArray.h Source File

Common/vtkIdTypeArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIdTypeArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkIdTypeArray_h
00037 #define __vtkIdTypeArray_h
00038
00039 #include "vtkDataArray.h"
00040
00041 class VTK_COMMON_EXPORT vtkIdTypeArray : public vtkDataArray
00042 {
00043 public:
00044   static vtkIdTypeArray *New();
00045
00046   vtkTypeRevisionMacro(vtkIdTypeArray, vtkDataArray);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00051   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00052
00054   void Initialize();
00055
00057   vtkDataArray *MakeObject();
00058
00060
00061   int GetDataType()
00062     {return VTK_ID_TYPE;}
00064
00066   int GetDataTypeSize() { return sizeof(vtkIdType); }
00067
00069
00070   void Squeeze()
00071     {this->ResizeAndExtend (this->MaxId+1);}
00073
00075   virtual void Resize(vtkIdType numTuples);
00076
00078   void SetNumberOfTuples(const vtkIdType number);
00079
00082   float *GetTuple(const vtkIdType i);
00083
00085
00086   void GetTuple(const vtkIdType i, float * tuple);
00087   void GetTuple(const vtkIdType i, double * tuple);
00089
00091
00092   void SetTuple(const vtkIdType i, const float * tuple);
00093   void SetTuple(const vtkIdType i, const double * tuple);
00095
00097
00099   void InsertTuple(const vtkIdType i, const float * tuple);
00100   void InsertTuple(const vtkIdType i, const double * tuple);
00102
00104
00106   vtkIdType InsertNextTuple(const float * tuple);
00107   vtkIdType InsertNextTuple(const double * tuple);
00109
00111
00112   vtkIdType GetValue(const vtkIdType id)
00113     {return this->Array[id];}
00115
00117
00119   void SetValue(const vtkIdType id, const vtkIdType value)
00120     {this->Array[id] = value;}
00122
00126   void SetNumberOfValues(const vtkIdType number);
00127
00129   void InsertValue(const vtkIdType id, const vtkIdType i);
00130
00133   vtkIdType InsertNextValue(const vtkIdType i);
00134
00136
00138   vtkIdType *GetPointer(const vtkIdType id)
00139     {return this->Array + id;}
00140   void *GetVoidPointer(const vtkIdType id)
00141     {return (void *)this->GetPointer(id);}
00143
00147   vtkIdType *WritePointer(const vtkIdType id, const vtkIdType number);
00148
00150   void DeepCopy(vtkDataArray *ia);
00151
00153
00159   void SetArray(vtkIdType* array, vtkIdType size, int save);
00160   void SetVoidArray(void *array, vtkIdType size, int save)
00161     {this->SetArray((vtkIdType*)array, size, save);};
00163
00164 protected:
00165   vtkIdTypeArray(vtkIdType numComp=1);
00166   ~vtkIdTypeArray();
00167
00168   vtkIdType *Array;   // pointer to data
00169   vtkIdType *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00170
00171   int TupleSize; //used for data conversion
00172   float *Tuple;
00173
00174   int SaveUserArray;
00175 private:
00176   vtkIdTypeArray(const vtkIdTypeArray&);  // Not implemented.
00177   void operator=(const vtkIdTypeArray&);  // Not implemented.
00178 };
00179
00180
00181 inline void vtkIdTypeArray::SetNumberOfValues(const vtkIdType number)
00182 {
00183   this->Allocate(number);
00184   this->MaxId = number - 1;
00185 }
00186
00187 inline vtkIdType *vtkIdTypeArray::WritePointer(const vtkIdType id,
00188                                                const vtkIdType number)
00189 {
00190   vtkIdType newSize=id+number;
00191   if ( newSize > this->Size )
00192     {
00193     this->ResizeAndExtend(newSize);
00194     }
00195   if ( (--newSize) > this->MaxId )
00196     {
00197     this->MaxId = newSize;
00198     }
00199   return this->Array + id;
00200 }
00201
00202 inline void vtkIdTypeArray::InsertValue(const vtkIdType id, const vtkIdType i)
00203 {
00204   if ( id >= this->Size )
00205     {
00206     this->ResizeAndExtend(id+1);
00207     }
00208   this->Array[id] = i;
00209   if ( id > this->MaxId )
00210     {
00211     this->MaxId = id;
00212     }
00213 }
00214
00215 inline vtkIdType vtkIdTypeArray::InsertNextValue(const vtkIdType i)
00216 {
00217   this->InsertValue (++this->MaxId,i);
00218   return this->MaxId;
00219 }
00220
00221
00222 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageAccumulate.h Source File

Imaging/vtkImageAccumulate.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageAccumulate.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkImageAccumulate_h
00053 #define __vtkImageAccumulate_h
00054
00055
00056 #include "vtkImageToImageFilter.h"
00057 #include "vtkImageStencilData.h"
00058
00059 class VTK_IMAGING_EXPORT vtkImageAccumulate : public vtkImageToImageFilter
00060 {
00061 public:
00062   static vtkImageAccumulate *New();
00063   vtkTypeRevisionMacro(vtkImageAccumulate,vtkImageToImageFilter);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067
00072   vtkSetVector3Macro(ComponentSpacing, float);
00073   vtkGetVector3Macro(ComponentSpacing, float);
00075
00077
00083   vtkSetVector3Macro(ComponentOrigin, float);
00084   vtkGetVector3Macro(ComponentOrigin, float);
00086
00088
00093   void SetComponentExtent(int extent[6]);
00094   void SetComponentExtent(int minX, int maxX, int minY, int maxY,
00095         int minZ, int maxZ);
00096   void GetComponentExtent(int extent[6]);
00097   int *GetComponentExtent() {return this->ComponentExtent;}
00099
00100
00102
00103   void SetStencil(vtkImageStencilData *stencil);
00104   vtkImageStencilData *GetStencil();
00106
00108
00109   vtkSetMacro(ReverseStencil, int);
00110   vtkBooleanMacro(ReverseStencil, int);
00111   vtkGetMacro(ReverseStencil, int);
00113
00115
00116   vtkGetVector3Macro(Min, double);
00117   vtkGetVector3Macro(Max, double);
00118   vtkGetVector3Macro(Mean, double);
00119   vtkGetVector3Macro(StandardDeviation, double);
00120   vtkGetMacro(VoxelCount, long int);
00122
00123
00124 protected:
00125   vtkImageAccumulate();
00126   ~vtkImageAccumulate();
00127
00128   float ComponentSpacing[3];
00129   float ComponentOrigin[3];
00130   int ComponentExtent[6];
00131
00132   void ExecuteInformation(vtkImageData *input, vtkImageData *output);
00133   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00134   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00135   void ExecuteData(vtkDataObject *out);
00136
00137   double Min[3];
00138   double Max[3];
00139   double Mean[3];
00140   double StandardDeviation[3];
00141   long int VoxelCount;
00142
00143   int ReverseStencil;
00144
00145 private:
00146   vtkImageAccumulate(const vtkImageAccumulate&);  // Not implemented.
00147   void operator=(const vtkImageAccumulate&);  // Not implemented.
00148 };
00149
00150 #endif
00151
00152
00153
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImageActor.h Source File

Rendering/vtkImageActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkImageActor_h
00052 #define __vtkImageActor_h
00053
00054 #include "vtkProp.h"
00055 #include "vtkImageData.h"
00056
00057 class vtkPropCollection;
00058 class vtkRenderer;
00059
00060 class VTK_RENDERING_EXPORT vtkImageActor : public vtkProp
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkImageActor,vtkProp);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067   static vtkImageActor *New();
00068
00070
00071   virtual void SetInput(vtkImageData *);
00072   vtkGetObjectMacro(Input,vtkImageData);
00074
00076
00077   vtkGetMacro(Interpolate,int);
00078   vtkSetMacro(Interpolate,int);
00079   vtkBooleanMacro(Interpolate,int);
00081
00083
00085   void SetDisplayExtent(int extent[6]);
00086   void SetDisplayExtent(int minX, int maxX, int minY, int maxY,
00087                         int minZ, int maxZ);
00088   void GetDisplayExtent(int extent[6]);
00089   int *GetDisplayExtent() {return this->DisplayExtent;}
00091
00093
00097   float *GetBounds();
00098   void GetBounds(float bounds[6]);
00100
00102   int GetSliceNumber();
00103
00104 //BTX
00106   /*! WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE
00107       THIS METHOD OUTSIDE OF THE RENDERING PROCESS Support the standard
00108       render methods. int RenderTranslucentGeometry(vtkViewport *viewport); */
00109   int RenderOpaqueGeometry(vtkViewport *viewport);
00110   virtual void Load(vtkRenderer *) {};
00112 //ETX
00113
00115
00122   void SetZSlice(int z) {this->SetDisplayExtent(
00123     this->DisplayExtent[0], this->DisplayExtent[1],
00124     this->DisplayExtent[2], this->DisplayExtent[3], z, z);
00125   };
00127
00128   int GetZSlice() { return this->DisplayExtent[4];};
00129   int GetWholeZMin();
00130   int GetWholeZMax();
00131
00132 protected:
00133   vtkImageActor();
00134   ~vtkImageActor();
00135
00136   int           Interpolate;
00137   vtkImageData* Input;
00138   int           DisplayExtent[6];
00139   float         Bounds[6];
00140 private:
00141   vtkImageActor(const vtkImageActor&);  // Not implemented.
00142   void operator=(const vtkImageActor&);  // Not implemented.
00143 };
00144
00145 #endif
00146
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageAnisotropicDiffusion2D.h Source File

Imaging/vtkImageAnisotropicDiffusion2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageAnisotropicDiffusion2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkImageAnisotropicDiffusion2D_h
00054 #define __vtkImageAnisotropicDiffusion2D_h
00055
00056
00057 #include "vtkImageSpatialFilter.h"
00058 class VTK_IMAGING_EXPORT vtkImageAnisotropicDiffusion2D : public vtkImageSpatialFilter
00059 {
00060 public:
00061   static vtkImageAnisotropicDiffusion2D *New();
00062   vtkTypeRevisionMacro(vtkImageAnisotropicDiffusion2D,vtkImageSpatialFilter);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00070   void SetNumberOfIterations(int num);
00071
00073
00074   vtkGetMacro(NumberOfIterations,int);
00076
00078
00083   vtkSetMacro(DiffusionThreshold,float);
00084   vtkGetMacro(DiffusionThreshold,float);
00086
00088
00092   vtkSetMacro(DiffusionFactor,float);
00093   vtkGetMacro(DiffusionFactor,float);
00095
00097
00098   vtkSetMacro(Faces,int);
00099   vtkGetMacro(Faces,int);
00100   vtkBooleanMacro(Faces,int);
00101   vtkSetMacro(Edges,int);
00102   vtkGetMacro(Edges,int);
00103   vtkBooleanMacro(Edges,int);
00104   vtkSetMacro(Corners,int);
00105   vtkGetMacro(Corners,int);
00106   vtkBooleanMacro(Corners,int);
00108
00110
00112   vtkSetMacro(GradientMagnitudeThreshold,int);
00113   vtkGetMacro(GradientMagnitudeThreshold,int);
00114   vtkBooleanMacro(GradientMagnitudeThreshold,int);
00116
00117 protected:
00118   vtkImageAnisotropicDiffusion2D();
00119   ~vtkImageAnisotropicDiffusion2D() {};
00120
00121   int NumberOfIterations;
00122   float DiffusionThreshold;
00123   float DiffusionFactor;
00124   // to determine which neighbors to diffuse
00125   int Faces;
00126   int Edges;
00127   int Corners;
00128   // What threshold to use
00129   int GradientMagnitudeThreshold;
00130
00131   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00132                        int extent[6], int id);
00133   void Iterate(vtkImageData *in, vtkImageData *out,
00134                float ar0, float ar1, int *coreExtent, int count);
00135 private:
00136   vtkImageAnisotropicDiffusion2D(const vtkImageAnisotropicDiffusion2D&);  // Not implemented.
00137   void operator=(const vtkImageAnisotropicDiffusion2D&);  // Not implemented.
00138 };
00139
00140 #endif
00141
00142
00143
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageAnisotropicDiffusion3D.h Source File

Imaging/vtkImageAnisotropicDiffusion3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageAnisotropicDiffusion3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkImageAnisotropicDiffusion3D_h
00055 #define __vtkImageAnisotropicDiffusion3D_h
00056
00057
00058 #include "vtkImageSpatialFilter.h"
00059
00060 class VTK_IMAGING_EXPORT vtkImageAnisotropicDiffusion3D : public vtkImageSpatialFilter
00061 {
00062 public:
00063   static vtkImageAnisotropicDiffusion3D *New();
00064   vtkTypeRevisionMacro(vtkImageAnisotropicDiffusion3D,vtkImageSpatialFilter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00067
00073   void SetNumberOfIterations(int num);
00074
00076
00077   vtkGetMacro(NumberOfIterations,int);
00079
00081
00086   vtkSetMacro(DiffusionThreshold,float);
00087   vtkGetMacro(DiffusionThreshold,float);
00089
00091
00092   vtkSetMacro(DiffusionFactor,float);
00093   vtkGetMacro(DiffusionFactor,float);
00095
00097
00098   vtkSetMacro(Faces,int);
00099   vtkGetMacro(Faces,int);
00100   vtkBooleanMacro(Faces,int);
00101   vtkSetMacro(Edges,int);
00102   vtkGetMacro(Edges,int);
00103   vtkBooleanMacro(Edges,int);
00104   vtkSetMacro(Corners,int);
00105   vtkGetMacro(Corners,int);
00106   vtkBooleanMacro(Corners,int);
00108
00110
00112   vtkSetMacro(GradientMagnitudeThreshold,int);
00113   vtkGetMacro(GradientMagnitudeThreshold,int);
00114   vtkBooleanMacro(GradientMagnitudeThreshold,int);
00116
00117 protected:
00118   vtkImageAnisotropicDiffusion3D();
00119   ~vtkImageAnisotropicDiffusion3D() {};
00120
00121   int NumberOfIterations;
00122   float DiffusionThreshold;
00123   float DiffusionFactor;
00124   // to determine which neighbors to diffuse
00125   int Faces;
00126   int Edges;
00127   int Corners;
00128   // What threshold to use
00129   int GradientMagnitudeThreshold;
00130
00131   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00132                        int extent[6], int id);
00133   void Iterate(vtkImageData *in, vtkImageData *out,
00134                float ar0, float ar1, float ar3, int *coreExtent, int count);
00135 private:
00136   vtkImageAnisotropicDiffusion3D(const vtkImageAnisotropicDiffusion3D&);  // Not implemented.
00137   void operator=(const vtkImageAnisotropicDiffusion3D&);  // Not implemented.
00138 };
00139
00140 #endif
00141
00142
00143
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageAppend.h Source File

Imaging/vtkImageAppend.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageAppend.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageAppend_h
00042 #define __vtkImageAppend_h
00043
00044
00045 #include "vtkImageMultipleInputFilter.h"
00046
00047 class VTK_IMAGING_EXPORT vtkImageAppend : public vtkImageMultipleInputFilter
00048 {
00049 public:
00050   static vtkImageAppend *New();
00051   vtkTypeRevisionMacro(vtkImageAppend,vtkImageMultipleInputFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00058   vtkSetMacro(AppendAxis, int);
00059   vtkGetMacro(AppendAxis, int);
00061
00063
00069   vtkSetMacro(PreserveExtents, int);
00070   vtkGetMacro(PreserveExtents, int);
00071   vtkBooleanMacro(PreserveExtents, int);
00073
00074 protected:
00075   vtkImageAppend();
00076   ~vtkImageAppend();
00077
00078   int PreserveExtents;
00079   int AppendAxis;
00080   // Array holds the AppendAxisExtent shift for each input.
00081   int *Shifts;
00082
00083   void ExecuteInformation(vtkImageData **inputs, vtkImageData *output);
00084   void ComputeInputUpdateExtent(int inExt[6], int outExt[6], int whichInput);
00085   void ExecuteInformation(){this->vtkImageMultipleInputFilter::ExecuteInformation();};
00086
00087   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00088                        int extent[6], int id);
00089
00090   void InitOutput(int outExt[6], vtkImageData *outData);
00091 private:
00092   vtkImageAppend(const vtkImageAppend&);  // Not implemented.
00093   void operator=(const vtkImageAppend&);  // Not implemented.
00094 };
00095
00096 #endif
00097
00098
00099
00100
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageAppendComponents.h Source File

Imaging/vtkImageAppendComponents.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageAppendComponents.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageAppendComponents_h
00041 #define __vtkImageAppendComponents_h
00042
00043
00044 #include "vtkImageMultipleInputFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageAppendComponents : public vtkImageMultipleInputFilter
00047 {
00048 public:
00049   static vtkImageAppendComponents *New();
00050   vtkTypeRevisionMacro(vtkImageAppendComponents,vtkImageMultipleInputFilter);
00051
00052 #ifndef VTK_REMOVE_LEGACY_CODE
00053
00054
00056   virtual void SetInput1(vtkImageData *input)
00057     {VTK_LEGACY_METHOD(SetInput,"3.2"); this->SetInput(0, input);}
00058   virtual void SetInput2(vtkImageData *input)
00059     {VTK_LEGACY_METHOD(SetInput,"3.2"); this->SetInput(1, input);}
00061 #endif
00062
00063 protected:
00064   vtkImageAppendComponents() {};
00065   ~vtkImageAppendComponents() {};
00066
00067   void ExecuteInformation(vtkImageData **inputs, vtkImageData *output);
00068   void ExecuteInformation(){this->vtkImageMultipleInputFilter::ExecuteInformation();};
00069   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00070                        int extent[6], int id);
00071 private:
00072   vtkImageAppendComponents(const vtkImageAppendComponents&);  // Not implemented.
00073   void operator=(const vtkImageAppendComponents&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
00079
00080
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageBlend.h Source File

Imaging/vtkImageBlend.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageBlend.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00087 #ifndef __vtkImageBlend_h
00088 #define __vtkImageBlend_h
00089
00090
00091 #include "vtkImageMultipleInputFilter.h"
00092 #include "vtkImageStencilData.h"
00093
00094 #define VTK_IMAGE_BLEND_MODE_NORMAL    0
00095 #define VTK_IMAGE_BLEND_MODE_COMPOUND 1
00096
00097 class VTK_IMAGING_EXPORT vtkImageBlend : public vtkImageMultipleInputFilter
00098 {
00099 public:
00100   static vtkImageBlend *New();
00101   vtkTypeRevisionMacro(vtkImageBlend,vtkImageMultipleInputFilter);
00102   void PrintSelf(ostream& os, vtkIndent indent);
00103
00105
00107   void SetOpacity(int idx, double opacity);
00108   double GetOpacity(int idx);
00110
00112
00113   vtkSetObjectMacro(Stencil, vtkImageStencilData);
00114   vtkGetObjectMacro(Stencil, vtkImageStencilData);
00116
00118
00119   vtkSetClampMacro(BlendMode,int,
00120                    VTK_IMAGE_BLEND_MODE_NORMAL,
00121                    VTK_IMAGE_BLEND_MODE_COMPOUND );
00122   vtkGetMacro(BlendMode,int);
00123   void SetBlendModeToNormal()
00124         {this->SetBlendMode(VTK_IMAGE_BLEND_MODE_NORMAL);};
00125   void SetBlendModeToCompound()
00126         {this->SetBlendMode(VTK_IMAGE_BLEND_MODE_COMPOUND);};
00127   const char *GetBlendModeAsString(void);
00129
00131
00133   vtkSetMacro(CompoundThreshold,float);
00134   vtkGetMacro(CompoundThreshold,float);
00136
00137 protected:
00138   vtkImageBlend();
00139   ~vtkImageBlend();
00140
00141   void ComputeInputUpdateExtent(int inExt[6], int outExt[6],
00142                                 int whichInput);
00143
00144   void ExecuteInformation() {
00145     this->vtkImageMultipleInputFilter::ExecuteInformation(); };
00146
00147   void ExecuteInformation(vtkImageData **, vtkImageData *);
00148
00149   void ThreadedExecute(vtkImageData **inDatas,
00150                        vtkImageData *outData,
00151                        int extent[6],
00152                        int id);
00153
00154   void ExecuteData(vtkDataObject *output);
00155
00156   vtkImageStencilData *Stencil;
00157   double *Opacity;
00158   int OpacityArrayLength;
00159   int BlendMode;
00160   float CompoundThreshold;
00161   int DataWasPassed;
00162 private:
00163   vtkImageBlend(const vtkImageBlend&);  // Not implemented.
00164   void operator=(const vtkImageBlend&);  // Not implemented.
00165 };
00166
00168 inline const char *vtkImageBlend::GetBlendModeAsString()
00169 {
00170   switch (this->BlendMode)
00171     {
00172     case VTK_IMAGE_BLEND_MODE_NORMAL:
00173       return "Normal";
00174     case VTK_IMAGE_BLEND_MODE_COMPOUND:
00175       return "Compound";
00176     default:
00177       return "Unknown Blend Mode";
00178     }
00179 }
00180
00181
00182 #endif
00183
00184
00185
00186
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkImageBlockReader.h Source File

Parallel/vtkImageBlockReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageBlockReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageBlockReader_h
00036 #define __vtkImageBlockReader_h
00037
00038 #include "vtkImageSource.h"
00039
00040
00041 class VTK_PARALLEL_EXPORT vtkImageBlockReader : public vtkImageSource
00042 {
00043 public:
00044   static vtkImageBlockReader *New();
00045   vtkTypeRevisionMacro(vtkImageBlockReader,vtkImageSource);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkSetVector3Macro(Divisions, int);
00052   vtkGetVector3Macro(Divisions, int);
00054
00056
00058   vtkSetMacro(Overlap, int);
00059   vtkGetMacro(Overlap, int);
00061
00063
00065   vtkSetVector6Macro(WholeExtent, int);
00066   vtkGetVector6Macro(WholeExtent, int);
00068
00070
00072   vtkSetMacro(NumberOfScalarComponents, int);
00073   vtkGetMacro(NumberOfScalarComponents, int);
00075
00077
00079   vtkSetMacro(ScalarType, int);
00080   vtkGetMacro(ScalarType, int);
00082
00084
00085   vtkSetStringMacro(FilePattern);
00086   vtkGetStringMacro(FilePattern);
00088
00089
00090
00091 protected:
00092   vtkImageBlockReader();
00093   ~vtkImageBlockReader();
00094
00095   char *FilePattern;
00096
00097   int WholeExtent[6];
00098   int NumberOfScalarComponents;
00099   int ScalarType;
00100   int Divisions[3];
00101   int Overlap;
00102
00103
00105
00106   void Execute(vtkImageData *data);
00107   void ExecuteInformation();
00109
00110   // This method computes the XYZExtents.
00111   void ComputeBlockExtents();
00112   void DeleteBlockExtents();
00113
00114   // helper methods
00115   void Read(vtkImageData *data, int *ext);
00116   void ReadRemainder(vtkImageData *data, int *ext, int *doneExt);
00117   void ReadBlock(int xIdx, int yIdx, int zIdx,
00118                  vtkImageData *data, int *ext);
00119
00122   void ModifyOutputUpdateExtent();
00123
00124   // extents (min, max) of the divisions.
00125   int *XExtents;
00126   int *YExtents;
00127   int *ZExtents;
00128 private:
00129   vtkImageBlockReader(const vtkImageBlockReader&);  // Not implemented.
00130   void operator=(const vtkImageBlockReader&);  // Not implemented.
00131 };
00132
00133
00134 #endif
00135
00136
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkImageBlockWriter.h Source File

Parallel/vtkImageBlockWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageBlockWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageBlockWriter_h
00036 #define __vtkImageBlockWriter_h
00037
00038 #include "vtkProcessObject.h"
00039 #include "vtkImageData.h"
00040
00041 class VTK_PARALLEL_EXPORT vtkImageBlockWriter : public vtkProcessObject
00042 {
00043 public:
00044   static vtkImageBlockWriter *New();
00045   vtkTypeRevisionMacro(vtkImageBlockWriter,vtkProcessObject);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkSetVector3Macro(Divisions, int);
00052   vtkGetVector3Macro(Divisions, int);
00054
00056
00058   vtkSetMacro(Overlap, int);
00059   vtkGetMacro(Overlap, int);
00061
00063
00064   void SetInput(vtkImageData *input);
00065   vtkImageData *GetInput();
00067
00069
00070   vtkSetStringMacro(FilePattern);
00071   vtkGetStringMacro(FilePattern);
00073
00075   void Write();
00076
00077
00078 protected:
00079   vtkImageBlockWriter();
00080   ~vtkImageBlockWriter();
00081
00082   char *FilePattern;
00083
00084   int Divisions[3];
00085   int Overlap;
00086 private:
00087   vtkImageBlockWriter(const vtkImageBlockWriter&);  // Not implemented.
00088   void operator=(const vtkImageBlockWriter&);  // Not implemented.
00089 };
00090
00091
00092 #endif
00093
00094
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageButterworthHighPass.h Source File

Imaging/vtkImageButterworthHighPass.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageButterworthHighPass.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageButterworthHighPass_h
00046 #define __vtkImageButterworthHighPass_h
00047
00048
00049 #include "vtkImageToImageFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageButterworthHighPass : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageButterworthHighPass *New();
00055   vtkTypeRevisionMacro(vtkImageButterworthHighPass,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00062   vtkSetVector3Macro(CutOff,float);
00063   void SetCutOff(float v) {this->SetCutOff(v, v, v);}
00064   void SetXCutOff(float v);
00065   void SetYCutOff(float v);
00066   void SetZCutOff(float v);
00067   vtkGetVector3Macro(CutOff,float);
00068   float GetXCutOff() {return this->CutOff[0];}
00069   float GetYCutOff() {return this->CutOff[1];}
00070   float GetZCutOff() {return this->CutOff[2];}
00072
00074
00075   vtkSetMacro(Order, int);
00076   vtkGetMacro(Order, int);
00078
00079 protected:
00080   vtkImageButterworthHighPass();
00081   ~vtkImageButterworthHighPass() {};
00082
00083   int Order;
00084   float CutOff[3];
00085
00086   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00087                        int outExt[6], int id);
00088 private:
00089   vtkImageButterworthHighPass(const vtkImageButterworthHighPass&);  // Not implemented.
00090   void operator=(const vtkImageButterworthHighPass&);  // Not implemented.
00091 };
00092
00093 #endif
00094
00095
00096
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageButterworthLowPass.h Source File

Imaging/vtkImageButterworthLowPass.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageButterworthLowPass.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageButterworthLowPass_h
00046 #define __vtkImageButterworthLowPass_h
00047
00048
00049 #include "vtkImageToImageFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageButterworthLowPass : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageButterworthLowPass *New();
00055   vtkTypeRevisionMacro(vtkImageButterworthLowPass,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00062   vtkSetVector3Macro(CutOff,float);
00063   void SetCutOff(float v) {this->SetCutOff(v, v, v);}
00064   void SetXCutOff(float v);
00065   void SetYCutOff(float v);
00066   void SetZCutOff(float v);
00067   vtkGetVector3Macro(CutOff,float);
00068   float GetXCutOff() {return this->CutOff[0];}
00069   float GetYCutOff() {return this->CutOff[1];}
00070   float GetZCutOff() {return this->CutOff[2];}
00072
00074
00075   vtkSetMacro(Order, int);
00076   vtkGetMacro(Order, int);
00078
00079
00080 protected:
00081   vtkImageButterworthLowPass();
00082   ~vtkImageButterworthLowPass() {};
00083
00084   int Order;
00085   float CutOff[3];
00086
00087   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00088                        int outExt[6], int id);
00089 private:
00090   vtkImageButterworthLowPass(const vtkImageButterworthLowPass&);  // Not implemented.
00091   void operator=(const vtkImageButterworthLowPass&);  // Not implemented.
00092 };
00093
00094 #endif
00095
00096
00097
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCacheFilter.h Source File

Imaging/vtkImageCacheFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCacheFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageCacheFilter_h
00038 #define __vtkImageCacheFilter_h
00039
00040 #include "vtkImageToImageFilter.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageCacheFilter : public vtkImageToImageFilter
00043 {
00044 public:
00045   static vtkImageCacheFilter *New();
00046   vtkTypeRevisionMacro(vtkImageCacheFilter,vtkImageToImageFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00052   void SetCacheSize(int size);
00053   vtkGetMacro(CacheSize, int);
00055
00057   void UpdateData(vtkDataObject *outData);
00058
00059 protected:
00060   vtkImageCacheFilter();
00061   ~vtkImageCacheFilter();
00062
00063   int CacheSize;
00064
00065   vtkImageData **Data;
00066   // I do not have write access to UpdateTime.
00067   unsigned long *Times;
00068 private:
00069   vtkImageCacheFilter(const vtkImageCacheFilter&);  // Not implemented.
00070   void operator=(const vtkImageCacheFilter&);  // Not implemented.
00071 };
00072
00073
00074
00075 #endif
00076
00077
00078
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCanvasSource2D.h Source File

Imaging/vtkImageCanvasSource2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCanvasSource2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkImageCanvasSource2D_h
00044 #define __vtkImageCanvasSource2D_h
00045
00046 #include <math.h>
00047 #include "vtkStructuredPoints.h"
00048
00049 //
00050 // Special classes for manipulating data
00051 //
00052 //BTX - begin tcl exclude
00053 //
00054 // For the fill functionality (use connector ??)
00055 class vtkImageCanvasSource2DPixel { //;prevent man page generation
00056 public:
00057   static vtkImageCanvasSource2DPixel *New()
00058     { return new vtkImageCanvasSource2DPixel ;}
00059   int X;
00060   int Y;
00061   void *Pointer;
00062   vtkImageCanvasSource2DPixel *Next;
00063 };
00064 //ETX - end tcl exclude
00065 //
00066
00067
00068 class VTK_IMAGING_EXPORT vtkImageCanvasSource2D : public vtkStructuredPoints
00069 {
00070 public:
00072   static vtkImageCanvasSource2D *New();
00073
00074   vtkTypeRevisionMacro(vtkImageCanvasSource2D,vtkStructuredPoints);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078
00079   void SetImageData(vtkImageData *image);
00080   vtkGetObjectMacro(ImageData, vtkImageData);
00082
00084
00086   vtkSetVector4Macro(DrawColor, float);
00087   vtkGetVector4Macro(DrawColor, float);
00088   void SetDrawColor(float a) {this->SetDrawColor(a, 0.0, 0.0, 0.0);}
00089   void SetDrawColor(float a,float b) {this->SetDrawColor(a, b, 0.0, 0.0);}
00090   void SetDrawColor(float a, float b, float c) {this->SetDrawColor(a, b, c, 0.0);}
00092
00093   void FillBox(int min0, int max0, int min1, int max1);
00094   void FillTube(int x0, int y0, int x1, int y1, float radius);
00095   void FillTriangle(int x0, int y0, int x1, int y1, int x2, int y2);
00096   void DrawCircle(int c0, int c1, float radius);
00097   void DrawPoint(int p0, int p1);
00098   void DrawSegment(int x0, int y0, int x1, int y1);
00099   void DrawSegment3D(float *p0, float *p1);
00100   void DrawSegment3D(float x1, float y1, float z1, float x2, float y2, float z2)
00101     { float p1[3], p2[3];
00102     p1[0] = x1; p1[1] = y1; p1[2] = z1; p2[0] = x2; p2[1] = y2; p2[2] = z2;
00103     this->DrawSegment3D(p1, p2);}
00104
00108   void FillPixel(int x, int y);
00109
00112   vtkImageData *GetOutput() {return this;}
00113
00115
00118   void SetExtent(int *extent);
00119   void SetExtent(int x1, int x2, int y1, int y2, int z1, int z2);
00121
00123
00126   vtkSetMacro(DefaultZ, int);
00127   vtkGetMacro(DefaultZ, int);
00129
00131
00133   vtkSetVector3Macro(Ratio, float);
00134   vtkGetVector3Macro(Ratio, float);
00136
00137 protected:
00138   vtkImageCanvasSource2D();
00139   // Destructor: Deleting a vtkImageCanvasSource2D automatically deletes the
00140   // associated vtkImageData.  However, since the data is reference counted,
00141   // it may not actually be deleted.
00142   ~vtkImageCanvasSource2D();
00143
00144   vtkImageData *ImageData;
00145   float DrawColor[4];
00146   int DefaultZ;
00147   float Ratio[3];
00148
00149   int ClipSegment(int &a0, int &a1, int &b0, int &b1);
00150 private:
00151   vtkImageCanvasSource2D(const vtkImageCanvasSource2D&);  // Not implemented.
00152   void operator=(const vtkImageCanvasSource2D&);  // Not implemented.
00153 };
00154
00155
00156
00157 #endif
00158
00159
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCast.h Source File

Imaging/vtkImageCast.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCast.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkImageCast_h
00044 #define __vtkImageCast_h
00045
00046
00047 #include "vtkImageToImageFilter.h"
00048
00049 class VTK_IMAGING_EXPORT vtkImageCast : public vtkImageToImageFilter
00050 {
00051 public:
00052   static vtkImageCast *New();
00053   vtkTypeRevisionMacro(vtkImageCast,vtkImageToImageFilter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetMacro(OutputScalarType,int);
00059   vtkGetMacro(OutputScalarType,int);
00060   void SetOutputScalarTypeToFloat(){this->SetOutputScalarType(VTK_FLOAT);};
00061   void SetOutputScalarTypeToDouble(){this->SetOutputScalarType(VTK_DOUBLE);};
00062   void SetOutputScalarTypeToInt(){this->SetOutputScalarType(VTK_INT);};
00063   void SetOutputScalarTypeToUnsignedInt()
00064     {this->SetOutputScalarType(VTK_UNSIGNED_INT);};
00065   void SetOutputScalarTypeToLong(){this->SetOutputScalarType(VTK_LONG);};
00066   void SetOutputScalarTypeToUnsignedLong()
00067     {this->SetOutputScalarType(VTK_UNSIGNED_LONG);};
00068   void SetOutputScalarTypeToShort(){this->SetOutputScalarType(VTK_SHORT);};
00069   void SetOutputScalarTypeToUnsignedShort()
00070     {this->SetOutputScalarType(VTK_UNSIGNED_SHORT);};
00071   void SetOutputScalarTypeToUnsignedChar()
00072     {this->SetOutputScalarType(VTK_UNSIGNED_CHAR);};
00073   void SetOutputScalarTypeToChar()
00074     {this->SetOutputScalarType(VTK_CHAR);};
00076
00078
00081   vtkSetMacro(ClampOverflow, int);
00082   vtkGetMacro(ClampOverflow, int);
00083   vtkBooleanMacro(ClampOverflow, int);
00085
00086
00087 protected:
00088   vtkImageCast();
00089   ~vtkImageCast() {};
00090
00091   int ClampOverflow;
00092   int OutputScalarType;
00093   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00094   void UpdateData(vtkDataObject *data);
00095   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00096   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00097                        int ext[6], int id);
00098
00099 private:
00100   vtkImageCast(const vtkImageCast&);  // Not implemented.
00101   void operator=(const vtkImageCast&);  // Not implemented.
00102 };
00103
00104 #endif
00105
00106
00107
00108
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageChangeInformation.h Source File

Imaging/vtkImageChangeInformation.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageChangeInformation.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageChangeInformation_h
00037 #define __vtkImageChangeInformation_h
00038
00039 #include "vtkImageToImageFilter.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageChangeInformation : public vtkImageToImageFilter
00042 {
00043 public:
00044   static vtkImageChangeInformation *New();
00045   vtkTypeRevisionMacro(vtkImageChangeInformation, vtkImageToImageFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkSetObjectMacro(InformationInput, vtkImageData);
00052   vtkGetObjectMacro(InformationInput, vtkImageData);
00054
00056
00060   vtkSetVector3Macro(OutputExtentStart, int);
00061   vtkGetVector3Macro(OutputExtentStart, int);
00063
00065
00068   vtkSetVector3Macro(OutputSpacing, float);
00069   vtkGetVector3Macro(OutputSpacing, float);
00071
00073
00076   vtkSetVector3Macro(OutputOrigin, float);
00077   vtkGetVector3Macro(OutputOrigin, float);
00079
00081
00085   vtkSetMacro(CenterImage, int);
00086   vtkBooleanMacro(CenterImage, int);
00087   vtkGetMacro(CenterImage, int);
00089
00091
00092   vtkSetVector3Macro(ExtentTranslation, int);
00093   vtkGetVector3Macro(ExtentTranslation, int);
00095
00097
00098   vtkSetVector3Macro(SpacingScale, float);
00099   vtkGetVector3Macro(SpacingScale, float);
00101
00103
00104   vtkSetVector3Macro(OriginTranslation, float);
00105   vtkGetVector3Macro(OriginTranslation, float);
00107
00109
00111   vtkSetVector3Macro(OriginScale, float);
00112   vtkGetVector3Macro(OriginScale, float);
00114
00115 protected:
00116   vtkImageChangeInformation();
00117   ~vtkImageChangeInformation();
00118
00119   vtkImageData *InformationInput;
00120   int CenterImage;
00121
00122   int OutputExtentStart[3];
00123   int ExtentTranslation[3];
00124   int FinalExtentTranslation[3];
00125
00126   float OutputSpacing[3];
00127   float SpacingScale[3];
00128
00129   float OutputOrigin[3];
00130   float OriginScale[3];
00131   float OriginTranslation[3];
00132
00133   void ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]);
00134   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00135   void ExecuteInformation() {
00136     this->vtkImageToImageFilter::ExecuteInformation(); };
00137   void ExecuteData(vtkDataObject *data);
00138 private:
00139   vtkImageChangeInformation(const vtkImageChangeInformation&) {};  // Not implemented.
00140   void operator=(const vtkImageChangeInformation&) {};  // Not implemented.
00141 };
00142
00143
00144
00145 #endif
00146
00147
00148
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCheckerboard.h Source File

Imaging/vtkImageCheckerboard.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCheckerboard.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageCheckerboard_h
00039 #define __vtkImageCheckerboard_h
00040
00041 #include "vtkImageTwoInputFilter.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageCheckerboard : public vtkImageTwoInputFilter
00044 {
00045 public:
00046   static vtkImageCheckerboard *New();
00047   vtkTypeRevisionMacro(vtkImageCheckerboard,vtkImageTwoInputFilter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   vtkSetVector3Macro(NumberOfDivisions,int);
00053   vtkGetVectorMacro(NumberOfDivisions,int,3);
00055
00056 protected:
00057   vtkImageCheckerboard();
00058   ~vtkImageCheckerboard() {};
00059
00060   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00061                        int extent[6], int id);
00062   int NumberOfDivisions[3];
00063 private:
00064   vtkImageCheckerboard(const vtkImageCheckerboard&) {};  // Not implemented.
00065   void operator=(const vtkImageCheckerboard&) {};  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
00071
00072
00073
00074
00075
00076
00077
00078
00079
00080
00081
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCityBlockDistance.h Source File

Imaging/vtkImageCityBlockDistance.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCityBlockDistance.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageCityBlockDistance_h
00046 #define __vtkImageCityBlockDistance_h
00047
00048
00049 #include "vtkImageDecomposeFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageCityBlockDistance : public vtkImageDecomposeFilter
00052 {
00053 public:
00054   static vtkImageCityBlockDistance *New();
00055   vtkTypeRevisionMacro(vtkImageCityBlockDistance,vtkImageDecomposeFilter);
00056
00057 protected:
00058   vtkImageCityBlockDistance();
00059   ~vtkImageCityBlockDistance() {};
00060
00061   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00062   void IterativeExecuteData(vtkImageData *inData, vtkImageData *outData);
00063
00064   void AllocateOutputScalars(vtkImageData *outData);
00065
00066 private:
00067   vtkImageCityBlockDistance(const vtkImageCityBlockDistance&);  // Not implemented.
00068   void operator=(const vtkImageCityBlockDistance&);  // Not implemented.
00069 };
00070
00071 #endif
00072
00073
00074
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageClip.h Source File

Imaging/vtkImageClip.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageClip.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageClip_h
00045 #define __vtkImageClip_h
00046
00047 // I did not make this a subclass of in place filter because
00048 // the references on the data do not matter. I make no modifications
00049 // to the data.
00050 #include "vtkImageToImageFilter.h"
00051
00052 class VTK_IMAGING_EXPORT vtkImageClip : public vtkImageToImageFilter
00053 {
00054 public:
00055   static vtkImageClip *New();
00056   vtkTypeRevisionMacro(vtkImageClip,vtkImageToImageFilter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00061   void SetOutputWholeExtent(int extent[6]);
00062   void SetOutputWholeExtent(int minX, int maxX, int minY, int maxY,
00063                             int minZ, int maxZ);
00064   void GetOutputWholeExtent(int extent[6]);
00065   int *GetOutputWholeExtent() {return this->OutputWholeExtent;}
00067
00068   void ResetOutputWholeExtent();
00069
00071
00074   vtkSetMacro(ClipData, int);
00075   vtkGetMacro(ClipData, int);
00076   vtkBooleanMacro(ClipData, int);
00078
00080   void SetOutputWholeExtent(int piece, int numPieces);
00081
00082 protected:
00083   vtkImageClip();
00084   ~vtkImageClip() {};
00085
00086   // Time when OutputImageExtent was computed.
00087   vtkTimeStamp CTime;
00088   int Initialized; // Set the OutputImageExtent for the first time.
00089   int OutputWholeExtent[6];
00090
00091   int ClipData;
00092
00093   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00094   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00095   void CopyData(vtkImageData *inData, vtkImageData *outData, int *ext);
00096
00097   int SplitExtentTmp(int piece, int numPieces, int *ext);
00098
00099   virtual void ExecuteData(vtkDataObject *out);
00100 private:
00101   vtkImageClip(const vtkImageClip&);  // Not implemented.
00102   void operator=(const vtkImageClip&);  // Not implemented.
00103 };
00104
00105
00106
00107 #endif
00108
00109
00110
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageConnector.h Source File

Imaging/vtkImageConnector.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageConnector.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageConnector_h
00041 #define __vtkImageConnector_h
00042
00043 #include "vtkObject.h"
00044 #include "vtkImageData.h"
00045
00046 //
00047 // Special classes for manipulating data
00048 //
00049 //BTX - begin tcl exclude
00050 //
00051 // For the breadth first search
00052 class vtkImageConnectorSeed { //;prevent man page generation
00053 public:
00054   static vtkImageConnectorSeed *New() { return new vtkImageConnectorSeed;}
00055   void *Pointer;
00056   int  Index[3];
00057   vtkImageConnectorSeed *Next;
00058 };
00059 //ETX - end tcl exclude
00060 //
00061
00062
00063 class VTK_IMAGING_EXPORT vtkImageConnector : public vtkObject
00064 {
00065 public:
00066   static vtkImageConnector *New();
00067
00068   vtkTypeRevisionMacro(vtkImageConnector,vtkObject);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00071   //BTX
00072   vtkImageConnectorSeed *NewSeed(int index[3], void *ptr);
00073   void AddSeed(vtkImageConnectorSeed *seed);
00074   void AddSeedToEnd(vtkImageConnectorSeed *seed);
00075   //ETX
00076   void RemoveAllSeeds();
00077
00079
00080   vtkSetMacro(ConnectedValue, unsigned char);
00081   vtkGetMacro(ConnectedValue, unsigned char);
00082   vtkSetMacro(UnconnectedValue, unsigned char);
00083   vtkGetMacro(UnconnectedValue, unsigned char);
00085
00086
00090   void MarkData(vtkImageData *data, int dimensionality, int ext[6]);
00091
00092
00093 protected:
00094   vtkImageConnector();
00095   ~vtkImageConnector();
00096
00097   unsigned char ConnectedValue;
00098   unsigned char UnconnectedValue;
00099
00100   vtkImageConnectorSeed *PopSeed();
00101
00102   vtkImageConnectorSeed *Seeds;
00103   vtkImageConnectorSeed *LastSeed;
00104 private:
00105   vtkImageConnector(const vtkImageConnector&);  // Not implemented.
00106   void operator=(const vtkImageConnector&);  // Not implemented.
00107 };
00108
00109
00110
00111 #endif
00112
00113
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageConstantPad.h Source File

Imaging/vtkImageConstantPad.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageConstantPad.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageConstantPad_h
00041 #define __vtkImageConstantPad_h
00042
00043
00044 #include "vtkImagePadFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageConstantPad : public vtkImagePadFilter
00047 {
00048 public:
00049   static vtkImageConstantPad *New();
00050   vtkTypeRevisionMacro(vtkImageConstantPad,vtkImagePadFilter);
00051
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkSetMacro(Constant, float);
00057   vtkGetMacro(Constant, float);
00059
00060
00061 protected:
00062   vtkImageConstantPad();
00063   ~vtkImageConstantPad() {};
00064
00065   float Constant;
00066
00067   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00068                        int outExt[6], int id);
00069 private:
00070   vtkImageConstantPad(const vtkImageConstantPad&);  // Not implemented.
00071   void operator=(const vtkImageConstantPad&);  // Not implemented.
00072 };
00073
00074 #endif
00075
00076
00077
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageContinuousDilate3D.h Source File

Imaging/vtkImageContinuousDilate3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageContinuousDilate3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageContinuousDilate3D_h
00038 #define __vtkImageContinuousDilate3D_h
00039
00040
00041 #include "vtkImageSpatialFilter.h"
00042
00043 class vtkImageEllipsoidSource;
00044
00045 class VTK_IMAGING_EXPORT vtkImageContinuousDilate3D : public vtkImageSpatialFilter
00046 {
00047 public:
00048
00050
00052   static vtkImageContinuousDilate3D *New();
00053   vtkTypeRevisionMacro(vtkImageContinuousDilate3D,vtkImageSpatialFilter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00056
00060   void SetKernelSize(int size0, int size1, int size2);
00061
00062
00063 protected:
00064   vtkImageContinuousDilate3D();
00065   ~vtkImageContinuousDilate3D();
00066
00067   vtkImageEllipsoidSource *Ellipse;
00068
00069   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00070                        int extent[6], int id);
00071 private:
00072   vtkImageContinuousDilate3D(const vtkImageContinuousDilate3D&);  // Not implemented.
00073   void operator=(const vtkImageContinuousDilate3D&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
00079
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageContinuousErode3D.h Source File

Imaging/vtkImageContinuousErode3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageContinuousErode3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageContinuousErode3D_h
00038 #define __vtkImageContinuousErode3D_h
00039
00040
00041 #include "vtkImageSpatialFilter.h"
00042
00043 class vtkImageEllipsoidSource;
00044
00045 class VTK_IMAGING_EXPORT vtkImageContinuousErode3D : public vtkImageSpatialFilter
00046 {
00047 public:
00049
00051   static vtkImageContinuousErode3D *New();
00052   vtkTypeRevisionMacro(vtkImageContinuousErode3D,vtkImageSpatialFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00055
00059   void SetKernelSize(int size0, int size1, int size2);
00060
00061
00062 protected:
00063   vtkImageContinuousErode3D();
00064   ~vtkImageContinuousErode3D();
00065
00066   vtkImageEllipsoidSource *Ellipse;
00067
00068   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00069                        int extent[6], int id);
00070 private:
00071   vtkImageContinuousErode3D(const vtkImageContinuousErode3D&);  // Not implemented.
00072   void operator=(const vtkImageContinuousErode3D&);  // Not implemented.
00073 };
00074
00075 #endif
00076
00077
00078
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageConvolve.h Source File

Imaging/vtkImageConvolve.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageConvolve.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageConvolve_h
00038 #define __vtkImageConvolve_h
00039
00040 #include "vtkImageToImageFilter.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageConvolve : public vtkImageToImageFilter
00043 {
00044 public:
00046
00047   static vtkImageConvolve *New();
00048   vtkTypeRevisionMacro(vtkImageConvolve,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkGetVector3Macro(KernelSize, int);
00056
00058
00059   void SetKernel3x3(const float kernel[9]);
00060   void SetKernel5x5(const float kernel[25]);
00062 //BTX
00063   void SetKernel7x7(float kernel[49]);
00064 //ETX
00065
00067
00068   float* GetKernel3x3();
00069   void GetKernel3x3(float kernel[9]);
00070   float* GetKernel5x5();
00071   void GetKernel5x5(float kernel[25]);
00073 //BTX
00074   float* GetKernel7x7();
00075   void GetKernel7x7(float kernel[49]);
00076 //ETX
00077
00079   void SetKernel3x3x3(const float kernel[27]);
00080 //BTX
00081   void SetKernel5x5x5(float kernel[125]);
00082   void SetKernel7x7x7(float kernel[343]);
00083 //ETX
00084
00086
00087   float* GetKernel3x3x3();
00088   void GetKernel3x3x3(float kernel[27]);
00090 //BTX
00091   float* GetKernel5x5x5();
00092   void GetKernel5x5x5(float kernel[125]);
00093   float* GetKernel7x7x7();
00094   void GetKernel7x7x7(float kernel[343]);
00095 //ETX
00096
00097 protected:
00098   vtkImageConvolve();
00099   ~vtkImageConvolve();
00100
00101   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00102                        int outExt[6], int id);
00103
00104   void GetKernel(float *kernel);
00105   float* GetKernel();
00106   void SetKernel(const float* kernel,
00107                  int sizeX, int sizeY, int sizeZ);
00108
00109
00110   int KernelSize[3];
00111   float Kernel[343];
00112 private:
00113   vtkImageConvolve(const vtkImageConvolve&);  // Not implemented.
00114   void operator=(const vtkImageConvolve&);  // Not implemented.
00115 };
00116
00117 #endif
00118
00119
00120
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCorrelation.h Source File

Imaging/vtkImageCorrelation.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCorrelation.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageCorrelation_h
00041 #define __vtkImageCorrelation_h
00042
00043
00044
00045 #include "vtkImageTwoInputFilter.h"
00046
00047 class VTK_IMAGING_EXPORT vtkImageCorrelation : public vtkImageTwoInputFilter
00048 {
00049 public:
00050   static vtkImageCorrelation *New();
00051   vtkTypeRevisionMacro(vtkImageCorrelation,vtkImageTwoInputFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkSetClampMacro(Dimensionality,int,2,3);
00057   vtkGetMacro(Dimensionality,int);
00059
00060 protected:
00061   vtkImageCorrelation();
00062   ~vtkImageCorrelation() {};
00063
00064   int Dimensionality;
00065   void ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData);
00066   virtual void ComputeInputUpdateExtent(int inExt[6], int outExt[6],
00067                                         int whichInput);
00068   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00069   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00070                        int extent[6], int id);
00071 private:
00072   vtkImageCorrelation(const vtkImageCorrelation&);  // Not implemented.
00073   void operator=(const vtkImageCorrelation&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
00079
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageCursor3D.h Source File

Imaging/vtkImageCursor3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageCursor3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageCursor3D_h
00037 #define __vtkImageCursor3D_h
00038
00039 #include "vtkImageInPlaceFilter.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageCursor3D : public vtkImageInPlaceFilter
00042 {
00043 public:
00044   static vtkImageCursor3D *New();
00045   vtkTypeRevisionMacro(vtkImageCursor3D,vtkImageInPlaceFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00048
00050
00051   vtkSetVector3Macro(CursorPosition, float);
00052   vtkGetVector3Macro(CursorPosition, float);
00054
00056
00057   vtkSetMacro(CursorValue, float);
00058   vtkGetMacro(CursorValue, float);
00060
00062
00064   vtkSetMacro(CursorRadius, int);
00065   vtkGetMacro(CursorRadius, int);
00067
00068
00069 protected:
00070   vtkImageCursor3D();
00071   ~vtkImageCursor3D() {};
00072
00073   float CursorPosition[3];
00074   float CursorValue;
00075   int CursorRadius;
00076
00077   // not threaded because it's too simple a filter
00078   void ExecuteData(vtkDataObject *outData);
00079 private:
00080   vtkImageCursor3D(const vtkImageCursor3D&);  // Not implemented.
00081   void operator=(const vtkImageCursor3D&);  // Not implemented.
00082 };
00083
00084
00085
00086 #endif
00087
00088
00089
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkImageData.h Source File

Common/vtkImageData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageData_h
00042 #define __vtkImageData_h
00043
00044 #include "vtkDataSet.h"
00045 #include "vtkStructuredData.h"
00046 class vtkVertex;
00047 class vtkLine;
00048 class vtkPixel;
00049 class vtkVoxel;
00050
00051
00052 class VTK_COMMON_EXPORT vtkImageData : public vtkDataSet
00053 {
00054 public:
00055   static vtkImageData *New();
00056
00057   vtkTypeRevisionMacro(vtkImageData,vtkDataSet);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   vtkDataObject *MakeObject() {return vtkImageData::New();};
00062
00065   void CopyStructure(vtkDataSet *ds);
00066
00068   int GetDataObjectType() {return VTK_IMAGE_DATA;};
00069
00072   void UpdateData();
00073
00075
00076   vtkIdType GetNumberOfCells();
00077   vtkIdType GetNumberOfPoints();
00078   float *GetPoint(vtkIdType ptId);
00079   void GetPoint(vtkIdType id, float x[3]);
00080   vtkCell *GetCell(vtkIdType cellId);
00081   void GetCell(vtkIdType cellId, vtkGenericCell *cell);
00082   void GetCellBounds(vtkIdType cellId, float bounds[6]);
00083   vtkIdType FindPoint(float x, float y, float z) { return this->vtkDataSet::FindPoint(x, y, z);};
00084   vtkIdType FindPoint(float x[3]);
00085   vtkIdType FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2,
00086                      int& subId, float pcoords[3], float *weights);
00087   vtkIdType FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell,
00088                      vtkIdType cellId, float tol2, int& subId,
00089                      float pcoords[3], float *weights);
00090   vtkCell *FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId,
00091                           float tol2, int& subId, float pcoords[3],
00092                           float *weights);
00093   int GetCellType(vtkIdType cellId);
00094   void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds)
00095     {vtkStructuredData::GetCellPoints(cellId,ptIds,this->DataDescription,
00096                                       this->GetDimensions());}
00097   void GetPointCells(vtkIdType ptId, vtkIdList *cellIds)
00098     {vtkStructuredData::GetPointCells(ptId,cellIds,this->GetDimensions());}
00099   void ComputeBounds();
00100   int GetMaxCellSize() {return 8;}; //voxel is the largest
00102
00104   void SetDimensions(int i, int j, int k);
00105
00107   void SetDimensions(int dims[3]);
00108
00110
00112   int *GetDimensions();
00113   void GetDimensions(int dims[3]);
00115
00121   int ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3]);
00122
00131   void GetVoxelGradient(int i,int j,int k, vtkDataArray *s, vtkDataArray *g);
00132
00138   void GetPointGradient(int i, int j, int k, vtkDataArray *s, float g[3]);
00139
00141   int GetDataDimension();
00142
00144
00146   vtkIdType ComputePointId(int ijk[3]) {
00147     return vtkStructuredData::ComputePointId(this->GetDimensions(),ijk);};
00149
00151
00153   vtkIdType ComputeCellId(int ijk[3]) {
00154     return vtkStructuredData::ComputeCellId(this->GetDimensions(),ijk);};
00156
00158
00159   void SetAxisUpdateExtent(int axis, int min, int max);
00160   void GetAxisUpdateExtent(int axis, int &min, int &max);
00162
00164
00167   void SetUpdateExtent(int piece, int numPieces, int ghostLevel);
00168   void SetUpdateExtent(int piece, int numPieces)
00169     {this->SetUpdateExtent(piece, numPieces, 0);}
00171
00173
00174   void SetUpdateExtent( int x1, int x2, int y1, int y2, int z1, int z2 )
00175     { this->vtkDataSet::SetUpdateExtent( x1, x2, y1, y2, z1, z2 ); };
00176   void SetUpdateExtent( int ext[6] )
00177     { this->vtkDataSet::SetUpdateExtent( ext ); };
00179
00181
00184   void SetExtent(int extent[6]);
00185   void SetExtent(int x1, int x2, int y1, int y2, int z1, int z2);
00186   vtkGetVector6Macro(Extent,int);
00188
00193   virtual unsigned long GetEstimatedMemorySize();
00194
00196
00198   double GetScalarTypeMin();
00199   double GetScalarTypeMax();
00201
00203   int GetScalarSize();
00204
00206
00209   int *GetIncrements();
00210   void GetIncrements(int &incX, int &incY, int &incZ);
00211   void GetIncrements(int inc[3]);
00213
00223   void GetContinuousIncrements(int extent[6], int &incX, int &incY, int &incZ);
00224
00226
00227   void *GetScalarPointerForExtent(int extent[6]);
00228   void *GetScalarPointer(int coordinates[3]);
00229   void *GetScalarPointer(int x, int y, int z);
00230   void *GetScalarPointer();
00232
00234   float GetScalarComponentAsFloat(int x, int y, int z, int component);
00235
00237   void AllocateScalars();
00238
00240
00244   void CopyAndCastFrom(vtkImageData *inData, int extent[6]);
00245   void CopyAndCastFrom(vtkImageData *inData, int x0, int x1,
00246                        int y0, int y1, int z0, int z1)
00247     {int e[6]; e[0]=x0; e[1]=x1; e[2]=y0; e[3]=y1; e[4]=z0; e[5]=z1;
00248     this->CopyAndCastFrom(inData, e);}
00250
00254   virtual void Crop();
00255
00261   unsigned long GetActualMemorySize();
00262
00264
00266   vtkSetVector3Macro(Spacing,float);
00267   vtkGetVector3Macro(Spacing,float);
00269
00271
00273   vtkSetVector3Macro(Origin,float);
00274   vtkGetVector3Macro(Origin,float);
00276
00278
00279   void SetScalarTypeToFloat(){this->SetScalarType(VTK_FLOAT);};
00280   void SetScalarTypeToDouble(){this->SetScalarType(VTK_DOUBLE);};
00281   void SetScalarTypeToInt(){this->SetScalarType(VTK_INT);};
00282   void SetScalarTypeToUnsignedInt()
00283     {this->SetScalarType(VTK_UNSIGNED_INT);};
00284   void SetScalarTypeToLong(){this->SetScalarType(VTK_LONG);};
00285   void SetScalarTypeToUnsignedLong()
00286     {this->SetScalarType(VTK_UNSIGNED_LONG);};
00287   void SetScalarTypeToShort(){this->SetScalarType(VTK_SHORT);};
00288   void SetScalarTypeToUnsignedShort()
00289     {this->SetScalarType(VTK_UNSIGNED_SHORT);};
00290   void SetScalarTypeToUnsignedChar()
00291     {this->SetScalarType(VTK_UNSIGNED_CHAR);};
00292   void SetScalarTypeToChar()
00293     {this->SetScalarType(VTK_CHAR);};
00294   vtkSetMacro(ScalarType, int);
00295   int GetScalarType();
00296   const char* GetScalarTypeAsString() { return vtkImageScalarTypeNameMacro ( this->GetScalarType() ); };
00298
00300
00301   void SetNumberOfScalarComponents( int n );
00302   vtkGetMacro(NumberOfScalarComponents,int);
00304
00305   // Must only be called with vtkImageData (or subclass) as input
00306   void CopyTypeSpecificInformation( vtkDataObject *image );
00307
00311   virtual void PrepareForNewData();
00312
00314
00315   void ShallowCopy(vtkDataObject *src);
00316   void DeepCopy(vtkDataObject *src);
00318
00319   //--------------------------------------------------------------------------
00320   // Methods that apply to any array (not just scalars).
00321   // I am starting to experiment with generalizing imaging fitlers
00322   // to operate on more than just scalars.
00323
00325
00328   void *GetArrayPointerForExtent(vtkDataArray* array, int extent[6]);
00329   void *GetArrayPointer(vtkDataArray* array, int coordinates[3]);
00331
00334   void GetArrayIncrements(vtkDataArray *array, int increments[3]);
00335
00336 protected:
00337   vtkImageData();
00338   ~vtkImageData();
00339
00340   // for the GetCell method
00341   vtkVertex *Vertex;
00342   vtkLine *Line;
00343   vtkPixel *Pixel;
00344   vtkVoxel *Voxel;
00345
00346   // The extent type is a 3D extent
00347   int GetExtentType() { return VTK_3D_EXTENT; };
00348
00349   // The extent of what is currently in the structured grid.
00350   // Dimensions is just an array to return a value.
00351   // Its contents are out of data until GetDimensions is called.
00352   int Dimensions[3];
00353   int DataDescription;
00354   int Increments[3];
00355
00356   float Origin[3];
00357   float Spacing[3];
00358   int ScalarType;
00359   int NumberOfScalarComponents;
00360
00361   void ComputeIncrements();
00362
00363 private:
00364   void InternalImageDataCopy(vtkImageData *src);
00365 private:
00366   vtkImageData(const vtkImageData&);  // Not implemented.
00367   void operator=(const vtkImageData&);  // Not implemented.
00368 };
00369
00370
00371 inline void vtkImageData::GetPoint(vtkIdType id, float x[3])
00372 {
00373   float *p=this->GetPoint(id);
00374   x[0] = p[0]; x[1] = p[1]; x[2] = p[2];
00375 }
00376
00377
00378
00379 inline vtkIdType vtkImageData::GetNumberOfPoints()
00380 {
00381   int *dims = this->GetDimensions();
00382   return dims[0]*dims[1]*dims[2];
00383 }
00384
00385 inline int vtkImageData::GetDataDimension()
00386 {
00387   return vtkStructuredData::GetDataDimension(this->DataDescription);
00388 }
00389
00390 #endif
00391
00392
00393
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkImageDataGeometryFilter.h Source File

Graphics/vtkImageDataGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDataGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkImageDataGeometryFilter_h
00054 #define __vtkImageDataGeometryFilter_h
00055
00056 #include "vtkStructuredPointsToPolyDataFilter.h"
00057
00058 class VTK_GRAPHICS_EXPORT vtkImageDataGeometryFilter : public vtkStructuredPointsToPolyDataFilter
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkImageDataGeometryFilter,vtkStructuredPointsToPolyDataFilter);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065   static vtkImageDataGeometryFilter *New();
00066
00067
00069
00070   void SetExtent(int extent[6]);
00071   void SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax);
00072   int *GetExtent() { return this->Extent;};
00074
00075 protected:
00076   vtkImageDataGeometryFilter();
00077   ~vtkImageDataGeometryFilter() {};
00078
00079   void Execute();
00080   int Extent[6];
00081 private:
00082   vtkImageDataGeometryFilter(const vtkImageDataGeometryFilter&);  // Not implemented.
00083   void operator=(const vtkImageDataGeometryFilter&);  // Not implemented.
00084 };
00085
00086 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDataStreamer.h Source File

Imaging/vtkImageDataStreamer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDataStreamer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageDataStreamer_h
00042 #define __vtkImageDataStreamer_h
00043
00044 #include "vtkImageToImageFilter.h"
00045 #include "vtkExtentTranslator.h"
00046
00047 class VTK_IMAGING_EXPORT vtkImageDataStreamer : public vtkImageToImageFilter
00048 {
00049 public:
00050   static vtkImageDataStreamer *New();
00051   vtkTypeRevisionMacro(vtkImageDataStreamer,vtkImageToImageFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00058   vtkSetMacro(NumberOfStreamDivisions,int);
00059   vtkGetMacro(NumberOfStreamDivisions,int);
00061
00063   void UpdateData( vtkDataObject *out );
00064
00066
00067   vtkGetObjectMacro(ExtentTranslator,vtkExtentTranslator);
00068   vtkSetObjectMacro(ExtentTranslator,vtkExtentTranslator);
00070
00071 protected:
00072   vtkImageDataStreamer();
00073   ~vtkImageDataStreamer();
00074
00075   vtkExtentTranslator *ExtentTranslator;
00076   int            NumberOfStreamDivisions;
00077 private:
00078   vtkImageDataStreamer(const vtkImageDataStreamer&);  // Not implemented.
00079   void operator=(const vtkImageDataStreamer&);  // Not implemented.
00080 };
00081
00082
00083
00084
00085 #endif
00086
00087
00088
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDecomposeFilter.h Source File

Imaging/vtkImageDecomposeFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDecomposeFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageDecomposeFilter_h
00038 #define __vtkImageDecomposeFilter_h
00039
00040
00041 #include "vtkImageIterateFilter.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageDecomposeFilter : public vtkImageIterateFilter
00044 {
00045 public:
00047
00049   vtkTypeRevisionMacro(vtkImageDecomposeFilter,vtkImageIterateFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00056   void SetDimensionality(int dim);
00057   vtkGetMacro(Dimensionality,int);
00059
00060 #ifndef VTK_REMOVE_LEGACY_CODE
00061
00062
00063   void SetFilteredAxes(int axis0);
00064   void SetFilteredAxes(int axis0, int axis2);
00065   void SetFilteredAxes(int axis0, int axis2, int axis3);
00067 #endif
00068
00070
00071   void PermuteIncrements(int *increments, int &inc0, int &inc1, int &inc2);
00072   void PermuteExtent(int *extent, int &min0, int &max0, int &min1, int &max1,
00073                      int &min2, int &max2);
00075
00076 protected:
00077   vtkImageDecomposeFilter();
00078   ~vtkImageDecomposeFilter() {};
00079
00080   int Dimensionality;
00081
00082
00083 private:
00084   vtkImageDecomposeFilter(const vtkImageDecomposeFilter&);  // Not implemented.
00085   void operator=(const vtkImageDecomposeFilter&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
00091
00092
00093
00094
00095
00096
00097
00098
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDifference.h Source File

Imaging/vtkImageDifference.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDifference.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageDifference_h
00041 #define __vtkImageDifference_h
00042
00043 #include "vtkImageTwoInputFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageDifference : public vtkImageTwoInputFilter
00046 {
00047 public:
00048   static vtkImageDifference *New();
00049   vtkTypeRevisionMacro(vtkImageDifference,vtkImageTwoInputFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   void SetImage(vtkImageData *image) {this->SetInput2(image);}
00055   vtkImageData *GetImage() {return this->GetInput2();}
00057
00059
00060   void SetInput(vtkImageData *input) {this->SetInput1(input);}
00061   void SetInput(int num, vtkImageData *input)
00062     { this->vtkImageMultipleInputFilter::SetInput(num, input); };
00064
00066
00067   float GetError(void);
00068   void GetError(float *e) { *e = this->GetError(); };
00070
00072
00075   float GetThresholdedError(void);
00076   void GetThresholdedError(float *e) { *e = this->GetThresholdedError(); };
00078
00079
00081
00082   vtkSetMacro(Threshold,int);
00083   vtkGetMacro(Threshold,int);
00085
00087
00092   vtkSetMacro(AllowShift,int);
00093   vtkGetMacro(AllowShift,int);
00094   vtkBooleanMacro(AllowShift,int);
00096
00098
00101   vtkSetMacro(Averaging,int);
00102   vtkGetMacro(Averaging,int);
00103   vtkBooleanMacro(Averaging,int);
00105
00106 protected:
00107   vtkImageDifference();
00108   ~vtkImageDifference() {};
00109
00110   float ErrorPerThread[VTK_MAX_THREADS];
00111   float ThresholdedErrorPerThread[VTK_MAX_THREADS];
00112   int AllowShift;
00113   int Threshold;
00114   int Averaging;
00115
00116   void ExecuteInformation(vtkImageData **inputs, vtkImageData *output);
00117   void ComputeInputUpdateExtent(int inExt[6], int outExt[6],
00118                                 int whichInput);
00119   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00120   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00121                        int extent[6], int id);
00122
00123 private:
00124   vtkImageDifference(const vtkImageDifference&);  // Not implemented.
00125   void operator=(const vtkImageDifference&);  // Not implemented.
00126 };
00127
00128 #endif
00129
00130
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDilateErode3D.h Source File

Imaging/vtkImageDilateErode3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDilateErode3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageDilateErode3D_h
00037 #define __vtkImageDilateErode3D_h
00038
00039
00040 #include "vtkImageSpatialFilter.h"
00041
00042 class vtkImageEllipsoidSource;
00043
00044 class VTK_IMAGING_EXPORT vtkImageDilateErode3D : public vtkImageSpatialFilter
00045 {
00046 public:
00048
00050   static vtkImageDilateErode3D *New();
00051   vtkTypeRevisionMacro(vtkImageDilateErode3D,vtkImageSpatialFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00054
00058   void SetKernelSize(int size0, int size1, int size2);
00059
00060
00062
00063   vtkSetMacro(DilateValue, float);
00064   vtkGetMacro(DilateValue, float);
00065   vtkSetMacro(ErodeValue, float);
00066   vtkGetMacro(ErodeValue, float);
00068
00069 protected:
00070   vtkImageDilateErode3D();
00071   ~vtkImageDilateErode3D();
00072
00073   vtkImageEllipsoidSource *Ellipse;
00074   float DilateValue;
00075   float ErodeValue;
00076
00077   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00078                        int extent[6], int id);
00079 private:
00080   vtkImageDilateErode3D(const vtkImageDilateErode3D&);  // Not implemented.
00081   void operator=(const vtkImageDilateErode3D&);  // Not implemented.
00082 };
00083
00084 #endif
00085
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDivergence.h Source File

Imaging/vtkImageDivergence.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDivergence.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkImageDivergence_h
00043 #define __vtkImageDivergence_h
00044
00045 #include "vtkImageToImageFilter.h"
00046
00047 class VTK_IMAGING_EXPORT vtkImageDivergence : public vtkImageToImageFilter
00048 {
00049 public:
00050   static vtkImageDivergence *New();
00051   vtkTypeRevisionMacro(vtkImageDivergence,vtkImageToImageFilter);
00052
00053 protected:
00054   vtkImageDivergence() {};
00055   ~vtkImageDivergence() {};
00056
00057   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00058   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00059   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();}
00060   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00061                        int ext[6], int id);
00062
00063 private:
00064   vtkImageDivergence(const vtkImageDivergence&);  // Not implemented.
00065   void operator=(const vtkImageDivergence&);  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
00071
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageDotProduct.h Source File

Imaging/vtkImageDotProduct.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageDotProduct.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageDotProduct_h
00039 #define __vtkImageDotProduct_h
00040
00041
00042
00043 #include "vtkImageTwoInputFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageDotProduct : public vtkImageTwoInputFilter
00046 {
00047 public:
00048   static vtkImageDotProduct *New();
00049   vtkTypeRevisionMacro(vtkImageDotProduct,vtkImageTwoInputFilter);
00050
00051 protected:
00052   vtkImageDotProduct() {};
00053   ~vtkImageDotProduct() {};
00054
00055   void ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData);
00056   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00057   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00058                        int extent[6], int id);
00059 private:
00060   vtkImageDotProduct(const vtkImageDotProduct&);  // Not implemented.
00061   void operator=(const vtkImageDotProduct&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
00067
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageEllipsoidSource.h Source File

Imaging/vtkImageEllipsoidSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageEllipsoidSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageEllipsoidSource_h
00039 #define __vtkImageEllipsoidSource_h
00040
00041 #include "vtkImageSource.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageEllipsoidSource : public vtkImageSource
00044 {
00045 public:
00046   static vtkImageEllipsoidSource *New();
00047   vtkTypeRevisionMacro(vtkImageEllipsoidSource,vtkImageSource);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   void SetWholeExtent(int extent[6]);
00053   void SetWholeExtent(int minX, int maxX, int minY, int maxY,
00054                             int minZ, int maxZ);
00055   void GetWholeExtent(int extent[6]);
00056   int *GetWholeExtent() {return this->WholeExtent;}
00058
00060
00061   vtkSetVector3Macro(Center, float);
00062   vtkGetVector3Macro(Center, float);
00064
00066
00067   vtkSetVector3Macro(Radius, float);
00068   vtkGetVector3Macro(Radius, float);
00070
00072
00073   vtkSetMacro(InValue,float);
00074   vtkGetMacro(InValue,float);
00076
00078
00079   vtkSetMacro(OutValue,float);
00080   vtkGetMacro(OutValue,float);
00082
00084
00085   vtkSetMacro(OutputScalarType,int);
00086   vtkGetMacro(OutputScalarType,int);
00087   void SetOutputScalarTypeToDouble()
00088     {this->SetOutputScalarType(VTK_DOUBLE);}
00089   void SetOutputScalarTypeToFloat()
00090     {this->SetOutputScalarType(VTK_FLOAT);}
00091   void SetOutputScalarTypeToLong()
00092     {this->SetOutputScalarType(VTK_LONG);}
00093   void SetOutputScalarTypeToUnsignedLong()
00094     {this->SetOutputScalarType(VTK_UNSIGNED_LONG);};
00095   void SetOutputScalarTypeToInt()
00096     {this->SetOutputScalarType(VTK_INT);}
00097   void SetOutputScalarTypeToUnsignedInt()
00098     {this->SetOutputScalarType(VTK_UNSIGNED_INT);}
00099   void SetOutputScalarTypeToShort()
00100     {this->SetOutputScalarType(VTK_SHORT);}
00101   void SetOutputScalarTypeToUnsignedShort()
00102     {this->SetOutputScalarType(VTK_UNSIGNED_SHORT);}
00103   void SetOutputScalarTypeToChar()
00104     {this->SetOutputScalarType(VTK_CHAR);}
00105   void SetOutputScalarTypeToUnsignedChar()
00106     {this->SetOutputScalarType(VTK_UNSIGNED_CHAR);}
00108
00109 protected:
00110   vtkImageEllipsoidSource();
00111   ~vtkImageEllipsoidSource();
00112
00113   int WholeExtent[6];
00114   float Center[3];
00115   float Radius[3];
00116   float InValue;
00117   float OutValue;
00118   int OutputScalarType;
00119
00120   virtual void ExecuteInformation();
00121   virtual void ExecuteData(vtkDataObject *outData);
00122 private:
00123   vtkImageEllipsoidSource(const vtkImageEllipsoidSource&);  // Not implemented.
00124   void operator=(const vtkImageEllipsoidSource&);  // Not implemented.
00125 };
00126
00127
00128 #endif
00129
00130
Generated on Mon Mar 25 01:07:48 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageEuclideanDistance.h Source File

Imaging/vtkImageEuclideanDistance.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageEuclideanDistance.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkImageEuclideanDistance_h
00059 #define __vtkImageEuclideanDistance_h
00060
00061 #include "vtkImageDecomposeFilter.h"
00062
00063 #define VTK_EDT_SAITO_CACHED 0
00064 #define VTK_EDT_SAITO 1
00065
00066 class VTK_IMAGING_EXPORT vtkImageEuclideanDistance : public vtkImageDecomposeFilter
00067 {
00068 public:
00069   static vtkImageEuclideanDistance *New();
00070   vtkTypeRevisionMacro(vtkImageEuclideanDistance,vtkImageDecomposeFilter);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00074
00080   int SplitExtent(int splitExt[6], int startExt[6],
00081                   int num, int total);
00083
00085
00089   vtkSetMacro(Initialize, int);
00090   vtkGetMacro(Initialize, int);
00091   vtkBooleanMacro(Initialize, int);
00093
00095
00097   vtkSetMacro(ConsiderAnisotropy, int);
00098   vtkGetMacro(ConsiderAnisotropy, int);
00099   vtkBooleanMacro(ConsiderAnisotropy, int);
00101
00103
00105   vtkSetMacro(MaximumDistance, float);
00106   vtkGetMacro(MaximumDistance, float);
00108
00110
00112   vtkSetMacro(Algorithm, int);
00113   vtkGetMacro(Algorithm, int);
00114   void SetAlgorithmToSaito ()
00115     { this->SetAlgorithm(VTK_EDT_SAITO); }
00116   void SetAlgorithmToSaitoCached ()
00117     { this->SetAlgorithm(VTK_EDT_SAITO_CACHED); }
00119
00120   void IterativeExecuteData(vtkImageData *in, vtkImageData *out);
00121
00122 protected:
00123   vtkImageEuclideanDistance();
00124   ~vtkImageEuclideanDistance() {}
00125
00126   float MaximumDistance;
00127   int Initialize;
00128   int ConsiderAnisotropy;
00129   int Algorithm;
00130
00131   // Replaces "EnlargeOutputUpdateExtent"
00132   virtual void AllocateOutputScalars(vtkImageData *outData);
00133
00134   void ExecuteInformation(vtkImageData *input, vtkImageData *output);
00135   void ExecuteInformation()
00136     {this->vtkImageIterateFilter::ExecuteInformation();}
00137   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00138 private:
00139   vtkImageEuclideanDistance(const vtkImageEuclideanDistance&);  // Not implemented.
00140   void operator=(const vtkImageEuclideanDistance&);  // Not implemented.
00141 };
00142
00143 #endif
00144
00145
00146
00147
00148
00149
00150
00151
00152
00153
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageEuclideanToPolar.h Source File

Imaging/vtkImageEuclideanToPolar.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageEuclideanToPolar.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageEuclideanToPolar_h
00039 #define __vtkImageEuclideanToPolar_h
00040
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageEuclideanToPolar : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImageEuclideanToPolar *New();
00048   vtkTypeRevisionMacro(vtkImageEuclideanToPolar,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00055   vtkSetMacro(ThetaMaximum,float);
00056   vtkGetMacro(ThetaMaximum,float);
00058
00059 protected:
00060   vtkImageEuclideanToPolar();
00061   ~vtkImageEuclideanToPolar() {};
00062
00063   float ThetaMaximum;
00064
00065   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00066                        int ext[6], int id);
00067 private:
00068   vtkImageEuclideanToPolar(const vtkImageEuclideanToPolar&);  // Not implemented.
00069   void operator=(const vtkImageEuclideanToPolar&);  // Not implemented.
00070 };
00071
00072 #endif
00073
00074
00075
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageExport.h Source File

Imaging/vtkImageExport.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageExport.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkImageExport_h
00047 #define __vtkImageExport_h
00048
00049 #include "vtkProcessObject.h"
00050 #include "vtkImageData.h"
00051
00052 class VTK_IMAGING_EXPORT vtkImageExport : public vtkProcessObject
00053 {
00054 public:
00055   static vtkImageExport *New();
00056   vtkTypeRevisionMacro(vtkImageExport,vtkProcessObject);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   int GetDataMemorySize();
00061
00063
00065   void GetDataDimensions(int *ptr);
00066   int *GetDataDimensions() {
00067     this->GetDataDimensions(this->DataDimensions);
00068     return this->DataDimensions; }
00070
00072
00075   int GetDataNumberOfScalarComponents() {
00076     if (this->GetInput() == NULL) { return 1; }
00077     this->GetInput()->UpdateInformation();
00078     return this->GetInput()->GetNumberOfScalarComponents(); };
00080
00082
00084   int GetDataScalarType() {
00085     if (this->GetInput() == NULL) { return VTK_UNSIGNED_CHAR; }
00086     this->GetInput()->UpdateInformation();
00087     return this->GetInput()->GetScalarType(); };
00088   const char *GetDataScalarTypeAsString() {
00089     return vtkImageScalarTypeNameMacro(this->GetDataScalarType()); }
00091
00093
00094   int *GetDataExtent() {
00095     static int defaultextent[6] = {0, 0, 0, 0, 0, 0};
00096     if (this->GetInput() == NULL) { return defaultextent; }
00097     this->GetInput()->UpdateInformation();
00098     return this->GetInput()->GetWholeExtent(); };
00099   void GetDataExtent(int *ptr) {
00100     if (this->GetInput() == NULL) {
00101       ptr[0] = ptr[1] = ptr[2] = ptr[3] = ptr[4] = ptr[5] = 0; return; }
00102     this->GetInput()->UpdateInformation();
00103     this->GetInput()->GetWholeExtent(ptr); };
00104   float *GetDataSpacing() {
00105     static float defaultspacing[3] = {1, 1, 1};
00106     if (this->GetInput() == NULL) { return defaultspacing; }
00107     this->GetInput()->UpdateInformation();
00108     return this->GetInput()->GetSpacing(); };
00109   void GetDataSpacing(float *ptr) {
00110     if (this->GetInput() == NULL) { ptr[0] = ptr[1] = ptr[2] = 0.0; return; }
00111     this->GetInput()->UpdateInformation();
00112     this->GetInput()->GetSpacing(ptr); };
00113   float *GetDataOrigin() {
00114     static float defaultorigin[3] = {0, 0, 0};
00115     if (this->GetInput() == NULL) { return defaultorigin; }
00116     this->GetInput()->UpdateInformation();
00117     return this->GetInput()->GetOrigin(); };
00118   void GetDataOrigin(float *ptr) {
00119     if (this->GetInput() == NULL) { ptr[0] = ptr[1] = ptr[2] = 0.0; return; }
00120     this->GetInput()->UpdateInformation();
00121     this->GetInput()->GetOrigin(ptr); };
00123
00125
00126   void SetInput(vtkImageData *input);
00127   vtkImageData *GetInput();
00129
00131
00136   vtkBooleanMacro(ImageLowerLeft, int);
00137   vtkGetMacro(ImageLowerLeft, int);
00138   vtkSetMacro(ImageLowerLeft, int);
00140
00142
00145   void SetExportVoidPointer(void *);
00146   void *GetExportVoidPointer() { return this->ExportVoidPointer; };
00148
00150
00153   void Export() { this->Export(this->ExportVoidPointer); };
00154   virtual void Export(void *);
00156
00161   void *GetPointerToData();
00162
00164   void* GetCallbackUserData();
00165
00166   //BTX
00168   /*! These are function pointer types for the pipeline connection
00169       callbacks.  See furhter documentation in vtkImageImport.h. */
00170   typedef void (*UpdateInformationCallbackType)(void*);
00171   typedef int (*PipelineModifiedCallbackType)(void*);
00172   typedef int* (*WholeExtentCallbackType)(void*);
00173   typedef float* (*SpacingCallbackType)(void*);
00174   typedef float* (*OriginCallbackType)(void*);
00175   typedef const char* (*ScalarTypeCallbackType)(void*);
00176   typedef int (*NumberOfComponentsCallbackType)(void*);
00177   typedef void (*PropagateUpdateExtentCallbackType)(void*, int*);
00178   typedef void (*UpdateDataCallbackType)(void*);
00179   typedef int* (*DataExtentCallbackType)(void*);
00180   typedef void* (*BufferPointerCallbackType)(void*);
00182
00184
00185   UpdateInformationCallbackType     GetUpdateInformationCallback() const;
00186   PipelineModifiedCallbackType      GetPipelineModifiedCallback() const;
00187   WholeExtentCallbackType           GetWholeExtentCallback() const;
00188   SpacingCallbackType               GetSpacingCallback() const;
00189   OriginCallbackType                GetOriginCallback() const;
00190   ScalarTypeCallbackType            GetScalarTypeCallback() const;
00191   NumberOfComponentsCallbackType    GetNumberOfComponentsCallback() const;
00192   PropagateUpdateExtentCallbackType GetPropagateUpdateExtentCallback() const;
00193   UpdateDataCallbackType            GetUpdateDataCallback() const;
00194   DataExtentCallbackType            GetDataExtentCallback() const;
00195   BufferPointerCallbackType         GetBufferPointerCallback() const;
00196   //ETX
00198
00199 protected:
00200   vtkImageExport();
00201   ~vtkImageExport();
00202
00203   virtual void UpdateInformationCallback();
00204   virtual int PipelineModifiedCallback();
00205   virtual void UpdateDataCallback();
00206   virtual int* WholeExtentCallback();
00207   virtual float* SpacingCallback();
00208   virtual float* OriginCallback();
00209   virtual const char* ScalarTypeCallback();
00210   virtual int NumberOfComponentsCallback();
00211   virtual void PropagateUpdateExtentCallback(int*);
00212   virtual int* DataExtentCallback();
00213   virtual void* BufferPointerCallback();
00214
00215   int ImageLowerLeft;
00216   int DataDimensions[3];
00217   void *ExportVoidPointer;
00218
00219   unsigned long LastPipelineMTime;
00220
00221 private:
00222   vtkImageExport(const vtkImageExport&);  // Not implemented.
00223   void operator=(const vtkImageExport&);  // Not implemented.
00224
00225   static void UpdateInformationCallbackFunction(void*);
00226   static int PipelineModifiedCallbackFunction(void*);
00227   static int* WholeExtentCallbackFunction(void*);
00228   static float* SpacingCallbackFunction(void*);
00229   static float* OriginCallbackFunction(void*);
00230   static const char* ScalarTypeCallbackFunction(void*);
00231   static int NumberOfComponentsCallbackFunction(void*);
00232   static void PropagateUpdateExtentCallbackFunction(void*, int*);
00233   static void UpdateDataCallbackFunction(void*);
00234   static int* DataExtentCallbackFunction(void*);
00235   static void* BufferPointerCallbackFunction(void*);
00236 };
00237
00238 #endif
00239
00240
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageExtractComponents.h Source File

Imaging/vtkImageExtractComponents.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageExtractComponents.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageExtractComponents_h
00040 #define __vtkImageExtractComponents_h
00041
00042
00043 #include "vtkImageToImageFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageExtractComponents : public vtkImageToImageFilter
00046 {
00047 public:
00048   static vtkImageExtractComponents *New();
00049   vtkTypeRevisionMacro(vtkImageExtractComponents,vtkImageToImageFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   void SetComponents(int c1);
00055   void SetComponents(int c1, int c2);
00056   void SetComponents(int c1, int c2, int c3);
00057   vtkGetVector3Macro(Components,int);
00059
00061
00063   vtkGetMacro(NumberOfComponents,int);
00065
00066 protected:
00067   vtkImageExtractComponents();
00068   ~vtkImageExtractComponents() {};
00069
00070   int NumberOfComponents;
00071   int Components[3];
00072
00073   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00074   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00075   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00076                        int ext[6], int id);
00077 private:
00078   vtkImageExtractComponents(const vtkImageExtractComponents&);  // Not implemented.
00079   void operator=(const vtkImageExtractComponents&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
00085
00086
00087
00088
00089
00090
00091
00092
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageFFT.h Source File

Imaging/vtkImageFFT.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageFFT.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkImageFFT_h
00043 #define __vtkImageFFT_h
00044
00045
00046 #include "vtkImageFourierFilter.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageFFT : public vtkImageFourierFilter
00049 {
00050 public:
00051   static vtkImageFFT *New();
00052   vtkTypeRevisionMacro(vtkImageFFT,vtkImageFourierFilter);
00053
00054
00056
00062   int SplitExtent(int splitExt[6], int startExt[6],
00063                   int num, int total);
00065
00066   virtual void IterativeExecuteData(vtkImageData *in, vtkImageData *out)
00067     { this->MultiThread(in,out); };
00068
00069
00070 protected:
00071   vtkImageFFT() {};
00072   ~vtkImageFFT() {};
00073
00074   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00075   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00076   void ExecuteInformation(){this->vtkImageIterateFilter::ExecuteInformation();};
00077
00078   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00079                        int outExt[6], int threadId);
00080 private:
00081   vtkImageFFT(const vtkImageFFT&);  // Not implemented.
00082   void operator=(const vtkImageFFT&);  // Not implemented.
00083 };
00084
00085 #endif
00086
00087
00088
00089
00090
00091
00092
00093
00094
00095
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageFlip.h Source File

Imaging/vtkImageFlip.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageFlip.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageFlip_h
00041 #define __vtkImageFlip_h
00042
00043
00044 #include "vtkImageToImageFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageFlip : public vtkImageToImageFilter
00047 {
00048 public:
00049   static vtkImageFlip *New();
00050
00051   vtkTypeRevisionMacro(vtkImageFlip,vtkImageToImageFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkSetMacro(FilteredAxis, int);
00057   vtkGetMacro(FilteredAxis, int);
00059
00062   void SetFilteredAxes(int axis) {this->SetFilteredAxis(axis);}
00063
00065
00068   vtkSetMacro(PreserveImageExtent, int);
00069   vtkGetMacro(PreserveImageExtent, int);
00070   vtkBooleanMacro(PreserveImageExtent, int);
00072
00073 protected:
00074   vtkImageFlip();
00075   ~vtkImageFlip() {};
00076
00077   int FilteredAxis;
00078   int PreserveImageExtent;
00079
00080   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00081   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00082   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00083   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00084                        int outExt[6], int id);
00085 private:
00086   vtkImageFlip(const vtkImageFlip&);  // Not implemented.
00087   void operator=(const vtkImageFlip&);  // Not implemented.
00088 };
00089
00090 #endif
00091
00092
00093
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageFourierCenter.h Source File

Imaging/vtkImageFourierCenter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageFourierCenter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageFourierCenter_h
00040 #define __vtkImageFourierCenter_h
00041
00042
00043 #include "vtkImageDecomposeFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageFourierCenter : public vtkImageDecomposeFilter
00046 {
00047 public:
00048   static vtkImageFourierCenter *New();
00049   vtkTypeRevisionMacro(vtkImageFourierCenter,vtkImageDecomposeFilter);
00050
00052
00053   virtual void IterativeExecuteData(vtkImageData *in, vtkImageData *out) {
00054     this->MultiThread(in, out); };
00056
00057 protected:
00058   vtkImageFourierCenter();
00059   ~vtkImageFourierCenter() {};
00060
00061   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00062   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00063                        int outExt[6], int threadId);
00064 private:
00065   vtkImageFourierCenter(const vtkImageFourierCenter&);  // Not implemented.
00066   void operator=(const vtkImageFourierCenter&);  // Not implemented.
00067 };
00068
00069 #endif
00070
00071
00072
00073
00074
00075
00076
00077
00078
00079
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageFourierFilter.h Source File

Imaging/vtkImageFourierFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageFourierFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageFourierFilter_h
00036 #define __vtkImageFourierFilter_h
00037
00038
00039 #include "vtkImageDecomposeFilter.h"
00040
00041
00042 //BTX
00043 /*******************************************************************
00044                         COMPLEX number stuff
00045 *******************************************************************/
00046
00047
00048 typedef struct{
00049     double Real;
00050     double Imag;
00051   } vtkImageComplex;
00052
00053
00054 #define vtkImageComplexEuclidSet(C, R, I) \
00055   (C).Real = (R); \
00056   (C).Imag = (I)
00057
00058 #define vtkImageComplexPolarSet(C, M, P) \
00059   (C).Real = (M)*cos(P); \
00060   (C).Imag = (M)*sin(P)
00061
00062 #define vtkImageComplexPrint(C) \
00063   printf("(%.3f, %.3f)", (C).Real, (C).Imag)
00064
00065 #define vtkImageComplexScale(cOut, S, cIn) \
00066   (cOut).Real = (cIn).Real * (S); \
00067   (cOut).Imag = (cIn).Imag * (S)
00068
00069 #define vtkImageComplexConjugate(cIn, cOut) \
00070   (cOut).Imag = (cIn).Imag * -1.0;    \
00071   (cOut).Real = (cIn).Real
00072
00073 #define vtkImageComplexAdd(C1, C2, cOut) \
00074   (cOut).Real = (C1).Real + (C2).Real; \
00075   (cOut).Imag = (C1).Imag + (C2).Imag
00076
00077 #define vtkImageComplexSubtract(C1, C2, cOut) \
00078   (cOut).Real = (C1).Real - (C2).Real; \
00079   (cOut).Imag = (C1).Imag - (C2).Imag
00080
00081 #define vtkImageComplexMultiply(C1, C2, cOut) \
00082 { \
00083   vtkImageComplex _vtkImageComplexMultiplyTemp; \
00084   _vtkImageComplexMultiplyTemp.Real = (C1).Real*(C2).Real-(C1).Imag*(C2).Imag;\
00085   _vtkImageComplexMultiplyTemp.Imag = (C1).Real*(C2).Imag+(C1).Imag*(C2).Real;\
00086   cOut = _vtkImageComplexMultiplyTemp; \
00087 }
00088
00089 // This macro calculates exp(cIn) and puts the result in cOut
00090 #define vtkImageComplexExponential(cIn, cOut) \
00091 { \
00092   float tmp = exp(cIn.Real); \
00093   cOut.Real = tmp * cos(cIn.Imag); \
00094   cOut.Imag = tmp * sin(cIn.Imag); \
00095 }
00096
00097 /******************* End of COMPLEX number stuff ********************/
00098 //ETX
00099
00100 class VTK_IMAGING_EXPORT vtkImageFourierFilter : public vtkImageDecomposeFilter
00101 {
00102 public:
00103   vtkTypeRevisionMacro(vtkImageFourierFilter,vtkImageDecomposeFilter);
00104
00105
00106   // public for templated functions of this object
00107   //BTX
00108
00111   void ExecuteFft(vtkImageComplex *in, vtkImageComplex *out, int N);
00112
00113
00116   void ExecuteRfft(vtkImageComplex *in, vtkImageComplex *out, int N);
00117
00118   //ETX
00119
00120 protected:
00121   vtkImageFourierFilter() {};
00122   ~vtkImageFourierFilter() {};
00123
00124   //BTX
00125   void ExecuteFftStep2(vtkImageComplex *p_in, vtkImageComplex *p_out,
00126                        int N, int bsize, int fb);
00127   void ExecuteFftStepN(vtkImageComplex *p_in, vtkImageComplex *p_out,
00128                        int N, int bsize, int n, int fb);
00129   void ExecuteFftForwardBackward(vtkImageComplex *in, vtkImageComplex *out,
00130                                  int N, int fb);
00131   //ETX
00132 private:
00133   vtkImageFourierFilter(const vtkImageFourierFilter&);  // Not implemented.
00134   void operator=(const vtkImageFourierFilter&);  // Not implemented.
00135 };
00136
00137
00138
00139 #endif
00140
00141
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageGaussianSmooth.h Source File

Imaging/vtkImageGaussianSmooth.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageGaussianSmooth.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageGaussianSmooth_h
00036 #define __vtkImageGaussianSmooth_h
00037
00038
00039 #include "vtkImageToImageFilter.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageGaussianSmooth : public vtkImageToImageFilter
00042 {
00043 public:
00044   vtkTypeRevisionMacro(vtkImageGaussianSmooth,vtkImageToImageFilter);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00050   static vtkImageGaussianSmooth *New();
00051
00052
00054
00055   vtkSetVector3Macro(StandardDeviations, float);
00056   void SetStandardDeviation(float std)
00057         {this->SetStandardDeviations(std,std,std);}
00058   void SetStandardDeviations(float a,float b)
00059         {this->SetStandardDeviations(a,b,0.0);}
00060   vtkGetVector3Macro(StandardDeviations, float);
00062
00064
00066   void SetStandardDeviation(float a,float b)
00067         {this->SetStandardDeviations(a,b,0.0);}
00068   void SetStandardDeviation(float a,float b,float c)
00069         {this->SetStandardDeviations(a,b,c);}
00071
00073
00076   vtkSetVector3Macro(RadiusFactors, float);
00077   void SetRadiusFactors(float f, float f2) {this->SetRadiusFactors(f,f2,1.5);}
00078   void SetRadiusFactor(float f) {this->SetRadiusFactors(f, f, f);}
00079   vtkGetVector3Macro(RadiusFactors, float);
00081
00083
00085   vtkSetMacro(Dimensionality, int);
00086   vtkGetMacro(Dimensionality, int);
00088
00089 protected:
00090   vtkImageGaussianSmooth();
00091   ~vtkImageGaussianSmooth();
00092
00093   int Dimensionality;
00094   float StandardDeviations[3];
00095   float RadiusFactors[3];
00096
00097   void ComputeKernel(double *kernel, int min, int max, double std);
00098   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00099   void ExecuteAxis(int axis, vtkImageData *inData, int inExt[6],
00100                    vtkImageData *outData, int outExt[6],
00101                    int *pcycle, int target, int *pcount, int total);
00102   void ThreadedExecute(vtkImageData *inData,
00103                        vtkImageData *outData, int outExt[6], int id);
00104
00105 private:
00106   vtkImageGaussianSmooth(const vtkImageGaussianSmooth&);  // Not implemented.
00107   void operator=(const vtkImageGaussianSmooth&);  // Not implemented.
00108 };
00109
00110 #endif
00111
00112
00113
00114
00115
00116
00117
00118
00119
00120
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageGaussianSource.h Source File

Imaging/vtkImageGaussianSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageGaussianSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageGaussianSource_h
00038 #define __vtkImageGaussianSource_h
00039
00040 #include "vtkImageSource.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageGaussianSource : public vtkImageSource
00043 {
00044 public:
00045   static vtkImageGaussianSource *New();
00046   vtkTypeRevisionMacro(vtkImageGaussianSource,vtkImageSource);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   void SetWholeExtent(int xMinx, int xMax, int yMin, int yMax,
00052                       int zMin, int zMax);
00054
00056
00057   vtkSetVector3Macro(Center, float);
00058   vtkGetVector3Macro(Center, float);
00060
00062
00063   vtkSetMacro(Maximum, float);
00064   vtkGetMacro(Maximum, float);
00066
00068
00069   vtkSetMacro(StandardDeviation, float);
00070   vtkGetMacro(StandardDeviation, float);
00072
00073 protected:
00074   vtkImageGaussianSource();
00075   ~vtkImageGaussianSource() {};
00076
00077   float StandardDeviation;
00078   int WholeExtent[6];
00079   float Center[3];
00080   float Maximum;
00081
00082   virtual void ExecuteInformation();
00083   virtual void ExecuteData(vtkDataObject *data);
00084 private:
00085   vtkImageGaussianSource(const vtkImageGaussianSource&);  // Not implemented.
00086   void operator=(const vtkImageGaussianSource&);  // Not implemented.
00087 };
00088
00089
00090 #endif
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageGradient.h Source File

Imaging/vtkImageGradient.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageGradient.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkImageGradient_h
00043 #define __vtkImageGradient_h
00044
00045
00046 #include "vtkImageToImageFilter.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageGradient : public vtkImageToImageFilter
00049 {
00050 public:
00051   static vtkImageGradient *New();
00052   vtkTypeRevisionMacro(vtkImageGradient,vtkImageToImageFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetClampMacro(Dimensionality,int,2,3);
00058   vtkGetMacro(Dimensionality,int);
00060
00062
00064   vtkSetMacro(HandleBoundaries, int);
00065   vtkGetMacro(HandleBoundaries, int);
00066   vtkBooleanMacro(HandleBoundaries, int);
00068
00069 protected:
00070   vtkImageGradient();
00071   ~vtkImageGradient() {};
00072
00073   int HandleBoundaries;
00074   int Dimensionality;
00075
00076   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00077   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00078   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00079   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00080                        int extent[6], int id);
00081 private:
00082   vtkImageGradient(const vtkImageGradient&);  // Not implemented.
00083   void operator=(const vtkImageGradient&);  // Not implemented.
00084 };
00085
00086 #endif
00087
00088
00089
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageGradientMagnitude.h Source File

Imaging/vtkImageGradientMagnitude.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageGradientMagnitude.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageGradientMagnitude_h
00045 #define __vtkImageGradientMagnitude_h
00046
00047
00048 #include "vtkImageToImageFilter.h"
00049
00050 class VTK_IMAGING_EXPORT vtkImageGradientMagnitude : public vtkImageToImageFilter
00051 {
00052 public:
00053   static vtkImageGradientMagnitude *New();
00054   vtkTypeRevisionMacro(vtkImageGradientMagnitude,vtkImageToImageFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00060   vtkSetMacro(HandleBoundaries, int);
00061   vtkGetMacro(HandleBoundaries, int);
00062   vtkBooleanMacro(HandleBoundaries, int);
00064
00066
00067   vtkSetClampMacro(Dimensionality,int,2,3);
00068   vtkGetMacro(Dimensionality,int);
00070
00071 protected:
00072   vtkImageGradientMagnitude();
00073   ~vtkImageGradientMagnitude() {};
00074
00075   int HandleBoundaries;
00076   int Dimensionality;
00077
00078   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00079   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00080   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00081   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00082                        int extent[6], int id);
00083 private:
00084   vtkImageGradientMagnitude(const vtkImageGradientMagnitude&);  // Not implemented.
00085   void operator=(const vtkImageGradientMagnitude&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
00091
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageGridSource.h Source File

Imaging/vtkImageGridSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageGridSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageGridSource_h
00037 #define __vtkImageGridSource_h
00038
00039 #include "vtkImageSource.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageGridSource : public vtkImageSource
00042 {
00043 public:
00044   static vtkImageGridSource *New();
00045   vtkTypeRevisionMacro(vtkImageGridSource,vtkImageSource);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkSetVector3Macro(GridSpacing,int);
00052   vtkGetVector3Macro(GridSpacing,int);
00054
00056
00057   vtkSetVector3Macro(GridOrigin,int);
00058   vtkGetVector3Macro(GridOrigin,int);
00060
00062
00063   vtkSetMacro(LineValue,float);
00064   vtkGetMacro(LineValue,float);
00066
00068
00069   vtkSetMacro(FillValue,float);
00070   vtkGetMacro(FillValue,float);
00072
00074
00076   vtkSetMacro(DataScalarType,int);
00077   void SetDataScalarTypeToFloat(){this->SetDataScalarType(VTK_FLOAT);}
00078   void SetDataScalarTypeToInt(){this->SetDataScalarType(VTK_INT);}
00079   void SetDataScalarTypeToShort(){this->SetDataScalarType(VTK_SHORT);}
00080   void SetDataScalarTypeToUnsignedShort()
00081     {this->SetDataScalarType(VTK_UNSIGNED_SHORT);}
00082   void SetDataScalarTypeToUnsignedChar()
00083     {this->SetDataScalarType(VTK_UNSIGNED_CHAR);}
00084   vtkGetMacro(DataScalarType, int);
00085   const char *GetDataScalarTypeAsString() {
00086     return vtkImageScalarTypeNameMacro(this->DataScalarType); }
00088
00090
00092   vtkSetVector6Macro(DataExtent,int);
00093   vtkGetVector6Macro(DataExtent,int);
00095
00097
00098   vtkSetVector3Macro(DataSpacing,float);
00099   vtkGetVector3Macro(DataSpacing,float);
00101
00103
00104   vtkSetVector3Macro(DataOrigin,float);
00105   vtkGetVector3Macro(DataOrigin,float);
00107
00108 protected:
00109   vtkImageGridSource();
00110   ~vtkImageGridSource() {};
00111
00112   int GridSpacing[3];
00113   int GridOrigin[3];
00114
00115   float LineValue;
00116   float FillValue;
00117
00118   int DataScalarType;
00119
00120   int DataExtent[6];
00121   float DataSpacing[3];
00122   float DataOrigin[3];
00123
00124   virtual void ExecuteInformation();
00125   virtual void ExecuteData(vtkDataObject *data);
00126 private:
00127   vtkImageGridSource(const vtkImageGridSource&);  // Not implemented.
00128   void operator=(const vtkImageGridSource&);  // Not implemented.
00129 };
00130
00131
00132 #endif
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageHSVToRGB.h Source File

Imaging/vtkImageHSVToRGB.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageHSVToRGB.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageHSVToRGB_h
00041 #define __vtkImageHSVToRGB_h
00042
00043
00044 #include "vtkImageToImageFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageHSVToRGB : public vtkImageToImageFilter
00047 {
00048 public:
00049   static vtkImageHSVToRGB *New();
00050   vtkTypeRevisionMacro(vtkImageHSVToRGB,vtkImageToImageFilter);
00051
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00059   vtkSetMacro(Maximum,float);
00060   vtkGetMacro(Maximum,float);
00062
00063 protected:
00064   vtkImageHSVToRGB();
00065   ~vtkImageHSVToRGB() {};
00066
00067   float Maximum;
00068
00069   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00070                        int ext[6], int id);
00071 private:
00072   vtkImageHSVToRGB(const vtkImageHSVToRGB&);  // Not implemented.
00073   void operator=(const vtkImageHSVToRGB&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
00079
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageHybridMedian2D.h Source File

Imaging/vtkImageHybridMedian2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageHybridMedian2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageHybridMedian2D_h
00041 #define __vtkImageHybridMedian2D_h
00042
00043
00044 #include "vtkImageSpatialFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageHybridMedian2D : public vtkImageSpatialFilter
00047 {
00048 public:
00049   static vtkImageHybridMedian2D *New();
00050   vtkTypeRevisionMacro(vtkImageHybridMedian2D,vtkImageSpatialFilter);
00051
00052 protected:
00053   vtkImageHybridMedian2D();
00054   ~vtkImageHybridMedian2D() {};
00055
00056   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00057                        int outExt[6], int id);
00058   float ComputeMedian(float *array, int size);
00059 private:
00060   vtkImageHybridMedian2D(const vtkImageHybridMedian2D&);  // Not implemented.
00061   void operator=(const vtkImageHybridMedian2D&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
00067
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageIdealHighPass.h Source File

Imaging/vtkImageIdealHighPass.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageIdealHighPass.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageIdealHighPass_h
00046 #define __vtkImageIdealHighPass_h
00047
00048
00049 #include "vtkImageToImageFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageIdealHighPass : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageIdealHighPass *New();
00055   vtkTypeRevisionMacro(vtkImageIdealHighPass,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00062   vtkSetVector3Macro(CutOff,float);
00063   void SetCutOff(float v) {this->SetCutOff(v, v, v);}
00064   void SetXCutOff(float v);
00065   void SetYCutOff(float v);
00066   void SetZCutOff(float v);
00067   vtkGetVector3Macro(CutOff,float);
00068   float GetXCutOff() {return this->CutOff[0];}
00069   float GetYCutOff() {return this->CutOff[1];}
00070   float GetZCutOff() {return this->CutOff[2];}
00072
00073 protected:
00074   vtkImageIdealHighPass();
00075   ~vtkImageIdealHighPass() {};
00076
00077   float CutOff[3];
00078
00079   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00080                        int outExt[6], int id);
00081 private:
00082   vtkImageIdealHighPass(const vtkImageIdealHighPass&);  // Not implemented.
00083   void operator=(const vtkImageIdealHighPass&);  // Not implemented.
00084 };
00085
00086 #endif
00087
00088
00089
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageIdealLowPass.h Source File

Imaging/vtkImageIdealLowPass.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageIdealLowPass.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageIdealLowPass_h
00046 #define __vtkImageIdealLowPass_h
00047
00048
00049 #include "vtkImageToImageFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageIdealLowPass : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageIdealLowPass *New();
00055   vtkTypeRevisionMacro(vtkImageIdealLowPass,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00062   vtkSetVector3Macro(CutOff,float);
00063   void SetCutOff(float v) {this->SetCutOff(v, v, v);}
00064   void SetXCutOff(float v);
00065   void SetYCutOff(float v);
00066   void SetZCutOff(float v);
00067   vtkGetVector3Macro(CutOff,float);
00068   float GetXCutOff() {return this->CutOff[0];}
00069   float GetYCutOff() {return this->CutOff[1];}
00070   float GetZCutOff() {return this->CutOff[2];}
00072
00073 protected:
00074   vtkImageIdealLowPass();
00075   ~vtkImageIdealLowPass() {};
00076
00077   float CutOff[3];
00078
00079   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00080                        int outExt[6], int id);
00081 private:
00082   vtkImageIdealLowPass(const vtkImageIdealLowPass&);  // Not implemented.
00083   void operator=(const vtkImageIdealLowPass&);  // Not implemented.
00084 };
00085
00086 #endif
00087
00088
00089
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageImport.h Source File

Imaging/vtkImageImport.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageImport.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkImageImport_h
00047 #define __vtkImageImport_h
00048
00049 #include "vtkImageSource.h"
00050 #include "vtkTransform.h"
00051
00052 class VTK_IMAGING_EXPORT vtkImageImport : public vtkImageSource
00053 {
00054 public:
00055   static vtkImageImport *New();
00056   vtkTypeRevisionMacro(vtkImageImport,vtkImageSource);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00062   void CopyImportVoidPointer(void *ptr, int size);
00063
00065
00069   void SetImportVoidPointer(void *ptr);
00070   void *GetImportVoidPointer() {return this->ImportVoidPointer;};
00072
00078   void SetImportVoidPointer(void *ptr, int save);
00079
00081
00083   vtkSetMacro(DataScalarType,int);
00084   void SetDataScalarTypeToDouble(){this->SetDataScalarType(VTK_DOUBLE);}
00085   void SetDataScalarTypeToFloat(){this->SetDataScalarType(VTK_FLOAT);}
00086   void SetDataScalarTypeToInt(){this->SetDataScalarType(VTK_INT);}
00087   void SetDataScalarTypeToShort(){this->SetDataScalarType(VTK_SHORT);}
00088   void SetDataScalarTypeToUnsignedShort()
00089     {this->SetDataScalarType(VTK_UNSIGNED_SHORT);}
00090   void SetDataScalarTypeToUnsignedChar()
00091     {this->SetDataScalarType(VTK_UNSIGNED_CHAR);}
00092   vtkGetMacro(DataScalarType, int);
00093   const char *GetDataScalarTypeAsString() {
00094     return vtkImageScalarTypeNameMacro(this->DataScalarType); }
00096
00098
00100   vtkSetMacro(NumberOfScalarComponents,int);
00101   vtkGetMacro(NumberOfScalarComponents,int);
00103
00105
00109   vtkSetVector6Macro(DataExtent,int);
00110   vtkGetVector6Macro(DataExtent,int);
00111   void SetDataExtentToWholeExtent()
00112     {this->SetDataExtent(this->GetWholeExtent());}
00114
00116
00118   vtkSetVector3Macro(DataSpacing,float);
00119   vtkGetVector3Macro(DataSpacing,float);
00121
00123
00125   vtkSetVector3Macro(DataOrigin,float);
00126   vtkGetVector3Macro(DataOrigin,float);
00128
00130
00133   vtkSetVector6Macro(WholeExtent,int);
00134   vtkGetVector6Macro(WholeExtent,int);
00136
00138   virtual void PropagateUpdateExtent(vtkDataObject *output);
00139
00140   //BTX
00142   /*! These are function pointer types for the pipeline connection
00143       callbacks.  See furhter documentation on each individual callback. */
00144   typedef void (*UpdateInformationCallbackType)(void*);
00145   typedef int (*PipelineModifiedCallbackType)(void*);
00146   typedef int* (*WholeExtentCallbackType)(void*);
00147   typedef float* (*SpacingCallbackType)(void*);
00148   typedef float* (*OriginCallbackType)(void*);
00149   typedef const char* (*ScalarTypeCallbackType)(void*);
00150   typedef int (*NumberOfComponentsCallbackType)(void*);
00151   typedef void (*PropagateUpdateExtentCallbackType)(void*, int*);
00152   typedef void (*UpdateDataCallbackType)(void*);
00153   typedef int* (*DataExtentCallbackType)(void*);
00154   typedef void* (*BufferPointerCallbackType)(void*);
00156
00158
00161   vtkSetMacro(UpdateInformationCallback, UpdateInformationCallbackType);
00162   vtkGetMacro(UpdateInformationCallback, UpdateInformationCallbackType);
00164
00166
00170   vtkSetMacro(PipelineModifiedCallback, PipelineModifiedCallbackType);
00171   vtkGetMacro(PipelineModifiedCallback, PipelineModifiedCallbackType);
00173
00175
00179   vtkSetMacro(WholeExtentCallback, WholeExtentCallbackType);
00180   vtkGetMacro(WholeExtentCallback, WholeExtentCallbackType);
00182
00184
00187   vtkSetMacro(SpacingCallback, SpacingCallbackType);
00188   vtkGetMacro(SpacingCallback, SpacingCallbackType);
00190
00192
00195   vtkSetMacro(OriginCallback, OriginCallbackType);
00196   vtkGetMacro(OriginCallback, OriginCallbackType);
00198
00200
00203   vtkSetMacro(ScalarTypeCallback, ScalarTypeCallbackType);
00204   vtkGetMacro(ScalarTypeCallback, ScalarTypeCallbackType);
00206
00208
00211   vtkSetMacro(NumberOfComponentsCallback, NumberOfComponentsCallbackType);
00212   vtkGetMacro(NumberOfComponentsCallback, NumberOfComponentsCallbackType);
00214
00216
00221   vtkSetMacro(PropagateUpdateExtentCallback,PropagateUpdateExtentCallbackType);
00222   vtkGetMacro(PropagateUpdateExtentCallback,PropagateUpdateExtentCallbackType);
00224
00226
00229   vtkSetMacro(UpdateDataCallback, UpdateDataCallbackType);
00230   vtkGetMacro(UpdateDataCallback, UpdateDataCallbackType);
00232
00234
00239   vtkSetMacro(DataExtentCallback, DataExtentCallbackType);
00240   vtkGetMacro(DataExtentCallback, DataExtentCallbackType);
00242
00244
00248   vtkSetMacro(BufferPointerCallback, BufferPointerCallbackType);
00249   vtkGetMacro(BufferPointerCallback, BufferPointerCallbackType);
00251
00253
00255   vtkSetMacro(CallbackUserData, void*);
00256   vtkGetMacro(CallbackUserData, void*);
00258
00259   //ETX
00260
00261 protected:
00262   vtkImageImport();
00263   ~vtkImageImport();
00264
00265   virtual void UpdateInformation();
00266   virtual void ExecuteInformation();
00267
00268   void InvokeUpdateInformationCallbacks();
00269   void InvokeExecuteInformationCallbacks();
00270   void InvokeExecuteDataCallbacks();
00271   void LegacyCheckWholeExtent();
00272
00273   void *ImportVoidPointer;
00274   int SaveUserArray;
00275
00276   int NumberOfScalarComponents;
00277   int DataScalarType;
00278
00279   int WholeExtent[6];
00280   int DataExtent[6];
00281   float DataSpacing[3];
00282   float DataOrigin[3];
00283
00284   void* CallbackUserData;
00285
00286   //BTX
00287   UpdateInformationCallbackType     UpdateInformationCallback;
00288   PipelineModifiedCallbackType      PipelineModifiedCallback;
00289   WholeExtentCallbackType           WholeExtentCallback;
00290   SpacingCallbackType               SpacingCallback;
00291   OriginCallbackType                OriginCallback;
00292   ScalarTypeCallbackType            ScalarTypeCallback;
00293   NumberOfComponentsCallbackType    NumberOfComponentsCallback;
00294   PropagateUpdateExtentCallbackType PropagateUpdateExtentCallback;
00295   UpdateDataCallbackType            UpdateDataCallback;
00296   DataExtentCallbackType            DataExtentCallback;
00297   BufferPointerCallbackType         BufferPointerCallback;
00298   //ETX
00299
00300   virtual void ExecuteData(vtkDataObject *d);
00301
00302 private:
00303   vtkImageImport(const vtkImageImport&);  // Not implemented.
00304   void operator=(const vtkImageImport&);  // Not implemented.
00305 };
00306
00307 #endif
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageInPlaceFilter.h Source File

Filtering/vtkImageInPlaceFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageInPlaceFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageInPlaceFilter_h
00040 #define __vtkImageInPlaceFilter_h
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_FILTERING_EXPORT vtkImageInPlaceFilter : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImageInPlaceFilter *New();
00048   vtkTypeRevisionMacro(vtkImageInPlaceFilter,vtkImageToImageFilter);
00049
00050
00051 protected:
00052   vtkImageInPlaceFilter() {};
00053   ~vtkImageInPlaceFilter() {};
00054
00055   virtual void ExecuteData(vtkDataObject *out);
00056   void CopyData(vtkImageData *in, vtkImageData *out);
00057
00058 private:
00059   vtkImageInPlaceFilter(const vtkImageInPlaceFilter&);  // Not implemented.
00060   void operator=(const vtkImageInPlaceFilter&);  // Not implemented.
00061 };
00062
00063 #endif
00064
00065
00066
00067
00068
00069
00070
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageIslandRemoval2D.h Source File

Imaging/vtkImageIslandRemoval2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageIslandRemoval2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageIslandRemoval2D_h
00039 #define __vtkImageIslandRemoval2D_h
00040
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 //BTX
00045 typedef struct{
00046   void *inPtr;
00047   void *outPtr;
00048   int idx0;
00049   int idx1;
00050   } vtkImage2DIslandPixel;
00051 //ETX
00052
00053 class VTK_IMAGING_EXPORT vtkImageIslandRemoval2D : public vtkImageToImageFilter
00054 {
00055 public:
00057
00058   static vtkImageIslandRemoval2D *New();
00059   vtkTypeRevisionMacro(vtkImageIslandRemoval2D,vtkImageToImageFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00065   vtkSetMacro(AreaThreshold, int);
00066   vtkGetMacro(AreaThreshold, int);
00068
00070
00071   vtkSetMacro(SquareNeighborhood, int);
00072   vtkGetMacro(SquareNeighborhood, int);
00073   vtkBooleanMacro(SquareNeighborhood, int);
00075
00077
00078   vtkSetMacro(IslandValue, float);
00079   vtkGetMacro(IslandValue, float);
00081
00083
00084   vtkSetMacro(ReplaceValue, float);
00085   vtkGetMacro(ReplaceValue, float);
00087
00088 protected:
00089   vtkImageIslandRemoval2D();
00090   ~vtkImageIslandRemoval2D() {};
00091
00092   int AreaThreshold;
00093   int SquareNeighborhood;
00094   float IslandValue;
00095   float ReplaceValue;
00096
00097   void ExecuteData(vtkDataObject *output);
00098 private:
00099   vtkImageIslandRemoval2D(const vtkImageIslandRemoval2D&);  // Not implemented.
00100   void operator=(const vtkImageIslandRemoval2D&);  // Not implemented.
00101 };
00102
00103 #endif
00104
00105
00106
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageIterateFilter.h Source File

Imaging/vtkImageIterateFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageIterateFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageIterateFilter_h
00037 #define __vtkImageIterateFilter_h
00038
00039
00040 #include "vtkImageToImageFilter.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageIterateFilter : public vtkImageToImageFilter
00043 {
00044 public:
00045   vtkTypeRevisionMacro(vtkImageIterateFilter,vtkImageToImageFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkGetMacro(Iteration,int);
00052   vtkGetMacro(NumberOfIterations,int);
00054
00055   void ComputeInputUpdateExtents( vtkDataObject *output );
00056   //BTX
00057   void ComputeInputUpdateExtent( int [6], int [6] )
00058     { vtkErrorMacro( << "ComputeInputUpdateExtent should be implemented in subclass" );};
00059   //ETX
00060
00061 protected:
00062   vtkImageIterateFilter();
00063   ~vtkImageIterateFilter();
00064
00065   // Superclass API. Sets defaults, then calls
00066   // ExecuteInformation(vtkImageData *inData, vtkImageData *outData)
00067   // for each iteration
00068   void ExecuteInformation();
00069   // Called for each iteration (differs from superclass in arguments).
00070   // You should override this method if needed.
00071   virtual void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00072
00073   // Superclass API: Calls Execute(vtkImageData *inData, vtkImageData *outData)
00074   // for each iteration.
00075   void ExecuteData(vtkDataObject *output);
00076   virtual void IterativeExecuteData(vtkImageData *in, vtkImageData *out) = 0;
00077
00078   // Replaces "EnlargeOutputUpdateExtent"
00079   virtual void AllocateOutputScalars(vtkImageData *outData);
00080
00081   // Allows subclass to specify the number of iterations
00082   virtual void SetNumberOfIterations(int num);
00083
00084   // for filters that execute multiple times.
00085   int NumberOfIterations;
00086   int Iteration;
00087   // A list of intermediate caches that is created when
00088   // is called SetNumberOfIterations()
00089   vtkImageData **IterationData;
00090
00091   // returns correct vtkImageDatas based on current iteration.
00092   vtkImageData *GetIterationInput();
00093   vtkImageData *GetIterationOutput();
00094 private:
00095   vtkImageIterateFilter(const vtkImageIterateFilter&);  // Not implemented.
00096   void operator=(const vtkImageIterateFilter&);  // Not implemented.
00097 };
00098
00099 #endif
00100
00101
00102
00103
00104
00105
00106
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkImageIterator.h Source File

Common/vtkImageIterator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageIterator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageIterator_h
00040 #define __vtkImageIterator_h
00041
00042 #include "vtkWin32Header.h"
00043 class vtkImageData;
00044
00045 template<class DType>
00046 class vtkImageIterator
00047 {
00048 public:
00049   typedef DType *SpanIterator;
00050
00052   vtkImageIterator(vtkImageData *id, int *ext);
00053
00055   void NextSpan();
00056
00058
00059   SpanIterator BeginSpan()
00060     {
00061       return this->Pointer;
00062     }
00064
00066
00067   SpanIterator EndSpan()
00068     {
00069       return this->SpanEndPointer;
00070     }
00072
00074
00075   int IsAtEnd()
00076     {
00077     return (this->Pointer >= this->EndPointer);
00078     }
00080
00081 protected:
00082   DType *Pointer;
00083   DType *SpanEndPointer;
00084   DType *SliceEndPointer;
00085   DType *EndPointer;
00086   int    Increments[3];
00087   int    ContinuousIncrements[3];
00088 };
00089
00090 #ifdef VTK_NO_EXPLICIT_TEMPLATE_INSTANTIATION
00091 #include "vtkImageIterator.txx"
00092 #endif
00093
00094 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageLaplacian.h Source File

Imaging/vtkImageLaplacian.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageLaplacian.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkimageLaplacian_h
00041 #define __vtkimageLaplacian_h
00042
00043
00044 #include "vtkImageToImageFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageLaplacian : public vtkImageToImageFilter
00047 {
00048 public:
00049   static vtkImageLaplacian *New();
00050   vtkTypeRevisionMacro(vtkImageLaplacian,vtkImageToImageFilter);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   vtkSetClampMacro(Dimensionality,int,2,3);
00056   vtkGetMacro(Dimensionality,int);
00058
00059 protected:
00060   vtkImageLaplacian();
00061   ~vtkImageLaplacian() {};
00062
00063   int Dimensionality;
00064
00065   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00066   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00067                        int ext[6], int id);
00068 private:
00069   vtkImageLaplacian(const vtkImageLaplacian&);  // Not implemented.
00070   void operator=(const vtkImageLaplacian&);  // Not implemented.
00071 };
00072
00073 #endif
00074
00075
00076
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageLogarithmicScale.h Source File

Imaging/vtkImageLogarithmicScale.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageLogarithmicScale.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageLogarithmicScale_h
00040 #define __vtkImageLogarithmicScale_h
00041
00042
00043 #include "vtkImageToImageFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageLogarithmicScale : public vtkImageToImageFilter
00046 {
00047 public:
00048   static vtkImageLogarithmicScale *New();
00049   vtkTypeRevisionMacro(vtkImageLogarithmicScale,vtkImageToImageFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetMacro(Constant,float);
00055   vtkGetMacro(Constant,float);
00057
00058 protected:
00059   vtkImageLogarithmicScale();
00060   ~vtkImageLogarithmicScale() {};
00061
00062   float Constant;
00063
00064   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00065                        int outExt[6], int id);
00066 private:
00067   vtkImageLogarithmicScale(const vtkImageLogarithmicScale&);  // Not implemented.
00068   void operator=(const vtkImageLogarithmicScale&);  // Not implemented.
00069 };
00070
00071 #endif
00072
00073
00074
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageLogic.h Source File

Imaging/vtkImageLogic.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageLogic.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageLogic_h
00038 #define __vtkImageLogic_h
00039
00040
00041 // Operation options.
00042 #define VTK_AND          0
00043 #define VTK_OR           1
00044 #define VTK_XOR          2
00045 #define VTK_NAND         3
00046 #define VTK_NOR          4
00047 #define VTK_NOT          5
00048 #define VTK_NOP          6
00049
00050
00051
00052 #include "vtkImageTwoInputFilter.h"
00053
00054 class VTK_IMAGING_EXPORT vtkImageLogic : public vtkImageTwoInputFilter
00055 {
00056 public:
00057   static vtkImageLogic *New();
00058   vtkTypeRevisionMacro(vtkImageLogic,vtkImageTwoInputFilter);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   vtkSetMacro(Operation,int);
00064   vtkGetMacro(Operation,int);
00065   void SetOperationToAnd() {this->SetOperation(VTK_AND);};
00066   void SetOperationToOr() {this->SetOperation(VTK_OR);};
00067   void SetOperationToXor() {this->SetOperation(VTK_XOR);};
00068   void SetOperationToNand() {this->SetOperation(VTK_NAND);};
00069   void SetOperationToNor() {this->SetOperation(VTK_NOR);};
00070   void SetOperationToNot() {this->SetOperation(VTK_NOT);};
00072
00074
00075   vtkSetMacro(OutputTrueValue, float);
00076   vtkGetMacro(OutputTrueValue, float);
00078
00079 protected:
00080   vtkImageLogic();
00081   ~vtkImageLogic() {};
00082
00083   int Operation;
00084   float OutputTrueValue;
00085
00086   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00087                        int extent[6], int id);
00088 private:
00089   vtkImageLogic(const vtkImageLogic&);  // Not implemented.
00090   void operator=(const vtkImageLogic&);  // Not implemented.
00091 };
00092
00093 #endif
00094
00095
00096
00097
00098
00099
00100
00101
00102
00103
00104
00105
00106
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageLuminance.h Source File

Imaging/vtkImageLuminance.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageLuminance.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageLuminance_h
00041 #define __vtkImageLuminance_h
00042
00043
00044 #include "vtkImageToImageFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageLuminance : public vtkImageToImageFilter
00047 {
00048 public:
00049   static vtkImageLuminance *New();
00050   vtkTypeRevisionMacro(vtkImageLuminance,vtkImageToImageFilter);
00051
00052 protected:
00053   vtkImageLuminance() {};
00054   ~vtkImageLuminance() {};
00055
00056   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00057   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00058   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00059                        int ext[6], int id);
00060 private:
00061   vtkImageLuminance(const vtkImageLuminance&);  // Not implemented.
00062   void operator=(const vtkImageLuminance&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
00068
00069
00070
00071
00072
00073
00074
00075
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMagnify.h Source File

Imaging/vtkImageMagnify.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMagnify.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageMagnify_h
00040 #define __vtkImageMagnify_h
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageMagnify : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImageMagnify *New();
00048   vtkTypeRevisionMacro(vtkImageMagnify,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   vtkSetVector3Macro(MagnificationFactors,int);
00054   vtkGetVector3Macro(MagnificationFactors,int);
00056
00058
00059   vtkSetMacro(Interpolate,int);
00060   vtkGetMacro(Interpolate,int);
00061   vtkBooleanMacro(Interpolate,int);
00063
00064
00065 protected:
00066   vtkImageMagnify();
00067   ~vtkImageMagnify() {};
00068
00069   int MagnificationFactors[3];
00070   int Interpolate;
00071   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00072   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00073   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00074   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00075                        int extent[6], int id);
00076 private:
00077   vtkImageMagnify(const vtkImageMagnify&);  // Not implemented.
00078   void operator=(const vtkImageMagnify&);  // Not implemented.
00079 };
00080
00081 #endif
00082
00083
00084
00085
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMagnitude.h Source File

Imaging/vtkImageMagnitude.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMagnitude.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageMagnitude_h
00036 #define __vtkImageMagnitude_h
00037
00038
00039 #include "vtkImageToImageFilter.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageMagnitude : public vtkImageToImageFilter
00042 {
00043 public:
00044   static vtkImageMagnitude *New();
00045   vtkTypeRevisionMacro(vtkImageMagnitude,vtkImageToImageFilter);
00046
00047 protected:
00048   vtkImageMagnitude() {};
00049   ~vtkImageMagnitude() {};
00050
00051   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00052   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00053   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00054                        int extent[6], int id);
00055 private:
00056   vtkImageMagnitude(const vtkImageMagnitude&);  // Not implemented.
00057   void operator=(const vtkImageMagnitude&);  // Not implemented.
00058 };
00059
00060 #endif
00061
00062
00063
00064
00065
00066
00067
00068
00069
00070
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMandelbrotSource.h Source File

Imaging/vtkImageMandelbrotSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMandelbrotSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageMandelbrotSource_h
00046 #define __vtkImageMandelbrotSource_h
00047
00048 #include "vtkImageSource.h"
00049
00050 class VTK_IMAGING_EXPORT vtkImageMandelbrotSource : public vtkImageSource
00051 {
00052 public:
00053   static vtkImageMandelbrotSource *New();
00054   vtkTypeRevisionMacro(vtkImageMandelbrotSource,vtkImageSource);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   void SetWholeExtent(int extent[6]);
00060   void SetWholeExtent(int minX, int maxX, int minY, int maxY,
00061                             int minZ, int maxZ);
00062   vtkGetVector6Macro(WholeExtent,int);
00064
00066
00068   vtkSetMacro(ConstantSize, int);
00069   vtkGetMacro(ConstantSize, int);
00070   vtkBooleanMacro(ConstantSize, int);
00072
00074
00077   void SetProjectionAxes(int x, int y, int z);
00078   void SetProjectionAxes(int *a) {this->SetProjectionAxes(a[0],a[1],a[2]);}
00079   vtkGetVector3Macro(ProjectionAxes, int);
00081
00083
00085   vtkSetVector4Macro(OriginCX, double);
00086   //void SetOriginCX(double cReal, double cImag, double xReal, double xImag);
00087   vtkGetVector4Macro(OriginCX, double);
00089
00091
00093   vtkSetVector4Macro(SampleCX, double);
00094   //void SetOriginCX(double cReal, double cImag, double xReal, double xImag);
00095   vtkGetVector4Macro(SampleCX, double);
00097
00099
00102   void SetSizeCX(double cReal, double cImag, double xReal, double xImag);
00103   double *GetSizeCX();
00104   void GetSizeCX(double s[4]);
00106
00108
00109   vtkSetClampMacro(MaximumNumberOfIterations, unsigned short, 1, 5000);
00110   vtkGetMacro(MaximumNumberOfIterations, unsigned short);
00112
00114
00116   void Zoom(double factor);
00117   void Pan(double x, double y, double z);
00119
00122   void CopyOriginAndSample(vtkImageMandelbrotSource *source);
00123
00124 #ifndef VTK_REMOVE_LEGACY_CODE
00125
00126
00127   void SetSample(double v)
00128     {VTK_LEGACY_METHOD(SetSampleCX,"3.2"); this->SetSampleCX(v, v, v, v);}
00130 #endif
00131
00132 protected:
00133   vtkImageMandelbrotSource();
00134   ~vtkImageMandelbrotSource();
00135
00136   int ProjectionAxes[3];
00137
00138   // WholeExtent in 3 space (after projection).
00139   int WholeExtent[6];
00140
00141   // Complex constant/initial-value at origin.
00142   double OriginCX[4];
00143   // Initial complex value at origin.
00144   double SampleCX[4];
00145   unsigned short MaximumNumberOfIterations;
00146
00147   // A temporary vector that is computed as needed.
00148   // It is used to return a vector.
00149   double SizeCX[4];
00150
00151   // A flag for keeping size constant (vs. keeping the spacing).
00152   int ConstantSize;
00153
00154   virtual void ExecuteData(vtkDataObject *outData);
00155   virtual void ExecuteInformation();
00156   float EvaluateSet(double p[4]);
00157 private:
00158   vtkImageMandelbrotSource(const vtkImageMandelbrotSource&);  // Not implemented.
00159   void operator=(const vtkImageMandelbrotSource&);  // Not implemented.
00160 };
00161
00162
00163 #endif
00164
00165
Generated on Mon Mar 25 01:07:49 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImageMapper.h Source File

Rendering/vtkImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkImageMapper_h
00043 #define __vtkImageMapper_h
00044
00045 #include "vtkMapper2D.h"
00046
00047 class vtkWindow;
00048 class vtkViewport;
00049 class vtkActor2D;
00050 #include "vtkImageData.h"
00051
00052 class VTK_RENDERING_EXPORT vtkImageMapper : public vtkMapper2D
00053 {
00054 public:
00055   vtkTypeRevisionMacro(vtkImageMapper,vtkMapper2D);
00056   static vtkImageMapper *New();
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   unsigned long int GetMTime();
00061
00063
00064   vtkSetMacro(ColorWindow, float);
00065   vtkGetMacro(ColorWindow, float);
00067
00069
00070   vtkSetMacro(ColorLevel, float);
00071   vtkGetMacro(ColorLevel, float);
00073
00075
00082   vtkSetMacro(ZSlice,int);
00083   vtkGetMacro(ZSlice,int);
00084   int GetWholeZMin();
00085   int GetWholeZMax();
00087
00089   void RenderStart(vtkViewport* viewport, vtkActor2D* actor);
00090
00092   virtual void RenderData(vtkViewport* , vtkImageData *, vtkActor2D* )=0;
00093
00095
00096   float GetColorShift();
00097   float GetColorScale();
00099
00100   // Public for templated functions. * *  Should remove this * *
00101   int DisplayExtent[6];
00102
00104
00105   virtual void SetInput(vtkImageData *input);
00106   vtkImageData *GetInput();
00108
00110
00113   vtkSetMacro(RenderToRectangle,int);
00114   vtkGetMacro(RenderToRectangle,int);
00115   vtkBooleanMacro(RenderToRectangle,int);
00117
00119
00123   vtkSetMacro(UseCustomExtents,int);
00124   vtkGetMacro(UseCustomExtents,int);
00125   vtkBooleanMacro(UseCustomExtents,int);
00127
00129
00132   vtkSetVectorMacro(CustomDisplayExtents,int,4);
00133   vtkGetVectorMacro(CustomDisplayExtents,int,4);
00135
00136 protected:
00137   vtkImageMapper();
00138   ~vtkImageMapper();
00139
00140   float ColorWindow;
00141   float ColorLevel;
00142
00143   int PositionAdjustment[2];
00144   int ZSlice;
00145   int UseCustomExtents;
00146   int CustomDisplayExtents[4];
00147   int RenderToRectangle;
00148 private:
00149   vtkImageMapper(const vtkImageMapper&);  // Not implemented.
00150   void operator=(const vtkImageMapper&);  // Not implemented.
00151 };
00152
00153
00154
00155 #endif
00156
00157
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMapToColors.h Source File

Imaging/vtkImageMapToColors.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMapToColors.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageMapToColors_h
00042 #define __vtkImageMapToColors_h
00043
00044
00045 #include "vtkImageToImageFilter.h"
00046 #include "vtkScalarsToColors.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageMapToColors : public vtkImageToImageFilter
00049 {
00050 public:
00051   static vtkImageMapToColors *New();
00052   vtkTypeRevisionMacro(vtkImageMapToColors,vtkImageToImageFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetObjectMacro(LookupTable,vtkScalarsToColors);
00058   vtkGetObjectMacro(LookupTable,vtkScalarsToColors);
00060
00062
00063   vtkSetMacro(OutputFormat,int);
00064   vtkGetMacro(OutputFormat,int);
00065   void SetOutputFormatToRGBA() { this->OutputFormat = VTK_RGBA; };
00066   void SetOutputFormatToRGB() { this->OutputFormat = VTK_RGB; };
00067   void SetOutputFormatToLuminanceAlpha() { this->OutputFormat = VTK_LUMINANCE_ALPHA; };
00068   void SetOutputFormatToLuminance() { this->OutputFormat = VTK_LUMINANCE; };
00070
00072
00073   vtkSetMacro(ActiveComponent,int);
00074   vtkGetMacro(ActiveComponent,int);
00076
00078
00081   vtkSetMacro(PassAlphaToOutput,int);
00082   vtkBooleanMacro(PassAlphaToOutput,int);
00083   vtkGetMacro(PassAlphaToOutput,int);
00085
00087   unsigned long GetMTime();
00088
00089 protected:
00090   vtkImageMapToColors();
00091   ~vtkImageMapToColors();
00092
00093   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00094   void ExecuteInformation() {
00095     this->vtkImageToImageFilter::ExecuteInformation(); };
00096   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00097                        int extent[6], int id);
00098
00099   void ExecuteData(vtkDataObject *output);
00100
00101   vtkScalarsToColors *LookupTable;
00102   int OutputFormat;
00103
00104   int ActiveComponent;
00105   int PassAlphaToOutput;
00106
00107   int DataWasPassed;
00108 private:
00109   vtkImageMapToColors(const vtkImageMapToColors&);  // Not implemented.
00110   void operator=(const vtkImageMapToColors&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
00116
00117
00118
00119
00120
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMapToRGBA.h Source File

Imaging/vtkImageMapToRGBA.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMapToRGBA.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageMapToRGBA_h
00045 #define __vtkImageMapToRGBA_h
00046
00047
00048 #include "vtkImageMapToColors.h"
00049
00050 class VTK_IMAGING_EXPORT vtkImageMapToRGBA : public vtkImageMapToColors
00051 {
00052 public:
00053   static vtkImageMapToRGBA *New();
00054   vtkTypeRevisionMacro(vtkImageMapToRGBA,vtkImageMapToColors);
00055
00056 protected:
00057   vtkImageMapToRGBA() {};
00058   ~vtkImageMapToRGBA() {};
00059 private:
00060   vtkImageMapToRGBA(const vtkImageMapToRGBA&);  // Not implemented.
00061   void operator=(const vtkImageMapToRGBA&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
00067
00068
00069
00070
00071
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMapToWindowLevelColors.h Source File

Imaging/vtkImageMapToWindowLevelColors.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMapToWindowLevelColors.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageMapToWindowLevelColors_h
00045 #define __vtkImageMapToWindowLevelColors_h
00046
00047
00048 #include "vtkImageMapToColors.h"
00049
00050 class VTK_IMAGING_EXPORT vtkImageMapToWindowLevelColors : public vtkImageMapToColors
00051 {
00052 public:
00053   static vtkImageMapToWindowLevelColors *New();
00054   vtkTypeRevisionMacro(vtkImageMapToWindowLevelColors,vtkImageToImageFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00061   vtkSetMacro( Window, float );
00062   vtkGetMacro( Window, float );
00064
00066
00069   vtkSetMacro( Level, float );
00070   vtkGetMacro( Level, float );
00072
00073 protected:
00074   vtkImageMapToWindowLevelColors();
00075   ~vtkImageMapToWindowLevelColors();
00076
00077   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00078   void ExecuteInformation(){this->vtkImageMapToColors::ExecuteInformation();};
00079   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00080                        int extent[6], int id);
00081   void ExecuteData(vtkDataObject *output);
00082
00083   float Window;
00084   float Level;
00085
00086 private:
00087   vtkImageMapToWindowLevelColors(const vtkImageMapToWindowLevelColors&);  // Not implemented.
00088   void operator=(const vtkImageMapToWindowLevelColors&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
00094
00095
00096
00097
00098
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkImageMarchingCubes.h Source File

Patented/vtkImageMarchingCubes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMarchingCubes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00016      "System and Method for the Display of Surface Structures Contained
00017      Within The Interior Region of a Solid body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00068 #ifndef __vtkImageMarchingCubes_h
00069 #define __vtkImageMarchingCubes_h
00070
00071 #include "vtkImageData.h"
00072 #include "vtkPolyDataSource.h"
00073 #include "vtkContourValues.h"
00074
00075 class vtkFloatArray;
00076
00077 class VTK_PATENTED_EXPORT vtkImageMarchingCubes : public vtkPolyDataSource
00078 {
00079 public:
00080   static vtkImageMarchingCubes *New();
00081   vtkTypeRevisionMacro(vtkImageMarchingCubes,vtkPolyDataSource);
00082   void PrintSelf(ostream& os, vtkIndent indent);
00083
00085
00086   void SetInput(vtkImageData *input);
00087   vtkImageData *GetInput();
00089
00090   // Methods to set contour values
00091   void SetValue(int i, float value);
00092   float GetValue(int i);
00093   float *GetValues();
00094   void GetValues(float *contourValues);
00095   void SetNumberOfContours(int number);
00096   int GetNumberOfContours();
00097   void GenerateValues(int numContours, float range[2]);
00098   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00099
00100   // Because we delegate to vtkContourValues & refer to vtkImplicitFunction
00101   unsigned long int GetMTime();
00102
00104
00105   vtkSetMacro(ComputeScalars, int);
00106   vtkGetMacro(ComputeScalars, int);
00107   vtkBooleanMacro(ComputeScalars, int);
00109
00111
00115   vtkSetMacro(ComputeNormals, int);
00116   vtkGetMacro(ComputeNormals, int);
00117   vtkBooleanMacro(ComputeNormals, int);
00119
00121
00127   vtkSetMacro(ComputeGradients, int);
00128   vtkGetMacro(ComputeGradients, int);
00129   vtkBooleanMacro(ComputeGradients, int);
00131
00132   // Should be protected, but the templated functions need these
00133   int ComputeScalars;
00134   int ComputeNormals;
00135   int ComputeGradients;
00136   int NeedGradients;
00137
00138   vtkCellArray *Triangles;
00139   vtkFloatArray *Scalars;
00140   vtkPoints *Points;
00141   vtkFloatArray *Normals;
00142   vtkFloatArray *Gradients;
00143
00144   int GetLocatorPoint(int cellX, int cellY, int edge);
00145   void AddLocatorPoint(int cellX, int cellY, int edge, int ptId);
00146   void IncrementLocatorZ();
00147
00148   void Update();
00149
00151
00154   vtkSetMacro(InputMemoryLimit, int);
00155   vtkGetMacro(InputMemoryLimit, int);
00157
00158 protected:
00159   vtkImageMarchingCubes();
00160   ~vtkImageMarchingCubes();
00161
00162   int NumberOfSlicesPerChunk;
00163   int InputMemoryLimit;
00164
00165   vtkContourValues *ContourValues;
00166
00167   int *LocatorPointIds;
00168   int LocatorDimX;
00169   int LocatorDimY;
00170   int LocatorMinX;
00171   int LocatorMinY;
00172
00173   void Execute();
00174
00175   void March(vtkImageData *inData, int chunkMin, int chunkMax,
00176              int numContours, float *values);
00177   void InitializeLocator(int min0, int max0, int min1, int max1);
00178   void DeleteLocator();
00179   int *GetLocatorPointer(int cellX, int cellY, int edge);
00180 private:
00181   vtkImageMarchingCubes(const vtkImageMarchingCubes&);  // Not implemented.
00182   void operator=(const vtkImageMarchingCubes&);  // Not implemented.
00183 };
00184
00187 inline void vtkImageMarchingCubes::SetValue(int i, float value)
00188 {this->ContourValues->SetValue(i,value);}
00189
00191
00192 inline float vtkImageMarchingCubes::GetValue(int i)
00193 {return this->ContourValues->GetValue(i);}
00195
00197
00199 inline float *vtkImageMarchingCubes::GetValues()
00200 {return this->ContourValues->GetValues();}
00202
00206 inline void vtkImageMarchingCubes::GetValues(float *contourValues)
00207 {this->ContourValues->GetValues(contourValues);}
00208
00212 inline void vtkImageMarchingCubes::SetNumberOfContours(int number)
00213 {this->ContourValues->SetNumberOfContours(number);}
00214
00216
00217 inline int vtkImageMarchingCubes::GetNumberOfContours()
00218 {return this->ContourValues->GetNumberOfContours();}
00220
00222
00224 inline void vtkImageMarchingCubes::GenerateValues(int numContours, float range[2])
00225 {this->ContourValues->GenerateValues(numContours, range);}
00227
00229
00231 inline void vtkImageMarchingCubes::GenerateValues(int numContours, float
00232                                                  rangeStart, float rangeEnd)
00233 {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00235
00236 #endif
00237
00238
00239
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMask.h Source File

Imaging/vtkImageMask.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMask.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageMask_h
00046 #define __vtkImageMask_h
00047
00048
00049 #include "vtkImageTwoInputFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageMask : public vtkImageTwoInputFilter
00052 {
00053 public:
00054   static vtkImageMask *New();
00055   vtkTypeRevisionMacro(vtkImageMask,vtkImageTwoInputFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   void SetMaskedOutputValue(int num, float *v);
00061   void SetMaskedOutputValue(float v) {this->SetMaskedOutputValue(1, &v);}
00062   void SetMaskedOutputValue(float v1, float v2)
00063     {float v[2]; v[0]=v1; v[1]=v2; this->SetMaskedOutputValue(2, v);}
00064   void SetMaskedOutputValue(float v1, float v2, float v3)
00065     {float v[3]; v[0]=v1; v[1]=v2; v[2]=v3; this->SetMaskedOutputValue(3, v);}
00066   float *GetMaskedOutputValue() {return this->MaskedOutputValue;}
00067   int GetMaskedOutputValueLength() {return this->MaskedOutputValueLength;}
00069
00071
00074   vtkSetClampMacro ( MaskAlpha, float, 0.0, 1.0 );
00075   vtkGetMacro ( MaskAlpha, float );
00077
00079   void SetImageInput(vtkImageData *in) {this->SetInput1(in);}
00080
00082   void SetMaskInput(vtkImageData *in) {this->SetInput2(in);}
00083
00085
00089   vtkSetMacro(NotMask,int);
00090   vtkGetMacro(NotMask,int);
00091   vtkBooleanMacro(NotMask, int);
00093
00094 protected:
00095   vtkImageMask();
00096   ~vtkImageMask();
00097
00098   float *MaskedOutputValue;
00099   int MaskedOutputValueLength;
00100   int NotMask;
00101   float MaskAlpha;
00102
00103   void ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData);
00104   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00105
00106   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00107                        int extent[6], int id);
00108 private:
00109   vtkImageMask(const vtkImageMask&);  // Not implemented.
00110   void operator=(const vtkImageMask&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
00116
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMaskBits.h Source File

Imaging/vtkImageMaskBits.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMaskBits.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageMaskBits_h
00037 #define __vtkImageMaskBits_h
00038
00039
00040 #include "vtkImageToImageFilter.h"
00041 #include "vtkImageLogic.h"     // included for the boolean operators
00042
00043 class VTK_IMAGING_EXPORT vtkImageMaskBits : public vtkImageToImageFilter
00044 {
00045 public:
00046   static vtkImageMaskBits *New();
00047   vtkTypeRevisionMacro(vtkImageMaskBits,vtkImageToImageFilter);
00048   void PrintSelf(ostream &, vtkIndent);
00049
00051
00052   vtkSetVector4Macro(Masks, unsigned int);
00053   void SetMask(unsigned int  mask)
00054     {this->SetMasks(mask, mask, mask, mask);}
00055   void SetMasks(unsigned int  mask1, unsigned int mask2)
00056     {this->SetMasks(mask1, mask2, 0xffffffff,  0xffffffff);}
00057   void SetMasks(unsigned int  mask1, unsigned int mask2, unsigned int mask3)
00058     {this->SetMasks(mask1, mask2, mask3,  0xffffffff);}
00059   vtkGetVector4Macro(Masks, unsigned int);
00061
00063
00064   vtkSetMacro(Operation,int);
00065   vtkGetMacro(Operation,int);
00066   void SetOperationToAnd() {this->SetOperation(VTK_AND);};
00067   void SetOperationToOr() {this->SetOperation(VTK_OR);};
00068   void SetOperationToXor() {this->SetOperation(VTK_XOR);};
00069   void SetOperationToNand() {this->SetOperation(VTK_NAND);};
00070   void SetOperationToNor() {this->SetOperation(VTK_NOR);};
00072
00073
00074 protected:
00075   vtkImageMaskBits();
00076   ~vtkImageMaskBits() {};
00077
00078   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00079                        int ext[6], int id);
00080
00081   unsigned int Masks[4];
00082   int Operation;
00083 private:
00084   vtkImageMaskBits(const vtkImageMaskBits&);  // Not implemented.
00085   void operator=(const vtkImageMaskBits&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
00091
00092
00093
00094
00095
00096
00097
00098
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMathematics.h Source File

Imaging/vtkImageMathematics.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMathematics.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageMathematics_h
00040 #define __vtkImageMathematics_h
00041
00042
00043 // Operation options.
00044 #define VTK_ADD                0
00045 #define VTK_SUBTRACT           1
00046 #define VTK_MULTIPLY           2
00047 #define VTK_DIVIDE             3
00048 #define VTK_INVERT             4
00049 #define VTK_SIN                5
00050 #define VTK_COS                6
00051 #define VTK_EXP                7
00052 #define VTK_LOG                8
00053 #define VTK_ABS                9
00054 #define VTK_SQR               10
00055 #define VTK_SQRT              11
00056 #define VTK_MIN               12
00057 #define VTK_MAX               13
00058 #define VTK_ATAN              14
00059 #define VTK_ATAN2             15
00060 #define VTK_MULTIPLYBYK       16
00061 #define VTK_ADDC              17
00062 #define VTK_CONJUGATE         18
00063 #define VTK_COMPLEX_MULTIPLY  19
00064 #define VTK_REPLACECBYK       20
00065
00066 #include "vtkImageTwoInputFilter.h"
00067
00068 class VTK_IMAGING_EXPORT vtkImageMathematics : public vtkImageTwoInputFilter
00069 {
00070 public:
00071   static vtkImageMathematics *New();
00072   vtkTypeRevisionMacro(vtkImageMathematics,vtkImageTwoInputFilter);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00076
00077   vtkSetMacro(Operation,int);
00078   vtkGetMacro(Operation,int);
00079   void SetOperationToAdd() {this->SetOperation(VTK_ADD);};
00080   void SetOperationToSubtract() {this->SetOperation(VTK_SUBTRACT);};
00081   void SetOperationToMultiply() {this->SetOperation(VTK_MULTIPLY);};
00082   void SetOperationToDivide() {this->SetOperation(VTK_DIVIDE);};
00083   void SetOperationToConjugate() {this->SetOperation(VTK_CONJUGATE);};
00084   void SetOperationToComplexMultiply()
00085     {this->SetOperation(VTK_COMPLEX_MULTIPLY);};
00087
00088   void SetOperationToInvert() {this->SetOperation(VTK_INVERT);};
00089   void SetOperationToSin() {this->SetOperation(VTK_SIN);};
00090   void SetOperationToCos() {this->SetOperation(VTK_COS);};
00091   void SetOperationToExp() {this->SetOperation(VTK_EXP);};
00092   void SetOperationToLog() {this->SetOperation(VTK_LOG);};
00093   void SetOperationToAbsoluteValue() {this->SetOperation(VTK_ABS);};
00094   void SetOperationToSquare() {this->SetOperation(VTK_SQR);};
00095   void SetOperationToSquareRoot() {this->SetOperation(VTK_SQRT);};
00096   void SetOperationToMin() {this->SetOperation(VTK_MIN);};
00097   void SetOperationToMax() {this->SetOperation(VTK_MAX);};
00098
00099   void SetOperationToATAN() {this->SetOperation(VTK_ATAN);};
00100   void SetOperationToATAN2() {this->SetOperation(VTK_ATAN2);};
00101   void SetOperationToMultiplyByK() {this->SetOperation(VTK_MULTIPLYBYK);};
00102   void SetOperationToAddConstant() {this->SetOperation(VTK_ADDC);};
00103   void SetOperationToReplaceCByK() {this->SetOperation(VTK_REPLACECBYK);};
00104   vtkSetMacro(ConstantK,double);
00105   vtkGetMacro(ConstantK,double);
00106   vtkSetMacro(ConstantC,double);
00107   vtkGetMacro(ConstantC,double);
00108
00109   // How to handle divide by zero
00110   vtkSetMacro(DivideByZeroToC,int);
00111   vtkGetMacro(DivideByZeroToC,int);
00112   vtkBooleanMacro(DivideByZeroToC,int);
00113
00114 protected:
00115   vtkImageMathematics();
00116   ~vtkImageMathematics() {};
00117
00118   int Operation;
00119   double ConstantK;
00120   double ConstantC;
00121   int DivideByZeroToC;
00122
00123   void ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData);
00124   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00125   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00126                        int extent[6], int id);
00127 private:
00128   vtkImageMathematics(const vtkImageMathematics&);  // Not implemented.
00129   void operator=(const vtkImageMathematics&);  // Not implemented.
00130 };
00131
00132 #endif
00133
00134
00135
00136
00137
00138
00139
00140
00141
00142
00143
00144
00145
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMedian3D.h Source File

Imaging/vtkImageMedian3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMedian3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageMedian3D_h
00041 #define __vtkImageMedian3D_h
00042
00043
00044 #include "vtkImageSpatialFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageMedian3D : public vtkImageSpatialFilter
00047 {
00048 public:
00049   static vtkImageMedian3D *New();
00050   vtkTypeRevisionMacro(vtkImageMedian3D,vtkImageSpatialFilter);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00055   void SetKernelSize(int size0, int size1, int size2);
00056
00058
00059   vtkGetMacro(NumberOfElements,int);
00061
00062 protected:
00063   vtkImageMedian3D();
00064   ~vtkImageMedian3D() {};
00065
00066   int NumberOfElements;
00067
00068   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00069                        int extent[6], int id);
00070
00071 private:
00072   vtkImageMedian3D(const vtkImageMedian3D&);  // Not implemented.
00073   void operator=(const vtkImageMedian3D&);  // Not implemented.
00074 };
00075
00076 #endif
00077
00078
00079
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageMirrorPad.h Source File

Imaging/vtkImageMirrorPad.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMirrorPad.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageMirrorPad_h
00037 #define __vtkImageMirrorPad_h
00038
00039
00040 #include "vtkImagePadFilter.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageMirrorPad : public vtkImagePadFilter
00043 {
00044 public:
00045   static vtkImageMirrorPad *New();
00046   vtkTypeRevisionMacro(vtkImageMirrorPad,vtkImagePadFilter);
00047
00048 protected:
00049   vtkImageMirrorPad() {};
00050   ~vtkImageMirrorPad() {};
00051
00052   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00053   void ThreadedExecute(vtkImageData *inData, vtkImageData *outRegion,
00054                        int ext[6], int id);
00055 private:
00056   vtkImageMirrorPad(const vtkImageMirrorPad&);  // Not implemented.
00057   void operator=(const vtkImageMirrorPad&);  // Not implemented.
00058 };
00059
00060 #endif
00061
00062
00063
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageMultipleInputFilter.h Source File

Filtering/vtkImageMultipleInputFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMultipleInputFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageMultipleInputFilter_h
00038 #define __vtkImageMultipleInputFilter_h
00039
00040
00041 #include "vtkImageSource.h"
00042 #include "vtkMultiThreader.h"
00043
00044
00045 class VTK_FILTERING_EXPORT vtkImageMultipleInputFilter : public vtkImageSource
00046 {
00047 public:
00048   static vtkImageMultipleInputFilter *New();
00049   vtkTypeRevisionMacro(vtkImageMultipleInputFilter,vtkImageSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053   virtual void SetInput(int num, vtkImageData *input);
00054
00056
00058   virtual void AddInput(vtkImageData *input);
00059   virtual void RemoveInput(vtkImageData *input);
00061
00063
00064   vtkImageData *GetInput(int num);
00065   vtkImageData *GetInput();
00067
00069
00072   vtkSetMacro(Bypass,int);
00073   vtkGetMacro(Bypass,int);
00074   vtkBooleanMacro(Bypass,int);
00076
00078
00079   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00080   vtkGetMacro( NumberOfThreads, int );
00082
00084
00085   virtual int SplitExtent(int splitExt[6], int startExt[6],
00086                           int num, int total);
00088
00090
00093   virtual void ThreadedExecute(vtkImageData **inDatas,
00094                                vtkImageData *outData,
00095                                int extent[6], int threadId);
00097
00098
00099
00100 protected:
00101   vtkImageMultipleInputFilter();
00102   ~vtkImageMultipleInputFilter();
00103
00104   vtkMultiThreader *Threader;
00105   int Bypass;
00106   int NumberOfThreads;
00107
00108   void ComputeInputUpdateExtents( vtkDataObject *output );
00109
00110   virtual void ComputeInputUpdateExtent( int inExt[6],
00111                                          int outExt[6],
00112                                          int whichInput );
00113
00114
00115   void ExecuteData(vtkDataObject *output);
00116
00117   // This one gets called by the superclass.
00118   void ExecuteInformation();
00119   // This is the one you should override.
00120   virtual void ExecuteInformation(vtkImageData **, vtkImageData *) {};
00121
00122 private:
00123   // hide the superclass' AddInput() from the user and the compiler
00124   void AddInput(vtkDataObject *)
00125     { vtkErrorMacro( << "AddInput() must be called with a vtkImageData not a vtkDataObject."); };
00126   void RemoveInput(vtkDataObject *)
00127     { vtkErrorMacro( << "RemoveInput() must be called with a vtkImageData not a vtkDataObject."); };
00128 private:
00129   vtkImageMultipleInputFilter(const vtkImageMultipleInputFilter&);  // Not implemented.
00130   void operator=(const vtkImageMultipleInputFilter&);  // Not implemented.
00131 };
00132
00133 #endif
00134
00135
00136
00137
00138
00139
00140
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageMultipleInputOutputFilter.h Source File

Filtering/vtkImageMultipleInputOutputFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageMultipleInputOutputFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageMultipleInputOutputFilter_h
00037 #define __vtkImageMultipleInputOutputFilter_h
00038
00039
00040 #include "vtkImageMultipleInputFilter.h"
00041
00042
00043 class VTK_FILTERING_EXPORT vtkImageMultipleInputOutputFilter : public vtkImageMultipleInputFilter
00044 {
00045 public:
00046   static vtkImageMultipleInputOutputFilter *New();
00047   vtkTypeRevisionMacro(vtkImageMultipleInputOutputFilter,vtkImageSource);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   vtkImageData *GetOutput(int num);
00053   vtkImageData *GetOutput();
00055
00057
00060   virtual void ThreadedExecute(vtkImageData **inDatas,
00061                                vtkImageData **outDatas,
00062                                int extent[6], int threadId);
00064
00065 protected:
00066   vtkImageMultipleInputOutputFilter();
00067   ~vtkImageMultipleInputOutputFilter();
00068
00069   void ComputeInputUpdateExtents( vtkDataObject *output );
00070
00071   virtual void ComputeInputUpdateExtent( int inExt[6],
00072                                          int outExt[6],
00073                                          int whichInput );
00074
00075
00076   void ExecuteData(vtkDataObject *out);
00077
00078   // this should never be called
00079   virtual void ThreadedExecute(vtkImageData **inDatas,
00080                                vtkImageData *outData,
00081                                int extent[6], int threadId);
00082   virtual void ExecuteInformation(vtkImageData **, vtkImageData *) {};
00083
00084   // This one gets called by the superclass.
00085   void ExecuteInformation();
00086   // This is the one you should override.
00087   virtual void ExecuteInformation(vtkImageData **, vtkImageData **) {};
00088 private:
00089   vtkImageMultipleInputOutputFilter(const vtkImageMultipleInputOutputFilter&);  // Not implemented.
00090   void operator=(const vtkImageMultipleInputOutputFilter&);  // Not implemented.
00091 };
00092
00093 #endif
00094
00095
00096
00097
00098
00099
00100
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageNoiseSource.h Source File

Imaging/vtkImageNoiseSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageNoiseSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageNoiseSource_h
00041 #define __vtkImageNoiseSource_h
00042
00043
00044 #include "vtkImageSource.h"
00045
00046
00047 class VTK_IMAGING_EXPORT vtkImageNoiseSource : public vtkImageSource
00048 {
00049 public:
00050   static vtkImageNoiseSource *New();
00051   vtkTypeRevisionMacro(vtkImageNoiseSource,vtkImageSource);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkSetMacro(Minimum, float);
00057   vtkGetMacro(Minimum, float);
00058   vtkSetMacro(Maximum, float);
00059   vtkGetMacro(Maximum, float);
00061
00063
00064   void SetWholeExtent(int xMinx, int xMax, int yMin, int yMax,
00065                       int zMin, int zMax);
00067
00068 protected:
00069   vtkImageNoiseSource();
00070   ~vtkImageNoiseSource() {};
00071
00072   float Minimum;
00073   float Maximum;
00074   int WholeExtent[6];
00075
00076   virtual void ExecuteInformation();
00077   virtual void ExecuteData(vtkDataObject *data);
00078 private:
00079   vtkImageNoiseSource(const vtkImageNoiseSource&);  // Not implemented.
00080   void operator=(const vtkImageNoiseSource&);  // Not implemented.
00081 };
00082
00083
00084 #endif
00085
00086
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageNonMaximumSuppression.h Source File

Imaging/vtkImageNonMaximumSuppression.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageNonMaximumSuppression.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageNonMaximumSuppression_h
00041 #define __vtkImageNonMaximumSuppression_h
00042
00043 #define VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_MAGNITUDE_INPUT 0
00044 #define VTK_IMAGE_NON_MAXIMUM_SUPPRESSION_VECTOR_INPUT 1
00045
00046 #include "vtkImageTwoInputFilter.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageNonMaximumSuppression : public vtkImageTwoInputFilter
00049 {
00050 public:
00051   static vtkImageNonMaximumSuppression *New();
00052   vtkTypeRevisionMacro(vtkImageNonMaximumSuppression,vtkImageTwoInputFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   void SetMagnitudeInput(vtkImageData *input) {this->SetInput1(input);};
00058   void SetVectorInput(vtkImageData *input) {this->SetInput2(input);};
00060
00062
00064   vtkSetMacro(HandleBoundaries, int);
00065   vtkGetMacro(HandleBoundaries, int);
00066   vtkBooleanMacro(HandleBoundaries, int);
00068
00070
00072   vtkSetClampMacro(Dimensionality,int,2,3);
00073   vtkGetMacro(Dimensionality,int);
00075
00076 protected:
00077   vtkImageNonMaximumSuppression();
00078   ~vtkImageNonMaximumSuppression() {};
00079
00080   int HandleBoundaries;
00081   int Dimensionality;
00082
00083   void ExecuteInformation(vtkImageData **inDatas, vtkImageData *outData);
00084   virtual void ComputeInputUpdateExtent(int inExt[6], int outExt[6],
00085                                         int whichInput);
00086   void ExecuteInformation(){this->vtkImageTwoInputFilter::ExecuteInformation();};
00087   void ThreadedExecute(vtkImageData **inDatas, vtkImageData *outData,
00088                        int extent[6], int id);
00089
00090 private:
00091   vtkImageNonMaximumSuppression(const vtkImageNonMaximumSuppression&);  // Not implemented.
00092   void operator=(const vtkImageNonMaximumSuppression&);  // Not implemented.
00093 };
00094
00095 #endif
00096
00097
00098
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageNormalize.h Source File

Imaging/vtkImageNormalize.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageNormalize.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageNormalize_h
00038 #define __vtkImageNormalize_h
00039
00040
00041 #include "vtkImageToImageFilter.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageNormalize : public vtkImageToImageFilter
00044 {
00045 public:
00046   static vtkImageNormalize *New();
00047   vtkTypeRevisionMacro(vtkImageNormalize,vtkImageToImageFilter);
00048
00049 protected:
00050   vtkImageNormalize() {};
00051   ~vtkImageNormalize() {};
00052
00053   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00054   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00055   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00056                        int extent[6], int id);
00057 private:
00058   vtkImageNormalize(const vtkImageNormalize&);  // Not implemented.
00059   void operator=(const vtkImageNormalize&);  // Not implemented.
00060 };
00061
00062 #endif
00063
00064
00065
00066
00067
00068
00069
00070
00071
00072
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageOpenClose3D.h Source File

Imaging/vtkImageOpenClose3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageOpenClose3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkImageOpenClose3D_h
00047 #define __vtkImageOpenClose3D_h
00048
00049
00050 #include "vtkImageToImageFilter.h"
00051 #include "vtkImageDilateErode3D.h"
00052
00053 class VTK_IMAGING_EXPORT vtkImageOpenClose3D : public vtkImageToImageFilter
00054 {
00055 public:
00057
00058   static vtkImageOpenClose3D *New();
00059   vtkTypeRevisionMacro(vtkImageOpenClose3D,vtkImageToImageFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00062
00065   unsigned long int GetMTime();
00066
00068
00069   void DebugOn();
00070   void DebugOff();
00072
00074   void Modified();
00075
00076   // Foward Source messages to filter1
00077
00079
00081   vtkImageData *GetOutput();
00082   vtkImageData *GetOutput(int idx)
00083     {return (vtkImageData *) this->vtkImageSource::GetOutput(idx); };
00085
00086
00087   // Foward filter messages
00088
00090   void SetInput(vtkImageData *Input);
00091
00092   // Forward dilateErode messages to both filters.
00093
00095   void SetKernelSize(int size0, int size1, int size2);
00096
00098
00100   void SetOpenValue(float value);
00101   float GetOpenValue();
00103
00105
00107   void SetCloseValue(float value);
00108   float GetCloseValue();
00110
00112
00113   vtkGetObjectMacro(Filter0, vtkImageDilateErode3D);
00114   vtkGetObjectMacro(Filter1, vtkImageDilateErode3D);
00116
00117 protected:
00118   vtkImageOpenClose3D();
00119   ~vtkImageOpenClose3D();
00120
00121   vtkImageDilateErode3D *Filter0;
00122   vtkImageDilateErode3D *Filter1;
00123 private:
00124   vtkImageOpenClose3D(const vtkImageOpenClose3D&);  // Not implemented.
00125   void operator=(const vtkImageOpenClose3D&);  // Not implemented.
00126 };
00127
00128 #endif
00129
00130
00131
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImagePadFilter.h Source File

Imaging/vtkImagePadFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImagePadFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImagePadFilter_h
00036 #define __vtkImagePadFilter_h
00037
00038 #include "vtkImageToImageFilter.h"
00039
00040 class VTK_IMAGING_EXPORT vtkImagePadFilter : public vtkImageToImageFilter
00041 {
00042 public:
00043   static vtkImagePadFilter *New();
00044   vtkTypeRevisionMacro(vtkImagePadFilter,vtkImageToImageFilter);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00048
00049   void SetOutputWholeExtent(int extent[6]);
00050   void SetOutputWholeExtent(int minX, int maxX, int minY, int maxY,
00051                             int minZ, int maxZ);
00052   void GetOutputWholeExtent(int extent[6]);
00053   int *GetOutputWholeExtent() {return this->OutputWholeExtent;}
00055
00057
00058   vtkSetMacro(OutputNumberOfScalarComponents, int);
00059   vtkGetMacro(OutputNumberOfScalarComponents, int);
00061
00062 protected:
00063   vtkImagePadFilter();
00064   ~vtkImagePadFilter() {};
00065
00066   int OutputWholeExtent[6];
00067   int OutputNumberOfScalarComponents;
00068
00069   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00070   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00071   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00072 private:
00073   vtkImagePadFilter(const vtkImagePadFilter&);  // Not implemented.
00074   void operator=(const vtkImagePadFilter&);  // Not implemented.
00075 };
00076
00077 #endif
00078
00079
00080
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImagePermute.h Source File

Imaging/vtkImagePermute.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImagePermute.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImagePermute_h
00039 #define __vtkImagePermute_h
00040
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImagePermute : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImagePermute *New();
00048   vtkTypeRevisionMacro(vtkImagePermute,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   vtkSetVector3Macro(FilteredAxes, int);
00054   vtkGetVector3Macro(FilteredAxes, int);
00056
00057 protected:
00058   vtkImagePermute();
00059   ~vtkImagePermute() {};
00060
00061   int  FilteredAxes[3];
00062   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00063   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00064   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00065   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00066                        int ext[6], int id);
00067 private:
00068   vtkImagePermute(const vtkImagePermute&);  // Not implemented.
00069   void operator=(const vtkImagePermute&);  // Not implemented.
00070 };
00071
00072 #endif
00073
00074
00075
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkImageProgressIterator.h Source File

Common/vtkImageProgressIterator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageProgressIterator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageProgressIterator_h
00041 #define __vtkImageProgressIterator_h
00042
00043 #include "vtkImageIterator.h"
00044 class vtkProcessObject;
00045
00046 template<class DType>
00047 class vtkImageProgressIterator : public vtkImageIterator<DType>
00048 {
00049 public:
00050
00052
00055   vtkImageProgressIterator(vtkImageData *imgd, int *ext,
00056                            vtkProcessObject *po, int id);
00058
00061   void NextSpan();
00062
00063 protected:
00064   vtkProcessObject *ProcessObject;
00065   unsigned long     Count;
00066   unsigned long     Count2;
00067   unsigned long     Target;
00068   int               ID;
00069 };
00070
00071 #ifdef VTK_NO_EXPLICIT_TEMPLATE_INSTANTIATION
00072 #include "vtkImageProgressIterator.txx"
00073 #endif
00074
00075 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageQuantizeRGBToIndex.h Source File

Imaging/vtkImageQuantizeRGBToIndex.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageQuantizeRGBToIndex.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageQuantizeRGBToIndex_h
00046 #define __vtkImageQuantizeRGBToIndex_h
00047
00048 #include "vtkImageToImageFilter.h"
00049 #include "vtkLookupTable.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageQuantizeRGBToIndex : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageQuantizeRGBToIndex *New();
00055   vtkTypeRevisionMacro(vtkImageQuantizeRGBToIndex,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00061   vtkSetClampMacro( NumberOfColors, int, 2, 65536 );
00062   vtkGetMacro( NumberOfColors, int );
00064
00066
00068   vtkGetObjectMacro( LookupTable, vtkLookupTable );
00070
00071   vtkGetMacro( InitializeExecuteTime, float );
00072   vtkGetMacro( BuildTreeExecuteTime, float );
00073   vtkGetMacro( LookupIndexExecuteTime, float );
00074
00075 //BTX
00077   /*! For internal use only - get the type of the image */
00078   vtkGetMacro( InputType, int );
00080
00082
00083   vtkSetMacro( InitializeExecuteTime, float );
00084   vtkSetMacro( BuildTreeExecuteTime, float );
00085   vtkSetMacro( LookupIndexExecuteTime, float );
00087 //ETX
00088
00089 protected:
00090   vtkImageQuantizeRGBToIndex();
00091   ~vtkImageQuantizeRGBToIndex();
00092
00093   vtkLookupTable  *LookupTable;
00094   int             NumberOfColors;
00095   int             InputType;
00096
00097   float           InitializeExecuteTime;
00098   float           BuildTreeExecuteTime;
00099   float           LookupIndexExecuteTime;
00100
00101   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00102   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00103   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00104
00105   virtual void ExecuteData(vtkDataObject *out);
00106 private:
00107   vtkImageQuantizeRGBToIndex(const vtkImageQuantizeRGBToIndex&);  // Not implemented.
00108   void operator=(const vtkImageQuantizeRGBToIndex&);  // Not implemented.
00109 };
00110
00111 #endif
00112
00113
00114
00115
00116
00117
00118
00119
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImager.h Source File

Rendering/vtkImager.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImager.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImager_h
00042 #define __vtkImager_h
00043
00044 #include "vtkObject.h"
00045 #include "vtkActor2DCollection.h"
00046 #include "vtkActor2D.h"
00047 #include "vtkViewport.h"
00048 #include "vtkWindow.h"
00049
00050 class vtkImageWindow;
00051
00052 class VTK_RENDERING_EXPORT vtkImager : public vtkViewport
00053 {
00054 public:
00055   static vtkImager *New();
00056   vtkTypeRevisionMacro(vtkImager,vtkViewport);
00057
00059
00061   virtual int RenderOpaqueGeometry();
00062   virtual int RenderTranslucentGeometry();
00063   virtual int RenderOverlay();
00065
00067
00068   vtkImageWindow* GetImageWindow();
00069   vtkWindow *GetVTKWindow() {return static_cast<vtkWindow*>(this->VTKWindow);};
00071
00072
00073   //BTX
00075   /*! These set methods are used by the image window, and should not be
00076       used by anyone else.  They do not reference count the window. */
00077   void SetImageWindow (vtkImageWindow* win);
00078   void SetVTKWindow (vtkWindow* win);
00079   //ETX
00081
00083   /*! Erase the contents of the imager in the window. */
00084   virtual void Erase(){vtkErrorMacro(<<"vtkImager::Erase - Not implemented!");};
00086
00087   virtual vtkAssemblyPath* PickProp(float selectionX, float selectionY);
00088   virtual float GetPickedZ();
00089
00090 protected:
00091   vtkImager();
00092   ~vtkImager();
00093
00094   virtual void StartPick(unsigned int pickFromSize);
00095   virtual void UpdatePickId();
00096   virtual void DonePick();
00097   virtual unsigned int GetPickedId();
00098   virtual void DevicePickRender();
00099 private:
00100   vtkImager(const vtkImager&);  // Not implemented.
00101   void operator=(const vtkImager&);  // Not implemented.
00102 };
00103
00104
00105 #endif
00106
00107
00108
00109
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageRange3D.h Source File

Imaging/vtkImageRange3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageRange3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageRange3D_h
00038 #define __vtkImageRange3D_h
00039
00040
00041 #include "vtkImageSpatialFilter.h"
00042
00043 class vtkImageEllipsoidSource;
00044
00045 class VTK_IMAGING_EXPORT vtkImageRange3D : public vtkImageSpatialFilter
00046 {
00047 public:
00048   static vtkImageRange3D *New();
00049   vtkTypeRevisionMacro(vtkImageRange3D,vtkImageSpatialFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00055   void SetKernelSize(int size0, int size1, int size2);
00056
00057 protected:
00058   vtkImageRange3D();
00059   ~vtkImageRange3D();
00060
00061   vtkImageEllipsoidSource *Ellipse;
00062
00063   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00064   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00065   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00066                        int extent[6], int id);
00067 private:
00068   vtkImageRange3D(const vtkImageRange3D&);  // Not implemented.
00069   void operator=(const vtkImageRange3D&);  // Not implemented.
00070 };
00071
00072 #endif
00073
00074
00075
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImagerCollection.h Source File

Rendering/vtkImagerCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImagerCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImagerCollection_h
00038 #define __vtkImagerCollection_h
00039
00040 #include "vtkCollection.h"
00041 #include "vtkImager.h"
00042
00043
00044 class VTK_RENDERING_EXPORT vtkImagerCollection : public vtkCollection
00045 {
00046  public:
00047   static vtkImagerCollection *New();
00048   vtkTypeRevisionMacro(vtkImagerCollection,vtkCollection);
00049
00051
00052   void AddItem(vtkImager *a);
00053   vtkImager *GetNextItem();
00054   vtkImager *GetLastItem();
00056
00057 protected:
00058   vtkImagerCollection() {};
00059   ~vtkImagerCollection() {};
00060
00061 private:
00062   // hide the standard AddItem from the user and the compiler.
00063   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00064
00065 private:
00066   vtkImagerCollection(const vtkImagerCollection&);  // Not implemented.
00067   void operator=(const vtkImagerCollection&);  // Not implemented.
00068 };
00069
00070 inline void vtkImagerCollection::AddItem(vtkImager *a)
00071 {
00072   this->vtkCollection::AddItem((vtkObject *)a);
00073 }
00074
00075 inline vtkImager *vtkImagerCollection::GetNextItem()
00076 {
00077   return static_cast<vtkImager *>(this->GetNextItemAsObject());
00078 }
00079
00080 inline vtkImager *vtkImagerCollection::GetLastItem()
00081 {
00082   if ( this->Bottom == NULL )
00083     {
00084     return NULL;
00085     }
00086   else
00087     {
00088     return static_cast<vtkImager *>(this->Bottom->Item);
00089     }
00090 }
00091
00092 #endif
00093
00094
00095
00096
00097
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkImageReader2.h Source File

IO/vtkImageReader2.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageReader2.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageReader2_h
00040 #define __vtkImageReader2_h
00041
00042 #include "vtkImageSource.h"
00043
00044 #define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
00045 #define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1
00046
00047 class VTK_IO_EXPORT vtkImageReader2 : public vtkImageSource
00048 {
00049 public:
00050   static vtkImageReader2 *New();
00051   vtkTypeRevisionMacro(vtkImageReader2,vtkImageSource);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00058   void SetFileName(const char *);
00059   vtkGetStringMacro(FileName);
00061
00063
00066   void SetFilePrefix(const char *);
00067   vtkGetStringMacro(FilePrefix);
00069
00071
00072   void SetFilePattern(const char *);
00073   vtkGetStringMacro(FilePattern);
00075
00077
00080   void SetDataScalarType(int type);
00081   void SetDataScalarTypeToFloat(){this->SetDataScalarType(VTK_FLOAT);}
00082   void SetDataScalarTypeToDouble(){this->SetDataScalarType(VTK_DOUBLE);}
00083   void SetDataScalarTypeToInt(){this->SetDataScalarType(VTK_INT);}
00084   void SetDataScalarTypeToShort(){this->SetDataScalarType(VTK_SHORT);}
00085   void SetDataScalarTypeToUnsignedShort()
00086     {this->SetDataScalarType(VTK_UNSIGNED_SHORT);}
00087   void SetDataScalarTypeToUnsignedChar()
00088     {this->SetDataScalarType(VTK_UNSIGNED_CHAR);}
00090
00092
00093   vtkGetMacro(DataScalarType, int);
00095
00097
00098   vtkSetMacro(NumberOfScalarComponents,int);
00099   vtkGetMacro(NumberOfScalarComponents,int);
00101
00103
00104   vtkSetVector6Macro(DataExtent,int);
00105   vtkGetVector6Macro(DataExtent,int);
00107
00109
00110   vtkSetMacro(FileDimensionality, int);
00111   int GetFileDimensionality() {return this->FileDimensionality;}
00113
00115
00116   vtkSetVector3Macro(DataSpacing,float);
00117   vtkGetVector3Macro(DataSpacing,float);
00119
00121
00122   vtkSetVector3Macro(DataOrigin,float);
00123   vtkGetVector3Macro(DataOrigin,float);
00125
00127
00128   unsigned long GetHeaderSize();
00129   unsigned long GetHeaderSize(unsigned long slice);
00131
00134   void SetHeaderSize(unsigned long size);
00135
00137
00147   void SetDataByteOrderToBigEndian();
00148   void SetDataByteOrderToLittleEndian();
00149   int GetDataByteOrder();
00150   void SetDataByteOrder(int);
00151   const char *GetDataByteOrderAsString();
00153
00155
00157   vtkSetMacro(FileNameSliceOffset,int);
00158   vtkGetMacro(FileNameSliceOffset,int);
00160
00162
00165   vtkSetMacro(FileNameSliceSpacing,int);
00166   vtkGetMacro(FileNameSliceSpacing,int);
00168
00169
00171
00172   vtkSetMacro(SwapBytes,int);
00173   int GetSwapBytes() {return this->SwapBytes;}
00174   vtkBooleanMacro(SwapBytes,int);
00176
00177 //BTX
00178   ifstream *GetFile() {return this->File;}
00179   vtkGetVectorMacro(DataIncrements,unsigned long,4);
00180 //ETX
00181
00182   int OpenFile();
00183   void SeekFile(int i, int j, int k);
00184
00186
00188   vtkBooleanMacro(FileLowerLeft, int);
00189   vtkGetMacro(FileLowerLeft, int);
00190   vtkSetMacro(FileLowerLeft, int);
00192
00194
00195   void ComputeInternalFileName(int slice);
00196   vtkGetStringMacro(InternalFileName);
00197   // Description:
00198   // virtual constructor.  This will make an object that is the
00199   // same type as the object that the call is made from.
00200   virtual vtkImageReader2* MakeObject() { return vtkImageReader2::New(); }
00201   // Description:
00202   // Return 1 if the reader can read the given file name.
00203   // Should be implemented by all sub-classes of vtkImageReader2.
00204   virtual int CanReadFile(const char* vtkNotUsed(fname))
00205     {
00206       return 0;
00207     }
00209
00211
00213   virtual const char* GetFileExensions()
00214     {
00215       return 0;
00216     }
00218
00220
00222   virtual const char* GetDescriptiveName()
00223     {
00224       return 0;
00225     }
00227 protected:
00228   vtkImageReader2();
00229   ~vtkImageReader2();
00230
00231   char *InternalFileName;
00232   char *FileName;
00233   char *FilePrefix;
00234   char *FilePattern;
00235   int NumberOfScalarComponents;
00236   int FileLowerLeft;
00237
00238   ifstream *File;
00239   unsigned long DataIncrements[4];
00240   int DataExtent[6];
00241   int SwapBytes;
00242
00243   int FileDimensionality;
00244   unsigned long HeaderSize;
00245   int DataScalarType;
00246   unsigned long ManualHeaderSize;
00247
00248   float DataSpacing[3];
00249   float DataOrigin[3];
00250
00251   int FileNameSliceOffset;
00252   int FileNameSliceSpacing;
00253
00254   virtual void ExecuteInformation();
00255   virtual void ExecuteData(vtkDataObject *data);
00256   virtual void ComputeDataIncrements();
00257 private:
00258   vtkImageReader2(const vtkImageReader2&);  // Not implemented.
00259   void operator=(const vtkImageReader2&);  // Not implemented.
00260 };
00261
00262 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkImageReader2Collection.h Source File

IO/vtkImageReader2Collection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageReader2Collection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkImageReader2Collection_h
00035 #define __vtkImageReader2Collection_h
00036
00037 #include "vtkCollection.h"
00038 #include "vtkImageReader2.h"
00039
00040 class VTK_IO_EXPORT vtkImageReader2Collection : public vtkCollection
00041 {
00042 public:
00043   vtkTypeRevisionMacro(vtkImageReader2Collection,vtkCollection);
00044   static vtkImageReader2Collection *New();
00045
00047   void AddItem(vtkImageReader2 *);
00048
00050   vtkImageReader2 *GetNextItem();
00051
00052 protected:
00053   vtkImageReader2Collection() {};
00054   ~vtkImageReader2Collection() {};
00055
00056
00057 private:
00058   // hide the standard AddItem from the user and the compiler.
00059   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00060
00061 private:
00062   vtkImageReader2Collection(const vtkImageReader2Collection&);  // Not implemented.
00063   void operator=(const vtkImageReader2Collection&);  // Not implemented.
00064 };
00065
00066 inline void vtkImageReader2Collection::AddItem(vtkImageReader2 *f)
00067 {
00068   this->vtkCollection::AddItem((vtkObject *)f);
00069 }
00070
00071 inline vtkImageReader2 *vtkImageReader2Collection::GetNextItem()
00072 {
00073   return static_cast<vtkImageReader2*>(this->GetNextItemAsObject());
00074 }
00075
00076 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkImageReader2Factory.h Source File

IO/vtkImageReader2Factory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageReader2Factory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkImageReader2Factory_h
00051 #define __vtkImageReader2Factory_h
00052
00053
00054 #include "vtkObject.h"
00055 class vtkImageReader2Collection;
00056 class vtkImageReader2;
00057
00058 class VTK_IO_EXPORT vtkImageReader2Factory : public vtkObject
00059 {
00060 public:
00061   static vtkImageReader2Factory *New();
00062   vtkTypeRevisionMacro(vtkImageReader2Factory,vtkObject);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00067   static void RegisterReader(vtkImageReader2* r);
00068
00071   static vtkImageReader2* CreateImageReader2(const char* path);
00072
00075   static void GetRegisteredReaders(vtkImageReader2Collection* );
00076 protected:
00077   vtkImageReader2Factory();
00078   ~vtkImageReader2Factory();
00079
00080   static void InitializeReaders();
00081
00082 private:
00083   static vtkImageReader2Collection* AvailiableReaders;
00084   vtkImageReader2Factory(const vtkImageReader2Factory&);  // Not implemented.
00085   void operator=(const vtkImageReader2Factory&);  // Not implemented.
00086 //BTX
00087   friend class vtkCleanUpImageReader2Factory;
00088 //ETX
00089 };
00090
00091 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkImageReader.h Source File

IO/vtkImageReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageReader_h
00045 #define __vtkImageReader_h
00046
00047 #include "vtkImageReader2.h"
00048 #include "vtkTransform.h"
00049
00050 #define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
00051 #define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1
00052
00053 class VTK_IO_EXPORT vtkImageReader : public vtkImageReader2
00054 {
00055 public:
00056   static vtkImageReader *New();
00057   vtkTypeRevisionMacro(vtkImageReader,vtkImageSource);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00063   vtkSetVector6Macro(DataVOI,int);
00064   vtkGetVector6Macro(DataVOI,int);
00066
00068
00069   vtkGetMacro(DataMask,unsigned short);
00070   void SetDataMask(int val)
00071        {if (val == this->DataMask) { return; }
00072         this->DataMask = ((unsigned short)(val)); this->Modified();}
00074
00076
00079   vtkSetObjectMacro(Transform,vtkTransform);
00080   vtkGetObjectMacro(Transform,vtkTransform);
00082
00083   // Warning !!!
00084   // following should only be used by methods or template helpers, not users
00085   void ComputeInverseTransformedExtent(int inExtent[6],
00086                                        int outExtent[6]);
00087   void ComputeInverseTransformedIncrements(int inIncr[3],
00088                                            int outIncr[3]);
00089
00090   int OpenAndSeekFile(int extent[6], int slice);
00091 protected:
00092   vtkImageReader();
00093   ~vtkImageReader();
00094
00095   unsigned short DataMask;  // Mask each pixel with ...
00096
00097   vtkTransform *Transform;
00098
00099   void ComputeTransformedSpacing (float Spacing[3]);
00100   void ComputeTransformedOrigin (float origin[3]);
00101   void ComputeTransformedExtent(int inExtent[6],
00102                                 int outExtent[6]);
00103   void ComputeTransformedIncrements(int inIncr[3],
00104                                     int outIncr[3]);
00105
00106   int DataVOI[6];
00107
00108   void ExecuteInformation();
00109   void ExecuteData(vtkDataObject *data);
00110 private:
00111   vtkImageReader(const vtkImageReader&);  // Not implemented.
00112   void operator=(const vtkImageReader&);  // Not implemented.
00113 };
00114
00115 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageResample.h Source File

Imaging/vtkImageResample.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageResample.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageResample_h
00039 #define __vtkImageResample_h
00040
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageResample : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImageResample *New();
00048   vtkTypeRevisionMacro(vtkImageResample,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00053   void SetAxisOutputSpacing(int axis, float spacing);
00054
00056
00058   void SetAxisMagnificationFactor(int axis, float factor);
00059   float GetAxisMagnificationFactor(int axis);
00061
00063
00064   vtkSetMacro(Interpolate,int);
00065   vtkGetMacro(Interpolate,int);
00066   vtkBooleanMacro(Interpolate,int);
00068
00070
00074   vtkSetMacro(Dimensionality,int);
00075   vtkGetMacro(Dimensionality,int);
00077
00078 protected:
00079   vtkImageResample();
00080   ~vtkImageResample() {};
00081
00082   float MagnificationFactors[3];
00083   float OutputSpacing[3];
00084   int Interpolate;
00085   int Dimensionality;
00086
00087   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00088   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00089   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00090   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00091                        int extent[6], int id);
00092 private:
00093   vtkImageResample(const vtkImageResample&);  // Not implemented.
00094   void operator=(const vtkImageResample&);  // Not implemented.
00095 };
00096
00097 #endif
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageReslice.h Source File

Imaging/vtkImageReslice.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageReslice.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkImageReslice_h
00065 #define __vtkImageReslice_h
00066
00067
00068 #include "vtkImageToImageFilter.h"
00069 #include "vtkAbstractTransform.h"
00070 #include "vtkMatrix4x4.h"
00071 #include "vtkImageStencilData.h"
00072
00073 // interpolation mode constants
00074 #define VTK_RESLICE_NEAREST 0
00075 #define VTK_RESLICE_LINEAR 1
00076 #define VTK_RESLICE_CUBIC 3
00077
00078 class VTK_IMAGING_EXPORT vtkImageReslice : public vtkImageToImageFilter
00079 {
00080 public:
00081   static vtkImageReslice *New();
00082   vtkTypeRevisionMacro(vtkImageReslice, vtkImageToImageFilter);
00083
00084   virtual void PrintSelf(ostream& os, vtkIndent indent);
00085
00087
00099   vtkSetObjectMacro(ResliceAxes, vtkMatrix4x4);
00100   vtkGetObjectMacro(ResliceAxes, vtkMatrix4x4);
00102
00104
00108   void SetResliceAxesDirectionCosines(double x0, double x1, double x2,
00109                                       double y0, double y1, double y2,
00110                                       double z0, double z1, double z2);
00111   void SetResliceAxesDirectionCosines(const double x[3],
00112                                       const double y[3],
00113                                       const double z[3]) {
00114     this->SetResliceAxesDirectionCosines(x[0], x[1], x[2],
00115                                          y[0], y[1], y[2],
00116                                          z[0], z[1], z[2]); };
00117   void SetResliceAxesDirectionCosines(const double xyz[9]) {
00118     this->SetResliceAxesDirectionCosines(xyz[0], xyz[1], xyz[2],
00119                                          xyz[3], xyz[4], xyz[5],
00120                                          xyz[6], xyz[7], xyz[8]); };
00121   void GetResliceAxesDirectionCosines(double x[3], double y[3], double z[3]);
00122   void GetResliceAxesDirectionCosines(double xyz[9]) {
00123     this->GetResliceAxesDirectionCosines(&xyz[0], &xyz[3], &xyz[6]); };
00124   double *GetResliceAxesDirectionCosines() {
00125     this->GetResliceAxesDirectionCosines(this->ResliceAxesDirectionCosines);
00126     return this->ResliceAxesDirectionCosines; };
00128
00130
00133   void SetResliceAxesOrigin(double x, double y, double z);
00134   void SetResliceAxesOrigin(const double xyz[3]) {
00135     this->SetResliceAxesOrigin(xyz[0], xyz[1], xyz[2]); };
00136   void GetResliceAxesOrigin(double xyz[3]);
00137   double *GetResliceAxesOrigin() {
00138     this->GetResliceAxesOrigin(this->ResliceAxesOrigin);
00139     return this->ResliceAxesOrigin; };
00141
00143
00150   vtkSetObjectMacro(ResliceTransform, vtkAbstractTransform);
00151   vtkGetObjectMacro(ResliceTransform, vtkAbstractTransform);
00153
00155
00161   vtkSetObjectMacro(InformationInput, vtkImageData);
00162   vtkGetObjectMacro(InformationInput, vtkImageData);
00164
00166
00170   vtkSetMacro(TransformInputSampling, int);
00171   vtkBooleanMacro(TransformInputSampling, int);
00172   vtkGetMacro(TransformInputSampling, int);
00174
00176
00178   vtkSetMacro(AutoCropOutput, int);
00179   vtkBooleanMacro(AutoCropOutput, int);
00180   vtkGetMacro(AutoCropOutput, int);
00182
00184
00185   vtkSetMacro(Wrap, int);
00186   vtkGetMacro(Wrap, int);
00187   vtkBooleanMacro(Wrap, int);
00189
00191
00193   vtkSetMacro(Mirror, int);
00194   vtkGetMacro(Mirror, int);
00195   vtkBooleanMacro(Mirror, int);
00197
00199
00200   vtkSetMacro(InterpolationMode, int);
00201   vtkGetMacro(InterpolationMode, int);
00202   void SetInterpolationModeToNearestNeighbor() {
00203     this->SetInterpolationMode(VTK_RESLICE_NEAREST); };
00204   void SetInterpolationModeToLinear() {
00205     this->SetInterpolationMode(VTK_RESLICE_LINEAR); };
00206   void SetInterpolationModeToCubic() {
00207     this->SetInterpolationMode(VTK_RESLICE_CUBIC); };
00208   const char *GetInterpolationModeAsString();
00210
00212
00214   vtkSetMacro(Optimization, int);
00215   vtkGetMacro(Optimization, int);
00216   vtkBooleanMacro(Optimization, int);
00218
00220
00221   vtkSetVector4Macro(BackgroundColor, float);
00222   vtkGetVector4Macro(BackgroundColor, float);
00224
00226
00227   void SetBackgroundLevel(float v) { this->SetBackgroundColor(v,v,v,v); };
00228   float GetBackgroundLevel() { return this->GetBackgroundColor()[0]; };
00230
00232
00234   vtkSetVector3Macro(OutputSpacing, float);
00235   vtkGetVector3Macro(OutputSpacing, float);
00236   void SetOutputSpacingToDefault() {
00237     this->SetOutputSpacing(VTK_FLOAT_MAX, VTK_FLOAT_MAX, VTK_FLOAT_MAX); };
00239
00241
00243   vtkSetVector3Macro(OutputOrigin, float);
00244   vtkGetVector3Macro(OutputOrigin, float);
00245   void SetOutputOriginToDefault() {
00246     this->SetOutputOrigin(VTK_FLOAT_MAX, VTK_FLOAT_MAX, VTK_FLOAT_MAX); };
00248
00250
00252   vtkSetVector6Macro(OutputExtent, int);
00253   vtkGetVector6Macro(OutputExtent, int);
00254   void SetOutputExtentToDefault() {
00255     this->SetOutputExtent(VTK_INT_MIN, VTK_INT_MAX,
00256                           VTK_INT_MIN, VTK_INT_MAX,
00257                           VTK_INT_MIN, VTK_INT_MAX); };
00259
00261
00267   vtkSetMacro(OutputDimensionality, int);
00268   vtkGetMacro(OutputDimensionality, int);
00270
00273   unsigned long int GetMTime();
00274
00276
00281   void SetInterpolate(int t) {
00282     if (t && !this->GetInterpolate()) {
00283       this->SetInterpolationModeToLinear(); }
00284     else if (!t && this->GetInterpolate()) {
00285       this->SetInterpolationModeToNearestNeighbor(); } };
00286   void InterpolateOn() {
00287     this->SetInterpolate(1); };
00288   void InterpolateOff() {
00289     this->SetInterpolate(0); };
00290   int GetInterpolate() {
00291     return (this->GetInterpolationMode() != VTK_RESLICE_NEAREST); };
00293
00295
00298   void SetStencil(vtkImageStencilData *stencil);
00299   vtkImageStencilData *GetStencil();
00301
00302 protected:
00303   vtkImageReslice();
00304   ~vtkImageReslice();
00305
00306   vtkMatrix4x4 *ResliceAxes;
00307   double ResliceAxesDirectionCosines[9];
00308   double ResliceAxesOrigin[3];
00309   vtkAbstractTransform *ResliceTransform;
00310   vtkImageData *InformationInput;
00311   int Wrap;
00312   int Mirror;
00313   int InterpolationMode;
00314   int Optimization;
00315   float BackgroundColor[4];
00316   float OutputOrigin[3];
00317   float OutputSpacing[3];
00318   int OutputExtent[6];
00319   int OutputDimensionality;
00320   int TransformInputSampling;
00321   int AutoCropOutput;
00322
00323   vtkMatrix4x4 *IndexMatrix;
00324   vtkAbstractTransform *OptimizedTransform;
00325
00326   void GetAutoCroppedOutputBounds(vtkImageData *input, float bounds[6]);
00327   void ExecuteInformation(vtkImageData *input, vtkImageData *output);
00328   void ExecuteInformation() {
00329     this->vtkImageToImageFilter::ExecuteInformation(); };
00330   void ComputeInputUpdateExtents(vtkDataObject *output);
00331   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00332   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00333                        int ext[6], int id);
00334
00335   vtkMatrix4x4 *GetIndexMatrix();
00336   vtkAbstractTransform *GetOptimizedTransform() {
00337     return this->OptimizedTransform; };
00338   void OptimizedComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00339   void OptimizedThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00340                                 int ext[6], int id);
00341 private:
00342   vtkImageReslice(const vtkImageReslice&);  // Not implemented.
00343   void operator=(const vtkImageReslice&);  // Not implemented.
00344 };
00345
00346 //----------------------------------------------------------------------------
00347 inline const char *vtkImageReslice::GetInterpolationModeAsString()
00348 {
00349   switch (this->InterpolationMode)
00350     {
00351     case VTK_RESLICE_NEAREST:
00352       return "NearestNeighbor";
00353     case VTK_RESLICE_LINEAR:
00354       return "Linear";
00355     case VTK_RESLICE_CUBIC:
00356       return "Cubic";
00357     default:
00358       return "";
00359     }
00360 }
00361
00362 #endif
00363
00364
00365
00366
00367
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageRFFT.h Source File

Imaging/vtkImageRFFT.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageRFFT.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkImageRFFT_h
00049 #define __vtkImageRFFT_h
00050
00051
00052 #include "vtkImageFourierFilter.h"
00053
00054 class VTK_IMAGING_EXPORT vtkImageRFFT : public vtkImageFourierFilter
00055 {
00056 public:
00057   static vtkImageRFFT *New();
00058   vtkTypeRevisionMacro(vtkImageRFFT,vtkImageFourierFilter);
00059
00060
00062
00068   int SplitExtent(int splitExt[6], int startExt[6],
00069                   int num, int total);
00071
00072   virtual void IterativeExecuteData(vtkImageData *in, vtkImageData *out) {
00073     this->MultiThread(in,out);};
00074
00075 protected:
00076   vtkImageRFFT() {};
00077   ~vtkImageRFFT() {};
00078
00079   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00080   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00081   void ExecuteInformation(){this->vtkImageIterateFilter::ExecuteInformation();};
00082   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00083                        int outExt[6], int threadId);
00084 private:
00085   vtkImageRFFT(const vtkImageRFFT&);  // Not implemented.
00086   void operator=(const vtkImageRFFT&);  // Not implemented.
00087 };
00088
00089 #endif
00090
00091
00092
00093
00094
00095
00096
00097
00098
00099
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageRGBToHSV.h Source File

Imaging/vtkImageRGBToHSV.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageRGBToHSV.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageRGBToHSV_h
00039 #define __vtkImageRGBToHSV_h
00040
00041
00042 #include "vtkImageToImageFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageRGBToHSV : public vtkImageToImageFilter
00045 {
00046 public:
00047   static vtkImageRGBToHSV *New();
00048   vtkTypeRevisionMacro(vtkImageRGBToHSV,vtkImageToImageFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00051
00052   // Hue is an angle. Maximum specifies when it maps back to 0.  HueMaximum
00053   // defaults to 255 instead of 2PI, because unsigned char is expected as
00054   // input.  Maximum also specifies the maximum of the Saturation.
00055   vtkSetMacro(Maximum,float);
00056   vtkGetMacro(Maximum,float);
00057
00058 protected:
00059   vtkImageRGBToHSV();
00060   ~vtkImageRGBToHSV() {};
00061
00062   float Maximum;
00063
00064   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00065                        int ext[6], int id);
00066 private:
00067   vtkImageRGBToHSV(const vtkImageRGBToHSV&);  // Not implemented.
00068   void operator=(const vtkImageRGBToHSV&);  // Not implemented.
00069 };
00070
00071 #endif
00072
00073
00074
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSeedConnectivity.h Source File

Imaging/vtkImageSeedConnectivity.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSeedConnectivity.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkImageSeedConnectivity_h
00045 #define __vtkImageSeedConnectivity_h
00046
00047
00048 #include "vtkImageConnector.h"
00049 #include "vtkImageToImageFilter.h"
00050
00051 class VTK_IMAGING_EXPORT vtkImageSeedConnectivity : public vtkImageToImageFilter
00052 {
00053 public:
00054   static vtkImageSeedConnectivity *New();
00055   vtkTypeRevisionMacro(vtkImageSeedConnectivity,vtkImageToImageFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   void RemoveAllSeeds();
00061   void AddSeed(int num, int *index);
00062   void AddSeed(int i0, int i1, int i2);
00063   void AddSeed(int i0, int i1);
00065
00067
00068   vtkSetMacro(InputConnectValue, int);
00069   vtkGetMacro(InputConnectValue, int);
00071
00073
00074   vtkSetMacro(OutputConnectedValue, int);
00075   vtkGetMacro(OutputConnectedValue, int);
00077
00079
00080   vtkSetMacro(OutputUnconnectedValue, int);
00081   vtkGetMacro(OutputUnconnectedValue, int);
00083
00085
00086   vtkGetObjectMacro(Connector,vtkImageConnector);
00088
00090
00091   vtkSetMacro(Dimensionality,int);
00092   vtkGetMacro(Dimensionality,int);
00094
00095 protected:
00096   vtkImageSeedConnectivity();
00097   ~vtkImageSeedConnectivity();
00098
00099   unsigned char InputConnectValue;
00100   unsigned char OutputConnectedValue;
00101   unsigned char OutputUnconnectedValue;
00102   vtkImageConnectorSeed *Seeds;
00103   vtkImageConnector *Connector;
00104   int Dimensionality;
00105
00106   void ComputeInputUpdateExtents(vtkDataObject *out);
00107
00108   void ExecuteData(vtkDataObject *out);
00109 private:
00110   vtkImageSeedConnectivity(const vtkImageSeedConnectivity&);  // Not implemented.
00111   void operator=(const vtkImageSeedConnectivity&);  // Not implemented.
00112 };
00113
00114
00115
00116 #endif
00117
00118
00119
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSeparableConvolution.h Source File

Imaging/vtkImageSeparableConvolution.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSeparableConvolution.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageSeparableConvolution_h
00042 #define __vtkImageSeparableConvolution_h
00043
00044
00045 #include "vtkImageDecomposeFilter.h"
00046 #include "vtkFloatArray.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageSeparableConvolution : public vtkImageDecomposeFilter
00049 {
00050 public:
00051   static vtkImageSeparableConvolution *New();
00052   vtkTypeRevisionMacro(vtkImageSeparableConvolution,vtkImageDecomposeFilter);
00053
00054
00055   // Set the X convolution kernel, a null value indicates no convolution to be done.
00056   // The kernel must be of odd length
00057   vtkSetObjectMacro ( XKernel, vtkFloatArray );
00058   vtkGetObjectMacro ( XKernel, vtkFloatArray );
00059
00060   // Set the Y convolution kernel, a null value indicates no convolution to be done
00061   // The kernel must be of odd length
00062   vtkSetObjectMacro ( YKernel, vtkFloatArray );
00063   vtkGetObjectMacro ( YKernel, vtkFloatArray );
00064
00065   // Set the Z convolution kernel, a null value indicates no convolution to be done
00066   // The kernel must be of odd length
00067   vtkSetObjectMacro ( ZKernel, vtkFloatArray );
00068   vtkGetObjectMacro ( ZKernel, vtkFloatArray );
00069
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00074   unsigned long int GetMTime();
00075
00076 protected:
00077   vtkImageSeparableConvolution();
00078   ~vtkImageSeparableConvolution();
00079
00080   vtkFloatArray* XKernel;
00081   vtkFloatArray* YKernel;
00082   vtkFloatArray* ZKernel;
00083
00084   // void AllocateOutputScalars(vtkImageData *outData);
00085   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00086   void IterativeExecuteData(vtkImageData *inData, vtkImageData *outData);
00087   void ExecuteInformation(vtkImageData *input, vtkImageData *output);
00088   void ExecuteInformation()
00089     {this->vtkImageIterateFilter::ExecuteInformation();}
00090
00091
00092   //void AllocateOutputScalars(vtkImageData *outData);
00093
00094
00095 private:
00096   vtkImageSeparableConvolution(const vtkImageSeparableConvolution&);  // Not implemented.
00097   void operator=(const vtkImageSeparableConvolution&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
00103
00104
00105
00106
00107
00108
00109
00110
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageShiftScale.h Source File

Imaging/vtkImageShiftScale.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageShiftScale.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkImageShiftScale_h
00044 #define __vtkImageShiftScale_h
00045
00046
00047 #include "vtkImageToImageFilter.h"
00048
00049 class VTK_IMAGING_EXPORT vtkImageShiftScale : public vtkImageToImageFilter
00050 {
00051 public:
00052   static vtkImageShiftScale *New();
00053   vtkTypeRevisionMacro(vtkImageShiftScale,vtkImageToImageFilter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetMacro(Shift,float);
00059   vtkGetMacro(Shift,float);
00061
00063
00064   vtkSetMacro(Scale,float);
00065   vtkGetMacro(Scale,float);
00067
00069
00071   vtkSetMacro(OutputScalarType, int);
00072   vtkGetMacro(OutputScalarType, int);
00073   void SetOutputScalarTypeToDouble()
00074     {this->SetOutputScalarType(VTK_DOUBLE);}
00075   void SetOutputScalarTypeToFloat()
00076     {this->SetOutputScalarType(VTK_FLOAT);}
00077   void SetOutputScalarTypeToLong()
00078     {this->SetOutputScalarType(VTK_LONG);}
00079   void SetOutputScalarTypeToUnsignedLong()
00080     {this->SetOutputScalarType(VTK_UNSIGNED_LONG);};
00081   void SetOutputScalarTypeToInt()
00082     {this->SetOutputScalarType(VTK_INT);}
00083   void SetOutputScalarTypeToUnsignedInt()
00084     {this->SetOutputScalarType(VTK_UNSIGNED_INT);}
00085   void SetOutputScalarTypeToShort()
00086     {this->SetOutputScalarType(VTK_SHORT);}
00087   void SetOutputScalarTypeToUnsignedShort()
00088     {this->SetOutputScalarType(VTK_UNSIGNED_SHORT);}
00089   void SetOutputScalarTypeToChar()
00090     {this->SetOutputScalarType(VTK_CHAR);}
00091   void SetOutputScalarTypeToUnsignedChar()
00092     {this->SetOutputScalarType(VTK_UNSIGNED_CHAR);}
00094
00096
00099   vtkSetMacro(ClampOverflow, int);
00100   vtkGetMacro(ClampOverflow, int);
00101   vtkBooleanMacro(ClampOverflow, int);
00103
00104 protected:
00105   vtkImageShiftScale();
00106   ~vtkImageShiftScale() {};
00107
00108   float Shift;
00109   float Scale;
00110   int OutputScalarType;
00111   int ClampOverflow;
00112
00113   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00114   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00115   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00116                        int extent[6], int id);
00117 private:
00118   vtkImageShiftScale(const vtkImageShiftScale&);  // Not implemented.
00119   void operator=(const vtkImageShiftScale&);  // Not implemented.
00120 };
00121
00122 #endif
00123
00124
00125
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageShrink3D.h Source File

Imaging/vtkImageShrink3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageShrink3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageShrink3D_h
00041 #define __vtkImageShrink3D_h
00042
00043
00044 #include "vtkImageToImageFilter.h"
00045
00046 class VTK_IMAGING_EXPORT vtkImageShrink3D : public vtkImageToImageFilter
00047 {
00048 public:
00049   static vtkImageShrink3D *New();
00050   vtkTypeRevisionMacro(vtkImageShrink3D,vtkImageToImageFilter);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   vtkSetVector3Macro(ShrinkFactors,int);
00056   vtkGetVector3Macro(ShrinkFactors,int);
00058
00060
00061   vtkSetVector3Macro(Shift,int);
00062   vtkGetVector3Macro(Shift,int);
00064
00066
00071   void SetAveraging(int);
00072   int GetAveraging() {return this->GetMean();};
00073   vtkBooleanMacro(Averaging,int);
00075
00076   void SetMean(int);
00077   vtkGetMacro(Mean,int);
00078   vtkBooleanMacro(Mean,int);
00079
00080   void SetMinimum(int);
00081   vtkGetMacro(Minimum,int);
00082   vtkBooleanMacro(Minimum,int);
00083
00084   void SetMaximum(int);
00085   vtkGetMacro(Maximum,int);
00086   vtkBooleanMacro(Maximum,int);
00087
00088   void SetMedian(int);
00089   vtkGetMacro(Median,int);
00090   vtkBooleanMacro(Median,int);
00091
00092
00093 protected:
00094   vtkImageShrink3D();
00095   ~vtkImageShrink3D() {};
00096
00097   int ShrinkFactors[3];
00098   int Shift[3];
00099   int Mean;
00100   int Minimum;
00101   int Maximum;
00102   int Median;
00103
00104   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00105   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00106   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00107   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00108                        int ext[6], int id);
00109 private:
00110   vtkImageShrink3D(const vtkImageShrink3D&);  // Not implemented.
00111   void operator=(const vtkImageShrink3D&);  // Not implemented.
00112 };
00113
00114 #endif
00115
00116
00117
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSinusoidSource.h Source File

Imaging/vtkImageSinusoidSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSinusoidSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageSinusoidSource_h
00037 #define __vtkImageSinusoidSource_h
00038
00039 #include "vtkImageSource.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageSinusoidSource : public vtkImageSource
00042 {
00043 public:
00044   static vtkImageSinusoidSource *New();
00045   vtkTypeRevisionMacro(vtkImageSinusoidSource,vtkImageSource);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00050   void SetWholeExtent(int xMinx, int xMax, int yMin, int yMax,
00051                       int zMin, int zMax);
00053
00055
00057   void SetDirection(float,float,float);
00058   void SetDirection(float dir[3]);
00059   vtkGetVector3Macro(Direction, float);
00061
00063
00064   vtkSetMacro(Period, float);
00065   vtkGetMacro(Period, float);
00067
00069
00070   vtkSetMacro(Phase, float);
00071   vtkGetMacro(Phase, float);
00073
00075
00076   vtkSetMacro(Amplitude, float);
00077   vtkGetMacro(Amplitude, float);
00079
00080 protected:
00081   vtkImageSinusoidSource();
00082   ~vtkImageSinusoidSource() {};
00083
00084   int WholeExtent[6];
00085   float Direction[3];
00086   float Period;
00087   float Phase;
00088   float Amplitude;
00089
00090   virtual void ExecuteInformation();
00091   virtual void ExecuteData(vtkDataObject *data);
00092 private:
00093   vtkImageSinusoidSource(const vtkImageSinusoidSource&);  // Not implemented.
00094   void operator=(const vtkImageSinusoidSource&);  // Not implemented.
00095 };
00096
00097
00098 #endif
00099
00100
00101
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSkeleton2D.h Source File

Imaging/vtkImageSkeleton2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSkeleton2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkImageSkeleton2D_h
00044 #define __vtkImageSkeleton2D_h
00045
00046 #include "vtkImageIterateFilter.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageSkeleton2D : public vtkImageIterateFilter
00049 {
00050 public:
00051   static vtkImageSkeleton2D *New();
00052   vtkTypeRevisionMacro(vtkImageSkeleton2D,vtkImageIterateFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetMacro(Prune,int);
00058   vtkGetMacro(Prune,int);
00059   vtkBooleanMacro(Prune,int);
00061
00063   void SetNumberOfIterations(int num);
00064
00065   virtual void IterativeExecuteData(vtkImageData *in, vtkImageData *out)
00066     { this->MultiThread(in,out);};
00067
00068 protected:
00069   vtkImageSkeleton2D();
00070   ~vtkImageSkeleton2D() {};
00071
00072   int Prune;
00073
00074   void ComputeInputUpdateExtent(int inExt[6], int outExt[6] );
00075   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00076                        int outExt[6], int id);
00077 private:
00078   vtkImageSkeleton2D(const vtkImageSkeleton2D&);  // Not implemented.
00079   void operator=(const vtkImageSkeleton2D&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
00085
Generated on Mon Mar 25 01:07:50 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSobel2D.h Source File

Imaging/vtkImageSobel2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSobel2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageSobel2D_h
00038 #define __vtkImageSobel2D_h
00039
00040
00041 #include "vtkImageSpatialFilter.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageSobel2D : public vtkImageSpatialFilter
00044 {
00045 public:
00046   static vtkImageSobel2D *New();
00047   vtkTypeRevisionMacro(vtkImageSobel2D,vtkImageSpatialFilter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00050 protected:
00051   vtkImageSobel2D();
00052   ~vtkImageSobel2D() {};
00053
00054   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00055                        int outExt[6], int id);
00056   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00057   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00058 private:
00059   vtkImageSobel2D(const vtkImageSobel2D&);  // Not implemented.
00060   void operator=(const vtkImageSobel2D&);  // Not implemented.
00061 };
00062
00063 #endif
00064
00065
00066
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSobel3D.h Source File

Imaging/vtkImageSobel3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSobel3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageSobel3D_h
00039 #define __vtkImageSobel3D_h
00040
00041
00042 #include "vtkImageSpatialFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageSobel3D : public vtkImageSpatialFilter
00045 {
00046 public:
00047   static vtkImageSobel3D *New();
00048   vtkTypeRevisionMacro(vtkImageSobel3D,vtkImageSpatialFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00051 protected:
00052   vtkImageSobel3D();
00053   ~vtkImageSobel3D() {};
00054
00055   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00056                        int outExt[6], int id);
00057   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00058   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00059 private:
00060   vtkImageSobel3D(const vtkImageSobel3D&);  // Not implemented.
00061   void operator=(const vtkImageSobel3D&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
00067
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageSource.h Source File

Filtering/vtkImageSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageSource_h
00038 #define __vtkImageSource_h
00039
00040 #include "vtkImageData.h"
00041 #include "vtkSource.h"
00042
00043 class VTK_FILTERING_EXPORT vtkImageSource : public vtkSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkImageSource,vtkSource);
00047   static vtkImageSource *New();
00048
00050
00051   void SetOutput(vtkImageData *output);
00052   vtkImageData *GetOutput();
00053   vtkImageData *GetOutput(int idx)
00054     {return (vtkImageData *) this->vtkSource::GetOutput(idx);}
00056
00057 protected:
00058   vtkImageSource();
00059   ~vtkImageSource() {};
00060
00061   void Execute();
00062   virtual void Execute(vtkImageData *data);
00063
00064   // a helper method that sets the extent and allocates the output
00065   // passed into it and returns it as an image data
00066   vtkImageData *AllocateOutputData(vtkDataObject *out);
00067
00068   void ComputeRequiredInputUpdateExtent( int *vtkNotUsed(in),
00069                                          int *vtkNotUsed(out) )
00070     {VTK_LEGACY_METHOD(ComputeRequiredInputUpdateExtent,"3.2");}
00071
00072 private:
00073   vtkImageSource(const vtkImageSource&);  // Not implemented.
00074   void operator=(const vtkImageSource&);  // Not implemented.
00075 };
00076
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageSpatialFilter.h Source File

Imaging/vtkImageSpatialFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageSpatialFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageSpatialFilter_h
00038 #define __vtkImageSpatialFilter_h
00039
00040
00041 #include "vtkImageToImageFilter.h"
00042
00043 class VTK_IMAGING_EXPORT vtkImageSpatialFilter : public vtkImageToImageFilter
00044 {
00045 public:
00046   static vtkImageSpatialFilter *New();
00047   vtkTypeRevisionMacro(vtkImageSpatialFilter,vtkImageToImageFilter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051   int *GetKernelSize() {return this->KernelSize;}
00052
00054   int *GetKernelMiddle() {return this->KernelMiddle;}
00055
00056 protected:
00057   vtkImageSpatialFilter();
00058   ~vtkImageSpatialFilter() {};
00059
00060   int   KernelSize[3];
00061   int   KernelMiddle[3];      // Index of kernel origin
00062   int   Strides[3];      // Shrink factor
00063   int   HandleBoundaries;     // Output shrinks if boundaries aren't handled
00064
00065   // Called by the superclass
00066   void ExecuteInformation();
00067   // Override this method if you have to.
00068   virtual void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00069
00070   void ComputeOutputWholeExtent(int extent[6], int handleBoundaries);
00071   void ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]);
00072
00073 private:
00074   vtkImageSpatialFilter(const vtkImageSpatialFilter&);  // Not implemented.
00075   void operator=(const vtkImageSpatialFilter&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
00081
00082
00083
00084
00085
00086
00087
00088
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageStencil.h Source File

Imaging/vtkImageStencil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageStencil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkImageStencil_h
00036 #define __vtkImageStencil_h
00037
00038 #include "vtkImageToImageFilter.h"
00039 #include "vtkImageStencilData.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageStencil : public vtkImageToImageFilter
00042 {
00043 public:
00044   static vtkImageStencil *New();
00045   vtkTypeRevisionMacro(vtkImageStencil, vtkImageToImageFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   virtual void SetStencil(vtkImageStencilData *stencil);
00052   vtkImageStencilData *GetStencil();
00054
00056
00057   vtkSetMacro(ReverseStencil, int);
00058   vtkBooleanMacro(ReverseStencil, int);
00059   vtkGetMacro(ReverseStencil, int);
00061
00063
00067   virtual void SetBackgroundInput(vtkImageData *input);
00068   vtkImageData *GetBackgroundInput();
00070
00072
00073   void SetBackgroundValue(float val) {
00074     this->SetBackgroundColor(val,val,val,val); };
00075   float GetBackgroundValue() {
00076     return this->BackgroundColor[0]; };
00078
00080
00082   vtkSetVector4Macro(BackgroundColor, float);
00083   vtkGetVector4Macro(BackgroundColor, float);
00085
00086 protected:
00087   vtkImageStencil();
00088   ~vtkImageStencil();
00089
00090   void ExecuteInformation() {
00091     this->vtkImageToImageFilter::ExecuteInformation(); };
00092   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00093
00094   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00095                        int extent[6], int id);
00096
00097   int ReverseStencil;
00098   float BackgroundColor[4];
00099 private:
00100   vtkImageStencil(const vtkImageStencil&);  // Not implemented.
00101   void operator=(const vtkImageStencil&);  // Not implemented.
00102 };
00103
00104 #endif
00105
00106
00107
00108
00109
00110
00111
00112
00113
00114
00115
00116
00117
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageStencilData.h Source File

Imaging/vtkImageStencilData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageStencilData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageStencilData_h
00037 #define __vtkImageStencilData_h
00038
00039
00040 #include "vtkDataObject.h"
00041
00042 class VTK_IMAGING_EXPORT vtkImageStencilData : public vtkDataObject
00043 {
00044 public:
00045   static vtkImageStencilData *New();
00046   vtkTypeRevisionMacro(vtkImageStencilData, vtkDataObject);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00049   vtkDataObject *MakeObject();
00050   void Initialize();
00051   void DeepCopy(vtkDataObject *o);
00052   void ShallowCopy(vtkDataObject *f);
00053   void InternalImageStencilDataCopy(vtkImageStencilData *s);
00054
00057   int GetDataObjectType() { return VTK_DATA_OBJECT; }
00058
00060   int GetExtentType() { return VTK_3D_EXTENT; };
00061
00063
00071   int GetNextExtent(int &r1, int &r2, int xMin, int xMax,
00072                     int yIdx, int zIdx, int &iter);
00074
00080   void InsertNextExtent(int r1, int r2, int yIdx, int zIdx);
00081
00083
00086   vtkSetVector3Macro(Spacing, float);
00087   vtkGetVector3Macro(Spacing, float);
00089
00091
00094   vtkSetVector3Macro(Origin, float);
00095   vtkGetVector3Macro(Origin, float);
00097
00099
00102   vtkSetVector6Macro(Extent, int);
00103   vtkGetVector6Macro(Extent, int);
00105
00107
00109   vtkSetVector3Macro(OldSpacing, float);
00110   vtkGetVector3Macro(OldSpacing, float);
00112
00114
00116   vtkSetVector3Macro(OldOrigin, float);
00117   vtkGetVector3Macro(OldOrigin, float);
00119
00122   void AllocateExtents();
00123
00130   void UpdateData();
00131
00136   void PropagateUpdateExtent();
00137
00143   void TriggerAsynchronousUpdate();
00144
00145 protected:
00146   vtkImageStencilData();
00147   ~vtkImageStencilData();
00148
00151   int SpacingOrOriginHasChanged();
00152
00154
00156   float OldSpacing[3];
00157   float OldOrigin[3];
00159
00161
00162   float Spacing[3];
00163   float Origin[3];
00165
00167
00168   int NumberOfExtentEntries;
00169   int *ExtentListLengths;
00170   int **ExtentLists;
00172 private:
00173   vtkImageStencilData(const vtkImageStencilData&);  // Not implemented.
00174   void operator=(const vtkImageStencilData&);  // Not implemented.
00175 };
00176
00177 #endif
00178
00179
00180
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageStencilSource.h Source File

Imaging/vtkImageStencilSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageStencilSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageStencilSource_h
00042 #define __vtkImageStencilSource_h
00043
00044
00045 #include "vtkSource.h"
00046 #include "vtkImageStencilData.h"
00047
00048 class VTK_IMAGING_EXPORT vtkImageStencilSource : public vtkSource
00049 {
00050 public:
00051   static vtkImageStencilSource *New();
00052   vtkTypeRevisionMacro(vtkImageStencilSource, vtkSource);
00053
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   void SetOutput(vtkImageStencilData *output);
00059   vtkImageStencilData *GetOutput();
00061
00062 protected:
00063   vtkImageStencilSource();
00064   ~vtkImageStencilSource();
00065
00066   void ExecuteData(vtkDataObject *out);
00067   vtkImageStencilData *AllocateOutputData(vtkDataObject *out);
00068
00070
00074   virtual void ThreadedExecute(vtkImageStencilData *output,
00075                                int extent[6], int threadId);
00077 private:
00078   vtkImageStencilSource(const vtkImageStencilSource&);  // Not implemented.
00079   void operator=(const vtkImageStencilSource&);  // Not implemented.
00080 };
00081
00082 #endif
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageThreshold.h Source File

Imaging/vtkImageThreshold.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageThreshold.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageThreshold_h
00040 #define __vtkImageThreshold_h
00041
00042
00043 #include "vtkImageToImageFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageThreshold : public vtkImageToImageFilter
00046 {
00047 public:
00048   static vtkImageThreshold *New();
00049   vtkTypeRevisionMacro(vtkImageThreshold,vtkImageToImageFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053   void ThresholdByUpper(float thresh);
00054
00056   void ThresholdByLower(float thresh);
00057
00059   void ThresholdBetween(float lower, float upper);
00060
00062
00063   vtkSetMacro(ReplaceIn, int);
00064   vtkGetMacro(ReplaceIn, int);
00065   vtkBooleanMacro(ReplaceIn, int);
00067
00069
00070   void SetInValue(float val);
00071   vtkGetMacro(InValue, float);
00073
00075
00076   vtkSetMacro(ReplaceOut, int);
00077   vtkGetMacro(ReplaceOut, int);
00078   vtkBooleanMacro(ReplaceOut, int);
00080
00082
00083   void SetOutValue(float val);
00084   vtkGetMacro(OutValue, float);
00086
00088
00089   vtkGetMacro(UpperThreshold, float);
00090   vtkGetMacro(LowerThreshold, float);
00092
00094
00095   vtkSetMacro(OutputScalarType, int);
00096   vtkGetMacro(OutputScalarType, int);
00097   void SetOutputScalarTypeToDouble()
00098     {this->SetOutputScalarType(VTK_DOUBLE);}
00099   void SetOutputScalarTypeToFloat()
00100     {this->SetOutputScalarType(VTK_FLOAT);}
00101   void SetOutputScalarTypeToLong()
00102     {this->SetOutputScalarType(VTK_LONG);}
00103   void SetOutputScalarTypeToUnsignedLong()
00104     {this->SetOutputScalarType(VTK_UNSIGNED_LONG);};
00105   void SetOutputScalarTypeToInt()
00106     {this->SetOutputScalarType(VTK_INT);}
00107   void SetOutputScalarTypeToUnsignedInt()
00108     {this->SetOutputScalarType(VTK_UNSIGNED_INT);}
00109   void SetOutputScalarTypeToShort()
00110     {this->SetOutputScalarType(VTK_SHORT);}
00111   void SetOutputScalarTypeToUnsignedShort()
00112     {this->SetOutputScalarType(VTK_UNSIGNED_SHORT);}
00113   void SetOutputScalarTypeToChar()
00114     {this->SetOutputScalarType(VTK_CHAR);}
00115   void SetOutputScalarTypeToUnsignedChar()
00116     {this->SetOutputScalarType(VTK_UNSIGNED_CHAR);}
00118
00119 protected:
00120   vtkImageThreshold();
00121   ~vtkImageThreshold() {};
00122
00123   float UpperThreshold;
00124   float LowerThreshold;
00125   int ReplaceIn;
00126   float InValue;
00127   int ReplaceOut;
00128   float OutValue;
00129
00130   int OutputScalarType;
00131
00132   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00133   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00134   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00135                        int extent[6], int id);
00136 private:
00137   vtkImageThreshold(const vtkImageThreshold&);  // Not implemented.
00138   void operator=(const vtkImageThreshold&);  // Not implemented.
00139 };
00140
00141 #endif
00142
00143
00144
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageToImageFilter.h Source File

Filtering/vtkImageToImageFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageToImageFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkImageToImageFilter_h
00042 #define __vtkImageToImageFilter_h
00043
00044
00045 #include "vtkImageSource.h"
00046 #include "vtkMultiThreader.h"
00047
00048 class VTK_FILTERING_EXPORT vtkImageToImageFilter : public vtkImageSource
00049 {
00050 public:
00051   static vtkImageToImageFilter *New();
00052   vtkTypeRevisionMacro(vtkImageToImageFilter,vtkImageSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   virtual void SetInput(vtkImageData *input);
00058   vtkImageData *GetInput();
00060
00062
00063   void SetBypass( int ) {};
00064   void BypassOn() {};
00065   void BypassOff() {};
00066   vtkGetMacro(Bypass,int);
00068
00070
00074   virtual void ThreadedExecute(vtkImageData *inData,
00075                                vtkImageData *outData,
00076                                int extent[6], int threadId);
00078
00080
00081   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00082   vtkGetMacro( NumberOfThreads, int );
00084
00085   void SetInputMemoryLimit(int)
00086     {vtkErrorMacro( << "SetInputMemoryLimit is obsolete: Use a vtkImageDataStreamer instead!" );};
00087   long GetInputMemoryLimit()
00088     {vtkErrorMacro( << "GetInputMemoryLimit is obsolete: Use a vtkImageDataStreamer instead!" ); return 0;};
00089
00091
00092   virtual int SplitExtent(int splitExt[6], int startExt[6],
00093                           int num, int total);
00095
00096 protected:
00097   vtkImageToImageFilter();
00098   ~vtkImageToImageFilter();
00099
00100   vtkMultiThreader *Threader;
00101   int Bypass;
00102   int BypassWasOn;
00103   int NumberOfThreads;
00104
00105   // This is called by the superclass.
00106   void ExecuteInformation();
00107   // This is the method you should override.
00108   virtual void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00109
00110   // This is called by the superclass.
00111   // This is the method you should override.
00112   void ExecuteData(vtkDataObject *output);
00113
00114   // The method that starts the multithreading
00115   void MultiThread(vtkImageData *input, vtkImageData *output);
00116
00117   void ComputeInputUpdateExtents( vtkDataObject *output );
00118   virtual void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00119 private:
00120   vtkImageToImageFilter(const vtkImageToImageFilter&);  // Not implemented.
00121   void operator=(const vtkImageToImageFilter&);  // Not implemented.
00122 };
00123
00124 #endif
00125
00126
00127
00128
00129
00130
00131
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageToImageStencil.h Source File

Imaging/vtkImageToImageStencil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageToImageStencil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageToImageStencil_h
00039 #define __vtkImageToImageStencil_h
00040
00041
00042 #include "vtkImageStencilSource.h"
00043 #include "vtkImageData.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImageToImageStencil : public vtkImageStencilSource
00046 {
00047 public:
00048   static vtkImageToImageStencil *New();
00049   vtkTypeRevisionMacro(vtkImageToImageStencil, vtkImageStencilSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   void SetInput(vtkImageData *input);
00055   vtkImageData *GetInput();
00057
00059   void ThresholdByUpper(float thresh);
00060
00062   void ThresholdByLower(float thresh);
00063
00065   void ThresholdBetween(float lower, float upper);
00066
00068
00069   vtkSetMacro(UpperThreshold, float);
00070   vtkGetMacro(UpperThreshold, float);
00071   vtkSetMacro(LowerThreshold, float);
00072   vtkGetMacro(LowerThreshold, float);
00074
00075 protected:
00076   vtkImageToImageStencil();
00077   ~vtkImageToImageStencil();
00078
00079   void ThreadedExecute(vtkImageStencilData *output,
00080                        int extent[6], int threadId);
00081
00082   float UpperThreshold;
00083   float LowerThreshold;
00084   float Threshold;
00085 private:
00086   vtkImageToImageStencil(const vtkImageToImageStencil&);  // Not implemented.
00087   void operator=(const vtkImageToImageStencil&);  // Not implemented.
00088 };
00089
00090 #endif
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkImageToPolyDataFilter.h Source File

Hybrid/vtkImageToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00076 #ifndef __vtkImageToPolyDataFilter_h
00077 #define __vtkImageToPolyDataFilter_h
00078
00079 #include "vtkStructuredPointsToPolyDataFilter.h"
00080 #include "vtkScalarsToColors.h"
00081
00082 #define VTK_STYLE_PIXELIZE 0
00083 #define VTK_STYLE_POLYGONALIZE 1
00084 #define VTK_STYLE_RUN_LENGTH 2
00085
00086 #define VTK_COLOR_MODE_LUT 0
00087 #define VTK_COLOR_MODE_LINEAR_256 1
00088
00089 class vtkStructuredPoints;
00090 class vtkEdgeTable;
00091 class vtkAppendPolyData;
00092
00093 class VTK_HYBRID_EXPORT vtkImageToPolyDataFilter : public vtkStructuredPointsToPolyDataFilter
00094 {
00095 public:
00096   vtkTypeRevisionMacro(vtkImageToPolyDataFilter,vtkStructuredPointsToPolyDataFilter);
00097   void PrintSelf(ostream& os, vtkIndent indent);
00098
00100
00101   static vtkImageToPolyDataFilter *New()
00102     {return new vtkImageToPolyDataFilter;};
00104
00106
00112   vtkSetClampMacro(OutputStyle,int,VTK_STYLE_PIXELIZE,VTK_STYLE_RUN_LENGTH);
00113   vtkGetMacro(OutputStyle,int);
00114   void SetOutputStyleToPixelize()
00115     {this->SetOutputStyle(VTK_STYLE_PIXELIZE);};
00116   void SetOutputStyleToPolygonalize()
00117     {this->SetOutputStyle(VTK_STYLE_POLYGONALIZE);};
00118   void SetOutputStyleToRunLength()
00119     {this->SetOutputStyle(VTK_STYLE_RUN_LENGTH);};
00121
00123
00124   vtkSetClampMacro(ColorMode,int,VTK_COLOR_MODE_LUT,VTK_COLOR_MODE_LINEAR_256);
00125   vtkGetMacro(ColorMode,int);
00126   void SetColorModeToLUT()
00127     {this->SetColorMode(VTK_COLOR_MODE_LUT);};
00128   void SetColorModeToLinear256()
00129     {this->SetColorMode(VTK_COLOR_MODE_LINEAR_256);};
00131
00133
00135   vtkSetObjectMacro(LookupTable,vtkScalarsToColors);
00136   vtkGetObjectMacro(LookupTable,vtkScalarsToColors);
00138
00140
00142   vtkSetMacro(Smoothing, int);
00143   vtkGetMacro(Smoothing, int);
00144   vtkBooleanMacro(Smoothing, int);
00146
00148
00150   vtkSetClampMacro(NumberOfSmoothingIterations,int,0,VTK_LARGE_INTEGER);
00151   vtkGetMacro(NumberOfSmoothingIterations,int);
00153
00155
00157   vtkSetMacro(Decimation, int);
00158   vtkGetMacro(Decimation, int);
00159   vtkBooleanMacro(Decimation, int);
00161
00163
00164   vtkSetClampMacro(DecimationError,float,0.0,VTK_LARGE_FLOAT);
00165   vtkGetMacro(DecimationError,float);
00167
00169
00172   vtkSetClampMacro(Error,int,0,VTK_LARGE_INTEGER);
00173   vtkGetMacro(Error,int);
00175
00177
00182   vtkSetClampMacro(SubImageSize,int,10,VTK_LARGE_INTEGER);
00183   vtkGetMacro(SubImageSize,int);
00185
00186 protected:
00187   vtkImageToPolyDataFilter();
00188   ~vtkImageToPolyDataFilter();
00189
00190   void Execute();
00191
00192   int OutputStyle;
00193   int ColorMode;
00194   int Smoothing;
00195   int NumberOfSmoothingIterations;
00196   int Decimation;
00197   float DecimationError;
00198   int Error;
00199   int SubImageSize;
00200   vtkScalarsToColors *LookupTable;
00201
00202   virtual void PixelizeImage(vtkUnsignedCharArray *pixels, int dims[3],
00203                              float origin[3], float spacing[3],
00204                              vtkPolyData *output);
00205   virtual void PolygonalizeImage(vtkUnsignedCharArray *pixels, int dims[3],
00206                                  float origin[3], float spacing[3],
00207                                  vtkPolyData *output);
00208   virtual void RunLengthImage(vtkUnsignedCharArray *pixels, int dims[3],
00209                               float origin[3], float spacing[3],
00210                               vtkPolyData *output);
00211 private:
00212   vtkUnsignedCharArray *Table;      // color table used to quantize points
00213   vtkTimeStamp         TableMTime;
00214   int                  *Visited;    // traverse & mark connected regions
00215   vtkUnsignedCharArray *PolyColors; // the colors of each region -> polygon
00216   vtkEdgeTable         *EdgeTable;  // keep track of intersection points
00217   vtkEdgeTable         *EdgeUseTable; // keep track of polygons use of edges
00218   vtkIntArray          *EdgeUses; //the two polygons that use an edge
00219                                   //and point id associated with edge (if any)
00220
00221   vtkAppendPolyData    *Append;
00222
00223   void BuildTable(unsigned char *inPixels);
00224   vtkUnsignedCharArray *QuantizeImage(vtkDataArray *inScalars, int numComp,
00225                                           int type, int dims[3], int ext[4]);
00226   int ProcessImage(vtkUnsignedCharArray *pixels, int dims[2]);
00227   int BuildEdges(vtkUnsignedCharArray *pixels, int dims[3], float origin[3],
00228                  float spacing[3], vtkUnsignedCharArray *pointDescr,
00229                  vtkPolyData *edges);
00230   void BuildPolygons(vtkUnsignedCharArray *pointDescr, vtkPolyData *edges,
00231                      int numPolys, vtkUnsignedCharArray *polyColors);
00232   void SmoothEdges(vtkUnsignedCharArray *pointDescr, vtkPolyData *edges);
00233   void DecimateEdges(vtkPolyData *edges, vtkUnsignedCharArray *pointDescr,
00234                      float tol2);
00235   void GeneratePolygons(vtkPolyData *edges, int numPolys, vtkPolyData *output,
00236                         vtkUnsignedCharArray *polyColors,
00237                         vtkUnsignedCharArray *pointDescr);
00238
00239   int GetNeighbors(unsigned char *ptr, int &i, int &j, int dims[3],
00240                    unsigned char *neighbors[4], int mode);
00241
00242   void GetIJ(int id, int &i, int &j, int dims[3]);
00243   unsigned char *GetColor(unsigned char *rgb);
00244   int IsSameColor(unsigned char *p1, unsigned char *p2);
00245
00246 private:
00247   vtkImageToPolyDataFilter(const vtkImageToPolyDataFilter&);  // Not implemented.
00248   void operator=(const vtkImageToPolyDataFilter&);  // Not implemented.
00249 };
00250
00251 #endif
00252
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageToStructuredPoints.h Source File

Filtering/vtkImageToStructuredPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageToStructuredPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageToStructuredPoints_h
00041 #define __vtkImageToStructuredPoints_h
00042
00043 #include "vtkSource.h"
00044 #include "vtkStructuredPoints.h"
00045
00046 class VTK_FILTERING_EXPORT vtkImageToStructuredPoints : public vtkSource
00047 {
00048 public:
00049   static vtkImageToStructuredPoints *New();
00050   vtkTypeRevisionMacro(vtkImageToStructuredPoints,vtkSource);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   void SetInput(vtkImageData *input);
00056   vtkImageData *GetInput();
00058
00059
00061
00062   void SetVectorInput(vtkImageData *input);
00063   vtkImageData *GetVectorInput();
00065
00067
00068   vtkStructuredPoints *GetOutput();
00069   vtkStructuredPoints *GetOutput(int idx)
00070     {return (vtkStructuredPoints *) this->vtkSource::GetOutput(idx); };
00072
00073 protected:
00074   vtkImageToStructuredPoints();
00075   ~vtkImageToStructuredPoints();
00076
00077   // to translate the wholeExtent to have min 0 ( I do not like this hack).
00078   int Translate[3];
00079
00080   void Execute();
00081   void ExecuteInformation();
00082   void ComputeInputUpdateExtents(vtkDataObject *data);
00083
00084
00085 private:
00086   vtkImageToStructuredPoints(const vtkImageToStructuredPoints&);  // Not implemented.
00087   void operator=(const vtkImageToStructuredPoints&);  // Not implemented.
00088 };
00089
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageTranslateExtent.h Source File

Imaging/vtkImageTranslateExtent.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageTranslateExtent.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageTranslateExtent_h
00037 #define __vtkImageTranslateExtent_h
00038
00039 #include "vtkImageToImageFilter.h"
00040
00041 class VTK_IMAGING_EXPORT vtkImageTranslateExtent : public vtkImageToImageFilter
00042 {
00043 public:
00044   static vtkImageTranslateExtent *New();
00045   vtkTypeRevisionMacro(vtkImageTranslateExtent,vtkImageToImageFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00050   vtkSetVector3Macro(Translation, int);
00051   vtkGetVector3Macro(Translation, int);
00053
00054 protected:
00055   vtkImageTranslateExtent();
00056   ~vtkImageTranslateExtent() {};
00057
00058   int Translation[3];
00059
00060   void ComputeInputUpdateExtent(int extent[6], int wholeExtent[6]);
00061   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00062   void ExecuteInformation() {
00063     this->vtkImageToImageFilter::ExecuteInformation(); };
00064   void ExecuteData(vtkDataObject *data);
00065 private:
00066   vtkImageTranslateExtent(const vtkImageTranslateExtent&);  // Not implemented.
00067   void operator=(const vtkImageTranslateExtent&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
00073
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImageTwoInputFilter.h Source File

Filtering/vtkImageTwoInputFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageTwoInputFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkImageTwoInputFilter_h
00037 #define __vtkImageTwoInputFilter_h
00038
00039 #include "vtkImageMultipleInputFilter.h"
00040
00041 class VTK_FILTERING_EXPORT vtkImageTwoInputFilter : public vtkImageMultipleInputFilter
00042 {
00043 public:
00044   static vtkImageTwoInputFilter *New();
00045   vtkTypeRevisionMacro(vtkImageTwoInputFilter,vtkImageMultipleInputFilter);
00046
00049   virtual void SetInput1(vtkImageData *input);
00050
00053   virtual void SetInput2(vtkImageData *input);
00054
00056
00057   vtkImageData *GetInput1() {return (vtkImageData *)this->Inputs[0];}
00058   vtkImageData *GetInput2() {return (vtkImageData *)this->Inputs[1];}
00060
00061 protected:
00062   vtkImageTwoInputFilter();
00063   ~vtkImageTwoInputFilter() {};
00064
00065 private:
00066   vtkImageTwoInputFilter(const vtkImageTwoInputFilter&);  // Not implemented.
00067   void operator=(const vtkImageTwoInputFilter&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
00073
00074
00075
00076
00077
00078
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageVariance3D.h Source File

Imaging/vtkImageVariance3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageVariance3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkImageVariance3D_h
00041 #define __vtkImageVariance3D_h
00042
00043
00044 #include "vtkImageSpatialFilter.h"
00045
00046 class vtkImageEllipsoidSource;
00047
00048 class VTK_IMAGING_EXPORT vtkImageVariance3D : public vtkImageSpatialFilter
00049 {
00050 public:
00051   static vtkImageVariance3D *New();
00052   vtkTypeRevisionMacro(vtkImageVariance3D,vtkImageSpatialFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00058   void SetKernelSize(int size0, int size1, int size2);
00059
00060 protected:
00061   vtkImageVariance3D();
00062   ~vtkImageVariance3D();
00063
00064   vtkImageEllipsoidSource *Ellipse;
00065
00066   void ExecuteInformation(vtkImageData *inData, vtkImageData *outData);
00067   void ExecuteInformation(){this->vtkImageToImageFilter::ExecuteInformation();};
00068   void ThreadedExecute(vtkImageData *inData, vtkImageData *outData,
00069                        int extent[6], int id);
00070 private:
00071   vtkImageVariance3D(const vtkImageVariance3D&);  // Not implemented.
00072   void operator=(const vtkImageVariance3D&);  // Not implemented.
00073 };
00074
00075 #endif
00076
00077
00078
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImageViewer2.h Source File

Rendering/vtkImageViewer2.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageViewer2.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkImageViewer2_h
00040 #define __vtkImageViewer2_h
00041
00042 #include "vtkObject.h"
00043 #include "vtkRenderWindow.h"
00044 #include "vtkImageActor.h"
00045 #include "vtkImageMapToWindowLevelColors.h"
00046
00047 class vtkInteractorStyleImage;
00048
00049 class VTK_RENDERING_EXPORT vtkImageViewer2 : public vtkObject
00050 {
00051 public:
00052   static vtkImageViewer2 *New();
00053
00054   vtkTypeRevisionMacro(vtkImageViewer2,vtkObject);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058   char *GetWindowName() {return this->RenderWindow->GetWindowName();};
00059
00061   virtual void Render(void);
00062
00064
00065   void SetInput(vtkImageData *in) {this->WindowLevel->SetInput(in);};
00066   vtkImageData *GetInput() { return this->WindowLevel->GetInput();};
00068
00070
00071   int GetWholeZMin() {return this->ImageActor->GetWholeZMin();};
00072   int GetWholeZMax() {return this->ImageActor->GetWholeZMax();};
00074
00076
00077   int GetZSlice() {return this->ImageActor->GetZSlice();};
00078   void SetZSlice(int s) {this->ImageActor->SetZSlice(s);};
00080
00082
00083   float GetColorWindow() {return this->WindowLevel->GetWindow();};
00084   float GetColorLevel() {return this->WindowLevel->GetLevel();};
00085   void SetColorWindow(float s) {this->WindowLevel->SetWindow(s);};
00086   void SetColorLevel(float s) {this->WindowLevel->SetLevel(s);};
00088
00090
00091   void SetDisplayId(void *a) {this->RenderWindow->SetDisplayId(a);};
00092   void SetWindowId(void *a) {this->RenderWindow->SetWindowId(a);};
00093   void SetParentId(void *a) {this->RenderWindow->SetParentId(a);};
00095
00097
00098   int *GetPosition() {return this->RenderWindow->GetPosition();};
00099   void SetPosition(int a,int b) {this->RenderWindow->SetPosition(a,b);};
00100   virtual void SetPosition(int a[2]);
00102
00104
00105   int *GetSize() {return this->RenderWindow->GetSize();};
00106   void SetSize(int a,int b) {this->RenderWindow->SetSize(a,b);};
00107   virtual void SetSize(int a[2]);
00109
00111
00112   vtkGetObjectMacro(RenderWindow,vtkRenderWindow);
00113   vtkGetObjectMacro(Renderer, vtkRenderer);
00114   vtkGetObjectMacro(ImageActor,vtkImageActor);
00115   vtkGetObjectMacro(WindowLevel,vtkImageMapToWindowLevelColors);
00117
00119   void SetupInteractor(vtkRenderWindowInteractor *);
00120
00121 protected:
00122   vtkImageViewer2();
00123   ~vtkImageViewer2();
00124
00125   vtkImageMapToWindowLevelColors  *WindowLevel;
00126   vtkRenderWindow *RenderWindow;
00127   vtkRenderer     *Renderer;
00128   vtkImageActor   *ImageActor;
00129   int FirstRender;
00130   vtkRenderWindowInteractor *Interactor;
00131   vtkInteractorStyleImage *InteractorStyle;
00132 private:
00133   vtkImageViewer2(const vtkImageViewer2&);  // Not implemented.
00134   void operator=(const vtkImageViewer2&);  // Not implemented.
00135 };
00136
00137 #endif
00138
00139
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImageViewer.h Source File

Rendering/vtkImageViewer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageViewer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkImageViewer_h
00046 #define __vtkImageViewer_h
00047
00048 #include "vtkObject.h"
00049 #include "vtkImageWindow.h"
00050 #include "vtkRenderWindow.h"
00051
00052 class VTK_RENDERING_EXPORT vtkImageViewer : public vtkObject
00053 {
00054 public:
00055   static vtkImageViewer *New();
00056
00057   vtkTypeRevisionMacro(vtkImageViewer,vtkObject);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   char *GetWindowName() {return this->RenderWindow->GetWindowName();};
00062
00064   virtual void Render(void);
00065
00067
00068   void SetInput(vtkImageData *in) {this->ImageMapper->SetInput(in);};
00069   vtkImageData *GetInput() { return this->ImageMapper->GetInput();};
00071
00073
00074   int GetWholeZMin() {return this->ImageMapper->GetWholeZMin();};
00075   int GetWholeZMax() {return this->ImageMapper->GetWholeZMax();};
00077
00079
00080   int GetZSlice() {return this->ImageMapper->GetZSlice();};
00081   void SetZSlice(int s) {this->ImageMapper->SetZSlice(s);};
00083
00085
00086   float GetColorWindow() {return this->ImageMapper->GetColorWindow();};
00087   float GetColorLevel() {return this->ImageMapper->GetColorLevel();};
00088   void SetColorWindow(float s) {this->ImageMapper->SetColorWindow(s);};
00089   void SetColorLevel(float s) {this->ImageMapper->SetColorLevel(s);};
00091
00093
00094   void SetDisplayId(void *a) {this->RenderWindow->SetDisplayId(a);};
00095   void SetWindowId(void *a) {this->RenderWindow->SetWindowId(a);};
00096   void SetParentId(void *a) {this->RenderWindow->SetParentId(a);};
00098
00100
00102   int GetGrayScaleHint()
00103     {vtkWarningMacro("GetGrayScaleHint deprecated, not required anymore"); return 0;};
00104   void SetGrayScaleHint(int vtkNotUsed(a))
00105     {vtkWarningMacro("SetGrayScaleHint deprecated, not required anymore");};
00106   void GrayScaleHintOn()
00107     {vtkWarningMacro("GrayScaleHintOn deprecated, not required anymore");};
00108   void GrayScaleHintOff()
00109     {vtkWarningMacro("GrayScaleHintOff deprecated, not required anymore");};
00111
00113
00114   int *GetPosition() {return this->RenderWindow->GetPosition();};
00115   void SetPosition(int a,int b) {this->RenderWindow->SetPosition(a,b);};
00116   virtual void SetPosition(int a[2]);
00118
00120
00121   int *GetSize() {return this->RenderWindow->GetSize();};
00122   void SetSize(int a,int b) {this->RenderWindow->SetSize(a,b);};
00123   virtual void SetSize(int a[2]);
00125
00127
00128   vtkImageWindow *GetImageWindow()
00129     {vtkWarningMacro("GetImageWindow deprecated, use GetRenderWindow instead."); return NULL;};
00130   vtkImager      *GetImager()
00131     {vtkWarningMacro("GetImager deprecated, use GetRenderer instead."); return NULL;};
00133
00134   vtkImageMapper *GetImageMapper() {return this->ImageMapper;};
00135   vtkActor2D     *GetActor2D() {return this->Actor2D;};
00136   vtkRenderWindow *GetRenderWindow() {return this->RenderWindow;};
00137   vtkRenderer     *GetRenderer() {return this->Renderer;};
00138
00139 protected:
00140   vtkImageViewer();
00141   ~vtkImageViewer();
00142
00143   vtkRenderWindow *RenderWindow;
00144   vtkRenderer *Renderer;
00145   vtkImageMapper *ImageMapper;
00146   vtkActor2D     *Actor2D;
00147 private:
00148   vtkImageViewer(const vtkImageViewer&);  // Not implemented.
00149   void operator=(const vtkImageViewer&);  // Not implemented.
00150 };
00151
00152 #endif
00153
00154
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImageWindow.h Source File

Rendering/vtkImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageWindow_h
00039 #define __vtkImageWindow_h
00040
00041 #include "vtkWindow.h"
00042 #include "vtkActor2D.h"
00043 #include "vtkImager.h"
00044 #include "vtkImageMapper.h"
00045 #include "vtkImagerCollection.h"
00046 #include "vtkWindow.h"
00047
00048
00049 class VTK_RENDERING_EXPORT vtkImageWindow : public vtkWindow
00050 {
00051 public:
00054   static vtkImageWindow *New();
00055
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057   vtkTypeRevisionMacro(vtkImageWindow,vtkWindow);
00058
00060
00061   virtual void SetPosition(int x, int y) = 0;
00062   virtual void SetPosition(int a[2]) { this->SetPosition(a[0],a[1]); };
00064
00066
00067   virtual int* GetPosition() = 0;
00068   virtual void GetPosition(int* x, int* y);
00070
00072
00073   virtual void SetSize(int , int ) = 0;
00074   virtual void SetSize(int a[2]) { this->SetSize(a[0], a[1]); };
00076
00078
00079   virtual int* GetSize() = 0;
00080   virtual void GetSize(int *x, int *y);
00082
00084
00085   virtual void SetDisplayId(void *) = 0;
00086   virtual void SetWindowId(void *) = 0;
00087   virtual void SetParentId(void *) = 0;
00088   virtual void *GetGenericDisplayId() = 0;
00089   virtual void *GetGenericWindowId() = 0;
00090   virtual void *GetGenericParentId() = 0;
00091   virtual void *GetGenericContext()   = 0;
00092   virtual void *GetGenericDrawable() {return NULL;};
00094
00098   virtual void SwapBuffers() = 0;
00099
00101   virtual void Frame() = 0;
00102
00104
00105   virtual void SetWindowInfo(char *)
00106       { vtkErrorMacro(<<"vtkImageWindow::SetWindowInfo - Not implemented"); };
00107   virtual void SetParentInfo(char *)
00108       { vtkErrorMacro(<<"vtkImageWindow::SetParentInfo - Not implemented"); };
00110
00112
00114   vtkSetMacro(GrayScaleHint, int);
00115   vtkGetMacro(GrayScaleHint, int);
00116   vtkBooleanMacro(GrayScaleHint, int);
00118
00120   void AddImager(vtkImager* im);
00121
00123   vtkImagerCollection *GetImagers() {return this->Imagers;};
00124
00126   void RemoveImager(vtkImager* im);
00127
00129   virtual void Render();
00130
00132   virtual void EraseWindow();
00133
00135   virtual void SaveImageAsPPM();
00136
00138
00139   virtual  int OpenPPMImageFile();
00140   virtual void WritePPMImageFile();
00141   virtual void ClosePPMImageFile();
00143
00145
00147   vtkSetStringMacro(FileName);
00148   vtkGetStringMacro(FileName);
00150
00153   virtual void MakeCurrent() {};
00154
00155 protected:
00156   vtkImageWindow();
00157   ~vtkImageWindow();
00158
00159   vtkImagerCollection *Imagers;
00160   int WindowCreated;
00161   int GrayScaleHint;
00162   virtual void MakeDefaultWindow() = 0;
00163   char *FileName;
00164   FILE* PPMImageFilePtr;
00165
00166 private:
00167   vtkImageWindow(const vtkImageWindow&);  // Not implemented.
00168   void operator=(const vtkImageWindow&);  // Not implemented.
00169 };
00170
00171
00172 #endif
00173
00174
00175
00176
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImageWrapPad.h Source File

Imaging/vtkImageWrapPad.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageWrapPad.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImageWrapPad_h
00039 #define __vtkImageWrapPad_h
00040
00041
00042 #include "vtkImagePadFilter.h"
00043
00044 class VTK_IMAGING_EXPORT vtkImageWrapPad : public vtkImagePadFilter
00045 {
00046 public:
00047   static vtkImageWrapPad *New();
00048   vtkTypeRevisionMacro(vtkImageWrapPad,vtkImagePadFilter);
00049
00050 protected:
00051   vtkImageWrapPad() {};
00052   ~vtkImageWrapPad() {};
00053
00054   void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00055
00056   void ThreadedExecute(vtkImageData *inData, vtkImageData *outRegion,
00057                        int ext[6], int id);
00058 private:
00059   vtkImageWrapPad(const vtkImageWrapPad&);  // Not implemented.
00060   void operator=(const vtkImageWrapPad&);  // Not implemented.
00061 };
00062
00063 #endif
00064
00065
00066
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkImageWriter.h Source File

IO/vtkImageWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImageWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImageWriter_h
00038 #define __vtkImageWriter_h
00039
00040 #include "vtkProcessObject.h"
00041 #include "vtkImageData.h"
00042
00043 class VTK_IO_EXPORT vtkImageWriter : public vtkProcessObject
00044 {
00045 public:
00046   static vtkImageWriter *New();
00047   vtkTypeRevisionMacro(vtkImageWriter,vtkProcessObject);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00054   void SetFileName(const char *);
00055   vtkGetStringMacro(FileName);
00057
00059
00062   void SetFilePrefix(char *filePrefix);
00063   vtkGetStringMacro(FilePrefix);
00065
00067
00068   void SetFilePattern(const char *filePattern);
00069   vtkGetStringMacro(FilePattern);
00071
00073
00076   vtkSetMacro(FileDimensionality, int);
00077   vtkGetMacro(FileDimensionality, int);
00079
00081
00082   virtual void SetInput(vtkImageData *input);
00083   vtkImageData *GetInput();
00085
00087   virtual void Write();
00088
00089 protected:
00090   vtkImageWriter();
00091   ~vtkImageWriter();
00092
00093   int FileDimensionality;
00094   char *FilePrefix;
00095   char *FilePattern;
00096   char *FileName;
00097   int FileNumber;
00098   int FileLowerLeft;
00099   char *InternalFileName;
00100
00101   virtual void RecursiveWrite(int dim, vtkImageData *region, ofstream *file);
00102   virtual void RecursiveWrite(int dim, vtkImageData *cache,
00103                               vtkImageData *data, ofstream *file);
00104   virtual void WriteFile(ofstream *file, vtkImageData *data, int extent[6]);
00105   virtual void WriteFileHeader(ofstream *, vtkImageData *) {};
00106   virtual void WriteFileTrailer(ofstream *, vtkImageData *) {};
00107 private:
00108   vtkImageWriter(const vtkImageWriter&);  // Not implemented.
00109   void operator=(const vtkImageWriter&);  // Not implemented.
00110 };
00111
00112 #endif
00113
00114
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImagingFactory.h Source File

Rendering/vtkImagingFactory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImagingFactory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkImagingFactory_h
00032 #define __vtkImagingFactory_h
00033
00034 #include "vtkObject.h"
00035
00036 class VTK_RENDERING_EXPORT vtkImagingFactory : public vtkObject
00037 {
00038 public:
00039   static vtkImagingFactory *New() {return new vtkImagingFactory;};
00040   vtkTypeRevisionMacro(vtkImagingFactory,vtkObject);
00041
00044   static vtkObject* CreateInstance(const char* vtkclassname);
00045
00046 protected:
00047   vtkImagingFactory() {};
00048 private:
00049   vtkImagingFactory(const vtkImagingFactory&);  // Not implemented.
00050   void operator=(const vtkImagingFactory&);  // Not implemented.
00051 };
00052
00053 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitBoolean.h Source File

Filtering/vtkImplicitBoolean.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitBoolean.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkImplicitBoolean_h
00053 #define __vtkImplicitBoolean_h
00054
00055 #include "vtkImplicitFunction.h"
00056 #include "vtkImplicitFunctionCollection.h"
00057
00058 #define VTK_UNION 0
00059 #define VTK_INTERSECTION 1
00060 #define VTK_DIFFERENCE 2
00061 #define VTK_UNION_OF_MAGNITUDES 3
00062
00063 class VTK_FILTERING_EXPORT vtkImplicitBoolean : public vtkImplicitFunction
00064 {
00065 public:
00066   vtkTypeRevisionMacro(vtkImplicitBoolean,vtkImplicitFunction);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00070   static vtkImplicitBoolean *New();
00071
00073
00075   float EvaluateFunction(float x[3]);
00076   float EvaluateFunction(float x, float y, float z)
00077     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00079
00081   void EvaluateGradient(float x[3], float g[3]);
00082
00084   unsigned long GetMTime();
00085
00087   void AddFunction(vtkImplicitFunction *in);
00088
00090   void RemoveFunction(vtkImplicitFunction *in);
00091
00093   vtkImplicitFunctionCollection *GetFunction() {return this->FunctionList;};
00094
00096
00097   vtkSetClampMacro(OperationType,int,VTK_UNION,VTK_UNION_OF_MAGNITUDES);
00098   vtkGetMacro(OperationType,int);
00099   void SetOperationTypeToUnion()
00100     {this->SetOperationType(VTK_UNION);};
00101   void SetOperationTypeToIntersection()
00102     {this->SetOperationType(VTK_INTERSECTION);};
00103   void SetOperationTypeToDifference()
00104     {this->SetOperationType(VTK_DIFFERENCE);};
00105   void SetOperationTypeToUnionOfMagnitudes()
00106     {this->SetOperationType(VTK_UNION_OF_MAGNITUDES);};
00107   const char *GetOperationTypeAsString();
00109
00110 protected:
00111   vtkImplicitBoolean();
00112   ~vtkImplicitBoolean();
00113
00114   vtkImplicitFunctionCollection *FunctionList;
00115
00116   int OperationType;
00117
00118 private:
00119   vtkImplicitBoolean(const vtkImplicitBoolean&);  // Not implemented.
00120   void operator=(const vtkImplicitBoolean&);  // Not implemented.
00121 };
00122
00124 inline const char *vtkImplicitBoolean::GetOperationTypeAsString(void)
00125 {
00126   if ( this->OperationType == VTK_UNION )
00127     {
00128     return "Union";
00129     }
00130   else if ( this->OperationType == VTK_INTERSECTION )
00131     {
00132     return "Intersection";
00133     }
00134   else if ( this->OperationType == VTK_DIFFERENCE )
00135     {
00136     return "Difference";
00137     }
00138   else
00139     {
00140     return "UnionOfMagnitudes";
00141     }
00142 }
00143
00144 #endif
00145
00146
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitDataSet.h Source File

Filtering/vtkImplicitDataSet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitDataSet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkImplicitDataSet_h
00056 #define __vtkImplicitDataSet_h
00057
00058 #include "vtkImplicitFunction.h"
00059 #include "vtkDataSet.h"
00060
00061 class VTK_FILTERING_EXPORT vtkImplicitDataSet : public vtkImplicitFunction
00062 {
00063 public:
00064   vtkTypeRevisionMacro(vtkImplicitDataSet,vtkImplicitFunction);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00069   static vtkImplicitDataSet *New();
00070
00072   unsigned long GetMTime();
00073
00075
00077   float EvaluateFunction(float x[3]);
00078   float EvaluateFunction(float x, float y, float z)
00079     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00081
00083   void EvaluateGradient(float x[3], float n[3]);
00084
00086
00087   vtkSetObjectMacro(DataSet,vtkDataSet);
00088   vtkGetObjectMacro(DataSet,vtkDataSet);
00090
00092
00094   vtkSetMacro(OutValue,float);
00095   vtkGetMacro(OutValue,float);
00097
00099
00101   vtkSetVector3Macro(OutGradient,float);
00102   vtkGetVector3Macro(OutGradient,float);
00104
00105 protected:
00106   vtkImplicitDataSet();
00107   ~vtkImplicitDataSet();
00108
00109   vtkDataSet *DataSet;
00110   float OutValue;
00111   float OutGradient[3];
00112
00113   float *Weights; //used to compute interpolation weights
00114   int Size; //keeps track of length of weights array
00115
00116 private:
00117   vtkImplicitDataSet(const vtkImplicitDataSet&);  // Not implemented.
00118   void operator=(const vtkImplicitDataSet&);  // Not implemented.
00119 };
00120
00121 #endif
00122
00123
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkImplicitFunction.h Source File

Common/vtkImplicitFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkImplicitFunction_h
00059 #define __vtkImplicitFunction_h
00060
00061 #include "vtkObject.h"
00062 #include "vtkAbstractTransform.h"
00063
00064 class VTK_COMMON_EXPORT vtkImplicitFunction : public vtkObject
00065 {
00066 public:
00067   vtkTypeRevisionMacro(vtkImplicitFunction,vtkObject);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00072   unsigned long GetMTime();
00073
00075
00077   float FunctionValue(const float x[3]);
00078   float FunctionValue(float x, float y, float z) {
00079     float xyz[3] = {x, y, z}; return this->FunctionValue(xyz); };
00081
00083
00085   void FunctionGradient(const float x[3], float g[3]);
00086   float *FunctionGradient(const float x[3]) {
00087     this->FunctionGradient(x,this->ReturnValue);
00088     return this->ReturnValue; };
00089   float *FunctionGradient(float x, float y, float z) {
00090     float xyz[3] = {x, y, z}; return this->FunctionGradient(xyz); };
00092
00094
00096   vtkSetObjectMacro(Transform,vtkAbstractTransform);
00097   vtkGetObjectMacro(Transform,vtkAbstractTransform);
00099
00101
00105   virtual float EvaluateFunction(float x[3]) = 0;
00106   float EvaluateFunction(float x, float y, float z) {
00107     float xyz[3] = {x, y, z}; return this->EvaluateFunction(xyz); };
00109
00114   virtual void EvaluateGradient(float x[3], float g[3]) = 0;
00115
00116 protected:
00117   vtkImplicitFunction();
00118   ~vtkImplicitFunction();
00119
00120   vtkAbstractTransform *Transform;
00121   float ReturnValue[3];
00122 private:
00123   vtkImplicitFunction(const vtkImplicitFunction&);  // Not implemented.
00124   void operator=(const vtkImplicitFunction&);  // Not implemented.
00125 };
00126
00127 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkImplicitFunctionCollection.h Source File

Common/vtkImplicitFunctionCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitFunctionCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkImplicitFunctionCollection_h
00038 #define __vtkImplicitFunctionCollection_h
00039
00040 #include "vtkCollection.h"
00041 #include "vtkImplicitFunction.h"
00042
00043 class VTK_COMMON_EXPORT vtkImplicitFunctionCollection : public vtkCollection
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkImplicitFunctionCollection,vtkCollection);
00047   static vtkImplicitFunctionCollection *New();
00048
00050   void AddItem(vtkImplicitFunction *);
00051
00053   vtkImplicitFunction *GetNextItem();
00054
00055 protected:
00056   vtkImplicitFunctionCollection() {};
00057   ~vtkImplicitFunctionCollection() {};
00058
00059
00060 private:
00061   // hide the standard AddItem from the user and the compiler.
00062   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00063
00064 private:
00065   vtkImplicitFunctionCollection(const vtkImplicitFunctionCollection&);  // Not implemented.
00066   void operator=(const vtkImplicitFunctionCollection&);  // Not implemented.
00067 };
00068
00069 inline void vtkImplicitFunctionCollection::AddItem(vtkImplicitFunction *f)
00070 {
00071   this->vtkCollection::AddItem((vtkObject *)f);
00072 }
00073
00074 inline vtkImplicitFunction *vtkImplicitFunctionCollection::GetNextItem()
00075 {
00076   return static_cast<vtkImplicitFunction *>(this->GetNextItemAsObject());
00077 }
00078
00079 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkImplicitFunctionToImageStencil.h Source File

Imaging/vtkImplicitFunctionToImageStencil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitFunctionToImageStencil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkImplicitFunctionToImageStencil_h
00039 #define __vtkImplicitFunctionToImageStencil_h
00040
00041
00042 #include "vtkImageStencilSource.h"
00043 #include "vtkImplicitFunction.h"
00044
00045 class VTK_IMAGING_EXPORT vtkImplicitFunctionToImageStencil : public vtkImageStencilSource
00046 {
00047 public:
00048   static vtkImplicitFunctionToImageStencil *New();
00049   vtkTypeRevisionMacro(vtkImplicitFunctionToImageStencil, vtkImageStencilSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetObjectMacro(Input, vtkImplicitFunction);
00055   vtkGetObjectMacro(Input, vtkImplicitFunction);
00057
00059
00060   vtkSetMacro(Threshold, float);
00061   vtkGetMacro(Threshold, float);
00063
00064 protected:
00065   vtkImplicitFunctionToImageStencil();
00066   ~vtkImplicitFunctionToImageStencil();
00067   void operator=(const vtkImplicitFunctionToImageStencil&);
00068
00069   void ThreadedExecute(vtkImageStencilData *output,
00070                        int extent[6], int threadId);
00071
00072   vtkImplicitFunction *Input;
00073   float Threshold;
00074 private:
00075   vtkImplicitFunctionToImageStencil(const vtkImplicitFunctionToImageStencil&)  // Not implemented.
00076     {};  // Not implemented.
00077 };
00078
00079 #endif
00080
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkImplicitModeller.h Source File

Hybrid/vtkImplicitModeller.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitModeller.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00089 #ifndef __vtkImplicitModeller_h
00090 #define __vtkImplicitModeller_h
00091
00092 #include "vtkDataSetToStructuredPointsFilter.h"
00093
00094 #define VTK_VOXEL_MODE   0
00095 #define VTK_CELL_MODE    1
00096
00097 class vtkMultiThreader;
00098 class vtkExtractGeometry;
00099
00100 class VTK_HYBRID_EXPORT vtkImplicitModeller : public vtkDataSetToStructuredPointsFilter
00101 {
00102 public:
00103   vtkTypeRevisionMacro(vtkImplicitModeller,vtkDataSetToStructuredPointsFilter);
00104   void PrintSelf(ostream& os, vtkIndent indent);
00105
00109   static vtkImplicitModeller *New();
00110
00113   float ComputeModelBounds(vtkDataSet *input = NULL);
00114
00116
00117   vtkGetVectorMacro(SampleDimensions,int,3);
00118   void SetSampleDimensions(int i, int j, int k);
00119   void SetSampleDimensions(int dim[3]);
00121
00123
00125   vtkSetClampMacro(MaximumDistance,float,0.0,1.0);
00126   vtkGetMacro(MaximumDistance,float);
00128
00130
00132   vtkSetVector6Macro(ModelBounds,float);
00133   vtkGetVectorMacro(ModelBounds,float,6);
00135
00137
00141   vtkSetMacro(AdjustBounds,int);
00142   vtkGetMacro(AdjustBounds,int);
00143   vtkBooleanMacro(AdjustBounds,int);
00145
00147
00150   vtkSetClampMacro(AdjustDistance,float,-1.0,1.0);
00151   vtkGetMacro(AdjustDistance,float);
00153
00155
00157   vtkSetMacro(Capping,int);
00158   vtkGetMacro(Capping,int);
00159   vtkBooleanMacro(Capping,int);
00161
00163
00165   vtkSetMacro(CapValue,float);
00166   vtkGetMacro(CapValue,float);
00168
00170
00175   vtkSetClampMacro(ProcessMode, int, 0, 1);
00176   vtkGetMacro(ProcessMode, int);
00177   void SetProcessModeToPerVoxel() {this->SetProcessMode(VTK_VOXEL_MODE);}
00178   void SetProcessModeToPerCell()  {this->SetProcessMode(VTK_CELL_MODE);}
00179   const char *GetProcessModeAsString(void);
00181
00183
00185   vtkSetMacro(LocatorMaxLevel,int);
00186   vtkGetMacro(LocatorMaxLevel,int);
00188
00190
00191   vtkSetMacro( NumberOfThreads, int );
00192   vtkGetMacro( NumberOfThreads, int );
00194
00199   void StartAppend();
00200
00206   void Append(vtkDataSet *input);
00207
00209   void EndAppend();
00210
00211   virtual void UpdateData(vtkDataObject *output);
00212
00213 protected:
00214   vtkImplicitModeller();
00215   ~vtkImplicitModeller();
00216
00217   void Execute();
00218   void ExecuteInformation();
00219
00220   void Cap(vtkDataArray *s);
00221
00222   vtkMultiThreader *Threader;
00223   int              NumberOfThreads;
00224
00225   int SampleDimensions[3];
00226   float MaximumDistance;
00227   float ModelBounds[6];
00228   int Capping;
00229   float CapValue;
00230   int DataAppended;
00231   int AdjustBounds;
00232   float AdjustDistance;
00233   int ProcessMode;
00234   int LocatorMaxLevel;
00235
00236   int BoundsComputed; // flag to limit to one ComputeModelBounds per StartAppend
00237   float InternalMaxDistance; // the max distance computed during that one call
00238 private:
00239   vtkImplicitModeller(const vtkImplicitModeller&);  // Not implemented.
00240   void operator=(const vtkImplicitModeller&);  // Not implemented.
00241 };
00242
00243 #endif
00244
00245
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitSelectionLoop.h Source File

Filtering/vtkImplicitSelectionLoop.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitSelectionLoop.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkImplicitSelectionLoop_h
00062 #define __vtkImplicitSelectionLoop_h
00063
00064 #include "vtkImplicitFunction.h"
00065 #include "vtkPolygon.h"
00066
00067 class VTK_FILTERING_EXPORT vtkImplicitSelectionLoop : public vtkImplicitFunction
00068 {
00069 public:
00070   vtkTypeRevisionMacro(vtkImplicitSelectionLoop,vtkImplicitFunction);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00074   static vtkImplicitSelectionLoop *New();
00075
00077
00078   float EvaluateFunction(float x[3]);
00079   float EvaluateFunction(float x, float y, float z)
00080     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00082
00084   void EvaluateGradient(float x[3], float n[3]);
00085
00087
00089   vtkSetObjectMacro(Loop,vtkPoints);
00090   vtkGetObjectMacro(Loop,vtkPoints);
00092
00094
00097   vtkSetMacro(AutomaticNormalGeneration,int);
00098   vtkGetMacro(AutomaticNormalGeneration,int);
00099   vtkBooleanMacro(AutomaticNormalGeneration,int);
00101
00103
00105   vtkSetVector3Macro(Normal,float);
00106   vtkGetVectorMacro(Normal,float,3);
00108
00110   unsigned long GetMTime();
00111
00112 protected:
00113   vtkImplicitSelectionLoop();
00114   ~vtkImplicitSelectionLoop();
00115
00116   vtkPoints *Loop;
00117   float Normal[3];
00118   int AutomaticNormalGeneration;
00119
00120 private:
00121   void Initialize();
00122   vtkPolygon *Polygon;
00123
00124   float Origin[3];
00125   float Bounds[6];
00126   float DeltaX;
00127   float DeltaY;
00128   float DeltaZ;
00129
00130   vtkTimeStamp InitializationTime;
00131
00132 private:
00133   vtkImplicitSelectionLoop(const vtkImplicitSelectionLoop&);  // Not implemented.
00134   void operator=(const vtkImplicitSelectionLoop&);  // Not implemented.
00135 };
00136
00137 #endif
00138
00139
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitSum.h Source File

Filtering/vtkImplicitSum.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitSum.h,v $
00005   Language:  C++
00006
00007
00008 Copyright (c) 1993-2001 Ken Martin, Will Schroeder, Bill Lorensen
00009 All rights reserved.
00010
00011 Redistribution and use in source and binary forms, with or without
00012 modification, are permitted provided that the following conditions are met:
00013
00014  * Redistributions of source code must retain the above copyright notice,
00015    this list of conditions and the following disclaimer.
00016
00017  * Redistributions in binary form must reproduce the above copyright notice,
00018    this list of conditions and the following disclaimer in the documentation
00019    and/or other materials provided with the distribution.
00020
00021  * Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names
00022    of any contributors may be used to endorse or promote products derived
00023    from this software without specific prior written permission.
00024
00025  * Modified source versions must be plainly marked as such, and must not be
00026    misrepresented as being the original software.
00027
00028 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS''
00029 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00030 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
00031 ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
00032 ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
00033 DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
00034 SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
00035 CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
00036 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00037 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00038
00039 =========================================================================*/
00066 #ifndef __vtkImplicitSum_h
00067 #define __vtkImplicitSum_h
00068
00069 #include "vtkImplicitFunctionCollection.h"
00070 #include "vtkFloatArray.h"
00071
00072 class VTK_FILTERING_EXPORT vtkImplicitSum : public vtkImplicitFunction
00073 {
00074 public:
00075   static vtkImplicitSum *New();
00076
00077   vtkTypeRevisionMacro(vtkImplicitSum,vtkImplicitFunction);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00081
00082   float EvaluateFunction(float x[3]);
00083   float EvaluateFunction(float x, float y, float z)
00084     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00086
00089   void EvaluateGradient(float x[3], float g[3]);
00090
00092   unsigned long GetMTime();
00093
00096   void AddFunction(vtkImplicitFunction *in, float weight);
00097
00100   void AddFunction(vtkImplicitFunction *in) { this->AddFunction(in, 1.0); }
00101
00103   void RemoveAllFunctions();
00104
00106   void SetFunctionWeight(vtkImplicitFunction *f, float weight);
00107
00109
00114   vtkSetMacro(NormalizeByWeight, int);
00115   vtkGetMacro(NormalizeByWeight, int);
00116   vtkBooleanMacro(NormalizeByWeight, int);
00118
00119 protected:
00120   vtkImplicitSum();
00121   ~vtkImplicitSum();
00122
00123   vtkImplicitFunctionCollection *FunctionList;
00124   vtkFloatArray *Weights;
00125   float TotalWeight;
00126
00127   void CalculateTotalWeight(void);
00128   int NormalizeByWeight;
00129
00130 private:
00131   vtkImplicitSum(const vtkImplicitSum&);  // Not implemented.
00132   void operator=(const vtkImplicitSum&);  // Not implemented.
00133 };
00134
00135 #endif
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkImplicitTextureCoords.h Source File

Graphics/vtkImplicitTextureCoords.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitTextureCoords.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00063 #ifndef __vtkImplicitTextureCoords_h
00064 #define __vtkImplicitTextureCoords_h
00065
00066 #include "vtkDataSetToDataSetFilter.h"
00067 #include "vtkImplicitFunction.h"
00068
00069 class VTK_GRAPHICS_EXPORT vtkImplicitTextureCoords : public vtkDataSetToDataSetFilter
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkImplicitTextureCoords,vtkDataSetToDataSetFilter);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00077   static vtkImplicitTextureCoords *New();
00078
00080
00081   vtkSetObjectMacro(RFunction,vtkImplicitFunction);
00082   vtkGetObjectMacro(RFunction,vtkImplicitFunction);
00084
00086
00087   vtkSetObjectMacro(SFunction,vtkImplicitFunction);
00088   vtkGetObjectMacro(SFunction,vtkImplicitFunction);
00090
00092
00093   vtkSetObjectMacro(TFunction,vtkImplicitFunction);
00094   vtkGetObjectMacro(TFunction,vtkImplicitFunction);
00096
00098
00100   vtkSetMacro(FlipTexture,int);
00101   vtkGetMacro(FlipTexture,int);
00102   vtkBooleanMacro(FlipTexture,int);
00104
00105 protected:
00106   vtkImplicitTextureCoords();
00107   ~vtkImplicitTextureCoords();
00108
00109   void Execute();
00110
00111   vtkImplicitFunction *RFunction;
00112   vtkImplicitFunction *SFunction;
00113   vtkImplicitFunction *TFunction;
00114   int FlipTexture;
00115 private:
00116   vtkImplicitTextureCoords(const vtkImplicitTextureCoords&);  // Not implemented.
00117   void operator=(const vtkImplicitTextureCoords&);  // Not implemented.
00118 };
00119
00120 #endif
00121
00122
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitVolume.h Source File

Filtering/vtkImplicitVolume.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitVolume.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkImplicitVolume_h
00057 #define __vtkImplicitVolume_h
00058
00059 #include "vtkImplicitFunction.h"
00060 #include "vtkImageData.h"
00061
00062 class VTK_FILTERING_EXPORT vtkImplicitVolume : public vtkImplicitFunction
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkImplicitVolume,vtkImplicitFunction);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00070   static vtkImplicitVolume *New();
00071
00075   unsigned long GetMTime();
00076
00078
00080   float EvaluateFunction(float x[3]);
00081   float EvaluateFunction(float x, float y, float z)
00082     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00084
00086   void EvaluateGradient(float x[3], float n[3]);
00087
00089
00090   vtkSetObjectMacro(Volume,vtkImageData);
00091   vtkGetObjectMacro(Volume,vtkImageData);
00093
00095
00096   vtkSetMacro(OutValue,float);
00097   vtkGetMacro(OutValue,float);
00099
00101
00102   vtkSetVector3Macro(OutGradient,float);
00103   vtkGetVector3Macro(OutGradient,float);
00105
00106 protected:
00107   vtkImplicitVolume();
00108   ~vtkImplicitVolume();
00109
00110   vtkImageData *Volume; // the structured points
00111   float OutValue;
00112   float OutGradient[3];
00113   // to replace a static
00114   vtkIdList *PointIds;
00115 private:
00116   vtkImplicitVolume(const vtkImplicitVolume&);  // Not implemented.
00117   void operator=(const vtkImplicitVolume&);  // Not implemented.
00118 };
00119
00120 #endif
00121
00122
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkImplicitWindowFunction.h Source File

Filtering/vtkImplicitWindowFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImplicitWindowFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkImplicitWindowFunction_h
00049 #define __vtkImplicitWindowFunction_h
00050
00051 #include <math.h>
00052 #include "vtkImplicitFunction.h"
00053
00054 class VTK_FILTERING_EXPORT vtkImplicitWindowFunction : public vtkImplicitFunction
00055 {
00056 public:
00057   vtkTypeRevisionMacro(vtkImplicitWindowFunction,vtkImplicitFunction);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   static vtkImplicitWindowFunction *New();
00062
00064
00065   float EvaluateFunction(float x[3]);
00066   float EvaluateFunction(float x, float y, float z)
00067     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00069
00072   void EvaluateGradient(float x[3], float n[3]);
00073
00075
00076   vtkSetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00077   vtkGetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00079
00081
00084   vtkSetVector2Macro(WindowRange,float);
00085   vtkGetVectorMacro(WindowRange,float,2);
00087
00089
00092   vtkSetVector2Macro(WindowValues,float);
00093   vtkGetVectorMacro(WindowValues,float,2);
00095
00097   unsigned long GetMTime();
00098
00099 protected:
00100   vtkImplicitWindowFunction();
00101   ~vtkImplicitWindowFunction();
00102
00103   vtkImplicitFunction *ImplicitFunction;
00104   float WindowRange[2];
00105   float WindowValues[2];
00106
00107 private:
00108   vtkImplicitWindowFunction(const vtkImplicitWindowFunction&);  // Not implemented.
00109   void operator=(const vtkImplicitWindowFunction&);  // Not implemented.
00110 };
00111
00112 #endif
00113
00114
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkImporter.h Source File

Rendering/vtkImporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkImporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkImporter_h
00058 #define __vtkImporter_h
00059
00060 #include <stdio.h>
00061 #include "vtkObject.h"
00062 #include "vtkRenderWindow.h"
00063 #include "vtkRenderer.h"
00064 #include "vtkPolyData.h"
00065 #include "vtkActorCollection.h"
00066 #include "vtkLightCollection.h"
00067
00068 class VTK_RENDERING_EXPORT vtkImporter : public vtkObject
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkImporter,vtkObject);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00074
00076
00078   vtkGetObjectMacro(Renderer,vtkRenderer);
00080
00082
00088   vtkSetObjectMacro(RenderWindow,vtkRenderWindow);
00089   vtkGetObjectMacro(RenderWindow,vtkRenderWindow);
00091
00092
00094
00096   void Read();
00097   void Update() {this->Read();};
00099
00100
00101 protected:
00102   vtkImporter();
00103   ~vtkImporter();
00104
00105   virtual int ImportBegin () {return 1;};
00106   virtual void ImportEnd () {};
00107   virtual void ImportActors (vtkRenderer *vtkNotUsed(renderer)) {};
00108   virtual void ImportCameras (vtkRenderer *vtkNotUsed(renderer)) {};
00109   virtual void ImportLights (vtkRenderer *vtkNotUsed(renderer)) {};
00110   virtual void ImportProperties (vtkRenderer *vtkNotUsed(renderer)) {};
00111
00112   vtkRenderer *Renderer;
00113   vtkRenderWindow *RenderWindow;
00114
00115   virtual void ReadData();
00116
00117 private:
00118   vtkImporter(const vtkImporter&);  // Not implemented.
00119   void operator=(const vtkImporter&);  // Not implemented.
00120 };
00121
00122 #endif
00123
00124
00125
00126
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkIndent.h Source File

Common/vtkIndent.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIndent.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00043 #ifndef __vtkIndent_h
00044 #define __vtkIndent_h
00045
00046 #include "vtkWin32Header.h"
00047 #include "vtkSystemIncludes.h"
00048
00049 class VTK_COMMON_EXPORT vtkIndent
00050 {
00051 public:
00052   void Delete() {delete this;};
00053   vtkIndent(int ind=0) {this->Indent=ind;};
00054   static vtkIndent *New();
00055
00056   virtual const char *GetClassName() {return "vtkIndent";};
00057
00060   vtkIndent GetNextIndent();
00061
00062   //BTX
00064   /*! Print out the indentation. Basically output a bunch of spaces. */
00065   friend VTK_COMMON_EXPORT ostream& operator<<(ostream& os, vtkIndent& o);
00066   //ETX
00068
00069 protected:
00070   int Indent;
00071
00072 };
00073
00074 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkInitialValueProblemSolver.h Source File

Common/vtkInitialValueProblemSolver.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInitialValueProblemSolver.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkInitialValueProblemSolver_h
00042 #define __vtkInitialValueProblemSolver_h
00043
00044 #include "vtkFunctionSet.h"
00045
00046 class VTK_COMMON_EXPORT vtkInitialValueProblemSolver : public vtkObject
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkInitialValueProblemSolver,vtkObject);
00050   virtual void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00067   virtual int ComputeNextStep(float* xprev, float* xnext, float t,
00068                float& delT, float maxError,
00069                float& error)
00070     {
00071       float minStep = delT;
00072       float maxStep = delT;
00073       float delTActual;
00074       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00075                minStep, maxStep, maxError, error);
00076     }
00077   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00078                float t, float& delT, float maxError,
00079                float& error)
00080     {
00081       float minStep = delT;
00082       float maxStep = delT;
00083       float delTActual;
00084       return this->ComputeNextStep(xprev, dxprev, xnext, t, delT, delTActual,
00085                minStep, maxStep, maxError, error);
00086     }
00087   virtual int ComputeNextStep(float* xprev, float* xnext,
00088                float t, float& delT, float& delTActual,
00089                float minStep, float maxStep,
00090                float maxError, float& error)
00091     {
00092       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00093                minStep, maxStep, maxError, error);
00094     }
00095   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00096                float t, float& delT, float& delTActual,
00097                float minStep, float maxStep,
00098                float maxError, float& error) = 0;
00100
00102   virtual vtkInitialValueProblemSolver *MakeObject()=0;
00103
00105
00106   virtual void SetFunctionSet(vtkFunctionSet* functionset);
00107   vtkGetObjectMacro(FunctionSet,vtkFunctionSet);
00109
00111   virtual int IsAdaptive() { return this->Adaptive; }
00112
00113 //BTX
00114   enum ErrorCodes
00115   {
00116     OUT_OF_DOMAIN = 1,
00117     NOT_INITIALIZED = 2,
00118     UNEXPECTED_VALUE = 3
00119   };
00120 //ETX
00121
00122 protected:
00123   vtkInitialValueProblemSolver();
00124   ~vtkInitialValueProblemSolver();
00125
00126   virtual void Initialize();
00127
00128   vtkFunctionSet* FunctionSet;
00129
00130   float* Vals;
00131   float* Derivs;
00132   int Initialized;
00133   int Adaptive;
00134
00135 private:
00136   vtkInitialValueProblemSolver(const vtkInitialValueProblemSolver&);  // Not implemented.
00137   void operator=(const vtkInitialValueProblemSolver&);  // Not implemented.
00138 };
00139
00140 #endif
00141
00142
00143
00144
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkInputPort.h Source File

Parallel/vtkInputPort.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInputPort.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkInputPort_h
00050 #define __vtkInputPort_h
00051
00052 #include "vtkSource.h"
00053 #include "vtkMultiProcessController.h"
00054 class vtkPolyData;
00055 class vtkUnstructuredGrid;
00056 class vtkStructuredGrid;
00057 class vtkRectilinearGrid;
00058 class vtkStructuredPoints;
00059 class vtkImageData;
00060
00061
00062
00063 class VTK_PARALLEL_EXPORT vtkInputPort : public vtkSource
00064 {
00065 public:
00066   static vtkInputPort *New();
00067   vtkTypeRevisionMacro(vtkInputPort,vtkSource);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00071
00075   vtkPolyData *GetPolyDataOutput();
00076   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00077   vtkStructuredGrid *GetStructuredGridOutput();
00078   vtkRectilinearGrid *GetRectilinearGridOutput();
00079   vtkStructuredPoints *GetStructuredPointsOutput();
00080   vtkImageData *GetImageDataOutput();
00082
00084
00087   vtkSetMacro(RemoteProcessId, int);
00088   vtkGetMacro(RemoteProcessId, int);
00089   vtkSetMacro(Tag, int);
00090   vtkGetMacro(Tag, int);
00092
00094   void UpdateInformation();
00095
00097   void PropagateUpdateExtent(vtkDataObject *vtkNotUsed(output)) {};
00098
00100   void UpdateData( vtkDataObject *out );
00101
00103   void TriggerAsynchronousUpdate();
00104
00106
00108   vtkMultiProcessController *GetController() {return this->Controller;}
00109   vtkSetObjectMacro(Controller, vtkMultiProcessController);
00111
00113
00118   vtkSetMacro(DoUpdateInformation, int);
00119   vtkGetMacro(DoUpdateInformation, int);
00121
00122 //BTX
00123
00124 // Arbitrary tags used by the ports for communication.
00125   enum Tags {
00126     DOWN_DATA_TIME_TAG = 98970,
00127     UPDATE_EXTENT_TAG = 98971,
00128     TRANSFER_NEEDED_TAG = 98972,
00129     INFORMATION_TRANSFER_TAG = 98973,
00130     DATA_TRANSFER_TAG = 98974,
00131     NEW_DATA_TIME_TAG = 98975
00132   };
00133
00134 //ETX
00135
00136 protected:
00137   vtkInputPort();
00138   ~vtkInputPort();
00139
00140   vtkMultiProcessController *Controller;
00141   int RemoteProcessId;
00142   int Tag;
00143
00144   unsigned long DataTime;
00145   unsigned long UpStreamMTime;
00146   int TransferNeeded;
00147   int DoUpdateInformation;
00148 private:
00149   vtkInputPort(const vtkInputPort&);  // Not implemented.
00150   void operator=(const vtkInputPort&);  // Not implemented.
00151 };
00152
00153 #endif
00154
00155
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkInstantiator.h Source File

Common/vtkInstantiator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInstantiator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00065 #ifndef __vtkInstantiator_h
00066 #define __vtkInstantiator_h
00067
00068 #include "vtkObject.h"
00069
00070 class vtkInstantiatorInitialize;
00071 class vtkInstantiatorHashTable;
00072
00073 class VTK_COMMON_EXPORT vtkInstantiator : public vtkObject
00074 {
00075 public:
00076   static vtkInstantiator* New();
00077   vtkTypeRevisionMacro(vtkInstantiator,vtkObject);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00082   static vtkObject* CreateInstance(const char* className);
00083
00084   //BTX
00085   typedef vtkObject* (*CreateFunction)();
00086
00088
00092   static void RegisterInstantiator(const char* className,
00093                                    CreateFunction createFunction);
00095
00097
00100   static void UnRegisterInstantiator(const char* className,
00101                                      CreateFunction createFunction);
00102   //ETX
00104
00105 protected:
00106   vtkInstantiator();
00107   ~vtkInstantiator();
00108
00109   // Internal storage for registered creation functions.
00110   static vtkInstantiatorHashTable* CreatorTable;
00111
00112   static void ClassInitialize();
00113   static void ClassFinalize();
00114
00115   //BTX
00116   friend class vtkInstantiatorInitialize;
00117   //ETX
00118
00119 private:
00120   vtkInstantiator(const vtkInstantiator&);  // Not implemented.
00121   void operator=(const vtkInstantiator&);  // Not implemented.
00122 };
00123
00124 //BTX
00125 // Utility class to make sure vtkInstantiator is initialized before it
00126 // is used.
00127 class VTK_COMMON_EXPORT vtkInstantiatorInitialize
00128 {
00129 public:
00130   vtkInstantiatorInitialize();
00131   ~vtkInstantiatorInitialize();
00132 private:
00133   static unsigned int Count;
00134 };
00135
00136 // This instance will show up in any translation unit that uses
00137 // vtkInstantiator.  It will make sure vtkInstantiator is initialized
00138 // before it is used.
00139 static vtkInstantiatorInitialize vtkInstantiatorInitializer;
00140 //ETX
00141
00142 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkIntArray.h Source File

Common/vtkIntArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIntArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkIntArray_h
00043 #define __vtkIntArray_h
00044
00045 #include "vtkDataArray.h"
00046
00047 class VTK_COMMON_EXPORT vtkIntArray : public vtkDataArray
00048 {
00049 public:
00050   static vtkIntArray *New();
00051
00052   vtkTypeRevisionMacro(vtkIntArray,vtkDataArray);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00058
00060   void Initialize();
00061
00063   vtkDataArray *MakeObject();
00064
00066
00067   int GetDataType()
00068     {return VTK_INT;}
00070
00072   int GetDataTypeSize() { return sizeof(int); }
00073
00075
00076   void Squeeze()
00077     {this->ResizeAndExtend (this->MaxId+1);}
00079
00081   virtual void Resize(vtkIdType numTuples);
00082
00084   void SetNumberOfTuples(const vtkIdType number);
00085
00088   float *GetTuple(const vtkIdType i);
00089
00091
00092   void GetTuple(const vtkIdType i, float * tuple);
00093   void GetTuple(const vtkIdType i, double * tuple);
00095
00097
00098   void SetTuple(const vtkIdType i, const float * tuple);
00099   void SetTuple(const vtkIdType i, const double * tuple);
00101
00103
00105   void InsertTuple(const vtkIdType i, const float * tuple);
00106   void InsertTuple(const vtkIdType i, const double * tuple);
00108
00110
00112   vtkIdType InsertNextTuple(const float * tuple);
00113   vtkIdType InsertNextTuple(const double * tuple);
00115
00117
00118   int GetValue(const vtkIdType id)
00119     {return this->Array[id];}
00121
00123
00125   void SetValue(const vtkIdType id, const int value)
00126     {this->Array[id] = value;}
00128
00132   void SetNumberOfValues(const vtkIdType number);
00133
00135   void InsertValue(const vtkIdType id, const int i);
00136
00139   vtkIdType InsertNextValue(const int i);
00140
00144   float GetComponent(const vtkIdType i, const int j);
00145
00150   void SetComponent(const vtkIdType i, const int j, const float c);
00151
00155   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00156
00158
00160   int *GetPointer(const vtkIdType id)
00161     {return this->Array + id;}
00162   void *GetVoidPointer(const vtkIdType id)
00163     {return (void *)this->GetPointer(id);}
00165
00169   int *WritePointer(const vtkIdType id, const vtkIdType number);
00170
00172   void DeepCopy(vtkDataArray *ia);
00173
00175
00181   void SetArray(int* array, vtkIdType size, int save);
00182   void SetVoidArray(void *array,vtkIdType size, int save)
00183     {this->SetArray((int*)array, size, save);};
00185
00186 protected:
00187   vtkIntArray(vtkIdType numComp=1);
00188   ~vtkIntArray();
00189
00190   int *Array;   // pointer to data
00191   int *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00192
00193   int TupleSize; //used for data conversion
00194   float *Tuple;
00195
00196   int SaveUserArray;
00197 private:
00198   vtkIntArray(const vtkIntArray&);  // Not implemented.
00199   void operator=(const vtkIntArray&);  // Not implemented.
00200 };
00201
00202
00203 inline void vtkIntArray::SetNumberOfValues(const vtkIdType number)
00204 {
00205   this->Allocate(number);
00206   this->MaxId = number - 1;
00207 }
00208
00209 inline int *vtkIntArray::WritePointer(const vtkIdType id,
00210                                       const vtkIdType number)
00211 {
00212   vtkIdType newSize=id+number;
00213   if ( newSize > this->Size )
00214     {
00215     this->ResizeAndExtend(newSize);
00216     }
00217   if ( (--newSize) > this->MaxId )
00218     {
00219     this->MaxId = newSize;
00220     }
00221   return this->Array + id;
00222 }
00223
00224 inline void vtkIntArray::InsertValue(const vtkIdType id, const int i)
00225 {
00226   if ( id >= this->Size )
00227     {
00228     this->ResizeAndExtend(id+1);
00229     }
00230   this->Array[id] = i;
00231   if ( id > this->MaxId )
00232     {
00233     this->MaxId = id;
00234     }
00235 }
00236
00237 inline vtkIdType vtkIntArray::InsertNextValue(const int i)
00238 {
00239   this->InsertValue (++this->MaxId,i);
00240   return this->MaxId;
00241 }
00242
00243
00244 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyle.h Source File

Rendering/vtkInteractorStyle.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyle.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00097 #ifndef __vtkInteractorStyle_h
00098 #define __vtkInteractorStyle_h
00099
00100 #include "vtkRenderWindowInteractor.h"
00101
00102 // motion flags
00103 #define VTKIS_START   0
00104 #define VTKIS_ROTATE 1
00105 #define VTKIS_ZOOM   2
00106 #define VTKIS_PAN    3
00107 #define VTKIS_SPIN   4
00108 #define VTKIS_DOLLY  5
00109 #define VTKIS_USCALE 6
00110 #define VTKIS_TIMER  7
00111 #define VTKIS_ANIM_OFF 0
00112 #define VTKIS_ANIM_ON  1
00113
00114 class vtkPolyDataMapper;
00115 class vtkOutlineSource;
00116 class vtkCallbackCommand;
00117
00118
00119 class VTK_RENDERING_EXPORT vtkInteractorStyle : public vtkObject
00120 {
00121 public:
00125   static vtkInteractorStyle *New();
00126
00127   vtkTypeRevisionMacro(vtkInteractorStyle,vtkObject);
00128   void PrintSelf(ostream& os, vtkIndent indent);
00129
00131
00132   virtual void SetInteractor(vtkRenderWindowInteractor *interactor);
00133   vtkGetObjectMacro(Interactor, vtkRenderWindowInteractor);
00135
00137
00143   vtkSetClampMacro( AutoAdjustCameraClippingRange, int, 0, 1 );
00144   vtkGetMacro( AutoAdjustCameraClippingRange, int );
00145   vtkBooleanMacro( AutoAdjustCameraClippingRange, int );
00147
00149
00153   void FindPokedCamera(int,int);
00154   void FindPokedRenderer(int,int);
00156
00158
00162   virtual void HighlightProp(vtkProp *prop);
00163   virtual void HighlightActor2D(vtkActor2D *actor2D);
00164   virtual void HighlightProp3D(vtkProp3D *prop3D);
00166
00168
00170   vtkSetVector3Macro(PickColor,float);
00171   vtkGetVectorMacro(PickColor, float, 3);
00173
00175
00176   virtual void OnMouseMove  (int ctrl, int shift, int X, int Y);
00177   virtual void OnLeftButtonDown(int ctrl, int shift, int X, int Y);
00178   virtual void OnLeftButtonUp  (int ctrl, int shift, int X, int Y);
00179   virtual void OnMiddleButtonDown(int ctrl, int shift, int X, int Y);
00180   virtual void OnMiddleButtonUp  (int ctrl, int shift, int X, int Y);
00181   virtual void OnRightButtonDown(int ctrl, int shift, int X, int Y);
00182   virtual void OnRightButtonUp  (int ctrl, int shift, int X, int Y);
00184
00186
00188   virtual void OnChar   (int ctrl, int shift, char keycode, int repeatcount);
00189   virtual void OnKeyDown(int ctrl, int shift, char keycode, int repeatcount);
00190   virtual void OnKeyUp  (int ctrl, int shift, char keycode, int repeatcount);
00191   virtual void OnKeyPress(int ctrl, int shift, char keycode, char *keysym,
00192                           int repeatcount);
00193   virtual void OnKeyRelease(int ctrl, int shift, char keycode, char *keysym,
00194                             int repeatcount);
00196
00198
00199   virtual void OnConfigure(int width, int height);
00200   virtual void OnEnter(int ctrl, int shift, int x, int y);
00201   virtual void OnLeave(int ctrl, int shift, int x, int y);
00203
00206   virtual void OnTimer();
00207
00209
00210   void SetLeftButtonPressMethod(void (*f)(void *), void *arg);
00211   void SetLeftButtonPressMethodArgDelete(void (*f)(void *));
00212   void SetLeftButtonReleaseMethod(void (*f)(void *), void *arg);
00213   void SetLeftButtonReleaseMethodArgDelete(void (*f)(void *));
00214   void SetMiddleButtonPressMethod(void (*f)(void *), void *arg);
00215   void SetMiddleButtonPressMethodArgDelete(void (*f)(void *));
00216   void SetMiddleButtonReleaseMethod(void (*f)(void *), void *arg);
00217   void SetMiddleButtonReleaseMethodArgDelete(void (*f)(void *));
00218   void SetRightButtonPressMethod(void (*f)(void *), void *arg);
00219   void SetRightButtonPressMethodArgDelete(void (*f)(void *));
00220   void SetRightButtonReleaseMethod(void (*f)(void *), void *arg);
00221   void SetRightButtonReleaseMethodArgDelete(void (*f)(void *));
00223
00224 protected:
00225   vtkInteractorStyle();
00226   ~vtkInteractorStyle();
00227
00228   // does ProcessEvents handle observers on this class or not
00229   vtkSetMacro(HandleObservers,int);
00230   vtkGetMacro(HandleObservers,int);
00231   vtkBooleanMacro(HandleObservers,int);
00232   // Will the clipping range be automatically adjust before each render?
00233   int AutoAdjustCameraClippingRange;
00234   void ResetCameraClippingRange();
00235
00236   // convenience methods for converting between coordinate systems
00237   virtual void ComputeDisplayToWorld(double x, double y, double z,
00238                                      double *worldPt);
00239   virtual void ComputeWorldToDisplay(double x, double y, double z,
00240                                      double *displayPt);
00241   virtual void ComputeDisplayToWorld(double x, double y, double z,
00242                                      float *worldPt);
00243   virtual void ComputeWorldToDisplay(double x, double y, double z,
00244                                      float *displayPt);
00245
00246   virtual void UpdateInternalState(int ctrl, int shift, int X, int Y);
00247
00248   // These methods for the different interactions in different modes
00249   // are overridden in subclasses to perform the correct motion
00250   // This class provides a default implementation.
00251
00252   virtual void RotateCamera(int x, int y);
00253   virtual void SpinCamera(int x, int y);
00254   virtual void PanCamera(int x, int y);
00255   virtual void DollyCamera(int x, int y);
00256
00257   // utility routines used by state changes below
00258   virtual void StartState(int newstate);
00259   virtual void StopState();
00260
00261   // Interaction mode entry points used internally.
00262   virtual void StartAnimate();
00263   virtual void StopAnimate();
00264   virtual void StartRotate();
00265   virtual void EndRotate();
00266   virtual void StartZoom();
00267   virtual void EndZoom();
00268   virtual void StartPan();
00269   virtual void EndPan();
00270   virtual void StartSpin();
00271   virtual void EndSpin();
00272   virtual void StartDolly();
00273   virtual void EndDolly();
00274   virtual void StartUniformScale();
00275   virtual void EndUniformScale();
00276   virtual void StartTimer();
00277   virtual void EndTimer();
00278
00279   static void ProcessEvents(vtkObject* object, unsigned long event,
00280                             void* clientdata, void* calldata);
00281
00282   // Data we need to maintain internally
00283   vtkRenderWindowInteractor *Interactor;
00284   //
00285   vtkCamera          *CurrentCamera;
00286   vtkLight           *CurrentLight;
00287   vtkRenderer        *CurrentRenderer;
00288   //
00289   float Center[2];
00290   float DeltaAzimuth;
00291   float DeltaElevation;
00292   int   CtrlKey;
00293   int   ShiftKey;
00294   int   LastPos[2];
00295   int   State;
00296   int   AnimState;
00297   float FocalDepth;
00298
00299   // for picking and highlighting props
00300   vtkOutlineSource   *Outline;
00301   vtkPolyDataMapper  *OutlineMapper;
00302   vtkActor           *OutlineActor;
00303   vtkRenderer        *PickedRenderer;
00304   vtkProp            *CurrentProp;
00305   int                PropPicked;          // boolean: prop picked?
00306   float              PickColor[3];        // support 2D picking
00307   vtkActor2D         *PickedActor2D;
00308   vtkCallbackCommand* EventCallbackCommand;
00309   int                HandleObservers; // boolean: should observers be handled here
00310
00311   unsigned long LeftButtonPressTag;
00312   unsigned long LeftButtonReleaseTag;
00313   unsigned long MiddleButtonPressTag;
00314   unsigned long MiddleButtonReleaseTag;
00315   unsigned long RightButtonPressTag;
00316   unsigned long RightButtonReleaseTag;
00317 private:
00318   vtkInteractorStyle(const vtkInteractorStyle&);  // Not implemented.
00319   void operator=(const vtkInteractorStyle&);  // Not implemented.
00320 };
00321
00322 #endif
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleFlight.h Source File

Rendering/vtkInteractorStyleFlight.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleFlight.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00050 #ifndef __vtkInteractorStyleFlight_h
00051 #define __vtkInteractorStyleFlight_h
00052
00053 #include "vtkInteractorStyle.h"
00054
00055 class VTK_RENDERING_EXPORT vtkInteractorStyleFlight : public vtkInteractorStyle
00056 {
00057 public:
00058   static vtkInteractorStyleFlight *New();
00059   vtkTypeRevisionMacro(vtkInteractorStyleFlight,vtkInteractorStyle);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   virtual   void OnRightButtonDown (int ctrl, int shift, int X, int Y);
00065   virtual   void OnRightButtonUp   (int ctrl, int shift, int X, int Y);
00066   virtual   void OnMiddleButtonDown(int ctrl, int shift, int X, int Y);
00067   virtual   void OnMiddleButtonUp  (int ctrl, int shift, int X, int Y);
00068   virtual   void OnLeftButtonDown  (int ctrl, int shift, int X, int Y);
00069   virtual   void OnLeftButtonUp    (int ctrl, int shift, int X, int Y);
00070   virtual   void OnMouseMove       (int ctrl, int shift, int X, int Y);
00072
00074
00075   virtual void OnChar   (int ctrl, int shift, char keycode, int repeatcount);
00076   virtual void OnKeyDown(int ctrl, int shift, char keycode, int repeatcount);
00077   virtual void OnKeyUp  (int ctrl, int shift, char keycode, int repeatcount);
00079
00082   virtual void OnTimer(void);
00083
00086   void JumpTo(double campos[3], double focpos[3]);
00087
00092   void PerformAzimuthalScan(int numsteps);
00093
00095
00096   vtkSetMacro(MotionStepSize,double);
00097   vtkGetMacro(MotionStepSize,double);
00099
00101
00102   vtkSetMacro(MotionAccelerationFactor,double);
00103   vtkGetMacro(MotionAccelerationFactor,double);
00105
00107
00108   vtkSetMacro(AngleStepSize,double);
00109   vtkGetMacro(AngleStepSize,double);
00111
00113
00114   vtkSetMacro(AngleAccelerationFactor,double);
00115   vtkGetMacro(AngleAccelerationFactor,double);
00117
00119
00120   vtkSetMacro(DisableMotion,int);
00121   vtkGetMacro(DisableMotion,int);
00122   vtkBooleanMacro(DisableMotion,int);
00124
00126
00127   vtkSetMacro(FixUpVector,int);
00128   vtkGetMacro(FixUpVector,int);
00129   vtkBooleanMacro(FixUpVector,int);
00131
00132   // Specify fixed "up"
00133   vtkGetVectorMacro(FixedUpVector,double,3);
00134   vtkSetVectorMacro(FixedUpVector,double,3);
00135
00136 protected:
00137   vtkInteractorStyleFlight();
00138   ~vtkInteractorStyleFlight();
00139   //
00141   /*! Routines used internally for computing motion and steering */
00142   void DoTimerStart(void);
00143   void DoTimerStop(void);
00144   void UpdateMouseSteering(int x, int y);
00145   void FlyByMouse(void);
00146   void FlyByKey(void);
00147   void ComputeLRVector(double vector[3]);
00148   void MotionAlongVector(double vector[3], double amount);
00149   void SetupMotionVars(void);
00150   void AzimuthScan(void);
00151   //
00152   //
00153   unsigned char KeysDown;
00154   int           Flying;
00155   int           Reversing;
00156   int           TimerRunning;
00157   int           AzimuthScanning;
00158   int           DisableMotion;
00159   int           FixUpVector;
00160   double        OldX;
00161   double        OldY;
00162   double        X2;
00163   double        Y2;
00164   double        DiagonalLength;
00165   double        MotionStepSize;
00166   double        MotionUserScale;
00167   double        MotionAccelerationFactor;
00168   double        AngleStepSize;
00169   double        AngleAccelerationFactor;
00170   double        YawAngle;
00171   double        PitchAngle;
00172   double        FixedUpVector[3];
00173   double        AzimuthStepSize;
00175 private:
00176   vtkInteractorStyleFlight(const vtkInteractorStyleFlight&);  // Not implemented.
00177   void operator=(const vtkInteractorStyleFlight&);  // Not implemented.
00178 };
00179
00180 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleImage.h Source File

Rendering/vtkInteractorStyleImage.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleImage.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkInteractorStyleImage_h
00056 #define __vtkInteractorStyleImage_h
00057
00058 #include "vtkInteractorStyle.h"
00059
00060
00061 #define VTK_INTERACTOR_STYLE_IMAGE_NONE    0
00062 #define VTK_INTERACTOR_STYLE_IMAGE_WINDOW_LEVEL  1
00063 #define VTK_INTERACTOR_STYLE_IMAGE_PAN     2
00064 #define VTK_INTERACTOR_STYLE_IMAGE_ZOOM    3
00065 #define VTK_INTERACTOR_STYLE_IMAGE_SPIN    4
00066
00067 class VTK_RENDERING_EXPORT vtkInteractorStyleImage : public vtkInteractorStyle
00068 {
00069 public:
00070   static vtkInteractorStyleImage *New();
00071   vtkTypeRevisionMacro(vtkInteractorStyleImage, vtkInteractorStyle);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075
00077   void OnMouseMove  (int ctrl, int shift, int x, int y);
00078   void OnLeftButtonDown(int ctrl, int shift, int x, int y);
00079   void OnLeftButtonUp  (int ctrl, int shift, int x, int y);
00080   void OnMiddleButtonDown(int ctrl, int shift, int x, int y);
00081   void OnMiddleButtonUp  (int ctrl, int shift, int x, int y);
00082   void OnRightButtonDown(int ctrl, int shift, int x, int y);
00083   void OnRightButtonUp  (int ctrl, int shift, int x, int y);
00085
00087   void OnChar   (int ctrl, int shift, char keycode, int repeatcount);
00088
00090
00091   vtkGetVector2Macro(WindowLevelStartPosition,int);
00092   vtkGetVector2Macro(WindowLevelCurrentPosition,int);
00094
00095 protected:
00096   vtkInteractorStyleImage();
00097   ~vtkInteractorStyleImage();
00098
00099   void WindowLevelXY(int dx, int dy);
00100   void PanXY(int x, int y, int oldX, int oldY);
00101   void DollyXY(int dx, int dy);
00102   void SpinXY(int dx, int dy, int oldX, int oldY);
00103
00104   int WindowLevelStartPosition[2];
00105   int WindowLevelCurrentPosition[2];
00106   int State;
00107   float MotionFactor;
00108   float RadianToDegree; // constant: for conv from deg to rad
00109 private:
00110   vtkInteractorStyleImage(const vtkInteractorStyleImage&);  // Not implemented.
00111   void operator=(const vtkInteractorStyleImage&);  // Not implemented.
00112 };
00113
00114 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleJoystickActor.h Source File

Rendering/vtkInteractorStyleJoystickActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleJoystickActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkInteractorStyleJoystickActor_h
00044 #define __vtkInteractorStyleJoystickActor_h
00045
00046 #include "vtkInteractorStyle.h"
00047 #include "vtkCellPicker.h"
00048
00049
00050 #define VTK_INTERACTOR_STYLE_ACTOR_NONE    0
00051 #define VTK_INTERACTOR_STYLE_ACTOR_ROTATE  1
00052 #define VTK_INTERACTOR_STYLE_ACTOR_PAN     2
00053 #define VTK_INTERACTOR_STYLE_ACTOR_ZOOM    3
00054 #define VTK_INTERACTOR_STYLE_ACTOR_SPIN    4
00055 #define VTK_INTERACTOR_STYLE_ACTOR_SCALE   5
00056
00057 class VTK_RENDERING_EXPORT vtkInteractorStyleJoystickActor : public vtkInteractorStyle
00058 {
00059 public:
00060   static vtkInteractorStyleJoystickActor *New();
00061
00062   vtkTypeRevisionMacro(vtkInteractorStyleJoystickActor, vtkObject);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00068   void OnMouseMove  (int ctrl, int shift, int x, int y);
00069   void OnLeftButtonDown(int ctrl, int shift, int x, int y);
00070   void OnLeftButtonUp  (int ctrl, int shift, int x, int y);
00071   void OnMiddleButtonDown(int ctrl, int shift, int x, int y);
00072   void OnMiddleButtonUp  (int ctrl, int shift, int x, int y);
00073   void OnRightButtonDown(int ctrl, int shift, int x, int y);
00074   void OnRightButtonUp  (int ctrl, int shift, int x, int y);
00075   void OnTimer(void);
00077
00078 protected:
00079   vtkInteractorStyleJoystickActor();
00080   ~vtkInteractorStyleJoystickActor();
00081
00082   void RotateXY(int x, int y);
00083   void PanXY(int x, int y);
00084   void DollyXY(int x, int y);
00085   void SpinXY(int x, int y);
00086   void ScaleXY(int x, int y);
00087   void FindPickedActor(int x, int y);
00088   void Prop3DTransform(vtkProp3D *prop3D, double *boxCenter,
00089                       int numRotation, double **rotate,
00090                       double *scale);
00091   void Prop3DTransform(vtkProp3D *prop3D,float *boxCenter,
00092                       int NumRotation,double **rotate,
00093                       double *scale);
00094
00095   int State;
00096   float MotionFactor;
00097   float RadianToDegree;                 // constant: for conv from deg to rad
00098   vtkProp3D *InteractionProp;
00099   double ViewUp[3];
00100   double ViewLook[3];
00101   double ViewRight[3];
00102   float ObjCenter[3];
00103   float DispObjCenter[3];
00104   float Radius;
00105   float NewPickPoint[4];
00106   float OldPickPoint[4];
00107   float MotionVector[3];
00108   double ViewPoint[3];
00109   double ViewFocus[3];
00110 //  vtkAbstractPropPicker *InteractionPicker;
00111   vtkCellPicker *InteractionPicker;
00112 private:
00113   vtkInteractorStyleJoystickActor(const vtkInteractorStyleJoystickActor&);  // Not implemented.
00114   void operator=(const vtkInteractorStyleJoystickActor&);  // Not implemented.
00115 };
00116
00117 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleJoystickCamera.h Source File

Rendering/vtkInteractorStyleJoystickCamera.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleJoystickCamera.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkInteractorStyleJoystickCamera_h
00046 #define __vtkInteractorStyleJoystickCamera_h
00047
00048 #include "vtkInteractorStyle.h"
00049
00050
00051 #define VTK_INTERACTOR_STYLE_CAMERA_NONE    0
00052 #define VTK_INTERACTOR_STYLE_CAMERA_ROTATE  1
00053 #define VTK_INTERACTOR_STYLE_CAMERA_PAN     2
00054 #define VTK_INTERACTOR_STYLE_CAMERA_ZOOM    3
00055 #define VTK_INTERACTOR_STYLE_CAMERA_SPIN    4
00056
00057 class VTK_RENDERING_EXPORT vtkInteractorStyleJoystickCamera : public vtkInteractorStyle
00058 {
00059 public:
00060   static vtkInteractorStyleJoystickCamera *New();
00061   vtkTypeRevisionMacro(vtkInteractorStyleJoystickCamera, vtkObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065
00067   void OnMouseMove  (int ctrl, int shift, int x, int y);
00068   void OnLeftButtonDown(int ctrl, int shift, int x, int y);
00069   void OnLeftButtonUp  (int ctrl, int shift, int x, int y);
00070   void OnMiddleButtonDown(int ctrl, int shift, int x, int y);
00071   void OnMiddleButtonUp  (int ctrl, int shift, int x, int y);
00072   void OnRightButtonDown(int ctrl, int shift, int x, int y);
00073   void OnRightButtonUp  (int ctrl, int shift, int x, int y);
00074   void OnTimer(void);
00076
00077 protected:
00078   vtkInteractorStyleJoystickCamera();
00079   ~vtkInteractorStyleJoystickCamera();
00080
00081   int State;
00082   float MotionFactor;
00083 private:
00084   vtkInteractorStyleJoystickCamera(const vtkInteractorStyleJoystickCamera&);  // Not implemented.
00085   void operator=(const vtkInteractorStyleJoystickCamera&);  // Not implemented.
00086 };
00087
00088 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleSwitch.h Source File

Rendering/vtkInteractorStyleSwitch.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleSwitch.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkInteractorStyleSwitch_h
00043 #define __vtkInteractorStyleSwitch_h
00044
00045 #define VTKIS_JOYSTICK 0
00046 #define VTKIS_TRACKBALL 1
00047 #define VTKIS_CAMERA 0
00048 #define VTKIS_ACTOR 1
00049
00050 #include "vtkInteractorStyle.h"
00051 class vtkInteractorStyleJoystickActor;
00052 class vtkInteractorStyleJoystickCamera;
00053 class vtkInteractorStyleTrackballActor;
00054 class vtkInteractorStyleTrackballCamera;
00055
00056 class VTK_RENDERING_EXPORT vtkInteractorStyleSwitch : public vtkInteractorStyle
00057 {
00058 public:
00059   static vtkInteractorStyleSwitch *New();
00060   vtkTypeRevisionMacro(vtkInteractorStyleSwitch, vtkInteractorStyle);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00064   void OnChar   (int ctrl, int shift, char keycode, int repeatcount);
00065
00067   void SetInteractor(vtkRenderWindowInteractor *iren);
00068
00071   void SetAutoAdjustCameraClippingRange( int value );
00072
00073   vtkGetObjectMacro(CurrentStyle, vtkInteractorStyle);
00074 protected:
00075   vtkInteractorStyleSwitch();
00076   ~vtkInteractorStyleSwitch();
00077
00078   void SetCurrentStyle();
00079
00080   vtkInteractorStyleJoystickActor *JoystickActor;
00081   vtkInteractorStyleJoystickCamera *JoystickCamera;
00082   vtkInteractorStyleTrackballActor *TrackballActor;
00083   vtkInteractorStyleTrackballCamera *TrackballCamera;
00084   vtkInteractorStyle* CurrentStyle;
00085   int JoystickOrTrackball;
00086   int CameraOrActor;
00087 private:
00088   vtkInteractorStyleSwitch(const vtkInteractorStyleSwitch&);  // Not implemented.
00089   void operator=(const vtkInteractorStyleSwitch&);  // Not implemented.
00090 };
00091
00092 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleTrackball.h Source File

Rendering/vtkInteractorStyleTrackball.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleTrackball.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkInteractorStyleTrackball_h
00048 #define __vtkInteractorStyleTrackball_h
00049
00050 #include "vtkInteractorStyle.h"
00051 #include "vtkAbstractPropPicker.h"
00052
00053 #define VTKIS_JOY   0
00054 #define VTKIS_TRACK  1
00055 #define VTKIS_CAMERA 0
00056 #define VTKIS_ACTOR  1
00057 #define VTKIS_CONTROL_OFF 0
00058 #define VTKIS_CONTROL_ON 1
00059
00060 class VTK_RENDERING_EXPORT vtkInteractorStyleTrackball : public vtkInteractorStyle
00061 {
00062 public:
00063   static vtkInteractorStyleTrackball *New();
00064   vtkTypeRevisionMacro(vtkInteractorStyleTrackball,vtkInteractorStyle);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068
00069   virtual   void OnRightButtonDown(int ctrl, int shift, int X, int Y);
00070   virtual   void OnRightButtonUp  (int ctrl, int shift, int X, int Y);
00071   virtual   void OnMiddleButtonDown(int ctrl, int shift, int X, int Y);
00072   virtual   void OnMiddleButtonUp  (int ctrl, int shift, int X, int Y);
00073   virtual   void OnLeftButtonDown(int ctrl, int shift, int X, int Y);
00074   virtual   void OnLeftButtonUp  (int ctrl, int shift, int X, int Y);
00075   virtual   void OnChar(int ctrl, int shift, char keycode, int repeatcount);
00077
00079
00080   virtual void SetActorModeToCamera();
00081   virtual void SetActorModeToActor();
00082   vtkGetMacro(ActorMode, int);
00084
00086
00087   virtual void SetTrackballModeToTrackball();
00088   virtual void SetTrackballModeToJoystick();
00089   vtkGetMacro(TrackballMode, int);
00091
00094   virtual void OnTimer(void);
00095
00096 protected:
00097   vtkInteractorStyleTrackball();
00098   ~vtkInteractorStyleTrackball();
00099
00100   // used to track picked objects in actor mode
00101   // reason for existence: user may use any kind of picker.  Interactor
00102   //    need the high precision of cell picker at all time.
00103   vtkAbstractPropPicker *InteractionPicker;
00104   int PropPicked;                      // boolean: prop picked?
00105   vtkProp3D *InteractionProp;
00106
00107   // new interactor modes
00108   int ActorMode;
00109   int TrackballMode;
00110   int ControlMode;
00111   float MotionFactor;                // constant: for motion
00112   int Preprocess;                       // boolean: was preprocessing done?
00113   float RadianToDegree;                 // constant: for conv from deg to rad
00114
00115   // data arrays for motion
00116   float NewPickPoint[4];
00117   float OldPickPoint[4];
00118   float MotionVector[3];                // vector used for interaction
00119   float OldX;
00120   float OldY;
00121
00122   // this really belong in camera
00123   double ViewLook[3];
00124   double ViewPoint[3];
00125   double ViewFocus[3];
00126   double ViewUp[3];
00127   double ViewRight[3];
00128
00129   // actor stuff
00130   float Origin[3];
00131   float Position[3];
00132   float ObjCenter[3];                   // center of bounding box
00133   float DispObjCenter[3];               // center of box in display coord
00134   float Radius;                         // radius of virtual sphere
00135
00136   // methods for the different interactions in different modes
00137   virtual void TrackballRotateCamera(int x, int y);
00138   virtual void TrackballSpinCamera(int x, int y);
00139   virtual void TrackballPanCamera(int x, int y);
00140   virtual void TrackballDollyCamera(int x, int y);
00141
00142   virtual void JoystickRotateActor(int x, int y);
00143   virtual void JoystickSpinActor(int x, int y);
00144   virtual void JoystickPanActor(int x, int y);
00145   virtual void JoystickDollyActor(int x, int y);
00146   virtual void JoystickScaleActor(int x, int y);
00147
00148   virtual void TrackballRotateActor(int x, int y);
00149   virtual void TrackballSpinActor(int x, int y);
00150   virtual void TrackballPanActor(int x, int y);
00151   virtual void TrackballDollyActor(int x, int y);
00152   virtual void TrackballScaleActor(int x, int y);
00153
00154   void Prop3DTransform(vtkProp3D *prop3D, double *boxCenter,
00155                       int numRotation, double **rotate,
00156                       double *scale);
00157   void Prop3DTransform(vtkProp3D *prop3D,float *boxCenter,
00158                       int NumRotation,double **rotate,
00159                       double *scale);
00160   void FindPickedActor(int X, int Y);
00161 private:
00162   vtkInteractorStyleTrackball(const vtkInteractorStyleTrackball&);  // Not implemented.
00163   void operator=(const vtkInteractorStyleTrackball&);  // Not implemented.
00164 };
00165
00166 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleTrackballActor.h Source File

Rendering/vtkInteractorStyleTrackballActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleTrackballActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkInteractorStyleTrackballActor_h
00044 #define __vtkInteractorStyleTrackballActor_h
00045
00046 #include "vtkInteractorStyle.h"
00047 #include "vtkCellPicker.h"
00048
00049 #define VTK_INTERACTOR_STYLE_ACTOR_NONE    0
00050 #define VTK_INTERACTOR_STYLE_ACTOR_ROTATE  1
00051 #define VTK_INTERACTOR_STYLE_ACTOR_PAN     2
00052 #define VTK_INTERACTOR_STYLE_ACTOR_ZOOM    3
00053 #define VTK_INTERACTOR_STYLE_ACTOR_SPIN    4
00054 #define VTK_INTERACTOR_STYLE_ACTOR_SCALE   5
00055
00056 class VTK_RENDERING_EXPORT vtkInteractorStyleTrackballActor : public vtkInteractorStyle
00057 {
00058 public:
00059   static vtkInteractorStyleTrackballActor *New();
00060   vtkTypeRevisionMacro(vtkInteractorStyleTrackballActor, vtkObject);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00066   void OnMouseMove  (int ctrl, int shift, int x, int y);
00067   void OnLeftButtonDown(int ctrl, int shift, int x, int y);
00068   void OnLeftButtonUp  (int ctrl, int shift, int x, int y);
00069   void OnMiddleButtonDown(int ctrl, int shift, int x, int y);
00070   void OnMiddleButtonUp  (int ctrl, int shift, int x, int y);
00071   void OnRightButtonDown(int ctrl, int shift, int x, int y);
00072   void OnRightButtonUp  (int ctrl, int shift, int x, int y);
00074
00075 protected:
00076   vtkInteractorStyleTrackballActor();
00077   ~vtkInteractorStyleTrackballActor();
00078
00079   void RotateXY(int x, int y, int oldX, int oldY);
00080   void PanXY(int x, int y, int oldX, int oldY);
00081   void DollyXY(int dx, int dy);
00082   void SpinXY(int dx, int dy, int oldX, int oldY);
00083   void ScaleXY(int x, int y, int oldX, int oldY);
00084   void FindPickedActor(int x, int y);
00085   void Prop3DTransform(vtkProp3D *prop3D, double *boxCenter,
00086                       int numRotation, double **rotate,
00087                       double *scale);
00088   void Prop3DTransform(vtkProp3D *prop3D,float *boxCenter,
00089                       int NumRotation,double **rotate,
00090                       double *scale);
00091
00092   int State;
00093   float MotionFactor;
00094   float RadianToDegree;                 // constant: for conv from deg to rad
00095   vtkProp3D *InteractionProp;
00096   double ViewUp[3];
00097   double ViewLook[3];
00098   double ViewRight[3];
00099   float ObjCenter[3];
00100   float DispObjCenter[3];
00101   float Radius;
00102   float NewPickPoint[4];
00103   float OldPickPoint[4];
00104   float MotionVector[3];
00105   double ViewPoint[3];
00106   double ViewFocus[3];
00107 //  vtkAbstractPropPicker *InteractionPicker;
00108   vtkCellPicker *InteractionPicker;
00109 private:
00110   vtkInteractorStyleTrackballActor(const vtkInteractorStyleTrackballActor&);  // Not implemented.
00111   void operator=(const vtkInteractorStyleTrackballActor&);  // Not implemented.
00112 };
00113
00114 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleTrackballCamera.h Source File

Rendering/vtkInteractorStyleTrackballCamera.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleTrackballCamera.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkInteractorStyleTrackballCamera_h
00047 #define __vtkInteractorStyleTrackballCamera_h
00048
00049 #include "vtkInteractorStyle.h"
00050
00051
00052 #define VTK_INTERACTOR_STYLE_CAMERA_NONE    0
00053 #define VTK_INTERACTOR_STYLE_CAMERA_ROTATE  1
00054 #define VTK_INTERACTOR_STYLE_CAMERA_PAN     2
00055 #define VTK_INTERACTOR_STYLE_CAMERA_ZOOM    3
00056 #define VTK_INTERACTOR_STYLE_CAMERA_SPIN    4
00057
00058 class VTK_RENDERING_EXPORT vtkInteractorStyleTrackballCamera : public vtkInteractorStyle
00059 {
00060 public:
00061   static vtkInteractorStyleTrackballCamera *New();
00062   vtkTypeRevisionMacro(vtkInteractorStyleTrackballCamera, vtkObject);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00068   void OnMouseMove  (int ctrl, int shift, int x, int y);
00069   void OnLeftButtonDown(int ctrl, int shift, int x, int y);
00070   void OnLeftButtonUp  (int ctrl, int shift, int x, int y);
00071   void OnMiddleButtonDown(int ctrl, int shift, int x, int y);
00072   void OnMiddleButtonUp  (int ctrl, int shift, int x, int y);
00073   void OnRightButtonDown(int ctrl, int shift, int x, int y);
00074   void OnRightButtonUp  (int ctrl, int shift, int x, int y);
00076
00077 protected:
00078   vtkInteractorStyleTrackballCamera();
00079   ~vtkInteractorStyleTrackballCamera();
00080
00081   void RotateXY(int dx, int dy);
00082   void PanXY(int x, int y, int oldX, int oldY);
00083   void DollyXY(int dx, int dy);
00084   void SpinXY(int dx, int dy, int oldX, int oldY);
00085
00086   int State;
00087   float MotionFactor;
00088   float RadianToDegree;                 // constant: for conv from deg to rad
00089 private:
00090   vtkInteractorStyleTrackballCamera(const vtkInteractorStyleTrackballCamera&);  // Not implemented.
00091   void operator=(const vtkInteractorStyleTrackballCamera&);  // Not implemented.
00092 };
00093
00094 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleUnicam.h Source File

Rendering/vtkInteractorStyleUnicam.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleUnicam.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00017 /*
00018  * This work (vtkInteractorStyleUnicam.h) was produced under a grant from
00019  * the Department of Energy to Brown University.  Neither Brown University
00020  * nor the authors assert any copyright with respect to this work and it may
00021  * be used, reproduced, and distributed without permission.
00022  */
00023
00089 #ifndef __vtkInteractorStyleUnicam_h
00090 #define __vtkInteractorStyleUnicam_h
00091
00092 #include "vtkInteractorStyle.h"
00093 #include "vtkRenderer.h"
00094 class vtkWorldPointPicker;
00095
00096 // define 'TheTime()' function-- returns time in elapsed seconds
00097 #if defined(_WIN32) || defined(WIN32)
00098 #include <winbase.h>
00099
00100 inline double TheTime()
00101   {return double(GetTickCount())/1000.0;}
00102 #else
00103 #include <sys/time.h>
00104
00105 inline double TheTime()
00106 {
00107   struct timeval ts; struct timezone tz;
00108   gettimeofday(&ts, &tz);
00109   return (double)(ts.tv_sec + ts.tv_usec/1e6);
00110 }
00111 #endif
00112
00113
00114 //
00115 // XXX - would have preferred to make these enumerations within the class,
00116 //    enum { NONE=0, BUTTON_LEFT, BUTTON_MIDDLE, BUTTON_RIGHT };
00117 //    enum {CAM_INT_ROT, CAM_INT_CHOOSE, CAM_INT_PAN, CAM_INT_DOLLY};
00118 // but vtkWrapTcl signaled a "syntax error" when it parsed the 'enum' line.
00119 // So, am making them defines which is what the other classes that want
00120 // to have constants appear to do.
00121 //
00122 // buttons pressed
00123 #define VTK_UNICAM_NONE           0
00124 #define VTK_UNICAM_BUTTON_LEFT    1
00125 #define VTK_UNICAM_BUTTON_MIDDLE  2
00126 #define VTK_UNICAM_BUTTON_RIGHT   3
00127 //
00128 // camera modes
00129 #define VTK_UNICAM_CAM_INT_ROT    0
00130 #define VTK_UNICAM_CAM_INT_CHOOSE 1
00131 #define VTK_UNICAM_CAM_INT_PAN    2
00132 #define VTK_UNICAM_CAM_INT_DOLLY  3
00133
00134 class VTK_RENDERING_EXPORT vtkInteractorStyleUnicam : public vtkInteractorStyle
00135 {
00136 public:
00137   static vtkInteractorStyleUnicam *New();
00138   vtkTypeRevisionMacro(vtkInteractorStyleUnicam,vtkInteractorStyle);
00139   void PrintSelf(ostream& os, vtkIndent indent);
00140
00142
00143   virtual   void OnLeftButtonDown(int ctrl, int shift, int X, int Y);
00144   virtual   void OnLeftButtonUp  (int ctrl, int shift, int X, int Y);
00145   virtual   void OnMouseMove(int ctrl, int shift, int X, int Y);
00147
00148   virtual   void OnLeftButtonMove  (int ctrl, int shift, int X, int Y);
00149   virtual   void OnMiddleButtonMove(int , int , int , int) {}
00150   virtual   void OnRightButtonMove (int , int , int , int) {}
00151
00154   virtual void OnTimer(void);
00155
00156   void SetWorldUpVector(double a[3]) {this->SetWorldUpVector(a[0],a[1],a[2]);}
00157   void SetWorldUpVector(float  a[3]) {this->SetWorldUpVector(a[0],a[1],a[2]);}
00158   void SetWorldUpVector(float x, float y, float z);
00159   vtkGetVectorMacro(WorldUpVector, float, 3);
00160
00161 protected:
00162   vtkInteractorStyleUnicam();
00163   virtual ~vtkInteractorStyleUnicam();
00164
00165   vtkWorldPointPicker *InteractionPicker;
00166
00167   int      ButtonDown;   // which button is down
00168   double   DTime;        // time mouse button was pressed
00169   double   Dist;         // distance the mouse has moved since button press
00170   float    StartPix[2]; // pixel mouse movement started at
00171   float    LastPos[2];  // normalized position of mouse last frame
00172   float    LastPix[2];  // pixel position of mouse last frame
00173   float    DownPt[3];   // 3D point under cursor when mouse button pressed
00174   float    Center [3];   // center of camera rotation
00175
00176   float    WorldUpVector[3]; // what the world thinks the 'up' vector is
00177
00178   vtkActor    *FocusSphere; // geometry for indicating center of rotation
00179   int          IsDot;       // flag-- is the FocusSphere being displayed?
00180   vtkRenderer *FocusSphereRenderer;  // renderer for 'FocusSphere'
00181
00182   int state;                 // which navigation mode was selected?
00183
00184   void Choose( int X, int Y );  // method for choosing type of navigation
00185   void Rotate( int X, int Y );  // method for rotating
00186   void Dolly ( int X, int Y );  // method for dollying
00187   void Pan   ( int X, int Y );  // method for panning
00188
00189   // conveinence methods for translating & rotating the camera
00190   void  MyTranslateCamera(float v[3]);
00191   void  MyRotateCamera(float cx, float cy, float cz,
00192                        float ax, float ay, float az,
00193                        float angle);
00194
00195   // Given a 3D point & a vtkCamera, compute the vectors that extend
00196   // from the projection of the center of projection to the center of
00197   // the right-edge and the center of the top-edge onto the plane
00198   // containing the 3D point & with normal parallel to the camera's
00199   // projection plane.
00200   void  GetRightVandUpV(float *p, vtkCamera *cam,
00201                         float *rightV, float *upV);
00202
00203   // takes in pixels, returns normalized window coordinates
00204   void  NormalizeMouseXY(int X, int Y, float *NX, float *NY);
00205
00206   // return the aspect ratio of the current window
00207   float WindowAspect();
00208 private:
00209   vtkInteractorStyleUnicam(const vtkInteractorStyleUnicam&);  // Not implemented.
00210   void operator=(const vtkInteractorStyleUnicam&);  // Not implemented.
00211 };
00212
00213 #endif  // __vtkInteractorStyleUnicam_h
00214
00215
00216
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkInteractorStyleUser.h Source File

Rendering/vtkInteractorStyleUser.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInteractorStyleUser.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00046 #ifndef __vtkInteractorStyleUser_h
00047 #define __vtkInteractorStyleUser_h
00048
00049 #include "vtkInteractorStyleSwitch.h"
00050
00051 // new motion flag
00052 #define VTKIS_USERINTERACTION 8
00053
00054 class VTK_RENDERING_EXPORT vtkInteractorStyleUser : public vtkInteractorStyleSwitch
00055 {
00056 public:
00057   static vtkInteractorStyleUser *New();
00058   vtkTypeRevisionMacro(vtkInteractorStyleUser,vtkInteractorStyleSwitch);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00069   void SetMouseMoveMethod(void (*f)(void *), void *arg);
00070   void SetMouseMoveMethodArgDelete(void (*f)(void *));
00072
00074
00078   void SetButtonPressMethod(void (*f)(void *), void *arg);
00079   void SetButtonPressMethodArgDelete(void (*f)(void *));
00081
00083
00088   void SetButtonReleaseMethod(void (*f)(void *), void *arg);
00089   void SetButtonReleaseMethodArgDelete(void (*f)(void *));
00091
00093
00097   void SetKeyPressMethod(void (*f)(void *), void *arg);
00098   void SetKeyPressMethodArgDelete(void (*f)(void *));
00100
00102
00105   void SetKeyReleaseMethod(void (*f)(void *), void *arg);
00106   void SetKeyReleaseMethodArgDelete(void (*f)(void *));
00108
00110
00114   void SetCharMethod(void (*f)(void *), void *arg);
00115   void SetCharMethodArgDelete(void (*f)(void *));
00117
00119
00123   void SetConfigureMethod(void (*f)(void *), void *arg);
00124   void SetConfigureMethodArgDelete(void (*f)(void *));
00126
00128
00131   void SetEnterMethod(void (*f)(void *), void *arg);
00132   void SetEnterMethodArgDelete(void (*f)(void *));
00133   void SetLeaveMethod(void (*f)(void *), void *arg);
00134   void SetLeaveMethodArgDelete(void (*f)(void *));
00136
00138
00142   void SetTimerMethod(void (*f)(void *), void *arg);
00143   void SetTimerMethodArgDelete(void (*f)(void *));
00145
00147
00151   vtkGetVector2Macro(LastPos,int);
00153
00155
00158   vtkGetVector2Macro(OldPos,int);
00160
00162
00164   vtkGetMacro(ShiftKey,int);
00165   vtkGetMacro(CtrlKey,int);
00167
00169
00170   vtkGetMacro(Char,int);
00172
00174
00176   vtkGetStringMacro(KeySym);
00178
00180
00182   vtkGetMacro(Button,int);
00184
00186
00189   void SetUserInteractionMethod(void (*f)(void *), void *arg);
00190   void SetUserInteractionMethodArgDelete(void (*f)(void *));
00192
00194
00197   void StartUserInteraction();
00198   void EndUserInteraction();
00200
00201 protected:
00202   vtkInteractorStyleUser();
00203   ~vtkInteractorStyleUser();
00204
00205   void OnChar(int ctrl, int shift, char keycode, int repeatcount);
00206   void OnKeyPress(int ctrl, int shift, char keycode, char *keysym,
00207                   int repeatcount);
00208   void OnKeyRelease(int ctrl, int shift, char keycode, char *keysym,
00209                     int repeatcount);
00210
00211   void OnLeftButtonDown(int ctrl, int shift, int X, int Y);
00212   void OnLeftButtonUp(int ctrl, int shift, int X, int Y);
00213   void OnMiddleButtonDown(int ctrl, int shift, int X, int Y);
00214   void OnMiddleButtonUp(int ctrl, int shift, int X, int Y);
00215   void OnRightButtonDown(int ctrl, int shift, int X, int Y);
00216   void OnRightButtonUp(int ctrl, int shift, int X, int Y);
00217
00218   void OnMouseMove(int ctrl, int shift, int X, int Y);
00219
00220   void OnConfigure(int width, int height);
00221
00222   void OnEnter(int ctrl, int shift, int X, int Y);
00223   void OnLeave(int ctrl, int shift, int X, int Y);
00224
00225   void OnTimer(void);
00226
00227   int OldPos[2];
00228
00229   int Char;
00230   char *KeySym;
00231   int Button;
00232
00233   unsigned long MouseMoveTag;
00234   unsigned long KeyPressTag;
00235   unsigned long KeyReleaseTag;
00236   unsigned long CharTag;
00237   unsigned long EnterTag;
00238   unsigned long LeaveTag;
00239   unsigned long ConfigureTag;
00240   unsigned long TimerTag;
00241   unsigned long UserTag;
00242
00243   void vtkSetOldCallback(unsigned long &tag, unsigned long event,
00244                          void (*f)(void *), void *arg);
00245   void vtkSetOldDelete(unsigned long tag, void (*f)(void *));
00246 private:
00247   vtkInteractorStyleUser(const vtkInteractorStyleUser&);  // Not implemented.
00248   void operator=(const vtkInteractorStyleUser&);  // Not implemented.
00249 };
00250
00251 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkInterpolateDataSetAttributes.h Source File

Graphics/vtkInterpolateDataSetAttributes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInterpolateDataSetAttributes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkInterpolateDataSetAttributes_h
00047 #define __vtkInterpolateDataSetAttributes_h
00048
00049 #include "vtkDataSetToDataSetFilter.h"
00050 #include "vtkDataSetCollection.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkInterpolateDataSetAttributes : public vtkDataSetToDataSetFilter
00053 {
00054 public:
00055   static vtkInterpolateDataSetAttributes *New();
00056   vtkTypeRevisionMacro(vtkInterpolateDataSetAttributes,vtkDataSetToDataSetFilter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   void AddInput(vtkDataSet *in);
00061
00063   vtkDataSetCollection *GetInputList();
00064
00066
00067   vtkSetClampMacro(T,float,0.0,VTK_LARGE_FLOAT);
00068   vtkGetMacro(T,float);
00070
00071 protected:
00072   vtkInterpolateDataSetAttributes();
00073   ~vtkInterpolateDataSetAttributes();
00074
00075   void Execute();
00076
00077   vtkDataSetCollection *InputList; // list of data sets to interpolate
00078   float T; // interpolation parameter
00079
00080 private:
00081   // hide the superclass' AddInput() from the user and the compiler
00082   void AddInput(vtkDataObject *)
00083     { vtkErrorMacro( << "AddInput() must be called with a vtkDataSet not a vtkDataObject."); };
00084   void RemoveInput(vtkDataObject *input)
00085     { this->vtkProcessObject::RemoveInput(input); };
00086 private:
00087   vtkInterpolateDataSetAttributes(const vtkInterpolateDataSetAttributes&);  // Not implemented.
00088   void operator=(const vtkInterpolateDataSetAttributes&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkInterpolatedVelocityField.h Source File

Common/vtkInterpolatedVelocityField.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInterpolatedVelocityField.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkInterpolatedVelocityField_h
00051 #define __vtkInterpolatedVelocityField_h
00052
00053 #include "vtkFunctionSet.h"
00054 #include "vtkDataSet.h"
00055 #include "vtkGenericCell.h"
00056
00057 class VTK_COMMON_EXPORT vtkInterpolatedVelocityField : public vtkFunctionSet
00058 {
00059 public:
00060   vtkTypeRevisionMacro(vtkInterpolatedVelocityField,vtkFunctionSet);
00061   virtual void PrintSelf(ostream& os, vtkIndent indent);
00062
00065   static vtkInterpolatedVelocityField *New();
00066
00069   virtual int FunctionValues(float* x, float* f);
00070
00072
00073   virtual void SetDataSet(vtkDataSet* dataset);
00074   vtkGetObjectMacro(DataSet,vtkDataSet);
00076
00078
00079   vtkGetMacro(LastCellId, vtkIdType);
00080   vtkSetMacro(LastCellId, vtkIdType);
00082
00085   void ClearLastCellId() { this->LastCellId = -1; }
00086
00088
00091   int GetLastWeights(float* w);
00092   int GetLastLocalCoordinates(float pcoords[3]);
00094
00096
00097   vtkGetMacro(Caching, int);
00098   vtkSetMacro(Caching, int);
00099   vtkBooleanMacro(Caching, int);
00101
00103
00104   vtkGetMacro(CacheHit, int);
00105   vtkGetMacro(CacheMiss, int);
00107
00108 protected:
00109   vtkInterpolatedVelocityField();
00110   ~vtkInterpolatedVelocityField();
00111
00112   vtkDataSet* DataSet;
00113   vtkGenericCell* GenCell; // last cell
00114   vtkGenericCell* Cell;
00115   float* Weights; // last weights
00116   float LastPCoords[3]; // last local coordinates
00117   vtkIdType LastCellId;
00118   int CacheHit;
00119   int CacheMiss;
00120   int Caching;
00121 private:
00122   vtkInterpolatedVelocityField(const vtkInterpolatedVelocityField&);  // Not implemented.
00123   void operator=(const vtkInterpolatedVelocityField&);  // Not implemented.
00124 };
00125
00126 #endif
00127
00128
00129
00130
00131
00132
00133
00134
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkInterpolatingSubdivisionFilter.h Source File

Graphics/vtkInterpolatingSubdivisionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkInterpolatingSubdivisionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkInterpolatingSubdivisionFilter_h
00034 #define __vtkInterpolatingSubdivisionFilter_h
00035
00036 #include "vtkPolyDataToPolyDataFilter.h"
00037
00038 class vtkIntArray;
00039 class vtkIdList;
00040 class vtkCellArray;
00041
00042 class VTK_GRAPHICS_EXPORT vtkInterpolatingSubdivisionFilter : public vtkPolyDataToPolyDataFilter
00043 {
00044 public:
00045   vtkTypeRevisionMacro(vtkInterpolatingSubdivisionFilter,vtkPolyDataToPolyDataFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00050   vtkSetMacro(NumberOfSubdivisions,int);
00051   vtkGetMacro(NumberOfSubdivisions,int);
00053
00054 protected:
00055   vtkInterpolatingSubdivisionFilter();
00056   ~vtkInterpolatingSubdivisionFilter() {};
00057
00058   void Execute();
00059   virtual void GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD) = 0;
00060   void GenerateSubdivisionCells (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkCellArray *outputPolys, vtkCellData *outputCD);
00061   int FindEdge (vtkPolyData *mesh, vtkIdType cellId, vtkIdType p1,
00062                 vtkIdType p2, vtkIntArray *edgeData, vtkIdList *cellIds);
00063   vtkIdType InterpolatePosition (vtkPoints *inputPts, vtkPoints *outputPts,
00064                                  vtkIdList *stencil, float *weights);
00065   int NumberOfSubdivisions;
00066 private:
00067   vtkInterpolatingSubdivisionFilter(const vtkInterpolatingSubdivisionFilter&);  // Not implemented.
00068   void operator=(const vtkInterpolatingSubdivisionFilter&);  // Not implemented.
00069 };
00070
00071 #endif
00072
00073
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkIterativeClosestPointTransform.h Source File

Hybrid/vtkIterativeClosestPointTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIterativeClosestPointTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00051 #ifndef __vtkIterativeClosestPointTransform_h
00052 #define __vtkIterativeClosestPointTransform_h
00053
00054 #include "vtkLinearTransform.h"
00055
00056 #define VTK_ICP_MODE_RMS 0
00057 #define VTK_ICP_MODE_AV 1
00058
00059 class vtkCellLocator;
00060 class vtkLandmarkTransform;
00061 class vtkDataSet;
00062
00063 class VTK_HYBRID_EXPORT vtkIterativeClosestPointTransform : public vtkLinearTransform
00064 {
00065 public:
00066   static vtkIterativeClosestPointTransform *New();
00067   vtkTypeRevisionMacro(vtkIterativeClosestPointTransform,vtkLinearTransform);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00071
00072   void SetSource(vtkDataSet *source);
00073   void SetTarget(vtkDataSet *target);
00074   vtkGetObjectMacro(Source, vtkDataSet);
00075   vtkGetObjectMacro(Target, vtkDataSet);
00077
00079
00081   void SetLocator(vtkCellLocator *locator);
00082   vtkGetObjectMacro(Locator,vtkCellLocator);
00084
00086
00087   vtkSetMacro(MaximumNumberOfIterations, int);
00088   vtkGetMacro(MaximumNumberOfIterations, int);
00090
00092
00093   vtkGetMacro(NumberOfIterations, int);
00095
00097
00098   vtkSetMacro(CheckMeanDistance, int);
00099   vtkGetMacro(CheckMeanDistance, int);
00100   vtkBooleanMacro(CheckMeanDistance, int);
00102
00104
00109   vtkSetClampMacro(MeanDistanceMode,int,
00110                    VTK_ICP_MODE_RMS,VTK_ICP_MODE_AV);
00111   vtkGetMacro(MeanDistanceMode,int);
00112   void SetMeanDistanceModeToRMS()
00113     {this->SetMeanDistanceMode(VTK_ICP_MODE_RMS);}
00114   void SetMeanDistanceModeToAbsoluteValue()
00115     {this->SetMeanDistanceMode(VTK_ICP_MODE_AV);}
00116   const char *GetMeanDistanceModeAsString();
00118
00120
00122   vtkSetMacro(MaximumMeanDistance, float);
00123   vtkGetMacro(MaximumMeanDistance, float);
00125
00127
00128   vtkGetMacro(MeanDistance, float);
00130
00132
00135   vtkSetMacro(MaximumNumberOfLandmarks, int);
00136   vtkGetMacro(MaximumNumberOfLandmarks, int);
00138
00140
00141   vtkSetMacro(StartByMatchingCentroids, int);
00142   vtkGetMacro(StartByMatchingCentroids, int);
00143   vtkBooleanMacro(StartByMatchingCentroids, int);
00145
00147
00150   vtkGetObjectMacro(LandmarkTransform,vtkLandmarkTransform);
00152
00155   void Inverse();
00156
00158   vtkAbstractTransform *MakeTransform();
00159
00160 protected:
00161
00163
00164   void ReleaseSource(void);
00165   void ReleaseTarget(void);
00167
00169   void ReleaseLocator(void);
00170
00172   void CreateDefaultLocator(void);
00173
00175   unsigned long int GetMTime();
00176
00177   vtkIterativeClosestPointTransform();
00178   ~vtkIterativeClosestPointTransform();
00179
00180   void InternalUpdate();
00181
00183   void InternalDeepCopy(vtkAbstractTransform *transform);
00184
00185   vtkDataSet* Source;
00186   vtkDataSet* Target;
00187   vtkCellLocator *Locator;
00188   int MaximumNumberOfIterations;
00189   int CheckMeanDistance;
00190   int MeanDistanceMode;
00191   float MaximumMeanDistance;
00192   int MaximumNumberOfLandmarks;
00193   int StartByMatchingCentroids;
00194
00195   int NumberOfIterations;
00196   float MeanDistance;
00197   vtkLandmarkTransform *LandmarkTransform;
00198 private:
00199   vtkIterativeClosestPointTransform(const vtkIterativeClosestPointTransform&);  // Not implemented.
00200   void operator=(const vtkIterativeClosestPointTransform&);  // Not implemented.
00201 };
00202
00203 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkIVExporter.h Source File

Rendering/vtkIVExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIVExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkIVExporter_h
00040 #define __vtkIVExporter_h
00041
00042 #include <stdio.h>
00043 #include "vtkExporter.h"
00044
00045 class VTK_RENDERING_EXPORT vtkIVExporter : public vtkExporter
00046 {
00047 public:
00048   static vtkIVExporter *New();
00049   vtkTypeRevisionMacro(vtkIVExporter,vtkExporter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetStringMacro(FileName);
00055   vtkGetStringMacro(FileName);
00057
00058 protected:
00059   vtkIVExporter();
00060   ~vtkIVExporter();
00061
00062   void WriteData();
00063   void WriteALight(vtkLight *aLight, FILE *fp);
00064   void WriteAnActor(vtkActor *anActor, FILE *fp);
00065   void WritePointData(vtkPoints *points, vtkDataArray *normals,
00066                       vtkDataArray *tcoords, vtkUnsignedCharArray *colors,
00067                       FILE *fp);
00068   char *FileName;
00069 private:
00070   vtkIVExporter(const vtkIVExporter&);  // Not implemented.
00071   void operator=(const vtkIVExporter&);  // Not implemented.
00072 };
00073
00074 #endif
00075
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkIVWriter.h Source File

IO/vtkIVWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkIVWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkIVWriter_h
00042 #define __vtkIVWriter_h
00043
00044 #include "vtkPolyDataWriter.h"
00045
00046 class VTK_IO_EXPORT vtkIVWriter : public vtkPolyDataWriter
00047 {
00048 public:
00049   static vtkIVWriter *New();
00050   vtkTypeRevisionMacro(vtkIVWriter,vtkPolyDataWriter);
00051
00052 protected:
00053   vtkIVWriter() {};
00054   ~vtkIVWriter() {};
00055
00056   void WriteData();
00057   void WritePolyData(vtkPolyData *polyData, FILE *fp);
00058 private:
00059   vtkIVWriter(const vtkIVWriter&);  // Not implemented.
00060   void operator=(const vtkIVWriter&);  // Not implemented.
00061 };
00062
00063 #endif
00064
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkJavaAwt.h Source File

Common/vtkJavaAwt.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkJavaAwt.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 // for use with JAWT
00017 #include "jawt_md.h"
00018
00019 extern "C" JNIEXPORT void  JNICALL
00020     Java_vtkPanel_RenderCreate(JNIEnv *env, jobject canvas, jobject id0)
00021 {
00022   JAWT awt;
00023   JAWT_DrawingSurface* ds;
00024   JAWT_DrawingSurfaceInfo* dsi;
00025   jint lock;
00026
00027   // get the render window pointer
00028   vtkRenderWindow *temp0;
00029   temp0 = (vtkRenderWindow *)(vtkJavaGetPointerFromObject(env,id0,(char *) "vtkRenderWindow"));
00030
00031   /* Get the AWT */
00032   awt.version = JAWT_VERSION_1_3;
00033   if (JAWT_GetAWT(env, &awt) == JNI_FALSE)
00034     {
00035     printf("AWT Not found\n");
00036     return;
00037     }
00038
00039   /* Get the drawing surface */
00040   ds = awt.GetDrawingSurface(env, canvas);
00041   if (ds == NULL)
00042     {
00043     printf("NULL drawing surface\n");
00044     return;
00045     }
00046
00047   /* Lock the drawing surface */
00048   lock = ds->Lock(ds);
00049   if((lock & JAWT_LOCK_ERROR) != 0)
00050     {
00051     printf("Error locking surface\n");
00052     awt.FreeDrawingSurface(ds);
00053     return;
00054     }
00055
00056   /* Get the drawing surface info */
00057   dsi = ds->GetDrawingSurfaceInfo(ds);
00058   if (dsi == NULL)
00059     {
00060     printf("Error getting surface info\n");
00061     ds->Unlock(ds);
00062     awt.FreeDrawingSurface(ds);
00063     return;
00064     }
00065
00066 // Here is the win32 drawing code
00067 #if defined(_WIN32) || defined(WIN32)
00068   JAWT_Win32DrawingSurfaceInfo* dsi_win;
00069   dsi_win = (JAWT_Win32DrawingSurfaceInfo*)dsi->platformInfo;
00070   temp0->SetWindowId((void *)dsi_win->hwnd);
00071
00072 // otherwise use X11 code
00073 #else
00074   JAWT_X11DrawingSurfaceInfo* dsi_x11;
00075   dsi_x11 = (JAWT_X11DrawingSurfaceInfo*)dsi->platformInfo;
00076   temp0->SetDisplayId((void *)dsi_x11->display);
00077   temp0->SetWindowId((void *)dsi_x11->drawable);
00078 #endif
00079
00080   temp0->Render();
00081
00082   /* Free the drawing surface info */
00083   ds->FreeDrawingSurfaceInfo(dsi);
00084
00085   /* Unlock the drawing surface */
00086   ds->Unlock(ds);
00087
00088   /* Free the drawing surface */
00089   awt.FreeDrawingSurface(ds);
00090 }
00091
00092
00093 // Lock must be called prior to render or anything which might
00094 // cause vtkRenderWindow to make an XLib call or to call Render().
00095 // The Lock() and UnLock() functions are necessary for drawing in
00096 // JAWT, but they also provide a form of mutex locking so that multiple
00097 // java threads are prevented from accessing X at the same time.  The only
00098 // requirement JAWT has is that all operations on a JAWT_DrawingSurface
00099 // MUST be performed from the same thread as the call to GetDrawingSurface.
00100 extern "C" JNIEXPORT void  JNICALL
00101     Java_vtkPanel_Lock(JNIEnv *env,
00102                        jobject canvas)
00103 {
00104   JAWT awt;
00105   JAWT_DrawingSurface* ds;
00106   jint lock;
00107
00108   /* Get the AWT */
00109   awt.version = JAWT_VERSION_1_3;
00110   if (JAWT_GetAWT(env, &awt) == JNI_FALSE)
00111       {
00112           printf("AWT Not found\n");
00113           return;
00114       }
00115
00116   /* Get the drawing surface */
00117   ds = awt.GetDrawingSurface(env, canvas);
00118   if (ds == NULL)
00119       {
00120           printf("NULL drawing surface\n");
00121           return;
00122       }
00123
00124   /* Lock the drawing surface */
00125   lock = ds->Lock(ds);
00126   if((lock & JAWT_LOCK_ERROR) != 0)
00127     {
00128     printf("Error locking surface\n");
00129     awt.FreeDrawingSurface(ds);
00130     return;
00131     }
00132
00133 }
00134
00135 // UnLock() must be called after a Lock() and execution of a
00136 // function which might change the drawing surface.  See Lock().
00137 extern "C" JNIEXPORT void  JNICALL
00138     Java_vtkPanel_UnLock(JNIEnv *env,
00139                          jobject canvas)
00140 {
00141   JAWT awt;
00142   JAWT_DrawingSurface* ds;
00143
00144   /* Get the AWT */
00145   awt.version = JAWT_VERSION_1_3;
00146   if (JAWT_GetAWT(env, &awt) == JNI_FALSE)
00147       {
00148           printf("AWT Not found\n");
00149           return;
00150       }
00151
00152   /* Get the drawing surface */
00153   ds = awt.GetDrawingSurface(env, canvas);
00154   if (ds == NULL)
00155       {
00156           printf("NULL drawing surface\n");
00157           return;
00158       }
00159
00160   /* Unlock the drawing surface */
00161   ds->Unlock(ds);
00162
00163   /* Free the drawing surface */
00164   awt.FreeDrawingSurface(ds);
00165 }
00166
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkJavaUtil.h Source File

Common/vtkJavaUtil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkJavaUtil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00017 #ifndef __vtkJavaUtil_h
00018 #define __vtkJavaUtil_h
00019
00020 #include "vtkSystemIncludes.h"
00021 #include <jni.h>
00022 #include "vtkCommand.h"
00023
00024
00025 extern JNIEXPORT int vtkJavaGetId(JNIEnv *env,jobject obj);
00026
00027 extern JNIEXPORT int vtkJavaRegisterNewObject(JNIEnv *env, jobject obj, void *ptr);
00028 extern JNIEXPORT void vtkJavaRegisterCastFunction(JNIEnv *env, jobject obj, int id, void *tcFunc);
00029
00030 extern JNIEXPORT void *vtkJavaGetPointerFromObject(JNIEnv *env,jobject obj,
00031            char *result_type);
00032 extern JNIEXPORT void vtkJavaDeleteObject(JNIEnv *env, jobject obj);
00033 extern JNIEXPORT jobject vtkJavaGetObjectFromPointer(void *ptr);
00034 extern JNIEXPORT char *vtkJavaUTFToChar(JNIEnv *env, jstring in);
00035 extern JNIEXPORT jstring vtkJavaMakeJavaString(JNIEnv *env, const char *in);
00036
00037 extern JNIEXPORT jarray vtkJavaMakeJArrayOfDoubleFromFloat(JNIEnv *env,
00038              float *arr, int size);
00039 extern JNIEXPORT jarray vtkJavaMakeJArrayOfDoubleFromDouble(JNIEnv *env,
00040               double *arr, int size);
00041 extern JNIEXPORT jarray vtkJavaMakeJArrayOfIntFromInt(JNIEnv *env, int *arr, int size);
00042 extern JNIEXPORT jarray vtkJavaMakeJArrayOfByteFromUnsignedChar(JNIEnv *env, unsigned char *arr, int size);
00043
00044 extern JNIEXPORT jobject vtkJavaCreateNewJavaStubForObject(JNIEnv *env, vtkObject* obj);
00045 extern JNIEXPORT jobject vtkJavaCreateNewJavaStub(JNIEnv *env,
00046               const char* fullclassname, void* obj);
00047
00048 // this is the void pointer parameter passed to the vtk callback routines on
00049 // behalf of the Java interface for callbacks.
00050 struct vtkJavaVoidFuncArg
00051 {
00052   JavaVM *vm;
00053   jobject  uobj;
00054   jmethodID mid;
00055 } ;
00056
00057 extern JNIEXPORT void vtkJavaVoidFunc(void *);
00058 extern JNIEXPORT void vtkJavaVoidFuncArgDelete(void *);
00059
00060 class vtkJavaCommand : public vtkCommand
00061 {
00062 public:
00063   static vtkJavaCommand *New() { return new vtkJavaCommand; };
00064
00065   void SetGlobalRef(jobject obj) { this->uobj = obj; };
00066   void SetMethodID(jmethodID id) { this->mid = id; };
00067   void AssignJavaVM(JNIEnv *env) { env->GetJavaVM(&(this->vm)); };
00068
00069   void Execute(vtkObject *, unsigned long, void *);
00070
00071   JavaVM *vm;
00072   jobject  uobj;
00073   jmethodID mid;
00074 protected:
00075   vtkJavaCommand();
00076   ~vtkJavaCommand();
00077 };
00078
00079 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkJPEGReader.h Source File

IO/vtkJPEGReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkJPEGReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkJPEGReader_h
00041 #define __vtkJPEGReader_h
00042
00043 #include <stdio.h>
00044 #include "vtkImageReader2.h"
00045
00046 class VTK_IO_EXPORT vtkJPEGReader : public vtkImageReader2
00047 {
00048 public:
00049   static vtkJPEGReader *New();
00050   vtkTypeRevisionMacro(vtkJPEGReader,vtkImageReader2);
00051
00052   virtual vtkImageReader2* MakeObject() { return vtkJPEGReader::New(); }
00053
00055   int CanReadFile(const char* fname);
00056
00058
00060   virtual const char* GetFileExensions()
00061     {
00062       return ".jpeg .jpg";
00063     }
00065
00067
00069   virtual const char* GetDescriptiveName()
00070     {
00071       return "JPEG";
00072     }
00074 protected:
00075   vtkJPEGReader() {};
00076   ~vtkJPEGReader() {};
00077
00078   virtual void ExecuteInformation();
00079   virtual void ExecuteData(vtkDataObject *out);
00080 private:
00081   vtkJPEGReader(const vtkJPEGReader&);  // Not implemented.
00082   void operator=(const vtkJPEGReader&);  // Not implemented.
00083 };
00084 #endif
00085
00086
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkJPEGWriter.h Source File

IO/vtkJPEGWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkJPEGWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkJPEGWriter_h
00040 #define __vtkJPEGWriter_h
00041
00042 #include "vtkImageWriter.h"
00043
00044 class VTK_IO_EXPORT vtkJPEGWriter : public vtkImageWriter
00045 {
00046 public:
00047   static vtkJPEGWriter *New();
00048   vtkTypeRevisionMacro(vtkJPEGWriter,vtkImageWriter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052   virtual void Write();
00053
00055
00056   vtkSetClampMacro(Quality, int, 0, 100);
00057   vtkGetMacro(Quality, int);
00059
00061
00062   vtkSetMacro(Progressive, unsigned int);
00063   vtkGetMacro(Progressive, unsigned int);
00064   vtkBooleanMacro(Progressive, unsigned int);
00066
00067 protected:
00068   vtkJPEGWriter();
00069   ~vtkJPEGWriter() {};
00070
00071   void WriteSlice(vtkImageData *data);
00072
00073 private:
00074   int Quality;
00075   unsigned int Progressive;
00076
00077 private:
00078   vtkJPEGWriter(const vtkJPEGWriter&);  // Not implemented.
00079   void operator=(const vtkJPEGWriter&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkKitwareContourFilter.h Source File

Patented/vtkKitwareContourFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkKitwareContourFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00070 #ifndef __vtkKitwareContourFilter_h
00071 #define __vtkKitwareContourFilter_h
00072
00073 #include "vtkContourFilter.h"
00074
00075 class VTK_PATENTED_EXPORT vtkKitwareContourFilter : public vtkContourFilter
00076 {
00077 public:
00078   vtkTypeRevisionMacro(vtkKitwareContourFilter,vtkContourFilter);
00079
00082   static vtkKitwareContourFilter *New();
00083
00084 protected:
00085   vtkKitwareContourFilter();
00086   ~vtkKitwareContourFilter();
00087
00088   void ComputeInputUpdateExtents(vtkDataObject *data);
00089   void Execute();
00090   void ExecuteInformation();
00091
00092   //special contouring for structured points
00093   void StructuredPointsContour(int dim);
00094   //special contouring for structured grid
00095   void StructuredGridContour(int dim);
00096   //default if not structured data
00097   void DataSetContour();
00098 private:
00099   vtkKitwareContourFilter(const vtkKitwareContourFilter&);  // Not implemented.
00100   void operator=(const vtkKitwareContourFilter&);  // Not implemented.
00101 };
00102
00103 #endif
00104
00105
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkKitwareObjectFactory.h Source File

Patented/vtkKitwareObjectFactory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkKitwareObjectFactory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkKitwareObjectFactory_h
00039 #define __vtkKitwareObjectFactory_h
00040
00041 #include "vtkObjectFactory.h"
00042
00043 class VTK_PATENTED_EXPORT vtkKitwareObjectFactory : public vtkObjectFactory
00044 {
00045 public:
00046   static vtkKitwareObjectFactory *New() {return new vtkKitwareObjectFactory;};
00047   vtkTypeRevisionMacro(vtkKitwareObjectFactory,vtkObjectFactory);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049   virtual const char* GetVTKSourceVersion();
00050 protected:
00051   vtkKitwareObjectFactory() {};
00052   virtual vtkObject* CreateObject(const char* vtkclassname );
00053 private:
00054   vtkKitwareObjectFactory(const vtkKitwareObjectFactory&);  // Not implemented.
00055   void operator=(const vtkKitwareObjectFactory&);  // Not implemented.
00056 };
00057
00058 extern "C" VTK_PATENTED_EXPORT vtkObjectFactory* vtkLoad();
00059 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkKochanekSpline.h Source File

Filtering/vtkKochanekSpline.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkKochanekSpline.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00060 #ifndef __vtkKochanekSpline_h
00061 #define __vtkKochanekSpline_h
00062
00063 #include <stdio.h>
00064 #include "vtkSpline.h"
00065
00066 class VTK_FILTERING_EXPORT vtkKochanekSpline : public vtkSpline
00067 {
00068 public:
00069   vtkTypeRevisionMacro(vtkKochanekSpline,vtkSpline);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00074   static vtkKochanekSpline *New();
00075
00077   void Compute ();
00078
00080   float Evaluate (float t);
00081
00083
00084   vtkSetMacro(DefaultBias,float);
00085   vtkGetMacro(DefaultBias,float);
00087
00089
00090   vtkSetMacro(DefaultTension,float);
00091   vtkGetMacro(DefaultTension,float);
00093
00095
00096   vtkSetMacro(DefaultContinuity,float);
00097   vtkGetMacro(DefaultContinuity,float);
00099
00100 protected:
00101   vtkKochanekSpline();
00102   ~vtkKochanekSpline() {};
00103
00104   void Fit1D (int n, float *x, float *y,
00105               float tension, float bias, float continuity,
00106               float coefficients[][4],
00107               int leftConstraint, float leftValue, int rightConstraint, float rightValue);
00108   float DefaultBias;
00109   float DefaultTension;
00110   float DefaultContinuity;
00111 private:
00112   vtkKochanekSpline(const vtkKochanekSpline&);  // Not implemented.
00113   void operator=(const vtkKochanekSpline&);  // Not implemented.
00114 };
00115
00116 #endif
00117
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLabeledDataMapper.h Source File

Rendering/vtkLabeledDataMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLabeledDataMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00065 #ifndef __vtkLabeledDataMapper_h
00066 #define __vtkLabeledDataMapper_h
00067
00068 #include "vtkMapper2D.h"
00069 #include "vtkTextMapper.h"
00070 #include "vtkDataSet.h"
00071
00072 #define VTK_LABEL_IDS        0
00073 #define VTK_LABEL_SCALARS    1
00074 #define VTK_LABEL_VECTORS    2
00075 #define VTK_LABEL_NORMALS    3
00076 #define VTK_LABEL_TCOORDS    4
00077 #define VTK_LABEL_TENSORS    5
00078 #define VTK_LABEL_FIELD_DATA 6
00079
00080 class VTK_RENDERING_EXPORT vtkLabeledDataMapper : public vtkMapper2D
00081 {
00082 public:
00086   static vtkLabeledDataMapper *New();
00087
00088   vtkTypeRevisionMacro(vtkLabeledDataMapper,vtkMapper2D);
00089   void PrintSelf(ostream& os, vtkIndent indent);
00090
00092
00093   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00094   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor);
00096
00098
00099   vtkSetObjectMacro(Input, vtkDataSet);
00100   vtkGetObjectMacro(Input, vtkDataSet);
00102
00106   virtual void ReleaseGraphicsResources(vtkWindow *);
00107
00109
00113   vtkSetMacro(LabelMode, int);
00114   vtkGetMacro(LabelMode, int);
00115   void SetLabelModeToLabelIds() {this->SetLabelMode(VTK_LABEL_IDS);};
00116   void SetLabelModeToLabelScalars() {this->SetLabelMode(VTK_LABEL_SCALARS);};
00117   void SetLabelModeToLabelVectors() {this->SetLabelMode(VTK_LABEL_VECTORS);};
00118   void SetLabelModeToLabelNormals() {this->SetLabelMode(VTK_LABEL_NORMALS);};
00119   void SetLabelModeToLabelTCoords() {this->SetLabelMode(VTK_LABEL_TCOORDS);};
00120   void SetLabelModeToLabelTensors() {this->SetLabelMode(VTK_LABEL_TENSORS);};
00121   void SetLabelModeToLabelFieldData()
00122             {this->SetLabelMode(VTK_LABEL_FIELD_DATA);};
00124
00126
00129   vtkSetClampMacro(FontSize,int,0,VTK_LARGE_INTEGER);
00130   vtkGetMacro(FontSize,int);
00132
00134
00135   vtkSetMacro(Bold, int);
00136   vtkGetMacro(Bold, int);
00137   vtkBooleanMacro(Bold, int);
00139
00141
00142   vtkSetMacro(Italic, int);
00143   vtkGetMacro(Italic, int);
00144   vtkBooleanMacro(Italic, int);
00146
00148
00150   vtkSetMacro(Shadow, int);
00151   vtkGetMacro(Shadow, int);
00152   vtkBooleanMacro(Shadow, int);
00154
00156
00159   vtkSetMacro(FontFamily, int);
00160   vtkGetMacro(FontFamily, int);
00161   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00162   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00163   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00165
00167
00173   vtkSetStringMacro(LabelFormat);
00174   vtkGetStringMacro(LabelFormat);
00176
00178
00183   vtkSetMacro(LabeledComponent,int);
00184   vtkGetMacro(LabeledComponent,int);
00186
00188
00190   vtkSetClampMacro(FieldDataArray,int,0,VTK_LARGE_INTEGER);
00191   vtkGetMacro(FieldDataArray,int);
00193
00194 protected:
00195   vtkLabeledDataMapper();
00196   ~vtkLabeledDataMapper();
00197
00198   vtkDataSet *Input;
00199   int LabelMode;
00200
00201   int   FontSize;
00202   int   Bold;
00203   int   Italic;
00204   int   Shadow;
00205   int   FontFamily;
00206
00207   char  *LabelFormat;
00208   int   LabeledComponent;
00209   int   FieldDataArray;
00210
00211   vtkTimeStamp BuildTime;
00212
00213 private:
00214   int NumberOfLabels;
00215   int NumberOfLabelsAllocated;
00216   vtkTextMapper **TextMappers;
00217
00218 private:
00219   vtkLabeledDataMapper(const vtkLabeledDataMapper&);  // Not implemented.
00220   void operator=(const vtkLabeledDataMapper&);  // Not implemented.
00221 };
00222
00223 #endif
00224
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkLandmarkTransform.h Source File

Hybrid/vtkLandmarkTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLandmarkTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkLandmarkTransform_h
00043 #define __vtkLandmarkTransform_h
00044
00045 #include "vtkLinearTransform.h"
00046 #include "vtkMutexLock.h"
00047
00048 #define VTK_LANDMARK_RIGIDBODY 6
00049 #define VTK_LANDMARK_SIMILARITY 7
00050 #define VTK_LANDMARK_AFFINE 12
00051
00052 class VTK_HYBRID_EXPORT vtkLandmarkTransform : public vtkLinearTransform
00053 {
00054 public:
00055   static vtkLandmarkTransform *New();
00056
00057   vtkTypeRevisionMacro(vtkLandmarkTransform,vtkLinearTransform);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00065   void SetSourceLandmarks(vtkPoints *points);
00066   void SetTargetLandmarks(vtkPoints *points);
00067   vtkGetObjectMacro(SourceLandmarks, vtkPoints);
00068   vtkGetObjectMacro(TargetLandmarks, vtkPoints);
00070
00072
00075   vtkSetMacro(Mode,int);
00076   void SetModeToRigidBody() { this->SetMode(VTK_LANDMARK_RIGIDBODY); };
00077   void SetModeToSimilarity() { this->SetMode(VTK_LANDMARK_SIMILARITY); };
00078   void SetModeToAffine() { this->SetMode(VTK_LANDMARK_AFFINE); };
00079   vtkGetMacro(Mode,int);
00080   const char *GetModeAsString();
00082
00085   void Inverse();
00086
00088   unsigned long GetMTime();
00089
00091   vtkAbstractTransform *MakeTransform();
00092
00093 protected:
00094   vtkLandmarkTransform();
00095   ~vtkLandmarkTransform();
00096
00097   // Update the matrix from the quaternion.
00098   void InternalUpdate();
00099
00101   void InternalDeepCopy(vtkAbstractTransform *transform);
00102
00103   vtkPoints* SourceLandmarks;
00104   vtkPoints* TargetLandmarks;
00105
00106   int Mode;
00107 private:
00108   vtkLandmarkTransform(const vtkLandmarkTransform&);  // Not implemented.
00109   void operator=(const vtkLandmarkTransform&);  // Not implemented.
00110 };
00111
00112 //BTX
00113 inline const char *vtkLandmarkTransform::GetModeAsString()
00114 {
00115   switch (this->Mode)
00116     {
00117     case VTK_LANDMARK_RIGIDBODY:
00118       return "RigidBody";
00119     case VTK_LANDMARK_SIMILARITY:
00120       return "Similarity";
00121     case VTK_LANDMARK_AFFINE:
00122       return "Affine";
00123     default:
00124       return "Unrecognized";
00125     }
00126 }
00127 //ETX
00128 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLargeInteger.h Source File

Common/vtkLargeInteger.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLargeInteger.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00029 #ifndef __vtkLargeInteger_h
00030 #define __vtkLargeInteger_h
00031
00032 #include "vtkObject.h"
00033
00034 class VTK_COMMON_EXPORT vtkLargeInteger
00035 {
00036 public:
00037   vtkLargeInteger(void);
00038   vtkLargeInteger(long n);
00039   vtkLargeInteger(unsigned long n);
00040   vtkLargeInteger(int n);
00041   vtkLargeInteger(unsigned int n);
00042   vtkLargeInteger(const vtkLargeInteger& n);
00043   ~vtkLargeInteger(void);
00044
00045   char CastToChar(void) const;
00046   short CastToShort(void) const;
00047   int CastToInt(void) const;
00048   long CastToLong(void) const;
00049   unsigned long CastToUnsignedLong(void) const;
00050
00051   int IsEven(void) const;
00052   int IsOdd(void) const;
00053   int GetLength(void) const; // in bits
00054   int GetBit(unsigned int p) const; // p'th bit (from zero)
00055   int IsZero() const; // is zero
00056   int GetSign(void) const; // is negative
00057
00058   void Truncate(unsigned int n); // reduce to lower n bits
00059   void Complement(void); // * -1
00060
00061   int operator==(const vtkLargeInteger& n) const;
00062   int operator!=(const vtkLargeInteger& n) const;
00063   int operator<(const vtkLargeInteger& n) const;
00064   int operator<=(const vtkLargeInteger& n) const;
00065   int operator>(const vtkLargeInteger& n) const;
00066   int operator>=(const vtkLargeInteger& n) const;
00067
00068   vtkLargeInteger& operator=(const vtkLargeInteger& n);
00069   vtkLargeInteger& operator+=(const vtkLargeInteger& n);
00070   vtkLargeInteger& operator-=(const vtkLargeInteger& n);
00071   vtkLargeInteger& operator<<=(int n);
00072   vtkLargeInteger& operator>>=(int n);
00073   vtkLargeInteger& operator++(void);
00074   vtkLargeInteger& operator--(void);
00075   vtkLargeInteger  operator++(int);
00076   vtkLargeInteger  operator--(int);
00077   vtkLargeInteger& operator*=(const vtkLargeInteger& n);
00078   vtkLargeInteger& operator/=(const vtkLargeInteger& n);
00079   vtkLargeInteger& operator%=(const vtkLargeInteger& n);
00080   // no change of sign for following operators
00081   vtkLargeInteger& operator&=(const vtkLargeInteger& n);
00082   vtkLargeInteger& operator|=(const vtkLargeInteger& n);
00083   vtkLargeInteger& operator^=(const vtkLargeInteger& n);
00084
00085   vtkLargeInteger operator+(const vtkLargeInteger& n) const;
00086   vtkLargeInteger operator-(const vtkLargeInteger& n) const;
00087   vtkLargeInteger operator*(const vtkLargeInteger& n) const;
00088   vtkLargeInteger operator/(const vtkLargeInteger& n) const;
00089   vtkLargeInteger operator%(const vtkLargeInteger& n) const;
00090   // no change of sign for following operators
00091   vtkLargeInteger operator&(const vtkLargeInteger& n) const;
00092   vtkLargeInteger operator|(const vtkLargeInteger& n) const;
00093   vtkLargeInteger operator^(const vtkLargeInteger& n) const;
00094   vtkLargeInteger operator<<(int n) const;
00095   vtkLargeInteger operator>>(int n) const;
00096
00097   friend ostream& operator<<(ostream& s, const vtkLargeInteger& n);
00098   friend istream& operator>>(istream& s, vtkLargeInteger& n);
00099
00100 private:
00101   char* Number;
00102   int Negative;
00103   unsigned int Sig;
00104   unsigned int Max;
00105
00106   // unsigned operators
00107   int IsSmaller(const vtkLargeInteger& n) const; // unsigned
00108   int IsGreater(const vtkLargeInteger& n) const; // unsigned
00109   void Expand(unsigned int n); // ensure n'th bit exits
00110   void Contract(); // remove leading 0s
00111   void Plus(const vtkLargeInteger& n); // unsigned
00112   void Minus(const vtkLargeInteger& n); // unsigned
00113 };
00114
00115 #endif
00116
00117
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkLegendBoxActor.h Source File

Hybrid/vtkLegendBoxActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLegendBoxActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkLegendBoxActor_h
00047 #define __vtkLegendBoxActor_h
00048
00049 #include "vtkActor2D.h"
00050 #include "vtkTextMapper.h"
00051
00052 class vtkActor;
00053 class vtkPolyData;
00054 class vtkPolyDataMapper;
00055 class vtkPolyDataMapper2D;
00056 class vtkTransformPolyDataFilter;
00057 class vtkTransform;
00058
00059 class VTK_HYBRID_EXPORT vtkLegendBoxActor : public vtkActor2D
00060 {
00061 public:
00062   vtkTypeRevisionMacro(vtkLegendBoxActor,vtkActor2D);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00067   static vtkLegendBoxActor *New();
00068
00070
00071   void SetNumberOfEntries(int num);
00072   int GetNumberOfEntries()
00073     {return this->NumberOfEntries;}
00075
00077
00085   void SetEntry(int i, vtkPolyData *symbol, const char* string, float color[3]);
00086   void SetEntrySymbol(int i, vtkPolyData *symbol);
00087   void SetEntryString(int i, const char* string);
00088   void SetEntryColor(int i, float color[3]);
00089   void SetEntryColor(int i, float r, float g, float b);
00090   vtkPolyData *GetEntrySymbol(int i);
00091   const char* GetEntryString(int i);
00092   float *GetEntryColor(int i);
00094
00096
00097   vtkSetMacro(Bold, int);
00098   vtkGetMacro(Bold, int);
00099   vtkBooleanMacro(Bold, int);
00101
00103
00104   vtkSetMacro(Italic, int);
00105   vtkGetMacro(Italic, int);
00106   vtkBooleanMacro(Italic, int);
00108
00110
00112   vtkSetMacro(Shadow, int);
00113   vtkGetMacro(Shadow, int);
00114   vtkBooleanMacro(Shadow, int);
00116
00118
00121   vtkSetMacro(FontFamily, int);
00122   vtkGetMacro(FontFamily, int);
00123   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00124   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00125   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00127
00129
00131   vtkSetMacro(Border, int);
00132   vtkGetMacro(Border, int);
00133   vtkBooleanMacro(Border, int);
00135
00137
00143   vtkSetMacro(LockBorder, int);
00144   vtkGetMacro(LockBorder, int);
00145   vtkBooleanMacro(LockBorder, int);
00147
00149
00151   vtkSetClampMacro(Padding, int, 0, 50);
00152   vtkGetMacro(Padding, int);
00154
00156
00159   vtkSetMacro(ScalarVisibility,int);
00160   vtkGetMacro(ScalarVisibility,int);
00161   vtkBooleanMacro(ScalarVisibility,int);
00163
00166   void ShallowCopy(vtkProp *prop);
00167
00168 //BTX
00173   virtual void ReleaseGraphicsResources(vtkWindow *);
00174
00176
00179   int RenderOpaqueGeometry(vtkViewport* viewport);
00180   int RenderTranslucentGeometry(vtkViewport* ) {return 0;};
00181   int RenderOverlay(vtkViewport* viewport);
00183 //ETX
00184
00185 protected:
00186   vtkLegendBoxActor();
00187   ~vtkLegendBoxActor();
00188
00189   void InitializeEntries();
00190
00191   int   Bold;
00192   int   Italic;
00193   int   Shadow;
00194   int   FontFamily;
00195   int   Border;
00196   int   Padding;
00197   int   LockBorder;
00198   int   ScalarVisibility;
00199
00200   // Internal actors, mappers, data to represent the legend
00201   int                        NumberOfEntries;
00202   int                        Size; //allocation size
00203   vtkFloatArray              *Colors;
00204   vtkTextMapper              **TextMapper;
00205   vtkActor2D                 **TextActor;
00206   vtkPolyData                **Symbol;
00207   vtkTransform               **Transform;
00208   vtkTransformPolyDataFilter **SymbolTransform;
00209   vtkPolyDataMapper2D        **SymbolMapper;
00210   vtkActor2D                 **SymbolActor;
00211   vtkPolyData                *BorderPolyData;
00212   vtkPolyDataMapper2D        *BorderMapper;
00213   vtkActor2D                 *BorderActor;
00214
00215   // Used to control whether the stuff is recomputed
00216   int           LegendEntriesVisible;
00217   int           CachedSize[2];
00218   vtkTimeStamp  BuildTime;
00219
00220 private:
00221   vtkLegendBoxActor(const vtkLegendBoxActor&);  // Not implemented.
00222   void operator=(const vtkLegendBoxActor&);  // Not implemented.
00223 };
00224
00225
00226 #endif
00227
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLight.h Source File

Rendering/vtkLight.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLight.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkLight_h
00059 #define __vtkLight_h
00060
00061 #include "vtkObject.h"
00062 #include "vtkMatrix4x4.h"
00063
00064 /* need for virtual function */
00065 class vtkRenderer;
00066
00067 #define VTK_LIGHT_TYPE_HEADLIGHT    1
00068 #define VTK_LIGHT_TYPE_CAMERA_LIGHT 2
00069 #define VTK_LIGHT_TYPE_SCENE_LIGHT  3
00070
00071 class VTK_RENDERING_EXPORT vtkLight : public vtkObject
00072 {
00073 public:
00074   vtkTypeRevisionMacro(vtkLight,vtkObject);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00080   static vtkLight *New();
00081
00086   virtual void Render(vtkRenderer *, int) {};
00087
00089
00090   vtkSetVector3Macro(Color,float);
00091   vtkGetVectorMacro(Color,float,3);
00093
00095
00099   vtkSetVector3Macro(Position,float);
00100   vtkGetVectorMacro(Position,float,3);
00101   void SetPosition(double *a) {this->SetPosition(a[0],a[1],a[2]);};
00103
00105
00110   vtkSetVector3Macro(FocalPoint,float);
00111   vtkGetVectorMacro(FocalPoint,float,3);
00112   void SetFocalPoint(double *a) {this->SetFocalPoint(a[0],a[1],a[2]);};
00114
00116
00117   vtkSetMacro(Intensity,float);
00118   vtkGetMacro(Intensity,float);
00120
00122
00123   vtkSetMacro(Switch,int);
00124   vtkGetMacro(Switch,int);
00125   vtkBooleanMacro(Switch,int);
00127
00129
00130   vtkSetMacro(Positional,int);
00131   vtkGetMacro(Positional,int);
00132   vtkBooleanMacro(Positional,int);
00134
00136
00137   vtkSetMacro(Exponent,float);
00138   vtkGetMacro(Exponent,float);
00140
00142
00145   vtkSetMacro(ConeAngle,float);
00146   vtkGetMacro(ConeAngle,float);
00148
00150
00152   vtkSetVector3Macro(AttenuationValues,float);
00153   vtkGetVectorMacro(AttenuationValues,float,3);
00155
00157
00160   vtkSetObjectMacro(TransformMatrix,vtkMatrix4x4);
00161   vtkGetObjectMacro(TransformMatrix,vtkMatrix4x4);
00163
00165
00167   void GetTransformedPosition(float &a0, float &a1, float &a2);
00168   void GetTransformedPosition(float a[3]);
00169   float *GetTransformedPosition();
00171
00173
00175   void GetTransformedFocalPoint(float &a0, float &a1, float &a2);
00176   void GetTransformedFocalPoint(float a[3]);
00177   float *GetTransformedFocalPoint();
00179
00181
00185   void SetDirectionAngle(float elevation, float azimuth);
00186   void SetDirectionAngle(float ang[2]) { this->SetDirectionAngle(ang[0], ang[1]); };
00188
00190   void DeepCopy(vtkLight *light);
00191
00202   vtkSetMacro(LightType, int);
00203   vtkGetMacro(LightType, int);
00204
00205   void SetLightTypeToHeadlight();
00206   void SetLightTypeToSceneLight();
00207   void SetLightTypeToCameraLight();
00208
00210
00211   int LightTypeIsHeadlight();
00212   int LightTypeIsSceneLight();
00213   int LightTypeIsCameraLight();
00215
00216   void ReadSelf(istream& is);
00217   void WriteSelf(ostream& os);
00218
00219 protected:
00220   vtkLight();
00221   ~vtkLight();
00222
00223   float FocalPoint[3];
00224   float Position[3];
00225   float Intensity;
00226   float Color[3];
00227   int   Switch;
00228   int   Positional;
00229   float Exponent;
00230   float ConeAngle;
00231   float AttenuationValues[3];
00232   vtkMatrix4x4 *TransformMatrix;
00233   float TransformedFocalPointReturn[3];
00234   float TransformedPositionReturn[3];
00235   int LightType;
00236 private:
00237   vtkLight(const vtkLight&);  // Not implemented.
00238   void operator=(const vtkLight&);  // Not implemented.
00239 };
00240
00241 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLightCollection.h Source File

Rendering/vtkLightCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLightCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkLightC_h
00041 #define __vtkLightC_h
00042
00043 #include "vtkCollection.h"
00044 #include "vtkLight.h"
00045
00046 class VTK_RENDERING_EXPORT vtkLightCollection : public vtkCollection
00047 {
00048  public:
00049   static vtkLightCollection *New();
00050   vtkTypeRevisionMacro(vtkLightCollection,vtkCollection);
00051
00053   void AddItem(vtkLight *a);
00054
00057   vtkLight *GetNextItem();
00058
00059 protected:
00060   vtkLightCollection() {};
00061   ~vtkLightCollection() {};
00062
00063
00064 private:
00065   // hide the standard AddItem from the user and the compiler.
00066   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00067
00068 private:
00069   vtkLightCollection(const vtkLightCollection&);  // Not implemented.
00070   void operator=(const vtkLightCollection&);  // Not implemented.
00071 };
00072
00073
00074 #endif
00075
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLightKit.h Source File

Rendering/vtkLightKit.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLightKit.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00098 #ifndef __vtkLightKit_h
00099 #define __vtkLightKit_h
00100
00101 #include "vtkObject.h"
00102 class vtkLight;
00103 class vtkPiecewiseFunction;
00104 class vtkRenderer;
00105
00106 class VTK_RENDERING_EXPORT vtkLightKit : public vtkObject
00107 {
00108 public:
00109   static vtkLightKit *New();
00110   vtkTypeRevisionMacro(vtkLightKit, vtkObject);
00111   void PrintSelf(ostream& os, vtkIndent indent);
00112
00114
00117   vtkSetMacro(KeyLightIntensity, float);
00118   vtkGetMacro(KeyLightIntensity, float);
00120
00122
00130   vtkSetClampMacro(KeyToFillRatio, float, 0.5, VTK_FLOAT_MAX);
00131   vtkGetMacro(KeyToFillRatio, float);
00133
00135
00144   vtkSetClampMacro(KeyToHeadRatio, float, 0.5, VTK_FLOAT_MAX);
00145   vtkGetMacro(KeyToHeadRatio, float);
00147
00149
00158   vtkSetMacro(KeyLightWarmth, float);
00159   vtkGetMacro(KeyLightWarmth, float);
00161
00162   vtkSetMacro(FillLightWarmth, float);
00163   vtkGetMacro(FillLightWarmth, float);
00164
00165   vtkSetMacro(HeadlightWarmth, float);
00166   vtkGetMacro(HeadlightWarmth, float);
00167
00169
00170   vtkGetVectorMacro(KeyLightColor,  float, 3);
00171   vtkGetVectorMacro(FillLightColor, float, 3);
00172   vtkGetVectorMacro(HeadlightColor, float, 3);
00174
00176
00179   vtkBooleanMacro(MaintainLuminance, int);
00180   vtkGetMacro(MaintainLuminance, int);
00181   vtkSetMacro(MaintainLuminance, int);
00183
00185
00192   void SetKeyLightAngle(float elevation, float azimuth);
00193   void SetKeyLightAngle(float angle[2]) {
00194     this->SetKeyLightAngle(angle[0], angle[1]); };
00196
00197   void SetKeyLightElevation(float x) {
00198     this->SetKeyLightAngle(x, this->KeyLightAngle[1]); };
00199
00200   void SetKeyLightAzimuth(float x) {
00201     this->SetKeyLightAngle(this->KeyLightAngle[0], x); };
00202
00203   vtkGetVectorMacro(KeyLightAngle, float, 2);
00204   float GetKeyLightElevation() {
00205     float ang[2]; this->GetKeyLightAngle(ang); return ang[0]; };
00206
00207   float GetKeyLightAzimuth() {
00208     float ang[2]; this->GetKeyLightAngle(ang); return ang[1]; };
00209
00210   void SetFillLightAngle(float elevation, float azimuth);
00211   void SetFillLightAngle(float angle[2]) {
00212     this->SetFillLightAngle(angle[0], angle[1]); };
00213
00214   void SetFillLightElevation(float x) {
00215     this->SetFillLightAngle(x, this->FillLightAngle[1]); };
00216
00217   void SetFillLightAzimuth(float x) {
00218     this->SetFillLightAngle(this->FillLightAngle[0], x); };
00219
00220   vtkGetVectorMacro(FillLightAngle, float, 2);
00221   float GetFillLightElevation() {
00222     float ang[2]; this->GetFillLightAngle(ang); return ang[0]; };
00223
00224   float GetFillLightAzimuth() {
00225     float ang[2]; this->GetFillLightAngle(ang); return ang[1]; };
00226
00228
00230   void AddLightsToRenderer(vtkRenderer *renderer);
00231   void RemoveLightsFromRenderer(vtkRenderer *renderer);
00233
00234   void DeepCopy(vtkLightKit *kit);
00235
00236   void Modified();
00237   void Update();
00238
00239 protected:
00240   vtkLightKit();
00241   ~vtkLightKit();
00242
00243   void WarmthToRGBI(float w, float rgb[3], float& i);
00244   void WarmthToRGB(float w, float rgb[3]);
00245   void InitializeWarmthFunctions();
00246   float WarmthToIntensity(float w);
00247
00248
00249   float KeyLightIntensity;
00250   float KeyToFillRatio;
00251   float KeyToHeadRatio;
00252
00253   vtkLight *KeyLight;
00254   float KeyLightWarmth;
00255   float KeyLightAngle[2];
00256   float KeyLightColor[3];
00257
00258   vtkLight *FillLight;
00259   float FillLightWarmth;
00260   float FillLightAngle[2];
00261   float FillLightColor[3];
00262
00263   vtkLight *Headlight;
00264   float HeadlightWarmth;
00265   float HeadlightColor[3];
00266
00267   int MaintainLuminance;
00268
00269   vtkPiecewiseFunction *WarmthFunction[4]; // r, g, b, perceptual length
00270 private:
00271   vtkLightKit(const vtkLightKit&);  // Not implemented.
00272   void operator=(const vtkLightKit&);  // Not implemented.
00273 };
00274
00275 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLine.h Source File

Common/vtkLine.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLine.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkLine_h
00041 #define __vtkLine_h
00042
00043 #include "vtkCell.h"
00044
00045 class VTK_COMMON_EXPORT vtkLine : public vtkCell
00046 {
00047 public:
00048   static vtkLine *New();
00049   vtkTypeRevisionMacro(vtkLine,vtkCell);
00050
00052
00053   vtkCell *MakeObject();
00054   int GetCellType() {return VTK_LINE;};
00055   int GetCellDimension() {return 1;};
00056   int GetNumberOfEdges() {return 0;};
00057   int GetNumberOfFaces() {return 0;};
00058   vtkCell *GetEdge(int) {return 0;};
00059   vtkCell *GetFace(int) {return 0;};
00060   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00061   void Contour(float value, vtkDataArray *cellScalars,
00062                vtkPointLocator *locator, vtkCellArray *verts,
00063                vtkCellArray *lines, vtkCellArray *polys,
00064                vtkPointData *inPd, vtkPointData *outPd,
00065                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00066   int EvaluatePosition(float x[3], float* closestPoint,
00067                        int& subId, float pcoords[3],
00068                        float& dist2, float *weights);
00069   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00070                         float *weights);
00071   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00072   void Derivatives(int subId, float pcoords[3], float *values,
00073                    int dim, float *derivs);
00075
00077
00079   void Clip(float value, vtkDataArray *cellScalars,
00080             vtkPointLocator *locator, vtkCellArray *lines,
00081             vtkPointData *inPd, vtkPointData *outPd,
00082             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00083             int insideOut);
00085
00087
00089   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00090                         float x[3], float pcoords[3], int& subId);
00092
00093
00095
00100   static int Intersection(float p1[3], float p2[3], float x1[3], float x2[3],
00101                           float& u, float& v);
00103
00104
00106
00108   static float DistanceToLine(float x[3], float p1[3], float p2[3],
00109                               float &t, float closestPoint[3]);
00111
00112
00116   static float DistanceToLine(float x[3], float p1[3], float p2[3]);
00117
00119   static void InterpolationFunctions(float pcoords[3], float weights[2]);
00120
00121 protected:
00122   vtkLine();
00123   ~vtkLine() {};
00124
00125 private:
00126   vtkLine(const vtkLine&);  // Not implemented.
00127   void operator=(const vtkLine&);  // Not implemented.
00128 };
00129
00130 #endif
00131
00132
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkLinearExtrusionFilter.h Source File

Graphics/vtkLinearExtrusionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLinearExtrusionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00065 #ifndef __vtkLinearExtrusionFilter_h
00066 #define __vtkLinearExtrusionFilter_h
00067
00068 #include "vtkPolyDataToPolyDataFilter.h"
00069
00070 #define VTK_VECTOR_EXTRUSION 1
00071 #define VTK_NORMAL_EXTRUSION 2
00072 #define VTK_POINT_EXTRUSION 3
00073
00074 class VTK_GRAPHICS_EXPORT vtkLinearExtrusionFilter : public vtkPolyDataToPolyDataFilter
00075 {
00076 public:
00077   vtkTypeRevisionMacro(vtkLinearExtrusionFilter,vtkPolyDataToPolyDataFilter);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00082   static vtkLinearExtrusionFilter *New();
00083
00085
00086   vtkSetClampMacro(ExtrusionType,int,VTK_VECTOR_EXTRUSION,VTK_POINT_EXTRUSION);
00087   vtkGetMacro(ExtrusionType,int);
00088   void SetExtrusionTypeToVectorExtrusion()
00089     {this->SetExtrusionType(VTK_VECTOR_EXTRUSION);};
00090   void SetExtrusionTypeToNormalExtrusion()
00091     {this->SetExtrusionType(VTK_NORMAL_EXTRUSION);};
00092   void SetExtrusionTypeToPointExtrusion()
00093     {this->SetExtrusionType(VTK_POINT_EXTRUSION);};
00095
00097
00098   vtkSetMacro(Capping,int);
00099   vtkGetMacro(Capping,int);
00100   vtkBooleanMacro(Capping,int);
00102
00104
00105   vtkSetMacro(ScaleFactor,float);
00106   vtkGetMacro(ScaleFactor,float);
00108
00110
00112   vtkSetVector3Macro(Vector,float);
00113   vtkGetVectorMacro(Vector,float,3);
00115
00117
00119   vtkSetVector3Macro(ExtrusionPoint,float);
00120   vtkGetVectorMacro(ExtrusionPoint,float,3);
00122
00123 protected:
00124   vtkLinearExtrusionFilter();
00125   ~vtkLinearExtrusionFilter() {};
00126
00127   void Execute();
00128   int ExtrusionType;
00129   int Capping;
00130   float ScaleFactor;
00131   float Vector[3];
00132   float ExtrusionPoint[3];
00133
00134   //BTX
00135   float *(vtkLinearExtrusionFilter::*ExtrudePoint)(float x[3], vtkIdType id,
00136                                                    vtkDataArray *normals);
00137   float *ViaNormal(float x[3], vtkIdType id, vtkDataArray *normals);
00138   float *ViaVector(float x[3], vtkIdType id, vtkDataArray *normals=0);
00139   float *ViaPoint(float x[3], vtkIdType id, vtkDataArray *normals=0);
00140   //ETX
00141
00142 private:
00143   vtkLinearExtrusionFilter(const vtkLinearExtrusionFilter&);  // Not implemented.
00144   void operator=(const vtkLinearExtrusionFilter&);  // Not implemented.
00145 };
00146
00147 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkLinearSubdivisionFilter.h Source File

Graphics/vtkLinearSubdivisionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLinearSubdivisionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkLinearSubdivisionFilter_h
00041 #define __vtkLinearSubdivisionFilter_h
00042
00043 #include "vtkInterpolatingSubdivisionFilter.h"
00044 #include "vtkIntArray.h"
00045
00046 class VTK_GRAPHICS_EXPORT vtkLinearSubdivisionFilter : public vtkInterpolatingSubdivisionFilter
00047 {
00048 public:
00050
00051   static vtkLinearSubdivisionFilter *New();
00052   vtkTypeRevisionMacro(vtkLinearSubdivisionFilter,vtkInterpolatingSubdivisionFilter);
00054
00055 protected:
00056   vtkLinearSubdivisionFilter () {};
00057   ~vtkLinearSubdivisionFilter () {};
00058
00059   void GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData, vtkPoints *outputPts, vtkPointData *outputPD);
00060
00061 private:
00062   vtkLinearSubdivisionFilter(const vtkLinearSubdivisionFilter&);  // Not implemented.
00063   void operator=(const vtkLinearSubdivisionFilter&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLinearTransform.h Source File

Common/vtkLinearTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLinearTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkLinearTransform_h
00036 #define __vtkLinearTransform_h
00037
00038 #include "vtkHomogeneousTransform.h"
00039
00040 class VTK_COMMON_EXPORT vtkLinearTransform : public vtkHomogeneousTransform
00041 {
00042 public:
00043
00044   vtkTypeRevisionMacro(vtkLinearTransform,vtkHomogeneousTransform);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00048
00050   void TransformNormal(const float in[3], float out[3]) {
00051     this->Update(); this->InternalTransformNormal(in,out); };
00053
00055
00057   void TransformNormal(const double in[3], double out[3]) {
00058     this->Update(); this->InternalTransformNormal(in,out); };
00060
00062
00064   double *TransformNormal(double x, double y, double z) {
00065     return this->TransformDoubleNormal(x,y,z); }
00066   double *TransformNormal(const double normal[3]) {
00067     return this->TransformDoubleNormal(normal[0],normal[1],normal[2]); };
00069
00071
00073   float *TransformFloatNormal(float x, float y, float z) {
00074     this->InternalFloatPoint[0] = x;
00075     this->InternalFloatPoint[1] = y;
00076     this->InternalFloatPoint[2] = z;
00077     this->TransformNormal(this->InternalFloatPoint,this->InternalFloatPoint);
00078     return this->InternalFloatPoint; };
00079   float *TransformFloatNormal(const float normal[3]) {
00080     return this->TransformFloatNormal(normal[0],normal[1],normal[2]); };
00082
00084
00086   double *TransformDoubleNormal(double x, double y, double z) {
00087     this->InternalDoublePoint[0] = x;
00088     this->InternalDoublePoint[1] = y;
00089     this->InternalDoublePoint[2] = z;
00090     this->TransformNormal(this->InternalDoublePoint,this->InternalDoublePoint);
00091     return this->InternalDoublePoint; };
00092   double *TransformDoubleNormal(const double normal[3]) {
00093     return this->TransformDoubleNormal(normal[0],normal[1],normal[2]); };
00095
00097
00099   double *TransformVector(double x, double y, double z) {
00100     return this->TransformDoubleVector(x,y,z); }
00101   double *TransformVector(const double normal[3]) {
00102     return this->TransformDoubleVector(normal[0],normal[1],normal[2]); };
00104
00106
00108   void TransformVector(const float in[3], float out[3]) {
00109     this->Update(); this->InternalTransformVector(in,out); };
00111
00113
00115   void TransformVector(const double in[3], double out[3]) {
00116     this->Update(); this->InternalTransformVector(in,out); };
00118
00120
00122   float *TransformFloatVector(float x, float y, float z) {
00123       this->InternalFloatPoint[0] = x;
00124       this->InternalFloatPoint[1] = y;
00125       this->InternalFloatPoint[2] = z;
00126       this->TransformVector(this->InternalFloatPoint,this->InternalFloatPoint);
00127       return this->InternalFloatPoint; };
00128   float *TransformFloatVector(const float vec[3]) {
00129     return this->TransformFloatVector(vec[0],vec[1],vec[2]); };
00131
00133
00135   double *TransformDoubleVector(double x, double y, double z) {
00136     this->InternalDoublePoint[0] = x;
00137     this->InternalDoublePoint[1] = y;
00138     this->InternalDoublePoint[2] = z;
00139     this->TransformVector(this->InternalDoublePoint,this->InternalDoublePoint);
00140     return this->InternalDoublePoint; };
00141   double *TransformDoubleVector(const double vec[3]) {
00142     return this->TransformDoubleVector(vec[0],vec[1],vec[2]); };
00144
00147   void TransformPoints(vtkPoints *inPts, vtkPoints *outPts);
00148
00151   virtual void TransformNormals(vtkDataArray *inNms, vtkDataArray *outNms);
00152
00155   virtual void TransformVectors(vtkDataArray *inVrs, vtkDataArray *outVrs);
00156
00158
00160   void TransformPointsNormalsVectors(vtkPoints *inPts,
00161                                      vtkPoints *outPts,
00162                                      vtkDataArray *inNms,
00163                                      vtkDataArray *outNms,
00164                                      vtkDataArray *inVrs,
00165                                      vtkDataArray *outVrs);
00167
00169
00171   vtkLinearTransform *GetLinearInverse() {
00172     return (vtkLinearTransform *)this->GetInverse(); };
00174
00176
00178   void InternalTransformPoint(const float in[3], float out[3]);
00179   void InternalTransformPoint(const double in[3], double out[3]);
00181
00183
00185   virtual void InternalTransformNormal(const float in[3], float out[3]);
00186   virtual void InternalTransformNormal(const double in[3], double out[3]);
00188
00190
00192   virtual void InternalTransformVector(const float in[3], float out[3]);
00193   virtual void InternalTransformVector(const double in[3], double out[3]);
00195
00197
00199   void InternalTransformDerivative(const float in[3], float out[3],
00200                                    float derivative[3][3]);
00201   void InternalTransformDerivative(const double in[3], double out[3],
00202                                    double derivative[3][3]);
00204
00205 protected:
00206   vtkLinearTransform() {};
00207   ~vtkLinearTransform() {};
00208 private:
00209   vtkLinearTransform(const vtkLinearTransform&);  // Not implemented.
00210   void operator=(const vtkLinearTransform&);  // Not implemented.
00211 };
00212
00213 #endif
00214
00215
00216
00217
00218
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkLineSource.h Source File

Graphics/vtkLineSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLineSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkLineSource_h
00041 #define __vtkLineSource_h
00042
00043 #include "vtkPolyDataSource.h"
00044
00045 class VTK_GRAPHICS_EXPORT vtkLineSource : public vtkPolyDataSource
00046 {
00047 public:
00048   static vtkLineSource *New();
00049   vtkTypeRevisionMacro(vtkLineSource,vtkPolyDataSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetVector3Macro(Point1,float);
00055   vtkGetVectorMacro(Point1,float,3);
00057
00059
00060   vtkSetVector3Macro(Point2,float);
00061   vtkGetVectorMacro(Point2,float,3);
00063
00065
00066   vtkSetClampMacro(Resolution,int,1,VTK_LARGE_INTEGER);
00067   vtkGetMacro(Resolution,int);
00069
00070 protected:
00071   vtkLineSource(int res=1);
00072   ~vtkLineSource() {};
00073
00074   void Execute();
00075   float Point1[3];
00076   float Point2[3];
00077   int Resolution;
00078 private:
00079   vtkLineSource(const vtkLineSource&);  // Not implemented.
00080   void operator=(const vtkLineSource&);  // Not implemented.
00081 };
00082
00083 #endif
00084
00085
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkLinkEdgels.h Source File

Graphics/vtkLinkEdgels.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLinkEdgels.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkLinkEdgels_h
00063 #define __vtkLinkEdgels_h
00064
00065 #include "vtkStructuredPointsToPolyDataFilter.h"
00066
00067 class VTK_GRAPHICS_EXPORT vtkLinkEdgels : public vtkStructuredPointsToPolyDataFilter
00068 {
00069 public:
00070   vtkTypeRevisionMacro(vtkLinkEdgels,vtkStructuredPointsToPolyDataFilter);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00076   static vtkLinkEdgels *New();
00077
00079
00080   vtkSetMacro(LinkThreshold,float);
00081   vtkGetMacro(LinkThreshold,float);
00083
00085
00086   vtkSetMacro(PhiThreshold,float);
00087   vtkGetMacro(PhiThreshold,float);
00089
00091
00092   vtkSetMacro(GradientThreshold,float);
00093   vtkGetMacro(GradientThreshold,float);
00095
00096 protected:
00097   vtkLinkEdgels();
00098   ~vtkLinkEdgels() {};
00099
00100   void Execute();
00101   void LinkEdgels(int xdim, int ydim,float *image, vtkDataArray *inVectors,
00102                   vtkCellArray *newLines, vtkPoints *newPts,
00103                   vtkFloatArray *outScalars, vtkFloatArray *outVectors,
00104                   int z);
00105   float GradientThreshold;
00106   float PhiThreshold;
00107   float LinkThreshold;
00108 private:
00109   vtkLinkEdgels(const vtkLinkEdgels&);  // Not implemented.
00110   void operator=(const vtkLinkEdgels&);  // Not implemented.
00111 };
00112
00113 #endif
Generated on Mon Mar 25 01:07:42 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLocator.h Source File

Common/vtkLocator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLocator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkLocator_h
00063 #define __vtkLocator_h
00064
00065 #include "vtkObject.h"
00066 #include "vtkDataSet.h"
00067 class vtkPolyData;
00068
00069 class VTK_COMMON_EXPORT vtkLocator : public vtkObject
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkLocator,vtkObject);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00076
00077   vtkSetObjectMacro(DataSet,vtkDataSet);
00078   vtkGetObjectMacro(DataSet,vtkDataSet);
00080
00082
00084   vtkSetClampMacro(MaxLevel,int,0,VTK_LARGE_INTEGER);
00085   vtkGetMacro(MaxLevel,int);
00087
00089
00092   vtkGetMacro(Level,int);
00094
00096
00100   vtkSetMacro(Automatic,int);
00101   vtkGetMacro(Automatic,int);
00102   vtkBooleanMacro(Automatic,int);
00104
00106
00108   vtkSetClampMacro(Tolerance,float,0.0,VTK_LARGE_FLOAT);
00109   vtkGetMacro(Tolerance,float);
00111
00113
00117   vtkSetMacro(RetainCellLists,int);
00118   vtkGetMacro(RetainCellLists,int);
00119   vtkBooleanMacro(RetainCellLists,int);
00121
00124   virtual void Update();
00125
00127   virtual void Initialize();
00128
00130   virtual void BuildLocator() = 0;
00131
00133   virtual void FreeSearchStructure() = 0;
00134
00139   virtual void GenerateRepresentation(int level, vtkPolyData *pd) = 0;
00140
00142
00143   vtkGetMacro(BuildTime, unsigned long);
00145
00146 protected:
00147   vtkLocator();
00148   ~vtkLocator();
00149
00150   vtkDataSet *DataSet;
00151   int Automatic; // boolean controls automatic subdivision (or uses user spec.)
00152   float Tolerance; // for performing merging
00153   int MaxLevel;
00154   int Level;
00155   int RetainCellLists;
00156
00157   vtkTimeStamp BuildTime;  // time at which locator was built
00158
00159 private:
00160   vtkLocator(const vtkLocator&);  // Not implemented.
00161   void operator=(const vtkLocator&);  // Not implemented.
00162 };
00163
00164 #endif
00165
00166
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLODActor.h Source File

Rendering/vtkLODActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLODActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00073 #ifndef __vtkLODActor_h
00074 #define __vtkLODActor_h
00075
00076 #include "vtkActor.h"
00077 #include "vtkMaskPoints.h"
00078 #include "vtkOutlineFilter.h"
00079 #include "vtkPolyDataMapper.h"
00080 #include "vtkMapperCollection.h"
00081
00082 class VTK_RENDERING_EXPORT vtkLODActor : public vtkActor
00083 {
00084 public:
00085   vtkTypeRevisionMacro(vtkLODActor,vtkActor);
00086   void PrintSelf(ostream& os, vtkIndent indent);
00087
00091   static vtkLODActor *New();
00092
00095   virtual void Render(vtkRenderer *, vtkMapper *);
00096
00099   int RenderOpaqueGeometry(vtkViewport *viewport);
00100
00104   void ReleaseGraphicsResources(vtkWindow *);
00105
00108   void AddLODMapper(vtkMapper *mapper);
00109
00111
00112   vtkGetMacro(NumberOfCloudPoints,int);
00113   vtkSetMacro(NumberOfCloudPoints,int);
00115
00117
00119   vtkGetObjectMacro(LODMappers, vtkMapperCollection);
00121
00124   void Modified();
00125
00127   void ShallowCopy(vtkProp *prop);
00128
00129 protected:
00130   vtkLODActor();
00131   ~vtkLODActor();
00132
00133   vtkActor            *Device;
00134   vtkMapperCollection *LODMappers;
00135
00136   // stuff for creating our own LOD mappers
00137   vtkMaskPoints       *MaskPoints;
00138   vtkOutlineFilter    *OutlineFilter;
00139   vtkTimeStamp        BuildTime;
00140   int                 NumberOfCloudPoints;
00141   vtkPolyDataMapper   *LowMapper;
00142   vtkPolyDataMapper   *MediumMapper;
00143
00144   void CreateOwnLODs();
00145   void UpdateOwnLODs();
00146   void DeleteOwnLODs();
00147
00148 private:
00149   vtkLODActor(const vtkLODActor&);  // Not implemented.
00150   void operator=(const vtkLODActor&);  // Not implemented.
00151 };
00152
00153 #endif
00154
00155
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkLODProp3D.h Source File

Rendering/vtkLODProp3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLODProp3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkLODProp3D_h
00048 #define __vtkLODProp3D_h
00049
00050 #include "vtkProp3D.h"
00051 #include "vtkTransform.h"
00052
00053 class vtkRenderer;
00054 class vtkMapper;
00055 class vtkVolumeMapper;
00056 class vtkAbstractMapper3D;
00057 class vtkProperty;
00058 class vtkVolumeProperty;
00059 class vtkTexture;
00060
00061 typedef struct
00062 {
00063   vtkProp3D   *Prop3D;
00064   int         Prop3DType;
00065   int         ID;
00066   float       EstimatedTime;
00067   int         State;
00068   float       Level;
00069 } vtkLODProp3DEntry;
00070
00071 class VTK_RENDERING_EXPORT vtkLODProp3D : public vtkProp3D
00072 {
00073 public:
00075   static vtkLODProp3D *New();
00076
00077   vtkTypeRevisionMacro(vtkLODProp3D,vtkProp3D);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00081
00082   float *GetBounds();
00083   void GetBounds(float bounds[6]) { this->vtkProp3D::GetBounds( bounds ); };
00085
00087
00094   int AddLOD( vtkMapper *m, vtkProperty *p, vtkProperty *back, vtkTexture *t, float time );
00095   int AddLOD( vtkMapper *m, vtkProperty *p, vtkTexture *t, float time );
00096   int AddLOD( vtkMapper *m, vtkProperty *p, vtkProperty *back, float time );
00097   int AddLOD( vtkMapper *m, vtkProperty *p, float time );
00098   int AddLOD( vtkMapper *m, vtkTexture *t, float time );
00099   int AddLOD( vtkMapper *m, float time );
00100   int AddLOD( vtkVolumeMapper *m, vtkVolumeProperty *p, float time );
00101   int AddLOD( vtkVolumeMapper *m, float time );
00103
00106   void RemoveLOD( int id );
00107
00109
00113   void SetLODProperty( int id, vtkProperty  *p );
00114   void GetLODProperty( int id, vtkProperty  **p );
00115   void SetLODProperty( int id, vtkVolumeProperty  *p );
00116   void GetLODProperty( int id, vtkVolumeProperty  **p );
00118
00120
00124   void SetLODMapper( int id, vtkMapper  *m );
00125   void GetLODMapper( int id, vtkMapper  **m );
00126   void SetLODMapper( int id, vtkVolumeMapper  *m );
00127   void GetLODMapper( int id, vtkVolumeMapper  **m );
00129
00133   vtkAbstractMapper3D *GetLODMapper(int id);
00134
00136
00138   void SetLODBackfaceProperty( int id, vtkProperty *t );
00139   void GetLODBackfaceProperty( int id, vtkProperty **t );
00141
00143
00145   void SetLODTexture( int id, vtkTexture *t );
00146   void GetLODTexture( int id, vtkTexture **t );
00148
00150
00153   void EnableLOD( int id );
00154   void DisableLOD( int id );
00156
00158
00163   void SetLODLevel( int id, float level );
00164   float GetLODLevel( int id );
00165   float GetLODIndexLevel( int index );
00167
00169
00172   float GetLODEstimatedRenderTime( int id );
00173   float GetLODIndexEstimatedRenderTime( int index );
00175
00177
00180   vtkSetClampMacro( AutomaticLODSelection, int, 0, 1 );
00181   vtkGetMacro( AutomaticLODSelection, int );
00182   vtkBooleanMacro( AutomaticLODSelection, int );
00184
00186
00188   vtkSetMacro( SelectedLODID, int );
00189   vtkGetMacro( SelectedLODID, int );
00191
00194   int GetLastRenderedLODID();
00195
00197   int GetPickLODID(void);
00198
00202   virtual void GetActors(vtkPropCollection *);
00203
00205
00207   void SetPickMethod(void (*f)(void *), void *arg);
00208   void SetPickMethodArgDelete(void (*f)(void *));
00210
00212
00214   void SetSelectedPickLODID(int id);
00215   vtkGetMacro( SelectedPickLODID, int );
00217
00219
00222   vtkSetClampMacro( AutomaticPickLODSelection, int, 0, 1 );
00223   vtkGetMacro( AutomaticPickLODSelection, int );
00224   vtkBooleanMacro( AutomaticPickLODSelection, int );
00226
00228   void ShallowCopy(vtkProp *prop);
00229
00230 //BTX
00231
00233
00234   int RenderOpaqueGeometry(vtkViewport *viewport);
00235   int RenderTranslucentGeometry(vtkViewport *viewport);
00237
00241   void ReleaseGraphicsResources(vtkWindow *);
00242
00246   void SetAllocatedRenderTime( float t, vtkViewport *vp );
00247
00252   void RestoreEstimatedRenderTime( );
00253
00256   virtual void AddEstimatedRenderTime( float t, vtkViewport *vp );
00257
00258 //ETX
00259
00260 protected:
00261   vtkLODProp3D();
00262   ~vtkLODProp3D();
00263
00264   int GetAutomaticPickPropIndex(void);
00265
00266   vtkLODProp3DEntry *LODs;
00267   int               NumberOfEntries;
00268   int               NumberOfLODs;
00269   int               CurrentIndex;
00270
00271   int               GetNextEntryIndex();
00272   int               ConvertIDToIndex( int id );
00273   int               SelectedLODIndex;
00274
00275   int               AutomaticLODSelection;
00276   int               SelectedLODID;
00277   int               SelectedPickLODID;
00278   int               AutomaticPickLODSelection;
00279   vtkProp*          PreviousPickProp;
00280   void (*PreviousPickMethod)(void *);
00281   void *            PreviousPickMethodArg;
00282 private:
00283   vtkLODProp3D(const vtkLODProp3D&);  // Not implemented.
00284   void operator=(const vtkLODProp3D&);  // Not implemented.
00285 };
00286
00287 #endif
00288
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLogLookupTable.h Source File

Common/vtkLogLookupTable.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLogLookupTable.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkLogLookupTable_h
00041 #define __vtkLogLookupTable_h
00042
00043 #include "vtkLookupTable.h"
00044
00045 class VTK_COMMON_EXPORT vtkLogLookupTable : public vtkLookupTable
00046 {
00047 public:
00048   static vtkLogLookupTable *New();
00049
00050   vtkTypeRevisionMacro(vtkLogLookupTable,vtkLookupTable);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00053 protected:
00054   vtkLogLookupTable(int sze=256, int ext=256);
00055   ~vtkLogLookupTable() {};
00056 private:
00057   vtkLogLookupTable(const vtkLogLookupTable&);  // Not implemented.
00058   void operator=(const vtkLogLookupTable&);  // Not implemented.
00059 };
00060
00061 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLongArray.h Source File

Common/vtkLongArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLongArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkLongArray_h
00042 #define __vtkLongArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkLongArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkLongArray *New();
00050
00051   vtkTypeRevisionMacro(vtkLongArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00063
00065   virtual void Resize(vtkIdType numTuples);
00066
00068   vtkDataArray *MakeObject();
00069
00071   int GetDataType() {return VTK_LONG;};
00072
00074   int GetDataTypeSize() { return sizeof(long); }
00075
00077   void SetNumberOfTuples(const vtkIdType number);
00078
00081   float *GetTuple(const vtkIdType i);
00082
00084
00085   void GetTuple(const vtkIdType i, float * tuple);
00086   void GetTuple(const vtkIdType i, double * tuple);
00088
00090
00091   void SetTuple(const vtkIdType i, const float * tuple);
00092   void SetTuple(const vtkIdType i, const double * tuple);
00094
00096
00098   void InsertTuple(const vtkIdType i, const float * tuple);
00099   void InsertTuple(const vtkIdType i, const double * tuple);
00101
00103
00105   vtkIdType InsertNextTuple(const float * tuple);
00106   vtkIdType InsertNextTuple(const double * tuple);
00108
00110   long GetValue(const vtkIdType id) {return this->Array[id];};
00111
00115   void SetNumberOfValues(const vtkIdType number);
00116
00118
00120   void SetValue(const vtkIdType id, const long value)
00121     { this->Array[id] = value;};
00123
00125   void InsertValue(const vtkIdType id, const long i);
00126
00129   vtkIdType InsertNextValue(const long);
00130
00134   float GetComponent(const vtkIdType i, const int j);
00135
00140   void SetComponent(const vtkIdType i, const int j, const float c);
00141
00145   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00146
00148
00150   long *GetPointer(const vtkIdType id) {return this->Array + id;}
00151   void *GetVoidPointer(const vtkIdType id)
00152     {return (void *)this->GetPointer(id);};
00154
00158   long *WritePointer(const vtkIdType id, const vtkIdType number);
00159
00161   void DeepCopy(vtkDataArray *da);
00162
00164
00170   void SetArray(long* array, vtkIdType size, int save);
00171   void SetVoidArray(void *array, vtkIdType size, int save)
00172     {this->SetArray((long*)array, size, save);};
00174
00175 protected:
00176   vtkLongArray(vtkIdType numComp=1);
00177   ~vtkLongArray();
00178
00179   long *Array;   // pointer to data
00180   long *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00181
00182   int TupleSize; //used for data conversion
00183   float *Tuple;
00184
00185   int SaveUserArray;
00186 private:
00187   vtkLongArray(const vtkLongArray&);  // Not implemented.
00188   void operator=(const vtkLongArray&);  // Not implemented.
00189 };
00190
00191 inline void vtkLongArray::SetNumberOfValues(const vtkIdType number)
00192 {
00193   this->Allocate(number);
00194   this->MaxId = number - 1;
00195 }
00196
00197 inline long *vtkLongArray::WritePointer(const vtkIdType id,
00198                                         const vtkIdType number)
00199 {
00200   vtkIdType newSize=id+number;
00201   if ( newSize > this->Size )
00202     {
00203     this->ResizeAndExtend(newSize);
00204     }
00205   if ( (--newSize) > this->MaxId )
00206     {
00207     this->MaxId = newSize;
00208     }
00209   return this->Array + id;
00210 }
00211
00212 inline void vtkLongArray::InsertValue(const vtkIdType id, const long i)
00213 {
00214   if ( id >= this->Size )
00215     {
00216     this->ResizeAndExtend(id+1);
00217     }
00218   this->Array[id] = i;
00219   if ( id > this->MaxId )
00220     {
00221     this->MaxId = id;
00222     }
00223 }
00224
00225 inline vtkIdType vtkLongArray::InsertNextValue(const long i)
00226 {
00227   this->InsertValue (++this->MaxId,i);
00228   return this->MaxId;
00229 }
00230
00231
00232 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkLookupTable.h Source File

Common/vtkLookupTable.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLookupTable.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkLookupTable_h
00048 #define __vtkLookupTable_h
00049
00050 #include "vtkScalarsToColors.h"
00051
00052 #define VTK_RAMP_LINEAR 0
00053 #define VTK_RAMP_SCURVE 1
00054 #define VTK_SCALE_LINEAR 0
00055 #define VTK_SCALE_LOG10 1
00056
00057 class VTK_COMMON_EXPORT vtkLookupTable : public vtkScalarsToColors
00058 {
00059 public:
00062   static vtkLookupTable *New();
00063
00064   vtkTypeRevisionMacro(vtkLookupTable,vtkScalarsToColors);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068   int Allocate(int sz=256, int ext=256);
00069
00072   virtual void Build();
00073
00079   virtual void ForceBuild();
00080
00082
00088   vtkSetMacro(Ramp,int);
00089   void SetRampToLinear() { this->SetRamp(VTK_RAMP_LINEAR); };
00090   void SetRampToSCurve() { this->SetRamp(VTK_RAMP_SCURVE); };
00091   vtkGetMacro(Ramp,int);
00093
00095
00098   void SetScale(int scale);
00099   void SetScaleToLinear() { this->SetScale(VTK_SCALE_LINEAR); };
00100   void SetScaleToLog10() { this->SetScale(VTK_SCALE_LOG10); };
00101   vtkGetMacro(Scale,int);
00103
00105
00109   void SetTableRange(float r[2]);
00110   virtual void SetTableRange(float min, float max);
00111   vtkGetVectorMacro(TableRange,float,2);
00113
00115
00117   vtkSetVector2Macro(HueRange,float);
00118   vtkGetVector2Macro(HueRange,float);
00120
00122
00124   vtkSetVector2Macro(SaturationRange,float);
00125   vtkGetVector2Macro(SaturationRange,float);
00127
00129
00131   vtkSetVector2Macro(ValueRange,float);
00132   vtkGetVector2Macro(ValueRange,float);
00134
00136
00138   vtkSetVector2Macro(AlphaRange,float);
00139   vtkGetVector2Macro(AlphaRange,float);
00141
00143   unsigned char *MapValue(float v);
00144
00146
00148   float *GetColor(float x) { return vtkScalarsToColors::GetColor(x); }
00149   void GetColor(float x, float rgb[3]);
00151
00154   float GetOpacity(float v);
00155
00157   virtual vtkIdType GetIndex(float v);
00158
00160
00161   void SetNumberOfTableValues(vtkIdType number);
00162   vtkIdType GetNumberOfTableValues() { return this->NumberOfColors; };
00164
00169   void SetTableValue(vtkIdType indx, float rgba[4]);
00170
00173   void SetTableValue(vtkIdType indx, float r, float g, float b, float a=1.0);
00174
00177   float *GetTableValue(vtkIdType id);
00178
00181   void GetTableValue(vtkIdType id, float rgba[4]);
00182
00184
00186   unsigned char *GetPointer(const vtkIdType id) {
00187     return this->Table->GetPointer(4*id); };
00189
00194   unsigned char *WritePointer(const vtkIdType id, const int number);
00195
00197
00199   float *GetRange() { return this->GetTableRange(); };
00200   void SetRange(float min, float max) { this->SetTableRange(min, max); };
00201   void SetRange(float rng[2]) { this->SetRange(rng[0], rng[1]); };
00203
00205
00209   vtkSetClampMacro(NumberOfColors,vtkIdType,2,VTK_LARGE_ID);
00210   vtkGetMacro(NumberOfColors,vtkIdType);
00212
00214
00215   void MapScalarsThroughTable2(void *input, unsigned char *output,
00216                                int inputDataType, int numberOfValues,
00217                                int inputIncrement, int outputIncrement);
00219
00220 protected:
00221   vtkLookupTable(int sze=256, int ext=256);
00222   ~vtkLookupTable();
00223
00224   vtkIdType NumberOfColors;
00225   vtkUnsignedCharArray *Table;
00226   float TableRange[2];
00227   float HueRange[2];
00228   float SaturationRange[2];
00229   float ValueRange[2];
00230   float AlphaRange[2];
00231   int Scale;
00232   int Ramp;
00233   vtkTimeStamp InsertTime;
00234   vtkTimeStamp BuildTime;
00235   float RGBA[4]; //used during conversion process
00236
00237 private:
00238   vtkLookupTable(const vtkLookupTable&);  // Not implemented.
00239   void operator=(const vtkLookupTable&);  // Not implemented.
00240 };
00241
00242 inline unsigned char *vtkLookupTable::WritePointer(const int id,
00243                                                    const int number)
00244 {
00245  return this->Table->WritePointer(4*id,4*number);
00246 }
00247
00248 #endif
00249
00250
00251
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkLoopSubdivisionFilter.h Source File

Graphics/vtkLoopSubdivisionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkLoopSubdivisionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkLoopSubdivisionFilter_h
00057 #define __vtkLoopSubdivisionFilter_h
00058
00059 #include "vtkApproximatingSubdivisionFilter.h"
00060 #include "vtkIntArray.h"
00061 #include "vtkIdList.h"
00062 #include "vtkCellArray.h"
00063
00064 class VTK_GRAPHICS_EXPORT vtkLoopSubdivisionFilter : public vtkApproximatingSubdivisionFilter
00065 {
00066 public:
00068
00069   static vtkLoopSubdivisionFilter *New();
00070   vtkTypeRevisionMacro(vtkLoopSubdivisionFilter,vtkApproximatingSubdivisionFilter);
00072
00073 protected:
00074   vtkLoopSubdivisionFilter () {};
00075   ~vtkLoopSubdivisionFilter () {};
00076
00077   void GenerateSubdivisionPoints (vtkPolyData *inputDS, vtkIntArray *edgeData,
00078                                   vtkPoints *outputPts,
00079                                   vtkPointData *outputPD);
00080   void GenerateEvenStencil (vtkIdType p1, vtkPolyData *polys,
00081                             vtkIdList *stencilIds, float *weights);
00082   void GenerateOddStencil (vtkIdType p1, vtkIdType p2, vtkPolyData *polys,
00083                            vtkIdList *stencilIds, float *weights);
00084
00085   void ComputeInputUpdateExtents(vtkDataObject *output);
00086 private:
00087   vtkLoopSubdivisionFilter(const vtkLoopSubdivisionFilter&);  // Not implemented.
00088   void operator=(const vtkLoopSubdivisionFilter&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMapper2D.h Source File

Common/vtkMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMapper2D_h
00037 #define __vtkMapper2D_h
00038
00039 #include "vtkAbstractMapper.h"
00040 #include "vtkWindow.h"
00041
00042 class vtkViewport;
00043 class vtkActor2D;
00044
00045 class VTK_COMMON_EXPORT vtkMapper2D : public vtkAbstractMapper
00046 {
00047 public:
00048   static vtkMapper2D* New();
00049
00050   vtkTypeRevisionMacro(vtkMapper2D,vtkAbstractMapper);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00053   virtual void RenderOverlay(vtkViewport*, vtkActor2D*) {};
00054   virtual void RenderOpaqueGeometry(vtkViewport*, vtkActor2D*) {};
00055   virtual void RenderTranslucentGeometry(vtkViewport*, vtkActor2D*) {};
00056
00057 protected:
00058   vtkMapper2D() {};
00059   ~vtkMapper2D() {};
00060
00061 private:
00062   vtkMapper2D(const vtkMapper2D&);  // Not implemented.
00063   void operator=(const vtkMapper2D&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
00069
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMapper.h Source File

Rendering/vtkMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00068 #ifndef __vtkMapper_h
00069 #define __vtkMapper_h
00070
00071 #include "vtkAbstractMapper3D.h"
00072 #include "vtkScalarsToColors.h"
00073 #include "vtkDataSet.h"
00074
00075 #define VTK_RESOLVE_OFF 0
00076 #define VTK_RESOLVE_POLYGON_OFFSET 1
00077 #define VTK_RESOLVE_SHIFT_ZBUFFER 2
00078
00079 #define VTK_GET_ARRAY_BY_ID 0
00080 #define VTK_GET_ARRAY_BY_NAME 1
00081
00082 class vtkWindow;
00083 class vtkRenderer;
00084 class vtkActor;
00085
00086 class VTK_RENDERING_EXPORT vtkMapper : public vtkAbstractMapper3D
00087 {
00088 public:
00089   vtkTypeRevisionMacro(vtkMapper,vtkAbstractMapper3D);
00090   void PrintSelf(ostream& os, vtkIndent indent);
00091
00093   void ShallowCopy(vtkAbstractMapper *m);
00094
00097   unsigned long GetMTime();
00098
00101   virtual void Render(vtkRenderer *ren, vtkActor *a) = 0;
00102
00106   virtual void ReleaseGraphicsResources(vtkWindow *) {};
00107
00109
00110   void SetLookupTable(vtkScalarsToColors *lut);
00111   vtkScalarsToColors *GetLookupTable();
00113
00116   virtual void CreateDefaultLookupTable();
00117
00119
00121   vtkSetMacro(ScalarVisibility,int);
00122   vtkGetMacro(ScalarVisibility,int);
00123   vtkBooleanMacro(ScalarVisibility,int);
00125
00127
00134   vtkSetMacro(ColorMode,int);
00135   vtkGetMacro(ColorMode,int);
00136   void SetColorModeToDefault()
00137     {this->SetColorMode(VTK_COLOR_MODE_DEFAULT);};
00138   void SetColorModeToMapScalars()
00139     {this->SetColorMode(VTK_COLOR_MODE_MAP_SCALARS);};
00141
00143   const char *GetColorModeAsString();
00144
00146
00152   vtkSetMacro(UseLookupTableScalarRange,int);
00153   vtkGetMacro(UseLookupTableScalarRange,int);
00154   vtkBooleanMacro(UseLookupTableScalarRange,int);
00156
00158
00161   vtkSetVector2Macro(ScalarRange,float);
00162   vtkGetVectorMacro(ScalarRange,float,2);
00164
00166
00171   vtkSetMacro(ImmediateModeRendering,int);
00172   vtkGetMacro(ImmediateModeRendering,int);
00173   vtkBooleanMacro(ImmediateModeRendering,int);
00175
00177
00182   static void SetGlobalImmediateModeRendering(int val);
00183   static void GlobalImmediateModeRenderingOn()
00184     {vtkMapper::SetGlobalImmediateModeRendering(1);};
00185   static void GlobalImmediateModeRenderingOff()
00186     {vtkMapper::SetGlobalImmediateModeRendering(0);};
00187   static int  GetGlobalImmediateModeRendering();
00189
00191
00201   vtkSetMacro(ScalarMode,int);
00202   vtkGetMacro(ScalarMode,int);
00203   void SetScalarModeToDefault() {
00204     this->SetScalarMode(VTK_SCALAR_MODE_DEFAULT);};
00205   void SetScalarModeToUsePointData() {
00206     this->SetScalarMode(VTK_SCALAR_MODE_USE_POINT_DATA);};
00207   void SetScalarModeToUseCellData() {
00208     this->SetScalarMode(VTK_SCALAR_MODE_USE_CELL_DATA);};
00209   void SetScalarModeToUsePointFieldData() {
00210     this->SetScalarMode(VTK_SCALAR_MODE_USE_POINT_FIELD_DATA);};
00211   void SetScalarModeToUseCellFieldData() {
00212     this->SetScalarMode(VTK_SCALAR_MODE_USE_CELL_FIELD_DATA);};
00214
00216
00217   void ColorByArrayComponent(int arrayNum, int component);
00218   void ColorByArrayComponent(const char* arrayName, int component);
00220
00222
00223   char* GetArrayName() { return this->ArrayName; }
00224   int GetArrayId() { return this->ArrayId; }
00225   int GetArrayAccessMode() { return this->ArrayAccessMode; }
00226   int GetArrayComponent() { return this->ArrayComponent; }
00228
00230   const char *GetScalarModeAsString();
00231
00233
00243   static void SetResolveCoincidentTopology(int val);
00244   static int  GetResolveCoincidentTopology();
00245   static void SetResolveCoincidentTopologyToDefault();
00246   static void SetResolveCoincidentTopologyToOff()
00247     {SetResolveCoincidentTopology(VTK_RESOLVE_OFF);}
00248   static void SetResolveCoincidentTopologyToPolygonOffset()
00249     {SetResolveCoincidentTopology(VTK_RESOLVE_POLYGON_OFFSET);}
00250   static void SetResolveCoincidentTopologyToShiftZBuffer()
00251     {SetResolveCoincidentTopology(VTK_RESOLVE_SHIFT_ZBUFFER);}
00253
00255
00258   static void SetResolveCoincidentTopologyPolygonOffsetParameters(float factor,
00259                                                                   float units);
00260   static void GetResolveCoincidentTopologyPolygonOffsetParameters(float& factor,
00261                                                                   float& units);
00263
00265
00267   static void SetResolveCoincidentTopologyZShift(double val);
00268   static double GetResolveCoincidentTopologyZShift();
00270
00272
00274   virtual float *GetBounds();
00275   virtual void GetBounds(float bounds[6])
00276     {this->vtkAbstractMapper3D::GetBounds(bounds);};
00278
00280
00283   void SetRenderTime(float time) {this->RenderTime = time;}
00284   vtkGetMacro(RenderTime, float);
00286
00287   //BTX
00289   /*! Get the input as a vtkDataSet.  This method is overridden in the
00290       specialized mapper classes to return more specific data types. */
00291   vtkDataSet *GetInput();
00292   //ETX
00294
00296   /*! Get the input to this mapper as a vtkDataSet, instead of as a more
00297       specialized data type that the subclass may return from GetInput().
00298       This method is provided for use in the wrapper languages, C++
00299       programmers should use GetInput() instead. */
00300   vtkDataSet *GetInputAsDataSet()
00301     {return this->GetInput();}
00303
00309   vtkUnsignedCharArray *MapScalars(float alpha);
00310
00312   virtual void Update();
00313
00314 protected:
00315   vtkMapper();
00316   ~vtkMapper();
00317
00318   vtkUnsignedCharArray *Colors;
00319
00320   vtkScalarsToColors *LookupTable;
00321   int ScalarVisibility;
00322   vtkTimeStamp BuildTime;
00323   float ScalarRange[2];
00324   int UseLookupTableScalarRange;
00325   int ImmediateModeRendering;
00326   int ColorMode;
00327   int ScalarMode;
00328
00329   float RenderTime;
00330
00331   // for coloring by a component of a field data array
00332   int ArrayId;
00333   char ArrayName[256];
00334   int ArrayComponent;
00335   int ArrayAccessMode;
00336 private:
00337   vtkMapper(const vtkMapper&);  // Not implemented.
00338   void operator=(const vtkMapper&);  // Not implemented.
00339 };
00340
00341 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMapperCollection.h Source File

Rendering/vtkMapperCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMapperCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkMapperC_h
00040 #define __vtkMapperC_h
00041
00042 #include "vtkCollection.h"
00043 #include "vtkMapper.h"
00044
00045 class VTK_RENDERING_EXPORT vtkMapperCollection : public vtkCollection
00046 {
00047  public:
00048   static vtkMapperCollection *New();
00049   vtkTypeRevisionMacro(vtkMapperCollection,vtkCollection);
00050
00052
00053   void AddItem(vtkMapper *a) {
00054     this->vtkCollection::AddItem((vtkObject *)a);};
00056
00058
00059   vtkMapper *GetNextItem() {
00060     return static_cast<vtkMapper *>(this->GetNextItemAsObject());};
00062
00064   vtkMapper *GetLastItem();
00065
00066 protected:
00067   vtkMapperCollection() {};
00068   ~vtkMapperCollection() {};
00069
00070 private:
00071   // hide the standard AddItem from the user and the compiler.
00072   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00073
00074 private:
00075   vtkMapperCollection(const vtkMapperCollection&);  // Not implemented.
00076   void operator=(const vtkMapperCollection&);  // Not implemented.
00077 };
00078
00079
00080 inline vtkMapper *vtkMapperCollection::GetLastItem()
00081 {
00082   if ( this->Bottom == NULL )
00083     {
00084     return NULL;
00085     }
00086   else
00087     {
00088     return static_cast<vtkMapper *>(this->Bottom->Item);
00089     }
00090 }
00091
00092 #endif
00093
00094
00095
00096
00097
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkMarchingContourFilter.h Source File

Patented/vtkMarchingContourFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMarchingContourFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00016      "System and Method for the Display of Surface Structures Contained
00017      Within the Interior Region of a Solid Body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00083 #ifndef __vtkMarchingContourFilter_h
00084 #define __vtkMarchingContourFilter_h
00085
00086 #include "vtkDataSetToPolyDataFilter.h"
00087 #include "vtkContourValues.h"
00088
00089 class vtkScalarTree;
00090
00091 class VTK_PATENTED_EXPORT vtkMarchingContourFilter : public vtkDataSetToPolyDataFilter
00092 {
00093 public:
00094   vtkTypeRevisionMacro(vtkMarchingContourFilter,vtkDataSetToPolyDataFilter);
00095   void PrintSelf(ostream& os, vtkIndent indent);
00096
00099   static vtkMarchingContourFilter *New();
00100
00102
00103   void SetValue(int i, float value);
00104   float GetValue(int i);
00105   float *GetValues();
00106   void GetValues(float *contourValues);
00107   void SetNumberOfContours(int number);
00108   int GetNumberOfContours();
00109   void GenerateValues(int numContours, float range[2]);
00110   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00112
00114   unsigned long GetMTime();
00115
00117
00121   vtkSetMacro(ComputeNormals,int);
00122   vtkGetMacro(ComputeNormals,int);
00123   vtkBooleanMacro(ComputeNormals,int);
00125
00127
00133   vtkSetMacro(ComputeGradients,int);
00134   vtkGetMacro(ComputeGradients,int);
00135   vtkBooleanMacro(ComputeGradients,int);
00137
00139
00140   vtkSetMacro(ComputeScalars,int);
00141   vtkGetMacro(ComputeScalars,int);
00142   vtkBooleanMacro(ComputeScalars,int);
00144
00146
00147   vtkSetMacro(UseScalarTree,int);
00148   vtkGetMacro(UseScalarTree,int);
00149   vtkBooleanMacro(UseScalarTree,int);
00151
00153
00155   void SetLocator(vtkPointLocator *locator);
00156   vtkGetObjectMacro(Locator,vtkPointLocator);
00158
00161   void CreateDefaultLocator();
00162
00163 protected:
00164   vtkMarchingContourFilter();
00165   ~vtkMarchingContourFilter();
00166
00167   void Execute();
00168
00169   vtkContourValues *ContourValues;
00170   int ComputeNormals;
00171   int ComputeGradients;
00172   int ComputeScalars;
00173   vtkPointLocator *Locator;
00174   int UseScalarTree;
00175   vtkScalarTree *ScalarTree;
00176
00177   //special contouring for structured points
00178   void StructuredPointsContour(int dim);
00179   //special contouring for image data
00180   void ImageContour(int dim);
00181   //default if not structured data
00182   void DataSetContour();
00183 private:
00184   vtkMarchingContourFilter(const vtkMarchingContourFilter&);  // Not implemented.
00185   void operator=(const vtkMarchingContourFilter&);  // Not implemented.
00186 };
00187
00190 inline void vtkMarchingContourFilter::SetValue(int i, float value)
00191 {
00192   this->ContourValues->SetValue(i,value);
00193 }
00194
00196 inline float vtkMarchingContourFilter::GetValue(int i)
00197 {
00198   return this->ContourValues->GetValue(i);
00199 }
00200
00203 inline float *vtkMarchingContourFilter::GetValues()
00204 {
00205   return this->ContourValues->GetValues();
00206 }
00207
00211 inline void vtkMarchingContourFilter::GetValues(float *contourValues)
00212 {
00213   this->ContourValues->GetValues(contourValues);
00214 }
00215
00219 inline void vtkMarchingContourFilter::SetNumberOfContours(int number)
00220 {
00221   this->ContourValues->SetNumberOfContours(number);
00222 }
00223
00225 inline int vtkMarchingContourFilter::GetNumberOfContours()
00226 {
00227   return this->ContourValues->GetNumberOfContours();
00228 }
00229
00231
00233 inline void vtkMarchingContourFilter::GenerateValues(int numContours,
00234                                                      float range[2])
00236 {
00237   this->ContourValues->GenerateValues(numContours, range);
00238 }
00239
00241
00243 inline void vtkMarchingContourFilter::GenerateValues(int numContours,
00244                                                      float rangeStart,
00245                                                      float rangeEnd)
00247 {
00248   this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);
00249 }
00250
00251 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkMarchingCubes.h Source File

Patented/vtkMarchingCubes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMarchingCubes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00016      "System and Method for the Display of Surface Structures Contained
00017      Within the Interior Region of a Solid Body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00062 #ifndef __vtkMarchingCubes_h
00063 #define __vtkMarchingCubes_h
00064
00065 #include "vtkStructuredPointsToPolyDataFilter.h"
00066 #include "vtkContourValues.h"
00067
00068 class VTK_PATENTED_EXPORT vtkMarchingCubes : public vtkStructuredPointsToPolyDataFilter
00069 {
00070 public:
00071   static vtkMarchingCubes *New();
00072   vtkTypeRevisionMacro(vtkMarchingCubes,vtkStructuredPointsToPolyDataFilter);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00075   // Methods to set contour values
00076   void SetValue(int i, float value);
00077   float GetValue(int i);
00078   float *GetValues();
00079   void GetValues(float *contourValues);
00080   void SetNumberOfContours(int number);
00081   int GetNumberOfContours();
00082   void GenerateValues(int numContours, float range[2]);
00083   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00084
00085   // Because we delegate to vtkContourValues
00086   unsigned long int GetMTime();
00087
00089
00093   vtkSetMacro(ComputeNormals,int);
00094   vtkGetMacro(ComputeNormals,int);
00095   vtkBooleanMacro(ComputeNormals,int);
00097
00099
00105   vtkSetMacro(ComputeGradients,int);
00106   vtkGetMacro(ComputeGradients,int);
00107   vtkBooleanMacro(ComputeGradients,int);
00109
00111
00112   vtkSetMacro(ComputeScalars,int);
00113   vtkGetMacro(ComputeScalars,int);
00114   vtkBooleanMacro(ComputeScalars,int);
00116
00118
00120   void SetLocator(vtkPointLocator *locator);
00121   vtkGetObjectMacro(Locator,vtkPointLocator);
00123
00126   void CreateDefaultLocator();
00127
00128 protected:
00129   vtkMarchingCubes();
00130   ~vtkMarchingCubes();
00131
00132   void Execute();
00133
00134   vtkContourValues *ContourValues;
00135   int ComputeNormals;
00136   int ComputeGradients;
00137   int ComputeScalars;
00138   vtkPointLocator *Locator;
00139 private:
00140   vtkMarchingCubes(const vtkMarchingCubes&);  // Not implemented.
00141   void operator=(const vtkMarchingCubes&);  // Not implemented.
00142 };
00143
00146 inline void vtkMarchingCubes::SetValue(int i, float value)
00147 {this->ContourValues->SetValue(i,value);}
00148
00150
00151 inline float vtkMarchingCubes::GetValue(int i)
00152 {return this->ContourValues->GetValue(i);}
00154
00156
00158 inline float *vtkMarchingCubes::GetValues()
00159 {return this->ContourValues->GetValues();}
00161
00165 inline void vtkMarchingCubes::GetValues(float *contourValues)
00166 {this->ContourValues->GetValues(contourValues);}
00167
00171 inline void vtkMarchingCubes::SetNumberOfContours(int number)
00172 {this->ContourValues->SetNumberOfContours(number);}
00173
00175
00176 inline int vtkMarchingCubes::GetNumberOfContours()
00177 {return this->ContourValues->GetNumberOfContours();}
00179
00181
00183 inline void vtkMarchingCubes::GenerateValues(int numContours, float range[2])
00184 {this->ContourValues->GenerateValues(numContours, range);}
00186
00188
00190 inline void vtkMarchingCubes::GenerateValues(int numContours, float
00191                                              rangeStart, float rangeEnd)
00192 {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00194
00195 #endif
00196
00197
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMarchingCubesCases.h Source File

Common/vtkMarchingCubesCases.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMarchingCubesCases.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 #ifndef __vtkMarchingCubesCases_h
00017 #define __vtkMarchingCubesCases_h
00018 //
00019 // marching cubes case table for generating isosurfaces
00020 //
00021 typedef int EDGE_LIST;
00022 struct VTK_COMMON_EXPORT VTK_TRIANGLE_CASES
00023 {
00024   EDGE_LIST edges[16];
00025   static VTK_TRIANGLE_CASES* GetCases();
00026 };
00027
00028 //
00029 // Edges to intersect.  Three at a time form a triangle. Comments at
00030 // end of line indicate case number (0->255) and base case number (0->15).
00031 //
00032
00033 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkMarchingSquares.h Source File

Patented/vtkMarchingSquares.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMarchingSquares.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00016      "System and Method for the Display of Surface Structures Contained
00017      Within the Interior Region of a Solid Body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00069 #ifndef __vtkMarchingSquares_h
00070 #define __vtkMarchingSquares_h
00071
00072 #include "vtkPolyDataSource.h"
00073 #include "vtkImageData.h"
00074 #include "vtkContourValues.h"
00075
00076 class VTK_PATENTED_EXPORT vtkMarchingSquares : public vtkPolyDataSource
00077 {
00078 public:
00079   static vtkMarchingSquares *New();
00080   vtkTypeRevisionMacro(vtkMarchingSquares,vtkPolyDataSource);
00081   void PrintSelf(ostream& os, vtkIndent indent);
00082
00084
00085   void SetInput(vtkImageData *input);
00086   vtkImageData *GetInput();
00088
00090
00094   vtkSetVectorMacro(ImageRange,int,6);
00095   vtkGetVectorMacro(ImageRange,int,6);
00096   void SetImageRange(int imin, int imax, int jmin, int jmax,
00097                      int kmin, int kmax);
00099
00100   // Methods to set contour values
00101   void SetValue(int i, float value);
00102   float GetValue(int i);
00103   float *GetValues();
00104   void GetValues(float *contourValues);
00105   void SetNumberOfContours(int number);
00106   int GetNumberOfContours();
00107   void GenerateValues(int numContours, float range[2]);
00108   void GenerateValues(int numContours, float rangeStart, float rangeEnd);
00109
00110   // Because we delegate to vtkContourValues
00111   unsigned long int GetMTime();
00112
00113   void SetLocator(vtkPointLocator *locator);
00114   vtkGetObjectMacro(Locator,vtkPointLocator);
00115
00118   void CreateDefaultLocator();
00119
00120 protected:
00121   vtkMarchingSquares();
00122   ~vtkMarchingSquares();
00123
00124   void Execute();
00125
00126   vtkContourValues *ContourValues;
00127   int ImageRange[6];
00128   vtkPointLocator *Locator;
00129 private:
00130   vtkMarchingSquares(const vtkMarchingSquares&);  // Not implemented.
00131   void operator=(const vtkMarchingSquares&);  // Not implemented.
00132 };
00133
00136 inline void vtkMarchingSquares::SetValue(int i, float value)
00137 {this->ContourValues->SetValue(i,value);}
00138
00140
00141 inline float vtkMarchingSquares::GetValue(int i)
00142 {return this->ContourValues->GetValue(i);}
00144
00146
00148 inline float *vtkMarchingSquares::GetValues()
00149 {return this->ContourValues->GetValues();}
00151
00155 inline void vtkMarchingSquares::GetValues(float *contourValues)
00156 {this->ContourValues->GetValues(contourValues);}
00157
00161 inline void vtkMarchingSquares::SetNumberOfContours(int number)
00162 {this->ContourValues->SetNumberOfContours(number);}
00163
00165
00166 inline int vtkMarchingSquares::GetNumberOfContours()
00167 {return this->ContourValues->GetNumberOfContours();}
00169
00171
00173 inline void vtkMarchingSquares::GenerateValues(int numContours, float range[2])
00174 {this->ContourValues->GenerateValues(numContours, range);}
00176
00178
00180 inline void vtkMarchingSquares::GenerateValues(int numContours, float
00181                                              rangeStart, float rangeEnd)
00182 {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00184
00185 #endif
00186
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMarchingSquaresCases.h Source File

Common/vtkMarchingSquaresCases.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMarchingSquaresCases.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 #ifndef __vtkMarchingSquaresCases_h
00017 #define __vtkMarchingSquaresCases_h
00018 //
00019 // marching squares cases for generating isolines
00020 //
00021
00022 typedef int EDGE_LIST;
00023 struct VTK_COMMON_EXPORT VTK_LINE_CASES
00024 {
00025   EDGE_LIST edges[5];
00026   static VTK_LINE_CASES* GetCases();
00027 };
00028
00029 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMaskFields.h Source File

Graphics/vtkMaskFields.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMaskFields.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkMaskFields_h
00040 #define __vtkMaskFields_h
00041
00042 #include "vtkDataSetToDataSetFilter.h"
00043
00044 class vtkDataSet;
00045
00046 class VTK_GRAPHICS_EXPORT vtkMaskFields : public vtkDataSetToDataSetFilter
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkMaskFields,vtkDataSetToDataSetFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053   static vtkMaskFields *New();
00054
00056
00065   void CopyFieldOn(int fieldLocation, const char* name) { this->CopyFieldOnOff(fieldLocation, name, 1); }
00066   void CopyFieldOff(int fieldLocation, const char* name) { this->CopyFieldOnOff(fieldLocation, name, 0); }
00068
00069
00071
00081   void CopyAttributeOn(int attributeLocation, int attributeType) { this->CopyAttributeOnOff(attributeLocation, attributeType, 1); }
00082   void CopyAttributeOff(int attributeLocation, int attributeType) { this->CopyAttributeOnOff(attributeLocation, attributeType, 0); }
00084
00086
00088   void CopyFieldsOff() { this->CopyFields = 0; }
00089   void CopyAttributesOff() { this->CopyAttributes = 0; }
00091
00092   void CopyFieldsOn() { this->CopyFields = 1; }
00093   void CopyAttributesOn() { this->CopyAttributes = 1; }
00094
00096
00098   void CopyAttributeOn(const char* attributeLoc,
00099                        const char* attributeType);
00100   void CopyAttributeOff(const char* attributeLoc,
00101                         const char* attributeType);
00102   void CopyFieldOn(const char* fieldLoc,
00103                    const char* name);
00104   void CopyFieldOff(const char* fieldLoc,
00105                     const char* name);
00107
00113   virtual void CopyAllOn();
00114
00120   virtual void CopyAllOff();
00121
00122   vtkMaskFields();
00123   virtual ~vtkMaskFields();
00124
00125 //BTX
00126   enum FieldLocation
00127     {
00128       OBJECT_DATA=0,
00129       POINT_DATA=1,
00130       CELL_DATA=2
00131     };
00132 //ETX
00133
00134 protected:
00135
00136   void Execute();
00137
00138 //BTX
00139   struct CopyFieldFlag
00140   {
00141     char* Name;
00142     int Type;
00143     int Location;
00144     int IsCopied;
00145   };
00146 //ETX
00147
00148   CopyFieldFlag* CopyFieldFlags; // the names of fields not to be copied
00149   int NumberOfFieldFlags; // the number of fields not to be copied
00150   void CopyFieldOnOff(int fieldLocation, const char* name, int onOff);
00151   void CopyAttributeOnOff(int attributeLocation, int attributeType, int onOff);
00152   void ClearFieldFlags();
00153   int FindFlag(const char* field, int location);
00154   int FindFlag(int arrayType, int location);
00155   int GetFlag(const char* field, int location);
00156   int GetFlag(int arrayType, int location);
00157   int GetAttributeLocation(const char* loc);
00158   int GetAttributeType(const char* type);
00159
00160   int CopyFields;
00161   int CopyAttributes;
00162
00163   static char FieldLocationNames[3][12];
00164   static char AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10];
00165
00166 private:
00167   vtkMaskFields(const vtkMaskFields&);  // Not implemented.
00168   void operator=(const vtkMaskFields&);  // Not implemented.
00169 };
00170
00171 #endif
00172
00173
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMaskPoints.h Source File

Graphics/vtkMaskPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMaskPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkMaskPoints_h
00046 #define __vtkMaskPoints_h
00047
00048 #include "vtkDataSetToPolyDataFilter.h"
00049
00050 class VTK_GRAPHICS_EXPORT vtkMaskPoints : public vtkDataSetToPolyDataFilter
00051 {
00052 public:
00053   static vtkMaskPoints *New();
00054   vtkTypeRevisionMacro(vtkMaskPoints,vtkDataSetToPolyDataFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkSetClampMacro(OnRatio,int,1,VTK_LARGE_INTEGER);
00060   vtkGetMacro(OnRatio,int);
00062
00064
00065   vtkSetClampMacro(MaximumNumberOfPoints,vtkIdType,0,VTK_LARGE_ID);
00066   vtkGetMacro(MaximumNumberOfPoints,vtkIdType);
00068
00070
00071   vtkSetClampMacro(Offset,vtkIdType,0,VTK_LARGE_ID);
00072   vtkGetMacro(Offset,vtkIdType);
00074
00076
00078   vtkSetMacro(RandomMode,int);
00079   vtkGetMacro(RandomMode,int);
00080   vtkBooleanMacro(RandomMode,int);
00082
00084
00088   vtkSetMacro(GenerateVertices,int);
00089   vtkGetMacro(GenerateVertices,int);
00090   vtkBooleanMacro(GenerateVertices,int);
00092
00093 protected:
00094   vtkMaskPoints();
00095   ~vtkMaskPoints() {};
00096
00097   void Execute();
00098
00099   int OnRatio;     // every OnRatio point is on; all others are off.
00100   vtkIdType Offset;      // offset (or starting point id)
00101   int RandomMode;  // turn on/off randomization
00102   vtkIdType MaximumNumberOfPoints;
00103   int GenerateVertices; //generate polydata verts
00104 private:
00105   vtkMaskPoints(const vtkMaskPoints&);  // Not implemented.
00106   void operator=(const vtkMaskPoints&);  // Not implemented.
00107 };
00108
00109 #endif
00110
00111
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMaskPolyData.h Source File

Graphics/vtkMaskPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMaskPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkMaskPolyData_h
00038 #define __vtkMaskPolyData_h
00039
00040 #include "vtkPolyDataToPolyDataFilter.h"
00041
00042 class VTK_GRAPHICS_EXPORT vtkMaskPolyData : public vtkPolyDataToPolyDataFilter
00043 {
00044 public:
00045   static vtkMaskPolyData *New();
00046   vtkTypeRevisionMacro(vtkMaskPolyData,vtkPolyDataToPolyDataFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   vtkSetClampMacro(OnRatio,int,1,VTK_LARGE_INTEGER);
00052   vtkGetMacro(OnRatio,int);
00054
00056
00057   vtkSetClampMacro(Offset,vtkIdType,0,VTK_LARGE_ID);
00058   vtkGetMacro(Offset,vtkIdType);
00060
00061 protected:
00062   vtkMaskPolyData();
00063   ~vtkMaskPolyData() {};
00064
00065   void Execute();
00066   int OnRatio; // every OnRatio entity is on; all others are off.
00067   vtkIdType Offset;  // offset (or starting point id)
00068 private:
00069   vtkMaskPolyData(const vtkMaskPolyData&);  // Not implemented.
00070   void operator=(const vtkMaskPolyData&);  // Not implemented.
00071 };
00072
00073 #endif
00074
00075
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMassProperties.h Source File

Graphics/vtkMassProperties.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMassProperties.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkMassProperties_h
00054 #define __vtkMassProperties_h
00055
00056 #include "vtkProcessObject.h"
00057 #include "vtkPolyData.h"
00058
00059 class VTK_GRAPHICS_EXPORT vtkMassProperties : public vtkProcessObject
00060 {
00061 public:
00063   static vtkMassProperties *New();
00064
00065   vtkTypeRevisionMacro(vtkMassProperties,vtkProcessObject);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   double GetVolume() {this->Update(); return this->Volume;}
00070
00072
00074   double GetVolumeX() {this->Update(); return this->VolumeX;}
00075   double GetVolumeY() {this->Update(); return this->VolumeY;}
00076   double GetVolumeZ() {this->Update(); return this->VolumeZ;}
00078
00080
00082   double GetKx() {this->Update(); return this->Kx;}
00083   double GetKy() {this->Update(); return this->Ky;}
00084   double GetKz() {this->Update(); return this->Kz;}
00086
00088   double GetSurfaceArea() {this->Update(); return this->SurfaceArea;}
00089
00091
00094   double GetNormalizedShapeIndex()
00095     {this->Update(); return this->NormalizedShapeIndex;}
00097
00098   void Update();
00099
00100   void SetInput(vtkPolyData *input);
00101   vtkPolyData *GetInput();
00102
00103 protected:
00104   vtkMassProperties();
00105   ~vtkMassProperties();
00106
00107   void Execute();
00108
00109   double  SurfaceArea;
00110   double  Volume;
00111   double  VolumeX;
00112   double  VolumeY;
00113   double  VolumeZ;
00114   double  Kx;
00115   double  Ky;
00116   double  Kz;
00117   double  NormalizedShapeIndex;
00118   vtkTimeStamp ExecuteTime;
00119
00120 private:
00121   vtkMassProperties(const vtkMassProperties&);  // Not implemented.
00122   void operator=(const vtkMassProperties&);  // Not implemented.
00123 };
00124
00125 #endif
00126
00127
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMath.h Source File

Common/vtkMath.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMath.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkMath_h
00045 #define __vtkMath_h
00046
00047 #include "vtkObject.h"
00048
00049 class VTK_COMMON_EXPORT vtkMath : public vtkObject
00050 {
00051 public:
00052   static vtkMath *New();
00053   vtkTypeRevisionMacro(vtkMath,vtkObject);
00054
00056
00057   static float Pi() {return 3.14159265358979;};
00058   static float DegreesToRadians() {return 0.017453292;};
00060
00062   static double DoubleDegreesToRadians() {return 0.017453292519943295;};
00063
00065
00066   static int Round(float f) {
00067     return static_cast<int>(f + (f >= 0 ? 0.5 : -0.5)); }
00068   static int Round(double f) {
00069     return static_cast<int>(f + (f >= 0 ? 0.5 : -0.5)); }
00071
00073
00074   static float Dot(const float x[3], const float y[3]) {
00075     return (x[0]*y[0] + x[1]*y[1] + x[2]*y[2]);};
00077
00079
00080   static double Dot(const double x[3], const double y[3]) {
00081     return (x[0]*y[0] + x[1]*y[1] + x[2]*y[2]);};
00083
00085   static void Cross(const float x[3], const float y[3], float z[3]);
00086
00089   static void Cross(const double x[3], const double y[3], double z[3]);
00090
00092   static float Norm(const float* x, int n);
00093
00095
00096   static float Norm(const float x[3]) {
00097     return sqrt(x[0]*x[0] + x[1]*x[1] + x[2]*x[2]);};
00099
00101
00102   static double Norm(const double x[3]) {
00103     return sqrt(x[0]*x[0] + x[1]*x[1] + x[2]*x[2]);};
00105
00107   static float Normalize(float x[3]);
00108
00111   static double Normalize(double x[3]);
00112
00114
00119   static void Perpendiculars(const double x[3], double y[3], double z[3],
00120                              double theta);
00121   static void Perpendiculars(const float x[3], float y[3], float z[3],
00122                              double theta);
00124
00126   static float Distance2BetweenPoints(const float x[3], const float y[3]);
00127
00130   static double Distance2BetweenPoints(const double x[3], const double y[3]);
00131
00133
00134   static float Dot2D(const float x[3], const float y[3]) {
00135     return (x[0]*y[0] + x[1]*y[1]);};
00137
00139
00141   static double Dot2D(const double x[3], const double y[3]) {
00142     return (x[0]*y[0] + x[1]*y[1]);};
00144
00146
00147   static float Norm2D(const float x[3]) {
00148     return sqrt(x[0]*x[0] + x[1]*x[1]);};
00150
00152
00154   static double Norm2D(const double x[3]) {
00155     return sqrt(x[0]*x[0] + x[1]*x[1]);};
00157
00160   static float Normalize2D(float x[3]);
00161
00164   static double Normalize2D(double x[3]);
00165
00167
00168   static float Determinant2x2(const float c1[2], const float c2[2]) {
00169     return (c1[0]*c2[1] - c2[0]*c1[1]);};
00171
00173
00174   static double Determinant2x2(double a, double b, double c, double d) {
00175     return (a * d - b * c);};
00177
00179
00181   static void LUFactor3x3(float A[3][3], int index[3]);
00182   static void LUFactor3x3(double A[3][3], int index[3]);
00184
00186
00188   static void LUSolve3x3(const float A[3][3], const int index[3],
00189                          float x[3]);
00190   static void LUSolve3x3(const double A[3][3], const int index[3],
00191                          double x[3]);
00193
00195
00197   static void LinearSolve3x3(const float A[3][3], const float x[3],
00198                              float y[3]);
00199   static void LinearSolve3x3(const double A[3][3], const double x[3],
00200                              double y[3]);
00202
00204
00205   static void Multiply3x3(const float A[3][3], const float in[3],
00206                           float out[3]);
00207   static void Multiply3x3(const double A[3][3], const double in[3],
00208                           double out[3]);
00210
00212
00213   static void Multiply3x3(const float A[3][3], const float B[3][3],
00214                           float C[3][3]);
00215   static void Multiply3x3(const double A[3][3], const double B[3][3],
00216                           double C[3][3]);
00218
00220
00221   static void Transpose3x3(const float A[3][3], float AT[3][3]);
00222   static void Transpose3x3(const double A[3][3], double AT[3][3]);
00224
00226
00227   static void Invert3x3(const float A[3][3], float AI[3][3]);
00228   static void Invert3x3(const double A[3][3], double AI[3][3]);
00230
00232
00233   static void Identity3x3(float A[3][3]);
00234   static void Identity3x3(double A[3][3]);
00236
00238
00239   static double Determinant3x3(float A[3][3]);
00240   static double Determinant3x3(double A[3][3]);
00242
00244
00245   static float Determinant3x3(const float c1[3],
00246                               const float c2[3],
00247                               const float c3[3]);
00249
00251
00253   static double Determinant3x3(double a1, double a2, double a3,
00254                                double b1, double b2, double b3,
00255                                double c1, double c2, double c3);
00257
00259
00261   static void QuaternionToMatrix3x3(const float quat[4], float A[3][3]);
00262   static void QuaternionToMatrix3x3(const double quat[4], double A[3][3]);
00264
00266
00269   static void Matrix3x3ToQuaternion(const float A[3][3], float quat[4]);
00270   static void Matrix3x3ToQuaternion(const double A[3][3], double quat[4]);
00272
00274
00277   static void Orthogonalize3x3(const float A[3][3], float B[3][3]);
00278   static void Orthogonalize3x3(const double A[3][3], double B[3][3]);
00280
00282
00286   static void Diagonalize3x3(const float A[3][3], float w[3], float V[3][3]);
00287   static void Diagonalize3x3(const double A[3][3],double w[3],double V[3][3]);
00289
00291
00298   static void SingularValueDecomposition3x3(const float A[3][3],
00299                                             float U[3][3], float w[3],
00300                                             float VT[3][3]);
00301   static void SingularValueDecomposition3x3(const double A[3][3],
00302                                             double U[3][3], double w[3],
00303                                             double VT[3][3]);
00305
00310   static int SolveLinearSystem(double **A, double *x, int size);
00311
00315   static int InvertMatrix(double **A, double **AI, int size);
00316
00318
00320   static int InvertMatrix(double **A, double **AI, int size,
00321                           int *tmp1Size, double *tmp2Size);
00323
00329   static int LUFactorLinearSystem(double **A, int *index, int size);
00330
00332
00334   static int LUFactorLinearSystem(double **A, int *index, int size,
00335                                   double *tmpSize);
00337
00339
00345   static void LUSolveLinearSystem(double **A, int *index,
00346                                   double *x, int size);
00348
00356   static double EstimateMatrixCondition(double **A, int size);
00357
00363   static void RandomSeed(long s);
00364
00367   static float Random();
00368
00370   static float Random(float min, float max);
00371
00373
00377   static int Jacobi(float **a, float *w, float **v);
00378   static int Jacobi(double **a, double *w, double **v);
00380
00382
00387   static int JacobiN(float **a, int n, float *w, float **v);
00388   static int JacobiN(double **a, int n, double *w, double **v);
00390
00397   static double* SolveCubic(double c0, double c1, double c2, double c3);
00398
00405   static double* SolveQuadratic(double c0, double c1, double c2);
00406
00410   static double* SolveLinear(double c0, double c1);
00411
00413
00424   static int SolveCubic(double c0, double c1, double c2, double c3,
00425                         double *r1, double *r2, double *r3, int *num_roots);
00427
00429
00433   static int SolveQuadratic(double c0, double c1, double c2,
00434                             double *r1, double *r2, int *num_roots);
00436
00441   static int SolveLinear(double c0, double c1, double *r1, int *num_roots);
00442
00443
00445
00452   static int SolveLeastSquares(int numberOfSamples, double **xt, int xOrder,
00453                                double **yt, int yOrder, double **mt);
00455
00456 protected:
00457   vtkMath() {};
00458   ~vtkMath() {};
00459
00460   static long Seed;
00461 private:
00462   vtkMath(const vtkMath&);  // Not implemented.
00463   void operator=(const vtkMath&);  // Not implemented.
00464 };
00465
00466 inline float vtkMath::Normalize(float x[3])
00467 {
00468   float den;
00469   if ( (den = vtkMath::Norm(x)) != 0.0 )
00470     {
00471     for (int i=0; i < 3; i++)
00472       {
00473       x[i] /= den;
00474       }
00475     }
00476   return den;
00477 }
00478 inline double vtkMath::Normalize(double x[3])
00479 {
00480   double den;
00481   if ( (den = vtkMath::Norm(x)) != 0.0 )
00482     {
00483     for (int i=0; i < 3; i++)
00484       {
00485       x[i] /= den;
00486       }
00487     }
00488   return den;
00489 }
00490
00491 inline float vtkMath::Normalize2D(float x[3])
00492 {
00493   float den;
00494   if ( (den = vtkMath::Norm2D(x)) != 0.0 )
00495     {
00496     for (int i=0; i < 2; i++)
00497       {
00498       x[i] /= den;
00499       }
00500     }
00501   return den;
00502 }
00503
00504 inline double vtkMath::Normalize2D(double x[3])
00505 {
00506   double den;
00507   if ( (den = vtkMath::Norm2D(x)) != 0.0 )
00508     {
00509     for (int i=0; i < 2; i++)
00510       {
00511       x[i] /= den;
00512       }
00513     }
00514   return den;
00515 }
00516
00517 inline float vtkMath::Determinant3x3(const float c1[3],
00518                                      const float c2[3],
00519                                      const float c3[3])
00520 {
00521   return c1[0]*c2[1]*c3[2] + c2[0]*c3[1]*c1[2] + c3[0]*c1[1]*c2[2] -
00522          c1[0]*c3[1]*c2[2] - c2[0]*c1[1]*c3[2] - c3[0]*c2[1]*c1[2];
00523 }
00524
00525 inline double vtkMath::Determinant3x3(double a1, double a2, double a3,
00526                                       double b1, double b2, double b3,
00527                                       double c1, double c2, double c3)
00528 {
00529     return ( a1 * vtkMath::Determinant2x2( b2, b3, c2, c3 )
00530            - b1 * vtkMath::Determinant2x2( a2, a3, c2, c3 )
00531            + c1 * vtkMath::Determinant2x2( a2, a3, b2, b3 ) );
00532 }
00533
00534 inline float vtkMath::Distance2BetweenPoints(const float x[3],
00535                                              const float y[3])
00536 {
00537   return ((x[0]-y[0])*(x[0]-y[0]) + (x[1]-y[1])*(x[1]-y[1]) +
00538           (x[2]-y[2])*(x[2]-y[2]));
00539 }
00540 inline double vtkMath::Distance2BetweenPoints(const double x[3],
00541                                               const double y[3])
00542 {
00543   return ((x[0]-y[0])*(x[0]-y[0]) + (x[1]-y[1])*(x[1]-y[1]) +
00544           (x[2]-y[2])*(x[2]-y[2]));
00545 }
00546
00547 inline float vtkMath::Random(float min, float max)
00548 {
00549   return (min + vtkMath::Random()*(max-min));
00550 }
00551
00552 // Cross product of two 3-vectors. Result vector in z[3].
00553 inline void vtkMath::Cross(const float x[3], const float y[3], float z[3])
00554 {
00555   float Zx = x[1]*y[2] - x[2]*y[1];
00556   float Zy = x[2]*y[0] - x[0]*y[2];
00557   float Zz = x[0]*y[1] - x[1]*y[0];
00558   z[0] = Zx; z[1] = Zy; z[2] = Zz;
00559 }
00560
00561 // Cross product of two 3-vectors. Result vector in z[3].
00562 inline void vtkMath::Cross(const double x[3], const double y[3], double z[3])
00563 {
00564   double Zx = x[1]*y[2] - x[2]*y[1];
00565   double Zy = x[2]*y[0] - x[0]*y[2];
00566   double Zz = x[0]*y[1] - x[1]*y[0];
00567   z[0] = Zx; z[1] = Zy; z[2] = Zz;
00568 }
00569
00570 //BTX
00571 //----------------------------------------------------------------------------
00572 template<class T>
00573 static inline double vtkDeterminant3x3(T A[3][3])
00574 {
00575   return A[0][0]*A[1][1]*A[2][2] + A[1][0]*A[2][1]*A[0][2] +
00576          A[2][0]*A[0][1]*A[1][2] - A[0][0]*A[2][1]*A[1][2] -
00577          A[1][0]*A[0][1]*A[2][2] - A[2][0]*A[1][1]*A[0][2];
00578 }
00579 //ETX
00580
00581 inline double vtkMath::Determinant3x3(float A[3][3])
00582 {
00583   return vtkDeterminant3x3(A);
00584 }
00585
00586 inline double vtkMath::Determinant3x3(double A[3][3])
00587 {
00588   return vtkDeterminant3x3(A);
00589 }
00590
00591
00592 #endif
Generated on Mon Mar 25 01:07:35 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMatrix4x4.h Source File

Common/vtkMatrix4x4.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMatrix4x4.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkMatrix4x4_h
00044 #define __vtkMatrix4x4_h
00045
00046 #include "vtkObject.h"
00047
00048 class VTK_COMMON_EXPORT vtkMatrix4x4 : public vtkObject
00049 {
00050   // Some of the methods in here have a corresponding static (class)
00051   // method taking a pointer to 16 doubles that constitutes a user
00052   // supplied matrix. This allows C++ clients to allocate double arrays
00053   // on the stack and manipulate them using vtkMatrix4x4 methods.
00054   // This is an alternative to allowing vtkMatrix4x4 instances to be
00055   // created on the stack (which is frowned upon) or doing lots of
00056   // temporary heap allocation within vtkTransform and vtkActor methods,
00057   // which is inefficient.
00058
00059 public:
00060   double Element[4][4];
00061
00063   static vtkMatrix4x4 *New();
00064
00065   vtkTypeRevisionMacro(vtkMatrix4x4,vtkObject);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069
00071   void DeepCopy(vtkMatrix4x4 *source)
00072     {vtkMatrix4x4::DeepCopy(*this->Element,source); this->Modified(); }
00074 //BTX
00075   static void DeepCopy(double Elements[16], vtkMatrix4x4 *source)
00076     {vtkMatrix4x4::DeepCopy(Elements,*source->Element); }
00077   static void DeepCopy(double Elements[16], const double newElements[16]);
00078 //ETX
00079
00081
00082   void DeepCopy(const double Elements[16])
00083     { this->DeepCopy(*this->Element,Elements); this->Modified(); }
00085
00087
00088   void Zero()
00089     { vtkMatrix4x4::Zero(*this->Element); this->Modified(); }
00091 //BTX
00092   static void Zero(double Elements[16]);
00093 //ETX
00094
00096
00097   void Identity()
00098     { vtkMatrix4x4::Identity(*this->Element); this->Modified();}
00100 //BTX
00101   static void Identity(double Elements[16]);
00102 //ETX
00103
00105
00107   static void Invert(vtkMatrix4x4 *in, vtkMatrix4x4 *out)
00108     {vtkMatrix4x4::Invert(*in->Element,*out->Element); out->Modified(); }
00109   void Invert()
00110     { vtkMatrix4x4::Invert(this,this); }
00112 //BTX
00113   static void Invert(const double inElements[16], double outElements[16]);
00114 //ETX
00115
00116
00118
00119   static void Transpose(vtkMatrix4x4 *in, vtkMatrix4x4 *out)
00120     {vtkMatrix4x4::Transpose(*in->Element,*out->Element); out->Modified(); }
00121   void Transpose()
00122     { vtkMatrix4x4::Transpose(this,this); }
00124 //BTX
00125   static void Transpose(const double inElements[16], double outElements[16]);
00126 //ETX
00127
00129
00131   void MultiplyPoint(const float in[4], float out[4])
00132     {vtkMatrix4x4::MultiplyPoint(*this->Element,in,out); }
00133   void MultiplyPoint(const double in[4], double out[4])
00134     {vtkMatrix4x4::MultiplyPoint(*this->Element,in,out); }
00136
00137 //BTX
00138   static void MultiplyPoint(const double Elements[16],
00139                             const float in[4], float out[4]);
00140   static void MultiplyPoint(const double Elements[16],
00141                             const double in[4], double out[4]);
00142 //ETX
00143
00145
00147   float *MultiplyPoint(const float in[4])
00148     {return this->MultiplyFloatPoint(in); }
00149   float *MultiplyFloatPoint(const float in[4])
00150     {this->MultiplyPoint(in,this->FloatPoint); return this->FloatPoint; }
00151   double *MultiplyDoublePoint(const double in[4])
00152     {this->MultiplyPoint(in,this->DoublePoint); return this->DoublePoint; }
00154
00156
00157   static void Multiply4x4(vtkMatrix4x4 *a, vtkMatrix4x4 *b, vtkMatrix4x4 *c) {
00158     vtkMatrix4x4::Multiply4x4(*a->Element,*b->Element,*c->Element); };
00160 //BTX
00161   static void Multiply4x4(const double a[16], const double b[16],
00162                           double c[16]);
00163 //ETX
00164
00166
00167   void Adjoint(vtkMatrix4x4 *in, vtkMatrix4x4 *out)
00168     {vtkMatrix4x4::Adjoint(*in->Element,*out->Element);}
00170 //BTX
00171   static void Adjoint(const double inElements[16], double outElements[16]);
00172 //ETX
00173
00175   double Determinant() {return vtkMatrix4x4::Determinant(*this->Element);}
00176 //BTX
00177   static double Determinant(const double Elements[16]);
00178 //ETX
00179
00181   void SetElement(int i, int j, double value);
00182
00184
00185   double GetElement(int i, int j) const
00186     {return this->Element[i][j];}
00188
00189 //BTX
00190   double *operator[](const unsigned int i)
00191     {return &(this->Element[i][0]);}
00192   const double *operator[](unsigned int i) const
00193     { return &(this->Element[i][0]); }
00194   void operator= (double element);
00195   void Adjoint(vtkMatrix4x4 &in,vtkMatrix4x4 &out)
00196     {this->Adjoint(&in,&out);}
00197   double Determinant(vtkMatrix4x4 &in)
00198     {return this->Determinant(&in);}
00199   double Determinant(vtkMatrix4x4 *in)
00200     {return vtkMatrix4x4::Determinant(*in->Element);}
00201   void Invert(vtkMatrix4x4 &in,vtkMatrix4x4 &out)
00202     {this->Invert(&in,&out);}
00203   void Transpose(vtkMatrix4x4 &in,vtkMatrix4x4 &out)
00204     {this->Transpose(&in,&out);}
00205   static void PointMultiply(const double Elements[16],
00206                             const float in[4], float out[4]);
00207   static void PointMultiply(const double Elements[16],
00208                             const double in[4], double out[4]);
00209 //ETX
00210
00211 protected:
00212   vtkMatrix4x4() { vtkMatrix4x4::Identity(*this->Element); };
00213   ~vtkMatrix4x4() {};
00214
00215   float FloatPoint[4];
00216   double DoublePoint[4];
00217 private:
00218   vtkMatrix4x4(const vtkMatrix4x4&);  // Not implemented.
00219   void operator= (const vtkMatrix4x4& source);  // Not implemented.
00220 };
00221
00222 inline void vtkMatrix4x4::SetElement(int i, int j, double value)
00223 {
00224   if (this->Element[i][j] != value)
00225     {
00226     this->Element[i][j] = value;
00227     this->Modified();
00228     }
00229 }
00230
00231 #endif
00232
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMatrixToHomogeneousTransform.h Source File

Common/vtkMatrixToHomogeneousTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMatrixToHomogeneousTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00041 #ifndef __vtkMatrixToHomogeneousTransform_h
00042 #define __vtkMatrixToHomogeneousTransform_h
00043
00044 #include "vtkHomogeneousTransform.h"
00045 #include "vtkMatrix4x4.h"
00046
00047 class VTK_COMMON_EXPORT vtkMatrixToHomogeneousTransform :
00048   public vtkHomogeneousTransform
00049 {
00050  public:
00051   static vtkMatrixToHomogeneousTransform *New();
00052   vtkTypeRevisionMacro(vtkMatrixToHomogeneousTransform,vtkHomogeneousTransform);
00053   void PrintSelf (ostream& os, vtkIndent indent);
00054
00055   // Set the input matrix.  Any modifications to the matrix will be
00056   // reflected in the transformation.
00057   vtkSetObjectMacro(Input,vtkMatrix4x4);
00058   vtkGetObjectMacro(Input,vtkMatrix4x4);
00059
00062   void Inverse();
00063
00065   unsigned long GetMTime();
00066
00068   vtkAbstractTransform *MakeTransform();
00069
00071
00072   void SetMatrix(vtkMatrix4x4 *matrix) {
00073     this->SetInput(matrix);
00074     vtkWarningMacro("SetMatrix: deprecated, use SetInput() instead"); }
00076
00077 protected:
00078   vtkMatrixToHomogeneousTransform();
00079   ~vtkMatrixToHomogeneousTransform();
00080
00081   void InternalUpdate();
00082   void InternalDeepCopy(vtkAbstractTransform *transform);
00083
00084   int InverseFlag;
00085   vtkMatrix4x4 *Input;
00086 private:
00087   vtkMatrixToHomogeneousTransform(const vtkMatrixToHomogeneousTransform&);  // Not implemented.
00088   void operator=(const vtkMatrixToHomogeneousTransform&);  // Not implemented.
00089 };
00090
00091 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMatrixToLinearTransform.h Source File

Common/vtkMatrixToLinearTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMatrixToLinearTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00041 #ifndef __vtkMatrixToLinearTransform_h
00042 #define __vtkMatrixToLinearTransform_h
00043
00044 #include "vtkLinearTransform.h"
00045 #include "vtkMatrix4x4.h"
00046
00047 class VTK_COMMON_EXPORT vtkMatrixToLinearTransform : public vtkLinearTransform
00048 {
00049  public:
00050   static vtkMatrixToLinearTransform *New();
00051   vtkTypeRevisionMacro(vtkMatrixToLinearTransform,vtkLinearTransform);
00052   void PrintSelf (ostream& os, vtkIndent indent);
00053
00055
00057   vtkSetObjectMacro(Input,vtkMatrix4x4);
00058   vtkGetObjectMacro(Input,vtkMatrix4x4);
00060
00063   void Inverse();
00064
00066   unsigned long GetMTime();
00067
00069   vtkAbstractTransform *MakeTransform();
00070
00072
00073   void SetMatrix(vtkMatrix4x4 *matrix) {
00074     this->SetInput(matrix);
00075     vtkWarningMacro("SetMatrix: deprecated, use SetInput() instead"); }
00077
00078 protected:
00079   vtkMatrixToLinearTransform();
00080   ~vtkMatrixToLinearTransform();
00081
00082   void InternalUpdate();
00083   void InternalDeepCopy(vtkAbstractTransform *transform);
00084
00085   int InverseFlag;
00086   vtkMatrix4x4 *Input;
00087 private:
00088   vtkMatrixToLinearTransform(const vtkMatrixToLinearTransform&);  // Not implemented.
00089   void operator=(const vtkMatrixToLinearTransform&);  // Not implemented.
00090 };
00091
00092 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkMCubesReader.h Source File

IO/vtkMCubesReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMCubesReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00068 #ifndef __vtkMCubesReader_h
00069 #define __vtkMCubesReader_h
00070
00071 #include <stdio.h>
00072 #include "vtkPolyDataSource.h"
00073 #include "vtkPoints.h"
00074 #include "vtkCellArray.h"
00075
00076 #define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
00077 #define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1
00078
00079 class VTK_IO_EXPORT vtkMCubesReader : public vtkPolyDataSource
00080 {
00081 public:
00082   vtkTypeRevisionMacro(vtkMCubesReader,vtkPolyDataSource);
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084
00086   static vtkMCubesReader *New();
00087
00089
00090   vtkSetStringMacro(FileName);
00091   vtkGetStringMacro(FileName);
00093
00095
00096   vtkSetStringMacro(LimitsFileName);
00097   vtkGetStringMacro(LimitsFileName);
00099
00101
00103   vtkSetClampMacro(HeaderSize,int,0,VTK_LARGE_INTEGER);
00104   vtkGetMacro(HeaderSize,int);
00106
00108
00112   vtkSetMacro(FlipNormals,int);
00113   vtkGetMacro(FlipNormals,int);
00114   vtkBooleanMacro(FlipNormals,int);
00116
00118
00119   vtkSetMacro(Normals,int);
00120   vtkGetMacro(Normals,int);
00121   vtkBooleanMacro(Normals,int);
00123
00125
00135   void SetDataByteOrderToBigEndian();
00136   void SetDataByteOrderToLittleEndian();
00137   int GetDataByteOrder();
00138   void SetDataByteOrder(int);
00139   const char *GetDataByteOrderAsString();
00141
00143
00144   vtkSetMacro(SwapBytes,int);
00145   vtkGetMacro(SwapBytes,int);
00146   vtkBooleanMacro(SwapBytes,int);
00148
00150
00152   void SetLocator(vtkPointLocator *locator);
00153   vtkGetObjectMacro(Locator,vtkPointLocator);
00155
00157   void CreateDefaultLocator();
00158
00160   unsigned long GetMTime();
00161
00162 protected:
00163   vtkMCubesReader();
00164   ~vtkMCubesReader();
00165
00166   void Execute();
00167
00168   char *FileName;
00169   char *LimitsFileName;
00170   vtkPointLocator *Locator;
00171   int SwapBytes;
00172   int HeaderSize;
00173   int FlipNormals;
00174   int Normals;
00175
00176 private:
00177   vtkMCubesReader(const vtkMCubesReader&);  // Not implemented.
00178   void operator=(const vtkMCubesReader&);  // Not implemented.
00179 };
00180
00181 #endif
00182
00183
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkMCubesWriter.h Source File

IO/vtkMCubesWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMCubesWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkMCubesWriter_h
00049 #define __vtkMCubesWriter_h
00050
00051 #include <stdio.h>
00052 #include "vtkPolyDataWriter.h"
00053
00054 class VTK_IO_EXPORT vtkMCubesWriter : public vtkPolyDataWriter
00055 {
00056 public:
00057   static vtkMCubesWriter *New();
00058   vtkTypeRevisionMacro(vtkMCubesWriter,vtkPolyDataWriter);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   vtkSetStringMacro(LimitsFileName);
00064   vtkGetStringMacro(LimitsFileName);
00066
00067 protected:
00068   vtkMCubesWriter();
00069   ~vtkMCubesWriter();
00070
00071   void WriteData();
00072   char *LimitsFileName;
00073 private:
00074   vtkMCubesWriter(const vtkMCubesWriter&);  // Not implemented.
00075   void operator=(const vtkMCubesWriter&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkMedicalImageReader2.h Source File

IO/vtkMedicalImageReader2.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMedicalImageReader2.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMedicalImageReader2_h
00037 #define __vtkMedicalImageReader2_h
00038
00039 #include "vtkImageReader2.h"
00040
00041
00042 class VTK_IO_EXPORT vtkMedicalImageReader2 : public vtkImageReader2
00043 {
00044 public:
00045   static vtkMedicalImageReader2 *New();
00046   vtkTypeRevisionMacro(vtkMedicalImageReader2,vtkImageReader2);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   vtkSetStringMacro(PatientName);
00052   vtkGetStringMacro(PatientName);
00053   vtkSetStringMacro(PatientID);
00054   vtkGetStringMacro(PatientID);
00055   vtkSetStringMacro(Date);
00056   vtkGetStringMacro(Date);
00057   vtkSetStringMacro(Series);
00058   vtkGetStringMacro(Series);
00059   vtkSetStringMacro(Study);
00060   vtkGetStringMacro(Study);
00061   vtkSetStringMacro(ImageNumber);
00062   vtkGetStringMacro(ImageNumber);
00064
00065 protected:
00066   vtkMedicalImageReader2();
00067   ~vtkMedicalImageReader2();
00068
00069   // store header info
00070   char *PatientName;
00071   char *PatientID;
00072   char *Date;
00073   char *ImageNumber;
00074   char *Study;
00075   char *Series;
00076
00077 private:
00078   vtkMedicalImageReader2(const vtkMedicalImageReader2&); // Not implemented.
00079   void operator=(const vtkMedicalImageReader2&); // Not implemented.
00080 };
00081
00082 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMemoryLimitImageDataStreamer.h Source File

Parallel/vtkMemoryLimitImageDataStreamer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMemoryLimitImageDataStreamer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMemoryLimitImageDataStreamer_h
00034 #define __vtkMemoryLimitImageDataStreamer_h
00035
00036 #include "vtkImageDataStreamer.h"
00037
00038
00039 class VTK_PARALLEL_EXPORT vtkMemoryLimitImageDataStreamer : public vtkImageDataStreamer
00040 {
00041 public:
00042   static vtkMemoryLimitImageDataStreamer *New();
00043   vtkTypeRevisionMacro(vtkMemoryLimitImageDataStreamer,vtkImageDataStreamer);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00047
00048   vtkSetMacro(MemoryLimit, unsigned long);
00049   vtkGetMacro(MemoryLimit, unsigned long);
00051
00053   void UpdateData( vtkDataObject *out );
00054
00055 protected:
00056   vtkMemoryLimitImageDataStreamer();
00057   ~vtkMemoryLimitImageDataStreamer() {};
00058
00059   unsigned long  MemoryLimit;
00060 private:
00061   vtkMemoryLimitImageDataStreamer(const vtkMemoryLimitImageDataStreamer&);  // Not implemented.
00062   void operator=(const vtkMemoryLimitImageDataStreamer&);  // Not implemented.
00063 };
00064
00065
00066
00067
00068 #endif
00069
00070
00071
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMergeDataObjectFilter.h Source File

Graphics/vtkMergeDataObjectFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMergeDataObjectFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkMergeDataObjectFilter_h
00051 #define __vtkMergeDataObjectFilter_h
00052
00053 #include "vtkDataSetToDataSetFilter.h"
00054 #include "vtkFieldDataToAttributeDataFilter.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkMergeDataObjectFilter : public vtkDataSetToDataSetFilter
00057 {
00058 public:
00059   static vtkMergeDataObjectFilter *New();
00060   vtkTypeRevisionMacro(vtkMergeDataObjectFilter,vtkDataSetToDataSetFilter);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00065   void SetDataObject(vtkDataObject *object);
00066   vtkDataObject *GetDataObject();
00068
00070
00074   vtkSetMacro(OutputField,int);
00075   vtkGetMacro(OutputField,int);
00076   void SetOutputFieldToDataObjectField()
00077     {this->SetOutputField(VTK_DATA_OBJECT_FIELD);};
00078   void SetOutputFieldToPointDataField()
00079     {this->SetOutputField(VTK_POINT_DATA_FIELD);};
00080   void SetOutputFieldToCellDataField()
00081     {this->SetOutputField(VTK_CELL_DATA_FIELD);};
00083
00084 protected:
00085   vtkMergeDataObjectFilter();
00086   ~vtkMergeDataObjectFilter();
00087
00088   // Usual data generation method
00089   void Execute();
00090
00091   int OutputField; // which output field
00092
00093 private:
00094   vtkMergeDataObjectFilter(const vtkMergeDataObjectFilter&);  // Not implemented.
00095   void operator=(const vtkMergeDataObjectFilter&);  // Not implemented.
00096 };
00097
00098 #endif
00099
00100
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMergeFields.h Source File

Graphics/vtkMergeFields.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMergeFields.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkMergeFields_h
00058 #define __vtkMergeFields_h
00059
00060 #include "vtkDataSetToDataSetFilter.h"
00061
00062 class vtkFieldData;
00063
00064 class VTK_GRAPHICS_EXPORT vtkMergeFields : public vtkDataSetToDataSetFilter
00065 {
00066 public:
00067   vtkTypeRevisionMacro(vtkMergeFields,vtkDataSetToDataSetFilter);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00071   static vtkMergeFields *New();
00072
00075   void SetOutputField(const char* name, int fieldLoc);
00076
00080   void SetOutputField(const char* name, const char* fieldLoc);
00081
00083   void Merge(int component, const char* arrayName, int sourceComp);
00084
00086
00088   vtkSetMacro(NumberOfComponents, int);
00090
00091 //BTX
00092   enum FieldLocations
00093   {
00094     DATA_OBJECT=0,
00095     POINT_DATA=1,
00096     CELL_DATA=2
00097   };
00098 //ETX
00099
00100 //BTX
00101   struct Component
00102   {
00103     int Index;
00104     int SourceIndex;
00105     char* FieldName;
00106     Component* Next;   // linked list
00107     void SetName(const char* name)
00108       {
00109         delete[] this->FieldName;
00110         this->FieldName = 0;
00111         if (name)
00112           {
00113           this->FieldName = new char[strlen(name)+1];
00114           strcpy(this->FieldName, name);
00115           }
00116       }
00117     Component() { FieldName = 0; }
00118     ~Component() { delete[] FieldName; }
00119   };
00120 //ETX
00121
00122 protected:
00123
00124 //BTX
00125   enum FieldType
00126   {
00127     NAME,
00128     ATTRIBUTE
00129   };
00130 //ETX
00131
00132   vtkMergeFields();
00133   virtual ~vtkMergeFields();
00134
00135   void Execute();
00136
00137   char* FieldName;
00138   int FieldLocation;
00139   int NumberOfComponents;
00140   int OutputDataType;
00141
00142   static char FieldLocationNames[3][12];
00143
00144
00145   int MergeArray(vtkDataArray* in, vtkDataArray* out, int inComp, int outComp);
00146
00147   // Components are stored as a linked list.
00148   Component* Head;
00149   Component* Tail;
00150
00151   // Methods to browse/modify the linked list.
00152   Component* GetNextComponent(Component* op)
00153     { return op->Next; }
00154   Component* GetFirst()
00155     { return this->Head; }
00156   void AddComponent(Component* op);
00157   Component* FindComponent(int index);
00158   void DeleteAllComponents();
00159
00160   void PrintComponent(Component* op, ostream& os, vtkIndent indent)
00161     {
00162       os << indent << "Field name: " << op->FieldName << endl;
00163       os << indent << "Component index: " << op->Index << endl;
00164       os << indent << "Source component index: " << op->SourceIndex << endl;
00165     }
00166
00167   void PrintAllComponents(ostream& os, vtkIndent indent)
00168     {
00169       Component* cur = this->GetFirst();
00170       if (!cur) { return; }
00171       Component* before;
00172       do
00173         {
00174         before = cur;
00175         cur = cur->Next;
00176         os << endl;
00177         this->PrintComponent(before, os, indent);
00178         }
00179       while (cur);
00180     }
00181 private:
00182   vtkMergeFields(const vtkMergeFields&);  // Not implemented.
00183   void operator=(const vtkMergeFields&);  // Not implemented.
00184 };
00185
00186 #endif
00187
00188
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkMergeFilter.h Source File

Graphics/vtkMergeFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMergeFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkMergeFilter_h
00044 #define __vtkMergeFilter_h
00045
00046 #include "vtkDataSetToDataSetFilter.h"
00047
00048 class vtkFieldList;
00049
00050 class VTK_GRAPHICS_EXPORT vtkMergeFilter : public vtkDataSetToDataSetFilter
00051 {
00052 public:
00053   static vtkMergeFilter *New();
00054   vtkTypeRevisionMacro(vtkMergeFilter,vtkDataSetToDataSetFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   void SetGeometry(vtkDataSet *input) {this->SetInput(input);};
00060   vtkDataSet *GetGeometry() {return this->GetInput();};
00062
00064
00065   void SetScalars(vtkDataSet *);
00066   vtkDataSet *GetScalars();
00068
00070
00071   void SetVectors(vtkDataSet *);
00072   vtkDataSet *GetVectors();
00074
00076
00077   void SetNormals(vtkDataSet *);
00078   vtkDataSet *GetNormals();
00080
00082
00084   void SetTCoords(vtkDataSet *);
00085   vtkDataSet *GetTCoords();
00087
00089
00090   void SetTensors(vtkDataSet *);
00091   vtkDataSet *GetTensors();
00093
00096   void AddField(const char* name, vtkDataSet* input);
00097
00098 protected:
00099   vtkMergeFilter();
00100   ~vtkMergeFilter();
00101
00102   // Usual data generation method
00103   void Execute();
00104   void ComputeInputUpdateExtents(vtkDataObject *data);
00105
00106   vtkFieldList* FieldList;
00107 private:
00108   vtkMergeFilter(const vtkMergeFilter&);  // Not implemented.
00109   void operator=(const vtkMergeFilter&);  // Not implemented.
00110   };
00111
00112 #endif
00113
00114
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkMergePoints2D.h Source File

Filtering/vtkMergePoints2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMergePoints2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMergePoints2D_h
00037 #define __vtkMergePoints2D_h
00038
00039 #include "vtkPointLocator2D.h"
00040
00041 class VTK_FILTERING_EXPORT vtkMergePoints2D : public vtkPointLocator2D
00042 {
00043 public:
00044   static vtkMergePoints2D *New();
00045   vtkTypeRevisionMacro(vtkMergePoints2D,vtkPointLocator2D);
00046
00050   int IsInsertedPoint(float x[2]);
00051
00052 protected:
00053   vtkMergePoints2D() {};
00054   ~vtkMergePoints2D() {};
00055
00056 private:
00057   vtkMergePoints2D(const vtkMergePoints2D&);  // Not implemented.
00058   void operator=(const vtkMergePoints2D&);  // Not implemented.
00059 };
00060
00061 #endif
00062
00063
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkMergePoints.h Source File

Filtering/vtkMergePoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMergePoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkMergePoints_h
00043 #define __vtkMergePoints_h
00044
00045 #include "vtkPointLocator.h"
00046
00047 class VTK_FILTERING_EXPORT vtkMergePoints : public vtkPointLocator
00048 {
00049 public:
00050   static vtkMergePoints *New();
00051   vtkTypeRevisionMacro(vtkMergePoints,vtkPointLocator);
00052
00054
00057   vtkIdType IsInsertedPoint(const float x[3]);
00058   vtkIdType IsInsertedPoint(float x, float  y, float z)
00059     {return this->vtkPointLocator::IsInsertedPoint(x, y, z); };
00061
00068   int InsertUniquePoint(const float x[3], vtkIdType &ptId);
00069
00070 protected:
00071   vtkMergePoints() {};
00072   ~vtkMergePoints() {};
00073
00074 private:
00075   vtkMergePoints(const vtkMergePoints&);  // Not implemented.
00076   void operator=(const vtkMergePoints&);  // Not implemented.
00077 };
00078
00079 #endif
00080
00081
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaActor.h Source File

Rendering/vtkMesaActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkMesaActor_h
00040 #define __vtkMesaActor_h
00041
00042 #include "vtkActor.h"
00043
00044 class vtkMesaRenderer;
00045
00046 class VTK_RENDERING_EXPORT vtkMesaActor : public vtkActor
00047 {
00048 protected:
00049
00050 public:
00051   static vtkMesaActor *New();
00052   vtkTypeRevisionMacro(vtkMesaActor,vtkActor);
00053
00055   void Render(vtkRenderer *ren, vtkMapper *mapper);
00056
00059   vtkProperty* MakeProperty();
00060 protected:
00061   vtkMesaActor() {};
00062   ~vtkMesaActor() {};
00063
00064 private:
00065   vtkMesaActor(const vtkMesaActor&);  // Not implemented.
00066   void operator=(const vtkMesaActor&);  // Not implemented.
00067 };
00068
00069 #endif
00070
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaCamera.h Source File

Rendering/vtkMesaCamera.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaCamera.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaCamera_h
00034 #define __vtkMesaCamera_h
00035
00036 #include "vtkCamera.h"
00037
00038 class vtkMesaRenderer;
00039
00040 class VTK_RENDERING_EXPORT vtkMesaCamera : public vtkCamera
00041 {
00042 public:
00043   static vtkMesaCamera *New();
00044   vtkTypeRevisionMacro(vtkMesaCamera,vtkCamera);
00045
00047   void Render(vtkRenderer *ren);
00048
00049   void UpdateViewport(vtkRenderer *ren);
00050
00051 protected:
00052   vtkMesaCamera() {};
00053   ~vtkMesaCamera() {};
00054 private:
00055   vtkMesaCamera(const vtkMesaCamera&);  // Not implemented.
00056   void operator=(const vtkMesaCamera&);  // Not implemented.
00057 };
00058
00059 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaImageActor.h Source File

Rendering/vtkMesaImageActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaImageActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaImageActor_h
00034 #define __vtkMesaImageActor_h
00035
00036 #include "vtkImageActor.h"
00037
00038 class vtkWindow;
00039 class vtkMesaRenderer;
00040 class vtkRenderWindow;
00041
00042 class VTK_RENDERING_EXPORT vtkMesaImageActor : public vtkImageActor
00043 {
00044 public:
00045   static vtkMesaImageActor *New();
00046   vtkTypeRevisionMacro(vtkMesaImageActor,vtkImageActor);
00047
00049   void Load(vtkRenderer *ren);
00050
00055   void ReleaseGraphicsResources(vtkWindow *);
00056
00057 protected:
00058   vtkMesaImageActor();
00059   ~vtkMesaImageActor();
00060
00061   unsigned char *MakeDataSuitable(int &xsize, int &ysize, int &release);
00062
00063   vtkTimeStamp   LoadTime;
00064   long          Index;
00065   static   long GlobalIndex;
00066   vtkRenderWindow *RenderWindow;   // RenderWindow used for previous render
00067   float Coords[12];
00068   float TCoords[8];
00069 private:
00070   vtkMesaImageActor(const vtkMesaImageActor&);  // Not implemented.
00071   void operator=(const vtkMesaImageActor&);  // Not implemented.
00072 };
00073
00074 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaImageMapper.h Source File

Rendering/vtkMesaImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMesaImageMapper_h
00037 #define __vtkMesaImageMapper_h
00038
00039
00040 #include "vtkImageMapper.h"
00041 class vtkActor2D;
00042
00043
00044 class VTK_RENDERING_EXPORT vtkMesaImageMapper : public vtkImageMapper
00045 {
00046 public:
00047   static vtkMesaImageMapper *New();
00048   vtkTypeRevisionMacro(vtkMesaImageMapper,vtkImageMapper);
00049
00051
00052   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor) {
00053     this->RenderStart(viewport,actor);}
00055
00057
00059   void RenderData(vtkViewport* viewport, vtkImageData* data,
00060                   vtkActor2D* actor);
00062
00063 protected:
00064   vtkMesaImageMapper();
00065   ~vtkMesaImageMapper();
00066
00067 private:
00068   vtkMesaImageMapper(const vtkMesaImageMapper&);  // Not implemented.
00069   void operator=(const vtkMesaImageMapper&);  // Not implemented.
00070 };
00071
00072
00073 #endif
00074
00075
00076
00077
00078
00079
00080
00081
00082
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaImager.h Source File

Rendering/vtkMesaImager.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaImager.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMesaImager_h
00037 #define __vtkMesaImager_h
00038
00039 #include "vtkImager.h"
00040
00041 class VTK_RENDERING_EXPORT vtkMesaImager : public vtkImager
00042 {
00043 public:
00044   static vtkMesaImager *New();
00045   vtkTypeRevisionMacro(vtkMesaImager,vtkImager);
00046
00049   int RenderOpaqueGeometry();
00050
00052   void Erase();
00053
00054 protected:
00055   vtkMesaImager() {};
00056   ~vtkMesaImager() {};
00057 private:
00058   vtkMesaImager(const vtkMesaImager&);  // Not implemented.
00059   void operator=(const vtkMesaImager&);  // Not implemented.
00060 };
00061
00062
00063 #endif
00064
00065
00066
00067
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaImageWindow.h Source File

Rendering/vtkMesaImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaImageWindow_h
00034 #define __vtkMesaImageWindow_h
00035
00036 #include "MangleMesaInclude/glx_mangle.h"
00037 #include "MangleMesaInclude/glx.h"
00038 #include "MangleMesaInclude/osmesa.h"
00039
00040 #include <stdlib.h>
00041 #include <X11/X.h>
00042 #include <X11/Xlib.h>
00043 #include <X11/Xutil.h>
00044 #include "vtkToolkits.h"
00045 #include "vtkXImageWindow.h"
00046
00047
00048
00049 class VTK_RENDERING_EXPORT vtkMesaImageWindow : public vtkXImageWindow
00050 {
00051 public:
00052   static vtkMesaImageWindow *New();
00053   vtkTypeRevisionMacro(vtkMesaImageWindow,vtkXImageWindow);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   virtual void MakeDefaultWindow();
00058
00060   void SwapBuffers();
00061
00063   void Frame();
00064
00066   void Render();
00067
00069
00070   virtual void *GetGenericDisplayId() {return (void *)this->DisplayId;};
00071   virtual void *GetGenericWindowId();
00072   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00073   virtual void *GetGenericContext();
00074   virtual void *GetGenericDrawable()  {return (void *)this->WindowId;};
00076
00078
00079   virtual Colormap GetDesiredColormap();
00080   virtual Visual  *GetDesiredVisual();
00081   XVisualInfo     *GetDesiredVisualInfo();
00082   virtual int      GetDesiredDepth();
00084
00086
00087   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00088   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00089                             int front);
00091
00093
00094   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00095   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00096                                 int blend=0);
00098
00100   void MakeCurrent();
00101
00103   virtual void EraseWindow() {this->vtkImageWindow::EraseWindow();};
00104
00107   virtual void SetOffScreenRendering(int i);
00108
00109 protected:
00110   vtkMesaImageWindow();
00111   ~vtkMesaImageWindow();
00112
00113   GLXContext ContextId;
00114   OSMesaContext OffScreenContextId;
00115   void *OffScreenWindow;
00116   int ScreenDoubleBuffer;
00117   int ScreenMapped;
00118 private:
00119   vtkMesaImageWindow(const vtkMesaImageWindow&);  // Not implemented.
00120   void operator=(const vtkMesaImageWindow&);  // Not implemented.
00121 };
00122
00123
00124 #endif
00125
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaLight.h Source File

Rendering/vtkMesaLight.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaLight.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaLight_h
00034 #define __vtkMesaLight_h
00035
00036 #include "vtkLight.h"
00037
00038 class vtkMesaRenderer;
00039
00040 class VTK_RENDERING_EXPORT vtkMesaLight : public vtkLight
00041 {
00042 public:
00043   static vtkMesaLight *New();
00044   vtkTypeRevisionMacro(vtkMesaLight,vtkLight);
00045
00047   void Render(vtkRenderer *ren,int light_index);
00048
00049 protected:
00050   vtkMesaLight() {};
00051   ~vtkMesaLight() {};
00052 private:
00053   vtkMesaLight(const vtkMesaLight&);  // Not implemented.
00054   void operator=(const vtkMesaLight&);  // Not implemented.
00055 };
00056
00057 #endif
00058
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaPolyDataMapper2D.h Source File

Rendering/vtkMesaPolyDataMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaPolyDataMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkMesaPolyDataMapper2D_h
00038 #define __vtkMesaPolyDataMapper2D_h
00039
00040 #include "vtkPolyDataMapper2D.h"
00041
00042 class VTK_RENDERING_EXPORT vtkMesaPolyDataMapper2D : public vtkPolyDataMapper2D
00043 {
00044 public:
00045   vtkTypeRevisionMacro(vtkMesaPolyDataMapper2D,vtkPolyDataMapper2D);
00046   static vtkMesaPolyDataMapper2D *New();
00047
00049   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00050
00051 protected:
00052   vtkMesaPolyDataMapper2D() {};
00053   ~vtkMesaPolyDataMapper2D() {};
00054
00055 private:
00056   vtkMesaPolyDataMapper2D(const vtkMesaPolyDataMapper2D&);  // Not implemented.
00057   void operator=(const vtkMesaPolyDataMapper2D&);  // Not implemented.
00058 };
00059
00060
00061 #endif
00062
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaPolyDataMapper.h Source File

Rendering/vtkMesaPolyDataMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaPolyDataMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkMesaPolyDataMapper_h
00041 #define __vtkMesaPolyDataMapper_h
00042
00043 #include "MangleMesaInclude/gl_mangle.h"
00044 #include "MangleMesaInclude/gl.h"
00045
00046 #include "vtkPolyDataMapper.h"
00047 #include <stdlib.h>
00048 #include "vtkToolkits.h"
00049
00050
00051 class vtkProperty;
00052 class vtkRenderWindow;
00053 class vtkMesaRenderer;
00054 class vtkTimerLog;
00055
00056 class VTK_RENDERING_EXPORT vtkMesaPolyDataMapper : public vtkPolyDataMapper
00057 {
00058 public:
00059   static vtkMesaPolyDataMapper *New();
00060   vtkTypeRevisionMacro(vtkMesaPolyDataMapper,vtkPolyDataMapper);
00061
00063   virtual void RenderPiece(vtkRenderer *ren, vtkActor *a);
00064
00068   void ReleaseGraphicsResources(vtkWindow *);
00069
00071   virtual int Draw(vtkRenderer *ren, vtkActor *a);
00072
00073   //BTX  begin tcl exclude
00074
00076
00080   GLenum GetLmcolorMode(vtkProperty *prop);
00081   //ETX
00083
00084 protected:
00085   vtkMesaPolyDataMapper();
00086   ~vtkMesaPolyDataMapper();
00087
00088   int ListId;
00089   vtkRenderWindow *RenderWindow;   // RenderWindow used for the previous render
00090 private:
00091   vtkMesaPolyDataMapper(const vtkMesaPolyDataMapper&);  // Not implemented.
00092   void operator=(const vtkMesaPolyDataMapper&);  // Not implemented.
00093 };
00094
00095 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaProperty.h Source File

Rendering/vtkMesaProperty.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaProperty.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaProperty_h
00034 #define __vtkMesaProperty_h
00035
00036 #include "vtkProperty.h"
00037
00038 class vtkMesaRenderer;
00039
00040 class VTK_RENDERING_EXPORT vtkMesaProperty : public vtkProperty
00041 {
00042 public:
00043   static vtkMesaProperty *New();
00044   vtkTypeRevisionMacro(vtkMesaProperty,vtkProperty);
00045
00047   void Render(vtkActor *a, vtkRenderer *ren);
00048
00050   void BackfaceRender(vtkActor *a, vtkRenderer *ren);
00051
00052 protected:
00053   vtkMesaProperty() {};
00054   ~vtkMesaProperty() {};
00055 private:
00056   vtkMesaProperty(const vtkMesaProperty&);  // Not implemented.
00057   void operator=(const vtkMesaProperty&);  // Not implemented.
00058 };
00059
00060 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaRenderer.h Source File

Rendering/vtkMesaRenderer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaRenderer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkMesaRenderer_h
00041 #define __vtkMesaRenderer_h
00042
00043 #include <stdlib.h>
00044 #include "vtkRenderer.h"
00045
00046 class VTK_RENDERING_EXPORT vtkMesaRenderer : public vtkRenderer
00047 {
00048 protected:
00049   int NumberOfLightsBound;
00050
00051 public:
00052   static vtkMesaRenderer *New();
00053   vtkTypeRevisionMacro(vtkMesaRenderer,vtkRenderer);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   void DeviceRender(void);
00058
00061   void ClearLights(void);
00062
00063   void Clear(void);
00064
00066   int UpdateLights(void);
00067
00068
00069
00070   // Create a vtkMesaCamera, will be used by the super class
00071   // to create the correct camera object.
00072   virtual vtkCamera* MakeCamera();
00073
00074   // Create a vtkMesaLight, will be used by the super class
00075   // to create the correct light object.
00076   virtual vtkLight* MakeLight();
00077
00078 protected:
00079   vtkMesaRenderer();
00080   ~vtkMesaRenderer();
00081
00082   //BTX
00083   // Picking functions to be implemented by sub-classes
00084   virtual void DevicePickRender();
00085   virtual void StartPick(unsigned int pickFromSize);
00086   virtual void UpdatePickId();
00087   virtual void DonePick();
00088   virtual unsigned int GetPickedId();
00089   virtual float GetPickedZ();
00090   // Ivars used in picking
00091   class vtkGLPickInfo* PickInfo;
00092   //ETX
00093   float PickedZ;
00094 private:
00095   vtkMesaRenderer(const vtkMesaRenderer&);  // Not implemented.
00096   void operator=(const vtkMesaRenderer&);  // Not implemented.
00097 };
00098
00099 #endif
Generated on Mon Mar 25 01:07:57 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaRenderWindow.h Source File

Rendering/vtkMesaRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkMesaRenderWindow_h
00038 #define __vtkMesaRenderWindow_h
00039
00040 #include "MangleMesaInclude/gl_mangle.h"
00041 #include <MangleMesaInclude/gl.h>
00042
00043
00044
00045 #include <stdlib.h>
00046 #include "vtkRenderWindow.h"
00047
00048 class vtkIdList;
00049
00050 class VTK_RENDERING_EXPORT vtkMesaRenderWindow : public vtkRenderWindow
00051 {
00052 protected:
00053   int MultiSamples;
00054   long OldMonitorSetting;
00055
00056 public:
00057   vtkTypeRevisionMacro(vtkMesaRenderWindow,vtkRenderWindow);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00062   static void SetGlobalMaximumNumberOfMultiSamples(int val);
00063   static int  GetGlobalMaximumNumberOfMultiSamples();
00065
00067
00069   vtkSetMacro(MultiSamples,int);
00070   vtkGetMacro(MultiSamples,int);
00072
00074   virtual void StereoUpdate();
00075
00077
00078   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00079   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00080                             int front);
00082
00084
00085   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00086   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00087                                 int blend=0);
00088   virtual void ReleaseRGBAPixelData(float *data);
00089   virtual unsigned char *GetRGBACharPixelData(int x,int y,int x2,int y2,
00090                                               int front);
00091   virtual void SetRGBACharPixelData(int x,int y,int x2,int y2,unsigned char *,
00092                                     int front, int blend=0);
00094
00096
00097   virtual float *GetZbufferData( int x1, int y1, int x2, int y2 );
00098   virtual void SetZbufferData( int x1, int y1, int x2, int y2, float *buffer );
00100
00102   void MakeCurrent() = 0;
00103
00105   void RegisterTextureResource (GLuint id);
00106
00108   int GetDepthBufferSize();
00109
00111   virtual void OpenGLInit();
00112
00113 protected:
00114   vtkMesaRenderWindow();
00115   ~vtkMesaRenderWindow();
00116
00117   vtkIdList *TextureResourceIds;
00118 private:
00119   vtkMesaRenderWindow(const vtkMesaRenderWindow&);  // Not implemented.
00120   void operator=(const vtkMesaRenderWindow&);  // Not implemented.
00121 };
00122
00123 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaTexture.h Source File

Rendering/vtkMesaTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkMesaTexture_h
00034 #define __vtkMesaTexture_h
00035
00036 #include "vtkTexture.h"
00037
00038 class vtkWindow;
00039 class vtkMesaRenderer;
00040 class vtkRenderWindow;
00041
00042 class VTK_RENDERING_EXPORT vtkMesaTexture : public vtkTexture
00043 {
00044 public:
00045   static vtkMesaTexture *New();
00046   vtkTypeRevisionMacro(vtkMesaTexture,vtkTexture);
00047
00049   void Load(vtkRenderer *ren);
00050
00055   void ReleaseGraphicsResources(vtkWindow *);
00056
00057 protected:
00058   vtkMesaTexture();
00059   ~vtkMesaTexture();
00060
00061   unsigned char *ResampleToPowerOfTwo(int &xsize, int &ysize,
00062                                       unsigned char *dptr, int bpp);
00063
00064   vtkTimeStamp   LoadTime;
00065   long          Index;
00066   static   long GlobalIndex;
00067   vtkRenderWindow *RenderWindow;   // RenderWindow used for previous render
00068 private:
00069   vtkMesaTexture(const vtkMesaTexture&);  // Not implemented.
00070   void operator=(const vtkMesaTexture&);  // Not implemented.
00071 };
00072
00073 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaVolumeRayCastMapper.h Source File

Rendering/vtkMesaVolumeRayCastMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaVolumeRayCastMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00039 #ifndef __vtkMesaVolumeRayCastMapper_h
00040 #define __vtkMesaVolumeRayCastMapper_h
00041
00042 #include "MangleMesaInclude/gl_mangle.h"
00043 #include "MangleMesaInclude/gl.h"
00044
00045 #include "vtkVolumeRayCastMapper.h"
00046 #include <stdlib.h>
00047 #include "vtkToolkits.h"
00048
00049
00050 class VTK_RENDERING_EXPORT vtkMesaVolumeRayCastMapper : public vtkVolumeRayCastMapper
00051 {
00052 public:
00053   static vtkMesaVolumeRayCastMapper *New();
00054   vtkTypeRevisionMacro(vtkMesaVolumeRayCastMapper,vtkVolumeRayCastMapper);
00055
00056 protected:
00057   vtkMesaVolumeRayCastMapper();
00058   ~vtkMesaVolumeRayCastMapper();
00059
00060   void RenderTexture( vtkVolume *vol, vtkRenderer *ren);
00061
00062 private:
00063   vtkMesaVolumeRayCastMapper(const vtkMesaVolumeRayCastMapper&);  // Not implemented.
00064   void operator=(const vtkMesaVolumeRayCastMapper&);  // Not implemented.
00065 };
00066
00067 #endif
00068
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkMesaVolumeTextureMapper2D.h Source File

Rendering/vtkMesaVolumeTextureMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMesaVolumeTextureMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMesaVolumeTextureMapper2D_h
00037 #define __vtkMesaVolumeTextureMapper2D_h
00038
00039 #include "vtkVolumeTextureMapper2D.h"
00040
00041 class VTK_RENDERING_EXPORT vtkMesaVolumeTextureMapper2D : public vtkVolumeTextureMapper2D
00042 {
00043 public:
00044   vtkTypeRevisionMacro(vtkMesaVolumeTextureMapper2D,vtkVolumeTextureMapper2D);
00045   void PrintSelf( ostream& os, vtkIndent index );
00046
00047   static vtkMesaVolumeTextureMapper2D *New();
00048
00049 //BTX
00050
00053   virtual void Render(vtkRenderer *ren, vtkVolume *vol);
00054
00055   void RenderQuads( int count, float *v, float *t,
00056                     unsigned char *texture, int size[2], int reverseFlag);
00057
00058 //ETX
00059
00060 protected:
00061   vtkMesaVolumeTextureMapper2D();
00062   ~vtkMesaVolumeTextureMapper2D();
00063
00064 private:
00065   vtkMesaVolumeTextureMapper2D(const vtkMesaVolumeTextureMapper2D&);  // Not implemented.
00066   void operator=(const vtkMesaVolumeTextureMapper2D&);  // Not implemented.
00067 };
00068
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkMILVideoSource.h Source File

Hybrid/vtkMILVideoSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMILVideoSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkMILVideoSource_h
00038 #define __vtkMILVideoSource_h
00039
00040 #include "vtkVideoSource.h"
00041
00042 // digitizer hardware
00043 #define VTK_MIL_DEFAULT       0
00044 #define VTK_MIL_METEOR        1
00045 #define VTK_MIL_METEOR_II     2
00046 #define VTK_MIL_METEOR_II_DIG 3
00047 #define VTK_MIL_CORONA        4
00048 #define VTK_MIL_PULSAR        5
00049 #define VTK_MIL_GENESIS       6
00050
00051 // video inputs:
00052 #define VTK_MIL_MONO          0
00053 #define VTK_MIL_COMPOSITE     1
00054 #define VTK_MIL_YC            2
00055 #define VTK_MIL_RGB           3
00056 #define VTK_MIL_DIGITAL       4
00057
00058 // video formats:
00059 #define VTK_MIL_RS170         0
00060 #define VTK_MIL_NTSC          1
00061 #define VTK_MIL_CCIR          2
00062 #define VTK_MIL_PAL           3
00063 #define VTK_MIL_SECAM         4
00064 #define VTK_MIL_NONSTANDARD   5
00065
00066 class VTK_HYBRID_EXPORT vtkMILVideoSource : public vtkVideoSource
00067 {
00068 public:
00069   static vtkMILVideoSource *New();
00070   vtkTypeRevisionMacro(vtkMILVideoSource,vtkVideoSource);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00074   void Record();
00075
00077   void Play();
00078
00080   void Stop();
00081
00083   void Grab();
00084
00086   void SetFrameSize(int x, int y, int z);
00087
00089   void SetOutputFormat(int format);
00090
00092
00093   virtual void SetVideoChannel(int channel);
00094   vtkGetMacro(VideoChannel, int);
00096
00098
00099   virtual void SetVideoFormat(int format);
00100   void SetVideoFormatToNTSC() { this->SetVideoFormat(VTK_MIL_NTSC); };
00101   void SetVideoFormatToPAL() { this->SetVideoFormat(VTK_MIL_PAL); };
00102   void SetVideoFormatToSECAM() { this->SetVideoFormat(VTK_MIL_SECAM); };
00103   void SetVideoFormatToRS170() { this->SetVideoFormat(VTK_MIL_RS170); };
00104   void SetVideoFormatToCCIR() { this->SetVideoFormat(VTK_MIL_CCIR); };
00105   void SetVideoFormatToNonStandard() {
00106     this->SetVideoFormat(VTK_MIL_NONSTANDARD); };
00107   vtkGetMacro(VideoFormat,int);
00109
00111
00112   virtual void SetVideoInput(int input);
00113   void SetVideoInputToMono() { this->SetVideoInput(VTK_MIL_MONO); };
00114   void SetVideoInputToComposite() {this->SetVideoInput(VTK_MIL_COMPOSITE);};
00115   void SetVideoInputToYC() { this->SetVideoInput(VTK_MIL_YC); };
00116   void SetVideoInputToRGB() { this->SetVideoInput(VTK_MIL_RGB); };
00117   void SetVideoInputToDigital() { this->SetVideoInput(VTK_MIL_DIGITAL); };
00118   vtkGetMacro(VideoInput,int);
00120
00122
00124   virtual void SetContrastLevel(float contrast);
00125   vtkGetMacro(ContrastLevel,float);
00126   virtual void SetBrightnessLevel(float brightness);
00127   vtkGetMacro(BrightnessLevel,float);
00128   virtual void SetHueLevel(float hue);
00129   vtkGetMacro(HueLevel,float);
00130   virtual void SetSaturationLevel(float saturation);
00131   vtkGetMacro(SaturationLevel,float);
00133
00135
00137   vtkSetMacro(MILSystemType,int);
00138   vtkGetMacro(MILSystemType,int);
00139   void SetMILSystemTypeToMeteor() { this->SetMILSystemType(VTK_MIL_METEOR); };
00140   void SetMILSystemTypeToMeteorII() { this->SetMILSystemType(VTK_MIL_METEOR_II); };
00141   void SetMILSystemTypeToCorona() { this->SetMILSystemType(VTK_MIL_CORONA); };
00142   void SetMILSystemTypeToPulsar() { this->SetMILSystemType(VTK_MIL_PULSAR); };
00143   void SetMILSystemTypeToMeteorIIDig() { this->SetMILSystemType(VTK_MIL_METEOR_II_DIG); };
00144   void SetMILSystemTypeToGenesis() { this->SetMILSystemType(VTK_MIL_GENESIS); };
00146
00148
00149   vtkSetMacro(MILSystemNumber,int);
00150   vtkGetMacro(MILSystemNumber,int);
00152
00154
00155   vtkSetStringMacro(MILDigitizerDCF);
00156   vtkGetStringMacro(MILDigitizerDCF);
00158
00160
00161   vtkSetMacro(MILDigitizerNumber,int);
00162   vtkGetMacro(MILDigitizerNumber,int);
00164
00166
00167   virtual void SetMILErrorMessages(int yesno);
00168   vtkBooleanMacro(MILErrorMessages,int);
00169   vtkGetMacro(MILErrorMessages,int);
00171
00173
00174   vtkSetMacro(MILAppID,long);
00175   vtkGetMacro(MILAppID,long);
00176   vtkSetMacro(MILSysID,long);
00177   vtkGetMacro(MILSysID,long);
00178   vtkGetMacro(MILDigID,long);
00179   vtkGetMacro(MILBufID,long);
00181
00184   void Initialize();
00185
00187   void ReleaseSystemResources();
00188
00190
00191   void *OldHookFunction;
00192   void *OldUserDataPtr;
00193   int FrameCounter;
00194   int ForceGrab;
00195   void InternalGrab();
00197
00198 protected:
00199   vtkMILVideoSource();
00200   ~vtkMILVideoSource();
00201
00202   virtual void AllocateMILDigitizer();
00203   virtual void AllocateMILBuffer();
00204
00205   virtual void *MILInterpreterForSystem(int system);
00206   char *MILInterpreterDLL;
00207
00208   int VideoChannel;
00209   int VideoInput;
00210   int VideoInputForColor;
00211   int VideoFormat;
00212
00213   float ContrastLevel;
00214   float BrightnessLevel;
00215   float HueLevel;
00216   float SaturationLevel;
00217
00218   int FrameMaxSize[2];
00219
00220   long MILAppID;
00221   long MILSysID;
00222   long MILDigID;
00223   long MILBufID;
00224   // long MILDispBufID;
00225   // long MILDispID;
00226
00227   int MILSystemType;
00228   int MILSystemNumber;
00229
00230   int MILDigitizerNumber;
00231   char *MILDigitizerDCF;
00232
00233   int MILErrorMessages;
00234
00235   int MILAppInternallyAllocated;
00236   int MILSysInternallyAllocated;
00237
00238   int FatalMILError;
00239
00240 private:
00241   vtkMILVideoSource(const vtkMILVideoSource&);  // Not implemented.
00242   void operator=(const vtkMILVideoSource&);  // Not implemented.
00243 };
00244
00245 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMPICommunicator.h Source File

Parallel/vtkMPICommunicator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMPICommunicator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkMPICommunicator_h
00049 #define __vtkMPICommunicator_h
00050
00051 #include "mpi.h"
00052 #include "vtkCommunicator.h"
00053 #include "vtkMPIGroup.h"
00054
00055 class vtkMPIController;
00056
00057 class VTK_PARALLEL_EXPORT vtkMPICommunicator : public vtkCommunicator
00058 {
00059
00060 public:
00061
00062   vtkTypeRevisionMacro( vtkMPICommunicator,vtkObject);
00063
00065   static vtkMPICommunicator* New();
00066
00069   static vtkMPICommunicator* GetWorldCommunicator();
00070
00071   virtual void PrintSelf(ostream& os, vtkIndent indent);
00072
00077   int Initialize(vtkMPICommunicator* mpiComm, vtkMPIGroup* group);
00078
00080
00082   virtual int Send(int* data, int length, int remoteProcessId, int tag);
00083   virtual int Send(unsigned long* data, int length, int remoteProcessId,
00084                    int tag);
00085   virtual int Send(char* data, int length, int remoteProcessId, int tag);
00086   virtual int Send(unsigned char* data, int length, int remoteProcessId, int tag);
00087   virtual int Send(float* data, int length, int remoteProcessId,
00088                    int tag);
00089   virtual int Send(double* data, int length, int remoteProcessId,
00090                    int tag);
00091 #ifdef VTK_USE_64BIT_IDS
00092   virtual int Send(vtkIdType* data, int length, int remoteProcessId,
00093                    int tag);
00095 #endif
00096   virtual int Send(vtkDataObject* data, int remoteProcessId, int tag)
00097     { return this->vtkCommunicator::Send(data, remoteProcessId, tag); }
00098   virtual int Send(vtkDataArray* data, int remoteProcessId, int tag)
00099     { return this->vtkCommunicator::Send(data, remoteProcessId, tag); }
00100
00101 //BTX
00102
00103   class VTK_PARALLEL_EXPORT Request
00104   {
00105   public:
00106     int Test();
00107     void Cancel();
00108     void Wait();
00109     MPI_Request Req;
00110   };
00111
00112 //ETX
00113
00115
00119   int NoBlockSend(int* data, int length, int remoteProcessId, int tag,
00120                   Request& req);
00121   int NoBlockSend(unsigned long* data, int length, int remoteProcessId,
00122                   int tag, Request& req);
00123   int NoBlockSend(char* data, int length, int remoteProcessId,
00124                   int tag, Request& req);
00125   int NoBlockSend(float* data, int length, int remoteProcessId,
00126                   int tag, Request& req);
00128
00130
00132   virtual int Receive(int* data, int length, int remoteProcessId,
00133                       int tag);
00134   virtual int Receive(unsigned long* data, int length,
00135                       int remoteProcessId, int tag);
00136   virtual int Receive(char* data, int length, int remoteProcessId,
00137                       int tag);
00138   virtual int Receive(unsigned char* data, int length, int remoteProcessId,
00139                       int tag);
00140   virtual int Receive(float* data, int length, int remoteProcessId,
00141                       int tag);
00142   virtual int Receive(double* data, int length, int remoteProcessId,
00143                       int tag);
00144 #ifdef VTK_USE_64BIT_IDS
00145   virtual int Receive(vtkIdType* data, int length, int remoteProcessId,
00146                       int tag);
00148 #endif
00149   virtual int Receive(vtkDataObject* data, int remoteProcessId, int tag)
00150     { return this->vtkCommunicator::Receive(data, remoteProcessId, tag); }
00151   virtual int Receive(vtkDataArray* data, int remoteProcessId, int tag)
00152     { return this->vtkCommunicator::Receive(data, remoteProcessId, tag); }
00153
00155
00158   int NoBlockReceive(int* data, int length, int remoteProcessId,
00159                      int tag, Request& req);
00160   int NoBlockReceive(unsigned long* data, int length,
00161                      int remoteProcessId, int tag, Request& req);
00162   int NoBlockReceive(char* data, int length, int remoteProcessId,
00163                      int tag, Request& req);
00164   int NoBlockReceive(float* data, int length, int remoteProcessId,
00165                      int tag, Request& req);
00167
00168 //BTX
00169
00170   friend class vtkMPIController;
00171
00172 //ETX
00173
00174 protected:
00175
00176   vtkSetObjectMacro(Group, vtkMPIGroup);
00177
00179
00186   vtkSetMacro(KeepHandle, int);
00187   vtkBooleanMacro(KeepHandle, int);
00189
00190   static vtkMPICommunicator* WorldCommunicator;
00191
00192   void InitializeCopy(vtkMPICommunicator* source);
00193
00198   void CopyFrom(vtkMPICommunicator* source);
00199
00206   void Duplicate(vtkMPICommunicator* source);
00207
00208   MPI_Comm* Handle;
00209   vtkMPIGroup* Group;
00210
00211   int Initialized;
00212   int KeepHandle;
00213
00214   vtkMPICommunicator();
00215   ~vtkMPICommunicator();
00216
00217  private:
00218   static int CheckForMPIError(int err);
00219
00220 private:
00221   vtkMPICommunicator(const vtkMPICommunicator&);  // Not implemented.
00222   void operator=(const vtkMPICommunicator&);  // Not implemented.
00223 };
00224
00225
00226 #endif //  __vtkMPICommunicator_h
00227
00228
00229
00230
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMPIController.h Source File

Parallel/vtkMPIController.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMPIController.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkMPIController_h
00059 #define __vtkMPIController_h
00060
00061 #include "mpi.h"
00062
00063 #include "vtkMultiProcessController.h"
00064 #include "vtkMPICommunicator.h"
00065
00066
00067 class VTK_PARALLEL_EXPORT vtkMPIController : public vtkMultiProcessController
00068 {
00069
00070 public:
00071
00072   static vtkMPIController *New();
00073   vtkTypeRevisionMacro(vtkMPIController,vtkMultiProcessController);
00074   void PrintSelf(ostream& os, vtkIndent indent);
00075
00084   virtual void Initialize(int* argc, char*** arcv);
00085
00088   virtual void Finalize();
00089
00092   virtual void SingleMethodExecute();
00093
00097   virtual void MultipleMethodExecute();
00098
00101   void Barrier();
00102
00105   virtual void CreateOutputWindow();
00106
00109   static char* ErrorString(int err);
00110
00111
00117   void SetCommunicator(vtkMPICommunicator* comm);
00118
00119 //BTX
00120
00122
00127   int NoBlockSend(int* data, int length, int remoteProcessId, int tag,
00128                   vtkMPICommunicator::Request& req)
00129     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockSend
00130         (data ,length, remoteProcessId, tag, req); }
00131   int NoBlockSend(unsigned long* data, int length, int remoteProcessId,
00132                   int tag, vtkMPICommunicator::Request& req)
00133     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockSend
00134         (data, length, remoteProcessId, tag, req); }
00135   int NoBlockSend(char* data, int length, int remoteProcessId,
00136                   int tag, vtkMPICommunicator::Request& req)
00137     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockSend
00138         (data, length, remoteProcessId, tag, req); }
00139   int NoBlockSend(float* data, int length, int remoteProcessId,
00140                   int tag, vtkMPICommunicator::Request& req)
00141     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockSend
00142         (data, length, remoteProcessId, tag, req); }
00144
00146
00150   int NoBlockReceive(int* data, int length, int remoteProcessId,
00151                      int tag, vtkMPICommunicator::Request& req)
00152     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockReceive
00153         (data, length, remoteProcessId, tag, req); }
00154   int NoBlockReceive(unsigned long* data, int length,
00155                      int remoteProcessId, int tag,
00156                      vtkMPICommunicator::Request& req)
00157     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockReceive
00158         (data, length, remoteProcessId, tag, req); }
00159   int NoBlockReceive(char* data, int length, int remoteProcessId,
00160                      int tag, vtkMPICommunicator::Request& req)
00161     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockReceive
00162         (data, length, remoteProcessId, tag, req); }
00163   int NoBlockReceive(float* data, int length, int remoteProcessId,
00164                      int tag, vtkMPICommunicator::Request& req)
00165     { return ((vtkMPICommunicator*)this->Communicator)->NoBlockReceive
00166         (data, length, remoteProcessId, tag, req); }
00168
00169 //ETX
00170
00171   static const char* GetProcessorName();
00172
00173 protected:
00174
00175   vtkMPIController();
00176   ~vtkMPIController();
00177
00178   // Given a communicator, obtain size and rank
00179   // setting NumberOfProcesses and LocalProcessId
00180   // Should not be called if the current communicator
00181   // does not include this process
00182   int InitializeNumberOfProcesses();
00183
00184   // Set the communicator to comm and call InitializeNumberOfProcesses()
00185   void InitializeCommunicator(vtkMPICommunicator* comm);
00186
00187   // Duplicate the current communicator, creating RMICommunicator
00188   void InitializeRMICommunicator();
00189
00190   // MPI communicator created when Initialize() called.
00191   // This is a copy of MPI_COMM_WORLD but uses a new
00192   // context, i.e. even if the tags are the same, the
00193   // RMI messages will not interfere with user level
00194   // messages.
00195   static vtkMPICommunicator* WorldRMICommunicator;
00196
00197   // Initialize only once.
00198   static int Initialized;
00199
00200   static char ProcessorName[MPI_MAX_PROCESSOR_NAME];
00201
00202 private:
00203   vtkMPIController(const vtkMPIController&);  // Not implemented.
00204   void operator=(const vtkMPIController&);  // Not implemented.
00205 };
00206
00207
00208 #endif
00209
00210
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMPIEventLog.h Source File

Parallel/vtkMPIEventLog.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMPIEventLog.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkMPIEventLog_h
00043 #define __vtkMPIEventLog_h
00044
00045 #include "vtkObject.h"
00046 #include "vtkMPIController.h"
00047
00048 class VTK_PARALLEL_EXPORT vtkMPIEventLog : public vtkObject
00049 {
00050
00051 public:
00052
00053   vtkTypeRevisionMacro(vtkMPIEventLog,vtkObject);
00054
00057   static vtkMPIEventLog* New();
00058
00064   int SetDescription(const char* name, const char* desc);
00065
00067
00070   static void InitializeLogging();
00071   static void FinalizeLogging(const char* fileName);
00073
00075
00076   void StartLogging();
00077   void StopLogging();
00079
00080   virtual void PrintSelf(ostream& os, vtkIndent indent);
00081
00082 protected:
00083
00084   vtkMPIEventLog();
00085   ~vtkMPIEventLog();
00086
00087   static int LastEventId;
00088   int Active;
00089   int BeginId;
00090   int EndId;
00091 private:
00092   vtkMPIEventLog(const vtkMPIEventLog&);  // Not implemented.
00093   void operator=(const vtkMPIEventLog&);  // Not implemented.
00094 };
00095
00096 #endif
00097
00098
00099
00100
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMPIGroup.h Source File

Parallel/vtkMPIGroup.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMPIGroup.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkMPIGroup_h
00042 #define __vtkMPIGroup_h
00043
00044 #include "vtkObject.h"
00045
00046 class vtkMPIController;
00047 class vtkMPICommunicator;
00048
00049 class VTK_PARALLEL_EXPORT vtkMPIGroup : public vtkObject
00050 {
00051
00052 public:
00053
00054   vtkTypeRevisionMacro( vtkMPIGroup,vtkObject);
00055
00058   static vtkMPIGroup* New();
00059
00060   virtual void PrintSelf(ostream& os, vtkIndent indent);
00061
00064   void Initialize(vtkMPIController* controller);
00065
00069   int AddProcessId(int processId);
00070
00073   void RemoveProcessId(int processId);
00074
00077   int FindProcessId(int processId);
00078
00081   int GetProcessId(int pos);
00082
00085   void CopyProcessIdsFrom(vtkMPIGroup* group);
00086
00088
00089   int GetNumberOfProcessIds()
00090     {
00091       return this->CurrentPosition;
00092     }
00094
00095 //BTX
00096
00097   friend class vtkMPICommunicator;
00098
00099 //ETX
00100
00101 protected:
00102
00105   void CopyFrom(vtkMPIGroup* group);
00106
00108   void Initialize(int numProcIds);
00109
00110   int* ProcessIds;
00111   int MaximumNumberOfProcessIds;
00112   int Initialized;
00113   int CurrentPosition;
00114
00115   vtkMPIGroup();
00116   ~vtkMPIGroup();
00117
00118 private:
00119   vtkMPIGroup(const vtkMPIGroup&);  // Not implemented.
00120   void operator=(const vtkMPIGroup&);  // Not implemented.
00121 };
00122
00123 #endif
00124
00125
00126
00127
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMultiProcessController.h Source File

Parallel/vtkMultiProcessController.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMultiProcessController.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkMultiProcessController_h
00058 #define __vtkMultiProcessController_h
00059
00060 #include "vtkObject.h"
00061 #include "vtkDataObject.h"
00062 #include "vtkCommunicator.h"
00063
00064 class vtkDataSet;
00065 class vtkImageData;
00066 class vtkCollection;
00067 class vtkOutputWindow;
00068
00069 class vtkMultiProcessController;
00070
00071
00072 //BTX
00073 // The type of function that gets called when new processes are initiated.
00074 typedef void (*vtkProcessFunctionType)(vtkMultiProcessController *controller,
00075                                        void *userData);
00076
00077 // The type of function that gets called when an RMI is triggered.
00078 typedef void (*vtkRMIFunctionType)(void *localArg,
00079                                    void *remoteArg, int remoteArgLength,
00080                                    int remoteProcessId);
00081 //ETX
00082
00083
00084 class VTK_PARALLEL_EXPORT vtkMultiProcessController : public vtkObject
00085 {
00086 public:
00087   static vtkMultiProcessController *New();
00088   vtkTypeRevisionMacro(vtkMultiProcessController,vtkObject);
00089   void PrintSelf(ostream& os, vtkIndent indent);
00090
00094   virtual void Initialize(int* vtkNotUsed(argc), char*** vtkNotUsed(arcv))=0;
00095
00098   virtual void Finalize()=0;
00099
00101
00104   virtual void SetNumberOfProcesses(int num);
00105   vtkGetMacro( NumberOfProcesses, int );
00107
00108   //BTX
00110   /*! Set the SingleMethod to f() and the UserData of the for the method to
00111       be executed by all of the processes when SingleMethodExecute is
00112       called.  All the processes will start by calling this function. */
00113   void SetSingleMethod(vtkProcessFunctionType, void *data);
00114   //ETX
00116
00120   virtual void SingleMethodExecute() = 0;
00121
00122   //BTX
00124   /*! Set the MultipleMethod to f() and the UserData of the for the method
00125       to be executed by the process index when MultipleMethodExecute is
00126       called.  This is for having each process start with a different
00127       function and data argument. */
00128   void SetMultipleMethod(int index, vtkProcessFunctionType, void *data);
00129   //ETX
00131
00135   virtual void MultipleMethodExecute() = 0;
00136
00138   virtual int GetLocalProcessId() { return this->LocalProcessId; }
00139
00144   static vtkMultiProcessController *GetGlobalController();
00145
00148   virtual void CreateOutputWindow() = 0;
00149
00151
00156   vtkSetMacro(ForceDeepCopy, int);
00157   vtkGetMacro(ForceDeepCopy, int);
00158   vtkBooleanMacro(ForceDeepCopy, int);
00160
00161
00162   //------------------ RMIs --------------------
00163   //BTX
00169   void AddRMI(vtkRMIFunctionType, void *localArg, int tag);
00170
00172
00173   void RemoveRMI(vtkRMIFunctionType f, void *arg, int tag)
00174     {f = f; arg = arg; tag = tag; vtkErrorMacro("RemoveRMI Not Implemented Yet");};
00175   //ETX
00177
00179   void TriggerRMI(int remoteProcessId, void *arg, int argLength, int tag);
00180
00183   void TriggerBreakRMIs();
00184
00186
00187   void TriggerRMI(int remoteProcessId, char *arg, int tag)
00188     { this->TriggerRMI(remoteProcessId, (void*)arg, strlen(arg)+1, tag); }
00190
00192
00193   void TriggerRMI(int remoteProcessId, int tag)
00194     { this->TriggerRMI(remoteProcessId, NULL, 0, tag); }
00196
00199   void ProcessRMIs();
00200
00202
00205   vtkSetMacro(BreakFlag, int);
00206   vtkGetMacro(BreakFlag, int);
00208
00210   vtkGetObjectMacro(Communicator, vtkCommunicator);
00212
00213 //BTX
00214
00215   enum Consts {
00216     MAX_PROCESSES=8192,
00217     ANY_SOURCE=-1,
00218     INVALID_SOURCE=-2,
00219     RMI_TAG=315167,
00220     RMI_ARG_TAG=315168,
00221     BREAK_RMI_TAG=239954
00222   };
00223
00224 //ETX
00225
00227   virtual void Barrier() = 0;
00228
00229   static void SetGlobalController(vtkMultiProcessController *controller);
00230
00231   //------------------ Communication --------------------
00232
00234
00236   int Send(int* data, int length, int remoteProcessId, int tag);
00237   int Send(unsigned long* data, int length, int remoteProcessId,
00238            int tag);
00239   int Send(char* data, int length, int remoteProcessId, int tag);
00240   int Send(unsigned char* data, int length, int remoteProcessId, int tag);
00241   int Send(float* data, int length, int remoteProcessId, int tag);
00242   int Send(double* data, int length, int remoteProcessId, int tag);
00243 #ifdef VTK_USE_64BIT_IDS
00244   int Send(vtkIdType* data, int length, int remoteProcessId, int tag);
00246 #endif
00247   int Send(vtkDataObject *data, int remoteId, int tag);
00248   int Send(vtkDataArray *data, int remoteId, int tag);
00249
00251
00254   int Receive(int* data, int length, int remoteProcessId, int tag);
00255   int Receive(unsigned long* data, int length, int remoteProcessId,
00256               int tag);
00257   int Receive(char* data, int length, int remoteProcessId, int tag);
00258   int Receive(unsigned char* data, int length, int remoteProcessId, int tag);
00259   int Receive(float* data, int length, int remoteProcessId, int tag);
00260   int Receive(double* data, int length, int remoteProcessId, int tag);
00261 #ifdef VTK_USE_64BIT_IDS
00262   int Receive(vtkIdType* data, int length, int remoteProcessId, int tag);
00264 #endif
00265   int Receive(vtkDataObject* data, int remoteId, int tag);
00266   int Receive(vtkDataArray* data, int remoteId, int tag);
00267
00268 // Internally implemented RMI to break the process loop.
00269
00270 protected:
00271   vtkMultiProcessController();
00272   ~vtkMultiProcessController();
00273
00274   int MaximumNumberOfProcesses;
00275   int NumberOfProcesses;
00276
00277   int LocalProcessId;
00278
00279   vtkProcessFunctionType      SingleMethod;
00280   void                       *SingleData;
00281   vtkProcessFunctionType      MultipleMethod[MAX_PROCESSES];
00282   void                       *MultipleData[MAX_PROCESSES];
00283
00284   vtkCollection *RMIs;
00285
00286   // This is a flag that can be used by the ports to break
00287   // their update loop. (same as ProcessRMIs)
00288   int BreakFlag;
00289
00290   void ProcessRMI(int remoteProcessId, void *arg, int argLength, int rmiTag);
00291
00292   // This method implements "GetGlobalController".
00293   // It needs to be virtual and static.
00294   virtual vtkMultiProcessController *GetLocalController();
00295
00296
00297   // This flag can force deep copies during send.
00298   int ForceDeepCopy;
00299
00300   vtkOutputWindow* OutputWindow;
00301
00302   // Note that since the communicators can be created differently
00303   // depending on the type of controller, the subclasses are
00304   // responsible of deleting them.
00305   vtkCommunicator* Communicator;
00306
00307   // Communicator which is a copy of the current user
00308   // level communicator except the context; i.e. even if the tags
00309   // are the same, the RMI messages will not interfere with user
00310   // level messages. (This only works with MPI. When using threads,
00311   // the tags have to be unique.)
00312   // Note that since the communicators can be created differently
00313   // depending on the type of controller, the subclasses are
00314   // responsible of deleting them.
00315   vtkCommunicator* RMICommunicator;
00316
00317 private:
00318   vtkMultiProcessController(const vtkMultiProcessController&);  // Not implemented.
00319   void operator=(const vtkMultiProcessController&);  // Not implemented.
00320 };
00321
00322
00323 inline int vtkMultiProcessController::Send(vtkDataObject *data,
00324                                            int remoteThreadId, int tag)
00325 {
00326   if (this->Communicator)
00327     {
00328     return this->Communicator->Send(data, remoteThreadId, tag);
00329     }
00330   else
00331     {
00332     return 0;
00333     }
00334 }
00335
00336 inline int vtkMultiProcessController::Send(vtkDataArray *data,
00337                                            int remoteThreadId, int tag)
00338 {
00339   if (this->Communicator)
00340     {
00341     return this->Communicator->Send(data, remoteThreadId, tag);
00342     }
00343   else
00344     {
00345     return 0;
00346     }
00347 }
00348
00349 inline int vtkMultiProcessController::Send(int* data, int length,
00350                                            int remoteThreadId, int tag)
00351 {
00352   if (this->Communicator)
00353     {
00354     return this->Communicator->Send(data, length, remoteThreadId, tag);
00355     }
00356   else
00357     {
00358     return 0;
00359     }
00360 }
00361
00362 inline int vtkMultiProcessController::Send(unsigned long* data,
00363                                            int length, int remoteThreadId,
00364                                            int tag)
00365 {
00366   if (this->Communicator)
00367     {
00368     return this->Communicator->Send(data, length, remoteThreadId, tag);
00369     }
00370   else
00371     {
00372     return 0;
00373     }
00374 }
00375
00376 inline int vtkMultiProcessController::Send(char* data, int length,
00377                                            int remoteThreadId, int tag)
00378 {
00379   if (this->Communicator)
00380     {
00381     return this->Communicator->Send(data, length, remoteThreadId, tag);
00382     }
00383   else
00384     {
00385     return 0;
00386     }
00387 }
00388
00389 inline int vtkMultiProcessController::Send(unsigned char* data, int length,
00390                                            int remoteThreadId, int tag)
00391 {
00392   if (this->Communicator)
00393     {
00394     return this->Communicator->Send(data, length, remoteThreadId, tag);
00395     }
00396   else
00397     {
00398     return 0;
00399     }
00400 }
00401
00402 inline int vtkMultiProcessController::Send(float* data, int length,
00403                                            int remoteThreadId, int tag)
00404 {
00405   if (this->Communicator)
00406     {
00407     return this->Communicator->Send(data, length, remoteThreadId, tag);
00408     }
00409   else
00410     {
00411     return 0;
00412     }
00413 }
00414
00415 inline int vtkMultiProcessController::Send(double* data, int length,
00416                                            int remoteThreadId, int tag)
00417 {
00418   if (this->Communicator)
00419     {
00420     return this->Communicator->Send(data, length, remoteThreadId, tag);
00421     }
00422   else
00423     {
00424     return 0;
00425     }
00426 }
00427
00428 #ifdef VTK_USE_64BIT_IDS
00429 inline int vtkMultiProcessController::Send(vtkIdType* data, int length,
00430                                            int remoteThreadId, int tag)
00431 {
00432   if (this->Communicator)
00433     {
00434     return this->Communicator->Send(data, length, remoteThreadId, tag);
00435     }
00436   else
00437     {
00438     return 0;
00439     }
00440 }
00441 #endif
00442
00443 inline int vtkMultiProcessController::Receive(vtkDataObject* data,
00444                                               int remoteThreadId, int tag)
00445 {
00446   if (this->Communicator)
00447     {
00448     return this->Communicator->Receive(data, remoteThreadId, tag);
00449     }
00450   else
00451     {
00452     return 0;
00453     }
00454 }
00455
00456 inline int vtkMultiProcessController::Receive(vtkDataArray* data,
00457                                               int remoteThreadId, int tag)
00458 {
00459   if (this->Communicator)
00460     {
00461     return this->Communicator->Receive(data, remoteThreadId, tag);
00462     }
00463   else
00464     {
00465     return 0;
00466     }
00467 }
00468
00469 inline int vtkMultiProcessController::Receive(int* data, int length,
00470                                               int remoteThreadId, int tag)
00471 {
00472   if (this->Communicator)
00473     {
00474     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00475     }
00476   else
00477     {
00478     return 0;
00479     }
00480 }
00481
00482 inline int vtkMultiProcessController::Receive(unsigned long* data,
00483                                               int length,int remoteThreadId,
00484                                               int tag)
00485 {
00486   if (this->Communicator)
00487     {
00488     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00489     }
00490   else
00491     {
00492     return 0;
00493     }
00494 }
00495
00496 inline int vtkMultiProcessController::Receive(char* data, int length,
00497                                               int remoteThreadId, int tag)
00498 {
00499   if (this->Communicator)
00500     {
00501     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00502     }
00503   else
00504     {
00505     return 0;
00506     }
00507 }
00508
00509 inline int vtkMultiProcessController::Receive(unsigned char* data, int length,
00510                                               int remoteThreadId, int tag)
00511 {
00512   if (this->Communicator)
00513     {
00514     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00515     }
00516   else
00517     {
00518     return 0;
00519     }
00520 }
00521
00522 inline int vtkMultiProcessController::Receive(float* data, int length,
00523                                               int remoteThreadId, int tag)
00524 {
00525   if (this->Communicator)
00526     {
00527     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00528     }
00529   else
00530     {
00531     return 0;
00532     }
00533 }
00534
00535 inline int vtkMultiProcessController::Receive(double* data, int length,
00536                                               int remoteThreadId, int tag)
00537 {
00538   if (this->Communicator)
00539     {
00540     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00541     }
00542   else
00543     {
00544     return 0;
00545     }
00546 }
00547
00548 #ifdef VTK_USE_64BIT_IDS
00549 inline int vtkMultiProcessController::Receive(vtkIdType* data, int length,
00550                                               int remoteThreadId, int tag)
00551 {
00552   if (this->Communicator)
00553     {
00554     return this->Communicator->Receive(data, length, remoteThreadId, tag);
00555     }
00556   else
00557     {
00558     return 0;
00559     }
00560 }
00561 #endif
00562
00563 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkMultiProcessLog.h Source File

Parallel/vtkMultiProcessLog.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMultiProcessLog.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkMultiProcessLog_h
00032 #define __vtkMultiProcessLog_h
00033
00034
00035 #include "vtkObject.h"
00036 #include "vtkThreadSafeLog.h"
00037
00038
00039 #define VTK_MULTI_PROCESS_LOG_MAX 1000
00040
00041 class VTK_PARALLEL_EXPORT vtkMultiProcessLog : public vtkObject
00042 {
00043 public:
00044   static vtkMultiProcessLog *New();
00045   const char *GetClassName() {return "vtkMultiProcessLog";};
00046
00048
00051   static void SetTimerLog(vtkThreadSafeLog *log);
00052   static vtkThreadSafeLog *GetTimerLog();
00054
00056   static void DumpLog(char *filename);
00057
00058 protected:
00059
00060   vtkMultiProcessLog() {}; //insure constructur/destructor protected
00061   ~vtkMultiProcessLog() {};
00062
00063 private:
00064   vtkMultiProcessLog(const vtkMultiProcessLog&);  // Not implemented.
00065   void operator=(const vtkMultiProcessLog&);  // Not implemented.
00066 };
00067
00068
00069
00070 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMultiThreader.h Source File

Common/vtkMultiThreader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMultiThreader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMultiThreader_h
00037 #define __vtkMultiThreader_h
00038
00039 #include "vtkObject.h"
00040 #include "vtkMutexLock.h"
00041
00042 #ifdef VTK_USE_SPROC
00043 #include <sys/types.h>
00044 #include <unistd.h>
00045 #endif
00046
00047 #ifdef VTK_USE_PTHREADS
00048 #include <sys/types.h>
00049 #include <unistd.h>
00050 #endif
00051
00052 // If VTK_USE_SPROC is defined, then sproc() will be used to create
00053 // multiple threads on an SGI. If VTK_USE_PTHREADS is defined, then
00054 // pthread_create() will be used to create multiple threads (on
00055 // a sun, for example)
00056
00057 // The maximum number of threads allowed
00058 #ifdef VTK_USE_SPROC
00059 #define VTK_MAX_THREADS              32
00060 #endif
00061
00062 #ifdef VTK_USE_PTHREADS
00063 #define VTK_MAX_THREADS              32
00064 #endif
00065
00066
00067 #ifdef VTK_USE_WIN32_THREADS
00068 #define VTK_MAX_THREADS              8
00069 #endif
00070
00071 #ifndef VTK_USE_WIN32_THREADS
00072 #ifndef VTK_USE_SPROC
00073 #ifndef VTK_USE_PTHREADS
00074 #define VTK_MAX_THREADS              1
00075 #endif
00076 #endif
00077 #endif
00078
00079 // If VTK_USE_PTHREADS is defined, then the multithreaded
00080 // function is of type void *, and returns NULL
00081 // Otherwise the type is void which is correct for WIN32
00082 // and SPROC
00083 //BTX
00084 #ifdef VTK_USE_SPROC
00085 typedef int vtkThreadProcessIDType;
00086 #endif
00087
00088 #ifdef VTK_USE_PTHREADS
00089 typedef void *(*vtkThreadFunctionType)(void *);
00090 typedef pthread_t vtkThreadProcessIDType;
00091 #define VTK_THREAD_RETURN_VALUE  NULL
00092 #define VTK_THREAD_RETURN_TYPE   void *
00093 #endif
00094
00095 #ifdef VTK_USE_WIN32_THREADS
00096 typedef LPTHREAD_START_ROUTINE vtkThreadFunctionType;
00097 typedef HANDLE vtkThreadProcessIDType;
00098 #define VTK_THREAD_RETURN_VALUE 0
00099 #define VTK_THREAD_RETURN_TYPE DWORD __stdcall
00100 #endif
00101
00102 #if !defined(VTK_USE_PTHREADS) && !defined(VTK_USE_WIN32_THREADS)
00103 typedef void (*vtkThreadFunctionType)(void *);
00104 typedef int vtkThreadProcessIDType;
00105 #define VTK_THREAD_RETURN_VALUE
00106 #define VTK_THREAD_RETURN_TYPE void
00107 #endif
00108 //ETX
00109
00120 //BTX
00121 struct ThreadInfoStruct
00122 {
00123   int                 ThreadID;
00124   int                 NumberOfThreads;
00125   int                 *ActiveFlag;
00126   vtkMutexLock        *ActiveFlagLock;
00127   void                *UserData;
00128 };
00129 //ETX
00130
00131 class VTK_COMMON_EXPORT vtkMultiThreader : public vtkObject
00132 {
00133 public:
00134   static vtkMultiThreader *New();
00135
00136   vtkTypeRevisionMacro(vtkMultiThreader,vtkObject);
00137   void PrintSelf(ostream& os, vtkIndent indent);
00138
00140
00143   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00144   vtkGetMacro( NumberOfThreads, int );
00146
00148
00151   static void SetGlobalMaximumNumberOfThreads(int val);
00152   static int  GetGlobalMaximumNumberOfThreads();
00154
00156
00159   static void SetGlobalDefaultNumberOfThreads(int val);
00160   static int  GetGlobalDefaultNumberOfThreads();
00162
00163   // These methods are excluded from Tcl wrapping 1) because the
00164   // wrapper gives up on them and 2) because they really shouldn't be
00165   // called from a script anyway.
00166   //BTX
00167
00170   void SingleMethodExecute();
00171
00175   void MultipleMethodExecute();
00176
00181   void SetSingleMethod(vtkThreadFunctionType, void *data );
00182
00185   void SetMultipleMethod( int index, vtkThreadFunctionType, void *data );
00186
00190   int SpawnThread( vtkThreadFunctionType, void *data );
00191
00193   void TerminateThread( int thread_id );
00194
00195
00196 protected:
00197   vtkMultiThreader();
00198   ~vtkMultiThreader();
00199
00200   // The number of threads to use
00201   int                        NumberOfThreads;
00202
00203   // An array of thread info containing a thread id
00204   // (0, 1, 2, .. VTK_MAX_THREADS-1), the thread count, and a pointer
00205   // to void so that user data can be passed to each thread
00206   ThreadInfoStruct           ThreadInfoArray[VTK_MAX_THREADS];
00207
00208   // The methods
00209   vtkThreadFunctionType      SingleMethod;
00210   vtkThreadFunctionType      MultipleMethod[VTK_MAX_THREADS];
00211
00212   // Storage of MutexFunctions and ints used to control spawned
00213   // threads and the spawned thread ids
00214   int                        SpawnedThreadActiveFlag[VTK_MAX_THREADS];
00215   vtkMutexLock               *SpawnedThreadActiveFlagLock[VTK_MAX_THREADS];
00216   vtkThreadProcessIDType     SpawnedThreadProcessID[VTK_MAX_THREADS];
00217   ThreadInfoStruct           SpawnedThreadInfoArray[VTK_MAX_THREADS];
00218
00219 //ETX
00220
00221   // Internal storage of the data
00222   void                       *SingleData;
00223   void                       *MultipleData[VTK_MAX_THREADS];
00224
00225 private:
00226   vtkMultiThreader(const vtkMultiThreader&);  // Not implemented.
00227   void operator=(const vtkMultiThreader&);  // Not implemented.
00228 };
00229
00230 #endif
00231
00232
00233
00234
00235
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkMutexLock.h Source File

Common/vtkMutexLock.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkMutexLock.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkMutexVariable_h
00037 #define __vtkMutexVariable_h
00038
00039
00040 #include "vtkObject.h"
00041
00042 //BTX
00043
00044 #ifdef VTK_USE_SPROC
00045 #include <abi_mutex.h>
00046 typedef abilock_t vtkMutexType;
00047 #endif
00048
00049 #ifdef VTK_USE_PTHREADS
00050 #include <pthread.h>
00051 typedef pthread_mutex_t vtkMutexType;
00052 #endif
00053
00054 #ifdef VTK_USE_WIN32_THREADS
00055 #include <winbase.h>
00056 typedef HANDLE vtkMutexType;
00057 #endif
00058
00059 #ifndef VTK_USE_SPROC
00060 #ifndef VTK_USE_PTHREADS
00061 #ifndef VTK_USE_WIN32_THREADS
00062 typedef int vtkMutexType;
00063 #endif
00064 #endif
00065 #endif
00066
00067 // Mutex lock that is not a vtkObject.
00068 class VTK_COMMON_EXPORT vtkSimpleMutexLock
00069 {
00070 public:
00071   // left public purposely
00072   vtkSimpleMutexLock();
00073   virtual ~vtkSimpleMutexLock();
00074
00075   static vtkSimpleMutexLock *New();
00076
00077   virtual const char *GetClassName() {return "vtkSimpleMutexLock";};
00078   virtual int IsA(const char *name);
00079   static vtkSimpleMutexLock *SafeDownCast(vtkSimpleMutexLock *o);
00080
00081   void Delete() {delete this;}
00082
00084   void Lock( void );
00085
00087   void Unlock( void );
00088
00089 protected:
00090   vtkMutexType   MutexLock;
00091 };
00092
00093 //ETX
00094
00095 class VTK_COMMON_EXPORT vtkMutexLock : public vtkObject
00096 {
00097 public:
00098   static vtkMutexLock *New();
00099
00100   vtkTypeRevisionMacro(vtkMutexLock,vtkObject);
00101   void PrintSelf(ostream& os, vtkIndent indent);
00102
00104   void Lock( void );
00105
00107   void Unlock( void );
00108
00109 protected:
00110   vtkSimpleMutexLock   SimpleMutexLock;
00111   vtkMutexLock() {};
00112 private:
00113   vtkMutexLock(const vtkMutexLock&);  // Not implemented.
00114   void operator=(const vtkMutexLock&);  // Not implemented.
00115 };
00116
00117
00118 inline void vtkMutexLock::Lock( void )
00119 {
00120   this->SimpleMutexLock.Lock();
00121 }
00122
00123 inline void vtkMutexLock::Unlock( void )
00124 {
00125   this->SimpleMutexLock.Unlock();
00126 }
00127
00128 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkNonLinearCell.h Source File

Common/vtkNonLinearCell.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkNonLinearCell.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkNonLinearCell_h
00047 #define __vtkNonLinearCell_h
00048
00049 #include "vtkCell.h"
00050 #include "vtkPointLocator.h"
00051
00052 class vtkPolyData;
00053 class vtkDataSet;
00054 class vtkUnstructuredGrid;
00055
00056
00057 class VTK_COMMON_EXPORT vtkNonLinearCell : public vtkCell
00058 {
00059 public:
00060   vtkTypeRevisionMacro(vtkNonLinearCell,vtkCell);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00066   vtkSetClampMacro(Error,float,0.001,1.0);
00067   vtkGetMacro(Error,float);
00069
00073   virtual int IsLinear() {return 0;}
00074
00076
00086   virtual void Tesselate(vtkIdType cellId,
00087                          vtkDataSet *input, vtkPolyData *output,
00088                          vtkPointLocator *locator=NULL);
00090
00092
00102   virtual void Tesselate(vtkIdType cellId,
00103                          vtkDataSet *input, vtkUnstructuredGrid *output,
00104                          vtkPointLocator *locator=NULL);
00106
00107
00108 protected:
00109   vtkNonLinearCell();
00110   ~vtkNonLinearCell() {}
00111
00112   float Error;
00113
00114   // inline helper for tesselation- used by subclasses
00115   vtkIdType InsertPoint(vtkPointLocator *locator, vtkPoints *pts, float *x)
00116     {
00117       if ( locator != NULL )
00118         {
00119         vtkIdType p;
00120         locator->InsertUniquePoint(x,p);
00121         return p;
00122         }
00123       else
00124         {
00125         return pts->InsertNextPoint(x);
00126         }
00127     }
00128
00129 private:
00130   vtkNonLinearCell(const vtkNonLinearCell&);  // Not implemented.
00131   void operator=(const vtkNonLinearCell&);  // Not implemented.
00132 };
00133
00134 #endif
00135
00136
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOBBDicer.h Source File

Graphics/vtkOBBDicer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOBBDicer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkOBBDicer_h
00045 #define __vtkOBBDicer_h
00046
00047 #include "vtkDicer.h"
00048 #include "vtkOBBTree.h"
00049 class vtkShortArray;
00050
00051 class VTK_GRAPHICS_EXPORT vtkOBBDicer : public vtkDicer
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkOBBDicer,vtkDicer);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058   static vtkOBBDicer *New();
00059
00060 protected:
00061   vtkOBBDicer() {};
00062   ~vtkOBBDicer() {};
00063
00064   // Usual data generation method
00065   void Execute();
00066
00067   //implementation ivars and methods
00068   void BuildTree(vtkIdList *ptIds, vtkOBBNode *OBBptr);
00069   void MarkPoints(vtkOBBNode *OBBptr, vtkShortArray *groupIds);
00070   void DeleteTree(vtkOBBNode *OBBptr);
00071   vtkPoints *PointsList;
00072
00073 private:
00074   vtkOBBDicer(const vtkOBBDicer&);  // Not implemented.
00075   void operator=(const vtkOBBDicer&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOBBTree.h Source File

Graphics/vtkOBBTree.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOBBTree.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00067 #ifndef __vtkOBBTree_h
00068 #define __vtkOBBTree_h
00069
00070 #include "vtkCellLocator.h"
00071 #include "vtkMatrix4x4.h"
00072
00073 // Special class defines node for the OBB tree
00074 //
00075 //BTX
00076 //
00077 class vtkOBBNode { //;prevent man page generation
00078 public:
00079   vtkOBBNode();
00080   ~vtkOBBNode();
00081
00082   float Corner[3]; //center point of this node
00083   float Axes[3][3]; //the axes defining the OBB - ordered from long->short
00084   vtkOBBNode *Parent; //parent node; NULL if root
00085   vtkOBBNode **Kids; //two children of this node; NULL if leaf
00086   vtkIdList *Cells; //list of cells in node
00087   void DebugPrintTree( int level, double *leaf_vol, int *minCells,
00088                        int *maxCells );
00089 };
00090 //ETX
00091 //
00092
00093 class VTK_GRAPHICS_EXPORT vtkOBBTree : public vtkCellLocator
00094 {
00095 public:
00096   vtkTypeRevisionMacro(vtkOBBTree,vtkCellLocator);
00097
00100   static vtkOBBTree *New();
00101
00103
00106   void ComputeOBB(vtkPoints *pts, float corner[3], float max[3],
00107                   float mid[3], float min[3], float size[3]);
00109
00111
00115   void ComputeOBB(vtkDataSet *input, float corner[3], float max[3],
00116                   float mid[3], float min[3], float size[3]);
00118
00123   int InsideOrOutside(const float point[3]);
00124
00126
00134   int IntersectWithLine(const float a0[3], const float a1[3],
00135                         vtkPoints *points, vtkIdList *cellIds);
00137
00139
00142   int IntersectWithLine(float a0[3], float a1[3], float tol,
00143                         float& t, float x[3], float pcoords[3],
00144                         int &subId);
00146
00147   int IntersectWithLine(float a0[3], float a1[3], float tol,
00148                         float& t, float x[3], float pcoords[3],
00149                         int &subId, vtkIdType &cellId);
00150
00151   int IntersectWithLine(float a0[3], float a1[3], float tol,
00152                         float& t, float x[3], float pcoords[3],
00153                         int &subId, vtkIdType &cellId, vtkGenericCell *cell);
00154
00155   //BTX
00156
00158
00160   int DisjointOBBNodes( vtkOBBNode *nodeA, vtkOBBNode *nodeB,
00161                         vtkMatrix4x4 *XformBtoA );
00163
00165   int LineIntersectsNode( vtkOBBNode *pA, float B0[3], float B1[3] );
00166
00168
00169   int TriangleIntersectsNode( vtkOBBNode *pA,
00170                               float p0[3], float p1[3],
00171                               float p2[3], vtkMatrix4x4 *XformBtoA );
00173
00175
00177   int IntersectWithOBBTree( vtkOBBTree *OBBTreeB, vtkMatrix4x4 *XformBtoA,
00178                             int(*function)( vtkOBBNode *nodeA,
00179                                             vtkOBBNode *nodeB,
00180                                             vtkMatrix4x4 *Xform,
00181                                             void *arg ),
00182                             void *data_arg );
00183   //ETX
00185
00187   /*! Satisfy locator's abstract interface, see vtkLocator. */
00188   void FreeSearchStructure();
00189   void BuildLocator();
00191
00200   void GenerateRepresentation(int level, vtkPolyData *pd);
00201
00202   //BTX
00203 protected:
00204   vtkOBBTree();
00205   ~vtkOBBTree();
00206
00207   // Compute an OBB from the list of cells given.  This used to be
00208   // public but should not have been.  A public call has been added
00209   // so that the functionality can be accessed.
00210   void ComputeOBB(vtkIdList *cells, float corner[3], float max[3],
00211                        float mid[3], float min[3], float size[3]);
00212
00213   vtkOBBNode *Tree;
00214   void BuildTree(vtkIdList *cells, vtkOBBNode *parent, int level);
00215   vtkPoints *PointsList;
00216   int *InsertedPoints;
00217   int OBBCount;
00218   int DeepestLevel;
00219
00220   void DeleteTree(vtkOBBNode *OBBptr);
00221   void GeneratePolygons(vtkOBBNode *OBBptr, int level, int repLevel,
00222                         vtkPoints* pts, vtkCellArray *polys);
00223
00224   //ETX
00225 private:
00226   vtkOBBTree(const vtkOBBTree&);  // Not implemented.
00227   void operator=(const vtkOBBTree&);  // Not implemented.
00228 };
00229
00230 #endif
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkObject.h Source File

Common/vtkObject.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkObject.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkObject_h
00062 #define __vtkObject_h
00063
00064 #include "vtkIndent.h"
00065 #include "vtkTimeStamp.h"
00066 #include "vtkSetGet.h"
00067
00068 class vtkSubjectHelper;
00069 class vtkCommand;
00070
00071 class VTK_COMMON_EXPORT vtkObject
00072 {
00073 public:
00077   virtual const char *GetClassName() {return "vtkObject";};
00078
00082   static int IsTypeOf(const char *name);
00083
00087   virtual int IsA(const char *name);
00088
00093   static vtkObject *SafeDownCast(vtkObject *o);
00094
00098   virtual void Delete();
00099
00101
00103   static vtkObject *New()
00104     {return new vtkObject;}
00106
00107 #ifdef _WIN32
00108   // avoid dll boundary problems
00109   void* operator new( size_t tSize );
00110   void operator delete( void* p );
00111 #endif
00112
00114   virtual void DebugOn();
00115
00117   virtual void DebugOff();
00118
00120   unsigned char GetDebug();
00121
00123   void SetDebug(unsigned char debugFlag);
00124
00127   static void BreakOnError();
00128
00133   virtual void Modified();
00134
00136   virtual unsigned long GetMTime();
00137
00140   void Print(ostream& os);
00141
00143
00147   virtual void PrintSelf(ostream& os, vtkIndent indent);
00148   virtual void PrintHeader(ostream& os, vtkIndent indent);
00149   virtual void PrintTrailer(ostream& os, vtkIndent indent);
00151
00153
00155   static void SetGlobalWarningDisplay(int val);
00156   static void GlobalWarningDisplayOn(){vtkObject::SetGlobalWarningDisplay(1);};
00157   static void GlobalWarningDisplayOff()
00158     {vtkObject::SetGlobalWarningDisplay(0);};
00159   static int  GetGlobalWarningDisplay();
00161
00163   void Register(vtkObject* o);
00164
00168   virtual void UnRegister(vtkObject* o);
00169
00171
00172   int  GetReferenceCount()
00173     {return this->ReferenceCount;}
00175
00177   void SetReferenceCount(int);
00178
00180
00189   unsigned long AddObserver(unsigned long event, vtkCommand *, float priority=0.0);
00190   unsigned long AddObserver(const char *event, vtkCommand *, float priority=0.0);
00191   vtkCommand *GetCommand(unsigned long tag);
00192   void InvokeEvent(unsigned long event, void *callData);
00193   void InvokeEvent(const char *event, void *callData);
00194   void RemoveObserver(vtkCommand*);
00195   //ETX
00196   void RemoveObserver(unsigned long tag);
00197   int HasObserver(unsigned long event);
00198   int HasObserver(const char *event);
00200
00201 protected:
00202   vtkObject();
00203   virtual ~vtkObject();
00204
00205   virtual void CollectRevisions(ostream& os);
00206
00207   unsigned char Debug;     // Enable debug messages
00208   vtkTimeStamp MTime;      // Keep track of modification time
00209   int ReferenceCount;      // Number of uses of this object by other objects
00210   vtkSubjectHelper *SubjectHelper;
00211
00212 private:
00213   //BTX
00214   friend VTK_COMMON_EXPORT ostream& operator<<(ostream& os, vtkObject& o);
00215   //ETX
00216 private:
00217   vtkObject(const vtkObject&);  // Not implemented.
00218   void operator=(const vtkObject&);  // Not implemented.
00219 };
00220
00221 #endif
00222
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkObjectFactory.h Source File

Common/vtkObjectFactory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkObjectFactory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkObjectFactory_h
00051 #define __vtkObjectFactory_h
00052
00053
00054
00055
00056 #include "vtkObject.h"
00057
00058 class vtkObjectFactoryCollection;
00059 class vtkOverrideInformationCollection;
00060 class vtkCollection;
00061
00062 class VTK_COMMON_EXPORT vtkObjectFactory : public vtkObject
00063 {
00064 public:
00065   // Class Methods used to interface with the registered factories
00066
00071   static vtkObject* CreateInstance(const char* vtkclassname);
00072
00074
00077   static void CreateAllInstance(const char* vtkclassname,
00078                                 vtkCollection* retList);
00079   // Description:
00080   // Re-check the VTK_AUTOLOAD_PATH for new factory libraries.
00081   // This calls UnRegisterAll before re-loading
00082   static void ReHash();
00083   // Description:
00084   // Register a factory so it can be used to create vtk objects
00085   static void RegisterFactory(vtkObjectFactory* );
00086   // Description:
00087   // Remove a factory from the list of registered factories
00088   static void UnRegisterFactory(vtkObjectFactory*);
00089   // Description:
00090   // Unregister all factories
00091   static void UnRegisterAllFactories();
00093
00096   static vtkObjectFactoryCollection* GetRegisteredFactories();
00097
00100   static int HasOverrideAny(const char* className);
00101
00103
00105   static void GetOverrideInformation(const char* name,
00106                                      vtkOverrideInformationCollection*);
00108
00110
00112   static void SetAllEnableFlags(int flag,
00113                                 const char* className);
00114   // Description:
00115   // Set the enable flag for a given named class subclass pair
00116   // for all registered factories.
00117   static void SetAllEnableFlags(int flag,
00118                                 const char* className,
00119                                 const char* subclassName);
00121
00122   // Instance methods to be used on individual instances of vtkObjectFactory
00123
00124   // Methods from vtkObject
00125   vtkTypeRevisionMacro(vtkObjectFactory,vtkObject);
00127   virtual void PrintSelf(ostream& os, vtkIndent indent);
00128
00135   virtual const char* GetVTKSourceVersion() = 0;
00136
00138   virtual const char* GetDescription() = 0;
00139
00141   virtual int GetNumberOfOverrides();
00142
00144   virtual const char* GetClassOverrideName(int index);
00145
00148   virtual const char* GetClassOverrideWithName(int index);
00149
00151   virtual int GetEnableFlag(int index);
00152
00154   virtual const char* GetOverrideDescription(int index);
00155
00157
00159   virtual void SetEnableFlag(int flag,
00160                              const char* className,
00161                              const char* subclassName);
00162   virtual int GetEnableFlag(const char* className,
00163                             const char* subclassName);
00165
00167
00168   virtual int HasOverride(const char* className);
00169   // Description:
00170   // Return 1 if this factory overrides the given class name, 0 otherwise.
00171   virtual int HasOverride(const char* className, const char* subclassName);
00173
00176   virtual void Disable(const char* className);
00177
00179
00180   vtkGetStringMacro(LibraryPath);
00182
00183   //BTX
00184   typedef vtkObject* (*CreateFunction)();
00185   //ETX
00186 protected:
00187   //BTX
00188
00190
00191   void RegisterOverride(const char* classOverride,
00192                         const char* overrideClassName,
00193                         const char* description,
00194                         int enableFlag,
00195                         CreateFunction createFunction);
00197
00198   //ETX
00199
00200
00204   virtual vtkObject* CreateObject(const char* vtkclassname );
00205
00206   vtkObjectFactory();
00207   ~vtkObjectFactory();
00208   //BTX
00209   struct OverrideInformation
00210   {
00211     char* Description;
00212     char* OverrideWithName;
00213     int EnabledFlag;
00214     CreateFunction CreateCallback;
00215   };
00216   //ETX
00217   OverrideInformation* OverrideArray;
00218   char** OverrideClassNames;
00219   int SizeOverrideArray;
00220   int OverrideArrayLength;
00221
00222 private:
00223   void GrowOverrideArray();
00224
00226
00228   static void Init();
00229   // Description:
00230   // Register default factories which are not loaded at run time.
00231   static void RegisterDefaults();
00232   // Description:
00233   // Load dynamic factories from the VTK_AUTOLOAD_PATH
00234   static void LoadDynamicFactories();
00235   // Description:
00236   // Load all dynamic libraries in the given path
00237   static void LoadLibrariesInPath( const char*);
00239
00240   // list of registered factories
00241   static vtkObjectFactoryCollection* RegisteredFactories;
00242
00243   // member variables for a factory set by the base class
00244   // at load or register time
00245   void* LibraryHandle;
00246   char* LibraryVTKVersion;
00247   char* LibraryCompilerUsed;
00248   char* LibraryPath;
00249 private:
00250   vtkObjectFactory(const vtkObjectFactory&);  // Not implemented.
00251   void operator=(const vtkObjectFactory&);  // Not implemented.
00252 };
00253
00254 // Macro to create an object creation function.
00255 // The name of the function will by vtkObjectFactoryCreateclassname
00256 // where classname is the name of the class being created
00257 #define VTK_CREATE_CREATE_FUNCTION(classname) \
00258 static vtkObject* vtkObjectFactoryCreate##classname() \
00259 { return classname::New(); }
00260
00261 #endif
00262
00263
00264 #ifdef _WIN32
00265 #define VTK_FACTORY_INTERFACE_EXPORT  __declspec( dllexport )
00266 #else
00267 #define VTK_FACTORY_INTERFACE_EXPORT
00268 #endif
00269
00270 // Macro to create the interface "C" functions used in
00271 // a dll or shared library that contains a VTK object factory.
00272 // Put this function in the .cxx file of your object factory,
00273 // and pass in the name of the factory sub-class that you want
00274 // the dll to create.
00275 #define VTK_FACTORY_INTERFACE_IMPLEMENT(factoryName)  \
00276 extern "C"                                      \
00277 VTK_FACTORY_INTERFACE_EXPORT                    \
00278 const char* vtkGetFactoryCompilerUsed()         \
00279 {                                               \
00280   return VTK_CXX_COMPILER;                      \
00281 }                                               \
00282 extern "C"                                      \
00283 VTK_FACTORY_INTERFACE_EXPORT                    \
00284 const char* vtkGetFactoryVersion()              \
00285 {                                               \
00286   return VTK_SOURCE_VERSION;                    \
00287 }                                               \
00288 extern "C"                                      \
00289 VTK_FACTORY_INTERFACE_EXPORT                    \
00290 vtkObjectFactory* vtkLoad()                     \
00291 {                                               \
00292   return factoryName ::New();                   \
00293 }
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkObjectFactoryCollection.h Source File

Common/vtkObjectFactoryCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkObjectFactoryCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkObjectFactoryCollection_h
00040 #define __vtkObjectFactoryCollection_h
00041
00042 #include "vtkCollection.h"
00043 #include "vtkObjectFactory.h"
00044 #include "vtkDebugLeaks.h"
00045
00046 class VTK_COMMON_EXPORT vtkObjectFactoryCollection : public vtkCollection
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkObjectFactoryCollection,vtkCollection);
00050   static vtkObjectFactoryCollection *New();
00051
00053   void AddItem(vtkObjectFactory *t) { this->vtkCollection::AddItem((vtkObject *)t); }
00054
00057   vtkObjectFactory *GetNextItem() { return static_cast<vtkObjectFactory *>(this->GetNextItemAsObject());}
00058
00059 protected:
00060   vtkObjectFactoryCollection() {};
00061   ~vtkObjectFactoryCollection() {};
00062
00063
00064 private:
00065   // hide the standard AddItem from the user and the compiler.
00066   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00067
00068 private:
00069   vtkObjectFactoryCollection(const vtkObjectFactoryCollection&);  // Not implemented.
00070   void operator=(const vtkObjectFactoryCollection&);  // Not implemented.
00071 };
00072
00073
00074 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOBJExporter.h Source File

Rendering/vtkOBJExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOBJExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkOBJExporter_h
00043 #define __vtkOBJExporter_h
00044
00045 #include <stdio.h>
00046 #include "vtkExporter.h"
00047
00048 class VTK_RENDERING_EXPORT vtkOBJExporter : public vtkExporter
00049 {
00050 public:
00051   static vtkOBJExporter *New();
00052   vtkTypeRevisionMacro(vtkOBJExporter,vtkExporter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00058   vtkSetStringMacro(FilePrefix);
00059   vtkGetStringMacro(FilePrefix);
00061
00062 protected:
00063   vtkOBJExporter();
00064   ~vtkOBJExporter();
00065
00066   void WriteData();
00067   void WriteAnActor(vtkActor *anActor, FILE *fpObj, FILE *fpMat, int &id);
00068   char *FilePrefix;
00069 private:
00070   vtkOBJExporter(const vtkOBJExporter&);  // Not implemented.
00071   void operator=(const vtkOBJExporter&);  // Not implemented.
00072 };
00073
00074 #endif
00075
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkOBJReader.h Source File

IO/vtkOBJReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOBJReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkOBJReader_h
00040 #define __vtkOBJReader_h
00041
00042 #include <stdio.h>
00043 #include "vtkPolyDataSource.h"
00044
00045 class VTK_IO_EXPORT vtkOBJReader : public vtkPolyDataSource
00046 {
00047 public:
00048   static vtkOBJReader *New();
00049   vtkTypeRevisionMacro(vtkOBJReader,vtkPolyDataSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetStringMacro(FileName);
00055   vtkGetStringMacro(FileName);
00057
00058 protected:
00059   vtkOBJReader();
00060   ~vtkOBJReader();
00061
00062   void Execute();
00063
00064   char *FileName;
00065 private:
00066   vtkOBJReader(const vtkOBJReader&);  // Not implemented.
00067   void operator=(const vtkOBJReader&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkOldStyleCallbackCommand.h Source File

Common/vtkOldStyleCallbackCommand.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOldStyleCallbackCommand.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00029 #ifndef __vtkOldStyleCallbackCommand_h
00030 #define __vtkOldStyleCallbackCommand_h
00031
00032 #include "vtkCommand.h"
00033
00034 // the old style void fund(void *) callbacks
00035 class VTK_COMMON_EXPORT vtkOldStyleCallbackCommand : public vtkCommand
00036 {
00037 public:
00038   static vtkOldStyleCallbackCommand *New()
00039     {return new vtkOldStyleCallbackCommand;};
00040
00041   void SetClientData(void *cd)
00042     {this->ClientData = cd;};
00043   void SetCallback(void (*f)(void *))
00044     {this->Callback = f;};
00045   void SetClientDataDeleteCallback(void (*f)(void *))
00046     {this->ClientDataDeleteCallback = f;};
00047
00048   void Execute(vtkObject *,unsigned long, void *);
00049
00050   void *ClientData;
00051   void (*Callback)(void *);
00052   void (*ClientDataDeleteCallback)(void *);
00053 protected:
00054   vtkOldStyleCallbackCommand();
00055   ~vtkOldStyleCallbackCommand();
00056 };
00057
00058
00059 #endif /* __vtkOldStyleCallbackCommand_h */
00060
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOOGLExporter.h Source File

Rendering/vtkOOGLExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOOGLExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00039 #ifndef __vtkOOGLExporter_h
00040 #define __vtkOOGLExporter_h
00041
00042 #include <stdio.h>
00043 #include "vtkExporter.h"
00044
00045 class VTK_RENDERING_EXPORT vtkOOGLExporter : public vtkExporter
00046 {
00047 public:
00048   static vtkOOGLExporter *New();
00049   vtkTypeRevisionMacro(vtkOOGLExporter,vtkExporter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetStringMacro(FileName);
00055   vtkGetStringMacro(FileName);
00057
00058 protected:
00059   vtkOOGLExporter();
00060   ~vtkOOGLExporter();
00061
00062   void WriteData();
00063   void WriteALight(vtkLight *aLight, FILE *fp);
00064   void WriteAnActor(vtkActor *anActor, FILE *fp, int count);
00065   char *FileName;
00066
00067 private:
00068   vtkOOGLExporter(const vtkOOGLExporter&);
00069   void operator=(const vtkOOGLExporter&);
00070 };
00071
00072 #endif
00073
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLActor.h Source File

Rendering/vtkOpenGLActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkOpenGLActor_h
00036 #define __vtkOpenGLActor_h
00037
00038 #include "vtkActor.h"
00039
00040 class vtkOpenGLRenderer;
00041
00042 class VTK_RENDERING_EXPORT vtkOpenGLActor : public vtkActor
00043 {
00044 protected:
00045
00046 public:
00047   static vtkOpenGLActor *New();
00048   vtkTypeRevisionMacro(vtkOpenGLActor,vtkActor);
00049
00051   void Render(vtkRenderer *ren, vtkMapper *mapper);
00052
00053 protected:
00054   vtkOpenGLActor() {};
00055   ~vtkOpenGLActor() {};
00056
00057 private:
00058   vtkOpenGLActor(const vtkOpenGLActor&);  // Not implemented.
00059   void operator=(const vtkOpenGLActor&);  // Not implemented.
00060 };
00061
00062 #endif
00063
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLCamera.h Source File

Rendering/vtkOpenGLCamera.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLCamera.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkOpenGLCamera_h
00035 #define __vtkOpenGLCamera_h
00036
00037 #include "vtkCamera.h"
00038
00039 class vtkOpenGLRenderer;
00040
00041 class VTK_RENDERING_EXPORT vtkOpenGLCamera : public vtkCamera
00042 {
00043 public:
00044   static vtkOpenGLCamera *New();
00045   vtkTypeRevisionMacro(vtkOpenGLCamera,vtkCamera);
00046
00048   void Render(vtkRenderer *ren);
00049
00050   void UpdateViewport(vtkRenderer *ren);
00051
00052 protected:
00053   vtkOpenGLCamera() {};
00054   ~vtkOpenGLCamera() {};
00055 private:
00056   vtkOpenGLCamera(const vtkOpenGLCamera&);  // Not implemented.
00057   void operator=(const vtkOpenGLCamera&);  // Not implemented.
00058 };
00059
00060 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLImageActor.h Source File

Rendering/vtkOpenGLImageActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLImageActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkOpenGLImageActor_h
00033 #define __vtkOpenGLImageActor_h
00034
00035 #include "vtkImageActor.h"
00036
00037 class vtkWindow;
00038 class vtkOpenGLRenderer;
00039 class vtkRenderWindow;
00040
00041 class VTK_RENDERING_EXPORT vtkOpenGLImageActor : public vtkImageActor
00042 {
00043 public:
00044   static vtkOpenGLImageActor *New();
00045   vtkTypeRevisionMacro(vtkOpenGLImageActor,vtkImageActor);
00046
00048   void Load(vtkRenderer *ren);
00049
00054   void ReleaseGraphicsResources(vtkWindow *);
00055
00056 protected:
00057   vtkOpenGLImageActor();
00058   ~vtkOpenGLImageActor();
00059
00060   unsigned char *MakeDataSuitable(int &xsize, int &ysize, int &release);
00061
00062   vtkTimeStamp   LoadTime;
00063   long          Index;
00064   vtkRenderWindow *RenderWindow;   // RenderWindow used for previous render
00065   float Coords[12];
00066   float TCoords[8];
00067 private:
00068   vtkOpenGLImageActor(const vtkOpenGLImageActor&);  // Not implemented.
00069   void operator=(const vtkOpenGLImageActor&);  // Not implemented.
00070 };
00071
00072 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLImageMapper.h Source File

Rendering/vtkOpenGLImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkOpenGLImageMapper_h
00038 #define __vtkOpenGLImageMapper_h
00039
00040
00041 #include "vtkImageMapper.h"
00042 class vtkActor2D;
00043
00044
00045 class VTK_RENDERING_EXPORT vtkOpenGLImageMapper : public vtkImageMapper
00046 {
00047 public:
00048   static vtkOpenGLImageMapper *New();
00049   vtkTypeRevisionMacro(vtkOpenGLImageMapper,vtkImageMapper);
00050
00052
00053   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor) {
00054     this->RenderStart(viewport,actor);}
00056
00058
00060   void RenderData(vtkViewport* viewport, vtkImageData* data,
00061                   vtkActor2D* actor);
00063
00064 protected:
00065   //
00066   //
00067   vtkOpenGLImageMapper();
00068   ~vtkOpenGLImageMapper();
00069
00070 private:
00071   vtkOpenGLImageMapper(const vtkOpenGLImageMapper&);  // Not implemented.
00072   void operator=(const vtkOpenGLImageMapper&);  // Not implemented.
00073 };
00074
00075
00076 #endif
00077
00078
00079
00080
00081
00082
00083
00084
00085
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLImager.h Source File

Rendering/vtkOpenGLImager.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLImager.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkOpenGLImager_h
00036 #define __vtkOpenGLImager_h
00037
00038 #include "vtkImager.h"
00039
00040 class VTK_RENDERING_EXPORT vtkOpenGLImager : public vtkImager
00041 {
00042 public:
00043   static vtkOpenGLImager *New();
00044   vtkTypeRevisionMacro(vtkOpenGLImager,vtkImager);
00045
00048   int RenderOpaqueGeometry();
00049
00051   void Erase();
00052
00053 protected:
00054   vtkOpenGLImager() {};
00055   ~vtkOpenGLImager() {};
00056 private:
00057   vtkOpenGLImager(const vtkOpenGLImager&);  // Not implemented.
00058   void operator=(const vtkOpenGLImager&);  // Not implemented.
00059 };
00060
00061
00062 #endif
00063
00064
00065
00066
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLImageWindow.h Source File

Rendering/vtkOpenGLImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkOpenGLImageWindow_h
00034 #define __vtkOpenGLImageWindow_h
00035
00036 #include <stdlib.h>
00037 #include <X11/X.h>
00038 #include <X11/Xlib.h>
00039 #include <X11/Xutil.h>
00040 #include "vtkXImageWindow.h"
00041 #include "GL/glx.h"
00042
00043
00044 class VTK_RENDERING_EXPORT vtkOpenGLImageWindow : public vtkXImageWindow
00045 {
00046 public:
00047   static vtkOpenGLImageWindow *New();
00048   vtkTypeRevisionMacro(vtkOpenGLImageWindow,vtkXImageWindow);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052   virtual void MakeDefaultWindow();
00053
00055   void SwapBuffers();
00056
00058   void Frame();
00059
00061   void Render();
00062
00064
00065   virtual void *GetGenericDisplayId() {return (void *)this->DisplayId;};
00066   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00067   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00068   virtual void *GetGenericContext();
00069   virtual void *GetGenericDrawable()  {return (void *)this->WindowId;};
00071
00073
00074   virtual Colormap GetDesiredColormap();
00075   virtual Visual  *GetDesiredVisual();
00076   XVisualInfo     *GetDesiredVisualInfo();
00077   virtual int      GetDesiredDepth();
00079
00081
00082   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00083   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00084                             int front);
00086
00088
00089   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00090   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00091                                 int blend=0);
00093
00095   void MakeCurrent();
00096
00098   virtual void EraseWindow() {this->vtkImageWindow::EraseWindow();};
00099
00100   GLXContext ContextId;
00101
00102 protected:
00103   vtkOpenGLImageWindow();
00104   ~vtkOpenGLImageWindow();
00105 private:
00106   vtkOpenGLImageWindow(const vtkOpenGLImageWindow&);  // Not implemented.
00107   void operator=(const vtkOpenGLImageWindow&);  // Not implemented.
00108 };
00109
00110
00111 #endif
00112
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLLight.h Source File

Rendering/vtkOpenGLLight.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLLight.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkOpenGLLight_h
00035 #define __vtkOpenGLLight_h
00036
00037 #include "vtkLight.h"
00038
00039 class vtkOpenGLRenderer;
00040
00041 class VTK_RENDERING_EXPORT vtkOpenGLLight : public vtkLight
00042 {
00043 public:
00044   static vtkOpenGLLight *New();
00045   vtkTypeRevisionMacro(vtkOpenGLLight,vtkLight);
00046
00048   void Render(vtkRenderer *ren,int light_index);
00049
00050 protected:
00051   vtkOpenGLLight() {};
00052   ~vtkOpenGLLight() {};
00053 private:
00054   vtkOpenGLLight(const vtkOpenGLLight&);  // Not implemented.
00055   void operator=(const vtkOpenGLLight&);  // Not implemented.
00056 };
00057
00058 #endif
00059
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLPolyDataMapper2D.h Source File

Rendering/vtkOpenGLPolyDataMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLPolyDataMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkOpenGLPolyDataMapper2D_h
00040 #define __vtkOpenGLPolyDataMapper2D_h
00041
00042 #include "vtkPolyDataMapper2D.h"
00043
00044 class VTK_RENDERING_EXPORT vtkOpenGLPolyDataMapper2D : public vtkPolyDataMapper2D
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkOpenGLPolyDataMapper2D,vtkPolyDataMapper2D);
00048   static vtkOpenGLPolyDataMapper2D *New();
00049
00051   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00052
00053 protected:
00054   vtkOpenGLPolyDataMapper2D() {};
00055   ~vtkOpenGLPolyDataMapper2D() {};
00056
00057 private:
00058   vtkOpenGLPolyDataMapper2D(const vtkOpenGLPolyDataMapper2D&);  // Not implemented.
00059   void operator=(const vtkOpenGLPolyDataMapper2D&);  // Not implemented.
00060 };
00061
00062
00063 #endif
00064
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLPolyDataMapper.h Source File

Rendering/vtkOpenGLPolyDataMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLPolyDataMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkOpenGLPolyDataMapper_h
00041 #define __vtkOpenGLPolyDataMapper_h
00042
00043 #include "vtkPolyDataMapper.h"
00044 #include <stdlib.h>
00045 #ifndef VTK_IMPLEMENT_MESA_CXX
00046   #ifdef __APPLE__
00047     #include <OpenGL/gl.h>
00048   #else
00049     #include <GL/gl.h>
00050   #endif
00051 #endif
00052
00053 class vtkProperty;
00054 class vtkRenderWindow;
00055 class vtkOpenGLRenderer;
00056
00057 class VTK_RENDERING_EXPORT vtkOpenGLPolyDataMapper : public vtkPolyDataMapper
00058 {
00059 public:
00060   static vtkOpenGLPolyDataMapper *New();
00061   vtkTypeRevisionMacro(vtkOpenGLPolyDataMapper,vtkPolyDataMapper);
00062
00064   virtual void RenderPiece(vtkRenderer *ren, vtkActor *a);
00065
00069   void ReleaseGraphicsResources(vtkWindow *);
00070
00072   virtual int Draw(vtkRenderer *ren, vtkActor *a);
00073
00074   //BTX  begin tcl exclude
00075
00077
00081   GLenum GetLmcolorMode(vtkProperty *prop);
00082   //ETX
00084
00085 protected:
00086   vtkOpenGLPolyDataMapper();
00087   ~vtkOpenGLPolyDataMapper();
00088
00089   int ListId;
00090 private:
00091   vtkOpenGLPolyDataMapper(const vtkOpenGLPolyDataMapper&);  // Not implemented.
00092   void operator=(const vtkOpenGLPolyDataMapper&);  // Not implemented.
00093 };
00094
00095 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLProperty.h Source File

Rendering/vtkOpenGLProperty.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLProperty.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkOpenGLProperty_h
00035 #define __vtkOpenGLProperty_h
00036
00037 #include "vtkProperty.h"
00038
00039 class vtkOpenGLRenderer;
00040
00041 class VTK_RENDERING_EXPORT vtkOpenGLProperty : public vtkProperty
00042 {
00043 public:
00044   static vtkOpenGLProperty *New();
00045   vtkTypeRevisionMacro(vtkOpenGLProperty,vtkProperty);
00046
00048   void Render(vtkActor *a, vtkRenderer *ren);
00049
00051   void BackfaceRender(vtkActor *a, vtkRenderer *ren);
00052
00053 protected:
00054   vtkOpenGLProperty() {};
00055   ~vtkOpenGLProperty() {};
00056 private:
00057   vtkOpenGLProperty(const vtkOpenGLProperty&);  // Not implemented.
00058   void operator=(const vtkOpenGLProperty&);  // Not implemented.
00059 };
00060
00061 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLRenderer.h Source File

Rendering/vtkOpenGLRenderer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLRenderer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkOpenGLRenderer_h
00036 #define __vtkOpenGLRenderer_h
00037
00038 #include <stdlib.h>
00039 #include "vtkRenderer.h"
00040
00041 class VTK_RENDERING_EXPORT vtkOpenGLRenderer : public vtkRenderer
00042 {
00043 protected:
00044   int NumberOfLightsBound;
00045
00046 public:
00047   static vtkOpenGLRenderer *New();
00048   vtkTypeRevisionMacro(vtkOpenGLRenderer,vtkRenderer);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052   void DeviceRender(void);
00053
00056   void ClearLights(void);
00057
00058   void Clear(void);
00059
00061   int UpdateLights(void);
00062
00063 protected:
00064   vtkOpenGLRenderer();
00065   ~vtkOpenGLRenderer();
00066
00067   //BTX
00068   // Picking functions to be implemented by sub-classes
00069   virtual void DevicePickRender();
00070   virtual void StartPick(unsigned int pickFromSize);
00071   virtual void UpdatePickId();
00072   virtual void DonePick();
00073   virtual unsigned int GetPickedId();
00074   virtual float GetPickedZ();
00075   // Ivars used in picking
00076   class vtkGLPickInfo* PickInfo;
00077   //ETX
00078   float PickedZ;
00079 private:
00080   vtkOpenGLRenderer(const vtkOpenGLRenderer&);  // Not implemented.
00081   void operator=(const vtkOpenGLRenderer&);  // Not implemented.
00082 };
00083
00084 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLRenderWindow.h Source File

Rendering/vtkOpenGLRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkOpenGLRenderWindow_h
00039 #define __vtkOpenGLRenderWindow_h
00040
00041 #include <stdlib.h>
00042 #include "vtkRenderWindow.h"
00043 #ifdef __APPLE__
00044 #include <OpenGL/gl.h>
00045 #else
00046 #include <GL/gl.h>
00047 #endif
00048
00049 class vtkIdList;
00050
00051 class VTK_RENDERING_EXPORT vtkOpenGLRenderWindow : public vtkRenderWindow
00052 {
00053 protected:
00054   int MultiSamples;
00055   long OldMonitorSetting;
00056
00057 public:
00058   vtkTypeRevisionMacro(vtkOpenGLRenderWindow,vtkRenderWindow);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   static void SetGlobalMaximumNumberOfMultiSamples(int val);
00064   static int  GetGlobalMaximumNumberOfMultiSamples();
00066
00068
00070   vtkSetMacro(MultiSamples,int);
00071   vtkGetMacro(MultiSamples,int);
00073
00075   virtual void StereoUpdate();
00076
00078
00079   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00080   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00081                             int front);
00083
00085
00086   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00087   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00088                                 int blend=0);
00089   virtual void ReleaseRGBAPixelData(float *data);
00090   virtual unsigned char *GetRGBACharPixelData(int x,int y,int x2,int y2,
00091                                               int front);
00092   virtual void SetRGBACharPixelData(int x,int y,int x2,int y2,unsigned char *,
00093                                     int front, int blend=0);
00095
00097
00098   virtual float *GetZbufferData( int x1, int y1, int x2, int y2 );
00099   virtual void SetZbufferData( int x1, int y1, int x2, int y2, float *buffer );
00101
00103   void MakeCurrent() = 0;
00104
00106   void RegisterTextureResource (GLuint id);
00107
00109   int GetDepthBufferSize();
00110
00112   virtual void OpenGLInit();
00113
00114 protected:
00115   vtkOpenGLRenderWindow();
00116   ~vtkOpenGLRenderWindow();
00117
00118   vtkIdList *TextureResourceIds;
00119 private:
00120   vtkOpenGLRenderWindow(const vtkOpenGLRenderWindow&);  // Not implemented.
00121   void operator=(const vtkOpenGLRenderWindow&);  // Not implemented.
00122 };
00123
00124 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLStateCache.h Source File

Rendering/vtkOpenGLStateCache.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLStateCache.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 //*************************************************************************
00017 /*
00018   GlStateCache_Cache============================================
00019   This simply checks for redundancies in state-change requests and
00020   only calls the real OpenGL call if there has in fact been a change.
00021   This cannot, however, fix problems with the ordering of calls.
00022 */
00023
00024 #ifndef VTK_IMPLEMENT_MESA_CXX
00025 #ifdef __APPLE__
00026 #include <OpenGL/gl.h>
00027 #else
00028 #include <GL/gl.h>
00029 #endif
00030 #endif
00031
00032 #define vtkOpenGLCall_glEnable vtkOpenGLStateCache::CurrentGLCache->glEnable
00033 #define vtkOpenGLCall_glDisable vtkOpenGLStateCache::CurrentGLCache->glDisable
00034 #define vtkOpenGLCall_glAlphaFunc vtkOpenGLStateCache::CurrentGLCache->glAlphaFunc
00035 #define vtkOpenGLCall_glBlendFunc vtkOpenGLStateCache::CurrentGLCache->glBlendFunc
00036 #define vtkOpenGLCall_glDepthFunc vtkOpenGLStateCache::CurrentGLCache->glDepthFunc
00037 #define vtkOpenGLCall_glTexEnvf vtkOpenGLStateCache::CurrentGLCache->glTexEnvf
00038 #define vtkOpenGLCall_glLightModeli vtkOpenGLStateCache::CurrentGLCache->glLightModeli
00039 #define vtkOpenGLCall_glLightModelfv vtkOpenGLStateCache::CurrentGLCache->glLightMOdelfv
00040 #define vtkOpenGLCall_glLightfv vtkOpenGLStateCache::CurrentGLCache->glLightfv
00041 #define vtkOpenGLCall_glLightf vtkOpenGLStateCache::CurrentGLCache->glLightf
00042 #define vtkOpenGLCall_glLighti vtkOpenGLStateCache::CurrentGLCache->glLighti
00043 #define vtkOpenGLCall_glMaterialfv vtkOpenGLStateCache::CurrentGLCache->glMaterialfv
00044 #define vtkOpenGLCall_glShadeModel vtkOpenGLStateCache::CurrentGLCache->glShadeModel
00045 #define vtkOpenGLCall_glClearColor vtkOpenGLStateCache::CurrentGLCache->glClearColor
00046 #define vtkOpenGLCall_glClearDepth vtkOpenGLStateCache::CurrentGLCache->glClearDepth
00047 #define vtkOpenGLCall_glDepthMask vtkOpenGLStateCache::CurrentGLCache->glDepthMask
00048 #define vtkOpenGLCall_glCullFace vtkOpenGLStateCache::CurrentGLCache->glCullFace
00049 #define vtkOpenGLCall_glClear vtkOpenGLStateCache::CurrentGLCache->glClear
00050 #define vtkOpenGLCall_glDrawBuffer vtkOpenGLStateCache::CurrentGLCache->glDrawBuffer
00051 #define vtkOpenGLCall_glMatrixMode vtkOpenGLStateCache::CurrentGLCache->glMatrixMode
00052 #define vtkOpenGLCall_glViewport vtkOpenGLStateCache::CurrentGLCache->glViewport
00053 #define vtkOpenGLCall_glScissor vtkOpenGLStateCache::CurrentGLCache->glScissor
00054 #define vtkOpenGLCall_glClipPlane vtkOpenGLStateCache::CurrentGLCache->glClipPlane
00055 #define vtkOpenGLCall_glColorMaterial vtkOpenGLStateCache::CurrentGLCache->glColorMaterial
00056 #define vtkOpenGLCall_glPointSize vtkOpenGLStateCache::CurrentGLCache->glPointSize
00057 #define vtkOpenGLCall_glLineWidth vtkOpenGLStateCache::CurrentGLCache->glLineWidth
00058 #define vtkOpenGLCall_glLineStipple vtkOpenGLStateCache::CurrentGLCache->glLineStipple
00059 #define vtkOpenGLCall_glDepthRange vtkOpenGLStateCache::CurrentGLCache->glDepthRange
00060 #define vtkOpenGLCall_glPolygonOffset vtkOpenGLStateCache::CurrentGLCache->glPolygonOffset
00061
00062 #define vtkOpenGLCall_glPushMatrix glPushMatrix
00063 #define vtkOpenGLCall_glPopMatrix glPopMatrix
00064 #define vtkOpenGLCall_glMultMatrixd glMultMatrixd
00065 #define vtkOpenGLCall_glLoadMatrixd glLoadMatrixd
00066 #define vtkOpenGLCall_glLoadIdentity glLoadIdentity
00067 #define vtkOpenGLCall_glSelectBuffer glSelectBuffer
00068 #define vtkOpenGLCall_glRenderMode glRenderMode
00069 #define vtkOpenGLCall_glInitNames glInitNames
00070 #define vtkOpenGLCall_glPushName glPushName
00071 #define vtkOpenGLCall_glLoadName glLoadName
00072 #define vtkOpenGLCall_glGetIntegerv glGetIntegerv
00073 #define vtkOpenGLCall_glIsTexture glIsTexture
00074 #define vtkOpenGLCall_glDeleteTextures glDeleteTexture
00075 #define vtkOpenGLCall_glGenTextures glGenTextures
00076 #define vtkOpenGLCall_glBindTexture glBindTexture
00077 #define vtkOpenGLCall_glTexParameterf glTextParameterf
00078 #define vtkOpenGLCall_glTexCoord2fv glTexCoord2fv
00079 #define vtkOpenGLCall_glVertex3fv glVertex3fv
00080 #define vtkOpenGLCall_glNormal3fv glNormal3fv
00081 #define vtkOpenGLCall_glColor3f glColor3f
00082 #define vtkOpenGLCall_glColor4ubv glColor4ubv
00083 #define vtkOpenGLCall_glColor4fv glColor4fv
00084 #define vtkOpenGLCall_glBegin glBegin
00085 #define vtkOpenGLCall_glEnd glEnd
00086 #define vtkOpenGLCall_glTexImage2D glTextImage2D
00087 #define vtkOpenGLCall_glDeleteLists glDeleteLists
00088 #define vtkOpenGLCall_glIsList glIsList
00089 #define vtkOpenGLCall_glGenLists glGenLists
00090 #define vtkOpenGLCall_glCallList glCallList
00091 #define vtkOpenGLCall_glReadBuffer glReadBuffer
00092 #define vtkOpenGLCall_glPixelStorei glPixelStorei
00093 #define vtkOpenGLCall_glReadPixels glReadPixels
00094 #define vtkOpenGLCall_glRasterPos3f glRasterPos3f
00095 #define vtkOpenGLCall_glDrawPixels glDrawPixels
00096 #define vtkOpenGLCall_glRasterPos2f glRasterPos2f
00097 #define vtkOpenGLCall_glNewList glNewList
00098 #define vtkOpenGLCall_glEndList glEndList
00099
00100 class vtkOpenGLStateCache
00101 {
00102 public:
00103   static vtkOpenGLStateCache *CurrentGLCache; // recursive definition
00104
00105   vtkOpenGLStateCache(); // set all members to initial values
00106   ~vtkOpenGLStateCache(); // delete any dynamic objects
00107   void Initialize();
00108
00109   // GL_BLEND         = 0x0BE2
00110   // GL_POINT_SMOOTH  = 0x0B10
00111   // GL_LINE_SMOOTH   = 0x0B20
00112   // GL_POLYGON_SMOOTH= 0x0B41
00113   // GL_DEPTH_TEST    = 0x0B71
00114   // GL_ALPHA_TEST    = 0x0BC0
00115   // GL_TEXTURE_2D    = 0x0DE1
00116   // GL_CLIP_PLANE0+i = 0x3000
00117   // GL_LIGHTING      = 0x0B50
00118   // GL_COLOR_MATERIAL= 0x0B57
00119   // GL_NORMALIZE     = 0x0BA1
00120   // GL_CULL_FACE     = 0x0B44
00121   // GL_SCISSOR_TEST  = 0x0C11
00122   // GL_POLYGON_OFFSET_FILL = 0x8037
00123   // GL_LINE_STIPPLE  = 0x0B24
00124   // GL_LIGHT+i       = 0x4000
00125   char Enable_buckets[0xDE1-0xB10+1]; // 0xB10-0xDE1
00126   char Enable_GL_LIGHT_buckets[8]; // 0x4000 + i (0<i<8)
00127   char Enable_GL_CLIP_PLANE_buckets[8]; // 0x8000 + i (0<i<8)
00128   /* Need to have special handling for disabling and enabling the
00129      GL_LIGHT's because they are disabling too many lights!
00130      need to propagate in how many lights are actually *on*
00131      and only apply the op to them.
00132    */
00133   inline void glEnable(GLenum e)
00134     {
00135       register int ex;
00136       register char *val=0;
00137       if(e&0x4000)
00138         {
00139         ex=e-0x4000;
00140         if(ex<8) {val=Enable_GL_LIGHT_buckets+ex; }
00141         }
00142       else
00143         {
00144         if(e&0x8000)
00145           {
00146           ex=e-0x8000;
00147           if(ex<8) { val=Enable_GL_CLIP_PLANE_buckets+ex; }
00148           }
00149         else
00150           {
00151           if(e>=0xB10 && e<=0xDE1)
00152             {
00153             ex=e-0xB10;
00154             val=Enable_buckets+ex;
00155             }
00156           else
00157             {
00158             printf("Error: glEnable of 0x%X failed\n",e);
00159             }
00160           }
00161         }
00162       if(val && *val!=1)
00163         {
00164         *val=1;
00165         ::glEnable(e);
00166         }
00167     }
00168   inline void glDisable(GLenum e)
00169     {
00170       register int ex;
00171       register char *val=0;
00172       if(e&0x4000)
00173         {
00174         ex=e-0x4000;
00175         if(ex<8) { val=Enable_GL_LIGHT_buckets+ex; }
00176         }
00177       else
00178         {
00179         if(e&0x8000)
00180           {
00181           ex=e-0x8000;
00182           if(ex<8) { val=Enable_GL_CLIP_PLANE_buckets+ex; }
00183           }
00184         else
00185           {
00186           if(e>=0xB10 && e<=0xDE1)
00187             {
00188             ex=e-0xB10;
00189             val=Enable_buckets+ex;
00190             }
00191           else
00192             {
00193             printf("Error: glEnable of 0x%X failed\n",e);
00194             }
00195           }
00196         }
00197       if(val && *val!=0)
00198         {
00199         *val=0;
00200         ::glDisable(e);
00201         }
00202     }
00203
00204   // GL_GREATER = 0x0204, (GLclampf) 0
00205   GLclampf AlphaFunc_bucket;
00206   inline void glAlphaFunc(GLenum e,GLclampf cf)
00207     {
00208       if(e==GL_GREATER && cf!=AlphaFunc_bucket)
00209         {
00210         AlphaFunc_bucket=cf;
00211         ::glAlphaFunc(e,cf);
00212         }
00213     }
00214
00215   // GL_SRC_ALPHA = 0x0302, GL_ONE_MINUS_SRC_ALPHA = 0x0303
00216   GLenum BlendFunc_bucket; // multibucket if any other blendfunc is used
00217   inline void glBlendFunc(GLenum e,GLenum e1)
00218     {
00219       if(e==GL_SRC_ALPHA && e1!=BlendFunc_bucket)
00220         {
00221         BlendFunc_bucket=e1;
00222         ::glBlendFunc(e,e1);
00223         }
00224     }
00225
00226   // GL_GREATER = 0x0204
00227   // GL_LESS    = 0x0201
00228   // GL_LEQUAL  = 0x0203
00229   GLenum DepthFunc_bucket;
00230   inline void glDepthFunc(GLenum e)
00231     {
00232       if(e!=DepthFunc_bucket)
00233         {
00234         DepthFunc_bucket=e;
00235         ::glDepthFunc(e);
00236         }
00237     }
00238
00239   // GL_TEXTURE_ENV = 0x2300, GL_TEXTURE_ENV_MODE = 0x2200, GL_MODULATE = 0x2100
00240   GLfloat TexEnvf_MODE_bucket; // total kludge right now
00241   inline void glTexEnvf(GLenum e,GLenum e1,GLfloat f)
00242     {
00243       if(e==GL_TEXTURE_ENV && e1==GL_TEXTURE_ENV_MODE)
00244         {
00245         if(f!=TexEnvf_MODE_bucket)
00246           {
00247           TexEnvf_MODE_bucket=f;
00248           ::glTexEnvf(e,e1,f);
00249           }
00250         }
00251     }
00252
00253   // GL_LIGHT_MODEL_TWO_SIDE, GL_TRUE/FALSE
00254   // GL_LIGHT_MODEL_TWO_SIDE, 0
00255   GLint LightModeli_LIGHT_MODEL_TWO_SIDE_bucket; // shoudld check other modes
00256   inline void glLightModeli(GLenum e,GLint i)
00257     {
00258       if(e==GL_LIGHT_MODEL_TWO_SIDE && i!=LightModeli_LIGHT_MODEL_TWO_SIDE_bucket){
00259       LightModeli_LIGHT_MODEL_TWO_SIDE_bucket=i;
00260       ::glLightModeli(e,i);
00261       }
00262     }
00263
00264   // GL_LIGHT_MODEL_AMBIENT, fvect(amb color), A=1.0
00265   // GL_LIGHT_MODEL_AMBIENT = 0x0B53
00266   GLfloat LightModelfv_LIGHT_MODEL_AMBIENT_bucket[3];
00267   inline void glLightModelfv(GLenum e,GLfloat *fv)
00268     {
00269       if(e==GL_LIGHT_MODEL_AMBIENT &&
00270          (fv[0]!=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[0] ||
00271           fv[1]!=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[1] ||
00272           fv[2]!=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[2])){
00273       fv[0]=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[0];
00274       fv[1]=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[1];
00275       fv[2]=LightModelfv_LIGHT_MODEL_AMBIENT_bucket[2];
00276       ::glLightModelfv(e,fv);
00277       }
00278     }
00279
00280   // light=GL_LIGHT index
00281   // pname= lighting type
00282   //   GL_DIFFUSE        = 0x1201
00283   //   GL_SPECULAR       = 0x1202
00284   //   GL_POSITION       = 0x1203
00285   //   GL_SPOT_DIRECTION = 0x1204
00286   GLfloat Lightfv_buckets[8*4*8];
00287   inline void glLightfv( GLenum light, GLenum pname, const GLfloat *params)
00288     {
00289       register GLfloat *val = Lightfv_buckets + ((((int)(pname-0x1201))|((int)(light-GL_LIGHT0)<<3))<<2);
00290       if(params[0]!=val[0] ||
00291          params[1]!=val[1] ||
00292          params[2]!=val[2] ||
00293          params[3]!=val[3])
00294         {
00295         val[0]=params[0];
00296         val[1]=params[1];
00297         val[2]=params[2];
00298         val[3]=params[3];
00299         ::glLightfv(light,pname,params);
00300         }
00301     }
00302
00303   // light=GL_LIGHT index
00304   // pname= lighting parameter
00305   //   GL_SPOT_EXPONENT        = 0x1205
00306   //   GL_SPOT_CUTOFF          = 0x1206
00307   //   GL_CONSTANT_ATTENUATION = 0x1207
00308   //   GL_LINEAR_ATTENUATION   = 0x1208
00309   //   GL_QUADRATIC_ATTENUATION= 0x1209
00310   GLfloat Lightf_buckets[8*8];
00311   GLint Lighti_SPOT_CUTOFF_buckets[8];
00312   inline void glLightf( GLenum light, GLenum pname, GLfloat f){
00313     register GLfloat *val=Lightf_buckets+(((int)(light-GL_LIGHT0)<<3)|((int)(pname-0x1205)));
00314     if(val[0]!=f)
00315       {
00316       val[0]=f;
00317       ::glLightf(light,pname,f);
00318       if(pname==GL_SPOT_CUTOFF) // invalidate integer spot cutoff
00319         Lighti_SPOT_CUTOFF_buckets[light-GL_LIGHT0]=-1;
00320       }
00321   }
00322
00323   // light=GL_LIGHT index
00324   // pname=lighting parameter
00325   //   GL_SPOT_CUTOFF = 0x1206
00326   // needs to invalidate the float light cutoff
00327   inline void glLighti( GLenum light, GLenum pname, GLint f)
00328     {
00329       if(pname==GL_SPOT_CUTOFF && f!=Lighti_SPOT_CUTOFF_buckets[light-GL_LIGHT0]){
00330       Lighti_SPOT_CUTOFF_buckets[light-GL_LIGHT0]=f;
00331       ::glLighti(light,pname,f);
00332       // need to invalidate the float cutoff
00333       Lightf_buckets[((int)(light-GL_LIGHT0)<<3)|0x02] = -1.0f;
00334       }
00335     }
00336
00337   // Face, GL_AMBIENT, float Info[4]
00338   //   GL_FRONT          = 0x0404
00339   //   GL_BACK           = 0x0405
00340   //   GL_FRONT_AND_BACK = 0x0408
00341   // GL_AMBIENT   = 0x1200
00342   // GL_DIFFUSE   = 0x1201
00343   // GL_SPECULAR  = 0x1202
00344   // GL_EMISSION  = 0x1600
00345   // GL_SHININESS = 0x1601
00346   // GL_AMBIENT_AND_DIFFUSE = 0x1602
00347   // GL_COLOR_INDEXES       = 0x1603
00348   GLfloat Materialfv_buckets[8*8*4];
00349   inline void glMaterialfv(GLenum face, GLenum pname, const GLfloat *params )
00350     {
00351       register int idx;
00352       register GLfloat *val;
00353       if(pname>=0x1600)
00354         {
00355         idx=pname-0x1600 + 4; // put it just past the 120x buckets
00356         }
00357       else
00358         {
00359         idx=pname-0x1200;
00360         }
00361       // FRONT/BACK and FRONT_AND_BACK should do both.
00362       // or perhaps should be a separate state key?
00363       // For now, we will treat FRONT_AND_BACK independently
00364       // because from a practical standpoint, that's how
00365       // it tends to get used.
00366       val = Materialfv_buckets + ((((face-0x0404)<<3)|idx)<<2);
00367       if(val[0]!=params[0] ||
00368          val[1]!=params[1] ||
00369          val[2]!=params[2] ||
00370          val[3]!=params[3])
00371         {
00372         val[0]=params[0];
00373         val[1]=params[1];
00374         val[2]=params[2];
00375         val[3]=params[3];
00376         ::glMaterialfv(face,pname,params);
00377         }
00378     }
00379
00380   /*
00381     a=0;
00382     a|=(val[0]^params[0])
00383     a|=(val[1]^params[1])
00384     a|=(val[2]^params[2])
00385     a|=(val[3]^params[3])
00386    */
00387   // GL_FLAT   = 0x1D00
00388   // GL_SMOOTH = 0x1D01
00389   GLenum ShadeModel_bucket;
00390   inline void glShadeModel(GLenum e)
00391     {
00392       if(ShadeModel_bucket!=e)
00393         {
00394         ShadeModel_bucket=e;
00395         ::glShadeModel(e);
00396         }
00397     }
00398
00399   GLclampf ClearColor_buckets[4];
00400   inline void glClearColor(GLclampf r,GLclampf g,GLclampf b,GLclampf a)
00401     {
00402       register GLclampf *c=ClearColor_buckets;
00403       if(c[0]!=r ||
00404          c[1]!=g ||
00405          c[2]!=b ||
00406          c[3]!=a)
00407         {
00408         c[0]=r;
00409         c[1]=g;
00410         c[2]=b;
00411         c[3]=a;
00412         ::glClearColor(r,g,b,a);
00413         }
00414     }
00415
00416   GLclampd ClearDepth_bucket;
00417   inline void glClearDepth(GLclampd d)
00418     {
00419       if(d!=ClearDepth_bucket)
00420         {
00421         ClearDepth_bucket=d;
00422         ::glClearDepth(d);
00423         }
00424     }
00425
00426   GLclampf DepthMask_bucket;
00427   inline void glDepthMask(GLenum e)
00428     {
00429       if(DepthMask_bucket!=e)
00430         {
00431         DepthMask_bucket=e;
00432         ::glDepthMask(e);
00433         }
00434     }
00435
00436   // GL_FRONT = 0x0404
00437   // GL_BACK  = 0x0405
00438   GLenum CullFace_bucket;
00439   inline void glCullFace(GLenum e)
00440     {
00441       if(CullFace_bucket!=e)
00442         {
00443         CullFace_bucket=e;
00444         ::glCullFace(e);
00445         }
00446     }
00447
00448   // well, lets go ahead and let it clear when it wants to
00449   inline void glClear(GLbitfield b) { ::glClear(b);}
00450   // GL_BACK_LEFT  = 0x0402
00451   // GL_BACK_RIGHT = 0x0403
00452   // GL_FRONT      = 0x0404
00453   // GL_BACK       = 0x0405
00454   GLenum DrawBuffer_bucket;
00455   inline void glDrawBuffer(GLenum e) {
00456     if(e!=DrawBuffer_bucket){
00457       DrawBuffer_bucket=e;
00458       ::glDrawBuffer(e);
00459     }
00460   }
00461   //============Matrix Ops (behave different for deferred ops)===
00462   // GL_MODELVIEW=0x1700
00463   // GL_PROJECTION=0x1701
00464   GLenum  MatrixMode_bucket;
00465   inline void glMatrixMode(GLenum e) {
00466     if(e!=MatrixMode_bucket){
00467       MatrixMode_bucket=e;
00468       ::glMatrixMode(e);
00469     }
00470   }
00471
00472   GLint Viewport_bucket[4];
00473   inline void glViewport(GLint llx,GLint lly,GLint u,GLint v){
00474     register GLint *val=Viewport_bucket;
00475     if(val[0]!=llx ||
00476        val[1]!=lly ||
00477        val[2]!=u ||
00478        val[3]!=v){
00479       val[0]=llx;
00480       val[1]=lly;
00481       val[2]=u;
00482       val[3]=v;
00483       ::glViewport(llx,lly,u,v);
00484     }
00485   }
00486   // only needs to be called if scissor changes (and it usually won't)
00487   GLint Scissor_bucket[4];
00488   inline void glScissor(GLint llx,GLint lly,GLint u,GLint v){
00489     register GLint *val=Scissor_bucket;
00490     if(val[0]!=llx ||
00491        val[1]!=lly ||
00492        val[2]!=u ||
00493        val[3]!=v){
00494       val[0]=llx;
00495       val[1]=lly;
00496       val[2]=u;
00497       val[3]=v;
00498       ::glScissor(llx,lly,u,v);
00499     }
00500   }
00501
00502   // what is the order of the clip plane eqn???
00503   // GL_CLIP_PLANE0 = 0x3000
00504   GLdouble ClipPlane_bucket[4*GL_MAX_CLIP_PLANES];
00505   inline void glClipPlane(GLenum e,const GLdouble *eqn){
00506     register GLdouble *val=ClipPlane_bucket + ((e-0x3000)<<2);
00507     if(val[0]!=eqn[0] ||
00508        val[1]!=eqn[1] ||
00509        val[2]!=eqn[2] ||
00510        val[3]!=eqn[3]){
00511       val[0]=eqn[0];
00512       val[1]=eqn[1];
00513       val[2]=eqn[2];
00514       val[3]=eqn[3];
00515       ::glClipPlane(e,eqn);
00516     }
00517   }
00518
00519   // face=
00520   //   GL_FRONT          = 0x0404
00521   //   GL_BACK           = 0x0405
00522   //   GL_FRONT_AND_BACK = 0x0408
00523   GLenum ColorMaterial_bucket[8];
00524   inline void glColorMaterial(GLenum face,GLenum mode ){
00525     register GLenum *val= ColorMaterial_bucket + (face-0x0404);
00526     if(*val!=mode){
00527       *val=mode;
00528       ::glColorMaterial(face,mode);
00529     }
00530   }
00531   GLfloat PointSize_bucket;
00532   inline void glPointSize(GLfloat f) {
00533     if(f!=PointSize_bucket){
00534       PointSize_bucket=f;
00535       ::glPointSize(f);
00536     }
00537   }
00538   GLfloat LineWidth_bucket;
00539   inline void glLineWidth(GLfloat f){
00540     if(f!=LineWidth_bucket){
00541       LineWidth_bucket=f;
00542       ::glPointSize(f);
00543     }
00544   }
00545   GLint LineStipple_FACTOR_bucket;
00546   GLushort LineStipple_PATTERN_bucket;
00547   inline void glLineStipple(GLint factor, GLushort pattern )
00548     {
00549       if(factor!=LineStipple_FACTOR_bucket ||
00550          pattern!=LineStipple_PATTERN_bucket)
00551         {
00552         LineStipple_FACTOR_bucket=factor;
00553         LineStipple_PATTERN_bucket=pattern;
00554         ::glLineStipple(factor,pattern);
00555         }
00556     }
00557
00558   GLclampd DepthRange_NEAR_bucket;
00559   GLclampd DepthRange_FAR_bucket;
00560   inline void glDepthRange(GLclampd nearval,GLclampd farval )
00561     {
00562       if(DepthRange_NEAR_bucket!=nearval ||
00563          DepthRange_FAR_bucket!=farval)
00564         {
00565         DepthRange_NEAR_bucket=nearval;
00566         DepthRange_FAR_bucket=farval;
00567         ::glDepthRange(nearval,farval);
00568         }
00569     }
00570
00571 #ifdef GL_VERSION_1_1
00572   // enable GL_POLYGON_OFFSET_FILL = 0x8037
00573   GLfloat PolygonOffset_bucket[2];
00574   inline void glPolygonOffset( GLfloat f,GLfloat u) {
00575     if(PolygonOffset_bucket[0]!=f ||
00576        PolygonOffset_bucket[1]!=u){
00577       PolygonOffset_bucket[0]=f;
00578       PolygonOffset_bucket[1]=u;
00579       ::glPolygonOffset(f,u);
00580     }
00581   }
00582 #endif
00583 };
00584
00585
00586 //#ifdef vtkOpenGLStateCache_Cache
00587 //#undef vtkOpenGLStateCache_Cache
00588 //#endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLTexture.h Source File

Rendering/vtkOpenGLTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkOpenGLTexture_h
00036 #define __vtkOpenGLTexture_h
00037
00038 #include "vtkTexture.h"
00039
00040 class vtkWindow;
00041 class vtkOpenGLRenderer;
00042 class vtkRenderWindow;
00043
00044 class VTK_RENDERING_EXPORT vtkOpenGLTexture : public vtkTexture
00045 {
00046 public:
00047   static vtkOpenGLTexture *New();
00048   vtkTypeRevisionMacro(vtkOpenGLTexture,vtkTexture);
00049
00051   void Load(vtkRenderer *ren);
00052
00057   void ReleaseGraphicsResources(vtkWindow *);
00058
00059 protected:
00060   vtkOpenGLTexture();
00061   ~vtkOpenGLTexture();
00062
00063   unsigned char *ResampleToPowerOfTwo(int &xsize, int &ysize,
00064                                       unsigned char *dptr, int bpp);
00065
00066   vtkTimeStamp   LoadTime;
00067   long          Index;
00068   vtkRenderWindow *RenderWindow;   // RenderWindow used for previous render
00069 private:
00070   vtkOpenGLTexture(const vtkOpenGLTexture&);  // Not implemented.
00071   void operator=(const vtkOpenGLTexture&);  // Not implemented.
00072 };
00073
00074 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLVolumeProVG500Mapper.h Source File

Rendering/vtkOpenGLVolumeProVG500Mapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLVolumeProVG500Mapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkOpenGLVolumeProVG500Mapper_h
00054 #define __vtkOpenGLVolumeProVG500Mapper_h
00055
00056 #include "vtkVolumeProVG500Mapper.h"
00057
00058 class VTK_VOLUMEPRO_EXPORT vtkOpenGLVolumeProVG500Mapper : public vtkVolumeProVG500Mapper
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkOpenGLVolumeProVG500Mapper,vtkVolumeProVG500Mapper);
00062   static vtkOpenGLVolumeProVG500Mapper *New();
00063
00064 protected:
00065   vtkOpenGLVolumeProVG500Mapper() {};
00066   ~vtkOpenGLVolumeProVG500Mapper() {};
00067
00068   // Render the hexagon returned by the hardware to the screen.
00069   void RenderHexagon( vtkRenderer  *ren,
00070                       vtkVolume    *vol,
00071                       VLIPixel     *basePlane,
00072                       int          size[2],
00073                       VLIVector3D  hexagon[6],
00074                       VLIVector2D  textureCoords[6] );
00075 private:
00076   vtkOpenGLVolumeProVG500Mapper(const vtkOpenGLVolumeProVG500Mapper&);  // Not implemented.
00077   void operator=(const vtkOpenGLVolumeProVG500Mapper&);  // Not implemented.
00078 };
00079
00080
00081 #endif
00082
00083
00084
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLVolumeProVP1000Mapper.h Source File

Rendering/vtkOpenGLVolumeProVP1000Mapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLVolumeProVP1000Mapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkOpenGLVolumeProVP1000Mapper_h
00053 #define __vtkOpenGLVolumeProVP1000Mapper_h
00054
00055 #include "vtkVolumeProVP1000Mapper.h"
00056
00057 class VTK_EXPORT vtkOpenGLVolumeProVP1000Mapper : public vtkVolumeProVP1000Mapper
00058 {
00059 public:
00060   vtkTypeRevisionMacro(vtkOpenGLVolumeProVP1000Mapper,vtkVolumeProVP1000Mapper);
00061   static vtkOpenGLVolumeProVP1000Mapper *New();
00062
00063 protected:
00064   vtkOpenGLVolumeProVP1000Mapper() {};
00065   ~vtkOpenGLVolumeProVP1000Mapper() {};
00066   vtkOpenGLVolumeProVP1000Mapper(const vtkOpenGLVolumeProVP1000Mapper&);
00067   void operator=(const vtkOpenGLVolumeProVP1000Mapper&);
00068
00069   // Render the hexagon returned by the hardware to the screen.
00070   void RenderImageBuffer( vtkRenderer  *ren,
00071                           vtkVolume    *vol,
00072                           int          size[2],
00073                           unsigned int *outData );
00074
00075   // Get the OpenGL depth buffer values in a the form needed for the
00076   // VolumePro board
00077   virtual void GetDepthBufferValues( vtkRenderer *ren, int size[2],
00078                                      unsigned int *outData);
00079
00080   // Render a bounding box of the volume because the texture map would be
00081   // too large
00082   virtual void RenderBoundingBox(vtkRenderer *ren, vtkVolume *vol);
00083 };
00084
00085
00086 #endif
00087
00088
00089
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLVolumeRayCastMapper.h Source File

Rendering/vtkOpenGLVolumeRayCastMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLVolumeRayCastMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00037 #ifndef __vtkOpenGLVolumeRayCastMapper_h
00038 #define __vtkOpenGLVolumeRayCastMapper_h
00039
00040 #include "vtkVolumeRayCastMapper.h"
00041 #include <stdlib.h>
00042 #ifndef VTK_IMPLEMENT_MESA_CXX
00043   #ifdef __APPLE__
00044     #include <OpenGL/gl.h>
00045   #else
00046     #include <GL/gl.h>
00047   #endif
00048 #endif
00049
00050 class VTK_RENDERING_EXPORT vtkOpenGLVolumeRayCastMapper : public vtkVolumeRayCastMapper
00051 {
00052 public:
00053   static vtkOpenGLVolumeRayCastMapper *New();
00054   vtkTypeRevisionMacro(vtkOpenGLVolumeRayCastMapper,vtkVolumeRayCastMapper);
00055
00056 protected:
00057   vtkOpenGLVolumeRayCastMapper();
00058   ~vtkOpenGLVolumeRayCastMapper();
00059
00060   void RenderTexture( vtkVolume *vol, vtkRenderer *ren);
00061
00062 private:
00063   vtkOpenGLVolumeRayCastMapper(const vtkOpenGLVolumeRayCastMapper&);  // Not implemented.
00064   void operator=(const vtkOpenGLVolumeRayCastMapper&);  // Not implemented.
00065 };
00066
00067 #endif
00068
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkOpenGLVolumeTextureMapper2D.h Source File

Rendering/vtkOpenGLVolumeTextureMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOpenGLVolumeTextureMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkOpenGLVolumeTextureMapper2D_h
00036 #define __vtkOpenGLVolumeTextureMapper2D_h
00037
00038 #include "vtkVolumeTextureMapper2D.h"
00039
00040 class VTK_RENDERING_EXPORT vtkOpenGLVolumeTextureMapper2D : public vtkVolumeTextureMapper2D
00041 {
00042 public:
00043   vtkTypeRevisionMacro(vtkOpenGLVolumeTextureMapper2D,vtkVolumeTextureMapper2D);
00044   void PrintSelf( ostream& os, vtkIndent index );
00045
00046   static vtkOpenGLVolumeTextureMapper2D *New();
00047
00048 //BTX
00049
00052   virtual void Render(vtkRenderer *ren, vtkVolume *vol);
00053
00054   void RenderQuads( int count, float *v, float *t,
00055                     unsigned char *texture, int size[2], int reverseFlag);
00056
00057 //ETX
00058
00059 protected:
00060   vtkOpenGLVolumeTextureMapper2D();
00061   ~vtkOpenGLVolumeTextureMapper2D();
00062
00063 private:
00064   vtkOpenGLVolumeTextureMapper2D(const vtkOpenGLVolumeTextureMapper2D&);  // Not implemented.
00065   void operator=(const vtkOpenGLVolumeTextureMapper2D&);  // Not implemented.
00066 };
00067
00068
00069 #endif
00070
00071
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkOrderedTriangulator.h Source File

Common/vtkOrderedTriangulator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOrderedTriangulator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00076 #ifndef __vtkOrderedTriangulator_h
00077 #define __vtkOrderedTriangulator_h
00078
00079 #include "vtkObject.h"
00080
00081 class vtkUnstructuredGrid;
00082 class vtkOTMesh;
00083 class vtkCellArray;
00084 class vtkMemoryPool;
00085
00086 class VTK_COMMON_EXPORT vtkOrderedTriangulator : public vtkObject
00087 {
00088 public:
00089   vtkTypeRevisionMacro(vtkOrderedTriangulator,vtkObject);
00090   void PrintSelf(ostream& os, vtkIndent indent);
00091
00093   static vtkOrderedTriangulator *New();
00094
00097   void InitTriangulation(float bounds[6], int numPts);
00098
00100
00110   vtkIdType InsertPoint(vtkIdType id, float x[3], int type);
00111   vtkIdType InsertPoint(vtkIdType id, vtkIdType sortid, float x[3], int type);
00112   vtkIdType InsertPoint(vtkIdType id, vtkIdType sortid,  vtkIdType sortid2,
00113                         float x[3], int type);
00115
00118   void Triangulate();
00119
00125   void UpdatePointType(vtkIdType internalId, int type);
00126
00128
00132   vtkSetMacro(PreSorted,int);
00133   vtkGetMacro(PreSorted,int);
00134   vtkBooleanMacro(PreSorted,int);
00136
00138
00140   vtkSetMacro(UseTwoSortIds,int);
00141   vtkGetMacro(UseTwoSortIds,int);
00142   vtkBooleanMacro(UseTwoSortIds,int);
00144
00154   vtkIdType GetTetras(int classification, vtkUnstructuredGrid *ugrid);
00155
00163   vtkIdType AddTetras(int classification, vtkUnstructuredGrid *ugrid);
00164
00170   vtkIdType AddTetras(int classification, vtkCellArray *connectivity);
00171
00172 protected:
00173   vtkOrderedTriangulator();
00174   ~vtkOrderedTriangulator();
00175
00176 private:
00177   vtkOTMesh  *Mesh;
00178   int NumberOfPoints; //number of points inserted
00179   int MaximumNumberOfPoints; //maximum possible number of points to be inserted
00180   int PreSorted;
00181   int UseTwoSortIds;
00182   vtkMemoryPool* Pool;
00183
00184 private:
00185   vtkOrderedTriangulator(const vtkOrderedTriangulator&);  // Not implemented.
00186   void operator=(const vtkOrderedTriangulator&);  // Not implemented.
00187 };
00188
00189 #endif
00190
00191
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOutlineCornerFilter.h Source File

Graphics/vtkOutlineCornerFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutlineCornerFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkOutlineCornerFilter_h
00037 #define __vtkOutlineCornerFilter_h
00038
00039 #include "vtkDataSetToPolyDataFilter.h"
00040 class vtkOutlineCornerSource;
00041
00042 class VTK_GRAPHICS_EXPORT vtkOutlineCornerFilter : public vtkDataSetToPolyDataFilter
00043 {
00044 public:
00045   vtkTypeRevisionMacro(vtkOutlineCornerFilter,vtkDataSetToPolyDataFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049   static vtkOutlineCornerFilter *New();
00050
00052
00054   vtkSetClampMacro(CornerFactor, float, 0.001, 0.5);
00055   vtkGetMacro(CornerFactor, float);
00057
00058 protected:
00059   vtkOutlineCornerFilter();
00060   ~vtkOutlineCornerFilter();
00061
00062   vtkOutlineCornerSource *OutlineCornerSource;
00063   void Execute();
00064   void ExecuteInformation();
00065
00066   float CornerFactor;
00067 private:
00068   vtkOutlineCornerFilter(const vtkOutlineCornerFilter&);  // Not implemented.
00069   void operator=(const vtkOutlineCornerFilter&);  // Not implemented.
00070 };
00071
00072 #endif
00073
00074
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOutlineCornerSource.h Source File

Graphics/vtkOutlineCornerSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutlineCornerSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkOutlineCornerSource_h
00033 #define __vtkOutlineCornerSource_h
00034
00035 #include "vtkOutlineSource.h"
00036
00037 class VTK_GRAPHICS_EXPORT vtkOutlineCornerSource : public vtkOutlineSource
00038 {
00039 public:
00040   vtkTypeRevisionMacro(vtkOutlineCornerSource,vtkOutlineSource);
00041   void PrintSelf(ostream& os, vtkIndent indent);
00042
00044   static vtkOutlineCornerSource *New();
00045
00047
00049   vtkSetClampMacro(CornerFactor, float, 0.001, 0.5);
00050   vtkGetMacro(CornerFactor, float);
00052
00053 protected:
00054   vtkOutlineCornerSource();
00055   ~vtkOutlineCornerSource() {};
00056
00057   void Execute();
00058
00059   float CornerFactor;
00060 private:
00061   vtkOutlineCornerSource(const vtkOutlineCornerSource&);  // Not implemented.
00062   void operator=(const vtkOutlineCornerSource&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOutlineFilter.h Source File

Graphics/vtkOutlineFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutlineFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkOutlineFilter_h
00042 #define __vtkOutlineFilter_h
00043
00044 #include "vtkDataSetToPolyDataFilter.h"
00045 class vtkOutlineSource;
00046
00047 class VTK_GRAPHICS_EXPORT vtkOutlineFilter : public vtkDataSetToPolyDataFilter
00048 {
00049 public:
00050   static vtkOutlineFilter *New();
00051   vtkTypeRevisionMacro(vtkOutlineFilter,vtkDataSetToPolyDataFilter);
00052
00053 protected:
00054   vtkOutlineFilter();
00055   ~vtkOutlineFilter();
00056
00057   vtkOutlineSource *OutlineSource;
00058   void Execute();
00059   void ExecuteInformation();
00060 private:
00061   vtkOutlineFilter(const vtkOutlineFilter&);  // Not implemented.
00062   void operator=(const vtkOutlineFilter&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
Generated on Mon Mar 25 01:07:43 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkOutlineSource.h Source File

Graphics/vtkOutlineSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutlineSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkOutlineSource_h
00034 #define __vtkOutlineSource_h
00035
00036 #include "vtkPolyDataSource.h"
00037
00038 class VTK_GRAPHICS_EXPORT vtkOutlineSource : public vtkPolyDataSource
00039 {
00040 public:
00041   static vtkOutlineSource *New();
00042   vtkTypeRevisionMacro(vtkOutlineSource,vtkPolyDataSource);
00043   void PrintSelf(ostream& os, vtkIndent indent);
00044
00046
00047   vtkSetVector6Macro(Bounds,float);
00048   vtkGetVectorMacro(Bounds,float,6);
00050
00051 protected:
00052   vtkOutlineSource();
00053   ~vtkOutlineSource() {};
00054
00055   void Execute();
00056   float Bounds[6];
00057 private:
00058   vtkOutlineSource(const vtkOutlineSource&);  // Not implemented.
00059   void operator=(const vtkOutlineSource&);  // Not implemented.
00060 };
00061
00062 #endif
00063
00064
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkOutputPort.h Source File

Parallel/vtkOutputPort.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutputPort.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkOutputPort_h
00051 #define __vtkOutputPort_h
00052
00053 #include "vtkProcessObject.h"
00054 #include "vtkMultiProcessController.h"
00055
00056
00057 class VTK_PARALLEL_EXPORT vtkOutputPort : public vtkProcessObject
00058 {
00059 public:
00060   static vtkOutputPort *New();
00061   vtkTypeRevisionMacro(vtkOutputPort,vtkProcessObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065
00066   void SetInput(vtkDataObject *input);
00067   vtkDataObject *GetInput();
00069
00071
00075   void SetTag(int tag);
00076   vtkGetMacro(Tag, int);
00078
00086   void WaitForUpdate() {this->Controller->ProcessRMIs();}
00087
00089
00090   vtkMultiProcessController *GetController() {return this->Controller;}
00091   vtkSetObjectMacro(Controller, vtkMultiProcessController);
00093
00095
00097   void TriggerUpdateInformation(int remoteProcessId);
00098   void TriggerUpdate(int remoteProcessId);
00100
00102
00103   vtkSetMacro(PipelineFlag, int);
00104   vtkGetMacro(PipelineFlag, int);
00105   vtkBooleanMacro(PipelineFlag, int);
00107
00111   void SetParameterMethod(void (*f)(void *), void *arg);
00112
00114   void SetParameterMethodArgDelete(void (*f)(void *));
00115
00116 protected:
00117   vtkOutputPort();
00118   ~vtkOutputPort();
00119
00120   int Tag;
00121
00122   vtkMultiProcessController *Controller;
00123   vtkTimeStamp UpdateTime;
00124
00125   // Stuff for pipeline parallelism.
00126   int PipelineFlag;
00127   void (*ParameterMethod)(void *);
00128   void (*ParameterMethodArgDelete)(void *);
00129   void *ParameterMethodArg;
00130 private:
00131   vtkOutputPort(const vtkOutputPort&);  // Not implemented.
00132   void operator=(const vtkOutputPort&);  // Not implemented.
00133 };
00134
00135 #endif
00136
00137
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkOutputWindow.h Source File

Common/vtkOutputWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOutputWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkOutputWindow_h
00040 #define __vtkOutputWindow_h
00041
00042 #include "vtkObject.h"
00043
00044 //BTX
00045
00046 class VTK_COMMON_EXPORT vtkOutputWindow;
00047
00048 class VTK_COMMON_EXPORT vtkOutputWindowSmartPointer
00049 {
00050 public:
00051   vtkOutputWindowSmartPointer(vtkOutputWindow* p) { this->Pointer=p; };
00052   void SetPointer(vtkOutputWindow* obj)
00053     {
00054       this->Pointer = obj;
00055     }
00056   ~vtkOutputWindowSmartPointer();
00057 private:
00058   vtkOutputWindow* Pointer;
00059 };
00060 //ETX
00061
00062 class VTK_COMMON_EXPORT vtkOutputWindow : public vtkObject
00063 {
00064 public:
00065 // Methods from vtkObject
00066   vtkTypeRevisionMacro(vtkOutputWindow,vtkObject);
00068   virtual void PrintSelf(ostream& os, vtkIndent indent);
00069
00071
00075   static vtkOutputWindow* New();
00076   // Description:
00077   // Return the singleton instance with no reference counting.
00078   static vtkOutputWindow* GetInstance();
00079   // Description:
00080   // Supply a user defined output window. Call ->Delete() on the supplied
00081   // instance after setting it.
00082   static void SetInstance(vtkOutputWindow *instance);
00083   // Description:
00084   // Display the text. Four virtual methods exist, depending on the type of
00085   // message to display. This allows redirection or reformatting of the
00086   // messages. The default implementation uses DisplayText for all.
00087   virtual void DisplayText(const char*);
00088   virtual void DisplayErrorText(const char*);
00089   virtual void DisplayWarningText(const char*);
00090   virtual void DisplayGenericWarningText(const char*);
00092
00093   virtual void DisplayDebugText(const char*);
00095
00097   vtkBooleanMacro(PromptUser,int);
00098   vtkSetMacro(PromptUser, int);
00100 //BTX
00101   // use this as a way of memory management when the
00102   // program exits the SmartPointer will be deleted which
00103   // will delete the Instance singleton
00104   static vtkOutputWindowSmartPointer SmartPointer;
00105 //ETX
00106 protected:
00107   vtkOutputWindow();
00108   virtual ~vtkOutputWindow();
00109   int PromptUser;
00110 private:
00111   static vtkOutputWindow* Instance;
00112 private:
00113   vtkOutputWindow(const vtkOutputWindow&);  // Not implemented.
00114   void operator=(const vtkOutputWindow&);  // Not implemented.
00115 };
00116
00117 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkOverrideInformation.h Source File

Common/vtkOverrideInformation.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOverrideInformation.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkOverrideInformation_h
00037 #define __vtkOverrideInformation_h
00038
00039
00040 #include "vtkObject.h"
00041 #include "vtkObjectFactory.h"
00042
00043
00044 class VTK_COMMON_EXPORT vtkOverrideInformation : public vtkObject
00045 {
00046 public:
00047   static vtkOverrideInformation* New();
00048   vtkTypeRevisionMacro(vtkOverrideInformation,vtkObject);
00050   virtual void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00056   const char* GetClassOverrideName()
00057     {
00058       return this->ClassOverrideName;
00059     }
00061
00063
00066   const char* GetClassOverrideWithName()
00067     {
00068       return this->ClassOverrideWithName;
00069     }
00071
00073
00075   const char* GetDescription()
00076     {
00077       return this->Description;
00078     }
00080
00082
00083   vtkObjectFactory* GetObjectFactory()
00084     {
00085       return this->ObjectFactory;
00086     }
00087   // Description:
00088   // Set the class override name
00089   vtkSetStringMacro(ClassOverrideName);
00090   // Set the class override with name
00091   vtkSetStringMacro(ClassOverrideWithName);
00092   // Set the description
00093   vtkSetStringMacro(Description);
00095 protected:
00096   vtkSetObjectMacro(ObjectFactory, vtkObjectFactory);
00097 private:
00098   vtkOverrideInformation();
00099   ~vtkOverrideInformation();
00100   // allow the object factory to set the values in this
00101   // class, but only the object factory
00102 //BTX
00103   friend class vtkObjectFactory;
00104 //ETX
00105
00106   char* ClassOverrideName;
00107   char* ClassOverrideWithName;
00108   char* Description;
00109   vtkObjectFactory* ObjectFactory;
00110 private:
00111   vtkOverrideInformation(const vtkOverrideInformation&);  // Not implemented.
00112   void operator=(const vtkOverrideInformation&);  // Not implemented.
00113 };
00114
00115 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkOverrideInformationCollection.h Source File

Common/vtkOverrideInformationCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkOverrideInformationCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkOverrideInformationCollection_h
00039 #define __vtkOverrideInformationCollection_h
00040
00041 #include "vtkCollection.h"
00042 #include "vtkOverrideInformation.h"
00043
00044 class VTK_COMMON_EXPORT vtkOverrideInformationCollection : public vtkCollection
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkOverrideInformationCollection,vtkCollection);
00048   static vtkOverrideInformationCollection *New();
00049
00051   void AddItem(vtkOverrideInformation *);
00052
00054   vtkOverrideInformation *GetNextItem();
00055
00056 protected:
00057   vtkOverrideInformationCollection() {};
00058   ~vtkOverrideInformationCollection() {};
00059
00060
00061 private:
00062   // hide the standard AddItem from the user and the compiler.
00063   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00064
00065 private:
00066   vtkOverrideInformationCollection(const vtkOverrideInformationCollection&);  // Not implemented.
00067   void operator=(const vtkOverrideInformationCollection&);  // Not implemented.
00068 };
00069
00070 inline void vtkOverrideInformationCollection::AddItem(vtkOverrideInformation *f)
00071 {
00072   this->vtkCollection::AddItem((vtkObject *)f);
00073 }
00074
00075 inline vtkOverrideInformation *vtkOverrideInformationCollection::GetNextItem()
00076 {
00077   return static_cast<vtkOverrideInformation *>(this->GetNextItemAsObject());
00078 }
00079
00080 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkParallelCoordinatesActor.h Source File

Rendering/vtkParallelCoordinatesActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkParallelCoordinatesActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00060 #ifndef __vtkParallelCoordinatesActor_h
00061 #define __vtkParallelCoordinatesActor_h
00062
00063 #include "vtkAxisActor2D.h"
00064 #include "vtkDataObject.h"
00065
00066 #define VTK_IV_COLUMN 0
00067 #define VTK_IV_ROW    1
00068
00069 class VTK_RENDERING_EXPORT vtkParallelCoordinatesActor : public vtkActor2D
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkParallelCoordinatesActor,vtkActor2D);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00079   static vtkParallelCoordinatesActor *New();
00080
00082
00085   vtkSetClampMacro(IndependentVariables,int,VTK_IV_COLUMN, VTK_IV_ROW);
00086   vtkGetMacro(IndependentVariables,int);
00087   void SetIndependentVariablesToColumns()
00088     {this->SetIndependentVariables(VTK_IV_COLUMN);};
00089   void SetIndependentVariablesToRows()
00090     {this->SetIndependentVariables(VTK_IV_ROW);};
00092
00094
00095   vtkSetStringMacro(Title);
00096   vtkGetStringMacro(Title);
00098
00100
00103   vtkSetClampMacro(NumberOfLabels, int, 0, 50);
00104   vtkGetMacro(NumberOfLabels, int);
00106
00108
00109   vtkSetMacro(Bold, int);
00110   vtkGetMacro(Bold, int);
00111   vtkBooleanMacro(Bold, int);
00113
00115
00116   vtkSetMacro(Italic, int);
00117   vtkGetMacro(Italic, int);
00118   vtkBooleanMacro(Italic, int);
00120
00122
00124   vtkSetMacro(Shadow, int);
00125   vtkGetMacro(Shadow, int);
00126   vtkBooleanMacro(Shadow, int);
00128
00130
00133   vtkSetMacro(FontFamily, int);
00134   vtkGetMacro(FontFamily, int);
00135   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00136   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00137   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00139
00141
00142   vtkSetStringMacro(LabelFormat);
00143   vtkGetStringMacro(LabelFormat);
00145
00147
00148   int RenderOpaqueGeometry(vtkViewport*);
00149   int RenderOverlay(vtkViewport*);
00150   int RenderTranslucentGeometry(vtkViewport *) {return 0;}
00152
00154
00155   vtkSetObjectMacro(Input,vtkDataObject);
00157
00159
00160   vtkGetObjectMacro(Input,vtkDataObject);
00162
00166   void ReleaseGraphicsResources(vtkWindow *);
00167
00168 protected:
00169   vtkParallelCoordinatesActor();
00170   ~vtkParallelCoordinatesActor();
00171
00172 private:
00173   vtkDataObject *Input; //list of data sets to plot
00174
00175   int IndependentVariables; //use column or row
00176   vtkIdType N; //the number of independent variables
00177   vtkAxisActor2D **Axes; //an array of axes
00178   float *Mins; //minimum data value along this row/column
00179   float *Maxs; //maximum data value along this row/column
00180   int   *Xs; //axes x-values (in viewport coordinates)
00181   int   YMin; //axes y-min-value (in viewport coordinates)
00182   int   YMax; //axes y-max-value (in viewport coordinates)
00183
00184   char *Title;
00185   vtkTextMapper *TitleMapper;
00186   vtkActor2D    *TitleActor;
00187
00188   vtkPolyData         *PlotData; //the lines drawn within the axes
00189   vtkPolyDataMapper2D *PlotMapper;
00190   vtkActor2D          *PlotActor;
00191
00192   // font characteristics
00193   int   NumberOfLabels; //along each axis
00194   int   Bold;
00195   int   Italic;
00196   int   Shadow;
00197   int   FontFamily;
00198   char  *LabelFormat;
00199
00200   vtkTimeStamp  BuildTime;
00201
00202   void Initialize();
00203   int PlaceAxes(vtkViewport *viewport, int *size);
00204 private:
00205   vtkParallelCoordinatesActor(const vtkParallelCoordinatesActor&);  // Not implemented.
00206   void operator=(const vtkParallelCoordinatesActor&);  // Not implemented.
00207 };
00208
00209
00210 #endif
00211
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkParallelFactory.h Source File

Parallel/vtkParallelFactory.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkParallelFactory.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkParallelFactory_h
00034 #define __vtkParallelFactory_h
00035
00036 #include "vtkObjectFactory.h"
00037
00038 class VTK_PARALLEL_EXPORT vtkParallelFactory : public vtkObjectFactory
00039 {
00040 public:
00041 // Methods from vtkObject
00042   vtkTypeRevisionMacro(vtkParallelFactory,vtkObjectFactory);
00043   static vtkParallelFactory *New();
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045   virtual const char* GetVTKSourceVersion();
00046   virtual const char* GetDescription();
00047 protected:
00048   vtkParallelFactory();
00049   ~vtkParallelFactory() { }
00050 private:
00051   vtkParallelFactory(const vtkParallelFactory&);  // Not implemented.
00052   void operator=(const vtkParallelFactory&);  // Not implemented.
00053 };
00054
00055 extern "C" VTK_PARALLEL_EXPORT vtkObjectFactory* vtkLoad();
00056 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkParticleReader.h Source File

IO/vtkParticleReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkParticleReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkParticleReader_h
00042 #define __vtkParticleReader_h
00043
00044 #include "vtkPolyDataSource.h"
00045
00046 #define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
00047 #define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1
00048
00049 class VTK_IO_EXPORT vtkParticleReader : public vtkPolyDataSource
00050 {
00051 public:
00052   static vtkParticleReader *New();
00053   vtkTypeRevisionMacro(vtkParticleReader,vtkPolyDataSource);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetStringMacro(FileName);
00059   vtkGetStringMacro(FileName);
00061
00063
00073   void SetDataByteOrderToBigEndian();
00074   void SetDataByteOrderToLittleEndian();
00075   int GetDataByteOrder();
00076   void SetDataByteOrder(int);
00077   const char *GetDataByteOrderAsString();
00079
00081
00082   vtkSetMacro(SwapBytes,int);
00083   int GetSwapBytes() {return this->SwapBytes;}
00084   vtkBooleanMacro(SwapBytes,int);
00086
00087 protected:
00088   vtkParticleReader();
00089   ~vtkParticleReader();
00090
00091   void OpenFile();
00092
00093   char *FileName;
00094   ifstream *File;
00095   int SwapBytes;
00096
00097   unsigned long NumberOfPoints;
00098
00099   void ExecuteInformation();
00100   void Execute();
00101 private:
00102   vtkParticleReader(const vtkParticleReader&);  // Not implemented.
00103   void operator=(const vtkParticleReader&);  // Not implemented.
00104 };
00105
00106 #endif
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkPCAAnalysisFilter.h Source File

Hybrid/vtkPCAAnalysisFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003 Program:   Visualization Toolkit
00004 Module:    $RCSfile: vtkPCAAnalysisFilter.h,v $
00005 Language:  C++
00006
00007 Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008 All rights reserved.
00009 See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011 This software is distributed WITHOUT ANY WARRANTY; without even
00012 the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013 PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkPCAAnalysisFilter_h
00062 #define __vtkPCAAnalysisFilter_h
00063
00064 #include "vtkSource.h"
00065
00066 class vtkFloatArray;
00067 class vtkPointSet;
00068
00069 class VTK_HYBRID_EXPORT vtkPCAAnalysisFilter : public vtkSource
00070 {
00071  public:
00072   vtkTypeRevisionMacro(vtkPCAAnalysisFilter,vtkSource);
00073
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078   static vtkPCAAnalysisFilter *New();
00079
00081
00082   vtkGetObjectMacro(Evals, vtkFloatArray);
00084
00086   void SetNumberOfInputs(int n);
00087
00090   void SetInput(int idx,vtkPointSet* p);
00091
00094   vtkPointSet* GetOutput(int idx);
00095
00102   void GetParameterisedShape(vtkFloatArray *b, vtkPointSet* shape);
00103
00109   void GetShapeParameters(vtkPointSet *shape, vtkFloatArray *b, int bsize);
00110
00113   vtkPointSet* GetInput(int idx);
00114
00117   int GetModesRequiredFor(float proportion);
00118
00119 protected:
00120   vtkPCAAnalysisFilter();
00121   ~vtkPCAAnalysisFilter();
00122
00124   void Execute();
00125
00126 private:
00127   vtkPCAAnalysisFilter(const vtkPCAAnalysisFilter&);  // Not implemented.
00128   void operator=(const vtkPCAAnalysisFilter&);  // Not implemented.
00129
00130   // Eigenvalues
00131   vtkFloatArray *Evals;
00132
00133   // Matrix where each column is an eigenvector
00134   double **evecMat2;
00135
00136   // The mean shape in a vector
00137   double *meanshape;
00138 };
00139
00140 #endif
00141
00142
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPCellDataToPointData.h Source File

Parallel/vtkPCellDataToPointData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPCellDataToPointData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkPCellDataToPointData_h
00036 #define __vtkPCellDataToPointData_h
00037
00038 #include "vtkCellDataToPointData.h"
00039
00040 class VTK_PARALLEL_EXPORT vtkPCellDataToPointData : public vtkCellDataToPointData
00041 {
00042 public:
00043   vtkTypeRevisionMacro(vtkPCellDataToPointData,vtkCellDataToPointData);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00046   static vtkPCellDataToPointData *New();
00047
00049
00051   vtkSetMacro(PieceInvariant, int);
00052   vtkGetMacro(PieceInvariant, int);
00053   vtkBooleanMacro(PieceInvariant, int);
00055
00056 protected:
00057   vtkPCellDataToPointData();
00058   ~vtkPCellDataToPointData() {};
00059
00060   // Usual data generation method
00061   virtual void Execute();
00062   void ComputeInputUpdateExtents(vtkDataObject *output);
00063
00064   int PieceInvariant;
00065 private:
00066   vtkPCellDataToPointData(const vtkPCellDataToPointData&);  // Not implemented.
00067   void operator=(const vtkPCellDataToPointData&);  // Not implemented.
00068 };
00069
00070 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPDataSetReader.h Source File

Parallel/vtkPDataSetReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPDataSetReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkPDataSetReader_h
00037 #define __vtkPDataSetReader_h
00038
00039 #include "vtkSource.h"
00040 #include "vtkDataSet.h"
00041 #include "vtkImageData.h"
00042
00043
00044 class VTK_PARALLEL_EXPORT vtkPDataSetReader : public vtkSource
00045 {
00046 public:
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048   vtkTypeRevisionMacro(vtkPDataSetReader,vtkSource);
00049   static vtkPDataSetReader *New();
00050
00052
00053   vtkSetStringMacro(FileName);
00054   vtkGetStringMacro(FileName);
00056
00058
00060   void SetOutput(vtkDataSet *output);
00061   virtual vtkDataSet *GetOutput();
00063
00065   virtual void Update();
00066
00068
00070   vtkGetMacro(DataType, int);
00072
00075   virtual int ReadOutputType();
00076
00077 protected:
00078   vtkPDataSetReader();
00079   ~vtkPDataSetReader();
00080   vtkPDataSetReader(const vtkPDataSetReader&);
00081   void operator=(const vtkPDataSetReader&);
00082
00083   virtual void ExecuteInformation();
00084   void ReadPVTKFileInformation(ifstream *fp);
00085   void ReadVTKFileInformation(ifstream *fp);
00086
00087   virtual void Execute();
00088   void PolyDataExecute();
00089   void UnstructuredGridExecute();
00090   void ImageDataExecute();
00091   void StructuredGridExecute();
00092
00093   void CoverExtent(int ext[6], int *pieceMask);
00094
00095   vtkDataSet *CheckOutput();
00096   void SetNumberOfPieces(int num);
00097
00098 //BTX
00099   ifstream *OpenFile();
00100 //ETX
00101   int ReadXML(ifstream *file, char **block, char **param, char **value);
00102
00103   int VTKFileFlag;
00104   int StructuredFlag;
00105   char *FileName;
00106   int DataType;
00107   int NumberOfPieces;
00108   char **PieceFileNames;
00109   int **PieceExtents;
00110 };
00111
00112 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPDataSetWriter.h Source File

Parallel/vtkPDataSetWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPDataSetWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkPDataSetWriter_h
00037 #define __vtkPDataSetWriter_h
00038
00039 #include "vtkDataSetWriter.h"
00040 #include "vtkImageData.h"
00041 #include "vtkStructuredGrid.h"
00042 #include "vtkRectilinearGrid.h"
00043
00044
00045 class VTK_PARALLEL_EXPORT vtkPDataSetWriter : public vtkDataSetWriter
00046 {
00047 public:
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049   vtkTypeRevisionMacro(vtkPDataSetWriter,vtkDataSetWriter);
00050   static vtkPDataSetWriter *New();
00051
00053   virtual void Write();
00054
00056
00057   void SetNumberOfPieces(int num);
00058   vtkGetMacro(NumberOfPieces, int);
00060
00062
00064   vtkSetMacro(GhostLevel, int);
00065   vtkGetMacro(GhostLevel, int);
00067
00069
00073   vtkSetMacro(StartPiece, int);
00074   vtkGetMacro(StartPiece, int);
00075   vtkSetMacro(EndPiece, int);
00076   vtkGetMacro(EndPiece, int);
00078
00080
00082   vtkSetStringMacro(FilePattern);
00083   vtkGetStringMacro(FilePattern);
00085
00087
00092   vtkSetMacro(UseRelativeFileNames, int);
00093   vtkGetMacro(UseRelativeFileNames, int);
00094   vtkBooleanMacro(UseRelativeFileNames, int);
00096
00097 protected:
00098   vtkPDataSetWriter();
00099   ~vtkPDataSetWriter();
00100   vtkPDataSetWriter(const vtkPDataSetWriter&);
00101   void operator=(const vtkPDataSetWriter&);
00102
00103 //BTX
00104   ostream *OpenFile();
00105   void WriteUnstructuredMetaData(vtkDataSet *input,
00106                           char *root, char *str, ostream *fptr);
00107   void WriteImageMetaData(vtkImageData *input,
00108                           char *root, char *str, ostream *fptr);
00109   void WriteRectilinearGridMetaData(vtkRectilinearGrid *input,
00110                           char *root, char *str, ostream *fptr);
00111   void WriteStructuredGridMetaData(vtkStructuredGrid *input,
00112                           char *root, char *str, ostream *fptr);
00113 //ETX
00114
00115   int StartPiece;
00116   int EndPiece;
00117   int NumberOfPieces;
00118   int GhostLevel;
00119
00120   int UseRelativeFileNames;
00121
00122   char *FilePattern;
00123 };
00124
00125 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPerlinNoise.h Source File

Filtering/vtkPerlinNoise.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPerlinNoise.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkPerlinNoise_h
00049 #define __vtkPerlinNoise_h
00050
00051 #include "vtkImplicitFunction.h"
00052
00053 class VTK_FILTERING_EXPORT vtkPerlinNoise : public vtkImplicitFunction
00054 {
00055 public:
00056   vtkTypeRevisionMacro(vtkPerlinNoise,vtkImplicitFunction);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   static vtkPerlinNoise *New();
00061
00063
00064   float EvaluateFunction(float x[3]);
00065   float EvaluateFunction(float x, float y, float z)
00066     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00068
00071   void EvaluateGradient(float x[3], float n[3]);
00072
00074
00077   vtkSetVector3Macro(Frequency,float);
00078   vtkGetVectorMacro(Frequency,float,3);
00080
00082
00086   vtkSetVector3Macro(Phase,float);
00087   vtkGetVectorMacro(Phase,float,3);
00089
00091
00093   vtkSetMacro(Amplitude,float);
00094   vtkGetMacro(Amplitude,float);
00096
00097 protected:
00098   vtkPerlinNoise();
00099   ~vtkPerlinNoise() {}
00100
00101   float Frequency[3];
00102   float Phase[3];
00103   float Amplitude;
00104
00105 private:
00106   vtkPerlinNoise(const vtkPerlinNoise&); //purposely not implemented
00107   void operator=(const vtkPerlinNoise&); //purposely not implemented
00108 };
00109
00110 #endif
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPerspectiveTransform.h Source File

Common/vtkPerspectiveTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPerspectiveTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00057 #ifndef __vtkPerspectiveTransform_h
00058 #define __vtkPerspectiveTransform_h
00059
00060 #include "vtkHomogeneousTransform.h"
00061
00062 class VTK_COMMON_EXPORT vtkPerspectiveTransform : public vtkHomogeneousTransform
00063 {
00064  public:
00065   static vtkPerspectiveTransform *New();
00066   vtkTypeRevisionMacro(vtkPerspectiveTransform,vtkHomogeneousTransform);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00072   void Identity() { this->Concatenation->Identity(); this->Modified(); };
00073
00077   void Inverse() { this->Concatenation->Inverse(); this->Modified(); };
00078
00080
00086   void AdjustViewport(double oldXMin, double oldXMax,
00087                       double oldYMin, double oldYMax,
00088                       double newXMin, double newXMax,
00089                       double newYMin, double newYMax);
00091
00093
00098   void AdjustZBuffer(double oldNearZ, double oldFarZ,
00099                      double newNearZ, double newFarZ);
00101
00103
00106   void Ortho(double xmin, double xmax, double ymin, double ymax,
00107              double znear, double zfar);
00109
00111
00115   void Frustum(double xmin, double xmax, double ymin, double ymax,
00116                double znear, double zfar);
00118
00123   void Perspective(double angle, double aspect, double znear, double zfar);
00124
00135   void Shear(double dxdz, double dydz, double zplane);
00136
00144   void Stereo(double angle, double focaldistance);
00145
00147
00150   void SetupCamera(const double position[3], const double focalpoint[3],
00151                    const double viewup[3]);
00153
00155
00157   void Translate(double x, double y, double z) {
00158     this->Concatenation->Translate(x,y,z); };
00159   void Translate(const double x[3]) { this->Translate(x[0], x[1], x[2]); };
00160   void Translate(const float x[3]) { this->Translate(x[0], x[1], x[2]); };
00162
00164
00168   void RotateWXYZ(double angle, double x, double y, double z) {
00169     this->Concatenation->Rotate(angle,x,y,z); };
00170   void RotateWXYZ(double angle, const double axis[3]) {
00171     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00172   void RotateWXYZ(double angle, const float axis[3]) {
00173     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00175
00177
00180   void RotateX(double angle) { this->RotateWXYZ(angle, 1, 0, 0); };
00181   void RotateY(double angle) { this->RotateWXYZ(angle, 0, 1, 0); };
00182   void RotateZ(double angle) { this->RotateWXYZ(angle, 0, 0, 1); };
00184
00186
00189   void Scale(double x, double y, double z) {
00190     this->Concatenation->Scale(x,y,z); };
00191   void Scale(const double s[3]) { this->Scale(s[0], s[1], s[2]); };
00192   void Scale(const float s[3]) { this->Scale(s[0], s[1], s[2]); };
00194
00196
00198   void SetMatrix(vtkMatrix4x4 *matrix) {
00199     this->SetMatrix(*matrix->Element); };
00200   void SetMatrix(const double elements[16]) {
00201     this->Identity(); this->Concatenate(elements); };
00203
00205
00207   void Concatenate(vtkMatrix4x4 *matrix) {
00208     this->Concatenate(*matrix->Element); };
00209   void Concatenate(const double elements[16]) {
00210     this->Concatenation->Concatenate(elements); };
00212
00218   void Concatenate(vtkHomogeneousTransform *transform);
00219
00221
00226   void PreMultiply() {
00227     if (this->Concatenation->GetPreMultiplyFlag()) { return; }
00228     this->Concatenation->SetPreMultiplyFlag(1); this->Modified(); };
00230
00232
00237   void PostMultiply()  {
00238     if (!this->Concatenation->GetPreMultiplyFlag()) { return; }
00239     this->Concatenation->SetPreMultiplyFlag(0); this->Modified(); };
00241
00243
00245   int GetNumberOfConcatenatedTransforms() {
00246     return this->Concatenation->GetNumberOfTransforms() +
00247       (this->Input == NULL ? 0 : 1); };
00249
00251
00256   vtkHomogeneousTransform *GetConcatenatedTransform(int i) {
00257     if (this->Input == NULL) {
00258       return (vtkHomogeneousTransform *)this->Concatenation->GetTransform(i); }
00259     else if (i < this->Concatenation->GetNumberOfPreTransforms()) {
00260       return (vtkHomogeneousTransform *)this->Concatenation->GetTransform(i); }
00261     else if (i > this->Concatenation->GetNumberOfPreTransforms()) {
00262       return (vtkHomogeneousTransform*)this->Concatenation->GetTransform(i-1);}
00263     else if (this->GetInverseFlag()) {
00264       return (vtkHomogeneousTransform *)this->Input->GetInverse(); }
00265     else {
00266       return (vtkHomogeneousTransform *)this->Input; } };
00268
00270
00276   void SetInput(vtkHomogeneousTransform *input);
00277   vtkHomogeneousTransform *GetInput() { return this->Input; };
00279
00281
00285   int GetInverseFlag() {
00286     return this->Concatenation->GetInverseFlag(); };
00288
00290
00291   void Push() { if (this->Stack == NULL) {
00292                     this->Stack = vtkTransformConcatenationStack::New(); }
00293                 this->Stack->Push(&this->Concatenation);
00294                 this->Modified(); };
00296
00298
00300   void Pop() { if (this->Stack == NULL) { return; }
00301                this->Stack->Pop(&this->Concatenation);
00302                this->Modified(); };
00304
00307   vtkAbstractTransform *MakeTransform();
00308
00315   int CircuitCheck(vtkAbstractTransform *transform);
00316
00318   unsigned long GetMTime();
00319
00320 protected:
00321   vtkPerspectiveTransform();
00322   ~vtkPerspectiveTransform();
00323
00324   void InternalDeepCopy(vtkAbstractTransform *t);
00325   void InternalUpdate();
00326
00327   vtkHomogeneousTransform *Input;
00328   vtkTransformConcatenation *Concatenation;
00329   vtkTransformConcatenationStack *Stack;
00330 private:
00331   vtkPerspectiveTransform(const vtkPerspectiveTransform& t);  // Not implemented.
00332   void operator=(const vtkPerspectiveTransform&);  // Not implemented.
00333 };
00334
00335
00336 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkPicker.h Source File

Rendering/vtkPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkPicker_h
00053 #define __vtkPicker_h
00054
00055 #include "vtkObject.h"
00056 #include "vtkAbstractPropPicker.h"
00057 #include "vtkRenderer.h"
00058 #include "vtkActor.h"
00059 #include "vtkActorCollection.h"
00060 #include "vtkProp3DCollection.h"
00061 #include "vtkMapper.h"
00062 #include "vtkTransform.h"
00063
00064 class VTK_RENDERING_EXPORT vtkPicker : public vtkAbstractPropPicker
00065 {
00066 public:
00067   static vtkPicker *New();
00068   vtkTypeRevisionMacro(vtkPicker,vtkAbstractPropPicker);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00072
00075   vtkSetMacro(Tolerance,float);
00076   vtkGetMacro(Tolerance,float);
00078
00080
00082   vtkGetVectorMacro(MapperPosition,float,3);
00084
00086
00087   vtkGetObjectMacro(Mapper,vtkAbstractMapper3D);
00089
00091
00093   vtkGetObjectMacro(DataSet,vtkDataSet);
00095
00098   vtkProp3DCollection *GetProp3Ds() {return this->Prop3Ds;};
00099
00101
00104   vtkActorCollection *GetActors() {
00105     if (this->Actors->GetNumberOfItems() !=
00106         this->PickedPositions->GetNumberOfPoints()) {
00107       vtkWarningMacro(<<"Not all Prop3Ds are actors, use GetProp3Ds instead");}
00108     return this->Actors; };
00110
00114   vtkPoints *GetPickedPositions() {return this->PickedPositions;};
00115
00117
00121   virtual int Pick(float selectionX, float selectionY, float selectionZ,
00122                    vtkRenderer *renderer);
00124
00126
00130   int Pick(float selectionPt[3], vtkRenderer *ren)
00131     {return this->Pick(selectionPt[0], selectionPt[1], selectionPt[2], ren);};
00133
00134 protected:
00135   vtkPicker();
00136   ~vtkPicker();
00137
00138   void MarkPicked(vtkAssemblyPath *path, vtkProp3D *p, vtkAbstractMapper3D *m,
00139                   float tMin, float mapperPos[3]);
00140   virtual float IntersectWithLine(float p1[3], float p2[3], float tol,
00141                                   vtkAssemblyPath *path, vtkProp3D *p,
00142                                   vtkAbstractMapper3D *m);
00143   virtual void Initialize();
00144
00145   float Tolerance; //tolerance for computation (% of window)
00146   float MapperPosition[3]; //selection point in untransformed coordinates
00147
00148   vtkAbstractMapper3D *Mapper; //selected mapper (if the prop has a mapper)
00149   vtkDataSet *DataSet; //selected dataset (if there is one)
00150
00151   float GlobalTMin; //parametric coordinate along pick ray where hit occured
00152   vtkTransform *Transform; //use to perform ray transformation
00153   vtkActorCollection *Actors; //candidate actors (based on bounding box)
00154   vtkProp3DCollection *Prop3Ds; //candidate actors (based on bounding box)
00155   vtkPoints *PickedPositions; // candidate positions
00156
00157 private:
00158   vtkPicker(const vtkPicker&);  // Not implemented.
00159   void operator=(const vtkPicker&);  // Not implemented.
00160 };
00161
00162
00163 #endif
00164
00165
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPieceScalars.h Source File

Parallel/vtkPieceScalars.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPieceScalars.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkPieceScalars_h
00041 #define __vtkPieceScalars_h
00042
00043 #include "vtkDataSetToDataSetFilter.h"
00044
00045 class VTK_PARALLEL_EXPORT vtkPieceScalars : public vtkDataSetToDataSetFilter
00046 {
00047 public:
00048   static vtkPieceScalars *New();
00049
00050   vtkTypeRevisionMacro(vtkPieceScalars,vtkDataSetToDataSetFilter);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00056   void SetScalarModeToCellData() {this->SetCellScalarsFlag(1);}
00057   void SetScalarModeToPointData() {this->SetCellScalarsFlag(0);}
00058   int GetScalarMode() {return this->CellScalarsFlag;}
00060
00061   // Dscription:
00062   // This option uses a random mapping between pieces and scalar values.
00063   // The scalar values are choosen between 0 and 1.  By default, random mode is off.
00064   vtkSetMacro(RandomMode, int);
00065   vtkGetMacro(RandomMode, int);
00066   vtkBooleanMacro(RandomMode, int);
00067
00068 protected:
00069   vtkPieceScalars();
00070   ~vtkPieceScalars();
00071
00072   // Append the pieces.
00073   void Execute();
00074
00075   vtkIntArray *MakePieceScalars(int piece, vtkIdType numScalars);
00076   vtkFloatArray *MakeRandomScalars(int piece, vtkIdType numScalars);
00077
00078   vtkSetMacro(CellScalarsFlag,int);
00079   int CellScalarsFlag;
00080   int RandomMode;
00081 private:
00082   vtkPieceScalars(const vtkPieceScalars&);  // Not implemented.
00083   void operator=(const vtkPieceScalars&);  // Not implemented.
00084 };
00085
00086 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPiecewiseFunction.h Source File

Filtering/vtkPiecewiseFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPiecewiseFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00043 #ifndef __vtkPiecewiseFunction_h
00044 #define __vtkPiecewiseFunction_h
00045
00046 #include "vtkDataObject.h"
00047
00048 class VTK_FILTERING_EXPORT vtkPiecewiseFunction : public vtkDataObject
00049 {
00050 public:
00051   static vtkPiecewiseFunction *New();
00052   vtkTypeRevisionMacro(vtkPiecewiseFunction,vtkDataObject);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00055   vtkDataObject *MakeObject();
00056   void Initialize();
00057   void DeepCopy( vtkDataObject *f );
00058   void ShallowCopy( vtkDataObject *f );
00059
00061   int GetDataObjectType() {return VTK_PIECEWISE_FUNCTION;};
00062
00064   int  GetSize();
00065
00067
00069   void AddPoint( float x, float val );
00070   void RemovePoint( float x );
00072
00074   void RemoveAllPoints();
00075
00078   void AddSegment( float x1, float val1, float x2, float val2 );
00079
00083   float GetValue( float x );
00084
00086   float *GetDataPointer() {return this->Function;};
00087
00089   float *GetRange();
00090
00095   void GetTable( float x1, float x2, int size, float *table, int stride=1 );
00096
00098
00103   void BuildFunctionFromTable( float x1, float x2, int size,
00104                                float *table, int stride=1 );
00106
00108
00114   vtkSetMacro( Clamping, int );
00115   vtkGetMacro( Clamping, int );
00116   vtkBooleanMacro( Clamping, int );
00118
00124   const char  *GetType();
00125
00128   unsigned long GetMTime();
00129
00132   float GetFirstNonZeroValue();
00133
00134 protected:
00135   vtkPiecewiseFunction();
00136   ~vtkPiecewiseFunction();
00137
00138   // Size of the array used to store function points
00139   int   ArraySize;
00140
00141   // Determines the function value outside of defined points
00142   // Zero = always return 0.0 outside of defined points
00143   // One  = clamp to the lowest value below defined points and
00144   //        highest value above defined points
00145   int   Clamping;
00146
00147   // Array of points ((X,Y) pairs)
00148   float *Function;
00149
00150   // Number of points used to specify function
00151   int   FunctionSize;
00152
00153   // Min and max range of function point locations
00154   float FunctionRange[2];
00155
00156   // Increases size of the function array. The array grows by a factor of 2
00157   // when the array limit has been reached.
00158   void IncreaseArraySize();
00159
00160   // Private function to add a point to the function. Returns the array
00161   // index of the inserted point.
00162   int InsertPoint( float x, float val );
00163
00164   // Move points one index down or up in the array. This is useful for
00165   // inserting and deleting points into the array.
00166   void MovePoints( int index, int down );
00167 private:
00168   vtkPiecewiseFunction(const vtkPiecewiseFunction&);  // Not implemented.
00169   void operator=(const vtkPiecewiseFunction&);  // Not implemented.
00170 };
00171
00172 #endif
00173
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPiecewiseFunctionShiftScale.h Source File

Filtering/vtkPiecewiseFunctionShiftScale.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPiecewiseFunctionShiftScale.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00031 #ifndef __vtkPiecewiseFunctionShiftScale_h
00032 #define __vtkPiecewiseFunctionShiftScale_h
00033
00034 #include "vtkPiecewiseFunctionToPiecewiseFunctionFilter.h"
00035 #include "vtkPiecewiseFunction.h"
00036
00037 class VTK_FILTERING_EXPORT vtkPiecewiseFunctionShiftScale : public vtkPiecewiseFunctionToPiecewiseFunctionFilter
00038 {
00039 public:
00040   static vtkPiecewiseFunctionShiftScale *New();
00041   vtkTypeRevisionMacro(vtkPiecewiseFunctionShiftScale, vtkPiecewiseFunctionToPiecewiseFunctionFilter);
00042   void PrintSelf(ostream& os, vtkIndent indent);
00043
00044   vtkSetMacro(PositionShift, float);
00045   vtkSetMacro(PositionScale, float);
00046   vtkSetMacro(ValueShift, float);
00047   vtkSetMacro(ValueScale, float);
00048
00049   vtkGetMacro(PositionShift, float);
00050   vtkGetMacro(PositionScale, float);
00051   vtkGetMacro(ValueShift, float);
00052   vtkGetMacro(ValueScale, float);
00053
00054 protected:
00055   vtkPiecewiseFunctionShiftScale();
00056   ~vtkPiecewiseFunctionShiftScale();
00057
00058   void Execute();
00059
00060   vtkPiecewiseFunction *Input;
00061
00062   float PositionShift;
00063   float PositionScale;
00064   float ValueShift;
00065   float ValueScale;
00066
00067 private:
00068   vtkPiecewiseFunctionShiftScale(const vtkPiecewiseFunctionShiftScale&);  // Not implemented
00069   void operator=(const vtkPiecewiseFunctionShiftScale&);  // Not implemented
00070 };
00071
00072 #endif
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPiecewiseFunctionSource.h Source File

Filtering/vtkPiecewiseFunctionSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPiecewiseFunctionSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkPiecewiseFunctionSource_h
00033 #define __vtkPiecewiseFunctionSource_h
00034
00035 #include "vtkSource.h"
00036 #include "vtkPiecewiseFunction.h"
00037
00038 class VTK_FILTERING_EXPORT vtkPiecewiseFunctionSource : public vtkSource
00039 {
00040 public:
00041   static vtkPiecewiseFunctionSource *New();
00042   vtkTypeRevisionMacro(vtkPiecewiseFunctionSource,vtkSource);
00043
00045
00046   vtkPiecewiseFunction *GetOutput();
00047   vtkPiecewiseFunction *GetOutput(int idx)
00048     {return (vtkPiecewiseFunction *) this->vtkSource::GetOutput(idx); };
00049   void SetOutput(vtkPiecewiseFunction *output);
00051
00052 protected:
00053   vtkPiecewiseFunctionSource();
00054   ~vtkPiecewiseFunctionSource() {};
00055
00056 private:
00057   vtkPiecewiseFunctionSource(const vtkPiecewiseFunctionSource&);  // Not implemented.
00058   void operator=(const vtkPiecewiseFunctionSource&);  // Not implemented.
00059 };
00060
00061 #endif
00062
00063
00064
00065
00066
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPiecewiseFunctionToPiecewiseFunctionFilter.h Source File

Filtering/vtkPiecewiseFunctionToPiecewiseFunctionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPiecewiseFunctionToPiecewiseFunctionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkPiecewiseFunctionToPiecewiseFunctionFilter_h
00034 #define __vtkPiecewiseFunctionToPiecewiseFunctionFilter_h
00035
00036 #include "vtkPiecewiseFunctionSource.h"
00037 #include "vtkPiecewiseFunction.h"
00038
00039 class VTK_FILTERING_EXPORT vtkPiecewiseFunctionToPiecewiseFunctionFilter : public vtkPiecewiseFunctionSource
00040 {
00041 public:
00042   vtkTypeRevisionMacro(vtkPiecewiseFunctionToPiecewiseFunctionFilter,vtkPiecewiseFunctionSource);
00043
00045
00046   virtual void SetInput(vtkPiecewiseFunction *input);
00047   vtkPiecewiseFunction *GetInput();
00049
00050 protected:
00051    vtkPiecewiseFunctionToPiecewiseFunctionFilter();
00052   ~vtkPiecewiseFunctionToPiecewiseFunctionFilter() {};
00053
00054 private:
00055   vtkPiecewiseFunctionToPiecewiseFunctionFilter(const vtkPiecewiseFunctionToPiecewiseFunctionFilter&);  // Not implemented.
00056   void operator=(const vtkPiecewiseFunctionToPiecewiseFunctionFilter&);  // Not implemented.
00057 };
00058
00059 #endif
00060
00061
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPImageWriter.h Source File

Parallel/vtkPImageWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPImageWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkPImageWriter_h
00037 #define __vtkPImageWriter_h
00038
00039 #include "vtkImageWriter.h"
00040 class vtkPipelineSize;
00041
00042 class VTK_PARALLEL_EXPORT vtkPImageWriter : public vtkImageWriter
00043 {
00044 public:
00045   static vtkPImageWriter *New();
00046   vtkTypeRevisionMacro(vtkPImageWriter,vtkImageWriter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00052   vtkSetMacro(MemoryLimit, unsigned long);
00053   vtkGetMacro(MemoryLimit, unsigned long);
00055
00056 protected:
00057   vtkPImageWriter();
00058   ~vtkPImageWriter();
00059
00060   unsigned long MemoryLimit;
00061
00062   virtual void RecursiveWrite(int dim, vtkImageData *region, ofstream *file);
00063   virtual void RecursiveWrite(int dim, vtkImageData *cache,
00064                               vtkImageData *data, ofstream *file)
00065     {this->vtkImageWriter::RecursiveWrite(dim,cache,data,file);};
00066
00067   vtkPipelineSize *SizeEstimator;
00068 private:
00069   vtkPImageWriter(const vtkPImageWriter&);  // Not implemented.
00070   void operator=(const vtkPImageWriter&);  // Not implemented.
00071 };
00072
00073 #endif
00074
00075
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPipelineSize.h Source File

Parallel/vtkPipelineSize.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPipelineSize.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkPipelineSize_h
00033 #define __vtkPipelineSize_h
00034
00035 #include "vtkObject.h"
00036 class vtkSource;
00037 class vtkDataObject;
00038 class vtkPolyDataMapper;
00039
00040 class VTK_PARALLEL_EXPORT vtkPipelineSize : public vtkObject
00041 {
00042 public:
00044   static vtkPipelineSize* New();
00045   vtkTypeRevisionMacro(vtkPipelineSize,vtkObject);
00047
00052   unsigned long GetEstimatedSize(vtkDataObject *input);
00053
00055
00058   unsigned long GetNumberOfSubPieces(unsigned long memoryLimit,
00059                                      vtkPolyDataMapper *mapper);
00061
00062 protected:
00063   vtkPipelineSize() {};
00064   void GenericComputeSourcePipelineSize(vtkSource *src,
00065                                         vtkDataObject *output,
00066                                         unsigned long size[3]);
00067   void ComputeSourcePipelineSize(vtkSource *src,
00068                                  vtkDataObject *output,
00069                                  unsigned long size[3]);
00070   void ComputeOutputMemorySize( vtkSource *src,
00071                                 vtkDataObject *output,
00072                                 unsigned long *inputSize,
00073                                 unsigned long size[2] );
00074   void GenericComputeOutputMemorySize( vtkSource *src,
00075                                        vtkDataObject *output,
00076                                        unsigned long *inputSize,
00077                                        unsigned long size[2] );
00078   void ComputeDataPipelineSize(vtkDataObject *input,
00079                                unsigned long sizes[3]);
00080
00081
00082 private:
00083   vtkPipelineSize(const vtkPipelineSize&);  // Not implemented.
00084   void operator=(const vtkPipelineSize&);  // Not implemented.
00085 };
00086
00087 #endif
00088
00089
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPixel.h Source File

Common/vtkPixel.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPixel.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkPixel_h
00044 #define __vtkPixel_h
00045
00046 #include "vtkCell.h"
00047 #include "vtkLine.h"
00048
00049 class VTK_COMMON_EXPORT vtkPixel : public vtkCell
00050 {
00051 public:
00052   static vtkPixel *New();
00053   vtkTypeRevisionMacro(vtkPixel,vtkCell);
00054
00056
00057   vtkCell *MakeObject();
00058   int GetCellType() {return VTK_PIXEL;};
00059   int GetCellDimension() {return 2;};
00060   int GetNumberOfEdges() {return 4;};
00061   int GetNumberOfFaces() {return 0;};
00062   vtkCell *GetEdge(int edgeId);
00063   vtkCell *GetFace(int) {return 0;};
00064   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00065   void Contour(float value, vtkDataArray *cellScalars,
00066                vtkPointLocator *locator, vtkCellArray *verts,
00067                vtkCellArray *lines, vtkCellArray *polys,
00068                vtkPointData *inPd, vtkPointData *outPd,
00069                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00070   void Clip(float value, vtkDataArray *cellScalars,
00071             vtkPointLocator *locator, vtkCellArray *polys,
00072             vtkPointData *inPd, vtkPointData *outPd,
00073             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00074             int insideOut);
00075   int EvaluatePosition(float x[3], float* closestPoint,
00076                        int& subId, float pcoords[3],
00077                        float& dist2, float *weights);
00078   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00079                         float *weights);
00080   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00081                         float x[3], float pcoords[3], int& subId);
00082   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00083   void Derivatives(int subId, float pcoords[3], float *values,
00084                    int dim, float *derivs);
00086
00088
00089   static void InterpolationFunctions(float pcoords[3], float weights[4]);
00090   static void InterpolationDerivs(float pcoords[3], float derivs[8]);
00092
00093
00094 protected:
00095   vtkPixel();
00096   ~vtkPixel();
00097
00098   vtkLine *Line;
00099
00100 private:
00101   vtkPixel(const vtkPixel&);  // Not implemented.
00102   void operator=(const vtkPixel&);  // Not implemented.
00103 };
00104
00105 #endif
00106
00107
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPlane.h Source File

Common/vtkPlane.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPlane.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkPlane_h
00044 #define __vtkPlane_h
00045
00046 #include <math.h>
00047 #include "vtkImplicitFunction.h"
00048
00049 class VTK_COMMON_EXPORT vtkPlane : public vtkImplicitFunction
00050 {
00051 public:
00053   static vtkPlane *New();
00054
00055   vtkTypeRevisionMacro(vtkPlane,vtkImplicitFunction);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   float EvaluateFunction(float x[3]);
00061   float EvaluateFunction(float x, float y, float z)
00062     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00064
00066   void EvaluateGradient(float x[3], float g[3]);
00067
00069
00070   vtkSetVector3Macro(Normal,float);
00071   vtkGetVectorMacro(Normal,float,3);
00073
00075
00077   vtkSetVector3Macro(Origin,float);
00078   vtkGetVectorMacro(Origin,float,3);
00080
00082
00085   static void ProjectPoint(float x[3], float origin[3], float normal[3],
00086                            float xproj[3]);
00087   static void ProjectPoint(double x[3], double origin[3], double normal[3],
00088                            double xproj[3]);
00090
00092
00095   static void GeneralizedProjectPoint(float x[3], float origin[3],
00096                                       float normal[3], float xproj[3]);
00098
00100
00101   static float Evaluate(float normal[3], float origin[3], float x[3]);
00102   static float Evaluate(double normal[3], double origin[3], double x[3]);
00104
00107   static float DistanceToPlane(float x[3], float n[3], float p0[3]);
00108
00110
00115   static int IntersectWithLine(float p1[3], float p2[3], float n[3],
00116                                float p0[3], float& t, float x[3]);
00118
00119
00120 protected:
00121   vtkPlane();
00122   ~vtkPlane() {};
00123
00124   float Normal[3];
00125   float Origin[3];
00126
00127 private:
00128   vtkPlane(const vtkPlane&);  // Not implemented.
00129   void operator=(const vtkPlane&);  // Not implemented.
00130 };
00131
00132 inline float vtkPlane::Evaluate(float normal[3], float origin[3], float x[3])
00133 {
00134   return normal[0]*(x[0]-origin[0]) + normal[1]*(x[1]-origin[1]) +
00135          normal[2]*(x[2]-origin[2]);
00136 }
00137 inline float vtkPlane::Evaluate(double normal[3], double origin[3],double x[3])
00138 {
00139   return normal[0]*(x[0]-origin[0]) + normal[1]*(x[1]-origin[1]) +
00140          normal[2]*(x[2]-origin[2]);
00141 }
00142
00143 inline float vtkPlane::DistanceToPlane(float x[3], float n[3], float p0[3])
00144 {
00145   return ((float) fabs(n[0]*(x[0]-p0[0]) + n[1]*(x[1]-p0[1]) +
00146                        n[2]*(x[2]-p0[2])));
00147 }
00148
00149 #endif
00150
00151
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPlaneCollection.h Source File

Common/vtkPlaneCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPlaneCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkPlaneCollection_h
00038 #define __vtkPlaneCollection_h
00039
00040 #include "vtkCollection.h"
00041 #include "vtkPlane.h"
00042
00043 class VTK_COMMON_EXPORT vtkPlaneCollection : public vtkCollection
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkPlaneCollection,vtkCollection);
00047   static vtkPlaneCollection *New();
00048
00050   void AddItem(vtkPlane *);
00051
00053   vtkPlane *GetNextItem();
00054
00055 protected:
00056   vtkPlaneCollection() {};
00057   ~vtkPlaneCollection() {};
00058
00059
00060 private:
00061   // hide the standard AddItem from the user and the compiler.
00062   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00063
00064 private:
00065   vtkPlaneCollection(const vtkPlaneCollection&);  // Not implemented.
00066   void operator=(const vtkPlaneCollection&);  // Not implemented.
00067 };
00068
00069 inline void vtkPlaneCollection::AddItem(vtkPlane *f)
00070 {
00071   this->vtkCollection::AddItem((vtkObject *)f);
00072 }
00073
00074 inline vtkPlane *vtkPlaneCollection::GetNextItem()
00075 {
00076   return static_cast<vtkPlane *>(this->GetNextItemAsObject());
00077 }
00078
00079 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPlanes.h Source File

Common/vtkPlanes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPlanes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkPlanes_h
00053 #define __vtkPlanes_h
00054
00055 #include "vtkImplicitFunction.h"
00056
00057 class vtkPlane;
00058
00059 class VTK_COMMON_EXPORT vtkPlanes : public vtkImplicitFunction
00060 {
00061 public:
00062   static vtkPlanes *New();
00063   vtkTypeRevisionMacro(vtkPlanes,vtkImplicitFunction);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067
00068   float EvaluateFunction(float x[3]);
00069   float EvaluateFunction(float x, float y, float z)
00070     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00072
00074   void EvaluateGradient(float x[3], float n[3]);
00075
00077
00079   vtkSetObjectMacro(Points,vtkPoints);
00080   vtkGetObjectMacro(Points,vtkPoints);
00082
00084
00086   void SetNormals(vtkDataArray* normals);
00087   vtkGetObjectMacro(Normals,vtkDataArray);
00089
00092   void SetFrustumPlanes(float planes[24]);
00093
00095
00099   void SetBounds(float bounds[6]);
00100   void SetBounds(float xmin, float xmax, float ymin, float ymax,
00101                  float zmin, float zmax);
00103
00105   int GetNumberOfPlanes();
00106
00110   vtkPlane *GetPlane(int i);
00111
00112 protected:
00113   vtkPlanes();
00114   ~vtkPlanes();
00115
00116   vtkPoints *Points;
00117   vtkDataArray *Normals;
00118   vtkPlane *Plane;
00119
00120 private:
00121   float Planes[24];
00122   float Bounds[6];
00123
00124 private:
00125   vtkPlanes(const vtkPlanes&);  // Not implemented.
00126   void operator=(const vtkPlanes&);  // Not implemented.
00127 };
00128
00129 #endif
00130
00131
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPlaneSource.h Source File

Graphics/vtkPlaneSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPlaneSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkPlaneSource_h
00063 #define __vtkPlaneSource_h
00064
00065 #include "vtkPolyDataSource.h"
00066
00067 class VTK_GRAPHICS_EXPORT vtkPlaneSource : public vtkPolyDataSource
00068 {
00069 public:
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071   vtkTypeRevisionMacro(vtkPlaneSource,vtkPolyDataSource);
00072
00075   static vtkPlaneSource *New();
00076
00078
00079   vtkSetMacro(XResolution,int);
00080   vtkGetMacro(XResolution,int);
00082
00084
00085   vtkSetMacro(YResolution,int);
00086   vtkGetMacro(YResolution,int);
00088
00090
00091   void SetResolution(const int xR, const int yR);
00092   void GetResolution(int& xR,int& yR) {
00093     xR=this->XResolution; yR=this->YResolution;};
00095
00097
00098   vtkSetVector3Macro(Origin,float);
00099   vtkGetVectorMacro(Origin,float,3);
00101
00103
00104   void SetPoint1(float x, float y, float z);
00105   void SetPoint1(float pnt[3]);
00106   vtkGetVectorMacro(Point1,float,3);
00108
00110
00111   void SetPoint2(float x, float y, float z);
00112   void SetPoint2(float pnt[3]);
00113   vtkGetVectorMacro(Point2,float,3);
00115
00117
00120   void SetCenter(float x, float y, float z);
00121   void SetCenter(float center[3]);
00122   vtkGetVectorMacro(Center,float,3);
00124
00126
00129   void SetNormal(float nx, float ny, float nz);
00130   void SetNormal(float n[3]);
00131   vtkGetVectorMacro(Normal,float,3);
00133
00136   void Push(float distance);
00137
00138 protected:
00139   vtkPlaneSource();
00140   ~vtkPlaneSource() {};
00141
00142   void Execute();
00143
00144   int XResolution;
00145   int YResolution;
00146   float Origin[3];
00147   float Point1[3];
00148   float Point2[3];
00149   float Normal[3];
00150   float Center[3];
00151
00152   int UpdatePlane(float v1[3], float v2[3]);
00153 private:
00154   vtkPlaneSource(const vtkPlaneSource&);  // Not implemented.
00155   void operator=(const vtkPlaneSource&);  // Not implemented.
00156 };
00157
00158 #endif
00159
00160
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPLinearExtrusionFilter.h Source File

Parallel/vtkPLinearExtrusionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPLinearExtrusionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkPLinearExtrusionFilter_h
00038 #define __vtkPLinearExtrusionFilter_h
00039
00040 #include "vtkLinearExtrusionFilter.h"
00041
00042 class VTK_PARALLEL_EXPORT vtkPLinearExtrusionFilter : public vtkLinearExtrusionFilter
00043 {
00044 public:
00045   vtkTypeRevisionMacro(vtkPLinearExtrusionFilter,vtkLinearExtrusionFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049   static vtkPLinearExtrusionFilter *New();
00050
00051   // To get piece invariance, this filter has to request an
00052   // extra ghost level.  Since piece invariance is not very
00053   // important for this filter,  it is optional.  Without invariance,
00054   // Internal surfaces will be generated.  These surface
00055   // Are hidden by the normal surface generated by this filter.
00056   // By default, PieceInvariance is off.
00057   vtkSetMacro(PieceInvariant, int);
00058   vtkGetMacro(PieceInvariant, int);
00059   vtkBooleanMacro(PieceInvariant, int);
00060
00061 protected:
00062   vtkPLinearExtrusionFilter();
00063   ~vtkPLinearExtrusionFilter() {};
00064
00065   void Execute();
00066   void ComputeInputUpdateExtents(vtkDataObject *output);
00067
00068   int PieceInvariant;
00069 private:
00070   vtkPLinearExtrusionFilter(const vtkPLinearExtrusionFilter&);  // Not implemented.
00071   void operator=(const vtkPLinearExtrusionFilter&);  // Not implemented.
00072 };
00073
00074 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPLOT3DReader.h Source File

IO/vtkPLOT3DReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPLOT3DReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00096 #ifndef __vtkPLOT3DReader_h
00097 #define __vtkPLOT3DReader_h
00098
00099 #include <stdio.h>
00100 #include "vtkStructuredGridSource.h"
00101 #include "vtkIntArray.h"
00102
00103 class vtkFloatArray;
00104
00105 // file formats
00106 #define VTK_WHOLE_SINGLE_GRID_NO_IBLANKING 0
00107 #define VTK_WHOLE_MULTI_GRID_NO_IBLANKING 2
00108
00109 class VTK_IO_EXPORT vtkPLOT3DReader : public vtkStructuredGridSource
00110 {
00111 public:
00112   static vtkPLOT3DReader *New();
00113   vtkTypeRevisionMacro(vtkPLOT3DReader,vtkStructuredGridSource);
00114   void PrintSelf(ostream& os, vtkIndent indent);
00115
00117
00118   vtkSetClampMacro(FileFormat,int,0,7);
00119   vtkGetMacro(FileFormat,int);
00121
00123
00124   vtkSetStringMacro(XYZFileName);
00125   vtkGetStringMacro(XYZFileName);
00127
00129
00130   vtkSetStringMacro(QFileName);
00131   vtkGetStringMacro(QFileName);
00133
00135
00136   vtkSetStringMacro(FunctionFileName);
00137   vtkGetStringMacro(FunctionFileName);
00139
00141
00142   vtkSetStringMacro(VectorFunctionFileName);
00143   vtkGetStringMacro(VectorFunctionFileName);
00145
00147
00148   vtkSetMacro(GridNumber,int);
00149   vtkGetMacro(GridNumber,int);
00151
00153
00155   vtkSetMacro(ScalarFunctionNumber,int);
00156   vtkGetMacro(ScalarFunctionNumber,int);
00158
00160
00162   vtkSetMacro(VectorFunctionNumber,int);
00163   vtkGetMacro(VectorFunctionNumber,int);
00165
00167
00170   void AddFunction(int functionNumber)
00171     {this->FunctionList->InsertNextValue(functionNumber);}
00172   void RemoveFunction(int);
00173   void RemoveAllFunctions()
00174     {this->FunctionList->Reset();}
00176
00177   // these are read from PLOT3D file
00179   /*! Get the free-stream mach number. */
00180   vtkGetMacro(Fsmach,float);
00182
00184
00185   vtkGetMacro(Alpha,float);
00187
00189
00190   vtkGetMacro(Re,float);
00192
00194
00195   vtkGetMacro(Time,float);
00197
00199
00200   vtkSetMacro(R,float);
00201   vtkGetMacro(R,float);
00203
00205
00206   vtkSetMacro(Gamma,float);
00207   vtkGetMacro(Gamma,float);
00209
00211
00212   vtkSetMacro(Uvinf,float);
00213   vtkGetMacro(Uvinf,float);
00215
00217
00218   vtkSetMacro(Vvinf,float);
00219   vtkGetMacro(Vvinf,float);
00221
00223
00224   vtkSetMacro(Wvinf,float);
00225   vtkGetMacro(Wvinf,float);
00227
00229
00231   vtkGetMacro(NumberOfGrids, int);
00233
00234 protected:
00235   vtkPLOT3DReader();
00236   ~vtkPLOT3DReader();
00237
00238   void ExecuteInformation();
00239   void Execute();
00240   int GetFileType(FILE *fp);
00241
00242   //plot3d FileNames
00243   int FileFormat; //various PLOT3D formats
00244   char *XYZFileName;
00245   char *QFileName;
00246   char *FunctionFileName;
00247   char *VectorFunctionFileName;
00248
00249   //flags describing data to be read
00250   int GridNumber; //for multi-grid files, the one we're interested in
00251   int ScalarFunctionNumber;
00252   int VectorFunctionNumber;
00253   int FunctionFileFunctionNumber;
00254   void MapFunction(int fNumber,vtkPointData *outputPD);
00255
00256   //functions to read that are not scalars or vectors
00257   vtkIntArray *FunctionList;
00258
00259   //temporary variables used during read
00260   float *TempStorage;
00261   int NumberOfPoints;
00262   int NumberOfGrids;
00263
00264   //supplied in PLOT3D file
00265   float Fsmach;
00266   float Alpha;
00267   float Re;
00268   float Time;
00269
00270   //parameters used in computing derived functions
00271   float R;
00272   float Gamma;
00273   float Uvinf;
00274   float Vvinf;
00275   float Wvinf;
00276
00277   //methods to read data
00278   int ReadBinaryGrid(FILE *fp,vtkStructuredGrid *output);
00279   int ReadBinaryGridDimensions(FILE *fp, vtkStructuredGrid *output);
00280   int ReadBinarySolution(FILE *fp, vtkStructuredGrid *output);
00281   int ReadBinaryFunctionFile(FILE *fp, vtkStructuredGrid *output);
00282   int ReadBinaryVectorFunctionFile(FILE *fp, vtkStructuredGrid *output);
00283
00284   vtkPoints *Grid;
00285   vtkFloatArray *Density;
00286   vtkFloatArray *Energy;
00287   vtkFloatArray *Momentum;
00288
00289   // derived functions from data in PLOT3D files
00290   void ComputeDensity(vtkPointData *outputPD);
00291   void ComputePressure(vtkPointData *outputPD);
00292   void ComputeTemperature(vtkPointData *outputPD);
00293   void ComputeEnthalpy(vtkPointData *outputPD);
00294   void ComputeInternalEnergy(vtkPointData *outputPD);
00295   void ComputeKineticEnergy(vtkPointData *outputPD);
00296   void ComputeVelocityMagnitude(vtkPointData *outputPD);
00297   void ComputeStagnationEnergy(vtkPointData *outputPD);
00298   void ComputeEntropy(vtkPointData *outputPD);
00299   void ComputeSwirl(vtkPointData *outputPD);
00300
00301   void ComputeVelocity(vtkPointData *outputPD);
00302   void ComputeVorticity(vtkPointData *outputPD);
00303   void ComputeMomentum(vtkPointData *outputPD);
00304   void ComputePressureGradient(vtkPointData *outputPD);
00305
00306 private:
00307   vtkPLOT3DReader(const vtkPLOT3DReader&);  // Not implemented.
00308   void operator=(const vtkPLOT3DReader&);  // Not implemented.
00309 };
00310
00311 #endif
00312
00313
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPLY.h Source File

IO/vtkPLY.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPLY.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 /*
00017
00018 The interface routines for reading and writing PLY polygon files.
00019
00020 Greg Turk, February 1994
00021
00022 ---------------------------------------------------------------
00023
00024 A PLY file contains a single polygonal _object_.
00025
00026 An object is composed of lists of _elements_.  Typical elements are
00027 vertices, faces, edges and materials.
00028
00029 Each type of element for a given object has one or more _properties_
00030 associated with the element type.  For instance, a vertex element may
00031 have as properties the floating-point values x,y,z and the three unsigned
00032 chars representing red, green and blue.
00033
00034 ---------------------------------------------------------------
00035
00036 Copyright (c) 1994 The Board of Trustees of The Leland Stanford
00037 Junior University.  All rights reserved.
00038
00039 Permission to use, copy, modify and distribute this software and its
00040 documentation for any purpose is hereby granted without fee, provided
00041 that the above copyright notice and this permission notice appear in
00042 all copies of this software and that you do not sell the software.
00043
00044 THE SOFTWARE IS PROVIDED "AS IS" AND WITHOUT WARRANTY OF ANY KIND,
00045 EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY
00046 WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
00047
00048 */
00049
00074 #ifndef __vtkPLY_h
00075 #define __vtkPLY_h
00076
00077 #include <stdio.h>
00078 #include <stddef.h>
00079 #include "vtkObject.h"
00080
00081 #define PLY_ASCII      1        /* ascii PLY file */
00082 #define PLY_BINARY_BE  2        /* binary PLY file, big endian */
00083 #define PLY_BINARY_LE  3        /* binary PLY file, little endian */
00084
00085 #define PLY_OKAY    0           /* ply routine worked okay */
00086 #define PLY_ERROR  -1           /* error in ply routine */
00087
00088 /* scalar data types supported by PLY format */
00089
00090 #define PLY_START_TYPE 0
00091 #define PLY_CHAR       1
00092 #define PLY_SHORT      2
00093 #define PLY_INT        3
00094 #define PLY_UCHAR      4
00095 #define PLY_USHORT     5
00096 #define PLY_UINT       6
00097 #define PLY_FLOAT      7
00098 #define PLY_DOUBLE     8
00099 #define PLY_END_TYPE   9
00100
00101 #define  PLY_SCALAR  0
00102 #define  PLY_LIST    1
00103
00104 typedef struct PlyProperty {    /* description of a property */
00105
00106   const char *name;                           /* property name */
00107   int external_type;                    /* file's data type */
00108   int internal_type;                    /* program's data type */
00109   int offset;                           /* offset bytes of prop in a struct */
00110
00111   int is_list;                          /* 1 = list, 0 = scalar */
00112   int count_external;                   /* file's count type */
00113   int count_internal;                   /* program's count type */
00114   int count_offset;                     /* offset byte for list count */
00115
00116 } PlyProperty;
00117
00118 typedef struct PlyElement {     /* description of an element */
00119   char *name;                   /* element name */
00120   int num;                      /* number of elements in this object */
00121   int size;                     /* size of element (bytes) or -1 if variable */
00122   int nprops;                   /* number of properties for this element */
00123   PlyProperty **props;          /* list of properties in the file */
00124   char *store_prop;             /* flags: property wanted by user? */
00125   int other_offset;             /* offset to un-asked-for props, or -1 if none*/
00126   int other_size;               /* size of other_props structure */
00127 } PlyElement;
00128
00129 typedef struct PlyOtherProp {   /* describes other properties in an element */
00130   char *name;                   /* element name */
00131   int size;                     /* size of other_props */
00132   int nprops;                   /* number of properties in other_props */
00133   PlyProperty **props;          /* list of properties in other_props */
00134 } PlyOtherProp;
00135
00136 typedef struct OtherData { /* for storing other_props for an other element */
00137   void *other_props;
00138 } OtherData;
00139
00140 typedef struct OtherElem {     /* data for one "other" element */
00141   char *elem_name;             /* names of other elements */
00142   int elem_count;              /* count of instances of each element */
00143   OtherData **other_data;      /* actual property data for the elements */
00144   PlyOtherProp *other_props;   /* description of the property data */
00145 } OtherElem;
00146
00147 typedef struct PlyOtherElems {  /* "other" elements, not interpreted by user */
00148   int num_elems;                /* number of other elements */
00149   OtherElem *other_list;        /* list of data for other elements */
00150 } PlyOtherElems;
00151
00152 typedef struct PlyFile {        /* description of PLY file */
00153   FILE *fp;                     /* file pointer */
00154   int file_type;                /* ascii or binary */
00155   float version;                /* version number of file */
00156   int nelems;                   /* number of elements of object */
00157   PlyElement **elems;           /* list of elements */
00158   int num_comments;             /* number of comments */
00159   char **comments;              /* list of comments */
00160   int num_obj_info;             /* number of items of object information */
00161   char **obj_info;              /* list of object info items */
00162   PlyElement *which_elem;       /* which element we're currently writing */
00163   PlyOtherElems *other_elems;   /* "other" elements from a PLY file */
00164 } PlyFile;
00165
00166 /* memory allocation */
00167 #define myalloc(mem_size) vtkPLY::my_alloc((mem_size), __LINE__, __FILE__)
00168
00169 class VTK_IO_EXPORT vtkPLY
00170 {
00171 public:
00172   //standard PLY library interface
00173   static PlyFile *ply_write(FILE *, int, const char **, int);
00174   static PlyFile *ply_open_for_writing(char *, int, const char **, int, float *);
00175   static void ply_describe_element(PlyFile *, char *, int, int, PlyProperty *);
00176   static void ply_describe_property(PlyFile *, char *, PlyProperty *);
00177   static void ply_element_count(PlyFile *, char *, int);
00178   static void ply_header_complete(PlyFile *);
00179   static void ply_put_element_setup(PlyFile *, char *);
00180   static void ply_put_element(PlyFile *, void *);
00181   static void ply_put_comment(PlyFile *, char *);
00182   static void ply_put_obj_info(PlyFile *, char *);
00183   static PlyFile *ply_read(FILE *, int *, char ***);
00184   static PlyFile *ply_open_for_reading( char *, int *, char ***, int *, float *);
00185   static PlyElement *ply_get_element_description(PlyFile *, char *, int*, int*);
00186   static void ply_get_element_setup( PlyFile *, char *, int, PlyProperty *);
00187   static void ply_get_property(PlyFile *, char *, PlyProperty *);
00188   static PlyOtherProp *ply_get_other_properties(PlyFile *, char *, int);
00189   static void ply_get_element(PlyFile *, void *);
00190   static char **ply_get_comments(PlyFile *, int *);
00191   static char **ply_get_obj_info(PlyFile *, int *);
00192   static void ply_close(PlyFile *);
00193   static void ply_get_info(PlyFile *, float *, int *);
00194   static PlyOtherElems *ply_get_other_element (PlyFile *, char *, int);
00195   static void ply_describe_other_elements ( PlyFile *, PlyOtherElems *);
00196   static void ply_put_other_elements (PlyFile *);
00197   static void ply_free_other_elements (PlyOtherElems *);
00198   static void ply_describe_other_properties(PlyFile *, PlyOtherProp *, int);
00199
00200   // These methods are internal to the PLY library in the normal distribution
00201   // They should be used carefully
00202   static int equal_strings(const char *, const char *);
00203   static PlyElement *find_element(PlyFile *, char *);
00204   static PlyProperty *find_property(PlyElement *, const char *, int *);
00205   static void write_scalar_type (FILE *, int);
00206   static char **get_words(FILE *, int *, char **);
00207   static char **old_get_words(FILE *, int *);
00208   static void write_binary_item(FILE *, int, unsigned int, double, int);
00209   static void write_ascii_item(FILE *, int, unsigned int, double, int);
00210   static double old_write_ascii_item(FILE *, char *, int);
00211   static void add_element(PlyFile *, char **, int);
00212   static void add_property(PlyFile *, char **, int);
00213   static void add_comment(PlyFile *, char *);
00214   static void add_obj_info(PlyFile *, char *);
00215   static void copy_property(PlyProperty *, PlyProperty *);
00216   static void store_item(char *, int, int, unsigned int, double);
00217   static void get_stored_item( void *, int, int *, unsigned int *, double *);
00218   static double get_item_value(char *, int);
00219   static void get_ascii_item(char *, int, int *, unsigned int *, double *);
00220   static void get_binary_item(FILE *, int, int *, unsigned int *, double *);
00221   static void ascii_get_element(PlyFile *, char *);
00222   static void binary_get_element(PlyFile *, char *);
00223   static char *my_alloc(int, int, char *);
00224   static int get_prop_type(char *);
00225
00226 };
00227
00228 #endif
00229
00230
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPLYReader.h Source File

IO/vtkPLYReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPLYReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkPLYReader_h
00047 #define __vtkPLYReader_h
00048
00049 #include "vtkPolyDataSource.h"
00050
00051 class VTK_IO_EXPORT vtkPLYReader : public vtkPolyDataSource
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkPLYReader,vtkPolyDataSource);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058   static vtkPLYReader *New();
00059
00061
00062   vtkSetStringMacro(FileName);
00063   vtkGetStringMacro(FileName);
00065
00066 protected:
00067   vtkPLYReader();
00068   ~vtkPLYReader();
00069
00070   char *FileName;
00071
00072   void Execute();
00073 private:
00074   vtkPLYReader(const vtkPLYReader&);  // Not implemented.
00075   void operator=(const vtkPLYReader&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPLYWriter.h Source File

IO/vtkPLYWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPLYWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkPLYWriter_h
00045 #define __vtkPLYWriter_h
00046
00047 #include "vtkPolyDataWriter.h"
00048 #include "vtkPolyData.h"
00049 #include "vtkScalarsToColors.h"
00050
00051 #define VTK_LITTLE_ENDIAN 0
00052 #define VTK_BIG_ENDIAN    1
00053
00054 #define VTK_COLOR_MODE_DEFAULT 0
00055 #define VTK_COLOR_MODE_UNIFORM_CELL_COLOR 1
00056 #define VTK_COLOR_MODE_UNIFORM_POINT_COLOR 2
00057 #define VTK_COLOR_MODE_UNIFORM_COLOR 3
00058 #define VTK_COLOR_MODE_OFF 4
00059
00060
00061 class VTK_IO_EXPORT vtkPLYWriter : public vtkPolyDataWriter
00062 {
00063 public:
00064   static vtkPLYWriter *New();
00065   vtkTypeRevisionMacro(vtkPLYWriter,vtkPolyDataWriter);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069
00071   vtkSetClampMacro(DataByteOrder,int,VTK_LITTLE_ENDIAN,VTK_BIG_ENDIAN);
00072   vtkGetMacro(DataByteOrder,int);
00073   void SetDataByteOrderToBigEndian()
00074     {this->SetDataByteOrder(VTK_BIG_ENDIAN);}
00075   void SetDataByteOrderToLittleEndian()
00076     {this->SetDataByteOrder(VTK_LITTLE_ENDIAN);}
00078
00080
00093   vtkSetMacro(ColorMode,int);
00094   vtkGetMacro(ColorMode,int);
00095   void SetColorModeToDefault()
00096     {this->SetColorMode(VTK_COLOR_MODE_DEFAULT);}
00097   void SetColorModeToUniformCellColor()
00098     {this->SetColorMode(VTK_COLOR_MODE_UNIFORM_CELL_COLOR);}
00099   void SetColorModeToUniformPointColor()
00100     {this->SetColorMode(VTK_COLOR_MODE_UNIFORM_POINT_COLOR);}
00101   void SetColorModeToUniformColor() //both cells and points are colored
00102     {this->SetColorMode(VTK_COLOR_MODE_UNIFORM_COLOR);}
00103   void SetColorModeToOff() //No color information is written
00104     {this->SetColorMode(VTK_COLOR_MODE_OFF);}
00106
00108
00109   vtkSetStringMacro(ArrayName);
00110   vtkGetStringMacro(ArrayName);
00112
00114
00115   vtkSetClampMacro(Component,int,0,VTK_LARGE_INTEGER);
00116   vtkGetMacro(Component,int);
00118
00120
00122   vtkSetObjectMacro(LookupTable,vtkScalarsToColors);
00123   vtkGetObjectMacro(LookupTable,vtkScalarsToColors);
00125
00127
00131   vtkSetVector3Macro(Color,unsigned char);
00132   vtkGetVector3Macro(Color,unsigned char);
00134
00135 protected:
00136   vtkPLYWriter();
00137   ~vtkPLYWriter();
00138
00139   void WriteData();
00140   unsigned char *GetColors(vtkIdType num, vtkDataSetAttributes *dsa);
00141
00142   int DataByteOrder;
00143   char *ArrayName;
00144   int Component;
00145   int ColorMode;
00146   vtkScalarsToColors *LookupTable;
00147   unsigned char Color[3];
00148
00149 private:
00150   vtkPLYWriter(const vtkPLYWriter&);  // Not implemented.
00151   void operator=(const vtkPLYWriter&);  // Not implemented.
00152 };
00153
00154 #endif
00155
Generated on Mon Mar 25 01:07:52 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPNGReader.h Source File

IO/vtkPNGReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPNGReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkPNGReader_h
00040 #define __vtkPNGReader_h
00041
00042 #include <stdio.h>
00043 #include "vtkImageReader2.h"
00044
00045 class VTK_IO_EXPORT vtkPNGReader : public vtkImageReader2
00046 {
00047 public:
00048   static vtkPNGReader *New();
00049   vtkTypeRevisionMacro(vtkPNGReader,vtkImageReader2);
00050
00051 protected:
00052   vtkPNGReader() {};
00053   ~vtkPNGReader() {};
00054   virtual vtkImageReader2* MakeObject() { return vtkPNGReader::New(); }
00055
00057   virtual int CanReadFile(const char* fname);
00058  // Description:
00059   // Get the file extensions for this format.
00060   // Returns a string with a space separated list of extensions in
00061   // the format .extension
00062   virtual const char* GetFileExensions()
00063     {
00064       return ".png";
00065     }
00067
00069
00071   virtual const char* GetDescriptiveName()
00072     {
00073       return "PNG";
00074     }
00076
00077   virtual void ExecuteInformation();
00078   virtual void ExecuteData(vtkDataObject *out);
00079 private:
00080   vtkPNGReader(const vtkPNGReader&);  // Not implemented.
00081   void operator=(const vtkPNGReader&);  // Not implemented.
00082 };
00083 #endif
00084
00085
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPNGWriter.h Source File

IO/vtkPNGWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPNGWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkPNGWriter_h
00042 #define __vtkPNGWriter_h
00043
00044 #include "vtkImageWriter.h"
00045
00046 class VTK_IO_EXPORT vtkPNGWriter : public vtkImageWriter
00047 {
00048 public:
00049   static vtkPNGWriter *New();
00050   vtkTypeRevisionMacro(vtkPNGWriter,vtkImageWriter);
00051
00053   virtual void Write();
00054
00055 protected:
00056   vtkPNGWriter();
00057   ~vtkPNGWriter() {};
00058
00059   void WriteSlice(vtkImageData *data);
00060
00061 private:
00062   vtkPNGWriter(const vtkPNGWriter&);  // Not implemented.
00063   void operator=(const vtkPNGWriter&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPNMReader.h Source File

IO/vtkPNMReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPNMReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkPNMReader_h
00050 #define __vtkPNMReader_h
00051
00052 #include <stdio.h>
00053 #include "vtkImageReader.h"
00054
00055 class VTK_IO_EXPORT vtkPNMReader : public vtkImageReader
00056 {
00057 public:
00058   static vtkPNMReader *New();
00059   vtkTypeRevisionMacro(vtkPNMReader,vtkImageReader);
00061   virtual vtkImageReader2* MakeObject() { return vtkPNMReader::New(); }
00062   int CanReadFile(const char* fname);
00063   // Description:
00064   // .pnm .pgm .ppm
00065   virtual const char* GetFileExensions()
00066     {
00067       return ".pnm .pgm .ppm";
00068     }
00070
00072
00073   virtual const char* GetDescriptiveName()
00074     {
00075       return "PNM";
00076     }
00078
00079 protected:
00080   vtkPNMReader() {};
00081   ~vtkPNMReader() {};
00082   void ExecuteInformation();
00083 private:
00084   vtkPNMReader(const vtkPNMReader&);  // Not implemented.
00085   void operator=(const vtkPNMReader&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPNMWriter.h Source File

IO/vtkPNMWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPNMWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkPNMWriter_h
00036 #define __vtkPNMWriter_h
00037
00038 #include "vtkImageWriter.h"
00039
00040 class VTK_IO_EXPORT vtkPNMWriter : public vtkImageWriter
00041 {
00042 public:
00043   static vtkPNMWriter *New();
00044   vtkTypeRevisionMacro(vtkPNMWriter,vtkImageWriter);
00045
00046 protected:
00047   vtkPNMWriter() {};
00048   ~vtkPNMWriter() {};
00049
00050   virtual void WriteFile(ofstream *file, vtkImageData *data, int extent[6]);
00051   virtual void WriteFileHeader(ofstream *, vtkImageData *);
00052 private:
00053   vtkPNMWriter(const vtkPNMWriter&);  // Not implemented.
00054   void operator=(const vtkPNMWriter&);  // Not implemented.
00055 };
00056
00057 #endif
00058
00059
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPointData.h Source File

Common/vtkPointData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPointData_h
00039 #define __vtkPointData_h
00040
00041 #include "vtkDataSetAttributes.h"
00042
00043 class VTK_COMMON_EXPORT vtkPointData : public vtkDataSetAttributes
00044 {
00045 public:
00046   static vtkPointData *New();
00047
00048   vtkTypeRevisionMacro(vtkPointData,vtkDataSetAttributes);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050   void NullPoint(vtkIdType ptId);
00051
00052 protected:
00053   vtkPointData() {};
00054   ~vtkPointData() {};
00055
00056 private:
00057   vtkPointData(const vtkPointData&);  // Not implemented.
00058   void operator=(const vtkPointData&);  // Not implemented.
00059 };
00060
00061 #endif
00062
00063
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPointDataToCellData.h Source File

Graphics/vtkPointDataToCellData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointDataToCellData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkPointDataToCellData_h
00053 #define __vtkPointDataToCellData_h
00054
00055 #include "vtkDataSetToDataSetFilter.h"
00056
00057 class VTK_GRAPHICS_EXPORT vtkPointDataToCellData : public vtkDataSetToDataSetFilter
00058 {
00059 public:
00060   static vtkPointDataToCellData *New();
00061   vtkTypeRevisionMacro(vtkPointDataToCellData,vtkDataSetToDataSetFilter);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065
00068   vtkSetMacro(PassPointData,int);
00069   vtkGetMacro(PassPointData,int);
00070   vtkBooleanMacro(PassPointData,int);
00072
00073 protected:
00074   vtkPointDataToCellData();
00075   ~vtkPointDataToCellData() {};
00076
00077   void Execute();
00078
00079   int PassPointData;
00080 private:
00081   vtkPointDataToCellData(const vtkPointDataToCellData&);  // Not implemented.
00082   void operator=(const vtkPointDataToCellData&);  // Not implemented.
00083 };
00084
00085 #endif
00086
00087
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkPointLoad.h Source File

Imaging/vtkPointLoad.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointLoad.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkPointLoad_h
00045 #define __vtkPointLoad_h
00046
00047 #include "vtkStructuredPointsSource.h"
00048
00049 class VTK_IMAGING_EXPORT vtkPointLoad :  public vtkStructuredPointsSource
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkPointLoad,vtkStructuredPointsSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   static vtkPointLoad *New();
00058
00060
00061   vtkSetMacro(LoadValue,float);
00062   vtkGetMacro(LoadValue,float);
00064
00067   void SetSampleDimensions(int i, int j, int k);
00068
00070
00072   void SetSampleDimensions(int dim[3]);
00073   vtkGetVectorMacro(SampleDimensions,int,3);
00075
00077
00079   vtkSetVector6Macro(ModelBounds,float);
00080   vtkGetVectorMacro(ModelBounds,float,6);
00082
00084
00085   vtkSetMacro(PoissonsRatio,float);
00086   vtkGetMacro(PoissonsRatio,float);
00088
00090
00091   vtkSetMacro(ComputeEffectiveStress,int);
00092   vtkGetMacro(ComputeEffectiveStress,int);
00093   vtkBooleanMacro(ComputeEffectiveStress,int);
00095
00096 protected:
00097   vtkPointLoad();
00098   ~vtkPointLoad() {};
00099
00100   void Execute();
00101
00102   float LoadValue;
00103   float PoissonsRatio;
00104   int SampleDimensions[3];
00105   float ModelBounds[6];
00106   int ComputeEffectiveStress;
00107
00108 private:
00109   vtkPointLoad(const vtkPointLoad&);  // Not implemented.
00110   void operator=(const vtkPointLoad&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPointLocator2D.h Source File

Common/vtkPointLocator2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointLocator2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkPointLocator2D_h
00054 #define __vtkPointLocator2D_h
00055
00056 #include "vtkLocator.h"
00057 #include "vtkPoints.h"
00058 #include "vtkIdList.h"
00059
00060 class vtkNeighborPoints2D;
00061
00062 class VTK_COMMON_EXPORT vtkPointLocator2D : public vtkLocator
00063 {
00064 public:
00067   static vtkPointLocator2D *New();
00068
00069   vtkTypeRevisionMacro(vtkPointLocator2D,vtkLocator);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00074   vtkSetVector2Macro(Divisions,int);
00075   vtkGetVectorMacro(Divisions,int,2);
00077
00079
00080   vtkSetClampMacro(NumberOfPointsPerBucket,int,1,VTK_LARGE_INTEGER);
00081   vtkGetMacro(NumberOfPointsPerBucket,int);
00083
00085   virtual int FindClosestPoint(float x[2]);
00086
00090   virtual int IsInsertedPoint(float x[2]);
00091
00093
00097   virtual void FindClosestNPoints(int N, float x[2], vtkIdList *result);
00098   virtual void FindClosestNPoints(int N, float x, float y,
00099                                   vtkIdList *result);
00101
00103
00106   virtual void FindDistributedPoints(int N, float x[2],
00107                                      vtkIdList *result, int M);
00108   virtual void FindDistributedPoints(int N, float x, float y,
00109                                      vtkIdList *result, int M);
00111
00113
00115   virtual void FindPointsWithinRadius(float R, float x[2], vtkIdList *result);
00116   virtual void FindPointsWithinRadius(float R, float x, float y,
00117                                       vtkIdList *result);
00118   // Description:
00119   // See vtkLocator interface documentation.
00120   void Initialize();
00121   void FreeSearchStructure();
00122   void BuildLocator();
00123   void GenerateRepresentation(int level, vtkPolyData *pd);
00125
00127
00128   vtkSetObjectMacro(Points,vtkPoints);
00129   vtkGetObjectMacro(Points,vtkPoints);
00131
00132 protected:
00133   vtkPointLocator2D();
00134   ~vtkPointLocator2D();
00135
00136   // place points in appropriate buckets
00137   void GetBucketNeighbors(int ijk[2], int ndivs[2], int level);
00138   void GetOverlappingBuckets(float x[2], int ijk[2], float dist, int level);
00139   void GenerateFace(int face, int i, int j, int k,
00140                     vtkPoints *pts, vtkCellArray *polys);
00141
00142   vtkPoints *Points; // Used for merging points
00143   int Divisions[2]; // Number of sub-divisions in x-y-z directions
00144   int NumberOfPointsPerBucket; //Used with previous boolean to control subdivide
00145   float Bounds[4]; // bounds of points
00146   vtkIdList **HashTable; // lists of point ids in buckets
00147   int NumberOfBuckets; // total size of hash table
00148   float H[2]; // width of each bucket in x-y-z directions
00149   vtkNeighborPoints2D *Buckets;
00150   float InsertionTol2;
00151 private:
00152   vtkPointLocator2D(const vtkPointLocator2D&);  // Not implemented.
00153   void operator=(const vtkPointLocator2D&);  // Not implemented.
00154 };
00155
00156 #endif
00157
00158
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPointLocator.h Source File

Common/vtkPointLocator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointLocator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkPointLocator_h
00057 #define __vtkPointLocator_h
00058
00059 #include "vtkLocator.h"
00060 #include "vtkPoints.h"
00061
00062 class vtkIdList;
00063 class vtkNeighborPoints;
00064
00065 class VTK_COMMON_EXPORT vtkPointLocator : public vtkLocator
00066 {
00067 public:
00070   static vtkPointLocator *New();
00071
00072   vtkTypeRevisionMacro(vtkPointLocator,vtkLocator);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00076
00077   vtkSetVector3Macro(Divisions,int);
00078   vtkGetVectorMacro(Divisions,int,3);
00080
00082
00083   vtkSetClampMacro(NumberOfPointsPerBucket,int,1,VTK_LARGE_INTEGER);
00084   vtkGetMacro(NumberOfPointsPerBucket,int);
00086
00088
00092   virtual vtkIdType FindClosestPoint(const float x[3]);
00093   vtkIdType FindClosestPoint(float x, float y, float z);
00095
00097
00101   vtkIdType FindClosestPointWithinRadius(float radius, const float x[3],
00102                                          float& dist2);
00103   vtkIdType FindClosestPointWithinRadius(float radius, const float x[3],
00104                                          float inputDataLength, float& dist2);
00106
00111   virtual int InitPointInsertion(vtkPoints *newPts, const float bounds[6]);
00112
00114
00118   virtual int InitPointInsertion(vtkPoints *newPts, const float bounds[6],
00119                                  vtkIdType estSize);
00121
00129   virtual void InsertPoint(vtkIdType ptId, const float x[3]);
00130
00138   virtual vtkIdType InsertNextPoint(const float x[3]);
00139
00141
00144   vtkIdType IsInsertedPoint(float x, float  y, float z)
00145     {
00146     float xyz[3];
00147     xyz[0] = x; xyz[1] = y; xyz[2] = z;
00148     return this->IsInsertedPoint (xyz);
00149     };
00150   virtual vtkIdType IsInsertedPoint(const float x[3]);
00152
00160   virtual int InsertUniquePoint(const float x[3], vtkIdType &ptId);
00161
00167   virtual vtkIdType FindClosestInsertedPoint(const float x[3]);
00168
00170
00176   virtual void FindClosestNPoints(int N, const float x[3], vtkIdList *result);
00177   virtual void FindClosestNPoints(int N, float x, float y, float z,
00178                                   vtkIdList *result);
00180
00182
00187   virtual void FindDistributedPoints(int N, const float x[3],
00188                                      vtkIdList *result, int M);
00189   virtual void FindDistributedPoints(int N, float x, float y,
00190                                      float z, vtkIdList *result, int M);
00192
00194
00198   virtual void FindPointsWithinRadius(float R, const float x[3],
00199                                       vtkIdList *result);
00200   virtual void FindPointsWithinRadius(float R, float x, float y, float z,
00201                                       vtkIdList *result);
00203
00208   virtual vtkIdList *GetPointsInBucket(const float x[3], int ijk[3]);
00209
00211
00213   void Initialize();
00214   void FreeSearchStructure();
00215   void BuildLocator();
00216   void GenerateRepresentation(int level, vtkPolyData *pd);
00218
00219 protected:
00220   vtkPointLocator();
00221   ~vtkPointLocator();
00222
00223   // place points in appropriate buckets
00224   void GetBucketNeighbors(vtkNeighborPoints* buckets,
00225                           const int ijk[3], const int ndivs[3], int level);
00226   void GetOverlappingBuckets(vtkNeighborPoints* buckets,
00227                              const float x[3], const int ijk[3], float dist,
00228                              int level);
00229   void GetOverlappingBuckets(vtkNeighborPoints* buckets,
00230                              const float x[3], float dist,
00231                              int prevMinLevel[3],
00232                              int prevMaxLevel[3]);
00233   void GenerateFace(int face, int i, int j, int k,
00234                     vtkPoints *pts, vtkCellArray *polys);
00235   float Distance2ToBucket(const float x[3], const int nei[3]);
00236   float Distance2ToBounds(const float x[3], const float bounds[6]);
00237
00238   vtkPoints *Points; // Used for merging points
00239   int Divisions[3]; // Number of sub-divisions in x-y-z directions
00240   int NumberOfPointsPerBucket; //Used with previous boolean to control subdivide
00241   float Bounds[6]; // bounds of points
00242   vtkIdList **HashTable; // lists of point ids in buckets
00243   vtkIdType NumberOfBuckets; // total size of hash table
00244   float H[3]; // width of each bucket in x-y-z directions
00245
00246   float InsertionTol2;
00247   vtkIdType InsertionPointId;
00248
00249   float InsertionLevel;
00250 private:
00251   vtkPointLocator(const vtkPointLocator&);  // Not implemented.
00252   void operator=(const vtkPointLocator&);  // Not implemented.
00253 };
00254
00255 #endif
00256
00257
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkPointPicker.h Source File

Rendering/vtkPointPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkPointPicker_h
00043 #define __vtkPointPicker_h
00044
00045 #include "vtkPicker.h"
00046
00047 class VTK_RENDERING_EXPORT vtkPointPicker : public vtkPicker
00048 {
00049 public:
00050   static vtkPointPicker *New();
00051   vtkTypeRevisionMacro(vtkPointPicker,vtkPicker);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkGetMacro(PointId, vtkIdType);
00058
00059 protected:
00060   vtkPointPicker();
00061   ~vtkPointPicker() {};
00062
00063   vtkIdType PointId; //picked point
00064
00065   float IntersectWithLine(float p1[3], float p2[3], float tol,
00066                           vtkAssemblyPath *path, vtkProp3D *p,
00067                           vtkAbstractMapper3D *m);
00068   void Initialize();
00069
00070 private:
00071   vtkPointPicker(const vtkPointPicker&);  // Not implemented.
00072   void operator=(const vtkPointPicker&);  // Not implemented.
00073 };
00074
00075 #endif
00076
00077
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPoints.h Source File

Common/vtkPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkPoints_h
00041 #define __vtkPoints_h
00042
00043 #include "vtkObject.h"
00044 #include "vtkDataArray.h"
00045
00046 class vtkIdList;
00047 class vtkPoints;
00048
00049 class VTK_COMMON_EXPORT vtkPoints : public vtkObject
00050 {
00051 public:
00052 //BTX
00053   static vtkPoints *New(int dataType);
00054 //ETX
00055   static vtkPoints *New();
00056
00057   vtkTypeRevisionMacro(vtkPoints,vtkObject);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061   virtual int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00062
00064   virtual void Initialize();
00065
00067   vtkPoints *MakeObject();
00068
00070
00076   virtual void SetData(vtkDataArray *);
00077   vtkDataArray *GetData() {return this->Data;};
00079
00082   virtual int GetDataType();
00083
00085
00086   virtual void SetDataType(int dataType);
00087   void SetDataTypeToBit() {this->SetDataType(VTK_BIT);};
00088   void SetDataTypeToChar() {this->SetDataType(VTK_CHAR);};
00089   void SetDataTypeToUnsignedChar() {this->SetDataType(VTK_UNSIGNED_CHAR);};
00090   void SetDataTypeToShort() {this->SetDataType(VTK_SHORT);};
00091   void SetDataTypeToUnsignedShort() {this->SetDataType(VTK_UNSIGNED_SHORT);};
00092   void SetDataTypeToInt() {this->SetDataType(VTK_INT);};
00093   void SetDataTypeToUnsignedInt() {this->SetDataType(VTK_UNSIGNED_INT);};
00094   void SetDataTypeToLong() {this->SetDataType(VTK_LONG);};
00095   void SetDataTypeToUnsignedLong() {this->SetDataType(VTK_UNSIGNED_LONG);};
00096   void SetDataTypeToFloat() {this->SetDataType(VTK_FLOAT);};
00097   void SetDataTypeToDouble() {this->SetDataType(VTK_DOUBLE);};
00099
00102   void *GetVoidPointer(const int id) {return this->Data->GetVoidPointer(id);};
00103
00105   virtual void Squeeze() {this->Data->Squeeze();};
00106
00108   virtual void Reset() {this->Data->Reset();};
00109
00111
00114   virtual void DeepCopy(vtkPoints *ad);
00115   virtual void ShallowCopy(vtkPoints *ad);
00117
00124   unsigned long GetActualMemorySize();
00125
00127   vtkIdType GetNumberOfPoints() { return this->Data->GetNumberOfTuples();};
00128
00130   float *GetPoint(vtkIdType id) { return this->Data->GetTuple(id);};
00131
00133
00134   void GetPoint(vtkIdType id, float x[3]) { this->Data->GetTuple(id,x);};
00135   void GetPoint(vtkIdType id, double x[3]) { this->Data->GetTuple(id,x);};
00137
00139
00142   void SetPoint(vtkIdType id, const float x[3]) { this->Data->SetTuple(id,x);};
00143   void SetPoint(vtkIdType id, const double x[3]) { this->Data->SetTuple(id,x);};
00144   void SetPoint(vtkIdType id, double x, double y, double z);
00146
00148
00150   void InsertPoint(vtkIdType id, const float x[3])
00151     { this->Data->InsertTuple(id,x);};
00152   void InsertPoint(vtkIdType id, const double x[3])
00153     {this->Data->InsertTuple(id,x);};
00154   void InsertPoint(vtkIdType id, double x, double y, double z);
00156
00158
00159   vtkIdType InsertNextPoint(const float x[3]) {
00160     return this->Data->InsertNextTuple(x);};
00161   vtkIdType InsertNextPoint(const double x[3]) {
00162     return this->Data->InsertNextTuple(x);};
00163   vtkIdType InsertNextPoint(double x, double y, double z);
00165
00169   void SetNumberOfPoints(vtkIdType number);
00170
00172   void GetPoints(vtkIdList *ptId, vtkPoints *fp);
00173
00175   virtual void ComputeBounds();
00176
00178   float *GetBounds();
00179
00181   void GetBounds(float bounds[6]);
00182
00183 protected:
00184   vtkPoints(int dataType=VTK_FLOAT);
00185   ~vtkPoints();
00186
00187   float Bounds[6];
00188   vtkTimeStamp ComputeTime; // Time at which bounds computed
00189   vtkDataArray *Data;  // Array which represents data
00190
00191 private:
00192   vtkPoints(const vtkPoints&);  // Not implemented.
00193   void operator=(const vtkPoints&);  // Not implemented.
00194 };
00195
00196 inline void vtkPoints::SetNumberOfPoints(vtkIdType number)
00197 {
00198   this->Data->SetNumberOfComponents(3);
00199   this->Data->SetNumberOfTuples(number);
00200 }
00201
00202 inline void vtkPoints::SetPoint(vtkIdType id, double x, double y, double z)
00203 {
00204   double p[3];
00205   p[0] = x;
00206   p[1] = y;
00207   p[2] = z;
00208   this->Data->SetTuple(id,p);
00209 }
00210
00211 inline void vtkPoints::InsertPoint(vtkIdType id, double x, double y, double z)
00212 {
00213   double p[3];
00214
00215   p[0] = x;
00216   p[1] = y;
00217   p[2] = z;
00218   this->Data->InsertTuple(id,p);
00219 }
00220
00221 inline vtkIdType vtkPoints::InsertNextPoint(double x, double y, double z)
00222 {
00223   double p[3];
00224
00225   p[0] = x;
00226   p[1] = y;
00227   p[2] = z;
00228   return this->Data->InsertNextTuple(p);
00229 }
00230
00231
00232 // These include files are placed here so that if Points.h is included
00233 // all other classes necessary for compilation are also included.
00234 #include "vtkIdList.h"
00235
00236 #endif
00237
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPointSet.h Source File

Common/vtkPointSet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointSet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkPointSet_h
00042 #define __vtkPointSet_h
00043
00044 #include "vtkDataSet.h"
00045 #include "vtkPointLocator.h"
00046
00047 class VTK_COMMON_EXPORT vtkPointSet : public vtkDataSet
00048 {
00049 public:
00050   vtkTypeRevisionMacro(vtkPointSet,vtkDataSet);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054   void Initialize();
00055
00057   void CopyStructure(vtkDataSet *pd);
00058
00060
00061   vtkIdType GetNumberOfPoints();
00062   float *GetPoint(vtkIdType ptId) {return this->Points->GetPoint(ptId);};
00063   void GetPoint(vtkIdType ptId, float x[3]) {this->Points->GetPoint(ptId,x);};
00064   vtkIdType FindPoint(float x[3]);
00065   vtkIdType FindPoint(float x, float y, float z) { return this->vtkDataSet::FindPoint(x, y, z);};
00066   vtkIdType FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2,
00067                int& subId, float pcoords[3], float *weights);
00068   vtkIdType FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell,
00069                vtkIdType cellId, float tol2, int& subId,
00070                float pcoords[3], float *weights);
00072
00074   unsigned long GetMTime();
00075
00077   void ComputeBounds();
00078
00080   void Squeeze();
00081
00083
00084   vtkSetObjectMacro(Points,vtkPoints);
00085   vtkGetObjectMacro(Points,vtkPoints);
00087
00089   void UnRegister(vtkObject *o);
00090
00094   virtual int GetNetReferenceCount();
00095
00101   unsigned long GetActualMemorySize();
00102
00104
00105   void ShallowCopy(vtkDataObject *src);
00106   void DeepCopy(vtkDataObject *src);
00108
00109 protected:
00110   vtkPointSet();
00111   ~vtkPointSet();
00112
00113   vtkPoints *Points;
00114   vtkPointLocator *Locator;
00115
00116 private:
00117   vtkPointSet(const vtkPointSet&);  // Not implemented.
00118   void operator=(const vtkPointSet&);  // Not implemented.
00119 };
00120
00121 inline vtkIdType vtkPointSet::GetNumberOfPoints()
00122 {
00123   if (this->Points)
00124     {
00125     return this->Points->GetNumberOfPoints();
00126     }
00127   else
00128     {
00129     return 0;
00130     }
00131 }
00132
00133
00134 #endif
00135
00136
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPointSetSource.h Source File

Filtering/vtkPointSetSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointSetSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkPointDataSource_h
00032 #define __vtkPointDataSource_h
00033
00034 #include "vtkSource.h"
00035 #include "vtkPointSet.h"
00036
00037 class VTK_FILTERING_EXPORT vtkPointSetSource : public vtkSource
00038 {
00039 public:
00040   static vtkPointSetSource *New();
00041   vtkTypeRevisionMacro(vtkPointSetSource,vtkSource);
00042
00044
00045   vtkPointSet *GetOutput();
00046   vtkPointSet *GetOutput(int idx)
00047     {return (vtkPointSet *) this->vtkSource::GetOutput(idx); };
00048   void SetOutput(vtkPointSet *output);
00050
00051 protected:
00052   vtkPointSetSource();
00053   ~vtkPointSetSource() {};
00054
00055 private:
00056   vtkPointSetSource(const vtkPointSetSource&);  // Not implemented.
00057   void operator=(const vtkPointSetSource&);  // Not implemented.
00058 };
00059
00060 #endif
00061
00062
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPointSetToPointSetFilter.h Source File

Filtering/vtkPointSetToPointSetFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointSetToPointSetFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkPointSetToPointSetFilter_h
00052 #define __vtkPointSetToPointSetFilter_h
00053
00054 #include "vtkPointSetSource.h"
00055
00056 class vtkPolyData;
00057 class vtkStructuredGrid;
00058 class vtkUnstructuredGrid;
00059
00060 class VTK_FILTERING_EXPORT vtkPointSetToPointSetFilter : public vtkPointSetSource
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkPointSetToPointSetFilter,vtkPointSetSource);
00064
00066   void SetInput(vtkPointSet *input);
00067
00069   vtkPointSet *GetInput();
00070
00072
00074   vtkPointSet *GetOutput();
00075   vtkPointSet *GetOutput(int idx)
00076     {return (vtkPointSet *) this->vtkPointSetSource::GetOutput(idx); };
00078
00080   vtkPolyData *GetPolyDataOutput();
00081
00083   vtkStructuredGrid *GetStructuredGridOutput();
00084
00086   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00087
00089   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00090
00091 protected:
00092   vtkPointSetToPointSetFilter();
00093   ~vtkPointSetToPointSetFilter();
00094
00095 private:
00096   vtkPointSetToPointSetFilter(const vtkPointSetToPointSetFilter&);  // Not implemented.
00097   void operator=(const vtkPointSetToPointSetFilter&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPointSource.h Source File

Graphics/vtkPointSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPointSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkPointSource_h
00043 #define __vtkPointSource_h
00044
00045 #include "vtkPolyDataSource.h"
00046
00047 #define VTK_POINT_UNIFORM   1
00048 #define VTK_POINT_SHELL     0
00049
00050 class VTK_GRAPHICS_EXPORT vtkPointSource : public vtkPolyDataSource
00051 {
00052 public:
00053   static vtkPointSource *New();
00054   vtkTypeRevisionMacro(vtkPointSource,vtkPolyDataSource);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkSetClampMacro(NumberOfPoints,vtkIdType,1,VTK_LARGE_ID);
00060   vtkGetMacro(NumberOfPoints,vtkIdType);
00062
00064
00065   vtkSetVector3Macro(Center,float);
00066   vtkGetVectorMacro(Center,float,3);
00068
00070
00073   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00074   vtkGetMacro(Radius,float);
00076
00078
00080   vtkSetMacro(Distribution,int);
00081   void SetDistributionToUniform() {
00082     this->SetDistribution(VTK_POINT_UNIFORM);};
00083   void SetDistributionToShell() {
00084     this->SetDistribution(VTK_POINT_SHELL);};
00085   vtkGetMacro(Distribution,int);
00087
00088 protected:
00089   vtkPointSource(vtkIdType numPts=10);
00090   ~vtkPointSource() {};
00091
00092   void Execute();
00093   void ExecuteInformation();
00094
00095   vtkIdType NumberOfPoints;
00096   float Center[3];
00097   float Radius;
00098   int Distribution;
00099 private:
00100   vtkPointSource(const vtkPointSource&);  // Not implemented.
00101   void operator=(const vtkPointSource&);  // Not implemented.
00102 };
00103
00104 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPolyData.h Source File

Common/vtkPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkPolyData_h
00057 #define __vtkPolyData_h
00058
00059 #include "vtkPointSet.h"
00060 #include "vtkPoints.h"
00061 #include "vtkCellArray.h"
00062 #include "vtkCellTypes.h"
00063 #include "vtkCellLinks.h"
00064
00065 class vtkVertex;
00066 class vtkPolyVertex;
00067 class vtkLine;
00068 class vtkPolyLine;
00069 class vtkTriangle;
00070 class vtkQuad;
00071 class vtkPolygon;
00072 class vtkTriangleStrip;
00073 class vtkEmptyCell;
00074
00075
00076
00077 class VTK_COMMON_EXPORT vtkPolyData : public vtkPointSet
00078 {
00079 public:
00080   static vtkPolyData *New();
00081
00082   vtkTypeRevisionMacro(vtkPolyData,vtkPointSet);
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084
00086   vtkDataObject *MakeObject() {return vtkPolyData::New();};
00087
00089   int GetDataObjectType() {return VTK_POLY_DATA;}
00090
00093   void CopyStructure(vtkDataSet *ds);
00094
00096
00097   vtkIdType GetNumberOfCells();
00098   vtkCell *GetCell(vtkIdType cellId);
00099   void GetCell(vtkIdType cellId, vtkGenericCell *cell);
00100   int GetCellType(vtkIdType cellId);
00101   void GetCellBounds(vtkIdType cellId, float bounds[6]);
00102   void GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds,
00103                         vtkIdList *cellIds);
00105
00107
00111   void CopyCells(vtkPolyData *pd, vtkIdList *idList,
00112                  vtkPointLocator *locator = NULL);
00114
00116   void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds);
00117
00120   void GetPointCells(vtkIdType ptId, vtkIdList *cellIds);
00121
00123   void ComputeBounds();
00124
00129   void Squeeze();
00130
00132   int GetMaxCellSize();
00133
00135   void SetVerts (vtkCellArray* v);
00136
00139   vtkCellArray *GetVerts();
00140
00142   void SetLines (vtkCellArray* l);
00143
00146   vtkCellArray *GetLines();
00147
00149   void SetPolys (vtkCellArray* p);
00150
00153   vtkCellArray *GetPolys();
00154
00156   void SetStrips (vtkCellArray* s);
00157
00161   vtkCellArray *GetStrips();
00162
00164
00165   vtkIdType GetNumberOfVerts();
00166   vtkIdType GetNumberOfLines();
00167   vtkIdType GetNumberOfPolys();
00168   vtkIdType GetNumberOfStrips();
00170
00175   void Allocate(vtkIdType numCells=1000, int extSize=1000);
00176
00178
00187   void Allocate(vtkPolyData *inPolyData, vtkIdType numCells=1000,
00188                 int extSize=1000);
00190
00197   int InsertNextCell(int type, int npts, vtkIdType *pts);
00198
00205   int InsertNextCell(int type, vtkIdList *pts);
00206
00209   void Reset();
00210
00212   void BuildCells();
00213
00216   void BuildLinks();
00217
00221   void DeleteCells();
00222
00224   void DeleteLinks();
00225
00227
00228   void GetPointCells(vtkIdType ptId, unsigned short& ncells,
00229                      vtkIdType* &cells);
00231
00233
00236   void GetCellEdgeNeighbors(vtkIdType cellId, vtkIdType p1, vtkIdType p2,
00237                             vtkIdList *cellIds);
00239
00242   void GetCellPoints(vtkIdType cellId, vtkIdType& npts, vtkIdType* &pts);
00243
00246   int IsTriangle(int v1, int v2, int v3);
00247
00250   int IsEdge(int v1, int v2);
00251
00254   int IsPointUsedByCell(vtkIdType ptId, vtkIdType cellId);
00255
00261   void ReplaceCell(vtkIdType cellId, int npts, vtkIdType *pts);
00262
00264
00265   void ReplaceCellPoint(vtkIdType cellId, vtkIdType oldPtId,
00266                         vtkIdType newPtId);
00268
00270   void ReverseCell(vtkIdType cellId);
00271
00273
00274   void DeletePoint(vtkIdType ptId);
00275   void DeleteCell(vtkIdType cellId);
00277
00282   int InsertNextLinkedPoint(float x[3], int numLinks);
00283
00287   int InsertNextLinkedCell(int type, int npts, vtkIdType *pts);
00288
00295   void ReplaceLinkedCell(vtkIdType cellId, int npts, vtkIdType *pts);
00296
00302   void RemoveCellReference(vtkIdType cellId);
00303
00309   void AddCellReference(vtkIdType cellId);
00310
00316   void RemoveReferenceToCell(vtkIdType ptId, vtkIdType cellId);
00317
00322   void AddReferenceToCell(vtkIdType ptId, vtkIdType cellId);
00323
00326   void ResizeCellList(vtkIdType ptId, int size);
00327
00329   virtual void Initialize();
00330
00332
00335   void SetUpdateExtent(int piece, int numPieces, int ghostLevel);
00336   void SetUpdateExtent(int piece, int numPieces)
00337     {this->SetUpdateExtent(piece, numPieces, 0);}
00338   void GetUpdateExtent(int &piece, int &numPieces, int &ghostLevel);
00340
00342
00343   vtkGetVector6Macro( UpdateExtent, int );
00345
00347
00351   void SetUpdateExtent( int x1, int x2, int y1, int y2, int z1, int z2 )
00352     { this->vtkPointSet::SetUpdateExtent( x1, x2, y1, y2, z1, z2 ); };
00353   void SetUpdateExtent( int ext[6] )
00354     { this->vtkPointSet::SetUpdateExtent( ext ); };
00356
00358
00360   vtkGetMacro( Piece, int );
00361   vtkGetMacro( NumberOfPieces, int );
00363
00365
00366   vtkGetMacro( GhostLevel, int );
00368
00374   unsigned long GetActualMemorySize();
00375
00377
00378   void ShallowCopy(vtkDataObject *src);
00379   void DeepCopy(vtkDataObject *src);
00381
00384   void RemoveGhostCells(int level);
00385
00386 protected:
00387   vtkPolyData();
00388   ~vtkPolyData();
00389
00390   // constant cell objects returned by GetCell called.
00391   vtkVertex *Vertex;
00392   vtkPolyVertex *PolyVertex;
00393   vtkLine *Line;
00394   vtkPolyLine *PolyLine;
00395   vtkTriangle *Triangle;
00396   vtkQuad *Quad;
00397   vtkPolygon *Polygon;
00398   vtkTriangleStrip *TriangleStrip;
00399   vtkEmptyCell *EmptyCell;
00400
00401   // points inherited
00402   // point data (i.e., scalars, vectors, normals, tcoords) inherited
00403   vtkCellArray *Verts;
00404   vtkCellArray *Lines;
00405   vtkCellArray *Polys;
00406   vtkCellArray *Strips;
00407
00408   // dummy static member below used as a trick to simplify traversal
00409   static vtkCellArray *Dummy;
00410
00411   // supporting structures for more complex topological operations
00412   // built only when necessary
00413   vtkCellTypes *Cells;
00414   vtkCellLinks *Links;
00415
00416   // This method is called during an update.
00417   // If the CropFilter is set, the user reqquested a piece which the
00418   // source cannot generate, then it will break up the
00419   // data set in order to satisfy the request.
00420   virtual void Crop();
00421
00422
00423 private:
00424   // Hide these from the user and the compiler.
00425
00427
00428   void GetCellNeighbors(vtkIdType cellId, vtkIdList& ptIds, vtkIdList& cellIds)
00429     {this->GetCellNeighbors(cellId, &ptIds, &cellIds);}
00431
00432 private:
00433   vtkPolyData(const vtkPolyData&);  // Not implemented.
00434   void operator=(const vtkPolyData&);  // Not implemented.
00435 };
00436
00437 inline void vtkPolyData::GetPointCells(vtkIdType ptId, unsigned short& ncells,
00438                                        vtkIdType* &cells)
00439 {
00440   ncells = this->Links->GetNcells(ptId);
00441   cells = this->Links->GetCells(ptId);
00442 }
00443
00444 inline int vtkPolyData::IsTriangle(int v1, int v2, int v3)
00445 {
00446   unsigned short int n1;
00447   int i, j, tVerts[3];
00448   vtkIdType *cells, *tVerts2, n2;
00449
00450   tVerts[0] = v1;
00451   tVerts[1] = v2;
00452   tVerts[2] = v3;
00453
00454   for (i=0; i<3; i++)
00455     {
00456     this->GetPointCells(tVerts[i], n1, cells);
00457     for (j=0; j<n1; j++)
00458       {
00459       this->GetCellPoints(cells[j], n2, tVerts2);
00460       if ( (tVerts[0] == tVerts2[0] || tVerts[0] == tVerts2[1] ||
00461             tVerts[0] == tVerts2[2]) &&
00462            (tVerts[1] == tVerts2[0] || tVerts[1] == tVerts2[1] ||
00463             tVerts[1] == tVerts2[2]) &&
00464            (tVerts[2] == tVerts2[0] || tVerts[2] == tVerts2[1] ||
00465             tVerts[2] == tVerts2[2]) )
00466         {
00467         return 1;
00468         }
00469       }
00470     }
00471   return 0;
00472 }
00473
00474 inline int vtkPolyData::IsPointUsedByCell(vtkIdType ptId, vtkIdType cellId)
00475 {
00476   vtkIdType *pts, npts;
00477
00478   this->GetCellPoints(cellId, npts, pts);
00479   for (vtkIdType i=0; i < npts; i++)
00480     {
00481     if ( pts[i] == ptId )
00482       {
00483       return 1;
00484       }
00485     }
00486
00487   return 0;
00488 }
00489
00490 inline int vtkPolyData::IsEdge(int p1, int p2)
00491 {
00492   unsigned short int ncells;
00493   int i;
00494   vtkIdType *cells;
00495
00496   this->GetPointCells(p1,ncells,cells);
00497   for (i=0; i < ncells; i++)
00498     {
00499     if ( this->IsPointUsedByCell(p2,cells[i]) )
00500       {
00501       return 1;
00502       }
00503     }
00504
00505   return 0;
00506 }
00507
00508 inline void vtkPolyData::DeletePoint(vtkIdType ptId)
00509 {
00510   this->Links->DeletePoint(ptId);
00511 }
00512
00513 inline void vtkPolyData::DeleteCell(vtkIdType cellId)
00514 {
00515   this->Cells->DeleteCell(cellId);
00516 }
00517
00518 inline void vtkPolyData::RemoveCellReference(vtkIdType cellId)
00519 {
00520   vtkIdType *pts, npts;
00521
00522   this->GetCellPoints(cellId, npts, pts);
00523   for (vtkIdType i=0; i<npts; i++)
00524     {
00525     this->Links->RemoveCellReference(cellId, pts[i]);
00526     }
00527 }
00528
00529 inline void vtkPolyData::AddCellReference(vtkIdType cellId)
00530 {
00531   vtkIdType *pts, npts;
00532
00533   this->GetCellPoints(cellId, npts, pts);
00534   for (vtkIdType i=0; i<npts; i++)
00535     {
00536     this->Links->AddCellReference(cellId, pts[i]);
00537     }
00538 }
00539
00540 inline void vtkPolyData::ResizeCellList(vtkIdType ptId, int size)
00541 {
00542   this->Links->ResizeCellList(ptId,size);
00543 }
00544
00545 inline void vtkPolyData::ReplaceCellPoint(vtkIdType cellId, vtkIdType oldPtId,
00546                                           vtkIdType newPtId)
00547 {
00548   int i;
00549   vtkIdType *verts, nverts;
00550
00551   this->GetCellPoints(cellId,nverts,verts);
00552   for ( i=0; i < nverts; i++ )
00553     {
00554     if ( verts[i] == oldPtId )
00555       {
00556       verts[i] = newPtId; // this is very nasty! direct write!
00557       return;
00558       }
00559     }
00560 }
00561
00562 #endif
00563
00564
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPolyDataCollection.h Source File

Filtering/vtkPolyDataCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPolyDataCollection_h
00039 #define __vtkPolyDataCollection_h
00040
00041 #include "vtkCollection.h"
00042 #include "vtkPolyData.h"
00043
00044 class VTK_FILTERING_EXPORT vtkPolyDataCollection : public vtkCollection
00045 {
00046 public:
00047   static vtkPolyDataCollection *New();
00048   vtkTypeRevisionMacro(vtkPolyDataCollection,vtkCollection);
00049
00051
00052   void AddItem(vtkPolyData *pd) {
00053     this->vtkCollection::AddItem((vtkObject *)pd);};
00055
00057
00058   vtkPolyData *GetNextItem() {
00059     return static_cast<vtkPolyData *>(this->GetNextItemAsObject());};
00061 protected:
00062   vtkPolyDataCollection() {};
00063   ~vtkPolyDataCollection() {};
00064
00065 private:
00066   // hide the standard AddItem from the user and the compiler.
00067   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00068
00069 private:
00070   vtkPolyDataCollection(const vtkPolyDataCollection&);  // Not implemented.
00071   void operator=(const vtkPolyDataCollection&);  // Not implemented.
00072 };
00073
00074
00075 #endif
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPolyDataConnectivityFilter.h Source File

Graphics/vtkPolyDataConnectivityFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataConnectivityFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkPolyDataConnectivityFilter_h
00059 #define __vtkPolyDataConnectivityFilter_h
00060
00061 #include "vtkPolyDataToPolyDataFilter.h"
00062
00063 #define VTK_EXTRACT_POINT_SEEDED_REGIONS 1
00064 #define VTK_EXTRACT_CELL_SEEDED_REGIONS 2
00065 #define VTK_EXTRACT_SPECIFIED_REGIONS 3
00066 #define VTK_EXTRACT_LARGEST_REGION 4
00067 #define VTK_EXTRACT_ALL_REGIONS 5
00068 #define VTK_EXTRACT_CLOSEST_POINT_REGION 6
00069
00070 class vtkDataArray;
00071
00072 class VTK_GRAPHICS_EXPORT vtkPolyDataConnectivityFilter : public vtkPolyDataToPolyDataFilter
00073 {
00074 public:
00075   vtkTypeRevisionMacro(vtkPolyDataConnectivityFilter,vtkPolyDataToPolyDataFilter);
00076   void PrintSelf(ostream& os, vtkIndent indent);
00077
00079   static vtkPolyDataConnectivityFilter *New();
00080
00082
00085   vtkSetMacro(ScalarConnectivity,int);
00086   vtkGetMacro(ScalarConnectivity,int);
00087   vtkBooleanMacro(ScalarConnectivity,int);
00089
00091
00093   vtkSetVectorMacro(ScalarRange,float,2);
00094   vtkGetVectorMacro(ScalarRange,float,2);
00096
00098
00099   vtkSetClampMacro(ExtractionMode,int,
00100                    VTK_EXTRACT_POINT_SEEDED_REGIONS,
00101                    VTK_EXTRACT_CLOSEST_POINT_REGION);
00102   vtkGetMacro(ExtractionMode,int);
00103   void SetExtractionModeToPointSeededRegions()
00104     {this->SetExtractionMode(VTK_EXTRACT_POINT_SEEDED_REGIONS);};
00105   void SetExtractionModeToCellSeededRegions()
00106     {this->SetExtractionMode(VTK_EXTRACT_CELL_SEEDED_REGIONS);};
00107   void SetExtractionModeToLargestRegion()
00108     {this->SetExtractionMode(VTK_EXTRACT_LARGEST_REGION);};
00109   void SetExtractionModeToSpecifiedRegions()
00110     {this->SetExtractionMode(VTK_EXTRACT_SPECIFIED_REGIONS);};
00111   void SetExtractionModeToClosestPointRegion()
00112     {this->SetExtractionMode(VTK_EXTRACT_CLOSEST_POINT_REGION);};
00113   void SetExtractionModeToAllRegions()
00114     {this->SetExtractionMode(VTK_EXTRACT_ALL_REGIONS);};
00115   const char *GetExtractionModeAsString();
00117
00119   void InitializeSeedList();
00120
00122   void AddSeed(int id);
00123
00125   void DeleteSeed(int id);
00126
00128   void InitializeSpecifiedRegionList();
00129
00131   void AddSpecifiedRegion(int id);
00132
00134   void DeleteSpecifiedRegion(int id);
00135
00137
00139   vtkSetVector3Macro(ClosestPoint,float);
00140   vtkGetVectorMacro(ClosestPoint,float,3);
00142
00144   int GetNumberOfExtractedRegions();
00145
00147
00148   vtkSetMacro(ColorRegions,int);
00149   vtkGetMacro(ColorRegions,int);
00150   vtkBooleanMacro(ColorRegions,int);
00152
00153 protected:
00154   vtkPolyDataConnectivityFilter();
00155   ~vtkPolyDataConnectivityFilter();
00156
00157   // Usual data generation method
00158   void Execute();
00159
00160   int ColorRegions; //boolean turns on/off scalar gen for separate regions
00161   int ExtractionMode; //how to extract regions
00162   vtkIdList *Seeds; //id's of points or cells used to seed regions
00163   vtkIdList *SpecifiedRegionIds; //regions specified for extraction
00164   vtkIdTypeArray *RegionSizes; //size (in cells) of each region extracted
00165
00166   float ClosestPoint[3];
00167
00168   int ScalarConnectivity;
00169   float ScalarRange[2];
00170
00171   void TraverseAndMark();
00172
00173 private:
00174   // used to support algorithm execution
00175   vtkDataArray *CellScalars;
00176   vtkIdList *NeighborCellPointIds;
00177   int *Visited;
00178   vtkIdType *PointMap;
00179   vtkDataArray *NewScalars;
00180   int RegionNumber;
00181   vtkIdType PointNumber;
00182   vtkIdType NumCellsInRegion;
00183   vtkDataArray *InScalars;
00184   vtkPolyData *Mesh;
00185   vtkIdList *Wave;
00186   vtkIdList *Wave2;
00187   vtkIdList *PointIds;
00188   vtkIdList *CellIds;
00189 private:
00190   vtkPolyDataConnectivityFilter(const vtkPolyDataConnectivityFilter&);  // Not implemented.
00191   void operator=(const vtkPolyDataConnectivityFilter&);  // Not implemented.
00192 };
00193
00195 inline const char *vtkPolyDataConnectivityFilter::GetExtractionModeAsString(void)
00196 {
00197   if ( this->ExtractionMode == VTK_EXTRACT_POINT_SEEDED_REGIONS )
00198     {
00199     return "ExtractPointSeededRegions";
00200     }
00201   else if ( this->ExtractionMode == VTK_EXTRACT_CELL_SEEDED_REGIONS )
00202     {
00203     return "ExtractCellSeededRegions";
00204     }
00205   else if ( this->ExtractionMode == VTK_EXTRACT_SPECIFIED_REGIONS )
00206     {
00207     return "ExtractSpecifiedRegions";
00208     }
00209   else if ( this->ExtractionMode == VTK_EXTRACT_ALL_REGIONS )
00210     {
00211     return "ExtractAllRegions";
00212     }
00213   else if ( this->ExtractionMode == VTK_EXTRACT_CLOSEST_POINT_REGION )
00214     {
00215     return "ExtractClosestPointRegion";
00216     }
00217   else
00218     {
00219     return "ExtractLargestRegion";
00220     }
00221 }
00222
00223
00224 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkPolyDataMapper2D.h Source File

Rendering/vtkPolyDataMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkPolyDataMapper2D_h
00051 #define __vtkPolyDataMapper2D_h
00052
00053
00054 #include "vtkMapper2D.h"
00055 #include "vtkWindow.h"
00056 #include "vtkViewport.h"
00057 #include "vtkActor2D.h"
00058 #include "vtkProperty2D.h"
00059 #include "vtkScalarsToColors.h"
00060 #include "vtkPolyData.h"
00061
00062 class VTK_RENDERING_EXPORT vtkPolyDataMapper2D : public vtkMapper2D
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkPolyDataMapper2D,vtkMapper2D);
00066   static vtkPolyDataMapper2D *New();
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00070
00071   vtkSetObjectMacro(Input, vtkPolyData);
00072   vtkGetObjectMacro(Input, vtkPolyData);
00074
00076
00077   void SetLookupTable(vtkScalarsToColors *lut);
00078   vtkScalarsToColors *GetLookupTable();
00080
00083   virtual void CreateDefaultLookupTable();
00084
00086
00088   vtkSetMacro(ScalarVisibility,int);
00089   vtkGetMacro(ScalarVisibility,int);
00090   vtkBooleanMacro(ScalarVisibility,int);
00092
00094
00101   vtkSetMacro(ColorMode,int);
00102   vtkGetMacro(ColorMode,int);
00103   void SetColorModeToDefault()
00104     {this->SetColorMode(VTK_COLOR_MODE_DEFAULT);};
00105   void SetColorModeToMapScalars()
00106     {this->SetColorMode(VTK_COLOR_MODE_MAP_SCALARS);};
00108
00110   const char *GetColorModeAsString();
00111
00113
00119   vtkSetMacro(UseLookupTableScalarRange,int);
00120   vtkGetMacro(UseLookupTableScalarRange,int);
00121   vtkBooleanMacro(UseLookupTableScalarRange,int);
00123
00125
00128   vtkSetVector2Macro(ScalarRange,float);
00129   vtkGetVectorMacro(ScalarRange,float,2);
00131
00133
00143   vtkSetMacro(ScalarMode,int);
00144   vtkGetMacro(ScalarMode,int);
00145   void SetScalarModeToDefault() {
00146     this->SetScalarMode(VTK_SCALAR_MODE_DEFAULT);};
00147   void SetScalarModeToUsePointData() {
00148     this->SetScalarMode(VTK_SCALAR_MODE_USE_POINT_DATA);};
00149   void SetScalarModeToUseCellData() {
00150     this->SetScalarMode(VTK_SCALAR_MODE_USE_CELL_DATA);};
00151   void SetScalarModeToUsePointFieldData() {
00152     this->SetScalarMode(VTK_SCALAR_MODE_USE_POINT_FIELD_DATA);};
00153   void SetScalarModeToUseCellFieldData() {
00154     this->SetScalarMode(VTK_SCALAR_MODE_USE_CELL_FIELD_DATA);};
00156
00158
00159   void ColorByArrayComponent(int arrayNum, int component);
00160   void ColorByArrayComponent(char* arrayName, int component);
00162
00164
00165   char* GetArrayName() { return this->ArrayName; }
00166   int GetArrayId() { return this->ArrayId; }
00167   int GetArrayAccessMode() { return this->ArrayAccessMode; }
00168   int GetArrayComponent() { return this->ArrayComponent; }
00170
00173   virtual unsigned long GetMTime();
00174
00176
00180   vtkSetObjectMacro(TransformCoordinate, vtkCoordinate);
00181   vtkGetObjectMacro(TransformCoordinate, vtkCoordinate);
00183
00189   vtkUnsignedCharArray *MapScalars(float alpha);
00190
00192   void ShallowCopy(vtkAbstractMapper *m);
00193
00194 protected:
00195   vtkPolyDataMapper2D();
00196   ~vtkPolyDataMapper2D();
00197
00198   vtkPolyData* Input;
00199
00200   vtkUnsignedCharArray *Colors;
00201
00202   vtkScalarsToColors *LookupTable;
00203   int ScalarVisibility;
00204   vtkTimeStamp BuildTime;
00205   float ScalarRange[2];
00206   int UseLookupTableScalarRange;
00207   int ColorMode;
00208   int ScalarMode;
00209
00210   vtkCoordinate *TransformCoordinate;
00211
00212   // for coloring by a component of a field data array
00213   int ArrayId;
00214   char ArrayName[256];
00215   int ArrayComponent;
00216   int ArrayAccessMode;
00217 private:
00218   vtkPolyDataMapper2D(const vtkPolyDataMapper2D&);  // Not implemented.
00219   void operator=(const vtkPolyDataMapper2D&);  // Not implemented.
00220 };
00221
00222
00223 #endif
00224
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkPolyDataMapper.h Source File

Rendering/vtkPolyDataMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkPolyDataMapper_h
00049 #define __vtkPolyDataMapper_h
00050
00051 #include "vtkMapper.h"
00052 #include "vtkPolyData.h"
00053 #include "vtkRenderer.h"
00054
00055 class VTK_RENDERING_EXPORT vtkPolyDataMapper : public vtkMapper
00056 {
00057 public:
00058   static vtkPolyDataMapper *New();
00059   vtkTypeRevisionMacro(vtkPolyDataMapper,vtkMapper);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063   virtual void RenderPiece(vtkRenderer *ren, vtkActor *act) = 0;
00064
00066   virtual void Render(vtkRenderer *ren, vtkActor *act);
00067
00069
00070   void SetInput(vtkPolyData *in);
00071   vtkPolyData *GetInput();
00073
00075   void Update();
00076
00078
00079   vtkSetMacro(Piece, int);
00080   vtkGetMacro(Piece, int);
00081   vtkSetMacro(NumberOfPieces, int);
00082   vtkGetMacro(NumberOfPieces, int);
00083   vtkSetMacro(NumberOfSubPieces, int);
00084   vtkGetMacro(NumberOfSubPieces, int);
00086
00088
00089   vtkSetMacro(GhostLevel, int);
00090   vtkGetMacro(GhostLevel, int);
00092
00094
00096   virtual float *GetBounds();
00097   virtual void GetBounds(float bounds[6])
00098     {this->vtkMapper::GetBounds(bounds);};
00100
00102   void ShallowCopy(vtkAbstractMapper *m);
00103
00104 protected:
00105   vtkPolyDataMapper();
00106   ~vtkPolyDataMapper() {};
00107
00108   int Piece;
00109   int NumberOfPieces;
00110   int NumberOfSubPieces;
00111   int GhostLevel;
00112 private:
00113   vtkPolyDataMapper(const vtkPolyDataMapper&);  // Not implemented.
00114   void operator=(const vtkPolyDataMapper&);  // Not implemented.
00115 };
00116
00117 #endif
Generated on Mon Mar 25 01:07:58 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPolyDataNormals.h Source File

Graphics/vtkPolyDataNormals.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataNormals.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkPolyDataNormals_h
00057 #define __vtkPolyDataNormals_h
00058
00059 #include "vtkPolyDataToPolyDataFilter.h"
00060 class vtkFloatArray;
00061
00062 class VTK_GRAPHICS_EXPORT vtkPolyDataNormals : public vtkPolyDataToPolyDataFilter
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkPolyDataNormals,vtkPolyDataToPolyDataFilter);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00071   static vtkPolyDataNormals *New();
00072
00074
00077   vtkSetClampMacro(FeatureAngle,float,0.0,180.0);
00078   vtkGetMacro(FeatureAngle,float);
00080
00082
00083   vtkSetMacro(Splitting,int);
00084   vtkGetMacro(Splitting,int);
00085   vtkBooleanMacro(Splitting,int);
00087
00089
00090   vtkSetMacro(Consistency,int);
00091   vtkGetMacro(Consistency,int);
00092   vtkBooleanMacro(Consistency,int);
00094
00096
00097   vtkSetMacro(ComputePointNormals,int);
00098   vtkGetMacro(ComputePointNormals,int);
00099   vtkBooleanMacro(ComputePointNormals,int);
00101
00103
00104   vtkSetMacro(ComputeCellNormals,int);
00105   vtkGetMacro(ComputeCellNormals,int);
00106   vtkBooleanMacro(ComputeCellNormals,int);
00108
00110
00114   vtkSetMacro(FlipNormals,int);
00115   vtkGetMacro(FlipNormals,int);
00116   vtkBooleanMacro(FlipNormals,int);
00118
00120
00123   vtkSetMacro(NonManifoldTraversal,int);
00124   vtkGetMacro(NonManifoldTraversal,int);
00125   vtkBooleanMacro(NonManifoldTraversal,int);
00127
00128 #ifndef VTK_REMOVE_LEGACY_CODE
00129
00130
00133   void SetMaxRecursionDepth(int)
00134     {VTK_LEGACY_METHOD(SetMaxRecursionDepth,"4.0");}
00135   int GetMaxRecursionDepth()
00136     {VTK_LEGACY_METHOD(GetMaxRecursionDepth,"4.0"); return 0;}
00138 #endif
00139
00140 protected:
00141   vtkPolyDataNormals();
00142   ~vtkPolyDataNormals() {};
00143
00144   // Usual data generation method
00145   void Execute();
00146
00147   float FeatureAngle;
00148   int Splitting;
00149   int Consistency;
00150   int FlipNormals;
00151   int NonManifoldTraversal;
00152   int ComputePointNormals;
00153   int ComputeCellNormals;
00154   int NumFlips;
00155
00156 private:
00157   vtkIdList *Wave;
00158   vtkIdList *Wave2;
00159   vtkIdList *CellIds;
00160   vtkIdList *Map;
00161   vtkPolyData *OldMesh;
00162   vtkPolyData *NewMesh;
00163   int *Visited;
00164   vtkFloatArray *PolyNormals;
00165   float CosAngle;
00166
00167   // Uses the list of cell ids (this->Wave) to propagate a wave of
00168   // checked and properly ordered polygons.
00169   void TraverseAndOrder(void);
00170
00171   // Check the point id give to see whether it lies on a feature
00172   // edge. If so, split the point (i.e., duplicate it) to topologically
00173   // separate the mesh.
00174   void MarkAndSplit(vtkIdType ptId);
00175
00176 private:
00177   vtkPolyDataNormals(const vtkPolyDataNormals&);  // Not implemented.
00178   void operator=(const vtkPolyDataNormals&);  // Not implemented.
00179 };
00180
00181 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPolyDataReader.h Source File

IO/vtkPolyDataReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkPolyDataReader_h
00049 #define __vtkPolyDataReader_h
00050
00051 #include "vtkDataReader.h"
00052 #include "vtkPolyData.h"
00053
00054 class VTK_IO_EXPORT vtkPolyDataReader : public vtkDataReader
00055 {
00056 public:
00057   static vtkPolyDataReader *New();
00058   vtkTypeRevisionMacro(vtkPolyDataReader,vtkDataReader);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   vtkPolyData *GetOutput();
00064   vtkPolyData *GetOutput(int idx)
00065     {return (vtkPolyData *) this->vtkSource::GetOutput(idx); };
00066   void SetOutput(vtkPolyData *output);
00068
00069 protected:
00070   vtkPolyDataReader();
00071   ~vtkPolyDataReader();
00072
00073   void Execute();
00074
00075   // Update extent of PolyData is specified in pieces.
00076   // Since all DataObjects should be able to set UpdateExent as pieces,
00077   // just copy output->UpdateExtent  all Inputs.
00078   void ComputeInputUpdateExtents(vtkDataObject *output);
00079
00080   // Used by streaming: The extent of the output being processed
00081   // by the execute method. Set in the ComputeInputUpdateExtents method.
00082   int ExecutePiece;
00083   int ExecuteNumberOfPieces;
00084   int ExecuteGhostLevel;
00085 private:
00086   vtkPolyDataReader(const vtkPolyDataReader&);  // Not implemented.
00087   void operator=(const vtkPolyDataReader&);  // Not implemented.
00088 };
00089
00090 #endif
00091
00092
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPolyDataSource.h Source File

Filtering/vtkPolyDataSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPolyDataSource_h
00039 #define __vtkPolyDataSource_h
00040
00041 #include "vtkSource.h"
00042 #include "vtkPolyData.h"
00043
00044 class VTK_FILTERING_EXPORT vtkPolyDataSource : public vtkSource
00045 {
00046 public:
00047   static vtkPolyDataSource *New();
00048   vtkTypeRevisionMacro(vtkPolyDataSource,vtkSource);
00049
00051
00052   vtkPolyData *GetOutput();
00053   vtkPolyData *GetOutput(int idx)
00054     {return (vtkPolyData *) this->vtkSource::GetOutput(idx); };
00055   void SetOutput(vtkPolyData *output);
00057
00058 protected:
00059   vtkPolyDataSource();
00060   ~vtkPolyDataSource() {};
00061
00062   // Update extent of PolyData is specified in pieces.
00063   // Since all DataObjects should be able to set UpdateExent as pieces,
00064   // just copy output->UpdateExtent  all Inputs.
00065   void ComputeInputUpdateExtents(vtkDataObject *output);
00066
00067   // Used by streaming: The extent of the output being processed
00068   // by the execute method. Set in the ComputeInputUpdateExtents method.
00069   int ExecutePiece;
00070   int ExecuteNumberOfPieces;
00071
00072   int ExecuteGhostLevel;
00073 private:
00074   vtkPolyDataSource(const vtkPolyDataSource&);  // Not implemented.
00075   void operator=(const vtkPolyDataSource&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
00081
00082
00083
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkPolyDataStreamer.h Source File

Graphics/vtkPolyDataStreamer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataStreamer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkPolyDataStreamer_h
00048 #define __vtkPolyDataStreamer_h
00049
00050 #include "vtkPolyDataToPolyDataFilter.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkPolyDataStreamer : public vtkPolyDataToPolyDataFilter
00053 {
00054 public:
00055   static vtkPolyDataStreamer *New();
00056
00057   vtkTypeRevisionMacro(vtkPolyDataStreamer,vtkPolyDataToPolyDataFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00062   void SetNumberOfStreamDivisions(int num);
00063   vtkGetMacro(NumberOfStreamDivisions,int);
00065
00067
00069   vtkSetMacro(ColorByPiece, int);
00070   vtkGetMacro(ColorByPiece, int);
00071   vtkBooleanMacro(ColorByPiece, int);
00073
00074
00075 protected:
00076   vtkPolyDataStreamer();
00077   ~vtkPolyDataStreamer();
00078
00079   // Append the pieces.
00080   void Execute();
00081   void ComputeInputUpdateExtents(vtkDataObject *output);
00082
00083   int NumberOfStreamDivisions;
00084   int ColorByPiece;
00085 private:
00086   vtkPolyDataStreamer(const vtkPolyDataStreamer&);  // Not implemented.
00087   void operator=(const vtkPolyDataStreamer&);  // Not implemented.
00088 };
00089
00090 #endif
00091
00092
00093
00094
00095
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkPolyDataToImageStencil.h Source File

Hybrid/vtkPolyDataToImageStencil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataToImageStencil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPolyDataToImageStencil_h
00039 #define __vtkPolyDataToImageStencil_h
00040
00041
00042 #include "vtkImageStencilSource.h"
00043 #include "vtkPolyData.h"
00044 #include "vtkOBBTree.h"
00045
00046 class VTK_HYBRID_EXPORT vtkPolyDataToImageStencil : public vtkImageStencilSource
00047 {
00048 public:
00049   static vtkPolyDataToImageStencil *New();
00050   vtkTypeRevisionMacro(vtkPolyDataToImageStencil, vtkImageStencilSource);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054
00055   void SetInput(vtkPolyData *input);
00056   vtkPolyData *GetInput();
00058
00060
00061   vtkSetMacro(Tolerance, float);
00062   vtkGetMacro(Tolerance, float);
00064
00065 protected:
00066   vtkPolyDataToImageStencil();
00067   ~vtkPolyDataToImageStencil();
00068   void operator=(const vtkPolyDataToImageStencil&);
00069
00070   void ExecuteData(vtkDataObject *out);
00071   void ThreadedExecute(vtkImageStencilData *output,
00072                        int extent[6], int threadId);
00073
00074   float Tolerance;
00075   vtkOBBTree *OBBTree;
00076 private:
00077   vtkPolyDataToImageStencil(const vtkPolyDataToImageStencil&)  // Not implemented.
00078     {};  // Not implemented.
00079 };
00080
00081 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkPolyDataToPolyDataFilter.h Source File

Filtering/vtkPolyDataToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkPolyDataToPolyDataFilter_h
00043 #define __vtkPolyDataToPolyDataFilter_h
00044
00045 #include "vtkPolyDataSource.h"
00046 #include "vtkPolyData.h"
00047
00048 class VTK_FILTERING_EXPORT vtkPolyDataToPolyDataFilter : public vtkPolyDataSource
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkPolyDataToPolyDataFilter,vtkPolyDataSource);
00052
00054
00055   virtual void SetInput(vtkPolyData *input);
00056   vtkPolyData *GetInput();
00058
00059 protected:
00060    vtkPolyDataToPolyDataFilter();
00061   ~vtkPolyDataToPolyDataFilter() {};
00062
00063 private:
00064   vtkPolyDataToPolyDataFilter(const vtkPolyDataToPolyDataFilter&);  // Not implemented.
00065   void operator=(const vtkPolyDataToPolyDataFilter&);  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPolyDataWriter.h Source File

IO/vtkPolyDataWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyDataWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPolyDataWriter_h
00039 #define __vtkPolyDataWriter_h
00040
00041 #include "vtkDataWriter.h"
00042 #include "vtkPolyData.h"
00043
00044 class VTK_IO_EXPORT vtkPolyDataWriter : public vtkDataWriter
00045 {
00046 public:
00047   static vtkPolyDataWriter *New();
00048   vtkTypeRevisionMacro(vtkPolyDataWriter,vtkDataWriter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   void SetInput(vtkPolyData *input);
00054   vtkPolyData *GetInput();
00056
00057 protected:
00058   vtkPolyDataWriter() {};
00059   ~vtkPolyDataWriter() {};
00060
00061   void WriteData();
00062
00063 private:
00064   vtkPolyDataWriter(const vtkPolyDataWriter&);  // Not implemented.
00065   void operator=(const vtkPolyDataWriter&);  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPolygon.h Source File

Common/vtkPolygon.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolygon.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkPolygon_h
00042 #define __vtkPolygon_h
00043
00044 #include "vtkCell.h"
00045 #include "vtkPoints.h"
00046 #include "vtkLine.h"
00047 #include "vtkTriangle.h"
00048 #include "vtkQuad.h"
00049
00050 class VTK_COMMON_EXPORT vtkPolygon : public vtkCell
00051 {
00052 public:
00053   static vtkPolygon *New();
00054   vtkTypeRevisionMacro(vtkPolygon,vtkCell);
00055
00057
00058   vtkCell *MakeObject();
00059   int GetCellType() {return VTK_POLYGON;};
00060   int GetCellDimension() {return 2;};
00061   int GetNumberOfEdges() {return this->GetNumberOfPoints();};
00062   int GetNumberOfFaces() {return 0;};
00063   vtkCell *GetEdge(int edgeId);
00064   vtkCell *GetFace(int) {return 0;};
00065   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00066   void Contour(float value, vtkDataArray *cellScalars,
00067                vtkPointLocator *locator,vtkCellArray *verts,
00068                vtkCellArray *lines, vtkCellArray *polys,
00069                vtkPointData *inPd, vtkPointData *outPd,
00070                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00071   void Clip(float value, vtkDataArray *cellScalars,
00072             vtkPointLocator *locator, vtkCellArray *tris,
00073             vtkPointData *inPd, vtkPointData *outPd,
00074             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00075             int insideOut);
00076   int EvaluatePosition(float x[3], float* closestPoint,
00077                        int& subId, float pcoords[3],
00078                        float& dist2, float *weights);
00079   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00080                         float *weights);
00081   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00082                         float x[3], float pcoords[3], int& subId);
00083   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00084   void Derivatives(int subId, float pcoords[3], float *values,
00085                    int dim, float *derivs);
00087
00089
00090   static void ComputeNormal(vtkPoints *p, int numPts, vtkIdType *pts,
00091                             float n[3]);
00092   static void ComputeNormal(vtkPoints *p, float n[3]);
00094
00098   static void ComputeNormal(int numPts, float *pts, float n[3]);
00099
00101   void ComputeWeights(float x[3], float *weights);
00102
00103
00105
00110   int ParameterizePolygon(float p0[3], float p10[3], float &l10,
00111                           float p20[3], float &l20, float n[3]);
00113
00115
00119   static int PointInPolygon(float x[3], int numPts, float *pts,
00120                             float bounds[6], float n[3]);
00122
00127   int Triangulate(vtkIdList *outTris);
00128
00130
00136   static int IntersectPolygonWithPolygon(int npts, float *pts, float bounds[6],
00137                                          int npts2, float *pts2,
00138                                          float bounds2[3], float tol,
00139                                          float x[3]);
00141
00142 protected:
00143   vtkPolygon();
00144   ~vtkPolygon();
00145
00146   // variables used by instances of this class
00147   float   Tolerance; // Intersection tolerance
00148   int     SuccessfulTriangulation; // Stops recursive tri. if necessary
00149   float   Normal[3]; //polygon normal
00150   vtkIdList *Tris;
00151   vtkTriangle *Triangle;
00152   vtkQuad *Quad;
00153   vtkFloatArray *TriScalars;
00154   vtkLine *Line;
00155
00156   // Helper methods for triangulation------------------------------
00161   int EarCutTriangulation();
00162
00163 private:
00164   vtkPolygon(const vtkPolygon&);  // Not implemented.
00165   void operator=(const vtkPolygon&);  // Not implemented.
00166 };
00167
00168 #endif
00169
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPolyLine.h Source File

Common/vtkPolyLine.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyLine.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkPolyLine_h
00041 #define __vtkPolyLine_h
00042
00043 #include "vtkCell.h"
00044 #include "vtkPoints.h"
00045 #include "vtkCellArray.h"
00046 #include "vtkLine.h"
00047
00048 class VTK_COMMON_EXPORT vtkPolyLine : public vtkCell
00049 {
00050 public:
00051   static vtkPolyLine *New();
00052   vtkTypeRevisionMacro(vtkPolyLine,vtkCell);
00053
00059   int GenerateSlidingNormals(vtkPoints *, vtkCellArray *, vtkDataArray *);
00060
00062
00063   vtkCell *MakeObject();
00064   int GetCellType() {return VTK_POLY_LINE;};
00065   int GetCellDimension() {return 1;};
00066   int GetNumberOfEdges() {return 0;};
00067   int GetNumberOfFaces() {return 0;};
00068   vtkCell *GetEdge(int vtkNotUsed(edgeId)) {return 0;};
00069   vtkCell *GetFace(int vtkNotUsed(faceId)) {return 0;};
00070   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00071   void Contour(float value, vtkDataArray *cellScalars,
00072                vtkPointLocator *locator, vtkCellArray *verts,
00073                vtkCellArray *lines, vtkCellArray *polys,
00074                vtkPointData *inPd, vtkPointData *outPd,
00075                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00076   void Clip(float value, vtkDataArray *cellScalars,
00077             vtkPointLocator *locator, vtkCellArray *lines,
00078             vtkPointData *inPd, vtkPointData *outPd,
00079             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00080             int insideOut);
00081   int EvaluatePosition(float x[3], float* closestPoint,
00082                        int& subId, float pcoords[3],
00083                        float& dist2, float *weights);
00084   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00085                         float *weights);
00086   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00087                         float x[3], float pcoords[3], int& subId);
00088   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00089   void Derivatives(int subId, float pcoords[3], float *values,
00090                    int dim, float *derivs);
00092
00094   int GetParametricCenter(float pcoords[3]);
00095
00096
00097 protected:
00098   vtkPolyLine();
00099   ~vtkPolyLine();
00100
00101   vtkLine *Line;
00102
00103 private:
00104   vtkPolyLine(const vtkPolyLine&);  // Not implemented.
00105   void operator=(const vtkPolyLine&);  // Not implemented.
00106 };
00107
00108 #endif
00109
00110
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPolyVertex.h Source File

Common/vtkPolyVertex.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPolyVertex.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkPolyVertex_h
00042 #define __vtkPolyVertex_h
00043
00044 #include "vtkCell.h"
00045 #include "vtkVertex.h"
00046
00047 class VTK_COMMON_EXPORT vtkPolyVertex : public vtkCell
00048 {
00049 public:
00050   static vtkPolyVertex *New();
00051   vtkTypeRevisionMacro(vtkPolyVertex,vtkCell);
00052
00054
00055   vtkCell *MakeObject();
00056   int GetCellType() {return VTK_POLY_VERTEX;};
00057   int GetCellDimension() {return 0;};
00058   int GetNumberOfEdges() {return 0;};
00059   int GetNumberOfFaces() {return 0;};
00060   vtkCell *GetEdge(int vtkNotUsed(edgeId)) {return 0;};
00061   vtkCell *GetFace(int vtkNotUsed(faceId)) {return 0;};
00062   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00063   void Contour(float value, vtkDataArray *cellScalars,
00064                vtkPointLocator *locator, vtkCellArray *verts,
00065                vtkCellArray *lines, vtkCellArray *polys,
00066                vtkPointData *inPd, vtkPointData *outPd,
00067                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00068   void Clip(float value, vtkDataArray *cellScalars,
00069             vtkPointLocator *locator, vtkCellArray *verts,
00070             vtkPointData *inPd, vtkPointData *outPd,
00071             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00072             int insideOut);
00073   int EvaluatePosition(float x[3], float* closestPoint,
00074                        int& subId, float pcoords[3],
00075                        float& dist2, float *weights);
00076   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00077                         float *weights);
00078   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00079                         float x[3], float pcoords[3], int& subId);
00080   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00081   void Derivatives(int subId, float pcoords[3], float *values,
00082                    int dim, float *derivs);
00084
00086   int GetParametricCenter(float pcoords[3]);
00087
00088
00089 protected:
00090   vtkPolyVertex();
00091   ~vtkPolyVertex();
00092
00093   vtkVertex *Vertex;
00094
00095 private:
00096   vtkPolyVertex(const vtkPolyVertex&);  // Not implemented.
00097   void operator=(const vtkPolyVertex&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPOPReader.h Source File

Parallel/vtkPOPReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPOPReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00032 #ifndef __vtkPOPReader_h
00033 #define __vtkPOPReader_h
00034
00035 #include <stdio.h>
00036 #include "vtkImageData.h"
00037 #include "vtkStructuredGridSource.h"
00038
00039 class VTK_PARALLEL_EXPORT vtkPOPReader : public vtkStructuredGridSource
00040 {
00041 public:
00042   static vtkPOPReader *New();
00043   vtkTypeRevisionMacro(vtkPOPReader,vtkStructuredGridSource);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00047
00048   vtkGetVector2Macro(Dimensions, int);
00050
00052
00054   vtkGetStringMacro(GridFileName);
00056
00058
00059   vtkGetStringMacro(UFlowFileName);
00060   vtkGetStringMacro(VFlowFileName);
00062
00064
00065   vtkSetStringMacro(FileName);
00066   vtkGetStringMacro(FileName);
00068
00070
00071   vtkSetMacro(Radius, float);
00072   vtkGetMacro(Radius, float);
00074
00076
00078   vtkSetVector6Macro(ClipExtent, int);
00079   vtkGetVector6Macro(ClipExtent, int);
00081
00083
00084   vtkSetMacro(NumberOfGhostLevels, int);
00085   vtkGetMacro(NumberOfGhostLevels, int);
00087
00088 protected:
00089   vtkPOPReader();
00090   ~vtkPOPReader();
00091   vtkPOPReader(const vtkPOPReader&) {};
00092   void operator=(const vtkPOPReader&) {};
00093
00094   void ExecuteInformation();
00095   void Execute();
00096
00097   void ReadInformationFile();
00098   vtkPoints *ReadPoints(vtkImageData *image);
00099   void ReadFlow();
00100   // NOT USED
00101   vtkPoints *GeneratePoints();
00102
00103   char *FileName;
00104
00105   int Dimensions[2];
00106   vtkSetStringMacro(GridFileName);
00107   void SetGridName(char *name);
00108   char *GridFileName;
00109
00110   float Radius;
00111   vtkFloatArray *DepthValues;
00112   int NumberOfGhostLevels;
00113
00114   void DeleteArrays();
00115   void AddArray(char *arrayName, char *fileName, unsigned long offset);
00116   void AddArrayName(char *arrayName, char *fileName, unsigned long offset);
00117   int NumberOfArrays;
00118   int MaximumNumberOfArrays;
00119   char **ArrayNames;
00120   char **ArrayFileNames;
00121   unsigned long *ArrayOffsets;
00122   int ArrayFileDimensionality;
00123
00124
00125   char *UFlowFileName;
00126   vtkSetStringMacro(UFlowFileName);
00127   unsigned long UFlowFileOffset;
00128   char *VFlowFileName;
00129   vtkSetStringMacro(VFlowFileName);
00130   unsigned long VFlowFileOffset;
00131
00132
00133   int IsFileName(char *name);
00134   char *MakeFileName(char *name);
00135
00136   int ClipExtent[6];
00137 };
00138
00139 #endif
00140
00141
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkPostScriptWriter.h Source File

IO/vtkPostScriptWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPostScriptWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkPostScriptWriter_h
00039 #define __vtkPostScriptWriter_h
00040
00041 #include "vtkImageWriter.h"
00042
00043 class VTK_IO_EXPORT vtkPostScriptWriter : public vtkImageWriter
00044 {
00045 public:
00046   static vtkPostScriptWriter *New();
00047   vtkTypeRevisionMacro(vtkPostScriptWriter,vtkImageWriter);
00048
00049 protected:
00050   vtkPostScriptWriter() {};
00051   ~vtkPostScriptWriter() {};
00052
00053   virtual void WriteFile(ofstream *file, vtkImageData *data, int extent[6]);
00054   virtual void WriteFileHeader(ofstream *, vtkImageData *);
00055   virtual void WriteFileTrailer(ofstream *, vtkImageData *);
00056 private:
00057   vtkPostScriptWriter(const vtkPostScriptWriter&);  // Not implemented.
00058   void operator=(const vtkPostScriptWriter&);  // Not implemented.
00059 };
00060
00061 #endif
00062
00063
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPPolyDataNormals.h Source File

Parallel/vtkPPolyDataNormals.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPPolyDataNormals.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkPPolyDataNormals_h
00032 #define __vtkPPolyDataNormals_h
00033
00034 #include "vtkPolyDataNormals.h"
00035
00036 class VTK_PARALLEL_EXPORT vtkPPolyDataNormals : public vtkPolyDataNormals
00037 {
00038 public:
00039   vtkTypeRevisionMacro(vtkPPolyDataNormals,vtkPolyDataNormals);
00040   void PrintSelf(ostream& os, vtkIndent indent);
00041
00042   static vtkPPolyDataNormals *New();
00043
00045
00047   vtkSetMacro(PieceInvariant, int);
00048   vtkGetMacro(PieceInvariant, int);
00049   vtkBooleanMacro(PieceInvariant, int);
00051
00052 protected:
00053   vtkPPolyDataNormals();
00054   ~vtkPPolyDataNormals() {};
00055
00056   // Usual data generation method
00057   virtual void Execute();
00058   void ComputeInputUpdateExtents(vtkDataObject *output);
00059
00060   int PieceInvariant;
00061 private:
00062   vtkPPolyDataNormals(const vtkPPolyDataNormals&);  // Not implemented.
00063   void operator=(const vtkPPolyDataNormals&);  // Not implemented.
00064 };
00065
00066 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPriorityQueue.h Source File

Common/vtkPriorityQueue.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPriorityQueue.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkPriorityQueue_h
00052 #define __vtkPriorityQueue_h
00053
00054 #include "vtkObject.h"
00055 #include "vtkIdTypeArray.h"
00056
00057 //BTX
00058 typedef struct _vtkPriorityItem
00059   {
00060   float priority;
00061   vtkIdType id;
00062   } vtkPriorityItem;
00063 //ETX
00064
00065 class VTK_COMMON_EXPORT vtkPriorityQueue : public vtkObject
00066 {
00067 public:
00070   static vtkPriorityQueue *New();
00071
00072   vtkTypeRevisionMacro(vtkPriorityQueue,vtkObject);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00076   void Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00077
00080   void Insert(float priority, vtkIdType id);
00081
00086   vtkIdType Pop(vtkIdType location, float &priority);
00087 //ETX
00088
00091   vtkIdType Pop(vtkIdType location=0);
00092
00095   vtkIdType Peek(vtkIdType location, float &priority);
00096 //ETX
00097
00100   vtkIdType Peek(vtkIdType location=0);
00101
00104   float DeleteId(vtkIdType id);
00105
00108   float GetPriority(vtkIdType id);
00109
00111   vtkIdType GetNumberOfItems() {return this->MaxId+1;};
00112
00115   void Reset();
00116
00117 protected:
00118   vtkPriorityQueue();
00119   ~vtkPriorityQueue();
00120
00121   vtkPriorityItem *Resize(const vtkIdType sz);
00122
00123   vtkIdTypeArray *ItemLocation;
00124   vtkPriorityItem *Array;
00125   vtkIdType Size;
00126   vtkIdType MaxId;
00127   vtkIdType Extend;
00128 private:
00129   vtkPriorityQueue(const vtkPriorityQueue&);  // Not implemented.
00130   void operator=(const vtkPriorityQueue&);  // Not implemented.
00131 };
00132
00133 inline float vtkPriorityQueue::DeleteId(vtkIdType id)
00134 {
00135   float priority=VTK_LARGE_FLOAT;
00136   int loc;
00137
00138   if ( id <= this->ItemLocation->GetMaxId() &&
00139   (loc=this->ItemLocation->GetValue(id)) != -1 )
00140     {
00141     this->Pop(loc,priority);
00142     }
00143   return priority;
00144 }
00145
00146 inline float vtkPriorityQueue::GetPriority(vtkIdType id)
00147 {
00148   int loc;
00149
00150   if ( id <= this->ItemLocation->GetMaxId() &&
00151   (loc=this->ItemLocation->GetValue(id)) != -1 )
00152     {
00153     return this->Array[loc].priority;
00154     }
00155   return VTK_LARGE_FLOAT;
00156 }
00157
00158 inline vtkIdType vtkPriorityQueue::Peek(vtkIdType location, float &priority)
00159 {
00160   if ( this->MaxId < 0 )
00161     {
00162     return -1;
00163     }
00164   else
00165     {
00166     priority = this->Array[location].priority;
00167     return this->Array[location].id;
00168     }
00169 }
00170
00171 inline vtkIdType vtkPriorityQueue::Peek(vtkIdType location)
00172 {
00173   if ( this->MaxId < 0 )
00174     {
00175     return -1;
00176     }
00177   else
00178     {
00179     return this->Array[location].id;
00180     }
00181 }
00182
00183 #endif
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProbeFilter.h Source File

Graphics/vtkProbeFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProbeFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkProbeFilter_h
00048 #define __vtkProbeFilter_h
00049
00050 #include "vtkDataSetToDataSetFilter.h"
00051 #include "vtkIdTypeArray.h"
00052
00053 class VTK_GRAPHICS_EXPORT vtkProbeFilter : public vtkDataSetToDataSetFilter
00054 {
00055 public:
00056   static vtkProbeFilter *New();
00057   vtkTypeRevisionMacro(vtkProbeFilter,vtkDataSetToDataSetFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00063   void SetSource(vtkDataSet *source);
00064   vtkDataSet *GetSource();
00066
00068
00076   vtkSetMacro(SpatialMatch, int);
00077   vtkGetMacro(SpatialMatch, int);
00078   vtkBooleanMacro(SpatialMatch, int);
00080
00082
00084   vtkGetObjectMacro(ValidPoints, vtkIdTypeArray);
00086
00087 protected:
00088   vtkProbeFilter();
00089   ~vtkProbeFilter();
00090
00091   int SpatialMatch;
00092
00093   void Execute();
00094   void ExecuteInformation();
00095   void ComputeInputUpdateExtents(vtkDataObject *output);
00096
00097   vtkIdTypeArray *ValidPoints;
00098 private:
00099   vtkProbeFilter(const vtkProbeFilter&);  // Not implemented.
00100   void operator=(const vtkProbeFilter&);  // Not implemented.
00101 };
00102
00103 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkProcessObject.h Source File

Common/vtkProcessObject.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProcessObject.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkProcessObject_h
00065 #define __vtkProcessObject_h
00066
00067 #include "vtkDataObject.h"
00068
00069 class VTK_COMMON_EXPORT vtkProcessObject : public vtkObject
00070 {
00071 public:
00073   static vtkProcessObject *New();
00074
00075   vtkTypeRevisionMacro(vtkProcessObject,vtkObject);
00076   void PrintSelf(ostream& os, vtkIndent indent);
00077
00079   void SetStartMethod(void (*f)(void *), void *arg);
00080
00082   void SetProgressMethod(void (*f)(void *), void *arg);
00083
00085   void SetEndMethod(void (*f)(void *), void *arg);
00086
00088   void SetStartMethodArgDelete(void (*f)(void *));
00089
00091   void SetProgressMethodArgDelete(void (*f)(void *));
00092
00094   void SetEndMethodArgDelete(void (*f)(void *));
00095
00097
00099   vtkSetMacro(AbortExecute,int);
00100   vtkGetMacro(AbortExecute,int);
00101   vtkBooleanMacro(AbortExecute,int);
00103
00105
00106   vtkSetClampMacro(Progress,float,0.0,1.0);
00107   vtkGetMacro(Progress,float);
00109
00113   void UpdateProgress(float amount);
00114
00116
00118   vtkSetStringMacro(ProgressText);
00119   vtkGetStringMacro(ProgressText);
00121
00122   // left public for performance since it is used in inner loops
00123   int AbortExecute;
00124
00126
00128   vtkDataObject **GetInputs() {return this->Inputs;}
00129   vtkGetMacro(NumberOfInputs,int);
00131
00134   void SqueezeInputArray();
00135
00137   void RemoveAllInputs();
00138
00139 protected:
00140   vtkProcessObject();
00141   ~vtkProcessObject();
00142
00143   // Progress/Update handling
00144   unsigned long StartTag;
00145   unsigned long ProgressTag;
00146   unsigned long EndTag;
00147   float Progress;
00148   char  *ProgressText;
00149
00150   int NumberOfInputs;
00151   int NumberOfRequiredInputs;
00152   vtkDataObject **Inputs;     //An array of the inputs to the filter
00153   // Temporary arrays used internally.
00154   // It is only valid after SortInputsByLocality is called.
00155   vtkDataObject **SortedInputs;   // Inputs sorted by locality
00156   // We need a second array for an effficeint search.
00157   // This array is never valid.
00158   vtkDataObject **SortedInputs2;
00159   void SortInputsByLocality();
00160   // A helper method for quicksort.
00161   void SortMerge(vtkDataObject **a1, int l1,
00162                  vtkDataObject **a2, int l2,
00163                  vtkDataObject **results);
00164
00165   // Called to allocate the input array.  Copies old inputs.
00166   void SetNumberOfInputs(int num);
00167
00168   // protected methods for setting inputs.
00169   virtual void SetNthInput(int num, vtkDataObject *input);
00170   virtual void AddInput(vtkDataObject *input);
00171   virtual void RemoveInput(vtkDataObject *input);
00172
00173 private:
00174   vtkProcessObject(const vtkProcessObject&);  // Not implemented.
00175   void operator=(const vtkProcessObject&);  // Not implemented.
00176 };
00177
00178 #endif
00179
Generated on Mon Mar 25 01:07:36 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkProcessStatistics.h Source File

Common/vtkProcessStatistics.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProcessStatistics.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkProcessStatistics_h
00032 #define __vtkProcessStatistics_h
00033
00034 #include "vtkObject.h"
00035 #include "vtkLine.h"
00036 #include "vtkPixel.h"
00037
00038 class VTK_COMMON_EXPORT vtkProcessStatistics : public vtkObject
00039 {
00040 public:
00042   static vtkProcessStatistics *New();
00043
00044   vtkTypeRevisionMacro(vtkProcessStatistics,vtkObject);
00045
00046   int   GetProcessSizeInBytes();
00047   float GetProcessCPUTimeInMilliseconds();
00048
00049 protected:
00050   vtkProcessStatistics();
00051   ~vtkProcessStatistics() {};
00052
00053
00054 private:
00055   vtkProcessStatistics(const vtkProcessStatistics&);  // Not implemented.
00056   void operator=(const vtkProcessStatistics&);  // Not implemented.
00057 };
00058
00059 #endif
00060
00061
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkProcrustesAlignmentFilter.h Source File

Hybrid/vtkProcrustesAlignmentFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProcrustesAlignmentFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00068 #ifndef __vtkProcrustesAlignmentFilter_h
00069 #define __vtkProcrustesAlignmentFilter_h
00070
00071 #include "vtkSource.h"
00072
00073 class vtkLandmarkTransform;
00074 class vtkPointSet;
00075
00076 class VTK_HYBRID_EXPORT vtkProcrustesAlignmentFilter : public vtkSource
00077 {
00078 public:
00079   vtkTypeRevisionMacro(vtkProcrustesAlignmentFilter,vtkSource);
00080
00082   void PrintSelf(ostream& os, vtkIndent indent);
00083
00085   static vtkProcrustesAlignmentFilter *New();
00086
00088
00091   vtkGetObjectMacro(LandmarkTransform,vtkLandmarkTransform);
00093
00095   void SetNumberOfInputs(int n);
00096
00099   void SetInput(int idx,vtkPointSet* p);
00100
00102   vtkPointSet* GetOutput(int idx);
00103
00106   vtkPointSet* GetInput(int idx);
00107
00108 protected:
00109   vtkProcrustesAlignmentFilter();
00110   ~vtkProcrustesAlignmentFilter();
00111
00113   void Execute();
00114
00115   vtkLandmarkTransform *LandmarkTransform;
00116
00117 private:
00118   vtkProcrustesAlignmentFilter(const vtkProcrustesAlignmentFilter&);  // Not implemented.
00119   void operator=(const vtkProcrustesAlignmentFilter&);  // Not implemented.
00120 };
00121
00122 #endif
00123
00124
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProgrammableAttributeDataFilter.h Source File

Graphics/vtkProgrammableAttributeDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProgrammableAttributeDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00091 #ifndef __vtkProgrammableAttributeDataFilter_h
00092 #define __vtkProgrammableAttributeDataFilter_h
00093
00094 #include "vtkDataSetToDataSetFilter.h"
00095 #include "vtkDataSetCollection.h"
00096
00097 class VTK_GRAPHICS_EXPORT vtkProgrammableAttributeDataFilter : public vtkDataSetToDataSetFilter
00098 {
00099 public:
00100   static vtkProgrammableAttributeDataFilter *New();
00101   vtkTypeRevisionMacro(vtkProgrammableAttributeDataFilter,vtkDataSetToDataSetFilter);
00102   void PrintSelf(ostream& os, vtkIndent indent);
00103
00105   void AddInput(vtkDataSet *in);
00106
00108   void RemoveInput(vtkDataSet *in);
00109
00111   vtkDataSetCollection *GetInputList() {return this->InputList;};
00112
00115   void SetExecuteMethod(void (*f)(void *), void *arg);
00116
00118   void SetExecuteMethodArgDelete(void (*f)(void *));
00119
00120 protected:
00121   vtkProgrammableAttributeDataFilter();
00122   ~vtkProgrammableAttributeDataFilter();
00123
00124   void Execute();
00125   vtkDataSetCollection *InputList; //list of datasets to process
00126   void (*ExecuteMethod)(void *); //function to invoke
00127   void (*ExecuteMethodArgDelete)(void *);
00128   void *ExecuteMethodArg;
00129
00130 private:
00131   // hide the superclass' AddInput() from the user and the compiler
00132   void AddInput(vtkDataObject *)
00133     { vtkErrorMacro( << "AddInput() must be called with a vtkDataSet not a vtkDataObject."); };
00134   void RemoveInput(vtkDataObject *input)
00135     { this->vtkProcessObject::RemoveInput(input); };
00136 private:
00137   vtkProgrammableAttributeDataFilter(const vtkProgrammableAttributeDataFilter&);  // Not implemented.
00138   void operator=(const vtkProgrammableAttributeDataFilter&);  // Not implemented.
00139 };
00140
00141 #endif
00142
00143
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProgrammableDataObjectSource.h Source File

Graphics/vtkProgrammableDataObjectSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProgrammableDataObjectSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkProgrammableDataObjectSource_h
00052 #define __vtkProgrammableDataObjectSource_h
00053
00054 #include "vtkSource.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkProgrammableDataObjectSource : public vtkSource
00057 {
00058 public:
00059   static vtkProgrammableDataObjectSource *New();
00060   vtkTypeRevisionMacro(vtkProgrammableDataObjectSource,vtkSource);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00065   void SetExecuteMethod(void (*f)(void *), void *arg);
00066
00068   void SetExecuteMethodArgDelete(void (*f)(void *));
00069
00071
00072   vtkDataObject *GetOutput();
00073   vtkDataObject *GetOutput(int idx)
00074     {return (vtkDataObject *) this->vtkSource::GetOutput(idx); };
00076
00077 protected:
00078   vtkProgrammableDataObjectSource();
00079   ~vtkProgrammableDataObjectSource();
00080
00081   void Execute();
00082
00083   void (*ExecuteMethod)(void *); //function to invoke
00084   void (*ExecuteMethodArgDelete)(void *);
00085   void *ExecuteMethodArg;
00086 private:
00087   vtkProgrammableDataObjectSource(const vtkProgrammableDataObjectSource&);  // Not implemented.
00088   void operator=(const vtkProgrammableDataObjectSource&);  // Not implemented.
00089 };
00090
00091 #endif
00092
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProgrammableFilter.h Source File

Graphics/vtkProgrammableFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProgrammableFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkProgrammableFilter_h
00055 #define __vtkProgrammableFilter_h
00056
00057 #include "vtkDataSetToDataSetFilter.h"
00058
00059 class VTK_GRAPHICS_EXPORT vtkProgrammableFilter : public vtkDataSetToDataSetFilter
00060 {
00061 public:
00062   static vtkProgrammableFilter *New();
00063   vtkTypeRevisionMacro(vtkProgrammableFilter,vtkDataSetToDataSetFilter);
00064
00067   void SetExecuteMethod(void (*f)(void *), void *arg);
00068
00070   void SetExecuteMethodArgDelete(void (*f)(void *));
00071
00076   vtkPolyData *GetPolyDataInput();
00077
00079   vtkStructuredPoints *GetStructuredPointsInput();
00080
00082   vtkStructuredGrid *GetStructuredGridInput();
00083
00085   vtkUnstructuredGrid *GetUnstructuredGridInput();
00086
00088   vtkRectilinearGrid *GetRectilinearGridInput();
00089
00090 protected:
00091   vtkProgrammableFilter();
00092   ~vtkProgrammableFilter();
00093
00094   void Execute();
00095
00096   void (*ExecuteMethod)(void *); //function to invoke
00097   void (*ExecuteMethodArgDelete)(void *);
00098   void *ExecuteMethodArg;
00099
00100 private:
00101   vtkProgrammableFilter(const vtkProgrammableFilter&);  // Not implemented.
00102   void operator=(const vtkProgrammableFilter&);  // Not implemented.
00103 };
00104
00105 #endif
00106
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProgrammableGlyphFilter.h Source File

Graphics/vtkProgrammableGlyphFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProgrammableGlyphFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00075 #ifndef __vtkProgrammableGlyphFilter_h
00076 #define __vtkProgrammableGlyphFilter_h
00077
00078 #define VTK_COLOR_BY_INPUT  0
00079 #define VTK_COLOR_BY_SOURCE 1
00080
00081 #include "vtkDataSetToPolyDataFilter.h"
00082
00083 class VTK_GRAPHICS_EXPORT vtkProgrammableGlyphFilter : public vtkDataSetToPolyDataFilter
00084 {
00085 public:
00086   vtkTypeRevisionMacro(vtkProgrammableGlyphFilter,vtkDataSetToPolyDataFilter);
00087   void PrintSelf(ostream& os, vtkIndent indent);
00088
00091   static vtkProgrammableGlyphFilter *New();
00092
00094
00096   void SetSource(vtkPolyData *source);
00097   vtkPolyData *GetSource();
00099
00101   void SetGlyphMethod(void (*f)(void *), void *arg);
00102
00105   void SetGlyphMethodArgDelete(void (*f)(void *));
00106
00108
00111   vtkGetMacro(PointId, vtkIdType);
00113
00115
00118   vtkGetVector3Macro(Point,float);
00120
00122
00125   vtkGetObjectMacro(PointData,vtkPointData);
00127
00129
00130   vtkSetMacro(ColorMode,int);
00131   vtkGetMacro(ColorMode,int);
00132   void SetColorModeToColorByInput()
00133     {this->SetColorMode(VTK_COLOR_BY_INPUT);};
00134   void SetColorModeToColorBySource()
00135     {this->SetColorMode(VTK_COLOR_BY_SOURCE);};
00136   const char *GetColorModeAsString();
00138
00139 protected:
00140   vtkProgrammableGlyphFilter();
00141   ~vtkProgrammableGlyphFilter();
00142
00143   void Execute();
00144
00145   float Point[3]; // Coordinates of point
00146   vtkIdType PointId; // Current point id during processing
00147   vtkPointData *PointData;
00148   int ColorMode;
00149
00150   void (*GlyphMethod)(void *); // Support GlyphMethod
00151   void (*GlyphMethodArgDelete)(void *);
00152   void *GlyphMethodArg;
00153
00154 private:
00155   vtkProgrammableGlyphFilter(const vtkProgrammableGlyphFilter&);  // Not implemented.
00156   void operator=(const vtkProgrammableGlyphFilter&);  // Not implemented.
00157 };
00158
00159 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProgrammableSource.h Source File

Graphics/vtkProgrammableSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProgrammableSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkProgrammableSource_h
00059 #define __vtkProgrammableSource_h
00060
00061 #include "vtkSource.h"
00062
00063 class vtkPolyData;
00064 class vtkStructuredPoints;
00065 class vtkStructuredGrid;
00066 class vtkUnstructuredGrid;
00067 class vtkRectilinearGrid;
00068
00069 class VTK_GRAPHICS_EXPORT vtkProgrammableSource : public vtkSource
00070 {
00071 public:
00072   static vtkProgrammableSource *New();
00073   vtkTypeRevisionMacro(vtkProgrammableSource,vtkSource);
00074
00077   void SetExecuteMethod(void (*f)(void *), void *arg);
00078
00080   void SetExecuteMethodArgDelete(void (*f)(void *));
00081
00086   vtkPolyData *GetPolyDataOutput();
00087
00089   vtkStructuredPoints *GetStructuredPointsOutput();
00090
00092   vtkStructuredGrid *GetStructuredGridOutput();
00093
00095   vtkUnstructuredGrid *GetUnstructuredGridOutput();
00096
00098   vtkRectilinearGrid *GetRectilinearGridOutput();
00099
00100   void UpdateInformation();
00101   void UpdateData(vtkDataObject *output);
00102
00103 protected:
00104   vtkProgrammableSource();
00105   ~vtkProgrammableSource();
00106
00107   void Execute();
00108
00109   void (*ExecuteMethod)(void *); //function to invoke
00110   void (*ExecuteMethodArgDelete)(void *);
00111   void *ExecuteMethodArg;
00112
00113   vtkTimeStamp ExecuteTime;
00114 private:
00115   vtkProgrammableSource(const vtkProgrammableSource&);  // Not implemented.
00116   void operator=(const vtkProgrammableSource&);  // Not implemented.
00117 };
00118
00119 #endif
00120
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkProjectedTexture.h Source File

Graphics/vtkProjectedTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProjectedTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkProjectedTexture_h
00043 #define __vtkProjectedTexture_h
00044
00045 #include "vtkDataSetToDataSetFilter.h"
00046
00047 class VTK_GRAPHICS_EXPORT vtkProjectedTexture : public vtkDataSetToDataSetFilter
00048 {
00049 public:
00050   static vtkProjectedTexture *New();
00051   vtkTypeRevisionMacro(vtkProjectedTexture,vtkDataSetToDataSetFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055
00056   vtkSetVector3Macro(Position,float);
00057   vtkGetVectorMacro(Position,float,3);
00059
00061
00063   void SetFocalPoint(float focalPoint[3]);
00064   void SetFocalPoint(float x, float y, float z);
00065   vtkGetVectorMacro(FocalPoint,float,3);
00067
00069
00070   vtkGetVectorMacro(Orientation,float,3);
00072
00073   // Set/Get the up vector of the projector.
00074   vtkSetVector3Macro(Up,float);
00075   vtkGetVectorMacro(Up,float,3);
00076
00077   // Set/Get the aspect ratio of a perpendicular cross-section of the
00078   // the projector's frustum.  The aspect ratio consists of three
00079   // numbers:  (x, y, z), where x is the width of the
00080   // frustum, y is the height, and z is the perpendicular
00081   // distance from the focus of the projector.
00082   vtkSetVector3Macro(AspectRatio,float);
00083   vtkGetVectorMacro(AspectRatio,float,3);
00084
00086
00087   vtkSetVector2Macro(SRange,float);
00088   vtkGetVectorMacro(SRange,float,2);
00090
00092
00093   vtkSetVector2Macro(TRange,float);
00094   vtkGetVectorMacro(TRange,float,2);
00096
00097 protected:
00098   vtkProjectedTexture();
00099   ~vtkProjectedTexture() {};
00100
00101   void Execute();
00102   void ComputeNormal();
00103
00104   float Position[3];
00105   float Orientation[3];
00106   float FocalPoint[3];
00107   float Up[3];
00108   float AspectRatio[3];
00109   float SRange[2];
00110   float TRange[2];
00111 private:
00112   vtkProjectedTexture(const vtkProjectedTexture&);  // Not implemented.
00113   void operator=(const vtkProjectedTexture&);  // Not implemented.
00114 };
00115
00116 #endif
00117
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkProp3D.h Source File

Rendering/vtkProp3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProp3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkProp3D_h
00046 #define __vtkProp3D_h
00047
00048 #include "vtkProp.h"
00049 #include "vtkTransform.h"
00050
00051 class vtkRenderer;
00052
00053 class VTK_RENDERING_EXPORT vtkProp3D : public vtkProp
00054 {
00055 public:
00056   vtkTypeRevisionMacro(vtkProp3D,vtkProp);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   void ShallowCopy(vtkProp *prop);
00061
00063
00064   virtual void SetPosition(float _arg1, float _arg2, float _arg3)
00065     {
00066       vtkDebugMacro(<< this->GetClassName() << " (" << this <<
00067       "): setting Position to (" << _arg1 << "," << _arg2 << "," <<
00068       _arg3 << ")");
00069       if ((this->Position[0] != _arg1)||
00070           (this->Position[1] != _arg2)||
00071           (this->Position[2] != _arg3))
00072         {
00073         this->Position[0] = _arg1;
00074         this->Position[1] = _arg2;
00075         this->Position[2] = _arg3;
00076         this->Modified();
00077         this->IsIdentity = 0;
00078         }
00079     };
00080   virtual void SetPosition (float _arg[3])
00081     {
00082       this->SetPosition (_arg[0], _arg[1], _arg[2]);
00083     }
00084   vtkGetVectorMacro(Position,float,3);
00085   void AddPosition(float deltaPosition[3]);
00086   void AddPosition(float deltaX,float deltaY,float deltaZ);
00088
00090
00092   virtual void SetOrigin(float _arg1, float _arg2, float _arg3)
00093     {
00094       vtkDebugMacro(<< this->GetClassName() << " (" << this <<
00095       "): setting Origin to (" << _arg1 << "," << _arg2 << "," <<
00096       _arg3 << ")");
00097       if ((this->Origin[0] != _arg1)||
00098           (this->Origin[1] != _arg2)||
00099           (this->Origin[2] != _arg3))
00100         {
00101         this->Origin[0] = _arg1;
00102         this->Origin[1] = _arg2;
00103         this->Origin[2] = _arg3;
00104         this->Modified();
00105         this->IsIdentity = 0;
00106         }
00107     };
00108   virtual void SetOrigin(float _arg[3])
00109     {
00110       this->SetOrigin (_arg[0], _arg[1], _arg[2]);
00111     }
00112   vtkGetVectorMacro(Origin,float,3);
00114
00116
00119   virtual void SetScale(float _arg1, float _arg2, float _arg3)
00120     {
00121       vtkDebugMacro(<< this->GetClassName() << " (" << this <<
00122       "): setting Scale to (" << _arg1 << "," << _arg2 << "," <<
00123       _arg3 << ")");
00124       if ((this->Scale[0] != _arg1)||
00125           (this->Scale[1] != _arg2)||
00126           (this->Scale[2] != _arg3))
00127         {
00128         this->Scale[0] = _arg1;
00129         this->Scale[1] = _arg2;
00130         this->Scale[2] = _arg3;
00131         this->Modified();
00132         this->IsIdentity = 0;
00133         }
00134     };
00135   virtual void SetScale (float _arg[3])
00136     {
00137       this->SetScale (_arg[0], _arg[1], _arg[2]);
00138     }
00139   vtkGetVectorMacro(Scale,float,3);
00141
00143   void SetScale(float s) {this->SetScale(s,s,s);};
00144
00146
00155   void SetUserTransform(vtkLinearTransform *transform);
00156   vtkGetObjectMacro(UserTransform,vtkLinearTransform);
00158
00160
00161   void SetUserMatrix(vtkMatrix4x4 *matrix);
00162   vtkMatrix4x4 *GetUserMatrix() {
00163     if (this->UserTransform) { this->UserTransform->Update(); };
00164     return this->UserMatrix; };
00166
00168
00171   virtual void GetMatrix(vtkMatrix4x4 *m);
00172   virtual void GetMatrix(double m[16]);
00174
00179   void GetBounds(float bounds[6]);
00180   virtual float *GetBounds() = 0;
00182
00184   float *GetCenter();
00185
00187   float *GetXRange();
00188
00190   float *GetYRange();
00191
00193   float *GetZRange();
00194
00196   float GetLength();
00197
00203   void RotateX(float);
00204
00210   void RotateY(float);
00211
00217   void RotateZ(float);
00218
00222   void RotateWXYZ(float,float,float,float);
00223
00227   void SetOrientation(float,float,float);
00228
00232   void SetOrientation(float a[3]);
00233
00235
00239   float *GetOrientation();
00240   void GetOrientation(float o[3]);
00242
00244   float *GetOrientationWXYZ();
00245
00249   void AddOrientation(float,float,float);
00250
00254   void AddOrientation(float a[3]);
00255
00264   void PokeMatrix(vtkMatrix4x4 *matrix);
00265
00268   void InitPathTraversal();
00269
00270
00272   virtual void ComputeMatrix();
00273
00275
00276   vtkMatrix4x4 *GetMatrix()
00277     {
00278       this->ComputeMatrix();
00279       return this->Matrix;
00280     }
00282
00284
00285   vtkGetMacro(IsIdentity,int);
00287
00288 protected:
00289   vtkProp3D();
00290   ~vtkProp3D();
00291
00292   vtkLinearTransform *UserTransform;
00293   vtkMatrix4x4  *UserMatrix;
00294   vtkMatrix4x4  *Matrix;
00295   vtkTimeStamp  MatrixMTime;
00296   float         Origin[3];
00297   float         Position[3];
00298   float         Orientation[3];
00299   float         Scale[3];
00300   float         Center[3];
00301   vtkTransform  *Transform;
00302   float         Bounds[6];
00303   vtkProp3D     *CachedProp3D; //support the PokeMatrix() method
00304   int           IsIdentity;
00305 private:
00306   vtkProp3D(const vtkProp3D&);  // Not implemented.
00307   void operator=(const vtkProp3D&);  // Not implemented.
00308 };
00309
00310 #endif
00311
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkProp3DCollection.h Source File

Rendering/vtkProp3DCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProp3DCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkProp3DCollection_h
00037 #define __vtkProp3DCollection_h
00038
00039 #include "vtkPropCollection.h"
00040 #include "vtkProp3D.h"
00041
00042 class VTK_RENDERING_EXPORT vtkProp3DCollection : public vtkPropCollection
00043 {
00044 public:
00045   static vtkProp3DCollection *New();
00046   vtkTypeRevisionMacro(vtkProp3DCollection,vtkPropCollection);
00047
00049   void AddItem(vtkProp3D *p);
00050
00052   vtkProp3D *GetNextProp3D();
00053
00055   vtkProp3D *GetLastProp3D();
00056
00057 protected:
00058   vtkProp3DCollection() {};
00059   ~vtkProp3DCollection() {};
00060
00061
00062 private:
00063   // hide the standard AddItem from the user and the compiler.
00064   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00065   void AddItem(vtkProp *o) { this->vtkPropCollection::AddItem(o); };
00066
00067 private:
00068   vtkProp3DCollection(const vtkProp3DCollection&);  // Not implemented.
00069   void operator=(const vtkProp3DCollection&);  // Not implemented.
00070 };
00071
00072 inline void vtkProp3DCollection::AddItem(vtkProp3D *a)
00073 {
00074   this->vtkCollection::AddItem((vtkObject *)a);
00075 }
00076
00077 inline vtkProp3D *vtkProp3DCollection::GetNextProp3D()
00078 {
00079   return static_cast<vtkProp3D *>(this->GetNextItemAsObject());
00080 }
00081
00082 inline vtkProp3D *vtkProp3DCollection::GetLastProp3D()
00083 {
00084   if ( this->Bottom == NULL )
00085     {
00086     return NULL;
00087     }
00088   else
00089     {
00090     return static_cast<vtkProp3D *>(this->Bottom->Item);
00091     }
00092 }
00093
00094 #endif
00095
00096
00097
00098
00099
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkProp.h Source File

Common/vtkProp.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProp.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkProp_h
00046 #define __vtkProp_h
00047
00048 #include "vtkObject.h"
00049 #include "vtkAssemblyPaths.h"
00050
00051 class vtkViewport;
00052 class vtkPropCollection;
00053 class vtkWindow;
00054 class vtkMatrix4x4;
00055
00056 class VTK_COMMON_EXPORT vtkProp : public vtkObject
00057 {
00058 public:
00060   static vtkProp* New();
00061
00062   vtkTypeRevisionMacro(vtkProp,vtkObject);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00069   virtual void GetActors(vtkPropCollection *) {}
00070   virtual void GetActors2D(vtkPropCollection *) {}
00071   virtual void GetVolumes(vtkPropCollection *) {}
00073
00075
00076   vtkSetMacro(Visibility, int);
00077   vtkGetMacro(Visibility, int);
00078   vtkBooleanMacro(Visibility, int);
00080
00082
00084   vtkSetMacro(Pickable,int);
00085   vtkGetMacro(Pickable,int);
00086   vtkBooleanMacro(Pickable,int);
00088
00090
00092   void SetPickMethod(void (*f)(void *), void *arg);
00093   void SetPickMethodArgDelete(void (*f)(void *));
00095
00097   virtual void Pick();
00098
00100
00106   vtkSetMacro(Dragable,int);
00107   vtkGetMacro(Dragable,int);
00108   vtkBooleanMacro(Dragable,int);
00110
00115   virtual unsigned long GetRedrawMTime() {return this->GetMTime();}
00116
00119   virtual float *GetBounds() {return NULL;}
00120
00122   virtual void ShallowCopy(vtkProp *prop);
00123
00125
00136   virtual void InitPathTraversal();
00137   virtual vtkAssemblyPath *GetNextPath();
00138   virtual int GetNumberOfPaths() {return 1;}
00140
00142
00145   virtual void PokeMatrix(vtkMatrix4x4 *vtkNotUsed(matrix)) {}
00146   virtual vtkMatrix4x4 *GetMatrix() {return NULL;}
00148
00149 //BTX
00151   /*! WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE
00152       THESE METHODS OUTSIDE OF THE RENDERING PROCESS All concrete
00153       subclasses must be able to render themselves. There are three key
00154       render methods in vtk and they correspond to three different points
00155       in the rendering cycle. Any given prop may implement one or more of
00156       these methods. The first method is intended for rendering all opaque
00157       geometry. The second method is intended for rendering all translucent
00158       geometry. Most volume rendering mappers draw their results during
00159       this second method. The last method is to render any 2D annotation or
00160       overlays. Each of these methods return an integer value indicating
00161       whether or not this render method was applied to this data. */
00162   virtual int RenderOpaqueGeometry(      vtkViewport *) { return 0; }
00163   virtual int RenderTranslucentGeometry( vtkViewport *) { return 0; }
00164   virtual int RenderOverlay(             vtkViewport *) { return 0; }
00166
00171   virtual void ReleaseGraphicsResources(vtkWindow *) {}
00172
00174
00184   virtual float GetEstimatedRenderTime( vtkViewport * )
00185     { return this->EstimatedRenderTime; }
00186   virtual float GetEstimatedRenderTime(){ return this->EstimatedRenderTime; }
00188
00190
00194   virtual void SetEstimatedRenderTime(float t)
00195     {this->EstimatedRenderTime = t; this->SavedEstimatedRenderTime = t;}
00197
00199
00204   virtual void RestoreEstimatedRenderTime()
00205     { this->EstimatedRenderTime = this->SavedEstimatedRenderTime; }
00207
00208
00210
00220   virtual void AddEstimatedRenderTime(float t, vtkViewport *vtkNotUsed(vp))
00221     {this->EstimatedRenderTime+=t;}
00223
00225
00232   virtual void SetAllocatedRenderTime(float t, vtkViewport *vtkNotUsed(v))
00233     {
00234     this->AllocatedRenderTime = t;
00235     this->SavedEstimatedRenderTime = this->EstimatedRenderTime;
00236     this->EstimatedRenderTime = 0.0;
00237     }
00239
00241
00243   vtkGetMacro(AllocatedRenderTime, float);
00245
00247
00251   void SetRenderTimeMultiplier( float t ) { this->RenderTimeMultiplier = t; }
00252   vtkGetMacro(RenderTimeMultiplier, float);
00254
00258   virtual void BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path);
00259
00261
00262   vtkGetMacro(NumberOfConsumers,int);
00264
00266
00267   void AddConsumer(vtkObject *c);
00268   void RemoveConsumer(vtkObject *c);
00269   vtkObject *GetConsumer(int i);
00270   int IsConsumer(vtkObject *c);
00272
00273 //ETX
00274
00275 protected:
00276   vtkProp();
00277   ~vtkProp();
00278
00279   int Visibility;
00280   int Pickable;
00281   unsigned long PickTag;
00282   int Dragable;
00283
00284   float AllocatedRenderTime;
00285   float EstimatedRenderTime;
00286   float SavedEstimatedRenderTime;
00287   float RenderTimeMultiplier;
00288
00289   // how many consumers does this object have
00290   int NumberOfConsumers;
00291   vtkObject **Consumers;
00292
00293   // support multi-part props and access to paths of prop
00294   // stuff that follows is used to build the assembly hierarchy
00295   vtkAssemblyPaths *Paths;
00296
00297 private:
00298   vtkProp(const vtkProp&);  // Not implemented.
00299   void operator=(const vtkProp&);  // Not implemented.
00300 };
00301
00302 #endif
00303
00304
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPropAssembly.h Source File

Common/vtkPropAssembly.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPropAssembly.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkPropAssembly_h
00058 #define __vtkPropAssembly_h
00059
00060 #include "vtkProp.h"
00061
00062 class VTK_COMMON_EXPORT vtkPropAssembly : public vtkProp
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkPropAssembly,vtkProp);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   static vtkPropAssembly *New();
00070
00072   void AddPart(vtkProp *);
00073
00075   void RemovePart(vtkProp *);
00076
00078   vtkPropCollection *GetParts();
00079
00081
00084   int RenderOpaqueGeometry(vtkViewport *ren);
00085   int RenderTranslucentGeometry(vtkViewport *ren);
00086   int RenderOverlay(vtkViewport *);
00088
00092   void ReleaseGraphicsResources(vtkWindow *);
00093
00097   float *GetBounds();
00098
00100   void ShallowCopy(vtkProp *Prop);
00101
00104   unsigned long int GetMTime();
00105
00107
00115   void InitPathTraversal();
00116   vtkAssemblyPath *GetNextPath();
00117   int GetNumberOfPaths();
00119
00120 //BTX
00124   void BuildPaths(vtkAssemblyPaths *paths, vtkAssemblyPath *path);
00125 //ETX
00126
00127 protected:
00128   vtkPropAssembly();
00129   ~vtkPropAssembly();
00130
00131   vtkPropCollection *Parts;
00132   float Bounds[6];
00133
00134   // Support the BuildPaths() method,
00135   vtkTimeStamp PathTime;
00136   void UpdatePaths(); //apply transformations and properties recursively
00137 private:
00138   vtkPropAssembly(const vtkPropAssembly&);  // Not implemented.
00139   void operator=(const vtkPropAssembly&);  // Not implemented.
00140 };
00141
00142 #endif
00143
00144
00145
00146
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPropCollection.h Source File

Common/vtkPropCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPropCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkPropC_h
00043 #define __vtkPropC_h
00044
00045 #include "vtkCollection.h"
00046 #include "vtkProp.h"
00047
00048 class VTK_COMMON_EXPORT vtkPropCollection : public vtkCollection
00049 {
00050  public:
00051   static vtkPropCollection *New();
00052   vtkTypeRevisionMacro(vtkPropCollection,vtkCollection);
00053
00055   void AddItem(vtkProp *a);
00056
00058   vtkProp *GetNextProp();
00059
00061   vtkProp *GetLastProp();
00062
00067   int GetNumberOfPaths();
00068
00069 protected:
00070   vtkPropCollection() {};
00071   ~vtkPropCollection() {};
00072
00073
00074 private:
00075   // hide the standard AddItem from the user and the compiler.
00076   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00077
00078 private:
00079   vtkPropCollection(const vtkPropCollection&);  // Not implemented.
00080   void operator=(const vtkPropCollection&);  // Not implemented.
00081 };
00082
00083 inline void vtkPropCollection::AddItem(vtkProp *a)
00084 {
00085   this->vtkCollection::AddItem((vtkObject *)a);
00086 }
00087
00088 inline vtkProp *vtkPropCollection::GetNextProp()
00089 {
00090   return static_cast<vtkProp *>(this->GetNextItemAsObject());
00091 }
00092
00093 inline vtkProp *vtkPropCollection::GetLastProp()
00094 {
00095   if ( this->Bottom == NULL )
00096     {
00097     return NULL;
00098     }
00099   else
00100     {
00101     return static_cast<vtkProp *>(this->Bottom->Item);
00102     }
00103 }
00104
00105 #endif
00106
00107
00108
00109
00110
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkProperty2D.h Source File

Common/vtkProperty2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProperty2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkProperty2D_h
00038 #define __vtkProperty2D_h
00039
00040 #include "vtkObject.h"
00041
00042 class vtkViewport;
00043
00044 #define VTK_BACKGROUND_LOCATION 0
00045 #define VTK_FOREGROUND_LOCATION 1
00046
00047 class VTK_COMMON_EXPORT vtkProperty2D : public vtkObject
00048 {
00049 public:
00050   vtkTypeRevisionMacro(vtkProperty2D,vtkObject);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00055   static vtkProperty2D *New();
00056
00058   void DeepCopy(vtkProperty2D *p);
00059
00061
00062   vtkSetVector3Macro(Color, float);
00063   vtkGetVectorMacro(Color, float, 3);
00065
00067
00068   vtkGetMacro(Opacity, float);
00069   vtkSetMacro(Opacity, float);
00071
00073
00075   vtkSetClampMacro(PointSize,float,0,VTK_LARGE_FLOAT);
00076   vtkGetMacro(PointSize,float);
00078
00080
00082   vtkSetClampMacro(LineWidth,float,0,VTK_LARGE_FLOAT);
00083   vtkGetMacro(LineWidth,float);
00085
00087
00090   vtkSetMacro(LineStipplePattern,int);
00091   vtkGetMacro(LineStipplePattern,int);
00093
00095
00098   vtkSetClampMacro(LineStippleRepeatFactor,int,1,VTK_LARGE_INTEGER);
00099   vtkGetMacro(LineStippleRepeatFactor,int);
00101
00103
00109   vtkSetClampMacro( DisplayLocation, int,
00110                     VTK_BACKGROUND_LOCATION, VTK_FOREGROUND_LOCATION );
00111   vtkGetMacro( DisplayLocation, int );
00112   void SetDisplayLocationToBackground()
00113     {this->DisplayLocation = VTK_BACKGROUND_LOCATION;};
00114   void SetDisplayLocationToForeground()
00115     {this->DisplayLocation = VTK_FOREGROUND_LOCATION;};
00117
00118
00120   virtual void Render (vtkViewport* vtkNotUsed(viewport))  {}
00121
00122 protected:
00123   vtkProperty2D();
00124   ~vtkProperty2D();
00125
00126   float Color[3];
00127   float Opacity;
00128   float PointSize;
00129   float LineWidth;
00130   int   LineStipplePattern;
00131   int   LineStippleRepeatFactor;
00132   int   DisplayLocation;
00133 private:
00134   vtkProperty2D(const vtkProperty2D&);  // Not implemented.
00135   void operator=(const vtkProperty2D&);  // Not implemented.
00136 };
00137
00138
00139 #endif
00140
00141
00142
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkProperty.h Source File

Rendering/vtkProperty.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkProperty.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkProperty_h
00049 #define __vtkProperty_h
00050
00051 #include "vtkRender.h"
00052 #include "vtkObject.h"
00053 #include "vtkStructuredPoints.h"
00054
00055 class vtkRenderer;
00056 class vtkActor;
00057
00058 class VTK_RENDERING_EXPORT vtkProperty : public vtkObject
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkProperty,vtkObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00069   static vtkProperty *New();
00070
00072   void DeepCopy(vtkProperty *p);
00073
00079   virtual void Render(vtkActor *,vtkRenderer *) {};
00080
00086   virtual void BackfaceRender(vtkActor *,vtkRenderer *) {};
00087
00089
00090   vtkSetClampMacro(Interpolation,int,VTK_FLAT,VTK_PHONG);
00091   vtkGetMacro(Interpolation,int);
00092   void SetInterpolationToFlat() {this->SetInterpolation(VTK_FLAT);};
00093   void SetInterpolationToGouraud() {this->SetInterpolation(VTK_GOURAUD);};
00094   void SetInterpolationToPhong() {this->SetInterpolation(VTK_PHONG);};
00095   char *GetInterpolationAsString();
00097
00099
00100   vtkSetClampMacro(Representation,int,VTK_POINTS,VTK_SURFACE);
00101   vtkGetMacro(Representation,int);
00102   void SetRepresentationToPoints() {this->SetRepresentation(VTK_POINTS);};
00103   void SetRepresentationToWireframe() {
00104     this->SetRepresentation(VTK_WIREFRAME);};
00105   void SetRepresentationToSurface() {this->SetRepresentation(VTK_SURFACE);};
00106   char *GetRepresentationAsString();
00108
00110
00113   void SetColor(float r,float g,float b);
00114   void SetColor(float a[3]) { this->SetColor(a[0], a[1], a[2]); };
00115   float *GetColor();
00116   void GetColor(float rgb[3]);
00118
00120
00121   vtkSetClampMacro(Ambient,float,0.0,1.0);
00122   vtkGetMacro(Ambient,float);
00124
00126
00127   vtkSetClampMacro(Diffuse,float,0.0,1.0);
00128   vtkGetMacro(Diffuse,float);
00130
00132
00133   vtkSetClampMacro(Specular,float,0.0,1.0);
00134   vtkGetMacro(Specular,float);
00136
00138
00139   vtkSetClampMacro(SpecularPower,float,0.0,100.0);
00140   vtkGetMacro(SpecularPower,float);
00142
00144
00146   vtkSetClampMacro(Opacity,float,0.0,1.0);
00147   vtkGetMacro(Opacity,float);
00149
00151
00155   vtkSetVector3Macro(AmbientColor,float);
00156   vtkGetVectorMacro(AmbientColor,float,3);
00158
00160
00161   vtkSetVector3Macro(DiffuseColor,float);
00162   vtkGetVectorMacro(DiffuseColor,float,3);
00164
00166
00167   vtkSetVector3Macro(SpecularColor,float);
00168   vtkGetVectorMacro(SpecularColor,float,3);
00170
00172
00175   vtkGetMacro(EdgeVisibility,int);
00176   vtkSetMacro(EdgeVisibility,int);
00177   vtkBooleanMacro(EdgeVisibility,int);
00179
00181
00182   vtkSetVector3Macro(EdgeColor,float);
00183   vtkGetVectorMacro(EdgeColor,float,3);
00185
00187
00189   vtkSetClampMacro(LineWidth,float,0,VTK_LARGE_FLOAT);
00190   vtkGetMacro(LineWidth,float);
00192
00194
00197   vtkSetMacro(LineStipplePattern,int);
00198   vtkGetMacro(LineStipplePattern,int);
00200
00202
00205   vtkSetClampMacro(LineStippleRepeatFactor,int,1,VTK_LARGE_INTEGER);
00206   vtkGetMacro(LineStippleRepeatFactor,int);
00208
00210
00212   vtkSetClampMacro(PointSize,float,0,VTK_LARGE_FLOAT);
00213   vtkGetMacro(PointSize,float);
00215
00217
00220   vtkGetMacro(BackfaceCulling,int);
00221   vtkSetMacro(BackfaceCulling,int);
00222   vtkBooleanMacro(BackfaceCulling,int);
00224
00226
00229   vtkGetMacro(FrontfaceCulling,int);
00230   vtkSetMacro(FrontfaceCulling,int);
00231   vtkBooleanMacro(FrontfaceCulling,int);
00233
00234 protected:
00235   vtkProperty();
00236   ~vtkProperty() {};
00237
00238   float Color[3];
00239   float AmbientColor[3];
00240   float DiffuseColor[3];
00241   float SpecularColor[3];
00242   float EdgeColor[3];
00243   float Ambient;
00244   float Diffuse;
00245   float Specular;
00246   float SpecularPower;
00247   float Opacity;
00248   float PointSize;
00249   float LineWidth;
00250   int   LineStipplePattern;
00251   int   LineStippleRepeatFactor;
00252   int   Interpolation;
00253   int   Representation;
00254   int   EdgeVisibility;
00255   int   BackfaceCulling;
00256   int   FrontfaceCulling;
00257 private:
00258   vtkProperty(const vtkProperty&);  // Not implemented.
00259   void operator=(const vtkProperty&);  // Not implemented.
00260 };
00261
00263 inline char *vtkProperty::GetInterpolationAsString(void)
00264 {
00265   if ( this->Interpolation == VTK_FLAT )
00266     {
00267     return (char *)"Flat";
00268     }
00269   else if ( this->Interpolation == VTK_GOURAUD )
00270     {
00271     return (char *)"Gouraud";
00272     }
00273   else
00274     {
00275     return (char *)"Phong";
00276     }
00277 }
00278
00279
00281 inline char *vtkProperty::GetRepresentationAsString(void)
00282 {
00283   if ( this->Representation == VTK_POINTS )
00284     {
00285     return (char *)"Points";
00286     }
00287   else if ( this->Representation == VTK_WIREFRAME )
00288     {
00289     return (char *)"Wireframe";
00290     }
00291   else
00292     {
00293     return (char *)"Surface";
00294     }
00295 }
00296
00297
00298
00299 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkPropPicker.h Source File

Rendering/vtkPropPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPropPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkPropPicker_h
00045 #define __vtkPropPicker_h
00046
00047 #include "vtkAbstractPropPicker.h"
00048
00049 class vtkProp;
00050 class vtkWorldPointPicker;
00051
00052 class VTK_RENDERING_EXPORT vtkPropPicker : public vtkAbstractPropPicker
00053 {
00054 public:
00055   static vtkPropPicker *New();
00056
00057   vtkTypeRevisionMacro(vtkPropPicker,vtkAbstractPropPicker);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00064   int PickProp(float selectionX, float selectionY, vtkRenderer *renderer);
00065
00067
00069   int PickProp(float selectionX, float selectionY, vtkRenderer *renderer,
00070                vtkPropCollection* pickfrom);
00072
00074
00075   int Pick(float selectionX, float selectionY, float selectionZ,
00076            vtkRenderer *renderer);
00077   int Pick(float selectionPt[3], vtkRenderer *renderer)
00078     { return this->Pick( selectionPt[0],
00079                          selectionPt[1], selectionPt[2], renderer); };
00081
00082 protected:
00083   vtkPropPicker();
00084   ~vtkPropPicker();
00085
00086   void Initialize();
00087
00088   vtkPropCollection* PickFromProps;
00089
00090   // Used to get x-y-z pick position
00091   vtkWorldPointPicker *WorldPointPicker;
00092 private:
00093   vtkPropPicker(const vtkPropPicker&);  // Not implemented.
00094   void operator=(const vtkPropPicker&);  // Not implemented.
00095 };
00096
00097 #endif
00098
00099
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPSphereSource.h Source File

Parallel/vtkPSphereSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPSphereSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00030 #ifndef __vtkPSphereSource_h
00031 #define __vtkPSphereSource_h
00032
00033 #include "vtkSphereSource.h"
00034
00035 class VTK_PARALLEL_EXPORT vtkPSphereSource : public vtkSphereSource
00036 {
00037 public:
00038   vtkTypeRevisionMacro(vtkPSphereSource,vtkSphereSource);
00039
00043   static vtkPSphereSource *New();
00044
00046   unsigned long GetEstimatedMemorySize();
00047
00048 protected:
00049   vtkPSphereSource() {};
00050   ~vtkPSphereSource() {};
00051
00052   void Execute();
00053 private:
00054   vtkPSphereSource(const vtkPSphereSource&);  // Not implemented.
00055   void operator=(const vtkPSphereSource&);  // Not implemented.
00056 };
00057
00058 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkPVGeometryFilter.h Source File

Parallel/vtkPVGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPVGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkPVGeometryFilter_h
00034 #define __vtkPVGeometryFilter_h
00035
00036 #include "vtkDataSetSurfaceFilter.h"
00037 #include "vtkImageData.h"
00038 #include "vtkStructuredGrid.h"
00039 #include "vtkRectilinearGrid.h"
00040 #include "vtkUnstructuredGrid.h"
00041
00042 class VTK_PARALLEL_EXPORT vtkPVGeometryFilter : public vtkDataSetSurfaceFilter
00043 {
00044 public:
00045   static vtkPVGeometryFilter *New();
00046   vtkTypeRevisionMacro(vtkPVGeometryFilter,vtkDataSetSurfaceFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00052   vtkGetMacro(OutlineFlag, int);
00054
00055 protected:
00056   vtkPVGeometryFilter();
00057   ~vtkPVGeometryFilter();
00058   vtkPVGeometryFilter(const vtkPVGeometryFilter&) {};
00059   void operator=(const vtkPVGeometryFilter&) {};
00060
00061   void Execute();
00062   void ImageDataExecute(vtkImageData *input);
00063   void StructuredGridExecute(vtkStructuredGrid *input);
00064   void RectilinearGridExecute(vtkRectilinearGrid *input);
00065   void UnstructuredGridExecute(vtkUnstructuredGrid *input);
00066
00067   int OutlineFlag;
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPyramid.h Source File

Common/vtkPyramid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPyramid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkPyramid_h
00042 #define __vtkPyramid_h
00043
00044 #include "vtkCell3D.h"
00045 #include "vtkLine.h"
00046 #include "vtkTriangle.h"
00047 #include "vtkQuad.h"
00048
00049 class vtkUnstructuredGrid;
00050
00051 class VTK_COMMON_EXPORT vtkPyramid : public vtkCell3D
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkPyramid,vtkCell);
00055
00057   static vtkPyramid *New();
00058
00060
00061   virtual void GetEdgePoints(int edgeId, int* &pts);
00062   virtual void GetFacePoints(int faceId, int* &pts);
00064
00066
00067   vtkCell *MakeObject();
00068   int GetCellType() {return VTK_PYRAMID;}
00069   int GetCellDimension() {return 3;}
00070   int GetNumberOfEdges() {return 8;}
00071   int GetNumberOfFaces() {return 5;}
00072   vtkCell *GetEdge(int edgeId);
00073   vtkCell *GetFace(int faceId);
00074   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00075   void Contour(float value, vtkDataArray *cellScalars,
00076                vtkPointLocator *locator, vtkCellArray *verts,
00077                vtkCellArray *lines, vtkCellArray *polys,
00078                vtkPointData *inPd, vtkPointData *outPd,
00079                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00080   int EvaluatePosition(float x[3], float* closestPoint,
00081                        int& subId, float pcoords[3],
00082                        float& dist2, float *weights);
00083   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00084                         float *weights);
00085   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00086                         float x[3], float pcoords[3], int& subId);
00087   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00088   void Derivatives(int subId, float pcoords[3], float *values,
00089                    int dim, float *derivs);
00091
00093   int GetParametricCenter(float pcoords[3]);
00094
00096
00098   static void InterpolationFunctions(float pcoords[3], float weights[5]);
00099   static void InterpolationDerivs(float pcoords[3], float derivs[15]);
00100   int JacobianInverse(float pcoords[3], double **inverse, float derivs[15]);
00101   static int *GetEdgeArray(int edgeId);
00102   static int *GetFaceArray(int faceId);
00104
00105 protected:
00106   vtkPyramid();
00107   ~vtkPyramid();
00108
00109   vtkLine *Line;
00110   vtkTriangle *Triangle;
00111   vtkQuad *Quad;
00112
00113 private:
00114   vtkPyramid(const vtkPyramid&);  // Not implemented.
00115   void operator=(const vtkPyramid&);  // Not implemented.
00116 };
00117
00118 inline int vtkPyramid::GetParametricCenter(float pcoords[3])
00119 {
00120   pcoords[0] = pcoords[1] = 0.5;
00121   pcoords[2] = 0.333333;
00122   return 0;
00123 }
00124
00125 #endif
00126
00127
00128
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkPythonUtil.h Source File

Common/vtkPythonUtil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkPythonUtil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 #include "vtkObject.h"
00017 #include "vtkTimeStamp.h"
00018 #include "Python.h"
00019 #include "vtkCommand.h"
00020
00021 #if defined(WIN32)
00022 #if defined(vtkCommonPython_EXPORTS)
00023   #define VTK_PYTHON_EXPORT __declspec( dllexport )
00024 #else
00025     #define VTK_PYTHON_EXPORT __declspec( dllimport )
00026 #endif
00027 #else
00028   #define VTK_PYTHON_EXPORT
00029 #endif
00030
00031 // This is the VTK/Python 'class,' it contains the method list and a pointer
00032 // to the superclass
00033 typedef vtkObject *(*vtknewfunc)();
00034
00035 typedef struct {
00036   PyObject_HEAD
00037   // the first six are common to PyClassObject
00038   PyObject *vtk_bases;
00039   PyObject *vtk_dict;
00040   PyObject *vtk_name;
00041   PyObject *vtk_getattr;
00042   PyObject *vtk_setattr;
00043   PyObject *vtk_delattr;
00044   // these are unique to the PyVTKClass
00045   PyObject *vtk_module;
00046   PyObject *vtk_doc;
00047   PyMethodDef *vtk_methods;
00048   vtknewfunc vtk_new;
00049 } PyVTKClass;
00050
00051 // This is the VTK/Python 'object,' it contains the python object header
00052 // plus a pointer to the associated vtkObject and PyVTKClass.
00053 typedef struct {
00054   PyObject_HEAD
00055   // the first two are common with the PyInstanceObject
00056   PyVTKClass *vtk_class;
00057   PyObject *vtk_dict;
00058   // the rest are unique to the PyVTKObject
00059   vtkObject *vtk_ptr;
00060 } PyVTKObject;
00061
00062 // This for objects not derived from vtkObject
00063 typedef struct {
00064   PyObject_HEAD
00065   void *vtk_ptr;
00066   PyMethodDef *vtk_methods;
00067   PyObject *vtk_name;
00068   PyObject *vtk_doc;
00069 } PyVTKSpecialObject;
00070
00071 // Standard methods for all vtk/python objects
00072 extern "C"
00073 {
00074 VTK_PYTHON_EXPORT int PyVTKObject_Check(PyObject *obj);
00075 VTK_PYTHON_EXPORT int PyVTKClass_Check(PyObject *obj);
00076 VTK_PYTHON_EXPORT int PyVTKSpecialObjectCheck(PyObject *obj);
00077 VTK_PYTHON_EXPORT
00078 PyObject *PyVTKObject_New(PyObject *vtkclass, vtkObject *ptr);
00079 VTK_PYTHON_EXPORT
00080 PyObject *PyVTKClass_New(vtknewfunc constructor, PyMethodDef *methods,
00081                          char *classname, char *modulename, char *docstring[],
00082                          PyObject *base);
00083 VTK_PYTHON_EXPORT
00084 PyObject *PyVTKSpecialObject_New(void *ptr, PyMethodDef *methods,
00085                                  char *classname, char *docstring[]);
00086
00087 // this is a special version of ParseTuple that handles both bound
00088 // and unbound method calls for VTK objects
00089 VTK_PYTHON_EXPORT
00090 vtkObject *PyArg_VTKParseTuple(PyObject *self, PyObject *args,
00091                                char *format, ...);
00092 }
00093
00094 // Add a PyVTKClass to the type lookup table, this allows us to later
00095 // create object given only the class name.
00096 extern VTK_PYTHON_EXPORT
00097 void vtkPythonAddClassToHash(PyObject *obj, char *type);
00098
00099 // Extract the vtkObject from a PyVTKObject.  If the PyObject is not a
00100 // PyVTKObject, or is not a PyVTKObject of the specified type, the python
00101 // error indicator will be set.
00102 // Special behaviour: Py_None is converted to NULL without no error.
00103 extern VTK_PYTHON_EXPORT
00104 vtkObject *vtkPythonGetPointerFromObject(PyObject *obj, char *type);
00105
00106 // Convert a vtkObject to a PyVTKObject.  This will first check to see if
00107 // the PyVTKObject already exists, and create a new PyVTKObject if necessary.
00108 // This function also passes ownership of the reference to the PyObject.
00109 // Special behaviour: NULL is converted to Py_None.
00110 extern VTK_PYTHON_EXPORT
00111 PyObject *vtkPythonGetObjectFromPointer(vtkObject *ptr);
00112
00113 // Try to convert some PyObject into a PyVTKObject, currently conversion
00114 // is supported for SWIG-style mangled pointer strings.
00115 extern VTK_PYTHON_EXPORT
00116 PyObject *vtkPythonGetObjectFromObject(PyObject *arg, const char *type);
00117
00118 // Add and delete PyVTKObject/vtkObject pairs from the wrapper hash table,
00119 // these methods do not change the reference counts of either the vtkObject
00120 // or the PyVTKObject.
00121 extern VTK_PYTHON_EXPORT
00122 void vtkPythonAddObjectToHash(PyObject *obj, vtkObject *anInstance);
00123 extern VTK_PYTHON_EXPORT
00124 void vtkPythonDeleteObjectFromHash(PyObject *obj);
00125
00126 // Utility functions for creating/usinge SWIG-style mangled pointer strings.
00127 extern VTK_PYTHON_EXPORT
00128 char *vtkPythonManglePointer(void *ptr, const char *type);
00129 extern VTK_PYTHON_EXPORT
00130 void *vtkPythonUnmanglePointer(char *ptrText, int *len, const char *type);
00131
00132 // check array arguments sent through the wrappers to see if the underlying
00133 // C++ method changed the values, and attempt to modify the original python
00134 // sequence (list or tuple) if so.
00135 extern VTK_PYTHON_EXPORT
00136 int vtkPythonCheckArray(PyObject *args, int i, char *a, int n);
00137 extern VTK_PYTHON_EXPORT
00138 int vtkPythonCheckArray(PyObject *args, int i, unsigned char *a, int n);
00139 extern VTK_PYTHON_EXPORT
00140 int vtkPythonCheckArray(PyObject *args, int i, short *a, int n);
00141 extern VTK_PYTHON_EXPORT
00142 int vtkPythonCheckArray(PyObject *args, int i, unsigned short *a, int n);
00143 extern VTK_PYTHON_EXPORT
00144 int vtkPythonCheckArray(PyObject *args, int i, int *a, int n);
00145 extern VTK_PYTHON_EXPORT
00146 int vtkPythonCheckArray(PyObject *args, int i, unsigned int *a, int n);
00147 extern VTK_PYTHON_EXPORT
00148 int vtkPythonCheckArray(PyObject *args, int i, long *a, int n);
00149 extern VTK_PYTHON_EXPORT
00150 int vtkPythonCheckArray(PyObject *args, int i, unsigned long *a, int n);
00151 extern VTK_PYTHON_EXPORT
00152 int vtkPythonCheckArray(PyObject *args, int i, float *a, int n);
00153 extern VTK_PYTHON_EXPORT
00154 int vtkPythonCheckArray(PyObject *args, int i, double *a, int n);
00155
00156 // For use by SetXXMethod() , SetXXMethodArgDelete()
00157 extern VTK_PYTHON_EXPORT void vtkPythonVoidFunc(void *);
00158 extern VTK_PYTHON_EXPORT void vtkPythonVoidFuncArgDelete(void *);
00159
00160 // To allow Python to use the vtkCommand features
00161 class vtkPythonCommand : public vtkCommand
00162 {
00163 public:
00164   static vtkPythonCommand *New() { return new vtkPythonCommand; };
00165
00166   void SetObject(PyObject *o);
00167   void Execute(vtkObject *ptr, unsigned long eventtype, void *);
00168
00169   PyObject *obj;
00170 protected:
00171   vtkPythonCommand();
00172   ~vtkPythonCommand();
00173 };
00174
00175
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkQuad.h Source File

Common/vtkQuad.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuad.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkQuad_h
00043 #define __vtkQuad_h
00044
00045 #include "vtkCell.h"
00046 #include "vtkLine.h"
00047
00048 class VTK_COMMON_EXPORT vtkQuad : public vtkCell
00049 {
00050 public:
00051   static vtkQuad *New();
00052   vtkTypeRevisionMacro(vtkQuad,vtkCell);
00053
00055
00056   vtkCell *MakeObject();
00057   int GetCellType() {return VTK_QUAD;};
00058   int GetCellDimension() {return 2;};
00059   int GetNumberOfEdges() {return 4;};
00060   int GetNumberOfFaces() {return 0;};
00061   vtkCell *GetEdge(int edgeId);
00062   vtkCell *GetFace(int) {return 0;};
00063   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00064   void Contour(float value, vtkDataArray *cellScalars,
00065                vtkPointLocator *locator, vtkCellArray *verts,
00066                vtkCellArray *lines, vtkCellArray *polys,
00067                vtkPointData *inPd, vtkPointData *outPd,
00068                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00069   int EvaluatePosition(float x[3], float* closestPoint,
00070                        int& subId, float pcoords[3],
00071                        float& dist2, float *weights);
00072   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00073                         float *weights);
00074   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00075                         float x[3], float pcoords[3], int& subId);
00076   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00077   void Derivatives(int subId, float pcoords[3], float *values,
00078                    int dim, float *derivs);
00080
00082
00084   void Clip(float value, vtkDataArray *cellScalars,
00085             vtkPointLocator *locator, vtkCellArray *polys,
00086             vtkPointData *inPd, vtkPointData *outPd,
00087             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00088             int insideOut);
00090
00092
00093   static void InterpolationFunctions(float pcoords[3], float sf[4]);
00094   static void InterpolationDerivs(float pcoords[3], float derivs[8]);
00096
00097
00098 protected:
00099   vtkQuad();
00100   ~vtkQuad();
00101
00102   vtkLine *Line;
00103
00104 private:
00105   vtkQuad(const vtkQuad&);  // Not implemented.
00106   void operator=(const vtkQuad&);  // Not implemented.
00107 };
00108
00109 #endif
00110
00111
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkQuadraticEdge.h Source File

Common/vtkQuadraticEdge.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuadraticEdge.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkQuadraticEdge_h
00037 #define __vtkQuadraticEdge_h
00038
00039 #include "vtkNonLinearCell.h"
00040
00041 class vtkPolyData;
00042
00043 class VTK_COMMON_EXPORT vtkQuadraticEdge : public vtkNonLinearCell
00044 {
00045 public:
00046   static vtkQuadraticEdge *New();
00047   vtkTypeRevisionMacro(vtkQuadraticEdge,vtkNonLinearCell);
00048
00050
00052   vtkCell *MakeObject();
00053   int GetCellType() {return VTK_LINE;};
00054   int GetCellDimension() {return 1;}
00055   int GetNumberOfEdges() {return 0;}
00056   int GetNumberOfFaces() {return 0;}
00057   vtkCell *GetEdge(int) {return 0;}
00058   vtkCell *GetFace(int) {return 0;}
00060
00061   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00062   void Contour(float value, vtkDataArray *cellScalars,
00063                vtkPointLocator *locator, vtkCellArray *verts,
00064                vtkCellArray *lines, vtkCellArray *polys,
00065                vtkPointData *inPd, vtkPointData *outPd,
00066                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00067   int EvaluatePosition(float x[3], float* closestPoint,
00068                        int& subId, float pcoords[3],
00069                        float& dist2, float *weights);
00070   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00071                         float *weights);
00072   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00073   void Derivatives(int subId, float pcoords[3], float *values,
00074                    int dim, float *derivs);
00075
00077
00079   void Clip(float value, vtkDataArray *cellScalars,
00080             vtkPointLocator *locator, vtkCellArray *lines,
00081             vtkPointData *inPd, vtkPointData *outPd,
00082             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00083             int insideOut);
00085
00087
00089   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00090                         float x[3], float pcoords[3], int& subId);
00092
00094
00097   virtual void Tesselate(vtkIdType cellId,
00098                          vtkDataSet *input, vtkPolyData *output,
00099                          vtkPointLocator *locator=NULL);
00100   virtual void Tesselate(vtkIdType vtkNotUsed(cellId),
00101                          vtkDataSet* vtkNotUsed(input),
00102                          vtkUnstructuredGrid* vtkNotUsed(output),
00103                          vtkPointLocator* locator=NULL );
00105
00106
00108
00109   static void InterpolationFunctions(float pcoords[3], float weights[3]);
00110   static void InterpolationDerivs(float pcoords[3], float derivs[3]);
00112
00113 protected:
00114   vtkQuadraticEdge();
00115   ~vtkQuadraticEdge();
00116
00117   vtkPolyData *Tesselation;
00118   vtkPolyData *InternalDataSet; //used for internal tesselation
00119
00120   void InternalTesselate(); //used internally to tessellate this cell.
00121
00122 private:
00123   vtkQuadraticEdge(const vtkQuadraticEdge&);  // Not implemented.
00124   void operator=(const vtkQuadraticEdge&);  // Not implemented.
00125 };
00126
00127 #endif
00128
00129
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkQuadric.h Source File

Common/vtkQuadric.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuadric.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkQuadric_h
00040 #define __vtkQuadric_h
00041
00042 #include "vtkImplicitFunction.h"
00043
00044 class VTK_COMMON_EXPORT vtkQuadric : public vtkImplicitFunction
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkQuadric,vtkImplicitFunction);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051   static vtkQuadric *New();
00052
00054
00055   float EvaluateFunction(float x[3]);
00056   float EvaluateFunction(float x, float y, float z)
00057     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00059
00061   void EvaluateGradient(float x[3], float g[3]);
00062
00064
00065   void SetCoefficients(float a[10]);
00066   void SetCoefficients(float a0, float a1, float a2, float a3, float a4,
00067                        float a5, float a6, float a7, float a8, float a9);
00068   vtkGetVectorMacro(Coefficients,float,10);
00070
00071 protected:
00072   vtkQuadric();
00073   ~vtkQuadric() {};
00074
00075   float Coefficients[10];
00076
00077 private:
00078   vtkQuadric(const vtkQuadric&);  // Not implemented.
00079   void operator=(const vtkQuadric&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkQuadricClustering.h Source File

Graphics/vtkQuadricClustering.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuadricClustering.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00078 #ifndef __vtkQuadricClustering_h
00079 #define __vtkQuadricClustering_h
00080
00081 #include "vtkPolyDataToPolyDataFilter.h"
00082 #include "vtkDataSetCollection.h"
00083
00084 class vtkFeatureEdges;
00085
00086 typedef struct {
00087   vtkIdType VertexId;
00088   // Dimension is supposed to be a flag representing the dimension of the cells
00089   // contributing to the quadric. Lines: 1, Triangles: 2 (and points 0 in the future?)
00090   unsigned char Dimension;
00091   float Quadric[9];
00092 } VTK_POINT_QUADRIC;
00093
00094 class VTK_GRAPHICS_EXPORT vtkQuadricClustering : public vtkPolyDataToPolyDataFilter
00095 {
00096 public:
00097   vtkTypeRevisionMacro(vtkQuadricClustering, vtkPolyDataToPolyDataFilter);
00098   void PrintSelf(ostream& os, vtkIndent indent);
00099   static vtkQuadricClustering *New();
00100
00102
00106   vtkSetMacro(UseFeatureEdges, int);
00107   vtkGetMacro(UseFeatureEdges, int);
00108   vtkBooleanMacro(UseFeatureEdges, int);
00109   vtkFeatureEdges *GetFeatureEdges() {return this->FeatureEdges;}
00111
00113
00118   vtkSetMacro(UseFeaturePoints, int);
00119   vtkGetMacro(UseFeaturePoints, int);
00120   vtkBooleanMacro(UseFeaturePoints, int);
00122
00124
00126   vtkSetClampMacro(FeaturePointsAngle, float, 0.0, 180.0);
00127   vtkGetMacro(FeaturePointsAngle, float);
00129
00131
00134   void SetNumberOfXDivisions(int num);
00135   void SetNumberOfYDivisions(int num);
00136   void SetNumberOfZDivisions(int num);
00137   vtkGetMacro(NumberOfXDivisions, int);
00138   vtkGetMacro(NumberOfYDivisions, int);
00139   vtkGetMacro(NumberOfZDivisions, int);
00140   void SetNumberOfDivisions(int div[3]);
00141   int *GetNumberOfDivisions();
00142   void GetNumberOfDivisions(int div[3]);
00144
00146
00149   void SetDivisionOrigin(float x, float y, float z);
00150   void SetDivisionOrigin(float o[3]) {this->SetDivisionOrigin(o[0],o[1],o[2]);}
00151   vtkGetVector3Macro(DivisionOrigin, float);
00152   void SetDivisionSpacing(float x, float y, float z);
00153   void SetDivisionSpacing(float s[3]) {this->SetDivisionSpacing(s[0],s[1],s[2]);}
00154   vtkGetVector3Macro(DivisionSpacing, float);
00156
00158
00162   vtkSetMacro(UseInternalTriangles, int);
00163   vtkGetMacro(UseInternalTriangles, int);
00164   vtkBooleanMacro(UseInternalTriangles, int);
00166
00168
00173   vtkSetMacro(UseInputPoints, int);
00174   vtkGetMacro(UseInputPoints, int);
00175   vtkBooleanMacro(UseInputPoints, int);
00177
00179
00183   void StartAppend(float *bounds);
00184   void StartAppend(float x0,float x1,float y0,float y1,float z0,float z1)
00185     {float b[6]; b[0]=x0; b[1]=x1; b[2]=y0; b[3]=y1; b[4]=z0; b[5]=z1;
00186     this->StartAppend(b);}
00187   void Append(vtkPolyData *piece);
00188   void EndAppend();
00190
00192
00196   vtkSetMacro(CopyCellData, int);
00197   vtkGetMacro(CopyCellData, int);
00198   vtkBooleanMacro(CopyCellData, int);
00200
00203 protected:
00204   vtkQuadricClustering();
00205   ~vtkQuadricClustering();
00206
00207   void Execute();
00208
00210   vtkIdType HashPoint(float point[3]);
00211
00213
00214   void ComputeRepresentativePoint(float quadric[9], vtkIdType binId,
00215                                   float point[3]);
00217
00219
00221   void AddTriangles(vtkCellArray *tris, vtkPoints *points,
00222                     int geometryFlag);
00223   void AddPolygons(vtkCellArray *polys, vtkPoints *points,
00224                    int geometryFlag);
00225   void AddTriangle(vtkIdType *binIds, float *pt0, float *pt1, float *pt2,
00226                    int geometeryFlag);
00228
00230
00232   void AddEdges(vtkCellArray *edges, vtkPoints *points,
00233                 int geometryFlag);
00234   void AddEdge(vtkIdType *binIds, float *pt0, float *pt1, int geometeryFlag);
00236
00238
00240   void AddVertices(vtkCellArray *verts, vtkPoints *points, int geometryFlag);
00241   void AddVertex(vtkIdType binId, float *pt, int geometryFlag);
00243
00245   void InitializeQuadric(float quadric[9]);
00246
00248   void AddQuadric(vtkIdType binId, float quadric[9]);
00249
00254   void FindFeaturePoints(vtkCellArray *edges, vtkPoints *edgePts, float angle);
00255
00257
00259   void EndAppendUsingPoints(vtkPolyData *input);
00260   int UseInputPoints;
00262
00265   void EndAppendVertexGeometry(vtkPolyData *input);
00266
00267   // Unfinished option to handle boundary edges differently.
00268   void AppendFeatureQuadrics(vtkPolyData *pd);
00269   int UseFeatureEdges;
00270   int UseFeaturePoints;
00271   int UseInternalTriangles;
00272
00273   int NumberOfXDivisions;
00274   int NumberOfYDivisions;
00275   int NumberOfZDivisions;
00276
00277   // Since there are two was of specifing the grid, we have this flag
00278   // to indicate which the user has set.  When this flag is on,
00279   // the bin sizes are computed from the DivisionOrigin and DivisionSpacing.
00280   int ComputeNumberOfDivisions;
00281
00282   float DivisionOrigin[3];
00283   float DivisionSpacing[3];
00284
00285   float Bounds[6];
00286   float XBinSize;
00287   float YBinSize;
00288   float ZBinSize;
00289   VTK_POINT_QUADRIC* QuadricArray;
00290   vtkIdType NumberOfBinsUsed;
00291
00292   // Have to make these instance variables if we are going to allow
00293   // the algorithm to be driven by the Append methods.
00294   vtkCellArray *OutputTriangleArray;
00295   vtkCellArray *OutputLines;
00296
00297   vtkFeatureEdges *FeatureEdges;
00298   vtkPoints *FeaturePoints;
00299   float FeaturePointsAngle;
00300
00301   int CopyCellData;
00302   int InCellCount;
00303   int OutCellCount;
00304 private:
00305   vtkQuadricClustering(const vtkQuadricClustering&);  // Not implemented.
00306   void operator=(const vtkQuadricClustering&);  // Not implemented.
00307 };
00308
00309 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkQuadricDecimation.h Source File

Graphics/vtkQuadricDecimation.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuadricDecimation.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkQuadricDecimation_h
00044 #define __vtkQuadricDecimation_h
00045
00046 #include "vtkPolyDataToPolyDataFilter.h"
00047 #include "vtkEdgeTable.h"
00048 #include "vtkPriorityQueue.h"
00049 #include "vtkIdList.h"
00050
00051 typedef struct {
00052   float *Quadric;
00053 } VTK_ERROR_QUADRIC;
00054
00055 class VTK_GRAPHICS_EXPORT vtkQuadricDecimation : public vtkPolyDataToPolyDataFilter
00056 {
00057 public:
00058   vtkTypeRevisionMacro(vtkQuadricDecimation, vtkPolyDataToPolyDataFilter);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00061   static vtkQuadricDecimation *New();
00062
00064
00065   vtkSetMacro(MaximumCost, float);
00066   vtkGetMacro(MaximumCost, float);
00068
00070
00071   vtkSetMacro(MaximumCollapsedEdges, int);
00072   vtkGetMacro(MaximumCollapsedEdges, int);
00074
00076   vtkPolyData *GetTestOutput() {return this->GetOutput(1);}
00077
00078 protected:
00079   vtkQuadricDecimation();
00080   ~vtkQuadricDecimation();
00081
00082   void Execute();
00083
00085   void ComputeQuadric(vtkIdType pointId);
00086
00089   void AddQuadric(vtkIdType oldPtId, vtkIdType newPtId);
00090
00093   float ComputeCost(vtkIdType edgeId, float x[3], vtkPointData *pd);
00094
00098   void FindAffectedEdges(vtkIdType p1Id, vtkIdType p2Id, vtkIdList *edges);
00099
00101   vtkIdType GetEdgeCellId(vtkIdType p1Id, vtkIdType p2Id);
00102
00105   void GetAttributeComponents();
00106
00107   float MaximumCost;
00108   int MaximumCollapsedEdges;
00109   int NumberOfCollapsedEdges;
00110   vtkEdgeTable *Edges;
00111   vtkIdList *EndPoint1List;
00112   vtkIdList *EndPoint2List;
00113   vtkPriorityQueue *EdgeCosts;
00114   VTK_ERROR_QUADRIC *ErrorQuadrics;
00115   int AttributeComponents[6];
00116   int NumberOfComponents;
00117   vtkPolyData *Mesh;
00118 private:
00119   vtkQuadricDecimation(const vtkQuadricDecimation&);  // Not implemented.
00120   void operator=(const vtkQuadricDecimation&);  // Not implemented.
00121 };
00122
00123 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkQuantizePolyDataPoints.h Source File

Graphics/vtkQuantizePolyDataPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuantizePolyDataPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkQuantizePolyDataPoints_h
00048 #define __vtkQuantizePolyDataPoints_h
00049
00050 #include "vtkCleanPolyData.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkQuantizePolyDataPoints : public vtkCleanPolyData
00053 {
00054 public:
00055   static vtkQuantizePolyDataPoints *New();
00056   vtkTypeRevisionMacro(vtkQuantizePolyDataPoints,vtkCleanPolyData);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00061   vtkSetClampMacro(QFactor,float,1E-5,VTK_LARGE_FLOAT);
00062   vtkGetMacro(QFactor,float);
00064
00066   virtual void OperateOnPoint(float in[3], float out[3]);
00067
00069   virtual void OperateOnBounds(float in[6], float out[6]);
00070
00071 protected:
00072   vtkQuantizePolyDataPoints();
00073   ~vtkQuantizePolyDataPoints() {};
00074
00075   float QFactor;
00076 private:
00077   vtkQuantizePolyDataPoints(const vtkQuantizePolyDataPoints&);  // Not implemented.
00078   void operator=(const vtkQuantizePolyDataPoints&);  // Not implemented.
00079 };
00080
00081 #endif
00082
00083
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzGLView.h Source File

Rendering/vtkQuartzGLView.h

Go to the documentation of this file.
00001 #import <Cocoa/Cocoa.h>
00002 #import <OpenGL/gl.h>
00003 #define id Id
00004 #import "vtkQuartzRenderWindow.h"
00005 #import "vtkQuartzRenderWindowInteractor.h"
00006 #include "vtkInteractorStyle.h"
00007 #undef id
00008
00009 @interface vtkQuartzGLView : NSOpenGLView
00010 {
00011     enum NSOpenGLPixelFormatAttribute bitsPerPixel, depthSize;
00012
00013     @private
00014     vtkQuartzRenderWindow *myVTKRenderWindow;
00015     vtkQuartzRenderWindowInteractor *myVTKRenderWindowInteractor;
00016 }
00017
00018 // Overrides
00019 - (void) drawRect:(NSRect)theRect;
00020 - (id)initWithFrame:(NSRect)theFrame;
00021
00022 - (vtkQuartzRenderWindow *)getVTKRenderWindow;
00023 - (void)setVTKRenderWindow:(vtkQuartzRenderWindow *)theVTKRenderWindow;
00024
00025 - (vtkQuartzRenderWindowInteractor *)getVTKRenderWindowInteractor;
00026 - (void)setVTKRenderWindowInteractor:(vtkQuartzRenderWindowInteractor *)theVTKRenderWindowInteractor;
00027
00028
00029 @end
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzImageMapper.h Source File

Rendering/vtkQuartzImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuartzImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkQuartzImageMapper_h
00036 #define __vtkQuartzImageMapper_h
00037
00038
00039 #include "vtkImageMapper.h"
00040 class vtkImageActor2D;
00041
00042
00043 class VTK_RENDERING_EXPORT vtkQuartzImageMapper : public vtkImageMapper
00044 {
00045 public:
00046   static vtkQuartzImageMapper *New();
00047   vtkTypeRevisionMacro(vtkQuartzImageMapper,vtkImageMapper);
00048
00050
00051   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor) {
00052     this->RenderStart(viewport,actor);}
00054
00056
00058   void RenderData(vtkViewport* viewport, vtkImageData* data,
00059                   vtkActor2D* actor);
00061
00062   unsigned char *DataOut;       // the data in the DIBSection
00063   void *HBitmap;                        // our handle to the DIBSection
00064
00065 protected:
00066   vtkQuartzImageMapper();
00067   ~vtkQuartzImageMapper();
00068
00069 private:
00070   vtkQuartzImageMapper(const vtkQuartzImageMapper&) {};  // Not implemented.
00071   void operator=(const vtkQuartzImageMapper&) {};  // Not implemented.
00072 };
00073
00074
00075 #endif
00076
00077
00078
00079
00080
00081
00082
00083
00084
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzImageWindow.h Source File

Rendering/vtkQuartzImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuartzImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkQuartzImageWindow_h
00034 #define __vtkQuartzImageWindow_h
00035
00036 #include <stdlib.h>
00037 #include "vtkImageWindow.h"
00038 #include "vtkMutexLock.h"
00039
00040 class VTK_RENDERING_EXPORT vtkQuartzImageWindow : public vtkImageWindow
00041 {
00042 public:
00043   static vtkQuartzImageWindow *New();
00044   vtkTypeRevisionMacro(vtkQuartzImageWindow,vtkImageWindow);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00047   // output to the viewer.
00048   vtkQuartzImageWindow *GetOutput(){return this;};
00049
00051   virtual void MakeDefaultWindow();
00052
00054   void SwapBuffers();
00055
00057   void Frame();
00058
00060   void Render();
00061
00063   virtual void SetSize(int,int);
00064
00066   virtual int *GetSize();
00067
00069   virtual void SetPosition(int,int);
00070
00072   virtual int *GetPosition();
00073
00076   virtual void SetWindowName(char *);
00077
00078   //BTX
00079   virtual void *GetGenericDisplayId() {return (void *)this->ContextId;};
00080   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00081   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00082   virtual void *GetGenericContext()   {return (void *)this->DeviceContext;};
00083   virtual void SetDisplayId(void *) {};
00084
00086   virtual void *GetWindowId();
00087
00089   virtual void  SetWindowId(void *);
00090
00092   virtual void  SetParentId(void *);
00093
00094   void  SetContextId(void *);   // hsr
00095   void  SetDeviceContext(void *);       // hsr
00096
00098
00099   virtual void  SetNextWindowId(void *);
00100   //ETX
00102
00104   /*! Set/Get the pixel data of an image, transmitted as RGBRGB... */
00105   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00106   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00107                             int front);
00109
00111
00112   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00113   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00114                                 int blend=0);
00115   virtual void ReleaseRGBAPixelData(float *data);
00117
00119   void MakeCurrent();
00120
00122
00124   void SetupMemoryRendering(int x, int y, void *prn);
00125   void ResumeScreenRendering();
00126   void *GetMemoryDC();
00127   unsigned char *GetMemoryData(){return this->MemoryData;};
00129
00131
00132   virtual void OpenGLInit();
00133   virtual void SetupPalette(void *hDC);
00134   virtual void SetupPixelFormat(void *hDC, int dwFlags, int debug,
00135                                 int bpp=16, int zbpp=16);
00137
00139   void Clean();
00140
00141 protected:
00142   vtkQuartzImageWindow();
00143   ~vtkQuartzImageWindow();
00144
00145   void      *ApplicationInstance;
00146   void      *Palette;
00147   void      *OldPalette;
00148   void      *ContextId;
00149   void      *DeviceContext;
00150   void      *WindowId;
00151   void      *ParentId;
00152   void      *NextWindowId;
00153   int       OwnWindow;
00154   int       ScreenSize[2];
00155
00156   // the following is used to support rendering into memory
00157   void *MemoryDataHeader;
00158   void *MemoryBuffer;
00159   unsigned char *MemoryData;    // the data in the DIBSection
00160   void *MemoryHdc;
00161
00162   int ScreenMapped;
00163   int ScreenWindowSize[2];
00164   void *ScreenDeviceContext;
00165   int ScreenDoubleBuffer;
00166   void *ScreenContextId;
00167
00168 private:
00169   vtkQuartzImageWindow(const vtkQuartzImageWindow&) {};  // Not implemented.
00170   void operator=(const vtkQuartzImageWindow&) {};  // Not implemented.
00171 };
00172
00173
00174 #endif
00175
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzRenderWindow.h Source File

Rendering/vtkQuartzRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuartzRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkQuartzRenderWindow_h
00034 #define __vtkQuartzRenderWindow_h
00035
00036 #include <stdlib.h>
00037 #include "vtkRenderWindow.h"
00038 #include "vtkMutexLock.h"
00039 #include <OpenGL/gl.h>
00040 #endif
00041
00042 class vtkIdList;
00043
00044 class VTK_RENDERING_EXPORT vtkQuartzRenderWindow : public vtkRenderWindow
00045 {
00046 public:
00047   static vtkQuartzRenderWindow *New();
00048   vtkTypeRevisionMacro(vtkQuartzRenderWindow,vtkRenderWindow);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052   void Start(void);
00053
00055   void Frame(void);
00056
00058   virtual void WindowConfigure(void);
00059
00061   virtual void WindowInitialize(void);
00062
00064   virtual void Initialize(void);
00065
00067   virtual void SetFullScreen(int);
00068
00070   virtual void WindowRemap(void);
00071
00073   virtual void PrefFullScreen(void);
00074
00076   virtual void SetSize(int,int);
00077
00079   virtual int *GetSize();
00080
00082   virtual void SetPosition(int,int);
00083
00085   virtual int *GetScreenSize();
00086
00088   virtual int *GetPosition();
00089
00092   virtual void SetWindowName(char *);
00093
00095   void SetWindowInfo(void *);
00096
00097   //BTX
00098   virtual void *GetGenericDisplayId() {return (void *)this->ContextId;};
00099   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00100   virtual void *GetGenericContext()   {return (void *)this->DeviceContext;};
00101   virtual void SetDisplayId(void *) {};
00102
00104   virtual void *GetWindowId();
00105
00107   virtual void  SetWindowId(void *);
00108
00109   void  SetContextId(void *);   // hsr
00110   void  SetDeviceContext(void *);       // hsr
00111
00112   //ETX
00113
00114   // supply base class virtual function
00115   vtkSetMacro(MultiSamples,int);
00116   vtkGetMacro(MultiSamples,int);
00117
00119   virtual void StereoUpdate();
00120
00125   virtual void SetStereoCapableWindow(int capable);
00126
00128
00129   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00130   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00131                             int front);
00133
00135
00136   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00137   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00138                                 int blend=0);
00139   virtual void ReleaseRGBAPixelData(float *data);
00141
00143
00144   virtual float *GetZbufferData( int x1, int y1, int x2, int y2 );
00145   virtual void SetZbufferData( int x1, int y1, int x2, int y2, float *buffer );
00147
00149   void MakeCurrent();
00150
00153   virtual  int GetEventPending();
00154
00162   virtual void OpenGLInit();
00163   virtual void SetupPalette(void *hDC);
00164   virtual void SetupPixelFormat(void *hDC, void *dwFlags, int debug,
00165                                 int bpp=16, int zbpp=16);
00167
00169   void Clean();
00170
00172   void RegisterTextureResource (GLuint id);
00173
00175   int GetDepthBufferSize();
00176
00178
00180   void HideCursor();
00181   void ShowCursor();
00183
00184   void UpdateSizeAndPosition(int xPos, int yPos, int xSize, int ySize);
00185
00186
00187 protected:
00188   vtkQuartzRenderWindow();
00189   ~vtkQuartzRenderWindow();
00190
00191   int       ApplicationInitialized; //NSApplication called?
00192   void     *ContextId;
00193   void     *DeviceContext;
00194   void     *WindowId;
00195   void     *WindowController;
00196   int       OwnWindow;
00197   int       ScreenSize[2];
00198   int       MultiSamples;
00199   vtkIdList *TextureResourceIds;
00200
00201   // the following is used to support rendering into memory
00202 //  void *MemoryDataHeader;
00203 //  void *MemoryBuffer;
00204 //  unsigned char *MemoryData;  // the data in the DIBSection
00205 //  void *MemoryHdc;
00206
00207   int ScreenMapped;
00208   int ScreenWindowSize[2];
00209   void *ScreenDeviceContext;
00210   int ScreenDoubleBuffer;
00211   void *ScreenContextId;
00212
00213   int CursorHidden;
00214
00215 private:
00216   vtkQuartzRenderWindow(const vtkQuartzRenderWindow&);  // Not implemented.
00217   void operator=(const vtkQuartzRenderWindow&);  // Not implemented.
00218 };
00219
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzRenderWindowInteractor.h Source File

Rendering/vtkQuartzRenderWindowInteractor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuartzRenderWindowInteractor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkQuartzRenderWindowInteractor_h
00040 #define __vtkQuartzRenderWindowInteractor_h
00041
00042 #include <stdlib.h>
00043 #include "vtkRenderWindowInteractor.h"
00044
00045
00046 #ifdef __cplusplus
00047 extern "C" {
00048 #endif
00049
00050 //int DrawSomeGL();
00051 //void VBTimerEvent(void *vtkClass);
00052 //void DoMouseMoved(void *vtkClass, int shiftDown, int controlDown, int altDown, int commandDown, float xLoc, float yLoc);
00053 //void DoMouseDragged(void *vtkClass, int shiftDown, int controlDown, int altDown, int commandDown, float xLoc, float yLoc);
00054 //void DoMouseUp(void *vtkClass, int shiftDown, int controlDown, int altDown, int commandDown, float xLoc, float yLoc);
00055 //void DoMouseDown(void *vtkClass, int shiftDown, int controlDown, int altDown, int commandDown, float xLoc, float yLoc);
00056
00057 #ifdef __cplusplus
00058 };
00059 #endif
00060
00061
00062
00063 class VTK_RENDERING_EXPORT vtkQuartzRenderWindowInteractor : public vtkRenderWindowInteractor {
00064 public:
00066   static vtkQuartzRenderWindowInteractor *New();
00067
00068   vtkTypeRevisionMacro(vtkQuartzRenderWindowInteractor,vtkRenderWindowInteractor);
00069   void PrintSelf(ostream& os, vtkIndent indent);
00070
00072   virtual void Initialize();
00073
00075
00082   virtual void Enable();
00083   virtual void Disable();
00085
00089   virtual void Start();
00090
00092
00097   vtkSetMacro(InstallMessageProc,int);
00098   vtkGetMacro(InstallMessageProc,int);
00099   vtkBooleanMacro(InstallMessageProc,int);
00101
00106   void TerminateApp(void);
00107
00109
00110   int CreateTimer(int timertype);
00111   int DestroyTimer(void);
00113
00114   //BTX
00116   /*! Various methods that a Quartz window can redirect to this class to be
00117       handled. virtual void OnMouseMove  (void *wnd, int nFlags, int X, int
00118       Y); */
00119   virtual void OnRButtonDown(void *wnd, int nFlags, int X, int Y);
00120   virtual void OnRButtonUp  (void *wnd, int nFlags, int X, int Y);
00121   virtual void OnMButtonDown(void *wnd, int nFlags, int X, int Y);
00122   virtual void OnMButtonUp  (void *wnd, int nFlags, int X, int Y);
00123   virtual void OnLButtonDown(void *wnd, int nFlags, int X, int Y);
00124   virtual void OnLButtonUp  (void *wnd, int nFlags, int X, int Y);
00125   virtual void OnSize       (void *wnd, int nType,  int X, int Y);
00126   virtual void OnTimer      (void *wnd, int nIDEvent);
00127   virtual void OnChar       (void *wnd, int nChar, int nRepCnt, int nFlags);
00128   //ETX
00130
00132   /*! Methods to set the default exit method for the class. This method is
00133       only used if no instance level ExitMethod has been defined.  It is
00134       provided as a means to control how an interactor is exited given the
00135       various language bindings (tcl, Quartz, etc.). */
00136   static void SetClassExitMethod(void (*f)(void *), void *arg);
00137   static void SetClassExitMethodArgDelete(void (*f)(void *));
00139
00142   virtual void ExitCallback();
00143
00144   int GetButtonDown();
00145   void SetButtonDown(int button);
00146
00147 protected:
00148   vtkQuartzRenderWindowInteractor();
00149   ~vtkQuartzRenderWindowInteractor();
00150
00151   void   *WindowId;
00152   void   *ApplicationId;
00153   int     TimerId;
00154   void   *OldProc;
00155   int     InstallMessageProc;
00156   int   whichButtonDown; //0=none, 1=left, 2=middle, 3=right
00157
00158   //BTX
00160   /*! Class variables so an exit method can be defined for this class (used
00161       to set different exit methods for various language bindings, i.e.
00162       tcl, java, Quartz) */
00163   static void (*ClassExitMethod)(void *);
00164   static void (*ClassExitMethodArgDelete)(void *);
00165   static void *ClassExitMethodArg;
00166   //ETX
00168
00169 private:
00170   vtkQuartzRenderWindowInteractor(const vtkQuartzRenderWindowInteractor&);  // Not implemented.
00171   void operator=(const vtkQuartzRenderWindowInteractor&);  // Not implemented.
00172 };
00173
00174 #endif
00175
00176
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzTextMapper.h Source File

Rendering/vtkQuartzTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkQuartzTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkQuartzTextMapper_h
00037 #define __vtkQuartzTextMapper_h
00038
00039 #include "vtkTextMapper.h"
00040
00041 class VTK_RENDERING_EXPORT vtkQuartzTextMapper : public vtkTextMapper
00042 {
00043 public:
00044   vtkTypeRevisionMacro(vtkQuartzTextMapper,vtkTextMapper);
00045   static vtkQuartzTextMapper *New();
00046
00048   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor);
00049
00051   void GetSize(vtkViewport* viewport, int size[2]);
00052
00053 protected:
00054   vtkQuartzTextMapper();
00055   ~vtkQuartzTextMapper();
00056
00057   vtkTimeStamp  BuildTime;
00058   int LastSize[2];
00059   void *Font;
00060 private:
00061   vtkQuartzTextMapper(const vtkQuartzTextMapper&) {};  // Not implemented.
00062   void operator=(const vtkQuartzTextMapper&) {};  // Not implemented.
00063 };
00064
00065
00066 #endif
00067
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkQuartzWindow.h Source File

Rendering/vtkQuartzWindow.h

Go to the documentation of this file.
00001 #import <Cocoa/Cocoa.h>
00002
00003 @class vtkQuartzGLView;
00004
00005 @interface vtkQuartzWindow : NSWindow
00006 {
00007     @private
00008     NSTimer *MyNSTimer;
00009     IBOutlet vtkQuartzGLView *myvtkQuartzGLView;
00010     void *myVTKRenderWindow;
00011     void *myVTKRenderWindowInteractor;
00012 }
00013
00014 // accessor and convenience
00015
00016 - (vtkQuartzGLView *)getvtkQuartzGLView;
00017 - (void)setvtkQuartzGLView:vtkQuartzGLView;
00018
00019 - (void *)getVTKRenderWindow;
00020 - (void)setVTKRenderWindow:(void *)theVTKRenderWindow;
00021
00022 - (void *)getVTKRenderWindowInteractor;
00023 - (void)setVTKRenderWindowInteractor:(void *)theVTKRenderWindowInteractor;
00024
00025 - (void)makeCurrentContext;
00026
00027 - (NSSize)windowWillResize:(NSWindow *)sender toSize:(NSSize)proposedFrameSize;
00028 - (BOOL)windowShouldZoom:(NSWindow *)sender toFrame:(NSRect)newFrame;
00029 - (void)close; //close your face!
00030
00031
00032 @end
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRayCaster.h Source File

Rendering/vtkRayCaster.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRayCaster.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkRayCaster_h
00037 #define __vtkRayCaster_h
00038
00039 #include "vtkObject.h"
00040 #include "vtkObjectFactory.h"
00041
00042 class VTK_RENDERING_EXPORT vtkRayCaster : public vtkObject
00043 {
00044 public:
00045   static vtkRayCaster *New();
00046   vtkTypeRevisionMacro(vtkRayCaster,vtkObject);
00047
00048 #ifndef VTK_REMOVE_LEGACY_CODE
00049
00050   float *GetPerspectiveViewRays()
00051     {VTK_LEGACY_METHOD(GetPersepctiveViewRays,"4.0"); return NULL;};
00052
00053   void GetViewRaysSize( int* vtkNotUsed(size) ) // It is actually int size[2]
00054     {VTK_LEGACY_METHOD(GetViewRaysSize,"4.0");};
00055
00056
00057   float *GetParallelStartPosition( void )
00058     {VTK_LEGACY_METHOD(GetParallelStartPosition,"4.0"); return NULL;};
00059
00060   float *GetParallelIncrements( void )
00061     {VTK_LEGACY_METHOD(GetParallelIncrements,"4.0"); return NULL;};
00062
00063
00064   void SetImageScale(int vtkNotUsed(level), float vtkNotUsed(scale))
00065     {VTK_LEGACY_METHOD(SetImageScale,"4.0");};
00066
00067   float GetImageScale(int vtkNotUsed(level))
00068     {VTK_LEGACY_METHOD(GetImageScale,"4.0"); return 0.0;};
00069
00070   int GetImageScaleCount( void )
00071     {VTK_LEGACY_METHOD(GetImageScaleCount,"4.0"); return 0;};
00072
00073   void SetSelectedImageScaleIndex(int vtkNotUsed(level),
00074                                   float vtkNotUsed(scale))
00075     {VTK_LEGACY_METHOD(SetSelectedImageScaleIndex,"4.0");};
00076
00077   float GetSelectedImageScaleIndex(int vtkNotUsed(level))
00078     {VTK_LEGACY_METHOD(GetSelectedImageScaleIndex,"4.0"); return 0.0;};
00079
00080   void SetViewRaysStepSize(int vtkNotUsed(level), float vtkNotUsed(scale))
00081     {VTK_LEGACY_METHOD(SetViewRaysStepSize,"4.0");};
00082
00083   float GetViewRaysStepSize(int vtkNotUsed(level))
00084     {VTK_LEGACY_METHOD(GetViewRaysStepSize,"4.0");return 0.0;};
00085
00086   int GetAutomaticScaleAdjustment()
00087     {VTK_LEGACY_METHOD(GetAutomaticScaleAdjustment,"4.0");return 0;};
00088
00089   void AutomaticScaleAdjustmentOn( void )
00090     {VTK_LEGACY_METHOD(AutomaticScaleAdjustmentOn,"4.0");};
00091
00092   void AutomaticScaleAdjustmentOff( void )
00093     {VTK_LEGACY_METHOD(AutomaticScaleAdjustmentOff,"4.0");};
00094
00095   void SetAutomaticScaleLowerLimit(float vtkNotUsed(scale))
00096     {VTK_LEGACY_METHOD(SetAutomaticScaleLowerLimit,"4.0");};
00097
00098   float GetAutomaticScaleLowerLimit()
00099     {VTK_LEGACY_METHOD(GetAutomaticScaleLowerLimit,"4.0"); return 0.0;};
00100
00101   void SetBilinearImageZoom(int vtkNotUsed(val))
00102     {VTK_LEGACY_METHOD(SetBilinearImageZoom,"4.0");};
00103
00104   int GetBilinearImageZoom()
00105     {VTK_LEGACY_METHOD(GetBilinearImageZoom,"4.0"); return 0;};
00106
00107   void BilinearImageZoomOn()
00108     {VTK_LEGACY_METHOD(BilinearImageZoomOn,"4.0");};
00109
00110   void BilinearImageZoomOff()
00111     {VTK_LEGACY_METHOD(BilinearImageZoomOff,"4.0");};
00112
00113   float GetTotalRenderTime()
00114     {VTK_LEGACY_METHOD(GetTotalRenderTime,"4.0"); return 0.0;};
00115
00116   void SetNumberOfThreads(int vtkNotUsed(val))
00117     {VTK_LEGACY_METHOD(SetNumberOfThreads,"4.0");};
00118
00119   int GetNumberOfThreads()
00120     {VTK_LEGACY_METHOD(GetNumberOfThreads,"4.0"); return 0;};
00121
00122   int GetNumberOfSamplesTaken()
00123     {VTK_LEGACY_METHOD(GetNumberOfSamplesTaken,"4.0"); return 0;};
00124 #endif
00125
00126 protected:
00127   vtkRayCaster() {};
00128   ~vtkRayCaster() {};
00129
00130 private:
00131   vtkRayCaster(const vtkRayCaster&);  // Not implemented.
00132   void operator=(const vtkRayCaster&);  // Not implemented.
00133 };
00134 #endif
00135
00136
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkRayCastStructures.h Source File

Common/vtkRayCastStructures.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRayCastStructures.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00036 #ifndef __vtkRayCastStructures_h
00037 #define __vtkRayCastStructures_h
00038
00039 typedef struct
00040 {
00041   // These are the input values that define the ray. Depending on
00042   // whether we are casting a WorldRay or a ViewRay, these are in
00043   // world coordinates or view coordinates.
00044   float Origin[3];
00045   float Direction[3];
00046
00047   // The pixel location for the ray that is being cast can be
00048   // important, for example if hardware ray bounding is being used
00049   // and the location in the depth buffer must be matched to this
00050   // ray.
00051   int   Pixel[2];
00052
00053   // The world coordinate location of the camera is important for the
00054   // ray caster to be able to return a Z value for the intersection
00055   float CameraPosition[3];
00056
00057   // This input value defines the size of the image
00058   int   ImageSize[2];
00059
00060   // These are input values for clipping but may be changed
00061   // along the way
00062   float NearClip;
00063   float FarClip;
00064
00065   // These are the return values - RGBA and Z
00066   float Color[4];
00067   float Depth;
00068
00069
00070   // Some additional space that may be useful for the
00071   // specific implementation of the ray caster. This structure
00072   // is a convenient place to put it, since there is one
00073   // per thread so that writing to these locations is safe
00074
00075   // Ray information transformed into local coordinates
00076   float                        TransformedStart[4];
00077   float                        TransformedEnd[4];
00078   float                        TransformedDirection[4];
00079   float                        TransformedIncrement[3];
00080
00081   // The number of steps we want to take if this is
00082   // a ray caster that takes steps
00083   int                          NumberOfStepsToTake;
00084
00085   // The number of steps we actually take if this is
00086   // a ray caster that takes steps
00087   int                          NumberOfStepsTaken;
00088
00089 } VTKRayCastRayInfo;
00090
00091 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRearrangeFields.h Source File

Graphics/vtkRearrangeFields.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRearrangeFields.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00073 #ifndef __vtkRearrangeFields_h
00074 #define __vtkRearrangeFields_h
00075
00076 #include "vtkDataSetToDataSetFilter.h"
00077
00078 class vtkFieldData;
00079
00080 class VTK_GRAPHICS_EXPORT vtkRearrangeFields : public vtkDataSetToDataSetFilter
00081 {
00082 public:
00083   vtkTypeRevisionMacro(vtkRearrangeFields,vtkDataSetToDataSetFilter);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00087   static vtkRearrangeFields *New();
00088
00089 //BTX
00090   enum OperationType
00091   {
00092     COPY=0,
00093     MOVE=1
00094   };
00095   enum FieldLocation
00096   {
00097     DATA_OBJECT=0,
00098     POINT_DATA=1,
00099     CELL_DATA=2
00100   };
00101 //ETX
00102
00104
00107   int AddOperation(int operationType, int attributeType, int fromFieldLoc,
00108                    int toFieldLoc);
00109   // Description:
00110   // Add an operation which copies a field (data array) from one field
00111   // data to another. Returns an operation id which can later
00112   // be used to remove the operation.
00113   int AddOperation(int operationType, const char* name, int fromFieldLoc,
00114                    int toFieldLoc);
00115   // Description:
00116   // Helper method used by other language bindings. Allows the caller to
00117   // specify arguments as strings instead of enums.Returns an operation id
00118   // which can later be used to remove the operation.
00119   int AddOperation(const char* operationType, const char* attributeType,
00120                    const char* fromFieldLoc,  const char* toFieldLoc);
00122
00124
00125   int RemoveOperation(int operationId);
00126   // Description:
00127   // Remove an operation with the given signature. See AddOperation
00128   // for details.
00129   int RemoveOperation(int operationType, int attributeType, int fromFieldLoc,
00130                       int toFieldLoc);
00131   // Description:
00132   // Remove an operation with the given signature. See AddOperation
00133   // for details.
00134   int RemoveOperation(int operationType, const char* name, int fromFieldLoc,
00135                       int toFieldLoc);
00136   // Description:
00137   // Remove an operation with the given signature. See AddOperation
00138   // for details.
00139   int RemoveOperation(const char* operationType, const char* attributeType,
00140                       const char* fromFieldLoc,  const char* toFieldLoc);
00142
00144
00145   void RemoveAllOperations()
00146     {
00147     this->Modified();
00148     this->LastId = 0;
00149     this->DeleteAllOperations();
00150     }
00152
00153 //BTX
00154   enum FieldType
00155   {
00156     NAME,
00157     ATTRIBUTE
00158   };
00159
00160   struct Operation
00161   {
00162     int OperationType; // COPY or MOVE
00163     int FieldType;     // NAME or ATTRIBUTE
00164     char* FieldName;
00165     int AttributeType;
00166     int FromFieldLoc; // fd, pd or do
00167     int ToFieldLoc;   // fd, pd or do
00168     int Id;            // assigned during creation
00169     Operation* Next;   // linked list
00170     Operation() { FieldName = 0; }
00171     ~Operation() { delete[] FieldName; }
00172   };
00173 //ETX
00174
00175 protected:
00176
00177   vtkRearrangeFields();
00178   virtual ~vtkRearrangeFields();
00179
00180   void Execute();
00181
00182
00183   // Operations are stored as a linked list.
00184   Operation* Head;
00185   Operation* Tail;
00186   // This is incremented whenever a new operation is created.
00187   // It is not decremented when an operation is deleted.
00188   int LastId;
00189
00190   // Methods to browse/modify the linked list.
00191   Operation* GetNextOperation(Operation* op)
00192     { return op->Next; }
00193   Operation* GetFirst()
00194     { return this->Head; }
00195   void AddOperation(Operation* op);
00196   void DeleteOperation(Operation* op, Operation* before);
00197   Operation* FindOperation(int id, Operation*& before);
00198   Operation* FindOperation(const char* name, Operation*& before);
00199   Operation* FindOperation(int operationType, const char* name,
00200                            int fromFieldLoc, int toFieldLoc,
00201                            Operation*& before);
00202   Operation* FindOperation(int operationType, int attributeType,
00203                            int fromFieldLoc, int toFieldLoc,
00204                            Operation*& before);
00205   // Used when finding/deleting an operation given a signature.
00206   int CompareOperationsByType(const Operation* op1, const Operation* op2);
00207   int CompareOperationsByName(const Operation* op1, const Operation* op2);
00208
00209   void DeleteAllOperations();
00210   void ApplyOperation(Operation* op, vtkDataSet* input, vtkDataSet* output);
00211   // Given location (DATA_OBJECT, CELL_DATA, POINT_DATA) return the
00212   // pointer to the corresponding field data.
00213   vtkFieldData* GetFieldDataFromLocation(vtkDataSet* ds, int fieldLoc);
00214
00215   // Used by AddOperation() and RemoveOperation() designed to be used
00216   // from other language bindings.
00217   static char OperationTypeNames[2][5];
00218   static char FieldLocationNames[3][12];
00219   static char AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10];
00220
00221   void PrintAllOperations(ostream& os, vtkIndent indent)
00222     {
00223       Operation* cur = this->GetFirst();
00224       if (!cur) { return; }
00225       Operation* before;
00226       do
00227         {
00228         before = cur;
00229         cur = cur->Next;
00230         os << endl;
00231         this->PrintOperation(before, os, indent);
00232         }
00233       while (cur);
00234     }
00235
00236   void PrintOperation(Operation* op, ostream& os, vtkIndent indent)
00237     {
00238       os << indent << "Id: " << op->Id << endl;
00239       os << indent << "Type: " << op->OperationType << endl;
00240       os << indent << "Field type: " << op->FieldType << endl;
00241       if ( op->FieldName)
00242         {
00243         os << indent << "Field name: " << op->FieldName << endl;
00244         }
00245       else
00246         {
00247         os << indent << "Field name: (none)" << endl;
00248         }
00249       os << indent << "Attribute type: " << op->AttributeType << endl;
00250       os << indent << "Source field location: " << op->FromFieldLoc << endl;
00251       os << indent << "Target field location: " << op->ToFieldLoc << endl;
00252       os << indent << "Next operation: " << op->Next << endl;
00253       os << endl;
00254     }
00255 private:
00256   vtkRearrangeFields(const vtkRearrangeFields&);  // Not implemented.
00257   void operator=(const vtkRearrangeFields&);  // Not implemented.
00258 };
00259
00260 #endif
00261
00262
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkRectilinearGrid.h Source File

Common/vtkRectilinearGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkRectilinearGrid_h
00056 #define __vtkRectilinearGrid_h
00057
00058 #include "vtkDataSet.h"
00059 #include "vtkStructuredData.h"
00060 class vtkVertex;
00061 class vtkLine;
00062 class vtkPixel;
00063 class vtkVoxel;
00064 class vtkDataArray;
00065
00066 class VTK_COMMON_EXPORT vtkRectilinearGrid : public vtkDataSet
00067 {
00068 public:
00069   static vtkRectilinearGrid *New();
00070
00071   vtkTypeRevisionMacro(vtkRectilinearGrid,vtkDataSet);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075   vtkDataObject *MakeObject() {return vtkRectilinearGrid::New();};
00076
00078   int GetDataObjectType() {return VTK_RECTILINEAR_GRID;};
00079
00082   void CopyStructure(vtkDataSet *ds);
00083
00085   void Initialize();
00086
00088
00089   vtkIdType GetNumberOfCells();
00090   vtkIdType GetNumberOfPoints();
00091   float *GetPoint(vtkIdType ptId);
00092   void GetPoint(vtkIdType id, float x[3]);
00093   vtkCell *GetCell(vtkIdType cellId);
00094   void GetCell(vtkIdType cellId, vtkGenericCell *cell);
00095   void GetCellBounds(vtkIdType cellId, float bounds[6]);
00096   int FindPoint(float x, float y, float z) { return this->vtkDataSet::FindPoint(x, y, z);};
00097   vtkIdType FindPoint(float x[3]);
00098   vtkIdType FindCell(float x[3], vtkCell *cell, vtkIdType cellId, float tol2,
00099                      int& subId, float pcoords[3], float *weights);
00100   vtkIdType FindCell(float x[3], vtkCell *cell, vtkGenericCell *gencell,
00101                      vtkIdType cellId, float tol2, int& subId,
00102                      float pcoords[3], float *weights);
00103   vtkCell *FindAndGetCell(float x[3], vtkCell *cell, vtkIdType cellId,
00104                           float tol2, int& subId, float pcoords[3],
00105                           float *weights);
00106   int GetCellType(vtkIdType cellId);
00107   void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds)
00108     {vtkStructuredData::GetCellPoints(cellId,ptIds,this->DataDescription,
00109                                       this->Dimensions);}
00110   void GetPointCells(vtkIdType ptId, vtkIdList *cellIds)
00111     {vtkStructuredData::GetPointCells(ptId,cellIds,this->Dimensions);}
00112   void ComputeBounds();
00113   int GetMaxCellSize() {return 8;}; //voxel is the largest
00114   void GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds,
00115                         vtkIdList *cellIds);
00117
00119
00121   void SetDimensions(int i, int j, int k);
00122   void SetDimensions(int dim[3]);
00124
00126
00127   vtkGetVectorMacro(Dimensions,int,3);
00129
00131   int GetDataDimension();
00132
00138   int ComputeStructuredCoordinates(float x[3], int ijk[3], float pcoords[3]);
00139
00142   vtkIdType ComputePointId(int ijk[3]);
00143
00146   vtkIdType ComputeCellId(int ijk[3]);
00147
00149
00150   vtkSetObjectMacro(XCoordinates,vtkDataArray);
00151   vtkGetObjectMacro(XCoordinates,vtkDataArray);
00153
00155
00156   vtkSetObjectMacro(YCoordinates,vtkDataArray);
00157   vtkGetObjectMacro(YCoordinates,vtkDataArray);
00159
00161
00162   vtkSetObjectMacro(ZCoordinates,vtkDataArray);
00163   vtkGetObjectMacro(ZCoordinates,vtkDataArray);
00165
00167
00170   void SetUpdateExtent(int piece, int numPieces, int ghostLevel);
00171   void SetUpdateExtent(int piece, int numPieces)
00172     {this->SetUpdateExtent(piece, numPieces, 0);}
00174
00176
00177   void SetUpdateExtent( int x1, int x2, int y1, int y2, int z1, int z2 )
00178     { this->vtkDataSet::SetUpdateExtent( x1, x2, y1, y2, z1, z2 ); };
00179   void SetUpdateExtent( int ext[6] )
00180     { this->vtkDataSet::SetUpdateExtent( ext ); };
00182
00184
00187   void SetExtent(int extent[6]);
00188   void SetExtent(int x1, int x2, int y1, int y2, int z1, int z2);
00189   vtkGetVector6Macro(Extent,int);
00191
00197   unsigned long GetActualMemorySize();
00198
00200
00201   void ShallowCopy(vtkDataObject *src);
00202   void DeepCopy(vtkDataObject *src);
00204
00205 protected:
00206   vtkRectilinearGrid();
00207   ~vtkRectilinearGrid();
00208
00209   // for the GetCell method
00210   vtkVertex *Vertex;
00211   vtkLine *Line;
00212   vtkPixel *Pixel;
00213   vtkVoxel *Voxel;
00214
00215   // The extent type is a 3D extent
00216   int GetExtentType() { return VTK_3D_EXTENT; };
00217
00221   virtual void Crop();
00222
00223   int Dimensions[3];
00224   int DataDescription;
00225
00226   vtkDataArray *XCoordinates;
00227   vtkDataArray *YCoordinates;
00228   vtkDataArray *ZCoordinates;
00229
00230   // Hang on to some space for returning points when GetPoint(id) is called.
00231   float PointReturn[3];
00232
00233 private:
00235
00236   void GetCellNeighbors(vtkIdType cellId, vtkIdList& ptIds, vtkIdList& cellIds)
00237     {this->GetCellNeighbors(cellId, &ptIds, &cellIds);}
00239 private:
00240   vtkRectilinearGrid(const vtkRectilinearGrid&);  // Not implemented.
00241   void operator=(const vtkRectilinearGrid&);  // Not implemented.
00242 };
00243
00244
00245
00246
00247 inline vtkIdType vtkRectilinearGrid::GetNumberOfCells()
00248 {
00249   vtkIdType nCells=1;
00250   int i;
00251
00252   for (i=0; i<3; i++)
00253     {
00254     if (this->Dimensions[i] <= 0)
00255       {
00256       return 0;
00257       }
00258     if (this->Dimensions[i] > 1)
00259       {
00260       nCells *= (this->Dimensions[i]-1);
00261       }
00262     }
00263
00264   return nCells;
00265 }
00266
00267 inline vtkIdType vtkRectilinearGrid::GetNumberOfPoints()
00268 {
00269   return this->Dimensions[0]*this->Dimensions[1]*this->Dimensions[2];
00270 }
00271
00272 inline int vtkRectilinearGrid::GetDataDimension()
00273 {
00274   return vtkStructuredData::GetDataDimension(this->DataDescription);
00275 }
00276
00277 inline vtkIdType vtkRectilinearGrid::ComputePointId(int ijk[3])
00278 {
00279   return vtkStructuredData::ComputePointId(this->Dimensions,ijk);
00280 }
00281
00282 inline vtkIdType vtkRectilinearGrid::ComputeCellId(int ijk[3])
00283 {
00284   return vtkStructuredData::ComputeCellId(this->Dimensions,ijk);
00285 }
00286
00287 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRectilinearGridGeometryFilter.h Source File

Graphics/vtkRectilinearGridGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkRectilinearGridGeometryFilter_h
00055 #define __vtkRectilinearGridGeometryFilter_h
00056
00057 #include "vtkRectilinearGridToPolyDataFilter.h"
00058
00059 class VTK_GRAPHICS_EXPORT vtkRectilinearGridGeometryFilter : public vtkRectilinearGridToPolyDataFilter
00060 {
00061 public:
00062   vtkTypeRevisionMacro(vtkRectilinearGridGeometryFilter,vtkRectilinearGridToPolyDataFilter);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066   static vtkRectilinearGridGeometryFilter *New();
00067
00069
00071   vtkGetVectorMacro(Extent,int,6);
00073
00075   void SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax);
00076
00078   void SetExtent(int extent[6]);
00079
00080 protected:
00081   vtkRectilinearGridGeometryFilter();
00082   ~vtkRectilinearGridGeometryFilter() {};
00083
00084   void Execute();
00085   int Extent[6];
00086 private:
00087   vtkRectilinearGridGeometryFilter(const vtkRectilinearGridGeometryFilter&);  // Not implemented.
00088   void operator=(const vtkRectilinearGridGeometryFilter&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkRectilinearGridOutlineFilter.h Source File

Parallel/vtkRectilinearGridOutlineFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridOutlineFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkRectilinearGridOutlineFilter_h
00038 #define __vtkRectilinearGridOutlineFilter_h
00039
00040 #include "vtkRectilinearGridToPolyDataFilter.h"
00041
00042 class VTK_PARALLEL_EXPORT vtkRectilinearGridOutlineFilter : public vtkRectilinearGridToPolyDataFilter
00043 {
00044 public:
00045   static vtkRectilinearGridOutlineFilter *New();
00046   vtkTypeRevisionMacro(vtkRectilinearGridOutlineFilter,vtkRectilinearGridToPolyDataFilter);
00047
00048 protected:
00049   vtkRectilinearGridOutlineFilter() {};
00050   ~vtkRectilinearGridOutlineFilter() {};
00051   void Execute();
00052   void ExecuteInformation();
00053
00054 private:
00055   vtkRectilinearGridOutlineFilter(const vtkRectilinearGridOutlineFilter&);  // Not implemented.
00056   void operator=(const vtkRectilinearGridOutlineFilter&);  // Not implemented.
00057 };
00058
00059 #endif
00060
00061
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkRectilinearGridReader.h Source File

IO/vtkRectilinearGridReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkRectilinearGridReader_h
00048 #define __vtkRectilinearGridReader_h
00049
00050 #include "vtkDataReader.h"
00051 #include "vtkRectilinearGrid.h"
00052
00053 class VTK_IO_EXPORT vtkRectilinearGridReader : public vtkDataReader
00054 {
00055 public:
00056   static vtkRectilinearGridReader *New();
00057   vtkTypeRevisionMacro(vtkRectilinearGridReader,vtkDataReader);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00061
00062   vtkRectilinearGrid *GetOutput();
00063   vtkRectilinearGrid *GetOutput(int idx)
00064     {return (vtkRectilinearGrid *) this->vtkSource::GetOutput(idx); };
00065   void SetOutput(vtkRectilinearGrid *output);
00067
00068 protected:
00069   vtkRectilinearGridReader();
00070   ~vtkRectilinearGridReader();
00071
00072   void Execute();
00073   void ExecuteInformation();
00074
00075 private:
00076   vtkRectilinearGridReader(const vtkRectilinearGridReader&);  // Not implemented.
00077   void operator=(const vtkRectilinearGridReader&);  // Not implemented.
00078 };
00079
00080 #endif
00081
00082
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkRectilinearGridSource.h Source File

Filtering/vtkRectilinearGridSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkRectilinearGridSource_h
00037 #define __vtkRectilinearGridSource_h
00038
00039 #include "vtkSource.h"
00040 #include "vtkRectilinearGrid.h"
00041
00042 class VTK_FILTERING_EXPORT vtkRectilinearGridSource : public vtkSource
00043 {
00044 public:
00045   static vtkRectilinearGridSource *New();
00046   vtkTypeRevisionMacro(vtkRectilinearGridSource,vtkSource);
00047
00049
00050   vtkRectilinearGrid *GetOutput();
00051   vtkRectilinearGrid *GetOutput(int idx)
00052     {return (vtkRectilinearGrid *) this->vtkSource::GetOutput(idx); };
00053   void SetOutput(vtkRectilinearGrid *output);
00055
00056 protected:
00057   vtkRectilinearGridSource();
00058   ~vtkRectilinearGridSource() {};
00059
00060 private:
00061   vtkRectilinearGridSource(const vtkRectilinearGridSource&);  // Not implemented.
00062   void operator=(const vtkRectilinearGridSource&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkRectilinearGridToPolyDataFilter.h Source File

Filtering/vtkRectilinearGridToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkRectilinearGridToPolyDataFilter_h
00038 #define __vtkRectilinearGridToPolyDataFilter_h
00039
00040 #include "vtkPolyDataSource.h"
00041 #include "vtkRectilinearGrid.h"
00042
00043 class VTK_FILTERING_EXPORT vtkRectilinearGridToPolyDataFilter : public vtkPolyDataSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkRectilinearGridToPolyDataFilter,vtkPolyDataSource);
00047
00049
00050   void SetInput(vtkRectilinearGrid *input);
00051   vtkRectilinearGrid *GetInput();
00053
00054 protected:
00055   vtkRectilinearGridToPolyDataFilter() {this->NumberOfRequiredInputs = 1;};
00056   ~vtkRectilinearGridToPolyDataFilter() {};
00057 private:
00058   vtkRectilinearGridToPolyDataFilter(const vtkRectilinearGridToPolyDataFilter&);  // Not implemented.
00059   void operator=(const vtkRectilinearGridToPolyDataFilter&);  // Not implemented.
00060 };
00061
00062 #endif
00063
00064
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkRectilinearGridWriter.h Source File

IO/vtkRectilinearGridWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRectilinearGridWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkRectilinearGridWriter_h
00038 #define __vtkRectilinearGridWriter_h
00039
00040 #include "vtkDataWriter.h"
00041 #include "vtkRectilinearGrid.h"
00042
00043 class VTK_IO_EXPORT vtkRectilinearGridWriter : public vtkDataWriter
00044 {
00045 public:
00046   static vtkRectilinearGridWriter *New();
00047   vtkTypeRevisionMacro(vtkRectilinearGridWriter,vtkDataWriter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051
00052   void SetInput(vtkRectilinearGrid *input);
00053   vtkRectilinearGrid *GetInput();
00055
00056 protected:
00057   vtkRectilinearGridWriter() {};
00058   ~vtkRectilinearGridWriter() {};
00059
00060   void WriteData();
00061
00062 private:
00063   vtkRectilinearGridWriter(const vtkRectilinearGridWriter&);  // Not implemented.
00064   void operator=(const vtkRectilinearGridWriter&);  // Not implemented.
00065 };
00066
00067 #endif
00068
00069
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRecursiveDividingCubes.h Source File

Graphics/vtkRecursiveDividingCubes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRecursiveDividingCubes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00053 #ifndef __vtkRecursiveDividingCubes_h
00054 #define __vtkRecursiveDividingCubes_h
00055
00056 #include "vtkStructuredPointsToPolyDataFilter.h"
00057
00058 class VTK_GRAPHICS_EXPORT vtkRecursiveDividingCubes : public vtkStructuredPointsToPolyDataFilter
00059 {
00060 public:
00061   static vtkRecursiveDividingCubes *New();
00062   vtkTypeRevisionMacro(vtkRecursiveDividingCubes,vtkStructuredPointsToPolyDataFilter);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00067   vtkSetMacro(Value,float);
00068   vtkGetMacro(Value,float);
00070
00072
00073   vtkSetClampMacro(Distance,float,1.0e-06,VTK_LARGE_FLOAT);
00074   vtkGetMacro(Distance,float);
00076
00078
00081   vtkSetClampMacro(Increment,int,1,VTK_LARGE_INTEGER);
00082   vtkGetMacro(Increment,int);
00084
00085 protected:
00086   vtkRecursiveDividingCubes();
00087   ~vtkRecursiveDividingCubes();
00088
00089   void Execute();
00090   void SubDivide(float origin[3], float h[3], float values[8]);
00091
00092   float Value;
00093   float Distance;
00094   int Increment;
00095
00096   // working variable
00097   int Count;
00098
00099   // to replace a static
00100   vtkVoxel *Voxel;
00101 private:
00102   vtkRecursiveDividingCubes(const vtkRecursiveDividingCubes&);  // Not implemented.
00103   void operator=(const vtkRecursiveDividingCubes&);  // Not implemented.
00104 };
00105
00106 #endif
00107
00108
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRecursiveSphereDirectionEncoder.h Source File

Rendering/vtkRecursiveSphereDirectionEncoder.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRecursiveSphereDirectionEncoder.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00039 #ifndef __vtkRecursiveSphereDirectionEncoder_h
00040 #define __vtkRecursiveSphereDirectionEncoder_h
00041
00042 #include "vtkDirectionEncoder.h"
00043
00044 class VTK_RENDERING_EXPORT vtkRecursiveSphereDirectionEncoder : public vtkDirectionEncoder
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkRecursiveSphereDirectionEncoder,vtkDirectionEncoder);
00048   void PrintSelf( ostream& os, vtkIndent index );
00049
00052   static vtkRecursiveSphereDirectionEncoder *New();
00053
00054
00056   int GetEncodedDirection( float n[3] );
00057
00059   float *GetDecodedGradient( int value );
00060
00062   int GetNumberOfEncodedDirections( void );
00063
00068   float *GetDecodedGradientTable( void );
00069
00071
00083   vtkSetClampMacro( RecursionDepth, int, 0, 6 );
00084   vtkGetMacro( RecursionDepth, int );
00086
00087 protected:
00088   vtkRecursiveSphereDirectionEncoder();
00089   ~vtkRecursiveSphereDirectionEncoder();
00090
00091   // How far to recursively divide the sphere
00092   int                     RecursionDepth;
00093
00094   // The index table which maps (x,y) position in the rotated grid
00095   // to an encoded normal
00096   //int                   IndexTable[2*NORM_SQR_SIZE - 1][2*NORM_SQR_SIZE -1];
00097   int                     *IndexTable;
00098
00099   // This is a table that maps encoded normal (2 byte value) to a
00100   // normal (dx, dy, dz)
00101   //float                 DecodedNormal[3*(1 + 2*(NORM_SQR_SIZE*NORM_SQR_SIZE+
00102   //                             (NORM_SQR_SIZE-1)*(NORM_SQR_SIZE-1)))];
00103   float                   *DecodedNormal;
00104
00105   // Method to initialize the index table and variable that
00106   // stored the recursion depth the last time the table was
00107   // built
00108   void                  InitializeIndexTable( void );
00109   int                   IndexTableRecursionDepth;
00110
00111   int                   OuterSize;
00112   int                   InnerSize;
00113   int                   GridSize;
00114 private:
00115   vtkRecursiveSphereDirectionEncoder(const vtkRecursiveSphereDirectionEncoder&);  // Not implemented.
00116   void operator=(const vtkRecursiveSphereDirectionEncoder&);  // Not implemented.
00117 };
00118
00119
00120 #endif
00121
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkReferenceCount.h Source File

Common/vtkReferenceCount.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkReferenceCount.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkReferenceCount_h
00036 #define __vtkReferenceCount_h
00037
00038 #include "vtkObject.h"
00039
00040 class VTK_COMMON_EXPORT vtkReferenceCount : public vtkObject
00041 {
00042 public:
00043   static vtkReferenceCount *New();
00044
00045   vtkTypeRevisionMacro(vtkReferenceCount,vtkObject);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00048 protected:
00049   vtkReferenceCount();
00050   ~vtkReferenceCount();
00051
00052 private:
00053   vtkReferenceCount(const vtkReferenceCount&);  // Not implemented.
00054   void operator=(const vtkReferenceCount&);  // Not implemented.
00055 };
00056
00057
00058 #endif
00059
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkReflectionFilter.h Source File

Graphics/vtkReflectionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkReflectionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkReflectionFilter_h
00036 #define __vtkReflectionFilter_h
00037
00038 #include "vtkPolyDataToPolyDataFilter.h"
00039
00040 #define VTK_USE_X_MIN 0
00041 #define VTK_USE_Y_MIN 1
00042 #define VTK_USE_Z_MIN 2
00043 #define VTK_USE_X_MAX 3
00044 #define VTK_USE_Y_MAX 4
00045 #define VTK_USE_Z_MAX 5
00046
00047 class VTK_GRAPHICS_EXPORT vtkReflectionFilter : public vtkPolyDataToPolyDataFilter
00048 {
00049 public:
00050   static vtkReflectionFilter *New();
00051
00052   vtkTypeRevisionMacro(vtkReflectionFilter, vtkPolyDataToPolyDataFilter);
00053   void PrintSelf(ostream &os, vtkIndent indent);
00054
00055   vtkSetClampMacro(Plane, int, 0, 5);
00056   vtkGetMacro(Plane, int);
00057   void SetPlaneToXMin() { this->SetPlane(VTK_USE_X_MIN); };
00058   void SetPlaneToYMin() { this->SetPlane(VTK_USE_Y_MIN); };
00059   void SetPlaneToZMin() { this->SetPlane(VTK_USE_Z_MIN); };
00060   void SetPlaneToXMax() { this->SetPlane(VTK_USE_X_MAX); };
00061   void SetPlaneToYMax() { this->SetPlane(VTK_USE_Y_MAX); };
00062   void SetPlaneToZMax() { this->SetPlane(VTK_USE_Z_MAX); };
00063
00064 protected:
00065   vtkReflectionFilter();
00066   ~vtkReflectionFilter();
00067
00068   void Execute();
00069
00070   int Plane;
00071
00072 private:
00073   vtkReflectionFilter(const vtkReflectionFilter&);  // Not implemented
00074   void operator=(const vtkReflectionFilter&);  // Not implemented
00075 };
00076
00077 #endif
00078
00079
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRender.h Source File

Rendering/vtkRender.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRender.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 #ifndef __vtkRender_h
00017 #define __vtkRender_h
00018
00019 // shading models
00020 #define VTK_FLAT    0
00021 #define VTK_GOURAUD 1
00022 #define VTK_PHONG   2
00023
00024 // representation models
00025 #define VTK_POINTS    0
00026 #define VTK_WIREFRAME 1
00027 #define VTK_SURFACE   2
00028
00029 #endif
00030
00031
00032
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRenderer.h Source File

Rendering/vtkRenderer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRenderer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkRenderer_h
00053 #define __vtkRenderer_h
00054
00055 #include "vtkMatrix4x4.h"
00056 #include "vtkLightCollection.h"
00057 #include "vtkVolumeCollection.h"
00058 #include "vtkCullerCollection.h"
00059 #include "vtkCamera.h"
00060 #include "vtkActor.h"
00061 #include "vtkActor2D.h"
00062 #include "vtkViewport.h"
00063 #include "vtkActorCollection.h"
00064
00065 class vtkRayCaster;
00066 class vtkRenderWindow;
00067 class vtkVolume;
00068 class vtkCuller;
00069
00070 class VTK_RENDERING_EXPORT vtkRenderer : public vtkViewport
00071 {
00072 public:
00073   vtkTypeRevisionMacro(vtkRenderer,vtkViewport);
00074   void PrintSelf(ostream& os, vtkIndent indent);
00075
00079   static vtkRenderer *New();
00080
00082   void AddLight(vtkLight *);
00083
00085
00088   void AddActor(vtkProp *p) {this->AddProp(p);};
00089   void AddVolume(vtkProp *p) {this->AddProp(p);};
00090   void RemoveActor(vtkProp *p) {this->Actors->RemoveItem(p);this->RemoveProp(p);};
00091   void RemoveVolume(vtkProp *p) {this->Volumes->RemoveItem(p);this->RemoveProp(p);};
00093
00095   void RemoveLight(vtkLight *);
00096
00098   vtkLightCollection *GetLights();
00099
00101   vtkVolumeCollection *GetVolumes();
00102
00104   vtkActorCollection *GetActors();
00105
00107   void SetActiveCamera(vtkCamera *);
00108
00110   vtkCamera *GetActiveCamera();
00111
00115   virtual vtkCamera *MakeCamera();
00116
00118   void AddCuller(vtkCuller *);
00119
00121   void RemoveCuller(vtkCuller *);
00122
00124   vtkCullerCollection *GetCullers();
00125
00127
00128   vtkSetVector3Macro(Ambient,float);
00129   vtkGetVectorMacro(Ambient,float,3);
00131
00133
00135   vtkSetMacro(AllocatedRenderTime,float);
00136   virtual float GetAllocatedRenderTime();
00138
00143   virtual float GetTimeFactor();
00144
00147   virtual void Render();
00148
00151   virtual void DeviceRender() =0;
00152
00153
00155   virtual void Clear() {};
00156
00158   int VisibleActorCount();
00159
00161   int VisibleVolumeCount();
00162
00164   void CreateLight(void);
00165
00169   virtual vtkLight *MakeLight();
00170
00173   void ComputeVisiblePropBounds( float bounds[6] );
00174
00177   void ResetCameraClippingRange();
00178
00180
00182   void ResetCameraClippingRange( float bounds[6] );
00183   void ResetCameraClippingRange( float xmin, float xmax,
00184                                  float ymin, float ymax,
00185                                  float zmin, float zmax);
00187
00193   void ResetCamera();
00194
00202   void ResetCamera(float bounds[6]);
00203
00205
00206   void ResetCamera(float xmin, float xmax, float ymin, float ymax,
00207                    float zmin, float zmax);
00209
00211
00214   void SetRenderWindow(vtkRenderWindow *);
00215   vtkRenderWindow *GetRenderWindow() {return this->RenderWindow;};
00216   virtual vtkWindow *GetVTKWindow();
00218
00220
00224   vtkGetMacro(TwoSidedLighting,int);
00225   vtkSetMacro(TwoSidedLighting,int);
00226   vtkBooleanMacro(TwoSidedLighting,int);
00228
00230
00233   vtkSetMacro(BackingStore,int);
00234   vtkGetMacro(BackingStore,int);
00235   vtkBooleanMacro(BackingStore,int);
00237
00239
00242   vtkSetMacro(Interactive,int);
00243   vtkGetMacro(Interactive,int);
00244   vtkBooleanMacro(Interactive,int);
00246
00248
00250   vtkSetMacro(Layer, int);
00251   vtkGetMacro(Layer, int);
00253
00256   int  Transparent();
00257
00259   void WorldToView();
00260
00262
00263   void ViewToWorld();
00264   virtual void ViewToWorld(float &wx, float &wy, float &wz);
00266
00268   virtual void WorldToView(float &wx, float &wy, float &wz);
00269
00271   float GetZ (int x, int y);
00272
00276   void RenderOverlay();
00277
00279   unsigned long GetMTime();
00280
00282
00283   vtkGetMacro( LastRenderTimeInSeconds, float );
00285
00287
00291   vtkGetMacro( NumberOfPropsRenderedAsGeometry, int );
00293
00299   vtkAssemblyPath* PickProp(float selectionX, float selectionY);
00300
00302
00314   vtkSetMacro(LightFollowCamera,int);
00315   vtkGetMacro(LightFollowCamera,int);
00316   vtkBooleanMacro(LightFollowCamera,int);
00318
00319   vtkRayCaster *GetRayCaster()
00320     {VTK_LEGACY_METHOD(GetRayCaster,"4.0");return this->RayCaster;};
00321
00322
00323 protected:
00324   vtkRenderer();
00325   ~vtkRenderer();
00326
00327   // internal method for doing a render for picking purposes
00328   virtual void PickRender(vtkPropCollection *props);
00329   virtual void PickGeometry();
00330
00331   vtkCamera *ActiveCamera;
00332   vtkLight  *CreatedLight;
00333
00334   vtkLightCollection *Lights;
00335   vtkCullerCollection *Cullers;
00336
00337   vtkActorCollection *Actors;
00338   vtkVolumeCollection *Volumes;
00339
00340   float              Ambient[3];
00341   vtkRenderWindow    *RenderWindow;
00342   float              AllocatedRenderTime;
00343   float              TimeFactor;
00344   int                TwoSidedLighting;
00345   int                BackingStore;
00346   unsigned char      *BackingImage;
00347   vtkTimeStamp       RenderTime;
00348
00349   float              LastRenderTimeInSeconds;
00350
00351   int                LightFollowCamera;
00352
00353   // Allocate the time for each prop
00354   void               AllocateTime();
00355
00356   // Internal variables indicating the number of props
00357   // that have been or will be rendered in each category.
00358   int                NumberOfPropsRenderedAsGeometry;
00359   int                NumberOfPropsToRayCast;
00360   int                NumberOfPropsToRenderIntoImage;
00361
00362   // A temporary list of props used for culling, and traversal
00363   // of all props when rendering
00364   vtkProp            **PropArray;
00365   int                PropArrayCount;
00366
00367   // A temporary list used for picking
00368   vtkAssemblyPath    **PathArray;
00369   int                PathArrayCount;
00370
00371   // Indicates if the renderer should receive events from an interactor.
00372   // Typically only used in conjunction with transparent renderers.
00373   int                Interactive;
00374
00375   // Shows what layer this renderer belongs to.  Only of interested when
00376   // there are layered renderers.
00377   int                Layer;
00378
00382   virtual int UpdateGeometry(void);
00383
00386   virtual int UpdateCamera(void);
00387
00391   virtual int UpdateLightGeometry(void);
00392
00395   virtual int UpdateLights(void) {return 0;};
00396
00397   vtkRayCaster *RayCaster;
00398 private:
00399   vtkRenderer(const vtkRenderer&);  // Not implemented.
00400   void operator=(const vtkRenderer&);  // Not implemented.
00401 };
00402
00404 inline vtkLightCollection *vtkRenderer::GetLights() {return this->Lights;}
00405
00407 inline vtkCullerCollection *vtkRenderer::GetCullers(){return this->Cullers;}
00408
00409
00410 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRendererCollection.h Source File

Rendering/vtkRendererCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRendererCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkRendererCollection_h
00039 #define __vtkRendererCollection_h
00040
00041 #include "vtkCollection.h"
00042 #include "vtkRenderer.h"
00043
00044 class VTK_RENDERING_EXPORT vtkRendererCollection : public vtkCollection
00045 {
00046  public:
00047   static vtkRendererCollection *New();
00048   vtkTypeRevisionMacro(vtkRendererCollection,vtkCollection);
00049
00051
00052   void AddItem(vtkRenderer *a) {
00053     this->vtkCollection::AddItem((vtkObject *)a);};
00055
00057
00059   vtkRenderer *GetNextItem() {
00060     return static_cast<vtkRenderer *>(this->GetNextItemAsObject());};
00062
00064
00065   void Render();
00066   void RenderOverlay();
00068
00069 protected:
00070   vtkRendererCollection() {};
00071   ~vtkRendererCollection() {};
00072
00073 private:
00074   // hide the standard AddItem from the user and the compiler.
00075   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00076
00077 private:
00078   vtkRendererCollection(const vtkRendererCollection&);  // Not implemented.
00079   void operator=(const vtkRendererCollection&);  // Not implemented.
00080 };
00081
00082
00083 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRendererSource.h Source File

Rendering/vtkRendererSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRendererSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkRendererSource_h
00049 #define __vtkRendererSource_h
00050
00051 #include "vtkStructuredPointsSource.h"
00052 #include "vtkRenderer.h"
00053
00054 class VTK_RENDERING_EXPORT vtkRendererSource : public vtkStructuredPointsSource
00055 {
00056 public:
00057   static vtkRendererSource *New();
00058   vtkTypeRevisionMacro(vtkRendererSource,vtkStructuredPointsSource);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062   unsigned long GetMTime();
00063
00065
00066   vtkSetObjectMacro(Input,vtkRenderer);
00068
00070
00072   vtkGetObjectMacro(Input,vtkRenderer);
00074
00076
00078   vtkSetMacro(WholeWindow,int);
00079   vtkGetMacro(WholeWindow,int);
00080   vtkBooleanMacro(WholeWindow,int);
00082
00084
00085   vtkSetMacro(RenderFlag, int);
00086   vtkGetMacro(RenderFlag, int);
00087   vtkBooleanMacro(RenderFlag, int);
00089
00091
00094   vtkSetMacro(DepthValues,int);
00095   vtkGetMacro(DepthValues,int);
00096   vtkBooleanMacro(DepthValues,int);
00098
00099 protected:
00100   vtkRendererSource();
00101   ~vtkRendererSource();
00102
00103   void Execute();
00104
00105   void UpdateInformation();
00106
00107   vtkRenderer *Input;
00108   int WholeWindow;
00109   int RenderFlag;
00110   int DepthValues;
00111
00112 private:
00113   vtkRendererSource(const vtkRendererSource&);  // Not implemented.
00114   void operator=(const vtkRendererSource&);  // Not implemented.
00115 };
00116
00117 #endif
00118
00119
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkRenderLargeImage.h Source File

Hybrid/vtkRenderLargeImage.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRenderLargeImage.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkRenderLargeImage_h
00039 #define __vtkRenderLargeImage_h
00040
00041 #include "vtkImageSource.h"
00042 #include "vtkRenderer.h"
00043
00044 class VTK_HYBRID_EXPORT vtkRenderLargeImage : public vtkImageSource
00045 {
00046 public:
00047   static vtkRenderLargeImage *New();
00048   vtkTypeRevisionMacro(vtkRenderLargeImage,vtkImageSource);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   vtkSetMacro(Magnification,int);
00054   vtkGetMacro(Magnification,int);
00056
00058
00059   vtkSetObjectMacro(Input,vtkRenderer);
00061
00063
00065   vtkGetObjectMacro(Input,vtkRenderer);
00067
00068 protected:
00069   vtkRenderLargeImage();
00070   ~vtkRenderLargeImage();
00071
00072   int Magnification;
00073   vtkRenderer *Input;
00074   void ExecuteData(vtkDataObject *data);
00075   void ExecuteInformation();
00076 private:
00077   vtkRenderLargeImage(const vtkRenderLargeImage&);  // Not implemented.
00078   void operator=(const vtkRenderLargeImage&);  // Not implemented.
00079 };
00080
00081 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRenderWindow.h Source File

Rendering/vtkRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkRenderWindow_h
00062 #define __vtkRenderWindow_h
00063
00064 #include "vtkWindow.h"
00065 #include "vtkRendererCollection.h"
00066 #include <stdio.h>
00067 #include "vtkGraphicsFactory.h"
00068
00069 class vtkRenderWindowInteractor;
00070
00071
00072
00073 // lets define the different types of stereo
00074 #define VTK_STEREO_CRYSTAL_EYES 1
00075 #define VTK_STEREO_RED_BLUE     2
00076 #define VTK_STEREO_INTERLACED   3
00077 #define VTK_STEREO_LEFT         4
00078 #define VTK_STEREO_RIGHT        5
00079 #define VTK_STEREO_DRESDEN      6
00080
00081 class VTK_RENDERING_EXPORT vtkRenderWindow : public vtkWindow
00082 {
00083 public:
00084   vtkTypeRevisionMacro(vtkRenderWindow,vtkWindow);
00085   void PrintSelf(ostream& os, vtkIndent indent);
00086
00090   static vtkRenderWindow *New();
00091
00093   void AddRenderer(vtkRenderer *);
00094
00096   void RemoveRenderer(vtkRenderer *);
00097
00099
00100   static const char *GetRenderLibrary() {
00101     return vtkGraphicsFactory::GetRenderLibrary();};
00103
00105   vtkRendererCollection *GetRenderers() {return this->Renderers;};
00106
00109   virtual void Render();
00110
00112   virtual void Start() {};
00113
00116   virtual void Frame() {};
00117
00120   virtual void CopyResultFrame();
00121
00125   virtual vtkRenderWindowInteractor *MakeRenderWindowInteractor();
00126
00128
00130   virtual void HideCursor() {};
00131   virtual void ShowCursor() {};
00133
00135
00136   virtual void SetFullScreen(int) {};
00137   vtkGetMacro(FullScreen,int);
00138   vtkBooleanMacro(FullScreen,int);
00140
00142
00145   vtkSetMacro(Borders,int);
00146   vtkGetMacro(Borders,int);
00147   vtkBooleanMacro(Borders,int);
00149
00151
00153   vtkGetMacro(StereoCapableWindow,int);
00154   vtkBooleanMacro(StereoCapableWindow,int);
00155   virtual void SetStereoCapableWindow(int capable);
00157
00159
00160   vtkGetMacro(StereoRender,int);
00161   void SetStereoRender(int stereo);
00162   vtkBooleanMacro(StereoRender,int);
00164
00166
00168   vtkSetMacro(PointSmoothing,int);
00169   vtkGetMacro(PointSmoothing,int);
00170   vtkBooleanMacro(PointSmoothing,int);
00172
00174
00176   vtkSetMacro(LineSmoothing,int);
00177   vtkGetMacro(LineSmoothing,int);
00178   vtkBooleanMacro(LineSmoothing,int);
00180
00182
00184   vtkSetMacro(PolygonSmoothing,int);
00185   vtkGetMacro(PolygonSmoothing,int);
00186   vtkBooleanMacro(PolygonSmoothing,int);
00188
00190
00191   vtkGetMacro(StereoType,int);
00192   vtkSetMacro(StereoType,int);
00193   void SetStereoTypeToCrystalEyes()
00194     {this->SetStereoType(VTK_STEREO_CRYSTAL_EYES);};
00195   void SetStereoTypeToRedBlue()
00196     {this->SetStereoType(VTK_STEREO_RED_BLUE);};
00197   void SetStereoTypeToInterlaced()
00198     {this->SetStereoType(VTK_STEREO_INTERLACED);};
00199   void SetStereoTypeToLeft()
00200     {this->SetStereoType(VTK_STEREO_LEFT);};
00201   void SetStereoTypeToRight()
00202     {this->SetStereoType(VTK_STEREO_RIGHT);};
00203   void SetStereoTypeToDresden()
00204     {this->SetStereoType(VTK_STEREO_DRESDEN);};
00205   char *GetStereoTypeAsString();
00207
00211   virtual void StereoUpdate();
00212
00215   virtual void StereoMidpoint();
00216
00219   virtual void StereoRenderComplete();
00220
00224   virtual void WindowRemap() {};
00225
00227
00228   vtkSetMacro(SwapBuffers,int);
00229   vtkGetMacro(SwapBuffers,int);
00230   vtkBooleanMacro(SwapBuffers,int);
00232
00241   virtual void SetPixelData(int, int, int, int, unsigned char *,int) {};
00242
00244
00249   virtual float *GetRGBAPixelData(int ,int ,int ,int ,int ) {
00250     return (float *)NULL;};
00251   virtual void SetRGBAPixelData(int ,int ,int ,int ,float *,int,
00252                                 int blend=0) { blend = blend;}
00253   virtual unsigned char *GetRGBACharPixelData(int ,int ,int ,int ,int ) {
00254     return (unsigned char*)NULL;}
00255   virtual void SetRGBACharPixelData(int ,int ,int ,int ,unsigned char *, int,
00256                                     int blend=0) { blend = blend;}
00258
00259
00261
00262   virtual float *GetZbufferData(int, int, int, int ) {return (float *)NULL;};
00263   virtual void SetZbufferData(int, int, int, int, float *) {};
00265
00267
00270   vtkGetMacro(AAFrames,int);
00271   vtkSetMacro(AAFrames,int);
00273
00275
00280   vtkGetMacro(FDFrames,int);
00281   vtkSetMacro(FDFrames,int);
00283
00285
00290   vtkGetMacro(SubFrames,int);
00291   vtkSetMacro(SubFrames,int);
00293
00295
00296   vtkGetMacro(NeverRendered,int);
00298
00300
00302   vtkGetMacro(AbortRender,int);
00303   vtkSetMacro(AbortRender,int);
00304   vtkGetMacro(InAbortCheck,int);
00305   vtkSetMacro(InAbortCheck,int);
00306   virtual int CheckAbortStatus();
00307   virtual int GetEventPending() { return 0;};
00309
00311   virtual int  CheckInRenderStatus() { return this->InRender; }
00312
00314   virtual void ClearInRenderStatus() { this->InRender = 0; }
00315
00318   void SetAbortCheckMethod(void (*f)(void *), void *arg);
00319
00321   void SetAbortCheckMethodArgDelete(void (*f)(void *));
00322
00324
00329   void SetDesiredUpdateRate(float);
00330   vtkGetMacro(DesiredUpdateRate,float);
00332
00334
00338   vtkGetMacro(NumberOfLayers, int);
00339   vtkSetClampMacro(NumberOfLayers, int, 1, VTK_LARGE_INTEGER);
00341
00343
00344   vtkGetObjectMacro(Interactor,vtkRenderWindowInteractor);
00345   void SetInteractor(vtkRenderWindowInteractor *);
00347
00350   void UnRegister(vtkObject *o);
00351
00353
00354   virtual void SetDisplayId(void *) {}
00355   virtual void SetWindowId(void *)  {}
00356   virtual void SetParentId(void *)  {}
00357   virtual void *GetGenericDisplayId() {return NULL;}
00358   virtual void *GetGenericWindowId() {return NULL;}
00359   virtual void *GetGenericParentId() {return NULL;}
00360   virtual void *GetGenericContext() {return NULL;}
00361   virtual void *GetGenericDrawable() {return NULL;}
00362   virtual void SetWindowInfo(char *) {}
00363   virtual void SetParentInfo(char *) {};
00365
00367   virtual void MakeCurrent() {};
00368
00371   virtual int GetDepthBufferSize() {return -1;}
00372
00373 protected:
00374   vtkRenderWindow();
00375   ~vtkRenderWindow();
00376
00377   virtual void DoStereoRender();
00378   virtual void DoFDRender();
00379   virtual void DoAARender();
00380
00381   vtkRendererCollection *Renderers;
00382   int Borders;
00383   int FullScreen;
00384   int OldScreen[5];
00385   int PointSmoothing;
00386   int LineSmoothing;
00387   int PolygonSmoothing;
00388   int StereoRender;
00389   int StereoType;
00390   int StereoStatus; // used for keeping track of what's going on
00391   int StereoCapableWindow;
00392   vtkRenderWindowInteractor *Interactor;
00393   unsigned char* StereoBuffer; // used for red blue stereo
00394   float *AccumulationBuffer;   // used for many techniques
00395   unsigned int AccumulationBufferSize;
00396   int AAFrames;
00397   int FDFrames;
00398   int SubFrames;               // number of sub frames
00399   int CurrentSubFrame;         // what one are we on
00400   unsigned char *ResultFrame;  // used for any non immediate rendering
00401   int   SwapBuffers;
00402   float DesiredUpdateRate;
00403   int   AbortRender;
00404   int   InAbortCheck;
00405   int   InRender;
00406   int   NeverRendered;
00407   int   NumberOfLayers;
00408   void (*AbortCheckMethod)(void *);
00409   void (*AbortCheckMethodArgDelete)(void *);
00410   void *AbortCheckMethodArg;
00411 private:
00412   vtkRenderWindow(const vtkRenderWindow&);  // Not implemented.
00413   void operator=(const vtkRenderWindow&);  // Not implemented.
00414 };
00415
00417 inline char *vtkRenderWindow::GetStereoTypeAsString(void)
00418 {
00419   switch ( this->StereoType )
00420     {
00421     case VTK_STEREO_CRYSTAL_EYES:
00422       return (char *)"CrystalEyes";
00423     case VTK_STEREO_RED_BLUE:
00424       return (char *)"RedBlue";
00425     case VTK_STEREO_LEFT:
00426       return (char *)"Left";
00427     case VTK_STEREO_RIGHT:
00428       return (char *)"Right";
00429     case VTK_STEREO_DRESDEN:
00430       return (char *)"DresdenDisplay";
00431     default:
00432       return (char *)"";
00433     }
00434 }
00435
00436 #endif
00437
00438
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRenderWindowCollection.h Source File

Rendering/vtkRenderWindowCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRenderWindowCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkRenderWindowCollection_h
00039 #define __vtkRenderWindowCollection_h
00040
00041 #include "vtkCollection.h"
00042 #include "vtkRenderWindow.h"
00043
00044 class VTK_RENDERING_EXPORT vtkRenderWindowCollection : public vtkCollection
00045 {
00046  public:
00047   static vtkRenderWindowCollection *New();
00048   vtkTypeRevisionMacro(vtkRenderWindowCollection,vtkCollection);
00049
00051
00052   void AddItem(vtkRenderWindow *a) {
00053     this->vtkCollection::AddItem((vtkObject *)a);};
00055
00057
00059   vtkRenderWindow *GetNextItem() {
00060     return static_cast<vtkRenderWindow *>(this->GetNextItemAsObject());};
00062
00063 protected:
00064   vtkRenderWindowCollection() {};
00065   ~vtkRenderWindowCollection() {};
00066
00067 private:
00068   // hide the standard AddItem from the user and the compiler.
00069   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00070
00071 private:
00072   vtkRenderWindowCollection(const vtkRenderWindowCollection&);  // Not implemented.
00073   void operator=(const vtkRenderWindowCollection&);  // Not implemented.
00074 };
00075
00076
00077 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkRenderWindowInteractor.h Source File

Rendering/vtkRenderWindowInteractor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRenderWindowInteractor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkRenderWindowInteractor_h
00058 #define __vtkRenderWindowInteractor_h
00059
00060 #include "vtkObject.h"
00061 #include "vtkRenderWindow.h"
00062 #include "vtkAbstractPropPicker.h"
00063
00064 // Timer flags for win32/X compatibility
00065 #define VTKI_TIMER_FIRST  0
00066 #define VTKI_TIMER_UPDATE 1
00067
00068 class vtkInteractorStyle;
00069
00070 class VTK_RENDERING_EXPORT vtkRenderWindowInteractor : public vtkObject
00071 {
00072 public:
00073   static vtkRenderWindowInteractor *New();
00074   vtkTypeRevisionMacro(vtkRenderWindowInteractor,vtkObject);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078
00080   virtual void Initialize() {this->Initialized=1; this->Enable();
00081                              this->RenderWindow->Render();}
00082   void ReInitialize() {  this->Initialized = 0; this->Enabled = 0;
00083                         this->Initialize(); }
00085
00088   void UnRegister(vtkObject *o);
00089
00093   virtual void Start() {};
00094
00096
00103   virtual void Enable() { this->Enabled = 1; this->Modified();};
00104   virtual void Disable() { this->Enabled = 0; this->Modified();};
00105   vtkGetMacro(Enabled, int);
00107
00109
00110   void SetRenderWindow(vtkRenderWindow *aren);
00111   vtkGetObjectMacro(RenderWindow,vtkRenderWindow);
00113
00115   virtual void UpdateSize(int x,int y);
00116
00118
00123   virtual int CreateTimer(int )  { return 1; };
00124   virtual int DestroyTimer()    { return 1; };
00126
00130   virtual void TerminateApp(void) {};
00131
00133
00134   virtual void SetInteractorStyle(vtkInteractorStyle *);
00135   vtkGetObjectMacro(InteractorStyle,vtkInteractorStyle);
00137
00139
00141   vtkSetMacro(LightFollowCamera,int);
00142   vtkGetMacro(LightFollowCamera,int);
00143   vtkBooleanMacro(LightFollowCamera,int);
00145
00147
00151   vtkSetClampMacro(DesiredUpdateRate,float,0.0001,VTK_LARGE_FLOAT);
00152   vtkGetMacro(DesiredUpdateRate,float);
00154
00156
00158   vtkSetClampMacro(StillUpdateRate,float,0.0001,VTK_LARGE_FLOAT);
00159   vtkGetMacro(StillUpdateRate,float);
00161
00163
00164   vtkGetMacro(Initialized,int);
00166
00168
00172   vtkSetObjectMacro(Picker,vtkAbstractPicker);
00173   vtkGetObjectMacro(Picker,vtkAbstractPicker);
00175
00178   virtual vtkAbstractPropPicker *CreateDefaultPicker();
00179
00181   void SetStartPickMethod(void (*f)(void *), void *arg);
00182
00185   void SetStartPickMethodArgDelete(void (*f)(void *));
00186
00188   void SetEndPickMethod(void (*f)(void *), void *arg);
00189
00192   void SetEndPickMethodArgDelete(void (*f)(void *));
00193
00195   void SetUserMethod(void (*f)(void *), void *arg);
00196
00199   void SetUserMethodArgDelete(void (*f)(void *));
00200
00202   void SetExitMethod(void (*f)(void *), void *arg);
00203
00206   void SetExitMethodArgDelete(void (*f)(void *));
00207
00209
00211   virtual void ExitCallback();
00212   virtual void UserCallback();
00213   virtual void StartPickCallback();
00214   virtual void EndPickCallback();
00216
00218   virtual void GetMousePosition(int *x, int *y) { *x = 0 ; *y = 0; };
00219
00221
00223   void HideCursor() { this->RenderWindow->HideCursor(); };
00224   void ShowCursor() { this->RenderWindow->ShowCursor(); };
00226
00229   void Render();
00230
00232
00235   void FlyTo(vtkRenderer *ren, float x, float y, float z);
00236   void FlyTo(vtkRenderer *ren, float *x)
00237     {this->FlyTo(ren, x[0], x[1], x[2]);}
00238   void FlyToImage(vtkRenderer *ren, float x, float y);
00239   void FlyToImage(vtkRenderer *ren, float *x)
00240     {this->FlyToImage(ren, x[0], x[1]);}
00242
00244
00245   vtkSetClampMacro(NumberOfFlyFrames,int,1,VTK_LARGE_INTEGER);
00246   vtkGetMacro(NumberOfFlyFrames,int);
00248
00250
00252   vtkSetMacro(Dolly,float);
00253   vtkGetMacro(Dolly,float);
00255
00257
00260   vtkSetVector2Macro(EventPosition,int);
00261   vtkGetVectorMacro(EventPosition,int,2);
00262   vtkSetMacro(ControlKey, int);
00263   vtkGetMacro(ControlKey, int);
00264   vtkSetMacro(ShiftKey, int);
00265   vtkGetMacro(ShiftKey, int);
00266   vtkSetMacro(KeyCode, int);
00267   vtkGetMacro(KeyCode, int);
00268   vtkSetMacro(RepeatCount, int);
00269   vtkGetMacro(RepeatCount, int);
00270   vtkSetStringMacro(KeySym);
00271   vtkGetStringMacro(KeySym);
00273
00275
00278   void SetEventInformation(int x, int y, int ctrl=0, int shift=0, int keycode=0, int repeatcount=0,
00279                            const char* keysym=0)
00280     {
00281       this->EventPosition[0] = x;
00282       this->EventPosition[1] = y;
00283       this->ControlKey = ctrl;
00284       this->ShiftKey = shift;
00285       this->KeyCode = keycode;
00286       this->RepeatCount = repeatcount;
00287       if(keysym)
00288         {
00289         this->SetKeySym(keysym);
00290         }
00291       this->Modified();
00292     }
00294
00295
00296
00297
00298
00300
00305   vtkSetVector2Macro(Size,int);
00306   vtkGetVector2Macro(Size,int);
00308
00309
00310 protected:
00311   vtkRenderWindowInteractor();
00312   ~vtkRenderWindowInteractor();
00313
00314   vtkRenderWindow    *RenderWindow;
00315   vtkInteractorStyle *InteractorStyle;
00316
00317   // Used as a helper object to pick instances of vtkProp
00318   vtkAbstractPicker          *Picker;
00319
00320   //
00321   int   Initialized;
00322   int   Enabled;
00323   int   Style;
00324   int   LightFollowCamera;
00325   int   ActorMode;
00326   float DesiredUpdateRate;
00327   float StillUpdateRate;
00328   // Event information
00329   int   ControlKey;
00330   int   ShiftKey;
00331   char  KeyCode;
00332   int   RepeatCount;
00333   char* KeySym;
00334   int   EventPosition[2];
00335   int   Size[2];
00336
00337   // user methods that can be used to override default behavior
00338   unsigned long StartPickTag;
00339   unsigned long EndPickTag;
00340   unsigned long UserTag;
00341   unsigned long ExitTag;
00342
00343   // control the fly to
00344   int NumberOfFlyFrames;
00345   float Dolly;
00346
00347 private:
00348   vtkRenderWindowInteractor(const vtkRenderWindowInteractor&);  // Not implemented.
00349   void operator=(const vtkRenderWindowInteractor&);  // Not implemented.
00350 };
00351
00352 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkReverseSense.h Source File

Graphics/vtkReverseSense.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkReverseSense.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkReverseSense_h
00048 #define __vtkReverseSense_h
00049
00050 #include "vtkPolyDataToPolyDataFilter.h"
00051
00052 class VTK_GRAPHICS_EXPORT vtkReverseSense : public vtkPolyDataToPolyDataFilter
00053 {
00054 public:
00055   vtkTypeRevisionMacro(vtkReverseSense,vtkPolyDataToPolyDataFilter);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00060   static vtkReverseSense *New();
00061
00063
00064   vtkSetMacro(ReverseCells,int);
00065   vtkGetMacro(ReverseCells,int);
00066   vtkBooleanMacro(ReverseCells,int);
00068
00070
00071   vtkSetMacro(ReverseNormals,int);
00072   vtkGetMacro(ReverseNormals,int);
00073   vtkBooleanMacro(ReverseNormals,int);
00075
00076
00077 protected:
00078   vtkReverseSense();
00079   ~vtkReverseSense() {};
00080
00081   // Usual data generation method
00082   void Execute();
00083
00084   int ReverseCells;
00085   int ReverseNormals;
00086 private:
00087   vtkReverseSense(const vtkReverseSense&);  // Not implemented.
00088   void operator=(const vtkReverseSense&);  // Not implemented.
00089 };
00090
00091 #endif
00092
00093
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRibbonFilter.h Source File

Graphics/vtkRibbonFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRibbonFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkRibbonFilter_h
00050 #define __vtkRibbonFilter_h
00051
00052 #include "vtkPolyDataToPolyDataFilter.h"
00053
00054 class VTK_GRAPHICS_EXPORT vtkRibbonFilter : public vtkPolyDataToPolyDataFilter
00055 {
00056 public:
00057   vtkTypeRevisionMacro(vtkRibbonFilter,vtkPolyDataToPolyDataFilter);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00062   static vtkRibbonFilter *New();
00063
00065
00067   vtkSetClampMacro(Width,float,0,VTK_LARGE_FLOAT);
00068   vtkGetMacro(Width,float);
00070
00072
00073   vtkSetClampMacro(Angle,float,0,360);
00074   vtkGetMacro(Angle,float);
00076
00078
00079   vtkSetMacro(VaryWidth,int);
00080   vtkGetMacro(VaryWidth,int);
00081   vtkBooleanMacro(VaryWidth,int);
00083
00085
00087   vtkSetMacro(WidthFactor,float);
00088   vtkGetMacro(WidthFactor,float);
00090
00092
00094   vtkSetVector3Macro(DefaultNormal,float);
00095   vtkGetVectorMacro(DefaultNormal,float,3);
00097
00099
00101   vtkSetMacro(UseDefaultNormal,int);
00102   vtkGetMacro(UseDefaultNormal,int);
00103   vtkBooleanMacro(UseDefaultNormal,int);
00105
00106 protected:
00107   vtkRibbonFilter();
00108   ~vtkRibbonFilter() {};
00109
00110   void Execute();
00111   float Width;
00112   float Angle;
00113   int VaryWidth; //controls whether width varies with scalar data
00114   float WidthFactor;
00115   float DefaultNormal[3];
00116   int UseDefaultNormal;
00117 private:
00118   vtkRibbonFilter(const vtkRibbonFilter&);  // Not implemented.
00119   void operator=(const vtkRibbonFilter&);  // Not implemented.
00120 };
00121
00122 #endif
00123
00124
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkRIBExporter.h Source File

Hybrid/vtkRIBExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRIBExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkRIBExporter_h
00065 #define __vtkRIBExporter_h
00066
00067 #include <stdio.h>
00068 #include "vtkExporter.h"
00069 #include "vtkRenderer.h"
00070 #include "vtkTexture.h"
00071 #include "vtkPolyData.h"
00072
00073 class VTK_HYBRID_EXPORT vtkRIBExporter : public vtkExporter
00074 {
00075 public:
00076   static vtkRIBExporter *New();
00077   vtkTypeRevisionMacro(vtkRIBExporter,vtkExporter);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00081
00083   vtkSetVector2Macro(Size,int);
00084   vtkGetVectorMacro(Size,int,2);
00086
00088
00089   vtkSetVector2Macro(PixelSamples,int);
00090   vtkGetVectorMacro(PixelSamples,int,2);
00092
00094
00096   vtkSetStringMacro(FilePrefix);
00097   vtkGetStringMacro(FilePrefix);
00099
00101
00102   vtkSetStringMacro(TexturePrefix);
00103   vtkGetStringMacro(TexturePrefix);
00105
00107
00121   vtkSetMacro(Background,int);
00122   vtkGetMacro(Background,int);
00123   vtkBooleanMacro(Background,int);
00125
00127
00130   vtkSetClampMacro(ExportArrays, int, 0, 1);
00131   vtkBooleanMacro(ExportArrays, int);
00132   vtkGetMacro(ExportArrays, int);
00134
00135 protected:
00136   vtkRIBExporter();
00137   ~vtkRIBExporter();
00138
00139   int Background;
00140   int Size[2];
00141   int PixelSamples[2];
00142
00144   int ExportArrays;
00145
00147
00148   void WriteHeader (vtkRenderer *aRen);
00149   void WriteTrailer ();
00150   void WriteTexture (vtkTexture *aTexture);
00151   void WriteViewport (vtkRenderer *aRenderer, int size[2]);
00152   void WriteCamera (vtkCamera *aCamera);
00153   void WriteLight (vtkLight *aLight, int count);
00154   void WriteAmbientLight (int count);
00155   void WriteProperty (vtkProperty *aProperty, vtkTexture *aTexture);
00156   void WritePolygons (vtkPolyData *pd, vtkUnsignedCharArray *colors,
00157                       vtkProperty *aProperty);
00158   void WriteStrips (vtkPolyData *pd, vtkUnsignedCharArray *colors,
00159                     vtkProperty *aProperty);
00161
00162   void WriteData();
00163   void WriteActor(vtkActor *anActor);
00164
00169   void ModifyArrayName(char *newname, const char* name);
00170
00171   char *GetTextureName (vtkTexture *aTexture);
00172   char *GetTIFFName (vtkTexture *aTexture);
00173   char *FilePrefix;
00174   FILE *FilePtr;
00175   char *TexturePrefix;
00176 private:
00177   vtkRIBExporter(const vtkRIBExporter&);  // Not implemented.
00178   void operator=(const vtkRIBExporter&);  // Not implemented.
00179 };
00180
00181 #endif
00182
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkRIBLight.h Source File

Hybrid/vtkRIBLight.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRIBLight.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkRIBLight_h
00040 #define __vtkRIBLight_h
00041
00042 #include <stdio.h>
00043 #include "vtkLight.h"
00044
00045 class vtkRIBRenderer;
00046
00047 class VTK_HYBRID_EXPORT vtkRIBLight : public vtkLight
00048 {
00049 public:
00050   static vtkRIBLight *New();
00051   vtkTypeRevisionMacro(vtkRIBLight,vtkLight);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00054   vtkBooleanMacro(Shadows,int);
00055   vtkSetMacro(Shadows,int);
00056   vtkGetMacro(Shadows,int);
00057
00058   void Render(vtkRenderer *ren, int index);
00059 protected:
00060   vtkRIBLight();
00061   ~vtkRIBLight();
00062
00063   vtkLight *Light;
00064   int Shadows;
00065 private:
00066   vtkRIBLight(const vtkRIBLight&);  // Not implemented.
00067   void operator=(const vtkRIBLight&);  // Not implemented.
00068 };
00069
00070 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkRIBProperty.h Source File

Hybrid/vtkRIBProperty.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRIBProperty.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkRIBProperty_h
00042 #define __vtkRIBProperty_h
00043
00044 #include <stdio.h>
00045 #include "vtkProperty.h"
00046
00047 class vtkRIBRenderer;
00048
00049 class VTK_HYBRID_EXPORT vtkRIBProperty : public vtkProperty
00050 {
00051 public:
00052   static vtkRIBProperty *New();
00053   vtkTypeRevisionMacro(vtkRIBProperty,vtkProperty);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057
00058   vtkSetStringMacro(SurfaceShader);
00059   vtkGetStringMacro(SurfaceShader);
00061
00063
00064   vtkSetStringMacro(DisplacementShader);
00065   vtkGetStringMacro(DisplacementShader);
00067
00069
00070   void SetVariable (char *variable, char *declaration);
00071   void AddVariable (char *variable, char *declaration);
00073
00075   char *GetDeclarations ();
00076
00078
00079   void SetParameter (char *parameter, char *value);
00080   void AddParameter (char *parameter, char *value);
00082
00084   char *GetParameters ();
00085
00086 protected:
00087   vtkRIBProperty();
00088   ~vtkRIBProperty();
00089
00090   void Render(vtkActor *a, vtkRenderer *ren);
00091   vtkProperty *Property;
00092   char *SurfaceShader;
00093   char *DisplacementShader;
00094   char *Declarations;
00095   char *Parameters;
00096 private:
00097   vtkRIBProperty(const vtkRIBProperty&);  // Not implemented.
00098   void operator=(const vtkRIBProperty&);  // Not implemented.
00099 };
00100
00101 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRotationalExtrusionFilter.h Source File

Graphics/vtkRotationalExtrusionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRotationalExtrusionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00075 #ifndef __vtkRotationalExtrusionFilter_h
00076 #define __vtkRotationalExtrusionFilter_h
00077
00078 #include "vtkPolyDataToPolyDataFilter.h"
00079
00080 class VTK_GRAPHICS_EXPORT vtkRotationalExtrusionFilter : public vtkPolyDataToPolyDataFilter
00081 {
00082 public:
00083   vtkTypeRevisionMacro(vtkRotationalExtrusionFilter,vtkPolyDataToPolyDataFilter);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00088   static vtkRotationalExtrusionFilter *New();
00089
00091
00093   vtkSetClampMacro(Resolution,int,1,VTK_LARGE_INTEGER);
00094   vtkGetMacro(Resolution,int);
00096
00098
00099   vtkSetMacro(Capping,int);
00100   vtkGetMacro(Capping,int);
00101   vtkBooleanMacro(Capping,int);
00103
00105
00106   vtkSetMacro(Angle,float);
00107   vtkGetMacro(Angle,float);
00109
00111
00112   vtkSetMacro(Translation,float);
00113   vtkGetMacro(Translation,float);
00115
00117
00118   vtkSetMacro(DeltaRadius,float);
00119   vtkGetMacro(DeltaRadius,float);
00121
00122 protected:
00123   vtkRotationalExtrusionFilter();
00124   ~vtkRotationalExtrusionFilter() {};
00125
00126   void Execute();
00127   int Resolution;
00128   int Capping;
00129   float Angle;
00130   float Translation;
00131   float DeltaRadius;
00132 private:
00133   vtkRotationalExtrusionFilter(const vtkRotationalExtrusionFilter&);  // Not implemented.
00134   void operator=(const vtkRotationalExtrusionFilter&);  // Not implemented.
00135 };
00136
00137 #endif
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkRTAnalyticSource.h Source File

Parallel/vtkRTAnalyticSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRTAnalyticSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkRTAnalyticSource_h
00040 #define __vtkRTAnalyticSource_h
00041
00042 #include "vtkImageSource.h"
00043
00044 class VTK_PARALLEL_EXPORT vtkRTAnalyticSource : public vtkImageSource
00045 {
00046 public:
00047   static vtkRTAnalyticSource *New();
00048   vtkTypeRevisionMacro(vtkRTAnalyticSource,vtkImageSource);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   void SetWholeExtent(int xMinx, int xMax, int yMin, int yMax,
00054                       int zMin, int zMax);
00055   vtkGetVector6Macro(WholeExtent, int);
00057
00059
00060   vtkSetVector3Macro(Center, float);
00061   vtkGetVector3Macro(Center, float);
00063
00065
00066   vtkSetMacro(Maximum, float);
00067   vtkGetMacro(Maximum, float);
00069
00071
00072   vtkSetMacro(StandardDeviation, float);
00073   vtkGetMacro(StandardDeviation, float);
00075
00077
00078   vtkSetMacro(XFreq, float);
00079   vtkGetMacro(XFreq, float);
00080   vtkSetMacro(YFreq, float);
00081   vtkGetMacro(YFreq, float);
00082   vtkSetMacro(ZFreq, float);
00083   vtkGetMacro(ZFreq, float);
00085
00086   vtkSetMacro(XMag, float);
00087   vtkGetMacro(XMag, float);
00088   vtkSetMacro(YMag, float);
00089   vtkGetMacro(YMag, float);
00090   vtkSetMacro(ZMag, float);
00091   vtkGetMacro(ZMag, float);
00092
00093 protected:
00094   vtkRTAnalyticSource();
00095   ~vtkRTAnalyticSource() {};
00096
00097   float XFreq;
00098   float YFreq;
00099   float ZFreq;
00100   float XMag;
00101   float YMag;
00102   float ZMag;
00103   float StandardDeviation;
00104   int WholeExtent[6];
00105   float Center[3];
00106   float Maximum;
00107
00108   virtual void ExecuteInformation();
00109   virtual void ExecuteData(vtkDataObject *data);
00110 private:
00111   vtkRTAnalyticSource(const vtkRTAnalyticSource&);  // Not implemented.
00112   void operator=(const vtkRTAnalyticSource&);  // Not implemented.
00113 };
00114
00115
00116 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkRuledSurfaceFilter.h Source File

Graphics/vtkRuledSurfaceFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRuledSurfaceFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00069 #ifndef __vtkRuledSurfaceFilter_h
00070 #define __vtkRuledSurfaceFilter_h
00071
00072 #include "vtkPolyDataToPolyDataFilter.h"
00073
00074 #define VTK_RULED_MODE_RESAMPLE 0
00075 #define VTK_RULED_MODE_POINT_WALK 1
00076
00077 class VTK_GRAPHICS_EXPORT vtkRuledSurfaceFilter : public vtkPolyDataToPolyDataFilter
00078 {
00079 public:
00080   vtkTypeRevisionMacro(vtkRuledSurfaceFilter,vtkPolyDataToPolyDataFilter);
00081   void PrintSelf(ostream& os, vtkIndent indent);
00082
00085   static vtkRuledSurfaceFilter *New();
00086
00088
00089   vtkSetClampMacro(DistanceFactor,float,1.0,VTK_LARGE_FLOAT);
00090   vtkGetMacro(DistanceFactor,float);
00092
00094
00097   vtkSetClampMacro(OnRatio,int,1,VTK_LARGE_INTEGER);
00098   vtkGetMacro(OnRatio,int);
00100
00102
00105   vtkSetClampMacro(Offset,int,0,VTK_LARGE_INTEGER);
00106   vtkGetMacro(Offset,int);
00108
00110
00115   vtkSetMacro(CloseSurface,int);
00116   vtkGetMacro(CloseSurface,int);
00117   vtkBooleanMacro(CloseSurface,int);
00119
00121
00125   vtkSetClampMacro(RuledMode,int,
00126                    VTK_RULED_MODE_RESAMPLE,VTK_RULED_MODE_POINT_WALK);
00127   vtkGetMacro(RuledMode,int);
00128   void SetRuledModeToResample()
00129     {this->SetRuledMode(VTK_RULED_MODE_RESAMPLE);}
00130   void SetRuledModeToPointWalk()
00131     {this->SetRuledMode(VTK_RULED_MODE_POINT_WALK);}
00132   const char *GetRuledModeAsString();
00134
00136
00141   vtkSetVector2Macro(Resolution, int);
00142   vtkGetVectorMacro(Resolution, int, 2);
00144
00146
00148   vtkSetMacro(PassLines,int);
00149   vtkGetMacro(PassLines,int);
00150   vtkBooleanMacro(PassLines,int);
00152
00153 protected:
00154   vtkRuledSurfaceFilter();
00155   ~vtkRuledSurfaceFilter();
00156
00157   // Usual data generation method
00158   void Execute();
00159
00160   float DistanceFactor;
00161   int   OnRatio;
00162   int   Offset;
00163   int   CloseSurface;
00164   int   RuledMode;
00165   int   Resolution[2];
00166   int   PassLines;
00167
00168 private:
00169   vtkIdList *Ids;
00170   float     Weights[4];
00171
00172   void  Resample(vtkPolyData *output, vtkPoints *inPts, vtkPoints *newPts,
00173                  int npts, vtkIdType *pts, int npts2, vtkIdType *pts2);
00174   void  PointWalk(vtkPolyData *output, vtkPoints *inPts,
00175                   int npts, vtkIdType *pts, int npts2, vtkIdType *pts2);
00176
00177 private:
00178   vtkRuledSurfaceFilter(const vtkRuledSurfaceFilter&);  // Not implemented.
00179   void operator=(const vtkRuledSurfaceFilter&);  // Not implemented.
00180 };
00181
00182 #endif
00183
00184
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkRungeKutta2.h Source File

Common/vtkRungeKutta2.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRungeKutta2.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkRungeKutta2_h
00039 #define __vtkRungeKutta2_h
00040
00041 #include "vtkInitialValueProblemSolver.h"
00042
00043 class VTK_COMMON_EXPORT vtkRungeKutta2 : public vtkInitialValueProblemSolver
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkRungeKutta2,vtkInitialValueProblemSolver);
00047
00049   static vtkRungeKutta2 *New();
00050
00052
00058   virtual int ComputeNextStep(float* xprev, float* xnext, float t,
00059                float& delT, float maxError, float& error)
00060     {
00061       float minStep = delT;
00062       float maxStep = delT;
00063       float delTActual;
00064       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00065                minStep, maxStep, maxError, error);
00066     }
00067   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00068                float t, float& delT,
00069                float maxError, float& error)
00070     {
00071       float minStep = delT;
00072       float maxStep = delT;
00073       float delTActual;
00074       return this->ComputeNextStep(xprev, dxprev, xnext, t, delT, delTActual,
00075                minStep, maxStep, maxError, error);
00076     }
00077   virtual int ComputeNextStep(float* xprev, float* xnext,
00078                float t, float& delT, float& delTActual,
00079                float minStep, float maxStep,
00080                float maxError, float& error)
00081     {
00082       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00083                minStep, maxStep, maxError, error);
00084     }
00085   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00086                float t, float& delT, float& delTActual,
00087                float minStep, float maxStep,
00088                float maxError, float& error);
00090
00092
00093   virtual vtkInitialValueProblemSolver* MakeObject()
00094     {
00095       return vtkRungeKutta2::New();
00096     }
00098
00099 protected:
00100   vtkRungeKutta2();
00101   ~vtkRungeKutta2();
00102 private:
00103   vtkRungeKutta2(const vtkRungeKutta2&);  // Not implemented.
00104   void operator=(const vtkRungeKutta2&);  // Not implemented.
00105 };
00106
00107 #endif
00108
00109
00110
00111
00112
00113
00114
00115
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkRungeKutta4.h Source File

Common/vtkRungeKutta4.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRungeKutta4.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkRungeKutta4_h
00045 #define __vtkRungeKutta4_h
00046
00047 #include "vtkInitialValueProblemSolver.h"
00048
00049 class VTK_COMMON_EXPORT vtkRungeKutta4 : public vtkInitialValueProblemSolver
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkRungeKutta4,vtkInitialValueProblemSolver);
00053   virtual void PrintSelf(ostream& os, vtkIndent indent);
00054
00056   static vtkRungeKutta4 *New();
00057
00058
00060
00066   virtual int ComputeNextStep(float* xprev, float* xnext, float t,
00067                float& delT, float maxError, float& error)
00068     {
00069       float minStep = delT;
00070       float maxStep = delT;
00071       float delTActual;
00072       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00073                minStep, maxStep, maxError, error);
00074     }
00075   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00076                float t, float& delT,
00077                float maxError, float& error)
00078     {
00079       float minStep = delT;
00080       float maxStep = delT;
00081       float delTActual;
00082       return this->ComputeNextStep(xprev, dxprev, xnext, t, delT, delTActual,
00083                minStep, maxStep, maxError, error);
00084     }
00085   virtual int ComputeNextStep(float* xprev, float* xnext,
00086                float t, float& delT, float& delTActual,
00087                float minStep, float maxStep,
00088                float maxError, float& error)
00089     {
00090       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00091                minStep, maxStep, maxError, error);
00092     }
00093   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00094                float t, float& delT, float& delTActual,
00095                float minStep, float maxStep,
00096                float maxError, float& error);
00098
00100
00101   virtual vtkInitialValueProblemSolver* MakeObject()
00102     {
00103       return vtkRungeKutta4::New();
00104     }
00106
00107
00108 protected:
00109   vtkRungeKutta4();
00110   ~vtkRungeKutta4();
00111
00112   virtual void Initialize();
00113
00114   float* NextDerivs[3];
00115 private:
00116   vtkRungeKutta4(const vtkRungeKutta4&);  // Not implemented.
00117   void operator=(const vtkRungeKutta4&);  // Not implemented.
00118 };
00119
00120 #endif
00121
00122
00123
00124
00125
00126
00127
00128
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkRungeKutta45.h Source File

Common/vtkRungeKutta45.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkRungeKutta45.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkRungeKutta45_h
00046 #define __vtkRungeKutta45_h
00047
00048 #include "vtkInitialValueProblemSolver.h"
00049
00050 class VTK_COMMON_EXPORT vtkRungeKutta45 : public vtkInitialValueProblemSolver
00051 {
00052 public:
00053   vtkTypeRevisionMacro(vtkRungeKutta45,vtkInitialValueProblemSolver);
00054
00056   static vtkRungeKutta45 *New();
00057
00059
00074   virtual int ComputeNextStep(float* xprev, float* xnext, float t,
00075                float& delT, float maxError, float& error)
00076     {
00077       float minStep = delT;
00078       float maxStep = delT;
00079       float delTActual;
00080       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00081                minStep, maxStep, maxError, error);
00082     }
00083   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00084                float t, float& delT,
00085                float maxError, float& error)
00086     {
00087       float minStep = delT;
00088       float maxStep = delT;
00089       float delTActual;
00090       return this->ComputeNextStep(xprev, dxprev, xnext, t, delT, delTActual,
00091                minStep, maxStep, maxError, error);
00092     }
00093   virtual int ComputeNextStep(float* xprev, float* xnext,
00094                float t, float& delT, float& delTActual,
00095                float minStep, float maxStep,
00096                float maxError, float& error)
00097     {
00098       return this->ComputeNextStep(xprev, 0, xnext, t, delT, delTActual,
00099                minStep, maxStep, maxError, error);
00100     }
00101   virtual int ComputeNextStep(float* xprev, float* dxprev, float* xnext,
00102                float t, float& delT, float& delTActual,
00103                float minStep, float maxStep,
00104                float maxError, float& error);
00106
00108
00109   virtual vtkInitialValueProblemSolver* MakeObject()
00110     {
00111       return vtkRungeKutta45::New();
00112     }
00114
00115 protected:
00116   vtkRungeKutta45();
00117   ~vtkRungeKutta45();
00118
00119   virtual void Initialize();
00120
00121   // Cash-Karp parameters
00122   static double A[5];
00123   static double B[5][5];
00124   static double C[6];
00125   static double DC[6];
00126
00127   float* NextDerivs[6];
00128
00129   int ComputeAStep(float* xprev, float* dxprev, float* xnext, float t,
00130          float& delT,  float& error);
00131
00132 private:
00133   vtkRungeKutta45(const vtkRungeKutta45&);  // Not implemented.
00134   void operator=(const vtkRungeKutta45&);  // Not implemented.
00135 };
00136
00137 #endif
00138
00139
00140
00141
00142
00143
00144
00145
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkSampleFunction.h Source File

Imaging/vtkSampleFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSampleFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkSampleFunction_h
00049 #define __vtkSampleFunction_h
00050
00051 #include "vtkStructuredPointsSource.h"
00052 #include "vtkImplicitFunction.h"
00053
00054 class VTK_IMAGING_EXPORT vtkSampleFunction : public vtkStructuredPointsSource
00055 {
00056 public:
00057   vtkTypeRevisionMacro(vtkSampleFunction,vtkStructuredPointsSource);
00058   void PrintSelf(ostream& os, vtkIndent indent);
00059
00063   static vtkSampleFunction *New();
00064
00066
00067   vtkSetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00068   vtkGetObjectMacro(ImplicitFunction,vtkImplicitFunction);
00070
00072
00075   vtkSetObjectMacro(Scalars,vtkDataArray);
00077
00079   void SetSampleDimensions(int i, int j, int k);
00080
00082
00083   void SetSampleDimensions(int dim[3]);
00084   vtkGetVectorMacro(SampleDimensions,int,3);
00086
00088
00089   vtkSetVector6Macro(ModelBounds,float);
00090   vtkGetVectorMacro(ModelBounds,float,6);
00092
00094
00097   vtkSetMacro(Capping,int);
00098   vtkGetMacro(Capping,int);
00099   vtkBooleanMacro(Capping,int);
00101
00103
00104   vtkSetMacro(CapValue,float);
00105   vtkGetMacro(CapValue,float);
00107
00109
00110   vtkSetMacro(ComputeNormals,int);
00111   vtkGetMacro(ComputeNormals,int);
00112   vtkBooleanMacro(ComputeNormals,int);
00114
00116   unsigned long GetMTime();
00117
00118 protected:
00119   vtkSampleFunction();
00120   ~vtkSampleFunction();
00121
00122   void Execute();
00123   void ExecuteInformation();
00124   void Cap(vtkDataArray *s);
00125
00126   int SampleDimensions[3];
00127   float ModelBounds[6];
00128   vtkDataArray *Scalars;
00129   int Capping;
00130   float CapValue;
00131   vtkImplicitFunction *ImplicitFunction;
00132   int ComputeNormals;
00133 private:
00134   vtkSampleFunction(const vtkSampleFunction&);  // Not implemented.
00135   void operator=(const vtkSampleFunction&);  // Not implemented.
00136 };
00137
00138 #endif
00139
00140
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkScalarBarActor.h Source File

Rendering/vtkScalarBarActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkScalarBarActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkScalarBarActor_h
00065 #define __vtkScalarBarActor_h
00066
00067 #include "vtkActor2D.h"
00068 #include "vtkScalarsToColors.h"
00069 #include "vtkPolyDataMapper2D.h"
00070 #include "vtkTextMapper.h"
00071
00072 #define VTK_ORIENT_HORIZONTAL 0
00073 #define VTK_ORIENT_VERTICAL 1
00074
00075 class VTK_RENDERING_EXPORT vtkScalarBarActor : public vtkActor2D
00076 {
00077 public:
00078   vtkTypeRevisionMacro(vtkScalarBarActor,vtkActor2D);
00079   void PrintSelf(ostream& os, vtkIndent indent);
00080
00085   static vtkScalarBarActor *New();
00086
00087
00089
00090   int RenderOpaqueGeometry(vtkViewport* viewport);
00091   int RenderTranslucentGeometry(vtkViewport*) { return 0; };
00092   int RenderOverlay(vtkViewport* viewport);
00094
00098   virtual void ReleaseGraphicsResources(vtkWindow *);
00099
00101
00104   vtkSetObjectMacro(LookupTable,vtkScalarsToColors);
00105   vtkGetObjectMacro(LookupTable,vtkScalarsToColors);
00107
00109
00112   vtkSetClampMacro(MaximumNumberOfColors, int, 2, VTK_LARGE_INTEGER);
00113   vtkGetMacro(MaximumNumberOfColors, int);
00115
00117
00118   vtkSetClampMacro(NumberOfLabels, int, 0, 64);
00119   vtkGetMacro(NumberOfLabels, int);
00121
00123
00124   vtkSetClampMacro(Orientation,int,VTK_ORIENT_HORIZONTAL, VTK_ORIENT_VERTICAL);
00125   vtkGetMacro(Orientation, int);
00126   void SetOrientationToHorizontal()
00127        {this->SetOrientation(VTK_ORIENT_HORIZONTAL);};
00128   void SetOrientationToVertical() {this->SetOrientation(VTK_ORIENT_VERTICAL);};
00130
00132
00133   vtkSetMacro(Bold, int);
00134   vtkGetMacro(Bold, int);
00135   vtkBooleanMacro(Bold, int);
00137
00139
00140   vtkSetMacro(Italic, int);
00141   vtkGetMacro(Italic, int);
00142   vtkBooleanMacro(Italic, int);
00144
00146
00148   vtkSetMacro(Shadow, int);
00149   vtkGetMacro(Shadow, int);
00150   vtkBooleanMacro(Shadow, int);
00152
00154
00157   vtkSetMacro(FontFamily, int);
00158   vtkGetMacro(FontFamily, int);
00159   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00160   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00161   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00163
00165
00166   vtkSetStringMacro(LabelFormat);
00167   vtkGetStringMacro(LabelFormat);
00169
00171
00172   vtkSetStringMacro(Title);
00173   vtkGetStringMacro(Title);
00175
00178   void ShallowCopy(vtkProp *prop);
00179
00180 protected:
00181   vtkScalarBarActor();
00182   ~vtkScalarBarActor();
00183
00184   vtkScalarsToColors *LookupTable;
00185   int   MaximumNumberOfColors;
00186   int   NumberOfLabels;
00187   int   NumberOfLabelsBuilt;
00188   int   Orientation;
00189   char  *Title;
00190
00191   int   Bold;
00192   int   Italic;
00193   int   Shadow;
00194   int   FontFamily;
00195   char  *LabelFormat;
00196
00197 private:
00198   vtkTextMapper *TitleMapper;
00199   vtkActor2D    *TitleActor;
00200
00201   vtkTextMapper **TextMappers;
00202   vtkActor2D    **TextActors;
00203
00204   vtkPolyData         *ScalarBar;
00205   vtkPolyDataMapper2D *ScalarBarMapper;
00206   vtkActor2D          *ScalarBarActor;
00207
00208   vtkTimeStamp  BuildTime;
00209   int LastSize[2];
00210   int LastOrigin[2];
00211
00212   void SizeTitle(int *titleSize, int *size, vtkViewport *viewport);
00213   void AllocateAndSizeLabels(int *labelSize, int *size,
00214                              vtkViewport *viewport, float *range);
00215 private:
00216   vtkScalarBarActor(const vtkScalarBarActor&);  // Not implemented.
00217   void operator=(const vtkScalarBarActor&);  // Not implemented.
00218 };
00219
00220
00221 #endif
00222
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkScalarsToColors.h Source File

Common/vtkScalarsToColors.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkScalarsToColors.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkScalarsToColors_h
00043 #define __vtkScalarsToColors_h
00044
00045 #include "vtkObject.h"
00046 #include "vtkUnsignedCharArray.h"
00047
00048 #define VTK_LUMINANCE       1
00049 #define VTK_LUMINANCE_ALPHA 2
00050 #define VTK_RGB             3
00051 #define VTK_RGBA            4
00052
00053 #define VTK_COLOR_MODE_DEFAULT 0
00054 #define VTK_COLOR_MODE_MAP_SCALARS 1
00055
00056 class vtkDataArray;
00057
00058 class VTK_COMMON_EXPORT vtkScalarsToColors : public vtkObject
00059 {
00060 public:
00061   vtkTypeRevisionMacro(vtkScalarsToColors,vtkObject);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065   virtual void Build() {};
00066
00068
00069   virtual float *GetRange() = 0;
00070   virtual void SetRange(float min, float max) = 0;
00071   void SetRange(float rng[2])
00072     {this->SetRange(rng[0],rng[1]);}
00074
00077   virtual unsigned char *MapValue(float v) = 0;
00078
00081   virtual void GetColor(float v, float rgb[3]) = 0;
00082
00084
00086   float *GetColor(float v)
00087     {this->GetColor(v,this->RGB); return this->RGB;}
00089
00091
00093   virtual float GetOpacity(float vtkNotUsed(v))
00094     {return 1.0;}
00096
00098
00101   float GetLuminance(float x)
00102     {float rgb[3]; this->GetColor(x,rgb);
00103     return rgb[0]*0.30 + rgb[1]*0.59 + rgb[2]*0.11;}
00105
00107
00111   void SetAlpha(float alpha);
00112   vtkGetMacro(Alpha,float);
00114
00116
00123   vtkUnsignedCharArray *MapScalars(vtkDataArray *scalars, int colorMode,
00124                                    int component);
00126
00128
00133   void MapScalarsThroughTable(vtkDataArray *scalars,
00134                               unsigned char *output,
00135                               int outputFormat);
00136   void MapScalarsThroughTable(vtkDataArray *scalars,
00137                               unsigned char *output)
00138     {this->MapScalarsThroughTable(scalars,output,VTK_RGBA);}
00140
00141
00143
00144   virtual void MapScalarsThroughTable2(void *input, unsigned char *output,
00145                                        int inputDataType, int numberOfValues,
00146                                        int inputIncrement,
00147                                        int outputFormat) = 0;
00149
00151
00154   virtual vtkUnsignedCharArray *ConvertUnsignedCharToRGBA(
00155     vtkUnsignedCharArray *colors, int numComp, int numTuples);
00157
00158 protected:
00159   vtkScalarsToColors():Alpha(1.0) {}
00160   ~vtkScalarsToColors() {}
00161
00162   float Alpha;
00163
00164 private:
00165   float RGB[3];
00166 private:
00167   vtkScalarsToColors(const vtkScalarsToColors&);  // Not implemented.
00168   void operator=(const vtkScalarsToColors&);  // Not implemented.
00169 };
00170
00171 #endif
00172
00173
00174
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkScalarTree.h Source File

Filtering/vtkScalarTree.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkScalarTree.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkScalarTree_h
00047 #define __vtkScalarTree_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkDataSet.h"
00051
00052 class VTK_FILTERING_EXPORT vtkScalarTree : public vtkObject
00053 {
00054 public:
00055   vtkTypeRevisionMacro(vtkScalarTree,vtkObject);
00056   void PrintSelf(ostream& os, vtkIndent indent);
00057
00059
00060   vtkSetObjectMacro(DataSet,vtkDataSet);
00061   vtkGetObjectMacro(DataSet,vtkDataSet);
00063
00067   virtual void BuildTree() = 0;
00068
00070   virtual void Initialize() = 0;
00071
00074   virtual void InitTraversal(float scalarValue) = 0;
00075
00077
00081   virtual vtkCell *GetNextCell(vtkIdType &cellId, vtkIdList* &ptIds,
00082                                vtkDataArray *cellScalars) = 0;
00084
00085 protected:
00086   vtkScalarTree();
00087   ~vtkScalarTree();
00088
00089   vtkDataSet   *DataSet;    //the dataset over which the scalar tree is built
00090   vtkDataArray *Scalars;    //the scalars of the DataSet
00091
00092   vtkTimeStamp BuildTime; //time at which tree was built
00093   float        ScalarValue; //current scalar value for traversal
00094
00095 private:
00096   vtkScalarTree(const vtkScalarTree&);  // Not implemented.
00097   void operator=(const vtkScalarTree&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkScaledTextActor.h Source File

Rendering/vtkScaledTextActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkScaledTextActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkScaledTextActor_h
00043 #define __vtkScaledTextActor_h
00044
00045 #include "vtkActor2D.h"
00046 #include "vtkTextMapper.h"
00047
00048 class VTK_RENDERING_EXPORT vtkScaledTextActor : public vtkActor2D
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkScaledTextActor,vtkActor2D);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   static vtkScaledTextActor *New();
00057
00059   void SetMapper(vtkTextMapper *mapper);
00060
00061   // Override superclass' SetMapper method and check type. This makes it possible
00062   // to use the virtual SetMapper call in Actor2D
00063   void SetMapper(vtkMapper2D *mapper);
00064
00066   vtkMapper2D *GetMapper(void);
00067
00069
00070   vtkSetVector2Macro(MinimumSize,int);
00071   vtkGetVector2Macro(MinimumSize,int);
00073
00075
00077   vtkSetMacro(MaximumLineHeight,float);
00078   vtkGetMacro(MaximumLineHeight,float);
00080
00083   void ShallowCopy(vtkProp *prop);
00084
00085 //BTX
00090   virtual void ReleaseGraphicsResources(vtkWindow *);
00091
00093
00096   int RenderOpaqueGeometry(vtkViewport* viewport);
00097   int RenderTranslucentGeometry(vtkViewport* ) {return 0;};
00098   int RenderOverlay(vtkViewport* viewport);
00100 //ETX
00101
00102 protected:
00103   vtkScaledTextActor();
00104   ~vtkScaledTextActor();
00105
00106   int MinimumSize[2];
00107   float MaximumLineHeight;
00108
00109   vtkActor2D *TextActor;
00110   vtkTimeStamp  BuildTime;
00111   int LastSize[2];
00112   int LastOrigin[2];
00113
00114 private:
00115   vtkScaledTextActor(const vtkScaledTextActor&);  // Not implemented.
00116   void operator=(const vtkScaledTextActor&);  // Not implemented.
00117 };
00118
00119
00120 #endif
00121
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSelectPolyData.h Source File

Graphics/vtkSelectPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSelectPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00092 #ifndef __vtkSelectPolyData_h
00093 #define __vtkSelectPolyData_h
00094
00095 #include "vtkPolyDataToPolyDataFilter.h"
00096
00097 #define VTK_INSIDE_SMALLEST_REGION 0
00098 #define VTK_INSIDE_LARGEST_REGION 1
00099 #define VTK_INSIDE_CLOSEST_POINT_REGION 2
00100
00101 class vtkCharArray;
00102
00103 class VTK_GRAPHICS_EXPORT vtkSelectPolyData : public vtkPolyDataToPolyDataFilter
00104 {
00105 public:
00109   static vtkSelectPolyData *New();
00110
00111   vtkTypeRevisionMacro(vtkSelectPolyData,vtkPolyDataToPolyDataFilter);
00112   void PrintSelf(ostream& os, vtkIndent indent);
00113
00115
00120   vtkSetMacro(GenerateSelectionScalars,int);
00121   vtkGetMacro(GenerateSelectionScalars,int);
00122   vtkBooleanMacro(GenerateSelectionScalars,int);
00124
00126
00128   vtkSetMacro(InsideOut,int);
00129   vtkGetMacro(InsideOut,int);
00130   vtkBooleanMacro(InsideOut,int);
00132
00134
00136   vtkSetObjectMacro(Loop,vtkPoints);
00137   vtkGetObjectMacro(Loop,vtkPoints);
00139
00141
00142   vtkSetClampMacro(SelectionMode,int,
00143              VTK_INSIDE_SMALLEST_REGION,VTK_INSIDE_CLOSEST_POINT_REGION);
00144   vtkGetMacro(SelectionMode,int);
00145   void SetSelectionModeToSmallestRegion()
00146     {this->SetSelectionMode(VTK_INSIDE_SMALLEST_REGION);};
00147   void SetSelectionModeToLargestRegion()
00148     {this->SetSelectionMode(VTK_INSIDE_LARGEST_REGION);};
00149   void SetSelectionModeToClosestPointRegion()
00150     {this->SetSelectionMode(VTK_INSIDE_CLOSEST_POINT_REGION);};
00151   const char *GetSelectionModeAsString();
00153
00155
00157   vtkSetMacro(GenerateUnselectedOutput,int);
00158   vtkGetMacro(GenerateUnselectedOutput,int);
00159   vtkBooleanMacro(GenerateUnselectedOutput,int);
00161
00164   vtkPolyData *GetUnselectedOutput() {return this->UnselectedOutput;};
00165
00167   vtkPolyData *GetSelectionEdges() {return this->SelectionEdges;};
00168
00169   // Overload GetMTime() because we depend on Loop
00170   unsigned long int GetMTime();
00171
00173   void UnRegister(vtkObject *o);
00174
00176   virtual int InRegisterLoop(vtkObject *);
00177
00178 protected:
00179   vtkSelectPolyData();
00180   ~vtkSelectPolyData();
00181
00182   void Execute();
00183
00184   int GenerateSelectionScalars;
00185   int InsideOut;
00186   vtkPoints *Loop;
00187   int SelectionMode;
00188   float ClosestPoint[3];
00189   int GenerateUnselectedOutput;
00190   vtkPolyData *UnselectedOutput;
00191   vtkPolyData *SelectionEdges;
00192
00193 private:
00194   vtkPolyData *Mesh;
00195   void GetPointNeighbors (vtkIdType ptId, vtkIdList *nei);
00196 private:
00197   vtkSelectPolyData(const vtkSelectPolyData&);  // Not implemented.
00198   void operator=(const vtkSelectPolyData&);  // Not implemented.
00199 };
00200
00202 inline const char *vtkSelectPolyData::GetSelectionModeAsString(void)
00203 {
00204   if ( this->SelectionMode == VTK_INSIDE_SMALLEST_REGION )
00205     {
00206     return "InsideSmallestRegion";
00207     }
00208   else if ( this->SelectionMode == VTK_INSIDE_LARGEST_REGION )
00209     {
00210     return "InsideLargestRegion";
00211     }
00212   else
00213     {
00214     return "InsideClosestPointRegion";
00215     }
00216 }
00217
00218 #endif
00219
00220
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkSelectVisiblePoints.h Source File

Rendering/vtkSelectVisiblePoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSelectVisiblePoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkSelectVisiblePoints_h
00062 #define __vtkSelectVisiblePoints_h
00063
00064 #include "vtkDataSetToPolyDataFilter.h"
00065 #include "vtkRenderer.h"
00066
00067 class VTK_RENDERING_EXPORT vtkSelectVisiblePoints : public vtkDataSetToPolyDataFilter
00068 {
00069 public:
00070   vtkTypeRevisionMacro(vtkSelectVisiblePoints,vtkDataSetToPolyDataFilter);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00075   static vtkSelectVisiblePoints *New();
00076
00078
00080   void SetRenderer(vtkRenderer* ren)
00081     {
00082       if (this->Renderer != ren)
00083         {
00084         this->Renderer = ren;
00085         this->Modified();
00086         }
00087     }
00088   vtkRenderer* GetRenderer() { return this->Renderer; }
00090
00092
00094   vtkSetMacro(SelectionWindow,int);
00095   vtkGetMacro(SelectionWindow,int);
00096   vtkBooleanMacro(SelectionWindow,int);
00098
00100
00102   vtkSetVector4Macro(Selection,int);
00103   vtkGetVectorMacro(Selection,int,4);
00105
00107
00109   vtkSetMacro(SelectInvisible,int);
00110   vtkGetMacro(SelectInvisible,int);
00111   vtkBooleanMacro(SelectInvisible,int);
00113
00115
00118   vtkSetClampMacro(Tolerance,float,0.0,VTK_LARGE_FLOAT);
00119   vtkGetMacro(Tolerance,float);
00121
00123   unsigned long GetMTime();
00124
00125 protected:
00126   vtkSelectVisiblePoints();
00127   ~vtkSelectVisiblePoints();
00128
00129   void Execute();
00130
00131   vtkRenderer *Renderer;
00132
00133   int SelectionWindow;
00134   int Selection[4];
00135   int SelectInvisible;
00136   float Tolerance;
00137
00138 private:
00139   vtkSelectVisiblePoints(const vtkSelectVisiblePoints&);  // Not implemented.
00140   void operator=(const vtkSelectVisiblePoints&);  // Not implemented.
00141 };
00142
00143 #endif
00144
00145
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkSetGet.h Source File

Common/vtkSetGet.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSetGet.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkSetGet_h
00039 #define __vtkSetGet_h
00040
00041 #include "vtkSystemIncludes.h"
00042 #include <math.h>
00043
00044 // Some constants used throughout the code
00045 #define VTK_LARGE_FLOAT 1.0e+38F
00046 #ifdef VTK_USE_64BIT_IDS
00047 #ifdef _WIN32
00048 #define VTK_LARGE_ID 9223372036854775807i64 // 2^63 - 1
00049 #else
00050 #define VTK_LARGE_ID 9223372036854775807LL // 2^63 - 1
00051 #endif
00052 #else
00053 #define VTK_LARGE_ID 2147483647 // 2^31 - 1
00054 #endif
00055
00056 #define VTK_LARGE_INTEGER 2147483647 // 2^31 - 1
00057
00058 // These types are returned by GetDataType to indicate pixel type.
00059 #define VTK_VOID            0
00060 #define VTK_BIT             1
00061 #define VTK_CHAR            2
00062 #define VTK_UNSIGNED_CHAR   3
00063 #define VTK_SHORT           4
00064 #define VTK_UNSIGNED_SHORT  5
00065 #define VTK_INT             6
00066 #define VTK_UNSIGNED_INT    7
00067 #define VTK_LONG            8
00068 #define VTK_UNSIGNED_LONG   9
00069 #define VTK_FLOAT          10
00070 #define VTK_DOUBLE         11
00071 #define VTK_ID_TYPE        12
00072
00073 // These types are not currently supported by GetDataType, but are
00074 // for completeness.
00075 #define VTK_STRING         13
00076 #define VTK_OPAQUE         14
00077
00078 // Some constant required for correct template performance
00079 #define VTK_BIT_MIN            0
00080 #define VTK_BIT_MAX            1
00081 #define VTK_CHAR_MIN          -128
00082 #define VTK_CHAR_MAX           127
00083 #define VTK_UNSIGNED_CHAR_MIN  0
00084 #define VTK_UNSIGNED_CHAR_MAX  255
00085 #define VTK_SHORT_MIN         -32768
00086 #define VTK_SHORT_MAX          32767
00087 #define VTK_UNSIGNED_SHORT_MIN 0
00088 #define VTK_UNSIGNED_SHORT_MAX 65535
00089 #define VTK_INT_MIN          (-VTK_LARGE_INTEGER-1)
00090 #define VTK_INT_MAX            VTK_LARGE_INTEGER
00091 #define VTK_UNSIGNED_INT_MIN   0
00092 #define VTK_UNSIGNED_INT_MAX   4294967295UL
00093 #define VTK_LONG_MIN         (-VTK_LARGE_INTEGER-1)
00094 #define VTK_LONG_MAX           VTK_LARGE_INTEGER
00095 #define VTK_UNSIGNED_LONG_MIN  0
00096 #define VTK_UNSIGNED_LONG_MAX  4294967295UL
00097 #define VTK_FLOAT_MIN         -VTK_LARGE_FLOAT
00098 #define VTK_FLOAT_MAX          VTK_LARGE_FLOAT
00099 #define VTK_DOUBLE_MIN        -1.0e+99L
00100 #define VTK_DOUBLE_MAX         1.0e+99L
00101
00102 // These types are returned to distinguish data object types
00103 #define VTK_POLY_DATA          0
00104 #define VTK_STRUCTURED_POINTS  1
00105 #define VTK_STRUCTURED_GRID    2
00106 #define VTK_RECTILINEAR_GRID   3
00107 #define VTK_UNSTRUCTURED_GRID  4
00108 #define VTK_PIECEWISE_FUNCTION 5
00109 #define VTK_IMAGE_DATA         6
00110 #define VTK_DATA_OBJECT        7
00111 #define VTK_DATA_SET           8
00112
00113 // These types define error codes for vtk functions
00114 #define VTK_OK                 1
00115 #define VTK_ERROR              2
00116
00117 // A macro to get the name of a type
00118 #define vtkImageScalarTypeNameMacro(type) \
00119 (((type) == VTK_VOID) ? "void" : \
00120 (((type) == VTK_FLOAT) ? "float" : \
00121 (((type) == VTK_INT) ? "int" : \
00122 (((type) == VTK_SHORT) ? "short" : \
00123 (((type) == VTK_UNSIGNED_SHORT) ? "unsigned short" : \
00124 (((type) == VTK_UNSIGNED_CHAR) ? "unsigned char" : \
00125 "Undefined"))))))
00126
00127
00128 //
00129 // Set built-in type.  Creates member Set"name"() (e.g., SetVisibility());
00130 //
00131 #define vtkSetMacro(name,type) \
00132 virtual void Set##name (type _arg) \
00133   { \
00134   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " #name " to " << _arg); \
00135   if (this->name != _arg) \
00136     { \
00137     this->name = _arg; \
00138     this->Modified(); \
00139     } \
00140   }
00141
00142 //
00143 // Get built-in type.  Creates member Get"name"() (e.g., GetVisibility());
00144 //
00145 #define vtkGetMacro(name,type) \
00146 virtual type Get##name () { \
00147   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " of " << this->name ); \
00148   return this->name; \
00149   }
00150
00151
00152 //
00153 // Set character string.  Creates member Set"name"()
00154 // (e.g., SetFilename(char *));
00155 //
00156 #define vtkSetStringMacro(name) \
00157 virtual void Set##name (const char* _arg) \
00158   { \
00159   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to " << _arg ); \
00160   if ( this->name == NULL && _arg == NULL) { return;} \
00161   if ( this->name && _arg && (!strcmp(this->name,_arg))) { return;} \
00162   if (this->name) { delete [] this->name; } \
00163   if (_arg) \
00164     { \
00165     this->name = new char[strlen(_arg)+1]; \
00166     strcpy(this->name,_arg); \
00167     } \
00168    else \
00169     { \
00170     this->name = NULL; \
00171     } \
00172   this->Modified(); \
00173   }
00174
00175 //
00176 // Get character string.  Creates member Get"name"()
00177 // (e.g., char *GetFilename());
00178 //
00179 #define vtkGetStringMacro(name) \
00180 virtual char* Get##name () { \
00181   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " of " << this->name); \
00182   return this->name; \
00183   }
00184
00185 //
00186 // Set built-in type where value is constrained between min/max limits.
00187 // Create member Set"name"() (eg., SetRadius()). #defines are
00188 // convenience for clamping open-ended values.
00189 // The Get"name"MinValue() and Get"name"MaxValue() members return the
00190 // min and max limits.
00191 //
00192 #define vtkSetClampMacro(name,type,min,max) \
00193 virtual void Set##name (type _arg) \
00194   { \
00195   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to " << _arg ); \
00196   if (this->name != (_arg<min?min:(_arg>max?max:_arg))) \
00197     { \
00198     this->name = (_arg<min?min:(_arg>max?max:_arg)); \
00199     this->Modified(); \
00200     } \
00201   } \
00202 virtual type Get##name##MinValue () \
00203   { \
00204   return min; \
00205   } \
00206 virtual type Get##name##MaxValue () \
00207   { \
00208   return max; \
00209   }
00210
00211 //
00212 // This macro defines a body of set object macro. It can be used either in
00213 // the header file vtkSetObjectMacro or in the implementation one
00214 // vtkSetObjectMacro. It sets the pointer to object; uses vtkObject
00215 // reference counting methodology. Creates method
00216 // Set"name"() (e.g., SetPoints()).
00217 //
00218 #define vtkSetObjectBodyMacro(name,type,args)                   \
00219   {                                                             \
00220   vtkDebugMacro(<< this->GetClassName() << " (" << this         \
00221                 << "): setting " << #name " to " << args );     \
00222   if (this->name != args)                                       \
00223     {                                                           \
00224     if (this->name != NULL) { this->name->UnRegister(this); }   \
00225     this->name = args;                                          \
00226     if (this->name != NULL) { this->name->Register(this); }     \
00227     this->Modified();                                           \
00228     }                                                           \
00229   }
00230
00231 //
00232 // Set pointer to object; uses vtkObject reference counting methodology.
00233 // Creates method Set"name"() (e.g., SetPoints()). This macro should
00234 // be used in the header file.
00235 //
00236 #define vtkSetObjectMacro(name,type)            \
00237 virtual void Set##name (type* _arg)             \
00238   {                                             \
00239   vtkSetObjectBodyMacro(name,type,_arg);        \
00240   }
00241
00242 //
00243 // Set pointer to object; uses vtkObject reference counting methodology.
00244 // Creates method Set"name"() (e.g., SetPoints()). This macro should
00245 // be used in the implementation file. You will also have to write
00246 // prototype in the header file. The prototype should look like this:
00247 // virtual void Set"name"("type" *);
00248 //
00249 // Please use vtkCxxSetObjectMacro not vtkSetObjectImplementationMacro.
00250 // The first one is just for people who already used it.
00251 #define vtkSetObjectImplementationMacro(class,name,type)        \
00252   vtkCxxSetObjectMacro(class,name,type)
00253
00254 #define vtkCxxSetObjectMacro(class,name,type)   \
00255 void class::Set##name (type* _arg)              \
00256   {                                             \
00257   vtkSetObjectBodyMacro(name,type,_arg);        \
00258   }
00259
00260 //
00261 // Get pointer to object.  Creates member Get"name" (e.g., GetPoints()).
00262 // This macro should be used in the header file.
00263 //
00264 #define vtkGetObjectMacro(name,type)                                    \
00265 virtual type *Get##name ()                                              \
00266   {                                                                     \
00267   vtkDebugMacro(<< this->GetClassName() << " (" << this                 \
00268                 << "): returning " #name " address " << this->name );   \
00269   return this->name;                                                    \
00270   }
00271
00272 //
00273 // Create members "name"On() and "name"Off() (e.g., DebugOn() DebugOff()).
00274 // Set method must be defined to use this macro.
00275 //
00276 #define vtkBooleanMacro(name,type) \
00277 virtual void name##On () { this->Set##name((type)1);}; \
00278 virtual void name##Off () { this->Set##name((type)0);}
00279
00280 //
00281 // Following set macros for vectors define two members for each macro.  The first
00282 // allows setting of individual components (e.g, SetColor(float,float,float)),
00283 // the second allows setting from an array (e.g., SetColor(float* rgb[3])).
00284 // The macros vary in the size of the vector they deal with.
00285 //
00286 #define vtkSetVector2Macro(name,type) \
00287 virtual void Set##name (type _arg1, type _arg2) \
00288   { \
00289   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << ")"); \
00290   if ((this->name[0] != _arg1)||(this->name[1] != _arg2)) \
00291     { \
00292     this->name[0] = _arg1; \
00293     this->name[1] = _arg2; \
00294     this->Modified(); \
00295     } \
00296   }; \
00297 void Set##name (type _arg[2]) \
00298   { \
00299   this->Set##name (_arg[0], _arg[1]); \
00300   }
00301
00302 #define vtkGetVector2Macro(name,type) \
00303 virtual type *Get##name () \
00304 { \
00305   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
00306   return this->name; \
00307 } \
00308 virtual void Get##name (type &_arg1, type &_arg2) \
00309   { \
00310     _arg1 = this->name[0]; \
00311     _arg2 = this->name[1]; \
00312   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << ")"); \
00313   }; \
00314 virtual void Get##name (type _arg[2]) \
00315   { \
00316   this->Get##name (_arg[0], _arg[1]);\
00317   }
00318
00319 #define vtkSetVector3Macro(name,type) \
00320 virtual void Set##name (type _arg1, type _arg2, type _arg3) \
00321   { \
00322   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << ")"); \
00323   if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)) \
00324     { \
00325     this->name[0] = _arg1; \
00326     this->name[1] = _arg2; \
00327     this->name[2] = _arg3; \
00328     this->Modified(); \
00329     } \
00330   }; \
00331 virtual void Set##name (type _arg[3]) \
00332   { \
00333   this->Set##name (_arg[0], _arg[1], _arg[2]);\
00334   }
00335
00336 #define vtkGetVector3Macro(name,type) \
00337 virtual type *Get##name () \
00338 { \
00339   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
00340   return this->name; \
00341 } \
00342 virtual void Get##name (type &_arg1, type &_arg2, type &_arg3) \
00343   { \
00344     _arg1 = this->name[0]; \
00345     _arg2 = this->name[1]; \
00346     _arg3 = this->name[2]; \
00347   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << ")"); \
00348   }; \
00349 virtual void Get##name (type _arg[3]) \
00350   { \
00351   this->Get##name (_arg[0], _arg[1], _arg[2]);\
00352   }
00353
00354 #define vtkSetVector4Macro(name,type) \
00355 virtual void Set##name (type _arg1, type _arg2, type _arg3, type _arg4) \
00356   { \
00357   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << ")"); \
00358   if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)||(this->name[3] != _arg4)) \
00359     { \
00360     this->name[0] = _arg1; \
00361     this->name[1] = _arg2; \
00362     this->name[2] = _arg3; \
00363     this->name[3] = _arg4; \
00364     this->Modified(); \
00365     } \
00366   }; \
00367 virtual void Set##name (type _arg[4]) \
00368   { \
00369   this->Set##name (_arg[0], _arg[1], _arg[2], _arg[3]);\
00370   }
00371
00372
00373 #define vtkGetVector4Macro(name,type) \
00374 virtual type *Get##name () \
00375 { \
00376   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
00377   return this->name; \
00378 } \
00379 virtual void Get##name (type &_arg1, type &_arg2, type &_arg3, type &_arg4) \
00380   { \
00381     _arg1 = this->name[0]; \
00382     _arg2 = this->name[1]; \
00383     _arg3 = this->name[2]; \
00384     _arg4 = this->name[3]; \
00385   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << ")"); \
00386   }; \
00387 virtual void Get##name (type _arg[4]) \
00388   { \
00389   this->Get##name (_arg[0], _arg[1], _arg[2], _arg[3]);\
00390   }
00391
00392 #define vtkSetVector6Macro(name,type) \
00393 virtual void Set##name (type _arg1, type _arg2, type _arg3, type _arg4, type _arg5, type _arg6) \
00394   { \
00395   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): setting " << #name " to (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << "," << _arg5 << "," << _arg6 << ")"); \
00396   if ((this->name[0] != _arg1)||(this->name[1] != _arg2)||(this->name[2] != _arg3)||(this->name[3] != _arg4)||(this->name[4] != _arg5)||(this->name[5] != _arg6)) \
00397     { \
00398     this->name[0] = _arg1; \
00399     this->name[1] = _arg2; \
00400     this->name[2] = _arg3; \
00401     this->name[3] = _arg4; \
00402     this->name[4] = _arg5; \
00403     this->name[5] = _arg6; \
00404     this->Modified(); \
00405     } \
00406   }; \
00407 virtual void Set##name (type _arg[6]) \
00408   { \
00409   this->Set##name (_arg[0], _arg[1], _arg[2], _arg[3], _arg[4], _arg[5]);\
00410   }
00411
00412 #define vtkGetVector6Macro(name,type) \
00413 virtual type *Get##name () \
00414 { \
00415   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
00416   return this->name; \
00417 } \
00418 virtual void Get##name (type &_arg1, type &_arg2, type &_arg3, type &_arg4, type &_arg5, type &_arg6) \
00419   { \
00420     _arg1 = this->name[0]; \
00421     _arg2 = this->name[1]; \
00422     _arg3 = this->name[2]; \
00423     _arg4 = this->name[3]; \
00424     _arg5 = this->name[4]; \
00425     _arg6 = this->name[5]; \
00426   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " = (" << _arg1 << "," << _arg2 << "," << _arg3 << "," << _arg4 << "," << _arg5 <<"," << _arg6 << ")"); \
00427   }; \
00428 virtual void Get##name (type _arg[6]) \
00429   { \
00430   this->Get##name (_arg[0], _arg[1], _arg[2], _arg[3], _arg[4], _arg[5]);\
00431   }
00432
00433 //
00434 // General set vector macro creates a single method that copies specified
00435 // number of values into object.
00436 // Examples: void SetColor(c,3)
00437 //
00438 #define vtkSetVectorMacro(name,type,count) \
00439 virtual void Set##name(type data[]) \
00440 { \
00441   int i; \
00442   for (i=0; i<count; i++) { if ( data[i] != this->name[i] ) { break; }} \
00443   if ( i < count ) \
00444     { \
00445     for (i=0; i<count; i++) { this->name[i] = data[i]; }\
00446     this->Modified(); \
00447     } \
00448 }
00449
00450 //
00451 // Get vector macro defines two methods. One returns pointer to type
00452 // (i.e., array of type). This is for efficiency. The second copies data
00453 // into user provided array. This is more object-oriented.
00454 // Examples: float *GetColor() and void GetColor(float c[count]).
00455 //
00456 #define vtkGetVectorMacro(name,type,count) \
00457 virtual type *Get##name () \
00458 { \
00459   vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " << #name " pointer " << this->name); \
00460   return this->name; \
00461 } \
00462 virtual void Get##name (type data[count]) \
00463 { \
00464   for (int i=0; i<count; i++) { data[i] = this->name[i]; }\
00465 }
00466
00467 // Use a global function which actually calls:
00468 //  vtkOutputWindow::GetInstance()->DisplayText();
00469 // This is to avoid vtkObject #include of vtkOutputWindow
00470 // while vtkOutputWindow #includes vtkObject
00471
00472 extern VTK_COMMON_EXPORT void vtkOutputWindowDisplayText(const char*);
00473 extern VTK_COMMON_EXPORT void vtkOutputWindowDisplayErrorText(const char*);
00474 extern VTK_COMMON_EXPORT void vtkOutputWindowDisplayWarningText(const char*);
00475 extern VTK_COMMON_EXPORT void vtkOutputWindowDisplayGenericWarningText(const char*);
00476 extern VTK_COMMON_EXPORT void vtkOutputWindowDisplayDebugText(const char*);
00477
00478 //
00479 // This macro is used for any output that may not be in an instance method
00480 // vtkGenericWarningMacro(<< "this is debug info" << this->SomeVariable);
00481 //
00482 #define vtkGenericWarningMacro(x) \
00483 { if (vtkObject::GetGlobalWarningDisplay()) { \
00484       char *vtkmsgbuff; ostrstream vtkmsg; \
00485       vtkmsg << "Generic Warning: In " __FILE__ ", line " << __LINE__ << "\n" x \
00486       << "\n\n" << ends; \
00487       vtkmsgbuff = vtkmsg.str(); \
00488       vtkOutputWindowDisplayGenericWarningText(vtkmsgbuff);\
00489       vtkmsg.rdbuf()->freeze(0);}}
00490
00491 //
00492 // This macro is used for  debug statements in instance methods
00493 // vtkDebugMacro(<< "this is debug info" << this->SomeVariable);
00494 //
00495 #ifdef VTK_LEAN_AND_MEAN
00496 #define vtkDebugMacro(x)
00497 #else
00498 #define vtkDebugMacro(x) \
00499 { if (this->Debug && vtkObject::GetGlobalWarningDisplay()) \
00500     { char *vtkmsgbuff; \
00501       ostrstream vtkmsg; \
00502       vtkmsg << "Debug: In " __FILE__ ", line " << __LINE__ << "\n" << this->GetClassName() << " (" << this << "): " x  << "\n\n" << ends; \
00503       vtkmsgbuff = vtkmsg.str(); \
00504       vtkOutputWindowDisplayDebugText(vtkmsgbuff);\
00505       vtkmsg.rdbuf()->freeze(0);}}
00506 #endif
00507 //
00508 // This macro is used to print out warning messages.
00509 // vtkWarningMacro(<< "Warning message" << variable);
00510 //
00511 #define vtkWarningMacro(x)                      \
00512    vtkWarningWithObjectMacro(this,x)
00513
00514 //
00515 // This macro is used to print out errors
00516 // vtkErrorMacro(<< "Error message" << variable);
00517 //
00518 #define vtkErrorMacro(x)                        \
00519    vtkErrorWithObjectMacro(this,x)
00520
00521 //
00522 // This macro is used to print out errors
00523 // vtkErrorWithObjectMacro(self, << "Error message" << variable);
00524 //
00525 #define vtkErrorWithObjectMacro(self, x)                        \
00526    {                                                            \
00527    if (vtkObject::GetGlobalWarningDisplay())                    \
00528      {                                                          \
00529      char *vtkmsgbuff;                                          \
00530      ostrstream vtkmsg;                                         \
00531      vtkmsg << "ERROR: In " __FILE__ ", line " << __LINE__      \
00532             << "\n" << self->GetClassName() << " (" << self     \
00533             << "): " x << "\n\n" << ends;                       \
00534      vtkmsgbuff = vtkmsg.str();                                 \
00535      if ( self->HasObserver("ErrorEvent") )                     \
00536        {                                                        \
00537        self->InvokeEvent("ErrorEvent", vtkmsg.str());           \
00538        }                                                        \
00539      else                                                       \
00540        {                                                        \
00541        vtkOutputWindowDisplayErrorText(vtkmsgbuff);             \
00542        }                                                        \
00543      vtkmsg.rdbuf()->freeze(0); vtkObject::BreakOnError();      \
00544      }                                                          \
00545    }
00546
00547 //
00548 // This macro is used to print out warnings
00549 // vtkWarningWithObjectMacro(self, "Warning message" << variable);
00550 //
00551 #define vtkWarningWithObjectMacro(self, x)                      \
00552    {                                                            \
00553    if (vtkObject::GetGlobalWarningDisplay())                    \
00554      {                                                          \
00555      char *vtkmsgbuff;                                          \
00556      ostrstream vtkmsg;                                         \
00557      vtkmsg << "Warning: In " __FILE__ ", line " << __LINE__    \
00558             << "\n" << self->GetClassName() << " (" << self     \
00559             << "): " x << "\n\n" << ends;                       \
00560      vtkmsgbuff = vtkmsg.str();                                 \
00561      if ( self->HasObserver("WarningEvent") )                   \
00562        {                                                        \
00563        self->InvokeEvent("WarningEvent", vtkmsg.str());         \
00564        }                                                        \
00565      else                                                       \
00566        {                                                        \
00567        vtkOutputWindowDisplayWarningText(vtkmsgbuff);           \
00568        }                                                        \
00569      vtkmsg.rdbuf()->freeze(0);                                 \
00570      }                                                          \
00571    }
00572
00573
00574
00575 //
00576 // This macro is used to quiet compiler warnings about unused parameters
00577 // to methods. Only use it when the parameter really shouldn't be used.
00578 // Don't use it as a way to shut up the compiler while you take your
00579 // sweet time getting around to implementing the method.
00580 //
00581 #define vtkNotUsed(x)
00582
00583 #define vtkWorldCoordinateMacro(name) \
00584 virtual vtkCoordinate *Get##name##Coordinate () \
00585 { \
00586     vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " #name "Coordinate address " << this->name##Coordinate ); \
00587     return this->name##Coordinate; \
00588 } \
00589 virtual void Set##name(float x[3]) {this->Set##name(x[0],x[1],x[2]);}; \
00590 virtual void Set##name(float x, float y, float z) \
00591 { \
00592     this->name##Coordinate->SetValue(x,y,z); \
00593 } \
00594 virtual float *Get##name() \
00595 { \
00596     return this->name##Coordinate->GetValue(); \
00597 }
00598
00599 #define vtkViewportCoordinateMacro(name) \
00600 virtual vtkCoordinate *Get##name##Coordinate () \
00601 { \
00602     vtkDebugMacro(<< this->GetClassName() << " (" << this << "): returning " #name "Coordinate address " << this->name##Coordinate ); \
00603     return this->name##Coordinate; \
00604 } \
00605 virtual void Set##name(float x[2]) {this->Set##name(x[0],x[1]);}; \
00606 virtual void Set##name(float x, float y) \
00607 { \
00608     this->name##Coordinate->SetValue(x,y); \
00609 } \
00610 virtual float *Get##name() \
00611 { \
00612     return this->name##Coordinate->GetValue(); \
00613 }
00614
00615 // Macro used to determine whether a class is the same class or
00616 // a subclass of the named class.
00617 //
00618 #define vtkTypeMacro(thisClass,superclass) \
00619   typedef superclass Superclass; \
00620   virtual const char *GetClassName() {return #thisClass;} \
00621   static int IsTypeOf(const char *type) \
00622   { \
00623     if ( !strcmp(#thisClass,type) ) \
00624       { \
00625       return 1; \
00626       } \
00627     return superclass::IsTypeOf(type); \
00628   } \
00629   virtual int IsA(const char *type) \
00630   { \
00631     return this->thisClass::IsTypeOf(type); \
00632   } \
00633   static thisClass* SafeDownCast(vtkObject *o) \
00634   { \
00635     if ( o && o->IsA(#thisClass) ) \
00636       { \
00637       return (thisClass *)o; \
00638       } \
00639     return NULL;\
00640   }
00641
00642 // Version of vtkTypeMacro that adds the CollectRevisions method.
00643 #define vtkTypeRevisionMacro(thisClass,superclass) \
00644   protected: \
00645   void CollectRevisions(ostream& os); \
00646   public: \
00647   vtkTypeMacro(thisClass,superclass)
00648
00649 // Macro to implement the standard CollectRevisions method.
00650 #define vtkCxxRevisionMacro(thisClass, revision) \
00651   void thisClass::CollectRevisions(ostream& os) \
00652   { \
00653     this->Superclass::CollectRevisions(os); \
00654     os << #thisClass " " revision "\n"; \
00655   }
00656
00657 // Macro to implement the standard form of the New() method.
00658 #define vtkStandardNewMacro(thisClass) \
00659   thisClass* thisClass::New() \
00660   { \
00661     vtkObject* ret = vtkObjectFactory::CreateInstance(#thisClass); \
00662     if(ret) \
00663       { \
00664       return static_cast<thisClass*>(ret); \
00665       } \
00666     return new thisClass; \
00667   }
00668
00669 // The following macros are all just there to centralize the template
00670 // switch code so that every execute method doesn't have to have the same
00671 // long list if case statements
00672
00673 #define vtkTemplateMacro3(func, arg1, arg2, arg3) \
00674       case VTK_DOUBLE: \
00675         { typedef double VTK_TT; \
00676         func(arg1, arg2, arg3); } \
00677         break; \
00678       case VTK_FLOAT: \
00679         { typedef float VTK_TT; \
00680         func(arg1, arg2, arg3); } \
00681         break; \
00682       case VTK_LONG: \
00683         { typedef long VTK_TT; \
00684         func(arg1, arg2, arg3); } \
00685         break; \
00686       case VTK_UNSIGNED_LONG: \
00687         { typedef unsigned long VTK_TT; \
00688         func(arg1, arg2, arg3); } \
00689         break; \
00690       case VTK_INT: \
00691         { typedef int VTK_TT; \
00692         func(arg1, arg2, arg3); } \
00693         break; \
00694       case VTK_UNSIGNED_INT: \
00695         { typedef unsigned int VTK_TT; \
00696         func(arg1, arg2, arg3); } \
00697         break; \
00698       case VTK_SHORT: \
00699         { typedef short VTK_TT; \
00700         func(arg1, arg2, arg3); } \
00701         break; \
00702       case VTK_UNSIGNED_SHORT: \
00703         { typedef unsigned short VTK_TT; \
00704         func(arg1, arg2, arg3); } \
00705         break; \
00706       case VTK_CHAR: \
00707         { typedef char VTK_TT; \
00708         func(arg1, arg2, arg3); } \
00709         break; \
00710       case VTK_UNSIGNED_CHAR: \
00711         { typedef unsigned char VTK_TT; \
00712         func(arg1, arg2, arg3); } \
00713         break
00714
00715 #define vtkTemplateMacro4(func, arg1, arg2, arg3, arg4) \
00716       case VTK_DOUBLE: \
00717         { typedef double VTK_TT; \
00718         func(arg1, arg2, arg3, arg4); } \
00719         break; \
00720       case VTK_FLOAT: \
00721         { typedef float VTK_TT; \
00722         func(arg1, arg2, arg3, arg4); } \
00723         break; \
00724       case VTK_LONG: \
00725         { typedef long VTK_TT; \
00726         func(arg1, arg2, arg3, arg4); } \
00727         break; \
00728       case VTK_UNSIGNED_LONG: \
00729         { typedef unsigned long VTK_TT; \
00730         func(arg1, arg2, arg3, arg4); } \
00731         break; \
00732       case VTK_INT: \
00733         { typedef int VTK_TT; \
00734         func(arg1, arg2, arg3, arg4); } \
00735         break; \
00736       case VTK_UNSIGNED_INT: \
00737         { typedef unsigned int VTK_TT; \
00738         func(arg1, arg2, arg3, arg4); } \
00739         break; \
00740       case VTK_SHORT: \
00741         { typedef short VTK_TT; \
00742         func(arg1, arg2, arg3, arg4); } \
00743         break; \
00744       case VTK_UNSIGNED_SHORT: \
00745         { typedef unsigned short VTK_TT; \
00746         func(arg1, arg2, arg3, arg4); } \
00747         break; \
00748       case VTK_CHAR: \
00749         { typedef char VTK_TT; \
00750         func(arg1, arg2, arg3, arg4); } \
00751         break; \
00752       case VTK_UNSIGNED_CHAR: \
00753         { typedef unsigned char VTK_TT; \
00754         func(arg1, arg2, arg3, arg4); } \
00755         break
00756
00757 #define vtkTemplateMacro5(func, arg1, arg2, arg3, arg4, arg5) \
00758       case VTK_DOUBLE: \
00759         { typedef double VTK_TT; \
00760         func(arg1, arg2, arg3, arg4, arg5); } \
00761         break; \
00762       case VTK_FLOAT: \
00763         { typedef float VTK_TT; \
00764         func(arg1, arg2, arg3, arg4, arg5); } \
00765         break; \
00766       case VTK_LONG: \
00767         { typedef long VTK_TT; \
00768         func(arg1, arg2, arg3, arg4, arg5); } \
00769         break; \
00770       case VTK_UNSIGNED_LONG: \
00771         { typedef unsigned long VTK_TT; \
00772         func(arg1, arg2, arg3, arg4, arg5); } \
00773         break; \
00774       case VTK_INT: \
00775         { typedef int VTK_TT; \
00776         func(arg1, arg2, arg3, arg4, arg5); } \
00777         break; \
00778       case VTK_UNSIGNED_INT: \
00779         { typedef unsigned int VTK_TT; \
00780         func(arg1, arg2, arg3, arg4, arg5); } \
00781         break; \
00782       case VTK_SHORT: \
00783         { typedef short VTK_TT; \
00784         func(arg1, arg2, arg3, arg4, arg5); } \
00785         break; \
00786       case VTK_UNSIGNED_SHORT: \
00787         { typedef unsigned short VTK_TT; \
00788         func(arg1, arg2, arg3, arg4, arg5); } \
00789         break; \
00790       case VTK_CHAR: \
00791         { typedef char VTK_TT; \
00792         func(arg1, arg2, arg3, arg4, arg5); } \
00793         break; \
00794       case VTK_UNSIGNED_CHAR: \
00795         { typedef unsigned char VTK_TT; \
00796         func(arg1, arg2, arg3, arg4, arg5); } \
00797         break
00798
00799 #define vtkTemplateMacro6(func, arg1, arg2, arg3, arg4, arg5, arg6) \
00800       case VTK_DOUBLE: \
00801         { typedef double VTK_TT; \
00802         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00803         break; \
00804       case VTK_FLOAT: \
00805         { typedef float VTK_TT; \
00806         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00807         break; \
00808       case VTK_LONG: \
00809         { typedef long VTK_TT; \
00810         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00811         break; \
00812       case VTK_UNSIGNED_LONG: \
00813         { typedef unsigned long VTK_TT; \
00814         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00815         break; \
00816       case VTK_INT: \
00817         { typedef int VTK_TT; \
00818         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00819         break; \
00820       case VTK_UNSIGNED_INT: \
00821         { typedef unsigned int VTK_TT; \
00822         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00823         break; \
00824       case VTK_SHORT: \
00825         { typedef short VTK_TT; \
00826         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00827         break; \
00828       case VTK_UNSIGNED_SHORT: \
00829         { typedef unsigned short VTK_TT; \
00830         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00831         break; \
00832       case VTK_CHAR: \
00833         { typedef char VTK_TT; \
00834         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00835         break; \
00836       case VTK_UNSIGNED_CHAR: \
00837         { typedef unsigned char VTK_TT; \
00838         func(arg1, arg2, arg3, arg4, arg5, arg6); } \
00839         break
00840
00841 #define vtkTemplateMacro7(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7) \
00842       case VTK_DOUBLE: \
00843         { typedef double VTK_TT; \
00844         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00845         break; \
00846       case VTK_FLOAT: \
00847         { typedef float VTK_TT; \
00848         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00849         break; \
00850       case VTK_LONG: \
00851         { typedef long VTK_TT; \
00852         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00853         break; \
00854       case VTK_UNSIGNED_LONG: \
00855         { typedef unsigned long VTK_TT; \
00856         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00857         break; \
00858       case VTK_INT: \
00859         { typedef int VTK_TT; \
00860         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00861         break; \
00862       case VTK_UNSIGNED_INT: \
00863         { typedef unsigned int VTK_TT; \
00864         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00865         break; \
00866       case VTK_SHORT: \
00867         { typedef short VTK_TT; \
00868         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00869         break; \
00870       case VTK_UNSIGNED_SHORT: \
00871         { typedef unsigned short VTK_TT; \
00872         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00873         break; \
00874       case VTK_CHAR: \
00875         { typedef char VTK_TT; \
00876         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00877         break; \
00878       case VTK_UNSIGNED_CHAR: \
00879         { typedef unsigned char VTK_TT; \
00880         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7); } \
00881         break
00882
00883 #define vtkTemplateMacro8(func, arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8) \
00884       case VTK_DOUBLE: \
00885         { typedef double VTK_TT; \
00886         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00887         break; \
00888       case VTK_FLOAT: \
00889         { typedef float VTK_TT; \
00890         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00891         break; \
00892       case VTK_LONG: \
00893         { typedef long VTK_TT; \
00894         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00895         break; \
00896       case VTK_UNSIGNED_LONG: \
00897         { typedef unsigned long VTK_TT; \
00898         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00899         break; \
00900       case VTK_INT: \
00901         { typedef int VTK_TT; \
00902         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00903         break; \
00904       case VTK_UNSIGNED_INT: \
00905         { typedef unsigned int VTK_TT; \
00906         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00907         break; \
00908       case VTK_SHORT: \
00909         { typedef short VTK_TT; \
00910         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00911         break; \
00912       case VTK_UNSIGNED_SHORT: \
00913         { typedef unsigned short VTK_TT; \
00914         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00915         break; \
00916       case VTK_CHAR: \
00917         { typedef char VTK_TT; \
00918         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00919         break; \
00920       case VTK_UNSIGNED_CHAR: \
00921         { typedef unsigned char VTK_TT; \
00922         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8); } \
00923         break
00924
00925 #define vtkTemplateMacro9(func,arg1,arg2,arg3,arg4,arg5,arg6,arg7,arg8,arg9) \
00926       case VTK_DOUBLE: \
00927         { typedef double VTK_TT; \
00928         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00929         break; \
00930       case VTK_FLOAT: \
00931         { typedef float VTK_TT; \
00932         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00933         break; \
00934       case VTK_LONG: \
00935         { typedef long VTK_TT; \
00936         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00937         break; \
00938       case VTK_UNSIGNED_LONG: \
00939         { typedef unsigned long VTK_TT; \
00940         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00941         break; \
00942       case VTK_INT: \
00943         { typedef int VTK_TT; \
00944         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00945         break; \
00946       case VTK_UNSIGNED_INT: \
00947         { typedef unsigned int VTK_TT; \
00948         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00949         break; \
00950       case VTK_SHORT: \
00951         { typedef short VTK_TT; \
00952         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00953         break; \
00954       case VTK_UNSIGNED_SHORT: \
00955         { typedef unsigned short VTK_TT; \
00956         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00957         break; \
00958       case VTK_CHAR: \
00959         { typedef char VTK_TT; \
00960         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00961         break; \
00962       case VTK_UNSIGNED_CHAR: \
00963         { typedef unsigned char VTK_TT; \
00964         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9); } \
00965         break
00966
00967 #define vtkTemplateMacro10(func,arg1,arg2,arg3,arg4,arg5,arg6,arg7,arg8,arg9,arg10) \
00968       case VTK_DOUBLE: \
00969         { typedef double VTK_TT; \
00970         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00971         break; \
00972       case VTK_FLOAT: \
00973         { typedef float VTK_TT; \
00974         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00975         break; \
00976       case VTK_LONG: \
00977         { typedef long VTK_TT; \
00978         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00979         break; \
00980       case VTK_UNSIGNED_LONG: \
00981         { typedef unsigned long VTK_TT; \
00982         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00983         break; \
00984       case VTK_INT: \
00985         { typedef int VTK_TT; \
00986         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00987         break; \
00988       case VTK_UNSIGNED_INT: \
00989         { typedef unsigned int VTK_TT; \
00990         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00991         break; \
00992       case VTK_SHORT: \
00993         { typedef short VTK_TT; \
00994         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00995         break; \
00996       case VTK_UNSIGNED_SHORT: \
00997         { typedef unsigned short VTK_TT; \
00998         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
00999         break; \
01000       case VTK_CHAR: \
01001         { typedef char VTK_TT; \
01002         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
01003         break; \
01004       case VTK_UNSIGNED_CHAR: \
01005         { typedef unsigned char VTK_TT; \
01006         func(arg1, arg2, arg3, arg4, arg5, arg6, arg7, arg8, arg9, arg10); } \
01007         break
01008
01009 // Use to mark methods legacy. Make sure the correct date is used to
01010 // keep track of when a method was made legacy, and so that it can be
01011 // eliminated at the right time.
01012 #ifndef VTK_LEAN_AND_MEAN
01013 #define VTK_LEGACY_METHOD(oldMethod,versionStringMadeLegacy) \
01014   vtkErrorMacro(<< #oldMethod \
01015                 << " was obsoleted for version " << #versionStringMadeLegacy \
01016                 << " and will be removed in a future version");
01017 #else
01018 #define VTK_LEGACY_METHOD(oldMethod,versionStringMadeLegacy)
01019 #endif
01020
01021
01022 #endif
01023
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkSharedMemoryCommunicator.h Source File

Parallel/vtkSharedMemoryCommunicator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSharedMemoryCommunicator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkSharedMemoryCommunicator_h
00044 #define __vtkSharedMemoryCommunicator_h
00045
00046 #include "vtkCommunicator.h"
00047 #include "vtkMultiProcessController.h"
00048 #include "vtkCriticalSection.h"
00049
00050 class vtkThreadedController;
00051 class vtkSharedMemoryCommunicatorMessage;
00052
00053 class VTK_PARALLEL_EXPORT vtkSharedMemoryCommunicator : public vtkCommunicator
00054 {
00055
00056 public:
00057
00058   vtkTypeRevisionMacro( vtkSharedMemoryCommunicator,vtkObject);
00059
00061   static vtkSharedMemoryCommunicator* New();
00062
00063   virtual void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00068   virtual int Send(int* data, int length, int remoteThreadId, int tag);
00069   virtual int Send(unsigned long* data, int length, int remoteThreadId,
00070                    int tag);
00071   virtual int Send(char* data, int length, int remoteThreadId, int tag);
00072   virtual int Send(unsigned char* data, int length, int remoteThreadId, int tag);
00073   virtual int Send(float* data, int length, int remoteThreadId, int tag);
00074   virtual int Send(double* data, int length, int remoteThreadId, int tag);
00075 #ifdef VTK_USE_64BIT_IDS
00076   virtual int Send(vtkIdType* data, int length, int remoteThreadId, int tag);
00078 #endif
00079   virtual int Send(vtkDataObject* data, int remoteThreadId, int tag);
00080   virtual int Send(vtkDataArray* data, int remoteThreadId, int tag);
00081
00083
00086   virtual int Receive(int* data, int length, int remoteThreadId,
00087                       int tag);
00088   virtual int Receive(unsigned long* data, int length,
00089                       int remoteThreadId, int tag);
00090   virtual int Receive(char* data, int length, int remoteThreadId,
00091                       int tag);
00092   virtual int Receive(unsigned char* data, int length, int remoteThreadId,
00093                       int tag);
00094   virtual int Receive(float* data, int length, int remoteThreadId,
00095                       int tag);
00096   virtual int Receive(double* data, int length, int remoteThreadId,
00097                       int tag);
00098 #ifdef VTK_USE_64BIT_IDS
00099   virtual int Receive(vtkIdType* data, int length, int remoteThreadId,
00100                       int tag);
00102 #endif
00103   virtual int Receive(vtkDataObject *data, int remoteThreadId, int tag);
00104   virtual int Receive(vtkDataArray *data, int remoteThreadId, int tag);
00105
00106 //BTX
00107
00108   friend class vtkThreadedController;
00109
00110 //ETX
00111
00112 protected:
00113
00114   int NumberOfThreads;
00115   int Initialized;
00116   void Initialize(int nThreads, int forceDeepCopy);
00117
00118   int LocalThreadId;
00119   int WaitingForId;
00120
00121   int ForceDeepCopy;
00122
00123   // It is not enough to block on the messages, we have to mutex
00124   // the whole send interaction.  I was trying to avoid a central
00125   // mutex (oh well).
00126   vtkSimpleCriticalSection* MessageListLock;
00127
00128
00129   // Each thread has its own communicator.
00130   vtkSharedMemoryCommunicator** Communicators;
00131
00132   vtkSharedMemoryCommunicator* Parent;
00133
00134   // Double linked list.
00135   vtkSharedMemoryCommunicatorMessage *MessageListStart;
00136   vtkSharedMemoryCommunicatorMessage *MessageListEnd;
00137
00138   vtkSharedMemoryCommunicator();
00139   ~vtkSharedMemoryCommunicator();
00140
00141   // The generic send and receive methods.
00142   int Send(vtkDataObject* object, void *data, int dataLength,
00143            int remoteThreadId, int tag);
00144   int Receive(vtkDataObject* object, void *data, int dataLength,
00145               int remoteThreadId, int tag);
00146
00147   int Send(vtkDataArray* object, int dataLength,
00148            int remoteThreadId, int tag);
00149   int Receive(vtkDataArray* object, int dataLength,
00150               int remoteThreadId, int tag);
00151
00152   vtkSharedMemoryCommunicatorMessage* NewMessage(vtkDataObject* object,
00153                                                  void* data,
00154                                                  int dataLength);
00155   vtkSharedMemoryCommunicatorMessage* NewMessage(vtkDataArray* object,
00156                                                  void* data,
00157                                                  int dataLength);
00158   void DeleteMessage(vtkSharedMemoryCommunicatorMessage *message);
00159   void AddMessage(vtkSharedMemoryCommunicatorMessage *message);
00160   vtkSharedMemoryCommunicatorMessage* FindMessage(int sendId, int tag);
00161
00162 #ifdef _WIN32
00163   // Event signaling the arrival of a new message.
00164   // Windows implementation only.
00165   HANDLE MessageSignal;
00166 #else
00167   // This mutex is normally locked.  It is used to block the execution
00168   // of the receiving process when the send has not been called yet.
00169   vtkSimpleCriticalSection* Gate;
00170 #endif
00171
00172   void SignalNewMessage(vtkSharedMemoryCommunicator* receiveCommunicator)
00173     {
00174 #ifdef _WIN32
00175     SetEvent( receiveCommunicator->MessageSignal );
00176 #else
00177     receiveCommunicator->Gate->Unlock();
00178 #endif
00179     }
00180
00181   void WaitForNewMessage()
00182     {
00183 #ifdef _WIN32
00184       WaitForSingleObject( this->MessageSignal, INFINITE );
00185 #else
00186       this->Gate->Lock();
00187 #endif
00188     }
00189
00190 private:
00191   vtkSharedMemoryCommunicator(const vtkSharedMemoryCommunicator&);  // Not implemented.
00192   void operator=(const vtkSharedMemoryCommunicator&);  // Not implemented.
00193 };
00194
00195 #endif //  __vtkSharedMemoryCommunicator_h
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkShepardMethod.h Source File

Imaging/vtkShepardMethod.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkShepardMethod.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkShepardMethod_h
00055 #define __vtkShepardMethod_h
00056
00057 #include "vtkDataSetToStructuredPointsFilter.h"
00058
00059 class VTK_IMAGING_EXPORT vtkShepardMethod : public vtkDataSetToStructuredPointsFilter
00060 {
00061 public:
00062   vtkTypeRevisionMacro(vtkShepardMethod,vtkDataSetToStructuredPointsFilter);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00068   static vtkShepardMethod *New();
00069
00071   float ComputeModelBounds(float origin[3], float ar[3]);
00072
00074
00075   vtkGetVectorMacro(SampleDimensions,int,3);
00077
00079   void SetSampleDimensions(int i, int j, int k);
00080
00082   void SetSampleDimensions(int dim[3]);
00083
00085
00090   vtkSetClampMacro(MaximumDistance,float,0.0,1.0);
00091   vtkGetMacro(MaximumDistance,float);
00093
00095
00096   vtkSetVector6Macro(ModelBounds,float);
00097   vtkGetVectorMacro(ModelBounds,float,6);
00099
00101
00103   vtkSetMacro(NullValue,float);
00104   vtkGetMacro(NullValue,float);
00106
00107 protected:
00108   vtkShepardMethod();
00109   ~vtkShepardMethod() {};
00110
00111   void Execute();
00112
00113   int SampleDimensions[3];
00114   float MaximumDistance;
00115   float ModelBounds[6];
00116   float NullValue;
00117 private:
00118   vtkShepardMethod(const vtkShepardMethod&);  // Not implemented.
00119   void operator=(const vtkShepardMethod&);  // Not implemented.
00120 };
00121
00122 #endif
00123
00124
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkShortArray.h Source File

Common/vtkShortArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkShortArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkShortArray_h
00042 #define __vtkShortArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkShortArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkShortArray *New();
00050
00051   vtkTypeRevisionMacro(vtkShortArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   vtkDataArray *MakeObject();
00063
00065   int GetDataType() {return VTK_SHORT;};
00066
00068   int GetDataTypeSize() { return sizeof(short); }
00069
00071   void SetNumberOfTuples(const vtkIdType number);
00072
00075   float *GetTuple(const vtkIdType i);
00076
00078
00079   void GetTuple(const vtkIdType i, float * tuple);
00080   void GetTuple(const vtkIdType i, double * tuple);
00082
00084
00085   void SetTuple(const vtkIdType i, const float * tuple);
00086   void SetTuple(const vtkIdType i, const double * tuple);
00088
00090
00092   void InsertTuple(const vtkIdType i, const float * tuple);
00093   void InsertTuple(const vtkIdType i, const double * tuple);
00095
00097
00099   vtkIdType InsertNextTuple(const float * tuple);
00100   vtkIdType InsertNextTuple(const double * tuple);
00102
00104   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00105
00107   virtual void Resize(vtkIdType numTuples);
00108
00112   float GetComponent(const vtkIdType i, const int j);
00113
00118   void SetComponent(const vtkIdType i, const int j, const float c);
00119
00123   void InsertComponent(const vtkIdType i, const int j, const float c);
00124
00126   short GetValue(const vtkIdType id) {return this->Array[id];};
00127
00129
00131   void SetValue(const vtkIdType id, const short value)
00132     {this->Array[id] = value;};
00134
00138   void SetNumberOfValues(const vtkIdType number);
00139
00141   void InsertValue(const vtkIdType id, const short i);
00142
00145   vtkIdType InsertNextValue(const short);
00146
00150   short *WritePointer(const vtkIdType id, const vtkIdType number);
00151
00153
00155   void *GetVoidPointer(const vtkIdType id)
00156     {return (void *)this->GetPointer(id);};
00157   short *GetPointer(const vtkIdType id) {return this->Array + id;}
00159
00161   void DeepCopy(vtkDataArray *da);
00162
00164
00170   void SetArray(short* array, vtkIdType size, int save);
00171   void SetVoidArray(void *array, vtkIdType size, int save)
00172     {this->SetArray((short*)array, size, save);};
00174
00175 protected:
00176   vtkShortArray(vtkIdType numComp=1);
00177   ~vtkShortArray();
00178
00179   short *Array;   // pointer to data
00180   short *ResizeAndExtend(const vtkIdType sz);  // function to resize data
00181
00182   int TupleSize; //used for data conversion
00183   float *Tuple;
00184
00185   int SaveUserArray;
00186 private:
00187   vtkShortArray(const vtkShortArray&);  // Not implemented.
00188   void operator=(const vtkShortArray&);  // Not implemented.
00189 };
00190
00191 inline void vtkShortArray::SetNumberOfValues(const vtkIdType number)
00192 {
00193   this->Allocate(number);
00194   this->MaxId = number - 1;
00195 }
00196
00197
00198 inline short *vtkShortArray::WritePointer(const vtkIdType id,
00199                                           const vtkIdType number)
00200 {
00201   vtkIdType newSize=id+number;
00202   if ( newSize > this->Size )
00203     {
00204     this->ResizeAndExtend(newSize);
00205     }
00206   if ( (--newSize) > this->MaxId )
00207     {
00208     this->MaxId = newSize;
00209     }
00210   return this->Array + id;
00211 }
00212
00213 inline void vtkShortArray::InsertValue(const vtkIdType id, const short i)
00214 {
00215   if ( id >= this->Size )
00216     {
00217     this->ResizeAndExtend(id+1);
00218     }
00219   this->Array[id] = i;
00220   if ( id > this->MaxId )
00221     {
00222     this->MaxId = id;
00223     }
00224 }
00225
00226 inline vtkIdType vtkShortArray::InsertNextValue(const short i)
00227 {
00228   this->InsertValue (++this->MaxId,i);
00229   return this->MaxId;
00230 }
00231
00232
00233 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkShrinkFilter.h Source File

Graphics/vtkShrinkFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkShrinkFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkShrinkFilter_h
00052 #define __vtkShrinkFilter_h
00053
00054 #include "vtkDataSetToUnstructuredGridFilter.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkShrinkFilter : public vtkDataSetToUnstructuredGridFilter
00057 {
00058 public:
00059   static vtkShrinkFilter *New();
00060   vtkTypeRevisionMacro(vtkShrinkFilter,vtkDataSetToUnstructuredGridFilter);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064
00065   vtkSetClampMacro(ShrinkFactor,float,0.0,1.0);
00067
00069
00070   vtkGetMacro(ShrinkFactor,float);
00072
00073 protected:
00074   vtkShrinkFilter(float sf=0.5);
00075   ~vtkShrinkFilter() {};
00076
00077   void Execute();
00078   float ShrinkFactor;
00079 private:
00080   vtkShrinkFilter(const vtkShrinkFilter&);  // Not implemented.
00081   void operator=(const vtkShrinkFilter&);  // Not implemented.
00082 };
00083
00084 #endif
00085
00086
Generated on Mon Mar 25 01:07:44 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkShrinkPolyData.h Source File

Graphics/vtkShrinkPolyData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkShrinkPolyData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkShrinkPolyData_h
00055 #define __vtkShrinkPolyData_h
00056
00057 #include "vtkPolyDataToPolyDataFilter.h"
00058
00059 class VTK_GRAPHICS_EXPORT vtkShrinkPolyData : public vtkPolyDataToPolyDataFilter
00060 {
00061 public:
00062   static vtkShrinkPolyData *New();
00063   vtkTypeRevisionMacro(vtkShrinkPolyData,vtkPolyDataToPolyDataFilter);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067
00068   vtkSetClampMacro(ShrinkFactor,float,0.0,1.0);
00070
00072
00073   vtkGetMacro(ShrinkFactor,float);
00075
00076 protected:
00077   vtkShrinkPolyData(float sf=0.5);
00078   ~vtkShrinkPolyData() {};
00079
00080   void Execute();
00081   float ShrinkFactor;
00082 private:
00083   vtkShrinkPolyData(const vtkShrinkPolyData&);  // Not implemented.
00084   void operator=(const vtkShrinkPolyData&);  // Not implemented.
00085 };
00086
00087 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSimpleElevationFilter.h Source File

Graphics/vtkSimpleElevationFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSimpleElevationFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkSimpleElevationFilter_h
00040 #define __vtkSimpleElevationFilter_h
00041
00042 #include "vtkDataSetToDataSetFilter.h"
00043
00044 class VTK_GRAPHICS_EXPORT vtkSimpleElevationFilter : public vtkDataSetToDataSetFilter
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkSimpleElevationFilter,vtkDataSetToDataSetFilter);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051   static vtkSimpleElevationFilter *New();
00052
00054
00055   vtkSetVector3Macro(Vector,float);
00056   vtkGetVectorMacro(Vector,float,3);
00058
00059 protected:
00060   vtkSimpleElevationFilter();
00061   ~vtkSimpleElevationFilter() {};
00062
00063   void Execute();
00064   float Vector[3];
00065 private:
00066   vtkSimpleElevationFilter(const vtkSimpleElevationFilter&);  // Not implemented.
00067   void operator=(const vtkSimpleElevationFilter&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkSimpleImageFilterExample.h Source File

Imaging/vtkSimpleImageFilterExample.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSimpleImageFilterExample.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkSimpleImageFilterExample_h
00041 #define __vtkSimpleImageFilterExample_h
00042
00043 #include "vtkSimpleImageToImageFilter.h"
00044
00045 class VTK_IMAGING_EXPORT vtkSimpleImageFilterExample : public vtkSimpleImageToImageFilter
00046 {
00047 public:
00048   static vtkSimpleImageFilterExample *New();
00049   vtkTypeRevisionMacro(vtkSimpleImageFilterExample,vtkSimpleImageToImageFilter);
00050
00051 protected:
00052
00053   vtkSimpleImageFilterExample() {};
00054   ~vtkSimpleImageFilterExample() {};
00055
00056   virtual void SimpleExecute(vtkImageData* input, vtkImageData* output);
00057 private:
00058   vtkSimpleImageFilterExample(const vtkSimpleImageFilterExample&);  // Not implemented.
00059   void operator=(const vtkSimpleImageFilterExample&);  // Not implemented.
00060 };
00061
00062 #endif
00063
00064
00065
00066
00067
00068
00069
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkSimpleImageToImageFilter.h Source File

Filtering/vtkSimpleImageToImageFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSimpleImageToImageFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkSimpleImageToImageFilter_h
00052 #define __vtkSimpleImageToImageFilter_h
00053
00054 #include "vtkImageSource.h"
00055
00056 class VTK_FILTERING_EXPORT vtkSimpleImageToImageFilter : public vtkImageSource
00057 {
00058 public:
00059
00060   vtkTypeRevisionMacro(vtkSimpleImageToImageFilter,vtkImageSource);
00061
00063
00064   virtual void SetInput(vtkImageData *input);
00065   vtkImageData *GetInput();
00067
00068
00069 protected:
00070   vtkSimpleImageToImageFilter();
00071   ~vtkSimpleImageToImageFilter();
00072
00073   // These are called by the superclass.
00074   // You might have to override ExecuteInformation
00075   virtual void ExecuteInformation();
00076   virtual void ComputeInputUpdateExtent(int inExt[6], int outExt[6]);
00077
00078   // You don't have to touch this unless you have a good reason.
00079   virtual void ExecuteData(vtkDataObject *output);
00080   // In the simplest case, this is the only method you need to define.
00081   virtual void SimpleExecute(vtkImageData* input, vtkImageData* output) = 0;
00082 private:
00083   vtkSimpleImageToImageFilter(const vtkSimpleImageToImageFilter&);  // Not implemented.
00084   void operator=(const vtkSimpleImageToImageFilter&);  // Not implemented.
00085 };
00086
00087 #endif
00088
00089
00090
00091
00092
00093
00094
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkSimpleScalarTree.h Source File

Filtering/vtkSimpleScalarTree.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSimpleScalarTree.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkSimpleScalarTree_h
00045 #define __vtkSimpleScalarTree_h
00046
00047 #include "vtkScalarTree.h"
00048
00049 //BTX
00050 class vtkFloatArray;
00051 class vtkScalarNode;
00052 //ETX
00053
00054 class VTK_FILTERING_EXPORT vtkSimpleScalarTree : public vtkScalarTree
00055 {
00056 public:
00059   static vtkSimpleScalarTree *New();
00060
00062
00063   vtkTypeRevisionMacro(vtkSimpleScalarTree,vtkScalarTree);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068
00072   vtkSetClampMacro(BranchingFactor,int,2,VTK_LARGE_INTEGER);
00073   vtkGetMacro(BranchingFactor,int);
00075
00077
00079   vtkGetMacro(Level,int);
00081
00083
00084   vtkSetClampMacro(MaxLevel,int,1,VTK_LARGE_INTEGER);
00085   vtkGetMacro(MaxLevel,int);
00087
00091   virtual void BuildTree();
00092
00094   virtual void Initialize();
00095
00098   virtual void InitTraversal(float scalarValue);
00099
00101
00105   virtual vtkCell *GetNextCell(vtkIdType &cellId, vtkIdList* &ptIds,
00106                                vtkDataArray *cellScalars);
00108
00109 protected:
00110   vtkSimpleScalarTree();
00111   ~vtkSimpleScalarTree();
00112
00113   vtkDataArray *Scalars;
00114   int MaxLevel;
00115   int Level;
00116   int BranchingFactor; //number of children per node
00117   vtkScalarNode *Tree; //pointerless scalar range tree
00118   int TreeSize; //allocated size of tree
00119
00120 private:
00121   vtkIdType TreeIndex; //traversal location within tree
00122   vtkIdType LeafOffset; //offset to leaf nodes of tree
00123   int       ChildNumber; //current child in traversal
00124   vtkIdType CellId; //current cell id being examined
00125   int       FindStartLeaf(vtkIdType index, int level);
00126   int       FindNextLeaf(vtkIdType index,int level);
00127
00128 private:
00129   vtkSimpleScalarTree(const vtkSimpleScalarTree&);  // Not implemented.
00130   void operator=(const vtkSimpleScalarTree&);  // Not implemented.
00131 };
00132
00133 #endif
00134
00135
Generated on Mon Mar 25 01:07:39 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkSLCReader.h Source File

IO/vtkSLCReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSLCReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00044 #ifndef __vtkSLCReader_h
00045 #define __vtkSLCReader_h
00046
00047 #include <stdio.h>
00048 #include "vtkImageReader2.h"
00049
00050 class VTK_IO_EXPORT vtkSLCReader : public vtkImageReader2
00051 {
00052 public:
00053   static vtkSLCReader *New();
00054   vtkTypeRevisionMacro(vtkSLCReader,vtkImageReader2);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00058
00059   vtkSetStringMacro(FileName);
00060   vtkGetStringMacro(FileName);
00062
00064
00065   vtkGetMacro(Error,int);
00066   //Description: create a clone of this object.
00067   virtual vtkImageReader2* MakeObject() { return vtkSLCReader::New(); }
00069
00071
00072   int CanReadFile(const char* fname);
00073   // Description:
00074   // .slc
00075   virtual const char* GetFileExensions()
00076     {
00077       return ".slc";
00078     }
00080
00082
00083   virtual const char* GetDescriptiveName()
00084     {
00085       return "SLC";
00086     }
00088
00089 protected:
00090   vtkSLCReader();
00091   ~vtkSLCReader();
00092
00093   // Reads the file name and builds a vtkStructuredPoints dataset.
00094   virtual void ExecuteData(vtkDataObject*);
00095
00096   // Not used now, but will be needed when this is made into an
00097   // imaging filter.
00098   // Sets WholeExtent, Origin, Spacing, ScalarType
00099   // and NumberOfComponents of output.
00100   void ExecuteInformation();
00101
00102   // Decodes an array of eight bit run-length encoded data.
00103   unsigned char *Decode8BitData( unsigned char *in_ptr, int size );
00104   int Error;
00105 private:
00106   vtkSLCReader(const vtkSLCReader&);  // Not implemented.
00107   void operator=(const vtkSLCReader&);  // Not implemented.
00108 };
00109
00110 #endif
00111
00112
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkSliceCubes.h Source File

Patented/vtkSliceCubes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSliceCubes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 4,710,876
00016      "System and Method for the Display of Surface Structures Contained
00017      Within the Interior Region of a Solid Body".
00018      Application of this software for commercial purposes requires
00019      a license grant from GE. Contact:
00020
00021          Carl B. Horton
00022          Sr. Counsel, Intellectual Property
00023          3000 N. Grandview Blvd., W-710
00024          Waukesha, WI  53188
00025          Phone:  (262) 513-4022
00026          E-Mail: Carl.Horton@med.ge.com
00027
00028      for more information.
00029
00030 =========================================================================*/
00078 #ifndef __vtkSliceCubes_h
00079 #define __vtkSliceCubes_h
00080
00081 #include "vtkObject.h"
00082 #include "vtkVolumeReader.h"
00083 #include "vtkMCubesReader.h"
00084
00085 class VTK_PATENTED_EXPORT vtkSliceCubes : public vtkObject
00086 {
00087 public:
00088   static vtkSliceCubes *New();
00089   vtkTypeRevisionMacro(vtkSliceCubes,vtkObject);
00090   void PrintSelf(ostream& os, vtkIndent indent);
00091
00092   // methods to make it look like a filter
00093   void Write() {this->Update();};
00094   void Update();
00095
00097
00098   vtkSetObjectMacro(Reader,vtkVolumeReader);
00099   vtkGetObjectMacro(Reader,vtkVolumeReader);
00101
00103
00104   vtkSetStringMacro(FileName);
00105   vtkGetStringMacro(FileName);
00107
00109
00110   vtkSetMacro(Value,float);
00111   vtkGetMacro(Value,float);
00113
00115
00117   vtkSetStringMacro(LimitsFileName);
00118   vtkGetStringMacro(LimitsFileName);
00120
00121 protected:
00122   vtkSliceCubes();
00123   ~vtkSliceCubes();
00124
00125   void Execute();
00126
00127   vtkVolumeReader *Reader;
00128   char *FileName;
00129   float Value;
00130   char *LimitsFileName;
00131 private:
00132   vtkSliceCubes(const vtkSliceCubes&);  // Not implemented.
00133   void operator=(const vtkSliceCubes&);  // Not implemented.
00134 };
00135
00136 #endif
00137
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSmoothPolyDataFilter.h Source File

Graphics/vtkSmoothPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSmoothPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00108 #ifndef __vtkSmoothPolyDataFilter_h
00109 #define __vtkSmoothPolyDataFilter_h
00110
00111 #include "vtkPolyDataToPolyDataFilter.h"
00112
00113 class vtkSmoothPoints;
00114
00115 class VTK_GRAPHICS_EXPORT vtkSmoothPolyDataFilter : public vtkPolyDataToPolyDataFilter
00116 {
00117 public:
00118   vtkTypeRevisionMacro(vtkSmoothPolyDataFilter,vtkPolyDataToPolyDataFilter);
00119   void PrintSelf(ostream& os, vtkIndent indent);
00120
00126   static vtkSmoothPolyDataFilter *New();
00127
00129
00131   vtkSetClampMacro(Convergence,float,0.0,1.0);
00132   vtkGetMacro(Convergence,float);
00134
00136
00137   vtkSetClampMacro(NumberOfIterations,int,0,VTK_LARGE_INTEGER);
00138   vtkGetMacro(NumberOfIterations,int);
00140
00142
00147   vtkSetMacro(RelaxationFactor,float);
00148   vtkGetMacro(RelaxationFactor,float);
00150
00152
00153   vtkSetMacro(FeatureEdgeSmoothing,int);
00154   vtkGetMacro(FeatureEdgeSmoothing,int);
00155   vtkBooleanMacro(FeatureEdgeSmoothing,int);
00157
00159
00160   vtkSetClampMacro(FeatureAngle,float,0.0,180.0);
00161   vtkGetMacro(FeatureAngle,float);
00163
00165
00167   vtkSetClampMacro(EdgeAngle,float,0.0,180.0);
00168   vtkGetMacro(EdgeAngle,float);
00170
00172
00173   vtkSetMacro(BoundarySmoothing,int);
00174   vtkGetMacro(BoundarySmoothing,int);
00175   vtkBooleanMacro(BoundarySmoothing,int);
00177
00179
00180   vtkSetMacro(GenerateErrorScalars,int);
00181   vtkGetMacro(GenerateErrorScalars,int);
00182   vtkBooleanMacro(GenerateErrorScalars,int);
00184
00186
00187   vtkSetMacro(GenerateErrorVectors,int);
00188   vtkGetMacro(GenerateErrorVectors,int);
00189   vtkBooleanMacro(GenerateErrorVectors,int);
00191
00193
00196   void SetSource(vtkPolyData *source);
00197   vtkPolyData *GetSource();
00199
00200 protected:
00201   vtkSmoothPolyDataFilter();
00202   ~vtkSmoothPolyDataFilter() {};
00203
00204   void Execute();
00205
00206   float Convergence;
00207   int NumberOfIterations;
00208   float RelaxationFactor;
00209   int FeatureEdgeSmoothing;
00210   float FeatureAngle;
00211   float EdgeAngle;
00212   int BoundarySmoothing;
00213   int GenerateErrorScalars;
00214   int GenerateErrorVectors;
00215
00216   vtkSmoothPoints *SmoothPoints;
00217 private:
00218   vtkSmoothPolyDataFilter(const vtkSmoothPolyDataFilter&);  // Not implemented.
00219   void operator=(const vtkSmoothPolyDataFilter&);  // Not implemented.
00220 };
00221
00222 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkSocketCommunicator.h Source File

Parallel/vtkSocketCommunicator.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSocketCommunicator.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkSocketCommunicator_h
00049 #define __vtkSocketCommunicator_h
00050
00051 #if !defined(_WIN32) || defined(__CYGWIN__)
00052  #include <sys/types.h>
00053  #include <sys/socket.h>
00054  #include <netinet/in.h>
00055  #include <arpa/inet.h>
00056  #include <netdb.h>
00057  #include <unistd.h>
00058 #endif
00059
00060 #include "vtkObject.h"
00061 #include "vtkByteSwap.h"
00062 #include "vtkCommunicator.h"
00063
00064 #ifdef VTK_WORDS_BIGENDIAN
00065 # define vtkSwap4 vtkByteSwap::Swap4LE
00066 # define vtkSwap4Range vtkByteSwap::Swap4LERange
00067 # define vtkSwap8 vtkByteSwap::Swap8LE
00068 # define vtkSwap8Range vtkByteSwap::Swap8LERange
00069 #else
00070 # define vtkSwap4 vtkByteSwap::Swap4BE
00071 # define vtkSwap4Range vtkByteSwap::Swap4BERange
00072 # define vtkSwap8 vtkByteSwap::Swap8BE
00073 # define vtkSwap8Range vtkByteSwap::Swap8BERange
00074 #endif
00075
00076 class VTK_PARALLEL_EXPORT vtkSocketCommunicator : public vtkCommunicator
00077 {
00078 public:
00079   static vtkSocketCommunicator *New();
00080   vtkTypeRevisionMacro(vtkSocketCommunicator,vtkCommunicator);
00081   void PrintSelf(ostream& os, vtkIndent indent);
00082
00084   virtual int WaitForConnection(int port);
00085
00087   virtual void CloseConnection();
00088
00090   virtual int ConnectTo( char* hostName, int port);
00091
00093
00094   vtkGetMacro(SwapBytesInReceivedData, int);
00096
00098
00099   vtkGetMacro(IsConnected, int);
00101
00102   //------------------ Communication --------------------
00103
00105
00107   int Send(int *data, int length, int remoteProcessId, int tag);
00108   int Send(unsigned long *data, int length, int remoteProcessId, int tag);
00109   int Send(char *data, int length, int remoteProcessId, int tag);
00110   int Send(unsigned char *data, int length, int remoteProcessId, int tag);
00111   int Send(float *data, int length, int remoteProcessId, int tag);
00112   int Send(double *data, int length, int remoteProcessId, int tag);
00113 #ifdef VTK_USE_64BIT_IDS
00114   int Send(vtkIdType *data, int length, int remoteProcessId, int tag);
00116 #endif
00117   int Send(vtkDataObject *data, int remoteId, int tag)
00118     {return this->vtkCommunicator::Send(data,remoteId,tag);}
00119   int Send(vtkDataArray *data, int remoteId, int tag)
00120     {return this->vtkCommunicator::Send(data,remoteId,tag);}
00121
00123
00126   int Receive(int *data, int length, int remoteProcessId, int tag);
00127   int Receive(unsigned long *data, int length, int remoteProcessId, int tag);
00128   int Receive(char *data, int length, int remoteProcessId, int tag);
00129   int Receive(unsigned char *data, int length, int remoteProcessId, int tag);
00130   int Receive(float *data, int length, int remoteProcessId, int tag);
00131   int Receive(double *data, int length, int remoteProcessId, int tag);
00132 #ifdef VTK_USE_64BIT_IDS
00133   int Receive(vtkIdType *data, int length, int remoteProcessId, int tag);
00135 #endif
00136   int Receive(vtkDataObject *data, int remoteId, int tag)
00137     {return this->vtkCommunicator::Receive(data, remoteId, tag);}
00138   int Receive(vtkDataArray *data, int remoteId, int tag)
00139     {return this->vtkCommunicator::Receive(data, remoteId, tag);}
00140
00141 protected:
00142
00143   int Socket;
00144   int IsConnected;
00145   int NumberOfProcesses;
00146   int SwapBytesInReceivedData;
00147
00148   vtkSocketCommunicator();
00149   ~vtkSocketCommunicator();
00150
00151   int ReceiveMessage(char *data, int size, int length, int tag );
00152 private:
00153   vtkSocketCommunicator(const vtkSocketCommunicator&);  // Not implemented.
00154   void operator=(const vtkSocketCommunicator&);  // Not implemented.
00155 };
00156
00157 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkSocketController.h Source File

Parallel/vtkSocketController.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSocketController.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkSocketController_h
00042 #define __vtkSocketController_h
00043
00044 #if !defined(_WIN32) || defined(__CYGWIN__)
00045  #include <sys/types.h>
00046  #include <sys/socket.h>
00047  #include <netinet/in.h>
00048  #include <arpa/inet.h>
00049  #include <netdb.h>
00050  #include <unistd.h>
00051 #endif
00052
00053 #include "vtkObject.h"
00054 #include "vtkMultiProcessController.h"
00055 #include "vtkSocketCommunicator.h"
00056
00057 class VTK_PARALLEL_EXPORT vtkSocketController : public vtkMultiProcessController
00058 {
00059 public:
00060   static vtkSocketController *New();
00061   vtkTypeRevisionMacro(vtkSocketController,vtkMultiProcessController);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065
00067   virtual void Initialize(int* , char***);
00068   virtual void Initialize()
00069     { this->Initialize(0,0); }
00071
00073   void Finalize() {};
00074
00076   void SingleMethodExecute() {};
00077
00079   void MultipleMethodExecute() {};
00080
00082   void CreateOutputWindow() {};
00083
00085   void Barrier() {};
00086
00088   virtual void SetNumberOfProcesses(int num);
00089
00091
00092   virtual int WaitForConnection(int port)
00093     {
00094     return vtkSocketCommunicator::SafeDownCast(this->Communicator)->
00095       WaitForConnection(port);
00096     }
00098
00100
00101   virtual void CloseConnection()
00102     {
00103     vtkSocketCommunicator::SafeDownCast(this->Communicator)->
00104       CloseConnection();
00105     }
00107
00109
00110   virtual int ConnectTo( char* hostName, int port )
00111     {
00112     return vtkSocketCommunicator::SafeDownCast(this->Communicator)->
00113       ConnectTo(hostName, port);
00114     }
00116
00117   int GetSwapBytesInReceivedData()
00118     {
00119     return vtkSocketCommunicator::SafeDownCast(this->Communicator)->
00120       GetSwapBytesInReceivedData();
00121     }
00122
00124   void SetCommunicator(vtkSocketCommunicator* comm);
00125
00126 //BTX
00127
00128   enum Consts {
00129     ENDIAN_TAG=1010580540 // 0x3c3c3c3c
00130   };
00131
00132 //ETX
00133
00134 protected:
00135
00136   vtkSocketController();
00137   ~vtkSocketController();
00138
00139   // Initialize only once, finialize on destruction.
00140   static int Initialized;
00141 private:
00142   vtkSocketController(const vtkSocketController&);  // Not implemented.
00143   void operator=(const vtkSocketController&);  // Not implemented.
00144 };
00145
00146
00147 #endif // __vtkSocketController_h
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkSource.h Source File

Common/vtkSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkSource_h
00062 #define __vtkSource_h
00063
00064 #include "vtkProcessObject.h"
00065 #include "vtkDataObject.h"
00066
00067 class vtkErrorCode;
00068
00069 class VTK_COMMON_EXPORT vtkSource : public vtkProcessObject
00070 {
00071 public:
00072   vtkTypeRevisionMacro(vtkSource,vtkProcessObject);
00073   void PrintSelf(ostream& os, vtkIndent indent);
00074
00078   virtual void Update();
00079
00082   virtual void UpdateWholeExtent();
00083
00086   virtual void UpdateInformation();
00087
00088   virtual void PropagateUpdateExtent(vtkDataObject *output);
00089
00090   virtual void TriggerAsynchronousUpdate();
00091
00092   virtual void UpdateData(vtkDataObject *output);
00093
00097   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00098
00100
00102   virtual void SetReleaseDataFlag(int);
00103   virtual int GetReleaseDataFlag();
00104   vtkBooleanMacro(ReleaseDataFlag,int);
00106
00108   void UnRegister(vtkObject *o);
00109
00111   virtual int InRegisterLoop(vtkObject *);
00112
00114
00116   vtkDataObject **GetOutputs();
00117   vtkGetMacro(NumberOfOutputs,int);
00119
00123   void UnRegisterAllOutputs(void);
00124
00127   int GetOutputIndex(vtkDataObject *out);
00128
00130
00135   virtual void EnlargeOutputUpdateExtents(vtkDataObject *output);
00136   int LegacyHack;
00138
00140
00142   vtkGetMacro( ErrorCode, unsigned long );
00144
00145 protected:
00146   vtkSource();
00147   ~vtkSource();
00148
00150
00153   virtual void ExecuteData(vtkDataObject *vtkNotUsed(output)) {
00154     this->Execute(); };
00156
00158   virtual void Execute();
00159
00160   // By default, UpdateInformation calls this method to copy information
00161   // unmodified from the input to the output.
00162   virtual void ExecuteInformation();
00163
00164   // Called to allocate the input array.  Copies old inputs.
00165   void SetNumberOfOutputs(int num);
00166
00167   // method used internally for getting an output.
00168   vtkDataObject *GetOutput(int idx);
00169
00170   // protected methods for setting inputs.
00171   virtual void SetNthOutput(int num, vtkDataObject *output);
00172   virtual void AddOutput(vtkDataObject *output);
00173   virtual void RemoveOutput(vtkDataObject *output);
00174
00175   vtkDataObject **Outputs;     // An Array of the outputs to the filter
00176   int NumberOfOutputs;
00177   int Updating;
00178   // Time when ExecuteInformation was last called.
00179   vtkTimeStamp InformationTime;
00180
00182
00184   vtkSetMacro( ErrorCode, unsigned long );
00186 private:
00187   vtkSource(const vtkSource&);  // Not implemented.
00188   void operator=(const vtkSource&);  // Not implemented.
00189
00190   unsigned long ErrorCode;
00191 };
00192
00193 #endif
00194
00195
00196
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSpatialRepresentationFilter.h Source File

Graphics/vtkSpatialRepresentationFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSpatialRepresentationFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00071 #ifndef __vtkSpatialRepresentationFilter_h
00072 #define __vtkSpatialRepresentationFilter_h
00073
00074 #include "vtkPolyDataSource.h"
00075 #include "vtkLocator.h"
00076
00077 #define VTK_MAX_SPATIAL_REP_LEVEL 24
00078
00079 class VTK_GRAPHICS_EXPORT vtkSpatialRepresentationFilter : public vtkPolyDataSource
00080 {
00081 public:
00082   static vtkSpatialRepresentationFilter *New();
00083   vtkTypeRevisionMacro(vtkSpatialRepresentationFilter,vtkPolyDataSource);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00087
00088   vtkSetObjectMacro(SpatialRepresentation,vtkLocator);
00089   vtkGetObjectMacro(SpatialRepresentation,vtkLocator);
00091
00093
00094   vtkGetMacro(Level,int);
00096
00099   vtkPolyData *GetOutput(int level);
00100
00102   vtkPolyData *GetOutput();
00103
00105   void ResetOutput();
00106
00108
00109   virtual void SetInput(vtkDataSet *input);
00110   vtkDataSet *GetInput();
00112
00113 protected:
00114   vtkSpatialRepresentationFilter();
00115   ~vtkSpatialRepresentationFilter();
00116
00117   void Execute();
00118   void GenerateOutput();
00119
00120   int Level;
00121   int TerminalNodesRequested;
00122
00123   vtkLocator *SpatialRepresentation;
00124 private:
00125   vtkSpatialRepresentationFilter(const vtkSpatialRepresentationFilter&);  // Not implemented.
00126   void operator=(const vtkSpatialRepresentationFilter&);  // Not implemented.
00127 };
00128
00129 #endif
00130
00131
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkSphere.h Source File

Filtering/vtkSphere.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSphere.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkSphere_h
00041 #define __vtkSphere_h
00042
00043 #include "vtkImplicitFunction.h"
00044
00045 class VTK_FILTERING_EXPORT vtkSphere : public vtkImplicitFunction
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkSphere,vtkImplicitFunction);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052   static vtkSphere *New();
00053
00055
00056   float EvaluateFunction(float x[3]);
00057   float EvaluateFunction(float x, float y, float z)
00058     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00060
00062   void EvaluateGradient(float x[3], float n[3]);
00063
00065
00066   vtkSetMacro(Radius,float);
00067   vtkGetMacro(Radius,float);
00069
00071
00072   vtkSetVector3Macro(Center,float);
00073   vtkGetVectorMacro(Center,float,3);
00075
00076 protected:
00077   vtkSphere();
00078   ~vtkSphere() {};
00079
00080   float Radius;
00081   float Center[3];
00082
00083 private:
00084   vtkSphere(const vtkSphere&);  // Not implemented.
00085   void operator=(const vtkSphere&);  // Not implemented.
00086 };
00087
00088 #endif
00089
00090
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSpherePuzzle.h Source File

Graphics/vtkSpherePuzzle.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSpherePuzzle.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkSpherePuzzle_h
00038 #define __vtkSpherePuzzle_h
00039
00040 #include "vtkPolyDataSource.h"
00041 #include "vtkTransform.h"
00042
00043 #define VTK_MAX_SPHERE_RESOLUTION 1024
00044
00045 class VTK_EXPORT vtkSpherePuzzle : public vtkPolyDataSource
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkSpherePuzzle,vtkPolyDataSource);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00051   static vtkSpherePuzzle *New();
00052
00054   void Reset();
00055
00057   void MoveHorizontal(int section, int percentage, int rightFlag);
00058
00060   void MoveVertical(int section, int percentage, int rightFlag);
00061
00067   int SetPoint(float x, float y, float z);
00068
00072   void MovePoint(int percentage);
00073
00075   int *GetState() {return this->State;}
00076
00077 protected:
00078   vtkSpherePuzzle();
00079   ~vtkSpherePuzzle();
00080   vtkSpherePuzzle(const vtkSpherePuzzle&);
00081   void operator=(const vtkSpherePuzzle&);
00082
00083   void Execute();
00084   void MarkVertical(int section);
00085   void MarkHorizontal(int section);
00086
00087   int State[32];
00088
00089   // Stuff for storing a partial move.
00090   int PieceMask[32];
00091   vtkTransform *Transform;
00092
00093   // Colors for faces.
00094   unsigned char Colors[96];
00095
00096   // State for potential move.
00097   int Active;
00098   int VerticalFlag;
00099   int RightFlag;
00100   int Section;
00101 };
00102
00103 #endif
00104
00105
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSpherePuzzleArrows.h Source File

Graphics/vtkSpherePuzzleArrows.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSpherePuzzleArrows.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkSpherePuzzleArrows_h
00038 #define __vtkSpherePuzzleArrows_h
00039
00040 #include "vtkPolyDataSource.h"
00041 #include "vtkSpherePuzzle.h"
00042
00043
00044 class VTK_EXPORT vtkSpherePuzzleArrows : public vtkPolyDataSource
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkSpherePuzzleArrows,vtkPolyDataSource);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00050   static vtkSpherePuzzleArrows *New();
00051
00053   vtkSetVectorMacro(Permutation,int,32);
00054   vtkGetVectorMacro(Permutation,int,32);
00055   void SetPermutationComponent(int comp, int val);
00056   void SetPermutation(vtkSpherePuzzle *puz)
00057     {this->SetPermutation(puz->GetState());}
00059
00060 protected:
00061   vtkSpherePuzzleArrows();
00062   ~vtkSpherePuzzleArrows();
00063   vtkSpherePuzzleArrows(const vtkSpherePuzzleArrows&);
00064   void operator=(const vtkSpherePuzzleArrows&);
00065
00066   void Execute();
00067   void AppendArrow(int id0, int id1, vtkPoints *pts, vtkCellArray *polys);
00068
00069   int Permutation[32];
00070
00071   float Radius;
00072 };
00073
00074 #endif
00075
00076
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSphereSource.h Source File

Graphics/vtkSphereSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSphereSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkSphereSource_h
00051 #define __vtkSphereSource_h
00052
00053 #include "vtkPolyDataSource.h"
00054
00055 #define VTK_MAX_SPHERE_RESOLUTION 1024
00056
00057 class VTK_GRAPHICS_EXPORT vtkSphereSource : public vtkPolyDataSource
00058 {
00059 public:
00060   vtkTypeRevisionMacro(vtkSphereSource,vtkPolyDataSource);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00066   static vtkSphereSource *New();
00067
00069
00070   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00071   vtkGetMacro(Radius,float);
00073
00075
00076   vtkSetVector3Macro(Center,float);
00077   vtkGetVectorMacro(Center,float,3);
00079
00081
00083   vtkSetClampMacro(ThetaResolution,int,3,VTK_MAX_SPHERE_RESOLUTION);
00084   vtkGetMacro(ThetaResolution,int);
00086
00088
00090   vtkSetClampMacro(PhiResolution,int,3,VTK_MAX_SPHERE_RESOLUTION);
00091   vtkGetMacro(PhiResolution,int);
00093
00095
00096   vtkSetClampMacro(StartTheta,float,0.0,360.0);
00097   vtkGetMacro(StartTheta,float);
00099
00101
00102   vtkSetClampMacro(EndTheta,float,0.0,360.0);
00103   vtkGetMacro(EndTheta,float);
00105
00107
00109   vtkSetClampMacro(StartPhi,float,0.0,360.0);
00110   vtkGetMacro(StartPhi,float);
00112
00114
00115   vtkSetClampMacro(EndPhi,float,0.0,360.0);
00116   vtkGetMacro(EndPhi,float);
00118
00120
00126   vtkSetMacro(LatLongTessellation,int);
00127   vtkGetMacro(LatLongTessellation,int);
00128   vtkBooleanMacro(LatLongTessellation,int);
00130
00131 protected:
00132   vtkSphereSource(int res=8);
00133   ~vtkSphereSource() {}
00134
00135   void Execute();
00136   void ExecuteInformation();
00137
00138   float Radius;
00139   float Center[3];
00140   int ThetaResolution;
00141   int PhiResolution;
00142   float StartTheta;
00143   float EndTheta;
00144   float StartPhi;
00145   float EndPhi;
00146   int LatLongTessellation;
00147
00148 private:
00149   vtkSphereSource(const vtkSphereSource&);  // Not implemented.
00150   void operator=(const vtkSphereSource&);  // Not implemented.
00151 };
00152
00153 #endif
00154
00155
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkSpline.h Source File

Filtering/vtkSpline.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSpline.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkSpline_h
00050 #define __vtkSpline_h
00051
00052 #include <stdio.h>
00053 #include "vtkObject.h"
00054 #include "vtkPiecewiseFunction.h"
00055
00056 class VTK_FILTERING_EXPORT vtkSpline : public vtkObject
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkSpline,vtkObject);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00065   vtkSetMacro(ClampValue,int);
00066   vtkGetMacro(ClampValue,int);
00067   vtkBooleanMacro(ClampValue,int);
00069
00071   virtual void Compute () = 0;
00072
00074   void AddPoint (float t, float x);
00075
00077   void RemovePoint (float t);
00078
00080   void RemoveAllPoints ();
00081
00083
00086   vtkSetMacro(Closed,int);
00087   vtkGetMacro(Closed,int);
00088   vtkBooleanMacro(Closed,int);
00090
00092
00098   vtkSetClampMacro(LeftConstraint,int,1,3);
00099   vtkGetMacro(LeftConstraint,int);
00100   vtkSetClampMacro(RightConstraint,int,1,3);
00101   vtkGetMacro(RightConstraint,int);
00102   vtkSetMacro(LeftValue,float);
00103   vtkGetMacro(LeftValue,float);
00104   vtkSetMacro(RightValue,float);
00105   vtkGetMacro(RightValue,float);
00107
00109   unsigned long GetMTime();
00110
00111 protected:
00112   vtkSpline();
00113   ~vtkSpline ();
00114
00115   unsigned long ComputeTime;
00116   int ClampValue;
00117   float *Intervals;
00118   float *Coefficients;
00119   int LeftConstraint;
00120   float LeftValue;
00121   int RightConstraint;
00122   float RightValue;
00123   vtkPiecewiseFunction *PiecewiseFunction;
00124   int Closed;
00125 private:
00126   vtkSpline(const vtkSpline&);  // Not implemented.
00127   void operator=(const vtkSpline&);  // Not implemented.
00128 };
00129
00130 #endif
00131
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSplitField.h Source File

Graphics/vtkSplitField.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSplitField.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00066 #ifndef __vtkSplitField_h
00067 #define __vtkSplitField_h
00068
00069 #include "vtkDataSetToDataSetFilter.h"
00070
00071 class vtkFieldData;
00072
00073 class VTK_GRAPHICS_EXPORT vtkSplitField : public vtkDataSetToDataSetFilter
00074 {
00075 public:
00076   vtkTypeRevisionMacro(vtkSplitField,vtkDataSetToDataSetFilter);
00077   void PrintSelf(ostream& os, vtkIndent indent);
00078
00080   static vtkSplitField *New();
00081
00084   void SetInputField(int attributeType, int fieldLoc);
00085
00088   void SetInputField(const char* name, int fieldLoc);
00089
00092   void SetInputField(const char* name, const char* fieldLoc);
00093
00095   void Split(int component, const char* arrayName);
00096
00097 //BTX
00098   enum FieldLocations
00099   {
00100     DATA_OBJECT=0,
00101     POINT_DATA=1,
00102     CELL_DATA=2
00103   };
00104 //ETX
00105
00106 //BTX
00107   struct Component
00108   {
00109     int Index;
00110     char* FieldName;
00111     Component* Next;   // linked list
00112     void SetName(const char* name)
00113       {
00114         delete[] this->FieldName;
00115         this->FieldName = 0;
00116         if (name)
00117           {
00118           this->FieldName = new char[strlen(name)+1];
00119           strcpy(this->FieldName, name);
00120           }
00121       }
00122     Component() { FieldName = 0; }
00123     ~Component() { delete[] FieldName; }
00124   };
00125 //ETX
00126
00127 protected:
00128
00129 //BTX
00130   enum FieldTypes
00131   {
00132     NAME,
00133     ATTRIBUTE
00134   };
00135 //ETX
00136
00137   vtkSplitField();
00138   virtual ~vtkSplitField();
00139
00140   void Execute();
00141
00142   char* FieldName;
00143   int FieldType;
00144   int AttributeType;
00145   int FieldLocation;
00146
00147   static char FieldLocationNames[3][12];
00148   static char AttributeNames[vtkDataSetAttributes::NUM_ATTRIBUTES][10];
00149
00150   vtkDataArray* SplitArray(vtkDataArray* da, int component);
00151
00152
00153   // Components are stored as a linked list.
00154   Component* Head;
00155   Component* Tail;
00156
00157   // Methods to browse/modify the linked list.
00158   Component* GetNextComponent(Component* op)
00159     { return op->Next; }
00160   Component* GetFirst()
00161     { return this->Head; }
00162   void AddComponent(Component* op);
00163   Component* FindComponent(int index);
00164   void DeleteAllComponents();
00165
00166   void PrintComponent(Component* op, ostream& os, vtkIndent indent)
00167     {
00168       os << indent << "Field name: " << op->FieldName << endl;
00169       os << indent << "Component index: " << op->Index << endl;
00170     }
00171
00172   void PrintAllComponents(ostream& os, vtkIndent indent)
00173     {
00174       Component* cur = this->GetFirst();
00175       if (!cur) { return; }
00176       Component* before;
00177       do
00178         {
00179         before = cur;
00180         cur = cur->Next;
00181         os << endl;
00182         this->PrintComponent(before, os, indent);
00183         }
00184       while (cur);
00185     }
00186 private:
00187   vtkSplitField(const vtkSplitField&);  // Not implemented.
00188   void operator=(const vtkSplitField&);  // Not implemented.
00189 };
00190
00191 #endif
00192
00193
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkSTLReader.h Source File

IO/vtkSTLReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSTLReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkSTLReader_h
00055 #define __vtkSTLReader_h
00056
00057 #include <stdio.h>
00058 #include "vtkPolyDataSource.h"
00059 #include "vtkPoints.h"
00060 #include "vtkCellArray.h"
00061
00062 class VTK_IO_EXPORT vtkSTLReader : public vtkPolyDataSource
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkSTLReader,vtkPolyDataSource);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   static vtkSTLReader *New();
00070
00073   unsigned long GetMTime();
00074
00076
00077   vtkSetStringMacro(FileName);
00078   vtkGetStringMacro(FileName);
00080
00082
00083   vtkSetMacro(Merging,int);
00084   vtkGetMacro(Merging,int);
00085   vtkBooleanMacro(Merging,int);
00087
00089
00090   vtkSetMacro(ScalarTags,int);
00091   vtkGetMacro(ScalarTags,int);
00092   vtkBooleanMacro(ScalarTags,int);
00094
00096
00098   void SetLocator(vtkPointLocator *locator);
00099   vtkGetObjectMacro(Locator,vtkPointLocator);
00101
00103   void CreateDefaultLocator();
00104
00105 protected:
00106   vtkSTLReader();
00107   ~vtkSTLReader();
00108
00109   char *FileName;
00110   int Merging;
00111   int ScalarTags;
00112   vtkPointLocator *Locator;
00113
00114   void Execute();
00115   int ReadBinarySTL(FILE *fp, vtkPoints*, vtkCellArray*);
00116   int ReadASCIISTL(FILE *fp, vtkPoints*, vtkCellArray*,
00117                    vtkFloatArray* scalars=0);
00118   int GetSTLFileType(FILE *fp);
00119 private:
00120   vtkSTLReader(const vtkSTLReader&);  // Not implemented.
00121   void operator=(const vtkSTLReader&);  // Not implemented.
00122 };
00123
00124 #endif
00125
00126
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkSTLWriter.h Source File

IO/vtkSTLWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSTLWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkSTLWriter_h
00044 #define __vtkSTLWriter_h
00045
00046 #include <stdio.h>
00047 #include "vtkPolyDataWriter.h"
00048 #include "vtkPolyData.h"
00049
00050 class VTK_IO_EXPORT vtkSTLWriter : public vtkPolyDataWriter
00051 {
00052 public:
00053   static vtkSTLWriter *New();
00054   vtkTypeRevisionMacro(vtkSTLWriter,vtkPolyDataWriter);
00055
00056 protected:
00057   vtkSTLWriter();
00058   ~vtkSTLWriter() {};
00059
00060   void WriteData();
00061
00062   void WriteBinarySTL(vtkPoints *pts, vtkCellArray *polys);
00063   void WriteAsciiSTL(vtkPoints *pts, vtkCellArray *polys);
00064 private:
00065   vtkSTLWriter(const vtkSTLWriter&);  // Not implemented.
00066   void operator=(const vtkSTLWriter&);  // Not implemented.
00067 };
00068
00069 #endif
00070
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStreamer.h Source File

Graphics/vtkStreamer.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStreamer.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00065 #ifndef __vtkStreamer_h
00066 #define __vtkStreamer_h
00067
00068 #include "vtkDataSetToPolyDataFilter.h"
00069 #include "vtkInitialValueProblemSolver.h"
00070 #include "vtkMultiThreader.h"
00071
00072 #define VTK_INTEGRATE_FORWARD 0
00073 #define VTK_INTEGRATE_BACKWARD 1
00074 #define VTK_INTEGRATE_BOTH_DIRECTIONS 2
00075
00076 typedef struct _vtkStreamPoint {
00077   float   x[3];    // position
00078   vtkIdType     cellId;  // cell
00079   int     subId;   // cell sub id
00080   float   p[3];    // parametric coords in cell
00081   float   v[3];    // velocity
00082   float   speed;   // velocity norm
00083   float   s;       // scalar value
00084   float   t;       // time travelled so far
00085   float   d;       // distance travelled so far
00086   float   omega;   // stream vorticity, if computed
00087   float   theta;    // rotation angle, if vorticity is computed
00088 } vtkStreamPoint;
00089
00090 //
00091 // Special classes for manipulating data
00092 //
00093 //BTX - begin tcl exclude
00094 //
00095 class vtkStreamArray { //;prevent man page generation
00096 public:
00097   vtkStreamArray();
00098   ~vtkStreamArray()
00099     {
00100     if (this->Array)
00101       {
00102       delete [] this->Array;
00103       }
00104     };
00105   vtkIdType GetNumberOfPoints() {return this->MaxId + 1;};
00106   vtkStreamPoint *GetStreamPoint(vtkIdType i) {return this->Array + i;};
00107   vtkIdType InsertNextStreamPoint()
00108     {
00109     if ( ++this->MaxId >= this->Size )
00110       {
00111       this->Resize(this->MaxId);
00112       }
00113     return this->MaxId; //return offset from array
00114     }
00115   vtkStreamPoint *Resize(vtkIdType sz); //reallocates data
00116   void Reset() {this->MaxId = -1;};
00117
00118   vtkStreamPoint *Array;  // pointer to data
00119   vtkIdType MaxId;        // maximum index inserted thus far
00120   vtkIdType Size;         // allocated size of data
00121   vtkIdType Extend;       // grow array by this amount
00122   float Direction;        // integration direction
00123 };
00124 //ETX
00125 //
00126
00127 class VTK_GRAPHICS_EXPORT vtkStreamer : public vtkDataSetToPolyDataFilter
00128 {
00129 public:
00130   vtkTypeRevisionMacro(vtkStreamer,vtkDataSetToPolyDataFilter);
00131   void PrintSelf(ostream& os, vtkIndent indent);
00132
00136   static vtkStreamer *New();
00137
00141   void SetStartLocation(vtkIdType cellId, int subId, float pcoords[3]);
00142
00144
00147   void SetStartLocation(vtkIdType cellId, int subId, float r, float s,
00148                         float t);
00150
00153   vtkIdType GetStartLocation(int& subId, float pcoords[3]);
00154
00158   void SetStartPosition(float x[3]);
00159
00163   void SetStartPosition(float x, float y, float z);
00164
00166   float *GetStartPosition();
00167
00169
00170   void SetSource(vtkDataSet *source);
00171   vtkDataSet *GetSource();
00173
00175
00176   vtkSetClampMacro(MaximumPropagationTime,float,0.0,VTK_LARGE_FLOAT);
00177   vtkGetMacro(MaximumPropagationTime,float);
00179
00181
00182   vtkSetClampMacro(IntegrationDirection,int,
00183                    VTK_INTEGRATE_FORWARD,VTK_INTEGRATE_BOTH_DIRECTIONS);
00184   vtkGetMacro(IntegrationDirection,int);
00185   void SetIntegrationDirectionToForward()
00186     {this->SetIntegrationDirection(VTK_INTEGRATE_FORWARD);};
00187   void SetIntegrationDirectionToBackward()
00188     {this->SetIntegrationDirection(VTK_INTEGRATE_BACKWARD);};
00189   void SetIntegrationDirectionToIntegrateBothDirections()
00190     {this->SetIntegrationDirection(VTK_INTEGRATE_BOTH_DIRECTIONS);};
00191   const char *GetIntegrationDirectionAsString();
00193
00195
00197   vtkSetClampMacro(IntegrationStepLength,float,0.0000001,VTK_LARGE_FLOAT);
00198   vtkGetMacro(IntegrationStepLength,float);
00200
00202
00204   vtkSetMacro(SpeedScalars,int);
00205   vtkGetMacro(SpeedScalars,int);
00206   vtkBooleanMacro(SpeedScalars,int);
00208
00210
00215   vtkSetMacro(OrientationScalars, int);
00216   vtkGetMacro(OrientationScalars, int);
00217   vtkBooleanMacro(OrientationScalars, int);
00219
00221
00223   vtkSetClampMacro(TerminalSpeed,float,0.0,VTK_LARGE_FLOAT);
00224   vtkGetMacro(TerminalSpeed,float);
00226
00228
00233   vtkSetMacro(Vorticity,int);
00234   vtkGetMacro(Vorticity,int);
00235   vtkBooleanMacro(Vorticity,int);
00237
00238   vtkSetMacro( NumberOfThreads, int );
00239   vtkGetMacro( NumberOfThreads, int );
00240
00241   vtkSetMacro( SavePointInterval, float );
00242   vtkGetMacro( SavePointInterval, float );
00243
00245
00249   vtkSetObjectMacro ( Integrator, vtkInitialValueProblemSolver );
00250   vtkGetObjectMacro ( Integrator, vtkInitialValueProblemSolver );
00252
00253 protected:
00254
00255   vtkStreamer();
00256   ~vtkStreamer();
00257
00258   // Integrate data
00259   void Integrate();
00260
00261   // Special method for computing streamer vorticity
00262   void ComputeVorticity();
00263
00264   // Controls where streamlines start from (either position or location).
00265   int StartFrom;
00266
00267   // Starting from cell location
00268   vtkIdType StartCell;
00269   int StartSubId;
00270   float StartPCoords[3];
00271
00272   // starting from global x-y-z position
00273   float StartPosition[3];
00274
00275   //array of streamers
00276   vtkStreamArray *Streamers;
00277   vtkIdType NumberOfStreamers;
00278
00279   // length of Streamer is generated by time, or by MaximumSteps
00280   float MaximumPropagationTime;
00281
00282   // integration direction
00283   int IntegrationDirection;
00284
00285   // the length (fraction of cell size) of integration steps
00286   float IntegrationStepLength;
00287
00288   // boolean controls whether vorticity is computed
00289   int Vorticity;
00290
00291   // terminal propagation speed
00292   float TerminalSpeed;
00293
00294   // boolean controls whether data scalars or velocity magnitude are used
00295   int SpeedScalars;
00296
00297   // boolean controls whether data scalars or vorticity orientation are used
00298   int OrientationScalars;
00299
00300   // Prototype showing the integrator type to be set by the user.
00301   vtkInitialValueProblemSolver* Integrator;
00302
00303   // Interval with which the stream points will be stored.
00304   // Useful in reducing the memory footprint. Since the initial
00305   // value is small, by default, it will store all/most points.
00306   float SavePointInterval;
00307
00308   static  VTK_THREAD_RETURN_TYPE ThreadedIntegrate( void *arg );
00309
00311
00313   vtkGetMacro( NumberOfStreamers, int );
00314   vtkStreamArray *GetStreamers() { return this->Streamers; };
00316
00317   void InitializeThreadedIntegrate();
00318   vtkMultiThreader           *Threader;
00319   int                        NumberOfThreads;
00320
00321 private:
00322   vtkStreamer(const vtkStreamer&);  // Not implemented.
00323   void operator=(const vtkStreamer&);  // Not implemented.
00324 };
00325
00327 inline const char *vtkStreamer::GetIntegrationDirectionAsString(void)
00328 {
00329   if ( this->IntegrationDirection == VTK_INTEGRATE_FORWARD )
00330     {
00331     return "IntegrateForward";
00332     }
00333   else if ( this->IntegrationDirection == VTK_INTEGRATE_BACKWARD )
00334     {
00335     return "IntegrateBackward";
00336     }
00337   else
00338     {
00339     return "IntegrateBothDirections";
00340     }
00341 }
00342
00343 #endif
00344
00345
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStreamLine.h Source File

Graphics/vtkStreamLine.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStreamLine.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00063 #ifndef __vtkStreamLine_h
00064 #define __vtkStreamLine_h
00065
00066 #include "vtkStreamer.h"
00067
00068 class VTK_GRAPHICS_EXPORT vtkStreamLine : public vtkStreamer
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkStreamLine,vtkStreamer);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075   static vtkStreamLine *New();
00076
00078
00081   vtkSetClampMacro(StepLength,float,0.000001,VTK_LARGE_FLOAT);
00082   vtkGetMacro(StepLength,float);
00084
00085 protected:
00086   vtkStreamLine();
00087   ~vtkStreamLine() {};
00088
00089   // Convert streamer array into vtkPolyData
00090   void Execute();
00091
00092   // the length of line primitives
00093   float StepLength;
00094
00095 private:
00096   vtkStreamLine(const vtkStreamLine&);  // Not implemented.
00097   void operator=(const vtkStreamLine&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStreamPoints.h Source File

Graphics/vtkStreamPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStreamPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkStreamPoints_h
00044 #define __vtkStreamPoints_h
00045
00046 #include "vtkStreamer.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkStreamPoints : public vtkStreamer
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkStreamPoints,vtkStreamer);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00055   static vtkStreamPoints *New();
00056
00058
00059   vtkSetClampMacro(TimeIncrement,float,0.000001,VTK_LARGE_FLOAT);
00060   vtkGetMacro(TimeIncrement,float);
00062
00063 protected:
00064   vtkStreamPoints();
00065   ~vtkStreamPoints() {};
00066
00067   // Convert streamer array into vtkPolyData
00068   void Execute();
00069
00070   // the separation of points
00071   float TimeIncrement;
00072
00073 private:
00074   vtkStreamPoints(const vtkStreamPoints&);  // Not implemented.
00075   void operator=(const vtkStreamPoints&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStripper.h Source File

Graphics/vtkStripper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStripper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkStripper_h
00059 #define __vtkStripper_h
00060
00061 #include "vtkPolyDataToPolyDataFilter.h"
00062
00063 class VTK_GRAPHICS_EXPORT vtkStripper : public vtkPolyDataToPolyDataFilter
00064 {
00065 public:
00066   vtkTypeRevisionMacro(vtkStripper,vtkPolyDataToPolyDataFilter);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00070   static vtkStripper *New();
00071
00073
00075   vtkSetClampMacro(MaximumLength,int,4,100000);
00076   vtkGetMacro(MaximumLength,int);
00078
00079 protected:
00080   vtkStripper();
00081   ~vtkStripper() {}
00082
00083   // Usual data generation method
00084   void Execute();
00085
00086   int MaximumLength;
00087
00088 private:
00089   vtkStripper(const vtkStripper&);  // Not implemented.
00090   void operator=(const vtkStripper&);  // Not implemented.
00091 };
00092
00093 #endif
00094
00095
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkStructuredData.h Source File

Common/vtkStructuredData.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredData.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkStructuredData_h
00036 #define __vtkStructuredData_h
00037
00038 #include "vtkObject.h"
00039 #include "vtkIdList.h"
00040
00041 #define VTK_UNCHANGED 0
00042 #define VTK_SINGLE_POINT 1
00043 #define VTK_X_LINE 2
00044 #define VTK_Y_LINE 3
00045 #define VTK_Z_LINE 4
00046 #define VTK_XY_PLANE 5
00047 #define VTK_YZ_PLANE 6
00048 #define VTK_XZ_PLANE 7
00049 #define VTK_XYZ_GRID 8
00050 #define VTK_EMPTY 9
00051
00052 class VTK_COMMON_EXPORT vtkStructuredData : public vtkObject
00053 {
00054 public:
00055   static vtkStructuredData *New();
00056   vtkTypeRevisionMacro(vtkStructuredData,vtkObject);
00057
00059
00064   static int SetDimensions(int inDim[3], int dim[3]);
00065   static int SetExtent(int inExt[6], int ext[6]);
00067
00069   static int GetDataDimension(int dataDescription);
00070
00072
00073   static void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds,
00074                             int dataDescription, int dim[3]);
00076
00078   static void GetPointCells(vtkIdType ptId, vtkIdList *cellIds, int dim[3]);
00079
00081
00083   static void GetCellNeigbors(vtkIdType cellId, vtkIdList *ptIds,
00084                               vtkIdList *cellIds, int dim[3]);
00086
00088
00090   static vtkIdType ComputePointId(int dim[3], int ijk[3]) {
00091     return ijk[2]*dim[0]*dim[1] + ijk[1]*dim[0] + ijk[0];}
00093
00095
00097   static vtkIdType ComputeCellId(int dim[3], int ijk[3]) {
00098     return ijk[2]*(dim[0]-1)*(dim[1]-1) + ijk[1]*(dim[0]-1) + ijk[0];};
00100
00101 protected:
00102   vtkStructuredData() {};
00103   ~vtkStructuredData() {};
00104
00105 private:
00106   vtkStructuredData(const vtkStructuredData&);  // Not implemented.
00107   void operator=(const vtkStructuredData&);  // Not implemented.
00108 };
00109
00110
00111 #endif
00112
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkStructuredGrid.h Source File

Common/vtkStructuredGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkStructuredGrid_h
00050 #define __vtkStructuredGrid_h
00051
00052 #include "vtkPointSet.h"
00053 #include "vtkStructuredData.h"
00054 #include "vtkUnsignedCharArray.h"
00055
00056 class vtkVertex;
00057 class vtkLine;
00058 class vtkQuad;
00059 class vtkHexahedron;
00060 class vtkEmptyCell;
00061
00062 class VTK_COMMON_EXPORT vtkStructuredGrid : public vtkPointSet
00063 {
00064 public:
00065   static vtkStructuredGrid *New();
00066
00067   vtkTypeRevisionMacro(vtkStructuredGrid,vtkPointSet);
00068   void PrintSelf(ostream& os, vtkIndent indent);
00069
00071   int GetDataObjectType() {return VTK_STRUCTURED_GRID;}
00072
00074   vtkDataObject *MakeObject() {return vtkStructuredGrid::New();}
00075
00078   void CopyStructure(vtkDataSet *ds);
00079
00081
00082   vtkIdType GetNumberOfPoints() {return vtkPointSet::GetNumberOfPoints();}
00083   float *GetPoint(vtkIdType ptId) {return this->vtkPointSet::GetPoint(ptId);}
00084   void GetPoint(vtkIdType ptId, float p[3])
00085     {this->vtkPointSet::GetPoint(ptId,p);}
00086   vtkCell *GetCell(vtkIdType cellId);
00087   void GetCell(vtkIdType cellId, vtkGenericCell *cell);
00088   void GetCellBounds(vtkIdType cellId, float bounds[6]);
00089   int GetCellType(vtkIdType cellId);
00090   vtkIdType GetNumberOfCells();
00091   void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds);
00092   void GetPointCells(vtkIdType ptId, vtkIdList *cellIds)
00093     {
00094       vtkStructuredData::GetPointCells(ptId,cellIds,this->GetDimensions());
00095     }
00096   void Initialize();
00097   int GetMaxCellSize() {return 8;}; //hexahedron is the largest
00098   void GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds,
00099                         vtkIdList *cellIds);
00100   virtual void GetScalarRange(float range[2]);
00101   float *GetScalarRange() {return this->vtkPointSet::GetScalarRange();}
00103
00105
00106   void SetDimensions(int i, int j, int k);
00107   void SetDimensions(int dim[3]);
00109
00111
00112   virtual int *GetDimensions ();
00113   virtual void GetDimensions (int dim[3]);
00115
00117   int GetDataDimension();
00118
00120
00122   void SetBlanking(int blanking);
00123   int GetBlanking() {return this->Blanking;}
00124   void BlankingOn();
00125   void BlankingOff();
00126   void BlankPoint(vtkIdType ptId);
00127   void UnBlankPoint(vtkIdType ptId);
00129
00131
00132   vtkUnsignedCharArray *GetPointVisibility()
00133     {return this->PointVisibility;}
00135
00139   void SetPointVisibility(vtkUnsignedCharArray *pointVisibility);
00140
00142
00144   unsigned char IsPointVisible(vtkIdType ptId)
00145     {return (this->Blanking ? this->PointVisibility->GetValue(ptId) : 1);}
00147
00150   unsigned char IsCellVisible(vtkIdType cellId);
00151
00153
00156   void SetUpdateExtent(int piece, int numPieces, int ghostLevel);
00157   void SetUpdateExtent(int piece, int numPieces)
00158     {this->SetUpdateExtent(piece, numPieces, 0);}
00160
00162
00163   void SetUpdateExtent( int x1, int x2, int y1, int y2, int z1, int z2 )
00164     { this->vtkPointSet::SetUpdateExtent( x1, x2, y1, y2, z1, z2 ); };
00165   void SetUpdateExtent( int ext[6] )
00166     { this->vtkPointSet::SetUpdateExtent( ext ); };
00168
00170
00173   void SetExtent(int extent[6]);
00174   void SetExtent(int x1, int x2, int y1, int y2, int z1, int z2);
00175   vtkGetVector6Macro(Extent,int);
00177
00183   unsigned long GetActualMemorySize();
00184
00186
00187   void ShallowCopy(vtkDataObject *src);
00188   void DeepCopy(vtkDataObject *src);
00190
00191 protected:
00192   vtkStructuredGrid();
00193   ~vtkStructuredGrid();
00194
00195   // for the GetCell method
00196   vtkVertex *Vertex;
00197   vtkLine *Line;
00198   vtkQuad *Quad;
00199   vtkHexahedron *Hexahedron;
00200   vtkEmptyCell *EmptyCell;
00201
00202   // The extent type is a 3D extent
00203   int GetExtentType() { return VTK_3D_EXTENT; }
00204
00208   virtual void Crop();
00209
00210   int Dimensions[3];
00211   int DataDescription;
00212   int Blanking;
00213   vtkUnsignedCharArray *PointVisibility;
00214   void AllocatePointVisibility();
00215
00216 private:
00218
00219   void GetCellNeighbors(vtkIdType cellId, vtkIdList& ptIds, vtkIdList& cellIds)
00220     {this->GetCellNeighbors(cellId, &ptIds, &cellIds);}
00222
00223   // Internal method used by DeepCopy and ShallowCopy.
00224   void InternalStructuredGridCopy(vtkStructuredGrid *src);
00225
00226 private:
00227   vtkStructuredGrid(const vtkStructuredGrid&);  // Not implemented.
00228   void operator=(const vtkStructuredGrid&);  // Not implemented.
00229 };
00230
00231
00232 inline vtkIdType vtkStructuredGrid::GetNumberOfCells()
00233 {
00234   int nCells=1;
00235   int dims[3];
00236   int i;
00237
00238   this->GetDimensions(dims);
00239   for (i=0; i<3; i++)
00240     {
00241     if (dims[i] <= 0)
00242       {
00243       return 0;
00244       }
00245     if (dims[i] > 1)
00246       {
00247       nCells *= (dims[i]-1);
00248       }
00249     }
00250
00251   return nCells;
00252 }
00253
00254 inline int vtkStructuredGrid::GetDataDimension()
00255 {
00256   return vtkStructuredData::GetDataDimension(this->DataDescription);
00257 }
00258
00259 #endif
00260
00261
00262
00263
00264
00265
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStructuredGridGeometryFilter.h Source File

Graphics/vtkStructuredGridGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkStructuredGridGeometryFilter_h
00063 #define __vtkStructuredGridGeometryFilter_h
00064
00065 #include "vtkStructuredGridToPolyDataFilter.h"
00066
00067 class VTK_GRAPHICS_EXPORT vtkStructuredGridGeometryFilter : public vtkStructuredGridToPolyDataFilter
00068 {
00069 public:
00070   static vtkStructuredGridGeometryFilter *New();
00071   vtkTypeRevisionMacro(vtkStructuredGridGeometryFilter,vtkStructuredGridToPolyDataFilter);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00075
00077   vtkGetVectorMacro(Extent,int,6);
00079
00081   void SetExtent(int iMin, int iMax, int jMin, int jMax, int kMin, int kMax);
00082
00084   void SetExtent(int extent[6]);
00085
00086 protected:
00087   vtkStructuredGridGeometryFilter();
00088   ~vtkStructuredGridGeometryFilter() {}
00089
00090   void Execute();
00091   void ComputeInputUpdateExtents( vtkDataObject *output );
00092   int Extent[6];
00093 private:
00094   vtkStructuredGridGeometryFilter(const vtkStructuredGridGeometryFilter&);  // Not implemented.
00095   void operator=(const vtkStructuredGridGeometryFilter&);  // Not implemented.
00096 };
00097
00098 #endif
00099
00100
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStructuredGridOutlineFilter.h Source File

Graphics/vtkStructuredGridOutlineFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridOutlineFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkStructuredGridOutlineFilter_h
00044 #define __vtkStructuredGridOutlineFilter_h
00045
00046 #include "vtkStructuredGridToPolyDataFilter.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkStructuredGridOutlineFilter : public vtkStructuredGridToPolyDataFilter
00049 {
00050 public:
00051   static vtkStructuredGridOutlineFilter *New();
00052   vtkTypeRevisionMacro(vtkStructuredGridOutlineFilter,vtkStructuredGridToPolyDataFilter);
00053
00054 protected:
00055   vtkStructuredGridOutlineFilter() {};
00056   ~vtkStructuredGridOutlineFilter() {};
00057
00058   void Execute();
00059 private:
00060   vtkStructuredGridOutlineFilter(const vtkStructuredGridOutlineFilter&);  // Not implemented.
00061   void operator=(const vtkStructuredGridOutlineFilter&);  // Not implemented.
00062 };
00063
00064 #endif
00065
00066
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkStructuredGridReader.h Source File

IO/vtkStructuredGridReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkStructuredGridReader_h
00050 #define __vtkStructuredGridReader_h
00051
00052 #include "vtkDataReader.h"
00053 #include "vtkStructuredGrid.h"
00054
00055 class VTK_IO_EXPORT vtkStructuredGridReader : public vtkDataReader
00056 {
00057 public:
00058   static vtkStructuredGridReader *New();
00059   vtkTypeRevisionMacro(vtkStructuredGridReader,vtkDataReader);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   vtkStructuredGrid *GetOutput();
00065   vtkStructuredGrid *GetOutput(int idx)
00066     {return (vtkStructuredGrid *) this->vtkSource::GetOutput(idx); };
00067   void SetOutput(vtkStructuredGrid *output);
00069
00070 protected:
00071   vtkStructuredGridReader();
00072   ~vtkStructuredGridReader();
00073
00074   void ExecuteInformation();
00075   void Execute();
00076
00077 private:
00078   vtkStructuredGridReader(const vtkStructuredGridReader&);  // Not implemented.
00079   void operator=(const vtkStructuredGridReader&);  // Not implemented.
00080 };
00081
00082 #endif
00083
00084
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredGridSource.h Source File

Filtering/vtkStructuredGridSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkStructuredGridSource_h
00037 #define __vtkStructuredGridSource_h
00038
00039 #include "vtkSource.h"
00040 #include "vtkStructuredGrid.h"
00041
00042 class VTK_FILTERING_EXPORT vtkStructuredGridSource : public vtkSource
00043 {
00044 public:
00045   static vtkStructuredGridSource *New();
00046   vtkTypeRevisionMacro(vtkStructuredGridSource,vtkSource);
00047
00049
00050   vtkStructuredGrid *GetOutput();
00051   vtkStructuredGrid *GetOutput(int idx)
00052     {return (vtkStructuredGrid *) this->vtkSource::GetOutput(idx); };
00053   void SetOutput(vtkStructuredGrid *output);
00055
00056 protected:
00057   vtkStructuredGridSource();
00058   ~vtkStructuredGridSource() {};
00059
00060 private:
00061   vtkStructuredGridSource(const vtkStructuredGridSource&);  // Not implemented.
00062   void operator=(const vtkStructuredGridSource&);  // Not implemented.
00063 };
00064
00065 #endif
00066
00067
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredGridToPolyDataFilter.h Source File

Filtering/vtkStructuredGridToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkStructuredGridToPolyDataFilter_h
00038 #define __vtkStructuredGridToPolyDataFilter_h
00039
00040 #include "vtkPolyDataSource.h"
00041 #include "vtkStructuredGrid.h"
00042
00043 class VTK_FILTERING_EXPORT vtkStructuredGridToPolyDataFilter : public vtkPolyDataSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkStructuredGridToPolyDataFilter,vtkPolyDataSource);
00047
00049
00050   void SetInput(vtkStructuredGrid *input);
00051   vtkStructuredGrid *GetInput();
00053
00054 protected:
00055   vtkStructuredGridToPolyDataFilter() {this->NumberOfRequiredInputs = 1;};
00056   ~vtkStructuredGridToPolyDataFilter() {};
00057
00058 private:
00059   vtkStructuredGridToPolyDataFilter(const vtkStructuredGridToPolyDataFilter&);  // Not implemented.
00060   void operator=(const vtkStructuredGridToPolyDataFilter&);  // Not implemented.
00061 };
00062
00063 #endif
00064
00065
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredGridToStructuredGridFilter.h Source File

Filtering/vtkStructuredGridToStructuredGridFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridToStructuredGridFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkStructuredGridToStructuredGridFilter_h
00039 #define __vtkStructuredGridToStructuredGridFilter_h
00040
00041 #include "vtkStructuredGridSource.h"
00042
00043 class VTK_FILTERING_EXPORT vtkStructuredGridToStructuredGridFilter : public vtkStructuredGridSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkStructuredGridToStructuredGridFilter,vtkStructuredGridSource);
00047
00049
00050   void SetInput(vtkStructuredGrid *input);
00051   vtkStructuredGrid *GetInput();
00053
00054 protected:
00055   vtkStructuredGridToStructuredGridFilter() {this->NumberOfRequiredInputs = 1;};
00056   ~vtkStructuredGridToStructuredGridFilter() {};
00057 private:
00058   vtkStructuredGridToStructuredGridFilter(const vtkStructuredGridToStructuredGridFilter&);  // Not implemented.
00059   void operator=(const vtkStructuredGridToStructuredGridFilter&);  // Not implemented.
00060 };
00061
00062 #endif
00063
00064
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkStructuredGridWriter.h Source File

IO/vtkStructuredGridWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredGridWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkStructuredGridWriter_h
00040 #define __vtkStructuredGridWriter_h
00041
00042 #include "vtkDataWriter.h"
00043 #include "vtkStructuredGrid.h"
00044
00045 class VTK_IO_EXPORT vtkStructuredGridWriter : public vtkDataWriter
00046 {
00047 public:
00048   static vtkStructuredGridWriter *New();
00049   vtkTypeRevisionMacro(vtkStructuredGridWriter,vtkDataWriter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   void SetInput(vtkStructuredGrid *input);
00055   vtkStructuredGrid *GetInput();
00057
00058 protected:
00059   vtkStructuredGridWriter() {};
00060   ~vtkStructuredGridWriter() {};
00061
00062   void WriteData();
00063   void WriteBlanking(ostream *fp, vtkStructuredGrid *ds);
00064
00065 private:
00066   vtkStructuredGridWriter(const vtkStructuredGridWriter&);  // Not implemented.
00067   void operator=(const vtkStructuredGridWriter&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkStructuredPoints.h Source File

Common/vtkStructuredPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkStructuredPoints_h
00045 #define __vtkStructuredPoints_h
00046
00047 #include "vtkImageData.h"
00048
00049
00050 class VTK_COMMON_EXPORT vtkStructuredPoints : public vtkImageData
00051 {
00052 public:
00053   static vtkStructuredPoints *New();
00054   vtkTypeRevisionMacro(vtkStructuredPoints,vtkImageData);
00055
00057   vtkDataObject *MakeObject() {return vtkStructuredPoints::New();}
00058
00060   int GetDataObjectType() {return VTK_STRUCTURED_POINTS;}
00061
00062 protected:
00063   vtkStructuredPoints();
00064   ~vtkStructuredPoints() {};
00065 private:
00066   vtkStructuredPoints(const vtkStructuredPoints&);  // Not implemented.
00067   void operator=(const vtkStructuredPoints&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
00073
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredPointsCollection.h Source File

Filtering/vtkStructuredPointsCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkStructuredPointsCollection_h
00037 #define __vtkStructuredPointsCollection_h
00038
00039 #include "vtkCollection.h"
00040 #include "vtkStructuredPoints.h"
00041
00042 class VTK_FILTERING_EXPORT vtkStructuredPointsCollection : public vtkCollection
00043 {
00044 public:
00045   static vtkStructuredPointsCollection *New();
00046   vtkTypeRevisionMacro(vtkStructuredPointsCollection,vtkCollection);
00047
00049
00050   void AddItem(vtkStructuredPoints *ds) {
00051     this->vtkCollection::AddItem((vtkObject *)ds);};
00053
00055
00057   vtkStructuredPoints *GetNextItem() {
00058     return static_cast<vtkStructuredPoints *>(this->GetNextItemAsObject());};
00060
00061 protected:
00062   vtkStructuredPointsCollection() {};
00063   ~vtkStructuredPointsCollection() {};
00064
00065
00066
00067 private:
00068   // hide the standard AddItem from the user and the compiler.
00069   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00070
00071 private:
00072   vtkStructuredPointsCollection(const vtkStructuredPointsCollection&);  // Not implemented.
00073   void operator=(const vtkStructuredPointsCollection&);  // Not implemented.
00074 };
00075
00076
00077 #endif
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkStructuredPointsGeometryFilter.h Source File

Graphics/vtkStructuredPointsGeometryFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsGeometryFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkStructuredPointsGeometryFilter_h
00036 #define __vtkStructuredPointsGeometryFilter_h
00037
00038 #include "vtkImageDataGeometryFilter.h"
00039
00040 class VTK_GRAPHICS_EXPORT vtkStructuredPointsGeometryFilter : public vtkImageDataGeometryFilter
00041 {
00042 public:
00043   vtkTypeRevisionMacro(vtkStructuredPointsGeometryFilter,vtkImageDataGeometryFilter);
00044
00046   static vtkStructuredPointsGeometryFilter *New();
00047
00048 protected:
00049   vtkStructuredPointsGeometryFilter();
00050   ~vtkStructuredPointsGeometryFilter() {};
00051   vtkStructuredPointsGeometryFilter(const vtkStructuredPointsGeometryFilter&);
00052   void operator=(const vtkStructuredPointsGeometryFilter&);
00053 };
00054
00055 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkStructuredPointsReader.h Source File

IO/vtkStructuredPointsReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkStructuredPointsReader_h
00050 #define __vtkStructuredPointsReader_h
00051
00052 #include "vtkDataReader.h"
00053 #include "vtkStructuredPoints.h"
00054
00055 class VTK_IO_EXPORT vtkStructuredPointsReader : public vtkDataReader
00056 {
00057 public:
00058   static vtkStructuredPointsReader *New();
00059   vtkTypeRevisionMacro(vtkStructuredPointsReader,vtkDataReader);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   void SetOutput(vtkStructuredPoints *output);
00065   vtkStructuredPoints *GetOutput(int idx)
00066     {return (vtkStructuredPoints *) this->vtkSource::GetOutput(idx); };
00067   vtkStructuredPoints *GetOutput();
00069
00070 protected:
00071   vtkStructuredPointsReader();
00072   ~vtkStructuredPointsReader();
00073
00074   void Execute();
00075
00076   // Default method performs Update to get information.  Not all the old
00077   // structured points sources compute information
00078   void ExecuteInformation();
00079
00080 private:
00081   vtkStructuredPointsReader(const vtkStructuredPointsReader&);  // Not implemented.
00082   void operator=(const vtkStructuredPointsReader&);  // Not implemented.
00083 };
00084
00085 #endif
00086
00087
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredPointsSource.h Source File

Filtering/vtkStructuredPointsSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkStructuredPointsSource_h
00038 #define __vtkStructuredPointsSource_h
00039
00040 #include "vtkSource.h"
00041 #include "vtkStructuredPoints.h"
00042
00043 class VTK_FILTERING_EXPORT vtkStructuredPointsSource : public vtkSource
00044 {
00045 public:
00046   static vtkStructuredPointsSource *New();
00047   vtkTypeRevisionMacro(vtkStructuredPointsSource,vtkSource);
00048
00050
00051   void SetOutput(vtkStructuredPoints *output);
00052   vtkStructuredPoints *GetOutput();
00053   vtkStructuredPoints *GetOutput(int idx)
00054     {return (vtkStructuredPoints *) this->vtkSource::GetOutput(idx); };
00056
00057 protected:
00058   vtkStructuredPointsSource();
00059   ~vtkStructuredPointsSource() {};
00060
00061   // Default method performs Update to get information.  Not all the old
00062   // structured points sources compute information
00063   void ExecuteInformation();
00064
00065 private:
00066   vtkStructuredPointsSource(const vtkStructuredPointsSource&);  // Not implemented.
00067   void operator=(const vtkStructuredPointsSource&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredPointsToPolyDataFilter.h Source File

Filtering/vtkStructuredPointsToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkStructuredPointsToPolyDataFilter_h
00041 #define __vtkStructuredPointsToPolyDataFilter_h
00042
00043 #include "vtkPolyDataSource.h"
00044 #include "vtkImageData.h"
00045 #include "vtkStructuredPoints.h"
00046
00047 class VTK_FILTERING_EXPORT vtkStructuredPointsToPolyDataFilter : public vtkPolyDataSource
00048 {
00049 public:
00050   vtkTypeRevisionMacro(vtkStructuredPointsToPolyDataFilter,vtkPolyDataSource);
00051
00053
00054   void SetInput(vtkImageData *input);
00055   vtkImageData *GetInput();
00057
00058 protected:
00059   vtkStructuredPointsToPolyDataFilter() {this->NumberOfRequiredInputs = 1;};
00060   ~vtkStructuredPointsToPolyDataFilter() {};
00061
00062   void ComputeInputUpdateExtents(vtkDataObject *output);
00063 private:
00064   vtkStructuredPointsToPolyDataFilter(const vtkStructuredPointsToPolyDataFilter&);  // Not implemented.
00065   void operator=(const vtkStructuredPointsToPolyDataFilter&);  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredPointsToStructuredPointsFilter.h Source File

Filtering/vtkStructuredPointsToStructuredPointsFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsToStructuredPointsFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkStructuredPointsToStructuredPointsFilter_h
00041 #define __vtkStructuredPointsToStructuredPointsFilter_h
00042
00043 #include "vtkStructuredPointsSource.h"
00044
00045 class VTK_FILTERING_EXPORT vtkStructuredPointsToStructuredPointsFilter : public vtkStructuredPointsSource
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkStructuredPointsToStructuredPointsFilter,vtkStructuredPointsSource);
00049
00051
00052   void SetInput(vtkImageData *input);
00053   vtkImageData *GetInput();
00055
00056 protected:
00057   vtkStructuredPointsToStructuredPointsFilter() {this->NumberOfRequiredInputs = 1;};
00058   ~vtkStructuredPointsToStructuredPointsFilter() {};
00059
00060   // Since input[0] and output are of same type, we can create this
00061   // method that defaults to just copying information.
00062   void ExecuteInformation();
00063
00064   void ComputeInputUpdateExtents(vtkDataObject *output);
00065
00066 private:
00067   vtkStructuredPointsToStructuredPointsFilter(const vtkStructuredPointsToStructuredPointsFilter&);  // Not implemented.
00068   void operator=(const vtkStructuredPointsToStructuredPointsFilter&);  // Not implemented.
00069 };
00070
00071 #endif
00072
00073
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkStructuredPointsToUnstructuredGridFilter.h Source File

Filtering/vtkStructuredPointsToUnstructuredGridFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsToUnstructuredGridFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkStructuredPointsToUnstructuredGridFilter_h
00040 #define __vtkStructuredPointsToUnstructuredGridFilter_h
00041
00042 #include "vtkStructuredPoints.h"
00043 #include "vtkUnstructuredGridSource.h"
00044
00045 class VTK_FILTERING_EXPORT vtkStructuredPointsToUnstructuredGridFilter : public vtkUnstructuredGridSource
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkStructuredPointsToUnstructuredGridFilter,vtkUnstructuredGridSource);
00049
00051
00052   void SetInput(vtkImageData *input);
00053   vtkImageData *GetInput();
00055
00056 protected:
00057   vtkStructuredPointsToUnstructuredGridFilter() {this->NumberOfRequiredInputs = 1;};
00058   ~vtkStructuredPointsToUnstructuredGridFilter() {};
00059
00060   void ComputeInputUpdateExtents(vtkDataObject *output);
00061
00062 private:
00063   vtkStructuredPointsToUnstructuredGridFilter(const vtkStructuredPointsToUnstructuredGridFilter&);  // Not implemented.
00064   void operator=(const vtkStructuredPointsToUnstructuredGridFilter&);  // Not implemented.
00065 };
00066
00067 #endif
00068
00069
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkStructuredPointsWriter.h Source File

IO/vtkStructuredPointsWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkStructuredPointsWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkStructuredPointsWriter_h
00037 #define __vtkStructuredPointsWriter_h
00038
00039 #include "vtkDataWriter.h"
00040 #include "vtkImageData.h"
00041
00042 class VTK_IO_EXPORT vtkStructuredPointsWriter : public vtkDataWriter
00043 {
00044 public:
00045   static vtkStructuredPointsWriter *New();
00046   vtkTypeRevisionMacro(vtkStructuredPointsWriter,vtkDataWriter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   void SetInput(vtkImageData *input);
00052   vtkImageData *GetInput();
00054
00055 protected:
00056   vtkStructuredPointsWriter() {};
00057   ~vtkStructuredPointsWriter() {};
00058
00059   void WriteData();
00060
00061 private:
00062   vtkStructuredPointsWriter(const vtkStructuredPointsWriter&);  // Not implemented.
00063   void operator=(const vtkStructuredPointsWriter&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSubdivideTetra.h Source File

Graphics/vtkSubdivideTetra.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSubdivideTetra.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkSubdivideTetra_h
00036 #define __vtkSubdivideTetra_h
00037
00038 #include "vtkUnstructuredGridToUnstructuredGridFilter.h"
00039
00040 class VTK_GRAPHICS_EXPORT vtkSubdivideTetra : public vtkUnstructuredGridToUnstructuredGridFilter
00041 {
00042 public:
00043   static vtkSubdivideTetra *New();
00044   vtkTypeRevisionMacro(vtkSubdivideTetra,vtkUnstructuredGridToUnstructuredGridFilter);
00045   void PrintSelf(ostream& os, vtkIndent indent);
00046
00047
00048 protected:
00049   vtkSubdivideTetra();
00050   ~vtkSubdivideTetra() {};
00051
00052   void Execute();
00053
00054 private:
00055   vtkSubdivideTetra(const vtkSubdivideTetra&);  // Not implemented.
00056   void operator=(const vtkSubdivideTetra&);  // Not implemented.
00057 };
00058
00059 #endif
00060
00061
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSubPixelPositionEdgels.h Source File

Graphics/vtkSubPixelPositionEdgels.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSubPixelPositionEdgels.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkSubPixelPositionEdgels_h
00053 #define __vtkSubPixelPositionEdgels_h
00054
00055 #include "vtkPolyDataToPolyDataFilter.h"
00056 #include "vtkStructuredPoints.h"
00057
00058 class VTK_GRAPHICS_EXPORT vtkSubPixelPositionEdgels : public vtkPolyDataToPolyDataFilter
00059 {
00060 public:
00061   static vtkSubPixelPositionEdgels *New();
00062   vtkTypeRevisionMacro(vtkSubPixelPositionEdgels,vtkPolyDataToPolyDataFilter);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066
00067   void SetGradMaps(vtkStructuredPoints *gm);
00068   vtkStructuredPoints *GetGradMaps();
00070
00072
00074   vtkSetMacro(TargetFlag, int);
00075   vtkGetMacro(TargetFlag, int);
00076   vtkBooleanMacro(TargetFlag, int);
00077   vtkSetMacro(TargetValue, float);
00078   vtkGetMacro(TargetValue, float);
00080
00081 protected:
00082   vtkSubPixelPositionEdgels();
00083   ~vtkSubPixelPositionEdgels();
00084
00085   // Usual data generation method
00086   void Execute();
00087   void Move(int xdim, int ydim, int zdim, int x, int y,
00088             float *img, vtkDataArray *inVecs,
00089             float *result, int z, float *aspect, float *resultNormal);
00090   // extension for target instead of maximum
00091   int TargetFlag;
00092   float TargetValue;
00093 private:
00094   vtkSubPixelPositionEdgels(const vtkSubPixelPositionEdgels&);  // Not implemented.
00095   void operator=(const vtkSubPixelPositionEdgels&);  // Not implemented.
00096 };
00097
00098 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkSuperquadric.h Source File

Filtering/vtkSuperquadric.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSuperquadric.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkSuperquadric_h
00052 #define __vtkSuperquadric_h
00053
00054 #include "vtkImplicitFunction.h"
00055
00056 #define VTK_MIN_SUPERQUADRIC_THICKNESS  1e-4
00057
00058 class VTK_FILTERING_EXPORT vtkSuperquadric : public vtkImplicitFunction
00059 {
00060 public:
00064   static vtkSuperquadric *New();
00065
00066   vtkTypeRevisionMacro(vtkSuperquadric,vtkImplicitFunction);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00069   // ImplicitFunction interface
00070   float EvaluateFunction(float x[3]);
00071   float EvaluateFunction(float x, float y, float z)
00072     {return this->vtkImplicitFunction::EvaluateFunction(x, y, z); } ;
00073   void EvaluateGradient(float x[3], float g[3]);
00074
00076
00077   vtkSetVector3Macro(Center,float);
00078   vtkGetVectorMacro(Center,float,3);
00080
00082
00083   vtkSetVector3Macro(Scale,float);
00084   vtkGetVectorMacro(Scale,float,3);
00086
00088
00090   vtkGetMacro(Thickness,float);
00091   vtkSetClampMacro(Thickness,float,VTK_MIN_SUPERQUADRIC_THICKNESS,1.0);
00093
00095
00097   vtkGetMacro(PhiRoundness,float);
00098   void SetPhiRoundness(float e);
00100
00102
00104   vtkGetMacro(ThetaRoundness,float);
00105   void SetThetaRoundness(float e);
00107
00109
00110   vtkSetMacro(Size,float);
00111   vtkGetMacro(Size,float);
00113
00115
00117   vtkBooleanMacro(Toroidal,int);
00118   vtkGetMacro(Toroidal,int);
00119   vtkSetMacro(Toroidal,int);
00121
00122 protected:
00123   vtkSuperquadric();
00124   ~vtkSuperquadric() {};
00125
00126   int Toroidal;
00127   float Thickness;
00128   float Size;
00129   float PhiRoundness;
00130   float ThetaRoundness;
00131   float Center[3];
00132   float Scale[3];
00133 private:
00134   vtkSuperquadric(const vtkSuperquadric&);  // Not implemented.
00135   void operator=(const vtkSuperquadric&);  // Not implemented.
00136 };
00137
00138 #endif
00139
00140
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkSuperquadricSource.h Source File

Graphics/vtkSuperquadricSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSuperquadricSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkSuperquadricSource_h
00063 #define __vtkSuperquadricSource_h
00064
00065 #include "vtkPolyDataSource.h"
00066
00067 #define VTK_MAX_SUPERQUADRIC_RESOLUTION 1024
00068 #define VTK_MIN_SUPERQUADRIC_THICKNESS  1e-4
00069 #define VTK_MIN_SUPERQUADRIC_ROUNDNESS  1e-24
00070
00071 class VTK_GRAPHICS_EXPORT vtkSuperquadricSource : public vtkPolyDataSource
00072 {
00073 public:
00076   static vtkSuperquadricSource *New();
00077
00078   vtkTypeRevisionMacro(vtkSuperquadricSource,vtkPolyDataSource);
00079   void PrintSelf(ostream& os, vtkIndent indent);
00080
00082
00083   vtkSetVector3Macro(Center,float);
00084   vtkGetVectorMacro(Center,float,3);
00086
00088
00089   vtkSetVector3Macro(Scale,float);
00090   vtkGetVectorMacro(Scale,float,3);
00092
00094
00095   vtkGetMacro(ThetaResolution,int);
00096   void SetThetaResolution(int i);
00098
00100
00101   vtkGetMacro(PhiResolution,int);
00102   void SetPhiResolution(int i);
00104
00106
00108   vtkGetMacro(Thickness,float);
00109   vtkSetClampMacro(Thickness,float,VTK_MIN_SUPERQUADRIC_THICKNESS,1.0);
00111
00113
00115   vtkGetMacro(PhiRoundness,float);
00116   void SetPhiRoundness(float e);
00118
00120
00122   vtkGetMacro(ThetaRoundness,float);
00123   void SetThetaRoundness(float e);
00125
00127
00128   vtkSetMacro(Size,float);
00129   vtkGetMacro(Size,float);
00131
00133
00135   vtkBooleanMacro(Toroidal,int);
00136   vtkGetMacro(Toroidal,int);
00137   vtkSetMacro(Toroidal,int);
00139
00140 protected:
00141   vtkSuperquadricSource(int res=16);
00142   ~vtkSuperquadricSource() {};
00143
00144   int Toroidal;
00145   float Thickness;
00146   float Size;
00147   float PhiRoundness;
00148   float ThetaRoundness;
00149   void Execute();
00150   float Center[3];
00151   float Scale[3];
00152   int ThetaResolution;
00153   int PhiResolution;
00154
00155 private:
00156   vtkSuperquadricSource(const vtkSuperquadricSource&);  // Not implemented.
00157   void operator=(const vtkSuperquadricSource&);  // Not implemented.
00158 };
00159
00160 #endif
00161
00162
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkSurfaceReconstructionFilter.h Source File

Imaging/vtkSurfaceReconstructionFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSurfaceReconstructionFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkSurfaceReconstructionFilter_h
00045 #define __vtkSurfaceReconstructionFilter_h
00046
00047 #include "vtkDataSetToStructuredPointsFilter.h"
00048
00049 class VTK_IMAGING_EXPORT vtkSurfaceReconstructionFilter : public vtkDataSetToStructuredPointsFilter
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkSurfaceReconstructionFilter,vtkDataSetToStructuredPointsFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056   static vtkSurfaceReconstructionFilter* New();
00057
00059
00065   vtkGetMacro(NeighborhoodSize,int);
00066   vtkSetMacro(NeighborhoodSize,int);
00068
00070
00072   vtkGetMacro(SampleSpacing,float);
00073   vtkSetMacro(SampleSpacing,float);
00075
00076 protected:
00077   vtkSurfaceReconstructionFilter();
00078   ~vtkSurfaceReconstructionFilter() {};
00079
00080   void Execute();
00081
00082   int NeighborhoodSize;
00083   float SampleSpacing;
00084 private:
00085   vtkSurfaceReconstructionFilter(const vtkSurfaceReconstructionFilter&);  // Not implemented.
00086   void operator=(const vtkSurfaceReconstructionFilter&);  // Not implemented.
00087 };
00088
00089 #endif
00090
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkSweptSurface.h Source File

Patented/vtkSweptSurface.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSweptSurface.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENTED UNDER UNITED STATES PATENT NUMBER 5,542,036
00016      "Implicit Modeling of Swept Volumes and Swept Surfaces"
00017      Application of this software for commercial purposes requires
00018      a license grant from GE. Contact:
00019
00020          Carl B. Horton
00021          Sr. Counsel, Intellectual Property
00022          3000 N. Grandview Blvd., W-710
00023          Waukesha, WI  53188
00024          Phone:  (262) 513-4022
00025          E-Mail: Carl.Horton@med.ge.com
00026
00027      for more information.
00028
00029 =========================================================================*/
00069 #ifndef __vtkSweptSurface_h
00070 #define __vtkSweptSurface_h
00071
00072 #include "vtkStructuredPointsToStructuredPointsFilter.h"
00073 #include "vtkTransformCollection.h"
00074
00075 class VTK_PATENTED_EXPORT vtkSweptSurface : public vtkStructuredPointsToStructuredPointsFilter
00076 {
00077 public:
00078   static vtkSweptSurface *New();
00079   vtkTypeRevisionMacro(vtkSweptSurface,vtkStructuredPointsToStructuredPointsFilter);
00080   void PrintSelf(ostream& os, vtkIndent indent);
00081
00083
00085   vtkSetVector3Macro(SampleDimensions,int);
00086   vtkGetVectorMacro(SampleDimensions,int,3);
00088
00090
00092   vtkSetObjectMacro(Transforms, vtkTransformCollection);
00093   vtkGetObjectMacro(Transforms, vtkTransformCollection);
00095
00097
00100   vtkSetMacro(FillValue,float);
00101   vtkGetMacro(FillValue,float);
00103
00105
00115   vtkSetMacro(NumberOfInterpolationSteps,int);
00116   vtkGetMacro(NumberOfInterpolationSteps,int);
00118
00120
00123   vtkSetMacro(MaximumNumberOfInterpolationSteps,int);
00124   vtkGetMacro(MaximumNumberOfInterpolationSteps,int);
00126
00128
00133   vtkSetMacro(Capping,int);
00134   vtkGetMacro(Capping,int);
00135   vtkBooleanMacro(Capping,int);
00137
00139
00144   vtkSetVectorMacro(ModelBounds,float,6);
00145   vtkGetVectorMacro(ModelBounds,float,6);
00146   void SetModelBounds(float xmin, float xmax, float ymin, float ymax,
00147                       float zmin, float zmax);
00149
00151
00155   vtkSetMacro(AdjustBounds,int);
00156   vtkGetMacro(AdjustBounds,int);
00157   vtkBooleanMacro(AdjustBounds,int);
00159
00161
00164   vtkSetClampMacro(AdjustDistance,float,-1.0,1.0);
00165   vtkGetMacro(AdjustDistance,float);
00167
00168   //overload to check transformation matrices
00169   unsigned long int GetMTime();
00170
00171 protected:
00172   vtkSweptSurface();
00173   ~vtkSweptSurface();
00174
00175   void Execute();
00176   void ExecuteInformation();
00177
00178   void ComputeBounds(float origin[3], float ar[3], float bbox[24]);
00179   int ComputeNumberOfSteps(vtkTransform *t1, vtkTransform *t2, float bbox[24]);
00180   void SampleInput(vtkMatrix4x4 *m, int inDim[3], float inOrigin[3],
00181                    float inAr[3], vtkDataArray *in, vtkDataArray *out);
00182   void ComputeFootprint (vtkMatrix4x4 *m, int inDim[3], float inOrigin[3],
00183                          float inSpacing[3], int Indicies[6]);
00184   void Cap(vtkDataArray *s);
00185   void GetRelativePosition(vtkTransform &t, float *origin, float *position);
00186   vtkMatrix4x4* GetActorMatrixPointer(vtkTransform &t,
00187                                       float origin[3],
00188                                      float position[3], float orientation[3]);
00189   virtual void InterpolateStates(float *pos1, float *pos2, float *euler1,
00190                                  float *euler2, float t, float *posOut,
00191                                  float *eulerOut);
00192
00193   int SampleDimensions[3];
00194   float FillValue;
00195   float ModelBounds[6];
00196   int NumberOfInterpolationSteps;
00197   int MaximumNumberOfInterpolationSteps;
00198   int Capping;
00199   int AdjustBounds;
00200   float AdjustDistance;
00201
00202   vtkTransformCollection *Transforms;
00203
00204 private:
00205   //used to perform computations
00206   vtkTransform *T;
00207 private:
00208   vtkSweptSurface(const vtkSweptSurface&);  // Not implemented.
00209   void operator=(const vtkSweptSurface&);  // Not implemented.
00210 };
00211
00212 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkSynchronizedTemplates2D.h Source File

Patented/vtkSynchronizedTemplates2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSynchronizedTemplates2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENT PENDING.
00016
00017      Application of this software for commercial purposes requires
00018      a license grant from Kitware. Contact:
00019          Ken Martin
00020          Kitware
00021          469 Clifton Corporate Parkway,
00022          Clifton Park, NY 12065
00023          Phone:1-518-371-3971
00024      for more information.
00025
00026 =========================================================================*/
00051 #ifndef __vtkSynchronizedTemplates2D_h
00052 #define __vtkSynchronizedTemplates2D_h
00053
00054 #include "vtkPolyDataSource.h"
00055 #include "vtkImageData.h"
00056 #include "vtkContourValues.h"
00057 #include "vtkKitwareContourFilter.h"
00058
00059 class VTK_PATENTED_EXPORT vtkSynchronizedTemplates2D : public vtkPolyDataSource
00060 {
00061 public:
00062   static vtkSynchronizedTemplates2D *New();
00063   vtkTypeRevisionMacro(vtkSynchronizedTemplates2D,vtkPolyDataSource);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00067
00068   void SetInput(vtkImageData *input);
00069   vtkImageData *GetInput();
00071
00073   unsigned long int GetMTime();
00074
00077   void SetValue(int i, float value) {this->ContourValues->SetValue(i,value);}
00078
00080   float GetValue(int i) {return this->ContourValues->GetValue(i);}
00081
00084   float *GetValues() {return this->ContourValues->GetValues();}
00085
00087
00090   void GetValues(float *contourValues) {
00091     this->ContourValues->GetValues(contourValues);}
00093
00095
00098   void SetNumberOfContours(int number) {
00099     this->ContourValues->SetNumberOfContours(number);}
00101
00103
00104   int GetNumberOfContours() {
00105     return this->ContourValues->GetNumberOfContours();}
00107
00109
00111   void GenerateValues(int numContours, float range[2]) {
00112     this->ContourValues->GenerateValues(numContours, range);}
00114
00116
00118   void GenerateValues(int numContours, float rangeStart, float rangeEnd)
00119     {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00121
00123
00125   vtkSetMacro(ComputeScalars,int);
00126   vtkGetMacro(ComputeScalars,int);
00127   vtkBooleanMacro(ComputeScalars,int);
00129
00131
00134   vtkGetStringMacro(InputScalarsSelection);
00135   void SelectInputScalars(const char *fieldName)
00136     {this->SetInputScalarsSelection(fieldName);}
00138
00139 protected:
00140   vtkSynchronizedTemplates2D();
00141   ~vtkSynchronizedTemplates2D();
00142
00143   void Execute();
00144   vtkContourValues *ContourValues;
00145
00146   int ComputeScalars;
00147
00148   char *InputScalarsSelection;
00149   vtkSetStringMacro(InputScalarsSelection);
00150
00151 private:
00152   //BTX
00153   friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter;
00154   //ETX
00155 private:
00156   vtkSynchronizedTemplates2D(const vtkSynchronizedTemplates2D&);  // Not implemented.
00157   void operator=(const vtkSynchronizedTemplates2D&);  // Not implemented.
00158 };
00159
00160
00161 #endif
00162
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Patented/vtkSynchronizedTemplates3D.h Source File

Patented/vtkSynchronizedTemplates3D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSynchronizedTemplates3D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015      THIS CLASS IS PATENT PENDING.
00016
00017      Application of this software for commercial purposes requires
00018      a license grant from Kitware. Contact:
00019          Ken Martin
00020          Kitware
00021          469 Clifton Corporate Parkway,
00022          Clifton Park, NY 12065
00023          Phone:1-518-371-3971
00024      for more information.
00025
00026 =========================================================================*/
00055 #ifndef __vtkSynchronizedTemplates3D_h
00056 #define __vtkSynchronizedTemplates3D_h
00057
00058 #include "vtkPolyDataSource.h"
00059 #include "vtkImageData.h"
00060 #include "vtkContourValues.h"
00061 #include "vtkMultiThreader.h"
00062 #include "vtkKitwareContourFilter.h"
00063
00064 class VTK_PATENTED_EXPORT vtkSynchronizedTemplates3D : public vtkPolyDataSource
00065 {
00066 public:
00067   static vtkSynchronizedTemplates3D *New();
00068
00069   vtkTypeRevisionMacro(vtkSynchronizedTemplates3D,vtkPolyDataSource);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00074   void SetInput(vtkImageData *input);
00075   vtkImageData *GetInput();
00077
00079   unsigned long int GetMTime();
00080
00082
00086   vtkSetMacro(ComputeNormals,int);
00087   vtkGetMacro(ComputeNormals,int);
00088   vtkBooleanMacro(ComputeNormals,int);
00090
00092
00098   vtkSetMacro(ComputeGradients,int);
00099   vtkGetMacro(ComputeGradients,int);
00100   vtkBooleanMacro(ComputeGradients,int);
00102
00104
00105   vtkSetMacro(ComputeScalars,int);
00106   vtkGetMacro(ComputeScalars,int);
00107   vtkBooleanMacro(ComputeScalars,int);
00109
00112   void SetValue(int i, float value) {this->ContourValues->SetValue(i,value);}
00113
00115   float GetValue(int i) {return this->ContourValues->GetValue(i);}
00116
00119   float *GetValues() {return this->ContourValues->GetValues();}
00120
00122
00125   void GetValues(float *contourValues) {
00126     this->ContourValues->GetValues(contourValues);}
00128
00130
00133   void SetNumberOfContours(int number) {
00134     this->ContourValues->SetNumberOfContours(number);}
00136
00138
00139   int GetNumberOfContours() {
00140     return this->ContourValues->GetNumberOfContours();}
00142
00144
00146   void GenerateValues(int numContours, float range[2]) {
00147     this->ContourValues->GenerateValues(numContours, range);}
00149
00151
00153   void GenerateValues(int numContours, float rangeStart, float rangeEnd)
00154     {this->ContourValues->GenerateValues(numContours, rangeStart, rangeEnd);}
00156
00158
00159   int *GetExecuteExtent() {return this->ExecuteExtent;}
00160   void ThreadedExecute(vtkImageData *data, int *exExt, int threadId);
00162
00164
00165   vtkSetClampMacro( NumberOfThreads, int, 1, VTK_MAX_THREADS );
00166   vtkGetMacro( NumberOfThreads, int );
00168
00170
00173   void SetInputMemoryLimit(unsigned long limit);
00174   unsigned long GetInputMemoryLimit();
00176
00178
00181   vtkGetStringMacro(InputScalarsSelection);
00182   void SelectInputScalars(const char *fieldName)
00183     {this->SetInputScalarsSelection(fieldName);}
00185
00186 protected:
00187   vtkSynchronizedTemplates3D();
00188   ~vtkSynchronizedTemplates3D();
00189
00190   int ComputeNormals;
00191   int ComputeGradients;
00192   int ComputeScalars;
00193   vtkContourValues *ContourValues;
00194
00195   void Execute();
00196   void ExecuteInformation();
00197
00198   void ComputeInputUpdateExtents(vtkDataObject *output);
00199
00200   int ExecuteExtent[6];
00201
00202   int NumberOfThreads;
00203   vtkMultiThreader *Threader;
00204   // temporary outputs
00205   vtkPolyData *Threads[VTK_MAX_THREADS];
00206
00207   char *InputScalarsSelection;
00208   vtkSetStringMacro(InputScalarsSelection);
00209
00210 private:
00211   //BTX
00212   friend class VTK_PATENTED_EXPORT vtkKitwareContourFilter;
00213   //ETX
00214
00215 private:
00216   vtkSynchronizedTemplates3D(const vtkSynchronizedTemplates3D&);  // Not implemented.
00217   void operator=(const vtkSynchronizedTemplates3D&);  // Not implemented.
00218 };
00219
00220
00221
00222
00223
00224
00225
00226 // template table.
00227 //BTX
00228
00229 extern int VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_1[];
00230 extern int VTK_SYNCHONIZED_TEMPLATES_3D_TABLE_2[];
00231
00232 //ETX
00233
00234 #endif
00235
Generated on Mon Mar 25 01:07:56 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkSystemIncludes.h Source File

Common/vtkSystemIncludes.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkSystemIncludes.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkSystemIncludes_h
00042 #define __vtkSystemIncludes_h
00043
00044 /* first include the local configuration for this machine */
00045 #include "vtkConfigure.h"
00046
00047 // include  generic stuff
00048 #include <stdio.h>
00049 #include <stdlib.h>
00050 #include <string.h>
00051
00052 // Handle changes for ANSI C++ ---------------------------------------------
00053 #ifdef VTK_USE_ANSI_STDLIB
00054 #include <iostream>
00055 #include <strstream>
00056 #include <fstream>
00057 using std::cerr;
00058 using std::cout;
00059 using std::cin;
00060 using std::ios;
00061 using std::endl;
00062 using std::ends;
00063 using std::ostream;
00064 using std::istream;
00065 using std::ostrstream;
00066 using std::istrstream;
00067 using std::ofstream;
00068 using std::ifstream;
00069
00070 // otherwise, non-ANSI -----------------------------------------------------
00071 #else
00072 #ifdef _WIN32_WCE
00073   #include "vtkWinCE.h"
00074 #else
00075   #include <iostream.h>
00076   #if defined(_MSC_VER)
00077     #include <strstrea.h>
00078   #else
00079     #include <strstream.h>
00080   #endif
00081   #include <fstream.h>
00082 #endif // Win CE
00083 #endif
00084
00085 #define VTK_HAS_ID_TYPE
00086 #ifdef VTK_USE_64BIT_IDS
00087 #ifdef _WIN32
00088 typedef __int64 vtkIdType;
00089
00090 /* ostream operator for __int64 */
00091 inline ostream& __cdecl operator<<(ostream& _O, __int64 i64Val)
00092 {
00093   wchar_t wchBuf[32];
00094   if (i64Val < 0)
00095   {
00096     _O << char("-");
00097     i64Val *= -1;
00098   }
00099   return (_O << _i64tow(i64Val, wchBuf, 10));
00100 };
00101
00102 #else
00103 typedef long long vtkIdType;
00104 #endif
00105 #else
00106 typedef int vtkIdType;
00107 #endif
00108
00109 #endif
00110
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTclUtil.h Source File

Common/vtkTclUtil.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTclUtil.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00017 #ifndef __vtkTclInclude_h
00018 #define __vtkTclInclude_h
00019
00020 #include "vtkObject.h"
00021 #include "vtkCommand.h"
00022 #include <tcl.h>
00023
00024 #ifdef WIN32
00025 #define VTKTCL_EXPORT __declspec( dllexport )
00026 #else
00027 #define VTKTCL_EXPORT
00028 #endif
00029
00030 extern VTKTCL_EXPORT void vtkTclDeleteObjectFromHash(vtkObject *,
00031                                                      unsigned long eventId,
00032                                                      void *, void *);
00033 extern VTKTCL_EXPORT void vtkTclGenericDeleteObject(ClientData cd);
00034
00035 extern VTKTCL_EXPORT void
00036 vtkTclGetObjectFromPointer(Tcl_Interp *interp, void *temp,
00037                            int (*command)(ClientData,
00038                                           Tcl_Interp *,int, char *[]));
00039
00040 extern VTKTCL_EXPORT void *
00041 vtkTclGetPointerFromObject(const char *name, const char *result_type,
00042                            Tcl_Interp *interp, int &error);
00043
00044 extern VTKTCL_EXPORT void vtkTclVoidFunc(void *);
00045 extern VTKTCL_EXPORT void vtkTclVoidFuncArgDelete(void *);
00046 extern VTKTCL_EXPORT void vtkTclListInstances(Tcl_Interp *interp,
00047                                               ClientData arg);
00048 extern VTKTCL_EXPORT int  vtkTclInDelete(Tcl_Interp *interp);
00049
00050 extern VTKTCL_EXPORT int vtkTclNewInstanceCommand(ClientData cd,
00051                                                   Tcl_Interp *interp,
00052                                                   int argc, char *argv[]);
00053 extern VTKTCL_EXPORT void vtkTclDeleteCommandStruct(ClientData cd);
00054 extern VTKTCL_EXPORT
00055 void vtkTclCreateNew(Tcl_Interp *interp, const char *cname,
00056                      ClientData (*NewCommand)(),
00057                      int (*CommandFunction)(ClientData cd,
00058                                             Tcl_Interp *interp,
00059                                             int argc, char *argv[]));
00060
00061 class vtkTclCommand : public vtkCommand
00062 {
00063 public:
00064   static vtkTclCommand *New() { return new vtkTclCommand; };
00065
00066   void SetStringCommand(const char *arg);
00067   void SetInterp(Tcl_Interp *interp) { this->Interp = interp; };
00068
00069   void Execute(vtkObject *, unsigned long, void *);
00070
00071   char *StringCommand;
00072   Tcl_Interp *Interp;
00073 protected:
00074   vtkTclCommand();
00075   ~vtkTclCommand();
00076 };
00077
00078 typedef struct _vtkTclVoidFuncArg
00079 {
00080   Tcl_Interp *interp;
00081   char *command;
00082 } vtkTclVoidFuncArg;
00083
00084 struct vtkTclCommandArgStruct
00085 {
00086   void *Pointer;
00087   Tcl_Interp *Interp;
00088   unsigned long Tag;
00089 };
00090
00091 struct vtkTclCommandStruct
00092 {
00093   ClientData (*NewCommand)();
00094   int (*CommandFunction)(ClientData cd, Tcl_Interp *interp,
00095                          int argc, char *argv[]);
00096 };
00097
00098 struct vtkTclInterpStruct
00099 {
00100   Tcl_HashTable InstanceLookup;
00101   Tcl_HashTable PointerLookup;
00102   Tcl_HashTable CommandLookup;
00103
00104   int Number;
00105   int DebugOn;
00106   int InDelete;
00107 };
00108
00109 #endif
00110
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTensor.h Source File

Common/vtkTensor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTensor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkTensor_h
00042 #define __vtkTensor_h
00043
00044 #include "vtkObject.h"
00045
00046 class VTK_COMMON_EXPORT vtkTensor : public vtkObject
00047 {
00048 public:
00049   static vtkTensor *New();
00050   vtkTypeRevisionMacro(vtkTensor,vtkObject);
00051
00053   void Initialize();
00054
00056   float GetComponent(int i, int j) {return this->T[i+3*j];};
00057
00059
00060   void SetComponent(int i, int j, float v) {if (i > 2 || j > 2) {vtkErrorMacro("trying to set tensor component i or j > 2: i = " << i << ", j = " << j); return;}; this->T[i+3*j] = v;};
00062
00064
00065   void AddComponent(int i, int j, float v) { if (i > 2 || j > 2) {vtkErrorMacro("trying to add tensor component i or j > 2: i = " << i << ", j = " << j); return;}; this->T[i+3*j] += v;};
00067
00069
00071   float *GetColumn(int j) { if (j > 2) {vtkErrorMacro("trying to get tensor column j > 2: j = " << j); return NULL;}; return this->T + 3*j;};
00073
00075   void DeepCopy(vtkTensor *t);
00076
00078   operator float*() {return this->T;};
00079
00081   float *T;
00082
00083 protected:
00084   vtkTensor();
00085   ~vtkTensor() {};
00086
00087   float Storage[9];
00088 private:
00089   vtkTensor(const vtkTensor&);  // Not implemented.
00090   void operator=(const vtkTensor&);  // Not implemented.
00091 };
00092
00093 inline void vtkTensor::Initialize()
00094 {
00095   for (int j=0; j<3; j++)
00096     {
00097     for (int i=0; i<3; i++)
00098       {
00099       this->T[i+j*3] = 0.0;
00100       }
00101     }
00102 }
00103
00104 inline void vtkTensor::DeepCopy(vtkTensor *t)
00105 {
00106   for (int j=0; j < 3; j++)
00107     {
00108     for (int i=0; i < 3; i++)
00109       {
00110       this->T[i+3*j] = t->T[i+3*j];
00111       }
00112     }
00113 }
00114
00115 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTensorGlyph.h Source File

Graphics/vtkTensorGlyph.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTensorGlyph.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00063 #ifndef __vtkTensorGlyph_h
00064 #define __vtkTensorGlyph_h
00065
00066 #include "vtkDataSetToPolyDataFilter.h"
00067
00068 class VTK_GRAPHICS_EXPORT vtkTensorGlyph : public vtkDataSetToPolyDataFilter
00069 {
00070 public:
00071   vtkTypeRevisionMacro(vtkTensorGlyph,vtkDataSetToPolyDataFilter);
00072   void PrintSelf(ostream& os, vtkIndent indent);
00073
00077   static vtkTensorGlyph *New();
00078
00080
00081   void SetSource(vtkPolyData *source);
00082   vtkPolyData *GetSource();
00084
00086
00087   vtkSetMacro(Scaling,int);
00088   vtkGetMacro(Scaling,int);
00089   vtkBooleanMacro(Scaling,int);
00091
00093
00095   vtkSetMacro(ScaleFactor,float);
00096   vtkGetMacro(ScaleFactor,float);
00098
00100
00101   vtkSetMacro(ExtractEigenvalues,int);
00102   vtkBooleanMacro(ExtractEigenvalues,int);
00103   vtkGetMacro(ExtractEigenvalues,int);
00105
00107
00110   vtkSetMacro(ColorGlyphs,int);
00111   vtkGetMacro(ColorGlyphs,int);
00112   vtkBooleanMacro(ColorGlyphs,int);
00114
00116
00119   vtkSetMacro(ClampScaling,int);
00120   vtkGetMacro(ClampScaling,int);
00121   vtkBooleanMacro(ClampScaling,int);
00123
00125
00129   vtkSetMacro(MaxScaleFactor,float);
00130   vtkGetMacro(MaxScaleFactor,float);
00132
00133 protected:
00134   vtkTensorGlyph();
00135   ~vtkTensorGlyph();
00136
00137   void Execute();
00138
00139   int Scaling; // Determine whether scaling of geometry is performed
00140   float ScaleFactor; // Scale factor to use to scale geometry
00141   int ExtractEigenvalues; // Boolean controls eigenfunction extraction
00142   int ColorGlyphs; // Boolean controls coloring with input scalar data
00143   int ClampScaling; // Boolean controls whether scaling is clamped.
00144   float MaxScaleFactor; // Maximum scale factor (ScaleFactor*eigenvalue)
00145 private:
00146   vtkTensorGlyph(const vtkTensorGlyph&);  // Not implemented.
00147   void operator=(const vtkTensorGlyph&);  // Not implemented.
00148 };
00149
00150 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTetra.h Source File

Common/vtkTetra.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTetra.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkTetra_h
00040 #define __vtkTetra_h
00041
00042 #include "vtkCell3D.h"
00043 #include "vtkLine.h"
00044 #include "vtkTriangle.h"
00045
00046 class vtkUnstructuredGrid;
00047
00048 class VTK_COMMON_EXPORT vtkTetra : public vtkCell3D
00049 {
00050 public:
00051   static vtkTetra *New();
00052   vtkTypeRevisionMacro(vtkTetra,vtkCell);
00053
00055
00056   virtual void GetEdgePoints(int edgeId, int* &pts);
00057   virtual void GetFacePoints(int faceId, int* &pts);
00059
00061
00062   vtkCell *MakeObject();
00063   int GetCellType() {return VTK_TETRA;}
00064   int GetNumberOfEdges() {return 6;}
00065   int GetNumberOfFaces() {return 4;}
00066   vtkCell *GetEdge(int edgeId);
00067   vtkCell *GetFace(int faceId);
00068   void Contour(float value, vtkDataArray *cellScalars,
00069                vtkPointLocator *locator, vtkCellArray *verts,
00070                vtkCellArray *lines, vtkCellArray *polys,
00071                vtkPointData *inPd, vtkPointData *outPd,
00072                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00073   void Clip(float value, vtkDataArray *cellScalars,
00074             vtkPointLocator *locator, vtkCellArray *connectivity,
00075             vtkPointData *inPd, vtkPointData *outPd,
00076             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00077             int insideOut);
00078   int EvaluatePosition(float x[3], float* closestPoint,
00079                        int& subId, float pcoords[3],
00080                        float& dist2, float *weights);
00081   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00082                         float *weights);
00083   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00084                         float x[3], float pcoords[3], int& subId);
00085   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00086   void Derivatives(int subId, float pcoords[3], float *values,
00087                    int dim, float *derivs);
00089
00093   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00094
00096   int GetParametricCenter(float pcoords[3]);
00097
00099
00100   static void TetraCenter(float p1[3], float p2[3], float p3[3], float p4[3],
00101                           float center[3]);
00103
00105
00107   static double Circumsphere(double  p1[3], double p2[3], double p3[3],
00108                              double p4[3], double center[3]);
00110
00112
00123   static int BarycentricCoords(double x[3], double  x1[3], double x2[3],
00124                                double x3[3], double x4[3], double bcoords[4]);
00126
00128
00130   static double ComputeVolume(double  p1[3], double p2[3], double p3[3],
00131                               double p4[3]);
00133
00137   int JacobianInverse(double **inverse, float derivs[12]);
00138
00140
00141   static void InterpolationFunctions(float pcoords[3], float weights[4]);
00142   static void InterpolationDerivs(float derivs[12]);
00143   static int *GetEdgeArray(int edgeId);
00144   static int *GetFaceArray(int faceId);
00146
00147 protected:
00148   vtkTetra();
00149   ~vtkTetra();
00150
00151   vtkLine *Line;
00152   vtkTriangle *Triangle;
00153
00154 private:
00155   vtkTetra(const vtkTetra&);  // Not implemented.
00156   void operator=(const vtkTetra&);  // Not implemented.
00157 };
00158
00159 inline int vtkTetra::GetParametricCenter(float pcoords[3])
00160 {
00161   pcoords[0] = pcoords[1] = pcoords[2] = 0.25;
00162   return 0;
00163 }
00164
00165 #endif
00166
00167
00168
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkTextMapper.h Source File

Rendering/vtkTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkTextMapper_h
00055 #define __vtkTextMapper_h
00056
00057 #include "vtkMapper2D.h"
00058 #include "vtkWindow.h"
00059 #include "vtkViewport.h"
00060 #include "vtkActor2D.h"
00061 #include "vtkProperty2D.h"
00062
00063 #define VTK_ARIAL     0
00064 #define VTK_COURIER   1
00065 #define VTK_TIMES     2
00066
00067 #define VTK_TEXT_LEFT     0
00068 #define VTK_TEXT_CENTERED 1
00069 #define VTK_TEXT_RIGHT    2
00070
00071 #define VTK_TEXT_BOTTOM 0
00072 #define VTK_TEXT_TOP    2
00073
00074 class VTK_RENDERING_EXPORT vtkTextMapper : public vtkMapper2D
00075 {
00076 public:
00077   vtkTypeRevisionMacro(vtkTextMapper,vtkMapper2D);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00082   static vtkTextMapper *New();
00083
00085
00087   virtual void GetSize(vtkViewport*, int size[2]) {size[0]=size[0];};
00088   int GetWidth(vtkViewport*);
00089   int GetHeight(vtkViewport*);
00091
00093
00095   void SetInput(const char *inputString);
00096   vtkGetStringMacro(Input);
00098
00102   virtual void SetFontSize(int size);
00103
00105
00108   vtkGetMacro(FontSize, int);
00110
00112
00113   void SetBold(int val);
00114   vtkGetMacro(Bold, int);
00115   vtkBooleanMacro(Bold, int);
00117
00119
00120   void SetItalic(int val);
00121   vtkGetMacro(Italic, int);
00122   vtkBooleanMacro(Italic, int);
00124
00126
00127   void SetShadow(int val);
00128   vtkGetMacro(Shadow, int);
00129   vtkBooleanMacro(Shadow, int);
00131
00133
00135   void SetFontFamily(int val);
00136   vtkGetMacro(FontFamily, int);
00137   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00138   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00139   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00141
00143
00145   vtkSetClampMacro(Justification,int,VTK_TEXT_LEFT,VTK_TEXT_RIGHT);
00146   vtkGetMacro(Justification,int);
00147   void SetJustificationToLeft() {this->SetJustification(VTK_TEXT_LEFT);};
00148   void SetJustificationToCentered() {this->SetJustification(VTK_TEXT_CENTERED);};
00149   void SetJustificationToRight() {this->SetJustification(VTK_TEXT_RIGHT);};
00151
00153
00155   vtkSetClampMacro(VerticalJustification,int,VTK_TEXT_BOTTOM,VTK_TEXT_TOP);
00156   vtkGetMacro(VerticalJustification,int);
00157   void SetVerticalJustificationToBottom()
00158     {this->SetVerticalJustification(VTK_TEXT_BOTTOM);};
00159   void SetVerticalJustificationToCentered()
00160     {this->SetVerticalJustification(VTK_TEXT_CENTERED);};
00161   void SetVerticalJustificationToTop()
00162     {this->SetVerticalJustification(VTK_TEXT_TOP);};
00164
00166
00169   vtkSetMacro(LineOffset, float);
00170   vtkGetMacro(LineOffset, float);
00171   vtkSetMacro(LineSpacing, float);
00172   vtkGetMacro(LineSpacing, float);
00173   vtkGetMacro(NumberOfLines,int);
00175
00177   void ShallowCopy(vtkTextMapper *tm);
00178
00181   int  GetNumberOfLines(const char *input);
00182
00183 protected:
00184   vtkTextMapper();
00185   ~vtkTextMapper();
00186
00187   int   Italic;
00188   int   Bold;
00189   int   Shadow;
00190   int   FontSize;
00191   int   FontFamily;
00192   char* Input;
00193   int   Justification;
00194   int   VerticalJustification;
00195   vtkTimeStamp FontMTime;
00196   // these functions are used to parse, process, and render multiple lines
00197   int LineSize;
00198   float LineOffset;
00199   float LineSpacing;
00200   int  NumberOfLines;
00201   int  NumberOfLinesAllocated;
00202   vtkTextMapper **TextLines;
00203   char *NextLine(const char *input, int lineNum);
00204   void GetMultiLineSize(vtkViewport* viewport, int size[2]);
00205   void RenderOverlayMultipleLines(vtkViewport *viewport, vtkActor2D *actor);
00206   void RenderOpaqueGeometryMultipleLines(vtkViewport *viewport, vtkActor2D *actor);
00207
00208 private:
00209   vtkTextMapper(const vtkTextMapper&);  // Not implemented.
00210   void operator=(const vtkTextMapper&);  // Not implemented.
00211 };
00212
00213 #endif
00214
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTextSource.h Source File

Graphics/vtkTextSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTextSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkTextSource_h
00051 #define __vtkTextSource_h
00052
00053 #include "vtkPolyDataSource.h"
00054
00055 class VTK_GRAPHICS_EXPORT vtkTextSource : public vtkPolyDataSource
00056 {
00057 public:
00058   vtkTypeRevisionMacro(vtkTextSource,vtkPolyDataSource);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062   static vtkTextSource *New();
00063
00065
00066   vtkSetStringMacro(Text);
00067   vtkGetStringMacro(Text);
00069
00071
00072   vtkSetMacro(Backing,int);
00073   vtkGetMacro(Backing,int);
00074   vtkBooleanMacro(Backing,int);
00076
00078
00080   vtkSetVector3Macro(ForegroundColor,float);
00081   vtkGetVectorMacro(ForegroundColor,float,3);
00083
00085
00087   vtkSetVector3Macro(BackgroundColor,float);
00088   vtkGetVectorMacro(BackgroundColor,float,3);
00090
00091 protected:
00092   vtkTextSource();
00093   ~vtkTextSource();
00094
00095   void Execute();
00096   char *Text;
00097   int  Backing;
00098   float ForegroundColor[4];
00099   float BackgroundColor[4];
00100 private:
00101   vtkTextSource(const vtkTextSource&);  // Not implemented.
00102   void operator=(const vtkTextSource&);  // Not implemented.
00103 };
00104
00105 #endif
00106
00107
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkTexture.h Source File

Rendering/vtkTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00064 #ifndef __vtkTexture_h
00065 #define __vtkTexture_h
00066
00067 #include "vtkProcessObject.h"
00068 #include "vtkImageData.h"
00069 #include "vtkLookupTable.h"
00070
00071 class vtkRenderer;
00072 class vtkWindow;
00073 class vtkUnsignedCharArray;
00074
00075 #define VTK_TEXTURE_QUALITY_DEFAULT 0
00076 #define VTK_TEXTURE_QUALITY_16BIT   16
00077 #define VTK_TEXTURE_QUALITY_32BIT   32
00078
00079 class VTK_RENDERING_EXPORT vtkTexture : public vtkProcessObject
00080 {
00081 public:
00082   static vtkTexture *New();
00083   vtkTypeRevisionMacro(vtkTexture,vtkObject);
00084   void PrintSelf(ostream& os, vtkIndent indent);
00085
00089   virtual void Render(vtkRenderer *ren);
00090
00094   virtual void ReleaseGraphicsResources(vtkWindow *) {};
00095
00099   virtual void Load(vtkRenderer *) {};
00100
00102
00104   vtkGetMacro(Repeat,int);
00105   vtkSetMacro(Repeat,int);
00106   vtkBooleanMacro(Repeat,int);
00108
00110
00111   vtkGetMacro(Interpolate,int);
00112   vtkSetMacro(Interpolate,int);
00113   vtkBooleanMacro(Interpolate,int);
00115
00117
00119   vtkSetMacro(Quality,int);
00120   vtkGetMacro(Quality,int);
00121   void SetQualityToDefault() {this->SetQuality(VTK_TEXTURE_QUALITY_DEFAULT);};
00122   void SetQualityTo16Bit() {this->SetQuality(VTK_TEXTURE_QUALITY_16BIT);};
00123   void SetQualityTo32Bit() {this->SetQuality(VTK_TEXTURE_QUALITY_32BIT);};
00125
00127
00133   vtkGetMacro(MapColorScalarsThroughLookupTable,int);
00134   vtkSetMacro(MapColorScalarsThroughLookupTable,int);
00135   vtkBooleanMacro(MapColorScalarsThroughLookupTable,int);
00137
00139
00140   void SetInput( vtkImageData *input );
00141   vtkImageData *GetInput();
00143
00145
00146   void SetLookupTable(vtkLookupTable *);
00147   vtkGetObjectMacro(LookupTable,vtkLookupTable);
00149
00151
00152   vtkGetObjectMacro(MappedScalars,vtkUnsignedCharArray);
00154
00156   unsigned char *MapScalarsToColors (vtkDataArray *scalars);
00157
00158 protected:
00159   vtkTexture();
00160   ~vtkTexture();
00161
00162   int   Repeat;
00163   int   Interpolate;
00164   int   Quality;
00165   int   MapColorScalarsThroughLookupTable;
00166   vtkLookupTable *LookupTable;
00167   vtkUnsignedCharArray *MappedScalars;
00168
00169   // this is to duplicated the previous behavior of SelfCreatedLookUpTable
00170   int SelfAdjustingTableRange;
00171 private:
00172   vtkTexture(const vtkTexture&);  // Not implemented.
00173   void operator=(const vtkTexture&);  // Not implemented.
00174 };
00175
00176 #endif
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTexturedSphereSource.h Source File

Graphics/vtkTexturedSphereSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTexturedSphereSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkTexturedSphereSource_h
00040 #define __vtkTexturedSphereSource_h
00041
00042 #include "vtkPolyDataSource.h"
00043
00044 #define VTK_MAX_SPHERE_RESOLUTION 1024
00045
00046 class VTK_GRAPHICS_EXPORT vtkTexturedSphereSource : public vtkPolyDataSource
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkTexturedSphereSource,vtkPolyDataSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00054   static vtkTexturedSphereSource *New();
00055
00057
00058   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00059   vtkGetMacro(Radius,float);
00061
00063
00064   vtkSetClampMacro(ThetaResolution,int,4,VTK_MAX_SPHERE_RESOLUTION);
00065   vtkGetMacro(ThetaResolution,int);
00067
00069
00070   vtkSetClampMacro(PhiResolution,int,4,VTK_MAX_SPHERE_RESOLUTION);
00071   vtkGetMacro(PhiResolution,int);
00073
00075
00076   vtkSetClampMacro(Theta,float,0.0,360.0);
00077   vtkGetMacro(Theta,float);
00079
00081
00082   vtkSetClampMacro(Phi,float,0.0,180.0);
00083   vtkGetMacro(Phi,float);
00085
00086 protected:
00087   vtkTexturedSphereSource(int res=8);
00088   ~vtkTexturedSphereSource() {};
00089
00090   void Execute();
00091   float Radius;
00092   float Theta;
00093   float Phi;
00094   int ThetaResolution;
00095   int PhiResolution;
00096
00097 private:
00098   vtkTexturedSphereSource(const vtkTexturedSphereSource&);  // Not implemented.
00099   void operator=(const vtkTexturedSphereSource&);  // Not implemented.
00100 };
00101
00102 #endif
00103
00104
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTextureMapToCylinder.h Source File

Graphics/vtkTextureMapToCylinder.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTextureMapToCylinder.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkTextureMapToCylinder_h
00063 #define __vtkTextureMapToCylinder_h
00064
00065 #include "vtkDataSetToDataSetFilter.h"
00066
00067 class VTK_GRAPHICS_EXPORT vtkTextureMapToCylinder : public vtkDataSetToDataSetFilter
00068 {
00069 public:
00070   vtkTypeRevisionMacro(vtkTextureMapToCylinder,vtkDataSetToDataSetFilter);
00071   void PrintSelf(ostream& os, vtkIndent indent);
00072
00076   static vtkTextureMapToCylinder *New();
00077
00079
00080   vtkSetVector3Macro(Point1,float);
00081   vtkGetVectorMacro(Point1,float,3);
00083
00085
00086   vtkSetVector3Macro(Point2,float);
00087   vtkGetVectorMacro(Point2,float,3);
00089
00091
00093   vtkSetMacro(AutomaticCylinderGeneration,int);
00094   vtkGetMacro(AutomaticCylinderGeneration,int);
00095   vtkBooleanMacro(AutomaticCylinderGeneration,int);
00097
00099
00103   vtkSetMacro(PreventSeam,int);
00104   vtkGetMacro(PreventSeam,int);
00105   vtkBooleanMacro(PreventSeam,int);
00107
00108 protected:
00109   vtkTextureMapToCylinder();
00110   ~vtkTextureMapToCylinder() {};
00111
00112   void Execute();
00113
00114   float Point1[3];
00115   float Point2[3];
00116   int AutomaticCylinderGeneration;
00117   int PreventSeam;
00118
00119 private:
00120   vtkTextureMapToCylinder(const vtkTextureMapToCylinder&);  // Not implemented.
00121   void operator=(const vtkTextureMapToCylinder&);  // Not implemented.
00122 };
00123
00124 #endif
00125
00126
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTextureMapToPlane.h Source File

Graphics/vtkTextureMapToPlane.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTextureMapToPlane.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkTextureMapToPlane_h
00057 #define __vtkTextureMapToPlane_h
00058
00059 #include "vtkDataSetToDataSetFilter.h"
00060
00061 class VTK_GRAPHICS_EXPORT vtkTextureMapToPlane : public vtkDataSetToDataSetFilter
00062 {
00063 public:
00064   vtkTypeRevisionMacro(vtkTextureMapToPlane,vtkDataSetToDataSetFilter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00069   static vtkTextureMapToPlane *New();
00070
00072
00074   vtkSetVector3Macro(Origin,float);
00075   vtkGetVectorMacro(Origin,float,3);
00077
00079
00080   vtkSetVector3Macro(Point1,float);
00081   vtkGetVectorMacro(Point1,float,3);
00083
00085
00086   vtkSetVector3Macro(Point2,float);
00087   vtkGetVectorMacro(Point2,float,3);
00089
00091
00094   vtkSetVector3Macro(Normal,float);
00095   vtkGetVectorMacro(Normal,float,3);
00097
00099
00100   vtkSetVector2Macro(SRange,float);
00101   vtkGetVectorMacro(SRange,float,2);
00103
00105
00106   vtkSetVector2Macro(TRange,float);
00107   vtkGetVectorMacro(TRange,float,2);
00109
00111
00112   vtkSetMacro(AutomaticPlaneGeneration,int);
00113   vtkGetMacro(AutomaticPlaneGeneration,int);
00114   vtkBooleanMacro(AutomaticPlaneGeneration,int);
00116
00117 protected:
00118   vtkTextureMapToPlane();
00119   ~vtkTextureMapToPlane() {};
00120
00121   void Execute();
00122   void ComputeNormal();
00123
00124   float Origin[3];
00125   float Point1[3];
00126   float Point2[3];
00127   float Normal[3];
00128   float SRange[2];
00129   float TRange[2];
00130   int AutomaticPlaneGeneration;
00131
00132 private:
00133   vtkTextureMapToPlane(const vtkTextureMapToPlane&);  // Not implemented.
00134   void operator=(const vtkTextureMapToPlane&);  // Not implemented.
00135 };
00136
00137 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTextureMapToSphere.h Source File

Graphics/vtkTextureMapToSphere.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTextureMapToSphere.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00061 #ifndef __vtkTextureMapToSphere_h
00062 #define __vtkTextureMapToSphere_h
00063
00064 #include "vtkDataSetToDataSetFilter.h"
00065
00066 class VTK_GRAPHICS_EXPORT vtkTextureMapToSphere : public vtkDataSetToDataSetFilter
00067 {
00068 public:
00069   vtkTypeRevisionMacro(vtkTextureMapToSphere,vtkDataSetToDataSetFilter);
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00074   static vtkTextureMapToSphere *New();
00075
00077
00078   vtkSetVector3Macro(Center,float);
00079   vtkGetVectorMacro(Center,float,3);
00081
00083
00085   vtkSetMacro(AutomaticSphereGeneration,int);
00086   vtkGetMacro(AutomaticSphereGeneration,int);
00087   vtkBooleanMacro(AutomaticSphereGeneration,int);
00089
00091
00095   vtkSetMacro(PreventSeam,int);
00096   vtkGetMacro(PreventSeam,int);
00097   vtkBooleanMacro(PreventSeam,int);
00099
00100 protected:
00101   vtkTextureMapToSphere();
00102   ~vtkTextureMapToSphere() {};
00103
00104   void Execute();
00105
00106   float Center[3];
00107   int AutomaticSphereGeneration;
00108   int PreventSeam;
00109
00110 private:
00111   vtkTextureMapToSphere(const vtkTextureMapToSphere&);  // Not implemented.
00112   void operator=(const vtkTextureMapToSphere&);  // Not implemented.
00113 };
00114
00115 #endif
00116
00117
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkThinPlateSplineTransform.h Source File

Hybrid/vtkThinPlateSplineTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThinPlateSplineTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkThinPlateSplineTransform_h
00048 #define __vtkThinPlateSplineTransform_h
00049
00050 #include "vtkWarpTransform.h"
00051
00052 #define VTK_RBF_CUSTOM 0
00053 #define VTK_RBF_R      1
00054 #define VTK_RBF_R2LOGR 2
00055
00056 class VTK_HYBRID_EXPORT vtkThinPlateSplineTransform : public vtkWarpTransform
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkThinPlateSplineTransform,vtkWarpTransform);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061   static vtkThinPlateSplineTransform *New();
00062
00064
00065   vtkGetMacro(Sigma,double);
00066   vtkSetMacro(Sigma,double);
00068
00070
00072   void SetBasis(int basis);
00073   vtkGetMacro(Basis,int);
00074   void SetBasisToR() { this->SetBasis(VTK_RBF_R); };
00075   void SetBasisToR2LogR() { this->SetBasis(VTK_RBF_R2LOGR); };
00076   const char *GetBasisAsString();
00078
00079 //BTX
00081   /*! Set the radial basis function to a custom function.  You must supply
00082       both the function and its derivative with respect to r. */
00083   void SetBasisFunction(double (*U)(double r)) {
00084     if (this->BasisFunction == U) { return; }
00085     this->SetBasis(VTK_RBF_CUSTOM);
00086     this->BasisFunction = U;
00087     this->Modified(); };
00088   void SetBasisDerivative(double (*dUdr)(double r, double &dU)) {
00089     this->BasisDerivative = dUdr;
00090     this->Modified(); };
00092 //ETX
00093
00095
00098   void SetSourceLandmarks(vtkPoints *source);
00099   vtkGetObjectMacro(SourceLandmarks,vtkPoints);
00101
00103
00106   void SetTargetLandmarks(vtkPoints *target);
00107   vtkGetObjectMacro(TargetLandmarks,vtkPoints);
00109
00111   unsigned long GetMTime();
00112
00114   vtkAbstractTransform *MakeTransform();
00115
00116 protected:
00117   vtkThinPlateSplineTransform();
00118   ~vtkThinPlateSplineTransform();
00119
00121   void InternalUpdate();
00122
00124   void InternalDeepCopy(vtkAbstractTransform *transform);
00125
00126   void ForwardTransformPoint(const float in[3], float out[3]);
00127   void ForwardTransformPoint(const double in[3], double out[3]);
00128
00129   void ForwardTransformDerivative(const float in[3], float out[3],
00130                                   float derivative[3][3]);
00131   void ForwardTransformDerivative(const double in[3], double out[3],
00132                                   double derivative[3][3]);
00133
00134   double Sigma;
00135   vtkPoints *SourceLandmarks;
00136   vtkPoints *TargetLandmarks;
00137
00138 //BTX
00139   // the radial basis function to use
00140   double (*BasisFunction)(double r);
00141   double (*BasisDerivative)(double r, double& dUdr);
00142 //ETX
00143   int Basis;
00144
00145   int NumberOfPoints;
00146   double **MatrixW;
00147 private:
00148   vtkThinPlateSplineTransform(const vtkThinPlateSplineTransform&);  // Not implemented.
00149   void operator=(const vtkThinPlateSplineTransform&);  // Not implemented.
00150 };
00151
00152 #endif
00153
00154
00155
00156
00157
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkThreadedController.h Source File

Parallel/vtkThreadedController.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThreadedController.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkThreadedController_h
00044 #define __vtkThreadedController_h
00045
00046 #include "vtkObject.h"
00047 #include "vtkMultiProcessController.h"
00048 #include "vtkMultiThreader.h"
00049 #include "vtkSharedMemoryCommunicator.h"
00050 #include "vtkCriticalSection.h"
00051
00052 class VTK_PARALLEL_EXPORT vtkThreadedController : public vtkMultiProcessController
00053 {
00054 public:
00055   static vtkThreadedController *New();
00056   vtkTypeRevisionMacro(vtkThreadedController,vtkMultiProcessController);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060
00061   virtual void Initialize(int* argc, char*** arcv);
00062   virtual void Finalize() {}
00064
00066
00071   vtkGetMacro(LocalProcessId, int);
00073
00077   virtual void SingleMethodExecute();
00078
00082   virtual void MultipleMethodExecute();
00083
00085   virtual void Barrier();
00086
00089   virtual void CreateOutputWindow();
00090
00091
00092 protected:
00093
00094   vtkThreadedController();
00095   ~vtkThreadedController();
00096
00097   void CreateProcessControllers();
00098
00100   void Start(int threadIdx);
00101
00102   void ResetControllers();
00103
00104   static VTK_THREAD_RETURN_TYPE vtkThreadedControllerStart( void *arg );
00105
00106   // Each Process/Thread has its own controller.
00107   vtkThreadedController** Controllers;
00108
00109 //BTX
00110
00111 // Required only for static access to threadId (GetLocalController).
00112 #ifdef VTK_USE_PTHREADS
00113   typedef pthread_t ThreadIdType;
00114 #elif defined VTK_USE_SPROC
00115   typedef pid_t ThreadIdType;
00116 #elif defined VTK_USE_WIN32_THREADS
00117   typedef DWORD ThreadIdType;
00118 #else
00119   typedef int ThreadIdType;
00120 #endif
00121
00122 //ETX
00123
00124   // Used in barrier
00125   static vtkSimpleCriticalSection CounterLock;
00126   static int Counter;
00127   static int IsBarrierInProgress;
00128   static void WaitForPreviousBarrierToEnd();
00129   static void BarrierStarted();
00130   static void BarrierEnded();
00131   static void SignalNextThread();
00132   static void InitializeBarrier();
00133   static void WaitForNextThread();
00134 #ifdef VTK_USE_WIN32_THREADS
00135   static HANDLE BarrierEndedEvent;
00136   static HANDLE NextThread;
00137 #else
00138   static vtkSimpleCriticalSection BarrierLock;
00139   static vtkSimpleCriticalSection BarrierInProgress;
00140 #endif
00141
00142   ThreadIdType ThreadId;
00143
00144   int LastNumberOfProcesses;
00145
00146   vtkMultiThreader *MultiThreader;
00147   // Used internally to switch between multiple and single method execution.
00148   int MultipleMethodFlag;
00149
00150   // For static GetGlobalController.  Translates controller for thread0
00151   // to controller for local thread.
00152   vtkMultiProcessController *GetLocalController();
00153
00154 private:
00155   vtkThreadedController(const vtkThreadedController&);  // Not implemented.
00156   void operator=(const vtkThreadedController&);  // Not implemented.
00157 };
00158
00159 #endif
00160
00161
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkThreadSafeLog.h Source File

Parallel/vtkThreadSafeLog.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThreadSafeLog.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00031 #ifndef __vtkThreadSafeLog_h
00032 #define __vtkThreadSafeLog_h
00033
00034
00035 #include "vtkObject.h"
00036 #include "vtkTimerLog.h"
00037
00038
00039 #define VTK_THREAD_SAFE_LOG_MAX 1000
00040
00041 class VTK_PARALLEL_EXPORT vtkThreadSafeLog : public vtkObject
00042 {
00043 public:
00044   static vtkThreadSafeLog *New();
00045   const char *GetClassName() {return "vtkThreadSafeLog";};
00046
00048
00049   void StartTimer() { this->Timer->StartTimer();}
00050   void StopTimer() { this->Timer->StopTimer();}
00051   double GetElapsedTime() { return this->Timer->GetElapsedTime();}
00053
00055   void AddEntry(char *tag, float value);
00056
00060   void DumpLog(char *filename, int mode = ios::out);
00061
00062 protected:
00063
00064   vtkThreadSafeLog(); //insure constructur/destructor protected
00065   ~vtkThreadSafeLog();
00066
00067
00068   char *Tags[VTK_THREAD_SAFE_LOG_MAX];
00069   float Values[VTK_THREAD_SAFE_LOG_MAX];
00070   int NumberOfEntries;
00071
00072   vtkTimerLog *Timer;
00073 private:
00074   vtkThreadSafeLog(const vtkThreadSafeLog&);  // Not implemented.
00075   void operator=(const vtkThreadSafeLog&);  // Not implemented.
00076 };
00077
00078
00079
00080 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkThreshold.h Source File

Graphics/vtkThreshold.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThreshold.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkThreshold_h
00052 #define __vtkThreshold_h
00053
00054 #include "vtkDataSetToUnstructuredGridFilter.h"
00055
00056 #define VTK_ATTRIBUTE_MODE_DEFAULT 0
00057 #define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
00058 #define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2
00059
00060 class VTK_GRAPHICS_EXPORT vtkThreshold : public vtkDataSetToUnstructuredGridFilter
00061 {
00062 public:
00063   static vtkThreshold *New();
00064   vtkTypeRevisionMacro(vtkThreshold,vtkDataSetToUnstructuredGridFilter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00069   void ThresholdByLower(float lower);
00070
00073   void ThresholdByUpper(float upper);
00074
00077   void ThresholdBetween(float lower, float upper);
00078
00080
00081   vtkGetMacro(UpperThreshold,float);
00082   vtkGetMacro(LowerThreshold,float);
00084
00086
00092   vtkSetMacro(AttributeMode,int);
00093   vtkGetMacro(AttributeMode,int);
00094   void SetAttributeModeToDefault()
00095     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_DEFAULT);};
00096   void SetAttributeModeToUsePointData()
00097     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_POINT_DATA);};
00098   void SetAttributeModeToUseCellData()
00099     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_CELL_DATA);};
00100   const char *GetAttributeModeAsString();
00102
00104
00108   vtkSetMacro(AllScalars,int);
00109   vtkGetMacro(AllScalars,int);
00110   vtkBooleanMacro(AllScalars,int);
00112
00114
00117   vtkGetStringMacro(InputScalarsSelection);
00118   void SelectInputScalars(const char *fieldName)
00119     {this->SetInputScalarsSelection(fieldName);}
00121
00122 protected:
00123   vtkThreshold();
00124   ~vtkThreshold();
00125
00126   // Usual data generation method
00127   void Execute();
00128
00129   int   AllScalars;
00130   float LowerThreshold;
00131   float UpperThreshold;
00132   int   AttributeMode;
00133
00134   //BTX
00135   int (vtkThreshold::*ThresholdFunction)(float s);
00136   //ETX
00137
00138   int Lower(float s) {return ( s <= this->LowerThreshold ? 1 : 0 );};
00139   int Upper(float s) {return ( s >= this->UpperThreshold ? 1 : 0 );};
00140   int Between(float s) {return ( s >= this->LowerThreshold ?
00141                                ( s <= this->UpperThreshold ? 1 : 0 ) : 0 );};
00142
00143   char *InputScalarsSelection;
00144   vtkSetStringMacro(InputScalarsSelection);
00145
00146 private:
00147   vtkThreshold(const vtkThreshold&);  // Not implemented.
00148   void operator=(const vtkThreshold&);  // Not implemented.
00149 };
00150
00151 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkThresholdPoints.h Source File

Graphics/vtkThresholdPoints.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThresholdPoints.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkThresholdPoints_h
00045 #define __vtkThresholdPoints_h
00046
00047 #include "vtkDataSetToPolyDataFilter.h"
00048
00049 class VTK_GRAPHICS_EXPORT vtkThresholdPoints : public vtkDataSetToPolyDataFilter
00050 {
00051 public:
00052   static vtkThresholdPoints *New();
00053   vtkTypeRevisionMacro(vtkThresholdPoints,vtkDataSetToPolyDataFilter);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   void ThresholdByLower(float lower);
00058
00060   void ThresholdByUpper(float upper);
00061
00064   void ThresholdBetween(float lower, float upper);
00065
00067
00068   vtkGetMacro(UpperThreshold,float);
00069   vtkGetMacro(LowerThreshold,float);
00071
00072 protected:
00073   vtkThresholdPoints();
00074   ~vtkThresholdPoints() {};
00075
00076   // Usual data generation method
00077   void Execute();
00078
00079   float LowerThreshold;
00080   float UpperThreshold;
00081
00082   //BTX
00083   int (vtkThresholdPoints::*ThresholdFunction)(float s);
00084   //ETX
00085
00086   int Lower(float s) {return ( s <= this->LowerThreshold ? 1 : 0 );};
00087   int Upper(float s) {return ( s >= this->UpperThreshold ? 1 : 0 );};
00088   int Between(float s) {return ( s >= this->LowerThreshold ?
00089                                ( s <= this->UpperThreshold ? 1 : 0 ) : 0 );};
00090 private:
00091   vtkThresholdPoints(const vtkThresholdPoints&);  // Not implemented.
00092   void operator=(const vtkThresholdPoints&);  // Not implemented.
00093 };
00094
00095 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkThresholdTextureCoords.h Source File

Graphics/vtkThresholdTextureCoords.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkThresholdTextureCoords.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkThresholdTextureCoords_h
00050 #define __vtkThresholdTextureCoords_h
00051
00052 #include "vtkDataSetToDataSetFilter.h"
00053
00054 class VTK_GRAPHICS_EXPORT vtkThresholdTextureCoords : public vtkDataSetToDataSetFilter
00055 {
00056 public:
00057   static vtkThresholdTextureCoords *New();
00058   vtkTypeRevisionMacro(vtkThresholdTextureCoords,vtkDataSetToDataSetFilter);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062   void ThresholdByLower(float lower);
00063
00065   void ThresholdByUpper(float upper);
00066
00069   void ThresholdBetween(float lower, float upper);
00070
00072
00073   vtkGetMacro(UpperThreshold,float);
00074   vtkGetMacro(LowerThreshold,float);
00076
00078
00079   vtkSetClampMacro(TextureDimension,int,1,3);
00080   vtkGetMacro(TextureDimension,int);
00082
00084
00086   vtkSetVector3Macro(InTextureCoord,float);
00087   vtkGetVectorMacro(InTextureCoord,float,3);
00089
00091
00093   vtkSetVector3Macro(OutTextureCoord,float);
00094   vtkGetVectorMacro(OutTextureCoord,float,3);
00096
00097 protected:
00098   vtkThresholdTextureCoords();
00099   ~vtkThresholdTextureCoords() {};
00100
00101   // Usual data generation method
00102   void Execute();
00103
00104   float LowerThreshold;
00105   float UpperThreshold;
00106
00107   int TextureDimension;
00108
00109   float InTextureCoord[3];
00110   float OutTextureCoord[3];
00111
00112   //BTX
00113   int (vtkThresholdTextureCoords::*ThresholdFunction)(float s);
00114   //ETX
00115
00116   int Lower(float s) {return ( s <= this->LowerThreshold ? 1 : 0 );};
00117   int Upper(float s) {return ( s >= this->UpperThreshold ? 1 : 0 );};
00118   int Between(float s) {return ( s >= this->LowerThreshold ?
00119                                ( s <= this->UpperThreshold ? 1 : 0 ) : 0 );};
00120 private:
00121   vtkThresholdTextureCoords(const vtkThresholdTextureCoords&);  // Not implemented.
00122   void operator=(const vtkThresholdTextureCoords&);  // Not implemented.
00123 };
00124
00125 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkTIFFReader.h Source File

IO/vtkTIFFReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTIFFReader.h,v $
00005   Language:  C++
00006
00007
00008 Copyright (c) 1993-2001 Ken Martin, Will Schroeder, Bill Lorensen
00009 All rights reserved.
00010
00011 Redistribution and use in source and binary forms, with or without
00012 modification, are permitted provided that the following conditions are met:
00013
00014  * Redistributions of source code must retain the above copyright notice,
00015    this list of conditions and the following disclaimer.
00016
00017  * Redistributions in binary form must reproduce the above copyright notice,
00018    this list of conditions and the following disclaimer in the documentation
00019    and/or other materials provided with the distribution.
00020
00021  * Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names
00022    of any contributors may be used to endorse or promote products derived
00023    from this software without specific prior written permission.
00024
00025  * Modified source versions must be plainly marked as such, and must not be
00026    misrepresented as being the original software.
00027
00028 THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS''
00029 AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
00030 IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
00031 ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR
00032 ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
00033 DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
00034 SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
00035 CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
00036 OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
00037 OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
00038
00039 =========================================================================*/
00064 #ifndef __vtkTIFFReader_h
00065 #define __vtkTIFFReader_h
00066
00067 #include <stdio.h>
00068 #include "vtkImageReader2.h"
00069
00070 //BTX
00071 class TIFFInternal;
00072 //ETX
00073
00074 class VTK_IO_EXPORT vtkTIFFReader : public vtkImageReader2
00075 {
00076 public:
00077   static vtkTIFFReader *New();
00078   vtkTypeMacro(vtkTIFFReader,vtkImageReader2);
00079
00080 //BTX
00081   enum { NOFORMAT, RGB, GRAYSCALE, PALETTE_RGB, PALETTE_GRAYSCALE, OTHER };
00082
00083   void GetColor( int index,
00084                  unsigned short *r, unsigned short *g, unsigned short *b );
00085   unsigned int  GetFormat();
00086   void InitializeColors();
00087
00088   void ReadImageInternal( void *, void *outPtr,
00089                           int *outExt, unsigned int size );
00090
00091   virtual vtkImageReader2* MakeObject() { return vtkTIFFReader::New(); }
00092
00093   virtual int CanReadFile(const char* fname);
00094
00096
00098   virtual const char* GetFileExensions()
00099     {
00100     return ".tif .tiff";
00101     }
00103
00105
00107   virtual const char* GetDescriptiveName()
00108     {
00109     return "TIFF";
00110     }
00112
00113   TIFFInternal *GetInternalImage()
00114     { return this->InternalImage; }
00115
00116 //ETX
00117
00118 protected:
00119   vtkTIFFReader();
00120   ~vtkTIFFReader();
00121
00122   virtual void ExecuteInformation();
00123   virtual void ExecuteData(vtkDataObject *out);
00124
00125   void ReadGenericImage( void *out,
00126                          unsigned int width, unsigned int height,
00127                          unsigned int size );
00128
00129   int EvaluateImageAt( void*, void* );
00130 private:
00131   vtkTIFFReader(const vtkTIFFReader&);  // Not implemented.
00132   void operator=(const vtkTIFFReader&);  // Not implemented.
00133
00134   unsigned short *ColorRed;
00135   unsigned short *ColorGreen;
00136   unsigned short *ColorBlue;
00137   int TotalColors;
00138   unsigned int ImageFormat;
00139   TIFFInternal *InternalImage;
00140   int *InternalExtents;
00141 };
00142 #endif
00143
00144
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkTIFFWriter.h Source File

IO/vtkTIFFWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTIFFWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkTIFFWriter_h
00039 #define __vtkTIFFWriter_h
00040
00041 #include <stdio.h>
00042 #include "vtkImageWriter.h"
00043
00044 class VTK_IO_EXPORT vtkTIFFWriter : public vtkImageWriter
00045 {
00046 public:
00047   static vtkTIFFWriter *New();
00048   vtkTypeRevisionMacro(vtkTIFFWriter,vtkImageWriter);
00049
00050 protected:
00051   vtkTIFFWriter() {};
00052   ~vtkTIFFWriter() {};
00053
00054   virtual void WriteFile(ofstream *file, vtkImageData *data,
00055                          int ext[6]);
00056   virtual void WriteFileHeader(ofstream *, vtkImageData *);
00057 private:
00058   vtkTIFFWriter(const vtkTIFFWriter&);  // Not implemented.
00059   void operator=(const vtkTIFFWriter&);  // Not implemented.
00060 };
00061
00062 #endif
00063
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTimerLog.h Source File

Common/vtkTimerLog.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTimerLog.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkTimerLog_h
00045 #define __vtkTimerLog_h
00046
00047  #include "vtkSystemIncludes.h"
00048
00049 #ifdef _WIN32
00050 #ifndef _WIN32_WCE
00051 #include <sys/types.h>
00052 #include <sys/timeb.h>
00053 #endif
00054 #else
00055 #include <time.h>
00056 #include <sys/time.h>
00057 #include <sys/types.h>
00058 #include <sys/times.h>
00059 #endif
00060
00061 // var args
00062 #ifndef _WIN32
00063 #include <unistd.h>
00064 #endif
00065 #include <stdarg.h>
00066
00067 // select stuff here is for sleep method
00068 #ifndef NO_FD_SET
00069 #   define SELECT_MASK fd_set
00070 #else
00071 #   ifndef _AIX
00072         typedef long fd_mask;
00073 #   endif
00074 #   if defined(_IBMR2)
00075 #       define SELECT_MASK void
00076 #   else
00077 #       define SELECT_MASK int
00078 #   endif
00079 #endif
00080
00081
00082 #include "vtkObject.h"
00083 #define VTK_LOG_EVENT_LENGTH 40
00084
00085 //BTX
00086 typedef struct
00087 {
00088   float WallTime;
00089   int CpuTicks;
00090   char Event[VTK_LOG_EVENT_LENGTH];
00091 } vtkTimerLogEntry;
00092 //ETX
00093
00094 // The microsoft compiler defines this as a macro, so
00095 // undefine it here
00096 #undef GetCurrentTime
00097
00098 class VTK_COMMON_EXPORT vtkTimerLog : public vtkObject
00099 {
00100 public:
00101   static vtkTimerLog *New();
00102
00103   vtkTypeRevisionMacro(vtkTimerLog,vtkObject);
00104   void PrintSelf(ostream& os, vtkIndent indent);
00105
00107
00108   static void SetMaxEntries(int a);
00109   static int  GetMaxEntries();
00111
00112 //BTX
00115   static void FormatAndMarkEvent(char *EventString, ...);
00116 //ETX
00117
00120   static void DumpLog(char *filename);
00121
00123   static void MarkEvent(char *EventString);
00124
00127   static void ResetLog();
00128
00130   static void AllocateLog();
00131
00134   static double GetCurrentTime();
00135
00138   static double GetCPUTime();
00139
00141   void StartTimer();
00142
00144   void StopTimer();
00145
00148   double GetElapsedTime();
00149
00150 protected:
00151   vtkTimerLog() {this->StartTime=0; this->EndTime = 0;}; //insure constructor/destructor protected
00152   ~vtkTimerLog() {};
00153
00154   static int               MaxEntries;
00155   static int               NextEntry;
00156   static int               WrapFlag;
00157   static int               TicksPerSecond;
00158   static vtkTimerLogEntry *TimerLog;
00159
00160 #ifdef _WIN32
00161 #ifndef _WIN32_WCE
00162   static timeb             FirstWallTime;
00163   static timeb             CurrentWallTime;
00164 #else
00165   static FILETIME FirstWallTime;
00166   static FILETIME CurrentWallTime;
00167 #endif
00168 #else
00169   static timeval           FirstWallTime;
00170   static timeval           CurrentWallTime;
00171   static tms               FirstCpuTicks;
00172   static tms               CurrentCpuTicks;
00173 #endif
00174
00175   // instance variables to support simple timing functionality,
00176   // separate from timer table logging.
00177   double StartTime;
00178   double EndTime;
00179
00180   //BTX
00181   static void DumpEntry(ostream& os, int index, float time, float deltatime,
00182                         int tick, int deltatick, char *event);
00183   //ETX
00184
00185 private:
00186   vtkTimerLog(const vtkTimerLog&);  // Not implemented.
00187   void operator=(const vtkTimerLog&);  // Not implemented.
00188 };
00189
00190
00191 //
00192 // Set built-in type.  Creates member Set"name"() (e.g., SetVisibility());
00193 //
00194 #define vtkTimerLogMacro(string) \
00195   { \
00196       vtkTimerLog::FormatAndMarkEvent("Mark: In %s, line %d, class %s: %s", \
00197                               __FILE__, __LINE__, this->GetClassName(), string); \
00198   }
00199
00200 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTimeStamp.h Source File

Common/vtkTimeStamp.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTimeStamp.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkTimeStamp_h
00042 #define __vtkTimeStamp_h
00043
00044 #include "vtkWin32Header.h"
00045
00046 class VTK_COMMON_EXPORT vtkTimeStamp
00047 {
00048 public:
00049   vtkTimeStamp() {this->ModifiedTime = 0;};
00050   static vtkTimeStamp *New();
00051   void Delete() {delete this;};
00052
00053   virtual const char *GetClassName() {return "vtkTimeStamp";};
00054
00062   void Modified();
00063
00065   unsigned long int GetMTime() {return this->ModifiedTime;};
00066
00068
00069   int operator>(vtkTimeStamp& ts) {
00070     return (this->ModifiedTime > ts.ModifiedTime);};
00071   int operator<(vtkTimeStamp& ts) {
00072     return (this->ModifiedTime < ts.ModifiedTime);};
00074
00076   operator unsigned long() {return this->ModifiedTime;};
00077
00078 private:
00079   unsigned long ModifiedTime;
00080 };
00081
00082 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkTkImageViewerWidget.h Source File

Rendering/vtkTkImageViewerWidget.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTkImageViewerWidget.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkTkImageViewerWidget_h
00049 #define __vtkTkImageViewerWidget_h
00050
00051 #include "vtkImageViewer.h"
00052 #include <tcl.h>
00053 #include <tk.h>
00054 #ifndef VTK_PYTHON_BUILD
00055 #include "vtkTclUtil.h"
00056 #endif
00057
00058 struct vtkTkImageViewerWidget
00059 {
00060   Tk_Window  TkWin;             /* Tk window structure */
00061   Tcl_Interp *Interp;           /* Tcl interpreter */
00062   int Width;
00063   int Height;
00064   vtkImageViewer *ImageViewer;
00065   char *IV;
00066 #ifdef _WIN32
00067   WNDPROC OldProc;
00068 #endif
00069 };
00070
00071 // This widget requires access to structures that are normally
00072 // not visible to Tcl/Tk applications. For this reason you must
00073 // have access to tkInt.h
00074 // #include "tkInt.h"
00075
00076 #ifdef _WIN32
00077 extern "C" {
00078 #include "tkWinInt.h"
00079 }
00080 #endif
00081
00082 #endif
00083
00084
00085
00086
00087
00088
00089
00090
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkTkImageWindowWidget.h Source File

Rendering/vtkTkImageWindowWidget.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTkImageWindowWidget.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkTkImageWindowWidget_h
00045 #define __vtkTkImageWindowWidget_h
00046
00047 #include "vtkImageWindow.h"
00048 #include <tcl.h>
00049 #include <tk.h>
00050 #ifndef VTK_PYTHON_BUILD
00051 #include "vtkTclUtil.h"
00052 #endif
00053 struct vtkTkImageWindowWidget
00054 {
00055   Tk_Window  TkWin;             /* Tk window structure */
00056   Tcl_Interp *Interp;           /* Tcl interpreter */
00057   int Width;
00058   int Height;
00059   vtkImageWindow *ImageWindow;
00060   char *IW;
00061 #ifdef _WIN32
00062   WNDPROC OldProc;
00063 #endif
00064 };
00065
00066 // This widget requires access to structures that are normally
00067 // not visible to Tcl/Tk applications. For this reason you must
00068 // have access to tkInt.h
00069 // #include "tkInt.h"
00070
00071 #ifdef _WIN32
00072 extern "C" {
00073 #include "tkWinInt.h"
00074 }
00075 #endif
00076
00077 #endif
00078
00079
00080
00081
00082
00083
00084
00085
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkTkRenderWidget.h Source File

Rendering/vtkTkRenderWidget.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTkRenderWidget.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkTkRenderWidget_h
00048 #define __vtkTkRenderWidget_h
00049
00050 #include "vtkRenderWindow.h"
00051 #include <tcl.h>
00052 #include <tk.h>
00053 #ifndef VTK_PYTHON_BUILD
00054 #include "vtkTclUtil.h"
00055 #endif
00056
00057 struct vtkTkRenderWidget
00058 {
00059   Tk_Window  TkWin;             /* Tk window structure */
00060   Tcl_Interp *Interp;           /* Tcl interpreter */
00061   int Width;
00062   int Height;
00063   vtkRenderWindow *RenderWindow;
00064   char *RW;
00065 #ifdef _WIN32
00066   WNDPROC OldProc;
00067 #endif
00068 };
00069
00070 // This widget requires access to structures that are normally
00071 // not visible to Tcl/Tk applications. For this reason you must
00072 // have access to tkInt.h
00073 // #include "tkInt.h"
00074
00075 #ifdef _WIN32
00076 extern "C" {
00077 #include "tkWinInt.h"
00078 }
00079 #endif
00080
00081 #endif
00082
00083
00084
00085
00086
00087
00088
00089
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTransform.h Source File

Common/vtkTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00065 #ifndef __vtkTransform_h
00066 #define __vtkTransform_h
00067
00068 #include "vtkLinearTransform.h"
00069 #include "vtkMatrix4x4.h"
00070
00071 class VTK_COMMON_EXPORT vtkTransform : public vtkLinearTransform
00072 {
00073  public:
00074   static vtkTransform *New();
00075   vtkTypeRevisionMacro(vtkTransform,vtkLinearTransform);
00076   void PrintSelf(ostream& os, vtkIndent indent);
00077
00081   void Identity();
00082
00086   void Inverse();
00087
00089
00091   void Translate(double x, double y, double z) {
00092     this->Concatenation->Translate(x,y,z); };
00093   void Translate(const double x[3]) { this->Translate(x[0], x[1], x[2]); };
00094   void Translate(const float x[3]) { this->Translate(x[0], x[1], x[2]); };
00096
00098
00102   void RotateWXYZ(double angle, double x, double y, double z) {
00103     this->Concatenation->Rotate(angle,x,y,z); };
00104   void RotateWXYZ(double angle, const double axis[3]) {
00105     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00106   void RotateWXYZ(double angle, const float axis[3]) {
00107     this->RotateWXYZ(angle, axis[0], axis[1], axis[2]); };
00109
00111
00114   void RotateX(double angle) { this->RotateWXYZ(angle, 1, 0, 0); };
00115   void RotateY(double angle) { this->RotateWXYZ(angle, 0, 1, 0); };
00116   void RotateZ(double angle) { this->RotateWXYZ(angle, 0, 0, 1); };
00118
00120
00123   void Scale(double x, double y, double z) {
00124     this->Concatenation->Scale(x,y,z); };
00125   void Scale(const double s[3]) { this->Scale(s[0], s[1], s[2]); };
00126   void Scale(const float s[3]) { this->Scale(s[0], s[1], s[2]); };
00128
00130
00132   void SetMatrix(vtkMatrix4x4 *matrix) {
00133     this->SetMatrix(*matrix->Element); };
00134   void SetMatrix(const double elements[16]) {
00135     this->Identity(); this->Concatenate(elements); };
00137
00139
00141   void Concatenate(vtkMatrix4x4 *matrix) {
00142     this->Concatenate(*matrix->Element); };
00143   void Concatenate(const double elements[16]) {
00144     this->Concatenation->Concatenate(elements); };
00146
00152   void Concatenate(vtkLinearTransform *transform);
00153
00155
00160   void PreMultiply() {
00161     if (this->Concatenation->GetPreMultiplyFlag()) { return; }
00162     this->Concatenation->SetPreMultiplyFlag(1); this->Modified(); };
00164
00166
00171   void PostMultiply()  {
00172     if (!this->Concatenation->GetPreMultiplyFlag()) { return; }
00173     this->Concatenation->SetPreMultiplyFlag(0); this->Modified(); };
00175
00177
00179   int GetNumberOfConcatenatedTransforms() {
00180     return this->Concatenation->GetNumberOfTransforms() +
00181       (this->Input == NULL ? 0 : 1); };
00183
00185
00190   vtkLinearTransform *GetConcatenatedTransform(int i) {
00191     if (this->Input == NULL) {
00192       return (vtkLinearTransform *)this->Concatenation->GetTransform(i); }
00193     else if (i < this->Concatenation->GetNumberOfPreTransforms()) {
00194       return (vtkLinearTransform *)this->Concatenation->GetTransform(i); }
00195     else if (i > this->Concatenation->GetNumberOfPreTransforms()) {
00196       return (vtkLinearTransform *)this->Concatenation->GetTransform(i-1); }
00197     else if (this->GetInverseFlag()) {
00198       return (vtkLinearTransform *)this->Input->GetInverse(); }
00199     else {
00200       return (vtkLinearTransform *)this->Input; } };
00202
00204
00206   void GetOrientation(double orient[3]);
00207   void GetOrientation(float orient[3]) {
00208     double temp[3]; this->GetOrientation(temp);
00209     orient[0] = temp[0]; orient[1] = temp[1]; orient[2] = temp[2]; };
00210   float *GetOrientation() {
00211     this->GetOrientation(this->ReturnValue); return this->ReturnValue; };
00213
00215
00216   void GetOrientationWXYZ(double wxyz[4]);
00217   void GetOrientationWXYZ(float wxyz[3]) {
00218     double temp[4]; this->GetOrientationWXYZ(temp);
00219     wxyz[0]=temp[0]; wxyz[1]=temp[1]; wxyz[2]=temp[2]; wxyz[3]=temp[3];};
00220   float *GetOrientationWXYZ() {
00221     this->GetOrientationWXYZ(this->ReturnValue); return this->ReturnValue; };
00223
00225
00228   void GetPosition(double pos[3]);
00229   void GetPosition(float pos[3]) {
00230     double temp[3]; this->GetPosition(temp);
00231     pos[0] = temp[0]; pos[1] = temp[1]; pos[2] = temp[2]; };
00232   float *GetPosition() {
00233     this->GetPosition(this->ReturnValue); return this->ReturnValue; };
00235
00237
00241   void GetScale(double scale[3]);
00242   void GetScale(float scale[3]) {
00243     double temp[3]; this->GetScale(temp);
00244     scale[0] = temp[0]; scale[1] = temp[1]; scale[2] = temp[2]; };
00245   float *GetScale() {
00246     this->GetScale(this->ReturnValue); return this->ReturnValue; };
00248
00251   void GetInverse(vtkMatrix4x4 *inverse);
00252
00256   void GetTranspose(vtkMatrix4x4 *transpose);
00257
00259
00265   void SetInput(vtkLinearTransform *input);
00266   vtkLinearTransform *GetInput() { return this->Input; };
00268
00270
00274   int GetInverseFlag() {
00275     return this->Concatenation->GetInverseFlag(); };
00277
00279
00280   void Push() { if (this->Stack == NULL) {
00281                     this->Stack = vtkTransformConcatenationStack::New(); }
00282                 this->Stack->Push(&this->Concatenation);
00283                 this->Modified(); };
00285
00287
00289   void Pop() { if (this->Stack == NULL) { return; }
00290                this->Stack->Pop(&this->Concatenation);
00291                this->Modified(); };
00293
00300   int CircuitCheck(vtkAbstractTransform *transform);
00301
00302   // Return an inverse transform which will always update itself
00303   // to match this transform.
00304   vtkAbstractTransform *GetInverse() {
00305     return vtkLinearTransform::GetInverse(); }
00306
00308   vtkAbstractTransform *MakeTransform();
00309
00311   unsigned long GetMTime();
00312
00314
00317   void MultiplyPoint(const float in[4], float out[4]) {
00318     this->GetMatrix()->MultiplyPoint(in,out);};
00319   void MultiplyPoint(const double in[4], double out[4]) {
00320     this->GetMatrix()->MultiplyPoint(in,out);};
00322
00323 protected:
00324   vtkTransform ();
00325   ~vtkTransform ();
00326
00327   void InternalDeepCopy(vtkAbstractTransform *t);
00328
00329   void InternalUpdate();
00330
00331   vtkLinearTransform *Input;
00332   vtkTransformConcatenation *Concatenation;
00333   vtkTransformConcatenationStack *Stack;
00334
00335   // this allows us to check whether people have been fooling
00336   // around with our matrix
00337   unsigned long MatrixUpdateMTime;
00338
00339   float Point[4];
00340   double DoublePoint[4];
00341   float ReturnValue[4];
00342 private:
00343   vtkTransform (const vtkTransform& t);  // Not implemented.
00344   void operator=(const vtkTransform&);  // Not implemented.
00345 };
00346
00347 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTransformCollection.h Source File

Common/vtkTransformCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransformCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkTransformCollection_h
00043 #define __vtkTransformCollection_h
00044
00045 #include "vtkCollection.h"
00046 #include "vtkTransform.h"
00047
00048 class VTK_COMMON_EXPORT vtkTransformCollection : public vtkCollection
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkTransformCollection,vtkCollection);
00052   static vtkTransformCollection *New();
00053
00055   void AddItem(vtkTransform *);
00056
00059   vtkTransform *GetNextItem();
00060
00061 protected:
00062   vtkTransformCollection() {};
00063   ~vtkTransformCollection() {};
00064
00065
00066 private:
00067   // hide the standard AddItem from the user and the compiler.
00068   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00069
00070 private:
00071   vtkTransformCollection(const vtkTransformCollection&);  // Not implemented.
00072   void operator=(const vtkTransformCollection&);  // Not implemented.
00073 };
00074
00075 inline void vtkTransformCollection::AddItem(vtkTransform *t)
00076 {
00077   this->vtkCollection::AddItem((vtkObject *)t);
00078 }
00079
00080 inline vtkTransform *vtkTransformCollection::GetNextItem()
00081 {
00082   return static_cast<vtkTransform *>(this->GetNextItemAsObject());
00083 }
00084
00085 #endif
Generated on Mon Mar 25 01:07:37 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTransformFilter.h Source File

Graphics/vtkTransformFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransformFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkTransformFilter_h
00051 #define __vtkTransformFilter_h
00052
00053 #include "vtkPointSetToPointSetFilter.h"
00054 #include "vtkAbstractTransform.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkTransformFilter : public vtkPointSetToPointSetFilter
00057 {
00058 public:
00059   static vtkTransformFilter *New();
00060   vtkTypeRevisionMacro(vtkTransformFilter,vtkPointSetToPointSetFilter);
00061   void PrintSelf(ostream& os, vtkIndent indent);
00062
00064   unsigned long GetMTime();
00065
00067
00068   vtkSetObjectMacro(Transform,vtkAbstractTransform);
00069   vtkGetObjectMacro(Transform,vtkAbstractTransform);
00071
00072 protected:
00073   vtkTransformFilter();
00074   ~vtkTransformFilter();
00075
00076   void Execute();
00077   vtkAbstractTransform *Transform;
00078 private:
00079   vtkTransformFilter(const vtkTransformFilter&);  // Not implemented.
00080   void operator=(const vtkTransformFilter&);  // Not implemented.
00081 };
00082
00083 #endif
Generated on Mon Mar 25 01:07:45 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTransformPolyDataFilter.h Source File

Graphics/vtkTransformPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransformPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00054 #ifndef __vtkTransformPolyDataFilter_h
00055 #define __vtkTransformPolyDataFilter_h
00056
00057 #include "vtkPolyDataToPolyDataFilter.h"
00058 #include "vtkTransform.h"
00059
00060 class VTK_GRAPHICS_EXPORT vtkTransformPolyDataFilter : public vtkPolyDataToPolyDataFilter
00061 {
00062 public:
00063   static vtkTransformPolyDataFilter *New();
00064   vtkTypeRevisionMacro(vtkTransformPolyDataFilter,vtkPolyDataToPolyDataFilter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068   unsigned long GetMTime();
00069
00071
00072   vtkSetObjectMacro(Transform,vtkAbstractTransform);
00073   vtkGetObjectMacro(Transform,vtkAbstractTransform);
00075
00076 protected:
00077   vtkTransformPolyDataFilter();
00078   ~vtkTransformPolyDataFilter();
00079
00080   void Execute();
00081   vtkAbstractTransform *Transform;
00082 private:
00083   vtkTransformPolyDataFilter(const vtkTransformPolyDataFilter&);  // Not implemented.
00084   void operator=(const vtkTransformPolyDataFilter&);  // Not implemented.
00085 };
00086
00087 #endif
00088
00089
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTransformTextureCoords.h Source File

Graphics/vtkTransformTextureCoords.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransformTextureCoords.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkTransformTextureCoords_h
00052 #define __vtkTransformTextureCoords_h
00053
00054 #include "vtkDataSetToDataSetFilter.h"
00055
00056 class VTK_GRAPHICS_EXPORT vtkTransformTextureCoords : public vtkDataSetToDataSetFilter
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkTransformTextureCoords,vtkDataSetToDataSetFilter);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00065   static vtkTransformTextureCoords *New();
00066
00068
00070   vtkSetVector3Macro(Position,float);
00071   vtkGetVectorMacro(Position,float,3);
00073
00075
00077   void AddPosition(float deltaR, float deltaS, float deltaT);
00078   void AddPosition(float deltaPosition[3]);
00080
00082
00084   vtkSetVector3Macro(Scale,float);
00085   vtkGetVectorMacro(Scale,float,3);
00087
00089
00093   vtkSetVector3Macro(Origin,float);
00094   vtkGetVectorMacro(Origin,float,3);
00096
00098
00100   vtkSetMacro(FlipR,int);
00101   vtkGetMacro(FlipR,int);
00102   vtkBooleanMacro(FlipR,int);
00104
00106
00108   vtkSetMacro(FlipS,int);
00109   vtkGetMacro(FlipS,int);
00110   vtkBooleanMacro(FlipS,int);
00112
00114
00116   vtkSetMacro(FlipT,int);
00117   vtkGetMacro(FlipT,int);
00118   vtkBooleanMacro(FlipT,int);
00120
00121 protected:
00122   vtkTransformTextureCoords();
00123   ~vtkTransformTextureCoords() {};
00124
00125   void Execute();
00126
00127   float Origin[3]; //point around which map rotates
00128   float Position[3]; //controls translation of map
00129   float Scale[3]; //scales the texture map
00130   int FlipR; //boolean indicates whether to flip texture around r-axis
00131   int FlipS; //boolean indicates whether to flip texture around s-axis
00132   int FlipT; //boolean indicates whether to flip texture around t-axis
00133 private:
00134   vtkTransformTextureCoords(const vtkTransformTextureCoords&);  // Not implemented.
00135   void operator=(const vtkTransformTextureCoords&);  // Not implemented.
00136 };
00137
00138 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkTransformToGrid.h Source File

Hybrid/vtkTransformToGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransformToGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkTransformToGrid_h
00040 #define __vtkTransformToGrid_h
00041
00042 #include "vtkImageSource.h"
00043 #include "vtkAbstractTransform.h"
00044
00045 class VTK_HYBRID_EXPORT vtkTransformToGrid : public vtkImageSource
00046 {
00047 public:
00048   static vtkTransformToGrid *New();
00049   vtkTypeRevisionMacro(vtkTransformToGrid,vtkImageSource);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053
00054   vtkSetObjectMacro(Input,vtkAbstractTransform);
00055   vtkGetObjectMacro(Input,vtkAbstractTransform);
00057
00059
00060   vtkSetVector6Macro(GridExtent,int);
00061   vtkGetVector6Macro(GridExtent,int);
00063
00065
00066   vtkSetVector3Macro(GridOrigin,float);
00067   vtkGetVector3Macro(GridOrigin,float);
00069
00071
00072   vtkSetVector3Macro(GridSpacing,float);
00073   vtkGetVector3Macro(GridSpacing,float);
00075
00077
00078   vtkSetMacro(GridScalarType,int);
00079   vtkGetMacro(GridScalarType,int);
00080   void SetGridScalarTypeToFloat(){this->SetGridScalarType(VTK_FLOAT);};
00081   void SetGridScalarTypeToShort(){this->SetGridScalarType(VTK_SHORT);};
00082   void SetGridScalarTypeToUnsignedShort()
00083     {this->SetGridScalarType(VTK_UNSIGNED_SHORT);};
00084   void SetGridScalarTypeToUnsignedChar()
00085     {this->SetGridScalarType(VTK_UNSIGNED_CHAR);};
00086   void SetGridScalarTypeToChar()
00087     {this->SetGridScalarType(VTK_CHAR);};
00089
00091
00094   float GetDisplacementScale() {
00095     this->UpdateShiftScale(); return this->DisplacementScale; };
00096   float GetDisplacementShift() {
00097     this->UpdateShiftScale(); return this->DisplacementShift; };
00099
00100 protected:
00101   vtkTransformToGrid();
00102   ~vtkTransformToGrid();
00103
00104   void ExecuteInformation();
00105
00106   void ExecuteData(vtkDataObject *data);
00107
00110   void UpdateShiftScale();
00111
00112   unsigned long GetMTime();
00113
00114   vtkAbstractTransform *Input;
00115
00116   int GridScalarType;
00117   int GridExtent[6];
00118   float GridOrigin[3];
00119   float GridSpacing[3];
00120
00121   float DisplacementScale;
00122   float DisplacementShift;
00123   vtkTimeStamp ShiftScaleTime;
00124 private:
00125   vtkTransformToGrid(const vtkTransformToGrid&);  // Not implemented.
00126   void operator=(const vtkTransformToGrid&);  // Not implemented.
00127 };
00128
00129 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkTransmitPolyDataPiece.h Source File

Parallel/vtkTransmitPolyDataPiece.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransmitPolyDataPiece.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkTransmitPolyDataPiece_h
00035 #define __vtkTransmitPolyDataPiece_h
00036
00037 #include "vtkPolyDataToPolyDataFilter.h"
00038 #include "vtkMultiProcessController.h"
00039
00040
00041 class VTK_PARALLEL_EXPORT vtkTransmitPolyDataPiece : public vtkPolyDataToPolyDataFilter
00042 {
00043 public:
00044   static vtkTransmitPolyDataPiece *New();
00045   vtkTypeRevisionMacro(vtkTransmitPolyDataPiece, vtkPolyDataToPolyDataFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   vtkSetObjectMacro(Controller, vtkMultiProcessController);
00052   vtkGetObjectMacro(Controller, vtkMultiProcessController);
00054
00056
00057   vtkSetMacro(CreateGhostCells, int);
00058   vtkGetMacro(CreateGhostCells, int);
00059   vtkBooleanMacro(CreateGhostCells, int);
00061
00062 protected:
00063   vtkTransmitPolyDataPiece();
00064   ~vtkTransmitPolyDataPiece();
00065   vtkTransmitPolyDataPiece(const vtkTransmitPolyDataPiece&);
00066   void operator=(const vtkTransmitPolyDataPiece&);
00067
00068   // Data generation method
00069   void Execute();
00070   void RootExecute();
00071   void SatelliteExecute(int procId);
00072   void ExecuteInformation();
00073   void ComputeInputUpdateExtents(vtkDataObject *out);
00074
00075   vtkPolyData *Buffer;
00076   int BufferPiece;
00077   int BufferNumberOfPieces;
00078   int BufferGhostLevel;
00079
00080   int CreateGhostCells;
00081   vtkMultiProcessController *Controller;
00082 };
00083
00084 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkTransmitUnstructuredGridPiece.h Source File

Parallel/vtkTransmitUnstructuredGridPiece.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTransmitUnstructuredGridPiece.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkTransmitUnstructuredGridPiece_h
00036 #define __vtkTransmitUnstructuredGridPiece_h
00037
00038 #include "vtkUnstructuredGridToUnstructuredGridFilter.h"
00039 #include "vtkMultiProcessController.h"
00040
00041
00042 class VTK_PARALLEL_EXPORT vtkTransmitUnstructuredGridPiece : public vtkUnstructuredGridToUnstructuredGridFilter
00043 {
00044 public:
00045   static vtkTransmitUnstructuredGridPiece *New();
00046   vtkTypeRevisionMacro(vtkTransmitUnstructuredGridPiece, vtkUnstructuredGridToUnstructuredGridFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00052   vtkSetObjectMacro(Controller, vtkMultiProcessController);
00053   vtkGetObjectMacro(Controller, vtkMultiProcessController);
00055
00057
00058   vtkSetMacro(CreateGhostCells, int);
00059   vtkGetMacro(CreateGhostCells, int);
00060   vtkBooleanMacro(CreateGhostCells, int);
00062
00063 protected:
00064   vtkTransmitUnstructuredGridPiece();
00065   ~vtkTransmitUnstructuredGridPiece();
00066   vtkTransmitUnstructuredGridPiece(const vtkTransmitUnstructuredGridPiece&);
00067   void operator=(const vtkTransmitUnstructuredGridPiece&);
00068
00069   // Data generation method
00070   void Execute();
00071   void RootExecute();
00072   void SatelliteExecute(int procId);
00073   void ExecuteInformation();
00074   void ComputeInputUpdateExtents(vtkDataObject *out);
00075
00076   int CreateGhostCells;
00077   vtkMultiProcessController *Controller;
00078 };
00079
00080 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Parallel/vtkTreeComposite.h Source File

Parallel/vtkTreeComposite.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTreeComposite.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00017 // This software and ancillary information known as vtk_ext (and
00018 // herein called "SOFTWARE") is made available under the terms
00019 // described below.  The SOFTWARE has been approved for release with
00020 // associated LA_CC Number 99-44, granted by Los Alamos National
00021 // Laboratory in July 1999.
00022 //
00023 // Unless otherwise indicated, this SOFTWARE has been authored by an
00024 // employee or employees of the University of California, operator of
00025 // the Los Alamos National Laboratory under Contract No. W-7405-ENG-36
00026 // with the United States Department of Energy.
00027 //
00028 // The United States Government has rights to use, reproduce, and
00029 // distribute this SOFTWARE.  The public may copy, distribute, prepare
00030 // derivative works and publicly display this SOFTWARE without charge,
00031 // provided that this Notice and any statement of authorship are
00032 // reproduced on all copies.
00033 //
00034 // Neither the U. S. Government, the University of California, nor the
00035 // Advanced Computing Laboratory makes any warranty, either express or
00036 // implied, nor assumes any liability or responsibility for the use of
00037 // this SOFTWARE.
00038 //
00039 // If SOFTWARE is modified to produce derivative works, such modified
00040 // SOFTWARE should be clearly marked, so as not to confuse it with the
00041 // version available from Los Alamos National Laboratory.
00042
00043
00072 #ifndef __vtkTreeComposite_h
00073 #define __vtkTreeComposite_h
00074
00075 #include "vtkCompositeManager.h"
00076
00077
00078 class VTK_PARALLEL_EXPORT vtkTreeComposite : public vtkCompositeManager
00079 {
00080 public:
00081   static vtkTreeComposite *New();
00082   vtkTypeRevisionMacro(vtkTreeComposite,vtkCompositeManager);
00083   void PrintSelf(ostream& os, vtkIndent indent);
00084
00085 protected:
00086   vtkTreeComposite();
00087   ~vtkTreeComposite();
00088   vtkTreeComposite(const vtkTreeComposite&);
00089   void operator=(const vtkTreeComposite&);
00090
00091   virtual void CompositeBuffer(int width, int height, int useCharFlag,
00092                                void *pBuf, float *zBuf,
00093                                void *pTmp, float *zTmp);
00094
00095 };
00096
00097 #endif
Generated on Mon Mar 25 01:07:55 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTriangle.h Source File

Common/vtkTriangle.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTriangle.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkTriangle_h
00043 #define __vtkTriangle_h
00044
00045 #include "vtkCell.h"
00046 #include "vtkMath.h"
00047 #include "vtkLine.h"
00048 #include "vtkQuadric.h"
00049
00050 class VTK_COMMON_EXPORT vtkTriangle : public vtkCell
00051 {
00052 public:
00053   static vtkTriangle *New();
00054   vtkTypeRevisionMacro(vtkTriangle,vtkCell);
00055
00058   vtkCell *MakeObject();
00059
00062   vtkCell *GetEdge(int edgeId);
00063
00065
00066   int GetCellType() {return VTK_TRIANGLE;};
00067   int GetCellDimension() {return 2;};
00068   int GetNumberOfEdges() {return 3;};
00069   int GetNumberOfFaces() {return 0;};
00070   vtkCell *GetFace(int) {return 0;};
00071   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00072   void Contour(float value, vtkDataArray *cellScalars,
00073                vtkPointLocator *locator, vtkCellArray *verts,
00074                vtkCellArray *lines, vtkCellArray *polys,
00075                vtkPointData *inPd, vtkPointData *outPd,
00076                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00077   int EvaluatePosition(float x[3], float* closestPoint,
00078                        int& subId, float pcoords[3],
00079                        float& dist2, float *weights);
00080   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00081                         float *weights);
00082   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00083   void Derivatives(int subId, float pcoords[3], float *values,
00084                    int dim, float *derivs);
00086
00088
00090   void Clip(float value, vtkDataArray *cellScalars,
00091             vtkPointLocator *locator, vtkCellArray *polys,
00092             vtkPointData *inPd, vtkPointData *outPd,
00093             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00094             int insideOut);
00096
00098
00100   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00101                         float x[3], float pcoords[3], int& subId);
00103
00105   int GetParametricCenter(float pcoords[3]);
00106
00108
00109   static void TriangleCenter(float p1[3], float p2[3], float p3[3],
00110                              float center[3]);
00112
00114   static float TriangleArea(float p1[3], float p2[3], float p3[3]);
00115
00117
00121   static double Circumcircle(double  p1[2], double p2[2], double p3[2],
00122                             double center[2]);
00124
00126
00137   static int BarycentricCoords(double x[2], double  x1[2], double x2[2],
00138                                double x3[2], double bcoords[3]);
00140
00141
00143
00146   static int ProjectTo2D(double x1[3], double x2[3], double x3[3],
00147                          double v1[2], double v2[2], double v3[2]);
00149
00151
00153   static void ComputeNormal(vtkPoints *p, int numPts, vtkIdType *pts,
00154                             float n[3]);
00156
00158   static void ComputeNormal(float v1[3], float v2[3], float v3[3], float n[3]);
00159
00161
00163   static void ComputeNormalDirection(float v1[3], float v2[3], float v3[3],
00164                                      float n[3]);
00166
00168
00170   static void ComputeNormal(double v1[3], double v2[3], double v3[3],
00171                             double n[3]);
00173
00175
00177   static void ComputeNormalDirection(double v1[3], double v2[3], double v3[3],
00178                                      double n[3]);
00180
00182
00187   static int PointInTriangle(float x[3], float x1[3], float x2[3], float x3[3],
00188                              float tol2);
00190
00192
00195   static void ComputeQuadric(float x1[3], float x2[3], float x3[3],
00196                              float quadric[4][4]);
00197   static void ComputeQuadric(float x1[3], float x2[3], float x3[3],
00198                              vtkQuadric *quadric);
00200
00201
00202 protected:
00203   vtkTriangle();
00204   ~vtkTriangle();
00205
00206   vtkLine *Line;
00207
00208 private:
00209   vtkTriangle(const vtkTriangle&);  // Not implemented.
00210   void operator=(const vtkTriangle&);  // Not implemented.
00211 };
00212
00213 inline int vtkTriangle::GetParametricCenter(float pcoords[3])
00214 {
00215   pcoords[0] = pcoords[1] = 0.333; pcoords[2] = 0.0;
00216   return 0;
00217 }
00218
00219 inline void vtkTriangle::ComputeNormalDirection(float v1[3], float v2[3],
00220                                        float v3[3], float n[3])
00221 {
00222   float ax, ay, az, bx, by, bz;
00223
00224   // order is important!!! maintain consistency with triangle vertex order
00225   ax = v3[0] - v2[0]; ay = v3[1] - v2[1]; az = v3[2] - v2[2];
00226   bx = v1[0] - v2[0]; by = v1[1] - v2[1]; bz = v1[2] - v2[2];
00227
00228   n[0] = (ay * bz - az * by);
00229   n[1] = (az * bx - ax * bz);
00230   n[2] = (ax * by - ay * bx);
00231 }
00232
00233 inline void vtkTriangle::ComputeNormal(float v1[3], float v2[3],
00234                                        float v3[3], float n[3])
00235 {
00236   float length;
00237
00238   vtkTriangle::ComputeNormalDirection(v1, v2, v3, n);
00239
00240   if ( (length = sqrt((n[0]*n[0] + n[1]*n[1] + n[2]*n[2]))) != 0.0 )
00241     {
00242     n[0] /= length;
00243     n[1] /= length;
00244     n[2] /= length;
00245     }
00246 }
00247
00248 inline void vtkTriangle::ComputeNormalDirection(double v1[3], double v2[3],
00249                                        double v3[3], double n[3])
00250 {
00251   double ax, ay, az, bx, by, bz;
00252
00253   // order is important!!! maintain consistency with triangle vertex order
00254   ax = v3[0] - v2[0]; ay = v3[1] - v2[1]; az = v3[2] - v2[2];
00255   bx = v1[0] - v2[0]; by = v1[1] - v2[1]; bz = v1[2] - v2[2];
00256
00257   n[0] = (ay * bz - az * by);
00258   n[1] = (az * bx - ax * bz);
00259   n[2] = (ax * by - ay * bx);
00260 }
00261
00262 inline void vtkTriangle::ComputeNormal(double v1[3], double v2[3],
00263                                        double v3[3], double n[3])
00264 {
00265   double length;
00266
00267   vtkTriangle::ComputeNormalDirection(v1, v2, v3, n);
00268
00269   if ( (length = sqrt((n[0]*n[0] + n[1]*n[1] + n[2]*n[2]))) != 0.0 )
00270     {
00271     n[0] /= length;
00272     n[1] /= length;
00273     n[2] /= length;
00274     }
00275 }
00276
00277 inline void vtkTriangle::TriangleCenter(float p1[3], float p2[3], float p3[3],
00278                                        float center[3])
00279 {
00280   center[0] = (p1[0]+p2[0]+p3[0]) / 3.0;
00281   center[1] = (p1[1]+p2[1]+p3[1]) / 3.0;
00282   center[2] = (p1[2]+p2[2]+p3[2]) / 3.0;
00283 }
00284
00285 inline float vtkTriangle::TriangleArea(float p1[3], float p2[3], float p3[3])
00286 {
00287   float a,b,c;
00288   a = vtkMath::Distance2BetweenPoints(p1,p2);
00289   b = vtkMath::Distance2BetweenPoints(p2,p3);
00290   c = vtkMath::Distance2BetweenPoints(p3,p1);
00291   return (0.25* sqrt(fabs((double)4.0*a*c - (a-b+c)*(a-b+c))));
00292 }
00293
00294 #endif
00295
00296
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTriangleFilter.h Source File

Graphics/vtkTriangleFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTriangleFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkTriangleFilter_h
00040 #define __vtkTriangleFilter_h
00041
00042 #include "vtkPolyDataToPolyDataFilter.h"
00043
00044 class VTK_GRAPHICS_EXPORT vtkTriangleFilter : public vtkPolyDataToPolyDataFilter
00045 {
00046 public:
00047   static vtkTriangleFilter *New();
00048   vtkTypeRevisionMacro(vtkTriangleFilter,vtkPolyDataToPolyDataFilter);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00053   vtkBooleanMacro(PassVerts,int);
00054   vtkSetMacro(PassVerts,int);
00055   vtkGetMacro(PassVerts,int);
00057
00059
00060   vtkBooleanMacro(PassLines,int);
00061   vtkSetMacro(PassLines,int);
00062   vtkGetMacro(PassLines,int);
00064
00065 protected:
00066   vtkTriangleFilter() : PassVerts(1), PassLines(1) {};
00067   ~vtkTriangleFilter() {};
00068
00069   // Usual data generation method
00070   void Execute();
00071
00072   int PassVerts;
00073   int PassLines;
00074 private:
00075   vtkTriangleFilter(const vtkTriangleFilter&);  // Not implemented.
00076   void operator=(const vtkTriangleFilter&);  // Not implemented.
00077 };
00078
00079 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkTriangleStrip.h Source File

Common/vtkTriangleStrip.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTriangleStrip.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkTriangleStrip_h
00045 #define __vtkTriangleStrip_h
00046
00047 #include "vtkCell.h"
00048 #include "vtkLine.h"
00049 #include "vtkTriangle.h"
00050
00051 class VTK_COMMON_EXPORT vtkTriangleStrip : public vtkCell
00052 {
00053 public:
00054   static vtkTriangleStrip *New();
00055   vtkTypeRevisionMacro(vtkTriangleStrip,vtkCell);
00056
00058
00059   vtkCell *MakeObject();
00060   int GetCellType() {return VTK_TRIANGLE_STRIP;};
00061   int GetCellDimension() {return 2;};
00062   int GetNumberOfEdges() {return this->GetNumberOfPoints();};
00063   int GetNumberOfFaces() {return 0;};
00064   vtkCell *GetEdge(int edgeId);
00065   vtkCell *GetFace(int vtkNotUsed(faceId)) {return 0;};
00066   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00067   void Contour(float value, vtkDataArray *cellScalars,
00068                vtkPointLocator *locator, vtkCellArray *verts,
00069                vtkCellArray *lines, vtkCellArray *polys,
00070                vtkPointData *inPd, vtkPointData *outPd,
00071                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00072   void Clip(float value, vtkDataArray *cellScalars,
00073             vtkPointLocator *locator, vtkCellArray *polys,
00074             vtkPointData *inPd, vtkPointData *outPd,
00075             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00076             int insideOut);
00078
00079   int EvaluatePosition(float x[3], float* closestPoint,
00080                        int& subId, float pcoords[3],
00081                        float& dist2, float *weights);
00082   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00083                         float *weights);
00084   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00085                         float x[3], float pcoords[3], int& subId);
00086   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00087   void Derivatives(int subId, float pcoords[3], float *values,
00088                    int dim, float *derivs);
00089
00091   int GetParametricCenter(float pcoords[3]);
00092
00096   static void DecomposeStrip(int npts, vtkIdType *pts, vtkCellArray *tris);
00097
00098
00099 protected:
00100   vtkTriangleStrip();
00101   ~vtkTriangleStrip();
00102
00103   vtkLine *Line;
00104   vtkTriangle *Triangle;
00105
00106 private:
00107   vtkTriangleStrip(const vtkTriangleStrip&);  // Not implemented.
00108   void operator=(const vtkTriangleStrip&);  // Not implemented.
00109 };
00110
00111 #endif
00112
00113
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTriangularTCoords.h Source File

Graphics/vtkTriangularTCoords.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTriangularTCoords.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkTriangularTCoords_h
00046 #define __vtkTriangularTCoords_h
00047
00048 #include "vtkPolyDataToPolyDataFilter.h"
00049
00050 class VTK_GRAPHICS_EXPORT vtkTriangularTCoords : public vtkPolyDataToPolyDataFilter
00051 {
00052 public:
00053   static vtkTriangularTCoords *New();
00054   vtkTypeRevisionMacro(vtkTriangularTCoords,vtkPolyDataToPolyDataFilter);
00055   void PrintSelf(ostream& os, vtkIndent indent);
00056
00057 protected:
00058   vtkTriangularTCoords() {};
00059   ~vtkTriangularTCoords() {};
00060
00061   // Usual data generation method
00062   void Execute();
00063 private:
00064   vtkTriangularTCoords(const vtkTriangularTCoords&);  // Not implemented.
00065   void operator=(const vtkTriangularTCoords&);  // Not implemented.
00066 };
00067
00068 #endif
00069
00070
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkTriangularTexture.h Source File

Imaging/vtkTriangularTexture.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTriangularTexture.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkTriangularTexture_h
00045 #define __vtkTriangularTexture_h
00046
00047 #include "vtkStructuredPointsSource.h"
00048
00049 class VTK_IMAGING_EXPORT vtkTriangularTexture : public vtkStructuredPointsSource
00050 {
00051 public:
00052   vtkTypeRevisionMacro(vtkTriangularTexture,vtkStructuredPointsSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   static vtkTriangularTexture *New();
00058
00060
00061   vtkSetMacro(ScaleFactor,float);
00062   vtkGetMacro(ScaleFactor,float);
00064
00066
00067   vtkSetMacro(XSize,int);
00068   vtkGetMacro(XSize,int);
00070
00072
00073   vtkSetMacro(YSize,int);
00074   vtkGetMacro(YSize,int);
00076
00078
00080   vtkSetClampMacro(TexturePattern,int,1,3);
00081   vtkGetMacro(TexturePattern,int);
00083
00084 protected:
00085   vtkTriangularTexture();
00086   ~vtkTriangularTexture() {};
00087
00088   void Execute();
00089
00090   int XSize;
00091   int YSize;
00092   float ScaleFactor;
00093
00094   int TexturePattern;
00095 private:
00096   vtkTriangularTexture(const vtkTriangularTexture&);  // Not implemented.
00097   void operator=(const vtkTriangularTexture&);  // Not implemented.
00098 };
00099
00100 #endif
00101
00102
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkTubeFilter.h Source File

Graphics/vtkTubeFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkTubeFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00066 #ifndef __vtkTubeFilter_h
00067 #define __vtkTubeFilter_h
00068
00069 #include "vtkPolyDataToPolyDataFilter.h"
00070
00071 #define VTK_VARY_RADIUS_OFF 0
00072 #define VTK_VARY_RADIUS_BY_SCALAR 1
00073 #define VTK_VARY_RADIUS_BY_VECTOR 2
00074
00075 class VTK_GRAPHICS_EXPORT vtkTubeFilter : public vtkPolyDataToPolyDataFilter
00076 {
00077 public:
00078   vtkTypeRevisionMacro(vtkTubeFilter,vtkPolyDataToPolyDataFilter);
00079   void PrintSelf(ostream& os, vtkIndent indent);
00080
00083   static vtkTubeFilter *New();
00084
00086
00088   vtkSetClampMacro(Radius,float,0.0,VTK_LARGE_FLOAT);
00089   vtkGetMacro(Radius,float);
00091
00093
00094   vtkSetClampMacro(VaryRadius,int,
00095                    VTK_VARY_RADIUS_OFF,VTK_VARY_RADIUS_BY_VECTOR);
00096   vtkGetMacro(VaryRadius,int);
00097   void SetVaryRadiusToVaryRadiusOff()
00098     {this->SetVaryRadius(VTK_VARY_RADIUS_OFF);};
00099   void SetVaryRadiusToVaryRadiusByScalar()
00100     {this->SetVaryRadius(VTK_VARY_RADIUS_BY_SCALAR);};
00101   void SetVaryRadiusToVaryRadiusByVector()
00102     {this->SetVaryRadius(VTK_VARY_RADIUS_BY_VECTOR);};
00103   const char *GetVaryRadiusAsString();
00105
00107
00109   vtkSetClampMacro(NumberOfSides,int,3,VTK_LARGE_INTEGER);
00110   vtkGetMacro(NumberOfSides,int);
00112
00114
00116   vtkSetMacro(RadiusFactor,float);
00117   vtkGetMacro(RadiusFactor,float);
00119
00121
00123   vtkSetVector3Macro(DefaultNormal,float);
00124   vtkGetVectorMacro(DefaultNormal,float,3);
00126
00128
00130   vtkSetMacro(UseDefaultNormal,int);
00131   vtkGetMacro(UseDefaultNormal,int);
00132   vtkBooleanMacro(UseDefaultNormal,int);
00134
00136
00137   vtkSetMacro(SidesShareVertices, int);
00138   vtkGetMacro(SidesShareVertices, int);
00139   vtkBooleanMacro(SidesShareVertices, int);
00141
00143
00144   vtkSetMacro(Capping,int);
00145   vtkGetMacro(Capping,int);
00146   vtkBooleanMacro(Capping,int);
00148
00150
00152   vtkSetClampMacro(OnRatio,int,1,VTK_LARGE_INTEGER);
00153   vtkGetMacro(OnRatio,int);
00155
00157
00160   vtkSetClampMacro(Offset,int,0,VTK_LARGE_INTEGER);
00161   vtkGetMacro(Offset,int);
00163
00164 protected:
00165   vtkTubeFilter();
00166   ~vtkTubeFilter() {};
00167
00168   // Usual data generation method
00169   void Execute();
00170
00171   float Radius; //minimum radius of tube
00172   int VaryRadius; //controls radius variation
00173   int NumberOfSides; //number of sides to create tube
00174   float RadiusFactor; //maxium allowablew radius
00175   float DefaultNormal[3];
00176   int UseDefaultNormal;
00177   int SidesShareVertices;
00178   int Capping;
00179   int OnRatio; //control the generation of the sides of the tube
00180   int Offset;  //control the generation of the sides
00181
00182 private:
00183   vtkTubeFilter(const vtkTubeFilter&);  // Not implemented.
00184   void operator=(const vtkTubeFilter&);  // Not implemented.
00185 };
00186
00188 inline const char *vtkTubeFilter::GetVaryRadiusAsString(void)
00189 {
00190   if ( this->VaryRadius == VTK_VARY_RADIUS_OFF )
00191     {
00192     return "VaryRadiusOff";
00193     }
00194   else if ( this->VaryRadius == VTK_VARY_RADIUS_BY_SCALAR )
00195     {
00196     return "VaryRadiusByScalar";
00197     }
00198   else
00199     {
00200     return "VaryRadiusByVector";
00201     }
00202 }
00203
00204
00205 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkUGFacetReader.h Source File

IO/vtkUGFacetReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUGFacetReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkUGFacetReader_h
00039 #define __vtkUGFacetReader_h
00040
00041 #include <stdio.h>
00042 #include "vtkPolyDataSource.h"
00043 #include "vtkShortArray.h"
00044
00045 class VTK_IO_EXPORT vtkUGFacetReader : public vtkPolyDataSource
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkUGFacetReader,vtkPolyDataSource);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00053   static vtkUGFacetReader *New();
00054
00057   unsigned long GetMTime();
00058
00060
00061   vtkSetStringMacro(FileName);
00062   vtkGetStringMacro(FileName);
00064
00066   int GetNumberOfParts();
00067
00069   short GetPartColorIndex(int partId);
00070
00072
00076   vtkSetMacro(PartNumber,int);
00077   vtkGetMacro(PartNumber,int);
00079
00081
00082   vtkSetMacro(Merging,int);
00083   vtkGetMacro(Merging,int);
00084   vtkBooleanMacro(Merging,int);
00086
00088
00090   void SetLocator(vtkPointLocator *locator);
00091   vtkGetObjectMacro(Locator,vtkPointLocator);
00093
00095   void CreateDefaultLocator();
00096
00097 protected:
00098   vtkUGFacetReader();
00099   ~vtkUGFacetReader();
00100
00101   void Execute();
00102
00103   char *FileName;
00104   vtkShortArray *PartColors;
00105   int PartNumber;
00106   int Merging;
00107   vtkPointLocator *Locator;
00108 private:
00109   vtkUGFacetReader(const vtkUGFacetReader&);  // Not implemented.
00110   void operator=(const vtkUGFacetReader&);  // Not implemented.
00111 };
00112
00113 #endif
00114
00115
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkUnsignedCharArray.h Source File

Common/vtkUnsignedCharArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnsignedCharArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkUnsignedCharArray_h
00042 #define __vtkUnsignedCharArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkUnsignedCharArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkUnsignedCharArray *New();
00050
00051   vtkTypeRevisionMacro(vtkUnsignedCharArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   vtkDataArray *MakeObject();
00063
00065   int GetDataType() {return VTK_UNSIGNED_CHAR;};
00066
00068   int GetDataTypeSize() { return sizeof(unsigned char); }
00069
00071   void SetNumberOfTuples(const vtkIdType number);
00072
00075   float *GetTuple(const vtkIdType i);
00076
00078
00079   void GetTuple(const vtkIdType i, float * tuple);
00080   void GetTuple(const vtkIdType i, double * tuple);
00082
00084
00085   void SetTuple(const vtkIdType i, const float * tuple);
00086   void SetTuple(const vtkIdType i, const double * tuple);
00088
00090
00092   void InsertTuple(const vtkIdType i, const float * tuple);
00093   void InsertTuple(const vtkIdType i, const double * tuple);
00095
00097
00099   vtkIdType InsertNextTuple(const float * tuple);
00100   vtkIdType InsertNextTuple(const double * tuple);
00102
00104   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00105
00107   virtual void Resize(vtkIdType numTuples);
00108
00112   float GetComponent(const vtkIdType i, const int j);
00113
00118   void SetComponent(const vtkIdType i, const int j, const float c);
00119
00123   void InsertComponent(const vtkIdType i, const int j, const float c);
00124
00126   unsigned char GetValue(const vtkIdType id) {return this->Array[id];};
00127
00129
00131   void SetValue(const vtkIdType id, const unsigned char value) {
00132     this->Array[id] = value;};
00134
00138   void SetNumberOfValues(const vtkIdType number);
00139
00141   void InsertValue(const vtkIdType id, const unsigned char c);
00142
00145   vtkIdType InsertNextValue(const unsigned char c);
00146
00148
00150   unsigned char *GetPointer(const vtkIdType id) {return this->Array + id;}
00151   void *GetVoidPointer(const vtkIdType id)
00152     {return (void *)this->GetPointer(id);};
00154
00158   unsigned char *WritePointer(const vtkIdType id, const vtkIdType number);
00159
00161   void DeepCopy(vtkDataArray *da);
00162
00164
00170   void SetArray(unsigned char* array, vtkIdType size, int save);
00171   void SetVoidArray(void *array, vtkIdType size, int save)
00172     {this->SetArray((unsigned char*)array, size, save);};
00174
00175
00176 protected:
00177   vtkUnsignedCharArray(vtkIdType numComp=1);
00178   ~vtkUnsignedCharArray();
00179
00180   unsigned char *Array;   // pointer to data
00181   unsigned char *ResizeAndExtend(const vtkIdType sz);
00182     // function to resize data
00183
00184   int TupleSize; //used for data conversion
00185   float *Tuple;
00186
00187   int SaveUserArray;
00188 private:
00189   vtkUnsignedCharArray(const vtkUnsignedCharArray&);  // Not implemented.
00190   void operator=(const vtkUnsignedCharArray&);  // Not implemented.
00191 };
00192
00193 inline void vtkUnsignedCharArray::SetNumberOfValues(const vtkIdType number)
00194 {
00195   this->Allocate(number);
00196   this->MaxId = number - 1;
00197 }
00198
00199 inline unsigned char *vtkUnsignedCharArray::WritePointer(const vtkIdType id,
00200                                                          const vtkIdType number)
00201 {
00202   vtkIdType newSize=id+number;
00203   if ( newSize > this->Size )
00204     {
00205     this->ResizeAndExtend(newSize);
00206     }
00207   if ( (--newSize) > this->MaxId )
00208     {
00209     this->MaxId = newSize;
00210     }
00211   return this->Array + id;
00212 }
00213
00214 inline void vtkUnsignedCharArray::InsertValue(const vtkIdType id,
00215                                               const unsigned char c)
00216 {
00217   if ( id >= this->Size )
00218     {
00219     this->ResizeAndExtend(id+1);
00220     }
00221   this->Array[id] = c;
00222   if ( id > this->MaxId )
00223     {
00224     this->MaxId = id;
00225     }
00226 }
00227
00228 inline vtkIdType vtkUnsignedCharArray::InsertNextValue(const unsigned char c)
00229 {
00230   this->InsertValue (++this->MaxId,c);
00231   return this->MaxId;
00232 }
00233
00234
00235 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkUnsignedIntArray.h Source File

Common/vtkUnsignedIntArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnsignedIntArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkUnsignedIntArray_h
00042 #define __vtkUnsignedIntArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkUnsignedIntArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkUnsignedIntArray *New();
00050
00051   vtkTypeRevisionMacro(vtkUnsignedIntArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   vtkDataArray *MakeObject();
00063
00065   int GetDataType() {return VTK_UNSIGNED_INT;};
00066
00068   int GetDataTypeSize() { return sizeof(unsigned int); }
00069
00071   void SetNumberOfTuples(const vtkIdType number);
00072
00075   float *GetTuple(const vtkIdType i);
00076
00078
00079   void GetTuple(const vtkIdType i, float * tuple);
00080   void GetTuple(const vtkIdType i, double * tuple);
00082
00084
00085   void SetTuple(const vtkIdType i, const float * tuple);
00086   void SetTuple(const vtkIdType i, const double * tuple);
00088
00090
00092   void InsertTuple(const vtkIdType i, const float * tuple);
00093   void InsertTuple(const vtkIdType i, const double * tuple);
00095
00097
00099   vtkIdType InsertNextTuple(const float * tuple);
00100   vtkIdType InsertNextTuple(const double * tuple);
00102
00104   unsigned int GetValue(const vtkIdType id) {return this->Array[id];};
00105
00107
00109   void SetValue(const vtkIdType id, const unsigned int value) {
00110     this->Array[id] = value;};
00112
00116   void SetNumberOfValues(const vtkIdType number);
00117
00119   void InsertValue(const vtkIdType id, const unsigned int i);
00120
00123   vtkIdType InsertNextValue(const unsigned int);
00124
00128   float GetComponent(const vtkIdType i, const int j);
00129
00134   void SetComponent(const vtkIdType i, const int j, const float c);
00135
00139   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00140
00142
00144   unsigned int *GetPointer(const vtkIdType id) {return this->Array + id;}
00145   void *GetVoidPointer(const vtkIdType id)
00146     {return (void *)this->GetPointer(id);};
00148
00152   unsigned int *WritePointer(const vtkIdType id, const vtkIdType number);
00153
00155   void DeepCopy(vtkDataArray *da);
00156
00158
00164   void SetArray(unsigned int* array, vtkIdType size, int save);
00165   void SetVoidArray(void *array,vtkIdType size, int save)
00166     {this->SetArray((unsigned int*)array, size, save);};
00168
00170
00171   void Squeeze()
00172     {this->ResizeAndExtend (this->MaxId+1);};
00174
00176   virtual void Resize(vtkIdType numTuples);
00177
00178 #ifndef VTK_REMOVE_LEGACY_CODE
00179
00180
00181   void DeepCopy(vtkDataArray &da)
00182     {VTK_LEGACY_METHOD(DeepCopy,"3.2"); this->DeepCopy(&da);}
00184 #endif
00185
00186
00187 protected:
00188   vtkUnsignedIntArray(vtkIdType numComp=1);
00189   ~vtkUnsignedIntArray();
00190
00191   unsigned int *Array;   // pointer to data
00192   unsigned int *ResizeAndExtend(const vtkIdType sz);
00193     // function to resize data
00194
00195   int TupleSize; //used for data conversion
00196   float *Tuple;
00197
00198   int SaveUserArray;
00199 private:
00200   vtkUnsignedIntArray(const vtkUnsignedIntArray&);  // Not implemented.
00201   void operator=(const vtkUnsignedIntArray&);  // Not implemented.
00202 };
00203
00204
00205 inline void vtkUnsignedIntArray::SetNumberOfValues(const vtkIdType number)
00206 {
00207   this->Allocate(number);
00208   this->MaxId = number - 1;
00209 }
00210
00211 inline unsigned int *vtkUnsignedIntArray::WritePointer(const vtkIdType id,
00212                                                        const vtkIdType number)
00213 {
00214   vtkIdType newSize=id+number;
00215   if ( newSize > this->Size )
00216     {
00217     this->ResizeAndExtend(newSize);
00218     }
00219   if ( (--newSize) > this->MaxId )
00220     {
00221     this->MaxId = newSize;
00222     }
00223   return this->Array + id;
00224 }
00225
00226 inline void vtkUnsignedIntArray::InsertValue(const vtkIdType id,
00227                                              const unsigned int i)
00228 {
00229   if ( id >= this->Size )
00230     {
00231     this->ResizeAndExtend(id+1);
00232     }
00233   this->Array[id] = i;
00234   if ( id > this->MaxId )
00235     {
00236     this->MaxId = id;
00237     }
00238 }
00239
00240 inline vtkIdType vtkUnsignedIntArray::InsertNextValue(const unsigned int i)
00241 {
00242   this->InsertValue (++this->MaxId,i);
00243   return this->MaxId;
00244 }
00245
00246
00247 #endif
00248
00249
00250
00251
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkUnsignedLongArray.h Source File

Common/vtkUnsignedLongArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnsignedLongArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkUnsignedLongArray_h
00042 #define __vtkUnsignedLongArray_h
00043
00044 #include "vtkDataArray.h"
00045
00046 class VTK_COMMON_EXPORT vtkUnsignedLongArray : public vtkDataArray
00047 {
00048 public:
00049   static vtkUnsignedLongArray *New();
00050
00051   vtkTypeRevisionMacro(vtkUnsignedLongArray,vtkDataArray);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00056   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00057
00059   void Initialize();
00060
00062   vtkDataArray *MakeObject();
00063
00065   int GetDataType() {return VTK_UNSIGNED_LONG;};
00066
00068   int GetDataTypeSize() { return sizeof(unsigned long); }
00069
00071   void SetNumberOfTuples(const vtkIdType number);
00072
00075   float *GetTuple(const vtkIdType i);
00076
00078
00079   void GetTuple(const vtkIdType i, float * tuple);
00080   void GetTuple(const vtkIdType i, double * tuple);
00082
00084
00085   void SetTuple(const vtkIdType i, const float * tuple);
00086   void SetTuple(const vtkIdType i, const double * tuple);
00088
00090
00092   void InsertTuple(const vtkIdType i, const float * tuple);
00093   void InsertTuple(const vtkIdType i, const double * tuple);
00095
00097
00099   vtkIdType InsertNextTuple(const float * tuple);
00100   vtkIdType InsertNextTuple(const double * tuple);
00102
00104   unsigned long GetValue(const vtkIdType id) {return this->Array[id];};
00105
00107
00109   void SetValue(const vtkIdType id, const unsigned long value) {
00110     this->Array[id] = value;};
00112
00116   void SetNumberOfValues(const vtkIdType number);
00117
00119   void InsertValue(const vtkIdType id, const unsigned long i);
00120
00123   vtkIdType InsertNextValue(const unsigned long);
00124
00128   float GetComponent(const vtkIdType i, const int j);
00129
00134   void SetComponent(const vtkIdType i, const int j, const float c);
00135
00139   virtual void InsertComponent(const vtkIdType i, const int j, const float c);
00140
00142
00144   unsigned long *GetPointer(const vtkIdType id) {return this->Array + id;}
00145   void *GetVoidPointer(const vtkIdType id)
00146     {return (void *)this->GetPointer(id);};
00148
00152   unsigned long *WritePointer(const vtkIdType id, const vtkIdType number);
00153
00155   void DeepCopy(vtkDataArray *da);
00156
00158
00164   void SetArray(unsigned long* array, vtkIdType size, int save);
00165   void SetVoidArray(void *array, vtkIdType size, int save)
00166     {this->SetArray((unsigned long*)array, size, save);};
00168
00170   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00171
00173   virtual void Resize(vtkIdType numTuples);
00174
00175 #ifndef VTK_REMOVE_LEGACY_CODE
00176
00177
00178   void DeepCopy(vtkDataArray &da)
00179     {VTK_LEGACY_METHOD(DeepCopy,"3.2"); this->DeepCopy(&da);}
00181 #endif
00182
00183
00184 protected:
00185   vtkUnsignedLongArray(vtkIdType numComp=1);
00186   ~vtkUnsignedLongArray();
00187
00188   unsigned long *Array;   // pointer to data
00189   unsigned long *ResizeAndExtend(const vtkIdType sz);
00190     // function to resize data
00191
00192   int TupleSize; //used for data conversion
00193   float *Tuple;
00194
00195   int SaveUserArray;
00196 private:
00197   vtkUnsignedLongArray(const vtkUnsignedLongArray&);  // Not implemented.
00198   void operator=(const vtkUnsignedLongArray&);  // Not implemented.
00199 };
00200
00201 inline void vtkUnsignedLongArray::SetNumberOfValues(const vtkIdType number)
00202 {
00203   this->Allocate(number);
00204   this->MaxId = number - 1;
00205 }
00206
00207 inline unsigned long *vtkUnsignedLongArray::WritePointer(const vtkIdType id,
00208                                                          const vtkIdType number)
00209 {
00210   vtkIdType newSize=id+number;
00211   if ( newSize > this->Size )
00212     {
00213     this->ResizeAndExtend(newSize);
00214     }
00215   if ( (--newSize) > this->MaxId )
00216     {
00217     this->MaxId = newSize;
00218     }
00219   return this->Array + id;
00220 }
00221
00222 inline void vtkUnsignedLongArray::InsertValue(const vtkIdType id,
00223                                               const unsigned long i)
00224 {
00225   if ( id >= this->Size )
00226     {
00227     this->ResizeAndExtend(id+1);
00228     }
00229   this->Array[id] = i;
00230   if ( id > this->MaxId )
00231     {
00232     this->MaxId = id;
00233     }
00234 }
00235
00236 inline vtkIdType vtkUnsignedLongArray::InsertNextValue(const unsigned long i)
00237 {
00238   this->InsertValue (++this->MaxId,i);
00239   return this->MaxId;
00240 }
00241
00242
00243 #endif
00244
00245
00246
00247
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkUnsignedShortArray.h Source File

Common/vtkUnsignedShortArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnsignedShortArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkUnsignedShortArray_h
00043 #define __vtkUnsignedShortArray_h
00044
00045 #include "vtkDataArray.h"
00046
00047 class VTK_COMMON_EXPORT vtkUnsignedShortArray : public vtkDataArray
00048 {
00049 public:
00050   static vtkUnsignedShortArray *New();
00051
00052   vtkTypeRevisionMacro(vtkUnsignedShortArray,vtkDataArray);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00058
00060   void Initialize();
00061
00063   vtkDataArray *MakeObject();
00064
00066   int GetDataType() {return VTK_UNSIGNED_SHORT;};
00067
00069   int GetDataTypeSize() { return sizeof(unsigned short); }
00070
00072   void SetNumberOfTuples(const vtkIdType number);
00073
00076   float *GetTuple(const vtkIdType i);
00077
00079
00080   void GetTuple(const vtkIdType i, float * tuple);
00081   void GetTuple(const vtkIdType i, double * tuple);
00083
00085
00086   void SetTuple(const vtkIdType i, const float * tuple);
00087   void SetTuple(const vtkIdType i, const double * tuple);
00089
00091
00093   void InsertTuple(const vtkIdType i, const float * tuple);
00094   void InsertTuple(const vtkIdType i, const double * tuple);
00096
00098
00100   vtkIdType InsertNextTuple(const float * tuple);
00101   vtkIdType InsertNextTuple(const double * tuple);
00103
00107   float GetComponent(const vtkIdType i, const int j);
00108
00113   void SetComponent(const vtkIdType i, const int j, const float c);
00114
00118   void InsertComponent(const vtkIdType i, const int j, const float c);
00119
00121   unsigned short GetValue(const vtkIdType id) {return this->Array[id];};
00122
00124
00126   void SetValue(const vtkIdType id, const unsigned short value) {
00127     this->Array[id] = value;};
00129
00133   void SetNumberOfValues(const vtkIdType number);
00134
00136   void InsertValue(const vtkIdType id, const unsigned short i);
00137
00140   vtkIdType InsertNextValue(const unsigned short);
00141
00143
00145   unsigned short *GetPointer(const vtkIdType id) {return this->Array + id;}
00146   void *GetVoidPointer(const vtkIdType id)
00147     {return (void *)this->GetPointer(id);};
00149
00153   unsigned short *WritePointer(const vtkIdType id, const vtkIdType number);
00154
00156   void DeepCopy(vtkDataArray *ia);
00157
00159
00165   void SetArray(unsigned short* array, vtkIdType size, int save);
00166   void SetVoidArray(void *array, vtkIdType size, int save)
00167     {this->SetArray((unsigned short*)array, size, save);};
00169
00171   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00172
00174   virtual void Resize(vtkIdType numTuples);
00175
00176 #ifndef VTK_REMOVE_LEGACY_CODE
00177
00178
00179   void DeepCopy(vtkDataArray &ia)
00180     {VTK_LEGACY_METHOD(DeepCopy,"3.2"); this->DeepCopy(&ia);}
00182 #endif
00183
00184
00185 protected:
00186   vtkUnsignedShortArray(vtkIdType numComp=1);
00187   ~vtkUnsignedShortArray();
00188
00189   unsigned short *Array;   // pointer to data
00190   unsigned short *ResizeAndExtend(const vtkIdType sz);
00191     // function to resize data
00192
00193   int TupleSize; //used for data conversion
00194   float *Tuple;
00195
00196   int SaveUserArray;
00197 private:
00198   vtkUnsignedShortArray(const vtkUnsignedShortArray&);  // Not implemented.
00199   void operator=(const vtkUnsignedShortArray&);  // Not implemented.
00200 };
00201
00202 inline void vtkUnsignedShortArray::SetNumberOfValues(const vtkIdType number)
00203 {
00204   this->Allocate(number);
00205   this->MaxId = number - 1;
00206 }
00207
00208 inline unsigned short *vtkUnsignedShortArray::WritePointer(const vtkIdType id,
00209                                                            const vtkIdType number)
00210 {
00211   vtkIdType newSize=id+number;
00212   if ( newSize > this->Size )
00213     {
00214     this->ResizeAndExtend(newSize);
00215     }
00216   if ( (--newSize) > this->MaxId )
00217     {
00218     this->MaxId = newSize;
00219     }
00220   return this->Array + id;
00221 }
00222
00223 inline void vtkUnsignedShortArray::InsertValue(const vtkIdType id,
00224                                                const unsigned short i)
00225 {
00226   if ( id >= this->Size )
00227     {
00228     this->ResizeAndExtend(id+1);
00229     }
00230   this->Array[id] = i;
00231   if ( id > this->MaxId )
00232     {
00233     this->MaxId = id;
00234     }
00235 }
00236
00237 inline vtkIdType vtkUnsignedShortArray::InsertNextValue(const unsigned short i)
00238 {
00239   this->InsertValue (++this->MaxId,i);
00240   return this->MaxId;
00241 }
00242
00243 #endif
00244
00245
00246
00247
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkUnstructuredGrid.h Source File

Common/vtkUnstructuredGrid.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGrid.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00045 #ifndef __vtkUnstructuredGrid_h
00046 #define __vtkUnstructuredGrid_h
00047
00048 #include "vtkPointSet.h"
00049 #include "vtkIdList.h"
00050 #include "vtkCellArray.h"
00051 #include "vtkCellLinks.h"
00052 #include "vtkIntArray.h"
00053 #include "vtkUnsignedCharArray.h"
00054 class vtkVertex;
00055 class vtkPolyVertex;
00056 class vtkLine;
00057 class vtkPolyLine;
00058 class vtkTriangle;
00059 class vtkTriangleStrip;
00060 class vtkPixel;
00061 class vtkQuad;
00062 class vtkPolygon;
00063 class vtkTetra;
00064 class vtkVoxel;
00065 class vtkHexahedron;
00066 class vtkWedge;
00067 class vtkPyramid;
00068 class vtkQuadraticEdge;
00069
00070 class VTK_COMMON_EXPORT vtkUnstructuredGrid : public vtkPointSet {
00071 private:
00072   vtkUnstructuredGrid(const vtkUnstructuredGrid&);  // Not implemented.
00073   void operator=(const vtkUnstructuredGrid&);  // Not implemented.
00074 public:
00075   static vtkUnstructuredGrid *New();
00076
00077   vtkTypeRevisionMacro(vtkUnstructuredGrid,vtkPointSet);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00081
00082   int GetDataObjectType() {return VTK_UNSTRUCTURED_GRID;};
00083   virtual void Allocate(vtkIdType numCells=1000, int extSize=1000);
00084   int InsertNextCell(int type, int npts, vtkIdType *pts);
00085   int InsertNextCell(int type, vtkIdList *ptIds);
00086   void Reset();
00087   void SetCells(int *types, vtkCellArray *cells);
00088   void SetCells(vtkUnsignedCharArray *cellTypes, vtkIntArray *cellLocations,
00089                 vtkCellArray *cells);
00090   vtkCellArray *GetCells() {return this->Connectivity;};
00091   vtkDataObject *MakeObject() {return vtkUnstructuredGrid::New();};
00092   virtual void CopyStructure(vtkDataSet *ds);
00093   vtkIdType GetNumberOfCells();
00094   virtual vtkCell *GetCell(vtkIdType cellId);
00095   virtual void GetCell(vtkIdType cellId, vtkGenericCell *cell);
00096   virtual void GetCellBounds(vtkIdType cellId, float bounds[6]);
00097   virtual void GetCellPoints(vtkIdType cellId, vtkIdList *ptIds);
00098   void GetPointCells(vtkIdType ptId, vtkIdList *cellIds);
00100
00101   int GetCellType(vtkIdType cellId);
00102   void Squeeze();
00103   void Initialize();
00104   int GetMaxCellSize();
00105   void BuildLinks();
00106   vtkCellLinks *GetCellLinks() {return this->Links;};
00107   virtual void GetCellPoints(vtkIdType cellId, vtkIdType& npts,
00108                              vtkIdType* &pts);
00109   void ReplaceCell(vtkIdType cellId, int npts, vtkIdType *pts);
00110   int InsertNextLinkedCell(int type, int npts, vtkIdType *pts);
00111   void RemoveReferenceToCell(vtkIdType ptId, vtkIdType cellId);
00112   void AddReferenceToCell(vtkIdType ptId, vtkIdType cellId);
00113   void ResizeCellList(vtkIdType ptId, int size);
00114
00116
00119   virtual void GetCellNeighbors(vtkIdType cellId, vtkIdList *ptIds,
00120                                 vtkIdList *cellIds);
00122
00124
00127   void SetUpdateExtent(int piece, int numPieces, int ghostLevel);
00128   void SetUpdateExtent(int piece, int numPieces)
00129     {this->SetUpdateExtent(piece, numPieces, 0);}
00130   void GetUpdateExtent(int &piece, int &numPieces, int &ghostLevel);
00132
00134
00135   vtkGetVector6Macro( UpdateExtent, int );
00137
00139
00143   void SetUpdateExtent( int x1, int x2, int y1, int y2, int z1, int z2 )
00144     { this->vtkPointSet::SetUpdateExtent( x1, x2, y1, y2, z1, z2 ); };
00145   void SetUpdateExtent( int ext[6] )
00146     { this->vtkPointSet::SetUpdateExtent( ext ); };
00148
00149
00151
00153   vtkGetMacro( Piece, int );
00154   vtkGetMacro( NumberOfPieces, int );
00156
00158
00159   vtkGetMacro( GhostLevel, int );
00161
00167   unsigned long GetActualMemorySize();
00168
00170
00171   virtual void ShallowCopy(vtkDataObject *src);
00172   virtual void DeepCopy(vtkDataObject *src);
00174
00178   void GetListOfUniqueCellTypes(vtkUnsignedCharArray *uniqueTypes);
00179
00183   void GetIdsOfCellsOfType(int type, vtkIntArray *array);
00184
00186   int IsHomogeneous();
00187
00190   void RemoveGhostCells(int level);
00191
00192 protected:
00193   vtkUnstructuredGrid();
00194   ~vtkUnstructuredGrid();
00195
00196   // used by GetCell method
00197   vtkVertex *Vertex;
00198   vtkPolyVertex *PolyVertex;
00199   vtkLine *Line;
00200   vtkPolyLine *PolyLine;
00201   vtkTriangle *Triangle;
00202   vtkTriangleStrip *TriangleStrip;
00203   vtkPixel *Pixel;
00204   vtkQuad *Quad;
00205   vtkPolygon *Polygon;
00206   vtkTetra *Tetra;
00207   vtkVoxel *Voxel;
00208   vtkHexahedron *Hexahedron;
00209   vtkWedge *Wedge;
00210   vtkPyramid *Pyramid;
00211   vtkQuadraticEdge *QuadraticEdge;
00212
00213   // points inherited
00214   // point data (i.e., scalars, vectors, normals, tcoords) inherited
00215   vtkCellArray *Connectivity;
00216   vtkCellLinks *Links;
00217   vtkUnsignedCharArray *Types;
00218   vtkIntArray *Locations;
00219
00220  private:
00221   // Hide these from the user and the compiler.
00222
00224
00225   void GetCellNeighbors(vtkIdType cellId, vtkIdList& ptIds, vtkIdList& cellIds)
00226     {this->GetCellNeighbors(cellId, &ptIds, &cellIds);}
00228 };
00229
00230 #endif
00231
00232
00233
00234
00235
00236
00237
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkUnstructuredGridReader.h Source File

IO/vtkUnstructuredGridReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGridReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkUnstructuredGridReader_h
00049 #define __vtkUnstructuredGridReader_h
00050
00051 #include "vtkDataReader.h"
00052 #include "vtkUnstructuredGrid.h"
00053
00054 class VTK_IO_EXPORT vtkUnstructuredGridReader : public vtkDataReader
00055 {
00056 public:
00057   static vtkUnstructuredGridReader *New();
00058   vtkTypeRevisionMacro(vtkUnstructuredGridReader,vtkDataReader);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   vtkUnstructuredGrid *GetOutput();
00064   vtkUnstructuredGrid *GetOutput(int idx)
00065     {return (vtkUnstructuredGrid *) this->vtkSource::GetOutput(idx); };
00066   void SetOutput(vtkUnstructuredGrid *output);
00068
00069 protected:
00070   vtkUnstructuredGridReader();
00071   ~vtkUnstructuredGridReader();
00072
00073   void Execute();
00074
00075   // Since the Outputs[0] has the same UpdateExtent format
00076   // as the generic DataObject we can copy the UpdateExtent
00077   // as a default behavior.
00078   void ComputeInputUpdateExtents(vtkDataObject *output);
00079
00080 private:
00081   vtkUnstructuredGridReader(const vtkUnstructuredGridReader&);  // Not implemented.
00082   void operator=(const vtkUnstructuredGridReader&);  // Not implemented.
00083 };
00084
00085 #endif
00086
00087
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkUnstructuredGridSource.h Source File

Filtering/vtkUnstructuredGridSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGridSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkUnstructuredGridSource_h
00037 #define __vtkUnstructuredGridSource_h
00038
00039 #include "vtkSource.h"
00040 #include "vtkUnstructuredGrid.h"
00041
00042 class VTK_FILTERING_EXPORT vtkUnstructuredGridSource : public vtkSource
00043 {
00044 public:
00045   static vtkUnstructuredGridSource *New();
00046   vtkTypeRevisionMacro(vtkUnstructuredGridSource,vtkSource);
00047
00049
00050   vtkUnstructuredGrid *GetOutput();
00051   vtkUnstructuredGrid *GetOutput(int idx)
00052     {return (vtkUnstructuredGrid *) this->vtkSource::GetOutput(idx); };
00053   void SetOutput(vtkUnstructuredGrid *output);
00055
00056 protected:
00057   vtkUnstructuredGridSource();
00058   ~vtkUnstructuredGridSource() {};
00059
00060   // Since the Outputs[0] has the same UpdateExtent format
00061   // as the generic DataObject we can copy the UpdateExtent
00062   // as a default behavior.
00063   void ComputeInputUpdateExtents(vtkDataObject *output);
00064
00065 private:
00066   vtkUnstructuredGridSource(const vtkUnstructuredGridSource&);  // Not implemented.
00067   void operator=(const vtkUnstructuredGridSource&);  // Not implemented.
00068 };
00069
00070 #endif
00071
00072
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkUnstructuredGridToPolyDataFilter.h Source File

Filtering/vtkUnstructuredGridToPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGridToPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkUnstructuredGridToPolyDataFilter_h
00038 #define __vtkUnstructuredGridToPolyDataFilter_h
00039
00040 #include "vtkPolyDataSource.h"
00041 #include "vtkUnstructuredGrid.h"
00042
00043 class VTK_FILTERING_EXPORT vtkUnstructuredGridToPolyDataFilter : public vtkPolyDataSource
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkUnstructuredGridToPolyDataFilter,vtkPolyDataSource);
00047
00049
00050   virtual void SetInput(vtkUnstructuredGrid *input);
00051   vtkUnstructuredGrid *GetInput();
00053
00055   virtual void ComputeInputUpdateExtents( vtkDataObject *output );
00056
00057 protected:
00058   vtkUnstructuredGridToPolyDataFilter() {this->NumberOfRequiredInputs = 1;}
00059   ~vtkUnstructuredGridToPolyDataFilter() {}
00060
00061
00062 private:
00063   vtkUnstructuredGridToPolyDataFilter(const vtkUnstructuredGridToPolyDataFilter&) {}  // Not implemented.
00064   void operator=(const vtkUnstructuredGridToPolyDataFilter&);  // Not implemented.
00065 };
00066
00067 #endif
00068
00069
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Filtering/vtkUnstructuredGridToUnstructuredGridFilter.h Source File

Filtering/vtkUnstructuredGridToUnstructuredGridFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGridToUnstructuredGridFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkUnstructuredGridToUnstructuredGridFilter_h
00035 #define __vtkUnstructuredGridToUnstructuredGridFilter_h
00036
00037 #include "vtkUnstructuredGridSource.h"
00038
00039 class VTK_FILTERING_EXPORT vtkUnstructuredGridToUnstructuredGridFilter : public vtkUnstructuredGridSource
00040 {
00041 public:
00042   vtkTypeRevisionMacro(vtkUnstructuredGridToUnstructuredGridFilter,vtkUnstructuredGridSource);
00043
00045
00046   void SetInput(vtkUnstructuredGrid *input);
00047   vtkUnstructuredGrid *GetInput();
00049
00050 protected:
00051   vtkUnstructuredGridToUnstructuredGridFilter() {this->NumberOfRequiredInputs = 1;};
00052   ~vtkUnstructuredGridToUnstructuredGridFilter() {};
00053 private:
00054   vtkUnstructuredGridToUnstructuredGridFilter(const vtkUnstructuredGridToUnstructuredGridFilter&);  // Not implemented.
00055   void operator=(const vtkUnstructuredGridToUnstructuredGridFilter&);  // Not implemented.
00056 };
00057
00058 #endif
00059
00060
Generated on Mon Mar 25 01:07:40 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkUnstructuredGridWriter.h Source File

IO/vtkUnstructuredGridWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkUnstructuredGridWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkUnstructuredGridWriter_h
00037 #define __vtkUnstructuredGridWriter_h
00038
00039 #include "vtkDataWriter.h"
00040 #include "vtkUnstructuredGrid.h"
00041
00042 class VTK_IO_EXPORT vtkUnstructuredGridWriter : public vtkDataWriter
00043 {
00044 public:
00045   static vtkUnstructuredGridWriter *New();
00046   vtkTypeRevisionMacro(vtkUnstructuredGridWriter,vtkDataWriter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   void SetInput(vtkUnstructuredGrid *input);
00052   vtkUnstructuredGrid *GetInput();
00054
00055 protected:
00056   vtkUnstructuredGridWriter() {};
00057   ~vtkUnstructuredGridWriter() {};
00058
00059   void WriteData();
00060
00061 private:
00062   vtkUnstructuredGridWriter(const vtkUnstructuredGridWriter&);  // Not implemented.
00063   void operator=(const vtkUnstructuredGridWriter&);  // Not implemented.
00064 };
00065
00066 #endif
00067
00068
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkVectorDot.h Source File

Graphics/vtkVectorDot.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVectorDot.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkVectorDot_h
00042 #define __vtkVectorDot_h
00043
00044 #include "vtkDataSetToDataSetFilter.h"
00045
00046 class VTK_GRAPHICS_EXPORT vtkVectorDot : public vtkDataSetToDataSetFilter
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkVectorDot,vtkDataSetToDataSetFilter);
00050   void PrintSelf(ostream& os, vtkIndent indent);
00051
00053   static vtkVectorDot *New();
00054
00056
00057   vtkSetVector2Macro(ScalarRange,float);
00059
00061
00062   vtkGetVectorMacro(ScalarRange,float,2);
00064
00065 protected:
00066   vtkVectorDot();
00067   ~vtkVectorDot() {};
00068
00069   void Execute();
00070   float ScalarRange[2];
00071 private:
00072   vtkVectorDot(const vtkVectorDot&);  // Not implemented.
00073   void operator=(const vtkVectorDot&);  // Not implemented.
00074 };
00075
00076 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkVectorNorm.h Source File

Graphics/vtkVectorNorm.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVectorNorm.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkVectorNorm_h
00045 #define __vtkVectorNorm_h
00046
00047 #define VTK_ATTRIBUTE_MODE_DEFAULT 0
00048 #define VTK_ATTRIBUTE_MODE_USE_POINT_DATA 1
00049 #define VTK_ATTRIBUTE_MODE_USE_CELL_DATA 2
00050
00051 #include "vtkDataSetToDataSetFilter.h"
00052
00053 class VTK_GRAPHICS_EXPORT vtkVectorNorm : public vtkDataSetToDataSetFilter
00054 {
00055 public:
00056   vtkTypeRevisionMacro(vtkVectorNorm,vtkDataSetToDataSetFilter);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00060   static vtkVectorNorm *New();
00061
00063
00064   vtkSetMacro(Normalize,int);
00065   vtkGetMacro(Normalize,int);
00066   vtkBooleanMacro(Normalize,int);
00068
00070
00076   vtkSetMacro(AttributeMode,int);
00077   vtkGetMacro(AttributeMode,int);
00078   void SetAttributeModeToDefault()
00079     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_DEFAULT);};
00080   void SetAttributeModeToUsePointData()
00081     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_POINT_DATA);};
00082   void SetAttributeModeToUseCellData()
00083     {this->SetAttributeMode(VTK_ATTRIBUTE_MODE_USE_CELL_DATA);};
00084   const char *GetAttributeModeAsString();
00086
00087 protected:
00088   vtkVectorNorm();
00089   ~vtkVectorNorm() {};
00090
00091   void Execute();
00092
00093   int Normalize;  // normalize 0<=n<=1 if true.
00094   int AttributeMode; //control whether to use point or cell data, or both
00095 private:
00096   vtkVectorNorm(const vtkVectorNorm&);  // Not implemented.
00097   void operator=(const vtkVectorNorm&);  // Not implemented.
00098 };
00099
00100 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkVectorText.h Source File

Hybrid/vtkVectorText.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVectorText.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00050 #ifndef __vtkVectorText_h
00051 #define __vtkVectorText_h
00052
00053 #include "vtkPolyDataSource.h"
00054
00055 class VTK_HYBRID_EXPORT vtkVectorText : public vtkPolyDataSource
00056 {
00057 public:
00058   static vtkVectorText *New();
00059   vtkTypeRevisionMacro(vtkVectorText,vtkPolyDataSource);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   vtkSetStringMacro(Text);
00065   vtkGetStringMacro(Text);
00067
00068 protected:
00069   vtkVectorText();
00070   ~vtkVectorText();
00071
00072   void Execute();
00073   char *Text;
00074   char *Letters[127];
00075
00076 private:
00077   vtkVectorText(const vtkVectorText&);  // Not implemented.
00078   void operator=(const vtkVectorText&);  // Not implemented.
00079 };
00080
00081 #endif
00082
00083
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkVersion.h Source File

Common/vtkVersion.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVersion.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00030 #ifndef __vtkVersion_h
00031 #define __vtkVersion_h
00032
00033
00034 #include "vtkObject.h"
00035
00036 #define VTK_MAJOR_VERSION 4
00037 #define VTK_MINOR_VERSION 1
00038 #define VTK_BUILD_VERSION 1
00039 #define VTK_VERSION "4.1.1"
00040 #define VTK_SOURCE_VERSION "vtk version " VTK_VERSION ", vtk source $Revision: 1.1187 $, $Date: 2002/03/25 03:45:02 $ (GMT)"
00041
00042
00043 class VTK_COMMON_EXPORT vtkVersion : public vtkObject
00044 {
00045 public:
00046   static vtkVersion *New();
00047   vtkTypeRevisionMacro(vtkVersion,vtkObject);
00048
00050
00053   static const char *GetVTKVersion() { return VTK_VERSION; }
00054   static int GetVTKMajorVersion() { return VTK_MAJOR_VERSION; }
00055   static int GetVTKMinorVersion() { return VTK_MINOR_VERSION; }
00056   static int GetVTKBuildVersion() { return VTK_BUILD_VERSION; }
00057   static const char *GetVTKSourceVersion() { return VTK_SOURCE_VERSION; }
00059
00060 protected:
00061   vtkVersion() {}; //insure constructor/destructor protected
00062   ~vtkVersion() {};
00063 private:
00064   vtkVersion(const vtkVersion&);  // Not implemented.
00065   void operator=(const vtkVersion&);  // Not implemented.
00066 };
00067
00068 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkVertex.h Source File

Common/vtkVertex.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVertex.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkVertex_h
00041 #define __vtkVertex_h
00042
00043 #include "vtkCell.h"
00044
00045 class VTK_COMMON_EXPORT vtkVertex : public vtkCell
00046 {
00047 public:
00048   static vtkVertex *New();
00049   vtkTypeRevisionMacro(vtkVertex,vtkCell);
00050
00052   vtkCell *MakeObject();
00053
00055
00056   int GetCellType() {return VTK_VERTEX;};
00057   int GetCellDimension() {return 0;};
00058   int GetNumberOfEdges() {return 0;};
00059   int GetNumberOfFaces() {return 0;};
00060   vtkCell *GetEdge(int) {return 0;};
00061   vtkCell *GetFace(int) {return 0;};
00062   void Clip(float value, vtkDataArray *cellScalars,
00063             vtkPointLocator *locator, vtkCellArray *pts,
00064             vtkPointData *inPd, vtkPointData *outPd,
00065             vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd,
00066             int insideOut);
00067   int EvaluatePosition(float x[3], float* closestPoint,
00068                        int& subId, float pcoords[3],
00069                        float& dist2, float *weights);
00070   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00071                         float *weights);
00073
00079   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00080
00082
00086   void Contour(float value, vtkDataArray *cellScalars,
00087                vtkPointLocator *locator, vtkCellArray *verts1,
00088                vtkCellArray *lines, vtkCellArray *verts2,
00089                vtkPointData *inPd, vtkPointData *outPd,
00090                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00092
00094
00097   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00098                         float x[3], float pcoords[3], int& subId);
00100
00103   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00104
00106
00108   void Derivatives(int subId, float pcoords[3], float *values,
00109                    int dim, float *derivs);
00111
00113   static void InterpolationFunctions(float pcoords[3], float weights[1]);
00114
00115 protected:
00116   vtkVertex();
00117   ~vtkVertex() {};
00118
00119 private:
00120   vtkVertex(const vtkVertex&);  // Not implemented.
00121   void operator=(const vtkVertex&);  // Not implemented.
00122 };
00123
00124 #endif
00125
00126
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkVideoSource.h Source File

Hybrid/vtkVideoSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVideoSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkVideoSource_h
00040 #define __vtkVideoSource_h
00041
00042 #include "vtkTimerLog.h"
00043 #include "vtkCriticalSection.h"
00044 #include "vtkMultiThreader.h"
00045 #include "vtkImageSource.h"
00046 #include "vtkScalarsToColors.h"
00047
00048 class VTK_HYBRID_EXPORT vtkVideoSource : public vtkImageSource
00049 {
00050 public:
00051   static vtkVideoSource *New();
00052   vtkTypeRevisionMacro(vtkVideoSource,vtkImageSource);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00057   virtual void Record();
00058
00061   virtual void Play();
00062
00064   virtual void Stop();
00065
00070   virtual void Rewind();
00071
00074   virtual void FastForward();
00075
00078   virtual void Seek(int n);
00079
00081   virtual void Grab();
00082
00084
00086   vtkGetMacro(Recording,int);
00088
00090
00092   vtkGetMacro(Playing,int);
00094
00096
00101   virtual void SetFrameSize(int x, int y, int z);
00102   virtual void SetFrameSize(int dim[3]) {
00103     this->SetFrameSize(dim[0], dim[1], dim[2]); };
00104   vtkGetVector3Macro(FrameSize,int);
00106
00108
00109   virtual void SetFrameRate(float rate);
00110   vtkGetMacro(FrameRate,float);
00112
00114
00116   virtual void SetOutputFormat(int format);
00117   void SetOutputFormatToLuminance() { this->SetOutputFormat(VTK_LUMINANCE); };
00118   void SetOutputFormatToRGB() { this->SetOutputFormat(VTK_RGB); };
00119   void SetOutputFormatToRGBA() { this->SetOutputFormat(VTK_RGBA); };
00120   vtkGetMacro(OutputFormat,int);
00122
00124
00126   virtual void SetFrameBufferSize(int FrameBufferSize);
00127   vtkGetMacro(FrameBufferSize,int);
00129
00131
00134   vtkSetMacro(NumberOfOutputFrames,int);
00135   vtkGetMacro(NumberOfOutputFrames,int);
00137
00139
00141   vtkBooleanMacro(AutoAdvance,int);
00142   vtkSetMacro(AutoAdvance,int)
00143   vtkGetMacro(AutoAdvance,int);
00145
00147
00151   virtual void SetClipRegion(int r[6]) {
00152     this->SetClipRegion(r[0],r[1],r[2],r[3],r[4],r[5]); };
00153   virtual void SetClipRegion(int x0, int x1, int y0, int y1, int z0, int z1);
00154   vtkGetVector6Macro(ClipRegion,int);
00156
00158
00165   vtkSetVector6Macro(OutputWholeExtent,int);
00166   vtkGetVector6Macro(OutputWholeExtent,int);
00168
00170
00171   vtkSetVector3Macro(DataSpacing,float);
00172   vtkGetVector3Macro(DataSpacing,float);
00174
00176
00178   vtkSetVector3Macro(DataOrigin,float);
00179   vtkGetVector3Macro(DataOrigin,float);
00181
00183
00186   vtkSetMacro(Opacity,float);
00187   vtkGetMacro(Opacity,float);
00189
00191
00193   vtkGetMacro(FrameCount, int);
00194   vtkSetMacro(FrameCount, int);
00196
00198
00200   vtkGetMacro(FrameIndex, int);
00202
00204
00208   virtual double GetFrameTimeStamp(int frame);
00209   virtual double GetFrameTimeStamp() { return this->GetFrameTimeStamp(0); };
00211
00213
00215   virtual void Initialize();
00216   virtual int GetInitialized() { return this->Initialized; };
00218
00221   virtual void ReleaseSystemResources();
00222
00226   virtual void InternalGrab();
00227
00229
00231   void SetStartTimeStamp(double t) { this->StartTimeStamp = t; };
00232   double GetStartTimeStamp() { return this->StartTimeStamp; };
00234
00235 protected:
00236   vtkVideoSource();
00237   ~vtkVideoSource();
00238   void ExecuteInformation();
00239
00240   int Initialized;
00241
00242   int FrameSize[3];
00243   int ClipRegion[6];
00244   int OutputWholeExtent[6];
00245   float DataSpacing[3];
00246   float DataOrigin[3];
00247   int OutputFormat;
00248   // set according to the OutputFormat
00249   int NumberOfScalarComponents;
00250   // The FrameOutputExtent is the WholeExtent for a single output frame.
00251   // It is initialized in ExecuteInformation.
00252   int FrameOutputExtent[6];
00253
00254   // save this information from the output so that we can see if the
00255   // output scalars have changed
00256   int LastNumberOfScalarComponents;
00257   int LastOutputExtent[6];
00258
00259   int Recording;
00260   int Playing;
00261   float FrameRate;
00262   int FrameCount;
00263   int FrameIndex;
00264   double StartTimeStamp;
00265
00266   int AutoAdvance;
00267   int NumberOfOutputFrames;
00268
00269   float Opacity;
00270
00271   // true if Execute() must apply a vertical flip to each frame
00272   int FlipFrames;
00273
00274   // set if output needs to be cleared to be cleared before being written
00275   int OutputNeedsInitialization;
00276
00277   // An example of asynchrony
00278   vtkMultiThreader *PlayerThreader;
00279   int PlayerThreadId;
00280
00281   // A mutex for the frame buffer: must be applied when any of the
00282   // below data is modified.
00283   vtkCriticalSection *FrameBufferMutex;
00284
00285   // set according to the needs of the hardware:
00286   // number of bits per framebuffer pixel
00287   int FrameBufferBitsPerPixel;
00288   // byte alignment of each row in the framebuffer
00289   int FrameBufferRowAlignment;
00290   // FrameBufferExtent is the extent of frame after it has been clipped
00291   // with ClipRegion.  It is initialized in CheckBuffer().
00292   int FrameBufferExtent[6];
00293
00294   int FrameBufferSize;
00295   int FrameBufferIndex;
00296   void **FrameBuffer;
00297   double *FrameBufferTimeStamps;
00298
00300
00301   virtual void UpdateFrameBuffer();
00302   virtual void AdvanceFrameBuffer(int n);
00303   virtual void ExecuteData(vtkDataObject *data);
00304   // if some component conversion is required, it is done here:
00305   virtual void UnpackRasterLine(char *outPtr, char *rowPtr,
00306                                 int start, int count);
00308
00309 private:
00310   vtkVideoSource(const vtkVideoSource&);  // Not implemented.
00311   void operator=(const vtkVideoSource&);  // Not implemented.
00312 };
00313
00314 #endif
00315
00316
00317
00318
00319
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkViewport.h Source File

Common/vtkViewport.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkViewport.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkViewport_h
00047 #define __vtkViewport_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkPropCollection.h"
00051 #include "vtkActor2DCollection.h"
00052
00053 class vtkWindow;
00054 class vtkAssemblyPath;
00055
00056 class VTK_COMMON_EXPORT vtkViewport : public vtkObject
00057 {
00058 public:
00059   vtkTypeRevisionMacro(vtkViewport,vtkObject);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00064   void AddProp(vtkProp *);
00065
00067   vtkPropCollection *GetProps() {return this->Props;};
00068
00070   void RemoveProp(vtkProp *);
00071
00073   void RemoveAllProps(void);
00074
00076
00079   void AddActor2D(vtkProp* p) {this->AddProp(p);};
00080   void RemoveActor2D(vtkProp* p);
00081   vtkActor2DCollection *GetActors2D();
00083
00085
00087   vtkSetVector3Macro(Background,float);
00088   vtkGetVectorMacro(Background,float,3);
00090
00092
00094   vtkSetVector2Macro(Aspect,float);
00095   vtkGetVectorMacro(Aspect,float,2);
00096   void ComputeAspect();
00098
00100
00103   vtkSetVector2Macro(PixelAspect,float);
00104   vtkGetVectorMacro(PixelAspect,float,2);
00106
00108
00111   vtkSetVector4Macro(Viewport,float);
00112   vtkGetVectorMacro(Viewport,float,4);
00114
00116
00119   vtkSetVector3Macro(DisplayPoint,float);
00120   vtkGetVectorMacro(DisplayPoint,float,3);
00121   void GetDisplayPoint(double *a)
00122     {
00123       a[0] = this->DisplayPoint[0];
00124       a[1] = this->DisplayPoint[1];
00125       a[2] = this->DisplayPoint[2];
00126       a[3] = 1.0;
00127     };
00129
00131
00134   vtkSetVector3Macro(ViewPoint,float);
00135   vtkGetVectorMacro(ViewPoint,float,3);
00137
00139
00141   vtkSetVector4Macro(WorldPoint,float);
00142   vtkGetVectorMacro(WorldPoint,float,4);
00143   void GetWorldPoint(double *a)
00144     {
00145       a[0] = this->WorldPoint[0];
00146       a[1] = this->WorldPoint[1];
00147       a[2] = this->WorldPoint[2];
00148       a[3] = this->WorldPoint[3];
00149     };
00151
00153   virtual float *GetCenter();
00154
00156   virtual int IsInViewport(int x,int y);
00157
00159   virtual vtkWindow *GetVTKWindow() = 0;
00160
00163   void SetStartRenderMethod(void (*f)(void *), void *arg);
00164
00167   void SetEndRenderMethod(void (*f)(void *), void *arg);
00168
00170   void SetStartRenderMethodArgDelete(void (*f)(void *));
00171
00173   void SetEndRenderMethodArgDelete(void (*f)(void *));
00174
00176   virtual void DisplayToView(); // these get modified in subclasses
00177
00179   virtual void ViewToDisplay(); // to handle stereo rendering
00180
00182   virtual void WorldToView();
00183
00185   virtual void ViewToWorld();
00186
00188   void DisplayToWorld() {this->DisplayToView(); this->ViewToWorld();};
00189
00191   void WorldToDisplay() {this->WorldToView(); this->ViewToDisplay();};
00192
00194
00199   virtual void LocalDisplayToDisplay(float &x, float &y);
00200   virtual void DisplayToNormalizedDisplay(float &u, float &v);
00201   virtual void NormalizedDisplayToViewport(float &x, float &y);
00202   virtual void ViewportToNormalizedViewport(float &u, float &v);
00203   virtual void NormalizedViewportToView(float &x, float &y, float &z);
00204   virtual void ViewToWorld(float &, float &, float &) {};
00205   virtual void DisplayToLocalDisplay(float &x, float &y);
00206   virtual void NormalizedDisplayToDisplay(float &u, float &v);
00207   virtual void ViewportToNormalizedDisplay(float &x, float &y);
00208   virtual void NormalizedViewportToViewport(float &u, float &v);
00209   virtual void ViewToNormalizedViewport(float &x, float &y, float &z);
00210   virtual void WorldToView(float &, float &, float &) {};
00212
00214
00217   int *GetSize();
00218   int *GetOrigin();
00219   void GetTiledSize(int *width, int *height);
00221
00222   // The following methods describe the public pick interface for picking
00223   // Props in a viewport.
00224
00230   virtual vtkAssemblyPath* PickProp(float selectionX, float selectionY) = 0;
00231
00233
00236   vtkAssemblyPath* PickPropFrom(float selectionX, float selectionY,
00237                                 vtkPropCollection*);
00239
00241
00243   vtkGetMacro(PickX, float);
00244   vtkGetMacro(PickY, float);
00245   vtkGetMacro(IsPicking, int);
00247
00249   virtual float GetPickedZ() = 0;
00250
00251 protected:
00252   // Create a vtkViewport with a black background, a white ambient light,
00253   // two-sided lighting turned on, a viewport of (0,0,1,1), and back face
00254   // culling turned off.
00255   vtkViewport();
00256   ~vtkViewport();
00257
00258   //BTX
00259   // Picking functions to be implemented by sub-classes
00260   // Perform the main picking loop
00261   virtual void DevicePickRender() = 0;
00262   // Enter a pick mode
00263   virtual void StartPick(unsigned int pickFromSize) = 0;
00264   // Set the pick id to the next id before drawing an object
00265   virtual void UpdatePickId() = 0;
00266   // Exit Pick mode
00267   virtual void DonePick() = 0;
00268   // Return the id of the picked object, only valid after a call to DonePick
00269   virtual unsigned int GetPickedId() = 0;
00270   //ETX
00271
00272   // Ivars for picking
00273   // Store a picked Prop (contained in an assembly path)
00274   vtkAssemblyPath* PickedProp;
00275   vtkPropCollection* PickFromProps;
00276   // Boolean flag to determine if picking is enabled for this render
00277   int IsPicking;
00278   unsigned int CurrentPickId;
00279   float PickX;
00280   float PickY;
00281   // End Ivars for picking
00282
00283   vtkPropCollection *Props;
00284   vtkActor2DCollection *Actors2D;
00285   vtkWindow *VTKWindow;
00286   float Background[3];
00287   float Viewport[4];
00288   float Aspect[2];
00289   float PixelAspect[2];
00290   float Center[2];
00291
00292   unsigned long StartTag;
00293   unsigned long EndTag;
00294
00295   int Size[2];
00296   int Origin[2];
00297   float DisplayPoint[3];
00298   float ViewPoint[3];
00299   float WorldPoint[4];
00300
00301 private:
00302   vtkViewport(const vtkViewport&);  // Not implemented.
00303   void operator=(const vtkViewport&);  // Not implemented.
00304 };
00305
00306
00307
00308 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkVoidArray.h Source File

Common/vtkVoidArray.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVoidArray.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkVoidArray_h
00039 #define __vtkVoidArray_h
00040
00041 #include "vtkDataArray.h"
00042
00043 class VTK_COMMON_EXPORT vtkVoidArray : public vtkDataArray
00044 {
00045 public:
00046   static vtkVoidArray *New();
00047
00048   vtkTypeRevisionMacro(vtkVoidArray,vtkDataArray);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00053   int Allocate(const vtkIdType sz, const vtkIdType ext=1000);
00054
00056   void Initialize();
00057
00059   vtkDataArray *MakeObject() {return vtkVoidArray::New();};
00060
00062   int GetDataType() {return VTK_VOID;};
00063
00065   int GetDataTypeSize() { return sizeof(void*); }
00066
00068   void SetNumberOfTuples(const vtkIdType number);
00069
00071   float *GetTuple(const vtkIdType i);
00072
00074
00075   void GetTuple(const vtkIdType i, float * tuple);
00076   void GetTuple(const vtkIdType i, double * tuple);
00078
00080
00081   void SetTuple(const vtkIdType i, const float * tuple);
00082   void SetTuple(const vtkIdType i, const double * tuple);
00084
00086
00088   void InsertTuple(const vtkIdType i, const float * tuple);
00089   void InsertTuple(const vtkIdType i, const double * tuple);
00091
00093
00095   vtkIdType InsertNextTuple(const float * tuple);
00096   vtkIdType InsertNextTuple(const double * tuple);
00098
00100   void Squeeze() {this->ResizeAndExtend (this->MaxId+1);};
00101
00103   virtual void Resize(vtkIdType numTuples);
00104
00106   void* GetValue(const vtkIdType id) {return this->Array[id];};
00107
00111   void SetNumberOfValues(const vtkIdType number);
00112
00115   void SetValue(const vtkIdType id, void *value);
00116
00118   void InsertValue(const vtkIdType id, void* p);
00119
00122   vtkIdType InsertNextValue(void* v);
00123
00125
00127   void** GetPointer(const vtkIdType id) {return this->Array + id;}
00128   void *GetVoidPointer(const vtkIdType id) {return this->GetPointer(id);};
00130
00134   void** WritePointer(const vtkIdType id, const vtkIdType number);
00135
00137   void DeepCopy(vtkDataArray *da);
00138
00139
00140 protected:
00141   vtkVoidArray();
00142   ~vtkVoidArray();
00143
00144   void** Array;  // pointer to data
00145   void** ResizeAndExtend(const vtkIdType sz);  // function to resize data
00146
00147   int TupleSize; //used for data conversion
00148   float *Tuple;
00149 private:
00150   vtkVoidArray(const vtkVoidArray&);  // Not implemented.
00151   void operator=(const vtkVoidArray&);  // Not implemented.
00152 };
00153
00154
00155 inline void vtkVoidArray::SetNumberOfValues(const vtkIdType number)
00156 {
00157   this->Allocate(number);
00158   this->MaxId = number - 1;
00159 }
00160
00161 inline void vtkVoidArray::SetValue(const vtkIdType id, void *value)
00162 {
00163   this->Array[id] = value;
00164 }
00165
00166 inline void** vtkVoidArray::WritePointer(const vtkIdType id,
00167                                          const vtkIdType number)
00168 {
00169   vtkIdType newSize=id+number;
00170   if ( newSize > this->Size )
00171     {
00172     this->ResizeAndExtend(newSize);
00173     }
00174   if ( (--newSize) > this->MaxId )
00175     {
00176     this->MaxId = newSize;
00177     }
00178   return this->Array + id;
00179 }
00180
00181 inline void vtkVoidArray::InsertValue(const vtkIdType id, void* p)
00182 {
00183   if ( id >= this->Size )
00184     {
00185     this->ResizeAndExtend(id+1);
00186     }
00187   this->Array[id] = p;
00188   if ( id > this->MaxId )
00189     {
00190     this->MaxId = id;
00191     }
00192 }
00193
00194 inline vtkIdType vtkVoidArray::InsertNextValue(void* p)
00195 {
00196   this->InsertValue (++this->MaxId,p);
00197   return this->MaxId;
00198 }
00199
00200
00201 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkVolume16Reader.h Source File

IO/vtkVolume16Reader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolume16Reader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkVolume16Reader_h
00063 #define __vtkVolume16Reader_h
00064
00065 #include <stdio.h>
00066 #include "vtkVolumeReader.h"
00067 #include "vtkTransform.h"
00068 class vtkUnsignedCharArray;
00069 class vtkUnsignedShortArray;
00070
00071 #define VTK_FILE_BYTE_ORDER_BIG_ENDIAN 0
00072 #define VTK_FILE_BYTE_ORDER_LITTLE_ENDIAN 1
00073
00074 class VTK_IO_EXPORT vtkVolume16Reader : public vtkVolumeReader
00075 {
00076 public:
00077   vtkTypeRevisionMacro(vtkVolume16Reader,vtkVolumeReader);
00078   void PrintSelf(ostream& os, vtkIndent indent);
00079
00083   static vtkVolume16Reader *New();
00084
00086
00087   vtkSetVector2Macro(DataDimensions,int);
00088   vtkGetVectorMacro(DataDimensions,int,2);
00090
00092
00094   vtkSetMacro(DataMask,unsigned short);
00095   vtkGetMacro(DataMask,unsigned short);
00097
00099
00100   vtkSetMacro(HeaderSize,int);
00101   vtkGetMacro(HeaderSize,int);
00103
00105
00115   void SetDataByteOrderToBigEndian();
00116   void SetDataByteOrderToLittleEndian();
00117   int GetDataByteOrder();
00118   void SetDataByteOrder(int);
00119   const char *GetDataByteOrderAsString();
00121
00123
00124   vtkSetMacro(SwapBytes,int);
00125   vtkGetMacro(SwapBytes,int);
00126   vtkBooleanMacro(SwapBytes,int);
00128
00130
00133   vtkSetObjectMacro(Transform,vtkTransform);
00134   vtkGetObjectMacro(Transform,vtkTransform);
00136
00138   vtkStructuredPoints *GetImage(int ImageNumber);
00139
00140 protected:
00141   vtkVolume16Reader();
00142   ~vtkVolume16Reader();
00143
00144   void Execute();
00145   void ExecuteInformation();
00146   int   DataDimensions[2];
00147   unsigned short DataMask;
00148   int   SwapBytes;
00149   int   HeaderSize;
00150   vtkTransform *Transform;
00151
00152   void TransformSlice (unsigned short *slice, unsigned short *pixels, int k, int dimensions[3], int bounds[3]);
00153   void ComputeTransformedDimensions(int dimensions[3]);
00154   void ComputeTransformedBounds(int bounds[6]);
00155   void ComputeTransformedSpacing(float Spacing[3]);
00156   void ComputeTransformedOrigin(float origin[3]);
00157   void AdjustSpacingAndOrigin(int dimensions[3], float Spacing[3], float origin[3]);
00158   vtkUnsignedShortArray *ReadImage(int ImageNumber);
00159   vtkUnsignedShortArray *ReadVolume(int FirstImage, int LastImage);
00160   int Read16BitImage(FILE *fp, unsigned short *pixels, int xsize, int ysize,
00161                      int skip, int swapBytes);
00162
00163 private:
00164   vtkVolume16Reader(const vtkVolume16Reader&);  // Not implemented.
00165   void operator=(const vtkVolume16Reader&);  // Not implemented.
00166 };
00167
00168 #endif
00169
00170
Generated on Mon Mar 25 01:07:53 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolume.h Source File

Rendering/vtkVolume.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolume.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkVolume_h
00048 #define __vtkVolume_h
00049
00050 #include "vtkProp3D.h"
00051 #include "vtkTransform.h"
00052 #include "vtkVolumeProperty.h"
00053 #include "vtkVolumeMapper.h"
00054
00055 class vtkRenderer;
00056 class vtkPropCollection;
00057 class vtkVolumeCollection;
00058 class vtkWindow;
00059
00060 class VTK_RENDERING_EXPORT vtkVolume : public vtkProp3D
00061 {
00062 public:
00063   vtkTypeRevisionMacro(vtkVolume,vtkProp3D);
00064   void PrintSelf(ostream& os, vtkIndent indent);
00065
00069   static vtkVolume *New();
00070
00072
00073   void SetMapper(vtkVolumeMapper *mapper);
00074   vtkGetObjectMacro(Mapper, vtkVolumeMapper);
00076
00078
00079   void SetProperty(vtkVolumeProperty *property);
00080   vtkVolumeProperty *GetProperty();
00082
00086   void GetVolumes(vtkPropCollection *vc);
00087
00089   void Update();
00090
00092
00094   float *GetBounds();
00095   void GetBounds(float bounds[6]) { this->vtkProp3D::GetBounds( bounds ); };
00096   float GetMinXBound();
00097   float GetMaxXBound();
00098   float GetMinYBound();
00099   float GetMaxYBound();
00100   float GetMinZBound();
00101   float GetMaxZBound();
00103
00105   unsigned long int GetMTime();
00106
00111   unsigned long GetRedrawMTime();
00112
00114   void ShallowCopy(vtkProp *prop);
00115
00116 //BTX
00122   int RenderTranslucentGeometry(vtkViewport *viewport);
00123
00128   void ReleaseGraphicsResources(vtkWindow *);
00129
00132   float *GetCorrectedScalarOpacityArray () { return this->CorrectedScalarOpacityArray; };
00133
00136   float *GetScalarOpacityArray () { return this->ScalarOpacityArray; };
00137
00140   float *GetGradientOpacityArray () { return this->GradientOpacityArray; };
00141
00144   float *GetGrayArray () { return this->GrayArray; };
00145
00148   float *GetRGBArray () { return this->RGBArray; };
00149
00152   float  GetGradientOpacityConstant () { return this->GradientOpacityConstant; };
00153
00156   float  GetArraySize () { return this->ArraySize; };
00157
00160   void UpdateTransferFunctions( vtkRenderer *ren );
00161
00164   void UpdateScalarOpacityforSampleSize( vtkRenderer *ren, float sample_distance );
00165
00166 //ETX
00167
00168 protected:
00169   vtkVolume();
00170   ~vtkVolume();
00171
00172   vtkVolumeMapper              *Mapper;
00173   vtkVolumeProperty            *Property;
00174
00175   // The rgb transfer function array - for unsigned char data this
00176   // is 256 elements, for short or unsigned short it is 65536 elements
00177   // This is a sample at each scalar value of the rgb transfer
00178   // function.  A time stamp is kept to know when it needs rebuilding
00179   float                        *RGBArray;
00180   vtkTimeStamp                 RGBArrayMTime;
00181
00182   // The gray transfer function array - for unsigned char data this
00183   // is 256 elements, for short or unsigned short it is 65536 elements
00184   // This is a sample at each scalar value of the gray transfer
00185   // function.  A time stamp is kept to know when it needs rebuilding
00186   float                        *GrayArray;
00187   vtkTimeStamp                 GrayArrayMTime;
00188
00189   // The scalar opacity transfer function array - for unsigned char data this
00190   // is 256 elements, for short or unsigned short it is 65536 elements
00191   // This is a sample at each scalar value of the opacity transfer
00192   // function.  A time stamp is kept to know when it needs rebuilding
00193   float                        *ScalarOpacityArray;
00194   vtkTimeStamp                 ScalarOpacityArrayMTime;
00195
00196   // The corrected scalar opacity transfer function array - this is identical
00197   // to the opacity transfer function array when the step size is 1.
00198   // In other cases, it is corrected to reflect the new material thickness
00199   // modeled by a step size different than 1.
00200   float                        *CorrectedScalarOpacityArray;
00201
00202   // CorrectedStepSize is the step size currently modeled by
00203   // CorrectedArray.  It is used to determine when the
00204   // CorrectedArray needs to be updated to match SampleDistance
00205   // in the volume mapper.
00206   float                        CorrectedStepSize;
00207
00208   // CorrectedSOArrayMTime - compared with OpacityArrayMTime for update
00209   vtkTimeStamp                 CorrectedScalarOpacityArrayMTime;
00210
00211   // Number of elements in the rgb, gray, and opacity transfer function arrays
00212   int                          ArraySize;
00213
00214   // The magnitude of gradient opacity transfer function array
00215   float                        GradientOpacityArray[256];
00216   float                        GradientOpacityConstant;
00217   vtkTimeStamp                 GradientOpacityArrayMTime;
00218
00219   // Function to compute screen coverage of this volume
00220   float ComputeScreenCoverage( vtkViewport *vp );
00221 private:
00222   vtkVolume(const vtkVolume&);  // Not implemented.
00223   void operator=(const vtkVolume&);  // Not implemented.
00224 };
00225
00226 #endif
00227
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeCollection.h Source File

Rendering/vtkVolumeCollection.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeCollection.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkVolumeC_h
00041 #define __vtkVolumeC_h
00042
00043 #include "vtkPropCollection.h"
00044 #include "vtkVolume.h"
00045
00046 class VTK_RENDERING_EXPORT vtkVolumeCollection : public vtkPropCollection
00047 {
00048  public:
00049   static vtkVolumeCollection *New();
00050   vtkTypeRevisionMacro(vtkVolumeCollection,vtkPropCollection);
00051
00053
00054   void AddItem(vtkVolume *a) {
00055     this->vtkCollection::AddItem((vtkObject *)a);};
00057
00059
00061   vtkVolume *GetNextVolume() {
00062       return static_cast<vtkVolume *>(this->GetNextItemAsObject());};
00064
00065
00068   vtkVolume *GetNextItem() { return this->GetNextVolume(); };
00069
00070 protected:
00071   vtkVolumeCollection() {};
00072   ~vtkVolumeCollection() {};
00073
00074 private:
00075   // hide the standard AddItem from the user and the compiler.
00076   void AddItem(vtkObject *o) { this->vtkCollection::AddItem(o); };
00077   void AddItem(vtkProp *o) { this->vtkPropCollection::AddItem(o); };
00078
00079 private:
00080   vtkVolumeCollection(const vtkVolumeCollection&);  // Not implemented.
00081   void operator=(const vtkVolumeCollection&);  // Not implemented.
00082 };
00083
00084
00085 #endif
00086
00087
00088
00089
00090
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeMapper.h Source File

Rendering/vtkVolumeMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkVolumeMapper_h
00042 #define __vtkVolumeMapper_h
00043
00044 #include "vtkAbstractMapper3D.h"
00045 #include "vtkImageData.h"
00046
00047 class vtkRenderer;
00048 class vtkVolume;
00049
00050 #define VTK_CROP_SUBVOLUME              0x0002000
00051 #define VTK_CROP_FENCE                  0x2ebfeba
00052 #define VTK_CROP_INVERTED_FENCE         0x5140145
00053 #define VTK_CROP_CROSS                  0x0417410
00054 #define VTK_CROP_INVERTED_CROSS         0x7be8bef
00055
00056 class vtkWindow;
00057 class vtkImageClip;
00058
00059 class VTK_RENDERING_EXPORT vtkVolumeMapper : public vtkAbstractMapper3D
00060 {
00061 public:
00062   vtkTypeRevisionMacro(vtkVolumeMapper,vtkAbstractMapper3D);
00063   void PrintSelf( ostream& os, vtkIndent index );
00064
00066   virtual void Update();
00067
00069
00070   void SetInput( vtkImageData * );
00071   vtkImageData *GetInput();
00073
00075
00090   vtkSetClampMacro( IndependentComponents, int, 0, 1 );
00091   vtkGetMacro( IndependentComponents, int );
00092   vtkBooleanMacro( IndependentComponents, int );
00094
00096
00100   vtkSetClampMacro( ComponentBlendMode, int,
00101                     vtkVolumeMapper::ComponentBlendAdd,
00102                     vtkVolumeMapper::ComponentBlendMaxOpacity );
00103   vtkGetMacro( ComponentBlendMode, int );
00104   void SetComponentBlendModeToAdd()
00105     {this->SetComponentBlendMode(vtkVolumeMapper::ComponentBlendAdd);};
00106   void SetComponentBlendModeToMaxOpacity()
00107     {this->SetComponentBlendMode(vtkVolumeMapper::ComponentBlendMaxOpacity);};
00109
00110
00111
00113
00115   vtkSetClampMacro(Cropping,int,0,1);
00116   vtkGetMacro(Cropping,int);
00117   vtkBooleanMacro(Cropping,int);
00119
00121
00124   vtkSetVector6Macro( CroppingRegionPlanes, float );
00125   vtkGetVectorMacro(  CroppingRegionPlanes, float, 6 );
00127
00129
00131   vtkGetVectorMacro( VoxelCroppingRegionPlanes, float, 6 );
00133
00135
00144   vtkSetClampMacro( CroppingRegionFlags, int, 0x0, 0x7ffffff );
00145   vtkGetMacro( CroppingRegionFlags, int );
00146   void SetCroppingRegionFlagsToSubVolume()
00147     {this->SetCroppingRegionFlags( VTK_CROP_SUBVOLUME );};
00148   void SetCroppingRegionFlagsToFence()
00149     {this->SetCroppingRegionFlags( VTK_CROP_FENCE );};
00150   void SetCroppingRegionFlagsToInvertedFence()
00151     {this->SetCroppingRegionFlags( VTK_CROP_INVERTED_FENCE );};
00152   void SetCroppingRegionFlagsToCross()
00153     {this->SetCroppingRegionFlags( VTK_CROP_CROSS );};
00154   void SetCroppingRegionFlagsToInvertedCross()
00155     {this->SetCroppingRegionFlags( VTK_CROP_INVERTED_CROSS );};
00157
00159
00161   virtual float *GetBounds();
00162   virtual void GetBounds(float bounds[6])
00163     { this->vtkAbstractMapper3D::GetBounds(bounds); };
00165
00166
00167 //BTX
00169   /*! WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE */
00170   virtual float GetGradientMagnitudeScale() {return 1.0;};
00171   virtual float GetGradientMagnitudeBias()  {return 0.0;};
00173
00174
00177   virtual void Render(vtkRenderer *ren, vtkVolume *vol)=0;
00178
00183   virtual void ReleaseGraphicsResources(vtkWindow *) {};
00184
00185   enum ComponentBlendModes {
00186     ComponentBlendAdd = 0,
00187     ComponentBlendMaxOpacity
00188   };
00189
00190 //ETX
00191
00192
00193 protected:
00194   vtkVolumeMapper();
00195   ~vtkVolumeMapper();
00196
00197   // Cropping variables, and a method for converting the world
00198   // coordinate cropping region planes to voxel coordinates
00199   int                  Cropping;
00200   float                CroppingRegionPlanes[6];
00201   float                VoxelCroppingRegionPlanes[6];
00202   int                  CroppingRegionFlags;
00203   void ConvertCroppingRegionPlanesToVoxels();
00204
00205   // Flag for independent or dependent components
00206   int                  IndependentComponents;
00207
00208   // How should we combine the components
00209   int                  ComponentBlendMode;
00210
00211   vtkTimeStamp         BuildTime;
00212
00213   // Clipper used on input to ensure it is the right size
00214   vtkImageClip        *ImageClipper;
00215
00216
00217 private:
00218   vtkVolumeMapper(const vtkVolumeMapper&);  // Not implemented.
00219   void operator=(const vtkVolumeMapper&);  // Not implemented.
00220 };
00221
00222
00223 #endif
00224
00225
Generated on Mon Mar 25 01:07:59 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeProMapper.h Source File

Rendering/vtkVolumeProMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeProMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00058 #ifndef __vtkVolumeProMapper_h
00059 #define __vtkVolumeProMapper_h
00060
00061 #include "vtkVolumeMapper.h"
00062 #include "vtkToolkits.h"
00063 #include "vtkVersion.h"
00064
00065 //BTX
00066 #if defined (VTK_HAVE_VP1000) || defined (VTK_FORCE_COMPILE_VP1000)
00067 namespace vli3 {
00068 #endif
00069 class VLIContext;
00070 class VLIVolume;
00071 class VLILookupTable;
00072 class VLILight;
00073 class VLICutPlane;
00074 #if defined (VTK_HAVE_VP1000) || defined (VTK_FORCE_COMPILE_VP1000)
00075 }
00076 using namespace vli3;
00077 #endif
00078 //ETX
00079
00080 #define VTK_BLEND_MODE_COMPOSITE        0
00081 #define VTK_BLEND_MODE_MAX_INTENSITY    1
00082 #define VTK_BLEND_MODE_MIN_INTENSITY    2
00083
00084 #define VTK_CURSOR_TYPE_CROSSHAIR       0
00085 #define VTK_CURSOR_TYPE_PLANE           1
00086
00087 #define VTK_VOLUME_8BIT                 0
00088 #define VTK_VOLUME_12BIT_UPPER          1
00089 #define VTK_VOLUME_12BIT_LOWER          2
00090 //BTX
00091 #if ((VTK_MAJOR_VERSION == 3)&&(VTK_MINOR_VERSION == 2))
00092 class VTK_EXPORT vtkVolumeProMapper : public vtkVolumeMapper
00093 #else
00094 //ETX
00095 class VTK_RENDERING_EXPORT vtkVolumeProMapper : public vtkVolumeMapper
00096 #endif
00097 {
00098 public:
00099   vtkTypeRevisionMacro(vtkVolumeProMapper,vtkVolumeMapper);
00100   void PrintSelf( ostream& os, vtkIndent index );
00101
00103   static vtkVolumeProMapper *New();
00104
00106   virtual void Render( vtkRenderer *, vtkVolume * ) {}
00107
00109
00110   vtkSetClampMacro( BlendMode, int,
00111         VTK_BLEND_MODE_COMPOSITE, VTK_BLEND_MODE_MIN_INTENSITY );
00112   vtkGetMacro(BlendMode,int);
00113   void SetBlendModeToComposite()
00114         {this->SetBlendMode(VTK_BLEND_MODE_COMPOSITE);};
00115   void SetBlendModeToMaximumIntensity()
00116         {this->SetBlendMode(VTK_BLEND_MODE_MAX_INTENSITY);};
00117   void SetBlendModeToMinimumIntensity()
00118         {this->SetBlendMode(VTK_BLEND_MODE_MIN_INTENSITY);};
00119   const char *GetBlendModeAsString(void);
00121
00123
00124   vtkSetVector6Macro( SubVolume, int );
00125   vtkGetVectorMacro( SubVolume, int, 6 );
00127
00129
00130   vtkSetClampMacro( Cursor, int, 0, 1 );
00131   vtkGetMacro( Cursor, int );
00132   vtkBooleanMacro( Cursor, int );
00134
00136
00137   vtkSetClampMacro( CursorType, int,
00138                     VTK_CURSOR_TYPE_CROSSHAIR, VTK_CURSOR_TYPE_PLANE );
00139   vtkGetMacro( CursorType, int );
00140   void SetCursorTypeToCrossHair()
00141     { this->SetCursorType( VTK_CURSOR_TYPE_CROSSHAIR ); };
00142   void SetCursorTypeToPlane()
00143     { this->SetCursorType( VTK_CURSOR_TYPE_PLANE ); };
00144   const char *GetCursorTypeAsString( void );
00146
00148
00149   vtkSetVector3Macro( CursorPosition, double );
00150   vtkGetVectorMacro( CursorPosition, double, 3 );
00152
00154
00155   vtkSetVector3Macro( CursorXAxisColor, double );
00156   vtkGetVectorMacro(  CursorXAxisColor, double, 3 );
00157   vtkSetVector3Macro( CursorYAxisColor, double );
00158   vtkGetVectorMacro(  CursorYAxisColor, double, 3 );
00159   vtkSetVector3Macro( CursorZAxisColor, double );
00160   vtkGetVectorMacro(  CursorZAxisColor, double, 3 );
00162
00164
00165   vtkSetClampMacro( SuperSampling, int, 0, 1 );
00166   vtkGetMacro( SuperSampling, int );
00167   vtkBooleanMacro( SuperSampling, int );
00169
00171
00172   void SetSuperSamplingFactor( double x, double y, double z );
00173   void SetSuperSamplingFactor( double f[3] )
00174     { this->SetSuperSamplingFactor( f[0], f[1], f[2] ); };
00175   vtkGetVectorMacro( SuperSamplingFactor, double, 3 );
00177
00179
00180   vtkSetClampMacro( CutPlane, int, 0, 1 );
00181   vtkGetMacro( CutPlane, int );
00182   vtkBooleanMacro( CutPlane, int );
00184
00186
00187   vtkSetVector4Macro( CutPlaneEquation, double );
00188   vtkGetVectorMacro( CutPlaneEquation, double, 4 );
00190
00192
00193   vtkSetClampMacro( CutPlaneThickness, double, 0.0, 9.99e10 );
00194   vtkGetMacro( CutPlaneThickness, double );
00196
00198
00199   vtkSetClampMacro( CutPlaneFallOffDistance, int, 0, 16 );
00200   vtkGetMacro( CutPlaneFallOffDistance, int );
00202
00204
00205   vtkSetClampMacro( GradientOpacityModulation, int, 0, 1 );
00206   vtkGetMacro( GradientOpacityModulation, int );
00207   vtkBooleanMacro( GradientOpacityModulation, int );
00209
00211
00212   vtkSetClampMacro( GradientDiffuseModulation, int, 0, 1 );
00213   vtkGetMacro( GradientDiffuseModulation, int );
00214   vtkBooleanMacro( GradientDiffuseModulation, int );
00216
00218
00219   vtkSetClampMacro( GradientSpecularModulation, int, 0, 1 );
00220   vtkGetMacro( GradientSpecularModulation, int );
00221   vtkBooleanMacro( GradientSpecularModulation, int );
00223
00225
00226   vtkGetMacro( NoHardware, int );
00227   vtkGetMacro( WrongVLIVersion, int );
00229
00231
00232   vtkGetMacro( NumberOfBoards, int );
00233   vtkGetMacro( MajorBoardVersion, int );
00234   vtkGetMacro( MinorBoardVersion, int );
00235   virtual int GetAvailableBoardMemory() { return 0; }
00236   virtual void GetLockSizesForBoardMemory( unsigned int vtkNotUsed(type),
00237                                            unsigned int * vtkNotUsed(xSize),
00238                                            unsigned int * vtkNotUsed(ySize),
00239                                            unsigned int * vtkNotUsed(zSize)) {};
00241
00243
00245   vtkSetClampMacro(IntermixIntersectingGeometry, int, 0, 1);
00246   vtkGetMacro(IntermixIntersectingGeometry, int);
00247   vtkBooleanMacro(IntermixIntersectingGeometry, int);
00249
00250 protected:
00251   vtkVolumeProMapper();
00252   ~vtkVolumeProMapper();
00253  // Make sure everything is OK for rendering
00254   int StatusOK();
00255
00256   // The volume context - create it once and keep it around
00257   VLIContext           *Context;
00258
00259   // The Volume, and the Input that was used to build the volume
00260   // and the time at which it was last built.
00261   VLIVolume            *Volume;
00262   vtkImageData         *VolumeInput;
00263   vtkTimeStamp         *VolumeBuildTime;
00264
00265   // The type of data in the volume - 8bit, 12bit upper, or 12bit lower
00266   int                  VolumeDataType;
00267
00268   // The lookup table for RGBA - create it once then modify it as
00269   // necessary
00270   VLILookupTable       *LookupTable;
00271
00272   // The blending mode to use
00273   int                  BlendMode;
00274
00275   // The lights, and how many of them there are. Not all of them
00276   // are turned on or used.
00277   VLILight             **Lights;
00278   int                  NumberOfLights;
00279
00280   // The subvolume extent (xmin, xmax, ymin, ymax, zmin, zmax)
00281   int                  SubVolume[6];
00282
00283   // The cursor parameters
00284   int                  Cursor;
00285   int                  CursorType;
00286   double               CursorPosition[3];
00287   double               CursorXAxisColor[3];
00288   double               CursorYAxisColor[3];
00289   double               CursorZAxisColor[3];
00290
00291   // The cut plane parameters
00292   int                  CutPlane;
00293   VLICutPlane          *Cut;
00294   double               CutPlaneEquation[4];
00295   double               CutPlaneThickness;
00296   int                  CutPlaneFallOffDistance;
00297
00298   // The supersampling parameters
00299   int                  SuperSampling;
00300   double               SuperSamplingFactor[3];
00301
00302   // The gradient modulation flags
00303   int                  GradientOpacityModulation;
00304   int                  GradientDiffuseModulation;
00305   int                  GradientSpecularModulation;
00306
00307   // Some board properties
00308   int                  NumberOfBoards;
00309   int                  MajorBoardVersion;
00310   int                  MinorBoardVersion;
00311   int                  GradientTableSize;
00312
00313   // Some error conditions that may occur during initialization
00314   int                  NoHardware;
00315   int                  WrongVLIVersion;
00316   int                  DisplayedMessage;
00317
00318   // The embedded geometry flag
00319   int IntermixIntersectingGeometry;
00320
00321 //BTX
00322 #if ((VTK_MAJOR_VERSION == 3)&&(VTK_MINOR_VERSION == 2))
00323   // WARNING: INTERNAL METHOD - NOT FOR GENERAL USE
00324   virtual int GetMapperType() {return VTK_FRAMEBUFFER_VOLUME_MAPPER;};
00325 #endif
00326 //ETX
00327
00328 private:
00329   vtkVolumeProMapper(const vtkVolumeProMapper&);  // Not implemented.
00330   void operator=(const vtkVolumeProMapper&);  // Not implemented.
00331 };
00332
00334 inline const char *vtkVolumeProMapper::GetBlendModeAsString()
00335 {
00336   switch ( this->BlendMode )
00337     {
00338     case VTK_BLEND_MODE_COMPOSITE:
00339       return "Composite";
00340     case VTK_BLEND_MODE_MAX_INTENSITY:
00341       return "Maximum Intensity";
00342     case VTK_BLEND_MODE_MIN_INTENSITY:
00343       return "Minimum Intensity";
00344     default:
00345       return "Unknown Blend Mode";
00346     }
00347 }
00348
00350 inline const char *vtkVolumeProMapper::GetCursorTypeAsString()
00351 {
00352   switch ( this->CursorType )
00353     {
00354     case VTK_CURSOR_TYPE_CROSSHAIR:
00355       return "Crosshair";
00356     case VTK_CURSOR_TYPE_PLANE:
00357       return "Plane";
00358     default:
00359       return "Unknown Cursor Type";
00360     }
00361 }
00362
00363 #endif
00364
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeProperty.h Source File

Rendering/vtkVolumeProperty.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeProperty.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00061 #ifndef __vtkVolumeProperty_h
00062 #define __vtkVolumeProperty_h
00063
00064 #include "vtkObject.h"
00065 #include "vtkPiecewiseFunction.h"
00066 #include "vtkColorTransferFunction.h"
00067 #include "vtkTimeStamp.h"
00068
00069 // Constants for InterpolationType
00070 #define VTK_NEAREST_INTERPOLATION       0
00071 #define VTK_LINEAR_INTERPOLATION        1
00072
00073
00074 class VTK_RENDERING_EXPORT vtkVolumeProperty : public vtkObject
00075 {
00076 public:
00077   static vtkVolumeProperty *New();
00078   vtkTypeRevisionMacro(vtkVolumeProperty,vtkObject);
00079   void PrintSelf(ostream& os, vtkIndent indent);
00080
00083   unsigned long GetMTime();
00084
00085
00087
00088   vtkSetClampMacro( InterpolationType, int,
00089         VTK_NEAREST_INTERPOLATION, VTK_LINEAR_INTERPOLATION);
00090   vtkGetMacro(InterpolationType,int);
00091   void SetInterpolationTypeToNearest()
00092         {this->SetInterpolationType(VTK_NEAREST_INTERPOLATION);};
00093   void SetInterpolationTypeToLinear()
00094         {this->SetInterpolationType(VTK_LINEAR_INTERPOLATION);};
00095   const char *GetInterpolationTypeAsString(void);
00097
00099
00102   void SetColor( int index, vtkPiecewiseFunction *function );
00103   void SetColor( vtkPiecewiseFunction *f ){this->SetColor(0,f);};
00105
00106
00108
00111   void SetColor( int index, vtkColorTransferFunction *function );
00112   void SetColor( vtkColorTransferFunction *f ){this->SetColor(0,f);};
00114
00116
00118   int GetColorChannels( int index );
00119   int GetColorChannels(){return this->GetColorChannels(0);};
00121
00123
00124   vtkPiecewiseFunction *GetGrayTransferFunction( int index );
00125   vtkPiecewiseFunction *GetGrayTransferFunction()
00126     {return this->GetGrayTransferFunction(0);};
00128
00130
00131   vtkColorTransferFunction *GetRGBTransferFunction( int index );
00132   vtkColorTransferFunction *GetRGBTransferFunction()
00133     {return this->GetRGBTransferFunction(0);};
00135
00137
00139   void SetScalarOpacity( int index, vtkPiecewiseFunction *function );
00140   void SetScalarOpacity( vtkPiecewiseFunction *f )
00141     {this->SetScalarOpacity(0,f);};
00143
00145
00146   vtkPiecewiseFunction *GetScalarOpacity( int index );
00147   vtkPiecewiseFunction *GetScalarOpacity()
00148     {return this->GetScalarOpacity(0);};
00150
00151
00153
00155   void SetGradientOpacity( int index, vtkPiecewiseFunction *function );
00156   void SetGradientOpacity( vtkPiecewiseFunction *function )
00157     {this->SetGradientOpacity(0,function);}
00159
00161
00163   vtkPiecewiseFunction *GetGradientOpacity( int index );
00164   vtkPiecewiseFunction *GetGradientOpacity()
00165     {return this->GetGradientOpacity( 0 );}
00167
00169
00177   void SetShade( int index, int value );
00178   void SetShade( int value ) {this->SetShade(0,value);}
00179   int GetShade( int index );
00180   int GetShade() {return this->GetShade(0);}
00181   void ShadeOn( int index );
00182   void ShadeOn() {this->ShadeOn(0);}
00183   void ShadeOff( int index );
00184   void ShadeOff() {this->ShadeOff(0);}
00186
00187
00189
00190   void SetAmbient( int index, float value );
00191   void SetAmbient( float value ) {this->SetAmbient( 0, value );}
00192   float GetAmbient( int index );
00193   float GetAmbient() {return this->GetAmbient(0);}
00195
00196
00198
00199   void SetDiffuse( int index, float value );
00200   void SetDiffuse( float value ) {this->SetDiffuse( 0, value );}
00201   float GetDiffuse( int index );
00202   float GetDiffuse() {return this->GetDiffuse(0);}
00204
00206
00207   void SetSpecular( int index, float value );
00208   void SetSpecular( float value ) {this->SetSpecular( 0, value );}
00209   float GetSpecular( int index );
00210   float GetSpecular() {return this->GetSpecular(0);}
00212
00214
00215   void SetSpecularPower( int index, float value );
00216   void SetSpecularPower( float value ) {this->SetSpecularPower( 0, value );}
00217   float GetSpecularPower( int index );
00218   float GetSpecularPower() {return this->GetSpecularPower(0);}
00220
00221 //BTX
00226   void UpdateMTimes();
00227
00229
00231   vtkTimeStamp GetGradientOpacityMTime( int index );
00232   vtkTimeStamp GetGradientOpacityMTime()
00233     { return this->GetGradientOpacityMTime(0); }
00235
00237
00239   vtkTimeStamp GetScalarOpacityMTime( int index );
00240   vtkTimeStamp GetScalarOpacityMTime()
00241     { return this->GetScalarOpacityMTime(0); }
00243
00245
00247   vtkTimeStamp GetRGBTransferFunctionMTime( int index );
00248   vtkTimeStamp GetRGBTransferFunctionMTime()
00249     { return this->GetRGBTransferFunctionMTime(0); }
00251
00253
00255   vtkTimeStamp GetGrayTransferFunctionMTime( int index );
00256   vtkTimeStamp GetGrayTransferFunctionMTime()
00257     { return this->GetGrayTransferFunctionMTime(0); }
00259 //ETX
00260
00261
00262 protected:
00263   vtkVolumeProperty();
00264   ~vtkVolumeProperty();
00265
00266   int                           InterpolationType;
00267
00268   int                           ColorChannels[4];
00269
00270   vtkPiecewiseFunction          *GrayTransferFunction[4];
00271   vtkTimeStamp                  GrayTransferFunctionMTime[4];
00272
00273   vtkColorTransferFunction      *RGBTransferFunction[4];
00274   vtkTimeStamp                  RGBTransferFunctionMTime[4];
00275
00276   vtkPiecewiseFunction          *ScalarOpacity[4];
00277   vtkTimeStamp                  ScalarOpacityMTime[4];
00278
00279   vtkPiecewiseFunction          *GradientOpacity[4];
00280   vtkTimeStamp                  GradientOpacityMTime[4];
00281
00282   int                           Shade[4];
00283   float                         Ambient[4];
00284   float                         Diffuse[4];
00285   float                         Specular[4];
00286   float                         SpecularPower[4];
00287
00288 private:
00289   vtkVolumeProperty(const vtkVolumeProperty&);  // Not implemented.
00290   void operator=(const vtkVolumeProperty&);  // Not implemented.
00291 };
00292
00294 inline const char *vtkVolumeProperty::GetInterpolationTypeAsString(void)
00295 {
00296   if( this->InterpolationType == VTK_NEAREST_INTERPOLATION )
00297     {
00298     return "Nearest Neighbor";
00299     }
00300   else if( this->InterpolationType == VTK_LINEAR_INTERPOLATION )
00301     {
00302     return "Linear";
00303     }
00304   else
00305     {
00306     return "Unknown";
00307     }
00308 }
00309
00310 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeProVG500Mapper.h Source File

Rendering/vtkVolumeProVG500Mapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeProVG500Mapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00060 #ifndef __vtkVolumeProVG500Mapper_h
00061 #define __vtkVolumeProVG500Mapper_h
00062
00063 #include "vtkVolumeProMapper.h"
00064
00065 #ifdef _WIN32
00066 #include "VolumePro/inc/vli.h"
00067 #else
00068 #include "vli/include/vli.h"
00069 #endif
00070
00071 #ifdef VTK_USE_VOLUMEPRO
00072 #define VTK_VOLUMEPRO_EXPORT VTK_RENDERING_EXPORT
00073 #else
00074 #define VTK_VOLUMEPRO_EXPORT
00075 #endif
00076
00077 class VTK_VOLUMEPRO_EXPORT vtkVolumeProVG500Mapper : public vtkVolumeProMapper
00078 {
00079 public:
00080   vtkTypeRevisionMacro(vtkVolumeProVG500Mapper,vtkVolumeProMapper);
00081   static vtkVolumeProVG500Mapper *New();
00083
00084   virtual void Render( vtkRenderer *, vtkVolume * );
00085   virtual int GetAvailableBoardMemory();
00086   virtual void GetLockSizesForBoardMemory( unsigned int type,
00087                                            unsigned int *xSize,
00088                                            unsigned int *ySize,
00089                                            unsigned int *zSize );
00091 protected:
00092   vtkVolumeProVG500Mapper();
00093   ~vtkVolumeProVG500Mapper();
00094
00095   // Update the camera - set the camera matrix
00096   void UpdateCamera( vtkRenderer *, vtkVolume * );
00097
00098   // Update the lights
00099   void UpdateLights( vtkRenderer *, vtkVolume * );
00100
00101   // Update the properties of the volume including transfer functions
00102   // and material properties
00103   void UpdateProperties( vtkRenderer *, vtkVolume * );
00104
00105   // Update the volume - create it if necessary
00106   // Set the volume matrix.
00107   void UpdateVolume( vtkRenderer *, vtkVolume * );
00108
00109   // Set the crop box (as defined in the vtkVolumeMapper superclass)
00110   void UpdateCropping( vtkRenderer *, vtkVolume * );
00111
00112   // Set the cursor
00113   void UpdateCursor( vtkRenderer *, vtkVolume * );
00114
00115   // Update the cut plane
00116   void UpdateCutPlane( vtkRenderer *, vtkVolume * );
00117
00118   // Render the hexagon to the screen
00119   // Defined in the specific graphics implementation.
00120   virtual void RenderHexagon( vtkRenderer  * vtkNotUsed(ren),
00121                               vtkVolume    * vtkNotUsed(vol),
00122                               VLIPixel     * vtkNotUsed(basePlane),
00123                               int          size[2],
00124                               VLIVector3D  hexagon[6],
00125                               VLIVector2D  textureCoords[6] )
00126     {(void)size; (void)hexagon; (void)textureCoords;}
00127
00128   // Make the base plane size a power of 2 for OpenGL
00129   void CorrectBasePlaneSize( VLIPixel *inBase, int inSize[2],
00130                              VLIPixel **outBase, int outSize[2],
00131                              VLIVector2D textureCoords[6] );
00132
00133   // Keep track of the size of the data loaded so we know if we can
00134   // simply update when a change occurs or if we need to release and
00135   // create again
00136   int LoadedDataSize[3];
00137
00138 private:
00139   vtkVolumeProVG500Mapper(const vtkVolumeProVG500Mapper&);  // Not implemented.
00140   void operator=(const vtkVolumeProVG500Mapper&);  // Not implemented.
00141 };
00142
00143
00144
00145 #endif
00146
00147
00148
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeProVP1000Mapper.h Source File

Rendering/vtkVolumeProVP1000Mapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeProVP1000Mapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00059 #ifndef __vtkVolumeProVP1000Mapper_h
00060 #define __vtkVolumeProVP1000Mapper_h
00061
00062 #include "vtkVolumeProMapper.h"
00063
00064 #ifdef _WIN32
00065 #include "VolumePro1000/inc/vli.h"
00066 #else
00067 #include "vli3/include/vli.h"
00068 #endif
00069
00070 #define VTK_VOLUME_16BIT 3
00071 #define VTK_VOLUME_32BIT 4
00072
00073 class VTK_EXPORT vtkVolumeProVP1000Mapper : public vtkVolumeProMapper
00074 {
00075 public:
00076   vtkTypeRevisionMacro(vtkVolumeProVP1000Mapper,vtkVolumeProMapper);
00077   static vtkVolumeProVP1000Mapper *New();
00079
00080   virtual void Render( vtkRenderer *, vtkVolume * );
00081   virtual int GetAvailableBoardMemory();
00082   virtual void GetLockSizesForBoardMemory(unsigned int type,
00083                                           unsigned int *xSize,
00084                                           unsigned int *ySize,
00085                                           unsigned int *zSize);
00087
00088 protected:
00089   vtkVolumeProVP1000Mapper();
00090   ~vtkVolumeProVP1000Mapper();
00091   vtkVolumeProVP1000Mapper(const vtkVolumeProVP1000Mapper&);
00092   void operator=(const vtkVolumeProVP1000Mapper&);
00093
00094   // Update the camera - set the camera matrix
00095   void UpdateCamera( vtkRenderer *, vtkVolume * );
00096
00097   // Update the lights
00098   void UpdateLights( vtkRenderer *, vtkVolume * );
00099
00100   // Update the properties of the volume including transfer functions
00101   // and material properties
00102   void UpdateProperties( vtkRenderer *, vtkVolume * );
00103
00104   // Update the volume - create it if necessary
00105   // Set the volume matrix.
00106   void UpdateVolume( vtkRenderer *, vtkVolume * );
00107
00108   // Set the crop box (as defined in the vtkVolumeMapper superclass)
00109   void UpdateCropping( vtkRenderer *, vtkVolume * );
00110
00111   // Set the cursor
00112   void UpdateCursor( vtkRenderer *, vtkVolume * );
00113
00114   // Update the cut plane
00115   void UpdateCutPlane( vtkRenderer *, vtkVolume * );
00116
00117   // Render the image buffer to the screen
00118   // Defined in the specific graphics implementation.
00119   virtual void RenderImageBuffer( vtkRenderer  * vtkNotUsed(ren),
00120                                   vtkVolume    * vol,
00121                                   int          size[2],
00122                                   unsigned int * outData )
00123     {(void)vol; (void)size; (void)outData;}
00124
00125   // Render a bounding box of the volume because the texture map would
00126   // be too large.
00127   virtual void RenderBoundingBox( vtkRenderer * vtkNotUsed(ren),
00128                                   vtkVolume   * vol )
00129     {(void)vol;}
00130
00131   // Get the depth buffer values
00132   virtual void GetDepthBufferValues( vtkRenderer *vtkNotUsed(ren),
00133                                      int size[2],
00134                                      unsigned int *outData )
00135     { (void)outData; }
00136
00137 #if ((VTK_MAJOR_VERSION == 3)&&(VTK_MINOR_VERSION == 2))
00138   vtkGetVectorMacro( VoxelCroppingRegionPlanes, float, 6 );
00139   void ConvertCroppingRegionPlanesToVoxels();
00140   float                VoxelCroppingRegionPlanes[6];
00141 #endif
00142
00143
00144   // Keep track of the size of the data loaded so we know if we can
00145   // simply update when a change occurs or if we need to release and
00146   // create again
00147   int LoadedDataSize[3];
00148
00149   VLIImageBuffer *ImageBuffer;
00150   VLIDepthBuffer *DepthBuffer;
00151
00152   VLIStatus CheckSubSampling(const VLIVolume *inVolume,
00153                              const VLIContext *inContext,
00154                              int &outImageWidth, int &outImageHeight);
00155
00156   int DrawBoundingBox;
00157 };
00158
00159
00160
00161 #endif
00162
00163
00164
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastCompositeFunction.h Source File

Rendering/vtkVolumeRayCastCompositeFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastCompositeFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00044 #ifndef __vtkVolumeRayCastCompositeFunction_h
00045 #define __vtkVolumeRayCastCompositeFunction_h
00046
00047 #include "vtkVolumeRayCastFunction.h"
00048
00049 #define VTK_COMPOSITE_CLASSIFY_FIRST 0
00050 #define VTK_COMPOSITE_INTERPOLATE_FIRST 1
00051
00052 class VTK_RENDERING_EXPORT vtkVolumeRayCastCompositeFunction : public vtkVolumeRayCastFunction
00053 {
00054 public:
00055   static vtkVolumeRayCastCompositeFunction *New();
00056   vtkTypeRevisionMacro(vtkVolumeRayCastCompositeFunction,vtkVolumeRayCastFunction);
00057   void PrintSelf( ostream& os, vtkIndent index );
00058
00060
00061   vtkSetClampMacro( CompositeMethod, int,
00062         VTK_COMPOSITE_CLASSIFY_FIRST, VTK_COMPOSITE_INTERPOLATE_FIRST );
00063   vtkGetMacro(CompositeMethod,int);
00064   void SetCompositeMethodToInterpolateFirst()
00065     {this->SetCompositeMethod(VTK_COMPOSITE_INTERPOLATE_FIRST);}
00066   void SetCompositeMethodToClassifyFirst()
00067     {this->SetCompositeMethod(VTK_COMPOSITE_CLASSIFY_FIRST);}
00068   const char *GetCompositeMethodAsString(void);
00070
00071 //BTX
00072   void CastRay( VTKVRCDynamicInfo *dynamicInfo,
00073                 VTKVRCStaticInfo *staticInfo);
00074
00075   float GetZeroOpacityThreshold( vtkVolume *vol );
00076 //ETX
00077
00078 protected:
00079   vtkVolumeRayCastCompositeFunction();
00080   ~vtkVolumeRayCastCompositeFunction();
00081
00082 //BTX
00083   void SpecificFunctionInitialize( vtkRenderer *ren,
00084                                    vtkVolume   *vol,
00085                                    VTKVRCStaticInfo *staticInfo,
00086                                    vtkVolumeRayCastMapper *mapper );
00087 //ETX
00088
00089   int           CompositeMethod;
00090 private:
00091   vtkVolumeRayCastCompositeFunction(const vtkVolumeRayCastCompositeFunction&);  // Not implemented.
00092   void operator=(const vtkVolumeRayCastCompositeFunction&);  // Not implemented.
00093 };
00094
00095
00096 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastFunction.h Source File

Rendering/vtkVolumeRayCastFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00040 #ifndef __vtkVolumeRayCastFunction_h
00041 #define __vtkVolumeRayCastFunction_h
00042
00043 #include "vtkObject.h"
00044
00045 class vtkRenderer;
00046 class vtkVolume;
00047 class vtkVolumeRayCastMapper;
00048
00049 // Define a couple of structures we need to hold all the important information
00050 // This first structure hold the dynamic information - stuff that changes per
00051 // ray
00052 typedef struct
00053 {
00054   // These are the return values - RGBA
00055   float Color[4];
00056   float ScalarValue;
00057
00058   // Ray information transformed into local coordinates
00059   float                        TransformedStart[4];
00060   float                        TransformedEnd[4];
00061   float                        TransformedDirection[4];
00062   float                        TransformedIncrement[3];
00063
00064   // The number of steps we want to take if this is
00065   // a ray caster that takes steps
00066   int                          NumberOfStepsToTake;
00067
00068   // The number of steps we actually take if this is
00069   // a ray caster that takes steps
00070   int                          NumberOfStepsTaken;
00071
00072 } VTKVRCDynamicInfo;
00073
00074 // This second structure hold the static information - things that don't
00075 // change over the whole image
00076 typedef struct
00077 {
00078   // A pointer to the volume
00079   vtkVolume                   *Volume;
00080
00081   // A pointer to the renderer
00082   vtkRenderer                 *Renderer;
00083
00084   // Matrices for switching from view to volume coordinate, and back
00085   float                        WorldToVoxelsMatrix[16];
00086   float                        VoxelsToWorldMatrix[16];
00087   float                        ViewToVoxelsMatrix[16];
00088
00089   float                       *ClippingPlane;
00090   int                          NumberOfClippingPlanes;
00091
00092   // The camera thickness (distance between near and far) is necessary
00093   // for computing sampling distance
00094   float                        CameraThickness;
00095
00096   // The type of the data and a pointer to it, and the information
00097   // about its size, spacing, origin and precomputed increment
00098   int                          ScalarDataType;
00099   void                        *ScalarDataPointer;
00100   int                          DataIncrement[3];
00101   int                          DataSize[3];
00102   float                        DataSpacing[3];
00103   float                        DataOrigin[3];
00104
00105   // Information from the vtkVolumeProperty
00106   int                          Shading;
00107   int                          ColorChannels;
00108   float                        Color[3];
00109   int                          InterpolationType;
00110
00111   // The shading tables from the vtkEncodedGradientShader
00112   // that will be used for shading the volume.
00113   float                       *RedDiffuseShadingTable;
00114   float                       *GreenDiffuseShadingTable;
00115   float                       *BlueDiffuseShadingTable;
00116   float                       *RedSpecularShadingTable;
00117   float                       *GreenSpecularShadingTable;
00118   float                       *BlueSpecularShadingTable;
00119
00120   // Info needed from the gradient estimator
00121   unsigned short               *EncodedNormals;
00122   unsigned char                *GradientMagnitudes;
00123
00124   // Image information
00125   int                          ImageInUseSize[2];
00126   int                          ImageMemorySize[2];
00127   int                          ImageViewportSize[2];
00128   int                          ImageOrigin[2];
00129   unsigned char               *Image;
00130
00131   int                         *RowBounds;
00132
00133   // Is a MIP ray cast function in use? This will control
00134   // how subsegments of the ray are combined when non-subvolume
00135   // cropping is used. If maximize opacity is used, the color[3]
00136   // value is used to find the max othersize the dynamicInfo->ScalarValue
00137   // value is used
00138   int                          MIPFunction;
00139   int                          MaximizeOpacity;
00140 } VTKVRCStaticInfo;
00141
00142 class VTK_RENDERING_EXPORT vtkVolumeRayCastFunction : public vtkObject
00143 {
00144 public:
00145   vtkTypeRevisionMacro(vtkVolumeRayCastFunction,vtkObject);
00146
00148
00153   void FunctionInitialize( vtkRenderer *ren,
00154                            vtkVolume   *vol,
00155                            VTKVRCStaticInfo *staticInfo );
00157
00158   virtual void CastRay( VTKVRCDynamicInfo *dynamicInfo,
00159                         VTKVRCStaticInfo *staticInfo )=0;
00160 //ETX
00161
00164   virtual float GetZeroOpacityThreshold( vtkVolume *vol )=0;
00165
00166 protected:
00167   vtkVolumeRayCastFunction() {};
00168   ~vtkVolumeRayCastFunction() {};
00169
00171
00173   virtual void SpecificFunctionInitialize( vtkRenderer *ren,
00174                                            vtkVolume   *vol,
00175                                            VTKVRCStaticInfo *staticInfo,
00176                                            vtkVolumeRayCastMapper *mapper )=0;
00178 //ETX
00179 private:
00180   vtkVolumeRayCastFunction(const vtkVolumeRayCastFunction&);  // Not implemented.
00181   void operator=(const vtkVolumeRayCastFunction&);  // Not implemented.
00182 };
00183
00184 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastIsosurfaceFunction.h Source File

Rendering/vtkVolumeRayCastIsosurfaceFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastIsosurfaceFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkVolumeRayCastIsosurfaceFunction_h
00047 #define __vtkVolumeRayCastIsosurfaceFunction_h
00048
00049 #include "vtkVolumeRayCastFunction.h"
00050
00051 class VTK_RENDERING_EXPORT vtkVolumeRayCastIsosurfaceFunction : public vtkVolumeRayCastFunction
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkVolumeRayCastIsosurfaceFunction,vtkVolumeRayCastFunction);
00055   void PrintSelf( ostream& os, vtkIndent index );
00056
00058   static vtkVolumeRayCastIsosurfaceFunction *New();
00059
00061   float GetZeroOpacityThreshold( vtkVolume *vol );
00062
00064
00065   vtkSetMacro( IsoValue, float );
00066   vtkGetMacro( IsoValue, float );
00068
00069
00071   float IsoValue;
00072
00074   float       Color[3];
00075
00076 //BTX
00077   void CastRay( VTKVRCDynamicInfo *dynamicInfo,
00078                 VTKVRCStaticInfo *staticInfo);
00079 //ETX
00080
00081 protected:
00082   vtkVolumeRayCastIsosurfaceFunction();
00083   ~vtkVolumeRayCastIsosurfaceFunction();
00084
00085 //BTX
00086   void SpecificFunctionInitialize( vtkRenderer *ren,
00087                                    vtkVolume   *vol,
00088                                    VTKVRCStaticInfo *staticInfo,
00089                                    vtkVolumeRayCastMapper *mapper );
00090 //ETX
00091 private:
00092   vtkVolumeRayCastIsosurfaceFunction(const vtkVolumeRayCastIsosurfaceFunction&);  // Not implemented.
00093   void operator=(const vtkVolumeRayCastIsosurfaceFunction&);  // Not implemented.
00094 };
00095 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastMapper.h Source File

Rendering/vtkVolumeRayCastMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00041 #ifndef __vtkVolumeRayCastMapper_h
00042 #define __vtkVolumeRayCastMapper_h
00043
00044 #include "vtkVolumeMapper.h"
00045 #include "vtkMultiThreader.h"
00046 #include "vtkVolumeRayCastFunction.h"
00047 #include "vtkEncodedGradientShader.h"
00048 #include "vtkEncodedGradientEstimator.h"
00049
00050 class  vtkRenderer;
00051 class  vtkVolume;
00052 class  vtkVolumeTransform;
00053 class  vtkPlaneCollection;
00054 class  vtkMultiThreader;
00055 class  vtkTimerLog;
00056
00057 // Macro for floor of x
00058 #define vtkFloorFuncMacro(x)   (((x) < 0.0)?((int)((x)-1.0)):((int)(x)))
00059
00060 // Macro for rounding x
00061 #define vtkRoundFuncMacro(x)   (int)((x)+0.5)
00062
00063 // Macro for tri-linear interpolation - do four linear interpolations on
00064 // edges, two linear interpolations between pairs of edges, then a final
00065 // interpolation between faces
00066 #define vtkTrilinFuncMacro(v,x,y,z,a,b,c,d,e,f,g,h)         \
00067         t00 =   a + (x)*(b-a);      \
00068         t01 =   c + (x)*(d-c);      \
00069         t10 =   e + (x)*(f-e);      \
00070         t11 =   g + (x)*(h-g);      \
00071         t0  = t00 + (y)*(t01-t00);  \
00072         t1  = t10 + (y)*(t11-t10);  \
00073         v   =  t0 + (z)*(t1-t0);
00074
00075 class VTK_RENDERING_EXPORT vtkVolumeRayCastMapper : public vtkVolumeMapper
00076 {
00077 public:
00078   static vtkVolumeRayCastMapper *New();
00079   vtkTypeRevisionMacro(vtkVolumeRayCastMapper,vtkVolumeMapper);
00080   void PrintSelf( ostream& os, vtkIndent index );
00081
00083
00086   vtkSetMacro( SampleDistance, float );
00087   vtkGetMacro( SampleDistance, float );
00089
00091
00093   vtkSetObjectMacro( VolumeRayCastFunction, vtkVolumeRayCastFunction );
00094   vtkGetObjectMacro( VolumeRayCastFunction, vtkVolumeRayCastFunction );
00096
00098
00099   void SetGradientEstimator( vtkEncodedGradientEstimator *gradest );
00100   vtkGetObjectMacro( GradientEstimator, vtkEncodedGradientEstimator );
00102
00104
00105   vtkGetObjectMacro( GradientShader, vtkEncodedGradientShader );
00107
00109
00112   vtkSetClampMacro( ImageSampleDistance, float, 0.1, 100.0 );
00113   vtkGetMacro( ImageSampleDistance, float );
00115
00117
00119   vtkSetClampMacro( MinimumImageSampleDistance, float, 0.1, 100.0 );
00120   vtkGetMacro( MinimumImageSampleDistance, float );
00122
00124
00126   vtkSetClampMacro( MaximumImageSampleDistance, float, 0.1, 100.0 );
00127   vtkGetMacro( MaximumImageSampleDistance, float );
00129
00131
00134   vtkSetClampMacro( AutoAdjustSampleDistances, int, 0, 1 );
00135   vtkGetMacro( AutoAdjustSampleDistances, int );
00136   vtkBooleanMacro( AutoAdjustSampleDistances, int );
00138
00140
00142   void SetNumberOfThreads( int num );
00143   vtkGetMacro( NumberOfThreads, int );
00145
00147
00149   vtkSetClampMacro( IntermixIntersectingGeometry, int, 0, 1 );
00150   vtkGetMacro( IntermixIntersectingGeometry, int );
00151   vtkBooleanMacro( IntermixIntersectingGeometry, int );
00153
00154 //BTX
00157   void Render( vtkRenderer *, vtkVolume * );
00158
00163   void ReleaseGraphicsResources(vtkWindow *);
00164
00167   float GetZeroOpacityThreshold( vtkVolume *vol );
00168
00170
00172   virtual float GetGradientMagnitudeScale();
00173   virtual float GetGradientMagnitudeBias();
00175
00176 //ETX
00177
00178 protected:
00179   vtkVolumeRayCastMapper();
00180   ~vtkVolumeRayCastMapper();
00181
00182   vtkVolumeRayCastFunction     *VolumeRayCastFunction;
00183   vtkEncodedGradientEstimator  *GradientEstimator;
00184   vtkEncodedGradientShader     *GradientShader;
00185
00186   // The distance between sample points along the ray
00187   float                        SampleDistance;
00188   float                        ImageSampleDistance;
00189   float                        MinimumImageSampleDistance;
00190   float                        MaximumImageSampleDistance;
00191   int                          AutoAdjustSampleDistances;
00192
00193   float                        WorldSampleDistance;
00194   int                          ScalarDataType;
00195   void                         *ScalarDataPointer;
00196
00197   void                         UpdateShadingTables( vtkRenderer *ren,
00198                                                     vtkVolume *vol );
00199
00200   void ComputeMatrices( vtkImageData *data, vtkVolume *vol );
00201   virtual void RenderTexture( vtkVolume *vol, vtkRenderer *ren)=0;
00202   int ComputeRowBounds( vtkVolume *vol, vtkRenderer *ren );
00203
00204   friend VTK_THREAD_RETURN_TYPE VolumeRayCastMapper_CastRays( void *arg );
00205
00206   vtkMultiThreader  *Threader;
00207   int               NumberOfThreads;
00208
00209   vtkMatrix4x4 *PerspectiveMatrix;
00210   vtkMatrix4x4 *ViewToWorldMatrix;
00211   vtkMatrix4x4 *ViewToVoxelsMatrix;
00212   vtkMatrix4x4 *VoxelsToViewMatrix;
00213   vtkMatrix4x4 *WorldToVoxelsMatrix;
00214   vtkMatrix4x4 *VoxelsToWorldMatrix;
00215
00216   // This is how big the image would be if it covered the entire viewport
00217   int            ImageViewportSize[2];
00218
00219   // This is how big the allocated memory for image is. This may be bigger
00220   // or smaller than ImageFullSize - it will be bigger if necessary to
00221   // ensure a power of 2, it will be smaller if the volume only covers a
00222   // small region of the viewport
00223   int            ImageMemorySize[2];
00224
00225   // This is the size of subregion in ImageSize image that we are using for
00226   // the current image. Since ImageSize is a power of 2, there is likely
00227   // wasted space in it. This number will be used for things such as clearing
00228   // the image if necessary.
00229   int            ImageInUseSize[2];
00230
00231   // This is the location in ImageFullSize image where our ImageSize image
00232   // is located.
00233   int            ImageOrigin[2];
00234
00235   // This is the allocated image
00236   unsigned char *Image;
00237
00238   int  *RowBounds;
00239   int  *OldRowBounds;
00240
00241   float        *RenderTimeTable;
00242   vtkVolume   **RenderVolumeTable;
00243   vtkRenderer **RenderRendererTable;
00244   int           RenderTableSize;
00245   int           RenderTableEntries;
00246
00247   void StoreRenderTime( vtkRenderer *ren, vtkVolume *vol, float t );
00248   float RetrieveRenderTime( vtkRenderer *ren, vtkVolume *vol );
00249
00250   int           IntermixIntersectingGeometry;
00251
00252   float        *ZBuffer;
00253   int           ZBufferSize[2];
00254   int           ZBufferOrigin[2];
00255
00256   float         MinimumViewDistance;
00257
00258   int           ClipRayAgainstVolume( VTKVRCDynamicInfo *dynamicInfo,
00259                                       float bounds[6] );
00260
00261   void          InitializeClippingPlanes( VTKVRCStaticInfo *staticInfo,
00262                                           vtkPlaneCollection *planes );
00263
00264   int           ClipRayAgainstClippingPlanes( VTKVRCDynamicInfo *dynamicInfo,
00265                                               VTKVRCStaticInfo *staticInfo);
00266
00267   // Get the ZBuffer value corresponding to location (x,y) where (x,y)
00268   // are indexing into the ImageInUse image. This must be converted to
00269   // the zbuffer image coordinates. Nearest neighbor value is returned.
00270   float         GetZBufferValue( int x, int y );
00271
00272 private:
00273   vtkVolumeRayCastMapper(const vtkVolumeRayCastMapper&);  // Not implemented.
00274   void operator=(const vtkVolumeRayCastMapper&);  // Not implemented.
00275 };
00276
00277 #endif
00278
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastMIPFunction.h Source File

Rendering/vtkVolumeRayCastMIPFunction.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastMIPFunction.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00047 #ifndef __vtkVolumeRayCastMIPFunction_h
00048 #define __vtkVolumeRayCastMIPFunction_h
00049
00050 #include "vtkVolumeRayCastFunction.h"
00051
00052 #define VTK_MAXIMIZE_SCALAR_VALUE 0
00053 #define VTK_MAXIMIZE_OPACITY      1
00054
00055 class VTK_RENDERING_EXPORT vtkVolumeRayCastMIPFunction : public vtkVolumeRayCastFunction
00056 {
00057 public:
00058   static vtkVolumeRayCastMIPFunction *New();
00059   vtkTypeRevisionMacro(vtkVolumeRayCastMIPFunction,vtkVolumeRayCastFunction);
00060   void PrintSelf( ostream& os, vtkIndent index );
00061
00062
00064   float GetZeroOpacityThreshold( vtkVolume *vol );
00065
00066
00068
00069   vtkSetClampMacro( MaximizeMethod, int,
00070         VTK_MAXIMIZE_SCALAR_VALUE, VTK_MAXIMIZE_OPACITY );
00071   vtkGetMacro(MaximizeMethod,int);
00072   void SetMaximizeMethodToScalarValue()
00073     {this->SetMaximizeMethod(VTK_MAXIMIZE_SCALAR_VALUE);}
00074   void SetMaximizeMethodToOpacity()
00075     {this->SetMaximizeMethod(VTK_MAXIMIZE_OPACITY);}
00076   const char *GetMaximizeMethodAsString(void);
00078
00079 //BTX
00080   void CastRay( VTKVRCDynamicInfo *dynamicInfo,
00081                 VTKVRCStaticInfo *staticInfo );
00082 //ETX
00083
00084
00085 protected:
00086   vtkVolumeRayCastMIPFunction();
00087   ~vtkVolumeRayCastMIPFunction();
00088
00089   int MaximizeMethod;
00090
00091 //BTX
00092   void SpecificFunctionInitialize( vtkRenderer *ren,
00093                                    vtkVolume   *vol,
00094                                    VTKVRCStaticInfo *staticInfo,
00095                                    vtkVolumeRayCastMapper *mapper );
00096
00097 //ETX
00098 private:
00099   vtkVolumeRayCastMIPFunction(const vtkVolumeRayCastMIPFunction&);  // Not implemented.
00100   void operator=(const vtkVolumeRayCastMIPFunction&);  // Not implemented.
00101 };
00102
00103
00104
00105 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeRayCastStructures.h Source File

Rendering/vtkVolumeRayCastStructures.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeRayCastStructures.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016
00036 #ifndef __vtkVolumeRayCastStructures_h
00037 #define __vtkVolumeRayCastStructures_h
00038
00039 class vtkVolume;
00040
00041 typedef struct
00042 {
00043   // A pointer to the volume
00044   vtkVolume                    *Volume;
00045
00046   // Matrices for switching from view to volume coordinate, and back
00047   float                        WorldToVolumeMatrix[16];
00048   float                        VolumeToWorldMatrix[16];
00049   float                        ViewToVolumeMatrix[16];
00050
00051   // The distance from the camera to the center of the volume
00052   // To be used as a simple depth return value
00053   float                        CenterDistance;
00054
00055   // The type of the data and a pointer to it, and the information
00056   // about its size, spacing, origin and precomputed increment
00057   int                          ScalarDataType;
00058   void                         *ScalarDataPointer;
00059   int                          DataIncrement[3];
00060   int                          DataSize[3];
00061   float                        DataSpacing[3];
00062   float                        DataOrigin[3];
00063
00064   // Information from the vtkVolumeProperty
00065   int                          Shading;
00066   int                          ColorChannels;
00067   float                        Color[3];
00068   int                          InterpolationType;
00069   float                        RGBTextureCoefficient;
00070
00071   // The shading tables from the vtkEncodedGradientShader
00072   // that will be used for shading the volume.
00073   float                        *RedDiffuseShadingTable;
00074   float                        *GreenDiffuseShadingTable;
00075   float                        *BlueDiffuseShadingTable;
00076   float                        *RedSpecularShadingTable;
00077   float                        *GreenSpecularShadingTable;
00078   float                        *BlueSpecularShadingTable;
00079
00080   // Info needed to do solid textures - a pointer to the texture
00081   // and info about its size, spacing, origin, and precomputed
00082   // increments
00083   unsigned char                *RGBDataPointer;
00084   int                          RGBDataIncrement[3];
00085   int                          RGBDataSize[3];
00086   float                        RGBDataSpacing[3];
00087   float                        RGBDataOrigin[3];
00088
00089   // Info needed from the gradient estimator
00090   unsigned short               *EncodedNormals;
00091   unsigned char                *GradientMagnitudes;
00092
00093 } VTKRayCastVolumeInfo;
00094
00095
00096 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkVolumeReader.h Source File

IO/vtkVolumeReader.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeReader.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00056 #ifndef __vtkVolumeReader_h
00057 #define __vtkVolumeReader_h
00058
00059 #include <stdio.h>
00060 #include "vtkStructuredPointsSource.h"
00061
00062 class VTK_IO_EXPORT vtkVolumeReader : public vtkStructuredPointsSource
00063 {
00064 public:
00065   vtkTypeRevisionMacro(vtkVolumeReader,vtkStructuredPointsSource);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069
00070   vtkSetStringMacro(FilePrefix);
00071   vtkGetStringMacro(FilePrefix);
00073
00075
00076   vtkSetStringMacro(FilePattern);
00077   vtkGetStringMacro(FilePattern);
00079
00081
00082   vtkSetVector2Macro(ImageRange,int);
00083   vtkGetVectorMacro(ImageRange,int,2);
00085
00087
00088   vtkSetVector3Macro(DataSpacing,float);
00089   vtkGetVectorMacro(DataSpacing,float,3);
00091
00093
00094   vtkSetVector3Macro(DataOrigin,float);
00095   vtkGetVectorMacro(DataOrigin,float,3);
00097
00099   virtual vtkStructuredPoints *GetImage(int ImageNumber) = 0;
00100
00101 protected:
00102   vtkVolumeReader();
00103   ~vtkVolumeReader();
00104
00105   char *FilePrefix;
00106   char *FilePattern;
00107   int ImageRange[2];
00108   float DataSpacing[3];
00109   float DataOrigin[3];
00110 private:
00111   vtkVolumeReader(const vtkVolumeReader&);  // Not implemented.
00112   void operator=(const vtkVolumeReader&);  // Not implemented.
00113 };
00114
00115 #endif
00116
00117
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeTextureMapper2D.h Source File

Rendering/vtkVolumeTextureMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeTextureMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkVolumeTextureMapper2D_h
00042 #define __vtkVolumeTextureMapper2D_h
00043
00044 #include "vtkVolumeTextureMapper.h"
00045
00046 class VTK_RENDERING_EXPORT vtkVolumeTextureMapper2D : public vtkVolumeTextureMapper
00047 {
00048 public:
00049   vtkTypeRevisionMacro(vtkVolumeTextureMapper2D,vtkVolumeTextureMapper);
00050   void PrintSelf( ostream& os, vtkIndent index );
00051
00052   static vtkVolumeTextureMapper2D *New();
00053
00055
00060   vtkSetVector2Macro( TargetTextureSize, int );
00061   vtkGetVector2Macro( TargetTextureSize, int );
00063
00065
00070   vtkSetMacro( MaximumNumberOfPlanes, int );
00071   vtkGetMacro( MaximumNumberOfPlanes, int );
00073
00075
00079   vtkSetMacro( MaximumStorageSize, int );
00080   vtkGetMacro( MaximumStorageSize, int );
00082
00083 //BTX
00084
00087   virtual void Render(vtkRenderer *, vtkVolume *) {};
00088
00089   virtual void RenderQuads( int vtkNotUsed(count),
00090                             float *vtkNotUsed(v), float *vtkNotUsed(t),
00091                             unsigned char *vtkNotUsed(texture),
00092                             int vtkNotUsed(size)[2],
00093                             int vtkNotUsed(reverseFlag)) {};
00094
00097   int GetInternalSkipFactor() {return this->InternalSkipFactor;};
00098
00099   int *GetAxisTextureSize() {return &(this->AxisTextureSize[0][0]);};
00100
00101   int GetSaveTextures() {return this->SaveTextures;};
00102
00103   unsigned char *GetTexture() {return this->Texture;};
00104
00105 //ETX
00106
00107
00108 protected:
00109   vtkVolumeTextureMapper2D();
00110   ~vtkVolumeTextureMapper2D();
00111
00112   void InitializeRender( vtkRenderer *ren, vtkVolume *vol )
00113     {this->InitializeRender( ren, vol, -1 );}
00114
00115   void InitializeRender( vtkRenderer *ren, vtkVolume *vol, int majorDirection );
00116
00117   void GenerateTexturesAndRenderQuads( vtkRenderer *ren, vtkVolume *vol );
00118
00119   int  MajorDirection;
00120   int  TargetTextureSize[2];
00121
00122   int  MaximumNumberOfPlanes;
00123   int  InternalSkipFactor;
00124   int  MaximumStorageSize;
00125
00126   unsigned char  *Texture;
00127   int             TextureSize;
00128   int             SaveTextures;
00129   vtkTimeStamp    TextureMTime;
00130
00131   int             AxisTextureSize[3][3];
00132   void            ComputeAxisTextureSize( int axis, int *size );
00133
00134   void           RenderSavedTexture();
00135
00136 private:
00137   vtkVolumeTextureMapper2D(const vtkVolumeTextureMapper2D&);  // Not implemented.
00138   void operator=(const vtkVolumeTextureMapper2D&);  // Not implemented.
00139 };
00140
00141
00142 #endif
00143
00144
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVolumeTextureMapper.h Source File

Rendering/vtkVolumeTextureMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVolumeTextureMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkVolumeTextureMapper_h
00037 #define __vtkVolumeTextureMapper_h
00038
00039 #include "vtkVolumeMapper.h"
00040 #include "vtkEncodedGradientShader.h"
00041 #include "vtkEncodedGradientEstimator.h"
00042
00043 class vtkVolume;
00044 class vtkRenderer;
00045 class vtkRenderWindow;
00046
00047 class VTK_RENDERING_EXPORT vtkVolumeTextureMapper : public vtkVolumeMapper
00048 {
00049 public:
00050   vtkTypeRevisionMacro(vtkVolumeTextureMapper,vtkVolumeMapper);
00051   void PrintSelf( ostream& os, vtkIndent index );
00052
00054   virtual void Update();
00055
00057
00058   void SetGradientEstimator( vtkEncodedGradientEstimator *gradest );
00059   vtkGetObjectMacro( GradientEstimator, vtkEncodedGradientEstimator );
00061
00063
00064   vtkGetObjectMacro( GradientShader, vtkEncodedGradientShader );
00066
00067 //BTX
00069   /*! Allow access to the arrays / variables from the templated functions
00070       in the subclasses. */
00071   float *GetGradientOpacityArray(){return this->GradientOpacityArray;};
00072   unsigned char *GetRGBAArray(){return this->RGBAArray;};
00073   float *GetRedDiffuseShadingTable(){return this->RedDiffuseShadingTable;};
00074   float *GetGreenDiffuseShadingTable(){return this->GreenDiffuseShadingTable;};
00075   float *GetBlueDiffuseShadingTable(){return this->BlueDiffuseShadingTable;};
00076   float *GetRedSpecularShadingTable(){return this->RedSpecularShadingTable;};
00077   float *GetGreenSpecularShadingTable(){return this->GreenSpecularShadingTable;};
00078   float *GetBlueSpecularShadingTable(){return this->BlueSpecularShadingTable;};
00079   unsigned short *GetEncodedNormals(){return this->EncodedNormals;};
00080   unsigned char *GetGradientMagnitudes(){return this->GradientMagnitudes;};
00081   vtkGetMacro( Shade, int );
00082   vtkGetObjectMacro( RenderWindow, vtkRenderWindow );
00083   vtkGetVectorMacro( DataOrigin, float, 3 );
00084   vtkGetVectorMacro( DataSpacing, float, 3 );
00086
00089   virtual void Render(vtkRenderer *ren, vtkVolume *vol)=0;
00090
00092
00094   virtual float GetGradientMagnitudeScale();
00095   virtual float GetGradientMagnitudeBias();
00097
00098 //ETX
00099
00100
00101
00102 protected:
00103   vtkVolumeTextureMapper();
00104   ~vtkVolumeTextureMapper();
00105
00106   void InitializeRender( vtkRenderer *ren, vtkVolume *vol );
00107
00108   // Objects / variables  needed for shading / gradient magnitude opacity
00109   vtkEncodedGradientEstimator  *GradientEstimator;
00110   vtkEncodedGradientShader     *GradientShader;
00111   int                          Shade;
00112
00113   float          *GradientOpacityArray;
00114   unsigned char  *RGBAArray;
00115   int            ArraySize;
00116
00117   float          *RedDiffuseShadingTable;
00118   float          *GreenDiffuseShadingTable;
00119   float          *BlueDiffuseShadingTable;
00120   float          *RedSpecularShadingTable;
00121   float          *GreenSpecularShadingTable;
00122   float          *BlueSpecularShadingTable;
00123
00124   float          DataOrigin[3];
00125   float          DataSpacing[3];
00126
00127   unsigned short *EncodedNormals;
00128   unsigned char  *GradientMagnitudes;
00129
00130   float          SampleDistance;
00131
00132   vtkRenderWindow *RenderWindow;
00133 private:
00134   vtkVolumeTextureMapper(const vtkVolumeTextureMapper&);  // Not implemented.
00135   void operator=(const vtkVolumeTextureMapper&);  // Not implemented.
00136 };
00137
00138
00139 #endif
00140
00141
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkVoxel.h Source File

Common/vtkVoxel.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVoxel.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkVoxel_h
00042 #define __vtkVoxel_h
00043
00044 #include "vtkCell3D.h"
00045 #include "vtkLine.h"
00046 #include "vtkPixel.h"
00047
00048 class VTK_COMMON_EXPORT vtkVoxel : public vtkCell3D
00049 {
00050 public:
00051   static vtkVoxel *New();
00052   vtkTypeRevisionMacro(vtkVoxel,vtkCell);
00053
00055
00056   virtual void GetEdgePoints(int edgeId, int* &pts);
00057   virtual void GetFacePoints(int faceId, int* &pts);
00059
00061
00062   vtkCell *MakeObject();
00063   int GetCellType() {return VTK_VOXEL;}
00064   int GetCellDimension() {return 3;}
00065   int GetNumberOfEdges() {return 12;}
00066   int GetNumberOfFaces() {return 6;}
00067   vtkCell *GetEdge(int edgeId);
00068   vtkCell *GetFace(int faceId);
00069   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00070   void Contour(float value, vtkDataArray *cellScalars,
00071                vtkPointLocator *locator, vtkCellArray *verts,
00072                vtkCellArray *lines, vtkCellArray *polys,
00073                vtkPointData *inPd, vtkPointData *outPd,
00074                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00075   int EvaluatePosition(float x[3], float* closestPoint,
00076                        int& subId, float pcoords[3],
00077                        float& dist2, float *weights);
00078   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00079                         float *weights);
00080   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00081                         float x[3], float pcoords[3], int& subId);
00082   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00083   void Derivatives(int subId, float pcoords[3], float *values,
00084                    int dim, float *derivs);
00086
00088
00089   static void InterpolationFunctions(float pcoords[3], float weights[8]);
00090   static void InterpolationDerivs(float pcoords[3], float derivs[24]);
00091   static int *GetEdgeArray(int edgeId);
00092   static int *GetFaceArray(int faceId);
00094
00095 protected:
00096   vtkVoxel();
00097   ~vtkVoxel();
00098
00099   vtkLine *Line;
00100   vtkPixel *Pixel;
00101
00102 private:
00103   vtkVoxel(const vtkVoxel&);  // Not implemented.
00104   void operator=(const vtkVoxel&);  // Not implemented.
00105 };
00106
00107 #endif
00108
00109
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkVoxelContoursToSurfaceFilter.h Source File

Graphics/vtkVoxelContoursToSurfaceFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVoxelContoursToSurfaceFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00055 #ifndef __vtkVoxelContoursToSurfaceFilter_h
00056 #define __vtkVoxelContoursToSurfaceFilter_h
00057
00058 #include "vtkPolyDataToPolyDataFilter.h"
00059
00060 class VTK_GRAPHICS_EXPORT vtkVoxelContoursToSurfaceFilter : public vtkPolyDataToPolyDataFilter
00061 {
00062 public:
00063   static vtkVoxelContoursToSurfaceFilter *New();
00064   vtkTypeRevisionMacro(vtkVoxelContoursToSurfaceFilter,vtkPolyDataToPolyDataFilter);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00068
00072   vtkSetMacro( MemoryLimitInBytes, int );
00073   vtkGetMacro( MemoryLimitInBytes, int );
00075
00076   vtkSetVector3Macro( Spacing, float );
00077   vtkGetVectorMacro( Spacing, float, 3 );
00078
00079 protected:
00080   vtkVoxelContoursToSurfaceFilter();
00081   ~vtkVoxelContoursToSurfaceFilter();
00082
00083   void    Execute();
00084
00085   int     MemoryLimitInBytes;
00086
00087   float   Spacing[3];
00088
00089   float   *LineList;
00090   int     LineListLength;
00091   int     LineListSize;
00092
00093   float   *SortedXList;
00094   float   *SortedYList;
00095   int     SortedListSize;
00096
00097   int     *WorkingList;
00098   int     WorkingListLength;
00099
00100   float   *IntersectionList;
00101   int     IntersectionListLength;
00102
00103   void    AddLineToLineList( float x1, float y1, float x2, float y2 );
00104   void    SortLineList();
00105
00106   void    CastLines( float *slice, float gridOrigin[3],
00107                      int gridSize[3], int type );
00108
00109   void    PushDistances( float *ptr, int gridSize[3], int chunkSize );
00110 private:
00111   vtkVoxelContoursToSurfaceFilter(const vtkVoxelContoursToSurfaceFilter&);  // Not implemented.
00112   void operator=(const vtkVoxelContoursToSurfaceFilter&);  // Not implemented.
00113 };
00114
00115 #endif
00116
00117
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Imaging/vtkVoxelModeller.h Source File

Imaging/vtkVoxelModeller.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVoxelModeller.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkVoxelModeller_h
00044 #define __vtkVoxelModeller_h
00045
00046 #include "vtkDataSetToStructuredPointsFilter.h"
00047
00048 class VTK_IMAGING_EXPORT vtkVoxelModeller : public vtkDataSetToStructuredPointsFilter
00049 {
00050 public:
00051   vtkTypeRevisionMacro(vtkVoxelModeller,vtkDataSetToStructuredPointsFilter);
00052   void PrintSelf(ostream& os, vtkIndent indent);
00053
00059   static vtkVoxelModeller *New();
00060
00062   float ComputeModelBounds(float origin[3], float ar[3]);
00063
00065   void SetSampleDimensions(int i, int j, int k);
00066
00068
00069   void SetSampleDimensions(int dim[3]);
00070   vtkGetVectorMacro(SampleDimensions,int,3);
00072
00074
00076   vtkSetClampMacro(MaximumDistance,float,0.0,1.0);
00077   vtkGetMacro(MaximumDistance,float);
00079
00081
00082   void SetModelBounds(float bounds[6]);
00083   void SetModelBounds(float xmin, float xmax, float ymin, float ymax, float zmin, float zmax);
00084   vtkGetVectorMacro(ModelBounds,float,6);
00086
00088   void Write(char *);
00089
00090 protected:
00091   vtkVoxelModeller();
00092   ~vtkVoxelModeller() {};
00093
00094   void Execute();
00095   int SampleDimensions[3];
00096   float MaximumDistance;
00097   float ModelBounds[6];
00098 private:
00099   vtkVoxelModeller(const vtkVoxelModeller&);  // Not implemented.
00100   void operator=(const vtkVoxelModeller&);  // Not implemented.
00101 };
00102
00103 #endif
Generated on Mon Mar 25 01:07:51 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkVRML.h Source File

Hybrid/vtkVRML.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVRML.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00016 /* ======================================================================
00017
00018    Importer based on BNF Yacc and Lex parser definition from:
00019
00020     **************************************************
00021         * VRML 2.0 Parser
00022         * Copyright (C) 1996 Silicon Graphics, Inc.
00023         *
00024         * Author(s) :    Gavin Bell
00025         *                Daniel Woods (first port)
00026         **************************************************
00027
00028   Ported to VTK By:     Thomas D. Citriniti
00029                         Rensselaer Polytechnic Institute
00030                         citrit@rpi.edu
00031
00032 =======================================================================*/
00033 #ifndef _VTKVRML_H_
00034 #define _VTKVRML_H_
00035
00036 #define DEFAULTINCREMENT        100
00037 #include <stdlib.h>
00038
00039 #include "vtkConfigure.h"
00040
00041 #ifdef VTK_USE_ANSI_STDLIB
00042 #include <new>
00043 #include <iostream>
00044 #else
00045 #include <new.h>
00046 #include <iostream.h>
00047 #endif
00048
00049 #ifdef __BORLANDC__
00050 // seems to be missing from new.h and new for borland
00051 void* operator new[](unsigned int,void *v)
00052 {
00053   return v;
00054 }
00055 #endif
00056
00057 #include <string.h>
00058
00059 #include "vtkWin32Header.h"
00060
00061 // Use a user-managed heap to remove memory leaks
00062 // This code must come before "#include vtkVRML.h" because
00063 // it uses the functions below.
00064 #include "vtkHeap.h"
00065 struct vtkVRMLAllocator
00066 {
00067   static void Initialize();
00068   static void *AllocateMemory(size_t n);
00069   static void CleanUp();
00070   static char* StrDup(const char *str);
00071   static vtkHeap *Heap;
00072 };
00073
00074
00075
00076 template <class T>
00077 class VTK_HYBRID_EXPORT VectorType
00078 {
00079 protected:
00080   T *Data;
00081   int Allocated;
00082   int Used;
00083 public:
00084   void Init()
00085     {
00086       Allocated=DEFAULTINCREMENT;
00087       if (!this->UseNew)
00088         {
00089         vtkVRMLAllocator::Initialize();
00090         void* mem = vtkVRMLAllocator::AllocateMemory(Allocated*sizeof(T));
00091         Data=new(mem) T[Allocated];
00092         }
00093       else
00094         {
00095         Data = new T[Allocated];
00096         }
00097       Used=0;
00098     }
00099   VectorType()
00100     {
00101       this->UseNew = 0;
00102       this->Init();
00103     }
00104   VectorType(int usenew) : UseNew(usenew)
00105     {
00106       this->Init();
00107     }
00108   ~VectorType(void)
00109     {
00110       if (this->UseNew)
00111         {
00112         delete[] Data;
00113         }
00114     }
00115   void Reserve(int newSize)
00116     {
00117       T *temp;
00118       int oldSize;
00119       if(newSize >= Allocated)
00120         {
00121         oldSize=Allocated;
00122         Allocated=newSize+DEFAULTINCREMENT;
00123         temp=Data;
00124         if (!this->UseNew)
00125           {
00126           void* mem = vtkVRMLAllocator::AllocateMemory(Allocated*sizeof(T));
00127           Data=new(mem) T[Allocated];
00128           }
00129         else
00130           {
00131           Data=new T[Allocated];
00132           }
00133         if(Data==(T *)'\0')
00134           {
00135           return;
00136           }
00137         memcpy((void*)Data, (void*)temp, oldSize*sizeof(T));
00138         if (this->UseNew)
00139           {
00140           delete[] temp;
00141           }
00142         }
00143     }
00144
00145   void Demand(int newSize)
00146     {
00147       Reserve(newSize);
00148       Used=newSize;
00149     }
00150   int Count(void) const
00151     {
00152       return Used;
00153     }
00154   T& Get(int index) const
00155     {
00156       if (index > Used)
00157         return Data[Used-1];
00158       return Data[index];
00159     }
00160   T& operator[](int index)
00161     {
00162       if (index > Used)
00163         Demand(index);
00164       return Data[index];
00165     }
00166   operator T*() const
00167     {
00168       return Data;
00169     }
00170   VectorType<T>& operator+=(T datum)
00171     {
00172       Reserve(Used+1);
00173       Data[Used]=datum;
00174       Used++;
00175       return *this;
00176     }
00177   void Push(T datum)
00178     {
00179       Reserve(Used+1);
00180       Data[Used]=datum;
00181       Used++;
00182     }
00183   T& Pop()
00184     {
00185       Used--;
00186       return Data[Used];
00187     }
00188   T& Top()
00189     {
00190       return Data[Used-1];
00191     }
00192
00193   void* operator new(size_t n)
00194     {
00195       return vtkVRMLAllocator::AllocateMemory(n);
00196     }
00197
00198   void operator delete(void *)
00199     {
00200     }
00201
00202   int UseNew;
00203 };
00204
00205 static const char standardNodes[][2042] = {
00206   "#VRML V2.0 utf8 \n\
00207 # \n\
00208 # ************************************************** \n\
00209 # * VRML 2.0 Parser \n\
00210 # * Copyright (C) 1996 Silicon Graphics, Inc. \n\
00211 # * \n\
00212 # * Author(s)    : Gavin Bell \n\
00213 # *                Daniel Woods (first port) \n\
00214 # ************************************************** \n\
00215 # \n\
00216 # Definitions for all of the nodes built-in to the spec. \n\
00217 # Taken almost directly from the VRML 2.0 final spec: \n\
00218  \n\
00219 PROTO Anchor [ \n\
00220   eventIn      MFNode   addChildren \n\
00221   eventIn      MFNode   removeChildren \n\
00222   exposedField MFNode   children        [] \n\
00223   exposedField SFString description     \"\"  \n\
00224   exposedField MFString parameter       [] \n\
00225   exposedField MFString url             [] \n\
00226   field        SFVec3f  bboxCenter      0.0 0.0 0.0 \n\
00227   field        SFVec3f  bboxSize        -1.0 -1.0 -1.0 \n\
00228 ] { } \n\
00229  \n\
00230 PROTO Appearance [ \n\
00231   exposedField SFNode material          NULL \n\
00232   exposedField SFNode texture           NULL \n\
00233   exposedField SFNode textureTransform  NULL \n\
00234 ] { } \n\
00235  \n\
00236 PROTO AudioClip [ \n\
00237   exposedField   SFString description  \"\" \n\
00238   exposedField   SFBool   loop         FALSE \n\
00239   exposedField   SFFloat  pitch        1.0 \n\
00240   exposedField   SFTime   startTime    0 \n\
00241   exposedField   SFTime   stopTime     0 \n\
00242   exposedField   MFString url          [] \n\
00243   eventOut       SFTime   duration_changed \n\
00244   eventOut       SFBool   isActive \n\
00245 ] { } \n\
00246  \n\
00247 PROTO Background [ \n\
00248   eventIn      SFBool   set_bind \n\
00249   exposedField MFFloat  groundAngle  [] \n\
00250   exposedField MFColor  groundColor  [] \n\
00251   exposedField MFString backUrl      [] \n\
00252   exposedField MFString bottomUrl    [] \n\
00253   exposedField MFString frontUrl     [] \n\
00254   exposedField MFString leftUrl      [] \n\
00255   exposedField MFString rightUrl     [] \n\
00256   exposedField MFString topUrl       [] \n\
00257   exposedField MFFloat  skyAngle     [] \n\
00258   exposedField MFColor  skyColor     [ 0 0 0  ] \n\
00259   eventOut     SFBool   isBound \n\
00260 ] { }",
00261   "PROTO Billboard [ \n\
00262   eventIn      MFNode   addChildren \n\
00263   eventIn      MFNode   removeChildren \n\
00264   exposedField SFVec3f  axisOfRotation  0 1 0 \n\
00265   exposedField MFNode   children        [] \n\
00266   field        SFVec3f  bboxCenter      0 0 0 \n\
00267   field        SFVec3f  bboxSize        -1 -1 -1 \n\
00268 ] { } \n\
00269  \n\
00270 PROTO Box [ \n\
00271   field    SFVec3f size  2 2 2  \n\
00272 ] { } \n\
00273  \n\
00274 PROTO Collision [  \n\
00275   eventIn      MFNode   addChildren \n\
00276   eventIn      MFNode   removeChildren \n\
00277   exposedField MFNode   children        [] \n\
00278   exposedField SFBool   collide         TRUE \n\
00279   field        SFVec3f  bboxCenter      0 0 0 \n\
00280   field        SFVec3f  bboxSize        -1 -1 -1 \n\
00281   field        SFNode   proxy           NULL \n\
00282   eventOut     SFTime   collideTime \n\
00283 ] { } \n\
00284  \n\
00285 PROTO Color [ \n\
00286   exposedField MFColor color     [] \n\
00287 ] { } \n\
00288  \n\
00289 PROTO ColorInterpolator [ \n\
00290   eventIn      SFFloat set_fraction \n\
00291   exposedField MFFloat key       [] \n\
00292   exposedField MFColor keyValue  [] \n\
00293   eventOut     SFColor value_changed \n\
00294 ] { } \n\
00295  \n\
00296 PROTO Cone [ \n\
00297   field     SFFloat   bottomRadius 1 \n\
00298   field     SFFloat   height       2 \n\
00299   field     SFBool    side         TRUE \n\
00300   field     SFBool    bottom       TRUE \n\
00301 ] { } \n\
00302  \n\
00303 PROTO Coordinate [ \n\
00304   exposedField MFVec3f point  [] \n\
00305 ] { } \n\
00306  \n\
00307 PROTO CoordinateInterpolator [ \n\
00308   eventIn      SFFloat set_fraction \n\
00309   exposedField MFFloat key       [] \n\
00310   exposedField MFVec3f keyValue  [] \n\
00311   eventOut     MFVec3f value_changed \n\
00312 ] { } \n\
00313  \n\
00314 PROTO Cylinder [ \n\
00315   field    SFBool    bottom  TRUE \n\
00316   field    SFFloat   height  2 \n\
00317   field    SFFloat   radius  1 \n\
00318   field    SFBool    side    TRUE \n\
00319   field    SFBool    top     TRUE \n\
00320 ] { } \n\
00321  \n\
00322 PROTO CylinderSensor [ \n\
00323   exposedField SFBool     autoOffset TRUE \n\
00324   exposedField SFFloat    diskAngle  0.262 \n\
00325   exposedField SFBool     enabled    TRUE \n\
00326   exposedField SFFloat    maxAngle   -1 \n\
00327   exposedField SFFloat    minAngle   0 \n\
00328   exposedField SFFloat    offset     0 \n\
00329   eventOut     SFBool     isActive \n\
00330   eventOut     SFRotation rotation_changed \n\
00331   eventOut     SFVec3f    trackPoint_changed \n\
00332 ] { }",
00333   "PROTO DirectionalLight [ \n\
00334   exposedField SFFloat ambientIntensity  0  \n\
00335   exposedField SFColor color             1 1 1 \n\
00336   exposedField SFVec3f direction         0 0 -1 \n\
00337   exposedField SFFloat intensity         1  \n\
00338   exposedField SFBool  on                TRUE  \n\
00339 ] { } \n\
00340  \n\
00341 PROTO ElevationGrid [ \n\
00342   eventIn      MFFloat  set_height \n\
00343   exposedField SFNode   color             NULL \n\
00344   exposedField SFNode   normal            NULL \n\
00345   exposedField SFNode   texCoord          NULL \n\
00346   field        SFBool   ccw               TRUE \n\
00347   field        SFBool   colorPerVertex    TRUE \n\
00348   field        SFFloat  creaseAngle       0 \n\
00349   field        MFFloat  height            [] \n\
00350   field        SFBool   normalPerVertex   TRUE \n\
00351   field        SFBool   solid             TRUE \n\
00352   field        SFInt32  xDimension        0 \n\
00353   field        SFFloat  xSpacing          0.0 \n\
00354   field        SFInt32  zDimension        0 \n\
00355   field        SFFloat  zSpacing          0.0 \n\
00356  \n\
00357 ] { } \n\
00358  \n\
00359 PROTO Extrusion [ \n\
00360   eventIn MFVec2f    set_crossSection \n\
00361   eventIn MFRotation set_orientation \n\
00362   eventIn MFVec2f    set_scale \n\
00363   eventIn MFVec3f    set_spine \n\
00364   field   SFBool     beginCap         TRUE \n\
00365   field   SFBool     ccw              TRUE \n\
00366   field   SFBool     convex           TRUE \n\
00367   field   SFFloat    creaseAngle      0 \n\
00368   field   MFVec2f    crossSection     [ 1 1, 1 -1, -1 -1, -1 1, 1 1 ] \n\
00369   field   SFBool     endCap           TRUE \n\
00370   field   MFRotation orientation      0 0 1 0 \n\
00371   field   MFVec2f    scale            1 1 \n\
00372   field   SFBool     solid            TRUE \n\
00373   field   MFVec3f    spine            [ 0 0 0, 0 1 0 ] \n\
00374 ] { } \n\
00375  \n\
00376 PROTO Fog [ \n\
00377   exposedField SFColor  color            1 1 1 \n\
00378   exposedField SFString fogType          \"LINEAR\" \n\
00379   exposedField SFFloat  visibilityRange  0 \n\
00380   eventIn      SFBool   set_bind \n\
00381   eventOut     SFBool   isBound \n\
00382 ] { }",
00383   "PROTO FontStyle [ \n\
00384   field SFString family     \"SERIF\" \n\
00385   field SFBool   horizontal  TRUE \n\
00386   field MFString justify     \"BEGIN\" \n\
00387   field SFString language    \"\" \n\
00388   field SFBool   leftToRight TRUE \n\
00389   field SFFloat  size       1.0 \n\
00390   field SFFloat  spacing     1.0 \n\
00391   field SFString style       \"PLAIN\" \n\
00392   field SFBool   topToBottom TRUE \n\
00393 ] { } \n\
00394  \n\
00395 PROTO Group [ \n\
00396   eventIn      MFNode  addChildren \n\
00397   eventIn      MFNode  removeChildren \n\
00398   exposedField MFNode  children   [] \n\
00399   field        SFVec3f bboxCenter 0 0 0 \n\
00400   field        SFVec3f bboxSize   -1 -1 -1 \n\
00401 ] { } \n\
00402  \n\
00403 PROTO ImageTexture [ \n\
00404   exposedField MFString url     [] \n\
00405   field        SFBool   repeatS TRUE \n\
00406   field        SFBool   repeatT TRUE \n\
00407 ] { } \n\
00408  \n\
00409 PROTO IndexedFaceSet [  \n\
00410   eventIn       MFInt32 set_colorIndex \n\
00411   eventIn       MFInt32 set_coordIndex \n\
00412   eventIn       MFInt32 set_normalIndex \n\
00413   eventIn       MFInt32 set_texCoordIndex \n\
00414   exposedField  SFNode  color             NULL \n\
00415   exposedField  SFNode  coord             NULL \n\
00416   exposedField  SFNode  normal            NULL \n\
00417   exposedField  SFNode  texCoord          NULL \n\
00418   field         SFBool  ccw               TRUE \n\
00419   field         MFInt32 colorIndex        [] \n\
00420   field         SFBool  colorPerVertex    TRUE \n\
00421   field         SFBool  convex            TRUE \n\
00422   field         MFInt32 coordIndex        [] \n\
00423   field         SFFloat creaseAngle       0 \n\
00424   field         MFInt32 normalIndex       [] \n\
00425   field         SFBool  normalPerVertex   TRUE \n\
00426   field         SFBool  solid             TRUE \n\
00427   field         MFInt32 texCoordIndex     [] \n\
00428 ] { } \n\
00429  \n\
00430 PROTO IndexedLineSet [ \n\
00431   eventIn       MFInt32 set_colorIndex \n\
00432   eventIn       MFInt32 set_coordIndex \n\
00433   exposedField  SFNode  color             NULL \n\
00434   exposedField  SFNode  coord             NULL \n\
00435   field         MFInt32 colorIndex        [] \n\
00436   field         SFBool  colorPerVertex    TRUE \n\
00437   field         MFInt32 coordIndex        [] \n\
00438 ] { }",
00439   "PROTO Inline [ \n\
00440   exposedField MFString url        [] \n\
00441   field        SFVec3f  bboxCenter 0 0 0 \n\
00442   field        SFVec3f  bboxSize   -1 -1 -1 \n\
00443 ] { } \n\
00444 PROTO LOD [ \n\
00445   exposedField MFNode  level    []  \n\
00446   field        SFVec3f center   0 0 0 \n\
00447   field        MFFloat range    []  \n\
00448 ] { } \n\
00449  \n\
00450 PROTO Material [ \n\
00451   exposedField SFFloat ambientIntensity  0.2 \n\
00452   exposedField SFColor diffuseColor      0.8 0.8 0.8 \n\
00453   exposedField SFColor emissiveColor     0 0 0 \n\
00454   exposedField SFFloat shininess         0.2 \n\
00455   exposedField SFColor specularColor     0 0 0 \n\
00456   exposedField SFFloat transparency      0 \n\
00457 ] { } \n\
00458  \n\
00459 PROTO MovieTexture [ \n\
00460   exposedField SFBool   loop       FALSE \n\
00461   exposedField SFFloat  speed      1 \n\
00462   exposedField SFTime   startTime  0 \n\
00463   exposedField SFTime   stopTime   0 \n\
00464   exposedField MFString url       [] \n\
00465   field        SFBool   repeatS    TRUE \n\
00466   field        SFBool   repeatT    TRUE \n\
00467   eventOut     SFFloat  duration_changed \n\
00468   eventOut     SFBool   isActive \n\
00469 ] { } \n\
00470  \n\
00471 PROTO NavigationInfo [ \n\
00472   eventIn      SFBool   set_bind \n\
00473   exposedField MFFloat  avatarSize       [ 0.25, 1.6, 0.75 ] \n\
00474   exposedField SFBool   headlight        TRUE \n\
00475   exposedField SFFloat  speed            1.0  \n\
00476   exposedField MFString type             \"WALK\"  \n\
00477   exposedField SFFloat  visibilityLimit  0.0  \n\
00478   eventOut     SFBool   isBound \n\
00479 ] { } \n\
00480  \n\
00481 PROTO Normal [ \n\
00482   exposedField MFVec3f vector [] \n\
00483 ] { } \n\
00484  \n\
00485 PROTO NormalInterpolator [ \n\
00486   eventIn      SFFloat set_fraction \n\
00487   exposedField MFFloat key       [] \n\
00488   exposedField MFVec3f keyValue  [] \n\
00489   eventOut     MFVec3f value_changed \n\
00490 ] { } \n\
00491  \n\
00492 PROTO OrientationInterpolator [ \n\
00493   eventIn      SFFloat    set_fraction \n\
00494   exposedField MFFloat    key       [] \n\
00495   exposedField MFRotation keyValue  [] \n\
00496   eventOut     SFRotation value_changed \n\
00497 ] { } \n\
00498  \n\
00499 PROTO PixelTexture [ \n\
00500   exposedField SFImage  image      0 0 0 \n\
00501   field        SFBool   repeatS    TRUE \n\
00502   field        SFBool   repeatT    TRUE \n\
00503 ] { }",
00504   "PROTO PlaneSensor [ \n\
00505   exposedField SFBool  autoOffset  TRUE \n\
00506   exposedField SFBool  enabled     TRUE \n\
00507   exposedField SFVec2f maxPosition -1 -1 \n\
00508   exposedField SFVec2f minPosition 0 0 \n\
00509   exposedField SFVec3f offset      0 0 0 \n\
00510   eventOut     SFBool  isActive \n\
00511   eventOut     SFVec3f trackPoint_changed \n\
00512   eventOut     SFVec3f translation_changed \n\
00513 ] { } \n\
00514  \n\
00515 PROTO PointLight [ \n\
00516   exposedField SFFloat ambientIntensity  0  \n\
00517   exposedField SFVec3f attenuation       1 0 0 \n\
00518   exposedField SFColor color             1 1 1  \n\
00519   exposedField SFFloat intensity         1 \n\
00520   exposedField SFVec3f location          0 0 0 \n\
00521   exposedField SFBool  on                TRUE  \n\
00522   exposedField SFFloat radius            100 \n\
00523 ] { } \n\
00524  \n\
00525 PROTO PointSet [ \n\
00526   exposedField  SFNode  color      NULL \n\
00527   exposedField  SFNode  coord      NULL \n\
00528 ] { } \n\
00529  \n\
00530 PROTO PositionInterpolator [ \n\
00531   eventIn      SFFloat set_fraction \n\
00532   exposedField MFFloat key       [] \n\
00533   exposedField MFVec3f keyValue  [] \n\
00534   eventOut     SFVec3f value_changed \n\
00535 ] { } \n\
00536  \n\
00537 PROTO ProximitySensor [ \n\
00538   exposedField SFVec3f    center      0 0 0 \n\
00539   exposedField SFVec3f    size        0 0 0 \n\
00540   exposedField SFBool     enabled     TRUE \n\
00541   eventOut     SFBool     isActive \n\
00542   eventOut     SFVec3f    position_changed \n\
00543   eventOut     SFRotation orientation_changed \n\
00544   eventOut     SFTime     enterTime \n\
00545   eventOut     SFTime     exitTime \n\
00546 ] { }",
00547   "PROTO ScalarInterpolator [ \n\
00548   eventIn      SFFloat set_fraction \n\
00549   exposedField MFFloat key       [] \n\
00550   exposedField MFFloat keyValue  [] \n\
00551   eventOut     SFFloat value_changed \n\
00552 ] { } \n\
00553  \n\
00554 PROTO Script [ \n\
00555   exposedField MFString url           [ ]  \n\
00556   field        SFBool   directOutput  FALSE \n\
00557   field        SFBool   mustEvaluate  FALSE \n\
00558 ] { } \n\
00559  \n\
00560 PROTO Shape [ \n\
00561   field SFNode appearance NULL \n\
00562   field SFNode geometry   NULL \n\
00563 ] { } \n\
00564  \n\
00565 PROTO Sound [ \n\
00566   exposedField SFVec3f  direction     0 0 1 \n\
00567   exposedField SFFloat  intensity     1 \n\
00568   exposedField SFVec3f  location      0 0 0 \n\
00569   exposedField SFFloat  maxBack       10 \n\
00570   exposedField SFFloat  maxFront      10 \n\
00571   exposedField SFFloat  minBack       1 \n\
00572   exposedField SFFloat  minFront      1 \n\
00573   exposedField SFFloat  priority      0 \n\
00574   exposedField SFNode   source        NULL \n\
00575   field        SFBool   spatialize    TRUE \n\
00576 ] { } \n\
00577  \n\
00578 PROTO Sphere [ \n\
00579   field SFFloat radius  1 \n\
00580 ] { } \n\
00581  \n\
00582 PROTO SphereSensor [ \n\
00583   exposedField SFBool     autoOffset TRUE \n\
00584   exposedField SFBool     enabled    TRUE \n\
00585   exposedField SFRotation offset     0 1 0 0 \n\
00586   eventOut     SFBool     isActive \n\
00587   eventOut     SFRotation rotation_changed \n\
00588   eventOut     SFVec3f    trackPoint_changed \n\
00589 ] { } \n\
00590  \n\
00591 PROTO SpotLight [ \n\
00592   exposedField SFFloat ambientIntensity  0  \n\
00593   exposedField SFVec3f attenuation       1 0 0 \n\
00594   exposedField SFFloat beamWidth         1.570796 \n\
00595   exposedField SFColor color             1 1 1  \n\
00596   exposedField SFFloat cutOffAngle       0.785398  \n\
00597   exposedField SFVec3f direction         0 0 -1 \n\
00598   exposedField SFFloat intensity         1   \n\
00599   exposedField SFVec3f location          0 0 0   \n\
00600   exposedField SFBool  on                TRUE \n\
00601   exposedField SFFloat radius            100 \n\
00602 ] { } \n\
00603  \n\
00604 PROTO Switch [ \n\
00605   exposedField    MFNode  choice      [] \n\
00606   exposedField    SFInt32 whichChoice -1 \n\
00607 ] { } \n\
00608  \n\
00609 PROTO Text [ \n\
00610   exposedField  MFString string    [] \n\
00611   field         SFNode   fontStyle NULL \n\
00612   field         MFFloat  length    [] \n\
00613   field         SFFloat  maxExtent 0.0 \n\
00614 ] { }",
00615   "PROTO TextureCoordinate [ \n\
00616   exposedField MFVec2f point [] \n\
00617 ] { } \n\
00618 PROTO TextureTransform [ \n\
00619   exposedField SFVec2f center      0 0 \n\
00620   exposedField SFFloat rotation    0 \n\
00621   exposedField SFVec2f scale       1 1 \n\
00622   exposedField SFVec2f translation 0 0 \n\
00623 ] { } \n\
00624  \n\
00625 PROTO TimeSensor [ \n\
00626   exposedField SFTime   cycleInterval 1 \n\
00627   exposedField SFBool   enabled       TRUE \n\
00628   exposedField SFBool   loop          FALSE \n\
00629   exposedField SFTime   startTime     0 \n\
00630   exposedField SFTime   stopTime      0 \n\
00631   eventOut     SFTime   cycleTime \n\
00632   eventOut     SFFloat  fraction_changed \n\
00633   eventOut     SFBool   isActive \n\
00634   eventOut     SFTime   time \n\
00635 ] { } \n\
00636  \n\
00637 PROTO TouchSensor [ \n\
00638   exposedField SFBool  enabled TRUE \n\
00639   eventOut     SFVec3f hitNormal_changed \n\
00640   eventOut     SFVec3f hitPoint_changed \n\
00641   eventOut     SFVec2f hitTexCoord_changed \n\
00642   eventOut     SFBool  isActive \n\
00643   eventOut     SFBool  isOver \n\
00644   eventOut     SFTime  touchTime \n\
00645 ] { } \n\
00646  \n\
00647 PROTO Transform [ \n\
00648   eventIn      MFNode      addChildren \n\
00649   eventIn      MFNode      removeChildren \n\
00650   exposedField SFVec3f     center           0 0 0 \n\
00651   exposedField MFNode      children         [] \n\
00652   exposedField SFRotation  rotation         0 0 1  0 \n\
00653   exposedField SFVec3f     scale            1 1 1 \n\
00654   exposedField SFRotation  scaleOrientation 0 0 1  0 \n\
00655   exposedField SFVec3f     translation      0 0 0 \n\
00656   field        SFVec3f     bboxCenter       0 0 0 \n\
00657   field        SFVec3f     bboxSize         -1 -1 -1 \n\
00658 ] { } \n\
00659  \n\
00660 PROTO Viewpoint [ \n\
00661   eventIn      SFBool     set_bind \n\
00662   exposedField SFFloat    fieldOfView    0.785398 \n\
00663   exposedField SFBool     jump           TRUE \n\
00664   exposedField SFRotation orientation    0 0 1  0 \n\
00665   exposedField SFVec3f    position       0 0 10 \n\
00666   field        SFString   description    \"\" \n\
00667   eventOut     SFTime     bindTime \n\
00668   eventOut     SFBool     isBound \n\
00669 ] { }",
00670   "PROTO VisibilitySensor [ \n\
00671   exposedField SFVec3f center   0 0 0 \n\
00672   exposedField SFBool  enabled  TRUE \n\
00673   exposedField SFVec3f size     0 0 0 \n\
00674   eventOut     SFTime  enterTime \n\
00675   eventOut     SFTime  exitTime \n\
00676   eventOut     SFBool  isActive \n\
00677 ] { } \n\
00678  \n\
00679 PROTO WorldInfo [ \n\
00680   field MFString info  [] \n\
00681   field SFString title \"\" \n\
00682 ] { }",""
00683 };
00684 #endif
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkVRMLExporter.h Source File

Rendering/vtkVRMLExporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVRMLExporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkVRMLExporter_h
00043 #define __vtkVRMLExporter_h
00044
00045 #include <stdio.h>
00046 #include "vtkExporter.h"
00047
00048 class VTK_RENDERING_EXPORT vtkVRMLExporter : public vtkExporter
00049 {
00050 public:
00051   static vtkVRMLExporter *New();
00052   vtkTypeRevisionMacro(vtkVRMLExporter,vtkExporter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetStringMacro(FileName);
00058   vtkGetStringMacro(FileName);
00060
00062
00063   vtkSetMacro(Speed,float);
00064   vtkGetMacro(Speed,float);
00066
00069   void SetFilePointer(FILE *);
00070
00071 protected:
00072   vtkVRMLExporter();
00073   ~vtkVRMLExporter();
00074
00075   void WriteData();
00076   void WriteALight(vtkLight *aLight, FILE *fp);
00077   void WriteAnActor(vtkActor *anActor, FILE *fp);
00078   void WritePointData(vtkPoints *points, vtkDataArray *normals,
00079                       vtkDataArray *tcoords, vtkUnsignedCharArray *colors,
00080                       FILE *fp);
00081   char *FileName;
00082   FILE *FilePointer;
00083   float Speed;
00084 private:
00085   vtkVRMLExporter(const vtkVRMLExporter&);  // Not implemented.
00086   void operator=(const vtkVRMLExporter&);  // Not implemented.
00087 };
00088
00089 #endif
00090
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkVRMLImporter.h Source File

Hybrid/vtkVRMLImporter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkVRMLImporter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkVRMLImporter_h
00063 #define __vtkVRMLImporter_h
00064
00065 // Includes for the yacc/lex parser
00066 #include "vtkVRML.h"
00067
00068 #include "vtkImporter.h"
00069 class  vtkActor;
00070 class  vtkProperty;
00071 class  vtkCamera;
00072 class  vtkLight;
00073 class  vtkTransform;
00074 class  vtkSource;
00075 class  vtkLookupTable;
00076 class  vtkFloatArray;
00077 class  vtkPolyDataMapper;
00078 class vtkPoints;
00079
00080 class VTK_HYBRID_EXPORT vtkVRMLImporter : public vtkImporter
00081 {
00082 public:
00083   static vtkVRMLImporter *New();
00084
00085   vtkTypeRevisionMacro(vtkVRMLImporter,vtkImporter);
00086   void PrintSelf(ostream& os, vtkIndent indent);
00087
00093   vtkObject *GetVRMLDEFObject(const char *name);
00094
00096
00097   void enterNode(const char *);
00098   void exitNode();
00099   void enterField(const char *);
00100   void exitField();
00101   void useNode(const char *);
00103
00105
00106   vtkSetStringMacro(FileName);
00107   vtkGetStringMacro(FileName);
00109
00111   FILE *GetFileFD() {return this->FileFD;};
00112
00113 //BTX
00114
00115   friend int yylex ( vtkVRMLImporter* );
00116
00117 //ETX
00118
00119 protected:
00120   vtkVRMLImporter();
00121   ~vtkVRMLImporter();
00122
00123   virtual int ImportBegin ();
00124   virtual void ImportEnd ();
00125   virtual void ImportActors (vtkRenderer *) {};
00126   virtual void ImportCameras (vtkRenderer *) {};
00127   virtual void ImportLights (vtkRenderer *) {};
00128   virtual void ImportProperties (vtkRenderer *) {};
00129
00130   int OpenImportFile();
00131   char *FileName;
00132   FILE *FileFD;
00133
00134 private:
00135   vtkActor             *CurrentActor;
00136   vtkProperty          *CurrentProperty;
00137   vtkCamera            *CurrentCamera;
00138   vtkLight             *CurrentLight;
00139   vtkTransform         *CurrentTransform;
00140   vtkSource            *CurrentSource;
00141   vtkPoints            *CurrentPoints;
00142   vtkFloatArray         *CurrentNormals;
00143   vtkLookupTable       *CurrentLut;
00144   vtkFloatArray        *CurrentScalars;
00145   vtkPolyDataMapper    *CurrentMapper;
00146
00147   vtkPoints* PointsNew();
00148   vtkIdTypeArray* IdTypeArrayNew();
00149
00150   void DeleteObject(vtkObject*);
00151
00152 //BTX
00153
00154 #ifdef WIN32
00155 #pragma warning( disable : 4251 )
00156 #endif
00157
00158   VectorType<vtkObject*> Heap;
00159
00160 #ifdef WIN32
00161 #pragma warning( default : 4251 )
00162 #endif
00163
00164 //ETX
00165
00166 private:
00167   vtkVRMLImporter(const vtkVRMLImporter&);  // Not implemented.
00168   void operator=(const vtkVRMLImporter&);  // Not implemented.
00169 };
00170
00171 #endif
00172
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkWarpLens.h Source File

Graphics/vtkWarpLens.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWarpLens.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkWarpLens_h
00037 #define __vtkWarpLens_h
00038
00039 #include "vtkPointSetToPointSetFilter.h"
00040
00041 class VTK_GRAPHICS_EXPORT vtkWarpLens : public vtkPointSetToPointSetFilter
00042 {
00043 public:
00044   static vtkWarpLens *New();
00045   vtkTypeRevisionMacro(vtkWarpLens,vtkPointSetToPointSetFilter);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00049
00051   void SetKappa(float kappa);
00052   float GetKappa();
00054
00056
00058   void SetCenter(float centerX, float centerY);
00059   float *GetCenter();
00061
00063
00064   vtkSetVector2Macro(PrincipalPoint,float);
00065   vtkGetVectorMacro(PrincipalPoint,float,2);
00067
00069
00070   vtkSetMacro(K1,float);
00071   vtkGetMacro(K1,float);
00072   vtkSetMacro(K2,float);
00073   vtkGetMacro(K2,float);
00075
00077
00078   vtkSetMacro(P1,float);
00079   vtkGetMacro(P1,float);
00080   vtkSetMacro(P2,float);
00081   vtkGetMacro(P2,float);
00083
00085
00086   vtkSetMacro(FormatWidth,float);
00087   vtkGetMacro(FormatWidth,float);
00088   vtkSetMacro(FormatHeight,float);
00089   vtkGetMacro(FormatHeight,float);
00091
00093
00094   vtkSetMacro(ImageWidth,int);
00095   vtkGetMacro(ImageWidth,int);
00096   vtkSetMacro(ImageHeight,int);
00097   vtkGetMacro(ImageHeight,int);
00099
00100
00101 protected:
00102   vtkWarpLens();
00103   ~vtkWarpLens() {};
00104
00105   void Execute();
00106
00107   float PrincipalPoint[2];      // The calibrated principal point of camera/lens in mm
00108   float K1;                     // Symmetric radial distortion parameters
00109   float K2;
00110   float P1;                     // Decentering distortion parameters
00111   float P2;
00112   float FormatWidth;            // imager format width in mm
00113   float FormatHeight;           // imager format height in mm
00114   int ImageWidth;               // image width in pixels
00115   int ImageHeight;              // image height in pixels
00116 private:
00117   vtkWarpLens(const vtkWarpLens&);  // Not implemented.
00118   void operator=(const vtkWarpLens&);  // Not implemented.
00119 };
00120
00121 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkWarpScalar.h Source File

Graphics/vtkWarpScalar.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWarpScalar.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00057 #ifndef __vtkWarpScalar_h
00058 #define __vtkWarpScalar_h
00059
00060 #include "vtkPointSetToPointSetFilter.h"
00061
00062 class VTK_GRAPHICS_EXPORT vtkWarpScalar : public vtkPointSetToPointSetFilter
00063 {
00064 public:
00065   static vtkWarpScalar *New();
00066   vtkTypeRevisionMacro(vtkWarpScalar,vtkPointSetToPointSetFilter);
00067   void PrintSelf(ostream& os, vtkIndent indent);
00068
00070
00071   vtkSetMacro(ScaleFactor,float);
00072   vtkGetMacro(ScaleFactor,float);
00074
00076
00078   vtkSetMacro(UseNormal,int);
00079   vtkGetMacro(UseNormal,int);
00080   vtkBooleanMacro(UseNormal,int);
00082
00084
00086   vtkSetVector3Macro(Normal,float);
00087   vtkGetVectorMacro(Normal,float,3);
00089
00091
00095   vtkSetMacro(XYPlane,int);
00096   vtkGetMacro(XYPlane,int);
00097   vtkBooleanMacro(XYPlane,int);
00099
00101
00104   vtkGetStringMacro(InputScalarsSelection);
00105   void SelectInputScalars(const char *fieldName)
00106     {this->SetInputScalarsSelection(fieldName);}
00108
00109 protected:
00110   vtkWarpScalar();
00111   ~vtkWarpScalar();
00112
00113   void Execute();
00114
00115   float ScaleFactor;
00116   int UseNormal;
00117   float Normal[3];
00118   int XYPlane;
00119
00120   //BTX
00121   float *(vtkWarpScalar::*PointNormal)(vtkIdType id, vtkDataArray *normals);
00122   float *DataNormal(vtkIdType id, vtkDataArray *normals=NULL);
00123   float *InstanceNormal(vtkIdType id, vtkDataArray *normals=NULL);
00124   float *ZNormal(vtkIdType id, vtkDataArray *normals=NULL);
00125   //ETX
00126
00127   char *InputScalarsSelection;
00128   vtkSetStringMacro(InputScalarsSelection);
00129
00130 private:
00131   vtkWarpScalar(const vtkWarpScalar&);  // Not implemented.
00132   void operator=(const vtkWarpScalar&);  // Not implemented.
00133 };
00134
00135 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkWarpTo.h Source File

Graphics/vtkWarpTo.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWarpTo.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkWarpTo_h
00038 #define __vtkWarpTo_h
00039
00040 #include "vtkPointSetToPointSetFilter.h"
00041
00042 class VTK_GRAPHICS_EXPORT vtkWarpTo : public vtkPointSetToPointSetFilter
00043 {
00044 public:
00045   static vtkWarpTo *New();
00046   vtkTypeRevisionMacro(vtkWarpTo,vtkPointSetToPointSetFilter);
00047   void PrintSelf(ostream& os, vtkIndent indent);
00048
00050
00051   vtkSetMacro(ScaleFactor,float);
00052   vtkGetMacro(ScaleFactor,float);
00054
00056
00057   vtkGetVectorMacro(Position,float,3);
00058   vtkSetVector3Macro(Position,float);
00060
00062
00064   vtkSetMacro(Absolute,int);
00065   vtkGetMacro(Absolute,int);
00066   vtkBooleanMacro(Absolute,int);
00068
00069 protected:
00070   vtkWarpTo();
00071   ~vtkWarpTo() {};
00072
00073   void Execute();
00074   float ScaleFactor;
00075   float Position[3];
00076   int   Absolute;
00077 private:
00078   vtkWarpTo(const vtkWarpTo&);  // Not implemented.
00079   void operator=(const vtkWarpTo&);  // Not implemented.
00080 };
00081
00082 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWarpTransform.h Source File

Common/vtkWarpTransform.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWarpTransform.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkWarpTransform_h
00035 #define __vtkWarpTransform_h
00036
00037 #include "vtkAbstractTransform.h"
00038
00039 class VTK_COMMON_EXPORT vtkWarpTransform : public vtkAbstractTransform
00040 {
00041 public:
00042
00043   vtkTypeRevisionMacro(vtkWarpTransform,vtkAbstractTransform);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00050   void Inverse();
00051
00053
00056   vtkGetMacro(InverseFlag,int);
00058
00060
00061   vtkSetMacro(InverseTolerance,double);
00062   vtkGetMacro(InverseTolerance,double);
00064
00066
00070   vtkSetMacro(InverseIterations,int);
00071   vtkGetMacro(InverseIterations,int);
00073
00075
00077   void InternalTransformPoint(const float in[3], float out[3]);
00078   void InternalTransformPoint(const double in[3], double out[3]);
00080
00082
00084   void InternalTransformDerivative(const float in[3], float out[3],
00085                                    float derivative[3][3]);
00086   void InternalTransformDerivative(const double in[3], double out[3],
00087                                    double derivative[3][3]);
00089
00091
00095   void TemplateTransformPoint(const float in[3], float out[3]) {
00096     this->ForwardTransformPoint(in,out); };
00097   void TemplateTransformPoint(const double in[3], double out[3]) {
00098     this->ForwardTransformPoint(in,out); };
00099   void TemplateTransformPoint(const float in[3], float out[3],
00100                               float derivative[3][3]) {
00101     this->ForwardTransformDerivative(in,out,derivative); };
00102   void TemplateTransformPoint(const double in[3], double out[3],
00103                               double derivative[3][3]) {
00104     this->ForwardTransformDerivative(in,out,derivative); };
00105   void TemplateTransformInverse(const float in[3], float out[3]) {
00106     this->InverseTransformPoint(in,out); };
00107   void TemplateTransformInverse(const double in[3], double out[3]) {
00108     this->InverseTransformPoint(in,out); };
00109   void TemplateTransformInverse(const float in[3], float out[3],
00110                                 float derivative[3][3]) {
00111     this->InverseTransformDerivative(in,out,derivative); };
00112   void TemplateTransformInverse(const double in[3], double out[3],
00113                                 double derivative[3][3]) {
00114     this->InverseTransformDerivative(in,out,derivative); };
00116
00117 protected:
00118   vtkWarpTransform();
00119   ~vtkWarpTransform();
00120
00122
00124   virtual void ForwardTransformPoint(const float in[3], float out[3]) = 0;
00125   virtual void ForwardTransformPoint(const double in[3], double out[3]) = 0;
00127
00129
00130   virtual void ForwardTransformDerivative(const float in[3], float out[3],
00131                                           float derivative[3][3]) = 0;
00132   virtual void ForwardTransformDerivative(const double in[3], double out[3],
00133                                           double derivative[3][3]) = 0;
00135
00137
00140   virtual void InverseTransformPoint(const float in[3], float out[3]);
00141   virtual void InverseTransformPoint(const double in[3], double out[3]);
00143
00145
00148   virtual void InverseTransformDerivative(const float in[3], float out[3],
00149                                           float derivative[3][3]);
00150   virtual void InverseTransformDerivative(const double in[3], double out[3],
00151                                           double derivative[3][3]);
00153
00154   int InverseFlag;
00155   int InverseIterations;
00156   double InverseTolerance;
00157 private:
00158   vtkWarpTransform(const vtkWarpTransform&);  // Not implemented.
00159   void operator=(const vtkWarpTransform&);  // Not implemented.
00160 };
00161
00162 #endif
00163
00164
00165
00166
00167
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkWarpVector.h Source File

Graphics/vtkWarpVector.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWarpVector.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00043 #ifndef __vtkWarpVector_h
00044 #define __vtkWarpVector_h
00045
00046 #include "vtkPointSetToPointSetFilter.h"
00047
00048 class VTK_GRAPHICS_EXPORT vtkWarpVector : public vtkPointSetToPointSetFilter
00049 {
00050 public:
00051   static vtkWarpVector *New();
00052   vtkTypeRevisionMacro(vtkWarpVector,vtkPointSetToPointSetFilter);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056
00057   vtkSetMacro(ScaleFactor,float);
00058   vtkGetMacro(ScaleFactor,float);
00060
00062
00065   vtkGetStringMacro(InputVectorsSelection);
00066   void SelectInputVectors(const char *fieldName)
00067     {this->SetInputVectorsSelection(fieldName);}
00069
00070 protected:
00071   vtkWarpVector();
00072   ~vtkWarpVector();
00073
00074   void Execute();
00075   float ScaleFactor;
00076
00077   char *InputVectorsSelection;
00078   vtkSetStringMacro(InputVectorsSelection);
00079
00080 private:
00081   vtkWarpVector(const vtkWarpVector&);  // Not implemented.
00082   void operator=(const vtkWarpVector&);  // Not implemented.
00083 };
00084
00085 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWedge.h Source File

Common/vtkWedge.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWedge.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00040 #ifndef __vtkWedge_h
00041 #define __vtkWedge_h
00042
00043 #include "vtkCell3D.h"
00044 #include "vtkLine.h"
00045 #include "vtkTriangle.h"
00046 #include "vtkQuad.h"
00047
00048 class vtkUnstructuredGrid;
00049
00050 class VTK_COMMON_EXPORT vtkWedge : public vtkCell3D
00051 {
00052 public:
00053   static vtkWedge *New();
00054   vtkTypeRevisionMacro(vtkWedge,vtkCell);
00055
00057
00058   virtual void GetEdgePoints(int edgeId, int* &pts);
00059   virtual void GetFacePoints(int faceId, int* &pts);
00061
00063
00064   vtkCell *MakeObject();
00065   int GetCellType() {return VTK_WEDGE;}
00066   int GetCellDimension() {return 3;}
00067   int GetNumberOfEdges() {return 9;}
00068   int GetNumberOfFaces() {return 5;}
00069   vtkCell *GetEdge(int edgeId);
00070   vtkCell *GetFace(int faceId);
00071   int CellBoundary(int subId, float pcoords[3], vtkIdList *pts);
00072   void Contour(float value, vtkDataArray *cellScalars,
00073                vtkPointLocator *locator, vtkCellArray *verts,
00074                vtkCellArray *lines, vtkCellArray *polys,
00075                vtkPointData *inPd, vtkPointData *outPd,
00076                vtkCellData *inCd, vtkIdType cellId, vtkCellData *outCd);
00077   int EvaluatePosition(float x[3], float* closestPoint,
00078                        int& subId, float pcoords[3],
00079                        float& dist2, float *weights);
00080   void EvaluateLocation(int& subId, float pcoords[3], float x[3],
00081                         float *weights);
00082   int IntersectWithLine(float p1[3], float p2[3], float tol, float& t,
00083                         float x[3], float pcoords[3], int& subId);
00084   int Triangulate(int index, vtkIdList *ptIds, vtkPoints *pts);
00085   void Derivatives(int subId, float pcoords[3], float *values,
00086                    int dim, float *derivs);
00088
00090   int GetParametricCenter(float pcoords[3]);
00091
00093
00095   static void InterpolationFunctions(float pcoords[3], float weights[6]);
00096   static void InterpolationDerivs(float pcoords[3], float derivs[18]);
00097   int JacobianInverse(float pcoords[3], double **inverse, float derivs[18]);
00098   static int *GetEdgeArray(int edgeId);
00099   static int *GetFaceArray(int faceId);
00101
00102 protected:
00103   vtkWedge();
00104   ~vtkWedge();
00105
00106   vtkLine *Line;
00107   vtkTriangle *Triangle;
00108   vtkQuad *Quad;
00109
00110 private:
00111   vtkWedge(const vtkWedge&);  // Not implemented.
00112   void operator=(const vtkWedge&);  // Not implemented.
00113 };
00114
00115 inline int vtkWedge::GetParametricCenter(float pcoords[3])
00116 {
00117   pcoords[0] = pcoords[1] = 0.333333;
00118   pcoords[2] = 0.5;
00119   return 0;
00120 }
00121
00122 #endif
00123
00124
00125
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkWeightedTransformFilter.h Source File

Hybrid/vtkWeightedTransformFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWeightedTransformFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00083 #ifndef __vtkWeightedTransformFilter_h
00084 #define __vtkWeightedTransformFilter_h
00085
00086 #include "vtkPointSetToPointSetFilter.h"
00087 #include "vtkAbstractTransform.h"
00088
00089 class VTK_HYBRID_EXPORT vtkWeightedTransformFilter : public vtkPointSetToPointSetFilter
00090 {
00091 public:
00092   static vtkWeightedTransformFilter *New();
00093   vtkTypeRevisionMacro(vtkWeightedTransformFilter,vtkPointSetToPointSetFilter);
00094   void PrintSelf(ostream& os, vtkIndent indent);
00095
00097   unsigned long GetMTime();
00098
00100
00107   vtkSetStringMacro(WeightArray);
00108   vtkGetStringMacro(WeightArray);
00110
00112
00116   vtkSetStringMacro(CellDataWeightArray);
00117   vtkGetStringMacro(CellDataWeightArray);
00119
00121
00125   virtual void SetTransform(vtkAbstractTransform *transform, int num);
00126   virtual vtkAbstractTransform *GetTransform(int num);
00128
00130
00133   virtual void SetNumberOfTransforms(int num);
00134   vtkGetMacro(NumberOfTransforms, int);
00136
00138
00142   vtkBooleanMacro(AddInputValues, int);
00143   vtkSetMacro(AddInputValues, int);
00144   vtkGetMacro(AddInputValues, int);
00146
00147 protected:
00148   vtkAbstractTransform **Transforms;
00149   int NumberOfTransforms;
00150   int AddInputValues;
00151
00152   char *CellDataWeightArray;
00153   char *WeightArray;
00154
00155   vtkWeightedTransformFilter();
00156   ~vtkWeightedTransformFilter();
00157
00158   void Execute();
00159 private:
00160   vtkWeightedTransformFilter(const vtkWeightedTransformFilter&);  // Not implemented.
00161   void operator=(const vtkWeightedTransformFilter&);  // Not implemented.
00162 };
00163
00164 #endif
00165
00166
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWin32Header.h Source File

Common/vtkWin32Header.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32Header.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkWIN32Header_h
00035 #define __vtkWIN32Header_h
00036
00037 #include "vtkConfigure.h"
00038
00039 //
00040 // Windows specific stuff------------------------------------------
00041 #if defined(_WIN32) || defined(WIN32)
00042
00043 // define strict header for windows
00044 #ifndef STRICT
00045 #define STRICT
00046 #endif
00047
00048 #ifdef VTK_USE_ANSI_STDLIB
00049 #define NOMINMAX
00050 #endif
00051
00052 #include <windows.h>
00053
00054 // Handle compiler warning messages, etc.
00055 #ifndef VTK_DISPLAY_WIN32_WARNINGS
00056 #pragma warning ( disable : 4127 )
00057 #pragma warning ( disable : 4244 )
00058 #pragma warning ( disable : 4251 )
00059 #pragma warning ( disable : 4305 )
00060 #pragma warning ( disable : 4309 )
00061 #pragma warning ( disable : 4706 )
00062 #pragma warning ( disable : 4786 )
00063 #endif //VTK_DISPLAY_WIN32_WARNINGS
00064
00065 #endif
00066
00067 #if defined(WIN32) && !defined(VTKSTATIC)
00068  #define VTK_EXPORT __declspec( dllexport )
00069
00070  #if defined(vtkCommon_EXPORTS)
00071   #define VTK_COMMON_EXPORT __declspec( dllexport )
00072  #else
00073   #define VTK_COMMON_EXPORT __declspec( dllimport )
00074  #endif
00075
00076  #if defined(vtkFiltering_EXPORTS)
00077   #define VTK_FILTERING_EXPORT __declspec( dllexport )
00078  #else
00079   #define VTK_FILTERING_EXPORT __declspec( dllimport )
00080  #endif
00081
00082  #if defined(vtkImaging_EXPORTS)
00083   #define VTK_IMAGING_EXPORT __declspec( dllexport )
00084  #else
00085   #define VTK_IMAGING_EXPORT __declspec( dllimport )
00086  #endif
00087
00088  #if defined(vtkGraphics_EXPORTS)
00089   #define VTK_GRAPHICS_EXPORT __declspec( dllexport )
00090  #else
00091   #define VTK_GRAPHICS_EXPORT __declspec( dllimport )
00092  #endif
00093
00094  #if defined(vtkIO_EXPORTS)
00095   #define VTK_IO_EXPORT __declspec( dllexport )
00096  #else
00097   #define VTK_IO_EXPORT __declspec( dllimport )
00098  #endif
00099
00100  #if defined(vtkRendering_EXPORTS)
00101   #define VTK_RENDERING_EXPORT __declspec( dllexport )
00102  #else
00103   #define VTK_RENDERING_EXPORT __declspec( dllimport )
00104  #endif
00105
00106  #if defined(vtkHybrid_EXPORTS)
00107   #define VTK_HYBRID_EXPORT __declspec( dllexport )
00108  #else
00109   #define VTK_HYBRID_EXPORT __declspec( dllimport )
00110  #endif
00111
00112  #if defined(vtkParallel_EXPORTS)
00113   #define VTK_PARALLEL_EXPORT __declspec( dllexport )
00114  #else
00115   #define VTK_PARALLEL_EXPORT __declspec( dllimport )
00116  #endif
00117
00118  #if defined(vtkPatented_EXPORTS)
00119   #define VTK_PATENTED_EXPORT __declspec( dllexport )
00120  #else
00121   #define VTK_PATENTED_EXPORT __declspec( dllimport )
00122  #endif
00123 #else
00124  #define VTK_COMMON_EXPORT
00125  #define VTK_FILTERING_EXPORT
00126  #define VTK_GRAPHICS_EXPORT
00127  #define VTK_IMAGING_EXPORT
00128  #define VTK_IO_EXPORT
00129  #define VTK_RENDERING_EXPORT
00130  #define VTK_HYBRID_EXPORT
00131  #define VTK_PARALLEL_EXPORT
00132  #define VTK_PATENTED_EXPORT
00133  #define VTK_EXPORT
00134 #endif
00135
00136 // this is exclusively for the tcl Init functions
00137 #if defined(WIN32)
00138  #define VTK_TK_EXPORT __declspec( dllexport )
00139 #else
00140  #define VTK_TK_EXPORT
00141 #endif
00142
00143 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32ImageMapper.h Source File

Rendering/vtkWin32ImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32ImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkWin32ImageMapper_h
00038 #define __vtkWin32ImageMapper_h
00039
00040
00041 #include "vtkImageMapper.h"
00042 #include "vtkLookupTable.h"
00043
00044 class vtkImageActor2D;
00045
00046 #ifndef VTK_REMOVE_LEGACY_CODE
00047 class VTK_RENDERING_EXPORT vtkWin32ImageMapper : public vtkImageMapper
00048 {
00049 public:
00050   static vtkWin32ImageMapper *New();
00051   vtkTypeRevisionMacro(vtkWin32ImageMapper,vtkImageMapper);
00052
00054
00055   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor) {
00056     this->RenderStart(viewport,actor);}
00058
00060
00062   void RenderData(vtkViewport* viewport, vtkImageData* data,
00063                   vtkActor2D* actor);
00065
00067   unsigned long int GetMTime();
00068
00070   void PrintSelf(ostream& os, vtkIndent indent);
00071
00073
00080   vtkSetObjectMacro(LookupTable, vtkLookupTable);
00081   vtkGetObjectMacro(LookupTable, vtkLookupTable);
00083
00085
00090   static HBITMAP CreateBitmapObject(
00091     HBITMAP oldBitmap, BITMAPINFO &dataHeader, HDC windowDC,
00092     unsigned char *&DataOut, vtkImageData *data, int width, int height);
00094
00095   static void GenerateBitmapData(
00096     vtkImageData *data, void *inptr, unsigned char *DataOut, int dim,
00097     int DisplayExtent[6], float cwindow, float clevel, float cshift, float cscale,
00098     vtkLookupTable *lut);
00099
00100   unsigned char *DataOut;       // the data in the DIBSection
00101   HBITMAP HBitmap;                      // our handle to the DIBSection
00102
00103 protected:
00104   vtkLookupTable *LookupTable;
00105
00106   vtkWin32ImageMapper();
00107   ~vtkWin32ImageMapper();
00108
00109 private:
00110   vtkWin32ImageMapper(const vtkWin32ImageMapper&);  // Not implemented.
00111   void operator=(const vtkWin32ImageMapper&);  // Not implemented.
00112 };
00113 #endif
00114
00115 #endif
00116
00117
00118
00119
00120
00121
00122
00123
00124
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32ImageWindow.h Source File

Rendering/vtkWin32ImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32ImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkWin32ImageWindow_h
00037 #define __vtkWin32ImageWindow_h
00038
00039
00040 #include        "vtkImageWindow.h"
00041
00042 #ifndef VTK_REMOVE_LEGACY_CODE
00043 class VTK_RENDERING_EXPORT vtkWin32ImageWindow : public vtkImageWindow
00044 {
00045 public:
00046   HINSTANCE ApplicationInstance;
00047   HPALETTE  Palette;
00048   HDC       DeviceContext;
00049   HWND      WindowId;
00050   HWND      ParentId;
00051
00052   static vtkWin32ImageWindow *New();
00053   vtkTypeRevisionMacro(vtkWin32ImageWindow,vtkImageWindow);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00058   void SwapBuffers();
00059
00062   void Frame();
00063
00064   // output to the viewer.
00065   vtkWin32ImageWindow *GetOutput(){return this;};
00066
00068   void SetWindowInfo(char *);
00069
00071   void SetParentInfo(char *);
00072
00073   //BTX
00074
00076
00077   HWND GetWindowId();
00078   void SetWindowId(void* id) {this->WindowId = (HWND) id;};
00079   void SetParentId(void* id) {this->ParentId = (HWND) id;};
00080   void SetWindowId(HWND);
00081   void SetParentId(HWND);
00083
00084   void SetDeviceContext(void* dc) {this->DeviceContext = (HDC) dc;};
00085   void SetDeviceContext(HDC);
00086   void SetDisplayId(void *foo) {vtkDebugMacro(<<"SetDisplayID not implemented");};
00087
00088   void *GetGenericDisplayId()
00089         {vtkDebugMacro(<<"Display ID not implemented in Win32."); return (void*) NULL;};
00090   void *GetGenericWindowId() {return (void*) this->WindowId;};
00091   void *GetGenericParentId() {return (void*) this->ParentId;};
00092   void *GetGenericContext() {return (void*) this->DeviceContext;};
00093   //ETX
00094
00096
00097   void   SetSize(int,int);
00098   int   *GetSize();
00100
00102
00103   int   *GetPosition();
00104   void   SetPosition(int,int);
00106
00108   void SetBackgroundColor(float r, float g, float b);
00109
00111   void EraseWindow();
00112
00113   unsigned char *GetDIBPtr();
00114   unsigned char *GetPixelData(int x1, int y1, int x2, int y2, int);
00115
00117   void MakeDefaultWindow();
00118
00120
00122   void SetupMemoryRendering(int x, int y, HDC prn);
00123   void ResumeScreenRendering();
00124   HDC GetMemoryDC();
00125   unsigned char *GetMemoryData(){return this->MemoryData;};
00127
00128 protected:
00129   vtkWin32ImageWindow();
00130   ~vtkWin32ImageWindow();
00131
00132   // the following is used to support rendering into memory
00133   BITMAPINFO MemoryDataHeader;
00134   HBITMAP MemoryBuffer;
00135   unsigned char *MemoryData;    // the data in the DIBSection
00136   HDC MemoryHdc;
00137   int ScreenMapped;
00138   int ScreenWindowSize[2];
00139   HDC ScreenDeviceContext;
00140
00141   int OwnWindow; // do we create this window ?
00142
00143   unsigned char *DIBPtr;        // the data in the DIBSection
00144   int SwapFlag;
00145   HDC CompatHdc;
00146   HDC OldHdc;
00147   HBITMAP BackBuffer;
00148   BITMAPINFO DataHeader;
00149 private:
00150   vtkWin32ImageWindow(const vtkWin32ImageWindow&);  // Not implemented.
00151   void operator=(const vtkWin32ImageWindow&);  // Not implemented.
00152 };
00153
00154 #endif
00155
00156 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32OpenGLImageWindow.h Source File

Rendering/vtkWin32OpenGLImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32OpenGLImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00034 #ifndef __vtkWin32OpenGLImageWindow_h
00035 #define __vtkWin32OpenGLImageWindow_h
00036
00037 #include <stdlib.h>
00038 #include "vtkImageWindow.h"
00039 #include "vtkMutexLock.h"
00040
00041 class VTK_RENDERING_EXPORT vtkWin32OpenGLImageWindow : public vtkImageWindow
00042 {
00043 public:
00044   static vtkWin32OpenGLImageWindow *New();
00045   vtkTypeRevisionMacro(vtkWin32OpenGLImageWindow,vtkImageWindow);
00046   void PrintSelf(ostream& os, vtkIndent indent);
00047
00048   // output to the viewer.
00049   vtkWin32OpenGLImageWindow *GetOutput(){return this;};
00050
00052   virtual void MakeDefaultWindow();
00053
00055   void SwapBuffers();
00056
00058   void Frame();
00059
00061   void Render();
00062
00064
00065   virtual void SetSize(int,int);
00066   virtual void SetSize(int a[2]) {this->vtkImageWindow::SetSize(a);};
00068
00070
00071   virtual int *GetSize();
00072   virtual void GetSize(int *x, int *y) { this->vtkImageWindow::GetSize(x,y);};
00074
00076
00077   virtual void SetPosition(int,int);
00078   virtual void SetPosition(int a[2]) {this->vtkImageWindow::SetPosition(a);};
00080
00082
00083   virtual int *GetPosition();
00084   virtual void GetPosition(int *x, int *y) { this->vtkImageWindow::GetPosition(x,y);};
00086
00089   virtual void SetWindowName(char *);
00090
00092   void SetWindowInfo(char *);
00093
00095   void SetParentInfo(char *);
00096
00097   //BTX
00098   virtual void *GetGenericDisplayId() {return (void *)this->ContextId;};
00099   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00100   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00101   virtual void *GetGenericContext()   {return (void *)this->DeviceContext;};
00102   virtual void SetDisplayId(void *) {};
00103
00105
00106   virtual HWND  GetWindowId();
00107   void  SetWindowId(void *foo) {this->SetWindowId((HWND)foo);};
00109
00111   virtual void  SetWindowId(HWND);
00112
00114
00115   virtual void  SetParentId(HWND);
00116   void  SetParentId(void *foo) {this->SetParentId((HWND)foo);};
00118
00119   void  SetContextId(HGLRC);    // hsr
00120   void  SetDeviceContext(HDC);  // hsr
00121
00123
00124   virtual void  SetNextWindowId(HWND);
00125   //ETX
00127
00129   /*! Set/Get the pixel data of an image, transmitted as RGBRGB... */
00130   virtual unsigned char *GetPixelData(int x,int y,int x2,int y2,int front);
00131   virtual void SetPixelData(int x,int y,int x2,int y2,unsigned char *,
00132                             int front);
00134
00136
00137   virtual float *GetRGBAPixelData(int x,int y,int x2,int y2,int front);
00138   virtual void SetRGBAPixelData(int x,int y,int x2,int y2,float *,int front,
00139                                 int blend=0);
00140   virtual void ReleaseRGBAPixelData(float *data);
00142
00144   void MakeCurrent();
00145
00147
00149   void SetupMemoryRendering(int x, int y, HDC prn);
00150   void ResumeScreenRendering();
00151   HDC GetMemoryDC();
00152   unsigned char *GetMemoryData(){return this->MemoryData;};
00154
00156
00157   virtual void OpenGLInit();
00158   virtual void SetupPalette(HDC hDC);
00159   virtual void SetupPixelFormat(HDC hDC, DWORD dwFlags, int debug,
00160                                 int bpp=16, int zbpp=16);
00162
00164   void Clean();
00165
00166 protected:
00167   vtkWin32OpenGLImageWindow();
00168   ~vtkWin32OpenGLImageWindow();
00169
00170   HINSTANCE ApplicationInstance;
00171   HPALETTE  Palette;
00172   HPALETTE  OldPalette;
00173   HGLRC     ContextId;
00174   HDC       DeviceContext;
00175   HWND      WindowId;
00176   HWND      ParentId;
00177   HWND      NextWindowId;
00178   int       OwnWindow;
00179   int       ScreenSize[2];
00180
00181   // the following is used to support rendering into memory
00182   BITMAPINFO MemoryDataHeader;
00183   HBITMAP MemoryBuffer;
00184   unsigned char *MemoryData;    // the data in the DIBSection
00185   HDC MemoryHdc;
00186
00187   int ScreenMapped;
00188   int ScreenWindowSize[2];
00189   HDC ScreenDeviceContext;
00190   int ScreenDoubleBuffer;
00191   HGLRC ScreenContextId;
00192
00193   //BTX
00194   // message handler
00195   virtual LRESULT MessageProc(HWND hWnd, UINT message,
00196                               WPARAM wParam, LPARAM lParam);
00197
00198   static LRESULT APIENTRY WndProc(HWND hWnd, UINT message,
00199                                   WPARAM wParam, LPARAM lParam);
00200   //ETX
00201
00202 private:
00203   vtkWin32OpenGLImageWindow(const vtkWin32OpenGLImageWindow&);  // Not implemented.
00204   void operator=(const vtkWin32OpenGLImageWindow&);  // Not implemented.
00205 };
00206
00207
00208 #endif
00209
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32OpenGLRenderWindow.h Source File

Rendering/vtkWin32OpenGLRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32OpenGLRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkWin32OpenGLRenderWindow_h
00039 #define __vtkWin32OpenGLRenderWindow_h
00040
00041 #include <stdlib.h>
00042 #include "vtkOpenGLRenderWindow.h"
00043 #ifndef VTK_IMPLEMENT_MESA_CXX
00044 #include <GL/gl.h>
00045 #endif
00046
00047 class vtkIdList;
00048
00049 class VTK_RENDERING_EXPORT vtkWin32OpenGLRenderWindow : public vtkOpenGLRenderWindow
00050 {
00051 public:
00052   static vtkWin32OpenGLRenderWindow *New();
00053   vtkTypeRevisionMacro(vtkWin32OpenGLRenderWindow,vtkOpenGLRenderWindow);
00054   void PrintSelf(ostream& os, vtkIndent indent);
00055
00057   virtual void Start(void);
00058
00060   void Frame(void);
00061
00063   virtual void WindowInitialize(void);
00064
00066   virtual void Initialize(void);
00067
00069   virtual void SetFullScreen(int);
00070
00072   virtual void WindowRemap(void);
00073
00075   virtual void PrefFullScreen(void);
00076
00078
00079   virtual void SetSize(int,int);
00080   virtual void SetSize(int a[2]) {vtkOpenGLRenderWindow::SetSize(a);};
00082
00084   virtual int *GetSize();
00085
00087
00088   virtual void SetPosition(int,int);
00089   virtual void SetPosition(int a[2]) {vtkOpenGLRenderWindow::SetPosition(a);};
00091
00093   virtual int *GetScreenSize();
00094
00096   virtual int *GetPosition();
00097
00100   virtual void SetWindowName(char *);
00101
00103   void SetWindowInfo(char *);
00104
00106   void SetParentInfo(char *);
00107
00108   //BTX
00109   virtual void *GetGenericDisplayId() {return (void *)this->ContextId;};
00110   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00111   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00112   virtual void *GetGenericContext()   {return (void *)this->DeviceContext;};
00113   virtual void SetDisplayId(void *) {};
00114
00116
00117   virtual HWND  GetWindowId();
00118   void  SetWindowId(void *foo) {this->SetWindowId((HWND)foo);};
00120
00122   virtual void  SetWindowId(HWND);
00123
00125
00126   virtual void  SetParentId(HWND);
00127   void  SetParentId(void *foo) {this->SetParentId((HWND)foo);};
00129
00130   void  SetContextId(HGLRC);    // hsr
00131   void  SetDeviceContext(HDC);  // hsr
00132
00134
00135   virtual void  SetNextWindowId(HWND);
00136   //ETX
00138
00143   virtual void SetStereoCapableWindow(int capable);
00144
00146   void MakeCurrent();
00147
00150   virtual  int GetEventPending();
00151
00153
00155   void SetupMemoryRendering(int x, int y, HDC prn);
00156   void SetupMemoryRendering(HBITMAP hbmp);
00157   void ResumeScreenRendering(void);
00158   HDC GetMemoryDC();
00159   unsigned char *GetMemoryData(){return this->MemoryData;};
00161
00163
00164   virtual void SetupPalette(HDC hDC);
00165   virtual void SetupPixelFormat(HDC hDC, DWORD dwFlags, int debug,
00166                                 int bpp=16, int zbpp=16);
00168
00170   void Clean();
00171
00173
00175   void HideCursor();
00176   void ShowCursor();
00178
00181   virtual void SetOffScreenRendering(int offscreen);
00182
00183 protected:
00184   vtkWin32OpenGLRenderWindow();
00185   ~vtkWin32OpenGLRenderWindow();
00186
00187   HINSTANCE ApplicationInstance;
00188   HPALETTE  Palette;
00189   HPALETTE  OldPalette;
00190   HGLRC     ContextId;
00191   HDC       DeviceContext;
00192   BOOL      MFChandledWindow;
00193   HWND      WindowId;
00194   HWND      ParentId;
00195   HWND      NextWindowId;
00196   int       OwnWindow;
00197   int       ScreenSize[2];
00198
00199   // the following is used to support rendering into memory
00200   BITMAPINFO MemoryDataHeader;
00201   HBITMAP MemoryBuffer;
00202   unsigned char *MemoryData;    // the data in the DIBSection
00203   HDC MemoryHdc;
00204
00205   int ScreenMapped;
00206   int ScreenWindowSize[2];
00207   HDC ScreenDeviceContext;
00208   int ScreenDoubleBuffer;
00209   HGLRC ScreenContextId;
00210
00211   //BTX
00212   // message handler
00213   virtual LRESULT MessageProc(HWND hWnd, UINT message,
00214                               WPARAM wParam, LPARAM lParam);
00215
00216   static LRESULT APIENTRY WndProc(HWND hWnd, UINT message,
00217                                   WPARAM wParam, LPARAM lParam);
00218   //ETX
00219   int CursorHidden;
00220
00221   void ResizeWhileOffscreen(int xsize, int ysize);
00222   void CreateAWindow(int x, int y, int width, int height);
00223   void InitializeApplication();
00224   void CleanUpOffScreenRendering(void);
00225   void CreateOffScreenDC(int xsize, int ysize, HDC aHdc);
00226   void CreateOffScreenDC(HBITMAP hbmp, HDC aHdc);
00227 private:
00228   vtkWin32OpenGLRenderWindow(const vtkWin32OpenGLRenderWindow&);  // Not implemented.
00229   void operator=(const vtkWin32OpenGLRenderWindow&);  // Not implemented.
00230 };
00231
00232
00233 #endif
00234
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32OpenGLTextMapper.h Source File

Rendering/vtkWin32OpenGLTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32OpenGLTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkWin32OpenGLTextMapper_h
00039 #define __vtkWin32OpenGLTextMapper_h
00040
00041 #include "vtkWin32TextMapper.h"
00042
00043 class VTK_RENDERING_EXPORT vtkWin32OpenGLTextMapper : public vtkWin32TextMapper
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkWin32OpenGLTextMapper,vtkWin32TextMapper);
00047   static vtkWin32OpenGLTextMapper *New();
00048
00050
00051   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00052   void RenderTranslucentGeometry(vtkViewport* viewport, vtkActor2D* actor);
00053   void RenderGeometry(vtkViewport* viewport, vtkActor2D* actor);
00054   void RenderOverlay(vtkViewport* vtkNotUsed(viewport),
00055                      vtkActor2D* vtkNotUsed(actor)) {};
00057
00061   virtual void ReleaseGraphicsResources(vtkWindow *);
00062
00064   static int GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp);
00065
00066 protected:
00067   vtkWin32OpenGLTextMapper();
00068   ~vtkWin32OpenGLTextMapper();
00069 private:
00070   vtkWin32OpenGLTextMapper(const vtkWin32OpenGLTextMapper&);  // Not implemented.
00071   void operator=(const vtkWin32OpenGLTextMapper&);  // Not implemented.
00072 };
00073
00074
00075 #endif
00076
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWin32OutputWindow.h Source File

Common/vtkWin32OutputWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32OutputWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkWin32OutputWindow_h
00043 #define __vtkWin32OutputWindow_h
00044
00045 #include "vtkOutputWindow.h"
00046
00047
00048 class VTK_COMMON_EXPORT vtkWin32OutputWindow : public vtkOutputWindow
00049 {
00050 public:
00051 // Methods from vtkObject
00052   vtkTypeRevisionMacro(vtkWin32OutputWindow,vtkOutputWindow);
00054
00055   static vtkWin32OutputWindow* New();
00056   // Description:  Put the text into the display window.
00057   // New lines are converted to carriage return new lines.
00058   virtual void DisplayText(const char*);
00059   //BTX
00060   static LRESULT APIENTRY WndProc(HWND hWnd, UINT message,
00061                                   WPARAM wParam, LPARAM lParam);
00062   //ETX
00064 protected:
00065   vtkWin32OutputWindow() {};
00066   virtual ~vtkWin32OutputWindow() {};
00067
00068   void PromptText(const char* text);
00069   static void AddText(const char*);
00070   static int Initialize();
00071   static HWND OutputWindow;
00072 private:
00073   vtkWin32OutputWindow(const vtkWin32OutputWindow&);  // Not implemented.
00074   void operator=(const vtkWin32OutputWindow&);  // Not implemented.
00075 };
00076
00077
00078
00079 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32PolyDataMapper2D.h Source File

Rendering/vtkWin32PolyDataMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32PolyDataMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkWin32PolyDataMapper2D_h
00038 #define __vtkWin32PolyDataMapper2D_h
00039
00040 #include "vtkPolyDataMapper2D.h"
00041
00042 #ifndef VTK_REMOVE_LEGACY_CODE
00043 class VTK_RENDERING_EXPORT vtkWin32PolyDataMapper2D : public vtkPolyDataMapper2D
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkWin32PolyDataMapper2D,vtkPolyDataMapper2D);
00047   static vtkWin32PolyDataMapper2D *New();
00048
00050   virtual void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor);
00051
00052 protected:
00053   vtkWin32PolyDataMapper2D() {};
00054   ~vtkWin32PolyDataMapper2D() {};
00055
00056 private:
00057   vtkWin32PolyDataMapper2D(const vtkWin32PolyDataMapper2D&);  // Not implemented.
00058   void operator=(const vtkWin32PolyDataMapper2D&);  // Not implemented.
00059 };
00060 #endif
00061
00062 #endif
00063
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32RenderWindowInteractor.h Source File

Rendering/vtkWin32RenderWindowInteractor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32RenderWindowInteractor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00048 #ifndef __vtkWin32RenderWindowInteractor_h
00049 #define __vtkWin32RenderWindowInteractor_h
00050
00051 #include <stdlib.h>
00052 #include "vtkRenderWindowInteractor.h"
00053
00054
00055 class VTK_RENDERING_EXPORT vtkWin32RenderWindowInteractor : public vtkRenderWindowInteractor
00056 {
00057 public:
00059   static vtkWin32RenderWindowInteractor *New();
00060
00061   vtkTypeRevisionMacro(vtkWin32RenderWindowInteractor,vtkRenderWindowInteractor);
00062   void PrintSelf(ostream& os, vtkIndent indent);
00063
00065   virtual void Initialize();
00066
00068
00075   virtual void Enable();
00076   virtual void Disable();
00078
00082   virtual void Start();
00083
00085
00090   vtkSetMacro(InstallMessageProc,int);
00091   vtkGetMacro(InstallMessageProc,int);
00092   vtkBooleanMacro(InstallMessageProc,int);
00094
00099   void TerminateApp(void);
00100
00102
00103   int CreateTimer(int timertype);
00104   int DestroyTimer(void);
00106
00107   //BTX
00108   friend VTK_RENDERING_EXPORT LRESULT CALLBACK vtkHandleMessage(HWND hwnd,UINT uMsg, WPARAM w, LPARAM l);
00109   friend VTK_RENDERING_EXPORT LRESULT CALLBACK vtkHandleMessage2(HWND hwnd,UINT uMsg, WPARAM w, LPARAM l, vtkWin32RenderWindowInteractor *me);
00110
00112
00114   virtual void OnMouseMove  (HWND wnd, UINT nFlags, int X, int Y);
00115   virtual void OnNCMouseMove(HWND wnd, UINT nFlags, int X, int Y);
00116   virtual void OnRButtonDown(HWND wnd, UINT nFlags, int X, int Y);
00117   virtual void OnRButtonUp  (HWND wnd, UINT nFlags, int X, int Y);
00118   virtual void OnMButtonDown(HWND wnd, UINT nFlags, int X, int Y);
00119   virtual void OnMButtonUp  (HWND wnd, UINT nFlags, int X, int Y);
00120   virtual void OnLButtonDown(HWND wnd, UINT nFlags, int X, int Y);
00121   virtual void OnLButtonUp  (HWND wnd, UINT nFlags, int X, int Y);
00122   virtual void OnSize       (HWND wnd, UINT nType,  int X, int Y);
00123   virtual void OnTimer      (HWND wnd, UINT nIDEvent);
00124   virtual void OnKeyDown    (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags);
00125   virtual void OnKeyUp      (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags);
00126   virtual void OnChar       (HWND wnd, UINT nChar, UINT nRepCnt, UINT nFlags);
00127   //ETX
00129
00131   /*! Methods to set the default exit method for the class. This method is
00132       only used if no instance level ExitMethod has been defined.  It is
00133       provided as a means to control how an interactor is exited given the
00134       various language bindings (tcl, Win32, etc.). */
00135   static void SetClassExitMethod(void (*f)(void *), void *arg);
00136   static void SetClassExitMethodArgDelete(void (*f)(void *));
00138
00141   virtual void ExitCallback();
00142
00143 protected:
00144   vtkWin32RenderWindowInteractor();
00145   ~vtkWin32RenderWindowInteractor();
00146
00147   HWND    WindowId;
00148   UINT    TimerId;
00149   WNDPROC OldProc;
00150   int     InstallMessageProc;
00151
00152   int     MouseInWindow;
00153
00154   //BTX
00156   /*! Class variables so an exit method can be defined for this class (used
00157       to set different exit methods for various language bindings, i.e.
00158       tcl, java, Win32) */
00159   static void (*ClassExitMethod)(void *);
00160   static void (*ClassExitMethodArgDelete)(void *);
00161   static void *ClassExitMethodArg;
00162   //ETX
00164
00165 private:
00166   vtkWin32RenderWindowInteractor(const vtkWin32RenderWindowInteractor&);  // Not implemented.
00167   void operator=(const vtkWin32RenderWindowInteractor&);  // Not implemented.
00168 };
00169
00170 #endif
00171
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWin32TextMapper.h Source File

Rendering/vtkWin32TextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32TextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkWin32TextMapper_h
00039 #define __vtkWin32TextMapper_h
00040
00041 #include "vtkTextMapper.h"
00042
00043 class VTK_RENDERING_EXPORT vtkWin32TextMapper : public vtkTextMapper
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkWin32TextMapper,vtkTextMapper);
00047   static vtkWin32TextMapper *New();
00048
00050   void GetSize(vtkViewport* viewport, int size[2]);
00051
00052 protected:
00053   vtkWin32TextMapper();
00054   ~vtkWin32TextMapper();
00055
00056   vtkTimeStamp  BuildTime;
00057   int LastSize[2];
00058   HFONT Font;
00059 private:
00060   vtkWin32TextMapper(const vtkWin32TextMapper&);  // Not implemented.
00061   void operator=(const vtkWin32TextMapper&);  // Not implemented.
00062 };
00063
00064
00065 #endif
00066
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkWin32VideoSource.h Source File

Hybrid/vtkWin32VideoSource.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWin32VideoSource.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkWin32VideoSource_h
00039 #define __vtkWin32VideoSource_h
00040
00041 #include "vtkVideoSource.h"
00042 #include <windows.h>
00043 #include <winuser.h>
00044 #include <vfw.h>
00045
00046 class VTK_HYBRID_EXPORT vtkWin32VideoSource : public vtkVideoSource
00047 {
00048 public:
00049   static vtkWin32VideoSource *New();
00050   vtkTypeRevisionMacro(vtkWin32VideoSource,vtkVideoSource);
00051   void PrintSelf(ostream& os, vtkIndent indent);
00052
00054   void Record();
00055
00057   void Play();
00058
00060   void Stop();
00061
00063   void Grab();
00064
00066   void SetFrameSize(int x, int y, int z);
00067
00069   void SetFrameRate(float rate);
00070
00072   void SetOutputFormat(int format);
00073
00075
00076   void SetPreview(int p);
00077   vtkBooleanMacro(Preview,int);
00078   vtkGetMacro(Preview,int);
00080
00082   void VideoFormatDialog();
00083
00085   void VideoSourceDialog();
00086
00089   void Initialize();
00090
00092   void ReleaseSystemResources();
00093
00095
00096   void InternalGrab(LPVIDEOHDR VideoHdrPtr);
00097   void OnParentWndDestroy();
00099
00100 protected:
00101   vtkWin32VideoSource();
00102   ~vtkWin32VideoSource();
00103
00104   char WndClassName[16];
00105   HWND CapWnd;
00106   HWND ParentWnd;
00107   CAPSTATUS CapStatus;
00108   CAPDRIVERCAPS CapDriverCaps;
00109   CAPTUREPARMS CaptureParms;
00110   LPBITMAPINFO BitMapPtr;
00111   int BitMapSize;
00112
00113   int Preview;
00114
00115   void CheckBuffer();
00116   void UnpackRasterLine(char *outptr, char *inptr,
00117                         int start, int count);
00118
00119   void DoVFWFormatSetup();
00120   void DoVFWFormatCheck();
00121
00122 private:
00123   vtkWin32VideoSource(const vtkWin32VideoSource&);  // Not implemented.
00124   void operator=(const vtkWin32VideoSource&);  // Not implemented.
00125 };
00126
00127 #endif
00128
00129
00130
00131
00132
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWinCE.h Source File

Common/vtkWinCE.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWinCE.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef vtkWinCE_h
00034
00035 #define vtkWinCE_h
00036 #define VTK_LEAN_AND_MEAN
00037
00038 struct ostream    // Output stream
00039 {
00040   ostream & operator <<(const char *str);   // strings
00041   ostream & operator <<(void *str);   // pointers
00042   ostream & operator <<(short x) ; // integers
00043   ostream & operator <<(unsigned short x) ; // integers
00044   ostream & operator <<(int x) ; // integers
00045   ostream & operator <<(unsigned int x) ; // integers
00046   ostream &operator <<(long l) ; // long integers
00047   ostream &operator <<(unsigned long l) ; // long integers
00048   ostream & operator << (char ch) ;  // characters
00049   ostream & operator <<(float fl ) ;  // floats
00050   ostream & operator << (double dbl);  // double floats
00051
00052   write(void *data, size_t size);
00053   void flush() {};
00054 };
00055
00056 struct ofstream    // Output stream
00057 {
00058   ofstream & operator <<(const char *str);   // strings
00059   ofstream & operator <<(void *str);   // pointers
00060   ofstream & operator <<(short x) ; // integers
00061   ofstream & operator <<(unsigned short x) ; // integers
00062   ofstream & operator <<(int x) ; // integers
00063   ofstream &operator <<(long l) ; // long integers
00064   ofstream &operator <<(unsigned long l) ; // long integers
00065   ofstream & operator << (char ch) ;  // characters
00066   ofstream & operator <<(float fl ) ;  // floats
00067   ofstream & operator << (double dbl);  // double floats
00068
00069   write(void *data, size_t size);
00070 };
00071
00072 struct ostrhelp
00073 {
00074   freeze(int i);
00075 };
00076
00077 struct ostrstream    // Output stream
00078 {
00079   ostrstream & operator <<(char *str);   // strings
00080   ostrstream & operator <<(void *str);   // pointers
00081   ostrstream & operator <<(int x) ; // integers
00082   ostrstream &operator <<(long l) ; // long integers
00083   ostrstream & operator << (char ch) ;  // characters
00084   ostrstream & operator <<(float fl ) ;  // floats
00085   ostrstream & operator << (double dbl);  // double floats
00086
00087   char *str();
00088   ostrhelp *rdbuf();
00089 };
00090
00091
00092 struct istream
00093 {
00094   int get(char &c) { c = (char)getchar(); return c;}
00095   int putback(char &c) { return ungetc(c,stdin);}
00096   istream & operator >>(char *str);  // strings
00097   istream & operator >>(int  &x) ; // integers
00098   istream & operator >> (char  &ch) ;  // characters
00099   istream & operator >> (float &fl ) ;  // floats
00100   istream & operator >> (double &dbl );  // doubles
00101 };
00102
00103
00104
00105 extern  char *endl;
00106 extern ostream cout;
00107 extern ostream cerr;
00108 extern istream cin;
00109
00110 #endif vtkWinCE_h
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWinCEOpenGLRenderWindow.h Source File

Rendering/vtkWinCEOpenGLRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWinCEOpenGLRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00033 #ifndef __vtkWinCEOpenGLRenderWindow_h
00034 #define __vtkWinCEOpenGLRenderWindow_h
00035
00036 #include <stdlib.h>
00037 #include "vtkOpenGLRenderWindow.h"
00038 #include "GL/osmesa.h"
00039
00040
00041 class vtkIdList;
00042
00043 class VTK_RENDERING_EXPORT vtkWinCEOpenGLRenderWindow : public vtkOpenGLRenderWindow
00044 {
00045 public:
00046   static vtkWinCEOpenGLRenderWindow *New();
00047   vtkTypeRevisionMacro(vtkWinCEOpenGLRenderWindow,vtkOpenGLRenderWindow);
00048   void PrintSelf(ostream& os, vtkIndent indent);
00049
00051   virtual void Start(void);
00052
00054   void Frame(void);
00055
00057   virtual void WindowInitialize(void);
00058
00060   virtual void Initialize(void);
00061
00063   virtual void SetFullScreen(int);
00064
00066   virtual void WindowRemap(void);
00067
00069   virtual void PrefFullScreen(void);
00070
00072   virtual void SetSize(int,int);
00073
00075   virtual int *GetSize();
00076
00078   virtual void SetPosition(int,int);
00079
00081   virtual int *GetScreenSize();
00082
00084   virtual int *GetPosition();
00085
00088   virtual void SetWindowName(char *);
00089
00091   void SetWindowInfo(char *);
00092
00094   void SetParentInfo(char *);
00095
00096   //BTX
00097   virtual void *GetGenericDisplayId() {return (void *)this->OffScreenContextId;};
00098   virtual void *GetGenericWindowId()  {return (void *)this->WindowId;};
00099   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00100   virtual void *GetGenericContext()   {return (void *)this->DeviceContext;};
00101   virtual void SetDisplayId(void *) {};
00102
00104
00105   virtual HWND  GetWindowId();
00106   void  SetWindowId(void *foo) {this->SetWindowId((HWND)foo);};
00108
00110   virtual void  SetWindowId(HWND);
00111
00113
00114   virtual void  SetParentId(HWND);
00115   void  SetParentId(void *foo) {this->SetParentId((HWND)foo);};
00117
00119
00120   virtual void  SetNextWindowId(HWND);
00121   //ETX
00123
00128   virtual void SetStereoCapableWindow(int capable);
00129
00131   void MakeCurrent();
00132
00135   virtual  int GetEventPending();
00136
00138   void Clean();
00139
00141
00143   void HideCursor();
00144   void ShowCursor();
00146
00147 protected:
00148   vtkWinCEOpenGLRenderWindow();
00149   ~vtkWinCEOpenGLRenderWindow();
00150
00151   HINSTANCE ApplicationInstance;
00152
00153   OSMesaContext OffScreenContextId;
00154   void *OffScreenWindow;
00155
00156   HDC       DeviceContext;
00157   HWND      WindowId;
00158   HWND      ParentId;
00159   HWND      NextWindowId;
00160   int       OwnWindow;
00161   int       ScreenSize[2];
00162
00163   //BTX
00164   // message handler
00165   virtual LRESULT MessageProc(HWND hWnd, UINT message,
00166                               WPARAM wParam, LPARAM lParam);
00167
00168   static LRESULT APIENTRY WndProc(HWND hWnd, UINT message,
00169                                   WPARAM wParam, LPARAM lParam);
00170   //ETX
00171   int CursorHidden;
00172
00173   void ResizeWhileOffscreen(int xsize, int ysize);
00174   void CreateAWindow(int x, int y, int width, int height);
00175   void InitializeApplication();
00176 private:
00177   vtkWinCEOpenGLRenderWindow(const vtkWinCEOpenGLRenderWindow&);  // Not implemented.
00178   void operator=(const vtkWinCEOpenGLRenderWindow&);  // Not implemented.
00179 };
00180
00181
00182 #endif
00183
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWindow.h Source File

Common/vtkWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkWindow_h
00040 #define __vtkWindow_h
00041
00042 #include "vtkObject.h"
00043 #include <stdio.h>
00044
00045 class VTK_COMMON_EXPORT vtkWindow : public vtkObject
00046 {
00047 public:
00048   vtkTypeRevisionMacro(vtkWindow,vtkObject);
00049   void PrintSelf(ostream& os, vtkIndent indent);
00050
00052
00054   virtual void SetDisplayId(void *) = 0;
00055   virtual void SetWindowId(void *)  = 0;
00056   virtual void SetParentId(void *)  = 0;
00057   virtual void *GetGenericDisplayId() = 0;
00058   virtual void *GetGenericWindowId()  = 0;
00059   virtual void *GetGenericParentId()  = 0;
00060   virtual void *GetGenericContext()   = 0;
00061   virtual void *GetGenericDrawable()  = 0;
00062   virtual void SetWindowInfo(char *) = 0;
00063   virtual void SetParentInfo(char *) = 0;
00065
00067
00068   virtual int *GetPosition();
00069   virtual void SetPosition(int,int);
00070   virtual void SetPosition(int a[2]);
00072
00074
00075   virtual int *GetSize();
00076   virtual void SetSize(int,int);
00077   virtual void SetSize(int a[2]);
00079
00081
00082   vtkSetMacro(Mapped,int);
00083   vtkGetMacro(Mapped,int);
00084   vtkBooleanMacro(Mapped,int);
00086
00088
00092   vtkSetMacro(Erase,int);
00093   vtkGetMacro(Erase,int);
00094   vtkBooleanMacro(Erase,int);
00096
00098
00099   vtkSetMacro(DoubleBuffer,int);
00100   vtkGetMacro(DoubleBuffer,int);
00101   vtkBooleanMacro(DoubleBuffer,int);
00103
00105
00106   vtkGetStringMacro(WindowName);
00107   virtual void SetWindowName(char * );
00109
00112   virtual void Render() = 0;
00113
00115
00123   virtual unsigned char *GetPixelData(int, int, int, int, int) {
00124     return (unsigned char *)NULL;};
00126
00128
00130   vtkGetMacro(DPI,int);
00131   vtkSetClampMacro(DPI,int,1,3000);
00133
00135
00138   vtkSetMacro(OffScreenRendering,int);
00139   vtkGetMacro(OffScreenRendering,int);
00140   vtkBooleanMacro(OffScreenRendering,int);
00142
00145   virtual void MakeCurrent() {};
00146
00148
00153   vtkSetMacro(TileScale,int);
00154   vtkGetMacro(TileScale,int);
00155   vtkSetVector4Macro(TileViewport,float);
00156   vtkGetVector4Macro(TileViewport,float);
00158
00159
00160 protected:
00161   int OffScreenRendering;
00162   vtkWindow();
00163   ~vtkWindow();
00164
00165   char *WindowName;
00166   int Size[2];
00167   int Position[2];
00168   int Mapped;
00169   int Erase;
00170   int DoubleBuffer;
00171   int DPI;
00172
00173   float TileViewport[4];
00174   int   TileSize[2];
00175   int   TileScale;
00176
00177 private:
00178   vtkWindow(const vtkWindow&);  // Not implemented.
00179   void operator=(const vtkWindow&);  // Not implemented.
00180 };
00181
00182 #endif
00183
00184
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Graphics/vtkWindowedSincPolyDataFilter.h Source File

Graphics/vtkWindowedSincPolyDataFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWindowedSincPolyDataFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00143 #ifndef __vtkWindowedSincPolyDataFilter_h
00144 #define __vtkWindowedSincPolyDataFilter_h
00145
00146
00147 #include "vtkPolyDataToPolyDataFilter.h"
00148
00149 class VTK_GRAPHICS_EXPORT vtkWindowedSincPolyDataFilter : public vtkPolyDataToPolyDataFilter
00150 {
00151 public:
00152   vtkTypeRevisionMacro(vtkWindowedSincPolyDataFilter,vtkPolyDataToPolyDataFilter);
00153   void PrintSelf(ostream& os, vtkIndent indent);
00154
00160   static vtkWindowedSincPolyDataFilter *New();
00161
00163
00165   vtkSetClampMacro(NumberOfIterations,int,0,VTK_LARGE_INTEGER);
00166   vtkGetMacro(NumberOfIterations,int);
00168
00170
00171   vtkSetClampMacro(PassBand,float, 0.0, 2.0);
00172   vtkGetMacro(PassBand,float);
00174
00176
00177   vtkSetMacro(FeatureEdgeSmoothing,int);
00178   vtkGetMacro(FeatureEdgeSmoothing,int);
00179   vtkBooleanMacro(FeatureEdgeSmoothing,int);
00181
00183
00184   vtkSetClampMacro(FeatureAngle,float,0.0,180.0);
00185   vtkGetMacro(FeatureAngle,float);
00187
00189
00191   vtkSetClampMacro(EdgeAngle,float,0.0,180.0);
00192   vtkGetMacro(EdgeAngle,float);
00194
00196
00197   vtkSetMacro(BoundarySmoothing,int);
00198   vtkGetMacro(BoundarySmoothing,int);
00199   vtkBooleanMacro(BoundarySmoothing,int);
00201
00203
00204   vtkSetMacro(GenerateErrorScalars,int);
00205   vtkGetMacro(GenerateErrorScalars,int);
00206   vtkBooleanMacro(GenerateErrorScalars,int);
00208
00210
00211   vtkSetMacro(GenerateErrorVectors,int);
00212   vtkGetMacro(GenerateErrorVectors,int);
00213   vtkBooleanMacro(GenerateErrorVectors,int);
00215
00216  protected:
00217   vtkWindowedSincPolyDataFilter();
00218   ~vtkWindowedSincPolyDataFilter() {};
00219
00220   void Execute();
00221
00222   int NumberOfIterations;
00223   float PassBand;
00224   int FeatureEdgeSmoothing;
00225   float FeatureAngle;
00226   float EdgeAngle;
00227   int BoundarySmoothing;
00228   int GenerateErrorScalars;
00229   int GenerateErrorVectors;
00230 private:
00231   vtkWindowedSincPolyDataFilter(const vtkWindowedSincPolyDataFilter&);  // Not implemented.
00232   void operator=(const vtkWindowedSincPolyDataFilter&);  // Not implemented.
00233 };
00234
00235 #endif
Generated on Mon Mar 25 01:07:46 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkWindowLevelLookupTable.h Source File

Common/vtkWindowLevelLookupTable.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWindowLevelLookupTable.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00046 #ifndef __vtkWindowLevelLookupTable_h
00047 #define __vtkWindowLevelLookupTable_h
00048
00049 #include "vtkObject.h"
00050 #include "vtkLookupTable.h"
00051
00052 class VTK_COMMON_EXPORT vtkWindowLevelLookupTable : public vtkLookupTable
00053 {
00054 public:
00055   static vtkWindowLevelLookupTable *New();
00056   vtkTypeRevisionMacro(vtkWindowLevelLookupTable,vtkLookupTable);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00061   void Build();
00062
00064
00066   void SetWindow(float window) {
00067     if (window < 1e-5) { window = 1e-5; }
00068     this->Window = window;
00069     this->SetTableRange(this->Level - this->Window/2.0,
00070                         this->Level + this->Window/2.0); };
00071   vtkGetMacro(Window,float);
00073
00075
00077   void SetLevel(float level) {
00078     this->Level = level;
00079     this->SetTableRange(this->Level - this->Window/2.0,
00080                         this->Level + this->Window/2.0); };
00081   vtkGetMacro(Level,float);
00083
00085
00087   void SetInverseVideo(int iv);
00088   vtkGetMacro(InverseVideo,int);
00089   vtkBooleanMacro(InverseVideo,int);
00091
00093
00096   vtkSetVector4Macro(MinimumTableValue,float);
00097   vtkGetVector4Macro(MinimumTableValue,float);
00099
00101
00104   vtkSetVector4Macro(MaximumTableValue,float);
00105   vtkGetVector4Macro(MaximumTableValue,float);
00107
00109
00111   void SetMinimumColor(int r, int g, int b, int a) {
00112     this->SetMinimumTableValue(r*255.0,g*255.0,b*255.0,a*255.0); };
00113   void SetMinimumColor(const unsigned char rgba[4]) {
00114     this->SetMinimumColor(rgba[0],rgba[1],rgba[2],rgba[3]); };
00115   void GetMinimumColor(unsigned char rgba[4]) {
00116     rgba[0] = int(this->MinimumColor[0]*255);
00117     rgba[1] = int(this->MinimumColor[1]*255);
00118     rgba[2] = int(this->MinimumColor[2]*255);
00119     rgba[3] = int(this->MinimumColor[3]*255); };
00120   unsigned char *GetMinimumColor() {
00121     this->GetMinimumColor(this->MinimumColor);
00122     return this->MinimumColor; };
00124
00126
00128   void SetMaximumColor(int r, int g, int b, int a) {
00129     this->SetMaximumTableValue(r*255.0,g*255.0,b*255.0,a*255.0); };
00130   void SetMaximumColor(const unsigned char rgba[4]) {
00131     this->SetMaximumColor(rgba[0],rgba[1],rgba[2],rgba[3]); };
00132   void GetMaximumColor(unsigned char rgba[4]) {
00133     rgba[0] = int(this->MaximumColor[0]*255);
00134     rgba[1] = int(this->MaximumColor[1]*255);
00135     rgba[2] = int(this->MaximumColor[2]*255);
00136     rgba[3] = int(this->MaximumColor[3]*255); };
00137   unsigned char *GetMaximumColor() {
00138     this->GetMaximumColor(this->MaximumColor);
00139     return this->MaximumColor; };
00141
00142 protected:
00143   vtkWindowLevelLookupTable(int sze=256, int ext=256);
00144   ~vtkWindowLevelLookupTable() {};
00145
00146   float Window;
00147   float Level;
00148   int InverseVideo;
00149   float MaximumTableValue[4];
00150   float MinimumTableValue[4];
00151   unsigned char MinimumColor[4];
00152   unsigned char MaximumColor[4];
00153 private:
00154   vtkWindowLevelLookupTable(const vtkWindowLevelLookupTable&);  // Not implemented.
00155   void operator=(const vtkWindowLevelLookupTable&);  // Not implemented.
00156 };
00157
00158 #endif
00159
00160
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWindowToImageFilter.h Source File

Rendering/vtkWindowToImageFilter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWindowToImageFilter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00062 #ifndef __vtkWindowToImageFilter_h
00063 #define __vtkWindowToImageFilter_h
00064
00065 #include "vtkImageSource.h"
00066
00067 class vtkWindow;
00068
00069 class VTK_RENDERING_EXPORT vtkWindowToImageFilter : public vtkImageSource
00070 {
00071 public:
00072   static vtkWindowToImageFilter *New();
00073
00074   vtkTypeRevisionMacro(vtkWindowToImageFilter,vtkImageSource);
00075   void PrintSelf(ostream& os, vtkIndent indent);
00076
00078   void SetInput(vtkWindow *input);
00079
00081
00083   vtkGetObjectMacro(Input,vtkWindow);
00085
00087
00088   vtkSetClampMacro(Magnification,int,1,2048);
00089   vtkGetMacro(Magnification,int);
00090   // Description:
00091   // Set/Get the flag that determines which buffer to read from.
00092   // The default is to read from the front buffer.
00093   vtkBooleanMacro(ReadFrontBuffer, int);
00094   vtkGetMacro(ReadFrontBuffer, int);
00095   vtkSetMacro(ReadFrontBuffer, int);
00097
00098 protected:
00099   vtkWindowToImageFilter();
00100   ~vtkWindowToImageFilter();
00101
00102   // vtkWindow is not a vtkDataObject, so we need our own ivar.
00103   vtkWindow *Input;
00104   int Magnification;
00105   int ReadFrontBuffer;
00106   void ExecuteInformation();
00107   void ExecuteData(vtkDataObject *data);
00108 private:
00109   vtkWindowToImageFilter(const vtkWindowToImageFilter&);  // Not implemented.
00110   void operator=(const vtkWindowToImageFilter&);  // Not implemented.
00111 };
00112
00113 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkWorldPointPicker.h Source File

Rendering/vtkWorldPointPicker.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWorldPointPicker.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkWorldPointPicker_h
00050 #define __vtkWorldPointPicker_h
00051
00052 #include "vtkAbstractPropPicker.h"
00053
00054 class VTK_RENDERING_EXPORT vtkWorldPointPicker : public vtkAbstractPicker
00055 {
00056 public:
00057   static vtkWorldPointPicker *New();
00058   vtkTypeRevisionMacro(vtkWorldPointPicker,vtkAbstractPicker);
00059   void PrintSelf(ostream& os, vtkIndent indent);
00060
00062
00063   int Pick(float selectionX, float selectionY, float selectionZ,
00064            vtkRenderer *renderer);
00065   int Pick(float selectionPt[3], vtkRenderer *renderer)
00066     { return this->vtkAbstractPicker::Pick( selectionPt, renderer); };
00068
00069 protected:
00070   vtkWorldPointPicker ();
00071   ~vtkWorldPointPicker() {};
00072
00073 private:
00074   vtkWorldPointPicker(const vtkWorldPointPicker&);  // Not implemented.
00075   void operator=(const vtkWorldPointPicker&);  // Not implemented.
00076 };
00077
00078 #endif
00079
00080
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkWriter.h Source File

IO/vtkWriter.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkWriter.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00052 #ifndef __vtkWriter_h
00053 #define __vtkWriter_h
00054
00055 #include "vtkProcessObject.h"
00056 #include "vtkDataObject.h"
00057
00058 #define VTK_ASCII 1
00059 #define VTK_BINARY 2
00060
00061 class VTK_IO_EXPORT vtkWriter : public vtkProcessObject
00062 {
00063 public:
00064   vtkTypeRevisionMacro(vtkWriter,vtkProcessObject);
00065   void PrintSelf(ostream& os, vtkIndent indent);
00066
00069   virtual void Write();
00070
00072   void Update();
00073
00076   void EncodeArrayName(char* resname, const char* name);
00077
00078 //BTX
00079   vtkDataObject *GetInput();
00080 //ETX
00081 protected:
00082   vtkWriter();
00083   ~vtkWriter();
00084
00085   virtual void WriteData() = 0; //internal method subclasses must respond to
00086   vtkTimeStamp WriteTime;
00087 private:
00088   vtkWriter(const vtkWriter&);  // Not implemented.
00089   void operator=(const vtkWriter&);  // Not implemented.
00090 };
00091
00092 #endif
00093
00094
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXImageMapper.h Source File

Rendering/vtkXImageMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXImageMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkXImageMapper_h
00039 #define __vtkXImageMapper_h
00040
00041 #include "vtkImageMapper.h"
00042 #include "vtkWindow.h"
00043 #include "vtkViewport.h"
00044 #include "vtkImageData.h"
00045 #include <X11/Xlib.h>
00046 #include <X11/Xutil.h>
00047 #include <X11/cursorfont.h>
00048 #include <X11/X.h>
00049 #include <X11/keysym.h>
00050
00051 class vtkActor2D;
00052
00053 #ifndef VTK_REMOVE_LEGACY_CODE
00054 class VTK_RENDERING_EXPORT vtkXImageMapper : public vtkImageMapper
00055 {
00056 public:
00057   static vtkXImageMapper *New();
00058
00059   vtkTypeRevisionMacro(vtkXImageMapper,vtkImageMapper);
00060   void PrintSelf(ostream& os, vtkIndent indent);
00061
00063
00064   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor) {
00065     this->RenderStart(viewport,actor);}
00067
00070   void RenderData(vtkViewport* viewport, vtkImageData* data, vtkActor2D* actor);
00071
00073   int GetXWindowDepth(vtkWindow* window);
00074
00076   void GetXWindowVisualId(vtkWindow* window, Visual* visualID);
00077
00079   int GetXWindowVisualClass(vtkWindow* window);
00080
00082   void GetXColors(int colors[]);
00083
00085
00086   void GetXWindowColorMasks(vtkWindow *window, unsigned long *rmask,
00087                             unsigned long *gmask, unsigned long *bmask);
00089
00091
00092   vtkGetMacro(NumberOfColors,int);
00094
00095 protected:
00096   vtkXImageMapper();
00097   ~vtkXImageMapper();
00098
00099   XImage          *Image;
00100   unsigned char   *DataOut;
00101   int             DataOutSize;
00102   int             NumberOfColors;
00103 private:
00104   vtkXImageMapper(const vtkXImageMapper&);  // Not implemented.
00105   void operator=(const vtkXImageMapper&);  // Not implemented.
00106 };
00107 #endif
00108
00109 #endif
00110
00111
00112
00113
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXImageWindow.h Source File

Rendering/vtkXImageWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXImageWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00037 #ifndef __vtkXImageWindow_h
00038 #define __vtkXImageWindow_h
00039
00040 #include        <X11/Xlib.h>
00041 #include        <X11/Xutil.h>
00042 #include        <X11/cursorfont.h>
00043 #include        <X11/X.h>
00044 #include        <X11/keysym.h>
00045
00046 #include        "vtkImageWindow.h"
00047
00048 class VTK_RENDERING_EXPORT vtkXImageWindow : public vtkImageWindow
00049 {
00050 public:
00051   static vtkXImageWindow *New();
00052   vtkTypeRevisionMacro(vtkXImageWindow,vtkImageWindow);
00053   void PrintSelf(ostream& os, vtkIndent indent);
00054
00056   void SetWindowName(char* name);
00057
00059
00060   vtkGetMacro(NumberOfColors,int);
00062
00064
00065   vtkGetMacro(VisualDepth,int);
00067
00069
00070   vtkGetMacro(VisualClass,int);
00072
00074
00075   Window   GetParentId();
00076   void     SetParentId(Window);
00077   void     SetParentId(void *);
00078   void     SetDisplayId(Display *);
00079   void     SetDisplayId(void *);
00080   void     SetWindowId(Window);
00081   void     SetWindowId(void *);
00082   Window   GetWindowId();
00083   Display *GetDisplayId();
00084   GC       GetGC();
00086
00088
00089   int     *GetPosition();
00090   void     GetPosition(int* x, int* y) {this->vtkImageWindow::GetPosition(x, y);};
00091   void     SetPosition(int,int);
00092   void     SetPosition(int a[2]) { this->SetPosition(a[0],a[1]); };
00094
00096
00097   int     *GetSize();
00098   void     GetSize(int* x, int* y) {this->vtkImageWindow::GetSize(x, y);};
00099   void     SetSize(int x, int y);
00100   void     SetSize(int a[2]) { this->SetSize(a[0], a[1]); };
00102
00104
00105   void *GetGenericDisplayId() {return (void*) this->DisplayId;};
00106   void *GetGenericWindowId() {return (void*) this->WindowId;};
00107   void *GetGenericParentId() {return (void*) this->ParentId;};
00108   void *GetGenericContext() {return (void*) this->Gc;};
00109   void *GetGenericDrawable();
00111
00114   void SwapBuffers();
00115
00117   void Frame();
00118
00120   virtual int      GetDesiredDepth();
00121
00123   virtual Colormap GetDesiredColormap();
00124
00126   virtual Visual  *GetDesiredVisual();
00127
00129   Visual *GetVisualId() {return VisualId;};
00130
00132   void SetBackgroundColor(float r, float g, float b);
00133
00135   void EraseWindow();
00136
00145   unsigned char *GetPixelData(int x1, int y1, int x2, int y2, int);
00146
00148   void     SetWindowInfo(char *info);
00149
00151   void     SetParentInfo(char *info);
00152
00153 protected:
00154   vtkXImageWindow();
00155   ~vtkXImageWindow();
00156
00157   // X stuff
00158   Window               ParentId;
00159   Window               WindowId;
00160   Display             *DisplayId;
00161   Visual              *VisualId;
00162   int                  VisualDepth;
00163   int                  VisualClass;
00164   Colormap             ColorMap;
00165   GC                   Gc;
00166   int                  Offset;
00167   XColor               Colors[256];
00168   int                  NumberOfColors;
00169   Pixmap               Drawable;
00170   int                  OwnDisplay;
00171   int                  PixmapWidth;
00172   int                  PixmapHeight;
00173
00174
00175   void MakeDefaultWindow();
00176   void GetDefaultVisualInfo(XVisualInfo *info);
00177   Colormap MakeColorMap(Visual *visual);
00178   void AllocateDirectColorMap();
00179   void GetShiftsScalesAndMasks(int &rshift, int &gshift, int &bshift,
00180                                int &rscale, int &gscale, int &bscale,
00181                                unsigned long &rmask, unsigned long &gmask,
00182                                unsigned long &bmask);
00183 private:
00184   vtkXImageWindow(const vtkXImageWindow&);  // Not implemented.
00185   void operator=(const vtkXImageWindow&);  // Not implemented.
00186 };
00187
00188 #endif
00189
00190
00191
00192
00193
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXMesaRenderWindow.h Source File

Rendering/vtkXMesaRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXMesaRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkXMesaRenderWindow_h
00039 #define __vtkXMesaRenderWindow_h
00040
00041 #include "MangleMesaInclude/gl_mangle.h"
00042 #include "MangleMesaInclude/glx_mangle.h"
00043 #include <stdlib.h>
00044 #include <X11/Xlib.h>
00045 #include <X11/Xutil.h>
00046 #include "vtkMesaRenderWindow.h"
00047 #include "MangleMesaInclude/glx.h"
00048 #include "MangleMesaInclude/osmesa.h"
00049
00050
00051
00052
00053 class vtkIdList;
00054
00055 class VTK_RENDERING_EXPORT vtkXMesaRenderWindow : public vtkMesaRenderWindow
00056 {
00057 protected:
00058   GLXContext ContextId;
00059
00060 public:
00061   static vtkXMesaRenderWindow *New();
00062   vtkTypeRevisionMacro(vtkXMesaRenderWindow,vtkMesaRenderWindow);
00063   void PrintSelf(ostream& os, vtkIndent indent);
00064
00066   virtual void Start(void);
00067
00069   virtual void Frame(void);
00070
00072   virtual void WindowInitialize(void);
00073
00075   virtual void Initialize(void);
00076
00078   virtual void SetFullScreen(int);
00079
00081   virtual void WindowRemap(void);
00082
00084   virtual void PrefFullScreen(void);
00085
00087
00088   virtual void SetSize(int,int);
00089   virtual void SetSize(int a[2]) {this->SetSize(a[0], a[1]);};
00091
00093
00094   virtual Colormap GetDesiredColormap();
00095   virtual Visual  *GetDesiredVisual();
00096   virtual XVisualInfo     *GetDesiredVisualInfo();
00097   virtual int      GetDesiredDepth();
00099
00104   virtual void SetStereoCapableWindow(int capable);
00105
00107   void MakeCurrent();
00108
00110
00111   virtual void *GetGenericDisplayId() {return (void *)this->GetDisplayId();};
00112   virtual void *GetGenericWindowId();
00113   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00114   virtual void *GetGenericContext();
00115   virtual void *GetGenericDrawable()  {return (void *)this->WindowId;};
00117
00119   virtual int     *GetScreenSize();
00120
00122   virtual int     *GetPosition();
00123
00125   Display *GetDisplayId();
00126
00128
00130   void     SetDisplayId(Display *);
00131   void     SetDisplayId(void *);
00133
00135   Window   GetParentId();
00136
00138
00139   void     SetParentId(Window);
00140   void     SetParentId(void *);
00142
00144   Window   GetWindowId();
00145
00147
00148   void     SetWindowId(Window);
00149   void     SetWindowId(void *);
00151
00153
00154   void     SetNextWindowId(Window);
00155   void     SetWindowName(char *);
00157
00159
00160   void     SetPosition(int,int);
00161   void     SetPosition(int a[2]) {this->SetPosition(a[0], a[1]);};
00163
00165
00167   void HideCursor();
00168   void ShowCursor();
00170
00173   virtual  int GetEventPending();
00174
00176   void     SetWindowInfo(char *info);
00177
00179   void     SetParentInfo(char *info);
00180
00183   void Render();
00184
00186   void SetOffScreenRendering(int i);
00187
00188 protected:
00189   vtkXMesaRenderWindow();
00190   ~vtkXMesaRenderWindow();
00191
00192   Window   ParentId;
00193   Window   WindowId;
00194   Window   NextWindowId;
00195   Display *DisplayId;
00196   Colormap ColorMap;
00197   int      OwnWindow;
00198   int      OwnDisplay;
00199   int      ScreenSize[2];
00200   int      CursorHidden;
00201
00202   // OffScreen stuff
00203   OSMesaContext OffScreenContextId;
00204   void *OffScreenWindow;
00205   int ScreenMapped;
00206   // Looks like this just stores DoubleBuffer.
00207   int ScreenDoubleBuffer;
00208 private:
00209   vtkXMesaRenderWindow(const vtkXMesaRenderWindow&);  // Not implemented.
00210   void operator=(const vtkXMesaRenderWindow&);  // Not implemented.
00211 };
00212
00213
00214
00215 #endif
Generated on Mon Mar 25 01:08:00 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXMesaTextMapper.h Source File

Rendering/vtkXMesaTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXMesaTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00036 #ifndef __vtkXMesaTextMapper_h
00037 #define __vtkXMesaTextMapper_h
00038
00039 #include "vtkXTextMapper.h"
00040
00041 class VTK_RENDERING_EXPORT vtkXMesaTextMapper : public vtkXTextMapper
00042 {
00043 public:
00044   vtkTypeRevisionMacro(vtkXMesaTextMapper,vtkXTextMapper);
00045   static vtkXMesaTextMapper *New();
00046
00048
00049   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00050   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor) {};
00052
00056   virtual void ReleaseGraphicsResources(vtkWindow *);
00057
00059
00060   static int GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp,
00061                                 Font);
00063
00064 protected:
00065   vtkXMesaTextMapper();
00066   ~vtkXMesaTextMapper() {};
00067 private:
00068   vtkXMesaTextMapper(const vtkXMesaTextMapper&);  // Not implemented.
00069   void operator=(const vtkXMesaTextMapper&);  // Not implemented.
00070 };
00071
00072
00073 #endif
00074
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Common/vtkXMLFileOutputWindow.h Source File

Common/vtkXMLFileOutputWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXMLFileOutputWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00049 #ifndef __vtkXMLFileOutputWindow_h
00050 #define __vtkXMLFileOutputWindow_h
00051
00052 #include "vtkFileOutputWindow.h"
00053
00054
00055 class VTK_COMMON_EXPORT vtkXMLFileOutputWindow : public vtkFileOutputWindow
00056 {
00057 public:
00058   vtkTypeRevisionMacro(vtkXMLFileOutputWindow, vtkFileOutputWindow);
00059
00060   static vtkXMLFileOutputWindow* New();
00061
00063
00066   virtual void DisplayText(const char*);
00067   virtual void DisplayErrorText(const char*);
00068   virtual void DisplayWarningText(const char*);
00069   virtual void DisplayGenericWarningText(const char*);
00070   virtual void DisplayDebugText(const char*);
00072
00074   virtual void DisplayTag(const char*);
00075
00076
00077  protected:
00078   vtkXMLFileOutputWindow() {};
00079   virtual ~vtkXMLFileOutputWindow() {};
00080
00081   void Initialize();
00082   virtual void DisplayXML(const char*, const char*);
00083 private:
00084   vtkXMLFileOutputWindow(const vtkXMLFileOutputWindow&);  // Not implemented.
00085   void operator=(const vtkXMLFileOutputWindow&);  // Not implemented.
00086 };
00087
00088
00089
00090 #endif
Generated on Mon Mar 25 01:07:38 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


IO/vtkXMLParser.h Source File

IO/vtkXMLParser.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXMLParser.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00035 #ifndef __vtkXMLParser_h
00036 #define __vtkXMLParser_h
00037
00038 #include "vtkObject.h"
00039
00040 class VTK_IO_EXPORT vtkXMLParser : public vtkObject
00041 {
00042 public:
00043   vtkTypeRevisionMacro(vtkXMLParser,vtkObject);
00044   void PrintSelf(ostream& os, vtkIndent indent);
00045
00046   static vtkXMLParser* New();
00047
00048   //BTX
00050   /*! Get/Set the input stream. */
00051   vtkSetMacro(Stream, istream*);
00052   vtkGetMacro(Stream, istream*);
00053   //ETX
00055
00057   int Parse();
00058
00059 protected:
00060   vtkXMLParser();
00061   ~vtkXMLParser();
00062
00063   // Input stream.  Set by user.
00064   istream* Stream;
00065
00066   // Expat parser structure.  Exists only during call to Parse().
00067   void* Parser;
00068
00069   // Called by Parse() to read the stream and call ParseBuffer.  Can
00070   // be replaced by subclasses to change how the stream is read.
00071   virtual int ParseStream();
00072
00073   // Called before each block of input is read from the stream to
00074   // check if parsing is complete.  Can be replaced by subclasses to
00075   // change the terminating condition for parsing.  Parsing always
00076   // stops when the end of file is reached in the stream.
00077   virtual int ParsingComplete();
00078
00079   // Called when a new element is opened in the XML source.  Should be
00080   // replaced by subclasses to handle each element.
00081   //  name = Name of new element.
00082   //  atts = Null-terminated array of attribute name/value pairs.
00083   //         Even indices are attribute names, and odd indices are values.
00084   virtual void StartElement(const char* name, const char** atts);
00085
00086   // Called at the end of an element in the XML source opened when
00087   // StartElement was called.
00088   virtual void EndElement(const char* name);
00089
00090   // Called when there is character data to handle.
00091   virtual void CharacterDataHandler(const char* data, int length);
00092
00093   // Called by begin handlers to report any stray attribute values.
00094   virtual void ReportStrayAttribute(const char* element, const char* attr,
00095                                     const char* value);
00096
00097   // Called by begin handlers to report any missing attribute values.
00098   virtual void ReportMissingAttribute(const char* element, const char* attr);
00099
00100   // Called by begin handlers to report bad attribute values.
00101   virtual void ReportBadAttribute(const char* element, const char* attr,
00102                                   const char* value);
00103
00104   // Called by StartElement to report unknown element type.
00105   virtual void ReportUnknownElement(const char* element);
00106
00107   // Called by Parse to report an XML syntax error.
00108   virtual void ReportXmlParseError();
00109
00110   // Get the current byte index from the beginning of the XML stream.
00111   unsigned long GetXMLByteIndex();
00112
00113   // Send the given buffer to the XML parser.
00114   int ParseBuffer(const char* buffer, unsigned int count);
00115
00116   // Send the given c-style string to the XML parser.
00117   int ParseBuffer(const char* buffer);
00118
00119   // Utility for convenience of subclasses.  Wraps isspace C library
00120   // routine.
00121   static int IsSpace(char c);
00122
00123   // Begin element handler that is registered with the XML_Parser.
00124   // This just casts the user data to a vtkXMLParser and calls
00125   // StartElement.
00126   static void StartElementFunction(void* parser, const char* name,
00127                                    const char** atts);
00128
00129   // End element handler that is registered with the XML_Parser.  This
00130   // just casts the user data to a vtkXMLParser and calls EndElement.
00131   static void EndElementFunction(void* parser, const char* name);
00132
00133   // Character data handler that is registered with the XML_Parser.
00134   // This just casts the user data to a vtkXMLParser and calls
00135   // CharacterDataHandler.
00136   static void CharacterDataHandlerFunction(void* parser, const char* data,
00137                                            int length);
00138 private:
00139   vtkXMLParser(const vtkXMLParser&);  // Not implemented.
00140   void operator=(const vtkXMLParser&);  // Not implemented.
00141 };
00142
00143 #endif
Generated on Mon Mar 25 01:07:54 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXOpenGLRenderWindow.h Source File

Rendering/vtkXOpenGLRenderWindow.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXOpenGLRenderWindow.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00041 #ifndef __vtkXOpenGLRenderWindow_h
00042 #define __vtkXOpenGLRenderWindow_h
00043
00044 #include <stdlib.h>
00045 #include <X11/Xlib.h>
00046 #include <X11/Xutil.h>
00047 #include "vtkOpenGLRenderWindow.h"
00048 #include "GL/glx.h"
00049 #include "vtkToolkits.h"
00050
00051
00052 #ifdef VTK_OPENGL_HAS_OSMESA
00053 #include "GL/osmesa.h"
00054 #endif
00055
00056 class vtkIdList;
00057
00058 class VTK_RENDERING_EXPORT vtkXOpenGLRenderWindow : public vtkOpenGLRenderWindow
00059 {
00060 protected:
00061   GLXContext ContextId;
00062
00063 public:
00064   static vtkXOpenGLRenderWindow *New();
00065   vtkTypeRevisionMacro(vtkXOpenGLRenderWindow,vtkOpenGLRenderWindow);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00069   virtual void Start(void);
00070
00072   virtual void Frame(void);
00073
00075   virtual void WindowInitialize(void);
00076
00078   virtual void Initialize(void);
00079
00081   virtual void SetFullScreen(int);
00082
00084   virtual void WindowRemap(void);
00085
00087   virtual void PrefFullScreen(void);
00088
00090
00091   virtual void SetSize(int,int);
00092   virtual void SetSize(int a[2]) {this->SetSize(a[0], a[1]);};
00094
00096
00097   virtual Colormap GetDesiredColormap();
00098   virtual Visual  *GetDesiredVisual();
00099   virtual XVisualInfo     *GetDesiredVisualInfo();
00100   virtual int      GetDesiredDepth();
00102
00107   virtual void SetStereoCapableWindow(int capable);
00108
00110   void MakeCurrent();
00111
00113
00114   virtual void *GetGenericDisplayId() {return (void *)this->GetDisplayId();};
00115   virtual void *GetGenericWindowId();
00116   virtual void *GetGenericParentId()  {return (void *)this->ParentId;};
00117   virtual void *GetGenericContext();
00118   virtual void *GetGenericDrawable()  {return (void *)this->WindowId;};
00120
00122   virtual int     *GetScreenSize();
00123
00125   virtual int     *GetPosition();
00126
00128   Display *GetDisplayId();
00129
00131
00133   void     SetDisplayId(Display *);
00134   void     SetDisplayId(void *);
00136
00138   Window   GetParentId();
00139
00141
00142   void     SetParentId(Window);
00143   void     SetParentId(void *);
00145
00147   Window   GetWindowId();
00148
00150
00151   void     SetWindowId(Window);
00152   void     SetWindowId(void *);
00154
00156
00157   void     SetNextWindowId(Window);
00158   void     SetWindowName(char *);
00160
00162
00163   void     SetPosition(int,int);
00164   void     SetPosition(int a[2]) {this->SetPosition(a[0], a[1]);};
00166
00168
00170   void HideCursor();
00171   void ShowCursor();
00173
00176   virtual  int GetEventPending();
00177
00179   void     SetWindowInfo(char *info);
00180
00182   void     SetParentInfo(char *info);
00183
00186   void Render();
00187
00189   void SetOffScreenRendering(int i);
00190
00191 protected:
00192   vtkXOpenGLRenderWindow();
00193   ~vtkXOpenGLRenderWindow();
00194
00195   Window   ParentId;
00196   Window   WindowId;
00197   Window   NextWindowId;
00198   Display *DisplayId;
00199   Colormap ColorMap;
00200   int      OwnWindow;
00201   int      OwnDisplay;
00202   int      ScreenSize[2];
00203   int      CursorHidden;
00204
00205 #ifdef VTK_OPENGL_HAS_OSMESA
00206   // OffScreen stuff
00207   OSMesaContext OffScreenContextId;
00208   void *OffScreenWindow;
00209   int ScreenMapped;
00210   // Looks like this just stores DoubleBuffer.
00211   int ScreenDoubleBuffer;
00212 #endif
00213 private:
00214   vtkXOpenGLRenderWindow(const vtkXOpenGLRenderWindow&);  // Not implemented.
00215   void operator=(const vtkXOpenGLRenderWindow&);  // Not implemented.
00216 };
00217
00218
00219
00220 #endif
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXOpenGLTextMapper.h Source File

Rendering/vtkXOpenGLTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXOpenGLTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkXOpenGLTextMapper_h
00039 #define __vtkXOpenGLTextMapper_h
00040
00041 #include "vtkXTextMapper.h"
00042
00043 class VTK_RENDERING_EXPORT vtkXOpenGLTextMapper : public vtkXTextMapper
00044 {
00045 public:
00046   vtkTypeRevisionMacro(vtkXOpenGLTextMapper,vtkXTextMapper);
00047   static vtkXOpenGLTextMapper *New();
00048
00050
00051   void RenderOpaqueGeometry(vtkViewport* viewport, vtkActor2D* actor);
00052   void RenderTranslucentGeometry(vtkViewport* viewport, vtkActor2D* actor);
00053   void RenderGeometry(vtkViewport* viewport, vtkActor2D* actor);
00054   void RenderOverlay(vtkViewport*, vtkActor2D*) {};
00056
00060   virtual void ReleaseGraphicsResources(vtkWindow *);
00061
00063
00064   static int GetListBaseForFont(vtkTextMapper *tm, vtkViewport *vp,
00065                                 Font);
00067
00068 protected:
00069   vtkXOpenGLTextMapper();
00070   ~vtkXOpenGLTextMapper();
00071 private:
00072   vtkXOpenGLTextMapper(const vtkXOpenGLTextMapper&);  // Not implemented.
00073   void operator=(const vtkXOpenGLTextMapper&);  // Not implemented.
00074 };
00075
00076
00077 #endif
00078
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXPolyDataMapper2D.h Source File

Rendering/vtkXPolyDataMapper2D.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXPolyDataMapper2D.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00038 #ifndef __vtkXPolyDataMapper2D_h
00039 #define __vtkXPolyDataMapper2D_h
00040
00041 #include "vtkPolyDataMapper2D.h"
00042
00043 #ifndef VTK_REMOVE_LEGACY_CODE
00044 class VTK_RENDERING_EXPORT vtkXPolyDataMapper2D : public vtkPolyDataMapper2D
00045 {
00046 public:
00047   vtkTypeRevisionMacro(vtkXPolyDataMapper2D,vtkPolyDataMapper2D);
00048   static vtkXPolyDataMapper2D *New();
00049
00051   void RenderOverlay(vtkViewport* viewport, vtkActor2D* actor);
00052
00053 protected:
00054   vtkXPolyDataMapper2D() {};
00055   ~vtkXPolyDataMapper2D() {};
00056
00057 private:
00058   vtkXPolyDataMapper2D(const vtkXPolyDataMapper2D&);  // Not implemented.
00059   void operator=(const vtkXPolyDataMapper2D&);  // Not implemented.
00060 };
00061 #endif
00062
00063 #endif
00064
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXRenderWindowInteractor.h Source File

Rendering/vtkXRenderWindowInteractor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXRenderWindowInteractor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00051 #ifndef __vtkXRenderWindowInteractor_h
00052 #define __vtkXRenderWindowInteractor_h
00053
00054 //===========================================================
00055 // now we define the C++ class
00056
00057 #include "vtkRenderWindowInteractor.h"
00058 #include <X11/StringDefs.h>
00059 #include <X11/Intrinsic.h>
00060
00061 class VTK_RENDERING_EXPORT vtkXRenderWindowInteractor : public vtkRenderWindowInteractor
00062 {
00063 public:
00064   static vtkXRenderWindowInteractor *New();
00065   vtkTypeRevisionMacro(vtkXRenderWindowInteractor,vtkRenderWindowInteractor);
00066   void PrintSelf(ostream& os, vtkIndent indent);
00067
00071   virtual void Initialize();
00072
00074   void TerminateApp(void) { exit(0); }
00075
00077
00080   vtkSetMacro(BreakLoopFlag, int);
00081   vtkGetMacro(BreakLoopFlag, int);
00082   vtkBooleanMacro(BreakLoopFlag, int);
00084
00086
00087   int CreateTimer(int timertype);
00088   int DestroyTimer(void);
00090
00092
00094   virtual void Initialize(XtAppContext app);
00095   vtkGetMacro( App, XtAppContext );
00097
00099
00106   virtual void Enable();
00107   virtual void Disable();
00109
00113   virtual void Start();
00114
00116
00130   virtual void SetWidget(Widget);
00131   Widget GetWidget() {return this->Top;};
00133
00135
00159   virtual void SetTopLevelShell(Widget);
00160   Widget GetTopLevelShell() {return this->TopLevelShell;};
00162
00165   virtual void GetMousePosition(int *x, int *y);
00166
00168
00169   friend void vtkXRenderWindowInteractorCallback(Widget,XtPointer,
00170                                                  XEvent *,Boolean *);
00171   friend void vtkXRenderWindowInteractorTimer(XtPointer,XtIntervalId *);
00173
00174 protected:
00175   vtkXRenderWindowInteractor();
00176   ~vtkXRenderWindowInteractor();
00177
00178   Display *DisplayId;
00179   Window WindowId;
00180   Widget Top;
00181   int OwnTop;
00182   XtAppContext App;
00183   int PositionBeforeStereo[2];
00184   Widget TopLevelShell;
00185
00186   int BreakLoopFlag;
00187   XtIntervalId AddTimeOut(XtAppContext app_context, unsigned long interval,
00188                           XtTimerCallbackProc proc, XtPointer client_data) ;
00189   void Timer(XtPointer client_data, XtIntervalId *id);
00190   void Callback(Widget w, XtPointer client_data, XEvent *event, Boolean *ctd);
00191
00192
00193 private:
00194   vtkXRenderWindowInteractor(const vtkXRenderWindowInteractor&);  // Not implemented.
00195   void operator=(const vtkXRenderWindowInteractor&);  // Not implemented.
00196 };
00197
00198 #endif
00199
00200
00201
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXRenderWindowTclInteractor.h Source File

Rendering/vtkXRenderWindowTclInteractor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXRenderWindowTclInteractor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00042 #ifndef __vtkXRenderWindowTclInteractor_h
00043 #define __vtkXRenderWindowTclInteractor_h
00044
00045 //===========================================================
00046 // now we define the C++ class
00047
00048 #include "vtkRenderWindowInteractor.h"
00049 #include <X11/StringDefs.h>
00050 #include <X11/Intrinsic.h>
00051
00052 class VTK_RENDERING_EXPORT vtkXRenderWindowTclInteractor : public vtkRenderWindowInteractor
00053 {
00054 public:
00055   static vtkXRenderWindowTclInteractor *New();
00056   vtkTypeRevisionMacro(vtkXRenderWindowTclInteractor,vtkRenderWindowInteractor);
00057   void PrintSelf(ostream& os, vtkIndent indent);
00058
00062   virtual void Initialize();
00063
00065
00067   virtual void Initialize(XtAppContext app);
00068   vtkGetMacro( App, XtAppContext );
00070
00072
00079   virtual void Enable();
00080   virtual void Disable();
00082
00084
00087   virtual void Start();
00088   virtual void UpdateSize(int,int);
00090
00092
00106   virtual void SetWidget(Widget);
00107   Widget GetWidget()
00108     {return this->top;}
00110
00112
00136   virtual void SetTopLevelShell(Widget);
00137   Widget GetTopLevelShell()
00138     {return this->TopLevelShell;}
00140
00142
00143   int CreateTimer(int timertype);
00144   int DestroyTimer(void);
00146
00148   void TerminateApp(void);
00149
00151
00152   vtkGetMacro(BreakLoopFlag, int);
00153   vtkSetMacro(BreakLoopFlag, int);
00155
00157
00158   friend void vtkXRenderWindowTclInteractorCallback(Widget,XtPointer,
00159                                                     XEvent *,Boolean *);
00160   friend void vtkXRenderWindowTclInteractorTimer(XtPointer,XtIntervalId *);
00162
00163 protected:
00164   vtkXRenderWindowTclInteractor();
00165   ~vtkXRenderWindowTclInteractor();
00166
00167   Widget TopLevelShell;
00168
00169   Display *DisplayId;
00170   Window WindowId;
00171   Widget top;
00172   Widget oldTop;
00173   XtAppContext App;
00174   int PositionBeforeStereo[2];
00175
00176   int BreakLoopFlag;
00177 private:
00178   vtkXRenderWindowTclInteractor(const vtkXRenderWindowTclInteractor&);  // Not implemented.
00179   void operator=(const vtkXRenderWindowTclInteractor&);  // Not implemented.
00180 };
00181
00182 #endif
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Rendering/vtkXTextMapper.h Source File

Rendering/vtkXTextMapper.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXTextMapper.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00039 #ifndef __vtkXTextMapper_h
00040 #define __vtkXTextMapper_h
00041
00042 #include "vtkTextMapper.h"
00043
00044 #include        <X11/Xlib.h>
00045 #include        <X11/Xutil.h>
00046 #include        <X11/cursorfont.h>
00047 #include        <X11/X.h>
00048 #include        <X11/keysym.h>
00049
00050
00051 class VTK_RENDERING_EXPORT vtkXTextMapper : public vtkTextMapper
00052 {
00053 public:
00054   vtkTypeRevisionMacro(vtkXTextMapper,vtkTextMapper);
00055   static vtkXTextMapper *New();
00056
00059   void SetFontSize(int size);
00060
00062   void GetSize(vtkViewport* viewport, int size[2]);
00063
00064 protected:
00065   vtkXTextMapper();
00066   ~vtkXTextMapper() {};
00067
00069   void DetermineSize(vtkViewport *viewport, int size[2]);
00070
00071   Font CurrentFont;
00072
00073   // Size of the Text.
00074   vtkTimeStamp  SizeMTime;
00075   int           Size[2];
00076   int           ViewportSize[2];
00077 private:
00078   vtkXTextMapper(const vtkXTextMapper&);  // Not implemented.
00079   void operator=(const vtkXTextMapper&);  // Not implemented.
00080 };
00081
00082
00083
00084
00085 #endif
00086
00087
00088
Generated on Mon Mar 25 01:08:01 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001


Hybrid/vtkXYPlotActor.h Source File

Hybrid/vtkXYPlotActor.h

Go to the documentation of this file.
00001 /*=========================================================================
00002
00003   Program:   Visualization Toolkit
00004   Module:    $RCSfile: vtkXYPlotActor.h,v $
00005   Language:  C++
00006
00007   Copyright (c) 1993-2002 Ken Martin, Will Schroeder, Bill Lorensen
00008   All rights reserved.
00009   See Copyright.txt or http://www.kitware.com/Copyright.htm for details.
00010
00011      This software is distributed WITHOUT ANY WARRANTY; without even
00012      the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
00013      PURPOSE.  See the above copyright notice for more information.
00014
00015 =========================================================================*/
00088 #ifndef __vtkXYPlotActor_h
00089 #define __vtkXYPlotActor_h
00090
00091 #define VTK_XYPLOT_INDEX                 0
00092 #define VTK_XYPLOT_ARC_LENGTH            1
00093 #define VTK_XYPLOT_NORMALIZED_ARC_LENGTH 2
00094 #define VTK_XYPLOT_VALUE                 3
00095
00096 #define VTK_XYPLOT_ROW 0
00097 #define VTK_XYPLOT_COLUMN 1
00098
00099 #include "vtkAxisActor2D.h"
00100 class vtkDataSetCollection;
00101 class vtkDataObjectCollection;
00102 class vtkGlyphSource2D;
00103 class vtkGlyph2D;
00104 class vtkLegendBoxActor;
00105 class vtkAppendPolyData;
00106 class vtkPlanes;
00107 class vtkIntArray;
00108
00109 class VTK_HYBRID_EXPORT vtkXYPlotActor : public vtkActor2D
00110 {
00111 public:
00112   vtkTypeRevisionMacro(vtkXYPlotActor,vtkActor2D);
00113   void PrintSelf(ostream& os, vtkIndent indent);
00114
00119   static vtkXYPlotActor *New();
00120
00121   //---Data Set Input----------------------------------------------------------
00122   // The following methods are used to plot input datasets. Datasets
00123   // will be plotted if set as input; otherwise the input data objects
00124   // will be plotted (if defined).
00125
00127
00131   void AddInput(vtkDataSet *in, const char* arrayName, int component);
00132   void AddInput(vtkDataSet *in) {this->AddInput(in, NULL, 0);}
00134
00136
00137   void RemoveInput(vtkDataSet *in, const char* arrayName, int component);
00138   void RemoveInput(vtkDataSet *in) {this->RemoveInput(in, NULL, 0);}
00140
00143   void RemoveAllInputs();
00144
00146   vtkDataSetCollection *GetInputList() {return this->InputList;}
00147
00149
00152   void SetPointComponent(int i, int comp);
00153   int GetPointComponent(int i);
00154   //---end Data Set Input-----------------------------------------------------
00156
00158   /*! Specify how the independent (x) variable is computed from the points.
00159       The independent variable can be the scalar/point index (i.e., point
00160       id), the accumulated arc length along the points, the normalized arc
00161       length, or by component value. If plotting datasets (e.g., points),
00162       the value that is used is specified by the PointComponent ivar.
00163       (Note: these methods also control how field data is plotted. Field
00164       data is usually plotted by value or index, if plotting length
00165       1-dimensional length measures are used.) */
00166   vtkSetClampMacro(XValues,int,VTK_XYPLOT_INDEX,VTK_XYPLOT_VALUE);
00167   vtkGetMacro(XValues,int);
00168   void SetXValuesToIndex(){this->SetXValues(VTK_XYPLOT_INDEX);};
00169   void SetXValuesToArcLength() {this->SetXValues(VTK_XYPLOT_ARC_LENGTH);};
00170   void SetXValuesToNormalizedArcLength()
00171     {this->SetXValues(VTK_XYPLOT_NORMALIZED_ARC_LENGTH);};
00172   void SetXValuesToValue() {this->SetXValues(VTK_XYPLOT_VALUE);};
00173   const char *GetXValuesAsString();
00175
00176   //---Data Object Input------------------------------------------------------
00177   // The following methods are used to plot input data objects. Datasets will
00178   // be plotted in preference to data objects if set as input; otherwise the
00179   // input data objects will be plotted (if defined).
00180
00182   void AddDataObjectInput(vtkDataObject *in);
00183
00185   void RemoveDataObjectInput(vtkDataObject *in);
00186
00188
00189   vtkDataObjectCollection *GetDataObjectInputList()
00190     {return this->DataObjectInputList;}
00192
00194
00196   vtkSetClampMacro(DataObjectPlotMode,int,VTK_XYPLOT_COLUMN,VTK_XYPLOT_ROW);
00197   vtkGetMacro(DataObjectPlotMode,int);
00198   void SetDataObjectPlotModeToRows()
00199     {this->SetDataObjectPlotMode(VTK_XYPLOT_ROW);}
00200   void SetDataObjectPlotModeToColumns()
00201     {this->SetDataObjectPlotMode(VTK_XYPLOT_COLUMN);}
00202   const char *GetDataObjectPlotModeAsString();
00204
00206
00212   void SetDataObjectXComponent(int i, int comp);
00213   int GetDataObjectXComponent(int i);
00215
00217
00223   void SetDataObjectYComponent(int i, int comp);
00224   int GetDataObjectYComponent(int i);
00225   //---end Data Object Input--------------------------------------------------
00227
00228   //---Per Curve Properties---------------------------------------------------
00229   // The following methods are used to set properties on each curve that is
00230   // plotted. Each input dataset (or data object) results in one curve. The
00231   // methods that follow have an index i that corresponds to the input dataset
00232   // or data object.
00233   void SetPlotColor(int i, float r, float g, float b);
00234   void SetPlotColor(int i, const float color[3]) {
00235     this->SetPlotColor(i, color[0], color[1], color[2]); };
00236   float *GetPlotColor(int i);
00237   void SetPlotSymbol(int i,vtkPolyData *input);
00238   vtkPolyData *GetPlotSymbol(int i);
00239   void SetPlotLabel(int i, const char *label);
00240   const char *GetPlotLabel(int i);
00241
00242   // Allow per-curve specification of line and point rendering.  These override
00243   // global settings PlotPoints and PlotLines.  If not on, the default behavior
00244   // is governed by PlotPoints and PlotLines ivars.
00245   vtkGetMacro(PlotCurvePoints, int);
00246   vtkSetMacro(PlotCurvePoints, int);
00247   vtkBooleanMacro(PlotCurvePoints, int);
00248
00249   vtkGetMacro(PlotCurveLines, int);
00250   vtkSetMacro(PlotCurveLines, int);
00251   vtkBooleanMacro(PlotCurveLines, int);
00252
00253   void SetPlotLines(int i, int);
00254   int GetPlotLines(int i);
00255
00256   void SetPlotPoints(int i, int);
00257   int GetPlotPoints(int i);
00258   //---end Per Curve Properties-----------------------------------------------
00259
00261
00263   vtkSetMacro(ExchangeAxes, int);
00264   vtkGetMacro(ExchangeAxes, int);
00265   vtkBooleanMacro(ExchangeAxes, int);
00267
00269
00273   vtkSetMacro(ReverseXAxis, int);
00274   vtkGetMacro(ReverseXAxis, int);
00275   vtkBooleanMacro(ReverseXAxis, int);
00277
00279
00283   vtkSetMacro(ReverseYAxis, int);
00284   vtkGetMacro(ReverseYAxis, int);
00285   vtkBooleanMacro(ReverseYAxis, int);
00287
00289
00293   vtkLegendBoxActor *GetLegendBoxActor()
00294     {return this->LegendActor;}
00295   vtkGlyphSource2D *GetGlyphSource()
00296     {return this->GlyphSource;}
00298
00300
00302   vtkSetStringMacro(Title);
00303   vtkGetStringMacro(Title);
00304   vtkSetStringMacro(XTitle);
00305   vtkGetStringMacro(XTitle);
00306   vtkSetStringMacro(YTitle);
00307   vtkGetStringMacro(YTitle);
00309
00311
00317   vtkSetVector2Macro(XRange,float);
00318   vtkGetVectorMacro(XRange,float,2);
00319   vtkSetVector2Macro(YRange,float);
00320   vtkGetVectorMacro(YRange,float,2);
00321   void SetPlotRange(float xmin, float ymin, float xmax, float ymax)
00322     {this->SetXRange(xmin,xmax); this->SetYRange(ymin,ymax);}
00324
00326
00331   vtkSetClampMacro(NumberOfXLabels, int, 0, 50);
00332   vtkGetMacro(NumberOfXLabels, int);
00333   vtkSetClampMacro(NumberOfYLabels, int, 0, 50);
00334   vtkGetMacro(NumberOfYLabels, int);
00335   void SetNumberOfLabels(int num)
00336     {this->SetNumberOfXLabels(num); this->SetNumberOfYLabels(num);}
00338
00340
00343   vtkSetMacro(Legend, int);
00344   vtkGetMacro(Legend, int);
00345   vtkBooleanMacro(Legend, int);
00347
00349
00355   vtkSetVector2Macro(LegendPosition,float);
00356   vtkGetVector2Macro(LegendPosition,float);
00357   vtkSetVector2Macro(LegendPosition2,float);
00358   vtkGetVector2Macro(LegendPosition2,float);
00360
00362
00363   vtkSetMacro(Bold, int);
00364   vtkGetMacro(Bold, int);
00365   vtkBooleanMacro(Bold, int);
00367
00369
00370   vtkSetMacro(Italic, int);
00371   vtkGetMacro(Italic, int);
00372   vtkBooleanMacro(Italic, int);
00374
00376
00378   vtkSetMacro(Shadow, int);
00379   vtkGetMacro(Shadow, int);
00380   vtkBooleanMacro(Shadow, int);
00382
00384
00385   vtkSetMacro(Logx, int);
00386   vtkGetMacro(Logx, int);
00387   vtkBooleanMacro(Logx, int);
00389
00391
00394   vtkSetMacro(FontFamily, int);
00395   vtkGetMacro(FontFamily, int);
00396   void SetFontFamilyToArial() {this->SetFontFamily(VTK_ARIAL);};
00397   void SetFontFamilyToCourier() {this->SetFontFamily(VTK_COURIER);};
00398   void SetFontFamilyToTimes() {this->SetFontFamily(VTK_TIMES);};
00400
00402
00403   vtkSetStringMacro(LabelFormat);
00404   vtkGetStringMacro(LabelFormat);
00406
00408
00410   vtkSetClampMacro(Border, int, 0, 50);
00411   vtkGetMacro(Border, int);
00413
00415
00418   vtkGetMacro(PlotPoints, int);
00419   vtkSetMacro(PlotPoints, int);
00420   vtkBooleanMacro(PlotPoints, int);
00422
00424
00426   vtkGetMacro(PlotLines, int);
00427   vtkSetMacro(PlotLines, int);
00428   vtkBooleanMacro(PlotLines, int);
00430
00432
00435   vtkSetClampMacro(GlyphSize, float, 0.0, 0.2);
00436   vtkGetMacro(GlyphSize, float);
00438
00441   void ViewportToPlotCoordinate(vtkViewport *viewport, float &u, float &v);
00442
00444
00447   void ViewportToPlotCoordinate(vtkViewport *viewport);
00448   vtkSetVector2Macro(PlotCoordinate,float);
00449   vtkGetVector2Macro(PlotCoordinate,float);
00451
00453   void PlotToViewportCoordinate(vtkViewport *viewport, float &u, float &v);
00454
00456
00460   void PlotToViewportCoordinate(vtkViewport *viewport);
00461   vtkSetVector2Macro(ViewportCoordinate,float);
00462   vtkGetVector2Macro(ViewportCoordinate,float);
00464
00467   int IsInPlot(vtkViewport *viewport, float u, float v);
00468
00470   unsigned long GetMTime();
00471
00472 //BTX
00474   /*! WARNING: INTERNAL METHOD - NOT INTENDED FOR GENERAL USE DO NOT USE
00475       THIS METHOD OUTSIDE OF THE RENDERING PROCESS. Draw the x-y plot. */
00476   int RenderOpaqueGeometry(vtkViewport*);
00477   int RenderOverlay(vtkViewport*);
00478   int RenderTranslucentGeometry(vtkViewport *) {return 0;}
00480
00484   void ReleaseGraphicsResources(vtkWindow *);
00485 //ETX
00486
00487 protected:
00488   vtkXYPlotActor();
00489   ~vtkXYPlotActor();
00490
00491   vtkDataSetCollection *InputList; //list of data sets to plot
00492   char** SelectedInputScalars; // list of data set arrays to plot
00493   vtkIntArray* SelectedInputScalarsComponent; // list of componenents
00494   vtkDataObjectCollection *DataObjectInputList; //list of data objects to plot
00495   char  *Title;
00496   char  *XTitle;
00497   char  *YTitle;
00498   int   XValues;
00499   int   NumberOfXLabels;
00500   int   NumberOfYLabels;
00501   int   Bold;
00502   int   Italic;
00503   int   Shadow;
00504   int   FontFamily;
00505   int   Logx;
00506   char  *LabelFormat;
00507   float XRange[2];
00508   float YRange[2];
00509   float XComputedRange[2];  //range actually used by plot
00510   float YComputedRange[2];  //range actually used by plot
00511   int Border;
00512   int PlotLines;
00513   int PlotPoints;
00514   int PlotCurveLines;
00515   int PlotCurvePoints;
00516   int ExchangeAxes;
00517   int ReverseXAxis;
00518   int ReverseYAxis;
00519
00520   vtkTextMapper *TitleMapper;
00521   vtkActor2D    *TitleActor;
00522
00523   vtkAxisActor2D      *XAxis;
00524   vtkAxisActor2D      *YAxis;
00525
00526   float ViewportCoordinate[2];
00527   float PlotCoordinate[2];
00528
00529   //Handle data objects and datasets
00530   int DataObjectPlotMode;
00531   vtkIntArray *XComponent;
00532   vtkIntArray *YComponent;
00533   vtkIntArray *LinesOn;
00534   vtkIntArray *PointsOn;
00535
00536   //The data drawn within the axes. Each curve is one polydata.
00537   //color is controlled by scalar data. The curves are appended
00538   //together, possibly glyphed with point symbols.
00539   int NumberOfInputs;
00540   vtkPolyData             **PlotData;
00541   vtkGlyph2D              **PlotGlyph;
00542   vtkAppendPolyData       **PlotAppend;
00543   vtkPolyDataMapper2D     **PlotMapper;
00544   vtkActor2D              **PlotActor;
00545   void                    InitializeEntries();
00546
00547   // Legends and plot symbols. The legend also keeps track of
00548   // the symbols and such.
00549   int Legend;
00550   float LegendPosition[2];
00551   float LegendPosition2[2];
00552   vtkLegendBoxActor *LegendActor;
00553   vtkGlyphSource2D *GlyphSource;
00554   vtkPlanes *ClipPlanes;
00555   float GlyphSize;
00556
00557   // Keep track of changes.
00558   int CachedSize[2];
00559   vtkTimeStamp  BuildTime;
00560
00561   void ComputeXRange(float range[2], float *lengths);
00562   void ComputeYRange(float range[2]);
00563   void ComputeDORange(float xrange[2], float yrange[2], float *lengths);
00564
00565   virtual void CreatePlotData(int *pos, int *pos2, float xRange[2],
00566                               float yRange[2], float *norms,
00567                               int numDS, int numDO);
00568   void PlaceAxes(vtkViewport *viewport, int *size, int pos[2], int pos2[2]);
00569   void GenerateClipPlanes(int *pos, int *pos2);
00570   float ComputeGlyphScale(int i, int *pos, int *pos2);
00571   void ClipPlotData(int *pos, int *pos2, vtkPolyData *pd);
00572   float *TransformPoint(int pos[2], int pos2[2], float x[3], float xNew[3]);
00573
00574 private:
00575   vtkXYPlotActor(const vtkXYPlotActor&);  // Not implemented.
00576   void operator=(const vtkXYPlotActor&);  // Not implemented.
00577 };
00578
00579
00580 #endif
00581
Generated on Mon Mar 25 01:07:47 2002 for VTK by doxygen 1.2.11.1 written by Dimitri van Heesch, © 1997-2001